PHP 手册

by:
Mehdi Achour
Friedhelm Betz
Antony Dovgal
Nuno Lopes
Hannes Magnusson
Georg Richter
Damien Seguy
Jakub Vrana
其他贡献者
2021-03-15
Edited By: Peter Cowburn
中文翻译人员：
戴劼
乔楚
袁玉强
王远之
段小强
陈伯乐
周梦康
肖理达
肖盛文
褚兆玮
© 1997-2021 PHP 文档组
  • 版权信息
  • PHP 手册
    • 序言
  • 入门指引
    • 简介
    • 简明教程
  • 安装与配置
    • 安装前需要考虑的事项
    • Unix 系统下的安装
    • Mac OS X 系统下的安装
    • Windows 系统下的安装
    • 云计算平台上的安装
    • FastCGI 进程管理器（FPM）
    • PECL 扩展库安装
    • 还有问题？
    • 运行时配置
  • 语言参考
    • 基本语法
    • 类型
    • 变量
    • 常量
    • 表达式
    • 运算符
    • 流程控制
    • 函数
    • 类与对象
    • 命名空间
    • 错误
    • 异常
    • 生成器
    • 注解
    • 引用的解释
    • 预定义变量
    • 预定义异常
    • 预定义接口
    • 上下文（Context）选项和参数
    • 支持的协议和封装协议
  • 安全
    • 简介
    • 总则
    • 以 CGI 模式安装时
    • 以 Apache 模块安装时
    • 会话（Session）安全
    • 文件系统安全
    • 数据库安全
    • 错误报告
    • 用户提交的数据
    • 隐藏 PHP
    • 保持更新
  • 特点
    • 用 PHP 进行 HTTP 认证
    • Cookie
    • 会话
    • 处理 XForms
    • 文件上传处理
    • 使用远程文件
    • 连接处理
    • 数据库持久连接
    • PHP 的命令行模式
    • 垃圾回收机制
    • DTrace 动态跟踪
  • 函数参考
    • 影响 PHP 行为的扩展
    • 音频格式操作
    • 身份认证服务
    • 针对命令行的扩展
    • 压缩与归档扩展
    • 加密扩展
    • 数据库扩展
    • 日期与时间相关扩展
    • 文件系统相关扩展
    • 国际化与字符编码支持
    • 图像生成和处理
    • 邮件相关扩展
    • 数学扩展
    • 非文本内容的 MIME 输出
    • 进程控制扩展
    • 其它基本扩展
    • 其它服务
    • 搜索引擎扩展
    • 针对服务器的扩展
    • Session 扩展
    • 文本处理
    • 变量与类型相关扩展
    • Web 服务
    • Windows 专用扩展
    • XML 操作
    • 图形用户界面(GUI) 扩展
  • FAQ — FAQ：常见问题
    • 一般信息
    • 邮件列表
    • 获取 PHP
    • 数据库问题
    • 安装 — 安装常见问题
    • 编译问题
    • 使用 PHP
    • 密码散列 — 密码散列安全
    • PHP 和 HTML
    • PHP 和 COM
    • 其他问题
  • 附录
    • PHP 及其相关工程的历史
    • 从 PHP 7.4.x 移植到 PHP 8.0.x
    • 从 PHP 7.3.x 移植到 PHP 7.4.x
    • 从 PHP 7.2.x 移植到 PHP 7.3.x
    • 从 PHP 7.1.x 移植到 PHP 7.2.x
    • 从 PHP 7.0.x 移植到 PHP 7.1.x
    • 从 PHP 5.6.x 移植到 PHP 7.0.x
    • 从 PHP 5.5.x 移植到 PHP 5.6.x
    • PHP 的调试
    • 配置选项
    • php.ini 配置
    • 扩展库列表／归类
    • 函数别名列表
    • 保留字列表
    • 资源类型列表
    • 可用过滤器列表
    • 所支持的套接字传输器（Socket Transports）列表
    • PHP 类型比较表
    • 解析器代号列表
    • 用户空间命名指南
    • 关于本手册
    • Creative Commons Attribution 3.0
    • 索引
    • 更新日志
  • CHM 版本
    • 关于此版本
    • Using PHP Manual CHM Edition
    • The Full Text Search
    • Integrating the PHP Manual


版权信息

Copyright © 1997 - 2021，PHP 文档组版权所有。发行本资料必须服从 Creative Commons Attribution 3.0 或更新版许可中阐明的条款及条件。Creative Commons Attribution 3.0 license 的副本已随本手册发行。其最新版本位于 » http://creativecommons.org/licenses/by/3.0/。

如有兴趣再发行或再版此文档的全部或部分内容，不论修改过与否，或有任何问题，请联系版权所有者 » doc-license@lists.php.net。注意，本地址映射到一个公开归档的邮件列表。


  • ? 版权信息
  • 序言 ?
  • PHP Manual
  • PHP 手册

PHP 手册

  • 序言


序言

PHP，即"PHP: Hypertext Preprocessor"，是一种被广泛应用的开源通用脚本语言，尤其适用于 Web 开发并可嵌入 HTML 中去。它的语法利用了 C、Java 和 Perl，易于学习。该语言的主要目标是允许 web 开发人员快速编写动态生成的 web 页面，但 PHP 的用途远不只于此。

本手册内容主要由函数参考构成，但也包含了语言参考，PHP 一些主要产品特点的说明以及其它补充信息。

可在 » https://www.php.net/download-docs.php 下载此手册的各种格式。更多关于如何开发本手册的信息可参阅附录："关于本手册"。如果你对 PHP 的历史感兴趣，可访问相关附录。

作者与贡献者

在手册的首页上仅突出了目前最活跃的人员，但还有更多的贡献者正在帮助我们工作或在过去给项目提供过巨大的帮助。有许多不知名的人帮助在手册中写下用户评论，并不断地包含在参考中，也很感谢他们的努力。下面所提供的列表均以字母顺序排序。

作者与编辑

下列人员曾经或者目前正在为本手册添砖加瓦： Bill Abt, Jouni Ahto, Alexander Aulbach, Stig Bakken, George Peter Banyard, Christoph M. Becker, Daniel Beckham, Nilgün Belma Bugüner, Jesus M. Castagnetto, Ron Chmara, Sean Coates, John Coggeshall, Simone Cortesi, Peter Cowburn, Daniel Egeberg, Markus Fischer, Wez Furlong, Sara Golemon, Rui Hirokawa, Brad House, Pierre-Alain Joye, Etienne Kneuss, Moriyoshi Koizumi, Rasmus Lerdorf, Andrew Lindeman, Stanislav Malyshev, Justin Martin, Rafael Martinez, Rick McGuire, Moacir de Oliveira Miranda Júnior, Kalle Sommer Nielsen, Yasuo Ohgaki, Philip Olson, Richard Quadling, Derick Rethans, Rob Richards, Sander Roobol, Egon Schmid, Thomas Schoefbeck, Sascha Schumann, Dan Scott, Masahiro Takagi, Yoshinari Takaoka, Yannick Torres, Michael Wallner, Lars Torben Wilson, Jim Winstead, Jeroen van Wolffelaar 和 Andrei Zmievski.

下列人员对本手册做了相当数量的编辑工作： Stig Bakken, Gabor Hojtsy, Hartmut Holzgraefe, Philip Olson 和 Egon Schmid.

用户评论维护者

目前最活跃的维护者是： Daniel Brown, Nuno Lopes, Felipe Pena, Thiago Pojda 和 Maciek Sokolewicz.

下列人员为维护用户评论作出了巨大的努力: Mehdi Achour, Daniel Beckham, Friedhelm Betz, Victor Boivie, Jesus M. Castagnetto, Nicolas Chaillan, Ron Chmara, Sean Coates, James Cox, Vincent Gevers, Sara Golemon, Zak Greant, Szabolcs Heilig, Oliver Hinckel, Hartmut Holzgraefe, Etienne Kneuss, Rasmus Lerdorf, Matthew Li, Andrew Lindeman, Aidan Lister, Hannes Magnusson, Maxim Maletsky, Bobby Matthis, James Moore, Philip Olson, Sebastian Picklum, Derick Rethans, Sander Roobol, Damien Seguy, Jason Sheets, Tom Sommer, Jani Taskinen, Yasuo Ohgaki, Jakub Vrana, Lars Torben Wilson, Jim Winstead, Jared Wyles 和 Jeroen van Wolffelaar.

中文翻译外部支持团队

PHP 手册中文翻译工作是一项长期而又艰巨的工作。如果您有兴趣加入，请参阅 » 中文手册翻译指南。

中文翻译贡献者名单

感谢以下贡献者为 PHP 中文翻译工作做出的贡献： Jiania（洪建家）、verdana（穆少磊）、Gregory（宋琪）、黄啸宇、 codingall.com（赵磊）、cuimuxi（崔玉松）、cztviztor、gaojian1226、HaoHappy（陈浩）、HonestQiao（乔楚）、 kendotom、lgg860911、loosen.copen、miusun01（李鼎峰）、ping3608、r.anerg（罗翀）、suppersoft（paris.wang） 、 fising（王祥中）、wind.golden（陈金）。


入门指引

  • 简介
    • PHP 是什么？
    • PHP 能做什么？
  • 简明教程
    • 需要些什么？
    • 第一个 PHP 页面
    • 实用的脚本
    • 处理表单
    • 在新版本的 PHP 中使用旧的 PHP 代码
    • 下一步做什么？


  • ? 入门指引
  • PHP 是什么？ ?
  • PHP Manual
  • 入门指引
  • 简介

简介

Table of Contents

  • PHP 是什么？
  • PHP 能做什么？


PHP 是什么？

PHP（"PHP: Hypertext Preprocessor"，超文本预处理器的字母缩写）是一种被广泛应用的开放源代码的多用途脚本语言，它可嵌入到 HTML中，尤其适合 web 开发。

以上是一个简单的回答，不过这是什么意思呢？请看如下例子：

Example #1 一个介绍性的范例

<html>
    <head>
        <title>Example</title>
    </head>
    <body>

        <?php
        echo "Hi, I'm a PHP script!";
        ?>

    </body>
</html>

请注意这个范例和其它用 C 或 Perl 语言写的脚本之间的区别——与用大量的命令来编写程序以输出 HTML 不同的是，PHP 页面就是 HTML，只不过在其中嵌入了一些代码来做一些事情（在本例中输出了 "Hi, I'm a PHP script!"）。PHP 代码被包含在特殊的起始符和结束符 <?php 和 ?> 中，使得可以进出"PHP 模式"。

和客户端的 JavaScript 不同的是，PHP 代码是运行在服务端的。如果在服务器上建立了如上例类似的代码，则在运行该脚本后，客户端就能接收到其结果，但他们无法得知其背后的代码是如何运作的。甚至可以将 web 服务器设置成让 PHP 来处理所有的 HTML 文件，这么一来，用户就无法得知服务端到底做了什么。

使用 PHP 的一大好处是它对于初学者来说极其简单，同时也给专业的程序员提供了各种高级的特性。当看到 PHP 长长的特性列表时，请不要害怕。可以很快的入门，只需几个小时就可以自己写一些简单的脚本。

尽管 PHP 的开发是以服务端脚本为目的，但事实上其功能远不局限与此。请继续读后面的章节，在"PHP 能做什么"一节中将获得更多的信息。如果对 web 编程感兴趣，也可以阅读简明教程。


PHP 能做什么？

PHP 能做任何事。PHP 主要是用于服务端的脚本程序，因此可以用 PHP 来完成任何其它的 CGI 程序能够完成的工作，例如收集表单数据，生成动态网页，或者发送／接收 Cookies。但 PHP 的功能远不局限于此。

PHP 脚本主要用于以下三个领域：

  • 服务端脚本。这是 PHP 最传统，也是最主要的目标领域。开展这项工作需要具备以下三点：PHP 解析器（CGI 或者服务器模块）、web 服务器和 web 浏览器。需要在运行 web 服务器时，安装并配置 PHP，然后，可以用 web 浏览器来访问 PHP 程序的输出，即浏览服务端的 PHP 页面。如果只是实验 PHP 编程，所有的这些都可以运行在自己家里的电脑中。请查阅安装一章以获取更多信息。
  • 命令行脚本。可以编写一段 PHP 脚本，并且不需要任何服务器或者浏览器来运行它。通过这种方式，仅仅只需要 PHP 解析器来执行。这种用法对于依赖 cron（Unix 或者 Linux 环境）或者 Task Scheduler（Windows 环境）的日常运行的脚本来说是理想的选择。这些脚本也可以用来处理简单的文本。请参阅 PHP 的命令行模式以获取更多信息。
  • 编写桌面应用程序。对于有着图形界面的桌面应用程序来说，PHP 或许不是一种最好的语言，但是如果用户非常精通 PHP，并且希望在客户端应用程序中使用 PHP 的一些高级特性，可以利用 PHP-GTK 来编写这些程序。用这种方法，还可以编写跨平台的应用程序。PHP-GTK 是 PHP 的一个扩展，在通常发布的 PHP 包中并不包含它。如果对 PHP-GTK 感兴趣，请访问其» 网站以获取更多信息。

PHP 能够在所有的主流操作系统上使用，包括 Linux、Unix 的各种变种（包括 HP-UX、Solaris 和 OpenBSD）、Microsoft Windows、Mac OS X、RISC OS 等。今天，PHP已经支持了大多数的 web 服务器，包括 Apache、Microsoft Internet Information Server（IIS）、Personal Web Server（PWS）、Netscape 以及 iPlant server、Oreilly Website Pro Server、Caudium、Xitami、OmniHTTPd 等。对于大多数的服务器，PHP 提供了一个模块；还有一些 PHP 支持 CGI 标准，使得 PHP 能够作为 CGI 处理器来工作。

综上所述，使用 PHP，可以自由地选择操作系统和 web 服务器。同时，还可以在开发时选择使用面对过程和面对对象，或者两者混和的方式来开发。尽管 PHP 4 不支持 OOP 所有的标准，但很多代码仓库和大型的应用程序（包括 PEAR 库）仅使用 OOP 代码来开发。PHP 5 弥补了 PHP 4 的这一弱点，引入了完全的对象模型。

使用 PHP，并不局限于输出 HTML。PHP 还能被用来动态输出图像、PDF 文件甚至 Flash 动画（使用 libswf 和 Ming）。还能够非常简便的输出文本，例如 XHTML 以及任何其它形式的 XML 文件。PHP 能够自动生成这些文件，在服务端开辟出一块动态内容的缓存，可以直接把它们打印出来，或者将它们存储到文件系统中。

PHP 最强大最显著的特性之一，是它支持很大范围的数据库。使用任何针对某数据库的扩展（例如 mysql）编写数据库支持的网页非常简单，或者使用抽象层如 PDO，或者通过 ODBC 扩展连接到任何支持 ODBC 标准的数据库。其它一些数据库也可能会用 cURL 或者 sockets，例如 CouchDB。

PHP 还支持利用诸如 LDAP、IMAP、SNMP、NNTP、POP3、HTTP、COM（Windows 环境）等不计其数的协议的服务。还可以开放原始网络端口，使得任何其它的协议能够协同工作。PHP 支持和所有 web 开发语言之间的 WDDX 复杂数据交换。关于相互连接，PHP 已经支持了对 Java 对象的即时连接，并且可以透明地将其用作 PHP 对象。

PHP 具有极其有效的文本处理特性，包括 Perl 兼容正则表达式（PCRE）以及许多扩展和工具可用于解析和访问 XML 文档。PHP 将所有的 XML 功能标准化于坚实的 libxml2 扩展，并且还增加了 SimpleXML，XMLReader 以及 XMLWriter 支持以扩充其功能。

另外，还有很多其它有趣的扩展库，在此根据字母和分类归类列出。还有一些附加的 PECL 扩展可能有也可能没有在 PHP 手册中列出，例如 » XDebug。

由于在这里无法列出 PHP 所有的特性和可提供的便利，请参阅安装以及函数参考有关章节以获取关于这里提到的扩展库更多的信息。


简明教程

Table of Contents

  • 需要些什么？
  • 第一个 PHP 页面
  • 实用的脚本
  • 处理表单
  • 在新版本的 PHP 中使用旧的 PHP 代码
  • 下一步做什么？

本章将给出关于 PHP 的简明教程。虽然 PHP 的功能并不局限于生成动态的 web 页面，但本章的内容仅涉及于此。请查阅"PHP 能做什么"一节以获取更多信息。

使用了 PHP 的 web 页面将被和通常的 HTML 页面一样处理，可以用通常建立 HTML 页面的方法来建立和编辑它们。


需要些什么？

在本教程中，假设用户的服务器已经安装并运行了 PHP，所有以 .php 结尾的文件都将由 PHP 来处理。在大部分的服务器上， 这是 PHP 的默认扩展名，不过，也请询问服务器管理员以确认。如果服务器支持 PHP ，则不需要做任何事情。只用建立 .php 文件，并把它们放置 到 web 目录中，服务器将神奇地自动解析这些文件。不用编译任何东西，也不用安装 任何其它的工具，仅仅只需把这些使用了 PHP 的文件想象成简单的 HTML 文件，其中 只不过多了一种新的标识符，在这里可以做各种各样的事情。

假设用户希望在本地机器开发以节约宝贵的带宽。在这种情况下，需要安装一个诸如 » Apache 的 web 服务器，当然还有 » PHP。可能还希望安装一个数据库，例如 » MySQL。

可以一个个的安装它们或选择一个更简单的方法。可以参考本手册中 PHP 安装说明的相关章节（假设已经配置好了某个 web 服务器）。若在自己安装 PHP 时出现了问题，建议在» 安装邮件列表中询问。如果想使用更简便的方法安装 PHP，那么可以考虑» 获取一个预先配置的安装包，用这个安装包，只用点击几下鼠标，就可以自动地安装所有这些系统。在任何操作系统下建立有 PHP 支持的 web 服务器都十分简单，包括 MacOSX、Linux 和 Windows。在 Linux 下，会发现 » rpmfind 和 » PBone 能够在获取 RPM 时提供帮助。也可以使用 » apt-get 搜索 Debian 的相关软件包。


第一个 PHP 页面

在 web 服务器根目录（DOCUMENT_ROOT）下建立一个文件名为 hello.php，然后完成如下内容：

Example #1 第一个 PHP 脚本：hello.php

<html>
 <head>
  <title>PHP 测试</title>
 </head>
 <body>
 <?php echo '<p>Hello World</p>'; ?>
 </body>
</html>

在浏览器的地址栏里输入 web 服务器的 URL 访问这个文件，在结尾加上"/hello.php"。如果本地开发，那么这个 URL 一般是 http://localhost/hello.php 或者 http://127.0.0.1/hello.php，当然这取决于 web 服务器的设置。如果所有的设置都正确，那么这个文件将被 PHP 解析，浏览器中将会输出如下结果：

<html>
 <head>
  <title>PHP 测试</title>
 </head>
 <body>
 <p>Hello World</p>
 </body>
</html>

该程序非常的简单，它仅仅只是利用了 PHP 的 echo 语句显示了 Hello World。用户一定不会满足与此。请注意该文件无需被执行或以任何方式指定。服务器会找到该文件并提供给 PHP 进行解释，因为使用了".php"的扩展名，服务器已被配置成自动传递有着".php"扩展名的文件给 PHP。一个普通的 HTML 文件，加上了几个特别的标签，就可以做很多非常有趣的事情！

如果试过了这个例子，但是没有得到任何输出，或者浏览器弹出了下载框，或者浏览器以文本方式显示了源文件，可能的原因是服务器还没有支持 PHP，或者没有正确配置。需要请服务器的管理员根据本手册"安装"一章的内容使得服务器支持 PHP。如果本地开发，请阅读手册有关安装的章节以确保所有的设置都正确。还要确认通过浏览器访问的 URL 确实指向了服务器上的这个文件。如果只是从本地文件系统调用这个文件，它不会被 PHP 解析。如果问题仍然存在，请通过 » PHP 在线支持中的各种方式获取帮助。

以上例子的目的是为了显示 PHP 特殊标识符的格式。在这个例子中，用 <?php 来表示 PHP 标识符的起始，然后放入 PHP 语句并通过加上一个终止标识符 ?> 来退出 PHP 模式。可以根据自己的需要在 HTML 文件中像这样开启或关闭 PHP 模式。请参阅手册中"PHP 基本语法"以获取更多信息。

Note: 关于换行

尽管换行在 HTML 中的实际意义不是很大，但适当地使用换行可以使 HTML 代码易读且美观。PHP 会在输出时自动删除其结束符 ?> 后的一个换行。该功能主要是针对在一个页面中嵌入多段 PHP 代码或者包含了无实质性输出的 PHP 文件而设计，与此同时也造成了一些疑惑。如果需要在 PHP 结束符 ?> 之后输出换行的话，可以在其后加一个空格，或者在最后的一个 echo/print 语句中加入一个换行。

Note: 关于文本编辑器

有很多文本编辑器以及集成开发环境（IDE）可以被用来建立、编辑和管理 PHP 文件。这些工具中的一部分被列在 » PHP 编辑器列表中。如果希望推荐其它的编辑器，请访问以上页面，并要求该页面的维护者将你推荐的编辑器加入到该列表中。使用支持语法高亮功能的编辑器会给开发带来很多帮助。

Note: 关于文字处理器

诸如 StarOffice Writer、Microsoft Word 和 Abiword 的文字处理器不适合用来编辑 PHP 程序。如果希望用以上这些工具的某一种来处理脚本，必须保证将结果存成了纯文本格式，否则 PHP 将无法读取并运行这些脚本。

Note: 关于 Windows 记事本

如果使用 Windows 记事本来编写 PHP 脚本，需要注意在保存文件时，文件的后缀名应该为 .php（记事本将自动在文件名后面加上 .txt 后缀，除非采取以下措施之一来避免这种情况）。当保存文件时，系统会让你指定文件的文件名，这时请将文件名加上引号（例如 "hello.php"）。或者，也可以点击"另存为"对话框中的"保存类型"下拉菜单，并将设置改为"所有文件"。这样在输入文件名的时候就不用加引号了。

现在已经成功建立了一个简单的 PHP 脚本，那么再来建立一个最著名的 PHP 脚本！调用函数 phpinfo()，将会看到很多有关自己系统的有用信息，例如预定义变量、已经加载的 PHP 模块和配置信息。请花一些时间来查看这些重要的信息。

Example #2 从 PHP 获取系统信息

<?php phpinfo(); ?>


实用的脚本

现在来编写一些更实用的脚本，比如检查浏览页面的访问者在用什么浏览器。要达到这个目的，需要检查用户的 agent 字符串，它是浏览器发送的 HTTP 请求的一部分。该信息被存储在一个变量中。在 PHP 中，变量总是以一个美元符开头。我们现在感兴趣的变量是 $_SERVER['HTTP_USER_AGENT']。

Note:

$_SERVER 是一个特殊的 PHP 保留变量，它包含了 web 服务器提供的所有信息，被称为超全局变量。请查阅本手册"超全局变量"中的有关内容以获取更多信息。这些特殊的变量是在 PHP » 4.1.0 版本引入的。在这之前使用 $HTTP_*_VARS 数组，如 $HTTP_SERVER_VARS。自 PHP 5.4.0 起，这些旧变量已经移除了。（参见"旧代码"一节中的注解）。

要显示该变量，只需简单地进行如下操作：

Example #1 打印一个变量（数组元素）

<?php
echo $_SERVER['HTTP_USER_AGENT'];
?>

该脚本的输出可能是：

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

PHP 有很多种不同类型的变量。在以上例子中我们打印了一个数组的单元。数组是一类非常有用的变量。

$_SERVER 只是 PHP 自动全局化的变量之一。可以查阅"预定义变量"一节来查看这些变量的列表，或者也可以通过上节例子中 phpinfo() 函数的输出来查看。

可以在一个 PHP 标识中加入多个 PHP 语句，也可以建立一个代码块来做比简单的 echo 更多的事情。例如，如果需要识别 Internet Explorer，可以进行如下操作：

Example #2 流程控制与函数的使用

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
    echo '正在使用 Internet Explorer。<br />';
}
?>

该脚本的输出可能是：

正在使用 Internet Explorer。<br />

这里要介绍一些新的原理。上面用了一个 if 语句。如果用户对 C 语言的基本语法比较熟悉，则应该对此很熟悉，否则，可能需要拿起任何一本 PHP 介绍性的书籍并阅读前面的两三个章节，或者也可以阅读本手册的"语言参考"一章。

需要介绍的第二个原理，是对 strpos() 函数的调用。strpos() 是 PHP 的一个内置函数，其功能是在一个字符串中搜索另外一个字符串。例如我们现在需要在 $_SERVER['HTTP_USER_AGENT']（即所谓的 haystack）变量中寻找 'MSIE'。如果在这个 haystack 中该字符串（即所谓的 needle）被找到（"草里寻针"），则函数返回 needle 在 haystack 中相对于开头的位置；如果没有，则返回 false。如果该函数没有返回 false，则 if 会将条件判断为 true 并运行其花括号 {} 内的代码；否则，则不运行这些代码。可以自己尝试利用 if，else 以及其它的函数如 strtoupper() 和 strlen() 来建立类似的脚本。在本手册中相关的页面也包含有范例。如果对如何使用函数不是很确定，可以阅读手册中有关"如何阅读函数的定义"和"函数"的有关章节。

以下我们进一步显示如何进出 PHP 模式，甚至是在一个 PHP 代码块的中间：

Example #3 混和 HTML 和 PHP 模式

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
?>
<h3>strpos() 肯定没有返回假 (FALSE)</h3>
<p>正在使用 Internet Explorer</p>
<?php
} else {
?>
<h3>strpos() 肯定返回假 (FALSE)</h3>
<center><b>没有使用 Internet Explorer</b></center>
<?php
}
?>

该脚本的输出可能是：

<h3>strpos() 肯定没有返回假 (FALSE)</h3>
<p>正在使用 Internet Explorer</p>

和以上我们用一个 PHP 的 echo 语句来输出不同的是，我们跳出了 PHP 模式来直接写 HTML 代码。这里很值得注意的一点是，对于这两种情况而言，脚本的逻辑效率是相同的。在判断了 strpos() 函数的返回值是 true 或是 false，也就是判断了字符串 'MSIE' 是否被找到之后，最终只有一个 HTML 块被发送给浏览者。


处理表单

PHP 一个很有用的特点体现在它处理 PHP 表单的方式。需要理解的非常重要的原理，是表单的任何元素都在 PHP 脚本中自动生效。请参阅本手册中"PHP 的外部变量"以获取关于在 PHP 中使用表单的详细信息及范例。以下是 HTML 表单的范例：

Example #1 一个简单的 HTML 表单

<form action="action.php" method="post">
 <p>姓名: <input type="text" name="name" /></p>
 <p>年龄: <input type="text" name="age" /></p>
 <p><input type="submit" /></p>
</form>

该表单中并没有什么特殊的地方，其中没有使用任何特殊的标识符。当用户填写了该表单并点击了提交按钮，页面 action.php 将被调用。在该文件中，可以加入如下内容：

Example #2 打印来自表单的数据

你好，<?php echo htmlspecialchars($_POST['name']); ?>。
你 <?php echo (int)$_POST['age']; ?> 岁了。

该脚本的输出可能是：

你好，Joe。你 22 岁了。

除了htmlspecialchars() 和 (int) 部分，这段程序做什么用显而易见。htmlspecialchars() 使得 HTML 之中的特殊字符被正确的编码，从而不会被使用者在页面注入 HTML 标签或者 Javascript 代码。例如 age 字段，我们明确知道他是一个数值，因此我们将它转换为一个int来自动的消除任何不必要的字符。也可以使用 PHP 的 filter 扩展来自动完成该工作。PHP 将自动设置 $_POST['name'] 和 $_POST['age'] 变量。在这之前我们使用了超全局变量 $_SERVER，现在我们引入了超全局变量 $_POST，它包含了所有的 POST 数据。请注意我们的表单提交数据的方法（method）。如果使用了 GET 方法，那么表单中的信息将被储存到超全局变量 $_GET 中。如果并不关心请求数据的来源，也可以用超全局变量 $_REQUEST，它包含了所有 GET、POST、COOKIE 和 FILE 的数据。

也可以在 PHP 中处理 XForms 的输入，尽管用户可能更喜欢使用长久以来支持良好的 HTML 表单。XForms 目前还不适合初学者使用，但是用户可能对它感兴趣。手册中在"特点"一章有一节对如何处理从 XForum 接收到的数据进行了简短的介绍。


在新版本的 PHP 中使用旧的 PHP 代码

现在，PHP 已经发展成为一种流行的脚本语言，可以在很多公共的资源里找到可以在自己的脚本中重新利用的代码。PHP 语言的开发者为向下兼容性下了很多功夫，因此在新版本的 PHP 下，老版本的代码应该可以在不作任何改动的情况下（理想地）运行。不过实际上，还是必须对老的代码做一些改动。

有可能影响到老版本的代码的最重要的两点改动分别是：

  • 旧的 $HTTP_*_VARS 数组从 PHP 5.4.0 开始将不再有效。 PHP » 4.1.0 版本引入了如下超全局数组变量： $_GET、$_POST、$_COOKIE、 $_SERVER、$_FILES、$_ENV、 $_REQUEST 以及 $_SESSION。
  • 外部变量不再被默认注册为全局变量。也就是说，从 PHP » 4.2.0 版开始，php.ini 中的设置选项 register_globals 默认值变成了 off。建议用以上提到的超全局数组变量来访问这些值。但可能老的脚本、书籍以及教程都可能建立在该设置为 on 的基础上。如果该选项被设置为 on，则可以在 URL http://www.example.com/foo.php?id=42 中直接使用变量 $id。但不管被设置为 on 还是 off，$_GET['id'] 一直有效。

如果希望了解关于这些改动的细节，请参阅"预定义变量"一章以及其中的连接。


下一步做什么？

用现在掌握的知识，应该能够理解本手册中的大部分内容以及其中各式各样的脚本范例。

请查阅 PHP Conference 资料网站 » http://talks.php.net/ 以观看更多幻灯片，这些幻灯片展示了许多 PHP 其它的功能。


安装与配置

  • 安装前需要考虑的事项
  • Unix 系统下的安装
    • Unix 系统下的 Apache 1.3.x
    • Unix 系统下的 Apache 2.x
    • Unix 系统下的 Nginx 1.4.x
    • Unix 平台的 Lighttpd 1.4
    • Unix系统下的LiteSpeed、OpenLiteSpeed服务
    • CGI 和命令行设置
    • 针对 HP-UX 平台的安装提示
    • 在 OpenBSD 系统下的安装
    • 针对 Solaris 的安装提示
    • Debian GNU/Linux 安装说明
  • Mac OS X 系统下的安装
    • 使用软件包
    • 使用内置的 PHP
    • 在 macOS 下编译 PHP
  • Windows 系统下的安装
    • 环境要求
    • PECL
    • Windows 下的 PHP 安装程序工具
    • Windows 系统下的推荐配置
    • 在 Windows 上手动安装 PHP
    • Windows 下 PHP 故障排除
    • 旧版本 Windows 支持
  • 云计算平台上的安装
    • Azure App Services
    • Amazon EC2
  • FastCGI 进程管理器（FPM）
    • 安装
    • 配置
  • PECL 扩展库安装
    • PECL 安装介绍
    • 下载 PECL 扩展库
    • 在 Windows 上安装 PHP 扩展
    • 用 PEAR 编译共享 PECL 扩展库
    • 用 phpize 编译共享 PECL 扩展库
    • php-config
    • 将 PECL 扩展库静态编译入 PHP
  • 还有问题？
    • 阅读 FAQ
    • 其它问题
    • 错误报告
  • 运行时配置
    • 配置文件
    • .user.ini 文件
    • 配置可被设定范围
    • 怎样修改配置设定


安装前需要考虑的事项

安装前，首先需要知道想用 PHP 来做什么。PHP 主要用在三个领域，分别在 PHP 能做什么 一节中进行了描述：

  • 网站和 web 应用程序（服务器端脚本）
  • 命令行脚本
  • 桌面（GUI）应用程序

在通常情况下，需要三样东西：PHP 自身、一个 web 服务器和一个 web 浏览器。通常你已经拥有了一个 web 浏览器，并且在你使用的操作系统中，也可能已经内置了 web 服务器（例如 Linux 和 macOS 下的 Apache；Windows 下的 IIS）。也许在某个公司租用了 web 空间（虚拟主机、VPS 等），这样，自己无需设置任何东西，仅需要编写 PHP 脚本，并上传到租用的空间中，然后在浏览器中查看结果。

如果需要自己配置服务器和 PHP，有两个方法将 PHP 连接到服务器上。对于很多服务器，PHP 均有一个直接的模块接口（也叫做 SAPI）。这些服务器包括 Apache、Microsoft Internet Information Server、Netscape 和 iPlanet 等服务器。如果你使用的 web 服务器不支持 PHP 模块接口，还可以将其作为 CGI 或 FastCGI 处理器来使用。这意味着可以使用 PHP 的 CGI 可执行程序来处理所有服务器上的 PHP 文件请求。

如果你对 PHP 命令行脚本感兴趣（例如在离线状态下，根据传递给脚本的参数，自动生成一些图片，或处理一些文本文件），可以参考 PHP 在命令行模式下的使用 章节。在这种情况下，不再需要 web 服务器和 web 浏览器支持。

还可以用 PHP 的 PHP-GTK 扩展来编写桌面图形界面应用程序。这与编写 web 页面完全不同，因为无需输出任何 HTML，而要管理窗口和窗口中的对象。关于 PHP-GTK 的更多信息，请访问 » PHP-GTK 扩展官网。PHP-GTK 没有包含在官方发布的 PHP 中。

本节开始介绍如何在 Unix 和 Windows 的 web 服务器中配置服务器模块接口和 CGI 可执行程序。也将在下面几节中了解到有关命令行可执行程序安装的信息。

PHP 源代码包和二进制包可以在以下链接获取 » https://www.php.net/downloads.php。


Unix 系统下的安装

Table of Contents

  • Unix 系统下的 Apache 1.3.x
  • Unix 系统下的 Apache 2.x
  • Unix 系统下的 Nginx 1.4.x
  • Unix 平台的 Lighttpd 1.4
  • Unix系统下的LiteSpeed、OpenLiteSpeed服务
  • CGI 和命令行设置
  • 针对 HP-UX 平台的安装提示
  • 在 OpenBSD 系统下的安装
  • 针对 Solaris 的安装提示
  • Debian GNU/Linux 安装说明

本节将指导如何在 Unix 系统下安装和配置 PHP。在开始安装之前，请务必研究自己使用的系统和 web 服务器的相关章节。

在安装前需要考虑的事项一节提到，在本节主要以 web 为中心介绍 PHP 的设置。不过本节也会覆盖一些 PHP 命令行用法的设置方法。

在 Unix 平台下安装 PHP 有几种方法：使用配置和编译过程，或是使用各种预编译的包。本文主要针对配置和编译 PHP 的过程。很多 Unix 类系统都有包安装系统，可以用它来设置一个有着标准配置的 PHP。但是若需要与标准配置不同的功能（例如一个安全服务器，或者不同的数据库驱动扩展模块），可能需要编译 PHP 和／或 web 服务器。如果不熟悉编译软件，可以考虑搜索一下是否有人已经编译了包含所需要功能的预编译包。

编译所需的知识和软件：

  • 基础的 Unix 技能（有能力操作"make"和一种 C 语言编译器）
  • 一个 ANSI C 语言编译器
  • 一个 web 服务器
  • 任何模块特需的组件（例如 GD 和 PDF 库等)

直接从 Git 源文件或者自己修改过的包编译时可能需要：

  • autoconf: 2.59+ (for PHP >= 7.0.0), 2.64+ (for PHP >= 7.2.0)
  • automake: 1.4+
  • libtool: 1.4.x+（除了 1.4.2）
  • re2c: 版本 0.13.4+（PHP > 7.0.0）， 0.13.7+ （PHP > 8.0.0）
  • bison:
    • PHP 7.0 - 7.3: 2.4 或更高 (包含 Bison 3.x)
    • PHP 7.4: > 3.0

PHP 初始的配置和安装过程被 configure 脚本中一系列命令行选项控制。可以通过 ./configure --help 命令了解 PHP 所有可用的编译选项及简短解释。本手册是分开对这些选项编写文档的。可在附录中找到 核心配置选项，而扩展模块特定的配置选项分别在其函数参考页面中描述。

配置好 PHP 后，便可以开始编译模块和／或可执行文件。make 命令用来做这一工作。如果该命令执行失败而找不到原因，请参考 安装问题 一节。

Note:

某些 Unix 系统（类似 OpenBSD 和 SELinux）出于安全考虑，可能不允许同时设置文件的写和执行的权限，又称为 "PaX MPROTECT" 或 "W^X violation" 保护。但是 PCRE's JIT 又要求不能这么做，所以安装时可以参考 关闭 PCRE's JIT 支持，或者在系统中将相关的二进制文件加入保护白名单。

Note: 目前还不支持 ARM 与 Android 工具链的交叉编译。


Unix 系统下的 Apache 1.3.x

本节包括在 Unix 平台的 Apache 下安装 PHP 的说明和提示。我们在另外的页面也有 Apache 2 的安装和说明。

可以从核心配置选项列表以及位于手册对应部分的特定扩展配置选项中选择参数并在安装步骤第 10 步将它们添加到 configure 命令中。版本号在这里被省略了以保证此说明的正确性。需要将这里的"xxx"替换为自己使用的文件的正确值。

Example #1 PHP 的 Apache 共享模块版本安装说明

1.  gunzip apache_xxx.tar.gz
2.  tar -xvf apache_xxx.tar
3.  gunzip php-xxx.tar.gz
4.  tar -xvf php-xxx.tar
5.  cd apache_xxx
6.  ./configure --prefix=/www --enable-module=so
7.  make
8.  make install
9.  cd ../php-xxx

10. 现在，配置 PHP。这是定制 PHP 的不同选项的时候，例如要加载哪些扩展库。使用
      ./configure --help
    来列出可用的选项。在下面的示例中只是简单地配置 Apache 1 和 MySQL 支持。
    用户的 apxs 的路径可能和此示例中的不同。

      ./configure --with-mysql --with-apxs=/www/bin/apxs

11. make
12. make install

    如果在安装之后决定修改配置选项，那么只需重复以上最后三步。只须重新启动
    Apache 就可以使新模块生效。不需要重新编译 Apache。

    注意除非特别指出，"make install"总是会安装 PEAR，各种 PHP 工具例如 phpize，
    PHP CLI 以及其它。

13. 建立 php.ini 文件。

      cp php.ini-dist /usr/local/lib/php.ini

    可以编辑 php.ini 来设置 PHP 选项。如果想把 php.ini 放在其它目录，在第
    10 步加上以下选项：

      --with-config-file-path=/path

    如果选择了  php.ini-production，确保阅读一下其中的变更说明，因为这些会
    影响到 PHP 的行为。

14. 编辑 httpd.conf 来加载 PHP 模块。在 LoadModule 语句右边的路径必须指向系统中
    PHP 模块所在的路径。上面的 make install 步骤可能已经添加了，但还是检查确认一下。

      LoadModule php5_module        libexec/libphp5.so

15. 在 httpd.conf 中加入 AddModule 部分，在 ClearModuleList 下面的某处，加上这一句：

      AddModule mod_php5.c

16. 告诉 Apache 将哪些后缀作为 PHP 解析。例如，让 Apache 把 .php 后缀的文件解析为
    PHP。可以将任何后缀的文件解析为 PHP，只要在以下语句中加入并用空格分开。这里以
    添加一个 .phtml 来示例。

      AddType application/x-httpd-php .php .phtml

    为了将 .phps 作为 PHP 的源文件进行语法高亮显示，还可以加上：

      AddType application/x-httpd-php-source .phps

17. 用通常的过程启动 Apache（必须完全停止 Apache 再重新启动，而不是用 HUP 或者
    USR1 信号使 Apache 重新加载）。

也可以将 PHP 作为静态对象来安装：

Example #2 PHP 的 Apache 静态模块版本安装说明

1.  gunzip -c apache_1.3.x.tar.gz | tar xf -
2.  cd apache_1.3.x
3.  ./configure
4.  cd ..

5.  gunzip -c php-5.x.y.tar.gz | tar xf -
6.  cd php-5.x.y
7.  ./configure --with-mysql --with-apache=../apache_1.3.x
8.  make
9.  make install

10. cd ../apache_1.3.x

11. ./configure --prefix=/www --activate-module=src/modules/php5/libphp5.a
    （上面一行是正确的！是的，我们知道 libphp5.a 尚不存在，还不到时候，
      它会在之后被创建。）

12. make
    （现在应该有一个 httpd 二进制文件，可以将它复制到 Apache bin 目录。如果这是
      第一次安装，还要"make install"。)

13. cd ../php-5.x.y
14. cp php.ini-development /usr/local/lib/php.ini

15. 可以编辑 /usr/local/lib/php.ini 文件以设置 PHP 选项。编辑 httpd.conf 或
    srm.conf 文件，添加：
    AddType application/x-httpd-php .php

根据 Unix 系统和 Apache 安装方法的不同，有很多方法停止和重启动 Apache。以下是一些不同的 Apache／UNIX 下重启动 Apache 的典型命令。需要把 /path/to/替换成自己系统上的确切路径。

Example #3 重启动 Apache 的示例命令

1. 在一些 Linux 和 SysV 的变种下：
/etc/rc.d/init.d/httpd restart

2. 使用 apachectl 脚本：
/path/to/apachectl stop
/path/to/apachectl start

3. httpdctl 和 httpsdctl（使用了 OpenSSL），类似 apachectl：
/path/to/httpsdctl stop
/path/to/httpsdctl start

4. 使用了 mod_ssl，或其他 SSL 服务器，可能需要手工重启动：
/path/to/apachectl stop
/path/to/apachectl startssl

apachectl 和 http(s)dctl 程序所在的路径在不同系统中通常不一样。如果系统中有 locate 或者 whereis 或者 which 命令，那么可以帮助找到这些控制程序。

编译 PHP 和 Apache 的不同例子还有：

./configure --with-apxs --with-pgsql

此配置将生成在 Apache 的 httpd.conf 文件中用 LoadModule 加载的 libphp5.so 共享库。而 PostgreSQL 支持将嵌入到此共享库中。

./configure --with-apxs --with-pgsql=shared

此配置将生成 Apache 的 libphp5.so 共享库，并且还生成 pgsql.so 共享库，可以在 php.ini 文件中用 extension 指令加载，或者在 PHP 脚本中用 dl() 函数明确地加载。

./configure --with-apache=/path/to/apache_source --with-pgsql

此配置将生成一个 libmodphp5.a 库，一个 mod_php5.c 和一些相关的文件并且拷贝到 Apache 源程序目录中的 src/modules/php5目录下。然后用 --activate-module=src/modules/php5/libphp5.a 编译 Apache，Apache 编译系统会生成 libphp5.a 并且将其静态地连接到 httpd 程序中。PostgreSQL 支持也直接包括在这个 httpd 程序中了，因此最终结果是单一的一个包括了所有 Apache 和 PHP 支持的 httpd 可执行文件。

./configure --with-apache=/path/to/apache_source --with-pgsql=shared

此配置和上面一样——除了没有在最后的 httpd 可执行文件中包括 PostgreSQL 的支持以及生成了一个 pgsql.so 共享库以外。该共享库可以在 php.ini 文件中或者用 dl() 函数加载。

当选择不同的方法编译 PHP 时，需要考虑每种方法的优势和缺点。用共享对象方式编译 PHP 意味着可以单独编译 Apache，并且不用在添加或修改了 PHP 的时候重新编译所有程序。用内置方法编译 PHP（静态方式）意味着 PHP 可以加载和运行得更快。更多信息见 Apache 的 » DSO 支持页面。

Note:

Apache 默认的 httpd.conf 文件中目前包括类似如下的内容：

User nobody
Group "#-1"
除非把它修改成"Group nogroup"或者其它类似的（"Group daemon"也很通用），PHP 将不能打开文件。

Note:

确认在使用 --with-apxs=/path/to/apxs 时指向 Apache 安装后的目录中的 apxs。绝对不能用 Apache 源程序中的 apxs 而要用安装后的 apxs。


Unix 系统下的 Apache 2.x

本节包括在 Unix 平台的 Apache 2.x 下安装 PHP 的说明和提示。

Warning

不推荐在使用 Apache 2 的产品中使用线程化 MPM。应使用预分支 MPM，Apache 2.0 和 2.2 默认的 MPM。其原因见 FAQ 中的相关条目使用线程化 MPM 的 Apache2。

推荐阅读 » Apache 文档，了解一下 Apache 2.x 服务器，以及详细的安装参数。

可以从 » Apache 下载站点下载最新版本的Apache，并且根据上文选择合适版本的 PHP 下载。本向导仅包含最基础的内容，只能让 Apache 2.x 和 PHP 能够正常工作。更多信息请阅读 » Apache 文档。这里省略所有的版本号，以保证本文的正确性。需要将本文的"NN"替换为相应的版本号。

当前 Apache 2.x 有两个流行的版本 - 2.4、2.2。虽然选择某个版本会有种种原因，但是如果可以考虑的话，我们还是建议使用最新的 Apache 2.4 版本。当然，以下的介绍同样适合 Apache 2.4 和 2.2。请注意 Apache 2.2 已经不再被官方支持，并且不再发布新功能和补丁更新。

  1. 从上面列出的地方获取 Apache 源码包，然后解压：

    tar -xzf httpd-2.x.NN.tar.gz

  2. 同样，获取 PHP 源码包并解压：

    tar -xzf php-NN.tar.gz

  3. 编译并安装 Apache。请参考 Apache 安装文档了解编译 Apache 的更多细节。

    cd httpd-2_x_NN
./configure --enable-so
make
make install

  4. 现在已经将 Apache 2.x.NN 安装在 /usr/local/apache2。本安装支持可装载模块 和标准的 MPM prefork。之后，可以使用如下命令启动 Apache 服务器：

    /usr/local/apache2/bin/apachectl start
    如果成功，可以停止 Apache 服务器并继续安装 PHP：
    /usr/local/apache2/bin/apachectl stop

  5. 现在需要配置并编译 PHP。在这里可以用各种各样的参数来自定义 PHP，例如启动哪些扩展功能包的支持等。用 ./configure --help 命令可以列出当前可用的所有参数。在此例中，将给出一个在有 MySQL 支持的 Apache 2 上进行配置的范例。

    如果按照上面的说明从源代码编译了 Apache，下面的例子会正确匹配 apxs 的路径。如果通过其他方式安装了 Apache，需要相应的调整 apxs 的路径。注意，在有些发行版本中，可能将 apxs 更名为 apxs2。

    cd ../php-NN
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
make
make install

    如果决定在安装后改变配置选项，只需重复最后的三步 configure，make，以及 make install，然后需要重新启动 Apache 使新模块生效。Apache 不需要重新编译。

    请注意，除非明确有提示，否则"make install"命令将安装 PEAR、各种 PHP 工具诸如 phpize，并安装 PHP CLI 等等。

  6. 配置 php.ini

    cp php.ini-development /usr/local/lib/php.ini

    可以编辑 php.ini 来设置 PHP 运行时的选项。如果想要把此文件放到另外的位置，需要在步骤 5 添加 --with-config-file-path=/path 选项。

    如果选择了 php.ini-production，请务必阅读其中的变更列表，它们将影响 PHP 的执行。

  7. 编辑 httpd.conf 文件以调用 PHP 模块。LoadModule 达式右边的路径必须指向系统中的 PHP 模块。以上的 make install 命令可能已经完成了这些，但务必要检查。

    PHP 7 版本:

    LoadModule php7_module modules/libphp7.so

    PHP 5 版本:

    LoadModule php5_module modules/libphp5.so

  8. 告知 Apache 将特定的扩展名解析成 PHP，例如，让 Apache 将扩展名 .php 解析成 PHP。为了避免潜在的危险，例如上传或者创建类似 exploit.php.jpg 的文件并被当做 PHP 执行，我们不再使用 Apache 的 AddType 指令来设置。参考下面的例子，你可以简单的将需要的扩展名解释为 PHP。我们演示为增加.php。

    <FilesMatch \.php$>
    SetHandler application/x-httpd-php
</FilesMatch>

    或者，你也想将 .php，.php2，.php3，.php4，.php5，.php6，以及 .phtml 文件都当做 PHP 来运行，我们无需额外的设置，仅需按照下面这样来：

    <FilesMatch "\.ph(p[2-6]?|tml)$">
    SetHandler application/x-httpd-php
</FilesMatch>

    然后，可以将 .phps 文件由 PHP 源码过滤器处理，使得其在显示时可以高亮源码，设置如下：

    <FilesMatch "\.phps$">
    SetHandler application/x-httpd-php-source
</FilesMatch>

    mod_rewrite 也有助于将那些不需要运行的 .php 文件的源码高亮显示，而并不需要将他们更名为 .phps 文件：

    RewriteEngine On
RewriteRule (.*\.php)s$ $1 [H=application/x-httpd-php-source]

    不要在正式生产运营的系统上启动 PHP 源码过滤器，因为这可能泄露系统机密或者嵌入的代码中的敏感信息。

  9. 按照通常的方式启动 Apache 服务：

    /usr/local/apache2/bin/apachectl start

    OR

    service httpd restart

按照上面的步骤便可以使 Apache 2.ｘ 将 PHP 作为 SAPI 模块了。当然 Apache 和 PHP 都还有很多配置选项，可以在相应的源代码目录中使用 ./configure --help 获得更多信息。

假如要编译一个多线程版本的 Apache，可在编译时选择用 worker MPM 来替换标准的 prefork MPM。只需在上面的第 3 步使用：

--with-mpm=worker

如果不是很明确这样做的后果并且大概理解其含义的话，最好不要进行这一步。更多信息请参考 Apache 文档中关于 » MPM-Modules 的部分。

Note:

Apache MultiViews 常见问题中讨论了在 PHP 中使用 MultiViews。

Note:

要编译多线程版本的 Apache，系统必须支持多线程。这也意味着需要将 PHP 编译为正处在试验阶段的 Zend Thread Safety（ZTS），因此并不是所有的扩展都可以使用了。推荐编译 Apache 使用标准的 prefork MPM-Module。


Unix 系统下的 Nginx 1.4.x

本文档包括使用 PHP-FPM 为 Nginx 1.4.x HTTP 服务器安装和配置 PHP 的说明和提示。

本指南假定您已经从源代码成功构建 Nginx，并且其二进制文件和配置文件都位于 /usr/local/nginx。 如果您使用其他方式获取的 Nginx，请参考 » Nginx Wiki 并对照本文档完成安装。

本文档仅包含 Nginx 服务器的基本配置，它将通过 80 端口提供 PHP 应用的处理能力。 如果您需要超出本文档范围的安装配置指导，建议您查阅 Nginx 和 PHP-FPM 的文档。

需要注意的是，本文档一律使用 'x' 来表示版本号，请根据实际情况将 'x' 替换为对应的版本号。

  1. 建议您访问 Nginx Wiki » 安装 页面以获取并在您的系统上安装 Nginx。

  2. 获取并解压 PHP 源代码:

    tar zxf php-x.x.x

  3. 配置并构建 PHP。在此步骤您可以使用很多选项自定义 PHP，例如启用某些扩展等。 运行 ./configure --help 命令来获得完整的可用选项清单。 在本示例中，我们仅进行包含 PHP-FPM 和 MySQL 支持的简单配置。

    cd ../php-x.x.x
./configure --enable-fpm --with-mysql
make
sudo make install

  4. 创建配置文件，并将其复制到正确的位置。

    cp php.ini-development /usr/local/php/php.ini
cp /usr/local/etc/php-fpm.d/www.conf.default /usr/local/etc/php-fpm.d/www.conf
cp sapi/fpm/php-fpm /usr/local/bin

  5. 需要着重提醒的是，如果文件不存在，则阻止 Nginx 将请求发送到后端的 PHP-FPM 模块， 以避免遭受恶意脚本注入的攻击。

    将 php.ini 文件中的配置项 cgi.fix_pathinfo 设置为 0 。

    打开 php.ini:

    vim /usr/local/php/php.ini

    定位到 cgi.fix_pathinfo= 并将其修改为如下所示：

    cgi.fix_pathinfo=0

  6. 在启动服务之前，需要修改 php-fpm.conf 配置文件，确保 php-fpm 模块使用 www-data 用户和 www-data 用户组的身份运行。

    vim /usr/local/etc/php-fpm.d/www.conf

    找到以下内容并修改：

    ; Unix user/group of processes
; Note: The user is mandatory. If the group is not set, the default user's group
;       will be used.
user = www-data
group = www-data

    然后启动 php-fpm 服务：

    /usr/local/bin/php-fpm

    本文档未涵盖对 php-fpm 进行进一步配置的信息，如果您需要更多信息，请查阅相关文档。

  7. 配置 Nginx 使其支持 PHP 应用：

    vim /usr/local/nginx/conf/nginx.conf

    修改默认的 location 块，使其支持 .php 文件：

    location / {
    root   html;
    index  index.php index.html index.htm;
}

    下一步配置来保证对于 .php 文件的请求将被传送到后端的 PHP-FPM 模块， 取消默认的 PHP 配置块的注释，并修改为下面的内容：

    location ~* \.php$ {
    fastcgi_index   index.php;
    fastcgi_pass    127.0.0.1:9000;
    include         fastcgi_params;
    fastcgi_param   SCRIPT_FILENAME    $document_root$fastcgi_script_name;
    fastcgi_param   SCRIPT_NAME        $fastcgi_script_name;
}

    重启 Nginx。

    sudo /usr/local/nginx/sbin/nginx -s stop
sudo /usr/local/nginx/sbin/nginx

  8. 创建测试文件。

    rm /usr/local/nginx/html/index.html
echo "<?php phpinfo(); ?>" >> /usr/local/nginx/html/index.php

    打开浏览器，访问 http://localhost，将会显示 phpinfo() 。

通过以上步骤的配置，Nginx 服务器现在可以以 SAPI SAPI 模块的方式支持 PHP 应用了。 当然，对于 Nginx 和 PHP 的配置，还有很多可用的选项， 请在对应的源代码目录执行 ./configure --help 来查阅更多配置选项。


Unix 平台的 Lighttpd 1.4

本节包括在 Unix 平台的 Lighttpd 1.4 下安装 PHP 的说明和提示。

推荐阅读 » Lighttpd trac 了解一下正确安装 Lighttpd 然后继续。

推荐使用 Fastcgi 作为 SAPI 模块来连接 PHP 和 Lighttpd。在 PHP 5.3 中自动激活了 Fastcgi，对于旧版本则在配置时使用 --enable-fastcgi。要确认 PHP 已激活 Fastcgi 可以使用命令 php -v，应该显示 PHP 5.2.5 (cgi-fcgi)。在 PHP 5.2.3 之前，Fastcgi 是包含在 php 可执行文件中（没有 php-cgi 文件）。

使 Lighttpd 产生 php 进程

要配置 Lighttpd 连接到 php 并产生 fastcgi 进程，编辑 lighttpd.conf。推荐使用套接字在本机连接 fastcgi 进程。

Example #1 Partial lighttpd.conf

server.modules += ( "mod_fastcgi" )

fastcgi.server = ( ".php" =>
  ((
    "socket" => "/tmp/php.socket",
    "bin-path" => "/usr/local/bin/php-cgi",
    "bin-environment" => (
      "PHP_FCGI_CHILDREN" => "16",
      "PHP_FCGI_MAX_REQUESTS" => "10000"
    ),
    "min-procs" => 1,
    "max-procs" => 1,
    "idle-timeout" => 20
  ))
)

bin-path 指令允许 lighttpd 动态产生 fastcgi 进程。PHP 会根据 PHP_FCGI_CHILDREN 环境变量产生子进程。"bin-environment"指令设定了所产生的进行的环境。PHP 会在达到 PHP_FCGI_MAX_REQUESTS 所指定的请求数目之后杀死一个子进程。在 PHP 中通常应避免"min-procs"和"max-procs"指令。PHP 自己管理其子进程，并且例如 APC 之类的 opcode 缓存仅在 PHP 管理下的子进程之间共享。如果"min-procs"被设定成某个大于 1 的值，则 PHP 应答器的总数目为该值乘以 PHP_FCGI_CHILDREN（如 min-procs 为 2，PHP_FCGI_CHILDREN 为 16 则会产生 32 个应答器）。

通过 spawn-fcgi 产生进程

Lighttpd 提供一个名为 spawn-fcgi 的程序来简化产生 fastcgi 进程的手续。

产生 php-cgi

有可能不通过 spawn-fcgi 来产生进程，但需要做些工作。设定 PHP_FCGI_CHILDREN 环境变量控制了 PHP 产生多少个子进程来处理请求。设定 PHP_FCGI_MAX_REQUESTS 将决定每个子进程存活多久（以请求数目决定）。以下为一个简单的 bash 脚本来帮助产生 php 应答器。

Example #2 产生 FastCGI 应答器

#!/bin/sh

# Location of the php-cgi binary
PHP=/usr/local/bin/php-cgi

# PID File location
PHP_PID=/tmp/php.pid

# Binding to an address
#FCGI_BIND_ADDRESS=10.0.1.1:10000
# Binding to a domain socket
FCGI_BIND_ADDRESS=/tmp/php.sock

PHP_FCGI_CHILDREN=16
PHP_FCGI_MAX_REQUESTS=10000

env -i PHP_FCGI_CHILDREN=$PHP_FCGI_CHILDREN \
       PHP_FCGI_MAX_REQUESTS=$PHP_FCGI_MAX_REQUESTS \
       $PHP -b $FCGI_BIND_ADDRESS &

echo $! > "$PHP_PID"

连接远程 FCGI 实例

Fastcgi 实例可被产生于多个远程机器以分散应用程序。

Example #3 连接远程 php-fastcgi 实例

fastcgi.server = ( ".php" =>
   (( "host" => "10.0.0.2", "port" => 1030 ),
    ( "host" => "10.0.0.3", "port" => 1030 ))
)


Unix系统下的LiteSpeed、OpenLiteSpeed服务

LiteSpeed PHP 是一个通过LiteSpeed SAPI方式和LiteSpeed协同工作的PHP优化编译器。LSPHP有自己的进程和独立的二进制包，这样可以让LSPHP能够执行命令行中的命令。

LSAPI是一个高性能的API框架，它能够在LiteSpeed和第三方web服务之间很好的工作。它的原理和FCGI很像，但是它更加高效。

本文档将包含安装和配置PHP的LSAPI，并将LSAPI适用于LiteSpeed服务和OpenLiteSpeed服务。

本文档假定 LSWS 或者 OLS 安装在默认的路径和标记。这两个web服务的默认路径为：/usr/local/lsws，并且都可以从bin子目录下运行。

请注意：本文档中对版本号使用x替代，以确保本文档在将来保持正确，请根据需要替换对应的版本号。

  1. 要获取和安装LiteSpeed服务或者OpenLiteSpeed服务，请访问LiteSpeed wiki » 安装页面 或者 OpenLiteSpeed wiki » 安装页面.

  2. 获取并且解压PHP源码：

    mkdir /home/php
cd /home/php
wget http://us1.php.net/get/php-x.x.x.tar.gz/from/this/mirror
tar -zxvf php-x.x.x.tar.gz
cd php-x.x.x

  3. 配置和生成PHP。这里可以根据需要来定制PHP需要的功能，例如需要开启哪些扩展。执行 ./configure --help 可以获得可用的配置选项。在例子中，我们将使用LiteSpeed服务默认推荐的配置：

    ./configure ... '--with-litespeed'
make
sudo make install

  4. 检查LSPHP是否安装正确

    检查LSPHP是否安装正确的一种最简单的方式是执行下面的命令：

    cd /usr/local/lsws/fcgi-bin/
./lsphp5 -v

    它将会返回新生成的PHP的版本信息：

    PHP 5.6.17 (litespeed) (built: Mar 22 2016 11:34:19)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies

    注意括号中的 litespeed 。 这表名PHP已经支持LSAPI服务。

按照上面的步骤，LiteSpeed / OpenLiteSpeed 已经作为PHP的SAPI扩展来运行。LSWS / OLS 和PHP更多的配置选项，请查看LiteSpeed wiki： » PHP.

从命令行来使用LSPHP：

LSPHP(LSAPI + PHP) 命令行模式常用于远程服务器上不需要一个web服务但是又需要处理PHP程序。它常用于处理常驻在本地服务器的PHP程序（独立的）。这个设置适用于在远程服务器上PHP程序的扩展方式。

从命令行启动一个远程的LSPHP服务： LSPHP 是可执行文件，可以手动启动，通过参数 -b socket地址 来绑定到IPv4，IPv6，或者Unix套接字上。

例如：

LSPHP绑定到所有IPv4和IPv6地址的3000端口：

/path/to/lsphp -b [::]:3000

LSPHP绑定到所有IPv4地址的3000端口：

/path/to/lsphp -b *:3000

LSPHP绑定到IP地址为192.168.0.2的3000端口：

/path/to/lsphp -b 192.168.0.2:3000

LSPHP通过Unix套接字/tmp/lsphp_manual.sock接受请求：

/path/to/lsphp -b /tmp/lsphp_manual.sock

在LSPHP执行前，可以设置环境变量：

PHP_LSAPI_MAX_REQUESTS=500 PHP_LSAPI_CHILDREN=35 /path/to/lsphp -b IP_address:port

目前LiteSpeed PHP可适用于LiteSpeed服务，OpenLiteSpeed服务和Apache mod_lsapi。如果需要服务器端的配置方法，请参考相应的wiki页面： » LiteSpeed Web Server 和 » OpenLiteSpeed.

LSPHP也可以通过其它的方式来安装。

CentOS: 在CentOS系统中，LSPHP可以从LiteSpeed镜像或者Remi镜像中通过» RPM的方式安装。

Debian: 在Debian系统中，LSPHP可以从LiteSpeed镜像中通过» apt的方式安装。

cPanel: 怎样通过cPanel和LSWS/OLS在EasyApache4中安装LSPHP，请参考各自的» wiki page

Plesk: Plesk可以在CentOS，CloudLinux，Debian和Ubuntu上使用LSPHP，想获取更多的信息，请参考对应的» wiki page


CGI 和命令行设置

默认为将 PHP 编译为 CLI 和 CGI 程序。这将建立一个命令行解释器，可用于 CGI 处理或非 web 相关的 PHP 脚本。如果用户运行着一个 PHP 模块支持的 web 服务器，那通常为性能考虑应该使用模块方式。不过 CGI 版可以使 Apache 用户用不同的用户 ID 运行不同的 PHP 页面。

Warning

服务器使用 CGI 方式进行部署可能存在几个公开的缺陷。请阅读 CGI 安全一章 以学习 如何抵御这些攻击。

测试

如果将 PHP 编译为 CGI 程序，可以通过键入 make test 来测试你的编译。测试一下编译永远是个好主意。这样就可以在你的平台上及早捕捉到 PHP 的问题而不是以后再费力的解决。

使用变量

某些服务器提供的环境变量没有定义在当前的 » CGI/1.1 标准中。只有下列变量定义在其中： AUTH_TYPE， CONTENT_LENGTH, CONTENT_TYPE, GATEWAY_INTERFACE, PATH_INFO, PATH_TRANSLATED, QUERY_STRING, REMOTE_ADDR, REMOTE_HOST, REMOTE_IDENT, REMOTE_USER, REQUEST_METHOD, SCRIPT_NAME, SERVER_NAME, SERVER_PORT, SERVER_PROTOCOL 和 SERVER_SOFTWARE。其它的变量均作为"供应商扩展（vendor extensions）"来对待。


针对 HP-UX 平台的安装提示

本节包括在 HP-UX 平台下安装 PHP 的说明和提示。

在 HP-UX 系统下安装 PHP 有两个选择，一是编译，二是安装预编译的可执行包。

官方发布的预编译包可在此地址搜索：» http://software.hp.com/。

在重新编写本节手册之前，在 HP-UX 系统下编译 PHP（以及相关扩展）的文档已被删除。目前请参考此外部文档：» Building Apache and PHP on HP-UX 11.11。


在 OpenBSD 系统下的安装

本章节的内容和提示仅限于将 PHP 安装到 » OpenBSD 3.6 系统上。

使用二进制包安装

使用二进制包安装 PHP 到 OpenBSD 系统上是被推荐的同时也是最简单的方法。PHP 核心包已经从其他模块中分离出来了并且每个模块可以被独立的安装／卸载而不影响其他模块。所有这些安装 PHP 需要的文件可以在 OpenBSD 光盘或者在 FTP 站点上找到。

需要安装的 PHP 核心包的文件是 php4-core-4.3.8.tgz，它包含了基本的引擎（包括 gettext 和 iconv）。其次，可能还需要安装一些模块包，如：php4-mysql-4.3.8.tgz 或 php4-imap-4.3.8.tgz。需要使用命令 phpxs 去激活它，并且再通过修改 php.ini 文件来屏蔽他们。

Example #1 在 OpenBSD 系统下的软件包的安装示例

# pkg_add php4-core-4.3.8.tgz
# /usr/local/sbin/phpxs -s
# cp /usr/local/share/doc/php4/php.ini-recommended /var/www/conf/php.ini
  （加入 mysql 包）
# pkg_add php4-mysql-4.3.8.tgz
# /usr/local/sbin/phpxs -a mysql
  （加入 imap 包）
# pkg_add php4-imap-4.3.8.tgz
# /usr/local/sbin/phpxs -a imap
  （测试一下删除 mysql 包）
# pkg_delete php4-mysql-4.3.8
# /usr/local/sbin/phpxs -r mysql
  （安装 PEAR 库）
# pkg_add php4-pear-4.3.8.tgz

阅读用户手册中的 » packages(7) 部分，可以得到更多 OpenBSD 系统下有关二进制软件包的信息。

使用软件包

同样可以使用» 软件包目录（ports tree）来编译 PHP 的源代码。然而，这样的安装方式仅仅是建议对 OpenBSD 非常熟悉的高级用户去做。PHP4 的软件包被分别分为了两个子目录：core 和 extensions。其中 extensions 目录产生了所有 PHP 所支持的子模块。如果不希望创建并且使用这些模块中的某些模块，请使用 FLAVOR no_* 参数。例如，如果希望跳过编译 imap 模块，设置 FLAVOR 为 no_imap即可。

常见问题

  • 默认安装的 Apache 运行于 » chroot(2) jail 内，将限制 PHP 脚本只能访问 /var/www下面的文件。需要建立 /var/www/tmp 目录来存放 PHP session 文件，或使用其它的 session 后端。此外，数据库套接字需要被放入 jail 或者侦听 localhost接口。如果使用网络函数，某些 /etc 下面的文件例如 /etc/resolv.conf 和 /etc/services 需要被移动到 /var/www/etc 中去。OpenBSD PEAR 包会自动安装到正确的 chroot 目录中，因此不需要作特殊改动。有关 OpenBSD Apache 的更多信息见 OpenBSD FAQ。
  • 对应于 » gd 扩展的 OpenBSD 3.6 包需要预先安装 XFree86。如果不想使用那些需要 X11 的字体特性，则安装 php4-gd-4.3.8-no_x11.tgz 包来替代之。

早期发布版本

早期的 OpenBSD 系统使用 FLAVORS 系统把 PHP 连接为静态模式。自从使用这种方法编译就造成了问题：很难制作二进制软件包。仍然可以使用早期稳定的 ports trees，但这种方式已经不被 OpenBSD 小组所支持。如果对此有任何建议和意见，软件包当前的维护人是 Anil Madhavapeddy（avsm at openbsd dot org）。


针对 Solaris 的安装提示

本节包含了在 Solaris 系统上安装 PHP 的说明和提示。

需要的软件

默认安装的 Solaris 系统经常缺少 C 语言编译器和其相关工具。部分工具必须使用该工具的 GNU 版本，原因请阅读 FAQ。

要解压缩 PHP 发行包，需要：

  • tar
  • gzip 或
  • bzip2

要编译 PHP，需要：

  • gcc（推荐使用，其它 C 编译器也许也能用）
  • make
  • GNU sed

要编译更多扩展库或自行开发 PHP 代码，可能还需要：

  • flex（直到 PHP 5.2）
  • re2c
  • bison
  • m4
  • autoconf
  • automake
此外，还需要安装（甚至编译）针对自己的配置所需的软件，例如 Oracle 或 MySQL。

使用软件包

可以使用 pkgadd 来安装大部分需要的软件来简化 Solaris 安装过程。Solaris 11 Express 下的映像打包系统（Image Packaging System，IPS）也包含了大多数安装所需的部件，通过 pkg 命令。


Debian GNU/Linux 安装说明

本节包含了在 » Debian GNU/Linux 下安装 PHP 的说明和提示。

Warning

这里不支持非官方的第三方发行包。任何错误应报告给 Debian 开发组，除非该错误在使用从官方» 下载的最新版时仍能重现。

尽管在 Unix 下编译 PHP 的指示也适用于 Debian，本节包含有一些特定信息，例如使用 apt-get 或者 aptitude 命令。本节中这两条命令可以互换。

使用 APT

首先，注意其它有关的包可能需要 libapache2-mod-php5 集成入 Apache 2，以及 PEAR 的 php-pear。

其次，在安装一个包之前，最好先确定该包是最新版。通常可以运行命令 apt-get update。

Example #1 Debian 下将 PHP 安装入 Apache 2 的例子

# apt-get install php5-common libapache2-mod-php5 php5-cli

APT 将自动安装 Apache 2 的 PHP 5 模块以及所有依赖的库并激活之。应重启动 Apache 以使更改生效，例如：

Example #2 安装完 PHP 后停止并启动 Apache

# /etc/init.d/apache2 stop
# /etc/init.d/apache2 start

更好地控制配置

上一节中 PHP 仅安装了核心模块。很可能还需要更多模块，例如 MySQL，cURL，GD 等。这些模块也可以通过 apt-get 命令安装。

Example #3 取得 PHP 附加软件包的列表

# apt-cache search php5
# aptitude search php5
# aptitude search php5 |grep -i mysql

以上命令的输出中列出了很多的包，其中有几个针对 PHP 的模块例如 php5-cgi，php5-cli 以及 php5-dev。决定好要安装哪些之后可以用 apt-get 或者 aptitude 来安装。Debian 会进行倚赖性检查，会给出提示，例如安装 MySQL 和 cURL：

Example #4 安装 PHP 的 MySQL 和 cURL 支持

# apt-get install php5-mysql php5-curl

APT 会自动把适当的行添加到不同的 php.ini 相关文件中去，例如 /etc/php5/apache2/php.ini，/etc/php5/conf.d/pdo.ini 等，并且根据扩展，还会添加类似 extension=foo.so 的内容。不过还是需要重新启动 web 服务器（例如 Apache）以使这些改动生效。

常见问题

  • 如果 PHP 脚本没有通过 web 服务器被解析，则有可能是 PHP 没有被加入到 web 服务器的配置文件中，在 Debian 中可能是 /etc/apache2/apache2.conf 或类似文件。具体内容参见 Debian 手册。
  • 如果某扩展貌似已经安装，但其函数却又未定义，确保合适的 ini 文件已被加载并且 web 服务器在安装后重新启动过。
  • 在 Debian（以及其它 Linux 变种）下有两个基本命令来安装包：apt-get 和 aptitude。不过要解释这两个命令的细微区别已超出本手册范围。


Mac OS X 系统下的安装

Table of Contents

  • 使用软件包
  • 使用内置的 PHP
  • 在 macOS 下编译 PHP

本章包括在 Mac OS X 平台下安装 PHP 的说明和提示。Mac OS X有内建支持的 PHP，编译安装类似于 Unix 系统下的安装。


使用软件包

Mac OS X 下有几个预编译和打包的 PHP 版本。可以通过它使用标准的配置的 PHP，但是若需要不同的功能集（比如一个安全服务器，或者一个不同的数据库驱动程序），可能需要自己编译 PHP 和／或 web 服务器。如果不熟悉如何自己编译软件，可以试着找一下包含自己所需功能的 PHP 预编译版本。

下面的资源提供了在 Mac OS 上易于安装的软件包和预编译的二进制 PHP。

  • MacPorts: » http://www.macports.org/
  • Liip: » http://php-osx.liip.ch/
  • Fink: » http://www.finkproject.org/
  • Homebrew: » https://github.com/Homebrew/brew


使用内置的 PHP

从 OS X 10.0.0 版本开始，PHP 作为 Mac 机的标准配置被提供。在默认的 web 服务器中启用 PHP，只需将 Apache 配置文件 httpd.conf 中的几行配置指令最前面的注释符号去掉，而 CGI 或 CLI 默认都可使用（可以很容易的被终端程序使用）。

按照以下的使用说明，可以快速的建立一个本地 PHP 开发环境。强烈建议将 PHP 升级到最新的版本。在大多数活跃的软件中， 新的版本会修复错误和添加新的功能，PHP 也是如此。请参见相应的 Mac OS X 安装文档，以进一步了解详细的信息。以下的说明以初学者的角度来详细描述如何操作来得到一个缺省的运行环境。建议所有的用户都编译或者安装一个新的打包版本。

标准的安装类型为 mod_php，在 Mac OS X 的 Apache web 服务器（默认 web 服务器，可以从系统设置中访问）中启用 PHP 包含以下的步骤：

  1. 找到并打开Apache的配置文件。默认情况下，这个配置文件的位置是： /private/etc/apache2/httpd.conf。 使用 Finder 或者 Spotlight 来找到这个文件可能不是很容易的事情，因为在默认情况下它一般是 root 用户拥有所有权的私有文件。

    Note: 要打开这个文件，可以在命令行下面使用基于 Unix 的文本编辑器，例如 nano，因为他的属主是 root，所以我们需要使用 sudo 来打开（以 root 用户权限）。例如我们在 Terminal 程序中敲入下面的指令（操作后，会提示输入密码）：sudo nano /private/etc/apache2/httpd.conf 注意 nano 中的命令：^w（搜索），^o（保存），以及 ^x（退出）。^ 表示 Ctrl 键。

    Note: 在Mac OS X 10.5之前的版本中捆绑的是旧版本的 PHP 和 Apache。因此在旧的计算机中 Apache 配置文件的位置可能是 /etc/httpd/httpd.conf。

  2. 使用文本的编辑器取消注释（删除前面的 #）看起来类似于下面的行（这两行常常不在一起，需要在文件中找到这两行）：

    # LoadModule php5_module libexec/httpd/libphp5.so

# AddModule mod_php5.c
    注意位置／路径。如果在以后重新编译了 PHP，以上文件应被更换或者注释掉。

  3. 确保将所需要的文件扩展名解析为 PHP（例如：.php .html 以及 .inc），否则不能正常运行。

    由于以下的配置已经写入 httpd.conf（自 Mac Panther 版起），一旦 PHP 被启用则 .php 文件会被自动解析为 PHP 脚本。

    <IfModule mod_php5.c>
    # If php is turned on, we respect .php and .phps files.
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

    # Since most users will want index.php to work we
    # also automatically enable index.php
    <IfModule mod_dir.c>
        DirectoryIndex index.html index.php
    </IfModule>
</IfModule>

    Note:

    在 OS X 10.5（Leopard）以前版本中，捆绑的是 PHP 4 而不是 PHP 5，因此上面的配置指令稍有不同，需要将 5 更改为 4。

  4. 确保 DirectoryIndex 加载了所需的默认索引文件。 这个也是在 httpd.conf 中设置的。 通常情况下使用 index.php 和 index.html 。默认情况下 index.php 会被启用，因为在我们上面的配置指令中写明了。根据实际情况可以做相应的调整。
  5. 设置 php.ini 的位置或者使用默认的位置。 Mac OS X 上通常默认的位置是 /usr/local/php/php.ini ，调用 phpinfo() 也可以得到此信息。如果没有使用 php.ini，PHP 将使用所有的默认值。参见常见问题中的寻找 php.ini。
  6. 定位或者设置 DocumentRoot。 这是网站所有文件的根目录。此目录中的文件由 web 服务器提供服务，从而使得 PHP 文件将在输出到浏览器之前解析为 PHP 脚本。通常情况下默认的路径是 /Library/WebServer/Documents，但是可以根据需要在 httpd.conf中设置为任何其他目录。另外，用户自己的缺省 DocumentRoot 是 /Users/yourusername/Sites。
  7. 创建一个 phpinfo() 文件。

    phpinfo() 将会显示PHP的相关系统信息。可以在 DocumentRoot 下创建一个 PHP 文件，其代码如下：

    <?php phpinfo(); ?>

  8. 重启 Apache，然后从浏览器访问上面创建的文件。

    要重启Apache，可以在 shell 中执行 sudo apachectl graceful，也可以停止/启动 OS X 系统首选项中的"Personal Web Server"选项。默认情况下，从浏览器访问本地文件的 URL 一般类似于：http://localhost/info.php，或者使用：http://localhost/~yourusername/info.php 来访问用户自己 DocumentRoot 中的文件。

CLI（或者旧版本中的 CGI）一般文件名为 php ，其路径可能是 /usr/bin/php。打开一个终端，参考 PHP 手册中的 PHP 的命令行模式一章，然后执行 php -v 可以检查当前运行的 PHP 的版本。调用 phpinfo() 也会显示相关的信息。


  • ? 使用内置的 PHP
  • Windows 系统下的安装 ?
  • PHP Manual
  • Mac OS X 系统下的安装
  • 在 macOS 下编译 PHP

在 macOS 下编译 PHP

参考 Unix 系统下的安装以在 macOS下编译 PHP。


Windows 系统下的安装

Table of Contents

  • 环境要求
  • PECL
  • Windows 下的 PHP 安装程序工具
  • Windows 系统下的推荐配置
  • 在 Windows 上手动安装 PHP
  • Windows 下 PHP 故障排除
  • 旧版本 Windows 支持

在微软 Windows 系统上安装 PHP，并推荐使用常见的 Web 服务器进行配置。

Note:

如果您正在寻找有关旧系统的信息，如 Windows XP、2003、98 或 Apache 1.x，请参阅 旧版本 Windows 支持 章节。

PHP 在 Windows 上的官方版本被推荐用于生产环境。如果有需要，你也可以从源码中构建 PHP。你需要一个 Visual Studio 环境。请参阅 » 从源码构建 章节。

  • 在 Windows 命令行使用 PHP

  • 在 Azure 上安装 PHP 服务 (又称 Microsoft Azure、Windows Azure 或 (Windows) Azure Web Apps)。


环境要求

PHP 5.5+ 至少需要 Windows 2008/Vista，或 2008r2、2012、2012r2、2016 或 7、8、8.1、10。32 位或 64 位（也就是 X86 或 X64。PHP 不能在 Windows RT/WOA/ARM上运行）。

PHP 需要 Visual C 运行时（CRT）。许多应用程序需要它，所以它可能已经被安装。

PHP 5.5 和 5.6 需要 VC CRT 11（Visual Studio 2012）。请参阅 » https://www.microsoft.com/en-us/download/details.aspx?id=30679

PHP 7.0 和 7.1 需要 VC CRT 14（Visual Studio 2015）。 PHP 7.2, 7.3 and 7.4 需要 VC CRT 15 (Visual Studio 2017)。 微软的开发环境 Visual Studio 2019 包含了编译 PHP 的全部环境要求，请参阅 » https://visualstudio.microsoft.com/downloads/。

你需要下载 x86 版本的 CRT 来编译 x86 版本的 PHP。同理，编译 x64 版本的 PHP 需要 x64 版本的 CRT。

如果系统已经安装了 CRT，安装程序会提示你，而不会改变任何东西。

CRT 安装程序支持 /quiet 和 /norestart 命令行开关，所以你可以用脚本运行它。

VC11 CRT DLLs 可以从您的本地机器复制到远程机器（"复制部署" 安装），而不是在远程机器上运行安装程序（例如您有限制访问的 Web 服务器）。参见：http://www.sitepoint.com/install-php53-windows/

VC14 CRT 不支持 "复制部署" 安装。VC14 CRT 有更多的 DLL (大部分以 api-* 开头的文件中)。如果你能找到它们并复制它们，它也会工作（尝试使用 "Resource Hacker" 这样的工具来获得所有要复制的 DLL 的列表）。


PECL

PECL 扩展在 Windows 版本中是预编译的，可从以下网站获得 » http://windows.php.net/downloads/pecl/releases/

某些扩展使用了某些 Unix 系统所特有的功能，因此在 Windows 上不可用。除此之外，所有的扩展都可以在 Windows 上使用。


Windows 下的 PHP 安装程序工具

PHP 安装工具

如果你想安装PHP，一些常见的PHP应用程序，使用的是IIS，最简单的方式是使用微软的 Web 平台安装程序（WebPI）。

Windows 下使用 Apache 安装 PHP 应用程序：XAMPP、WampServer 和 BitNami。


Windows 系统下的推荐配置

OpCache

强烈建议开启 OpCache。此扩展默认已经包含到 PHP Windows 版本中。它会自动编译和优化 PHP 脚本，并将它们缓存在内存中，这样就不会在每次加载页面时动态编译它们。

在 php.ini 配置中，设置

Example #1 推荐的 OpCache 配置

zend_extension=php_opcache.dll
opcache.enable=On
opcache.enable_cli=On
然后重新启动你的 WEB 服务器。更多信息，请参阅：OpCache 配置 章节。

WinCache

WinCache 推荐在 IIS 下使用，尤其是在共享虚拟主机环境中或使用网络文件存储（NAS）时。所有 PHP 应用程序都会自动受益于 WinCache 的文件缓存功能。文件系统操作被缓存在内存中。 WinCache 还可以缓存内存中的用户对象，并在 php.exe 或 php-cgi.exe 进程之间共享它们（在请求之间共享对象）。许多主流的 Web应用程序都有一个插件或扩展或配置选项来使用 WinCache 用户对象缓存。如果你需要高性能，你应该在你的应用程序中使用对象缓存。请参阅：» http://pecl.php.net/package/WinCache to download a WinCache DLL (or tgz) to your PHP extensions directory (extensions_dir in your php.ini)。 在 php.ini 配置中，设置

Example #2 推荐的 WinCache 配置

extension=php_wincache.dll
wincache.fcenabled=1
wincache.ocenabled=1 ; removed as of wincache 2.0.0.0
更多信息，请参阅：» http://php.net/manual/en/wincache.configuration.php

IIS 配置

在 IIS 管理器中，安装 FastCGI 模块，并将 `.php` 后缀映射到 PHP-CGI.exe 文件的真实路径 (注意：不是 PHP.exe)

你可以使用 APPCMD 命令行工具来编写 IIS 配置脚本。

数据库

如果你需要一个数据库服务器，PHP 提供了对应的扩展来使用它们。如果你的网站没有太多的流量，你可以将数据库服务器与你的 Web 服务器运行在同一台服务器上。世面上流行的数据库，基本都会提供运行在 Windows 上的版本。

PHP 内置了 mysqli 和 pdo_mysql 扩展。PHP 5.5 和 5.6 内置了 mysql 扩展(7.0 版本中被废弃)。

参见 » https://dev.mysql.com/downloads/windows/


在 Windows 上手动安装 PHP

选择 Web 服务器

IIS

IIS 是 Windows 内置的服务。在 Windows 服务器版本上，请使用服务器管理（Server Manager）来添加 IIS 规则。同时需要设置 CGI 角色规则。在 Windows 桌面版本上，需要使用控制面板中的 "添加/删除程序" 功能来添加 IIS。请参阅微软的官方文档的 » 详细说明。 对于桌面 web app 开发者，你也可以选择 IIS/Express 或 PHP Desktop。

Example #1 命令行下配置 IIS 和 PHP

@echo off

REM download .ZIP file of PHP build from http://windows.php.net/downloads/

REM path to directory you decompressed PHP .ZIP file into (no trailing \)
set phppath=c:\php

REM Clear current PHP handlers
%windir%\system32\inetsrv\appcmd clear config /section:system.webServer/fastCGI
REM The following command will generate an error message if PHP is not installed. This can be ignored.
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /-[name='PHP_via_FastCGI']

REM Set up the PHP handler
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/fastCGI /+[fullPath='%phppath%\php-cgi.exe']
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /+[name='PHP_via_FastCGI',path='*.php',verb='*',modules='FastCgiModule',scriptProcessor='%phppath%\php-cgi.exe',resourceType='Unspecified']
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /accessPolicy:Read,Script

REM Configure FastCGI Variables
%windir%\system32\inetsrv\appcmd set config -section:system.webServer/fastCgi /[fullPath='%phppath%\php-cgi.exe'].instanceMaxRequests:10000
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi /+"[fullPath='%phppath%\php-cgi.exe'].environmentVariables.[name='PHP_FCGI_MAX_REQUESTS',value='10000']"
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi /+"[fullPath='%phppath%\php-cgi.exe'].environmentVariables.[name='PHPRC',value='%phppath%\php.ini']"
请参阅：旧版本的 IIS 配置。

Apache

There are several builds of Apache2 for Windows. The Apache builds of ApacheLounge are recommended, but other options include XAMPP, WampServer and BitNami, which provide automatic installer tools. PHP can be used on Apache through mod_php or mod_fastcgi. mod_php requires a TS build of Apache built with same version of Visual C and same CPU (x86 or x64). 请参阅：旧版本的 Apache 配置。

选择编译版本

从 Windows 专用站点下载适合产品环境使用的 PHP 预编译版本： » http://windows.php.net/download/。All builds are optimized (PGO), and QA and GA releases are thoroughly tested.

There are 4 types of PHP builds:

  • Thread-Safe(TS) - use for single process web servers, like Apache with mod_php

  • Non-Thread-Safe(NTS) - use for IIS and other FastCGI web servers (Apache with mod_fastcgi) and recommended for command-line scripts

  • x86 - production use of PHP 5.5 or 5.6 or 7.0.

  • x64 - production use of PHP 7.0+ unless its a 32-bit only version of Windows. 5.5 and 5.6 x64 are experimental.


Windows 下 PHP 故障排除

检查临时目录权限

  1. 在"文件管理器"中右键单击"临时目录"以获得权限。

  2. IIS, 检查用户的 IIS_User 是否有修改文件的权限。可以从配置或 php info 中获取临时目录的位置。


旧版本 Windows 支持

本节适用于 Windows 98/Me 和 Windows NT/2000/XP/2003。PHP 不能在 16 位平台上工作，如 Windows 3.1，有时我们将支持的 Windows 平台为 Win32。

Note:

从 PHP 5.5.0 开始不再支持 Windows XP/2003。

Note:

从 PHP 5.3.0 开始，不再支持 Windows 98/Me/NT4/2000。

Note:

从 PHP 4.3.0 开始不再支持 Windows 95。

如果你有微软 Visual Studio 这样的开发环境，你也可以从原始源码中构建 PHP。

在 Windows 系统上安装 PHP 后，如果还想加载各种扩展来增加功能，请参考 这里。

手工安装步骤

本章包含有在 Microsoft Windows 中手工安装和配置 PHP 的指示。

选择和下载 PHP 发行包

从 » PHP for Windows: Binaries and Sources 页面下载 PHP 的 zip 二进制发行包。有几个不同版本，根据所用 web 服务器选择合适的版本： 参见 » 下载页 中的指南。

PHP 压缩包的结构和内容

将 zip 包解压缩到自己选择的目录，例如 C:\PHP\。此目录和文件结构类似于：

Example #1 PHP 5 压缩包的结构

c:\php
   |
   +--dev
   |  |
   |  |-php5ts.lib                 -- php5.lib 的非线程安全版本
   |
   +--ext                          -- PHP 扩展库的 DLL 文件目录
   |  |
   |  |-php_bz2.dll
   |  |
   |  |-php_cpdf.dll
   |  |
   |  |-...
   |
   +--extras                       -- 空
   |
   +--pear                         -- PEAR 的初始版本
   |
   |
   |-go-pear.bat                   -- PEAR 安装脚本
   |
   |-...
   |
   |-php-cgi.exe                   -- CGI 可执行文件
   |
   |-php-win.exe                   -- 无窗口执行脚本的可执行文件
   |
   |-php.exe                       -- PHP 命令行可执行文件（CLI）
   |
   |-...
   |
   |-php.ini-development           -- 默认的 php.ini 设置
   |
   |-php.ini-production            -- 推荐的 php.ini 设置
   |
   |-php5apache2_2.dll             -- 非线程安全版本中无此文件
   |
   |-php5apache2_2_filter.dll      -- 非线程安全版本中无此文件
   |
   |-...
   |
   |-php5ts.dll                    -- PHP 核心 DLL（php5.dll 的非线程安全版本）
   |
   |-...

以下是 PHP zip 包中包含的模块和可执行文件列表：

  • go-pear.bat - PEAR 安装脚本。更多内容参见» 安装 PEAR。

  • php-cgi.exe - CGI 可执行文件，可用于 IIS 上以 CGI 或者 FastCGI 方式运行 PHP。

  • php-win.exe - PHP 可执行文件，可运行 PHP 脚本而不打开命令行窗口（例如使用 Windows 图形界面的 PHP 程序）。

  • php.exe - PHP 可执行文件，用于命令行界面运行 PHP 脚本（CLI）。

  • php5apache2_2.dll - Apache 2.2.X 模块。

  • php5apache2_2_filter.dll - Apache 2.2.X 过滤器。

修改 php.ini 文件

解压缩 PHP 的包之后，将 php.ini-production 拷贝为 同一目录下的 php.ini。如有必要，也可以将 php.ini 放到其它地方，但是需要更多配置步骤，具体见配置文件。

php.ini 文件决定 PHP 如何配置自身以及如何在其工作环境下运行。以下 php.ini 文件中的配置指令有助于使 PHP 更好地运行于 Windows 之中。有一些是可选项。还有很多其它指令也可能与用户环境有关，更多信息见 php.ini 配置选项列表。

必须的指令：

  • extension_dir = <指向扩展库目录的路径> - extension_dir 需要指向存放 PHP 扩展库文件的目录。可以是绝对路径（如 "C:\PHP\ext"）或相对路径（如 ".\ext"）。在 php.ini 文件中要加载的扩展库都必须在 extension_dir 所指定的目录之中。

  • extension = xxxxx.dll - 对每个需要激活的扩展，都需要一行相应的 "extension=" 语句来说明 PHP 启动时加载 extension_dir 目录下的哪些扩展。

  • log_errors = On - PHP 有错误日志的功能可以将错误报告发送到一个文件中，或者系统服务中（例如系统日志），与下面的 error_log 指令配合工作。在 IIS 下运行时，log_errors 应被激活，并且配合有效的 error_log。

  • error_log = <指向错误日志文件的路径> - error_log 需要指向一个具有绝对或相对路径的文件名用于记录 PHP 的错误日志。Web 服务器需要对此文件有可写权限。最常用的位置是各种临时目录，例如 "C:\inetpub\temp\php-errors.log"。

  • cgi.force_redirect = 0 - 在 IIS 下运行时需要关闭此项指令。这是个在许多其它 web 服务器中都需要激活的目录安全功能，但是在 IIS 下如果激活则会导致 PHP 引擎在 Windows 中出错。

  • cgi.fix_pathinfo = 1 - 此指令可以允许 PHP 遵从 CGI 规则访问真实路径信息。IIS 的 FastCGI 实现需要激活此指令。

  • fastcgi.impersonate = 1 - IIS 下的 FastCGI 支持模拟呼叫用户方安全令牌的能力。这使得 IIS 可以定义请求方的安全上下文。

  • fastcgi.logging = 0 - FastCGI 日志在 IIS 下应被关闭。如果激活，则任何类的任何消息都被 FastCGI 视为错误条件从而导致 IIS 产生 HTTP 500 错误。

可选指令：

  • max_execution_time = ## - 此指令设定任何脚本所能够运行的最长时间。默认值是 30 秒。如果 PHP 程序需要更多时间运行则增大此值。

  • memory_limit = ###M - PHP 进程能够占用的内存，单位为兆字节。默认值是 128M，对大多数程序都够用了。某些复杂程序可能需要更多。

  • display_errors = Off - 此指令设定 PHP 是否将任何错误信息包含在返回给 web 服务器的数据流中。如果设定为 "On"，则 PHP 将任何由 error_reporting 指令所定义的错误信息作为错误数据流发给 web 服务器。为安全起见，建议对在线服务器设为 "Off" 以避免泄露任何可能包含在错误消息中的安全敏感信息。

  • open_basedir = <指向目录的路径，由分号分隔> - 例如 openbasedir="C:\inetpub\wwwroot;C:\inetpub\temp"。此指令指定了允许 PHP 进行文件系统操作的目录。任何对这些目录之外的文件操作都会导致错误。此指令在共享主机环境中特别有用，可以阻止 PHP 脚本访问任何其网站根目录之外的文件。

  • upload_max_filesize = ###M 和 post_max_size = ###M - 分别是上传文件的最大大小和 POST 方法提交数据的最大大小。如果 PHP 程序需要上传大型数据例如照片和视频文件，则应提高这两项的值。

至此已在系统中安装了 PHP。下一步是选择一种 web 服务器并且使其能够运行 PHP。在目录中选择 web 服务器。

除了可在 web 服务器中运行 PHP 之外，PHP 还可以在命令行运行，如同 .BAT 批处理脚本一样。详见 Windows 下的 PHP 命令行方式。

Microsoft IIS

本部分将具体指导如何在微软 Internet 信息服务（IIS）上安装 PHP。

  • 在 IIS 5.1 和 IIS 6.0 上手工安装 PHP
  • 在 IIS 7.0 及更高版本上手工安装 PHP

Microsoft IIS 5.1 和 IIS 6.0

本章包含有在 Windows XP 和 Windows Server 2003 下的 Internet 信息服务（IIS）5.1 和 IIS 6.0 中安装 PHP 的指南。有关在 Windows Vista，Windows Server 2008，Windows 7 以及 Windows Server 2008 R2 下的 IIS 7.0 以及更高版本中安装 PHP 的指南见 Microsoft IIS 7.0 及更高版本一章。

配置 IIS 以处理 PHP 请求

根据手工安装步骤的说明下载和安装 PHP。

Note:

在使用 IIS 时推荐使用非线程安全的 PHP。可以在 » PHP for Windows: Binaries and Sources Releases 下载。

按以下示例在 php.ini 文件中配置 针对 CGI- 和 FastCGI- 的指令：

Example #2 php.ini 中的 CGI 和 FastCGI 设定

fastcgi.impersonate = 1
fastcgi.logging = 0
cgi.fix_pathinfo=1
cgi.force_redirect = 0

下载并安装 » FastCGI for IIS。有 32 位和 64 位平台的，根据用户平台选择相应的下载。

用以下命令配置 FastCGI 扩展处理 PHP 请求。用指向 php-cgi.exe 文件的绝对路径替换其中的 "-path" 的参数。

Example #3 配置 FastCGI 扩展以处理 PHP 请求

cscript %windir%\system32\inetsrv\fcgiconfig.js -add -section:"PHP" ^
-extension:php -path:"C:\PHP\php-cgi.exe"

此命令将创建对应于 *.php 文件后缀的 IIS 脚本映射，则所有以 *.php 结尾的 URL 都会被 FastCGI 扩展处理。此外还配置了 FastCGI 扩展使用 php-cgi.exe 可执行文件来处理 PHP 请求。

Note:

至此所需的安装和配置步骤就完成了。以下剩余的指示是可选项，但是强烈推荐以使得在 IIS 上达到最佳的 PHP 功能和性能。

角色扮演及文件系统访问

在 IIS 中使用 PHP 建议激活 FastCGI 的角色扮演功能。此功能在 php.ini 中由 fastcgi.impersonate 指令控制。激活角色扮演后，PHP 将以 IIS 所认证的用户帐号身份进行所有的文件系统操作。这将确保即使在（同一个主机）不同的 IIS 网站下使用了同一个 PHP 进程，只要每个网站使用了不同的用户帐号作为 IIS 身份认证，则这些网站的 PHP 脚本将不能访问彼此的文件。

例如在 IIS 5.1 和 IIS 6.0 中，默认配置下的匿名认证将使用内置的用户帐号 IUSR_<MACHINE_NAME> 作为默认身份。这意味着要使得 IIS 能够运行 PHP 脚本，至少要将这些脚本的读取权限授予 IUSR_<MACHINE_NAME> 帐号。如果 PHP 程序需要对某些文件或文件夹进行写入操作，那 IUSR_<MACHINE_NAME> 帐号也需要有相对应的写入权限。

要查看哪个用户帐号被用作 IIS 匿名认证的身份，使用以下步骤：

  1. 在 Windows 开始菜单中选择"运行..."，输入"inetmgr"并点击"确定"；

  2. 在树形视图下展开"网站"节点，右键点击要使用的网站并选择"属性"；

  3. 点击"目录安全"面板；

  4. 记录下在"认证方式"对话框中的"用户名"字段。

IIS 5.1 和 IIS 6.0 的匿名认证

要修改文件及文件夹的权限，使用 Windows 资源管理器或者 icacls 命令行。

Example #4 配置文件访问权限

icacls C:\inetpub\wwwroot\upload /grant IUSR:(OI)(CI)(M)

在 IIS 中把 index.php 设定为默认文档

IIS 的默认文档用于没有指定文件名的 HTTP 请求。对于 PHP 应用来说默认文档通常为 index.php。要将 index.php 添加到 IIS 的默认文档列表中，使用以下步骤：

  1. 在 Windows 开始菜单中选择"运行..."，输入"inetmgr"并点击"确定"；

  2. 在树形视图下展开"网站"节点，右键点击要使用的网站并选择"属性"；

  3. 点击"文档"面板；

  4. 点击"添加..."按钮并在"默认内容页面"中输入"index.php"。

将 index.php 设为 IIS 的默认文档

FastCGI 和 PHP 回收配置

用以下命令配置 IIS FastCGI 对于 PHP 进程的回收设定。FastCGI 的设置 instanceMaxRequests 控制了单一的 php-cgi.exe 进程处理多少个请求之后会被 IIS 关闭。PHP 环境变量 PHP_FCGI_MAX_REQUESTS 控制了一个 php-cgi.exe 进程处理多少个请求之后会被自我回收。要确保 FastCGI 中 InstanceMaxRequests 的值小于或等于 PHP_FCGI_MAX_REQUESTS 的值。

Example #5 配置 FastCGI 和 PHP 的回收

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-InstanceMaxRequests:10000

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-EnvironmentVars:PHP_FCGI_MAX_REQUESTS:10000

FastCGI 超时设定

如果会有一些需时较长的 PHP 脚本运行，则增加超时的设定值。有两个控制超时的指令 activityTimeout 和 requestTimeout。有关这些设定的更多信息参见 » Configuring FastCGI Extension for IIS 6.0。

Example #6 配置 FastCGI 超时设定

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-ActivityTimeout:90

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-RequestTimeout:90

改变 php.ini 文件的位置

PHP 在几个位置搜索配置文件 php.ini，可以通过环境变量 PHPRC 来改变 php.ini 的默认位置。要使得 PHP 从用户指定的位置加载配置文件，使用以下命令。指向 php.ini 文件的绝对路径应作为环境变量 PHPRC 的值。

Example #7 改变 php.ini 文件的位置

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-EnvironmentVars:PHPRC:"C:\Some\Directory\"

Microsoft IIS 7.0 及更高版本

本章包含有在 Windows Vista SP1，Windows 7，Windows Server 2008 以及 Windows Server 2008 R2下的 IIS 7.0 以及更高版本中手工安装 PHP 的指南。有关在 Windows XP 和 Windows Server 2003 下的 IIS 5.1 和 IIS 6.0 中安装 PHP 的指南见 Microsoft IIS 5.1 和 IIS 6.0 一章。

在 IIS 中激活 FastCGI 支持

默认安装的 IIS 中 FastCGI 模块被关闭。要激活其的步骤在不同版本的 Windows 下不同。

要在 Windows Vista SP1 和 Windows 7 中激活 FastCGI 支持：

  1. 在 Windows 开始菜单中选择"运行..."（或在搜索框内），输入"optionalfeatures.exe"并按"确定"（或敲回车键）；

  2. 在"Windows 功能"对话框中展开"Internet 信息服务"，"万维网服务"，"应用程序开发功能"，并选中"CGI"的选择框；

  3. 点击确定按钮并等待安装完成。

在 Windows Vista SP1 和 Windows 7 中激活 FastCGI 支持

要在 Windows Server 2008 和 Windows Server 2008 R2 中激活 FastCGI 支持：

  1. 在 Windows 开始菜单中选择 "Run:"，输入 "CompMgmtLauncher" 并点击 "Ok"；

  2. 如果在 "Roles" 节点下没有 "Web Server (IIS)" role，则点击 "Add Roles" 添加之；

  3. 如果存在 "Web Server (IIS)" role，则点击 "Add Role Services" 并激活 "Application Development" 组之下的 "CGI" 选择框；

  4. 点击 "Next" 及 "Install"，等待安装完成。

在 Windows Server 2008 和 Windows Server 2008 R2 中激活 FastCGI 支持

配置 IIS 以处理 PHP 请求

根据 手工安装步骤 的说明下载和安装 PHP。

Note:

在使用 IIS 时推荐使用非线程安全的 PHP。可以在 » PHP for Windows: Binaries and Sources Releases 下载。

按以下示例在 php.ini 文件中配置 针对 CGI- 和 FastCGI- 的指令：

Example #8 php.ini 中的 CGI 和 FastCGI 设定

fastcgi.impersonate = 1
fastcgi.logging = 0
cgi.fix_pathinfo=1
cgi.force_redirect = 0

通过 IIS 管理界面或者命令行工具配置对应于 PHP 的 IIS 程序映射。

使用 IIS 管理界面来创建 PHP 的程序映射

按照以下步骤在 IIS 管理界面中创建 PHP 的程序映射：

  1. 在 Windows 开始菜单中选择"运行..."，输入"inetmgr"并点击"确定"；

  2. 在 IIS 管理器中左边面板"连接"下面的树状图中选择该服务器的节点；

  3. 在中间面板下方的"功能视图"页面打开"处理程序映射"功能；

    创建 PHP 的程序映射：处理程序映射的位置

  4. 在右边"操作"面板中点击"添加模块映射..."；

  5. 在"添加模块映射"对话框中输入以下内容：

    • 请求路径(P)：*.php
    • 模块(M)：FastCgiModule
    • 可执行文件(可选)(E)：C:\[Path to PHP installation]\php-cgi.exe
    • 名称(N)：PHP_via_FastCGI

  6. 点击"请求限制(R)..."按钮并选中"仅当请求映射至以下内容时才调用处理程序(I)："然后选择"文件或文件夹(O)"；

  7. 在所有对话框中点击确定以保存配置。

创建 PHP 的程序映射：添加程序映射

使用命令行工具创建 PHP 的程序映射

用以下命令创建一个 IIS FastCGI 处理池以使 php-cgi.exe 可执行文件来处理 PHP 请求。用自己系统上指向 php-cgi.exe 文件的绝对路径来替代 fullPath 参数的值。

Example #9 创建 IIS FastCGI 处理池

%windir%\system32\inetsrv\appcmd set config /section:system.webServer/fastCGI ^
/+[fullPath='c:\PHP\php-cgi.exe']

用以下命令配置 IIS 处理针对 PHP 的请求。用自己系统上指向 php-cgi.exe 文件的绝对路径来替代 scriptProcessor 参数的值。

Example #10 创建对应于 PHP 请求的处理程序映射

%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers ^
/+[name='PHP_via_FastCGI', path='*.php',verb='*',modules='FastCgiModule',^
scriptProcessor='c:\PHP\php-cgi.exe',resourceType='Either']

此命令创建了一个对于 *.php 文件后缀的处理程序映射，使得所有以 .php 结尾的 URL 都会被 FastCGI 模块处理。

Note:

至此所需的安装和配置步骤就完成了。以下剩余的指示是可选项，但是强烈推荐以使得在 IIS 上达到最佳的 PHP 功能和性能。

角色扮演及文件系统访问

在 IIS 中使用 PHP 建议激活 FastCGI 的角色扮演功能。此功能在 php.ini 中由 fastcgi.impersonate 指令控制。激活角色扮演后，PHP 将以 IIS 所认证的用户帐号身份进行所有的文件系统操作。这将确保即使在（同一个主机）不同的 IIS 网站下使用了同一个 PHP 进程，只要每个网站使用了不同的用户帐号作为 IIS 身份认证，则这些网站的 PHP 脚本将不能访问彼此的文件。

例如在 IIS 7 中，默认配置下的匿名认证将使用内置的用户帐号 IUSR 作为默认身份。这意味着要使得 IIS 能够运行 PHP 脚本，至少要将这些脚本的读取权限授予 IUSR 帐号。如果 PHP 程序需要对某些文件或文件夹进行写入操作，那 IUSER 帐号也需要有相对应的写入权限。

在 IIS 7 中要查看哪个用户帐号被用作匿名认证的身份，使用以下命令。将其中的 "Default Web Site" 替换为自己使用的网站名。在输出的 XML 配置单元中查找 userName 属性。（注意：要以管理员身份运行此命令行）

Example #11 确定用于 IIS 匿名认证的用户帐号

%windir%\system32\inetsrv\appcmd.exe list config "Default Web Site" ^
/section:anonymousAuthentication

<system.webServer>
  <security>
    <authentication>
      <anonymousAuthentication enabled="true" userName="IUSR" />
    </authentication>
   </security>
</system.webServer>

Note:

如果在 anonymousAuthentication 单元中没有显示 userName 属性，或者其值为一个空字符串，那意味着应用程序池的身份被用于该网站的匿名身份。

要修改文件及文件夹的权限，使用 Windows 资源管理器或者 icacls 命令行。

Example #12 配置文件访问权限

icacls C:\inetpub\wwwroot\upload /grant IUSR:(OI)(CI)(M)

在 IIS 中把 index.php 设定为默认文档

IIS 的默认文档用于没有指定文件名的 HTTP 请求。对于 PHP 应用来说默认文档通常为 index.php。要将 index.php 添加到 IIS 的默认文档列表中，使用此命令：

Example #13 将 index.php 设为 IIS 的默认文档

%windir%\system32\inetsrv\appcmd.exe set config ^
-section:system.webServer/defaultDocument /+"files.[value='index.php']" ^
/commit:apphost

FastCGI 和 PHP 回收配置

用以下命令配置 IIS FastCGI 对于 PHP 进程的回收设定。FastCGI 的设置 instanceMaxRequests 控制了单一的 php-cgi.exe 进程处理多少个请求之后会被 IIS 关闭。PHP 环境变量 PHP_FCGI_MAX_REQUESTS 控制了一个 php-cgi.exe 进程处理多少个请求之后会被自我回收。要确保 FastCGI 中 InstanceMaxRequests 的值小于或等于 PHP_FCGI_MAX_REQUESTS 的值。

Example #14 配置 FastCGI 和 PHP 的回收

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
/[fullPath='c:\php\php-cgi.exe'].instanceMaxRequests:10000

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
/+"[fullPath='C:\{php_folder}\php-cgi.exe'].environmentVariables.^
[name='PHP_FCGI_MAX_REQUESTS',value='10000']"

FastCGI 超时设定

如果会有一些需时较长的 PHP 脚本运行，则增加超时的设定值。有两个控制超时的指令 activityTimeout 和 requestTimeout。用以下命令修改超时设定。确保在 fullPath 的参数中使用自己系统上的 php-cgi.exe 的绝对路径。

Example #15 配置 FastCGI 超时设定

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
/[fullPath='C:\php\php-cgi.exe',arguments=''].activityTimeout:"90"  /commit:apphost

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
/[fullPath='C:\php\php-cgi.exe',arguments=''].requestTimeout:"90"  /commit:apphost

改变 php.ini 文件的位置

PHP 在几个位置搜索配置文件 php.ini，可以通过环境变量 PHPRC 来改变 php.ini 的默认位置。要使得 PHP 从用户指定的位置加载配置文件，使用以下命令。指向 php.ini 文件的绝对路径应作为环境变量 PHPRC 的值。

Example #16 改变 php.ini 文件的位置

appcmd.exe set config  -section:system.webServer/fastCgi ^
/+"[fullPath='C:\php\php.exe',arguments=''].environmentVariables.^
[name='PHPRC',value='C:\Some\Directory\']" /commit:apphost

Microsoft Windows 下的 Apache 1.3.x

本节包括在 Microsoft Windows 平台的 Apache 下安装 PHP 的说明和提示。在另外的页面也有

Note:

请先阅读 手动安装步骤！

有两种方式让 PHP 工作在 Windows 下的 Apache 1.3.x 中。首先是使用 CGI 可执行程序（PHP 4 下为 php.exe，PHP 5 下为 php-cgi.exe），另外一种方式是使用 Apache 模块 DLL。无论是那种方式，都需要修改 httpd.conf 来配置 Apache，使 PHP 能够在其上运行，然后都需要重启服务。

值得注意的是，现在 Windows 下的 SAPI 模块已经稳定得多，我们建议首先考虑使用 SAPI 而不要使用 CGI 可执行程序。因为 SAPI 更加透明和安全。

虽然还有些其它的方法来在 Apache 下配置 PHP，下面介绍的方法是最简单并适用于新手的。请参考 Apache 的文档以获得更多的配置参数。

在修改完配置文件后，请记得重启 Apache 服务。例如，如果把 Apache 作为 Windows 的一个服务来运行，那么在命令提示行下使用 NET STOP APACHE命令然后再使用 NET START APACHE命令便可重启服务。也可以使用重启 Apache 服务的快捷方式来重启。

Note: 记住当在 Windows 环境下的 Apache 配置文件中添加路径值时，所有的反斜线，如 c:\directory\file.ext，应转换为正斜线： c:/directory/file.ext。对目录来说，也必须由斜线结尾。

作为 Apache 的模块安装

应该将下面几行加入 Apache 的 httpd.conf 文件：

Example #17 PHP 作为 Apache 1.3.x 的一个模块

这里假设 PHP 安装在 c:\php。如果不是这样请根据情况修改路径。

对于 PHP 4：

# 在 LoadModule 一节的末尾添加
# 不要忘记将该文件从 sapi 复制出来
LoadModule php4_module "C:/php/php4apache.dll"

# 在 AddModule 一节的末尾添加
AddModule mod_php4.c

对于 PHP 5：

# 在 LoadModule 一节的末尾添加
LoadModule php5_module "C:/php/php5apache.dll"

# 在 AddModule 一节的末尾添加
AddModule mod_php5.c

两个 PHP 版本都需要添加的内容：

# 将下面这行添加到 <IfModule mod_mime.c> 条件块中
AddType application/x-httpd-php .php

# 如果要使用语法高亮的 .phps 文件，需要添加
AddType application/x-httpd-php-source .phps

作为 CGI 可执行文件的安装

如果按照 手工安装步骤 将 PHP 解压到 C:\php\，需要在 Apache 的配置文件中添加如下内容以使 PHP 按照 CGI 方式运行:

Example #18 PHP 以 CGI 方式运行在 Apache 1.3.x

ScriptAlias /php/ "c:/php/"
AddType application/x-httpd-php .php

# 对于 PHP 4
Action application/x-httpd-php "/php/php.exe"

# 对于 PHP 5
Action application/x-httpd-php "/php/php-cgi.exe"

# 指定 php.ini 所在目录
SetEnv PHPRC C:/php
请注意第二行的配置可以在默认的 httpd.conf 中找到，但是是被注释掉的。也请记得将 c:/php/替换为 PHP 所在的真实路径。

Warning

服务器使用 CGI 方式进行部署可能存在几个公开的缺陷。请阅读 CGI 安全一章 以学习 如何抵御这些攻击。

如果想发布语法高亮的 php 文件，没有类似于模块方式下 PHP 那种方便的方法。如果选择了 CGI 方式运行 PHP，需要使用 highlight_file() 函数来进行语法高亮。创建一个 PHP 文件，加入下述代码即可：<?php highlight_file('some_php_script.php'); ?>。

Microsoft Windows 下的 Apache 2.x

本节包括在 Microsoft Windows 系统中针对 Apache 2.x 安装 PHP 的指导与说明。

Note:

应该先阅读手工安装步骤！

Note: Apache 2.2 支持

Apache 2.2 用户应留意对于 Apache 2.2 的 DLL 文件名是 php5apache2_2.dll 而不是 php5apache2.dll，并且只在 PHP 5.2.0 以及更高版本中出现。

强烈建议阅读 » Apache 文档来加深对 Apache 2.x 服务器的基本理解。此外在继续下去之前考虑先阅读一下 Apache 2.x 的 » Windows 下使用说明。

Apache 2.x 被设计运行于 Windows 版的服务器平台下，例如 Windows NT 4.0，Windows 2000，Windows XP 或 Windows 7。虽然 Apache 2.x 可以在 Windows 9x 下勉强运行，但对此平台的支持尚未完成，某些功能无法正确工作。对此并无补救计划。

下载最新版本的 » Apache 2.x 以及适合的 PHP 版本。先完成手工安装步骤后再回来继续将 PHP 集成入 Apache。

Windows 下有三种方法使 PHP 工作于 Apache 2.x 之中。可以以 handler，CGI，或者 FastCGI 方式运行 PHP。

Note: 记住当在 Windows 环境下的 Apache 配置文件中添加路径值时，所有的反斜线，如 c:\directory\file.ext，应转换为正斜线： c:/directory/file.ext。对目录来说，也必须由斜线结尾。

以 Apache handler 方式安装

需要将以下几行加入到 Apache 的 httpd.conf 配置文件中以加载 Apache 2.x 的 PHP 模块：

Example #19 PHP 在 Apache 2.x 中作为 handler

#
LoadModule php5_module "c:/php/php5apache2.dll"
AddHandler application/x-httpd-php .php

# 配置 php.ini 的路径
PHPIniDir "C:/php"

Note: 记得用自己 PHP 实际所在的路径替换掉上例中的 c:/php/。要留意在 LoadModule 指令中使用了 php5apache2.dll 或者 php5apache2_2.dll，并且该文件确实位于所指定的位置。

以上配置将使 PHP 处理任何具有 .php 后缀的文件，即使该文件还有其它的文件后缀。例如一个名为 example.php.txt 的文件将被作为 PHP 文件运行。要确保只有以 .php 结尾的文件才被执行，则用以下配置替换上面的：

<FilesMatch \.php$>
      SetHandler application/x-httpd-php
 </FilesMatch>

以 CGI 方式运行 PHP

要更好地理解在 Apache 下运行 CGI，请参阅 » Apache CGI 文档。

要将 PHP 以 CGI 方式运行，需要将 php-cgi 文件放入到用 ScriptAlias 指令所指定的 CGI 目录中。

然后需要给 PHP 文件中添加一 #! 的行来指明 PHP 可执行文件的位置：

Example #20 Apache 2.x 下 CGI 方式的 PHP

#!C:/php/php.exe
<?php
  phpinfo();
?>

Warning

服务器使用 CGI 方式进行部署可能存在几个公开的缺陷。请阅读 CGI 安全一章 以学习 如何抵御这些攻击。

以 FastCGI 方式运行 PHP

以 FastCGI 方式运行 PHP 比起 CGI 方式有很多优点。设定的方式很直接：

从 » http://httpd.apache.org/mod_fcgid/ 取得 mod_fcgid，该站点有 Win32 可执行文件的下载。按照下载文件中的指示安装此模块。

按以下方法配置 web 服务器，注意用自己系统上的路径替换其中相应的内容：

Example #21 配置 Apache 以 FastCGI 方式运行 PHP

LoadModule fcgid_module modules/mod_fcgid.so

# Where is your php.ini file?
FcgidInitialEnv PHPRC        "c:/php"

AddHandler fcgid-script .php
FcgidWrapper "c:/php/php-cgi.exe" .php
此时具有 .php 后缀的文件将被 PHP FastCGI 所解析执行。

Microsoft Windows 下的 Sambar 服务器

本节包含针对 Windows 下的 » Sambar 服务器的说明和提示。

Note:

应该首先阅读 手工安装步骤！

下面列出了怎样在 Windows 下设置 Sambar 服务器的 ISAPI 模块。

  • 在 Sambar 安装目录中找到 mappings.ini文件（在 config 目录中）；

  • 打开 mappings.ini 并在 [ISAPI] 部分加入下面一行：

    Example #22 Sambar 的 ISAPI 设置

    #对 PHP 4
*.php = c:\php\php4isapi.dll

#对 PHP 5
*.php = c:\php\php5isapi.dll
    （上面假定 PHP 安装在 c:\php。）

  • 重启动 Sambar 服务器以使改动生效。

Note:

如果想要用 PHP 与分布于网络中不同的主机上的资源通讯，则需要改变 Sambar 服务器的服务进程所使用的帐号。Sambar 服务进程使用的默认帐号是 LocalSystem，没有远程资源的访问许可。可以通过 Windows 控制面板中的"管理工具"里面的"服务"来修改此帐号。

Microsoft Windows 下的 Xitami

本节包含针对 Windows 下的 » Xitami 的说明与提示。

Note:

应该首先阅读 手工安装步骤！

下面列出了怎样在 Windows 下在 Xitami 中设置 PHP 的 CGI 方式。

Note: CGI 用户重要提示

请阅读 FAQ：cgi.force_redirect 中的重要细节。此选项需要被设为 0。如果想要使用 $_SERVER['PHP_SELF']，还必须激活 cgi.fix_pathinfo选项。

Warning

服务器使用 CGI 方式进行部署可能存在几个公开的缺陷。请阅读 CGI 安全一章 以学习 如何抵御这些攻击。

  • 确保 web 服务器在运行，在浏览器中打开 Xitami 的管理控制台（通常是 http://127.0.0.1/admin），并点击 Configuration；

  • 找到 Filters，在 File extensions（.xxx）字段中加入想要 PHP 解析的后缀名（例如 .php）；

  • 在 Filter command 或 script 中输入 PHP 的 CGI 可执行文件名，例如 PHP 4 是 C:\php\php.exe，PHP 5 是 C:\php\php-cgi.exe；

  • 点击"Save"图标；

  • 重启动服务器以使改动生效。

从源程序编译

本章讲述了在 Windows 下如何使用 Microsoft 的工具编译 PHP。要在 CygWin 中编译 PHP，请参考 Unix 系统下的安装 一章。

具体内容见：» https://wiki.php.net/internals/windows/stepbystepbuild。

Windows 下安装扩展库

在 Windows 下安装完 PHP 和 web 服务器之后，可能想要安装一些扩展库来获得更多功能。可以通过修改 php.ini 来选择当 PHP 启动时加载哪些扩展库。也可以在脚本中通过使用 dl()来动态加载。

PHP 扩展库的 DLL 文件都具有 php_ 前缀。

很多扩展库都 内置于 Windows 版的 PHP 之中。这意味着要加载这些扩展库，额外的 DLL 文件和 extension 配置指令都 不需要。Windows 下的 PHP 扩展库 列表列出了需要或曾经需要额外 PHP DLL 文件的扩展库。下面是内置的扩展库列表（截止到 PHP 5.0.4）： BCMath, Calendar, COM, Ctype, DOM, FTP, LibXML, Iconv, ODBC, PCRE, Session, SimpleXML, SPL, WDDX, XML 和 Zlib.

PHP 搜索扩展库的默认位置在 C:\php5。要修改此项以符合用户自己的 PHP 设置，需要编辑 php.ini 文件：

  • 需要修改 extension_dir 设置以指向用户放置扩展库的目录或者说放置 php_*.dll 文件的位置。例如：

    extension_dir = C:\php\extensions

  • 要在 php.ini 中启用某扩展库，需要去掉 php.ini 文件中该行 extension=php_*.dll 前的注释符号，将想要加载的扩展库前的分号（;）删除即可。

    Example #23 在 Windows 下启用 Bzip2 扩展库

    // 将这一行
;extension=php_bz2.dll

// 改成这样
extension=php_bz2.dll

  • 有些扩展库需要额外的 DLL 才能工作。其中一部分包括在发行包里，在主目录下可以找到。但还有一些，例如 Oracle（php_oci8.dll）所需要的 DLL 没有绑定在发行包里。别忘了将 C:\php 放到系统路径 PATH 中去（此过程在另外的 FAQ 条目中有说明）。

  • 某些 DLL 没有绑定在 PHP 发行包中，详情见每个扩展库的文档页。此外有关 PECL 的说明见手册页 PECL 扩展库安装。在 PECL 中有日益增加数目巨大的 PHP 扩展库，这些扩展库需要 单独下载。

Note: 如果运行服务器模块版的 PHP，在修改了 php.ini 之后别忘了重新启动 web 服务器以使其改动生效。

下表说明了哪些扩展库需要额外的 DLL。

PHP 扩展库
扩展库 | 说明 | 注解
php_bz2.dll | bzip2 压缩函数 | 无
php_calendar.dll | Calendar 日历转换函数 | 无
php_ctype.dll | ctype 家族函数 | 无
php_curl.dll | CURL，客户端 URL 库函数 | 需要：libeay32.dll，ssleay32.dll（已附带），在 OpenSSL 1.1 版本里需要：libcrypto-*.dll and libssl-*.dll (已附带)
php_dba.dll | DBA：数据库（dbm 风格）抽象层函数 | 无
php_dbase.dll | dBase 函数 | 无
php_exif.dll | EXIF 函数 | 需要 php_mbstring.dll。并且在 php.ini 中，php_exif.dll 必须在 php_mbstring.dll 之后加载
php_fbsql.dll | FrontBase 函数 | 无
php_fdf.dll | FDF：表单数据格式化函数 | 需要：fdftk.dll（已附带）
php_filepro.dll | filePro 函数 | 只读访问
php_ftp.dll | FTP 函数 | 无
php_gd2.dll | GD 库图像函数 | GD2
php_gettext.dll | Gettext 函数 | PHP <= 4.2.0 需要 gnu_gettext.dll（已附带），PHP >= 4.2.3 需要 libintl-1.dll， iconv.dll（已附带）
php_hyperwave.dll | HyperWave 函数 | 无
php_iconv.dll | ICONV 字符集转换 | 需要：iconv-1.3.dll（已附带），iconv.dll
php_iisfunc.dll | IIS 管理函数库 | 无
php_imap.dll | IMAP，POP3 和 NNTP 函数 | 无
php_ingres.dll | Ingres II 函数 | 需要：Ingres II 库
php_interbase.dll | InterBase 函数 | 需要：gds32.dll（已附带）
php_ldap.dll | LDAP 函数 | 需要 ： libeay32.dll，ssleay32.dll（已附带）。在 OpenSSL 1.1 里需要： libcrypto-*.dll 和 libssl-*.dll (已附带)
php_mbstring.dll | Multi-Byte String 多字节字符串函数 | 无
php_mcrypt.dll | Mcrypt 加密函数 | 需要：libmcrypt.dll
php_mhash.dll | Mhash 函数 | 需要：libmhash.dll（已附带）
php_mysql.dll | MySQL 函数 | 需要：libmysql.dll（已附带）
php_mysqli.dll | MySQLi 函数 | 需要：libmysql.dll（PHP <= 5.0.2 中是 libmysqli.dll）（已附带）
php_oci8.dll | Oracle 8 函数 | 需要：Oracle 8.1+ 客户端库
php_openssl.dll | OpenSSL 函数 | 需要：libeay32.dll（已附带），OpenSSL 1.1 起需要 liblibcrypto-*.dll（已附带）
php_pgsql.dll | PostgreSQL 函数 | 无
php_shmop.dll | Shared Memory 共享内存函数 | 无
php_snmp.dll | SNMP 函数 | 仅用于 Windows NT！
php_soap.dll | SOAP 函数 | 无
php_sockets.dll | Socket 函数 | 无
php_tidy.dll | Tidy 函数 | 无
php_tokenizer.dll | Tokenizer 函数 | 无
php_w32api.dll | W32api 函数 | 无
php_xmlrpc.dll | XML-RPC 函数 | 需要：iconv.dll（已附带）
php_xslt.dll | XSLT 函数 | 需要：sablot.dll，expat.dll， iconv.dll（已附带）。
php_yaz.dll | YAZ 函数 | 需要：yaz.dll（已附带）
php_zip.dll | Zip 文件函数 | 只读访问
php_zlib.dll | ZLib 压缩函数 | 无

PHP 在 Microsoft Windows 下的命令行方式

本章包含有针对在 Windows 下以命令行运行 PHP 的说明与提示。

Note:

应该先阅读 手工安装步骤！

要在命令行下运行 PHP，可以无需对 Windows 做任何改动。

C:\PHP5\php.exe -f "C:\PHP Scripts\script.php" -- -arg1 -arg2 -arg3

但是有几个很容易的步骤可以使其更加简便。某些步骤可能已经在之前完成了，不过还是在这里重复说明以便提供一个完整的步骤序列。

    Note:

    PATH 和 PATHEXT 都是在 Windows 下已有的重要环境变量，要留意不要覆盖了其内容，仅仅是向其中添加内容。

  • 将 PHP 可执行文件（php.exe，php-win.exe 或者 php-cli.exe）的路径添加到 PATH 环境变量中去。如何将 PHP 目录添加到 PATH 中请参阅与之相关的常见问题。

  • 将 .PHP 后缀添加到 PATHEXT 环境变量中去。可以在修改 PATH 环境变量时同时进行。跟常见问题中说明的步骤一样，不要要修改的是 PATHEXT 环境变量而不是 PATH 环境变量。

    Note:

    把 .PHP 放置到什么位置将决定具有相同文件名时运行的优先级。例如将 .PHP 放到 .BAT 之前将导致如果有同名的 PHP 脚本和批处理文件，则 PHP 脚本会运行。

  • 将 .PHP 后缀关联为一种文件类型，用以下命令完成：

    assoc .php=phpfile

  • 将 phpfile 文件类型关联到适当的 PHP 可执行文件，用以下命令完成：

    ftype phpfile="C:\PHP5\php.exe" -f "%1" -- %~2

按照以上步骤将使 PHP 脚本可以在任何目录下运行，不需要输入 PHP 可执行文件名以及 .PHP 后缀，并且所有参数都会被传递给脚本来处理。

以下例子说明了可以手工修改的注册表项目变化。

Example #24 注册表变化

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.php]
@="phpfile"
"Content Type"="application/php"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile]
@="PHP Script"
"EditFlags"=dword:00000000
"BrowserFlags"=dword:00000008
"AlwaysShowExt"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\DefaultIcon]
@="C:\\PHP5\\php-win.exe,0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell]
@="Open"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell\Open]
@="&Open"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell\Open\command]
@="\"C:\\PHP5\\php.exe\" -f \"%1\" -- %~2"

有了这些改变之后，本页顶端第一个例子中的命令可以写成这样：

"C:\PHP Scripts\script" -arg1 -arg2 -arg3
或者如果 "C:\PHP Scripts" 路径位于 PATH 环境变量中的话：
script -arg1 -arg2 -arg3

Note:

不过如果想要通过此技巧将 PHP 脚本作为命令行管道过滤器的话，有个小问题。例如以下例子：

dir | "C:\PHP Scripts\script" -arg1 -arg2 -arg3
或者
dir | script -arg1 -arg2 -arg3
此时脚本会死掉，没有输出任何内容。要解决此问题，还需要做一个注册表修改。
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"InheritConsoleHandles"=dword:00000001
有关此问题的更多信息见» 微软知识库文章：321788。 从 Windows 10 开始，此设置似乎被颠倒，请参考以下链接 » Microsoft forum post。


云计算平台上的安装

Table of Contents

  • Azure App Services
  • Amazon EC2

PHP 在云平台上的安装。进入 PHP 云世界！


Azure App Services

PHP is frequently used on Azure App Services (aka Microsoft Azure, Windows Azure, Azure Web Apps).

Azure App Services manages pools of Windows Web Servers to host your web application, as an alternative to managing your own web server on your own Azure Compute VMs or other servers.

PHP is already enabled for your Azure App Services web site automatically. In the Azure Portal, select your web site, and you can choose which version of PHP to use. You may want to choose a newer version than the default.

As such, PHP and extensions will run on Azure App Services just as it will on other Windows servers. Much of the knowledgebase is also portable, so see the Windows Troubleshooting Page too. However, the management interface for Azure App Services is different:

  • Azure portal: create, edit settings and delete web sites. » Azure Portal

  • Kudu Dashboard: [your web site name].azurewebsites.net Then, the Kudu dashboard is » https://[your web site name].scm.azurewebsites.net/. The Dashboard gives you access to some debugging capabilities, file management and site extensions. Site extensions are an Azure mechanism to add extra programs, like PHP preview builds, to your web site.

  • You can not use IIS Manager, Server Manager, or RDP.

There is also a PHP SDK for programmatically using many Azure Services from your PHP code. See » Azure SDK for PHP.

For more information, see » Azure PHP Developer Center

WinCache

WinCache is enabled by default on Azure App Services and it is recommended that you leave it enabled. If you install your own build of PHP, you should enable WinCache on that too.

Custom PHP Build

You may upload your own PHP build to your D:\Home (C:\ is NOT writable). Then in the Azure Portal, set SCRIPT_PROCESSOR for .php to the absolute path to php-cgi.exe file in your build.


  • ? Azure App Services
  • FastCGI 进程管理器（FPM） ?
  • PHP Manual
  • 云计算平台上的安装
  • Amazon EC2

Amazon EC2

» EC2 云平台上 PHP 的安装。

参见 » AWS SDK for PHP。


FastCGI 进程管理器（FPM）

Table of Contents

  • 安装
  • 配置

FPM（FastCGI 进程管理器）用于替换 PHP FastCGI 的大部分附加功能，对于高负载网站是非常有用的。

它的功能包括：

  • 支持平滑停止/启动的高级进程管理功能；

  • 可以工作于不同的 uid/gid/chroot 环境下，并监听不同的端口和使用不同的 php.ini 配置文件（可取代 safe_mode 的设置）；

  • stdout 和 stderr 日志记录;

  • 在发生意外情况的时候能够重新启动并缓存被破坏的 opcode;

  • 文件上传优化支持;

  • "慢日志" - 记录脚本（不仅记录文件名，还记录 PHP backtrace 信息，可以使用 ptrace或者类似工具读取和分析远程进程的运行数据）运行所导致的异常缓慢;

  • fastcgi_finish_request() - 特殊功能：用于在请求完成和刷新数据后，继续在后台执行耗时的工作（录入视频转换、统计处理等）；

  • 动态／静态子进程产生；

  • 基本 SAPI 运行状态信息（类似Apache的 mod_status）；

  • 基于 php.ini 的配置文件。


安装

从源代码编译

编译 PHP 时需要 --enable-fpm 配置选项来激活 FPM 支持。

以下为 FPM 编译的具体配置参数（全部为可选参数）：

  • --with-fpm-user - 设置 FPM 运行的用户身份（默认 - nobody）

  • --with-fpm-group - 设置 FPM 运行时的用户组（默认 - nobody）

  • --with-fpm-systemd - 启用 systemd 集成 (默认 - no)

  • --with-fpm-acl - 使用POSIX 访问控制列表 (默认 - no) 5.6.5版本起有效


配置

FPM 使用类似 php.ini 语法的 php-fpm.conf 和进程池配置文件。

php-fpm.conf 全局配置段

pid string

PID 文件的位置。默认为空。

error_log string

错误日志的位置。默认：#INSTALL_PREFIX#/log/php-fpm.log。 如果设置为 "syslog"，日志将不会写入本地文件，而是发送到 syslogd。

log_level string

错误级别。可用级别为：alert（必须立即处理），error（错误情况），warning（警告情况），notice（一般重要信息），debug（调试信息）。默认：notice。

syslog.facility string

设置何种程序记录消息，默认值：daemon。

syslog.ident string

为每条信息添加前缀。 如果在同一台服务器上运行了多个 FPM 实例，可以修改此默认值来满足需求。默认值：php-fpm。

emergency_restart_threshold int

如果子进程在 emergency_restart_interval 设定的时间内收到该参数设定次数的 SIGSEGV 或者 SIGBUS退出信息号，则FPM会重新启动。0 表示"关闭该功能"。默认值：0（关闭）。

emergency_restart_interval mixed

emergency_restart_interval 用于设定平滑重启的间隔时间。这么做有助于解决加速器中共享内存的使用问题。可用单位：s（秒），m（分），h（小时）或者 d（天）。默认单位：s（秒）。默认值：0（关闭）。

process_control_timeout mixed

设置子进程接受主进程复用信号的超时时间。可用单位：s（秒），m（分），h（小时）或者 d（天）。默认单位：s（秒）。默认值：0（关闭）。

process.max int

Fork 的最大 FPM 进程数。使用动态管理进程数时，此设计可以控制在一个进程池内的全局进程数量。 使用需谨慎。默认值：0。

process.priority int

设置 master 进程的 nice(2) 优先级（如果设置了此值）。 可以是 -19（最高优先级）到 20 （更低优先级）。 默认值：不设置。

daemonize boolean

设置 FPM 在后台运行。设置"no"将 FPM 保持在前台运行用于调试。默认值：yes。

rlimit_files int

设置 master 进程的打开文件描述符 rlimit 数。

rlimit_core int

设置 master 进程最大 core 的 rlimit 尺寸。 默认值：0。

events.mechanism string

设置 FPM 使用的事件机制。 可用以下选项：select、pool、epoll、kqueue (*BSD)、port (Solaris)。 默认值：不设置（自动检测）

systemd_interval int

使用 systemd 集成的 FPM 时，设置间歇秒数，报告健在通知给 systemd。 设置为 0 表示禁用。默认值：10。

运行配置区段

在FPM中，可以使用不同的设置来运行多个进程池。 这些设置可以针对每个进程池单独设置。

listen string

设置接受 FastCGI 请求的地址。可用格式为：'ip:port'，'port'，'/path/to/unix/socket'。每个进程池都需要设置。

listen.backlog int

设置 listen(2) 的 backlog 最大值。"-1"表示无限制。默认值：-1。

listen.allowed_clients string

设置允许连接到 FastCGI 的服务器 IPV4 地址。等同于 PHP FastCGI (5.2.2+) 中的 FCGI_WEB_SERVER_ADDRS 环境变量。仅对 TCP 监听起作用。每个地址是用逗号分隔，如果没有设置或者为空，则允许任何服务器请求连接。默认值：any。 PHP 5.5.20 和 5.6.4起，开始支持 IPv6 地址。

listen.owner string

如果使用了 Unix 套接字，表示它的权限。在 Linux 中必须设置读/写权限，以便用于 WEB 服务器连接。 在很多 BSD 派生的系统中可以忽略权限允许自由连接。 默认值：运行所使用的用户和组，权限为 0660。

listen.group string

参见 listen.owner。

listen.mode string

参见 listen.owner。

listen.acl_users string

当系统支持 POSIX ACL（Access Control Lists）时，可以设置使用此选项。 当设置了的时候，将会忽略 listen.owner 和 listen.group。 值是逗号分割的用户名列表。 PHP 5.6.5 起可用。

listen.acl_groups string

参见 listen.acl_users。 值是逗号分割的用户组名称列表。 PHP 5.6.5 起可用。

user string

FPM 进程运行的Unix用户。必须设置。

group string

FPM 进程运行的 Unix 用户组。如果不设置，就使用默认用户的用户组。

pm string

设置进程管理器如何管理子进程。可用值：static，ondemand，dynamic。必须设置。

static - 子进程的数量是固定的（pm.max_children）。

ondemand - 进程在有需求时才产生（当请求时才启动。与 dynamic 相反，在服务启动时 pm.start_servers 就启动了。

dynamic - 子进程的数量在下面配置的基础上动态设置：pm.max_children，pm.start_servers，pm.min_spare_servers，pm.max_spare_servers。

pm.max_children int

pm 设置为 static 时表示创建的子进程的数量，pm 设置为 dynamic 时表示最大可创建的子进程的数量。必须设置。

该选项设置可以同时提供服务的请求数限制。类似 Apache 的 mpm_prefork 中 MaxClients 的设置和 普通PHP FastCGI中的 PHP_FCGI_CHILDREN 环境变量。

pm.start_servers in

设置启动时创建的子进程数目。仅在 pm 设置为 dynamic 时使用。默认值：min_spare_servers + (max_spare_servers - min_spare_servers) / 2。

pm.min_spare_servers int

设置空闲服务进程的最低数目。仅在 pm 设置为 dynamic 时使用。必须设置。

pm.max_spare_servers int

设置空闲服务进程的最大数目。仅在 pm 设置为 dynamic 时使用。必须设置。

pm.process_idle_timeout mixed

秒数，多久之后结束空闲进程。 仅当设置 pm 为 ondemand。 可用单位：s（秒），m（分），h（小时）或者 d（天）。默认单位：10s。

pm.max_requests int

设置每个子进程重生之前服务的请求数。对于可能存在内存泄漏的第三方模块来说是非常有用的。如果设置为 '0' 则一直接受请求，等同于 PHP_FCGI_MAX_REQUESTS 环境变量。默认值：0。

pm.status_path string

FPM 状态页面的网址。如果没有设置，则无法访问状态页面，默认值：无。

ping.path string

FPM 监控页面的 ping 网址。如果没有设置，则无法访问 ping 页面。该页面用于外部检测 FPM 是否存活并且可以响应请求。请注意必须以斜线开头（/）。

ping.response string

用于定义 ping 请求的返回响应。返回为 HTTP 200 的 text/plain 格式文本。默认值：pong。

process.priority int

设置 worker 的 nice(2)优先级（如果设置了的话）。 该值从 -19（最高优先级） 到 20（更低优先级）。 默认值：不设置

prefix string

检测路径时使用的前缀。

request_terminate_timeout mixed

设置单个请求的超时中止时间。该选项可能会对 php.ini 设置中的 'max_execution_time' 因为某些特殊原因没有中止运行的脚本有用。设置为 '0' 表示 'Off'。可用单位：s（秒），m（分），h（小时）或者 d（天）。默认单位：s（秒）。默认值：0（关闭）。

request_slowlog_timeout mixed

当一个请求该设置的超时时间后，就会将对应的 PHP 调用堆栈信息完整写入到慢日志中。设置为 '0' 表示 'Off'。可用单位：s（秒），m（分），h（小时）或者 d（天）。默认单位：s（秒）。默认值：0（关闭）。

slowlog string

慢请求的记录日志。默认值：#INSTALL_PREFIX#/log/php-fpm.log.slow。

rlimit_files int

设置文件打开描述符的 rlimit 限制。默认值：系统定义值。

rlimit_core int

设置核心 rlimit 最大限制值。可用值：'unlimited'，0 或者正整数。默认值：系统定义值。

chroot string

启动时的 Chroot 目录。所定义的目录需要是绝对路径。如果没有设置，则 chroot 不被使用。

chdir string

设置启动目录，启动时会自动 Chdir 到该目录。所定义的目录需要是绝对路径。默认值：当前目录，或者根目录（chroot时）。

catch_workers_output boolean

重定向运行过程中的 stdout 和 stderr 到主要的错误日志文件中。如果没有设置，stdout 和 stderr 将会根据 FastCGI 的规则被重定向到 /dev/null。默认值：无。

clear_env boolean

为 FPM worker 进程清除环境变量。 在进程池配置文件里设置环境变量前，阻止任意系统的环境变量进入 FPM worker 进程。 自 PHP 5.4.27、 5.5.11 和 5.6.0 起。 默认值: Yes

security.limit_extensions string

限制 FPM 允许解析的脚本扩展名。 此设置可以预防 web 服务器配置的错误。 应当限制 FPM 仅仅解析 .php 扩展名，阻止恶意用户使用其他扩展名运行 php 代码。 默认值： .php .phar

access.log string

Access log 文件。 默认值：不设置

access.format string

access log 的格式。 默认值: "%R - %u %t \"%m %r\" %s"

还可以在为一个运行池传递附加的环境变量，或者更新 PHP 的配置值。可以在进程池配置文件中如下面的配置参数来做到：

Example #1 给运行池传递环境变量和设置 PHP 的配置值

env[HOSTNAME] = $HOSTNAME
       env[PATH] = /usr/local/bin:/usr/bin:/bin
       env[TMP] = /tmp
       env[TMPDIR] = /tmp
       env[TEMP] = /tmp

       php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com
       php_flag[display_errors] = off
       php_admin_value[error_log] = /var/log/fpm-php.www.log
       php_admin_flag[log_errors] = on
       php_admin_value[memory_limit] = 32M
PHP配置值通过 php_value 或者 php_flag 设置，并且会覆盖以前的值。请注意 disable_functions 或者 disable_classes 在 php.ini 之中定义的值不会被覆盖掉，但是会将新的设置附加在原有值的后面。

使用 php_admin_value 或者 php_admin_flag 定义的值，不能被 PHP 代码中的 ini_set() 覆盖。

自 5.3.3 起，也可以通过 web 服务器设置 PHP 的设定。

Example #2 在 nginx.conf 中设定 PHP

set $php_value "pcre.backtrack_limit=424242";
set $php_value "$php_value \n pcre.recursion_limit=99999";
fastcgi_param  PHP_VALUE $php_value;

fastcgi_param  PHP_ADMIN_VALUE "open_basedir=/var/www/htdocs";
Caution

由于这些设定是以 FastCGI 标头传递给 php-fpm，php-fpm 不应绑定到外部网可以访问的地址上，否则任何人都能修改 PHP 的配置选项了。参见 listen.allowed_clients。


PECL 扩展库安装

Table of Contents

  • PECL 安装介绍
  • 下载 PECL 扩展库
  • 在 Windows 上安装 PHP 扩展
  • 用 PEAR 编译共享 PECL 扩展库
  • 用 phpize 编译共享 PECL 扩展库
  • php-config
  • 将 PECL 扩展库静态编译入 PHP


PECL 安装介绍

» PECL 是通过 » PEAR 打包系统来的 PHP 扩展库仓库，本章内容示范了怎样取得并安装 PECL 扩展。

以下指南中假定 /your/phpsrcdir/ 是 PHP 源程序的路径，extname 是 PECL 扩展库的名字。自己根据实际情况调整。此外还假定用户熟悉 » pear 命令。 PEAR 手册里 pear 命令的信息同样适用于 pecl。

要使用共享扩展库，必须经过编译，安装，然后加载。以下说明的方法提供了怎样编译和安装扩展库的各种指导，但并不会自动加载它们。可以通过将其包括在 php.ini 中用 extension PHP 指令加载，或者 用 dl() 函数。

当编译 PHP 模块时，拥有各种工具（autoconf，automake，libtool 等）的已知好使的版本很重要。所需工具和所需版本的详情见» 匿名 Git 说明。


下载 PECL 扩展库

下载 PECL 扩展库有几种方法，如：

  • pecl install extname 命令会自动下载扩展代码， 所以在这种情况下不需要再次下载。
  • » https://pecl.php.net/ PECL 网站包括有 PHP 开发组提供的不同扩展库的信息。这里的信息包括：更新记录，版本说明，需求，以及其它信息。
  • pecl download extname PECL 网站中列出的 PECL 扩展库的发行版本可以用 » pear 命令 来下载和安装。也可以指明具体的修正版。
  • SVN 大多数 PECL 扩展库也在 SVN 中。其 web 页面见 be seen at » https://svn.php.net/viewvc/pecl/。要直接从 SVN 中下载，用以下命令：

    $ svn checkout http://svn.php.net/repository/pecl/extname/trunk extname

  • Windows 下载 PHP 官方已为 Windows 预编译了大部分的 PECL 扩展（.dll 文件），可以直接从 PECL 官网下载。


在 Windows 上安装 PHP 扩展

在 Windows 上有两种加载 PHP 扩展的方式：把扩展编译进 PHP，或者加载 DLL。加载预编译的扩展是更简单更被推荐的方式。

要加载某扩展，需要在系统中有其相对应的 ".dll" 文件。所有扩展都会由 PHP 小组定期自动编译（如何下载见下节）。

要将一扩展编译入 PHP，请参考 从源程序编译 一章。

要编译一个独立的扩展（即 DLL 文件），请参考 从源程序编译 一章。如果在 PHP 发行包和 PCEL 中都没有某 DLL 文件，那可能需要自己编译之后才能使用该扩展。

去哪里找扩展库？

PHP 扩展库通常称为"php_*.dll"（其中星号代表具体某扩展的名字），位于"PHP\ext"目录下。

PHP 发行包中包括了大多数开发者最常用到的扩展库。这些被称为"核心"扩展库。

不过呢，如果用户所需要的功能并没有被任何核心扩展提供，那还是有可能在 PECL 中找到。PHP Extension Community Library（PECL，PHP 扩展社区库）是个 PHP 扩展的储存室，提供了对于所有已知扩展的下载及开发途径的指南。

如果用户开发了一个自己使用的扩展，可以考虑将其发布到 PECL 中以便于其他有相同需求的用户使用。一个很好的副作用是可以得到其他用户的反馈，感谢，错误报告甚至修正／更新。不过在向 PECL 发布扩展之前，请先阅读 » PECL 提交指南。

下载哪个扩展？

用户常常会发现每个 DLL 都有好几个版本：

  • 不同的版本号（至少前两个数字要一致）
  • 不同的线程安全性设定
  • 不同的处理器体系（x86，x64，...)
  • 不同的排错设定
  • 其它

请记住用户的扩展设定应该与所使用的 PHP 可执行文件的设定都保持一致。以下脚本可以显示所有 PHP 设定：

Example #1 phpinfo() call

<?php
phpinfo();
?>

或者在命令行运行：

drive:\\path\to\php\executable\php.exe -i

载入一个扩展

最常见的方式是在 php.ini 配置文件里包含一个 PHP 扩展。请注意很多扩展已经在 php.ini 里了，仅需要移除分号来激活它们。

需要注意，从 PHP 7.2.0 开始，可以直接用扩展的名称，来替代扩展的文件名。这样配置文件就跟操作系统解耦了，也更容易理解。我们推荐采用此方式加载扩展。为了与之前的版本保持兼容，直接写扩展名的方式会仍然支持。

;extension=php_extname.dll

extension=php_extname.dll

; PHP version 7.2 开始的推荐写法：
extension=extname
zend_extension=another_extension

不过呢，有些 web 服务器会搞混，因为其并不一定使用和 PHP 可执行文件处于同一目录下的 php.ini 文件。要搞清楚具体使用了哪一个 php.ini 文件，在 phpinfo() 的输出中查看：

Configuration File (php.ini) Path  C:\WINDOWS

Loaded Configuration File   C:\Program Files\PHP\5.2\php.ini

激活一个扩展后，保存 php.ini 文件并重启动 web 服务器，然后用 phpinfo() 再次查看确定。新的扩展应该有其自己的一节。

解决问题

如果某扩展并未在 phpinfo() 中显示，应该查看日志以确定问题出在哪里。

如果是在命令行使用 PHP（CLI），扩展加载出错信息会直接在屏幕显示。

如果在 web 服务器中使用 PHP，则日志文件的位置与格式各不相同。请阅读所使用的 web 服务器之文档以确定日志文件的位置，这与 PHP 本身并无关系。

最常见的问题是 DLL 文件的位置，php.ini 中"extension_dir"设定的值，以及编译时的设置不匹配。

如果问题出在编译时设置不匹配，那可能所下载的 DLL 文件不对。可以尝试重新下载一个设置匹配的扩展。此外，phpinfo() 可以起到很大帮助。


用 PEAR 编译共享 PECL 扩展库

PECL 使建立共享 PHP 扩展库更容易。用 » pecl 命令这样做：

$ pecl install extname

这将下载 extname 的源代码，编译之，并将 extname.so 安装到 extension_dir 中。然后 extname.so 就可以通过 php.ini 加载了。

默认情况下，pecl 命令不会安装标记为 alpha 或 beta 状态的包。如果没有 stable 包可用，也可以用以下命令安装一个 beta 包：

$ pecl install extname-beta

也可以用此命令安装一个指定的版本：

$ pecl install extname-0.1

Note:

在 php.ini 中激活扩展之后，需要重新启动 web 服务以使更改生效。


用 phpize 编译共享 PECL 扩展库

有时候不能用 pecl 安装命令。这可能是因为在防火墙后面，或者是因为想要安装的扩展库还没有 PECL 兼容的包，例如 SVN 中尚未发布的扩展库。如果要编译这种扩展库，可以用更底层的编译工具来手工进行编译。

phpize 命令是用来准备 PHP 扩展库的编译环境的。下面例子中，扩展库的源程序位于 extname 目录中：

$ cd extname
$ phpize
$ ./configure
$ make
# make install

成功的安装将创建 extname.so 并放置于 PHP 的扩展库目录中。需要调整 php.ini，加入 extension=extname.so 这一行之后才能使用此扩展库。

如果系统中没有 phpize 命令并且使用了预编译的包（例如 RPM），那要安装 PHP 包相应的开发版本，此版本通常包含了 phpize 命令以及相应的用于编译 PHP 及其扩展库的头文件。

使用 phpize --help 命令可以显示此命令用法。


php-config

php-config 是一个简单的命令行脚本用于获取所安装的 PHP 配置的信息。

在编译扩展时，如果安装有多个 PHP 版本，可以在配置时用 --with-php-config 选项来指定使用哪一个版本编译，该选项指定了相对应的 php-config 脚本的路径。

php-config 脚本在命令行所能使用的选项可以通过 -h 选项来显示：

Usage: /usr/local/bin/php-config [OPTION]
Options:
  --prefix            [...]
  --includes          [...]
  --ldflags           [...]
  --libs              [...]
  --extension-dir     [...]
  --include-dir       [...]
  --php-binary        [...]
  --php-sapis         [...]
  --configure-options [...]
  --version           [...]
  --vernum            [...]

命令行选项
选项 | 说明
--prefix | PHP 所安装的路径前缀，例如 /usr/local
--includes | 列出用 -I 选项包含的所有文件
--ldflags | PHP 编译时所使用的 LD 标志
--libs | PHP 编译时所附加的库
--extension-dir | 扩展库的默认路径
--include-dir | 头文件的默认路径前缀
--php-binary | PHP CLI 或者 CGI 可执行文件的完整路径
--php-sapis | 列出所有可用的 SAPI 模块
--configure-options | 重现当前 PHP 在编译时的配置选项
--version | PHP 版本号
--vernum | PHP 版本号，以整数表示


将 PECL 扩展库静态编译入 PHP

有时可能需要将扩展库静态编译到 PHP 中。这需要将扩展库源程序放入 /your/phpsrcdir/ext/ 目录中去并告诉 PHP 编译系统来生成其配置脚本。

$ cd /your/phpsrcdir/ext
$ pecl download extname
$ gzip -d < extname.tgz | tar -xvf -
$ mv extname-x.x.x extname

这将产生以下目录：

/your/phpsrcdir/ext/extname

此时强制 PHP 重新生成配置脚本，然后正常编译 PHP：

$ cd /your/phpsrcdir
$ rm configure
$ ./buildconf --force
$ ./configure --help
$ ./configure --with-extname --enable-someotherext --with-foobar
$ make
$ make install

Note: 要运行"buildconf"脚本，需要 autoconf 2.13 和 automake 1.4+（更新版本的 autoconf 也许能工作，但不被支持）。

是否用 --enable-extname 或 --with-extname 取决于扩展库。通常不需要外部库文件的扩展库使用 --enable。要确认的话，在 buildconf 之后运行：

$ ./configure --help | grep extname


  • ? 将 PECL 扩展库静态编译入 PHP
  • 阅读 FAQ ?
  • PHP Manual
  • 安装与配置
  • 还有问题？

还有问题？

Table of Contents

  • 阅读 FAQ
  • 其它问题
  • 错误报告


  • ? 还有问题？
  • 其它问题 ?
  • PHP Manual
  • 还有问题？
  • 阅读 FAQ

阅读 FAQ

有些问题比其它的更为普遍。最常见的列在 PHP 常见问题中，是本手册的一部分。


其它问题

如果还卡着，PHP 安装邮件列表中的人可能会帮你。应该先查看归档，也许有人已经回答了另一个人提出的和你相同的问题。归档可以从支持页 » https://www.php.net/support.php 访问到。要订阅 PHP 安装邮件列表，发送一封空邮件去 » php-install-subscribe@lists.php.net。邮件列表地址是 » php-install@lists.php.net。

如果想从邮件列表中取得帮助，请准确给出有关你的环境的必要细节（哪个操作系统，PHP 的版本，哪个 web 服务器，是否以 CGI 方式还是以服务器模块方式运行 PHP），并给出足够的代码让别人能重现和测试你碰到的问题。


错误报告

如果你觉得自己发现了一个 PHP 的 bug，请提出报告。PHP 开发人员也许还不知道有问题，除非你报告了，否则有可能不会被修正。可以通过错误跟踪系统 » https://bugs.php.net/ 来报告错误。请不要在邮件列表或私人信件中发送错误报告。错误跟踪系统也可以用来提出对新特性的要求。

在提交错误报告之前请先阅读» 怎样报告错误！


运行时配置

Table of Contents

  • 配置文件
  • .user.ini 文件
  • 配置可被设定范围
  • 怎样修改配置设定


配置文件

配置文件（php.ini）在 PHP 启动时被读取。对于服务器模块版本的 PHP，仅在 web 服务器启动时读取一次。对于 CGI 和 CLI 版本，每次调用都会读取。

php.ini 的搜索路径如下（按顺序）：

  • SAPI 模块所指定的位置（Apache 2 中的 PHPIniDir 指令，CGI 和 CLI 中的 -c 命令行选项，NSAPI 中的 php_ini 参数，THTTPD 中的 PHP_INI_PATH 环境变量）。
  • PHPRC 环境变量。在 PHP 5.2.0 之前，其顺序在以下提及的注册表键值之后。
  • 自 PHP 5.2.0 起，可以为不同版本的 PHP 指定不同的 php.ini 文件位置。注册表目录所在的位置取决于你的系统是 32 位还是 64 位。32-bit 的 PHP 运行在 32-bit 的系统或 64-bit 的 PHP 运行在 64-bit 系统时使用 [(HKEY_LOCAL_MACHINE\SOFTWARE\PHP] 32-bit 的 PHP 运行在 64-bit 的系统上时，则使用 [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PHP]] 替代。 系统版本跟 PHP 版本架构一致时，会按以下顺序依次进行检查： [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x.y.z]， [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x.y] 和 [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x]，其中的 x，y 和 z 指的是 PHP 主版本号，次版本号和发行批次。 对于 32 bit 版本的 PHP 运行在 64 bit 系统上的情况，则会按以下顺序依次进行检查： [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6421Node\PHP\x.y.z]， [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6421Node\PHP\x.y] 和 [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6421Node\PHP\x]，其中的 x，y 和 z 指的是 PHP 主版本号，次版本号和发行批次。如果在其中任何目录下的 IniFilePath 有键值，则第一个值将被用作 php.ini 的位置（仅适用于 Windows）。
  • [HKEY_LOCAL_MACHINE\SOFTWARE\PHP] 内 IniFilePath 的值（Windows 注册表位置）。
  • 当前工作目录（对于 CLI）。
  • web 服务器目录（对于 SAPI 模块）或 PHP 所在目录（Windows 下其它情况）。
  • Windows 目录（C:\windows 或 C:\winnt），或 --with-config-file-path 编译时选项指定的位置。

如果存在 php-SAPI.ini（SAPI 是当前所用的 SAPI 名称，因此实际文件名为 php-cli.ini 或 php-apache.ini 等），则会用它替代 php.ini。SAPI 的名称可以用 php_sapi_name() 来测定。

Note:

Apache web 服务器在启动时会把目录转到根目录，这将导致 PHP 尝试在根目录下读取 php.ini，如果存在的话。

在 php.ini 中可以使用环境变量，如下示例：

Example #1 php.ini 中的环境变量

; PHP_MEMORY_LIMIT 来自于环境变量的值
memory_limit = ${PHP_MEMORY_LIMIT}

由扩展库处理的 php.ini 指令，其文档分别在各扩展库的页面。内核配置选项见附录。不过也许不是所有的 PHP 指令都在手册中有文档说明。要得到自己的 PHP 版本中的配置指令完整列表，请阅读 php.ini 文件，其中都有注释。此外，也许从 Git 得到的» 最新版 php.ini 也有帮助。

Example #2 php.ini 例子

; any text on a line after an unquoted semicolon (;) is ignored
[php] ; section markers (text within square brackets) are also ignored
; Boolean values can be set to either:
;    true, on, yes
; or false, off, no, none
register_globals = off
track_errors = yes

; you can enclose strings in double-quotes
include_path = ".:/usr/local/lib/php"

; backslashes are treated the same as any other character
include_path = ".;c:\php\lib"

自 PHP 5.1.0 起，有可能在 .ini 文件内引用已存在的 .ini 变量。例如：open_basedir = ${open_basedir} ":/new/dir"。

扫描路径配置

可以通过配置，让 PHP 在读完 php.ini 后，扫描指定路径中的附加 .ini 配置文件。编译时通过 --with-config-file-scan-dir 参数来指定要扫描的目录。自 PHP 5.2.0 起，扫描路径也可以通过环境变量 PHP_INI_SCAN_DIR 来设置。

通过在扫描路径配置中加入特定系统的目录分隔符（Windows、NetWare 和 RISC OS 下是 ;；其它操作系统下是 :；该值可以通过 PHP 常量 PATH_SEPARATOR 获取），还可以设置多个扫描路径。如果 PHP_INI_SCAN_DIR 为空，PHP 一样会扫描在编译时指定的 --with-config-file-scan-dir 此路径。

对于每个目录而言，PHP 会以首字符顺序为优先级，扫描该目录下所有的 .ini 结尾的配置文件。所有被截入的配置文件，可以通过 php_ini_scanned_files() 函数来获取列表，也可以通过 PHP 命令行加入 --ini 参数来查看。

以下假设 PHP 配置为 --with-config-file-scan-dir=/etc/php.d
并且目录分隔符为 :

$ php
  PHP 会加载 /etc/php.d/*.ini 全部配置文件。

$ PHP_INI_SCAN_DIR=/usr/local/etc/php.d php
  PHP 会加载 /usr/local/etc/php.d/*.ini 全部配置文件。

$ PHP_INI_SCAN_DIR=:/usr/local/etc/php.d php
  PHP 会加载 /etc/php.d/*.ini 下的全部配置文件，然后加载
  /usr/local/etc/php.d/*.ini 下的全部配置文件。

$ PHP_INI_SCAN_DIR=/usr/local/etc/php.d: php
  PHP 会加载 /usr/local/etc/php.d/*.ini 下的全部配置文件，然后加载
  /etc/php.d/*.ini 下的全部配置文件。

更新日志

版本 | 说明
7.0.0 | Hash 符号 (#) 不再被当做注释。
5.3.0 | Hash 符号 (#) 不应该被用于注释用，如果使用的话会抛出一个 warning 提醒。
5.2.0 | 允许设置 PHP_INI_SCAN_DIR 系统变量，来覆盖编译时指定的 "扫描路径" 配置。
5.1.0 | 可以从 .ini 文件中引用现有的 .ini 变量。


.user.ini 文件

自 PHP 5.3.0 起，PHP 支持基于每个目录的 INI 文件配置。此类文件 仅被 CGI／FastCGI SAPI 处理。此功能使得 PECL 的 htscanner 扩展作废。如果你的 PHP 以模块化运行在 Apache 里，则用 .htaccess 文件有同样效果。

除了主 php.ini 之外，PHP 还会在每个目录下扫描 INI 文件，从被执行的 PHP 文件所在目录开始一直上升到 web 根目录（$_SERVER['DOCUMENT_ROOT'] 所指定的）。如果被执行的 PHP 文件在 web 根目录之外，则只扫描该目录。

在 .user.ini 风格的 INI 文件中只有具有 PHP_INI_PERDIR 和 PHP_INI_USER 模式的 INI 设置可被识别。

两个新的 INI 指令， user_ini.filename 和 user_ini.cache_ttl 控制着用户 INI 文件的使用。

user_ini.filename 设定了 PHP 会在每个目录下搜寻的文件名；如果设定为空字符串则 PHP 不会搜寻。默认值是 .user.ini。

user_ini.cache_ttl 控制着重新读取用户 INI 文件的间隔时间。默认是 300 秒（5 分钟）。


配置可被设定范围

这些模式决定着一个 PHP 的指令在何时何地，是否能够被设定。手册中的每个指令都有其所属的模式。例如有些指令可以在 PHP 脚本中用 ini_set() 来设定，而有些则只能在 php.ini 或 httpd.conf 中。

例如 output_buffering 指令是属于 PHP_INI_PERDIR，因而就不能用 ini_set() 来设定。但是 display_errors 指令是属于 PHP_INI_ALL 因而就可以在任何地方被设定，包括 ini_set()。

PHP_INI_* 模式的定义
模式 | 含义
PHP_INI_USER | 可在用户脚本（例如 ini_set()）或 Windows 注册表（自 PHP 5.3 起）以及 .user.ini 中设定
PHP_INI_PERDIR | 可在 php.ini，.htaccess 或 httpd.conf 中设定
PHP_INI_SYSTEM | 可在 php.ini 或 httpd.conf 中设定
PHP_INI_ALL | 可在任何地方设定


怎样修改配置设定

PHP 运行于 Apache 模块方式

当使用 PHP 作为 Apache 模块时，也可以用 Apache 的配置文件（例如 httpd.conf）和 .htaccess 文件中的指令来修改 PHP 的配置设定。需要有"AllowOverride Options"或"AllowOverride All"权限才可以。

有几个 Apache 指令可以使用户在 Apache 配置文件内部修改 PHP 的配置。哪些指令属于 PHP_INI_ALL，PHP_INI_PERDIR 或 PHP_INI_SYSTEM 中的哪一个，请参考附录中的 php.ini 配置选项列表。

php_value name value

设定指定的值。只能用于 PHP_INI_ALL 或 PHP_INI_PERDIR 类型的指令。要清除先前设定的值，把 value 设为 none。

Note: 不要用 php_value 设定布尔值。应该用 php_flag（见下面）。

php_flag name on|off

用来设定布尔值的配置指令。仅能用于 PHP_INI_ALL 和 PHP_INI_PERDIR 类型的指令。

php_admin_value name value

设定指定的指令的值。不能用于 .htaccess 文件。任何用 php_admin_value 设定的指令都不能被 .htaccess 或 virtualhost 中的指令覆盖。要清除先前设定的值，把 value 设为 none。

php_admin_flag name on|off

用来设定布尔值的配置指令。不能用于 .htaccess 文件。任何用 php_admin_flag 设定的指令都不能被 .htaccess 或 virtualhost 中的指令覆盖。

Example #1 Apache 配置例子

<IfModule mod_php5.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag engine on
</IfModule>
<IfModule mod_php4.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag engine on
</IfModule>

Caution

PHP 常量不存在于 PHP 之外。例如在 httpd.conf 中不能使用 PHP 常量如 E_ALL 或 E_NOTICE 来设定 error_reporting 指令，因为其无意义，实际等于 0。应该用相应的掩码值来替代。这些常量可以在 php.ini 中使用。

通过 Windows 注册表修改 PHP 配置

在 Windows 下运行 PHP 时，可以用 Windows 注册表以目录为单位来修改配置。配置值存放于注册表项 HKLM\SOFTWARE\PHP\Per Directory Values 下面，子项对应于路径名。例如对于目录 c:\inetpub\wwwroot 的配置值会存放于 HKLM\SOFTWARE\PHP\Per Directory Values\c\inetpub\wwwroot 项下面。其中的设定对于任何位于此目录及其任何子目录的脚本都有效。项中的值的名称是 PHP 配置指令的名字，值的数据是字符串格式的指令值。值中的 PHP 常量不被解析。不过只有可修改范围是 PHP_INI_USER 的配置值可以用此方法设定，PHP_INI_PERDIR 的值就不行。因为这些配置对于每次请求来说是只读的。

其它接口下的 PHP

无论怎样运行 PHP，都可以在脚本中通过 ini_set() 而在运行时修改某个值。更多信息见手册中 ini_set() 的页面。

如果对自己系统中的配置设定及其当前值的完整列表感兴趣，可以运行
phpinfo() 函数并查看其结果的页面。也可以在运行时用
ini_get() 或
get_cfg_var() 取得个别配置指令的值。


语言参考

  • 基本语法
    • PHP 标记
    • 从 HTML 中分离
    • 指令分隔符
    • 注释
  • 类型
    • 简介
    • Boolean 布尔类型
    • Integer 整型
    • Float 浮点型
    • String 字符串
    • Numeric strings
    • Array 数组
    • Iterable 可迭代对象
    • Object 对象
    • Resource 资源类型
    • NULL
    • Callback / Callable 类型
    • 类型声明
    • 类型转换的判别
  • 变量
    • 基础
    • 预定义变量
    • 变量范围
    • 可变变量
    • 来自 PHP 之外的变量
  • 常量
    • 语法
    • 魔术常量
  • 表达式
  • 运算符
    • 运算符优先级
    • 算术运算符
    • 赋值运算符
    • 位运算符
    • 比较运算符
    • 错误控制运算符
    • 执行运算符
    • 递增／递减运算符
    • 逻辑运算符
    • 字符串运算符
    • 数组运算符
    • 类型运算符
  • 流程控制
    • 简介
    • if
    • else
    • elseif/else if
    • 流程控制的替代语法
    • while
    • do-while
    • for
    • foreach
    • break
    • continue
    • switch
    • match
    • declare
    • return
    • require
    • include
    • require_once
    • include_once
    • goto
  • 函数
    • 用户自定义函数
    • 函数的参数
    • 返回值
    • 可变函数
    • 内部（内置）函数
    • 匿名函数
    • 箭头函数
  • 类与对象
    • 简介
    • 基本概念
    • 属性
    • 类常量
    • 类的自动加载
    • 构造函数和析构函数
    • 访问控制（可见性）
    • 对象继承
    • 范围解析操作符 （::）
    • 静态（static）关键字
    • 抽象类
    • 对象接口
    • Trait
    • 匿名类
    • 重载
    • 遍历对象
    • 魔术方法
    • Final 关键字
    • 对象复制
    • 对象比较
    • 后期静态绑定
    • 对象和引用
    • 对象序列化
    • 协变与逆变
    • OOP 变更日志
  • 命名空间
    • 命名空间概述
    • 定义命名空间
    • 定义子命名空间
    • 在同一个文件中定义多个命名空间
    • 使用命名空间：基础
    • 命名空间和动态语言特征
    • namespace 关键字和 __NAMESPACE__ 常量
    • 使用命名空间：别名/导入
    • 全局空间
    • 使用命名空间：后备全局函数/常量
    • 名称解析规则
    • FAQ: things you need to know about namespaces
  • 错误
    • 基础概要
    • PHP 7 错误处理
  • 异常
    • 扩展（extend） 异常处理类
  • 生成器
    • 生成器总览
    • 生成器语法
    • 生成器与 Iterator 对象的比较
  • 注解
    • 注解概览
    • 注解语法
    • 使用反射 API 读取注解
    • 声明注解类
  • 引用的解释
    • 引用是什么
    • 引用做什么
    • 引用不是什么
    • 引用传递
    • 引用返回
    • 取消引用
    • 引用定位
  • 预定义变量
    • 超全局变量 — 超全局变量是在全部作用域中始终可用的内置变量
    • $GLOBALS — 引用全局作用域中可用的全部变量
    • $_SERVER — 服务器和执行环境信息
    • $_GET — HTTP GET 变量
    • $_POST — HTTP POST 变量
    • $_FILES — HTTP 文件上传变量
    • $_REQUEST — HTTP Request 变量
    • $_SESSION — Session 变量
    • $_ENV — 环境变量
    • $_COOKIE — HTTP Cookies
    • $php_errormsg — 前一个错误信息
    • $http_response_header — HTTP 响应头
    • $argc — 传递给脚本的参数数目
    • $argv — 传递给脚本的参数数组
  • 预定义异常
    • Exception
    • ErrorException
    • Error
    • ArgumentCountError
    • ArithmeticError
    • AssertionError
    • DivisionByZeroError
    • CompileError
    • ParseError
    • TypeError
  • 预定义接口
    • 遍历 — Traversable（遍历）接口
    • 迭代器 — Iterator（迭代器）接口
    • 聚合式迭代器 — IteratorAggregate（聚合式迭代器）接口
    • 数组式访问 — ArrayAccess（数组式访问）接口
    • 序列化 — 序列化接口
    • Closure — Closure 类
    • 生成器 — 生成器类
  • 上下文（Context）选项和参数
    • 套接字上下文选项 — 套接字上下文选项列表
    • HTTP context 选项 — HTTP context 的选项列表
    • FTP context options — FTP context option listing
    • SSL 上下文选项 — SSL 上下文选项清单
    • CURL context options — CURL 上下文选项列表
    • Phar 上下文（context）选项 — Phar 上下文（context）选项列表
    • MongoDB context options — MongoDB context option listing
    • Context 参数 — Context 参数列表
    • Zip context options — Zip context option listing
  • 支持的协议和封装协议
    • file:// — 访问本地文件系统
    • http:// — 访问 HTTP(s) 网址
    • ftp:// — 访问 FTP(s) URLs
    • php:// — 访问各个输入/输出流（I/O streams）
    • zlib:// — 压缩流
    • data:// — 数据（RFC 2397）
    • glob:// — 查找匹配的文件路径模式
    • phar:// — PHP 归档
    • ssh2:// — Secure Shell 2
    • rar:// — RAR
    • ogg:// — 音频流
    • expect:// — 处理交互式的流


基本语法

Table of Contents

  • PHP 标记
  • 从 HTML 中分离
  • 指令分隔符
  • 注释


PHP 标记

当解析一个文件时，PHP 会寻找起始和结束标记，也就是 <?php 和 ?>，这告诉 PHP 开始和停止解析二者之间的代码。此种解析方式使得 PHP 可以被嵌入到各种不同的文档中去，而任何起始和结束标记之外的部分都会被 PHP 解析器忽略。

PHP 有一个 echo 标记简写 <?=， 它是更完整的 <?php echo 的简写形式。

Example #1 PHP 开始和结束标记

1.  <?php echo 'if you want to serve PHP code in XHTML or XML documents,
                use these tags'; ?>

2.  You can use the short echo tag to <?= 'print this string' ?>.
    It's equivalent to <?php echo 'print this string' ?>.

3.  <? echo 'this code is within short tags, but will only work '.
            'if short_open_tag is enabled'; ?>

短标记 (第三个例子) 是被默认开启的，但是也可以通过 short_open_tag php.ini 来直接禁用。如果 PHP 在被安装时使用了 --disable-short-tags 的配置，该功能则是被默认禁用的。

Note:

因为短标记可以被禁用，所以建议使用普通标记 (<?php ?> 和 <?= ?>) 来最大化兼容性。

如果文件内容仅仅包含 PHP 代码，最好在文件末尾删除 PHP 结束标记。这可以避免在 PHP 结束标记之后万一意外加入了空格或者换行符，会导致 PHP 开始输出这些空白，而脚本中此时并无输出的意图。

<?php
echo "Hello world";

// ... more code

echo "Last statement";

// the script ends here with no PHP closing tag


从 HTML 中分离

凡是在一对开始和结束标记之外的内容都会被 PHP 解析器忽略，这使得 PHP 文件可以具备混合内容。 可以使 PHP 嵌入到 HTML 文档中去，如下例所示。

<p>This is going to be ignored by PHP and displayed by the browser.</p>
<?php echo 'While this is going to be parsed.'; ?>
<p>This will also be ignored by PHP and displayed by the browser.</p>
这将如预期中的运行，因为当 PHP 解释器碰到 ?> 结束标记时就简单地将其后内容原样输出（除非马上紧接换行 - 见 指令分隔符）直到碰到下一个开始标记；例外是处于条件语句中间时，此时 PHP 解释器会根据条件判断来决定哪些输出，哪些跳过。见下例。

使用条件结构：

Example #1 使用条件的高级分离术

<?php if ($expression == true): ?>
  This will show if the expression is true.
<?php else: ?>
  Otherwise this will show.
<?php endif; ?>
上例中 PHP 将跳过条件语句未达成的段落，即使该段落位于 PHP 开始和结束标记之外。由于 PHP 解释器会在条件未达成时直接跳过该段条件语句块，因此 PHP 会根据条件来忽略之。

要输出大段文本时，跳出 PHP 解析模式通常比将文本通过 echo 或 print 输出更有效率。

Note:

此外注意如果将 PHP 嵌入到 XML 或 XHTML 中则需要使用 <?php ?> 标记以保持符合标准。


指令分隔符

同 C 或 Perl 一样，PHP 需要在每个语句后用分号结束指令。一段 PHP 代码中的结束标记隐含表示了一个分号；在一个 PHP 代码段中的最后一行可以不用分号结束。如果后面还有新行，则代码段的结束标记包含了行结束。

Example #1 包含末尾换行符的结束标记的例子

<?php echo "Some text"; ?>
No newline
<?= "But newline now" ?>

以上例程会输出：

Some textNo newline
But newline now

进入和退出 PHP 解析的例子：

<?php
    echo 'This is a test';
?>

<?php echo 'This is a test' ?>

<?php echo 'We omitted the last closing tag';

Note:

文件末尾的 PHP 代码段结束标记可以不要，有些情况下当使用 include 或者 require 时省略掉会更好些，这样不期望的空白符就不会出现在文件末尾，之后仍然可以输出响应标头。在使用输出缓冲时也很便利，就不会看到由包含文件生成的不期望的空白符。


注释

PHP 支持 C，C++ 和 Unix Shell 风格（Perl 风格）的注释。例如:

<?php
    echo 'This is a test'; // This is a one-line c++ style comment
    /* This is a multi line comment
       yet another line of comment */
    echo 'This is yet another test';
    echo 'One Final Test'; # This is a one-line shell-style comment
?>

单行注释仅仅注释到行末或者当前的 PHP 代码块，视乎哪个首先出现。这意味着在 // ... ?> 或者 # ... ?> 之后的 HTML 代码将被显示出来：?> 跳出了 PHP 模式并返回了 HTML 模式，// 或 # 并不能影响到这一点。

<h1>This is an <?php # echo 'simple';?> example</h1>
<p>The header above will say 'This is an  example'.</p>

C 风格的注释在碰到第一个 */ 时结束。要确保不要嵌套 C 风格的注释。试图注释掉一大块代码时很容易出现该错误。

<?php
 /*
    echo 'This is a test'; /* This comment will cause a problem */
 */
?>


类型

Table of Contents

  • 简介
  • Boolean 布尔类型
  • Integer 整型
  • Float 浮点型
  • String 字符串
  • Numeric strings
  • Array 数组
  • Iterable 可迭代对象
  • Object 对象
  • Resource 资源类型
  • NULL
  • Callback / Callable 类型
  • 类型声明
  • 类型转换的判别


简介

PHP 支持 10 种原始数据类型。

四种标量类型：

  • bool（布尔型）
  • int（整型）
  • float（浮点型，也称作 double)
  • string（字符串）

四种复合类型：

  • array（数组）
  • object（对象）
  • callable（可调用）
  • iterable（可迭代）

最后是两种特殊类型：

  • resource（资源）
  • NULL（无类型）

可能还会读到一些关于"双精度（double）"类型的参考。实际上 double 和 float 是相同的，由于一些历史的原因，这两个名称同时存在。

变量的类型通常不是由程序员设定的，确切地说，是由 PHP 根据该变量使用的上下文在运行时决定的。

Note: 如果想查看某个表达式的值和类型，用 var_dump() 函数。

如果只是想得到一个易读懂的类型的表达方式用于调试，用 gettype() 函数。要检验某个类型，不要用 gettype()，而用 is_type 函数。以下是一些范例：

<?php
$a_bool = TRUE;   // 布尔值 boolean
$a_str  = "foo";  // 字符串 string
$a_str2 = 'foo';  // 字符串 string
$an_int = 12;     // 整型 integer

echo gettype($a_bool); // 输出:  boolean
echo gettype($a_str);  // 输出:  string

// 如果是整型，就加上 4
if (is_int($an_int)) {
    $an_int += 4;
}

// 如果 $bool 是字符串，就打印出来
// (啥也没打印出来)
if (is_string($a_bool)) {
    echo "String: $a_bool";
}
?>

如果要将一个变量强制转换为某类型，可以对其使用强制转换或者 settype() 函数。

注意变量根据其当时的类型在特定场合下会表现出不同的值。更多信息见类型转换的判别。此外，还可以参考 PHP 类型比较表看不同类型相互比较的例子。


Boolean 布尔类型

这是最简单的类型。boolean 表达了真值，可以为 true 或 false。

语法

要指定一个布尔值，使用常量 true 或 false。两个都不区分大小写。

<?php
$foo = True; // 设置 $foo 为 TRUE
?>

通常运算符所返回的 boolean 值结果会被传递给控制流程。

<?php
// == 是一个操作符，它检测两个变量是否相等，并返回一个布尔值
if ($action == "show_version") {
    echo "The version is 1.23";
}

// 这样做是不必要的...
if ($show_separators == TRUE) {
    echo "<hr>\n";
}

// ...因为可以使用下面这种简单的方式：
if ($show_separators) {
    echo "<hr>\n";
}
?>

转换为布尔值

要明确地将一个值转换成 boolean，用 (bool) 或者 (boolean) 来强制转换。但是很多情况下不需要用强制转换，因为当运算符，函数或者流程控制结构需要一个 boolean 参数时，该值会被自动转换。

参见类型转换的判别。

当转换为 boolean 时，以下值被认为是 false：

  • 布尔值 false 本身
  • 整型值 0（零）及 -0 (零)
  • 浮点型值 0.0（零）-0.0(零)
  • 空字符串，以及字符串 "0"
  • 不包括任何元素的数组
  • 特殊类型 NULL（包括尚未赋值的变量）
  • 从空标记生成的 SimpleXML 对象

所有其它值都被认为是 true（包括任何资源 和 NAN）。

Warning

-1 和其它非零值（不论正负）一样，被认为是 true！

<?php
var_dump((bool) "");        // bool(false)
var_dump((bool) 1);         // bool(true)
var_dump((bool) -2);        // bool(true)
var_dump((bool) "foo");     // bool(true)
var_dump((bool) 2.3e5);     // bool(true)
var_dump((bool) array(12)); // bool(true)
var_dump((bool) array());   // bool(false)
var_dump((bool) "false");   // bool(true)
?>


Integer 整型

integer 是集合 ? = {..., -2, -1, 0, 1, 2, ...} 中的某个数。

参见：

  • 任意长度整数／GMP
  • 浮点型
  • 任意精度数学库／BCMath

语法

整型值可以使用十进制，十六进制，八进制或二进制表示，前面可以加上可选的符号（- 或者 +）。 可以用 负运算符 来表示一个负的integer。

二进制表达的 integer 自 PHP 5.4.0 起可用。

要使用八进制表达，数字前必须加上 0（零）。要使用十六进制表达，数字前必须加上 0x。要使用二进制表达，数字前必须加上 0b。

从 PHP 7.4.0 开始，整型数值可能会包含下划线 (_)，为了更好的阅读体验，这些下划线在展示的时候，会被 PHP 过滤掉。

Example #1 整数文字表达

<?php
$a = 1234; // 十进制数
$a = 0123; // 八进制数 (等于十进制 83)
$a = 0x1A; // 十六进制数 (等于十进制 26)
$a = 0b11111111; // 二进制数字 (等于十进制 255)
$a = 1_234_567; // 整型数值 (PHP 7.4.0 以后)
?>

integer 语法的结构形式是（PHP 7.4.0 之前不支持下划线）：

decimal     : [1-9][0-9]*(_[0-9]+)*
            | 0

hexadecimal : 0[xX][0-9a-fA-F]+(_[0-9a-fA-F]+)*

octal       : 0[0-7]+(_[0-7]+)*

binary      : 0[bB][01]+(_[01]+)*

integer     : decimal
            | hexadecimal
            | octal
            | binary

整型数的字长和平台有关，尽管通常最大值是大约二十亿（32 位有符号）。64 位平台下的最大值通常是大约 9E18，除了 Windows 下 PHP 7 以前的版本，总是 32 位的。 PHP 不支持无符号的 integer。Integer 值的字长可以用常量 PHP_INT_SIZE来表示，自 PHP 4.4.0 和 PHP 5.0.5后，最大值可以用常量 PHP_INT_MAX 来表示，最小值可以在 PHP 7.0.0 及以后的版本中用常量 PHP_INT_MIN 表示。

Warning

PHP 7 以前的版本里，如果向八进制数传递了一个非法数字（即 8 或 9），则后面其余数字会被忽略。PHP 7 以后，会产生 Parse Error。

整数溢出

如果给定的一个数超出了 integer 的范围，将会被解释为 float。同样如果执行的运算结果超出了 integer 范围，也会返回 float。

Example #2 32 位系统下的整数溢出

<?php
$large_number = 2147483647;
var_dump($large_number);                     // int(2147483647)

$large_number = 2147483648;
var_dump($large_number);                     // float(2147483648)

$million = 1000000;
$large_number =  50000 * $million;
var_dump($large_number);                     // float(50000000000)
?>

Example #3 64 位系统下的整数溢出

<?php
$large_number = 9223372036854775807;
var_dump($large_number);                     // int(9223372036854775807)

$large_number = 9223372036854775808;
var_dump($large_number);                     // float(9.2233720368548E+18)

$million = 1000000;
$large_number =  50000000000000 * $million;
var_dump($large_number);                     // float(5.0E+19)
?>

PHP 中没有整除的运算符。1/2 产生出 float 0.5。 值可以舍弃小数部分，强制转换为 integer，或者使用 round() 函数可以更好地进行四舍五入。

Note: 从 PHP 7.0.0 开始，函数 intdiv() 可以用于整数除法。

<?php
var_dump(25/7);         // float(3.5714285714286)
var_dump((int) (25/7)); // int(3)
var_dump(round(25/7));  // float(4)
?>

转换为整型

要明确地将一个值转换为 integer，用 (int) 或 (integer) 强制转换。不过大多数情况下都不需要强制转换，因为当运算符，函数或流程控制需要一个 integer 参数时，值会自动转换。还可以通过函数 intval() 来将一个值转换成整型。

将 resource 转换成 integer 时， 结果会是 PHP 运行时为 resource 分配的唯一资源号。

参见：类型转换的判别。

从布尔值转换

false 将产生出 0（零），true 将产生出 1（壹）。

从浮点型转换

当从浮点数转换成整数时，将向下取整。

如果浮点数超出了整数范围（32 位平台下通常为 +/- 2.15e+9 = 2^31，64 位平台下，除了 Windows 且版本低于 PHP 7，通常为 +/- 9.22e+18 = 2^63），则结果为未定义，因为没有足够的精度给出一个确切的整数结果。在此情况下没有警告，甚至没有任何通知！

Note:

PHP 7.0.0 起，NaN 和 Infinity 在转换成 integer 时，不再是 undefined 或者依赖于平台，而是都会变成零。

Warning

绝不要将未知的分数强制转换为 integer，这样有时会导致不可预料的结果。

<?php
echo (int) ( (0.1+0.7) * 10 ); // 显示 7!
?>

参见关于浮点数精度的警告。

从字符串转换

参见字符串转换为数值。

从 NULL 转换

null 会转换为零 (0)。

从其它类型转换

Caution

没有定义从其它类型转换为整型的行为。不要依赖任何现有的行为，因为它会未加通知地改变。


Float 浮点型

浮点型（也叫浮点数 float，双精度数 double 或实数 real）可以用以下任一语法定义：

<?php
$a = 1.234;
$b = 1.2e3;
$c = 7E-10;
$d = 1_234.567; // 从 PHP 7.4.0 开始支持
?>

浮点数的形式表示（PHP 7.4.0 之前不支持下划线）：

LNUM          [0-9]+(_[0-9]+)*
DNUM          ([0-9]*(_[0-9]+)*[\.]{LNUM}) | ({LNUM}[\.][0-9]*(_[0-9]+)*)
EXPONENT_DNUM (({LNUM} | {DNUM}) [eE][+-]? {LNUM})

浮点数的字长和平台相关，尽管通常最大值是 1.8e308 并具有 14 位十进制数字的精度（64 位 IEEE 格式）。

Warning

浮点数的精度

浮点数的精度有限。尽管取决于系统，PHP 通常使用 IEEE 754 双精度格式，则由于取整而导致的最大相对误差为 1.11e-16。非基本数学运算可能会给出更大误差，并且要考虑到进行复合运算时的误差传递。

此外，以十进制能够精确表示的有理数如 0.1 或 0.7，无论有多少尾数都不能被内部所使用的二进制精确表示，因此不能在不丢失一点点精度的情况下转换为二进制的格式。这就会造成混乱的结果：例如，floor((0.1+0.7)*10) 通常会返回 7 而不是预期中的 8，因为该结果内部的表示其实是类似 7.9999999999999991118...。

所以永远不要相信浮点数结果精确到了最后一位，也永远不要比较两个浮点数是否相等。如果确实需要更高的精度，应该使用任意精度数学函数或者 gmp 函数。

参见» 浮点数指南网页的简单解释。

转换为浮点数

如果希望了解有关何时和如何将字符串转换成浮点数的信息，请参阅"字符串转换为数值"一节。对于其它类型的值，其情况类似于先将值转换成整型，然后再转换成浮点。请参阅"转换为整型"一节以获取更多信息。自 PHP 5 起，如果试图将对象转换为浮点数，会发出一条 E_NOTICE 错误消息。

比较浮点数

如上述警告信息所言，由于内部表达方式的原因，比较两个浮点数是否相等是有问题的。不过还是有迂回的方法来比较浮点数值的。

要测试浮点数是否相等，要使用一个仅比该数值大一丁点的最小误差值。该值也被称为机器极小值（epsilon）或最小单元取整数，是计算中所能接受的最小的差别值。

$a 和 $b 在小数点后五位精度内都是相等的。

<?php
$a = 1.23456789;
$b = 1.23456780;
$epsilon = 0.00001;

if(abs($a-$b) < $epsilon) {
    echo "true";
}
?>

NaN

某些数学运算会产生一个由常量 NAN 所代表的结果。此结果代表着一个在浮点数运算中未定义或不可表述的值。任何拿此值与其它任何值（除了 true）进行的松散或严格比较的结果都是 false。

由于 NAN 代表着任何不同值，不应拿 NAN 去和其它值进行比较，包括其自身，应该用 is_nan() 来检查。


String 字符串

一个字符串 string 就是由一系列的字符组成，其中每个字符等同于一个字节。这意味着 PHP 只能支持 256 的字符集，因此不支持 Unicode 。详见字符串类型详解。

Note: string 最大可以达到 2GB。

语法

一个字符串可以用 4 种方式表达：

  • 单引号
  • 双引号
  • heredoc 语法结构
  • nowdoc 语法结构（自 PHP 5.3.0 起）

单引号

定义一个字符串的最简单的方法是用单引号把它包围起来（字符 '）。

要表达一个单引号自身，需在它的前面加个反斜线（\）来转义。要表达一个反斜线自身，则用两个反斜线（\\）。其它任何方式的反斜线都会被当成反斜线本身：也就是说如果想使用其它转义序列例如 \r 或者 \n，并不代表任何特殊含义，就单纯是这两个字符本身。

Note: 不像双引号和 heredoc 语法结构，在单引号字符串中的变量和特殊字符的转义序列将不会被替换。

<?php
echo 'this is a simple string';

// 可以录入多行
echo 'You can also have embedded newlines in
strings this way as it is
okay to do';

// 输出： Arnold once said: "I'll be back"
echo 'Arnold once said: "I\'ll be back"';

// 输出： You deleted C:\*.*?
echo 'You deleted C:\\*.*?';

// 输出： You deleted C:\*.*?
echo 'You deleted C:\*.*?';

// 输出： This will not expand: \n a newline
echo 'This will not expand: \n a newline';

// 输出： Variables do not $expand $either
echo 'Variables do not $expand $either';
?>

双引号

如果字符串是包围在双引号（"）中， PHP 将对一些特殊的字符进行解析：

转义字符
序列 | 含义
\n | 换行（ASCII 字符集中的 LF 或 0x0A (10)）
\r | 回车（ASCII 字符集中的 CR 或 0x0D (13)）
\t | 水平制表符（ASCII 字符集中的 HT 或 0x09 (9)）
\v | 垂直制表符（ASCII 字符集中的 VT 或 0x0B (11)）（自 PHP 5.2.5 起）
\e | Escape（ASCII 字符集中的 ESC 或 0x1B (27)）（自 PHP 5.4.0 起）
\f | 换页（ASCII 字符集中的 FF 或 0x0C (12)）（自 PHP 5.2.5 起）
\\ | 反斜线
\$ | 美元标记
\" | 双引号
\[0-7]{1,3} | 符合该正则表达式序列的是一个以八进制方式来表达的字符
\x[0-9A-Fa-f]{1,2} | 符合该正则表达式序列的是一个以十六进制方式来表达的字符

和单引号字符串一样，转义任何其它字符都会导致反斜线被显示出来。PHP 5.1.1 以前，\{$var} 中的反斜线还不会被显示出来。

用双引号定义的字符串最重要的特征是变量会被解析，详见变量解析。

Heredoc 结构

第三种表达字符串的方法是用 heredoc 句法结构：<<<。在该运算符之后要提供一个标识符，然后换行。接下来是字符串 string 本身，最后要用前面定义的标识符作为结束标志。

结束时所引用的标识符必须在该行的第一列，而且，标识符的命名也要像其它标签一样遵守 PHP 的规则：只能包含字母、数字和下划线，并且必须以字母和下划线作为开头。

Warning

要注意的是结束标识符这行除了可能有一个分号（;）外，绝对不能包含其它字符。这意味着标识符不能缩进，分号的前后也不能有任何空白或制表符。更重要的是结束标识符的前面必须是个被本地操作系统认可的换行，比如在 UNIX 和 Mac OS X 系统中是 \n，而结束定界符（可能其后有个分号）之后也必须紧跟一个换行。

如果不遵守该规则导致结束标识不"干净"，PHP 将认为它不是结束标识符而继续寻找。如果在文件结束前也没有找到一个正确的结束标识符，PHP 将会在最后一行产生一个解析错误。

Heredocs 结构不能用来初始化类的属性。自 PHP 5.3 起，此限制仅对 heredoc 包含变量时有效。

Example #1 非法的示例

<?php
class foo {
    public $bar = <<<EOT
bar
    EOT;
}
?>

Heredoc 结构就象是没有使用双引号的双引号字符串，这就是说在 heredoc 结构中单引号不用被转义，但是上文中列出的转义序列还可以使用。变量将被替换，但在 heredoc 结构中含有复杂的变量时要格外小心。

Example #2 Heredoc 结构的字符串示例

<?php
$str = <<<EOD
Example of string
spanning multiple lines
using heredoc syntax.
EOD;

/* 含有变量的更复杂示例 */
class foo
{
    var $foo;
    var $bar;

    function foo()
    {
        $this->foo = 'Foo';
        $this->bar = array('Bar1', 'Bar2', 'Bar3');
    }
}

$foo = new foo();
$name = 'MyName';

echo <<<EOT
My name is "$name". I am printing some $foo->foo.
Now, I am printing some {$foo->bar[1]}.
This should print a capital 'A': \x41
EOT;
?>

以上例程会输出：

My name is "MyName". I am printing some Foo.
Now, I am printing some Bar2.
This should print a capital 'A': A

也可以把 Heredoc 结构用在函数参数中来传递数据：

Example #3 Heredoc 结构在参数中的示例

<?php
var_dump(array(<<<EOD
foobar!
EOD
));
?>

在 PHP 5.3.0 以后，也可以用 Heredoc 结构来初始化静态变量和类的属性和常量：

Example #4 使用 Heredoc 结构来初始化静态值

<?php
// 静态变量
function foo()
{
    static $bar = <<<LABEL
Nothing in here...
LABEL;
}

// 类的常量、属性
class foo
{
    const BAR = <<<FOOBAR
Constant example
FOOBAR;

    public $baz = <<<FOOBAR
Property example
FOOBAR;
}
?>

自 PHP 5.3.0 起还可以在 Heredoc 结构中用双引号来声明标识符：

Example #5 在 heredoc 结构中使用双引号

<?php
echo <<<"FOOBAR"
Hello World!
FOOBAR;
?>

Nowdoc 结构

就象 heredoc 结构类似于双引号字符串，Nowdoc 结构是类似于单引号字符串的。Nowdoc 结构很象 heredoc 结构，但是 nowdoc 中不进行解析操作。这种结构很适合用于嵌入 PHP 代码或其它大段文本而无需对其中的特殊字符进行转义。与 SGML 的 <![CDATA[ ]]> 结构是用来声明大段的不用解析的文本类似，nowdoc 结构也有相同的特征。

一个 nowdoc 结构也用和 heredocs 结构一样的标记 <<<， 但是跟在后面的标识符要用单引号括起来，即 <<<'EOT'。Heredoc 结构的所有规则也同样适用于 nowdoc 结构，尤其是结束标识符的规则。

Example #6 Nowdoc 结构字符串示例

<?php
$str = <<<'EOD'
Example of string
spanning multiple lines
using nowdoc syntax.
EOD;

/* 含有变量的更复杂的示例 */
class foo
{
    public $foo;
    public $bar;

    function foo()
    {
        $this->foo = 'Foo';
        $this->bar = array('Bar1', 'Bar2', 'Bar3');
    }
}

$foo = new foo();
$name = 'MyName';

echo <<<'EOT'
My name is "$name". I am printing some $foo->foo.
Now, I am printing some {$foo->bar[1]}.
This should not print a capital 'A': \x41
EOT;
?>

以上例程会输出：

My name is "$name". I am printing some $foo->foo.
Now, I am printing some {$foo->bar[1]}.
This should not print a capital 'A': \x41

Note:

不象 heredoc 结构，nowdoc 结构可以用在任意的静态数据环境中，最典型的示例是用来初始化类的属性或常量：

Example #7 静态数据的示例

<?php
class foo {
    public $bar = <<<'EOT'
bar
EOT;
}
?>

Note:

Nowdoc 结构是在 PHP 5.3.0 中加入的。

变量解析

当字符串用双引号或 heredoc 结构定义时，其中的变量将会被解析。

这里共有两种语法规则：一种简单规则，一种复杂规则。简单的语法规则是最常用和最方便的，它可以用最少的代码在一个 string 中嵌入一个变量，一个 array 的值，或一个 object 的属性。

复杂规则语法的显著标记是用花括号包围的表达式。

简单语法

当 PHP 解析器遇到一个美元符号（$）时，它会和其它很多解析器一样，去组合尽量多的标识以形成一个合法的变量名。可以用花括号来明确变量名的界线。

<?php
$juice = "apple";

echo "He drank some $juice juice.".PHP_EOL;
// Invalid. "s" is a valid character for a variable name, but the variable is $juice.
echo "He drank some juice made of $juices.";
?>

以上例程会输出：

He drank some apple juice.
He drank some juice made of .

类似的，一个 array 索引或一个 object 属性也可被解析。数组索引要用方括号（]）来表示索引结束的边际，对象属性则是和上述的变量规则相同。

Example #8 简单语法示例

<?php
$juices = array("apple", "orange", "koolaid1" => "purple");

echo "He drank some $juices[0] juice.".PHP_EOL;
echo "He drank some $juices[1] juice.".PHP_EOL;
echo "He drank some juice made of $juice[0]s.".PHP_EOL; // Won't work
echo "He drank some $juices[koolaid1] juice.".PHP_EOL;

class people {
    public $john = "John Smith";
    public $jane = "Jane Smith";
    public $robert = "Robert Paulsen";

    public $smith = "Smith";
}

$people = new people();

echo "$people->john drank some $juices[0] juice.".PHP_EOL;
echo "$people->john then said hello to $people->jane.".PHP_EOL;
echo "$people->john's wife greeted $people->robert.".PHP_EOL;
echo "$people->robert greeted the two $people->smiths."; // Won't work
?>

以上例程会输出：

He drank some apple juice.
He drank some orange juice.
He drank some juice made of s.
He drank some purple juice.
John Smith drank some apple juice.
John Smith then said hello to Jane Smith.
John Smith's wife greeted Robert Paulsen.
Robert Paulsen greeted the two .

如果想要表达更复杂的结构，请用复杂语法。

复杂（花括号）语法

复杂语法不是因为其语法复杂而得名，而是因为它可以使用复杂的表达式。

任何具有 string 表达的标量变量，数组单元或对象属性都可使用此语法。只需简单地像在 string 以外的地方那样写出表达式，然后用花括号 { 和 } 把它括起来即可。由于 { 无法被转义，只有 $ 紧挨着 { 时才会被识别。可以用 {\$ 来表达 {$。下面的示例可以更好的解释：

<?php
// 显示所有错误
error_reporting(E_ALL);

$great = 'fantastic';

// 无效，输出: This is { fantastic}
echo "This is { $great}";

// 有效，输出： This is fantastic
echo "This is {$great}";
echo "This is ${great}";

// 有效
echo "This square is {$square->width}00 centimeters broad.";

// 有效，只有通过花括号语法才能正确解析带引号的键名
echo "This works: {$arr['key']}";

// 有效
echo "This works: {$arr[4][3]}";

// 这是错误的表达式，因为就象 $foo[bar] 的格式在字符串以外也是错的一样。
// 换句话说，只有在 PHP 能找到常量 foo 的前提下才会正常工作；这里会产生一个
// E_NOTICE (undefined constant) 级别的错误。
echo "This is wrong: {$arr[foo][3]}";

// 有效，当在字符串中使用多重数组时，一定要用括号将它括起来
echo "This works: {$arr['foo'][3]}";

// 有效
echo "This works: " . $arr['foo'][3];

echo "This works too: {$obj->values[3]->name}";

echo "This is the value of the var named $name: {${$name}}";

echo "This is the value of the var named by the return value of getName(): {${getName()}}";

echo "This is the value of the var named by the return value of \$object->getName(): {${$object->getName()}}";

// 无效，输出： This is the return value of getName(): {getName()}
echo "This is the return value of getName(): {getName()}";
?>

也可以在字符串中用此语法通过变量来调用类的属性。

<?php
class foo {
    var $bar = 'I am bar.';
}

$foo = new foo();
$bar = 'bar';
$baz = array('foo', 'bar', 'baz', 'quux');
echo "{$foo->$bar}\n";
echo "{$foo->{$baz[1]}}\n";
?>

以上例程会输出：

I am bar.
I am bar.

Note:

函数、方法、静态类变量和类常量只有在 PHP 5 以后才可在 {$} 中使用。然而，只有在该字符串被定义的命名空间中才可以将其值作为变量名来访问。只单一使用花括号 ({}) 无法处理从函数或方法的返回值或者类常量以及类静态变量的值。

<?php
// 显示所有错误
error_reporting(E_ALL);

class beers {
    const softdrink = 'rootbeer';
    public static $ale = 'ipa';
}

$rootbeer = 'A & W';
$ipa = 'Alexander Keith\'s';

// 有效，输出： I'd like an A & W
echo "I'd like an {${beers::softdrink}}\n";

// 也有效，输出： I'd like an Alexander Keith's
echo "I'd like an {${beers::$ale}}\n";
?>

存取和修改字符串中的字符

string 中的字符可以通过一个从 0 开始的下标，用类似 array 结构中的方括号包含对应的数字来访问和修改，比如 $str[42]。可以把 string 当成字符组成的 array。函数 substr() 和 substr_replace() 可用于操作多于一个字符的情况。

Note: string 也可用花括号访问，比如 $str{42}。

Warning

用超出字符串长度的下标写入将会拉长该字符串并以空格填充。非整数类型下标会被转换成整数。非法下标类型会产生一个 E_NOTICE 级别错误。用负数下标写入字符串时会产生一个 E_NOTICE 级别错误，用负数下标读取字符串时返回空字符串。写入时只用到了赋值字符串的第一个字符。用空字符串赋值则赋给的值是 NULL 字符。

Warning

PHP 的字符串在内部是字节组成的数组。因此用花括号访问或修改字符串对多字节字符集很不安全。仅应对单字节编码例如 ISO-8859-1 的字符串进行此类操作。

Example #9 一些字符串示例

<?php
// 取得字符串的第一个字符
$str = 'This is a test.';
$first = $str[0];

// 取得字符串的第三个字符
$third = $str[2];

// 取得字符串的最后一个字符
$str = 'This is still a test.';
$last = $str[strlen($str)-1];

// 修改字符串的最后一个字符
$str = 'Look at the sea';
$str[strlen($str)-1] = 'e';

?>

自 PHP 5.4 起字符串下标必须为整数或可转换为整数的字符串，否则会发出警告。之前类似 "foo" 的下标会无声地转换成 0。

Example #10 PHP 5.3 和 PHP 5.4 的区别

<?php
$str = 'abc';

var_dump($str['1']);
var_dump(isset($str['1']));

var_dump($str['1.0']);
var_dump(isset($str['1.0']));

var_dump($str['x']);
var_dump(isset($str['x']));

var_dump($str['1x']);
var_dump(isset($str['1x']));
?>

以上例程在 PHP 5.3 中的输出：

string(1) "b"
bool(true)
string(1) "b"
bool(true)
string(1) "a"
bool(true)
string(1) "b"
bool(true)

以上例程在 PHP 5.4 中的输出：

string(1) "b"
bool(true)

Warning: Illegal string offset '1.0' in /tmp/t.php on line 7
string(1) "b"
bool(false)

Warning: Illegal string offset 'x' in /tmp/t.php on line 9
string(1) "a"
bool(false)
string(1) "b"
bool(false)

Note:

用 [] 或 {} 访问任何其它类型（不包括数组或具有相应接口的对象实现）的变量只会无声地返回 null。

Note:

PHP 5.5 增加了直接在字符串原型中用 [] 或 {} 访问字符的支持。

有用的函数和运算符

字符串可以用 '.'（点）运算符连接起来，注意 '+'（加号）运算符没有这个功能。更多信息参考字符串运算符。

对于 string 的操作有很多有用的函数。

可以参考字符串函数了解大部分函数，高级的查找与替换功能可以参考正则表达式函数或 Perl 兼容正则表达式函数。

另外还有 URL 字符串函数，也有加密／解密字符串的函数（mcrypt 和 mhash）。

最后，可以参考字符类型函数。

转换成字符串

一个值可以通过在其前面加上 (string) 或用 strval() 函数来转变成字符串。在一个需要字符串的表达式中，会自动转换为 string。比如在使用函数 echo 或 print 时，或在一个变量和一个 string 进行比较时，就会发生这种转换。类型和类型转换可以更好的解释下面的事情，也可参考函数 settype()。

一个布尔值 boolean 的 true 被转换成 string 的 "1"。Boolean 的 false 被转换成 ""（空字符串）。这种转换可以在 boolean 和 string 之间相互进行。

一个整数 integer 或浮点数 float 被转换为数字的字面样式的 string（包括 float 中的指数部分）。使用指数计数法的浮点数（4.1E+6）也可转换。

Note:

在脚本的区域（category LC_NUMERIC）中定义了十进制小数点字符。参见 setlocale()。

数组 array 总是转换成字符串 "Array"，因此，echo 和 print 无法显示出该数组的内容。要显示某个单元，可以用 echo $arr['foo'] 这种结构。要显示整个数组内容见下文。

在 PHP 4 中对象 object 总是被转换成字符串 "Object"，如果为了调试原因需要打印出对象的值，请继续阅读下文。为了得到对象的类的名称，可以用 get_class() 函数。自 PHP 5 起，适当时可以用 __toString 方法。

资源 resource 总会被转变成 "Resource id #1" 这种结构的字符串，其中的 1 是 PHP 在运行时分配给该 resource 的唯一值。不要依赖此结构，可能会有变更。要得到一个 resource 的类型，可以用函数 get_resource_type()。

null 总是被转变成空字符串。

如上面所说的，直接把 array，object 或 resource 转换成 string 不会得到除了其类型之外的任何有用信息。可以使用函数 print_r() 和 var_dump() 列出这些类型的内容。

大部分的 PHP 值可以转变成 string 来永久保存，这被称作串行化，可以用函数 serialize() 来实现。如果 PHP 引擎设定支持 WDDX，PHP 值也可被串行化为格式良好的 XML 文本。

字符串转换为数值

当一个字符串被当作一个数值来取值，其结果和类型如下：

如果该字符串没有包含 '.'，'e' 或 'E' 并且其数字值在整型的范围之内（由 PHP_INT_MAX 所定义），该字符串将被当成 integer 来取值。其它所有情况下都被作为 float 来取值。

该字符串的开始部分决定了它的值。如果该字符串以合法的数值开始，则使用该数值。否则其值为 0（零）。合法数值由可选的正负号，后面跟着一个或多个数字（可能有小数点），再跟着可选的指数部分。指数部分由 'e' 或 'E' 后面跟着一个或多个数字构成。

<?php
$foo = 1 + "10.5";                // $foo is float (11.5)
$foo = 1 + "-1.3e3";              // $foo is float (-1299)
$foo = 1 + "bob-1.3e3";           // $foo is integer (1)
$foo = 1 + "bob3";                // $foo is integer (1)
$foo = 1 + "10 Small Pigs";       // $foo is integer (11)
$foo = 4 + "10.2 Little Piggies"; // $foo is float (14.2)
$foo = "10.0 pigs " + 1;          // $foo is float (11)
$foo = "10.0 pigs " + 1.0;        // $foo is float (11)
?>

更多信息可以参考 Unix 手册中的 strtod(3)。

本节中的示例可以通过复制／粘贴到下面的代码中来显示：

<?php
echo "\$foo==$foo; type is " . gettype ($foo) . "<br />\n";
?>

不要想像在 C 语言中的那样，通过将一个字符转换成整数以得到其代码。使用函数 ord() 和 chr() 实现 ASCII 码和字符间的转换。

字符串类型详解

PHP 中的 string 的实现方式是一个由字节组成的数组再加上一个整数指明缓冲区长度。并无如何将字节转换成字符的信息，由程序员来决定。字符串由什么值来组成并无限制；特别的，其值为 0（"NUL bytes"）的字节可以处于字符串任何位置（不过有几个函数，在本手册中被称为非"二进制安全"的，也许会把 NUL 字节之后的数据全都忽略）。

字符串类型的此特性解释了为什么 PHP 中没有单独的"byte"类型 - 已经用字符串来代替了。返回非文本值的函数 - 例如从网络套接字读取的任意数据 - 仍会返回字符串。

由于 PHP 并不特别指明字符串的编码，那字符串到底是怎样编码的呢？例如字符串 "á" 到底是等于 "\xE1"（ISO-8859-1），"\xC3\xA1"（UTF-8，C form），"\x61\xCC\x81"（UTF-8，D form）还是任何其它可能的表达呢？答案是字符串会被按照该脚本文件相同的编码方式来编码。因此如果一个脚本的编码是 ISO-8859-1，则其中的字符串也会被编码为 ISO-8859-1，以此类推。不过这并不适用于激活了 Zend Multibyte 时；此时脚本可以是以任何方式编码的（明确指定或被自动检测）然后被转换为某种内部编码，然后字符串将被用此方式编码。注意脚本的编码有一些约束（如果激活了 Zend Multibyte 则是其内部编码）- 这意味着此编码应该是 ASCII 的兼容超集，例如 UTF-8 或 ISO-8859-1。不过要注意，依赖状态的编码其中相同的字节值可以用于首字母和非首字母而转换状态，这可能会造成问题。

当然了，要做到有用，操作文本的函数必须假定字符串是如何编码的。不幸的是，PHP 关于此的函数有很多变种：

  • 某些函数假定字符串是以单字节编码的，但并不需要将字节解释为特定的字符。例如 substr()，strpos()，strlen() 和 strcmp()。理解这些函数的另一种方法是它们作用于内存缓冲区，即按照字节和字节下标操作。
  • 某些函数被传递入了字符串的编码方式，也可能会假定默认无此信息。例如 htmlentities() 和 mbstring 扩展中的大部分函数。
  • 其它函数使用了当前区域（见 setlocale()），但是逐字节操作。例如
strcasecmp()，strtoupper() 和
ucfirst()。这意味着这些函数只能用于单字节编码，而且编码要与区域匹配。例如
strtoupper("á") 在区域设定正确并且 á
是单字节编码时会返回 "á"。如果是用 UTF-8
编码则不会返回正确结果，其结果根据当前区域有可能返回损坏的值。
  • 最后一些函数会假定字符串是使用某特定编码的，通常是 UTF-8。intl 扩展和 PCRE（上例中仅在使用了 u 修饰符时）扩展中的大部分函数都是这样。尽管这是由于其特殊用途，utf8_decode() 会假定 UTF-8 编码而 utf8_encode() 会假定 ISO-8859-1 编码。

最后，要书写能够正确使用 Unicode 的程序依赖于很小心地避免那些可能会损坏数据的函数。要使用来自于 intl 和 mbstring 扩展的函数。不过使用能处理 Unicode 编码的函数只是个开始。不管用何种语言提供的函数，最基本的还是了解 Unicode 规格。例如一个程序如果假定只有大写和小写，那可是大错特错。


Numeric strings

A PHP string is considered numeric if it can be interpreted as an int or a float.

Formally as of PHP 8.0.0:

WHITESPACES      \s*
LNUM             [0-9]+
DNUM             ([0-9]*)[\.]{LNUM}) | ({LNUM}[\.][0-9]*)
EXPONENT_DNUM    (({LNUM} | {DNUM}) [eE][+-]? {LNUM})
INT_NUM_STRING   {WHITESPACES} [+-]? {LNUM} {WHITESPACES}
FLOAT_NUM_STRING {WHITESPACES} [+-]? ({DNUM} | {EXPONENT_DNUM}) {WHITESPACES}
NUM_STRING       ({INT_NUM_STRING} | {FLOAT_NUM_STRING})

PHP also has a concept of leading numeric strings. This is simply a string which starts like a numeric string followed by any characters.

Strings used in numeric contexts

When a string needs to be evaluated as number (e.g. arithmetic operations, int type declaration, etc.) the following steps are taken to determine the outcome:

  1. If the string is numeric, resolve to an int if the string is an integer numeric string and fits into the limits of the int type limits (as defined by PHP_INT_MAX), otherwise resolve to a float.
  2. If the context allows leading numeric strings and the string is one, resolve to an int if the leading part of the string is an integer numeric string and fits into the limits of the int type limits (as defined by PHP_INT_MAX), otherwise resolve to a float. Additionally an error of level E_WARNING is raised.
  3. The string is not numeric, throw a TypeError.

Behavior prior to PHP 8.0.0

Prior to PHP 8.0.0, a string was considered numeric only if it had leading whitespaces, if it had trailing whitespaces then the string was considered to be leading numeric.

Prior to PHP 8.0.0, when a string was used in a numeric context it would perform the same steps as above with the following differences:

  • The usage of a leading numeric string would raise an E_NOTICE instead of an E_WARNING.
  • If the string is not numeric, an E_WARNING was raised and the value 0 would be returned.

<?php
$foo = 1 + "10.5";                // $foo is float (11.5)
$foo = 1 + "-1.3e3";              // $foo is float (-1299)
$foo = 1 + "bob-1.3e3";           // TypeError as of PHP 8.0.0, $foo is integer (1) previously
$foo = 1 + "bob3";                // TypeError as of PHP 8.0.0, $foo is integer (1) previously
$foo = 1 + "10 Small Pigs";       // $foo is integer (11) and an E_WARNING is raised in PHP 8.0.0, E_NOTICE previously
$foo = 4 + "10.2 Little Piggies"; // $foo is float (14.2) and an E_WARNING is raised in PHP 8.0.0, E_NOTICE previously
$foo = "10.0 pigs " + 1;          // $foo is float (11) and an E_WARNING is raised in PHP 8.0.0, E_NOTICE previously
$foo = "10.0 pigs " + 1.0;        // $foo is float (11) and an E_WARNING is raised in PHP 8.0.0, E_NOTICE previously
?>


Array 数组

PHP 中的数组实际上是一个有序映射。映射是一种把 values 关联到 keys 的类型。此类型在很多方面做了优化，因此可以把它当成真正的数组，或列表（向量），散列表（是映射的一种实现），字典，集合，栈，队列以及更多可能性。由于数组元素的值也可以是另一个数组，树形结构和多维数组也是允许的。

解释这些结构超出了本手册的范围，但对于每种结构至少会提供一个例子。要得到这些结构的更多信息，建议参考有关此广阔主题的其它著作。

语法

定义数组 array()

可以用 array() 语言结构来新建一个数组。它接受任意数量用逗号分隔的 键（key） => 值（value）对。

array(  key =>  value
     , ...
     )
// 键（key）可是是一个整数 integer 或字符串 string
// 值（value）可以是任意类型的值

最后一个数组单元之后的逗号可以省略。通常用于单行数组定义中，例如常用 array(1, 2) 而不是 array(1, 2, )。对多行数组定义通常保留最后一个逗号，这样要添加一个新单元时更方便。

自 5.4 起可以使用短数组定义语法，用 [] 替代 array()。

Example #1 一个简单数组

<?php
$array = array(
    "foo" => "bar",
    "bar" => "foo",
);

// 自 PHP 5.4 起
$array = [
    "foo" => "bar",
    "bar" => "foo",
];
?>

key 可以是 integer 或者 string。value 可以是任意类型。

此外 key 会有如下的强制转换：

  • 包含有合法整型值的字符串会被转换为整型。例如键名 "8" 实际会被储存为 8。但是 "08" 则不会强制转换，因为其不是一个合法的十进制数值。
  • 浮点数也会被转换为整型，意味着其小数部分会被舍去。例如键名 8.7 实际会被储存为 8。
  • 布尔值也会被转换成整型。即键名 true 实际会被储存为 1 而键名 false 会被储存为 0。
  • Null 会被转换为空字符串，即键名 null 实际会被储存为 ""。
  • 数组和对象不能被用为键名。坚持这么做会导致警告：Illegal offset type。

如果在数组定义中多个单元都使用了同一个键名，则只使用了最后一个，之前的都被覆盖了。

Example #2 类型强制与覆盖示例

<?php
$array = array(
    1    => "a",
    "1"  => "b",
    1.5  => "c",
    true => "d",
);
var_dump($array);
?>

以上例程会输出：

array(1) {
  [1]=>
  string(1) "d"
}

上例中所有的键名都被强制转换为 1，则每一个新单元都会覆盖前一个的值，最后剩下的只有一个 "d"。

PHP 数组可以同时含有 integer 和 string 类型的键名，因为 PHP 实际并不区分索引数组和关联数组。

如果对给出的值没有指定键名，则取当前最大的整数索引值，而新的键名将是该值加一。如果指定的键名已经有了值，则该值会被覆盖。

Example #3 混合 integer 和 string 键名

<?php
$array = array(
    "foo" => "bar",
    "bar" => "foo",
    100   => -100,
    -100  => 100,
);
var_dump($array);
?>

以上例程会输出：

array(4) {
  ["foo"]=>
  string(3) "bar"
  ["bar"]=>
  string(3) "foo"
  [100]=>
  int(-100)
  [-100]=>
  int(100)
}

key 为可选项。如果未指定，PHP 将自动使用之前用过的最大 integer 键名加上 1 作为新的键名。

Example #4 没有键名的索引数组

<?php
$array = array("foo", "bar", "hallo", "world");
var_dump($array);
?>

以上例程会输出：

array(4) {
  [0]=>
  string(3) "foo"
  [1]=>
  string(3) "bar"
  [2]=>
  string(5) "hallo"
  [3]=>
  string(5) "world"
}

还可以只对某些单元指定键名而对其它的空置：

Example #5 仅对部分单元指定键名

<?php
$array = array(
         "a",
         "b",
    6 => "c",
         "d",
);
var_dump($array);
?>

以上例程会输出：

array(4) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [6]=>
  string(1) "c"
  [7]=>
  string(1) "d"
}

可以看到最后一个值 "d" 被自动赋予了键名 7。这是由于之前最大的整数键名是 6。

用方括号语法访问数组单元

数组单元可以通过 array[key] 语法来访问。

Example #6 访问数组单元

<?php
$array = array(
    "foo" => "bar",
    42    => 24,
    "multi" => array(
         "dimensional" => array(
             "array" => "foo"
         )
    )
);

var_dump($array["foo"]);
var_dump($array[42]);
var_dump($array["multi"]["dimensional"]["array"]);
?>

以上例程会输出：

string(3) "bar"
int(24)
string(3) "foo"

Note:

方括号和花括号可以互换使用来访问数组单元（例如 $array[42] 和 $array{42} 在上例中效果相同）。

自 PHP 5.4 起可以用直接对函数或方法调用的结果进行数组解引用，在此之前只能通过一个临时变量。

自 PHP 5.5 起可以直接对一个数组原型进行数组解引用。

Example #7 数组解引用

<?php
function getArray() {
    return array(1, 2, 3);
}

// on PHP 5.4
$secondElement = getArray()[1];

// previously
$tmp = getArray();
$secondElement = $tmp[1];

// or
list(, $secondElement) = getArray();
?>

Note:

试图访问一个未定义的数组键名与访问任何未定义变量一样：会导致 E_NOTICE 级别错误信息，其结果为 null。

用方括号的语法新建／修改

可以通过明示地设定其中的值来修改一个已有数组。

这是通过在方括号内指定键名来给数组赋值实现的。也可以省略键名，在这种情况下给变量名加上一对空的方括号（[]）。

$arr[key] = value;
$arr[] = value;
// key 可以是 integer 或 string
// value 可以是任意类型的值

如果 $arr 还不存在，将会新建一个，这也是另一种新建数组的方法。不过并不鼓励这样做，因为如果 $arr 已经包含有值（例如来自请求变量的 string）则此值会保留而 [] 实际上代表着字符串访问运算符。初始化变量的最好方式是直接给其赋值。。

要修改某个值，通过其键名给该单元赋一个新值。要删除某键值对，对其调用 unset() 函数。

<?php
$arr = array(5 => 1, 12 => 2);

$arr[] = 56;    // This is the same as $arr[13] = 56;
                // at this point of the script

$arr["x"] = 42; // This adds a new element to
                // the array with key "x"

unset($arr[5]); // This removes the element from the array

unset($arr);    // This deletes the whole array
?>

Note:

如上所述，如果给出方括号但没有指定键名，则取当前最大整数索引值，新的键名将是该值加上 1（但是最小为 0）。如果当前还没有整数索引，则键名将为 0。

注意这里所使用的最大整数键名不一定当前就在数组中。它只要在上次数组重新生成索引后曾经存在过就行了。以下面的例子来说明：

<?php
// 创建一个简单的数组
$array = array(1, 2, 3, 4, 5);
print_r($array);

// 现在删除其中的所有元素，但保持数组本身不变:
foreach ($array as $i => $value) {
    unset($array[$i]);
}
print_r($array);

// 添加一个单元（注意新的键名是 5，而不是你可能以为的 0）
$array[] = 6;
print_r($array);

// 重新索引：
$array = array_values($array);
$array[] = 7;
print_r($array);
?>

以上例程会输出：

Array
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)
Array
(
)
Array
(
    [5] => 6
)
Array
(
    [0] => 6
    [1] => 7
)

实用函数

有很多操作数组的函数，参见数组函数一节。

Note:

unset() 函数允许删除数组中的某个键。但要注意数组将不会重建索引。如果需要删除后重建索引，可以用 array_values() 函数。

<?php
$a = array(1 => 'one', 2 => 'two', 3 => 'three');
unset($a[2]);
/* will produce an array that would have been defined as
   $a = array(1 => 'one', 3 => 'three');
   and NOT
   $a = array(1 => 'one', 2 =>'three');
*/

$b = array_values($a);
// Now $b is array(0 => 'one', 1 =>'three')
?>

foreach 控制结构是专门用于数组的。它提供了一个简单的方法来遍历数组。

数组做什么和不做什么

为什么 $foo[bar] 错了？

应该始终在用字符串表示的数组索引上加上引号。例如用 $foo['bar'] 而不是 $foo[bar]。但是为什么呢？可能在老的脚本中见过如下语法：

<?php
$foo[bar] = 'enemy';
echo $foo[bar];
// etc
?>

这样是错的，但可以正常运行。那么为什么错了呢？原因是此代码中有一个未定义的常量（bar）而不是字符串（'bar'－注意引号），而 PHP 可能会在以后定义此常量，不幸的是你的代码中有同样的名字。它能运行，是因为 PHP 自动将裸字符串（没有引号的字符串且不对应于任何已知符号）转换成一个其值为该裸字符串的正常字符串。例如，如果没有常量定义为 bar，PHP 将把它替代为 'bar' 并使用之。

Note: 这并不意味着总是给键名加上引号。用不着给键名为常量或变量的加上引号，否则会使 PHP 不能解析它们。

<?php
error_reporting(E_ALL);
ini_set('display_errors', true);
ini_set('html_errors', false);
// Simple array:
$array = array(1, 2);
$count = count($array);
for ($i = 0; $i < $count; $i++) {
    echo "\nChecking $i: \n";
    echo "Bad: " . $array['$i'] . "\n";
    echo "Good: " . $array[$i] . "\n";
    echo "Bad: {$array['$i']}\n";
    echo "Good: {$array[$i]}\n";
}
?>

以上例程会输出：

Checking 0:
Notice: Undefined index:  $i in /path/to/script.html on line 9
Bad:
Good: 1
Notice: Undefined index:  $i in /path/to/script.html on line 11
Bad:
Good: 1

Checking 1:
Notice: Undefined index:  $i in /path/to/script.html on line 9
Bad:
Good: 2
Notice: Undefined index:  $i in /path/to/script.html on line 11
Bad:
Good: 2

演示此行为的更多例子：

<?php
// Show all errors
error_reporting(E_ALL);

$arr = array('fruit' => 'apple', 'veggie' => 'carrot');

// Correct
print $arr['fruit'];  // apple
print $arr['veggie']; // carrot

// Incorrect.  This works but also throws a PHP error of level E_NOTICE because
// of an undefined constant named fruit
//
// Notice: Use of undefined constant fruit - assumed 'fruit' in...
print $arr[fruit];    // apple

// This defines a constant to demonstrate what's going on.  The value 'veggie'
// is assigned to a constant named fruit.
define('fruit', 'veggie');

// Notice the difference now
print $arr['fruit'];  // apple
print $arr[fruit];    // carrot

// The following is okay, as it's inside a string. Constants are not looked for
// within strings, so no E_NOTICE occurs here
print "Hello $arr[fruit]";      // Hello apple

// With one exception: braces surrounding arrays within strings allows constants
// to be interpreted
print "Hello {$arr[fruit]}";    // Hello carrot
print "Hello {$arr['fruit']}";  // Hello apple

// This will not work, and will result in a parse error, such as:
// Parse error: parse error, expecting T_STRING' or T_VARIABLE' or T_NUM_STRING'
// This of course applies to using superglobals in strings as well
print "Hello $arr['fruit']";
print "Hello $_GET['foo']";

// Concatenation is another option
print "Hello " . $arr['fruit']; // Hello apple
?>

当打开 error_reporting 来显示 E_NOTICE 级别的错误（将其设为 E_ALL）时将看到这些错误。默认情况下 error_reporting 被关闭不显示这些。

和在语法一节中规定的一样，在方括号（"["和"]"）之间必须有一个表达式。这意味着可以这样写：

<?php
echo $arr[somefunc($bar)];
?>

这是一个用函数返回值作为数组索引的例子。PHP 也可以用已知常量，可能之前已经见过：

<?php
$error_descriptions[E_ERROR]   = "A fatal error has occured";
$error_descriptions[E_WARNING] = "PHP issued a warning";
$error_descriptions[E_NOTICE]  = "This is just an informal notice";
?>

注意 E_ERROR 也是个合法的标识符，就和第一个例子中的 bar 一样。但是上一个例子实际上和如下写法是一样的：

<?php
$error_descriptions[1] = "A fatal error has occured";
$error_descriptions[2] = "PHP issued a warning";
$error_descriptions[8] = "This is just an informal notice";
?>

因为 E_ERROR 等于 1，等等。

那么为什么这样做不好？

也许有一天，PHP 开发小组可能会想新增一个常量或者关键字，或者用户可能希望以后在自己的程序中引入新的常量，那就有麻烦了。例如已经不能这样用 empty 和 default 这两个词了，因为他们是保留字。

Note: 重申一次，在双引号字符串中，不给索引加上引号是合法的因此 "$foo[bar]" 是合法的（"合法"的原文为 valid。在实际测试中，这么做确实可以访问数组的该元素，但是会报一个常量未定义的 notice。无论如何，强烈建议不要使用 $foo[bar]这样的写法，而要使用 $foo['bar'] 来访问数组中元素。--haohappy 注）。至于为什么参见以上的例子和字符串中的变量解析中的解释。

转换为数组

对于任意 integer，float，string，boolean 和 resource 类型，如果将一个值转换为数组，将得到一个仅有一个元素的数组，其下标为 0，该元素即为此标量的值。换句话说，(array)$scalarValue 与 array($scalarValue) 完全一样。

如果一个 object 类型转换为 array，则结果为一个数组，其单元为该对象的属性。键名将为成员变量名，不过有几点例外：整数属性不可访问；私有变量前会加上类名作前缀；保护变量前会加上一个 '*' 做前缀。这些前缀的前后都各有一个 NULL 字符。这会导致一些不可预知的行为：

<?php

class A {
    private $A; // This will become '\0A\0A'
}

class B extends A {
    private $A; // This will become '\0B\0A'
    public $AA; // This will become 'AA'
}

var_dump((array) new B());
?>

上例会有两个键名为 'AA'，不过其中一个实际上是 '\0A\0A'。

将 null 转换为 array 会得到一个空的数组。

比较

可以用 array_diff() 和数组运算符来比较数组。

示例

PHP 中的数组类型有非常多的用途。以下是一些示例：

<?php
// This:
$a = array( 'color' => 'red',
            'taste' => 'sweet',
            'shape' => 'round',
            'name'  => 'apple',
            4        // key will be 0
          );

$b = array('a', 'b', 'c');

// . . .is completely equivalent with this:
$a = array();
$a['color'] = 'red';
$a['taste'] = 'sweet';
$a['shape'] = 'round';
$a['name']  = 'apple';
$a[]        = 4;        // key will be 0

$b = array();
$b[] = 'a';
$b[] = 'b';
$b[] = 'c';

// After the above code is executed, $a will be the array
// array('color' => 'red', 'taste' => 'sweet', 'shape' => 'round',
// 'name' => 'apple', 0 => 4), and $b will be the array
// array(0 => 'a', 1 => 'b', 2 => 'c'), or simply array('a', 'b', 'c').
?>

Example #8 使用 array()

<?php
// Array as (property-)map
$map = array( 'version'    => 4,
              'OS'         => 'Linux',
              'lang'       => 'english',
              'short_tags' => true
            );

// strictly numerical keys
$array = array( 7,
                8,
                0,
                156,
                -10
              );
// this is the same as array(0 => 7, 1 => 8, ...)

$switching = array(         10, // key = 0
                    5    =>  6,
                    3    =>  7,
                    'a'  =>  4,
                            11, // key = 6 (maximum of integer-indices was 5)
                    '8'  =>  2, // key = 8 (integer!)
                    '02' => 77, // key = '02'
                    0    => 12  // the value 10 will be overwritten by 12
                  );

// empty array
$empty = array();
?>

Example #9 集合

<?php
$colors = array('red', 'blue', 'green', 'yellow');

foreach ($colors as $color) {
    echo "Do you like $color?\n";
}

?>

以上例程会输出：

Do you like red?
Do you like blue?
Do you like green?
Do you like yellow?

直接改变数组的值自 PHP 5 起可以通过引用传递来做到。之前的版本需要需要采取变通的方法：

Example #10 在循环中改变单元

<?php
// PHP 5
foreach ($colors as &$color) {
    $color = strtoupper($color);
}
unset($color); /* ensure that following writes to
$color will not modify the last array element */

// Workaround for older versions
foreach ($colors as $key => $color) {
    $colors[$key] = strtoupper($color);
}

print_r($colors);
?>

以上例程会输出：

Array
(
    [0] => RED
    [1] => BLUE
    [2] => GREEN
    [3] => YELLOW
)

本例生成一个下标从 1 开始的数组。

Example #11 下标从 1 开始的数组

<?php
$firstquarter  = array(1 => 'January', 'February', 'March');
print_r($firstquarter);
?>

以上例程会输出：

Array
(
    [1] => 'January'
    [2] => 'February'
    [3] => 'March'
)

Example #12 填充数组

<?php
// fill an array with all items from a directory
$handle = opendir('.');
while (false !== ($file = readdir($handle))) {
    $files[] = $file;
}
closedir($handle);
?>

数组是有序的。也可以使用不同的排序函数来改变顺序。更多信息参见数组函数。可以用 count() 函数来数出数组中元素的个数。

Example #13 数组排序

<?php
sort($files);
print_r($files);
?>

因为数组中的值可以为任意值，也可是另一个数组。这样可以产生递归或多维数组。

Example #14 递归和多维数组

<?php
$fruits = array ( "fruits"  => array ( "a" => "orange",
                                       "b" => "banana",
                                       "c" => "apple"
                                     ),
                  "numbers" => array ( 1,
                                       2,
                                       3,
                                       4,
                                       5,
                                       6
                                     ),
                  "holes"   => array (      "first",
                                       5 => "second",
                                            "third"
                                     )
                );

// Some examples to address values in the array above
echo $fruits["holes"][5];    // prints "second"
echo $fruits["fruits"]["a"]; // prints "orange"
unset($fruits["holes"][0]);  // remove "first"

// Create a new multi-dimensional array
$juices["apple"]["green"] = "good";
?>

数组(Array) 的赋值总是会涉及到值的拷贝。使用引用运算符通过引用来拷贝数组。

<?php
$arr1 = array(2, 3);
$arr2 = $arr1;
$arr2[] = 4; // $arr2 is changed,
             // $arr1 is still array(2, 3)

$arr3 = &$arr1;
$arr3[] = 4; // now $arr1 and $arr3 are the same
?>


Iterable 可迭代对象

Iterable是 PHP 7.1 中引入的一个伪类型。它接受任何 array 或实现了 Traversable 接口的对象。这些类型都能用 foreach 迭代， 也可以和 生成器 里的 yield from 一起使用。

使用可迭代对象

可迭代对象可以用作参数类型，表示函数需要一组值， 但是不会关心值集的形式，因为它将与 foreach 一起使用。如果一个值不是数组或 Traversable 的实例，则会抛出一个 TypeError。

Example #1 Iterable 可迭代参数类型示例

<?php

function foo(iterable $iterable) {
    foreach ($iterable as $value) {
        // ...
    }
}

?>

声明为可迭代的参数可能会使用 null 或者一个数组作为默认值。

Example #2 可迭代参数默认值示例

<?php

function foo(iterable $iterable = []) {
    // ...
}

?>

可迭代对象还可以用作返回类型，表示函数将返回一个可迭代的值。 如果返回值不是数组或 Traversable 的实例，则会抛出一个 TypeError。

Example #3 可迭代返回类型示例

<?php

function bar(): iterable {
    return [1, 2, 3];
}

?>

将可迭代对象声明为返回类型的函数也可能是 生成器。

Example #4 可迭代生成器返回类型的示例

<?php

function gen(): iterable {
    yield 1;
    yield 2;
    yield 3;
}

?>

可迭代类型的协变

类在扩展/实现（extending/implementing）的时候， 可以将参数类型从 array 或 Traversable 放宽到 iterable， 也可以将返回类型 iterable 的范围缩小到 array 或 Traversable。

Example #5 可迭代的类型协变示例

<?php

interface Example {
    public function method(array $array): iterable;
}

class ExampleImplementation implements Example {
    public function method(iterable $iterable): array {
        // 放宽了参数类型，缩窄了返回的类型
    }
}

?>


Object 对象

对象初始化

要创建一个新的对象 object，使用 new 语句实例化一个类：

<?php
class foo
{
    function do_foo()
    {
        echo "Doing foo.";
    }
}

$bar = new foo;
$bar->do_foo();
?>

详细讨论参见手册中类与对象章节。

转换为对象

如果将一个对象转换成对象，它将不会有任何变化。如果其它任何类型的值被转换成对象，将会创建一个内置类 stdClass 的实例。如果该值为 null，则新的实例为空。 array 转换成 object 将使键名成为属性名并具有相对应的值。注意：在这个例子里， 使用 PHP 7.2.0 之前的版本，数字键只能通过迭代访问。

<?php
$obj = (object) array('1' => 'foo');
var_dump(isset($obj->{'1'})); // PHP 7.2.0 后输出 'bool(true)'，之前版本会输出 'bool(false)'
var_dump(key($obj)); // PHP 7.2.0 后输出 'string(1) "1"'，之前版本输出  'int(1)'
?>

对于其他值，会包含进成员变量名 scalar。

<?php
$obj = (object) 'ciao';
echo $obj->scalar;  // outputs 'ciao'
?>


Resource 资源类型

资源 resource 是一种特殊变量，保存了到外部资源的一个引用。资源是通过专门的函数来建立和使用的。所有这些函数及其相应资源类型见附录。

参见 get_resource_type()。

转换为资源

由于资源类型变量保存有为打开文件、数据库连接、图形画布区域等的特殊句柄，因此将其它类型的值转换为资源没有意义。

释放资源

引用计数系统是 Zend 引擎的一部分，可以自动检测到一个资源不再被引用了（和 Java 一样）。这种情况下此资源使用的所有外部资源都会被垃圾回收系统释放。因此，很少需要手工释放内存。

Note: 持久数据库连接比较特殊，它们不会被垃圾回收系统销毁。参见数据库永久连接一章。


NULL

特殊的 null 值表示一个变量没有值。NULL 类型唯一可能的值就是 null。

在下列情况下一个变量被认为是 null：

  • 被赋值为 null。

  • 尚未被赋值。

  • 被 unset()。

语法

null 类型只有一个值，就是不区分大小写的常量 null。

<?php
$var = NULL;
?>

参见 is_null() 和 unset()。

转换到 NULL

Warning

本特性已自 PHP 7.2.0 起废弃。强烈建议不要使用本特性。

使用 (unset) $var 将一个变量转换为 null 将不会删除该变量或 unset 其值。仅是返回 null 值而已。


Callback / Callable 类型

自 PHP 5.4 起可用 callable 类型指定回调类型 callback。本文档基于同样理由使用 callback 类型信息。

一些函数如 call_user_func() 或 usort() 可以接受用户自定义的回调函数作为参数。回调函数不止可以是简单函数，还可以是对象的方法，包括静态类方法。

传递

PHP是将函数以string形式传递的。 可以使用任何内置或用户自定义函数，但除了语言结构例如：array()，echo，empty()，eval()，exit()，isset()，list()，print 或 unset()。

一个已实例化的 object 的方法被作为 array 传递，下标 0 包含该 object，下标 1 包含方法名。 在同一个类里可以访问 protected 和 private 方法。

静态类方法也可不经实例化该类的对象而传递，只要在下标 0 中包含类名而不是对象。自 PHP 5.2.3 起，也可以传递 'ClassName::methodName'。

除了普通的用户自定义函数外，也可传递 匿名函数 给回调参数。

Example #1 回调函数示例

<?php

// An example callback function
function my_callback_function() {
    echo 'hello world!';
}

// An example callback method
class MyClass {
    static function myCallbackMethod() {
        echo 'Hello World!';
    }
}

// Type 1: Simple callback
call_user_func('my_callback_function');

// Type 2: Static class method call
call_user_func(array('MyClass', 'myCallbackMethod'));

// Type 3: Object method call
$obj = new MyClass();
call_user_func(array($obj, 'myCallbackMethod'));

// Type 4: Static class method call (As of PHP 5.2.3)
call_user_func('MyClass::myCallbackMethod');

// Type 5: Relative static class method call (As of PHP 5.3.0)
class A {
    public static function who() {
        echo "A\n";
    }
}

class B extends A {
    public static function who() {
        echo "B\n";
    }
}

call_user_func(array('B', 'parent::who')); // A

// Type 6: Objects implementing __invoke can be used as callables (since PHP 5.3)
class C {
    public function __invoke($name) {
        echo 'Hello ', $name, "\n";
    }
}

$c = new C();
call_user_func($c, 'PHP!');
?>

Example #2 使用 Closure 的示例

<?php
// Our closure
$double = function($a) {
    return $a * 2;
};

// This is our range of numbers
$numbers = range(1, 5);

// Use the closure as a callback here to
// double the size of each element in our
// range
$new_numbers = array_map($double, $numbers);

print implode(' ', $new_numbers);
?>

以上例程会输出：

2 4 6 8 10

Note:

在函数中注册有多个回调内容时(如使用 call_user_func() 与 call_user_func_array())，如在前一个回调中有未捕获的异常，其后的将不再被调用。


类型声明

类型声明可以用于函数的参数、返回值，PHP 7.4.0 起还可以用于类的属性，来显性的指定需要的类型，如果预期类型在调用时不匹配，则会抛出一个 TypeError 异常。

Note:

当子类覆盖父方法时，子类的方法必须匹配父类的类型声明。如果父类没有定义返回类型，那么子方法可以指定自己的返回类型。

单一类型

类型 | 说明 | 版本
类/接口 名称 | 值必须为指定类和接口的实例化对象 instanceof |
self | 值必定是所在方法的类的一个 instanceof。 只能在类的内部使用。 |
array | 值必须为 array。 |
callable | 值必定是一个有效的 callable。 不能用于类属性的类型声明。 |
bool | 值必须为一个布尔值。 |
float | 值必须为一个浮点数字。 |
int | 值必须为一个整型数字。 |
string | 值必须为一个 string。 |
iterable | 值必须为 array 或 instanceof Traversable。 | PHP 7.1.0
object | 值必须为object。 | PHP 7.2.0
mixed | 值可以为任何类型。 | PHP 8.0.0
Warning

不支持上述标量类型的别名。相反，它们被视为类或接口名。例如，使用 boolean 作为类型声明，将要求值是一个 instanceof 类或接口 boolean，而不能是类型 bool。

<?php
    function test(boolean $param) {}
    test(true);
?>

以上例程在 PHP 8 中的输出：

Warning: "boolean" will be interpreted as a class name. Did you mean "bool"? Write "\boolean" to suppress this warning in /in/9YrUX on line 2

Fatal error: Uncaught TypeError: test(): Argument #1 ($param) must be of type boolean, bool given, called in - on line 3 and defined in -:2
Stack trace:
#0 -(3): test(true)
#1 {main}
  thrown in - on line 2

范例

Example #1 在类中使用类型声明

<?php
class C {}
class D extends C {}

// 它没有 extend C。
class E {}

function f(C $c) {
    echo get_class($c)."\n";
}

f(new C);
f(new D);
f(new E);
?>

以上例程在 PHP 8 中的输出：

C
D

Fatal error: Uncaught TypeError: f(): Argument #1 ($c) must be of type C, E given, called in /in/gLonb on line 14 and defined in /in/gLonb:8
Stack trace:
#0 -(14): f(Object(E))
#1 {main}
  thrown in - on line 8

Example #2 在接口中使用类型声明

<?php
interface I { public function f(); }
class C implements I { public function f() {} }

// 它没有 implement I。
class E {}

function f(I $i) {
    echo get_class($i)."\n";
}

f(new C);
f(new E);
?>

以上例程在 PHP 8 中的输出：

C

Fatal error: Uncaught TypeError: f(): Argument #1 ($i) must be of type I, E given, called in - on line 13 and defined in -:8
Stack trace:
#0 -(13): f(Object(E))
#1 {main}
  thrown in - on line 8

Example #3 返回类型声明

<?php
function sum($a, $b): float {
    return $a + $b;
}

// 注意必须返回一个 float。
var_dump(sum(1, 2));
?>

以上例程会输出：

float(3)

Example #4 返回一个对象

<?php
class C {}

function getC(): C {
    return new C;
}

var_dump(getC());
?>

以上例程会输出：

object(C)#1 (0) {
}

允许为空的（Nullable）类型

自 PHP 7.1.0 起，类型声明允许前置一个问号 (?) 用来声明这个值允许为指定类型，或者为 null。

Example #5 定义可空（Nullable）的参数类型

<?php
class C {}

function f(?C $c) {
    var_dump($c);
}

f(new C);
f(null);
?>

以上例程会输出：

object(C)#1 (0) {
}
NULL

Example #6 定义可空（Nullable）的返回类型

<?php
function get_item(): ?string {
    if (isset($_GET['item'])) {
        return $_GET['item'];
    } else {
        return null;
    }
}
?>

Note:

在 PHP 7.1.0 之前版本中，可以通过设置参数的默认值为 null 来实现允许为空的参数。不建议这样做，因为影响到类的继承调用。

Example #7 旧版本中实现允许为空参数的示例

<?php
class C {}

function f(C $c = null) {
    var_dump($c);
}

f(new C);
f(null);
?>

以上例程会输出：

object(C)#1 (0) {
}
NULL

联合类型

联合类型接受多个不同的类型做为参数。声明联合类型的语法为 T1|T2|...。联合类型自 PHP 8.0.0 起可用。

允许为空的联合类型

null 类型允许在联合类型中使用，例如 T1|T2|null 代表接受一个空值为参数。已经存在的 ?T 语法可以视为以下联合类型的一个简写 T|null。

Caution

null 不能作为一个独立的类型使用。

false 伪类型

通过联合类型支持字面类型（Literal Type）false， 出于历史原因，很多内部函数在失败时返回了 false 而不是 null。 这类函数的典型例子是 strpos()。

Caution

false 不能单独作为类型使用（包括可空 nullable 类型）。 因此，false、false|null、 ?false 都是不可以用的。

Caution

true 字面类型不存在。

重复冗余的类型

为了能在联合类型声明中暴露简单的 bug，不需要加载 class 就可以在编译时让重复冗余的类型产生错误。 包含：

  • 解析出来的类型只能出现一次。例如这样的类型 int|string|INT 会导致错误。
  • 使用了 bool 时就不能再附带使用 false。
  • 使用了 object 时就不能再附带使用 class 类型。
  • 使用了 iterable 时，array、 Traversable 都不能再附带使用。

Note: 不过它不能确保类型最小化，因为要达到这样的效果，还要加载使用类型的 class。

例如，假设 A 和 B 都是一个类的别名， 而 A|B 仍然是有效的，哪怕它可以被简化为 A 或 B。 同样的，如果 B extends A {}，那 A|B 仍然是有效的联合类型，尽管它可以被简化为 A。

<?php
function foo(): int|INT {} // 不允许
function foo(): bool|false {} // 不允许

use A as B;
function foo(): A|B {} // 不允许 ("use" 是名称解析的一部分)

class_alias('X', 'Y');
function foo(): X|Y {} // 允许 (运行时才能知道重复性)
?>

仅仅返回类型

void

void 是一个返回类型，用于标识函数没有返回值。 它不能是联合类型的一部分。 PHP 7.1.0 起可用。

static

它的值必须是一个 class 的 instanceof，该 class 是调用方法所在的同一个类。 PHP 8.0.0 起有效。

严格类型

默认如果可能，PHP 会强制转化不合适的类型为想要的标量类型。 比如，参数想要 string，传入的是 int， 则会获取 string 类型的变量。

可以按文件开启严格模式。 在严格模式下，只能接受完全匹配的类型，否则会抛出 TypeError。 唯一的例外是 int 值也可以传入声明为 float 的类型。

Warning

通过内部函数调用函数时，不会受 strict_types 声明影响。

要开启严格模式，使用 declare 开启 strict_types：

Note:

文件开启严格类型后的内部调用函数将应用严格类型， 而不是在声明函数的文件内开启。 如果文件没有声明开启严格类型，而被调用的函数所在文件有严格类型声明， 那将遵循调用者的设置（开启类型强制转化）， 值也会强制转化。

Note:

只有为标量类型的声明开启严格类型。

Example #8 参数值的严格类型

<?php
declare(strict_types=1);

function sum(int $a, int $b) {
    return $a + $b;
}

var_dump(sum(1, 2));
var_dump(sum(1.5, 2.5));
?>

以上例程在 PHP 8 中的输出：

int(3)

Fatal error: Uncaught TypeError: sum(): Argument #1 ($a) must be of type int, float given, called in - on line 9 and defined in -:4
Stack trace:
#0 -(9): sum(1.5, 2.5)
#1 {main}
  thrown in - on line 4

Example #9 参数值的类型强制转化

<?php
function sum(int $a, int $b) {
    return $a + $b;
}

var_dump(sum(1, 2));

// 以下会强制转化为整型，注意以下内容输出！
var_dump(sum(1.5, 2.5));
?>

以上例程会输出：

int(3)
int(3)

Example #10 返回值的严格类型

<?php
declare(strict_types=1);

function sum($a, $b): int {
    return $a + $b;
}

var_dump(sum(1, 2));
var_dump(sum(1, 2.5));
?>

以上例程会输出：

int(3)

Fatal error: Uncaught TypeError: sum(): Return value must be of type int, float returned in -:5
Stack trace:
#0 -(9): sum(1, 2.5)
#1 {main}
  thrown in - on line 5

联合类型的内部隐式强制转化

没有开启 strict_types 时，标量类型可能会限制内部隐式类型转化。 如果值的类型不是联合类型中的一部分，则目标类型会按以下顺序：

  1. int
  2. float
  3. string
  4. bool
如果类型出现在组合中，值可以按 PHP 现有的类型语义检测进行内部隐式强制转化，则会选择该类型。 否则会尝试下一个类型。

Caution

有一个例外：当值是字符串，而 int 与 float 同时在组合中，将按现有的"数字字符串"检测语义，识别首选的类型。 例如，"42" 会选择 int 类型， 而 "42.0" 会选择 float 类型。

Note:

没有出现在上面列表中的类型则不是有效的内部隐式转化目标。 尤其是不会出现内部隐式转化 null 和 false 类型。

Example #11 类型强制转换为联合类型的例子

<?php
// int|string
42    --> 42          // 类型完全匹配
"42"  --> "42"        // 类型完全匹配
new ObjectWithToString --> "__toString() 的结果"
                      // object 不兼容 int，降级到 string
42.0  --> 42          // float 与 int 兼容
42.1  --> 42          // float 与 int 兼容
1e100 --> "1.0E+100"  // float 比 int 大太多了，降级到 string
INF   --> "INF"       // float 比 int 大太多了，降级到 string
true  --> 1           // bool 与 int 兼容
[]    --> TypeError   // array 不兼容 int 或 string

// int|float|bool
"45"    --> 45        // int 的数字字符串
"45.0"  --> 45.0      // float 的数字字符串

"45X"   --> true      // 不是数字字符串，降级到 bool
""      --> false     // 不是数字字符串，降级到 bool
"X"     --> true      // 不是数字字符串，降级到 bool
[]      --> TypeError // array 不兼容 int、float、bool
?>

其他

Example #12 传引用参数的类型

仅仅会在函数入口检查传引用的参数类型，而不是在函数返回时检查。 所以函数返回时，参数类型可能会发生变化。

<?php
function array_baz(array &$param)
{
    $param = 1;
}
$var = [];
array_baz($var);
var_dump($var);
array_baz($var);
?>

以上例程在 PHP 8 中的输出：

int(1)

Fatal error: Uncaught TypeError: array_baz(): Argument #1 ($param) must be of type array, int given, called in - on line 9 and defined in -:2
Stack trace:
#0 -(9): array_baz(1)
#1 {main}
  thrown in - on line 2

Example #13 捕获 TypeError

<?php
declare(strict_types=1);

function sum(int $a, int $b) {
    return $a + $b;
}

try {
    var_dump(sum(1, 2));
    var_dump(sum(1.5, 2.5));
} catch (TypeError $e) {
    echo 'Error: ', $e->getMessage();
}
?>

以上例程在 PHP 8 中的输出：

int(3)
Error: sum(): Argument #1 ($a) must be of type int, float given, called in - on line 10


类型转换的判别

PHP 在变量定义中不需要（或不支持）明确的类型定义；变量类型是根据使用该变量的上下文所决定的。也就是说，如果把一个 string 值赋给变量 $var，$var 就成了一个 string。如果又把一个integer 赋给 $var，那它就成了一个integer。

PHP 的自动类型转换的一个例子是乘法运算符"*"。如果任何一个操作数是float，则所有的操作数都被当成float，结果也是float。否则操作数会被解释为integer，结果也是integer。注意这并没有改变这些操作数本身的类型；改变的仅是这些操作数如何被求值以及表达式本身的类型。

<?php
$foo = "1";  // $foo 是字符串 (ASCII 49)
$foo *= 2;   // $foo 现在是一个整数 (2)
$foo = $foo * 1.3;  // $foo 现在是一个浮点数 (2.6)
$foo = 5 * "10 Little Piggies"; // $foo 是整数 (50)
$foo = 5 * "10 Small Pigs";     // $foo 是整数 (50)
?>

如果上面两个例子看上去古怪的话，参见字符串转换为数值。

如果要强制将一个变量当作某种类型来求值，参见类型强制转换一节。如果要改变一个变量的类型，参见 settype()。

如果想要测试本节中任何例子的话，可以用 var_dump() 函数。

Note:

自动转换为 数组 的行为目前没有定义。

此外，由于 PHP 支持使用和数组下标同样的语法访问字符串下标，以下例子在所有 PHP 版本中都有效：

<?php
$a    = 'car'; // $a is a string
$a[0] = 'b';   // $a is still a string
echo $a;       // bar
?>

请参阅存取和修改字符串中的字符一节以获取更多信息。

类型强制转换

PHP 中的类型强制转换和 C 中的非常像：在要转换的变量之前加上用括号括起来的目标类型。

<?php
$foo = 10;   // $foo is an integer
$bar = (boolean) $foo;   // $bar is a boolean
?>

允许的强制转换有：

  • (int), (integer) - 转换为整形 integer
  • (bool), (boolean) - 转换为布尔类型 boolean
  • (float), (double), (real) - 转换为浮点型 float
  • (string) - 转换为字符串 string
  • (array) - 转换为数组 array
  • (object) - 转换为对象 object
  • (unset) - 转换为 NULL

(binary) 转换和 b 前缀转换支持为 PHP 5.2.1 新增。注意 (binary) 转换和 (string) 基本相同，但是不应该依赖它。

(unset) 转换在 PHP 7.2.0 中已被废弃。请注意 (unset) 转换等于将值赋予 NULL。(unset) 转换将在 PHP 8.0.0 中被移除。

注意在括号内允许有空格和制表符，所以下面两个例子功能相同：

<?php
$foo = (int) $bar;
$foo = ( int ) $bar;
?>

将字符串文字和变量转换为二进制字符串：

<?php
$binary = (binary)$string;
$binary = b"binary string";
?>

Note:

可以将变量放置在双引号中的方式来代替将变量转换成字符串：

<?php
$foo = 10;            // $foo 是一个整数
$str = "$foo";        // $str 是一个字符串
$fst = (string) $foo; // $fst 也是一个字符串

// 输出 "they are the same"
if ($fst === $str) {
    echo "they are the same";
}
?>

有时在类型之间强制转换时确切地会发生什么可能不是很明显。更多信息见如下小节：

  • 转换为布尔型
  • 转换为整型
  • 转换为浮点型
  • 转换为字符串
  • 转换为数组
  • 转换为对象
  • 转换为资源
  • 转换为 NULL
  • 类型比较表


变量

Table of Contents

  • 基础
  • 预定义变量
  • 变量范围
  • 可变变量
  • 来自 PHP 之外的变量


基础

PHP 中的变量用一个美元符号后面跟变量名来表示。变量名是区分大小写的。

变量名与 PHP 中其它的标签一样遵循相同的规则。一个有效的变量名由字母或者下划线开头，后面跟上任意数量的字母，数字，或者下划线。 按照正常的正则表达式，它将被表述为：'^[a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*$'。

Note: 在此所说的字母是 a-z，A-Z，以及 ASCII 字符从 128 到 255（0x80-0xff）。

Note: $this 是一个特殊的变量，它不能被赋值。 Prior to PHP 7.1.0, indirect assignment (e.g. by using variable variables) was possible.

Tip

请参见用户空间命名指南。

有关变量的函数信息见变量函数。

<?php
$var = 'Bob';
$Var = 'Joe';
echo "$var, $Var";      // 输出 "Bob, Joe"

$4site = 'not yet';     // 非法变量名；以数字开头
$_4site = 'not yet';    // 合法变量名；以下划线开头
$i站点is = 'mansikka';  // 合法变量名；可以用中文
?>

变量默认总是传值赋值。那也就是说，当将一个表达式的值赋予一个变量时，整个原始表达式的值被赋值到目标变量。这意味着，例如，当一个变量的值赋予另外一个变量时，改变其中一个变量的值，将不会影响到另外一个变量。有关这种类型的赋值操作，请参阅表达式一章。

PHP 也提供了另外一种方式给变量赋值：引用赋值。这意味着新的变量简单的引用（换言之，"成为其别名" 或者 "指向"）了原始变量。改动新的变量将影响到原始变量，反之亦然。

使用引用赋值，简单地将一个 & 符号加到将要赋值的变量前（源变量）。例如，下列代码片断将输出"My name is Bob"两次：

<?php
$foo = 'Bob';              // 将 'Bob' 赋给 $foo
$bar = &$foo;              // 通过 $bar 引用 $foo
$bar = "My name is $bar";  // 修改 $bar 变量
echo $bar;
echo $foo;                 // $foo 的值也被修改
?>

有一点重要事项必须指出，那就是只有有名字的变量才可以引用赋值。

<?php
$foo = 25;
$bar = &$foo;      // 合法的赋值
$bar = &(24 * 7);  // 非法; 引用没有名字的表达式

function test()
{
   return 25;
}

$bar = &test();    // 非法
?>

虽然在 PHP 中并不需要初始化变量，但对变量进行初始化是个好习惯。未初始化的变量具有其类型的默认值 - 布尔类型的变量默认值是 false，整形和浮点型变量默认值是零，字符串型变量（例如用于 echo 中）默认值是空字符串以及数组变量的默认值是空数组。

Example #1 未初始化变量的默认值

<?php
// Unset AND unreferenced (no use context) variable; outputs NULL
var_dump($unset_var);

// Boolean usage; outputs 'false' (See ternary operators for more on this syntax)
echo($unset_bool ? "true\n" : "false\n");

// String usage; outputs 'string(3) "abc"'
$unset_str .= 'abc';
var_dump($unset_str);

// Integer usage; outputs 'int(25)'
$unset_int += 25; // 0 + 25 => 25
var_dump($unset_int);

// Float/double usage; outputs 'float(1.25)'
$unset_float += 1.25;
var_dump($unset_float);

// Array usage; outputs array(1) {  [3]=>  string(3) "def" }
$unset_arr[3] = "def"; // array() + array(3 => "def") => array(3 => "def")
var_dump($unset_arr);

// Object usage; creates new stdClass object (see http://www.php.net/manual/en/reserved.classes.php)
// Outputs: object(stdClass)#1 (1) {  ["foo"]=>  string(3) "bar" }
$unset_obj->foo = 'bar';
var_dump($unset_obj);
?>

依赖未初始化变量的默认值在某些情况下会有问题，例如把一个文件包含到另一个之中时碰上相同的变量名。 使用未初始化的变量会发出 E_NOTICE 错误，但是在向一个未初始化的数组附加单元时不会。isset() 语言结构可以用来检测一个变量是否已被初始化。


预定义变量

PHP 提供了大量的预定义变量。由于许多变量依赖于运行的服务器的版本和设置，及其它因素，所以并没有详细的说明文档。一些预定义变量在 PHP 以命令行形式运行时并不生效。 详细参阅预定义变量一章。

PHP 提供了一套附加的预定数组，这些数组变量包含了来自 web 服务器（如果可用），运行环境，和用户输入的数据。这些数组非常特别，它们在全局范围内自动生效，例如，在任何范围内自动生效。因此通常被称为自动全局变量（autoglobals）或者超全局变量（superglobals）。（PHP 中没有用户自定义超全局变量的机制。） 详情参阅超全局变量列表。

Note: 可变变量

超级全局变量不能被用作函数或类方法中的可变变量。

如果某些 variables_order 中的变量没有设定，它们的对应的 PHP 预定义数组也是空的。


变量范围

变量的范围即它定义的上下文背景（也就是它的生效范围）。大部分的 PHP 变量只有一个单独的范围。这个单独的范围跨度同样包含了 include 和 require 引入的文件。例如：

<?php
$a = 1;
include 'b.inc';
?>

这里变量 $a 将会在包含文件 b.inc 中生效。但是，在用户自定义函数中，一个局部函数范围将被引入。任何用于函数内部的变量按缺省情况将被限制在局部函数范围内。例如：

<?php
$a = 1; /* global scope */

function Test()
{
    echo $a; /* reference to local scope variable */
}

Test();
?>

这个脚本不会有任何输出，因为 echo 语句引用了一个局部版本的变量 $a，而且在这个范围内，它并没有被赋值。你可能注意到 PHP 的全局变量和 C 语言有一点点不同，在 C 语言中，全局变量在函数中自动生效，除非被局部变量覆盖。这可能引起一些问题，有些人可能不小心就改变了一个全局变量。PHP 中全局变量在函数中使用时必须声明为 global。

global 关键字

首先，一个使用 global 的例子：

Example #1 使用 global

<?php
$a = 1;
$b = 2;

function Sum()
{
    global $a, $b;

    $b = $a + $b;
}

Sum();
echo $b;
?>

以上脚本的输出将是"3"。在函数中声明了全局变量 $a 和 $b 之后，对任一变量的所有引用都会指向其全局版本。对于一个函数能够声明的全局变量的最大个数，PHP 没有限制。

在全局范围内访问变量的第二个办法，是用特殊的 PHP 自定义 $GLOBALS 数组。前面的例子可以写成：

Example #2 使用 $GLOBALS 替代 global

<?php
$a = 1;
$b = 2;

function Sum()
{
    $GLOBALS['b'] = $GLOBALS['a'] + $GLOBALS['b'];
}

Sum();
echo $b;
?>

$GLOBALS 是一个关联数组，每一个变量为一个元素，键名对应变量名，值对应变量的内容。$GLOBALS 之所以在全局范围内存在，是因为 $GLOBALS 是一个超全局变量。以下范例显示了超全局变量的用处：

Example #3 演示超全局变量和作用域的例子

<?php
function test_superglobal()
{
    echo $_POST['name'];
}
?>

使用静态变量

变量范围的另一个重要特性是静态变量（static variable）。静态变量仅在局部函数域中存在，但当程序执行离开此作用域时，其值并不丢失。看看下面的例子：

Example #4 演示需要静态变量的例子

<?php
function Test()
{
    $a = 0;
    echo $a;
    $a++;
}
?>

本函数没什么用处，因为每次调用时都会将 $a 的值设为 0 并输出 0。将变量加一的 $a++ 没有作用，因为一旦退出本函数则变量 $a 就不存在了。要写一个不会丢失本次计数值的计数函数，要将变量 $a 定义为静态的：

Example #5 使用静态变量的例子

<?php
function test()
{
    static $a = 0;
    echo $a;
    $a++;
}
?>

现在，变量 $a 仅在第一次调用 test() 函数时被初始化，之后每次调用 test() 函数都会输出 $a 的值并加一。

静态变量也提供了一种处理递归函数的方法。递归函数是一种调用自己的函数。写递归函数时要小心，因为可能会无穷递归下去。必须确保有充分的方法来中止递归。以下这个简单的函数递归计数到 10，使用静态变量 $count 来判断何时停止：

Example #6 静态变量与递归函数

<?php
function test()
{
    static $count = 0;

    $count++;
    echo $count;
    if ($count < 10) {
        test();
    }
    $count--;
}
?>

Static variables can be assigned values which are the, result of constant expressions, but dynamic expressions, such as function calls, will cause a parse error.

Example #7 声明静态变量

<?php
function foo(){
    static $int = 0;          // correct
    static $int = 1+2;        // correct
    static $int = sqrt(121);  // wrong  (as it is a function)

    $int++;
    echo $int;
}
?>

静态声明是在编译时解析的。

全局和静态变量的引用

对于变量的 static 和 global 定义是以引用的方式实现的。例如，在一个函数域内部用 global 语句导入的一个真正的全局变量实际上是建立了一个到全局变量的引用。这有可能导致预料之外的行为，如以下例子所演示的：

<?php
function test_global_ref() {
    global $obj;
    $new = new stdclass;
    $obj = &$new;
}

function test_global_noref() {
    global $obj;
    $new = new stdclass;
    $obj = $new;
}

test_global_ref();
var_dump($obj);
test_global_noref();
var_dump($obj);
?>

以上例程会输出：

NULL
object(stdClass)#1 (0) {
}

类似的行为也适用于 static 语句。引用并不是静态地存储的：

<?php
function &get_instance_ref() {
    static $obj;

    echo 'Static object: ';
    var_dump($obj);
    if (!isset($obj)) {
        $new = new stdclass;
        // 将一个引用赋值给静态变量
        $obj = &$new;
    }
    if (!isset($obj->property)) {
        $obj->property = 1;
    } else {
        $obj->property++;
    }
    return $obj;
}

function &get_instance_noref() {
    static $obj;

    echo 'Static object: ';
    var_dump($obj);
    if (!isset($obj)) {
        $new = new stdclass;
        // 将一个对象赋值给静态变量
        $obj = $new;
    }
    if (!isset($obj->property)) {
        $obj->property = 1;
    } else {
        $obj->property++;
    }
    return $obj;
}

$obj1 = get_instance_ref();
$still_obj1 = get_instance_ref();
echo "\n";
$obj2 = get_instance_noref();
$still_obj2 = get_instance_noref();
?>

以上例程会输出：

Static object: NULL
Static object: NULL

Static object: NULL
Static object: object(stdClass)#3 (1) {
  ["property"]=>
  int(1)
}

上例演示了当把一个引用赋值给一个静态变量时，第二次调用 &get_instance_ref() 函数时其值并没有被记住。


可变变量

有时候使用可变变量名是很方便的。就是说，一个变量的变量名可以动态的设置和使用。一个普通的变量通过声明来设置，例如：

<?php
$a = 'hello';
?>

一个可变变量获取了一个普通变量的值作为这个可变变量的变量名。在上面的例子中 hello 使用了两个美元符号（$）以后，就可以作为一个可变变量的变量了。例如：

<?php
$$a = 'world';
?>

这时，两个变量都被定义了：$a 的内容是"hello"并且 $hello 的内容是"world"。因此，以下语句：

<?php
echo "$a ${$a}";
?>

与以下语句输出完全相同的结果：

<?php
echo "$a $hello";
?>

它们都会输出：hello world。

要将可变变量用于数组，必须解决一个模棱两可的问题。这就是当写下 $$a[1] 时，解析器需要知道是想要 $a[1] 作为一个变量呢，还是想要 $$a 作为一个变量并取出该变量中索引为 [1] 的值。解决此问题的语法是，对第一种情况用 ${$a[1]}，对第二种情况用 ${$a}[1]。

类的属性也可以通过可变属性名来访问。可变属性名将在该调用所处的范围内被解析。例如，对于 $foo->$bar 表达式，则会在本地范围来解析 $bar 并且其值将被用于 $foo 的属性名。对于 $bar 是数组单元时也是一样。

也可使用花括号来给属性名清晰定界。最有用是在属性位于数组中，或者属性名包含有多个部分或者属性名包含有非法字符时（例如来自 json_decode() 或 SimpleXML）。

Example #1 可变属性示例

<?php
class foo {
    var $bar = 'I am bar.';
    var $arr = array('I am A.', 'I am B.', 'I am C.');
    var $r   = 'I am r.';
}

$foo = new foo();
$bar = 'bar';
$baz = array('foo', 'bar', 'baz', 'quux');
echo $foo->$bar . "\n";
echo $foo->{$baz[1]} . "\n";

$start = 'b';
$end   = 'ar';
echo $foo->{$start . $end} . "\n";

$arr = 'arr';
echo $foo->{$arr[1]} . "\n";

?>

以上例程会输出：

I am bar.
I am bar.
I am bar.
I am r.

Warning

注意，在 PHP 的函数和类的方法中，超全局变量不能用作可变变量。$this 变量也是一个特殊变量，不能被动态引用。


来自 PHP 之外的变量

HTML 表单（GET 和 POST）

当一个表单提交给 PHP 脚本时，表单中的信息会自动在脚本中可用。有几个方法访问此信息，例如：

Example #1 一个简单的 HTML 表单

<form action="foo.php" method="POST">
    Name:  <input type="text" name="username"><br />
    Email: <input type="text" name="email"><br />
    <input type="submit" name="submit" value="Submit me!" />
</form>

只有两种方法可以访问 HTML 表单中的数据。 以下列出了当前有效的方法：

Example #2 从一个简单的 POST HTML 表单访问数据

<?php
        echo $_POST['username'];
        echo $_REQUEST['username'];
        ?>

使用 GET 表单也类似，只不过要用适当的 GET 预定义变量。GET 也适用于 QUERY_STRING（URL 中在"?"之后的信息）。因此，举例说，http://www.example.com/test.php?id=3 包含有可用 $_GET['id'] 来访问的 GET 数据。参见 $_REQUEST。

Note:

变量名中的点和空格被转换成下划线。例如 <input name="a.b" /> 变成了 $_REQUEST["a_b"]。

PHP 也懂得表单变量上下文中的数组（参见相关常见问题）。例如可以将相关的变量编成组，或者用此特性从多选输入框中取得值。例如，将一个表单 POST 给自己并在提交时显示数据：

Example #3 更复杂的表单变量

<?php
if (isset($_POST['action']) && $_POST['action'] == 'submitted') {
    echo '<pre>';

    print_r($_POST);
    echo '<a href="'. $_SERVER['PHP_SELF'] .'">Please try again</a>';

    echo '</pre>';
} else {
?>
<form action="<?php echo $_SERVER['PHP_SELF']; ?>" method="post">
    Name:  <input type="text" name="personal[name]"><br />
    Email: <input type="text" name="personal[email]"><br />
    Beer: <br>
    <select multiple name="beer[]">
        <option value="warthog">Warthog</option>
        <option value="guinness">Guinness</option>
        <option value="stuttgarter">Stuttgarter Schwabenbr</option>
    </select><br />
    <input type="hidden" name="action" value="submitted" />
    <input type="submit" name="submit" value="submit me!" />
</form>
<?php
}
?>

Note: If an external variable name begins with a valid array syntax, trailing characters are silently ignored. For example, <input name="foo[bar]baz"> becomes $_REQUEST['foo']['bar'].

IMAGE SUBMIT 变量名

当提交表单时，可以用一幅图像代替标准的提交按钮，用类似这样的标记：

<input type="image" src="image.gif" name="sub" />

当用户点击到图像中的某处时，相应的表单会被传送到服务器，并加上两个变量 sub_x 和 sub_y。它们包含了用户点击图像的坐标。有经验的用户可能会注意到被浏览器发送的实际变量名包含的是一个点而不是下划线（即 sub.x 和 sub.y），但 PHP 自动将点转换成了下划线。

HTTP Cookies

PHP 透明地支持 » RFC 6265定义中的 HTTP cookies。Cookies 是一种在远端浏览器端存储数据并能追踪或识别再次访问的用户的机制。可以用 setcookie() 函数设定 cookies。Cookies 是 HTTP 信息头中的一部分，因此 SetCookie 函数必须在向浏览器发送任何输出之前调用。对于 header() 函数也有同样的限制。Cookie 数据会在相应的 cookie 数据数组中可用，例如 $_COOKIE 和 $_REQUEST。更多细节和例子见 setcookie() 手册页面。

Note: As of PHP 7.2.34, 7.3.23 and 7.4.11, respectively, the names of incoming cookies are no longer url-decoded for security reasons.

如果要将多个值赋给一个 cookie 变量，必须将其赋成数组。例如：

<?php
  setcookie("MyCookie[foo]", 'Testing 1', time()+3600);
  setcookie("MyCookie[bar]", 'Testing 2', time()+3600);
?>

这将会建立两个单独的 cookie，尽管 MyCookie 在脚本中是一个单一的数组。如果想在仅仅一个 cookie 中设定多个值，考虑先在值上使用 serialize() 或 explode()。

注意在浏览器中一个 cookie 会替换掉上一个同名的 cookie，除非路径或者域不同。因此对于购物车程序可以保留一个计数器并一起传递，例如：

Example #4 一个 setcookie() 的示例

<?php
if (isset($_COOKIE['count'])) {
    $count = $_COOKIE['count'] + 1;
} else {
    $count = 1;
}
setcookie('count', $count, time()+3600);
setcookie("Cart[$count]", $item, time()+3600);
?>

变量名中的点

通常，PHP 不会改变传递给脚本中的变量名。然而应该注意到点（句号）不是 PHP 变量名中的合法字符。至于原因，看看：

<?php
$varname.ext;  /* 非法变量名 */
?>
这时，解析器看到是一个名为 $varname 的变量，后面跟着一个字符串连接运算符，后面跟着一个裸字符串（即没有加引号的字符串，且不匹配任何已知的健名或保留字）'ext'。很明显这不是想要的结果。

出于此原因，要注意 PHP 将会自动将变量名中的点替换成下划线。

确定变量类型

因为 PHP 会判断变量类型并在需要时进行转换（通常情况下），因此在某一时刻给定的变量是何种类型并不明显。PHP 包括几个函数可以判断变量的类型，例如：gettype()，is_array()，is_float()，is_int()，is_object() 和 is_string()。参见类型一章。

HTTP being a text protocol, most, if not all, content that comes in Superglobal arrays, like $_POST and $_GET will remain as strings. PHP will not try to convert values to a specific type. In the example below, $_GET["var1"] will contain the string "null" and $_GET["var2"], the string "123".

/index.php?var1=null&var2=123

更新日志

版本 | 说明
7.2.34, 7.3.23, 7.4.11 | The names of incoming cookies are no longer url-decoded for security reasons.


常量

Table of Contents

  • 语法
  • 魔术常量

常量是一个简单值的标识符（名字）。如同其名称所暗示的，在脚本执行期间该值不能改变（除了所谓的 魔术常量，它们其实不是常量）。常量默认为大小写敏感。传统上常量标识符总是大写的。

常量名和其它任何 PHP 标签遵循同样的命名规则。合法的常量名以字母或下划线开始，后面跟着任何字母，数字或下划线。用正则表达式是这样表达的： ^[a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*$。

还可以使用 define() 来定义包含保留字或非常规名称的常量，这类常量可以通过 constant() 来获取名称，但是非常不推荐这种用法。

Tip

请参见用户空间命名指南。

Example #1 合法与非法的常量名

<?php

// 合法的常量名
define("FOO",     "something");
define("FOO2",    "something else");
define("FOO_BAR", "something more");

// 非法的常量名
define("2FOO",    "something");

// 下面的定义是合法的，但应该避免这样做：(自定义常量不要以__开头)
// 也许将来有一天 PHP 会定义一个 __FOO__ 的魔术常量
// 这样就会与你的代码相冲突
define("__FOO__", "something");

?>

Note: 在这里，字母指的是 a-z，A-Z，以及从 128 到 255（0x80-0xff）的 ASCII 字符。

和 superglobals 一样，常量的范围是全局的。不用管作用区域就可以在脚本的任何地方访问常量。有关作用区域的更多信息请阅读手册中的变量范围。


语法

在PHP 5.3.0 之后的版本中，你可以用 define() 函数，或 const 两种方法来定义一个常量。函数 define() 允许将常量定义为一个表达式，而 const 关键字有一些限制，具体可参见下述章节。一个常量一旦被定义，就不能再改变或者取消定义。

使用 const 关键字定义常量时，PHP 5.6 之前只能包含标量数据（boolean，integer，float 和 string）。从 PHP 5.6 开始，可以将常量定义为一个表达式，也可以定义为一个 array。还可以定义 resource 为常量，但应尽量避免，因为可能会造成不可预料的结果。

可以简单的通过指定其名字来取得常量的值，与变量不同，不应该在常量前面加上 $ 符号。如果常量名是动态的，也可以用函数 constant() 来获取常量的值。用 get_defined_constants() 可以获得所有已定义的常量列表。

Note: 常量和（全局）变量在不同的名字空间中。这意味着例如 true 和 $TRUE 是不同的。

如果使用了一个未定义的常量，PHP 假定想要的是该常量本身的名字，如同用字符串调用它一样（CONSTANT 对应 "CONSTANT"）。此方法已在 PHP 7.2.0 中被废弃，会抛出一个 E_WARNING 级错误。（之前版本会发出一个 E_NOTICE 级的错误。）参见手册中为什么 $foo[bar] 是错误的（除非事先用 define() 将 bar 定义为一个常量）。这不适用于 (完全)限定的常量，如果未定义，将引发致命错误。如果仅是检查是否定义了某常量，请使用 defined() 函数。

常量和变量有如下不同：

  • 常量前面没有美元符号（$）；
  • PHP 5.3 之前，常量只能用 define() 函数定义，而不能通过赋值语句；
  • 常量可以不用理会变量的作用域而在任何地方定义和访问；
  • 常量一旦定义就不能被重新定义或者取消定义；
  • 常量的值只能是标量值。从 PHP 5.6 开始可以用 const 关键字来定义数组常量，从 PHP 7 开始也可以用 define() 函数来定义。你可以在常量标量表达式中使用数组（例如 const FOO = array(1,2,3)[0];），但是要求最终的结果必须是一个允许的类型的值。

Example #1 定义常量

<?php
define("CONSTANT", "Hello world.");
echo CONSTANT; // outputs "Hello world."
echo Constant; // 输出 "Constant" 并发出一个提示级别错误信息
?>

Example #2 使用关键字 const 定义常量

<?php
// 以下代码在 PHP 5.3.0 后可以正常工作
const CONSTANT = 'Hello World';

echo CONSTANT;

// PHP 5.6.0 后的写法
const ANOTHER_CONST = CONSTANT.'; Goodbye World';
echo ANOTHER_CONST;

const ANIMALS = array('dog', 'cat', 'bird');
echo ANIMALS[1]; // 将输出 "cat"

// PHP 7 中的写法
define('ANIMALS', array(
    'dog',
    'cat',
    'bird'
));
echo ANIMALS[1]; // 将输出 "cat"
?>

?>

Note:

和使用 define() 来定义常量相反的是，使用 const 关键字定义常量必须处于最顶端的作用区域，因为用此方法是在编译时定义的。这就意味着不能在函数内，循环内以及 if 或 try/catch 语句之内用 const 来定义常量。

Note:

使用 const 关键字定义的常量总是大小写敏感的，而使用 define() 函数定义的常量可能不区分大小写。

参见类常量。


魔术常量

PHP 向它运行的任何脚本提供了大量的预定义常量。不过很多常量都是由不同的扩展库定义的，只有在加载了这些扩展库时才会出现，或者动态加载后，或者在编译时已经包括进去了。

有八个魔术常量它们的值随着它们在代码中的位置改变而改变。例如 __LINE__ 的值就依赖于它在脚本中所处的行来决定。这些特殊的常量不区分大小写，如下：

几个 PHP 的"魔术常量"
名称 | 说明
__LINE__ | 文件中的当前行号。
__FILE__ | 文件的完整路径和文件名。如果用在被包含文件中，则返回被包含的文件名。
__DIR__ | 文件所在的目录。如果用在被包括文件中，则返回被包括的文件所在的目录。它等价于 dirname(__FILE__)。除非是根目录，否则目录中名不包括末尾的斜杠。
__FUNCTION__ | 当前函数的名称。匿名函数则为 {closure}。
__CLASS__ | 当前类的名称。类名包括其被声明的作用区域（例如 Foo\Bar）。注意自 PHP 5.4 起 __CLASS__ 对 trait 也起作用。当用在 trait 方法中时，__CLASS__ 是调用 trait 方法的类的名字。
__TRAIT__ | Trait 的名字。Trait 名包括其被声明的作用区域（例如 Foo\Bar）。
__METHOD__ | 类的方法名。
__NAMESPACE__ | 当前命名空间的名称。
ClassName::class | 完整的类名，参见 ::class。

参见
get_class()
get_object_vars(),
file_exists() 和
function_exists()。

更新日志

版本 | 说明
5.5.0 | 增加 ::class 魔术常量
5.4.0 | 增加 __TRAIT__ 常量
5.3.0 | 增加 __DIR__ 和 __NAMESPACE__ 常量


表达式

表达式是 PHP 最重要的基石。在 PHP 中，几乎所写的任何东西都是一个表达式。简单但却最精确的定义一个表达式的方式就是"任何有值的东西"。

最基本的表达式形式是常量和变量。当键入"$a = 5"，即将值"5"分配给变量 $a。"5"，很明显，其值为 5，换句话说"5"是一个值为 5 的表达式（在这里，"5"是一个整型常量）。

赋值之后，所期待情况是 $a 的值为 5，因而如果写下 $b = $a，期望的是它犹如 $b = 5 一样。换句话说，$a 是一个值也为 5 的表达式。如果一切运行正确，那这正是将要发生的正确结果。

稍微复杂的表达式例子就是函数。例如，考虑下面的函数：

<?php
function foo ()
{
    return 5;
}
?>

假定已经熟悉了函数的概念（果不是的话，请看一下函数的相关章节），那么键入
$c = foo() 从本质上来说就如写下
$c = 5，这没错。函数也是表达式，表达式的值即为它们的返回值。既然
foo() 返回 5，表达式"foo()"的值也是 5。通常函数不会仅仅返回一个静态值，而可能会计算一些东西。

当然，PHP 中的值常常并非是整型的。PHP 支持四种标量值（标量值不能拆分为更小的单元，例如和数组不同）类型：整型值（integer），浮点数值（float），字符串值（string）和布尔值（boolean）。PHP 也支持两种复合类型：数组和对象。这两种类型具可以赋值给变量或者从函数返回。

PHP 和其它语言一样在表达式的道路上发展，但推进得更深远。PHP 是一种面向表达式的语言，从这一方面来讲几乎一切都是表达式。考虑刚才已经研究过的例子，"$a = 5"。很显然这里涉及到两个值，整型常量 5 的值以及而且变量 $a 的值，它也被更新为 5。但是事实是这里还涉及到一个额外的值，即附值语句本身的值。赋值语句本身求值为被赋的值，即 5。实际上这意味着"$a = 5"，不必管它是做什么的，是一个值为 5 的表达式。因而，这样写"$b = ($a = 5)"和这样写"$a =5; $b=5"（分号标志着语句的结束）是一样的。因为赋值操作的顺序是由右到左的，也可以这么写"$b = $a =5"。

另外一个很好的面向表达式的例子就是前、后递增和递减。PHP 和多数其它语言的用户应该比较熟悉变量 ++ 和变量 -- 符号。即递增和递减运算符。在 PHP/FI 2 中，语句"$a++"没有值（不是表达式），这样的话你便不能为其赋值或者以任何其它方式来使用它。PHP 通过将其变为了表达式，类似 C 语言，增强了递增/递减的能力。在 PHP 和 C 语言 中，有两种类型的递增前递增和后递增，本质上来讲，前递增和后递增均增加了变量的值，并且对于变量的影响是相同的。不同的是递增表达式的值。前递增，写做"++$variable"，求增加后的值（PHP 在读取变量的值之前，增加变量的值，因而称之为"前递增"）。后递增，写做"$variable++"，求变量未递增之前的原始值（PHP 在读取变量的值之后，增加变量的值，因而叫做"后递增"）。

一个常用到表达式类型是比较表达式。这些表达式求值 false 或 true。PHP 支持 >（大于），>=（大于等于），==（等于），!=（不等于），<（小于），<= (小于等于)。PHP 还支持全等运算符 ===（值和类型均相同）和非全等运算符 !==（值或者类型不同）。这些表达式都是在条件判断语句，比如，if 语句中最常用的。

这里，将要研究的最后一个例子是组合的运算赋值表达式。已经知道如果想要为变量 $a 加1，可以简单的写"$a++"或者"++$a"。但是如果想为变量增加大于 1 的值，比如 3，该怎么做？可以多次写"$a++"，但这样明显不是一种高效舒适的方法，一个更加通用的做法是"$a = $a + 3"。"$a + 3"计算 $a 加上 3 的值，并且得到的值重新赋予变量 $a，于是 $a 的值增加了3。在 PHP 及其它几种类似 C 的语言中，可以以一种更加简短的形式完成上述功能，因而也更加清楚快捷。为 $a 的当前值加 3，可以这样写："$a += 3"。这里的意思是"取变量 $a 的值，加 3，得到的结果再次分配给变量 $a"。除了更简略和清楚外，也可以更快的运行。"$a += 3"的值，如同一个正常赋值操作的值，是赋值后的值。注意它不是 3，而是 $a 的值加上3 之后的值（此值将被赋给 $a）。任何二元运算符都可以用运算赋值模式，例如"$a -= 5"（从变量 $a 的值中减去 5），"$b *= 7"（变量 $b 乘以 7），等等。

还有一个表达式，如果没有在别的语言中看到过的话，可能看上去很奇怪，即三元条件运算符：

$first ? $second : $third
如果第一个子表达式的值是 true（非零），那么计算第二个子表达式的值，其值即为整个表达式的值。否则，将是第三个子表达式的值。

下面的例子一般来说应该有助于理解前、后递增和表达式：

<?php
function double($i)
{
    return $i*2;
}
$b = $a = 5;        /* assign the value five into the variable $a and $b */
$c = $a++;          /* post-increment, assign original value of $a
                       (5) to $c */
$e = $d = ++$b;     /* pre-increment, assign the incremented value of
                       $b (6) to $d and $e */

/* at this point, both $d and $e are equal to 6 */

$f = double($d++);  /* assign twice the value of $d before
                       the increment, 2*6 = 12 to $f */
$g = double(++$e);  /* assign twice the value of $e after
                       the increment, 2*7 = 14 to $g */
$h = $g += 10;      /* first, $g is incremented by 10 and ends with the
                       value of 24. the value of the assignment (24) is
                       then assigned into $h, and $h ends with the value
                       of 24 as well. */
?>

一些表达式可以被当成语句。这时，一条语句的形式是 'expr' ';'，即一个表达式加一个分号结尾。在"$b=$a=5;"中，$a=5 是一个有效的表达式，但它本身不是一条语句。"$b=$a=5;"是一条有效的语句。

最后一件值得提起的事情就是表达式的真值。在许多事件中，大体上主要是在条件执行和循环中，不要专注于表达式中明确的值，反而要注意表达式的值是否是 true 或者 false。常量 true 和 false（大小写无关）是两种可能的 Boolean 值。如果有必要，一个表达式将自动转换为 Boolean。参见类型强制转换一节。

PHP 提供了一套完整强大的表达式，而为它提供完整的文件资料已经超出了本手册的范围。上面的例子应该为你提供了一个好的关于什么是表达式和怎样构建一个有用的表达式的概念。在本手册的其余部分，我们将始终使用 expr 来表示一个有效的 PHP 表达式。


运算符

Table of Contents

  • 运算符优先级
  • 算术运算符
  • 赋值运算符
  • 位运算符
  • 比较运算符
  • 错误控制运算符
  • 执行运算符
  • 递增／递减运算符
  • 逻辑运算符
  • 字符串运算符
  • 数组运算符
  • 类型运算符

运算符是可以通过给出的一或多个值（用编程行话来说，表达式）来产生另一个值（因而整个结构成为一个表达式）的东西。

运算符可按照其能接受几个值来分组。一元运算符只能接受一个值，例如 !（逻辑取反运算符）或 ++（递增运算符）。 二元运算符可接受两个值，例如熟悉的算术运算符 +（加）和 -（减），大多数 PHP 运算符都是这种。最后是唯一的三元运算符 ? :，可接受三个值；通常就简单称之为"三元运算符"（尽管称之为条件运算符可能更合适）。

PHP 的运算符完整列表见下节运算符优先级。该节也解释了运算符优先级和结合方向，这控制着在表达式包含有若干个不同运算符时究竟怎样对其求值。


运算符优先级

运算符优先级指定了两个表达式绑定得有多"紧密"。例如，表达式 1 + 5 * 3 的结果是 16 而不是 18 是因为乘号（"*"）的优先级比加号（"+"）高。必要时可以用括号来强制改变优先级。例如：(1 + 5) * 3 的值为 18。

如果运算符优先级相同，那运算符的结合方向决定了该如何运算。例如，"-"是左联的，那么 1 - 2 - 3 就等同于 (1 - 2) - 3 并且结果是 -4. 另外一方面，"="是右联的，所以 $a = $b = $c 等同于 $a = ($b = $c)。

没有结合的相同优先级的运算符不能连在一起使用，例如 1 < 2 > 1 在PHP是不合法的。但另外一方面表达式 1 <= 1 == 1 是合法的, 因为 == 的优先级低于 <=。

括号的使用，哪怕在不是必要的场合下，通过括号的配对来明确标明运算顺序，而非靠运算符优先级和结合性来决定，通常能够增加代码的可读性。

下表按照优先级从高到低列出了运算符。同一行中的运算符具有相同优先级，此时它们的结合方向决定求值顺序。

运算符优先级
结合方向 | 运算符 | 附加信息
不适用 | clone new | clone 和 new
右 | ** | 算术运算符
不适用 | ++ -- ~ (int) (float) (string) (array) (object) (bool) @ | 类型、递增／递减
左 | instanceof | 类型
不适用 | ! | 逻辑运算符
左 | * / % | 算术运算符
左 | + - . | 算术运算符 和 字符串运算符
左 | << >> | 位运算符
无 | < <= > >= | 比较运算符
无 | == != === !== <> <=> | 比较运算符
左 | & | 位运算符 和 引用
左 | ^ | 位运算符
左 | | | 位运算符
左 | && | 逻辑运算符
左 | || | 逻辑运算符
右 | ?? | null 合并运算符
左 | ? : | 三元运算符
右 | = += -= *= **= /= .= %= &= |= ^= <<= >>= ??= | 赋值运算符
不适用 | yield from | yield from
不适用 | yield | yield
不适用 | print | print
左 | and | 逻辑运算符
左 | xor | 逻辑运算符
左 | or | 逻辑运算符

Example #1 结合方向

<?php
$a = 3 * 3 % 5; // (3 * 3) % 5 = 4
// ternary operator associativity differs from C/C++
$a = true ? 0 : true ? 1 : 2; // (true ? 0 : true) ? 1 : 2 = 2

$a = 1;
$b = 2;
$a = $b += 3; // $a = ($b += 3) -> $a = 5, $b = 5
?>

Operator precedence and associativity only determine how expressions are grouped, they do not specify an order of evaluation. PHP does not (in the general case) specify in which order an expression is evaluated and code that assumes a specific order of evaluation should be avoided, because the behavior can change between versions of PHP or depending on the surrounding code.

Example #2 Undefined order of evaluation

<?php
$a = 1;
echo $a + $a++; // may print either 2 or 3

$i = 1;
$array[$i] = $i++; // may set either index 1 or 2
?>

Example #3 +、- 、. 具有相同的优先级

<?php
$x = 4;
// this line might result in unexpected output:
echo "x minus one equals " . $x-1 . ", or so I hope\n";
// because it is evaluated like this line:
echo (("x minus one equals " . $x) - 1) . ", or so I hope\n";
// the desired precedence can be enforced by using parentheses:
echo "x minus one equals " . ($x-1) . ", or so I hope\n";
?>

以上例程会输出：

-1, or so I hope
-1, or so I hope
x minus one equals 3, or so I hope

Note:

尽管 = 比其它大多数的运算符的优先级低，PHP
仍旧允许类似如下的表达式：if (!$a = foo())，在此例中
foo() 的返回值被赋给了 $a。


算术运算符

还记得学校里学到的基本数学知识吗？就和它们一样。

算术运算符
例子 | 名称 | 结果
+$a | 标识 | 根据情况将 $a 转化为 int 或 float。
-$a | 取反 | $a 的负值。
$a + $b | 加法 | $a 和 $b 的和。
$a - $b | 减法 | $a 和 $b 的差。
$a * $b | 乘法 | $a 和 $b 的积。
$a / $b | 除法 | $a 除以 $b 的商。
$a % $b | 取模 | $a 除以 $b 的余数。
$a ** $b | 求幂 | $a 的 $b次方的值。

除法运算符总是返回浮点数。只有在下列情况例外：两个操作数都是整数（或字符串转换成的整数）并且正好能整除，这时它返回一个整数。 整数除法可参考 intdiv()。

取模运算符的操作数在运算之前都会转换成整数（除去小数部分）。 浮点数取模可参考 fmod()。

取模运算符 % 的结果和被除数的符号（正负号）相同。即 $a % $b 的结果和 $a 的符号相同。例如：

<?php

echo (5 % 3)."\n";           // prints 2
echo (5 % -3)."\n";          // prints 2
echo (-5 % 3)."\n";          // prints -2
echo (-5 % -3)."\n";         // prints -2

?>

参见

  • 数学函数


赋值运算符

基本的赋值运算符是"="。一开始可能会以为它是"等于"，其实不是的。它实际上意味着把右边表达式的值赋给左边的运算数。

赋值运算表达式的值也就是所赋的值。也就是说，"$a = 3"的值是 3。这样就可以做一些小技巧：

<?php

$a = ($b = 4) + 5; // $a 现在成了 9，而 $b 成了 4。

?>

在基本赋值运算符之外，还有适合于所有二元算术，数组集合和字符串运算符的"组合运算符"，这样可以在一个表达式中使用它的值并把表达式的结果赋给它，例如：

<?php

$a = 3;
$a += 5; // sets $a to 8, as if we had said: $a = $a + 5;
$b = "Hello ";
$b .= "There!"; // sets $b to "Hello There!", just like $b = $b . "There!";

?>

注意赋值运算将原变量的值拷贝到新变量中（传值赋值），所以改变其中一个并不影响另一个。这也适合于在密集循环中拷贝一些值例如大数组。

在 PHP 中普通的传值赋值行为有个例外就是碰到对象 object 时，在 PHP 5 中是以引用赋值的，除非明确使用了 clone 关键字来拷贝。

引用赋值

PHP 支持引用赋值，使用"$var = &$othervar;"语法。引用赋值意味着两个变量指向了同一个数据，没有拷贝任何东西。

Example #1 引用赋值

<?php
$a = 3;
$b = &$a; // $b 是 $a 的引用

print "$a\n"; // 输出 3
print "$b\n"; // 输出 3

$a = 4; // 修改 $a

print "$a\n"; // 输出 4
print "$b\n"; // 也输出 4，因为 $b 是 $a 的引用，因此也被改变
?>

new 运算符自动返回一个引用，因此对 new 的结果进行引用赋值是错误的。

<?php
class C {}

$o = &new C;
?>

以上例程会输出：

Parse error: syntax error, unexpected 'new' (T_NEW) in ...

有关引用更多信息参见本手册中 引用的解释 一章。

算术赋值运算符

例子 | 等同于 | 操作
$a += $b | $a = $a + $b | 加法
$a -= $b | $a = $a - $b | 减法
$a *= $b | $a = $a * $b | 乘法
$a /= $b | $a = $a / $b | 除法
$a %= $b | $a = $a % $b | 取模
$a **= $b | $a = $a ** $b | 指数

位赋值运算符

例子 | 等同于 | 操作
$a &= $b | $a = $a & $b | 按位与
$a |= $b | $a = $a | $b | 按位或
$a ^= $b | $a = $a ^ $b | 按位异或
$a <<= $b | $a = $a << $b | 左移
$a >>= $b | $a = $a >> $b | 右移

其他赋值运算符

例子 | 等同于 | 操作
$a .= $b | $a = $a . $b | 字符串拼接
$a ??= $b | $a = $a ?? $b | NULL 合并

参见

  • 算术运算符
  • 位运算符
  • NULL 合并运算符


位运算符

位运算符允许对整型数中指定的位进行求值和操作。

位运算符
例子 | 名称 | 结果
$a & $b | And（按位与） | 将把 $a 和 $b 中都为 1 的位设为 1。
$a | $b | Or（按位或） | 将把 $a 和 $b 中任何一个为 1 的位设为 1。
$a ^ $b | Xor（按位异或） | 将把 $a 和 $b 中一个为 1 另一个为 0 的位设为 1。
~ $a | Not（按位取反） | 将 $a 中为 0 的位设为 1，反之亦然。
$a << $b | Shift left（左移） | 将 $a 中的位向左移动 $b 次（每一次移动都表示"乘以 2"）。
$a >> $b | Shift right（右移） | 将 $a 中的位向右移动 $b 次（每一次移动都表示"除以 2"）。

位移在 PHP 中是数学运算。向任何方向移出去的位都被丢弃。左移时右侧以零填充，符号位被移走意味着正负号不被保留。右移时左侧以符号位填充，意味着正负号被保留。

要用括号确保想要的优先级。例如 $a & $b == true 先进行比较再进行按位与；而 ($a & $b) == true 则先进行按位与再进行比较。

If both operands for the &, | and ^ operators are strings, then the operation will be performed on the ASCII values of the characters that make up the strings and the result will be a string. In all other cases, both operands will be converted to integers and the result will be an integer.

If the operand for the ~ operator is a string, the operation will be performed on the ASCII values of the characters that make up the string and the result will be a string, otherwise the operand and the result will be treated as integers.

Both operands and the result for the << and >> operators are always treated as integers.

PHP 的 ini 设定 error_reporting 使用了按位的值，
提供了关闭某个位的真实例子。要显示除了提示级别
之外的所有错误，php.ini 中是这样用的：
E_ALL & ~E_NOTICE

具体运作方式是先取得 E_ALL 的值：
00000000000000000111011111111111
再取得 E_NOTICE 的值：
00000000000000000000000000001000
然后通过 ~ 将其取反：
11111111111111111111111111110111
最后再用按位与 AND（&）得到两个值中都设定了（为 1）的位：
00000000000000000111011111110111

另外一个方法是用按位异或 XOR（^）来取得只在
其中一个值中设定了的位：
E_ALL ^ E_NOTICE

error_reporting 也可用来演示怎样置位。只显示错误和可恢复
错误的方法是：
E_ERROR | E_RECOVERABLE_ERROR

也就是将 E_ERROR
00000000000000000000000000000001
和 E_RECOVERABLE_ERROR
00000000000000000001000000000000
用按位或 OR（|）运算符来取得在任何一个值中被置位的结果：
00000000000000000001000000000001

Example #1 整数的 AND，OR 和 XOR 位运算符

<?php
/*
 * Ignore the top section,
 * it is just formatting to make output clearer.
 */

$format = '(%1$2d = %1$04b) = (%2$2d = %2$04b)'
        . ' %3$s (%4$2d = %4$04b)' . "\n";

echo <<<EOH
 ---------     ---------  -- ---------
 result        value      op test
 ---------     ---------  -- ---------
EOH;

/*
 * Here are the examples.
 */

$values = array(0, 1, 2, 4, 8);
$test = 1 + 4;

echo "\n Bitwise AND \n";
foreach ($values as $value) {
    $result = $value & $test;
    printf($format, $result, $value, '&', $test);
}

echo "\n Bitwise Inclusive OR \n";
foreach ($values as $value) {
    $result = $value | $test;
    printf($format, $result, $value, '|', $test);
}

echo "\n Bitwise Exclusive OR (XOR) \n";
foreach ($values as $value) {
    $result = $value ^ $test;
    printf($format, $result, $value, '^', $test);
}
?>

以上例程会输出：

 ---------     ---------  -- ---------
 result        value      op test
 ---------     ---------  -- ---------
 Bitwise AND
( 0 = 0000) = ( 0 = 0000) & ( 5 = 0101)
( 1 = 0001) = ( 1 = 0001) & ( 5 = 0101)
( 0 = 0000) = ( 2 = 0010) & ( 5 = 0101)
( 4 = 0100) = ( 4 = 0100) & ( 5 = 0101)
( 0 = 0000) = ( 8 = 1000) & ( 5 = 0101)

 Bitwise Inclusive OR
( 5 = 0101) = ( 0 = 0000) | ( 5 = 0101)
( 5 = 0101) = ( 1 = 0001) | ( 5 = 0101)
( 7 = 0111) = ( 2 = 0010) | ( 5 = 0101)
( 5 = 0101) = ( 4 = 0100) | ( 5 = 0101)
(13 = 1101) = ( 8 = 1000) | ( 5 = 0101)

 Bitwise Exclusive OR (XOR)
( 5 = 0101) = ( 0 = 0000) ^ ( 5 = 0101)
( 4 = 0100) = ( 1 = 0001) ^ ( 5 = 0101)
( 7 = 0111) = ( 2 = 0010) ^ ( 5 = 0101)
( 1 = 0001) = ( 4 = 0100) ^ ( 5 = 0101)
(13 = 1101) = ( 8 = 1000) ^ ( 5 = 0101)

Example #2 字符串的 XOR 运算符

<?php
echo 12 ^ 9; // Outputs '5'

echo "12" ^ "9"; // Outputs the Backspace character (ascii 8)
                 // ('1' (ascii 49)) ^ ('9' (ascii 57)) = #8

echo "hallo" ^ "hello"; // Outputs the ascii values #0 #4 #0 #0 #0
                        // 'a' ^ 'e' = #4

echo 2 ^ "3"; // Outputs 1
              // 2 ^ ((int)"3") == 1

echo "2" ^ 3; // Outputs 1
              // ((int)"2") ^ 3 == 1
?>

Example #3 整数的位移

<?php
/*
 * Here are the examples.
 */

echo "\n--- BIT SHIFT RIGHT ON POSITIVE INTEGERS ---\n";

$val = 4;
$places = 1;
$res = $val >> $places;
p($res, $val, '>>', $places, 'copy of sign bit shifted into left side');

$val = 4;
$places = 2;
$res = $val >> $places;
p($res, $val, '>>', $places);

$val = 4;
$places = 3;
$res = $val >> $places;
p($res, $val, '>>', $places, 'bits shift out right side');

$val = 4;
$places = 4;
$res = $val >> $places;
p($res, $val, '>>', $places, 'same result as above; can not shift beyond 0');

echo "\n--- BIT SHIFT RIGHT ON NEGATIVE INTEGERS ---\n";

$val = -4;
$places = 1;
$res = $val >> $places;
p($res, $val, '>>', $places, 'copy of sign bit shifted into left side');

$val = -4;
$places = 2;
$res = $val >> $places;
p($res, $val, '>>', $places, 'bits shift out right side');

$val = -4;
$places = 3;
$res = $val >> $places;
p($res, $val, '>>', $places, 'same result as above; can not shift beyond -1');

echo "\n--- BIT SHIFT LEFT ON POSITIVE INTEGERS ---\n";

$val = 4;
$places = 1;
$res = $val << $places;
p($res, $val, '<<', $places, 'zeros fill in right side');

$val = 4;
$places = (PHP_INT_SIZE * 8) - 4;
$res = $val << $places;
p($res, $val, '<<', $places);

$val = 4;
$places = (PHP_INT_SIZE * 8) - 3;
$res = $val << $places;
p($res, $val, '<<', $places, 'sign bits get shifted out');

$val = 4;
$places = (PHP_INT_SIZE * 8) - 2;
$res = $val << $places;
p($res, $val, '<<', $places, 'bits shift out left side');

echo "\n--- BIT SHIFT LEFT ON NEGATIVE INTEGERS ---\n";

$val = -4;
$places = 1;
$res = $val << $places;
p($res, $val, '<<', $places, 'zeros fill in right side');

$val = -4;
$places = (PHP_INT_SIZE * 8) - 3;
$res = $val << $places;
p($res, $val, '<<', $places);

$val = -4;
$places = (PHP_INT_SIZE * 8) - 2;
$res = $val << $places;
p($res, $val, '<<', $places, 'bits shift out left side, including sign bit');

/*
 * Ignore this bottom section,
 * it is just formatting to make output clearer.
 */

function p($res, $val, $op, $places, $note = '') {
    $format = '%0' . (PHP_INT_SIZE * 8) . "b\n";

    printf("Expression: %d = %d %s %d\n", $res, $val, $op, $places);

    echo " Decimal:\n";
    printf("  val=%d\n", $val);
    printf("  res=%d\n", $res);

    echo " Binary:\n";
    printf('  val=' . $format, $val);
    printf('  res=' . $format, $res);

    if ($note) {
        echo " NOTE: $note\n";
    }

    echo "\n";
}
?>

以上例程在 32 位机器上的输出:

--- BIT SHIFT RIGHT ON POSITIVE INTEGERS ---
Expression: 2 = 4 >> 1
 Decimal:
  val=4
  res=2
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000010
 NOTE: copy of sign bit shifted into left side

Expression: 1 = 4 >> 2
 Decimal:
  val=4
  res=1
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000001

Expression: 0 = 4 >> 3
 Decimal:
  val=4
  res=0
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000000
 NOTE: bits shift out right side

Expression: 0 = 4 >> 4
 Decimal:
  val=4
  res=0
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000000
 NOTE: same result as above; can not shift beyond 0

--- BIT SHIFT RIGHT ON NEGATIVE INTEGERS ---
Expression: -2 = -4 >> 1
 Decimal:
  val=-4
  res=-2
 Binary:
  val=11111111111111111111111111111100
  res=11111111111111111111111111111110
 NOTE: copy of sign bit shifted into left side

Expression: -1 = -4 >> 2
 Decimal:
  val=-4
  res=-1
 Binary:
  val=11111111111111111111111111111100
  res=11111111111111111111111111111111
 NOTE: bits shift out right side

Expression: -1 = -4 >> 3
 Decimal:
  val=-4
  res=-1
 Binary:
  val=11111111111111111111111111111100
  res=11111111111111111111111111111111
 NOTE: same result as above; can not shift beyond -1

--- BIT SHIFT LEFT ON POSITIVE INTEGERS ---
Expression: 8 = 4 << 1
 Decimal:
  val=4
  res=8
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000001000
 NOTE: zeros fill in right side

Expression: 1073741824 = 4 << 28
 Decimal:
  val=4
  res=1073741824
 Binary:
  val=00000000000000000000000000000100
  res=01000000000000000000000000000000

Expression: -2147483648 = 4 << 29
 Decimal:
  val=4
  res=-2147483648
 Binary:
  val=00000000000000000000000000000100
  res=10000000000000000000000000000000
 NOTE: sign bits get shifted out

Expression: 0 = 4 << 30
 Decimal:
  val=4
  res=0
 Binary:
  val=00000000000000000000000000000100
  res=00000000000000000000000000000000
 NOTE: bits shift out left side

--- BIT SHIFT LEFT ON NEGATIVE INTEGERS ---
Expression: -8 = -4 << 1
 Decimal:
  val=-4
  res=-8
 Binary:
  val=11111111111111111111111111111100
  res=11111111111111111111111111111000
 NOTE: zeros fill in right side

Expression: -2147483648 = -4 << 29
 Decimal:
  val=-4
  res=-2147483648
 Binary:
  val=11111111111111111111111111111100
  res=10000000000000000000000000000000

Expression: 0 = -4 << 30
 Decimal:
  val=-4
  res=0
 Binary:
  val=11111111111111111111111111111100
  res=00000000000000000000000000000000
 NOTE: bits shift out left side, including sign bit

以上例程在 64 位机器上的输出:

--- BIT SHIFT RIGHT ON POSITIVE INTEGERS ---
Expression: 2 = 4 >> 1
 Decimal:
  val=4
  res=2
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000010
 NOTE: copy of sign bit shifted into left side

Expression: 1 = 4 >> 2
 Decimal:
  val=4
  res=1
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000001

Expression: 0 = 4 >> 3
 Decimal:
  val=4
  res=0
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000000
 NOTE: bits shift out right side

Expression: 0 = 4 >> 4
 Decimal:
  val=4
  res=0
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000000
 NOTE: same result as above; can not shift beyond 0

--- BIT SHIFT RIGHT ON NEGATIVE INTEGERS ---
Expression: -2 = -4 >> 1
 Decimal:
  val=-4
  res=-2
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1111111111111111111111111111111111111111111111111111111111111110
 NOTE: copy of sign bit shifted into left side

Expression: -1 = -4 >> 2
 Decimal:
  val=-4
  res=-1
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1111111111111111111111111111111111111111111111111111111111111111
 NOTE: bits shift out right side

Expression: -1 = -4 >> 3
 Decimal:
  val=-4
  res=-1
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1111111111111111111111111111111111111111111111111111111111111111
 NOTE: same result as above; can not shift beyond -1

--- BIT SHIFT LEFT ON POSITIVE INTEGERS ---
Expression: 8 = 4 << 1
 Decimal:
  val=4
  res=8
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000001000
 NOTE: zeros fill in right side

Expression: 4611686018427387904 = 4 << 60
 Decimal:
  val=4
  res=4611686018427387904
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0100000000000000000000000000000000000000000000000000000000000000

Expression: -9223372036854775808 = 4 << 61
 Decimal:
  val=4
  res=-9223372036854775808
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=1000000000000000000000000000000000000000000000000000000000000000
 NOTE: sign bits get shifted out

Expression: 0 = 4 << 62
 Decimal:
  val=4
  res=0
 Binary:
  val=0000000000000000000000000000000000000000000000000000000000000100
  res=0000000000000000000000000000000000000000000000000000000000000000
 NOTE: bits shift out left side

--- BIT SHIFT LEFT ON NEGATIVE INTEGERS ---
Expression: -8 = -4 << 1
 Decimal:
  val=-4
  res=-8
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1111111111111111111111111111111111111111111111111111111111111000
 NOTE: zeros fill in right side

Expression: -9223372036854775808 = -4 << 61
 Decimal:
  val=-4
  res=-9223372036854775808
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=1000000000000000000000000000000000000000000000000000000000000000

Expression: 0 = -4 << 62
 Decimal:
  val=-4
  res=0
 Binary:
  val=1111111111111111111111111111111111111111111111111111111111111100
  res=0000000000000000000000000000000000000000000000000000000000000000
 NOTE: bits shift out left side, including sign bit

Warning

使用 gmp 扩展对超出 PHP_INT_MAX 的数值来进行位操作。

参见

  • pack()
  • unpack()
  • gmp_and()
  • gmp_or()
  • gmp_xor()
  • gmp_testbit()
  • gmp_clrbit()


比较运算符

比较运算符，如同它们名称所暗示的，允许对两个值进行比较。还可以参考 PHP 类型比较表看不同类型相互比较的例子。

比较运算符
例子 | 名称 | 结果
$a == $b | 等于 | true，如果类型转换后 $a 等于 $b。
$a === $b | 全等 | true，如果 $a 等于 $b，并且它们的类型也相同。
$a != $b | 不等 | true，如果类型转换后 $a 不等于 $b。
$a <> $b | 不等 | true，如果类型转换后 $a 不等于 $b。
$a !== $b | 不全等 | true，如果 $a 不等于 $b，或者它们的类型不同。
$a < $b | 小与 | true，如果 $a 严格小于 $b。
$a > $b | 大于 | true，如果 $a 严格大于 $b。
$a <= $b | 小于等于 | true，如果 $a 小于或者等于 $b。
$a >= $b | 大于等于 | true，如果 $a 大于或者等于 $b。
$a <=> $b | 太空船运算符（组合比较符） | 当$a小于、等于、大于 $b时 分别返回一个小于、等于、大于0的 int 值。

当两个操作对象都是 数字字符串， 或一个是数字另一个是 数字字符串， 就会自动按照数值进行比较。 此规则也适用于 switch 语句。 当比较时用的是 === 或 !==， 则不会进行类型转换——因为不仅要对比数值，还要对比类型。

Warning

Prior to PHP 8.0.0, if a string is compared to a number or a numeric string then the string was converted to a number before performing the comparison. This can lead to surprising results as can be seen with the following example:

<?php
var_dump(0 == "a"); // 0 == 0 -> true
var_dump("1" == "01"); // 1 == 1 -> true
var_dump("10" == "1e1"); // 10 == 10 -> true
var_dump(100 == "1e2"); // 100 == 100 -> true

switch ("a") {
case 0:
    echo "0";
    break;
case "a": // never reached because "a" is already matched with 0
    echo "a";
    break;
}
?>

<?php
// Integers
echo 1 <=> 1; // 0
echo 1 <=> 2; // -1
echo 2 <=> 1; // 1

// Floats
echo 1.5 <=> 1.5; // 0
echo 1.5 <=> 2.5; // -1
echo 2.5 <=> 1.5; // 1

// Strings
echo "a" <=> "a"; // 0
echo "a" <=> "b"; // -1
echo "b" <=> "a"; // 1

echo "a" <=> "aa"; // -1
echo "zz" <=> "aa"; // 1

// Arrays
echo [] <=> []; // 0
echo [1, 2, 3] <=> [1, 2, 3]; // 0
echo [1, 2, 3] <=> []; // 1
echo [1, 2, 3] <=> [1, 2, 1]; // 1
echo [1, 2, 3] <=> [1, 2, 4]; // -1

// Objects
$a = (object) ["a" => "b"];
$b = (object) ["a" => "b"];
echo $a <=> $b; // 0

$a = (object) ["a" => "b"];
$b = (object) ["a" => "c"];
echo $a <=> $b; // -1

$a = (object) ["a" => "c"];
$b = (object) ["a" => "b"];
echo $a <=> $b; // 1

// not only values are compared; keys must match
$a = (object) ["a" => "b"];
$b = (object) ["b" => "b"];
echo $a <=> $b; // 1

?>

对于多种类型，比较运算符根据下表比较（按顺序）。

比较多种类型
运算数 1 类型 | 运算数 2 类型 | 结果
null 或 string | string | 将 null 转换为 ""，进行数字或词汇比较
bool 或 null | 任何其它类型 | 转换为 bool，false < true
object | object | 内置类可以定义自己的比较，不同类不能比较，相同类和数组同样方式比较属性（PHP 4 中），PHP 5 有其自己的说明
string、resource、int、float | string、resource、int、float | 将字符串和资源转换成数字，按普通数学比较
array | array | 具有较少成员的数组较小，如果运算数 1 中的键不存在于运算数 2 中则数组无法比较，否则挨个值比较（见下例）
object | 任何其它类型 | object 总是更大
array | 任何其它类型 | array 总是更大

Example #1 Boolean/null comparison

<?php
// Bool and null are compared as bool always
var_dump(1 == TRUE);  // TRUE - same as (bool)1 == TRUE
var_dump(0 == FALSE); // TRUE - same as (bool)0 == FALSE
var_dump(100 < TRUE); // FALSE - same as (bool)100 < TRUE
var_dump(-10 < FALSE);// FALSE - same as (bool)-10 < FALSE
var_dump(min(-100, -10, NULL, 10, 100)); // NULL - (bool)NULL < (bool)-100 is FALSE < TRUE
?>

Example #2 标准数组比较代码

<?php
// 数组是用标准比较运算符这样比较的
function standard_array_compare($op1, $op2)
{
    if (count($op1) < count($op2)) {
        return -1; // $op1 < $op2
    } elseif (count($op1) > count($op2)) {
        return 1; // $op1 > $op2
    }
    foreach ($op1 as $key => $val) {
        if (!array_key_exists($key, $op2)) {
            return null; // uncomparable
        } elseif ($val < $op2[$key]) {
            return -1;
        } elseif ($val > $op2[$key]) {
            return 1;
        }
    }
    return 0; // $op1 == $op2
}
?>

Warning

比较浮点数

由于浮点数 float 的内部表达方式，不应比较两个浮点数float是否相等。

更多信息参见 float。

参见

  • strcasecmp()
  • strcmp()
  • 数组运算符
  • 类型

三元运算符

另一个条件运算符是"?:"（或三元）运算符 。

Example #3 赋默认值

<?php
// 三元运算符的例子
$action = (empty($_POST['action'])) ? 'default' : $_POST['action'];

// 以上等同于以下的  if/else 语句
if (empty($_POST['action'])) {
    $action = 'default';
} else {
    $action = $_POST['action'];
}

?>
表达式 (expr1) ? (expr2) : (expr3) 在 expr1 求值为 true 时的值为 expr2，在 expr1 求值为 false 时的值为 expr3。

可以省略三元运算符中间那部分。表达式 expr1 ?: expr3 在 expr1 求值为 true 时返回 expr1，否则返回 expr3。

Note: 注意三元运算符是个语句，因此其求值不是变量，而是语句的结果。如果想通过引用返回一个变量这点就很重要。在一个通过引用返回的函数中语句 return $var == 42 ? $a : $b; 将不起作用，以后的 PHP 版本会为此发出一条警告。

Note:

建议避免将三元运算符堆积在一起使用。和其他语言相比， 当在一条语句中使用多个三元运算符时会造成 PHP 运算结果不清晰。 甚至在 PHP 8.0.0 之前，三元运算符是从左到右执行的， 而大多数其他编程语言是从右到左的。

Example #4 不清晰的三元运算符行为

<?php
// 乍看起来下面的输出是 'true'
echo (true?'true':false?'t':'f');

// 然而，上面语句的实际输出是't'，因为在 PHP 8.0.0 之前三元运算符是从左往右计算的

// 下面是与上面等价的语句，但更清晰
echo ((true ? 'true' : 'false') ? 't' : 'f');

// here, one can see that the first expression is evaluated to 'true', which
// in turn evaluates to (bool)true, thus returning the true branch of the
// second ternary expression.
?>

NULL 合并运算符

而且存在 "??" （NULL 合并）运算符。

Example #5 设置默认值

<?php
// NULL 合并运算符的例子
$action = $_POST['action'] ?? 'default';

// 以上例子等同于于以下 if/else 语句
if (isset($_POST['action'])) {
    $action = $_POST['action'];
} else {
    $action = 'default';
}

?>
当 expr1 为 null，表达式 (expr1) ?? (expr2) 等同于 expr2，否则为 expr1。

尤其要注意，当不存在左侧的值时，此运算符也和 isset() 一样不会产生警告。 对于 array 键尤其有用。

Note: 请注意：NULL 合并运算符是一个表达式，产生的也是表达式结果，而不是变量。 返回引用变量时需要强调这一点。 因此，在返回引用的函数里就无法使用这样的语句：return $foo ?? $bar;，还会提示警告。

Note:

请注意，NULL 合并运算符支持简单的嵌套：

Example #6 嵌套 NULL 合并运算符

<?php

$foo = null;
$bar = null;
$baz = 1;
$qux = 2;

echo $foo ?? $bar ?? $baz ?? $qux; // 输出 1

?>


错误控制运算符

PHP 支持一个错误控制运算符：@。当将其放置在一个 PHP 表达式之前，该表达式可能产生的任何错误信息都被忽略掉。

如果用 set_error_handler() 设定了自定义的错误处理函数，仍然会被调用，但是此错误处理函数可以（并且也应该）调用 error_reporting()，而该函数在出错语句前有 @ 时将返回 0。

error_get_last() 返回数组中的 "message" 元素储存了表达式产生的任意错误信息。 此函数的返回结果会随着每次错误的发生而相应变化，所以需要尽早检查。

<?php
/* Intentional file error */
$my_file = @file ('non_existent_file') or
    die ("Failed opening file: error was '" . error_get_last()['message'] . "'");

// this works for any expression, not just functions:
$value = @$cache[$key];
// will not issue a notice if the index $key doesn't exist.

?>

Note: @ 运算符只对表达式有效。对新手来说一个简单的规则就是：如果能从某处得到值，就能在它前面加上 @ 运算符。例如，可以把它放在变量，函数和 include 调用，常量，等等之前。不能把它放在函数或类的定义之前，也不能用于条件结构例如 if 和 foreach 等。

Warning

目前的"@"错误控制运算符前缀甚至使导致脚本终止的严重错误的错误报告也失效。 这意味着如果在某个不存在或者敲错了字母的函数调用前用了"@"来抑制错误信息， 那脚本会没有任何迹象显示原因而死在那里。

参见

  • error_reporting()
  • 错误处理与日志记录函数


执行运算符

PHP 支持一个执行运算符：反引号（``）。注意这不是单引号！PHP 将尝试将反引号中的内容作为 shell 命令来执行，并将其输出信息返回（即，可以赋给一个变量而不是简单地丢弃到标准输出）。使用反引号运算符"`"的效果与函数 shell_exec() 相同。

<?php
$output = `ls -al`;
echo "<pre>$output</pre>";
?>

Note:

关闭了 shell_exec() 时反引号运算符是无效的。

Note:

与其它某些语言不同，反引号不能在双引号字符串中使用。

参见

  • 程序执行函数
  • popen()
  • proc_open()
  • PHP 的命令行模式


递增／递减运算符

PHP 支持 C 风格的前／后递增与递减运算符。

Note: 递增／递减运算符不影响布尔值。递减 null 值也没有效果，但是递增 null 的结果是 1。

递增／递减运算符
例子 | 名称 | 效果
++$a | 前加 | $a 的值加一，然后返回 $a。
$a++ | 后加 | 返回 $a，然后将 $a 的值加一。
--$a | 前减 | $a 的值减一， 然后返回 $a。
$a-- | 后减 | 返回 $a，然后将 $a 的值减一。

一个简单的示例脚本：

<?php
echo "<h3>Postincrement</h3>";
$a = 5;
echo "Should be 5: " . $a++ . "<br />\n";
echo "Should be 6: " . $a . "<br />\n";

echo "<h3>Preincrement</h3>";
$a = 5;
echo "Should be 6: " . ++$a . "<br />\n";
echo "Should be 6: " . $a . "<br />\n";

echo "<h3>Postdecrement</h3>";
$a = 5;
echo "Should be 5: " . $a-- . "<br />\n";
echo "Should be 4: " . $a . "<br />\n";

echo "<h3>Predecrement</h3>";
$a = 5;
echo "Should be 4: " . --$a . "<br />\n";
echo "Should be 4: " . $a . "<br />\n";
?>

在处理字符变量的算数运算时，PHP 沿袭了 Perl 的习惯，而非 C 的。例如，在 Perl 中 $a = 'Z'; $a++; 将把 $a 变成'AA'，而在 C 中，a = 'Z'; a++; 将把 a 变成 '['（'Z' 的 ASCII 值是 90，'[' 的 ASCII 值是 91）。注意字符变量只能递增，不能递减，并且只支持纯字母（a-z 和 A-Z）。递增／递减其他字符变量则无效，原字符串没有变化。

Example #1 涉及字符变量的算数运算

<?php
echo '== Alphabets ==' . PHP_EOL;
$s = 'W';
for ($n=0; $n<6; $n++) {
    echo ++$s . PHP_EOL;
}
// Digit characters behave differently
echo '== Digits ==' . PHP_EOL;
$d = 'A8';
for ($n=0; $n<6; $n++) {
    echo ++$d . PHP_EOL;
}
$d = 'A08';
for ($n=0; $n<6; $n++) {
    echo ++$d . PHP_EOL;
}
?>

以上例程会输出：

== Characters ==
X
Y
Z
AA
AB
AC
== Digits ==
A9
B0
B1
B2
B3
B4
A09
A10
A11
A12
A13
A14

递增或递减布尔值没有效果。


逻辑运算符

逻辑运算符
例子 | 名称 | 结果
$a and $b | And（逻辑与） | true，如果 $a 和 $b 都为 true。
$a or $b | Or（逻辑或） | true，如果 $a 或 $b 任一为 true。
$a xor $b | Xor（逻辑异或） | true，如果 $a 或 $b 任一为 true，但不同时是。
! $a | Not（逻辑非） | true，如果 $a 不为 true。
$a && $b | And（逻辑与） | true，如果 $a 和 $b 都为 true。
$a || $b | Or（逻辑或） | true，如果 $a 或 $b 任一为 true。

"与"和"或"有两种不同形式运算符的原因是它们运算的优先级不同（见运算符优先级）。

Example #1 逻辑运算符示例

<?php

// --------------------
// foo() 根本没机会被调用，被运算符"短路"了

$a = (false && foo());
$b = (true  || foo());
$c = (false and foo());
$d = (true  or  foo());

// --------------------
// "||" 比 "or" 的优先级高

// 表达式 (false || true) 的结果被赋给 $e
// 等同于：($e = (false || true))
$e = false || true;

// 常量 false 被赋给 $f，true 被忽略
// 等同于：(($f = false) or true)
$f = false or true;

var_dump($e, $f);

// --------------------
// "&&" 比 "and" 的优先级高

// 表达式 (true && false) 的结果被赋给 $g
// 等同于：($g = (true && false))
$g = true && false;

// 常量 true 被赋给 $h，false 被忽略
// 等同于：(($h = true) and false)
$h = true and false;

var_dump($g, $h);
?>

以上例程的输出类似于：

bool(true)
bool(false)
bool(false)
bool(true)


字符串运算符

有两个字符串（string）运算符。第一个是连接运算符（"."），它返回其左右参数连接后的字符串。第二个是连接赋值运算符（".="），它将右边参数附加到左边的参数之后。更多信息见赋值运算符。

<?php
$a = "Hello ";
$b = $a . "World!"; // now $b contains "Hello World!"

$a = "Hello ";
$a .= "World!";     // now $a contains "Hello World!"
?>

参见

  • 字符串类型
  • 字符串函数


数组运算符

数组运算符
例子 | 名称 | 结果
$a + $b | 联合 | $a 和 $b 的联合。
$a == $b | 相等 | 如果 $a 和 $b 具有相同的键／值对则为 true。
$a === $b | 全等 | 如果 $a 和 $b 具有相同的键／值对并且顺序和类型都相同则为 true。
$a != $b | 不等 | 如果 $a 不等于 $b 则为 true。
$a <> $b | 不等 | 如果 $a 不等于 $b 则为 true。
$a !== $b | 不全等 | 如果 $a 不全等于 $b 则为 true。

+ 运算符把右边的数组元素附加到左边的数组后面，两个数组中都有的键名，则只用左边数组中的，右边的被忽略。

<?php
$a = array("a" => "apple", "b" => "banana");
$b = array("a" => "pear", "b" => "strawberry", "c" => "cherry");

$c = $a + $b; // Union of $a and $b
echo "Union of \$a and \$b: \n";
var_dump($c);

$c = $b + $a; // Union of $b and $a
echo "Union of \$b and \$a: \n";
var_dump($c);

$a += $b; // Union of $a += $b is $a and $b
echo "Union of \$a += \$b: \n";
var_dump($a);
?>
执行后，此脚本会显示：
Union of $a and $b:
array(3) {
  ["a"]=>
  string(5) "apple"
  ["b"]=>
  string(6) "banana"
  ["c"]=>
  string(6) "cherry"
}
Union of $b and $a:
array(3) {
  ["a"]=>
  string(4) "pear"
  ["b"]=>
  string(10) "strawberry"
  ["c"]=>
  string(6) "cherry"
}
Union of $a += $b:
array(3) {
  'a' =>
  string(5) "apple"
  'b' =>
  string(6) "banana"
  'c' =>
  string(6) "cherry"
}

数组中的单元如果具有相同的键名和值则比较时相等。

Example #1 比较数组

<?php
$a = array("apple", "banana");
$b = array(1 => "banana", "0" => "apple");

var_dump($a == $b); // bool(true)
var_dump($a === $b); // bool(false)
?>

参见

  • 数组类型
  • 数组函数


类型运算符

instanceof 用于确定一个 PHP 变量是否属于某一类 class 的实例：

Example #1 对类使用 instanceof

<?php
class MyClass
{
}

class NotMyClass
{
}
$a = new MyClass;

var_dump($a instanceof MyClass);
var_dump($a instanceof NotMyClass);
?>

以上例程会输出：

bool(true)
bool(false)

instanceof　也可用来确定一个变量是不是继承自某一父类的子类的实例：

Example #2 对继承类使用 instanceof

<?php
class ParentClass
{
}

class MyClass extends ParentClass
{
}

$a = new MyClass;

var_dump($a instanceof MyClass);
var_dump($a instanceof ParentClass);
?>

以上例程会输出：

bool(true)
bool(true)

检查一个对象是否不是某个类的实例，可以使用逻辑运算符 not。

Example #3 使用 instanceof 检查对象不是某个类的实例

<?php
class MyClass
{
}

$a = new MyClass;
var_dump(!($a instanceof stdClass));
?>

以上例程会输出：

bool(true)

最后，instanceof也可用于确定一个变量是不是实现了某个接口的对象的实例:

Example #4 对接口使用 instanceof

<?php
interface MyInterface
{
}

class MyClass implements MyInterface
{
}

$a = new MyClass;

var_dump($a instanceof MyClass);
var_dump($a instanceof MyInterface);
?>

以上例程会输出：

bool(true)
bool(true)

虽然 instanceof 通常直接与类名一起使用，但也可以使用对象或字符串变量：

Example #5 对其它变量使用 instanceof

<?php
interface MyInterface
{
}

class MyClass implements MyInterface
{
}

$a = new MyClass;
$b = new MyClass;
$c = 'MyClass';
$d = 'NotMyClass';

var_dump($a instanceof $b); // $b is an object of class MyClass
var_dump($a instanceof $c); // $c is a string 'MyClass'
var_dump($a instanceof $d); // $d is a string 'NotMyClass'
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)

如果被检测的变量不是对象，instanceof 并不发出任何错误信息而是返回 false。PHP 7.3.0 之前不允许用于检测常量。

Example #6 用 instanceof 检测其它变量

<?php
$a = 1;
$b = NULL;
$c = imagecreate(5, 5);
var_dump($a instanceof stdClass); // $a is an integer
var_dump($b instanceof stdClass); // $b is NULL
var_dump($c instanceof stdClass); // $c is a resource
var_dump(FALSE instanceof stdClass);
?>

以上例程会输出：

bool(false)
bool(false)
bool(false)
PHP Fatal error:  instanceof expects an object instance, constant given

PHP 7.3.0 起， instanceof 操作符的左侧可以放常量。

Example #7 使用 instanceof 测试常量

<?php
var_dump(FALSE instanceof stdClass);
?>

以上例程在 PHP 7.3 中的输出：

bool(false)

instanceof 在功能上有个 类似的变体 is_a()。

参见

  • get_class()
  • is_a()


流程控制

Table of Contents

  • 简介
  • if
  • else
  • elseif/else if
  • 流程控制的替代语法
  • while
  • do-while
  • for
  • foreach
  • break
  • continue
  • switch
  • match
  • declare
  • return
  • require
  • include
  • require_once
  • include_once
  • goto


简介

任何 PHP 脚本都是由一系列语句构成的。一条语句可以是一个赋值语句，一个函数调用，一个循环，一个条件语句或者甚至是一个什么也不做的语句（空语句）。语句通常以分号结束。此外，还可以用花括号将一组语句封装成一个语句组。语句组本身可以当作是一行语句。本章介绍了各种语句类型。

参见

以下也被认为是语言结构，尽管在手册中它们是在函数下引用的。

  • list()
  • array()
  • echo
  • eval()


if

(PHP 4, PHP 5, PHP 7, PHP 8)

if 结构是很多语言包括 PHP 在内最重要的特性之一，它允许按照条件执行代码片段。PHP 的 if 结构和 C 语言相似：

<?php
if (expr)
  statement
?>

如同在表达式一章中定义的，expr 按照布尔求值。如果 expr 的值为 true，PHP 将执行 statement，如果值为 false ——将忽略 statement。有关哪些值被视为 false 的更多信息参见转换为布尔值一节。

如果 $a 大于 $b，则以下例子将显示 a is bigger than b：

<?php
if ($a > $b)
  echo "a is bigger than b";
?>

经常需要按照条件执行不止一条语句，当然并不需要给每条语句都加上一个 if 子句。可以将这些语句放入语句组中。例如，如果 $a 大于 $b，以下代码将显示 a is bigger than b 并且将 $a 的值赋给 $b：

<?php
if ($a > $b) {
  echo "a is bigger than b";
  $b = $a;
}
?>

if 语句可以无限层地嵌套在其它 if 语句中，这给程序的不同部分的条件执行提供了充分的弹性。


else

(PHP 4, PHP 5, PHP 7, PHP 8)

经常需要在满足某个条件时执行一条语句，而在不满足该条件时执行其它语句，这正是 else 的功能。else 延伸了 if 语句，可以在 if 语句中的表达式的值为 false 时执行语句。例如以下代码在 $a 大于 $b 时显示 a is bigger than b，反之则显示 a is NOT bigger than b：

<?php
if ($a > $b) {
  echo "a is greater than b";
} else {
  echo "a is NOT greater than b";
}
?>
else 语句仅在 if 以及 elseif（如果有的话）语句中的表达式的值为 false 时执行（参见 elseif）。


elseif/else if

(PHP 4, PHP 5, PHP 7, PHP 8)

elseif，和此名称暗示的一样，是 if 和 else 的组合。和 else 一样，它延伸了 if 语句，可以在原来的 if 表达式值为 false 时执行不同语句。但是和 else 不一样的是，它仅在 elseif 的条件表达式值为 true 时执行语句。例如以下代码将根据条件分别显示 a is bigger than b，a equal to b 或者 a is smaller than b：

<?php
if ($a > $b) {
    echo "a is bigger than b";
} elseif ($a == $b) {
    echo "a is equal to b";
} else {
    echo "a is smaller than b";
}
?>

在同一个 if 语句中可以有多个 elseif 部分，其中第一个表达式值为 true（如果有的话）的 elseif 部分将会执行。在 PHP 中，也可以写成"else if"（两个单词），它和"elseif"（一个单词）的行为完全一样。句法分析的含义有少许区别（如果你熟悉 C 语言的话，与之行为相同），但是底线是两者会产生完全一样的行为。

elseif 的语句仅在之前的 if 和所有之前 elseif 的表达式值为 false，并且当前的 elseif 表达式值为 true 时执行。

Note: 必须要注意的是 elseif 与 else if 只有在类似上例中使用花括号的情况下才认为是完全相同。如果用冒号来定义 if/elseif 条件，那就不能用两个单词的 else if，否则 PHP 会产生解析错误。

<?php

/* 不正确的使用方法： */
if ($a > $b):
    echo $a." is greater than ".$b;
else if ($a == $b): // 将无法编译
    echo "The above line causes a parse error.";
endif;

/* 正确的使用方法： */
if ($a > $b):
    echo $a." is greater than ".$b;
elseif ($a == $b): // 注意使用了一个单词的 elseif
    echo $a." equals ".$b;
else:
    echo $a." is neither greater than or equal to ".$b;
endif;

?>


流程控制的替代语法

(PHP 4, PHP 5, PHP 7, PHP 8)

PHP 提供了一些流程控制的替代语法，包括 if，while，for，foreach 和 switch。替代语法的基本形式是把左花括号（{）换成冒号（:），把右花括号（}）分别换成 endif;，endwhile;，endfor;，endforeach; 以及 endswitch;。

<?php if ($a == 5): ?>
A is equal to 5
<?php endif; ?>

在上面的例子中，HTML 内容"A is equal to 5"用替代语法嵌套在 if 语句中。该 HTML 的内容仅在 $a 等于 5 时显示。

替代语法同样可以用在 else 和 elseif 中。下面是一个包括 elseif 和 else 的 if 结构用替代语法格式写的例子：

<?php
if ($a == 5):
    echo "a equals 5";
    echo "...";
elseif ($a == 6):
    echo "a equals 6";
    echo "!!!";
else:
    echo "a is neither 5 nor 6";
endif;
?>

Note:

不支持在同一个控制块内混合使用两种语法。

Warning

switch 和第一个 case 之间的任何输出（含空格）将导致语法错误。例如，这样是无效的：

<?php switch ($foo): ?>
    <?php case 1: ?>
    ...
<?php endswitch ?>

而这样是有效的，因为 switch 之后的换行符被认为是结束标记 ?> 的一部分，所以在 switch 和 case 之间不能有任何输出：

<?php switch ($foo): ?>
<?php case 1: ?>
    ...
<?php endswitch ?>

更多例子参见 while，for 和 if。


while

(PHP 4, PHP 5, PHP 7, PHP 8)

while 循环是 PHP 中最简单的循环类型。它和 C 语言中的 while 表现地一样。while 语句的基本格式是：

while (expr)
    statement

while 语句的含意很简单，它告诉 PHP 只要 while 表达式的值为 true 就重复执行嵌套中的循环语句。表达式的值在每次开始循环时检查，所以即使这个值在循环语句中改变了，语句也不会停止执行，直到本次循环结束。 如果 while 表达式的值一开始就是 false，则循环语句一次都不会执行。

和 if 语句一样，可以在 while 循环中用花括号括起一个语句组，或者用替代语法：

while (expr):
    statement
    ...
endwhile;

下面两个例子完全一样，都显示数字 1 到 10：

<?php
/* example 1 */

$i = 1;
while ($i <= 10) {
    echo $i++;  /* the printed value would be
                    $i before the increment
                    (post-increment) */
}

/* example 2 */

$i = 1;
while ($i <= 10):
    print $i;
    $i++;
endwhile;
?>


do-while

(PHP 4, PHP 5, PHP 7, PHP 8)

do-while 循环和 while 循环非常相似，区别在于表达式的值是在每次循环结束时检查而不是开始时。和一般的 while 循环主要的区别是 do-while 的循环语句保证会执行一次（表达式的真值在每次循环结束后检查），然而在一般的 while 循环中就不一定了（表达式真值在循环开始时检查，如果一开始就为 false 则整个循环立即终止）。

do-while 循环只有一种语法：

<?php
$i = 0;
do {
   echo $i;
} while ($i > 0);
?>

以上循环将正好运行一次，因为经过第一次循环后，当检查表达式的真值时，其值为 false（$i 不大于 0）而导致循环终止。

资深的 C 语言用户可能熟悉另一种不同的 do-while 循环用法，把语句放在 do-while(0) 之中，在循环内部用 break 语句来结束执行循环。以下代码片段示范了此方法：

<?php
do {
    if ($i < 5) {
        echo "i is not big enough";
        break;
    }
    $i *= $factor;
    if ($i < $minimum_limit) {
        break;
    }
    echo "i is ok";

    /* process i */

} while(0);
?>

如果还不能立刻理解也不用担心。即使不用此"特性"也照样可以写出强大的代码来。自 PHP 5.3.0 起，还可以使用 goto 来跳出循环。


for

(PHP 4, PHP 5, PHP 7, PHP 8)

for 循环是 PHP 中最复杂的循环结构。它的行为和 C 语言的相似。 for 循环的语法是：

for (expr1; expr2; expr3)
    statement

第一个表达式（expr1）在循环开始前无条件求值（并执行）一次。

expr2 在每次循环开始前求值。如果值为 true，则继续循环，执行嵌套的循环语句。如果值为 false，则终止循环。

expr3 在每次循环之后被求值（并执行）。

每个表达式都可以为空或包括逗号分隔的多个表达式。表达式 expr2 中，所有用逗号分隔的表达式都会计算，但只取最后一个结果。expr2 为空意味着将无限循环下去（和 C 一样，PHP 暗中认为其值为 true）。这可能不像想象中那样没有用，因为经常会希望用有条件的 break 语句来结束循环而不是用 for 的表达式真值判断。

考虑以下的例子，它们都显示数字 1 到 10：

<?php
/* example 1 */

for ($i = 1; $i <= 10; $i++) {
    echo $i;
}

/* example 2 */

for ($i = 1; ; $i++) {
    if ($i > 10) {
        break;
    }
    echo $i;
}

/* example 3 */

$i = 1;
for (;;) {
    if ($i > 10) {
        break;
    }
    echo $i;
    $i++;
}

/* example 4 */

for ($i = 1, $j = 0; $i <= 10; $j += $i, print $i, $i++);
?>

当然，第一个例子看上去最简洁（或者有人认为是第四个），但用户可能会发现在 for 循环中用空的表达式在很多场合下会很方便。

PHP 也支持用冒号的 for 循环的替代语法。

for (expr1; expr2; expr3):
    statement;
    ...
endfor;

有时经常需要像下面这样例子一样对数组进行遍历：

<?php
/*
 * 此数组将在遍历的过程中改变其中某些单元的值
 */
$people = Array(
        Array('name' => 'Kalle', 'salt' => 856412),
        Array('name' => 'Pierre', 'salt' => 215863)
        );

for($i = 0; $i < count($people); ++$i)
{
    $people[$i]['salt'] = rand(000000, 999999);
}
?>

以上代码可能执行很慢，因为每次循环时都要计算一遍数组的长度。由于数组的长度始终不变，可以用一个中间变量来储存数组长度以优化而不是不停调用 count()：

<?php
$people = Array(
        Array('name' => 'Kalle', 'salt' => 856412),
        Array('name' => 'Pierre', 'salt' => 215863)
        );

for($i = 0, $size = count($people); $i < $size; ++$i)
{
    $people[$i]['salt'] = rand(000000, 999999);
}
?>


foreach

(PHP 4, PHP 5, PHP 7, PHP 8)

foreach 语法结构提供了遍历数组的简单方式。foreach 仅能够应用于数组和对象，如果尝试应用于其他数据类型的变量，或者未初始化的变量将发出错误信息。有两种语法：

foreach (iterable_expression as $value)
    statement
foreach (iterable_expression as $key => $value)
    statement

第一种格式遍历给定的 iterable_expression 迭代器。每次循环中，当前单元的值被赋给 $value。

第二种格式做同样的事，只除了当前单元的键名也会在每次循环中被赋给变量 $key。

还能够自定义遍历对象。

可以很容易地通过在 $value 之前加上 & 来修改数组的元素。此方法将以引用赋值而不是拷贝一个值。

<?php
$arr = array(1, 2, 3, 4);
foreach ($arr as &$value) {
    $value = $value * 2;
}
// $arr is now array(2, 4, 6, 8)
unset($value); // 最后取消掉引用
?>

Warning

数组最后一个元素的 $value 引用在 foreach 循环之后仍会保留。建议使用 unset() 来将其销毁。 否则你会遇到下面的情况：

<?php
$arr = array(1, 2, 3, 4);
foreach ($arr as &$value) {
    $value = $value * 2;
}
// 现在 $arr 是 array(2, 4, 6, 8)

// 未使用 unset($value) 时，$value 仍然引用到最后一项 $arr[3]

foreach ($arr as $key => $value) {
    // $arr[3] 会被 $arr 的每一项值更新掉...
    echo "{$key} => {$value} ";
    print_r($arr);
}
// ...until ultimately the second-to-last value is copied onto the last value

// output:
// 0 => 2 Array ( [0] => 2, [1] => 4, [2] => 6, [3] => 2 )
// 1 => 4 Array ( [0] => 2, [1] => 4, [2] => 6, [3] => 4 )
// 2 => 6 Array ( [0] => 2, [1] => 4, [2] => 6, [3] => 6 )
// 3 => 6 Array ( [0] => 2, [1] => 4, [2] => 6, [3] => 6 )
?>

可以通过引用来遍历数组常量的值：

<?php
foreach (array(1, 2, 3, 4) as &$value) {
    $value = $value * 2;
}
?>

Note:

foreach 不支持用 "@" 来抑制错误信息的能力。

示范用法的更多例子：

<?php
/* foreach example 1: value only */

$a = array(1, 2, 3, 17);

foreach ($a as $v) {
   echo "Current value of \$a: $v.\n";
}

/* foreach example 2: value (with its manual access notation printed for illustration) */

$a = array(1, 2, 3, 17);

$i = 0; /* for illustrative purposes only */

foreach ($a as $v) {
    echo "\$a[$i] => $v.\n";
    $i++;
}

/* foreach example 3: key and value */

$a = array(
    "one" => 1,
    "two" => 2,
    "three" => 3,
    "seventeen" => 17
);

foreach ($a as $k => $v) {
    echo "\$a[$k] => $v.\n";
}

/* foreach example 4: multi-dimensional arrays */
$a = array();
$a[0][0] = "a";
$a[0][1] = "b";
$a[1][0] = "y";
$a[1][1] = "z";

foreach ($a as $v1) {
    foreach ($v1 as $v2) {
        echo "$v2\n";
    }
}

/* foreach example 5: dynamic arrays */

foreach (array(1, 2, 3, 4, 5) as $v) {
    echo "$v\n";
}
?>

用 list() 给嵌套的数组解包

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

可以遍历一个数组的数组并且把嵌套的数组解包到循环变量中，只需将 list() 作为值提供。

例如：

<?php
$array = [
    [1, 2],
    [3, 4],
];

foreach ($array as list($a, $b)) {
    // $a contains the first element of the nested array,
    // and $b contains the second element.
    echo "A: $a; B: $b\n";
}
?>

以上例程会输出：

A: 1; B: 2
A: 3; B: 4

list() 中的单元可以少于嵌套数组的，此时多出来的数组单元将被忽略：

<?php
$array = [
    [1, 2],
    [3, 4],
];

foreach ($array as list($a)) {
    // Note that there is no $b here.
    echo "$a\n";
}
?>

以上例程会输出：

1
3

如果 list() 中列出的单元多于嵌套数组则会发出一条消息级别的错误信息：

<?php
$array = [
    [1, 2],
    [3, 4],
];

foreach ($array as list($a, $b, $c)) {
    echo "A: $a; B: $b; C: $c\n";
}
?>

以上例程会输出：

Notice: Undefined offset: 2 in example.php on line 7
A: 1; B: 2; C:

Notice: Undefined offset: 2 in example.php on line 7
A: 3; B: 4; C:


break

(PHP 4, PHP 5, PHP 7, PHP 8)

break 结束当前 for，foreach，while，do-while 或者 switch 结构的执行。

break 可以接受一个可选的数字参数来决定跳出几重循环。

<?php
$arr = array('one', 'two', 'three', 'four', 'stop', 'five');
while (list (, $val) = each($arr)) {
    if ($val == 'stop') {
        break;    /* You could also write 'break 1;' here. */
    }
    echo "$val<br />\n";
}

/* 使用可选参数 */

$i = 0;
while (++$i) {
    switch ($i) {
    case 5:
        echo "At 5<br />\n";
        break 1;  /* 只退出 switch. */
    case 10:
        echo "At 10; quitting<br />\n";
        break 2;  /* 退出 switch 和 while 循环 */
    default:
        break;
    }
}
?>

break 的更新记录
版本 | 说明
5.4.0 | break 0; 不再合法。这在之前的版本被解析为 break 1;。
5.4.0 | 取消变量作为参数传递（例如 $num = 2; break $num;）。


continue

(PHP 4, PHP 5, PHP 7, PHP 8)

continue 在循环结构用用来跳过本次循环中剩余的代码并在条件求值为真时开始执行下一次循环。

Note: 注意在 PHP 中 switch 语句被认为是可以使用 continue 的一种循环结构。

continue 接受一个可选的数字参数来决定跳过几重循环到循环结尾。默认值是 1，即跳到当前循环末尾。

<?php
while (list ($key, $value) = each($arr)) {
    if (!($key % 2)) { // skip odd members
        continue;
    }
    do_something_odd($value);
}

$i = 0;
while ($i++ < 5) {
    echo "Outer<br />\n";
    while (1) {
        echo "Middle<br />\n";
        while (1) {
            echo "Inner<br />\n";
            continue 3;
        }
        echo "This never gets output.<br />\n";
    }
    echo "Neither does this.<br />\n";
}
?>

省略 continue 后面的分号会导致混淆。以下例子示意了不应该这样做。

<?php
  for ($i = 0; $i < 5; ++$i) {
      if ($i == 2)
          continue
      print "$i\n";
  }
?>

希望得到的结果是：

0
1
3
4

可实际的输出是：

2

因为整个 continue print "$i\n"; 被当做单一的表达式而求值，所以 print 函数只有在 $i == 2 为真时才被调用（print 的值被当成了上述的可选数字参数而传递给了 continue）。

continue 的更新记录
版本 | 说明
5.4.0 | continue 0; 不再合法。这在之前的版本被解析为 continue 1;。
5.4.0 | 取消变量作为参数传递（例如 $num = 2; continue $num;）。


switch

(PHP 4, PHP 5, PHP 7, PHP 8)

switch 语句类似于具有同一个表达式的一系列 if 语句。很多场合下需要把同一个变量（或表达式）与很多不同的值比较，并根据它等于哪个值来执行不同的代码。这正是 switch 语句的用途。

Note: 注意和其它语言不同，continue 语句作用到 switch 上的作用类似于 break。如果在循环中有一个 switch 并希望 continue 到外层循环中的下一轮循环，用 continue 2。

Note:

注意 switch/case 作的是松散比较。

下面两个例子使用两种不同方法实现同样的事，一个用一系列的 if 和 elseif 语句，另一个用 switch 语句：

Example #1 switch 结构

<?php
if ($i == 0) {
    echo "i equals 0";
} elseif ($i == 1) {
    echo "i equals 1";
} elseif ($i == 2) {
    echo "i equals 2";
}

switch ($i) {
    case 0:
        echo "i equals 0";
        break;
    case 1:
        echo "i equals 1";
        break;
    case 2:
        echo "i equals 2";
        break;
}
?>

Example #2 switch 结构可以用 string

<?php
switch ($i) {
case "apple":
    echo "i is apple";
    break;
case "bar":
    echo "i is bar";
    break;
case "cake":
    echo "i is cake";
    break;
}
?>

为避免错误，理解 switch 是怎样执行的非常重要。switch 语句一行接一行地执行（实际上是语句接语句）。开始时没有代码被执行。仅当一个 case 语句中的值和 switch 表达式的值匹配时 PHP 才开始执行语句，直到 switch 的程序段结束或者遇到第一个 break 语句为止。如果不在 case 的语句段最后写上 break 的话，PHP 将继续执行下一个 case 中的语句段。例如：

<?php
switch ($i) {
    case 0:
        echo "i equals 0";
    case 1:
        echo "i equals 1";
    case 2:
        echo "i equals 2";
}
?>

这里如果 $i 等于 0，PHP 将执行所有的 echo 语句！如果 $i 等于 1，PHP 将执行后面两条 echo 语句。只有当 $i 等于 2 时，才会得到"预期"的结果——只显示"i equals 2"。所以，别忘了 break 语句就很重要（即使在某些情况下故意想避免提供它们时）。

在 switch 语句中条件只求值一次并用来和每个 case 语句比较。在 elseif 语句中条件会再次求值。如果条件比一个简单的比较要复杂得多或者在一个很多次的循环中，那么用 switch 语句可能会快一些。

在一个 case 中的语句也可以为空，这样只不过将控制转移到了下一个 case 中的语句。

<?php
switch ($i) {
    case 0:
    case 1:
    case 2:
        echo "i is less than 3 but not negative";
        break;
    case 3:
        echo "i is 3";
}
?>

一个 case 的特例是 default。它匹配了任何和其它 case 都不匹配的情况。例如：

<?php
switch ($i) {
    case 0:
        echo "i equals 0";
        break;
    case 1:
        echo "i equals 1";
        break;
    case 2:
        echo "i equals 2";
        break;
    default:
        echo "i is not equal to 0, 1 or 2";
}
?>

Note: 如果有多个 default 将导致 E_COMPILE_ERROR 错误。

switch 支持替代语法的流程控制。更多信息见流程控制的替代语法一节。

<?php
switch ($i):
    case 0:
        echo "i equals 0";
        break;
    case 1:
        echo "i equals 1";
        break;
    case 2:
        echo "i equals 2";
        break;
    default:
        echo "i is not equal to 0, 1 or 2";
endswitch;
?>

允许使用分号代替 case 语句后的冒号，例如：

<?php
switch($beer)
{
    case 'tuborg';
    case 'carlsberg';
    case 'heineken';
        echo 'Good choice';
    break;
    default;
        echo 'Please make a new selection...';
    break;
}
?>


match

(PHP 8)

The match expression branches evaluation based on an identity check of a value. Similarly to a switch statement, a match expression has a subject expression that is compared against multiple alternatives. Unlike switch, it will evaluate to a value much like ternary expressions. Unlike switch, the comparison is an identity check (===) rather than a weak equality check (==). Match expressions are available as of PHP 8.0.0.

Example #1 Structure of a match expression

<?php
$return_value = match (subject_expression) {
    single_conditional_expression => return_expression,
    conditional_expression1, conditional_expression2 => return_expression,
};
?>

Note: The result of a match expression does not need to be used.

Note: A match expression must be terminated by a semicolon ;.

The match expression is similar to a switch statement but has some key differences:

  • A match arm compares values strictly (===) instead of loosely as the switch statement does.
  • A match expression returns a value.
  • Match arms do not fall-through to later cases the way switch statements do.
  • A match expression must be exhaustive.

As switch statements, match expressions are executed match arm by match arm. In the beginning, no code is executed. The conditional expressions are only evaluated if all previous conditional expressions failed to match the subject expression. Only the return expression corresponding to the matching conditional expression will be evaluated. For example:

<?php
$result = match ($x) {
    foo() => ...,
    $this->bar() => ..., // bar() isn't called if foo() === $x
    $this->baz => beep(), // beep() isn't called unless $x === $this->baz
    // etc.
};
?>

match expression arms may contain multiple expressions separated by a comma. That is a logical OR, and is a short-hand for multiple match arms with the same right-hand side.

<?php
$result = match ($x) {
    // This match arm:
    $a, $b, $c => 5,
    // Is equivalent to these three match arms:
    $a => 5,
    $b => 5,
    $c => 5,
};
?>

A special case is the default pattern. This pattern matches anything that wasn't previously matched. For example:

<?php
$expressionResult = match ($condition) {
    1, 2 => foo(),
    3, 4 => bar(),
    default => baz(),
};
?>

Note: Multiple default patterns will raise a E_FATAL_ERROR error.

A match expression must be exhaustive. If the subject expression is not handled by any match arm an UnhandledMatchError is thrown.

Example #2 Example of an unhandled match expression

<?php
$condition = 5;

try {
    match ($condition) {
        1, 2 => foo(),
        3, 4 => bar(),
    };
} catch (\UnhandledMatchError $e) {
    var_dump($e);
}
?>

以上例程会输出：

object(UnhandledMatchError)#1 (7) {
  ["message":protected]=>
  string(33) "Unhandled match value of type int"
  ["string":"Error":private]=>
  string(0) ""
  ["code":protected]=>
  int(0)
  ["file":protected]=>
  string(9) "/in/ICgGK"
  ["line":protected]=>
  int(6)
  ["trace":"Error":private]=>
  array(0) {
  }
  ["previous":"Error":private]=>
  NULL
}

Using match expressions to handle non identity checks

It is possible to use a match expression to handle non-identity conditional cases by using true as the subject expression.

Example #3 Using a generalized match expressions to branch on integer ranges

<?php

$age = 23;

$result = match (true) {
    $age >= 65 => 'senior',
    $age >= 25 => 'adult',
    $age >= 18 => 'young adult',
    default => 'kid',
};

var_dump($result);
?>

以上例程会输出：

string(11) "young adult"

Example #4 Using a generalized match expressions to branch on string content

<?php

$text = 'Bienvenue chez nous';

$result = match (true) {
    str_contains($text, 'Welcome') || str_contains($text, 'Hello') => 'en',
    str_contains($text, 'Bienvenue') || str_contains($text, 'Bonjour') => 'fr',
    // ...
};

var_dump($result);
?>

以上例程会输出：

string(2) "fr"


declare

(PHP 4, PHP 5, PHP 7, PHP 8)

declare 结构用来设定一段代码的执行指令。declare 的语法和其它流程控制结构相似：

declare (directive)
    statement

directive 部分允许设定 declare 代码段的行为。目前只认识三个指令：ticks（更多信息见下面 ticks 指令）、 encoding（更多信息见下面 encoding 指令）、 strict_types 指令 (更多信息见函数参数页面 严格类型 章节)。

因为本指令是在文件编译时处理的，所以指令只接受字面量的值。 无法使用变量和常量。下面为你演示：

<?php
// 这样是有效的：
declare(ticks=1);

// 这样是无效的：
const TICK_VALUE = 1;
declare(ticks=TICK_VALUE);
?>

declare 代码段中的 statement 部分将被执行——怎样执行以及执行中有什么副作用出现取决于 directive 中设定的指令。

declare 结构也可用于全局范围，影响到其后的所有代码（但如果有 declare 结构的文件被其它文件包含，则对包含它的父文件不起作用）。

<?php
// 两者相等：

// 可以这样用：
declare(ticks=1) {
    // 这里写完整的脚本
}

// 也可以这样用：
declare(ticks=1);
// 这里写完整的脚本
?>

Ticks

Tick（时钟周期）是一个在 declare 代码段中解释器每执行 N 条可计时的低级语句就会发生的事件。N 的值是在 declare 中的 directive 部分用 ticks=N 来指定的。

不是所有语句都可计时。通常条件表达式和参数表达式都不可计时。

在每个 tick 中出现的事件是由 register_tick_function() 来指定的。更多细节见下面的例子。注意每个 tick 中可以出现多个事件。

Example #1 Tick 的用法示例

<?php

declare(ticks=1);

// 每次 tick 事件都会调用该函数
function tick_handler()
{
    echo "tick_handler() called\n";
}

register_tick_function('tick_handler');

$a = 1;

if ($a > 0) {
    $a += 2;
    print($a);
}

?>

Example #2 Ticks 的用法示例

<?php

function tick_handler()
{
  echo "tick_handler() called\n";
}

$a = 1;
tick_handler();

if ($a > 0) {
    $a += 2;
    tick_handler();
    print($a);
    tick_handler();
}
tick_handler();

?>

参见 register_tick_function() 和 unregister_tick_function()。

Encoding

可以用 encoding 指令来对每段脚本指定其编码方式。

Example #3 对脚本指定编码方式

<?php
declare(encoding='ISO-8859-1');
// 在这里写代码
?>

Caution

当和命名空间结合起来时 declare 的唯一合法语法是 declare(encoding='...');，其中 ... 是编码的值。而 declare(encoding='...') {} 将在与命名空间结合时产生解析错误。

参见 zend.script_encoding。


return

(PHP 4, PHP 5, PHP 7, PHP 8)

return 将程序控制返还给调用模块。 将在调用模块中执行的下一句表达式中继续。

如果在一个函数中调用 return 语句，将立即结束此函数的执行并将它的参数作为函数的值返回。return 也会终止 eval() 语句或者脚本文件的执行。

如果在全局范围中调用，则当前脚本文件中止运行。如果当前脚本文件是被 include 的或者 require 的，则控制交回调用文件。此外，如果当前脚本是被 include 的，则 return 的值会被当作 include 调用的返回值。如果在主脚本文件中调用 return，则脚本中止运行。如果当前脚本文件是在 php.ini 中的配置选项 auto_prepend_file 或者 auto_append_file 所指定的，则此脚本文件中止运行。

更多信息见返回值。

Note: 注意既然 return 是语言结构而不是函数，因此其参数没有必要用括号将其括起来，也不推荐这样用。

Note: 如果没有提供参数，则一定不能用括号，此时返回 null。如果调用 return 时加上了括号却又没有参数会导致解析错误。

自 PHP 7.1.0 起，如果返回类型需要是 void 而带了返回的参数， 将导致 E_COMPILE_ERROR； 相反返回类型需要而未带参数也会同样导致该错误。


require

(PHP 4, PHP 5, PHP 7, PHP 8)

require 和 include 几乎完全一样，除了处理失败的方式不同之外。require 在出错时产生 E_COMPILE_ERROR 级别的错误。换句话说将导致脚本中止而 include 只产生警告（E_WARNING），脚本会继续运行。

参见 include 文档了解详情。


include

(PHP 4, PHP 5, PHP 7, PHP 8)

include 语句包含并运行指定文件。

以下文档也适用于 require。

被包含文件先按参数给出的路径寻找，如果没有给出目录（只有文件名）时则按照 include_path 指定的目录寻找。如果在 include_path 下没找到该文件则 include 最后才在调用脚本文件所在的目录和当前工作目录下寻找。如果最后仍未找到文件则 include 结构会发出一条警告；这一点和 require 不同，后者会发出一个致命错误。

如果定义了路径——不管是绝对路径（在 Windows 下以盘符或者 \ 开头，在 Unix/Linux 下以 / 开头）还是当前目录的相对路径（以 . 或者 .. 开头）——include_path 都会被完全忽略。例如一个文件以 ../ 开头，则解析器会在当前目录的父目录下寻找该文件。

有关 PHP 怎样处理包含文件和包含路径的更多信息参见 include_path 部分的文档。

当一个文件被包含时，其中所包含的代码继承了 include 所在行的变量范围。从该处开始，调用文件在该行处可用的任何变量在被调用的文件中也都可用。不过所有在包含文件中定义的函数和类都具有全局作用域。

Example #1 基本的 include 例子

vars.php
<?php

$color = 'green';
$fruit = 'apple';

?>

test.php
<?php

echo "A $color $fruit"; // A

include 'vars.php';

echo "A $color $fruit"; // A green apple

?>

如果 include 出现于调用文件中的一个函数里，则被调用的文件中所包含的所有代码将表现得如同它们是在该函数内部定义的一样。所以它将遵循该函数的变量范围。此规则的一个例外是魔术常量，它们是在发生包含之前就已被解析器处理的。

Example #2 函数中的包含

<?php

function foo()
{
    global $color;

    include 'vars.php';

    echo "A $color $fruit";
}

/* vars.php is in the scope of foo() so     *
 * $fruit is NOT available outside of this  *
 * scope.  $color is because we declared it *
 * as global.                               */

foo();                    // A green apple
echo "A $color $fruit";   // A green

?>

当一个文件被包含时，语法解析器在目标文件的开头脱离 PHP 模式并进入 HTML 模式，到文件结尾处恢复。由于此原因，目标文件中需要作为 PHP 代码执行的任何代码都必须被包括在有效的 PHP 起始和结束标记之中。

如果"URL include wrappers"在 PHP 中被激活，可以用 URL（通过 HTTP 或者其它支持的封装协议——见支持的协议和封装协议）而不是本地文件来指定要被包含的文件。如果目标服务器将目标文件作为 PHP 代码解释，则可以用适用于 HTTP GET 的 URL 请求字符串来向被包括的文件传递变量。严格的说这和包含一个文件并继承父文件的变量空间并不是一回事；该脚本文件实际上已经在远程服务器上运行了，而本地脚本则包括了其结果。

Example #3 通过 HTTP 进行的 include

<?php

/* This example assumes that www.example.com is configured to parse .php *
 * files and not .txt files. Also, 'Works' here means that the variables *
 * $foo and $bar are available within the included file.                 */

// Won't work; file.txt wasn't handled by www.example.com as PHP
include 'http://www.example.com/file.txt?foo=1&bar=2';

// Won't work; looks for a file named 'file.php?foo=1&bar=2' on the
// local filesystem.
include 'file.php?foo=1&bar=2';

// Works.
include 'http://www.example.com/file.php?foo=1&bar=2';

$foo = 1;
$bar = 2;
include 'file.txt';  // Works.
include 'file.php';  // Works.

?>

Warning

安全警告

远程文件可能会经远程服务器处理（根据文件后缀以及远程服务器是否在运行 PHP 而定），但必须产生出一个合法的 PHP 脚本，因为其将被本地服务器处理。如果来自远程服务器的文件应该在远端运行而只输出结果，那用 readfile() 函数更好。另外还要格外小心以确保远程的脚本产生出合法并且是所需的代码。

相关信息参见使用远程文件，fopen() 和 file()。

处理返回值：在失败时 include 返回 FALSE 并且发出警告。成功的包含则返回 1，除非在包含文件中另外给出了返回值。可以在被包括的文件中使用 return 语句来终止该文件中程序的执行并返回调用它的脚本。同样也可以从被包含的文件中返回值。可以像普通函数一样获得 include 调用的返回值。不过这在包含远程文件时却不行，除非远程文件的输出具有合法的 PHP 开始和结束标记（如同任何本地文件一样）。可以在标记内定义所需的变量，该变量在文件被包含的位置之后就可用了。

因为 include 是一个特殊的语言结构，其参数不需要括号。在比较其返回值时要注意。

Example #4 比较 include 的返回值

<?php
// won't work, evaluated as include(('vars.php') == TRUE), i.e. include('')
if (include('vars.php') == TRUE) {
    echo 'OK';
}

// works
if ((include 'vars.php') == TRUE) {
    echo 'OK';
}
?>

Example #5 include 和 return 语句

return.php
<?php

$var = 'PHP';

return $var;

?>

noreturn.php
<?php

$var = 'PHP';

?>

testreturns.php
<?php

$foo = include 'return.php';

echo $foo; // prints 'PHP'

$bar = include 'noreturn.php';

echo $bar; // prints 1

?>

$bar 的值为 1 是因为 include 成功运行了。注意以上例子中的区别。第一个在被包含的文件中用了 return 而另一个没有。如果文件不能被包含，则返回 false 并发出一个 E_WARNING 警告。

如果在包含文件中定义有函数，这些函数不管是在 return 之前还是之后定义的，都可以独立在主文件中使用。如果文件被包含两次，PHP 5 发出致命错误因为函数已经被定义，但是 PHP 4 不会对在 return 之后定义的函数报错。推荐使用 include_once 而不是检查文件是否已包含并在包含文件中有条件返回。

另一个将 PHP 文件"包含"到一个变量中的方法是用输出控制函数结合 include 来捕获其输出，例如：

Example #6 使用输出缓冲来将 PHP 文件包含入一个字符串

<?php
$string = get_include_contents('somefile.php');

function get_include_contents($filename) {
    if (is_file($filename)) {
        ob_start();
        include $filename;
        $contents = ob_get_contents();
        ob_end_clean();
        return $contents;
    }
    return false;
}

?>

要在脚本中自动包含文件，参见 php.ini 中的 auto_prepend_file 和 auto_append_file 配置选项。

Note: 因为是一个语言构造器而不是一个函数，不能被 可变函数 调用。

参见 require，require_once，include_once，get_included_files()，readfile()，virtual() 和 include_path。


require_once

(PHP 4, PHP 5, PHP 7, PHP 8)

require_once 语句和 require 语句完全相同，唯一区别是 PHP 会检查该文件是否已经被包含过，如果是则不会再次包含。

参见 include_once 的文档来理解 _once 的含义，并理解与没有 _once 时候有什么不同。


include_once

(PHP 4, PHP 5, PHP 7, PHP 8)

include_once 语句在脚本执行期间包含并运行指定文件。此行为和 include 语句类似，唯一区别是如果该文件中已经被包含过，则不会再次包含，且 include_once 会返回 true。 如同此语句名字暗示的那样，该文件只会包含一次。

include_once 可以用于在脚本执行期间同一个文件有可能被包含超过一次的情况下，想确保它只被包含一次以避免函数重定义，变量重新赋值等问题。

更多信息参见 include 文档。


goto

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

What's the worse thing that could happen if you use goto?
此漫画鸣谢 » xkcd

goto 操作符可以用来跳转到程序中的另一位置。该目标位置可以用目标名称加上冒号来标记，而跳转指令是 goto 之后接上目标位置的标记。PHP 中的 goto 有一定限制，目标位置只能位于同一个文件和作用域，也就是说无法跳出一个函数或类方法，也无法跳入到另一个函数。也无法跳入到任何循环或者 switch 结构中。可以跳出循环或者 switch，通常的用法是用 goto 代替多层的 break。

Example #1 goto 示例

<?php
goto a;
echo 'Foo';

a:
echo 'Bar';
?>

以上例程会输出：

Bar

Example #2 goto 跳出循环示例

<?php
for($i=0,$j=50; $i<100; $i++) {
  while($j--) {
    if($j==17) goto end;
  }
}
echo "i = $i";
end:
echo 'j hit 17';
?>

以上例程会输出：

j hit 17

Example #3 以下写法无效

<?php
goto loop;
for($i=0,$j=50; $i<100; $i++) {
  while($j--) {
    loop:
  }
}
echo "$i = $i";
?>

以上例程会输出：

Fatal error: 'goto' into loop or switch statement is disallowed in
script on line 2

Note:

goto 操作符仅在 PHP 5.3及以上版本有效。


函数

Table of Contents

  • 用户自定义函数
  • 函数的参数
  • 返回值
  • 可变函数
  • 内部（内置）函数
  • 匿名函数
  • 箭头函数


用户自定义函数

一个函数可由以下的语法来定义：

Example #1 展示函数用途的伪代码

<?php
function foo($arg_1, $arg_2, /* ..., */ $arg_n)
{
    echo "Example function.\n";
    return $retval;
}
?>

任何有效的 PHP 代码都有可能出现在函数内部，甚至包括其它函数和 类 定义。

函数名和 PHP 中的其它标识符命名规则相同。有效的函数名以字母或下划线打头，后面跟字母，数字或下划线。可以用正则表达式表示为: ^[a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*$。

Tip

请参见用户空间命名指南。

函数无需在调用之前被定义，除非 是下面两个例子中函数是有条件被定义时。

当一个函数是有条件被定义时，必须在调用函数 之前 定义。

Example #2 有条件的函数

<?php

$makefoo = true;

/* 不能在此处调用foo()函数，
   因为它还不存在，但可以调用bar()函数。*/

bar();

if ($makefoo) {
  function foo()
  {
    echo "I don't exist until program execution reaches me.\n";
  }
}

/* 现在可以安全调用函数 foo()
   因为 $makefoo 值为真 */

if ($makefoo) foo();

function bar()
{
  echo "I exist immediately upon program start.\n";
}

?>

Example #3 函数中的函数

<?php
function foo()
{
  function bar()
  {
    echo "I don't exist until foo() is called.\n";
  }
}

/* 现在还不能调用 bar() 函数，因为它还不存在 */

foo();

/* 现在可以调用 bar() 函数了，因为 foo() 函数
   的执行使得 bar() 函数变为已定义的函数 */

bar();

?>

PHP 中的所有函数和类都具有全局作用域，可以定义在一个函数之内而在之外调用，反之亦然。

PHP 不支持函数重载，也不可能取消定义或者重定义已声明的函数。

Note: 从 A 到 Z 的 ASCII 函数名是大小写无关的，不过在调用函数的时候，使用其在定义时相同的形式是个好习惯。

PHP 的函数支持 可变数量的参数 和 默认参数。参见 func_num_args()，func_get_arg() 和 func_get_args()。

在 PHP 中可以调用递归函数。

Example #4 递归函数

<?php
function recursion($a)
{
    if ($a < 20) {
        echo "$a\n";
        recursion($a + 1);
    }
}
?>

Note: 但是要避免递归函数／方法调用超过 100-200 层，因为可能会使堆栈崩溃从而使当前脚本终止。 无限递归可视为编程错误。


函数的参数

通过参数列表可以传递信息到函数，即以逗号作为分隔符的表达式列表。参数是从左向右求值的。

PHP 支持按值传递参数（默认），通过引用传递参数 以及 默认参数。也支持 可变长度参数列表 和 命名参数。

Example #1 向函数传递数组

<?php
function takes_array($input)
{
    echo "$input[0] + $input[1] = ", $input[0]+$input[1];
}
?>

从 PHP 8.0.0 开始，函数参数列表可以包含一个尾部的逗号，这个逗号将被忽略。这在参数列表较长或包含较长的变量名的情况下特别有用，这样可以方便地垂直列出参数。

Example #2 函数参数使用尾部逗号

<?php
function takes_many_args(
    $first_arg,
    $second_arg,
    $a_very_long_argument_name,
    $arg_with_default = 5,
    $again = 'a default string', // 在 8.0.0 之前，这个尾部的逗号是不允许的。
)
{
    // ...
}
?>

As of PHP 8.0.0, passing mandatory arguments after optional arguments is deprecated. This can generally be resolved by dropping the default value. One exception to this rule are arguments of the form Type $param = null, where the null default makes the type implicitly nullable. This usage remains allowed, though it is recommended to use an explicit nullable type instead.

Example #3 Passing optional arguments after mandatory arguments

<?php
function foo($a = [], $b) {} // 之前
function foo($a, $b) {}      // 之后

function bar(A $a = null, $b) {} // 同时可用
function bar(?A $a, $b) {}       // 官方推荐的写法
?>

通过引用传递参数

默认情况下，函数参数通过值传递（因而即使在函数内部改变参数的值，它并不会改变函数外部的值）。如果希望允许函数修改它的参数值，必须通过引用传递参数。

如果想要函数的一个参数总是通过引用传递，可以在函数定义中该参数的前面加上符号 &：

Example #4 用引用传递函数参数

<?php
function add_some_extra(&$string)
{
    $string .= 'and something extra.';
}
$str = 'This is a string, ';
add_some_extra($str);
echo $str;    // outputs 'This is a string, and something extra.'
?>

默认参数的值

函数可以定义 C++ 风格的标量参数默认值，如下所示：

Example #5 在函数中使用默认参数

<?php
function makecoffee($type = "cappuccino")
{
    return "Making a cup of $type.\n";
}
echo makecoffee();
echo makecoffee(null);
echo makecoffee("espresso");
?>

以上例程会输出：

Making a cup of cappuccino.
Making a cup of .
Making a cup of espresso.

PHP 还允许使用数组 array 和特殊类型 null 作为默认参数，例如：

Example #6 使用非标量类型作为默认参数

<?php
function makecoffee($types = array("cappuccino"), $coffeeMaker = NULL)
{
    $device = is_null($coffeeMaker) ? "hands" : $coffeeMaker;
    return "Making a cup of ".join(", ", $types)." with $device.\n";
}
echo makecoffee();
echo makecoffee(array("cappuccino", "lavazza"), "teapot");
?>

默认值必须是常量表达式，不能是诸如变量，类成员，或者函数调用等。

注意当使用默认参数时，任何默认参数必须放在任何非默认参数的右侧；否则，函数将不会按照预期的情况工作。考虑下面的代码片断：

Example #7 函数默认参数的不正确用法

<?php
function makeyogurt($type = "acidophilus", $flavour)
{
    return "Making a bowl of $type $flavour.\n";
}

echo makeyogurt("raspberry");   // won't work as expected
?>

以上例程会输出：

Warning: Missing argument 2 in call to makeyogurt() in
/usr/local/etc/httpd/htdocs/phptest/functest.html on line 41
Making a bowl of raspberry .

现在，比较上面的例子和这个例子：

Example #8 函数默认参数正确的用法

<?php
function makeyogurt($flavour, $type = "acidophilus")
{
    return "Making a bowl of $type $flavour.\n";
}

echo makeyogurt("raspberry");   // works as expected
?>

以上例程会输出：

Making a bowl of acidophilus raspberry.

Note: 传引用的参数也可以有默认值。

可变数量的参数列表

PHP 在用户自定义函数中支持可变数量的参数列表。由 ... 语法实现。

Note: 还可以使用以下函数来获取可变参数 func_num_args()、 func_get_arg() 和 func_get_args()，不建议使用此方式，请使用 ... 来替代。

包含 ... 的参数，会转换为指定参数变量的一个数组，见以下示例：

Example #9 使用 ... 来访问变量参数

<?php
function sum(...$numbers) {
    $acc = 0;
    foreach ($numbers as $n) {
        $acc += $n;
    }
    return $acc;
}

echo sum(1, 2, 3, 4);
?>

以上例程会输出：

10

也可以使用 ... 语法来传递 array 或 Traversable 做为参数到函数中：

Example #10 使用 ... 来传递参数

<?php
function add($a, $b) {
    return $a + $b;
}

echo add(...[1, 2])."\n";

$a = [1, 2];
echo add(...$a);
?>

以上例程会输出：

3
3

你可以在 ... 前指定正常的位置参数。在这种情况下，只有不符合位置参数的尾部参数才会被添加到 ... 生成的数组中。

你也可以在 ... 标记前添加一个 类型声明。如果存在这种情况，那么 ... 捕获的所有参数必须是提示类的对象。

Example #11 输入提示的变量参数

<?php
function total_intervals($unit, DateInterval ...$intervals) {
    $time = 0;
    foreach ($intervals as $interval) {
        $time += $interval->$unit;
    }
    return $time;
}

$a = new DateInterval('P1D');
$b = new DateInterval('P2D');
echo total_intervals('d', $a, $b).' days';

// This will fail, since null isn't a DateInterval object.
echo total_intervals('d', null);
?>

以上例程会输出：

3 days
Catchable fatal error: Argument 2 passed to total_intervals() must be an instance of DateInterval, null given, called in - on line 14 and defined in - on line 2

最后，你还可以给参数传递 引用变量，通过在 ... 前加上一个 (&) 符号来实现。

旧版本的 PHP

不需要特殊的语法来声明一个函数是可变的；但是访问函数的参数必须使用 func_num_args(), func_get_arg() 和 func_get_args() 函数。

上面的第一个例子在早期 PHP 版本中的实现如下：

Example #12 在 PHP 早期版本中访问可变参数

<?php
function sum() {
    $acc = 0;
    foreach (func_get_args() as $n) {
        $acc += $n;
    }
    return $acc;
}

echo sum(1, 2, 3, 4);
?>

以上例程会输出：

10

命名参数

PHP 8.0.0 开始引入了命名参数作为现有位置参数的扩展。命名参数允许根据参数名而不是参数位置向函数传参。这使得参数的含义自成体系，参数与顺序无关，并允许任意跳过默认值。

命名参数通过在参数名前加上冒号来传递。允许使用保留关键字作为参数名。参数名必须是一个标识符，不允许动态指定。

Example #13 命名参数的语法

<?php
myFunction(paramName: $value);
array_foobar(array: $value);

// NOT supported.
function_name($variableStoringParamName: $value);
?>

Example #14 通过位置传参与命名参数的对比

<?php
// 使用顺序传递参数：
array_fill(0, 100, 50);

// 使用命名参数：
array_fill(start_index: 0, count: 100, value: 50);
?>

指定参数的传递顺序并不重要。

Example #15 参数顺序不同的示例（同上例）

<?php
array_fill(value: 50, num: 100, start_index: 0);
?>

命名参数也可以与位置参数相结合使用。此种情况下，命名参数必须在位置参数之后。也可以只指定一个函数的部分可选参数，而不考虑它们的顺序。

Example #16 命名参数与位置参数结合使用

<?php
htmlspecialchars($string, double_encode: false);
// 等价于
htmlspecialchars($string, ENT_COMPAT | ENT_HTML401, 'UTF-8', false);
?>

Passing the same parameter multiple times results in an Error exception.

Example #17 Error exception when passing the same parameter multiple times

<?php
function foo($param) { ... }

foo(param: 1, param: 2);
// Error: Named parameter $param overwrites previous argument
foo(1, param: 2);
// Error: Named parameter $param overwrites previous argument
?>


返回值

值通过使用可选的返回语句返回。可以返回包括数组和对象的任意类型。返回语句会立即中止函数的运行，并且将控制权交回调用该函数的代码行。更多信息见 return。

Note:

如果省略了 return，则返回值为 null。

return 的使用

Example #1 return 的使用

<?php
function square($num)
{
    return $num * $num;
}
echo square(4);   // outputs '16'.
?>

函数不能返回多个值，但可以通过返回一个数组来得到类似的效果。

Example #2 返回一个数组以得到多个返回值

<?php
function small_numbers()
{
    return array (0, 1, 2);
}
list ($zero, $one, $two) = small_numbers();
?>

从函数返回一个引用，必须在函数声明和指派返回值给一个变量时都使用引用运算符 &：

Example #3 从函数返回一个引用

<?php
function &returns_reference()
{
    return $someref;
}

$newref =& returns_reference();
?>

有关引用的更多信息, 请查看 引用的解释。


可变函数

PHP 支持可变函数的概念。这意味着如果一个变量名后有圆括号，PHP 将寻找与变量的值同名的函数，并且尝试执行它。可变函数可以用来实现包括回调函数，函数表在内的一些用途。

可变函数不能用于例如 echo，print，unset()，isset()，empty()，include，require 以及类似的语言结构。需要使用自己的包装函数来将这些结构用作可变函数。

Example #1 可变函数示例

<?php
function foo() {
    echo "In foo()<br />\n";
}

function bar($arg = '')
{
    echo "In bar(); argument was '$arg'.<br />\n";
}

// 使用 echo 的包装函数
function echoit($string)
{
    echo $string;
}

$func = 'foo';
$func();        // This calls foo()

$func = 'bar';
$func('test');  // This calls bar()

$func = 'echoit';
$func('test');  // This calls echoit()
?>

也可以用可变函数的语法来调用一个对象的方法。

Example #2 可变方法范例

<?php
class Foo
{
    function Variable()
    {
        $name = 'Bar';
        $this->$name(); // This calls the Bar() method
    }

    function Bar()
    {
        echo "This is Bar";
    }
}

$foo = new Foo();
$funcname = "Variable";
$foo->$funcname();  // This calls $foo->Variable()

?>

当调用静态方法时，函数调用要比静态属性优先：

Example #3 Variable 方法和静态属性示例

<?php
class Foo
{
    static $variable = 'static property';
    static function Variable()
    {
        echo 'Method Variable called';
    }
}

echo Foo::$variable; // This prints 'static property'. It does need a $variable in this scope.
$variable = "Variable";
Foo::$variable();  // This calls $foo->Variable() reading $variable in this scope.

?>

Example #4 Complex callables

<?php
class Foo
{
    static function bar()
    {
        echo "bar\n";
    }
    function baz()
    {
        echo "baz\n";
    }
}

$func = array("Foo", "bar");
$func(); // prints "bar"
$func = array(new Foo, "baz");
$func(); // prints "baz"
$func = "Foo::bar";
$func(); // prints "bar"
?>

参见

  • is_callable()
  • call_user_func()
  • function_exists()
  • variable variables


内部（内置）函数

PHP 有很多标准的函数和结构。还有一些函数需要和特定地 PHP 扩展模块一起编译，否则在使用它们的时候就会得到一个致命的"未定义函数"错误。例如，要使用 image 函数中的 imagecreatetruecolor()，需要在编译 PHP 的时候加上 GD 的支持。或者，要使用 mysqli_connect() 函数，就需要在编译 PHP 的时候加上 MySQLi 支持。有很多核心函数已包含在每个版本的 PHP 中如字符串和变量函数。调用 phpinfo() 或者 get_loaded_extensions() 可以得知 PHP 加载了那些扩展库。同时还应该注意，很多扩展库默认就是有效的。PHP 手册按照不同的扩展库组织了它们的文档。请参阅配置，安装以及各自的扩展库章节以获取有关如何设置 PHP 的信息。

手册中如何阅读函数原型讲解了如何阅读和理解一个函数的原型。确认一个函数将返回什么，或者函数是否直接作用于传递的参数是很重要的。例如，str_replace() 函数将返回修改过的字符串，而 usort() 却直接作用于传递的参数变量本身。手册中，每一个函数的页面中都有关于函数参数、行为改变、成功与否的返回值以及使用条件等信息。了解这些重要的（常常是细微的）差别是编写正确的 PHP 代码的关键。

Note: 如果传递给函数的参数类型与实际的类型不一致，例如将一个 array 传递给一个 string 类型的变量，那么函数的返回值是不确定的。在这种情况下，通常函数会返回 null。但这仅仅是一个惯例，并不一定如此。

参见

  • function_exists()
  • the function reference
  • get_extension_funcs()
  • dl()


匿名函数

匿名函数（Anonymous functions），也叫闭包函数（closures），允许 临时创建一个没有指定名称的函数。最经常用作回调函数 callable参数的值。当然，也有其它应用的情况。

匿名函数目前是通过 Closure 类来实现的。

Example #1 匿名函数示例

<?php
echo preg_replace_callback('~-([a-z])~', function ($match) {
    return strtoupper($match[1]);
}, 'hello-world');
// 输出 helloWorld
?>

闭包函数也可以作为变量的值来使用。PHP 会自动把此种表达式转换成内置类 Closure 的对象实例。把一个 closure 对象赋值给一个变量的方式与普通变量赋值的语法是一样的，最后也要加上分号：

Example #2 匿名函数变量赋值示例

<?php
$greet = function($name)
{
    printf("Hello %s\r\n", $name);
};

$greet('World');
$greet('PHP');
?>

闭包可以从父作用域中继承变量。 任何此类变量都应该用 use 语言结构传递进去。 PHP 7.1 起，不能传入此类变量： superglobals、 $this 或者和参数重名。

Example #3 从父作用域继承变量

<?php
$message = 'hello';

// 没有 "use"
$example = function () {
    var_dump($message);
};
$example();

// 继承 $message
$example = function () use ($message) {
    var_dump($message);
};
$example();

// Inherited variable's value is from when the function
// is defined, not when called
$message = 'world';
$example();

// Reset message
$message = 'hello';

// Inherit by-reference
$example = function () use (&$message) {
    var_dump($message);
};
$example();

// The changed value in the parent scope
// is reflected inside the function call
$message = 'world';
$example();

// Closures can also accept regular arguments
$example = function ($arg) use ($message) {
    var_dump($arg . ' ' . $message);
};
$example("hello");
?>

以上例程的输出类似于：

Notice: Undefined variable: message in /example.php on line 6
NULL
string(5) "hello"
string(5) "hello"
string(5) "hello"
string(5) "world"
string(11) "hello world"

从 PHP 8.0.0 开始，作用域继承的变量列表可能包含一个尾部的逗号，这个逗号将被忽略。

这些变量都必须在函数或类的头部声明。 从父作用域中继承变量与使用全局变量是不同的。全局变量存在于一个全局的范围，无论当前在执行的是哪个函数。而 闭包的父作用域是定义该闭包的函数（不一定是调用它的函数）。示例如下：

Example #4 Closures 和作用域

<?php
// 一个基本的购物车，包括一些已经添加的商品和每种商品的数量。
// 其中有一个方法用来计算购物车中所有商品的总价格，该方法使
// 用了一个 closure 作为回调函数。
class Cart
{
    const PRICE_BUTTER  = 1.00;
    const PRICE_MILK    = 3.00;
    const PRICE_EGGS    = 6.95;

    protected $products = array();

    public function add($product, $quantity)
    {
        $this->products[$product] = $quantity;
    }

    public function getQuantity($product)
    {
        return isset($this->products[$product]) ? $this->products[$product] :
               FALSE;
    }

    public function getTotal($tax)
    {
        $total = 0.00;

        $callback =
            function ($quantity, $product) use ($tax, &$total)
            {
                $pricePerItem = constant(__CLASS__ . "::PRICE_" .
                    strtoupper($product));
                $total += ($pricePerItem * $quantity) * ($tax + 1.0);
            };

        array_walk($this->products, $callback);
        return round($total, 2);
    }
}

$my_cart = new Cart;

// 往购物车里添加条目
$my_cart->add('butter', 1);
$my_cart->add('milk', 3);
$my_cart->add('eggs', 6);

// 打出出总价格，其中有 5% 的销售税.
print $my_cart->getTotal(0.05) . "\n";
// 最后结果是 54.29
?>

Example #5 自动绑定 $this

<?php

class Test
{
    public function testing()
    {
        return function() {
            var_dump($this);
        };
    }
}

$object = new Test;
$function = $object->testing();
$function();

?>

以上例程会输出：

object(Test)#1 (0) {
}

当在类的上下文中声明时，当前的类会自动与之绑定，使得 $this 在函数的作用域中可用。如果不需要当前类的自动绑定，可以使用 静态匿名函数 替代。

静态匿名函数

匿名函数允许被定义为静态化。这样可以防止当前类自动绑定到它们身上，对象在运行时也可能不会被绑定到它们上面。

Example #6 试图在静态匿名函数中使用 $this

<?php

class Foo
{
    function __construct()
    {
        $func = static function() {
            var_dump($this);
        };
        $func();
    }
};
new Foo();

?>

以上例程会输出：

Notice: Undefined variable: this in %s on line %d
NULL

Example #7 试图将对象绑定到静态匿名函数

<?php

$func = static function() {
    // function body
};
$func = $func->bindTo(new StdClass);
$func();

?>

以上例程会输出：

Warning: Cannot bind an instance to a static closure in %s on line %d

更新日志

版本 | 说明
7.1.0 | Anonymous functions may not close over superglobals, $this, or any variable with the same name as a parameter.

注释

Note: 可以在闭包中使用 func_num_args()，func_get_arg() 和 func_get_args()。


箭头函数

箭头函数是 PHP 7.4 的新语法，是一种更简洁的 匿名函数 写法。

匿名函数和箭头函数都是 Closure 类的实现。

箭头函数的基本语法为 fn (argument_list) => expr。

箭头函数支持与 匿名函数 相同的功能，只是其父作用域的变量总是自动的。

当表达式中使用的变量是在父作用域中定义的，它将被隐式地按值捕获。在下面的例子中，函数 $fn1 和 $fn2 的行为是一样的。

Example #1 箭头函数自动捕捉变量的值

<?php

$y = 1;

$fn1 = fn($x) => $x + $y;
// 相当于 using $y by value:
$fn2 = function ($x) use ($y) {
    return $x + $y;
};

var_export($fn1(3));
?>

以上例程会输出：

4

在箭头函数嵌套的情况下同样有效。

Example #2 箭头函数自动捕捉变量的值，即使在嵌套的情况下

<?php

$z = 1;
$fn = fn($x) => fn($y) => $x * $y + $z;
// 输出 51
var_export($fn(5)(10));
?>

和匿名函数一样，箭头函数语法同样允许标准的函数声明，包括参数和返回类型、缺省值、变量，以及通过引用传递和返回。以下都是箭头函数的有效例子。

Example #3 合法的箭头函数例子

<?php

fn(array $x) => $x;
static fn(): int => $x;
fn($x = 42) => $x;
fn(&$x) => $x;
fn&($x) => $x;
fn($x, ...$rest) => $rest;

?>

箭头函数会自动绑定上下文变量，这相当于对箭头函数内部使用的每一个变量 $x 执行了一个 use($x)。这意味着不可能修改外部作用域的任何值，若要实现对值的修改，可以使用 匿名函数 来替代。

Example #4 来自外部范围的值不能在箭头函数内修改

<?php

$x = 1;
$fn = fn() => $x++; // 不会影响 x 的值
$fn();
var_export($x);  // 输出 1

?>

更新日志

版本 | 说明
7.4.0 | 新增箭头函数语法。

注释

Note: 可以对箭头函数使用 func_num_args(), func_get_arg(), 和 func_get_args() 函数。


类与对象

Table of Contents

  • 简介
  • 基本概念
  • 属性
  • 类常量
  • 类的自动加载
  • 构造函数和析构函数
  • 访问控制（可见性）
  • 对象继承
  • 范围解析操作符 （::）
  • 静态（static）关键字
  • 抽象类
  • 对象接口
  • Trait
  • 匿名类
  • 重载
  • 遍历对象
  • 魔术方法
  • Final 关键字
  • 对象复制
  • 对象比较
  • 后期静态绑定
  • 对象和引用
  • 对象序列化
  • 协变与逆变
  • OOP 变更日志


简介

PHP 具有完整的对象模型。特性包括： 访问控制，抽象类和 final 类与方法，附加的魔术方法，接口，对象复制。

PHP 对待对象的方式与引用和句柄相同，即每个变量都持有对象的引用，而不是整个对象的拷贝。参见 对象和引用。

Tip

请参见用户空间命名指南。


基本概念

class

每个类的定义都以关键字 class 开头，后面跟着类名，后面跟着一对花括号，里面包含有类的属性与方法的定义。

类名可以是任何非 PHP 保留字 的合法标签。一个合法类名以字母或下划线开头，后面跟着若干字母，数字或下划线。以正则表达式表示为： ^[a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*$。

一个类可以包含有属于自己的 常量，变量（称为"属性"）以及函数（称为"方法"）。

Example #1 简单的类定义

<?php
class SimpleClass
{
    // 声明属性
    public $var = 'a default value';

    // 声明方法
    public function displayVar() {
        echo $this->var;
    }
}
?>

当一个方法在类定义内部被调用时，有一个可用的伪变量 $this。$this 是一个到当前对象的引用。

Warning

以静态方式去调用一个静态方法，将会抛出一个 Error。 在 PHP 8.0.0 之前版本中，将会产生一个废弃通知，同时 $this 将会被声明为未定义。

Example #2 使用 $this 伪变量的示例

<?php
class A
{
    function foo()
    {
        if (isset($this)) {
            echo '$this is defined (';
            echo get_class($this);
            echo ")\n";
        } else {
            echo "\$this is not defined.\n";
        }
    }
}

class B
{
    function bar()
    {
        A::foo();
    }
}

$a = new A();
$a->foo();

A::foo();

$b = new B();
$b->bar();

B::bar();
?>

以上例程在 PHP 7 中的输出：

$this is defined (A)

Deprecated: Non-static method A::foo() should not be called statically in %s  on line 27
$this is not defined.

Deprecated: Non-static method A::foo() should not be called statically in %s  on line 20
$this is not defined.

Deprecated: Non-static method B::bar() should not be called statically in %s  on line 32

Deprecated: Non-static method A::foo() should not be called statically in %s  on line 20
$this is not defined.

以上例程在 PHP 8 中的输出：

$this is defined (A)

Fatal error: Uncaught Error: Non-static method A::foo() cannot be called statically in %s :27
Stack trace:
#0 {main}
  thrown in %s  on line 27

new

要创建一个类的实例，必须使用 new 关键字。当创建新对象时该对象总是被赋值，除非该对象定义了 构造函数 并且在出错时抛出了一个 异常。类应在被实例化之前定义（某些情况下则必须这样）。

如果在 new 之后跟着的是一个包含有类名的字符串 string，则该类的一个实例被创建。如果该类属于一个命名空间，则必须使用其完整名称。

Note:

如果没有参数要传递给类的构造函数，类名后的括号则可以省略掉。

Example #3 创建实例

<?php
$instance = new SimpleClass();

// 也可以这样做：
$className = 'SimpleClass';
$instance = new $className(); // new SimpleClass()
?>

在类定义内部，可以用 new self 和 new parent 创建新对象。

当把一个对象已经创建的实例赋给一个新变量时，新变量会访问同一个实例，就和用该对象赋值一样。此行为和给函数传递入实例时一样。可以用 克隆 给一个已创建的对象建立一个新实例。

Example #4 对象赋值

<?php

$instance = new SimpleClass();

$assigned   =  $instance;
$reference  =& $instance;

$instance->var = '$assigned will have this value';

$instance = null; // $instance and $reference become null

var_dump($instance);
var_dump($reference);
var_dump($assigned);
?>

以上例程会输出：

NULL
NULL
object(SimpleClass)#1 (1) {
   ["var"]=>
     string(30) "$assigned will have this value"
}

有几种方法可以创建一个对象的实例。

Example #5 创建新对象

<?php
class Test
{
    static public function getNew()
    {
        return new static;
    }
}

class Child extends Test
{}

$obj1 = new Test();
$obj2 = new $obj1;
var_dump($obj1 !== $obj2);

$obj3 = Test::getNew();
var_dump($obj3 instanceof Test);

$obj4 = Child::getNew();
var_dump($obj4 instanceof Child);
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)

可以通过一个表达式来访问新创建对象的成员：

Example #6 访问新创建对象的成员

<?php
echo (new DateTime())->format('Y');
?>

以上例程的输出类似于：

2016

Note: 在 PHP 7.1 之前，如果类没有定义构造函数，则不对参数进行执行。

属性和方法

类的属性和方法存在于不同的"命名空间"中，这意味着同一个类的属性和方法可以使用同样的名字。在类中访问属性和调用方法使用同样的操作符，具体是访问一个属性还是调用一个方法，取决于你的上下文，即用法是变量访问还是函数调用。

Example #7 访问类属性 vs. 调用类方法

<?php
class Foo
{
    public $bar = 'property';

    public function bar() {
        return 'method';
    }
}

$obj = new Foo();
echo $obj->bar, PHP_EOL, $obj->bar(), PHP_EOL;

以上例程会输出：

property
method

这意味着，如果你的类属性被分配给一个 匿名函数 你将无法直接调用它。因为访问类属性的优先级要更高，在此场景下需要用括号包裹起来调用。

Example #8 类属性被赋值为匿名函数时的调用示例

<?php
class Foo
{
    public $bar;

    public function __construct() {
        $this->bar = function() {
            return 42;
        };
    }
}

$obj = new Foo();

echo ($obj->bar)(), PHP_EOL;

以上例程会输出：

42

extends

一个类可以在声明中用 extends 关键字继承另一个类的方法和属性。PHP 不支持多重继承，一个类只能继承一个基类。

被继承的方法和属性可以通过用同样的名字重新声明被覆盖。但是如果父类定义方法时使用了 final，则该方法不可被覆盖。可以通过 parent:: 来访问被覆盖的方法或属性。

Example #9 简单的类继承

<?php
class ExtendClass extends SimpleClass
{
    // 同样名称的方法，将会覆盖父类的方法
    function displayVar()
    {
        echo "Extending class\n";
        parent::displayVar();
    }
}

$extended = new ExtendClass();
$extended->displayVar();
?>

以上例程会输出：

Extending class
a default value

Signature compatibility rules

When overriding a method, its signature must be compatible with the parent method. Otherwise, a fatal error is emitted, or, prior to PHP 8.0.0, an E_WARNING level error is generated. A signature is compatible if it respects the variance rules, makes a mandatory parameter optional, and if any new parameters are optional. This is known as the Liskov Substitution Principle, or LSP for short. The constructor, and private methods are exempt from these signature compatibility rules, and thus won't emit a fatal error in case of a signature mismatch.

Example #10 Compatible child methods

<?php

class Base
{
    public function foo(int $a) {
        echo "Valid\n";
    }
}

class Extend1 extends Base
{
    function foo(int $a = 5)
    {
        parent::foo($a);
    }
}

class Extend2 extends Base
{
    function foo(int $a, $b = 5)
    {
        parent::foo($a);
    }
}

$extended1 = new Extend1();
$extended1->foo();
$extended2 = new Extend2();
$extended2->foo(1);

以上例程会输出：

Valid
Valid

The following examples demonstrate that a child method which removes a parameter, or makes an optional parameter mandatory, is not compatible with the parent method.

Example #11 Fatal error when a child method removes a parameter

<?php

class Base
{
    public function foo(int $a = 5) {
        echo "Valid\n";
    }
}

class Extend extends Base
{
    function foo()
    {
        parent::foo(1);
    }
}

Output of the above example in PHP 8 is similar to:

Fatal error: Declaration of Extend::foo() must be compatible with Base::foo(int $a = 5) in /in/evtlq on line 13

Example #12 Fatal error when a child method makes an optional parameter mandatory

<?php

class Base
{
    public function foo(int $a = 5) {
        echo "Valid\n";
    }
}

class Extend extends Base
{
    function foo(int $a)
    {
        parent::foo($a);
    }
}

Output of the above example in PHP 8 is similar to:

Fatal error: Declaration of Extend::foo(int $a) must be compatible with Base::foo(int $a = 5) in /in/qJXVC on line 13
Warning

Renaming a method's parameter in a child class is not a signature incompatibility. However, this is discouraged as it will result in a runtime Error if named arguments are used.

Example #13 Error when using named arguments and parameters were renamed in a child class

<?php

class A {
    public function test($foo, $bar) {}
}

class B extends A {
    public function test($a, $b) {}
}

$obj = new B;

// Pass parameters according to A::test() contract
$obj->test(foo: "foo", bar: "bar"); // ERROR!

以上例程的输出类似于：

Fatal error: Uncaught Error: Unknown named parameter $foo in /in/XaaeN:14
Stack trace:
#0 {main}
  thrown in /in/XaaeN on line 14

::class

关键词 class 也可用于类名的解析。使用 ClassName::class 你可以获取一个字符串，包含了类 ClassName 的完全限定名称。这对使用了 命名空间 的类尤其有用。

Example #14 类名的解析

<?php
namespace NS {
    class ClassName {
    }

    echo ClassName::class;
}
?>

以上例程会输出：

NS\ClassName

Note:

使用 ::class 解析类名操作会在底层编译时进行。这意味着在执行该操作时，类还没有被加载。因此，即使要调用的类不存在，类名也会被展示。在此种场景下，并不会发生错误。

Example #15 解析不存在的类名

<?php
print Does\Not\Exist::class;
?>

以上例程会输出：

Does\Not\Exist

自 PHP 8.0.0 起，::class 关键字也可以对象上使用。与上述情况不同，此时解析将会在运行时进行。此操作的运行结果和 get_class() 函数一致。

Example #16 类名解析

<?php
namespace NS {
    class ClassName {
    }
}
$c = new ClassName();
print $c::class;
?>

以上例程会输出：

NS\ClassName

Nullsafe 方法和属性

自 PHP 8.0.0 起，类属性和方法新增加了一个 "nullsafe" 操作符: ?->。The nullsafe operator works the same as property or method access as above, except that if the object being dereferenced is null then null will be returned rather than an exception thrown. If the dereference is part of a chain, the rest of the chain is skipped.

此操作的结果，类似于在每次访问前使用 is_null() 函数判断方法和属性是否存在，但更加简洁。

Example #17 Nullsafe 操作符

<?php

// 自 PHP 8.0.0 起可用
$result = $repository?->getUser(5)?->name;

// 上边那行代码等价于以下代码
if (is_null($repository)) {
    $result = null;
} else {
    $user = $repository->getUser(5);
    if (is_null($user)) {
        $result = null;
    } else {
        $result = $user->name;
    }
}
?>

Note:

仅当 null 被认为是属性或方法返回的有效和预期的可能值时，才推荐使用 nullsafe 操作符。如果业务中需要明确指示错误，抛出异常会是更好的处理方式。


属性

类的变量成员叫做"属性"，或者叫"字段"、"特征"，在本文档统一称为"属性"。属性声明是由关键字 public，protected 或者 private 开头，然后跟一个普通的变量声明来组成。属性中的变量可以初始化，但是初始化的值必须是常数，这里的常数是指 PHP 脚本在编译阶段时就可以得到其值，而不依赖于运行时的信息才能求值。

有关 public，protected 和 private 的更多详细信息，请查看访问控制（可见性）。

Note:

为了向后兼容 PHP 4，PHP 5 声明属性依然可以直接使用关键字 var 来替代（或者附加于）public，protected 或 private。但是已不再需要 var 了。在 PHP 5.0 到 5.1.3，var 会被认为是废弃的，而且抛出 E_STRICT 警告，但是 5.1.3 之后就不再认为是废弃，也不会抛出警告。

如果直接使用 var 声明属性，而没有用 public，protected 或 private 之一，PHP 5 会将其视为 public。

在类的成员方法里面，可以用 ->（对象运算符）：$this->property（其中 property 是该属性名）这种方式来访问非静态属性。静态属性则是用 ::（双冒号）：self::$property 来访问。更多静态属性与非静态属性的区别参见 Static 关键字。

当一个方法在类定义内部被调用时，有一个可用的伪变量 $this。$this 是一个到主叫对象的引用（通常是该方法所从属的对象，但如果是从第二个对象静态调用时也可能是另一个对象）。

Example #1 属性声明

<?php
class SimpleClass
{
   // 错误的属性声明
   public $var1 = 'hello ' . 'world';
   public $var2 = <<<EOD
hello world
EOD;
   public $var3 = 1+2;
   public $var4 = self::myStaticMethod();
   public $var5 = $myVar;

   // 正确的属性声明
   public $var6 = myConstant;
   public $var7 = array(true, false);

   //在 PHP 5.3.0 及之后，下面的声明也正确
   public $var8 = <<<'EOD'
hello world
EOD;
}
?>

Note:

更多关于类／对象的处理函数，请查看类／对象函数。

跟 heredocs 不同，nowdocs 可在任何静态数据上下文中使用，包括属性声明。

Example #2 示例：使用 nowdoc 初始化属性

<?php
class foo {
   // 自 5.3.0 起
   public $bar = <<<'EOT'
bar
EOT;
}
?>

Note:

Nowdoc 支持是在 PHP 5.3.0 新增的。


类常量

可以把在类中始终保持不变的值定义为常量。在定义和使用常量的时候不需要使用 $ 符号。

常量的值必须是一个定值，不能是变量，类属性，数学运算的结果或函数调用。

接口（interface）中也可以定义常量。更多示例见文档中的接口部分。

自 PHP 5.3.0 起，可以用一个变量来动态调用类。但该变量的值不能为关键字（如 self，parent 或 static）。

Example #1 定义和使用一个类常量

<?php
class MyClass
{
    const constant = 'constant value';

    function showConstant() {
        echo  self::constant . "\n";
    }
}

echo MyClass::constant . "\n";

$classname = "MyClass";
echo $classname::constant . "\n"; // 自 5.3.0 起

$class = new MyClass();
$class->showConstant();

echo $class::constant."\n"; // 自 PHP 5.3.0 起
?>

Example #2 静态数据示例

<?php
class foo {
    // 自 PHP 5.3.0 起
    const bar = <<<'EOT'
bar
EOT;
}
?>

和 heredoc 不同，nowdoc 可以用在任何静态数据中。

Note:

Nowdoc 支持是在 PHP 5.3.0 新增的。


类的自动加载

在编写面向对象（OOP） 程序时，很多开发者为每个类新建一个 PHP 文件。 这会带来一个烦恼：每个脚本的开头，都需要包含（include）一个长长的列表（每个类都有个文件）。

在 PHP 5 中，已经不再需要这样了。 spl_autoload_register() 函数可以注册任意数量的自动加载器，当使用尚未被定义的类（class）和接口（interface）时自动去加载。通过注册自动加载器，脚本引擎在 PHP 出错失败前有了最后一个机会加载所需的类。

Tip

尽管 __autoload() 函数也能自动加载类和接口，但更建议使用 spl_autoload_register() 函数。 spl_autoload_register() 提供了一种更加灵活的方式来实现类的自动加载（同一个应用中，可以支持任意数量的加载器，比如第三方库中的）。因此，不再建议使用 __autoload() 函数，在以后的版本中它可能被弃用。

Note:

在 PHP 5.3 之前，__autoload 函数抛出的异常不能被 catch 语句块捕获并会导致一个致命错误（Fatal Error）。 自 PHP 5.3 起，能够 thrown 自定义的异常（Exception），随后自定义异常类即可使用。 __autoload 函数可以递归的自动加载自定义异常类。

Note:

自动加载不可用于 PHP 的 CLI 交互模式。

Note:

如果类名比如被用于 call_user_func()，则它可能包含一些危险的字符，比如 ../。 建议您在这样的函数中不要使用用户的输入，起码需要在 __autoload() 时验证下输入。

Example #1 自动加载示例

本例尝试分别从 MyClass1.php 和 MyClass2.php 文件中加载 MyClass1 和 MyClass2 类。

<?php
spl_autoload_register(function ($class_name) {
    require_once $class_name . '.php';
});

$obj  = new MyClass1();
$obj2 = new MyClass2();
?>

Example #2 另一个例子

本例尝试加载接口 ITest。

<?php

spl_autoload_register(function ($name) {
    var_dump($name);
});

class Foo implements ITest {
}

/*
string(5) "ITest"

Fatal error: Interface 'ITest' not found in ...
*/
?>

Example #3 自动加载在 PHP 5.3.0+ 中的异常处理

本例抛出一个异常并在 try/catch 语句块中演示。

<?php
spl_autoload_register(function ($name) {
    echo "Want to load $name.\n";
    throw new Exception("Unable to load $name.");
});

try {
    $obj = new NonLoadableClass();
} catch (Exception $e) {
    echo $e->getMessage(), "\n";
}
?>

以上例程会输出：

Want to load NonLoadableClass.
Unable to load NonLoadableClass.

Example #4 自动加载在 PHP 5.3.0+ 中的异常处理 - 没有自定义异常机制

本例将一个异常抛给不存在的自定义异常处理函数。

<?php
spl_autoload_register(function ($name) {
    echo "Want to load $name.\n";
    throw new MissingException("Unable to load $name.");
});

try {
    $obj = new NonLoadableClass();
} catch (Exception $e) {
    echo $e->getMessage(), "\n";
}
?>

以上例程会输出：

Want to load NonLoadableClass.
Want to load MissingException.

Fatal error: Class 'MissingException' not found in testMissingException.php on line 4

参见

  • unserialize()
  • unserialize_callback_func
  • spl_autoload_register()
  • spl_autoload()
  • __autoload()


构造函数和析构函数

构造函数

__construct ( mixed ...$values = "" ) : void

PHP 允许开发者在一个类中定义一个方法作为构造函数。具有构造函数的类会在每次创建新对象时先调用此方法，所以非常适合在使用对象之前做一些初始化工作。

Note: 如果子类中定义了构造函数则不会隐式调用其父类的构造函数。要执行父类的构造函数，需要在子类的构造函数中调用 parent::__construct()。如果子类没有定义构造函数则会如同一个普通的类方法一样从父类继承（假如没有被定义为 private 的话）。

Example #1 继承中的构造函数

<?php
class BaseClass {
    function __construct() {
        print "In BaseClass constructor\n";
    }
}

class SubClass extends BaseClass {
    function __construct() {
        parent::__construct();
        print "In SubClass constructor\n";
    }
}

class OtherSubClass extends BaseClass {
    // 继承 BaseClass 的构造函数
}

// In BaseClass constructor
$obj = new BaseClass();

// In BaseClass constructor
// In SubClass constructor
$obj = new SubClass();

// In BaseClass constructor
$obj = new OtherSubClass();
?>

与其它方法不同，当 __construct() 被与父类 __construct() 具有不同参数的方法覆盖时，PHP 不会产生一个 E_STRICT 错误信息。

自 PHP 5.3.3 起，在命名空间中，与类名同名的方法不再作为构造函数。不使用命名空间中的类则不受影响。 构造函数是一个普通的方法，在对应对象实例化时自动被调用。 因此可以定义任何数量的参数，可以是必选、可以有类型、可以有默认值。 构造器的参数放在类名后的括号里调用。

Example #2 使用构造器参数

<?php
class Point {
    protected int $x;
    protected int $y;

    public function __construct(int $x, int $y = 0) {
        $this->x = $x;
        $this->y = $y;
    }
}

// 两个参数都传入
$p1 = new Point(4, 5);
// 仅传入必填的参数。 $y 会默认取值 0。
$p2 = new Point(4);
// 使用命名参数（PHP 8.0 起）:
$p3 = new Point(y: 5, x: 4);
?>

如果一个类没有构造函数，以及构造函数的参数不是必填项时，括号就可以省略。

旧式风格的构造器

PHP 8.0.0 之前，全局命名空间内的类如果有一个同名的方法，则会解析为旧式风格的构造器。 虽然函数能被当作构造器，但该语法已被废弃，并会导致 E_DEPRECATED 错误。 如果 __construct() 和同名方法同时存在时， 会调用 __construct()。

以下两种情况时，与类同名的方法不再有特殊意义：命名空间中的类、PHP 8.0.0 起的任何类。

新代码中要使用 __construct()。

构造器属性提升

PHP 8.0.0 起，构造器的参数也可以相应提升为类的属性。 构造器的参数赋值给类属性的行为很普遍，否则无法操作。 而构造器提升的功能则为这种场景提供了便利。 因此上面的例子可以用以下方式重写：

Example #3 使用构造器属性提升

<?php
class Point {
    public function __construct(protected int $x, protected int $y = 0) {
    }
}

当构造器参数带访问控制（visibility modifier）时，PHP 会同时把它当作对象属性和构造器参数， 并赋值到属性。 构造器可以是空的，或者包含其他语句。 参数值赋值到相应属性后执行正文中额外的代码语句。

并非所有参数都需要提升。可以混合提升或不提升参数作为属性，也不需要按顺序。 提升后的参数不影响构造器内代码调用。

Note:

对象属性的类型不能为 callable 以避免为引擎带来混淆。 因此提升的参数也不能是 callable。 其他任意 类型声明 是允许的。

Note:

放在构造器提升参数里的属性会同时复制为属性和参数。

Static 创造方法

在 PHP 中每个 class 只能有一个构造器。 然而有些情况下，需要用不同的输入实现不同的方式构造对象。 这种情况下推荐使用 static 方法包装构造。

Example #4 使用 static 创造方法

<?php
class Product {

    private ?int $id;
    private ?string $name;

    private function __construct(?int $id = null, ?string $name = null) {
        $this->id = $id;
        $this->name = $name;
    }

    public static function fromBasicData(int $id, string $name): static {
        $new = new static($id, $name);
        return $new;
    }

    public static function fromJson(string $json): static {
        $data = json_decode($json);
        return new static($data['id'], $data['name']);
    }

    public static function fromXml(string $xml): static {
        // 此处放置自己的代码逻辑
        $data = convert_xml_to_array($xml);
        $new = new static();
        $new->id = $data['id'];
        $new->name = $data['name'];
        return $new;
    }
}

$p1 = Product::fromBasicData(5, 'Widget');
$p2 = Product::fromJson($some_json_string);
$p3 = Product::fromXml($some_xml_string);

可以设置构造器为 private 或 protected，防止自行额外调用。 这时只有 static 方法可以实例化一个类。 由于它们位于同一个定义的 class 因此可以访问私有方法，也不需要在同一个对象实例中。 当然构造器不一定要设置为 private，是否合理取决于实际情况。

三个 static 方法展示了对象以不同方式的实例化方式。

  • fromBasicData() 把所需的全部参数传入构造器，创建对象并返回结果。
  • fromJson() 接受 JSON 字符串，，预处理成构造器所需的格式，然后返回新的对象。
  • fromXml() 接受 XML 字符串并解析，然后创建一个单纯的对象。 由于参数都是可选的，使得可以忽略所有参数去调用构造器。然后为对象的属性赋值后返回结果。

在以上三个例子中，static 关键词会被翻译成代码所在类的类名。 这个例子中是 Product。

析构函数

__destruct ( ) : void

PHP 5 引入了析构函数的概念，这类似于其它面向对象的语言，如 C++。析构函数会在到某个对象的所有引用都被删除或者当对象被显式销毁时执行。

Example #5 析构函数示例

<?php

class MyDestructableClass
{
    function __construct() {
        print "In constructor\n";
    }

    function __destruct() {
        print "Destroying " . __CLASS__ . "\n";
    }
}

$obj = new MyDestructableClass();

和构造函数一样，父类的析构函数不会被引擎暗中调用。要执行父类的析构函数，必须在子类的析构函数体中显式调用 parent::__destruct()。此外也和构造函数一样，子类如果自己没有定义析构函数则会继承父类的。

析构函数即使在使用 exit() 终止脚本运行时也会被调用。在析构函数中调用 exit() 将会中止其余关闭操作的运行。

Note:

析构函数在脚本关闭时调用，此时所有的 HTTP 头信息已经发出。脚本关闭时的工作目录有可能和在 SAPI（如 apache）中时不同。

Note:

试图在析构函数（在脚本终止时被调用）中抛出一个异常会导致致命错误。


访问控制（可见性）

对属性或方法的访问控制（PHP 7.1.0 以后支持常量），是通过在前面添加关键字 public（公有），protected（受保护）或 private（私有）来实现的。被定义为公有的类成员可以在任何地方被访问。被定义为受保护的类成员则可以被其自身以及其子类和父类访问。被定义为私有的类成员则只能被其定义所在的类访问。

属性的访问控制

类属性必须定义为公有，受保护，私有之一。如果用 var 定义，则被视为公有。

Example #1 属性声明

<?php
/**
 * Define MyClass
 */
class MyClass
{
    public $public = 'Public';
    protected $protected = 'Protected';
    private $private = 'Private';

    function printHello()
    {
        echo $this->public;
        echo $this->protected;
        echo $this->private;
    }
}

$obj = new MyClass();
echo $obj->public; // 这行能被正常执行
echo $obj->protected; // 这行会产生一个致命错误
echo $obj->private; // 这行也会产生一个致命错误
$obj->printHello(); // 输出 Public、Protected 和 Private

/**
 * Define MyClass2
 */
class MyClass2 extends MyClass
{
    // 可以对 public 和 protected 进行重定义，但 private 而不能
    public $public = 'Public2';
    protected $protected = 'Protected2';

    function printHello()
    {
        echo $this->public;
        echo $this->protected;
        echo $this->private;
    }
}

$obj2 = new MyClass2();
echo $obj2->public; // 这行能被正常执行
echo $obj2->protected; // 这行会产生一个致命错误
echo $obj2->private; // 未定义 private
$obj2->printHello(); // 输出 Public、Protected2 和 Undefined

?>

Note: 为了兼容性考虑，在 PHP 4 中使用 var 关键字对变量进行定义的方法在 PHP 5 中仍然有效（只是作为 public 关键字的一个别名）。在 PHP 5.1.3 之前的版本，该语法会产生一个 E_STRICT 警告。

方法的访问控制

类中的方法可以被定义为公有，私有或受保护。如果没有设置这些关键字，则该方法默认为公有。

Example #2 方法声明

<?php
/**
 * Define MyClass
 */
class MyClass
{
    // 声明一个公有的构造函数
    public function __construct() { }

    // 声明一个公有的方法
    public function MyPublic() { }

    // 声明一个受保护的方法
    protected function MyProtected() { }

    // 声明一个私有的方法
    private function MyPrivate() { }

    // 此方法为公有
    function Foo()
    {
        $this->MyPublic();
        $this->MyProtected();
        $this->MyPrivate();
    }
}

$myclass = new MyClass;
$myclass->MyPublic(); // 这行能被正常执行
$myclass->MyProtected(); // 这行会产生一个致命错误
$myclass->MyPrivate(); // 这行会产生一个致命错误
$myclass->Foo(); // 公有，受保护，私有都可以执行

/**
 * Define MyClass2
 */
class MyClass2 extends MyClass
{
    // 此方法为公有
    function Foo2()
    {
        $this->MyPublic();
        $this->MyProtected();
        $this->MyPrivate(); // 这行会产生一个致命错误
    }
}

$myclass2 = new MyClass2;
$myclass2->MyPublic(); // 这行能被正常执行
$myclass2->Foo2(); // 公有的和受保护的都可执行，但私有的不行

class Bar
{
    public function test() {
        $this->testPrivate();
        $this->testPublic();
    }

    public function testPublic() {
        echo "Bar::testPublic\n";
    }

    private function testPrivate() {
        echo "Bar::testPrivate\n";
    }
}

class Foo extends Bar
{
    public function testPublic() {
        echo "Foo::testPublic\n";
    }

    private function testPrivate() {
        echo "Foo::testPrivate\n";
    }
}

$myFoo = new foo();
$myFoo->test(); // Bar::testPrivate
                // Foo::testPublic
?>

常量的控制访问

PHP 7.1.0 开始，类的常量可以定义为公有、私有或受保护。如果没有设置这些关键字，则该常量默认为公有。

Example #3 PHP 7.1.0 中的常量声明

<?php
/**
 * Define MyClass
 */
class MyClass
{
    // 公有常量
    public const MY_PUBLIC = 'public';

    // 受保护的常量
    protected const MY_PROTECTED = 'protected';

    // 私有常量
    private const MY_PRIVATE = 'private';

    public function foo()
    {
        echo self::MY_PUBLIC;
        echo self::MY_PROTECTED;
        echo self::MY_PRIVATE;
    }
}

$myclass = new MyClass();
MyClass::MY_PUBLIC; // 这行可以正常执行
MyClass::MY_PROTECTED; // 这行会产生一个致命错误
MyClass::MY_PRIVATE; // 这行会产生一个致命错误
$myclass->foo(); // 将会输出：Public Protected Private

/**
 * Define MyClass2
 */
class MyClass2 extends MyClass
{
    // This is public
    function foo2()
    {
        echo self::MY_PUBLIC;
        echo self::MY_PROTECTED;
        echo self::MY_PRIVATE; // 这行会产生一个致命错误
    }
}

$myclass2 = new MyClass2;
echo MyClass2::MY_PUBLIC; // 这行可以正常执行
$myclass2->foo2(); // 将会输出：Public Protected，MY_PRIVATE 是私有常量，无法输出
?>

其它对象的访问控制

同一个类的对象即使不是同一个实例也可以互相访问对方的私有与受保护成员。这是由于在这些对象的内部具体实现的细节都是已知的。

Example #4 访问同一个对象类型的私有成员

<?php
class Test
{
    private $foo;

    public function __construct($foo)
    {
        $this->foo = $foo;
    }

    private function bar()
    {
        echo 'Accessed the private method.';
    }

    public function baz(Test $other)
    {
        // We can change the private property:
        $other->foo = 'hello';
        var_dump($other->foo);

        // We can also call the private method:
        $other->bar();
    }
}

$test = new Test('test');

$test->baz(new Test('other'));
?>

以上例程会输出：

string(5) "hello"
Accessed the private method.


对象继承

继承已为大家所熟知的一个程序设计特性，PHP 的对象模型也使用了继承。继承将会影响到类与类，对象与对象之间的关系。

比如，当扩展一个类，子类就会继承父类所有公有的和受保护的方法。除非子类覆盖了父类的方法，被继承的方法都会保留其原有功能。

继承对于功能的设计和抽象是非常有用的，而且对于类似的对象增加新功能就无须重新再写这些公用的功能。

Note:

除非使用了自动加载，否则一个类必须在使用之前被定义。如果一个类扩展了另一个，则父类必须在子类之前被声明。此规则适用于类继承其它类与接口。

Example #1 继承示例

<?php

class foo
{
    public function printItem($string)
    {
        echo 'Foo: ' . $string . PHP_EOL;
    }

    public function printPHP()
    {
        echo 'PHP is great.' . PHP_EOL;
    }
}

class bar extends foo
{
    public function printItem($string)
    {
        echo 'Bar: ' . $string . PHP_EOL;
    }
}

$foo = new foo();
$bar = new bar();
$foo->printItem('baz'); // Output: 'Foo: baz'
$foo->printPHP();       // Output: 'PHP is great'
$bar->printItem('baz'); // Output: 'Bar: baz'
$bar->printPHP();       // Output: 'PHP is great'

?>


范围解析操作符 （::）

范围解析操作符（也可称作 Paamayim Nekudotayim）或者更简单地说是一对冒号，可以用于访问静态成员，类常量，还可以用于覆盖类中的属性和方法。

当在类定义之外引用到这些项目时，要使用类名。

自 PHP 5.3.0 起，可以通过变量来引用类，该变量的值不能是关键字（如 self，parent 和 static）。

把 Paamayim Nekudotayim 选作双冒号操作符的名字似乎有些奇怪。然而，这是 Zend 开发小组在写 Zend Engine 0.5（被用于 PHP 3 中）时所作出的决定。事实上这个词在希伯莱文就是双冒号的意思。

Example #1 在类的外部使用 :: 操作符

<?php
class MyClass {
    const CONST_VALUE = 'A constant value';
}

$classname = 'MyClass';
echo $classname::CONST_VALUE; // 自 PHP 5.3.0 起

echo MyClass::CONST_VALUE;
?>

self，parent 和 static 这三个特殊的关键字是用于在类定义的内部对其属性或方法进行访问的。

Example #2 在类定义内部使用 ::

<?php
class OtherClass extends MyClass
{
    public static $my_static = 'static var';

    public static function doubleColon() {
        echo parent::CONST_VALUE . "\n";
        echo self::$my_static . "\n";
    }
}

$classname = 'OtherClass';
echo $classname::doubleColon(); // 自 PHP 5.3.0 起

OtherClass::doubleColon();
?>

当一个子类覆盖其父类中的方法时，PHP 不会调用父类中已被覆盖的方法。是否调用父类的方法取决于子类。这种机制也作用于构造函数和析构函数，重载以及魔术方法。

Example #3 调用父类的方法

<?php
class MyClass
{
    protected function myFunc() {
        echo "MyClass::myFunc()\n";
    }
}

class OtherClass extends MyClass
{
    // 覆盖了父类的定义
    public function myFunc()
    {
        // 但还是可以调用父类中被覆盖的方法
        parent::myFunc();
        echo "OtherClass::myFunc()\n";
    }
}

$class = new OtherClass();
$class->myFunc();
?>

参见 伪变量的示例。


静态（static）关键字

Tip

本页说明了用 static 关键字来定义静态方法和属性。static 也可用于定义静态变量以及后期静态绑定。参见上述页面了解 static 在其中的用法。

声明类属性或方法为静态，就可以不实例化类而直接访问。静态属性不能通过一个类已实例化的对象来访问（但静态方法可以）。

静态方法

由于静态方法不需要通过对象即可调用，所以伪变量 $this 在静态方法中不可用。

Warning

用静态方式调用一个非静态方法会抛出 Error。

在 PHP 8.0.0 之前，通过静态方式调用一个非静态方法这种用法已经被废弃，并且会导致一个 E_DEPRECATED 级别的警告。

Example #1 静态方法示例

<?php
class Foo {
    public static function aStaticMethod() {
        // ...
    }
}

Foo::aStaticMethod();
$classname = 'Foo';
$classname::aStaticMethod();
?>

静态属性

静态属性不可以由对象通过 -> 操作符来访问。

就像其它所有的 PHP 静态变量一样，静态属性在初始化时遵循和 const 表达式一样的规则： 有一些特定的表达式是可行的，取决于它们是否能在编译时就计算出值。

通过变量来引用一个类是可行的，但这个变量的值不能是一个保留字 （例如self，parent和 static）

Example #2 静态属性示例

<?php
class Foo
{
    public static $my_static = 'foo';

    public function staticValue() {
        return self::$my_static;
    }
}

class Bar extends Foo
{
    public function fooStatic() {
        return parent::$my_static;
    }
}

print Foo::$my_static . "\n";

$foo = new Foo();
print $foo->staticValue() . "\n";
print $foo->my_static . "\n";      // 未定义的 "属性" my_static

print $foo::$my_static . "\n";
$classname = 'Foo';
print $classname::$my_static . "\n";

print Bar::$my_static . "\n";
$bar = new Bar();
print $bar->fooStatic() . "\n";
?>


抽象类

PHP 5 支持抽象类和抽象方法。定义为抽象的类不能被实例化。任何一个类，如果它里面至少有一个方法是被声明为抽象的，那么这个类就必须被声明为抽象的。被定义为抽象的方法只是声明了其调用方式（参数），不能定义其具体的功能实现。

继承一个抽象类的时候，子类必须定义父类中的所有抽象方法；另外，这些方法的访问控制必须和父类中一样（或者更为宽松）。例如某个抽象方法被声明为受保护的，那么子类中实现的方法就应该声明为受保护的或者公有的，而不能定义为私有的。此外方法的调用方式必须匹配，即类型和所需参数数量必须一致。例如，子类定义了一个可选参数，而父类抽象方法的声明里没有，则两者的声明并无冲突。 这也适用于 PHP 5.4 起的构造函数。在 PHP 5.4 之前的构造函数声明可以不一样的。

Example #1 抽象类示例

<?php
abstract class AbstractClass
{
 // 强制要求子类定义这些方法
    abstract protected function getValue();
    abstract protected function prefixValue($prefix);

    // 普通方法（非抽象方法）
    public function printOut() {
        print $this->getValue() . "\n";
    }
}

class ConcreteClass1 extends AbstractClass
{
    protected function getValue() {
        return "ConcreteClass1";
    }

    public function prefixValue($prefix) {
        return "{$prefix}ConcreteClass1";
    }
}

class ConcreteClass2 extends AbstractClass
{
    public function getValue() {
        return "ConcreteClass2";
    }

    public function prefixValue($prefix) {
        return "{$prefix}ConcreteClass2";
    }
}

$class1 = new ConcreteClass1;
$class1->printOut();
echo $class1->prefixValue('FOO_') ."\n";

$class2 = new ConcreteClass2;
$class2->printOut();
echo $class2->prefixValue('FOO_') ."\n";
?>

以上例程会输出：

ConcreteClass1
FOO_ConcreteClass1
ConcreteClass2
FOO_ConcreteClass2

Example #2 抽象类示例

<?php
abstract class AbstractClass
{
    // 我们的抽象方法仅需要定义需要的参数
    abstract protected function prefixName($name);

}

class ConcreteClass extends AbstractClass
{

    // 我们的子类可以定义父类签名中不存在的可选参数
    public function prefixName($name, $separator = ".") {
        if ($name == "Pacman") {
            $prefix = "Mr";
        } elseif ($name == "Pacwoman") {
            $prefix = "Mrs";
        } else {
            $prefix = "";
        }
        return "{$prefix}{$separator} {$name}";
    }
}

$class = new ConcreteClass;
echo $class->prefixName("Pacman"), "\n";
echo $class->prefixName("Pacwoman"), "\n";
?>

以上例程会输出：

Mr. Pacman
Mrs. Pacwoman

老代码中如果没有自定义类或函数被命名为"abstract"，则应该能不加修改地正常运行。


对象接口

使用接口（interface），可以指定某个类必须实现哪些方法，但不需要定义这些方法的具体内容。

接口是通过 interface 关键字来定义的，就像定义一个标准的类一样，但其中定义所有的方法都是空的。

接口中定义的所有方法都必须是公有，这是接口的特性。

需要注意的是，在接口中定义一个构造方法是被允许的。在有些场景下这可能会很有用，例如用于工厂模式时。

实现（implements）

要实现一个接口，使用 implements 操作符。类中必须实现接口中定义的所有方法，否则会报一个致命错误。类可以实现多个接口，用逗号来分隔多个接口的名称。

Note:

在 PHP 5.3.9 之前，实现多个接口时，接口中的方法不能有重名，因为这可能会有歧义。在最近的 PHP 版本中，只要这些重名的方法签名相同，这种行为就是允许的。

Note:

接口也可以继承，通过使用 extends 操作符。

Note:

类要实现接口，必须使用和接口中所定义的方法完全一致的方式。否则会导致致命错误。

常量

接口中也可以定义常量。接口常量和类常量的使用完全相同，但是不能被子类或子接口所覆盖。

范例

Example #1 接口示例

<?php

// 声明一个'iTemplate'接口
interface iTemplate
{
    public function setVariable($name, $var);
    public function getHtml($template);
}

// 实现接口
// 下面的写法是正确的
class Template implements iTemplate
{
    private $vars = array();

    public function setVariable($name, $var)
    {
        $this->vars[$name] = $var;
    }

    public function getHtml($template)
    {
        foreach($this->vars as $name => $value) {
            $template = str_replace('{' . $name . '}', $value, $template);
        }

        return $template;
    }
}

// 下面的写法是错误的，会报错，因为没有实现 getHtml()：
// Fatal error: Class BadTemplate contains 1 abstract methods
// and must therefore be declared abstract (iTemplate::getHtml)
class BadTemplate implements iTemplate
{
    private $vars = array();

    public function setVariable($name, $var)
    {
        $this->vars[$name] = $var;
    }
}
?>

Example #2 可扩充的接口

<?php
interface a
{
    public function foo();
}

interface b extends a
{
    public function baz(Baz $baz);
}

// 正确写法
class c implements b
{
    public function foo()
    {
    }

    public function baz(Baz $baz)
    {
    }
}

// 错误写法会导致一个致命错误
class d implements b
{
    public function foo()
    {
    }

    public function baz(Foo $foo)
    {
    }
}
?>

Example #3 继承多个接口

<?php
interface a
{
    public function foo();
}

interface b
{
    public function bar();
}

interface c extends a, b
{
    public function baz();
}

class d implements c
{
    public function foo()
    {
    }

    public function bar()
    {
    }

    public function baz()
    {
    }
}
?>

Example #4 使用接口常量

<?php
interface a
{
    const b = 'Interface constant';
}

// 输出接口常量
echo a::b;

// 错误写法，因为常量不能被覆盖。接口常量的概念和类常量是一样的。
class b implements a
{
    const b = 'Class constant';
}
?>

接口加上类型约束，提供了一种很好的方式来确保某个对象包含有某些方法。参见 instanceof 操作符和类型声明。


Trait

自 PHP 5.4.0 起，PHP 实现了一种代码复用的方法，称为 trait。

Trait 是为类似 PHP 的单继承语言而准备的一种代码复用机制。Trait 为了减少单继承语言的限制，使开发人员能够自由地在不同层次结构内独立的类中复用 method。Trait 和 Class 组合的语义定义了一种减少复杂性的方式，避免传统多继承和 Mixin 类相关典型问题。

Trait 和 Class 相似，但仅仅旨在用细粒度和一致的方式来组合功能。 无法通过 trait 自身来实例化。它为传统继承增加了水平特性的组合；也就是说，应用的几个 Class 之间不需要继承。

Example #1 Trait 示例

<?php
trait ezcReflectionReturnInfo {
    function getReturnType() { /*1*/ }
    function getReturnDescription() { /*2*/ }
}

class ezcReflectionMethod extends ReflectionMethod {
    use ezcReflectionReturnInfo;
    /* ... */
}

class ezcReflectionFunction extends ReflectionFunction {
    use ezcReflectionReturnInfo;
    /* ... */
}
?>

优先级

从基类继承的成员会被 trait 插入的成员所覆盖。优先顺序是来自当前类的成员覆盖了 trait 的方法，而 trait 则覆盖了被继承的方法。

Example #2 优先顺序示例

从基类继承的成员被插入的 SayWorld Trait 中的 MyHelloWorld 方法所覆盖。其行为 MyHelloWorld 类中定义的方法一致。优先顺序是当前类中的方法会覆盖 trait 方法，而 trait 方法又覆盖了基类中的方法。

<?php
class Base {
    public function sayHello() {
        echo 'Hello ';
    }
}

trait SayWorld {
    public function sayHello() {
        parent::sayHello();
        echo 'World!';
    }
}

class MyHelloWorld extends Base {
    use SayWorld;
}

$o = new MyHelloWorld();
$o->sayHello();
?>

以上例程会输出：

Hello World!

Example #3 另一个优先级顺序的例子

<?php
trait HelloWorld {
    public function sayHello() {
        echo 'Hello World!';
    }
}

class TheWorldIsNotEnough {
    use HelloWorld;
    public function sayHello() {
        echo 'Hello Universe!';
    }
}

$o = new TheWorldIsNotEnough();
$o->sayHello();
?>

以上例程会输出：

Hello Universe!

多个 trait

通过逗号分隔，在 use 声明列出多个 trait，可以都插入到一个类中。

Example #4 多个 trait 的用法

<?php
trait Hello {
    public function sayHello() {
        echo 'Hello ';
    }
}

trait World {
    public function sayWorld() {
        echo 'World';
    }
}

class MyHelloWorld {
    use Hello, World;
    public function sayExclamationMark() {
        echo '!';
    }
}

$o = new MyHelloWorld();
$o->sayHello();
$o->sayWorld();
$o->sayExclamationMark();
?>

以上例程会输出：

Hello World!

冲突的解决

如果两个 trait 都插入了一个同名的方法，如果没有明确解决冲突将会产生一个致命错误。

为了解决多个 trait 在同一个类中的命名冲突，需要使用 insteadof 操作符来明确指定使用冲突方法中的哪一个。

以上方式仅允许排除掉其它方法，as 操作符可以 为某个方法引入别名。 注意，as 操作符不会对方法进行重命名，也不会影响其方法。

Example #5 冲突的解决

在本例中 Talker 使用了 trait A 和 B。由于 A 和 B 有冲突的方法，其定义了使用 trait B 中的 smallTalk 以及 trait A 中的 bigTalk。

Aliased_Talker 使用了 as 操作符来定义了 talk 来作为 B 的 bigTalk 的别名。

<?php
trait A {
    public function smallTalk() {
        echo 'a';
    }
    public function bigTalk() {
        echo 'A';
    }
}

trait B {
    public function smallTalk() {
        echo 'b';
    }
    public function bigTalk() {
        echo 'B';
    }
}

class Talker {
    use A, B {
        B::smallTalk insteadof A;
        A::bigTalk insteadof B;
    }
}

class Aliased_Talker {
    use A, B {
        B::smallTalk insteadof A;
        A::bigTalk insteadof B;
        B::bigTalk as talk;
    }
}
?>

Note:

在 PHP 7.0 之前，在类里定义和 trait 同名的属性，哪怕是完全兼容的也会抛出 E_STRICT（完全兼容的意思：具有相同的访问可见性、初始默认值）。

修改方法的访问控制

使用 as 语法还可以用来调整方法的访问控制。

Example #6 修改方法的访问控制

<?php
trait HelloWorld {
    public function sayHello() {
        echo 'Hello World!';
    }
}

// 修改 sayHello 的访问控制
class MyClass1 {
    use HelloWorld { sayHello as protected; }
}

// 给方法一个改变了访问控制的别名
// 原版 sayHello 的访问控制则没有发生变化
class MyClass2 {
    use HelloWorld { sayHello as private myPrivateHello; }
}
?>

从 trait 来组成 trait

正如 class 能够使用 trait 一样，其它 trait 也能够使用 trait。在 trait 定义时通过使用一个或多个 trait，能够组合其它 trait 中的部分或全部成员。

Example #7 从 trait 来组成 trait

<?php
trait Hello {
    public function sayHello() {
        echo 'Hello ';
    }
}

trait World {
    public function sayWorld() {
        echo 'World!';
    }
}

trait HelloWorld {
    use Hello, World;
}

class MyHelloWorld {
    use HelloWorld;
}

$o = new MyHelloWorld();
$o->sayHello();
$o->sayWorld();
?>

以上例程会输出：

Hello World!

Trait 的抽象成员

为了对使用的类施加强制要求，trait 支持抽象方法的使用。

Caution

一个可继承实体类，可以通过定义同名非抽象方法来满足要求；方法的签名可以不同。

Example #8 表示通过抽象方法来进行强制要求

<?php
trait Hello {
    public function sayHelloWorld() {
        echo 'Hello'.$this->getWorld();
    }
    abstract public function getWorld();
}

class MyHelloWorld {
    private $world;
    use Hello;
    public function getWorld() {
        return $this->world;
    }
    public function setWorld($val) {
        $this->world = $val;
    }
}
?>

Trait 的静态成员

Traits 可以被静态成员静态方法定义。

Example #9 静态变量

<?php
trait Counter {
    public function inc() {
        static $c = 0;
        $c = $c + 1;
        echo "$c\n";
    }
}

class C1 {
    use Counter;
}

class C2 {
    use Counter;
}

$o = new C1(); $o->inc(); // echo 1
$p = new C2(); $p->inc(); // echo 1
?>

Example #10 静态方法

<?php
trait StaticExample {
    public static function doSomething() {
        return 'Doing something';
    }
}

class Example {
    use StaticExample;
}

Example::doSomething();
?>

属性

Trait 同样可以定义属性。

Example #11 定义属性

<?php
trait PropertiesTrait {
    public $x = 1;
}

class PropertiesExample {
    use PropertiesTrait;
}

$example = new PropertiesExample;
$example->x;
?>

Trait 定义了一个属性后，类就不能定义同样名称的属性，否则会产生 fatal error。 有种情况例外：属性是兼容的（同样的访问可见度、初始默认值）。 在 PHP 7.0 之前，属性是兼容的，则会有 E_STRICT 的提醒。

Example #12 解决冲突

<?php
trait PropertiesTrait {
    public $same = true;
    public $different = false;
}

class PropertiesExample {
    use PropertiesTrait;
    public $same = true; // PHP 7.0.0 后没问题，之前版本是 E_STRICT 提醒
    public $different = true; // 致命错误
}
?>


匿名类

PHP 7 开始支持匿名类。 匿名类很有用，可以创建一次性的简单对象。

<?php

// PHP 7 之前的代码
class Logger
{
    public function log($msg)
    {
        echo $msg;
    }
}

$util->setLogger(new Logger());

// 使用了 PHP 7+ 后的代码
$util->setLogger(new class {
    public function log($msg)
    {
        echo $msg;
    }
});

可以传递参数到匿名类的构造器，也可以扩展（extend）其他类、实现接口（implement interface），以及像其他普通的类一样使用 trait：

<?php

class SomeClass {}
interface SomeInterface {}
trait SomeTrait {}

var_dump(new class(10) extends SomeClass implements SomeInterface {
    private $num;

    public function __construct($num)
    {
        $this->num = $num;
    }

    use SomeTrait;
});

以上例程会输出：

object(class@anonymous)#1 (1) {
  ["Command line code0x104c5b612":"class@anonymous":private]=>
  int(10)
}

匿名类被嵌套进普通 Class 后，不能访问这个外部类（Outer class）的 private（私有）、protected（受保护）方法或者属性。 为了访问外部类（Outer class）protected 属性或方法，匿名类可以 extend（扩展）此外部类。 为了使用外部类（Outer class）的 private 属性，必须通过构造器传进来：

<?php

class Outer
{
    private $prop = 1;
    protected $prop2 = 2;

    protected function func1()
    {
        return 3;
    }

    public function func2()
    {
        return new class($this->prop) extends Outer {
            private $prop3;

            public function __construct($prop)
            {
                $this->prop3 = $prop;
            }

            public function func3()
            {
                return $this->prop2 + $this->prop3 + $this->func1();
            }
        };
    }
}

echo (new Outer)->func2()->func3();

以上例程会输出：

6

声明的同一个匿名类，所创建的对象都是这个类的实例。

<?php
function anonymous_class()
{
    return new class {};
}

if (get_class(anonymous_class()) === get_class(anonymous_class())) {
    echo 'same class';
} else {
    echo 'different class';
}

以上例程会输出：

same class

Note:

注意，匿名类的名称是通过引擎赋予的，如下例所示。 由于实现的细节，不应该去依赖这个类名。

<?php
echo get_class(new class {});

以上例程的输出类似于：

class@anonymous/in/oNi1A0x7f8636ad2021


重载

PHP所提供的重载（overloading）是指动态地创建类属性和方法。我们是通过魔术方法（magic methods）来实现的。

当调用当前环境下未定义或不可见的类属性或方法时，重载方法会被调用。本节后面将使用不可访问属性（inaccessible properties）和不可访问方法（inaccessible methods）来称呼这些未定义或不可见的类属性或方法。

所有的重载方法都必须被声明为 public。

Note:

这些魔术方法的参数都不能通过引用传递。

Note:

PHP中的重载与其它绝大多数面向对象语言不同。传统的重载是用于提供多个同名的类方法，但各方法的参数类型和个数不同。

更新日志

版本 | 说明
5.3.0 | 新增 __callStatic()魔术方法。可见性未设置为 public 或未声明为 static 的时候会产生一个警告。
5.1.0 | 新增 __isset() 和 __unset() 两个魔术方法。

属性重载

public __set ( string $name , mixed $value ) : void
public __get ( string $name ) : mixed
public __isset ( string $name ) : bool
public __unset ( string $name ) : void

在给不可访问属性赋值时，__set() 会被调用。

读取不可访问属性的值时，__get() 会被调用。

当对不可访问属性调用 isset() 或 empty() 时，__isset() 会被调用。

当对不可访问属性调用 unset() 时，__unset() 会被调用。

参数 $name 是指要操作的变量名称。__set() 方法的 $value 参数指定了 $name 变量的值。

属性重载只能在对象中进行。在静态方法中，这些魔术方法将不会被调用。所以这些方法都不能被 声明为 static。从 PHP 5.3.0 起, 将这些魔术方法定义为 static 会产生一个警告。

Note:

因为 PHP 处理赋值运算的方式，__set() 的返回值将被忽略。类似的, 在下面这样的链式赋值中，__get() 不会被调用：

 $a = $obj->b = 8;

Note:

在除 isset() 外的其它语言结构中无法使用重载的属性，这意味着当对一个重载的属性使用 empty() 时，重载魔术方法将不会被调用。

为避开此限制，必须将重载属性赋值到本地变量再使用 empty()。

Example #1 使用 __get()，__set()，__isset() 和 __unset() 进行属性重载

<?php
class PropertyTest {
     /**  被重载的数据保存在此  */
    private $data = array();

     /**  重载不能被用在已经定义的属性  */
    public $declared = 1;

     /**  只有从类外部访问这个属性时，重载才会发生 */
    private $hidden = 2;

    public function __set($name, $value)
    {
        echo "Setting '$name' to '$value'\n";
        $this->data[$name] = $value;
    }

    public function __get($name)
    {
        echo "Getting '$name'\n";
        if (array_key_exists($name, $this->data)) {
            return $this->data[$name];
        }

        $trace = debug_backtrace();
        trigger_error(
            'Undefined property via __get(): ' . $name .
            ' in ' . $trace[0]['file'] .
            ' on line ' . $trace[0]['line'],
            E_USER_NOTICE);
        return null;
    }

    /**  PHP 5.1.0之后版本 */
    public function __isset($name)
    {
        echo "Is '$name' set?\n";
        return isset($this->data[$name]);
    }

    /**  PHP 5.1.0之后版本 */
    public function __unset($name)
    {
        echo "Unsetting '$name'\n";
        unset($this->data[$name]);
    }

    /**  非魔术方法  */
    public function getHidden()
    {
        return $this->hidden;
    }
}

echo "<pre>\n";

$obj = new PropertyTest;

$obj->a = 1;
echo $obj->a . "\n\n";

var_dump(isset($obj->a));
unset($obj->a);
var_dump(isset($obj->a));
echo "\n";

echo $obj->declared . "\n\n";

echo "Let's experiment with the private property named 'hidden':\n";
echo "Privates are visible inside the class, so __get() not used...\n";
echo $obj->getHidden() . "\n";
echo "Privates not visible outside of class, so __get() is used...\n";
echo $obj->hidden . "\n";
?>

以上例程会输出：

Setting 'a' to '1'
Getting 'a'
1

Is 'a' set?
bool(true)
Unsetting 'a'
Is 'a' set?
bool(false)

1

Let's experiment with the private property named 'hidden':
Privates are visible inside the class, so __get() not used...
2
Privates not visible outside of class, so __get() is used...
Getting 'hidden'

Notice:  Undefined property via __get(): hidden in <file> on line 70 in <file> on line 29

方法重载

public __call ( string $name , array $arguments ) : mixed
public static __callStatic ( string $name , array $arguments ) : mixed

在对象中调用一个不可访问方法时，__call() 会被调用。

在静态上下文中调用一个不可访问方法时，__callStatic() 会被调用。

$name 参数是要调用的方法名称。$arguments 参数是一个枚举数组，包含着要传递给方法 $name 的参数。

Example #2 使用 __call() 和 __callStatic() 对方法重载

<?php
class MethodTest
{
    public function __call($name, $arguments)
    {
        // 注意: $name 的值区分大小写
        echo "Calling object method '$name' "
             . implode(', ', $arguments). "\n";
    }

    /**  PHP 5.3.0之后版本  */
    public static function __callStatic($name, $arguments)
    {
        // 注意: $name 的值区分大小写
        echo "Calling static method '$name' "
             . implode(', ', $arguments). "\n";
    }
}

$obj = new MethodTest;
$obj->runTest('in object context');

MethodTest::runTest('in static context');  // PHP 5.3.0之后版本
?>

以上例程会输出：

Calling object method 'runTest' in object context
Calling static method 'runTest' in static context


遍历对象

PHP 5 提供了一种定义对象的方法使其可以通过单元列表来遍历，例如用 foreach 语句。默认情况下，所有可见属性都将被用于遍历。

Example #1 简单的对象遍历

<?php
class MyClass
{
    public $var1 = 'value 1';
    public $var2 = 'value 2';
    public $var3 = 'value 3';

    protected $protected = 'protected var';
    private   $private   = 'private var';

    function iterateVisible() {
       echo "MyClass::iterateVisible:\n";
       foreach($this as $key => $value) {
           print "$key => $value\n";
       }
    }
}

$class = new MyClass();

foreach($class as $key => $value) {
    print "$key => $value\n";
}
echo "\n";

$class->iterateVisible();

?>

以上例程会输出：

var1 => value 1
var2 => value 2
var3 => value 3

MyClass::iterateVisible:
var1 => value 1
var2 => value 2
var3 => value 3
protected => protected var
private => private var

如上所示，foreach 遍历了所有其能够访问的可见属性。

更进一步，可以实现 Iterator 接口。可以让对象自行决定如何遍历以及每次遍历时那些值可用。

Example #2 实现 Iterator 接口的对象遍历

<?php
class MyIterator implements Iterator
{
    private $var = array();

    public function __construct($array)
    {
        if (is_array($array)) {
            $this->var = $array;
        }
    }

    public function rewind() {
        echo "rewinding\n";
        reset($this->var);
    }

    public function current() {
        $var = current($this->var);
        echo "current: $var\n";
        return $var;
    }

    public function key() {
        $var = key($this->var);
        echo "key: $var\n";
        return $var;
    }

    public function next() {
        $var = next($this->var);
        echo "next: $var\n";
        return $var;
    }

    public function valid() {
        $var = $this->current() !== false;
        echo "valid: {$var}\n";
        return $var;
    }
}

$values = array(1,2,3);
$it = new MyIterator($values);

foreach ($it as $a => $b) {
    print "$a: $b\n";
}
?>

以上例程会输出：

rewinding
current: 1
valid: 1
current: 1
key: 0
0: 1
next: 2
current: 2
valid: 1
current: 2
key: 1
1: 2
next: 3
current: 3
valid: 1
current: 3
key: 2
2: 3
next:
current:
valid:

可以用 IteratorAggregate 接口以替代实现所有的 Iterator 方法。IteratorAggregate 只需要实现一个方法 IteratorAggregate::getIterator()，其应返回一个实现了 Iterator 的类的实例。

Example #3 通过实现 IteratorAggregate 来遍历对象

<?php
class MyCollection implements IteratorAggregate
{
    private $items = array();
    private $count = 0;

    // Required definition of interface IteratorAggregate
    public function getIterator() {
        return new MyIterator($this->items);
    }

    public function add($value) {
        $this->items[$this->count++] = $value;
    }
}

$coll = new MyCollection();
$coll->add('value 1');
$coll->add('value 2');
$coll->add('value 3');

foreach ($coll as $key => $val) {
    echo "key/value: [$key -> $val]\n\n";
}
?>

以上例程会输出：

rewinding
current: value 1
valid: 1
current: value 1
key: 0
key/value: [0 -> value 1]

next: value 2
current: value 2
valid: 1
current: value 2
key: 1
key/value: [1 -> value 2]

next: value 3
current: value 3
valid: 1
current: value 3
key: 2
key/value: [2 -> value 3]

next:
current:
valid:

Note:

更多遍历的示例见 SPL 扩展。

Note:

PHP 5.5 及以后版本的用户也可参考生成器，其提供了另一方法来定义 Iterators。


魔术方法

__construct()，
__destruct()，
__call()，
__callStatic()，
__get()，
__set()，
__isset()，
__unset()，
__sleep()，
__wakeup()，
__serialize(),
__unserialize(),
__toString()，
__invoke()，
__set_state()，
__clone() 和
__debugInfo()
等方法在 PHP 中被称为魔术方法（Magic
methods）。在命名自己的类方法时不能使用这些方法名，除非是想使用其魔术功能。

Note: 所有的魔术方法 必须 声明为 public

Caution

PHP 将所有以 __（两个下划线）开头的类方法保留为魔术方法。所以在定义类方法时，除了上述魔术方法，建议不要以 __ 为前缀。

__sleep() 和 __wakeup()

public __sleep ( ) : array
public __wakeup ( ) : void

serialize() 函数会检查类中是否存在一个魔术方法 __sleep()。如果存在，该方法会先被调用，然后才执行序列化操作。此功能可以用于清理对象，并返回一个包含对象中所有应被序列化的变量名称的数组。如果该方法未返回任何内容，则 null 被序列化，并产生一个 E_NOTICE 级别的错误。

Note:

__sleep() 不能返回父类的私有成员的名字。这样做会产生一个 E_NOTICE 级别的错误。可以用 Serializable 接口来替代。

__sleep() 方法常用于提交未提交的数据，或类似的清理操作。同时，如果有一些很大的对象，但不需要全部保存，这个功能就很好用。

与之相反，unserialize() 会检查是否存在一个 __wakeup() 方法。如果存在，则会先调用 __wakeup 方法，预先准备对象需要的资源。

__wakeup() 经常用在反序列化操作中，例如重新建立数据库连接，或执行其它初始化操作。

Example #1 Sleep 和 wakeup

<?php
class Connection
{
    protected $link;
    private $server, $username, $password, $db;

    public function __construct($server, $username, $password, $db)
    {
        $this->server = $server;
        $this->username = $username;
        $this->password = $password;
        $this->db = $db;
        $this->connect();
    }

    private function connect()
    {
        $this->link = mysql_connect($this->server, $this->username, $this->password);
        mysql_select_db($this->db, $this->link);
    }

    public function __sleep()
    {
        return array('server', 'username', 'password', 'db');
    }

    public function __wakeup()
    {
        $this->connect();
    }
}
?>

__serialize() 和 __unserialize()

public __serialize ( ) : array
public __unserialize ( array $data ) : void

serialize() 函数会检查类中是否存在一个魔术方法 __serialize()。如果存在，该方法将在任何序列化之前优先执行。它必须以一个代表对象序列化形式的 键/值 成对的关联数组形式来返回，如果没有返回数组，将会抛出一个 TypeError 错误。

Note:

如果类中同时定义了 __serialize() 和 __sleep()
两个魔术方法，则只有 __serialize() 方法会被调用。
__sleep() 方法会被忽略掉。如果对象实现了 Serializable
接口，接口的 serialize() 方法会被忽略，做为代替类中的 __serialize() 方法会被调用。

The intended use of __serialize() is to define a serialization-friendly arbitrary representation of the object. Elements of the array may correspond to properties of the object but that is not required.

Conversely, unserialize() checks for the presence of a function with the magic name __unserialize(). If present, this function will be passed the restored array that was returned from __serialize(). It may then restore the properties of the object from that array as appropriate.

Note:

如果类中同时定义了 __unserialize() 和 __wakeup() 两个魔术方法，则只有 __unserialize() 方法会生效，__wakeup() 方法会被忽略。

Note:

此特性自 PHP 7.4.0 起可用。

Example #2 序列化和反序列化

<?php
class Connection
{
    protected $link;
    private $dsn, $username, $password;

    public function __construct($dsn, $username, $password)
    {
        $this->dsn = $dsn;
        $this->username = $username;
        $this->password = $password;
        $this->connect();
    }

    private function connect()
    {
        $this->link = new PDO($this->dsn, $this->username, $this->password);
    }

    public function __serialize(): array
    {
        return [
          'dsn' => $this->dsn,
          'user' => $this->username,
          'pass' => $this->password,
        ];
    }

    public function __unserialize(array $data): void
    {
        $this->dsn = $data['dsn'];
        $this->username = $data['user'];
        $this->password = $data['pass'];

        $this->connect();
    }
}?>

__toString()

public __toString ( ) : string

__toString() 方法用于一个类被当成字符串时应怎样回应。例如 echo $obj; 应该显示些什么。此方法必须返回一个字符串，否则将发出一条 E_RECOVERABLE_ERROR 级别的致命错误。

Warning

不能在 __toString() 方法中抛出异常。这么做会导致致命错误。

Example #3 简单示例

<?php
// Declare a simple class
class TestClass
{
    public $foo;

    public function __construct($foo)
    {
        $this->foo = $foo;
    }

    public function __toString() {
        return $this->foo;
    }
}

$class = new TestClass('Hello');
echo $class;
?>

以上例程会输出：

Hello

需要指出的是在 PHP 5.2.0 之前，__toString() 方法只有在直接使用于 echo 或 print 时才能生效。PHP 5.2.0 之后，则可以在任何字符串环境生效（例如通过 printf()，使用 %s 修饰符），但不能用于非字符串环境（如使用 %d 修饰符）。自 PHP 5.2.0 起，如果将一个未定义 __toString() 方法的对象转换为字符串，会产生 E_RECOVERABLE_ERROR 级别的错误。

__invoke()

__invoke ( $... = ? ) : mixed

当尝试以调用函数的方式调用一个对象时，__invoke() 方法会被自动调用。

Note:

本特性只在 PHP 5.3.0 及以上版本有效。

Example #4 使用 __invoke()

<?php
class CallableClass
{
    function __invoke($x) {
        var_dump($x);
    }
}
$obj = new CallableClass;
$obj(5);
var_dump(is_callable($obj));
?>

以上例程会输出：

int(5)
bool(true)

__set_state()

static __set_state ( array $properties ) : object

自 PHP 5.1.0 起当调用 var_export() 导出类时，此静态 方法会被调用。

本方法的唯一参数是一个数组，其中包含按 array('property' => value, ...) 格式排列的类属性。

Example #5 使用 __set_state()>（PHP 5.1.0 起）

<?php

class A
{
    public $var1;
    public $var2;

    public static function __set_state($an_array) // As of PHP 5.1.0
    {
        $obj = new A;
        $obj->var1 = $an_array['var1'];
        $obj->var2 = $an_array['var2'];
        return $obj;
    }
}

$a = new A;
$a->var1 = 5;
$a->var2 = 'foo';

eval('$b = ' . var_export($a, true) . ';'); // $b = A::__set_state(array(
                                            //    'var1' => 5,
                                            //    'var2' => 'foo',
                                            // ));
var_dump($b);

?>

以上例程会输出：

object(A)#2 (2) {
  ["var1"]=>
  int(5)
  ["var2"]=>
  string(3) "foo"
}

__debugInfo()

__debugInfo ( ) : array

This method is called by var_dump() when dumping an object to get the properties that should be shown. If the method isn't defined on an object, then all public, protected and private properties will be shown.

This feature was added in PHP 5.6.0.

Example #6 Using __debugInfo()

<?php
class C {
    private $prop;

    public function __construct($val) {
        $this->prop = $val;
    }

    public function __debugInfo() {
        return [
            'propSquared' => $this->prop ** 2,
        ];
    }
}

var_dump(new C(42));
?>

以上例程会输出：

object(C)#1 (1) {
  ["propSquared"]=>
  int(1764)
}


Final 关键字

PHP 5 新增了一个 final 关键字。如果父类中的方法被声明为 final，则子类无法覆盖该方法。如果一个类被声明为 final，则不能被继承。

Example #1 Final 方法示例

<?php
class BaseClass {
   public function test() {
       echo "BaseClass::test() called\n";
   }

   final public function moreTesting() {
       echo "BaseClass::moreTesting() called\n";
   }
}

class ChildClass extends BaseClass {
   public function moreTesting() {
       echo "ChildClass::moreTesting() called\n";
   }
}
// Results in Fatal error: Cannot override final method BaseClass::moreTesting()
?>

Example #2 Final 类示例

<?php
final class BaseClass {
   public function test() {
       echo "BaseClass::test() called\n";
   }

   // 这里无论你是否将方法声明为final，都没有关系
   final public function moreTesting() {
       echo "BaseClass::moreTesting() called\n";
   }
}

class ChildClass extends BaseClass {
}
// 产生 Fatal error: Class ChildClass may not inherit from final class (BaseClass)
?>

Note: 属性不能被定义为 final，只有类和方法才能被定义为 final。


对象复制

在多数情况下，我们并不需要完全复制一个对象来获得其中属性。但有一个情况下确实需要：如果你有一个 GTK 窗口对象，该对象持有窗口相关的资源。你可能会想复制一个新的窗口，保持所有属性与原来的窗口相同，但必须是一个新的对象（因为如果不是新的对象，那么一个窗口中的改变就会影响到另一个窗口）。还有一种情况：如果对象 A 中保存着对象 B 的引用，当你复制对象 A 时，你想其中使用的对象不再是对象 B 而是 B 的一个副本，那么你必须得到对象 A 的一个副本。

对象复制可以通过 clone 关键字来完成（如果可能，这将调用对象的 __clone() 方法）。对象中的 __clone() 方法不能被直接调用。

$copy_of_object = clone $object;

当对象被复制后，PHP 5 会对对象的所有属性执行一个浅复制（shallow copy）。所有的引用属性 仍然会是一个指向原来的变量的引用。

__clone ( ) : void

当复制完成时，如果定义了 __clone() 方法，则新创建的对象（复制生成的对象）中的 __clone() 方法会被调用，可用于修改属性的值（如果有必要的话）。

Example #1 复制一个对象

<?php
class SubObject
{
    static $instances = 0;
    public $instance;

    public function __construct() {
        $this->instance = ++self::$instances;
    }

    public function __clone() {
        $this->instance = ++self::$instances;
    }
}

class MyCloneable
{
    public $object1;
    public $object2;

    function __clone()
    {

        // 强制复制一份this->object， 否则仍然指向同一个对象
        $this->object1 = clone $this->object1;
    }
}

$obj = new MyCloneable();

$obj->object1 = new SubObject();
$obj->object2 = new SubObject();

$obj2 = clone $obj;

print("Original Object:\n");
print_r($obj);

print("Cloned Object:\n");
print_r($obj2);

?>

以上例程会输出：

Original Object:
MyCloneable Object
(
    [object1] => SubObject Object
        (
            [instance] => 1
        )

    [object2] => SubObject Object
        (
            [instance] => 2
        )

)
Cloned Object:
MyCloneable Object
(
    [object1] => SubObject Object
        (
            [instance] => 3
        )

    [object2] => SubObject Object
        (
            [instance] => 2
        )

)


对象比较

PHP 5 中的对象比较要比 PHP 4 中复杂，所期望的结果更符合一个面向对象语言。

当使用比较运算符（==）比较两个对象变量时，比较的原则是：如果两个对象的属性和属性值 都相等，而且两个对象是同一个类的实例，那么这两个对象变量相等。

而如果使用全等运算符（===），这两个对象变量一定要指向某个类的同一个实例（即同一个对象）。

通过下面的示例可以理解以上原则。

Example #1 PHP 5 的对象比较

<?php
function bool2str($bool)
{
    if ($bool === false) {
        return 'FALSE';
    } else {
        return 'TRUE';
    }
}

function compareObjects(&$o1, &$o2)
{
    echo 'o1 == o2 : ' . bool2str($o1 == $o2) . "\n";
    echo 'o1 != o2 : ' . bool2str($o1 != $o2) . "\n";
    echo 'o1 === o2 : ' . bool2str($o1 === $o2) . "\n";
    echo 'o1 !== o2 : ' . bool2str($o1 !== $o2) . "\n";
}

class Flag
{
    public $flag;

    function Flag($flag = true) {
        $this->flag = $flag;
    }
}

class OtherFlag
{
    public $flag;

    function OtherFlag($flag = true) {
        $this->flag = $flag;
    }
}

$o = new Flag();
$p = new Flag();
$q = $o;
$r = new OtherFlag();

echo "Two instances of the same class\n";
compareObjects($o, $p);

echo "\nTwo references to the same instance\n";
compareObjects($o, $q);

echo "\nInstances of two different classes\n";
compareObjects($o, $r);
?>

以上例程会输出：

Two instances of the same class
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Two references to the same instance
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : TRUE
o1 !== o2 : FALSE

Instances of two different classes
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Note:

PHP 扩展中可以自行定义对象比较的原则。


后期静态绑定

自 PHP 5.3.0 起，PHP 增加了一个叫做后期静态绑定的功能，用于在继承范围内引用静态调用的类。

准确说，后期静态绑定工作原理是存储了在上一个"非转发调用"（non-forwarding call）的类名。当进行静态方法调用时，该类名即为明确指定的那个（通常在 :: 运算符左侧部分）；当进行非静态方法调用时，即为该对象所属的类。所谓的"转发调用"（forwarding call）指的是通过以下几种方式进行的静态调用：self::，parent::，static:: 以及 forward_static_call()。可用 get_called_class() 函数来得到被调用的方法所在的类名，static:: 则指出了其范围。

该功能从语言内部角度考虑被命名为"后期静态绑定"。"后期绑定"的意思是说，static:: 不再被解析为定义当前方法所在的类，而是在实际运行时计算的。也可以称之为"静态绑定"，因为它可以用于（但不限于）静态方法的调用。

self:: 的限制

使用 self:: 或者 __CLASS__ 对当前类的静态引用，取决于定义当前方法所在的类：

Example #1 self:: 用法

<?php
class A {
    public static function who() {
        echo __CLASS__;
    }
    public static function test() {
        self::who();
    }
}

class B extends A {
    public static function who() {
        echo __CLASS__;
    }
}

B::test();
?>

以上例程会输出：

A

后期静态绑定的用法

后期静态绑定本想通过引入一个新的关键字表示运行时最初调用的类来绕过限制。简单地说，这个关键字能够让你在上述例子中调用 test() 时引用的类是 B 而不是 A。最终决定不引入新的关键字，而是使用已经预留的 static 关键字。

Example #2 static:: 简单用法

<?php
class A {
    public static function who() {
        echo __CLASS__;
    }
    public static function test() {
        static::who(); // 后期静态绑定从这里开始
    }
}

class B extends A {
    public static function who() {
        echo __CLASS__;
    }
}

B::test();
?>

以上例程会输出：

B

Note:

在非静态环境下，所调用的类即为该对象实例所属的类。由于 $this-> 会在同一作用范围内尝试调用私有方法，而 static:: 则可能给出不同结果。另一个区别是 static:: 只能用于静态属性。

Example #3 非静态环境下使用 static::

<?php
class A {
    private function foo() {
        echo "success!\n";
    }
    public function test() {
        $this->foo();
        static::foo();
    }
}

class B extends A {
   /* foo() will be copied to B, hence its scope will still be A and
    * the call be successful */
}

class C extends A {
    private function foo() {
        /* original method is replaced; the scope of the new one is C */
    }
}

$b = new B();
$b->test();
$c = new C();
$c->test();   //fails
?>

以上例程会输出：

success!
success!
success!

Fatal error:  Call to private method C::foo() from context 'A' in /tmp/test.php on line 9

Note:

后期静态绑定的解析会一直到取得一个完全解析了的静态调用为止。另一方面，如果静态调用使用 parent:: 或者 self:: 将转发调用信息。

Example #4 转发和非转发调用

<?php
class A {
    public static function foo() {
        static::who();
    }

    public static function who() {
        echo __CLASS__."\n";
    }
}

class B extends A {
    public static function test() {
        A::foo();
        parent::foo();
        self::foo();
    }

    public static function who() {
        echo __CLASS__."\n";
    }
}
class C extends B {
    public static function who() {
        echo __CLASS__."\n";
    }
}

C::test();
?>

以上例程会输出：

A
C
C


对象和引用

在php5 的对象编程经常提到的一个关键点是"默认情况下对象是通过引用传递的"。但其实这不是完全正确的。下面通过一些例子来说明。

PHP 的引用是别名，就是两个不同的变量名字指向相同的内容。在 PHP 5，一个对象变量已经不再保存整个对象的值。只是保存一个标识符来访问真正的对象内容。 当对象作为参数传递，作为结果返回，或者赋值给另外一个变量，另外一个变量跟原来的不是引用的关系，只是他们都保存着同一个标识符的拷贝，这个标识符指向同一个对象的真正内容。

Example #1 引用和对象

<?php
class A {
    public $foo = 1;
}

$a = new A;
$b = $a;     // $a ,$b都是同一个标识符的拷贝
             // ($a) = ($b) = <id>
$b->foo = 2;
echo $a->foo."\n";

$c = new A;
$d = &$c;    // $c ,$d是引用
             // ($c,$d) = <id>

$d->foo = 2;
echo $c->foo."\n";

$e = new A;

function foo($obj) {
    // ($obj) = ($e) = <id>
    $obj->foo = 2;
}

foo($e);
echo $e->foo."\n";

?>

以上例程会输出：

2
2
2


对象序列化

序列化对象 - 在会话中存放对象

所有php里面的值都可以使用函数serialize()来返回一个包含字节流的字符串来表示。unserialize()函数能够重新把字符串变回php原来的值。 序列化一个对象将会保存对象的所有变量，但是不会保存对象的方法，只会保存类的名字。

为了能够unserialize()一个对象，这个对象的类必须已经定义过。如果序列化类A的一个对象，将会返回一个跟类A相关，而且包含了对象所有变量值的字符串。 如果要想在另外一个文件中反序列化一个对象，这个对象的类必须在反序列化之前定义，可以通过包含一个定义该类的文件或使用函数spl_autoload_register()来实现。

<?php
// classa.inc:

  class A {
      public $one = 1;

      public function show_one() {
          echo $this->one;
      }
  }

// page1.php:

  include("classa.inc");

  $a = new A;
  $s = serialize($a);
  // 把变量$s保存起来以便文件page2.php能够读到
  file_put_contents('store', $s);

// page2.php:

  // 要正确反序列化，必须包含下面一个文件
  include("classa.inc");

  $s = file_get_contents('store');
  $a = unserialize($s);

  // 现在可以使用对象$a里面的函数 show_one()
  $a->show_one();
?>

当一个应用程序使用函数session_register()来保存对象到会话中时，在每个页面结束的时候这些对象都会自动序列化，而在每个页面开始的时候又自动反序列化。 所以一旦对象被保存在会话中，整个应用程序的页面都能使用这些对象。但是，session_register()在php5.4.0之后被移除了。

在应用程序中序列化对象以便在之后使用，强烈推荐在整个应用程序都包含对象的类的定义。 不然有可能出现在反序列化对象的时候，没有找到该对象的类的定义，从而把没有方法的类__PHP_Incomplete_Class_Name作为该对象的类，导致返回一个没有用的对象。

所以在上面的例子中，当运行session_register("a")，把变量$a放在会话里之后，需要在每个页面都包含文件classa.inc，而不是只有文件page1.php和page2.php。

除了以上建议，可以在对象上使用 __sleep() 和 __wakeup() 方法对序列化/反序列化事件挂载钩子。 使用 __sleep() 也能够让你仅序列化对象的某些属性。


协变与逆变

在 PHP 7.2.0 里，通过对子类方法里参数的类型放宽限制，实现对逆变的部分支持。 自 PHP 7.4.0 起开始支持完整的协变和逆变。

协变使子类比父类方法能返回更具体的类型； 逆变使子类比父类方法参数类型能接受更模糊的类型。

协变

创建一个名为 Animal 的简单的抽象父类，用于演示什么是协变。 两个子类：Cat 和 Dog 扩展（extended）了 Animal。

<?php

abstract class Animal
{
    protected string $name;

    public function __construct(string $name)
    {
        $this->name = $name;
    }

    abstract public function speak();
}

class Dog extends Animal
{
    public function speak()
    {
        echo $this->name . " barks";
    }
}

class Cat extends Animal
{
    public function speak()
    {
        echo $this->name . " meows";
    }
}

注意：在这个例子中，没有方法返回了值。 将通过添加个别工厂方法，创建并返回 Animal、Cat、Dog 类型的新对象。

<?php

interface AnimalShelter
{
    public function adopt(string $name): Animal;
}

class CatShelter implements AnimalShelter
{
    public function adopt(string $name): Cat // 返回类的类型不仅限于 Animal，还可以是 Cat 类型
    {
        return new Cat($name);
    }
}

class DogShelter implements AnimalShelter
{
    public function adopt(string $name): Dog // 返回类的类型不仅限于 Animal，还可以是 Dog 类型
    {
        return new Dog($name);
    }
}

$kitty = (new CatShelter)->adopt("Ricky");
$kitty->speak();
echo "\n";

$doggy = (new DogShelter)->adopt("Mavrick");
$doggy->speak();

以上例程会输出：

Ricky meows
Mavrick barks

逆变

继续上一个例子，除了 Animal、 Cat、Dog，我们还添加了 Food、AnimalFood 类， 同时为抽象类 Animal 添加了一个 eat(AnimalFood $food) 方法。

<?php

class Food {}

class AnimalFood extends Food {}

abstract class Animal
{
    protected string $name;

    public function __construct(string $name)
    {
        $this->name = $name;
    }

    public function eat(AnimalFood $food)
    {
        echo $this->name . " eats " . get_class($food);
    }
}

为了演示什么是逆变，Dog 类重写（overridden）了 eat 方法， 允许传入任意 Food 类型的对象。 而 Cat 类保持不变。

<?php

class Dog extends Animal
{
    public function eat(Food $food) {
        echo $this->name . " eats " . get_class($food);
    }
}

下面的例子展示了逆变。

<?php

$kitty = (new CatShelter)->adopt("Ricky");
$catFood = new AnimalFood();
$kitty->eat($catFood);
echo "\n";

$doggy = (new DogShelter)->adopt("Mavrick");
$banana = new Food();
$doggy->eat($banana);

以上例程会输出：

Ricky eats AnimalFood
Mavrick eats Food

但 $kitty 若尝试 eat $banana 会发生什么呢？

$kitty->eat($banana);

以上例程会输出：

Fatal error: Uncaught TypeError: Argument 1 passed to Animal::eat() must be an instance of AnimalFood, instance of Food given


OOP 变更日志

这里只记录了 PHP OOP 模型的变更记录。有关变更功能的具体描述与其他相关注意事项，可以到具体的 OOP 文档链接中查看。

版本 | 说明
7.4.0 | 已变更：可以通过 __toString() 抛出异常。
7.4.0 | 增加：Support for limited return type covariance and argument type contravariance. Full variance support is only available if autoloading is used. Inside a single file only non-cyclic type references are possible.
7.4.0 | 增加：可以给类属性增加类型。
7.3.0 | 不兼容：Argument unpacking of Traversables with non-int keys is no longer supported. This behaviour was not intended and thus has been removed.
7.3.0 | 不兼容：在以前的版本中，可以通过分配一个引用来分离静态属性，这一特性已被移除。
7.3.0 | 已变更：The instanceof operator now allows literals as the first operand, in which case the result is always false.
7.2.0 | 废弃：__autoload() 方法已被废弃，请使用 spl_autoload_register() 代替。
7.2.0 | 已变更：object 做为保留关键字，不允许做为 classes、interfaces、traits 的名称。
7.2.0 | 已变更：分组引入命名空间时，允许行尾添加多余的逗号分隔符。
7.2.0 | 已变更：Parameter type widening. Parameter types from overridden methods and from interface implementations may now be omitted.
7.2.0 | 已变更：当一个抽象类（abstract class）继承另一个抽象类时，抽象的方法现在可以被覆写。
7.1.0 | 已变更：增加系统保留关键字 void 和 iterable，不允许做为 classes、interfaces、traits 的名称。
7.1.0 | 增加：类常量增加了 访问控制（可见性）。
7.0.0 | 废弃：对未声明为静态的方法（Static）的静态调用。
7.0.0 | 废弃：PHP 4 风格的构造函数 constructor 已被废弃。
7.0.0 | 增加：Group use declaration: classes, functions and constants being imported from the same namespace can now be grouped together in a single use statement.
7.0.0 | 增加：使用 new class 语法来支持 匿名类。
7.0.0 | 不兼容：Iterating over a non-Traversable object will now have the same behaviour as iterating over by-reference arrays.
7.0.0 | 已变更：traits 里定义兼容的属性不再产生错误信息。
5.6.0 | 增加: __debugInfo() 方法。
5.5.0 | 增加: ::class 魔法常量。
5.5.0 | 增加: finally 来处理异常。
5.4.0 | 增加： traits。
5.4.0 | 已变更：如果一个抽象 类定义了 构造函数 的签名，它将必须被实现。
5.3.3 | 已变更： 命名空间 中和类同名的方法不再被作为 构造函数。这个变更不影响非命名空间中的类。
5.3.0 | 已变更：类实现接口的方法所具有的默认值不再需要和接口的默认值一致。
5.3.0 | 已变更： 现在它也能够通过一个变量来引用一个类（例如，echo $classname::constant;）。 这个变量的值不能是一个保留关键词（比如，self、parent 或 static）。
5.3.0 | 已变更： 如果重载方法被定义为 static 将导致一个 E_WARNING 级别的错误。 同时它也需要强制使用 public 的可见性。
5.3.0 | 已变更： 在 5.3.0 之前的版本，__autoload() 函数里抛出的异常不能被 catch 块结构捕获，并会导致一个致命错误。 现在在一个前提下 catch 块能够捕获 __autoload 函数中抛出的错误。如果抛出一个自定义异常，这个自定义异常的类必须是可用的。否则 __autoload 函数可能递归自动加载这个自定义异常类。
5.3.0 | 新增： __callStatic 方法。
5.3.0 | 新增： heredoc 和 nowdoc 支持类的 常量 和属性的定义。 注意：heredoc 值必须和双引号字符串遵循同样的规则（比如，变量将被替换）。
5.3.0 | 新增： 后期静态绑定。
5.3.0 | 新增： __invoke 方法。
5.2.0 | 已变更：__toString 方法仅在直接与 echo 或 print 使用时被调用。但是现在它能在任何字符串上下文被调用（比如在 printf() 中使用 %s ），但不是在其他类型的上下文被调用（例如 %d 修饰符）。 自 PHP 5.2.0 起，将不具有 __toString 方法的对象转化为字符串将导致一个 E_RECOVERABLE_ERROR 级别的错误。
5.1.3 | 已变更：在 PHP 5 之前的版本，var 的使用已被废弃，并将产生一个 E_STRICT 级别的错误。现在它不再被废弃，因此也不会产生错误。
5.1.0 | 已变更：现在 __set_state 静态方法在 var_export() 导出类时会被调用。
5.1.0 | 新增：__isset 和 __unset 方法。


命名空间

Table of Contents

  • 命名空间概述
  • 定义命名空间
  • 定义子命名空间
  • 在同一个文件中定义多个命名空间
  • 使用命名空间：基础
  • 命名空间和动态语言特征
  • namespace 关键字和 __NAMESPACE__ 常量
  • 使用命名空间：别名/导入
  • 全局空间
  • 使用命名空间：后备全局函数/常量
  • 名称解析规则
  • FAQ: things you need to know about namespaces


命名空间概述

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

什么是命名空间？从广义上来说，命名空间是一种封装事物的方法。在很多地方都可以见到这种抽象概念。例如，在操作系统中目录用来将相关文件分组，对于目录中的文件来说，它就扮演了命名空间的角色。具体举个例子，文件 foo.txt 可以同时在目录 /home/greg 和 /home/other 中存在，但在同一个目录中不能存在两个 foo.txt 文件。另外，在目录 /home/greg 外访问 foo.txt 文件时，我们必须将目录名以及目录分隔符放在文件名之前得到 /home/greg/foo.txt。这个原理应用到程序设计领域就是命名空间的概念。

在 PHP 中，命名空间用来解决在编写类库或应用程序时创建可重用的代码如类或函数时碰到的两类问题：

  1. 用户编写的代码与PHP内部的类/函数/常量或第三方类/函数/常量之间的名字冲突。
  2. 为很长的标识符名称(通常是为了缓解第一类问题而定义的)创建一个别名（或简短）的名称，提高源代码的可读性。

PHP 命名空间提供了一种将相关的类、函数和常量组合到一起的途径。下面是一个说明 PHP 命名空间语法的示例：

Example #1 命名空间语法示例

<?php
namespace my\name; // 参考 "定义命名空间" 小节

class MyClass {}
function myfunction() {}
const MYCONST = 1;

$a = new MyClass;
$c = new \my\name\MyClass; // 参考 "全局空间" 小节

$a = strlen('hi'); // 参考 "使用命名空间：后备全局函数/常量" 小节

$d = namespace\MYCONST; // 参考 "namespace操作符和__NAMESPACE__常量" 小节

$d = __NAMESPACE__ . '\MYCONST';
echo constant($d); // 参考 "命名空间和动态语言特征" 小节
?>

Note:

名为 PHP 或 php 的命名空间，以及以这些名字开头的命名空间（例如PHP\Classes）被保留用作语言内核使用，而不应该在用户空间的代码中使用。


定义命名空间

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

虽然任意合法的 PHP 代码都可以包含在命名空间中，但只有以下类型的代码受命名空间的影响，它们是：类（包括抽象类和 trait）、接口、函数和常量。

命名空间通过关键字 namespace 来声明。如果一个文件中包含命名空间，它必须在其它所有代码之前声明命名空间，除了一个以外：declare关键字。

Example #1 声明单个命名空间

<?php
namespace MyProject;

const CONNECT_OK = 1;
class Connection { /* ... */ }
function connect() { /* ... */  }

?>
在声明命名空间之前唯一合法的代码是用于定义源文件编码方式的 declare 语句。另外，所有非 PHP 代码包括空白符都不能出现在命名空间的声明之前：

Example #2 声明单个命名空间

<html>
<?php
namespace MyProject; // 致命错误 -　命名空间必须是程序脚本的第一条语句
?>

另外，与 PHP 其它的语言特征不同，同一个命名空间可以定义在多个文件中，即允许将同一个命名空间的内容分割存放在不同的文件中。


定义子命名空间

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

与目录和文件的关系很象，PHP 命名空间也允许指定层次化的命名空间的名称。因此，命名空间的名字可以使用分层次的方式定义：

Example #1 声明分层次的单个命名空间

<?php
namespace MyProject\Sub\Level;

const CONNECT_OK = 1;
class Connection { /* ... */ }
function connect() { /* ... */  }

?>
上面的例子创建了常量 MyProject\Sub\Level\CONNECT_OK，类 MyProject\Sub\Level\Connection 和函数 MyProject\Sub\Level\connect。


在同一个文件中定义多个命名空间

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

也可以在同一个文件中定义多个命名空间。在同一个文件中定义多个命名空间有两种语法形式。

Example #1 定义多个命名空间，简单组合语法

<?php
namespace MyProject;

const CONNECT_OK = 1;
class Connection { /* ... */ }
function connect() { /* ... */  }

namespace AnotherProject;

const CONNECT_OK = 1;
class Connection { /* ... */ }
function connect() { /* ... */  }
?>

不建议使用这种语法在单个文件中定义多个命名空间。建议使用下面的大括号形式的语法。

Example #2 定义多个命名空间，大括号语法

<?php
namespace MyProject {

const CONNECT_OK = 1;
class Connection { /* ... */ }
function connect() { /* ... */  }
}

namespace AnotherProject {

const CONNECT_OK = 1;
class Connection { /* ... */ }
function connect() { /* ... */  }
}
?>

在实际的编程实践中，非常不提倡在同一个文件中定义多个命名空间。这种方式的主要用于将多个 PHP 脚本合并在同一个文件中。

将全局的非命名空间中的代码与命名空间中的代码组合在一起，只能使用大括号形式的语法。全局代码必须用一个不带名称的 namespace 语句加上大括号括起来，例如：

Example #3 定义多个命名空间和不包含在命名空间中的代码

<?php
namespace MyProject {

const CONNECT_OK = 1;
class Connection { /* ... */ }
function connect() { /* ... */  }
}

namespace { // global code
session_start();
$a = MyProject\connect();
echo MyProject\Connection::start();
}
?>

除了开始的 declare 语句外，命名空间的括号外不得有任何 PHP 代码。

Example #4 定义多个命名空间和不包含在命名空间中的代码

<?php
declare(encoding='UTF-8');
namespace MyProject {

const CONNECT_OK = 1;
class Connection { /* ... */ }
function connect() { /* ... */  }
}

namespace { // 全局代码
session_start();
$a = MyProject\connect();
echo MyProject\Connection::start();
}
?>


使用命名空间：基础

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

在讨论如何使用命名空间之前，必须了解 PHP 是如何知道要使用哪一个命名空间中的元素的。可以将 PHP 命名空间与文件系统作一个简单的类比。在文件系统中访问一个文件有三种方式：

  1. 相对文件名形式如 foo.txt。它会被解析为 currentdirectory/foo.txt，其中 currentdirectory 表示当前目录。因此如果当前目录是 /home/foo，则该文件名被解析为 /home/foo/foo.txt。
  2. 相对路径名形式如 subdirectory/foo.txt。它会被解析为 currentdirectory/subdirectory/foo.txt。
  3. 绝对路径名形式如 /main/foo.txt。它会被解析为 /main/foo.txt。
PHP 命名空间中的元素使用同样的原理。例如，类名可以通过三种方式引用：
  1. 非限定名称，或不包含前缀的类名称，例如 $a=new foo(); 或 foo::staticmethod();。如果当前命名空间是 currentnamespace，foo 将被解析为 currentnamespace\foo。如果使用 foo 的代码是全局的，不包含在任何命名空间中的代码，则 foo 会被解析为 foo。 警告：如果命名空间中的函数或常量未定义，则该非限定的函数名称或常量名称会被解析为全局函数名称或常量名称。详情参见 使用命名空间：后备全局函数名称/常量名称。
  2. 限定名称,或包含前缀的名称，例如 $a = new subnamespace\foo(); 或 subnamespace\foo::staticmethod();。如果当前的命名空间是 currentnamespace，则 foo 会被解析为 currentnamespace\subnamespace\foo。如果使用 foo 的代码是全局的，不包含在任何命名空间中的代码，foo 会被解析为 subnamespace\foo。
  3. 完全限定名称，或包含了全局前缀操作符的名称，例如， $a = new \currentnamespace\foo(); 或 \currentnamespace\foo::staticmethod();。在这种情况下，foo 总是被解析为代码中的文字名(literal name)currentnamespace\foo。

下面是一个使用这三种方式的实例：

file1.php

<?php
namespace Foo\Bar\subnamespace;

const FOO = 1;
function foo() {}
class foo
{
    static function staticmethod() {}
}
?>

file2.php

<?php
namespace Foo\Bar;
include 'file1.php';

const FOO = 2;
function foo() {}
class foo
{
    static function staticmethod() {}
}

/* 非限定名称 */
foo(); // 解析为函数 Foo\Bar\foo
foo::staticmethod(); // 解析为类 Foo\Bar\foo 的静态方法 staticmethod
echo FOO; // 解析为常量 Foo\Bar\FOO

/* 限定名称 */
subnamespace\foo(); // 解析为函数 Foo\Bar\subnamespace\foo
subnamespace\foo::staticmethod(); // 解析为类 Foo\Bar\subnamespace\foo,
                                  // 以及类的方法 staticmethod
echo subnamespace\FOO; // 解析为常量 Foo\Bar\subnamespace\FOO

/* 完全限定名称 */
\Foo\Bar\foo(); // 解析为函数 Foo\Bar\foo
\Foo\Bar\foo::staticmethod(); // 解析为类 Foo\Bar\foo, 以及类的方法 staticmethod
echo \Foo\Bar\FOO; // 解析为常量 Foo\Bar\FOO
?>

注意访问任意全局类、函数或常量，都可以使用完全限定名称，例如 \strlen() 或 \Exception 或 \INI_ALL。

Example #1 在命名空间内部访问全局类、函数和常量

<?php
namespace Foo;

function strlen() {}
const INI_ALL = 3;
class Exception {}

$a = \strlen('hi'); // 调用全局函数strlen
$b = \INI_ALL; // 访问全局常量 INI_ALL
$c = new \Exception('error'); // 实例化全局类 Exception
?>


命名空间和动态语言特征

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

PHP 命名空间的实现受到其语言自身的动态特征的影响。因此，如果要将下面的代码转换到命名空间中：

Example #1 动态访问元素

example1.php:

<?php
class classname
{
    function __construct()
    {
        echo __METHOD__,"\n";
    }
}
function funcname()
{
    echo __FUNCTION__,"\n";
}
const constname = "global";

$a = 'classname';
$obj = new $a; // prints classname::__construct
$b = 'funcname';
$b(); // prints funcname
echo constant('constname'), "\n"; // prints global
?>
必须使用完全限定名称（包括命名空间前缀的类名称）。注意因为在动态的类名称、函数名称或常量名称中，限定名称和完全限定名称没有区别，因此其前导的反斜杠是不必要的。

Example #2 动态访问命名空间的元素

<?php
namespace namespacename;
class classname
{
    function __construct()
    {
        echo __METHOD__,"\n";
    }
}
function funcname()
{
    echo __FUNCTION__,"\n";
}
const constname = "namespaced";

include 'example1.php';

$a = 'classname';
$obj = new $a; // prints classname::__construct
$b = 'funcname';
$b(); // prints funcname
echo constant('constname'), "\n"; // prints global

/* note that if using double quotes, "\\namespacename\\classname" must be used */
$a = '\namespacename\classname';
$obj = new $a; // prints namespacename\classname::__construct
$a = 'namespacename\classname';
$obj = new $a; // also prints namespacename\classname::__construct
$b = 'namespacename\funcname';
$b(); // prints namespacename\funcname
$b = '\namespacename\funcname';
$b(); // also prints namespacename\funcname
echo constant('\namespacename\constname'), "\n"; // prints namespaced
echo constant('namespacename\constname'), "\n"; // also prints namespaced
?>

请一定别忘了阅读 对字符串中的命名空间名称转义的注解.


namespace 关键字和 __NAMESPACE__ 常量

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

PHP支持两种抽象的访问当前命名空间内部元素的方法，__NAMESPACE__ 魔术常量和 namespace 关键字。

常量 __NAMESPACE__ 的值是包含当前命名空间名称的字符串。在全局的，不包括在任何命名空间中的代码，它包含一个空的字符串。

Example #1 __NAMESPACE__ 示例, 在命名空间中的代码

<?php
namespace MyProject;

echo '"', __NAMESPACE__, '"'; // 输出 "MyProject"
?>

Example #2 __NAMESPACE__ 示例，全局代码

<?php

echo '"', __NAMESPACE__, '"'; // 输出 ""
?>
常量 __NAMESPACE__ 在动态创建名称时很有用，例如：

Example #3 使用 __NAMESPACE__ 动态创建名称

<?php
namespace MyProject;

function get($classname)
{
    $a = __NAMESPACE__ . '\\' . $classname;
    return new $a;
}
?>

关键字 namespace 可用来显式访问当前命名空间或子命名空间中的元素。它等价于类中的 self 操作符。

Example #4 namespace 操作符，命名空间中的代码

<?php
namespace MyProject;

use blah\blah as mine; // see "Using namespaces: importing/aliasing"

blah\mine(); // calls function MyProject\blah\mine()
namespace\blah\mine(); // calls function MyProject\blah\mine()

namespace\func(); // calls function MyProject\func()
namespace\sub\func(); // calls function MyProject\sub\func()
namespace\cname::method(); // calls static method "method" of class MyProject\cname
$a = new namespace\sub\cname(); // instantiates object of class MyProject\sub\cname
$b = namespace\CONSTANT; // assigns value of constant MyProject\CONSTANT to $b
?>

Example #5 namespace 操作符, 全局代码

<?php

namespace\func(); // calls function func()
namespace\sub\func(); // calls function sub\func()
namespace\cname::method(); // calls static method "method" of class cname
$a = new namespace\sub\cname(); // instantiates object of class sub\cname
$b = namespace\CONSTANT; // assigns value of constant CONSTANT to $b
?>


使用命名空间：别名/导入

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

允许通过别名引用或导入外部的完全限定名称，是命名空间的一个重要特征。这有点类似于在类 unix 文件系统中可以创建对其它的文件或目录的符号连接。

所有支持命名空间的 PHP 版本支持三种别名或导入方式：为类名称使用别名、为接口使用别名或为命名空间名称使用别名。PHP 5.6 开始允许导入函数或常量或者为它们设置别名。

在PHP中，别名是通过操作符 use 来实现的. 下面是一个使用所有可能的五种导入方式的例子：

Example #1 使用 use 操作符导入/使用别名

<?php
namespace foo;
use My\Full\Classname as Another;

// 下面的例子与 use My\Full\NSname as NSname 相同
use My\Full\NSname;

// 导入一个全局类
use ArrayObject;

// importing a function (PHP 5.6+)
use function My\Full\functionName;

// aliasing a function (PHP 5.6+)
use function My\Full\functionName as func;

// importing a constant (PHP 5.6+)
use const My\Full\CONSTANT;

$obj = new namespace\Another; // 实例化 foo\Another 对象
$obj = new Another; // 实例化 My\Full\Classname　对象
NSname\subns\func(); // 调用函数 My\Full\NSname\subns\func
$a = new ArrayObject(array(1)); // 实例化 ArrayObject 对象
// 如果不使用 "use \ArrayObject" ，则实例化一个 foo\ArrayObject 对象
func(); // calls function My\Full\functionName
echo CONSTANT; // echoes the value of My\Full\CONSTANT
?>
注意对命名空间中的名称（包含命名空间分隔符的完全限定名称如 Foo\Bar 以及相对的不包含命名空间分隔符的全局名称如 FooBar）来说，前导的反斜杠是不必要的也不推荐的，因为导入的名称必须是完全限定的，不会根据当前的命名空间作相对解析。

为了简化操作，PHP 还支持在一行中使用多个 use 语句

Example #2 通过 use 操作符导入/使用别名，一行中包含多个 use 语句

<?php
use My\Full\Classname as Another, My\Full\NSname;

$obj = new Another; // 实例化 My\Full\Classname 对象
NSname\subns\func(); // 调用函数 My\Full\NSname\subns\func
?>

导入操作是在编译执行的，但动态的类名称、函数名称或常量名称则不是。

Example #3 导入和动态名称

<?php
use My\Full\Classname as Another, My\Full\NSname;

$obj = new Another; // 实例化一个 My\Full\Classname 对象
$a = 'Another';
$obj = new $a;      // 实际化一个 Another 对象
?>

另外，导入操作只影响非限定名称和限定名称。完全限定名称由于是确定的，故不受导入的影响。

Example #4 导入和完全限定名称

<?php
use My\Full\Classname as Another, My\Full\NSname;

$obj = new Another; // instantiates object of class My\Full\Classname
$obj = new \Another; // instantiates object of class Another
$obj = new Another\thing; // instantiates object of class My\Full\Classname\thing
$obj = new \Another\thing; // instantiates object of class Another\thing
?>

Scoping rules for importing

The use keyword must be declared in the outermost scope of a file (the global scope) or inside namespace declarations. This is because the importing is done at compile time and not runtime, so it cannot be block scoped. The following example will show an illegal use of the use keyword:

Example #5 Illegal importing rule

<?php
namespace Languages;

class Greenlandic
{
    use Languages\Danish;

    ...
}
?>

Note:

Importing rules are per file basis, meaning included files will NOT inherit the parent file's importing rules.


全局空间

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

如果没有定义任何命名空间，所有的类与函数的定义都是在全局空间，与 PHP 引入命名空间概念前一样。在名称前加上前缀 \ 表示该名称是全局空间中的名称，即使该名称位于其它的命名空间中时也是如此。

Example #1 使用全局空间说明

<?php
namespace A\B\C;

/* 这个函数是 A\B\C\fopen */
function fopen() {
     /* ... */
     $f = \fopen(...); // 调用全局的fopen函数
     return $f;
}
?>


使用命名空间：后备全局函数/常量

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

在一个命名空间中，当 PHP 遇到一个非限定的类、函数或常量名称时，它使用不同的优先策略来解析该名称。类名称总是解析到当前命名空间中的名称。因此在访问系统内部或不包含在命名空间中的类名称时，必须使用完全限定名称，例如：

Example #1 在命名空间中访问全局类

<?php
namespace A\B\C;
class Exception extends \Exception {}

$a = new Exception('hi'); // $a 是类 A\B\C\Exception 的一个对象
$b = new \Exception('hi'); // $b 是类 Exception 的一个对象

$c = new ArrayObject; // 致命错误, 找不到 A\B\C\ArrayObject 类
?>

对于函数和常量来说，如果当前命名空间中不存在该函数或常量，PHP 会退而使用全局空间中的函数或常量。

Example #2 命名空间中后备的全局函数/常量

<?php
namespace A\B\C;

const E_ERROR = 45;
function strlen($str)
{
    return \strlen($str) - 1;
}

echo E_ERROR, "\n"; // 输出 "45"
echo INI_ALL, "\n"; // 输出 "7" - 使用全局常量 INI_ALL

echo strlen('hi'), "\n"; // 输出 "1"
if (is_array('hi')) { // 输出 "is not array"
    echo "is array\n";
} else {
    echo "is not array\n";
}
?>


名称解析规则

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

在说明名称解析规则之前，我们先看一些重要的定义：

命名空间名称定义
非限定名称 Unqualified name

名称中不包含命名空间分隔符的标识符，例如 Foo

限定名称 Qualified name

名称中含有命名空间分隔符的标识符，例如 Foo\Bar

完全限定名称 Fully qualified name

名称中包含命名空间分隔符，并以命名空间分隔符开始的标识符，例如 \Foo\Bar。 namespace\Foo 也是一个完全限定名称。

名称解析遵循下列规则：

  1. 对完全限定名称的函数，类和常量的调用在编译时解析。例如 new \A\B 解析为类 A\B。
  2. 所有的非限定名称和限定名称（非完全限定名称）根据当前的导入规则在编译时进行转换。例如，如果命名空间 A\B\C 被导入为 C，那么对 C\D\e() 的调用就会被转换为 A\B\C\D\e()。
  3. 在命名空间内部，所有的没有根据导入规则转换的限定名称均会在其前面加上当前的命名空间名称。例如，在命名空间 A\B 内部调用 C\D\e()，则 C\D\e() 会被转换为 A\B\C\D\e() 。
  4. 非限定类名根据当前的导入规则在编译时转换（用全名代替短的导入名称）。例如，如果命名空间 A\B\C 导入为C，则 new C() 被转换为 new A\B\C() 。
  5. 在命名空间内部（例如A\B），对非限定名称的函数调用是在运行时解析的。例如对函数 foo() 的调用是这样解析的：
    1. 在当前命名空间中查找名为 A\B\foo() 的函数
    2. 尝试查找并调用 全局(global) 空间中的函数 foo()。
  6. 在命名空间（例如A\B）内部对非限定名称或限定名称类（非完全限定名称）的调用是在运行时解析的。下面是调用 new C() 及 new D\E() 的解析过程： new C() 的解析:
    1. 在当前命名空间中查找A\B\C类。
    2. 尝试自动装载类A\B\C。
    new D\E()的解析:
    1. 在类名称前面加上当前命名空间名称变成：A\B\D\E，然后查找该类。
    2. 尝试自动装载类 A\B\D\E。
    为了引用全局命名空间中的全局类，必须使用完全限定名称 new \C()。

Example #1 名称解析示例

<?php
namespace A;
use B\D, C\E as F;

// 函数调用

foo();      // 首先尝试调用定义在命名空间"A"中的函数foo()
            // 再尝试调用全局函数 "foo"

\foo();     // 调用全局空间函数 "foo"

my\foo();   // 调用定义在命名空间"A\my"中函数 "foo"

F();        // 首先尝试调用定义在命名空间"A"中的函数 "F"
            // 再尝试调用全局函数 "F"

// 类引用

new B();    // 创建命名空间 "A" 中定义的类 "B" 的一个对象
            // 如果未找到，则尝试自动装载类 "A\B"

new D();    // 使用导入规则，创建命名空间 "B" 中定义的类 "D" 的一个对象
            // 如果未找到，则尝试自动装载类 "B\D"

new F();    // 使用导入规则，创建命名空间 "C" 中定义的类 "E" 的一个对象
            // 如果未找到，则尝试自动装载类 "C\E"

new \B();   // 创建定义在全局空间中的类 "B" 的一个对象
            // 如果未发现，则尝试自动装载类 "B"

new \D();   // 创建定义在全局空间中的类 "D" 的一个对象
            // 如果未发现，则尝试自动装载类 "D"

new \F();   // 创建定义在全局空间中的类 "F" 的一个对象
            // 如果未发现，则尝试自动装载类 "F"

// 调用另一个命名空间中的静态方法或命名空间函数

B\foo();    // 调用命名空间 "A\B" 中函数 "foo"

B::foo();   // 调用命名空间 "A" 中定义的类 "B" 的 "foo" 方法
            // 如果未找到类 "A\B" ，则尝试自动装载类 "A\B"

D::foo();   // 使用导入规则，调用命名空间 "B" 中定义的类 "D" 的 "foo" 方法
            // 如果类 "B\D" 未找到，则尝试自动装载类 "B\D"

\B\foo();   // 调用命名空间 "B" 中的函数 "foo"

\B::foo();  // 调用全局空间中的类 "B" 的 "foo" 方法
            // 如果类 "B" 未找到，则尝试自动装载类 "B"

// 当前命名空间中的静态方法或函数

A\B::foo();   // 调用命名空间 "A\A" 中定义的类 "B" 的 "foo" 方法
              // 如果类 "A\A\B" 未找到，则尝试自动装载类 "A\A\B"

\A\B::foo();  // 调用命名空间 "A\B" 中定义的类 "B" 的 "foo" 方法
              // 如果类 "A\B" 未找到，则尝试自动装载类 "A\B"
?>


FAQ: things you need to know about namespaces

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

This FAQ is split into two sections: common questions, and some specifics of implementation that are helpful to understand fully.

First, the common questions.

  1. If I don't use namespaces, should I care about any of this?
  2. How do I use internal or global classes in a namespace?
  3. How do I use namespaces classes functions, or constants in their own namespace?
  4. How does a name like \my\name or \name resolve?
  5. How does a name like my\name resolve?
  6. How does an unqualified class name like name resolve?
  7. How does an unqualified function name or unqualified constant name like name resolve?

There are a few implementation details of the namespace implementations that are helpful to understand.

  1. Import names cannot conflict with classes defined in the same file.
  2. Nested namespaces are not allowed.
  3. Neither functions nor constants can be imported via the use statement.
  4. Dynamic namespace names (quoted identifiers) should escape backslash.
  5. Undefined Constants referenced using any backslash die with fatal error
  6. Cannot override special constants NULL, TRUE, FALSE, ZEND_THREAD_SAFE or ZEND_DEBUG_BUILD

If I don't use namespaces, should I care about any of this?

No. Namespaces do not affect any existing code in any way, or any as-yet-to-be-written code that does not contain namespaces. You can write this code if you wish:

Example #1 Accessing global classes outside a namespace

<?php
$a = new \stdClass;

This is functionally equivalent to:

Example #2 Accessing global classes outside a namespace

<?php
$a = new stdClass;

How do I use internal or global classes in a namespace?

Example #3 Accessing internal classes in namespaces

<?php
namespace foo;
$a = new \stdClass;

function test(\ArrayObject $typehintexample = null) {}

$a = \DirectoryIterator::CURRENT_AS_FILEINFO;

// extending an internal or global class
class MyException extends \Exception {}
?>

How do I use namespaces classes, functions, or constants in their own namespace?

Example #4 Accessing internal classes, functions or constants in namespaces

<?php
namespace foo;

class MyClass {}

// using a class from the current namespace as a type hint
function test(MyClass $typehintexample = null) {}
// another way to use a class from the current namespace as a type hint
function test(\foo\MyClass $typehintexample = null) {}

// extending a class from the current namespace
class Extended extends MyClass {}

// accessing a global function
$a = \globalfunc();

// accessing a global constant
$b = \INI_ALL;
?>

How does a name like \my\name or \name resolve?

Names that begin with a \ always resolve to what they look like, so \my\name is in fact my\name, and \Exception is Exception.

Example #5 Fully Qualified names

<?php
namespace foo;
$a = new \my\name(); // instantiates "my\name" class
echo \strlen('hi'); // calls function "strlen"
$a = \INI_ALL; // $a is set to the value of constant "INI_ALL"
?>

How does a name like my\name resolve?

Names that contain a backslash but do not begin with a backslash like my\name can be resolved in 2 different ways.

If there is an import statement that aliases another name to my, then the import alias is applied to the my in my\name.

Otherwise, the current namespace name is prepended to my\name.

Example #6 Qualified names

<?php
namespace foo;
use blah\blah as foo;

$a = new my\name(); // instantiates "foo\my\name" class
foo\bar::name(); // calls static method "name" in class "blah\blah\bar"
my\bar(); // calls function "foo\my\bar"
$a = my\BAR; // sets $a to the value of constant "foo\my\BAR"
?>

How does an unqualified class name like name resolve?

Class names that do not contain a backslash like name can be resolved in 2 different ways.

If there is an import statement that aliases another name to name, then the import alias is applied.

Otherwise, the current namespace name is prepended to name.

Example #7 Unqualified class names

<?php
namespace foo;
use blah\blah as foo;

$a = new name(); // instantiates "foo\name" class
foo::name(); // calls static method "name" in class "blah\blah"
?>

How does an unqualified function name or unqualified constant name like name resolve?

Function or constant names that do not contain a backslash like name can be resolved in 2 different ways.

First, the current namespace name is prepended to name.

Finally, if the constant or function name does not exist in the current namespace, a global constant or function name is used if it exists.

Example #8 Unqualified function or constant names

<?php
namespace foo;
use blah\blah as foo;

const FOO = 1;

function my() {}
function foo() {}
function sort(&$a)
{
    sort($a);
    $a = array_flip($a);
    return $a;
}

my(); // calls "foo\my"
$a = strlen('hi'); // calls global function "strlen" because "foo\strlen" does not exist
$arr = array(1,3,2);
$b = sort($arr); // calls function "foo\sort"
$c = foo(); // calls function "foo\foo" - import is not applied

$a = FOO; // sets $a to value of constant "foo\FOO" - import is not applied
$b = INI_ALL; // sets $b to value of global constant "INI_ALL"
?>

Import names cannot conflict with classes defined in the same file.

The following script combinations are legal:

file1.php

<?php
namespace my\stuff;
class MyClass {}
?>

another.php

<?php
namespace another;
class thing {}
?>

file2.php

<?php
namespace my\stuff;
include 'file1.php';
include 'another.php';

use another\thing as MyClass;
$a = new MyClass; // instantiates class "thing" from namespace another
?>

There is no name conflict, even though the class MyClass exists within the my\stuff namespace, because the MyClass definition is in a separate file. However, the next example causes a fatal error on name conflict because MyClass is defined in the same file as the use statement.

<?php
namespace my\stuff;
use another\thing as MyClass;
class MyClass {} // fatal error: MyClass conflicts with import statement
$a = new MyClass;
?>

Nested namespaces are not allowed.

PHP does not allow nesting namespaces

<?php
namespace my\stuff {
    namespace nested {
        class foo {}
    }
}
?>
However, it is easy to simulate nested namespaces like so:
<?php
namespace my\stuff\nested {
    class foo {}
}
?>

Neither functions nor constants can be imported via the use statement.

The only elements that are affected by use statements are namespaces and class names. In order to shorten a long constant or function, import its containing namespace

<?php
namespace mine;
use ultra\long\ns\name;

$a = name\CONSTANT;
name\func();
?>

Dynamic namespace names (quoted identifiers) should escape backslash

It is very important to realize that because the backslash is used as an escape character within strings, it should always be doubled when used inside a string. Otherwise there is a risk of unintended consequences:

Example #9 Dangers of using namespaced names inside a double-quoted string

<?php
$a = new "dangerous\name"; // \n is a newline inside double quoted strings!
$obj = new $a;

$a = new 'not\at\all\dangerous'; // no problems here.
$obj = new $a;
?>
Inside a single-quoted string, the backslash escape sequence is much safer to use, but it is still recommended practice to escape backslashes in all strings as a best practice.

Undefined Constants referenced using any backslash die with fatal error

Any undefined constant that is unqualified like FOO will produce a notice explaining that PHP assumed FOO was the value of the constant. Any constant, qualified or fully qualified, that contains a backslash will produce a fatal error if not found.

Example #10 Undefined constants

<?php
namespace bar;
$a = FOO; // produces notice - undefined constants "FOO" assumed "FOO";
$a = \FOO; // fatal error, undefined namespace constant FOO
$a = Bar\FOO; // fatal error, undefined namespace constant bar\Bar\FOO
$a = \Bar\FOO; // fatal error, undefined namespace constant Bar\FOO
?>

Cannot override special constants NULL, TRUE, FALSE, ZEND_THREAD_SAFE or ZEND_DEBUG_BUILD

Any attempt to define a namespaced constant that is a special, built-in constant results in a fatal error

Example #11 Undefined constants

<?php
namespace bar;
const NULL = 0; // fatal error;
const true = 'stupid'; // also fatal error;
// etc.
?>


错误

Table of Contents

  • 基础概要
  • PHP 7 错误处理

介绍

可悲的是，不管我们在写代码时多么小心，错误始终是有的。PHP 会为许多常见的编码和运行问题报告错误、警告、通知。知道如何检测和处理这些错误，使得调试程序更容易。


基础概要

PHP 遇到一系列内部错误时，会报告出来作为应对。 它可以用来标示不同的情况，可以要求将错误显示出来或记录到日志中。

每个 PHP 产生的错误都包含了类型。可查看 错误类型清单，它附带了不同类型行为的简短描述和 产生的原因。

PHP 错误处理

当未设置错误处理函数时，PHP 会根据配置处理所有出现的错误。 php.ini 中 error_reporting 的配置 或者是运行时调用 error_reporting() 控制了哪些错误需要报告，哪些错误需要自动忽略。 由于有些错误会在运行用户脚本前就可能出现，所以强烈推荐用配置指令来设置。

在开发环境里为了发现并修复 PHP 产生的问题， 应该总是把 error_reporting 设置为 E_ALL。 在生产环境里，用户可能为了降低信息的详细程度， 想要将它设置为类似 E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED， 但很多情况下 E_ALL 也同样适用，这样可以更早地警告潜在问题。

PHP 对这些错误的处理方式，取决于两个更深的 php.ini 指令。 display_errors 控制了是否要将错位作为脚本输出的一部分显示。 在生产环境里应该禁用，因为可能包含类似数据库密码这样的敏感信息， 而在开发环境中应该启用，能确保立即报告问题。

PHP 不仅能显示错误，还可以开启 log_errors 指令来记录错误日志。它能根据 error_log 的设置， 记录任意错误到文件或者 syslog。 特别适用于生产环境，用户可以记录发生的错误，并根据这些错误生成报告。

用户的错误处理器

如果 PHP 默认错误处理器还不能满足要求，用户可以通过 set_error_handler() 设置自定义错误处理器，可处理很多类型的错误。 虽然有些类型的错误不能通过这种方式处理，但能处理的类型可以用脚本合适的方式处理： 例如为用户显示自定义错误页面，同时以一种比日志更直接的方式上报错误，例如发送邮件。


PHP 7 错误处理

PHP 7 改变了大多数错误的报告方式。不同于传统（PHP 5）的错误报告机制，现在大多数错误被作为 Error 异常抛出。

这种 Error 异常可以像 Exception 异常一样被第一个匹配的 try / catch 块所捕获。如果没有匹配的 catch 块，则调用异常处理函数（事先通过 set_exception_handler() 注册）进行处理。 如果尚未注册异常处理函数，则按照传统方式处理：被报告为一个致命错误（Fatal Error）。

Error 类并非继承自 Exception 类，所以不能用 catch (Exception $e) { ... } 来捕获 Error。你可以用 catch (Error $e) { ... }，或者通过注册异常处理函数（ set_exception_handler()）来捕获 Error。

Error 层次结构

  • Throwable
    • Error
      • ArithmeticError
        • DivisionByZeroError
      • AssertionError
      • CompileError
        • ParseError
      • TypeError
        • ArgumentCountError
    • Exception
      • ...


异常

Table of Contents

  • 扩展（extend） 异常处理类

PHP 有一个和其他语言相似的异常模型。 在 PHP 里可以 throw 并 catch 异常。 为了捕获潜在的异常，可以将代码包含在 try 块里。 每个 try 都必须有一个相应的 catch 或 finally 代码块。

如果抛出异常的函数范围内没有 catch 块，异常会沿调用栈"向上冒泡"， 直到找到匹配的 catch 块。 沿途会执行所有遇到的 finally 块。 在没有设置全局异常处理程序（exception handler）时， 如果调用栈向上都没有遇到匹配的 catch，程序会抛出 fatal 错误并终止执行。

抛出的对象必须是 Exception 自身或 Exception的子类。 抛出其他对象会导致 PHP 报 Fatal 错误。

PHP 8.0.0 起，throw 关键词现在开始是一个表达式，可用于任何表达式的场景。 在此之前，它是一个语句，必须独占一行。

catch

catch 定义了处理抛出异常的方式。 catch 块定义了它能处理的异常/错误的类型，并可以选择将异常赋值到变量中。 （在 PHP 8.0.0 之前的版本中必须要赋值到变量） 如果遇到抛出对象的类型匹配了首个 catch 块的异常或错误，将会处理该对象。

可用多个 catch 捕获不同的异常类。 正常情况下（try 代码块里没有抛出异常）会在最后一个定义的 catch 后面继续执行。 catch 代码块里也可以 throw 或者重新抛出异常。 不抛出的话，会在触发的 catch 后面继续执行。

当 PHP 抛出一个异常时，将不会执行后续的代码语句，并会尝试查找首个匹配的 catch 代码块。 如果没有用 set_exception_handler() 设置异常处理函数， PHP 会在异常未被捕获时产生 Fatal 级错误，提示 "Uncaught Exception ..." 消息。

从 PHP 7.1.0 起 catch 可以用竖线符（|） 指定多个异常。 如果在不同的类层次结构中，不同异常的异常需要用同样的方式处理，就特别适用这种方式。

从 PHP 8.0.0 起，捕获的异常不再强制要求指定变量名。 catch 代码块会在未指定时继续执行，只是无法访问到抛出的对象。

finally

finally 代码块可以放在 catch 之后，或者直接代替它。 无论是否抛出了异常，在 try 和 catch 之后、在执行后续代码之前， 放在 finally 里的代码总是会执行。

值得注意的是 finally 和 return 语句之间存在相互影响。 如果在 try 或 catch 里遇到 return，仍然会执行 finally 里的代码。 而且，遇到 return 语句时，会先执行 finally 再返回结果。 此外，如果 finally 里也包含了 return 语句，将返回 finally 里的值。

全局异常处理器

当允许异常冒泡到全局范围时，它可以被全局异常处理器捕获到。 set_exception_handler() 可以设置一个函数，在没有调用其他块时代替 catch。 在本质上，实现的效果等同于整个程序被 try-catch 包裹起来， 而该函数就是 catch。

注释

Note:

PHP 内部函数主要使用 错误报告， 只有一些现代 面向对象 的扩展使用异常。 不过，错误很容易用 ErrorException 转化成异常。 然而，这个技术方案仅适用非 Fatal 级的错误。

Example #3 将错误报告转成异常

<?php
function exceptions_error_handler($severity, $message, $filename, $lineno) {
    throw new ErrorException($message, 0, $severity, $filename, $lineno);
}

set_error_handler('exceptions_error_handler');
?>

Tip

PHP 标准库（SPL） 提供了大量的 标准内置异常。

范例

Example #4 抛出一个异常

<?php
function inverse($x) {
    if (!$x) {
        throw new Exception('Division by zero.');
    }
    return 1/$x;
}

try {
    echo inverse(5) . "\n";
    echo inverse(0) . "\n";
} catch (Exception $e) {
    echo 'Caught exception: ',  $e->getMessage(), "\n";
}

// Continue execution
echo "Hello World\n";
?>

以上例程会输出：

0.2
Caught exception: Division by zero.
Hello World

Example #5 带 finally 块的异常处理

<?php
function inverse($x) {
    if (!$x) {
        throw new Exception('Division by zero.');
    }
    return 1/$x;
}

try {
    echo inverse(5) . "\n";
} catch (Exception $e) {
    echo 'Caught exception: ',  $e->getMessage(), "\n";
} finally {
    echo "First finally.\n";
}

try {
    echo inverse(0) . "\n";
} catch (Exception $e) {
    echo 'Caught exception: ',  $e->getMessage(), "\n";
} finally {
    echo "Second finally.\n";
}

// 继续执行
echo "Hello World\n";
?>

以上例程会输出：

0.2
First finally.
Caught exception: Division by zero.
Second finally.
Hello World

Example #6 finally 和 return 相互之间的影响

<?php

function test() {
    try {
        throw new Exception('foo');
    } catch (Exception $e) {
        return 'catch';
    } finally {
        return 'finally';
    }
}

echo test();
?>

以上例程会输出：

finally

Example #7 异常嵌套

<?php

class MyException extends Exception { }

class Test {
    public function testing() {
        try {
            try {
                throw new MyException('foo!');
            } catch (MyException $e) {
                // 重新 throw
                throw $e;
            }
        } catch (Exception $e) {
            var_dump($e->getMessage());
        }
    }
}

$foo = new Test;
$foo->testing();

?>

以上例程会输出：

string(4) "foo!"

Example #8 多个异常的捕获处理

<?php

class MyException extends Exception { }

class MyOtherException extends Exception { }

class Test {
    public function testing() {
        try {
            throw new MyException();
        } catch (MyException | MyOtherException $e) {
            var_dump(get_class($e));
        }
    }
}

$foo = new Test;
$foo->testing();

?>

以上例程会输出：

string(11) "MyException"

Example #9 忽略捕获的变量

仅仅在 PHP 8.0.0 及以上版本有效

<?php

class SpecificException extends Exception {}

function test() {
    throw new SpecificException('Oopsie');
}

try {
    test();
} catch (SpecificException) {
    print "A SpecificException was thrown, but we don't care about the details.";
}
?>

Example #10 以表达式的形式抛出

仅仅在 PHP 8.0.0 及以上版本有效

<?php

class SpecificException extends Exception {}

function test() {
    do_something_risky() or throw new Exception('It did not work');
}

try {
    test();
} catch (Exception $e) {
    print $e->getMessage();
}
?>


扩展（extend） 异常处理类

用户可以用自定义的异常处理类来扩展 PHP 内置的异常处理类。以下的代码说明了在内置的异常处理类中，哪些属性和方法在子类中是可访问和可继承的。

Example #1 内置的异常处理类

<?php
class Exception extends Throwable
{
    protected $message = 'Unknown exception';   // 异常信息
    private   $string;                          // __toString 的缓存
    protected $code = 0;                        // 用户自定义异常错误码
    protected $file;                            // 发生异常的源文件名
    protected $line;                            // 发生异常的源代码行号
    private   $trace;                           // backtrace
    private   $previous;                        // 如果是嵌套异常，则是之前的 exception

    public function __construct($message = null, $code = 0, Exception $previous = null);

    final private function __clone();           // Inhibits cloning of exceptions.

    final public  function getMessage();        // 异常信息
    final public  function getCode();           // 异常错误码
    final public  function getFile();           // 发生异常的源文件名
    final public  function getLine();           // 发生异常的源代码行号
    final public  function getTrace();          // backtrace() 数组
    final public  function getPrevious();       // 之前的 exception
    final public  function getTraceAsString();  // 已格成化成字符串的 getTrace() 信息

    // Overrideable
    public function __toString();               // 可输出的格式化后的字符串
}
?>

如果使用自定义的类来扩展内置异常处理类，并且要重新定义构造函数的话，建议同时调用 parent::__construct() 来确保所有的变量已赋值。当对象要输出字符串的时候，可以重载 __toString() 并自定义输出的样式。

Note:

Exception 对象不能被复制。尝试对 Exception 对象复制 会导致一个 E_ERROR 级别的错误。

Example #2 扩展 PHP 内置的异常处理类

<?php
/**
 * 自定义一个异常处理类
 */
class MyException extends Exception
{
    // 重定义构造器使 message 变为必须被指定的属性
    public function __construct($message, $code = 0, Exception $previous = null) {
        // 这里写用户的代码

        // 确保所有变量都被正确赋值
        parent::__construct($message, $code, $previous);
    }

    // 自定义字符串输出的格式
    public function __toString() {
        return __CLASS__ . ": [{$this->code}]: {$this->message}\n";
    }

    public function customFunction() {
        echo "A custom function for this type of exception\n";
    }
}

/**
 * 创建一个类，测试该 exception 类
 */
class TestException
{
    public $var;

    const THROW_NONE    = 0;
    const THROW_CUSTOM  = 1;
    const THROW_DEFAULT = 2;

    function __construct($avalue = self::THROW_NONE) {

        switch ($avalue) {
            case self::THROW_CUSTOM:
                // 抛出自定义异常
                throw new MyException('1 is an invalid parameter', 5);
                break;

            case self::THROW_DEFAULT:
                // 抛出默认的异常
                throw new Exception('2 is not allowed as a parameter', 6);
                break;

            default:
                // 没有异常的情况下，创建一个对象
                $this->var = $avalue;
                break;
        }
    }
}

// 例子 1
try {
    $o = new TestException(TestException::THROW_CUSTOM);
} catch (MyException $e) {      // 捕获异常
    echo "Caught my exception\n", $e;
    $e->customFunction();
} catch (Exception $e) {        // 被忽略
    echo "Caught Default Exception\n", $e;
}

// 继续执行后续代码
var_dump($o); // Null
echo "\n\n";

// 例子 2
try {
    $o = new TestException(TestException::THROW_DEFAULT);
} catch (MyException $e) {      //  不能匹配异常的种类，被忽略
    echo "Caught my exception\n", $e;
    $e->customFunction();
} catch (Exception $e) {        // 捕获异常
    echo "Caught Default Exception\n", $e;
}

// 执行后续代码
var_dump($o); // Null
echo "\n\n";

// 例子 3
try {
    $o = new TestException(TestException::THROW_CUSTOM);
} catch (Exception $e) {        // 捕获异常
    echo "Default Exception caught\n", $e;
}

// 执行后续代码
var_dump($o); // Null
echo "\n\n";

// 例子 4
try {
    $o = new TestException();
} catch (Exception $e) {        // 没有异常，被忽略
    echo "Default Exception caught\n", $e;
}

// 执行后续代码
var_dump($o); // TestException
echo "\n\n";
?>


  • ? 扩展（extend） 异常处理类
  • 生成器总览 ?
  • PHP Manual
  • 语言参考
  • 生成器

生成器

Table of Contents

  • 生成器总览
  • 生成器语法
  • 生成器与 Iterator 对象的比较


生成器总览

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

生成器提供了一种更容易的方法来实现简单的对象迭代，相比较定义类实现 Iterator 接口的方式，性能开销和复杂性大大降低。

生成器允许你在 foreach 代码块中写代码来迭代一组数据而不需要在内存中创建一个数组, 那会使你的内存达到上限，或者会占据可观的处理时间。相反，你可以写一个生成器函数，就像一个普通的自定义函数一样, 和普通函数只返回一次不同的是, 生成器可以根据需要 yield 多次，以便生成需要迭代的值。

一个简单的例子就是使用生成器来重新实现 range() 函数。 标准的 range() 函数需要在内存中生成一个数组包含每一个在它范围内的值，然后返回该数组, 结果就是会产生多个很大的数组。 比如，调用 range(0, 1000000) 将导致内存占用超过 100 MB。

做为一种替代方法, 我们可以实现一个 xrange() 生成器, 只需要足够的内存来创建 Iterator 对象并在内部跟踪生成器的当前状态，这样只需要不到1K字节的内存。

Example #1 将 range() 实现为生成器

<?php
function xrange($start, $limit, $step = 1) {
    if ($start <= $limit) {
        if ($step <= 0) {
            throw new LogicException('Step must be positive');
        }

        for ($i = $start; $i <= $limit; $i += $step) {
            yield $i;
        }
    } else {
        if ($step >= 0) {
            throw new LogicException('Step must be negative');
        }

        for ($i = $start; $i >= $limit; $i += $step) {
            yield $i;
        }
    }
}

/*
 * 注意下面range()和xrange()输出的结果是一样的。
 */

echo 'Single digit odd numbers from range():  ';
foreach (range(1, 9, 2) as $number) {
    echo "$number ";
}
echo "\n";

echo 'Single digit odd numbers from xrange(): ';
foreach (xrange(1, 9, 2) as $number) {
    echo "$number ";
}
?>

以上例程会输出：

Single digit odd numbers from range():  1 3 5 7 9
Single digit odd numbers from xrange(): 1 3 5 7 9

Generator 对象

调用生成器函数时会返回一个内部的 Generator 类的对象。 该对象实现了 Iterator 接口，基本上和仅向前的迭代器一样， 它提供的方法可以操控生成器的状态，包括发送值、返回值。


生成器语法

生成器函数看起来像普通函数——不同的是普通函数返回一个值，而生成器可以 yield 生成多个想要的值。 任何包含 yield 的函数都是一个生成器函数。

当一个生成器被调用的时候，它返回一个可以被遍历的对象.当你遍历这个对象的时候(例如通过一个foreach循环)，PHP 将会在每次需要值的时候调用对象的遍历方法，并在产生一个值之后保存生成器的状态，这样它就可以在需要产生下一个值的时候恢复调用状态。

一旦不再需要产生更多的值，生成器可以简单退出，而调用生成器的代码还可以继续执行，就像一个数组已经被遍历完了。

Note:

生成器能够返回多个值，通过 Generator::getReturn() 可以获取到。

yield关键字

生成器函数的核心是yield关键字。它最简单的调用形式看起来像一个return申明，不同之处在于普通return会返回值并终止函数的执行，而yield会返回一个值给循环调用此生成器的代码并且只是暂停执行生成器函数。

Example #1 一个简单的生成值的例子

<?php
function gen_one_to_three() {
    for ($i = 1; $i <= 3; $i++) {
        //注意变量$i的值在不同的yield之间是保持传递的。
        yield $i;
    }
}

$generator = gen_one_to_three();
foreach ($generator as $value) {
    echo "$value\n";
}
?>

以上例程会输出：

1
2
3

Note:

在内部会为生成的值配对连续的整型索引，就像一个非关联的数组。

Caution

传入 Generator::send() 的值会被赋值到 $data， 或者直接调用 Generator::next() 时，赋的值将是 null。

指定键名来生成值

PHP的数组支持关联键值对数组，生成器也一样支持。所以除了生成简单的值，你也可以在生成值的时候指定键名。

如下所示，生成一个键值对与定义一个关联数组十分相似。

Example #2 生成一个键值对

<?php
/*
 * 下面每一行是用分号分割的字段组合，第一个字段将被用作键名。
 */

$input = <<<'EOF'
1;PHP;Likes dollar signs
2;Python;Likes whitespace
3;Ruby;Likes blocks
EOF;

function input_parser($input) {
    foreach (explode("\n", $input) as $line) {
        $fields = explode(';', $line);
        $id = array_shift($fields);

        yield $id => $fields;
    }
}

foreach (input_parser($input) as $id => $fields) {
    echo "$id:\n";
    echo "    $fields[0]\n";
    echo "    $fields[1]\n";
}
?>

以上例程会输出：

1:
    PHP
    Likes dollar signs
2:
    Python
    Likes whitespace
3:
    Ruby
    Likes blocks
Caution

和之前生成简单值类型一样，在一个表达式上下文中生成键值对也需要使用圆括号进行包围：

$data = (yield $key => $value);

生成 null 值

Yield 可以在没有参数传入的情况下被调用来生成一个 null 值并配对一个自动的键名。

Example #3 生成nulls

<?php
function gen_three_nulls() {
    foreach (range(1, 3) as $i) {
        yield;
    }
}

var_dump(iterator_to_array(gen_three_nulls()));
?>

以上例程会输出：

array(3) {
  [0]=>
  NULL
  [1]=>
  NULL
  [2]=>
  NULL
}

使用引用来生成值

生成函数可以像使用值一样来使用引用生成。这个和从函数返回一个引用一样：通过在函数名前面加一个引用符号。

Example #4 使用引用来生成值

<?php
function &gen_reference() {
    $value = 3;

    while ($value > 0) {
        yield $value;
    }
}

/*
 * 我们可以在循环中修改 $number 的值，而生成器是使用的引用值来生成，所以 gen_reference() 内部的 $value 值也会跟着变化。
 */
foreach (gen_reference() as &$number) {
    echo (--$number).'... ';
}
?>

以上例程会输出：

2... 1... 0...

Generator delegation via yield from

Generator delegation allows you to yield values from another generator, Traversable object, or array by using the yield from keyword. The outer generator will then yield all values from the inner generator, object, or array until that is no longer valid, after which execution will continue in the outer generator.

If a generator is used with yield from, the yield from expression will also return any value returned by the inner generator.

Caution

Storing into an array (e.g. with iterator_to_array())

yield from does not reset the keys. It preserves the keys returned by the Traversable object, or array. Thus some values may share a common key with another yield or yield from, which, upon insertion into an array, will overwrite former values with that key.

A common case where this matters is iterator_to_array() returning a keyed array by default, leading to possibly unexpected results. iterator_to_array() has a second parameter use_keys which can be set to false to collect all the values while ignoring the keys returned by the Generator.

Example #5 yield from with iterator_to_array()

<?php
 function inner() {
     yield 1; // key 0
     yield 2; // key 1
     yield 3; // key 2
 }
 function gen() {
     yield 0; // key 0
     yield from inner(); // keys 0-2
     yield 4; // key 1
 }
 // pass false as second parameter to get an array [0, 1, 2, 3, 4]
 var_dump(iterator_to_array(gen()));
 ?>

以上例程会输出：

 array(3) {
   [0]=>
   int(1)
   [1]=>
   int(4)
   [2]=>
   int(3)
 }

Example #6 yield from 的基本用法

<?php
function count_to_ten() {
    yield 1;
    yield 2;
    yield from [3, 4];
    yield from new ArrayIterator([5, 6]);
    yield from seven_eight();
    yield 9;
    yield 10;
}

function seven_eight() {
    yield 7;
    yield from eight();
}

function eight() {
    yield 8;
}

foreach (count_to_ten() as $num) {
    echo "$num ";
}
?>

以上例程会输出：

1 2 3 4 5 6 7 8 9 10

Example #7 yield from 并返回多个值

<?php
function count_to_ten() {
    yield 1;
    yield 2;
    yield from [3, 4];
    yield from new ArrayIterator([5, 6]);
    yield from seven_eight();
    return yield from nine_ten();
}

function seven_eight() {
    yield 7;
    yield from eight();
}

function eight() {
    yield 8;
}

function nine_ten() {
    yield 9;
    return 10;
}

$gen = count_to_ten();
foreach ($gen as $num) {
    echo "$num ";
}
echo $gen->getReturn();
?>

以上例程会输出：

1 2 3 4 5 6 7 8 9 10


生成器与 Iterator 对象的比较

生成器最主要的优点是简洁。和实现一个 Iterator 类相较而言， 同样的功能，用生成器可以编写更少的代码，可读性也更强。 举例，下面的类和函数是相等的：

<?php
function getLinesFromFile($fileName) {
    if (!$fileHandle = fopen($fileName, 'r')) {
        return;
    }

    while (false !== $line = fgets($fileHandle)) {
        yield $line;
    }

    fclose($fileHandle);
}

// 比较下...

class LineIterator implements Iterator {
    protected $fileHandle;

    protected $line;
    protected $i;

    public function __construct($fileName) {
        if (!$this->fileHandle = fopen($fileName, 'r')) {
            throw new RuntimeException('Couldn\'t open file "' . $fileName . '"');
        }
    }

    public function rewind() {
        fseek($this->fileHandle, 0);
        $this->line = fgets($this->fileHandle);
        $this->i = 0;
    }

    public function valid() {
        return false !== $this->line;
    }

    public function current() {
        return $this->line;
    }

    public function key() {
        return $this->i;
    }

    public function next() {
        if (false !== $this->line) {
            $this->line = fgets($this->fileHandle);
            $this->i++;
        }
    }

    public function __destruct() {
        fclose($this->fileHandle);
    }
}
?>

不过，这也付出了灵活性的代价： 生成器是一个只能向前的迭代器，一旦开始遍历就无法后退。 意思也就是说，同样的生成器无法遍历多遍：要么再次调用生成器函数，重新生成后再遍历。


  • ? 生成器与 Iterator 对象的比较
  • 注解概览 ?
  • PHP Manual
  • 语言参考
  • 注解

注解

Table of Contents

  • 注解概览
  • 注解语法
  • 使用反射 API 读取注解
  • 声明注解类


注解概览

(PHP 8)

注解功能使得代码中的声明部分都可以添加结构化、机器可读的元数据， 注解的目标可以是类、方法、函数、参数、属性、类常量。 通过 反射 API 可在运行时获取注解所定义的元数据。 因此注解可以成为直接嵌入代码的配置式语言。

通过注解的使用，在应用中实现功能、使用功能可以相互解耦。 某种程度上讲，它可以和接口（interface）与其实现（implementation）相比较。 但接口与实现是代码相关的，注解则与声明额外信息和配置相关。 接口可以通过类来实现，而注解也可以声明到方法、函数、参数、属性、类常量中。 因此它们比接口更灵活。

注解使用的一个简单例子：将接口（interface）的可选方法改用注解实现。 我们假设接口 ActionHandler 代表了应用的一个操作： 部分 action handler 的实现需要 setup，部分不需要。 我们可以使用注解，而不用要求所有类必须实现 ActionHandler 接口并实现 setUp() 方法。 因此带来一个好处——可以多次使用注解。

Example #1 用注解实现接口的可选方法

<?php
interface ActionHandler
{
    public function execute();
}

#[Attribute]
class SetUp {}

class CopyFile implements ActionHandler
{
    public string $fileName;
    public string $targetDirectory;

    #[SetUp]
    public function fileExists()
    {
        if (!file_exists($this->fileName)) {
            throw new RuntimeException("File does not exist");
        }
    }

    #[SetUp]
    public function targetDirectoryExists()
    {
        mkdir($this->targetDirectory);
    }

    public function execute()
    {
        copy($this->fileName, $this->targetDirectory . '/' . basename($this->fileName));
    }
}

function executeAction(ActionHandler $actionHandler)
{
    $reflection = new ReflectionObject($actionHandler);

    foreach ($reflection->getMethods() as $method) {
        $attributes = $method->getAttributes(SetUp::class);

        if (count($attributes) > 0) {
            $methodName = $method->getName();

            $actionHandler->$methodName();
        }
    }

    $actionHandler->execute();
}

$copyAction = new CopyFile();
$copyAction->fileName = "/tmp/foo.jpg";
$copyAction->targetDirectory = "/home/user";

executeAction($copyAction);


注解语法

注解语法包含以下几部分。 首先，注解声明总是以 #[ 开头，以 ] 结尾来包围。 内部则是一个或以逗号包含的多个注解。 注解的名称按 使用命名空间：基础 章节中描述，可以是非限定、限定、完全限定的名称。 注解的参数是可以选的，以常见的括号()包围。 注解的参数可以是字面值或者常量表达式。 它同时接受位置参数和命名参数两种语法。

通过反射 API 请求注解实例时，注解的名称会被解析到一个类，注解的参数则传入该类的构造器中。 因此每个注解都需要引入一个类。

Example #1 注解语法

<?php
// a.php
namespace MyExample;

use Attribute;

#[Attribute]
class MyAttribute
{
    const VALUE = 'value';

    private $value;

    public function __construct($value = null)
    {
        $this->value = $value;
    }
}

// b.php

namespace Another;

use MyExample\MyAttribute;

#[MyAttribute]
#[\MyExample\MyAttribute]
#[MyAttribute(1234)]
#[MyAttribute(value: 1234)]
#[MyAttribute(MyAttribute::VALUE)]
#[MyAttribute(array("key" => "value"))]
#[MyAttribute(100 + 200)]
class Thing
{
}

#[MyAttribute(1234), MyAttribute(5678)]
class AnotherThing
{
}


使用反射 API 读取注解

反射 API 提供了 getAttributes() 方法， 类、方法、函数、参数、属性、类常量的反射对象可通过它获取相应的注解。 该方法返回了 ReflectionAttribute 实例的数组， 可用于查询注解名称、参数、也可以实例化一个注解。

实例和反射注解的分离使得程序员增加了在丢失反射类、类型错误、丢失参数等情况下的处理能力，也能处理错误。 只有调用 newInstance() 后，注解类的对象才会以验证过匹配的参数来实例化。

Example #1 通过反射 API 读取注解

<?php

#[Attribute]
class MyAttribute
{
    public $value;

    public function __construct($value)
    {
        $this->value = $value;
    }
}

#[MyAttribute(value: 1234)]
class Thing
{
}

function dumpAttributeData($reflection) {
    $attributes = $reflection->getAttributes();

    foreach ($attributes as $attribute) {
       var_dump($attribute->getName());
       var_dump($attribute->getArguments());
       var_dump($attribute->newInstance());
    }
}

dumpAttributeData(new ReflectionClass(Thing::class));
/*
string(11) "MyAttribute"
array(1) {
  ["value"]=>
  int(1234)
}
object(MyAttribute)#3 (1) {
  ["value"]=>
  int(1234)
}
*/

通过传入参数：待搜索的注解类名，可返回指定的注解类， 而不需要再到反射类中迭代循环获取所有注解。

Example #2 使用反射 API 读取指定的注解

<?php

function dumpMyAttributeData($reflection) {
    $attributes = $reflection->getAttributes(MyAttribute::class);

    foreach ($attributes as $attribute) {
       var_dump($attribute->getName());
       var_dump($attribute->getArguments());
       var_dump($attribute->newInstance());
    }
}

dumpAttributeData(new ReflectionClass(Thing::class));


声明注解类

虽然没有严格要求，推荐为每个注解创建一个实际的类。 在这个最简单的例子中，通过 use 语法从全局命名空间引入 #[Attribute] 注解所需要全空的类。

Example #1 目标限定使用的注解

<?php

namespace Example;

use Attribute;

#[Attribute]
class MyAttribute
{
}

要限制指定注解的声明类型，可为 #[Attribute] 注解第一个参数传入字节位掩码设置。

Example #2 简单的 Attribute 类

<?php

namespace Example;

use Attribute;

#[Attribute(Attribute::TARGET_METHOD | Attribute::TARGET_FUNCTION)]
class MyAttribute
{
}

在另一个类型中声明 MyAttribute 会在调用 ReflectionAttribute::newInstance() 时抛出异常。

注解在每个声明中默认情况下只能使用一次。 如果需要重复，可以在 #[Attribute] 声明中设置字节位掩码。

Example #3 使用 IS_REPEATABLE 允许注解在声明中出现多次

<?php

namespace Example;

use Attribute;

#[Attribute(Attribute::TARGET_METHOD | Attribute::TARGET_FUNCTION | Attribute::IS_REPEATABLE)]
class MyAttribute
{
}


引用的解释

Table of Contents

  • 引用是什么
  • 引用做什么
  • 引用不是什么
  • 引用传递
  • 引用返回
  • 取消引用
  • 引用定位


引用是什么

在 PHP 中引用意味着用不同的名字访问同一个变量内容。这并不像 C 的指针：例如你不能对他们做指针运算，他们并不是实际的内存地址...... 查看引用不是什么了解更多信息。 替代的是，引用是符号表别名。注意在PHP 中，变量名和变量内容是不一样的， 因此同样的内容可以有不同的名字。最接近的比喻是 Unix 的文件名和文件本身——变量名是目录条目，而变量内容则是文件本身。引用可以被看作是 Unix 文件系统中的硬链接。


引用做什么

There are three basic operations performed using references: assigning by reference, passing by reference, and returning by reference. This section will give an introduction to these operations, with links for further reading.

引用赋值

PHP 的引用允许用两个变量来指向同一个内容。意思是，当这样做时：

<?php
  $a =& $b;
  ?>
这意味着 $a 和 $b 指向了同一个变量。

Note:

$a 和 $b 在这里是完全相同的，这并不是 $a 指向了 $b 或者相反，而是 $a 和 $b 指向了同一个地方。

Note:

如果对一个未定义的变量进行引用赋值、引用参数传递或引用返回，则会自动创建该变量。

Example #1 对未定义的变量使用引用

<?php
function foo(&$var) { }

foo($a); // $a is "created" and assigned to null

$b = array();
foo($b['b']);
var_dump(array_key_exists('b', $b)); // bool(true)

$c = new StdClass;
foo($c->d);
var_dump(property_exists($c, 'd')); // bool(true)
?>

同样的语法可以用在返回引用的函数中：

<?php
$foo =& find_var($bar);
?>
new 会自动返回引用，因此在语法上这样是无效的。 更多信息参见 对象和引用 章节。

Warning

如果在一个函数内部给一个声明为 global 的变量赋于一个引用，该引用只在函数内部可见。可以通过使用 $GLOBALS 数组避免这一点。

Example #2 在函数内引用全局变量

<?php
$var1 = "Example variable";
$var2 = "";

function global_references($use_globals)
{
    global $var1, $var2;
    if (!$use_globals) {
        $var2 =& $var1; // visible only inside the function
    } else {
        $GLOBALS["var2"] =& $var1; // visible also in global context
    }
}

global_references(false);
echo "var2 is set to '$var2'\n"; // var2 is set to ''
global_references(true);
echo "var2 is set to '$var2'\n"; // var2 is set to 'Example variable'
?>
把 global $var; 当成是 $var =& $GLOBALS['var']; 的简写。从而将其它引用赋给 $var 只改变了本地变量的引用。

Note:

如果在 foreach 语句中给一个具有引用的变量赋值，被引用的对象也被改变。

Example #3 引用与 foreach 语句

<?php
$ref = 0;
$row =& $ref;
foreach (array(1, 2, 3) as $row) {
    // do something
}
echo $ref; // 3 - last element of the iterated array
?>

While not being strictly an assignment by reference, expressions created with the language construct array() can also behave as such by prefixing & to the array element to add. Example:

<?php
$a = 1;
$b = array(2, 3);
$arr = array(&$a, &$b[0], &$b[1]);
$arr[0]++; $arr[1]++; $arr[2]++;
/* $a == 2, $b == array(3, 4); */
?>

Note, however, that references inside arrays are potentially dangerous. Doing a normal (not by reference) assignment with a reference on the right side does not turn the left side into a reference, but references inside arrays are preserved in these normal assignments. This also applies to function calls where the array is passed by value. Example:

<?php
/* Assignment of scalar variables */
$a = 1;
$b =& $a;
$c = $b;
$c = 7; //$c is not a reference; no change to $a or $b

/* Assignment of array variables */
$arr = array(1);
$a =& $arr[0]; //$a and $arr[0] are in the same reference set
$arr2 = $arr; //not an assignment-by-reference!
$arr2[0]++;
/* $a == 2, $arr == array(2) */
/* The contents of $arr are changed even though it's not a reference! */
?>
In other words, the reference behavior of arrays is defined in an element-by-element basis; the reference behavior of individual elements is dissociated from the reference status of the array container.

传引用

引用做的第二件事是用引用传递变量。这是通过在函数内建立一个本地变量并且该变量在呼叫范围内引用了同一个内容来实现的。例如：

<?php
function foo(&$var)
{
    $var++;
}

$a=5;
foo($a);
?>
将使 $a 变成 6。这是因为在 foo 函数中变量 $var 指向了和 $a 指向的同一个内容。更多详细解释见引用传递。

引用返回

引用做的第三件事是引用返回。


引用不是什么

如前所述，引用不是指针。这意味着下面的结构不会产生预期的效果：

<?php
function foo(&$var)
{
    $var =& $GLOBALS["baz"];
}
foo($bar);
?>

这将使 foo 函数中的 $var 变量在函数调用时和 $bar 绑定在一起，但接着又被重新绑定到了 $GLOBALS["baz"] 上面。不可能通过引用机制将 $bar 在函数调用范围内绑定到别的变量上面，因为在函数 foo 中并没有变量 $bar（它被表示为 $var，但是 $var 只有变量内容而没有调用符号表中的名字到值的绑定）。可以使用引用返回来引用被函数选择的变量。


引用传递

可以将一个变量通过引用传递给函数，这样该函数就可以修改其参数的值。语法如下：

<?php
function foo(&$var)
{
    $var++;
}

$a=5;
foo($a);
// $a is 6 here
?>
注意在函数调用时没有引用符号——只有函数定义中有。光是函数定义就足够使参数通过引用来正确传递了。

以下内容可以通过引用传递：

  • 变量，例如 foo($a)

  • 从函数中返回的引用，例如：

    <?php
    function foo(&$var)
    {
            $var++;
    }
    function &    bar()
    {
            $a = 5;
        return     $a;
    }
    foo(bar());
    ?>
    详细解释见引用返回。

任何其它表达式都不能通过引用传递，结果未定义。例如下面引用传递的例子是无效的：

<?php
function foo(&$var)
{
    $var++;
}
function bar() // Note the missing &
{
    $a = 5;
    return $a;
}
foo(bar()); // 导致 notice 信息

foo($a = 5) // 表达式，不是变量
foo(5) // 导致致命错误

class Foobar
{
}

foo(new Foobar()) // Produces a notice as of PHP 7.0.7
                  // Notice: Only variables should be passed by reference
?>


引用返回

引用返回用在当想用函数找到引用应该被绑定在哪一个变量上面时。 不要用返回引用来增加性能，引擎足够聪明来自己进行优化。 仅在有合理的技术原因时才返回引用！ 使用此语法返回引用：

<?php
class foo {
    public $value = 42;

    public function &getValue() {
        return $this->value;
    }
}

$obj = new foo;
$myValue = &$obj->getValue(); // $myValue is a reference to $obj->value, which is 42.
$obj->value = 2;
echo $myValue;                // prints the new value of $obj->value, i.e. 2.
?>
本例中 getValue 函数所返回的对象的属性将被赋值， 而不是拷贝，就和没有用引用语法一样。

Note: 和参数传递不同，这里必须在两个地方都用 & 符号——指出返回的是一个引用，而不是通常的一个拷贝，同样也指出 $myValue 是作为引用的绑定，而不是通常的赋值。

Note: 如果试图这样从函数返回引用：return ($this->value);，这将不会起作用， 因为在试图返回一个表达式的结果而不是一个引用的变量。 只能从函数返回引用变量——没别的方法。

To use the returned reference, you must use reference assignment:

<?php
function &collector() {
  static $collection = array();
  return $collection;
}
$collection = &collector();
$collection[] = 'foo';
?>
To pass the returned reference to another function expecting a reference you can use this syntax:
<?php
function &collector() {
  static $collection = array();
  return $collection;
}
array_push(collector(), 'foo');
?>

Note: Note that array_push(&collector(), 'foo'); will not work, it results in a fatal error.


取消引用

当 unset 一个引用，只是断开了变量名和变量内容之间的绑定。这并不意味着变量内容被销毁了。例如：

<?php
$a = 1;
$b =& $a;
unset($a);
?>
不会 unset $b，只是 $a。

再拿这个和 Unix 的 unlink 调用来类比一下可能有助于理解。


引用定位

许多 PHP 的语法结构是通过引用机制实现的，所以上述有关引用绑定的一切也都适用于这些结构。 一些结构，例如引用传递和返回，已经在上面提到了。 其它使用引用的结构有：

global 引用

当用 global $var 声明一个变量时实际上建立了一个到全局变量的引用。 也就是说和这样做是相同的：

<?php
$var =& $GLOBALS["var"];
?>

这意味着，例如，unset $var 不会 unset 全局变量。

$this

在一个对象的方法中，$this 永远是调用它的对象的引用。


预定义变量

对于全部脚本而言，PHP 提供了大量的预定义变量。这些变量将所有的外部变量表示成内建环境变量，并且将错误信息表示成返回头。

Table of Contents

  • 超全局变量 — 超全局变量是在全部作用域中始终可用的内置变量
  • $GLOBALS — 引用全局作用域中可用的全部变量
  • $_SERVER — 服务器和执行环境信息
  • $_GET — HTTP GET 变量
  • $_POST — HTTP POST 变量
  • $_FILES — HTTP 文件上传变量
  • $_REQUEST — HTTP Request 变量
  • $_SESSION — Session 变量
  • $_ENV — 环境变量
  • $_COOKIE — HTTP Cookies
  • $php_errormsg — 前一个错误信息
  • $http_response_header — HTTP 响应头
  • $argc — 传递给脚本的参数数目
  • $argv — 传递给脚本的参数数组


超全局变量是在全部作用域中始终可用的内置变量

  • ? 预定义变量
  • $GLOBALS ?
  • PHP Manual
  • 预定义变量
  • 超全局变量是在全部作用域中始终可用的内置变量

超全局变量

超全局变量 — 超全局变量是在全部作用域中始终可用的内置变量

说明

PHP 中的许多预定义变量都是"超全局的"，这意味着它们在一个脚本的全部作用域中都可用。在函数或方法中无需执行 global $variable; 就可以访问它们。

这些超全局变量是：

  • $GLOBALS
  • $_SERVER
  • $_GET
  • $_POST
  • $_FILES
  • $_COOKIE
  • $_SESSION
  • $_REQUEST
  • $_ENV

注释

Note: 变量可用性

默认情况下，所有的超全局变量都是可用的。但是，有一些指令会影响这种可用性。更多信息，参见文档 variables_order.

Note: 可变变量

在函数或类方法中，超全局变量不能被用作可变变量。

参见

  • 变量作用域
  • variables_order 指令
  • 过滤器扩展


引用全局作用域中可用的全部变量

  • ? 超全局变量
  • $_SERVER ?
  • PHP Manual
  • 预定义变量
  • 引用全局作用域中可用的全部变量

$GLOBALS

$GLOBALS — 引用全局作用域中可用的全部变量

说明

一个包含了全部变量的全局组合数组。变量的名字就是数组的键。

范例

Example #1 $GLOBALS 范例

<?php
function test() {
    $foo = "local variable";

    echo '$foo in global scope: ' . $GLOBALS["foo"] . "\n";
    echo '$foo in current scope: ' . $foo . "\n";
}

$foo = "Example content";
test();
?>

以上例程的输出类似于：

$foo in global scope: Example content
$foo in current scope: local variable

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

Note: 变量可用性

与所有其他超全局变量不同，$GLOBALS在PHP中总是可用的。


服务器和执行环境信息

  • ? $GLOBALS
  • $_GET ?
  • PHP Manual
  • 预定义变量
  • 服务器和执行环境信息

$_SERVER

Server and execution environment information

$_SERVER -- Server and execution environment information — 服务器和执行环境信息

说明

$_SERVER 是一个包含了诸如头信息(header)、路径(path)、以及脚本位置(script locations)等等信息的数组。这个数组中的项目由 Web 服务器创建。不能保证每个服务器都提供全部项目；服务器可能会忽略一些，或者提供一些没有在这里列举出来的项目。这也就意味着大量的此类变量都会在» CGI 1.1 规范中说明，所以应该仔细研究一下。

目录

在 $_SERVER 中，你也许能够，也许不能够找到下面的这些元素。注意，如果以命令行方式运行 PHP，下面列出的元素几乎没有有效的(或是没有任何实际意义的)。

'PHP_SELF'
当前执行脚本的文件名，与 document root 有关。例如，在地址为 http://example.com/foo/bar.php 的脚本中使用 $_SERVER['PHP_SELF'] 将得到 /foo/bar.php。__FILE__ 常量包含当前(例如包含)文件的完整路径和文件名。 如果 PHP 以命令行模式运行，这个变量将包含脚本名。
'argv'
传递给该脚本的参数的数组。当脚本以命令行方式运行时，argv 变量传递给程序 C 语言样式的命令行参数。当通过 GET 方式调用时，该变量包含query string。
'argc'
包含命令行模式下传递给该脚本的参数的数目(如果运行在命令行模式下)。
'GATEWAY_INTERFACE'
服务器使用的 CGI 规范的版本；例如，"CGI/1.1"。
'SERVER_ADDR'
当前运行脚本所在的服务器的 IP 地址。
'SERVER_NAME'
当前运行脚本所在的服务器的主机名。如果脚本运行于虚拟主机中，该名称是由那个虚拟主机所设置的值决定。

Note: 在 Apache 2 里，必须设置 UseCanonicalName = On 和 ServerName。 否则该值会由客户端提供，就有可能被伪造。 上下文有安全性要求的环境里，不应该依赖此值。

'SERVER_SOFTWARE'
服务器标识字符串，在响应请求时的头信息中给出。
'SERVER_PROTOCOL'
请求页面时通信协议的名称和版本。例如，"HTTP/1.0"。
'REQUEST_METHOD'
访问页面使用的请求方法；例如，"GET", "HEAD"，"POST"，"PUT"。

Note:

如果请求方法为 HEAD，PHP 脚本将在发送 Header 头信息之后终止(这意味着在产生任何输出后，不再有输出缓冲)。

'REQUEST_TIME'
请求开始时的时间戳。
'REQUEST_TIME_FLOAT'
请求开始时的时间戳，微秒级别的精准度。
'QUERY_STRING'
query string（查询字符串），如果有的话，通过它进行页面访问。
'DOCUMENT_ROOT'
当前运行脚本所在的文档根目录。在服务器配置文件中定义。
'HTTP_ACCEPT'
当前请求头中 Accept: 项的内容，如果存在的话。
'HTTP_ACCEPT_CHARSET'
当前请求头中 Accept-Charset: 项的内容，如果存在的话。例如："iso-8859-1,*,utf-8"。
'HTTP_ACCEPT_ENCODING'
当前请求头中 Accept-Encoding: 项的内容，如果存在的话。例如："gzip"。
'HTTP_ACCEPT_LANGUAGE'
当前请求头中 Accept-Language: 项的内容，如果存在的话。例如："en"。
'HTTP_CONNECTION'
当前请求头中 Connection: 项的内容，如果存在的话。例如："Keep-Alive"。
'HTTP_HOST'
当前请求头中 Host: 项的内容，如果存在的话。
'HTTP_REFERER'
引导用户代理到当前页的前一页的地址（如果存在）。由 user agent 设置决定。并不是所有的用户代理都会设置该项，有的还提供了修改 HTTP_REFERER 的功能。简言之，该值并不可信。
'HTTP_USER_AGENT'
当前请求头中 User-Agent: 项的内容，如果存在的话。该字符串表明了访问该页面的用户代理的信息。一个典型的例子是：Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586)。除此之外，你可以通过 get_browser() 来使用该值，从而定制页面输出以便适应用户代理的性能。
'HTTPS'
如果脚本是通过 HTTPS 协议被访问，则被设为一个非空的值。
'REMOTE_ADDR'
浏览当前页面的用户的 IP 地址。
'REMOTE_HOST'
浏览当前页面的用户的主机名。DNS 反向解析不依赖于用户的 REMOTE_ADDR。

Note: 你的服务器必须被配置以便产生这个变量。例如在 Apache 中，你需要在 httpd.conf 中设置 HostnameLookups On 来产生它。参见 gethostbyaddr()。

'REMOTE_PORT'
用户机器上连接到 Web 服务器所使用的端口号。
'REMOTE_USER'
经验证的用户
'REDIRECT_REMOTE_USER'
验证的用户，如果请求已在内部重定向。
'SCRIPT_FILENAME'

当前执行脚本的绝对路径。

Note:

如果在命令行界面（Command Line Interface, CLI）使用相对路径执行脚本，例如 file.php 或 ../file.php，那么 $_SERVER['SCRIPT_FILENAME'] 将包含用户指定的相对路径。

'SERVER_ADMIN'
该值指明了 Apache 服务器配置文件中的 SERVER_ADMIN 参数。如果脚本运行在一个虚拟主机上，则该值是那个虚拟主机的值。
'SERVER_PORT'
Web 服务器使用的端口。默认值为 "80"。如果使用 SSL 安全连接，则这个值为用户设置的 HTTP 端口。

Note: 在 Apache 2 里，为了获取真实物理端口，必须设置 UseCanonicalName = On 以及 UseCanonicalPhysicalPort = On。 否则此值可能被伪造，不一定会返回真实端口值。 上下文有安全性要求的环境里，不应该依赖此值。

'SERVER_SIGNATURE'
包含了服务器版本和虚拟主机名的字符串。
'PATH_TRANSLATED'
当前脚本所在文件系统（非文档根目录）的基本路径。这是在服务器进行虚拟到真实路径的映像后的结果。

Note: Apache 2 用户可以在 httpd.conf 中设置 AcceptPathInfo = On 来定义 PATH_INFO。

'SCRIPT_NAME'
包含当前脚本的路径。这在页面需要指向自己时非常有用。__FILE__ 常量包含当前脚本(例如包含文件)的完整路径和文件名。
'REQUEST_URI'
URI 用来指定要访问的页面。例如 "/index.html"。
'PHP_AUTH_DIGEST'
当作为 Apache 模块运行时，进行 HTTP Digest 认证的过程中，此变量被设置成客户端发送的"Authorization" HTTP 头内容（以便作进一步的认证操作）。
'PHP_AUTH_USER'
当 PHP 运行在 Apache 或 IIS（PHP 5 是 ISAPI）模块方式下，并且正在使用 HTTP 认证功能，这个变量便是用户输入的用户名。
'PHP_AUTH_PW'
当 PHP 运行在 Apache 或 IIS（PHP 5 是 ISAPI）模块方式下，并且正在使用 HTTP 认证功能，这个变量便是用户输入的密码。
'AUTH_TYPE'
当 PHP 运行在 Apache 模块方式下，并且正在使用 HTTP 认证功能，这个变量便是认证的类型。
'PATH_INFO'
包含由客户端提供的、跟在真实脚本名称之后并且在查询语句（query string）之前的路径信息，如果存在的话。例如，如果当前脚本是通过 URL http://www.example.com/php/path_info.php/some/stuff?foo=bar 被访问，那么 $_SERVER['PATH_INFO'] 将包含 /some/stuff。
'ORIG_PATH_INFO'
在被 PHP 处理之前，"PATH_INFO" 的原始版本。

范例

Example #1 $_SERVER 范例

<?php
echo $_SERVER['SERVER_NAME'];
?>

以上例程的输出类似于：

www.example.com

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

参见

  • 过滤器扩展


HTTP GET 变量

  • ? $_SERVER
  • $_POST ?
  • PHP Manual
  • 预定义变量
  • HTTP GET 变量

$_GET

$HTTP_GET_VARS [已弃用]

$_GET -- $HTTP_GET_VARS [已弃用] — HTTP GET 变量

说明

通过 URL 参数（又叫 query string）传递给当前脚本的变量的数组。 注意：该数组不仅仅对 method 为 GET 的请求生效，而是会针对所有带 query string 的请求。

$HTTP_GET_VARS 包含相同的信息， 但它不是一个超全局变量。 (注意 $HTTP_GET_VARS 和 $_GET 是不同的变量，PHP 处理它们的方式不同)

范例

Example #1 $_GET 范例

<?php
echo 'Hello ' . htmlspecialchars($_GET["name"]) . '!';
?>

假设用户访问的是 http://example.com/?name=Hannes

以上例程的输出类似于：

Hello Hannes!

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

Note:

GET 是通过 urldecode() 传递的。

参见

  • 处理外部变量
  • 过滤器扩展


HTTP POST 变量

  • ? $_GET
  • $_FILES ?
  • PHP Manual
  • 预定义变量
  • HTTP POST 变量

$_POST

$HTTP_POST_VARS [已弃用]

$_POST -- $HTTP_POST_VARS [已弃用] — HTTP POST 变量

说明

当 HTTP POST 请求的 Content-Type 是 application/x-www-form-urlencoded 或 multipart/form-data 时，会将变量以关联数组形式传入当前脚本。

$HTTP_POST_VARS 包含相同的信息，但它不是一个超全局变量。 (注意 $HTTP_POST_VARS 和 $_POST 是不同的变量，PHP 处理它们的方式不同)

范例

Example #1 $_POST 范例

<?php
echo 'Hello ' . htmlspecialchars($_POST["name"]) . '!';
?>

假设用户通过 HTTP POST 方式传递了参数 name=Hannes

以上例程的输出类似于：

Hello Hannes!

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

参见

  • 处理外部变量
  • 过滤器扩展


HTTP 文件上传变量

  • ? $_POST
  • $_REQUEST ?
  • PHP Manual
  • 预定义变量
  • HTTP 文件上传变量

$_FILES

$HTTP_POST_FILES [已弃用]

$_FILES -- $HTTP_POST_FILES [已弃用] — HTTP 文件上传变量

说明

通过 HTTP POST 方式上传到当前脚本的项目的数组。 此数组的概况在 POST 方法上传 章节中有描述。

$HTTP_POST_FILES 包含相同的信息，但它不是一个超全局变量。 (注意 $HTTP_POST_FILES 和 $_FILES 是不同的变量，PHP 处理它们的方式不同)

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

参见

  • move_uploaded_file() - 将上传的文件移动到新位置
  • 处理文件上传


HTTP Request 变量

  • ? $_FILES
  • $_SESSION ?
  • PHP Manual
  • 预定义变量
  • HTTP Request 变量

$_REQUEST

$_REQUEST — HTTP Request 变量

说明

默认情况下包含了 $_GET，$_POST 和 $_COOKIE 的数组。

更新日志

版本 | 说明
5.3.0 | 引入 request_order。该指令会影响 $_REQUEST 的内容。

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

Note:

以命令行方式运行时，将不包含 argv 和 argc 信息；它们将存在于 $_SERVER 数组。

Note:

由于 $_REQUEST 中的变量通过 GET，POST 和 COOKIE 输入机制传递给脚本文件，因此可以被远程用户篡改而并不可信。这个数组的项目及其顺序依赖于 PHP 的 variables_order 指令的配置。

参见

  • import_request_variables()
  • 处理外部变量
  • 过滤器扩展


Session 变量

  • ? $_REQUEST
  • $_ENV ?
  • PHP Manual
  • 预定义变量
  • Session 变量

$_SESSION

$HTTP_SESSION_VARS [已弃用]

$_SESSION -- $HTTP_SESSION_VARS [已弃用] — Session 变量

说明

当前脚本可用 SESSION 变量的数组。更多关于如何使用的信息，参见 Session 函数 文档。

$HTTP_SESSION_VARS 包含相同的信息，但它不是一个超全局变量。 (注意 $HTTP_SESSION_VARS 和 $_SESSION 是不同的变量，PHP 处理它们的方式不同)

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

参见

  • session_start() - 启动新会话或者重用现有会话


环境变量

  • ? $_SESSION
  • $_COOKIE ?
  • PHP Manual
  • 预定义变量
  • 环境变量

$_ENV

$HTTP_ENV_VARS [已弃用]

$_ENV -- $HTTP_ENV_VARS [已弃用] — 环境变量

说明

通过环境方式传递给当前脚本的变量的数组。

这些变量被从 PHP 解析器的运行环境导入到 PHP 的全局命名空间。很多是由支持 PHP 运行的 Shell 提供的，并且不同的系统很可能运行着不同种类的 Shell，所以不可能有一份确定的列表。请查看你的 Shell 文档来获取定义的环境变量列表。

其他环境变量包含了 CGI 变量，而不管 PHP 是以服务器模块还是 CGI 处理器的方式运行。

$HTTP_ENV_VARS 包含相同的信息，但它不是一个超全局变量。 (注意 $HTTP_ENV_VARS 和 $_ENV 是不同的变量，PHP 处理它们的方式不同)

范例

Example #1 $_ENV 范例

<?php
echo 'My username is ' .$_ENV["USER"] . '!';
?>

假设 "bjori" 运行此段脚本

以上例程的输出类似于：

My username is bjori!

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

参见

  • getenv() - 获取一个环境变量的值
  • 过滤器扩展


HTTP Cookies

  • ? $_ENV
  • $php_errormsg ?
  • PHP Manual
  • 预定义变量
  • HTTP Cookies

$_COOKIE

$HTTP_COOKIE_VARS [已弃用]

$_COOKIE -- $HTTP_COOKIE_VARS [已弃用] — HTTP Cookies

说明

通过 HTTP Cookies 方式传递给当前脚本的变量的数组。

$HTTP_COOKIE_VARS 包含相同的信息，但它不是一个超全局变量。 (注意 $HTTP_COOKIE_VARS 和 $_COOKIE 是不同的变量，PHP 处理它们的方式不同)

范例

Example #1 $_COOKIE 范例

<?php
echo 'Hello ' . htmlspecialchars($_COOKIE["name"]) . '!';
?>

假设之前发送了 "name" Cookie

以上例程的输出类似于：

Hello Hannes!

注释

Note:

"Superglobal"也称为自动化的全局变量。这就表示其在脚本的所有作用域中都是可用的。不需要在函数或方法中用 global $variable; 来访问它。

参见

  • setcookie() - 发送 Cookie
  • 处理外部变量
  • 过滤器扩展


前一个错误信息

  • ? $_COOKIE
  • $http_response_header ?
  • PHP Manual
  • 预定义变量
  • 前一个错误信息

$php_errormsg

$php_errormsg — 前一个错误信息

Warning

本特性已自 PHP 7.2.0 起废弃。强烈建议不要使用本特性。

用 error_get_last() 函数代替。

说明

$php_errormsg 变量包含由 PHP 生成的最新错误信息。这个变量只在错误发生的作用域内可用，并且要求 track_errors 配置项是开启的（默认是关闭的）。

Warning

如果用户定义了错误处理句柄（set_error_handler()）并且返回 false 的时候，$php_errormsg 就会被设置。

范例

Example #1 $php_errormsg 范例

<?php
@strpos();
echo $php_errormsg;
?>

以上例程的输出类似于：

Wrong parameter count for strpos()

参见

  • error_get_last() - 获取最后发生的错误


HTTP 响应头

  • ? $php_errormsg
  • $argc ?
  • PHP Manual
  • 预定义变量
  • HTTP 响应头

$http_response_header

$http_response_header — HTTP 响应头

说明

$http_response_header 数组与 get_headers() 函数类似。当使用HTTP 包装器时，$http_response_header 将会被 HTTP 响应头信息填充。$http_response_header 将被创建于局部作用域中。

范例

Example #1 $http_response_header 范例

<?php
function get_contents() {
  file_get_contents("http://example.com");
  var_dump($http_response_header);
}
get_contents();
var_dump($http_response_header);
?>

以上例程的输出类似于：

array(9) {
  [0]=>
  string(15) "HTTP/1.1 200 OK"
  [1]=>
  string(35) "Date: Sat, 12 Apr 2008 17:30:38 GMT"
  [2]=>
  string(29) "Server: Apache/2.2.3 (CentOS)"
  [3]=>
  string(44) "Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT"
  [4]=>
  string(27) "ETag: "280100-1b6-80bfd280""
  [5]=>
  string(20) "Accept-Ranges: bytes"
  [6]=>
  string(19) "Content-Length: 438"
  [7]=>
  string(17) "Connection: close"
  [8]=>
  string(38) "Content-Type: text/html; CHARSET=gb2312"
}
NULL


传递给脚本的参数数目

  • ? $http_response_header
  • $argv ?
  • PHP Manual
  • 预定义变量
  • 传递给脚本的参数数目

$argc

$argc — 传递给脚本的参数数目

说明

包含当运行于命令行下时传递给当前脚本的参数的数目。

Note: 脚本的文件名总是作为参数传递给当前脚本，因此 $argc 的最小值为 1。

Note: 这个变量仅在 register_argc_argv 打开时可用。

范例

Example #1 $argc 范例

<?php
var_dump($argc);
?>

当使用这个命令执行: php script.php arg1 arg2 arg3

以上例程的输出类似于：

int(4)

注释

Note:

也可以在 $_SERVER['argc'] 中获取。

参见

  • getopt() - 从命令行参数列表中获取选项


传递给脚本的参数数组

  • ? $argc
  • 预定义异常 ?
  • PHP Manual
  • 预定义变量
  • 传递给脚本的参数数组

$argv

$argv — 传递给脚本的参数数组

说明

包含当运行于命令行下时传递给当前脚本的参数的数组。

Note: 第一个参数总是当前脚本的文件名，因此 $argv[0] 就是脚本文件名。

Note: 这个变量仅在 register_argc_argv 打开时可用。

范例

Example #1 $argv 范例

<?php
var_dump($argv);
?>

当使用这个命令执行：php script.php arg1 arg2 arg3

以上例程的输出类似于：

array(4) {
  [0]=>
  string(10) "script.php"
  [1]=>
  string(4) "arg1"
  [2]=>
  string(4) "arg2"
  [3]=>
  string(4) "arg3"
}

参见

  • getopt() - 从命令行参数列表中获取选项


预定义异常

Table of Contents

  • Exception
  • ErrorException
  • Error
  • ArgumentCountError
  • ArithmeticError
  • AssertionError
  • DivisionByZeroError
  • CompileError
  • ParseError
  • TypeError

参见 SPL 异常处理


Exception

(PHP 5, PHP 7, PHP 8)

简介

Exception是所有异常的基类。

类摘要

Exception {
/* 属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
public __construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public getMessage ( ) : string
final public getPrevious ( ) : Throwable
final public getCode ( ) : mixed
final public getFile ( ) : string
final public getLine ( ) : int
final public getTrace ( ) : array
final public getTraceAsString ( ) : string
public __toString ( ) : string
final private __clone ( ) : void
}

属性

message

异常消息内容

code

异常代码

file

抛出异常的文件名

line

抛出异常在该文件中的行号

Table of Contents

  • Exception::__construct — 异常构造函数
  • Exception::getMessage — 获取异常消息内容
  • Exception::getPrevious — 返回异常链中的前一个异常
  • Exception::getCode — 获取异常代码
  • Exception::getFile — 创建异常时的程序文件名称
  • Exception::getLine — 获取创建的异常所在文件中的行号
  • Exception::getTrace — 获取异常追踪信息
  • Exception::getTraceAsString — 获取字符串类型的异常追踪信息
  • Exception::__toString — 将异常对象转换为字符串
  • Exception::__clone — 异常克隆


异常构造函数

  • ? Exception
  • Exception::getMessage ?
  • PHP Manual
  • Exception
  • 异常构造函数

Exception::__construct

(PHP 5, PHP 7, PHP 8)

Exception::__construct — 异常构造函数

说明

public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )

异常构造函数。

参数

message

抛出的异常消息内容。

code

异常代码。

previous

异常链中的前一个异常。

Note: 如果子类的 $code 和 $message 属性已设置，在调用 Exception 父类的构造器时可以省略默认参数。

更新日志

版本 | 说明
7.0.0 | previous 参数现在是 Throwable 类型了。
5.3.0 | 增加previous参数。

注释

Note:

The message is NOT binary safe.


获取异常消息内容

  • ? Exception::__construct
  • Exception::getPrevious ?
  • PHP Manual
  • Exception
  • 获取异常消息内容

Exception::getMessage

(PHP 5, PHP 7, PHP 8)

Exception::getMessage — 获取异常消息内容

说明

final public Exception::getMessage ( ) : string

返回异常消息内容。

参数

此函数没有参数。

返回值

返回字符串类型的异常消息内容。

范例

Example #1 Exception::getMessage()示例

<?php
try {
    throw new Exception("Some error message");
} catch(Exception $e) {
    echo $e->getMessage();
}
?>

以上例程的输出类似于：

Some error message

参见

  • Throwable::getMessage()


返回异常链中的前一个异常

  • ? Exception::getMessage
  • Exception::getCode ?
  • PHP Manual
  • Exception
  • 返回异常链中的前一个异常

Exception::getPrevious

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Exception::getPrevious — 返回异常链中的前一个异常

说明

final public Exception::getPrevious ( ) : Throwable

返回异常链中的前一个异常（Exception::__construct()方法的第三个参数）。

参数

此函数没有参数。

返回值

返回异常链中的前一个异常 Throwable，否则返回null。

更新日志

版本 | 说明
7.0.0 | 返回类型的定义改成了 Throwable。

范例

Example #1 Exception::getPrevious()示例

追踪异常，并循环打印。

<?php
class MyCustomException extends Exception {}

function doStuff() {
    try {
        throw new InvalidArgumentException("You are doing it wrong!", 112);
    } catch(Exception $e) {
        throw new MyCustomException("Something happend", 911, $e);
    }
}

try {
    doStuff();
} catch(Exception $e) {
    do {
        printf("%s:%d %s (%d) [%s]\n", $e->getFile(), $e->getLine(), $e->getMessage(), $e->getCode(), get_class($e));
    } while($e = $e->getPrevious());
}
?>

以上例程的输出类似于：

/home/bjori/ex.php:8 Something happend (911) [MyCustomException]
/home/bjori/ex.php:6 You are doing it wrong! (112) [InvalidArgumentException]

参见

  • Throwable::getPrevious()


获取异常代码

  • ? Exception::getPrevious
  • Exception::getFile ?
  • PHP Manual
  • Exception
  • 获取异常代码

Exception::getCode

(PHP 5, PHP 7, PHP 8)

Exception::getCode — 获取异常代码

说明

final public Exception::getCode ( ) : mixed

返回异常代码。

参数

此函数没有参数。

返回值

Exception 返回整型（int）的异常代码，但在其他类中可能返回其他类型(比如在 PDOException 中返回 string)。

范例

Example #1 Exception::getCode()示例

<?php
try {
    throw new Exception("Some error message", 30);
} catch(Exception $e) {
    echo "The exception code is: " . $e->getCode();
}
?>

以上例程的输出类似于：

The exception code is: 30

参见

  • Throwable::getCode()


创建异常时的程序文件名称

  • ? Exception::getCode
  • Exception::getLine ?
  • PHP Manual
  • Exception
  • 创建异常时的程序文件名称

Exception::getFile

(PHP 5, PHP 7, PHP 8)

Exception::getFile — 创建异常时的程序文件名称

说明

final public Exception::getFile ( ) : string

获取创建异常的程序文件名称。

参数

此函数没有参数。

返回值

返回发生异常的程序文件名称。

范例

Example #1 Exception::getFile()示例

<?php
try {
    throw new Exception;
} catch(Exception $e) {
    echo $e->getFile();
}
?>

以上例程的输出类似于：

/home/bjori/tmp/ex.php

参见

  • Throwable::getFile()


获取创建的异常所在文件中的行号

  • ? Exception::getFile
  • Exception::getTrace ?
  • PHP Manual
  • Exception
  • 获取创建的异常所在文件中的行号

Exception::getLine

(PHP 5, PHP 7, PHP 8)

Exception::getLine — 获取创建的异常所在文件中的行号

说明

final public Exception::getLine ( ) : int

返回发生异常的代码在文件中的行号。

参数

此函数没有参数。

返回值

返回发生异常的代码在文件中的行号。

范例

Example #1 Exception::getLine()示例

<?php
try {
    throw new Exception("Some error message");
} catch(Exception $e) {
    echo "The exception was thrown on line: " . $e->getLine();
}
?>

以上例程的输出类似于：

The exception was thrown on line: 3

参见

  • Throwable::getLine()


获取异常追踪信息

  • ? Exception::getLine
  • Exception::getTraceAsString ?
  • PHP Manual
  • Exception
  • 获取异常追踪信息

Exception::getTrace

(PHP 5, PHP 7, PHP 8)

Exception::getTrace — 获取异常追踪信息

说明

final public Exception::getTrace ( ) : array

返回异常追踪信息。

参数

此函数没有参数。

返回值

返回包含异常追踪信息的数组（array）。

范例

Example #1 Exception::getTrace()示例

<?php
function test() {
 throw new Exception;
}

try {
 test();
} catch(Exception $e) {
 var_dump($e->getTrace());
}
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["file"]=>
    string(22) "/home/bjori/tmp/ex.php"
    ["line"]=>
    int(7)
    ["function"]=>
    string(4) "test"
    ["args"]=>
    array(0) {
    }
  }
}

参见

  • Throwable::getTrace()


获取字符串类型的异常追踪信息

  • ? Exception::getTrace
  • Exception::__toString ?
  • PHP Manual
  • Exception
  • 获取字符串类型的异常追踪信息

Exception::getTraceAsString

(PHP 5, PHP 7, PHP 8)

Exception::getTraceAsString — 获取字符串类型的异常追踪信息

说明

final public Exception::getTraceAsString ( ) : string

以字符串类型返回异常追踪信息。

参数

此函数没有参数。

返回值

以字符串类型返回异常追踪信息。

范例

Example #1 Exception::getTraceAsString()示例

<?php
function test() {
    throw new Exception;
}

try {
    test();
} catch(Exception $e) {
    echo $e->getTraceAsString();
}
?>

以上例程的输出类似于：

#0 /home/bjori/tmp/ex.php(7): test()
#1 {main}

参见

  • Throwable::getTraceAsString()


将异常对象转换为字符串

  • ? Exception::getTraceAsString
  • Exception::__clone ?
  • PHP Manual
  • Exception
  • 将异常对象转换为字符串

Exception::__toString

(PHP 5, PHP 7, PHP 8)

Exception::__toString — 将异常对象转换为字符串

说明

public Exception::__toString ( ) : string

返回转换为字符串（string）类型的异常。

参数

此函数没有参数。

返回值

返回转换为字符串（string）类型的异常。

范例

Example #1 Exception::__toString()示例

<?php
try {
    throw new Exception("Some error message");
} catch(Exception $e) {
    echo $e;
}
?>

以上例程的输出类似于：

exception 'Exception' with message 'Some error message' in /home/bjori/tmp/ex.php:3
Stack trace:
#0 {main}

参见

  • Throwable::__toString()


异常克隆

  • ? Exception::__toString
  • ErrorException ?
  • PHP Manual
  • Exception
  • 异常克隆

Exception::__clone

(PHP 5, PHP 7, PHP 8)

Exception::__clone — 异常克隆

说明

final private Exception::__clone ( ) : void

尝试克隆异常，这将导致一个致命错误。

参数

此函数没有参数。

返回值

没有返回值。

错误／异常

异常被不允许克隆。


ErrorException

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

简介

错误异常。

类摘要

ErrorException extends Exception {
/* 属性 */
protected int $severity ;
/* 方法 */
public __construct ( string $message = "" , int $code = 0 , int $severity = E_ERROR , string $filename = __FILE__ , int $lineno = __LINE__ , Exception $previous = null )
final public getSeverity ( ) : int
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

severity

异常级别

范例

Example #1 使用set_error_handler()函数将错误信息托管至ErrorException

<?php
function exception_error_handler($errno, $errstr, $errfile, $errline ) {
    throw new ErrorException($errstr, 0, $errno, $errfile, $errline);
}
set_error_handler("exception_error_handler");

/* Trigger exception */
strpos();
?>

以上例程的输出类似于：

Fatal error: Uncaught exception 'ErrorException' with message 'Wrong parameter count for strpos()' in /home/bjori/tmp/ex.php:8
Stack trace:
#0 [internal function]: exception_error_handler(2, 'Wrong parameter...', '/home/bjori/php...', 8, Array)
#1 /home/bjori/php/cleandocs/test.php(8): strpos()
#2 {main}
  thrown in /home/bjori/tmp/ex.php on line 8

Table of Contents

  • ErrorException::__construct — 构造一个异常（Exception）
  • ErrorException::getSeverity — 获取异常的严重程度


构造一个异常（Exception）

  • ? ErrorException
  • ErrorException::getSeverity ?
  • PHP Manual
  • ErrorException
  • 构造一个异常（Exception）

ErrorException::__construct

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

ErrorException::__construct — 构造一个异常（Exception）

说明

public ErrorException::__construct ( string $message = "" , int $code = 0 , int $severity = E_ERROR , string $filename = __FILE__ , int $lineno = __LINE__ , Exception $previous = null )

构造一个异常（Exception）。

参数

message

抛出的异常消息内容。

code

异常代码。

severity

异常的严重级别。

Note:

severity 可以是任意 integer 值，即错误常量里面的值。

filename

抛出异常所在的文件名。

lineno

抛出异常所在的行号。

previous

异常链中的前一个异常。

更新日志

版本 | 说明
5.3.0 | 增加 previous 参数。


获取异常的严重程度

  • ? ErrorException::__construct
  • Error ?
  • PHP Manual
  • ErrorException
  • 获取异常的严重程度

ErrorException::getSeverity

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

ErrorException::getSeverity — 获取异常的严重程度

说明

final public ErrorException::getSeverity ( ) : int

返回异常的严重程度。

参数

此函数没有参数。

返回值

返回异常的严重级别。

范例

Example #1 ErrorException::getSeverity() 例子

<?php
try {
    throw new ErrorException("Exception message", 0, E_USER_ERROR);
} catch(ErrorException $e) {
    echo "This exception severity is: " . $e->getSeverity();
    var_dump($e->getSeverity() === E_USER_ERROR);
}
?>

以上例程的输出类似于：

This exception severity is: 256
bool(true)


Error

(PHP 7, PHP 8)

简介

Error 是所有PHP内部错误类的基类。

类摘要

Error implements Throwable {
/* 属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
public __construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public getMessage ( ) : string
final public getPrevious ( ) : Throwable
final public getCode ( ) : mixed
final public getFile ( ) : string
final public getLine ( ) : int
final public getTrace ( ) : array
final public getTraceAsString ( ) : string
public __toString ( ) : string
final private __clone ( ) : void
}

属性

message

错误消息内容

code

错误代码

file

抛出错误的文件名

line

抛出错误的行数

Table of Contents

  • Error::__construct — 初始化 error 对象
  • Error::getMessage — 获取错误信息
  • Error::getPrevious — 返回先前的 Throwable
  • Error::getCode — 获取错误代码
  • Error::getFile — 获取错误发生时的文件
  • Error::getLine — 获取错误发生时的行号
  • Error::getTrace — 获取调用栈（stack trace）
  • Error::getTraceAsString — 获取字符串形式的调用栈（stack trace）
  • Error::__toString — error 的字符串表达
  • Error::__clone — 克隆 error


初始化 error 对象

  • ? Error
  • Error::getMessage ?
  • PHP Manual
  • Error
  • 初始化 error 对象

Error::__construct

(PHP 7, PHP 8)

Error::__construct — 初始化 error 对象

说明

public Error::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )

初始化 Error。

参数

message

错误信息。

code

错误代码。

previous

先前的 throwable，用于异常链。

注释

Note:

message 不是二进制安全的。


获取错误信息

  • ? Error::__construct
  • Error::getPrevious ?
  • PHP Manual
  • Error
  • 获取错误信息

Error::getMessage

(PHP 7, PHP 8)

Error::getMessage — 获取错误信息

说明

final public Error::getMessage ( ) : string

返回错误信息。

参数

此函数没有参数。

返回值

返回字符串错误信息。

范例

Example #1 Error::getMessage() 例子

<?php
try {
    throw new Error("Some error message");
} catch(Error $e) {
    echo $e->getMessage();
}
?>

以上例程的输出类似于：

Some error message

参见

  • Throwable::getMessage()


返回先前的 Throwable

  • ? Error::getMessage
  • Error::getCode ?
  • PHP Manual
  • Error
  • 返回先前的 Throwable

Error::getPrevious

(PHP 7, PHP 8)

Error::getPrevious — 返回先前的 Throwable

说明

final public Error::getPrevious ( ) : Throwable

返回先前的 Throwable（Error::__construct() 的第三个参数）。

参数

此函数没有参数。

返回值

如果有的话，返回先前的 Throwable，没有就返回 null。 or null otherwise.

范例

Example #1 Error::getPrevious() 例子

循环输出错误栈。

<?php
class MyCustomError extends Error {}

function doStuff() {
    try {
        throw new InvalidArgumentError("You are doing it wrong!", 112);
    } catch(Error $e) {
        throw new MyCustomError("Something happened", 911, $e);
    }
}

try {
    doStuff();
} catch(Error $e) {
    do {
        printf("%s:%d %s (%d) [%s]\n", $e->getFile(), $e->getLine(), $e->getMessage(), $e->getCode(), get_class($e));
    } while($e = $e->getPrevious());
}
?>

以上例程的输出类似于：

/home/bjori/ex.php:8 Something happened (911) [MyCustomError]
/home/bjori/ex.php:6 You are doing it wrong! (112) [InvalidArgumentError]

参见

  • Throwable::getPrevious()


获取错误代码

  • ? Error::getPrevious
  • Error::getFile ?
  • PHP Manual
  • Error
  • 获取错误代码

Error::getCode

(PHP 7, PHP 8)

Error::getCode — 获取错误代码

说明

final public Error::getCode ( ) : mixed

返回错误代码。

参数

此函数没有参数。

返回值

返回 integer 的错误代码

范例

Example #1 Error::getCode() 例子

<?php
try {
    throw new Error("Some error message", 30);
} catch(Error $e) {
    echo "The Error code is: " . $e->getCode();
}
?>

以上例程的输出类似于：

The Error code is: 30

参见

  • Throwable::getCode()


获取错误发生时的文件

  • ? Error::getCode
  • Error::getLine ?
  • PHP Manual
  • Error
  • 获取错误发生时的文件

Error::getFile

(PHP 7, PHP 8)

Error::getFile — 获取错误发生时的文件

说明

final public Error::getFile ( ) : string

获取错误发生时的文件名称。

参数

此函数没有参数。

返回值

返回错误发生时的文件名。

范例

Example #1 Error::getFile() 例子

<?php
try {
    throw new Error;
} catch(Error $e) {
    echo $e->getFile();
}
?>

以上例程的输出类似于：

/home/bjori/tmp/ex.php

参见

  • Throwable::getFile()


获取错误发生时的行号

  • ? Error::getFile
  • Error::getTrace ?
  • PHP Manual
  • Error
  • 获取错误发生时的行号

Error::getLine

(PHP 7, PHP 8)

Error::getLine — 获取错误发生时的行号

说明

final public Error::getLine ( ) : int

获取错误发生时的行号。

参数

此函数没有参数。

返回值

返回错误发生时的行号。

范例

Example #1 Error::getLine() 例子

<?php
try {
    throw new Error("Some error message");
} catch(Error $e) {
    echo "The error was created on line: " . $e->getLine();
}
?>

以上例程的输出类似于：

The error was created on line: 3

参见

  • Throwable::getLine()


获取调用栈（stack trace）

  • ? Error::getLine
  • Error::getTraceAsString ?
  • PHP Manual
  • Error
  • 获取调用栈（stack trace）

Error::getTrace

(PHP 7, PHP 8)

Error::getTrace — 获取调用栈（stack trace）

说明

final public Error::getTrace ( ) : array

返回 stack trace。

参数

此函数没有参数。

返回值

返回 array 的 stack trace。

范例

Example #1 Error::getTrace() 例子

<?php
function test() {
 throw new Error;
}

try {
 test();
} catch(Error $e) {
 var_dump($e->getTrace());
}
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["file"]=>
    string(22) "/home/bjori/tmp/ex.php"
    ["line"]=>
    int(7)
    ["function"]=>
    string(4) "test"
    ["args"]=>
    array(0) {
    }
  }
}

参见

  • Throwable::getTrace()


获取字符串形式的调用栈（stack trace）

  • ? Error::getTrace
  • Error::__toString ?
  • PHP Manual
  • Error
  • 获取字符串形式的调用栈（stack trace）

Error::getTraceAsString

(PHP 7, PHP 8)

Error::getTraceAsString — 获取字符串形式的调用栈（stack trace）

说明

final public Error::getTraceAsString ( ) : string

以字符串形式返回 stack trace。

参数

此函数没有参数。

返回值

以字符串形式返回 stack trace。

范例

Example #1 Error::getTraceAsString() 例子

<?php
function test() {
    throw new Error;
}

try {
    test();
} catch(Error $e) {
    echo $e->getTraceAsString();
}
?>

以上例程的输出类似于：

#0 /home/bjori/tmp/ex.php(7): test()
#1 {main}

参见

  • Throwable::getTraceAsString()


error 的字符串表达

  • ? Error::getTraceAsString
  • Error::__clone ?
  • PHP Manual
  • Error
  • error 的字符串表达

Error::__toString

(PHP 7, PHP 8)

Error::__toString — error 的字符串表达

说明

public Error::__toString ( ) : string

返回 Error 的 string表达形式。

参数

此函数没有参数。

返回值

返回 Error 的 string表达形式。

范例

Example #1 Error::__toString() 例子

<?php
try {
    throw new Error("Some error message");
} catch(Error $e) {
    echo $e;
}
?>

以上例程的输出类似于：

Error: Some error message in /home/bjori/tmp/ex.php:3
Stack trace:
#0 {main}

参见

  • Throwable::__toString()


克隆 error

  • ? Error::__toString
  • ArgumentCountError ?
  • PHP Manual
  • Error
  • 克隆 error

Error::__clone

(PHP 7, PHP 8)

Error::__clone — 克隆 error

说明

final private Error::__clone ( ) : void

Error 无法被克隆，调用该方法会导致 fatal error。

参数

此函数没有参数。

返回值

没有返回值。

错误／异常

Error 无法被克隆。


ArgumentCountError

(PHP 7 >= PHP 7.1.0, PHP 8)

简介

ArgumentCountError 当传递给用户定义的函数或方法的参数太少时被抛出。

类摘要

ArgumentCountError extends TypeError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


ArithmeticError

(PHP 7, PHP 8)

简介

ArithmeticError 当执行数学运算时发生错误时被抛出。PHP 7.0 these errors include attempting to perform a bitshift by a negative amount, and any call to intdiv() that would result in a value outside the possible bounds of an integer.

类摘要

ArithmeticError extends Error {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


AssertionError

(PHP 7, PHP 8)

简介

AssertionError 在函数 assert() 断言失败时被抛出。

类摘要

AssertionError extends Error {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


DivisionByZeroError

(PHP 7, PHP 8)

简介

DivisionByZeroError 当除数为零时被抛出。

类摘要

DivisionByZeroError extends ArithmeticError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


CompileError

(PHP 7 > 7.3.0, PHP 8)

简介

CompileError 是针对一些编译错误抛出的，之前是会发出致命错误。

类摘要

CompileError extends Error {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


ParseError

(PHP 7, PHP 8)

简介

ParseError 当解析 PHP 代码时发生错误时抛出，比如当 eval()被调用出错时。

Note: 从 PHP 7.3.0 开始，ParseError 继承自 CompileError。之前的版本，则继承自 Error。

类摘要

ParseError extends CompileError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


TypeError

(PHP 7, PHP 8)

简介

有三种情况会抛出 TypeError。第一种，传递给函数的参数类型与函数预期声明的参数类型不匹配；第二种，函数返回的值与声明的函数返回类型不匹配；第三种，调用 PHP 内置函数时，传递了非法的数字参数（仅限在严格模式下 / strict mode）。

类摘要

TypeError extends Error {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


预定义接口

Table of Contents

  • 遍历
  • 迭代器
  • 聚合式迭代器
  • 数组式访问
  • 序列化
  • Closure
  • 生成器

参见 SPL 接口 和 预定义类


Traversable（遍历）接口

(No version information available, might only be in Git)

简介

检测一个类是否可以使用 foreach 进行遍历的接口。

无法被单独实现的基本抽象接口。相反它必须由 IteratorAggregate 或 Iterator 接口实现。

Note:

实现此接口的内建类可以使用 foreach 进行遍历而无需实现 IteratorAggregate 或 Iterator 接口。

Note:

这是一个无法在 PHP 脚本中实现的内部引擎接口。IteratorAggregate 或 Iterator 接口可以用来代替它。

接口摘要

Traversable {
}

这个接口没有任何方法，它的作用仅仅是作为所有可遍历类的基本接口。


Iterator（迭代器）接口

(No version information available, might only be in Git)

简介

可在内部迭代自己的外部迭代器或类的接口。

接口摘要

Iterator extends Traversable {
/* 方法 */
abstract public current ( ) : mixed
abstract public key ( ) : scalar
abstract public next ( ) : void
abstract public rewind ( ) : void
abstract public valid ( ) : bool
}

预定义迭代器

PHP 已经提供了一些用于日常任务的迭代器。 详细列表参见 SPL 迭代器。

范例

Example #1 基本用法

这个例子展示了使用 foreach 时，迭代器方法的调用顺序。

<?php
class myIterator implements Iterator {
    private $position = 0;
    private $array = array(
        "firstelement",
        "secondelement",
        "lastelement",
    );

    public function __construct() {
        $this->position = 0;
    }

    function rewind() {
        var_dump(__METHOD__);
        $this->position = 0;
    }

    function current() {
        var_dump(__METHOD__);
        return $this->array[$this->position];
    }

    function key() {
        var_dump(__METHOD__);
        return $this->position;
    }

    function next() {
        var_dump(__METHOD__);
        ++$this->position;
    }

    function valid() {
        var_dump(__METHOD__);
        return isset($this->array[$this->position]);
    }
}

$it = new myIterator;

foreach($it as $key => $value) {
    var_dump($key, $value);
    echo "\n";
}
?>

以上例程的输出类似于：

string(18) "myIterator::rewind"
string(17) "myIterator::valid"
string(19) "myIterator::current"
string(15) "myIterator::key"
int(0)
string(12) "firstelement"

string(16) "myIterator::next"
string(17) "myIterator::valid"
string(19) "myIterator::current"
string(15) "myIterator::key"
int(1)
string(13) "secondelement"

string(16) "myIterator::next"
string(17) "myIterator::valid"
string(19) "myIterator::current"
string(15) "myIterator::key"
int(2)
string(11) "lastelement"

string(16) "myIterator::next"
string(17) "myIterator::valid"

Table of Contents

  • Iterator::current — 返回当前元素
  • Iterator::key — 返回当前元素的键
  • Iterator::next — 向前移动到下一个元素
  • Iterator::rewind — 返回到迭代器的第一个元素
  • Iterator::valid — 检查当前位置是否有效


返回当前元素

  • ? 迭代器
  • Iterator::key ?
  • PHP Manual
  • 迭代器
  • 返回当前元素

Iterator::current

(PHP 5, PHP 7, PHP 8)

Iterator::current — 返回当前元素

说明

abstract public Iterator::current ( ) : mixed

返回当前元素。

参数

此函数没有参数。

返回值

可返回任何类型。


返回当前元素的键

  • ? Iterator::current
  • Iterator::next ?
  • PHP Manual
  • 迭代器
  • 返回当前元素的键

Iterator::key

(PHP 5, PHP 7, PHP 8)

Iterator::key — 返回当前元素的键

说明

abstract public Iterator::key ( ) : scalar

返回当前元素的键。

参数

此函数没有参数。

返回值

成功返回标量，失败则返回 null。

错误／异常

失败时分发 E_NOTICE 级错误。


向前移动到下一个元素

  • ? Iterator::key
  • Iterator::rewind ?
  • PHP Manual
  • 迭代器
  • 向前移动到下一个元素

Iterator::next

(PHP 5, PHP 7, PHP 8)

Iterator::next — 向前移动到下一个元素

说明

abstract public Iterator::next ( ) : void

移动当前位置到下一个元素。

Note:

此方法在 foreach 循环之后被调用。

参数

此函数没有参数。

返回值

任何返回都将被忽略。


返回到迭代器的第一个元素

  • ? Iterator::next
  • Iterator::valid ?
  • PHP Manual
  • 迭代器
  • 返回到迭代器的第一个元素

Iterator::rewind

(PHP 5, PHP 7, PHP 8)

Iterator::rewind — 返回到迭代器的第一个元素

说明

abstract public Iterator::rewind ( ) : void

返回到迭代器的第一个元素。

Note:

当开始一个 foreach 循环时，这是第一个被调用的方法。它将不会在 foreach 循环之后被调用。

参数

此函数没有参数。

返回值

任何返回都将被忽略。


检查当前位置是否有效

  • ? Iterator::rewind
  • 聚合式迭代器 ?
  • PHP Manual
  • 迭代器
  • 检查当前位置是否有效

Iterator::valid

(PHP 5, PHP 7, PHP 8)

Iterator::valid — 检查当前位置是否有效

说明

abstract public Iterator::valid ( ) : bool

此方法在 Iterator::rewind() 和 Iterator::next() 方法之后被调用以此用来检查当前位置是否有效。

参数

此函数没有参数。

返回值

返回将被转换为布尔型。成功时返回 true， 或者在失败时返回 false。


IteratorAggregate（聚合式迭代器）接口

(No version information available, might only be in Git)

简介

创建外部迭代器的接口。

接口摘要

IteratorAggregate extends Traversable {
/* 方法 */
abstract public getIterator ( ) : Traversable
}

Example #1 基本用法

<?php
class myData implements IteratorAggregate {
    public $property1 = "Public property one";
    public $property2 = "Public property two";
    public $property3 = "Public property three";

    public function __construct() {
        $this->property4 = "last property";
    }

    public function getIterator() {
        return new ArrayIterator($this);
    }
}

$obj = new myData;

foreach($obj as $key => $value) {
    var_dump($key, $value);
    echo "\n";
}
?>

以上例程的输出类似于：

string(9) "property1"
string(19) "Public property one"

string(9) "property2"
string(19) "Public property two"

string(9) "property3"
string(21) "Public property three"

string(9) "property4"
string(13) "last property"

Table of Contents

  • IteratorAggregate::getIterator — 获取一个外部迭代器


获取一个外部迭代器

  • ? 聚合式迭代器
  • 数组式访问 ?
  • PHP Manual
  • 聚合式迭代器
  • 获取一个外部迭代器

IteratorAggregate::getIterator

(PHP 5, PHP 7, PHP 8)

IteratorAggregate::getIterator — 获取一个外部迭代器

说明

abstract public IteratorAggregate::getIterator ( ) : Traversable

返回一个外部迭代器。

参数

此函数没有参数。

返回值

实现了 Iterator 或 Traversable 接口的类的一个实例。

错误／异常

失败时抛出 Exception。


ArrayAccess（数组式访问）接口

(No version information available, might only be in Git)

简介

提供像访问数组一样访问对象的能力的接口。

接口摘要

ArrayAccess {
/* 方法 */
abstract public offsetExists ( mixed $offset ) : boolean
abstract public offsetGet ( mixed $offset ) : mixed
abstract public offsetSet ( mixed $offset , mixed $value ) : void
abstract public offsetUnset ( mixed $offset ) : void
}

Example #1 Basic usage

<?php
class obj implements arrayaccess {
    private $container = array();
    public function __construct() {
        $this->container = array(
            "one"   => 1,
            "two"   => 2,
            "three" => 3,
        );
    }
    public function offsetSet($offset, $value) {
        if (is_null($offset)) {
            $this->container[] = $value;
        } else {
            $this->container[$offset] = $value;
        }
    }
    public function offsetExists($offset) {
        return isset($this->container[$offset]);
    }
    public function offsetUnset($offset) {
        unset($this->container[$offset]);
    }
    public function offsetGet($offset) {
        return isset($this->container[$offset]) ? $this->container[$offset] : null;
    }
}

$obj = new obj;

var_dump(isset($obj["two"]));
var_dump($obj["two"]);
unset($obj["two"]);
var_dump(isset($obj["two"]));
$obj["two"] = "A value";
var_dump($obj["two"]);
$obj[] = 'Append 1';
$obj[] = 'Append 2';
$obj[] = 'Append 3';
print_r($obj);
?>

以上例程的输出类似于：

bool(true)
int(2)
bool(false)
string(7) "A value"
obj Object
(
    [container:obj:private] => Array
        (
            [one] => 1
            [three] => 3
            [two] => A value
            [0] => Append 1
            [1] => Append 2
            [2] => Append 3
        )

)

Table of Contents

  • ArrayAccess::offsetExists — 检查一个偏移位置是否存在
  • ArrayAccess::offsetGet — 获取一个偏移位置的值
  • ArrayAccess::offsetSet — 设置一个偏移位置的值
  • ArrayAccess::offsetUnset — 复位一个偏移位置的值


检查一个偏移位置是否存在

  • ? 数组式访问
  • ArrayAccess::offsetGet ?
  • PHP Manual
  • 数组式访问
  • 检查一个偏移位置是否存在

ArrayAccess::offsetExists

(PHP 5, PHP 7, PHP 8)

ArrayAccess::offsetExists — 检查一个偏移位置是否存在

说明

abstract public ArrayAccess::offsetExists ( mixed $offset ) : boolean

检查一个偏移位置是否存在。

对一个实现了 ArrayAccess 接口的对象使用 isset() 或 empty() 时，此方法将执行。

Note:

当使用 empty() 并且仅当 ArrayAccess::offsetExists() 返回 true 时，ArrayAccess::offsetGet() 将被调用以检查是为否空。

参数

offset

需要检查的偏移位置。

返回值

成功时返回 true， 或者在失败时返回 false。

Note:

如果一个非布尔型返回值被返回，将被转换为布尔型。

范例

Example #1 ArrayAccess::offsetExists() 范例

<?php
class obj implements arrayaccess {
    public function offsetSet($offset, $value) {
        var_dump(__METHOD__);
    }
    public function offsetExists($var) {
        var_dump(__METHOD__);
        if ($var == "foobar") {
            return true;
        }
        return false;
    }
    public function offsetUnset($var) {
        var_dump(__METHOD__);
    }
    public function offsetGet($var) {
        var_dump(__METHOD__);
        return "value";
    }
}

$obj = new obj;

echo "Runs obj::offsetExists()\n";
var_dump(isset($obj["foobar"]));

echo "\nRuns obj::offsetExists() and obj::offsetGet()\n";
var_dump(empty($obj["foobar"]));

echo "\nRuns obj::offsetExists(), *not* obj:offsetGet() as there is nothing to get\n";
var_dump(empty($obj["foobaz"]));
?>

以上例程的输出类似于：

Runs obj::offsetExists()
string(17) "obj::offsetExists"
bool(true)

Runs obj::offsetExists() and obj::offsetGet()
string(17) "obj::offsetExists"
string(14) "obj::offsetGet"
bool(false)

Runs obj::offsetExists(), *not* obj:offsetGet() as there is nothing to get
string(17) "obj::offsetExists"
bool(true)


获取一个偏移位置的值

  • ? ArrayAccess::offsetExists
  • ArrayAccess::offsetSet ?
  • PHP Manual
  • 数组式访问
  • 获取一个偏移位置的值

ArrayAccess::offsetGet

(PHP 5, PHP 7, PHP 8)

ArrayAccess::offsetGet — 获取一个偏移位置的值

说明

abstract public ArrayAccess::offsetGet ( mixed $offset ) : mixed

返回指定偏移位置的值。

当检查一个偏移位置是否为 empty() 时，此方法被执行。

参数

offset

需要获取的偏移位置。

注释

Note:

Starting with PHP 5.3.4, the prototype checks were relaxed and it's possible for implementations of this method to return by reference. This makes indirect modifications to the overloaded array dimensions of ArrayAccess objects possible.

A direct modification is one that replaces completely the value of the array dimension, as in $obj[6] = 7. An indirect modification, on the other hand, only changes part of the dimension, or attempts to assign the dimension by reference to another variable, as in $obj[6][7] = 7 or $var =& $obj[6]. Increments with ++ and decrements with -- are also implemented in a way that requires indirect modification.

While direct modification triggers a call to ArrayAccess::offsetSet(), indirect modification triggers a call to ArrayAccess::offsetGet(). In that case, the implementation of ArrayAccess::offsetGet() must be able to return by reference, otherwise an E_NOTICE message is raised.

返回值

可返回任何类型。

参见

  • ArrayAccess::offsetExists() - 检查一个偏移位置是否存在


设置一个偏移位置的值

  • ? ArrayAccess::offsetGet
  • ArrayAccess::offsetUnset ?
  • PHP Manual
  • 数组式访问
  • 设置一个偏移位置的值

ArrayAccess::offsetSet

(PHP 5, PHP 7, PHP 8)

ArrayAccess::offsetSet — 设置一个偏移位置的值

说明

abstract public ArrayAccess::offsetSet ( mixed $offset , mixed $value ) : void

为指定的偏移位置设置一个值。

参数

offset

待设置的偏移位置。

value

需要设置的值。

返回值

没有返回值。

注释

Note:

如果另一个值不可用，那么 offset 参数将被设置为 null，就像下面的例子。

<?php
$arrayaccess[] = "first value";
$arrayaccess[] = "second value";
print_r($arrayaccess);
?>

以上例程会输出：

Array
(
    [0] => first value
    [1] => second value
)


复位一个偏移位置的值

  • ? ArrayAccess::offsetSet
  • 序列化 ?
  • PHP Manual
  • 数组式访问
  • 复位一个偏移位置的值

ArrayAccess::offsetUnset

(PHP 5, PHP 7, PHP 8)

ArrayAccess::offsetUnset — 复位一个偏移位置的值

说明

abstract public ArrayAccess::offsetUnset ( mixed $offset ) : void

复位一个偏移位置的值。

Note:

当使用 (unset) 进行类型转换时，该方法不会被调用。

参数

offset

待复位的偏移位置。

返回值

没有返回值。


序列化接口

(No version information available, might only be in Git)

简介

自定义序列化的接口。

实现此接口的类将不再支持 __sleep() 和 __wakeup()。不论何时，只要有实例需要被序列化，serialize 方法都将被调用。它将不会调用 __destruct() 或有其他影响，除非程序化地调用此方法。当数据被反序列化时，类将被感知并且调用合适的 unserialize() 方法而不是调用 __construct()。如果需要执行标准的构造器，你应该在这个方法中进行处理。

接口摘要

Serializable {
/* 方法 */
abstract public serialize ( ) : string
abstract public unserialize ( string $serialized ) : mixed
}

Example #1 Basic usage

<?php
class obj implements Serializable {
    private $data;
    public function __construct() {
        $this->data = "My private data";
    }
    public function serialize() {
        return serialize($this->data);
    }
    public function unserialize($data) {
        $this->data = unserialize($data);
    }
    public function getData() {
        return $this->data;
    }
}

$obj = new obj;
$ser = serialize($obj);

$newobj = unserialize($ser);

var_dump($newobj->getData());
?>

以上例程的输出类似于：

string(15) "My private data"

Table of Contents

  • Serializable::serialize — 对象的字符串表示
  • Serializable::unserialize — 构造对象


对象的字符串表示

  • ? 序列化
  • Serializable::unserialize ?
  • PHP Manual
  • 序列化
  • 对象的字符串表示

Serializable::serialize

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

Serializable::serialize — 对象的字符串表示

说明

abstract public Serializable::serialize ( ) : string

返回对象的字符串表示。

参数

此函数没有参数。

返回值

返回对象的字符串表示或者 null 。

错误／异常

如果返回除了字符串或 null 之外的其他类型，将抛出 Exception。

参见

  • __sleep()
  • __serialize()


构造对象

  • ? Serializable::serialize
  • Closure ?
  • PHP Manual
  • 序列化
  • 构造对象

Serializable::unserialize

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

Serializable::unserialize — 构造对象

说明

abstract public Serializable::unserialize ( string $serialized ) : mixed

在反序列化对象时被调用。

Note:

这个方法担当着对象构造器的角色。在此方法之后，__construct() 将不会被调用。

参数

serialized

对象的字符串表示

返回值

返回没有序列化之前的原始值。

参见

  • __wakeup()
  • __unserialize()


Closure 类

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

简介

用于代表 匿名函数 的类.

匿名函数（在 PHP 5.3 中被引入）会产生这个类型的对象。在过去，这个类被认为是一个实现细节，但现在可以依赖它做一些事情。自 PHP 5.4 起，这个类带有一些方法，允许在匿名函数创建后对其进行更多的控制。

除了此处列出的方法，还有一个 __invoke 方法。这是为了与其他实现了 __invoke()魔术方法 的对象保持一致性，但调用匿名函数的过程与它无关。

类摘要

Closure {
/* 方法 */
__construct ( )
public static bind ( Closure $closure , object $newthis , mixed $newscope = 'static' ) : Closure
public bindTo ( object $newthis , mixed $newscope = 'static' ) : Closure
}

Table of Contents

  • Closure::__construct — 用于禁止实例化的构造函数
  • Closure::bind — 复制一个闭包，绑定指定的$this对象和类作用域。
  • Closure::bindTo — 复制当前闭包对象，绑定指定的$this对象和类作用域。


用于禁止实例化的构造函数

  • ? Closure
  • Closure::bind ?
  • PHP Manual
  • Closure
  • 用于禁止实例化的构造函数

Closure::__construct

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

Closure::__construct — 用于禁止实例化的构造函数

说明

Closure::__construct ( )

这个方法仅用于禁止实例化一个 Closure 类的对象。这个类的对象的创建方法写在 匿名函数 页。

参数

此函数没有参数。

返回值

没有返回值，它只是简单的触发一个错误 （类型是 E_RECOVERABLE_ERROR）。

参见

  • 匿名函数


复制一个闭包，绑定指定的$this对象和类作用域。

  • ? Closure::__construct
  • Closure::bindTo ?
  • PHP Manual
  • Closure
  • 复制一个闭包，绑定指定的$this对象和类作用域。

Closure::bind

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Closure::bind — 复制一个闭包，绑定指定的$this对象和类作用域。

说明

public static Closure::bind ( Closure $closure , object $newthis , mixed $newscope = 'static' ) : Closure

这个方法是 Closure::bindTo() 的静态版本。查看它的文档获取更多信息。

参数

closure

需要绑定的匿名函数。

newthis

需要绑定到匿名函数的对象，或者 null 创建未绑定的闭包。

newscope

想要绑定给闭包的类作用域，或者 'static' 表示不改变。如果传入一个对象，则使用这个对象的类型名。 类作用域用来决定在闭包中 $this 对象的 私有、保护方法 的可见性。 The class scope to which associate the closure is to be associated, or 'static' to keep the current one. If an object is given, the type of the object will be used instead. This determines the visibility of protected and private methods of the bound object.

返回值

返回一个新的 Closure 对象 或者在失败时返回 false

范例

Example #1 Closure::bind() 实例

<?php
class A {
    private static $sfoo = 1;
    private $ifoo = 2;
}
$cl1 = static function() {
    return A::$sfoo;
};
$cl2 = function() {
    return $this->ifoo;
};

$bcl1 = Closure::bind($cl1, null, 'A');
$bcl2 = Closure::bind($cl2, new A(), 'A');
echo $bcl1(), "\n";
echo $bcl2(), "\n";
?>

以上例程的输出类似于：

1
2

参见

  • 匿名函数
  • Closure::bindTo() - 复制当前闭包对象，绑定指定的$this对象和类作用域。


复制当前闭包对象，绑定指定的$this对象和类作用域。

  • ? Closure::bind
  • 生成器 ?
  • PHP Manual
  • Closure
  • 复制当前闭包对象，绑定指定的$this对象和类作用域。

Closure::bindTo

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

Closure::bindTo — 复制当前闭包对象，绑定指定的$this对象和类作用域。

说明

public Closure::bindTo ( object $newthis , mixed $newscope = 'static' ) : Closure

创建并返回一个 匿名函数， 它与当前对象的函数体相同、绑定了同样变量，但可以绑定不同的对象，也可以绑定新的类作用域。

"绑定的对象"决定了函数体中的 $this 的取值，"类作用域"代表一个类型、决定在这个匿名函数中能够调用哪些 私有 和 保护 的方法。 也就是说，此时 $this 可以调用的方法，与 newscope 类的成员函数是相同的。

静态闭包不能有绑定的对象（ newthis 参数的值应该设为 null）不过仍然可以用 bubdTo 方法来改变它们的类作用域。

This function will ensure that for a non-static closure, having a bound instance will imply being scoped and vice-versa. To this end, non-static closures that are given a scope but a null instance are made static and non-static non-scoped closures that are given a non-null instance are scoped to an unspecified class.

Note:

如果你只是想要复制一个匿名函数，可以用 cloning 代替。

参数

newthis

绑定给匿名函数的一个对象，或者 null 来取消绑定。

newscope

关联到匿名函数的类作用域，或者 'static' 保持当前状态。如果是一个对象，则使用这个对象的类型为心得类作用域。 这会决定绑定的对象的 保护、私有成员 方法的可见性。

返回值

返回新创建的 Closure 对象 或者在失败时返回 false

范例

Example #1 Closure::bindTo() 实例

<?php

class A {
    function __construct($val) {
        $this->val = $val;
    }
    function getClosure() {
        //returns closure bound to this object and scope
        return function() { return $this->val; };
    }
}

$ob1 = new A(1);
$ob2 = new A(2);

$cl = $ob1->getClosure();
echo $cl(), "\n";
$cl = $cl->bindTo($ob2);
echo $cl(), "\n";
?>

以上例程的输出类似于：

1
2

参见

  • 匿名函数
  • Closure::bind() - 复制一个闭包，绑定指定的$this对象和类作用域。


生成器类

(No version information available, might only be in Git)

简介

Generator 对象是从 generators返回的.

Caution

Generator 对象不能通过 new 实例化.

类摘要

Generator implements Iterator {
/* 方法 */
public current ( ) : mixed
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public send ( mixed $value ) : mixed
public throw ( Exception $exception ) : void
public valid ( ) : bool
public __wakeup ( ) : void
}

Table of Contents

  • Generator::current — 返回当前产生的值
  • Generator::key — 返回当前产生的键
  • Generator::next — 生成器继续执行
  • Generator::rewind — 重置迭代器
  • Generator::send — 向生成器中传入一个值
  • Generator::throw — 向生成器中抛入一个异常
  • Generator::valid — 检查迭代器是否被关闭
  • Generator::__wakeup — 序列化回调


返回当前产生的值

  • ? 生成器
  • Generator::key ?
  • PHP Manual
  • 生成器
  • 返回当前产生的值

Generator::current

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::current — 返回当前产生的值

说明

public Generator::current ( ) : mixed

参数

此函数没有参数。

返回值

返回当前产生的值。


返回当前产生的键

  • ? Generator::current
  • Generator::next ?
  • PHP Manual
  • 生成器
  • 返回当前产生的键

Generator::key

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::key — 返回当前产生的键

说明

public Generator::key ( ) : mixed

获取产生的值的键

参数

此函数没有参数。

返回值

返回当前产生的键。

范例

Example #1 Generator::key() example

<?php

function Gen()
{
    yield 'key' => 'value';
}

$gen = Gen();

echo "{$gen->key()} => {$gen->current()}";

以上例程会输出：

key => value


生成器继续执行

  • ? Generator::key
  • Generator::rewind ?
  • PHP Manual
  • 生成器
  • 生成器继续执行

Generator::next

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::next — 生成器继续执行

说明

public Generator::next ( ) : void

参数

此函数没有参数。

返回值

没有返回值。


重置迭代器

  • ? Generator::next
  • Generator::send ?
  • PHP Manual
  • 生成器
  • 重置迭代器

Generator::rewind

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::rewind — 重置迭代器

说明

public Generator::rewind ( ) : void

如果迭代已经开始了，这里会抛出一个异常。

参数

此函数没有参数。

返回值

没有返回值。


向生成器中传入一个值

  • ? Generator::rewind
  • Generator::throw ?
  • PHP Manual
  • 生成器
  • 向生成器中传入一个值

Generator::send

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::send — 向生成器中传入一个值

说明

public Generator::send ( mixed $value ) : mixed

向生成器中传入一个值，并且当做 yield 表达式的结果，然后继续执行生成器。

如果当这个方法被调用时，生成器不在 yield 表达式，那么在传入值之前，它会先运行到第一个 yield 表达式。As such it is not necessary to "prime" PHP generators with a Generator::next() call (like it is done in Python).

参数

value

传入生成器的值。这个值将会被作为生成器当前所在的 yield 的返回值

返回值

返回生成的值。

范例

Example #1 用 Generator::send() 向生成器函数中传值

<?php
function printer() {
    while (true) {
        $string = yield;
        echo $string;
    }
}

$printer = printer();
$printer->send('Hello world!');
?>

以上例程会输出：

Hello world!


向生成器中抛入一个异常

  • ? Generator::send
  • Generator::valid ?
  • PHP Manual
  • 生成器
  • 向生成器中抛入一个异常

Generator::throw

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::throw — 向生成器中抛入一个异常

说明

public Generator::throw ( Exception $exception ) : void

参数

exception

返回值

返回生成的值。


检查迭代器是否被关闭

  • ? Generator::throw
  • Generator::__wakeup ?
  • PHP Manual
  • 生成器
  • 检查迭代器是否被关闭

Generator::valid

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::valid — 检查迭代器是否被关闭

说明

public Generator::valid ( ) : bool

参数

此函数没有参数。

返回值

如果迭代器已被关闭返回 false，否则返回 true。


序列化回调

  • ? Generator::valid
  • 上下文（Context）选项和参数 ?
  • PHP Manual
  • 生成器
  • 序列化回调

Generator::__wakeup

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

Generator::__wakeup — 序列化回调

说明

public Generator::__wakeup ( ) : void

抛出一个异常以表示生成器不能被序列化。

参数

此函数没有参数。

返回值

没有返回值。


上下文（Context）选项和参数

PHP 提供了多种上下文选项和参数，可用于所有的文件系统或数据流封装协议。上下文（Context）由
stream_context_create() 创建。选项可通过
stream_context_set_option() 设置，参数可通过
stream_context_set_params() 设置。

Table of Contents

  • 套接字上下文选项 — 套接字上下文选项列表
  • HTTP context 选项 — HTTP context 的选项列表
  • FTP context options — FTP context option listing
  • SSL 上下文选项 — SSL 上下文选项清单
  • CURL context options — CURL 上下文选项列表
  • Phar 上下文（context）选项 — Phar 上下文（context）选项列表
  • MongoDB context options — MongoDB context option listing
  • Context 参数 — Context 参数列表
  • Zip context options — Zip context option listing


套接字上下文选项列表

  • ? 上下文（Context）选项和参数
  • HTTP context 选项 ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • 套接字上下文选项列表

套接字上下文选项

套接字上下文选项 — 套接字上下文选项列表

说明

套接字上下文选项可用于所有工作在套接字上的封装协议，像 tcp, http 和 ftp。

可选项

bindto

用户 PHP 访问网络的指定的 IP 地址（IPv4 或 IPv6 其中的一个）和/或 端口号，这个语法是 ip:port. Setting the IP or the port to 0 will let the system choose the IP and/or port.

Note:

As FTP creates two socket connections during normal operation, the port number cannot be specified using this option.

backlog

Used to limit the number of outstanding connections in the socket's listen queue.

Note:

This is only applicable to stream_socket_server().

ipv6_v6only

Overrides the OS default regarding mapping IPv4 into IPv6.

Note:

This is important in particular when trying to listen on IPv4 addresses separately while there exists a binding on [::].

This is only applicable to stream_socket_server().

so_reuseport

Allows multiple bindings to a same ip:port pair, even from separate processes.

Note:

This is only applicable to stream_socket_server().

so_broadcast

Enables sending and receiving data to/from broadcast addresses.

Note:

This is only applicable to stream_socket_server().

tcp_nodelay

Setting this option to true will set SOL_TCP,NO_DELAY=1 appropriately, thus disabling the TCP Nagle algorithm.

更新日志

版本 | 说明
7.1.0 | Added tcp_nodelay.
7.0.1 | Added ipv6_v6only.
7.0.0 | Added so_broadcast.
7.0.0 | Added so_reuseport.
5.3.3 | Added backlog.
5.1.0 | Added bindto.

范例

Example #1 Basic bindto usage example

<?php
// connect to the internet using the '192.168.0.100' IP
$opts = array(
    'socket' => array(
        'bindto' => '192.168.0.100:0',
    ),
);

// connect to the internet using the '192.168.0.100' IP and port '7000'
$opts = array(
    'socket' => array(
        'bindto' => '192.168.0.100:7000',
    ),
);

// connect to the internet using the '2001:db8::1' IPv6 address
// and port '7000'
$opts = array(
    'socket' => array(
        'bindto' => '[2001:db8::1]:7000',
    ),
);

// connect to the internet using port '7000'
$opts = array(
    'socket' => array(
        'bindto' => '0:7000',
    ),
);

// create the context...
$context = stream_context_create($opts);

// ...and use it to fetch the data
echo file_get_contents('http://www.example.com', false, $context);

?>


HTTP context 的选项列表

  • ? 套接字上下文选项
  • FTP context options ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • HTTP context 的选项列表

HTTP context 选项

HTTP context 选项 — HTTP context 的选项列表

说明

提供给 http:// 和 https:// 传输协议的 context 选项。 transports.

可选项

method string

远程服务器支持的 GET，POST 或其它 HTTP 方法。

默认值是 GET。

header string

请求期间发送的额外 header 。在此选项的值将覆盖其他值 （诸如 User-agent:， Host: 和 Authentication:）。

user_agent string

要发送的 header User-Agent: 的值。如果在上面的 header context 选项中没有指定 user-agent，此值将被使用。

默认使用 php.ini 中设置的 user_agent。

content string

在 header 后面要发送的额外数据。通常使用POST或PUT请求。

proxy string

URI 指定的代理服务器的地址。(e.g. tcp://proxy.example.com:5100).

request_fulluri boolean

当设置为 true 时，在构建请求时将使用整个 URI 。(i.e. GET http://www.example.com/path/to/file.html HTTP/1.0)。 虽然这是一个非标准的请求格式，但某些代理服务器需要它。

默认值是 false.

follow_location integer

跟随 Location header 的重定向。设置为 0 以禁用。

默认值是 1。

max_redirects integer

跟随重定向的最大次数。值为 1 或更少则意味不跟随重定向。

默认值是 20。

protocol_version float

HTTP 协议版本。

默认值是 1.0。

Note:

PHP 5.3.0 以前的版本没有实现分块传输解码。 如果此值设置为 1.1 ，与 1.1 的兼容将是你的责任。

timeout float

读取超时时间，单位为秒（s），用 float 指定(e.g. 10.5)。

默认使用 php.ini 中设置的 default_socket_timeout。

ignore_errors boolean

即使是故障状态码依然获取内容。

默认值为 false.

更新日志

版本 | 说明
5.3.4 | 添加 follow_location。
5.3.0 | 当 protocol_version 设置为 1.1 时支持分块传输解码。
5.2.10 | 添加 ignore_errors。
5.2.10 | header 现在可以是一个数字索引的 array。
5.2.1 | 添加 timeout。
5.1.0 | Added HTTPS proxying through HTTP proxies. 添加经由 HTTP 代理的 HTTPS 代理。
5.1.0 | 添加 max_redirects。
5.1.0 | 添加 protocol_version。

范例

Example #1 获取一个页面并发送 POST 数据

<?php

$postdata = http_build_query(
    array(
        'var1' => 'some content',
        'var2' => 'doh'
    )
);

$opts = array('http' =>
    array(
        'method'  => 'POST',
        'header'  => 'Content-type: application/x-www-form-urlencoded',
        'content' => $postdata
    )
);

$context = stream_context_create($opts);

$result = file_get_contents('http://example.com/submit.php', false, $context);

?>

Example #2 忽略重定向并获取 header 和内容

<?php

$url = "http://www.example.org/header.php";

$opts = array('http' =>
    array(
        'method' => 'GET',
        'max_redirects' => '0',
        'ignore_errors' => '1'
    )
);

$context = stream_context_create($opts);
$stream = fopen($url, 'r', false, $context);

// header information as well as meta data
// about the stream
var_dump(stream_get_meta_data($stream));

// actual data at $url
var_dump(stream_get_contents($stream));
fclose($stream);
?>

注释

Note: Underlying socket stream context options
Additional context options may be supported by the underlying transport For http:// streams, refer to context options for the tcp:// transport. For https:// streams, refer to context options for the ssl:// transport.

Note: HTTP status line
When this stream wrapper follows a redirect, the wrapper_data returned by stream_get_meta_data() might not necessarily contain the HTTP status line that actually applies to the content data at index 0.

array (
  'wrapper_data' =>
  array (
    0 => 'HTTP/1.0 301 Moved Permantenly',
    1 => 'Cache-Control: no-cache',
    2 => 'Connection: close',
    3 => 'Location: http://example.com/foo.jpg',
    4 => 'HTTP/1.1 200 OK',
    ...
The first request returned a 301 (permanent redirect), so the stream wrapper automatically followed the redirect to get a 200 response (index = 4).

参见

  • http://
  • 套接字上下文选项
  • SSL 上下文选项


FTP context option listing

  • ? HTTP context 选项
  • SSL 上下文选项 ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • FTP context option listing

FTP context options

FTP context options — FTP context option listing

说明

Context options for ftp:// and ftps:// transports.

可选项

overwrite bool

Allow overwriting of already existing files on remote server. Applies to write mode (uploading) only.

Defaults to false.

resume_pos int

File offset at which to begin transfer. Applies to read mode (downloading) only.

Defaults to 0 (Beginning of File).

proxy string

Proxy FTP request via http proxy server. Applies to file read operations only. Ex: tcp://squid.example.com:8000.

注释

Note: Underlying socket stream context options
Additional context options may be supported by the underlying transport For ftp:// streams, refer to context options for the tcp:// transport. For ftps:// streams, refer to context options for the ssl:// transport.

参见

  • ftp://
  • 套接字上下文选项
  • SSL 上下文选项


SSL 上下文选项清单

  • ? FTP context options
  • CURL context options ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • SSL 上下文选项清单

SSL 上下文选项

SSL 上下文选项 — SSL 上下文选项清单

说明

ssl:// 和 tls:// 传输协议上下文选项清单。

可选项

peer_name string

要连接的服务器名称。如果未设置，那么服务器名称将根据打开 SSL 流的主机名称猜测得出。

verify_peer boolean

是否需要验证 SSL 证书。

默认值为 true。

verify_peer_name boolean

是否需要验证 peer name。

默认值为 true.

allow_self_signed boolean

是否允许自签名证书。需要配合 verify_peer 参数使用（注：当 verify_peer 参数为 true 时才会根据 allow_self_signed 参数值来决定是否允许自签名证书）。

默认值为 false

cafile string

当设置 verify_peer 为 true 时， 用来验证远端证书所用到的 CA 证书。 本选项值为 CA 证书在本地文件系统的全路径及文件名。

capath string

如果未设置 cafile，或者 cafile 所指的文件不存在时， 会在 capath 所指定的目录搜索适用的证书。 该目录必须是已经经过哈希处理的证书目录。 （注：所谓 hashed certificate 目录是指使用类似 c_rehash 命令将目录中的 .pem 和 .crt 文件扫描并提取哈希码，然后根据此哈希码创建文件链接，以便于快速查找证书）

local_cert string

本地证书路径。 必须是 PEM 格式，并且包含本地的证书及私钥。 也可以包含证书颁发者证书链。 也可以通过 local_pk 指定包含私钥的独立文件。

local_pk string

如果使用独立的文件来存储证书（local_cert）和私钥， 那么使用此选项来指明私钥文件的路径。

passphrase string

local_cert 文件的密码。

CN_match string

期望远端证书的 CN 名称。 PHP 会进行有限的通配符匹配， 如果服务器给出的 CN 名称和本地访问的名称不匹配，则视为连接失败。

Note: 在PHP 5.6.0中，这个选项已废弃，替换为 peer_name。

verify_depth integer

如果证书链条层次太深，超过了本选项的设定值，则终止验证。

默认情况下不限制证书链条层次深度。

ciphers string

设置可用的密码列表。 可用的值参见： » ciphers(1)。

默认值为 DEFAULT.

capture_peer_cert boolean

如果设置为 true 将会在上下文中创建 peer_certificate 选项， 该选项中包含远端证书。

capture_peer_cert_chain boolean

如果设置为 true 将会在上下文中创建 peer_certificate_chain 选项， 该选项中包含远端证书链条。

SNI_enabled boolean

设置为 true 将启用服务器名称指示（server name indication）。 启用 SNI 将允许同一 IP 地址使用多个证书。

SNI_server_name string

如果设置此参数，那么其设置值将被视为 SNI 服务器名称。 如果未设置，那么服务器名称将基于打开 SSL 流的主机名称猜测得出。

Note: 在PHP 5.6.0中，这个选项已废弃，替换为 peer_name。

disable_compression boolean

如果设置，则禁用 TLS 压缩，有助于减轻恶意攻击。

peer_fingerprint string | array

当远程服务器证书的摘要和指定的散列值不相同的时候， 终止操作。

当使用 string 时， 会根据字符串的长度来检测所使用的散列算法："md5"（32 字节）还是"sha1"（40 字节）。

当使用 array 时， 数组的键表示散列算法名称，其对应的值是预期的摘要值。

更新日志

版本 | 说明
5.6.0 | 新加 peer_fingerprint 参数。
5.4.13 | 新加 disable_compression。 需要 OpenSSL >= 1.0.0.
5.3.2 | 新加 SNI_enabled 和 SNI_server_name。

注释

Note: 因为 ssl:// 是 https:// 和 ftps:// 的底层传输协议， 所以，ssl:// 的上下文选项也同样适用于 https:// 和 ftps:// 上下文。

Note: PHP 必须联合 OpenSSL 0.9.8j 或以上版本编译才可以支持 SNI， 同时也支持使用 OPENSSL_TLSEXT_SERVER_NAME 来探测 SNI 服务器名称。

参见

  • 套接字上下文选项


CURL 上下文选项列表

  • ? SSL 上下文选项
  • Phar 上下文（context）选项 ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • CURL 上下文选项列表

CURL context options

CURL context options — CURL 上下文选项列表

说明

CURL 上下文选项在 CURL 扩展被编译（通过 --with-curlwrappers configure选项）时可用

可选项

method string

GET，POST，或者其他远程服务器支持的 HTTP 方法。

默认为 GET.

header string

额外的请求标头。这个值会覆盖通过其他选项设定的值（如： User-agent:，Host:， ，Authentication:）。

user_agent string

设置请求时 User-Agent 标头的值。

默认为 php.ini 中的 user_agent 设定。

content string

在头部之后发送的额外数据。这个选项在 GET 和 HEAD 请求中不使用。

proxy string

URI，用于指定代理服务器的地址（例如 tcp://proxy.example.com:5100）。

max_redirects integer

最大重定向次数。1 或者更小则代表不会跟随重定向。

默认为 20.

curl_verify_ssl_host boolean

校验服务器。

默认为 false

Note:

这个选项在 HTTP 和 FTP 协议中均可使用。

curl_verify_ssl_peer boolean

要求对使用的SSL证书进行校验。

默认为 false

Note:

这个选项在 HTTP 和 FTP 协议中均可使用。

范例

Example #1 获取一个页面，并以POST发送数据

<?php

$postdata = http_build_query(
    array(
        'var1' => 'some content',
        'var2' => 'doh'
    )
);

$opts = array('http' =>
    array(
        'method'  => 'POST',
        'header'  => 'Content-type: application/x-www-form-urlencoded',
        'content' => $postdata
    )
);

$context = stream_context_create($opts);

$result = file_get_contents('http://example.com/submit.php', false, $context);

?>

参见

  • 套接字上下文选项


Phar 上下文（context）选项列表

  • ? CURL context options
  • MongoDB context options ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • Phar 上下文（context）选项列表

Phar 上下文（context）选项

Phar 上下文（context）选项 — Phar 上下文（context）选项列表

说明

phar:// 封装（wrapper）的上下文（context）选项。

可选项

compress int

Phar compression constants 中的一个。

metadata mixed

Phar 元数据（metadata）。查看 Phar::setMetadata()。

参见

  • phar://
  • Phar stream wrapper


MongoDB context option listing

  • ? Phar 上下文（context）选项
  • Context 参数 ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • MongoDB context option listing

MongoDB context options

MongoDB context options — MongoDB context option listing

说明

Context options for mongodb:// transports.

可选项

log_cmd_insert callable

A callback function called when inserting a document, see log_cmd_insert().

log_cmd_delete callable

A callback function called when deleting a document, see log_cmd_delete().

log_cmd_update callable

A callback function called when updating a document, see log_cmd_update().

log_write_batch callable

A callback function called when executing a Write Batch, see log_write_batch().

log_reply callable

A callback function called when reading a reply from MongoDB, see log_reply().

log_getmore callable

A callback function called when retrieving more results from a MongoDB cursor, see log_getmore().

log_killcursor callable

A callback function called executing a killcursor opcode, see log_killcursor().

更新日志

版本 | 说明
pecl/mongo 1.5.0 | Added Write API Context options

参见

  • 套接字上下文选项
  • SSL 上下文选项


Context 参数列表

  • ? MongoDB context options
  • Zip context options ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • Context 参数列表

Context 参数

Context 参数 — Context 参数列表

说明

这些参数（parameters）可以设置为由函数 stream_context_set_params() 返回的 context。

参数

notification callable

当一个流（stream）上发生事件时，callable 将被调用。

查看 stream_notification_callback 以获得更多信息。


Zip context option listing

  • ? Context 参数
  • 支持的协议和封装协议 ?
  • PHP Manual
  • 上下文（Context）选项和参数
  • Zip context option listing

Zip context options

Zip context options — Zip context option listing

说明

Zip context options are available for zip wrappers.

可选项

password

Used to specify password used for encrypted archive.

更新日志

版本 | 说明
PHP 7.2.0, PECL zip 1.14.0 | Added password.

范例

Example #1 Basic password usage example

<?php
// Read encrypted archive
$opts = array(
    'zip' => array(
        'password' => 'secret',
    ),
);
// create the context...
$context = stream_context_create($opts);

// ...and use it to fetch the data
echo file_get_contents('zip://test.zip#test.txt', false, $context);

?>


支持的协议和封装协议

PHP 带有很多内置 URL 风格的封装协议，可用于类似 fopen()、
copy()、 file_exists() 和
filesize() 的文件系统函数。
除了这些封装协议，还能通过 stream_wrapper_register() 来注册自定义的封装协议。

Note: 用于描述一个封装协议的 URL 语法仅支持 scheme://... 的语法。 scheme:/ 和 scheme: 语法是不支持的。

Table of Contents

  • file:// — 访问本地文件系统
  • http:// — 访问 HTTP(s) 网址
  • ftp:// — 访问 FTP(s) URLs
  • php:// — 访问各个输入/输出流（I/O streams）
  • zlib:// — 压缩流
  • data:// — 数据（RFC 2397）
  • glob:// — 查找匹配的文件路径模式
  • phar:// — PHP 归档
  • ssh2:// — Secure Shell 2
  • rar:// — RAR
  • ogg:// — 音频流
  • expect:// — 处理交互式的流


访问本地文件系统

  • ? 支持的协议和封装协议
  • http:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • 访问本地文件系统

file://

file:// — 访问本地文件系统

说明

文件系统 是 PHP 使用的默认封装协议，展现了本地文件系统。 当指定了一个相对路径（不以/、\、\\或 Windows 盘符开头的路径）提供的路径将基于当前的工作目录。 在很多情况下是脚本所在的目录，除非被修改了。 使用 CLI 的时候，目录默认是脚本被调用时所在的目录。

在某些函数里，例如 fopen() 和 file_get_contents()， include_path 会可选地搜索，也作为相对的路径。

用法

  • /path/to/file.ext
  • relative/path/to/file.ext
  • fileInCwd.ext
  • C:/path/to/winfile.ext
  • C:\path\to\winfile.ext
  • \\smbserver\share\path\to\winfile.ext
  • file:///path/to/file.ext

可选项

封装协议概要
属性 | 支持
受 allow_url_fopen 影响 | No
允许读取 | Yes
允许写入 | Yes
允许添加 | Yes
允许同时读和写 | Yes
支持 stat() | Yes
支持 unlink() | Yes
支持 rename() | Yes
支持 mkdir() | Yes
支持 rmdir() | Yes


访问 HTTP(s) 网址

  • ? file://
  • ftp:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • 访问 HTTP(s) 网址

http://

https://

http:// -- https:// — 访问 HTTP(s) 网址

说明

允许通过 HTTP 1.0 的 GET方法，以只读访问文件或资源。 HTTP 请求会附带一个 Host: 头，用于兼容基于域名的虚拟主机。 如果在你的 php.ini 文件中或字节流上下文（context）配置了 user_agent 字符串，它也会被包含在请求之中。

数据流允许读取资源的 body，而 headers 则储存在了 $http_response_header 变量里。

如果需要知道文档资源来自哪个 URL（经过所有重定向的处理后）， 需要处理数据流返回的系列响应报头（response headers）。

The from directive will be used for the From: header if set and not overwritten by the 上下文（Context）选项和参数.

用法

  • http://example.com
  • http://example.com/file.php?var1=val1&var2=val2
  • http://user:password@example.com
  • https://example.com
  • https://example.com/file.php?var1=val1&var2=val2
  • https://user:password@example.com

可选项

封装协议概要
属性 | 支持
受 allow_url_fopen 限制 | Yes
允许读取 | Yes
允许写入 | No
允许添加 | No
允许同时读和写 | N/A
支持 stat() | No
支持 unlink() | No
支持 rename() | No
支持 mkdir() | No
支持 rmdir() | No

范例

Example #1 检测重定向后最终的 URL

<?php
$url = 'http://www.example.com/redirecting_page.php';

$fp = fopen($url, 'r');

$meta_data = stream_get_meta_data($fp);
foreach ($meta_data['wrapper_data'] as $response) {

    /* 我们是否被重定向了？ */
    if (strtolower(substr($response, 0, 10)) == 'location: ') {

        /* 更新我们被重定向后的 $url */
        $url = substr($response, 10);
    }

}

?>

注释

Note: openssl 扩展启用后才能够支持 HTTPS 协议。

HTTP 连接是只读的；还不支持对一个 HTTP 资源进行写数据或者复制文件。

比如发送 POST 和 PUT 请求， 可以在 HTTP Contexts 的支持下实现。

参见

  • HTTP context 选项
  • $http_response_header
  • stream_get_meta_data() - 从封装协议文件指针中取得报头／元数据


访问 FTP(s) URLs

  • ? http://
  • php:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • 访问 FTP(s) URLs

ftp://

ftps://

ftp:// -- ftps:// — 访问 FTP(s) URLs

说明

允许通过 FTP 读取存在的文件，以及创建新文件。 如果服务器不支持被动（passive）模式的 FTP，连接会失败。

打开文件后你既可以读也可以写，但是不能同时进行。 当远程文件已经存在于 ftp 服务器上，如果尝试打开并写入文件的时候， 未指定上下文（context）选项 overwrite，连接会失败。 如果要通过 FTP 覆盖存在的文件， 指定上下文（context）的 overwrite 选项来打开、写入。 另外可使用 FTP 扩展来代替。

如果你设置了 php.ini 中的 from 指令， 这个值会作为匿名（anonymous）ftp 的密码。

用法

  • ftp://example.com/pub/file.txt
  • ftp://user:password@example.com/pub/file.txt
  • ftps://example.com/pub/file.txt
  • ftps://user:password@example.com/pub/file.txt

可选项

封装协议概要
属性 | 是否支持
受 allow_url_fopen 影响 | 是
允许读取 | 是
允许写入 | 是 (新文件/启用 overwrite 后已存在的文件)
允许添加 | 是
允许同时读和写 | 否
支持 stat() | 仅 filesize()、 filetype()、 file_exists()、 is_file() 和 is_dir()。 自 PHP 5.1.0 起： filemtime()。
支持 unlink() | 是
支持 rename() | 是
支持 mkdir() | 是
支持 rmdir() | 是

注释

Note:

FTPS 仅在 openssl 扩展开启时有效。

如果服务器不支持 SSL，这个连接会降级（falls back）到普通未加密的 ftp。

Note: 追加
文件可以通过 ftp:// URL 封装器来追加（append）。

参见

  • FTP context options


访问各个输入/输出流（I/O streams）

  • ? ftp://
  • zlib:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • 访问各个输入/输出流（I/O streams）

php://

php:// — 访问各个输入/输出流（I/O streams）

说明

PHP 提供了一些杂项输入/输出（IO）流，允许访问 PHP 的输入输出流、标准输入输出和错误描述符， 内存中、磁盘备份的临时文件流以及可以操作其他读取写入文件资源的过滤器。

php://stdin, php://stdout 和 php://stderr

php://stdin、php://stdout 和 php://stderr 允许直接访问 PHP 进程相应的输入或者输出流。 数据流引用了复制的文件描述符，所以如果你打开 php://stdin 并在之后关了它， 仅是关闭了复制品，真正被引用的 STDIN 并不受影响。 注意 PHP 在这方面的行为有很多 BUG 直到 PHP 5.2.1。 推荐你简单使用常量 STDIN、 STDOUT 和 STDERR 来代替手工打开这些封装器。

php://stdin 是只读的， php://stdout 和 php://stderr 是只写的。

php://input

php://input 是个可以访问请求的原始数据的只读流。 POST 请求的情况下，最好使用 php://input 来代替 $HTTP_RAW_POST_DATA，因为它不依赖于特定的 php.ini 指令。 而且，这样的情况下 $HTTP_RAW_POST_DATA 默认没有填充， 比激活 always_populate_raw_post_data 潜在需要更少的内存。 enctype="multipart/form-data" 的时候 php://input 是无效的。

php://output

php://output 是一个只写的数据流， 允许你以 print 和 echo 一样的方式 写入到输出缓冲区。

php://fd

php://fd 允许直接访问指定的文件描述符。 例如 php://fd/3 引用了文件描述符 3。

php://memory 和 php://temp

php://memory 和 php://temp 是一个类似文件 包装器的数据流，允许读写临时数据。 两者的唯一区别是 php://memory 总是把数据储存在内存中， 而 php://temp 会在内存量达到预定义的限制后（默认是 2MB）存入临时文件中。 临时文件位置的决定和 sys_get_temp_dir() 的方式一致。

php://temp 的内存限制可通过添加 /maxmemory:NN 来控制，NN 是以字节为单位、保留在内存的最大数据量，超过则使用临时文件。

php://filter

php://filter 是一种元封装器， 设计用于数据流打开时的筛选过滤应用。 这对于一体式（all-in-one）的文件函数非常有用，类似 readfile()、 file() 和 file_get_contents()， 在数据流内容读取之前没有机会应用其他过滤器。

php://filter 目标使用以下的参数作为它路径的一部分。 复合过滤链能够在一个路径上指定。详细使用这些参数可以参考具体范例。

php://filter 参数
名称 | 描述
resource=<要过滤的数据流> | 这个参数是必须的。它指定了你要筛选过滤的数据流。
read=<读链的筛选列表> | 该参数可选。可以设定一个或多个过滤器名称，以管道符（|）分隔。
write=<写链的筛选列表> | 该参数可选。可以设定一个或多个过滤器名称，以管道符（|）分隔。
<；两个链的筛选列表> | 任何没有以 read= 或 write= 作前缀 的筛选器列表会视情况应用于读或写链。

可选项

封装协议摘要（针对 php://filter，参考被筛选的封装器。）
属性 | 支持
受限于 allow_url_fopen | No
受限于 allow_url_include | 仅 php://input、 php://stdin、 php://memory 和 php://temp。
允许读取 | 仅 php://stdin、 php://input、 php://fd、 php://memory 和 php://temp。
允许写入 | 仅 php://stdout、 php://stderr、 php://output、 php://fd、 php://memory 和 php://temp。
允许追加 | 仅 php://stdout、 php://stderr、 php://output、 php://fd、 php://memory 和 php://temp（等于写入）
允许同时读写 | 仅 php://fd、 php://memory 和 php://temp。
支持 stat() | 不支持。不过，php://memory 和 php://temp 支持 fstat()。
支持 unlink() | No
支持 rename() | No
支持 mkdir() | No
支持 rmdir() | No
仅仅支持 stream_select() | php://stdin、 php://stdout、 php://stderr、 php://fd 和 php://temp。

范例

Example #1 php://temp/maxmemory

这个可选选项允许设置 php://temp 开始使用临时文件前的最大内存限制。

<?php
// Set the limit to 5 MB.
$fiveMBs = 5 * 1024 * 1024;
$fp = fopen("php://temp/maxmemory:$fiveMBs", 'r+');

fputs($fp, "hello\n");

// Read what we have written.
rewind($fp);
echo stream_get_contents($fp);
?>

Example #2 php://filter/resource=<待过滤的数据流>

这个参数必须位于 php://filter 的末尾，并且指向需要过滤筛选的数据流。

<?php
/* 这简单等同于：
  readfile("http://www.example.com");
  实际上没有指定过滤器 */

readfile("php://filter/resource=http://www.example.com");
?>

Example #3 php://filter/read=<读链需要应用的过滤器列表>

这个参数采用一个或以管道符 | 分隔的多个过滤器名称。

<?php
/* 这会以大写字母输出 www.example.com 的全部内容 */
readfile("php://filter/read=string.toupper/resource=http://www.example.com");

/* 这会和以上所做的一样，但还会用 ROT13 加密。 */
readfile("php://filter/read=string.toupper|string.rot13/resource=http://www.example.com");
?>

Example #4 php://filter/write=<写链需要应用的过滤器列表>

这个参数采用一个或以管道符 | 分隔的多个过滤器名称。

<?php
/* 这会通过 rot13 过滤器筛选出字符 "Hello World"
  然后写入当前目录下的 example.txt */
file_put_contents("php://filter/write=string.rot13/resource=example.txt","Hello World");
?>

Example #5 php://memory 和 php://temp 是一次性的

php://memory 和 php://temp 是一次性的，比如：stream 流关闭后，就无法再次得到以前的内容了。

file_put_contents('php://memory', 'PHP');
echo file_get_contents('php://memory'); // 啥也没有


压缩流

  • ? php://
  • data:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • 压缩流

zlib://

bzip2://

zip://

zlib:// -- bzip2:// -- zip:// — 压缩流

说明

compress.zlib:// and compress.bzip2://

zlib: 的功能类似 gzopen()，但是 其数据流还能被 fread() 和其他文件系统函数使用。 不建议使用，因为会和其他带":"字符的文件名混淆； 请使用 compress.zlib:// 替代。

compress.zlib://、 compress.bzip2:// 和 gzopen()、bzopen() 是相等的。并且可以在不支持 fopencookie 的系统中使用。

ZIP 扩展 注册了 zip: 封装器。 自 PHP 7.2.0 和 libzip 1.2.0+ 起，加密归档开始支持密码，允许数据流中使用密码。 字节流上下文（stream contexts）中使用 'password' 选项设置密码。

可选项

  • compress.zlib://file.gz
  • compress.bzip2://file.bz2
  • zip://archive.zip#dir/file.txt

用法

封装协议摘要
属性 | 支持
受限于 allow_url_fopen | No
允许读取 | Yes
允许写入 | Yes（除了 zip://）
允许附加 | Yes（除了 zip://）
允许同时读写 | No
支持 stat() | No，请使用普通的 file:// 封装器统计压缩文件。
支持 unlink() | No，请使用 file:// 封装器删除压缩文件。
支持 rename() | No
支持 mkdir() | No
支持 rmdir() | No


数据（RFC 2397）

  • ? zlib://
  • glob:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • 数据（RFC 2397）

data://

data:// — 数据（RFC 2397）

说明

自 PHP 5.2.0 起 data:（» RFC 2397）数据流封装器开始有效。

用法

  • data://text/plain;base64,

可选项

封装协议摘要
属性 | 支持
受限于 allow_url_fopen | No
受限于 allow_url_include | Yes
允许读取 | Yes
允许写入 | No
允许追加 | No
允许同时读写 | No
支持 stat() | No
支持 unlink() | No
支持 rename() | No
支持 mkdir() | No
支持 rmdir() | No

范例

Example #1 打印 data:// 的内容

<?php
// 打印 "I love PHP"
echo file_get_contents('data://text/plain;base64,SSBsb3ZlIFBIUAo=');
?>

Example #2 获取媒体类型

<?php
$fp   = fopen('data://text/plain;base64,', 'r');
$meta = stream_get_meta_data($fp);

// 打印 "text/plain"
echo $meta['mediatype'];
?>


查找匹配的文件路径模式

  • ? data://
  • phar:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • 查找匹配的文件路径模式

glob://

glob:// — 查找匹配的文件路径模式

说明

glob: 数据流包装器自 PHP 5.3.0 起开始有效。

用法

  • glob://

可选项

封装协议摘要
属性 | 支持
受限于 allow_url_fopen | No
受限于 allow_url_include | No
允许读取 | No
允许写入 | No
允许附加 | No
允许同时读写 | No
支持 stat() | No
支持 unlink() | No
支持 rename() | No
支持 mkdir() | No
支持 rmdir() | No

范例

Example #1 基本用法

<?php
// 循环 ext/spl/examples/ 目录里所有 *.php 文件
// 并打印文件名和文件尺寸
$it = new DirectoryIterator("glob://ext/spl/examples/*.php");
foreach($it as $f) {
    printf("%s: %.1FK\n", $f->getFilename(), $f->getSize()/1024);
}
?>
tree.php: 1.0K
findregex.php: 0.6K
findfile.php: 0.7K
dba_dump.php: 0.9K
nocvsdir.php: 1.1K
phar_from_dir.php: 1.0K
ini_groups.php: 0.9K
directorytree.php: 0.9K
dba_array.php: 1.1K
class_tree.php: 1.8K


PHP 归档

  • ? glob://
  • ssh2:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • PHP 归档

phar://

phar:// — PHP 归档

说明

phar:// 数据流包装器自 PHP 5.3.0 起开始有效。详细的描述可参见 Phar 数据流包装器。

用法

  • phar://

可选项

封装协议摘要
属性 | 支持
支持 allow_url_fopen | No
支持 allow_url_include | No
允许读取 | Yes
允许写入 | Yes
允许附加 | No
允许同时读写 | Yes
支持 stat() | Yes
支持 unlink() | Yes
支持 rename() | Yes
支持 mkdir() | Yes
支持 rmdir() | Yes

参见

  • Phar 上下文（context）选项


Secure Shell 2

  • ? phar://
  • rar:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • Secure Shell 2

ssh2://

ssh2:// — Secure Shell 2

说明

ssh2.shell:// ssh2.exec:// ssh2.tunnel:// ssh2.sftp:// ssh2.scp:// (PECL)

Note: 该封装器默认没有激活
为了使用 ssh2.*:// 封装协议， 你必须安装来自 » PECL 的 » SSH2 扩展。

除了支持传统的 URI 登录信息，ssh2 封装协议也支持通过 URL 的主机（host）部分来复用打开连接。

用法

  • ssh2.shell://user:pass@example.com:22/xterm
  • ssh2.exec://user:pass@example.com:22/usr/local/bin/somecmd
  • ssh2.tunnel://user:pass@example.com:22/192.168.0.1:14
  • ssh2.sftp://user:pass@example.com:22/path/to/filename

可选项

封装协议概要
属性 | ssh2.shell | ssh2.exec | ssh2.tunnel | ssh2.sftp | ssh2.scp
受 allow_url_fopen 影响 | Yes | Yes | Yes | Yes | Yes
允许读取 | Yes | Yes | Yes | Yes | Yes
允许写入 | Yes | Yes | Yes | Yes | No
允许追加 | No | No | No | Yes（当服务器支持的时候） | No
允许同时读和写 | Yes | Yes | Yes | Yes | No
支持 stat() | No | No | No | Yes | No
支持 unlink() | No | No | No | Yes | No
支持 rename() | No | No | No | Yes | No
支持 mkdir() | No | No | No | Yes | No
支持 rmdir() | No | No | No | Yes | No

上下文选项（Context）
名称 | 用法 | 默认
session | 重复使用预连接的 ssh2 资源 |
sftp | 重复使用预先分配的 sftp 资源 |
methods | 密钥交换（key exchange）、主机密钥（hostkey）、cipher、压缩和 MAC 方法 |
callbacks |  |
username | 以该用户名连接 |
password | 使用的密码来进行密码验证 |
pubkey_file | 用于验证的公钥（public key）文件 |
privkey_file | 用于验证的私钥（private key）文件 |
env | 需要设置的环境变量的关联数组 |
term | 在分配一个 pty 时请求的终端类型 |
term_width | 在分配一个 pty 时请求的终端宽度 |
term_height | 在分配一个 pty 时请求的终端宽度高度 |
term_units | term_width 和 term_height 的单位 | SSH2_TERM_UNIT_CHARS

范例

Example #1 从一个活动连接中打开字节流

<?php
$session = ssh2_connect('example.com', 22);
ssh2_auth_pubkey_file($session, 'username', '/home/username/.ssh/id_rsa.pub',
                                            '/home/username/.ssh/id_rsa', 'secret');
$stream = fopen("ssh2.tunnel://$session/remote.example.com:1234", 'r');
?>

Example #2 This $session variable must be kept available!

In order to use the ssh2.*://$session wrappers you must keep the $session resouce variable. The code below will not have the desired effect:

<?php
$session = ssh2_connect('example.com', 22);
ssh2_auth_pubkey_file($session, 'username', '/home/username/.ssh/id_rsa.pub',
                                            '/home/username/.ssh/id_rsa', 'secret');
$connection_string = "ssh2.sftp://$session/";
unset($session);
$stream = fopen($connection_string . "path/to/file", 'r');
?>

unset() closes the session, because $connection_string does not hold a reference to the $session variable, just a string cast derived from it. This also happens when the unset() is implicit because of leaving scope (like in a function).


RAR

  • ? ssh2://
  • ogg:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • RAR

rar://

rar:// — RAR

说明

The wrapper takes the url encoded path to the RAR archive (relative or absolute), an optional asterik (*), an optional number sign (#) and an optional url encoded entry name, as stored in the archive. Specifying an entry name requires the number sign; a leading forward slash in the entry name is optional.

This wrapper can open both files and directories. When opening directories, the asterisk sign forces the directory entries names to be returned unencoded. If it's not specified, they will be returned url encoded - the reason for this is to allow the wrapper to be correctly used with built-in functionality like the RecursiveDirectoryIterator in the presence of file names that seem like url encoded data.

If the pound sign and the entry name part are not included, the root of the archive will be displayed. This differs from regular directories in that the resulting stream will not contain information such as the modification time, as the root directory is not stored in an individual entry in the archive. The usage of the wrapper with RecursiveDirectoryIterator requires the number sign to be included in the URL when accessing the root, so that the URLs of the children may be constructed correctly.

Note: This wrapper is not enabled by default
In order to use the rar:// wrapper, you must install the » rar extension available from » PECL.

rar:// Available since PECL rar 3.0.0

用法

  • rar://<url encoded archive name>[*][#[<url encoded entry name>]]

可选项

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Restricted by allow_url_include | No
Allows Reading | Yes
Allows Writing | No
Allows Appending | No
Allows Simultaneous Reading and Writing | No
Supports stat() | Yes
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Context options
Name | Usage | Default
open_password | The password used to encrypt the headers of the archive, if any. WinRAR will encrypt all the files with the same password as the headers password when the later is present, so for archives with encrypted headers, file_password will be ignored. |
file_password | The password used to encrypt a file, if any. If the headers are also encrypted, this option will be ignored in favor of open_password. The reason there are two options is to cover the possibility of supporting archives with different headers and file passwords, should those archives arise. Note that if the archive does not have its headers encrypted, open_password will be ignored and this option must be used instead. |
volume_callback | A callback to determine the path of missing volumes. See RarArchive::open() for more information. |

范例

Example #1 Traversing a RAR archive

<?php

class MyRecDirIt extends RecursiveDirectoryIterator {
    function current() {
        return rawurldecode($this->getSubPathName()) .
            (is_dir(parent::current())?" [DIR]":"");
    }
}

$f = "rar://" . rawurlencode(dirname(__FILE__)) .
    DIRECTORY_SEPARATOR . 'dirs_and_extra_headers.rar#';

$it = new RecursiveTreeIterator(new MyRecDirIt($f));

foreach ($it as $s) {
    echo $s, "\n";
}
?>

以上例程的输出类似于：

|-allow_everyone_ni [DIR]
|-file1.txt
|-file2_?.txt
|-with_streams.txt
\-? [DIR]
  |-?\%2Fempty%2E [DIR]
  | \-?\%2Fempty%2E\file7.txt
  |-?\empty [DIR]
  |-?\file3.txt
  |-?\file4_?.txt
  \-?\?_2 [DIR]
    |-?\?_2\file5.txt
    \-?\?_2\file6_?.txt

Example #2 Opening an encrypted file (header encryption)

<?php
$stream = fopen("rar://" .
    rawurlencode(dirname(__FILE__)) . DIRECTORY_SEPARATOR .
    'encrypted_headers.rar' . '#encfile1.txt', "r", false,
    stream_context_create(
        array(
            'rar' =>
                array(
                    'open_password' => 'samplepassword'
                )
            )
        )
    );
var_dump(stream_get_contents($stream));
/* creation and last access date is opt-in in WinRAR, hence most
 * files don't have them */
var_dump(fstat($stream));
?>

以上例程的输出类似于：

string(26) "Encrypted file 1 contents."
Array
(
    [0] => 0
    [1] => 0
    [2] => 33206
    [3] => 1
    [4] => 0
    [5] => 0
    [6] => 0
    [7] => 26
    [8] => 0
    [9] => 1259550052
    [10] => 0
    [11] => -1
    [12] => -1
    [dev] => 0
    [ino] => 0
    [mode] => 33206
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 26
    [atime] => 0
    [mtime] => 1259550052
    [ctime] => 0
    [blksize] => -1
    [blocks] => -1
)


音频流

  • ? rar://
  • expect:// ?
  • PHP Manual
  • 支持的协议和封装协议
  • 音频流

ogg://

ogg:// — 音频流

说明

通过包装器 ogg:// 读取的文件， 是作为 OGG/Vorbis 格式的压缩音频编码。 同样，通过包装器 ogg:// 写入或追加的数据格式也是压缩音频。 当 stream_get_meta_data() 用于一个打开读取的 OGG/Vorbis 文件时，会返回关于数据流的详细信息，包含了 vendor 标签、任何内含的 comments、 channels 数字、采样率（rate），以及 用 bitrate_lower、bitrate_upper、 bitrate_nominal 和 bitrate_window 描述的可变比特率范围。

ogg:// （PECL）

Note: 该封装器默认未激活
要使用 ogg:// 封装器，您必须安装 » OGG/Vorbis 扩展。 可以在 » PECL 上找到。

用法

  • ogg://soundfile.ogg
  • ogg:///path/to/soundfile.ogg
  • ogg://http://www.example.com/path/to/soundstream.ogg

可选项

封装协议摘要
属性 | 支持
受限于 allow_url_fopen | No
允许读取 | Yes
允许写入 | Yes
允许附加 | Yes
允许同时读写 | No
支持 stat() | No
支持 unlink() | No
支持 rename() | No
支持 mkdir() | No
支持 rmdir() | No

上下文选项
Name | Usage | Default | Mode
pcm_mode | 读取时使用如下 PCM 编码之一: OGGVORBIS_PCM_U8、OGGVORBIS_PCM_S8、 OGGVORBIS_PCM_U16_BE、OGGVORBIS_PCM_S16_BE、 OGGVORBIS_PCM_U16_LE 和 OGGVORBIS_PCM_S16_LE。 (8 或 16 位，签名或未签名，大或小的 endian) | OGGVORBIS_PCM_S16_LE | 读取
rate | 输入数据的采样率，单位为 Hz | 44100 | 写入/附加
bitrate | 若给的值为整数，则是用固定的比特率进行编码。（16000 到 131072）若给的值为浮点数，则使用可变的比特率（质。(-1.0 到 1.0） | 128000 | 写入/附加
channels | 要编码的声道的数量，典型为 1 (单声道), 或 2 (立体声)。最高支持 16 声道。 | 2 | 写入/附加
comments | 编码到音轨头部的字符串数组。 |  | 写入/附加

范例


处理交互式的流

  • ? ogg://
  • 安全 ?
  • PHP Manual
  • 支持的协议和封装协议
  • 处理交互式的流

expect://

expect:// — 处理交互式的流

说明

由 expect:// 封装协议打开的数据流 PTY 通过提供了对进程 stdio、stdout 和 stderr 的访问。

Note: 该封装协议默认未开启
为了使用 expect:// 封装器，你必须安装 » PECL 上的 » Expect 扩展。

expect:// (PECL)

用法

  • expect://command

可选项

封装协议概要
属性 | 支持
受 allow_url_fopen 影响 | No
允许读取 | Yes
允许写入 | Yes
允许添加 | Yes
允许同时读和写 | No
支持 stat() | No
支持 unlink() | No
支持 rename() | No
支持 mkdir() | No
支持 rmdir() | No

范例


安全

  • 简介
  • 总则
  • 以 CGI 模式安装时
    • 可能受到的攻击
    • 情形一：只运行公开的文件
    • 情形二：使用 --enable-force-cgi-redirect 选项
    • 情形三：设置 doc_root 或 user_dir
    • 情形四：PHP 解释器放在 web 目录以外
  • 以 Apache 模块安装时
  • 会话（Session）安全
  • 文件系统安全
    • Null 字符问题
  • 数据库安全
    • 设计数据库
    • 连接数据库
    • 加密存储模型
    • SQL 注入
  • 错误报告
  • 用户提交的数据
  • 隐藏 PHP
  • 保持更新


简介

PHP 作为一种强大的语言，无论是以模块还是 CGI 的方式安装，它的解释器都可以在服务器上访问文件、运行命令以及创建网络连接等。这些功能也许会给服务器添加很多不安全因素，但是只要正确地安装和配置 PHP，以及编写安全的代码，那么 PHP 相对于 Perl 和 C 来说，是能创建出更安全的 CGI 程序的。而且，也可以在可用性和安全性之间找到一个很好的平衡点。

PHP 可能会被用在很多不同的方面，因此，PHP 内置的选项以方便用户对其进行配置。虽然众多的选项可以使 PHP 完成很多工作，但是对这些选项的设定以及对服务器的配置很可能会产生安全问题。

PHP 的选项与其语法一样，具有很高的灵活性。使用 PHP，可以在只有 shell 用户权限的环境下创建完善的服务器端程序，或者在被严格限制环境下使用它来完成服务器端包含（Server-Side Includes）而无需承但太大的风险。如何建立这样一种环境，其安全性如何，很大程度上取决于 PHP 的开发者。

本章以一些常规的安全建议作开头，讲述如何在不同的环境下尽可能地提高安全性，以及介绍对于不同安全级别的一些编程原则。


总则

绝对安全的系统是不存在的，因此安全业界常用的方法有助于平衡可用性和风险。对用户提交的每一个变量都进行双重验证可能是一个很负责任的行为，但会导致用户必须花很多时间去填写一张复杂无比的表格，从而迫使某些用户尝试绕过安全机制。

最好的安全机制应该能在不防碍用户，并且不过多地增加开发难度的情况下做到能满足需求。实际上，一些安全问题往往会发生在这种过度强化安全机制的系统上。

不要忘记著名的等强原则：一个系统的的强度是由它最薄弱的环节决定的（译者注：相当于木桶原理）。如果所有的事务都基于时间、地点、事务种类进行详细的记录，而用户验证却只依靠一个 cookie，那么用户所对应的事务记录的可信度就被大大剥弱了。

调试代码的时候一定要记住，就算是一个简单的页面也很难对所有可能发生的情况进行检测：对你不满的雇员不一定会输入如你所愿的东西，黑客也有足够的时间研究你的系统，当然，你的宠物猫也会跳到你的键盘上。这就是为什么必须检查所有的代码，去发现哪里可以引入不正当的数据，然后对代码改进、简化或者增强。

互联网上充满了为了成名而破坏你的代码、攻击你的网站并输入不正当数据的人，总之他们会使你的生活充满乐趣。无论是大网站还是小网站，只要能和互联网连接，就会成为一个目标。很多黑客程序并不理会网站的大小，只会机械地扫描 IP 地址并找寻受害者。我们希望那个不要是你。


以 CGI 模式安装时

Table of Contents

  • 可能受到的攻击
  • 情形一：只运行公开的文件
  • 情形二：使用 --enable-force-cgi-redirect 选项
  • 情形三：设置 doc_root 或 user_dir
  • 情形四：PHP 解释器放在 web 目录以外


可能受到的攻击

如果不想把 PHP 嵌入到服务器端软件（如 Apache）作为一个模块安装的话，可以选择以 CGI 的模式安装。或者把 PHP 用于不同的 CGI 封装以便为代码创建安全的 chroot 和 setuid 环境。这种安装方式通常会把 PHP 的可执行文件安装到 web 服务器的 cgi-bin 目录。CERT 建议书 » CA-96.11 建议不要把任何的解释器放到 cgi-bin 目录。尽管 PHP 可以作为一个独立的解释器，但是它的设计使它可以防止下面类型的攻击：

  • 访问系统文件：http://my.host/cgi-bin/php?/etc/passwd 在 URL 请求的问号（?）后面的信息会传给 CGI 接口作为命名行的参数。其它的解释器会在命令行中打开并执行第一个参数所指定的文件。 但是，以 CGI 模式安装的 PHP 解释器被调用时，它会拒绝解释这些参数。
  • 访问服务器上的任意目录：http://my.host/cgi-bin/php/secret/doc.html 好像上面这种情况，PHP 解释器所在目录后面的 URL 信息 /secret/doc.html 将会例行地传给 CGI 程序并进行解释。通常一些 web 服务器的会将它重定向到页面，如 http://my.host/secret/script.php。如果是这样的话，某些服务器会先检查用户访问 /secret 目录的权限，然后才会创建 http://my.host/cgi-bin/php/secret/script.php 上的页面重定向。不幸的是，很多服务器并没有检查用户访问 /secret/script.php 的权限，只检查了 /cgi-bin/php 的权限，这样任何能访问 /cgi-bin/php 的用户就可以访问 web 目录下的任意文件了。 在 PHP 里，编译时配置选项 --enable-force-cgi-redirect 以及运行时配置指令 doc_root 和 user_dir 都可以为服务器上的文件和目录添加限制，用于防止这类攻击。下面将对各个选项的设置进行详细讲解。


情形一：只运行公开的文件

如果 web 服务器中所有内容都受到密码或 IP 地址的访问限制，就不需要设置这些选项。如果 web 服务器不支持重定向，或者 web 服务器不能和 PHP 通信而使访问请求变得更为安全，可以在 configure 脚本中指定 --enable-force-cgi-redirect 选项。除此之外，还要确认 PHP 程序不依赖其它方式调用，比如通过直接的 http://my.host/cgi-bin/php/dir/script.php 访问或通过重定向访问 http://my.host/dir/script.php。

在Apache中，重定向可以使用 AddHandler 和 Action 语句来设置，请看下一节。


情形二：使用 --enable-force-cgi-redirect 选项

此编译选项可以防止任何人通过如 http://my.host/cgi-bin/php/secretdir/script.php 这样的 URL 直接调用 PHP。PHP 在此模式下只会解析已经通过了 web 服务器的重定向规则的 URL。

通常 Apache 中的重定向设置可以通过以下指令完成：

Action php-script /cgi-bin/php
AddHandler php-script .php

此选项只在 Apache 下进行过测试，并且要依赖于 Apache 在重定向操作中所设置的非标准 CGI 环境变量 REDIRECT_STATUS。如果 web 服务器不支持任何方式能够判断请求是直接的还是重定向的，就不能使用这个选项，而应该用其它方法。请看下一节。


情形三：设置 doc_root 或 user_dir

在 web 服务器的主文档目录中包含动态内容如脚本和可执行程序有时被认为是一种不安全的实践。如果因为配置上的错误而未能执行脚本而作为普通 HTML 文档显示，那就可能导致知识产权或密码资料的泄露。所以很多系统管理员都会专门设置一个只能通过 PHP CGI 来访问的目录，这样该目录中的内容只会被解析而不会原样显示出来。

对于前面所说无法判断是否重定向的情况，很有必要在主文档目录之外建立一个专用于脚本的 doc_root 目录。

可以通过配置文件内的 doc_root 或设置环境变量 PHP_DOCUMENT_ROOT 来定义 PHP 脚本主目录。如果设置了该项，那么 PHP 就只会解释 doc_root 目录下的文件，并确保目录外的脚本不会被 PHP 解释器执行（下面所说的 user_dir 除外）。

另一个可用的选项就是 user_dir。当 user_dir 没有设置的时候，doc_root 就是唯一能控制在哪里打开文件的选项。访问如 http://my.host/~user/doc.php 这个 URL 时，并不会打开用户主目录下文件，而只会执行 doc_root 目录下的 ~user/doc.php（这个子目录以 [~] 作开头）。

如果设置了 user_dir，例如 public_php，那么像 http://my.host/~user/doc.php 这样的请求将会执行用户主目录下的 public_php 子目录下的 doc.php 文件。假设用户主目录的绝对路径是 /home/user，那么被执行文件将会是 /home/user/public_php/doc.php。

user_dir 的设置与 doc_root 无关，所以可以分别控制 PHP 脚本的主目录和用户目录。


情形四：PHP 解释器放在 web 目录以外

一个非常安全的做法就是把 PHP 解释器放在 web 目录外的地方，比如说 /usr/local/bin。这样做唯一不便的地方就是必须在每一个包含 PHP 代码的文件的第一行加入如下语句：

#!/usr/local/bin/php
还要将这些文件的属性改成可执行。也就是说，要像处理用 Perl 或 sh 或其它任何脚本语言写的 CGI 脚本一样，使用以 #! 开头的 shell-escape 机制来启动它们。

在这种情况下，要使 PHP 能正确处理 PATH_INFO 和 PATH_TRANSLATED 等变量的话，在编译 PHP 解释器时必须加入 --enable-discard-path 参数。


以 Apache 模块安装时

当 PHP 以 Apache 模块方式安装时，它将继承 Apache 用户（通常为"nobody"）的权限。这对安全和认证有一些影响。比如，如果用 PHP 来访问数据库，除非数据库有自己的访问控制，否则就要使"nobody"用户可以访问数据库。这意味着恶意的脚本在不用提供用户名和密码时就可能访问和修改数据库。一个 web Spider 也完全有可能偶然发现数据库的管理页面，并且删除所有的数据库。可以通过 Apache 认证来避免此问题，或者用 LDAP、.htaccess 等技术来设计自己的访问模型，并把这些代码作为 PHP 脚本的一部份。

通常，一但安全性达到可以使 PHP 用户（这里也就是 Apache 用户）承担的风险极小的程度时候，可能 PHP 已经到了阻止向用户目录写入任何文件或禁止访问和修改数据库的地步了。这就是说，无论是正常的文件还是非正常的文件，无论是正常的数据库事务来是恶意的请求，都会被拒之门外。

一个常犯的对安全性不利的错误就是让 Apache 拥有 root 权限，或者通过其它途径斌予 Apache 更强大的功能。

把 Apache 用户的权限提升为 root 是极度危险的做法，而且可能会危及到整个系统的安全。所以除非是安全专家，否则决不要考虑使用 su，chroot 或者以 root 权限运行。

除此之外还有一些比较简单的解决方案。比如说可以使用 open_basedir 来限制哪些目录可以被 PHP 使用。也可以设置 Apache 的专属区域，从而把所有的 web 活动都限制到非用户和非系统文件之中。


  • ? 以 Apache 模块安装时
  • 文件系统安全 ?
  • PHP Manual
  • 安全
  • 会话（Session）安全

会话（Session）安全

保持 HTTP 会话管理的安全是重要的。会话安全相关内容描述章节在Session 模块 文档下的会话安全部分。


文件系统安全

Table of Contents

  • Null 字符问题

PHP 遵从大多数服务器系统中关于文件和目录权限的安全机制。这就使管理员可以控制哪些文件在文件系统内是可读的。必须特别注意的是全局的可读文件，并确保每一个有权限的用户对这些文件的读取动作都是安全的。

PHP 被设计为以用户级别来访问文件系统，所以完全有可能通过编写一段 PHP 代码来读取系统文件如 /etc/passwd，更改网络连接以及发送大量打印任务等等。因此必须确保 PHP 代码读取和写入的是合适的文件。

请看下面的代码，用户想要删除自己主目录中的一个文件。假设此情形是通过 web 界面来管理文件系统，因此 Apache 用户有权删除用户目录下的文件。

Example #1 不对变量进行安全检查会导致......

<?php
// 从用户目录中删除指定的文件
$username = $_POST['user_submitted_name'];
$userfile = $_POST['user_submitted_filename'];
$homedir = "/home/$username";
unlink ("$homedir/$userfile");
echo "The file has been deleted!";
?>
既然 username 和 filename 变量可以通过用户表单来提交，那就可以提交别人的用户名和文件名，甚至可以删掉本来不应该让他们删除的文件。这种情况下，就要考虑其它方式的认证。想想看如果提交的变量是"../etc/"和"passwd"会发生什么。上面的代码就等同于：

Example #2 ......文件系统攻击

<?php
// 删除硬盘中任何 PHP 有访问权限的文件。如果 PHP 有 root 权限：
$username = $_POST['user_submitted_name']; // "../etc"
$userfile = $_POST['user_submitted_filename']; // "passwd"
$homedir  = "/home/$username"; // "/home/../etc"

unlink("$homedir/$userfile"); // "/home/../etc/passwd"

echo "The file has been deleted!";
?>
有两个重要措施来防止此类问题。
  • 只给 PHP 的 web 用户很有限的权限。
  • 检查所有提交上来的变量。
下面是改进的脚本：

Example #3 更安全的文件名检查

<?php
// 删除硬盘中 PHP 有权访问的文件
$username = $_SERVER['REMOTE_USER']; // 使用认证机制
$userfile = basename($_POST['user_submitted_filename']);
$homedir = "/home/$username";

$filepath = "$homedir/$userfile";

if (file_exists($filepath) && unlink($filepath)) {
    $logstring = "Deleted $filepath\n";
} else {
    $logstring = "Failed to delete $filepath\n";
}
$fp = fopen("/home/logging/filedelete.log", "a");
fwrite ($fp, $logstring);
fclose($fp);

echo htmlentities($logstring, ENT_QUOTES);
?>
然而，这样做仍然是有缺陷的。如果认证系统允许用户建立自己的登录用户名，而用户选择用"../etc/"作为用户名，系统又一次沦陷了。所以，需要加强检查：

Example #4 更安全的文件名检查

<?php
$username = $_SERVER['REMOTE_USER']; // 使用认证机制
$userfile     = $_POST['user_submitted_filename'];
$homedir = "/home/$username";

$filepath     = "$homedir/$userfile";
if (!ctype_alnum($username) || !preg_match('/^(?:[a-z0-9_-]|\.(?!\.))+$/iD', $userfile)) {
    die("Bad username/filename");
}
//后略......
?>

根据操作系统的不同，存在着各种各样需要注意的文件，包括联系到系统的设备（/dev/ 或者 COM1）、配置文件（/ect/ 文件和 .ini文件）、常用的存储区域（/home/ 或者 My Documents）等等。由于此原因，建立一个策略禁止所有权限而只开放明确允许的通常更容易些。


Null 字符问题

由于 PHP 的文件系统操作是基于 C 语言的函数的，所以它可能会以您意想不到的方式处理 Null 字符。 Null字符在 C 语言中用于标识字符串结束，一个完整的字符串是从其开头到遇见 Null 字符为止。 以下代码演示了类似的攻击：

Example #1 会被 Null 字符问题攻击的代码

<?php
$file = $_GET['file']; // "../../etc/passwd\0"
if (file_exists('/home/wwwrun/'.$file.'.php')) {
    // file_exists will return true as the file /home/wwwrun/../../etc/passwd exists
    include '/home/wwwrun/'.$file.'.php';
    // the file /etc/passwd will be included
}
?>

因此，任何用于操作文件系统的字符串（译注：特别是程序外部输入的字符串）都必须经过适当的检查。以下是上述例子的改进版本：

Example #2 验证输入的正确做法

<?php
$file = $_GET['file'];

// 对字符串进行白名单检查
switch ($file) {
    case 'main':
    case 'foo':
    case 'bar':
        include '/home/wwwrun/include/'.$file.'.php';
        break;
    default:
        include '/home/wwwrun/include/main.php';
}
?>


数据库安全

Table of Contents

  • 设计数据库
  • 连接数据库
  • 加密存储模型
  • SQL 注入

今时今日，数据库系统已经成为各个动态网站上 web 应用程序的重要组成部分。由于非常敏感和机密的数据有可能保存在数据库中，所以对数据库实施保护就显得尤为重要了。

要从数据库中提取或者存入数据，就必须经过连接数据库、发送一条合法查询、获取结果、关闭连接等步骤。目前，能完成这一系列动作的最常用的查询语言是结构化查询语言 Structured Query Language (SQL)。可以看看攻击者是如何篡改 SQL 查询语句的。

PHP 本身并不能保护数据库的安全。下面的章节只是讲述怎样用 PHP 脚本对数据库进行基本的访问和操作。

记住一条简单的原则：深入防御。保护数据库的措施越多，攻击者就越难获得和使用数据库内的信息。正确地设计和应用数据库可以减少被攻击的担忧。


设计数据库

第一步一般都是创建数据库，除非是使用第三方的数据库服务。当创建一个数据库的时候，会指定一个所有者来执行和新建语句。通常，只有所有者（或超级用户）才有权对数据库中的对象进行任意操作。如果想让其他用户使用，就必须赋予他们权限。

应用程序永远不要使用数据库所有者或超级用户帐号来连接数据库，因为这些帐号可以执行任意的操作，比如说修改数据库结构（例如删除一个表）或者清空整个数据库的内容。

应该为程序的每个方面创建不同的数据库帐号，并赋予对数据库对象的极有限的权限。仅分配给能完成其功能所需的权限，避免同一个用户可以完成另一个用户的事情。这样即使攻击者利用程序漏洞取得了数据库的访问权限，也最多只能做到和该程序一样的影响范围。

鼓励用户不要把所有的事务逻辑都用 web 应用程序（即用户的脚本）来实现。最好用视图（view）、触发器（trigger）或者规则（rule）在数据库层面完成。当系统升级的时候，需要为数据库开辟新的接口，这时就必须重做所有的数据库客户端。除此之外，触发器还可以透明和自动地处理字段，并在调试程序和跟踪事实时提供有用的信息。


连接数据库

把连接建立在 SSL 加密技术上可以增加客户端和服务器端通信的安全性，或者 SSH 也可以用于加密客户端和数据库之间的连接。如果使用了这些技术的话，攻击者要监视服务器的通信或者得到数据库的信息是很困难的。


加密存储模型

SSL/SSH 能保护客户端和服务器端交换的数据，但 SSL/SSH 并不能保护数据库中已有的数据。SSL 只是一个加密网络数据流的协议。

如果攻击者取得了直接访问数据库的许可（绕过 web 服务器），敏感数据就可能暴露或者被滥用，除非数据库自己保护了这些信息。对数据库内的数据加密是减少这类风险的有效途径，但是只有很少的数据库提供这些加密功能。

解决这个问题最简单的方法是创建自己的加密包，然后在 PHP 脚本中使用它。PHP 可以通过一些扩展来帮助你解决这个问题，比如 OpenSSL 和 Sodium，涵盖了多种加密算法。脚本在将数据插入数据库之前对其进行加密，并在检索时对其进行解密。更多关于加密工作的例子请参见参考文献。

Hashing

In the case of truly hidden data, if its raw representation is not needed (i.e. will not be displayed), hashing should be taken into consideration. The well-known example for hashing is storing the cryptographic hash of a password in a database, instead of the password itself.

The password functions provide a convenient way to hash sensitive data and work with these hashes.

password_hash() is used to hash a given string using the strongest algorithm currently available and password_verify() checks whether the given password matches the hash stored in database.

Example #1 Hashing password field

<?php

// 存储密码散列
$query  = sprintf("INSERT INTO users(name,pwd) VALUES('%s','%s');",
            pg_escape_string($username),
            password_hash($password, PASSWORD_DEFAULT));
$result = pg_query($connection, $query);

// 发送请求来验证用户密码
$query = sprintf("SELECT pwd FROM users WHERE name='%s';",
            pg_escape_string($username));
$row = pg_fetch_assoc(pg_query($connection, $query));

if ($row && password_verify($password, $row['pwd'])) {
    echo 'Welcome, ' . htmlspecialchars($username) . '!';
} else {
    echo 'Authentication failed for ' . htmlspecialchars($username) . '.';
}

?>


SQL 注入

很多 web 开发者没有注意到 SQL 查询是可以被篡改的，因而把 SQL 查询当作可信任的命令。殊不知道，SQL 查询可以绕开访问控制，从而绕过身份验证和权限检查。更有甚者，有可能通过 SQL 查询去运行主机操作系统级的命令。

直接 SQL 命令注入就是攻击者常用的一种创建或修改已有 SQL 语句的技术，从而达到取得隐藏数据，或覆盖关键的值，甚至执行数据库主机操作系统命令的目的。这是通过应用程序取得用户输入并与静态参数组合成 SQL 查询来实现的。下面将会给出一些真实的例子。

由于在缺乏对输入的数据进行验证，并且使用了超级用户或其它有权创建新用户的数据库帐号来连接，攻击者可以在数据库中新建一个超级用户。

Example #1 一段实现数据分页显示的代码...... 也可以被用作创建一个超级用户（PostgreSQL 数据库）。

<?php

$offset = $argv[0]; // 注意，没有输入验证！
$query  = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $offset;";
$result = pg_query($conn, $query);

?>
一般的用户会点击 $offset 已被斌值的"上一页"、"下一页"的链接。原本代码只会认为 $offset 是一个数值。然而，如果有人尝试把以下语句先经过 urlencode() 处理，然后加入URL中的话：
0;
insert into pg_shadow(usename,usesysid,usesuper,usecatupd,passwd)
    select 'crack', usesysid, 't','t','crack'
    from pg_shadow where usename='postgres';
--
那么他就可以创建一个超级用户了。注意那个 0; 只不过是为了提供一个正确的偏移量以便补充完整原来的查询，使它不要出错而已。

Note:

-- 是 SQL 的注释标记，一般可以使用来它告诉 SQL 解释器忽略后面的语句。

对显示搜索结果的页面下手是一个能得到密码的可行办法。攻击者所要做的只不过是找出哪些提交上去的变量是用于 SQL 语句并且处理不当的。而这类的变量通常都被用于 SELECT 查询中的条件语句，如 WHERE, ORDER BY, LIMIT 和 OFFSET。如果数据库支持 UNION 构造的话，攻击者还可能会把一个完整的 SQL 查询附加到原来的语句上以便从任意数据表中得到密码。因此，对密码字段加密是很重要的。

Example #2 显示文章......以及一些密码（任何数据库系统）

<?php

$query  = "SELECT id, name, inserted, size FROM products
           WHERE size = '$size'";
$result = odbc_exec($conn, $query);

?>
可以在原来的查询的基础上添加另一个 SELECT 查询来获得密码：
'
union select '1', concat(uname||'-'||passwd) as name, '1971-01-01', '0' from usertable;
--
假如上述语句（使用 ' 和 --）被加入到 $query 中的任意一个变量的话，那么就麻烦了。

SQL 中的 UPDATE 也会受到攻击。这种查询也可能像上面的例子那样被插入或附加上另一个完整的请求。但是攻击者更愿意对 SET 子句下手，这样他们就可以更改数据表中的一些数据。这种情况下必须要知道数据库的结构才能修改查询成功进行。可以通过表单上的变量名对字段进行猜测，或者进行暴力破解。对于存放用户名和密码的字段，命名的方法并不多。

Example #3 从重设密码......到获得更多权限（任何数据库系统）

<?php
$query = "UPDATE usertable SET pwd='$pwd' WHERE uid='$uid';";
?>
但是恶意的用户会把 ' or uid like'%admin%'; -- 作为变量的值提交给 $uid 来改变 admin 的密码，或者把 $pwd 的值提交为 "hehehe', admin='yes', trusted=100 "（后面有个空格）去获得更多的权限。这样做的话，查询语句实际上就变成了：
<?php

// $uid: ' or uid like '%admin%
$query = "UPDATE usertable SET pwd='...' WHERE uid='' or uid like '%admin%';";

// $pwd: hehehe', trusted=100, admin='yes
$query = "UPDATE usertable SET pwd='hehehe', trusted=100, admin='yes' WHERE
...;";

?>

下面这个可怕的例子将会演示如何在某些数据库上执行系统命令。

Example #4 攻击数据库所在主机的操作系统（MSSQL Server 数据库）

<?php

$query  = "SELECT * FROM products WHERE id LIKE '%$prod%'";
$result = mssql_query($query);

?>
如果攻击提交 a%' exec master..xp_cmdshell 'net user test testpass /ADD' -- 作为变量 $prod的值，那么 $query 将会变成
<?php

$query  = "SELECT * FROM products
           WHERE id LIKE '%a%'
           exec master..xp_cmdshell 'net user test testpass /ADD' --%'";
$result = mssql_query($query);

?>
MSSQL 服务器会执行这条 SQL 语句，包括它后面那个用于向系统添加用户的命令。如果这个程序是以 sa 运行而 MSSQLSERVER 服务又有足够的权限的话，攻击者就可以获得一个系统帐号来访问主机了。

Note:

虽然以上的例子是针对某一特定的数据库系统的，但是这并不代表不能对其它数据库系统实施类似的攻击。使用不同的方法，各种数据库都有可能遭殃。

关于 SQL 注入问题的工作实例
Image courtesy of » xkcd

预防措施

也许有人会自我安慰，说攻击者要知道数据库结构的信息才能实施上面的攻击。没错，确实如此。但没人能保证攻击者一定得不到这些信息，一但他们得到了，数据库有泄露的危险。如果你在用开放源代码的软件包来访问数据库，比如论坛程序，攻击者就很容得到到相关的代码。如果这些代码设计不良的话，风险就更大了。

这些攻击总是建立在发掘安全意识不强的代码上的。所以，永远不要信任外界输入的数据，特别是来自于客户端的，包括选择框、表单隐藏域和 cookie。就如上面的第一个例子那样，就算是正常的查询也有可能造成灾难。

  • 永远不要使用超级用户或所有者帐号去连接数据库。要用权限被严格限制的帐号。
  • 检查输入的数据是否具有所期望的数据格式。PHP 有很多可以用于检查输入的函数，从简单的 变量函数 和 字符类型函数（比如 is_numeric()，ctype_digit()）到复杂的 Perl 兼容正则表达式函数都可以完成这个工作。

  • 如果程序等待输入一个数字，可以考虑使用 is_numeric()
来检查，或者直接使用 settype() 来转换它的类型，也可以用
sprintf() 把它格式化为数字。

    Example #5 一个实现分页更安全的方法

    <?php

    settype    ($offset, 'integer');
    $query = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $offset;";

    // 请注意格式字符串中的 %d，如果用 %s 就毫无意义了
    $query = sprintf("SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET %d;",
                         $offset);

    ?>

  • 使用数据库特定的敏感字符转义函数（比如 mysql_escape_string() 和
sql_escape_string()）把用户提交上来的非数字数据进行转义。如果数据库没有专门的敏感字符转义功能的话
addslashes() 和 str_replace()
可以代替完成这个工作。看看第一个例子，此例显示仅在查询的静态部分加上引号是不够的，查询很容易被攻破。
  • 要不择手段避免显示出任何有关数据库的信心，尤其是数据库结构。参见错误报告和错误处理函数。
  • 也可以选择使用数据库的存储过程和预定义指针等特性来抽象数库访问，使用户不能直接访问数据表和视图。但这个办法又有别的影响。

除此之外，在允许的情况下，使用代码或数据库系统保存查询日志也是一个好办法。显然，日志并不能防止任何攻击，但利用它可以跟踪到哪个程序曾经被尝试攻击过。日志本身没用，要查阅其中包含的信息才行。毕竟，更多的信息总比没有要好。


错误报告

对于 PHP 的安全性来说错误报告是一把双刃剑。一方面可以提高安全性，另一方面又有害。

攻击系统时经常使用的手法就是输入不正确的数据，然后查看错误提示的类型及上下文。这样做有利于攻击者收集服务器的信息以便寻找弱点。比如说，如果一个攻击者知道了一个页面所基于的表单信息，那么他就会尝试修改变量：

Example #1 用自定义的 HTML 页面攻击变量

<form method="post" action="attacktarget?username=badfoo&amp;password=badfoo">
<input type="hidden" name="username" value="badfoo" />
<input type="hidden" name="password" value="badfoo" />
</form>

通常 PHP 所返回的错误提示都能帮助开发者调试程序，它会提出哪个文件的哪些函数或代码出错，并指出错误发生的在文件的第几行，这些就是 PHP 本身所能给出的信息。很多 PHP 开发者会使用 show_source()、highlight_string() 或者 highlight_file() 函数来调试代码，但是在正式运行的网站中，这种做法可能会暴露出隐藏的变量、未检查的语法和其它的可能危及系统安全的信息。在运行一些具有内部调试处理的程序，或者使用通用调试技术是很危险的。如果让攻击者确定了程序是使用了哪种具体的调试技术，他们会尝试发送变量来打开调试功能：

Example #2 利用变量打开调式功能

<form method="post" action="attacktarget?errors=Y&amp;showerrors=1&amp;debug=1">
<input type="hidden" name="errors" value="Y" />
<input type="hidden" name="showerrors" value="1" />
<input type="hidden" name="debug" value="1" />
</form>

不管错误处理机制如何，可以探测系统错误的能力会给攻击者提供更多信息。

比如说，PHP 的独有的错误提示风格可以说明系统在运行 PHP。如果攻击者在寻找一个 .html 为页面，想知道其后台的技术（为了寻找系统弱点），他们就会把错误的数据提交上去，然后就有可以得知系统是基于 PHP 的了。

一个函数错误就可能暴露系统正在使用的数据库，或者为攻击者提供有关网页、程序或设计方面的有用信息。攻击者往往会顺藤摸瓜地找到开放的数据库端口，以及页面上某些 bug 或弱点等。比如说，攻击者可以一些不正常的数据使程序出错，来探测脚本中认证的顺序（通过错误提示的行号数字）以及脚本中其它位置可能泄露的信息。

一个文件系统或者 PHP 的错误就会暴露 web 服务器具有什么权限，以及文件在服务器上的组织结构。开发者自己写的错误代码会加剧此问题，导致泄漏了原本隐藏的信息。

有三个常用的办法处理这些问题。第一个是彻底地检查所有函数，并尝试弥补大多数错误。第二个是对在线系统彻底关闭错误报告。第三个是使用 PHP 自定义的错误处理函数创建自己的错误处理机制。根据不同的安全策略，三种方法可能都适用。

一个能提前阻止这个问题发生的方法就是利用 error_reporting() 来帮助使代码更安全并发现变量使用的危险之处。在发布程序之前，先打开 E_ALL 测试代码，可以帮你很快找到变量使用不当的地方。一旦准备正式发布，就应该把 error_reporting() 的参数设为 0 来彻底关闭错误报告或者把 php.ini 中的 display_errors 设为 off 来关闭所有的错误显示以将代码隔绝于探测。当然，如果要迟一些再这样做，就不要忘记打开 ini 文件内的 log_errors 选项，并通过 error_log 指定用于记录错误信息的文件。

Example #3 用 E_ALL 来查找危险的变量

<?php
if ($username) {  // Not initialized or checked before usage
    $good_login = 1;
}
if ($good_login == 1) { // If above test fails, not initialized or checked before usage
    readfile ("/highly/sensitive/data/index.html");
}
?>


用户提交的数据

很多 PHP 程序所存在的重大弱点并不是 PHP 语言本身的问题，而是编程者的安全意识不高而导致的。因此，必须时时注意每一段代码可能存在的问题，去发现非正确数据提交时可能造成的影响。

Example #1 危险的变量用法

<?php
// 从用户目录中删除一个文件，或者......能删除更多的东西？
unlink ($evil_var);

// 记录用户的登陆，或者......能否在 /etc/passwd 添加数据？
fwrite ($fp, $evil_var);

// 执行一些普通的命令，或者......可以执行 rm -rf * ？
system ($evil_var);
exec ($evil_var);

?>

必须时常留意你的代码，以确保每一个从客户端提交的变量都经过适当的检查，然后问自己以下一些问题：

  • 此脚本是否只能影响所预期的文件？
  • 非正常的数据被提交后能否产生作用？
  • 此脚本能用于计划外的用途吗？
  • 此脚本能否和其它脚本结合起来做坏事？
  • 是否所有的事务都被充分记录了？
在写代码的时候问自己这些问题，否则以后可能要为了增加安全性而重写代码了。注意了这些问题的话，也许还不完全能保证系统的安全，但是至少可以提高安全性。

还可以考虑关闭 register_globals，magic_quotes 或者其它使编程更方便但会使某个变量的合法性，来源和其值被搞乱的设置。在开发时，可以使用 error_reporting(E_ALL) 模式帮助检查变量使用前是否有被检查或被初始化，这样就可以防止某些非正常的数据的挠乱了。


隐藏 PHP

一般而言，通过隐藏的手段提高安全性被认为是作用不大的做法。但某些情况下，尽可能的多增加一份安全性都是值得的。

一些简单的方法可以帮助隐藏 PHP，这样做可以提高攻击者发现系统弱点的难度。在 php.ini 文件里设置 expose_php = off ，可以减少他们能获得的有用信息。

另一个策略就是让 web 服务器用 PHP 解析不同扩展名。无论是通过 .htaccess 文件还是 Apache 的配置文件，都可以设置能误导攻击者的文件扩展名：

Example #1 把 PHP 隐藏为另一种语言

# 使PHP看上去像其它的编程语言
AddType application/x-httpd-php .asp .py .pl
或者干脆彻底隐藏它：

Example #2 使用未知的扩展名作为 PHP 的扩展名

# 使 PHP 看上去像未知的文件类型
AddType application/x-httpd-php .bop .foo .133t
或者把它隐藏为 HTML 页面，这样所有的 HTML 文件都会通过 PHP 引擎，会为服务器增加一些负担：

Example #3 用 HTML 做 PHP 的文件后缀

# 使 PHP 代码看上去像 HTML 页面
AddType application/x-httpd-php .htm .html
要让此方法生效，必须把 PHP 文件的扩展名改为以上的扩展名。这样就通过隐藏来提高了安全性，虽然防御能力很低而且有些缺点。


保持更新

PHP 和其它的大型系统一样，在持续的研究和改进中。每一个版本都会有或多或少的改进来增强安全性和修复任何缺陷，配置问题以及任何会影响到整个系统安全与性能的问题。

和其它系统级的脚本语言一样，最好的途径是经常更新，并时刻留意最新版本及其改变。


特点

  • 用 PHP 进行 HTTP 认证
  • Cookie
  • 会话
  • 处理 XForms
  • 文件上传处理
    • POST 方法上传
    • 错误信息说明
    • 常见缺陷
    • 上传多个文件
    • 对 PUT 方法的支持
    • 参见
  • 使用远程文件
  • 连接处理
  • 数据库持久连接
  • PHP 的命令行模式
    • 如何得知自己使用的是哪个 SAPI？
    • 和其它 SAPI 模块的区别
    • Options — 命令行模式的选项参数
    • Usage — Executing PHP files
    • I/O streams — Input/output streams
    • Interactive shell
    • 内置Web Server
    • INI 配置
  • 垃圾回收机制
    • 引用计数基本知识
    • 回收周期(Collecting Cycles)
    • 性能方面考虑的因素
  • DTrace 动态跟踪
    • PHP 和 DTrace 介绍
    • 使用 PHP 和 DTrace
    • 使用 SystemTap 监控 PHP DTrace 静态探针


用 PHP 进行 HTTP 认证

可以用 header() 函数来向客户端浏览器发送"Authentication Required"信息，使其弹出一个用户名／密码输入窗口。当用户输入用户名和密码后，包含有 URL 的 PHP 脚本将会加上预定义变量 PHP_AUTH_USER，PHP_AUTH_PW 和 AUTH_TYPE 被再次调用，这三个变量分别被设定为用户名，密码和认证类型。预定义变量保存在 $_SERVER 数组中。支持"Basic"和"Digest"（自 PHP 5.1.0 起）认证方法。请参阅 header() 函数以获取更多信息。

以下是在页面上强迫客户端认证的脚本范例：

Example #1 Basic HTTP 认证范例

<?php
  if (!isset($_SERVER['PHP_AUTH_USER'])) {
    header('WWW-Authenticate: Basic realm="My Realm"');
    header('HTTP/1.0 401 Unauthorized');
    echo 'Text to send if user hits Cancel button';
    exit;
  } else {
    echo "<p>Hello {$_SERVER['PHP_AUTH_USER']}.</p>";
    echo "<p>You entered {$_SERVER['PHP_AUTH_PW']} as your password.</p>";
  }
?>

Example #2 Digest HTTP 认证范例

本例演示怎样实现一个简单的 Digest HTTP 认证脚本。更多信息请参考 » RFC 2617。

<?php
$realm = 'Restricted area';

//user => password
$users = array('admin' => 'mypass', 'guest' => 'guest');

if (empty($_SERVER['PHP_AUTH_DIGEST'])) {
    header('HTTP/1.1 401 Unauthorized');
    header('WWW-Authenticate: Digest realm="'.$realm.
           '",qop="auth",nonce="'.uniqid().'",opaque="'.md5($realm).'"');

    die('Text to send if user hits Cancel button');
}

// analyze the PHP_AUTH_DIGEST variable
if (!($data = http_digest_parse($_SERVER['PHP_AUTH_DIGEST'])) ||
    !isset($users[$data['username']]))
    die('Wrong Credentials!');

// generate the valid response
$A1 = md5($data['username'] . ':' . $realm . ':' . $users[$data['username']]);
$A2 = md5($_SERVER['REQUEST_METHOD'].':'.$data['uri']);
$valid_response = md5($A1.':'.$data['nonce'].':'.$data['nc'].':'.$data['cnonce'].':'.$data['qop'].':'.$A2);

if ($data['response'] != $valid_response)
    die('Wrong Credentials!');

// ok, valid username & password
echo 'You are logged in as: ' . $data['username'];

// function to parse the http auth header
function http_digest_parse($txt)
{
    // protect against missing data
    $needed_parts = array('nonce'=>1, 'nc'=>1, 'cnonce'=>1, 'qop'=>1, 'username'=>1, 'uri'=>1, 'response'=>1);
    $data = array();
    $keys = implode('|', array_keys($needed_parts));

    preg_match_all('@(' . $keys . ')=(?:([\'"])([^\2]+?)\2|([^\s,]+))@', $txt, $matches, PREG_SET_ORDER);

    foreach ($matches as $m) {
        $data[$m[1]] = $m[3] ? $m[3] : $m[4];
        unset($needed_parts[$m[1]]);
    }

    return $needed_parts ? false : $data;
}
?>

Note: 兼容性问题

在编写 HTTP 标头代码时请格外小心。为了对所有的客户端保证兼容性，关键字"Basic"的第一个字母必须大写为"B"，分界字符串必须用双引号（不是单引号）引用；并且在标头行 HTTP/1.0 401 中，在 401 前必须有且仅有一个空格。

在以上例子中，仅仅只打印出了 PHP_AUTH_USER 和 PHP_AUTH_PW 的值，但在实际运用中，可能需要对用户名和密码的合法性进行检查。或许进行数据库的查询，或许从 dbm 文件中检索。

注意有些 Internet Explorer 浏览器本身有问题。它对标头的顺序显得似乎有点吹毛求疵。目前看来在发送 HTTP/1.0 401 之前先发送 WWW-Authenticate 标头似乎可以解决此问题。

Note: 配置说明

PHP 用是否有 AuthType 指令来判断外部认证机制是否有效。

注意，这仍然不能防止有人通过未认证的 URL 来从同一服务器上认证的 URL 上偷取密码。

Netscape Navigator 和 Internet Explorer 浏览器都会在收到 401 的服务端返回信息时清空所有的本地浏览器整个域的 Windows 认证缓存。这能够有效的注销一个用户，并迫使他们重新输入他们的用户名和密码。有些人用这种方法来使登录状态"过期"，或者作为"注销"按钮的响应行为。

Example #3 强迫重新输入用户名和密码的 HTTP 认证的范例

<?php
  function authenticate() {
    header('WWW-Authenticate: Basic realm="Test Authentication System"');
    header('HTTP/1.0 401 Unauthorized');
    echo "You must enter a valid login ID and password to access this resource\n";
    exit;
  }

  if (!isset($_SERVER['PHP_AUTH_USER']) ||
      ($_POST['SeenBefore'] == 1 && $_POST['OldAuth'] == $_SERVER['PHP_AUTH_USER'])) {
   authenticate();
  }
  else {
   echo "<p>Welcome: {$_SERVER['PHP_AUTH_USER']}<br />";
   echo "Old: {$_REQUEST['OldAuth']}";
   echo "<form action='{$_SERVER['PHP_SELF']}' METHOD='post'>\n";
   echo "<input type='hidden' name='SeenBefore' value='1' />\n";
   echo "<input type='hidden' name='OldAuth' value='{$_SERVER['PHP_AUTH_USER']}' />\n";
   echo "<input type='submit' value='Re Authenticate' />\n";
   echo "</form></p>\n";
  }

该行为对于 HTTP 的 Basic 认证标准来说并不是必须的，因此不能依靠这种方法。对 Lynx 浏览器的测试表明 Lynx 在收到 401 的服务端返回信息时不会清空认证文件，因此只要对认证文件的检查要求没有变化，只要用户点击"后退"按钮，再点击"前进"按钮，其原有资源仍然能够被访问。不过，用户可以通过按"_"键来清空他们的认证信息。

为了能够使HTTP工作在 IIS 服务器的 CGI 模式下。 你需要编辑 IIS的设置"目录安全"。点击"编辑"并且只选择"匿名访问"，其它所有的复选框都应该留空。

Note: IIS 注意事项
要 HTTP 认证能够在 IIS 下工作，PHP 配置选项 cgi.rfc2616_headers 必须设置成 0（默认值）。


Cookie

PHP 透明地支持 HTTP cookie。cookie 是一种在远程浏览器端储存数据并以此来跟踪和识别用户的机制。可以用 setcookie() 或 setrawcookie() 函数来设置 cookie。cookie 是 HTTP 标头的一部分，因此 setcookie() 函数必须在其它信息被输出到浏览器前调用，这和对 header() 函数的限制类似。可以使用输出缓冲函数来延迟脚本的输出，直到按需要设置好了所有的 cookie 或者其它HTTP头。

如果 variables_order 中包括"C"，则任何从客户端发送的 cookie 都会被自动包括进 $_COOKIE 自动全局数组。如果希望对一个 cookie 变量设置多个值，则需在 cookie 的名称后加 [] 符号。

关于更多细节以及有关浏览器问题的注意事项，参见 setcookie() 和 setrawcookie() 函数。


会话

会话机制(Session）在PHP 中用于保持用户连续访问Web应用时的相关数据，有助于创建高度定制化的程序、增加站点的吸引力。关于会话机制的更多信息，请参见会话处理函数一章。


处理 XForms

» XForms 定义了一种传统 web 表单的变种，它可以用于更多的平台和浏览器，甚至非传统的媒体例如 PDF 文档。

XFroms 的第一个关键区别是表单怎样发送到客户端。» XForms for HTML Authors 包含有怎样创建 XForms 的详细说明。本节只看一个简单例子。

Example #1 一个简单的 XForms 搜索表单

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
 <h:title>Search</h:title>
 <model>
  <submission action="http://example.com/search"
              method="post" xml:id="s"/>
 </model>
</h:head>
<h:body>
 <h:p>
  <input ref="q"><label>Find</label></input>
  <submit submission="s"><label>Go</label></submit>
 </h:p>
</h:body>
</h:html>

上面的表单显示一个文本输入框（命名为 q）和一个提交按钮。当点击提交按钮，表单将被发送到 action 所指示的页面。

下面是从 web 应用端的角度看上去的区别。在普通的 HTML 表单中，数据发送格式是 application/x-www-form-urlencoded，在 XForms 的世界中，该信息是以 XML 格式数据发送的。

如果选择使用 XForms，那么数据为 XML，这种情况下，在 $HTTP_RAW_POST_DATA 中包含了由浏览器产生的 XML 文档，可以将其传递给所偏好的 XSLT 引擎或者文档解析器。

如果对格式不感兴趣，只想让数据进入到传统的 $_POST 变量中，可以指示客户端浏览器将其以 application/x-www-form-urlencoded 格式发送，只要将 method 属性改成 urlencoded-post 即可。

Example #2 使用 XForm 来产生 $_POST

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
 <h:title>Search</h:title>
 <model>
  <submission action="http://example.com/search"
              method="urlencoded-post" xml:id="s"/>
 </model>
</h:head>
<h:body>
 <h:p>
  <input ref="q"><label>Find</label></input>
  <submit submission="s"><label>Go</label></submit>
 </h:p>
</h:body>
</h:html>

Note: 在写本文档时，许多浏览器还不支持 XForms。如果上面例子失败请检查自己的浏览器版本。


文件上传处理

Table of Contents

  • POST 方法上传
  • 错误信息说明
  • 常见缺陷
  • 上传多个文件
  • 对 PUT 方法的支持
  • 参见


POST 方法上传

本特性可以使用户上传文本和二进制文件。用 PHP 的认证和文件操作函数，可以完全控制允许哪些人上传以及文件上传后怎样处理。

PHP 能够接受任何来自符合 RFC-1867 标准的浏览器上传的文件。

Note: 相关的设置

请参阅 php.ini 的 file_uploads，upload_max_filesize，upload_tmp_dir post_max_size 以及 max_input_time 设置选项。

请注意 PHP 也支持 PUT 方法的文件上传，Netscape Composer 和 W3C 的 Amaya 客户端使用这种方法。请参阅对 PUT 方法的支持以获取更多信息。

Example #1 文件上传表单

可以如下建立一个特殊的表单来支持文件上传：

<!-- The data encoding type, enctype, MUST be specified as below -->
<form enctype="multipart/form-data" action="__URL__" method="POST">
    <!-- MAX_FILE_SIZE must precede the file input field -->
    <input type="hidden" name="MAX_FILE_SIZE" value="30000" />
    <!-- Name of input element determines name in $_FILES array -->
    Send this file: <input name="userfile" type="file" />
    <input type="submit" value="Send File" />
</form>

以上范例中的 __URL__ 应该被换掉，指向一个真实的 PHP 文件。

MAX_FILE_SIZE 隐藏字段（单位为字节）必须放在文件输入字段之前，其值为接收文件的最大尺寸。这是对浏览器的一个建议，PHP 也会检查此项。在浏览器端可以简单绕过此设置，因此不要指望用此特性来阻挡大文件。实际上，PHP 设置中的上传文件最大值是不会失效的。但是最好还是在表单中加上此项目，因为它可以避免用户在花时间等待上传大文件之后才发现文件过大上传失败的麻烦。

Note:

要确保文件上传表单的属性是 enctype="multipart/form-data"，否则文件上传不了。

全局变量 $_FILES 包含有所有上传的文件信息。 数组的内容来自以下范例表单。我们假设文件上传字段的名称如下例所示，为 userfile。名称可随意命名。

$_FILES['userfile']['name']

客户端机器文件的原名称。

$_FILES['userfile']['type']

文件的 MIME 类型，如果浏览器提供此信息的话。一个例子是"image/gif"。不过此 MIME 类型在 PHP 端并不检查，因此不要想当然认为有这个值。

$_FILES['userfile']['size']

已上传文件的大小，单位为字节。

$_FILES['userfile']['tmp_name']

文件被上传后在服务端储存的临时文件名。

$_FILES['userfile']['error']

和该文件上传相关的错误代码。

文件被上传后，默认地会被储存到服务端的默认临时目录中，除非 php.ini 中的 upload_tmp_dir 设置为其它的路径。服务端的默认临时目录可以通过更改 PHP 运行环境的环境变量 TMPDIR 来重新设置，但是在 PHP 脚本内部通过运行 putenv() 函数来设置是不起作用的。该环境变量也可以用来确认其它的操作也是在上传的文件上进行的。

Example #2 验证上传的文件

请查阅函数 is_uploaded_file() 和 move_uploaded_file() 以获取进一步的信息。 以下范例处理由表单提供的文件上传。

<?php
$uploaddir = '/var/www/uploads/';
$uploadfile = $uploaddir . basename($_FILES['userfile']['name']);

echo '<pre>';
if (move_uploaded_file($_FILES['userfile']['tmp_name'], $uploadfile)) {
    echo "File is valid, and was successfully uploaded.\n";
} else {
    echo "Possible file upload attack!\n";
}

echo 'Here is some more debugging info:';
print_r($_FILES);

print "</pre>";

?>

接受上传文件的 PHP 脚本为了决定接下来要对该文件进行哪些操作，应该实现任何逻辑上必要的检查。例如可以用 $_FILES['userfile']['size'] 变量来排除过大或过小的文件，也可以通过 $_FILES['userfile']['type'] 变量来排除文件类型和某种标准不相符合的文件，但只把这个当作一系列检查中的第一步，因为此值完全由客户端控制而在 PHP 端并不检查。同时，还可以通过 $_FILES['userfile']['error'] 变量来根据不同的错误代码来计划下一步如何处理。不管怎样，要么将该文件从临时目录中删除，要么将其移动到其它的地方。

如果表单中没有选择上传的文件，则 PHP 变量 $_FILES['userfile']['size'] 的值将为 0，$_FILES['userfile']['tmp_name'] 将为空。

如果该文件没有被移动到其它地方也没有被改名，则该文件将在表单请求结束时被删除。

Example #3 上传一组文件

PHP 的 HTML 数组特性甚至支持文件类型。

<form action="" method="post" enctype="multipart/form-data">
<p>Pictures:
<input type="file" name="pictures[]" />
<input type="file" name="pictures[]" />
<input type="file" name="pictures[]" />
<input type="submit" value="Send" />
</p>
</form>
<?php
foreach ($_FILES["pictures"]["error"] as $key => $error) {
    if ($error == UPLOAD_ERR_OK) {
        $tmp_name = $_FILES["pictures"]["tmp_name"][$key];
        // basename() may prevent filesystem traversal attacks;
        // further validation/sanitation of the filename may be appropriate
        $name = basename($_FILES["pictures"]["name"][$key]);
        move_uploaded_file($tmp_name, "data/$name");
    }
}
?>

File upload progress bar can be implemented using Session Upload Progress.


错误信息说明

PHP 将随文件信息数组一起返回一个对应的错误代码。该代码可以在文件上传时生成的文件数组中的 error 字段中被找到，也就是 $_FILES['userfile']['error']。

UPLOAD_ERR_OK

其值为 0，没有错误发生，文件上传成功。

UPLOAD_ERR_INI_SIZE

其值为 1，上传的文件超过了 php.ini 中 upload_max_filesize 选项限制的值。

UPLOAD_ERR_FORM_SIZE

其值为 2，上传文件的大小超过了 HTML 表单中 MAX_FILE_SIZE 选项指定的值。

UPLOAD_ERR_PARTIAL

其值为 3，文件只有部分被上传。

UPLOAD_ERR_NO_FILE

其值为 4，没有文件被上传。

UPLOAD_ERR_NO_TMP_DIR

其值为 6，找不到临时文件夹。PHP 5.0.3 引进。

UPLOAD_ERR_CANT_WRITE

其值为 7，文件写入失败。PHP 5.1.0 引进。

UPLOAD_ERR_EXTENSION

Value: 8; A PHP extension stopped the file upload. PHP does not provide a way to ascertain which extension caused the file upload to stop; examining the list of loaded extensions with phpinfo() may help. Introduced in PHP 5.2.0.


常见缺陷

对 MAX_FILE_SIZE 设置的值，不能大于 php.ini 文件 设置中 upload_max_filesize 选项设置的值。其默认值为 2M 字节。

如果内存限制设置被激活，可能需要将 memory_limit 设置的更大些，请确认 memory_limit 的设置足够的大。

如果 max_execution_time 设置的值太小，脚本运行的时间可能会超过该设置。因此，也请保证 max_execution_time 足够的大。

Note: max_execution_time 仅仅只影响脚本本身运行的时间。任何其它花费在脚本运行之外的时间，诸如用函数 system() 对系统的调用、sleep() 函数的使用、数据库查询、文件上传等，在计算脚本运行的最大时间时都不包括在内。

Warning

max_input_time 以秒为单位设定了脚本接收输入的最大时间，包括文件上传。对于较大或多个文件，或者用户的网速较慢时，可能会超过默认的 60 秒。

如果 post_max_size 设置的值太小，则较大的文件会无法被上传。因此，请保证 post_max_size 的值足够的大。

As of PHP 5.2.12, the max_file_uploads configuration setting controls the maximum number of files that can uploaded in one request. If more files are uploaded than the limit, then $_FILES will stop processing files once the limit is reached. For example, if max_file_uploads is set to 10, then $_FILES will never contain more than 10 items.

不对正在操作的文件进行验证可能意味着用户能够访问其它目录下的敏感信息。

请注意 CERN httpd 似乎会丢弃它从客户端获得的 content-type mime 头信息中第一个空格后所有的内容，基于这一点，CERN httpd 不支持文件上传特性。

鉴于文件路径的表示方法有很多种，我们无法确保用使用各种外语的文件名（尤其是包含空格的）能够被正确的处理。

开发人员不应将普通的 input 输入字段和文件上传的字段混用同一个表单变量（例如 input 名都用 foo[]）。


上传多个文件

可以对 input 域使用不同的 name 来上传多个文件。

PHP 支持同时上传多个文件并将它们的信息自动以数组的形式组织。要完成这项功能，需要在 HTML 表单中对文件上传域使用和多选框与复选框相同的数组式提交语法。

Example #1 上传多个文件

<form action="file-upload.php" method="post" enctype="multipart/form-data">
  Send these files:<br />
  <input name="userfile[]" type="file" /><br />
  <input name="userfile[]" type="file" /><br />
  <input type="submit" value="Send files" />
</form>

当以上表单被提交后，数组 $_FILES['userfile']，$_FILES['userfile']['name'] 和 $_FILES['userfile']['size'] 将被初始化。

例如，假设名为 /home/test/review.html 和 /home/test/xwp.out 的文件被提交，则 $_FILES['userfile']['name'][0] 的值将是 review.html，而 $_FILES['userfile']['name'][1] 的值将是 xwp.out。类似的，$_FILES['userfile']['size'][0] 将包含文件 review.html 的大小，依此类推。

此外也同时设置了 $_FILES['userfile']['name'][0]， $_FILES['userfile']['tmp_name'][0]， $_FILES['userfile']['size'][0] 以及 $_FILES['userfile']['type'][0]。

Warning

As of PHP 5.2.12, the max_file_uploads configuration setting acts as a limit on the number of files that can be uploaded in one request. You will need to ensure that your form does not try to upload more files in one request than this limit.


对 PUT 方法的支持

PHP 对部分客户端具备的 HTTP PUT 方法提供了支持。PUT 请求比文件上传要简单的多，它们一般的形式为：

PUT /path/filename.html HTTP/1.1

这通常意味着远程客户端会将其中的 /path/filename.html 存储到 web 目录树。让 Apache 或者 PHP 自动允许所有人覆盖 web 目录树下的任何文件显然是很不明智的。因此，要处理类似的请求，必须先告诉 web 服务器需要用特定的 PHP 脚本来处理该请求。在 Apache 下，可以用 Script 选项来设置。它可以被放置到 Apache 配置文件中几乎所有的位置。通常我们把它放置在 <Directory> 区域或者 <VirtualHost> 区域。可以用如下一行来完成该设置：

Script PUT /put.php

这将告诉 Apache 将所有对 URI 的 PUT 请求全部发送到 put.php 脚本，这些 URI 必须和 PUT 命令中的内容相匹配。当然，这是建立在 PHP 支持 .php 扩展名，并且 PHP 已经在运行的假设之上。 The destination resource for all PUT requests to this script has to be the script itself, not a filename the uploaded file should have.

With PHP you would then do something like the following in your put.php. This would copy the contents of the uploaded file to the file myputfile.ext on the server. You would probably want to perform some checks and/or authenticate the user before performing this file copy.

Example #1 保存 HTTP PUT 文件

<?php
/* PUT data comes in on the stdin stream */
$putdata = fopen("php://input", "r");

/* Open a file for writing */
$fp = fopen("myputfile.ext", "w");

/* Read the data 1 KB at a time
   and write to the file */
while ($data = fread($putdata, 1024))
  fwrite($fp, $data);

/* Close the streams */
fclose($fp);
fclose($putdata);
?>


  • ? 对 PUT 方法的支持
  • 使用远程文件 ?
  • PHP Manual
  • 文件上传处理
  • 参见

参见

  • 文件系统安全


使用远程文件

只要在 php.ini 文件中激活了 allow_url_fopen 选项，就可以在大多数需要用文件名作为参数的函数中使用 HTTP 和 FTP 的 URL 来代替文件名。同时，也可以在 include、include_once、require 及 require_once 语句中使用 URL。PHP 所支持协议的更多信息参见支持的协议和封装协议。

Note:

要在 PHP 4.0.3 及其更早的版本中使用 URL 封装协议，需要在编译时用 --enable-url-fopen-wrapper 参数来配置 PHP。

Note:

Windows 版本的 PHP 4.3 版之前不支持以下函数的远程访问：include，include_once，require，require_once 以及GD 和图像处理 函数中的 imagecreatefromXXX 函数。

例如，可以用以下范例来打开远程 web 服务器上的文件，解析需要的输出数据，然后将这些数据用在数据库的检索中，或者简单地以和自己网站其它页面相同的风格输出其内容。

Example #1 获取远程文件的标题

<?php
$file = fopen ("http://www.example.com/", "r");
if (!$file) {
    echo "<p>Unable to open remote file.\n";
    exit;
}
while (!feof ($file)) {
    $line = fgets ($file, 1024);
    /* This only works if the title and its tags are on one line */
    if (eregi ("<title>(.*)</title>", $line, $out)) {
        $title = $out[1];
        break;
    }
}
fclose($file);
?>

如果有合法的访问权限，以一个用户的身份和某 FTP 服务器建立了链接，还可以向该 FTP 服务器端的文件进行写操作。仅能用该方法来创建新的文件；如果尝试覆盖已经存在的文件，fopen() 函数的调用将会失败。

要以"anonymous"以外的用户名连接服务器，需要指明用户名（可能还有密码），例如"ftp://user:password@ftp.example.com/path/to/file"（也可以在通过需要 Basic 认证的 HTTP 协议访问远程文件时使用相同的语法）。

Example #2 将数据保存到远程服务器

<?php
$file = fopen ("ftp://ftp.example.com/incoming/outputfile", "w");
if (!$file) {
    echo "<p>Unable to open remote file for writing.\n";
    exit;
}
/* Write the data here. */
fwrite ($file, $_SERVER['HTTP_USER_AGENT'] . "\n");
fclose ($file);
?>

Note:

或许可以从以上范例中得到启发，用该技术来存储远程日志文件。但是正如以上提到的，在用 fopen() 方式打开的 URL 中，仅能对新文件进行写操作。如果远程文件已经存在则 fopen() 函数的操作将会失败。要做类似于分布式日志的事，可以参考 syslog() 函数。


连接处理

在 PHP 内部，系统维护着连接状态，其状态有三种可能的情况：

  • 0 - NORMAL（正常）
  • 1 - ABORTED（异常退出）
  • 2 - TIMEOUT（超时）

当 PHP 脚本正常地运行 NORMAL 状态时，连接为有效。当远程客户端中断连接时，ABORTED 状态的标记将会被打开。远程客户端连接的中断通常是由用户点击 STOP 按钮导致的。当连接时间超过 PHP 的时限（请参阅 set_time_limit() 函数）时，TIMEOUT 状态的标记将被打开。

可以决定脚本是否需要在客户端中断连接时退出。有时候让脚本完整地运行会带来很多方便，即使没有远程浏览器接受脚本的输出。默认的情况是当远程客户端连接中断时脚本将会退出。该处理过程可由 php.ini 的 ignore_user_abort 或由 httpd.conf 设置中对应的"php_value ignore_user_abort"以及 ignore_user_abort() 函数来控制。如果没有告诉 PHP 忽略用户的中断，脚本将会被中断，除非通过 register_shutdown_function() 设置了关闭触发函数。通过该关闭触发函数，当远程用户点击 STOP 按钮后，脚本再次尝试输出数据时，PHP 将会检测到连接已被中断，并调用关闭触发函数。

脚本也有可能被内置的脚本计时器中断。默认的超时限制为 30 秒。这个值可以通过设置 php.ini 的 max_execution_time 或 httpd.conf 设置中对应的"php_value max_execution_time"参数或者 set_time_limit() 函数来更改。当计数器超时的时候，脚本将会类似于以上连接中断的情况退出，先前被注册过的关闭触发函数也将在这时被执行。在该关闭触发函数中，可以通过调用 connection_status() 函数来检查超时是否导致关闭触发函数被调用。如果超时导致了关闭触发函数的调用，该函数将返回 2。

需要注意的一点是 ABORTED 和 TIMEOUT 状态可以同时有效。这在告诉 PHP 忽略用户的退出操作时是可能的。PHP 将仍然注意用户已经中断了连接但脚本仍然在运行的情况。如果到了运行的时间限制，脚本将被退出，设置过的关闭触发函数也将被执行。在这时会发现函数 connection_status() 返回 3。


数据库持久连接

持久的数据库连接是指在脚本结束运行时不关闭的连接。当收到一个持久连接的请求时。PHP 将检查是否已经存在一个（前面已经开启的）相同的持久连接。如果存在，将直接使用这个连接；如果不存在，则建立一个新的连接。所谓"相同"的连接是指用相同的用户名和密码到相同主机的连接。

对 web 服务器的工作和分布负载没有完全理解的读者可能会错误地理解持久连接的作用。特别的，持久连接不会在相同的连接上提供建立"用户会话"的能力，也不提供有效建立事务的能力。实际上，从严格意义上来讲，持久连接不会提供任何非持久连接无法提供的特殊功能。

为什么？

这和 web 服务器工作的方式有关。web 服务器可以用三种方法来利用 PHP 生成 web 页面。

第一种方法是将 PHP 用作一个单独运行的语言解释器(CGI Wapper)。以这种方法运行，PHP 会为向 web 服务器提出的每个 PHP 页面请求生成并结束一个 PHP解释器线程。由于该线程会随每个请求的结束而结束，因此任何在这个线程中利用的任何资源（例如指向SQL 数据库服务器的连接）都会随线程的结束而关闭。在这种情况下，使用持久连接和非持久连接没有任何区别——因为PHP脚本本身的执行不是持久的。

第二，也是最常用的方法，是把 PHP 用作多进程 web 服务器的一个模块，这种方法目前只适用于 Apache。对于一个多进程的服务器，其典型特征是有一个父进程和一组子进程协调运行，其中实际生成 web 页面的是子进程。每当客户端向父进程提出请求时，该请求会被传递给还没有被其它的客户端请求占用的子进程。这也就是说当相同的客户端第二次向服务端提出请求时，它将有可能被一个不同的子进程来处理。在开启了一个持久连接后，所有请求 SQL 服务的后继页面都能够重用这个已经建立的 SQL Server 连接。

最后一种方法是将 PHP 用作多线程 web 服务器的一个插件。目前 PHP 4 已经支持 ISAPI、WSAPI 和 NSAPI（在非Windows 环境下），这些使得 PHP 可以被用作诸如 Netscape FastTrack (iPlanet)、Microsoft's Internet Information Server (IIS) 和 O'Reilly's WebSite Pro 等多线程 web 服务器的插件。持久连接的行为和前面所描述的多过程模型在本质上是相同的。注意 PHP 3 不支持 SAPI。

如果持久连接并没有任何附加的功能，那么使用它有什么好处？

答案非常简单——效率。当Web Server创建到SQL服务器的连接耗费(Overhead)较高（如耗时较久，消耗临时内存较多）时，持久连接将更加高效。Overhead高低取决于很多因素。例如，数据库的种类，数据库服务和web 服务是否在同一台服务器上，SQL 服务器负载状况等。当Overhead较高，每次创建数据库连接成本较高时，持久连接将显著的提高效率。它使得每个子进程在其生命周期中只做一次连接操作，而非每次在处理一个页面时都要向SQL 服务器提出连接请求。这也就是说，每个子进程将对服务器建立各自独立的持久连接。例如，如果有 20 个不同的子进程运行某脚本建立了持久的 SQL 服务器持久连接，那么实际上向该 SQL 服务器建立了 20 个不同的持久连接，每个进程占有一个。

注意，如果持久连接的子进程数目超过了设定的数据库连接数限制，系统将会产生一些问题。如果数据库的同时连接数限制为 16，而在繁忙会话的情况下，有 17 个线程试图连接，那么有一个线程将无法连接。如果这个时候，在脚本中出现了使得连接无法关闭的错误（例如无限循环），则该数据库的 16 个连接将迅速地受到影响。请查阅使用的数据库的文档，以获取关于如何处理已放弃的及闲置的连接的方法。

Warning

在使用持久连接时还有一些特别的问题需要注意。例如在持久连接中使用数据表锁时，如果脚本不管什么原因无法释放该数据表锁，其随后使用相同连接的脚本将会被持久的阻塞，使得需要重新启动 httpd 服务或者数据库服务。另外，在使用事务处理时，如果脚本在事务阻塞产生前结束，则该阻塞也会影响到使用相同连接的下一个脚本。不管在什么情况下，都可以通过使用 register_shutdown_function() 函数来注册一个简单的清理函数来打开数据表锁，或者回滚事务。或者更好的处理方法，是不在使用数据表锁或者事务处理的脚本中使用持久连接，这可以从根本上解决这个问题（当然还可以在其它地方使用持久连接）。

以下是一点重要的总结。持久连接与常规的非持久连接应该是可以互相替换的。即将持久连接替换为非持久连接时，你的脚本的行为不应该发生改变。使用持久连接只应该改变脚本的效率，不应该改变其行为！

参见 fbsql_pconnect()，ibase_pconnect()，ifx_pconnect()，ingres_pconnect()，msql_pconnect()，mssql_pconnect()，mysql_pconnect()，ociplogon()，odbc_pconnect()，ora_plogon()，pfsockopen()，pg_pconnect() 和 sybase_pconnect()。


PHP 的命令行模式

Table of Contents

  • 如何得知自己使用的是哪个 SAPI？
  • 和其它 SAPI 模块的区别
  • Options
  • Usage
  • I/O streams
  • Interactive shell
  • 内置Web Server
  • INI 配置


如何得知自己使用的是哪个 SAPI？

  • ? PHP 的命令行模式
  • 和其它 SAPI 模块的区别 ?
  • PHP Manual
  • PHP 的命令行模式
  • 如何得知自己使用的是哪个 SAPI？

CLI SAPI 模块主要用作 PHP 的开发外壳应用。CLI SAPI 和其它 SAPI 模块相比有很多的不同之处，我们将在本章中详细阐述。值得一提的是，尽管 CLI 和 CGI 有很多共同的行为，但它们是不同的 SAPI。

CLI SAPI 模块会通过默认的 --enable-cli 参数设置启用， 也可以在运行 ./configure 时用参数 --disable-cli 来屏蔽。

CLI/CGI 二进制执行文件的文件名、位置和是否存在会根据 PHP 在系统上的安装而不同。在默认情况下，当运行 make 时，CGI 和 CLI 都会被编译并且分别放置在 PHP 源文件目录的 sapi/cgi/php-cgi 和 sapi/cli/php 下。可以注意到两个文件都被命名为了 php。在 make install 的过程中会发生什么取决于配置行。如果在配置的时候选择了一个 SAPI 模块，如 apxs，或者使用了 --disable-cgi 参数，则在 make install 的过程中，CLI 将被拷贝到 {PREFIX}/bin/php，除非 CGI 已经被放置在了那个位置。因此，例如，如果在配置行中有 --with--apxs，则在 make install 的过程中，CLI 将被拷贝到 {PREFIX}/bin/php。如果希望覆盖 CGI 执行文件的安装，请在 make install 之后运行 make install-cli。或者，也可以在配置行中加上 --disable-cgi 参数。

Note:

由于 --enable-cli 和 --enable-cgi 同时默认有效，因此，不必再配置行中加上 --enable-cli 来使得 CLI 在 make install 过程中被拷贝到 {PREFIX}/bin/php。

自 PHP 5 起，Windows 发行包中，CLI 在主目录中的二进制文件名为 php.exe。CGI 版本的文件名为 php-cli.exe。 如果 PHP 配置使用了 --enable-cli-win32，还会有一个额外的 php-win.exe 随包发布。 它相当于 CLI 版本，但是 php-win 不输出任何内容，便不提供控制台（不会弹出"DOS 窗口"）。

Note: 如何得知自己使用的是哪个 SAPI？

在命令行下，运行 php -v 便能得知该 php 是 CGI 还是 CLI。请参考函数 php_sapi_name() 以及常量 PHP_SAPI。

Note:

在命令行中键入 man php 可以查看 Unix man 手册页面。


和其它 SAPI 模块的区别

以下为 CLI SAPI 和其它 SAPI 模块相比的显著区别：

  • 与 CGI SAPI 不同，其输出没有任何头信息。

    尽管 CGI SAPI 提供了取消 HTTP 头信息的方法，但在 CLI SAPI 中并不存在类似的方法以开启 HTTP 头信息的输出。

    CLI 默认以安静模式开始，但为了保证兼容性，-q 和 --no-header 参数为了向后兼容仍然保留，使得可以使用旧的 CGI 脚本。

    在运行时，不会把工作目录改为脚本的当前目录（可以使用 -C 和 --no-chdir 参数来兼容 CGI 模式）。

    出错时输出纯文本的错误信息（非 HTML 格式）。

  • CLI SAPI 强制覆盖了 php.ini 中的某些设置，因为这些设置在外壳环境下是没有意义的。

    覆盖 php.ini 设置选项
    设置选项 | CLI SAPI 默认值 | 备注
    html_errors | false | 无意义的 HTML 标记符会使得出错信息很凌乱，所以在外壳下阅读报错信息是十分困难的。因此将该选项的默认值改为 false。
    implicit_flush | true | 在命令行模式下，所有来自 print 和 echo 的输出将被立即写到输出端，而不作任何地缓冲操作。如果希望延缓或控制标准输出，仍然可以使用 output buffering 设置项。
    max_execution_time | 0（无限值） | 鉴于在外壳环境下使用 PHP 的无穷的可能性，最大运行时间被设置为了无限值。为 web 开发的应用程序可能只需运行几秒钟时间，而外壳应用程序的运行时间可能会长的多。
    register_argc_argv true

    由于该设置为 true，将总是可以在 CLI SAPI 中访问到 argc（传送给应用程序参数的个数）和 argv（包含有实际参数的数组）。

    在使用 CLI SAPI 时，PHP 变量 $argc 和 $argv 已被注册并且设定了对应的值。随时可以通过 $_SERVER 数组 来访问它们，例如：$_SERVER['argv']

    output_buffering false

    虽然 php.ini 设置已经硬编码为 false， 输出缓冲控制函数仍然有效。

    max_input_time false

    PHP CLI 不支持 GET、POST、文件上传。

    Note:

    这些设置无法在设置文件 php.ini 或任何指定的其它文件中被初始化为其它值。这些默认值被限制在所有其它的设置文件被解析后改变。 不过，它们的值可以在程序运行的过程中被改变 （尽管对于该运行过程来说，这些设置项是没有意义的，例如 register_argc_argv）。

    Note:

    推荐命令行脚本设置 ignore_user_abort。 更多信息参见 ignore_user_abort()。

  • 为了减轻外壳环境下的工作，我们为 I/O 流 定义了一系列常量。

  • CLI SAPI 不会将当前目录改为已运行的脚本所在的目录。

    以下范例显示了本模块与 CGI SAPI 模块之间的不同：

    <?php
    // 名为 test.php 的简单测试程序
    echo getcwd(), "\n";
    ?>

    在使用 CGI 版本时，其输出为

    $ pwd
/tmp

$ php-cgi -f another_directory/test.php
/tmp/another_directory

    明显可以看到 PHP 将当前目录改成了刚刚运行过的脚本所在的目录。

    使用 CLI SAPI 模式，得到：

    $ pwd
/tmp

$ php -q another_directory/test.php
/tmp
    这使得在利用 PHP 编写外壳工具时获得了很大的便利。

    Note:

    可以在命令行运行时给该 CGI SAPI 加上 -C 参数，使其支持 CLI SAPI 的功能。


命令行模式的选项参数

以下是 PHP 二进制文件提供的命令行模式的选项参数，随时可以运行带 -h 参数的 PHP 命令来查询这些参数。

Usage: php [options] [-f] <file> [--] [args...]
   php [options] -r <code> [--] [args...]
   php [options] [-B <begin_code>] -R <code> [-E <end_code>] [--] [args...]
   php [options] [-B <begin_code>] -F <file> [-E <end_code>] [--] [args...]
   php [options] -- [args...]
   php [options] -a

  -a               Run interactively
  -c <path>|<file> Look for php.ini file in this directory
  -n               No php.ini file will be used
  -d foo[=bar]     Define INI entry foo with value 'bar'
  -e               Generate extended information for debugger/profiler
  -f <file>        Parse and execute <file>.
  -h               This help
  -i               PHP information
  -l               Syntax check only (lint)
  -m               Show compiled in modules
  -r <code>        Run PHP <code> without using script tags <?..?>
  -B <begin_code>  Run PHP <begin_code> before processing input lines
  -R <code>        Run PHP <code> for every input line
  -F <file>        Parse and execute <file> for every input line
  -E <end_code>    Run PHP <end_code> after processing all input lines
  -H               Hide any passed arguments from external tools.
  -S <addr>:<port> Run with built-in web server.
  -t <docroot>     Specify document root <docroot> for built-in web server.
  -s               Output HTML syntax highlighted source.
  -v               Version number
  -w               Output source with stripped comments and whitespace.
  -z <file>        Load Zend extension <file>.

  args...          Arguments passed to script. Use -- args when first argument
                   starts with - or script is read from stdin

  --ini            Show configuration file names

  --rf <name>      Show information about function <name>.
  --rc <name>      Show information about class <name>.
  --re <name>      Show information about extension <name>.
  --rz <name>      Show information about Zend extension <name>.
  --ri <name>      Show configuration for extension <name>.

命令行选项
选项名称 | 长名称 | 说明
-a --interactive

交互式运行 PHP。For more information, see the Interactive shell section.

-b --bindpath

Bind Path for external FASTCGI Server mode (CGI only).

-C --no-chdir

Do not chdir to the script's directory (CGI only).

-q --no-header

Quiet-mode. Suppress HTTP header output (CGI only).

-T --timing

Measure execution time of script repeated count times (CGI only).

-c --php-ini

用该参数，可以指定一个放置 php.ini 文件的目录，或者直接指定一个自定义的 INI 文件（其文件名可以不是 php.ini），例如：

$ php -c /custom/directory/ my_script.php

$ php -c /custom/directory/custom-file.ini my_script.php

如果不指定此选项，php.ini 将在默认位置 搜索。

-n --no-php-ini

完全忽略 php.ini。

-d --define

用该参数可以自行设置任何可以在 php.ini 文件中设置的配置选项的值，其语法为：

 -d configuration_directive[=value]

# 取值部分被省略，将会把配置选项设为 "1"
$ php -d max_execution_time
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(1) "1"

# 取值部分为空白，将会把配置选项设为 ""
php -d max_execution_time=
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(0) ""

# 配置选项将被设置成为任何 '=' 字符之后的值
$  php -d max_execution_time=20
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(2) "20"
$  php
        -d max_execution_time=doesntmakesense
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(15) "doesntmakesense"

-e --profile-info

激活扩展信息模式，被用于调试／测试。

-f --file

解析并运行 -f 选项给定的文件名。该参数为可选参数，可以省略，仅指明需要运行的文件名即可。

Note:

To pass arguments to a script, the first argument must be --, otherwise PHP will interpret them as PHP options.

-h and -? | --help and --usage | 使用该参数，可以得到完整的命令行参数的列表及这些参数作用的简单描述。
-i | --info | 该命令行参数会调用 phpinfo() 函数并显示出结果。如果 PHP 没有正常工作，建议执行 php -i 命令来查看在信息表格之前或者对应的地方是否有任何错误信息输出。请注意当使用 CGI 摸索时，输出的内容为 HTML 格式，因此输出的信息篇幅较大。
-l --syntax-check

该参数提供了对指定 PHP 代码进行语法检查的方便的方法。如果成功，则向标准输出写入 No syntax errors detected in <filename> 字符串，并且外壳返回值为 0。如果失败，则输出 Errors parsing <filename> 以及内部解析器错误信息到标准输出，同时外壳返回值将别设置为 -1。

该参数将无法检查致命错误（如未定义函数），如果也希望检测致命错误，请使用 -f 参数。

Note:

该参数不能和 -r 一同使用。

-m --modules

Example #1 使用该参数，PHP 将打印出内置以及已加载的 PHP 及 Zend 模块：

$ php -m
[PHP Modules]
xml
tokenizer
standard
session
posix
pcre
overload
mysql
mbstring
ctype

[Zend Modules]

-r --run

使用该参数可以在命令行内运行单行 PHP 代码。无需加上 PHP 的起始和结束标识符（<?php 和 ?>），否则将会导致语法解析错误。

Note:

使用这种形式的 PHP 时，应注意避免和外壳环境进行的命令行参数替换相冲突。

Example #2 显示双引号语法解析错误的范例

$ php -r "$foo = get_defined_constants();"
Command line code(1) : Parse error - parse error, unexpected '='

这里的问题在于即使使用了双引号 "，sh/bash 仍然实行了参数替换。由于 $foo 没有被定义，被替换后它所在的位置变成了空字符，因此在运行时，实际被 PHP 读取的代码为：

$ php -r " = get_defined_constants();"

正确的方法是使用单引号 '。在用单引号引用的字符串中，变量不会被 sh/bash 还原成其原值。

Example #3 Using single quotes to prevent the shell's variable substitution

$ php -r '$foo = get_defined_constants(); var_dump($foo);'
array(370) {
  ["E_ERROR"]=>
  int(1)
  ["E_WARNING"]=>
  int(2)
  ["E_PARSE"]=>
  int(4)
  ["E_NOTICE"]=>
  int(8)
  ["E_CORE_ERROR"]=>
  [...]

如果使用的外壳不是 sh/bash，可能会碰到更多问题。请将碰到的 Bug 向 » https://bugs.php.net/ 报告。注意，当试图将 shell 变量用到代码中或者使用反斜线时仍然很容易碰到问题。

Note:

-r 在 CLI SAPI 中有效，在 CGI SAPI 中无效。

Note:

此选项只用于非常基本的用途。因此一些配置指令（例如 auto_prepend_file 和 auto_append_file）在此模式下被忽略。

-B --process-begin

在处理 stdin 之前先执行 PHP 代码。PHP 5 新加。

-R --process-code

对每个输入行都执行 PHP 代码。PHP 5 新加。

此模式下有两个特殊变量：$argn 和 $argi。$argn 包含 PHP 当前处理的行内容，而 $argi 则包含该行号。

-F --process-file

对每个输入行都执行 PHP 文件。PHP 5 新加。

-E --process-end

在处理完输入后执行的 PHP 代码。PHP 5 新加。

Example #4 使用 -B，-R 和 -E 选项来计算一个项目总行数的例子。

$ find my_proj | php -B '$l=0;' -R '$l += count(@file($argn));' -E 'echo "Total Lines: $l\n";'
Total Lines: 37328

-S --server

Starts built-in web server. Available as of PHP 5.4.0.

-t | --docroot | Specifies document root for built-in web server. Available as of PHP 5.4.0.
-s --syntax-highlight and --syntax-highlighting

显示有语法高亮色彩的源代码。

该参数使用内建机制来解析文件并为其生成一个 HTML 高亮版本并将结果写到标准输出。请注意该过程所做的只是生成了一个 <code> [...] </code> 的 HTML 标记的块，并不包含任何的 HTML 头。

Note:

该选项不能和 -r 参数同时使用。

-v --version

Example #5 使用 -v 将 PHP、SAPI 名称和 Zend 的版本信息写入标准输出。

$ php -v
PHP 5.3.1 (cli) (built: Dec 11 2009 19:55:07)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies

-w --strip

显示除去了注释和多余空白的源代码。

Note:

该选项不能和 -r 参数同时使用。

-z --zend-extension

加载 Zend 扩展库。如果仅给定一个文件名，PHP 将试图从当前系统扩展库的默认路径（在 Linux 系统下，该路径通常由 /etc/ld.so.conf 指定）加载该扩展库。如果用一个绝对路径指定文件名，则不会使用系统的扩展库默认路径。如果用相对路径指定的文件名，则 PHP 仅试图在当前目录的相对目录加载扩展库。

--ini

Show configuration file names and scanned directories. Available as of PHP 5.2.3.

Example #6 --ini example

$ php --ini
Configuration File (php.ini) Path: /usr/dev/php/5.2/lib
Loaded Configuration File:         /usr/dev/php/5.2/lib/php.ini
Scan for additional .ini files in: (none)
Additional .ini files parsed:      (none)
--rf --rfunction

Show information about the given function or class method (e.g. number and name of the parameters). Available as of PHP 5.1.2.

This option is only available if PHP was compiled with Reflection support.

Example #7 basic --rf usage

$ php --rf var_dump
Function [ <internal> public function var_dump ] {

  - Parameters [2] {
    Parameter #0 [ <required> $var ]
    Parameter #1 [ <optional> $... ]
  }
}
--rc --rclass

Show information about the given class (list of constants, properties and methods). Available as of PHP 5.1.2.

This option is only available if PHP was compiled with Reflection support.

Example #8 --rc example

$ php --rc Directory
Class [ <internal:standard> class Directory ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [0] {
  }

  - Methods [3] {
    Method [ <internal> public method close ] {
    }

    Method [ <internal> public method rewind ] {
    }

    Method [ <internal> public method read ] {
    }
  }
}
--re --rextension

Show information about the given extension (list of php.ini options, defined functions, constants and classes). Available as of PHP 5.1.2.

This option is only available if PHP was compiled with Reflection support.

Example #9 --re example

$ php --re json
Extension [ <persistent> extension #19 json version 1.2.1 ] {

  - Functions {
    Function [ <internal> function json_encode ] {
    }
    Function [ <internal> function json_decode ] {
    }
  }
}
--rz --rzendextension

Show the configuration information for the given Zend extension (the same information that is returned by phpinfo()). Available as of PHP 5.4.0.

--ri --rextinfo

Show the configuration information for the given extension (the same information that is returned by phpinfo()). Available as of PHP 5.2.2. The core configuration information is available using "main" as extension name.

Example #10 --ri example

$ php --ri date

date

date/time support => enabled
"Olson" Timezone Database Version => 2009.20
Timezone Database => internal
Default timezone => Europe/Oslo

Directive => Local Value => Master Value
date.timezone => Europe/Oslo => Europe/Oslo
date.default_latitude => 59.930972 => 59.930972
date.default_longitude => 10.776699 => 10.776699
date.sunset_zenith => 90.583333 => 90.583333
date.sunrise_zenith => 90.583333 => 90.583333

Note:

Options -rBRFEH, --ini and --r[fcezi] are available only in CLI.


Executing PHP files

CLI SAPI 模块有以下三种不同的方法来获取要运行的 PHP 代码：

  1. 让 PHP 运行指定文件。

    php my_script.php

php -f my_script.php

    以上两种方法（使用或不使用 -f 参数）都能够运行给定的 my_script.php 文件。可以选择任何文件来运行，指定的 PHP 脚本并非必须要以 .php 为扩展名，它们可以有任意的文件名和扩展名。

    Note:

    If arguments need to be passed to the script when using -f, the first argument must be --.

  2. 在命令行直接运行 PHP 代码。

    php -r 'print_r(get_defined_constants());'

    在使用这种方法时，请注意外壳变量的替代及引号的使用。

    Note:

    请仔细阅读以上范例，在运行代码时没有开始和结束的标记符！加上 -r 参数后，这些标记符是不需要的，加上它们会导致语法错误。

  3. 通过标准输入（stdin）提供需要运行的 PHP 代码。

    以上用法提供了非常强大的功能，使得可以如下范例所示，动态地生成 PHP 代码并通过命令行运行这些代码：

    $ some_application | some_filter | php | sort -u >final_output.txt

以上三种运行代码的方法不能同时使用。

和所有的外壳应用程序一样，PHP 的二进制文件及其运行的 PHP 脚本能够接受一系列的参数。PHP 没有限制传送给脚本程序的参数的个数（外壳程序对命令行的字符数有限制，但通常都不会超过该限制）。传递给脚本的参数可在全局变量 $argv 中获取。该数组中下标为零的成员 $argv[0] 为脚本的名称（当 PHP 代码来自标准输入获直接用 -r 参数以命令行方式运行时，该名称为"-"）。The same is true if the code is executed via a pipe from STDIN.

另外，全局变量 $argc 存有 $argv 数组中成员变量的个数（而非传送给脚本程序的参数的个数）。

只要传送给脚本的参数不是以 - 符号开头，就无需过多的注意什么。向脚本传送以 - 开头的参数会导致错误，因为 PHP 会认为应该由它自身来处理这些参数。可以用参数列表分隔符 -- 来解决这个问题。在 PHP 解析完参数后，该符号后所有的参数将会被原样传送给脚本程序。

# 以下命令将不会运行 PHP 代码，而只显示 PHP 命令行模式的使用说明：
$ php -r 'var_dump($argv);' -h
Usage: php [options] [-f] <file> [args...]
[...]

# 以下命令将会把"-h"参数传送给脚本程序，PHP 不会显示命令行模式的使用说明：
$ php -r 'var_dump($argv);' -- -h
array(2) {
  [0]=>
  string(1) "-"
  [1]=>
  string(2) "-h"
}

除此之外，还有另一个方法将 PHP 用于外壳脚本。可以在写一个脚本，并在第一行以 #!/usr/bin/php 开头，在其后加上以 PHP 开始和结尾标记符包含的正常的 PHP 代码，然后为该文件设置正确的运行属性（例如：chmod +x test）。 该方法可以使得该文件能够像外壳脚本或 PERL 脚本一样被直接执行。

Example #1 Execute PHP script as shell script

#!/usr/bin/php
<?php
    var_dump($argv);
?>

假设改文件名为 test 并被放置在当前目录下，可以做如下操作：

$ chmod +x test
$ ./test -h -- foo
array(4) {
  [0]=>
  string(6) "./test"
  [1]=>
  string(2) "-h"
  [2]=>
  string(2) "--"
  [3]=>
  string(3) "foo"
}

正如所看到的，在向该脚本传送以 - 开头的参数时，脚本仍然能够正常运行。

PHP 的命令行模式能使得 PHP 脚本能完全独立于 web 服务器单独运行。如果使用 Unix 系统，需要在 PHP 脚本的最前面加上一行特殊的代码，使得它能够被执行，这样系统就能知道用哪个程序去运行该脚本。在 Windows 平台下可以将 php.exe 和 .php 文件的双击属性相关联，也可以编写一个批处理文件来用 PHP 执行脚本。为 Unix 系统增加的第一行代码不会影响该脚本在 Windows 下的运行，因此也可以用该方法编写跨平台的脚本程序。以下是一个简单的 PHP 命令行程序的范例。

Example #2 试图以命令行方式运行的 PHP 脚本（script.php）

#!/usr/bin/php
<?php

if ($argc != 2 || in_array($argv[1], array('--help', '-help', '-h', '-?'))) {
?>

This is a command line PHP script with one option.

  Usage:
  <?php echo $argv[0]; ?> <option>

  <option> can be some word you would like
  to print out. With the --help, -help, -h,
  or -? options, you can get this help.

<?php
} else {
    echo $argv[1];
}
?>

在以上脚本中，用第一行特殊的代码来指明该文件应该由 PHP 来执行。在这里使用 CLI 的版本，因此不会有 HTTP 头信息输出。

以上程序中检查了参数的个数是大于 1 个还是小于 1 个。此外如果参数是 --help，-help，-h 或 -? 时，打印出帮助信息，并同时用 $argv[0] 动态输出脚本的名称。如果还收到了其它参数，将其显示出来。

如果希望在 Unix 下运行以上脚本，需要使其属性为可执行文件，然后简单的运行 script.php echothis 或 script.php -h。在 Windows 下，可以为此编写一个批处理文件：

Example #3 运行 PHP 命令行脚本的批处理文件（script.bat）

@echo OFF
"C:\php\php.exe" script.php %*

假设将上述程序命名为 script.php，且 CLI 版的 php.exe 文件放置在 c:\php\cli\php.exe，该批处理文件会帮助将附加的参数传给脚本程序：script.bat echothis 或 script.bat -h。

请参阅 Readline 扩展模块的有关文档，以获取更多的函数的信息。这些函数可以帮助完善 PHP 命令行应用程序。

On Windows, PHP can be configured to run without the need to supply the C:\php\php.exe or the .php extension, as described in Command Line PHP on Microsoft Windows.

Note:

On Windows it is recommended to run PHP under an actual user account. When running under a network service certain operations will fail, because "No mapping between account names and security IDs was done".


Input/output streams

The CLI SAPI defines a few constants for I/O streams to make programming for the command line a bit easier.

CLI 专用常量
常量名称 描述
STDIN

An already opened stream to stdin. This saves opening it with

<?php
$stdin = fopen('php://stdin', 'r');
?>
If you want to read single line from stdin, you can use
<?php
$line = trim(fgets(STDIN)); // reads one line from STDIN
fscanf(STDIN, "%d\n", $number); // reads number from STDIN
?>

STDOUT

An already opened stream to stdout. This saves opening it with

<?php
$stdout = fopen('php://stdout', 'w');
?>

STDERR

An already opened stream to stderr. This saves opening it with

<?php
$stderr = fopen('php://stderr', 'w');
?>

有了以上常量，就无需自己建立指向诸如 stderr 的流，只需简单的使用这些常量来代替流指向：

php -r 'fwrite(STDERR, "stderr\n");'
无需自己来关闭这些流，PHP 会在脚本结束时自动完成这些操作。

Note:

These constants are not available if reading the PHP script from stdin.


Interactive shell

As of PHP 5.1.0, the CLI SAPI provides an interactive shell using the -a option if PHP is compiled with the --with-readline option.

Using the interactive shell you are able to type PHP code and have it executed directly.

Example #1 Executing code using the interactive shell

$ php -a
Interactive shell

php > echo 5+8;
13
php > function addTwo($n)
php > {
php { return $n + 2;
php { }
php > var_dump(addtwo(2));
int(4)
php >

The interactive shell also features tab completion for functions, constants, class names, variables, static method calls and class constants.

Example #2 Tab completion

Pressing the tab key twice when there are multiple possible completions will result in a list of these completions:

php > strp[TAB][TAB]
strpbrk   strpos    strptime
php > strp

When there is only one possible completion, pressing tab once will complete the rest on the same line:

php > strpt[TAB]ime(

Completion will also work for names that have been defined during the current interactive shell session:

php > $fooThisIsAReallyLongVariableName = 42;
php > $foo[TAB]ThisIsAReallyLongVariableName

The interactive shell stores your history which can be accessed using the up and down keys. The history is saved in the ~/.php_history file.

As of PHP 5.4.0, the CLI SAPI provides the php.ini settings cli.pager and cli.prompt. The cli.pager setting allows an external program (such as less) to act as a pager for the output instead of being displayed directly on the screen. The cli.prompt setting makes it possible to change the php > prompt.

In PHP 5.4.0 it was also made possible to set php.ini settings in the interactive shell using a shorthand notation.

Example #3 Setting php.ini settings in the interactive shell

The cli.prompt setting:

php > #cli.prompt=hello world :>
hello world :>

Using backticks it is possible to have PHP code executed in the prompt:

php > #cli.prompt=`echo date('H:i:s');` php >
15:49:35 php > echo 'hi';
hi
15:49:43 php > sleep(2);
15:49:45 php >

Setting the pager to less:

php > #cli.pager=less
php > phpinfo();
(output displayed in less)
php >

The cli.prompt setting supports a few escape sequences:

cli.prompt escape sequences
Sequence | Description
\e | Used for adding colors to the prompt. An example could be \e[032m\v \e[031m\b \e[34m\> \e[0m
\v | The PHP version.
\b | Indicates which block PHP is in. For instance /* to indicate being inside a multi-line comment. The outer scope is denoted by php.
\> | Indicates the prompt character. By default this is >, but changes when the shell is inside an unterminated block or string. Possible characters are: ' " { ( >

Note:

Files included through auto_prepend_file and auto_append_file are parsed in this mode but with some restrictions - e.g. functions have to be defined before called.

Note:

Autoloading is not available if using PHP in CLI interactive mode.


内置Web Server

PHP 5.4.0起， CLI SAPI 提供了一个内置的Web服务器。

这个内置的Web服务器主要用于本地开发使用，不可用于线上产品环境。

URI请求会被发送到PHP所在的的工作目录（Working Directory）进行处理，除非你使用了-t参数来自定义不同的目录。

如果请求未指定执行哪个PHP文件，则默认执行目录内的index.php 或者 index.html。如果这两个文件都不存在，服务器会返回404错误。

当你在命令行启动这个Web Server时，如果指定了一个PHP文件，则这个文件会作为一个"路由"脚本，意味着每次请求都会先执行这个脚本。如果这个脚本返回 false ，那么直接返回请求的文件（例如请求静态文件不作任何处理）。否则会把输出返回到浏览器。

Example #1 启动Web服务器

$ cd ~/public_html
$ php -S localhost:8000

终端窗口会显示:

PHP 5.4.0 Development Server started at Thu Jul 21 10:43:28 2011
Listening on localhost:8000
Document root is /home/me/public_html
Press Ctrl-C to quit

接着访问http://localhost:8000/和http://localhost:8000/myscript.html，窗口会显示：

PHP 5.4.0 Development Server started at Thu Jul 21 10:43:28 2011
Listening on localhost:8000
Document root is /home/me/public_html
Press Ctrl-C to quit.
[Thu Jul 21 10:48:48 2011] ::1:39144 GET /favicon.ico - Request read
[Thu Jul 21 10:48:50 2011] ::1:39146 GET / - Request read
[Thu Jul 21 10:48:50 2011] ::1:39147 GET /favicon.ico - Request read
[Thu Jul 21 10:48:52 2011] ::1:39148 GET /myscript.html - Request read
[Thu Jul 21 10:48:52 2011] ::1:39149 GET /favicon.ico - Request read

Example #2 启动时指定根目录

$ cd ~/public_html
$ php -S localhost:8000 -t foo/

终端窗口显示：

PHP 5.4.0 Development Server started at Thu Jul 21 10:50:26 2011
Listening on localhost:8000
Document root is /home/me/public_html/foo
Press Ctrl-C to quit

Example #3 使用路由（Router）脚本

请求图片直接显示图片，请求HTML则显示"Welcome to PHP"

<?php
// router.php
if (preg_match('/\.(?:png|jpg|jpeg|gif)$/', $_SERVER["REQUEST_URI"]))
    return false;    // 直接返回请求的文件
else {
    echo "<p>Welcome to PHP</p>";
}
?>
$ php -S localhost:8000 router.php

执行之后终端显示：

PHP 5.4.0 Development Server started at Thu Jul 21 10:53:19 2011
Listening on localhost:8000
Document root is /home/me/public_html
Press Ctrl-C to quit.
[Thu Jul 21 10:53:45 2011] ::1:55801 GET /mylogo.jpg - Request read
[Thu Jul 21 10:53:52 2011] ::1:55803 GET /abc.html - Request read
[Thu Jul 21 10:53:52 2011] ::1:55804 GET /favicon.ico - Request read


INI 配置

CLI SAPI 配置选项
名字 | 默认 | 可修改范围 | 更新日志
cli_server.color | "0" | PHP_INI_ALL | PHP 5.4.0. 起生效

这是配置指令的简短说明。

cli_server.color boolean

控制内置Web Server的终端输出有无颜色。


垃圾回收机制

Table of Contents

  • 引用计数基本知识
  • 回收周期(Collecting Cycles)
  • 性能方面考虑的因素

这部分将说明PHP 5.3的新的垃圾回收机制（也就是GC）的特点。


引用计数基本知识

每个php变量存在一个叫"zval"的变量容器中。一个zval变量容器，除了包含变量的类型和值，还包括两个字节的额外信息。第一个是"is_ref"，是个bool值，用来标识这个变量是否是属于引用集合(reference set)。通过这个字节，php引擎才能把普通变量和引用变量区分开来，由于php允许用户通过使用&来使用自定义引用，zval变量容器中还有一个内部引用计数机制，来优化内存使用。第二个额外字节是"refcount"，用以表示指向这个zval变量容器的变量(也称符号即symbol)个数。所有的符号存在一个符号表中，其中每个符号都有作用域(scope)，那些主脚本(比如：通过浏览器请求的的脚本)和每个函数或者方法也都有作用域。

当一个变量被赋常量值时，就会生成一个zval变量容器，如下例这样：

Example #1 生成一个新的zval容器

<?php
$a = "new string";
?>

在上例中，新的变量a，是在当前作用域中生成的。并且生成了类型为 string 和值为new string的变量容器。在额外的两个字节信息中，"is_ref"被默认设置为 false，因为没有任何自定义的引用生成。"refcount" 被设定为 1，因为这里只有一个变量使用这个变量容器. 注意到当"refcount"的值是1时，"is_ref"的值总是false. 如果你已经安装了» Xdebug，你能通过调用函数 xdebug_debug_zval()显示"refcount"和"is_ref"的值。

Example #2 显示zval信息

<?php
xdebug_debug_zval('a');
?>

以上例程会输出：

a: (refcount=1, is_ref=0)='new string'

把一个变量赋值给另一变量将增加引用次数(refcount).

Example #3 增加一个zval的引用计数

<?php
$a = "new string";
$b = $a;
xdebug_debug_zval( 'a' );
?>

以上例程会输出：

a: (refcount=2, is_ref=0)='new string'

这时，引用次数是2，因为同一个变量容器被变量 a 和变量 b关联.当没必要时，php不会去复制已生成的变量容器。变量容器在"refcount"变成0时就被销毁. 当任何关联到某个变量容器的变量离开它的作用域(比如：函数执行结束)，或者对变量调用了函数 unset()时，"refcount"就会减1，下面的例子就能说明:

Example #4 减少引用计数

<?php
$a = "new string";
$c = $b = $a;
xdebug_debug_zval( 'a' );
unset( $b, $c );
xdebug_debug_zval( 'a' );
?>

以上例程会输出：

a: (refcount=3, is_ref=0)='new string'
a: (refcount=1, is_ref=0)='new string'

如果我们现在执行 unset($a);，包含类型和值的这个变量容器就会从内存中删除。

复合类型(Compound Types)

当考虑像 array和object这样的复合类型时，事情就稍微有点复杂. 与 标量(scalar)类型的值不同，array和 object类型的变量把它们的成员或属性存在自己的符号表中。这意味着下面的例子将生成三个zval变量容器。

Example #5 Creating a array zval

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
xdebug_debug_zval( 'a' );
?>

以上例程的输出类似于：

a: (refcount=1, is_ref=0)=array (
   'meaning' => (refcount=1, is_ref=0)='life',
   'number' => (refcount=1, is_ref=0)=42
)

图示:

这三个zval变量容器是: a，meaning和 number。增加和减少"refcount"的规则和上面提到的一样. 下面, 我们在数组中再添加一个元素,并且把它的值设为数组中已存在元素的值:

Example #6 添加一个已经存在的元素到数组中

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
$a['life'] = $a['meaning'];
xdebug_debug_zval( 'a' );
?>

以上例程的输出类似于：

a: (refcount=1, is_ref=0)=array (
   'meaning' => (refcount=2, is_ref=0)='life',
   'number' => (refcount=1, is_ref=0)=42,
   'life' => (refcount=2, is_ref=0)='life'
)

图示：

从以上的xdebug输出信息，我们看到原有的数组元素和新添加的数组元素关联到同一个"refcount"2的zval变量容器. 尽管 Xdebug的输出显示两个值为'life'的 zval 变量容器，其实是同一个。 函数xdebug_debug_zval()不显示这个信息，但是你能通过显示内存指针信息来看到。

删除数组中的一个元素，就是类似于从作用域中删除一个变量. 删除后,数组中的这个元素所在的容器的"refcount"值减少，同样，当"refcount"为0时，这个变量容器就从内存中被删除，下面又一个例子可以说明：

Example #7 从数组中删除一个元素

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
$a['life'] = $a['meaning'];
unset( $a['meaning'], $a['number'] );
xdebug_debug_zval( 'a' );
?>

以上例程的输出类似于：

a: (refcount=1, is_ref=0)=array (
   'life' => (refcount=1, is_ref=0)='life'
)

现在，当我们添加一个数组本身作为这个数组的元素时，事情就变得有趣，下个例子将说明这个。例中我们加入了引用操作符，否则php将生成一个复制。

Example #8 把数组作为一个元素添加到自己

<?php
$a = array( 'one' );
$a[] =& $a;
xdebug_debug_zval( 'a' );
?>

以上例程的输出类似于：

a: (refcount=2, is_ref=1)=array (
   0 => (refcount=1, is_ref=0)='one',
   1 => (refcount=2, is_ref=1)=...
)

图示：

能看到数组变量 (a) 同时也是这个数组的第二个元素(1) 指向的变量容器中"refcount"为 2。上面的输出结果中的"..."说明发生了递归操作, 显然在这种情况下意味着"..."指向原始数组。

跟刚刚一样，对一个变量调用unset，将删除这个符号，且它指向的变量容器中的引用次数也减1。所以，如果我们在执行完上面的代码后，对变量$a调用unset, 那么变量 $a 和数组元素 "1" 所指向的变量容器的引用次数减1, 从"2"变成"1". 下例可以说明:

Example #9 Unsetting $a

(refcount=1, is_ref=1)=array (
   0 => (refcount=1, is_ref=0)='one',
   1 => (refcount=1, is_ref=1)=...
)

图示：

Zvals after removal of array with a circular reference demonstrating the memory leak

清理变量容器的问题(Cleanup Problems)

尽管不再有某个作用域中的任何符号指向这个结构(就是变量容器)，由于数组元素"1"仍然指向数组本身，所以这个容器不能被清除 。因为没有另外的符号指向它，用户没有办法清除这个结构，结果就会导致内存泄漏。庆幸的是，php将在脚本执行结束时清除这个数据结构，但是在php清除之前，将耗费不少内存。如果你要实现分析算法，或者要做其他像一个子元素指向它的父元素这样的事情，这种情况就会经常发生。当然，同样的情况也会发生在对象上，实际上对象更有可能出现这种情况，因为对象总是隐式的被引用。

如果上面的情况发生仅仅一两次倒没什么，但是如果出现几千次，甚至几十万次的内存泄漏，这显然是个大问题。这样的问题往往发生在长时间运行的脚本中，比如请求基本上不会结束的守护进程(deamons)或者单元测试中的大的套件(sets)中。后者的例子：在给巨大的eZ(一个知名的PHP Library) 组件库的模板组件做单元测试时，就可能会出现问题。有时测试可能需要耗用2GB的内存，而测试服务器很可能没有这么大的内存。


回收周期(Collecting Cycles)

传统上，像以前的 php 用到的引用计数内存机制，无法处理循环的引用内存泄漏。然而 5.3.0 PHP 使用文章» 引用计数系统中的同步周期回收(Concurrent Cycle Collection in Reference Counted Systems)中的同步算法，来处理这个内存泄漏问题。

对算法的完全说明有点超出这部分内容的范围，将只介绍其中基础部分。首先，我们先要建立一些基本规则，如果一个引用计数增加，它将继续被使用，当然就不再在垃圾中。如果引用计数减少到零，所在变量容器将被清除(free)。就是说，仅仅在引用计数减少到非零值时，才会产生垃圾周期(garbage cycle)。其次，在一个垃圾周期中，通过检查引用计数是否减1，并且检查哪些变量容器的引用次数是零，来发现哪部分是垃圾。

为避免不得不检查所有引用计数可能减少的垃圾周期，这个算法把所有可能根(possible roots 都是zval变量容器),放在根缓冲区(root buffer)中(用紫色来标记，称为疑似垃圾)，这样可以同时确保每个可能的垃圾根(possible garbage root)在缓冲区中只出现一次。仅仅在根缓冲区满了时，才对缓冲区内部所有不同的变量容器执行垃圾回收操作。看上图的步骤 A。

在步骤 B 中，模拟删除每个紫色变量。模拟删除时可能将不是紫色的普通变量引用数减"1"，如果某个普通变量引用计数变成0了，就对这个普通变量再做一次模拟删除。每个变量只能被模拟删除一次，模拟删除后标记为灰（原文说确保不会对同一个变量容器减两次"1",不对的吧）。

在步骤 C 中，模拟恢复每个紫色变量。恢复是有条件的，当变量的引用计数大于0时才对其做模拟恢复。同样每个变量只能恢复一次，恢复后标记为黑，基本就是步骤 B 的逆运算。这样剩下的一堆没能恢复的就是该删除的蓝色节点了，在步骤 D 中遍历出来真的删除掉。

算法中都是模拟删除、模拟恢复、真的删除，都使用简单的遍历即可（最典型的深搜遍历）。复杂度为执行模拟操作的节点数正相关，不只是紫色的那些疑似垃圾变量。

现在，你已经对这个算法有了基本了解，我们回头来看这个如何与PHP集成。默认的，PHP的垃圾回收机制是打开的，然后有个 php.ini 设置允许你修改它：zend.enable_gc。

当垃圾回收机制打开时，每当根缓存区存满时，就会执行上面描述的循环查找算法。根缓存区有固定的大小，可存10,000个可能根,当然你可以通过修改PHP源码文件Zend/zend_gc.c中的常量GC_ROOT_BUFFER_MAX_ENTRIES，然后重新编译PHP，来修改这个10,000值。当垃圾回收机制关闭时，循环查找算法永不执行，然而，可能根将一直存在根缓冲区中，不管在配置中垃圾回收机制是否激活。

当垃圾回收机制关闭时，如果根缓冲区存满了可能根，更多的可能根显然不会被记录。那些没被记录的可能根，将不会被这个算法来分析处理。如果他们是循环引用周期的一部分，将永不能被清除进而导致内存泄漏。

即使在垃圾回收机制不可用时，可能根也被记录的原因是，相对于每次找到可能根后检查垃圾回收机制是否打开而言，记录可能根的操作更快。不过垃圾回收和分析机制本身要耗不少时间。

除了修改配置zend.enable_gc，也能通过分别调用gc_enable() 和 gc_disable()函数来打开和关闭垃圾回收机制。调用这些函数，与修改配置项来打开或关闭垃圾回收机制的效果是一样的。即使在可能根缓冲区还没满时，也能强制执行周期回收。你能调用gc_collect_cycles()函数达到这个目的。这个函数将返回使用这个算法回收的周期数。

允许打开和关闭垃圾回收机制并且允许自主的初始化的原因，是由于你的应用程序的某部分可能是高时效性的。在这种情况下，你可能不想使用垃圾回收机制。当然，对你的应用程序的某部分关闭垃圾回收机制，是在冒着可能内存泄漏的风险，因为一些可能根也许存不进有限的根缓冲区。因此，就在你调用gc_disable()函数释放内存之前，先调用gc_collect_cycles()函数可能比较明智。因为这将清除已存放在根缓冲区中的所有可能根，然后在垃圾回收机制被关闭时，可留下空缓冲区以有更多空间存储可能根。


性能方面考虑的因素

在上一节我们已经简单的提到：回收可能根有细微的性能上影响，但这是把PHP 5.2与PHP 5.3比较时才有的。尽管在PHP 5.2中，记录可能根相对于完全不记录可能根要慢些，而PHP 5.3中对 PHP run-time 的其他修改减少了这个性能损失。

这里主要有两个领域对性能有影响。第一个是内存占用空间的节省，另一个是垃圾回收机制执行内存清理时的执行时间增加(run-time delay)。我们将研究这两个领域。

内存占用空间的节省

首先，实现垃圾回收机制的整个原因是为了，一旦先决条件满足，通过清理循环引用的变量来节省内存占用。在PHP执行中，一旦根缓冲区满了或者调用gc_collect_cycles() 函数时，就会执行垃圾回收。在下图中，显示了下面脚本分别在PHP 5.2 和 PHP 5.3环境下的内存占用情况，其中排除了脚本启动时PHP本身占用的基本内存。

Example #1 Memory usage example

<?php
class Foo
{
    public $var = '3.1415962654';
}

$baseMemory = memory_get_usage();

for ( $i = 0; $i <= 100000; $i++ )
{
    $a = new Foo;
    $a->self = $a;
    if ( $i % 500 === 0 )
    {
        echo sprintf( '%8d: ', $i ), memory_get_usage() - $baseMemory, "\n";
    }
}
?>
Comparison of memory usage between PHP 5.2 and PHP 5.3

在这个很理论性的例子中，我们创建了一个对象，这个对象中的一个属性被设置为指回对象本身。在循环的下一个重复(iteration)中，当脚本中的变量被重新复制时，就会发生典型性的内存泄漏。在这个例子中，两个变量容器是泄漏的(对象容器和属性容器)，但是仅仅能找到一个可能根：就是被unset的那个变量。在10,000次重复后(也就产生总共10,000个可能根)，当根缓冲区满时，就执行垃圾回收机制，并且释放那些关联的可能根的内存。这从PHP 5.3的锯齿型内存占用图中很容易就能看到。每次执行完10,000次重复后，执行垃圾回收，并释放相关的重复使用的引用变量。在这个例子中由于泄漏的数据结构非常简单，所以垃圾回收机制本身不必做太多工作。从这个图表中，你能看到 PHP 5.3的最大内存占用大概是9 Mb，而PHP 5.2的内存占用一直增加。

执行时间增加(Run-Time Slowdowns)

垃圾回收影响性能的第二个领域是它释放已泄漏的内存耗费的时间。为了看到这个耗时时多少，我们稍微改变了上面的脚本，有更多次数的重复并且删除了循环中的内存占用计算，第二个脚本代码如下：

Example #2 GC性能影响

<?php
class Foo
{
    public $var = '3.1415962654';
}

for ( $i = 0; $i <= 1000000; $i++ )
{
    $a = new Foo;
    $a->self = $a;
}

echo memory_get_peak_usage(), "\n";
?>

我们将运行这个脚本两次，一次通过配置zend.enable_gc打开垃圾回收机制时，另一次是它关闭时。

Example #3 执行以上脚本

time php -dzend.enable_gc=0 -dmemory_limit=-1 -n example2.php
# and
time php -dzend.enable_gc=1 -dmemory_limit=-1 -n example2.php

在我的机器上，第一个命令持续执行时间大概为10.7秒，而第二个命令耗费11.4秒。时间上增加了7%。然而，执行这个脚本时内存占用的峰值降低了98%，从931Mb 降到 10Mb。这个基准不是很科学，或者并不能代表真实应用程序的数据，但是它的确显示了垃圾回收机制在内存占用方面的好处。好消息就是，对这个脚本而言，在执行中出现更多的循环引用变量时，内存节省的更多的情况下，每次时间增加的百分比都是7%。

PHP内部 GC 统计信息

在PHP内部，可以显示更多的关于垃圾回收机制如何运行的信息。但是要显示这些信息，你需要先重新编译PHP使benchmark和data-collecting code可用。你需要在按照你的意愿运行./configure前，把环境变量CFLAGS设置成-DGC_BENCH=1。下面的命令串就是做这个事：

Example #4 重新编译PHP以启用GC benchmarking

export CFLAGS=-DGC_BENCH=1
./config.nice
make clean
make

当你用新编译的PHP二进制文件来重新执行上面的例子代码，在PHP执行结束后，你将看到下面的信息：

Example #5 GC 统计数据

GC Statistics
-------------
Runs:               110
Collected:          2072204
Root buffer length: 0
Root buffer peak:   10000

      Possible            Remove from  Marked
        Root    Buffered     buffer     grey
      --------  --------  -----------  ------
ZVAL   7175487   1491291    1241690   3611871
ZOBJ  28506264   1527980     677581   1025731

主要的信息统计在第一个块。你能看到垃圾回收机制运行了110次，而且在这110次运行中，总共有超过两百万的内存分配被释放。只要垃圾回收机制运行了至少一次，根缓冲区峰值(Root buffer peak)总是10000.

结论

通常，PHP中的垃圾回收机制，仅仅在循环回收算法确实运行时会有时间消耗上的增加。但是在平常的(更小的)脚本中应根本就没有性能影响。

然而，在平常脚本中有循环回收机制运行的情况下，内存的节省将允许更多这种脚本同时运行在你的服务器上。因为总共使用的内存没达到上限。

这种好处在长时间运行脚本中尤其明显，诸如长时间的测试套件或者daemon脚本此类。同时，对通常比Web脚本运行时间长的» PHP-GTK应用程序，新的垃圾回收机制，应该会大大改变一直以来认为内存泄漏问题难以解决的看法。


DTrace 动态跟踪

Table of Contents

  • PHP 和 DTrace 介绍
  • 使用 PHP 和 DTrace
  • 使用 SystemTap 监控 PHP DTrace 静态探针


PHP 和 DTrace 介绍

包括 Solaris，macOS，Oracle Linux 和 BSD 在内的很多操作系统 都提供了 DTrace 跟踪调试框架，它永远可用，并且额外消耗极低。 DTrace 可以跟踪操作系统行为和用户程序的执行情况。 它可以显示参数值，也可以用来分析性能问题。 用户可以使用 DTrace D 脚本语言创建脚本文件来监控探针，进而高效分析数据指针。

除非用户使用 DTrace D 脚本激活并监控 PHP 探针，否则它并不会运行，所以不会给正常的应用执行带来任何性能损耗。 即使 PHP 探针被激活，它的消耗也是非常低的，甚至可以直接在生产系统中使用。

在运行时可以激活 PHP "用户级静态定义跟踪"（USDT）探针。 举例说明，如果 D 脚本正在监控 PHP function-entry 探针， 那么，每当 PHP 脚本函数被调用的时候，这个探针将被触发，同时 D 脚本中所关联的动作代码将被执行。 在脚本的动作代码中，可以打印出诸如函数所在源文件等信息的探针参数， 也可以记录诸如函数执行次数这样的聚合数据。

这里仅描述了 PHP USDT 探针。请参考各操作系统文档中关于 DTrace 的部分获取更多信息， 例如，如何使用 DTrace 跟踪函数调用，如何跟踪操作系统行为等。 需要注意的是，不同平台提供的 DTrace 功能并不完全相同。

从 PHP 5.4 开始加入 DTrace 静态探针，之前的版本需要使用 » PECL 扩展来实现跟踪功能。这个扩展现在已经废弃。

在某些 Linux 发行版中，可以使用 SystemTap 工具来监控 PHP DTrace 静态探针。


使用 PHP 和 DTrace

在支持 DTrace 动态跟踪的平台上，可以配置 PHP 打开 DTrace 静态探针。

PHP DTrace 静态探针配置

请参考操作系统文档获取启用操作系统 DTrace 支持的信息。 例如，在 Oracle Linux 系统上启动 UEK3 内核，并进行如下操作：

# modprobe fasttrap
# chmod 666 /dev/dtrace/helper

除了 chmod 命令，您也可以使用 ACL 包规则来限制特定用户对于设备的访问权限。

使用 --enable-dtrace 配置参数构建 PHP：

# ./configure --enable-dtrace ...
# make
# make install

这样就启用了 PHP 核心的静态探针。对于提供了自有探针的 PHP 扩展需要分别构建。

PHP 核心的 DTrace 静态探针

PHP 中包括以下可用的静态探针
探针名称 | 探针描述 | 探针参数
request-startup | 请求开始时触发。 | char *file, char *request_uri, char *request_method
request-shutdown | 请求关闭时触发。 | char *file, char *request_uri, char *request_method
compile-file-entry | 脚本开始编译时触发。 | char *compile_file, char *compile_file_translated
compile-file-return | 脚本完成编译时触发。 | char *compile_file, char *compile_file_translated
execute-entry | 操作数数组开始执行时触发。例如：函数调用，文件包含以及生成器恢复时会被触发。 | char *request_file, int lineno
execute-return | 操作数数组执行完毕之后触发。 | char *request_file, int lineno
function-entry | PHP 引擎进入 PHP 函数或者方法调用时触发。 | char *function_name, char *request_file, int lineno, char *classname, char *scope
function-return | PHP 引擎从 PHP 函数或者方法调用返回后触发。. | char *function_name, char *request_file, int lineno, char *classname, char *scope
exception-thrown | 有异常抛出时触发。 | char *classname
exception-caught | 有异常被捕获时触发。 | char *classname
error | 无论 error_reporting 的设定如何，在发生错误时都会触发。 | char *errormsg, char *request_file, int lineno

PHP 扩展可以拥有额外的静态探针。

列出 PHP 中可用的静态探针

要列出 PHP 中可用的静态探针，开启一个 PHP 进程，然后运行：

# dtrace -l

输出信息类似如下所示：

   ID   PROVIDER            MODULE                          FUNCTION NAME
   [ . . . ]
    4   php15271               php               dtrace_compile_file compile-file-entry
    5   php15271               php               dtrace_compile_file compile-file-return
    6   php15271               php                        zend_error error
    7   php15271               php  ZEND_CATCH_SPEC_CONST_CV_HANDLER exception-caught
    8   php15271               php     zend_throw_exception_internal exception-thrown
    9   php15271               php                 dtrace_execute_ex execute-entry
   10   php15271               php           dtrace_execute_internal execute-entry
   11   php15271               php                 dtrace_execute_ex execute-return
   12   php15271               php           dtrace_execute_internal execute-return
   13   php15271               php                 dtrace_execute_ex function-entry
   14   php15271               php                 dtrace_execute_ex function-return
   15   php15271               php              php_request_shutdown request-shutdown
   16   php15271               php               php_request_startup request-startup

Provider 一列由 php 和当前进程 id 的组成。

如果运行的是 Apache web 服务器，那么模块名称可能是 libphp5.so， 并且可能会出现多块信息，每个运行中的 Apache 进程对应一个输出块。

Function Name 一列表示 Provider 对应的 PHP 内部 C 实现函数名称。

如果没有运行任何 PHP 进程，那么就不会显示任何 PHP 探针。

PHP DTrace 示例

下例展示了基本的 DTrace D 脚本。

Example #1 all_probes.d for tracing all PHP Static Probes with DTrace

#!/usr/sbin/dtrace -Zs

#pragma D option quiet

php*:::compile-file-entry
{
    printf("PHP compile-file-entry\n");
    printf("  compile_file              %s\n", copyinstr(arg0));
    printf("  compile_file_translated   %s\n", copyinstr(arg1));
}

php*:::compile-file-return
{
    printf("PHP compile-file-return\n");
    printf("  compile_file              %s\n", copyinstr(arg0));
    printf("  compile_file_translated   %s\n", copyinstr(arg1));
}

php*:::error
{
    printf("PHP error\n");
    printf("  errormsg                  %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
}

php*:::exception-caught
{
    printf("PHP exception-caught\n");
    printf("  classname                 %s\n", copyinstr(arg0));
}

php*:::exception-thrown
{
    printf("PHP exception-thrown\n");
    printf("  classname                 %s\n", copyinstr(arg0));
}

php*:::execute-entry
{
    printf("PHP execute-entry\n");
    printf("  request_file              %s\n", copyinstr(arg0));
    printf("  lineno                    %d\n", (int)arg1);
}

php*:::execute-return
{
    printf("PHP execute-return\n");
    printf("  request_file              %s\n", copyinstr(arg0));
    printf("  lineno                    %d\n", (int)arg1);
}

php*:::function-entry
{
    printf("PHP function-entry\n");
    printf("  function_name             %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
    printf("  classname                 %s\n", copyinstr(arg3));
    printf("  scope                     %s\n", copyinstr(arg4));
}

php*:::function-return
{
    printf("PHP function-return\n");
    printf("  function_name             %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
    printf("  classname                 %s\n", copyinstr(arg3));
    printf("  scope                     %s\n", copyinstr(arg4));
}

php*:::request-shutdown
{
    printf("PHP request-shutdown\n");
    printf("  file                      %s\n", copyinstr(arg0));
    printf("  request_uri               %s\n", copyinstr(arg1));
    printf("  request_method            %s\n", copyinstr(arg2));
}

php*:::request-startup
{
    printf("PHP request-startup\n");
    printf("  file                      %s\n", copyinstr(arg0));
    printf("  request_uri               %s\n", copyinstr(arg1));
    printf("  request_method            %s\n", copyinstr(arg2));
}

此脚本在 dtrace 命令中使用了 -Z 选项。 此选项保证即使在没有任何 PHP 进程运行的时候脚本也能够正确执行。 如果省略了此选项，当没有任何探针可监控的时候，脚本会立即终止执行。

在运行此脚本的过程中，它将监控全部 PHP 核心静态探针。 运行 D 脚本：

# ./all_probes.d

再运行一个 PHP 脚本或者 PHP 应用，用来进行监控的 D 脚本会输出每个探针被触发时所携带的参数。

监控完成之后，使用 ^C 来终止 D 脚本的执行。

在多 CPU 的主机上，探针的显示顺序可能不是连续的，这取决于哪颗 CPU 执行探针以及多个 CPU 之间的线程迁移情况。 可以通过显示探针时间戳来减少混淆，例如：

php*:::function-entry
{
      printf("%lld: PHP function-entry ", walltimestamp);
      [ . . .]
}

参见

  • OCI8 和 DTrace 动态跟踪


使用 SystemTap 监控 PHP DTrace 静态探针

在某些 Linux 发行版上，可以使用 SystemTap 跟踪工具来跟踪 PHP 的静态 DTrace 探针。 此特性在 PHP 5.4.20 和 PHP 5.5 中具备。

安装支持 SystemTap 的 PHP

安装 SystemTap SDT 开发包。

# yum install systemtap-sdt-devel

安装 PHP 并启用 DTrace 探针：

# ./configure --enable-dtrace ...
# make

使用 SystemTap 列出 PHP 静态探针

使用 stap 命令列出 PHP 静态探针：

# stap -l 'process.provider("php").mark("*")' -c 'sapi/cli/php -i'

输出如下：

process("sapi/cli/php").provider("php").mark("compile__file__entry")
process("sapi/cli/php").provider("php").mark("compile__file__return")
process("sapi/cli/php").provider("php").mark("error")
process("sapi/cli/php").provider("php").mark("exception__caught")
process("sapi/cli/php").provider("php").mark("exception__thrown")
process("sapi/cli/php").provider("php").mark("execute__entry")
process("sapi/cli/php").provider("php").mark("execute__return")
process("sapi/cli/php").provider("php").mark("function__entry")
process("sapi/cli/php").provider("php").mark("function__return")
process("sapi/cli/php").provider("php").mark("request__shutdown")
process("sapi/cli/php").provider("php").mark("request__startup")

SystemTap 示例

Example #1 all_probes.stp for tracing all PHP Static Probes with SystemTap

probe process("sapi/cli/php").provider("php").mark("compile__file__entry") {
    printf("Probe compile__file__entry\n");
    printf("  compile_file %s\n", user_string($arg1));
    printf("  compile_file_translated %s\n", user_string($arg2));
}
probe process("sapi/cli/php").provider("php").mark("compile__file__return") {
    printf("Probe compile__file__return\n");
    printf("  compile_file %s\n", user_string($arg1));
    printf("  compile_file_translated %s\n", user_string($arg2));
}
probe process("sapi/cli/php").provider("php").mark("error") {
    printf("Probe error\n");
    printf("  errormsg %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
}
probe process("sapi/cli/php").provider("php").mark("exception__caught") {
    printf("Probe exception__caught\n");
    printf("  classname %s\n", user_string($arg1));
}
probe process("sapi/cli/php").provider("php").mark("exception__thrown") {
    printf("Probe exception__thrown\n");
    printf("  classname %s\n", user_string($arg1));
}
probe process("sapi/cli/php").provider("php").mark("execute__entry") {
    printf("Probe execute__entry\n");
    printf("  request_file %s\n", user_string($arg1));
    printf("  lineno %d\n", $arg2);
}
probe process("sapi/cli/php").provider("php").mark("execute__return") {
    printf("Probe execute__return\n");
    printf("  request_file %s\n", user_string($arg1));
    printf("  lineno %d\n", $arg2);
}
probe process("sapi/cli/php").provider("php").mark("function__entry") {
    printf("Probe function__entry\n");
    printf("  function_name %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
    printf("  classname %s\n", user_string($arg4));
    printf("  scope %s\n", user_string($arg5));
}
probe process("sapi/cli/php").provider("php").mark("function__return") {
    printf("Probe function__return: %s\n", user_string($arg1));
    printf(" function_name %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
    printf("  classname %s\n", user_string($arg4));
    printf("  scope %s\n", user_string($arg5));
}
probe process("sapi/cli/php").provider("php").mark("request__shutdown") {
    printf("Probe request__shutdown\n");
    printf("  file %s\n", user_string($arg1));
    printf("  request_uri %s\n", user_string($arg2));
    printf("  request_method %s\n", user_string($arg3));
}
probe process("sapi/cli/php").provider("php").mark("request__startup") {
    printf("Probe request__startup\n");
    printf("  file %s\n", user_string($arg1));
    printf("  request_uri %s\n", user_string($arg2));
    printf("  request_method %s\n", user_string($arg3));
}

在 PHP 脚本的执行过程中，上述脚本会跟踪所有的 PHP 核心静态探针：

# stap -c 'sapi/cli/php test.php' all_probes.stp


函数参考

Tip

参见 扩展库列表／归类.

  • 影响 PHP 行为的扩展
    • APCu — APC User Cache
    • Componere
    • 错误处理 — 错误处理和日志记录
    • FFI — Foreign Function Interface
    • Memtrack
    • OPcache
    • 输出控制 — 输出缓冲控制
    • PHP 选项/信息 — PHP 选项和信息
    • phpdbg — Interactive PHP Debugger
    • runkit7
    • uopz — User Operations for Zend
    • Weakref — Weak References
    • WinCache — Windows Cache for PHP
    • Xhprof — 层次式性能分析器
    • Yac
  • 音频格式操作
    • OpenAL — OpenAL Audio Bindings
  • 身份认证服务
    • Radius
  • 针对命令行的扩展
    • Ncurses — Ncurses Terminal Screen Control
    • Readline — GNU Readline
  • 压缩与归档扩展
    • Bzip2
    • LZF
    • Phar
    • Rar — Rar Archiving
    • Zip
    • Zlib — Zlib Compression
  • 加密扩展
    • CSPRNG
    • Hash — 哈希信息摘要框架
    • Mcrypt
    • Mhash
    • OpenSSL
    • 密码散列算法
    • Sodium
  • 数据库扩展
    • 数据库抽象层
    • 针对各数据库系统对应的扩展
  • 日期与时间相关扩展
    • Calendar
    • 日期/时间 — 日期和时间
    • HRTime — High resolution timing
  • 文件系统相关扩展
    • Direct IO
    • 目录
    • Fileinfo — 文件信息
    • 文件系统
    • Inotify
    • Proctitle
    • xattr
    • xdiff
  • 国际化与字符编码支持
    • Enchant — Enchant spelling library
    • Gender — Determine gender of firstnames
    • Gettext
    • iconv
    • intl — Internationalization Functions
    • 多字节字符串
    • Pspell
    • Recode — GNU Recode
  • 图像生成和处理
    • Exif — 可交换图像信息
    • GD — 图像处理和 GD
    • Gmagick
    • ImageMagick — 图像处理(ImageMagick)
  • 邮件相关扩展
    • IMAP — IMAP, POP3 和 NNTP
    • Mail
    • Mailparse
  • 数学扩展
    • BC Math — BCMath 任意精度数学
    • GMP — GNU Multiple Precision
    • Math — Mathematical Functions
    • Statistics
    • Trader — Technical Analysis for Traders
  • 非文本内容的 MIME 输出
    • FDF — Forms Data Format
    • GnuPG — GNU Privacy Guard
    • wkhtmltox
    • PS — PostScript document creation
    • RpmInfo
    • XLSWriter
  • 进程控制扩展
    • Eio
    • Ev
    • Expect
    • PCNTL — 进程控制
    • POSIX
    • 程序执行 — 系统程序执行
    • parallel
    • pthreads
    • pht
    • Semaphore — Semaphore, Shared Memory and IPC
    • Shared Memory
    • Sync
  • 其它基本扩展
    • GeoIP — Geo IP 定位
    • FANN — FANN (快速人工神经网络)
    • JSON — JavaScript对象符号（JSON）
    • Lua
    • LuaSandbox
    • Misc. — 杂项函数
    • SeasLog
    • SPL — PHP标准库 (SPL)
    • Streams
    • Swoole
    • Tidy
    • Tokenizer
    • URLs
    • V8js — V8 Javascript Engine Integration
    • Yaml — YAML 数据序列化
    • Yaf — Yet Another Framework
    • Yaconf
    • Taint
    • Data Structures
  • 其它服务
    • cURL — Client URL 库
    • Event
    • FTP
    • Gearman
    • LDAP — Lightweight Directory Access Protocol
    • Memcache
    • Memcached
    • mqseries
    • 网络
    • RRD — RRDtool
    • ScoutAPM
    • SNMP
    • Sockets
    • SSH2 — Secure Shell2
    • Stomp — Stomp Client
    • SVM — 支持向量机
    • SVN — Subversion
    • TCP — TCP Wrappers
    • Varnish
    • YAZ
    • 0MQ消息系统 — ZMQ
    • ZooKeeper
  • 搜索引擎扩展
    • Solr — Apache Solr
    • Sphinx — Sphinx 客户端
  • 针对服务器的扩展
    • Apache
    • FastCGI 进程管理器
  • Session 扩展
    • Sessions — Session Handling
  • 文本处理
    • CommonMark
    • Parle — Parsing and lexing
    • PCRE — 正则表达式(兼容 Perl)
    • POSIX Regex — Regular Expression (POSIX Extended)
    • ssdeep — ssdeep Fuzzy Hashing
    • 字符串
  • 变量与类型相关扩展
    • 数组
    • 类/对象 — 类/对象的信息
    • Classkit
    • Ctype — 字符类型检测
    • Filter — Data Filtering
    • 函数处理
    • Quickhash
    • 反射
    • Variable handling
  • Web 服务
    • OAuth
    • SOAP
    • Yar — Yet Another RPC Framework
    • XML-RPC
  • Windows 专用扩展
    • COM — COM and .Net (Windows)
    • win32service
  • XML 操作
    • DOM — Document Object Model
    • libxml
    • SimpleXML
    • WDDX
    • XMLDiff — XML diff and merge
    • XML 解析器
    • XMLReader
    • XMLWriter
    • XSL
  • 图形用户界面(GUI) 扩展
    • UI


影响 PHP 行为的扩展

  • APCu — APC User Cache
    • 简介
    • 安装／配置
    • 预定义常量
    • APCu 函数
    • APCUIterator — The APCUIterator class
  • Componere
    • 简介
    • 安装／配置
    • Componere\Abstract\Definition — The Componere\Abstract\Definition class
    • Componere\Definition — The Componere\Definition class
    • Componere\Patch — The Componere\Patch class
    • Componere\Method — The Componere\Method class
    • Componere\Value — The Componere\Value class
    • Componere 函数
  • 错误处理 — 错误处理和日志记录
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • 错误处理 函数
  • FFI — Foreign Function Interface
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • FFI — Main interface to C code and data
    • FFI\CData — C Data Handles
    • FFI\CType — C Type Handles
    • FFI\Exception — FFI Exceptions
    • FFI\ParserException — FFI Parser Exceptions
  • Memtrack
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
  • OPcache
    • 简介
    • 安装／配置
    • Preloading
    • OPcache 函数
  • 输出控制 — 输出缓冲控制
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Output Control 函数
  • PHP 选项/信息 — PHP 选项和信息
    • 简介
    • 安装／配置
    • 预定义常量
    • PHP 选项/信息 函数
  • phpdbg — Interactive PHP Debugger
    • 简介
    • 安装／配置
    • 预定义常量
    • phpdbg 函数
  • runkit7
    • 简介
    • 安装／配置
    • 预定义常量
    • runkit7 函数
  • uopz — User Operations for Zend
    • 简介
    • 安装／配置
    • 预定义常量
    • Uopz 函数
  • Weakref — Weak References
    • 简介
    • 安装／配置
    • WeakRef — The WeakRef class
    • WeakMap — The WeakMap class
  • WinCache — Windows Cache for PHP
    • 简介
    • 安装／配置
    • 预定义常量
    • WinCache 函数
    • Building for Windows
  • Xhprof — 层次式性能分析器
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Xhprof 函数
  • Yac
    • 简介
    • 安装／配置
    • 预定义常量
    • Yac — The Yac class


APC User Cache

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • APCu 函数
    • apcu_add — Cache a new variable in the data store
    • apcu_cache_info — Retrieves cached information from APCu's data store
    • apcu_cas — Updates an old value with a new value
    • apcu_clear_cache — Clears the APCu cache
    • apcu_dec — Decrease a stored number
    • apcu_delete — Removes a stored variable from the cache
    • apcu_enabled — Whether APCu is usable in the current environment
    • apcu_entry — Atomically fetch or generate a cache entry
    • apcu_exists — Checks if entry exists
    • apcu_fetch — Fetch a stored variable from the cache
    • apcu_inc — Increase a stored number
    • apcu_key_info — Get detailed information about the cache key
    • apcu_sma_info — Retrieves APCu Shared Memory Allocation information
    • apcu_store — Cache a variable in the data store
  • APCUIterator — The APCUIterator class
    • APCUIterator::__construct — Constructs an APCUIterator iterator object
    • APCUIterator::current — Get current item
    • APCUIterator::getTotalCount — Get total count
    • APCUIterator::getTotalHits — Get total cache hits
    • APCUIterator::getTotalSize — Get total cache size
    • APCUIterator::key — Get iterator key
    • APCUIterator::next — Move pointer to next item
    • APCUIterator::rewind — Rewinds iterator
    • APCUIterator::valid — Checks if current position is valid


简介

APCu is APC stripped of opcode caching.

The first APCu codebase was versioned 4.0.0, it was forked from the head of the APC master branch at the time.

PHP 7 support is available as of APCu 5.0.0.

APCu can provide a compatibility mode, such that it can provide a drop in replacement for the applicable parts of APC.


安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

构建此扩展不需要其他扩展。


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/apcu.

If backward compatibility with the applicable parts of APC is required, APCu must be configured with the option --enable-apcu-bc.

Warning

PHP 7 has a separate module (» apc.so) for backwards compatibility with APC.

In backward compatibility mode, APCu registers the applicable APC functions with backward compatible prototypes.

Where an APC function accepted cache_type, it is simply ignored by the backward compatible version, and omitted from the prototype for the APCu version.

Note: On Windows, APCu needs a temp path to exist, and be writable by the web server. It checks the TMP, TEMP and USERPROFILE environment variables in that order and finally tries the WINDOWS directory if none of those are set.

Note: For more in-depth, highly technical implementation details, see the » developer-supplied TECHNOTES file .

APCu sources can be found » here.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Although the default APCu settings are fine for many installations, serious users should consider tuning the following parameters.

There is one decision to be made configuring APCu. How much memory is going to be allocated to APCu. The ini directive that controls this is apc.shm_size Read the sections on this carefully below.

Once the server is running, the apc.php script that is bundled with the extension should be copied somewhere into the docroot and viewed with a browser as it provides a detailed analysis of the internal workings of APCu. If GD is enabled in PHP, it will even display some interesting graphs. If APCu is working, the Cache full count number (on the left) will display the number of times the cache has reached maximum capacity and has had to forcefully clean any entries that haven't been accessed in the last apc.ttl seconds. This number is minimized in a well-configured cache. If the cache is constantly being filled, and thusly forcefully freed, the resulting churning will have disparaging effects on script performance. The easiest way to minimize this number is to allocate more memory for APCu.

When APCu is compiled with mmap support (Memory Mapping), it will use only one memory segment, unlike when APCu is built with SHM (SysV Shared Memory) support that uses multiple memory segments. MMAP does not have a maximum limit like SHM does in /proc/sys/kernel/shmmax. In general MMAP support is recommended because it will reclaim the memory faster when the webserver is restarted and all in all reduces memory allocation impact at startup.

APCu configuration options
名字 | 默认 | 可修改范围 | 更新日志
apc.enabled | "1" | PHP_INI_SYSTEM |
apc.shm_segments | "1" | PHP_INI_SYSTEM |
apc.shm_size | "32M" | PHP_INI_SYSTEM |
apc.entries_hint | "4096" | PHP_INI_SYSTEM |
apc.ttl | "0" | PHP_INI_SYSTEM |
apc.gc_ttl | "3600" | PHP_INI_SYSTEM |
apc.mmap_file_mask | NULL | PHP_INI_SYSTEM |
apc.slam_defense | "1" | PHP_INI_SYSTEM |
apc.enable_cli | "0" | PHP_INI_SYSTEM |
apc.use_request_time | "0" | PHP_INI_ALL | Prior to APCu 5.1.19, the default was "1".
apc.serializer | "php" | PHP_INI_SYSTEM | Prior to APCu 5.1.15, the default was "default".
apc.coredump_unmap | "0" | PHP_INI_SYSTEM |
apc.preload_path | NULL | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

apc.enabled bool

apc.enabled can be set to 0 to disable APC. This is primarily useful when APC is statically compiled into PHP, since there is no other way to disable it (when compiled as a DSO, the extension line in php.ini can just be commented-out).

apc.shm_segments int

The number of shared memory segments to allocate for the compiler cache. If APC is running out of shared memory but apc.shm_size is set as high as the system allows, raising this value might prevent APC from exhausting its memory.

apc.shm_size string

The size of each shared memory segment given by a shorthand notation as described in this FAQ. By default, some systems (including most BSD variants) have very low limits on the size of a shared memory segment.

apc.entries_hint int

A "hint" about the number of distinct variables that might be stored. Set to zero or omit if not sure.

apc.ttl int

The number of seconds a cache entry is allowed to idle in a slot in case this cache entry slot is needed by another entry. Leaving this at zero means that APC's cache could potentially fill up with stale entries while newer entries won't be cached. In the event of a cache running out of available memory, the cache will be completely expunged if ttl is equal to 0. Otherwise, if the ttl is greater than 0, APC will attempt to remove expired entries.

apc.gc_ttl int

The number of seconds that a cache entry may remain on the garbage-collection list. This value provides a fail-safe in the event that a server process dies while executing a cached source file; if that source file is modified, the memory allocated for the old version will not be reclaimed until this TTL reached. Set to zero to disable this feature.

apc.mmap_file_mask string

If compiled with MMAP support by using --enable-mmap this is the mktemp-style file_mask to pass to the mmap module for determining whether your mmap'ed memory region is going to be file-backed or shared memory backed. For straight file-backed mmap, set it to something like /tmp/apc.XXXXXX (exactly 6 Xs). To use POSIX-style shm_open/mmap put a .shm somewhere in your mask. e.g. /apc.shm.XXXXXX You can also set it to /dev/zero to use your kernel's /dev/zero interface to anonymous mmap'ed memory. Leaving it undefined will force an anonymous mmap.

apc.slam_defense int

On very busy servers whenever you start the server or modify files you can create a race of many processes all trying to cache the same file at the same time. This option sets the percentage of processes that will skip trying to cache an uncached file. Or think of it as the probability of a single process to skip caching. For example, setting apc.slam_defense to 75 would mean that there is a 75% chance that the process will not cache an uncached file. So, the higher the setting the greater the defense against cache slams. Setting this to 0 disables this feature.

apc.enable_cli int

Mostly for testing and debugging. Setting this enables APC for the CLI version of PHP. Under normal circumstances, it is not ideal to create, populate and destroy the APC cache on every CLI request, but for various test scenarios it is useful to be able to enable APC for the CLI version of PHP easily.

apc.serializer string

Used to configure APC to use a third party serializer.

apc.coredump_unmap bool

Enables APC handling of signals, such as SIGSEGV, that write core files when signaled. When these signals are received, APC will attempt to unmap the shared memory segment in order to exclude it from the core file. This setting may improve system stability when fatal signals are received and a large APC shared memory segment is configured.

Warning

This feature is potentially dangerous. Unmapping the shared memory segment in a fatal signal handler may cause undefined behaviour if a fatal error occurs.

Note:

Although some kernels may provide a facility to ignore various types of shared memory when generating a core dump file, these implementations may also ignore important shared memory segments such as the Apache scoreboard.

apc.preload_path string

Optionally, set a path to the directory that APC will load cache data at startup.

apc.use_request_time bool

Use the SAPI request start time for TTL.


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

APC_ITER_ALL (int)
APC_ITER_ATIME (int)
APC_ITER_CTIME (int)
APC_ITER_DEVICE (int)
APC_ITER_DTIME (int)
APC_ITER_FILENAME (int)
APC_ITER_INODE (int)
APC_ITER_KEY (int)
APC_ITER_MD5 (int)
APC_ITER_MEM_SIZE (int)
APC_ITER_MTIME (int)
APC_ITER_NONE (int)
APC_ITER_NUM_HITS (int)
APC_ITER_REFCOUNT (int)
APC_ITER_TTL (int)
APC_ITER_TYPE (int)
APC_ITER_VALUE (int)
APC_LIST_ACTIVE (int)
APC_LIST_DELETED (int)


APCu 函数

Table of Contents

  • apcu_add — Cache a new variable in the data store
  • apcu_cache_info — Retrieves cached information from APCu's data store
  • apcu_cas — Updates an old value with a new value
  • apcu_clear_cache — Clears the APCu cache
  • apcu_dec — Decrease a stored number
  • apcu_delete — Removes a stored variable from the cache
  • apcu_enabled — Whether APCu is usable in the current environment
  • apcu_entry — Atomically fetch or generate a cache entry
  • apcu_exists — Checks if entry exists
  • apcu_fetch — Fetch a stored variable from the cache
  • apcu_inc — Increase a stored number
  • apcu_key_info — Get detailed information about the cache key
  • apcu_sma_info — Retrieves APCu Shared Memory Allocation information
  • apcu_store — Cache a variable in the data store


Cache a new variable in the data store

  • ? APCu 函数
  • apcu_cache_info ?
  • PHP Manual
  • APCu 函数
  • Cache a new variable in the data store

apcu_add

(PECL apcu >= 4.0.0)

apcu_add — Cache a new variable in the data store

说明

apcu_add ( string $key , mixed $var , int $ttl = 0 ) : bool
apcu_add ( array $values , mixed $unused = NULL , int $ttl = 0 ) : array

Caches a variable in the data store, only if it's not already stored.

Note: Unlike many other mechanisms in PHP, variables stored using apcu_add() will persist between requests (until the value is removed from the cache).

参数

key

Store the variable using this name. keys are cache-unique, so attempting to use apcu_add() to store data with a key that already exists will not overwrite the existing data, and will instead return false. (This is the only difference between apcu_add() and apcu_store().)

var

The variable to store

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

values

Names in key, variables in value.

返回值

Returns TRUE if something has effectively been added into the cache, FALSE otherwise. Second syntax returns array with error keys.

范例

Example #1 A apcu_add() example

<?php
$bar = 'BAR';
apcu_add('foo', $bar);
var_dump(apcu_fetch('foo'));
echo "\n";
$bar = 'NEVER GETS SET';
apcu_add('foo', $bar);
var_dump(apcu_fetch('foo'));
echo "\n";
?>

以上例程会输出：

string(3) "BAR"
string(3) "BAR"

参见

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Removes a stored variable from the cache


Retrieves cached information from APCu's data store

  • ? apcu_add
  • apcu_cas ?
  • PHP Manual
  • APCu 函数
  • Retrieves cached information from APCu's data store

apcu_cache_info

(PECL apcu >= 4.0.0)

apcu_cache_info — Retrieves cached information from APCu's data store

说明

apcu_cache_info ( bool $limited = false ) : array|false

Retrieves cached information and meta-data from APC's data store.

参数

limited

If limited is true, the return value will exclude the individual list of cache entries. This is useful when trying to optimize calls for statistics gathering.

返回值

Array of cached data (and meta-data) 或者在失败时返回 false

Note: apcu_cache_info() will raise a warning if it is unable to retrieve APC cache data. This typically occurs when APC is not enabled.

更新日志

版本 | 说明
PECL apcu 3.0.11 | The limited parameter was introduced.
PECL apcu 3.0.16 | The "filehits" option for the cache_type parameter was introduced.

范例

Example #1 A apcu_cache_info() example

<?php
print_r(apcu_cache_info());
?>

以上例程的输出类似于：

Array
(
    [num_slots] => 2000
    [ttl] => 0
    [num_hits] => 9
    [num_misses] => 3
    [start_time] => 1123958803
    [cache_list] => Array
        (
            [0] => Array
                (
                    [filename] => /path/to/apcu_test.php
                    [device] => 29954
                    [inode] => 1130511
                    [type] => file
                    [num_hits] => 1
                    [mtime] => 1123960686
                    [creation_time] => 1123960696
                    [deletion_time] => 0
                    [access_time] => 1123962864
                    [ref_count] => 1
                    [mem_size] => 677
                )
            [1] => Array (...iterates for each cached file)
)

参见

  • APCu configuration directives
  • APCUIterator::getTotalSize() - Get total cache size
  • APCUIterator::getTotalHits() - Get total cache hits
  • APCUIterator::getTotalCount() - Get total count


Updates an old value with a new value

  • ? apcu_cache_info
  • apcu_clear_cache ?
  • PHP Manual
  • APCu 函数
  • Updates an old value with a new value

apcu_cas

(PECL apcu >= 4.0.0)

apcu_cas — Updates an old value with a new value

说明

apcu_cas ( string $key , int $old , int $new ) : bool

apcu_cas() updates an already existing integer value if the old parameter matches the currently stored value with the value of the new parameter.

参数

key

The key of the value being updated.

old

The old value (the value currently stored).

new

The new value to update to.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 apcu_cas() example

<?php
apcu_store('foobar', 2);
echo '$foobar = 2', PHP_EOL;
echo '$foobar == 1 ? 2 : 1 = ', (apcu_cas('foobar', 1, 2) ? 'ok' : 'fail'), PHP_EOL;
echo '$foobar == 2 ? 1 : 2 = ', (apcu_cas('foobar', 2, 1) ? 'ok' : 'fail'), PHP_EOL;

echo '$foobar = ', apcu_fetch('foobar'), PHP_EOL;

echo '$f__bar == 1 ? 2 : 1 = ', (apcu_cas('f__bar', 1, 2) ? 'ok' : 'fail'), PHP_EOL;

apcu_store('perfection', 'xyz');
echo '$perfection == 2 ? 1 : 2 = ', (apcu_cas('perfection', 2, 1) ? 'ok' : 'epic fail'), PHP_EOL;

echo '$foobar = ', apcu_fetch('foobar'), PHP_EOL;
?>

以上例程的输出类似于：

$foobar = 2
$foobar == 1 ? 2 : 1 = fail
$foobar == 2 ? 1 : 2 = ok
$foobar = 1
$f__bar == 1 ? 2 : 1 = fail
$perfection == 2 ? 1 : 2 = epic fail
$foobar = 1

参见

  • apcu_dec() - Decrease a stored number
  • apcu_store() - Cache a variable in the data store


Clears the APCu cache

  • ? apcu_cas
  • apcu_dec ?
  • PHP Manual
  • APCu 函数
  • Clears the APCu cache

apcu_clear_cache

(PECL apcu >= 4.0.0)

apcu_clear_cache — Clears the APCu cache

说明

apcu_clear_cache ( ) : bool

Clears the cache.

参数

此函数没有参数。

返回值

Returns true always

参见

  • apcu_cache_info() - Retrieves cached information from APCu's data store


Decrease a stored number

  • ? apcu_clear_cache
  • apcu_delete ?
  • PHP Manual
  • APCu 函数
  • Decrease a stored number

apcu_dec

(PECL apcu >= 4.0.0)

apcu_dec — Decrease a stored number

说明

apcu_dec ( string $key , int $step = 1 , bool &$success = ? , int $ttl = 0 ) : int|false

Decreases a stored integer value.

参数

key

The key of the value being decreased.

step

The step, or value to decrease.

success

Optionally pass the success or fail boolean value to this referenced variable.

ttl

TTL to use if the operation inserts a new value (rather than decrementing an existing one).

返回值

Returns the current value of key's value on success, 或者在失败时返回 false

更新日志

版本 | 说明
5.1.12 | The ttl parameter has been added.

范例

Example #1 apcu_dec() example

<?php
echo "Let's do something with success", PHP_EOL;

apcu_store('anumber', 42);

echo apcu_fetch('anumber'), PHP_EOL;

echo apcu_dec('anumber'), PHP_EOL;
echo apcu_dec('anumber', 10), PHP_EOL;
echo apcu_dec('anumber', 10, $success), PHP_EOL;

var_dump($success);

echo "Now, let's fail", PHP_EOL, PHP_EOL;

apcu_store('astring', 'foo');

$ret = apcu_dec('astring', 1, $fail);

var_dump($ret);
var_dump($fail);
?>

以上例程的输出类似于：

Let's do something with success
42
41
31
21
bool(true)
Now, let's fail

bool(false)
bool(false)

参见

  • apcu_inc() - Increase a stored number


Removes a stored variable from the cache

  • ? apcu_dec
  • apcu_enabled ?
  • PHP Manual
  • APCu 函数
  • Removes a stored variable from the cache

apcu_delete

(PECL apcu >= 4.0.0)

apcu_delete — Removes a stored variable from the cache

说明

apcu_delete ( mixed $key ) : mixed

Removes a stored variable from the cache.

参数

key

A key used to store the value as a string for a single key, or as an array of strings for several keys, or as an APCUIterator object.

返回值

If key is an array, an indexed array of the keys is returned. Otherwise true is returned on success, or false on failure.

范例

Example #1 A apcu_delete() example

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
apcu_delete('foo');
// this is obviously useless in this form

// Alternatively delete multiple keys.
apcu_delete(['foo', 'bar', 'baz']);

// Or use an Iterator with a regular expression.
apcu_delete(new APCUIterator('#^myprefix_#'));
?>

参见

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_clear_cache() - Clears the APCu cache
  • APCUIterator


Whether APCu is usable in the current environment

  • ? apcu_delete
  • apcu_entry ?
  • PHP Manual
  • APCu 函数
  • Whether APCu is usable in the current environment

apcu_enabled

(PECL apcu >= 4.0.3)

apcu_enabled — Whether APCu is usable in the current environment

说明

apcu_enabled ( ) : bool

Returns whether APCu is usable in the current environment.

参数

此函数没有参数。

返回值

Returns true when APCu is usable in the current environment, false otherwise.


Atomically fetch or generate a cache entry

  • ? apcu_enabled
  • apcu_exists ?
  • PHP Manual
  • APCu 函数
  • Atomically fetch or generate a cache entry

apcu_entry

(PECL apcu >= 5.1.0)

apcu_entry — Atomically fetch or generate a cache entry

说明

apcu_entry ( string $key , callable $generator , int $ttl = 0 ) : mixed

Atomically attempts to find key in the cache, if it cannot be found generator is called, passing key as the only argument. The return value of the call is then cached with the optionally specified ttl, and returned.

Note: When control enters apcu_entry() the lock for the cache is acquired exclusively, it is released when control leaves apcu_entry(): In effect, this turns the body of generator into a critical section, disallowing two processes from executing the same code paths concurrently. In addition, it prohibits the concurrent execution of any other APCu functions, since they will acquire the same lock.

Warning

The only APCu function that can be called safely by generator is apcu_entry().

参数

key

Identity of cache entry

generator

A callable that accepts key as the only argument and returns the value to cache.

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

返回值

Returns the cached value

范例

Example #1 An apcu_entry() example

<?php
$config = apcu_entry("config", function($key) {
 return [
   "fruit" => apcu_entry("config.fruit", function($key){
     return [
       "apples",
       "pears"
     ];
   }),
   "people" => apcu_entry("config.people", function($key){
     return [
      "bob",
      "joe",
      "niki"
     ];
   })
 ];
});

var_dump($config);
?>

以上例程会输出：

array(2) {
  ["fruit"]=>
  array(2) {
    [0]=>
    string(6) "apples"
    [1]=>
    string(5) "pears"
  }
  ["people"]=>
  array(3) {
    [0]=>
    string(3) "bob"
    [1]=>
    string(3) "joe"
    [2]=>
    string(4) "niki"
  }
}

参见

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Removes a stored variable from the cache


Checks if entry exists

  • ? apcu_entry
  • apcu_fetch ?
  • PHP Manual
  • APCu 函数
  • Checks if entry exists

apcu_exists

(PECL apcu >= 4.0.0)

apcu_exists — Checks if entry exists

说明

apcu_exists ( mixed $keys ) : mixed

Checks if one or more APCu entries exist.

参数

keys

A string, or an array of strings, that contain keys.

返回值

Returns true if the key exists, otherwise false Or if an array was passed to keys, then an array is returned that contains all existing keys, or an empty array if none exist.

范例

Example #1 apcu_exists() example

<?php
$fruit  = 'apple';
$veggie = 'carrot';

apcu_store('foo', $fruit);
apcu_store('bar', $veggie);

if (apcu_exists('foo')) {
    echo "Foo exists: ";
    echo apcu_fetch('foo');
} else {
    echo "Foo does not exist";
}

echo PHP_EOL;
if (apcu_exists('baz')) {
    echo "Baz exists.";
} else {
    echo "Baz does not exist";
}

echo PHP_EOL;

$ret = apcu_exists(array('foo', 'donotexist', 'bar'));
var_dump($ret);

?>

以上例程的输出类似于：

Foo exists: apple
Baz does not exist
array(2) {
  ["foo"]=>
  bool(true)
  ["bar"]=>
  bool(true)
}

参见

  • apcu_cache_info() - Retrieves cached information from APCu's data store
  • apcu_fetch() - Fetch a stored variable from the cache


Fetch a stored variable from the cache

  • ? apcu_exists
  • apcu_inc ?
  • PHP Manual
  • APCu 函数
  • Fetch a stored variable from the cache

apcu_fetch

(PECL apcu >= 4.0.0)

apcu_fetch — Fetch a stored variable from the cache

说明

apcu_fetch ( mixed $key , bool &$success = ? ) : mixed

Fetches an entry from the cache.

参数

key

The key used to store the value (with apcu_store()). If an array is passed then each element is fetched and returned.

success

Set to true in success and false in failure.

返回值

The stored variable or array of variables on success; false on failure

范例

Example #1 A apcu_fetch() example

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
var_dump(apcu_fetch('foo'));
?>

以上例程会输出：

string(3) "BAR"

更新日志

版本 | 说明
PECL apcu 3.0.17 | The success parameter was added.

参见

  • apcu_store() - Cache a variable in the data store
  • apcu_delete() - Removes a stored variable from the cache
  • APCUIterator


Increase a stored number

  • ? apcu_fetch
  • apcu_key_info ?
  • PHP Manual
  • APCu 函数
  • Increase a stored number

apcu_inc

(PECL apcu >= 4.0.0)

apcu_inc — Increase a stored number

说明

apcu_inc ( string $key , int $step = 1 , bool &$success = ? , int $ttl = 0 ) : int|false

Increases a stored number.

参数

key

The key of the value being increased.

step

The step, or value to increase.

success

Optionally pass the success or fail boolean value to this referenced variable.

ttl

TTL to use if the operation inserts a new value (rather than incrementing an existing one).

返回值

Returns the current value of key's value on success, 或者在失败时返回 false

更新日志

版本 | 说明
5.1.12 | The ttl parameter has been added.

范例

Example #1 apcu_inc() example

<?php
echo "Let's do something with success", PHP_EOL;

apcu_store('anumber', 42);

echo apcu_fetch('anumber'), PHP_EOL;

echo apcu_inc('anumber'), PHP_EOL;
echo apcu_inc('anumber', 10), PHP_EOL;
echo apcu_inc('anumber', 10, $success), PHP_EOL;

var_dump($success);

echo "Now, let's fail", PHP_EOL, PHP_EOL;

apcu_store('astring', 'foo');

$ret = apcu_inc('astring', 1, $fail);

var_dump($ret);
var_dump($fail);
?>

以上例程的输出类似于：

Let's do something with success
42
43
53
63
bool(true)
Now, let's fail

bool(false)
bool(false)

参见

  • apcu_dec() - Decrease a stored number


Get detailed information about the cache key

  • ? apcu_inc
  • apcu_sma_info ?
  • PHP Manual
  • APCu 函数
  • Get detailed information about the cache key

apcu_key_info

(No version information available, might only be in Git)

apcu_key_info — Get detailed information about the cache key

说明

apcu_key_info ( string $key ) : array

Get detailed information about the cache key

参数

key

Get detailed information about the cache key

返回值

null or array info

范例

Example #1 A apcu_key_info() example

<?php
apcu_add('a','b');
var_dump(apcu_key_info('a'));
?>

以上例程会输出：

array(7) {
  ["hits"]=>
  int(0)
  ["access_time"]=>
  int(1606701783)
  ["mtime"]=>
  int(1606701783)
  ["creation_time"]=>
  int(1606701783)
  ["deletion_time"]=>
  int(0)
  ["ttl"]=>
  int(0)
  ["refs"]=>
  int(0)
}

参见

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Removes a stored variable from the cache


Retrieves APCu Shared Memory Allocation information

  • ? apcu_key_info
  • apcu_store ?
  • PHP Manual
  • APCu 函数
  • Retrieves APCu Shared Memory Allocation information

apcu_sma_info

(PECL apcu >= 4.0.0)

apcu_sma_info — Retrieves APCu Shared Memory Allocation information

说明

apcu_sma_info ( bool $limited = false ) : array

Retrieves APCu Shared Memory Allocation information.

参数

limited

When set to false (default) apcu_sma_info() will return a detailed information about each segment.

返回值

Array of Shared Memory Allocation data; false on failure.

范例

Example #1 A apcu_sma_info() example

<?php
print_r(apcu_sma_info());
?>

以上例程的输出类似于：

Array
(
    [num_seg] => 1
    [seg_size] => 31457280
    [avail_mem] => 31448408
    [block_lists] => Array
        (
            [0] => Array
                (
                    [0] => Array
                        (
                            [size] => 31448408
                            [offset] => 8864
                        )

                )

        )

)

参见

  • APCu configuration directives


Cache a variable in the data store

  • ? apcu_sma_info
  • APCUIterator ?
  • PHP Manual
  • APCu 函数
  • Cache a variable in the data store

apcu_store

(PECL apcu >= 4.0.0)

apcu_store — Cache a variable in the data store

说明

apcu_store ( string $key , mixed $var , int $ttl = 0 ) : bool
apcu_store ( array $values , mixed $unused = NULL , int $ttl = 0 ) : array

Cache a variable in the data store.

Note: Unlike many other mechanisms in PHP, variables stored using apcu_store() will persist between requests (until the value is removed from the cache).

参数

key

Store the variable using this name. keys are cache-unique, so storing a second value with the same key will overwrite the original value.

var

The variable to store

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

values

Names in key, variables in value.

返回值

成功时返回 true， 或者在失败时返回 false。 Second syntax returns array with error keys.

范例

Example #1 A apcu_store() example

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
var_dump(apcu_fetch('foo'));
?>

以上例程会输出：

string(3) "BAR"

参见

  • apcu_add() - Cache a new variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Removes a stored variable from the cache


The APCUIterator class

(PECL apcu >= 5.0.0)

简介

The APCUIterator class makes it easier to iterate over large APCu caches. This is helpful as it allows iterating over large caches in steps, while grabbing a defined number of entries per lock instance, so it frees the cache locks for other activities rather than hold up the entire cache to grab 100 (the default) entries. Also, using regular expression matching is more efficient as it's been moved to the C level.

类摘要

APCUIterator implements Iterator {
/* Methods */
public __construct ( mixed $search = null , int $format = APC_ITER_ALL , int $chunk_size = 100 , int $list = APC_LIST_ACTIVE )
public current ( ) : mixed
public getTotalCount ( ) : int
public getTotalHits ( ) : int
public getTotalSize ( ) : int
public key ( ) : string
public next ( ) : bool
public rewind ( ) : void
public valid ( ) : bool
}

Table of Contents

  • APCUIterator::__construct — Constructs an APCUIterator iterator object
  • APCUIterator::current — Get current item
  • APCUIterator::getTotalCount — Get total count
  • APCUIterator::getTotalHits — Get total cache hits
  • APCUIterator::getTotalSize — Get total cache size
  • APCUIterator::key — Get iterator key
  • APCUIterator::next — Move pointer to next item
  • APCUIterator::rewind — Rewinds iterator
  • APCUIterator::valid — Checks if current position is valid


Constructs an APCUIterator iterator object

  • ? APCUIterator
  • APCUIterator::current ?
  • PHP Manual
  • APCUIterator
  • Constructs an APCUIterator iterator object

APCUIterator::__construct

(PECL apcu >= 5.0.0)

APCUIterator::__construct — Constructs an APCUIterator iterator object

说明

public APCUIterator::__construct ( mixed $search = null , int $format = APC_ITER_ALL , int $chunk_size = 100 , int $list = APC_LIST_ACTIVE )

Constructs an APCUIterator object.

参数

search

A PCRE regular expression that matches against APCu key names, either as a string for a single regular expression, or as an array of regular expressions. Or, optionally pass in null to skip the search.

format

The desired format, as configured with one or more of the APC_ITER_* constants.

chunk_size

The chunk size. Must be a value greater than 0. The default value is 100.

list

The type to list. Either pass in APC_LIST_ACTIVE or APC_LIST_DELETED.

返回值

An APCUIterator object on success, or null on failure.

范例

Example #1 A APCUIterator::__construct() example

<?php
foreach (new APCUIterator('/^counter\./') as $counter) {
    echo "$counter[key]: $counter[value]\n";
    apc_dec($counter['key'], $counter['value']);
}
?>

参见

  • apcu_exists() - Checks if entry exists
  • apcu_cache_info() - Retrieves cached information from APCu's data store


Get current item

  • ? APCUIterator::__construct
  • APCUIterator::getTotalCount ?
  • PHP Manual
  • APCUIterator
  • Get current item

APCUIterator::current

(PECL apcu >= 5.0.0)

APCUIterator::current — Get current item

说明

public APCUIterator::current ( ) : mixed

Gets the current item from the APCUIterator stack.

参数

此函数没有参数。

返回值

Returns the current item on success, or false if no more items or exist, or on failure.

参见

  • APCUIterator::next() - Move pointer to next item
  • Iterator::current() - 返回当前元素


Get total count

  • ? APCUIterator::current
  • APCUIterator::getTotalHits ?
  • PHP Manual
  • APCUIterator
  • Get total count

APCUIterator::getTotalCount

(PECL apcu >= 5.0.0)

APCUIterator::getTotalCount — Get total count

说明

public APCUIterator::getTotalCount ( ) : int

Get the total count.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The total count.

参见

  • APCUIterator::getTotalHits() - Get total cache hits
  • APCUIterator::getTotalSize() - Get total cache size
  • apcu_cache_info() - Retrieves cached information from APCu's data store


Get total cache hits

  • ? APCUIterator::getTotalCount
  • APCUIterator::getTotalSize ?
  • PHP Manual
  • APCUIterator
  • Get total cache hits

APCUIterator::getTotalHits

(PECL apcu >= 5.0.0)

APCUIterator::getTotalHits — Get total cache hits

说明

public APCUIterator::getTotalHits ( ) : int

Gets the total number of cache hits.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The number of hits on success, or false on failure.

参见

  • APCUIterator::getTotalCount() - Get total count
  • APCUIterator::getTotalSize() - Get total cache size
  • apcu_cache_info() - Retrieves cached information from APCu's data store


Get total cache size

  • ? APCUIterator::getTotalHits
  • APCUIterator::key ?
  • PHP Manual
  • APCUIterator
  • Get total cache size

APCUIterator::getTotalSize

(PECL apcu >= 5.0.0)

APCUIterator::getTotalSize — Get total cache size

说明

public APCUIterator::getTotalSize ( ) : int

Gets the total cache size.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The total cache size.

参见

  • APCUIterator::getTotalCount() - Get total count
  • APCUIterator::getTotalHits() - Get total cache hits
  • apc_cache_info()


Get iterator key

  • ? APCUIterator::getTotalSize
  • APCUIterator::next ?
  • PHP Manual
  • APCUIterator
  • Get iterator key

APCUIterator::key

(PECL apcu >= 5.0.0)

APCUIterator::key — Get iterator key

说明

public APCUIterator::key ( ) : string

Gets the current iterator key.

参数

此函数没有参数。

返回值

Returns the key on success, or false upon failure.

参见

  • APCUIterator::current() - Get current item
  • Iterator::key() - 返回当前元素的键


Move pointer to next item

  • ? APCUIterator::key
  • APCUIterator::rewind ?
  • PHP Manual
  • APCUIterator
  • Move pointer to next item

APCUIterator::next

(PECL apcu >= 5.0.0)

APCUIterator::next — Move pointer to next item

说明

public APCUIterator::next ( ) : bool

Moves the iterator pointer to the next element.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • APCUIterator::current() - Get current item
  • APCUIterator::rewind() - Rewinds iterator
  • Iterator::next() - 向前移动到下一个元素


Rewinds iterator

  • ? APCUIterator::next
  • APCUIterator::valid ?
  • PHP Manual
  • APCUIterator
  • Rewinds iterator

APCUIterator::rewind

(PECL apcu >= 5.0.0)

APCUIterator::rewind — Rewinds iterator

说明

public APCUIterator::rewind ( ) : void

Rewinds back the iterator to the first element.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • APCUIterator::next() - Move pointer to next item
  • Iterator::next() - 向前移动到下一个元素


Checks if current position is valid

  • ? APCUIterator::rewind
  • Componere ?
  • PHP Manual
  • APCUIterator
  • Checks if current position is valid

APCUIterator::valid

(PECL apcu >= 5.0.0)

APCUIterator::valid — Checks if current position is valid

说明

public APCUIterator::valid ( ) : bool

Checks if the current iterator position is valid.

参数

此函数没有参数。

返回值

Returns true if the current iterator position is valid, otherwise false.

参见

  • APCUIterator::current() - Get current item
  • Iterator::valid() - 检查当前位置是否有效


Componere

  • 简介
  • 安装／配置
    • 需求
    • 安装
  • Componere\Abstract\Definition — The Componere\Abstract\Definition class
    • Componere\Abstract\Definition::addInterface — Add Interface
    • Componere\Abstract\Definition::addMethod — Add Method
    • Componere\Abstract\Definition::addTrait — Add Trait
    • Componere\Abstract\Definition::getReflector — Reflection
  • Componere\Definition — The Componere\Definition class
    • Componere\Definition::__construct — Definition Construction
    • Componere\Definition::addConstant — Add Constant
    • Componere\Definition::addProperty — Add Property
    • Componere\Definition::register — Registration
    • Componere\Definition::isRegistered — State Detection
    • Componere\Definition::getClosure — Get Closure
    • Componere\Definition::getClosures — Get Closures
  • Componere\Patch — The Componere\Patch class
    • Componere\Patch::__construct — Patch Construction
    • Componere\Patch::apply — Application
    • Componere\Patch::revert — Reversal
    • Componere\Patch::isApplied — State Detection
    • Componere\Patch::derive — Patch Derivation
    • Componere\Patch::getClosure — Get Closure
    • Componere\Patch::getClosures — Get Closures
  • Componere\Method — The Componere\Method class
    • Componere\Method::__construct — Method Construction
    • Componere\Method::setPrivate — Accessibility Modification
    • Componere\Method::setProtected — Accessibility Modification
    • Componere\Method::setStatic — Accessibility Modification
    • Componere\Method::getReflector — Reflection
  • Componere\Value — The Componere\Value class
    • Componere\Value::__construct — Value Construction
    • Componere\Value::setPrivate — Accessibility Modification
    • Componere\Value::setProtected — Accessibility Modification
    • Componere\Value::setStatic — Accessibility Modification
    • Componere\Value::isPrivate — Accessibility Detection
    • Componere\Value::isProtected — Accessibility Detection
    • Componere\Value::isStatic — Accessibility Detection
    • Componere\Value::hasDefault — Value Interaction
  • Componere 函数
    • Componere\cast — Casting
    • Componere\cast_by_ref — Casting


简介

Componere (latin, English: compose) targets production environments and provides an API for composition of classes, monkey patching, and casting.

Composition:

Componere\Definition is used to define (or redefine) a class at runtime; The class can then be registered, and in the case of redefinition it replaces the original class for as long as the Componere\Definition exists.

public Componere\Definition::__construct ( string $name )
public Componere\Definition::__construct ( string $name , string $parent )
public Componere\Definition::__construct ( string $name , array $interfaces )
public Componere\Definition::__construct ( string $name , string $parent , array $interfaces )

Patching:

Componere\Patch is used to change the class of a specific instance of an object at runtime; Upon application the patch will remain applied for as long as the Componere\Patch exists, and can be reverted explicitly.

public Componere\Patch::__construct ( object $instance )
public Componere\Patch::__construct ( object $instance , array $interfaces )

Casting:

Componere\ casting functions can cast among user defined compatible types; Where compatible means Type is sub or super to the type of object.

Componere\cast ( Type $type , $object ) : Type
Componere\cast_by_ref ( Type $type , $object ) : Type


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Componere
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

Reflection is required


  • ? 需求
  • Componere\Abstract\Definition ?
  • PHP Manual
  • 安装／配置
  • 安装

安装

Componere source and releases are available on » github


The Componere\Abstract\Definition class

(Componere 2 >= 2.1.0)

简介

This final abstract represents a class entry, and should not be used by the programmer.

类摘要

final abstract Componere\Abstract\Definition {
/* 方法 */
public addInterface ( string $interface ) : Definition
public addMethod ( string $name , Componere\Method $method ) : Definition
public addTrait ( string $trait ) : Definition
public getReflector ( ) : ReflectionClass
}

Table of Contents

  • Componere\Abstract\Definition::addInterface — Add Interface
  • Componere\Abstract\Definition::addMethod — Add Method
  • Componere\Abstract\Definition::addTrait — Add Trait
  • Componere\Abstract\Definition::getReflector — Reflection


Add Interface

  • ? Componere\Abstract\Definition
  • Componere\Abstract\Definition::addMethod ?
  • PHP Manual
  • Componere\Abstract\Definition
  • Add Interface

Componere\Abstract\Definition::addInterface

(Componere 2 >= 2.1.0)

Componere\Abstract\Definition::addInterface — Add Interface

说明

public Componere\Abstract\Definition::addInterface ( string $interface ) : Definition

Shall implement the given interface on the current definition

参数

interface

The case insensitive name of an interface

返回值

The current Definition

Exceptions

Warning

Shall throw RuntimeException if Definition was registered


Add Method

  • ? Componere\Abstract\Definition::addInterface
  • Componere\Abstract\Definition::addTrait ?
  • PHP Manual
  • Componere\Abstract\Definition
  • Add Method

Componere\Abstract\Definition::addMethod

(Componere 2 >= 2.1.0)

Componere\Abstract\Definition::addMethod — Add Method

说明

public Componere\Abstract\Definition::addMethod ( string $name , Componere\Method $method ) : Definition

Shall create or override a method on the current definition.

参数

name

The case insensitive name for method

method

Componere\Method not previously added to another Definition

返回值

The current Definition

Exceptions

Warning

Shall throw RuntimeException if Definition was registered

Warning

Shall throw RuntimeException if Method was added to another Definition


Add Trait

  • ? Componere\Abstract\Definition::addMethod
  • Componere\Abstract\Definition::getReflector ?
  • PHP Manual
  • Componere\Abstract\Definition
  • Add Trait

Componere\Abstract\Definition::addTrait

(Componere 2 >= 2.1.0)

Componere\Abstract\Definition::addTrait — Add Trait

说明

public Componere\Abstract\Definition::addTrait ( string $trait ) : Definition

Shall use the given trait for the current definition

参数

trait

The case insensitive name of a trait

返回值

The current Definition

Exceptions

Warning

Shall throw RuntimeException if Definition was registered


Reflection

  • ? Componere\Abstract\Definition::addTrait
  • Componere\Definition ?
  • PHP Manual
  • Componere\Abstract\Definition
  • Reflection

Componere\Abstract\Definition::getReflector

(Componere 2 >= 2.1.0)

Componere\Abstract\Definition::getReflector — Reflection

说明

public Componere\Abstract\Definition::getReflector ( ) : ReflectionClass

Shall create or return a ReflectionClass

返回值

A ReflectionClass for the current definition (cached)


The Componere\Definition class

(Componere 2 >= 2.1.0)

简介

The Definition class allows the programmer to build and register a type at runtime.

Should a Definition replace an existing class, the existing class will be restored when the Definition is destroyed.

类摘要

final Componere\Definition extends Componere\Abstract\Definition {
/* Constructors */
public __construct ( string $name )
public __construct ( string $name , string $parent )
public __construct ( string $name , array $interfaces )
public __construct ( string $name , string $parent , array $interfaces )
/* 方法 */
public addConstant ( string $name , Componere\Value $value ) : Definition
public addProperty ( string $name , Componere\Value $value ) : Definition
public register ( ) : void
public isRegistered ( ) : bool
public getClosure ( string $name ) : Closure
public getClosures ( ) : array
/* 继承的方法 */
public Componere\Abstract\Definition::addInterface ( string $interface ) : Definition
public Componere\Abstract\Definition::addMethod ( string $name , Componere\Method $method ) : Definition
public Componere\Abstract\Definition::addTrait ( string $trait ) : Definition
public Componere\Abstract\Definition::getReflector ( ) : ReflectionClass
}

Table of Contents

  • Componere\Definition::__construct — Definition Construction
  • Componere\Definition::addConstant — Add Constant
  • Componere\Definition::addProperty — Add Property
  • Componere\Definition::register — Registration
  • Componere\Definition::isRegistered — State Detection
  • Componere\Definition::getClosure — Get Closure
  • Componere\Definition::getClosures — Get Closures


Definition Construction

  • ? Componere\Definition
  • Componere\Definition::addConstant ?
  • PHP Manual
  • Componere\Definition
  • Definition Construction

Componere\Definition::__construct

(Componere 2 >= 2.1.0)

Componere\Definition::__construct — Definition Construction

说明

public Componere\Definition::__construct ( string $name )
public Componere\Definition::__construct ( string $name , string $parent )
public Componere\Definition::__construct ( string $name , array $interfaces )
public Componere\Definition::__construct ( string $name , string $parent , array $interfaces )

参数

name

A case insensitive class name

parent

A case insensitive class name

interfaces

An array of case insensitive class names

Exceptions

Warning

Shall throw InvalidArgumentException if an attempt is made to replace an internal class

Warning

Shall throw InvalidArgumentException if an attempt is made to replace an interface

Warning

Shall throw InvalidArgumentException if an attempt is made to replace a trait

Warning

Shall throw RuntimeException if a class in interfaces cannot be found

Warning

Shall throw RuntimeException if an class in interfaces is not an interface


Add Constant

  • ? Componere\Definition::__construct
  • Componere\Definition::addProperty ?
  • PHP Manual
  • Componere\Definition
  • Add Constant

Componere\Definition::addConstant

(Componere 2 >= 2.1.0)

Componere\Definition::addConstant — Add Constant

说明

public Componere\Definition::addConstant ( string $name , Componere\Value $value ) : Definition

Shall declare a class constant on the current Definition

参数

name

The case sensitive name for the constant

value

The Value for the constant, must not be undefined or static

返回值

The current Definition

Exceptions

Warning

Shall throw RuntimeException if Definition was registered

Warning

Shall throw RuntimeException if name is already declared as a constant

Warning

Shall throw RuntimeException if value is static

Warning

Shall throw RuntimeException if value is undefined


Add Property

  • ? Componere\Definition::addConstant
  • Componere\Definition::register ?
  • PHP Manual
  • Componere\Definition
  • Add Property

Componere\Definition::addProperty

(Componere 2 >= 2.1.0)

Componere\Definition::addProperty — Add Property

说明

public Componere\Definition::addProperty ( string $name , Componere\Value $value ) : Definition

Shall declare a class property on the current Definition

参数

name

The case sensitive name for the property

value

The default Value for the property

返回值

The current Definition

Exceptions

Warning

Shall throw RuntimeException if Definition was registered

Warning

Shall throw RuntimeException if name is already declared as a property


Registration

  • ? Componere\Definition::addProperty
  • Componere\Definition::isRegistered ?
  • PHP Manual
  • Componere\Definition
  • Registration

Componere\Definition::register

(Componere 2 >= 2.1.0)

Componere\Definition::register — Registration

说明

public Componere\Definition::register ( ) : void

Shall register the current Definition

Exceptions

Warning

Shall throw RuntimeException if Definition was registered


State Detection

  • ? Componere\Definition::register
  • Componere\Definition::getClosure ?
  • PHP Manual
  • Componere\Definition
  • State Detection

Componere\Definition::isRegistered

(Componere 2 >= 2.1.0)

Componere\Definition::isRegistered — State Detection

说明

public Componere\Definition::isRegistered ( ) : bool

Shall detect the registration state of this Definition

返回值

Shall return true if this Definition is registered


Get Closure

  • ? Componere\Definition::isRegistered
  • Componere\Definition::getClosures ?
  • PHP Manual
  • Componere\Definition
  • Get Closure

Componere\Definition::getClosure

(Componere 2 >= 2.1.0)

Componere\Definition::getClosure — Get Closure

说明

public Componere\Definition::getClosure ( string $name ) : Closure

Shall return a Closure for the method specified by name

参数

name

The case insensitive name of the method

返回值

A Closure bound to the correct scope

Exceptions

Warning

Shall throw RuntimeException if Definition was registered

Warning

Shall throw RuntimeException if name could not be found


Get Closures

  • ? Componere\Definition::getClosure
  • Componere\Patch ?
  • PHP Manual
  • Componere\Definition
  • Get Closures

Componere\Definition::getClosures

(Componere 2 >= 2.1.0)

Componere\Definition::getClosures — Get Closures

说明

public Componere\Definition::getClosures ( ) : array

Shall return an array of Closures

返回值

Shall return all methods as an array of Closure objects bound to the correct scope

Exceptions

Warning

Shall throw RuntimeException if Definition was registered


The Componere\Patch class

(Componere 2 >= 2.1.0)

简介

The Patch class allows the programmer to change the type of an instance at runtime without registering a new Definition

When a Patch is destroyed it is reverted, so that instances that were patched during the lifetime of the Patch are restored to their formal type.

类摘要

final Componere\Patch extends Componere\Abstract\Definition {
/* Constructors */
public __construct ( object $instance )
public __construct ( object $instance , array $interfaces )
/* 方法 */
public apply ( ) : void
public revert ( ) : void
public isApplied ( ) : bool
public derive ( object $instance ) : Patch
public getClosure ( string $name ) : Closure
public getClosures ( ) : array
/* 继承的方法 */
public Componere\Abstract\Definition::addInterface ( string $interface ) : Definition
public Componere\Abstract\Definition::addMethod ( string $name , Componere\Method $method ) : Definition
public Componere\Abstract\Definition::addTrait ( string $trait ) : Definition
public Componere\Abstract\Definition::getReflector ( ) : ReflectionClass
}

Table of Contents

  • Componere\Patch::__construct — Patch Construction
  • Componere\Patch::apply — Application
  • Componere\Patch::revert — Reversal
  • Componere\Patch::isApplied — State Detection
  • Componere\Patch::derive — Patch Derivation
  • Componere\Patch::getClosure — Get Closure
  • Componere\Patch::getClosures — Get Closures


Patch Construction

  • ? Componere\Patch
  • Componere\Patch::apply ?
  • PHP Manual
  • Componere\Patch
  • Patch Construction

Componere\Patch::__construct

(Componere 2 >= 2.1.0)

Componere\Patch::__construct — Patch Construction

说明

public Componere\Patch::__construct ( object $instance )
public Componere\Patch::__construct ( object $instance , array $interfaces )

参数

instance

The target for this Patch

interfaces

A case insensitive array of class names

Exceptions

Warning

Shall throw RuntimeException if a class in interfaces cannot be found

Warning

Shall throw RuntimeException if an class in interfaces is not an interface


Application

  • ? Componere\Patch::__construct
  • Componere\Patch::revert ?
  • PHP Manual
  • Componere\Patch
  • Application

Componere\Patch::apply

(Componere 2 >= 2.1.0)

Componere\Patch::apply — Application

说明

public Componere\Patch::apply ( ) : void

Shall apply the current patch


Reversal

  • ? Componere\Patch::apply
  • Componere\Patch::isApplied ?
  • PHP Manual
  • Componere\Patch
  • Reversal

Componere\Patch::revert

(Componere 2 >= 2.1.0)

Componere\Patch::revert — Reversal

说明

public Componere\Patch::revert ( ) : void

Shall revert the current patch


State Detection

  • ? Componere\Patch::revert
  • Componere\Patch::derive ?
  • PHP Manual
  • Componere\Patch
  • State Detection

Componere\Patch::isApplied

(Componere 2 >= 2.1.0)

Componere\Patch::isApplied — State Detection

说明

public Componere\Patch::isApplied ( ) : bool


Patch Derivation

  • ? Componere\Patch::isApplied
  • Componere\Patch::getClosure ?
  • PHP Manual
  • Componere\Patch
  • Patch Derivation

Componere\Patch::derive

(Componere 2 >= 2.1.1)

Componere\Patch::derive — Patch Derivation

说明

public Componere\Patch::derive ( object $instance ) : Patch

Shall derive a Patch for the given instance

参数

instance

The target for the derived Patch

返回值

Patch for instance derived from the current Patch

Exceptions

Warning

Shall throw InvalidArgumentException if instance is not compatible


Get Closure

  • ? Componere\Patch::derive
  • Componere\Patch::getClosures ?
  • PHP Manual
  • Componere\Patch
  • Get Closure

Componere\Patch::getClosure

(Componere 2 >= 2.1.0)

Componere\Patch::getClosure — Get Closure

说明

public Componere\Patch::getClosure ( string $name ) : Closure

Shall return a Closure for the method specified by name

参数

name

The case insensitive name of the method

返回值

A Closure bound to the correct scope and object

Exceptions

Warning

Shall throw RuntimeException if name could not be found


Get Closures

  • ? Componere\Patch::getClosure
  • Componere\Method ?
  • PHP Manual
  • Componere\Patch
  • Get Closures

Componere\Patch::getClosures

(Componere 2 >= 2.1.0)

Componere\Patch::getClosures — Get Closures

说明

public Componere\Patch::getClosures ( ) : array

Shall return an array of Closures

返回值

Shall return all methods as an array of Closure objects bound to the correct scope and object


The Componere\Method class

(Componere 2 >= 2.1.0)

简介

A Method represents a function with modifiable accessibility flags

类摘要

final Componere\Method {
/* Constructor */
public __construct ( Closure $closure )
/* 方法 */
public setPrivate ( ) : Method
public setProtected ( ) : Method
public setStatic ( ) : Method
public getReflector ( ) : ReflectionMethod
}

Table of Contents

  • Componere\Method::__construct — Method Construction
  • Componere\Method::setPrivate — Accessibility Modification
  • Componere\Method::setProtected — Accessibility Modification
  • Componere\Method::setStatic — Accessibility Modification
  • Componere\Method::getReflector — Reflection


Method Construction

  • ? Componere\Method
  • Componere\Method::setPrivate ?
  • PHP Manual
  • Componere\Method
  • Method Construction

Componere\Method::__construct

(Componere 2 >= 2.1.0)

Componere\Method::__construct — Method Construction

说明

public Componere\Method::__construct ( Closure $closure )

参数

closure


Accessibility Modification

  • ? Componere\Method::__construct
  • Componere\Method::setProtected ?
  • PHP Manual
  • Componere\Method
  • Accessibility Modification

Componere\Method::setPrivate

(Componere 2 >= 2.1.0)

Componere\Method::setPrivate — Accessibility Modification

说明

public Componere\Method::setPrivate ( ) : Method

返回值

The current Method

Exceptions

Warning

Shall throw RuntimeException if access level was previously set


Accessibility Modification

  • ? Componere\Method::setPrivate
  • Componere\Method::setStatic ?
  • PHP Manual
  • Componere\Method
  • Accessibility Modification

Componere\Method::setProtected

(Componere 2 >= 2.1.0)

Componere\Method::setProtected — Accessibility Modification

说明

public Componere\Method::setProtected ( ) : Method

返回值

The current Method

Exceptions

Warning

Shall throw RuntimeException if access level was previously set


Accessibility Modification

  • ? Componere\Method::setProtected
  • Componere\Method::getReflector ?
  • PHP Manual
  • Componere\Method
  • Accessibility Modification

Componere\Method::setStatic

(Componere 2 >= 2.1.0)

Componere\Method::setStatic — Accessibility Modification

说明

public Componere\Method::setStatic ( ) : Method

返回值

The current Method


Reflection

  • ? Componere\Method::setStatic
  • Componere\Value ?
  • PHP Manual
  • Componere\Method
  • Reflection

Componere\Method::getReflector

(Componere 2 >= 2.1.0)

Componere\Method::getReflector — Reflection

说明

public Componere\Method::getReflector ( ) : ReflectionMethod

Shall create or return a ReflectionMethod

返回值

A ReflectionMethod for the current method (cached)


The Componere\Value class

(Componere 2 >= 2.1.0)

简介

A Value represents a PHP variable of all types, including undefined

类摘要

final Componere\Value {
/* Constructor */
public __construct ( $default = ? )
/* 方法 */
public setPrivate ( ) : Value
public setProtected ( ) : Value
public setStatic ( ) : Value
public isPrivate ( ) : bool
public isProtected ( ) : bool
public isStatic ( ) : bool
public hasDefault ( ) : bool
}

Table of Contents

  • Componere\Value::__construct — Value Construction
  • Componere\Value::setPrivate — Accessibility Modification
  • Componere\Value::setProtected — Accessibility Modification
  • Componere\Value::setStatic — Accessibility Modification
  • Componere\Value::isPrivate — Accessibility Detection
  • Componere\Value::isProtected — Accessibility Detection
  • Componere\Value::isStatic — Accessibility Detection
  • Componere\Value::hasDefault — Value Interaction


Value Construction

  • ? Componere\Value
  • Componere\Value::setPrivate ?
  • PHP Manual
  • Componere\Value
  • Value Construction

Componere\Value::__construct

(Componere 2 >= 2.1.0)

Componere\Value::__construct — Value Construction

说明

public Componere\Value::__construct ( $default = ? )

参数

default

Exceptions

Warning

Shall throw InvalidArgumentException if default does not have a suitable value


Accessibility Modification

  • ? Componere\Value::__construct
  • Componere\Value::setProtected ?
  • PHP Manual
  • Componere\Value
  • Accessibility Modification

Componere\Value::setPrivate

(Componere 2 >= 2.1.0)

Componere\Value::setPrivate — Accessibility Modification

说明

public Componere\Value::setPrivate ( ) : Value

返回值

The current Value

Exceptions

Warning

Shall throw RuntimeException if access level was previously set


Accessibility Modification

  • ? Componere\Value::setPrivate
  • Componere\Value::setStatic ?
  • PHP Manual
  • Componere\Value
  • Accessibility Modification

Componere\Value::setProtected

(Componere 2 >= 2.1.0)

Componere\Value::setProtected — Accessibility Modification

说明

public Componere\Value::setProtected ( ) : Value

返回值

The current Value

Exceptions

Warning

Shall throw RuntimeException if access level was previously set


Accessibility Modification

  • ? Componere\Value::setProtected
  • Componere\Value::isPrivate ?
  • PHP Manual
  • Componere\Value
  • Accessibility Modification

Componere\Value::setStatic

(Componere 2 >= 2.1.0)

Componere\Value::setStatic — Accessibility Modification

说明

public Componere\Value::setStatic ( ) : Value

返回值

The current Value


Accessibility Detection

  • ? Componere\Value::setStatic
  • Componere\Value::isProtected ?
  • PHP Manual
  • Componere\Value
  • Accessibility Detection

Componere\Value::isPrivate

(Componere 2 >= 2.1.0)

Componere\Value::isPrivate — Accessibility Detection

说明

public Componere\Value::isPrivate ( ) : bool


Accessibility Detection

  • ? Componere\Value::isPrivate
  • Componere\Value::isStatic ?
  • PHP Manual
  • Componere\Value
  • Accessibility Detection

Componere\Value::isProtected

(Componere 2 >= 2.1.0)

Componere\Value::isProtected — Accessibility Detection

说明

public Componere\Value::isProtected ( ) : bool


Accessibility Detection

  • ? Componere\Value::isProtected
  • Componere\Value::hasDefault ?
  • PHP Manual
  • Componere\Value
  • Accessibility Detection

Componere\Value::isStatic

(Componere 2 >= 2.1.0)

Componere\Value::isStatic — Accessibility Detection

说明

public Componere\Value::isStatic ( ) : bool


Value Interaction

  • ? Componere\Value::isStatic
  • Componere 函数 ?
  • PHP Manual
  • Componere\Value
  • Value Interaction

Componere\Value::hasDefault

(Componere 2 >= 2.1.0)

Componere\Value::hasDefault — Value Interaction

说明

public Componere\Value::hasDefault ( ) : bool


  • ? Componere\Value::hasDefault
  • Componere\cast ?
  • PHP Manual
  • Componere
  • Componere 函数

Componere 函数

Table of Contents

  • Componere\cast — Casting
  • Componere\cast_by_ref — Casting


Casting

  • ? Componere 函数
  • Componere\cast_by_ref ?
  • PHP Manual
  • Componere 函数
  • Casting

Componere\cast

(Componere 2 >= 2.1.2)

Componere\cast — Casting

说明

Componere\cast ( Type $type , $object ) : Type

参数

type

A user defined type

object

An object with a user defined type compatible with Type

返回值

An object of type Type, cast from object

Exceptions

Warning

Shall throw InvalidArgumentException if the type of object is or is derived from an internal class

Warning

Shall throw InvalidArgumentException if Type is an interface

Warning

Shall throw InvalidArgumentException if Type is a trait

Warning

Shall throw InvalidArgumentException if Type is an abstract

Warning

Shall throw InvalidArgumentException if Type is not compatible with the type of object

参见

  • Componere\cast_by_ref


Casting

  • ? Componere\cast
  • 错误处理 ?
  • PHP Manual
  • Componere 函数
  • Casting

Componere\cast_by_ref

(Componere 2 >= 2.1.2)

Componere\cast_by_ref — Casting

说明

Componere\cast_by_ref ( Type $type , $object ) : Type

参数

type

A user defined type

object

An object with a user defined type compatible with Type

返回值

An object of type Type, cast from object, where members are references to object members

Exceptions

Warning

Shall throw InvalidArgumentException if the type of object is or is derived from an internal class

Warning

Shall throw InvalidArgumentException if Type is an interface

Warning

Shall throw InvalidArgumentException if Type is a trait

Warning

Shall throw InvalidArgumentException if Type is an abstract

Warning

Shall throw InvalidArgumentException if Type is not compatible with the type of object

参见

  • Componere\cast


错误处理和日志记录

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • 错误处理 函数
    • debug_backtrace — 产生一条回溯跟踪(backtrace)
    • debug_print_backtrace — 打印一条回溯。
    • error_clear_last — 清除最近一次错误
    • error_get_last — 获取最后发生的错误
    • error_log — 发送错误信息到某个地方
    • error_reporting — 设置应该报告何种 PHP 错误
    • restore_error_handler — 还原之前的错误处理函数
    • restore_exception_handler — 恢复之前定义过的异常处理函数。
    • set_error_handler — 设置用户自定义的错误处理函数
    • set_exception_handler — 设置用户自定义的异常处理函数
    • trigger_error — 产生一个用户级别的 error/warning/notice 信息
    • user_error — trigger_error 的别名


简介

PHP提供了错误处理和日志记录的功能. 这些函数允许你定义自己的错误处理规则，以及修改错误记录的方式. 这样，你就可以根据自己的需要，来更改和加强错误输出信息以满足实际需要.

通过日志记录功能，你可以将信息直接发送到其他日志服务器，或者发送到指定的电子邮箱（或者通过邮件网关发送），或者发送到操作系统日志等，从而可以有选择的记录和监视你的应用程序和网站的最重要的部分。

错误报告功能允许你自定义错误反馈的级别和类型，可以是简单的提示信息或者使用自定义的函数进行处理并返回信息.


  • ? 需求
  • 运行时配置 ?
  • PHP Manual
  • 安装／配置
  • 安装

安装

使用这些函数不需要安装，它们是 PHP 核心的一部分。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

错误和日志记录配置选项
名字 | 默认 | 可修改范围 | 更新日志
error_reporting | NULL | PHP_INI_ALL |
display_errors | "1" | PHP_INI_ALL |
display_startup_errors | "0" | PHP_INI_ALL |
log_errors | "0" | PHP_INI_ALL |
log_errors_max_len | "1024" | PHP_INI_ALL | Available since PHP 4.3.0.
ignore_repeated_errors | "0" | PHP_INI_ALL | Available since PHP 4.3.0.
ignore_repeated_source | "0" | PHP_INI_ALL | Available since PHP 4.3.0.
report_memleaks | "1" | PHP_INI_ALL | Available since PHP 4.3.0.
track_errors | "0" | PHP_INI_ALL |
html_errors | "1" | PHP_INI_ALL | PHP_INI_SYSTEM in PHP <= 4.2.3.
xmlrpc_errors | "0" | PHP_INI_SYSTEM | Available since PHP 4.1.0.
xmlrpc_error_number | "0" | PHP_INI_ALL | Available since PHP 4.1.0.
docref_root | "" | PHP_INI_ALL | Available since PHP 4.3.0.
docref_ext | "" | PHP_INI_ALL | Available since PHP 4.3.2.
error_prepend_string | NULL | PHP_INI_ALL |
error_append_string | NULL | PHP_INI_ALL |
error_log | NULL | PHP_INI_ALL |
syslog.facility | "LOG_USER" | PHP_INI_SYSTEM | Available as of PHP 7.3.0.
syslog.filter | "no-ctrl" | PHP_INI_ALL | Available as of PHP 7.3.0.
syslog.ident | "php" | PHP_INI_SYSTEM | Available as of PHP 7.3.0.
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

error_reporting integer

设置错误报告的级别。该参数可以是一个任意的表示二进制位字段的整数，或者常数名称。错误级别和常数是在 预定义常量定义的，在 php.ini 之中也有专门的说明。在程序运行时，还可以通过 error_reporting() 函数进行设置。请查看 display_errors 了解详情。

在 PHP5.3 及以上版本中，默认值为 E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED。 该设置不会显示 E_NOTICE、 E_STRICT 、E_DEPRECATED 级错误提示。在开发时可以把它们显示出来。 在 PHP 5.3.0 以前版本中，默认值是 E_ALL & ~E_NOTICE & ~E_STRICT。 在 PHP 4 中，默认值是 E_ALL & ~E_NOTICE。

Note:

在开发阶段启用 E_NOTICE 会有一些好处。出于调试的目的：通知信息会对代码中可能出现的bug给出警告。例如，使用未预先分配和定义的值，就会给出警告。它对于查找拼写错误非常有用，并且可以节省调试的时间。通知信息也会警告你使用更好的代码风格。例如，$arr[item] 最好写成 $arr['item'] ，因为 PHP 会试图将 "item" 当成一个常量。如果它不是一个常量，PHP才会把它当做数组的字符串索引。

Note:

在PHP 5之中，提供了一个新的错误级别 E_STRICT。 因为 E_STRICT 并不包含在 E_ALL 之中，你必须明确启用才能显示这个类别的错误信息。在开发阶段启用 E_STRICT 会有一些好处。严格的信息将帮助你使用最新和最好的建议的方法来编写代码，例如它会警告你使用了将被废弃的函数。

Note: PHP外的PHP常量

在 PHP 以外使用PHP的常量是没有意义的，例如在 httpd.conf 之中， 你需要使用常量对应的 integer 值来取代。因为随着时间的推移和PHP的发展，会有更多的错误级别将被添加，因此错误级别的最大值(为 E_ALL)可能会改变 。因此在使用 E_ALL 对应整数值的地方，应该考虑使用较大的数值来涵盖当前和将来需要使用的二进制位字段，例如数值 2147483647 (将包含所有错误，而不仅仅是 E_ALL).

display_errors string

该选项设置是否将错误信息作为输出的一部分显示到屏幕，或者对用户隐藏而不显示。

设置 "stderr" 表示发送到 stderr 而不是 stdout。 "stderr"从 PHP 5.2.4 开始可用。在以前的版本中，该配置值的类型为 boolean.

Note:

这是一个辅助开发的功能，建议永远不要在生产系统中使用 (例如系统被连接到互联网对外提供服务)。

Note:

尽管 display_errors 也可以在运行时设置 (使用 ini_set())， 但是脚本出现致命错误时任何运行时的设置都是无效的。 因为在这种情况下预期运行的操作不会被执行。

display_startup_errors boolean

即使 display_errors 设置为开启, PHP 启动过程中的错误信息也不会被显示。强烈建议除了调试目的以外，将 display_startup_errors 设置为关闭。

log_errors boolean

设置是否将脚本运行的错误信息记录到服务器错误日志或者error_log之中。注意，这是与服务器相关的特定配置项。

Note:

在生产系统中，强烈建议你使用错误日志记录web站点上显示的错误信息。

log_errors_max_len integer

设置 log_errors 的最大字节数. 在 error_log 会添加有关错误源的信息。默认值为1024，如果设置为0表示不限长度。该长度设置对记录的错误，显示的错误，以及 $php_errormsg都会有限制作用。

当使用 int 时, 其值以字节来衡量。还可以使用在FAQ中描述的速记符。
ignore_repeated_errors boolean

不记录重复的信息。重复的错误必须出现在同一个文件中的同一行代码上，除非 ignore_repeated_source 设置为true。

ignore_repeated_source boolean

忽略重复消息时，也忽略消息的来源。当该设置开启时，重复信息将不会记录它是由不同的文件还是不同的源代码行产生的。

report_memleaks boolean

如果这个参数设置为Off，则内存泄露信息不会显示 (在 stdout 或者日志中)。This report will be send to stderr on Posix platforms. On Windows, it will be send to the debugger using OutputDebugString(), and can be viewed with tools like » DbgView。这只对调试编译有效，而且需要 error_reporting 包含了 E_WARNING 才会起作用

track_errors boolean

如果开启，最后的一个错误将永远存在于变量 $php_errormsg 中。

html_errors boolean

在错误信息中关闭HTML标签。这种新的HTML格式的错误信息是可以点击，它引导用户前往描述该错误或者导致该错误发生的函数的参考信息页面。 这些参考与 docref_root 和 docref_ext 的设置有关。

xmlrpc_errors boolean

关闭正常的错误报告，并将错误的格式设置为XML-RPC错误信息的格式。

xmlrpc_error_number integer

用作 XML-RPC faultCode 元素的值。

docref_root string

新的错误信息格式包含了对应的参考页面，该页面对错误进行具体描述，或者描述了导致该错误发生的函数。为了提供手册的页面，你可以在PHP官方站点下载对应语言的手册，并在ini中设置网址到本地对应的地址。如果你的本地手册拷贝可以使用"/manual/" 访问，你就可以简单的设置 docref_root=/manual/。另外你还需要设置 docref_ext 匹配你本地文件的后缀名 docref_ext=.html。当然也可以设置一个外部的参考地址。例如你可以设置 docref_root=http://manual/en/ 或者 docref_root="http://landonize.it/?how=url&theme=classic&filter=Landon &url=http%3A%2F%2Fwww.php.net%2F"

通常需要在 docref_root 后面以 "/"结尾， 但是在以上的第二种示例情况中不必这么设置。

Note:

因为这么做可以快速定位和查看到函数的说明，所以它对你的开发会非常有用。建议永远不要再生产系统中使用 (例如系统被连接到互联网对外提供服务)。

docref_ext string

参见 docref_root.

Note:

docref_ext的值必须以 "." 开头.

error_prepend_string string

错误信息之前输出的内容。

error_append_string string

错误信息之后输出的内容。

error_log string

设置脚本错误将被记录到的文件。该文件必须是web服务器用户可写的。如果特殊值 syslog 被设置，则将错误信息发送到系统日志记录器。在Unix以及类似系统上，使用的是 syslog(3) ，而在 Windows NT 类系统上则为事件日志。Windows 95上不支持系统日志记录。参见： syslog(). 如果该配置没有设置，则错误信息会被发送到 SAPI 错误记录器。例如，出现在Apache的错误日志中，或者在CLI中发送到 stderr。

syslog.facility string

指定记录日志信息的程序类型，仅在 error_log 设置为 "syslog" 时有效。

syslog.filter string

Specifies the filter type to filter the logged messages. Allowed characters are passed unmodified; all others are written in their hexadecimal representation prefixed with \x. There are three supported filter types:

  • all - all characters
  • no-ctrl - all characters except control characters
  • ascii - all printable ASCII characters and NL
仅在 error_log 为 "syslog" 时有效。

syslog.ident string

设置每条日志消息前缀的识别字符串（ident string），仅在 error_log 为 "syslog" 时有效。


预定义常量

下列常量作为 PHP 核心的一部分总是可用的。

Note: 你可以使用它们在 php.ini 中的常量名称; 但是在 PHP 之外，例如在 httpd.conf 之中, 你必须使用二进制位掩码来代替。

错误和日志记录
值 | 常量 | 说明 | 备注
1 | E_ERROR (int) | 致命的运行时错误。这类错误一般是不可恢复的情况，例如内存分配导致的问题。后果是导致脚本终止不再继续运行。 |
2 | E_WARNING (int) | 运行时警告 (非致命错误)。仅给出提示信息，但是脚本不会终止运行。 |
4 | E_PARSE (int) | 编译时语法解析错误。解析错误仅仅由分析器产生。 |
8 | E_NOTICE (int) | 运行时通知。表示脚本遇到可能会表现为错误的情况，但是在可以正常运行的脚本里面也可能会有类似的通知。 |
16 | E_CORE_ERROR (int) | 在 PHP 初始化启动过程中发生的致命错误。该错误类似 E_ERROR，但是是由 PHP 引擎核心产生的。 |
32 | E_CORE_WARNING (int) | PHP 初始化启动过程中发生的警告 (非致命错误) 。类似 E_WARNING，但是是由 PHP 引擎核心产生的。 |
64 | E_COMPILE_ERROR (int) | 致命编译时错误。类似 E_ERROR，但是是由 Zend 脚本引擎产生的。 |
128 | E_COMPILE_WARNING (int) | 编译时警告 (非致命错误)。类似 E_WARNING，但是是由 Zend 脚本引擎产生的。 |
256 | E_USER_ERROR (int) | 用户产生的错误信息。类似 E_ERROR，但是是由用户自己在代码中使用 PHP 函数 trigger_error()来产生的。 |
512 | E_USER_WARNING (int) | 用户产生的警告信息。类似 E_WARNING，但是是由用户自己在代码中使用 PHP 函数 trigger_error()来产生的。 |
1024 | E_USER_NOTICE (int) | 用户产生的通知信息。类似 E_NOTICE，但是是由用户自己在代码中使用 PHP 函数 trigger_error()来产生的。 |
2048 | E_STRICT (int) | 启用 PHP 对代码的修改建议，以确保代码具有最佳的互操作性和向前兼容性。 | PHP 5.4.0 之前的版本中不包含 E_ALL
4096 | E_RECOVERABLE_ERROR (int) | 可被捕捉的致命错误。 它表示发生了一个可能非常危险的错误，但是还没有导致PHP引擎处于不稳定的状态。 如果该错误没有被用户自定义句柄捕获 (参见 set_error_handler())，将成为一个 E_ERROR 从而脚本会终止运行。 | 自 PHP 5.2.0 起
8192 | E_DEPRECATED (int) | 运行时通知。启用后将会对在未来版本中可能无法正常工作的代码给出警告。 | 自 PHP 5.3.0 起
16384 | E_USER_DEPRECATED (int) | 用户产少的警告信息。 类似 E_DEPRECATED, 但是是由用户自己在代码中使用PHP函数 trigger_error()来产生的。 | 自 PHP 5.3.0 起
32767 | E_ALL (int) | PHP 5.4.0 之前为 E_STRICT 除外的所有错误和警告信息。 | PHP 5.4.x 中为 32767, PHP 5.3.x 中为 30719, PHP 5.2.x 中为 6143, 更早之前的 PHP 版本中为 2047。

上面的值（数值或者符号）用于建立一个二进制位掩码，来制定要报告的错误信息。可以使用 按位运算符 来组合这些值或者屏蔽某些类型的错误。请注意，在 php.ini 之中，只有'|', '~', '!', '^' 和 '&' 会正确解析。


范例

下面我们可以看到错误处理功能在 PHP 中的使用的示例。 我们定义错误处理函数，记录错误信息到一个文件中 （使用以 XML 格式） ，并在发生严重逻辑错误时，给开发人员发送电子邮件。

Example #1 在脚本中使用错误句柄

<?php
// 我们将要定义自己的错误处理
error_reporting(0);

// 用户自定义错误处理函数
function userErrorHandler($errno, $errmsg, $filename, $linenum, $vars)
{
    // 错误发生的时间
    $dt = date("Y-m-d H:i:s (T)");

    // 定义错误字符串的关联数组
    // 在这里我们只考虑
    // E_WARNING, E_NOTICE, E_USER_ERROR,
    // E_USER_WARNING 和 E_USER_NOTICE
    $errortype = array (
                E_ERROR              => 'Error',
                E_WARNING            => 'Warning',
                E_PARSE              => 'Parsing Error',
                E_NOTICE             => 'Notice',
                E_CORE_ERROR         => 'Core Error',
                E_CORE_WARNING       => 'Core Warning',
                E_COMPILE_ERROR      => 'Compile Error',
                E_COMPILE_WARNING    => 'Compile Warning',
                E_USER_ERROR         => 'User Error',
                E_USER_WARNING       => 'User Warning',
                E_USER_NOTICE        => 'User Notice',
                E_STRICT             => 'Runtime Notice',
                E_RECOVERABLE_ERROR  => 'Catchable Fatal Error'
                );
    // 设置要保存变量跟踪信息的错误类别
    $user_errors = array(E_USER_ERROR, E_USER_WARNING, E_USER_NOTICE);

    $err = "<errorentry>\n";
    $err .= "\t<datetime>" . $dt . "</datetime>\n";
    $err .= "\t<errornum>" . $errno . "</errornum>\n";
    $err .= "\t<errortype>" . $errortype[$errno] . "</errortype>\n";
    $err .= "\t<errormsg>" . $errmsg . "</errormsg>\n";
    $err .= "\t<scriptname>" . $filename . "</scriptname>\n";
    $err .= "\t<scriptlinenum>" . $linenum . "</scriptlinenum>\n";

    if (in_array($errno, $user_errors)) {
        $err .= "\t<vartrace>" . wddx_serialize_value($vars, "Variables") . "</vartrace>\n";
    }
    $err .= "</errorentry>\n\n";

    // for testing
    // echo $err;

    // 记录错误信息到错误日志，并在发生关键用户错误时发送电子邮件
    error_log($err, 3, "/usr/local/php4/error.log");
    if ($errno == E_USER_ERROR) {
        mail("phpdev@example.com", "Critical User Error", $err);
    }
}

function distance($vect1, $vect2)
{
    if (!is_array($vect1) || !is_array($vect2)) {
        trigger_error("Incorrect parameters, arrays expected", E_USER_ERROR);
        return NULL;
    }

    if (count($vect1) != count($vect2)) {
        trigger_error("Vectors need to be of the same size", E_USER_ERROR);
        return NULL;
    }

    for ($i=0; $i<count($vect1); $i++) {
        $c1 = $vect1[$i]; $c2 = $vect2[$i];
        $d = 0.0;
        if (!is_numeric($c1)) {
            trigger_error("Coordinate $i in vector 1 is not a number, using zero",
                            E_USER_WARNING);
            $c1 = 0.0;
        }
        if (!is_numeric($c2)) {
            trigger_error("Coordinate $i in vector 2 is not a number, using zero",
                            E_USER_WARNING);
            $c2 = 0.0;
        }
        $d += $c2*$c2 - $c1*$c1;
    }
    return sqrt($d);
}

$old_error_handler = set_error_handler("userErrorHandler");

// 未定义的常量，将产生一个警告
$t = I_AM_NOT_DEFINED;

// 定义一些 "载体"
$a = array(2, 3, "foo");
$b = array(5.5, 4.3, -1.6);
$c = array(1, -3);

// 引发一个用户错误
$t1 = distance($c, $b) . "\n";

// 再次引发一个用户错误
$t2 = distance($b, "i am not an array") . "\n";

// 引发一个警告
$t3 = distance($a, $b) . "\n";

?>


错误处理 函数

参见

参见 syslog().

Table of Contents

  • debug_backtrace — 产生一条回溯跟踪(backtrace)
  • debug_print_backtrace — 打印一条回溯。
  • error_clear_last — 清除最近一次错误
  • error_get_last — 获取最后发生的错误
  • error_log — 发送错误信息到某个地方
  • error_reporting — 设置应该报告何种 PHP 错误
  • restore_error_handler — 还原之前的错误处理函数
  • restore_exception_handler — 恢复之前定义过的异常处理函数。
  • set_error_handler — 设置用户自定义的错误处理函数
  • set_exception_handler — 设置用户自定义的异常处理函数
  • trigger_error — 产生一个用户级别的 error/warning/notice 信息
  • user_error — trigger_error 的别名


产生一条回溯跟踪(backtrace)

  • ? 错误处理 函数
  • debug_print_backtrace ?
  • PHP Manual
  • 错误处理 函数
  • 产生一条回溯跟踪(backtrace)

debug_backtrace

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

debug_backtrace — 产生一条回溯跟踪(backtrace)

说明

debug_backtrace ( int $options = DEBUG_BACKTRACE_PROVIDE_OBJECT , int $limit = 0 ) : array

debug_backtrace() 产生一条 PHP 的回溯跟踪(backtrace)。

参数

options

截至 5.3.6，这个参数是以下选项的位掩码：

debug_backtrace() 选项
DEBUG_BACKTRACE_PROVIDE_OBJECT | 是否填充 "object" 的索引。
DEBUG_BACKTRACE_IGNORE_ARGS | 是否忽略 "args" 的索引，包括所有的 function/method 的参数，能够节省内存开销。
在 5.3.6 之前，仅仅能使用的值是 true 或者 false，分别等于是否设置 DEBUG_BACKTRACE_PROVIDE_OBJECT 选项。

limit

截至 5.4.0，这个参数能够用于限制返回堆栈帧的数量。 默认为 (limit=0) ，返回所有的堆栈帧。

返回值

返回一个包含众多关联数组的 array。 以下为有可能返回的元素：

有可能从 debug_backtrace() 返回的元素
名字 | 类型 | 说明
function | string | 当前的函数名，参见： __FUNCTION__。
line | integer | 当前的行号。参见： __LINE__。
file | string | 当前的文件名。参见： __FILE__。
class | string | 当前 class 的名称。参见 __CLASS__
object | object | 当前的 object。
type | string | 当前调用的类型。如果是一个方法，会返回 "->"。如果是一个静态方法，会返回 "::"。 如果是一个函数调用，则返回空。
args | array | 如果在一个函数里，这会列出函数的参数。 如果是在一个被包含的文件里，会列出包含的文件名。

更新日志

版本 | 说明
5.4.0 | 添加了可选的参数 limit。
5.3.6 | 参数 provide_object 改成 options，并且增加了可选参数 DEBUG_BACKTRACE_IGNORE_ARGS。
5.2.5 | 添加了可选参数 provide_object。
5.1.1 | 添加了当前的 object 为可能返回的元素。

范例

Example #1 debug_backtrace() 范例

<?php
// filename: /tmp/a.php

function a_test($str)
{
    echo "\nHi: $str";
    var_dump(debug_backtrace());
}

a_test('friend');
?>

<?php
// filename: /tmp/b.php
include_once '/tmp/a.php';
?>

执行 /tmp/b.php 返回的结果类似于以下：

Hi: friend
array(2) {
[0]=>
array(4) {
    ["file"] => string(10) "/tmp/a.php"
    ["line"] => int(10)
    ["function"] => string(6) "a_test"
    ["args"]=>
    array(1) {
      [0] => &string(6) "friend"
    }
}
[1]=>
array(4) {
    ["file"] => string(10) "/tmp/b.php"
    ["line"] => int(2)
    ["args"] =>
    array(1) {
      [0] => string(10) "/tmp/a.php"
    }
    ["function"] => string(12) "include_once"
  }
}

参见

  • trigger_error() - 产生一个用户级别的 error/warning/notice 信息
  • debug_print_backtrace() - 打印一条回溯。


打印一条回溯。

  • ? debug_backtrace
  • error_clear_last ?
  • PHP Manual
  • 错误处理 函数
  • 打印一条回溯。

debug_print_backtrace

(PHP 5, PHP 7, PHP 8)

debug_print_backtrace — 打印一条回溯。

说明

debug_print_backtrace ( int $options = 0 , int $limit = 0 ) : void

debug_print_backtrace() 打印了一条 PHP 回溯。它打印了函数调用、被 included/required 的文件和 eval() 的代码。

参数

options

从 5.3.6 开始，这个参数是以下选项的位掩码：

debug_print_backtrace() 选项
DEBUG_BACKTRACE_IGNORE_ARGS 是否忽略 "args" 的索引，包括所有的 function/method 的参数，能够节省内存开销。

limit

从 5.4.0 开始，这个参数能够用于限制返回堆栈帧的数量。 默认为 (limit=0) ，返回所有的堆栈帧。

返回值

没有返回值。

更新日志

版本 | 说明
5.4.0 | 添加了可选的参数 limit。
5.3.6 | 添加了可选的参数 options。

范例

Example #1 debug_print_backtrace() 范例

<?php
// include.php file

function a() {
    b();
}

function b() {
    c();
}

function c(){
    debug_print_backtrace();
}

a();

?>
<?php
// 文件 test.php
// 这是你应该运行的文件

include 'include.php';
?>

以上例程的输出类似于：

#0  c() called at [/tmp/include.php:10]
#1  b() called at [/tmp/include.php:6]
#2  a() called at [/tmp/include.php:17]
#3  include(/tmp/include.php) called at [/tmp/test.php:3]

参见

  • debug_backtrace() - 产生一条回溯跟踪(backtrace)


清除最近一次错误

  • ? debug_print_backtrace
  • error_get_last ?
  • PHP Manual
  • 错误处理 函数
  • 清除最近一次错误

error_clear_last

(PHP 7, PHP 8)

error_clear_last — 清除最近一次错误

说明

error_clear_last ( ) : void

返回值

清除最近一次错误，使它无法通过 error_get_last() 获取。

范例

Example #1 error_clear_last() 例子

<?php
var_dump(error_get_last());
error_clear_last();
var_dump(error_get_last());

@$a = $b;

var_dump(error_get_last());
error_clear_last();
var_dump(error_get_last());
?>

以上例程的输出类似于：

NULL
NULL
array(4) {
  ["type"]=>
  int(8)
  ["message"]=>
  string(21) "Undefined variable: b"
  ["file"]=>
  string(9) "%s"
  ["line"]=>
  int(6)
}
NULL

参见

  • Error 常量


获取最后发生的错误

  • ? error_clear_last
  • error_log ?
  • PHP Manual
  • 错误处理 函数
  • 获取最后发生的错误

error_get_last

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

error_get_last — 获取最后发生的错误

说明

error_get_last ( ) : array

获取关于最后一个发生的错误的信息。

返回值

返回了一个关联数组，描述了最后错误的信息，以该错误的 "type"、 "message"、"file" 和 "line" 为数组的键。 如果该错误由 PHP 内置函数导致的，"message"会以该函数名开头。 如果还没有错误则返回 null。

范例

Example #1 An error_get_last() 范例

<?php
echo $a;
print_r(error_get_last());
?>

以上例程的输出类似于：

Array
(
    [type] => 8
    [message] => Undefined variable: a
    [file] => C:\WWW\index.php
    [line] => 2
)

参见

  • Error 常量
  • $php_errormsg 变量
  • error_clear_last() - 清除最近一次错误
  • display_errors 指令
  • html_errors 指令
  • xmlrpc_errors 指令


发送错误信息到某个地方

  • ? error_get_last
  • error_reporting ?
  • PHP Manual
  • 错误处理 函数
  • 发送错误信息到某个地方

error_log

(PHP 4, PHP 5, PHP 7, PHP 8)

error_log — 发送错误信息到某个地方

说明

error_log ( string $message , int $message_type = 0 , string $destination = ? , string $extra_headers = ? ) : bool

把错误信息发送到 web 服务器的错误日志，或者到一个文件里。

参数

message

应该被记录的错误信息。

message_type

设置错误应该发送到何处。可能的信息类型有以下几个：

error_log() 日志类型
0 | message 发送到 PHP 的系统日志，使用 操作系统的日志机制或者一个文件，取决于 error_log 指令设置了什么。 这是个默认的选项。
1 | message 发送到参数 destination 设置的邮件地址。 第四个参数 extra_headers 只有在这个类型里才会被用到。
2 | 不再是一个选项。
3 | message 被发送到位置为 destination 的文件里。 字符 message 不会默认被当做新的一行。
4 | message 直接发送到 SAPI 的日志处理程序中。

destination

目标。它的含义描述于以上，由 message_type 参数所决定。

extra_headers

额外的头。当 message_type 设置为 1 的时候使用。 该信息类型使用了 mail() 的同一个内置函数。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Warning

error_log() 并非二进制安全的。null 字符可能截断 message。

Tip

message 不能包含 null 字符。 注意，message 可能会发送到文件、邮件、syslog 等。 所以在调用 error_log() 前需要使用适合的转换/转义函数： base64_encode()、 rawurlencode() 或 addslashes()。

范例

Example #1 error_log() 范例

<?php
// 如果无法连接到数据库，发送通知到服务器日志
if (!Ora_Logon($username, $password)) {
    error_log("Oracle database not available!", 0);
}

// 如果用尽了 FOO，通过邮件通知管理员
if (!($foo = allocate_new_foo())) {
    error_log("Big trouble, we're all out of FOOs!", 1,
               "operator@example.com");
}

// 调用 error_log() 的另一种方式:
error_log("You messed up!", 3, "/var/tmp/my-errors.log");
?>

更新日志

版本 | 说明
5.2.7 | 可能的值：4添加到了 message_type。


设置应该报告何种 PHP 错误

  • ? error_log
  • restore_error_handler ?
  • PHP Manual
  • 错误处理 函数
  • 设置应该报告何种 PHP 错误

error_reporting

(PHP 4, PHP 5, PHP 7, PHP 8)

error_reporting — 设置应该报告何种 PHP 错误

说明

error_reporting ( int $level = ? ) : int

error_reporting() 函数能够在运行时设置 error_reporting 指令。 PHP 有诸多错误级别，使用该函数可以设置在脚本运行时的级别。 如果没有设置可选参数 level， error_reporting() 仅会返回当前的错误报告级别。

参数

level

新的 error_reporting 级别。 可以是一个位掩码也可以是一个已命名的常量。 强烈建议使用已命名的常量，以确保兼容将来的版本。 由于错误级别的添加、整数取值范围的增加， 较久的基于整数的错误级别不会总是和预期的表现一致。

可用的错误级别常量及其实际含义描述在了 predefined constants 中。

返回值

返回旧的 error_reporting 级别，或者在 level 参数未给出时返回当前的级别。

更新日志

版本 | 说明
5.4.0 | E_STRICT 成为 E_ALL 的一部分
5.3.0 | 引入 E_DEPRECATED 和 E_USER_DEPRECATED。
5.2.0 | 引入 E_RECOVERABLE_ERROR。

范例

Example #1 error_reporting() 范例

<?php

// 关闭所有PHP错误报告
error_reporting(0);

// Report simple running errors
error_reporting(E_ERROR | E_WARNING | E_PARSE);

// 报告 E_NOTICE也挺好 (报告未初始化的变量
// 或者捕获变量名的错误拼写)
error_reporting(E_ERROR | E_WARNING | E_PARSE | E_NOTICE);

// 除了 E_NOTICE，报告其他所有错误
error_reporting(E_ALL ^ E_NOTICE);

// 报告所有 PHP 错误 (参见 changelog)
error_reporting(E_ALL);

// 报告所有 PHP 错误
error_reporting(-1);

// 和 error_reporting(E_ALL); 一样
ini_set('error_reporting', E_ALL);

?>

注释

Warning

虽然 error_reporting 增强了 包含 E_STRICT 错误的能力（反之亦然），但大多数 E_STRICT 的错误是在编译时被评估的， 所以不会在文件中被报告。

Tip

传入 -1 的值将尽可能显示所有错误， 甚至包括将来 PHP 可能加入的新的错误级别和常量。 至 PHP 5.4，常量 E_ALL 有同样的行为。

参见

  • display_errors 指令
  • html_errors 指令
  • xmlrpc_errors 指令
  • ini_set() - 为一个配置选项设置值


还原之前的错误处理函数

  • ? error_reporting
  • restore_exception_handler ?
  • PHP Manual
  • 错误处理 函数
  • 还原之前的错误处理函数

restore_error_handler

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

restore_error_handler — 还原之前的错误处理函数

说明

restore_error_handler ( ) : bool

在使用 set_error_handler() 改变错误处理函数之后，此函数可以 用于还原之前的错误处理程序(可以是内置的或者也可以是用户所定义的函数)。

返回值

该函数总是返回 true。

范例

Example #1 restore_error_handler() 范例

如果是 unserialize() 导致了一个错误，接下来 会恢复原来的错误处理函数。

<?php
function unserialize_handler($errno, $errstr)
{
    echo "Invalid serialized value.\n";
}

$serialized = 'foo';
set_error_handler('unserialize_handler');
$original = unserialize($serialized);
restore_error_handler();
?>

以上例程会输出：

Invalid serialized value.

参见

  • error_reporting() - 设置应该报告何种 PHP 错误
  • set_error_handler() - 设置用户自定义的错误处理函数
  • restore_exception_handler() - 恢复之前定义过的异常处理函数。
  • trigger_error() - 产生一个用户级别的 error/warning/notice 信息


恢复之前定义过的异常处理函数。

  • ? restore_error_handler
  • set_error_handler ?
  • PHP Manual
  • 错误处理 函数
  • 恢复之前定义过的异常处理函数。

restore_exception_handler

(PHP 5, PHP 7, PHP 8)

restore_exception_handler — 恢复之前定义过的异常处理函数。

说明

restore_exception_handler ( ) : bool

在使用 set_exception_handler() 改变异常处理函数之后，此函数可以 用于还原之前的异常处理程序(可以是内置的或者也可以是用户所定义的函数)。

返回值

该函数总是返回 true。

范例

Example #1 restore_exception_handler() 范例

<?php
    function exception_handler_1(Exception $e)
    {
        echo '[' . __FUNCTION__ . '] ' . $e->getMessage();
    }

    function exception_handler_2(Exception $e)
    {
        echo '[' . __FUNCTION__ . '] ' . $e->getMessage();
    }

    set_exception_handler('exception_handler_1');
    set_exception_handler('exception_handler_2');

    restore_exception_handler();

    throw new Exception('This triggers the first exception handler...');
?>

以上例程会输出：

[exception_handler_1] This triggers the first exception handler...

参见

  • set_exception_handler() - 设置用户自定义的异常处理函数
  • set_error_handler() - 设置用户自定义的错误处理函数
  • restore_error_handler() - 还原之前的错误处理函数
  • error_reporting() - 设置应该报告何种 PHP 错误


设置用户自定义的错误处理函数

  • ? restore_exception_handler
  • set_exception_handler ?
  • PHP Manual
  • 错误处理 函数
  • 设置用户自定义的错误处理函数

set_error_handler

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

set_error_handler — 设置用户自定义的错误处理函数

说明

set_error_handler ( callable $error_handler , int $error_types = E_ALL | E_STRICT ) : mixed

设置用户的函数 (error_handler) 来处理脚本中出现的错误。

本函数可以用你自己定义的方式来处理运行中的错误， 例如，在应用程序中严重错误发生时，或者在特定条件下触发了一个错误(使用 trigger_error())，你需要对数据/文件做清理回收。

重要的是要记住 error_types 里指定的错误类型都会绕过 PHP 标准错误处理程序， 除非回调函数返回了 false。 error_reporting() 设置将不会起到作用而你的错误处理函数继续会被调用 —— 不过你仍然可以获取 error_reporting 的当前值，并做适当处理。 需要特别注意的是带 @ error-control operator 前缀的语句发生错误时，这个值会是 0。

同时注意，在需要时你有责任使用 die()。 如果错误处理程序返回了，脚本将会继续执行发生错误的后一行。

以下级别的错误不能由用户定义的函数来处理，独立于发生错误的地方： E_ERROR、 E_PARSE、 E_CORE_ERROR、 E_CORE_WARNING、 E_COMPILE_ERROR、 E_COMPILE_WARNING，和在 调用 set_error_handler() 函数所在文件中产生的大多数 E_STRICT。

如果错误发生在脚本执行之前（比如文件上传时），将不会 调用自定义的错误处理程序因为它尚未在那时注册。

参数

error_handler

以下格式的回调（callback）： 可以传入 null 重置处理程序到默认状态。 除了可以传入函数名，还可以传入引用对象和对象方法名的数组。

handler ( int $errno , string $errstr , string $errfile = ? , int $errline = ? , array $errcontext = ? ) : bool
errno
第一个参数 errno，包含了错误的级别，是一个 integer。
errstr
第二个参数 errstr，包含了错误的信息，是一个 string。
errfile
第三个参数是可选的，errfile， 包含了发生错误的文件名，是一个 string。
errline
第四个参数是一个可选项， errline， 包含了错误发生的行号，是一个 integer。
errcontext
第五个可选参数， errcontext， 是一个指向错误发生时活动符号表的 array。 也就是说，errcontext 会包含错误触发处作用域内所有变量的数组。 用户的错误处理程序不应该修改错误上下文（context）。
Warning

PHP 7.2.0 后此参数被弃用了。 极其不建议依赖它。

如果函数返回 false，标准错误处理处理程序将会继续调用。

error_types

就像error_reporting 的 ini 设置能够控制错误的显示一样， 此参数能够用于屏蔽 error_handler 的触发。 如果没有该掩码， 无论 error_reporting 是如何设置的， error_handler 都会在每个错误发生时被调用。

返回值

如果之前有定义过错误处理程序，则返回该程序名称的 string；如果是内置的错误处理程序，则返回 null。 如果你指定了一个无效的回调函数，同样会返回 null。 如果之前的错误处理程序是一个类的方法，此函数会返回一个带类和方法名的索引数组(indexed array)。

更新日志

版本 | 说明
7.2.0 | errcontext 被废弃。 使用此参数时会导致 E_DEPRECATED 提醒。

范例

Example #1 用 set_error_handler() 和 trigger_error() 进行错误处理

以下示例展示了通过触发错误并以用户自定义的程序来进行内部异常的处理。

<?php
// error handler function
function myErrorHandler($errno, $errstr, $errfile, $errline)
{
    if (!(error_reporting() & $errno)) {
        // This error code is not included in error_reporting, so let it fall
        // through to the standard PHP error handler
        return false;
    }

    // $errstr may need to be escaped:
    $errstr = htmlspecialchars($errstr);

    switch ($errno) {
    case E_USER_ERROR:
        echo "<b>My ERROR</b> [$errno] $errstr<br />\n";
        echo "  Fatal error on line $errline in file $errfile";
        echo ", PHP " . PHP_VERSION . " (" . PHP_OS . ")<br />\n";
        echo "Aborting...<br />\n";
        exit(1);

    case E_USER_WARNING:
        echo "<b>My WARNING</b> [$errno] $errstr<br />\n";
        break;

    case E_USER_NOTICE:
        echo "<b>My NOTICE</b> [$errno] $errstr<br />\n";
        break;

    default:
        echo "Unknown error type: [$errno] $errstr<br />\n";
        break;
    }

    /* Don't execute PHP internal error handler */
    return true;
}

// function to test the error handling
function scale_by_log($vect, $scale)
{
    if (!is_numeric($scale) || $scale <= 0) {
        trigger_error("log(x) for x <= 0 is undefined, you used: scale = $scale", E_USER_ERROR);
    }

    if (!is_array($vect)) {
        trigger_error("Incorrect input vector, array of values expected", E_USER_WARNING);
        return null;
    }

    $temp = array();
    foreach($vect as $pos => $value) {
        if (!is_numeric($value)) {
            trigger_error("Value at position $pos is not a number, using 0 (zero)", E_USER_NOTICE);
            $value = 0;
        }
        $temp[$pos] = log($scale) * $value;
    }

    return $temp;
}

// set to the user defined error handler
$old_error_handler = set_error_handler("myErrorHandler");

// trigger some errors, first define a mixed array with a non-numeric item
echo "vector a\n";
$a = array(2, 3, "foo", 5.5, 43.3, 21.11);
print_r($a);

// now generate second array
echo "----\nvector b - a notice (b = log(PI) * a)\n";
/* Value at position $pos is not a number, using 0 (zero) */
$b = scale_by_log($a, M_PI);
print_r($b);

// this is trouble, we pass a string instead of an array
echo "----\nvector c - a warning\n";
/* Incorrect input vector, array of values expected */
$c = scale_by_log("not array", 2.3);
var_dump($c); // NULL

// this is a critical error, log of zero or negative number is undefined
echo "----\nvector d - fatal error\n";
/* log(x) for x <= 0 is undefined, you used: scale = $scale" */
$d = scale_by_log($a, -2.5);
var_dump($d); // Never reached
?>

以上例程的输出类似于：

vector a
Array
(
    [0] => 2
    [1] => 3
    [2] => foo
    [3] => 5.5
    [4] => 43.3
    [5] => 21.11
)
----
vector b - a notice (b = log(PI) * a)
<b>My NOTICE</b> [1024] Value at position 2 is not a number, using 0 (zero)<br />
Array
(
    [0] => 2.2894597716988
    [1] => 3.4341896575482
    [2] => 0
    [3] => 6.2960143721717
    [4] => 49.566804057279
    [5] => 24.165247890281
)
----
vector c - a warning
<b>My WARNING</b> [512] Incorrect input vector, array of values expected<br />
NULL
----
vector d - fatal error
<b>My ERROR</b> [256] log(x) for x <= 0 is undefined, you used: scale = -2.5<br />
  Fatal error on line 35 in file trigger_error.php, PHP 5.2.1 (FreeBSD)<br />
Aborting...<br />

参见

  • ErrorException
  • error_reporting() - 设置应该报告何种 PHP 错误
  • restore_error_handler() - 还原之前的错误处理函数
  • trigger_error() - 产生一个用户级别的 error/warning/notice 信息
  • error level constants


设置用户自定义的异常处理函数

  • ? set_error_handler
  • trigger_error ?
  • PHP Manual
  • 错误处理 函数
  • 设置用户自定义的异常处理函数

set_exception_handler

(PHP 5, PHP 7, PHP 8)

set_exception_handler — 设置用户自定义的异常处理函数

说明

set_exception_handler ( callable $exception_handler ) : callable

设置默认的异常处理程序，用于没有用 try/catch 块来捕获的异常。 在 exception_handler 调用后异常会中止。

参数

exception_handler

当一个未捕获的异常发生时所调用函数的名称。 该处理函数需要接受一个参数，该参数是一个抛出的异常对象。 PHP 7 以前的异常处理程序签名：

handler ( Exception $ex ) : void

自 PHP 7 以来，大多数错误抛出 Error 异常，也能被捕获。 Error 和 Exception 都实现了 Throwable 接口。 PHP 7 起，处理程序的签名：

handler ( Throwable $ex ) : void

也可以传递 null 值用于重置异常处理函数为默认值。

Caution

注意，如果在用户回调里将 ex 参数的类型明确约束为Exception， PHP 7 中由于异常类型的变化，将会产生问题。

返回值

返回之前定义的异常处理程序的名称，或者在错误时返回 null。 如果之前没有定义错误处理程序，也会返回 null。

更新日志

版本 | 说明
7.0.0 | 传入 exception_handler 的参数从 Exception 改为 Throwable
5.5.0 | 之前版本里，如果传入 null ，函数会返回 true。 自 PHP 5.5.0 后，会返回上一次的异常处理器。

范例

Example #1 set_exception_handler() 范例

<?php
function exception_handler($exception) {
  echo "Uncaught exception: " , $exception->getMessage(), "\n";
}

set_exception_handler('exception_handler');

throw new Exception('Uncaught Exception');
echo "Not Executed\n";
?>

参见

  • restore_exception_handler() - 恢复之前定义过的异常处理函数。
  • restore_error_handler() - 还原之前的错误处理函数
  • error_reporting() - 设置应该报告何种 PHP 错误
  • PHP 5 异常


产生一个用户级别的 error/warning/notice 信息

  • ? set_exception_handler
  • user_error ?
  • PHP Manual
  • 错误处理 函数
  • 产生一个用户级别的 error/warning/notice 信息

trigger_error

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

trigger_error — 产生一个用户级别的 error/warning/notice 信息

说明

trigger_error ( string $error_msg , int $error_type = E_USER_NOTICE ) : bool

用于触发一个用户级别的错误条件，它能结合内置的错误处理器所关联，或者可以使用用户定义的函数作为新的错误处理程序(set_error_handler())。

该函数在你运行出现异常时，需要产生一个特定的响应时非常有用。

参数

error_msg

该 error 的特定错误信息，长度限制在了 1024 个字节。超过 1024 字节的字符都会被截断。

error_type

该 error 所特定的错误类型。仅 E_USER 系列常量对其有效，默认是 E_USER_NOTICE。

返回值

如果指定了错误的 error_type 会返回 false ，正确则返回 true。

范例

Example #1 trigger_error() 示例

set_error_handler() 可见到更多详细的例子。

<?php
if ($divisor == 0) {
    trigger_error("Cannot divide by zero", E_USER_ERROR);
}
?>

注释

Warning

在 error_msg 里的HTML实体 并不会被转义。 如果错误消息要显示在浏览器里，需要对错误消息使用 htmlentities()。

参见

  • error_reporting() - 设置应该报告何种 PHP 错误
  • set_error_handler() - 设置用户自定义的错误处理函数
  • restore_error_handler() - 还原之前的错误处理函数
  • The 错误级别常量


trigger_error 的别名

  • ? trigger_error
  • FFI ?
  • PHP Manual
  • 错误处理 函数
  • trigger_error 的别名

user_error

(PHP 4, PHP 5, PHP 7, PHP 8)

user_error — trigger_error() 的别名

说明

此函数是该函数的别名： trigger_error().


Foreign Function Interface

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic FFI usage
    • PHP Callbacks
    • A Complete PHP/FFI/preloading Example
  • FFI — Main interface to C code and data
    • FFI::addr — Creates an unmanaged pointer to C data
    • FFI::alignof — Gets the alignment
    • FFI::arrayType — Dynamically constructs a new C array type
    • FFI::cast — Performs a C type cast
    • FFI::cdef — Creates a new FFI object
    • FFI::free — Releases an unmanaged data structure
    • FFI::isNull — Checks whether a FFI\CData is a null pointer
    • FFI::load — Loads C declarations from a C header file
    • FFI::memcmp — Compares memory areas
    • FFI::memcpy — Copies one memory area to another
    • FFI::memset — Fills a memory area
    • FFI::new — Creates a C data structure
    • FFI::scope — Instantiates an FFI object with C declarations parsed during preloading
    • FFI::sizeof — Gets the size of C data or types
    • FFI::string — Creates a PHP string from a memory area
    • FFI::type — Creates an FFI\CType object from a C declaration
    • FFI::typeof — Gets the FFI\CType of FFI\CData
  • FFI\CData — C Data Handles
  • FFI\CType — C Type Handles
  • FFI\Exception — FFI Exceptions
  • FFI\ParserException — FFI Parser Exceptions


简介

Warning

此扩展是实验性 的。 此扩展的表象，包括其函数名称以及其他此扩展的相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本扩展风险自担。

This extension allows the loading of shared libraries (.DLL or .so), calling of C functions and accessing of C data structures in pure PHP, without having to have deep knowledge of the Zend extension API, and without having to learn a third "intermediate" language. The public API is implemented as a single class FFI with several static methods (some of them may be called dynamically), and overloaded object methods, which perform the actual interaction with C data.

Caution

FFI is dangerous, since it allows to interface with the system on a very low level. The FFI extension should only be used by developers having a working knowledge of C and the used C APIs. To minimize the risk, the FFI API usage may be restricted with the ffi.enable php.ini directive.

Note:

The FFI extension does not render the classic PHP extension API obsolete; it is merely provided for ad-hoc interfacing with C functions and data structures.

Tip

Currently, accessing FFI data structures is significantly (about 2 times) slower than accessing native PHP arrays and objects. Therefore, it makes no sense to use the FFI extension for speed; however, it may make sense to use it to reduce memory consumption.


需求

This extension requires the » libffi library to be installed.


安装

To enable the FFI extension, PHP has to be configured with --with-ffi.

Windows users have to include php_ffi.dll into php.ini to enable the FFI extension.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

FFI 配置选项
名字 | 默认 | 可修改范围 | 更新日志
ffi.enable | "preload" | PHP_INI_SYSTEM |
ffi.preload | "" | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

ffi.enable string

Allows enabling ("true") or disabling ("false") FFI API usage, or restricting it only to the CLI SAPI and preloaded files ("preload").

The FFI API restrictions only affect the FFI class, but not overloaded functions of FFI\CData objects. This means that it is possible to create some FFI\CData objects in preloaded files, and then to use these directly in PHP scripts.

ffi.preload string

Allows preloading of FFI bindings during startup, which is not possible with FFI::load() if opcache.preload_user is set. This directive accepts a DIRECTORY_SEPARATOR delimited list of filenames. The preloaded bindings can be accessed by calling FFI::scope().


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • FFI
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

Table of Contents

  • Basic FFI usage
  • PHP Callbacks
  • A Complete PHP/FFI/preloading Example


Basic FFI usage

Before diving into the details of the FFI API, lets take a look at a few examples demonstrating the simplicity of the FFI API usage for regular tasks.

Note:

Some of these examples require libc.so.6 and as such will not work on systems where it is not available.

Example #1 Calling a function from shared library

<?php
// create FFI object, loading libc and exporting function printf()
$ffi = FFI::cdef(
    "int printf(const char *format, ...);", // this is a regular C declaration
    "libc.so.6");
// call C's printf()
$ffi->printf("Hello %s!\n", "world");
?>

以上例程会输出：

Hello world!

Note:

Note that some C functions need specific calling conventions, e.g. __fastcall, __stdcall or ,__vectorcall.

Example #2 Calling a function, returning a structure through an argument

<?php
// create gettimeofday() binding
$ffi = FFI::cdef("
    typedef unsigned int time_t;
    typedef unsigned int suseconds_t;

    struct timeval {
        time_t      tv_sec;
        suseconds_t tv_usec;
    };

    struct timezone {
        int tz_minuteswest;
        int tz_dsttime;
    };

    int gettimeofday(struct timeval *tv, struct timezone *tz);
", "libc.so.6");
// create C data structures
$tv = $ffi->new("struct timeval");
$tz = $ffi->new("struct timezone");
// call C's gettimeofday()
var_dump($ffi->gettimeofday(FFI::addr($tv), FFI::addr($tz)));
// access field of C data structure
var_dump($tv->tv_sec);
// print the whole C data structure
var_dump($tz);
?>

以上例程的输出类似于：

int(0)
int(1555946835)
object(FFI\CData:struct timezone)#3 (2) {
  ["tz_minuteswest"]=>
  int(0)
  ["tz_dsttime"]=>
  int(0)
}

Example #3 Accessing existing C variables

<?php
// create FFI object, loading libc and exporting errno variable
$ffi = FFI::cdef(
    "int errno;", // this is a regular C declaration
    "libc.so.6");
// print C's errno
var_dump($ffi->errno);
?>

以上例程会输出：

int(0)

Example #4 Creating and Modifying C variables

<?php
// create a new C int variable
$x = FFI::new("int");
var_dump($x->cdata);

// simple assignment
$x->cdata = 5;
var_dump($x->cdata);

// compound assignment
$x->cdata += 2;
var_dump($x->cdata);
?>

以上例程会输出：

int(0)
int(5)
int(7)

Example #5 Working with C arrays

<?php
// create C data structure
$a = FFI::new("long[1024]");
// work with it like with a regular PHP array
for ($i = 0; $i < count($a); $i++) {
    $a[$i] = $i;
}
var_dump($a[25]);
$sum = 0;
foreach ($a as $n) {
    $sum += $n;
}
var_dump($sum);
var_dump(count($a));
var_dump(FFI::sizeof($a));
?>

以上例程会输出：

int(25)
int(523776)
int(1024)
int(8192)

Example #6 Working with C enums

<?php
$a = FFI::cdef('typedef enum _zend_ffi_symbol_kind {
    ZEND_FFI_SYM_TYPE,
    ZEND_FFI_SYM_CONST = 2,
    ZEND_FFI_SYM_VAR,
    ZEND_FFI_SYM_FUNC
} zend_ffi_symbol_kind;
');
var_dump($a->ZEND_FFI_SYM_TYPE);
var_dump($a->ZEND_FFI_SYM_CONST);
var_dump($a->ZEND_FFI_SYM_VAR);
?>

以上例程会输出：

int(0)
int(2)
int(3)


PHP Callbacks

It is possible to assign a PHP closure to a native variable of function pointer type or to pass it as a function argument:

<?php
$zend = FFI::cdef("
    typedef int (*zend_write_func_t)(const char *str, size_t str_length);
    extern zend_write_func_t zend_write;
");

echo "Hello World 1!\n";

$orig_zend_write = clone $zend->zend_write;
$zend->zend_write = function($str, $len) {
    global $orig_zend_write;
    $orig_zend_write("{\n\t", 3);
    $ret = $orig_zend_write($str, $len);
    $orig_zend_write("}\n", 2);
    return $ret;
};
echo "Hello World 2!\n";
$zend->zend_write = $orig_zend_write;
echo "Hello World 3!\n";
?>

以上例程会输出：

Hello World 1!
{
        Hello World 2!
}
Hello World 3!
Although this works, this functionality is not supported on all libffi platforms, is not efficient and leaks resources by the end of request.
Tip

It is therefore recommended to minimize the usage of PHP callbacks.


A Complete PHP/FFI/preloading Example

php.ini

ffi.enable=preload
opcache.preload=preload.php

preload.php

<?php
FFI::load(__DIR__ . "/dummy.h");
opcache_compile_file(__DIR__ . "/dummy.php");
?>

dummy.h

#define FFI_SCOPE "DUMMY"
#define FFI_LIB "libc.so.6"

int printf(const char *format, ...);

dummy.php

<?php
final class Dummy {
    private static $ffi = null;
    function __construct() {
        if (is_null(self::$ffi)) {
            self::$ffi = FFI::scope("DUMMY");
        }
    }
    function printf($format, ...$args) {
       return (int)self::$ffi->printf($format, ...$args);
    }
}
?>

test.php

<?php
$d = new Dummy();
$d->printf("Hello %s!\n", "world");
?>


Main interface to C code and data

(PHP 7 >= 7.4.0)

简介

Objects of this class are created by the factory methods FFI::cdef(), FFI::load() or FFI::scope(). Defined C variables are made available as properties of the FFI instance, and defined C functions are made available as methods of the FFI instance. Declared C types can be used to create new C data structures using FFI::new() and FFI::type().

FFI definition parsing and shared library loading may take significant time. It is not useful to do it on each HTTP request in a Web environment. However, it is possible to preload FFI definitions and libraries at PHP startup, and to instantiate FFI objects when necessary. Header files may be extended with special FFI_SCOPE defines (e.g. #define FFI_SCOPE "foo"""; the default scope is "C") and then loaded by FFI::load() during preloading. This leads to the creation of a persistent binding, that will be available to all the following requests through FFI::scope(). Refer to the complete PHP/FFI/preloading example for details.

It is possible to preload more than one C header file into the same scope.

类摘要

FFI {
/* 方法 */
public static addr ( FFI\CData &$ptr ) : FFI\CData
public static alignof ( FFI\CData|FFI\CType &$ptr ) : int
public static arrayType ( FFI\CType $type , array $dimensions ) : FFI\CType
public static cast ( FFI\CType|string $type , FFI\CData|int|float|bool|null &$ptr ) : FFI\CData|null
public cast ( FFI\CType|string $type , FFI\CData|int|float|bool|null &$ptr ) : FFI\CData|null
public static cdef ( string $code = "" , string|null $lib = null ) : FFI
public static free ( FFI\CData &$ptr ) : void
public static isNull ( FFI\CData &$ptr ) : bool
public static load ( string $filename ) : FFI|null
public static memcmp ( string|FFI\CData &$ptr1 , string|FFI\CData &$ptr2 , int $size ) : int
public static memcpy ( FFI\CData &$to , FFI\CData|string &$from , int $size ) : void
public static memset ( FFI\CData &$ptr , int $value , int $size ) : void
public static new ( FFI\CType|string $type , bool $owned = true , bool $persistent = false ) : FFI\CData|null
public new ( FFI\CType|string $type , bool $owned = true , bool $persistent = false ) : FFI\CData|null
public static scope ( string $name ) : FFI
public static sizeof ( FFI\CData|FFI\CType &$ptr ) : int
public static string ( FFI\CData &$ptr , int|null $size = null ) : string
public static type ( string $type ) : FFI\CType|null
public type ( string $type ) : FFI\CType|null
public static typeof ( FFI\CData &$ptr ) : FFI\CType
}

Table of Contents

  • FFI::addr — Creates an unmanaged pointer to C data
  • FFI::alignof — Gets the alignment
  • FFI::arrayType — Dynamically constructs a new C array type
  • FFI::cast — Performs a C type cast
  • FFI::cdef — Creates a new FFI object
  • FFI::free — Releases an unmanaged data structure
  • FFI::isNull — Checks whether a FFI\CData is a null pointer
  • FFI::load — Loads C declarations from a C header file
  • FFI::memcmp — Compares memory areas
  • FFI::memcpy — Copies one memory area to another
  • FFI::memset — Fills a memory area
  • FFI::new — Creates a C data structure
  • FFI::scope — Instantiates an FFI object with C declarations parsed during preloading
  • FFI::sizeof — Gets the size of C data or types
  • FFI::string — Creates a PHP string from a memory area
  • FFI::type — Creates an FFI\CType object from a C declaration
  • FFI::typeof — Gets the FFI\CType of FFI\CData


Creates an unmanaged pointer to C data

  • ? FFI
  • FFI::alignof ?
  • PHP Manual
  • FFI
  • Creates an unmanaged pointer to C data

FFI::addr

(PHP 7 >= 7.4.0)

FFI::addr — Creates an unmanaged pointer to C data

说明

public static FFI::addr ( FFI\CData &$ptr ) : FFI\CData

Creates an unmanaged pointer to the C data represented by the given FFI\CData. The source ptr must survive the resulting pointer. This function is mainly useful to pass arguments to C functions by pointer.

参数

ptr

The handle of the pointer to a C data structure.

返回值

Returns the freshly created FFI\CData object.


Gets the alignment

  • ? FFI::addr
  • FFI::arrayType ?
  • PHP Manual
  • FFI
  • Gets the alignment

FFI::alignof

(PHP 7 >= 7.4.0)

FFI::alignof — Gets the alignment

说明

public static FFI::alignof ( FFI\CData|FFI\CType &$ptr ) : int

Gets the alignment of the given FFI\CData or FFI\CType object.

参数

ptr

The handle of the C data or type.

返回值

Returns the alignment of the given FFI\CData or FFI\CType object.


Dynamically constructs a new C array type

  • ? FFI::alignof
  • FFI::cast ?
  • PHP Manual
  • FFI
  • Dynamically constructs a new C array type

FFI::arrayType

(PHP 7 >= 7.4.0)

FFI::arrayType — Dynamically constructs a new C array type

说明

public static FFI::arrayType ( FFI\CType $type , array $dimensions ) : FFI\CType

Dynamically constructs a new C array type with elements of type defined by type, and dimensions specified by dimensions. In the following example $t1 and $t2 are equivalent array types:

<?php
$t1 = FFI::type("int[2][3]");
$t2 = FFI::arrayType(FFI::type("int"), [2, 3]);
?>

参数

type

A valid C declaration as string, or an instance of FFI\CType which has already been created.

dimensions

The dimensions of the type as array.

返回值

Returns the freshly created FFI\CType object.


Performs a C type cast

  • ? FFI::arrayType
  • FFI::cdef ?
  • PHP Manual
  • FFI
  • Performs a C type cast

FFI::cast

(PHP 7 >= 7.4.0)

FFI::cast — Performs a C type cast

说明

public static FFI::cast ( FFI\CType|string $type , FFI\CData|int|float|bool|null &$ptr ) : FFI\CData|null
public FFI::cast ( FFI\CType|string $type , FFI\CData|int|float|bool|null &$ptr ) : FFI\CData|null

FFI::cast() creates a new FFI\CData object, that references the same C data structure, but is associated with a different type. The resulting object does not own the C data, and the source ptr must survive the result. The C type may be specified as a string with any valid C type declaration or as FFI\CType object, created before. If this method is called statically, it must only use predefined C type names (e.g. int, char, etc.); if the method is called as instance method, any type declared for the instance is allowed.

参数

type

A valid C declaration as string, or an instance of FFI\CType which has already been created.

ptr

The handle of the pointer to a C data structure.

返回值

Returns the freshly created FFI\CData object.


Creates a new FFI object

  • ? FFI::cast
  • FFI::free ?
  • PHP Manual
  • FFI
  • Creates a new FFI object

FFI::cdef

(PHP 7 >= 7.4.0)

FFI::cdef — Creates a new FFI object

说明

public static FFI::cdef ( string $code = "" , string|null $lib = null ) : FFI

Creates a new FFI object.

参数

code

A string containing a sequence of declarations in regular C language (types, structures, functions, variables, etc). Actually, this string may be copy-pasted from C header files.

Note:

C preprocessor directives are not supported, i.e. #include, #define and CPP macros do not work.

lib

The name of a shared library file, to be loaded and linked with the definitions.

Note:

If lib is omitted, platforms supporting RTLD_DEFAULT attempt to lookup symbols declared in code in the normal global scope. Other systems will fail to resolve these symbols.

返回值

Returns the freshly created FFI object.

更新日志

版本 | 说明
8.0.0 | lib is nullable now.


Releases an unmanaged data structure

  • ? FFI::cdef
  • FFI::isNull ?
  • PHP Manual
  • FFI
  • Releases an unmanaged data structure

FFI::free

(PHP 7 >= 7.4.0)

FFI::free — Releases an unmanaged data structure

说明

public static FFI::free ( FFI\CData &$ptr ) : void

Manually releases a previously created unmanaged data structure.

参数

ptr

The handle of the unmanaged pointer to a C data structure.

返回值

没有返回值。


Checks whether a FFI\CData is a null pointer

  • ? FFI::free
  • FFI::load ?
  • PHP Manual
  • FFI
  • Checks whether a FFI\CData is a null pointer

FFI::isNull

(PHP 7 >= 7.4.0)

FFI::isNull — Checks whether a FFI\CData is a null pointer

说明

public static FFI::isNull ( FFI\CData &$ptr ) : bool

Checks whether a FFI\CData is a null pointer.

参数

ptr

The handle of the pointer to a C data structure.

返回值

Returns whether a FFI\CData is a null pointer.


Loads C declarations from a C header file

  • ? FFI::isNull
  • FFI::memcmp ?
  • PHP Manual
  • FFI
  • Loads C declarations from a C header file

FFI::load

(PHP 7 >= 7.4.0)

FFI::load — Loads C declarations from a C header file

说明

public static FFI::load ( string $filename ) : FFI|null

Loads C declarations from a C header file. It is possible to specify shared libraries that should be loaded, using special FFI_LIB defines in the loaded C header file.

参数

filename

The name of a C header file.

C preprocessor directives are not supported, i.e. #include, #define and CPP macros do not work, except for special cases listed below.

The header file should contain a #define statement for the FFI_SCOPE variable, e.g.: #define FFI_SCOPE "MYLIB". Refer to the class introduction for details.

The header file may contain a #define statement for the FFI_LIB variable to specify the library it exposes. If it is a system library only the file name is required, e.g.: #define FFI_LIB "libc.so.6". If it is a custom library, a relative path is required, e.g.: #define FFI_LIB "./mylib.so".

返回值

Returns the freshly created FFI object, or null on failure.

参见

  • FFI::scope() - Instantiates an FFI object with C declarations parsed during preloading


Compares memory areas

  • ? FFI::load
  • FFI::memcpy ?
  • PHP Manual
  • FFI
  • Compares memory areas

FFI::memcmp

(PHP 7 >= 7.4.0)

FFI::memcmp — Compares memory areas

说明

public static FFI::memcmp ( string|FFI\CData &$ptr1 , string|FFI\CData &$ptr2 , int $size ) : int

Compares size bytes from the memory areas ptr1 and ptr2. Both ptr1 and ptr2 can be any native data structures (FFI\CData) or PHP strings.

参数

ptr1

The start of one memory area.

ptr2

The start of another memory area.

size

The number of bytes to compare.

返回值

Returns < 0 if the contents of the memory area starting at ptr1 are considered less than the contents of the memory area starting at ptr2, > 0 if the contents of the first memory area are considered greater than the second, and 0 if they are equal.


Copies one memory area to another

  • ? FFI::memcmp
  • FFI::memset ?
  • PHP Manual
  • FFI
  • Copies one memory area to another

FFI::memcpy

(PHP 7 >= 7.4.0)

FFI::memcpy — Copies one memory area to another

说明

public static FFI::memcpy ( FFI\CData &$to , FFI\CData|string &$from , int $size ) : void

Copies size bytes from the memory area from to the memory area to.

参数

to

The start of the memory area to copy to.

from

The start of the memory area to copy from.

size

The number of bytes to copy.

返回值

没有返回值。


Fills a memory area

  • ? FFI::memcpy
  • FFI::new ?
  • PHP Manual
  • FFI
  • Fills a memory area

FFI::memset

(PHP 7 >= 7.4.0)

FFI::memset — Fills a memory area

说明

public static FFI::memset ( FFI\CData &$ptr , int $value , int $size ) : void

Fills size bytes of the memory area pointed to by ptr with the given byte value.

参数

ptr

The start of the memory area to fill.

value

The byte to fill with.

size

The number of bytes to fill.

返回值

没有返回值。


Creates a C data structure

  • ? FFI::memset
  • FFI::scope ?
  • PHP Manual
  • FFI
  • Creates a C data structure

FFI::new

(PHP 7 >= 7.4.0)

FFI::new — Creates a C data structure

说明

public static FFI::new ( FFI\CType|string $type , bool $owned = true , bool $persistent = false ) : FFI\CData|null
public FFI::new ( FFI\CType|string $type , bool $owned = true , bool $persistent = false ) : FFI\CData|null

Creates a native data structure of the given C type. If this method is called statically, it must only use predefined C type names (e.g. int, char, etc.); if the method is called as instance method, any type declared for the instance is allowed.

参数

type

type is a valid C declaration as string, or an instance of FFI\CType which has already been created.

owned

Whether to create owned (i.e. managed) or unmanaged data. Managed data lives together with the returned FFI\CData object, and is released when the last reference to that object is released by regular PHP reference counting or GC. Unmanaged data should be released by calling FFI::free(), when no longer needed.

persistent

Whether to allocate the C data structure permanently on the system heap (using malloc()), or on the PHP request heap (using emalloc()).

返回值

Returns the freshly created FFI\CData object, or null on failure.


Instantiates an FFI object with C declarations parsed during preloading

  • ? FFI::new
  • FFI::sizeof ?
  • PHP Manual
  • FFI
  • Instantiates an FFI object with C declarations parsed during preloading

FFI::scope

(PHP 7 >= 7.4.0)

FFI::scope — Instantiates an FFI object with C declarations parsed during preloading

说明

public static FFI::scope ( string $name ) : FFI

Instantiates an FFI object with C declarations parsed during preloading.

The FFI::scope() method is safe to call multiple times for the same scope. Multiple references to the same scope may be loaded at the same time.

参数

name

The scope name defined by a special FFI_SCOPE define.

返回值

Returns the freshly created FFI object.

参见

  • FFI::load() - Loads C declarations from a C header file


Gets the size of C data or types

  • ? FFI::scope
  • FFI::string ?
  • PHP Manual
  • FFI
  • Gets the size of C data or types

FFI::sizeof

(PHP 7 >= 7.4.0)

FFI::sizeof — Gets the size of C data or types

说明

public static FFI::sizeof ( FFI\CData|FFI\CType &$ptr ) : int

Returns the size of the given FFI\CData or FFI\CType object.

参数

ptr

The handle of the C data or type.

返回值

The size of the memory area pointed at by ptr.


Creates a PHP string from a memory area

  • ? FFI::sizeof
  • FFI::type ?
  • PHP Manual
  • FFI
  • Creates a PHP string from a memory area

FFI::string

(PHP 7 >= 7.4.0)

FFI::string — Creates a PHP string from a memory area

说明

public static FFI::string ( FFI\CData &$ptr , int|null $size = null ) : string

Creates a PHP string from size bytes of the memory area pointed to by ptr.

参数

ptr

The start of the memory area from which to create a string.

size

The number of bytes to copy to the string. If size is omitted, ptr must be a zero terminated array of C chars.

返回值

The freshly created PHP string.

更新日志

版本 | 说明
8.0.0 | size is nullable now; previously, its default was 0.


Creates an FFI\CType object from a C declaration

  • ? FFI::string
  • FFI::typeof ?
  • PHP Manual
  • FFI
  • Creates an FFI\CType object from a C declaration

FFI::type

(PHP 7 >= 7.4.0)

FFI::type — Creates an FFI\CType object from a C declaration

说明

public static FFI::type ( string $type ) : FFI\CType|null
public FFI::type ( string $type ) : FFI\CType|null

This function creates and returns a FFI\CType object for the given string containing a C type declaration. If this method is called statically, it must only use predefined C type names (e.g. int, char, etc.); if the method is called as instance method, any type declared for the instance is allowed.

参数

type

A valid C declaration as string, or an instance of FFI\CType which has already been created.

返回值

Returns the freshly created FFI\CType object, or null on failure.


Gets the FFI\CType of FFI\CData

  • ? FFI::type
  • FFI\CData ?
  • PHP Manual
  • FFI
  • Gets the FFI\CType of FFI\CData

FFI::typeof

(PHP 7 >= 7.4.0)

FFI::typeof — Gets the FFI\CType of FFI\CData

说明

public static FFI::typeof ( FFI\CData &$ptr ) : FFI\CType

Gets the FFI\CType object representing the type of the given FFI\CData object.

参数

ptr

The handle of the pointer to a C data structure.

返回值

Returns the FFI\CType object representing the type of the given FFI\CData object.


C Data Handles

(PHP 7 >= 7.4.0)

简介

FFI\CData objects can be used in a number of ways as a regular PHP data:

  • C data of scalar types can be read and assigned via the $cdata property, e.g. $x = FFI::new('int'); $x->cdata = 42;
  • C struct and union fields can be accessed as regular PHP object property, e.g. $cdata->field
  • C array elements can be accessed as regular PHP array elements, e.g. $cdata[$offset]
  • C arrays can be iterated using foreach statements.
  • C arrays can be used as arguments of count().
  • C pointers can be dereferenced as arrays, e.g. $cdata[0]
  • C pointers can be compared using regular comparison operators (<, <=, ==, !=, >=, >).
  • C pointers can be incremented and decremented using regular +/-/ ++/-- operations, e.g. $cdata += 5
  • C pointers can be subtracted from another using regular - operations.
  • C pointers to functions can be called as a regular PHP closure, e.g. $cdata()
  • Any C data can be duplicated using the clone operator, e.g. $cdata2 = clone $cdata;
  • Any C data can be visualized using var_dump(), print_r(), etc.

Note: Notable limitations are that FFI\CData instances do not support isset(), empty() and unset(), and that wrapped C structs and unions do not implement Traversable.

类摘要

FFI\CData {
}


  • ? FFI\CData
  • FFI\Exception ?
  • PHP Manual
  • FFI
  • C Type Handles

C Type Handles

(PHP 7 >= 7.4.0)

简介

类摘要

FFI\CType {
}


FFI Exceptions

(PHP 7 >= 7.4.0)

简介

类摘要

FFI\Exception extends Error implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Error::getMessage ( ) : string
final public Error::getPrevious ( ) : Throwable
final public Error::getCode ( ) : mixed
final public Error::getFile ( ) : string
final public Error::getLine ( ) : int
final public Error::getTrace ( ) : array
final public Error::getTraceAsString ( ) : string
public Error::__toString ( ) : string
final private Error::__clone ( ) : void
}


FFI Parser Exceptions

(PHP 7 >= 7.4.0)

简介

类摘要

FFI\ParserException extends FFI\Exception implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}


Memtrack

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic usage


简介

The purpose of this extension is to detect the most memory hungry scripts and functions.

memtrack tracks memory consumption in PHP scripts and produces reports (warnings) when the consumption reaches certain levels set by the user. This is achieved by replacing default executor function by a special function which compares memory usage before and after running the original executor - this way we can tell how much the memory usage has changed during the execution of the current part of the code.

Zend Engine runs its executor for each opcode array (op_array), which usually means function, plain script and such, so memtrack doesn't have any noticeable effect on performance.

memtrack doesn't provide any functions, there are only INI directives which allow you to configure the way it should work.

Warning

此扩展是实验性 的。 此扩展的表象，包括其函数名称以及其他此扩展的相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本扩展风险自担。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Memtrack
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/memtrack


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Memtrack Configuration Options
名字 | 默认 | 可修改范围
memtrack.enabled | "0" | PHP_INI_SYSTEM
memtrack.soft_limit | "0" | PHP_INI_ALL
memtrack.hard_limit | "0" | PHP_INI_ALL
memtrack.vm_limit | "0" | PHP_INI_ALL
memtrack.ignore_functions | "" | PHP_INI_SYSTEM
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

memtrack.enabled bool

Disables or enables the extension. Default value is 0, i.e. disabled.

memtrack.soft_limit int

Soft memory limit.

The extension checks memory consumption before and after executing an op_array and produces a warning is the difference between the two values is equal to or greater than the soft limit, but only if the function is not ignored.

Setting this option to 0 also disables both soft and hard limit warnings. Default value is 0, i.e. no warnings is produced.

memtrack.hard_limit int

Hard memory limit.

The extension checks memory consumption before and after executing an op_array and produces a warning is the difference between the two values is equal to or greater than the hard limit, even if the function is ignored. Setting this option to 0 disables hard limit warnings completely. Default value is 0, i.e. no hard limit warnings is produced.

memtrack.vm_limit int

Virtual memory limit (set on a process).

This limit is checked only on shutdown and a warning is produced if the value is greater than or equal to the limit.

This option is currently supported only on OSes where mallinfo() function is available (i.e. Linux).

memtrack.ignore_functions string

A comma or whitespace-separated list of functions which are to be ignored by soft_limit. The values are case-insensitive, for class methods use class::method syntax.


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • Memtrack
  • 预定义常量

预定义常量

此扩展没有定义常量。


  • ? 预定义常量
  • Basic usage ?
  • PHP Manual
  • Memtrack
  • 范例

范例

Table of Contents

  • Basic usage


Basic usage

Basic example on using memtrack extension:

Example #1 Creating large array in a function

<?php

/* /tmp/example1.php */

function foo() {
    $a = array();
    for ($i = 0; $i < 10000; $i++) $a[] = "test";
    return $a;
}
$arr = foo();

?>

Run the example with the following command:

php -d memtrack.enabled=1 -d memtrack.soft_limit=1M -d memtrack.vm_limit=3M /tmp/example1.php

以上例程的输出类似于：

Warning: [memtrack] [pid 26177] user function foo() executed in /tmp/example1.php on line 10 allocated 4194304 bytes in /tmp/example1.php on line 0
Warning: [memtrack] [pid 26177] virtual memory usage on shutdown: 32911360 bytes in Unknown on line 0


OPcache

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • Preloading
  • OPcache 函数
    • opcache_compile_file — 无需运行，即可编译并缓存 PHP 脚本
    • opcache_get_configuration — 获取缓存的配置信息
    • opcache_get_status — 获取缓存的状态信息
    • opcache_invalidate — 废除脚本缓存
    • opcache_is_script_cached — Tells whether a script is cached in OPCache
    • opcache_reset — 重置字节码缓存的内容


简介

OPcache 通过将 PHP 脚本预编译的字节码存储到共享内存中来提升 PHP 的性能， 存储预编译字节码的好处就是 省去了每次加载和解析 PHP 脚本的开销。

PHP 5.5.0 及后续版本中已经绑定了 OPcache 扩展。 对于 PHP 5.2，5.3 和 5.4 版本可以使用 » PECL 扩展中的 OPcache 库。


安装

安装 OPcache 的过程根据所用的 PHP 版本有所不同。 请参考以下小节中适用的内容。

Note:

如果需要将 » Xdebug 扩展和 OPcache 一起使用，必须在 Xdebug 扩展之前加载 OPcache 扩展。

PHP 5.5.0 及后续版本

OPcache 只能编译为共享扩展。 如果你使用 --disable-all 参数 禁用了默认扩展的构建， 那么必须使用 --enable-opcache 选项来开启 OPcache。

编译之后，就可以使用 zend_extension 指令来将 OPcache 扩展加载到 PHP 中。在非 Windows 平台使用 zend_extension=/full/path/to/opcache.so， Windows 平台使用 zend_extension=C:\path\to\php_opcache.dll。

PHP 5.2, 5.3 和 5.4 版本

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ZendOpcache.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。

推荐的 php.ini 设置

使用下列推荐设置来获得较好的 性能：

opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1

你也可以禁用 opcache.save_comments 并且启用 opcache.enable_file_override。 需要提醒的是，在生产环境中使用上述配置之前，必须经过严格测试。 因为上述配置存在一个已知问题，它会引发一些框架和应用的异常， 尤其是在存在文档使用了备注注解的时候。

这里是 OPcache 可用的配置指令完整列表。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

OPcache 配置选项
名字 | 默认 | 可修改范围 | 更新日志
opcache.enable | "1" | PHP_INI_ALL |
opcache.enable_cli | "0" | PHP_INI_SYSTEM | 在 PHP 7.1.2 至 7.1.6 （含）的版本，默认值是"1"
opcache.memory_consumption | "128" | PHP_INI_SYSTEM | 在 PHP 7.0.0 之前，默认值是 "64"
opcache.interned_strings_buffer | "8" | PHP_INI_SYSTEM | 在 PHP 7.0.0 之前，默认值是 "4"
opcache.max_accelerated_files | "10000" | PHP_INI_SYSTEM | 在 PHP 7.0.0 之前，默认值是 "2000"
opcache.max_wasted_percentage | "5" | PHP_INI_SYSTEM |
opcache.use_cwd | "1" | PHP_INI_SYSTEM |
opcache.validate_timestamps | "1" | PHP_INI_ALL |
opcache.revalidate_freq | "2" | PHP_INI_ALL |
opcache.revalidate_path | "0" | PHP_INI_ALL |
opcache.save_comments | "1" | PHP_INI_SYSTEM |
opcache.load_comments | "1" | PHP_INI_ALL | 从 PHP 7.0.0 开始被移除
opcache.fast_shutdown | "0" | PHP_INI_SYSTEM | 从 PHP 7.2.0 开始被移除
opcache.enable_file_override | "0" | PHP_INI_SYSTEM |
opcache.optimization_level | "0x7FFFBFFF" | PHP_INI_SYSTEM | 从 PHP 5.6.18 开始，默认值从 0xFFFFFFFF 修改为 0x7FFFBFFF
opcache.inherited_hack | "1" | PHP_INI_SYSTEM | 自 PHP 7.3.0 被移除
opcache.dups_fix | "0" | PHP_INI_ALL |
opcache.blacklist_filename | "" | PHP_INI_SYSTEM |
opcache.max_file_size | "0" | PHP_INI_SYSTEM |
opcache.consistency_checks | "0" | PHP_INI_ALL |
opcache.force_restart_timeout | "180" | PHP_INI_SYSTEM |
opcache.error_log | "" | PHP_INI_SYSTEM |
opcache.log_verbosity_level | "1" | PHP_INI_SYSTEM |
opcache.preferred_memory_model | "" | PHP_INI_SYSTEM |
opcache.protect_memory | "0" | PHP_INI_SYSTEM |
opcache.mmap_base | null | PHP_INI_SYSTEM |
opcache.restrict_api | "" | PHP_INI_SYSTEM |
opcache.file_update_protection | "2" | PHP_INI_ALL |
opcache.huge_code_pages | "0" | PHP_INI_SYSTEM |
opcache.lockfile_path | "/tmp" | PHP_INI_SYSTEM |
opcache.opt_debug_level | "0" | PHP_INI_SYSTEM |
opcache.file_cache | NULL | PHP_INI_SYSTEM | 从 PHP 7.0.0 开始支持
opcache.file_cache_only | "0" | PHP_INI_SYSTEM | 从 PHP 7.0.0 开始支持
opcache.file_cache_consistency_checks | "1" | PHP_INI_SYSTEM | 从 PHP 7.0.0 开始支持
opcache.file_cache_fallback | "1" | PHP_INI_SYSTEM | 从 PHP 7.0.0 开始支持，仅适用于 Windows 平台
opcache.validate_permission | "0" | PHP_INI_SYSTEM | 从 PHP 7.0.14 开始支持
opcache.validate_root | "0" | PHP_INI_SYSTEM | 从 PHP 7.0.14 开始支持
opcache.preload | "" | PHP_INI_SYSTEM | 从 PHP 7.4.0 开始支持
opcache.preload_user | "" | PHP_INI_SYSTEM | 从 PHP 7.4.0 开始支持
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

opcache.enable boolean

启用操作码缓存。如果禁用此选项，则不会优化和缓存代码。 在运行期使用 ini_set() 函数只能禁用 opcache.enable 设置，不可以启用此设置。 如果在脚本中尝试启用此设置项会产生警告。

opcache.enable_cli boolean

仅针对 CLI 版本的 PHP 启用操作码缓存。 通常被用来测试和调试。

opcache.memory_consumption integer

OPcache 的共享内存大小，以兆字节为单位。

opcache.interned_strings_buffer integer

用来存储预留字符串的内存大小，以兆字节为单位。 PHP 5.3.0 之前的版本会忽略此配置指令。

opcache.max_accelerated_files integer

OPcache 哈希表中可存储的脚本文件数量上限。 真实的取值是在质数集合 { 223, 463, 983, 1979, 3907, 7963, 16229, 32531, 65407, 130987 } 中找到的第一个大于等于设置值的质数。 设置值取值范围最小值是 200，最大值在 PHP 5.5.6 之前是 100000，PHP 5.5.6 及之后是 1000000。

opcache.max_wasted_percentage integer

浪费内存的上限，以百分比计。 如果达到此上限，那么 OPcache 将产生重新启动续发事件。

opcache.use_cwd boolean

如果启用，OPcache 将在哈希表的脚本键之后附加改脚本的工作目录， 以避免同名脚本冲突的问题。 禁用此选项可以提高性能，但是可能会导致应用崩溃。

opcache.validate_timestamps boolean

如果启用，那么 OPcache 会每隔 opcache.revalidate_freq 设定的秒数 检查脚本是否更新。 如果禁用此选项，你必须使用 opcache_reset() 或者 opcache_invalidate() 函数来手动重置 OPcache，也可以 通过重启 Web 服务器来使文件系统更改生效。

opcache.revalidate_freq integer

检查脚本时间戳是否有更新的周期，以秒为单位。 设置为 0 会导致针对每个请求， OPcache 都会检查脚本更新。

如果 opcache.validate_timestamps 配置指令设置为禁用，那么此设置项将会被忽略。

opcache.revalidate_path boolean

如果禁用此选项，在同一个 include_path 已存在的缓存文件会被重用。 因此，将无法找到不在包含路径下的同名文件。

opcache.save_comments boolean

如果禁用，脚本文件中的注释内容将不会被包含到操作码缓存文件， 这样可以有效减小优化后的文件体积。 禁用此配置指令可能会导致一些依赖注释或注解的 应用或框架无法正常工作， 比如： Doctrine， Zend Framework 2 以及 PHPUnit。

opcache.load_comments boolean

如果禁用，则即使文件中包含注释，也不会加载这些注释内容。 本选项可以和 opcache.save_comments 一起使用，以实现按需加载注释内容。

opcache.fast_shutdown boolean

如果启用，则会使用快速停止续发事件。 所谓快速停止续发事件是指依赖 Zend 引擎的内存管理模块 一次释放全部请求变量的内存，而不是依次释放每一个已分配的内存块。

从 PHP 7.2.0 开始，此配置指令被移除。 快速停止的续发事件的处理已经集成到 PHP 中， 只要有可能，PHP 会自动处理这些续发事件。

opcache.enable_file_override boolean

如果启用，则在调用函数 file_exists()， is_file() 以及 is_readable() 的时候， 都会检查操作码缓存，无论文件是否已经被缓存。 如果应用中包含检查 PHP 脚本存在性和可读性的功能，这样可以提升性能。 但是如果禁用了 opcache.validate_timestamps 选项， 可能存在返回过时数据的风险。

opcache.optimization_level integer

控制优化级别的二进制位掩码。

opcache.inherited_hack boolean

该配置指令已被忽略。

opcache.dups_fix boolean

仅作为针对 "不可重定义类"错误的一种解决方案。

opcache.blacklist_filename string

OPcache 黑名单文件位置。 黑名单文件为文本文件，包含了不进行预编译优化的文件名，每行一个文件名。 黑名单中的文件名可以使用通配符，也可以使用前缀。 此文件中以分号（;）开头的行将被视为注释。

简单的黑名单文件可能如下所示：

; 将特定文件加入到黑名单
/var/www/broken.php
; 以字符 x 文件打头的文件
/var/www/x
; 通配符匹配
/var/www/*-broken.php
opcache.max_file_size integer

以字节为单位的缓存的文件大小上限。设置为 0 表示缓存全部文件。

opcache.consistency_checks integer

如果是非 0 值，OPcache 将会每隔 N 次请求检查缓存校验和。 N 即为此配置指令的设置值。 由于此选项对于性能有较大影响，请尽在调试环境使用。

opcache.force_restart_timeout integer

如果缓存处于非激活状态，等待多少秒之后计划重启。 如果超出了设定时间，则 OPcache 模块将杀除持有缓存锁的进程， 并进行重启。

如果选项 opcache.log_verbosity_level 设置为 2 或者 2 以上的数值，当发生重启时将在日志中记录一条警告信息。

opcache.error_log string

OPcache 模块的错误日志文件。 如果留空，则视为 stderr， 错误日志将被送往标准错误输出 （通常情况下是 Web 服务器的错误日志文件）。

opcache.log_verbosity_level integer

OPcache 模块的日志级别。 默认情况下，仅有致命级别（0）及错误级别（1）的日志会被记录。 其他可用的级别有：警告（2），信息（3）和调试（4）。

opcache.preferred_memory_model string

OPcache 首选的内存模块。 如果留空，OPcache 会选择适用的模块， 通常情况下，自动选择就可以满足需求。

可选值包括： mmap，shm, posix 以及 win32。

opcache.protect_memory boolean

保护共享内存，以避免执行脚本时发生非预期的写入。 仅用于内部调试。

opcache.mmap_base string

在 Windows 平台上共享内存段的基地址。 所有的 PHP 进程都将共享内存映射到同样的地址空间。 使用此配置指令避免"无法重新附加到基地址"的错误。

opcache.restrict_api string

仅允许路径是以指定字符串开始的 PHP 脚本调用 OPcache API 函数。 默认值为空字符串 ""，表示不做限制。

opcache.file_update_protection string

如果文件的最后修改时间距现在不足此项配置指令所设定的秒数，那么这个文件不会进入到缓存中。 这是为了防止尚未完全修改完毕的文件进入到缓存。 如果你的应用中不存在部分修改文件的情况，把此项设置为 0 可以提高性能。

opcache.huge_code_pages string

启用或者禁用将 PHP 代码（文本段）拷贝到 HUGE PAGES 中。 此项配置指令可以提高性能，但是需要在 OS 层面进行对应的配置。

opcache.lockfile_path string

用来存储共享锁文件的绝对路径（仅适用于 *nix 操作系统）。

opcache.opt_debug_level string

出于对不同阶段的优化情况进行调试的目的，生成操作码转储。 设置为 0x10000 会在进行优化之前输出编译器编译后的操作码， 设置为 0x20000 会输出优化后的操作码。

opcache.file_cache string

配置二级缓存目录并启用二级缓存。 启用二级缓存可以在 SHM 内存满了、服务器重启或者重置 SHM 的时候提高性能。 默认值为空字符串 ""，表示禁用基于文件的缓存。

opcache.file_cache_only boolean

启用或禁用在共享内存中的 opcode 缓存。

opcache.file_cache_consistency_checks boolean

当从文件缓存中加载脚本的时候，是否对文件的校验和进行验证。

opcache.file_cache_fallback boolean

在 Windows 平台上，当一个进程无法附加到共享内存的时候， 使用基于文件的缓存，也即：opcache.file_cache_only=1。 需要显示的启用文件缓存。

Caution

不鼓励禁用此配置项， 禁用它可能会导致进程无法启动。

opcache.validate_permission boolean

针对当前用户，验证缓存文件的访问权限。

opcache.validate_root boolean

在 chroot 的环境中避免命名冲突。 为了防止进程访问到 chroot 环境之外的文件，应该在 chroot 的情况下启用这个选项。

opcache.preload string

指定要在服务器启动时期进行编译和缓存的 PHP 脚本文件， 这些文件也可能通过 include 或者 opcache_compile_file() 函数 来预加载其他文件。 所有这些文件中包含的实体，包括函数、类等，在服务器启动的时候就被加载和缓存， 对于用户代码来讲是"开箱可用"的。

opcache.preload_user string

考虑到安全因素，禁止以 root 用户预加载代码。该指令方便以其他用户预加载。


  • ? 运行时配置
  • Preloading ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


Preloading

As of PHP 7.4.0, PHP can be configured to preload scripts into the opcache when the engine starts. Any symbols (functions, classes, etc.) in those files will then become globally available for all requests without needing to be explicitly included. That trades convenience and performance (because the code is always available) for baseline memory usage. It also requires restarting the PHP process to clear pre-loaded scripts, meaning this feature is only practical to use in production, not in a development environment.

Note that the optimal tradeoff between performance and memory may vary with the application. "Preload everything" may be the easiest strategy, but not necessarily the best strategy. Additionally, preloading is only useful when there is a persistent process from one request to another. That means while it can work in a CLI script if the opcache is enabled, it's generally pointless. The exception is when using preloading on FFI libraries.

Note:

Preloading is not supported on Windows.

Configuring preloading involves two steps, and requires that the opcache be enabled. First, set the opcache.preload value in php.ini:

opcache.preload=preload.php

preload.php is an arbitrary file that will run once at server startup (PHP-FPM, mod_php, etc.) and load code into persistent memory. If PHP will be run as root (not recommended), the opcache.preload_user value can specify an alternate system user to run the preloading. Running preloading as root is not allowed.

In the preload.php script, any file referenced by include, include_once, require, require_once, or opcache_compile_file() will be parsed into persistent memory. In the following example, all .php files in the src directory will be preloaded, unless they are a Test file.

<?php
$directory = new RecursiveDirectoryIterator(__DIR__ . '/src');
$fullTree = new RecursiveIteratorIterator($directory);
$phpFiles = new RegexIterator($fullTree, '/.+((?<!Test)+\.php$)/i', RecursiveRegexIterator::GET_MATCH);

foreach ($phpFiles as $key => $file) {
    require_once($file[0]);
}
?>

Both include and opcache_compile_file() will work, but have different implications for how code gets handled.

  • include will execute code in the file, while opcache_compile_file() will not. That means only the former supports conditional declaration (functions declared inside an if-block).
  • Because include will execute code, nested included files will also be parsed and their declarations preloaded.
  • opcache_compile_file() can load files in any order. That is, if a.php defines class A and b.php defines class B that extends A, then opcache_compile_file() can load those two files in any order. When using include, however, a.php must be included first.
  • In either case, if a later script includes a file that has already been preloaded then its contents will still execute, but any symbols it defines will not be re-defined. Using include_once will not prevent the file from being included a second time.
Which approach is better therefore depends on the desired behavior. With code that would otherwise use an autoloader, opcache_compile_file() allows for greater flexibility. With code that would otherwise be loaded manually, include will be more robust.


OPcache 函数

Table of Contents

  • opcache_compile_file — 无需运行，即可编译并缓存 PHP 脚本
  • opcache_get_configuration — 获取缓存的配置信息
  • opcache_get_status — 获取缓存的状态信息
  • opcache_invalidate — 废除脚本缓存
  • opcache_is_script_cached — Tells whether a script is cached in OPCache
  • opcache_reset — 重置字节码缓存的内容


无需运行，即可编译并缓存 PHP 脚本

  • ? OPcache 函数
  • opcache_get_configuration ?
  • PHP Manual
  • OPcache 函数
  • 无需运行，即可编译并缓存 PHP 脚本

opcache_compile_file

(PHP 5 >= 5.5.5, PHP 7, PHP 8, PECL ZendOpcache > 7.0.2)

opcache_compile_file — 无需运行，即可编译并缓存 PHP 脚本

说明

opcache_compile_file ( string $file ) : boolean

该函数可以用于在不用运行某个 PHP 脚本的情况下，编译该 PHP 脚本并将其添加到字节码缓存中去。 该函数可用于在 Web 服务器重启之后初始化缓存，以供后续请求调用。

参数

file

被编译的 PHP 脚本的路径。

返回值

如果 file 被成功编译，则返回 true 或者在失败时返回 false。

错误／异常

如果文件（ file ）不能被载入或者不能被编译，则会生成一个 E_WARNING 级别的错误。 可以使用 @ 来抑制该警告。

参见

  • opcache_invalidate() - 废除脚本缓存


获取缓存的配置信息

  • ? opcache_compile_file
  • opcache_get_status ?
  • PHP Manual
  • OPcache 函数
  • 获取缓存的配置信息

opcache_get_configuration

(PHP 5 >= 5.5.0, PHP 7, PHP 8, PECL ZendOpcache > 7.0.2)

opcache_get_configuration — 获取缓存的配置信息

说明

opcache_get_configuration ( ) : array

该函数将返回缓存实例的配置信息。

返回值

返回一个数组，该数组里包含了缓存的初始化信息，黑名单和版本号。

错误／异常

在启用了 opcache.restrict_api 的情况下，如果当前路径在禁止规则里，将会出现 E_WARNING ；不会返回任何状态信息。

参见

  • opcache_get_status() - 获取缓存的状态信息


获取缓存的状态信息

  • ? opcache_get_configuration
  • opcache_invalidate ?
  • PHP Manual
  • OPcache 函数
  • 获取缓存的状态信息

opcache_get_status

(PHP 5 >= 5.5.0, PHP 7, PHP 8, PECL ZendOpcache > 7.0.2)

opcache_get_status — 获取缓存的状态信息

说明

opcache_get_status ( boolean $get_scripts = true ) : array

该函数将返回缓存实例的状态信息。

参数

get_scripts

包含脚本的具体声明信息。

返回值

返回一个数组，该数组可能包含有脚本具体的声明信息。

错误／异常

在启用了 opcache.restrict_api 的情况下，如果当前路径在禁止规则里，将会出现 E_WARNING ；不会返回任何状态信息。

参见

  • opcache_get_configuration() - 获取缓存的配置信息


废除脚本缓存

  • ? opcache_get_status
  • opcache_is_script_cached ?
  • PHP Manual
  • OPcache 函数
  • 废除脚本缓存

opcache_invalidate

(PHP 5 >= 5.5.0, PHP 7, PHP 8, PECL ZendOpcache >= 7.0.0)

opcache_invalidate — 废除脚本缓存

说明

opcache_invalidate ( string $script , boolean $force = false ) : boolean

该函数的作用是使得指定脚本的字节码缓存失效。 如果 force 没有设置或者传入的是 false，那么只有当脚本的修改时间 比对应字节码的时间更新，脚本的缓存才会失效。

参数

script

缓存需要被作废对应的脚本路径

force

如果该参数设置为true，那么不管是否必要，该脚本的缓存都将被废除。

返回值

如果脚本的字节码缓存失效设置成功或者该脚本本来就没有缓存，则返回 true；如果字节码缓存被禁用，则返回false。

参见

  • opcache_compile_file() - 无需运行，即可编译并缓存 PHP 脚本
  • opcache_reset() - 重置字节码缓存的内容


Tells whether a script is cached in OPCache

  • ? opcache_invalidate
  • opcache_reset ?
  • PHP Manual
  • OPcache 函数
  • Tells whether a script is cached in OPCache

opcache_is_script_cached

(PHP 5 >= 5.5.11, PHP 7, PHP 8, PECL ZendOpcache >= 7.0.4)

opcache_is_script_cached — Tells whether a script is cached in OPCache

说明

opcache_is_script_cached ( string $filename ) : bool

This function checks if a PHP script has been cached in OPCache. This can be used to more easily detect the "warming" of the cache for a particular script.

参数

filename

The path to the PHP script to be checked.

返回值

Returns true if filename is cached in OPCache, false otherwise.

参见

  • opcache_compile_file() - 无需运行，即可编译并缓存 PHP 脚本


重置字节码缓存的内容

  • ? opcache_is_script_cached
  • 输出控制 ?
  • PHP Manual
  • OPcache 函数
  • 重置字节码缓存的内容

opcache_reset

(PHP 5 >= 5.5.0, PHP 7, PHP 8, PECL ZendOpcache >= 7.0.0)

opcache_reset — 重置字节码缓存的内容

说明

opcache_reset ( ) : boolean

该函数将重置整个字节码缓存。 在调用 opcache_reset() 之后，所有的脚本将会重新载入并且在下次被点击的时候重新解析。

参数

此函数没有参数。

返回值

如果字节码缓存被重置成功，则返回 true；如果字节码缓存被禁用，则返回 false。

参见

  • opcache_invalidate() - 废除脚本缓存


输出缓冲控制

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • 基本用法
  • Output Control 函数
    • flush — 刷新输出缓冲
    • ob_clean — 清空（擦掉）输出缓冲区
    • ob_end_clean — 清空（擦除）缓冲区并关闭输出缓冲
    • ob_end_flush — 冲刷出（送出）输出缓冲区内容并关闭缓冲
    • ob_flush — 冲刷出（送出）输出缓冲区中的内容
    • ob_get_clean — 得到当前缓冲区的内容并删除当前输出缓。
    • ob_get_contents — 返回输出缓冲区的内容
    • ob_get_flush — 刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。
    • ob_get_length — 返回输出缓冲区内容的长度
    • ob_get_level — 返回输出缓冲机制的嵌套级别
    • ob_get_status — 得到所有输出缓冲区的状态
    • ob_gzhandler — 在ob_start中使用的用来压缩输出缓冲区中内容的回调函数。ob_start callback function to gzip output buffer
    • ob_implicit_flush — 打开/关闭绝对刷送
    • ob_list_handlers — 列出所有使用中的输出处理程序。
    • ob_start — 打开输出控制缓冲
    • output_add_rewrite_var — 添加URL重写器的值（Add URL rewriter values）
    • output_reset_rewrite_vars — 重设URL重写器的值（Reset URL rewriter values）


简介

当PHP脚本有输出时，输出控制函数可以用这些来控制输出。这在多种不同情况中非常有用，尤其是用来在脚本开始输出 数据后，发送http头信息到浏览器。输出控制函数不影响由 header() 或 setcookie()发送的文件头信息，仅影响象 echo这样的函数和PHP代码块间的数据。

Note:

由于早先的版本的缺陷，当从PHP4.1.x(4.2.x,4.3.x)升级时，必须保证php.ini中的implicit_flush 是 OFF， 否则任何用ob_start()的输出将在输出中隐藏掉。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

输出控制配置选项
名字 | 默认 | 可修改范围 | 更新日志
output_buffering | "0" | PHP_INI_PERDIR |
output_handler | NULL | PHP_INI_PERDIR |
implicit_flush | "0" | PHP_INI_ALL |
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL | Before PHP 7.1.0, this was used to set session's trans sid rewrite. From PHP 7.1.0, it is only used by output_add_rewrite_var().
url_rewriter.hosts | $_SERVER['HTTP_HOST'] is used as default. | PHP_INI_ALL | Available as of PHP 7.1.0
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

output_buffering bool/int

该选项设置为 On 时，将在所有的脚本中使用输出控制。如果要限制输出缓冲区的最大值，可将该选项设定为指定的最大字节数（例如 output_buffering=4096）。从PHP 该选项在 PHP-CLI 下总是为 Off。

output_handler string

该选项可将脚本所有的输出，重定向到一个函数。例如，将 output_handler 设置为 mb_output_handler() 时，字符的编码将被修改为指定的编码。设置的任何处理函数，将自动的处理输出缓冲。

Note:

不能同时使用 mb_output_handler() 和
ob_iconv_handler()，也不能同时使用
ob_gzhandler() 和
zlib.output_compression。

Note:

只有内置函数可以使用此指令。对于用户定义的函数，使用 ob_start()。

implicit_flush bool

默认为 false。如将该选项改为 true，PHP 将使输出层，在每段信息块输出后，自动刷新。这等同于在每次使用 print、echo 等函数或每个 HTML 块之后，调用 PHP 中的 flush() 函数。

不在web环境中使用 PHP 时，打开这个选项对程序执行的性能有严重的影响，通常只推荐在调试时使用。在 CLI SAPI 的执行模式下，该标记默认为 true。

参见 ob_implicit_flush()。

url_rewriter.tags string
url_rewriter.tags specifies which HTML tags are rewritten by output_add_rewrite_var() values. Defaults to a=href,area=href,frame=src,input=src,form= form is special tag. <input hidden="session_id" name="session_name"> is added as form variable.

Note: Before PHP 7.1.0, url_rewriter.tags was used to specify session.trans_sid_tags. As of PHP 7.1.0, fieldset is no longer considered as special tag.

url_rewriter.hosts string
url_rewriter.hosts specifies which hosts are rewritten to include output_add_rewrite_var() values. Defaults to $_SERVER['HTTP_HOST']. Multiple hosts can be specified by ",", no space is allowed between hosts. e.g. php.net,wiki.php.net,bugs.php.net


预定义常量

下列常量作为 PHP 核心的一部分总是可用的。

PHP_OUTPUT_HANDLER_START (int)

Indicates that output buffering has begun.

PHP_OUTPUT_HANDLER_WRITE (int)

Indicates that the output buffer is being flushed, and had data to output.

Available since PHP 5.4.

PHP_OUTPUT_HANDLER_FLUSH (int)

Indicates that the buffer has been flushed.

Available since PHP 5.4.

PHP_OUTPUT_HANDLER_CLEAN (int)

Indicates that the output buffer has been cleaned.

Available since PHP 5.4.

PHP_OUTPUT_HANDLER_FINAL (int)

Indicates that this is the final output buffering operation.

Available since PHP 5.4.

PHP_OUTPUT_HANDLER_CONT (int)

Indicates that the buffer has been flushed, but output buffering will continue.

As of PHP 5.4, this is an alias for PHP_OUTPUT_HANDLER_WRITE.

PHP_OUTPUT_HANDLER_END (int)

Indicates that output buffering has ended.

As of PHP 5.4, this is an alias for PHP_OUTPUT_HANDLER_FINAL.

PHP_OUTPUT_HANDLER_CLEANABLE (int)

Controls whether an output buffer created by ob_start() can be cleaned.

Available since PHP 5.4.

PHP_OUTPUT_HANDLER_FLUSHABLE (int)

Controls whether an output buffer created by ob_start() can be flushed.

Available since PHP 5.4.

PHP_OUTPUT_HANDLER_REMOVABLE (int)

Controls whether an output buffer created by ob_start() can be removed before the end of the script.

Available since PHP 5.4.

PHP_OUTPUT_HANDLER_STDFLAGS (int)

The default set of output buffer flags; currently equivalent to PHP_OUTPUT_HANDLER_CLEANABLE | PHP_OUTPUT_HANDLER_FLUSHABLE | PHP_OUTPUT_HANDLER_REMOVABLE.

Available since PHP 5.4.


  • ? 预定义常量
  • 基本用法 ?
  • PHP Manual
  • 输出控制
  • 范例

范例

Table of Contents

  • 基本用法


基本用法

Example #1 输出控制举例

<?php

ob_start();
echo "Hello\n";

setcookie("cookiename", "cookiedata");

ob_end_flush();

?>

在上面的例子中，echo函数的输出将一直被保存在输出缓冲区中直到调用 ob_end_flush() 。同时，对setcookie()的调用也成功存储了一个cookie,而不会引起错误。（正常情况下，在数据被发送到浏览器后，就不能再发送http头信息了。）


Output Control 函数

参见

See also header() and setcookie().

Table of Contents

  • flush — 刷新输出缓冲
  • ob_clean — 清空（擦掉）输出缓冲区
  • ob_end_clean — 清空（擦除）缓冲区并关闭输出缓冲
  • ob_end_flush — 冲刷出（送出）输出缓冲区内容并关闭缓冲
  • ob_flush — 冲刷出（送出）输出缓冲区中的内容
  • ob_get_clean — 得到当前缓冲区的内容并删除当前输出缓。
  • ob_get_contents — 返回输出缓冲区的内容
  • ob_get_flush — 刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。
  • ob_get_length — 返回输出缓冲区内容的长度
  • ob_get_level — 返回输出缓冲机制的嵌套级别
  • ob_get_status — 得到所有输出缓冲区的状态
  • ob_gzhandler — 在ob_start中使用的用来压缩输出缓冲区中内容的回调函数。ob_start callback function to gzip output buffer
  • ob_implicit_flush — 打开/关闭绝对刷送
  • ob_list_handlers — 列出所有使用中的输出处理程序。
  • ob_start — 打开输出控制缓冲
  • output_add_rewrite_var — 添加URL重写器的值（Add URL rewriter values）
  • output_reset_rewrite_vars — 重设URL重写器的值（Reset URL rewriter values）


刷新输出缓冲

  • ? Output Control 函数
  • ob_clean ?
  • PHP Manual
  • Output Control 函数
  • 刷新输出缓冲

flush

(PHP 4, PHP 5, PHP 7, PHP 8)

flush — 刷新输出缓冲

说明

flush ( ) : void

刷新PHP程序的缓冲，而不论PHP执行在何种情况下（CGI ，web服务器等等）。该函数将当前为止程序的所有输出发送到用户的浏览器。

flush() 函数不会对服务器或客户端浏览器的缓存模式产生影响。因此，必须同时使用 ob_flush() 和flush() 函数来刷新输出缓冲。

个别web服务器程序，特别是Win32下的web服务器程序，在发送结果到浏览器之前，仍然会缓存脚本的输出，直到程序结束为止。

有些Apache的模块，比如mod_gzip，可能自己进行输出缓存，这将导致flush()函数产生的结果不会立即被发送到客户端浏览器。

甚至浏览器也会在显示之前，缓存接收到的内容。例如 Netscape 浏览器会在接受到换行或 html 标记的开头之前缓存内容，并且在接受到 </table> 标记之前，不会显示出整个表格。

一些版本的 Microsoft Internet Explorer 只有当接受到的256个字节以后才开始显示该页面，所以必须发送一些额外的空格来让这些浏览器显示页面内容。


清空（擦掉）输出缓冲区

  • ? flush
  • ob_end_clean ?
  • PHP Manual
  • Output Control 函数
  • 清空（擦掉）输出缓冲区

ob_clean

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ob_clean — 清空（擦掉）输出缓冲区

说明

ob_clean ( ) : void

此函数用来丢弃输出缓冲区中的内容。

此函数不会像 ob_end_clean() 函数那样销毁输出缓冲区。

输出缓冲必须已被 ob_start() 以 PHP_OUTPUT_HANDLER_CLEANABLE 标记启动。否则 ob_clean() 不会有效果。

返回值

没有返回值。

参见

  • ob_flush() - 冲刷出（送出）输出缓冲区中的内容
  • ob_end_flush() - 冲刷出（送出）输出缓冲区内容并关闭缓冲
  • ob_end_clean() - 清空（擦除）缓冲区并关闭输出缓冲


清空（擦除）缓冲区并关闭输出缓冲

  • ? ob_clean
  • ob_end_flush ?
  • PHP Manual
  • Output Control 函数
  • 清空（擦除）缓冲区并关闭输出缓冲

ob_end_clean

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_end_clean — 清空（擦除）缓冲区并关闭输出缓冲

说明

ob_end_clean ( ) : bool

此函数丢弃最顶层输出缓冲区的内容并关闭这个缓冲区。如果想要进一步处理缓冲区的内容，必须在ob_end_clean()之前调用ob_get_contents()，因为当调用ob_end_clean()时缓冲区内容将被丢弃。

返回值

成功时返回 true， 或者在失败时返回 false。 错误的原因首先是，在调用时没有一个起作用的缓冲区，或者是因为某些原因缓冲区不能被删除（可能对特殊缓冲区而言）。

错误／异常

如果函数失败了，将引发一个E_NOTICE异常。

更新日志

版本 | 说明
4.2.0 | 添加了布尔返回值。

范例

下面的例子给出了一种去除所有输出缓冲区的方法：

Example #1 ob_end_clean() example

<?php
ob_start();
echo 'Text that won\'t get displayed.';
ob_end_clean();
?>

参见

  • ob_start() - 打开输出控制缓冲
  • ob_get_contents() - 返回输出缓冲区的内容
  • ob_flush() - 冲刷出（送出）输出缓冲区中的内容


冲刷出（送出）输出缓冲区内容并关闭缓冲

  • ? ob_end_clean
  • ob_flush ?
  • PHP Manual
  • Output Control 函数
  • 冲刷出（送出）输出缓冲区内容并关闭缓冲

ob_end_flush

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_end_flush — 冲刷出（送出）输出缓冲区内容并关闭缓冲

说明

ob_end_flush ( ) : bool

这个函数将送出最顶层缓冲区的内容（如果里边有内容的话），并关闭缓冲区。如果想进一步处理缓冲区中的内容，必须在ob_end_flush()之前调用 ob_get_contents()，因为在调用ob_end_flush()后缓冲区内容被丢弃。

Note: 这个函数与ob_get_flush()相似，不同的是ob_get_flush()会把缓冲区中的内容作为字符串返回。

返回值

成功时返回 true， 或者在失败时返回 false。 错误的原因首先是，在调用时没有一个起作用的缓冲区，或者是因为某些原因缓冲区不能被删除（可能对特殊缓冲区而言）。

错误／异常

如果函数失败了，将引发一个E_NOTICE异常。

更新日志

版本 | 说明
4.2.0 | 添加了布尔返回值。

范例

Example #1 ob_end_flush() example

下面的例子给出了一种送出缓冲区内容并关闭所有输出缓冲区的容易的方法：

<?php
  while (@ob_end_flush());
?>

参见

  • ob_start() - 打开输出控制缓冲
  • ob_get_contents() - 返回输出缓冲区的内容
  • ob_get_flush() - 刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。
  • ob_flush() - 冲刷出（送出）输出缓冲区中的内容
  • ob_end_clean() - 清空（擦除）缓冲区并关闭输出缓冲


冲刷出（送出）输出缓冲区中的内容

  • ? ob_end_flush
  • ob_get_clean ?
  • PHP Manual
  • Output Control 函数
  • 冲刷出（送出）输出缓冲区中的内容

ob_flush

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ob_flush — 冲刷出（送出）输出缓冲区中的内容

说明

ob_flush ( ) : void

这个函数将送出缓冲区的内容（如果里边有内容的话）。如果想进一步处理缓冲区中的内容，必须在ob_flush()之前调用ob_get_contents() ，因为在调用ob_flush()之后缓冲区内容将被丢弃。

此函数不会销毁输出缓冲区，而像ob_end_flush() 函数会销毁缓冲区。

返回值

没有返回值。

参见

  • ob_get_contents() - 返回输出缓冲区的内容
  • ob_clean() - 清空（擦掉）输出缓冲区
  • ob_end_flush() - 冲刷出（送出）输出缓冲区内容并关闭缓冲
  • ob_end_clean() - 清空（擦除）缓冲区并关闭输出缓冲


得到当前缓冲区的内容并删除当前输出缓。

  • ? ob_flush
  • ob_get_contents ?
  • PHP Manual
  • Output Control 函数
  • 得到当前缓冲区的内容并删除当前输出缓。

ob_get_clean

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ob_get_clean — 得到当前缓冲区的内容并删除当前输出缓。

说明

ob_get_clean ( ) : string

得到当前缓冲区的内容并删除当前输出缓冲区。

ob_get_clean() 实质上是一起执行了
ob_get_contents() 和
ob_end_clean()。

返回值

返回输出缓冲区的内容，并结束输出缓冲区。如果输出缓冲区不是活跃的，即返回 false 。

范例

Example #1 A simple ob_get_clean() example

<?php

ob_start();

echo "Hello World";

$out = ob_get_clean();
$out = strtolower($out);

var_dump($out);
?>

以上例程会输出：

string(11) "hello world"

参见

  • ob_get_contents() - 返回输出缓冲区的内容
  • ob_start() - 打开输出控制缓冲


返回输出缓冲区的内容

  • ? ob_get_clean
  • ob_get_flush ?
  • PHP Manual
  • Output Control 函数
  • 返回输出缓冲区的内容

ob_get_contents

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_get_contents — 返回输出缓冲区的内容

说明

ob_get_contents ( ) : string

只是得到输出缓冲区的内容，但不清除它。

返回值

此函数返回输出缓冲区的内容，或者如果输出缓冲区无效将返回false 。

范例

Example #1 A simple ob_get_contents() example

<?php

ob_start();

echo "Hello ";

$out1 = ob_get_contents();

echo "World";

$out2 = ob_get_contents();

ob_end_clean();

var_dump($out1, $out2);
?>

以上例程会输出：

string(6) "Hello "
string(11) "Hello World"

参见

  • ob_start() - 打开输出控制缓冲
  • ob_get_length() - 返回输出缓冲区内容的长度


刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。

  • ? ob_get_contents
  • ob_get_length ?
  • PHP Manual
  • Output Control 函数
  • 刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。

ob_get_flush

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ob_get_flush — 刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。

说明

ob_get_flush ( ) : string

ob_get_flush() 刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。

Note: 这个函数与ob_end_flush()相似，不同的是本函数还会以字符串形式返回缓冲区内容。

返回值

返回输出缓冲区的内容；或者是，如果没有起作用的输出缓冲区，返回false 。

范例

Example #1 ob_get_flush() example

<?php
//using output_buffering=On
print_r(ob_list_handlers());

//save buffer in a file
$buffer = ob_get_flush();
file_put_contents('buffer.txt', $buffer);

print_r(ob_list_handlers());
?>

以上例程会输出：

Array
(
    [0] => default output handler
)
Array
(
)

参见

  • ob_end_clean() - 清空（擦除）缓冲区并关闭输出缓冲
  • ob_end_flush() - 冲刷出（送出）输出缓冲区内容并关闭缓冲
  • ob_list_handlers() - 列出所有使用中的输出处理程序。


返回输出缓冲区内容的长度

  • ? ob_get_flush
  • ob_get_level ?
  • PHP Manual
  • Output Control 函数
  • 返回输出缓冲区内容的长度

ob_get_length

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

ob_get_length — 返回输出缓冲区内容的长度

说明

ob_get_length ( ) : int

此函数将返回输出缓中冲区内容的长度。

返回值

返回输出缓冲区内容的长度；或者返回false——如果没有起作用的缓冲区。

范例

Example #1 A simple ob_get_length() example

<?php

ob_start();

echo "Hello ";

$len1 = ob_get_length();

echo "World";

$len2 = ob_get_length();

ob_end_clean();

echo $len1 . ", ." . $len2;
?>

以上例程会输出：

6, 11

参见

  • ob_start() - 打开输出控制缓冲
  • ob_get_contents() - 返回输出缓冲区的内容


返回输出缓冲机制的嵌套级别

  • ? ob_get_length
  • ob_get_status ?
  • PHP Manual
  • Output Control 函数
  • 返回输出缓冲机制的嵌套级别

ob_get_level

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ob_get_level — 返回输出缓冲机制的嵌套级别

说明

ob_get_level ( ) : int

返回输出缓冲机制的嵌套级别。

返回值

返回嵌套的输出缓冲处理程序的级别；或者是，如果输出缓冲区不起作用，返回零。

参见

  • ob_start() - 打开输出控制缓冲
  • ob_get_contents() - 返回输出缓冲区的内容


得到所有输出缓冲区的状态

  • ? ob_get_level
  • ob_gzhandler ?
  • PHP Manual
  • Output Control 函数
  • 得到所有输出缓冲区的状态

ob_get_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ob_get_status — 得到所有输出缓冲区的状态

说明

ob_get_status ( bool $full_status = FALSE ) : array

ob_get_status()返回最顶层输出缓冲区的状态信息；或者如果full_status设为true，返回所有有效的输出缓冲级别。

参数

full_status

设为true 返回所有有效的输出缓冲区级别的状态信息。如果设为 false 或者没有设置，仅返回最 顶层输出缓冲区的状态信息。

返回值

如果调用时没有full_status参数，或者full_status = false 将返回一个包含下面元素的简单数组：

Array
(
    [level] => 2
    [type] => 0
    [status] => 0
    [name] => URL-Rewriter
    [del] => 1
)
Simple ob_get_status() results
Key | Value
level | 输出嵌套级别
type | PHP_OUTPUT_HANDLER_INTERNAL (0) 或者 PHP_OUTPUT_HANDLER_USER (1)
status | PHP_OUTPUT_HANDLER_START (0), PHP_OUTPUT_HANDLER_CONT (1) or PHP_OUTPUT_HANDLER_END (2) 三个之一
name | 起作用的输出处理程序的名字，或者是默认的输出处理程序的名字（如果没有设置的话）
del | 由ob_start()设置的删除标签（Erase-flag）

如果调用时full_status = true，将返回一个数组，该数组的每个元素包含有效的输出缓冲区级别的状态信息。缓冲区的级别数用来当作数组的第一维数；每个元素自身是另一个数组，它持有该有效输出级别的状态信息。

Array
(
    [0] => Array
        (
            [chunk_size] => 0
            [size] => 40960
            [block_size] => 10240
            [type] => 1
            [status] => 0
            [name] => default output handler
            [del] => 1
        )

    [1] => Array
        (
            [chunk_size] => 0
            [size] => 40960
            [block_size] => 10240
            [type] => 0
            [buffer_size] => 0
            [status] => 0
            [name] => URL-Rewriter
            [del] => 1
        )

)

完整的输出包含以下附加元素：

完整的ob_get_status() 结果
Key | Value
chunk_size | 由 ob_start()设置的Chunk size值
size | ...
blocksize | ...

参见

  • ob_get_level() - 返回输出缓冲机制的嵌套级别
  • ob_list_handlers() - 列出所有使用中的输出处理程序。


在ob_start中使用的用来压缩输出缓冲区中内容的回调函数。ob_start callback function to gzip output buffer

  • ? ob_get_status
  • ob_implicit_flush ?
  • PHP Manual
  • Output Control 函数
  • 在ob_start中使用的用来压缩输出缓冲区中内容的回调函数。ob_start callback function to gzip output buffer

ob_gzhandler

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ob_gzhandler — 在ob_start中使用的用来压缩输出缓冲区中内容的回调函数。ob_start callback function to gzip output buffer

说明

ob_gzhandler ( string $buffer , int $mode ) : string

ob_gzhandler()目的是用在ob_start()中作回调函数，以方便将gz 编码的数据发送到支持压缩页面的浏览器。在ob_gzhandler()真正发送压缩过的数据之前，该 函数会确定（判定）浏览器可以接受哪种类型内容编码（"gzip","deflate",或者根本什么都不支持），然后 返回相应的输出。 所有可以发送正确头信息表明他自己可以接受压缩的网页的浏览器，都可以支持。 All browsers are supported since it's up to the browser to send the correct header saying that it accepts compressed web pages. 如果一个浏览器不支持压缩过的页面，此函数返回false。

参数

buffer

mode

返回值

更新日志

版本 | 说明
4.0.5 | 填加了 mode 参数。

范例

Example #1 ob_gzhandler() example

<?php

ob_start("ob_gzhandler");

?>
<html>
<body>
<p>This should be a compressed page.</p>
</html>
<body>

注释

Note:

ob_gzhandler() 需要 zlib 扩展。

Note:

不能同时使用ob_gzhandler() 和 zlib.output_compression。 也要注意使用 zlib.output_compression 要优于 ob_gzhandler()。

参见

  • ob_start() - 打开输出控制缓冲
  • ob_end_flush() - 冲刷出（送出）输出缓冲区内容并关闭缓冲


打开/关闭绝对刷送

  • ? ob_gzhandler
  • ob_list_handlers ?
  • PHP Manual
  • Output Control 函数
  • 打开/关闭绝对刷送

ob_implicit_flush

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_implicit_flush — 打开/关闭绝对刷送

说明

ob_implicit_flush ( int $flag = true ) : void

ob_implicit_flush()将打开或关闭绝对（隐式）刷送。绝对（隐式）刷送将导致在每次输出调用后有一次刷送操作，以便不再需要对 flush() 的显式调用。

参数

flag

设为true 打开绝对刷送，反之是 false 。

返回值

没有返回值。

参见

  • flush() - 刷新输出缓冲
  • ob_start() - 打开输出控制缓冲
  • ob_end_flush() - 冲刷出（送出）输出缓冲区内容并关闭缓冲


列出所有使用中的输出处理程序。

  • ? ob_implicit_flush
  • ob_start ?
  • PHP Manual
  • Output Control 函数
  • 列出所有使用中的输出处理程序。

ob_list_handlers

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ob_list_handlers — 列出所有使用中的输出处理程序。

说明

ob_list_handlers ( ) : array

列出所有使用中的输出处理程序。

返回值

此函数将返回一个数组，数组元素是正在使用中输出处理程序名（如果存在的输出处理程序的话）。 如果启用了output_buffering 或者在 ob_start() 中创建了一个匿名函数，ob_list_handlers() 将返回 "default output handler"。

范例

Example #1 ob_list_handlers() example

<?php
//using output_buffering=On
print_r(ob_list_handlers());
ob_end_flush();

ob_start("ob_gzhandler");
print_r(ob_list_handlers());
ob_end_flush();

// anonymous functions
ob_start(create_function('$string', 'return $string;'));
print_r(ob_list_handlers());
ob_end_flush();
?>

以上例程会输出：

Array
(
    [0] => default output handler
)

Array
(
    [0] => ob_gzhandler
)

Array
(
    [0] => default output handler
)

参见

  • ob_end_clean() - 清空（擦除）缓冲区并关闭输出缓冲
  • ob_end_flush() - 冲刷出（送出）输出缓冲区内容并关闭缓冲
  • ob_get_flush() - 刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。
  • ob_start() - 打开输出控制缓冲


打开输出控制缓冲

  • ? ob_list_handlers
  • output_add_rewrite_var ?
  • PHP Manual
  • Output Control 函数
  • 打开输出控制缓冲

ob_start

(PHP 4, PHP 5, PHP 7, PHP 8)

ob_start — 打开输出控制缓冲

说明

ob_start ( callable $output_callback = null , int $chunk_size = 0 , int $flags = PHP_OUTPUT_HANDLER_STDFLAGS ) : bool

此函数将打开输出缓冲。当输出缓冲激活后，脚本将不会输出内容（除http标头外），相反需要输出的内容被存储在内部缓冲区中。

内部缓冲区的内容可以用 ob_get_contents() 函数复制到一个字符串变量中。
想要输出存储在内部缓冲区中的内容，可以使用 ob_end_flush() 函数。另外，
使用 ob_end_clean() 函数会静默丢弃掉缓冲区的内容。

Warning

当有正在调用的回调函数时，一些网络服务器（例如Apache）会改变一个脚本的工作目录。 你可以在回调函数中再把它改回来，例如 chdir(dirname($_SERVER['SCRIPT_FILENAME'])) 。

输出缓冲区是可堆叠的，这即意谓着，当有一个 ob_start() 是活跃的时，
你可以调用另一个 ob_start() 。
只要确保又正确调用了 ob_end_flush() 恰当的次数即可。
如果有多重输出回调函数是活跃的，输出内容会一直按嵌套的顺序依次通过它们而被过滤。

参数

output_callback

可选参数 output_callback 函数可以被指定。 此函数把一个字符串当作参数并返回一个字符串。 当输出缓冲区被( ob_flush(), ob_clean() 或者相似的函数)冲刷（送出）或者被清洗的时候；或者在请求结束之际输出缓冲区内容被冲刷到浏览器的时候该函数将会被调用。 当调用 output_callback 时，它将收到输出缓冲区的内容作为参数 并预期返回一个新的输出缓冲区作为结果，这个新返回的输出缓冲区内容将被送到浏览器。 如果这个 output_callback 不是一个可以调用的函数，此函数 会返回 false。以下是回调签名：

handler ( string $buffer , int $phase = ? ) : string
buffer
输出缓冲区中的内容。
phase
比特掩码 PHP_OUTPUT_HANDLER_* 常量。

如果 output_callback 返回 false ，其原来的输入 内容被直接送到浏览器。

这个参数 output_callback 可以通过直接给一个 null 值而避开。

ob_end_clean(), ob_end_flush(), ob_clean(), ob_flush() 和 ob_start() 不能从一个回调函数中调用。 如果从回调函数中调用了它们，产生的行为是不明确的。 如果想要删除缓冲区的内容，从回调函数中返回一个"" (空字符串)。 更不能从一个回调函数中使用像print_r($expression, true) 或highlight_file($filename, true) 一样的输出缓冲函数。

Note:

ob_gzhandler() function exists to facilitate sending gz-encoded data to web browsers that support compressed web pages. ob_gzhandler() determines what type of content encoding the browser will accept and will return its output accordingly.

chunk_size

如果可选参数 chunk_size 被赋值了，在任何一个能引起缓冲区的长度等于 或超过 chunk_size 的输出操作后，缓冲区都会被刷送。 默认值 0 意味着函数仅在最后被调用。

PHP 5.4.0 之前，1 是一个特殊情况下的值，代表将 chunk_size 设置为 4096 字节。

flags

flags 参数代表了一个掩码位，用来控制对缓冲区的操作。 The default is to allow output buffers to be cleaned, flushed and removed, which can be set explicitly via PHP_OUTPUT_HANDLER_CLEANABLE | PHP_OUTPUT_HANDLER_FLUSHABLE | PHP_OUTPUT_HANDLER_REMOVABLE, or PHP_OUTPUT_HANDLER_STDFLAGS as shorthand.

每个标志都控制着对一组功能的访问，详细介绍如下：

Constant | Functions
PHP_OUTPUT_HANDLER_CLEANABLE | ob_clean(), ob_end_clean() 和 ob_get_clean()。
PHP_OUTPUT_HANDLER_FLUSHABLE | ob_end_flush(), ob_flush() 和 ob_get_flush()。
PHP_OUTPUT_HANDLER_REMOVABLE | ob_end_clean(), ob_end_flush() 和 ob_get_flush()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 用户自定义回调函数的例子

<?php

function callback($buffer)
{
  // replace all the apples with oranges
  return (str_replace("apples", "oranges", $buffer));
}

ob_start("callback");

?>
<html>
<body>
<p>It's like comparing apples to oranges.</p>
</body>
</html>
<?php

ob_end_flush();

?>

以上例程会输出：

<html>
<body>
<p>It's like comparing oranges to oranges.</p>
</body>
</html>

Example #2 以兼容 PHP 5.3 和 5.4 的方式创建一个不可擦除的输出缓冲区

<?php

if (version_compare(PHP_VERSION, '5.4.0', '>=')) {
  ob_start(null, 0, PHP_OUTPUT_HANDLER_STDFLAGS ^
    PHP_OUTPUT_HANDLER_REMOVABLE);
} else {
  ob_start(null, 0, false);
}

?>

参见

  • ob_get_contents() - 返回输出缓冲区的内容
  • ob_end_clean() - 清空（擦除）缓冲区并关闭输出缓冲
  • ob_end_flush() - 冲刷出（送出）输出缓冲区内容并关闭缓冲
  • ob_implicit_flush() - 打开/关闭绝对刷送
  • ob_gzhandler() - 在ob_start中使用的用来压缩输出缓冲区中内容的回调函数。ob_start callback function to gzip output buffer
  • ob_iconv_handler() - 以输出缓冲处理程序转换字符编码
  • mb_output_handler() - 在输出缓冲中转换字符编码的回调函数
  • ob_tidyhandler() - ob_start callback function to repair the buffer


添加URL重写器的值（Add URL rewriter values）

  • ? ob_start
  • output_reset_rewrite_vars ?
  • PHP Manual
  • Output Control 函数
  • 添加URL重写器的值（Add URL rewriter values）

output_add_rewrite_var

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

output_add_rewrite_var — 添加URL重写器的值（Add URL rewriter values）

说明

output_add_rewrite_var ( string $name , string $value ) : bool

此函数给URL重写机制添加名/值对。 这种名值对将被添加到URL（以GET参数的形式）和表单（以input隐藏域的形式），当透明URL重写用 session.use_trans_sid 开启时同样可以添加到session ID。 要注意，绝对URL(http://example.com/..)不能被重写。

此函数的行为由url_rewriter.tags php.ini 参数控制。

Note: 如果还没有活跃的输出缓冲区，调用此函数将隐式地开启它。

参数

name

变量名。

value

变量值。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 output_add_rewrite_var() example

<?php
output_add_rewrite_var('var', 'value');

// some links
echo '<a href="file.php">link</a>
<a href="http://example.com">link2</a>';

// a form
echo '<form action="script.php" method="post">
<input type="text" name="var2" />
</form>';

print_r(ob_list_handlers());
?>

以上例程会输出：

<a href="file.php?var=value">link</a>
<a href="http://example.com">link2</a>

<form action="script.php" method="post">
<input type="hidden" name="var" value="value" />
<input type="text" name="var2" />
</form>

Array
(
    [0] => URL-Rewriter
)

参见

  • output_reset_rewrite_vars() - 重设URL重写器的值（Reset URL rewriter values）
  • ob_flush() - 冲刷出（送出）输出缓冲区中的内容
  • ob_list_handlers() - 列出所有使用中的输出处理程序。


重设URL重写器的值（Reset URL rewriter values）

  • ? output_add_rewrite_var
  • PHP 选项/信息 ?
  • PHP Manual
  • Output Control 函数
  • 重设URL重写器的值（Reset URL rewriter values）

output_reset_rewrite_vars

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

output_reset_rewrite_vars — 重设URL重写器的值（Reset URL rewriter values）

说明

output_reset_rewrite_vars ( ) : bool

此函数重置URL重写器，移除所有的先前由 output_add_rewrite_var() 函数设置的重写变量，或者移除会话机制（如果session.use_trans_sid 在 session_start()上进行了设置）。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 output_reset_rewrite_vars() example

<?php
session_start();
output_add_rewrite_var('var', 'value');

echo '<a href="file.php">link</a>';
ob_flush();

output_reset_rewrite_vars();
echo '<a href="file.php">link</a>';
?>

以上例程会输出：

<a href="file.php?PHPSESSID=xxx&var=value">link</a>
<a href="file.php">link</a>

参见

  • output_add_rewrite_var() - 添加URL重写器的值（Add URL rewriter values）
  • ob_flush() - 冲刷出（送出）输出缓冲区中的内容
  • ob_list_handlers() - 列出所有使用中的输出处理程序。
  • session_start() - 启动新会话或者重用现有会话


PHP 选项和信息

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • PHP 选项/信息 函数
    • assert_options — 设置/获取断言的各种标志
    • assert — 检查一个断言是否为 false
    • cli_get_process_title — Returns the current process title
    • cli_set_process_title — Sets the process title
    • dl — 运行时载入一个 PHP 扩展
    • extension_loaded — 检查一个扩展是否已经加载
    • gc_collect_cycles — 强制收集所有现存的垃圾循环周期
    • gc_disable — 停用循环引用收集器
    • gc_enable — 激活循环引用收集器
    • gc_enabled — 返回循环引用计数器的状态
    • gc_mem_caches — Reclaims memory used by the Zend Engine memory manager
    • gc_status — Gets information about the garbage collector
    • get_cfg_var — 获取 PHP 配置选项的值
    • get_current_user — 获取当前 PHP 脚本所有者名称
    • get_defined_constants — 返回所有常量的关联数组，键是常量名，值是常量值
    • get_extension_funcs — 返回模块函数名称的数组
    • get_include_path — 获取当前的 include_path 配置选项
    • get_included_files — 返回被 include 和 require 文件名的 array
    • get_loaded_extensions — 返回所有编译并加载模块名的 array
    • get_magic_quotes_gpc — 获取当前 magic_quotes_gpc 的配置选项设置
    • get_magic_quotes_runtime — 获取当前 magic_quotes_runtime 配置选项的激活状态
    • get_required_files — 别名 get_included_files
    • get_resources — Returns active resources
    • getenv — 获取一个环境变量的值
    • getlastmod — 获取页面最后修改的时间
    • getmygid — 获取当前 PHP 脚本拥有者的 GID
    • getmyinode — 获取当前脚本的索引节点（inode）
    • getmypid — 获取 PHP 进程的 ID
    • getmyuid — 获取 PHP 脚本所有者的 UID
    • getopt — 从命令行参数列表中获取选项
    • getrusage — 获取当前资源使用状况
    • ini_alter — 别名 ini_set
    • ini_get_all — 获取所有配置选项
    • ini_get — 获取一个配置选项的值
    • ini_restore — 恢复配置选项的值
    • ini_set — 为一个配置选项设置值
    • main — 虚拟的main
    • memory_get_peak_usage — 返回分配给 PHP 内存的峰值
    • memory_get_usage — 返回分配给 PHP 的内存量
    • php_ini_loaded_file — 取得已加载的 php.ini 文件的路径
    • php_ini_scanned_files — 返回从额外 ini 目录里解析的 .ini 文件列表
    • php_sapi_name — 返回 web 服务器和 PHP 之间的接口类型
    • php_uname — 返回运行 PHP 的系统的有关信息
    • phpcredits — 打印 PHP 贡献者名单
    • phpinfo — 输出关于 PHP 配置的信息
    • phpversion — 获取当前的PHP版本
    • putenv — 设置环境变量的值
    • restore_include_path — 还原 include_path 配置选项的值
    • set_include_path — 设置 include_path 配置选项
    • set_time_limit — 设置脚本最大执行时间
    • sys_get_temp_dir — 返回用于临时文件的目录
    • version_compare — 对比两个「PHP 规范化」的版本数字字符串
    • zend_thread_id — 返回当前线程的唯一识别符
    • zend_version — 获取当前 Zend 引擎的版本


简介

这些函数允许你获得许多关于PHP本身的参数，例如：运行时的配置，被加载的扩展，版本等。 你也将找到设置你的运行中的PHP的选项的函数。可能最好用的 PHP- 函数 phpinfo() 可以在这里找到。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • PHP 选项/信息
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


运行时配置

这些函数的行为受 php.ini 中的设置影响。

PHP 选项 / Info 配置选项
名字 | 默认 | 可修改范围 | 更新日志
assert.active | "1" | PHP_INI_ALL |
assert.bail | "0" | PHP_INI_ALL |
assert.warning | "1" | PHP_INI_ALL |
assert.callback | NULL | PHP_INI_ALL |
assert.quiet_eval | "0" | PHP_INI_ALL |
assert.exception | "0" | PHP_INI_ALL | 自 PHP 7.0.0 起有效。
enable_dl | "1" | PHP_INI_SYSTEM | 本过时特性将肯定会在未来被移除。
max_execution_time | "30" | PHP_INI_ALL |
max_input_time | "-1" | PHP_INI_PERDIR |
max_input_nesting_level | "64" | PHP_INI_PERDIR | 自 PHP 5.2.3 起有效。
max_input_vars | 1000 | PHP_INI_PERDIR | 自 PHP 5.3.9 起有效。
magic_quotes_gpc | "1" | PHP_INI_PERDIR | 在 PHP 5.4.0 中被移除。
magic_quotes_runtime | "0" | PHP_INI_ALL | 在 PHP 5.4.0 中移除
zend.enable_gc | "1" | PHP_INI_ALL | 自 PHP 5.3.0 起有效。
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

assert.active boolean

激活 assert() 断言评测。

assert.bail boolean

失败的断言将中止脚本。

assert.warning boolean

为每个失败的断言产生一条 PHP 警告信息。

assert.callback string

断言失败后要调用的回调函数。

assert.quiet_eval boolean

在 断言表达式执行时 error_reporting() 使用当前的设置。
如果启用了，在执行时错误将不会被显示（隐式的 error_reporting(0)）。
如果禁用了，错误将根据 error_reporting() 的设置来显示。

assert.exception boolean

在断言（assert）失败时产生 AssertionError 异常。

enable_dl boolean

该指令仅对 Apache 模块版本的 PHP 有效。 你可以针对每个虚拟机或每个目录开启或关闭 dl() 动态加载 PHP 模块。

关闭动态加载的主要原因是为了安全。通过动态加载，有可能忽略所有 open_basedir 限制。 默认允许动态加载。

max_execution_time integer

这设置了脚本被解析器中止之前允许的最大执行时间，单位秒。 这有助于防止写得不好的脚本占尽服务器资源。 默认设置为 30。 从 命令行 运行 PHP 时，默认设置为 0。

最大执行时间不会影响系统调用和系统操作等。更多细节参见 set_time_limit()。

你的 web 服务器也可以有其他超时设置，也有可能中断 PHP 的执行。 Apache 有一个 Timeout 指令，IIS 有一个 CGI 超时功能。 他们默认都是 300 秒。更多具体信息参见你的 web 服务器的文档。

max_input_time integer

脚本解析输入数据（类似 POST 和 GET）允许的最大时间，单位是秒。 它从接收所有数据到开始执行脚本进行测量的。默认设置为 -1，意味着使用 max_execution_time 的值做为默认值，如果不想限制，请设置为 0。

max_input_nesting_level integer

设置 输入变量 的最大允许嵌套的深度 (例如 $_GET，$_POST)

max_input_vars integer

接受多少 输入的变量（限制分别应用于 $_GET、$_POST 和 $_COOKIE 超全局变量） 指令的使用减轻了以哈希碰撞来进行拒绝服务攻击的可能性。 如有超过指令指定数量的输入变量，将会导致 E_WARNING 的产生， 更多的输入变量将会从请求中截断。

magic_quotes_gpc boolean
Warning

本特性已自 PHP 5.3.0 起废弃并将自 PHP 5.4.0 起移除。

为 GPC (Get/Post/Cookie) 操作设置 magic_quotes 状态。 当 magic_quotes 为 on，所有的 ' (单引号)、" (双引号)、\（反斜杠）和 NUL's 被一个反斜杠自动转义。

参见 get_magic_quotes_gpc()。

magic_quotes_runtime boolean
Warning

本特性已自 PHP 5.3.0 起废弃并将自 PHP 5.4.0 起移除。

如果启用了 magic_quotes_runtime，大多数返回任何形式外部数据的函数，包括数据库和文本段将会用反斜线转义引号。

受 magic_quotes_runtime 影响的函数（不包括 PECL 里的函数）：

  • get_meta_tags()
  • file_get_contents()
  • file()
  • fgets()
  • fwrite()
  • fread()
  • fputcsv()
  • stream_socket_recvfrom()
  • exec()
  • system()
  • passthru()
  • stream_get_contents()
  • bzread()
  • gzfile()
  • gzgets()
  • gzwrite()
  • gzread()
  • exif_read_data()
  • dba_insert()
  • dba_replace()
  • dba_fetch()
  • ibase_fetch_row()
  • ibase_fetch_assoc()
  • ibase_fetch_object()
  • mssql_fetch_row()
  • mssql_fetch_object()
  • mssql_fetch_array()
  • mssql_fetch_assoc()
  • mysqli_fetch_row()
  • mysqli_fetch_array()
  • mysqli_fetch_assoc()
  • mysqli_fetch_object()
  • pg_fetch_row()
  • pg_fetch_assoc()
  • pg_fetch_array()
  • pg_fetch_object()
  • pg_fetch_all()
  • pg_select()
  • sybase_fetch_object()
  • sybase_fetch_array()
  • sybase_fetch_assoc()
  • SplFileObject::fgets()
  • SplFileObject::fgetcsv()
  • SplFileObject::fwrite()

zend.enable_gc boolean

启用或禁用循环引用记数搜集器。


预定义常量

下列常量作为 PHP 核心的一部分总是可用的。

预定义 phpcredits() 常量
常量 | 值 | 描述
CREDITS_GROUP | 1 | 核心开发者名单
CREDITS_GENERAL | 2 | 总的贡献：语言设计和理念，PHP 作者 和 SAPI 模块。
CREDITS_SAPI | 4 | PHP 的服务器 API 模块列表，以及它们的作者。
CREDITS_MODULES | 8 | PHP 扩展的列表，以及它们的作者。
CREDITS_DOCS | 16 | 文档组的贡献。
CREDITS_FULLPAGE | 32 | 通常与其他标志组合使用。通过其他标志指示了完整独立的 HTML 页面，用于打印包含信息。
CREDITS_QA | 64 | 质量保证团队的贡献。
CREDITS_ALL | -1 | 所有的贡献者，等于使用 CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_QA CREDITS_FULLPAGE。 它以合适的标签产生了完整的独立 HTML 页面。这是默认的值。
phpinfo() 常量
常量 | 值 | 描述
INFO_GENERAL | 1 | 配置行，php.ini 的位置、构建日期，Web 服务器、操作系统及其他。
INFO_CREDITS | 2 | PHP 贡献者。参见 phpcredits()。
INFO_CONFIGURATION | 4 | 当前 PHP 指令的本地（Local）和主（Master）值。参见 ini_get()。
INFO_MODULES | 8 | 已加载的模块和各自的设置。
INFO_ENVIRONMENT | 16 | 环境变量信息在 $_ENV 中亦有效。
INFO_VARIABLES | 32 | 显示所有 EGPCS （环境变量、GET、POST、Cookie、Server）中的预定义变量。
INFO_LICENSE | 64 | PHP 版权信息。参见 » license faq。
INFO_ALL | -1 | 显示以上所有。这是默认值。
INI 常量
常量 | 值 | 描述
INI_USER | 1 | Unused
INI_PERDIR | 2 | Unused
INI_SYSTEM | 4 | Unused
INI_ALL | 7 | Unused

断言常量，这些值用于设置 assert_options() 中的断言标记 。

assert() 常量
常量 | INI 设置 | 描述
ASSERT_ACTIVE | assert.active | 启用 assert()。
ASSERT_CALLBACK | assert.callback | 失败断言的回调函数。
ASSERT_BAIL | assert.bail | 断言失败时中止执行。
ASSERT_WARNING | assert.warning | 为每个失败的断言产生一条 PHP 警告。
ASSERT_QUIET_EVAL | assert.quiet_eval | 在执行断言表达式时禁用 error_reporting。

以下常量仅在主机操作系统是 Windows的情况下有效，能得到不同版本信息，能够检测利用一些功能。 自 PHP 5.3.0 起有效。

Windows 特定常量
常量 | 描述
PHP_WINDOWS_VERSION_MAJOR | windows 主版本，可以是 4 (NT4/Me/98/95)、 5 (XP/2003 R2/2003/2000) 或 6 (Vista/2008/7/8/8.1)。
PHP_WINDOWS_VERSION_MINOR | Windows 副版本号，可以是 0 (Vista/2008/2000/NT4/95)、 1 (XP)、2 (2003 R2/2003/XP x64)、 10 (98) 或 90 (ME)。
PHP_WINDOWS_VERSION_BUILD | Windows 内部版本号(例如 Windows Vista SP1 是 build 6001)
PHP_WINDOWS_VERSION_PLATFORM | PHP 当前运行的平台， Windows Vista/XP/2000/NT4、Server 2008/2003 的值是 2， Windows ME/98/95 下值是 1。
PHP_WINDOWS_VERSION_SP_MAJOR | 安装的 service pack 主版本号，没有安装是 0。 例如， Windows XP service pack 3 上这个值是 3。
PHP_WINDOWS_VERSION_SP_MINOR | 安装的 service pack 副版本号，如果没有安装则是 0 。
PHP_WINDOWS_VERSION_SUITEMASK | The suitemask is a bitmask that can tell if various features of Windows is installed, see the table below for possible bitfield values.
PHP_WINDOWS_VERSION_PRODUCTTYPE | This contains the value used to determine the PHP_WINDOWS_NT_* constants. This value may be one of the PHP_WINDOWS_NT_* constants indicating the platform type.
PHP_WINDOWS_NT_DOMAIN_CONTROLLER | 这是域控制器
PHP_WINDOWS_NT_SERVER | 这是一个服务器系统 (eg. Server 2008/2003/2000)，注意如果这是一个域控制器，通过 PHP_WINDOWS_NT_DOMAIN_CONTROLLER 报告。
PHP_WINDOWS_NT_WORKSTATION | 这是一个工作站系统 (例如 Vista/XP/2000/NT4)

此功能列表可以通过 PHP_WINDOWS_VERSION_SUITEMASK 位掩码检测。

Windows suitemask 位字段
Bits | 描述
0x00000004 | 安装的是 Microsoft BackOffice components。
0x00000400 | 安装的是 Windows Server 2003, Web Edition。
0x00004000 | 安装的是 Windows Server 2003, Compute Cluster Edition。
0x00000080 | 安装的是 Windows Server 2008 Datacenter, Windows Server 2003, Datacenter Edition or Windows 2000 Datacenter Server。
0x00000002 | 安装的是 Windows Server 2008 Enterprise, Windows Server 2003, Enterprise Edition, Windows 2000 Advanced Server 或 Windows NT Server 4.0 Enterprise Edition 。
0x00000040 | 安装的是 Windows XP Embedded。
0x00000200 | 安装的是 Windows Vista Home Premium, Windows Vista Home Basic 或 Windows XP Home Edition。
0x00000100 | Remote Desktop is supported, but only one interactive session is supported. This value is set unless the system is running in application server mode.
0x00000001 | Microsoft Small Business Server was once installed on the system, but may have been upgraded to another version of Windows.
0x00000020 | Microsoft Small Business Server is installed with the restrictive client license in force.
0x00002000 | 安装的是 Windows Storage Server 2003 R2 或 Windows Storage Server 2003。
0x00000010 | 中断服务安装了。这个值总是设置的。如果这个值设置了，但 0x00000100 没有设置，操作系统运行于 application server 模式。
0x00008000 | 安装的是 Windows Home Server。


PHP 选项/信息 函数

Table of Contents

  • assert_options — 设置/获取断言的各种标志
  • assert — 检查一个断言是否为 false
  • cli_get_process_title — Returns the current process title
  • cli_set_process_title — Sets the process title
  • dl — 运行时载入一个 PHP 扩展
  • extension_loaded — 检查一个扩展是否已经加载
  • gc_collect_cycles — 强制收集所有现存的垃圾循环周期
  • gc_disable — 停用循环引用收集器
  • gc_enable — 激活循环引用收集器
  • gc_enabled — 返回循环引用计数器的状态
  • gc_mem_caches — Reclaims memory used by the Zend Engine memory manager
  • gc_status — Gets information about the garbage collector
  • get_cfg_var — 获取 PHP 配置选项的值
  • get_current_user — 获取当前 PHP 脚本所有者名称
  • get_defined_constants — 返回所有常量的关联数组，键是常量名，值是常量值
  • get_extension_funcs — 返回模块函数名称的数组
  • get_include_path — 获取当前的 include_path 配置选项
  • get_included_files — 返回被 include 和 require 文件名的 array
  • get_loaded_extensions — 返回所有编译并加载模块名的 array
  • get_magic_quotes_gpc — 获取当前 magic_quotes_gpc 的配置选项设置
  • get_magic_quotes_runtime — 获取当前 magic_quotes_runtime 配置选项的激活状态
  • get_required_files — 别名 get_included_files
  • get_resources — Returns active resources
  • getenv — 获取一个环境变量的值
  • getlastmod — 获取页面最后修改的时间
  • getmygid — 获取当前 PHP 脚本拥有者的 GID
  • getmyinode — 获取当前脚本的索引节点（inode）
  • getmypid — 获取 PHP 进程的 ID
  • getmyuid — 获取 PHP 脚本所有者的 UID
  • getopt — 从命令行参数列表中获取选项
  • getrusage — 获取当前资源使用状况
  • ini_alter — 别名 ini_set
  • ini_get_all — 获取所有配置选项
  • ini_get — 获取一个配置选项的值
  • ini_restore — 恢复配置选项的值
  • ini_set — 为一个配置选项设置值
  • main — 虚拟的main
  • memory_get_peak_usage — 返回分配给 PHP 内存的峰值
  • memory_get_usage — 返回分配给 PHP 的内存量
  • php_ini_loaded_file — 取得已加载的 php.ini 文件的路径
  • php_ini_scanned_files — 返回从额外 ini 目录里解析的 .ini 文件列表
  • php_sapi_name — 返回 web 服务器和 PHP 之间的接口类型
  • php_uname — 返回运行 PHP 的系统的有关信息
  • phpcredits — 打印 PHP 贡献者名单
  • phpinfo — 输出关于 PHP 配置的信息
  • phpversion — 获取当前的PHP版本
  • putenv — 设置环境变量的值
  • restore_include_path — 还原 include_path 配置选项的值
  • set_include_path — 设置 include_path 配置选项
  • set_time_limit — 设置脚本最大执行时间
  • sys_get_temp_dir — 返回用于临时文件的目录
  • version_compare — 对比两个「PHP 规范化」的版本数字字符串
  • zend_thread_id — 返回当前线程的唯一识别符
  • zend_version — 获取当前 Zend 引擎的版本


设置/获取断言的各种标志

  • ? PHP 选项/信息 函数
  • assert ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 设置/获取断言的各种标志

assert_options

(PHP 4, PHP 5, PHP 7, PHP 8)

assert_options — 设置/获取断言的各种标志

说明

assert_options ( int $what , mixed $value = ? ) : mixed

设置 assert() 的各种控制选项，或者是仅仅查询当前的设置。

参数

what

断言标志
标志 | INI 设置 | 默认值 | 描述
ASSERT_ACTIVE | assert.active | 1 | 启用 assert() 断言
ASSERT_WARNING | assert.warning | 1 | 为每个失败的断言产生一个 PHP 警告（warning）
ASSERT_BAIL | assert.bail | 0 | 在断言失败时中止执行
ASSERT_QUIET_EVAL | assert.quiet_eval | 0 | 在断言表达式求值时禁用 error_reporting
ASSERT_CALLBACK | assert.callback | (null) | 断言失败时调用回调函数

value

标志的新值。

返回值

返回任意标志的原始设置，出错时返回 false。

范例

Example #1 assert_options() 例子

<?php
// 处理断言失败时的函数
function assert_failure()
{
    echo 'Assert failed';
}

// 我们的测试函数
function test_assert($parameter)
{
    assert(is_bool($parameter));
}

// 设置断言标志
assert_options(ASSERT_ACTIVE,   true);
assert_options(ASSERT_BAIL,     true);
assert_options(ASSERT_WARNING,  false);
assert_options(ASSERT_CALLBACK, 'assert_failure');

// 让一个断言会失败
test_assert(1);

// 由于 ASSERT_BAIL 是 true，这里永远也到不了
echo 'Never reached';
?>

参见

  • assert() - 检查一个断言是否为 false


检查一个断言是否为 false

  • ? assert_options
  • cli_get_process_title ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 检查一个断言是否为 false

assert

(PHP 4, PHP 5, PHP 7, PHP 8)

assert — 检查一个断言是否为 false

说明

PHP 5

assert ( mixed $assertion , string $description = ? ) : bool

PHP 7

assert ( mixed $assertion , Throwable $exception = ? ) : bool

assert() 会检查指定的 assertion 并在结果为 false 时采取适当的行动。

Traditional assertions (PHP 5 and 7)

如果 assertion 是字符串，它将会被 assert() 当做 PHP 代码来执行。 assertion 是字符串的优势是当禁用断言时它的开销会更小，并且在断言失败时消息会包含 assertion 表达式。 这意味着如果你传入了 boolean 的条件作为 assertion，这个条件将不会显示为断言函数的参数；在调用你定义的 assert_options() 处理函数时，条件会转换为字符串，而布尔值 false 会被转换成空字符串。

断言这个功能应该只被用来调试。 你应该用于完整性检查时测试条件是否始终应该为 true，来指示某些程序错误，或者检查具体功能的存在（类似扩展函数或特定的系统限制和功能）。

断言不应该用于普通运行时操作，类似输入参数的检查。 作为一个经验法则，在断言禁用时你的代码也应该能够正确地运行。

assert() 的行为可以通过 assert_options() 来配置，或者手册页面上描述的 .ini 设置。

assert_options() ASSERT_CALLBACK 配置指令允许设置回调函数来处理失败的断言。

assert() 回调函数在构建自动测试套件的时候尤其有用，因为它们允许你简易地捕获传入断言的代码，并包含断言的位置信息。 当信息能够被其他方法捕获，使用断言可以让它更快更方便！

回调函数应该接受三个参数。 第一个参数包括了断言失败所在的文件。 第二个参数包含了断言失败所在的行号，第三个参数包含了失败的表达式（如有任意 — 字面值例如 1 或者 "two" 将不会传递到这个参数）。 PHP 5.4.8 及更高版本的用户也可以提供第四个可选参数，如果设置了，用于将 description 指定到 assert()。

Expectations (PHP 7 only)

assert() is a language construct in PHP 7, allowing for the definition of expectations: assertions that take effect in development and testing environments, but are optimised away to have zero cost in production.

While assert_options() can still be used to control behaviour as described above for backward compatibility reasons, PHP 7 only code should use the two new configuration directives to control the behaviour of assert() and not call assert_options().

PHP 7 configuration directives for assert()
Directive Default value Possible values
zend.assertions 1
  • 1: generate and execute code (development mode)
  • 0: generate code but jump around it at runtime
  • -1: do not generate code (production mode)
assert.exception 0
  • 1: throw when the assertion fails, either by throwing the object provided as the exception or by throwing a new AssertionError object if exception wasn't provided
  • 0: use or generate a Throwable as described above, but only generate a warning based on that object rather than throwing it (compatible with PHP 5 behaviour)

参数

assertion

断言。In PHP 5, this must be either a string to be evaluated or a boolean to be tested. In PHP 7, this may also be any expression that returns a value, which will be executed and the result used to indicate whether the assertion succeeded or failed.

description

如果 assertion 失败了，选项 description 将会包括在失败信息里。

exception

In PHP 7, the second parameter can be a Throwable object instead of a descriptive string, in which case this is the object that will be thrown if the assertion fails and the assert.exception configuration directive is enabled.

返回值

assertion 是 false 则返回 false，否则是 true。

更新日志

版本 | 说明
7.0.0 | assert() is now a language construct and not a function. assertion() can now be an expression. The second parameter is now interpreted either as an exception (if a Throwable object is given), or as the description supported from PHP 5.4.8 onwards.
5.4.8 | 增加了参数 description。 description 现在也作为第四个参数提供给 ASSERT_CALLBACK 模式里的回调函数。

范例

Traditional assertions (PHP 5 and 7)

Example #1 使用自定义处理程序处理失败的断言

<?php
// 激活断言，并设置它为 quiet
assert_options(ASSERT_ACTIVE, 1);
assert_options(ASSERT_WARNING, 0);
assert_options(ASSERT_QUIET_EVAL, 1);

//创建处理函数
function my_assert_handler($file, $line, $code)
{
    echo "<hr>Assertion Failed:
        File '$file'<br />
        Line '$line'<br />
        Code '$code'<br /><hr />";
}

// 设置回调函数
assert_options(ASSERT_CALLBACK, 'my_assert_handler');

// 让一则断言失败
assert('mysql_query("")');
?>

Example #2 使用自定义处理器打印描述信息

<?php
// 激活断言，并设置它为 quiet
assert_options(ASSERT_ACTIVE, 1);
assert_options(ASSERT_WARNING, 0);
assert_options(ASSERT_QUIET_EVAL, 1);

//创建处理函数
function my_assert_handler($file, $line, $code, $desc = null)
{
    echo "Assertion failed at $file:$line: $code";
    if ($desc) {
        echo ": $desc";
    }
    echo "\n";
}

// 设置回调函数
assert_options(ASSERT_CALLBACK, 'my_assert_handler');

// Make an assertion that should fail
assert('2 < 1');
assert('2 < 1', 'Two is less than one');
?>

以上例程会输出：

Assertion failed at test.php:21: 2 < 1
Assertion failed at test.php:22: 2 < 1: Two is less than one

Expectations (PHP 7 only)

Example #3 Expectations without a custom exception

<?php
assert(true == false);
echo 'Hi!';
?>

With zend.assertions set to 0, the above example will output:

Hi!

With zend.assertions set to 1 and assert.exception set to 0, the above example will output:

Warning: assert(): assert(true == false) failed in - on line 2
Hi!

With zend.assertions set to 1 and assert.exception set to 1, the above example will output:

Fatal error: Uncaught AssertionError: assert(true == false) in -:2
Stack trace:
#0 -(2): assert(false, 'assert(true == ...')
#1 {main}
  thrown in - on line 2

Example #4 Expectations with a custom exception

<?php
class CustomError extends AssertionError {}

assert(true == false, new CustomError('True is not false!'));
echo 'Hi!';
?>

With zend.assertions set to 0, the above example will output:

Hi!

With zend.assertions set to 1 and assert.exception set to 0, the above example will output:

Warning: assert(): CustomError: True is not false! in -:4
Stack trace:
#0 {main} failed in - on line 4
Hi!

With zend.assertions set to 1 and assert.exception set to 1, the above example will output:

Fatal error: Uncaught CustomError: True is not false! in -:4
Stack trace:
#0 {main}
  thrown in - on line 4

参见

  • assert_options() - 设置/获取断言的各种标志


Returns the current process title

  • ? assert
  • cli_set_process_title ?
  • PHP Manual
  • PHP 选项/信息 函数
  • Returns the current process title

cli_get_process_title

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

cli_get_process_title — Returns the current process title

说明

cli_get_process_title ( ) : string|null

Returns the current process title, as set by cli_set_process_title(). Note that this may not exactly match what is shown in ps or top, depending on your operating system.

This function is available only in CLI mode.

参数

此函数没有参数。

返回值

Return a string with the current process title or null on error.

错误／异常

An E_WARNING will be generated if the operating system is unsupported.

范例

Example #1 cli_get_process_title() example

<?php
echo "Process title: " . cli_get_process_title() . "\n";
?>

参见

  • cli_set_process_title() - Sets the process title


Sets the process title

  • ? cli_get_process_title
  • dl ?
  • PHP Manual
  • PHP 选项/信息 函数
  • Sets the process title

cli_set_process_title

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

cli_set_process_title — Sets the process title

说明

cli_set_process_title ( string $title ) : bool

Sets the process title visible in tools such as top and ps. This function is available only in CLI mode.

参数

title

The new title.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

An E_WARNING will be generated if the operating system is unsupported.

范例

Example #1 cli_set_process_title() example

<?php
$title = "My Amazing PHP Script";
$pid = getmypid(); // you can use this to see your process title in ps

if (!cli_set_process_title($title)) {
    echo "Unable to set process title for PID $pid...\n";
    exit(1);
} else {
    echo "The process title '$title' for PID $pid has been set for your process!\n";
    sleep(5);
}
?>

参见

  • cli_get_process_title() - Returns the current process title
  • setproctitle() - Set the process title


运行时载入一个 PHP 扩展

  • ? cli_set_process_title
  • extension_loaded ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 运行时载入一个 PHP 扩展

dl

(PHP 4, PHP 5, PHP 7, PHP 8)

dl — 运行时载入一个 PHP 扩展

说明

dl ( string $library ) : bool

载入指定参数 library 的 PHP 扩展。

使用 extension_loaded() 来测试指定的扩展是否已经激活。 这既能用于内建的扩展也可以用于动态加载的扩展（既可以通过 php.ini 也可以通过 dl()）。

Warning

在 PHP 5.3 里，此函数被某些 SAPI 移除了。

参数

library

此参数仅仅是要加载的扩展的文件名，依赖于你的平台。 比如，sockets（作为共享模块编译，而不是默认的！）在 Unix 平台上称为 sockets.so 而 在 Windows 平台上是 php_sockets.dll。

扩展加载的目录依赖于你的平台：

Windows - 如果没有在 php.ini 里明确设置，扩展默认会从 C:\php5\ 加载。

Unix - 如果没有在 php.ini 里明确设置，默认的扩展目录依赖于

  • PHP 是否通过 --enable-debug 选项构建
  • PHP 是否以（实验性质的）ZTS （Zned 线程安全）支持构建
  • 当前的内部 ZEND_MODULE_API_NO（Zend 内部模块 API 数字，基本上是主要模块修改时的日期）
考虑到上述，目录默认为 <install-dir>/lib/php/extensions/ <debug-or-not>-<zts-or-not>-ZEND_MODULE_API_NO，例如 /usr/local/php/lib/php/extensions/debug-non-zts-20010901 或 /usr/local/php/lib/php/extensions/no-debug-zts-20010901。

返回值

成功时返回 true， 或者在失败时返回 false。 如果加载模块的功能是无效或者禁用的（可以关闭 enable_dl 设置）将导致一个 E_ERROR 并中断执行。 如果因为指定的库无法加载而导致 dl() 失败，除了返回 false，还会产生一个 E_WARNING 的消息。

范例

Example #1 dl() 例子

<?php
// 加载一个扩展的例子，基于操作系统
if (!extension_loaded('sqlite')) {
    if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
        dl('php_sqlite.dll');
    } else {
        dl('sqlite.so');
    }
}

// 或者，使用常量 PHP_SHLIB_SUFFIX
if (!extension_loaded('sqlite')) {
    $prefix = (PHP_SHLIB_SUFFIX === 'dll') ? 'php_' : '';
    dl($prefix . 'sqlite.' . PHP_SHLIB_SUFFIX);
}
?>

注释

Note:

当 PHP 以支持 ZTS 构建时，不支持 dl()。 使用 扩展加载指令 作为替代。

Note:

在某些 Unix 平台上，dl() 是大小写敏感的。

参见

  • 扩展加载指令
  • extension_loaded() - 检查一个扩展是否已经加载


检查一个扩展是否已经加载

  • ? dl
  • gc_collect_cycles ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 检查一个扩展是否已经加载

extension_loaded

(PHP 4, PHP 5, PHP 7, PHP 8)

extension_loaded — 检查一个扩展是否已经加载

说明

extension_loaded ( string $name ) : bool

检查一个扩展是否已经加载。

参数

name

扩展名称，大小写不敏感。

你可以用 phpinfo() 来查看一系列扩展名称，而在 CGI 或 CLI 的 PHP 版本里你可以使用 -m 参数来列出所有有效的扩展：

$ php -m
[PHP Modules]
xml
tokenizer
standard
sockets
session
posix
pcre
overload
mysql
mbstring
ctype

[Zend Modules]

返回值

如果 name 指定的扩展已加载，返回true，否则返回 false。

范例

Example #1 extension_loaded() 例子

<?php
if (!extension_loaded('gd')) {
    if (!dl('gd.so')) {
        exit;
    }
}
?>

参见

  • get_loaded_extensions() - 返回所有编译并加载模块名的 array
  • get_extension_funcs() - 返回模块函数名称的数组
  • phpinfo() - 输出关于 PHP 配置的信息
  • dl() - 运行时载入一个 PHP 扩展
  • function_exists() - 如果给定的函数已经被定义就返回 true


强制收集所有现存的垃圾循环周期

  • ? extension_loaded
  • gc_disable ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 强制收集所有现存的垃圾循环周期

gc_collect_cycles

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gc_collect_cycles — 强制收集所有现存的垃圾循环周期

说明

gc_collect_cycles ( ) : int

强制收集所有现存的垃圾循环周期。

参数

此函数没有参数。

返回值

返回收集的循环数量。

参见

  • 垃圾回收机制


停用循环引用收集器

  • ? gc_collect_cycles
  • gc_enable ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 停用循环引用收集器

gc_disable

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gc_disable — 停用循环引用收集器

说明

gc_disable ( ) : void

停用循环引用收集器，设置 zend.enable_gc 为 0。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • 垃圾回收机制


激活循环引用收集器

  • ? gc_disable
  • gc_enabled ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 激活循环引用收集器

gc_enable

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gc_enable — 激活循环引用收集器

说明

gc_enable ( ) : void

设置 zend.enable_gc 为 1， 激活循环引用收集器。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • 垃圾回收机制


返回循环引用计数器的状态

  • ? gc_enable
  • gc_mem_caches ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回循环引用计数器的状态

gc_enabled

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gc_enabled — 返回循环引用计数器的状态

说明

gc_enabled ( ) : bool

返回循环引用计数器的状态。

参数

此函数没有参数。

返回值

如果垃圾收集器已启用则返回 true，否则返回 false。

范例

Example #1 一个 gc_enabled() 例子

<?php
if(gc_enabled()) gc_collect_cycles();
?>

参见

  • 垃圾回收机制


Reclaims memory used by the Zend Engine memory manager

  • ? gc_enabled
  • gc_status ?
  • PHP Manual
  • PHP 选项/信息 函数
  • Reclaims memory used by the Zend Engine memory manager

gc_mem_caches

(PHP 7, PHP 8)

gc_mem_caches — Reclaims memory used by the Zend Engine memory manager

说明

gc_mem_caches ( ) : int

Reclaims memory used by the Zend Engine memory manager.

参数

此函数没有参数。

返回值

Returns the number of bytes freed.

参见

  • Garbage Collection


Gets information about the garbage collector

  • ? gc_mem_caches
  • get_cfg_var ?
  • PHP Manual
  • PHP 选项/信息 函数
  • Gets information about the garbage collector

gc_status

(PHP 7 >= 7.3.0, PHP 8)

gc_status — Gets information about the garbage collector

说明

gc_status ( ) : array

Gets information about the current state of the garbage collector.

参数

此函数没有参数。

返回值

Returns an associative array with the following elements:

  • "runs"
  • "collected"
  • "threshold"
  • "roots"

范例

Example #1 gc_status() Usage

<?php

// create object tree that needs gc collection
$a = new stdClass();
$a->b = [];
for ($i = 0; $i < 100000; $i++) {
    $b = new stdClass();
    $b->a = $a;
    $a->b[] = $b;
}
unset($a);
unset($b);
gc_collect_cycles();

var_dump(gc_status());

以上例程的输出类似于：

array(4) {
  ["runs"]=>
  int(5)
  ["collected"]=>
  int(100002)
  ["threshold"]=>
  int(50001)
  ["roots"]=>
  int(0)
}

参见

  • Garbage Collection


获取 PHP 配置选项的值

  • ? gc_status
  • get_current_user ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取 PHP 配置选项的值

get_cfg_var

(PHP 4, PHP 5, PHP 7, PHP 8)

get_cfg_var — 获取 PHP 配置选项的值

说明

get_cfg_var ( string $option ) : mixed

获取 PHP 配置选项 option 的值。

此函数不会返回 PHP 编译的配置信息，或从 Apache 配置文件读取。

检查系统是否使用了一个配置文件，并尝试获取 cfg_file_path 的配置设置的值。 如果有效，将会使用一个配置文件。

参数

option

配置选项的名称。

返回值

返回 option 指定的当前 PHP 配置变量的值，错误发生时返回 false。

更新日志

版本 | 说明
5.3.0 | get_cfg_var() 被修复，能够返回 "array" 的 ini 选项。

参见

  • ini_get() - 获取一个配置选项的值
  • ini_get_all() - 获取所有配置选项


获取当前 PHP 脚本所有者名称

  • ? get_cfg_var
  • get_defined_constants ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前 PHP 脚本所有者名称

get_current_user

(PHP 4, PHP 5, PHP 7, PHP 8)

get_current_user — 获取当前 PHP 脚本所有者名称

说明

get_current_user ( ) : string

返回当前 PHP 脚本所有者名称。

返回值

以字符串返回用户名。

范例

Example #1 get_current_user() 例子

<?php
echo 'Current script owner: ' . get_current_user();
?>

以上例程的输出类似于：

Current script owner: SYSTEM

参见

  • getmyuid() - 获取 PHP 脚本所有者的 UID
  • getmygid() - 获取当前 PHP 脚本拥有者的 GID
  • getmypid() - 获取 PHP 进程的 ID
  • getmyinode() - 获取当前脚本的索引节点（inode）
  • getlastmod() - 获取页面最后修改的时间


返回所有常量的关联数组，键是常量名，值是常量值

  • ? get_current_user
  • get_extension_funcs ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回所有常量的关联数组，键是常量名，值是常量值

get_defined_constants

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

get_defined_constants — 返回所有常量的关联数组，键是常量名，值是常量值

说明

get_defined_constants ( bool $categorize = false ) : array

返回当前所有已定义的常量名和值。 这包含 define() 函数所创建的，也包含了所有扩展所创建的。

参数

categorize

让此函数返回一个多维数组，分类为第一维的键名，常量和它们的值位于第二维。

<?php
define("MY_CONSTANT", 1);
print_r(get_defined_constants(true));
?>

以上例程的输出类似于：

Array
(
    [Core] => Array
        (
            [E_ERROR] => 1
            [E_WARNING] => 2
            [E_PARSE] => 4
            [E_NOTICE] => 8
            [E_CORE_ERROR] => 16
            [E_CORE_WARNING] => 32
            [E_COMPILE_ERROR] => 64
            [E_COMPILE_WARNING] => 128
            [E_USER_ERROR] => 256
            [E_USER_WARNING] => 512
            [E_USER_NOTICE] => 1024
            [E_ALL] => 2047
            [TRUE] => 1
        )

    [pcre] => Array
        (
            [PREG_PATTERN_ORDER] => 1
            [PREG_SET_ORDER] => 2
            [PREG_OFFSET_CAPTURE] => 256
            [PREG_SPLIT_NO_EMPTY] => 1
            [PREG_SPLIT_DELIM_CAPTURE] => 2
            [PREG_SPLIT_OFFSET_CAPTURE] => 4
            [PREG_GREP_INVERT] => 1
        )

    [user] => Array
        (
            [MY_CONSTANT] => 1
        )

)

返回值

返回的数组为 常量名 => 常量值，也可以按注册变量的扩展名称来分组。

更新日志

版本 | 说明
5.3.1 | 仅作用于 Windows：内核常量归类到 Core，之前是 mhash。
5.3.0 | 内核常量归类为 Core，之前是 internal。在 Windows 上，内核常量归类到 mhash。
5.2.11 | categorize 参数现在可以合适得被处理。 在此之前，categorize 被解释为 !is_null($categorize)，导致任何非 null 的值会强制常量分类。

范例

Example #1 get_defined_constants() 例子

<?php
print_r(get_defined_constants());
?>

以上例程的输出类似于：

Array
(
    [E_ERROR] => 1
    [E_WARNING] => 2
    [E_PARSE] => 4
    [E_NOTICE] => 8
    [E_CORE_ERROR] => 16
    [E_CORE_WARNING] => 32
    [E_COMPILE_ERROR] => 64
    [E_COMPILE_WARNING] => 128
    [E_USER_ERROR] => 256
    [E_USER_WARNING] => 512
    [E_USER_NOTICE] => 1024
    [E_ALL] => 2047
    [TRUE] => 1
)

参见

  • defined() - 检查某个名称的常量是否存在
  • get_loaded_extensions() - 返回所有编译并加载模块名的 array
  • get_defined_functions() - 返回所有已定义函数的数组
  • get_defined_vars() - 返回由所有已定义变量所组成的数组


返回模块函数名称的数组

  • ? get_defined_constants
  • get_include_path ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回模块函数名称的数组

get_extension_funcs

(PHP 4, PHP 5, PHP 7, PHP 8)

get_extension_funcs — 返回模块函数名称的数组

说明

get_extension_funcs ( string $module_name ) : array

该函数根据 module_name 返回模块内定义的所有函数的名称。

参数

module_name

模块名称。

Note:

这个参数必须是小写（lowercase）的。

返回值

返回包含所有函数名的数组，如果 module_name 不是一个有效的扩展则返回 false。

范例

Example #1 打印 XML 函数

<?php
print_r(get_extension_funcs("xml"));
?>

以上例程的输出类似于：

Array
(
    [0] => xml_parser_create
    [1] => xml_parser_create_ns
    [2] => xml_set_object
    [3] => xml_set_element_handler
    [4] => xml_set_character_data_handler
    [5] => xml_set_processing_instruction_handler
    [6] => xml_set_default_handler
    [7] => xml_set_unparsed_entity_decl_handler
    [8] => xml_set_notation_decl_handler
    [9] => xml_set_external_entity_ref_handler
    [10] => xml_set_start_namespace_decl_handler
    [11] => xml_set_end_namespace_decl_handler
    [12] => xml_parse
    [13] => xml_parse_into_struct
    [14] => xml_get_error_code
    [15] => xml_error_string
    [16] => xml_get_current_line_number
    [17] => xml_get_current_column_number
    [18] => xml_get_current_byte_index
    [19] => xml_parser_free
    [20] => xml_parser_set_option
    [21] => xml_parser_get_option
    [22] => utf8_encode
    [23] => utf8_decode
)

参见

  • get_loaded_extensions() - 返回所有编译并加载模块名的 array
  • ReflectionExtension::getFunctions() - 获取扩展中的函数


获取当前的 include_path 配置选项

  • ? get_extension_funcs
  • get_included_files ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前的 include_path 配置选项

get_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

get_include_path — 获取当前的 include_path 配置选项

说明

get_include_path ( ) : string

获取当前 include_path 配置选项的值。

返回值

返回字符串的路径。

范例

Example #1 get_include_path() 例子

<?php
echo get_include_path();

// 或使用 ini_get()
echo ini_get('include_path');
?>

参见

  • ini_get() - 获取一个配置选项的值
  • restore_include_path() - 还原 include_path 配置选项的值
  • set_include_path() - 设置 include_path 配置选项
  • include - include


返回被 include 和 require 文件名的 array

  • ? get_include_path
  • get_loaded_extensions ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回被 include 和 require 文件名的 array

get_included_files

(PHP 4, PHP 5, PHP 7, PHP 8)

get_included_files — 返回被 include 和 require 文件名的 array

说明

get_included_files ( ) : array

返回所有被 include、 include_once、 require 和 require_once 的文件名。

返回值

返回所有文件名称的 array。

脚本最初被称为"被包含的文件"，所以脚本自身也会和 include 系列函数引用的脚本列在一起。

被多次 include 和 require 的文件在返回的 array 里只会列出一次。

范例

Example #1 get_included_files() 范例

<?php
// 本文件是 abc.php

include 'test1.php';
include_once 'test2.php';
require 'test3.php';
require_once 'test4.php';

$included_files = get_included_files();

foreach ($included_files as $filename) {
    echo "$filename\n";
}

?>

以上例程会输出：

/path/to/abc.php
/path/to/test1.php
/path/to/test2.php
/path/to/test3.php
/path/to/test4.php

注释

Note:

使用 auto_prepend_file 配置指令所包含的文件不会包含在返回的数组里。

参见

  • include - include
  • include_once - include_once
  • require - require
  • require_once - require_once
  • get_required_files() - 别名 get_included_files


返回所有编译并加载模块名的 array

  • ? get_included_files
  • get_magic_quotes_gpc ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回所有编译并加载模块名的 array

get_loaded_extensions

(PHP 4, PHP 5, PHP 7, PHP 8)

get_loaded_extensions — 返回所有编译并加载模块名的 array

说明

get_loaded_extensions ( bool $zend_extensions = false ) : array

该函数返回了 PHP 解析器里所有编译并加载的模块名。

参数

zend_extensions

只返回 Zend 扩展，并非类似 mysqli 的普通扩展。默认是 false (返回普通扩展)。

返回值

返回所有模块名的一个索引数组(array)。

范例

Example #1 get_loaded_extensions() 范例

<?php
print_r(get_loaded_extensions());
?>

以上例程的输出类似于：

Array
(
   [0] => xml
   [1] => wddx
   [2] => standard
   [3] => session
   [4] => posix
   [5] => pgsql
   [6] => pcre
   [7] => gd
   [8] => ftp
   [9] => db
   [10] => calendar
   [11] => bcmath
)

参见

  • get_extension_funcs() - 返回模块函数名称的数组
  • extension_loaded() - 检查一个扩展是否已经加载
  • dl() - 运行时载入一个 PHP 扩展
  • phpinfo() - 输出关于 PHP 配置的信息


获取当前 magic_quotes_gpc 的配置选项设置

  • ? get_loaded_extensions
  • get_magic_quotes_runtime ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前 magic_quotes_gpc 的配置选项设置

get_magic_quotes_gpc

(PHP 4, PHP 5, PHP 7)

get_magic_quotes_gpc — 获取当前 magic_quotes_gpc 的配置选项设置

Warning

本函数已自 PHP 7.4.0 起废弃。强烈建议不要使用本函数。

说明

get_magic_quotes_gpc ( ) : bool

始终返回 false。

返回值

始终返回 false。

更新日志

版本 | 说明
7.4.0 | 该函数已被废弃。

参见

  • addslashes() - 使用反斜线引用字符串
  • stripslashes() - 反引用一个引用字符串
  • get_magic_quotes_runtime() - 获取当前 magic_quotes_runtime 配置选项的激活状态
  • ini_get() - 获取一个配置选项的值


获取当前 magic_quotes_runtime 配置选项的激活状态

  • ? get_magic_quotes_gpc
  • get_required_files ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前 magic_quotes_runtime 配置选项的激活状态

get_magic_quotes_runtime

(PHP 4, PHP 5, PHP 7)

get_magic_quotes_runtime — 获取当前 magic_quotes_runtime 配置选项的激活状态

说明

get_magic_quotes_runtime ( ) : bool

返回当前 magic_quotes_runtime 配置选项的激活状态。

返回值

magic_quotes_runtime 在关闭时返回 0，否则返回 1。 自 PHP 5.4.0 起始终返回 false。

更新日志

版本 | 说明
5.4.0 | 总是返回 false，因为魔术引号（magic quotes）功能已经从 PHP 中移除。

范例

Example #1 get_magic_quotes_runtime() 例子

<?php
// 检测 magic_quotes_runtime 是否已经激活
if(get_magic_quotes_runtime())
{
    // 关闭功能
    set_magic_quotes_runtime(false);
}
?>

参见

  • get_magic_quotes_gpc() - 获取当前 magic_quotes_gpc 的配置选项设置
  • set_magic_quotes_runtime()


别名 get_included_files

  • ? get_magic_quotes_runtime
  • get_resources ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 别名 get_included_files

get_required_files

(PHP 4, PHP 5, PHP 7, PHP 8)

get_required_files — 别名 get_included_files()

说明

此函数是该函数的别名： get_included_files().


Returns active resources

  • ? get_required_files
  • getenv ?
  • PHP Manual
  • PHP 选项/信息 函数
  • Returns active resources

get_resources

(PHP 7, PHP 8)

get_resources — Returns active resources

说明

get_resources ( string $type = ? ) : array

Returns an array of all currently active resources, optionally filtered by resource type.

参数

type

If defined, this will cause get_resources() to only return resources of the given type. A list of resource types is available.

If the string Unknown is provided as the type, then only resources that are of an unknown type will be returned.

If omitted, all resources will be returned.

返回值

Returns an array of currently active resources, indexed by resource number.

范例

Example #1 Unfiltered get_resources()

<?php
$fp = tmpfile();
var_dump(get_resources());
?>

以上例程的输出类似于：

array(1) {
  [1]=>
  resource(1) of type (stream)
}

Example #2 Filtered get_resources()

<?php
$fp = tmpfile();
var_dump(get_resources('stream'));
var_dump(get_resources('curl'));
?>

以上例程的输出类似于：

array(1) {
  [1]=>
  resource(1) of type (stream)
}
array(0) {
}

参见

  • get_loaded_extensions() - 返回所有编译并加载模块名的 array
  • get_defined_constants() - 返回所有常量的关联数组，键是常量名，值是常量值
  • get_defined_functions() - 返回所有已定义函数的数组
  • get_defined_vars() - 返回由所有已定义变量所组成的数组


获取一个环境变量的值

  • ? get_resources
  • getlastmod ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取一个环境变量的值

getenv

(PHP 4, PHP 5, PHP 7, PHP 8)

getenv — 获取一个环境变量的值

说明

getenv ( string $varname , bool $local_only = false ) : string
getenv ( ) : array

获取一个环境变量的值。

使用 phpinfo() 你可以看到所有环境变量的列表。 这些变量很多都在 » RFC 3875 的范围之内， 尤其是章节4.1，"Request Meta-Variables"。

参数

varname

变量名。

local_only

设置为 true 以仅返回本地环境变量（由操作系统或 putenv() 设置）。

返回值

返回环境变量 varname 的值， 如果环境变量 varname 不存在则返回 false。 如果省略 varname，则所有环境变量都将作为关联数组 array 返回。

更新日志

版本 | 说明
7.1.0 | 现在可以省略 varname 来检索所有环境变量的关联数组 array。
5.5.38, 5.6.24, 7.0.9 | 添加 local_only 参数。

注释

Warning

如果 PHP 在诸如 Fast CGI 之类的 SAPI 中运行，则此函数将始终返回由 SAPI 设置的环境变量的值，即使已使用 putenv() 来设置同名的本地环境变量。使用 local_only 参数返回本地设置的环境变量的值。

范例

Example #1 getenv() 例子

<?php
// getenv() 使用示例
$ip = getenv('REMOTE_ADDR');

// 或简单仅使用全局变量（$_SERVER 或 $_ENV）
$ip = $_SERVER['REMOTE_ADDR'];

// 安全地获取环境变量，忽略通过 SAPI 或 putenv 修改的值
$ip = getenv('REMOTE_ADDR', true) ?: getenv('REMOTE_ADDR')
?>

参见

  • putenv() - 设置环境变量的值
  • apache_getenv() - 获取 Apache subprocess_env 变量
  • 超全局变量


获取页面最后修改的时间

  • ? getenv
  • getmygid ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取页面最后修改的时间

getlastmod

(PHP 4, PHP 5, PHP 7, PHP 8)

getlastmod — 获取页面最后修改的时间

说明

getlastmod ( ) : int

获取执行的主脚本的最后修改时间。

如果你对其他文件的最后修改时间的感兴趣，可考虑使用 filemtime()。

返回值

返回当前页面最后修改的时间。这个值是一个 Unix 时间戳，可以传入 date()。 错误时返回 false。

范例

Example #1 getlastmod() 例子

<?php
// 输出类似 'Last modified: March 04 1998 20:43:59.'
echo "Last modified: " . date ("F d Y H:i:s.", getlastmod());
?>

参见

  • date() - 格式化一个本地时间／日期
  • getmyuid() - 获取 PHP 脚本所有者的 UID
  • getmygid() - 获取当前 PHP 脚本拥有者的 GID
  • get_current_user() - 获取当前 PHP 脚本所有者名称
  • getmyinode() - 获取当前脚本的索引节点（inode）
  • getmypid() - 获取 PHP 进程的 ID
  • filemtime() - 取得文件修改时间


获取当前 PHP 脚本拥有者的 GID

  • ? getlastmod
  • getmyinode ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前 PHP 脚本拥有者的 GID

getmygid

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

getmygid — 获取当前 PHP 脚本拥有者的 GID

说明

getmygid ( ) : int

获取当前 PHP 脚本拥有者的用户组 ID。

返回值

返回当前 PHP 脚本拥有者的用户组 ID，或在错误时返回 false。

参见

  • getmyuid() - 获取 PHP 脚本所有者的 UID
  • getmypid() - 获取 PHP 进程的 ID
  • get_current_user() - 获取当前 PHP 脚本所有者名称
  • getmyinode() - 获取当前脚本的索引节点（inode）
  • getlastmod() - 获取页面最后修改的时间


获取当前脚本的索引节点（inode）

  • ? getmygid
  • getmypid ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前脚本的索引节点（inode）

getmyinode

(PHP 4, PHP 5, PHP 7, PHP 8)

getmyinode — 获取当前脚本的索引节点（inode）

说明

getmyinode ( ) : int

获取当前脚本的索引节点（inode）。

返回值

以整型返回当前脚本的索引节点（inode），或在错误时返回 false。

参见

  • getmygid() - 获取当前 PHP 脚本拥有者的 GID
  • getmyuid() - 获取 PHP 脚本所有者的 UID
  • getmypid() - 获取 PHP 进程的 ID
  • get_current_user() - 获取当前 PHP 脚本所有者名称
  • getlastmod() - 获取页面最后修改的时间


获取 PHP 进程的 ID

  • ? getmyinode
  • getmyuid ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取 PHP 进程的 ID

getmypid

(PHP 4, PHP 5, PHP 7, PHP 8)

getmypid — 获取 PHP 进程的 ID

说明

getmypid ( ) : int

获取当前 PHP 进程 ID。

返回值

返回当前 PHP 进程 ID，或在错误时返回 false。

注释

Warning

进程 ID 并不是唯一的，所以他们是一个弱熵源。 对安全性有依赖的上下文中我们不推荐依赖于 pid。

参见

  • getmygid() - 获取当前 PHP 脚本拥有者的 GID
  • getmyuid() - 获取 PHP 脚本所有者的 UID
  • get_current_user() - 获取当前 PHP 脚本所有者名称
  • getmyinode() - 获取当前脚本的索引节点（inode）
  • getlastmod() - 获取页面最后修改的时间


获取 PHP 脚本所有者的 UID

  • ? getmypid
  • getopt ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取 PHP 脚本所有者的 UID

getmyuid

(PHP 4, PHP 5, PHP 7, PHP 8)

getmyuid — 获取 PHP 脚本所有者的 UID

说明

getmyuid ( ) : int

获取当前脚本的用户 ID。

返回值

返回当前脚本的用户 ID，或在错误时返回 false。

参见

  • getmygid() - 获取当前 PHP 脚本拥有者的 GID
  • getmypid() - 获取 PHP 进程的 ID
  • get_current_user() - 获取当前 PHP 脚本所有者名称
  • getmyinode() - 获取当前脚本的索引节点（inode）
  • getlastmod() - 获取页面最后修改的时间


从命令行参数列表中获取选项

  • ? getmyuid
  • getrusage ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 从命令行参数列表中获取选项

getopt

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

getopt — 从命令行参数列表中获取选项

说明

getopt ( string $short_options , array $long_options = [] , int &$rest_index = null ) : array|false

解析传入脚本的选项。

参数

short_options
该字符串中的每个字符会被当做选项字符，匹配传入脚本的选项以单个连字符 (-) 开头。 比如，一个选项字符串 "x" 识别了一个选项 -x。 只允许 a-z、A-Z 和 0-9。
long_options
选项数组。此数组中的每个元素会被作为选项字符串，匹配了以两个连字符 (--) 传入到脚本的选项。 例如，长选项元素 "opt" 识别了一个选项 --opt。
rest_index
如果传递了 rest_index 参数，那么参数解析停止时的索引，将被赋值给此变量。

short_options 可能包含了以下元素：

  • 单独的字符（不接受值）
  • 后面跟随冒号的字符（此选项需要值）
  • 后面跟随两个冒号的字符（此选项的值可选）
选项的值是字符串后的第一个参数。如果需要一个值，它不介意值之前是否有前置的空格，参见以下内容。

Note: 选项的值不接受空格（" "）作为分隔符。

long_options 数组可能包含了以下元素：

  • 字符串（参数不接受任何值）
  • 后面跟随冒号的字符串（此选项需要值）
  • 后面跟随两个冒号的字符串（此选项的值可选）

Note:

options 和 longopts 的格式几乎是一样的，唯一的不同之处是 longopts 需要是选项的数组（每个元素为一个选项），而 options 需要一个字符串（每个字符是个选项）。

返回值

此函数会返回选项/参数对， 或者在失败时返回 false。

Note:

选项的解析会终止于找到的第一个非选项，之后的任何东西都会被丢弃。

更新日志

版本 | 说明
7.1.0 | 添加 optind 参数。

范例

Example #1 getopt() 例子：基本用法

<?php
// Script example.php
$options = getopt("f:hp:");
var_dump($options);
?>
shell> php example.php -fvalue -h

以上例程会输出：

array(2) {
  ["f"]=>
  string(5) "value"
  ["h"]=>
  bool(false)
}

Example #2 getopt() 例子：引入长选项

<?php
// Script example.php
$shortopts  = "";
$shortopts .= "f:";  // Required value
$shortopts .= "v::"; // Optional value
$shortopts .= "abc"; // These options do not accept values

$longopts  = array(
    "required:",     // Required value
    "optional::",    // Optional value
    "option",        // No value
    "opt",           // No value
);
$options = getopt($shortopts, $longopts);
var_dump($options);
?>
shell> php example.php -f "value for f" -v -a --required value --optional="optional value" --option

以上例程会输出：

array(6) {
  ["f"]=>
  string(11) "value for f"
  ["v"]=>
  bool(false)
  ["a"]=>
  bool(false)
  ["required"]=>
  string(5) "value"
  ["optional"]=>
  string(14) "optional value"
  ["option"]=>
  bool(false)
}

Example #3 getopt() 例子：传递同一多个选项

<?php
// Script example.php
$options = getopt("abc");
var_dump($options);
?>
shell> php example.php -aaac

以上例程会输出：

array(2) {
  ["a"]=>
  array(3) {
    [0]=>
    bool(false)
    [1]=>
    bool(false)
    [2]=>
    bool(false)
  }
  ["c"]=>
  bool(false)
}

Example #4 getopt() 例子：使用 optind

<?php
// Script example.php
$optind = null;
$opts = getopt('a:b:', [], $optind);
$pos_args = array_slice($argv, $optind);
var_dump($pos_args);
shell> php example.php -a 1 -b 2 -- test

以上例程会输出：

array(1) {
  [0]=>
  string(4) "test"
}

参见

  • $argv


获取当前资源使用状况

  • ? getopt
  • ini_alter ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前资源使用状况

getrusage

(PHP 4, PHP 5, PHP 7, PHP 8)

getrusage — 获取当前资源使用状况

说明

getrusage ( int $who = 0 ) : array

这是 getrusage(2) 的接口。它返回了调用自系统的数据。

参数

who

如果 who 是 1，getrusage 会使用 RUSAGE_CHILDREN 来调用。

返回值

返回了一个包含系统返回数据的关联数组。所以条目均可通过文档中字段的名称来访问。

范例

Example #1 getrusage() 例子

<?php
$dat = getrusage();
echo $dat["ru_oublock"];       // number of block output operations
echo $dat["ru_inblock"];       // number of block input operations
echo $dat["ru_msgsnd"];        // number of IPC messages sent
echo $dat["ru_msgrcv"];        // number of IPC messages received
echo $dat["ru_maxrss"];        // maximum resident set size
echo $dat["ru_ixrss"];         // integral shared memory size
echo $dat["ru_idrss"];         // integral unshared data size
echo $dat["ru_minflt"];        // number of page reclaims (soft page faults)
echo $dat["ru_majflt"];        // number of page faults (hard page faults)
echo $dat["ru_nsignals"];      // number of signals received
echo $dat["ru_nvcsw"];         // number of voluntary context switches
echo $dat["ru_nivcsw"];        // number of involuntary context switches
echo $dat["ru_nswap"];         // number of swaps
echo $dat["ru_utime.tv_usec"]; // user time used (microseconds)
echo $dat["ru_utime.tv_sec"];  // user time used (seconds)
echo $dat["ru_stime.tv_usec"]; // system time used (microseconds)
?>

更新日志

版本 | 说明
7.0.0 | 此函数现在开始支持 Windows。

注释

Note:

在 Windows 上 getrusage() 仅会返回以下类型：

  • "ru_stime.tv_sec"
  • "ru_stime.tv_usec"
  • "ru_utime.tv_sec"
  • "ru_utime.tv_usec"
  • "ru_majflt" (only if who is RUSAGE_SELF)
  • "ru_maxrss" (only if who is RUSAGE_SELF)

If getrusage() is called with who set to 1 (RUSAGE_CHILDREN), then resource usage for threads are collected (meaning that internally the function is called with RUSAGE_THREAD).

Note:

在 BeOS 2000，仅会返回以下类型：

  • "ru_stime.tv_sec"
  • "ru_stime.tv_usec"
  • "ru_utime.tv_sec"
  • "ru_utime.tv_usec"

参见

  • 你系统上 getrusage(2) 的 man page


别名 ini_set

  • ? getrusage
  • ini_get_all ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 别名 ini_set

ini_alter

(PHP 4, PHP 5, PHP 7, PHP 8)

ini_alter — 别名 ini_set()

说明

此函数是该函数的别名： ini_set().


获取所有配置选项

  • ? ini_alter
  • ini_get ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取所有配置选项

ini_get_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ini_get_all — 获取所有配置选项

说明

ini_get_all ( string $extension = ? , bool $details = true ) : array

获取所有已注册的配置选项

参数

extension

可选的扩展名称。如果设置了，此函数仅仅返回指定该扩展的选项。

details

获取详细设置或者仅仅是每个设置的当前值。 默认是 true（获取详细信息）。

返回值

返回一个关联数组，指令名称是数组的键。 如果 extension 不存在，返回 false 并产生 E_WARNING 级错误。

当 details 为 true（默认），数组会包含 global_value（php.ini 中的设置）、local_value（可能是 ini_set() 或 .htaccess 中的设置） 以及 access（访问级别）。

当 details 为 false，这个值会是选项的当前值。

参见手册章节中访问级别含义的信息。

Note:

指令可以有多个访问级别，这也是为什么 access 会显示适当的位掩码。

注释

Note:

ini_get_all() 忽略 "array" 的 ini 选项，例如 pdo.dsn.*。

更新日志

版本 | 说明
5.3.0 | 增加参数 details。

范例

Example #1 ini_get_all() 例子

<?php
print_r(ini_get_all("pcre"));
print_r(ini_get_all());
?>

以上例程的输出类似于：

Array
(
    [pcre.backtrack_limit] => Array
        (
            [global_value] => 100000
            [local_value] => 100000
            [access] => 7
        )

    [pcre.recursion_limit] => Array
        (
            [global_value] => 100000
            [local_value] => 100000
            [access] => 7
        )

)
Array
(
    [allow_call_time_pass_reference] => Array
        (
            [global_value] => 0
            [local_value] => 0
            [access] => 6
        )

    [allow_url_fopen] => Array
        (
            [global_value] => 1
            [local_value] => 1
            [access] => 4
        )

    ...

)

Example #2 禁用 details

<?php
print_r(ini_get_all("pcre", false)); // Added in PHP 5.3.0
print_r(ini_get_all(null, false)); // Added in PHP 5.3.0
?>

以上例程的输出类似于：

Array
(
    [pcre.backtrack_limit] => 100000
    [pcre.recursion_limit] => 100000
)
Array
(
    [allow_call_time_pass_reference] => 0
    [allow_url_fopen] => 1
    ...
)

参见

  • 怎样修改配置设定
  • ini_get() - 获取一个配置选项的值
  • ini_restore() - 恢复配置选项的值
  • ini_set() - 为一个配置选项设置值
  • get_loaded_extensions() - 返回所有编译并加载模块名的 array
  • phpinfo() - 输出关于 PHP 配置的信息
  • ReflectionExtension::getINIEntries() - 获取ini配置


获取一个配置选项的值

  • ? ini_get_all
  • ini_restore ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取一个配置选项的值

ini_get

(PHP 4, PHP 5, PHP 7, PHP 8)

ini_get — 获取一个配置选项的值

说明

ini_get ( string $varname ) : string

成功时返回配置选项的值。

参数

varname

配置选项名称。

返回值

成功是返回配置选项值的字符串，null 的值则返回空字符串。如果配置选项不存在，将会返回 false。

范例

Example #1 一些 ini_get() 例子

<?php
/*
我们的 php.ini 包含了以下的设置：

display_errors = On
register_globals = Off
post_max_size = 8M
*/

echo 'display_errors = ' . ini_get('display_errors') . "\n";
echo 'register_globals = ' . ini_get('register_globals') . "\n";
echo 'post_max_size = ' . ini_get('post_max_size') . "\n";
echo 'post_max_size+1 = ' . (ini_get('post_max_size')+1) . "\n";
echo 'post_max_size in bytes = ' . return_bytes(ini_get('post_max_size'));

function return_bytes($val) {
    $val = trim($val);
    $last = strtolower($val[strlen($val)-1]);
    switch($last) {
        // 自 PHP 5.1.0 起可以使用修饰符 'G'
        case 'g':
            $val *= 1024;
        case 'm':
            $val *= 1024;
        case 'k':
            $val *= 1024;
    }

    return $val;
}

?>

以上例程的输出类似于：

display_errors = 1
register_globals = 0
post_max_size = 8M
post_max_size+1 = 9
post_max_size in bytes = 8388608

注释

Note: 当查询一个 boolean 值

一个 off 的 boolean ini 值将会以空字符串或者 "0" 返回；on 的 ini 值会以 "1" 返回。 此函数也会返回 INI 值的文字字符串。

Note: 当查询一个内存尺寸的值

许多内存尺寸的 ini 值，类似 upload_max_filesize 是以简写表示法储存在 php.ini 文件里。 ini_get() 会返回 php.ini 文件中储存的确切字符串，而不是它的等量 integer。 尝试对这些值使用常规算术运算函数将不会得到预期的结果。 以上例子显示了转换简写表示法为字节的一种方式，和 PHP 源码所做的比较像。

Note:

ini_get() 无法读取 "array" 的 ini 选项，例如 pdo.dsn.*，在这个例子中会返回 false 。

更新日志

版本 | 说明
5.3.0 | 当配置项不存在，之前会返回空字符串，现在会返回 false。

参见

  • get_cfg_var() - 获取 PHP 配置选项的值
  • ini_get_all() - 获取所有配置选项
  • ini_restore() - 恢复配置选项的值
  • ini_set() - 为一个配置选项设置值


恢复配置选项的值

  • ? ini_get
  • ini_set ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 恢复配置选项的值

ini_restore

(PHP 4, PHP 5, PHP 7, PHP 8)

ini_restore — 恢复配置选项的值

说明

ini_restore ( string $varname ) : void

恢复指定的配置选项到它的原始值。

参数

varname

配置选项名称。

返回值

没有返回值。

范例

Example #1 ini_restore() 例子

<?php
$setting = 'y2k_compliance';

echo 'Current value for \'' . $setting . '\': ' . ini_get($setting), PHP_EOL;

ini_set($setting, ini_get($setting) ? 0 : 1);
echo 'New value for \'' . $setting . '\': ' . ini_get($setting), PHP_EOL;

ini_restore($setting);
echo 'Original value for \'' . $setting . '\': ' . ini_get($setting), PHP_EOL;
?>

以上例程会输出：

Current value for 'y2k_compliance': 1
New value for 'y2k_compliance': 0
Original value for 'y2k_compliance': 1

参见

  • ini_get() - 获取一个配置选项的值
  • ini_get_all() - 获取所有配置选项
  • ini_set() - 为一个配置选项设置值


为一个配置选项设置值

  • ? ini_restore
  • main ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 为一个配置选项设置值

ini_set

(PHP 4, PHP 5, PHP 7, PHP 8)

ini_set — 为一个配置选项设置值

说明

ini_set ( string $varname , string $newvalue ) : string

设置指定配置选项的值。这个选项会在脚本运行时保持新的值，并在脚本结束时恢复。

参数

varname

不是所有有效的选项都能够用 ini_set() 来改变的。 这里有个有效选项的清单附录。

newvalue

选项新的值。

返回值

成功时返回旧的值，失败时返回 false。

范例

Example #1 设置一个 ini 选项

<?php
echo ini_get('display_errors');

if (!ini_get('display_errors')) {
    ini_set('display_errors', '1');
}

echo ini_get('display_errors');
?>

参见

  • get_cfg_var() - 获取 PHP 配置选项的值
  • ini_get() - 获取一个配置选项的值
  • ini_get_all() - 获取所有配置选项
  • ini_restore() - 恢复配置选项的值
  • 如何改变配置选项


虚拟的main

  • ? ini_set
  • memory_get_peak_usage ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 虚拟的main

main

main — 虚拟的main()

说明

除了在PHP源码里，并没有一个名称为 main() 的函数。 在 PHP 4.3.0 的源码里，引入了新的错误处理类型(php_error_docref)。 其中一个功能是在 PHP 指令 html_errors(默认为 on) 和 docref_root(默认为on直至 PHP 4.3.2) 被设置时，在错误信息里提供对应的手册链接。

本页存在的原因是因为有时函数 main() 错误信息里的手册链接会指到本页。 如果你发现了这样的引用，请 » 提交错误报告， 说明 PHP 函数发生了错误，并链接到了 main()， 错误会被妥善处理并可能会记录在文档里。

已知这些错误会指向 main()
函数名 | 直到该版本，不会再指到这里
include | 5.1.0
include_once | 5.1.0
require | 5.1.0
require_once | 5.1.0

参见

  • html_errors
  • display_errors


返回分配给 PHP 内存的峰值

  • ? main
  • memory_get_usage ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回分配给 PHP 内存的峰值

memory_get_peak_usage

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

memory_get_peak_usage — 返回分配给 PHP 内存的峰值

说明

memory_get_peak_usage ( bool $real_usage = false ) : int

返回分配给你的 PHP 脚本的内存峰值字节数。

参数

real_usage

如果设置为 true 可以获取从系统分配到的真实内存尺寸。 如果未设置，或者设置为 false，仅会报告 emalloc() 使用的内存。

返回值

返回内存峰值的字节数。

更新日志

版本 | 说明
5.2.1 | 使用此函数无需在编译时加上 --enable-memory-limit 选项。
5.2.0 | 添加参数 real_usage。

参见

  • memory_get_usage() - 返回分配给 PHP 的内存量
  • memory_limit


返回分配给 PHP 的内存量

  • ? memory_get_peak_usage
  • php_ini_loaded_file ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回分配给 PHP 的内存量

memory_get_usage

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

memory_get_usage — 返回分配给 PHP 的内存量

说明

memory_get_usage ( bool $real_usage = false ) : int

返回当前分配给你的 PHP 脚本的内存量，单位是字节（byte）。

参数

real_usage

如果设置为 true，获取系统分配总的内存尺寸，包括未使用的页。如果未设置或者设置为 false，仅仅报告实际使用的内存量。

Note:

PHP 不跟踪非emalloc() 分配的内存

返回值

返回内存量字节数。

更新日志

版本 | 说明
5.2.1 | 不需要在编译时使用 --enable-memory-limit 选项就能够使用这个函数。
5.2.0 | 增加了参数 real_usage。

范例

Example #1 一个 memory_get_usage() 例子

<?php
//这只是个例子，下面的数字取决于你的系统

echo memory_get_usage() . "\n"; // 36640

$a = str_repeat("Hello", 4242);

echo memory_get_usage() . "\n"; // 57960

unset($a);

echo memory_get_usage() . "\n"; // 36744

?>

参见

  • memory_get_peak_usage() - 返回分配给 PHP 内存的峰值
  • memory_limit


取得已加载的 php.ini 文件的路径

  • ? memory_get_usage
  • php_ini_scanned_files ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 取得已加载的 php.ini 文件的路径

php_ini_loaded_file

(PHP 5 >= 5.2.4, PHP 7, PHP 8)

php_ini_loaded_file — 取得已加载的 php.ini 文件的路径

说明

php_ini_loaded_file ( ) : string

检查是否有加载的 php.ini 文件，并取回它的路径。

参数

此函数没有参数。

返回值

已加载的 php.ini 路径，或在没有时返回 false。

范例

Example #1 php_ini_loaded_file() 例子

<?php
$inipath = php_ini_loaded_file();

if ($inipath) {
    echo 'Loaded php.ini: ' . $inipath;
} else {
    echo 'A php.ini file is not loaded';
}
?>

以上例程的输出类似于：

Loaded php.ini: /usr/local/php/php.ini

参见

  • php_ini_scanned_files() - 返回从额外 ini 目录里解析的 .ini 文件列表
  • phpinfo() - 输出关于 PHP 配置的信息
  • 配置文件


返回从额外 ini 目录里解析的 .ini 文件列表

  • ? php_ini_loaded_file
  • php_sapi_name ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回从额外 ini 目录里解析的 .ini 文件列表

php_ini_scanned_files

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

php_ini_scanned_files — 返回从额外 ini 目录里解析的 .ini 文件列表

说明

php_ini_scanned_files ( ) : string

php_ini_scanned_files() 返回解析的 php.ini 后逗号分隔的配置文件列表。 这些文件从编译时 --with-config-file-scan-dir 选项里指定的目录里找到。

这些返回的配置文件也包括了 --with-config-file-scan-dir 选项里声明的路径。

返回值

成功时返回逗号分隔的 .ini 文件字符串。 每个逗号后紧跟新的一行。 如果未设置指令 --with-config-file-scan-dir 将会返回 false。 如果它设置了，并且目录是空的，将会返回一个空字符串。 如果有未识别的文件，此文件也会进入返回的字符串，但是会导致一个 PHP 错误。 此 PHP 错误即会在编译时出现也会在使用 php_ini_scanned_files() 函数时出现。

范例

Example #1 列出返回的 ini 文件的简单例子

<?php
if ($filelist = php_ini_scanned_files()) {
    if (strlen($filelist) > 0) {
        $files = explode(',', $filelist);

        foreach ($files as $file) {
            echo "<li>" . trim($file) . "</li>\n";
        }
    }
}
?>

参见

  • ini_set() - 为一个配置选项设置值
  • phpinfo() - 输出关于 PHP 配置的信息
  • php_ini_loaded_file() - 取得已加载的 php.ini 文件的路径


返回 web 服务器和 PHP 之间的接口类型

  • ? php_ini_scanned_files
  • php_uname ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回 web 服务器和 PHP 之间的接口类型

php_sapi_name

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

php_sapi_name — 返回 web 服务器和 PHP 之间的接口类型

说明

php_sapi_name ( ) : string|false

返回描述 PHP 所使用的接口类型（the Server API, SAPI）的小写字符串。 例如，CLI 的 PHP 下这个字符串会是 "cli"，Apache 下可能会有几个不同的值，取决于具体使用的 SAPI。 以下列出了可能的值。

返回值

返回接口类型的小写字符串， 或者在失败时返回 false。

尽管不够全面，可能返回的值包括了 apache、 apache2handler、 cgi （直到 PHP 5.3）, cgi-fcgi、cli、 cli-server、 embed、fpm-fcgi、 litespeed、 nsapi、phpdbg。

范例

Example #1 php_sapi_name() 例子

以下例子检测了子字符串 cgi，因为它也有可能会是 cgi-fcgi。

<?php
$sapi_type = php_sapi_name();
if (substr($sapi_type, 0, 3) == 'cgi') {
    echo "You are using CGI PHP\n";
} else {
    echo "You are not using CGI PHP\n";
}
?>

注释

Note: 另一种方法

PHP 常量 PHP_SAPI 具有和 php_sapi_name() 相同的值。

Tip

一个潜在的疑难问题

定义的 SAPI 可能不够明显，比如它可能定义为 apache2handler，而不是 apache。

参见

  • PHP_SAPI


返回运行 PHP 的系统的有关信息

  • ? php_sapi_name
  • phpcredits ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回运行 PHP 的系统的有关信息

php_uname

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

php_uname — 返回运行 PHP 的系统的有关信息

说明

php_uname ( string $mode = "a" ) : string

php_uname() 返回了运行 PHP 的操作系统的描述。 这和 phpinfo() 最顶端上输出的是同一个字符串。 如果仅仅要获取操作系统的名称。可以考虑使用常量 PHP_OS，不过要注意该常量会包含 PHP 构建（built）时的操作系统名。

在一些旧的 UNIX 平台，它有可能无法检测到当前系统的信息，然后会还原显示成构建 PHP 时的系统信息。 这仅仅在你的 uname() 函数库不存在或无法运行时发生。

参数

mode

mode 是单个字符，用于定义要返回什么信息：

  • 'a'：此为默认。包含序列 "s n r v m" 里的所有模式。
  • 's'：操作系统名称。例如： FreeBSD。
  • 'n'：主机名。例如： localhost.example.com。
  • 'r'：版本名称，例如： 5.1.2-RELEASE。
  • 'v'：版本信息。操作系统之间有很大的不同。
  • 'm'：机器类型。例如：i386。

返回值

返回描述字符串。

范例

Example #1 一些 php_uname() 的例子

<?php
echo php_uname();
echo PHP_OS;

/* 比如有些会输出：
Linux localhost 2.4.21-0.13mdk #1 Fri Mar 14 15:08:06 EST 2003 i686
Linux

FreeBSD localhost 3.2-RELEASE #15: Mon Dec 17 08:46:02 GMT 2001
FreeBSD

Windows NT XN1 5.1 build 2600
WINNT
*/

if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
    echo 'This is a server using Windows!';
} else {
    echo 'This is a server not using Windows!';
}

?>

同样可以方便地使用一些相关的 PHP 预定义常量，例如：

Example #2 一些系统相关常量的例子

<?php
// *nix
echo DIRECTORY_SEPARATOR; // /
echo PHP_SHLIB_SUFFIX;    // so
echo PATH_SEPARATOR;      // :

// Win*
echo DIRECTORY_SEPARATOR; // \
echo PHP_SHLIB_SUFFIX;    // dll
echo PATH_SEPARATOR;      // ;
?>

参见

  • phpversion() - 获取当前的PHP版本
  • php_sapi_name() - 返回 web 服务器和 PHP 之间的接口类型
  • phpinfo() - 输出关于 PHP 配置的信息


打印 PHP 贡献者名单

  • ? php_uname
  • phpinfo ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 打印 PHP 贡献者名单

phpcredits

(PHP 4, PHP 5, PHP 7, PHP 8)

phpcredits — 打印 PHP 贡献者名单

说明

phpcredits ( int $flag = CREDITS_ALL ) : bool

这个函数打印出了 PHP 开发者、模块等贡献者名单。 它生成了合适、可嵌入信息到页面中的 HTML 代码。

参数

flag

生成自定义的贡献者页面，你也许想要使用 flag 参数。

预定义的 phpcredits() flags
名称 | 描述
CREDITS_ALL | 所有贡献者，等同于使用： CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_FULLPAGE。 它以适当的标签产生了完整独立的 HTML 页面。
CREDITS_DOCS | 文档组贡献名单
CREDITS_FULLPAGE | 常用于和其他标志进行组合。 表示需要打印包含其他标志表示信息的独立 HTML 页面。
CREDITS_GENERAL | 普遍名单：语言设计与理念、PHP作者以及 SAPI 模块。
CREDITS_GROUP | 核心开发者名单
CREDITS_MODULES | PHP 扩展模块以及它们的作者的清单
CREDITS_SAPI | PHP 的服务器 API 模块以及他们的作者的清单

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 打印普遍名单

<?php
phpcredits(CREDITS_GENERAL);
?>

Example #2 打印核心开发者和文档组

<?php
phpcredits(CREDITS_GROUP | CREDITS_DOCS | CREDITS_FULLPAGE);
?>

Example #3 打印所有贡献者

<html>
 <head>
  <title>My credits page</title>
 </head>
 <body>
<?php
// 一些你自己的代码
phpcredits(CREDITS_ALL - CREDITS_FULLPAGE);
// 一些其他的代码
?>
 </body>
</html>

注释

Note:

在 CLI 模式下 phpcredits() 输出明文而不是 HTML。

参见

  • phpversion() - 获取当前的PHP版本
  • php_logo_guid()
  • phpinfo() - 输出关于 PHP 配置的信息


输出关于 PHP 配置的信息

  • ? phpcredits
  • phpversion ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 输出关于 PHP 配置的信息

phpinfo

(PHP 4, PHP 5, PHP 7, PHP 8)

phpinfo — 输出关于 PHP 配置的信息

说明

phpinfo ( int $what = INFO_ALL ) : bool

输出 PHP 当前状态的大量信息，包含了 PHP 编译选项、启用的扩展、PHP 版本、服务器信息和环境变量（如果编译为一个模块的话）、PHP环境变量、操作系统版本信息、path 变量、配置选项的本地值和主值、HTTP 头和PHP授权信息(License)。

因为每个系统安装得有所不同，phpinfo() 常用于在系统上检查 配置设置和 预定义变量。

phpinfo() 同时是个很有价值的、包含所有 EGPCS(Environment, GET, POST, Cookie, Server) 数据的调试工具。

参数

what

可以用以下的一个或多个 constants 用位运算传递给可选的 what 参数来定制输出的信息。 该参数可以把常量相加或者用按位或操作符按位运算。

phpinfo() 选项
Name (constant) | Value | Description
INFO_GENERAL | 1 | 配置的命令行、 php.ini 的文件位置、建立的时间、Web 服务器、系统及更多其他信息。
INFO_CREDITS | 2 | PHP 贡献者名单。参加 phpcredits()。
INFO_CONFIGURATION | 4 | 当前PHP指令的本地值和主值。参见 ini_get()。
INFO_MODULES | 8 | 已加载的模块和模块相应的设置。参见 get_loaded_extensions()。
INFO_ENVIRONMENT | 16 | 环境变量信息也可以用 $_ENV 获取。
INFO_VARIABLES | 32 | 显示所有来自 EGPCS (Environment, GET, POST, Cookie, Server) 的 预定义变量。
INFO_LICENSE | 64 | PHP许可证信息。参见 » license FAQ。
INFO_ALL | -1 | 显示以上所有信息。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

5.5.0 | Logo GUIDs were replaced with data URIs, and so turning off expose_php now has no effect on the result of phpinfo(). Credits are also now embedded within the output itself instead of linked.
版本 | 说明
5.2.2 | 增加了"已加载的配置文件"信息，之前只存在"配置文件路径(php.ini)"。

范例

Example #1 phpinfo() 范例

<?php

// 显示所有信息，默认显示 INFO_ALL
phpinfo();

// Show just the module information. 仅仅显示PHP模块信息，
// phpinfo(8) 返回同样的结果。
phpinfo(INFO_MODULES);

?>

注释

Note:

在 PHP 5.5 之前版本，当 expose_php 设置为 off 可以禁用一部分信息。 这包括了 PHP 和 Zend 的 logo，以及贡献者名单。

Note:

在命令行（CLI）模式下 phpinfo() 仅会输出纯文本，而不是HTML。

参见

  • phpversion() - 获取当前的PHP版本
  • phpcredits() - 打印 PHP 贡献者名单
  • php_logo_guid()
  • ini_get() - 获取一个配置选项的值
  • ini_set() - 为一个配置选项设置值
  • get_loaded_extensions() - 返回所有编译并加载模块名的 array
  • Predefined Variables


获取当前的PHP版本

  • ? phpinfo
  • putenv ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前的PHP版本

phpversion

(PHP 4, PHP 5, PHP 7, PHP 8)

phpversion — 获取当前的PHP版本

说明

phpversion ( string $extension = ? ) : string

返回了包含当前运行 PHP 解释器或扩展版本信息的 string。

参数

extension

可选的扩展名。

返回值

如果指定了可选参数 extension，phpversion()会返回该扩展的版本。 如果没有对应的版本信息，或者该扩展未启用，则返回 false。

范例

Example #1 phpversion() 范例

<?php
// prints e.g. 'Current PHP version: 4.1.1'
echo 'Current PHP version: ' . phpversion();

// prints e.g. '2.0' or nothing if the extension isn't enabled
echo phpversion('tidy');
?>

Example #2 PHP_VERSION_ID 范例和用法

<?php
// PHP_VERSION_ID 自 PHP 5.2.7 起有效，
// 如果我们的版本低于该版本，则用以下代码来模拟
if (!defined('PHP_VERSION_ID')) {
    $version = explode('.', PHP_VERSION);

    define('PHP_VERSION_ID', ($version[0] * 10000 + $version[1] * 100 + $version[2]));
}

// PHP_VERSION_ID 定义为一个数字，PHP 版本越新，数字越大。
// 它的定义是以下的表达式：
//
// $version_id = $major_version * 10000 + $minor_version * 100 + $release_version;
//
// 现在我们可以通过 PHP_VERSION_ID 来检查 PHP 版本，
// 而不用每次都必须用 version_compare() 来检查 PHP 是否支持某个功能。
//
// 比如，我们在此可以定义一系列 PHP_VERSION_* constants 常量，
// 而在 5.2.7 之前的版本并没有被定义。

if (PHP_VERSION_ID < 50207) {
    define('PHP_MAJOR_VERSION',   $version[0]);
    define('PHP_MINOR_VERSION',   $version[1]);
    define('PHP_RELEASE_VERSION', $version[2]);

    // 等等， ...
}
?>

注释

Note:

这些信息也存在于预定义常量 PHP_VERSION里。 更多版本的信息可以使用常量 PHP_VERSION_*。

参见

  • 常量 PHP_VERSION
  • version_compare() - 对比两个「PHP 规范化」的版本数字字符串
  • phpinfo() - 输出关于 PHP 配置的信息
  • phpcredits() - 打印 PHP 贡献者名单
  • php_logo_guid()
  • zend_version() - 获取当前 Zend 引擎的版本


设置环境变量的值

  • ? phpversion
  • restore_include_path ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 设置环境变量的值

putenv

(PHP 4, PHP 5, PHP 7, PHP 8)

putenv — 设置环境变量的值

说明

putenv ( string $setting ) : bool

添加 setting 到服务器环境变量。 环境变量仅存活于当前请求期间。 在请求结束时环境会恢复到初始状态。

参数

setting

设置，例如 "FOO=BAR"

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 设置一个环境变量

<?php
putenv("UNIQID=$uniqid");
?>

参见

  • getenv() - 获取一个环境变量的值
  • apache_setenv() - 设置 Apache 子进程环境变量


还原 include_path 配置选项的值

  • ? putenv
  • set_include_path ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 还原 include_path 配置选项的值

restore_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

restore_include_path — 还原 include_path 配置选项的值

说明

restore_include_path ( ) : void

还原到 php.ini 中设置的 include_path 主值。

返回值

没有返回值。

范例

Example #1 restore_include_path() 例子

<?php

echo get_include_path();  // .:/usr/local/lib/php

set_include_path('/inc');

echo get_include_path();  // /inc

restore_include_path();

// 或使用 ini_restore
ini_restore('include_path');

echo get_include_path();  // .:/usr/local/lib/php

?>

参见

  • ini_restore() - 恢复配置选项的值
  • get_include_path() - 获取当前的 include_path 配置选项
  • set_include_path() - 设置 include_path 配置选项
  • include - include


设置 include_path 配置选项

  • ? restore_include_path
  • set_time_limit ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 设置 include_path 配置选项

set_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

set_include_path — 设置 include_path 配置选项

说明

set_include_path ( string $new_include_path ) : string

为当前脚本设置 include_path 运行时的配置选项。

参数

new_include_path

include_path 新的值。

返回值

成功时返回旧的 include_path 或者在失败时返回 false。

范例

Example #1 set_include_path() 例子

<?php
set_include_path('/usr/lib/pear');

// 或使用 ini_set
ini_set('include_path', '/usr/lib/pear');
?>

Example #2 添加到include path

利用常量 PATH_SEPARATOR 可跨平台扩展 include path。

这个例子中我们把 /usr/lib/pear 添加到了 现有的 include_path 的尾部。

<?php
$path = '/usr/lib/pear';
set_include_path(get_include_path() . PATH_SEPARATOR . $path);
?>

参见

  • ini_set() - 为一个配置选项设置值
  • get_include_path() - 获取当前的 include_path 配置选项
  • restore_include_path() - 还原 include_path 配置选项的值
  • include - include


设置脚本最大执行时间

  • ? set_include_path
  • sys_get_temp_dir ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 设置脚本最大执行时间

set_time_limit

(PHP 4, PHP 5, PHP 7, PHP 8)

set_time_limit — 设置脚本最大执行时间

说明

set_time_limit ( int $seconds ) : bool

设置允许脚本运行的时间，单位为秒。如果超过了此设置，脚本返回一个致命的错误。默认值为30秒，或者是在php.ini的max_execution_time被定义的值，如果此值存在。

当此函数被调用时，set_time_limit()会从零开始重新启动超时计数器。换句话说，如果超时默认是30秒，在脚本运行了了25秒时调用 set_time_limit(20)，那么，脚本在超时之前可运行总时间为45秒。

参数

seconds

最大的执行时间，单位为秒。如果设置为0（零），没有时间方面的限制。

返回值

成功时返回 true，失败时返回 false 。

注释

Note:

set_time_limit()函数和配置指令max_execution_time只影响脚本本身执行的时间。任何发生在诸如使用system()的系统调用，流操作，数据库操作等的脚本执行的最大时间不包括其中，当该脚本已运行。在测量时间是实值的Windows中，情况就不是如此了。

参见

  • max_execution_time
  • max_input_time


返回用于临时文件的目录

  • ? set_time_limit
  • version_compare ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回用于临时文件的目录

sys_get_temp_dir

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

sys_get_temp_dir — 返回用于临时文件的目录

说明

sys_get_temp_dir ( ) : string

返回 PHP 储存临时文件的默认目录的路径。

返回值

返回临时目录的路径。

范例

Example #1 sys_get_temp_dir() 例子

<?php
// 使用 sys_get_temp_dir() 在目录里创建临时文件
$temp_file = tempnam(sys_get_temp_dir(), 'Tux');

echo $temp_file;
?>

以上例程的输出类似于：

C:\Windows\Temp\TuxA318.tmp

参见

  • tmpfile() - 建立一个临时文件
  • tempnam() - 建立一个具有唯一文件名的文件


对比两个「PHP 规范化」的版本数字字符串

  • ? sys_get_temp_dir
  • zend_thread_id ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 对比两个「PHP 规范化」的版本数字字符串

version_compare

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

version_compare — 对比两个「PHP 规范化」的版本数字字符串

说明

version_compare ( string $version1 , string $version2 , string $operator = ? ) : mixed

version_compare() 用于对比两个「PHP 规范化」的版本数字字符串。

此函数首先在版本字符串里用一个点 . 替换 _、- 和 +，也会在任意非数字前后插入一个点 .，这样，类似 '4.3.2RC1' 将会变成 '4.3.2.RC.1'。 接下来它会分割结果， 然后它会从左往右对比各个部分。 如果某部分包含了特定的版本字符串，将会用以下顺序处理： 列表中未找到的任意字符串 < dev < alpha = a < beta = b < RC = rc < # < pl = p。 这种方式不仅能够对比类似 '4.1' 和 '4.1.2' 那种不同的版本级别，同时也可以指定对比任何包含 PHP 开发状态的版本。

参数

version1

第一个版本数。

version2

第二个版本数。

operator

如果你指定了可选的第三个参数 operator，你可以测试两者的特定关系。 可以的操作符分别是：<、 lt、<=、 le、>、 gt、>=、 ge、==、 =、eq、 !=、<> 和 ne。

此参数区分大小写，它的值应该是小写的。

返回值

默认情况下，在第一个版本低于第二个时，version_compare() 返回 -1；如果两者相等，返回 0；第二个版本更低时则返回 1。

当使用了可选参数 operator 时，如果关系是操作符所指定的那个，函数将返回 true，否则返回 false。

范例

下例使用了 PHP_VERSION 常量，因为它执行的代码包含了 PHP 版本的值。

Example #1 version_compare() examples

<?php
if (version_compare(PHP_VERSION, '7.0.0') >= 0) {
    echo 'I am at least PHP version 7.0.0, my version: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.3.0') >= 0) {
    echo 'I am at least PHP version 5.3.0, my version: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.0.0', '>=')) {
    echo 'I am at least PHP version 5.0.0, my version: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.0.0', '<')) {
    echo 'I am still PHP 4, my version: ' . PHP_VERSION . "\n";
}
?>

注释

Note:

PHP_VERSION 常量包含了当前 PHP 的版本。

Note:

注意，类似 5.3.0-dev 的预发行版本，被认为是低于它们的最终发行版本（就像 5.3.0）。

Note:

指定类似 alpha、beta 的版本字符串是大小写敏感的。 版本字符串的来源若不遵循 PHP 标准，可能需要在调用 version_compare() 之前先用 strtolower() 转成小写。

参见

  • phpversion() - 获取当前的PHP版本
  • php_uname() - 返回运行 PHP 的系统的有关信息
  • function_exists() - 如果给定的函数已经被定义就返回 true


返回当前线程的唯一识别符

  • ? version_compare
  • zend_version ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 返回当前线程的唯一识别符

zend_thread_id

(PHP 5, PHP 7, PHP 8)

zend_thread_id — 返回当前线程的唯一识别符

说明

zend_thread_id ( ) : int

该函数返回当前线程的唯一识别符。

返回值

以整型（integer）返回线程的 ID。

范例

Example #1 zend_thread_id() 例子

<?php
$thread_id = zend_thread_id();

echo 'Current thread id is: ' . $thread_id;
?>

以上例程的输出类似于：

Current thread id is: 7864

注释

Note:

该函数仅在以下情况有效：PHP 内置 ZTS（Zend 线程安全）的支持， 并开启调试模式（--enable-debug）时。


获取当前 Zend 引擎的版本

  • ? zend_thread_id
  • phpdbg ?
  • PHP Manual
  • PHP 选项/信息 函数
  • 获取当前 Zend 引擎的版本

zend_version

(PHP 4, PHP 5, PHP 7, PHP 8)

zend_version — 获取当前 Zend 引擎的版本

说明

zend_version ( ) : string

获取当前运行的 Zend 引擎的版本字符串。

返回值

获取 Zend 引擎的版本数字的字符串。

范例

Example #1 zend_version() 例子

<?php
echo "Zend engine version: " . zend_version();
?>

以上例程的输出类似于：

Zend engine version: 2.2.0

参见

  • phpinfo() - 输出关于 PHP 配置的信息
  • phpcredits() - 打印 PHP 贡献者名单
  • php_logo_guid()
  • phpversion() - 获取当前的PHP版本


Interactive PHP Debugger

  • 简介
  • 安装／配置
    • 运行时配置
  • 预定义常量
  • phpdbg 函数
    • phpdbg_break_file — Inserts a breakpoint at a line in a file
    • phpdbg_break_function — Inserts a breakpoint at entry to a function
    • phpdbg_break_method — Inserts a breakpoint at entry to a method
    • phpdbg_break_next — Inserts a breakpoint at the next opcode
    • phpdbg_clear — Clears all breakpoints
    • phpdbg_color — Sets the color of certain elements
    • phpdbg_end_oplog — 说明
    • phpdbg_exec — Attempts to set the execution context
    • phpdbg_get_executable — 说明
    • phpdbg_prompt — Sets the command prompt
    • phpdbg_start_oplog — 说明


简介

Implemented as a SAPI module, phpdbg can exert complete control over the environment without impacting the functionality or performance of your code.

phpdbg aims to be a lightweight, powerful, easy to use debugging platform for PHP. It offers the following features:

  • Step-Through Debugging
  • Flexible Breakpoints (Class Method, Function, File:Line, Address, Opcode)
  • Easy Access to PHP with built-in eval()
  • Userland API
  • SAPI Agnostic - Easily Integrated
  • PHP Configuration File Support
  • JIT Super Globals - Set Your Own !!
  • Optional readline Support - Comfortable Terminal Operation
  • Easy Operation - See Help :)

Command line options
Option | Example Argument | Description
-c | -c/my/php.ini | Set php.ini file to load
-d | -dmemory_limit=4G | Set a php.ini directive
-n |  | Disable default php.ini
-q |  | Suppress welcome banner
-v |  | Enable oplog output
-b |  | Disable color
-i | -imy.init | Set .phpdbginit file
-I |  | Ignore default .phpdbginit
-O | -Omy.oplog | Set oplog output file
-r |  | Run execution context
-rr |  | Run execution context and quit after execution (not respecting breakpoints)
-e |  | Generate extended information for debugger/profiler
-E |  | Enable step through eval, careful!
-s | -s=, -s=foo | Read code to execute from stdin with an optional delimiter
-S | -Scli | Override SAPI name, careful!
-l | -l4000 | Setup remote console ports
-a | -a192.168.0.3 | Setup remote console bind address
-x |  | Enable xml output (instead of normal text output)
-p | -p, -p=func, -p* | Output opcodes and quit
-h |  | Print the help overview
-V |  | Print version number
-- | -- arg1 arg2 | Use to delimit phpdbg arguments and php $argv; append any $argv argument after it


  • ? 简介
  • 运行时配置 ?
  • PHP Manual
  • phpdbg
  • 安装／配置

安装／配置

Table of Contents

  • 运行时配置


运行时配置

这些函数的行为受 php.ini 中的设置影响。

phpdbg 配置选项
名字 | 默认 | 可修改范围 | 更新日志
phpdbg.eol | 2 | PHP_INI_ALL | Available as of PHP 7.0.0
phpdbg.path |  | 6 | Available as of PHP 5.6.3

这是配置指令的简短说明。

phpdbg.eol mixed

The kind of line ending to use for output. For setting the value, one of the string aliases must be used.

int Value | string Alias
0 | CRLF, crlf, DOS, dos
1 | LF, lf, UNIX, unix
2 | CR, cr, MAC, mac

phpdbg.path string


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

PHPDBG_VERSION (string)
PHPDBG_FILE (int)
Removed as of PHP 7.3.0.
PHPDBG_METHOD (int)
Removed as of PHP 7.3.0.
PHPDBG_LINENO (int)
Removed as of PHP 7.3.0.
PHPDBG_FUNC (int)
Removed as of PHP 7.3.0.
PHPDBG_COLOR_PROMPT (int)
PHPDBG_COLOR_NOTICE (int)
PHPDBG_COLOR_ERROR (int)


phpdbg 函数

Table of Contents

  • phpdbg_break_file — Inserts a breakpoint at a line in a file
  • phpdbg_break_function — Inserts a breakpoint at entry to a function
  • phpdbg_break_method — Inserts a breakpoint at entry to a method
  • phpdbg_break_next — Inserts a breakpoint at the next opcode
  • phpdbg_clear — Clears all breakpoints
  • phpdbg_color — Sets the color of certain elements
  • phpdbg_end_oplog — 说明
  • phpdbg_exec — Attempts to set the execution context
  • phpdbg_get_executable — 说明
  • phpdbg_prompt — Sets the command prompt
  • phpdbg_start_oplog — 说明


Inserts a breakpoint at a line in a file

  • ? phpdbg 函数
  • phpdbg_break_function ?
  • PHP Manual
  • phpdbg 函数
  • Inserts a breakpoint at a line in a file

phpdbg_break_file

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

phpdbg_break_file — Inserts a breakpoint at a line in a file

说明

phpdbg_break_file ( string $file , int $line ) : void

Insert a breakpoint at the given line in the given file.

参数

file

The name of the file.

line

The line number.

返回值

没有返回值。

参见

  • phpdbg_break_function() - Inserts a breakpoint at entry to a function
  • phpdbg_break_method() - Inserts a breakpoint at entry to a method
  • phpdbg_break_next() - Inserts a breakpoint at the next opcode
  • phpdbg_clear() - Clears all breakpoints


Inserts a breakpoint at entry to a function

  • ? phpdbg_break_file
  • phpdbg_break_method ?
  • PHP Manual
  • phpdbg 函数
  • Inserts a breakpoint at entry to a function

phpdbg_break_function

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

phpdbg_break_function — Inserts a breakpoint at entry to a function

说明

phpdbg_break_function ( string $function ) : void

Insert a breakpoint at the entry to the given function.

参数

function

The name of the function.

返回值

没有返回值。

参见

  • phpdbg_break_file() - Inserts a breakpoint at a line in a file
  • phpdbg_break_method() - Inserts a breakpoint at entry to a method
  • phpdbg_break_next() - Inserts a breakpoint at the next opcode
  • phpdbg_clear() - Clears all breakpoints


Inserts a breakpoint at entry to a method

  • ? phpdbg_break_function
  • phpdbg_break_next ?
  • PHP Manual
  • phpdbg 函数
  • Inserts a breakpoint at entry to a method

phpdbg_break_method

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

phpdbg_break_method — Inserts a breakpoint at entry to a method

说明

phpdbg_break_method ( string $class , string $method ) : void

Insert a breakpoint at the entry to the given method of the given class.

参数

class

The name of the class.

method

The name of the method.

返回值

没有返回值。

参见

  • phpdbg_break_file() - Inserts a breakpoint at a line in a file
  • phpdbg_break_function() - Inserts a breakpoint at entry to a function
  • phpdbg_break_next() - Inserts a breakpoint at the next opcode
  • phpdbg_clear() - Clears all breakpoints


Inserts a breakpoint at the next opcode

  • ? phpdbg_break_method
  • phpdbg_clear ?
  • PHP Manual
  • phpdbg 函数
  • Inserts a breakpoint at the next opcode

phpdbg_break_next

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

phpdbg_break_next — Inserts a breakpoint at the next opcode

说明

phpdbg_break_next ( ) : void

Insert a breakpoint at the next opcode.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • phpdbg_break_file() - Inserts a breakpoint at a line in a file
  • phpdbg_break_function() - Inserts a breakpoint at entry to a function
  • phpdbg_break_method() - Inserts a breakpoint at entry to a method
  • phpdbg_clear() - Clears all breakpoints


Clears all breakpoints

  • ? phpdbg_break_next
  • phpdbg_color ?
  • PHP Manual
  • phpdbg 函数
  • Clears all breakpoints

phpdbg_clear

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

phpdbg_clear — Clears all breakpoints

说明

phpdbg_clear ( ) : void

Clear all breakpoints that have been set, either via one of the phpdbg_break_*() functions or interactively in the console.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • phpdbg_break_file() - Inserts a breakpoint at a line in a file
  • phpdbg_break_function() - Inserts a breakpoint at entry to a function
  • phpdbg_break_method() - Inserts a breakpoint at entry to a method
  • phpdbg_break_next() - Inserts a breakpoint at the next opcode


Sets the color of certain elements

  • ? phpdbg_clear
  • phpdbg_end_oplog ?
  • PHP Manual
  • phpdbg 函数
  • Sets the color of certain elements

phpdbg_color

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

phpdbg_color — Sets the color of certain elements

说明

phpdbg_color ( int $element , string $color ) : void

Set the color of the given element.

参数

element

One of the PHPDBG_COLOR_* constants.

color

The name of the color. One of white, red, green, yellow, blue, purple, cyan or black, optionally with either a trailing -bold or -underline, for instance, white-bold or green-underline.

返回值

没有返回值。

参见

  • phpdbg_prompt() - Sets the command prompt


说明

  • ? phpdbg_color
  • phpdbg_exec ?
  • PHP Manual
  • phpdbg 函数
  • 说明

phpdbg_end_oplog

(PHP 7, PHP 8)

phpdbg_end_oplog —

说明

phpdbg_end_oplog ( array $options = [] ) : array|null

Warning

本函数还未编写文档，仅有参数列表。

参数

options

返回值


Attempts to set the execution context

  • ? phpdbg_end_oplog
  • phpdbg_get_executable ?
  • PHP Manual
  • phpdbg 函数
  • Attempts to set the execution context

phpdbg_exec

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

phpdbg_exec — Attempts to set the execution context

说明

phpdbg_exec ( string $context ) : string|bool

Warning

本函数还未编写文档，仅有参数列表。

参数

context

返回值

If the execution context was set previously it is returned. If the execution context was not set previously true is returned. If the request to set the context fails, false is returned, and an E_WARNING raised.


说明

  • ? phpdbg_exec
  • phpdbg_prompt ?
  • PHP Manual
  • phpdbg 函数
  • 说明

phpdbg_get_executable

(PHP 7, PHP 8)

phpdbg_get_executable —

说明

phpdbg_get_executable ( array $options = [] ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

options

返回值


Sets the command prompt

  • ? phpdbg_get_executable
  • phpdbg_start_oplog ?
  • PHP Manual
  • phpdbg 函数
  • Sets the command prompt

phpdbg_prompt

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

phpdbg_prompt — Sets the command prompt

说明

phpdbg_prompt ( string $string ) : void

Set the command prompt to the given string.

参数

string

The string to use as command prompt.

返回值

没有返回值。

参见

  • phpdbg_color() - Sets the color of certain elements


说明

  • ? phpdbg_prompt
  • runkit7 ?
  • PHP Manual
  • phpdbg 函数
  • 说明

phpdbg_start_oplog

(PHP 7, PHP 8)

phpdbg_start_oplog —

说明

phpdbg_start_oplog ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


runkit7

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • runkit7 函数
    • runkit7_constant_add — Similar to define(), but allows defining in class definitions as well
    • runkit7_constant_redefine — Redefine an already defined constant
    • runkit7_constant_remove — Remove/Delete an already defined constant
    • runkit7_function_add — Add a new function, similar to create_function
    • runkit7_function_copy — Copy a function to a new function name
    • runkit7_function_redefine — Replace a function definition with a new implementation
    • runkit7_function_remove — Remove a function definition
    • runkit7_function_rename — Change a function's name
    • runkit7_import — Process a PHP file importing function and class definitions, overwriting where appropriate
    • runkit7_method_add — Dynamically adds a new method to a given class
    • runkit7_method_copy — Copies a method from class to another
    • runkit7_method_redefine — Dynamically changes the code of the given method
    • runkit7_method_remove — Dynamically removes the given method
    • runkit7_method_rename — Dynamically changes the name of the given method
    • runkit7_object_id — Return the integer object handle for given object
    • runkit7_superglobals — Return numerically indexed array of registered superglobals
    • runkit7_zval_inspect — Returns information about the passed in value with data types, reference counts, etc


简介

The runkit7 extension provides means to modify constants, user-defined functions, and user-defined classes. It also provides for custom superglobal variables.

This package is a fork of the » runkit package providing PHP 7 support.


需求

Modifying Constants, Functions, Classes, and Methods as well as Custom Superglobals works with all releases of PHP 7. No special requirements are necessary.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/runkit7.

此扩展在 Windows 平台的二进制扩展 (DLL 文件) PECL 可以在 PECL 官方网站上下载。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Runkit Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
runkit.superglobal | "" | PHP_INI_PERDIR |
runkit.internal_override | "0" | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

runkit.superglobal string
Comma-separated list of variable names to be treated as superglobals. This value should be set in the systemwide php.ini file, but may work in perdir configuration contexts depending on your SAPI.

Example #1 Custom Superglobals with runkit.superglobal=_FOO,_BAR in php.ini

<?php
function show_values() {
  echo "Foo is $_FOO\n";
  echo "Bar is $_BAR\n";
  echo "Baz is $_BAZ\n";
}

$_FOO = 'foo';
$_BAR = 'bar';
$_BAZ = 'baz';

/* Displays foo and bar, but not baz */
show_values();
?>
runkit.internal_override bool
Enables ability to modify/rename/remove internal functions.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

RUNKIT7_IMPORT_FUNCTIONS (int)
runkit7_import() flag indicating that normal functions should be imported from the specified file.
RUNKIT7_IMPORT_CLASS_METHODS (int)
runkit7_import() flag indicating that class methods should be imported from the specified file.
RUNKIT7_IMPORT_CLASS_CONSTS (int)
runkit7_import() flag indicating that class constants should be imported from the specified file.
RUNKIT7_IMPORT_CLASS_PROPS (int)
runkit7_import() flag indicating that class standard properties should be imported from the specified file.
RUNKIT7_IMPORT_CLASS_STATIC_PROPS (int)
runkit7_import() flag indicating that class static properties should be imported from the specified file. Available since Runkit 1.0.1.
RUNKIT7_IMPORT_CLASSES (int)
runkit7_import() flag representing a bitwise OR of the RUNKIT7_IMPORT_CLASS_* constants.
RUNKIT7_IMPORT_OVERRIDE (int)
runkit7_import() flag indicating that if any of the imported functions, methods, constants, or properties already exist, they should be replaced with the new definitions. If this flag is not set, then any imported definitions which already exist will be discarded.
RUNKIT7_ACC_RETURN_REFERENCE (int)
Include this flag to make the function or method being created or redeclared return a reference.
RUNKIT7_ACC_PUBLIC (int)
Flag for runkit7_method_add() and runkit7_method_redefine() to make the method public.
RUNKIT7_ACC_PROTECTED (int)
Flag for runkit7_method_add() and runkit7_method_redefine() to make the method protected.
RUNKIT7_ACC_PRIVATE (int)
Flag for runkit7_method_add() and runkit7_method_redefine() to make the method private.
RUNKIT7_ACC_STATIC (int)
Flag for runkit7_method_add() and runkit7_method_redefine() to make the method static.
RUNKIT7_FEATURE_MANIPULATION (int)
Equal to 1 if runtime manipulation is enabled, and 0 otherwise.
RUNKIT7_FEATURE_SUPERGLOBALS (int)
Equal to 1 if custom superglobals are enabled, and 0 otherwise.
RUNKIT7_FEATURE_SANDBOX (int)
Always 0, it's impractical to implement the sandbox feature in php 7.


runkit7 函数

Table of Contents

  • runkit7_constant_add — Similar to define(), but allows defining in class definitions as well
  • runkit7_constant_redefine — Redefine an already defined constant
  • runkit7_constant_remove — Remove/Delete an already defined constant
  • runkit7_function_add — Add a new function, similar to create_function
  • runkit7_function_copy — Copy a function to a new function name
  • runkit7_function_redefine — Replace a function definition with a new implementation
  • runkit7_function_remove — Remove a function definition
  • runkit7_function_rename — Change a function's name
  • runkit7_import — Process a PHP file importing function and class definitions, overwriting where appropriate
  • runkit7_method_add — Dynamically adds a new method to a given class
  • runkit7_method_copy — Copies a method from class to another
  • runkit7_method_redefine — Dynamically changes the code of the given method
  • runkit7_method_remove — Dynamically removes the given method
  • runkit7_method_rename — Dynamically changes the name of the given method
  • runkit7_object_id — Return the integer object handle for given object
  • runkit7_superglobals — Return numerically indexed array of registered superglobals
  • runkit7_zval_inspect — Returns information about the passed in value with data types, reference counts, etc


Similar to define(), but allows defining in class definitions as well

  • ? runkit7 函数
  • runkit7_constant_redefine ?
  • PHP Manual
  • runkit7 函数
  • Similar to define(), but allows defining in class definitions as well

runkit7_constant_add

(PECL runkit7 >= Unknown)

runkit7_constant_add — Similar to define(), but allows defining in class definitions as well

说明

runkit7_constant_add ( string $constname , mixed $value , int $newVisibility = ? ) : bool

参数

constname

Name of constant to declare. Either a string to indicate a global constant, or classname::constname to indicate a class constant.

value

NULL, Bool, Long, Double, String, Array, or Resource value to store in the new constant.

newVisibility

Visibility of the constant, for class constants. Public by default. One of the RUNKIT7_ACC_* constants.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • define() - 定义一个常量
  • runkit7_constant_redefine() - Redefine an already defined constant
  • runkit7_constant_remove() - Remove/Delete an already defined constant


Redefine an already defined constant

  • ? runkit7_constant_add
  • runkit7_constant_remove ?
  • PHP Manual
  • runkit7 函数
  • Redefine an already defined constant

runkit7_constant_redefine

(PECL runkit7 >= Unknown)

runkit7_constant_redefine — Redefine an already defined constant

说明

runkit7_constant_redefine ( string $constname , mixed $value , string $newVisibility = ? ) : bool

参数

constname

Constant to redefine. Either the name of a global constant, or classname::constname indicating class constant.

value

Value to assign to the constant.

newVisibility

The new visibility of the constant, for class constants. Unchanged by default. One of the RUNKIT7_ACC_* constants.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • runkit7_constant_add() - Similar to define(), but allows defining in class definitions as well
  • runkit7_constant_remove() - Remove/Delete an already defined constant


Remove/Delete an already defined constant

  • ? runkit7_constant_redefine
  • runkit7_function_add ?
  • PHP Manual
  • runkit7 函数
  • Remove/Delete an already defined constant

runkit7_constant_remove

(PECL runkit7 >= Unknown)

runkit7_constant_remove — Remove/Delete an already defined constant

说明

runkit7_constant_remove ( string $constname ) : bool

参数

constname

Name of the constant to remove. Either the name of a global constant, or classname::constname indicating a class constant.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • define() - 定义一个常量
  • runkit7_constant_add() - Similar to define(), but allows defining in class definitions as well
  • runkit7_constant_redefine() - Redefine an already defined constant


Add a new function, similar to create_function

  • ? runkit7_constant_remove
  • runkit7_function_copy ?
  • PHP Manual
  • runkit7 函数
  • Add a new function, similar to create_function

runkit7_function_add

(PECL runkit7 >= Unknown)

runkit7_function_add — Add a new function, similar to create_function()

说明

runkit7_function_add ( string $funcname , string $arglist , string $code , bool $return_by_reference = null , string $doc_comment = null , string $return_type = ? , bool $is_strict = ? ) : bool
runkit7_function_add ( string $funcname , Closure $closure , string $doc_comment = null , string $return_type = ? , bool $is_strict = ? ) : bool

参数

funcname

Name of the function to be created

arglist

Comma separated argument list

code

Code making up the function

closure

A closure that defines the function.

return_by_reference

Whether the function should return by reference.

doc_comment

The doc comment of the function.

return_type

The return type of the function.

is_strict

Whether the function should behave as if it were declared in a file with strict_types=1

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 A runkit7_function_add() example

<?php
runkit7_function_add('testme','$a,$b','echo "The value of a is $a\n"; echo "The value of b is $b\n";');
testme(1,2);
?>

以上例程会输出：

The value of a is 1
The value of b is 2

参见

  • create_function() - Create an anonymous (lambda-style) function
  • runkit7_function_redefine() - Replace a function definition with a new implementation
  • runkit7_function_copy() - Copy a function to a new function name
  • runkit7_function_rename() - Change a function's name
  • runkit7_function_remove() - Remove a function definition
  • runkit7_method_add() - Dynamically adds a new method to a given class


Copy a function to a new function name

  • ? runkit7_function_add
  • runkit7_function_redefine ?
  • PHP Manual
  • runkit7 函数
  • Copy a function to a new function name

runkit7_function_copy

(PECL runkit7 >= Unknown)

runkit7_function_copy — Copy a function to a new function name

说明

runkit7_function_copy ( string $funcname , string $targetname ) : bool

参数

funcname

Name of the existing function

targetname

Name of the new function to copy the definition to

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 A runkit7_function_copy() example

<?php
function original() {
  echo "In a function\n";
}
runkit7_function_copy('original','duplicate');
original();
duplicate();
?>

以上例程会输出：

In a function
In a function

参见

  • runkit7_function_add() - Add a new function, similar to create_function
  • runkit7_function_redefine() - Replace a function definition with a new implementation
  • runkit7_function_rename() - Change a function's name
  • runkit7_function_remove() - Remove a function definition


Replace a function definition with a new implementation

  • ? runkit7_function_copy
  • runkit7_function_remove ?
  • PHP Manual
  • runkit7 函数
  • Replace a function definition with a new implementation

runkit7_function_redefine

(PECL runkit7 >= Unknown)

runkit7_function_redefine — Replace a function definition with a new implementation

说明

runkit7_function_redefine ( string $funcname , string $arglist , string $code , bool $return_by_reference = null , string $doc_comment = null , string $return_type = ? , string $is_strict = ? ) : bool
runkit7_function_redefine ( string $funcname , Closure $closure , string $doc_comment = null , string $return_type = ? , string $is_strict = ? ) : bool

Note: 默认情况下，仅在用户空间可删除，重命名，或者修改函数。为了覆盖内部函数，必须启用 php.ini 中的 runkit.internal_override 设置。

参数

funcname

Name of function to redefine

arglist

New list of arguments to be accepted by function

code

New code implementation

closure

A closure that defines the function.

return_by_reference

Whether the function should return by reference.

doc_comment

The doc comment of the function.

return_type

The return type of the function.

is_strict

Whether the function behaves as if it was declared in a file with strict_types=1

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 A runkit7_function_redefine() example

<?php
function testme() {
  echo "Original Testme Implementation\n";
}
testme();
runkit7_function_redefine('testme','','echo "New Testme Implementation\n";');
testme();
?>

以上例程会输出：

Original Testme Implementation
New Testme Implementation

参见

  • runkit7_function_add() - Add a new function, similar to create_function
  • runkit7_function_copy() - Copy a function to a new function name
  • runkit7_function_rename() - Change a function's name
  • runkit7_function_remove() - Remove a function definition
  • runkit7_method_redefine() - Dynamically changes the code of the given method


Remove a function definition

  • ? runkit7_function_redefine
  • runkit7_function_rename ?
  • PHP Manual
  • runkit7 函数
  • Remove a function definition

runkit7_function_remove

(PECL runkit7 >= Unknown)

runkit7_function_remove — Remove a function definition

说明

runkit7_function_remove ( string $funcname ) : bool

Note: 默认情况下，仅在用户空间可删除，重命名，或者修改函数。为了覆盖内部函数，必须启用 php.ini 中的 runkit.internal_override 设置。

参数

funcname

Name of the function to be deleted

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • runkit7_function_add() - Add a new function, similar to create_function
  • runkit7_function_copy() - Copy a function to a new function name
  • runkit7_function_redefine() - Replace a function definition with a new implementation
  • runkit7_function_rename() - Change a function's name


Change a function's name

  • ? runkit7_function_remove
  • runkit7_import ?
  • PHP Manual
  • runkit7 函数
  • Change a function's name

runkit7_function_rename

(PECL runkit7 >= Unknown)

runkit7_function_rename — Change a function's name

说明

runkit7_function_rename ( string $funcname , string $newname ) : bool

Note: 默认情况下，仅在用户空间可删除，重命名，或者修改函数。为了覆盖内部函数，必须启用 php.ini 中的 runkit.internal_override 设置。

参数

funcname

Current function name

newname

New function name

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • runkit7_function_add() - Add a new function, similar to create_function
  • runkit7_function_copy() - Copy a function to a new function name
  • runkit7_function_redefine() - Replace a function definition with a new implementation
  • runkit7_function_remove() - Remove a function definition


Process a PHP file importing function and class definitions, overwriting where appropriate

  • ? runkit7_function_rename
  • runkit7_method_add ?
  • PHP Manual
  • runkit7 函数
  • Process a PHP file importing function and class definitions, overwriting where appropriate

runkit7_import

(PECL runkit7 >= Unknown)

runkit7_import — Process a PHP file importing function and class definitions, overwriting where appropriate

说明

runkit7_import ( string $filename , int $flags = ? ) : bool

Similar to include. However, any code residing outside of a function or class is simply ignored. Additionally, depending on the value of flags, any functions or classes which already exist in the currently running environment may be automatically overwritten by their new definitions.

参数

filename

Filename to import function and class definitions from

flags

Bitwise OR of the RUNKIT7_IMPORT_* family of constants.

返回值

成功时返回 true， 或者在失败时返回 false。


Dynamically adds a new method to a given class

  • ? runkit7_import
  • runkit7_method_copy ?
  • PHP Manual
  • runkit7 函数
  • Dynamically adds a new method to a given class

runkit7_method_add

(PECL runkit7 >= Unknown)

runkit7_method_add — Dynamically adds a new method to a given class

说明

runkit7_method_add ( string $classname , string $methodname , string $args , string $code , int $flags = RUNKIT7_ACC_PUBLIC , string $doc_comment = null , string $return_type = ? , bool $is_strict = ? ) : bool
runkit7_method_add ( string $classname , string $methodname , Closure $closure , int $flags = RUNKIT7_ACC_PUBLIC , string $doc_comment = null , string $return_type = ? , bool $is_strict = ? ) : bool

参数

classname

The class to which this method will be added

methodname

The name of the method to add

args

Comma-delimited list of arguments for the newly-created method

code

The code to be evaluated when methodname is called

closure

A closure that defines the method.

flags

The type of method to create, can be RUNKIT7_ACC_PUBLIC, RUNKIT7_ACC_PROTECTED or RUNKIT7_ACC_PRIVATE optionally combined via bitwise OR with RUNKIT7_ACC_STATIC

doc_comment

The doc comment of the method.

return_type

The return type of the method.

is_strict

Whether the method behaves as if it were declared in a file with strict_types=1

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 runkit7_method_add() example

<?php
class Example {
    function foo() {
        echo "foo!\n";
    }
}

// create an Example object
$e = new Example();

// Add a new public method
runkit7_method_add(
    'Example',
    'add',
    '$num1, $num2',
    'return $num1 + $num2;',
    RUNKIT7_ACC_PUBLIC
);

// add 12 + 4
echo $e->add(12, 4);
?>

以上例程会输出：

16

参见

  • runkit7_method_copy() - Copies a method from class to another
  • runkit7_method_redefine() - Dynamically changes the code of the given method
  • runkit7_method_remove() - Dynamically removes the given method
  • runkit7_method_rename() - Dynamically changes the name of the given method
  • runkit7_function_add() - Add a new function, similar to create_function


Copies a method from class to another

  • ? runkit7_method_add
  • runkit7_method_redefine ?
  • PHP Manual
  • runkit7 函数
  • Copies a method from class to another

runkit7_method_copy

(PECL runkit7 >= Unknown)

runkit7_method_copy — Copies a method from class to another

说明

runkit7_method_copy ( string $dClass , string $dMethod , string $sClass , string $sMethod = ? ) : bool

参数

dClass

Destination class for copied method

dMethod

Destination method name

sClass

Source class of the method to copy

sMethod

Name of the method to copy from the source class. If this parameter is omitted, the value of dMethod is assumed.

返回值

范例

Example #1 runkit7_method_copy() example

<?php
class Foo {
    function example() {
        return "foo!\n";
    }
}

class Bar {
    // initially, no methods
}

// copy the example() method from the Foo class to the Bar class, as baz()
runkit7_method_copy('Bar', 'baz', 'Foo', 'example');

// output copied function
echo Bar::baz();
?>

以上例程会输出：

foo!

参见

  • runkit7_method_add() - Dynamically adds a new method to a given class
  • runkit7_method_redefine() - Dynamically changes the code of the given method
  • runkit7_method_remove() - Dynamically removes the given method
  • runkit7_method_rename() - Dynamically changes the name of the given method
  • runkit7_function_copy() - Copy a function to a new function name


Dynamically changes the code of the given method

  • ? runkit7_method_copy
  • runkit7_method_remove ?
  • PHP Manual
  • runkit7 函数
  • Dynamically changes the code of the given method

runkit7_method_redefine

(PECL runkit7 >= Unknown)

runkit7_method_redefine — Dynamically changes the code of the given method

说明

runkit7_method_redefine ( string $classname , string $methodname , string $args , string $code , int $flags = RUNKIT7_ACC_PUBLIC , string $doc_comment = null , string $return_type = ? , bool $is_strict = ? ) : bool
runkit7_method_redefine ( string $classname , string $methodname , Closure $closure , int $flags = RUNKIT7_ACC_PUBLIC , string $doc_comment = null , string $return_type = ? , bool $is_strict = ? ) : bool

参数

classname

The class in which to redefine the method

methodname

The name of the method to redefine

args

Comma-delimited list of arguments for the redefined method

code

The new code to be evaluated when methodname is called

closure

A closure that defines the method.

flags

The redefined method can be RUNKIT7_ACC_PUBLIC, RUNKIT7_ACC_PROTECTED or RUNKIT7_ACC_PRIVATE optionally combined via bitwise OR with RUNKIT7_ACC_STATIC

doc_comment

The doc comment of the method.

return_type

The return type of the method.

is_strict

Whether the method behaves as if it was declared in a file with strict_types=1.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 runkit7_method_redefine() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// create an Example object
$e = new Example();

// output Example::foo() (before redefine)
echo "Before: " . $e->foo();

// Redefine the 'foo' method
runkit7_method_redefine(
    'Example',
    'foo',
    '',
    'return "bar!\n";',
    RUNKIT7_ACC_PUBLIC
);

// output Example::foo() (after redefine)
echo "After: " . $e->foo();
?>

以上例程会输出：

Before: foo!
After: bar!

参见

  • runkit7_method_add() - Dynamically adds a new method to a given class
  • runkit7_method_copy() - Copies a method from class to another
  • runkit7_method_remove() - Dynamically removes the given method
  • runkit7_method_rename() - Dynamically changes the name of the given method
  • runkit7_function_redefine() - Replace a function definition with a new implementation


Dynamically removes the given method

  • ? runkit7_method_redefine
  • runkit7_method_rename ?
  • PHP Manual
  • runkit7 函数
  • Dynamically removes the given method

runkit7_method_remove

(PECL runkit7 >= Unknown)

runkit7_method_remove — Dynamically removes the given method

说明

runkit7_method_remove ( string $classname , string $methodname ) : bool

Note: 此函数不能用来操作当前正常运行（或运行链上）的方法。

参数

classname

The class in which to remove the method

methodname

The name of the method to remove

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 runkit7_method_remove() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }

    function bar() {
        return "bar!\n";
    }
}

// Remove the 'foo' method
runkit7_method_remove(
    'Example',
    'foo'
);

echo implode(' ', get_class_methods('Example'));

?>

以上例程会输出：

bar

参见

  • runkit7_method_add() - Dynamically adds a new method to a given class
  • runkit7_method_copy() - Copies a method from class to another
  • runkit7_method_redefine() - Dynamically changes the code of the given method
  • runkit7_method_rename() - Dynamically changes the name of the given method
  • runkit7_function_remove() - Remove a function definition


Dynamically changes the name of the given method

  • ? runkit7_method_remove
  • runkit7_object_id ?
  • PHP Manual
  • runkit7 函数
  • Dynamically changes the name of the given method

runkit7_method_rename

(PECL runkit7 >= Unknown)

runkit7_method_rename — Dynamically changes the name of the given method

说明

runkit7_method_rename ( string $classname , string $methodname , string $newname ) : bool

Note: 此函数不能用来操作当前正常运行（或运行链上）的方法。

参数

classname

The class in which to rename the method

methodname

The name of the method to rename

newname

The new name to give to the renamed method

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 runkit7_method_rename() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// Rename the 'foo' method to 'bar'
runkit7_method_rename(
    'Example',
    'foo',
    'bar'
);

// output renamed function
echo Example::bar();
?>

以上例程会输出：

foo!

参见

  • runkit7_method_add() - Dynamically adds a new method to a given class
  • runkit7_method_copy() - Copies a method from class to another
  • runkit7_method_redefine() - Dynamically changes the code of the given method
  • runkit7_method_remove() - Dynamically removes the given method
  • runkit7_function_rename() - Change a function's name


Return the integer object handle for given object

  • ? runkit7_method_rename
  • runkit7_superglobals ?
  • PHP Manual
  • runkit7 函数
  • Return the integer object handle for given object

runkit7_object_id

(PECL runkit7 >= Unknown)

runkit7_object_id — Return the integer object handle for given object

说明

runkit7_object_id ( object $obj ) : int

This function returns a unique identifier for the object. The object id is unique for the lifetime of the object. Once the object is destroyed, its id may be reused for other objects. This behavior is similar to spl_object_hash().

参数

obj

Any object.

返回值

An integer identifier that is unique for each currently existing object and is always the same for each object.

注释

Note:

When an object is destroyed, its id may be reused for other objects.


Return numerically indexed array of registered superglobals

  • ? runkit7_object_id
  • runkit7_zval_inspect ?
  • PHP Manual
  • runkit7 函数
  • Return numerically indexed array of registered superglobals

runkit7_superglobals

(PECL runkit7 >= Unknown)

runkit7_superglobals — Return numerically indexed array of registered superglobals

说明

runkit7_superglobals ( ) : array

参数

此函数没有参数。

返回值

Returns a numerically indexed array of the currently registered superglobals. i.e. _GET, _POST, _REQUEST, _COOKIE, _SESSION, _SERVER, _ENV, _FILES

参见

  • Variable Scope


Returns information about the passed in value with data types, reference counts, etc

  • ? runkit7_superglobals
  • uopz ?
  • PHP Manual
  • runkit7 函数
  • Returns information about the passed in value with data types, reference counts, etc

runkit7_zval_inspect

(PECL runkit7 >= Unknown)

runkit7_zval_inspect — Returns information about the passed in value with data types, reference counts, etc

说明

runkit7_zval_inspect ( string $value ) : array

参数

value

The value to return the representation of


User Operations for Zend

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Uopz 函数
    • uopz_add_function — Adds non-existent function or method
    • uopz_allow_exit — Allows control over disabled exit opcode
    • uopz_backup — Backup a function
    • uopz_compose — Compose a class
    • uopz_copy — Copy a function
    • uopz_del_function — Deletes previously added function or method
    • uopz_delete — Delete a function
    • uopz_extend — Extend a class at runtime
    • uopz_flags — Get or set flags on function or class
    • uopz_function — Creates a function at runtime
    • uopz_get_exit_status — Retrieve the last set exit status
    • uopz_get_hook — Gets previously set hook on function or method
    • uopz_get_mock — Get the current mock for a class
    • uopz_get_property — Gets value of class or instance property
    • uopz_get_return — Gets a previous set return value for a function
    • uopz_get_static — Gets the static variables from function or method scope
    • uopz_implement — Implements an interface at runtime
    • uopz_overload — Overload a VM opcode
    • uopz_redefine — Redefine a constant
    • uopz_rename — Rename a function at runtime
    • uopz_restore — Restore a previously backed up function
    • uopz_set_hook — Sets hook to execute when entering a function or method
    • uopz_set_mock — Use mock instead of class for new objects
    • uopz_set_property — Sets value of existing class or instance property
    • uopz_set_return — Provide a return value for an existing function
    • uopz_set_static — Sets the static variables in function or method scope
    • uopz_undefine — Undefine a constant
    • uopz_unset_hook — Removes previously set hook on function or method
    • uopz_unset_mock — Unset previously set mock
    • uopz_unset_return — Unsets a previously set return value for a function


简介

The uopz - User Operations for Zend - extension exposes Zend Engine functionality normally used at compilation and execution time in order to allow modification of the internal structures that represent PHP code, and for user code to interact with the VM.

uopz supports the following activities:

  • Overloading some opcodes including ZEND_EXIT and ZEND_NEW
  • Backup and restore functions and methods
  • Renaming functions and methods
  • Copying of functions and methods
  • Deletion of functions and methods
  • Redefinition of global and class constants
  • Deletion of global and class constants
  • Runtime composition and modification of classes

Note:

All of the activities supported are compatible with opcache

Caution

PECL uopz 6.1.1 is not compatible with Xdebug >= 2.9.4. Later uopz versions are not compatible with Xdebug < 2.9.4.


需求

uopz 2 requires PHP 5.4+. uopz 5.0 requires PHP 7. As of uopz 5.1, PHP 7.1+ is required.


安装

uopz releases are hosted by PECL and the source code by » github, the easiest route to installation is the normal PECL route: » https://pecl.php.net/package/uopz.

Windows users can download prebuilt release binaries from the » PECL website.

As of uopz 5.0.0 the extension must be loaded as extension. Before this version it must be loaded as zend_extension.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

uopz 配置选项
名字 | 默认 | 可修改范围 | 更新日志
uopz.disable | "0" | PHP_INI_SYSTEM | Available as of uopz 5.0.2
uopz.exit | "0" | PHP_INI_SYSTEM | Available as of uopz 6.0.1
uopz.overloads | "1" | PHP_INI_SYSTEM | Available as of uopz 2.0.2. Removed as of uopz 5.0.0.
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

uopz.disable bool

If enabled, uopz should stop having any effect on the engine.

uopz.exit bool

Whether to allow the execution of exit opcodes or not. This setting can be overridden during runtime by calling uopz_allow_exit().

uopz.exit bool

Enables the ability to use uopz_overload().

Note: When running with OPcache enabled, it may be necessary to disable all OPcache optimizations (opcache.optimization_level=0).


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

The following opcodes are defined as constants by uopz before 5.0.0:

ZEND_EXIT (int)
Invoked by exit() and die(), receives no arguments. Return boolean true to exit, false to continue
ZEND_NEW (int)
Invoked by object construction, receives the class of object being created as the only argument
ZEND_THROW (int)
Invoked by the throw construct, receives the class of exception being thrown as the only argument
ZEND_FETCH_CLASS (int)
Invoked upon composure, receives the class the name of the class being fetched as the only argument
ZEND_ADD_TRAIT (int)
Invoked upon composure, receives the class the trait is being added to as the first argument, and the name of the trait as the second argument
ZEND_ADD_INTERFACE (int)
Invoked upon composure, receives the class the interface is being added to as the first argument, and the name of the interface as the second argument
ZEND_INSTANCEOF (int)
Invoked by instanceof operator, receives the object being verified as the first argument, and the name of the class which that object should be as the second argument

The following constants control the VM's behaviour after a user handler is invoked, be extremely careful! These constants are removed as of uopz 5.0.0.

ZEND_USER_OPCODE_CONTINUE (int)
Advance 1 opcode and continuue
ZEND_USER_OPCODE_ENTER (int)
Enter into new op_array without recursion
ZEND_USER_OPCODE_LEAVE (int)
Return to calling op_array within the same executor
ZEND_USER_OPCODE_DISPATCH (int)
Dispatch to original opcode handler
ZEND_USER_OPCODE_DISPATCH_TO (int)
Dispatch to a specific handler (OR'd with ZEND opcode constant)
ZEND_USER_OPCODE_RETURN (int)
Exit from executor (return from function)

The following modifiers are registered as constants by uopz

ZEND_ACC_PUBLIC (int)
Mark function as public, the default
ZEND_ACC_PROTECTED (int)
Mark function as protected
ZEND_ACC_PRIVATE (int)
Mark function as private
ZEND_ACC_STATIC (int)
Mark function as static
ZEND_ACC_FINAL (int)
Mark function as final
ZEND_ACC_ABSTRACT (int)
Mark function as abstract
ZEND_ACC_CLASS (int)
Dummy registered for consistency, the default kind of class entry. Removed as of uopz 5.0.0.
ZEND_ACC_INTERFACE (int)
Mark class as interface. Removed as of uopz 5.0.0.
ZEND_ACC_TRAIT (int)
Mark class as trait. Removed as of uopz 5.0.0.
ZEND_ACC_FETCH (int)
Used for getting flags only. Removed as of uopz 5.0.0.


Uopz 函数

Table of Contents

  • uopz_add_function — Adds non-existent function or method
  • uopz_allow_exit — Allows control over disabled exit opcode
  • uopz_backup — Backup a function
  • uopz_compose — Compose a class
  • uopz_copy — Copy a function
  • uopz_del_function — Deletes previously added function or method
  • uopz_delete — Delete a function
  • uopz_extend — Extend a class at runtime
  • uopz_flags — Get or set flags on function or class
  • uopz_function — Creates a function at runtime
  • uopz_get_exit_status — Retrieve the last set exit status
  • uopz_get_hook — Gets previously set hook on function or method
  • uopz_get_mock — Get the current mock for a class
  • uopz_get_property — Gets value of class or instance property
  • uopz_get_return — Gets a previous set return value for a function
  • uopz_get_static — Gets the static variables from function or method scope
  • uopz_implement — Implements an interface at runtime
  • uopz_overload — Overload a VM opcode
  • uopz_redefine — Redefine a constant
  • uopz_rename — Rename a function at runtime
  • uopz_restore — Restore a previously backed up function
  • uopz_set_hook — Sets hook to execute when entering a function or method
  • uopz_set_mock — Use mock instead of class for new objects
  • uopz_set_property — Sets value of existing class or instance property
  • uopz_set_return — Provide a return value for an existing function
  • uopz_set_static — Sets the static variables in function or method scope
  • uopz_undefine — Undefine a constant
  • uopz_unset_hook — Removes previously set hook on function or method
  • uopz_unset_mock — Unset previously set mock
  • uopz_unset_return — Unsets a previously set return value for a function


Adds non-existent function or method

  • ? Uopz 函数
  • uopz_allow_exit ?
  • PHP Manual
  • Uopz 函数
  • Adds non-existent function or method

uopz_add_function

(PECL uopz 5, PECL uopz 6)

uopz_add_function — Adds non-existent function or method

说明

uopz_add_function ( string $function , Closure $handler , int &$flags = ZEND_ACC_PUBLIC ) : bool
uopz_add_function ( string $class , string $function , Closure $handler , int &$flags = ZEND_ACC_PUBLIC , int &$all = true ) : bool

Adds a non-existent function or method.

参数

class

The name of the class.

function

The name of the function or method.

handler

The Closure that defines the new function or method.

flags

Flags to set for the new function or method.

all

Whether all classes that descend from class will also be affected.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

uopz_add_function() throws a RuntimeException if the function or method to add already exists.

范例

Example #1 Basic uopz_add_function() Usage

<?php
uopz_add_function('foo', function () {echo 'bar';});
foo();
?>

以上例程会输出：

bar

参见

  • uopz_del_function() - Deletes previously added function or method
  • uopz_set_return() - Provide a return value for an existing function


Allows control over disabled exit opcode

  • ? uopz_add_function
  • uopz_backup ?
  • PHP Manual
  • Uopz 函数
  • Allows control over disabled exit opcode

uopz_allow_exit

(PECL uopz 5, PECL uopz 6)

uopz_allow_exit — Allows control over disabled exit opcode

说明

uopz_allow_exit ( bool $allow ) : void

By default uopz disables the exit opcode, so exit() calls are practically ignored. uopz_allow_exit() allows to control this behavior.

参数

allow

Whether to allow the execution of exit opcodes or not.

返回值

没有返回值。

范例

Example #1 uopz_allow_exit() example

<?php
exit(1);
echo 1;
uopz_allow_exit(true);
exit(2);
echo 2;
?>

以上例程会输出：

1

注释

Caution

OPcache optimizes away dead code after unconditional exit.

参见

  • uopz_get_exit_status() - Retrieve the last set exit status


Backup a function

  • ? uopz_allow_exit
  • uopz_compose ?
  • PHP Manual
  • Uopz 函数
  • Backup a function

uopz_backup

(PECL uopz 1 >= 1.0.3, PECL uopz 2)

uopz_backup — Backup a function

Warning

This function has been REMOVED in PECL uopz 5.0.0.

说明

uopz_backup ( string $function ) : void
uopz_backup ( string $class , string $function ) : void

Backup a function at runtime, to be restored on shutdown

参数

class

The name of the class containing the function to backup

function

The name of the function

返回值

范例

Example #1 uopz_backup() example

<?php
uopz_backup("fgets");
uopz_function("fgets", function(){
    return true;
});
var_dump(fgets());
?>

以上例程会输出：

bool(true)


Compose a class

  • ? uopz_backup
  • uopz_copy ?
  • PHP Manual
  • Uopz 函数
  • Compose a class

uopz_compose

(PECL uopz 1, PECL uopz 2)

uopz_compose — Compose a class

Warning

This function has been REMOVED in PECL uopz 5.0.0.

说明

uopz_compose ( string $name , array $classes , array $methods = ? , array $properties = ? , int $flags = ? ) : void

Creates a new class of the given name that implements, extends, or uses all of the provided classes

参数

name

A legal class name

classes

An array of class, interface and trait names

methods

An associative array of methods, values are either closures or [modifiers => closure]

properties

An associative array of properties, keys are names, values are modifiers

flags

Entry type, by default ZEND_ACC_CLASS

返回值

范例

Example #1 uopz_compose() example

<?php
class myClass {}
trait myTrait {}
interface myInterface {}

uopz_compose(
    Composed::class, [
        myClass::class,
        myTrait::class,
        myInterface::class
    ], [
    "__construct" => function() {
        /* ... */
    }
]);

var_dump(
 class_uses(Composed::class),
 class_parents(Composed::class),
 class_implements(Composed::class));
?>

以上例程会输出：

array(1) {
  ["myTrait"]=>
  string(7) "myTrait"
}
array(1) {
  ["myClass"]=>
  string(7) "myClass"
}
array(1) {
  ["myInterface"]=>
  string(11) "myInterface"
}


Copy a function

  • ? uopz_compose
  • uopz_del_function ?
  • PHP Manual
  • Uopz 函数
  • Copy a function

uopz_copy

(PECL uopz 1 >= 1.0.4, PECL uopz 2)

uopz_copy — Copy a function

Warning

This function has been REMOVED in PECL uopz 5.0.0.

说明

uopz_copy ( string $function ) : Closure
uopz_copy ( string $class , string $function ) : Closure

Copy a function by name

参数

class

The name of the class containing the function to copy

function

The name of the function

返回值

A Closure for the specified function

范例

Example #1 uopz_copy() example

<?php
$strtotime = uopz_copy('strtotime');

uopz_function("strtotime", function($arg1, $arg2) use($strtotime) {
    /* can call original strtotime from here */
    var_dump($arg1);
});

var_dump(strtotime('dummy'));
?>

以上例程会输出：

string(5) "dummy"


Deletes previously added function or method

  • ? uopz_copy
  • uopz_delete ?
  • PHP Manual
  • Uopz 函数
  • Deletes previously added function or method

uopz_del_function

(PECL uopz 5, PECL uopz 6)

uopz_del_function — Deletes previously added function or method

说明

uopz_del_function ( string $function ) : bool
uopz_del_function ( string $class , string $function , int &$all = true ) : bool

Deletes a previously added function or method.

参数

class

The name of the class.

function

The name of the function or method.

all

Whether all classes that descend from class will also be affected.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

uopz_del_function() throws a RuntimeException if the function or method to delete has not been added by uopz_add_function().

范例

Example #1 Basic uopz_del_function() Usage

<?php
uopz_add_function('foo', function () {echo 'bar';});
var_dump(function_exists('foo'));
uopz_del_function('foo');
var_dump(function_exists('foo'));
?>

以上例程会输出：

bool(true)
bool(false)

参见

  • uopz_add_function() - Adds non-existent function or method
  • uopz_unset_return() - Unsets a previously set return value for a function


Delete a function

  • ? uopz_del_function
  • uopz_extend ?
  • PHP Manual
  • Uopz 函数
  • Delete a function

uopz_delete

(PECL uopz 1, PECL uopz 2)

uopz_delete — Delete a function

Warning

This function has been REMOVED in PECL uopz 5.0.0.

说明

uopz_delete ( string $function ) : void
uopz_delete ( string $class , string $function ) : void

Deletes a function or method

参数

class

function

返回值

范例

Example #1 uopz_delete() example

<?php
uopz_delete("strlen");

echo strlen("Hello World");
?>

以上例程的输出类似于：

PHP Fatal error: Call to undefined function strlen() in /path/to/script.php on line 4

Example #2 uopz_delete() class example

<?php
class My {
    public static function strlen($arg) {
        return strlen($arg);
    }
}

uopz_delete(My::class, "strlen");

echo My::strlen("Hello World");
?>

以上例程的输出类似于：

PHP Fatal error: Call to undefined method My::strlen() in /path/to/script.php on line 10


Extend a class at runtime

  • ? uopz_delete
  • uopz_flags ?
  • PHP Manual
  • Uopz 函数
  • Extend a class at runtime

uopz_extend

(PECL uopz 1, PECL uopz 2, PECL uopz 5, PECL uopz 6)

uopz_extend — Extend a class at runtime

说明

uopz_extend ( string $class , string $parent ) : bool

Makes class extend parent

参数

class

The name of the class to extend

parent

The name of the class to inherit

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

As of PHP 7.4.0, uopz_extends() throws a RuntimeException, if OPcache is enabled, and the class entry of either class or parent (if it is a trait) is immutable.

范例

Example #1 uopz_extend() example

<?php
class A {}
class B {}

uopz_extend(A::class, B::class);

var_dump(class_parents(A::class));
?>

以上例程会输出：

array(1) {
  ["B"]=>
  string(1) "B"
}


Get or set flags on function or class

  • ? uopz_extend
  • uopz_function ?
  • PHP Manual
  • Uopz 函数
  • Get or set flags on function or class

uopz_flags

(PECL uopz 2 >= 2.0.2, PECL uopz 5, PECL uopz 6)

uopz_flags — Get or set flags on function or class

说明

uopz_flags ( string $function , int $flags = PHP_INT_MAX ) : int
uopz_flags ( string $class , string $function , int $flags = PHP_INT_MAX ) : int

Get or set the flags on a class or function entry at runtime

参数

class

The name of a class

function

The name of the function. If class is given and an empty string is passed as function, uopz_flags() gets or sets the flags of the class entry.

flags

A valid set of ZEND_ACC_ flags. If omitted, uopz_flags() acts as getter.

返回值

If setting, returns old flags, else returns flags

错误／异常

As of PHP 7.4.0, if the parameter flags is passed, uopz_flags() throws a RuntimeException, if OPcache is enabled, and the class entry of class or the function entry of function is immutable.

更新日志

版本 | 说明
PECL uopz 5.0.0 | The flags parameter is now optional. Formerly, ZEND_ACC_FETCH had to be passed to use uopz_flags() as getter.

范例

Example #1 uopz_flags() example

<?php
class Test {
    public function method() {
        return __CLASS__;
    }
}

$flags = uopz_flags("Test", "method");

var_dump((bool) (uopz_flags("Test", "method") & ZEND_ACC_PRIVATE));
var_dump((bool) (uopz_flags("Test", "method") & ZEND_ACC_STATIC));

var_dump(uopz_flags("Test", "method", $flags|ZEND_ACC_STATIC|ZEND_ACC_PRIVATE));

var_dump((bool) (uopz_flags("Test", "method") & ZEND_ACC_PRIVATE));
var_dump((bool) (uopz_flags("Test", "method") & ZEND_ACC_STATIC));
?>

以上例程会输出：

bool(false)
bool(false)
int(1234567890)
bool(true)
bool(true)

Example #2 "Unfinalize" a Class

<?php
final class MyClass
{
}

$flags = uopz_flags(MyClass::class, '');
uopz_flags(MyClass::class, '', $flags & ~ZEND_ACC_FINAL);
var_dump((new ReflectionClass(MyClass::class))->isFinal());
?>

以上例程会输出：

bool(false)


Creates a function at runtime

  • ? uopz_flags
  • uopz_get_exit_status ?
  • PHP Manual
  • Uopz 函数
  • Creates a function at runtime

uopz_function

(PECL uopz 1, PECL uopz 2)

uopz_function — Creates a function at runtime

Warning

This function has been REMOVED in PECL uopz 5.0.0.

说明

uopz_function ( string $function , Closure $handler , int $modifiers = ? ) : void
uopz_function ( string $class , string $function , Closure $handler , int $modifiers = ? ) : void

Creates a function at runtime

参数

class

The name of the class to receive the new function

function

The name of the function

handler

The Closure for the function

modifiers

The modifiers for the function, by default copied or ZEND_ACC_PUBLIC

返回值

范例

Example #1 uopz_function() example

<?php
uopz_function("my_strlen", function($arg) {
    return strlen($arg);
});
echo my_strlen("Hello World");
?>

以上例程会输出：

11

Example #2 uopz_function() class example

<?php
class My {}

uopz_function(My::class, "strlen", function($arg) {
    return strlen($arg);
}, ZEND_ACC_STATIC);

echo My::strlen("Hello World");
?>

以上例程会输出：

11


Retrieve the last set exit status

  • ? uopz_function
  • uopz_get_hook ?
  • PHP Manual
  • Uopz 函数
  • Retrieve the last set exit status

uopz_get_exit_status

(PECL uopz 5, PECL uopz 6)

uopz_get_exit_status — Retrieve the last set exit status

说明

uopz_get_exit_status ( ) : mixed

Retrieves the last set exit status, i.e. the value passed to exit().

参数

此函数没有参数。

返回值

This function returns the last exit status, or null if exit() has not been called.

范例

Example #1 uopz_get_exit_status() example

<?php
exit(123);
echo uopz_get_exit_status();?>

以上例程会输出：

123

注释

Caution

OPcache optimizes away dead code after unconditional exit.

参见

  • uopz_allow_exit() - Allows control over disabled exit opcode


Gets previously set hook on function or method

  • ? uopz_get_exit_status
  • uopz_get_mock ?
  • PHP Manual
  • Uopz 函数
  • Gets previously set hook on function or method

uopz_get_hook

(PECL uopz 5, PECL uopz 6)

uopz_get_hook — Gets previously set hook on function or method

说明

uopz_get_hook ( string $function ) : Closure
uopz_get_hook ( string $class , string $function ) : Closure

Gets the previously set hook on a function or method.

参数

class

The name of the class.

function

The name of the function or method.

返回值

Returns the previously set hook on a function or method, or null if no hook has been set.

范例

Example #1 Basic uopz_get_hook() Usage

<?php
function foo() {
    echo 'foo';
}
uopz_set_hook('foo', function () {echo 'bar';});
var_dump(uopz_get_hook('foo'));
?>

以上例程的输出类似于：

object(Closure)#2 (0) {
}

参见

  • uopz_set_hook() - Sets hook to execute when entering a function or method
  • uopz_unset_hook() - Removes previously set hook on function or method


Get the current mock for a class

  • ? uopz_get_hook
  • uopz_get_property ?
  • PHP Manual
  • Uopz 函数
  • Get the current mock for a class

uopz_get_mock

(PECL uopz 5, PECL uopz 6)

uopz_get_mock — Get the current mock for a class

说明

uopz_get_mock ( string $class ) : mixed

Returns the current mock for class.

参数

class

The name of the mocked class.

返回值

Either a string containing the name of the mock, or an object, or null if no mock has been set.

范例

Example #1 uopz_get_mock() example

<?php
class A {
    public static function who() {
        echo "A";
    }
}

class mockA {
    public static function who() {
        echo "mockA";
    }
}

uopz_set_mock(A::class, mockA::class);
echo uopz_get_mock(A::class);
?>

以上例程会输出：

mockA

参见

  • uopz_set_mock() - Use mock instead of class for new objects
  • uopz_unset_mock() - Unset previously set mock


Gets value of class or instance property

  • ? uopz_get_mock
  • uopz_get_return ?
  • PHP Manual
  • Uopz 函数
  • Gets value of class or instance property

uopz_get_property

(PECL uopz 5, PECL uopz 6)

uopz_get_property — Gets value of class or instance property

说明

uopz_get_property ( string $class , string $property ) : mixed
uopz_get_property ( object $instance , string $property ) : mixed

Gets the value of a static class property, if class is given, or the value of an instance property, if instance is given.

参数

class

The name of the class.

instance

The object instance.

property

The name of the property.

返回值

Returns the value of the class or instance property, or null if the property is not defined.

范例

Example #1 Basic uopz_get_property() Usage

<?php
class Foo {
    private static $staticBar = 10;
    private $bar = 100;
}
$foo = new Foo;
var_dump(uopz_get_property('Foo', 'staticBar'));
var_dump(uopz_get_property($foo, 'bar'));
?>

以上例程的输出类似于：

int(10)
int(100)

参见

  • uopz_set_property() - Sets value of existing class or instance property


Gets a previous set return value for a function

  • ? uopz_get_property
  • uopz_get_static ?
  • PHP Manual
  • Uopz 函数
  • Gets a previous set return value for a function

uopz_get_return

(PECL uopz 5, PECL uopz 6)

uopz_get_return — Gets a previous set return value for a function

说明

uopz_get_return ( string $function ) : mixed
uopz_get_return ( string $class , string $function ) : mixed

Gets the return value of the function previously set by uopz_set_return().

参数

class

The name of the class containing the function

function

The name of the function

返回值

The return value or Closure previously set.

范例

Example #1 uopz_get_return() example

<?php
uopz_set_return("strlen", 42);
echo uopz_get_return("strlen");
?>

以上例程会输出：

42


Gets the static variables from function or method scope

  • ? uopz_get_return
  • uopz_implement ?
  • PHP Manual
  • Uopz 函数
  • Gets the static variables from function or method scope

uopz_get_static

(PECL uopz 5, PECL uopz 6)

uopz_get_static — Gets the static variables from function or method scope

说明

uopz_get_static ( string $class , string $function ) : array
uopz_get_static ( string $function ) : array

Gets the static variables from function or method scope.

参数

class

The name of the class.

function

The name of the function or method.

返回值

Returns an associative array of variable names mapped to their current values on success, or null if the function or method does not exist.

范例

Example #1 Basic uopz_get_static() Usage

<?php
function foo() {
    static $bar = 'baz';
}
var_dump(uopz_get_static('foo'));
?>

以上例程会输出：

array(1) {
  ["bar"]=>
  string(3) "baz"
}

参见

  • uopz_set_static() - Sets the static variables in function or method scope


Implements an interface at runtime

  • ? uopz_get_static
  • uopz_overload ?
  • PHP Manual
  • Uopz 函数
  • Implements an interface at runtime

uopz_implement

(PECL uopz 1, PECL uopz 2, PECL uopz 5, PECL uopz 6)

uopz_implement — Implements an interface at runtime

说明

uopz_implement ( string $class , string $interface ) : bool

Makes class implement interface

参数

class

interface

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

As of PHP 7.4.0, uopz_implements() throws a RuntimeException, if OPcache is enabled, and the class entry of class is immutable.

范例

Example #1 uopz_implement() example

<?php
interface myInterface {}

class myClass {}

uopz_implement(myClass::class, myInterface::class);

var_dump(class_implements(myClass::class));
?>

以上例程会输出：

array(1) {
  ["myInterface"]=>
  string(11) "myInterface"
}


Overload a VM opcode

  • ? uopz_implement
  • uopz_redefine ?
  • PHP Manual
  • Uopz 函数
  • Overload a VM opcode

uopz_overload

(PECL uopz 1, PECL uopz 2)

uopz_overload — Overload a VM opcode

Warning

This function has been REMOVED in PECL uopz 5.0.0.

说明

uopz_overload ( int $opcode , Callable $callable ) : void

Overloads the specified opcode with the user defined function

参数

opcode

A valid opcode, see constants for details of supported codes

callable

返回值

范例

Example #1 uopz_overload() example

<?php
uopz_overload(ZEND_EXIT, function(){});

exit();
echo "Hello World";
?>

以上例程会输出：

Hello World


Redefine a constant

  • ? uopz_overload
  • uopz_rename ?
  • PHP Manual
  • Uopz 函数
  • Redefine a constant

uopz_redefine

(PECL uopz 1, PECL uopz 2, PECL uopz 5, PECL uopz 6)

uopz_redefine — Redefine a constant

说明

uopz_redefine ( string $constant , mixed $value ) : bool
uopz_redefine ( string $class , string $constant , mixed $value ) : bool

Redefines the given constant as value

参数

class

The name of the class containing the constant

constant

The name of the constant

value

The new value for the constant, must be a valid type for a constant variable

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 uopz_redefine() example

<?php
define("MY", 100);

uopz_redefine("MY", 1000);

echo MY;
?>

以上例程会输出：

1000


Rename a function at runtime

  • ? uopz_redefine
  • uopz_restore ?
  • PHP Manual
  • Uopz 函数
  • Rename a function at runtime

uopz_rename

(PECL uopz 1, PECL uopz 2)

uopz_rename — Rename a function at runtime

Warning

This function has been REMOVED in PECL uopz 5.0.0.

说明

uopz_rename ( string $function , string $rename ) : void
uopz_rename ( string $class , string $function , string $rename ) : void

Renames function to rename

Note:

If both functions exist, this effectively swaps their names

参数

class

The name of the class containing the function

function

The name of an existing function

rename

The new name for the function

返回值

范例

Example #1 uopz_rename() example

<?php
uopz_rename("strlen", "original_strlen");

echo original_strlen("Hello World");
?>

以上例程会输出：

11

Example #2 uopz_rename() class example

<?php
class My {
    public function strlen($arg) {
        return strlen($arg);
    }
}

uopz_rename(My::class, "strlen", "original_strlen");

echo My::original_strlen("Hello World");
?>

以上例程会输出：

11


Restore a previously backed up function

  • ? uopz_rename
  • uopz_set_hook ?
  • PHP Manual
  • Uopz 函数
  • Restore a previously backed up function

uopz_restore

(PECL uopz 1 >= 1.0.3, PECL uopz 2)

uopz_restore — Restore a previously backed up function

Warning

This function has been REMOVED in PECL uopz 5.0.0.

说明

uopz_restore ( string $function ) : void
uopz_restore ( string $class , string $function ) : void

Restore a previously backed up function

参数

class

The name of the class containing the function to restore

function

The name of the function

返回值

范例

Example #1 uopz_restore() example

<?php
uopz_backup("fgets");
uopz_function("fgets", function(){
    return true;
});
var_dump(fgets());
uopz_restore('fgets');
fgets();
?>

以上例程的输出类似于：

Warning: fgets() expects at least 1 parameter, 0 given in /path/to/script.php on line 8


Sets hook to execute when entering a function or method

  • ? uopz_restore
  • uopz_set_mock ?
  • PHP Manual
  • Uopz 函数
  • Sets hook to execute when entering a function or method

uopz_set_hook

(PECL uopz 5, PECL uopz 6)

uopz_set_hook — Sets hook to execute when entering a function or method

说明

uopz_set_hook ( string $function , Closure $hook ) : bool
uopz_set_hook ( string $class , string $function , Closure $hook ) : bool

Sets a hook to execute when entering a function or method.

参数

class

The name of the class.

function

The name of the function or method.

hook

A closure to execute when entering the function or method.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Basic uopz_set_hook() Usage

<?php
function foo() {
    echo 'foo';
}
uopz_set_hook('foo', function () {echo 'bar';});
foo();
?>

以上例程会输出：

barfoo

参见

  • uopz_get_hook() - Gets previously set hook on function or method
  • uopz_unset_hook() - Removes previously set hook on function or method


Use mock instead of class for new objects

  • ? uopz_set_hook
  • uopz_set_property ?
  • PHP Manual
  • Uopz 函数
  • Use mock instead of class for new objects

uopz_set_mock

(PECL uopz 5, PECL uopz 6)

uopz_set_mock — Use mock instead of class for new objects

说明

uopz_set_mock ( string $class , mixed $mock ) : void

If mock is a string containing the name of a class then it will be instantiated instead of class. mock can also be an object.

Note:

Only dynamic access to properties and methods will use the mock object. Static access still uses the original class. See example below.

参数

class

The name of the class to be mocked.

mock

The mock to use in the form of a string containing the name of the class to use or an object. If a string is passed, it has to be the fully qualified class name. It is recommended to use the ::class magic constant in this case.

更新日志

版本 | 说明
uopz 6.0.0 | Mocking static members is no longer supported by this function. uopz_redefine() and uopz_set_return(), or Componere can be used instead.

范例

Example #1 uopz_set_mock() example

<?php
class A {
    public function who() {
        echo "A";
    }
}

class mockA {
    public function who() {
        echo "mockA";
    }
}

uopz_set_mock(A::class, mockA::class);
(new A)->who();
?>

以上例程会输出：

mockA

Example #2 uopz_set_mock() example

<?php
class A {
    public function who() {
        echo "A";
    }
}

uopz_set_mock(A::class, new class {
                            public function who() {
                                echo "mockA";
                            }
                        });
(new A)->who();
?>

以上例程会输出：

mockA

Example #3 uopz_set_mock() and static members

As of uopz 6.0.0 mocking static members is no longer supported.

<?php
class A {
    const CON = 'A';
    public static function who() {
        echo "A";
    }
}

uopz_set_mock(A::class, new class {
                            const CON = 'mockA';
                            public static function who() {
                                echo "mockA";
                            }
                        });
echo A::CON, PHP_EOL;
A::who();
?>

以上例程会输出：

A
A

Output of the above example in uopz 5:

mockA
mockA

参见

  • uopz_get_mock() - Get the current mock for a class
  • uopz_unset_mock() - Unset previously set mock


Sets value of existing class or instance property

  • ? uopz_set_mock
  • uopz_set_return ?
  • PHP Manual
  • Uopz 函数
  • Sets value of existing class or instance property

uopz_set_property

(PECL uopz 5, PECL uopz 6)

uopz_set_property — Sets value of existing class or instance property

说明

uopz_set_property ( string $class , string $property , mixed $value ) : void
uopz_set_property ( object $instance , string $property , mixed $value ) : void

Sets the value of an existing static class property, if class is given, or the value of an instance property (regardless whether the instance property already exists), if instance is given.

参数

class

The name of the class.

instance

The object instance.

property

The name of the property.

value

The value to assign to the property.

返回值

没有返回值。

范例

Example #1 Basic uopz_set_property() Usage

<?php
class Foo {
   private static $staticBar;
   private $bar;
   public static function testStaticBar() {
      return self::$staticBar;
   }
   public function testBar() {
      return $this->bar;
   }
}
$foo = new Foo;
uopz_set_property('Foo', 'staticBar', 10);
uopz_set_property($foo, 'bar', 100);
var_dump(Foo::testStaticBar());
var_dump($foo->testBar());
?>

以上例程会输出：

int(10)

参见

  • uopz_get_property() - Gets value of class or instance property


Provide a return value for an existing function

  • ? uopz_set_property
  • uopz_set_static ?
  • PHP Manual
  • Uopz 函数
  • Provide a return value for an existing function

uopz_set_return

(PECL uopz 5, PECL uopz 6)

uopz_set_return — Provide a return value for an existing function

说明

uopz_set_return ( string $function , mixed $value , bool $execute = false ) : bool
uopz_set_return ( string $class , string $function , mixed $value , bool $execute = false ) : bool

Sets the return value of the function to value. If value is a Closure and execute is set, the Closure will be executed in place of the original function. It is possible to call the original function from the Closure.

Note:

This function replaces uopz_rename().

参数

class

The name of the class containing the function

function

The name of an existing function

value

The value the function should return. If a Closure is provided and the execute flag is set, the Closure will be executed in place of the original function.

execute

If true, and a Closure was provided as the value, the Closure will be executed in place of the original function.

返回值

True if succeeded, false otherwise.

范例

Example #1 uopz_set_return() example

<?php
uopz_set_return("strlen", 42);
echo strlen("Banana");
?>

以上例程会输出：

42

Example #2 uopz_set_return() example

<?php
uopz_set_return("strlen", function($str) { return strlen($str) * 2; }, true );
echo strlen("Banana");
?>

以上例程会输出：

12

Example #3 uopz_set_return() class example

<?php
class My {
    public static function strlen($arg) {
        return strlen($arg);
    }
}
uopz_set_return(My::class, "strlen", function($str) { return strlen($str) * 2; }, true );
echo My::strlen("Banana");
?>

以上例程会输出：

12


Sets the static variables in function or method scope

  • ? uopz_set_return
  • uopz_undefine ?
  • PHP Manual
  • Uopz 函数
  • Sets the static variables in function or method scope

uopz_set_static

(PECL uopz 5, PECL uopz 6)

uopz_set_static — Sets the static variables in function or method scope

说明

uopz_set_static ( string $function , array $static ) : void
uopz_set_static ( string $class , string $function , array $static ) : void

Sets the static variables in function or method scope.

参数

class

The name of the class.

function

The name of the function or method.

static

The associative array of variable names mapped to their values.

返回值

没有返回值。

范例

Example #1 Basic uopz_set_static() Usage

<?php
function foo() {
    static $bar = 'baz';
    var_dump($bar);
}
uopz_set_static('foo', ['bar' => 'qux']);
foo();
?>

以上例程会输出：

string(3) "qux"

参见

  • uopz_get_static() - Gets the static variables from function or method scope


Undefine a constant

  • ? uopz_set_static
  • uopz_unset_hook ?
  • PHP Manual
  • Uopz 函数
  • Undefine a constant

uopz_undefine

(PECL uopz 1, PECL uopz 2, PECL uopz 5, PECL uopz 6)

uopz_undefine — Undefine a constant

说明

uopz_undefine ( string $constant ) : bool
uopz_undefine ( string $class , string $constant ) : bool

Removes the constant at runtime

参数

class

The name of the class containing constant

constant

The name of an existing constant

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 uopz_undefine() example

<?php
define("MY", true);

uopz_undefine("MY");

var_dump(defined("MY"));
?>

以上例程会输出：

bool(false)


Removes previously set hook on function or method

  • ? uopz_undefine
  • uopz_unset_mock ?
  • PHP Manual
  • Uopz 函数
  • Removes previously set hook on function or method

uopz_unset_hook

(PECL uopz 5, PECL uopz 6)

uopz_unset_hook — Removes previously set hook on function or method

说明

uopz_unset_hook ( string $function ) : bool
uopz_unset_hook ( string $class , string $function ) : bool

Removes the previously set hook on a function or method.

参数

class

The name of the class.

function

The name of the function or method.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Basic uopz_unset_hook() Usage

<?php
function foo() {
    echo 'foo';
}
uopz_set_hook('foo', function () {echo 'bar';});
foo();
echo PHP_EOL;
uopz_unset_hook('foo');
foo();
?>

以上例程会输出：

barfoo
foo

参见

  • uopz_set_hook() - Sets hook to execute when entering a function or method
  • uopz_get_hook() - Gets previously set hook on function or method


Unset previously set mock

  • ? uopz_unset_hook
  • uopz_unset_return ?
  • PHP Manual
  • Uopz 函数
  • Unset previously set mock

uopz_unset_mock

(PECL uopz 5, PECL uopz 6)

uopz_unset_mock — Unset previously set mock

说明

uopz_unset_mock ( string $class ) : void

Unsets the previously set mock for class.

参数

class

The name of the mocked class.

错误／异常

A RuntimeException is thrown, if no mock was previously set for class.

范例

Example #1 uopz_unset_mock() example

<?php
class A {
    public static function who() {
        echo "A";
    }
}

class mockA {
    public static function who() {
        echo "mockA";
    }
}

uopz_set_mock(A::class, mockA::class);
uopz_unset_mock(A::class);
A::who();
?>

以上例程会输出：

A

参见

  • uopz_set_mock() - Use mock instead of class for new objects
  • uopz_get_mock() - Get the current mock for a class


Unsets a previously set return value for a function

  • ? uopz_unset_mock
  • Weakref ?
  • PHP Manual
  • Uopz 函数
  • Unsets a previously set return value for a function

uopz_unset_return

(PECL uopz 5, PECL uopz 6)

uopz_unset_return — Unsets a previously set return value for a function

说明

uopz_unset_return ( string $function ) : bool
uopz_unset_return ( string $class , string $function ) : bool

Unsets the return value of the function previously set by uopz_set_return().

参数

class

The name of the class containing the function

function

The name of the function

返回值

True on success

范例

Example #1 uopz_unset_return() example

<?php
uopz_set_return("strlen", 42);
$len = strlen("Banana");
uopz_unset_return("strlen");
echo $len + strlen("Banana");
?>

以上例程会输出：

48


Weak References

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 资源类型
  • WeakRef — The WeakRef class
    • Weakref::acquire — Acquires a strong reference on that object
    • Weakref::__construct — Constructs a new weak reference
    • Weakref::get — Returns the object pointed to by the weak reference
    • Weakref::release — Releases a previously acquired reference
    • Weakref::valid — Checks whether the object referenced still exists
  • WeakMap — The WeakMap class
    • WeakMap::__construct — Constructs a new map
    • WeakMap::count — Counts the number of live entries in the map
    • WeakMap::current — Returns the current value under iteration
    • WeakMap::key — Returns the current key under iteration
    • WeakMap::next — Advances to the next map element
    • WeakMap::offsetExists — Checks whether a certain object is in the map
    • WeakMap::offsetGet — Returns the value pointed to by a certain object
    • WeakMap::offsetSet — Updates the map with a new key-value pair
    • WeakMap::offsetUnset — Removes an entry from the map
    • WeakMap::rewind — Rewinds the iterator to the beginning of the map
    • WeakMap::valid — Returns whether the iterator is still on a valid map element


简介

Weak references provide a non-intrusive gateway to ephemeral objects. Unlike normal (strong) references, weak references do not prevent the garbage collector from freeing that object. For this reason, an object may be destroyed even though a weak reference to that object still exists. In such conditions, the weak reference seamlessly becomes invalid.

Example #1 Weakref usage example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}
?>

以上例程会输出：

Object still exists!
object(MyClass)#1 (0) {
}
Destroying object!
Object is dead!


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Weakref
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 资源类型


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/weakref.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


  • ? 安装
  • WeakRef ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


The WeakRef class

(PECL weakref >= 0.1.0)

简介

The WeakRef class provides a gateway to objects without preventing the garbage collector from freeing those objects. It also provides a way to turn a weak reference into a strong one.

Note:

The class WeakRef is not to be confused with the class WeakReference.

类摘要

WeakRef {
/* 方法 */
public Weakref::__construct ( object $object )
public Weakref::acquire ( ) : bool
public Weakref::get ( ) : object
public Weakref::release ( ) : bool
public Weakref::valid ( ) : bool
}

范例

Example #1 WeakRef usage example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new WeakRef($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}
?>

以上例程会输出：

Object still exists!
object(MyClass)#1 (0) {
}
Destroying object!
Object is dead!

Table of Contents

  • Weakref::acquire — Acquires a strong reference on that object
  • Weakref::__construct — Constructs a new weak reference
  • Weakref::get — Returns the object pointed to by the weak reference
  • Weakref::release — Releases a previously acquired reference
  • Weakref::valid — Checks whether the object referenced still exists


Acquires a strong reference on that object

  • ? WeakRef
  • Weakref::__construct ?
  • PHP Manual
  • WeakRef
  • Acquires a strong reference on that object

Weakref::acquire

(PECL weakref >= 0.1.0)

Weakref::acquire — Acquires a strong reference on that object

说明

public Weakref::acquire ( ) : bool

Acquires a strong reference on that object, virtually turning the weak reference into a strong one.

The Weakref instance maintains an internal acquired counter to track outstanding strong references. If the call to Weakref::acquire() is successful, this counter will be incremented by one.

参数

此函数没有参数。

返回值

Returns true if the reference was valid and could be turned into a strong reference, false otherwise.

范例

Example #1 Weakref::acquire() example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

$r1->acquire();

echo "Unsetting o1...\n";
unset($o1);

$o2 = $r1->get();

$r1->release();

echo "Unsetting o2...\n";
unset($o2);
?>

以上例程会输出：

Unsetting o1...
Unsetting o2...
Destroying object!

Example #2 Nested acquire/release example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

echo "Acquiring...\n";
$r1->acquire();

echo "  Unsetting...\n";
unset($o1);

echo "  Acquiring...\n";
$r1->acquire();

echo "    Acquiring...\n";
$r1->acquire();

echo "    Releasing...\n";
$r1->release();

echo "  Releasing...\n";
$r1->release();

echo "Releasing...\n";
$r1->release();

?>

以上例程会输出：

Acquiring...
  Unsetting...
  Acquiring...
    Acquiring...
    Releasing...
  Releasing...
Releasing...
Destroying object!

参见

  • Weakref::release() - Releases a previously acquired reference


Constructs a new weak reference

  • ? Weakref::acquire
  • Weakref::get ?
  • PHP Manual
  • WeakRef
  • Constructs a new weak reference

Weakref::__construct

(PECL weakref >= 0.1.0)

Weakref::__construct — Constructs a new weak reference

说明

public Weakref::__construct ( object $object )

Constructs a new weak reference.

参数

object

The object to reference.

返回值

没有返回值。

范例

Example #1 Weakref::__construct() example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}
?>

以上例程会输出：

Object still exists!
object(MyClass)#1 (0) {
}
Destroying object!
Object is dead!


Returns the object pointed to by the weak reference

  • ? Weakref::__construct
  • Weakref::release ?
  • PHP Manual
  • WeakRef
  • Returns the object pointed to by the weak reference

Weakref::get

(PECL weakref >= 0.1.0)

Weakref::get — Returns the object pointed to by the weak reference

说明

public Weakref::get ( ) : object

Returns the object pointed to by the weak reference.

参数

此函数没有参数。

返回值

Returns the object if the reference is still valid, null otherwise.

参见

  • Weakref::valid() - Checks whether the object referenced still exists


Releases a previously acquired reference

  • ? Weakref::get
  • Weakref::valid ?
  • PHP Manual
  • WeakRef
  • Releases a previously acquired reference

Weakref::release

(PECL weakref >= 0.1.0)

Weakref::release — Releases a previously acquired reference

说明

public Weakref::release ( ) : bool

Releases a previously acquired reference, potentially turning a strong reference back into a weak reference.

The Weakref instance maintains an internal acquired counter to track outstanding strong references. If the call to Weakref::release() is successful, this counter will be decremented by one. Once this counter reaches zero, the strong reference is turned back into a weak reference.

参数

此函数没有参数。

返回值

Returns true if the reference was previously acquired and thus could be released, false otherwise.

范例

Example #1 Weakref::release() example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

$r1->acquire();

echo "Unsetting o1...\n";
unset($o1);

$o2 = $r1->get();

$r1->release();

echo "Unsetting o2...\n";
unset($o2);
?>

以上例程会输出：

Unsetting o1...
Unsetting o2...
Destroying object!

参见

  • Weakref::acquire() - Acquires a strong reference on that object


Checks whether the object referenced still exists

  • ? Weakref::release
  • WeakMap ?
  • PHP Manual
  • WeakRef
  • Checks whether the object referenced still exists

Weakref::valid

(PECL weakref >= 0.1.0)

Weakref::valid — Checks whether the object referenced still exists

说明

public Weakref::valid ( ) : bool

Checks whether the object referenced still exists.

参数

此函数没有参数。

返回值

Returns true if the object still exists and is thus still accessible via Weakref::get(), false otherwise.

参见

  • Weakref::get() - Returns the object pointed to by the weak reference


The WeakMap class

(PECL weakref >= 0.2.0)

简介

类摘要

WeakMap implements Countable , ArrayAccess , Iterator {
/* 方法 */
public __construct ( )
public count ( ) : int
public current ( ) : mixed
public key ( ) : object
public next ( ) : void
public offsetExists ( object $object ) : bool
public offsetGet ( object $object ) : mixed
public offsetSet ( object $object , mixed $value ) : void
public offsetUnset ( object $object ) : void
public rewind ( ) : void
public valid ( ) : bool
}

范例

Example #1 Weakmap usage example

<?php
$wm = new WeakMap();

$o = new StdClass;

class A {
    public function __destruct() {
        echo "Dead!\n";
    }
}

$wm[$o] = new A;

var_dump(count($wm));
echo "Unsetting...\n";
unset($o);
echo "Done\n";
var_dump(count($wm));

以上例程会输出：

int(1)
Unsetting...
Dead!
Done
int(0)

Table of Contents

  • WeakMap::__construct — Constructs a new map
  • WeakMap::count — Counts the number of live entries in the map
  • WeakMap::current — Returns the current value under iteration
  • WeakMap::key — Returns the current key under iteration
  • WeakMap::next — Advances to the next map element
  • WeakMap::offsetExists — Checks whether a certain object is in the map
  • WeakMap::offsetGet — Returns the value pointed to by a certain object
  • WeakMap::offsetSet — Updates the map with a new key-value pair
  • WeakMap::offsetUnset — Removes an entry from the map
  • WeakMap::rewind — Rewinds the iterator to the beginning of the map
  • WeakMap::valid — Returns whether the iterator is still on a valid map element


Constructs a new map

  • ? WeakMap
  • WeakMap::count ?
  • PHP Manual
  • WeakMap
  • Constructs a new map

WeakMap::__construct

(PECL weakref >= 0.2.0)

WeakMap::__construct — Constructs a new map

说明

public WeakMap::__construct ( )

Constructs a new map.

参数

此函数没有参数。

返回值

没有返回值。


Counts the number of live entries in the map

  • ? WeakMap::__construct
  • WeakMap::current ?
  • PHP Manual
  • WeakMap
  • Counts the number of live entries in the map

WeakMap::count

(PECL weakref >= 0.2.0)

WeakMap::count — Counts the number of live entries in the map

说明

public WeakMap::count ( ) : int

Counts the number of live entries in the map.

参数

此函数没有参数。

返回值

Returns the number of live entries in the map.


Returns the current value under iteration

  • ? WeakMap::count
  • WeakMap::key ?
  • PHP Manual
  • WeakMap
  • Returns the current value under iteration

WeakMap::current

(PECL weakref >= 0.2.0)

WeakMap::current — Returns the current value under iteration

说明

public WeakMap::current ( ) : mixed

Returns the current value being iterated on in the map.

参数

此函数没有参数。

返回值

The value currently being iterated on.


Returns the current key under iteration

  • ? WeakMap::current
  • WeakMap::next ?
  • PHP Manual
  • WeakMap
  • Returns the current key under iteration

WeakMap::key

(PECL weakref >= 0.2.0)

WeakMap::key — Returns the current key under iteration

说明

public WeakMap::key ( ) : object

Returns the object serving as key in the map, at the current iterating position.

参数

此函数没有参数。

返回值

The object key currently being iterated.


Advances to the next map element

  • ? WeakMap::key
  • WeakMap::offsetExists ?
  • PHP Manual
  • WeakMap
  • Advances to the next map element

WeakMap::next

(PECL weakref >= 0.2.0)

WeakMap::next — Advances to the next map element

说明

public WeakMap::next ( ) : void

Advances to the next map element.

参数

此函数没有参数。

返回值

没有返回值。


Checks whether a certain object is in the map

  • ? WeakMap::next
  • WeakMap::offsetGet ?
  • PHP Manual
  • WeakMap
  • Checks whether a certain object is in the map

WeakMap::offsetExists

(PECL weakref >= 0.2.0)

WeakMap::offsetExists — Checks whether a certain object is in the map

说明

public WeakMap::offsetExists ( object $object ) : bool

Checks whether the passed object is referenced in the map.

参数

object

Object to check for.

返回值

Returns true if the object is contained in the map, false otherwise.


Returns the value pointed to by a certain object

  • ? WeakMap::offsetExists
  • WeakMap::offsetSet ?
  • PHP Manual
  • WeakMap
  • Returns the value pointed to by a certain object

WeakMap::offsetGet

(PECL weakref >= 0.2.0)

WeakMap::offsetGet — Returns the value pointed to by a certain object

说明

public WeakMap::offsetGet ( object $object ) : mixed

Returns the value pointed to by a certain object.

参数

object

Some object contained as key in the map.

返回值

Returns the value associated to the object passed as argument, null otherwise.


Updates the map with a new key-value pair

  • ? WeakMap::offsetGet
  • WeakMap::offsetUnset ?
  • PHP Manual
  • WeakMap
  • Updates the map with a new key-value pair

WeakMap::offsetSet

(PECL weakref >= 0.2.0)

WeakMap::offsetSet — Updates the map with a new key-value pair

说明

public WeakMap::offsetSet ( object $object , mixed $value ) : void

Updates the map with a new key-value pair. If the key already existed in the map, the old value is replaced with the new.

参数

object

The object serving as key of the key-value pair.

value

The arbitrary data serving as value of the key-value pair.

返回值

没有返回值。


Removes an entry from the map

  • ? WeakMap::offsetSet
  • WeakMap::rewind ?
  • PHP Manual
  • WeakMap
  • Removes an entry from the map

WeakMap::offsetUnset

(PECL weakref >= 0.2.0)

WeakMap::offsetUnset — Removes an entry from the map

说明

public WeakMap::offsetUnset ( object $object ) : void

Removes an entry from the map.

参数

object

The key object to remove from the map.

返回值

没有返回值。


Rewinds the iterator to the beginning of the map

  • ? WeakMap::offsetUnset
  • WeakMap::valid ?
  • PHP Manual
  • WeakMap
  • Rewinds the iterator to the beginning of the map

WeakMap::rewind

(PECL weakref >= 0.2.0)

WeakMap::rewind — Rewinds the iterator to the beginning of the map

说明

public WeakMap::rewind ( ) : void

Rewinds the iterator to the beginning of the map.

参数

此函数没有参数。

返回值

没有返回值。


Returns whether the iterator is still on a valid map element

  • ? WeakMap::rewind
  • WinCache ?
  • PHP Manual
  • WeakMap
  • Returns whether the iterator is still on a valid map element

WeakMap::valid

(PECL weakref >= 0.2.0)

WeakMap::valid — Returns whether the iterator is still on a valid map element

说明

public WeakMap::valid ( ) : bool

Returns whether the iterator is still on a valid map element.

参数

此函数没有参数。

返回值

Returns true if the iterator is on a valid element that can be accessed, false otherwise.


Windows Cache for PHP

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • WinCache Statistics Script
    • WinCache Session Handler
    • WinCache Functions Reroutes
    • 资源类型
  • 预定义常量
  • WinCache 函数
    • wincache_fcache_fileinfo — Retrieves information about files cached in the file cache
    • wincache_fcache_meminfo — Retrieves information about file cache memory usage
    • wincache_lock — Acquires an exclusive lock on a given key
    • wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache
    • wincache_ocache_meminfo — Retrieves information about opcode cache memory usage
    • wincache_refresh_if_changed — Refreshes the cache entries for the cached files
    • wincache_rplist_fileinfo — Retrieves information about resolve file path cache
    • wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache
    • wincache_scache_info — Retrieves information about files cached in the session cache
    • wincache_scache_meminfo — Retrieves information about session cache memory usage
    • wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache
    • wincache_ucache_cas — Compares the variable with old value and assigns new value to it
    • wincache_ucache_clear — Deletes entire content of the user cache
    • wincache_ucache_dec — Decrements the value associated with the key
    • wincache_ucache_delete — Deletes variables from the user cache
    • wincache_ucache_exists — Checks if a variable exists in the user cache
    • wincache_ucache_get — Gets a variable stored in the user cache
    • wincache_ucache_inc — Increments the value associated with the key
    • wincache_ucache_info — Retrieves information about data stored in the user cache
    • wincache_ucache_meminfo — Retrieves information about user cache memory usage
    • wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache
    • wincache_unlock — Releases an exclusive lock on a given key
  • Building for Windows
    • Prerequisites
    • Compiling and building
    • Verifying the build


简介

Windows Cache Extension for PHP is a PHP accelerator that is used to increase the speed of PHP applications running on Windows and Windows Server. Once the Windows Cache Extension for PHP is enabled and loaded by the PHP engine, PHP applications can take advantage of the functionality without any code modifications.

The Windows Cache Extension includes 5 different types of caches. The following describes the purpose of each cache type and the benefits it provides.

  • PHP Opcode Cache - PHP is a script processing engine, which reads an input stream of data that contains text and/or PHP instructions and produces another stream of data, most commonly in the HTML format. This means that on a web server the PHP engine reads, parses, compiles and executes a PHP script each time that it is requested by a Web client. The reading, parsing and compilation operations put additional load on the web server's CPU and file system and thus affect the overall performance of a PHP web application. The PHP bytecode (opcode) cache is used to store the compiled script bytecode in shared memory so that it can be re-used by PHP engine for subsequent executions of the same script.

    Support for opcode caching was removed in Wincache 2.0.0, all users who wish to have an opcache should use the OPcache extension that is included with PHP as of PHP 5.5.0.

  • File Cache - Even with the PHP opcode cache enabled, the PHP engine has to accesses the script files on a file system. When PHP scripts are stored on a remote UNC file share, the file operations introduce a significant performance overhead. The Windows Cache Extension for PHP includes a file cache that is used to store the content of the PHP script files in shared memory, which reduces the amount of file system operations performed by PHP engine.

  • Resolve File Path Cache - PHP scripts very often include or operate with files by using relative file paths. Every file path has to be normalized to an absolute file path by the PHP engine. When a PHP application uses many PHP files and accesses them by relative paths, the operation of resolving the paths may negatively impact the application's performance. The Windows Cache Extension for PHP provides a Resolve File Path cache, which is used to store the mappings between relative and absolute file paths, thereby reducing the number of path resolutions that the PHP engine has to perform.

  • User Cache (available since version 1.1.0) - PHP scripts can take advantage of the shared memory cache by using the user cache API's. PHP objects and variables can be stored in the user cache and then re-used on subsequent requests. This can be used to improve performance of PHP scripts and to share the data across multiple PHP processes.

  • Session Handler (available since version 1.1.0) - The WinCache session handler can be used to store the PHP session data in the shared memory cache. This avoids file system operations for reading and writing session data, which improves performance when large amount of data is stored in PHP session.


安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • WinCache Statistics Script
  • WinCache Session Handler
  • WinCache Functions Reroutes
  • 资源类型


需求

The extension is currently supported only on the following configurations:

Windows OS:

  • Windows XP SP3 with IIS 5.1 and » FastCGI Extension
  • Windows Server 2003 with IIS 6.0 and » FastCGI Extension
  • Windows Vista SP1 with IIS 7.0 and FastCGI Module
  • Windows Server 2008 with IIS 7.0 and FastCGI Module
  • Windows 7 with IIS 7.5 and FastCGI Module
  • Windows Server 2008 R2 with IIS 7.5 and FastCGI Module

PHP:

  • PHP 5.2.X, Non-thread-safe build
  • PHP 5.3 X86, Non-thread-safe VC9 build

Note: The WinCache Extension can only be used when IIS is configured to run PHP via FastCGI.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/wincache.

There are two packages for this extension: one package is for PHP versions 5.2.X, and the other package is for PHP 5.3.X. Select the package that is appropriate for the PHP version being used.

To install and enable the extension, follow these steps:

  1. Unpack the package into some temporary location.

  2. Copy the php_wincache.dll file into the PHP extensions folder. Typically this folder is called "ext" and it is located in the same folder with all PHP binary files. For example: C:\Program Files\PHP\ext.

  3. Using a text editor, open the php.ini file, which is usually located in the same folder where all PHP binary files are. For example: C:\Program Files\PHP\php.ini.

  4. Add the following line at the end of the php.ini file: extension = php_wincache.dll.

  5. Save and close the php.ini file.

  6. Recycle the IIS Application Pools for PHP to pick up the configuration changes. To check that the extension has been enabled, create a file called phpinfo.php with a PHP code that calls phpinfo function.

  7. Save the phpinfo.php file in the root folder of a IIS web site that uses PHP, then open a browser and make a request to http://localhost/phpinfo.php. Search within the returned web page for a section called wincache. If the extension is enabled, then the phpinfo output will list the configuration settings provided by the WinCache.

Note: Do not forget to remove phpinfo.php file from the web site's root folder after verifying that extension has been enabled.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

The following table lists and explains the configuration settings provided by the WinCache extension:

WinCache configuration options
名字 | 默认 | Minimum | Maximum | 可修改范围 | 更新日志
wincache.fcenabled | "1" | "0" | "1" | PHP_INI_ALL | Available as of WinCache 1.0.0
wincache.fcenabledfilter | "NULL" | "NULL" | "NULL" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.fcachesize | "24" | "5" | "255" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.fcndetect | "1" | "0" | "1" | PHP_INI_SYSTEM | Available as of WinCache 1.1.0
wincache.maxfilesize | "256" | "10" | "2048" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.ocenabled | "1" | "0" | "1" | PHP_INI_ALL | Available as of WinCache 1.0.0. Removed as of 2.0.0.0
wincache.ocenabledfilter | "NULL" | "NULL" | "NULL" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0. Removed as of 2.0.0.0
wincache.ocachesize | "96" | "15" | "255" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0. Removed as of 2.0.0.0
wincache.filecount | "4096" | "1024" | "16384" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.chkinterval | "30" | "0" | "300" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.ttlmax | "1200" | "0" | "7200" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.enablecli | 0 | 0 | 1 | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.ignorelist | NULL | NULL | NULL | PHP_INI_ALL | Available as of WinCache 1.0.0
wincache.namesalt | NULL | NULL | NULL | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.ucenabled | 1 | 0 | 1 | PHP_INI_SYSTEM | Available as of WinCache 1.1.0
wincache.ucachesize | 8 | 5 | 85 | PHP_INI_SYSTEM | Available as of WinCache 1.1.0
wincache.scachesize | 8 | 5 | 85 | PHP_INI_SYSTEM | Available as of WinCache 1.1.0
wincache.rerouteini | NULL | NULL | NULL | PHP_INI_SYSTEM | Available as of WinCache 1.2.0. Removed as of 1.3.7
wincache.reroute_enabled | 1 | 0 | 1 | PHP_INI_SYSTEM | PHP_INI_PERDIR | Available as of WinCache 1.3.7
wincache.srwlocks | 1 | 0 | 1 | PHP_INI_SYSTEM | Available as of WinCache 1.3.6.3. Removed as of 2.0.0.0
wincache.filemapdir | NULL | NULL | NULL | PHP_INI_SYSTEM | Available as of WinCache 1.3.7.4
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

wincache.fcenabled bool
Enables or disables the file cache functionality.
wincache.fcenabledfilter string
Defines a comma-separated list of IIS web site identifiers where file cache should be enabled or disabled. This setting works in conjunction with wincache.fcenabled: if wincache.fcenabled is set to 1, then the sites listed in the wincache.fcenabledfilter will have the file cache turned off; if wincache.fcenabled is set to 0, then the sites listed in the wincache.fcenabledfilter will have the file cache turned on.
wincache.fcachesize int
Defines the maximum memory size (in megabytes) that is allocated for the file cache. If the total size of all the cached files exceeds the value specified in this setting, then most stale files will be removed from the file cache.
wincache.fcndetect bool
Enables or disables the file change notification detection functionality. If file change notification is supported then it will be used to refresh the opcode and file cache entries as soon as the corresponding files are modified on a file system. If file change notification is not supported, for example when using network file shares, then wincache will poll for file changes at regular time intervals specified by wincache.chkinterval.
wincache.maxfilesize int
Defines the maximum allowed size (in kilobytes) for a single file to be cached. If a file size exceeds the specified value, the file will not be cached. This setting applies to the file cache only.
wincache.ocenabled bool
Warning

This option has been REMOVED as of 2.0.0.0

Enables or disables the opcode cache functionality
wincache.ocenabledfilter string
Warning

This option has been REMOVED as of 2.0.0.0

Defines a comma-separated list of IIS web site identifiers where opcode cache should be enabled or disabled. This setting works in conjunction with wincache.ocenabled: if wincache.ocenabled is set to 1, then the sites listed in the wincache.ocenabledfilter will have the opcode cache turned off; if wincache.ocenabled is set to 0, then the sites listed in the wincache.ocenabledfilter will have the opcode cache turned on.
wincache.ocachesize int
Warning

This option has been REMOVED as of 2.0.0.0

Defines the maximum memory size (in megabytes) that is allocated for the opcode cache. If the cached opcode size exceeds the specified value, then most stale opcode will be removed from the cache. Note that the opcode cache size must be at least 3 times bigger than file cache size. If that is not the case the opcode cache size will be automatically increased.
wincache.filecount int
Defines how many files are expected to be cached by the extension, so that appropriate memory size is allocated at the startup time. If the number of files exceeds the specified value, the WinCache will re-allocate more memory as needed.
wincache.chkinterval int
Defines how often (in seconds) the extension checks for file changes in order to refresh the cache. Setting it to 0 will disable the refreshing of the cache. The file changes will not be reflected in the cache unless the cache entry for that file is removed by scavenger or IIS application pool is recycled or wincache_refresh_if_changed function is called.
wincache.ttlmax int
Defines the maximum time to live (in seconds) for a cached entry without being used. Setting it to 0 will disable the cache scavenger, so the cached entries will never be removed from the cache during the lifetime of the IIS worker process.
wincache.enablecli bool
Defines if caching is enabled when PHP is running in command line (CLI) mode.
wincache.ignorelist string

Defines a list of files that should not be cached by the extension. The files list is specified by using file names only, separated by the pipe symbol - "|".

Example #1 wincache.ignorelist example

wincache.ignorelist = "index.php|misc.php|admin.php"

wincache.namesalt string
Defines a string that will be used when naming the extension specific objects that are stored in shared memory. This is used to avoid conflicts that may be caused if other applications within an IIS worker process tries to access shared memory. The length of the namesalt string cannot exceed 8 characters.
wincache.ucenabled bool
Enables or disables the user cache functionality.
wincache.ucachesize int
Defines the maximum memory size in megabytes that is allocated for the user cache. If the total size of variables stored in the user cache exceeds the specified value, then the most stale variables will be removed from the cache.
wincache.scachesize int
Defines the maximum memory size in megabytes that is allocated for the session cache. If the total size of data stored in the session cache exceeds the specified value, then the most stale data will be removed from the cache.
wincache.rerouteini string
Warning

This option has been REMOVED as of 1.3.7. See wincache.reroute_enabled for similar functionality as of 1.3.7.

Specifies an absolute or a relateve path to the reroute.ini file that contains the list of PHP functions whose implementation should be replaced with the WinCache function equivalents. If a relative path is specified then it is assumed to be relative to the location of php-cgi.exe file.
wincache.reroute_enabled bool
Enables or disables the rerouting of certain file I/O functions through the file cache.
wincache.srwlocks bool
Warning

This option has been REMOVED as of 2.0.0.0

Enables or disables the use of shared reader/writer locks. Disabling is useful when troubleshooting deadlock conditions in WinCache.
wincache.filemapdir string
Specifies an absolute path to a directory where WinCache will store the temporary files used for shared memory segments. This directory must be on the local machine and not on a networked file system. If the directory is not specified, WinCache will use the Windows System Page File for all shared memory segments.


WinCache Statistics Script

The installation package for WinCache includes a PHP script, wincache.php, that can be used to obtain cache information and statistics.

If the WinCache extension was installed via the Microsoft Web Platform Installer, then this script is located in %SystemDrive%\Program Files\IIS\Windows Cache for PHP\. On a 64-bit version of the Windows Server operating system, the script is located in %SystemDrive%\Program Files (x86)\IIS\Windows Cache for PHP. If the extension was installed manually, then the wincache.php will be located in the same folder from which the content of the installation package was extracted.

To use wincache.php, copy it into a root folder of a Web site or into any subfolder. To protect the script, open it in any text editor and replace the values for USERNAME and PASSWORD constants. If any other IIS authentication is enabled on the server, then follow the instructions in the comments:

Example #1 Authentication configuration for wincache.php

<?php
/**
 * ======================== CONFIGURATION SETTINGS ==============================
 * If you do not want to use authentication for this page, set USE_AUTHENTICATION to 0.
 * If you use authentication then replace the default password.
 */
define('USE_AUTHENTICATION', 1);
define('USERNAME', 'wincache');
define('PASSWORD', 'wincache');

/**
 * The Basic PHP authentication will work only when IIS is configured to support
 * Anonymous Authentication' and nothing else. If IIS is configured to support/use
 * any other kind of authentication like Basic/Negotiate/Digest etc, this will not work.
 * In that case use the array below to define the names of users in your
 * domain/network/workgroup which you want to grant access to.
 */
$user_allowed = array('DOMAIN\user1', 'DOMAIN\user2', 'DOMAIN\user3');

/**
 * If the array contains string 'all', then all the users authenticated by IIS
 * will have access to the page. Uncomment the below line and comment above line
 * to grant access to all users who gets authenticated by IIS.
 */
/* $user_allowed = array('all'); */

/** ===================== END OF CONFIGURATION SETTINGS ========================== */
?>

Note: Always protect the wincache.php script by using either the built-in authentication or the server's authentication mechanism. Leaving this script unprotected may compromise the security of your web application and web server.


WinCache Session Handler

The WinCache session handler (available since WinCache 1.1.0) can be used to configure PHP to store the session data in shared memory session cache. Using shared memory instead of the default file session storage helps improve performance of PHP applications that store large amount of data in session objects. Wincache session cache uses file-backed shared memory, which ensures that the session data is not lost during recycling of IIS application pools.

To configure PHP to use WinCache session handler set the php.ini setting session.save_handler to wincache. By default the Windows temporary file location is used for storing the session data. To change the location of the session file use session.save_path directive.

Example #1 Enabling WinCache session handler

session.save_handler = wincache
session.save_path = C:\inetpub\temp\session\


WinCache Functions Reroutes

NOTE: wincache.rerouteini was removed as of WinCache 1.3.7.0. It has been replaced with automatic function reroutes. See: wincache.reroute_enabled.

The WinCache functions reroutes (available since WinCache 1.2.0, removed since WinCache 1.3.7.0) can be used to replace built-in PHP functions with their equivalents that are optimized for a particular purpose. WinCache extension includes Windows-optimized implementation of PHP file functions that may improve performance of PHP applications in cases when PHP has to access files on network shares. The optimized implementation is provided for the following functions:

  • file_exists
  • file_get_contents
  • readfile
  • is_readable
  • is_writable
  • is_dir
  • realpath
  • filesize

To configure WinCache to use the functions reroutes use the file reroute.ini that is included in WinCache installation package. Copy this file into the same directory where php.ini file is located. After that add the wincache.rerouteini setting in php.ini and specify an absolute or relative path to the reroute.ini file.

Example #1 Enabling WinCache functions reroutes

wincache.rerouteini = C:\PHP\reroute.ini

Note: If WinCache functions reroutes are enabled it is recommended to increase the WinCache file cache size. This can be done by using wincache.fcachesize setting.

The reroute.ini file contains the mappings between the native PHP functions and their equivalents in WinCache. Each line in the file defines a mapping by using the following syntax:

<PHP function name>:[<number of function parameters>]=<wincache function name>

The example of the file is shown below. In this example the calls to PHP function file_get_contents() will be replaced with calls to wincache_file_get_contents() only if the number of parameters passed to the function is less than or equals to 2. Specifying the number of parameters is useful when replacement function does not handle all the function's parameters.

Example #2 Reroute.ini file content

[FunctionRerouteList]
file_exists=wincache_file_exists
file_get_contents:2=wincache_file_get_contents
readfile:2=wincache_readfile
is_readable=wincache_is_readable
is_writable=wincache_is_writable
is_writeable=wincache_is_writable
is_file=wincache_is_file
is_dir=wincache_is_dir
realpath=wincache_realpath
filesize=wincache_filesize


  • ? WinCache Functions Reroutes
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


  • ? 资源类型
  • WinCache 函数 ?
  • PHP Manual
  • WinCache
  • 预定义常量

预定义常量

此扩展没有定义常量。


WinCache 函数

Table of Contents

  • wincache_fcache_fileinfo — Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo — Retrieves information about file cache memory usage
  • wincache_lock — Acquires an exclusive lock on a given key
  • wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo — Retrieves information about opcode cache memory usage
  • wincache_refresh_if_changed — Refreshes the cache entries for the cached files
  • wincache_rplist_fileinfo — Retrieves information about resolve file path cache
  • wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache
  • wincache_scache_info — Retrieves information about files cached in the session cache
  • wincache_scache_meminfo — Retrieves information about session cache memory usage
  • wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_cas — Compares the variable with old value and assigns new value to it
  • wincache_ucache_clear — Deletes entire content of the user cache
  • wincache_ucache_dec — Decrements the value associated with the key
  • wincache_ucache_delete — Deletes variables from the user cache
  • wincache_ucache_exists — Checks if a variable exists in the user cache
  • wincache_ucache_get — Gets a variable stored in the user cache
  • wincache_ucache_inc — Increments the value associated with the key
  • wincache_ucache_info — Retrieves information about data stored in the user cache
  • wincache_ucache_meminfo — Retrieves information about user cache memory usage
  • wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_unlock — Releases an exclusive lock on a given key


Retrieves information about files cached in the file cache

  • ? WinCache 函数
  • wincache_fcache_meminfo ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about files cached in the file cache

wincache_fcache_fileinfo

(PECL wincache >= 1.0.0)

wincache_fcache_fileinfo — Retrieves information about files cached in the file cache

说明

wincache_fcache_fileinfo ( bool $summaryonly = false ) : array|false

Retrieves information about file cache content and its usage.

参数

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the file cache summary.

返回值

Array of meta data about file cache 或者在失败时返回 false

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the file cache has been active
  • total_file_count - total number of files that are currently in the file cache
  • total_hit_count - number of times the files have been served from the file cache
  • total_miss_count - number of times the files have not been found in the file cache

  • file_entries - an array that contains the information about all the cached files:

    • file_name - absolute file name of the cached file
    • add_time - time in seconds since the file has been added to the file cache
    • use_time - time in seconds since the file has been accessed in the file cache
    • last_check - time in seconds since the file has been checked for modifications
    • hit_count - number of times the file has been served from the cache
    • file_size - size of the cached file in bytes

范例

Example #1 A wincache_fcache_fileinfo() example

<pre>
<?php
print_r(wincache_fcache_fileinfo());
?>
</pre>

以上例程会输出：

Array
(   [total_cache_uptime] => 3234
    [total_file_count] => 5
    [total_hit_count] => 0
    [total_miss_count] => 1
    [file_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 1
                    [use_time] => 0
                    [last_check] => 1
                    [hit_count] => 1
                    [file_size] => 2435
                )
            [2] => Array (...iterates for each cached file)
        )
)

参见

  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Retrieves information about file cache memory usage

  • ? wincache_fcache_fileinfo
  • wincache_lock ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about file cache memory usage

wincache_fcache_meminfo

(PECL wincache >= 1.0.0)

wincache_fcache_meminfo — Retrieves information about file cache memory usage

说明

wincache_fcache_meminfo ( ) : array|false

Retrieves information about memory usage by file cache.

返回值

Array of meta data about file cache memory usage 或者在失败时返回 false

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the file cache
  • memory_free - amount of free memory in bytes available for the file cache
  • num_used_blks - number of memory blocks used by the file cache
  • num_free_blks - number of free memory blocks available for the file cache
  • memory_overhead - amount of memory in bytes used for the file cache internal structures

范例

Example #1 A wincache_fcache_meminfo() example

<pre>
<?php
print_r(wincache_fcache_meminfo());
?>
</pre>

以上例程会输出：

Array
(
    [memory_total] => 134217728
    [memory_free] => 131339120
    [num_used_blks] => 361
    [num_free_blks] => 3
    [memory_overhead] => 5856
)

参见

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Acquires an exclusive lock on a given key

  • ? wincache_fcache_meminfo
  • wincache_ocache_fileinfo ?
  • PHP Manual
  • WinCache 函数
  • Acquires an exclusive lock on a given key

wincache_lock

(PECL wincache >= 1.1.0)

wincache_lock — Acquires an exclusive lock on a given key

说明

wincache_lock ( string $key , bool $isglobal = false ) : bool

Obtains an exclusive lock on a given key. The execution of the current script will be blocked until the lock can be obtained. Once the lock is obtained, the other scripts that try to request the lock by using the same key will be blocked, until the current script releases the lock by using wincache_unlock().

Warning

Using of the wincache_lock() and wincache_unlock() can cause deadlocks when executing PHP scripts in a multi-process environment like FastCGI. Do not use these functions unless you are absolutely sure you need to use them. For the majority of the operations on the user cache it is not necessary to use these functions.

参数

key

Name of the key in the cache to get the lock on.

isglobal

Controls whether the scope of the lock is system-wide or local. Local locks are scoped to the application pool in IIS FastCGI case or to all php processes that have the same parent process identifier.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Using wincache_lock()

<?php
$fp = fopen("/tmp/lock.txt", "r+");
if (wincache_lock("lock_txt_lock")) { // do an exclusive lock
    ftruncate($fp, 0); // truncate file
    fwrite($fp, "Write something here\n");
    wincache_unlock("lock_txt_lock"); // release the lock
} else {
    echo "Couldn't get the lock!";
}
fclose($fp);
?>

参见

  • wincache_unlock() - Releases an exclusive lock on a given key
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache


Retrieves information about files cached in the opcode cache

  • ? wincache_lock
  • wincache_ocache_meminfo ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about files cached in the opcode cache

wincache_ocache_fileinfo

(PECL wincache >= 1.0.0)

wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache

说明

wincache_ocache_fileinfo ( bool $summaryonly = false ) : array|false

Retrieves information about opcode cache content and its usage.

Warning

该函数已在 PHP 7.0.0 中 移除。

参数

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the opcode cache summary.

返回值

Array of meta data about opcode cache 或者在失败时返回 false

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the opcode cache has been active
  • total_file_count - total number of files that are currently in the opcode cache
  • total_hit_count - number of times the compiled opcode have been served from the cache
  • total_miss_count - number of times the compiled opcode have not been found in the cache
  • is_local_cache - true is the cache metadata is for a local cache instance, false if the metadata is for the global cache

  • file_entries - an array that contains the information about all the cached files:

    • file_name - absolute file name of the cached file
    • add_time - time in seconds since the file has been added to the opcode cache
    • use_time - time in seconds since the file has been accessed in the opcode cache
    • last_check - time in seconds since the file has been checked for modifications
    • hit_count - number of times the file has been served from the cache
    • function_count - number of functions in the cached file
    • class_count - number of classes in the cached file

范例

Example #1 A wincache_ocache_fileinfo() example

<pre>
<?php
print_r(wincache_ocache_fileinfo());
?>
</pre>

以上例程会输出：

Array
(
    [total_cache_uptime] => 17357
    [total_file_count] => 121
    [total_hit_count] => 36562
    [total_miss_count] => 201
    [file_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 17356
                    [use_time] => 7
                    [last_check] => 10
                    [hit_count] => 454
                    [function_count] => 0
                    [class_count] => 1
                )
            [2] => Array (...iterates for each cached file)
        )
)

参见

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Retrieves information about opcode cache memory usage

  • ? wincache_ocache_fileinfo
  • wincache_refresh_if_changed ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about opcode cache memory usage

wincache_ocache_meminfo

(PECL wincache >= 1.0.0)

wincache_ocache_meminfo — Retrieves information about opcode cache memory usage

说明

wincache_ocache_meminfo ( ) : array|false

Retrieves information about memory usage by opcode cache.

返回值

Array of meta data about opcode cache memory usage 或者在失败时返回 false

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the opcode cache
  • memory_free - amount of free memory in bytes available for the opcode cache
  • num_used_blks - number of memory blocks used by the opcode cache
  • num_free_blks - number of free memory blocks available for the opcode cache
  • memory_overhead - amount of memory in bytes used for the opcode cache internal structures

Warning

该函数已在 PHP 7.0.0 中 移除。

范例

Example #1 A wincache_ocache_meminfo() example

<pre>
<?php
print_r(wincache_ocache_meminfo());
?>
</pre>

以上例程会输出：

Array
(
    [memory_total] => 134217728
    [memory_free] => 112106972
    [num_used_blks] => 15469
    [num_free_blks] => 4
    [memory_overhead] => 247600
)

参见

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Refreshes the cache entries for the cached files

  • ? wincache_ocache_meminfo
  • wincache_rplist_fileinfo ?
  • PHP Manual
  • WinCache 函数
  • Refreshes the cache entries for the cached files

wincache_refresh_if_changed

(PECL wincache >= 1.0.0)

wincache_refresh_if_changed — Refreshes the cache entries for the cached files

说明

wincache_refresh_if_changed ( array $files = NULL ) : bool

Refreshes the cache entries for the files, whose names were passed in the input argument. If no argument is specified then refreshes all the entries in the cache.

参数

files

An array of file names for files that need to be refreshed. An absolute or relative file paths can be used.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

WinCache performs regular checks on the cached files to ensure that if any file has changed then the corresponding entry in the cache is updated. By default this check is performed every 30 seconds. If, for example, a PHP script updates another PHP script where the application's configuration settings are stored, then it may happen that after the configuration settings have been saved to a file, the application is still using old settings for some time until the cache is refreshed. In those cases it may be preferrable to refresh the cache right after the file has been changed. The following example shows how this can be done.

Example #1 A wincache_refresh_if_changed() example

<?php
$filename = 'C:\inetpub\wwwroot\config.php';
$handle = fopen($filename, 'w+');
if ($handle === FALSE) die('Failed to open file '.$filename.' for writing');
fwrite($handle, '<?php $setting=something; ?>');
fclose($handle);
wincache_refresh_if_changed(array($filename));
?>

参见

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache


Retrieves information about resolve file path cache

  • ? wincache_refresh_if_changed
  • wincache_rplist_meminfo ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about resolve file path cache

wincache_rplist_fileinfo

(PECL wincache >= 1.0.0)

wincache_rplist_fileinfo — Retrieves information about resolve file path cache

说明

wincache_rplist_fileinfo ( bool $summaryonly = false ) : array|false

Retrieves information about cached mappings between relative file paths and corresponding absolute file paths.

返回值

Array of meta data about the resolve file path cache 或者在失败时返回 false

The array returned by this function contains the following elements:

  • total_file_count - total number of file path mappings stored in the cache

  • rplist_entries - an array that contains the information about all the cached file paths:

    • resolve_path - path to a file
    • subkey_data - corresponding absolute path to a file

范例

Example #1 A wincache_rplist_fileinfo() example

<pre>
<?php
print_r(wincache_rplist_fileinfo());
?>
</pre>

以上例程会输出：

Array
(
    [total_file_count] => 5
    [rplist_entries] => Array
        (
            [1] => Array
                (
                    [resolve_path] => checkcache.php
                    [subkey_data] => c:\inetpub\wwwroot|c:\inetpub\wwwroot\checkcache.php
                )

            [2] => Array (...iterates for each cached file)
        )
)

参见

  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Retrieves information about memory usage by the resolve file path cache

  • ? wincache_rplist_fileinfo
  • wincache_scache_info ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about memory usage by the resolve file path cache

wincache_rplist_meminfo

(PECL wincache >= 1.0.0)

wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache

说明

wincache_rplist_meminfo ( ) : array|false

Retrieves information about memory usage by resolve file path cache.

返回值

Array of meta data that describes memory usage by resolve file path cache. 或者在失败时返回 false

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the resolve file path cache
  • memory_free - amount of free memory in bytes available for the resolve file path cache
  • num_used_blks - number of memory blocks used by the resolve file path cache
  • num_free_blks - number of free memory blocks available for the resolve file path cache
  • memory_overhead - amount of memory in bytes used for the internal structures of resolve file path cache

范例

Example #1 A wincache_rplist_meminfo() example

<pre>
<?php
print_r(wincache_rplist_meminfo());
?>
</pre>

以上例程会输出：

Array
(
    [memory_total] => 9437184
    [memory_free] => 9416744
    [num_used_blks] => 23
    [num_free_blks] => 1
    [memory_overhead] => 416
)

参见

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Retrieves information about files cached in the session cache

  • ? wincache_rplist_meminfo
  • wincache_scache_meminfo ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about files cached in the session cache

wincache_scache_info

(PECL wincache >= 1.1.0)

wincache_scache_info — Retrieves information about files cached in the session cache

说明

wincache_scache_info ( bool $summaryonly = false ) : array|false

Retrieves information about session cache content and its usage.

参数

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the session cache summary.

返回值

Array of meta data about session cache 或者在失败时返回 false

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the session cache has been active
  • total_item_count - total number of elements that are currently in the session cache
  • is_local_cache - true is the cache metadata is for a local cache instance, false if the metadata is for the global cache
  • total_hit_count - number of times the data has been served from the cache
  • total_miss_count - number of times the data has not been found in the cache

  • scache_entries - an array that contains the information about all the cached items:

    • key_name - name of the key which is used to store the data
    • value_type - type of value stored by the key
    • use_time - time in seconds since the file has been accessed in the opcode cache
    • last_check - time in seconds since the file has been checked for modifications
    • ttl_seconds - time remaining for the data to live in the cache, 0 meaning infinite
    • age_seconds - time elapsed from the time data has been added in the cache
    • hitcount - number of times data has been served from the cache

范例

Example #1 A wincache_scache_info() example

<pre>
<?php
print_r(wincache_scache_info());
?>
</pre>

以上例程会输出：

Array
(
    [total_cache_uptime] => 17357
    [total_file_count] => 121
    [total_hit_count] => 36562
    [total_miss_count] => 201
    [scache_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 17356
                    [use_time] => 7
                    [last_check] => 10
                    [hit_count] => 454
                    [function_count] => 0
                    [class_count] => 1
                )
            [2] => Array (...iterates for each cached file)
        )
)

参见

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Retrieves information about session cache memory usage

  • ? wincache_scache_info
  • wincache_ucache_add ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about session cache memory usage

wincache_scache_meminfo

(PECL wincache >= 1.1.0)

wincache_scache_meminfo — Retrieves information about session cache memory usage

说明

wincache_scache_meminfo ( ) : array|false

Retrieves information about memory usage by session cache.

返回值

Array of meta data about session cache memory usage 或者在失败时返回 false

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the session cache
  • memory_free - amount of free memory in bytes available for the session cache
  • num_used_blks - number of memory blocks used by the session cache
  • num_free_blks - number of free memory blocks available for the session cache
  • memory_overhead - amount of memory in bytes used for the session cache internal structures

范例

Example #1 A wincache_scache_meminfo() example

<pre>
<?php
print_r(wincache_scache_meminfo());
?>
</pre>

以上例程会输出：

Array
(
    [memory_total] => 5242880
    [memory_free] => 5215056
    [num_used_blks] => 6
    [num_free_blks] => 3
    [memory_overhead] => 176
)

参见

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache


Adds a variable in user cache only if variable does not already exist in the cache

  • ? wincache_scache_meminfo
  • wincache_ucache_cas ?
  • PHP Manual
  • WinCache 函数
  • Adds a variable in user cache only if variable does not already exist in the cache

wincache_ucache_add

(PECL wincache >= 1.1.0)

wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache

说明

wincache_ucache_add ( string $key , mixed $value , int $ttl = 0 ) : bool
wincache_ucache_add ( array $values , mixed $unused = NULL , int $ttl = 0 ) : bool

Adds a variable in user cache, only if this variable doesn't already exist in the cache. The added variable remains in the user cache unless its time to live expires or it is deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

参数

key

Store the variable using this key name. If a variable with same key is already present the function will fail and return false. key is case sensitive. To override the value even if key is present use wincache_ucache_set() function instad. key can also take array of name => value pairs where names will be used as keys. This can be used to add multiple values in the cache in one operation, thus avoiding race condition.

value

Value of a variable to store. Value supports all data types except resources, such as file handles. This paramter is ignored if first argument is an array. A general guidance is to pass null as value while using array as key. If value is an object, or an array containing objects, then the objects will be serialized. See __sleep() for details on serializing objects.

values

Associative array of keys and values.

ttl

Time for the variable to live in the cache in seconds. After the value specified in ttl has passed the stored variable will be deleted from the cache. This parameter takes a default value of 0 which means the variable will stay in the cache unless explicitly deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

返回值

If key is string, the function returns true on success and false on failure.

If key is an array, the function returns:

  • If all the name => value pairs in the array can be set, function returns an empty array;
  • If all the name => value pairs in the array cannot be set, function returns false;
  • If some can be set while others cannot, function returns an array with name=>value pair for which the addition failed in the user cache.

范例

Example #1 wincache_ucache_add() with key as a string

<?php
$bar = 'BAR';
var_dump(wincache_ucache_add('foo', $bar));
var_dump(wincache_ucache_add('foo', $bar));
var_dump(wincache_ucache_get('foo'));
?>

以上例程会输出：

bool(true)
bool(false)
string(3) "BAR"

Example #2 wincache_ucache_add() with key as an array

<?php
$colors_array = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
var_dump(wincache_ucache_add($colors_array));
var_dump(wincache_ucache_add($colors_array));
var_dump(wincache_ucache_get('Blue'));
?>

以上例程会输出：

array(0) { }
array(4) {
  ["green"]=> int(-1)
  ["Blue"]=> int(-1)
  ["yellow"]=> int(-1)
  ["cyan"]=> int(-1)
}
string(1) "6"

参见

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • __sleep()


Compares the variable with old value and assigns new value to it

  • ? wincache_ucache_add
  • wincache_ucache_clear ?
  • PHP Manual
  • WinCache 函数
  • Compares the variable with old value and assigns new value to it

wincache_ucache_cas

(PECL wincache >= 1.1.0)

wincache_ucache_cas — Compares the variable with old value and assigns new value to it

说明

wincache_ucache_cas ( string $key , int $old_value , int $new_value ) : bool

Compares the variable associated with the key with old_value and if it matches then assigns the new_value to it.

参数

key

The key that is used to store the variable in the cache. key is case sensitive.

old_value

Old value of the variable pointed by key in the user cache. The value should be of type long, otherwise the function returns false.

new_value

New value which will get assigned to variable pointer by key if a match is found. The value should be of type long, otherwise the function returns false.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Using wincache_ucache_cas()

<?php
wincache_ucache_set('counter', 2922);
var_dump(wincache_ucache_cas('counter', 2922, 1));
var_dump(wincache_ucache_get('counter'));
?>

以上例程会输出：

bool(true)
int(1)

参见

  • wincache_ucache_inc() - Increments the value associated with the key
  • wincache_ucache_dec() - Decrements the value associated with the key


Deletes entire content of the user cache

  • ? wincache_ucache_cas
  • wincache_ucache_dec ?
  • PHP Manual
  • WinCache 函数
  • Deletes entire content of the user cache

wincache_ucache_clear

(PECL wincache >= 1.1.0)

wincache_ucache_clear — Deletes entire content of the user cache

说明

wincache_ucache_clear ( ) : bool

Clears/deletes all the values stored in the user cache.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 using wincache_ucache_clear()

<?php
wincache_ucache_set('green', 1);
wincache_ucache_set('red', 2);
wincache_ucache_set('orange', 4);
wincache_ucache_set('blue', 8);
wincache_ucache_set('cyan', 16);
$array1 = array('green', 'red', 'orange', 'blue', 'cyan');
var_dump(wincache_ucache_get($array1));
var_dump(wincache_ucache_clear());
var_dump(wincache_ucache_get($array1));
?>

以上例程会输出：

array(5) { ["green"]=> int(1)
           ["red"]=> int(2)
           ["orange"]=> int(4)
           ["blue"]=> int(8)
           ["cyan"]=> int(16) }
bool(true)
bool(false)

参见

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache


Decrements the value associated with the key

  • ? wincache_ucache_clear
  • wincache_ucache_delete ?
  • PHP Manual
  • WinCache 函数
  • Decrements the value associated with the key

wincache_ucache_dec

(PECL wincache >= 1.1.0)

wincache_ucache_dec — Decrements the value associated with the key

说明

wincache_ucache_dec ( string $key , int $dec_by = 1 , bool &$success = ? ) : mixed

Decrements the value associated with the key by 1 or as specified by dec_by.

参数

key

The key that was used to store the variable in the cache. key is case sensitive.

dec_by

The value by which the variable associated with the key will get decremented. If the argument is a floating point number it will be truncated to nearest integer. The variable associated with the key should be of type long, otherwise the function fails and returns false.

success

Will be set to true on success and false on failure.

返回值

Returns the decremented value on success and false on failure.

范例

Example #1 Using wincache_ucache_dec()

<?php
wincache_ucache_set('counter', 1);
var_dump(wincache_ucache_dec('counter', 2923, $success));
var_dump($success);
?>

以上例程会输出：

int(2922)
bool(true)

参见

  • wincache_ucache_inc() - Increments the value associated with the key
  • wincache_ucache_cas() - Compares the variable with old value and assigns new value to it


Deletes variables from the user cache

  • ? wincache_ucache_dec
  • wincache_ucache_exists ?
  • PHP Manual
  • WinCache 函数
  • Deletes variables from the user cache

wincache_ucache_delete

(PECL wincache >= 1.1.0)

wincache_ucache_delete — Deletes variables from the user cache

说明

wincache_ucache_delete ( mixed $key ) : bool

Deletes the elements in the user cache pointed by key.

参数

key

The key that was used to store the variable in the cache. key is case sensitive. key can be an array of keys.

返回值

成功时返回 true， 或者在失败时返回 false。

If key is an array then the function returns false if every element of the array fails to get deleted from the user cache, otherwise returns an array which consists of all the keys that are deleted.

范例

Example #1 Using wincache_ucache_delete() with key as a string

<?php
wincache_ucache_set('foo', 'bar');
var_dump(wincache_ucache_delete('foo'));
var_dump(wincache_ucache_exists('foo'));
?>

以上例程会输出：

bool(true)
bool(false)

Example #2 Usingwincache_ucache_delete() with key as an array

<?php
$array1 = array('green' => '5', 'blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('green', 'blue', 'yellow', 'cyan');
var_dump(wincache_ucache_delete($array2));
?>

以上例程会输出：

array(4) { [0]=> string(5) "green"
           [1]=> string(4) "Blue"
           [2]=> string(6) "yellow"
           [3]=> string(4) "cyan" }

Example #3 Using wincache_ucache_delete() with key as an array where some elements cannot be deleted

<?php
$array1 = array('green' => '5', 'blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('orange', 'red', 'yellow', 'cyan');
var_dump(wincache_ucache_delete($array2));
?>

以上例程会输出：

array(2) { [0]=> string(6) "yellow"
           [1]=> string(4) "cyan" }

参见

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache


Checks if a variable exists in the user cache

  • ? wincache_ucache_delete
  • wincache_ucache_get ?
  • PHP Manual
  • WinCache 函数
  • Checks if a variable exists in the user cache

wincache_ucache_exists

(PECL wincache >= 1.1.0)

wincache_ucache_exists — Checks if a variable exists in the user cache

说明

wincache_ucache_exists ( string $key ) : bool

Checks if a variable with the key exists in the user cache or not.

参数

key

The key that was used to store the variable in the cache. key is case sensitive.

返回值

Returns true if variable with the key exitsts, otherwise returns false.

范例

Example #1 Using wincache_ucache_exists()

<?php
if (!wincache_ucache_exists('green'))
    wincache_ucache_set('green', 1);
var_dump(wincache_ucache_exists('green'));
?>

以上例程会输出：

bool(true)

参见

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache


Gets a variable stored in the user cache

  • ? wincache_ucache_exists
  • wincache_ucache_inc ?
  • PHP Manual
  • WinCache 函数
  • Gets a variable stored in the user cache

wincache_ucache_get

(PECL wincache >= 1.1.0)

wincache_ucache_get — Gets a variable stored in the user cache

说明

wincache_ucache_get ( mixed $key , bool &$success = ? ) : mixed

Gets a variable stored in the user cache.

参数

key

The key that was used to store the variable in the cache. key is case sensitive. key can be an array of keys. In this case the return value will be an array of values of each element in the key array. If an object, or an array containing objects, is returned, then the objects will be unserialized. See __wakeup() for details on unserializing objects.

success

Will be set to true on success and false on failure.

返回值

If key is a string, the function returns the value of the variable stored with that key. The success is set to true on success and to false on failure.

The key is an array, the parameter success is always set to true. The returned array (name => value pairs) will contain only those name => value pairs for which the get operation in user cache was successful. If none of the keys in the key array finds a match in the user cache an empty array will be returned.

范例

Example #1 wincache_ucache_get() with key as a string

<?php
wincache_ucache_add('color', 'blue');
var_dump(wincache_ucache_get('color', $success));
var_dump($success);
?>

以上例程会输出：

string(4) "blue"
bool(true)

Example #2 wincache_ucache_get() with key as an array

<?php
$array1 = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('green', 'Blue', 'yellow', 'cyan');
var_dump(wincache_ucache_get($array2, $success));
var_dump($success);
?>

以上例程会输出：

array(4) { ["green"]=> string(1) "5"
           ["Blue"]=> string(1) "6"
           ["yellow"]=> string(1) "7"
           ["cyan"]=> string(1) "8" }
bool(true)

参见

  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • __wakeup()


Increments the value associated with the key

  • ? wincache_ucache_get
  • wincache_ucache_info ?
  • PHP Manual
  • WinCache 函数
  • Increments the value associated with the key

wincache_ucache_inc

(PECL wincache >= 1.1.0)

wincache_ucache_inc — Increments the value associated with the key

说明

wincache_ucache_inc ( string $key , int $inc_by = 1 , bool &$success = ? ) : mixed

Increments the value associated with the key by 1 or as specified by inc_by.

参数

key

The key that was used to store the variable in the cache. key is case sensitive.

inc_by

The value by which the variable associated with the key will get incremented. If the argument is a floating point number it will be truncated to nearest integer. The variable associated with the key should be of type long, otherwise the function fails and returns false.

success

Will be set to true on success and false on failure.

返回值

Returns the incremented value on success and false on failure.

范例

Example #1 Using wincache_ucache_inc()

<?php
wincache_ucache_set('counter', 1);
var_dump(wincache_ucache_inc('counter', 2921, $success));
var_dump($success);
?>

以上例程会输出：

int(2922)
bool(true)

参见

  • wincache_ucache_dec() - Decrements the value associated with the key
  • wincache_ucache_cas() - Compares the variable with old value and assigns new value to it


Retrieves information about data stored in the user cache

  • ? wincache_ucache_inc
  • wincache_ucache_meminfo ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about data stored in the user cache

wincache_ucache_info

(PECL wincache >= 1.1.0)

wincache_ucache_info — Retrieves information about data stored in the user cache

说明

wincache_ucache_info ( bool $summaryonly = false , string $key = NULL ) : array|false

Retrieves information about data stored in the user cache.

参数

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the user cache summary.

key

The key of an entry in the user cache. If specified then the returned array will contain information only about that cache entry. If not specified and summaryonly is set to false then the returned array will contain information about all entries in the cache.

返回值

Array of meta data about user cache 或者在失败时返回 false

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the user cache has been active
  • total_item_count - total number of elements that are currently in the user cache
  • is_local_cache - true is the cache metadata is for a local cache instance, false if the metadata is for the global cache
  • total_hit_count - number of times the data has been served from the cache
  • total_miss_count - number of times the data has not been found in the cache

  • ucache_entries - an array that contains the information about all the cached items:

    • key_name - name of the key which is used to store the data
    • value_type - type of value stored by the key
    • use_time - time in seconds since the file has been accessed in the opcode cache
    • last_check - time in seconds since the file has been checked for modifications
    • is_session - indicates if the data is a session variable
    • ttl_seconds - time remaining for the data to live in the cache, 0 meaning infinite
    • age_seconds - time elapsed from the time data has been added in the cache
    • hitcount - number of times data has been served from the cache

范例

Example #1 Using wincache_ucache_info()

<?php
wincache_ucache_get('green');
wincache_ucache_set('green', 2922);
wincache_ucache_get('green');
wincache_ucache_get('green');
wincache_ucache_get('green');
print_r(wincache_ucache_info());
?>

以上例程会输出：

Array
( ["total_cache_uptime"] => int(0)
  ["is_local_cache"] => bool(false)
  ["total_item_count"] => int(1)
  ["total_hit_count"] => int(3)
  ["total_miss_count"] => int(1)
  ["ucache_entries"] => Array(1)
    ( [1] => Array(6)
      (
        ["key_name"] => string(5) "green"
        ["value_type"] => string(4) "long"
        ["is_session"] => int(0)
        ["ttl_seconds"] => int(0)
        ["age_seconds"] => int(0)
        ["hitcount"] => int(3)
       )
    )
)

参见

  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Retrieves information about user cache memory usage

  • ? wincache_ucache_info
  • wincache_ucache_set ?
  • PHP Manual
  • WinCache 函数
  • Retrieves information about user cache memory usage

wincache_ucache_meminfo

(PECL wincache >= 1.1.0)

wincache_ucache_meminfo — Retrieves information about user cache memory usage

说明

wincache_ucache_meminfo ( ) : array|false

Retrieves information about memory usage by user cache.

返回值

Array of meta data about user cache memory usage 或者在失败时返回 false

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the user cache
  • memory_free - amount of free memory in bytes available for the user cache
  • num_used_blks - number of memory blocks used by the user cache
  • num_free_blks - number of free memory blocks available for the user cache
  • memory_overhead - amount of memory in bytes used for the user cache internal structures

范例

Example #1 A wincache_ucache_meminfo() example

<pre>
<?php
print_r(wincache_ucache_meminfo());
?>
</pre>

以上例程会输出：

Array
(
    [memory_total] => 5242880
    [memory_free] => 5215056
    [num_used_blks] => 6
    [num_free_blks] => 3
    [memory_overhead] => 176
)

参见

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage


Adds a variable in user cache and overwrites a variable if it already exists in the cache

  • ? wincache_ucache_meminfo
  • wincache_unlock ?
  • PHP Manual
  • WinCache 函数
  • Adds a variable in user cache and overwrites a variable if it already exists in the cache

wincache_ucache_set

(PECL wincache >= 1.1.0)

wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache

说明

wincache_ucache_set ( mixed $key , mixed $value , int $ttl = 0 ) : bool
wincache_ucache_set ( array $values , mixed $unused = NULL , int $ttl = 0 ) : bool

Adds a variable in user cache. Overwrites a variable if it already exists in the cache. The added or updated variable remains in the user cache unless its time to live expires or it is deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

参数

key

Store the variable using this key name. If a variable with same key is already present the function will overwrite the previous value with the new one. key is case sensitive. key can also take array of name => value pairs where names will be used as keys. This can be used to add multiple values in the cache in one operation, thus avoiding race condition.

value

Value of a variable to store. Value supports all data types except resources, such as file handles. This paramter is ignored if first argument is an array. A general guidance is to pass null as value while using array as key. If value is an object, or an array containing objects, then the objects will be serialized. See __sleep() for details on serializing objects.

values

Associative array of keys and values.

ttl

Time for the variable to live in the cache in seconds. After the value specified in ttl has passed the stored variable will be deleted from the cache. This parameter takes a default value of 0 which means the variable will stay in the cache unless explicitly deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

返回值

If key is string, the function returns true on success and false on failure.

If key is an array, the function returns:

  • If all the name => value pairs in the array can be set, function returns an empty array;
  • If all the name => value pairs in the array cannot be set, function returns false;
  • If some can be set while others cannot, function returns an array with name=>value pair for which the addition failed in the user cache.

范例

Example #1 wincache_ucache_set() with key as a string

<?php
$bar = 'BAR';
var_dump(wincache_ucache_set('foo', $bar));
var_dump(wincache_ucache_get('foo'));
$bar1 = 'BAR1';
var_dump(wincache_ucache_set('foo', $bar1));
var_dump(wincache_ucache_get('foo'));
?>

以上例程会输出：

bool(true)
string(3) "BAR"
bool(true)
string(3) "BAR1"

Example #2 wincache_ucache_set() with key as an array

<?php
$colors_array = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
var_dump(wincache_ucache_set($colors_array));
var_dump(wincache_ucache_set($colors_array));
var_dump(wincache_ucache_get('Blue'));
?>

以上例程会输出：

array(0) {}
array(0) {}
string(1) "6"

参见

  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • __sleep()


Releases an exclusive lock on a given key

  • ? wincache_ucache_set
  • Building for Windows ?
  • PHP Manual
  • WinCache 函数
  • Releases an exclusive lock on a given key

wincache_unlock

(PECL wincache >= 1.1.0)

wincache_unlock — Releases an exclusive lock on a given key

说明

wincache_unlock ( string $key ) : bool

Releases an exclusive lock that was obtained on a given key by using wincache_lock(). If any other process was blocked waiting for the lock on this key, that process will be able to obtain the lock.

Warning

Using of the wincache_lock() and wincache_unlock() can cause deadlocks when executing PHP scripts in a multi-process environment like FastCGI. Do not use these functions unless you are absolutely sure you need to use them. For the majority of the operations on the user cache it is not necessary to use these functions.

参数

key

Name of the key in the cache to release the lock on.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Using wincache_unlock()

<?php
$fp = fopen("/tmp/lock.txt", "r+");
if (wincache_lock("lock_txt_lock")) { // do an exclusive lock
    ftruncate($fp, 0); // truncate file
    fwrite($fp, "Write something here\n");
    wincache_unlock("lock_txt_lock"); // release the lock
} else {
    echo "Couldn't get the lock!";
}
fclose($fp);
?>

参见

  • wincache_lock() - Acquires an exclusive lock on a given key
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache


Building for Windows

Table of Contents

  • Prerequisites
  • Compiling and building
  • Verifying the build


Prerequisites

Building WinCache extension will require:

  1. PHP source code
  2. PHP build environment
  3. WinCache source code

For completing first two steps, follow the step-by-step guide for how to » build PHP on Windows.

For getting the WinCache source code follow the instructions described in Downloading PECL extensions.


Compiling and building

The following steps describe how to compile and build WinCache on Windows OS:

  1. Open a command prompt which is used to build PHP

  2. Go to the root folder where PHP sources are present

  3. Run the command:

    cscript.exe win32\build\buildconf.js

  4. Run the command:

    configure.bat --help
    The output will contain a new flag --enable-wincache.

  5. Run the command:

    configure.js [all options used to build PHP] --enable-wincache
    --enable-wincache is the only extra option which is required to ensure that WinCache extension gets built properly. This option will build WinCache and will statically link it with PHP dll. To build WinCache extension as a stand-alone DLL use the option --enable-wincache=shared.

  6. Run the command:

    nmake


Verifying the build

The following steps describe how to verify that WinCache has been built correctly:

  1. Go to the folder where the PHP binaries are built

  2. Run the command:

    php.exe -n -d extension=php_wincache.dll -re wincache
    If WinCache has been built properly, the output of this command will list the INI directives and functions supported by WinCache.


层次式性能分析器

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Xhprof 函数
    • xhprof_disable — 停止 xhprof 分析器
    • xhprof_enable — 启动 xhprof 性能分析器
    • xhprof_sample_disable — 停止 xhprof 性能采样分析器
    • xhprof_sample_enable — 以采样模式启动 XHProf 性能分析


简介

XHProf 是一个轻量级的分层性能测量分析器。 在数据收集阶段，它跟踪调用次数与测量数据，展示程序动态调用的弧线图。 它在报告、后期处理阶段计算了独占的性能度量，例如运行经过的时间、CPU 计算时间和内存开销。 函数性能报告可以由调用者和被调用者终止。 在数据搜集阶段 XHProf 通过调用图的循环来检测递归函数，通过赋予唯一的深度名称来避免递归调用的循环。

XHProf 包含了一个基于 HTML 的简单用户界面(由 PHP 写成)。 基于浏览器的用户界面使得浏览、分享性能数据结果更加简单方便。 同时也支持查看调用图。

XHProf 的报告对理解代码执行结构常常很有帮助。 比如此分层报告可用于确定在哪个调用链里调用了某个函数。

XHProf 对两次运行进行比较（又名 "diff" 报告），或者多次运行数据的合计。 对比、合并报告，很像针对单次运行的"平式视图"性能报告，就像"分层式视图"的性能报告。

更多额外文档可以在 » facebook xhprof 上找到。


需求

虽然不是必需的，xhprof 包含了一个用 PHP 写的用户界面。 它是一个用来保存分析后的数据、并用浏览器显示的实用办法。 因此一个启用了 PHP 的 web 服务器将使人更能体验到 xhprof 的用处。

在 » http://github.com/preinheimer/xhprof 也有一个 GUI 的分支。


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/xhprof


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Xhprof 配置选项
名字 | 默认 | 可修改范围 | 更新日志
xhprof.output_dir | "" | PHP_INI_ALL |

这是配置指令的简短说明。

xhprof.output_dir string

储存 XHProf 运行数据的默认目录，用于接口 iXHProfRuns(即 XHProfRuns_Default 类)。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

XHPROF_FLAGS_NO_BUILTINS (integer)
使得跳过所有内置（内部）函数。
XHPROF_FLAGS_CPU (integer)
使输出的性能数据中添加 CPU 数据。
XHPROF_FLAGS_MEMORY (integer)
使输出的性能数据中添加内存数据。


范例

Example #1 Xhprof 范例，可选使用图形界面

本示例启动并结束性能分析器，然后使用捆绑的用户界面来保存和解析结果。 换言之，扩展的代码在调用 xhprof_disable() 函数后结束。

<?php
xhprof_enable(XHPROF_FLAGS_CPU + XHPROF_FLAGS_MEMORY);

for ($i = 0; $i <= 1000; $i++) {
    $a = $i * $i;
}

$xhprof_data = xhprof_disable();

$XHPROF_ROOT = "/tools/xhprof/";
include_once $XHPROF_ROOT . "/xhprof_lib/utils/xhprof_lib.php";
include_once $XHPROF_ROOT . "/xhprof_lib/utils/xhprof_runs.php";

$xhprof_runs = new XHProfRuns_Default();
$run_id = $xhprof_runs->save_run($xhprof_data, "xhprof_testing");

echo "http://localhost/xhprof/xhprof_html/index.php?run={$run_id}&source=xhprof_testing\n";

?>

以上例程的输出类似于：

http://localhost/xhprof/xhprof_html/index.php?run=t11_4bdf44d21121f&source=xhprof_testing


Xhprof 函数

Table of Contents

  • xhprof_disable — 停止 xhprof 分析器
  • xhprof_enable — 启动 xhprof 性能分析器
  • xhprof_sample_disable — 停止 xhprof 性能采样分析器
  • xhprof_sample_enable — 以采样模式启动 XHProf 性能分析


停止 xhprof 分析器

  • ? Xhprof 函数
  • xhprof_enable ?
  • PHP Manual
  • Xhprof 函数
  • 停止 xhprof 分析器

xhprof_disable

(PECL xhprof >= 0.9.0)

xhprof_disable — 停止 xhprof 分析器

说明

xhprof_disable ( ) : array

停止性能分析，并返回此次运行的 xhprof 数据。

参数

此函数没有参数。

返回值

本次运行的 array 类型的 xhprof 数据。

范例

Example #1 xhprof_disable() 范例

<?php
xhprof_enable();

$foo = strlen("foo bar");

$xhprof_data = xhprof_disable();

print_r($xhprof_data);
?>

以上例程的输出类似于：

Array
(
    [main()==>strlen] => Array
        (
            [ct] => 1
            [wt] => 279
        )

    [main()==>xhprof_disable] => Array
        (
            [ct] => 1
            [wt] => 9
        )

    [main()] => Array
        (
            [ct] => 1
            [wt] => 610
        )

)


启动 xhprof 性能分析器

  • ? xhprof_disable
  • xhprof_sample_disable ?
  • PHP Manual
  • Xhprof 函数
  • 启动 xhprof 性能分析器

xhprof_enable

(PECL xhprof >= 0.9.0)

xhprof_enable — 启动 xhprof 性能分析器

说明

xhprof_enable ( int $flags = 0 , array $options = ? ) : void

启动 xhprof 进行性能分析。

参数

flags

分析添加额外信息的可选标记。 关于此标记的更多信息参见 XHprof 常量，例如， XHPROF_FLAGS_MEMORY 可以开启内存的分析。

options

array 的可选选项，就是通过传递 'ignored_functions' 选项来忽略性能分析中的某些函数。

返回值

null

更新日志

版本 | 说明
0.9.2 | 添加可选的 options 参数。

范例

Example #1 xhprof_enable() 范例

<?php
// 1. elapsed time + memory + CPU profiling; and ignore built-in (internal) functions
xhprof_enable(XHPROF_FLAGS_NO_BUILTINS | XHPROF_FLAGS_CPU | XHPROF_FLAGS_MEMORY);

// 2. elapsed time profiling; ignore call_user_func* during profiling
xhprof_enable(
    0,
    array('ignored_functions' =>  array('call_user_func',
                                        'call_user_func_array')));

// 3. elapsed time + memory profiling; ignore call_user_func* during profiling
xhprof_enable(
    XHPROF_FLAGS_MEMORY,
    array('ignored_functions' =>  array('call_user_func',
                                        'call_user_func_array')));
?>

参见

  • xhprof_disable() - 停止 xhprof 分析器
  • xhprof_sample_enable() - 以采样模式启动 XHProf 性能分析
  • memory_get_usage() - 返回分配给 PHP 的内存量
  • getrusage() - 获取当前资源使用状况


停止 xhprof 性能采样分析器

  • ? xhprof_enable
  • xhprof_sample_enable ?
  • PHP Manual
  • Xhprof 函数
  • 停止 xhprof 性能采样分析器

xhprof_sample_disable

(PECL xhprof >= 0.9.0)

xhprof_sample_disable — 停止 xhprof 性能采样分析器

说明

xhprof_sample_disable ( ) : array

停止采样模式的 xhprof 分析器。

参数

此函数没有参数。

返回值

本次运行的xhprof采样数据，array 类型。

范例

Example #1 xhprof_sample_disable() 范例

<?php
xhprof_sample_enable();

for ($i = 0; $i <= 10000; $i++) {
    $a = strlen($i);
    $b = $i * $a;
    $c = rand();
}

$xhprof_data = xhprof_sample_disable();

print_r($xhprof_data);
?>

以上例程的输出类似于：

Array
(
    [1272935300.800000] => main()
    [1272935300.900000] => main()
)


以采样模式启动 XHProf 性能分析

  • ? xhprof_sample_disable
  • Yac ?
  • PHP Manual
  • Xhprof 函数
  • 以采样模式启动 XHProf 性能分析

xhprof_sample_enable

(PECL xhprof >= 0.9.0)

xhprof_sample_enable — 以采样模式启动 XHProf 性能分析

说明

xhprof_sample_enable ( ) : void

xhprof_enable() 的更轻量的版本，以采样模式开始性能分析。 抽样的间隔为 0.1 秒，样本记录了完整的函数调用堆栈。 主要使用的情况是以较低的性能开销来进行性能监控和诊断。

参数

此函数没有参数。

返回值

null

参见

  • xhprof_sample_disable() - 停止 xhprof 性能采样分析器
  • xhprof_enable() - 启动 xhprof 性能分析器
  • memory_get_usage() - 返回分配给 PHP 的内存量
  • getrusage() - 获取当前资源使用状况


Yac

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Yac — The Yac class
    • Yac::add — Store into cache
    • Yac::__construct — Constructor
    • Yac::delete — Remove items from cache
    • Yac::dump — Dump cache
    • Yac::flush — Flush the cache
    • Yac::get — Retrieve values from cache
    • Yac::__get — Getter
    • Yac::info — Status of cache
    • Yac::set — Store into cache
    • Yac::__set — Setter


简介

Yac (Yet Another cache), is a lock-free, shared memory user data cache, could be used to replace APC, local memcache.


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/yac.

此扩展在 Windows 平台的二进制扩展 (DLL 文件) PECL 可以在 PECL 官方网站上下载。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Yac 配置选项
名字 | 默认 | 可修改范围 | 更新日志
yac.compress_threshold | -1 | PHP_INI_SYSTEM |
yac.debug | 0 | PHP_INI_ALL |
yac.enable | 1 | PHP_INI_SYSTEM |
yac.enable_cli | 0 | PHP_INI_SYSTEM |
yac.keys_memory_size | 4M | PHP_INI_SYSTEM |
yac.serializer | php | PHP_INI_SYSTEM |
yac.values_memory_size | 64M | PHP_INI_SYSTEM |

这是配置指令的简短说明。

yac.compress_threshold int

yac.debug int

yac.enable int

yac.enable_cli int

yac.keys_memory_size string

yac.serializer string

yac.values_memory_size string


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

YAC_VERSION (string)
YAC_MAX_KEY_LEN (int)
Max length of a key could be, it is 48 bytes.
YAC_MAX_VALUE_RAW_LEN (int)
YAC_MAX_RAW_COMPRESSED_LEN (int)
YAC_SERIALIZER_PHP (int)
Use php serialize as serializer
YAC_SERIALIZER_JSON (int)
Use json as serializer(requrie --enable-json)
YAC_SERIALIZER_IGBINARY (int)
Use igbinary as serializer(require --enable-igbinary)
YAC_SERIALIZER_MSGPACK (int)
Use msgpack as serializer(require --enable-msgpack)
YAC_SERIALIZER (string)
Which serialzier is yac used


The Yac class

(PECL yac >= 1.0.0)

简介

类摘要

Yac {
/* 属性 */
protected $_prefix ;
/* 方法 */
public __construct ( string $prefix = "" )
public add ( string $keys , mixed $value , int $ttl = 0 ) : bool
public add ( array $key_vals ) : bool
public delete ( string|array $keys , int $ttl = ? ) : bool
public dump ( int $$num ) : mixed
public flush ( ) : bool
public get ( string|array $key , int &$cas = null ) : mixed
public __get ( string $key ) : mixed
public info ( ) : array
public set ( string $keys , mixed $value , int $ttl = 0 ) : bool
public add ( array $key_vals ) : bool
public __set ( string $keys , mixed $value ) : mixed
}

属性

_prefix

Table of Contents

  • Yac::add — Store into cache
  • Yac::__construct — Constructor
  • Yac::delete — Remove items from cache
  • Yac::dump — Dump cache
  • Yac::flush — Flush the cache
  • Yac::get — Retrieve values from cache
  • Yac::__get — Getter
  • Yac::info — Status of cache
  • Yac::set — Store into cache
  • Yac::__set — Setter


Store into cache

  • ? Yac
  • Yac::__construct ?
  • PHP Manual
  • Yac
  • Store into cache

Yac::add

(PECL yac >= 1.0.0)

Yac::add — Store into cache

说明

public Yac::add ( string $keys , mixed $value , int $ttl = 0 ) : bool
public Yac::add ( array $key_vals ) : bool

Added a item into cache.

参数

keys

string key

value

mixed value, All php value type could be stored except 资源(resource)

ttl

expire time

返回值

bool, true on success, false on failure

Note:

Yac::add() may fail if cas lock could not obtain, so, if you need the value to be stored properly, you may write codes like:

Example #1 Make sure the item is stored

while(!$yac->set("key", "vale));


Constructor

  • ? Yac::add
  • Yac::delete ?
  • PHP Manual
  • Yac
  • Constructor

Yac::__construct

(PECL yac >= 1.0.0)

Yac::__construct — Constructor

说明

public Yac::__construct ( string $prefix = "" )

prefix is used to prepended to keys, this could be used to avoiding conflicts between apps.

参数

prefix

string prefix


Remove items from cache

  • ? Yac::__construct
  • Yac::dump ?
  • PHP Manual
  • Yac
  • Remove items from cache

Yac::delete

(PECL yac >= 1.0.0)

Yac::delete — Remove items from cache

说明

public Yac::delete ( string|array $keys , int $ttl = ? ) : bool

remove items from cache

参数

keys

string key, or array of multiple keys to be removed

ttl

if delay is set, delete will mark the items to be invalid in ttl second.

返回值


Dump cache

  • ? Yac::delete
  • Yac::flush ?
  • PHP Manual
  • Yac
  • Dump cache

Yac::dump

(PECL yac >= 1.0.0)

Yac::dump — Dump cache

说明

public Yac::dump ( int $$num ) : mixed

Dump values stored in cache

参数

num

Maximum number of items should be returned

返回值

mixed


Flush the cache

  • ? Yac::dump
  • Yac::get ?
  • PHP Manual
  • Yac
  • Flush the cache

Yac::flush

(PECL yac >= 1.0.0)

Yac::flush — Flush the cache

说明

public Yac::flush ( ) : bool

Remove all cached values

参数

此函数没有参数。

返回值

bool, always true


Retrieve values from cache

  • ? Yac::flush
  • Yac::__get ?
  • PHP Manual
  • Yac
  • Retrieve values from cache

Yac::get

(PECL yac >= 1.0.0)

Yac::get — Retrieve values from cache

说明

public Yac::get ( string|array $key , int &$cas = null ) : mixed

Retrieve values from cache

参数

key

string keys, or array of multiple keys.

cas

if not null, it will be set to the retrieved item's cas.

返回值

mixed on success, false on failure


Getter

  • ? Yac::get
  • Yac::info ?
  • PHP Manual
  • Yac
  • Getter

Yac::__get

(PECL yac >= 1.0.0)

Yac::__get — Getter

说明

public Yac::__get ( string $key ) : mixed

Retrieve values from cache

参数

key

string key

返回值

mixed on success, null on failure


Status of cache

  • ? Yac::__get
  • Yac::set ?
  • PHP Manual
  • Yac
  • Status of cache

Yac::info

(PECL yac >= 1.0.0)

Yac::info — Status of cache

说明

public Yac::info ( ) : array

Get status of cache system

参数

此函数没有参数。

返回值

Return an array, consistent with: "memory_size", "slots_memory_size", "values_memory_size", "segment_size", "segment_num", "miss", "hits", "fails", "kicks", "recycles", "slots_size", "slots_used"


Store into cache

  • ? Yac::info
  • Yac::__set ?
  • PHP Manual
  • Yac
  • Store into cache

Yac::set

(PECL yac >= 1.0.0)

Yac::set — Store into cache

说明

public Yac::set ( string $keys , mixed $value , int $ttl = 0 ) : bool
public Yac::add ( array $key_vals ) : bool

Add a item into cache, it the key is already exists, override it.

参数

keys

string key

value

mixed value, All php value type could be stored except 资源(resource)

ttl

expire time

返回值

the value self


Setter

  • ? Yac::set
  • 音频格式操作 ?
  • PHP Manual
  • Yac
  • Setter

Yac::__set

(PECL yac >= 1.0.0)

Yac::__set — Setter

说明

public Yac::__set ( string $keys , mixed $value ) : mixed

store a item into cache

参数

keys

string key

value

mixed value, All php value type could be stored except 资源(resource)

返回值

Always return the value self


音频格式操作

  • OpenAL — OpenAL Audio Bindings
    • 简介
    • 安装／配置
    • 预定义常量
    • OpenAL 函数


OpenAL Audio Bindings

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • OpenAL 函数
    • openal_buffer_create — Generate OpenAL buffer
    • openal_buffer_data — Load a buffer with data
    • openal_buffer_destroy — Destroys an OpenAL buffer
    • openal_buffer_get — Retrieve an OpenAL buffer property
    • openal_buffer_loadwav — Load a .wav file into a buffer
    • openal_context_create — Create an audio processing context
    • openal_context_current — Make the specified context current
    • openal_context_destroy — Destroys a context
    • openal_context_process — Process the specified context
    • openal_context_suspend — Suspend the specified context
    • openal_device_close — Close an OpenAL device
    • openal_device_open — Initialize the OpenAL audio layer
    • openal_listener_get — Retrieve a listener property
    • openal_listener_set — Set a listener property
    • openal_source_create — Generate a source resource
    • openal_source_destroy — Destroy a source resource
    • openal_source_get — Retrieve an OpenAL source property
    • openal_source_pause — Pause the source
    • openal_source_play — Start playing the source
    • openal_source_rewind — Rewind the source
    • openal_source_set — Set source property
    • openal_source_stop — Stop playing the source
    • openal_stream — Begin streaming on a source


简介

Platform independent audio bindings. Requires the » OpenAL library.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/openal.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


  • ? 安装
  • 资源类型 ?
  • PHP Manual
  • 安装／配置
  • 运行时配置

运行时配置

此扩展没有在 php.ini 中定义配置指令。


资源类型

This extension defines four resource types:
Open AL(Device) - Returned by openal_device_open(),
Open AL(Context) - Returned by openal_context_create(),
Open AL(Buffer) - Returned by openal_buffer_create(),
and Open AL(Source) - Returned by openal_source_create().


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

ALC_FREQUENCY (int)
Context Attribute
ALC_REFRESH (int)
Context Attribute
ALC_SYNC (int)
Context Attribute
AL_FREQUENCY (int)
Buffer Setting
AL_BITS (int)
Buffer Setting
AL_CHANNELS (int)
Buffer Setting
AL_SIZE (int)
Buffer Setting
AL_BUFFER (int)
Source/Listener Setting (Integer)
AL_SOURCE_RELATIVE (int)
Source/Listener Setting (Integer)
AL_SOURCE_STATE (int)
Source/Listener Setting (Integer)
AL_PITCH (int)
Source/Listener Setting (Float)
AL_GAIN (int)
Source/Listener Setting (Float)
AL_MIN_GAIN (int)
Source/Listener Setting (Float)
AL_MAX_GAIN (int)
Source/Listener Setting (Float)
AL_MAX_DISTANCE (int)
Source/Listener Setting (Float)
AL_ROLLOFF_FACTOR (int)
Source/Listener Setting (Float)
AL_CONE_OUTER_GAIN (int)
Source/Listener Setting (Float)
AL_CONE_INNER_ANGLE (int)
Source/Listener Setting (Float)
AL_CONE_OUTER_ANGLE (int)
Source/Listener Setting (Float)
AL_REFERENCE_DISTANCE (int)
Source/Listener Setting (Float)
AL_POSITION (int)
Source/Listener Setting (Float Vector)
AL_VELOCITY (int)
Source/Listener Setting (Float Vector)
AL_DIRECTION (int)
Source/Listener Setting (Float Vector)
AL_ORIENTATION (int)
Source/Listener Setting (Float Vector)
AL_FORMAT_MONO8 (int)
PCM Format
AL_FORMAT_MONO16 (int)
PCM Format
AL_FORMAT_STEREO8 (int)
PCM Format
AL_FORMAT_STEREO16 (int)
PCM Format
AL_INITIAL (int)
Source State
AL_PLAYING (int)
Source State
AL_PAUSED (int)
Source State
AL_STOPPED (int)
Source State
AL_LOOPING (int)
Source State
AL_TRUE (int)
Boolean value recognized by OpenAL
AL_FALSE (int)
Boolean value recognized by OpenAL


OpenAL 函数

Table of Contents

  • openal_buffer_create — Generate OpenAL buffer
  • openal_buffer_data — Load a buffer with data
  • openal_buffer_destroy — Destroys an OpenAL buffer
  • openal_buffer_get — Retrieve an OpenAL buffer property
  • openal_buffer_loadwav — Load a .wav file into a buffer
  • openal_context_create — Create an audio processing context
  • openal_context_current — Make the specified context current
  • openal_context_destroy — Destroys a context
  • openal_context_process — Process the specified context
  • openal_context_suspend — Suspend the specified context
  • openal_device_close — Close an OpenAL device
  • openal_device_open — Initialize the OpenAL audio layer
  • openal_listener_get — Retrieve a listener property
  • openal_listener_set — Set a listener property
  • openal_source_create — Generate a source resource
  • openal_source_destroy — Destroy a source resource
  • openal_source_get — Retrieve an OpenAL source property
  • openal_source_pause — Pause the source
  • openal_source_play — Start playing the source
  • openal_source_rewind — Rewind the source
  • openal_source_set — Set source property
  • openal_source_stop — Stop playing the source
  • openal_stream — Begin streaming on a source


Generate OpenAL buffer

  • ? OpenAL 函数
  • openal_buffer_data ?
  • PHP Manual
  • OpenAL 函数
  • Generate OpenAL buffer

openal_buffer_create

(PECL openal >= 0.1.0)

openal_buffer_create — Generate OpenAL buffer

说明

openal_buffer_create ( ) : resource

返回值

Returns an Open AL(Buffer) resource on success or false on failure.

参见

  • openal_buffer_loadwav() - Load a .wav file into a buffer
  • openal_buffer_data() - Load a buffer with data


Load a buffer with data

  • ? openal_buffer_create
  • openal_buffer_destroy ?
  • PHP Manual
  • OpenAL 函数
  • Load a buffer with data

openal_buffer_data

(PECL openal >= 0.1.0)

openal_buffer_data — Load a buffer with data

说明

openal_buffer_data ( resource $buffer , int $format , string $data , int $freq ) : bool

参数

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

format

Format of data, one of: AL_FORMAT_MONO8, AL_FORMAT_MONO16, AL_FORMAT_STEREO8 和 AL_FORMAT_STEREO16

data

Block of binary audio data in the format and freq specified.

freq

Frequency of data given in Hz.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_buffer_loadwav() - Load a .wav file into a buffer
  • openal_stream() - Begin streaming on a source


Destroys an OpenAL buffer

  • ? openal_buffer_data
  • openal_buffer_get ?
  • PHP Manual
  • OpenAL 函数
  • Destroys an OpenAL buffer

openal_buffer_destroy

(PECL openal >= 0.1.0)

openal_buffer_destroy — Destroys an OpenAL buffer

说明

openal_buffer_destroy ( resource $buffer ) : bool

参数

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_buffer_create() - Generate OpenAL buffer


Retrieve an OpenAL buffer property

  • ? openal_buffer_destroy
  • openal_buffer_loadwav ?
  • PHP Manual
  • OpenAL 函数
  • Retrieve an OpenAL buffer property

openal_buffer_get

(PECL openal >= 0.1.0)

openal_buffer_get — Retrieve an OpenAL buffer property

说明

openal_buffer_get ( resource $buffer , int $property ) : int|false

参数

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

property

Specific property, one of: AL_FREQUENCY, AL_BITS, AL_CHANNELS 和 AL_SIZE.

返回值

Returns an integer value appropriate to the property requested 或者在失败时返回 false.

参见

  • openal_buffer_create() - Generate OpenAL buffer


Load a .wav file into a buffer

  • ? openal_buffer_get
  • openal_context_create ?
  • PHP Manual
  • OpenAL 函数
  • Load a .wav file into a buffer

openal_buffer_loadwav

(PECL openal >= 0.1.0)

openal_buffer_loadwav — Load a .wav file into a buffer

说明

openal_buffer_loadwav ( resource $buffer , string $wavfile ) : bool

参数

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

wavfile

Path to .wav file on local file system.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_buffer_data() - Load a buffer with data
  • openal_stream() - Begin streaming on a source


Create an audio processing context

  • ? openal_buffer_loadwav
  • openal_context_current ?
  • PHP Manual
  • OpenAL 函数
  • Create an audio processing context

openal_context_create

(PECL openal >= 0.1.0)

openal_context_create — Create an audio processing context

说明

openal_context_create ( resource $device ) : resource

参数

device

An Open AL(Device) resource (previously created by openal_device_open()).

返回值

Returns an Open AL(Context) resource on success or false on failure.

参见

  • openal_device_open() - Initialize the OpenAL audio layer
  • openal_context_destroy() - Destroys a context


Make the specified context current

  • ? openal_context_create
  • openal_context_destroy ?
  • PHP Manual
  • OpenAL 函数
  • Make the specified context current

openal_context_current

(PECL openal >= 0.1.0)

openal_context_current — Make the specified context current

说明

openal_context_current ( resource $context ) : bool

参数

context

An Open AL(Context) resource (previously created by openal_context_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_context_create() - Create an audio processing context


Destroys a context

  • ? openal_context_current
  • openal_context_process ?
  • PHP Manual
  • OpenAL 函数
  • Destroys a context

openal_context_destroy

(PECL openal >= 0.1.0)

openal_context_destroy — Destroys a context

说明

openal_context_destroy ( resource $context ) : bool

参数

context

An Open AL(Context) resource (previously created by openal_context_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_context_create() - Create an audio processing context


Process the specified context

  • ? openal_context_destroy
  • openal_context_suspend ?
  • PHP Manual
  • OpenAL 函数
  • Process the specified context

openal_context_process

(PECL openal >= 0.1.0)

openal_context_process — Process the specified context

说明

openal_context_process ( resource $context ) : bool

参数

context

An Open AL(Context) resource (previously created by openal_context_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_context_create() - Create an audio processing context
  • openal_context_current() - Make the specified context current
  • openal_context_suspend() - Suspend the specified context


Suspend the specified context

  • ? openal_context_process
  • openal_device_close ?
  • PHP Manual
  • OpenAL 函数
  • Suspend the specified context

openal_context_suspend

(PECL openal >= 0.1.0)

openal_context_suspend — Suspend the specified context

说明

openal_context_suspend ( resource $context ) : bool

参数

context

An Open AL(Context) resource (previously created by openal_context_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_context_create() - Create an audio processing context
  • openal_context_current() - Make the specified context current
  • openal_context_process() - Process the specified context


Close an OpenAL device

  • ? openal_context_suspend
  • openal_device_open ?
  • PHP Manual
  • OpenAL 函数
  • Close an OpenAL device

openal_device_close

(PECL openal >= 0.1.0)

openal_device_close — Close an OpenAL device

说明

openal_device_close ( resource $device ) : bool

参数

device

An Open AL(Device) resource (previously created by openal_device_open()) to be closed.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_device_open() - Initialize the OpenAL audio layer


Initialize the OpenAL audio layer

  • ? openal_device_close
  • openal_listener_get ?
  • PHP Manual
  • OpenAL 函数
  • Initialize the OpenAL audio layer

openal_device_open

(PECL openal >= 0.1.0)

openal_device_open — Initialize the OpenAL audio layer

说明

openal_device_open ( string $device_desc = ? ) : resource

参数

device_desc

Open an audio device optionally specified by device_desc. If device_desc is not specified the first available audio device will be used.

返回值

Returns an Open AL(Device) resource on success or false on failure.

参见

  • openal_device_close() - Close an OpenAL device
  • openal_context_create() - Create an audio processing context


Retrieve a listener property

  • ? openal_device_open
  • openal_listener_set ?
  • PHP Manual
  • OpenAL 函数
  • Retrieve a listener property

openal_listener_get

(PECL openal >= 0.1.0)

openal_listener_get — Retrieve a listener property

说明

openal_listener_get ( int $property ) : mixed

参数

property

Property to retrieve, one of:
AL_GAIN (float),
AL_POSITION (array(float,float,float)),
AL_VELOCITY (array(float,float,float)) 和
AL_ORIENTATION (array(float,float,float)).

返回值

Returns a float or array of floats (as appropriate) 或者在失败时返回 false.

参见

  • openal_listener_set() - Set a listener property


Set a listener property

  • ? openal_listener_get
  • openal_source_create ?
  • PHP Manual
  • OpenAL 函数
  • Set a listener property

openal_listener_set

(PECL openal >= 0.1.0)

openal_listener_set — Set a listener property

说明

openal_listener_set ( int $property , mixed $setting ) : bool

参数

property

Property to set, one of:
AL_GAIN (float),
AL_POSITION (array(float,float,float)),
AL_VELOCITY (array(float,float,float)) 和
AL_ORIENTATION (array(float,float,float)).

setting

Value to set, either float, or an array of floats as appropriate.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_listener_get() - Retrieve a listener property


Generate a source resource

  • ? openal_listener_set
  • openal_source_destroy ?
  • PHP Manual
  • OpenAL 函数
  • Generate a source resource

openal_source_create

(PECL openal >= 0.1.0)

openal_source_create — Generate a source resource

说明

openal_source_create ( ) : resource

返回值

Returns an Open AL(Source) resource on success or false on failure.

参见

  • openal_source_set() - Set source property
  • openal_source_play() - Start playing the source
  • openal_source_destroy() - Destroy a source resource


Destroy a source resource

  • ? openal_source_create
  • openal_source_get ?
  • PHP Manual
  • OpenAL 函数
  • Destroy a source resource

openal_source_destroy

(PECL openal >= 0.1.0)

openal_source_destroy — Destroy a source resource

说明

openal_source_destroy ( resource $source ) : bool

参数

source

An Open AL(Source) resource (previously created by openal_source_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_source_create() - Generate a source resource


Retrieve an OpenAL source property

  • ? openal_source_destroy
  • openal_source_pause ?
  • PHP Manual
  • OpenAL 函数
  • Retrieve an OpenAL source property

openal_source_get

(PECL openal >= 0.1.0)

openal_source_get — Retrieve an OpenAL source property

说明

openal_source_get ( resource $source , int $property ) : mixed

参数

source

An Open AL(Source) resource (previously created by openal_source_create()).

property

Property to get, one of: AL_SOURCE_RELATIVE (int), AL_SOURCE_STATE (int), AL_PITCH (float), AL_GAIN (float), AL_MIN_GAIN (float), AL_MAX_GAIN (float), AL_MAX_DISTANCE (float), AL_ROLLOFF_FACTOR (float), AL_CONE_OUTER_GAIN (float), AL_CONE_INNER_ANGLE (float), AL_CONE_OUTER_ANGLE (float), AL_REFERENCE_DISTANCE (float), AL_POSITION (array(float,float,float)), AL_VELOCITY (array(float,float,float)), AL_DIRECTION (array(float,float,float)).

返回值

Returns the type associated with the property being retrieved 或者在失败时返回 false.

参见

  • openal_source_create() - Generate a source resource
  • openal_source_set() - Set source property
  • openal_source_play() - Start playing the source


Pause the source

  • ? openal_source_get
  • openal_source_play ?
  • PHP Manual
  • OpenAL 函数
  • Pause the source

openal_source_pause

(PECL openal >= 0.1.0)

openal_source_pause — Pause the source

说明

openal_source_pause ( resource $source ) : bool

参数

source

An Open AL(Source) resource (previously created by openal_source_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_source_stop() - Stop playing the source
  • openal_source_play() - Start playing the source
  • openal_source_rewind() - Rewind the source


Start playing the source

  • ? openal_source_pause
  • openal_source_rewind ?
  • PHP Manual
  • OpenAL 函数
  • Start playing the source

openal_source_play

(PECL openal >= 0.1.0)

openal_source_play — Start playing the source

说明

openal_source_play ( resource $source ) : bool

参数

source

An Open AL(Source) resource (previously created by openal_source_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_source_stop() - Stop playing the source
  • openal_source_pause() - Pause the source
  • openal_source_rewind() - Rewind the source


Rewind the source

  • ? openal_source_play
  • openal_source_set ?
  • PHP Manual
  • OpenAL 函数
  • Rewind the source

openal_source_rewind

(PECL openal >= 0.1.0)

openal_source_rewind — Rewind the source

说明

openal_source_rewind ( resource $source ) : bool

参数

source

An Open AL(Source) resource (previously created by openal_source_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_source_stop() - Stop playing the source
  • openal_source_pause() - Pause the source
  • openal_source_play() - Start playing the source


Set source property

  • ? openal_source_rewind
  • openal_source_stop ?
  • PHP Manual
  • OpenAL 函数
  • Set source property

openal_source_set

(PECL openal >= 0.1.0)

openal_source_set — Set source property

说明

openal_source_set ( resource $source , int $property , mixed $setting ) : bool

参数

source

An Open AL(Source) resource (previously created by openal_source_create()).

property

Property to set, one of: AL_BUFFER (OpenAL(Source)), AL_LOOPING (bool), AL_SOURCE_RELATIVE (int), AL_SOURCE_STATE (int), AL_PITCH (float), AL_GAIN (float), AL_MIN_GAIN (float), AL_MAX_GAIN (float), AL_MAX_DISTANCE (float), AL_ROLLOFF_FACTOR (float), AL_CONE_OUTER_GAIN (float), AL_CONE_INNER_ANGLE (float), AL_CONE_OUTER_ANGLE (float), AL_REFERENCE_DISTANCE (float), AL_POSITION (array(float,float,float)), AL_VELOCITY (array(float,float,float)), AL_DIRECTION (array(float,float,float)).

setting

Value to assign to specified property. Refer to the description of property for a description of the value(s) expected.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_source_create() - Generate a source resource
  • openal_source_get() - Retrieve an OpenAL source property
  • openal_source_play() - Start playing the source


Stop playing the source

  • ? openal_source_set
  • openal_stream ?
  • PHP Manual
  • OpenAL 函数
  • Stop playing the source

openal_source_stop

(PECL openal >= 0.1.0)

openal_source_stop — Stop playing the source

说明

openal_source_stop ( resource $source ) : bool

参数

source

An Open AL(Source) resource (previously created by openal_source_create()).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openal_source_play() - Start playing the source
  • openal_source_pause() - Pause the source
  • openal_source_rewind() - Rewind the source


Begin streaming on a source

  • ? openal_source_stop
  • 身份认证服务 ?
  • PHP Manual
  • OpenAL 函数
  • Begin streaming on a source

openal_stream

(PECL openal >= 0.1.0)

openal_stream — Begin streaming on a source

说明

openal_stream ( resource $source , int $format , int $rate ) : resource|false

参数

source

An Open AL(Source) resource (previously created by openal_source_create()).

format

Format of data, one of: AL_FORMAT_MONO8, AL_FORMAT_MONO16, AL_FORMAT_STEREO8 和 AL_FORMAT_STEREO16

rate

Frequency of data to stream given in Hz.

返回值

Returns a stream resource on success 或者在失败时返回 false.

参见

  • openal_source_create() - Generate a source resource
  • fwrite() - 写入文件（可安全用于二进制文件）


身份认证服务

  • Radius
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Radius 函数


Radius

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
    • RADIUS Options
    • RADIUS Packet Types
    • RADIUS Attribute Types
    • RADIUS Vendor Specific Attribute Types
  • 范例
  • Radius 函数
    • radius_acct_open — Creates a Radius handle for accounting
    • radius_add_server — Adds a server
    • radius_auth_open — Creates a Radius handle for authentication
    • radius_close — Frees all ressources
    • radius_config — Causes the library to read the given configuration file
    • radius_create_request — Create accounting or authentication request
    • radius_cvt_addr — Converts raw data to IP-Address
    • radius_cvt_int — Converts raw data to integer
    • radius_cvt_string — Converts raw data to string
    • radius_demangle_mppe_key — Derives mppe-keys from mangled data
    • radius_demangle — Demangles data
    • radius_get_attr — Extracts an attribute
    • radius_get_tagged_attr_data — Extracts the data from a tagged attribute
    • radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute
    • radius_get_vendor_attr — Extracts a vendor specific attribute
    • radius_put_addr — Attaches an IP address attribute
    • radius_put_attr — Attaches a binary attribute
    • radius_put_int — Attaches an integer attribute
    • radius_put_string — Attaches a string attribute
    • radius_put_vendor_addr — Attaches a vendor specific IP address attribute
    • radius_put_vendor_attr — Attaches a vendor specific binary attribute
    • radius_put_vendor_int — Attaches a vendor specific integer attribute
    • radius_put_vendor_string — Attaches a vendor specific string attribute
    • radius_request_authenticator — Returns the request authenticator
    • radius_salt_encrypt_attr — Salt-encrypts a value
    • radius_send_request — Sends the request and waits for a reply
    • radius_server_secret — Returns the shared secret
    • radius_strerror — Returns an error message


简介

This package is based on the libradius (Remote Authentication Dial In User Service) of FreeBSD. It allows clients to perform authentication and accounting by means of network requests to remote servers.

This PECL extension adds full support for Radius Authentication (» RFC 2865) and Radius Accounting (» RFC 2866). This package is available for Unix (tested on FreeBSD and Linux) and for Windows.

Note:

An exact description for libradius can be found » here. A detailed description of the configuration file can be found » here.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/radius.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


预定义常量

Table of Contents

  • RADIUS Options
  • RADIUS Packet Types
  • RADIUS Attribute Types
  • RADIUS Vendor Specific Attribute Types

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

RADIUS_MPPE_KEY_LEN (int)
The maximum length of MPPE keys.


RADIUS Options

Several RADIUS functions accept option flags as bitmasks. The constants representing those flags are listed below.

RADIUS_OPTION_SALT (int)

When set, this option will result in the attribute value being salt-encrypted.

RADIUS_OPTION_TAGGED (int)

When set, this option will result in the attribute value being tagged with the value of the tag parameter.


RADIUS Packet Types

RADIUS packets, whether requests or responses, always include a type. These constants are provided to make it easier to specify types when using radius_create_request() and when comparing the result of radius_send_request().

RADIUS_ACCESS_REQUEST (int)

An Access-Request, used to authenticate a user against a RADIUS server. Access request packets must include a RADIUS_NAS_IP_ADDRESS or a RADIUS_NAS_IDENTIFIER attribute, must also include a RADIUS_USER_PASSWORD, RADIUS_CHAP_PASSWORD or a RADIUS_STATE attribute, and should include a RADIUS_USER_NAME attribute.

RADIUS_ACCESS_ACCEPT (int)

An Access-Accept response to an Access-Request indicating that the RADIUS server authenticated the user successfully.

RADIUS_ACCESS_REJECT (int)

An Access-Reject response to an Access-Request indicating that the RADIUS server could not authenticate the user.

RADIUS_ACCESS_CHALLENGE (int)

An Access-Challenge response to an Access-Request indicating that the RADIUS server requires further information in another Access-Request before authenticating the user.

RADIUS_ACCOUNTING_REQUEST (int)

An Accounting-Request, used to convey accounting information for a service to the RADIUS server.

RADIUS_ACCOUNTING_RESPONSE (int)

An Accounting-Response response to an Accounting-Request.

RADIUS_COA_REQUEST (int)

A CoA-Request, sent from the RADIUS server to indicate that the authorisations within the user session have changed. A response must be sent in the form of a CoA-ACK or a CoA-NAK.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_COA_ACK (int)

A CoA-ACK, sent to the RADIUS server to indicate that the user authorisations have been updated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_COA_NAK (int)

A CoA-NAK, sent to the RADIUS server to indicate that the user authorisations could not be updated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_REQUEST (int)

A Disconnect-Request, sent from the RADIUS server to indicate that the user session must be terminated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_ACK (int)

A Disconnect-ACK, sent to the RADIUS server to indicate that the user session has been terminated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_NAK (int)

A Disconnect-NAK, sent to the RADIUS server to indicate that the user session could not be terminated.

This constant is available in PECL radius 1.3.0 and later.


RADIUS Attribute Types

These constants define RADIUS attribute types that can be used with
radius_put_addr(), radius_put_attr(),
radius_put_int() and
radius_put_string().

RADIUS_USER_NAME (int)

The User-Name attribute. The attribute value is expected to be a string containing the name of the user being authenticated, and can be set using radius_put_attr().

RADIUS_USER_PASSWORD (int)

The User-Password attribute. The attribute value is expected to be a string containing the user's password, and can be set using radius_put_attr(). This value will be obfuscated on transmission as described in » section 5.2 of RFC 2865.

RADIUS_CHAP_PASSWORD (int)

The Chap-Password attribute. The attribute value is expected to be a string with the first byte containing the CHAP identifier, and the subsequent 16 bytes containing the MD5 hash of the CHAP identifier, the plaintext password and the CHAP challenge value concatenated together. Note that the CHAP challenge value should also be sent separately in a RADIUS_CHAP_CHALLENGE attribute.

Example #1 Using CHAP passwords

<?php
// Firstly, we'll create an authentication handle and request.
$radh = radius_auth_open();
radius_add_server($radh, $server, $port, $secret, 3, 3);
radius_create_request($radh, RADIUS_ACCESS_REQUEST);

// Assuming $password contains the plaintext password, we now:

// Generate a challenge.
$challenge = mt_rand();

// Specify a CHAP identifier.
$ident = 1;

// Add the Chap-Password attribute.
$cp = md5(pack('Ca*', $ident, $password.$challenge), true);
radius_put_attr($radh, RADIUS_CHAP_PASSWORD, pack('C', $ident).$cp);

// Add the Chap-Challenge attribute.
radius_put_attr($radh, RADIUS_CHAP_CHALLENGE, $challenge);

/* From here, you would add the remaining attributes and
 * call radius_send_request(). */
?>

RADIUS_NAS_IP_ADDRESS (int)

The NAS-IP-Address attribute. The attribute value is expected to the IP address of the RADIUS client encoded as an int, which can be set using radius_put_addr().

RADIUS_NAS_PORT (int)

The NAS-Port attribute. The attribute value is expected to be the physical port of the user on the RADIUS client encoded as an int, which can be set using radius_put_int().

RADIUS_SERVICE_TYPE (int)

The Service-Type attribute. The attribute value indicates the service type the user is requesting, and is expected to be an int, which can be set using radius_put_int().

A number of constants are provided to represent the possible values of this attribute. They include:

  • RADIUS_LOGIN
  • RADIUS_FRAMED
  • RADIUS_CALLBACK_LOGIN
  • RADIUS_CALLBACK_FRAMED
  • RADIUS_OUTBOUND
  • RADIUS_ADMINISTRATIVE
  • RADIUS_NAS_PROMPT
  • RADIUS_AUTHENTICATE_ONLY
  • RADIUS_CALLBACK_NAS_PROMPT

RADIUS_FRAMED_PROTOCOL (int)

The Framed-Protocol attribute. The attribute value is expected to be an int indicating the framing to be used for framed access, and can be set using radius_put_int(). The possible attribute values include these constants:

  • RADIUS_PPP
  • RADIUS_SLIP
  • RADIUS_ARAP
  • RADIUS_GANDALF
  • RADIUS_XYLOGICS

RADIUS_FRAMED_IP_ADDRESS (int)

The Framed-IP-Address attribute. The attribute value is expected to be the address of the user's network encoded as an int, which can be set using radius_put_addr() and retrieved using radius_cvt_addr().

RADIUS_FRAMED_IP_NETMASK (int)

The Framed-IP-Netmask attribute. The attribute value is expected to be the netmask of the user's network encoded as an int, which can be set using radius_put_addr() and retrieved using radius_cvt_addr().

RADIUS_FRAMED_ROUTING (int)

The Framed-Routing attribute. The attribute value is expected to be an int indicating the routing method for the user, which can be set using radius_put_int().

Possible values include:

  • 0: No routing
  • 1: Send routing packets
  • 2: Listen for routing packets
  • 3: Send and listen

RADIUS_FILTER_ID (int)

The Filter-ID attribute. The attribute value is expected to be an implementation-specific, human-readable string of filters, which can be set using radius_put_attr().

RADIUS_FRAMED_MTU (int)

The Framed-MTU attribute. The attribute value is expected to be an int indicating the MTU to be configured for the user, and can be set using radius_put_int().

RADIUS_FRAMED_COMPRESSION (int)

The Framed-Compression attribute. The attribute value is expected to be an int indicating the compression protocol to be used, and can be set using radius_put_int(). Possible values include these constants:

  • RADIUS_COMP_NONE: No compression
  • RADIUS_COMP_VJ: VJ TCP/IP header compression
  • RADIUS_COMP_IPXHDR: IPX header compression
  • RADIUS_COMP_STAC_LZS: Stac-LZS compression (added in PECL radius 1.3.0b2)

RADIUS_LOGIN_IP_HOST (int)

The Login-IP-Host attribute. The attribute value is expected to the IP address to connect the user to, encoded as an int, which can be set using radius_put_addr().

RADIUS_LOGIN_SERVICE (int)

The Login-Service attribute. The attribute value is an int indicating the service to connect the user to on the login host. The value can be converted to a PHP integer via radius_cvt_int().

RADIUS_LOGIN_TCP_PORT (int)

The Login-TCP-Port attribute. The attribute value is an int indicating the port to connect the user to on the login host. The value can be converted to a PHP integer via radius_cvt_int().

RADIUS_REPLY_MESSAGE (int)

The Reply-Message attribute. The attribute value is a string containing text that may be displayed to the user in response to an access request.

RADIUS_CALLBACK_NUMBER (int)

The Callback-Number attribute. The attribute value is a string containing the dialing string to use for callback.

RADIUS_CALLBACK_ID (int)

The Callback-Id attribute. The attribute value is a string containing an implementation-specific name of the place to be called.

RADIUS_FRAMED_ROUTE (int)

The Framed-Route attribute. The attribute value is a string containing an implementation-specific set of routes to be configured for the user.

RADIUS_FRAMED_IPX_NETWORK (int)

The Framed-IPX-Network attribute. The attribute value is an int containing the IPX network to be configured for the user, or 0xFFFFFFFE to indicate that the RADIUS client should select the network, and can be accessed via radius_cvt_int().

RADIUS_STATE (int)

The State attribute. The attribute value is an implementation-defined string included in an Access-Challenge from a server that must be included in the subsequent Access-Request, and can be set using radius_put_attr().

RADIUS_CLASS (int)

The Class attribute. The attribute value is an arbitrary string included in an Access-Accept message that should then be sent to the accounting server in Accounting-Request messages, and can be set using radius_put_attr().

RADIUS_VENDOR_SPECIFIC (int)

The Vendor-Specific attribute. In general, vendor attribute values
should be set using radius_put_vendor_addr(),
radius_put_vendor_attr(),
radius_put_vendor_int() and
radius_put_vendor_string(), rather than directly.

This constant is mostly useful when interpreting vendor specific attributes in responses from a RADIUS server; when a vendor specific attribute is received, the radius_get_vendor_attr() function should be used to access the vendor ID, attribute type and attribute value.

RADIUS_SESSION_TIMEOUT (int)

Session timeout

RADIUS_IDLE_TIMEOUT (int)

Idle timeout

RADIUS_TERMINATION_ACTION (int)

Termination action

RADIUS_CALLED_STATION_ID (int)

Called Station Id

RADIUS_CALLING_STATION_ID (int)

Calling Station Id

RADIUS_NAS_IDENTIFIER (int)

NAS ID

RADIUS_PROXY_STATE (int)

Proxy State

RADIUS_LOGIN_LAT_SERVICE (int)

Login LAT Service

RADIUS_LOGIN_LAT_NODE (int)

Login LAT Node

RADIUS_LOGIN_LAT_GROUP (int)

Login LAT Group

RADIUS_FRAMED_APPLETALK_LINK (int)

Framed Appletalk Link

RADIUS_FRAMED_APPLETALK_NETWORK (int)

Framed Appletalk Network

RADIUS_FRAMED_APPLETALK_ZONE (int)

Framed Appletalk Zone

RADIUS_CHAP_CHALLENGE (int)

Challenge

RADIUS_NAS_PORT_TYPE (int)

NAS port type, one of:

  • RADIUS_ASYNC
  • RADIUS_SYNC
  • RADIUS_ISDN_SYNC
  • RADIUS_ISDN_ASYNC_V120
  • RADIUS_ISDN_ASYNC_V110
  • RADIUS_VIRTUAL
  • RADIUS_PIAFS
  • RADIUS_HDLC_CLEAR_CHANNEL
  • RADIUS_X_25
  • RADIUS_X_75
  • RADIUS_G_3_FAX
  • RADIUS_SDSL
  • RADIUS_ADSL_CAP
  • RADIUS_ADSL_DMT
  • RADIUS_IDSL
  • RADIUS_ETHERNET
  • RADIUS_XDSL
  • RADIUS_CABLE
  • RADIUS_WIRELESS_OTHER
  • RADIUS_WIRELESS_IEEE_802_11

RADIUS_PORT_LIMIT (int)

Port Limit

RADIUS_LOGIN_LAT_PORT (int)

Login LAT Port

RADIUS_CONNECT_INFO (int)

Connect info

RADIUS_ACCT_STATUS_TYPE (int)

Accounting status type, one of:

  • RADIUS_START
  • RADIUS_STOP
  • RADIUS_ACCOUNTING_ON
  • RADIUS_ACCOUNTING_OFF

RADIUS_ACCT_DELAY_TIME (int)

Accounting delay time

RADIUS_ACCT_INPUT_OCTETS (int)

Accounting input bytes

RADIUS_ACCT_OUTPUT_OCTETS (int)

Accounting output bytes

RADIUS_ACCT_SESSION_ID (int)

Accounting session ID

RADIUS_ACCT_AUTHENTIC (int)

Accounting authentic, one of:

  • RADIUS_AUTH_RADIUS
  • RADIUS_AUTH_LOCAL
  • RADIUS_AUTH_REMOTE

RADIUS_ACCT_SESSION_TIME (int)

Accounting session time

RADIUS_ACCT_INPUT_PACKETS (int)

Accounting input packets

RADIUS_ACCT_OUTPUT_PACKETS (int)

Accounting output packets

RADIUS_ACCT_TERMINATE_CAUSE (int)

Accounting terminate cause, one of:

  • RADIUS_TERM_USER_REQUEST
  • RADIUS_TERM_LOST_CARRIER
  • RADIUS_TERM_LOST_SERVICE
  • RADIUS_TERM_IDLE_TIMEOUT
  • RADIUS_TERM_SESSION_TIMEOUT
  • RADIUS_TERM_ADMIN_RESET
  • RADIUS_TERM_ADMIN_REBOOT
  • RADIUS_TERM_PORT_ERROR
  • RADIUS_TERM_NAS_ERROR
  • RADIUS_TERM_NAS_REQUEST
  • RADIUS_TERM_NAS_REBOOT
  • RADIUS_TERM_PORT_UNNEEDED
  • RADIUS_TERM_PORT_PREEMPTED
  • RADIUS_TERM_PORT_SUSPENDED
  • RADIUS_TERM_SERVICE_UNAVAILABLE
  • RADIUS_TERM_CALLBACK
  • RADIUS_TERM_USER_ERROR
  • RADIUS_TERM_HOST_REQUEST

RADIUS_ACCT_MULTI_SESSION_ID (int)

Accounting multi session ID

RADIUS_ACCT_LINK_COUNT (int)

Accounting link count


RADIUS Vendor Specific Attribute Types

RADIUS_VENDOR_MICROSOFT (int)

Microsoft specific vendor attributes (» RFC 2548), one of:

  • RADIUS_MICROSOFT_MS_CHAP_RESPONSE
  • RADIUS_MICROSOFT_MS_CHAP_ERROR
  • RADIUS_MICROSOFT_MS_CHAP_PW_1
  • RADIUS_MICROSOFT_MS_CHAP_PW_2
  • RADIUS_MICROSOFT_MS_CHAP_LM_ENC_PW
  • RADIUS_MICROSOFT_MS_CHAP_NT_ENC_PW
  • RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_POLICY
  • RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_TYPES
  • RADIUS_MICROSOFT_MS_RAS_VENDOR
  • RADIUS_MICROSOFT_MS_CHAP_DOMAIN
  • RADIUS_MICROSOFT_MS_CHAP_CHALLENGE
  • RADIUS_MICROSOFT_MS_CHAP_MPPE_KEYS
  • RADIUS_MICROSOFT_MS_BAP_USAGE
  • RADIUS_MICROSOFT_MS_LINK_UTILIZATION_THRESHOLD
  • RADIUS_MICROSOFT_MS_LINK_DROP_TIME_LIMIT
  • RADIUS_MICROSOFT_MS_MPPE_SEND_KEY
  • RADIUS_MICROSOFT_MS_MPPE_RECV_KEY
  • RADIUS_MICROSOFT_MS_RAS_VERSION
  • RADIUS_MICROSOFT_MS_OLD_ARAP_PASSWORD
  • RADIUS_MICROSOFT_MS_NEW_ARAP_PASSWORD
  • RADIUS_MICROSOFT_MS_ARAP_PASSWORD_CHANGE_REASON
  • RADIUS_MICROSOFT_MS_FILTER
  • RADIUS_MICROSOFT_MS_ACCT_AUTH_TYPE
  • RADIUS_MICROSOFT_MS_ACCT_EAP_TYPE
  • RADIUS_MICROSOFT_MS_CHAP2_RESPONSE
  • RADIUS_MICROSOFT_MS_CHAP2_SUCCESS
  • RADIUS_MICROSOFT_MS_CHAP2_PW
  • RADIUS_MICROSOFT_MS_PRIMARY_DNS_SERVER
  • RADIUS_MICROSOFT_MS_SECONDARY_DNS_SERVER
  • RADIUS_MICROSOFT_MS_PRIMARY_NBNS_SERVER
  • RADIUS_MICROSOFT_MS_SECONDARY_NBNS_SERVER
  • RADIUS_MICROSOFT_MS_ARAP_CHALLENGE


范例

Howto start?

  • get a radius resource
  • configure the library
  • create the request
  • put attributes
  • send the request
  • receive attributes
  • close the radius resource (optional)
Take also a look at the examples in this package.

The package contains an example php script. This script demonstrates howto authenticate with radius using PAP or CHAP (md5). If you authenticate with Microsoft Radius servers then its not possible to use CHAP (md5). If you would like to authenticate with Microsoft Servers you have to use MS-CHAPv1 or MS-CHAPv2, but its more complicated, because you need md4, sha1 and des to generate the right data. The enclosed examples demonstrate all authentication-methods, including MS-CHAPv1 and MS-CHAPv2. To get the MS-CHAP to work you need the mcrypt and the mhash extension, starting with version 1.2 of the package, the mcrypt extension is no longer needed.


Radius 函数

Table of Contents

  • radius_acct_open — Creates a Radius handle for accounting
  • radius_add_server — Adds a server
  • radius_auth_open — Creates a Radius handle for authentication
  • radius_close — Frees all ressources
  • radius_config — Causes the library to read the given configuration file
  • radius_create_request — Create accounting or authentication request
  • radius_cvt_addr — Converts raw data to IP-Address
  • radius_cvt_int — Converts raw data to integer
  • radius_cvt_string — Converts raw data to string
  • radius_demangle_mppe_key — Derives mppe-keys from mangled data
  • radius_demangle — Demangles data
  • radius_get_attr — Extracts an attribute
  • radius_get_tagged_attr_data — Extracts the data from a tagged attribute
  • radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute
  • radius_get_vendor_attr — Extracts a vendor specific attribute
  • radius_put_addr — Attaches an IP address attribute
  • radius_put_attr — Attaches a binary attribute
  • radius_put_int — Attaches an integer attribute
  • radius_put_string — Attaches a string attribute
  • radius_put_vendor_addr — Attaches a vendor specific IP address attribute
  • radius_put_vendor_attr — Attaches a vendor specific binary attribute
  • radius_put_vendor_int — Attaches a vendor specific integer attribute
  • radius_put_vendor_string — Attaches a vendor specific string attribute
  • radius_request_authenticator — Returns the request authenticator
  • radius_salt_encrypt_attr — Salt-encrypts a value
  • radius_send_request — Sends the request and waits for a reply
  • radius_server_secret — Returns the shared secret
  • radius_strerror — Returns an error message


Creates a Radius handle for accounting

  • ? Radius 函数
  • radius_add_server ?
  • PHP Manual
  • Radius 函数
  • Creates a Radius handle for accounting

radius_acct_open

(PECL radius >= 1.1.0)

radius_acct_open — Creates a Radius handle for accounting

说明

radius_acct_open ( ) : resource

返回值

Returns a handle on success, false on error. This function only fails if insufficient memory is available.

范例

Example #1 radius_acct_open() example

<?php
$res = radius_acct_open ()
    or die ("Could not create handle");
print("Handle successfully created");
?>


Adds a server

  • ? radius_acct_open
  • radius_auth_open ?
  • PHP Manual
  • Radius 函数
  • Adds a server

radius_add_server

(PECL radius >= 1.1.0)

radius_add_server — Adds a server

说明

radius_add_server ( resource $radius_handle , string $hostname , int $port , string $secret , int $timeout , int $max_tries ) : bool

radius_add_server() may be called multiple times, and it may be used together with radius_config(). At most 10 servers may be specified. When multiple servers are given, they are tried in round-robin fashion until a valid response is received, or until each server's max_tries limit has been reached.

参数

radius_handle

hostname

The hostname parameter specifies the server host, either as a fully qualified domain name or as a dotted-quad IP address in text form.

port

The port specifies the UDP port to contact on the server. If port is given as 0, the library looks up the radius/udp or radacct/udp service in the network services database, and uses the port found there. If no entry is found, the library uses the standard Radius ports, 1812 for authentication and 1813 for accounting.

secret

The shared secret for the server host is passed to the secret parameter. The Radius protocol ignores all but the leading 128 bytes of the shared secret.

timeout

The timeout for receiving replies from the server is passed to the timeout parameter, in units of seconds.

max_tries

The maximum number of repeated requests to make before giving up is passed into the max_tries.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 radius_add_server() example

<?php
if (!radius_add_server($res, 'radius.example.com', 1812, 'testing123', 3, 3)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br>";
    exit;
}
?>

参见

  • radius_config() - Causes the library to read the given configuration file


Creates a Radius handle for authentication

  • ? radius_add_server
  • radius_close ?
  • PHP Manual
  • Radius 函数
  • Creates a Radius handle for authentication

radius_auth_open

(PECL radius >= 1.1.0)

radius_auth_open — Creates a Radius handle for authentication

说明

radius_auth_open ( ) : resource

返回值

Returns a handle on success, false on error. This function only fails if insufficient memory is available.

范例

Example #1 radius_auth_open() example

<?php
$radh = radius_auth_open()
    or die ("Could not create handle");
echo "Handle successfully created";
?>


Frees all ressources

  • ? radius_auth_open
  • radius_config ?
  • PHP Manual
  • Radius 函数
  • Frees all ressources

radius_close

(PECL radius >= 1.1.0)

radius_close — Frees all ressources

说明

radius_close ( resource $radius_handle ) : bool

It is not needed to call this function because php frees all resources at the end of each request.

返回值

成功时返回 true， 或者在失败时返回 false。


Causes the library to read the given configuration file

  • ? radius_close
  • radius_create_request ?
  • PHP Manual
  • Radius 函数
  • Causes the library to read the given configuration file

radius_config

(PECL radius >= 1.1.0)

radius_config — Causes the library to read the given configuration file

说明

radius_config ( resource $radius_handle , string $file ) : bool

Before issuing any Radius requests, the library must be made aware of the servers it can contact. The easiest way to configure the library is to call radius_config(). radius_config() causes the library to read a configuration file whose format is described in » radius.conf.

参数

radius_handle

file

The pathname of the configuration file is passed as the file argument to radius_config(). The library can also be configured programmatically by calls to radius_add_server().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • radius_add_server() - Adds a server


Create accounting or authentication request

  • ? radius_config
  • radius_cvt_addr ?
  • PHP Manual
  • Radius 函数
  • Create accounting or authentication request

radius_create_request

(PECL radius >= 1.1.0)

radius_create_request — Create accounting or authentication request

说明

radius_create_request ( resource $radius_handle , int $type ) : bool

A Radius request consists of a code specifying the kind of request, and zero or more attributes which provide additional information. To begin constructing a new request, call radius_create_request().

Note: Attention: You must call this function, before you can put any attribute!

参数

radius_handle

type

Type is RADIUS_ACCESS_REQUEST or RADIUS_ACCOUNTING_REQUEST.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 radius_create_request() example

<?php
if (!radius_create_request($res, RADIUS_ACCESS_REQUEST)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

参见

  • radius_send_request() - Sends the request and waits for a reply


Converts raw data to IP-Address

  • ? radius_create_request
  • radius_cvt_int ?
  • PHP Manual
  • Radius 函数
  • Converts raw data to IP-Address

radius_cvt_addr

(PECL radius >= 1.1.0)

radius_cvt_addr — Converts raw data to IP-Address

说明

radius_cvt_addr ( string $data ) : string

范例

Example #1 radius_cvt_addr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FRAMED_IP_ADDRESS:
        $ip = radius_cvt_addr($data);
        echo "IP: $ip<br>\n";
        break;

    case RADIUS_FRAMED_IP_NETMASK:
        $mask = radius_cvt_addr($data);
        echo "MASK: $mask<br>\n";
        break;
    }
}
?>

参见

  • radius_cvt_int() - Converts raw data to integer
  • radius_cvt_string() - Converts raw data to string


Converts raw data to integer

  • ? radius_cvt_addr
  • radius_cvt_string ?
  • PHP Manual
  • Radius 函数
  • Converts raw data to integer

radius_cvt_int

(PECL radius >= 1.1.0)

radius_cvt_int — Converts raw data to integer

说明

radius_cvt_int ( string $data ) : int

范例

Example #1 radius_cvt_int() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FRAMED_MTU:
        $mtu = radius_cvt_int($data);
        echo "MTU: $mtu<br>\n";
        break;
    }
}
?>

参见

  • radius_cvt_addr() - Converts raw data to IP-Address
  • radius_cvt_string() - Converts raw data to string


Converts raw data to string

  • ? radius_cvt_int
  • radius_demangle_mppe_key ?
  • PHP Manual
  • Radius 函数
  • Converts raw data to string

radius_cvt_string

(PECL radius >= 1.1.0)

radius_cvt_string — Converts raw data to string

说明

radius_cvt_string ( string $data ) : string

范例

Example #1 radius_cvt_string() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FILTER_ID:
        $id = radius_cvt_string($data);
        echo "Filter ID: $id<br>\n";
        break;
    }
}
?>

参见

  • radius_cvt_addr() - Converts raw data to IP-Address
  • radius_cvt_int() - Converts raw data to integer


Derives mppe-keys from mangled data

  • ? radius_cvt_string
  • radius_demangle ?
  • PHP Manual
  • Radius 函数
  • Derives mppe-keys from mangled data

radius_demangle_mppe_key

(PECL radius >= 1.2.0)

radius_demangle_mppe_key — Derives mppe-keys from mangled data

说明

radius_demangle_mppe_key ( resource $radius_handle , string $mangled ) : string

When using MPPE with MS-CHAPv2, the send- and recv-keys are mangled (see » RFC 2548), however this function is useless, because I don't think that there is or will be a PPTP-MPPE implementation in PHP.

返回值

Returns the demangled string, or false on error.


Demangles data

  • ? radius_demangle_mppe_key
  • radius_get_attr ?
  • PHP Manual
  • Radius 函数
  • Demangles data

radius_demangle

(PECL radius >= 1.2.0)

radius_demangle — Demangles data

说明

radius_demangle ( resource $radius_handle , string $mangled ) : string

Some data (Passwords, MS-CHAPv1 MPPE-Keys) is mangled for security reasons, and must be demangled before you can use them.

返回值

Returns the demangled string, or false on error.


Extracts an attribute

  • ? radius_demangle
  • radius_get_tagged_attr_data ?
  • PHP Manual
  • Radius 函数
  • Extracts an attribute

radius_get_attr

(PECL radius >= 1.1.0)

radius_get_attr — Extracts an attribute

说明

radius_get_attr ( resource $radius_handle ) : mixed

Like Radius requests, each response may contain zero or more attributes. After a response has been received successfully by radius_send_request(), its attributes can be extracted one by one using radius_get_attr(). Each time radius_get_attr() is called, it gets the next attribute from the current response.

返回值

Returns an associative array containing the attribute-type and the data, or error number <= 0.

范例

Example #1 radius_get_attr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];
    printf("Got Attr:%d %d Bytes %s\n", $attr, strlen($data), bin2hex($data));
}
?>

参见

  • radius_put_attr() - Attaches a binary attribute
  • radius_get_vendor_attr() - Extracts a vendor specific attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute
  • radius_send_request() - Sends the request and waits for a reply


Extracts the data from a tagged attribute

  • ? radius_get_attr
  • radius_get_tagged_attr_tag ?
  • PHP Manual
  • Radius 函数
  • Extracts the data from a tagged attribute

radius_get_tagged_attr_data

(PECL radius >= 1.3.0)

radius_get_tagged_attr_data — Extracts the data from a tagged attribute

说明

radius_get_tagged_attr_data ( string $data ) : string|false

If a tagged attribute has been returned from radius_get_attr(), radius_get_tagged_attr_data() will return the data from the attribute.

参数

data

The tagged attribute to be decoded.

返回值

Returns the data from the tagged attribute 或者在失败时返回 false.

范例

Example #1 radius_get_tagged_attr_data() example

<?php
while ($resa = radius_get_attr($res)) {
    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    $tag = radius_get_tagged_attr_tag($data);
    $value = radius_get_tagged_attr_data($data);

    printf("Got tagged attribute with tag %d and value %s\n", $tag, $value);
}
?>

参见

  • radius_get_attr() - Extracts an attribute
  • radius_get_tagged_attr_tag() - Extracts the tag from a tagged attribute


Extracts the tag from a tagged attribute

  • ? radius_get_tagged_attr_data
  • radius_get_vendor_attr ?
  • PHP Manual
  • Radius 函数
  • Extracts the tag from a tagged attribute

radius_get_tagged_attr_tag

(PECL radius >= 1.3.0)

radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute

说明

radius_get_tagged_attr_tag ( string $data ) : int|false

If a tagged attribute has been returned from radius_get_attr(), radius_get_tagged_attr_data() will return the tag from the attribute.

参数

data

The tagged attribute to be decoded.

返回值

Returns the tag from the tagged attribute 或者在失败时返回 false.

范例

Example #1 radius_get_tagged_attr_tag() example

<?php
while ($resa = radius_get_attr($res)) {
    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    $tag = radius_get_tagged_attr_tag($data);
    $value = radius_get_tagged_attr_data($data);

    printf("Got tagged attribute with tag %d and value %s\n", $tag, $value);
}
?>

参见

  • radius_get_attr() - Extracts an attribute
  • radius_get_tagged_attr_data() - Extracts the data from a tagged attribute


Extracts a vendor specific attribute

  • ? radius_get_tagged_attr_tag
  • radius_put_addr ?
  • PHP Manual
  • Radius 函数
  • Extracts a vendor specific attribute

radius_get_vendor_attr

(PECL radius >= 1.1.0)

radius_get_vendor_attr — Extracts a vendor specific attribute

说明

radius_get_vendor_attr ( string $data ) : array

If radius_get_attr() returns RADIUS_VENDOR_SPECIFIC, radius_get_vendor_attr() may be called to determine the vendor.

返回值

Returns an associative array containing the attribute-type, vendor and the data, or false on error.

范例

Example #1 radius_get_vendor_attr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];
    printf("Got Attr:%d %d Bytes %s\n", $attr, strlen($data), bin2hex($data));
    if ($attr == RADIUS_VENDOR_SPECIFIC) {

        $resv = radius_get_vendor_attr($data);
        if (is_array($resv)) {
            $vendor = $resv['vendor'];
            $attrv = $resv['attr'];
            $datav = $resv['data'];
            printf("Got Vendor Attr:%d %d Bytes %s\n", $attrv, strlen($datav), bin2hex($datav));
        }

    }
}
?>

参见

  • radius_get_attr() - Extracts an attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute


Attaches an IP address attribute

  • ? radius_get_vendor_attr
  • radius_put_attr ?
  • PHP Manual
  • Radius 函数
  • Attaches an IP address attribute

radius_put_addr

(PECL radius >= 1.1.0)

radius_put_addr — Attaches an IP address attribute

说明

radius_put_addr ( resource $radius_handle , int $type , string $addr , int $options = 0 , int $tag = ? ) : bool

Attaches an IP address attribute to the current RADIUS request.

Note:

A request must be created via radius_create_request() before this function can be called.

参数

radius_handle

The RADIUS resource.

type

The attribute type.

addr

An IPv4 address in string form, such as 10.0.0.1.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL radius 1.3.0 | The options and tag parameters were added.


Attaches a binary attribute

  • ? radius_put_addr
  • radius_put_int ?
  • PHP Manual
  • Radius 函数
  • Attaches a binary attribute

radius_put_attr

(PECL radius >= 1.1.0)

radius_put_attr — Attaches a binary attribute

说明

radius_put_attr ( resource $radius_handle , int $type , string $value , int $options = 0 , int $tag = ? ) : bool

Attaches a binary attribute to the current RADIUS request.

Note:

A request must be created via radius_create_request() before this function can be called.

参数

radius_handle

The RADIUS resource.

type

The attribute type.

value

The attribute value, which will be treated as a raw binary string.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 radius_put_attr() example

<?php
mt_srand(time());
$chall = mt_rand();
$chapval = md5(pack('Ca*',1 , 'sepp' . $chall));
$pass = pack('CH*', 1, $chapval);
if (!radius_put_attr($res, RADIUS_CHAP_PASSWORD, $pass)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

更新日志

版本 | 说明
PECL radius 1.3.0 | The options and tag parameters were added.

参见

  • radius_get_attr() - Extracts an attribute
  • radius_get_vendor_attr() - Extracts a vendor specific attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute


Attaches an integer attribute

  • ? radius_put_attr
  • radius_put_string ?
  • PHP Manual
  • Radius 函数
  • Attaches an integer attribute

radius_put_int

(PECL radius >= 1.1.0)

radius_put_int — Attaches an integer attribute

说明

radius_put_int ( resource $radius_handle , int $type , int $value , int $options = 0 , int $tag = ? ) : bool

Attaches an integer attribute to the current RADIUS request.

Note:

A request must be created via radius_create_request() before this function can be called.

参数

radius_handle

The RADIUS resource.

type

The attribute type.

value

The attribute value.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL radius 1.3.0 | The options and tag parameters were added.

范例

Example #1 radius_put_int() example

<?php
if (!radius_put_int($res, RAD_FRAMED_PROTOCOL, RAD_PPP)) {
   echo 'RadiusError:' . radius_strerror($res). "\n<br />";
   exit;
}
?>

参见

  • radius_put_string() - Attaches a string attribute
  • radius_put_vendor_int() - Attaches a vendor specific integer attribute
  • radius_put_vendor_string() - Attaches a vendor specific string attribute


Attaches a string attribute

  • ? radius_put_int
  • radius_put_vendor_addr ?
  • PHP Manual
  • Radius 函数
  • Attaches a string attribute

radius_put_string

(PECL radius >= 1.1.0)

radius_put_string — Attaches a string attribute

说明

radius_put_string ( resource $radius_handle , int $type , string $value , int $options = 0 , int $tag = ? ) : bool

Attaches a string attribute to the current RADIUS request. In general, radius_put_attr() is a more useful function for attaching string attributes, as it is binary safe.

Note:

A request must be created via radius_create_request() before this function can be called.

参数

radius_handle

The RADIUS resource.

type

The attribute type.

value

The attribute value. This value is expected by the underlying library to be null terminated, therefore this parameter is not binary safe.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL radius 1.3.0 | The options and tag parameters were added.

范例

Example #1 radius_put_string() example

<?php
if (!radius_put_string($res, RADIUS_USER_NAME, 'billy')) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

参见

  • radius_put_int() - Attaches an integer attribute
  • radius_put_vendor_int() - Attaches a vendor specific integer attribute
  • radius_put_vendor_string() - Attaches a vendor specific string attribute


Attaches a vendor specific IP address attribute

  • ? radius_put_string
  • radius_put_vendor_attr ?
  • PHP Manual
  • Radius 函数
  • Attaches a vendor specific IP address attribute

radius_put_vendor_addr

(PECL radius >= 1.1.0)

radius_put_vendor_addr — Attaches a vendor specific IP address attribute

说明

radius_put_vendor_addr ( resource $radius_handle , int $vendor , int $type , string $addr ) : bool

Attaches an IP address vendor specific attribute to the current RADIUS request.

Note:

A request must be created via radius_create_request() before this function can be called.

参数

radius_handle

The RADIUS resource.

vendor

The vendor ID.

type

The attribute type.

addr

An IPv4 address in string form, such as 10.0.0.1.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL radius 1.3.0 | The options and tag parameters were added.


Attaches a vendor specific binary attribute

  • ? radius_put_vendor_addr
  • radius_put_vendor_int ?
  • PHP Manual
  • Radius 函数
  • Attaches a vendor specific binary attribute

radius_put_vendor_attr

(PECL radius >= 1.1.0)

radius_put_vendor_attr — Attaches a vendor specific binary attribute

说明

radius_put_vendor_attr ( resource $radius_handle , int $vendor , int $type , string $value , int $options = 0 , int $tag = ? ) : bool

Attaches a vendor specific binary attribute to the current RADIUS request.

Note:

A request must be created via radius_create_request() before this function can be called.

参数

radius_handle

The RADIUS resource.

vendor

The vendor ID.

type

The attribute type.

value

The attribute value, which will be treated as a raw binary string.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL radius 1.3.0 | The options and tag parameters were added.

范例

Example #1 radius_put_vendor_attr() example

<?php
if (!radius_put_vendor_attr($res, RADIUS_VENDOR_MICROSOFT, RAD_MICROSOFT_MS_CHAP_CHALLENGE, $challenge)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

参见

  • radius_get_vendor_attr() - Extracts a vendor specific attribute


Attaches a vendor specific integer attribute

  • ? radius_put_vendor_attr
  • radius_put_vendor_string ?
  • PHP Manual
  • Radius 函数
  • Attaches a vendor specific integer attribute

radius_put_vendor_int

(PECL radius >= 1.1.0)

radius_put_vendor_int — Attaches a vendor specific integer attribute

说明

radius_put_vendor_int ( resource $radius_handle , int $vendor , int $type , int $value , int $options = 0 , int $tag = ? ) : bool

Attaches a vendor specific integer attribute to the current RADIUS request.

Note:

A request must be created via radius_create_request() before this function can be called.

参数

radius_handle

The RADIUS resource.

vendor

The vendor ID.

type

The attribute type.

value

The attribute value.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL radius 1.3.0 | The options and tag parameters were added.

参见

  • radius_put_vendor_string() - Attaches a vendor specific string attribute


Attaches a vendor specific string attribute

  • ? radius_put_vendor_int
  • radius_request_authenticator ?
  • PHP Manual
  • Radius 函数
  • Attaches a vendor specific string attribute

radius_put_vendor_string

(PECL radius >= 1.1.0)

radius_put_vendor_string — Attaches a vendor specific string attribute

说明

radius_put_vendor_string ( resource $radius_handle , int $vendor , int $type , string $value , int $options = 0 , int $tag = ? ) : bool

Attaches a vendor specific string attribute to the current RADIUS request. In general, radius_put_vendor_attr() is a more useful function for attaching string attributes, as it is binary safe.

Note:

A request must be created via radius_create_request() before this function can be called.

参数

radius_handle

The RADIUS resource.

vendor

The vendor ID.

type

The attribute type.

value

The attribute value. This value is expected by the underlying library to be null terminated, therefore this parameter is not binary safe.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL radius 1.3.0 | The options and tag parameters were added.

参见

  • radius_put_vendor_int() - Attaches a vendor specific integer attribute


Returns the request authenticator

  • ? radius_put_vendor_string
  • radius_salt_encrypt_attr ?
  • PHP Manual
  • Radius 函数
  • Returns the request authenticator

radius_request_authenticator

(PECL radius >= 1.1.0)

radius_request_authenticator — Returns the request authenticator

说明

radius_request_authenticator ( resource $radius_handle ) : string

The request authenticator is needed for demangling mangled data like passwords and encryption-keys.

返回值

Returns the request authenticator as string, or false on error.

参见

  • radius_demangle() - Demangles data


Salt-encrypts a value

  • ? radius_request_authenticator
  • radius_send_request ?
  • PHP Manual
  • Radius 函数
  • Salt-encrypts a value

radius_salt_encrypt_attr

(PECL radius >= 1.3.0)

radius_salt_encrypt_attr — Salt-encrypts a value

说明

radius_salt_encrypt_attr ( resource $radius_handle , string $data ) : string|false

Applies the RADIUS salt-encryption algorithm to the given value.

In general, this is achieved automatically by providing the RADIUS_OPTION_SALT option to an attribute setter function, but this function can be used if low-level request construction is required.

参数

data

The data to be salt-encrypted.

返回值

Returns the salt-encrypted data 或者在失败时返回 false.

参见

  • radius_put_addr() - Attaches an IP address attribute
  • radius_put_attr() - Attaches a binary attribute
  • radius_put_int() - Attaches an integer attribute
  • radius_put_string() - Attaches a string attribute


Sends the request and waits for a reply

  • ? radius_salt_encrypt_attr
  • radius_server_secret ?
  • PHP Manual
  • Radius 函数
  • Sends the request and waits for a reply

radius_send_request

(PECL radius >= 1.1.0)

radius_send_request — Sends the request and waits for a reply

说明

radius_send_request ( resource $radius_handle ) : int

After the Radius request has been constructed, it is sent by radius_send_request().

The radius_send_request() function sends the request and waits for a valid reply, retrying the defined servers in round-robin fashion as necessary.

返回值

If a valid response is received, radius_send_request() returns the Radius code which specifies the type of the response. This will typically be RADIUS_ACCESS_ACCEPT, RADIUS_ACCESS_REJECT, or RADIUS_ACCESS_CHALLENGE. If no valid response is received, radius_send_request() returns false.

参见

  • radius_create_request() - Create accounting or authentication request


Returns the shared secret

  • ? radius_send_request
  • radius_strerror ?
  • PHP Manual
  • Radius 函数
  • Returns the shared secret

radius_server_secret

(PECL radius >= 1.1.0)

radius_server_secret — Returns the shared secret

说明

radius_server_secret ( resource $radius_handle ) : string

The shared secret is needed as salt for demangling mangled data like passwords and encryption-keys.

返回值

Returns the server's shared secret as string, or false on error.


Returns an error message

  • ? radius_server_secret
  • 针对命令行的扩展 ?
  • PHP Manual
  • Radius 函数
  • Returns an error message

radius_strerror

(PECL radius >= 1.1.0)

radius_strerror — Returns an error message

说明

radius_strerror ( resource $radius_handle ) : string

If Radius-functions fail then they record an error message. This error message can be retrieved with this function.

返回值

Returns error messages as string from failed radius functions.


针对命令行的扩展

  • Ncurses — Ncurses Terminal Screen Control
    • 简介
    • 安装／配置
    • 预定义常量
    • Ncurses 函数
  • Readline — GNU Readline
    • 简介
    • 安装／配置
    • 预定义常量
    • Readline 函数


Ncurses Terminal Screen Control

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
    • Error codes
    • Colors
    • Keys
    • Mouse
  • Ncurses 函数
    • ncurses_addch — Add character at current position and advance cursor
    • ncurses_addchnstr — Add attributed string with specified length at current position
    • ncurses_addchstr — Add attributed string at current position
    • ncurses_addnstr — Add string with specified length at current position
    • ncurses_addstr — Output text at current position
    • ncurses_assume_default_colors — Define default colors for color 0
    • ncurses_attroff — Turn off the given attributes
    • ncurses_attron — Turn on the given attributes
    • ncurses_attrset — Set given attributes
    • ncurses_baudrate — Returns baudrate of terminal
    • ncurses_beep — Let the terminal beep
    • ncurses_bkgd — Set background property for terminal screen
    • ncurses_bkgdset — Control screen background
    • ncurses_border — Draw a border around the screen using attributed characters
    • ncurses_bottom_panel — Moves a visible panel to the bottom of the stack
    • ncurses_can_change_color — Checks if terminal color definitions can be changed
    • ncurses_cbreak — Switch off input buffering
    • ncurses_clear — Clear screen
    • ncurses_clrtobot — Clear screen from current position to bottom
    • ncurses_clrtoeol — Clear screen from current position to end of line
    • ncurses_color_content — Retrieves RGB components of a color
    • ncurses_color_set — Set active foreground and background colors
    • ncurses_curs_set — Set cursor state
    • ncurses_def_prog_mode — Saves terminals (program) mode
    • ncurses_def_shell_mode — Saves terminals (shell) mode
    • ncurses_define_key — Define a keycode
    • ncurses_del_panel — Remove panel from the stack and delete it (but not the associated window)
    • ncurses_delay_output — Delay output on terminal using padding characters
    • ncurses_delch — Delete character at current position, move rest of line left
    • ncurses_deleteln — Delete line at current position, move rest of screen up
    • ncurses_delwin — Delete a ncurses window
    • ncurses_doupdate — Write all prepared refreshes to terminal
    • ncurses_echo — Activate keyboard input echo
    • ncurses_echochar — Single character output including refresh
    • ncurses_end — Stop using ncurses, clean up the screen
    • ncurses_erase — Erase terminal screen
    • ncurses_erasechar — Returns current erase character
    • ncurses_filter — Set LINES for iniscr() and newterm() to 1
    • ncurses_flash — Flash terminal screen (visual bell)
    • ncurses_flushinp — Flush keyboard input buffer
    • ncurses_getch — Read a character from keyboard
    • ncurses_getmaxyx — Returns the size of a window
    • ncurses_getmouse — Reads mouse event
    • ncurses_getyx — Returns the current cursor position for a window
    • ncurses_halfdelay — Put terminal into halfdelay mode
    • ncurses_has_colors — Checks if terminal has color capabilities
    • ncurses_has_ic — Check for insert- and delete-capabilities
    • ncurses_has_il — Check for line insert- and delete-capabilities
    • ncurses_has_key — Check for presence of a function key on terminal keyboard
    • ncurses_hide_panel — Remove panel from the stack, making it invisible
    • ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long
    • ncurses_inch — Get character and attribute at current position
    • ncurses_init_color — Define a terminal color
    • ncurses_init_pair — Define a color pair
    • ncurses_init — Initialize ncurses
    • ncurses_insch — Insert character moving rest of line including character at current position
    • ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)
    • ncurses_insertln — Insert a line, move rest of screen down
    • ncurses_insstr — Insert string at current position, moving rest of line right
    • ncurses_instr — Reads string from terminal screen
    • ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed
    • ncurses_keyok — Enable or disable a keycode
    • ncurses_keypad — Turns keypad on or off
    • ncurses_killchar — Returns current line kill character
    • ncurses_longname — Returns terminals description
    • ncurses_meta — Enables/Disable 8-bit meta key information
    • ncurses_mouse_trafo — Transforms coordinates
    • ncurses_mouseinterval — Set timeout for mouse button clicks
    • ncurses_mousemask — Sets mouse options
    • ncurses_move_panel — Moves a panel so that its upper-left corner is at [startx, starty]
    • ncurses_move — Move output position
    • ncurses_mvaddch — Move current position and add character
    • ncurses_mvaddchnstr — Move position and add attributed string with specified length
    • ncurses_mvaddchstr — Move position and add attributed string
    • ncurses_mvaddnstr — Move position and add string with specified length
    • ncurses_mvaddstr — Move position and add string
    • ncurses_mvcur — Move cursor immediately
    • ncurses_mvdelch — Move position and delete character, shift rest of line left
    • ncurses_mvgetch — Move position and get character at new position
    • ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long
    • ncurses_mvinch — Move position and get attributed character at new position
    • ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long
    • ncurses_mvwaddstr — Add string at new position in window
    • ncurses_napms — Sleep
    • ncurses_new_panel — Create a new panel and associate it with window
    • ncurses_newpad — Creates a new pad (window)
    • ncurses_newwin — Create a new window
    • ncurses_nl — Translate newline and carriage return / line feed
    • ncurses_nocbreak — Switch terminal to cooked mode
    • ncurses_noecho — Switch off keyboard input echo
    • ncurses_nonl — Do not translate newline and carriage return / line feed
    • ncurses_noqiflush — Do not flush on signal characters
    • ncurses_noraw — Switch terminal out of raw mode
    • ncurses_pair_content — Retrieves foreground and background colors of a color pair
    • ncurses_panel_above — Returns the panel above panel
    • ncurses_panel_below — Returns the panel below panel
    • ncurses_panel_window — Returns the window associated with panel
    • ncurses_pnoutrefresh — Copies a region from a pad into the virtual screen
    • ncurses_prefresh — Copies a region from a pad into the virtual screen
    • ncurses_putp — Apply padding information to the string and output it
    • ncurses_qiflush — Flush on signal characters
    • ncurses_raw — Switch terminal into raw mode
    • ncurses_refresh — Refresh screen
    • ncurses_replace_panel — Replaces the window associated with panel
    • ncurses_reset_prog_mode — Resets the prog mode saved by def_prog_mode
    • ncurses_reset_shell_mode — Resets the shell mode saved by def_shell_mode
    • ncurses_resetty — Restores saved terminal state
    • ncurses_savetty — Saves terminal state
    • ncurses_scr_dump — Dump screen content to file
    • ncurses_scr_init — Initialize screen from file dump
    • ncurses_scr_restore — Restore screen from file dump
    • ncurses_scr_set — Inherit screen from file dump
    • ncurses_scrl — Scroll window content up or down without changing current position
    • ncurses_show_panel — Places an invisible panel on top of the stack, making it visible
    • ncurses_slk_attr — Returns current soft label key attribute
    • ncurses_slk_attroff — Turn off the given attributes for soft function-key labels
    • ncurses_slk_attron — Turn on the given attributes for soft function-key labels
    • ncurses_slk_attrset — Set given attributes for soft function-key labels
    • ncurses_slk_clear — Clears soft labels from screen
    • ncurses_slk_color — Sets color for soft label keys
    • ncurses_slk_init — Initializes soft label key functions
    • ncurses_slk_noutrefresh — Copies soft label keys to virtual screen
    • ncurses_slk_refresh — Copies soft label keys to screen
    • ncurses_slk_restore — Restores soft label keys
    • ncurses_slk_set — Sets function key labels
    • ncurses_slk_touch — Forces output when ncurses_slk_noutrefresh is performed
    • ncurses_standend — Stop using 'standout' attribute
    • ncurses_standout — Start using 'standout' attribute
    • ncurses_start_color — Initializes color functionality
    • ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal
    • ncurses_termname — Returns terminals (short)-name
    • ncurses_timeout — Set timeout for special key sequences
    • ncurses_top_panel — Moves a visible panel to the top of the stack
    • ncurses_typeahead — Specify different filedescriptor for typeahead checking
    • ncurses_ungetch — Put a character back into the input stream
    • ncurses_ungetmouse — Pushes mouse event to queue
    • ncurses_update_panels — Refreshes the virtual screen to reflect the relations between panels in the stack
    • ncurses_use_default_colors — Assign terminal default colors to color id -1
    • ncurses_use_env — Control use of environment information about terminal size
    • ncurses_use_extended_names — Control use of extended names in terminfo descriptions
    • ncurses_vidattr — Display the string on the terminal in the video attribute mode
    • ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long
    • ncurses_waddch — Adds character at current position in a window and advance cursor
    • ncurses_waddstr — Outputs text at current postion in window
    • ncurses_wattroff — Turns off attributes for a window
    • ncurses_wattron — Turns on attributes for a window
    • ncurses_wattrset — Set the attributes for a window
    • ncurses_wborder — Draws a border around the window using attributed characters
    • ncurses_wclear — Clears window
    • ncurses_wcolor_set — Sets windows color pairings
    • ncurses_werase — Erase window contents
    • ncurses_wgetch — Reads a character from keyboard (window)
    • ncurses_whline — Draws a horizontal line in a window at current position using an attributed character and max. n characters long
    • ncurses_wmouse_trafo — Transforms window/stdscr coordinates
    • ncurses_wmove — Moves windows output position
    • ncurses_wnoutrefresh — Copies window to virtual screen
    • ncurses_wrefresh — Refresh window on terminal screen
    • ncurses_wstandend — End standout mode for a window
    • ncurses_wstandout — Enter standout mode for a window
    • ncurses_wvline — Draws a vertical line in a window at current position using an attributed character and max. n characters long


简介

ncurses (new curses) is a free software emulation of curses in System V Rel 4.0 (and above). It uses terminfo format, supports pads, colors, multiple highlights, form characters and function key mapping. Because of the interactive nature of this library, it will be of little use for writing Web applications, but may be useful when writing scripts meant using PHP from the command line.

The features available, such as colors, depend on the terminal that you are using. Use functions such as ncurses_has_colors(), ncurses_can_change_color(), and ncurses_has_ic() to check for individual capabilities.

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.3.0.

ncurses is available for the following platforms:

  • AIX
  • BeOS
  • BSD variants (FreeBSD, NetBSD, OpenBSD)
  • Cygwin
  • Digital Unix (aka OSF1)
  • GNU/Linux
  • HPUX
  • IRIX64
  • macOS
  • OS/2
  • QNX
  • SCO OpenServer
  • Solaris
  • Tru64


需求

You need the ncurses libraries and headerfiles. Download the latest version from the » ftp://ftp.gnu.org/pub/gnu/ncurses/ or from an other GNU-Mirror.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ncurses.

Wide character CRT screen handling (ncursesw) support was added in version 1.0.1 of this PECL extension.


资源类型

This extension defines window, panel and pad resources.


预定义常量

Table of Contents

  • Error codes
  • Colors
  • Keys
  • Mouse

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。


Error codes

On error ncurses functions return -1. Some functions return 0 on success. See the relevant pages in the documentation for actual return values.


Colors

ncurses color constants
constant | meaning
NCURSES_COLOR_BLACK | no color (black)
NCURSES_COLOR_WHITE | white
NCURSES_COLOR_RED | red - supported when terminal is in color mode
NCURSES_COLOR_GREEN | green - supported when terminal is in color mode
NCURSES_COLOR_YELLOW | yellow - supported when terminal is in color mode
NCURSES_COLOR_BLUE | blue - supported when terminal is in color mode
NCURSES_COLOR_CYAN | cyan - supported when terminal is in color mode
NCURSES_COLOR_MAGENTA | magenta - supported when terminal is in color mode


Keys

ncurses key constants
constant | meaning
NCURSES_KEY_F0 - NCURSES_KEY_F64 | function keys F1 - F64
NCURSES_KEY_DOWN | down arrow
NCURSES_KEY_UP | up arrow
NCURSES_KEY_LEFT | left arrow
NCURSES_KEY_RIGHT | right arrow
NCURSES_KEY_HOME | home key (upward+left arrow)
NCURSES_KEY_BACKSPACE | backspace
NCURSES_KEY_DL | delete line
NCURSES_KEY_IL | insert line
NCURSES_KEY_DC | delete character
NCURSES_KEY_IC | insert char or enter insert mode
NCURSES_KEY_EIC | exit insert char mode
NCURSES_KEY_CLEAR | clear screen
NCURSES_KEY_EOS | clear to end of screen
NCURSES_KEY_EOL | clear to end of line
NCURSES_KEY_SF | scroll one line forward
NCURSES_KEY_SR | scroll one line backward
NCURSES_KEY_NPAGE | next page
NCURSES_KEY_PPAGE | previous page
NCURSES_KEY_STAB | set tab
NCURSES_KEY_CTAB | clear tab
NCURSES_KEY_CATAB | clear all tabs
NCURSES_KEY_SRESET | soft (partial) reset
NCURSES_KEY_RESET | reset or hard reset
NCURSES_KEY_PRINT | print
NCURSES_KEY_LL | lower left
NCURSES_KEY_A1 | upper left of keypad
NCURSES_KEY_A3 | upper right of keypad
NCURSES_KEY_B2 | center of keypad
NCURSES_KEY_C1 | lower left of keypad
NCURSES_KEY_C3 | lower right of keypad
NCURSES_KEY_BTAB | back tab
NCURSES_KEY_BEG | beginning
NCURSES_KEY_CANCEL | cancel
NCURSES_KEY_CLOSE | close
NCURSES_KEY_COMMAND | cmd (command)
NCURSES_KEY_COPY | copy
NCURSES_KEY_CREATE | create
NCURSES_KEY_END | end
NCURSES_KEY_EXIT | exit
NCURSES_KEY_FIND | find
NCURSES_KEY_HELP | help
NCURSES_KEY_MARK | mark
NCURSES_KEY_MESSAGE | message
NCURSES_KEY_MOVE | move
NCURSES_KEY_NEXT | next
NCURSES_KEY_OPEN | open
NCURSES_KEY_OPTIONS | options
NCURSES_KEY_PREVIOUS | previous
NCURSES_KEY_REDO | redo
NCURSES_KEY_REFERENCE | ref (reference)
NCURSES_KEY_REFRESH | refresh
NCURSES_KEY_REPLACE | replace
NCURSES_KEY_RESTART | restart
NCURSES_KEY_RESUME | resume
NCURSES_KEY_SAVE | save
NCURSES_KEY_SBEG | shiftet beg (beginning)
NCURSES_KEY_SCANCEL | shifted cancel
NCURSES_KEY_SCOMMAND | shifted command
NCURSES_KEY_SCOPY | shifted copy
NCURSES_KEY_SCREATE | shifted create
NCURSES_KEY_SDC | shifted delete char
NCURSES_KEY_SDL | shifted delete line
NCURSES_KEY_SELECT | select
NCURSES_KEY_SEND | shifted end
NCURSES_KEY_SEOL | shifted end of line
NCURSES_KEY_SEXIT | shifted exit
NCURSES_KEY_SFIND | shifted find
NCURSES_KEY_SHELP | shifted help
NCURSES_KEY_SHOME | shifted home
NCURSES_KEY_SIC | shifted input
NCURSES_KEY_SLEFT | shifted left arrow
NCURSES_KEY_SMESSAGE | shifted message
NCURSES_KEY_SMOVE | shifted move
NCURSES_KEY_SNEXT | shifted next
NCURSES_KEY_SOPTIONS | shifted options
NCURSES_KEY_SPREVIOUS | shifted previous
NCURSES_KEY_SPRINT | shifted print
NCURSES_KEY_SREDO | shifted redo
NCURSES_KEY_SREPLACE | shifted replace
NCURSES_KEY_SRIGHT | shifted right arrow
NCURSES_KEY_SRSUME | shifted resume
NCURSES_KEY_SSAVE | shifted save
NCURSES_KEY_SSUSPEND | shifted suspend
NCURSES_KEY_UNDO | undo
NCURSES_KEY_MOUSE | mouse event has occurred
NCURSES_KEY_MAX | maximum key value


Mouse

mouse constants
Constant | meaning
NCURSES_BUTTON1_RELEASED - NCURSES_BUTTON4_RELEASED | button (1-4) released
NCURSES_BUTTON1_PRESSED - NCURSES_BUTTON4_PRESSED | button (1-4) pressed
NCURSES_BUTTON1_CLICKED - NCURSES_BUTTON4_CLICKED | button (1-4) clicked
NCURSES_BUTTON1_DOUBLE_CLICKED - NCURSES_BUTTON4_DOUBLE_CLICKED | button (1-4) double clicked
NCURSES_BUTTON1_TRIPLE_CLICKED - NCURSES_BUTTON4_TRIPLE_CLICKED | button (1-4) triple clicked
NCURSES_BUTTON_CTRL | ctrl pressed during click
NCURSES_BUTTON_SHIFT | shift pressed during click
NCURSES_BUTTON_ALT | alt pressed during click
NCURSES_ALL_MOUSE_EVENTS | report all mouse events
NCURSES_REPORT_MOUSE_POSITION | report mouse position


Ncurses 函数

Table of Contents

  • ncurses_addch — Add character at current position and advance cursor
  • ncurses_addchnstr — Add attributed string with specified length at current position
  • ncurses_addchstr — Add attributed string at current position
  • ncurses_addnstr — Add string with specified length at current position
  • ncurses_addstr — Output text at current position
  • ncurses_assume_default_colors — Define default colors for color 0
  • ncurses_attroff — Turn off the given attributes
  • ncurses_attron — Turn on the given attributes
  • ncurses_attrset — Set given attributes
  • ncurses_baudrate — Returns baudrate of terminal
  • ncurses_beep — Let the terminal beep
  • ncurses_bkgd — Set background property for terminal screen
  • ncurses_bkgdset — Control screen background
  • ncurses_border — Draw a border around the screen using attributed characters
  • ncurses_bottom_panel — Moves a visible panel to the bottom of the stack
  • ncurses_can_change_color — Checks if terminal color definitions can be changed
  • ncurses_cbreak — Switch off input buffering
  • ncurses_clear — Clear screen
  • ncurses_clrtobot — Clear screen from current position to bottom
  • ncurses_clrtoeol — Clear screen from current position to end of line
  • ncurses_color_content — Retrieves RGB components of a color
  • ncurses_color_set — Set active foreground and background colors
  • ncurses_curs_set — Set cursor state
  • ncurses_def_prog_mode — Saves terminals (program) mode
  • ncurses_def_shell_mode — Saves terminals (shell) mode
  • ncurses_define_key — Define a keycode
  • ncurses_del_panel — Remove panel from the stack and delete it (but not the associated window)
  • ncurses_delay_output — Delay output on terminal using padding characters
  • ncurses_delch — Delete character at current position, move rest of line left
  • ncurses_deleteln — Delete line at current position, move rest of screen up
  • ncurses_delwin — Delete a ncurses window
  • ncurses_doupdate — Write all prepared refreshes to terminal
  • ncurses_echo — Activate keyboard input echo
  • ncurses_echochar — Single character output including refresh
  • ncurses_end — Stop using ncurses, clean up the screen
  • ncurses_erase — Erase terminal screen
  • ncurses_erasechar — Returns current erase character
  • ncurses_filter — Set LINES for iniscr() and newterm() to 1
  • ncurses_flash — Flash terminal screen (visual bell)
  • ncurses_flushinp — Flush keyboard input buffer
  • ncurses_getch — Read a character from keyboard
  • ncurses_getmaxyx — Returns the size of a window
  • ncurses_getmouse — Reads mouse event
  • ncurses_getyx — Returns the current cursor position for a window
  • ncurses_halfdelay — Put terminal into halfdelay mode
  • ncurses_has_colors — Checks if terminal has color capabilities
  • ncurses_has_ic — Check for insert- and delete-capabilities
  • ncurses_has_il — Check for line insert- and delete-capabilities
  • ncurses_has_key — Check for presence of a function key on terminal keyboard
  • ncurses_hide_panel — Remove panel from the stack, making it invisible
  • ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long
  • ncurses_inch — Get character and attribute at current position
  • ncurses_init_color — Define a terminal color
  • ncurses_init_pair — Define a color pair
  • ncurses_init — Initialize ncurses
  • ncurses_insch — Insert character moving rest of line including character at current position
  • ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)
  • ncurses_insertln — Insert a line, move rest of screen down
  • ncurses_insstr — Insert string at current position, moving rest of line right
  • ncurses_instr — Reads string from terminal screen
  • ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed
  • ncurses_keyok — Enable or disable a keycode
  • ncurses_keypad — Turns keypad on or off
  • ncurses_killchar — Returns current line kill character
  • ncurses_longname — Returns terminals description
  • ncurses_meta — Enables/Disable 8-bit meta key information
  • ncurses_mouse_trafo — Transforms coordinates
  • ncurses_mouseinterval — Set timeout for mouse button clicks
  • ncurses_mousemask — Sets mouse options
  • ncurses_move_panel — Moves a panel so that its upper-left corner is at [startx, starty]
  • ncurses_move — Move output position
  • ncurses_mvaddch — Move current position and add character
  • ncurses_mvaddchnstr — Move position and add attributed string with specified length
  • ncurses_mvaddchstr — Move position and add attributed string
  • ncurses_mvaddnstr — Move position and add string with specified length
  • ncurses_mvaddstr — Move position and add string
  • ncurses_mvcur — Move cursor immediately
  • ncurses_mvdelch — Move position and delete character, shift rest of line left
  • ncurses_mvgetch — Move position and get character at new position
  • ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long
  • ncurses_mvinch — Move position and get attributed character at new position
  • ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long
  • ncurses_mvwaddstr — Add string at new position in window
  • ncurses_napms — Sleep
  • ncurses_new_panel — Create a new panel and associate it with window
  • ncurses_newpad — Creates a new pad (window)
  • ncurses_newwin — Create a new window
  • ncurses_nl — Translate newline and carriage return / line feed
  • ncurses_nocbreak — Switch terminal to cooked mode
  • ncurses_noecho — Switch off keyboard input echo
  • ncurses_nonl — Do not translate newline and carriage return / line feed
  • ncurses_noqiflush — Do not flush on signal characters
  • ncurses_noraw — Switch terminal out of raw mode
  • ncurses_pair_content — Retrieves foreground and background colors of a color pair
  • ncurses_panel_above — Returns the panel above panel
  • ncurses_panel_below — Returns the panel below panel
  • ncurses_panel_window — Returns the window associated with panel
  • ncurses_pnoutrefresh — Copies a region from a pad into the virtual screen
  • ncurses_prefresh — Copies a region from a pad into the virtual screen
  • ncurses_putp — Apply padding information to the string and output it
  • ncurses_qiflush — Flush on signal characters
  • ncurses_raw — Switch terminal into raw mode
  • ncurses_refresh — Refresh screen
  • ncurses_replace_panel — Replaces the window associated with panel
  • ncurses_reset_prog_mode — Resets the prog mode saved by def_prog_mode
  • ncurses_reset_shell_mode — Resets the shell mode saved by def_shell_mode
  • ncurses_resetty — Restores saved terminal state
  • ncurses_savetty — Saves terminal state
  • ncurses_scr_dump — Dump screen content to file
  • ncurses_scr_init — Initialize screen from file dump
  • ncurses_scr_restore — Restore screen from file dump
  • ncurses_scr_set — Inherit screen from file dump
  • ncurses_scrl — Scroll window content up or down without changing current position
  • ncurses_show_panel — Places an invisible panel on top of the stack, making it visible
  • ncurses_slk_attr — Returns current soft label key attribute
  • ncurses_slk_attroff — Turn off the given attributes for soft function-key labels
  • ncurses_slk_attron — Turn on the given attributes for soft function-key labels
  • ncurses_slk_attrset — Set given attributes for soft function-key labels
  • ncurses_slk_clear — Clears soft labels from screen
  • ncurses_slk_color — Sets color for soft label keys
  • ncurses_slk_init — Initializes soft label key functions
  • ncurses_slk_noutrefresh — Copies soft label keys to virtual screen
  • ncurses_slk_refresh — Copies soft label keys to screen
  • ncurses_slk_restore — Restores soft label keys
  • ncurses_slk_set — Sets function key labels
  • ncurses_slk_touch — Forces output when ncurses_slk_noutrefresh is performed
  • ncurses_standend — Stop using 'standout' attribute
  • ncurses_standout — Start using 'standout' attribute
  • ncurses_start_color — Initializes color functionality
  • ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal
  • ncurses_termname — Returns terminals (short)-name
  • ncurses_timeout — Set timeout for special key sequences
  • ncurses_top_panel — Moves a visible panel to the top of the stack
  • ncurses_typeahead — Specify different filedescriptor for typeahead checking
  • ncurses_ungetch — Put a character back into the input stream
  • ncurses_ungetmouse — Pushes mouse event to queue
  • ncurses_update_panels — Refreshes the virtual screen to reflect the relations between panels in the stack
  • ncurses_use_default_colors — Assign terminal default colors to color id -1
  • ncurses_use_env — Control use of environment information about terminal size
  • ncurses_use_extended_names — Control use of extended names in terminfo descriptions
  • ncurses_vidattr — Display the string on the terminal in the video attribute mode
  • ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long
  • ncurses_waddch — Adds character at current position in a window and advance cursor
  • ncurses_waddstr — Outputs text at current postion in window
  • ncurses_wattroff — Turns off attributes for a window
  • ncurses_wattron — Turns on attributes for a window
  • ncurses_wattrset — Set the attributes for a window
  • ncurses_wborder — Draws a border around the window using attributed characters
  • ncurses_wclear — Clears window
  • ncurses_wcolor_set — Sets windows color pairings
  • ncurses_werase — Erase window contents
  • ncurses_wgetch — Reads a character from keyboard (window)
  • ncurses_whline — Draws a horizontal line in a window at current position using an attributed character and max. n characters long
  • ncurses_wmouse_trafo — Transforms window/stdscr coordinates
  • ncurses_wmove — Moves windows output position
  • ncurses_wnoutrefresh — Copies window to virtual screen
  • ncurses_wrefresh — Refresh window on terminal screen
  • ncurses_wstandend — End standout mode for a window
  • ncurses_wstandout — Enter standout mode for a window
  • ncurses_wvline — Draws a vertical line in a window at current position using an attributed character and max. n characters long


Add character at current position and advance cursor

  • ? Ncurses 函数
  • ncurses_addchnstr ?
  • PHP Manual
  • Ncurses 函数
  • Add character at current position and advance cursor

ncurses_addch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addch — Add character at current position and advance cursor

说明

ncurses_addch ( int $ch ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

ch


Add attributed string with specified length at current position

  • ? ncurses_addch
  • ncurses_addchstr ?
  • PHP Manual
  • Ncurses 函数
  • Add attributed string with specified length at current position

ncurses_addchnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addchnstr — Add attributed string with specified length at current position

说明

ncurses_addchnstr ( string $s , int $n ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

s

n


Add attributed string at current position

  • ? ncurses_addchnstr
  • ncurses_addnstr ?
  • PHP Manual
  • Ncurses 函数
  • Add attributed string at current position

ncurses_addchstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addchstr — Add attributed string at current position

说明

ncurses_addchstr ( string $s ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

s


Add string with specified length at current position

  • ? ncurses_addchstr
  • ncurses_addstr ?
  • PHP Manual
  • Ncurses 函数
  • Add string with specified length at current position

ncurses_addnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addnstr — Add string with specified length at current position

说明

ncurses_addnstr ( string $s , int $n ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

s

n


Output text at current position

  • ? ncurses_addnstr
  • ncurses_assume_default_colors ?
  • PHP Manual
  • Ncurses 函数
  • Output text at current position

ncurses_addstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addstr — Output text at current position

说明

ncurses_addstr ( string $text ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

text


Define default colors for color 0

  • ? ncurses_addstr
  • ncurses_attroff ?
  • PHP Manual
  • Ncurses 函数
  • Define default colors for color 0

ncurses_assume_default_colors

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_assume_default_colors — Define default colors for color 0

说明

ncurses_assume_default_colors ( int $fg , int $bg ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

fg

bg


Turn off the given attributes

  • ? ncurses_assume_default_colors
  • ncurses_attron ?
  • PHP Manual
  • Ncurses 函数
  • Turn off the given attributes

ncurses_attroff

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attroff — Turn off the given attributes

说明

ncurses_attroff ( int $attributes ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

attributes


Turn on the given attributes

  • ? ncurses_attroff
  • ncurses_attrset ?
  • PHP Manual
  • Ncurses 函数
  • Turn on the given attributes

ncurses_attron

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attron — Turn on the given attributes

说明

ncurses_attron ( int $attributes ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

attributes


Set given attributes

  • ? ncurses_attron
  • ncurses_baudrate ?
  • PHP Manual
  • Ncurses 函数
  • Set given attributes

ncurses_attrset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attrset — Set given attributes

说明

ncurses_attrset ( int $attributes ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

attributes


Returns baudrate of terminal

  • ? ncurses_attrset
  • ncurses_beep ?
  • PHP Manual
  • Ncurses 函数
  • Returns baudrate of terminal

ncurses_baudrate

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_baudrate — Returns baudrate of terminal

说明

ncurses_baudrate ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Let the terminal beep

  • ? ncurses_baudrate
  • ncurses_bkgd ?
  • PHP Manual
  • Ncurses 函数
  • Let the terminal beep

ncurses_beep

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_beep — Let the terminal beep

说明

ncurses_beep ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

ncurses_beep() sends an audible alert (bell) and if its not possible flashes the screen.

参见

  • ncurses_flash() - Flash terminal screen (visual bell)


Set background property for terminal screen

  • ? ncurses_beep
  • ncurses_bkgdset ?
  • PHP Manual
  • Ncurses 函数
  • Set background property for terminal screen

ncurses_bkgd

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bkgd — Set background property for terminal screen

说明

ncurses_bkgd ( int $attrchar ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

attrchar


Control screen background

  • ? ncurses_bkgd
  • ncurses_border ?
  • PHP Manual
  • Ncurses 函数
  • Control screen background

ncurses_bkgdset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bkgdset — Control screen background

说明

ncurses_bkgdset ( int $attrchar ) : void
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

attrchar


Draw a border around the screen using attributed characters

  • ? ncurses_bkgdset
  • ncurses_bottom_panel ?
  • PHP Manual
  • Ncurses 函数
  • Draw a border around the screen using attributed characters

ncurses_border

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_border — Draw a border around the screen using attributed characters

说明

ncurses_border ( int $left , int $right , int $top , int $bottom , int $tl_corner , int $tr_corner , int $bl_corner , int $br_corner ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Draws the specified lines and corners around the main window.

Use ncurses_wborder() for borders around subwindows!

参数

Every parameter expects 0 to draw a line or 1 to skip it.

left

right

top

bottom

tl_corner

Top left corner

tr_corner

Top right corner

bl_corner

Bottom left corner

br_corner

Bottom right corner

参见

  • ncurses_wborder() - Draws a border around the window using attributed characters


Moves a visible panel to the bottom of the stack

  • ? ncurses_border
  • ncurses_can_change_color ?
  • PHP Manual
  • Ncurses 函数
  • Moves a visible panel to the bottom of the stack

ncurses_bottom_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bottom_panel — Moves a visible panel to the bottom of the stack

说明

ncurses_bottom_panel ( resource $panel ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

panel


Checks if terminal color definitions can be changed

  • ? ncurses_bottom_panel
  • ncurses_cbreak ?
  • PHP Manual
  • Ncurses 函数
  • Checks if terminal color definitions can be changed

ncurses_can_change_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_can_change_color — Checks if terminal color definitions can be changed

说明

ncurses_can_change_color ( ) : bool

Checks whether the terminal has color capabilities and whether the programmer can change color definitions using ncurses_init_color(). ncurses must be initialized using ncurses_init() before calling this function.

参数

此函数没有参数。

返回值

Return true if the programmer can change color definitions, false otherwise.

参见

  • ncurses_has_colors() - Checks if terminal has color capabilities
  • ncurses_init_color() - Define a terminal color
  • ncurses_start_color() - Initializes color functionality


Switch off input buffering

  • ? ncurses_can_change_color
  • ncurses_clear ?
  • PHP Manual
  • Ncurses 函数
  • Switch off input buffering

ncurses_cbreak

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_cbreak — Switch off input buffering

说明

ncurses_cbreak ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Disables line buffering and character processing (interrupt and flow control characters are unaffected), making characters typed by the user immediately available to the program.

返回值

Returns true or NCURSES_ERR if any error occurred.

参见

  • ncurses_nocbreak() - Switch terminal to cooked mode


Clear screen

  • ? ncurses_cbreak
  • ncurses_clrtobot ?
  • PHP Manual
  • Ncurses 函数
  • Clear screen

ncurses_clear

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clear — Clear screen

说明

ncurses_clear ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Clears the screen completely without setting blanks.

Note: ncurses_clear() clears the screen without setting blanks, which have the current background rendition. To clear screen with blanks, use ncurses_erase().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ncurses_erase() - Erase terminal screen


Clear screen from current position to bottom

  • ? ncurses_clear
  • ncurses_clrtoeol ?
  • PHP Manual
  • Ncurses 函数
  • Clear screen from current position to bottom

ncurses_clrtobot

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clrtobot — Clear screen from current position to bottom

说明

ncurses_clrtobot ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Erases all lines from cursor to end of screen and creates blanks. Blanks created by ncurses_clrtobot() have the current background rendition.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ncurses_clear() - Clear screen
  • ncurses_clrtoeol() - Clear screen from current position to end of line


Clear screen from current position to end of line

  • ? ncurses_clrtobot
  • ncurses_color_content ?
  • PHP Manual
  • Ncurses 函数
  • Clear screen from current position to end of line

ncurses_clrtoeol

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clrtoeol — Clear screen from current position to end of line

说明

ncurses_clrtoeol ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Erases the current line from cursor position to the end. Blanks created by ncurses_clrtoeol() have the current background rendition.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ncurses_clear() - Clear screen
  • ncurses_clrtobot() - Clear screen from current position to bottom


Retrieves RGB components of a color

  • ? ncurses_clrtoeol
  • ncurses_color_set ?
  • PHP Manual
  • Ncurses 函数
  • Retrieves RGB components of a color

ncurses_color_content

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_color_content — Retrieves RGB components of a color

说明

ncurses_color_content ( int $color , int &$r , int &$g , int &$b ) : int

Retrieves the red, green, and blue components for the given color definition. Terminal color capabilities must be initialized with ncurses_start_color() prior to calling this function.

参数

color

The number of the color to retrieve information for. May be one of the pre-defined color constants.

r

A reference to which to return the red component of the color. The value returned to the reference will be between 0 and 1000.

g

A reference to which to return the green component of the color. The value returned to the reference will be between 0 and 1000.

b

A reference to which to return the blue component of the color. The value returned to the reference will be between 0 and 1000.

返回值

Returns -1 if the function was successful, and 0 if ncurses or terminal color capabilities have not been initialized.

参见

  • ncurses_init_color() - Define a terminal color
  • ncurses_start_color() - Initializes color functionality


Set active foreground and background colors

  • ? ncurses_color_content
  • ncurses_curs_set ?
  • PHP Manual
  • Ncurses 函数
  • Set active foreground and background colors

ncurses_color_set

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_color_set — Set active foreground and background colors

说明

ncurses_color_set ( int $pair ) : int

Sets the active foreground and background colors. Any characters written after this function is invoked will have these colors. This function requires terminal colors to be supported and initialized using ncurses_start_color() beforehand.

ncurses uses color pairs to specify both foreground and background colors. Use ncurses_init_pair() to define a color pair.

参数

pair

The color pair from which to get the foreground and background colors to set as the active colors.

返回值

Returns -1 on success, and 0 on failure.

范例

Example #1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// If the terminal supports colors, initialize and set active color
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Write a string at specified location
ncurses_mvaddstr(10, 10, "Hello world! Yellow on blue text!");

// Flush output to screen
ncurses_refresh();

ncurses_end();
?>

参见

  • ncurses_init_pair() - Define a color pair
  • ncurses_start_color() - Initializes color functionality


Set cursor state

  • ? ncurses_color_set
  • ncurses_def_prog_mode ?
  • PHP Manual
  • Ncurses 函数
  • Set cursor state

ncurses_curs_set

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_curs_set — Set cursor state

说明

ncurses_curs_set ( int $visibility ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

visibility


Saves terminals (program) mode

  • ? ncurses_curs_set
  • ncurses_def_shell_mode ?
  • PHP Manual
  • Ncurses 函数
  • Saves terminals (program) mode

ncurses_def_prog_mode

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_def_prog_mode — Saves terminals (program) mode

说明

ncurses_def_prog_mode ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Saves the current terminal modes for program (in curses) for use by ncurses_reset_prog_mode().

返回值

Returns false on success, otherwise true.

参见

  • ncurses_reset_prog_mode() - Resets the prog mode saved by def_prog_mode


Saves terminals (shell) mode

  • ? ncurses_def_prog_mode
  • ncurses_define_key ?
  • PHP Manual
  • Ncurses 函数
  • Saves terminals (shell) mode

ncurses_def_shell_mode

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_def_shell_mode — Saves terminals (shell) mode

说明

ncurses_def_shell_mode ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Saves the current terminal modes for shell (not in curses) for use by ncurses_reset_shell_mode().

返回值

Returns false on success, true otherwise.

参见

  • ncurses_reset_shell_mode() - Resets the shell mode saved by def_shell_mode


Define a keycode

  • ? ncurses_def_shell_mode
  • ncurses_del_panel ?
  • PHP Manual
  • Ncurses 函数
  • Define a keycode

ncurses_define_key

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_define_key — Define a keycode

说明

ncurses_define_key ( string $definition , int $keycode ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

definition

keycode


Remove panel from the stack and delete it (but not the associated window)

  • ? ncurses_define_key
  • ncurses_delay_output ?
  • PHP Manual
  • Ncurses 函数
  • Remove panel from the stack and delete it (but not the associated window)

ncurses_del_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_del_panel — Remove panel from the stack and delete it (but not the associated window)

说明

ncurses_del_panel ( resource $panel ) : bool
Warning

本函数还未编写文档，仅有参数列表。

参数

panel


Delay output on terminal using padding characters

  • ? ncurses_del_panel
  • ncurses_delch ?
  • PHP Manual
  • Ncurses 函数
  • Delay output on terminal using padding characters

ncurses_delay_output

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delay_output — Delay output on terminal using padding characters

说明

ncurses_delay_output ( int $milliseconds ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

milliseconds


Delete character at current position, move rest of line left

  • ? ncurses_delay_output
  • ncurses_deleteln ?
  • PHP Manual
  • Ncurses 函数
  • Delete character at current position, move rest of line left

ncurses_delch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delch — Delete character at current position, move rest of line left

说明

ncurses_delch ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Deletes the character under the cursor. All characters to the right of the cursor on the same line are moved to the left one position and the last character on the line is filled with a blank. The cursor position does not change.

返回值

Returns false on success, true otherwise.

参见

  • ncurses_deleteln() - Delete line at current position, move rest of screen up


Delete line at current position, move rest of screen up

  • ? ncurses_delch
  • ncurses_delwin ?
  • PHP Manual
  • Ncurses 函数
  • Delete line at current position, move rest of screen up

ncurses_deleteln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_deleteln — Delete line at current position, move rest of screen up

说明

ncurses_deleteln ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Deletes the current line under cursor position. All lines below the current line are moved up one line. The bottom line of window is cleared. Cursor position does not change.

返回值

Returns false on success, otherwise true.

参见

  • ncurses_delch() - Delete character at current position, move rest of line left


Delete a ncurses window

  • ? ncurses_deleteln
  • ncurses_doupdate ?
  • PHP Manual
  • Ncurses 函数
  • Delete a ncurses window

ncurses_delwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delwin — Delete a ncurses window

说明

ncurses_delwin ( resource $window ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

window


Write all prepared refreshes to terminal

  • ? ncurses_delwin
  • ncurses_echo ?
  • PHP Manual
  • Ncurses 函数
  • Write all prepared refreshes to terminal

ncurses_doupdate

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_doupdate — Write all prepared refreshes to terminal

说明

ncurses_doupdate ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Compares the virtual screen to the physical screen and updates the physical screen. This way is more effective than using multiple refresh calls.

返回值

成功时返回 true， 或者在失败时返回 false。


Activate keyboard input echo

  • ? ncurses_doupdate
  • ncurses_echochar ?
  • PHP Manual
  • Ncurses 函数
  • Activate keyboard input echo

ncurses_echo

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_echo — Activate keyboard input echo

说明

ncurses_echo ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Enables echo mode. All characters typed by user are echoed by ncurses_getch().

返回值

Returns false on success, true if any error occurred.

参见

  • ncurses_noecho() - Switch off keyboard input echo to disable echo mode


Single character output including refresh

  • ? ncurses_echo
  • ncurses_end ?
  • PHP Manual
  • Ncurses 函数
  • Single character output including refresh

ncurses_echochar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_echochar — Single character output including refresh

说明

ncurses_echochar ( int $character ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

character


Stop using ncurses, clean up the screen

  • ? ncurses_echochar
  • ncurses_erase ?
  • PHP Manual
  • Ncurses 函数
  • Stop using ncurses, clean up the screen

ncurses_end

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_end — Stop using ncurses, clean up the screen

说明

ncurses_end ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Erase terminal screen

  • ? ncurses_end
  • ncurses_erasechar ?
  • PHP Manual
  • Ncurses 函数
  • Erase terminal screen

ncurses_erase

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_erase — Erase terminal screen

说明

ncurses_erase ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Fills the terminal screen with blanks.

Created blanks have the current background rendition, set by ncurses_bkgd().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ncurses_bkgd() - Set background property for terminal screen
  • ncurses_clear() - Clear screen


Returns current erase character

  • ? ncurses_erase
  • ncurses_filter ?
  • PHP Manual
  • Ncurses 函数
  • Returns current erase character

ncurses_erasechar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_erasechar — Returns current erase character

说明

ncurses_erasechar ( ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Returns the current erase character.

返回值

The current erase char, as a string.

参见

  • ncurses_killchar() - Returns current line kill character


Set LINES for iniscr() and newterm() to 1

  • ? ncurses_erasechar
  • ncurses_flash ?
  • PHP Manual
  • Ncurses 函数
  • Set LINES for iniscr() and newterm() to 1

ncurses_filter

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_filter — Set LINES for iniscr() and newterm() to 1

说明

ncurses_filter ( ) : void
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Flash terminal screen (visual bell)

  • ? ncurses_filter
  • ncurses_flushinp ?
  • PHP Manual
  • Ncurses 函数
  • Flash terminal screen (visual bell)

ncurses_flash

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_flash — Flash terminal screen (visual bell)

说明

ncurses_flash ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Flashes the screen, and if its not possible, sends an audible alert (bell).

返回值

Returns false on success, otherwise true.

参见

  • ncurses_beep() - Let the terminal beep


Flush keyboard input buffer

  • ? ncurses_flash
  • ncurses_getch ?
  • PHP Manual
  • Ncurses 函数
  • Flush keyboard input buffer

ncurses_flushinp

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_flushinp — Flush keyboard input buffer

说明

ncurses_flushinp ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Throws away any typeahead that has been typed and has not yet been read by your program.

返回值

Returns false on success, otherwise true.


Read a character from keyboard

  • ? ncurses_flushinp
  • ncurses_getmaxyx ?
  • PHP Manual
  • Ncurses 函数
  • Read a character from keyboard

ncurses_getch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getch — Read a character from keyboard

说明

ncurses_getch ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Returns the size of a window

  • ? ncurses_getch
  • ncurses_getmouse ?
  • PHP Manual
  • Ncurses 函数
  • Returns the size of a window

ncurses_getmaxyx

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getmaxyx — Returns the size of a window

说明

ncurses_getmaxyx ( resource $window , int &$y , int &$x ) : void
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Gets the horizontal and vertical size of the given window into the given variables.

Variables must be passed as reference, so they are updated when the user changes the terminal size.

参数

window

The measured window

y

This will be set to the window height

x

This will be set to the window width

返回值

没有返回值。


Reads mouse event

  • ? ncurses_getmaxyx
  • ncurses_getyx ?
  • PHP Manual
  • Ncurses 函数
  • Reads mouse event

ncurses_getmouse

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getmouse — Reads mouse event

说明

ncurses_getmouse ( array &$mevent ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

ncurses_getmouse() reads mouse event out of queue.

参数

mevent

Event options will be delivered in this parameter which has to be an array, passed by reference (see example below).

On success an associative array with following keys will be delivered:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

返回值

Returns false if a mouse event is actually visible in the given window, otherwise returns true.

范例

Example #1 ncurses_getmouse() example

<?php
switch (ncurses_getch()){
  case NCURSES_KEY_MOUSE:
    if (!ncurses_getmouse($mevent)){
      if ($mevent["mmask"] & NCURSES_MOUSE_BUTTON1_PRESSED){
        $mouse_x = $mevent["x"]; // Save mouse position
        $mouse_y = $mevent["y"];
      }
    }
  break;

  default:
    /* .... */
}
?>

参见

  • ncurses_ungetmouse() - Pushes mouse event to queue


Returns the current cursor position for a window

  • ? ncurses_getmouse
  • ncurses_halfdelay ?
  • PHP Manual
  • Ncurses 函数
  • Returns the current cursor position for a window

ncurses_getyx

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getyx — Returns the current cursor position for a window

说明

ncurses_getyx ( resource $window , int &$y , int &$x ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

window

y

x


Put terminal into halfdelay mode

  • ? ncurses_getyx
  • ncurses_has_colors ?
  • PHP Manual
  • Ncurses 函数
  • Put terminal into halfdelay mode

ncurses_halfdelay

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_halfdelay — Put terminal into halfdelay mode

说明

ncurses_halfdelay ( int $tenth ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

tenth


Checks if terminal has color capabilities

  • ? ncurses_halfdelay
  • ncurses_has_ic ?
  • PHP Manual
  • Ncurses 函数
  • Checks if terminal has color capabilities

ncurses_has_colors

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_colors — Checks if terminal has color capabilities

说明

ncurses_has_colors ( ) : bool

Checks whether the terminal has color capabilities. This function can be used to write terminal-independent programs. ncurses must be initialized using ncurses_init() before calling this function.

参数

此函数没有参数。

返回值

Return true if the terminal has color capabilities, false otherwise.

范例

Example #1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// If the terminal supports colors, initialize and set active color
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Write a string at specified location
ncurses_mvaddstr(10, 10, "Hello world! Yellow on blue text!");

// Flush output to screen
ncurses_refresh();

ncurses_end();
?>

参见

  • ncurses_can_change_color() - Checks if terminal color definitions can be changed
  • ncurses_start_color() - Initializes color functionality


Check for insert- and delete-capabilities

  • ? ncurses_has_colors
  • ncurses_has_il ?
  • PHP Manual
  • Ncurses 函数
  • Check for insert- and delete-capabilities

ncurses_has_ic

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_ic — Check for insert- and delete-capabilities

说明

ncurses_has_ic ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Checks whether the terminal has insert and delete capabilities.

返回值

Returns true if the terminal has insert/delete-capabilities, false otherwise.

参见

  • ncurses_has_il() - Check for line insert- and delete-capabilities


Check for line insert- and delete-capabilities

  • ? ncurses_has_ic
  • ncurses_has_key ?
  • PHP Manual
  • Ncurses 函数
  • Check for line insert- and delete-capabilities

ncurses_has_il

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_il — Check for line insert- and delete-capabilities

说明

ncurses_has_il ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Checks whether the terminal has insert- and delete-line-capabilities.

返回值

Returns true if the terminal has insert/delete-line capabilities, false otherwise.

参见

  • ncurses_has_ic() - Check for insert- and delete-capabilities


Check for presence of a function key on terminal keyboard

  • ? ncurses_has_il
  • ncurses_hide_panel ?
  • PHP Manual
  • Ncurses 函数
  • Check for presence of a function key on terminal keyboard

ncurses_has_key

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_key — Check for presence of a function key on terminal keyboard

说明

ncurses_has_key ( int $keycode ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

keycode


Remove panel from the stack, making it invisible

  • ? ncurses_has_key
  • ncurses_hline ?
  • PHP Manual
  • Ncurses 函数
  • Remove panel from the stack, making it invisible

ncurses_hide_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_hide_panel — Remove panel from the stack, making it invisible

说明

ncurses_hide_panel ( resource $panel ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

panel


Draw a horizontal line at current position using an attributed character and max. n characters long

  • ? ncurses_hide_panel
  • ncurses_inch ?
  • PHP Manual
  • Ncurses 函数
  • Draw a horizontal line at current position using an attributed character and max. n characters long

ncurses_hline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long

说明

ncurses_hline ( int $charattr , int $n ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

charattr

n


Get character and attribute at current position

  • ? ncurses_hline
  • ncurses_init_color ?
  • PHP Manual
  • Ncurses 函数
  • Get character and attribute at current position

ncurses_inch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_inch — Get character and attribute at current position

说明

ncurses_inch ( ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Returns the character from the current position.

返回值

Returns the character, as a string.


Define a terminal color

  • ? ncurses_inch
  • ncurses_init_pair ?
  • PHP Manual
  • Ncurses 函数
  • Define a terminal color

ncurses_init_color

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init_color — Define a terminal color

说明

ncurses_init_color ( int $color , int $r , int $g , int $b ) : int

Defines or redefines the given color. When this function is called, all occurrences of the given color on the screen, if any, immediately change to the new definition.

Color capabilities must be supported by the terminal and initialized using ncurses_start_color() prior to calling this function. In addition, the terminal must have color changing capabilities; use ncurses_can_change_color() to check for this.

参数

color

The identification number of the color to redefine. It may be one of the default color constants.

r

A color value, between 0 and 1000, for the red component.

g

A color value, between 0 and 1000, for the green component.

b

A color value, between 0 and 1000, for the blue component.

返回值

Returns -1 if the function was successful, and 0 if ncurses or terminal color capabilities have not been initialized or the terminal does not have color changing capabilities.

参见

  • ncurses_color_content() - Retrieves RGB components of a color
  • ncurses_start_color() - Initializes color functionality


Define a color pair

  • ? ncurses_init_color
  • ncurses_init ?
  • PHP Manual
  • Ncurses 函数
  • Define a color pair

ncurses_init_pair

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init_pair — Define a color pair

说明

ncurses_init_pair ( int $pair , int $fg , int $bg ) : int

Defines or redefines the given color pair to have the given foreground and background colors. If the color pair was previously initialized, the screen is refreshed and all occurrences of it are changed to reflect the new definition.

Color capabilities must be initialized using ncurses_start_color() before calling this function. The first color pair (color pair 0) is assumed to be white on black by default, but can be changed using ncurses_assume_default_colors().

参数

pair

The number of the color pair to define.

fg

The foreground color for the color pair. May be one of the pre-defined colors or one defined by ncurses_init_color() if the terminal has color changing capabilities.

bg

The background color for the color pair. May be one of the pre-defined colors or one defined by ncurses_init_color() if the terminal has color changing capabilities.

返回值

Returns -1 if the function was successful, and 0 if ncurses or color support were not initialized.

注释

Note that color changing capabilities are not required for defining color pairs of pre-existing colors, but only for changing definitions (red, green, and blue components) of colors themselves per ncurses_init_color().

范例

Example #1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// If the terminal supports colors, initialize and set active color
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Write a string at specified location
ncurses_mvaddstr(10, 10, "Hello world! Yellow on blue text!");

// Flush output to screen
ncurses_refresh();

ncurses_end();
?>

参见

  • ncurses_pair_content() - Retrieves foreground and background colors of a color pair
  • ncurses_start_color() - Initializes color functionality


Initialize ncurses

  • ? ncurses_init_pair
  • ncurses_insch ?
  • PHP Manual
  • Ncurses 函数
  • Initialize ncurses

ncurses_init

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init — Initialize ncurses

说明

ncurses_init ( ) : void

Initializes the ncurses interface. This function must be used before any other ncurses function call.

Note that ncurses_end() must be called before exiting from the program, or the terminal will not be restored to its proper non-visual mode.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • ncurses_end() - Stop using ncurses, clean up the screen


Insert character moving rest of line including character at current position

  • ? ncurses_init
  • ncurses_insdelln ?
  • PHP Manual
  • Ncurses 函数
  • Insert character moving rest of line including character at current position

ncurses_insch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insch — Insert character moving rest of line including character at current position

说明

ncurses_insch ( int $character ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

character


Insert lines before current line scrolling down (negative numbers delete and scroll up)

  • ? ncurses_insch
  • ncurses_insertln ?
  • PHP Manual
  • Ncurses 函数
  • Insert lines before current line scrolling down (negative numbers delete and scroll up)

ncurses_insdelln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)

说明

ncurses_insdelln ( int $count ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

count


Insert a line, move rest of screen down

  • ? ncurses_insdelln
  • ncurses_insstr ?
  • PHP Manual
  • Ncurses 函数
  • Insert a line, move rest of screen down

ncurses_insertln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insertln — Insert a line, move rest of screen down

说明

ncurses_insertln ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Inserts a new line above the current line. The bottom line will be lost.


Insert string at current position, moving rest of line right

  • ? ncurses_insertln
  • ncurses_instr ?
  • PHP Manual
  • Ncurses 函数
  • Insert string at current position, moving rest of line right

ncurses_insstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insstr — Insert string at current position, moving rest of line right

说明

ncurses_insstr ( string $text ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

text


Reads string from terminal screen

  • ? ncurses_insstr
  • ncurses_isendwin ?
  • PHP Manual
  • Ncurses 函数
  • Reads string from terminal screen

ncurses_instr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_instr — Reads string from terminal screen

说明

ncurses_instr ( string &$buffer ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Reads a string from the terminal screen and returns the number of characters read from the current character position until end of line.

参数

buffer

The characters. Attributes will be stripped.

返回值

Returns the number of characters.


Ncurses is in endwin mode, normal screen output may be performed

  • ? ncurses_instr
  • ncurses_keyok ?
  • PHP Manual
  • Ncurses 函数
  • Ncurses is in endwin mode, normal screen output may be performed

ncurses_isendwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed

说明

ncurses_isendwin ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Checks if ncurses is in endwin mode.

返回值

Returns true, if ncurses_end() has been called without any subsequent calls to ncurses_wrefresh(), false otherwise.

参见

  • ncurses_end() - Stop using ncurses, clean up the screen
  • ncurses_wrefresh() - Refresh window on terminal screen


Enable or disable a keycode

  • ? ncurses_isendwin
  • ncurses_keypad ?
  • PHP Manual
  • Ncurses 函数
  • Enable or disable a keycode

ncurses_keyok

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_keyok — Enable or disable a keycode

说明

ncurses_keyok ( int $keycode , bool $enable ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

keycode

enable


Turns keypad on or off

  • ? ncurses_keyok
  • ncurses_killchar ?
  • PHP Manual
  • Ncurses 函数
  • Turns keypad on or off

ncurses_keypad

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_keypad — Turns keypad on or off

说明

ncurses_keypad ( resource $window , bool $bf ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

bf


Returns current line kill character

  • ? ncurses_keypad
  • ncurses_longname ?
  • PHP Manual
  • Ncurses 函数
  • Returns current line kill character

ncurses_killchar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_killchar — Returns current line kill character

说明

ncurses_killchar ( ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Returns the current line kill character.

返回值

Returns the kill character, as a string.

参见

  • ncurses_erasechar() - Returns current erase character


Returns terminals description

  • ? ncurses_killchar
  • ncurses_meta ?
  • PHP Manual
  • Ncurses 函数
  • Returns terminals description

ncurses_longname

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_longname — Returns terminals description

说明

ncurses_longname ( ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Returns a verbose description of the terminal.

返回值

Returns the description, as a string truncated to 128 characters. On errors, returns null.

参见

  • ncurses_termname() - Returns terminals (short)-name


Enables/Disable 8-bit meta key information

  • ? ncurses_longname
  • ncurses_mouse_trafo ?
  • PHP Manual
  • Ncurses 函数
  • Enables/Disable 8-bit meta key information

ncurses_meta

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_meta — Enables/Disable 8-bit meta key information

说明

ncurses_meta ( resource $window , bool $8bit ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

8bit


Transforms coordinates

  • ? ncurses_meta
  • ncurses_mouseinterval ?
  • PHP Manual
  • Ncurses 函数
  • Transforms coordinates

ncurses_mouse_trafo

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mouse_trafo — Transforms coordinates

说明

ncurses_mouse_trafo ( int &$y , int &$x , bool $toscreen ) : bool
Warning

本函数还未编写文档，仅有参数列表。

参数

y

x

toscreen


Set timeout for mouse button clicks

  • ? ncurses_mouse_trafo
  • ncurses_mousemask ?
  • PHP Manual
  • Ncurses 函数
  • Set timeout for mouse button clicks

ncurses_mouseinterval

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mouseinterval — Set timeout for mouse button clicks

说明

ncurses_mouseinterval ( int $milliseconds ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

milliseconds


Sets mouse options

  • ? ncurses_mouseinterval
  • ncurses_move_panel ?
  • PHP Manual
  • Ncurses 函数
  • Sets mouse options

ncurses_mousemask

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mousemask — Sets mouse options

说明

ncurses_mousemask ( int $newmask , int &$oldmask ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Sets mouse events to be reported. By default no mouse events will be reported.

Mouse events are represented by NCURSES_KEY_MOUSE in the ncurses_wgetch() input stream. To read the event data and pop the event of queue, call ncurses_getmouse().

参数

newmask

Mouse mask options can be set with the following predefined constants:

  • NCURSES_BUTTON1_PRESSED

  • NCURSES_BUTTON1_RELEASED

  • NCURSES_BUTTON1_CLICKED

  • NCURSES_BUTTON1_DOUBLE_CLICKED

  • NCURSES_BUTTON1_TRIPLE_CLICKED

  • NCURSES_BUTTON2_PRESSED

  • NCURSES_BUTTON2_RELEASED

  • NCURSES_BUTTON2_CLICKED

  • NCURSES_BUTTON2_DOUBLE_CLICKED

  • NCURSES_BUTTON2_TRIPLE_CLICKED

  • NCURSES_BUTTON3_PRESSED

  • NCURSES_BUTTON3_RELEASED

  • NCURSES_BUTTON3_CLICKED

  • NCURSES_BUTTON3_DOUBLE_CLICKED

  • NCURSES_BUTTON3_TRIPLE_CLICKED

  • NCURSES_BUTTON4_PRESSED

  • NCURSES_BUTTON4_RELEASED

  • NCURSES_BUTTON4_CLICKED

  • NCURSES_BUTTON4_DOUBLE_CLICKED

  • NCURSES_BUTTON4_TRIPLE_CLICKED

  • NCURSES_BUTTON_SHIFT>

  • NCURSES_BUTTON_CTRL

  • NCURSES_BUTTON_ALT

  • NCURSES_ALL_MOUSE_EVENTS

  • NCURSES_REPORT_MOUSE_POSITION

As a side effect, setting a zero mousemask in newmask turns off the mouse pointer. Setting a non zero value turns mouse pointer on.

oldmask

This will be set to the previous value of the mouse event mask.

返回值

Returns the mask of reportable events. On complete failure, it returns 0.

范例

Example #1 ncurses_mousemask() example

<?php
$newmask = NCURSES_BUTTON1_CLICKED + NCURSES_BUTTON1_RELEASED;
$mask = ncurses_mousemask($newmask, $oldmask);
if ($mask & $newmask){
    printf("All specified mouse options will be supported\n");
}
?>

参见

  • ncurses_getch() - Read a character from keyboard
  • ncurses_getmouse() - Reads mouse event
  • ncurses_ungetmouse() - Pushes mouse event to queue


Moves a panel so that its upper-left corner is at [startx, starty]

  • ? ncurses_mousemask
  • ncurses_move ?
  • PHP Manual
  • Ncurses 函数
  • Moves a panel so that its upper-left corner is at [startx, starty]

ncurses_move_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_move_panel — Moves a panel so that its upper-left corner is at [startx, starty]

说明

ncurses_move_panel ( resource $panel , int $startx , int $starty ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

panel

startx

starty


Move output position

  • ? ncurses_move_panel
  • ncurses_mvaddch ?
  • PHP Manual
  • Ncurses 函数
  • Move output position

ncurses_move

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_move — Move output position

说明

ncurses_move ( int $y , int $x ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x


Move current position and add character

  • ? ncurses_move
  • ncurses_mvaddchnstr ?
  • PHP Manual
  • Ncurses 函数
  • Move current position and add character

ncurses_mvaddch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddch — Move current position and add character

说明

ncurses_mvaddch ( int $y , int $x , int $c ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x

c


Move position and add attributed string with specified length

  • ? ncurses_mvaddch
  • ncurses_mvaddchstr ?
  • PHP Manual
  • Ncurses 函数
  • Move position and add attributed string with specified length

ncurses_mvaddchnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddchnstr — Move position and add attributed string with specified length

说明

ncurses_mvaddchnstr ( int $y , int $x , string $s , int $n ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x

s

n


Move position and add attributed string

  • ? ncurses_mvaddchnstr
  • ncurses_mvaddnstr ?
  • PHP Manual
  • Ncurses 函数
  • Move position and add attributed string

ncurses_mvaddchstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddchstr — Move position and add attributed string

说明

ncurses_mvaddchstr ( int $y , int $x , string $s ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x

s


Move position and add string with specified length

  • ? ncurses_mvaddchstr
  • ncurses_mvaddstr ?
  • PHP Manual
  • Ncurses 函数
  • Move position and add string with specified length

ncurses_mvaddnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddnstr — Move position and add string with specified length

说明

ncurses_mvaddnstr ( int $y , int $x , string $s , int $n ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x

s

n


Move position and add string

  • ? ncurses_mvaddnstr
  • ncurses_mvcur ?
  • PHP Manual
  • Ncurses 函数
  • Move position and add string

ncurses_mvaddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddstr — Move position and add string

说明

ncurses_mvaddstr ( int $y , int $x , string $s ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x

s


Move cursor immediately

  • ? ncurses_mvaddstr
  • ncurses_mvdelch ?
  • PHP Manual
  • Ncurses 函数
  • Move cursor immediately

ncurses_mvcur

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvcur — Move cursor immediately

说明

ncurses_mvcur ( int $old_y , int $old_x , int $new_y , int $new_x ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

old_y

old_x

new_y

new_x


Move position and delete character, shift rest of line left

  • ? ncurses_mvcur
  • ncurses_mvgetch ?
  • PHP Manual
  • Ncurses 函数
  • Move position and delete character, shift rest of line left

ncurses_mvdelch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvdelch — Move position and delete character, shift rest of line left

说明

ncurses_mvdelch ( int $y , int $x ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x


Move position and get character at new position

  • ? ncurses_mvdelch
  • ncurses_mvhline ?
  • PHP Manual
  • Ncurses 函数
  • Move position and get character at new position

ncurses_mvgetch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvgetch — Move position and get character at new position

说明

ncurses_mvgetch ( int $y , int $x ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x


Set new position and draw a horizontal line using an attributed character and max. n characters long

  • ? ncurses_mvgetch
  • ncurses_mvinch ?
  • PHP Manual
  • Ncurses 函数
  • Set new position and draw a horizontal line using an attributed character and max. n characters long

ncurses_mvhline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long

说明

ncurses_mvhline ( int $y , int $x , int $attrchar , int $n ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x

attrchar

n


Move position and get attributed character at new position

  • ? ncurses_mvhline
  • ncurses_mvvline ?
  • PHP Manual
  • Ncurses 函数
  • Move position and get attributed character at new position

ncurses_mvinch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvinch — Move position and get attributed character at new position

说明

ncurses_mvinch ( int $y , int $x ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x


Set new position and draw a vertical line using an attributed character and max. n characters long

  • ? ncurses_mvinch
  • ncurses_mvwaddstr ?
  • PHP Manual
  • Ncurses 函数
  • Set new position and draw a vertical line using an attributed character and max. n characters long

ncurses_mvvline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long

说明

ncurses_mvvline ( int $y , int $x , int $attrchar , int $n ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

y

x

attrchar

n


Add string at new position in window

  • ? ncurses_mvvline
  • ncurses_napms ?
  • PHP Manual
  • Ncurses 函数
  • Add string at new position in window

ncurses_mvwaddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvwaddstr — Add string at new position in window

说明

ncurses_mvwaddstr ( resource $window , int $y , int $x , string $text ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

window

y

x

text


Sleep

  • ? ncurses_mvwaddstr
  • ncurses_new_panel ?
  • PHP Manual
  • Ncurses 函数
  • Sleep

ncurses_napms

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_napms — Sleep

说明

ncurses_napms ( int $milliseconds ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

milliseconds


Create a new panel and associate it with window

  • ? ncurses_napms
  • ncurses_newpad ?
  • PHP Manual
  • Ncurses 函数
  • Create a new panel and associate it with window

ncurses_new_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_new_panel — Create a new panel and associate it with window

说明

ncurses_new_panel ( resource $window ) : resource
Warning

本函数还未编写文档，仅有参数列表。

参数

window


Creates a new pad (window)

  • ? ncurses_new_panel
  • ncurses_newwin ?
  • PHP Manual
  • Ncurses 函数
  • Creates a new pad (window)

ncurses_newpad

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_newpad — Creates a new pad (window)

说明

ncurses_newpad ( int $rows , int $cols ) : resource
Warning

本函数还未编写文档，仅有参数列表。

参数

rows

cols


Create a new window

  • ? ncurses_newpad
  • ncurses_nl ?
  • PHP Manual
  • Ncurses 函数
  • Create a new window

ncurses_newwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_newwin — Create a new window

说明

ncurses_newwin ( int $rows , int $cols , int $y , int $x ) : resource
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Creates a new window to draw elements in.

When creating additional windows, remember to use ncurses_getmaxyx() to check for available space, as terminal size is individual and may vary.

参数

rows

Number of rows

cols

Number of columns

y

y-coordinate of the origin

x

x-coordinate of the origin

返回值

Returns a resource ID for the new window.


Translate newline and carriage return / line feed

  • ? ncurses_newwin
  • ncurses_nocbreak ?
  • PHP Manual
  • Ncurses 函数
  • Translate newline and carriage return / line feed

ncurses_nl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nl — Translate newline and carriage return / line feed

说明

ncurses_nl ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Switch terminal to cooked mode

  • ? ncurses_nl
  • ncurses_noecho ?
  • PHP Manual
  • Ncurses 函数
  • Switch terminal to cooked mode

ncurses_nocbreak

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nocbreak — Switch terminal to cooked mode

说明

ncurses_nocbreak ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Returns terminal to normal (cooked) mode. Initially the terminal may or may not be in cbreak mode as the mode is inherited. Therefore a program should call ncurses_cbreak() and ncurses_nocbreak() explicitly.

返回值

Returns true if any error occurred, otherwise false.

参见

  • ncurses_cbreak() - Switch off input buffering


Switch off keyboard input echo

  • ? ncurses_nocbreak
  • ncurses_nonl ?
  • PHP Manual
  • Ncurses 函数
  • Switch off keyboard input echo

ncurses_noecho

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noecho — Switch off keyboard input echo

说明

ncurses_noecho ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Prevents echoing of user typed characters.

返回值

Returns true if any error occurred, false otherwise.

参见

  • ncurses_echo() - Activate keyboard input echo
  • ncurses_getch() - Read a character from keyboard


Do not translate newline and carriage return / line feed

  • ? ncurses_noecho
  • ncurses_noqiflush ?
  • PHP Manual
  • Ncurses 函数
  • Do not translate newline and carriage return / line feed

ncurses_nonl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nonl — Do not translate newline and carriage return / line feed

说明

ncurses_nonl ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Do not flush on signal characters

  • ? ncurses_nonl
  • ncurses_noraw ?
  • PHP Manual
  • Ncurses 函数
  • Do not flush on signal characters

ncurses_noqiflush

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noqiflush — Do not flush on signal characters

说明

ncurses_noqiflush ( ) : void
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Switch terminal out of raw mode

  • ? ncurses_noqiflush
  • ncurses_pair_content ?
  • PHP Manual
  • Ncurses 函数
  • Switch terminal out of raw mode

ncurses_noraw

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noraw — Switch terminal out of raw mode

说明

ncurses_noraw ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Switches the terminal out of raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The difference is that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal.

返回值

Returns true if any error occurred, otherwise false.

参见

  • ncurses_raw() - Switch terminal into raw mode
  • ncurses_cbreak() - Switch off input buffering
  • ncurses_nocbreak() - Switch terminal to cooked mode


Retrieves foreground and background colors of a color pair

  • ? ncurses_noraw
  • ncurses_panel_above ?
  • PHP Manual
  • Ncurses 函数
  • Retrieves foreground and background colors of a color pair

ncurses_pair_content

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_pair_content — Retrieves foreground and background colors of a color pair

说明

ncurses_pair_content ( int $pair , int &$f , int &$b ) : int

Retrieves the foreground and background colors that constitute the given color pair. Terminal color capabilities must be initialized with ncurses_start_color() prior to calling this function.

参数

pair

The number of the color pair to retrieve information for.

f

A reference to which to return the foreground color of the color pair. The information returned will be a color number referring to one of the pre-defined colors or a color defined previously by ncurses_init_color() if the terminal supports color changing.

b

A reference to which to return the background color of the color pair. The information returned will be a color number referring to one of the pre-defined colors or a color defined previously by ncurses_init_color() if the terminal supports color changing.

返回值

Returns -1 if the function was successful, and 0 if ncurses or terminal color capabilities have not been initialized.

参见

  • ncurses_init_pair() - Define a color pair
  • ncurses_start_color() - Initializes color functionality


Returns the panel above panel

  • ? ncurses_pair_content
  • ncurses_panel_below ?
  • PHP Manual
  • Ncurses 函数
  • Returns the panel above panel

ncurses_panel_above

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_above — Returns the panel above panel

说明

ncurses_panel_above ( resource $panel ) : resource
Warning

本函数还未编写文档，仅有参数列表。

参数

panel

返回值

If panel is null, returns the bottom panel in the stack.


Returns the panel below panel

  • ? ncurses_panel_above
  • ncurses_panel_window ?
  • PHP Manual
  • Ncurses 函数
  • Returns the panel below panel

ncurses_panel_below

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_below — Returns the panel below panel

说明

ncurses_panel_below ( resource $panel ) : resource
Warning

本函数还未编写文档，仅有参数列表。

参数

panel

参数

If panel is null, returns the top panel in the stack.


Returns the window associated with panel

  • ? ncurses_panel_below
  • ncurses_pnoutrefresh ?
  • PHP Manual
  • Ncurses 函数
  • Returns the window associated with panel

ncurses_panel_window

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_window — Returns the window associated with panel

说明

ncurses_panel_window ( resource $panel ) : resource
Warning

本函数还未编写文档，仅有参数列表。

参数

panel


Copies a region from a pad into the virtual screen

  • ? ncurses_panel_window
  • ncurses_prefresh ?
  • PHP Manual
  • Ncurses 函数
  • Copies a region from a pad into the virtual screen

ncurses_pnoutrefresh

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_pnoutrefresh — Copies a region from a pad into the virtual screen

说明

ncurses_pnoutrefresh ( resource $pad , int $pminrow , int $pmincol , int $sminrow , int $smincol , int $smaxrow , int $smaxcol ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

pad

pminrow

pmincol

sminrow

smincol

smaxrow

smaxcol


Copies a region from a pad into the virtual screen

  • ? ncurses_pnoutrefresh
  • ncurses_putp ?
  • PHP Manual
  • Ncurses 函数
  • Copies a region from a pad into the virtual screen

ncurses_prefresh

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_prefresh — Copies a region from a pad into the virtual screen

说明

ncurses_prefresh ( resource $pad , int $pminrow , int $pmincol , int $sminrow , int $smincol , int $smaxrow , int $smaxcol ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

pad

pminrow

pmincol

sminrow

smincol

smaxrow

smaxcol


Apply padding information to the string and output it

  • ? ncurses_prefresh
  • ncurses_qiflush ?
  • PHP Manual
  • Ncurses 函数
  • Apply padding information to the string and output it

ncurses_putp

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_putp — Apply padding information to the string and output it

说明

ncurses_putp ( string $text ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

text


Flush on signal characters

  • ? ncurses_putp
  • ncurses_raw ?
  • PHP Manual
  • Ncurses 函数
  • Flush on signal characters

ncurses_qiflush

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_qiflush — Flush on signal characters

说明

ncurses_qiflush ( ) : void
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Switch terminal into raw mode

  • ? ncurses_qiflush
  • ncurses_refresh ?
  • PHP Manual
  • Ncurses 函数
  • Switch terminal into raw mode

ncurses_raw

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_raw — Switch terminal into raw mode

说明

ncurses_raw ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Places the terminal in raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The difference is that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal.

返回值

Returns true if any error occurred, otherwise false.

参见

  • ncurses_noraw() - Switch terminal out of raw mode
  • ncurses_cbreak() - Switch off input buffering
  • ncurses_nocbreak() - Switch terminal to cooked mode


Refresh screen

  • ? ncurses_raw
  • ncurses_replace_panel ?
  • PHP Manual
  • Ncurses 函数
  • Refresh screen

ncurses_refresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_refresh — Refresh screen

说明

ncurses_refresh ( int $ch ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

ch


Replaces the window associated with panel

  • ? ncurses_refresh
  • ncurses_reset_prog_mode ?
  • PHP Manual
  • Ncurses 函数
  • Replaces the window associated with panel

ncurses_replace_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_replace_panel — Replaces the window associated with panel

说明

ncurses_replace_panel ( resource $panel , resource $window ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

panel

window


Resets the prog mode saved by def_prog_mode

  • ? ncurses_replace_panel
  • ncurses_reset_shell_mode ?
  • PHP Manual
  • Ncurses 函数
  • Resets the prog mode saved by def_prog_mode

ncurses_reset_prog_mode

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_reset_prog_mode — Resets the prog mode saved by def_prog_mode

说明

ncurses_reset_prog_mode ( ) : int
Warning

本函数还未编写文档，仅有参数列表。


Resets the shell mode saved by def_shell_mode

  • ? ncurses_reset_prog_mode
  • ncurses_resetty ?
  • PHP Manual
  • Ncurses 函数
  • Resets the shell mode saved by def_shell_mode

ncurses_reset_shell_mode

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_reset_shell_mode — Resets the shell mode saved by def_shell_mode

说明

ncurses_reset_shell_mode ( ) : int
Warning

本函数还未编写文档，仅有参数列表。


Restores saved terminal state

  • ? ncurses_reset_shell_mode
  • ncurses_savetty ?
  • PHP Manual
  • Ncurses 函数
  • Restores saved terminal state

ncurses_resetty

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_resetty — Restores saved terminal state

说明

ncurses_resetty ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Restores the terminal state, which was previously saved by calling ncurses_savetty().

返回值

Always returns false.

参见

  • ncurses_savetty() - Saves terminal state


Saves terminal state

  • ? ncurses_resetty
  • ncurses_scr_dump ?
  • PHP Manual
  • Ncurses 函数
  • Saves terminal state

ncurses_savetty

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_savetty — Saves terminal state

说明

ncurses_savetty ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Saves the current terminal state. The saved terminal state can be restored with ncurses_resetty().

返回值

Always returns false.

参见

  • ncurses_resetty() - Restores saved terminal state


Dump screen content to file

  • ? ncurses_savetty
  • ncurses_scr_init ?
  • PHP Manual
  • Ncurses 函数
  • Dump screen content to file

ncurses_scr_dump

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_dump — Dump screen content to file

说明

ncurses_scr_dump ( string $filename ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

filename


Initialize screen from file dump

  • ? ncurses_scr_dump
  • ncurses_scr_restore ?
  • PHP Manual
  • Ncurses 函数
  • Initialize screen from file dump

ncurses_scr_init

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_init — Initialize screen from file dump

说明

ncurses_scr_init ( string $filename ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

filename


Restore screen from file dump

  • ? ncurses_scr_init
  • ncurses_scr_set ?
  • PHP Manual
  • Ncurses 函数
  • Restore screen from file dump

ncurses_scr_restore

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_restore — Restore screen from file dump

说明

ncurses_scr_restore ( string $filename ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

filename


Inherit screen from file dump

  • ? ncurses_scr_restore
  • ncurses_scrl ?
  • PHP Manual
  • Ncurses 函数
  • Inherit screen from file dump

ncurses_scr_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_set — Inherit screen from file dump

说明

ncurses_scr_set ( string $filename ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

filename


Scroll window content up or down without changing current position

  • ? ncurses_scr_set
  • ncurses_show_panel ?
  • PHP Manual
  • Ncurses 函数
  • Scroll window content up or down without changing current position

ncurses_scrl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scrl — Scroll window content up or down without changing current position

说明

ncurses_scrl ( int $count ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

count


Places an invisible panel on top of the stack, making it visible

  • ? ncurses_scrl
  • ncurses_slk_attr ?
  • PHP Manual
  • Ncurses 函数
  • Places an invisible panel on top of the stack, making it visible

ncurses_show_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_show_panel — Places an invisible panel on top of the stack, making it visible

说明

ncurses_show_panel ( resource $panel ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

panel


Returns current soft label key attribute

  • ? ncurses_show_panel
  • ncurses_slk_attroff ?
  • PHP Manual
  • Ncurses 函数
  • Returns current soft label key attribute

ncurses_slk_attr

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attr — Returns current soft label key attribute

说明

ncurses_slk_attr ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Returns the current soft label key attribute.

返回值

The attribute, as an integer.


Turn off the given attributes for soft function-key labels

  • ? ncurses_slk_attr
  • ncurses_slk_attron ?
  • PHP Manual
  • Ncurses 函数
  • Turn off the given attributes for soft function-key labels

ncurses_slk_attroff

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attroff — Turn off the given attributes for soft function-key labels

说明

ncurses_slk_attroff ( int $intarg ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

intarg


Turn on the given attributes for soft function-key labels

  • ? ncurses_slk_attroff
  • ncurses_slk_attrset ?
  • PHP Manual
  • Ncurses 函数
  • Turn on the given attributes for soft function-key labels

ncurses_slk_attron

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attron — Turn on the given attributes for soft function-key labels

说明

ncurses_slk_attron ( int $intarg ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

intarg


Set given attributes for soft function-key labels

  • ? ncurses_slk_attron
  • ncurses_slk_clear ?
  • PHP Manual
  • Ncurses 函数
  • Set given attributes for soft function-key labels

ncurses_slk_attrset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attrset — Set given attributes for soft function-key labels

说明

ncurses_slk_attrset ( int $intarg ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

intarg


Clears soft labels from screen

  • ? ncurses_slk_attrset
  • ncurses_slk_color ?
  • PHP Manual
  • Ncurses 函数
  • Clears soft labels from screen

ncurses_slk_clear

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_clear — Clears soft labels from screen

说明

ncurses_slk_clear ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

The function ncurses_slk_clear() clears soft label keys from screen.

返回值

Returns true on errors, false otherwise.


Sets color for soft label keys

  • ? ncurses_slk_clear
  • ncurses_slk_init ?
  • PHP Manual
  • Ncurses 函数
  • Sets color for soft label keys

ncurses_slk_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_color — Sets color for soft label keys

说明

ncurses_slk_color ( int $intarg ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

intarg


Initializes soft label key functions

  • ? ncurses_slk_color
  • ncurses_slk_noutrefresh ?
  • PHP Manual
  • Ncurses 函数
  • Initializes soft label key functions

ncurses_slk_init

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_init — Initializes soft label key functions

说明

ncurses_slk_init ( int $format ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Initializes soft label key functions

This function must be called before ncurses_init() or ncurses_newwin() is called.

参数

format

If ncurses_init() eventually uses a line from stdscr to emulate the soft labels, then this parameter determines how the labels are arranged of the screen.

0 indicates a 3-2-3 arrangement of the labels, 1 indicates a 4-4 arrangement and 2 indicates the PC like 4-4-4 mode, but in addition an index line will be created.

返回值

成功时返回 true， 或者在失败时返回 false。


Copies soft label keys to virtual screen

  • ? ncurses_slk_init
  • ncurses_slk_refresh ?
  • PHP Manual
  • Ncurses 函数
  • Copies soft label keys to virtual screen

ncurses_slk_noutrefresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_noutrefresh — Copies soft label keys to virtual screen

说明

ncurses_slk_noutrefresh ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Copies soft label keys to screen

  • ? ncurses_slk_noutrefresh
  • ncurses_slk_restore ?
  • PHP Manual
  • Ncurses 函数
  • Copies soft label keys to screen

ncurses_slk_refresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_refresh — Copies soft label keys to screen

说明

ncurses_slk_refresh ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Copies soft label keys from virtual screen to physical screen.


Restores soft label keys

  • ? ncurses_slk_refresh
  • ncurses_slk_set ?
  • PHP Manual
  • Ncurses 函数
  • Restores soft label keys

ncurses_slk_restore

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_restore — Restores soft label keys

说明

ncurses_slk_restore ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Restores the soft label keys after ncurses_slk_clear() has been performed.


Sets function key labels

  • ? ncurses_slk_restore
  • ncurses_slk_touch ?
  • PHP Manual
  • Ncurses 函数
  • Sets function key labels

ncurses_slk_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_set — Sets function key labels

说明

ncurses_slk_set ( int $labelnr , string $label , int $format ) : bool
Warning

本函数还未编写文档，仅有参数列表。

参数

labelnr

label

format


Forces output when ncurses_slk_noutrefresh is performed

  • ? ncurses_slk_set
  • ncurses_standend ?
  • PHP Manual
  • Ncurses 函数
  • Forces output when ncurses_slk_noutrefresh is performed

ncurses_slk_touch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_touch — Forces output when ncurses_slk_noutrefresh is performed

说明

ncurses_slk_touch ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Forces all the soft labels to be output the next time a ncurses_slk_noutrefresh() is performed.


Stop using 'standout' attribute

  • ? ncurses_slk_touch
  • ncurses_standout ?
  • PHP Manual
  • Ncurses 函数
  • Stop using 'standout' attribute

ncurses_standend

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_standend — Stop using 'standout' attribute

说明

ncurses_standend ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Start using 'standout' attribute

  • ? ncurses_standend
  • ncurses_start_color ?
  • PHP Manual
  • Ncurses 函数
  • Start using 'standout' attribute

ncurses_standout

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_standout — Start using 'standout' attribute

说明

ncurses_standout ( ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Initializes color functionality

  • ? ncurses_standout
  • ncurses_termattrs ?
  • PHP Manual
  • Ncurses 函数
  • Initializes color functionality

ncurses_start_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_start_color — Initializes color functionality

说明

ncurses_start_color ( ) : int

Initializes color functionality in ncurses. This function must be called before any color manipulation functions are called and after ncurses_init() is called. It is good practice to call this function right after ncurses_init().

参数

此函数没有参数。

返回值

Returns 0 on success, or -1 if the color table could not be allocated or ncurses was not initialized.

范例

Example #1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// If the terminal supports colors, initialize and set active color
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Write a string at specified location
ncurses_mvaddstr(10, 10, "Hello world! Yellow on blue text!");

// Flush output to screen
ncurses_refresh();

ncurses_end();
?>

参见

  • ncurses_can_change_color() - Checks if terminal color definitions can be changed
  • ncurses_has_colors() - Checks if terminal has color capabilities


Returns a logical OR of all attribute flags supported by terminal

  • ? ncurses_start_color
  • ncurses_termname ?
  • PHP Manual
  • Ncurses 函数
  • Returns a logical OR of all attribute flags supported by terminal

ncurses_termattrs

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal

说明

ncurses_termattrs ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Returns terminals (short)-name

  • ? ncurses_termattrs
  • ncurses_timeout ?
  • PHP Manual
  • Ncurses 函数
  • Returns terminals (short)-name

ncurses_termname

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_termname — Returns terminals (short)-name

说明

ncurses_termname ( ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Returns terminals shortname.

返回值

Returns the shortname of the terminal, truncated to 14 characters. On errors, returns null.

参见

  • ncurses_longname() - Returns terminals description


Set timeout for special key sequences

  • ? ncurses_termname
  • ncurses_top_panel ?
  • PHP Manual
  • Ncurses 函数
  • Set timeout for special key sequences

ncurses_timeout

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_timeout — Set timeout for special key sequences

说明

ncurses_timeout ( int $millisec ) : void
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

millisec


Moves a visible panel to the top of the stack

  • ? ncurses_timeout
  • ncurses_typeahead ?
  • PHP Manual
  • Ncurses 函数
  • Moves a visible panel to the top of the stack

ncurses_top_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_top_panel — Moves a visible panel to the top of the stack

说明

ncurses_top_panel ( resource $panel ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

panel


Specify different filedescriptor for typeahead checking

  • ? ncurses_top_panel
  • ncurses_ungetch ?
  • PHP Manual
  • Ncurses 函数
  • Specify different filedescriptor for typeahead checking

ncurses_typeahead

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_typeahead — Specify different filedescriptor for typeahead checking

说明

ncurses_typeahead ( int $fd ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

fd


Put a character back into the input stream

  • ? ncurses_typeahead
  • ncurses_ungetmouse ?
  • PHP Manual
  • Ncurses 函数
  • Put a character back into the input stream

ncurses_ungetch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_ungetch — Put a character back into the input stream

说明

ncurses_ungetch ( int $keycode ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

keycode


Pushes mouse event to queue

  • ? ncurses_ungetch
  • ncurses_update_panels ?
  • PHP Manual
  • Ncurses 函数
  • Pushes mouse event to queue

ncurses_ungetmouse

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_ungetmouse — Pushes mouse event to queue

说明

ncurses_ungetmouse ( array $mevent ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Pushes a KEY_MOUSE event onto the input queue and associates with this event the given state data and screen-relative character cell coordinates, specified in mevent.

参数

mevent

An associative array specifying the event options:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

返回值

Returns false on success, true otherwise.

参见

  • ncurses_getmouse() - Reads mouse event


Refreshes the virtual screen to reflect the relations between panels in the stack

  • ? ncurses_ungetmouse
  • ncurses_use_default_colors ?
  • PHP Manual
  • Ncurses 函数
  • Refreshes the virtual screen to reflect the relations between panels in the stack

ncurses_update_panels

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_update_panels — Refreshes the virtual screen to reflect the relations between panels in the stack

说明

ncurses_update_panels ( ) : void
Warning

本函数还未编写文档，仅有参数列表。


Assign terminal default colors to color id -1

  • ? ncurses_update_panels
  • ncurses_use_env ?
  • PHP Manual
  • Ncurses 函数
  • Assign terminal default colors to color id -1

ncurses_use_default_colors

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_default_colors — Assign terminal default colors to color id -1

说明

ncurses_use_default_colors ( ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


Control use of environment information about terminal size

  • ? ncurses_use_default_colors
  • ncurses_use_extended_names ?
  • PHP Manual
  • Ncurses 函数
  • Control use of environment information about terminal size

ncurses_use_env

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_env — Control use of environment information about terminal size

说明

ncurses_use_env ( bool $flag ) : void
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

flag


Control use of extended names in terminfo descriptions

  • ? ncurses_use_env
  • ncurses_vidattr ?
  • PHP Manual
  • Ncurses 函数
  • Control use of extended names in terminfo descriptions

ncurses_use_extended_names

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_extended_names — Control use of extended names in terminfo descriptions

说明

ncurses_use_extended_names ( bool $flag ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

flag


Display the string on the terminal in the video attribute mode

  • ? ncurses_use_extended_names
  • ncurses_vline ?
  • PHP Manual
  • Ncurses 函数
  • Display the string on the terminal in the video attribute mode

ncurses_vidattr

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_vidattr — Display the string on the terminal in the video attribute mode

说明

ncurses_vidattr ( int $intarg ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

intarg


Draw a vertical line at current position using an attributed character and max. n characters long

  • ? ncurses_vidattr
  • ncurses_waddch ?
  • PHP Manual
  • Ncurses 函数
  • Draw a vertical line at current position using an attributed character and max. n characters long

ncurses_vline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long

说明

ncurses_vline ( int $charattr , int $n ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

charattr

n


Adds character at current position in a window and advance cursor

  • ? ncurses_vline
  • ncurses_waddstr ?
  • PHP Manual
  • Ncurses 函数
  • Adds character at current position in a window and advance cursor

ncurses_waddch

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_waddch — Adds character at current position in a window and advance cursor

说明

ncurses_waddch ( resource $window , int $ch ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

ch


Outputs text at current postion in window

  • ? ncurses_waddch
  • ncurses_wattroff ?
  • PHP Manual
  • Ncurses 函数
  • Outputs text at current postion in window

ncurses_waddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_waddstr — Outputs text at current postion in window

说明

ncurses_waddstr ( resource $window , string $str , int $n = ? ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

str

n


Turns off attributes for a window

  • ? ncurses_waddstr
  • ncurses_wattron ?
  • PHP Manual
  • Ncurses 函数
  • Turns off attributes for a window

ncurses_wattroff

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattroff — Turns off attributes for a window

说明

ncurses_wattroff ( resource $window , int $attrs ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

attrs


Turns on attributes for a window

  • ? ncurses_wattroff
  • ncurses_wattrset ?
  • PHP Manual
  • Ncurses 函数
  • Turns on attributes for a window

ncurses_wattron

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattron — Turns on attributes for a window

说明

ncurses_wattron ( resource $window , int $attrs ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

attrs


Set the attributes for a window

  • ? ncurses_wattron
  • ncurses_wborder ?
  • PHP Manual
  • Ncurses 函数
  • Set the attributes for a window

ncurses_wattrset

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattrset — Set the attributes for a window

说明

ncurses_wattrset ( resource $window , int $attrs ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

attrs


Draws a border around the window using attributed characters

  • ? ncurses_wattrset
  • ncurses_wclear ?
  • PHP Manual
  • Ncurses 函数
  • Draws a border around the window using attributed characters

ncurses_wborder

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wborder — Draws a border around the window using attributed characters

说明

ncurses_wborder ( resource $window , int $left , int $right , int $top , int $bottom , int $tl_corner , int $tr_corner , int $bl_corner , int $br_corner ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Draws the specified lines and corners around the passed window.

Use ncurses_border() for borders around the main window.

参数

Each parameter expects 0 to draw a line and 1 to skip it.

window

The window on which we operate

left

right

top

bottom

tl_corner

Top left corner

tr_corner

Top right corner

bl_corner

Bottom left corner

br_corner

Bottom right corner

参见

  • ncurses_border() - Draw a border around the screen using attributed characters


Clears window

  • ? ncurses_wborder
  • ncurses_wcolor_set ?
  • PHP Manual
  • Ncurses 函数
  • Clears window

ncurses_wclear

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wclear — Clears window

说明

ncurses_wclear ( resource $window ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window


Sets windows color pairings

  • ? ncurses_wclear
  • ncurses_werase ?
  • PHP Manual
  • Ncurses 函数
  • Sets windows color pairings

ncurses_wcolor_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wcolor_set — Sets windows color pairings

说明

ncurses_wcolor_set ( resource $window , int $color_pair ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

color_pair


Erase window contents

  • ? ncurses_wcolor_set
  • ncurses_wgetch ?
  • PHP Manual
  • Ncurses 函数
  • Erase window contents

ncurses_werase

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_werase — Erase window contents

说明

ncurses_werase ( resource $window ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window


Reads a character from keyboard (window)

  • ? ncurses_werase
  • ncurses_whline ?
  • PHP Manual
  • Ncurses 函数
  • Reads a character from keyboard (window)

ncurses_wgetch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wgetch — Reads a character from keyboard (window)

说明

ncurses_wgetch ( resource $window ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window


Draws a horizontal line in a window at current position using an attributed character and max. n characters long

  • ? ncurses_wgetch
  • ncurses_wmouse_trafo ?
  • PHP Manual
  • Ncurses 函数
  • Draws a horizontal line in a window at current position using an attributed character and max. n characters long

ncurses_whline

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_whline — Draws a horizontal line in a window at current position using an attributed character and max. n characters long

说明

ncurses_whline ( resource $window , int $charattr , int $n ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

charattr

n


Transforms window/stdscr coordinates

  • ? ncurses_whline
  • ncurses_wmove ?
  • PHP Manual
  • Ncurses 函数
  • Transforms window/stdscr coordinates

ncurses_wmouse_trafo

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wmouse_trafo — Transforms window/stdscr coordinates

说明

ncurses_wmouse_trafo ( resource $window , int &$y , int &$x , bool $toscreen ) : bool
Warning

本函数还未编写文档，仅有参数列表。

参数

window

x

y

toscreen


Moves windows output position

  • ? ncurses_wmouse_trafo
  • ncurses_wnoutrefresh ?
  • PHP Manual
  • Ncurses 函数
  • Moves windows output position

ncurses_wmove

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wmove — Moves windows output position

说明

ncurses_wmove ( resource $window , int $y , int $x ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

y

x


Copies window to virtual screen

  • ? ncurses_wmove
  • ncurses_wrefresh ?
  • PHP Manual
  • Ncurses 函数
  • Copies window to virtual screen

ncurses_wnoutrefresh

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wnoutrefresh — Copies window to virtual screen

说明

ncurses_wnoutrefresh ( resource $window ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window


Refresh window on terminal screen

  • ? ncurses_wnoutrefresh
  • ncurses_wstandend ?
  • PHP Manual
  • Ncurses 函数
  • Refresh window on terminal screen

ncurses_wrefresh

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wrefresh — Refresh window on terminal screen

说明

ncurses_wrefresh ( resource $window ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。

参数

window


End standout mode for a window

  • ? ncurses_wrefresh
  • ncurses_wstandout ?
  • PHP Manual
  • Ncurses 函数
  • End standout mode for a window

ncurses_wstandend

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wstandend — End standout mode for a window

说明

ncurses_wstandend ( resource $window ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window


Enter standout mode for a window

  • ? ncurses_wstandend
  • ncurses_wvline ?
  • PHP Manual
  • Ncurses 函数
  • Enter standout mode for a window

ncurses_wstandout

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wstandout — Enter standout mode for a window

说明

ncurses_wstandout ( resource $window ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window


Draws a vertical line in a window at current position using an attributed character and max. n characters long

  • ? ncurses_wstandout
  • Readline ?
  • PHP Manual
  • Ncurses 函数
  • Draws a vertical line in a window at current position using an attributed character and max. n characters long

ncurses_wvline

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wvline — Draws a vertical line in a window at current position using an attributed character and max. n characters long

说明

ncurses_wvline ( resource $window , int $charattr , int $n ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

window

charattr

n


GNU Readline

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Readline 函数
    • readline_add_history — 添加一行命令行历史记录
    • readline_callback_handler_install — 初始化一个 readline 回调接口，然后终端输出提示信息并立即返回
    • readline_callback_handler_remove — 移除上一个安装的回调函数句柄并且恢复终端设置
    • readline_callback_read_char — 当一个行被接收时读取一个字符并且通知 readline 调用回调函数
    • readline_clear_history — 清除历史
    • readline_completion_function — 注册一个完成函数
    • readline_info — 获取/设置readline内部的各个变量
    • readline_list_history — 获取命令历史列表
    • readline_on_new_line — 通知readline将光标移动到新行
    • readline_read_history — 读取命令历史
    • readline_redisplay — 重绘显示区
    • readline_write_history — 写入历史记录
    • readline — 读取一行


简介

readline 扩展函数实现了访问 GNU Readline 库的接口. 这些函数提供了可编辑的命令行. 一个例子是在 Bash 中允许你使用箭头按键来插入字符或者翻看历史命令. 因为这个库的交互特性，这个功能在你写的 Web 程序中没多大用处， 但是当你写的脚本被用在命令行中时非常有用.

从PHP 7.1.0 开始，这个扩展在Windows上也可用。

Caution

readline扩展并非线程安全的！因此，在任何真线程安全的SAPI（例如Apache的mod_winnt）中使用这个扩展是非常不推荐的！


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Readline
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

如果要使用 readline 函数，你必须安装 libreadline. 你能在 GNU readline 项目主页找到 libreadline. 地址» http://cnswww.cns.cwru.edu/~chet/readline/rltop.html . 它被 Chet Ramey 维护， 他也是 Bash 的作者

你也能使用非 GPL 的 libedit 库来替代 readline 库， libedit 库是使用 BSD 证书，你可以从» http://www.thrysoee.dk/editline/下载.


安装

要使用这些函数，你必须在编译 PHP 的 CGI 或者 CLI 版本时启用 readline 支持. 你需要在编译配置 PHP 时使用 --with-readline[=DIR]选项. 如果你想使用 libedit 来代替 readline , 配置 PHP 时使用 --with-libedit[=DIR]选项


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Readline 配置选项
名字 | 默认 | 可修改范围 | 更新日志
cli.pager | "" | PHP_INI_ALL | 自 PHP 5.4.0 可用.
cli.prompt | "\\b \\> " | PHP_INI_ALL | 自 PHP 5.4.0 可用.

这是配置指令的简短说明。

cli.pager string

External tool to display output from command line.

cli.prompt string

命令行 提示.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

READLINE_LIB (string)
The library which is used for readline support; currently either readline or libedit. Available as of PHP 5.5.0.


Readline 函数

Table of Contents

  • readline_add_history — 添加一行命令行历史记录
  • readline_callback_handler_install — 初始化一个 readline 回调接口，然后终端输出提示信息并立即返回
  • readline_callback_handler_remove — 移除上一个安装的回调函数句柄并且恢复终端设置
  • readline_callback_read_char — 当一个行被接收时读取一个字符并且通知 readline 调用回调函数
  • readline_clear_history — 清除历史
  • readline_completion_function — 注册一个完成函数
  • readline_info — 获取/设置readline内部的各个变量
  • readline_list_history — 获取命令历史列表
  • readline_on_new_line — 通知readline将光标移动到新行
  • readline_read_history — 读取命令历史
  • readline_redisplay — 重绘显示区
  • readline_write_history — 写入历史记录
  • readline — 读取一行


添加一行命令行历史记录

  • ? Readline 函数
  • readline_callback_handler_install ?
  • PHP Manual
  • Readline 函数
  • 添加一行命令行历史记录

readline_add_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_add_history — 添加一行命令行历史记录

说明

readline_add_history ( string $line ) : bool

这个函数添加一行到命令行历史记录 This function adds a line to the command line history.

参数

line

这一行将被添加到历史.

返回值

成功时返回 true， 或者在失败时返回 false。


初始化一个 readline 回调接口，然后终端输出提示信息并立即返回

  • ? readline_add_history
  • readline_callback_handler_remove ?
  • PHP Manual
  • Readline 函数
  • 初始化一个 readline 回调接口，然后终端输出提示信息并立即返回

readline_callback_handler_install

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_callback_handler_install — 初始化一个 readline 回调接口，然后终端输出提示信息并立即返回

说明

readline_callback_handler_install ( string $prompt , callable $callback ) : bool

设置一个 readline 回调接口然后输出 prompt 并立即返回. 第二次调用这个函数不需要移除上一个回调接口，这个函数将自动覆盖旧的接口.

当配合 stream_select() 时回调的特性非常有用，它允许在 IO 与用户输入 间交叉进行，不像readline().

参数

prompt

提示信息.

callback

callback 函数需要一个参数; 用户输入将被返回.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Readline Callback Interface Example

<?php
function rl_callback($ret)
{
    global $c, $prompting;

    echo "You entered: $ret\n";
    $c++;

    if ($c > 10) {
        $prompting = false;
        readline_callback_handler_remove();
    } else {
        readline_callback_handler_install("[$c] Enter something: ", 'rl_callback');
    }
}

$c = 1;
$prompting = true;

readline_callback_handler_install("[$c] Enter something: ", 'rl_callback');

while ($prompting) {
    $w = NULL;
    $e = NULL;
    $n = stream_select($r = array(STDIN), $w, $e, null);
    if ($n && in_array(STDIN, $r)) {
        // read a character, will call the callback when a newline is entered
        readline_callback_read_char();
    }
}

echo "Prompting disabled. All done.\n";
?>

参见

  • readline_callback_handler_remove() - 移除上一个安装的回调函数句柄并且恢复终端设置
  • readline_callback_read_char() - 当一个行被接收时读取一个字符并且通知 readline 调用回调函数
  • stream_select() - Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec


移除上一个安装的回调函数句柄并且恢复终端设置

  • ? readline_callback_handler_install
  • readline_callback_read_char ?
  • PHP Manual
  • Readline 函数
  • 移除上一个安装的回调函数句柄并且恢复终端设置

readline_callback_handler_remove

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_callback_handler_remove — 移除上一个安装的回调函数句柄并且恢复终端设置

说明

readline_callback_handler_remove ( ) : bool

移除上一个安装的回调函数句柄并且恢复终端设置.

返回值

如果上一个被安装的回调函数句柄被移出返回 true 否则 false 如果没有找到的话.

范例

See readline_callback_handler_install() for an example of how to use the readline callback interface.

参见

  • readline_callback_handler_install() - 初始化一个 readline 回调接口，然后终端输出提示信息并立即返回
  • readline_callback_read_char() - 当一个行被接收时读取一个字符并且通知 readline 调用回调函数


当一个行被接收时读取一个字符并且通知 readline 调用回调函数

  • ? readline_callback_handler_remove
  • readline_clear_history ?
  • PHP Manual
  • Readline 函数
  • 当一个行被接收时读取一个字符并且通知 readline 调用回调函数

readline_callback_read_char

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_callback_read_char — 当一个行被接收时读取一个字符并且通知 readline 调用回调函数

说明

readline_callback_read_char ( ) : void

读取用户输入中的一个字符.当一行被接收时，这个函数将通知 readline 调用使用 readline_callback_handler_install() 安装的回调函数接口，并且 这一个行已经准备输入.

返回值

没有返回值。

范例

See readline_callback_handler_install() for an example of how to use the readline callback interface.

参见

  • readline_callback_handler_install() - 初始化一个 readline 回调接口，然后终端输出提示信息并立即返回
  • readline_callback_handler_remove() - 移除上一个安装的回调函数句柄并且恢复终端设置


清除历史

  • ? readline_callback_read_char
  • readline_completion_function ?
  • PHP Manual
  • Readline 函数
  • 清除历史

readline_clear_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_clear_history — 清除历史

说明

readline_clear_history ( ) : bool

这个函数清除整个的命令行历史.

返回值

成功时返回 true， 或者在失败时返回 false。


注册一个完成函数

  • ? readline_clear_history
  • readline_info ?
  • PHP Manual
  • Readline 函数
  • 注册一个完成函数

readline_completion_function

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_completion_function — 注册一个完成函数

说明

readline_completion_function ( callable $function ) : bool

这个函数注册一个完成函数.这就像你在使用 Bash 时按 tab 键时你想要的功能一样

参数

function

你必须提供一个已经存在的函数的名字并且可以接受命令行中的部分输入 然后返回一些可能匹配的数组.

返回值

成功时返回 true， 或者在失败时返回 false。


获取/设置readline内部的各个变量

  • ? readline_completion_function
  • readline_list_history ?
  • PHP Manual
  • Readline 函数
  • 获取/设置readline内部的各个变量

readline_info

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_info — 获取/设置readline内部的各个变量

说明

readline_info ( string $varname = ? , string $newvalue = ? ) : mixed

获取/设置readline内部的各个变量.

参数

varname

变量名.

newvalue

如果提供，将被设置成这个值.

返回值

如果调用时没有参数，这个函数将返回一个包括了所有已采用的readline设置的数组. 数组元素将索引是以下这些值：done, end, erase_empty_line, library_version, line_buffer, mark, pending_input, point, prompt, readline_name, and terminal_name.

如果调用是提供了一个或两个参数，原来的值将被返回.


获取命令历史列表

  • ? readline_info
  • readline_on_new_line ?
  • PHP Manual
  • Readline 函数
  • 获取命令历史列表

readline_list_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_list_history — 获取命令历史列表

说明

readline_list_history ( ) : array

获取整个命令行历史.

返回值

返回整个命令行历史的数组.元素的整数索引从零开始


通知readline将光标移动到新行

  • ? readline_list_history
  • readline_read_history ?
  • PHP Manual
  • Readline 函数
  • 通知readline将光标移动到新行

readline_on_new_line

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_on_new_line — 通知readline将光标移动到新行

说明

readline_on_new_line ( ) : void

告诉readline将光标移动到新行.

返回值

没有返回值。


读取命令历史

  • ? readline_on_new_line
  • readline_redisplay ?
  • PHP Manual
  • Readline 函数
  • 读取命令历史

readline_read_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_read_history — 读取命令历史

说明

readline_read_history ( string $filename = ? ) : bool

这个函数从一个文件读取命令历史

参数

filename

保存了命令历史的文件的路径.

返回值

成功时返回 true， 或者在失败时返回 false。


重绘显示区

  • ? readline_read_history
  • readline_write_history ?
  • PHP Manual
  • Readline 函数
  • 重绘显示区

readline_redisplay

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

readline_redisplay — 重绘显示区

说明

readline_redisplay ( ) : void

readline 重绘用于重绘显示区

返回值

没有返回值。


写入历史记录

  • ? readline_redisplay
  • readline ?
  • PHP Manual
  • Readline 函数
  • 写入历史记录

readline_write_history

(PHP 4, PHP 5, PHP 7, PHP 8)

readline_write_history — 写入历史记录

说明

readline_write_history ( string $filename = ? ) : bool

这个函数将命令历史写入到一个文件.

参数

filename

保存文件的路径.

返回值

成功时返回 true， 或者在失败时返回 false。


读取一行

  • ? readline_write_history
  • 压缩与归档扩展 ?
  • PHP Manual
  • Readline 函数
  • 读取一行

readline

(PHP 4, PHP 5, PHP 7, PHP 8)

readline — 读取一行

说明

readline ( string $prompt = ? ) : string

从用户端读取一行.你必须自己使用 readline_add_history() 将这一行添加到历史记录中

参数

prompt

你可以指定一个字符串来作为用户的提示信息

返回值

从用户端返回一个行字符串.返回的该行的行尾换行符会被删除

范例

Example #1 readline() Example

<?php
//get 3 commands from user
for ($i=0; $i < 3; $i++) {
        $line = readline("Command: ");
        readline_add_history($line);
}

//dump history
print_r(readline_list_history());

//dump variables
print_r(readline_info());
?>


压缩与归档扩展

  • Bzip2
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Bzip2 函数
  • LZF
    • 简介
    • 安装／配置
    • 预定义常量
    • LZF 函数
  • Phar
    • 简介
    • 安装／配置
    • 预定义常量
    • Using Phar Archives
    • Creating Phar Archives
    • What makes a phar a phar and not a tar or a zip?
    • Phar — The Phar class
    • PharData — The PharData class
    • PharFileInfo — The PharFileInfo class
    • PharException — The PharException class
  • Rar — Rar Archiving
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Rar 函数
    • RarArchive — The RarArchive class
    • RarEntry — The RarEntry class
    • RarException — The RarException class
  • Zip
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • ZipArchive — ZipArchive 类
    • Zip 函数
  • Zlib — Zlib Compression
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Zlib 函数
    • DeflateContext — The DeflateContext class
    • InflateContext — The InflateContext class


Bzip2

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Bzip2 函数
    • bzclose — 关闭一个 bzip2 文件
    • bzcompress — 把一个字符串压缩成 bzip2 编码数据
    • bzdecompress — 解压经 bzip2 编码过的数据
    • bzerrno — 返回一个 bzip2 错误码
    • bzerror — 返回包含 bzip2 错误号和错误字符串的一个 array
    • bzerrstr — 返回一个 bzip2 的错误字符串
    • bzflush — 强制写入所有写缓冲区的数据
    • bzopen — 打开 bzip2 压缩文件
    • bzread — bzip2 文件二进制安全地读取
    • bzwrite — 二进制安全地写入 bzip2 文件


  • ? Bzip2
  • 安装／配置 ?
  • PHP Manual
  • Bzip2
  • 简介

简介

bzip2 函数用于透明地读写 bzip2（.bz2）压缩文件。


需求

本模块使用了 Julian Seward 的 » bzip2 库中的函数。本模块需要 bzip2/libbzip2 版本 >= 1.0.x。


安装

PHP 的 Bzip2 支持默认未打开。编译 PHP 时需要 --with-bz2[=DIR] 配置选项来激活 bzip2 支持。


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

本扩展定义了一种资源类型：用于识别和操作 bz2 文件的指针。


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • Bzip2
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

该范例打开一个临时文件并写入了一个测试字符串，然后输出该文件里的内容。

Example #1 bzip2 小例子

<?php

$filename = "/tmp/testfile.bz2";
$str = "This is a test string.\n";

// 打开一个文件用于写入
$bz = bzopen($filename, "w");

// 写入字符串到文件
bzwrite($bz, $str);

// 关闭文件
bzclose($bz);

// 打开文件用于读取
$bz = bzopen($filename, "r");

// 读取 10 个字符
echo bzread($bz, 10);

// 输出直到文件末尾（或者后面的 1024 个字符），并关闭。
echo bzread($bz);

bzclose($bz);

?>


Bzip2 函数

Table of Contents

  • bzclose — 关闭一个 bzip2 文件
  • bzcompress — 把一个字符串压缩成 bzip2 编码数据
  • bzdecompress — 解压经 bzip2 编码过的数据
  • bzerrno — 返回一个 bzip2 错误码
  • bzerror — 返回包含 bzip2 错误号和错误字符串的一个 array
  • bzerrstr — 返回一个 bzip2 的错误字符串
  • bzflush — 强制写入所有写缓冲区的数据
  • bzopen — 打开 bzip2 压缩文件
  • bzread — bzip2 文件二进制安全地读取
  • bzwrite — 二进制安全地写入 bzip2 文件


关闭一个 bzip2 文件

  • ? Bzip2 函数
  • bzcompress ?
  • PHP Manual
  • Bzip2 函数
  • 关闭一个 bzip2 文件

bzclose

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzclose — 关闭一个 bzip2 文件

说明

bzclose ( resource $bz ) : bool

关闭给出的 bzip2 文件指针。

参数

bz

文件指针。它必须是有效的并且指向 bzopen() 成功打开的文件。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • bzopen() - 打开 bzip2 压缩文件


把一个字符串压缩成 bzip2 编码数据

  • ? bzclose
  • bzdecompress ?
  • PHP Manual
  • Bzip2 函数
  • 把一个字符串压缩成 bzip2 编码数据

bzcompress

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzcompress — 把一个字符串压缩成 bzip2 编码数据

说明

bzcompress ( string $source , int $blocksize = 4 , int $workfactor = 0 ) : mixed

bzcompress() 压缩了指定的字符串并以 bzip2 编码返回数据。

参数

source

待压缩的字符串。

blocksize

指定压缩时使用的块大小，应该是一个 1-9 的数字。9 可以有最高的压缩比，但会使用更多的资源。

workfactor

控制压缩阶段出现最坏的重复性高的情况下输入数据时的行为。 该值可以是在 0 至 250 之间，0是一个特殊的情况。

无论 workfactor是什么，产生的输出都是一致的。

返回值

压缩后的字符串，或者在出现错误时返回错误号。

范例

Example #1 压缩数据

<?php
$str = "sample data";
$bzstr = bzcompress($str, 9);
echo $bzstr;
?>

参见

  • bzdecompress() - 解压经 bzip2 编码过的数据


解压经 bzip2 编码过的数据

  • ? bzcompress
  • bzerrno ?
  • PHP Manual
  • Bzip2 函数
  • 解压经 bzip2 编码过的数据

bzdecompress

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzdecompress — 解压经 bzip2 编码过的数据

说明

bzdecompress ( string $source , int $small = 0 ) : mixed

bzdecompress() 解压了包含 bzip2 压缩数据的指定字符串。

参数

source

要解压的字符串。

small

如果为 true，将会使用一种内存开销更小的替代算法（最大内存需求降低至大约 2300K）但速度会降低约一半。

寻找该功能的更多信息可参见 » bzip2 文档。

返回值

解压后的字符串，如果发生了一个错误则返回一个错误码。

范例

Example #1 解压一个字符串

<?php
$start_str = "This is not an honest face?";
$bzstr = bzcompress($start_str);

echo "Compressed String: ";
echo $bzstr;
echo "\n<br />\n";

$str = bzdecompress($bzstr);
echo "Decompressed String: ";
echo $str;
echo "\n<br />\n";
?>

参见

  • bzcompress() - 把一个字符串压缩成 bzip2 编码数据


返回一个 bzip2 错误码

  • ? bzdecompress
  • bzerror ?
  • PHP Manual
  • Bzip2 函数
  • 返回一个 bzip2 错误码

bzerrno

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzerrno — 返回一个 bzip2 错误码

说明

bzerrno ( resource $bz ) : int

返回指定文件指针任意返回的 bzip2 错误的错误码。

参数

bz

文件指针。它必须是有效的并且指向 bzopen() 成功打开的文件。

返回值

返回 integer 的错误码。

参见

  • bzerror() - 返回包含 bzip2 错误号和错误字符串的一个 array
  • bzerrstr() - 返回一个 bzip2 的错误字符串


返回包含 bzip2 错误号和错误字符串的一个 array

  • ? bzerrno
  • bzerrstr ?
  • PHP Manual
  • Bzip2 函数
  • 返回包含 bzip2 错误号和错误字符串的一个 array

bzerror

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzerror — 返回包含 bzip2 错误号和错误字符串的一个 array

说明

bzerror ( resource $bz ) : array

返回文件指针中返回的 bzip2 错误的错误号和错误字符串。

参数

bz

文件指针。它必须是有效的并且指向 bzopen() 成功打开的文件。

返回值

返回一个关联数组，包含错误码于 errno 条目， 以及错误信息于 errstr 条目。

范例

Example #1 bzerror() 范例

<?php
$error = bzerror($bz);

echo $error["errno"];
echo $error["errstr"];
?>

参见

  • bzerrno() - 返回一个 bzip2 错误码
  • bzerrstr() - 返回一个 bzip2 的错误字符串


返回一个 bzip2 的错误字符串

  • ? bzerror
  • bzflush ?
  • PHP Manual
  • Bzip2 函数
  • 返回一个 bzip2 的错误字符串

bzerrstr

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzerrstr — 返回一个 bzip2 的错误字符串

说明

bzerrstr ( resource $bz ) : string

获取指定文件指针中返回 bzip2 任何错误的错误字符串。

参数

bz

文件指针。它必须是有效的并且指向 bzopen() 成功打开的文件。

返回值

返回包含错误信息的 string。

参见

  • bzerrno() - 返回一个 bzip2 错误码
  • bzerror() - 返回包含 bzip2 错误号和错误字符串的一个 array


强制写入所有写缓冲区的数据

  • ? bzerrstr
  • bzopen ?
  • PHP Manual
  • Bzip2 函数
  • 强制写入所有写缓冲区的数据

bzflush

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzflush — 强制写入所有写缓冲区的数据

说明

bzflush ( resource $bz ) : bool

强制写入 bzip2 文件指针 bz 的所有写缓冲数据。

参数

bz

文件指针。它必须是有效的并且指向 bzopen() 成功打开的文件。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • bzread() - bzip2 文件二进制安全地读取
  • bzwrite() - 二进制安全地写入 bzip2 文件


打开 bzip2 压缩文件

  • ? bzflush
  • bzread ?
  • PHP Manual
  • Bzip2 函数
  • 打开 bzip2 压缩文件

bzopen

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzopen — 打开 bzip2 压缩文件

说明

bzopen ( mixed $file , string $mode ) : resource

bzopen() 打开一个 bzip2（.bz2）文件用于读或写。

参数

file

待打开的文件的文件名，或者已经存在的资源流。

mode

支持 'r'（读）和 'w'（写）模式。 其他任何模式都会导致 bzopen() 返回 false。

返回值

如果打开失败，bzopen() 会返回 false，否则返回一个指向最新打开文件的指针。

范例

Example #1 bzopen() 范例

<?php

$file = "/tmp/foo.bz2";
$bz = bzopen($file, "r") or die("Couldn't open $file for reading");

bzclose($bz);

?>

参见

  • bzclose() - 关闭一个 bzip2 文件


bzip2 文件二进制安全地读取

  • ? bzopen
  • bzwrite ?
  • PHP Manual
  • Bzip2 函数
  • bzip2 文件二进制安全地读取

bzread

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzread — bzip2 文件二进制安全地读取

说明

bzread ( resource $bz , int $length = 1024 ) : string

bzread() 从指定的 bzip2 文件指针中读取数据。

读取到 length（未经压缩的长度）个字节，或者到文件尾，取决于先到哪个。

参数

bz

文件指针。它必须是有效的并且指向 bzopen() 成功打开的文件。

length

如果没有提供， bzread() 一次会读入 1024 个字节（未经压缩的长度）。 一次最大可读入 8192 个未压缩的字节。

返回值

返回解压的数据，在错误时返回 false。

范例

Example #1 bzread() 范例

<?php

$file = "/tmp/foo.bz2";
$bz = bzopen($file, "r") or die("Couldn't open $file");

$decompressed_file = '';
while (!feof($bz)) {
  $decompressed_file .= bzread($bz, 4096);
}
bzclose($bz);

echo "The contents of $file are: <br />\n";
echo $decompressed_file;

?>

参见

  • bzwrite() - 二进制安全地写入 bzip2 文件
  • feof() - 测试文件指针是否到了文件结束的位置
  • bzopen() - 打开 bzip2 压缩文件


二进制安全地写入 bzip2 文件

  • ? bzread
  • LZF ?
  • PHP Manual
  • Bzip2 函数
  • 二进制安全地写入 bzip2 文件

bzwrite

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

bzwrite — 二进制安全地写入 bzip2 文件

说明

bzwrite ( resource $bz , string $data , int $length = ? ) : int

bzwrite() 把字符串（string）写入了指定的 bzip2 文件流。

参数

bz

文件指针。它必须是有效的并且指向 bzopen() 成功打开的文件。

data

要写入的数据。

length

如果提供了这个参数，将仅仅写入 length（未压缩）个字节，若 data 小于该指定的长度则写入全部数据。

返回值

返回写入的数据字节数，错误时返回 false。

范例

Example #1 bzwrite() 范例

<?php
$str = "uncompressed data";
$bz = bzopen("/tmp/foo.bz2", "w");
bzwrite($bz, $str, strlen($str));
bzclose($bz);
?>

参见

  • bzread() - bzip2 文件二进制安全地读取
  • bzopen() - 打开 bzip2 压缩文件


LZF

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • LZF 函数
    • lzf_compress — LZF compression
    • lzf_decompress — LZF decompression
    • lzf_optimized_for — Determines what LZF extension was optimized for


简介

LZF is a very fast compression algorithm, ideal for saving space with only slight speed cost. It can be optimized for speed or space at the time of compilation. This extension is using » liblzf library by Marc Lehmann for its operations.


安装

此 » PECL 扩展未与 PHP 捆绑。 安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/lzf.

In order to use these functions you must compile PHP with lzf support by using the --with-lzf[=DIR] configure option. You may also pass --enable-lzf-better-compression to optimize LZF for space rather than speed.

Windows users will enable php_lzf.dll inside of php.ini in order to use these functions. PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


  • ? 资源类型
  • LZF 函数 ?
  • PHP Manual
  • LZF
  • 预定义常量

预定义常量

此扩展没有定义常量。


LZF 函数

Table of Contents

  • lzf_compress — LZF compression
  • lzf_decompress — LZF decompression
  • lzf_optimized_for — Determines what LZF extension was optimized for


LZF compression

  • ? LZF 函数
  • lzf_decompress ?
  • PHP Manual
  • LZF 函数
  • LZF compression

lzf_compress

(PECL lzf >= 0.1.0)

lzf_compress — LZF compression

说明

lzf_compress ( string $data ) : string

lzf_compress() compresses the given data string using LZF encoding.

参数

data

The string to compress.

返回值

Returns the compressed data or false if an error occurred.

参见

  • lzf_decompress() - LZF decompression


LZF decompression

  • ? lzf_compress
  • lzf_optimized_for ?
  • PHP Manual
  • LZF 函数
  • LZF decompression

lzf_decompress

(PECL lzf >= 0.1.0)

lzf_decompress — LZF decompression

说明

lzf_decompress ( string $data ) : string

lzf_compress() decompresses the given data string containing lzf encoded data.

参数

data

The compressed string.

返回值

Returns the decompressed data or false if an error occurred.

参见

  • lzf_compress() - LZF compression


Determines what LZF extension was optimized for

  • ? lzf_decompress
  • Phar ?
  • PHP Manual
  • LZF 函数
  • Determines what LZF extension was optimized for

lzf_optimized_for

(PECL lzf >= 1.0.0)

lzf_optimized_for — Determines what LZF extension was optimized for

说明

lzf_optimized_for ( ) : int

Determines what was LZF extension optimized for during compilation.

返回值

Returns 1 if LZF was optimized for speed, 0 for compression.


Phar

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Using Phar Archives
    • Using Phar Archives: Introduction
    • Using Phar Archives: the phar stream wrapper
    • Using Phar Archives: the Phar and PharData class
  • Creating Phar Archives
    • Creating Phar Archives: Introduction
  • What makes a phar a phar and not a tar or a zip?
    • Ingredients of all Phar archives, independent of file format
    • Phar file stub
    • Head-to-head comparison of Phar, Tar and Zip
    • Tar-based phars
    • Zip-based phars
    • Phar File Format
    • Global Phar bitmapped flags
    • Phar manifest file entry definition
    • Phar Signature format
  • Phar — The Phar class
    • Phar::addEmptyDir — 添加一个空目录到 phar 档案
    • Phar::addFile — 将一个文件从文件系统添加到 phar 档案中
    • Phar::addFromString — 以字符串的形式添加一个文件到 phar 档案
    • Phar::apiVersion — Returns the api version
    • Phar::buildFromDirectory — Construct a phar archive from the files within a directory
    • Phar::buildFromIterator — Construct a phar archive from an iterator
    • Phar::canCompress — Returns whether phar extension supports compression using either zlib or bzip2
    • Phar::canWrite — Returns whether phar extension supports writing and creating phars
    • Phar::compress — Compresses the entire Phar archive using Gzip or Bzip2 compression
    • Phar::compressFiles — Compresses all files in the current Phar archive
    • Phar::__construct — Construct a Phar archive object
    • Phar::convertToData — Convert a phar archive to a non-executable tar or zip file
    • Phar::convertToExecutable — Convert a phar archive to another executable phar archive file format
    • Phar::copy — Copy a file internal to the phar archive to another new file within the phar
    • Phar::count — Returns the number of entries (files) in the Phar archive
    • Phar::createDefaultStub — Create a phar-file format specific stub
    • Phar::decompress — Decompresses the entire Phar archive
    • Phar::decompressFiles — Decompresses all files in the current Phar archive
    • Phar::delMetadata — Deletes the global metadata of the phar
    • Phar::delete — 删除 phar 档案中的一个文件
    • Phar::extractTo — Extract the contents of a phar archive to a directory
    • Phar::getAlias — Get the alias for Phar
    • Phar::getMetadata — Returns phar archive meta-data
    • Phar::getModified — Return whether phar was modified
    • Phar::getPath — Get the real path to the Phar archive on disk
    • Phar::getSignature — Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive
    • Phar::getStub — Return the PHP loader or bootstrap stub of a Phar archive
    • Phar::getSupportedCompression — Return array of supported compression algorithms
    • Phar::getSupportedSignatures — Return array of supported signature types
    • Phar::getVersion — Return version info of Phar archive
    • Phar::hasMetadata — Returns whether phar has global meta-data
    • Phar::interceptFileFuncs — Instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions
    • Phar::isBuffering — Used to determine whether Phar write operations are being buffered, or are flushing directly to disk
    • Phar::isCompressed — Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
    • Phar::isFileFormat — Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter
    • Phar::isValidPharFilename — Returns whether the given filename is a valid phar filename
    • Phar::isWritable — Returns true if the phar archive can be modified
    • Phar::loadPhar — Loads any phar archive with an alias
    • Phar::mapPhar — Reads the currently executed file (a phar) and registers its manifest
    • Phar::mount — Mount an external path or file to a virtual location within the phar archive
    • Phar::mungServer — Defines a list of up to 4 $_SERVER variables that should be modified for execution
    • Phar::offsetExists — Determines whether a file exists in the phar
    • Phar::offsetGet — Gets a PharFileInfo object for a specific file
    • Phar::offsetSet — Set the contents of an internal file to those of an external file
    • Phar::offsetUnset — Remove a file from a phar
    • Phar::running — Returns the full path on disk or full phar URL to the currently executing Phar archive
    • Phar::setAlias — Set the alias for the Phar archive
    • Phar::setDefaultStub — Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader
    • Phar::setMetadata — Sets phar archive meta-data
    • Phar::setSignatureAlgorithm — Set the signature algorithm for a phar and apply it
    • Phar::setStub — Used to set the PHP loader or bootstrap stub of a Phar archive
    • Phar::startBuffering — Start buffering Phar write operations, do not modify the Phar object on disk
    • Phar::stopBuffering — Stop buffering write requests to the Phar archive, and save changes to disk
    • Phar::unlinkArchive — Completely remove a phar archive from disk and from memory
    • Phar::webPhar — mapPhar for web-based phars. front controller for web applications
  • PharData — The PharData class
    • PharData::addEmptyDir — Add an empty directory to the tar/zip archive
    • PharData::addFile — Add a file from the filesystem to the tar/zip archive
    • PharData::addFromString — Add a file from the filesystem to the tar/zip archive
    • PharData::buildFromDirectory — Construct a tar/zip archive from the files within a directory
    • PharData::buildFromIterator — Construct a tar or zip archive from an iterator
    • PharData::compress — Compresses the entire tar/zip archive using Gzip or Bzip2 compression
    • PharData::compressFiles — Compresses all files in the current tar/zip archive
    • PharData::__construct — Construct a non-executable tar or zip archive object
    • PharData::convertToData — Convert a phar archive to a non-executable tar or zip file
    • PharData::convertToExecutable — Convert a non-executable tar/zip archive to an executable phar archive
    • PharData::copy — Copy a file internal to the phar archive to another new file within the phar
    • PharData::decompress — Decompresses the entire Phar archive
    • PharData::decompressFiles — Decompresses all files in the current zip archive
    • PharData::delMetadata — Deletes the global metadata of a zip archive
    • PharData::delete — Delete a file within a tar/zip archive
    • PharData::extractTo — Extract the contents of a tar/zip archive to a directory
    • PharData::isWritable — Returns true if the tar/zip archive can be modified
    • PharData::offsetSet — Set the contents of a file within the tar/zip to those of an external file or string
    • PharData::offsetUnset — Remove a file from a tar/zip archive
    • PharData::setAlias — Dummy function (Phar::setAlias is not valid for PharData)
    • PharData::setDefaultStub — Dummy function (Phar::setDefaultStub is not valid for PharData)
    • PharData::setMetadata — Sets phar archive meta-data
    • PharData::setSignatureAlgorithm — Set the signature algorithm for a phar and apply it
    • PharData::setStub — Dummy function (Phar::setStub is not valid for PharData)
  • PharFileInfo — The PharFileInfo class
    • PharFileInfo::chmod — Sets file-specific permission bits
    • PharFileInfo::compress — Compresses the current Phar entry with either zlib or bzip2 compression
    • PharFileInfo::__construct — Construct a Phar entry object
    • PharFileInfo::decompress — Decompresses the current Phar entry within the phar
    • PharFileInfo::delMetadata — Deletes the metadata of the entry
    • PharFileInfo::getCRC32 — Returns CRC32 code or throws an exception if CRC has not been verified
    • PharFileInfo::getCompressedSize — Returns the actual size of the file (with compression) inside the Phar archive
    • PharFileInfo::getContent — Get the complete file contents of the entry
    • PharFileInfo::getMetadata — Returns file-specific meta-data saved with a file
    • PharFileInfo::getPharFlags — Returns the Phar file entry flags
    • PharFileInfo::hasMetadata — Returns the metadata of the entry
    • PharFileInfo::isCRCChecked — Returns whether file entry has had its CRC verified
    • PharFileInfo::isCompressed — Returns whether the entry is compressed
    • PharFileInfo::setMetadata — Sets file-specific meta-data saved with a file
  • PharException — The PharException class


简介

The phar extension provides a way to put entire PHP applications into a single file called a "phar" (PHP Archive) for easy distribution and installation. In addition to providing this service, the phar extension also provides a file-format abstraction method for creating and manipulating tar and zip files through the PharData class, much as PDO provides a unified interface for accessing different databases. Unlike PDO, which cannot convert between different databases, Phar also can convert between tar, zip and phar file formats with a single line of code. see Phar::convertToExecutable() for one example.

What is phar? Phar archives are best characterized as a convenient way to group several files into a single file. As such, a phar archive provides a way to distribute a complete PHP application in a single file and run it from that file without the need to extract it to disk. Additionally, phar archives can be executed by PHP as easily as any other file, both on the commandline and from a web server. Phar is kind of like a thumb drive for PHP applications.

Phar implements this functionality through a Stream Wrapper. Normally, to use an external file within a PHP script, you would use include

Example #1 Using an external file

<?php
 include '/path/to/external/file.php';
 ?>

PHP can be thought of as actually translating /path/to/external/file.php into a stream wrapper as file:///path/to/external/file.php, and under the hood it does in fact use the plain file stream wrapper stream functions to access all local files.

To use a file named file.php contained with a phar archive /path/to/myphar.phar, the syntax is very similar to the file:// syntax above.

Example #2 Using a file within a phar archive

<?php
 include 'phar:///path/to/myphar.phar/file.php';
 ?>

In fact, one can treat a phar archive exactly as if it were an external disk, using any of fopen()-related functions, opendir() and mkdir()-related functions to read, change, or create new files and directories within the phar archive. This allows complete PHP applications to be distributed in a single file and run directly from that file.

The most common usage for a phar archive is to distribute a complete application in a single file. For instance, the PEAR Installer that is bundled with PHP versions is distributed as a phar archive. To use a phar archive distributed in this way, the archive can be executed on the command-line or via a web server.

Phar archives can be distributed as tar archives, zip archives, or as the custom phar file format designed specifically for the phar extension. Each file format has advantages and disadvantages. The tar and zip file formats can be read or extracted by any third-party tool that can read the format, but require the phar extension in order to run with PHP. The phar file format is customized and unique to the phar extension, and can only be created by the phar extension or the PEAR package » PHP_Archive, but has the advantage that applications created in this format will run even if the phar extension is not enabled.

In other words, even with the phar extension disabled, one can execute or include a phar-based archive. Accessing individual files within a phar archive is only possible with the phar extension unless the phar archive was created by PHP_Archive.

The phar extension is also capable of converting a phar archive from tar to zip or to phar file format in a single command:

Example #3 Converting a phar archive from phar to tar file format

<?php
 $phar = new Phar('myphar.phar');
 $pgz = $phar->convertToExecutable(Phar::TAR, Phar::GZ); // makes myphar.phar.tar.gz
 ?>

Phar can compress individual files or an entire archive using gzip compression or bzip2 compression, and can verify archive integrity automatically through the use of MD5, SHA-1, SHA-256 or SHA-512 signatures.

Lastly, the Phar extension is security-conscious, and disables write access to executable phar archives by default, and requires system-level disabling of the phar.readonly php.ini setting in order to create or modify phar archives. Normal tar and zip archives without an executable stub can always be created or modified using the PharData class.

If you are creating applications for distribution, you will want to read How to create Phar Archives. If you want more information on the differences between the three file formats that phar supports, you should read Phar, Tar and Zip.

If you are using phar applications, there are helpful tips in How to use Phar Archives

The word phar is a portmanteau of PHP and Archive and is based loosely on the jar (Java Archive) familiar to Java developers.

The implementation for Phar archives is based on the PEAR package » PHP_Archive, and the implementation details are similar, although the Phar extension is much more powerful. In addition, the Phar extension allows most PHP applications to be run unmodified while PHP_Archive-based phar archives often require extensive modification in order to work.


需求

Phar requires PHP 5.2.0 or newer. Additional features require the SPL extension in order to take advantage of iteration and array access to a Phar's file contents. The phar stream does not require any additional extensions to function.

You may optionally wish to enable the zlib and bzip2 extensions to take advantage of compressed phar support. In addition, to take advantage of OpenSSL signing, the OpenSSL extension must be enabled.

Note that a bug in the zlib.deflate stream filter fixed in PHP version 5.2.6 and newer may cause truncation of gzip and bzip2-compressed phar archives.

PHP 5.3 configured with --enable-zend-multibyte makes phar dependant on the ini option detect_unicode.


安装

自 PHP 版本 5.3.0 Phar 扩展成为了内置的组件。在之前的版本，Phar 可以通过 PECL 扩展安装 » Phar PECL 页面 包含了历史以及更多信息。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Filesystem and Streams Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
phar.readonly | "1" | PHP_INI_ALL |
phar.require_hash | "1" | PHP_INI_ALL |
phar.cache_list | "" | PHP_INI_SYSTEM |

这是配置指令的简短说明。

phar.readonly bool

This option disables creation or modification of Phar archives using the phar stream or Phar object's write support. This setting should always be enabled on production machines, as the phar extension's convenient write support could allow straightforward creation of a php-based virus when coupled with other common security vulnerabilities.

Note:

This setting can only be unset in php.ini due to security reasons. If phar.readonly is disabled in php.ini, the user may enable phar.readonly in a script or disable it later. If phar.readonly is enabled in php.ini, a script may harmlessly "re-enable" the INI variable, but may not disable it.

phar.require_hash bool

This option will force all opened Phar archives to contain some kind of signature (currently MD5, SHA1, SHA256, SHA512 and OpenSSL are supported), and will refuse to process any Phar archive that does not contain a signature.

Note:

This setting can only be unset in php.ini. If phar.require_hash is disabled in php.ini, the user may enable phar.require_hash in a script or disable it later. If phar.require_hash is enabled in php.ini, a script may harmlessly "re-enable" the INI variable, but may not disable it.

This setting does not affect reading plain tar files with the PharData class.

Caution

phar.require_hash does not provide any security per se, it is merely a measure against running accidentially corrupted Phar archives, because anyone who would be able to tamper with the Phar could easily fix the signature afterwards.

phar.cache_list string

Allows mapping phar archives to be pre-parsed at web server startup, providing a performance improvement that brings running files out of a phar archive very close to the speed of running those files from a traditional disk-based installation.

Example #1 phar.cache_list usage example

in php.ini (windows):
phar.cache_list =C:\path\to\phar1.phar;C:\path\to\phar2.phar
in php.ini (unix):
phar.cache_list =/path/to/phar1.phar:/path/to/phar2.phar


资源类型

The Phar extension provides the phar stream, which allows accessing files contained within a phar transparently. See also the description of the Phar file format.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Phar compression constants
Constant | Value | Description
Phar::NONE (int) | 0x00000000 | no compression
Phar::COMPRESSED (int) | 0x0000F000 | bitmask that can be used with file flags to determine if any compression is present
Phar::GZ (int) | 0x00001000 | zlib (gzip) compression
Phar::BZ2 (int) | 0x00002000 | bzip2 compression
Phar file format constants
Constant | Value | Description
Phar::PHAR (int) | 1 | phar file format
Phar::TAR (int) | 2 | tar file format
Phar::ZIP (int) | 3 | zip file format
Phar signature constants
Constant | Value | Description
Phar::MD5 (int) | 0x0001 | signature with md5 hash algorithm
Phar::SHA1 (int) | 0x0002 | signature with sha1 hash algorithm
Phar::SHA256 (int) | 0x0003 | signature with sha256 hash algorithm (requires hash extension)
Phar::SHA512 (int) | 0x0004 | signature with sha512 hash algorithm (requires hash extension)
Phar::OPENSSL (int) | 0x0010 | signature with OpenSSL public/private key pair. This is a true, asymmetric key signature.
Phar webPhar mime override constants
Constant | Value | Description
Phar::PHP (int) | 0 | used to instruct the mimeoverrides parameter of Phar::webPhar() that the extension should be parsed as a PHP file
Phar::PHPS (int) | 1 | used to instruct the mimeoverrides parameter of Phar::webPhar() that the extension should be parsed as a PHP source file through highlight_file()


Using Phar Archives

Table of Contents

  • Using Phar Archives: Introduction
  • Using Phar Archives: the phar stream wrapper
  • Using Phar Archives: the Phar and PharData class


Using Phar Archives: Introduction

Phar archives are similar in concept to Java JAR archives, but are tailored to the needs and to the flexibility of PHP applications. A Phar archive is used to distribute a complete PHP application or library in a single file. A Phar archive application is used exactly like any other PHP application:

php coolapplication.phar

Using a Phar archive library is identical to using any other PHP library:

<?php
include 'coollibrary.phar';
?>

The phar stream wrapper provides the core of the phar extension, and is explained in detail here. The phar stream wrapper allows accessing the files within a phar archive using PHP's standard file functions fopen(), opendir(), and others that work on regular files. The phar stream wrapper supports all read/write operations on both files and directories.

<?php
include 'phar://coollibrary.phar/internal/file.php';
header('Content-type: image/jpeg');
// phars can be accessed by full path or by alias
echo file_get_contents('phar:///fullpath/to/coollibrary.phar/images/wow.jpg');
?>

The Phar class implements advanced functionality for accessing files and for creating phar archives. The Phar class is explained in detail here.

<?php
try {
    // open an existing phar
    $p = new Phar('coollibrary.phar', 0);
    // Phar extends SPL's DirectoryIterator class
    foreach (new RecursiveIteratorIterator($p) as $file) {
        // $file is a PharFileInfo class, and inherits from SplFileInfo
        echo $file->getFileName() . "\n";
        echo file_get_contents($file->getPathName()) . "\n"; // display contents;
    }
    if (isset($p['internal/file.php'])) {
        var_dump($p['internal/file.php']->getMetadata());
    }

    // create a new phar - phar.readonly must be 0 in php.ini
    // phar.readonly is enabled by default for security reasons.
    // On production servers, Phars need never be created,
    // only executed.
    if (Phar::canWrite()) {
        $p = new Phar('newphar.tar.phar', 0, 'newphar.tar.phar');
        // make this a tar-based phar archive, compressed with gzip compression (.tar.gz)
        $p = $p->convertToExecutable(Phar::TAR, Phar::GZ);

        // create transaction - nothing is written to newphar.phar
        // until stopBuffering() is called, although temporary storage is needed
        $p->startBuffering();
        // add all files in /path/to/project, saving in the phar with the prefix "project"
        $p->buildFromIterator(new RecursiveIteratorIterator(new RecursiveDirectoryIterator('/path/to/project')), '/path/to/');

        // add a new file via the array access API
        $p['file1.txt'] = 'Information';
        $fp = fopen('hugefile.dat', 'rb');
        // copy all data from the stream
        $p['data/hugefile.dat'] = $fp;

        if (Phar::canCompress(Phar::GZ)) {
            $p['data/hugefile.dat']->compress(Phar::GZ);
        }

        $p['images/wow.jpg'] = file_get_contents('images/wow.jpg');
        // any value can be saved as file-specific meta-data
        $p['images/wow.jpg']->setMetadata(array('mime-type' => 'image/jpeg'));
        $p['index.php'] = file_get_contents('index.php');
        $p->setMetadata(array('bootstrap' => 'index.php'));

        // save the phar archive to disk
        $p->stopBuffering();
    }
} catch (Exception $e) {
    echo 'Could not open Phar: ', $e;
}
?>

In addition, verification of phar file contents can be done using any of the supported symmetric hash algorithms (MD5, SHA1, SHA256 and SHA512 if ext/hash is enabled) and using asymmetric public/private key signing using OpenSSL. To take advantage of OpenSSL signing, you need to generate a public/private key pair, and use the private key to set the signature using Phar::setSignatureAlgorithm(). In addition, the public key as extracted using this code:

<?php
$public = openssl_get_publickey(file_get_contents('private.pem'));
$pkey = '';
openssl_pkey_export($public, $pkey);
?>
must be saved adjacent to the phar archive it verifies. If the phar archive is saved as /path/to/my.phar, the public key must be saved as /path/to/my.phar.pubkey, or phar will be unable to verify the OpenSSL signature.

The Phar class also provides 3 static methods, Phar::webPhar(), Phar::mungServer() and Phar::interceptFileFuncs() that are crucial to packaging up PHP applications designed for usage on regular filesystems and for web-based applications. Phar::webPhar() implements a front controller that routes HTTP calls to the correct location within the phar archive. Phar::mungServer() is used to modify the values of the $_SERVER array to trick applications that process these values. Phar::interceptFileFuncs() instructs Phar to intercept calls to fopen(), file_get_contents(), opendir(), and all of the stat-based functions (file_exists(), is_readable() and so on) and route all relative paths to locations within the phar archive.

As an example, packaging up a release of the popular phpMyAdmin application for use as a phar archive requires only this simple script and then phpMyAdmin.phar.tar.php can be accessed as a regular file from your web server after modifying the user/password:

<?php
@unlink('phpMyAdmin.phar.tar.php');
copy('phpMyAdmin-2.11.3-english.tar.gz', 'phpMyAdmin.phar.tar.php');
$a = new Phar('phpMyAdmin.phar.tar.php');
$a->startBuffering();
$a["phpMyAdmin-2.11.3-english/config.inc.php"] = '<?php
/* Servers configuration */
$i = 0;

/* Server localhost (config:root) [1] */
$i++;
$cfg[\'Servers\'][$i][\'host\'] = \'localhost\';
$cfg[\'Servers\'][$i][\'extension\'] = \'mysqli\';
$cfg[\'Servers\'][$i][\'connect_type\'] = \'tcp\';
$cfg[\'Servers\'][$i][\'compress\'] = false;
$cfg[\'Servers\'][$i][\'auth_type\'] = \'config\';
$cfg[\'Servers\'][$i][\'user\'] = \'root\';
$cfg[\'Servers\'][$i][\'password\'] = \'\';

/* End of servers configuration */
if (strpos(PHP_OS, \'WIN\') !== false) {
    $cfg[\'UploadDir\'] = getcwd();
} else {
    $cfg[\'UploadDir\'] = \'/tmp/pharphpmyadmin\';
    @mkdir(\'/tmp/pharphpmyadmin\');
    @chmod(\'/tmp/pharphpmyadmin\', 0777);
}';
$a->setStub('<?php
Phar::interceptFileFuncs();
Phar::webPhar("phpMyAdmin.phar", "phpMyAdmin-2.11.3-english/index.php");
echo "phpMyAdmin is intended to be executed from a web browser\n";
exit -1;
__HALT_COMPILER();
');
$a->stopBuffering();
?>


Using Phar Archives: the phar stream wrapper

The Phar stream wrapper fully supports fopen() for read and write (not append), unlink(), stat(), fstat(), fseek(), rename() and directory stream operations opendir() and rmdir() and mkdir().

Individual file compression and per-file metadata can also be manipulated in a Phar archive using stream contexts:

<?php
$context = stream_context_create(array('phar' =>
                                    array('compress' => Phar::GZ)),
                                    array('metadata' => array('user' => 'cellog')));
file_put_contents('phar://my.phar/somefile.php', 0, $context);
?>

The phar stream wrapper does not operate on remote files, and cannot operate on remote files, and so is allowed even when the allow_url_fopen and allow_url_include INI options are disabled.

Although it is possible to create phar archives from scratch just using stream operations, it is best to use the functionality built into the Phar class. The stream wrapper is best used for read-only operations.


Using Phar Archives: the Phar and PharData class

The Phar class supports reading and manipulation of Phar archives, as well as iteration through inherited functionality of the RecursiveDirectoryIterator class. With support for the ArrayAccess interface, files inside a Phar archive can be accessed as if they were part of an associative array.

The PharData class extends the Phar, and allows creating and modifying non-executable (data) tar and zip archives even if phar.readonly=1 in php.ini. As such, PharData::setAlias() and PharData::setStub() are both disabled as the concept of alias and stub are unique to executable phar archives.

It is important to note that when creating a Phar archive, the full path should be passed to the Phar object constructor. Relative paths will fail to initialize.

Assuming that $p is a Phar object initialized as follows:

<?php
$p = new Phar('/path/to/myphar.phar', 0, 'myphar.phar');
?>

An empty Phar archive will be created at /path/to/myphar.phar, or if /path/to/myphar.phar already exists, it will be opened again. The literal myphar.phar demonstrates the concept of an alias that can be used to reference /path/to/myphar.phar in URLs as in:

<?php
// these two calls to file_get_contents() are equivalent if
// /path/to/myphar.phar has an explicit alias of "myphar.phar"
// in its manifest, or if the phar was initialized with the
// previous example's Phar object setup
$f = file_get_contents('phar:///path/to/myphar.phar/whatever.txt');
$f = file_get_contents('phar://myphar.phar/whatever.txt');
?>

With the newly created $p Phar object, the following is possible:

  • $a = $p['file.php'] creates a PharFileInfo class that refers to the contents of phar://myphar.phar/file.php
  • $p['file.php'] = $v creates a new file (phar://myphar.phar/file.php), or overwrites an existing file within myphar.phar. $v can be either a string or an open file pointer, in which case the entire contents of the file will be used to create the new file. Note that $p->addFromString('file.php', $v) is functionally equivalent to the above. Also possible is to add the contents of a file with $p->addFile('/path/to/file.php', 'file.php'). Lastly, an empty directory can be created with $p->addEmptyDir('empty').
  • isset($p['file.php']) can be used to determine whether phar://myphar.phar/file.php exists within myphar.phar.
  • unset($p['file.php']) erases phar://myphar.phar/file.php from myphar.phar.

In addition, the Phar object is the only way to access Phar-specific metadata, through Phar::getMetadata(), and the only way to set or retrieve a Phar archive's PHP loader stub through Phar::getStub() and Phar::setStub(). Additionally, compression for the entire Phar archive at once can only be manipulated using the Phar class.

The full list of Phar object functionality is documented below.

The PharFileInfo class extends the SplFileInfo class, and adds several methods for manipulating Phar-specific details of a file contained within a Phar, such as manipulating compression and metadata.


  • ? Using Phar Archives: the Phar and PharData class
  • Creating Phar Archives: Introduction ?
  • PHP Manual
  • Phar
  • Creating Phar Archives

Creating Phar Archives

Table of Contents

  • Creating Phar Archives: Introduction


Creating Phar Archives: Introduction

To be written fully in the near future. Before reading this, be sure to read How to use Phar Archives.

A great place to start is by reading about Phar::buildFromIterator(), and the specifics of the file format choices available for archives. A healthy understanding of what a stub is and does is crucial to phar archive creation, and so Phar::setStub() and Phar::createDefaultStub() are good places to start as well. If you are distributing a web-based application, it is crucial to know about Phar::webPhar() and related method Phar::mungServer(). Any application that accesses its own files should also consider using Phar::interceptFileFuncs().


What makes a phar a phar and not a tar or a zip?

Table of Contents

  • Ingredients of all Phar archives, independent of file format
  • Phar file stub
  • Head-to-head comparison of Phar, Tar and Zip
  • Tar-based phars
  • Zip-based phars
  • Phar File Format
  • Global Phar bitmapped flags
  • Phar manifest file entry definition
  • Phar Signature format


Ingredients of all Phar archives, independent of file format

All Phar archives contain three to four sections:

  1. a stub

  2. a manifest describing the contents

  3. the file contents

  4. [optional] a signature for verifying Phar integrity (phar file format only)


Phar file stub

A Phar's stub is a simple PHP file. The smallest possible stub follows:

<?php __HALT_COMPILER();

A stub must contain as a minimum, the __HALT_COMPILER(); token at its conclusion. Typically, a stub will contain loader functionality like so:

<?php
Phar::mapPhar();
include 'phar://myphar.phar/index.php';
__HALT_COMPILER();

There are no restrictions on the contents of a Phar stub, except for the requirement that it conclude with __HALT_COMPILER();. The closing PHP tag

?>
may be included or omitted, but there can be no more than 1 space between the ; and the close tag
?>
 or the phar extension will be unable to process the Phar archive's manifest.

In a tar or zip-based phar archive, the stub is stored in the .phar/stub.php file. The default stub for phar-based Phar archives contains approximately 7k of code to extract the contents of the phar and execute them. See Phar::createDefaultStub() for more detail.

The phar alias is stored in a tar or zip-based phar archive in the .phar/alias.txt file as plain text.


Head-to-head comparison of Phar, Tar and Zip

What are the good and the bad things about the three supported file formats in the phar extension? This table attempts to address that question.

Feature matrix: Phar vs. Tar vs. Zip
Feature | Phar | Tar | Zip
Standard File Format | No | Yes | Yes
Can be executed without the Phar Extension [1] | Yes | No | No
Per-file compression | Yes | No | Yes
Whole-archive compression | Yes | Yes | No
Whole-archive signature validation | Yes | Yes | Yes (PHP 5.3.1+)
Web-specific application support | Yes | Yes | Yes
Per-file Meta-data | Yes | Yes | Yes
Whole-Archive Meta-data | Yes | Yes | Yes
Archive creation/modification [2] | Yes | Yes | Yes
Full support for all stream wrapper functions | Yes | Yes | Yes
Can be created/modified even if phar.readonly=1 [3] | No | Yes | Yes

Tip

[1] PHP can only directly access the contents of a Phar archive without the Phar extension if it is using a stub that extracts the contents of the phar archive. The stub created by Phar::createDefaultStub() extracts the phar archive and runs its contents from a temporary directory if no phar extension is found.

Tip

[2] All write access requires phar.readonly to be disabled in php.ini or on the command-line directly.

Tip

[3] Only tar and zip archives without .phar in their filename and without an executable stub .phar/stub.php can be created if phar.readonly=1.


Tar-based phars

Archives based on the tar file format follow the more modern USTAR file format. The design of the tar file header makes them more efficient to access than the zip file format, and almost as efficient as the phar file format. File names are limited to 255 bytes, including full path within the phar archive. There is no limit on the number of files within a tar-based phar archive. These archives can fully compressed in gzip or bzip2 format and still be executed by the Phar extension.

There is limited support for reading tarballs in pax interchange format, but all recognized pax headers (currently, typeflag x and g) are silently ignored. There is also limited support for GNU Tar Archives; currently, ././@LongLink headers are resolved.

To compress an entire archive, use Phar::compress(). To decompress an entire archive, use Phar::decompress().


Zip-based phars

Archives based on the zip file format support several features built into the zip file format. Per-file and whole-archive metadata is stored in the zip file comment and zip archive comment as a serialized string. Pre-existing zip comments will be successfully read as a string. Per-file compression read/write is supported with zlib DEFLATE compression, and read access is supported with bzip2 compression. There is no limit on the number of files within a zip-based phar archive. Empty directories are stored in the zip archive as files with a trailing slash like my/directory/


Phar File Format

The phar file format is literally laid out as stub/manifest/contents/signature, and stores the crucial information of what is included in the phar archive in its manifest.

The Phar manifest is a highly optimized format that allows per-file specification of file compression, file permissions, and even user-defined meta-data such as file user or group. All values greater than 1 byte are stored in little-endian byte order, with the exception of the API version, which for historical reasons is stored as 3 nibbles in big-endian order.

All unused flags are reserved for future use, and must not be used to store custom information. Use the per-file meta-data facility to store customized information about particular files.

The basic file format of a Phar archive manifest is as follows:

Global Phar manifest format
Size in bytes | Description
4 bytes | Length of manifest in bytes (1 MB limit)
4 bytes | Number of files in the Phar
2 bytes | API version of the Phar manifest (currently 1.0.0)
4 bytes | Global Phar bitmapped flags
4 bytes | Length of Phar alias
?? | Phar alias (length based on previous)
4 bytes | Length of Phar metadata (0 for none)
?? | Serialized Phar Meta-data, stored in serialize() format
at least 24 * number of entries bytes | entries for each file


Global Phar bitmapped flags

Here are the bitmapped flags currently recognized by the Phar extension for the global Phar flat bitmap:

Bitmap values recognized
Value | Description
0x00010000 | If set, this Phar contains a verification signature
0x00001000 | If set, this Phar contains at least 1 file that is compressed with zlib DEFLATE compression
0x00002000 | If set, this Phar contains at least 1 file that is compressed with bzip2 compression


Phar manifest file entry definition

Each file in the manifest contains the following information:

Phar Manifest file entry
Size in bytes | Description
4 bytes | Filename length in bytes
?? | Filename (length specified in previous)
4 bytes | Un-compressed file size in bytes
4 bytes | Unix timestamp of file
4 bytes | Compressed file size in bytes
4 bytes | CRC32 checksum of un-compressed file contents
4 bytes | Bit-mapped File-specific flags
4 bytes | Serialized File Meta-data length (0 for none)
?? | Serialized File Meta-data, stored in serialize() format

Note that as of API version 1.1.1, empty directories are stored as filenames with a trailing slash like my/directory/

The File-specific bitmap values recognized are:

Bitmap values recognized
Value | Description
0x000001FF | These bits are reserved for defining specific file permissions of a file. Permissions are used for fstat() and can be used to recreate desired permissions upon extraction.
0x00001000 | If set, this file is compressed with zlib DEFLATE compression
0x00002000 | If set, this file is compressed with bzip2 compression


Phar Signature format

Phars containing a signature always have the signature appended to the end of the Phar archive after the loader, manifest, and file contents. The signature formats supported at this time are MD5, SHA1, SHA256, SHA512, and OPENSSL.

Signature format
Length in bytes | Description
varying | The actual signature, 20 bytes for an SHA1 signature, 16 bytes for an MD5 signature, 32 bytes for an SHA256 signature, and 64 bytes for an SHA512 signature. The length of an OPENSSL signature depends on the size of the private key.
4 bytes | Signature flags. 0x0001 is used to define an MD5 signature, 0x0002 is used to define an SHA1 signature, 0x0003 is used to define an SHA256 signature, and 0x0004 is used to define an SHA512 signature. The SHA256 and SHA512 signature support is available as of API version 1.1.0. 0x0010 is used to define an OPENSSL signature, what is available as of API version 1.1.1, if OpenSSL is available.
4 bytes | Magic GBMB used to define the presence of a signature.


The Phar class

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

简介

The Phar class provides a high-level interface to accessing and creating phar archives.

类摘要

Phar extends RecursiveDirectoryIterator implements Countable , ArrayAccess {
/* 继承的常量 */
const int FilesystemIterator::CURRENT_AS_PATHNAME = 32 ;
const int FilesystemIterator::CURRENT_AS_FILEINFO = 0 ;
const int FilesystemIterator::CURRENT_AS_SELF = 16 ;
const int FilesystemIterator::CURRENT_MODE_MASK = 240 ;
const int FilesystemIterator::KEY_AS_PATHNAME = 0 ;
const int FilesystemIterator::KEY_AS_FILENAME = 256 ;
const int FilesystemIterator::FOLLOW_SYMLINKS = 512 ;
const int FilesystemIterator::KEY_MODE_MASK = 3840 ;
const int FilesystemIterator::NEW_CURRENT_AND_KEY = 256 ;
const int FilesystemIterator::SKIP_DOTS = 4096 ;
const int FilesystemIterator::UNIX_PATHS = 8192 ;
/* 方法 */
public addEmptyDir ( string $dirname ) : void
public addFile ( string $file , string $localname = ? ) : void
public addFromString ( string $localname , string $contents ) : void
final public static apiVersion ( ) : string
public buildFromDirectory ( string $base_dir , string $regex = ? ) : array
public buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array
final public static canCompress ( int $type = 0 ) : bool
final public static canWrite ( ) : bool
public compress ( int $compression , string $extension = ? ) : Phar
public compressFiles ( int $compression ) : void
public __construct ( string $fname , int $flags = ? , string $alias = ? )
public convertToData ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : PharData
public convertToExecutable ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : Phar
public copy ( string $oldfile , string $newfile ) : bool
public count ( ) : int
final public static createDefaultStub ( string $indexfile = ? , string $webindexfile = ? ) : string
public decompress ( string $extension = ? ) : Phar
public decompressFiles ( ) : bool
public delMetadata ( ) : bool
public delete ( string $entry ) : bool
public extractTo ( string $pathto , string|array|null $files = null , bool $overwrite = false ) : bool
public getAlias ( ) : string
public getMetadata ( ) : mixed
public getModified ( ) : bool
public getPath ( ) : string
public getSignature ( ) : array
public getStub ( ) : string
final public static getSupportedCompression ( ) : array
final public static getSupportedSignatures ( ) : array
public getVersion ( ) : string
public hasMetadata ( ) : bool
final public static interceptFileFuncs ( ) : void
public isBuffering ( ) : bool
public isCompressed ( ) : mixed
public isFileFormat ( int $format ) : bool
final public static isValidPharFilename ( string $filename , bool $executable = true ) : bool
public isWritable ( ) : bool
final public static loadPhar ( string $filename , string $alias = ? ) : bool
final public static mapPhar ( string $alias = ? , int $dataoffset = 0 ) : bool
final public static mount ( string $pharpath , string $externalpath ) : void
final public static mungServer ( array $munglist ) : void
public offsetExists ( string $offset ) : bool
public offsetGet ( string $offset ) : PharFileInfo
public offsetSet ( string $offset , string $value ) : void
public offsetUnset ( string $offset ) : bool
final public static running ( bool $retphar = true ) : string
public setAlias ( string $alias ) : bool
public setDefaultStub ( string $index = ? , string $webindex = ? ) : bool
public setMetadata ( mixed $metadata ) : void
public setSignatureAlgorithm ( int $sigtype , string $privatekey = ? ) : void
public setStub ( string $stub , int $len = -1 ) : bool
public startBuffering ( ) : void
public stopBuffering ( ) : void
final public static unlinkArchive ( string $archive ) : bool
final public static webPhar ( string $alias = ? , string $index = "index.php" , string $f404 = ? , array $mimetypes = ? , callable $rewrites = ? ) : void
}

Table of Contents

  • Phar::addEmptyDir — 添加一个空目录到 phar 档案
  • Phar::addFile — 将一个文件从文件系统添加到 phar 档案中
  • Phar::addFromString — 以字符串的形式添加一个文件到 phar 档案
  • Phar::apiVersion — Returns the api version
  • Phar::buildFromDirectory — Construct a phar archive from the files within a directory
  • Phar::buildFromIterator — Construct a phar archive from an iterator
  • Phar::canCompress — Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::canWrite — Returns whether phar extension supports writing and creating phars
  • Phar::compress — Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::compressFiles — Compresses all files in the current Phar archive
  • Phar::__construct — Construct a Phar archive object
  • Phar::convertToData — Convert a phar archive to a non-executable tar or zip file
  • Phar::convertToExecutable — Convert a phar archive to another executable phar archive file format
  • Phar::copy — Copy a file internal to the phar archive to another new file within the phar
  • Phar::count — Returns the number of entries (files) in the Phar archive
  • Phar::createDefaultStub — Create a phar-file format specific stub
  • Phar::decompress — Decompresses the entire Phar archive
  • Phar::decompressFiles — Decompresses all files in the current Phar archive
  • Phar::delMetadata — Deletes the global metadata of the phar
  • Phar::delete — 删除 phar 档案中的一个文件
  • Phar::extractTo — Extract the contents of a phar archive to a directory
  • Phar::getAlias — Get the alias for Phar
  • Phar::getMetadata — Returns phar archive meta-data
  • Phar::getModified — Return whether phar was modified
  • Phar::getPath — Get the real path to the Phar archive on disk
  • Phar::getSignature — Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive
  • Phar::getStub — Return the PHP loader or bootstrap stub of a Phar archive
  • Phar::getSupportedCompression — Return array of supported compression algorithms
  • Phar::getSupportedSignatures — Return array of supported signature types
  • Phar::getVersion — Return version info of Phar archive
  • Phar::hasMetadata — Returns whether phar has global meta-data
  • Phar::interceptFileFuncs — Instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions
  • Phar::isBuffering — Used to determine whether Phar write operations are being buffered, or are flushing directly to disk
  • Phar::isCompressed — Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::isFileFormat — Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter
  • Phar::isValidPharFilename — Returns whether the given filename is a valid phar filename
  • Phar::isWritable — Returns true if the phar archive can be modified
  • Phar::loadPhar — Loads any phar archive with an alias
  • Phar::mapPhar — Reads the currently executed file (a phar) and registers its manifest
  • Phar::mount — Mount an external path or file to a virtual location within the phar archive
  • Phar::mungServer — Defines a list of up to 4 $_SERVER variables that should be modified for execution
  • Phar::offsetExists — Determines whether a file exists in the phar
  • Phar::offsetGet — Gets a PharFileInfo object for a specific file
  • Phar::offsetSet — Set the contents of an internal file to those of an external file
  • Phar::offsetUnset — Remove a file from a phar
  • Phar::running — Returns the full path on disk or full phar URL to the currently executing Phar archive
  • Phar::setAlias — Set the alias for the Phar archive
  • Phar::setDefaultStub — Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader
  • Phar::setMetadata — Sets phar archive meta-data
  • Phar::setSignatureAlgorithm — Set the signature algorithm for a phar and apply it
  • Phar::setStub — Used to set the PHP loader or bootstrap stub of a Phar archive
  • Phar::startBuffering — Start buffering Phar write operations, do not modify the Phar object on disk
  • Phar::stopBuffering — Stop buffering write requests to the Phar archive, and save changes to disk
  • Phar::unlinkArchive — Completely remove a phar archive from disk and from memory
  • Phar::webPhar — mapPhar for web-based phars. front controller for web applications


添加一个空目录到 phar 档案

  • ? Phar
  • Phar::addFile ?
  • PHP Manual
  • Phar
  • 添加一个空目录到 phar 档案

Phar::addEmptyDir

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::addEmptyDir — 添加一个空目录到 phar 档案

说明

public Phar::addEmptyDir ( string $dirname ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

通过这个方法，可以创建一个以 dirname 为路径名的空目录。 这个方法和 ZipArchive::addEmptyDir() 类似。

参数

dirname

需要在 phar 档案中创建的空目录名称

返回值

没有返回值, 失败时抛出异常（exception）。

范例

Example #1 一个 Phar::addEmptyDir() 示例

<?php
try {
    $a = new Phar('/path/to/phar.phar');

    $a->addEmptyDir('/full/path/to/file');
    // demonstrates how this file is stored
    $b = $a['full/path/to/file']->isDir();
} catch (Exception $e) {
    // handle errors here
}
?>

参见

  • PharData::addEmptyDir() - Add an empty directory to the tar/zip archive
  • Phar::addFile() - 将一个文件从文件系统添加到 phar 档案中
  • Phar::addFromString() - 以字符串的形式添加一个文件到 phar 档案


将一个文件从文件系统添加到 phar 档案中

  • ? Phar::addEmptyDir
  • Phar::addFromString ?
  • PHP Manual
  • Phar
  • 将一个文件从文件系统添加到 phar 档案中

Phar::addFile

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::addFile — 将一个文件从文件系统添加到 phar 档案中

说明

public Phar::addFile ( string $file , string $localname = ? ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

通过这个方法，任何文件或者 URL 可以被添加到 phar 档案中。如果第二个可选参数 localname 被设定， 那么文件则会以该参数为名称保存到档案中，此外，file 参数会被作为路径保存在档案中。 URLs 必须提交 localname 参数，否则会抛出异常。 这个方法与 ZipArchive::addFile() 类似。

参数

file

需要添加到 phar 档案的文件在磁盘上的完全（绝对）或者相对路径。

localname

文件保存到档案时的路径。

返回值

没有返回值，失败时会抛出异常。

范例

Example #1 一个 Phar::addFile() 示例

<?php
try {
    $a = new Phar('/path/to/phar.phar');

    $a->addFile('/full/path/to/file');
    // demonstrates how this file is stored
    $b = $a['full/path/to/file']->getContent();

    $a->addFile('/full/path/to/file', 'my/file.txt');
    $c = $a['my/file.txt']->getContent();

    // demonstrate URL usage
    $a->addFile('http://www.example.com', 'example.html');
} catch (Exception $e) {
    // handle errors here
}
?>

参见

  • Phar::offsetSet() - Set the contents of an internal file to those of an external file
  • PharData::addFile() - Add a file from the filesystem to the tar/zip archive
  • Phar::addFromString() - 以字符串的形式添加一个文件到 phar 档案
  • Phar::addEmptyDir() - 添加一个空目录到 phar 档案


以字符串的形式添加一个文件到 phar 档案

  • ? Phar::addFile
  • Phar::apiVersion ?
  • PHP Manual
  • Phar
  • 以字符串的形式添加一个文件到 phar 档案

Phar::addFromString

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::addFromString — 以字符串的形式添加一个文件到 phar 档案

说明

public Phar::addFromString ( string $localname , string $contents ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

通过这个方法，任何字符串都可以被添加到 phar 档案中。 文件将会以 localname 为路径保存到档案中。 这个方法与 ZipArchive::addFromString() 类似。

参数

localname

文件保存到档案时的路径。

contents

要保存的文件内容。

返回值

没有返回值，失败时会抛出异常。

范例

Example #1 一个 Phar::addFromString() 示例

<?php
try {
    $a = new Phar('/path/to/phar.phar');

    $a->addFromString('path/to/file.txt', 'my simple file');
    $b = $a['path/to/file.txt']->getContent();

    // to add contents from a stream handle for large files, use offsetSet()
    $c = fopen('/path/to/hugefile.bin');
    $a['largefile.bin'] = $c;
    fclose($c);
} catch (Exception $e) {
    // handle errors here
}
?>

参见

  • Phar::offsetSet() - Set the contents of an internal file to those of an external file
  • PharData::addFromString() - Add a file from the filesystem to the tar/zip archive
  • Phar::addFile() - 将一个文件从文件系统添加到 phar 档案中
  • Phar::addEmptyDir() - 添加一个空目录到 phar 档案


Returns the api version

  • ? Phar::addFromString
  • Phar::buildFromDirectory ?
  • PHP Manual
  • Phar
  • Returns the api version

Phar::apiVersion

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::apiVersion — Returns the api version

说明

final public static Phar::apiVersion ( ) : string

Return the API version of the phar file format that will be used when creating phars. The Phar extension supports reading API version 1.0.0 or newer. API version 1.1.0 is required for SHA-256 and SHA-512 hash, and API version 1.1.1 is required to store empty directories.

参数

返回值

The API version string as in "1.0.0".

范例

Example #1 A Phar::apiVersion() example

<?php
echo Phar::apiVersion();
?>

以上例程会输出：

1.1.1


Construct a phar archive from the files within a directory

  • ? Phar::apiVersion
  • Phar::buildFromIterator ?
  • PHP Manual
  • Phar
  • Construct a phar archive from the files within a directory

Phar::buildFromDirectory

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::buildFromDirectory — Construct a phar archive from the files within a directory

说明

public Phar::buildFromDirectory ( string $base_dir , string $regex = ? ) : array

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Populate a phar archive from directory contents. The optional second parameter is a regular expression (pcre) that is used to exclude files. Any filename that matches the regular expression will be included, all others will be excluded. For more fine-grained control, use Phar::buildFromIterator().

参数

base_dir

The full or relative path to the directory that contains all files to add to the archive.

regex

An optional pcre regular expression that is used to filter the list of files. Only file paths matching the regular expression will be included in the archive.

返回值

Phar::buildFromDirectory() returns an associative array mapping internal path of file to the full path of the file on the filesystem.

错误／异常

This method throws BadMethodCallException when unable to instantiate the internal directory iterators, or a PharException if there were errors saving the phar archive.

范例

Example #1 A Phar::buildFromDirectory() example

<?php
// create with alias "project.phar"
$phar = new Phar('project.phar', 0, 'project.phar');
// add all files in the project
$phar->buildFromDirectory(dirname(__FILE__) . '/project');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));

$phar2 = new Phar('project2.phar', 0, 'project2.phar');
// add all files in the project, only include php files
$phar2->buildFromDirectory(dirname(__FILE__) . '/project', '/\.php$/');
$phar2->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

参见

  • Phar::buildFromIterator() - Construct a phar archive from an iterator


Construct a phar archive from an iterator

  • ? Phar::buildFromDirectory
  • Phar::canCompress ?
  • PHP Manual
  • Phar
  • Construct a phar archive from an iterator

Phar::buildFromIterator

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::buildFromIterator — Construct a phar archive from an iterator

说明

public Phar::buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Populate a phar archive from an iterator. Two styles of iterators are supported, iterators that map the filename within the phar to the name of a file on disk, and iterators like DirectoryIterator that return SplFileInfo objects. For iterators that return SplFileInfo objects, the second parameter is required.

参数

iter

Any iterator that either associatively maps phar file to location or returns SplFileInfo objects

base_directory

For iterators that return SplFileInfo objects, the portion of each file's full path to remove when adding to the phar archive

返回值

Phar::buildFromIterator() returns an associative array mapping internal path of file to the full path of the file on the filesystem.

范例

Example #1 A Phar::buildFromIterator() with SplFileInfo

For most phar archives, the archive will reflect an actual directory layout, and the second style is the most useful. For instance, to create a phar archive containing the files in this sample directory layout:

/path/to/project/
                 config/
                        dist.xml
                        debug.xml
                 lib/
                     file1.php
                     file2.php
                 src/
                     processthing.php
                 www/
                     index.php
                 cli/
                     index.php

This code could be used to add these files to the "project.phar" phar archive:

<?php
// create with alias "project.phar"
$phar = new Phar('project.phar', 0, 'project.phar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new RecursiveDirectoryIterator('/path/to/project')),
    '/path/to/project');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

The file project.phar can then be used immediately. Phar::buildFromIterator() does not set values such as compression, metadata, and this can be done after creating the phar archive.

As an interesting note, Phar::buildFromIterator() can also be used to copy the contents of an existing phar archive, as the Phar object descends from DirectoryIterator:

<?php
// create with alias "project.phar"
$phar = new Phar('project.phar', 0, 'project.phar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new Phar('/path/to/anotherphar.phar')),
    'phar:///path/to/anotherphar.phar/path/to/project');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Example #2 A Phar::buildFromIterator() with other iterators

The second form of the iterator can be used with any iterator that returns a key => value mapping, such as an ArrayIterator:

<?php
// create with alias "project.phar"
$phar = new Phar('project.phar', 0, 'project.phar');
$phar->buildFromIterator(
    new ArrayIterator(
     array(
        'internal/file.php' => dirname(__FILE__) . '/somefile.php',
        'another/file.jpg' => fopen('/path/to/bigfile.jpg', 'rb'),
     )));
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

错误／异常

This method returns UnexpectedValueException when the iterator returns incorrect values, such as an integer key instead of a string, a BadMethodCallException when an SplFileInfo-based iterator is passed without a base_directory parameter, or a PharException if there were errors saving the phar archive.

参见

  • Phar::buildFromDirectory() - Construct a phar archive from the files within a directory


Returns whether phar extension supports compression using either zlib or bzip2

  • ? Phar::buildFromIterator
  • Phar::canWrite ?
  • PHP Manual
  • Phar
  • Returns whether phar extension supports compression using either zlib or bzip2

Phar::canCompress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::canCompress — Returns whether phar extension supports compression using either zlib or bzip2

说明

final public static Phar::canCompress ( int $type = 0 ) : bool

This should be used to test whether compression is possible prior to loading a phar archive containing compressed files.

参数

type

Either Phar::GZ or Phar::BZ2 can be used to test whether compression is possible with a specific compression algorithm (zlib or bzip2).

返回值

true if compression/decompression is available, false if not.

范例

Example #1 A Phar::canCompress() example

<?php
if (Phar::canCompress()) {
    echo file_get_contents('phar://compressedphar.phar/internal/file.txt');
} else {
    echo 'no compression available';
}
?>

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file


Returns whether phar extension supports writing and creating phars

  • ? Phar::canCompress
  • Phar::compress ?
  • PHP Manual
  • Phar
  • Returns whether phar extension supports writing and creating phars

Phar::canWrite

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::canWrite — Returns whether phar extension supports writing and creating phars

说明

final public static Phar::canWrite ( ) : bool

This static method determines whether write access has been disabled in the system php.ini via the phar.readonly ini variable.

参数

返回值

true if write access is enabled, false if it is disabled.

范例

Example #1 A Phar::canWrite() example

<?php
if (Phar::canWrite()) {
    file_put_contents('phar://myphar.phar/file.txt', 'hi there');
}
?>

参见

  • phar.readonly
  • Phar::isWritable() - Returns true if the phar archive can be modified


Compresses the entire Phar archive using Gzip or Bzip2 compression

  • ? Phar::canWrite
  • Phar::compressFiles ?
  • PHP Manual
  • Phar
  • Compresses the entire Phar archive using Gzip or Bzip2 compression

Phar::compress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::compress — Compresses the entire Phar archive using Gzip or Bzip2 compression

说明

public Phar::compress ( int $compression , string $extension = ? ) : Phar

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

For tar-based and phar-based phar archives, this method compresses the entire archive using gzip compression or bzip2 compression. The resulting file can be processed with the gunzip command/bunzip command, or accessed directly and transparently with the Phar extension.

For Zip-based phar archives, this method fails with an exception. The zlib extension must be enabled to compress with gzip compression, the bzip2 extension must be enabled in order to compress with bzip2 compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

In addition, this method automatically renames the archive, appending .gz, .bz2 or removing the extension if passed Phar::NONE to remove compression. Alternatively, a file extension may be specified with the second parameter.

参数

compression

Compression must be one of Phar::GZ, Phar::BZ2 to add compression, or Phar::NONE to remove compression.

extension

By default, the extension is .phar.gz or .phar.bz2 for compressing phar archives, and .phar.tar.gz or .phar.tar.bz2 for compressing tar archives. For decompressing, the default file extensions are .phar and .phar.tar.

返回值

Returns a Phar object.

错误／异常

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or the bzip2 extension is not enabled.

范例

Example #1 A Phar::compress() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p1 = $p->compress(Phar::GZ); // copies to /path/to/my.phar.gz
$p2 = $p->compress(Phar::BZ2); // copies to /path/to/my.phar.bz2
$p3 = $p2->compress(Phar::NONE); // exception: /path/to/my.phar already exists
?>

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive


Compresses all files in the current Phar archive

  • ? Phar::compress
  • Phar::__construct ?
  • PHP Manual
  • Phar
  • Compresses all files in the current Phar archive

Phar::compressFiles

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::compressFiles — Compresses all files in the current Phar archive

说明

public Phar::compressFiles ( int $compression ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

For tar-based phar archives, this method throws a BadMethodCallException, as compression of individual files within a tar archive is not supported by the file format. Use Phar::compress() to compress an entire tar-based phar archive.

For Zip-based and phar-based phar archives, this method compresses all files in the Phar archive using the specified compression. The zlib or bzip2 extensions must be enabled to take advantage of this feature. In addition, if any files are already compressed using bzip2/zlib compression, the respective extension must be enabled in order to decompress the files prior to re-compressing. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

参数

compression

Compression must be one of Phar::GZ, Phar::BZ2 to add compression, or Phar::NONE to remove compression.

返回值

没有返回值。

错误／异常

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

范例

Example #1 A Phar::compressFiles() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
$p->compressFiles(Phar::GZ);
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
?>

以上例程会输出：

string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)
string(10) "myfile.txt"
int(4096)
bool(false)
bool(true)
string(11) "myfile2.txt"
int(4096)
bool(false)
bool(true)

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive


Construct a Phar archive object

  • ? Phar::compressFiles
  • Phar::convertToData ?
  • PHP Manual
  • Phar
  • Construct a Phar archive object

Phar::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::__construct — Construct a Phar archive object

说明

public Phar::__construct ( string $fname , int $flags = ? , string $alias = ? )

参数

fname

Path to an existing Phar archive or to-be-created archive. The file name's extension must contain .phar.

flags

Flags to pass to parent class RecursiveDirectoryIterator.

alias

Alias with which this Phar archive should be referred to in calls to stream functionality.

错误／异常

Throws BadMethodCallException if called twice, UnexpectedValueException if the phar archive can't be opened.

范例

Example #1 A Phar::__construct() example

<?php
try {
    $p = new Phar('/path/to/my.phar', FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::KEY_AS_FILENAME,
                  'my.phar');
} catch (UnexpectedValueException $e) {
    die('Could not open my.phar');
} catch (BadMethodCallException $e) {
    echo 'technically, this cannot happen';
}
// this works now
echo file_get_contents('phar://my.phar/example.txt');
// and works as if we had typed
echo file_get_contents('phar:///path/to/my.phar/example.txt');
?>


Convert a phar archive to a non-executable tar or zip file

  • ? Phar::__construct
  • Phar::convertToExecutable ?
  • PHP Manual
  • Phar
  • Convert a phar archive to a non-executable tar or zip file

Phar::convertToData

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::convertToData — Convert a phar archive to a non-executable tar or zip file

说明

public Phar::convertToData ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : PharData

This method is used to convert an executable phar archive to either a tar or zip file. To make the tar or zip non-executable, the phar stub and phar alias files are removed from the newly created archive.

If no changes are specified, this method throws a BadMethodCallException if the archive is in phar file format. For archives in tar or zip file format, this method converts the archive to a non-executable archive.

If successful, the method creates a new archive on disk and returns a PharData object. The old archive is not removed from disk, and should be done manually after the process has finished.

参数

format

This should be one of Phar::TAR or Phar::ZIP. If set to null, the existing file format will be preserved.

compression

This should be one of Phar::NONE for no whole-archive compression, Phar::GZ for zlib-based compression, and Phar::BZ2 for bzip-based compression.

extension

This parameter is used to override the default file extension for a converted archive. Note that .phar cannot be used anywhere in the filename for a non-executable tar or zip archive.

If converting to a tar-based phar archive, the default extensions are .tar, .tar.gz, and .tar.bz2 depending on specified compression. For zip-based archives, the default extension is .zip.

返回值

The method returns a PharData object on success and throws an exception on failure.

错误／异常

This method throws BadMethodCallException when unable to compress, an unknown compression method has been specified, the requested archive is buffering with Phar::startBuffering() and has not concluded with Phar::stopBuffering(), and a PharException if any problems are encountered during the phar creation process.

范例

Example #1 A Phar::convertToData() example

Using Phar::convertToData():

<?php
try {
    $tarphar = new Phar('myphar.phar.tar');
    // note that myphar.phar.tar is *not* unlinked
    // convert it to the non-executable tar file format
    // creates myphar.tar
    $tar = $tarphar->convertToData();
    // convert to non-executable zip format, creates myphar.zip
    $zip = $tarphar->convertToData(Phar::ZIP);
    // create myphar.tbz
    $tgz = $tarphar->convertToData(Phar::TAR, Phar::BZ2, '.tbz');
    // creates myphar.phar.tgz
    $phar = $tarphar->convertToData(Phar::PHAR); // throws exception
} catch (Exception $e) {
    // handle the error here
}
?>

参见

  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • PharData::convertToExecutable() - Convert a non-executable tar/zip archive to an executable phar archive
  • PharData::convertToData() - Convert a phar archive to a non-executable tar or zip file


Convert a phar archive to another executable phar archive file format

  • ? Phar::convertToData
  • Phar::copy ?
  • PHP Manual
  • Phar
  • Convert a phar archive to another executable phar archive file format

Phar::convertToExecutable

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::convertToExecutable — Convert a phar archive to another executable phar archive file format

说明

public Phar::convertToExecutable ( int $format = 9021976 , int $compression = 9021976 , string $extension = ? ) : Phar

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

This method is used to convert a phar archive to another file format. For instance, it can be used to create a tar-based executable phar archive from a zip-based executable phar archive, or from an executable phar archive in the phar file format. In addition, it can be used to apply whole-archive compression to a tar or phar-based archive.

If no changes are specified, this method throws a BadMethodCallException.

If successful, the method creates a new archive on disk and returns a Phar object. The old archive is not removed from disk, and should be done manually after the process has finished.

参数

format

This should be one of Phar::PHAR, Phar::TAR, or Phar::ZIP. If set to null, the existing file format will be preserved.

compression

This should be one of Phar::NONE for no whole-archive compression, Phar::GZ for zlib-based compression, and Phar::BZ2 for bzip-based compression.

extension

This parameter is used to override the default file extension for a converted archive. Note that all zip- and tar-based phar archives must contain .phar in their file extension in order to be processed as a phar archive.

If converting to a phar-based archive, the default extensions are .phar, .phar.gz, or .phar.bz2 depending on the specified compression. For tar-based phar archives, the default extensions are .phar.tar, .phar.tar.gz, and .phar.tar.bz2. For zip-based phar archives, the default extension is .phar.zip.

返回值

The method returns a Phar object on success and throws an exception on failure.

错误／异常

This method throws BadMethodCallException when unable to compress, an unknown compression method has been specified, the requested archive is buffering with Phar::startBuffering() and has not concluded with Phar::stopBuffering(), an UnexpectedValueException if write support is disabled, and a PharException if any problems are encountered during the phar creation process.

范例

Example #1 A Phar::convertToExecutable() example

Using Phar::convertToExecutable():

<?php
try {
    $tarphar = new Phar('myphar.phar.tar');
    // convert it to the phar file format
    // note that myphar.phar.tar is *not* unlinked
    $phar = $tarphar->convertToExecutable(Phar::PHAR); // creates myphar.phar
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
    // creates myphar.phar.tgz
    $compressed = $phar->convertToExecutable(Phar::TAR, Phar::GZ, '.phar.tgz');
} catch (Exception $e) {
    // handle the error here
}
?>

参见

  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file
  • PharData::convertToExecutable() - Convert a non-executable tar/zip archive to an executable phar archive
  • PharData::convertToData() - Convert a phar archive to a non-executable tar or zip file


Copy a file internal to the phar archive to another new file within the phar

  • ? Phar::convertToExecutable
  • Phar::count ?
  • PHP Manual
  • Phar
  • Copy a file internal to the phar archive to another new file within the phar

Phar::copy

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::copy — Copy a file internal to the phar archive to another new file within the phar

说明

public Phar::copy ( string $oldfile , string $newfile ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Copy a file internal to the phar archive to another new file within the phar. This is an object-oriented alternative to using copy() with the phar stream wrapper.

参数

oldfile

newfile

返回值

returns true on success, but it is safer to encase method call in a try/catch block and assume success if no exception is thrown.

错误／异常

throws UnexpectedValueException if the source file does not exist, the destination file already exists, write access is disabled, opening either file fails, reading the source file fails, or a PharException if writing the changes to the phar fails.

范例

Example #1 A Phar::copy() example

This example shows using Phar::copy() and the equivalent stream wrapper performance of the same thing. The primary difference between the two approaches is error handling. All Phar methods throw exceptions, whereas the stream wrapper uses trigger_error().

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar['a'] = 'hi';
    $phar->copy('a', 'b');
    echo $phar['b']; // outputs "hi"
} catch (Exception $e) {
    // handle error
}

// the stream wrapper equivalent of the above code.
// E_WARNINGS are triggered on error rather than exceptions.
copy('phar://myphar.phar/a', 'phar//myphar.phar/c');
echo file_get_contents('phar://myphar.phar/c'); // outputs "hi"
?>


Returns the number of entries (files) in the Phar archive

  • ? Phar::copy
  • Phar::createDefaultStub ?
  • PHP Manual
  • Phar
  • Returns the number of entries (files) in the Phar archive

Phar::count

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::count — Returns the number of entries (files) in the Phar archive

说明

public Phar::count ( ) : int

参数

返回值

The number of files contained within this phar, or 0 (the number zero) if none.

范例

Example #1 A Phar::count() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
} catch (Exception $e) {
    echo 'Could not create phar:', $e;
}
echo 'The new phar has ' . $p->count() . " entries\n";
$p['file.txt'] = 'hi';
echo 'The new phar has ' . $p->count() . " entries\n";
?>

以上例程会输出：

The new phar has 0 entries
The new phar has 1 entries


Create a phar-file format specific stub

  • ? Phar::count
  • Phar::decompress ?
  • PHP Manual
  • Phar
  • Create a phar-file format specific stub

Phar::createDefaultStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::createDefaultStub — Create a phar-file format specific stub

说明

final public static Phar::createDefaultStub ( string $indexfile = ? , string $webindexfile = ? ) : string

This method is intended for creation of phar-file format-specific stubs, and is not intended for use with tar- or zip-based phar archives.

Phar archives contain a bootstrap loader, or stub written in PHP that is executed when the archive is executed in PHP either via include:

<?php
include 'myphar.phar';
?>
or by simple execution:
php myphar.phar

This method provides a simple and easy method to create a stub that will run a startup file from the phar archive. In addition, different files can be specified for running the phar archive from the command line versus through a web server. The loader stub also calls Phar::interceptFileFuncs() to allow easy bundling of a PHP application that accesses the file system. If the phar extension is not present, the loader stub will extract the phar archive to a temporary directory and then operate on the files. A shutdown function erases the temporary files on exit.

返回值

Returns a string containing the contents of a customized bootstrap loader (stub) that allows the created Phar archive to work with or without the Phar extension enabled.

错误／异常

Throws UnexpectedValueException if either parameter is longer than 400 bytes.

范例

Example #1 A Phar::createDefaultStub() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
} catch (Exception $e) {
    // handle errors
}
?>

参见

  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive
  • Phar::getStub() - Return the PHP loader or bootstrap stub of a Phar archive


Decompresses the entire Phar archive

  • ? Phar::createDefaultStub
  • Phar::decompressFiles ?
  • PHP Manual
  • Phar
  • Decompresses the entire Phar archive

Phar::decompress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::decompress — Decompresses the entire Phar archive

说明

public Phar::decompress ( string $extension = ? ) : Phar

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

For tar-based and phar-based phar archives, this method decompresses the entire archive.

For Zip-based phar archives, this method fails with an exception. The zlib extension must be enabled to decompress an archive compressed with gzip compression, and the bzip2 extension must be enabled in order to decompress an archive compressed with bzip2 compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

In addition, this method automatically changes the file extension of the archive, .phar by default for phar archives, or .phar.tar for tar-based phar archives. Alternatively, a file extension may be specified with the second parameter.

参数

extension

For decompressing, the default file extensions are .phar and .phar.tar. Use this parameter to specify another file extension. Be aware that all executable phar archives must contain .phar in their filename.

返回值

A Phar object is returned.

错误／异常

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or the bzip2 extension is not enabled.

范例

Example #1 A Phar::decompress() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar.gz');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p3 = $p2->decompress(); // creates /path/to/my.phar
?>

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive


Decompresses all files in the current Phar archive

  • ? Phar::decompress
  • Phar::delMetadata ?
  • PHP Manual
  • Phar
  • Decompresses all files in the current Phar archive

Phar::decompressFiles

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::decompressFiles — Decompresses all files in the current Phar archive

说明

public Phar::decompressFiles ( ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

For tar-based phar archives, this method throws a BadMethodCallException, as compression of individual files within a tar archive is not supported by the file format. Use Phar::compress() to compress an entire tar-based phar archive.

For Zip-based and phar-based phar archives, this method decompresses all files in the Phar archive. The zlib or bzip2 extensions must be enabled to take advantage of this feature if any files are compressed using bzip2/zlib compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

范例

Example #1 A Phar::decompressFiles() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p->compressFiles(Phar::GZ);
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
$p->decompressFiles();
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
?>

以上例程会输出：

string(10) "myfile.txt"
int(4096)
bool(false)
bool(true)
string(11) "myfile2.txt"
int(4096)
bool(false)
bool(true)
string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive


Deletes the global metadata of the phar

  • ? Phar::decompressFiles
  • Phar::delete ?
  • PHP Manual
  • Phar
  • Deletes the global metadata of the phar

Phar::delMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

Phar::delMetadata — Deletes the global metadata of the phar

说明

public Phar::delMetadata ( ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Deletes the global metadata of the phar

参数

返回值

returns true on success, but it is better to check for thrown exception, and assume success if none is thrown.

错误／异常

Throws PharException if errors occur while flushing changes to disk.

范例

Example #1 A Phar::delMetaData() example

<?php
try {
    $phar = new Phar('myphar.phar');
    var_dump($phar->getMetadata());
    $phar->setMetadata("hi there");
    var_dump($phar->getMetadata());
    $phar->delMetadata();
    var_dump($phar->getMetadata());
} catch (Exception $e) {
    // handle errors
}
?>

以上例程会输出：

NULL
string(8) "hi there"
NULL

参见

  • Phar::getMetadata() - Returns phar archive meta-data
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data


删除 phar 档案中的一个文件

  • ? Phar::delMetadata
  • Phar::extractTo ?
  • PHP Manual
  • Phar
  • 删除 phar 档案中的一个文件

Phar::delete

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::delete — 删除 phar 档案中的一个文件

说明

public Phar::delete ( string $entry ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

删除档案中的一个文件。这个方法与下面示例中调用 unlink() 处理数据流包装器的方式等价。

参数

entry

需要删除的文件在档案中的路径。

返回值

成功时返回 true，但是最好还是检查一下是否抛出了异常，如果没有抛出，可以认定操作成功。

错误／异常

如果将修改保存到磁盘时发生了错误，会抛出 PharException 异常。

范例

Example #1 一个 Phar::delete() 示例

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->delete('unlink/me.php');
    // this is equivalent to:
    unlink('phar://myphar.phar/unlink/me.php');
} catch (Exception $e) {
    // handle errors
}
?>

参见

  • PharData::delete() - Delete a file within a tar/zip archive
  • Phar::unlinkArchive() - Completely remove a phar archive from disk and from memory


Extract the contents of a phar archive to a directory

  • ? Phar::delete
  • Phar::getAlias ?
  • PHP Manual
  • Phar
  • Extract the contents of a phar archive to a directory

Phar::extractTo

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::extractTo — Extract the contents of a phar archive to a directory

说明

public Phar::extractTo ( string $pathto , string|array|null $files = null , bool $overwrite = false ) : bool

Extract all files within a phar archive to disk. Extracted files and directories preserve permissions as stored in the archive. The optional parameters allow optional control over which files are extracted, and whether existing files on disk can be overwritten. The second parameter files can be either the name of a file or directory to extract, or an array of names of files and directories to extract. By default, this method will not overwrite existing files, the third parameter can be set to true to enable overwriting of files. This method is similar to ZipArchive::extractTo().

参数

pathto

Path to extract the given files to

files

The name of a file or directory to extract, or an array of files/directories to extract, null to skip this param

overwrite

Set to true to enable overwriting existing files

返回值

returns true on success, but it is better to check for thrown exception, and assume success if none is thrown.

错误／异常

Throws PharException if errors occur while flushing changes to disk.

范例

Example #1 A Phar::extractTo() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->extractTo('/full/path'); // extract all files
    $phar->extractTo('/another/path', 'file.txt'); // extract only file.txt
    $phar->extractTo('/this/path',
        array('file1.txt', 'file2.txt')); // extract 2 files only
    $phar->extractTo('/third/path', null, true); // extract all files, and overwrite
} catch (Exception $e) {
    // handle errors
}
?>

参见

  • PharData::extractTo() - Extract the contents of a tar/zip archive to a directory


Get the alias for Phar

  • ? Phar::extractTo
  • Phar::getMetadata ?
  • PHP Manual
  • Phar
  • Get the alias for Phar

Phar::getAlias

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.1)

Phar::getAlias — Get the alias for Phar

说明

public Phar::getAlias ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns the alias or null if there's no alias.


Returns phar archive meta-data

  • ? Phar::getAlias
  • Phar::getModified ?
  • PHP Manual
  • Phar
  • Returns phar archive meta-data

Phar::getMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getMetadata — Returns phar archive meta-data

说明

public Phar::getMetadata ( ) : mixed

Retrieve archive meta-data. Meta-data can be any PHP variable that can be serialized.

参数

No parameters.

返回值

any PHP variable that can be serialized and is stored as meta-data for the Phar archive, or null if no meta-data is stored.

范例

Example #1 A Phar::getMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.php'] = '<?php echo "hello";';
    $p->setMetadata(array('bootstrap' => 'file.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'Could not modify phar:', $e;
}
?>

以上例程会输出：

array(1) {
  ["bootstrap"]=>
  string(8) "file.php"
}

参见

  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::delMetadata() - Deletes the global metadata of the phar
  • Phar::hasMetadata() - Returns whether phar has global meta-data


Return whether phar was modified

  • ? Phar::getMetadata
  • Phar::getPath ?
  • PHP Manual
  • Phar
  • Return whether phar was modified

Phar::getModified

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getModified — Return whether phar was modified

说明

public Phar::getModified ( ) : bool

This method can be used to determine whether a phar has either had an internal file deleted, or contents of a file changed in some way.

参数

No parameters.

返回值

true if the phar has been modified since opened, false if not.


Get the real path to the Phar archive on disk

  • ? Phar::getModified
  • Phar::getSignature ?
  • PHP Manual
  • Phar
  • Get the real path to the Phar archive on disk

Phar::getPath

(PHP 5 >= 5.3.0, PHP 7)

Phar::getPath — Get the real path to the Phar archive on disk

说明

public Phar::getPath ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive

  • ? Phar::getPath
  • Phar::getStub ?
  • PHP Manual
  • Phar
  • Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive

Phar::getSignature

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getSignature — Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive

说明

public Phar::getSignature ( ) : array

Returns the verification signature of a phar archive in a hexadecimal string.

参数

返回值

Array with the opened archive's signature in hash key and MD5, SHA-1, SHA-256, SHA-512, or OpenSSL in hash_type. This signature is a hash calculated on the entire phar's contents, and may be used to verify the integrity of the archive. A valid signature is absolutely required of all executable phar archives if the phar.require_hash INI variable is set to true.


Return the PHP loader or bootstrap stub of a Phar archive

  • ? Phar::getSignature
  • Phar::getSupportedCompression ?
  • PHP Manual
  • Phar
  • Return the PHP loader or bootstrap stub of a Phar archive

Phar::getStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getStub — Return the PHP loader or bootstrap stub of a Phar archive

说明

public Phar::getStub ( ) : string

Phar archives contain a bootstrap loader, or stub written in PHP that is executed when the archive is executed in PHP either via include:

<?php
include 'myphar.phar';
?>
or by simple execution:
php myphar.phar

返回值

Returns a string containing the contents of the bootstrap loader (stub) of the current Phar archive.

错误／异常

Throws RuntimeException if it is not possible to read the stub from the Phar archive.

范例

Example #1 A Phar::getStub() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
echo $p->getStub();
echo "==NEXT==\n";
$p->setStub("<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER(); ?>");
echo $p->getStub();
?>

以上例程会输出：

<?php __HALT_COMPILER(); ?>
==NEXT==
<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER(); ?>

参见

  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive
  • Phar::createDefaultStub() - Create a phar-file format specific stub


Return array of supported compression algorithms

  • ? Phar::getStub
  • Phar::getSupportedSignatures ?
  • PHP Manual
  • Phar
  • Return array of supported compression algorithms

Phar::getSupportedCompression

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

Phar::getSupportedCompression — Return array of supported compression algorithms

说明

final public static Phar::getSupportedCompression ( ) : array

参数

No parameters.

返回值

Returns an array containing any of Phar::GZ or Phar::BZ2, depending on the availability of the zlib extension or the bz2 extension.

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive


Return array of supported signature types

  • ? Phar::getSupportedCompression
  • Phar::getVersion ?
  • PHP Manual
  • Phar
  • Return array of supported signature types

Phar::getSupportedSignatures

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.1.0)

Phar::getSupportedSignatures — Return array of supported signature types

说明

final public static Phar::getSupportedSignatures ( ) : array

Return array of supported signature types

参数

No parameters.

返回值

Returns an array containing any of MD5, SHA-1, SHA-256, SHA-512, or OpenSSL.

参见

  • Phar::getSignature() - Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive
  • Phar::setSignatureAlgorithm() - Set the signature algorithm for a phar and apply it


Return version info of Phar archive

  • ? Phar::getSupportedSignatures
  • Phar::hasMetadata ?
  • PHP Manual
  • Phar
  • Return version info of Phar archive

Phar::getVersion

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::getVersion — Return version info of Phar archive

说明

public Phar::getVersion ( ) : string

Returns the API version of an opened Phar archive.

参数

返回值

The opened archive's API version. This is not to be confused with the API version that the loaded phar extension will use to create new phars. Each Phar archive has the API version hard-coded into its manifest. See Phar file format documentation for more information.

参见

  • Phar::apiVersion() - Returns the api version


Returns whether phar has global meta-data

  • ? Phar::getVersion
  • Phar::interceptFileFuncs ?
  • PHP Manual
  • Phar
  • Returns whether phar has global meta-data

Phar::hasMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

Phar::hasMetadata — Returns whether phar has global meta-data

说明

public Phar::hasMetadata ( ) : bool

Returns whether phar has global meta-data set.

参数

No parameters.

返回值

Returns true if meta-data has been set, and false if not.

范例

Example #1 A Phar::hasMetadata() example

<?php
try {
    $phar = new Phar('myphar.phar');
    var_dump($phar->hasMetadata());
    $phar->setMetadata(array('thing' => 'hi'));
    var_dump($phar->hasMetadata());
    $phar->delMetadata();
    var_dump($phar->hasMetadata());
} catch (Exception $e) {
    // handle error
}
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)

参见

  • Phar::getMetadata() - Returns phar archive meta-data
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::delMetadata() - Deletes the global metadata of the phar


Instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions

  • ? Phar::hasMetadata
  • Phar::isBuffering ?
  • PHP Manual
  • Phar
  • Instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions

Phar::interceptFileFuncs

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::interceptFileFuncs — Instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions

说明

final public static Phar::interceptFileFuncs ( ) : void

instructs phar to intercept fopen(), readfile(), file_get_contents(), opendir(), and all of the stat-related functions. If any of these functions is called from within a phar archive with a relative path, the call is modified to access a file within the phar archive. Absolute paths are assumed to be attempts to load external files from the filesystem.

This function makes it possible to run PHP applications designed to run off of a hard disk as a phar application.

参数

No parameters.

返回值

范例

Example #1 A Phar::interceptFileFuncs() example

<?php
Phar::interceptFileFuncs();
include 'phar://' . __FILE__ . '/file.php';
?>

Assuming that this phar is at /path/to/myphar.phar and it contains file.php and file2.txt, if file.php contains this code:

Example #2 A Phar::interceptFileFuncs() example

<?php
echo file_get_contents('file2.txt');
?>

Normally PHP would search the current directory for file2.txt, which would translate as the directory of file.php, or the current directory of a command-line user. Phar::interceptFileFuncs() instructs PHP to consider the current directory to be phar:///path/to/myphar.phar/ and so opens phar:///path/to/myphar.phar/file2.txt in the above example code.


Used to determine whether Phar write operations are being buffered, or are flushing directly to disk

  • ? Phar::interceptFileFuncs
  • Phar::isCompressed ?
  • PHP Manual
  • Phar
  • Used to determine whether Phar write operations are being buffered, or are flushing directly to disk

Phar::isBuffering

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::isBuffering — Used to determine whether Phar write operations are being buffered, or are flushing directly to disk

说明

public Phar::isBuffering ( ) : bool

This method can be used to determine whether a Phar will save changes to disk immediately, or whether a call to Phar::stopBuffering() is needed to enable saving changes.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

返回值

Returns true if the write operations are being buffer, false otherwise.

范例

Example #1 A Phar::isBuffering() example

<?php
$p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
$p2 = new Phar('existingphar.phar');
$p['file1.txt'] = 'hi';
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
?>
=2=
<?php
$p->startBuffering();
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
$p->stopBuffering();
?>
=3=
<?php
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
?>

以上例程会输出：

bool(false)
bool(false)
=2=
bool(true)
bool(false)
=3=
bool(false)
bool(false)

参见

  • Phar::startBuffering() - Start buffering Phar write operations, do not modify the Phar object on disk
  • Phar::stopBuffering() - Stop buffering write requests to the Phar archive, and save changes to disk


Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)

  • ? Phar::isBuffering
  • Phar::isFileFormat ?
  • PHP Manual
  • Phar
  • Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)

Phar::isCompressed

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::isCompressed — Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)

说明

public Phar::isCompressed ( ) : mixed

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on). Zip-based phar archives cannot be compressed as a file, and so this method will always return false if a zip-based phar archive is queried.

参数

No parameters.

返回值

Phar::GZ, Phar::BZ2 or false

范例

Example #1 A Phar::isCompressed() example

<?php
try {
    $phar1 = new Phar('myphar.zip.phar');
    var_dump($phar1->isCompressed());
    $phar2 = new Phar('myuncompressed.tar.phar');
    var_dump($phar2->isCompressed());
    $phar2->compress(Phar::GZ);
    var_dump($phar2->isCompressed() == Phar::GZ);
} catch (Exception $e) {
}
?>

以上例程会输出：

bool(false)
bool(false)
bool(true)

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms


Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter

  • ? Phar::isCompressed
  • Phar::isValidPharFilename ?
  • PHP Manual
  • Phar
  • Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter

Phar::isFileFormat

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::isFileFormat — Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter

说明

public Phar::isFileFormat ( int $format ) : bool

参数

format

Either Phar::PHAR, Phar::TAR, or Phar::ZIP to test for the format of the archive.

返回值

Returns true if the phar archive matches the file format requested by the parameter

错误／异常

PharException is thrown if the parameter is an unknown file format specifier.

参见

  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file


Returns whether the given filename is a valid phar filename

  • ? Phar::isFileFormat
  • Phar::isWritable ?
  • PHP Manual
  • Phar
  • Returns whether the given filename is a valid phar filename

Phar::isValidPharFilename

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

Phar::isValidPharFilename — Returns whether the given filename is a valid phar filename

说明

final public static Phar::isValidPharFilename ( string $filename , bool $executable = true ) : bool

Returns whether the given filename is a valid phar filename that will be recognized as a phar archive by the phar extension. This can be used to test a name without having to instantiate a phar archive and catch the inevitable Exception that will be thrown if an invalid name is specified.

参数

filename

The name or full path to a phar archive not yet created

executable

This parameter determines whether the filename should be treated as a phar executable archive, or a data non-executable archive

返回值

Returns true if the filename is valid, false if not.


Returns true if the phar archive can be modified

  • ? Phar::isValidPharFilename
  • Phar::loadPhar ?
  • PHP Manual
  • Phar
  • Returns true if the phar archive can be modified

Phar::isWritable

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::isWritable — Returns true if the phar archive can be modified

说明

public Phar::isWritable ( ) : bool

This method returns true if phar.readonly is 0, and the actual phar archive on disk is not read-only.

参数

No parameters.

返回值

Returns true if the phar archive can be modified

参见

  • Phar::canWrite() - Returns whether phar extension supports writing and creating phars
  • PharData::isWritable() - Returns true if the tar/zip archive can be modified


Loads any phar archive with an alias

  • ? Phar::isWritable
  • Phar::mapPhar ?
  • PHP Manual
  • Phar
  • Loads any phar archive with an alias

Phar::loadPhar

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::loadPhar — Loads any phar archive with an alias

说明

final public static Phar::loadPhar ( string $filename , string $alias = ? ) : bool

This can be used to read the contents of an external Phar archive. This is most useful for assigning an alias to a phar so that subsequent references to the phar can use the shorter alias, or for loading Phar archives that only contain data and are not intended for execution/inclusion in PHP scripts.

参数

filename

the full or relative path to the phar archive to open

alias

The alias that may be used to refer to the phar archive. Note that many phar archives specify an explicit alias inside the phar archive, and a PharException will be thrown if a new alias is specified in this case.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

PharException is thrown if an alias is passed in and the phar archive already has an explicit alias

范例

Example #1 A Phar::loadPhar() example

Phar::loadPhar can be used anywhere to load an external Phar archive, whereas Phar::mapPhar should be used in a loader stub for a Phar.

<?php
try {
    Phar::loadPhar('/path/to/phar.phar', 'my.phar');
    echo file_get_contents('phar://my.phar/file.txt');
} catch (PharException $e) {
    echo $e;
}
?>

参见

  • Phar::mapPhar() - Reads the currently executed file (a phar) and registers its manifest


Reads the currently executed file (a phar) and registers its manifest

  • ? Phar::loadPhar
  • Phar::mount ?
  • PHP Manual
  • Phar
  • Reads the currently executed file (a phar) and registers its manifest

Phar::mapPhar

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::mapPhar — Reads the currently executed file (a phar) and registers its manifest

说明

final public static Phar::mapPhar ( string $alias = ? , int $dataoffset = 0 ) : bool

This static method can only be used inside a Phar archive's loader stub in order to initialize the phar when it is directly executed, or when it is included in another script.

参数

alias

The alias that can be used in phar:// URLs to refer to this archive, rather than its full path.

dataoffset

Unused variable, here for compatibility with PEAR's PHP_Archive.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

PharException is thrown if not called directly within PHP execution, if no __HALT_COMPILER(); token is found in the current source file, or if the file cannot be opened for reading.

范例

Example #1 A Phar::mapPhar() example

mapPhar should be used only inside a phar's loader stub. Use loadPhar to load an external phar into memory.

Here is a sample Phar loader stub that uses mapPhar.

<?php
function __autoload($class)
{
    include 'phar://me.phar/' . str_replace('_', '/', $class) . '.php';
}
try {
    Phar::mapPhar('me.phar');
    include 'phar://me.phar/startup.php';
} catch (PharException $e) {
    echo $e->getMessage();
    die('Cannot initialize Phar');
}
__HALT_COMPILER();

参见

  • Phar::loadPhar() - Loads any phar archive with an alias


Mount an external path or file to a virtual location within the phar archive

  • ? Phar::mapPhar
  • Phar::mungServer ?
  • PHP Manual
  • Phar
  • Mount an external path or file to a virtual location within the phar archive

Phar::mount

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::mount — Mount an external path or file to a virtual location within the phar archive

说明

final public static Phar::mount ( string $pharpath , string $externalpath ) : void

Much like the unix file system concept of mounting external devices to paths within the directory tree, Phar::mount() allows referring to external files and directories as if they were inside of an archive. This allows powerful abstraction such as referring to external configuration files as if they were inside the archive.

参数

pharpath

The internal path within the phar archive to use as the mounted path location. This must be a relative path within the phar archive, and must not already exist.

externalpath

A path or URL to an external file or directory to mount within the phar archive

返回值

No return. PharException is thrown on failure.

错误／异常

Throws PharException if any problems occur mounting the path.

范例

Example #1 A Phar::mount() example

The following example shows accessing an external configuration file as if it were a path within a phar archive.

First, the code inside of a phar archive:

<?php
$configuration = simplexml_load_string(file_get_contents(
    Phar::running(false) . '/config.xml'));
?>

Next the external code used to mount the configuration file:

<?php
// first set up the association between the abstract config.xml
// and the actual one on disk
Phar::mount('phar://config.xml', '/home/example/config.xml');
// now run the application
include '/path/to/archive.phar';
?>

Another method is to put the mounting code inside the stub of the phar archive. Here is an example of setting up a default configuration file if no user configuration is specified:

<?php
// first set up the association between the abstract config.xml
// and the actual one on disk
if (defined('EXTERNAL_CONFIG')) {
    Phar::mount('config.xml', EXTERNAL_CONFIG);
    if (file_exists(__DIR__ . '/extra_config.xml')) {
        Phar::mount('extra.xml', __DIR__ . '/extra_config.xml');
    }
} else {
    Phar::mount('config.xml', 'phar://' . __FILE__ . '/default_config.xml');
    Phar::mount('extra.xml', 'phar://' . __FILE__ . '/default_extra.xml');
}
// now run the application
include 'phar://' . __FILE__ . '/index.php';
__HALT_COMPILER();
?>

...and the code externally to load this phar archive:

<?php
define('EXTERNAL_CONFIG', '/home/example/config.xml');
// now run the application
include '/path/to/archive.phar';
?>


Defines a list of up to 4 $_SERVER variables that should be modified for execution

  • ? Phar::mount
  • Phar::offsetExists ?
  • PHP Manual
  • Phar
  • Defines a list of up to 4 $_SERVER variables that should be modified for execution

Phar::mungServer

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::mungServer — Defines a list of up to 4 $_SERVER variables that should be modified for execution

说明

final public static Phar::mungServer ( array $munglist ) : void

Phar::mungServer() should only be called within the stub of a phar archive.

Defines a list of up to 4 $_SERVER variables that should be modified for execution. Variables that can be modified to remove traces of phar execution are REQUEST_URI, PHP_SELF, SCRIPT_NAME and SCRIPT_FILENAME.

On its own, this method does nothing. Only when combined with Phar::webPhar() does it take effect, and only when the requested file is a PHP file to be parsed. Note that the PATH_INFO and PATH_TRANSLATED variables are always modified.

The original values of variables that are modified are stored in the SERVER array with PHAR_ prepended, so for instance SCRIPT_NAME would be saved as PHAR_SCRIPT_NAME.

参数

munglist

an array containing as string indices any of REQUEST_URI, PHP_SELF, SCRIPT_NAME and SCRIPT_FILENAME. Other values trigger an exception, and Phar::mungServer() is case-sensitive.

返回值

No return.

错误／异常

Throws UnexpectedValueException if any problems are found with the passed in data.

范例

Example #1 A Phar::mungServer() example

<?php
// example stub
Phar::mungServer(array('REQUEST_URI'));
Phar::webPhar();
__HALT_COMPILER();
?>

参见

  • Phar::webPhar() - mapPhar for web-based phars. front controller for web applications
  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive


Determines whether a file exists in the phar

  • ? Phar::mungServer
  • Phar::offsetGet ?
  • PHP Manual
  • Phar
  • Determines whether a file exists in the phar

Phar::offsetExists

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::offsetExists — Determines whether a file exists in the phar

说明

public Phar::offsetExists ( string $offset ) : bool

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets.

offsetExists() is called whenever isset() is called.

参数

offset

The filename (relative path) to look for in a Phar.

返回值

Returns true if the file exists within the phar, or false if not.

范例

Example #1 A Phar::offsetExists() example

<?php
$p = new Phar(dirname(__FILE__) . '/my.phar', 0, 'my.phar');
$p['firstfile.txt'] = 'first file';
$p['secondfile.txt'] = 'second file';
// the next set of lines call offsetExists() indirectly
var_dump(isset($p['firstfile.txt']));
var_dump(isset($p['nothere.txt']));
?>

以上例程会输出：

bool(true)
bool(false)

参见

  • Phar::offsetGet() - Gets a PharFileInfo object for a specific file
  • Phar::offsetSet() - Set the contents of an internal file to those of an external file
  • Phar::offsetUnset() - Remove a file from a phar


Gets a PharFileInfo object for a specific file

  • ? Phar::offsetExists
  • Phar::offsetSet ?
  • PHP Manual
  • Phar
  • Gets a PharFileInfo object for a specific file

Phar::offsetGet

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::offsetGet — Gets a PharFileInfo object for a specific file

说明

public Phar::offsetGet ( string $offset ) : PharFileInfo

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. Phar::offsetGet() is used for retrieving files from a Phar archive.

参数

offset

The filename (relative path) to look for in a Phar.

返回值

A PharFileInfo object is returned that can be used to iterate over a file's contents or to retrieve information about the current file.

错误／异常

This method throws BadMethodCallException if the file does not exist in the Phar archive.

范例

Example #1 Phar::offsetGet() example

As with all classes that implement the ArrayAccess interface, Phar::offsetGet() is automatically called when using the [] angle bracket operator.

<?php
$p = new Phar(dirname(__FILE__) . '/myphar.phar', 0, 'myphar.phar');
$p['exists.txt'] = "file exists\n";
try {
    // automatically calls offsetGet()
    echo $p['exists.txt'];
    echo $p['doesnotexist.txt'];
} catch (BadMethodCallException $e) {
    echo $e;
}
?>

以上例程会输出：

file exists
Entry doesnotexist.txt does not exist

参见

  • Phar::offsetExists() - Determines whether a file exists in the phar
  • Phar::offsetSet() - Set the contents of an internal file to those of an external file
  • Phar::offsetUnset() - Remove a file from a phar


Set the contents of an internal file to those of an external file

  • ? Phar::offsetGet
  • Phar::offsetUnset ?
  • PHP Manual
  • Phar
  • Set the contents of an internal file to those of an external file

Phar::offsetSet

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::offsetSet — Set the contents of an internal file to those of an external file

说明

public Phar::offsetSet ( string $offset , string $value ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. offsetSet is used for modifying an existing file, or adding a new file to a Phar archive.

参数

offset

The filename (relative path) to modify in a Phar.

value

Content of the file.

返回值

No return values.

错误／异常

if phar.readonly is 1, BadMethodCallException is thrown, as modifying a Phar is only allowed when phar.readonly is set to 0. Throws PharException if there are any problems flushing changes made to the Phar archive to disk.

范例

Example #1 A Phar::offsetSet() example

offsetSet should not be accessed directly, but instead used via array access with the [] operator.

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
try {
    // calls offsetSet
    $p['file.txt'] = 'Hi there';
} catch (Exception $e) {
    echo 'Could not modify file.txt:', $e;
}
?>

注释

Note: Phar::addFile(), Phar::addFromString() and Phar::offsetSet() save a new phar archive each time they are called. If performance is a concern, Phar::buildFromDirectory() or Phar::buildFromIterator() should be used instead.

参见

  • Phar::offsetExists() - Determines whether a file exists in the phar
  • Phar::offsetGet() - Gets a PharFileInfo object for a specific file
  • Phar::offsetUnset() - Remove a file from a phar


Remove a file from a phar

  • ? Phar::offsetSet
  • Phar::running ?
  • PHP Manual
  • Phar
  • Remove a file from a phar

Phar::offsetUnset

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::offsetUnset — Remove a file from a phar

说明

public Phar::offsetUnset ( string $offset ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. offsetUnset is used for deleting an existing file, and is called by the unset() language construct.

参数

offset

The filename (relative path) to modify in a Phar.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

if phar.readonly is 1, BadMethodCallException is thrown, as modifying a Phar is only allowed when phar.readonly is set to 0. Throws PharException if there are any problems flushing changes made to the Phar archive to disk.

范例

Example #1 A Phar::offsetUnset() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
try {
    // deletes file.txt from my.phar by calling offsetUnset
    unset($p['file.txt']);
} catch (Exception $e) {
    echo 'Could not delete file.txt: ', $e;
}
?>

参见

  • Phar::offsetExists() - Determines whether a file exists in the phar
  • Phar::offsetGet() - Gets a PharFileInfo object for a specific file
  • Phar::offsetSet() - Set the contents of an internal file to those of an external file
  • Phar::unlinkArchive() - Completely remove a phar archive from disk and from memory
  • Phar::delete() - 删除 phar 档案中的一个文件


Returns the full path on disk or full phar URL to the currently executing Phar archive

  • ? Phar::offsetUnset
  • Phar::setAlias ?
  • PHP Manual
  • Phar
  • Returns the full path on disk or full phar URL to the currently executing Phar archive

Phar::running

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::running — Returns the full path on disk or full phar URL to the currently executing Phar archive

说明

final public static Phar::running ( bool $retphar = true ) : string

Returns the full path to the running phar archive. This is intended for use much like the __FILE__ magic constant, and only has effect inside an executing phar archive.

Inside the stub of an archive, Phar::running() returns "". Simply use __FILE__ to access the current running phar inside a stub.

参数

retphar

If false, the full path on disk to the phar archive is returned. If true, a full phar URL is returned.

返回值

Returns the filename if valid, empty string otherwise.

范例

Example #1 A Phar::running() example

For the following example, assume the phar archive is located at /path/to/phar/my.phar.

<?php
$a = Phar::running(); // $a is "phar:///path/to/my.phar"
$b = Phar::running(false); // $b is "/path/to/my.phar"
?>


Set the alias for the Phar archive

  • ? Phar::running
  • Phar::setDefaultStub ?
  • PHP Manual
  • Phar
  • Set the alias for the Phar archive

Phar::setAlias

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.1)

Phar::setAlias — Set the alias for the Phar archive

说明

public Phar::setAlias ( string $alias ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Set the alias for the Phar archive, and write it as the permanent alias for this phar archive. An alias can be used internally to a phar archive to ensure that use of the phar stream wrapper to access internal files always works regardless of the location of the phar archive on the filesystem. Another alternative is to rely upon Phar's interception of include or to use Phar::interceptFileFuncs() and use relative paths.

参数

alias

A shorthand string that this archive can be referred to in phar stream wrapper access.

返回值

错误／异常

Throws UnexpectedValueException when write access is disabled, and PharException if the alias is already in use or any problems were encountered flushing changes to disk.

范例

Example #1 A Phar::setAlias() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->setAlias('myp.phar');
} catch (Exception $e) {
    // handle error
}
?>

参见

  • Phar::__construct() - Construct a Phar archive object
  • Phar::interceptFileFuncs() - Instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions


Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader

  • ? Phar::setAlias
  • Phar::setMetadata ?
  • PHP Manual
  • Phar
  • Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader

Phar::setDefaultStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::setDefaultStub — Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader

说明

public Phar::setDefaultStub ( string $index = ? , string $webindex = ? ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

This method is a convenience method that combines the functionality of Phar::createDefaultStub() and Phar::setStub().

参数

index

Relative path within the phar archive to run if accessed on the command-line

webindex

Relative path within the phar archive to run if accessed through a web browser

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

UnexpectedValueException is thrown if phar.readonly is enabled in php.ini. PharException is thrown if any problems are encountered flushing changes to disk.

范例

Example #1 A Phar::setDefaultStub() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->setDefaultStub('cli.php', 'web/index.php');
    // this is the same as:
    // $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
} catch (Exception $e) {
    // handle errors
}
?>

参见

  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive
  • Phar::createDefaultStub() - Create a phar-file format specific stub


Sets phar archive meta-data

  • ? Phar::setDefaultStub
  • Phar::setSignatureAlgorithm ?
  • PHP Manual
  • Phar
  • Sets phar archive meta-data

Phar::setMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::setMetadata — Sets phar archive meta-data

说明

public Phar::setMetadata ( mixed $metadata ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Phar::setMetadata() should be used to store customized data that describes something about the phar archive as a complete entity. PharFileInfo::setMetadata() should be used for file-specific meta-data. Meta-data can slow down the performance of loading a phar archive if the data is large.

Some possible uses for meta-data include specifying which file within the archive should be used to bootstrap the archive, or the location of a file manifest like » PEAR's package.xml file. However, any useful data that describes the phar archive may be stored.

参数

metadata

Any PHP variable containing information to store that describes the phar archive

返回值

没有返回值。

范例

Example #1 A Phar::setMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.php'] = '<?php echo "hello"';
    $p->setMetadata(array('bootstrap' => 'file.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'Could not create and/or modify phar:', $e;
}
?>

以上例程会输出：

array(1) {
  ["bootstrap"]=>
  string(8) "file.php"
}

参见

  • Phar::getMetadata() - Returns phar archive meta-data
  • Phar::delMetadata() - Deletes the global metadata of the phar
  • Phar::hasMetadata() - Returns whether phar has global meta-data


Set the signature algorithm for a phar and apply it

  • ? Phar::setMetadata
  • Phar::setStub ?
  • PHP Manual
  • Phar
  • Set the signature algorithm for a phar and apply it

Phar::setSignatureAlgorithm

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.1.0)

Phar::setSignatureAlgorithm — Set the signature algorithm for a phar and apply it

说明

public Phar::setSignatureAlgorithm ( int $sigtype , string $privatekey = ? ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

set the signature algorithm for a phar and apply it. The signature algorithm must be one of Phar::MD5, Phar::SHA1, Phar::SHA256, Phar::SHA512, or Phar::OPENSSL.

Note that all executable phar archives have a signature created automatically, SHA1 by default. data tar- or zip-based archives (archives created with the PharData class) must have their signature created and set explicitly via Phar::setSignatureAlgorithm().

参数

sigtype

    One of Phar::MD5,
Phar::SHA1, Phar::SHA256,
Phar::SHA512, or Phar::OPENSSL

privatekey

The contents of an OpenSSL private key, as extracted from a certificate or OpenSSL key file:

<?php
$private = openssl_get_privatekey(file_get_contents('private.pem'));
$pkey = '';
openssl_pkey_export($private, $pkey);
$p->setSignatureAlgorithm(Phar::OPENSSL, $pkey);
?>
See phar introduction for instructions on naming and placement of the public key file.

返回值

没有返回值。

错误／异常

Throws UnexpectedValueException for many errors, and a PharException if any problems occur flushing changes to disk.

参见

  • Phar::getSupportedSignatures() - Return array of supported signature types
  • Phar::getSignature() - Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive


Used to set the PHP loader or bootstrap stub of a Phar archive

  • ? Phar::setSignatureAlgorithm
  • Phar::startBuffering ?
  • PHP Manual
  • Phar
  • Used to set the PHP loader or bootstrap stub of a Phar archive

Phar::setStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::setStub — Used to set the PHP loader or bootstrap stub of a Phar archive

说明

public Phar::setStub ( string $stub , int $len = -1 ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

This method is used to add a PHP bootstrap loader stub to a new Phar archive, or to replace the loader stub in an existing Phar archive.

The loader stub for a Phar archive is used whenever an archive is included directly as in this example:

<?php
include 'myphar.phar';
?>

The loader is not accessed when including a file through the phar stream wrapper like so:

<?php
include 'phar://myphar.phar/somefile.php';
?>

参数

stub

A string or an open stream handle to use as the executable stub for this phar archive.

len

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

UnexpectedValueException is thrown if phar.readonly is enabled in php.ini. PharException is thrown if any problems are encountered flushing changes to disk.

范例

Example #1 A Phar::setStub() example

<?php
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['a.php'] = '<?php var_dump("Hello");';
    $p->setStub('<?php var_dump("First"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>');
    include 'phar://brandnewphar.phar/a.php';
    var_dump($p->getStub());
    $p['b.php'] = '<?php var_dump("World");';
    $p->setStub('<?php var_dump("Second"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>');
    include 'phar://brandnewphar.phar/b.php';
    var_dump($p->getStub());
} catch (Exception $e) {
    echo 'Write operations failed on brandnewphar.phar: ', $e;
}
?>

以上例程会输出：

string(5) "Hello"
string(82) "<?php var_dump("First"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>"
string(5) "World"
string(83) "<?php var_dump("Second"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>"

参见

  • Phar::getStub() - Return the PHP loader or bootstrap stub of a Phar archive
  • Phar::createDefaultStub() - Create a phar-file format specific stub


Start buffering Phar write operations, do not modify the Phar object on disk

  • ? Phar::setStub
  • Phar::stopBuffering ?
  • PHP Manual
  • Phar
  • Start buffering Phar write operations, do not modify the Phar object on disk

Phar::startBuffering

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::startBuffering — Start buffering Phar write operations, do not modify the Phar object on disk

说明

public Phar::startBuffering ( ) : void

Although technically unnecessary, the Phar::startBuffering() method can provide a significant performance boost when creating or modifying a Phar archive with a large number of files. Ordinarily, every time a file within a Phar archive is created or modified in any way, the entire Phar archive will be recreated with the changes. In this way, the archive will be up-to-date with the activity performed on it.

However, this can be unnecessary when simply creating a new Phar archive, when it would make more sense to write the entire archive out at once. Similarly, it is often necessary to make a series of changes and to ensure that they all are possible before making any changes on disk, similar to the relational database concept of transactions. the Phar::startBuffering()/Phar::stopBuffering() pair of methods is provided for this purpose.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

返回值

没有返回值。

范例

Example #1 A Phar::startBuffering() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
} catch (Exception $e) {
    echo 'Could not create phar:', $e;
}
echo 'The new phar has ' . $p->count() . " entries\n";
$p->startBuffering();
$p['file.txt'] = 'hi';
$p['file2.txt'] = 'there';
$p['file2.txt']->setCompressedGZ();
$p['file3.txt'] = 'babyface';
$p['file3.txt']->setMetadata(42);
$p->setStub("<?php
function __autoload($class)
{
    include 'phar://myphar.phar/' . str_replace('_', '/', $class) . '.php';
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER();");
$p->stopBuffering();
?>

参见

  • Phar::stopBuffering() - Stop buffering write requests to the Phar archive, and save changes to disk
  • Phar::isBuffering() - Used to determine whether Phar write operations are being buffered, or are flushing directly to disk


Stop buffering write requests to the Phar archive, and save changes to disk

  • ? Phar::startBuffering
  • Phar::unlinkArchive ?
  • PHP Manual
  • Phar
  • Stop buffering write requests to the Phar archive, and save changes to disk

Phar::stopBuffering

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

Phar::stopBuffering — Stop buffering write requests to the Phar archive, and save changes to disk

说明

public Phar::stopBuffering ( ) : void

Phar::stopBuffering() is used in conjunction with the Phar::startBuffering() method. Phar::startBuffering() can provide a significant performance boost when creating or modifying a Phar archive with a large number of files. Ordinarily, every time a file within a Phar archive is created or modified in any way, the entire Phar archive will be recreated with the changes. In this way, the archive will be up-to-date with the activity performed on it.

However, this can be unnecessary when simply creating a new Phar archive, when it would make more sense to write the entire archive out at once. Similarly, it is often necessary to make a series of changes and to ensure that they all are possible before making any changes on disk, similar to the relational database concept of transactions. The Phar::startBuffering()/Phar::stopBuffering() pair of methods is provided for this purpose.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

返回值

没有返回值。

错误／异常

PharException is thrown if any problems are encountered flushing changes to disk.

范例

Example #1 A Phar::stopBuffering() example

<?php
$p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
$p['file1.txt'] = 'hi';
$p->startBuffering();
var_dump($p->getStub());
$p->setStub("<?php
function __autoload(\$class)
{
    include 'phar://brandnewphar.phar/' . str_replace('_', '/', \$class) . '.php';
}
Phar::mapPhar('brandnewphar.phar');
include 'phar://brandnewphar.phar/startup.php';
__HALT_COMPILER();");
$p->stopBuffering();
var_dump($p->getStub());
?>

以上例程会输出：

string(24) "<?php __HALT_COMPILER();"
string(195) "<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('brandnewphar.phar');
include 'phar://brandnewphar.phar/startup.php';
__HALT_COMPILER();"

参见

  • Phar::startBuffering() - Start buffering Phar write operations, do not modify the Phar object on disk
  • Phar::isBuffering() - Used to determine whether Phar write operations are being buffered, or are flushing directly to disk


Completely remove a phar archive from disk and from memory

  • ? Phar::stopBuffering
  • Phar::webPhar ?
  • PHP Manual
  • Phar
  • Completely remove a phar archive from disk and from memory

Phar::unlinkArchive

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::unlinkArchive — Completely remove a phar archive from disk and from memory

说明

final public static Phar::unlinkArchive ( string $archive ) : bool

Removes a phar archive from disk and memory.

参数

archive

The path on disk to the phar archive.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

PharException is thrown if there are any open file pointers to the phar archive, or any existing Phar, PharData, or PharFileInfo objects referring to the phar archive.

范例

Example #1 A Phar::unlinkArchive() example

<?php
// simple usage
Phar::unlinkArchive('/path/to/my.phar');

// more common example:
$p = new Phar('my.phar');
$fp = fopen('phar://my.phar/file.txt', 'r');
// this creates 'my.phar.gz'
$gp = $p->compress(Phar::GZ);
// remove all references to the archive
unset($p);
fclose($fp);
// now remove all traces of the archive
Phar::unlinkArchive('my.phar');
?>

参见

  • Phar::delete() - 删除 phar 档案中的一个文件
  • Phar::offsetUnset() - Remove a file from a phar


mapPhar for web-based phars. front controller for web applications

  • ? Phar::unlinkArchive
  • PharData ?
  • PHP Manual
  • Phar
  • mapPhar for web-based phars. front controller for web applications

Phar::webPhar

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

Phar::webPhar — mapPhar for web-based phars. front controller for web applications

说明

final public static Phar::webPhar ( string $alias = ? , string $index = "index.php" , string $f404 = ? , array $mimetypes = ? , callable $rewrites = ? ) : void

Phar::mapPhar() for web-based phars. This method parses $_SERVER['REQUEST_URI'] and routes a request from a web browser to an internal file within the phar archive. In essence, it simulates a web server, routing requests to the correct file, echoing the correct headers and parsing PHP files as needed. This powerful method is part of what makes it easy to convert an existing PHP application into a phar archive. Combined with Phar::mungServer() and Phar::interceptFileFuncs(), any web application can be used unmodified from a phar archive.

Phar::webPhar() should only be called from the stub of a phar archive (see here for more information on what a stub is).

参数

alias

The alias that can be used in phar:// URLs to refer to this archive, rather than its full path.

index

The location within the phar of the directory index.

f404

The location of the script to run when a file is not found. This script should output the proper HTTP 404 headers.

mimetypes

An array mapping additional file extensions to MIME type. If the default mapping is sufficient, pass an empty array. By default, these extensions are mapped to these MIME types:

<?php
$mimes = array(
    'phps' => Phar::PHPS, // pass to highlight_file()
    'c' => 'text/plain',
    'cc' => 'text/plain',
    'cpp' => 'text/plain',
    'c++' => 'text/plain',
    'dtd' => 'text/plain',
    'h' => 'text/plain',
    'log' => 'text/plain',
    'rng' => 'text/plain',
    'txt' => 'text/plain',
    'xsd' => 'text/plain',
    'php' => Phar::PHP, // parse as PHP
    'inc' => Phar::PHP, // parse as PHP
    'avi' => 'video/avi',
    'bmp' => 'image/bmp',
    'css' => 'text/css',
    'gif' => 'image/gif',
    'htm' => 'text/html',
    'html' => 'text/html',
    'htmls' => 'text/html',
    'ico' => 'image/x-ico',
    'jpe' => 'image/jpeg',
    'jpg' => 'image/jpeg',
    'jpeg' => 'image/jpeg',
    'js' => 'application/x-javascript',
    'midi' => 'audio/midi',
    'mid' => 'audio/midi',
    'mod' => 'audio/mod',
    'mov' => 'movie/quicktime',
    'mp3' => 'audio/mp3',
    'mpg' => 'video/mpeg',
    'mpeg' => 'video/mpeg',
    'pdf' => 'application/pdf',
    'png' => 'image/png',
    'swf' => 'application/shockwave-flash',
    'tif' => 'image/tiff',
    'tiff' => 'image/tiff',
    'wav' => 'audio/wav',
    'xbm' => 'image/xbm',
    'xml' => 'text/xml',
);
?>

rewrites

The rewrites function is passed a string as its only parameter and must return a string or false.

If you are using fast-cgi or cgi then the parameter passed to the function is the value of the $_SERVER['PATH_INFO'] variable. Otherwise, the parameter passed to the function is the value of the $_SERVER['REQUEST_URI'] variable.

If a string is returned it is used as the internal file path. If false is returned then webPhar() will send a HTTP 403 Denied Code.

返回值

没有返回值。

错误／异常

Throws PharException when unable to open the internal file to output, or if called from a non-stub. If an invalid array value is passed into mimetypes or an invalid callback is passed into rewrites, then UnexpectedValueException is thrown.

范例

Example #1 A Phar::webPhar() example

With the example below, the created phar will display Hello World if one browses to /myphar.phar/index.php or to /myphar.phar, and will display the source of index.phps if one browses to /myphar.phar/index.phps.

<?php
// creating the phar archive:
try {
    $phar = new Phar('myphar.phar');
    $phar['index.php'] = '<?php echo "Hello World"; ?>';
    $phar['index.phps'] = '<?php echo "Hello World"; ?>';
    $phar->setStub('<?php
Phar::webPhar();
__HALT_COMPILER(); ?>');
} catch (Exception $e) {
    // handle error here
}
?>

参见

  • Phar::mungServer() - Defines a list of up to 4 $_SERVER variables that should be modified for execution
  • Phar::interceptFileFuncs() - Instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions


The PharData class

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

简介

The PharData class provides a high-level interface to accessing and creating non-executable tar and zip archives. Because these archives do not contain a stub and cannot be executed by the phar extension, it is possible to create and manipulate regular zip and tar files using the PharData class even if phar.readonly php.ini setting is 1.

类摘要

PharData extends RecursiveDirectoryIterator implements Countable , ArrayAccess {
/* 继承的常量 */
const int FilesystemIterator::CURRENT_AS_PATHNAME = 32 ;
const int FilesystemIterator::CURRENT_AS_FILEINFO = 0 ;
const int FilesystemIterator::CURRENT_AS_SELF = 16 ;
const int FilesystemIterator::CURRENT_MODE_MASK = 240 ;
const int FilesystemIterator::KEY_AS_PATHNAME = 0 ;
const int FilesystemIterator::KEY_AS_FILENAME = 256 ;
const int FilesystemIterator::FOLLOW_SYMLINKS = 512 ;
const int FilesystemIterator::KEY_MODE_MASK = 3840 ;
const int FilesystemIterator::NEW_CURRENT_AND_KEY = 256 ;
const int FilesystemIterator::SKIP_DOTS = 4096 ;
const int FilesystemIterator::UNIX_PATHS = 8192 ;
/* 方法 */
public addEmptyDir ( string $dirname ) : void
public addFile ( string $file , string $localname = ? ) : void
public addFromString ( string $localname , string $contents ) : void
public buildFromDirectory ( string $base_dir , string $regex = ? ) : array
public buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array
public compress ( int $compression , string $extension = ? ) : PharData
public compressFiles ( int $compression ) : void
public __construct ( string $fname , int $flags = ? , string $alias = ? , int $format = Phar::TAR )
public convertToData ( int $format = ? , int $compression = ? , string $extension = ? ) : PharData
public convertToExecutable ( int $format = ? , int $compression = ? , string $extension = ? ) : Phar
public copy ( string $oldfile , string $newfile ) : bool
public decompress ( string $extension = ? ) : PharData
public decompressFiles ( ) : bool
public delMetadata ( ) : bool
public delete ( string $entry ) : bool
public extractTo ( string $pathto , string|array|null $files = null , bool $overwrite = false ) : bool
public isWritable ( ) : bool
public offsetSet ( string $offset , string $value ) : void
public offsetUnset ( string $offset ) : bool
public setAlias ( string $alias ) : bool
public setDefaultStub ( string $index = ? , string $webindex = ? ) : bool
public setMetadata ( mixed $metadata ) : void
public setSignatureAlgorithm ( int $sigtype ) : void
public setStub ( string $stub , int $len = -1 ) : bool
}

Table of Contents

  • PharData::addEmptyDir — Add an empty directory to the tar/zip archive
  • PharData::addFile — Add a file from the filesystem to the tar/zip archive
  • PharData::addFromString — Add a file from the filesystem to the tar/zip archive
  • PharData::buildFromDirectory — Construct a tar/zip archive from the files within a directory
  • PharData::buildFromIterator — Construct a tar or zip archive from an iterator
  • PharData::compress — Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • PharData::compressFiles — Compresses all files in the current tar/zip archive
  • PharData::__construct — Construct a non-executable tar or zip archive object
  • PharData::convertToData — Convert a phar archive to a non-executable tar or zip file
  • PharData::convertToExecutable — Convert a non-executable tar/zip archive to an executable phar archive
  • PharData::copy — Copy a file internal to the phar archive to another new file within the phar
  • PharData::decompress — Decompresses the entire Phar archive
  • PharData::decompressFiles — Decompresses all files in the current zip archive
  • PharData::delMetadata — Deletes the global metadata of a zip archive
  • PharData::delete — Delete a file within a tar/zip archive
  • PharData::extractTo — Extract the contents of a tar/zip archive to a directory
  • PharData::isWritable — Returns true if the tar/zip archive can be modified
  • PharData::offsetSet — Set the contents of a file within the tar/zip to those of an external file or string
  • PharData::offsetUnset — Remove a file from a tar/zip archive
  • PharData::setAlias — Dummy function (Phar::setAlias is not valid for PharData)
  • PharData::setDefaultStub — Dummy function (Phar::setDefaultStub is not valid for PharData)
  • PharData::setMetadata — Sets phar archive meta-data
  • PharData::setSignatureAlgorithm — Set the signature algorithm for a phar and apply it
  • PharData::setStub — Dummy function (Phar::setStub is not valid for PharData)


Add an empty directory to the tar/zip archive

  • ? PharData
  • PharData::addFile ?
  • PHP Manual
  • PharData
  • Add an empty directory to the tar/zip archive

PharData::addEmptyDir

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::addEmptyDir — Add an empty directory to the tar/zip archive

说明

public PharData::addEmptyDir ( string $dirname ) : void

With this method, an empty directory is created with path dirname. This method is similar to ZipArchive::addEmptyDir().

参数

dirname

The name of the empty directory to create in the phar archive

返回值

no return value, exception is thrown on failure.

范例

Example #1 A PharData::addEmptyDir() example

<?php
try {
    $a = new PharData('/path/to/my.tar');

    $a->addEmptyDir('/full/path/to/file');
    // demonstrates how this file is stored
    $b = $a['full/path/to/file']->isDir();
} catch (Exception $e) {
    // handle errors here
}
?>

参见

  • Phar::addEmptyDir() - 添加一个空目录到 phar 档案
  • PharData::addFile() - Add a file from the filesystem to the tar/zip archive
  • PharData::addFromString() - Add a file from the filesystem to the tar/zip archive


Add a file from the filesystem to the tar/zip archive

  • ? PharData::addEmptyDir
  • PharData::addFromString ?
  • PHP Manual
  • PharData
  • Add a file from the filesystem to the tar/zip archive

PharData::addFile

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::addFile — Add a file from the filesystem to the tar/zip archive

说明

public PharData::addFile ( string $file , string $localname = ? ) : void

With this method, any file or URL can be added to the tar/zip archive. If the optional second parameter localname is specified, the file will be stored in the archive with that name, otherwise the file parameter is used as the path to store within the archive. URLs must have a localname or an exception is thrown. This method is similar to ZipArchive::addFile().

参数

file

Full or relative path to a file on disk to be added to the phar archive.

localname

Path that the file will be stored in the archive.

返回值

no return value, exception is thrown on failure.

范例

Example #1 A PharData::addFile() example

<?php
try {
    $a = new PharData('/path/to/my.tar');

    $a->addFile('/full/path/to/file');
    // demonstrates how this file is stored
    $b = $a['full/path/to/file']->getContent();

    $a->addFile('/full/path/to/file', 'my/file.txt');
    $c = $a['my/file.txt']->getContent();

    // demonstrate URL usage
    $a->addFile('http://www.example.com', 'example.html');
} catch (Exception $e) {
    // handle errors here
}
?>

注释

Note: PharData::addFile(), PharData::addFromString() and PharData::offsetSet() save a new phar archive each time they are called. If performance is a concern, PharData::buildFromDirectory() or PharData::buildFromIterator() should be used instead.

参见

  • PharData::offsetSet() - Set the contents of a file within the tar/zip to those of an external file or string
  • Phar::addFile() - 将一个文件从文件系统添加到 phar 档案中
  • PharData::addFromString() - Add a file from the filesystem to the tar/zip archive
  • PharData::addEmptyDir() - Add an empty directory to the tar/zip archive


Add a file from the filesystem to the tar/zip archive

  • ? PharData::addFile
  • PharData::buildFromDirectory ?
  • PHP Manual
  • PharData
  • Add a file from the filesystem to the tar/zip archive

PharData::addFromString

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::addFromString — Add a file from the filesystem to the tar/zip archive

说明

public PharData::addFromString ( string $localname , string $contents ) : void

With this method, any string can be added to the tar/zip archive. The file will be stored in the archive with localname as its path. This method is similar to ZipArchive::addFromString().

参数

localname

Path that the file will be stored in the archive.

contents

The file contents to store

返回值

no return value, exception is thrown on failure.

范例

Example #1 A PharData::addFromString() example

<?php
try {
    $a = new PharData('/path/to/my.tar');

    $a->addFromString('path/to/file.txt', 'my simple file');
    $b = $a['path/to/file.txt']->getContent();

    // to add contents from a stream handle for large files, use offsetSet()
    $c = fopen('/path/to/hugefile.bin');
    $a['largefile.bin'] = $c;
    fclose($c);
} catch (Exception $e) {
    // handle errors here
}
?>

注释

Note: PharData::addFile(), PharData::addFromString() and PharData::offsetSet() save a new phar archive each time they are called. If performance is a concern, PharData::buildFromDirectory() or PharData::buildFromIterator() should be used instead.

参见

  • PharData::offsetSet() - Set the contents of a file within the tar/zip to those of an external file or string
  • Phar::addFromString() - 以字符串的形式添加一个文件到 phar 档案
  • PharData::addFile() - Add a file from the filesystem to the tar/zip archive
  • PharData::addEmptyDir() - Add an empty directory to the tar/zip archive


Construct a tar/zip archive from the files within a directory

  • ? PharData::addFromString
  • PharData::buildFromIterator ?
  • PHP Manual
  • PharData
  • Construct a tar/zip archive from the files within a directory

PharData::buildFromDirectory

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::buildFromDirectory — Construct a tar/zip archive from the files within a directory

说明

public PharData::buildFromDirectory ( string $base_dir , string $regex = ? ) : array

Populate a tar/zip archive from directory contents. The optional second parameter is a regular expression (pcre) that is used to exclude files. Any filename that matches the regular expression will be included, all others will be excluded. For more fine-grained control, use PharData::buildFromIterator().

参数

base_dir

The full or relative path to the directory that contains all files to add to the archive.

regex

An optional pcre regular expression that is used to filter the list of files. Only file paths matching the regular expression will be included in the archive.

返回值

Phar::buildFromDirectory() returns an associative array mapping internal path of file to the full path of the file on the filesystem.

错误／异常

This method throws BadMethodCallException when unable to instantiate the internal directory iterators, or a PharException if there were errors saving the phar archive.

范例

Example #1 A PharData::buildFromDirectory() example

<?php
$phar = new PharData('project.tar');
// add all files in the project
$phar->buildFromDirectory(dirname(__FILE__) . '/project');

$phar2 = new PharData('project2.zip');
// add all files in the project, only include php files
$phar2->buildFromDirectory(dirname(__FILE__) . '/project', '/\.php$/');
?>

参见

  • Phar::buildFromDirectory() - Construct a phar archive from the files within a directory
  • PharData::buildFromIterator() - Construct a tar or zip archive from an iterator


Construct a tar or zip archive from an iterator

  • ? PharData::buildFromDirectory
  • PharData::compress ?
  • PHP Manual
  • PharData
  • Construct a tar or zip archive from an iterator

PharData::buildFromIterator

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::buildFromIterator — Construct a tar or zip archive from an iterator

说明

public PharData::buildFromIterator ( Iterator $iter , string $base_directory = ? ) : array

Populate a tar or zip archive from an iterator. Two styles of iterators are supported, iterators that map the filename within the tar/zip to the name of a file on disk, and iterators like DirectoryIterator that return SplFileInfo objects. For iterators that return SplFileInfo objects, the second parameter is required.

范例

Example #1 A PharData::buildFromIterator() with SplFileInfo

For most tar/zip archives, the archive will reflect an actual directory layout, and the second style is the most useful. For instance, to create a tar/zip archive containing the files in this sample directory layout:

/path/to/project/
                 config/
                        dist.xml
                        debug.xml
                 lib/
                     file1.php
                     file2.php
                 src/
                     processthing.php
                 www/
                     index.php
                 cli/
                     index.php

This code could be used to add these files to the "project.tar" tar archive:

<?php
$phar = new PharData('project.tar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new RecursiveDirectoryIterator('/path/to/project')),
    '/path/to/project');
?>

The file project.tar can then be used immediately. PharData::buildFromIterator() does not set values such as compression, metadata, and this can be done after creating the tar/zip archive.

As an interesting note, PharData::buildFromIterator() can also be used to copy the contents of an existing phar, tar or zip archive, as the PharData object descends from DirectoryIterator:

<?php
$phar = new PharData('project.tar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new Phar('/path/to/anotherphar.phar')),
    'phar:///path/to/anotherphar.phar/path/to/project');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Example #2 A PharData::buildFromIterator() with other iterators

The second form of the iterator can be used with any iterator that returns a key => value mapping, such as an ArrayIterator:

<?php
$phar = new PharData('project.tar');
$phar->buildFromIterator(
    new ArrayIterator(
     array(
        'internal/file.php' => dirname(__FILE__) . '/somefile.php',
        'another/file.jpg' => fopen('/path/to/bigfile.jpg', 'rb'),
     )));
?>

参数

iter

Any iterator that either associatively maps tar/zip file to location or returns SplFileInfo objects

base_directory

For iterators that return SplFileInfo objects, the portion of each file's full path to remove when adding to the tar/zip archive

返回值

PharData::buildFromIterator() returns an associative array mapping internal path of file to the full path of the file on the filesystem.

错误／异常

This method returns UnexpectedValueException when the iterator returns incorrect values, such as an integer key instead of a string, a BadMethodCallException when an SplFileInfo-based iterator is passed without a base_directory parameter, or a PharException if there were errors saving the phar archive.

参见

  • Phar::buildFromIterator() - Construct a phar archive from an iterator


Compresses the entire tar/zip archive using Gzip or Bzip2 compression

  • ? PharData::buildFromIterator
  • PharData::compressFiles ?
  • PHP Manual
  • PharData
  • Compresses the entire tar/zip archive using Gzip or Bzip2 compression

PharData::compress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::compress — Compresses the entire tar/zip archive using Gzip or Bzip2 compression

说明

public PharData::compress ( int $compression , string $extension = ? ) : PharData

For tar archives, this method compresses the entire archive using gzip compression or bzip2 compression. The resulting file can be processed with the gunzip command/bunzip command, or accessed directly and transparently with the Phar extension.

For zip archives, this method fails with an exception. The zlib extension must be enabled to compress with gzip compression, the bzip2 extension must be enabled in order to compress with bzip2 compression.

In addition, this method automatically renames the archive, appending .gz, .bz2 or removing the extension if passed Phar::NONE to remove compression. Alternatively, a file extension may be specified with the second parameter.

参数

compression

Compression must be one of Phar::GZ, Phar::BZ2 to add compression, or Phar::NONE to remove compression.

extension

By default, the extension is .tar.gz or .tar.bz2 for compressing a tar, and .tar for decompressing.

返回值

A PharData object is returned.

错误／异常

Throws BadMethodCallException if the zlib extension is not available, or the bzip2 extension is not enabled.

范例

Example #1 A PharData::compress() example

<?php
$p = new PharData('/path/to/my.tar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p1 = $p->compress(Phar::GZ); // copies to /path/to/my.tar.gz
$p2 = $p->compress(Phar::BZ2); // copies to /path/to/my.tar.bz2
$p3 = $p2->compress(Phar::NONE); // exception: /path/to/my.tar already exists
?>

参见

  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression


Compresses all files in the current tar/zip archive

  • ? PharData::compress
  • PharData::__construct ?
  • PHP Manual
  • PharData
  • Compresses all files in the current tar/zip archive

PharData::compressFiles

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::compressFiles — Compresses all files in the current tar/zip archive

说明

public PharData::compressFiles ( int $compression ) : void

For tar-based archives, this method throws a BadMethodCallException, as compression of individual files within a tar archive is not supported by the file format. Use PharData::compress() to compress an entire tar-based archive.

For Zip-based archives, this method compresses all files in the archive using the specified compression. The zlib or bzip2 extensions must be enabled to take advantage of this feature. In addition, if any files are already compressed using bzip2/zlib compression, the respective extension must be enabled in order to decompress the files prior to re-compressing.

参数

compression

Compression must be one of Phar::GZ, Phar::BZ2 to add compression, or Phar::NONE to remove compression.

返回值

没有返回值。

错误／异常

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

范例

Example #1 A PharData::compressFiles() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
$p->compressFiles(Phar::GZ);
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
?>

以上例程会输出：

string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)
string(10) "myfile.txt"
int(4096)
bool(false)
bool(true)
string(11) "myfile2.txt"
int(4096)
bool(false)
bool(true)

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • PharData::decompressFiles() - Decompresses all files in the current zip archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • PharData::decompress() - Decompresses the entire Phar archive


Construct a non-executable tar or zip archive object

  • ? PharData::compressFiles
  • PharData::convertToData ?
  • PHP Manual
  • PharData
  • Construct a non-executable tar or zip archive object

PharData::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::__construct — Construct a non-executable tar or zip archive object

说明

public PharData::__construct ( string $fname , int $flags = ? , string $alias = ? , int $format = Phar::TAR )

参数

fname

Path to an existing tar/zip archive or to-be-created archive

flags

Flags to pass to Phar parent class RecursiveDirectoryIterator.

alias

Alias with which this Phar archive should be referred to in calls to stream functionality.

format

One of the file format constants available within the Phar class.

错误／异常

Throws BadMethodCallException if called twice; UnexpectedValueException if the Phar archive can't be opened.

范例

Example #1 A PharData::__construct() example

<?php
try {
    $p = new PharData('/path/to/my.tar', Phar::CURRENT_AS_FILEINFO | Phar::KEY_AS_FILENAME);
} catch (UnexpectedValueException $e) {
    die('Could not open my.tar');
} catch (BadMethodCallException $e) {
    echo 'technically, this cannot happen';
}
echo file_get_contents('phar:///path/to/my.tar/example.txt');
?>


Convert a phar archive to a non-executable tar or zip file

  • ? PharData::__construct
  • PharData::convertToExecutable ?
  • PHP Manual
  • PharData
  • Convert a phar archive to a non-executable tar or zip file

PharData::convertToData

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::convertToData — Convert a phar archive to a non-executable tar or zip file

说明

public PharData::convertToData ( int $format = ? , int $compression = ? , string $extension = ? ) : PharData

This method is used to convert a non-executable tar or zip archive to another non-executable format.

If no changes are specified, this method throws a BadMethodCallException. This method should be used to convert a tar archive to zip format or vice-versa. Although it is possible to simply change the compression of a tar archive using this method, it is better to use the PharData::compress() method for logical consistency.

If successful, the method creates a new archive on disk and returns a PharData object. The old archive is not removed from disk, and should be done manually after the process has finished.

参数

format

This should be one of Phar::TAR or Phar::ZIP. If set to null, the existing file format will be preserved.

compression

This should be one of Phar::NONE for no whole-archive compression, Phar::GZ for zlib-based compression, and Phar::BZ2 for bzip-based compression.

extension

This parameter is used to override the default file extension for a converted archive. Note that .phar cannot be used anywhere in the filename for a non-executable tar or zip archive.

If converting to a tar-based phar archive, the default extensions are .tar, .tar.gz, and .tar.bz2 depending on specified compression. For zip-based archives, the default extension is .zip.

返回值

The method returns a PharData object on success and throws an exception on failure.

错误／异常

This method throws BadMethodCallException when unable to compress, an unknown compression method has been specified, the requested archive is buffering with Phar::startBuffering() and has not concluded with Phar::stopBuffering(), and a PharException if any problems are encountered during the phar creation process.

范例

Example #1 A PharData::convertToData() example

Using PharData::convertToData():

<?php
try {
    $tarphar = new PharData('myphar.tar');
    // note that myphar.tar is *not* unlinked
    // convert it to the non-executable tar file format
    // creates myphar.zip
    $zip = $tarphar->convertToData(Phar::ZIP);
    // create myphar.tbz
    $tgz = $zip->convertToData(Phar::TAR, Phar::BZ2, '.tbz');
    // creates myphar.phar.tgz
    $phar = $tarphar->convertToData(Phar::PHAR); // throws exception
} catch (Exception $e) {
    // handle the error here
}
?>

参见

  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file
  • PharData::convertToExecutable() - Convert a non-executable tar/zip archive to an executable phar archive


Convert a non-executable tar/zip archive to an executable phar archive

  • ? PharData::convertToData
  • PharData::copy ?
  • PHP Manual
  • PharData
  • Convert a non-executable tar/zip archive to an executable phar archive

PharData::convertToExecutable

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::convertToExecutable — Convert a non-executable tar/zip archive to an executable phar archive

说明

public PharData::convertToExecutable ( int $format = ? , int $compression = ? , string $extension = ? ) : Phar

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

This method is used to convert a non-executable tar or zip archive to an executable phar archive. Any of the three executable file formats (phar, tar or zip) can be used, and whole-archive compression can also be performed.

If no changes are specified, this method throws a BadMethodCallException.

If successful, the method creates a new archive on disk and returns a Phar object. The old archive is not removed from disk, and should be done manually after the process has finished.

参数

format

This should be one of Phar::PHAR, Phar::TAR, or Phar::ZIP. If set to null, the existing file format will be preserved.

compression

This should be one of Phar::NONE for no whole-archive compression, Phar::GZ for zlib-based compression, and Phar::BZ2 for bzip-based compression.

extension

This parameter is used to override the default file extension for a converted archive. Note that all zip- and tar-based phar archives must contain .phar in their file extension in order to be processed as a phar archive.

If converting to a phar-based archive, the default extensions are .phar, .phar.gz, or .phar.bz2 depending on the specified compression. For tar-based phar archives, the default extensions are .phar.tar, .phar.tar.gz, and .phar.tar.bz2. For zip-based phar archives, the default extension is .phar.zip.

返回值

The method returns a Phar object on success and throws an exception on failure.

错误／异常

This method throws BadMethodCallException when unable to compress, an unknown compression method has been specified, the requested archive is buffering with Phar::startBuffering() and has not concluded with Phar::stopBuffering(), an UnexpectedValueException if write support is disabled, and a PharException if any problems are encountered during the phar creation process.

范例

Example #1 A PharData::convertToExecutable() example

Using PharData::convertToExecutable():

<?php
try {
    $tarphar = new PharData('myphar.tar');
    // convert it to the phar file format
    // note that myphar.tar is *not* unlinked
    $phar = $tarphar->convertToExecutable(Phar::PHAR); // creates myphar.phar
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
    // creates myphar.phar.tgz
    $compressed = $tarphar->convertToExecutable(Phar::TAR, Phar::GZ, '.phar.tgz');
} catch (Exception $e) {
    // handle the error here
}
?>

参见

  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file
  • PharData::convertToData() - Convert a phar archive to a non-executable tar or zip file


Copy a file internal to the phar archive to another new file within the phar

  • ? PharData::convertToExecutable
  • PharData::decompress ?
  • PHP Manual
  • PharData
  • Copy a file internal to the phar archive to another new file within the phar

PharData::copy

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::copy — Copy a file internal to the phar archive to another new file within the phar

说明

public PharData::copy ( string $oldfile , string $newfile ) : bool

Copy a file internal to the tar/zip archive to another new file within the same archive. This is an object-oriented alternative to using copy() with the phar stream wrapper.

参数

oldfile

newfile

返回值

returns true on success, but it is safer to encase method call in a try/catch block and assume success if no exception is thrown.

错误／异常

throws UnexpectedValueException if the source file does not exist, the destination file already exists, write access is disabled, opening either file fails, reading the source file fails, or a PharException if writing the changes to the phar fails.

范例

Example #1 A PharData::copy() example

This example shows using PharData::copy() and the equivalent stream wrapper performance of the same thing. The primary difference between the two approaches is error handling. All PharData methods throw exceptions, whereas the stream wrapper uses trigger_error().

<?php
try {
    $phar = new PharData('myphar.tar');
    $phar['a'] = 'hi';
    $phar->copy('a', 'b');
    echo $phar['b']; // outputs "phar://myphar.tar/b"
} catch (Exception $e) {
    // handle error
}

// the stream wrapper equivalent of the above code.
// E_WARNINGS are triggered on error rather than exceptions.
copy('phar://myphar.tar/a', 'phar//myphar.tar/c');
echo file_get_contents('phar://myphar.tar/c'); // outputs "hi"
?>


Decompresses the entire Phar archive

  • ? PharData::copy
  • PharData::decompressFiles ?
  • PHP Manual
  • PharData
  • Decompresses the entire Phar archive

PharData::decompress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::decompress — Decompresses the entire Phar archive

说明

public PharData::decompress ( string $extension = ? ) : PharData

For tar-based archives, this method decompresses the entire archive.

For Zip-based archives, this method fails with an exception. The zlib extension must be enabled to decompress an archive compressed with gzip compression, and the bzip2 extension must be enabled in order to decompress an archive compressed with bzip2 compression.

In addition, this method automatically renames the file extension of the archive, .tar by default. Alternatively, a file extension may be specified with the extension parameter.

参数

extension

For decompressing, the default file extension is .tar. Use this parameter to specify another file extension. Be aware that only executable archives can contain .phar in their filename.

返回值

A PharData object is returned.

错误／异常

Throws BadMethodCallException if the zlib extension is not available, or the bzip2 extension is not enabled.

范例

Example #1 A PharData::decompress() example

<?php
$p = new PharData('/path/to/my.tar.gz');
$p->decompress(); // creates /path/to/my.tar
?>

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • PharData::compressFiles() - Compresses all files in the current tar/zip archive
  • PharData::decompressFiles() - Decompresses all files in the current zip archive


Decompresses all files in the current zip archive

  • ? PharData::decompress
  • PharData::delMetadata ?
  • PHP Manual
  • PharData
  • Decompresses all files in the current zip archive

PharData::decompressFiles

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::decompressFiles — Decompresses all files in the current zip archive

说明

public PharData::decompressFiles ( ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

For tar-based archives, this method throws a BadMethodCallException, as compression of individual files within a tar archive is not supported by the file format. Use PharData::compress() to compress an entire tar-based archive.

For Zip-based archives, this method decompresses all files in the archive. The zlib or bzip2 extensions must be enabled to take advantage of this feature if any files are compressed using bzip2/zlib compression.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws BadMethodCallException if the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

范例

Example #1 A PharData::decompressFiles() example

<?php
$p = new PharData('/path/to/my.zip');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p->compressFiles(Phar::GZ);
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
$p->decompressFiles();
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
?>

以上例程会输出：

string(10) "myfile.txt"
int(4096)
bool(false)
bool(true)
string(11) "myfile2.txt"
int(4096)
bool(false)
bool(true)
string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • PharData::compressFiles() - Compresses all files in the current tar/zip archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • PharData::decompress() - Decompresses the entire Phar archive


Deletes the global metadata of a zip archive

  • ? PharData::decompressFiles
  • PharData::delete ?
  • PHP Manual
  • PharData
  • Deletes the global metadata of a zip archive

PharData::delMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::delMetadata — Deletes the global metadata of a zip archive

说明

public PharData::delMetadata ( ) : bool

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Deletes the global metadata of the zip archive

参数

返回值

returns true on success, but it is better to check for thrown exception, and assume success if none is thrown.

错误／异常

Throws PharException if errors occur while flushing changes to disk.

范例

Example #1 A PharData::delMetaData() example

<?php
try {
    $phar = new PharData('myphar.zip');
    var_dump($phar->getMetadata());
    $phar->setMetadata("hi there");
    var_dump($phar->getMetadata());
    $phar->delMetadata();
    var_dump($phar->getMetadata());
} catch (Exception $e) {
    // handle errors
}
?>

以上例程会输出：

NULL
string(8) "hi there"
NULL

参见

  • Phar::delMetadata() - Deletes the global metadata of the phar


Delete a file within a tar/zip archive

  • ? PharData::delMetadata
  • PharData::extractTo ?
  • PHP Manual
  • PharData
  • Delete a file within a tar/zip archive

PharData::delete

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::delete — Delete a file within a tar/zip archive

说明

public PharData::delete ( string $entry ) : bool

Delete a file within an archive. This is the functional equivalent of calling unlink() on the stream wrapper equivalent, as shown in the example below.

参数

entry

Path within an archive to the file to delete.

返回值

returns true on success, but it is better to check for thrown exception, and assume success if none is thrown.

错误／异常

Throws PharException if errors occur while flushing changes to disk.

范例

Example #1 A PharData::delete() example

<?php
try {
    $phar = new PharData('myphar.zip');
    $phar->delete('unlink/me.php');
    // this is equivalent to:
    unlink('phar://myphar.phar/unlink/me.php');
} catch (Exception $e) {
    // handle errors
}
?>

参见

  • Phar::delete() - 删除 phar 档案中的一个文件


Extract the contents of a tar/zip archive to a directory

  • ? PharData::delete
  • PharData::isWritable ?
  • PHP Manual
  • PharData
  • Extract the contents of a tar/zip archive to a directory

PharData::extractTo

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::extractTo — Extract the contents of a tar/zip archive to a directory

说明

public PharData::extractTo ( string $pathto , string|array|null $files = null , bool $overwrite = false ) : bool

Extract all files within a tar/zip archive to disk. Extracted files and directories preserve permissions as stored in the archive. The optional parameters allow optional control over which files are extracted, and whether existing files on disk can be overwritten. The second parameter files can be either the name of a file or directory to extract, or an array of names of files and directories to extract. By default, this method will not overwrite existing files, the third parameter can be set to true to enable overwriting of files. This method is similar to ZipArchive::extractTo().

参数

pathto

Path to extract the given files to

files

The name of a file or directory to extract, or an array of files/directories to extract

overwrite

Set to true to enable overwriting existing files

返回值

returns true on success, but it is better to check for thrown exception, and assume success if none is thrown.

错误／异常

Throws PharException if errors occur while flushing changes to disk.

范例

Example #1 A PharData::extractTo() example

<?php
try {
    $phar = new PharData('myphar.tar');
    $phar->extractTo('/full/path'); // extract all files
    $phar->extractTo('/another/path', 'file.txt'); // extract only file.txt
    $phar->extractTo('/this/path',
        array('file1.txt', 'file2.txt')); // extract 2 files only
    $phar->extractTo('/third/path', null, true); // extract all files, and overwrite
} catch (Exception $e) {
    // handle errors
}
?>

参见

  • Phar::extractTo() - Extract the contents of a phar archive to a directory


Returns true if the tar/zip archive can be modified

  • ? PharData::extractTo
  • PharData::offsetSet ?
  • PHP Manual
  • PharData
  • Returns true if the tar/zip archive can be modified

PharData::isWritable

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::isWritable — Returns true if the tar/zip archive can be modified

说明

public PharData::isWritable ( ) : bool

This method returns true if the tar/zip archive on disk is not read-only. Unlike Phar::isWritable(), data-only tar/zip archives can be modified even if phar.readonly is set to 1.

参数

No parameters.

返回值

Returns true if the tar/zip archive can be modified

参见

  • Phar::canWrite() - Returns whether phar extension supports writing and creating phars
  • Phar::isWritable() - Returns true if the phar archive can be modified


Set the contents of a file within the tar/zip to those of an external file or string

  • ? PharData::isWritable
  • PharData::offsetUnset ?
  • PHP Manual
  • PharData
  • Set the contents of a file within the tar/zip to those of an external file or string

PharData::offsetSet

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::offsetSet — Set the contents of a file within the tar/zip to those of an external file or string

说明

public PharData::offsetSet ( string $offset , string $value ) : void

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a tar/zip archive using array access brackets. offsetSet is used for modifying an existing file, or adding a new file to a tar/zip archive.

参数

offset

The filename (relative path) to modify in a tar or zip archive.

value

Content of the file.

返回值

No return values.

错误／异常

Throws PharException if there are any problems flushing changes made to the tar/zip archive to disk.

范例

Example #1 A PharData::offsetSet() example

offsetSet should not be accessed directly, but instead used via array access with the [] operator.

<?php
$p = new PharData('/path/to/my.tar');
try {
    // calls offsetSet
    $p['file.txt'] = 'Hi there';
} catch (Exception $e) {
    echo 'Could not modify file.txt:', $e;
}
?>

注释

Note: PharData::addFile(), PharData::addFromString() and PharData::offsetSet() save a new phar archive each time they are called. If performance is a concern, PharData::buildFromDirectory() or PharData::buildFromIterator() should be used instead.

参见

  • Phar::offsetSet() - Set the contents of an internal file to those of an external file


Remove a file from a tar/zip archive

  • ? PharData::offsetSet
  • PharData::setAlias ?
  • PHP Manual
  • PharData
  • Remove a file from a tar/zip archive

PharData::offsetUnset

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::offsetUnset — Remove a file from a tar/zip archive

说明

public PharData::offsetUnset ( string $offset ) : bool

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a tar/zip archive using array access brackets. offsetUnset is used for deleting an existing file, and is called by the unset() language construct.

参数

offset

The filename (relative path) to modify in the tar/zip archive.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws PharException if there are any problems flushing changes made to the tar/zip archive to disk.

范例

Example #1 A PharData::offsetUnset() example

<?php
$p = new PharData('/path/to/my.zip');
try {
    // deletes file.txt from my.zip by calling offsetUnset
    unset($p['file.txt']);
} catch (Exception $e) {
    echo 'Could not delete file.txt: ', $e;
}
?>

参见

  • Phar::offsetUnset() - Remove a file from a phar


Dummy function (Phar::setAlias is not valid for PharData)

  • ? PharData::offsetUnset
  • PharData::setDefaultStub ?
  • PHP Manual
  • PharData
  • Dummy function (Phar::setAlias is not valid for PharData)

PharData::setAlias

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::setAlias — Dummy function (Phar::setAlias is not valid for PharData)

说明

public PharData::setAlias ( string $alias ) : bool

Non-executable tar/zip archives cannot have an alias, so this method simply throws an exception.

参数

alias

A shorthand string that this archive can be referred to in phar stream wrapper access. This parameter is ignored.

返回值

错误／异常

Throws PharException on all method calls

参见

  • Phar::setAlias() - Set the alias for the Phar archive


Dummy function (Phar::setDefaultStub is not valid for PharData)

  • ? PharData::setAlias
  • PharData::setMetadata ?
  • PHP Manual
  • PharData
  • Dummy function (Phar::setDefaultStub is not valid for PharData)

PharData::setDefaultStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::setDefaultStub — Dummy function (Phar::setDefaultStub is not valid for PharData)

说明

public PharData::setDefaultStub ( string $index = ? , string $webindex = ? ) : bool

Non-executable tar/zip archives cannot have a stub, so this method simply throws an exception.

参数

index

Relative path within the phar archive to run if accessed on the command-line

webindex

Relative path within the phar archive to run if accessed through a web browser

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws PharException on all method calls

参见

  • Phar::setDefaultStub() - Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader


Sets phar archive meta-data

  • ? PharData::setDefaultStub
  • PharData::setSignatureAlgorithm ?
  • PHP Manual
  • PharData
  • Sets phar archive meta-data

PharData::setMetadata

(No version information available, might only be in Git)

PharData::setMetadata — Sets phar archive meta-data

说明

public PharData::setMetadata ( mixed $metadata ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Phar::setMetadata() should be used to store customized data that describes something about the phar archive as a complete entity. PharFileInfo::setMetadata() should be used for file-specific meta-data. Meta-data can slow down the performance of loading a phar archive if the data is large.

Some possible uses for meta-data include specifying which file within the archive should be used to bootstrap the archive, or the location of a file manifest like » PEAR's package.xml file. However, any useful data that describes the phar archive may be stored.

参数

metadata

Any PHP variable containing information to store that describes the phar archive

返回值

没有返回值。

范例

Example #1 A Phar::setMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.php'] = '<?php echo "hello"';
    $p->setMetadata(array('bootstrap' => 'file.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'Could not create and/or modify phar:', $e;
}
?>

以上例程会输出：

array(1) {
  ["bootstrap"]=>
  string(8) "file.php"
}

参见

  • Phar::getMetadata() - Returns phar archive meta-data
  • Phar::delMetadata() - Deletes the global metadata of the phar
  • Phar::hasMetadata() - Returns whether phar has global meta-data


Set the signature algorithm for a phar and apply it

  • ? PharData::setMetadata
  • PharData::setStub ?
  • PHP Manual
  • PharData
  • Set the signature algorithm for a phar and apply it

PharData::setSignatureAlgorithm

(No version information available, might only be in Git)

PharData::setSignatureAlgorithm — Set the signature algorithm for a phar and apply it

说明

public PharData::setSignatureAlgorithm ( int $sigtype ) : void

Note:

此方法需要 将 php.ini 中的 phar.readonly 设为 0 以适合 Phar 对象. 否则, 将抛出PharException.

Set the signature algorithm for a phar and apply it. The signature algorithm must be one of Phar::MD5, Phar::SHA1, Phar::SHA256, Phar::SHA512, or Phar::OPENSSL.

参数

sigtype

    One of Phar::MD5,
Phar::SHA1, Phar::SHA256,
Phar::SHA512, or Phar::OPENSSL

返回值

没有返回值。

错误／异常

Throws UnexpectedValueException for many errors, BadMethodCallException if called for a zip- or a tar-based phar archive, and a PharException if any problems occur flushing changes to disk.

参见

  • Phar::getSupportedSignatures() - Return array of supported signature types
  • Phar::getSignature() - Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive


Dummy function (Phar::setStub is not valid for PharData)

  • ? PharData::setSignatureAlgorithm
  • PharFileInfo ?
  • PHP Manual
  • PharData
  • Dummy function (Phar::setStub is not valid for PharData)

PharData::setStub

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharData::setStub — Dummy function (Phar::setStub is not valid for PharData)

说明

public PharData::setStub ( string $stub , int $len = -1 ) : bool

Non-executable tar/zip archives cannot have a stub, so this method simply throws an exception.

参数

stub

A string or an open stream handle to use as the executable stub for this phar archive. This parameter is ignored.

len

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws PharException on all method calls

参见

  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive


The PharFileInfo class

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

简介

The PharFileInfo class provides a high-level interface to the contents and attributes of a single file within a phar archive.

类摘要

PharFileInfo extends SplFileInfo {
/* 方法 */
public chmod ( int $permissions ) : void
public compress ( int $compression ) : bool
public __construct ( string $entry )
public decompress ( ) : bool
public delMetadata ( ) : bool
public getCRC32 ( ) : int
public getCompressedSize ( ) : int
public getContent ( ) : string
public getMetadata ( ) : mixed
public getPharFlags ( ) : int
public hasMetadata ( ) : bool
public isCRCChecked ( ) : bool
public isCompressed ( int $compression_type = 9021976 ) : bool
public setMetadata ( mixed $metadata ) : void
/* 继承的方法 */
public SplFileInfo::getATime ( ) : int
public SplFileInfo::getBasename ( string $suffix = ? ) : string
public SplFileInfo::getCTime ( ) : int
public SplFileInfo::getExtension ( ) : string
public SplFileInfo::getFileInfo ( string $class_name = ? ) : SplFileInfo
public SplFileInfo::getFilename ( ) : string
public SplFileInfo::getGroup ( ) : int
public SplFileInfo::getInode ( ) : int
public SplFileInfo::getLinkTarget ( ) : string
public SplFileInfo::getMTime ( ) : int
public SplFileInfo::getOwner ( ) : int
public SplFileInfo::getPath ( ) : string
public SplFileInfo::getPathInfo ( string $class_name = ? ) : SplFileInfo
public SplFileInfo::getPathname ( ) : string
public SplFileInfo::getPerms ( ) : int
public SplFileInfo::getRealPath ( ) : string
public SplFileInfo::getSize ( ) : int
public SplFileInfo::getType ( ) : string
public SplFileInfo::isDir ( ) : bool
public SplFileInfo::isExecutable ( ) : bool
public SplFileInfo::isFile ( ) : bool
public SplFileInfo::isLink ( ) : bool
public SplFileInfo::isReadable ( ) : bool
public SplFileInfo::isWritable ( ) : bool
public SplFileInfo::openFile ( string $open_mode = "r" , bool $use_include_path = false , resource $context = null ) : SplFileObject
public SplFileInfo::setFileClass ( string $class_name = "SplFileObject" ) : void
public SplFileInfo::setInfoClass ( string $class_name = "SplFileInfo" ) : void
public SplFileInfo::__toString ( ) : string
}

Table of Contents

  • PharFileInfo::chmod — Sets file-specific permission bits
  • PharFileInfo::compress — Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::__construct — Construct a Phar entry object
  • PharFileInfo::decompress — Decompresses the current Phar entry within the phar
  • PharFileInfo::delMetadata — Deletes the metadata of the entry
  • PharFileInfo::getCRC32 — Returns CRC32 code or throws an exception if CRC has not been verified
  • PharFileInfo::getCompressedSize — Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::getContent — Get the complete file contents of the entry
  • PharFileInfo::getMetadata — Returns file-specific meta-data saved with a file
  • PharFileInfo::getPharFlags — Returns the Phar file entry flags
  • PharFileInfo::hasMetadata — Returns the metadata of the entry
  • PharFileInfo::isCRCChecked — Returns whether file entry has had its CRC verified
  • PharFileInfo::isCompressed — Returns whether the entry is compressed
  • PharFileInfo::setMetadata — Sets file-specific meta-data saved with a file


Sets file-specific permission bits

  • ? PharFileInfo
  • PharFileInfo::compress ?
  • PHP Manual
  • PharFileInfo
  • Sets file-specific permission bits

PharFileInfo::chmod

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::chmod — Sets file-specific permission bits

说明

public PharFileInfo::chmod ( int $permissions ) : void

PharFileInfo::chmod() allows setting of the executable file permissions bit, as well as read-only bits. Writeable bits are ignored, and set at runtime based on the phar.readonly INI variable. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

参数

permissions

permissions (see chmod())

返回值

没有返回值。

范例

Example #1 A PharFileInfo::chmod() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar('brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.sh'] = '#!/usr/local/lib/php
    <?php echo "hi"; ?>';
    // set executable bit
    $p['file.sh']->chmod(0555);
    var_dump($p['file.sh']->isExecutable());
} catch (Exception $e) {
    echo 'Could not create/modify phar: ', $e;
}
?>

以上例程会输出：

bool(true)


Compresses the current Phar entry with either zlib or bzip2 compression

  • ? PharFileInfo::chmod
  • PharFileInfo::__construct ?
  • PHP Manual
  • PharFileInfo
  • Compresses the current Phar entry with either zlib or bzip2 compression

PharFileInfo::compress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharFileInfo::compress — Compresses the current Phar entry with either zlib or bzip2 compression

说明

public PharFileInfo::compress ( int $compression ) : bool

This method compresses the file inside the Phar archive using either bzip2 compression or zlib compression. The bzip2 or zlib extension must be enabled to take advantage of this feature. In addition, if the file is already compressed, the respective extension must be enabled in order to decompress the file. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the bzip2/zlib extension is not available.

范例

Example #1 A PharFileInfo::compress() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCompressed(Phar::BZ2));
    $p['myfile.txt']->compress(Phar::BZ2);
    var_dump($file->isCompressed(Phar::BZ2));
} catch (Exception $e) {
    echo 'Create/modify operations on my.phar failed: ', $e;
}
?>

以上例程会输出：

bool(false)
bool(true)

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms


Construct a Phar entry object

  • ? PharFileInfo::compress
  • PharFileInfo::decompress ?
  • PHP Manual
  • PharFileInfo
  • Construct a Phar entry object

PharFileInfo::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::__construct — Construct a Phar entry object

说明

public PharFileInfo::__construct ( string $entry )

This should not be called directly. Instead, a PharFileInfo object is initialized by calling Phar::offsetGet() through array access.

参数

entry

The full url to retrieve a file. If you wish to retrieve the information for the file my/file.php from the phar boo.phar, the entry should be phar://boo.phar/my/file.php.

错误／异常

Throws BadMethodCallException if __construct() is called twice. Throws UnexpectedValueException if the phar URL requested is malformed, the requested phar cannot be opened, or the file can't be found within the phar.

范例

Example #1 A PharFileInfo::__construct() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['testfile.txt'] = "hi\nthere\ndude";
    $file = $p['testfile.txt'];
    foreach ($file as $line => $text) {
        echo "line number $line: $text";
    }
    // this also works
    $file = new PharFileInfo('phar:///path/to/my.phar/testfile.txt');
    foreach ($file as $line => $text) {
        echo "line number $line: $text";
    }
} catch (Exception $e) {
    echo 'Phar operations failed: ', $e;
}
?>

以上例程会输出：

line number 1: hi
line number 2: there
line number 3: dude
line number 1: hi
line number 2: there
line number 3: dude


Decompresses the current Phar entry within the phar

  • ? PharFileInfo::__construct
  • PharFileInfo::delMetadata ?
  • PHP Manual
  • PharFileInfo
  • Decompresses the current Phar entry within the phar

PharFileInfo::decompress

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 2.0.0)

PharFileInfo::decompress — Decompresses the current Phar entry within the phar

说明

public PharFileInfo::decompress ( ) : bool

This method decompresses the file inside the Phar archive. Depending on how the file is compressed, the bzip2 or zlib extensions must be enabled to take advantage of this feature. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the bzip2/zlib extension is not available.

范例

Example #1 A PharFileInfo::decompress() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    $file->compress(Phar::GZ);
    var_dump($file->isCompressed());
    $p['myfile.txt']->decompress();
    var_dump($file->isCompressed());
} catch (Exception $e) {
    echo 'Create/modify failed for my.phar: ', $e;
}
?>

以上例程会输出：

int(4096)
bool(false)

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms


Deletes the metadata of the entry

  • ? PharFileInfo::decompress
  • PharFileInfo::getCRC32 ?
  • PHP Manual
  • PharFileInfo
  • Deletes the metadata of the entry

PharFileInfo::delMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

PharFileInfo::delMetadata — Deletes the metadata of the entry

说明

public PharFileInfo::delMetadata ( ) : bool

Deletes the metadata of the entry, if any.

参数

No parameters.

返回值

Returns true if successful, false if the entry had no metadata. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

错误／异常

Throws PharException if errors occurred while flushing changes to disk, and BadMethodCallException if write access is disabled.

范例

Example #1 A PharFileInfo::delMetaData() example

<?php
try {
    $a = new Phar('myphar.phar');
    $a['hi'] = 'hi';
    var_dump($a['hi']->delMetadata());
    $a['hi']->setMetadata('there');
    var_dump($a['hi']->delMetadata());
    var_dump($a['hi']->delMetadata());
} catch (Exception $e) {
    // handle errors
}
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)

参见

  • PharFileInfo::setMetadata() - Sets file-specific meta-data saved with a file
  • PharFileInfo::hasMetadata() - Returns the metadata of the entry
  • PharFileInfo::getMetadata() - Returns file-specific meta-data saved with a file
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data
  • Phar::getMetadata() - Returns phar archive meta-data


Returns CRC32 code or throws an exception if CRC has not been verified

  • ? PharFileInfo::delMetadata
  • PharFileInfo::getCompressedSize ?
  • PHP Manual
  • PharFileInfo
  • Returns CRC32 code or throws an exception if CRC has not been verified

PharFileInfo::getCRC32

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::getCRC32 — Returns CRC32 code or throws an exception if CRC has not been verified

说明

public PharFileInfo::getCRC32 ( ) : int

This returns the crc32() checksum of the file within the Phar archive.

返回值

The crc32() checksum of the file within the Phar archive.

错误／异常

Throws BadMethodCallException if the file has not yet had its CRC32 verified. This should be impossible with normal use, as the CRC is verified upon opening the file for reading or writing.

范例

Example #1 A PharFileInfo::getCRC32() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    echo $file->getCRC32();
} catch (Exception $e) {
    echo 'Write operations on my.phar.phar failed: ', $e;
}
?>

以上例程会输出：

3633523372


Returns the actual size of the file (with compression) inside the Phar archive

  • ? PharFileInfo::getCRC32
  • PharFileInfo::getContent ?
  • PHP Manual
  • PharFileInfo
  • Returns the actual size of the file (with compression) inside the Phar archive

PharFileInfo::getCompressedSize

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::getCompressedSize — Returns the actual size of the file (with compression) inside the Phar archive

说明

public PharFileInfo::getCompressedSize ( ) : int

This returns the size of the file within the Phar archive. Uncompressed files will return the same value for getCompressedSize as they will with filesize()

返回值

The size in bytes of the file within the Phar archive on disk.

范例

Example #1 A PharFileInfo::getCompressedSize() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    echo $file->getCompressedSize();
} catch (Exception $e) {
    echo 'Write operations failed on my.phar: ', $e;
}
?>

以上例程会输出：

2

参见

  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::compressFiles() - Compresses all files in the current Phar archive


Get the complete file contents of the entry

  • ? PharFileInfo::getCompressedSize
  • PharFileInfo::getMetadata ?
  • PHP Manual
  • PharFileInfo
  • Get the complete file contents of the entry

PharFileInfo::getContent

(PHP 5 >= 5.3.0, PHP 7)

PharFileInfo::getContent — Get the complete file contents of the entry

说明

public PharFileInfo::getContent ( ) : string

This function behaves like file_get_contents() but for Phar.

参数

此函数没有参数。

返回值

Returns the file contents.


Returns file-specific meta-data saved with a file

  • ? PharFileInfo::getContent
  • PharFileInfo::getPharFlags ?
  • PHP Manual
  • PharFileInfo
  • Returns file-specific meta-data saved with a file

PharFileInfo::getMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::getMetadata — Returns file-specific meta-data saved with a file

说明

public PharFileInfo::getMetadata ( ) : mixed

Return meta-data that was saved in the Phar archive's manifest for this file.

参数

返回值

any PHP variable that can be serialized and is stored as meta-data for the file, or null if no meta-data is stored.

范例

Example #1 A PharFileInfo::getMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.txt'] = 'hello';
    $p['file.txt']->setMetadata(array('user' => 'bill', 'mime-type' => 'text/plain'));
    var_dump($p['file.txt']->getMetadata());
} catch (Exception $e) {
    echo 'Could not create/modify brandnewphar.phar: ', $e;
}
?>

以上例程会输出：

array(2) {
  ["user"]=>
  string(4) "bill"
  ["mime-type"]=>
  string(10) "text/plain"
}

参见

  • PharFileInfo::setMetadata() - Sets file-specific meta-data saved with a file
  • PharFileInfo::hasMetadata() - Returns the metadata of the entry
  • PharFileInfo::delMetadata() - Deletes the metadata of the entry
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data
  • Phar::getMetadata() - Returns phar archive meta-data


Returns the Phar file entry flags

  • ? PharFileInfo::getMetadata
  • PharFileInfo::hasMetadata ?
  • PHP Manual
  • PharFileInfo
  • Returns the Phar file entry flags

PharFileInfo::getPharFlags

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::getPharFlags — Returns the Phar file entry flags

说明

public PharFileInfo::getPharFlags ( ) : int

This returns the flags set in the manifest for a Phar. This will always return 0 in the current implementation.

返回值

The Phar flags (always 0 in the current implementation)

范例

Example #1 A PharFileInfo::getPharFlags() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->getPharFlags());
} catch (Exception $e) {
    echo 'Could not create/modify my.phar: ', $e;
}
?>

以上例程会输出：

int(0)


Returns the metadata of the entry

  • ? PharFileInfo::getPharFlags
  • PharFileInfo::isCRCChecked ?
  • PHP Manual
  • PharFileInfo
  • Returns the metadata of the entry

PharFileInfo::hasMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.2.0)

PharFileInfo::hasMetadata — Returns the metadata of the entry

说明

public PharFileInfo::hasMetadata ( ) : bool

Returns the metadata of a file within a phar archive.

参数

No parameters.

返回值

Returns false if no metadata is set or is null, true if metadata is not null

参见

  • PharFileInfo::setMetadata() - Sets file-specific meta-data saved with a file
  • PharFileInfo::getMetadata() - Returns file-specific meta-data saved with a file
  • PharFileInfo::delMetadata() - Deletes the metadata of the entry
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data
  • Phar::getMetadata() - Returns phar archive meta-data


Returns whether file entry has had its CRC verified

  • ? PharFileInfo::hasMetadata
  • PharFileInfo::isCompressed ?
  • PHP Manual
  • PharFileInfo
  • Returns whether file entry has had its CRC verified

PharFileInfo::isCRCChecked

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::isCRCChecked — Returns whether file entry has had its CRC verified

说明

public PharFileInfo::isCRCChecked ( ) : bool

This returns whether a file within a Phar archive has had its CRC verified.

返回值

true if the file has had its CRC verified, false if not.

范例

Example #1 A PharFileInfo::isCRCChecked() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCRCChecked());
} catch (Exception $e) {
    echo 'Create/modify operations failed on my.phar: ', $e;
}
?>

以上例程会输出：

bool(true)


Returns whether the entry is compressed

  • ? PharFileInfo::isCRCChecked
  • PharFileInfo::setMetadata ?
  • PHP Manual
  • PharFileInfo
  • Returns whether the entry is compressed

PharFileInfo::isCompressed

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::isCompressed — Returns whether the entry is compressed

说明

public PharFileInfo::isCompressed ( int $compression_type = 9021976 ) : bool

This returns whether a file is compressed within a Phar archive with either Gzip or Bzip2 compression.

参数

compression_type

One of Phar::GZ or Phar::BZ2, defaults to any compression.

返回值

true if the file is compressed within the Phar archive, false if not.

范例

Example #1 A PharFileInfo::isCompressed() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p['myfile2.txt']->setCompressedGZ();
    $file = $p['myfile.txt'];
    $file2 = $p['myfile2.txt'];
    var_dump($file->isCompressed());
    var_dump($file2->isCompressed());
} catch (Exception $e) {
    echo 'Create/modify on phar my.phar failed: ', $e;
}
?>

以上例程会输出：

bool(false)
bool(true)

参见

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::compressFiles() - Compresses all files in the current Phar archive


Sets file-specific meta-data saved with a file

  • ? PharFileInfo::isCompressed
  • PharException ?
  • PHP Manual
  • PharFileInfo
  • Sets file-specific meta-data saved with a file

PharFileInfo::setMetadata

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

PharFileInfo::setMetadata — Sets file-specific meta-data saved with a file

说明

public PharFileInfo::setMetadata ( mixed $metadata ) : void

PharFileInfo::setMetadata() should only be used to store customized data in a file that cannot be represented with existing information stored with a file. Meta-data can significantly slow down the performance of loading a phar archive if the data is large, or if there are many files containing meta-data. It is important to note that file permissions are natively supported inside a phar; it is possible to set them with the PharFileInfo::chmod() method. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

Some possible uses for meta-data include passing a user/group that should be set when a file is extracted from the phar to disk. Other uses could include explicitly specifying a MIME type to return. However, any useful data that describes a file, but should not be contained inside of it may be stored.

参数

metadata

Any PHP variable containing information to store alongside a file

返回值

没有返回值。

范例

Example #1 A PharFileInfo::setMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.txt'] = 'hello';
    $p['file.txt']->setMetadata(array('user' => 'bill', 'mime-type' => 'text/plain'));
    var_dump($p['file.txt']->getMetaData());
} catch (Exception $e) {
    echo 'Could not create/modify phar: ', $e;
}
?>

以上例程会输出：

array(2) {
  ["user"]=>
  string(4) "bill"
  ["mime-type"]=>
  string(10) "text/plain"
}

参见

  • PharFileInfo::hasMetadata() - Returns the metadata of the entry
  • PharFileInfo::getMetadata() - Returns file-specific meta-data saved with a file
  • PharFileInfo::delMetadata() - Deletes the metadata of the entry
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data
  • Phar::getMetadata() - Returns phar archive meta-data


The PharException class

(PHP 5 >= 5.3.0, PHP 7, PECL phar >= 1.0.0)

简介

The PharException class provides a phar-specific exception class for try/catch blocks.

类摘要

PharException extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Rar Archiving

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Rar 函数
    • rar_wrapper_cache_stats — Cache hits and misses for the URL wrapper
  • RarArchive — The RarArchive class
    • RarArchive::close — Close RAR archive and free all resources
    • RarArchive::getComment — Get comment text from the RAR archive
    • RarArchive::getEntries — Get full list of entries from the RAR archive
    • RarArchive::getEntry — Get entry object from the RAR archive
    • RarArchive::isBroken — Test whether an archive is broken (incomplete)
    • RarArchive::isSolid — Check whether the RAR archive is solid
    • RarArchive::open — Open RAR archive
    • RarArchive::setAllowBroken — Whether opening broken archives is allowed
    • RarArchive::__toString — Get text representation
  • RarEntry — The RarEntry class
    • RarEntry::extract — Extract entry from the archive
    • RarEntry::getAttr — Get attributes of the entry
    • RarEntry::getCrc — Get CRC of the entry
    • RarEntry::getFileTime — Get entry last modification time
    • RarEntry::getHostOs — Get entry host OS
    • RarEntry::getMethod — Get pack method of the entry
    • RarEntry::getName — Get name of the entry
    • RarEntry::getPackedSize — Get packed size of the entry
    • RarEntry::getStream — Get file handler for entry
    • RarEntry::getUnpackedSize — Get unpacked size of the entry
    • RarEntry::getVersion — Get minimum version of RAR program required to unpack the entry
    • RarEntry::isDirectory — Test whether an entry represents a directory
    • RarEntry::isEncrypted — Test whether an entry is encrypted
    • RarEntry::__toString — Get text representation of entry
  • RarException — The RarException class
    • RarException::isUsingExceptions — Check whether error handling with exceptions is in use
    • RarException::setUsingExceptions — Activate and deactivate error handling with exceptions


简介

Rar is a powerful and effective archiver created by Eugene Roshal. This extension gives you possibility to read Rar archives but doesn't support writing Rar archives, because this is not supported by the UnRar library and is directly prohibited by its license.

More information about Rar and UnRar can be found at » http://www.rarlabs.com/.


安装

Rar is currently available through PECL » https://pecl.php.net/package/rar.

Also you can use the PECL installer to install the Rar extension, using the following command: pecl -v install rar.

You can always download the tar.gz package and install Rar by hand:

Example #1 Rar installation

gunzip rar-xxx.tgz
tar -xvf rar-xxx.tar
cd rar-xxx
phpize
./configure && make && make install

Windows users will enable php_rar.dll inside of php.ini in order to use these functions. PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


资源类型

This extension registers three internal classes: The archive representations returned by rar_open() - RarArchive -, the entry representations returned by rar_list() and rar_entry_get() - RarEntry and the exception type RarException.

This extension also register a stream resource, called "rar" and a URL wrapper called "rar wrapper" and registered under the prefix "rar".


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

RAR_HOST_MSDOS (int)
Use RarEntry::HOST_MSDOS instead.
RAR_HOST_OS2 (int)
Use RarEntry::HOST_OS2 instead.
RAR_HOST_WIN32 (int)
Use RarEntry::HOST_WIN32 instead.
RAR_HOST_UNIX (int)
Use RarEntry::HOST_UNIX instead.
RAR_HOST_BEOS (int)
Use RarEntry::HOST_BEOS instead.


范例

See also the examples under rar:// wrapper.

Example #1 On-the-fly decompression

<?php

if (!array_key_exists("i", $_GET) || !is_numeric($_GET["i"]))
    die("Index unspecified or non-numeric");
$index = (int) $_GET["i"];

$arch = RarArchive::open("example.rar");
if ($arch === FALSE)
    die("Cannot open example.rar");

$entries = $arch->getEntries();
if ($entries === FALSE)
    die("Cannot retrieve entries");

if (!array_key_exists($index, $entries))
    die("No such index: $index");

$orfilename = $entries[$index]->getName(); //UTF-8 encoded

$filesize = $entries[$index]->getUnpackedSize();

/* you could check HTTP_IF_MODIFIED_SINCE here and compare with
 * $entries[$index]->getFileTime(). You could also send a
 * "Last modified" header */

$fp = $entries[$index]->getStream();
if ($fp === FALSE)
    die("Cannot open file with index $index insided the archive.");

$arch->close(); //no longer needed; stream is independent

function detectUserAgent() {
    if (!array_key_exists('HTTP_USER_AGENT', $_SERVER))
        return "Other";

    $uas = $_SERVER['HTTP_USER_AGENT'];
    if (preg_match("@Opera/@", $uas))
        return "Opera";
    if (preg_match("@Firefox/@", $uas))
        return "Firefox";
    if (preg_match("@Chrome/@", $uas))
        return "Chrome";
    if (preg_match("@MSIE ([0-9.]+);@", $uas, $matches)) {
        if (((float)$matches[1]) >= 7.0)
            return "IE";
    }

    return "Other";
}

/*
 * We have 3 options:
 * - For FF and Opera, which support RFC 2231, use that format.
 * - For IE and Chrome, use attwithfnrawpctenclong
 *   (http://greenbytes.de/tech/tc2231/#attwithfnrawpctenclong)
 * - For the others, convert to ISO-8859-1, if possible
 */
$formatRFC2231 = 'Content-Disposition: attachment; filename*=UTF-8\'\'%s';
$formatDef = 'Content-Disposition: attachment; filename="%s"';

switch (detectUserAgent()) {
    case "Opera":
    case "Firefox":
        $orfilename = rawurlencode($orfilename);
        $format = $formatRFC2231;
        break;

    case "IE":
    case "Chrome":
        $orfilename = rawurlencode($orfilename);
        $format = $formatDef;
        break;
    default:
        if (function_exists('iconv'))
            $orfilename =
                @iconv("UTF-8", "ISO-8859-1//TRANSLIT", $orfilename);
        $format = $formatDef;
}

header(sprintf($format, $orfilename));
//cannot send error messages from now on (headers already sent)

//replace by real content type, perhaps infering from the file extension
$contentType = "application/octet-stream";
header("Content-Type: $contentType");

header("Content-Transfer-Encoding: binary");

header("Content-Length: $filesize");

if ($_SERVER['REQUEST_METHOD'] == "HEAD")
    die();

while (!feof($fp)) {
    $s = @fread($fp, 8192);
    if ($s === false)
        break; //useless to send error messages

    echo $s;
}
?>

This example opens a RAR file and presents the requested file inside the RAR archive for download to the client.

Example #2 RAR extension filesystem extraction example

<?php

$rar_file = rar_open('example.rar') or die("Can't open Rar archive");

$entries = rar_list($rar_file);

foreach ($entries as $entry) {
    echo 'Filename: ' . $entry->getName() . "\n";
    echo 'Packed size: ' . $entry->getPackedSize() . "\n";
    echo 'Unpacked size: ' . $entry->getUnpackedSize() . "\n";

    $entry->extract('/dir/extract/to/');
}

rar_close($rar_file);

?>

This example opens a RAR file archive and extracts each entry to the specified directory.


Rar 函数

Table of Contents

  • rar_wrapper_cache_stats — Cache hits and misses for the URL wrapper


Cache hits and misses for the URL wrapper

  • ? Rar 函数
  • RarArchive ?
  • PHP Manual
  • Rar 函数
  • Cache hits and misses for the URL wrapper

rar_wrapper_cache_stats

(PECL rar >= 3.0.0)

rar_wrapper_cache_stats — Cache hits and misses for the URL wrapper

说明

rar_wrapper_cache_stats ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The RarArchive class

(PECL rar >= 2.0.0)

简介

This class represents a RAR archive, which may be formed by several volumes (parts) and which contains a number of RAR entries (i.e., files, directories and other special objects such as symbolic links).

Objects of this class can be traversed, yielding the entries stored in the respective RAR archive. Those entries can also be obtained through RarArchive::getEntry() and RarArchive::getEntries().

类摘要

final RarArchive implements Traversable {
/* 方法 */
public close ( ) : bool
public getComment ( ) : string
public getEntries ( ) : array|false
public getEntry ( string $entryname ) : RarEntry|false
public isBroken ( ) : bool
public isSolid ( ) : bool
public static open ( string $filename , string $password = NULL , callable $volume_callback = NULL ) : RarArchive|false
public setAllowBroken ( bool $allow_broken ) : bool
public __toString ( ) : string
}

Table of Contents

  • RarArchive::close — Close RAR archive and free all resources
  • RarArchive::getComment — Get comment text from the RAR archive
  • RarArchive::getEntries — Get full list of entries from the RAR archive
  • RarArchive::getEntry — Get entry object from the RAR archive
  • RarArchive::isBroken — Test whether an archive is broken (incomplete)
  • RarArchive::isSolid — Check whether the RAR archive is solid
  • RarArchive::open — Open RAR archive
  • RarArchive::setAllowBroken — Whether opening broken archives is allowed
  • RarArchive::__toString — Get text representation


Close RAR archive and free all resources

  • ? RarArchive
  • RarArchive::getComment ?
  • PHP Manual
  • RarArchive
  • Close RAR archive and free all resources

RarArchive::close

rar_close

(PECL rar >= 2.0.0)

RarArchive::close -- rar_close — Close RAR archive and free all resources

说明

面向对象风格 (method):

public RarArchive::close ( ) : bool

过程化风格:

rar_close ( RarArchive $rarfile ) : bool

Close RAR archive and free all allocated resources.

参数

rarfile

A RarArchive object, opened with rar_open().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL rar 2.0.0 | The RAR entries returned by RarArchive::getEntry() and RarArchive::getEntries() are now invalidated when calling this method. This means that all instance methods called for such entries and not guaranteed to succeed.

范例

Example #1 面向对象风格

<?php
$rar_arch = RarArchive::open('latest_winrar.rar');
echo $rar_arch."\n";
$rar_arch->close();
echo $rar_arch."\n";
?>

以上例程的输出类似于：

RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar"
RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar" (closed)

Example #2 过程化风格

<?php
$rar_arch = rar_open('latest_winrar.rar');
echo $rar_arch."\n";
rar_close($rar_arch);
echo $rar_arch."\n";
?>


Get comment text from the RAR archive

  • ? RarArchive::close
  • RarArchive::getEntries ?
  • PHP Manual
  • RarArchive
  • Get comment text from the RAR archive

RarArchive::getComment

rar_comment_get

(PECL rar >= 2.0.0)

RarArchive::getComment -- rar_comment_get — Get comment text from the RAR archive

说明

面向对象风格 (method):

public RarArchive::getComment ( ) : string

过程化风格:

rar_comment_get ( RarArchive $rarfile ) : string

Get the (global) comment stored in the RAR archive. It may be up to 64 KiB long.

Note:

This extension does not support comments at the entry level.

参数

rarfile

A RarArchive object, opened with rar_open().

返回值

Returns the comment or null if there is none.

Note:

RAR has currently no support for unicode comments. The encoding of the result of this function is not specified, but it will probably be Windows-1252.

范例

Example #1 面向对象风格

<?php
$rar_arch = RarArchive::open('commented.rar');
echo $rar_arch->getComment();
?>

以上例程的输出类似于：

This is the comment of the file commented.rar.

Example #2 过程化风格

<?php
$rar_arch = rar_open('commented.rar');
echo rar_comment_get($rar_arch);
?>


Get full list of entries from the RAR archive

  • ? RarArchive::getComment
  • RarArchive::getEntry ?
  • PHP Manual
  • RarArchive
  • Get full list of entries from the RAR archive

RarArchive::getEntries

rar_list

(PECL rar >= 2.0.0)

RarArchive::getEntries -- rar_list — Get full list of entries from the RAR archive

说明

面向对象风格 (method):

public RarArchive::getEntries ( ) : array|false

过程化风格:

rar_list ( RarArchive $rarfile ) : array|false

Get entries list (files and directories) from the RAR archive.

Note:

If the archive has entries with the same name, this method, together with RarArchive foreach iteration and array-like access with numeric indexes, are the only ones to access all the entries (i.e., RarArchive::getEntry() and the rar:// wrapper are insufficient).

参数

rarfile

A RarArchive object, opened with rar_open().

返回值

rar_list() returns array of RarEntry objects 或者在失败时返回 false.

更新日志

版本 | 说明
PECL rar 3.0.0 | Support for RAR archives with repeated entry names is no longer defective.

范例

Example #1 面向对象风格

<?php
$rar_arch = RarArchive::open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");

$rar_entries = $rar_arch->getEntries();
if ($rar_entries === FALSE)
    die("Could not retrieve entries.");

echo "Found " . count($rar_entries) . " entries.\n";

foreach ($rar_entries as $e) {
    echo $e;
    echo "\n";
}
$rar_arch->close();
?>

以上例程的输出类似于：

Found 2 entries.
RarEntry for file "tese.txt" (23b93a7a)
RarEntry for file "unrardll.txt" (2ed64b6e)

Example #2 过程化风格

<?php
$rar_arch = rar_open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");

$rar_entries = rar_list($rar_arch);
if ($rar_entries === FALSE)
    die("Could retrieve entries.");

echo "Found " . count($rar_entries) . " entries.\n";

foreach ($rar_entries as $e) {
    echo $e;
    echo "\n";
}
rar_close($rar_arch);
?>

参见

  • RarArchive::getEntry() - Get entry object from the RAR archive
  • rar:// wrapper


Get entry object from the RAR archive

  • ? RarArchive::getEntries
  • RarArchive::isBroken ?
  • PHP Manual
  • RarArchive
  • Get entry object from the RAR archive

RarArchive::getEntry

rar_entry_get

(PECL rar >= 2.0.0)

RarArchive::getEntry -- rar_entry_get — Get entry object from the RAR archive

说明

面向对象风格 (method):

public RarArchive::getEntry ( string $entryname ) : RarEntry|false

过程化风格:

rar_entry_get ( RarArchive $rarfile , string $entryname ) : RarEntry|false

Get entry object (file or directory) from the RAR archive.

Note:

You can also get entry objects using RarArchive::getEntries().

Note that a RAR archive can have multiple entries with the same name; this method will retrieve only the first.

参数

rarfile

A RarArchive object, opened with rar_open().

entryname

Path to the entry within the RAR archive.

Note:

The path must be the same returned by RarEntry::getName().

返回值

Returns the matching RarEntry object 或者在失败时返回 false.

范例

Example #1 面向对象风格

<?php
$rar_arch = RarArchive::open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");
$rar_entry = $rar_arch->getEntry('tese.txt');
if ($rar_entry === FALSE)
    die("Could not get such entry");
echo get_class($rar_entry)."\n";
echo $rar_entry;
$rar_arch->close();
?>

以上例程的输出类似于：

RarEntry
RarEntry for file "tese.txt" (23b93a7a)

Example #2 过程化风格

<?php
$rar_arch = rar_open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");
$rar_entry = rar_entry_get($rar_arch, 'tese.txt');
if ($rar_entry === FALSE)
    die("Could not get such entry");
echo get_class($rar_entry)."\n";
echo $rar_entry;
rar_close($rar_arch);
?>

参见

  • RarArchive::getEntries() - Get full list of entries from the RAR archive
  • rar:// wrapper


Test whether an archive is broken (incomplete)

  • ? RarArchive::getEntry
  • RarArchive::isSolid ?
  • PHP Manual
  • RarArchive
  • Test whether an archive is broken (incomplete)

RarArchive::isBroken

rar_broken_is

(PECL rar >= 3.0.0)

RarArchive::isBroken -- rar_broken_is — Test whether an archive is broken (incomplete)

说明

面向对象风格 (method):

public RarArchive::isBroken ( ) : bool

过程化风格:

rar_broken_is ( RarArchive $rarfile ) : bool

This function determines whether an archive is incomplete, i.e., if a volume is missing or a volume is truncated.

参数

rarfile

A RarArchive object, opened with rar_open().

返回值

Returns true if the archive is broken, false otherwise. This function may also return false if the passed file has already been closed. The only way to tell the two cases apart is to enable exceptions with RarException::setUsingExceptions(); however, this should be unnecessary as a program should not operate on closed files.

范例

Example #1 面向对象风格

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* Third argument is used to omit notice */
$arch = RarArchive::open($file, null, 'retnull');
var_dump($arch->isBroken());
?>

以上例程的输出类似于：

bool(true)

Example #2 过程化风格

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* Third argument is used to omit notice */
$arch = rar_open($file, null, 'retnull');
var_dump(rar_broken_is($arch));
?>

参见

  • RarArchive::setAllowBroken() - Whether opening broken archives is allowed


Check whether the RAR archive is solid

  • ? RarArchive::isBroken
  • RarArchive::open ?
  • PHP Manual
  • RarArchive
  • Check whether the RAR archive is solid

RarArchive::isSolid

rar_solid_is

(PECL rar >= 2.0.0)

RarArchive::isSolid -- rar_solid_is — Check whether the RAR archive is solid

说明

面向对象风格 (method):

public RarArchive::isSolid ( ) : bool

过程化风格:

rar_solid_is ( RarArchive $rarfile ) : bool

Check whether the RAR archive is solid. Individual file extraction is slower on solid archives.

参数

rarfile

A RarArchive object, opened with rar_open().

返回值

Returns true if the archive is solid, false otherwise.

范例

Example #1 面向对象风格

<?php
$arch1 = RarArchive::open("store_method.rar");
$arch2 = RarArchive::open("solid.rar");
echo "$arch1: " . ($arch1->isSolid()?'yes':'no') ."\n";
echo "$arch2: " . ($arch2->isSolid()?'yes':'no') . "\n";
?>

以上例程的输出类似于：

RAR Archive "C:\php_rar\trunk\tests\store_method.rar": no
RAR Archive "C:\php_rar\trunk\tests\solid.rar": yes

Example #2 过程化风格

<?php
$arch1 = rar_open("store_method.rar");
$arch2 = rar_open("solid.rar");
echo "$arch1: " . (rar_solid_is($arch1)?'yes':'no') ."\n";
echo "$arch2: " . (rar_solid_is($arch2)?'yes':'no') . "\n";
?>


Open RAR archive

  • ? RarArchive::isSolid
  • RarArchive::setAllowBroken ?
  • PHP Manual
  • RarArchive
  • Open RAR archive

RarArchive::open

rar_open

(PECL rar >= 2.0.0)

RarArchive::open -- rar_open — Open RAR archive

说明

面向对象风格 (method):

public static RarArchive::open ( string $filename , string $password = NULL , callable $volume_callback = NULL ) : RarArchive|false

过程化风格:

rar_open ( string $filename , string $password = NULL , callable $volume_callback = NULL ) : RarArchive|false

Open specified RAR archive and return RarArchive instance representing it.

Note:

If opening a multi-volume archive, the path of the first volume should be passed as the first parameter. Otherwise, not all files will be shown. This is by design.

参数

filename

Path to the Rar archive.

password

A plain password, if needed to decrypt the headers. It will also be used by default if encrypted files are found. Note that the files may have different passwords in respect to the headers and among them.

volume_callback

A function that receives one parameter - the path of the volume that was not found - and returns a string with the correct path for such volume or null if such volume does not exist or is not known. The programmer should ensure the passed function doesn't cause loops as this function is called repeatedly if the path returned in a previous call did not correspond to the needed volume. Specifying this parameter omits the notice that would otherwise be emitted whenever a volume is not found; an implementation that only returns null can therefore be used to merely omit such notices.

Warning

Prior to version 2.0.0, this function would not handle relative paths correctly. Use realpath() as a workaround.

返回值

Returns the requested RarArchive instance 或者在失败时返回 false.

更新日志

版本 | 说明
PECL rar 3.0.0 | volume_callback was added.

范例

Example #1 面向对象风格

<?php
$rar_arch = RarArchive::open('encrypted_headers.rar', 'samplepassword');
if ($rar_arch === FALSE)
    die("Failed opening file");

$entries = $rar_arch->getEntries();
if ($entries === FALSE)
    die("Failed fetching entries");

echo "Found " . count($entries) . " files.\n";

if (empty($entries))
    die("No valid entries found.");

$stream = reset($entries)->getStream();
if ($stream === FALSE)
    die("Failed opening first file");

$rar_arch->close();

echo "Content of first one follows:\n";
echo stream_get_contents($stream);

fclose($stream);
?>

以上例程的输出类似于：

Found 2 files.
Content of first one follows:
Encrypted file 1 contents.

Example #2 过程化风格

<?php
$rar_arch = rar_open('encrypted_headers.rar', 'samplepassword');
if ($rar_arch === FALSE)
    die("Failed opening file");

$entries = rar_list($rar_arch);
if ($entries === FALSE)
    die("Failed fetching entries");

echo "Found " . count($entries) . " files.\n";

if (empty($entries))
    die("No valid entries found.");

$stream = reset($entries)->getStream();
if ($stream === FALSE)
    die("Failed opening first file");

rar_close($rar_arch);

echo "Content of first one follows:\n";
echo stream_get_contents($stream);

fclose($stream);
?>

Example #3 Volume Callback

<?php
/* In this example, there's a volume named multi_broken.part1.rar
 * whose next volume is named multi.part2.rar */
function resolve($vol) {
    if (preg_match('/_broken/', $vol))
        return str_replace('_broken', '', $vol);
    else
        return null;
}
$rar_file1 = rar_open(dirname(__FILE__).'/multi_broken.part1.rar', null, 'resolve');
$entry = $rar_file1->getEntry('file2.txt');
$entry->extract(null, dirname(__FILE__) . "/temp_file2.txt");
?>

参见

  • rar:// wrapper


Whether opening broken archives is allowed

  • ? RarArchive::open
  • RarArchive::__toString ?
  • PHP Manual
  • RarArchive
  • Whether opening broken archives is allowed

RarArchive::setAllowBroken

(PECL rar >= 3.0.0)

RarArchive::setAllowBroken — Whether opening broken archives is allowed

说明

面向对象风格 (method):

public RarArchive::setAllowBroken ( bool $allow_broken ) : bool

过程化风格:

rar_allow_broken_set ( RarArchive $rarfile , bool $allow_broken ) : bool

This method defines whether broken archives can be read or all the operations that attempt to extract the archive entries will fail. Broken archives are archives for which no error is detected when the file is opened but an error occurs when reading the entries.

参数

rarfile

A RarArchive object, opened with rar_open().

allow_broken

Whether to allow reading broken files (true) or not (false).

返回值

Returns true 或者在失败时返回 false. It will only fail if the file has already been closed.

范例

Example #1 面向对象风格

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* Third argument omits "volume not found" message */
$a = RarArchive::open($file, null, 'retnull');
$a->setAllowBroken(true);
foreach ($a->getEntries() as $e) {
    echo "$e\n";
}
var_dump(count($a));
?>

以上例程的输出类似于：

RarEntry for file "file1.txt" (52b28202)
int(1)

Example #2 过程化风格

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* Third argument omits "volume not found" message */
$a = rar_open($file, null, 'retnull');
rar_allow_broken_set($a, true);
foreach (rar_list($a) as $e) {
    echo "$e\n";
}
var_dump(count($a));
?>

参见

  • RarArchive::isBroken() - Test whether an archive is broken (incomplete)


Get text representation

  • ? RarArchive::setAllowBroken
  • RarEntry ?
  • PHP Manual
  • RarArchive
  • Get text representation

RarArchive::__toString

(PECL rar >= 2.0.0)

RarArchive::__toString — Get text representation

说明

public RarArchive::__toString ( ) : string

Provides a string representation for this RarArchive object. It currently shows the full path name of the archive volume that was opened and whether the resource is valid or was already closed through a call to RarArchive::close().

This method may be used only for debugging purposes, as there are no guarantees as to which information the result contains or how it is formatted.

参数

此函数没有参数。

返回值

A textual representation of this RarArchive object. The content of this representation is unspecified.

范例

Example #1 RarArchive::__toString() example

<?php
$rar_arch = RarArchive::open('latest_winrar.rar');
echo $rar_arch."\n";
$rar_arch->close();
echo $rar_arch."\n";
?>

以上例程的输出类似于：

RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar"
RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar" (closed)


The RarEntry class

(PECL rar >= 0.1)

简介

A RAR entry, representing a directory or a compressed file inside a RAR archive.

类摘要

final RarEntry {
/* 常量 */
const int HOST_MSDOS = 0 ;
const int HOST_OS2 = 1 ;
const int HOST_WIN32 = 2 ;
const int HOST_UNIX = 3 ;
const int HOST_MACOS = 4 ;
const int HOST_BEOS = 5 ;
const int ATTRIBUTE_WIN_READONLY = 1 ;
const int ATTRIBUTE_WIN_HIDDEN = 2 ;
const int ATTRIBUTE_WIN_SYSTEM = 4 ;
const int ATTRIBUTE_WIN_DIRECTORY = 16 ;
const int ATTRIBUTE_WIN_ARCHIVE = 32 ;
const int ATTRIBUTE_WIN_DEVICE = 64 ;
const int ATTRIBUTE_WIN_NORMAL = 128 ;
const int ATTRIBUTE_WIN_TEMPORARY = 256 ;
const int ATTRIBUTE_WIN_SPARSE_FILE = 512 ;
const int ATTRIBUTE_WIN_REPARSE_POINT = 1024 ;
const int ATTRIBUTE_WIN_COMPRESSED = 2048 ;
const int ATTRIBUTE_WIN_OFFLINE = 4096 ;
const int ATTRIBUTE_WIN_NOT_CONTENT_INDEXED = 8192 ;
const int ATTRIBUTE_WIN_ENCRYPTED = 16384 ;
const int ATTRIBUTE_WIN_VIRTUAL = 65536 ;
const int ATTRIBUTE_UNIX_WORLD_EXECUTE = 1 ;
const int ATTRIBUTE_UNIX_WORLD_WRITE = 2 ;
const int ATTRIBUTE_UNIX_WORLD_READ = 4 ;
const int ATTRIBUTE_UNIX_GROUP_EXECUTE = 8 ;
const int ATTRIBUTE_UNIX_GROUP_WRITE = 16 ;
const int ATTRIBUTE_UNIX_GROUP_READ = 32 ;
const int ATTRIBUTE_UNIX_OWNER_EXECUTE = 64 ;
const int ATTRIBUTE_UNIX_OWNER_WRITE = 128 ;
const int ATTRIBUTE_UNIX_OWNER_READ = 256 ;
const int ATTRIBUTE_UNIX_STICKY = 512 ;
const int ATTRIBUTE_UNIX_SETGID = 1024 ;
const int ATTRIBUTE_UNIX_SETUID = 2048 ;
const int ATTRIBUTE_UNIX_FINAL_QUARTET = 61440 ;
const int ATTRIBUTE_UNIX_FIFO = 4096 ;
const int ATTRIBUTE_UNIX_CHAR_DEV = 8192 ;
const int ATTRIBUTE_UNIX_DIRECTORY = 16384 ;
const int ATTRIBUTE_UNIX_BLOCK_DEV = 24576 ;
const int ATTRIBUTE_UNIX_REGULAR_FILE = 32768 ;
const int ATTRIBUTE_UNIX_SYM_LINK = 40960 ;
const int ATTRIBUTE_UNIX_SOCKET = 49152 ;
/* 方法 */
public extract ( string $dir , string $filepath = "" , string $password = NULL , bool $extended_data = false ) : bool
public getAttr ( ) : int
public getCrc ( ) : string
public getFileTime ( ) : string
public getHostOs ( ) : int
public getMethod ( ) : int
public getName ( ) : string
public getPackedSize ( ) : int
public getStream ( string $password = ? ) : resource|false
public getUnpackedSize ( ) : int
public getVersion ( ) : int
public isDirectory ( ) : bool
public isEncrypted ( ) : bool
public __toString ( ) : string
}

预定义常量

RarEntry::HOST_MSDOS

If the return value of RarEntry::getHostOs() equals this constant, MS-DOS was used to add this entry. Use instead of RAR_HOST_MSDOS.

RarEntry::HOST_OS2

If the return value of RarEntry::getHostOs() equals this constant, OS/2 was used to add this entry. Intended to replace RAR_HOST_OS2.

RarEntry::HOST_WIN32

If the return value of RarEntry::getHostOs() equals this constant, Microsoft Windows was used to add this entry. Intended to replace RAR_HOST_WIN32.

RarEntry::HOST_UNIX

If the return value of RarEntry::getHostOs() equals this constant, an unspecified UNIX OS was used to add this entry. Intended to replace RAR_HOST_UNIX.

RarEntry::HOST_MACOS

If the return value of RarEntry::getHostOs() equals this constant, Mac OS was used to add this entry.

RarEntry::HOST_BEOS

If the return value of RarEntry::getHostOs() equals this constant, BeOS was used to add this entry. Intended to replace RAR_HOST_BEOS.

RarEntry::ATTRIBUTE_WIN_READONLY

Bit that represents a Windows entry with a read-only attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_HIDDEN

Bit that represents a Windows entry with a hidden attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_SYSTEM

Bit that represents a Windows entry with a system attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_DIRECTORY

Bit that represents a Windows entry with a directory attribute (entry is a directory). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows. See also RarEntry::isDirectory(), which also works with entries that were not added in WinRAR.

RarEntry::ATTRIBUTE_WIN_ARCHIVE

Bit that represents a Windows entry with an archive attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_DEVICE

Bit that represents a Windows entry with a device attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_NORMAL

Bit that represents a Windows entry with a normal file attribute (entry is NOT a directory). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows. See also RarEntry::isDirectory(), which also works with entries that were not added in WinRAR.

RarEntry::ATTRIBUTE_WIN_TEMPORARY

Bit that represents a Windows entry with a temporary attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_SPARSE_FILE

Bit that represents a Windows entry with a sparse file attribute (file is an NTFS sparse file). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_REPARSE_POINT

Bit that represents a Windows entry with a reparse point attribute (entry is an NTFS reparse point, e.g. a directory junction or a mount file system). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_COMPRESSED

Bit that represents a Windows entry with a compressed attribute (NTFS only). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_OFFLINE

Bit that represents a Windows entry with an offline attribute (entry is offline and not accessible). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_NOT_CONTENT_INDEXED

Bit that represents a Windows entry with a not content indexed attribute (entry is to be indexed). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_ENCRYPTED

Bit that represents a Windows entry with an encrypted attribute (NTFS only). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_VIRTUAL

Bit that represents a Windows entry with a virtual attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_UNIX_WORLD_EXECUTE

Bit that represents a UNIX entry that is world executable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_WORLD_WRITE

Bit that represents a UNIX entry that is world writable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_WORLD_READ

Bit that represents a UNIX entry that is world readable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_EXECUTE

Bit that represents a UNIX entry that is group executable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_WRITE

Bit that represents a UNIX entry that is group writable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_READ

Bit that represents a UNIX entry that is group readable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_EXECUTE

Bit that represents a UNIX entry that is owner executable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_WRITE

Bit that represents a UNIX entry that is owner writable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_READ

Bit that represents a UNIX entry that is owner readable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_STICKY

Bit that represents the UNIX sticky bit. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_SETGID

Bit that represents the UNIX setgid attribute. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_SETUID

Bit that represents the UNIX setuid attribute. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET

Mask to isolate the last four bits (nibble) of UNIX attributes
      (_S_IFMT, the type of file mask). To be used with
      RarEntry::getAttr() on entries whose host OS is UNIX and with the
      constants RarEntry::ATTRIBUTE_UNIX_FIFO,
      RarEntry::ATTRIBUTE_UNIX_CHAR_DEV,
      RarEntry::ATTRIBUTE_UNIX_DIRECTORY,
      RarEntry::ATTRIBUTE_UNIX_BLOCK_DEV,
      RarEntry::ATTRIBUTE_UNIX_REGULAR_FILE,
      RarEntry::ATTRIBUTE_UNIX_SYM_LINK and
      RarEntry::ATTRIBUTE_UNIX_SOCKET.

RarEntry::ATTRIBUTE_UNIX_FIFO

Unix FIFOs will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_CHAR_DEV

Unix character devices will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_DIRECTORY

Unix directories will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET. See also RarEntry::isDirectory(), which also works with entries that were added in other operating systems.

RarEntry::ATTRIBUTE_UNIX_BLOCK_DEV

Unix block devices will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_REGULAR_FILE

Unix regular files (not directories) will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET. See also RarEntry::isDirectory(), which also works with entries that were added in other operating systems.

RarEntry::ATTRIBUTE_UNIX_SYM_LINK

Unix symbolic links will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_SOCKET

Unix sockets will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

Table of Contents

  • RarEntry::extract — Extract entry from the archive
  • RarEntry::getAttr — Get attributes of the entry
  • RarEntry::getCrc — Get CRC of the entry
  • RarEntry::getFileTime — Get entry last modification time
  • RarEntry::getHostOs — Get entry host OS
  • RarEntry::getMethod — Get pack method of the entry
  • RarEntry::getName — Get name of the entry
  • RarEntry::getPackedSize — Get packed size of the entry
  • RarEntry::getStream — Get file handler for entry
  • RarEntry::getUnpackedSize — Get unpacked size of the entry
  • RarEntry::getVersion — Get minimum version of RAR program required to unpack the entry
  • RarEntry::isDirectory — Test whether an entry represents a directory
  • RarEntry::isEncrypted — Test whether an entry is encrypted
  • RarEntry::__toString — Get text representation of entry


Extract entry from the archive

  • ? RarEntry
  • RarEntry::getAttr ?
  • PHP Manual
  • RarEntry
  • Extract entry from the archive

RarEntry::extract

(PECL rar >= 0.1)

RarEntry::extract — Extract entry from the archive

说明

public RarEntry::extract ( string $dir , string $filepath = "" , string $password = NULL , bool $extended_data = false ) : bool

RarEntry::extract() extracts the entry's data. It will create new file in the specified dir with the name identical to the entry's name, unless the second argument is specified. See below for more information.

参数

dir

Path to the directory where files should be extracted. This parameter is considered if and only if filepath is not. If both parameters are empty an extraction to the current directory will be attempted.

filepath

Path (relative or absolute) containing the directory and filename of the extracted file. This parameter overrides both the parameter dir and the original file name.

password

The password used to encrypt this entry. If the entry is not encrypted, this value will not be used and can be omitted. If this parameter is omitted and the entry is encrypted, the password given to rar_open(), if any, will be used. If a wrong password is given, either explicitly or implicitly via rar_open(), CRC checking will fail and this method will fail and return false. If no password is given and one is required, this method will fail and return false. You can check whether an entry is encrypted with RarEntry::isEncrypted().

extended_data

If true, extended information such as NTFS ACLs and Unix owner information will be set in the extract files, as long as it's present in the archive.

Warning

Prior to version 2.0.0, this function would not handle relative paths correctly. Use realpath() as a workaround.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PECL rar 3.0.0 | extended_data was added.
PECL rar 3.0.0 | Support for RAR archives with repeated entry names is no longer defective.

范例

Example #1 RarEntry::extract() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

$entry->extract('/dir/to'); // create /dir/to/Dir/file.txt
$entry->extract(false, '/dir/to/new_name.txt'); // create /dir/to/new_name.txt

?>

Example #2 How to extract all files in archive:

<?php

/* example by Erik Jenssen aka erix */

$filename = "foobar.rar";
$filepath = "/home/foo/bar/";

$rar_file = rar_open($filepath.$filename);
$list = rar_list($rar_file);
foreach($list as $file) {
    $entry = rar_entry_get($rar_file, $file);
    $entry->extract("."); // extract to the current dir
}
rar_close($rar_file);

?>

参见

  • RarEntry::getStream() - Get file handler for entry
  • rar:// wrapper


Get attributes of the entry

  • ? RarEntry::extract
  • RarEntry::getCrc ?
  • PHP Manual
  • RarEntry
  • Get attributes of the entry

RarEntry::getAttr

(PECL rar >= 0.1)

RarEntry::getAttr — Get attributes of the entry

说明

public RarEntry::getAttr ( ) : int

Returns the OS-dependent attributes of the archive entry.

参数

此函数没有参数。

返回值

Returns the attributes or false on error.

范例

Example #1 RarEntry::getAttr() example

<?php

$rar_file = rar_open('example.rar') or die("Can't open Rar archive");

$entry = rar_entry_get($rar_file, 'dir/in/the/archive') or die("Can't find such entry");

$host_os = $entry->getHostOs();
$attr = $entry->getAttr();

switch($host_os) {
    case RAR_HOST_MSDOS:
    case RAR_HOST_OS2:
    case RAR_HOST_WIN32:
    case RAR_HOST_MACOS:
        printf("%c%c%c%c%c%c\n",
                ($attr & 0x08) ? 'V' : '.',
                ($attr & 0x10) ? 'D' : '.',
                ($attr & 0x01) ? 'R' : '.',
                ($attr & 0x02) ? 'H' : '.',
                ($attr & 0x04) ? 'S' : '.',
                ($attr & 0x20) ? 'A' : '.');
        break;
    case RAR_HOST_UNIX:
    case RAR_HOST_BEOS:
        switch ($attr & 0xF000)
        {
            case 0x4000:
                printf("d");
                break;
            case 0xA000:
                printf("l");
                break;
            default:
                printf("-");
                break;
        }
        printf("%c%c%c%c%c%c%c%c%c\n",
                ($attr & 0x0100) ? 'r' : '-',
                ($attr & 0x0080) ? 'w' : '-',
                ($attr & 0x0040) ? (($attr & 0x0800) ? 's':'x'):(($attr & 0x0800) ? 'S':'-'),
                ($attr & 0x0020) ? 'r' : '-',
                ($attr & 0x0010) ? 'w' : '-',
                ($attr & 0x0008) ? (($attr & 0x0400) ? 's':'x'):(($attr & 0x0400) ? 'S':'-'),
                ($attr & 0x0004) ? 'r' : '-',
                ($attr & 0x0002) ? 'w' : '-',
                ($attr & 0x0001) ? 'x' : '-');
        break;
}

rar_close($rar_file);

?>

参见

  • RarEntry::getHostOs() - Get entry host OS
  • The constants in RarEntry


Get CRC of the entry

  • ? RarEntry::getAttr
  • RarEntry::getFileTime ?
  • PHP Manual
  • RarEntry
  • Get CRC of the entry

RarEntry::getCrc

(PECL rar >= 0.1)

RarEntry::getCrc — Get CRC of the entry

说明

public RarEntry::getCrc ( ) : string

Returns an hexadecimal string representation of the CRC of the archive entry.

参数

此函数没有参数。

返回值

Returns the CRC of the archive entry or false on error.

更新日志

版本 | 说明
PECL rar 2.0.0 | This method now returns correct values for multiple volume archives.


Get entry last modification time

  • ? RarEntry::getCrc
  • RarEntry::getHostOs ?
  • PHP Manual
  • RarEntry
  • Get entry last modification time

RarEntry::getFileTime

(PECL rar >= 0.1)

RarEntry::getFileTime — Get entry last modification time

说明

public RarEntry::getFileTime ( ) : string

Gets entry last modification time.

参数

此函数没有参数。

返回值

Returns entry last modification time as string in format YYYY-MM-DD HH:II:SS, or false on error.


Get entry host OS

  • ? RarEntry::getFileTime
  • RarEntry::getMethod ?
  • PHP Manual
  • RarEntry
  • Get entry host OS

RarEntry::getHostOs

(PECL rar >= 0.1)

RarEntry::getHostOs — Get entry host OS

说明

public RarEntry::getHostOs ( ) : int

Returns the code of the host OS of the archive entry.

参数

此函数没有参数。

返回值

Returns the code of the host OS, or false on error.

范例

Example #1 RarEntry::getHostOs() example (version >= 2.0.0)

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

switch ($entry->getHostOs()) {
    case RarEntry::HOST_MSDOS:
        echo "MS-DOS\n";
        break;
    case RarEntry::HOST_OS2:
        echo "OS2\n";
        break;
    case RarEntry::HOST_WIN32:
        echo "Win32\n";
        break;
    case RarEntry::HOST_MACOS:
        echo "MacOS\n";
        break;
    case RarEntry::HOST_UNIX:
        echo "Unix/Linux\n";
        break;
    case RarEntry::HOST_BEOS:
        echo "BeOS\n";
        break;
}

?>

Example #2 RarEntry::getHostOs() example (version <= 1.0.0)

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

switch ($entry->getHostOs()) {
    case RAR_HOST_MSDOS:
        echo "MS-DOS\n";
        break;
    case RAR_HOST_OS2:
        echo "OS2\n";
        break;
    case RAR_HOST_WIN32:
        echo "Win32\n";
        break;
    case RAR_HOST_MACOS:
        echo "MacOS\n";
        break;
    case RAR_HOST_UNIX:
        echo "Unix/Linux\n";
        break;
    case RAR_HOST_BEOS:
        echo "BeOS\n";
        break;
}

?>

参见

  • RarEntry::extract() - Extract entry from the archive


Get pack method of the entry

  • ? RarEntry::getHostOs
  • RarEntry::getName ?
  • PHP Manual
  • RarEntry
  • Get pack method of the entry

RarEntry::getMethod

(PECL rar >= 0.1)

RarEntry::getMethod — Get pack method of the entry

说明

public RarEntry::getMethod ( ) : int

RarEntry::getMethod() returns number of the method used when adding current archive entry.

参数

此函数没有参数。

返回值

Returns the method number or false on error.

范例

Example #1 RarEntry::getMethod() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Method number: " . $entry->getMethod();

?>


Get name of the entry

  • ? RarEntry::getMethod
  • RarEntry::getPackedSize ?
  • PHP Manual
  • RarEntry
  • Get name of the entry

RarEntry::getName

(PECL rar >= 0.1)

RarEntry::getName — Get name of the entry

说明

public RarEntry::getName ( ) : string

Returns the name (with path) of the archive entry.

参数

此函数没有参数。

返回值

Returns the entry name as a string, or false on error.

更新日志

版本 | 说明
PECL rar 2.0.0 | As of version 2.0.0, the returned string is encoded in Unicode/UTF-8.

范例

Example #1 RarEntry::getName() example

<?php

//this example is safe even in pages not encoded in UTF-8
//for those encoded in UTF-8, the call to mb_convert_encoding is unnecessary

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Entry name: " . mb_convert_encoding(
    htmlentities(
        $entry->getName(),
        ENT_COMPAT,
        "UTF-8"
    ),
    "HTML-ENTITIES",
    "UTF-8"
);

?>


Get packed size of the entry

  • ? RarEntry::getName
  • RarEntry::getStream ?
  • PHP Manual
  • RarEntry
  • Get packed size of the entry

RarEntry::getPackedSize

(PECL rar >= 0.1)

RarEntry::getPackedSize — Get packed size of the entry

说明

public RarEntry::getPackedSize ( ) : int

Get packed size of the archive entry.

Note:

Note that on platforms with 32-bit longs (that includes Windows x64), the maximum size returned is capped at 2 GiB. Check the constant PHP_INT_MAX.

参数

此函数没有参数。

返回值

Returns the packed size, or false on error.

更新日志

版本 | 说明
PECL rar 2.0.0 | This method now returns correct values of packed sizes bigger than 2 GiB on platforms with 64-bit ints and never returns negative values on other platforms.

范例

Example #1 RarEntry::getPackedSize() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Packed size of " . $entry->getName() . " = " . $entry->getPackedSize() . " bytes";

?>


Get file handler for entry

  • ? RarEntry::getPackedSize
  • RarEntry::getUnpackedSize ?
  • PHP Manual
  • RarEntry
  • Get file handler for entry

RarEntry::getStream

(PECL rar >= 2.0.0)

RarEntry::getStream — Get file handler for entry

说明

public RarEntry::getStream ( string $password = ? ) : resource|false

Returns a file handler that supports read operations. This handler provides on-the-fly decompression for this entry.

The handler is not invalidated by calling rar_close().

Warning

The resulting stream has no integrity verification. In particular, file corruption and decryption with a wrong a key will not be detected. It is the programmer's responsability to use the entry's CRC to check for integrity, if he so wishes.

参数

password

The password used to encrypt this entry. If the entry is not encrypted, this value will not be used and can be omitted. If this parameter is omitted and the entry is encrypted, the password given to rar_open(), if any, will be used. If a wrong password is given, either explicitly or implicitly via rar_open(), this method's resulting stream will produce wrong output. If no password is given and one is required, this method will fail and return false. You can check whether an entry is encrypted with RarEntry::isEncrypted().

返回值

The file handler 或者在失败时返回 false.

更新日志

版本 | 说明
PECL rar 3.0.0 | Support for RAR archives with repeated entry names is no longer defective.

范例

Example #1 RarEntry::getStream() example

<?php

$rar_file = rar_open('example.rar');
if ($rar_file === false)
    die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt');
if ($entry === false)
    die("Failed to find such entry");

$stream = $entry->getStream();
if ($stream === false)
    die("Failed to obtain stream.");

rar_close($rar_file); //stream is independent from file

while (!feof($stream)) {
    $buff = fread($stream, 8192);
    if ($buff !== false)
        echo $buff;
    else
        break; //fread error
}

fclose($stream);

?>

参见

  • RarEntry::extract() - Extract entry from the archive
  • rar:// wrapper


Get unpacked size of the entry

  • ? RarEntry::getStream
  • RarEntry::getVersion ?
  • PHP Manual
  • RarEntry
  • Get unpacked size of the entry

RarEntry::getUnpackedSize

(PECL rar >= 0.1)

RarEntry::getUnpackedSize — Get unpacked size of the entry

说明

public RarEntry::getUnpackedSize ( ) : int

Get unpacked size of the archive entry.

Note:

Note that on platforms with 32-bit longs (that includes Windows x64), the maximum size returned is capped at 2 GiB. Check the constant PHP_INT_MAX.

参数

此函数没有参数。

返回值

Returns the unpacked size, or false on error.

更新日志

版本 | 说明
PECL rar 2.0.0 | This method now returns correct values of unpacked sizes bigger than 2 GiB on platforms with 64-bit ints and never returns negative values on other platforms.

返回值

Example #1 RarEntry::getUnpackedSize() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Unpacked size of " . $entry->getName() . " = " . $entry->getPackedSize() . " bytes";

?>


Get minimum version of RAR program required to unpack the entry

  • ? RarEntry::getUnpackedSize
  • RarEntry::isDirectory ?
  • PHP Manual
  • RarEntry
  • Get minimum version of RAR program required to unpack the entry

RarEntry::getVersion

(PECL rar >= 0.1)

RarEntry::getVersion — Get minimum version of RAR program required to unpack the entry

说明

public RarEntry::getVersion ( ) : int

Returns minimum version of RAR program (e.g. WinRAR) required to unpack the entry. It is encoded as 10 * major version + minor version.

参数

此函数没有参数。

返回值

Returns the version or false on error.

范例

Example #1 RarEntry::getVersion() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Rar version required for unpacking: " . $entry->getVersion();

?>


Test whether an entry represents a directory

  • ? RarEntry::getVersion
  • RarEntry::isEncrypted ?
  • PHP Manual
  • RarEntry
  • Test whether an entry represents a directory

RarEntry::isDirectory

(PECL rar >= 2.0.0)

RarEntry::isDirectory — Test whether an entry represents a directory

说明

public RarEntry::isDirectory ( ) : bool

Tests whether the current entry is a directory.

参数

此函数没有参数。

返回值

Returns true if this entry is a directory and false otherwise.

注释

This function is only available starting with version 2.0.0, but one can also test whether an entry is a directory by checking the entry attributes, like this (only works for files compressed in RAR for Windows or Unix):

<?php
//...
//Open file, get entry and store in variable $e...
//...

$isDirectory = (bool) ((($e->getHostOs() == RAR_HOST_WIN32) && ($e->getAttr() & 0x10)) ||
    (($e->getHostOs() == RAR_HOST_UNIX) && (($e->getAttr() & 0xf000) == 0x4000)));
?>


Test whether an entry is encrypted

  • ? RarEntry::isDirectory
  • RarEntry::__toString ?
  • PHP Manual
  • RarEntry
  • Test whether an entry is encrypted

RarEntry::isEncrypted

(PECL rar >= 2.0.0)

RarEntry::isEncrypted — Test whether an entry is encrypted

说明

public RarEntry::isEncrypted ( ) : bool

Tests whether the current entry contents are encrypted.

Note:

The password used may differ between files inside the same RAR archive.

参数

此函数没有参数。

返回值

Returns true if the current entry is encrypted and false otherwise.


Get text representation of entry

  • ? RarEntry::isEncrypted
  • RarException ?
  • PHP Manual
  • RarEntry
  • Get text representation of entry

RarEntry::__toString

(PECL rar >= 2.0.0)

RarEntry::__toString — Get text representation of entry

说明

public RarEntry::__toString ( ) : string

RarEntry::__toString() returns a textual representation for this entry. It includes whether the entry is a file or a directory (symbolic links and other special objects will be treated as files), the UTF-8 name of the entry and its CRC. The form and content of this representation may be changed in the future, so they cannot be relied upon.

参数

此函数没有参数。

返回值

A textual representation for the entry.


The RarException class

(PECL rar >= 2.0.0)

简介

This class serves two purposes: it is the type of the exceptions thrown by the RAR extension functions and methods and it allows, through static methods to query and define the error behaviour of the extension, i.e., whether exceptions are thrown or only warnings are emitted.

The following error codes are used:

  • -1 - error outside UnRAR library
  • 11 - insufficient memory
  • 12 - bad data
  • 13 - bad archive
  • 14 - unknown format
  • 15 - file open error
  • 16 - file create error
  • 17 - file close error
  • 18 - read error
  • 19 - write error
  • 20 - buffer too small
  • 21 - unknown RAR error
  • 22 - password required but not given

类摘要

final RarException extends Exception {
/* 方法 */
public static isUsingExceptions ( ) : bool
public static setUsingExceptions ( bool $using_exceptions ) : void
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Table of Contents

  • RarException::isUsingExceptions — Check whether error handling with exceptions is in use
  • RarException::setUsingExceptions — Activate and deactivate error handling with exceptions


Check whether error handling with exceptions is in use

  • ? RarException
  • RarException::setUsingExceptions ?
  • PHP Manual
  • RarException
  • Check whether error handling with exceptions is in use

RarException::isUsingExceptions

(PECL rar >= 2.0.0)

RarException::isUsingExceptions — Check whether error handling with exceptions is in use

说明

public static RarException::isUsingExceptions ( ) : bool

Checks whether the RAR functions will emit warnings and return error values or whether they will throw exceptions in most of the circumstances (does not include some programmatic errors such as passing the wrong type of arguments).

参数

此函数没有参数。

返回值

Returns true if exceptions are being used, false otherwise.

范例

Example #1 RarException::isUsingExceptions() example

<?php
//The default is not to use exceptions
var_dump(RarException::isUsingExceptions());
?>

以上例程的输出类似于：

bool(false)

参见

  • RarException::setUsingExceptions() - Activate and deactivate error handling with exceptions


Activate and deactivate error handling with exceptions

  • ? RarException::isUsingExceptions
  • Zip ?
  • PHP Manual
  • RarException
  • Activate and deactivate error handling with exceptions

RarException::setUsingExceptions

(PECL rar >= 2.0.0)

RarException::setUsingExceptions — Activate and deactivate error handling with exceptions

说明

public static RarException::setUsingExceptions ( bool $using_exceptions ) : void

If and only if the argument is true, then, instead of emitting warnings and returning a special value indicating error when the UnRAR library encounters an error, an exception of type RarException will be thrown.

Exceptions will also be thrown for the following errors, which occur outside the library (their error code will be -1):

  • attempting some operations on a closed RarArchive object or a RarEntry object relative to the first;
  • attempting to get an entry that does not exist with RarArchive::getEntry().

参数

using_exceptions

Should be true to activate exception throwing, false to deactivate (the default).

范例

Example #1 RarException::setUsingExceptions() example

<?php
var_dump(RarException::isUsingExceptions());
$arch = RarArchive::open("does_not_exist.rar");
var_dump($arch);

RarException::setUsingExceptions(true);
var_dump(RarException::isUsingExceptions());
$arch = RarArchive::open("does_not_exist.rar");
var_dump($arch); //not reached
?>

以上例程的输出类似于：

bool(false)

Warning: RarArchive::open(): Failed to open does_not_exist.rar: ERAR_EOPEN (file open error) in C:\php_rar\trunk\tests\test.php on line 3
bool(false)
bool(true)

Fatal error: Uncaught exception 'RarException' with message 'unRAR internal error: Failed to open does_not_exist.rar: ERAR_EOPEN (file open error)' in C:\php_rar\trunk\tests\test.php:8
Stack trace:
#0 C:\php_rar\trunk\tests\test.php(8): RarArchive::open('does_not_exist....')
#1 {main}
  thrown in C:\php_rar\trunk\tests\test.php on line 8

参见

  • RarException::isUsingExceptions() - Check whether error handling with exceptions is in use


Zip

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • ZipArchive — ZipArchive 类
    • ZipArchive::addEmptyDir — Add a new directory
    • ZipArchive::addFile — Adds a file to a ZIP archive from the given path
    • ZipArchive::addFromString — Add a file to a ZIP archive using its contents
    • ZipArchive::addGlob — Add files from a directory by glob pattern
    • ZipArchive::addPattern — Add files from a directory by PCRE pattern
    • ZipArchive::close — Close the active archive (opened or newly created)
    • ZipArchive::count — Counts the number of files in the archive
    • ZipArchive::deleteIndex — Delete an entry in the archive using its index
    • ZipArchive::deleteName — Delete an entry in the archive using its name
    • ZipArchive::extractTo — 解压缩文件
    • ZipArchive::getArchiveComment — Returns the Zip archive comment
    • ZipArchive::getCommentIndex — Returns the comment of an entry using the entry index
    • ZipArchive::getCommentName — Returns the comment of an entry using the entry name
    • ZipArchive::getExternalAttributesIndex — Retrieve the external attributes of an entry defined by its index
    • ZipArchive::getExternalAttributesName — Retrieve the external attributes of an entry defined by its name
    • ZipArchive::getFromIndex — Returns the entry contents using its index
    • ZipArchive::getFromName — Returns the entry contents using its name
    • ZipArchive::getNameIndex — Returns the name of an entry using its index
    • ZipArchive::getStatusString — Returns the status error message, system and/or zip messages
    • ZipArchive::getStream — Get a file handler to the entry defined by its name (read only)
    • ZipArchive::isCompressionMethodSupported — Check if a compression method is supported by libzip
    • ZipArchive::isEncryptionMethodSupported — Check if a encryption method is supported by libzip
    • ZipArchive::locateName — Returns the index of the entry in the archive
    • ZipArchive::open — Open a ZIP file archive
    • ZipArchive::registerCancelCallback — Register a callback to allow cancellation during archive close.
    • ZipArchive::registerProgressCallback — Register a callback to provide updates during archive close.
    • ZipArchive::renameIndex — Renames an entry defined by its index
    • ZipArchive::renameName — Renames an entry defined by its name
    • ZipArchive::replaceFile — Replace file in ZIP archive with a given path
    • ZipArchive::setArchiveComment — Set the comment of a ZIP archive
    • ZipArchive::setCommentIndex — Set the comment of an entry defined by its index
    • ZipArchive::setCommentName — Set the comment of an entry defined by its name
    • ZipArchive::setCompressionIndex — Set the compression method of an entry defined by its index
    • ZipArchive::setCompressionName — Set the compression method of an entry defined by its name
    • ZipArchive::setEncryptionIndex — Set the encryption method of an entry defined by its index
    • ZipArchive::setEncryptionName — Set the encryption method of an entry defined by its name
    • ZipArchive::setExternalAttributesIndex — Set the external attributes of an entry defined by its index
    • ZipArchive::setExternalAttributesName — Set the external attributes of an entry defined by its name
    • ZipArchive::setMtimeIndex — Set the modification time of an entry defined by its index
    • ZipArchive::setMtimeName — Set the modification time of an entry defined by its name
    • ZipArchive::setPassword — Set the password for the active archive
    • ZipArchive::statIndex — Get the details of an entry defined by its index
    • ZipArchive::statName — Get the details of an entry defined by its name
    • ZipArchive::unchangeAll — Undo all changes done in the archive
    • ZipArchive::unchangeArchive — Revert all global changes done in the archive
    • ZipArchive::unchangeIndex — Revert all changes done to an entry at the given index
    • ZipArchive::unchangeName — Revert all changes done to an entry with the given name
  • Zip 函数
    • zip_close — 关闭一个ZIP档案文件
    • zip_entry_close — 关闭目录项
    • zip_entry_compressedsize — 检索目录项压缩过后的大小
    • zip_entry_compressionmethod — 检索目录实体的压缩方法
    • zip_entry_filesize — 检索目录实体的实际大小
    • zip_entry_name — 检索目录项的名称
    • zip_entry_open — 打开用于读取的目录实体
    • zip_entry_read — 读取一个打开了的压缩目录实体
    • zip_open — 打开ZIP存档文件
    • zip_read — 读取ZIP存档文件中下一项


  • ? Zip
  • 安装／配置 ?
  • PHP Manual
  • Zip
  • 简介

简介

此扩展可以让你透明地读写ZIP压缩文档以及它们里面的文件。


需求

PHP 5.2.0 或更新版本

此扩展用到 Jean-loup Gailly 和 Mark Adle 的 » zlib 里的函数。


安装

Linux 系统

从 PHP 7.4.0 开始，必须在编译 PHP 时用 --with-zip 配置选项来提供 zip 支持。之前的 PHP 版本，需要使用 --enable-zip 选项。

从 PHP 5.6.0 开始，添加了一个选项 --with-libzip=DIR 用来指定系统的 libzip 目录。要求 libzip 最低版本为 0.11，推荐使用 0.11.2 及以上版本。

从 PHP 7.3.0 开始, 不鼓励使用捆绑的 libzip 进行构建，但通过在配置中添加 --without-libzip 参数仍然可以实现。 从 PHP 7.4.0 开始，捆绑的 libzip 被移除。

Windows

PHP 5.3 之后该扩展已经内置。之前的版本，Windows 用户需要在 php.ini 里使 php_zip.dll 可用，以便使用这些函数。

通过 PECL 安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/zip.


资源类型

在 Zip 模块里用到两种资源类型。第一种是 Zip 文档的 Zip 目录，第二种是文档条目的 Zip 条目。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

ZipArchive 使用的类常量。 有以下三类常量：Flags（以 FL_ 为前缀），errors（以 ER_ 为前缀）以及 mode（没有前缀）。

ZIPARCHIVE::CREATE (integer)
如果不存在则创建一个zip压缩包。
ZIPARCHIVE::OVERWRITE (integer)
总是以一个新的压缩包开始，此模式下如果已经存在则会被覆盖。
ZIPARCHIVE::EXCL (integer)
如果压缩包已经存在，则出错。
ZipArchive::RDONLY (integer)
只读模式打开压缩包。 Available as of PHP 7.4.3 and PECL zip 1.17.1, respectively, if built against libzip ≥ 1.0.0.
ZIPARCHIVE::CHECKCONS (integer)
对压缩包执行额外的一致性检查，如果失败则显示错误。
ZIPARCHIVE::FL_NOCASE (integer)
查找时忽略名称的大小写。
ZIPARCHIVE::FL_NODIR (integer)
忽略目录部分
ZIPARCHIVE::FL_COMPRESSED (integer)
读取压缩数据
ZIPARCHIVE::FL_UNCHANGED (integer)
使用原始数据，忽略更改。
ZipArchive::FL_RECOMPRESS (integer)
强制重新压缩数据。 PHP 8.0.0 和 PECL zip 1.18.0 起可以使用。
ZipArchive::FL_ENCRYPTED (integer)
Read encrypted data (implies FL_COMPRESSED). Available as of PHP 8.0.0 and PECL zip 1.18.0.
ZipArchive::FL_OVERWRITE (integer)
If file with name exists, overwrite (replace) it. Available as of PHP 8.0.0 and PECL zip 1.18.0.
ZipArchive::FL_LOCAL (integer)
In local header. Available as of PHP 8.0.0 and PECL zip 1.18.0.
ZipArchive::ZIP_FL_CENTRAL (integer)
In central directory. Available as of PHP 8.0.0 and PECL zip 1.18.0.
ZipArchive::FL_ENC_GUESS (integer)
Guess string encoding (is default). Available as of PHP 7.0.8.
ZipArchive::FL_ENC_RAW (integer)
Get unmodified string. Available as of PHP 7.0.8.
ZipArchive::FL_ENC_STRICT (integer)
Follow specification strictly. Available as of PHP 7.0.8.
ZipArchive::FL_ENC_UTF_8 (integer)
String is UTF-8 encoded. Available as of PHP 7.0.8.
ZipArchive::FL_ENC_CP437 (integer)
String is CP437 encoded. Available as of PHP 7.0.8.
ZIPARCHIVE::CM_DEFAULT (integer)
更好的压缩或存储。
ZIPARCHIVE::CM_STORE (integer)
存储（不压缩）。
ZIPARCHIVE::CM_SHRINK (integer)
收缩
ZIPARCHIVE::CM_REDUCE_1 (integer)
用因子1换算
ZIPARCHIVE::CM_REDUCE_2 (integer)
用因子2换算
ZIPARCHIVE::CM_REDUCE_3 (integer)
用因子3换算
ZIPARCHIVE::CM_REDUCE_4 (integer)
用因子4换算
ZIPARCHIVE::CM_IMPLODE (integer)
聚爆
ZIPARCHIVE::CM_DEFLATE (integer)
deflated
ZIPARCHIVE::CM_DEFLATE64 (integer)
deflate64
ZIPARCHIVE::CM_PKWARE_IMPLODE (integer)
PKWARE imploding
ZIPARCHIVE::CM_BZIP2 (integer)
BZIP2算法
ZipArchive::CM_LZMA (integer)
LZMA 算法
ZipArchive::CM_LZMA2 (integer)
LZMA2 algorithm. Available as of PHP 7.4.3 and PECL zip 1.16.0, respectively, if built against libzip ≥ 1.6.0.
ZipArchive::CM_XZ (integer)
XZ algorithm. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively, if built against libzip ≥ 1.6.0.
ZIPARCHIVE::ER_OK (integer)
没有错误。
ZIPARCHIVE::ER_MULTIDISK (integer)
不支持多磁盘zip压缩包。
ZIPARCHIVE::ER_RENAME (integer)
重命名临时文件失败。
ZIPARCHIVE::ER_CLOSE (integer)
关闭zip压缩包失败。
ZIPARCHIVE::ER_SEEK (integer)
寻址错误
ZIPARCHIVE::ER_READ (integer)
读取错误
ZIPARCHIVE::ER_WRITE (integer)
写入错误
ZIPARCHIVE::ER_CRC (integer)
CRC校验失败
ZIPARCHIVE::ER_ZIPCLOSED (integer)
zip压缩包已关闭
ZIPARCHIVE::ER_NOENT (integer)
没有文件
ZIPARCHIVE::ER_EXISTS (integer)
文件已经存在
ZIPARCHIVE::ER_OPEN (integer)
不能打开文件
ZIPARCHIVE::ER_TMPOPEN (integer)
创建临时文件失败
ZIPARCHIVE::ER_ZLIB (integer)
Zlib错误
ZIPARCHIVE::ER_MEMORY (integer)
内存分配失败
ZIPARCHIVE::ER_CHANGED (string)
条目已被改变
ZIPARCHIVE::ER_COMPNOTSUPP (integer)
不支持的压缩方式
ZIPARCHIVE::ER_EOF (integer)
过早的EOF
ZIPARCHIVE::ER_INVAL (integer)
无效的参数
ZIPARCHIVE::ER_NOZIP (integer)
不是一个zip压缩包
ZIPARCHIVE::ER_INTERNAL (integer)
内部错误（Internal error）
ZIPARCHIVE::ER_INCONS (integer)
Zip压缩包不一致
ZIPARCHIVE::ER_REMOVE (integer)
不能移除文件
ZIPARCHIVE::ER_DELETED (integer)
条目已被删除
ZipArchive::ER_ENCRNOTSUPP (integer)
不支持的压缩方式。 PHP 7.4.3 和 PECL zip 1.16.1 起可用。
ZipArchive::ER_RDONLY (integer)
Read-only archive. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively.
ZipArchive::ER_NOPASSWD (integer)
No password provided. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively.
ZipArchive::ER_WRONGPASSWD (integer)
Wrong password provided. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively.
ZipArchive::ZIP_ER_OPNOTSUPP (integer)
Operation not supported. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively, if built against libzip ≥ 1.0.0.
ZipArchive::ZIP_ER_INUSE (integer)
Resource still in use. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively, if built against libzip ≥ 1.0.0.
ZipArchive::ZIP_ER_TELL (integer)
Tell error. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively, if built against libzip ≥ 1.0.0.
ZipArchive::ZIP_ER_COMPRESSED_DATA (integer)
Compressed data invalid. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively, if built against libzip ≥ 1.6.0.
ZipArchive::ER_CANCELLED (integer)
Operation cancelled. Available as of PHP 7.4.3 and PECL zip 1.16.1, respectively, if built against libzip ≥ 1.6.0.
ZipArchive::EM_NONE (integer)
No encryption, since PHP 7.2.0, PECL zip 1.14.0
ZipArchive::EM_AES_128 (integer)
AES 128 encryption, since PHP 7.2.0, PECL zip 1.14.0
ZipArchive::EM_AES_192 (integer)
AES 1192 encryption, since PHP 7.2.0, PECL zip 1.14.0
ZipArchive::EM_AES_256 (integer)
AES 256 encryption, since PHP 7.2.0, PECL zip 1.14.0
ZipArchive::LIBZIP_VERSION (string)
Zip library version. Available as of PHP 7.4.3 and PECL zip 1.16.0.
Operating system constants for external attributes
ZipArchive::OPSYS_DOS (integer)
ZipArchive::OPSYS_AMIGA (integer)
ZipArchive::OPSYS_OPENVMS (integer)
ZipArchive::OPSYS_UNIX (integer)
ZipArchive::OPSYS_VM_CMS (integer)
ZipArchive::OPSYS_ATARI_ST (integer)
ZipArchive::OPSYS_OS_2 (integer)
ZipArchive::OPSYS_MACINTOSH (integer)
ZipArchive::OPSYS_Z_SYSTEM (integer)
ZipArchive::OPSYS_CPM (integer)
ZipArchive::OPSYS_WINDOWS_NTFS (integer)
ZipArchive::OPSYS_MVS (integer)
ZipArchive::OPSYS_VSE (integer)
ZipArchive::OPSYS_ACORN_RISC (integer)
ZipArchive::OPSYS_VFAT (integer)
ZipArchive::OPSYS_ALTERNATE_MVS (integer)
ZipArchive::OPSYS_BEOS (integer)
ZipArchive::OPSYS_TANDEM (integer)
ZipArchive::OPSYS_OS_400 (integer)
ZipArchive::OPSYS_OS_X (integer)
ZipArchive::OPSYS_DEFAULT (integer)
Since PHP 5.6.0, PECL zip 1.12.4


范例

Example #1 创建一个 Zip 归档

<?php

$zip = new ZipArchive();
$filename = "./test112.zip";

if ($zip->open($filename, ZIPARCHIVE::CREATE)!==TRUE) {
    exit("cannot open <$filename>\n");
}

$zip->addFromString("testfilephp.txt" . time(), "#1 This is a test string added as testfilephp.txt.\n");
$zip->addFromString("testfilephp2.txt" . time(), "#2 This is a test string added as testfilephp2.txt.\n");
$zip->addFile($thisdir . "/too.php","/testfromfile.php");
echo "numfiles: " . $zip->numFiles . "\n";
echo "status:" . $zip->status . "\n";
$zip->close();
?>

Example #2 输出文档细节和列表

<?php
$za = new ZipArchive();

$za->open('test_with_comment.zip');
print_r($za);
var_dump($za);
echo "numFiles: " . $za->numFiles . "\n";
echo "status: " . $za->status  . "\n";
echo "statusSys: " . $za->statusSys . "\n";
echo "filename: " . $za->filename . "\n";
echo "comment: " . $za->comment . "\n";

for ($i=0; $i<$za->numFiles;$i++) {
    echo "index: $i\n";
    print_r($za->statIndex($i));
}
echo "numFile:" . $za->numFiles . "\n";
?>

Example #3 Zip 流封装，读取一个 OpenOffice 文件的元信息

<?php
$reader = new XMLReader();

$reader->open('zip://' . dirname(__FILE__) . '/test.odt#meta.xml');
$odt_meta = array();
while ($reader->read()) {
    if ($reader->nodeType == XMLREADER::ELEMENT) {
        $elm = $reader->name;
    } else {
        if ($reader->nodeType == XMLREADER::END_ELEMENT && $reader->name == 'office:meta') {
            break;
        }
        if (!trim($reader->value)) {
            continue;
        }
        $odt_meta[$elm] = $reader->value;
    }
}
print_r($odt_meta);
?>

此例使用了旧的 API（PHP 4），它打开了一个 ZIP 文件归档，读取归档里的每个文件，并输出文件内容。此例用到的 test2.zip 文档是 ZZIPlib 源分布里测试文档中的一个。

Example #4 Zip 使用范例

<?php

$zip = zip_open("/tmp/test2.zip");

if ($zip) {
    while ($zip_entry = zip_read($zip)) {
        echo "Name:               " . zip_entry_name($zip_entry) . "\n";
        echo "Actual Filesize:    " . zip_entry_filesize($zip_entry) . "\n";
        echo "Compressed Size:    " . zip_entry_compressedsize($zip_entry) . "\n";
        echo "Compression Method: " . zip_entry_compressionmethod($zip_entry) . "\n";

        if (zip_entry_open($zip, $zip_entry, "r")) {
            echo "File Contents:\n";
            $buf = zip_entry_read($zip_entry, zip_entry_filesize($zip_entry));
            echo "$buf\n";

            zip_entry_close($zip_entry);
        }
        echo "\n";

    }

    zip_close($zip);

}
?>


ZipArchive 类

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

简介

一个用 Zip 压缩的文件存档。

类摘要

ZipArchive {
/* 属性 */
/* 方法 */
public addEmptyDir ( string $dirname , int $flags = 0 ) : bool
public addFile ( string $filepath , string $entryname = "" , int $start = 0 , int $length = 0 , int $flags = ZipArchive::FL_OVERWRITE ) : bool
public addFromString ( string $name , string $content , int $flags = ZipArchive::FL_OVERWRITE ) : bool
public addGlob ( string $pattern , int $flags = 0 , array $options = [] ) : array|false
public addPattern ( string $pattern , string $path = "." , array $options = [] ) : array|false
public close ( ) : bool
public count ( ) : int
public deleteIndex ( int $index ) : bool
public deleteName ( string $name ) : bool
extractTo ( string $destination , mixed $entries = ? ) : bool
public getArchiveComment ( int $flags = 0 ) : string|false
public getCommentIndex ( int $index , int $flags = 0 ) : string|false
public getCommentName ( string $name , int $flags = 0 ) : string|false
public GetExternalAttributesIndex ( int $index , int &$opsys , int &$attr , int $flags = ? ) : bool
public getExternalAttributesName ( string $name , int &$opsys , int &$attr , int $flags = 0 ) : bool
public getFromIndex ( int $index , int $len = 0 , int $flags = 0 ) : string|false
public getFromName ( string $name , int $len = 0 , int $flags = 0 ) : string|false
public getNameIndex ( int $index , int $flags = 0 ) : string|false
public getStatusString ( ) : string
public getStream ( string $name ) : resource|false
public static isCompressionMethodSupported ( int $method , bool $enc = true ) : bool
public static isEncryptionMethodSupported ( int $method , bool $enc = true ) : bool
public locateName ( string $name , int $flags = 0 ) : int|false
public open ( string $filename , int $flags = 0 ) : bool|int
public registerCancelCallback ( callable $callback ) : bool
public registerProgressCallback ( float $rate , callable $callback ) : bool
public renameIndex ( int $index , string $new_name ) : bool
public renameName ( string $name , string $new_name ) : bool
public replaceFile ( string $filepath , string $index , int $start = 0 , int $length = 0 , int $flags = 0 ) : bool
public setArchiveComment ( string $comment ) : bool
public setCommentIndex ( int $index , string $comment ) : bool
public setCommentName ( string $name , string $comment ) : bool
public setCompressionIndex ( int $index , int $method , int $compflags = 0 ) : bool
public setCompressionName ( string $name , int $method , int $compflags = 0 ) : bool
public setEncryptionIndex ( int $index , int $method , string|null $password = null ) : bool
public setEncryptionName ( string $name , int $method , string|null $password = null ) : bool
public setExternalAttributesIndex ( int $index , int $opsys , int $attr , int $flags = 0 ) : bool
public setExternalAttributesName ( string $name , int $opsys , int $attr , int $flags = 0 ) : bool
public setMtimeIndex ( int $index , int $timestamp , int $flags = 0 ) : bool|null
public setMtimeName ( string $name , int $timestamp , int $flags = 0 ) : bool|null
public setPassword ( string $password ) : bool
public statIndex ( int $index , int $flags = 0 ) : array|false
public statName ( string $name , int $flags = 0 ) : array|false
public unchangeAll ( ) : bool
public unchangeArchive ( ) : bool
public unchangeIndex ( int $index ) : bool
public unchangeName ( string $name ) : bool
}

属性

status

Zip Archive 的状态

statusSys

Zip Archive 的系统状态

numFiles

压缩包里的文件数

filename

在文件系统里的文件名

comment

压缩包的注释

Table of Contents

  • ZipArchive::addEmptyDir — Add a new directory
  • ZipArchive::addFile — Adds a file to a ZIP archive from the given path
  • ZipArchive::addFromString — Add a file to a ZIP archive using its contents
  • ZipArchive::addGlob — Add files from a directory by glob pattern
  • ZipArchive::addPattern — Add files from a directory by PCRE pattern
  • ZipArchive::close — Close the active archive (opened or newly created)
  • ZipArchive::count — Counts the number of files in the archive
  • ZipArchive::deleteIndex — Delete an entry in the archive using its index
  • ZipArchive::deleteName — Delete an entry in the archive using its name
  • ZipArchive::extractTo — 解压缩文件
  • ZipArchive::getArchiveComment — Returns the Zip archive comment
  • ZipArchive::getCommentIndex — Returns the comment of an entry using the entry index
  • ZipArchive::getCommentName — Returns the comment of an entry using the entry name
  • ZipArchive::getExternalAttributesIndex — Retrieve the external attributes of an entry defined by its index
  • ZipArchive::getExternalAttributesName — Retrieve the external attributes of an entry defined by its name
  • ZipArchive::getFromIndex — Returns the entry contents using its index
  • ZipArchive::getFromName — Returns the entry contents using its name
  • ZipArchive::getNameIndex — Returns the name of an entry using its index
  • ZipArchive::getStatusString — Returns the status error message, system and/or zip messages
  • ZipArchive::getStream — Get a file handler to the entry defined by its name (read only)
  • ZipArchive::isCompressionMethodSupported — Check if a compression method is supported by libzip
  • ZipArchive::isEncryptionMethodSupported — Check if a encryption method is supported by libzip
  • ZipArchive::locateName — Returns the index of the entry in the archive
  • ZipArchive::open — Open a ZIP file archive
  • ZipArchive::registerCancelCallback — Register a callback to allow cancellation during archive close.
  • ZipArchive::registerProgressCallback — Register a callback to provide updates during archive close.
  • ZipArchive::renameIndex — Renames an entry defined by its index
  • ZipArchive::renameName — Renames an entry defined by its name
  • ZipArchive::replaceFile — Replace file in ZIP archive with a given path
  • ZipArchive::setArchiveComment — Set the comment of a ZIP archive
  • ZipArchive::setCommentIndex — Set the comment of an entry defined by its index
  • ZipArchive::setCommentName — Set the comment of an entry defined by its name
  • ZipArchive::setCompressionIndex — Set the compression method of an entry defined by its index
  • ZipArchive::setCompressionName — Set the compression method of an entry defined by its name
  • ZipArchive::setEncryptionIndex — Set the encryption method of an entry defined by its index
  • ZipArchive::setEncryptionName — Set the encryption method of an entry defined by its name
  • ZipArchive::setExternalAttributesIndex — Set the external attributes of an entry defined by its index
  • ZipArchive::setExternalAttributesName — Set the external attributes of an entry defined by its name
  • ZipArchive::setMtimeIndex — Set the modification time of an entry defined by its index
  • ZipArchive::setMtimeName — Set the modification time of an entry defined by its name
  • ZipArchive::setPassword — Set the password for the active archive
  • ZipArchive::statIndex — Get the details of an entry defined by its index
  • ZipArchive::statName — Get the details of an entry defined by its name
  • ZipArchive::unchangeAll — Undo all changes done in the archive
  • ZipArchive::unchangeArchive — Revert all global changes done in the archive
  • ZipArchive::unchangeIndex — Revert all changes done to an entry at the given index
  • ZipArchive::unchangeName — Revert all changes done to an entry with the given name


Add a new directory

  • ? ZipArchive
  • ZipArchive::addFile ?
  • PHP Manual
  • ZipArchive
  • Add a new directory

ZipArchive::addEmptyDir

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.8.0)

ZipArchive::addEmptyDir — Add a new directory

说明

public ZipArchive::addEmptyDir ( string $dirname , int $flags = 0 ) : bool

Adds an empty directory in the archive.

参数

dirname

The directory to add.

flags

Bitmask consisting of ZipArchive::FL_ENC_GUESS, ZipArchive::FL_ENC_UTF_8, ZipArchive::FL_ENC_CP437. The behaviour of these constants is described on the ZIP constants page.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 / 1.18.0 | flags was added.

范例

Example #1 Create a new directory in an archive

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    if($zip->addEmptyDir('newDirectory')) {
        echo 'Created a new root directory';
    } else {
        echo 'Could not create the directory';
    }
    $zip->close();
} else {
    echo 'failed';
}
?>


Adds a file to a ZIP archive from the given path

  • ? ZipArchive::addEmptyDir
  • ZipArchive::addFromString ?
  • PHP Manual
  • ZipArchive
  • Adds a file to a ZIP archive from the given path

ZipArchive::addFile

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::addFile — Adds a file to a ZIP archive from the given path

说明

public ZipArchive::addFile ( string $filepath , string $entryname = "" , int $start = 0 , int $length = 0 , int $flags = ZipArchive::FL_OVERWRITE ) : bool

Adds a file to a ZIP archive from a given path.

Note: 为了最大限度地提高代码可移植性，建议在 ZIP 文件名中使用斜线 (/) 做为目录分隔符。

参数

filepath

The path to the file to add.

entryname

If supplied and not empty, this is the local name inside the ZIP archive that will override the filepath.

start

For partial copy, start position.

length

For partial copy, length to be copied, if 0 or -1 the whole file (starting from start) is used.

flags

Bitmask consisting of ZipArchive::FL_OVERWRITE, ZipArchive::FL_ENC_GUESS, ZipArchive::FL_ENC_UTF_8, ZipArchive::FL_ENC_CP437. The behaviour of these constants is described on the ZIP constants page.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 / 1.18.0 | flags was added.

范例

This example opens a ZIP file archive test.zip and add the file /path/to/index.txt. as newname.txt.

Example #1 Open and add

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->addFile('/path/to/index.txt', 'newname.txt');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

注释

Note:

When a file is set to be added to the archive, PHP will lock the file. The lock is only released once the ZipArchive object has been closed, either via ZipArchive::close() or the ZipArchive object being destroyed. This may prevent you from being able to delete the file being added until after the lock has been released.

参见

  • ZipArchive::replaceFile() - Replace file in ZIP archive with a given path


Add a file to a ZIP archive using its contents

  • ? ZipArchive::addFile
  • ZipArchive::addGlob ?
  • PHP Manual
  • ZipArchive
  • Add a file to a ZIP archive using its contents

ZipArchive::addFromString

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::addFromString — Add a file to a ZIP archive using its contents

说明

public ZipArchive::addFromString ( string $name , string $content , int $flags = ZipArchive::FL_OVERWRITE ) : bool

Add a file to a ZIP archive using its contents.

Note: 为了最大限度地提高代码可移植性，建议在 ZIP 文件名中使用斜线 (/) 做为目录分隔符。

参数

name

The name of the entry to create.

content

The contents to use to create the entry. It is used in a binary safe mode.

flags

Bitmask consisting of ZipArchive::FL_OVERWRITE, ZipArchive::FL_ENC_GUESS, ZipArchive::FL_ENC_UTF_8, ZipArchive::FL_ENC_CP437. The behaviour of these constants is described on the ZIP constants page.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 / 1.18.0 | flags was added.

范例

Example #1 Add an entry to a new archive

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'file content goes here');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Example #2 Add file to a directory inside an archive

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->addFromString('dir/test.txt', 'file content goes here');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Add files from a directory by glob pattern

  • ? ZipArchive::addFromString
  • ZipArchive::addPattern ?
  • PHP Manual
  • ZipArchive
  • Add files from a directory by glob pattern

ZipArchive::addGlob

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL zip >= 1.9.0)

ZipArchive::addGlob — Add files from a directory by glob pattern

说明

public ZipArchive::addGlob ( string $pattern , int $flags = 0 , array $options = [] ) : array|false

Add files from a directory which match the glob pattern.

Note: 为了最大限度地提高代码可移植性，建议在 ZIP 文件名中使用斜线 (/) 做为目录分隔符。

参数

pattern

A glob() pattern against which files will be matched.

flags

A bit mask of glob() flags.

options

An associative array of options. Available options are:

  • "add_path"

    Prefix to prepend when translating to the local path of the file within the archive. This is applied after any remove operations defined by the "remove_path" or "remove_all_path" options.

  • "remove_path"

    Prefix to remove from matching file paths before adding to the archive.

  • "remove_all_path"

    true to use the file name only and add to the root of the archive.

  • "flags"

    Bitmask consisting of ZipArchive::FL_OVERWRITE, ZipArchive::FL_ENC_GUESS, ZipArchive::FL_ENC_UTF_8, ZipArchive::FL_ENC_CP437. The behaviour of these constants is described on the ZIP constants page.

  • "comp_method"

    Compression method, one of the ZipArchive::CM_* constants, see ZIP constants page.

  • "comp_flags"

    Compression level.

  • "enc_method"

    Encryption method, one of the ZipArchive::EM_* constants, see ZIP constants page.

  • "enc_password"

    Password used for encryption.

返回值

An array of added files on success 或者在失败时返回 false

更新日志

版本 | 说明
8.0.0 / 1.18.0 | "flags" in options was added.
8.0.0 / 1.18.1 | "comp_method", "comp_flags", "enc_method" and "enc_password" in options were added.

范例

Example #1 ZipArchive::addGlob() example

Add all php scripts and text files from current working directory

<?php
$zip = new ZipArchive();
$ret = $zip->open('application.zip', ZipArchive::CREATE | ZipArchive::OVERWRITE);
if ($ret !== TRUE) {
    printf('Failed with code %d', $ret);
} else {
    $options = array('add_path' => 'sources/', 'remove_all_path' => TRUE);
    $zip->addGlob('*.{php,txt}', GLOB_BRACE, $options);
    $zip->close();
}
?>

参见

  • ZipArchive::addFile() - Adds a file to a ZIP archive from the given path
  • ZipArchive::addPattern() - Add files from a directory by PCRE pattern


Add files from a directory by PCRE pattern

  • ? ZipArchive::addGlob
  • ZipArchive::close ?
  • PHP Manual
  • ZipArchive
  • Add files from a directory by PCRE pattern

ZipArchive::addPattern

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL zip >= 1.9.0)

ZipArchive::addPattern — Add files from a directory by PCRE pattern

说明

public ZipArchive::addPattern ( string $pattern , string $path = "." , array $options = [] ) : array|false

Add files from a directory which match the regular expression pattern. The operation is not recursive. The pattern will be matched against the file name only.

参数

pattern

A PCRE pattern against which files will be matched.

path

The directory that will be scanned. Defaults to the current working directory.

options

An associative array of options accepted by ZipArchive::addGlob().

返回值

An array of added files on success 或者在失败时返回 false

范例

Example #1 ZipArchive::addPattern() example

Add all php scripts and text files from current directory

<?php
$zip = new ZipArchive();
$ret = $zip->open('application.zip', ZipArchive::CREATE | ZipArchive::OVERWRITE);
if ($ret !== TRUE) {
    printf('Failed with code %d', $ret);
} else {
    $directory = realpath('.');
    $options = array('add_path' => 'sources/', 'remove_path' => $directory);
    $zip->addPattern('/\.(?:php|txt)$/', $directory, $options);
    $zip->close();
}
?>

参见

  • ZipArchive::addFile() - Adds a file to a ZIP archive from the given path
  • ZipArchive::addGlob() - Add files from a directory by glob pattern


Close the active archive (opened or newly created)

  • ? ZipArchive::addPattern
  • ZipArchive::count ?
  • PHP Manual
  • ZipArchive
  • Close the active archive (opened or newly created)

ZipArchive::close

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::close — Close the active archive (opened or newly created)

说明

public ZipArchive::close ( ) : bool

Close opened or created archive and save changes. This method is automatically called at the end of the script.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Counts the number of files in the archive

  • ? ZipArchive::close
  • ZipArchive::deleteIndex ?
  • PHP Manual
  • ZipArchive
  • Counts the number of files in the archive

ZipArchive::count

(PHP 7 >= 7.2.0, PHP 8, PECL zip >= 1.15.0)

ZipArchive::count — Counts the number of files in the archive

说明

public ZipArchive::count ( ) : int

参数

此函数没有参数。

返回值

Returns the number of files in the archive.


Delete an entry in the archive using its index

  • ? ZipArchive::count
  • ZipArchive::deleteName ?
  • PHP Manual
  • ZipArchive
  • Delete an entry in the archive using its index

ZipArchive::deleteIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::deleteIndex — Delete an entry in the archive using its index

说明

public ZipArchive::deleteIndex ( int $index ) : bool

Delete an entry in the archive using its index.

参数

index

Index of the entry to delete.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Delete file from archive using its index

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->deleteIndex(2);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Delete an entry in the archive using its name

  • ? ZipArchive::deleteIndex
  • ZipArchive::extractTo ?
  • PHP Manual
  • ZipArchive
  • Delete an entry in the archive using its name

ZipArchive::deleteName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::deleteName — Delete an entry in the archive using its name

说明

public ZipArchive::deleteName ( string $name ) : bool

Delete an entry in the archive using its name.

参数

name

Name of the entry to delete.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Deleting a file and directory from an archive, using names

<?php
$zip = new ZipArchive;
if ($zip->open('test1.zip') === TRUE) {
    $zip->deleteName('testfromfile.php');
    $zip->deleteName('testDir/');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


解压缩文件

  • ? ZipArchive::deleteName
  • ZipArchive::getArchiveComment ?
  • PHP Manual
  • ZipArchive
  • 解压缩文件

ZipArchive::extractTo

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::extractTo — 解压缩文件

说明

ZipArchive::extractTo ( string $destination , mixed $entries = ? ) : bool

将压缩文件解压缩到指定的目录

参数

destination

解压缩的本地目标路径

entries

解压缩的文件。它接受一个单独的文件名或一个文件名数组。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Extract all entries

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->extractTo('/my/destination/dir/');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Example #2 Extract two entries

<?php
$zip = new ZipArchive;
$res = $zip->open('test_im.zip');
if ($res === TRUE) {
    $zip->extractTo('/my/destination/dir/', array('pear_item.gif', 'testfromfile.php'));
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Returns the Zip archive comment

  • ? ZipArchive::extractTo
  • ZipArchive::getCommentIndex ?
  • PHP Manual
  • ZipArchive
  • Returns the Zip archive comment

ZipArchive::getArchiveComment

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::getArchiveComment — Returns the Zip archive comment

说明

public ZipArchive::getArchiveComment ( int $flags = 0 ) : string|false

Returns the Zip archive comment.

参数

flags

If flags is set to ZipArchive::FL_UNCHANGED, the original unchanged comment is returned.

返回值

Returns the Zip archive comment 或者在失败时返回 false.

范例

Example #1 Dump an archive comment

<?php
$zip = new ZipArchive;
$res = $zip->open('test_with_comment.zip');
if ($res === TRUE) {
    var_dump($zip->getArchiveComment());
    /* Or using the archive property */
    var_dump($zip->comment);
} else {
    echo 'failed, code:' . $res;
}
?>


Returns the comment of an entry using the entry index

  • ? ZipArchive::getArchiveComment
  • ZipArchive::getCommentName ?
  • PHP Manual
  • ZipArchive
  • Returns the comment of an entry using the entry index

ZipArchive::getCommentIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::getCommentIndex — Returns the comment of an entry using the entry index

说明

public ZipArchive::getCommentIndex ( int $index , int $flags = 0 ) : string|false

Returns the comment of an entry using the entry index.

参数

index

Index of the entry

flags

If flags is set to ZipArchive::FL_UNCHANGED, the original unchanged comment is returned.

返回值

Returns the comment on success 或者在失败时返回 false.

范例

Example #1 Dump an entry comment

<?php
$zip = new ZipArchive;
$res = $zip->open('test1.zip');
if ($res === TRUE) {
    var_dump($zip->getCommentIndex(1));
} else {
    echo 'failed, code:' . $res;
}
?>


Returns the comment of an entry using the entry name

  • ? ZipArchive::getCommentIndex
  • ZipArchive::getExternalAttributesIndex ?
  • PHP Manual
  • ZipArchive
  • Returns the comment of an entry using the entry name

ZipArchive::getCommentName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::getCommentName — Returns the comment of an entry using the entry name

说明

public ZipArchive::getCommentName ( string $name , int $flags = 0 ) : string|false

Returns the comment of an entry using the entry name.

参数

name

Name of the entry

flags

If flags is set to ZipArchive::FL_UNCHANGED, the original unchanged comment is returned.

返回值

Returns the comment on success 或者在失败时返回 false.

范例

Example #1 Dump an entry comment

<?php
$zip = new ZipArchive;
$res = $zip->open('test1.zip');
if ($res === TRUE) {
    var_dump($zip->getCommentName('test/entry1.txt'));
} else {
    echo 'failed, code:' . $res;
}
?>


Retrieve the external attributes of an entry defined by its index

  • ? ZipArchive::getCommentName
  • ZipArchive::getExternalAttributesName ?
  • PHP Manual
  • ZipArchive
  • Retrieve the external attributes of an entry defined by its index

ZipArchive::getExternalAttributesIndex

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::getExternalAttributesIndex — Retrieve the external attributes of an entry defined by its index

说明

public ZipArchive::GetExternalAttributesIndex ( int $index , int &$opsys , int &$attr , int $flags = ? ) : bool

Retrieve the external attributes of an entry defined by its index.

参数

index

Index of the entry.

opsys

On success, receive the operating system code defined by one of the ZipArchive::OPSYS_ constants.

attr

On success, receive the external attributes. Value depends on operating system.

flags

If flags is set to ZipArchive::FL_UNCHANGED, the original unchanged attributes are returned.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

This example extract all the entries of a ZIP archive test.zip and set the Unix rights from external attributes.

Example #1 Extract all entries with Unix rights

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip') === TRUE) {
    for ($idx=0 ; $s = $zip->statIndex($idx) ; $idx++) {
        if ($zip->extractTo('.', $s['name'])) {
            if ($zip->getExternalAttributesIndex($idx, $opsys, $attr)
                && $opsys==ZipArchive::OPSYS_UNIX) {
               chmod($s['name'], ($attr >> 16) & 0777);
            }
        }
    }
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>


Retrieve the external attributes of an entry defined by its name

  • ? ZipArchive::getExternalAttributesIndex
  • ZipArchive::getFromIndex ?
  • PHP Manual
  • ZipArchive
  • Retrieve the external attributes of an entry defined by its name

ZipArchive::getExternalAttributesName

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::getExternalAttributesName — Retrieve the external attributes of an entry defined by its name

说明

public ZipArchive::getExternalAttributesName ( string $name , int &$opsys , int &$attr , int $flags = 0 ) : bool

Retrieve the external attributes of an entry defined by its name.

参数

name

Name of the entry.

opsys

On success, receive the operating system code defined by one of the ZipArchive::OPSYS_ constants.

attr

On success, receive the external attributes. Value depends on operating system.

flags

If flags is set to ZipArchive::FL_UNCHANGED, the original unchanged attributes are returned.

返回值

成功时返回 true， 或者在失败时返回 false。


Returns the entry contents using its index

  • ? ZipArchive::getExternalAttributesName
  • ZipArchive::getFromName ?
  • PHP Manual
  • ZipArchive
  • Returns the entry contents using its index

ZipArchive::getFromIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::getFromIndex — Returns the entry contents using its index

说明

public ZipArchive::getFromIndex ( int $index , int $len = 0 , int $flags = 0 ) : string|false

Returns the entry contents using its index.

参数

index

Index of the entry

len

The length to be read from the entry. If 0, then the entire entry is read.

flags

The flags to use to open the archive. the following values may be ORed to it.

  • ZipArchive::FL_UNCHANGED

  • ZipArchive::FL_COMPRESSED

返回值

Returns the contents of the entry on success 或者在失败时返回 false.

范例

Example #1 Get the file contents

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    echo $zip->getFromIndex(2);
    $zip->close();
} else {
    echo 'failed';
}
?>

参见

  • ZipArchive::getFromName() - Returns the entry contents using its name


Returns the entry contents using its name

  • ? ZipArchive::getFromIndex
  • ZipArchive::getNameIndex ?
  • PHP Manual
  • ZipArchive
  • Returns the entry contents using its name

ZipArchive::getFromName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::getFromName — Returns the entry contents using its name

说明

public ZipArchive::getFromName ( string $name , int $len = 0 , int $flags = 0 ) : string|false

Returns the entry contents using its name.

参数

name

Name of the entry

len

The length to be read from the entry. If 0, then the entire entry is read.

flags

The flags to use to find the entry. The following values may be ORed.

  • ZipArchive::FL_UNCHANGED

  • ZipArchive::FL_COMPRESSED

  • ZipArchive::FL_NOCASE

返回值

Returns the contents of the entry on success 或者在失败时返回 false.

范例

Example #1 Get the file contents

<?php
$zip = new ZipArchive;
if ($zip->open('test1.zip') === TRUE) {
    echo $zip->getFromName('testfromfile.php');
    $zip->close();
} else {
    echo 'failed';
}
?>

Example #2 Convert an image from a zip entry

<?php
$z = new ZipArchive();
if ($z->open(dirname(__FILE__) . '/test_im.zip')) {
    $im_string = $z->getFromName("pear_item.gif");
    $im = imagecreatefromstring($im_string);
    imagepng($im, 'b.png');
}
?>

参见

  • ZipArchive::getFromIndex() - Returns the entry contents using its index


Returns the name of an entry using its index

  • ? ZipArchive::getFromName
  • ZipArchive::getStatusString ?
  • PHP Manual
  • ZipArchive
  • Returns the name of an entry using its index

ZipArchive::getNameIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::getNameIndex — Returns the name of an entry using its index

说明

public ZipArchive::getNameIndex ( int $index , int $flags = 0 ) : string|false

Returns the name of an entry using its index.

参数

index

Index of the entry.

flags

If flags is set to ZipArchive::FL_UNCHANGED, the original unchanged name is returned.

返回值

Returns the name on success 或者在失败时返回 false.

范例

Example #1 ZipArchive::getNameIndex() example

<?php
if ($zip->open('test.zip') == TRUE) {
 for ($i = 0; $i < $zip->numFiles; $i++) {
     $filename = $zip->getNameIndex($i);
     // ...
 }
}
?>


Returns the status error message, system and/or zip messages

  • ? ZipArchive::getNameIndex
  • ZipArchive::getStream ?
  • PHP Manual
  • ZipArchive
  • Returns the status error message, system and/or zip messages

ZipArchive::getStatusString

(PHP 5 >= 5.2.7, PHP 7, PHP 8)

ZipArchive::getStatusString — Returns the status error message, system and/or zip messages

说明

public ZipArchive::getStatusString ( ) : string

Returns the status error message, system and/or zip messages.

参数

此函数没有参数。

返回值

Returns a string with the status message.

更新日志

版本 | 说明
8.0.0 / 1.18.0 | This method can be called on closed archive.
8.0.0 / 1.18.0 | This method no longer returns false on failure.


Get a file handler to the entry defined by its name (read only)

  • ? ZipArchive::getStatusString
  • ZipArchive::isCompressionMethodSupported ?
  • PHP Manual
  • ZipArchive
  • Get a file handler to the entry defined by its name (read only)

ZipArchive::getStream

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::getStream — Get a file handler to the entry defined by its name (read only)

说明

public ZipArchive::getStream ( string $name ) : resource|false

Get a file handler to the entry defined by its name. For now it only supports read operations.

参数

name

The name of the entry to use.

返回值

Returns a file pointer (resource) on success 或者在失败时返回 false.

范例

Example #1 Get the entry contents with fread() and store it

<?php
$contents = '';
$z = new ZipArchive();
if ($z->open('test.zip')) {
    $fp = $z->getStream('test');
    if(!$fp) exit("failed\n");

    while (!feof($fp)) {
        $contents .= fread($fp, 2);
    }

    fclose($fp);
    file_put_contents('t',$contents);
    echo "done.\n";
}
?>

Example #2 Same as the previous example but with fopen() and the zip stream wrapper

<?php
$contents = '';
$fp = fopen('zip://' . dirname(__FILE__) . '/test.zip#test', 'r');
if (!$fp) {
    exit("cannot open\n");
}
while (!feof($fp)) {
    $contents .= fread($fp, 2);
}
echo "$contents\n";
fclose($fp);
echo "done.\n";
?>

Example #3 Stream wrapper and image, can be used with the xml function as well

<?php
$im = imagecreatefromgif('zip://' . dirname(__FILE__) . '/test_im.zip#pear_item.gif');
imagepng($im, 'a.png');
?>


Check if a compression method is supported by libzip

  • ? ZipArchive::getStream
  • ZipArchive::isEncryptionMethodSupported ?
  • PHP Manual
  • ZipArchive
  • Check if a compression method is supported by libzip

ZipArchive::isCompressionMethodSupported

(PHP >= 8.0.0, PECL zip >= 1.19.0)

ZipArchive::isCompressionMethodSupported — Check if a compression method is supported by libzip

说明

public static ZipArchive::isCompressionMethodSupported ( int $method , bool $enc = true ) : bool

Check if a compression method is supported by libzip.

参数

method

The compression method, one of the ZipArchive::CM_* constants.

enc

If true check for compression, else check for decompression.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function is only available if built against libzip ≥ 1.7.0.

参见

  • ZipArchive::setCompressionIndex() - Set the compression method of an entry defined by its index
  • ZipArchive::setCompressionName() - Set the compression method of an entry defined by its name


Check if a encryption method is supported by libzip

  • ? ZipArchive::isCompressionMethodSupported
  • ZipArchive::locateName ?
  • PHP Manual
  • ZipArchive
  • Check if a encryption method is supported by libzip

ZipArchive::isEncryptionMethodSupported

(PHP >= 8.0.0, PECL zip >= 1.19.0)

ZipArchive::isEncryptionMethodSupported — Check if a encryption method is supported by libzip

说明

public static ZipArchive::isEncryptionMethodSupported ( int $method , bool $enc = true ) : bool

Check if a compression method is supported by libzip.

参数

method

The encryption method, one of the ZipArchive::EM_* constants.

enc

If true check for encryption, else check for decryption.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function is only available if built against libzip ≥ 1.7.0.

参见

  • ZipArchive::setEncryptionIndex() - Set the encryption method of an entry defined by its index
  • ZipArchive::setEncryptionName() - Set the encryption method of an entry defined by its name


Returns the index of the entry in the archive

  • ? ZipArchive::isEncryptionMethodSupported
  • ZipArchive::open ?
  • PHP Manual
  • ZipArchive
  • Returns the index of the entry in the archive

ZipArchive::locateName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::locateName — Returns the index of the entry in the archive

说明

public ZipArchive::locateName ( string $name , int $flags = 0 ) : int|false

Locates an entry using its name.

参数

name

The name of the entry to look up

flags

The flags are specified by ORing the following values, or 0 for none of them.

  • ZipArchive::FL_NOCASE

  • ZipArchive::FL_NODIR

返回值

Returns the index of the entry on success 或者在失败时返回 false.

范例

Example #1 Create an archive and then use it with ZipArchive::locateName()

<?php
$file = 'testlocate.zip';

$zip = new ZipArchive;
if ($zip->open($file, ZipArchive::CREATE) !== TRUE) {
    exit('failed');
}

$zip->addFromString('entry1.txt', 'entry #1');
$zip->addFromString('entry2.txt', 'entry #2');
$zip->addFromString('dir/entry2d.txt', 'entry #2');

if ($zip->status !== ZipArchive::ER_OK) {
    echo "failed to write zip\n";
}
$zip->close();

if ($zip->open($file) !== TRUE) {
    exit('failed');
}

echo $zip->locateName('entry1.txt') . "\n";
echo $zip->locateName('eNtry2.txt') . "\n";
echo $zip->locateName('eNtry2.txt', ZipArchive::FL_NOCASE) . "\n";
echo $zip->locateName('enTRy2d.txt', ZipArchive::FL_NOCASE|ZipArchive::FL_NODIR) . "\n";
$zip->close();

?>

以上例程会输出：

0

1
2


Open a ZIP file archive

  • ? ZipArchive::locateName
  • ZipArchive::registerCancelCallback ?
  • PHP Manual
  • ZipArchive
  • Open a ZIP file archive

ZipArchive::open

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::open — Open a ZIP file archive

说明

public ZipArchive::open ( string $filename , int $flags = 0 ) : bool|int

Opens a new or existing zip archive for reading, writing or modifying.

Since libzip 1.6.0, a empty file is not a valid archive any longer.

参数

filename

The file name of the ZIP archive to open.

flags

The mode to use to open the archive.

  • ZipArchive::OVERWRITE

  • ZipArchive::CREATE

  • ZipArchive::RDONLY

  • ZipArchive::EXCL

  • ZipArchive::CHECKCONS

返回值

Returns true on success, or one of the following error codes:

ZipArchive::ER_EXISTS
File already exists.
ZipArchive::ER_INCONS
Zip archive inconsistent.
ZipArchive::ER_INVAL
Invalid argument.
ZipArchive::ER_MEMORY
Malloc failure.
ZipArchive::ER_NOENT
No such file.
ZipArchive::ER_NOZIP
Not a zip archive.
ZipArchive::ER_OPEN
Can't open file.
ZipArchive::ER_READ
Read error.
ZipArchive::ER_SEEK
Seek error.

范例

Example #1 Open and extract

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    echo 'ok';
    $zip->extractTo('test');
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>

Example #2 Create an archive

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'file content goes here');
    $zip->addFile('data.txt', 'entryname.txt');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Example #3 Create an temporary archive

<?php
$name = tempnam(sys_get_temp_dir(), "FOO");
$zip = new ZipArchive;
$res = $zip->open($name, ZipArchive::OVERWRITE); /* truncate as empty file is not valid */
if ($res === TRUE) {
    $zip->addFile('data.txt', 'entryname.txt');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Register a callback to allow cancellation during archive close.

  • ? ZipArchive::open
  • ZipArchive::registerProgressCallback ?
  • PHP Manual
  • ZipArchive
  • Register a callback to allow cancellation during archive close.

ZipArchive::registerCancelCallback

(PHP >= 8.0.0, PECL zip >= 1.17.0)

ZipArchive::registerCancelCallback — Register a callback to allow cancellation during archive close.

说明

public ZipArchive::registerCancelCallback ( callable $callback ) : bool

Register a callback function to allow cancellation during archive close.

参数

callback

If this function return 0 operation will continue, other value it will be cancelled.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function is only available if built against libzip ≥ 1.6.0.

范例

This example creates a ZIP file archive php.zip and cancel operation on some run condition.

Example #1 Archive a file

<?php
$zip = new ZipArchive();
if ($zip->open('php.zip', ZipArchive::CREATE | ZipArchive::OVERWRITE)) {
    $zip->addFile(PHP_BINARY, 'php');
    $zip->registerCancelCallback(function () {
        return ($someruncondition ? -1 : 0);
    });
    $zip->close();
}

参见

  • ZipArchive::registerProgressCallback() - Register a callback to provide updates during archive close.


Register a callback to provide updates during archive close.

  • ? ZipArchive::registerCancelCallback
  • ZipArchive::renameIndex ?
  • PHP Manual
  • ZipArchive
  • Register a callback to provide updates during archive close.

ZipArchive::registerProgressCallback

(PHP >= 8.0.0, PECL zip >= 1.17.0)

ZipArchive::registerProgressCallback — Register a callback to provide updates during archive close.

说明

public ZipArchive::registerProgressCallback ( float $rate , callable $callback ) : bool

Register a callback function to provide updates during archive close.

参数

rate

Change between each call of the callback (from 0.0 to 1.0).

callback

This function will receive the current state as a float (from 0.0 to 1.0).

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function is only available if built against libzip ≥ 1.3.0.

范例

This example creates a ZIP file archive php.zip and show progression.

Example #1 Archive a file

$zip = new ZipArchive();
if ($zip->open('php.zip', ZipArchive::CREATE | ZipArchive::OVERWRITE)) {
    $zip->addFile(PHP_BINARY, 'php');
    $zip->registerProgressCallback(0.05, function ($r) {
        printf("%d%%\n", $r * 100);
    });
    $zip->close();
}

参见

  • ZipArchive::registerCancelCallback() - Register a callback to allow cancellation during archive close.


Renames an entry defined by its index

  • ? ZipArchive::registerProgressCallback
  • ZipArchive::renameName ?
  • PHP Manual
  • ZipArchive
  • Renames an entry defined by its index

ZipArchive::renameIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::renameIndex — Renames an entry defined by its index

说明

public ZipArchive::renameIndex ( int $index , string $new_name ) : bool

Renames an entry defined by its index.

参数

index

Index of the entry to rename.

new_name

New name.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Rename one entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->renameIndex(2,'newname.txt');
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>


Renames an entry defined by its name

  • ? ZipArchive::renameIndex
  • ZipArchive::replaceFile ?
  • PHP Manual
  • ZipArchive
  • Renames an entry defined by its name

ZipArchive::renameName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::renameName — Renames an entry defined by its name

说明

public ZipArchive::renameName ( string $name , string $new_name ) : bool

Renames an entry defined by its name.

参数

name

Name of the entry to rename.

new_name

New name.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Rename one entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->renameName('currentname.txt','newname.txt');
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>


Replace file in ZIP archive with a given path

  • ? ZipArchive::renameName
  • ZipArchive::setArchiveComment ?
  • PHP Manual
  • ZipArchive
  • Replace file in ZIP archive with a given path

ZipArchive::replaceFile

(PHP >= 8.0.0, PECL zip >= 1.18.0)

ZipArchive::replaceFile — Replace file in ZIP archive with a given path

说明

public ZipArchive::replaceFile ( string $filepath , string $index , int $start = 0 , int $length = 0 , int $flags = 0 ) : bool

Replace file in ZIP archive with a given path.

Note: 为了最大限度地提高代码可移植性，建议在 ZIP 文件名中使用斜线 (/) 做为目录分隔符。

参数

filepath

The path to the file to add.

index

The index of the file to be replaced, its name is unchanged.

start

For partial copy, start position.

length

For partial copy, length to be copied, if 0 or -1 the whole file (starting from start) is used.

flags

Bitmask consisting of ZipArchive::FL_ENC_GUESS, ZipArchive::FL_ENC_UTF_8, ZipArchive::FL_ENC_CP437. The behaviour of these constants is described on the ZIP constants page.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

This example opens a ZIP file archive test.zip and replaces index 1 entry with /path/to/index.txt.

Example #1 Open and replace

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->replaceFile('/path/to/index.txt', 1);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

参见

  • ZipArchive::addFile() - Adds a file to a ZIP archive from the given path


Set the comment of a ZIP archive

  • ? ZipArchive::replaceFile
  • ZipArchive::setCommentIndex ?
  • PHP Manual
  • ZipArchive
  • Set the comment of a ZIP archive

ZipArchive::setArchiveComment

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::setArchiveComment — Set the comment of a ZIP archive

说明

public ZipArchive::setArchiveComment ( string $comment ) : bool

Set the comment of a ZIP archive.

参数

comment

The contents of the comment.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Create an archive and set a comment

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'file content goes here');
    $zip->setArchiveComment('new archive comment');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Set the comment of an entry defined by its index

  • ? ZipArchive::setArchiveComment
  • ZipArchive::setCommentName ?
  • PHP Manual
  • ZipArchive
  • Set the comment of an entry defined by its index

ZipArchive::setCommentIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::setCommentIndex — Set the comment of an entry defined by its index

说明

public ZipArchive::setCommentIndex ( int $index , string $comment ) : bool

Set the comment of an entry defined by its index.

参数

index

Index of the entry.

comment

The contents of the comment.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Open an archive and set a comment for an entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->setCommentIndex(2, 'new entry comment');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Set the comment of an entry defined by its name

  • ? ZipArchive::setCommentIndex
  • ZipArchive::setCompressionIndex ?
  • PHP Manual
  • ZipArchive
  • Set the comment of an entry defined by its name

ZipArchive::setCommentName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.4.0)

ZipArchive::setCommentName — Set the comment of an entry defined by its name

说明

public ZipArchive::setCommentName ( string $name , string $comment ) : bool

Set the comment of an entry defined by its name.

参数

name

Name of the entry.

comment

The contents of the comment.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Open an archive and set a comment for an entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->setCommentName('entry1.txt', 'new entry comment');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Set the compression method of an entry defined by its index

  • ? ZipArchive::setCommentName
  • ZipArchive::setCompressionName ?
  • PHP Manual
  • ZipArchive
  • Set the compression method of an entry defined by its index

ZipArchive::setCompressionIndex

(PHP 7, PHP 8, PECL zip >= 1.13.0)

ZipArchive::setCompressionIndex — Set the compression method of an entry defined by its index

说明

public ZipArchive::setCompressionIndex ( int $index , int $method , int $compflags = 0 ) : bool

Set the compression method of an entry defined by its index.

参数

index

Index of the entry.

method

The compression method, one of the ZipArchive::CM_* constants.

compflags

Compression level.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Add files with different compression methods to an archive

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('foo', 'Some text');
    $zip->addFromString('bar', 'Some other text');
    $zip->setCompressionIndex(0, ZipArchive::CM_STORE);
    $zip->setCompressionIndex(1, ZipArchive::CM_DEFLATE);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Set the compression method of an entry defined by its name

  • ? ZipArchive::setCompressionIndex
  • ZipArchive::setEncryptionIndex ?
  • PHP Manual
  • ZipArchive
  • Set the compression method of an entry defined by its name

ZipArchive::setCompressionName

(PHP 7, PHP 8, PECL zip >= 1.13.0)

ZipArchive::setCompressionName — Set the compression method of an entry defined by its name

说明

public ZipArchive::setCompressionName ( string $name , int $method , int $compflags = 0 ) : bool

Set the compression method of an entry defined by its name.

参数

name

Name of the entry.

method

The compression method, one of the ZipArchive::CM_* constants.

compflags

Compression level.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Add files with different compression methods to an archive

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('foo', 'Some text');
    $zip->addFromString('bar', 'Some other text');
    $zip->setCompressionName('foo', ZipArchive::CM_STORE);
    $zip->setCompressionName('bar', ZipArchive::CM_DEFLATE);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Example #2 Add file and set compression method

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFile('foo.jpg', 'bar.jpg');
    $zip->setCompressionName('bar.jpg', ZipArchive::CM_XZ);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>


Set the encryption method of an entry defined by its index

  • ? ZipArchive::setCompressionName
  • ZipArchive::setEncryptionName ?
  • PHP Manual
  • ZipArchive
  • Set the encryption method of an entry defined by its index

ZipArchive::setEncryptionIndex

(PHP >= 7.2.0, PHP 8, PECL zip >= 1.14.0)

ZipArchive::setEncryptionIndex — Set the encryption method of an entry defined by its index

说明

public ZipArchive::setEncryptionIndex ( int $index , int $method , string|null $password = null ) : bool

Set the encryption method of an entry defined by its index.

参数

index

Index of the entry.

method

The encryption method defined by one of the ZipArchive::EM_ constants.

password

Optional password, default used when missing.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function is only available if built against libzip ≥ 1.2.0.

更新日志

版本 | 说明
8.0.0 | password is now nullable.

参见

  • ZipArchive::setPassword() - Set the password for the active archive
  • ZipArchive::setEncryptionName() - Set the encryption method of an entry defined by its name


Set the encryption method of an entry defined by its name

  • ? ZipArchive::setEncryptionIndex
  • ZipArchive::setExternalAttributesIndex ?
  • PHP Manual
  • ZipArchive
  • Set the encryption method of an entry defined by its name

ZipArchive::setEncryptionName

(PHP >= 7.2.0, PHP 8, PECL zip >= 1.14.0)

ZipArchive::setEncryptionName — Set the encryption method of an entry defined by its name

说明

public ZipArchive::setEncryptionName ( string $name , int $method , string|null $password = null ) : bool

Set the encryption method of an entry defined by its name.

参数

name

Name of the entry.

method

The encryption method defined by one of the ZipArchive::EM_ constants.

password

Optional password, default used when missing.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | password is now nullable.

范例

This example creates a ZIP file archive test.zip and add the file test.txt encrypted using the AES 256 method.

Example #1 Archive and encrypt a file

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->setPassword('secret');
    $zip->addFile('text.txt');
    $zip->setEncryptionName('text.txt', ZipArchive::EM_AES_256);
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>

注释

Note:

This function is only available if built against libzip ≥ 1.2.0.

参见

  • ZipArchive::setPassword() - Set the password for the active archive
  • ZipArchive::setEncryptionIndex() - Set the encryption method of an entry defined by its index


Set the external attributes of an entry defined by its index

  • ? ZipArchive::setEncryptionName
  • ZipArchive::setExternalAttributesName ?
  • PHP Manual
  • ZipArchive
  • Set the external attributes of an entry defined by its index

ZipArchive::setExternalAttributesIndex

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::setExternalAttributesIndex — Set the external attributes of an entry defined by its index

说明

public ZipArchive::setExternalAttributesIndex ( int $index , int $opsys , int $attr , int $flags = 0 ) : bool

Set the external attributes of an entry defined by its index.

参数

index

Index of the entry.

opsys

The operating system code defined by one of the ZipArchive::OPSYS_ constants.

attr

The external attributes. Value depends on operating system.

flags

Optional flags. Currently unused.

返回值

成功时返回 true， 或者在失败时返回 false。


Set the external attributes of an entry defined by its name

  • ? ZipArchive::setExternalAttributesIndex
  • ZipArchive::setMtimeIndex ?
  • PHP Manual
  • ZipArchive
  • Set the external attributes of an entry defined by its name

ZipArchive::setExternalAttributesName

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::setExternalAttributesName — Set the external attributes of an entry defined by its name

说明

public ZipArchive::setExternalAttributesName ( string $name , int $opsys , int $attr , int $flags = 0 ) : bool

Set the external attributes of an entry defined by its name.

参数

name

Name of the entry.

opsys

The operating system code defined by one of the ZipArchive::OPSYS_ constants.

attr

The external attributes. Value depends on operating system.

flags

Optional flags. Currently unused.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

This example opens a ZIP file archive test.zip and add the file test.txt with its Unix rights as external attributes.

Example #1 Archive a file, with its Unix rights

<?php
$zip = new ZipArchive();
$stat = stat($filename='test.txt');
if (is_array($stat) && $zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->addFile($filename);
    $zip->setExternalAttributesName($filename, ZipArchive::OPSYS_UNIX, $stat['mode'] << 16);
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>


Set the modification time of an entry defined by its index

  • ? ZipArchive::setExternalAttributesName
  • ZipArchive::setMtimeName ?
  • PHP Manual
  • ZipArchive
  • Set the modification time of an entry defined by its index

ZipArchive::setMtimeIndex

(PHP >= 8.0.0, PECL zip >= 1.16.0)

ZipArchive::setMtimeIndex — Set the modification time of an entry defined by its index

说明

public ZipArchive::setMtimeIndex ( int $index , int $timestamp , int $flags = 0 ) : bool|null

Set the modification time of an entry defined by its index.

参数

index

Index of the entry.

timestamp

The modification time (unix timestamp) of the file.

flags

Optional flags, unused for now.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

This example creates a ZIP file archive test.zip and add the file test.txt with its modification date.

Example #1 Archive a file

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->addFile('text.txt');
    $zip->setMtimeIndex(0, mktime(0,0,0,12,25,2019));
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>

注释

Note:

This function is only available if built against libzip ≥ 1.0.0.

参见

  • ZipArchive::setMtimeName() - Set the modification time of an entry defined by its name


Set the modification time of an entry defined by its name

  • ? ZipArchive::setMtimeIndex
  • ZipArchive::setPassword ?
  • PHP Manual
  • ZipArchive
  • Set the modification time of an entry defined by its name

ZipArchive::setMtimeName

(PHP >= 8.0.0, PECL zip >= 1.16.0)

ZipArchive::setMtimeName — Set the modification time of an entry defined by its name

说明

public ZipArchive::setMtimeName ( string $name , int $timestamp , int $flags = 0 ) : bool|null

Set the modification time of an entry defined by its name.

参数

name

Name of the entry.

timestamp

The modification time (unix timestamp) of the file.

flags

Optional flags, unused for now.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

This example creates a ZIP file archive test.zip and add the file test.txt with its modification date.

Example #1 Archive a file

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->addFile('text.txt');
    $zip->setMtimeName('text.txt', mktime(0,0,0,12,25,2019));
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>

注释

Note:

This function is only available if built against libzip ≥ 1.0.0.

参见

  • ZipArchive::setMtimeIndex() - Set the modification time of an entry defined by its index


Set the password for the active archive

  • ? ZipArchive::setMtimeName
  • ZipArchive::statIndex ?
  • PHP Manual
  • ZipArchive
  • Set the password for the active archive

ZipArchive::setPassword

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL zip >= 1.12.4)

ZipArchive::setPassword — Set the password for the active archive

说明

public ZipArchive::setPassword ( string $password ) : bool

Sets the password for the active archive.

参数

password

The password to be used for the archive.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

As of PHP 7.2.0 and libzip 1.2.0 the password is used to decompress the archive, and is also the default password for ZipArchive::setEncryptionName() and ZipArchive::setEncryptionIndex(). Formerly, this function only set the password to be used to decompress the archive; it did not turn a non-password-protected ZipArchive into a password-protected ZipArchive.

参见

  • ZipArchive::setEncryptionIndex() - Set the encryption method of an entry defined by its index
  • ZipArchive::setEncryptionName() - Set the encryption method of an entry defined by its name


Get the details of an entry defined by its index

  • ? ZipArchive::setPassword
  • ZipArchive::statName ?
  • PHP Manual
  • ZipArchive
  • Get the details of an entry defined by its index

ZipArchive::statIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::statIndex — Get the details of an entry defined by its index

说明

public ZipArchive::statIndex ( int $index , int $flags = 0 ) : array|false

The function obtains information about the entry defined by its index.

参数

index

Index of the entry

flags

ZipArchive::FL_UNCHANGED may be ORed to it to request information about the original file in the archive, ignoring any changes made.

返回值

Returns an array containing the entry details 或者在失败时返回 false.

范例

Example #1 Dump the stat info of an entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    print_r($zip->statIndex(3));
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>

以上例程的输出类似于：

Array
(
    [name] => foobar/baz
    [index] => 3
    [crc] => 499465816
    [size] => 27
    [mtime] => 1123164748
    [comp_size] => 24
    [comp_method] => 8
)


Get the details of an entry defined by its name

  • ? ZipArchive::statIndex
  • ZipArchive::unchangeAll ?
  • PHP Manual
  • ZipArchive
  • Get the details of an entry defined by its name

ZipArchive::statName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::statName — Get the details of an entry defined by its name

说明

public ZipArchive::statName ( string $name , int $flags = 0 ) : array|false

The function obtains information about the entry defined by its name.

参数

name

Name of the entry

flags

The flags argument specifies how the name lookup should be done. Also, ZipArchive::FL_UNCHANGED may be ORed to it to request information about the original file in the archive, ignoring any changes made.

  • ZipArchive::FL_NOCASE

  • ZipArchive::FL_NODIR

  • ZipArchive::FL_UNCHANGED

返回值

Returns an array containing the entry details 或者在失败时返回 false.

范例

Example #1 Dump the stat info of an entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    print_r($zip->statName('foobar/baz'));
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>

以上例程的输出类似于：

Array
(
    [name] => foobar/baz
    [index] => 3
    [crc] => 499465816
    [size] => 27
    [mtime] => 1123164748
    [comp_size] => 24
    [comp_method] => 8
)


Undo all changes done in the archive

  • ? ZipArchive::statName
  • ZipArchive::unchangeArchive ?
  • PHP Manual
  • ZipArchive
  • Undo all changes done in the archive

ZipArchive::unchangeAll

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::unchangeAll — Undo all changes done in the archive

说明

public ZipArchive::unchangeAll ( ) : bool

Undo all changes done in the archive.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Revert all global changes done in the archive

  • ? ZipArchive::unchangeAll
  • ZipArchive::unchangeIndex ?
  • PHP Manual
  • ZipArchive
  • Revert all global changes done in the archive

ZipArchive::unchangeArchive

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::unchangeArchive — Revert all global changes done in the archive

说明

public ZipArchive::unchangeArchive ( ) : bool

Revert all global changes to the archive. For now, this only reverts archive comment changes.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Revert all changes done to an entry at the given index

  • ? ZipArchive::unchangeArchive
  • ZipArchive::unchangeName ?
  • PHP Manual
  • ZipArchive
  • Revert all changes done to an entry at the given index

ZipArchive::unchangeIndex

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.1.0)

ZipArchive::unchangeIndex — Revert all changes done to an entry at the given index

说明

public ZipArchive::unchangeIndex ( int $index ) : bool

Revert all changes done to an entry at the given index.

参数

index

Index of the entry.

返回值

成功时返回 true， 或者在失败时返回 false。


Revert all changes done to an entry with the given name

  • ? ZipArchive::unchangeIndex
  • Zip 函数 ?
  • PHP Manual
  • ZipArchive
  • Revert all changes done to an entry with the given name

ZipArchive::unchangeName

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.5.0)

ZipArchive::unchangeName — Revert all changes done to an entry with the given name

说明

public ZipArchive::unchangeName ( string $name ) : bool

Revert all changes done to an entry.

参数

name

Name of the entry.

返回值

成功时返回 true， 或者在失败时返回 false。


Zip 函数

Table of Contents

  • zip_close — 关闭一个ZIP档案文件
  • zip_entry_close — 关闭目录项
  • zip_entry_compressedsize — 检索目录项压缩过后的大小
  • zip_entry_compressionmethod — 检索目录实体的压缩方法
  • zip_entry_filesize — 检索目录实体的实际大小
  • zip_entry_name — 检索目录项的名称
  • zip_entry_open — 打开用于读取的目录实体
  • zip_entry_read — 读取一个打开了的压缩目录实体
  • zip_open — 打开ZIP存档文件
  • zip_read — 读取ZIP存档文件中下一项


关闭一个ZIP档案文件

  • ? Zip 函数
  • zip_entry_close ?
  • PHP Manual
  • Zip 函数
  • 关闭一个ZIP档案文件

zip_close

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_close — 关闭一个ZIP档案文件

说明

zip_close ( resource $zip ) : void

关闭一个指定的ZIP档案文件。

参数

zip

一个由zip_open()打开的ZIP文件资源。

返回值

没有返回值。

参见

  • zip_open() - 打开ZIP存档文件
  • zip_read() - 读取ZIP存档文件中下一项


关闭目录项

  • ? zip_close
  • zip_entry_compressedsize ?
  • PHP Manual
  • Zip 函数
  • 关闭目录项

zip_entry_close

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_close — 关闭目录项

说明

zip_entry_close ( resource $zip_entry ) : bool

关闭指定的目录项。

参数

zip_entry

一个由zip_entry_open()打开的项目。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • zip_entry_open() - 打开用于读取的目录实体
  • zip_entry_read() - 读取一个打开了的压缩目录实体


检索目录项压缩过后的大小

  • ? zip_entry_close
  • zip_entry_compressionmethod ?
  • PHP Manual
  • Zip 函数
  • 检索目录项压缩过后的大小

zip_entry_compressedsize

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_compressedsize — 检索目录项压缩过后的大小

说明

zip_entry_compressedsize ( resource $zip_entry ) : int

返回指定目录项压缩过后的大小。

参数

zip_entry

由函数zip_read() 返回的目录项。

返回值

压缩后的大小。

参见

  • zip_open() - 打开ZIP存档文件
  • zip_read() - 读取ZIP存档文件中下一项


检索目录实体的压缩方法

  • ? zip_entry_compressedsize
  • zip_entry_filesize ?
  • PHP Manual
  • Zip 函数
  • 检索目录实体的压缩方法

zip_entry_compressionmethod

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_compressionmethod — 检索目录实体的压缩方法

说明

zip_entry_compressionmethod ( resource $zip_entry ) : string

返回由函数zip_entry确定的目录实体的压缩方法。

参数

zip_entry

由函数zip_read() 返回的目录实体。

返回值

压缩方法。

参见

  • zip_open() - 打开ZIP存档文件
  • zip_read() - 读取ZIP存档文件中下一项


检索目录实体的实际大小

  • ? zip_entry_compressionmethod
  • zip_entry_name ?
  • PHP Manual
  • Zip 函数
  • 检索目录实体的实际大小

zip_entry_filesize

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_filesize — 检索目录实体的实际大小

说明

zip_entry_filesize ( resource $zip_entry ) : int

返回指定目录实体的实际大小。

参数

zip_entry

由函数zip_read() 返回的目录实体。

返回值

返回该目录实体的大小。

参见

  • zip_open() - 打开ZIP存档文件
  • zip_read() - 读取ZIP存档文件中下一项


检索目录项的名称

  • ? zip_entry_filesize
  • zip_entry_open ?
  • PHP Manual
  • Zip 函数
  • 检索目录项的名称

zip_entry_name

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_name — 检索目录项的名称

说明

zip_entry_name ( resource $zip_entry ) : string

返回指定目录项的名称。

参数

zip_entry

由函数zip_read() 返回的目录项。

返回值

目录项的名称。

参见

  • zip_open() - 打开ZIP存档文件
  • zip_read() - 读取ZIP存档文件中下一项


打开用于读取的目录实体

  • ? zip_entry_name
  • zip_entry_read ?
  • PHP Manual
  • Zip 函数
  • 打开用于读取的目录实体

zip_entry_open

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_open — 打开用于读取的目录实体

说明

zip_entry_open ( resource $zip , resource $zip_entry , string $mode = ? ) : bool

打开ZIP文件中的目录实体以便后续读取。

参数

zip

由函数zip_open()返回的有效的资源句柄。

zip_entry

由函数zip_read()返回的目录实体。

mode

任何在fopen()处理文档中指定的模式。

Note:

由于ZIP在PHP中只支持读取模式，所以mode 实际上总是被设置为"rb"(其他模式会被忽略)。

返回值

成功时返回 true， 或者在失败时返回 false。

Note:

与fopen()和其他类似的方法不同，zip_entry_open() 的返回值只用于标示该操作结果，不需要读取或关闭该目录实体。

参见

  • zip_entry_close() - 关闭目录项
  • zip_entry_read() - 读取一个打开了的压缩目录实体


读取一个打开了的压缩目录实体

  • ? zip_entry_open
  • zip_open ?
  • PHP Manual
  • Zip 函数
  • 读取一个打开了的压缩目录实体

zip_entry_read

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_entry_read — 读取一个打开了的压缩目录实体

说明

zip_entry_read ( resource $zip_entry , int $length = 1024 ) : string

读取一个打开了的压缩目录实体。

参数

zip_entry

由函数zip_read() 返回的目录实体。

length

需要返回的字节数。

Note:

这字节数应该是你所要读取的未压缩的字节数。

返回值

成功的时候返回读取到的数据；到达文件末尾的时候返回一个空的字符串； 读取出错的时候则会返回false

参见

  • zip_entry_open() - 打开用于读取的目录实体
  • zip_entry_close() - 关闭目录项
  • zip_entry_filesize() - 检索目录实体的实际大小


打开ZIP存档文件

  • ? zip_entry_read
  • zip_read ?
  • PHP Manual
  • Zip 函数
  • 打开ZIP存档文件

zip_open

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_open — 打开ZIP存档文件

说明

zip_open ( string $filename ) : resource

打开一个新的ZIP归档文件进行读取。

参数

filename

待打开ZIP归档的文件名。

返回值

成功的时候返回一个资源句柄供函数zip_read() 和 zip_close()后续使用; 如果filename 文件不存在或者出现其他错误，则会返回相应的错误码。

参见

  • zip_read() - 读取ZIP存档文件中下一项
  • zip_close() - 关闭一个ZIP档案文件


读取ZIP存档文件中下一项

  • ? zip_open
  • Zlib ?
  • PHP Manual
  • Zip 函数
  • 读取ZIP存档文件中下一项

zip_read

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL zip >= 1.0.0)

zip_read — 读取ZIP存档文件中下一项

说明

zip_read ( resource $zip ) : resource

读取ZIP存档文件中下一项。

参数

zip

一个ZIP压缩文件,该ZIP归档文件之前应由函数 zip_open() 打开。

返回值

成功的时候返回该当前实体资源供zip_entry_... 系列函数后续使用; 如果没有更多的读取项，则会返回 false 如果遇到错误则会返回相应的错误码。

参见

  • zip_open() - 打开ZIP存档文件
  • zip_close() - 关闭一个ZIP档案文件
  • zip_entry_open() - 打开用于读取的目录实体
  • zip_entry_read() - 读取一个打开了的压缩目录实体


Zlib Compression

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Zlib 函数
    • deflate_add — Incrementally deflate data
    • deflate_init — Initialize an incremental deflate context
    • gzclose — Close an open gz-file pointer
    • gzcompress — Compress a string
    • gzdecode — Decodes a gzip compressed string
    • gzdeflate — Deflate a string
    • gzencode — Create a gzip compressed string
    • gzeof — Test for EOF on a gz-file pointer
    • gzfile — Read entire gz-file into an array
    • gzgetc — Get character from gz-file pointer
    • gzgets — Get line from file pointer
    • gzgetss — Get line from gz-file pointer and strip HTML tags
    • gzinflate — Inflate a deflated string
    • gzopen — Open gz-file
    • gzpassthru — Output all remaining data on a gz-file pointer
    • gzputs — 别名 gzwrite
    • gzread — Binary-safe gz-file read
    • gzrewind — Rewind the position of a gz-file pointer
    • gzseek — Seek on a gz-file pointer
    • gztell — Tell gz-file pointer read/write position
    • gzuncompress — Uncompress a compressed string
    • gzwrite — Binary-safe gz-file write
    • inflate_add — Incrementally inflate encoded data
    • inflate_get_read_len — Get number of bytes read so far
    • inflate_get_status — Get decompression status
    • inflate_init — Initialize an incremental inflate context
    • readgzfile — Output a gz-file
    • zlib_decode — Uncompress any raw/gzip/zlib encoded data
    • zlib_encode — Compress data with the specified encoding
    • zlib_get_coding_type — Returns the coding type used for output compression
  • DeflateContext — The DeflateContext class
  • InflateContext — The InflateContext class


简介

This module enables you to transparently read and write gzip (.gz) compressed files, through versions of most of the filesystem functions which work with gzip-compressed files (and uncompressed files, too, but not with sockets).

Note:

Version 4.0.4 introduced a fopen-wrapper for .gz-files, so that you can use a special zlib: URL to access compressed files transparently using the normal f*() file access functions if you prefix the filename or path with zlib: when calling fopen(). This feature requires a C runtime library that provides the fopencookie() function. Up to now the GNU libc seems to be the only library that provides this feature.

In PHP 4.3.0, zlib: has been changed to compress.zlib:// to prevent ambiguities with filenames containing ':' characters. The fopencookie() function is no longer required. More information is available in the section about zlib://.


需求

This module uses the functions of » zlib by Jean-loup Gailly and Mark Adler. You have to use a zlib version >= 1.0.9 with this module. As of PHP 5.4.0 you have to use zlib >= 1.2.0.4.


安装

Zlib support in PHP is not enabled by default. You will need to configure PHP --with-zlib[=DIR]

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

The zlib extension offers the option to transparently compress your pages on-the-fly, if the requesting browser supports this. Therefore there are three options in the configuration file php.ini.

Zlib Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
zlib.output_compression | "0" | PHP_INI_ALL |
zlib.output_compression_level | "-1" | PHP_INI_ALL |
zlib.output_handler | "" | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

zlib.output_compression bool/int

Whether to transparently compress pages. If this option is set to "On" in php.ini or the Apache configuration, pages are compressed if the browser sends an "Accept-Encoding: gzip" or "deflate" header. "Content-Encoding: gzip" (respectively "deflate") and "Vary: Accept-Encoding" headers are added to the output. In runtime, it can be set only before sending any output.

This option also accepts integer values instead of boolean "On"/"Off", using this you can set the output buffer size (default is 4KB).

Note:

output_handler must be empty if this is set 'On' ! Instead you must use zlib.output_handler.

zlib.output_compression_level int

Compression level used for transparent output compression. Specify a value between 0 (no compression) to 9 (most compression). The default value, -1, lets the server decide which level to use.

zlib.output_handler string

You cannot specify additional output handlers if zlib.output_compression is activated here. This setting does the same as output_handler but in a different order.


资源类型

This extension defines a file pointer resource returned by gzopen(). Prior to PHP 8.0.0, zlib.deflate and zlib.inflate resources were also defined.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

FORCE_GZIP (int)
FORCE_DEFLATE (int)
ZLIB_ENCODING_RAW (int)
DEFLATE algorithm as per RFC 1951. Available as of PHP 7.0.0.
ZLIB_ENCODING_DEFLATE (int)
ZLIB compression algorithm as per RFC 1950. Available as of PHP 7.0.0.
ZLIB_ENCODING_GZIP (int)
GZIP algorithm as per RFC 1952. Available as of PHP 7.0.0.
ZLIB_FILTERED (int)
Available as of PHP 7.0.0.
ZLIB_HUFFMAN_ONLY (int)
Available as of PHP 7.0.0.
ZLIB_FIXED (int)
Available as of PHP 7.0.0.
ZLIB_RLE (int)
Available as of PHP 7.0.0.
ZLIB_DEFAULT_STRATEGY (int)
Available as of PHP 7.0.0.
ZLIB_BLOCK (int)
Available as of PHP 7.0.0.
ZLIB_NO_FLUSH (int)
Available as of PHP 7.0.0.
ZLIB_PARTIAL_FLUSH (int)
Available as of PHP 7.0.0.
ZLIB_SYNC_FLUSH (int)
Available as of PHP 7.0.0.
ZLIB_FULL_FLUSH (int)
Available as of PHP 7.0.0.
ZLIB_FINISH (int)
Available as of PHP 7.0.0.


范例

This example opens a temporary file and writes a test string to it, then it prints out the content of this file twice.

Example #1 Small Zlib Example

<?php

$filename = tempnam('/tmp', 'zlibtest') . '.gz';
echo "<html>\n<head></head>\n<body>\n<pre>\n";
$s = "Only a test, test, test, test, test, test, test, test!\n";

// open file for writing with maximum compression
$zp = gzopen($filename, "w9");

// write string to file
gzwrite($zp, $s);

// close file
gzclose($zp);

// open file for reading
$zp = gzopen($filename, "r");

// read 3 char
echo gzread($zp, 3);

// output until end of the file and close it.
gzpassthru($zp);
gzclose($zp);

echo "\n";

// open file and print content (the 2nd time).
if (readgzfile($filename) != strlen($s)) {
        echo "Error with zlib functions!";
}
unlink($filename);
echo "</pre>\n</body>\n</html>\n";

?>

Example #2 Working with the incremental compression and decompression API as of PHP 7.0.0

<?php
// Perform GZIP compression:
$deflateContext = deflate_init(ZLIB_ENCODING_GZIP);
$compressed = deflate_add($deflateContext, "Data to compress", ZLIB_NO_FLUSH);
$compressed .= deflate_add($deflateContext, ", more data", ZLIB_NO_FLUSH);
$compressed .= deflate_add($deflateContext, ", and even more data!", ZLIB_FINISH);

// Perform GZIP decompression:
$inflateContext = inflate_init(ZLIB_ENCODING_GZIP);
$uncompressed = inflate_add($inflateContext, $compressed, ZLIB_NO_FLUSH);
$uncompressed .= inflate_add($inflateContext, NULL, ZLIB_FINISH);
echo $uncompressed;
?>

以上例程会输出：

Data to compress, more data, and even more data!


Zlib 函数

Table of Contents

  • deflate_add — Incrementally deflate data
  • deflate_init — Initialize an incremental deflate context
  • gzclose — Close an open gz-file pointer
  • gzcompress — Compress a string
  • gzdecode — Decodes a gzip compressed string
  • gzdeflate — Deflate a string
  • gzencode — Create a gzip compressed string
  • gzeof — Test for EOF on a gz-file pointer
  • gzfile — Read entire gz-file into an array
  • gzgetc — Get character from gz-file pointer
  • gzgets — Get line from file pointer
  • gzgetss — Get line from gz-file pointer and strip HTML tags
  • gzinflate — Inflate a deflated string
  • gzopen — Open gz-file
  • gzpassthru — Output all remaining data on a gz-file pointer
  • gzputs — 别名 gzwrite
  • gzread — Binary-safe gz-file read
  • gzrewind — Rewind the position of a gz-file pointer
  • gzseek — Seek on a gz-file pointer
  • gztell — Tell gz-file pointer read/write position
  • gzuncompress — Uncompress a compressed string
  • gzwrite — Binary-safe gz-file write
  • inflate_add — Incrementally inflate encoded data
  • inflate_get_read_len — Get number of bytes read so far
  • inflate_get_status — Get decompression status
  • inflate_init — Initialize an incremental inflate context
  • readgzfile — Output a gz-file
  • zlib_decode — Uncompress any raw/gzip/zlib encoded data
  • zlib_encode — Compress data with the specified encoding
  • zlib_get_coding_type — Returns the coding type used for output compression


Incrementally deflate data

  • ? Zlib 函数
  • deflate_init ?
  • PHP Manual
  • Zlib 函数
  • Incrementally deflate data

deflate_add

(PHP 7, PHP 8)

deflate_add — Incrementally deflate data

说明

deflate_add ( DeflateContext $context , string $data , int $flush_mode = ZLIB_SYNC_FLUSH ) : string|false

Incrementally deflates data in the specified context.

参数

context

A context created with deflate_init().

data

A chunk of data to compress.

flush_mode

One of ZLIB_BLOCK, ZLIB_NO_FLUSH, ZLIB_PARTIAL_FLUSH, ZLIB_SYNC_FLUSH (default), ZLIB_FULL_FLUSH, ZLIB_FINISH. Normally you will want to set ZLIB_NO_FLUSH to maximize compression, and ZLIB_FINISH to terminate with the last chunk of data. See the » zlib manual for a detailed description of these constants.

返回值

Returns a chunk of compressed data, 或者在失败时返回 false.

错误／异常

If invalid arguments are given, an error of level E_WARNING is generated.

更新日志

版本 | 说明
8.0.0 | context expects a DeflateContext instance now; previously, a resource was expected.

参见

  • deflate_init() - Initialize an incremental deflate context


Initialize an incremental deflate context

  • ? deflate_add
  • gzclose ?
  • PHP Manual
  • Zlib 函数
  • Initialize an incremental deflate context

deflate_init

(PHP 7, PHP 8)

deflate_init — Initialize an incremental deflate context

说明

deflate_init ( int $encoding , array $options = [] ) : DeflateContext|false

Initializes an incremental deflate context using the specified encoding.

Note that the window option here only sets the window size of the algorithm, differently from the zlib filters where the same parameter also sets the encoding to use; the encoding must be set with the encoding parameter.

Limitation: there is currently no way to set the header information on a GZIP compressed stream, which are set as follows: GZIP signature (\x1f\x8B); compression method (\x08 == DEFLATE); 6 zero bytes; the operating system set to the current system (\x00 = Windows, \x03 = Unix, etc.)

参数

encoding

One of the ZLIB_ENCODING_* constants.

options

An associative array which may contain the following elements:

level

The compression level in range -1..9; defaults to -1.

memory

The compression memory level in range 1..9; defaults to 8.

window

The zlib window size (logarithmic) in range 8..15; defaults to 15. zlib changes a window size of 8 to 9, and as of zlib 1.2.8 fails with a warning, if a window size of 8 is requested for ZLIB_ENCODING_RAW or ZLIB_ENCODING_GZIP.

strategy

One of ZLIB_FILTERED, ZLIB_HUFFMAN_ONLY, ZLIB_RLE, ZLIB_FIXED or ZLIB_DEFAULT_STRATEGY (the default).

dictionary

A string or an array of strings of the preset dictionary (default: no preset dictionary).

返回值

Returns a deflate context resource (zlib.deflate) on success, 或者在失败时返回 false.

错误／异常

If an invalid option is passed to options or the context couldn't be created, an error of level E_WARNING is generated.

更新日志

版本 | 说明
8.0.0 | On success, this function returns a DeflateContext instance now; previously, a resource was returned.

参见

  • deflate_add() - Incrementally deflate data
  • inflate_init() - Initialize an incremental inflate context


Close an open gz-file pointer

  • ? deflate_init
  • gzcompress ?
  • PHP Manual
  • Zlib 函数
  • Close an open gz-file pointer

gzclose

(PHP 4, PHP 5, PHP 7, PHP 8)

gzclose — Close an open gz-file pointer

说明

gzclose ( resource $stream ) : bool

Closes the given gz-file pointer.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 gzclose() example

<?php
$gz = gzopen('somefile.gz','w9');
gzputs ($gz, 'I was added to somefile.gz');
gzclose($gz);
?>

参见

  • gzopen() - Open gz-file


Compress a string

  • ? gzclose
  • gzdecode ?
  • PHP Manual
  • Zlib 函数
  • Compress a string

gzcompress

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

gzcompress — Compress a string

说明

gzcompress ( string $data , int $level = -1 , int $encoding = ZLIB_ENCODING_DEFLATE ) : string|false

This function compresses the given string using the ZLIB data format.

For details on the ZLIB compression algorithm see the document "» ZLIB Compressed Data Format Specification version 3.3" (RFC 1950).

Note:

This is not the same as gzip compression, which includes some header data. See gzencode() for gzip compression.

参数

data

The data to compress.

level

The level of compression. Can be given as 0 for no compression up to 9 for maximum compression.

If -1 is used, the default compression of the zlib library is used which is 6.

encoding

One of ZLIB_ENCODING_* constants.

返回值

The compressed string or false if an error occurred.

范例

Example #1 gzcompress() example

<?php
$compressed = gzcompress('Compress me', 9);
echo $compressed;
?>

参见

  • gzdeflate() - Deflate a string
  • gzinflate() - Inflate a deflated string
  • gzuncompress() - Uncompress a compressed string
  • gzencode() - Create a gzip compressed string


Decodes a gzip compressed string

  • ? gzcompress
  • gzdeflate ?
  • PHP Manual
  • Zlib 函数
  • Decodes a gzip compressed string

gzdecode

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

gzdecode — Decodes a gzip compressed string

说明

gzdecode ( string $data , int $max_length = 0 ) : string|false

This function returns a decoded version of the input data.

参数

data

The data to decode, encoded by gzencode().

max_length

The maximum length of data to decode.

返回值

The decoded string, or false if an error occurred.

参见

  • gzencode() - Create a gzip compressed string


Deflate a string

  • ? gzdecode
  • gzencode ?
  • PHP Manual
  • Zlib 函数
  • Deflate a string

gzdeflate

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gzdeflate — Deflate a string

说明

gzdeflate ( string $data , int $level = -1 , int $encoding = ZLIB_ENCODING_RAW ) : string|false

This function compresses the given string using the DEFLATE data format.

For details on the DEFLATE compression algorithm see the document "» DEFLATE Compressed Data Format Specification version 1.3" (RFC 1951).

参数

data

The data to deflate.

level

The level of compression. Can be given as 0 for no compression up to 9 for maximum compression. If not given, the default compression level will be the default compression level of the zlib library.

encoding

One of ZLIB_ENCODING_* constants.

返回值

The deflated string or false if an error occurred.

范例

Example #1 gzdeflate() example

<?php
$compressed = gzdeflate('Compress me', 9);
echo $compressed;
?>

参见

  • gzinflate() - Inflate a deflated string
  • gzcompress() - Compress a string
  • gzuncompress() - Uncompress a compressed string
  • gzencode() - Create a gzip compressed string


Create a gzip compressed string

  • ? gzdeflate
  • gzeof ?
  • PHP Manual
  • Zlib 函数
  • Create a gzip compressed string

gzencode

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gzencode — Create a gzip compressed string

说明

gzencode ( string $data , int $level = -1 , int $encoding = ZLIB_ENCODING_GZIP ) : string|false

This function returns a compressed version of the input data compatible with the output of the gzip program.

For more information on the GZIP file format, see the document: » GZIP file format specification version 4.3 (RFC 1952).

参数

data

The data to encode.

level

The level of compression. Can be given as 0 for no compression up to 9 for maximum compression. If not given, the default compression level will be the default compression level of the zlib library.

encoding

The encoding mode. Can be FORCE_GZIP (the default) or FORCE_DEFLATE.

Prior to PHP 5.4.0, using FORCE_DEFLATE results in a standard zlib deflated string (inclusive zlib headers) after a gzip file header but without the trailing crc32 checksum.

In PHP 5.4.0 and later, FORCE_DEFLATE generates RFC 1950 compliant output, consisting of a zlib header, the deflated data, and an Adler checksum.

返回值

The encoded string, or false if an error occurred.

范例

The resulting data contains the appropriate headers and data structure to make a standard .gz file, e.g.:

Example #1 Creating a gzip file

<?php
$data = implode("", file("bigfile.txt"));
$gzdata = gzencode($data, 9);
$fp = fopen("bigfile.txt.gz", "w");
fwrite($fp, $gzdata);
fclose($fp);
?>

参见

  • gzdecode() - Decodes a gzip compressed string
  • gzdeflate() - Deflate a string
  • gzinflate() - Inflate a deflated string
  • gzuncompress() - Uncompress a compressed string
  • gzcompress() - Compress a string
  • » ZLIB Compressed Data Format Specification (RFC 1950)


Test for EOF on a gz-file pointer

  • ? gzencode
  • gzfile ?
  • PHP Manual
  • Zlib 函数
  • Test for EOF on a gz-file pointer

gzeof

(PHP 4, PHP 5, PHP 7, PHP 8)

gzeof — Test for EOF on a gz-file pointer

说明

gzeof ( resource $stream ) : bool

Tests the given GZ file pointer for EOF.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

返回值

Returns true if the gz-file pointer is at EOF or an error occurs; otherwise returns false.

范例

Example #1 gzeof() example

<?php
$gz = gzopen('somefile.gz', 'r');
while (!gzeof($gz)) {
  echo gzgetc($gz);
}
gzclose($gz);
?>


Read entire gz-file into an array

  • ? gzeof
  • gzgetc ?
  • PHP Manual
  • Zlib 函数
  • Read entire gz-file into an array

gzfile

(PHP 4, PHP 5, PHP 7, PHP 8)

gzfile — Read entire gz-file into an array

说明

gzfile ( string $filename , int $use_include_path = 0 ) : array|false

This function is identical to readgzfile(), except that it returns the file in an array.

参数

filename

The file name.

use_include_path

You can set this optional parameter to 1, if you want to search for the file in the include_path too.

返回值

An array containing the file, one line per cell, empty lines included, and with newlines still attached, 或者在失败时返回 false.

范例

Example #1 gzfile() example

<?php
$lines = gzfile('somefile.gz');
foreach ($lines as $line) {
    echo $line;
}
?>

参见

  • readgzfile() - Output a gz-file
  • gzopen() - Open gz-file


Get character from gz-file pointer

  • ? gzfile
  • gzgets ?
  • PHP Manual
  • Zlib 函数
  • Get character from gz-file pointer

gzgetc

(PHP 4, PHP 5, PHP 7, PHP 8)

gzgetc — Get character from gz-file pointer

说明

gzgetc ( resource $stream ) : string|false

Returns a string containing a single (uncompressed) character read from the given gz-file pointer.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

返回值

The uncompressed character or false on EOF (unlike gzeof()).

范例

Example #1 gzgetc() example

<?php
$gz = gzopen('somefile.gz', 'r');
while (!gzeof($gz)) {
  echo gzgetc($gz);
}
gzclose($gz);
?>

参见

  • gzopen() - Open gz-file
  • gzgets() - Get line from file pointer


Get line from file pointer

  • ? gzgetc
  • gzgetss ?
  • PHP Manual
  • Zlib 函数
  • Get line from file pointer

gzgets

(PHP 4, PHP 5, PHP 7, PHP 8)

gzgets — Get line from file pointer

说明

gzgets ( resource $stream , int|null $length = null ) : string|false

Gets a (uncompressed) string of up to length - 1 bytes read from the given file pointer. Reading ends when length - 1 bytes have been read, on a newline, or on EOF (whichever comes first).

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

length

The length of data to get.

返回值

The uncompressed string, or false on error.

更新日志

版本 | 说明
8.0.0 | length is nullable now; previously, the default was 1024.

范例

Example #1 gzgets() example

<?php
$handle = gzopen('somefile.gz', 'r');
while (!gzeof($handle)) {
   $buffer = gzgets($handle, 4096);
   echo $buffer;
}
gzclose($handle);
?>

参见

  • gzopen() - Open gz-file
  • gzgetc() - Get character from gz-file pointer
  • gzwrite() - Binary-safe gz-file write


Get line from gz-file pointer and strip HTML tags

  • ? gzgets
  • gzinflate ?
  • PHP Manual
  • Zlib 函数
  • Get line from gz-file pointer and strip HTML tags

gzgetss

(PHP 4, PHP 5, PHP 7)

gzgetss — Get line from gz-file pointer and strip HTML tags

Warning

This function has been DEPRECATED as of PHP 7.3.0, and REMOVED as of PHP 8.0.0. Relying on this function is highly discouraged.

说明

gzgetss ( resource $zp , int $length , string $allowable_tags = ? ) : string

Identical to gzgets(), except that gzgetss() attempts to strip any HTML and PHP tags from the text it reads.

参数

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

length

The length of data to get.

allowable_tags

You can use this optional parameter to specify tags which should not be stripped.

返回值

The uncompressed and stripped string, or false on error.

范例

Example #1 gzgetss() example

<?php
$handle = gzopen('somefile.gz', 'r');
while (!gzeof($handle)) {
   $buffer = gzgetss($handle, 4096);
   echo $buffer;
}
gzclose($handle);
?>

参见

  • gzopen() - Open gz-file
  • gzgets() - Get line from file pointer
  • strip_tags() - 从字符串中去除 HTML 和 PHP 标记


Inflate a deflated string

  • ? gzgetss
  • gzopen ?
  • PHP Manual
  • Zlib 函数
  • Inflate a deflated string

gzinflate

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gzinflate — Inflate a deflated string

说明

gzinflate ( string $data , int $max_length = 0 ) : string|false

This function inflates a deflated string.

参数

data

The data compressed by gzdeflate().

max_length

The maximum length of data to decode.

返回值

The original uncompressed data or false on error.

The function will return an error if the uncompressed data is more than 32768 times the length of the compressed input data or more than the optional parameter max_length.

范例

Example #1 gzinflate() example

<?php
$compressed   = gzdeflate('Compress me', 9);
$uncompressed = gzinflate($compressed);
echo $uncompressed;
?>

参见

  • gzdeflate() - Deflate a string
  • gzcompress() - Compress a string
  • gzuncompress() - Uncompress a compressed string
  • gzencode() - Create a gzip compressed string


Open gz-file

  • ? gzinflate
  • gzpassthru ?
  • PHP Manual
  • Zlib 函数
  • Open gz-file

gzopen

(PHP 4, PHP 5, PHP 7, PHP 8)

gzopen — Open gz-file

说明

gzopen ( string $filename , string $mode , int $use_include_path = 0 ) : resource|false

Opens a gzip (.gz) file for reading or writing.

gzopen() can be used to read a file which is not in gzip format; in this case gzread() will directly read from the file without decompression.

参数

filename

The file name.

mode

As in fopen() (rb or wb) but can also include a compression level (wb9) or a strategy: f for filtered data as in wb6f, h for Huffman only compression as in wb1h. (See the description of deflateInit2 in zlib.h for more information about the strategy parameter.)

use_include_path

You can set this optional parameter to 1, if you want to search for the file in the include_path too.

返回值

Returns a file pointer to the file opened, after that, everything you read from this file descriptor will be transparently decompressed and what you write gets compressed.

If the open fails, the function returns false.

范例

Example #1 gzopen() Example

<?php
$fp = gzopen("/tmp/file.gz", "r");
?>

参见

  • gzclose() - Close an open gz-file pointer


Output all remaining data on a gz-file pointer

  • ? gzopen
  • gzputs ?
  • PHP Manual
  • Zlib 函数
  • Output all remaining data on a gz-file pointer

gzpassthru

(PHP 4, PHP 5, PHP 7, PHP 8)

gzpassthru — Output all remaining data on a gz-file pointer

说明

gzpassthru ( resource $stream ) : int

Reads to EOF on the given gz-file pointer from the current position and writes the (uncompressed) results to standard output.

Note:

You may need to call gzrewind() to reset the file pointer to the beginning of the file if you have already written data to it.

Tip

If you just want to dump the contents of a file to the output buffer, without first modifying it or seeking to a particular offset, you may want to use the readgzfile() function, which saves you the gzopen() call.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

返回值

The number of uncompressed characters read from gz and passed through to the input, or false on error.

范例

Example #1 gzpassthru() example

<?php
$fp = gzopen('file.gz', 'r');
gzpassthru($fp);
gzclose($fp);
?>


别名 gzwrite

  • ? gzpassthru
  • gzread ?
  • PHP Manual
  • Zlib 函数
  • 别名 gzwrite

gzputs

(PHP 4, PHP 5, PHP 7, PHP 8)

gzputs — 别名 gzwrite()

说明

此函数是该函数的别名： gzwrite().


Binary-safe gz-file read

  • ? gzputs
  • gzrewind ?
  • PHP Manual
  • Zlib 函数
  • Binary-safe gz-file read

gzread

(PHP 4, PHP 5, PHP 7, PHP 8)

gzread — Binary-safe gz-file read

说明

gzread ( resource $stream , int $length ) : string|false

gzread() reads up to length bytes from the given gz-file pointer. Reading stops when length (uncompressed) bytes have been read or EOF is reached, whichever comes first.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

length

The number of bytes to read.

返回值

The data that have been read, 或者在失败时返回 false.

更新日志

版本 | 说明
7.4.0 | This functions returns false on failure now; previously 0 was returned.

范例

Example #1 gzread() example

<?php
// get contents of a gz-file into a string
$filename = "/usr/local/something.txt.gz";
$zd = gzopen($filename, "r");
$contents = gzread($zd, 10000);
gzclose($zd);
?>

参见

  • gzwrite() - Binary-safe gz-file write
  • gzopen() - Open gz-file
  • gzgets() - Get line from file pointer
  • gzgetss() - Get line from gz-file pointer and strip HTML tags
  • gzfile() - Read entire gz-file into an array
  • gzpassthru() - Output all remaining data on a gz-file pointer


Rewind the position of a gz-file pointer

  • ? gzread
  • gzseek ?
  • PHP Manual
  • Zlib 函数
  • Rewind the position of a gz-file pointer

gzrewind

(PHP 4, PHP 5, PHP 7, PHP 8)

gzrewind — Rewind the position of a gz-file pointer

说明

gzrewind ( resource $stream ) : bool

Sets the file position indicator of the given gz-file pointer to the beginning of the file stream.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • gzseek() - Seek on a gz-file pointer
  • gztell() - Tell gz-file pointer read/write position


Seek on a gz-file pointer

  • ? gzrewind
  • gztell ?
  • PHP Manual
  • Zlib 函数
  • Seek on a gz-file pointer

gzseek

(PHP 4, PHP 5, PHP 7, PHP 8)

gzseek — Seek on a gz-file pointer

说明

gzseek ( resource $stream , int $offset , int $whence = SEEK_SET ) : int

Sets the file position indicator for the given file pointer to the given offset byte into the file stream. Equivalent to calling (in C) gzseek(zp, offset, SEEK_SET).

If the file is opened for reading, this function is emulated but can be extremely slow. If the file is opened for writing, only forward seeks are supported; gzseek() then compresses a sequence of zeroes up to the new starting position.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

offset

The seeked offset.

whence

whence values are:

  • SEEK_SET - Set position equal to offset bytes.
  • SEEK_CUR - Set position to current location plus offset.

If whence is not specified, it is assumed to be SEEK_SET.

返回值

Upon success, returns 0; otherwise, returns -1. Note that seeking past EOF is not considered an error.

范例

Example #1 gzseek() example

<?php
$gz = gzopen('somefile.gz', 'r');
gzseek($gz,2);
echo gzgetc($gz);
gzclose($gz);
?>

参见

  • gztell() - Tell gz-file pointer read/write position
  • gzrewind() - Rewind the position of a gz-file pointer


Tell gz-file pointer read/write position

  • ? gzseek
  • gzuncompress ?
  • PHP Manual
  • Zlib 函数
  • Tell gz-file pointer read/write position

gztell

(PHP 4, PHP 5, PHP 7, PHP 8)

gztell — Tell gz-file pointer read/write position

说明

gztell ( resource $stream ) : int|false

Gets the position of the given file pointer; i.e., its offset into the uncompressed file stream.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

返回值

The position of the file pointer or false if an error occurs.

参见

  • gzopen() - Open gz-file
  • gzseek() - Seek on a gz-file pointer
  • gzrewind() - Rewind the position of a gz-file pointer


Uncompress a compressed string

  • ? gztell
  • gzwrite ?
  • PHP Manual
  • Zlib 函数
  • Uncompress a compressed string

gzuncompress

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

gzuncompress — Uncompress a compressed string

说明

gzuncompress ( string $data , int $max_length = 0 ) : string|false

This function uncompress a compressed string.

参数

data

The data compressed by gzcompress().

max_length

The maximum length of data to decode.

返回值

The original uncompressed data or false on error.

The function will return an error if the uncompressed data is more than 32768 times the length of the compressed input data or more than the optional parameter max_length.

范例

Example #1 gzuncompress() example

<?php
$compressed   = gzcompress('Compress me', 9);
$uncompressed = gzuncompress($compressed);
echo $uncompressed;
?>

参见

  • gzcompress() - Compress a string
  • gzinflate() - Inflate a deflated string
  • gzdeflate() - Deflate a string
  • gzencode() - Create a gzip compressed string


Binary-safe gz-file write

  • ? gzuncompress
  • inflate_add ?
  • PHP Manual
  • Zlib 函数
  • Binary-safe gz-file write

gzwrite

(PHP 4, PHP 5, PHP 7, PHP 8)

gzwrite — Binary-safe gz-file write

说明

gzwrite ( resource $stream , string $data , int|null $length = null ) : int|false

gzwrite() writes the contents of data to the given gz-file.

参数

stream

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

data

The string to write.

length

The number of uncompressed bytes to write. If supplied, writing will stop after length (uncompressed) bytes have been written or the end of data is reached, whichever comes first.

Note:

Note that if the length argument is given, then the magic_quotes_runtime configuration option will be ignored and no slashes will be stripped from data.

返回值

Returns the number of (uncompressed) bytes written to the given gz-file stream, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | length is nullable now; previously, the default was 0.
7.4.0 | This functions returns false on failure now; previously 0 was returned.

范例

Example #1 gzwrite() example

<?php
$string = 'Some information to compress';
$gz = gzopen('somefile.gz','w9');
gzwrite($gz, $string);
gzclose($gz);
?>

参见

  • gzread() - Binary-safe gz-file read
  • gzopen() - Open gz-file


Incrementally inflate encoded data

  • ? gzwrite
  • inflate_get_read_len ?
  • PHP Manual
  • Zlib 函数
  • Incrementally inflate encoded data

inflate_add

(PHP 7, PHP 8)

inflate_add — Incrementally inflate encoded data

说明

inflate_add ( InflateContext $context , string $data , int $flush_mode = ZLIB_SYNC_FLUSH ) : string|false

Incrementally inflates encoded data in the specified context.

Limitation: header information from GZIP compressed data are not made available.

参数

context

A context created with inflate_init().

data

A chunk of compressed data.

flush_mode

One of ZLIB_BLOCK, ZLIB_NO_FLUSH, ZLIB_PARTIAL_FLUSH, ZLIB_SYNC_FLUSH (default), ZLIB_FULL_FLUSH, ZLIB_FINISH. Normally you will want to set ZLIB_NO_FLUSH to maximize compression, and ZLIB_FINISH to terminate with the last chunk of data. See the » zlib manual for a detailed description of these constants.

返回值

Returns a chunk of uncompressed data, 或者在失败时返回 false.

错误／异常

If invalid parameters are given, inflating the data requires a preset dictionary, but none is specified, the compressed stream is corrupt or has an invalid checksum, an error of level E_WARNING is generated.

更新日志

版本 | 说明
8.0.0 | context expects an InflateContext instance now; previously, a resource was expected.

参见

  • inflate_init() - Initialize an incremental inflate context


Get number of bytes read so far

  • ? inflate_add
  • inflate_get_status ?
  • PHP Manual
  • Zlib 函数
  • Get number of bytes read so far

inflate_get_read_len

(PHP 7 >= 7.2.0, PHP 8)

inflate_get_read_len — Get number of bytes read so far

说明

inflate_get_read_len ( InflateContext $context ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

context

返回值

Returns number of bytes read so far 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | context expects an InflateContext instance now; previously, a resource was expected.


Get decompression status

  • ? inflate_get_read_len
  • inflate_init ?
  • PHP Manual
  • Zlib 函数
  • Get decompression status

inflate_get_status

(PHP 7 >= 7.2.0, PHP 8)

inflate_get_status — Get decompression status

说明

inflate_get_status ( InflateContext $context ) : int

Usually returns either ZLIB_OK or ZLIB_STREAM_END.

参数

context

返回值

Returns decompression status 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | context expects an InflateContext instance now; previously, a resource was expected.


Initialize an incremental inflate context

  • ? inflate_get_status
  • readgzfile ?
  • PHP Manual
  • Zlib 函数
  • Initialize an incremental inflate context

inflate_init

(PHP 7, PHP 8)

inflate_init — Initialize an incremental inflate context

说明

inflate_init ( int $encoding , array $options = [] ) : InflateContext|false

Initialize an incremental inflate context with the specified encoding.

参数

encoding

One of the ZLIB_ENCODING_* constants.

options

An associative array which may contain the following elements:

level

The compression level in range -1..9; defaults to -1.

memory

The compression memory level in range 1..9; defaults to 8.

window

The zlib window size (logarithmic) in range 8..15; defaults to 15.

strategy

One of ZLIB_FILTERED, ZLIB_HUFFMAN_ONLY, ZLIB_RLE, ZLIB_FIXED or ZLIB_DEFAULT_STRATEGY (the default).

dictionary

A string or an array of strings of the preset dictionary (default: no preset dictionary).

返回值

Returns an inflate context resource (zlib.inflate) on success, 或者在失败时返回 false.

错误／异常

If an invalid encoding or option is passed to options, or the context couldn't be created, an error of level E_WARNING is generated.

更新日志

版本 | 说明
8.0.0 | On success, this function returns an InflateContext instance now; previously, a resource was returned.

参见

  • inflate_add() - Incrementally inflate encoded data
  • deflate_init() - Initialize an incremental deflate context


Output a gz-file

  • ? inflate_init
  • zlib_decode ?
  • PHP Manual
  • Zlib 函数
  • Output a gz-file

readgzfile

(PHP 4, PHP 5, PHP 7, PHP 8)

readgzfile — Output a gz-file

说明

readgzfile ( string $filename , int $use_include_path = 0 ) : int|false

Reads a file, decompresses it and writes it to standard output.

readgzfile() can be used to read a file which is not in gzip format; in this case readgzfile() will directly read from the file without decompression.

参数

filename

The file name. This file will be opened from the filesystem and its contents written to standard output.

use_include_path

You can set this optional parameter to 1, if you want to search for the file in the include_path too.

返回值

Returns the number of (uncompressed) bytes read from the file on success, 或者在失败时返回 false

错误／异常

失败时抛出E_WARNING警告。

参见

  • gzpassthru() - Output all remaining data on a gz-file pointer
  • gzfile() - Read entire gz-file into an array
  • gzopen() - Open gz-file


Uncompress any raw/gzip/zlib encoded data

  • ? readgzfile
  • zlib_encode ?
  • PHP Manual
  • Zlib 函数
  • Uncompress any raw/gzip/zlib encoded data

zlib_decode

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

zlib_decode — Uncompress any raw/gzip/zlib encoded data

说明

zlib_decode ( string $data , int $max_length = 0 ) : string|false

Uncompress any raw/gzip/zlib encoded data.

Warning

本函数还未编写文档，仅有参数列表。

参数

data

max_length

返回值

Returns the uncompressed data, 或者在失败时返回 false.

参见

  • zlib_encode() - Compress data with the specified encoding


Compress data with the specified encoding

  • ? zlib_decode
  • zlib_get_coding_type ?
  • PHP Manual
  • Zlib 函数
  • Compress data with the specified encoding

zlib_encode

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

zlib_encode — Compress data with the specified encoding

说明

zlib_encode ( string $data , int $encoding , int $level = -1 ) : string|false

Compress data with the specified encoding.

Warning

本函数还未编写文档，仅有参数列表。

参数

data

The data to compress.

encoding

The compression algorithm. Either ZLIB_ENCODING_RAW, ZLIB_ENCODING_DEFLATE or ZLIB_ENCODING_GZIP.

level

返回值

范例

Example #1 zlib_encode() example

<?php
$str = 'hello world';
$enc = zlib_encode($str, ZLIB_ENCODING_DEFLATE);
echo bin2hex($enc);
?>

以上例程会输出：

789ccb48cdc9c95728cf2fca4901001a0b045d

参见

  • zlib_decode() - Uncompress any raw/gzip/zlib encoded data


Returns the coding type used for output compression

  • ? zlib_encode
  • DeflateContext ?
  • PHP Manual
  • Zlib 函数
  • Returns the coding type used for output compression

zlib_get_coding_type

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

zlib_get_coding_type — Returns the coding type used for output compression

说明

zlib_get_coding_type ( ) : string|false

Returns the coding type used for output compression.

返回值

Possible return values are gzip, deflate, or false.

参见

  • The zlib.output_compression directive


The DeflateContext class

(PHP 8)

简介

A fully opaque class which replaces zlib.deflate resources as of PHP 8.0.0.

类摘要

final DeflateContext {
}


The InflateContext class

(PHP 8)

简介

A fully opaque class which replaces zlib.inflate resources as of PHP 8.0.0.

类摘要

final InflateContext {
}


加密扩展

  • CSPRNG
    • 简介
    • 安装／配置
    • 预定义常量
    • CSPRNG 函数
  • Hash — 哈希信息摘要框架
    • 简介
    • 安装／配置
    • 预定义常量
    • Hash 函数
  • Mcrypt
    • 安装／配置
    • 预定义常量
    • Mcrypt 密码
    • 范例
    • Mcrypt 函数
  • Mhash
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Mhash 函数
  • OpenSSL
    • 简介
    • 安装／配置
    • 预定义常量
    • 密钥/证书参数
    • 证书验证
    • OpenSSL 函数
  • 密码散列算法
    • 简介
    • 安装／配置
    • 预定义常量
    • 密码散列算法函数
  • Sodium
    • 简介
    • 安装／配置
    • 预定义常量
    • Sodium 函数
    • SodiumException — The SodiumException class


CSPRNG

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • CSPRNG 函数
    • random_bytes — Generates cryptographically secure pseudo-random bytes
    • random_int — Generates cryptographically secure pseudo-random integers


简介

The » cryptographically secure pseudo-random number generator (CSPRNG) API provides an easy and reliable way to generate crypto-strong random integers and bytes for use within cryptographic contexts.

自以下版本起 PHP 7.0.0 but there is also a » userland implementation for PHP >= 5.2.0.


  • ? 资源类型
  • CSPRNG 函数 ?
  • PHP Manual
  • CSPRNG
  • 预定义常量

预定义常量

此扩展没有定义常量。


CSPRNG 函数

Table of Contents

  • random_bytes — Generates cryptographically secure pseudo-random bytes
  • random_int — Generates cryptographically secure pseudo-random integers


Generates cryptographically secure pseudo-random bytes

  • ? CSPRNG 函数
  • random_int ?
  • PHP Manual
  • CSPRNG 函数
  • Generates cryptographically secure pseudo-random bytes

random_bytes

(PHP 7, PHP 8)

random_bytes — Generates cryptographically secure pseudo-random bytes

说明

random_bytes ( int $length ) : string

Generates an arbitrary length string of cryptographic random bytes that are suitable for cryptographic use, such as when generating salts, keys or initialization vectors.

The sources of randomness used for this function are as follows:

  • On Windows, » CryptGenRandom() will always be used. As of PHP 7.2.0, the » CNG-API will always be used instead.
  • On Linux, the » getrandom(2) syscall will be used if available.
  • On other platforms, /dev/urandom will be used.
  • If none of the aforementioned sources are available, then an Exception will be thrown.

Note: Although this function was added to PHP in PHP 7.0, a » userland implementation is available for PHP 5.2 to 5.6, inclusive.

参数

length

The length of the random string that should be returned in bytes.

返回值

Returns a string containing the requested number of cryptographically secure random bytes.

错误／异常

  • If an appropriate source of randomness cannot be found, an Exception will be thrown.
  • If invalid parameters are given, a TypeError will be thrown.
  • If an invalid length of bytes is given, an Error will be thrown.

范例

Example #1 random_bytes() example

<?php
$bytes = random_bytes(5);
var_dump(bin2hex($bytes));
?>

以上例程的输出类似于：

string(10) "385e33f741"

参见

  • random_int() - Generates cryptographically secure pseudo-random integers
  • openssl_random_pseudo_bytes() - 生成一个伪随机字节串
  • bin2hex() - 函数把包含数据的二进制字符串转换为十六进制值


Generates cryptographically secure pseudo-random integers

  • ? random_bytes
  • Hash ?
  • PHP Manual
  • CSPRNG 函数
  • Generates cryptographically secure pseudo-random integers

random_int

(PHP 7, PHP 8)

random_int — Generates cryptographically secure pseudo-random integers

说明

random_int ( int $min , int $max ) : int

Generates cryptographic random integers that are suitable for use where unbiased results are critical, such as when shuffling a deck of cards for a poker game.

The sources of randomness used for this function are as follows:

  • On Windows, » CryptGenRandom() will always be used. As of PHP 7.2.0, the » CNG-API will always be used instead.
  • On Linux, the » getrandom(2) syscall will be used if available.
  • On other platforms, /dev/urandom will be used.
  • If none of the aforementioned sources are available, then an Exception will be thrown.

Note: Although this function was added to PHP in PHP 7.0, a » userland implementation is available for PHP 5.2 to 5.6, inclusive.

参数

min

The lowest value to be returned, which must be PHP_INT_MIN or higher.

max

The highest value to be returned, which must be less than or equal to PHP_INT_MAX.

返回值

Returns a cryptographically secure random integer in the range min to max, inclusive.

错误／异常

  • If an appropriate source of randomness cannot be found, an Exception will be thrown.
  • If invalid parameters are given, a TypeError will be thrown.
  • If max is less than min, an Error will be thrown.

范例

Example #1 random_int() example

<?php
var_dump(random_int(100, 999));
var_dump(random_int(-1000, 0));
?>

以上例程的输出类似于：

int(248)
int(-898)

参见

  • random_bytes() - Generates cryptographically secure pseudo-random bytes


哈希信息摘要框架

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Hash 函数
    • hash_algos — 返回已注册的哈希算法列表
    • hash_copy — 拷贝哈希运算上下文
    • hash_equals — 可防止时序攻击的字符串比较
    • hash_file — 给指定文件的内容生成哈希值
    • hash_final — 结束增量哈希，并且返回摘要结果
    • hash_hkdf — Generate a HKDF key derivation of a supplied key input
    • hash_hmac_algos — Return a list of registered hashing algorithms suitable for hash_hmac
    • hash_hmac_file — 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值
    • hash_hmac — 使用 HMAC 方法生成带有密钥的哈希值
    • hash_init — 初始化增量哈希运算上下文
    • hash_pbkdf2 — 生成所提供密码的 PBKDF2 密钥导出
    • hash_update_file — 从文件向活跃的哈希运算上下文中填充数据
    • hash_update_stream — 从打开的流向活跃的哈希运算上下文中填充数据
    • hash_update — 向活跃的哈希运算上下文中填充数据
    • hash — 生成哈希值 （消息摘要）


  • ? Hash
  • 安装／配置 ?
  • PHP Manual
  • Hash
  • 简介

简介

信息摘要（哈希）引擎。允许使用各种哈希算法直接或增量处理任意长度的信息。


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

使用这些函数不需要安装，它们是 PHP 核心的一部分。


安装

从 PHP 5.1.2 开始，哈希扩展是内置的，不需要外部库， 并且默认是启用的。

可以通过 --disable-hash 参数来禁用此扩展。 对于更早版本的 PHP，可以通过安装 » PECL 模块 来使用哈希扩展。

从 PHP 7.4.0 开始，Hash 扩展成为 PHP 的核心扩展，所以可以直接使用。


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

本扩展中定义了哈希上下文资源类型， 该类型资源由 hash_init() 函数返回。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

HASH_HMAC (integer)
hash_init() 中的可选标志。表示 HMAC digest-keying 算法应被用于当前哈希上下文环境。


Hash 函数

Table of Contents

  • hash_algos — 返回已注册的哈希算法列表
  • hash_copy — 拷贝哈希运算上下文
  • hash_equals — 可防止时序攻击的字符串比较
  • hash_file — 给指定文件的内容生成哈希值
  • hash_final — 结束增量哈希，并且返回摘要结果
  • hash_hkdf — Generate a HKDF key derivation of a supplied key input
  • hash_hmac_algos — Return a list of registered hashing algorithms suitable for hash_hmac
  • hash_hmac_file — 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值
  • hash_hmac — 使用 HMAC 方法生成带有密钥的哈希值
  • hash_init — 初始化增量哈希运算上下文
  • hash_pbkdf2 — 生成所提供密码的 PBKDF2 密钥导出
  • hash_update_file — 从文件向活跃的哈希运算上下文中填充数据
  • hash_update_stream — 从打开的流向活跃的哈希运算上下文中填充数据
  • hash_update — 向活跃的哈希运算上下文中填充数据
  • hash — 生成哈希值 （消息摘要）


返回已注册的哈希算法列表

  • ? Hash 函数
  • hash_copy ?
  • PHP Manual
  • Hash 函数
  • 返回已注册的哈希算法列表

hash_algos

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_algos — 返回已注册的哈希算法列表

说明

hash_algos ( ) : array

返回值

返回一个数值索引的数组， 包含了受支持的哈希算法名称。

更新日志

版本 | 说明
7.4.0 | 支持 crc32c。
7.1.0 | 加入 sha512/224，sha512/256，sha3-224，sha3-256，sha3-384 以及 sha3-512 算法的支持。

范例

Example #1 hash_algos() 例程

在 PHP 7.4.0 中，hash_algos() 会返回下表所示的算法清单：

<?php
print_r(hash_algos());
?>

以上例程的输出类似于：

Array
(
    [0] => md2
    [1] => md4
    [2] => md5
    [3] => sha1
    [4] => sha224
    [5] => sha256
    [6] => sha384
    [7] => sha512/224
    [8] => sha512/256
    [9] => sha512
    [10] => sha3-224
    [11] => sha3-256
    [12] => sha3-384
    [13] => sha3-512
    [14] => ripemd128
    [15] => ripemd160
    [16] => ripemd256
    [17] => ripemd320
    [18] => whirlpool
    [19] => tiger128,3
    [20] => tiger160,3
    [21] => tiger192,3
    [22] => tiger128,4
    [23] => tiger160,4
    [24] => tiger192,4
    [25] => snefru
    [26] => snefru256
    [27] => gost
    [28] => gost-crypto
    [29] => adler32
    [30] => crc32
    [31] => crc32b
    [32] => crc32c
    [33] => fnv132
    [34] => fnv1a32
    [35] => fnv164
    [36] => fnv1a64
    [37] => joaat
    [38] => haval128,3
    [39] => haval160,3
    [40] => haval192,3
    [41] => haval224,3
    [42] => haval256,3
    [43] => haval128,4
    [44] => haval160,4
    [45] => haval192,4
    [46] => haval224,4
    [47] => haval256,4
    [48] => haval128,5
    [49] => haval160,5
    [50] => haval192,5
    [51] => haval224,5
    [52] => haval256,5
)

参见

  • hash_hmac_algos() - Return a list of registered hashing algorithms suitable for hash_hmac


拷贝哈希运算上下文

  • ? hash_algos
  • hash_equals ?
  • PHP Manual
  • Hash 函数
  • 拷贝哈希运算上下文

hash_copy

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

hash_copy — 拷贝哈希运算上下文

说明

hash_copy ( HashContext $context ) : HashContext

参数

context

由 hash_init() 函数返回的哈希运算上下文。

返回值

返回哈希运算上下文的一个复本。

更新日志

版本 | 说明
7.2.0 | 接受的参数以及返回值从资源类型修改为 HashContext 对象类型。

范例

Example #1 hash_copy() 例程

<?php
$context = hash_init("md5");
hash_update($context, "data");

/* 拷贝上下文资源以便继续使用 */
$copy_context = hash_copy($context);

echo hash_final($context), "\n";

hash_update($copy_context, "data");
echo hash_final($copy_context), "\n";
?>

以上例程会输出：

8d777f385d3dfec8815d20f7496026dc
511ae0b1c13f95e5f08f1a0dd3da3d93


可防止时序攻击的字符串比较

  • ? hash_copy
  • hash_file ?
  • PHP Manual
  • Hash 函数
  • 可防止时序攻击的字符串比较

hash_equals

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

hash_equals — 可防止时序攻击的字符串比较

说明

hash_equals ( string $known_string , string $user_string ) : bool

比较两个字符串，无论它们是否相等，本函数的时间消耗是恒定的。

本函数可以用在需要防止时序攻击的字符串比较场景中， 例如，可以用在比较 crypt() 密码哈希值的场景。

参数

known_string

已知长度的、要参与比较的 string

user_string

用户提供的字符串

返回值

当两个字符串相等时返回 true，否则返回 false。

错误／异常

如果所提供的 2 个参数中任何一个不是字符串， 会导致 E_WARNING 消息。

范例

Example #1 hash_equals() 例程

<?php
$expected  = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$correct   = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$incorrect = crypt('apple', '$2a$07$usesomesillystringforsalt$');

var_dump(hash_equals($expected, $correct));
var_dump(hash_equals($expected, $incorrect));
?>

以上例程会输出：

bool(true)
bool(false)

注释

Note:

要想成功进行比较，那么所提供的 2 个参数必须是相同长度的字符串。 如果所提供的字符串长度不同，那么本函数会立即返回 false， 在时序攻击的场景下，已知字符串的长度可能会被泄露。

Note:

非常重要的一点是，用户提供的字符串必须是第二个参数。


给指定文件的内容生成哈希值

  • ? hash_equals
  • hash_final ?
  • PHP Manual
  • Hash 函数
  • 给指定文件的内容生成哈希值

hash_file

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_file — 给指定文件的内容生成哈希值

说明

hash_file ( string $algo , string $filename , bool $binary = false ) : string|false

参数

algo

要使用的哈希算法的名称（例如："md5"，"sha256"，"haval160,4" 等）。 可以在 hash_algos() 中查看当前支持的算法。

filename

要进行哈希运算的文件位置的 URL ；支持 fopen 封装协议。

binary

设置为 true 时，输出原始二进制数据。 设置为 false 时，输出小写的十六进制字符串。

返回值

如果 binary 设置为 true， 则返回原始二进制数据表示的信息摘要， 否则返回十六进制小写字符串格式表示的信息摘要。

范例

Example #1 使用 hash_file()

<?php
/* 创建一个要计算哈希值的文件 */
file_put_contents('example.txt', 'The quick brown fox jumped over the lazy dog.');
echo hash_file('md5', 'example.txt');
?>

以上例程会输出：

5c6ffbdd40d9556b73a21e63c3e0e904

参见

  • hash() - 生成哈希值 （消息摘要）
  • hash_hmac_file() - 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值
  • hash_update_file() - 从文件向活跃的哈希运算上下文中填充数据
  • md5_file() - 计算指定文件的 MD5 散列值
  • sha1_file() - 计算文件的 sha1 散列值


结束增量哈希，并且返回摘要结果

  • ? hash_file
  • hash_hkdf ?
  • PHP Manual
  • Hash 函数
  • 结束增量哈希，并且返回摘要结果

hash_final

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_final — 结束增量哈希，并且返回摘要结果

说明

hash_final ( HashContext $context , bool $raw_output = false ) : string

参数

context

hash_init() 函数返回的哈希运算上下文资源。

raw_output

设置为 true，输出格式为原始的二进制数据。 设置为 false，输出小写的 16 进制字符串。

返回值

如果 raw_output 设置为 true， 则返回原始二进制数据表示的信息摘要， 否则返回 16 进制小写字符串格式表示的信息摘要。

更新日志

版本 | 说明
7.2.0 | 接收参数从资源类型修改为 HashContext 对象类型。

范例

Example #1 hash_final() 例程

<?php
$ctx = hash_init('sha1');
hash_update($ctx, 'The quick brown fox jumped over the lazy dog.');
echo hash_final($ctx);
?>

以上例程会输出：

c0854fb9fb03c41cce3802cb0d220529e6eef94e

参见

  • hash_init() - 初始化增量哈希运算上下文
  • hash_update() - 向活跃的哈希运算上下文中填充数据
  • hash_update_stream() - 从打开的流向活跃的哈希运算上下文中填充数据
  • hash_update_file() - 从文件向活跃的哈希运算上下文中填充数据


Generate a HKDF key derivation of a supplied key input

  • ? hash_final
  • hash_hmac_algos ?
  • PHP Manual
  • Hash 函数
  • Generate a HKDF key derivation of a supplied key input

hash_hkdf

(PHP 7 >= 7.1.2, PHP 8)

hash_hkdf — Generate a HKDF key derivation of a supplied key input

说明

hash_hkdf ( string $algo , string $key , int $length = 0 , string $info = "" , string $salt = "" ) : string

参数

algo

Name of selected hashing algorithm (i.e. "sha256", "sha512", "haval160,4", etc..) See hash_algos() for a list of supported algorithms.

Note:

Non-cryptographic hash functions are not allowed.

key

Input keying material (raw binary). Cannot be empty.

length

Desired output length in bytes. Cannot be greater than 255 times the chosen hash function size.

If length is 0, the output length will default to the chosen hash function size.

info

Application/context-specific info string.

salt

Salt to use during derivation.

While optional, adding random salt significantly improves the strength of HKDF.

返回值

Returns a string containing a raw binary representation of the derived key (also known as output keying material - OKM); or false on failure.

错误／异常

An E_WARNING will be raised if key is empty, algo is unknown/non-cryptographic, length is less than 0 or too large (greater than 255 times the size of the hash function).

范例

Example #1 hash_hkdf() example

<?php
// Generate a random key, and salt to strengthen it during derivation.
$inputKey = random_bytes(32);
$salt = random_bytes(16);

// Derive a pair of separate keys, using the same input created above.
$encryptionKey = hash_hkdf('sha256', $inputKey, 32, 'aes-256-encryption', $salt);
$authenticationKey = hash_hkdf('sha256', $inputKey, 32, 'sha-256-authentication', $salt);

var_dump($encryptionKey !== $authenticationKey); // bool(true)
?>

The above example produces a pair of separate keys, suitable for creation of an encrypt-then-HMAC construct, using AES-256 and SHA-256 for encryption and authentication respectively.

参见

  • hash_pbkdf2() - 生成所提供密码的 PBKDF2 密钥导出
  • » RFC 5869
  • » userland implementation


Return a list of registered hashing algorithms suitable for hash_hmac

  • ? hash_hkdf
  • hash_hmac_file ?
  • PHP Manual
  • Hash 函数
  • Return a list of registered hashing algorithms suitable for hash_hmac

hash_hmac_algos

(PHP 7 >= 7.2.0, PHP 8)

hash_hmac_algos — Return a list of registered hashing algorithms suitable for hash_hmac

说明

hash_hmac_algos ( ) : array

返回值

Returns a numerically indexed array containing the list of supported hashing algorithms suitable for hash_hmac().

范例

Example #1 hash_hmac_algos() example

<?php
print_r(hash_hmac_algos());

以上例程的输出类似于：

Array
(
    [0] => md2
    [1] => md4
    [2] => md5
    [3] => sha1
    [4] => sha224
    [5] => sha256
    [6] => sha384
    [7] => sha512/224
    [8] => sha512/256
    [9] => sha512
    [10] => sha3-224
    [11] => sha3-256
    [12] => sha3-384
    [13] => sha3-512
    [14] => ripemd128
    [15] => ripemd160
    [16] => ripemd256
    [17] => ripemd320
    [18] => whirlpool
    [19] => tiger128,3
    [20] => tiger160,3
    [21] => tiger192,3
    [22] => tiger128,4
    [23] => tiger160,4
    [24] => tiger192,4
    [25] => snefru
    [26] => snefru256
    [27] => gost
    [28] => gost-crypto
    [29] => haval128,3
    [30] => haval160,3
    [31] => haval192,3
    [32] => haval224,3
    [33] => haval256,3
    [34] => haval128,4
    [35] => haval160,4
    [36] => haval192,4
    [37] => haval224,4
    [38] => haval256,4
    [39] => haval128,5
    [40] => haval160,5
    [41] => haval192,5
    [42] => haval224,5
    [43] => haval256,5
)

注释

Note:

Before PHP 7.2.0 the only means to get a list of supported hash algorithms has been to call hash_algos() which also returns hash algorithms that are not suitable for hash_hmac().

参见

  • hash_hmac() - 使用 HMAC 方法生成带有密钥的哈希值
  • hash_algos() - 返回已注册的哈希算法列表


使用 HMAC 方法和给定文件的内容生成带密钥的哈希值

  • ? hash_hmac_algos
  • hash_hmac ?
  • PHP Manual
  • Hash 函数
  • 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值

hash_hmac_file

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_hmac_file — 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值

说明

hash_hmac_file ( string $algo , string $filename , string $key , bool $raw_output = false ) : string

参数

algo

要使用的哈希算法名称，例如："md5"，"sha256"，"haval160,4" 等。 如何获取受支持的算法清单，请参见 hash_hmac_algos() 函数。

filename

要进行哈希运算的文件路径，支持 fopen 封装器。

key

使用 HMAC 生成信息摘要时所使用的密钥。

raw_output

设置为 true 输出原始二进制数据， 设置为 false 输出小写 16 进制字符串。

返回值

如果 raw_output 设置为 true， 则返回原始二进制数据表示的信息摘要， 否则返回 16 进制小写字符串格式表示的信息摘要。 如果 algo 参数指定的不是受支持的算法，或者无法读取 filename 给定的文件，则返回 false。

更新日志

版本 | 说明
7.2.0 | 不再支持非加密的哈希函数（adler32，crc32，crc32b，fnv132，fnv1a32，fnv164，fnv1a64，joaat）。

范例

Example #1 hash_hmac_file() 例程

<?php
/* 创建一个要计算哈希值的文件 */
file_put_contents('example.txt', 'The quick brown fox jumped over the lazy dog.');

echo hash_hmac_file('md5', 'example.txt', 'secret');
?>

以上例程会输出：

7eb2b5c37443418fc77c136dd20e859c

参见

  • hash_hmac_algos() - Return a list of registered hashing algorithms suitable for hash_hmac
  • hash_hmac() - 使用 HMAC 方法生成带有密钥的哈希值
  • hash_file() - 给指定文件的内容生成哈希值


使用 HMAC 方法生成带有密钥的哈希值

  • ? hash_hmac_file
  • hash_init ?
  • PHP Manual
  • Hash 函数
  • 使用 HMAC 方法生成带有密钥的哈希值

hash_hmac

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_hmac — 使用 HMAC 方法生成带有密钥的哈希值

说明

hash_hmac ( string $algo , string $data , string $key , bool $raw_output = false ) : string

参数

algo

要使用的哈希算法名称，例如："md5"，"sha256"，"haval160,4" 等。 如何获取受支持的算法清单，请参见 hash_hmac_algos() 函数。

data

要进行哈希运算的消息。

key

使用 HMAC 生成信息摘要时所使用的密钥。

raw_output

设置为 true 输出原始二进制数据， 设置为 false 输出小写 16 进制字符串。

返回值

如果 raw_output 设置为 true， 则返回原始二进制数据表示的信息摘要， 否则返回 16 进制小写字符串格式表示的信息摘要。 如果 algo 参数指定的不是受支持的算法，返回 false。

更新日志

版本 | 说明
7.2.0 | 不再支持非加密的哈希函数（adler32，crc32，crc32b，fnv132，fnv1a32，fnv164，fnv1a64，joaat）。

范例

Example #1 hash_hmac() 例程

<?php
echo hash_hmac('ripemd160', 'The quick brown fox jumped over the lazy dog.', 'secret');
?>

以上例程会输出：

b8e7ae12510bdfb1812e463a7f086122cf37e4f7

参见

  • hash() - 生成哈希值 （消息摘要）
  • hash_hmac_algos() - Return a list of registered hashing algorithms suitable for hash_hmac
  • hash_init() - 初始化增量哈希运算上下文
  • hash_hmac_file() - 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值


初始化增量哈希运算上下文

  • ? hash_hmac
  • hash_pbkdf2 ?
  • PHP Manual
  • Hash 函数
  • 初始化增量哈希运算上下文

hash_init

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_init — 初始化增量哈希运算上下文

说明

hash_init ( string $algo , int $options = 0 , string $key = null ) : HashContext

参数

algo

要使用的哈希算法名称，例如："md5"，"sha256"，"haval160,4" 等。 如何获取受支持的算法清单，请参见 hash_algos()。

options

进行哈希运算的可选设置，目前仅支持一个选项：HASH_HMAC。 当指定此选项的时候，必须 指定 key 参数。

key

当 options 参数为 HASH_HMAC 时， 使用此参数传入进行 HMAC 哈希运算时的共享密钥。

返回值

返回哈希运算上下文对象，以供
hash_update()，
hash_update_stream()，hash_update_file(),
和 hash_final() 函数使用。

更新日志

版本 | 说明
7.2.0 | 当使用 HASH_HMAC 选项的时候，不再支持非加密的哈希函数（adler32，crc32，crc32b，fnv132，fnv1a32，fnv164，fnv1a64，joaat）。
7.2.0 | 返回 HashContext 对象，不再返回资源类型。

范例

Example #1 增量哈希运算例程

<?php
$ctx = hash_init('md5');
hash_update($ctx, 'The quick brown fox ');
hash_update($ctx, 'jumped over the lazy dog.');
echo hash_final($ctx);
?>

以上例程会输出：

5c6ffbdd40d9556b73a21e63c3e0e904

参见

  • hash() - 生成哈希值 （消息摘要）
  • hash_algos() - 返回已注册的哈希算法列表
  • hash_file() - 给指定文件的内容生成哈希值
  • hash_hmac() - 使用 HMAC 方法生成带有密钥的哈希值
  • hash_hmac_file() - 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值


生成所提供密码的 PBKDF2 密钥导出

  • ? hash_init
  • hash_update_file ?
  • PHP Manual
  • Hash 函数
  • 生成所提供密码的 PBKDF2 密钥导出

hash_pbkdf2

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

hash_pbkdf2 — 生成所提供密码的 PBKDF2 密钥导出

说明

hash_pbkdf2 ( string $algo , string $password , string $salt , int $iterations , int $length = 0 , bool $raw_output = false ) : string

参数

algo

哈希算法名称，例如 md5，sha256，haval160,4 等。 受支持的算法清单请参见 hash_algos()。

password

要进行导出的密码。

salt

进行导出时所使用的"盐"，这个值应该是随机生成的。

iterations

进行导出时的迭代次数。

length

密钥导出数据的长度。如果 raw_output 为 true， 此参数为密钥导出数据的字节长度。如果 raw_output 为 false， 此参数为密钥导出数据的字节长度的 2 倍，因为 1 个字节数据对应的 2 个 16 进制的字符。

如果传入 0，则使用所选算法的完整输出大小。

raw_output

设置为 true 输出原始二进制数据， 设置为 false 输出小写 16 进制字符串。

返回值

如果 raw_output 设置为 true， 则返回原始二进制数据表示的信息摘要， 否则返回 16 进制小写字符串格式表示的信息摘要。

错误／异常

在以下情况下会产生 E_WARNING： 指定了未知的算法， iterations 小于等于 0， length 小于等于 0 或者 salt 过长（大于 INT_MAX - 4）。

更新日志

版本 | 说明
7.2.0 | 不再支持非加密的哈希函数（adler32，crc32，crc32b，fnv132，fnv1a32，fnv164，fnv1a64，joaat）。

范例

Example #1 hash_pbkdf2() 例程，基础用法

<?php
$password = "password";
$iterations = 1000;

// 使用 openssl_random_pseudo_bytes()，random_bytes()，或者其他合适的随机数生成函数
// 来生成随机初始向量
$salt = openssl_random_pseudo_bytes(16, MCRYPT_DEV_URANDOM);

$hash = hash_pbkdf2("sha256", $password, $salt, $iterations, 20);
echo $hash;
?>

以上例程的输出类似于：

120fb6cffcf8b32c43e7

注释

Caution

为了安全起见，可以使用 PBKDF2 方法对密码明文进行哈希运算后再存储。 但是更好的方案是使用 password_hash() 函数 或者使用 CRYPT_BLOWFISH 算法调用 crypt() 函数。

参见

  • crypt() - 单向字符串散列
  • password_hash() - 创建密码的散列（hash）
  • hash() - 生成哈希值 （消息摘要）
  • hash_algos() - 返回已注册的哈希算法列表
  • hash_init() - 初始化增量哈希运算上下文
  • hash_hmac() - 使用 HMAC 方法生成带有密钥的哈希值
  • hash_hmac_file() - 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值
  • openssl_pbkdf2() - 生成一个 PKCS5 v2 PBKDF2 字符串


从文件向活跃的哈希运算上下文中填充数据

  • ? hash_pbkdf2
  • hash_update_stream ?
  • PHP Manual
  • Hash 函数
  • 从文件向活跃的哈希运算上下文中填充数据

hash_update_file

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_update_file — 从文件向活跃的哈希运算上下文中填充数据

说明

hash_update_file ( HashContext $hcontext , string $filename , resource $scontext = null ) : bool

参数

hcontext

由 hash_init() 函数返回的哈希运算上下文。

filename

要进行哈希运算的文件路径，支持 fopen 封装器。

scontext

由 stream_context_create() 函数返回的流上下文。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.2.0 | 接收参数从资源类型修改为 HashContext 对象类型。

参见

  • hash_init() - 初始化增量哈希运算上下文
  • hash_update() - 向活跃的哈希运算上下文中填充数据
  • hash_update_stream() - 从打开的流向活跃的哈希运算上下文中填充数据
  • hash_final() - 结束增量哈希，并且返回摘要结果
  • hash() - 生成哈希值 （消息摘要）
  • hash_file() - 给指定文件的内容生成哈希值


从打开的流向活跃的哈希运算上下文中填充数据

  • ? hash_update_file
  • hash_update ?
  • PHP Manual
  • Hash 函数
  • 从打开的流向活跃的哈希运算上下文中填充数据

hash_update_stream

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_update_stream — 从打开的流向活跃的哈希运算上下文中填充数据

说明

hash_update_stream ( HashContext $context , resource $handle , int $length = -1 ) : int

参数

context

由 hash_init() 函数返回的哈希运算上下文。

handle

创建流的函数返回的打开的文件句柄。

length

要从 handle 向活跃的哈希运算上下文中拷贝 的最大字符数。

返回值

从 handle 向哈希运算上下文中实际填充的字节数量。

更新日志

版本 | 说明
7.2.0 | 接收参数从资源类型修改为 HashContext 对象类型。

范例

Example #1 hash_update_stream() 例程

<?php
$fp = tmpfile();
fwrite($fp, 'The quick brown fox jumped over the lazy dog.');
rewind($fp);

$ctx = hash_init('md5');
hash_update_stream($ctx, $fp);
echo hash_final($ctx);
?>

以上例程会输出：

5c6ffbdd40d9556b73a21e63c3e0e904

参见

  • hash_init() - 初始化增量哈希运算上下文
  • hash_update() - 向活跃的哈希运算上下文中填充数据
  • hash_final() - 结束增量哈希，并且返回摘要结果
  • hash() - 生成哈希值 （消息摘要）
  • hash_file() - 给指定文件的内容生成哈希值


向活跃的哈希运算上下文中填充数据

  • ? hash_update_stream
  • hash ?
  • PHP Manual
  • Hash 函数
  • 向活跃的哈希运算上下文中填充数据

hash_update

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash_update — 向活跃的哈希运算上下文中填充数据

说明

hash_update ( HashContext $context , string $data ) : bool

参数

context

由 hash_init() 函数返回的哈希运算上下文。

data

要向哈希摘要中追加的数据。

返回值

返回 true。

更新日志

版本 | 说明
7.2.0 | 接收参数从资源类型修改为 HashContext 对象类型。

参见

  • hash_init() - 初始化增量哈希运算上下文
  • hash_update_file() - 从文件向活跃的哈希运算上下文中填充数据
  • hash_update_stream() - 从打开的流向活跃的哈希运算上下文中填充数据
  • hash_final() - 结束增量哈希，并且返回摘要结果


生成哈希值 （消息摘要）

  • ? hash_update
  • Mcrypt ?
  • PHP Manual
  • Hash 函数
  • 生成哈希值 （消息摘要）

hash

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL hash >= 1.1)

hash — 生成哈希值 （消息摘要）

说明

hash ( string $algo , string $data , bool $raw_output = false ) : string

参数

algo

要使用的哈希算法，例如："md5"，"sha256"，"haval160,4" 等。 在 hash_algos() 中查看支持的算法。

data

要进行哈希运算的消息。

raw_output

设置为 true 输出原始二进制数据， 设置为 false 输出小写 16 进制字符串。

返回值

如果 raw_output 设置为 true， 则返回原始二进制数据表示的信息摘要， 否则返回 16 进制小写字符串格式表示的信息摘要。

范例

Example #1 一个 hash() 例程

<?php
echo hash('ripemd160', 'The quick brown fox jumped over the lazy dog.');
?>

以上例程会输出：

ec457d0a974c48d5685a7efa03d137dc8bbde7e3

Example #2 使用 PHP 5.4 或者更高版本计算 tiger 哈希值

<?php
function old_tiger($data = "", $width=192, $rounds = 3) {
    return substr(
        implode(
            array_map(
                function ($h) {
                    return str_pad(bin2hex(strrev($h)), 16, "0");
                },
                str_split(hash("tiger192,$rounds", $data, true), 8)
            )
        ),
        0, 48-(192-$width)/4
    );
}
echo hash('tiger192,3', 'a-string'), PHP_EOL;
echo old_tiger('a-string'), PHP_EOL;
?>

以上例程在 PHP 5.3 中的输出：

146a7492719b3564094efe7abbd40a7416fd900179d02773
64359b7192746a14740ad4bb7afe4e097327d0790190fd16

以上例程在 PHP 5.4 中的输出：

64359b7192746a14740ad4bb7afe4e097327d0790190fd16
146a7492719b3564094efe7abbd40a7416fd900179d02773

参见

  • hash_file() - 给指定文件的内容生成哈希值
  • hash_hmac() - 使用 HMAC 方法生成带有密钥的哈希值
  • hash_init() - 初始化增量哈希运算上下文
  • md5() - 计算字符串的 MD5 散列值
  • sha1() - 计算字符串的 sha1 散列值


Mcrypt

  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Mcrypt 密码
  • 范例
  • Mcrypt 函数
    • mcrypt_cbc — 以 CBC 模式加解密数据
    • mcrypt_cfb — 以 CFB 模式加解密数据
    • mcrypt_create_iv — 从随机源创建初始向量
    • mcrypt_decrypt — 使用给定参数解密密文
    • mcrypt_ecb — 已废弃：使用 ECB 模式加解密数据
    • mcrypt_enc_get_algorithms_name — 返回打开的算法名称
    • mcrypt_enc_get_block_size — 返回打开的算法的分组大小
    • mcrypt_enc_get_iv_size — 返回打开的算法的初始向量大小
    • mcrypt_enc_get_key_size — 返回打开的模式所能支持的最长密钥
    • mcrypt_enc_get_modes_name — 返回打开的模式的名称
    • mcrypt_enc_get_supported_key_sizes — 以数组方式返回打开的算法所支持的密钥长度
    • mcrypt_enc_is_block_algorithm_mode — 检测打开的模式是否支持分组加密
    • mcrypt_enc_is_block_algorithm — 检测打开模式的算法是否为分组算法
    • mcrypt_enc_is_block_mode — 检测打开的模式是否以分组方式输出
    • mcrypt_enc_self_test — 在打开的模块上进行自检
    • mcrypt_encrypt — 使用给定参数加密明文
    • mcrypt_generic_deinit — 对加密模块进行清理工作
    • mcrypt_generic_end — 终止加密
    • mcrypt_generic_init — 初始化加密所需的缓冲区
    • mcrypt_generic — 加密数据
    • mcrypt_get_block_size — 获得加密算法的分组大小
    • mcrypt_get_cipher_name — 获取加密算法名称
    • mcrypt_get_iv_size — 返回指定算法/模式组合的初始向量大小
    • mcrypt_get_key_size — 获取指定加密算法的密钥大小
    • mcrypt_list_algorithms — 获取支持的加密算法
    • mcrypt_list_modes — 获取所支持的模式
    • mcrypt_module_close — 关闭加密模块
    • mcrypt_module_get_algo_block_size — 返回指定算法的分组大小
    • mcrypt_module_get_algo_key_size — 获取打开模式所支持的最大密钥大小
    • mcrypt_module_get_supported_key_sizes — 以数组形式返回打开的算法所支持的密钥大小
    • mcrypt_module_is_block_algorithm_mode — 返回指定模块是否是分组加密模式
    • mcrypt_module_is_block_algorithm — 检测指定算法是否为分组加密算法
    • mcrypt_module_is_block_mode — 检测指定模式是否以分组方式输出
    • mcrypt_module_open — 打开算法和模式对应的模块
    • mcrypt_module_self_test — 在指定模块上执行自检
    • mcrypt_ofb — 使用 OFB 模式加密/解密数据
    • mdecrypt_generic — 解密数据


  • ? Mcrypt
  • 安装／配置 ?
  • PHP Manual
  • Mcrypt
Warning

This feature was DEPRECATED in PHP 7.1.0, and REMOVED in PHP 7.2.0.

Alternatives to this feature include:

  • Sodium (available as of PHP 7.2.0)
  • OpenSSL

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。7.2.0.

本扩展是 mcrypt 库的接口，mcrypt 库提供了对多种块算法的支持， 包括：DES，TripleDES，Blowfish （默认）， 3-WAY，SAFER-SK64，SAFER-SK128，TWOFISH，TEA，RC2 以及 GOST，并且支持 CBC，OFB，CFB 和 ECB 密码模式。 甚至，它还支持诸如 RC6 和 IDEA 这两种"非免费"的算法。 默认情况下，CFB/OFB 是 8 比特的。


需求

这些函数需要使用 » mcrypt 库。 请从 » http://mcrypt.sourceforge.net/ 下载 libmcrypt-x.x.tar.gz， 并按以下指导完成安装。

你需要使用 libmcrypt 2.5.6 或更高版本。

PHP 5.2 的 Windows 二进制发行版中已经包含了本库。 PHP 5.3 的 Windows 二进制发行版中开始使用 MCrypt 静态库， 所以不再需要 DLL。

如果使用 libmcrypt 2.4.x 或更高版本链接编译 PHP，支持以下附加的分组加密算法： CAST，LOKI97，RIJNDAEL，SAFERPLUS，SERPENT， 以及以下流密码：ENIGMA（加密）， PANAMA，RC4 和 WAKE。 如果使用 libmcrypt 2.4.x 或更高版本，那么还支持 nOFB 密码模式。


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mcrypt.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Mcrypt 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mcrypt.algorithms_dir | null | PHP_INI_ALL |
mcrypt.modes_dir | null | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

mcrypt.algorithms_dir string

包含算法的目录。 默认情况向是 libmcrypt 的编译目录， 通常是 /usr/local/lib/libmcrypt。 更多信息请参见 mcrypt_list_algorithms()。

mcrypt.modes_dir string

包含模式的目录。 默认情况向是 libmcrypt 的编译目录， 通常是 /usr/local/lib/libmcrypt。 更多信息请参见 mcrypt_list_modes()。


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

mcrypt_module_open() 返回加密描述符。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Mcrypt 支持以下四种分组密码模式：CBC， OFB，CFB 和 ECB。 如果使用 libmcrypt-2.4.x 或更高版本链接， 还可以支持 nOFB 分组模式 和 STREAM 模式。 下列是所支持的加密模式以及其对应的预定义常量。 完整的参考见：Applied Cryptography by Schneier (ISBN 0-471-11709-9)。

  • MCRYPT_MODE_ECB (electronic codebook) 是一种分组加密模式，但是它无法适用于大部分场景， 所以不建议使用这种模式进行分组加密。
  • MCRYPT_MODE_CBC (cipher block chaining) 也是一种分组加密方式， 相对 ECB 模式，它更加安全。
  • MCRYPT_MODE_CFB (8 比特模式的 cipher feedback) 是一种流式加密模式。 相对于 CFB 而言， 推荐使用 NCFB 模式。
  • MCRYPT_MODE_OFB (output feedback, in 8bit) 和 CFB 类似， 也是一种流式加密模式，它可以用在无法容忍加密错误传播的应用中。 推荐使用 NOFB 模式，而不是 OFB 模式。
  • MCRYPT_MODE_NOFB (output feedback, in nbit) 和 OFB 类似，但是更加安全， 因为它可以按照算法指定的分组大小来对数据进行加密。
  • MCRYPT_MODE_STREAM 是一种扩展模式， 它包含了诸如 "WAKE" 或 "RC4" 的流加密算法。

Mcrypt 还支持一些尚未预定义常量的加密模式。 可以通过传入一个字符串来使用使用未预定义常量的加密模式。

  • "ctr" (counter mode) 是一种流式加密模式。
  • "ncfb" (cipher feedback, in n-bit mode)，类似于 CFB 模式， 但是它会对于算法设定的整块数据进行操作。

其他模式以及随机设备常量：

MCRYPT_ENCRYPT (integer)
MCRYPT_DECRYPT (integer)
MCRYPT_DEV_RANDOM (integer)
MCRYPT_DEV_URANDOM (integer)
MCRYPT_RAND (integer)


Mcrypt 密码

下表是 mcrypt 扩展所支持的密码。 所支持的密码的完整列表请参见 mcrypt.h 文件。 在 PHP 中使用 mcrypt-2.2.x 的一个通用规则是你可以使用 MCRYPT_ciphername 来访问密码。 在 libmcrypt-2.4.x 和 libmcrypt-2.5.x 的 API 中，这些常量依然可用， 但是你也可以把密码模式以字符串的形式传入 mcrypt_module_open() 函数 来进行访问。

  • MCRYPT_3DES
  • MCRYPT_ARCFOUR_IV ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_ARCFOUR ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_BLOWFISH
  • MCRYPT_CAST_128
  • MCRYPT_CAST_256
  • MCRYPT_CRYPT
  • MCRYPT_DES
  • MCRYPT_DES_COMPAT ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_ENIGMA ( 仅 libmcrypt > 2.4.x 可用，MCRYPT_CRYPT 的别名)
  • MCRYPT_GOST
  • MCRYPT_IDEA (非免费算法)
  • MCRYPT_LOKI97 ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_MARS ( 仅 libmcrypt > 2.4.x 可用，非免费算法)
  • MCRYPT_PANAMA ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_RIJNDAEL_128 ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_RIJNDAEL_192 ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_RIJNDAEL_256 ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_RC2
  • MCRYPT_RC4 ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_RC6 ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_RC6_128 ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_RC6_192 ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_RC6_256 ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_SAFER64
  • MCRYPT_SAFER128
  • MCRYPT_SAFERPLUS ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_SERPENT( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_SERPENT_128 ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_SERPENT_192 ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_SERPENT_256 ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_SKIPJACK ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_TEAN ( 仅 libmcrypt 2.2.x 可用 )
  • MCRYPT_THREEWAY
  • MCRYPT_TRIPLEDES ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_TWOFISH ( mcrypt 2.x 之前的版本，或者 2.4.x 之后版本可用 )
  • MCRYPT_TWOFISH128 (TWOFISHxxx 在新的 2.x 版本可用，但在 2.4.x 版本不可用)
  • MCRYPT_TWOFISH192
  • MCRYPT_TWOFISH256
  • MCRYPT_WAKE ( 仅 libmcrypt > 2.4.x 可用 )
  • MCRYPT_XTEA ( 仅 libmcrypt > 2.4.x 可用 )

如果使用 CFB 和 OFB 模式， 必须提供初始向量（IV）， 如果使用 CBC 模式， 可以提供一个初始向量。 初始向量必须是唯一的，并且在加密和解密过程中要保持一致。 你可以将初始向量和加密后数据一起存储， 其存储位置可以由一个函数的输出来指定， 例如文件名的 MD5 散列值， 这样你就可以把初始向量和加密后的数据一起传输 （关于本话题的更多信息，请参见 Applied Cryptography by Schneier (ISBN 0-471-11709-9) 9.3 一节）。


范例

Mcrypt 支持使用上述的算法来进行加密和解密。 如果你使用 libmcrypt-2.2.x 链接编译 PHP， 通过使用最重要的四个函数（mcrypt_cfb()， mcrypt_cbc(), mcrypt_ecb()， 和 mcrypt_ofb()） 以及 MCRYPT_ENCRYPT and MCRYPT_DECRYPT 来对数据进行加解密。

如果你使用 libmcrypt 2.4.x 或者 2.5.x 版本，以上函数依然可用。 但是建议使用新版本提供的更先进的函数。

Example #1 在 2.4.x 或更高版本，使用 256 比特的密钥，AES 算法和 CBC 模式来加密输入数据

<?php
    $key = hash('sha256', 'this is a secret key', true);
    $input = "Let us meet at 9 o'clock at the secret place.";

    $td = mcrypt_module_open('rijndael-128', '', 'cbc', '');
    $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td), MCRYPT_DEV_URANDOM);
    mcrypt_generic_init($td, $key, $iv);
    $encrypted_data = mcrypt_generic($td, $input);
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);
?>
本例程将加密后的数据以字符串格式存储于 $encrypted_data 变量。 完整例程请参见 mcrypt_module_open()。


Mcrypt 函数

Table of Contents

  • mcrypt_cbc — 以 CBC 模式加解密数据
  • mcrypt_cfb — 以 CFB 模式加解密数据
  • mcrypt_create_iv — 从随机源创建初始向量
  • mcrypt_decrypt — 使用给定参数解密密文
  • mcrypt_ecb — 已废弃：使用 ECB 模式加解密数据
  • mcrypt_enc_get_algorithms_name — 返回打开的算法名称
  • mcrypt_enc_get_block_size — 返回打开的算法的分组大小
  • mcrypt_enc_get_iv_size — 返回打开的算法的初始向量大小
  • mcrypt_enc_get_key_size — 返回打开的模式所能支持的最长密钥
  • mcrypt_enc_get_modes_name — 返回打开的模式的名称
  • mcrypt_enc_get_supported_key_sizes — 以数组方式返回打开的算法所支持的密钥长度
  • mcrypt_enc_is_block_algorithm_mode — 检测打开的模式是否支持分组加密
  • mcrypt_enc_is_block_algorithm — 检测打开模式的算法是否为分组算法
  • mcrypt_enc_is_block_mode — 检测打开的模式是否以分组方式输出
  • mcrypt_enc_self_test — 在打开的模块上进行自检
  • mcrypt_encrypt — 使用给定参数加密明文
  • mcrypt_generic_deinit — 对加密模块进行清理工作
  • mcrypt_generic_end — 终止加密
  • mcrypt_generic_init — 初始化加密所需的缓冲区
  • mcrypt_generic — 加密数据
  • mcrypt_get_block_size — 获得加密算法的分组大小
  • mcrypt_get_cipher_name — 获取加密算法名称
  • mcrypt_get_iv_size — 返回指定算法/模式组合的初始向量大小
  • mcrypt_get_key_size — 获取指定加密算法的密钥大小
  • mcrypt_list_algorithms — 获取支持的加密算法
  • mcrypt_list_modes — 获取所支持的模式
  • mcrypt_module_close — 关闭加密模块
  • mcrypt_module_get_algo_block_size — 返回指定算法的分组大小
  • mcrypt_module_get_algo_key_size — 获取打开模式所支持的最大密钥大小
  • mcrypt_module_get_supported_key_sizes — 以数组形式返回打开的算法所支持的密钥大小
  • mcrypt_module_is_block_algorithm_mode — 返回指定模块是否是分组加密模式
  • mcrypt_module_is_block_algorithm — 检测指定算法是否为分组加密算法
  • mcrypt_module_is_block_mode — 检测指定模式是否以分组方式输出
  • mcrypt_module_open — 打开算法和模式对应的模块
  • mcrypt_module_self_test — 在指定模块上执行自检
  • mcrypt_ofb — 使用 OFB 模式加密/解密数据
  • mdecrypt_generic — 解密数据


以 CBC 模式加解密数据

  • ? Mcrypt 函数
  • mcrypt_cfb ?
  • PHP Manual
  • Mcrypt 函数
  • 以 CBC 模式加解密数据

mcrypt_cbc

(PHP 4, PHP 5)

mcrypt_cbc — 以 CBC 模式加解密数据

Warning

This function was DEPRECATED in PHP 5.5.0, and REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • mcrypt_decrypt()
  • mcrypt_encrypt()

说明

mcrypt_cbc ( int $cipher , string $key , string $data , int $mode , string $iv = ? ) : string
mcrypt_cbc ( string $cipher , string $key , string $data , int $mode , string $iv = ? ) : string

第一个原型是针对 libmcrypt 2.2.x 的， 第二个原型是针对 libmcrypt 2.4.x 及更高版本的。 mode 可选值为： MCRYPT_ENCRYPT 或 MCRYPT_DECRYPT。


以 CFB 模式加解密数据

  • ? mcrypt_cbc
  • mcrypt_create_iv ?
  • PHP Manual
  • Mcrypt 函数
  • 以 CFB 模式加解密数据

mcrypt_cfb

(PHP 4, PHP 5)

mcrypt_cfb — 以 CFB 模式加解密数据

Warning

This function was DEPRECATED in PHP 5.5.0, and REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • mcrypt_decrypt()
  • mcrypt_encrypt()

说明

mcrypt_cfb ( int $cipher , string $key , string $data , int $mode , string $iv ) : string
mcrypt_cfb ( string $cipher , string $key , string $data , int $mode , string $iv = ? ) : string

第一个原型是针对 libmcrypt 2.2.x 的， 第二个原型是针对 libmcrypt 2.4.x 及更高版本的。 mode 可选值为： MCRYPT_ENCRYPT 或 MCRYPT_DECRYPT。


从随机源创建初始向量

  • ? mcrypt_cfb
  • mcrypt_decrypt ?
  • PHP Manual
  • Mcrypt 函数
  • 从随机源创建初始向量

mcrypt_create_iv

(PHP 4, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_create_iv — 从随机源创建初始向量

Warning

This function was DEPRECATED in PHP 7.1.0, and REMOVED in PHP 7.2.0.

Alternatives to this function include:

  • random_bytes()

说明

mcrypt_create_iv ( int $size , int $source = MCRYPT_DEV_URANDOM ) : string

从随机源创建初始向量。

初始向量只是为了给加密算法提供一个可用的种子， 所以它不需要安全保护， 你甚至可以随同密文一起发布初始向量也不会对安全性带来影响。

参数

size

初始向量大小。

source

初始向量数据来源。可选值有： MCRYPT_RAND （系统随机数生成器）, MCRYPT_DEV_RANDOM （从 /dev/random 文件读取数据） 和 MCRYPT_DEV_URANDOM （从 /dev/urandom 文件读取数据）。 在 Windows 平台，PHP 5.3.0 之前的版本中，仅支持 MCRYPT_RAND。

请注意，在 PHP 5.6.0 之前的版本中， 此参数的默认值为 MCRYPT_DEV_RANDOM。

Note: 需要注意的是，如果没有更多可用的用来产生随机数据的信息，那么 MCRYPT_DEV_RANDOM 可能进入阻塞状态。

返回值

返回初始向量。如果发生错误，则返回 false。

更新日志

版本 | 说明
5.6.0 | source 参数的默认值是 MCRYPT_DEV_URANDOM。
5.3.0 | MCRYPT_DEV_RANDOM 和 MCRYPT_DEV_URANDOM 在 Windows 平台也可用了。
5.3.0 | 不再需要提前调用 srand() 函数， 由本函数自动完成调用。

范例

Example #1 mcrypt_create_iv() 例程

<?php
    $size = mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB);
    $iv = mcrypt_create_iv($size, MCRYPT_DEV_RANDOM);
?>

参见

  • » http://www.ciphersbyritter.com/GLOSSARY.HTM#IV
  • » http://www.quadibloc.com/crypto/co0409.htm
  • Applied Cryptography by Schneier (ISBN 0-471-11709-9) 9.3 节。
  • random_bytes() - Generates cryptographically secure pseudo-random bytes


使用给定参数解密密文

  • ? mcrypt_create_iv
  • mcrypt_ecb ?
  • PHP Manual
  • Mcrypt 函数
  • 使用给定参数解密密文

mcrypt_decrypt

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_decrypt — 使用给定参数解密密文

Warning

本函数已自 PHP 7.1.0 起废弃并将自 PHP 7.2.0 起移除。强烈建议不要使用本函数。

说明

mcrypt_decrypt ( string $cipher , string $key , string $data , string $mode , string $iv = ? ) : string

解密 data 并返回明文。

参数

cipher

MCRYPT_ciphername 常量中的一个，或者是字符串值的算法名称。

key

数据加密密钥。 如果密钥长度不是加解密算法能够支持的有效长度， 那么会产生警告并且返回 false

data

要使用给定的 cipher 和 mode 解密的数据。 如果数据大小不是 n * 分组大小，则在其后追加 '\0' 来补齐。

mode

MCRYPT_MODE_modename 常量中的一个，或以下字符串中的一个："ecb"，"cbc"，"cfb"，"ofb"，"nofb" 和 "stream"。

iv

Used for the initialization in CBC, CFB, OFB modes, and in some algorithms in STREAM mode. If the provided IV size is not supported by the chaining mode or no IV was provided, but the chaining mode requires one, the function will emit a warning and return false.

返回值

以字符串格式返回解密后的数据， 或者在失败时返回 false。

更新日志

版本 | 说明
5.6.0 | 不再接受无效长度的 key and iv 参数。 如果参数长度无效，则 mcrypt_decrypt() 函数会产生警告并且返回 false。 之前版本中，对于长度不足的密钥和初始向量会在其后补齐 '\0' 使其达到有效长度。

参见

  • mcrypt_encrypt() - 使用给定参数加密明文


已废弃：使用 ECB 模式加解密数据

  • ? mcrypt_decrypt
  • mcrypt_enc_get_algorithms_name ?
  • PHP Manual
  • Mcrypt 函数
  • 已废弃：使用 ECB 模式加解密数据

mcrypt_ecb

(PHP 4, PHP 5)

mcrypt_ecb — 已废弃：使用 ECB 模式加解密数据

Warning

This function was DEPRECATED in PHP 5.5.0, and REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • mcrypt_decrypt()
  • mcrypt_encrypt()

说明

mcrypt_ecb ( int $cipher , string $key , string $data , int $mode ) : string
mcrypt_ecb ( string $cipher , string $key , string $data , int $mode , string $iv = ? ) : string

第一个原型是针对 libmcrypt 2.2.x 的， 第二个原型是针对 libmcrypt 2.4.x 及更高版本的。 mode 可选值为： MCRYPT_ENCRYPT 或 MCRYPT_DECRYPT。


返回打开的算法名称

  • ? mcrypt_ecb
  • mcrypt_enc_get_block_size ?
  • PHP Manual
  • Mcrypt 函数
  • 返回打开的算法名称

mcrypt_enc_get_algorithms_name

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_algorithms_name — 返回打开的算法名称

Warning

本函数已自 PHP 7.1.0 起废弃并将自 PHP 7.2.0 起移除。强烈建议不要使用本函数。

说明

mcrypt_enc_get_algorithms_name ( resource $td ) : string

本函数返回算法名称。

参数

td

加密描述符。

返回值

以字符串格式返回打开的加密算法名称。

范例

Example #1 mcrypt_enc_get_algorithms_name() 例程

<?php
$td = mcrypt_module_open(MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_algorithms_name($td). "\n";

$td = mcrypt_module_open('cast-256', '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_algorithms_name($td). "\n";
?>

以上例程会输出：

CAST-256
CAST-256


返回打开的算法的分组大小

  • ? mcrypt_enc_get_algorithms_name
  • mcrypt_enc_get_iv_size ?
  • PHP Manual
  • Mcrypt 函数
  • 返回打开的算法的分组大小

mcrypt_enc_get_block_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_block_size — 返回打开的算法的分组大小

Warning

本函数已自 PHP 7.1.0 起废弃并将自 PHP 7.2.0 起移除。强烈建议不要使用本函数。

说明

mcrypt_enc_get_block_size ( resource $td ) : int

获取打开的算法的分组大小。

参数

td

加密描述符。

返回值

返回指定算法的分组大小，以字节为单位。


返回打开的算法的初始向量大小

  • ? mcrypt_enc_get_block_size
  • mcrypt_enc_get_key_size ?
  • PHP Manual
  • Mcrypt 函数
  • 返回打开的算法的初始向量大小

mcrypt_enc_get_iv_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_iv_size — 返回打开的算法的初始向量大小

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_enc_get_iv_size ( resource $td ) : int

本函数返回由加密描述符指定的算法所使用的初始向量大小， 以字节为单位。 在 cbc，cfb 和 ofb 模式以及某些流模式算法中会用到初始向量。

参数

td

加密描述符。

返回值

返回初始向量大小。如果算法忽略初始向量，则返回 0。


返回打开的模式所能支持的最长密钥

  • ? mcrypt_enc_get_iv_size
  • mcrypt_enc_get_modes_name ?
  • PHP Manual
  • Mcrypt 函数
  • 返回打开的模式所能支持的最长密钥

mcrypt_enc_get_key_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_key_size — 返回打开的模式所能支持的最长密钥

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_enc_get_key_size ( resource $td ) : int

返回打开的模式所能支持的最长密钥，以字节为单位。

参数

td

加密描述符。

返回值

返回打开的模式所能支持的最长密钥，以字节为单位。


返回打开的模式的名称

  • ? mcrypt_enc_get_key_size
  • mcrypt_enc_get_supported_key_sizes ?
  • PHP Manual
  • Mcrypt 函数
  • 返回打开的模式的名称

mcrypt_enc_get_modes_name

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_modes_name — 返回打开的模式的名称

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_enc_get_modes_name ( resource $td ) : string

返回模式名称。

参数

td

加密描述符。

返回值

以字符串格式返回模式名称。

范例

Example #1 mcrypt_enc_get_modes_name() 例程

<?php
$td = mcrypt_module_open (MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_modes_name($td). "\n";

$td = mcrypt_module_open ('cast-256', '', 'ecb', '');
echo mcrypt_enc_get_modes_name($td). "\n";
?>

以上例程会输出：

CFB
ECB


以数组方式返回打开的算法所支持的密钥长度

  • ? mcrypt_enc_get_modes_name
  • mcrypt_enc_is_block_algorithm_mode ?
  • PHP Manual
  • Mcrypt 函数
  • 以数组方式返回打开的算法所支持的密钥长度

mcrypt_enc_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_get_supported_key_sizes — 以数组方式返回打开的算法所支持的密钥长度

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_enc_get_supported_key_sizes ( resource $td ) : array

获取打开的算法所支持的密钥长度。

参数

td

加密描述符。

返回值

返回由加密描述符指定的算法所能够支持的密钥长度。 如果该算法支持从 1 到 mcrypt_enc_get_key_size() 之间任意长度的密钥，则返回空数组。

范例

Example #1 mcrypt_enc_get_supported_key_sizes() 例程

<?php
    $td = mcrypt_module_open('rijndael-256', '', 'ecb', '');
    var_dump(mcrypt_enc_get_supported_key_sizes($td));
?>

以上例程会输出：

array(3) {
  [0]=>
  int(16)
  [1]=>
  int(24)
  [2]=>
  int(32)
}


检测打开的模式是否支持分组加密

  • ? mcrypt_enc_get_supported_key_sizes
  • mcrypt_enc_is_block_algorithm ?
  • PHP Manual
  • Mcrypt 函数
  • 检测打开的模式是否支持分组加密

mcrypt_enc_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_is_block_algorithm_mode — 检测打开的模式是否支持分组加密

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_enc_is_block_algorithm_mode ( resource $td ) : bool

打开的模式的算法是否支持分组加密 （例如： 如果是流模式，则返回 false， cbc，cfb，ofb 模式则返回 true）。

参数

td

加密描述符。

返回值

如果算法支持分组模式，返回 true， 反之返回 false。


检测打开模式的算法是否为分组算法

  • ? mcrypt_enc_is_block_algorithm_mode
  • mcrypt_enc_is_block_mode ?
  • PHP Manual
  • Mcrypt 函数
  • 检测打开模式的算法是否为分组算法

mcrypt_enc_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_is_block_algorithm — 检测打开模式的算法是否为分组算法

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_enc_is_block_algorithm ( resource $td ) : bool

打开模式的算法是否为分组算法。

参数

td

加密描述符。

返回值

如果是分组算法，返回 true， 如果是流模式，返回 false。


检测打开的模式是否以分组方式输出

  • ? mcrypt_enc_is_block_algorithm
  • mcrypt_enc_self_test ?
  • PHP Manual
  • Mcrypt 函数
  • 检测打开的模式是否以分组方式输出

mcrypt_enc_is_block_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_is_block_mode — 检测打开的模式是否以分组方式输出

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_enc_is_block_mode ( resource $td ) : bool

打开的模式是否以分组方式输出 （例如，对于 cbc 和 ecb 模式而言返回 true，对于 cfb 和流模式而言，返回 false）。

参数

td

加密描述符。

返回值

如果模式以字节分组（字节块）方式输出，返回 true， 如果是以字节方式输出，返回 false。


在打开的模块上进行自检

  • ? mcrypt_enc_is_block_mode
  • mcrypt_encrypt ?
  • PHP Manual
  • Mcrypt 函数
  • 在打开的模块上进行自检

mcrypt_enc_self_test

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_enc_self_test — 在打开的模块上进行自检

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_enc_self_test ( resource $td ) : int

在 td 指定的算法 上进行自检操作。

参数

td

加密描述符。

返回值

自检成功返回 0，失败则返回一个小于零的int。


使用给定参数加密明文

  • ? mcrypt_enc_self_test
  • mcrypt_generic_deinit ?
  • PHP Manual
  • Mcrypt 函数
  • 使用给定参数加密明文

mcrypt_encrypt

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_encrypt — 使用给定参数加密明文

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_encrypt ( string $cipher , string $key , string $data , string $mode , string $iv = ? ) : string

加密数据并返回密文。

参数

cipher

MCRYPT_ciphername 常量中的一个，或者是字符串值的算法名称。

key

加密密钥。 如果密钥长度不是该算法所能够支持的有效长度，则函数将会发出警告并返回 false

data

使用给定的 cipher 和 mode 加密的数据。 如果数据长度不是 n*分组大小，则在其后使用 '\0' 补齐。

返回的密文长度可能比 data 更大。

mode

MCRYPT_MODE_modename 常量中的一个，或以下字符串中的一个："ecb"，"cbc"，"cfb"，"ofb"，"nofb" 和 "stream"。

iv

Used for the initialization in CBC, CFB, OFB modes, and in some algorithms in STREAM mode. If the provided IV size is not supported by the chaining mode or no IV was provided, but the chaining mode requires one, the function will emit a warning and return false.

返回值

以字符串方式返回密文， 或者在失败时返回 false。

更新日志

版本 | 说明
5.6.0 | 不再接受无效长度的 key and iv 参数。 如果参数长度无效，则 mcrypt_decrypt() 函数会产生警告并且返回 false。 之前版本中，对于长度不足的密钥和初始向量会在其后补齐 '\0' 使其达到有效长度。

范例

Example #1 mcrypt_encrypt() 例程

<?php
    # --- 加密 ---

    # 密钥应该是随机的二进制数据，
    # 开始使用 scrypt, bcrypt 或 PBKDF2 将一个字符串转换成一个密钥
    # 密钥是 16 进制字符串格式
    $key = pack('H*', "bcb04b7e103a0cd8b54763051cef08bc55abe029fdebae5e1d417e2ffb2a00a3");

    # 显示 AES-128, 192, 256 对应的密钥长度：
    #16，24，32 字节。
    $key_size =  strlen($key);
    echo "Key size: " . $key_size . "\n";

    $plaintext = "This string was AES-256 / CBC / ZeroBytePadding encrypted.";

    # 为 CBC 模式创建随机的初始向量
    $iv_size = mcrypt_get_iv_size(MCRYPT_RIJNDAEL_128, MCRYPT_MODE_CBC);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);

    # 创建和 AES 兼容的密文（Rijndael 分组大小 = 128）
    # 仅适用于编码后的输入不是以 00h 结尾的
    # （因为默认是使用 0 来补齐数据）
    $ciphertext = mcrypt_encrypt(MCRYPT_RIJNDAEL_128, $key,
                                 $plaintext, MCRYPT_MODE_CBC, $iv);

    # 将初始向量附加在密文之后，以供解密时使用
    $ciphertext = $iv . $ciphertext;

    # 对密文进行 base64 编码
    $ciphertext_base64 = base64_encode($ciphertext);

    echo  $ciphertext_base64 . "\n";

    # === 警告 ===

    # 密文并未进行完整性和可信度保护，
    # 所以可能遭受 Padding Oracle 攻击。

    # --- 解密 ---

    $ciphertext_dec = base64_decode($ciphertext_base64);

    # 初始向量大小，可以通过 mcrypt_get_iv_size() 来获得
    $iv_dec = substr($ciphertext_dec, 0, $iv_size);

    # 获取除初始向量外的密文
    $ciphertext_dec = substr($ciphertext_dec, $iv_size);

    # 可能需要从明文末尾移除 0
    $plaintext_dec = mcrypt_decrypt(MCRYPT_RIJNDAEL_128, $key,
                                    $ciphertext_dec, MCRYPT_MODE_CBC, $iv_dec);

    echo  $plaintext_dec . "\n";
?>

以上例程会输出：

Key size: 32
ENJW8mS2KaJoNB5E5CoSAAu0xARgsR1bdzFWpEn+poYw45q+73az5kYi4j+0haevext1dGrcW8Qi59txfCBV8BBj3bzRP3dFCp3CPQSJ8eU=
This string was AES-256 / CBC / ZeroBytePadding encrypted.

参见

  • mcrypt_decrypt() - 使用给定参数解密密文
  • mcrypt_module_open() - 打开算法和模式对应的模块


对加密模块进行清理工作

  • ? mcrypt_encrypt
  • mcrypt_generic_end ?
  • PHP Manual
  • Mcrypt 函数
  • 对加密模块进行清理工作

mcrypt_generic_deinit

(PHP 4 >= 4.0.7, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_generic_deinit — 对加密模块进行清理工作

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_generic_deinit ( resource $td ) : bool

本函数终止由加密描述符（td）指定的加密模块， 它会清理缓冲区，但是并不关闭模块。 要想关闭加密模块， 你需要自行调用 mcrypt_module_close() 函数。 （但是 PHP 会在脚本末尾为你关闭已打开的加密模块）

参数

td

加密描述符。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mcrypt_module_open() - 打开算法和模式对应的模块
  • mcrypt_generic_init() - 初始化加密所需的缓冲区


终止加密

  • ? mcrypt_generic_deinit
  • mcrypt_generic_init ?
  • PHP Manual
  • Mcrypt 函数
  • 终止加密

mcrypt_generic_end

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_generic_end — 终止加密

Warning

This function was DEPRECATED in PHP 5.3.0, and REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • mcrypt_generic_deinit()

说明

mcrypt_generic_end ( resource $td ) : bool
Warning

This alias was DEPRECATED in PHP 5.3.0, and REMOVED as of PHP 7.0.0.

Warning

请使用函数 mcrypt_generic_deinit() 来替代本函数， 因为当本函数和 mcrypt_module_close() 一起使用的时候， 可能会发生由重复释放缓冲区导致的崩溃。

本函数终止由加密描述符（td）指定的加密模块。 实际上，它会清理所有的缓冲区，并且关闭已经打开的模块。 如果发生错误，返回 false， 成功返回 true。


初始化加密所需的缓冲区

  • ? mcrypt_generic_end
  • mcrypt_generic ?
  • PHP Manual
  • Mcrypt 函数
  • 初始化加密所需的缓冲区

mcrypt_generic_init

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_generic_init — 初始化加密所需的缓冲区

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_generic_init ( resource $td , string $key , string $iv ) : int

在每次调用 mcrypt_generic() 或 mdecrypt_generic() 函数之前必须调用本函数。

参数

td

加密描述符。

key

调用 mcrypt_enc_get_key_size() 函数获得的密钥最大长度。 小于最大长度的数值都被视为非法参数。

iv

通常情况下，向量大小等于算法的分组大小， 但是你应该通过 mcrypt_enc_get_iv_size() 函数 来获得这个值。在 ECB 模式下，初始向量会被忽略， 在 CFB，CBC，STREAM，nOFB 和 OFB 模式下，必须提供初始向量。 初始向量要求是随机的，并且是唯一的（不需要是安全的）。 加密和解密必须使用相同的初始向量。 如果你不想使用初始向量，请将其设置为全 0 值，但是不建议你这么做。

返回值

如果发生错误，将会返回负数： -3 表示密钥长度有误，-4 表示内存分配失败， 其他值表示未知错误， 同时会显示对应的警告信息。 如果传入参数不正确，返回 false。

参见

  • mcrypt_module_open() - 打开算法和模式对应的模块


加密数据

  • ? mcrypt_generic_init
  • mcrypt_get_block_size ?
  • PHP Manual
  • Mcrypt 函数
  • 加密数据

mcrypt_generic

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_generic — 加密数据

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_generic ( resource $td , string $data ) : string

本函数用来加密数据。 传入数据长度必须是 n * 分组大小，否则需要后补 "\0"。 本函数返回加密后的数据。 注意，根据数据补齐不同， 返回的数据可能比输入的数据长度有所增加。

如果你需要把加密后的数据保存到数据库， 请确保保存 mcrypt_generic 返回的完整的字符串， 否则将无法正确解密。 如果原始数据有 10 个字符，分组大小为 8 （使用 mcrypt_enc_get_block_size() 获取分组大小）， 则数据库中至少需要 16 个字符来保存数据。 请注意 mdecrypt_generic() 函数返回的数据也会是 16 个字符。 使用 rtrim($str, "\0") 移除字符串末尾的 0 。

如果你在例如 MySQL 这样的数据库中存储数据， 请注意 varchar 类型的字段会在插入数据时自动移除字符串末尾的"空格"。 由于加密后的数据可能是以空格（ASCII 32）结尾， 这种特性会导致数据损坏。 请使用 tinyblob/tinytext（或 larger）字段来存储加密数据。

参数

td

加密描述符。

在调用本函数之前， 请使用 mcrypt_generic_init() 函数初始化加密句柄。 在加密完成之后， 需要调用 mcrypt_generic_deinit() 函数进行必要的清理工作。 请参见 mcrypt_module_open() 。

data

要加密的数据。

返回值

返回加密后的数据。

参见

  • mdecrypt_generic() - 解密数据
  • mcrypt_generic_init() - 初始化加密所需的缓冲区
  • mcrypt_generic_deinit() - 对加密模块进行清理工作


获得加密算法的分组大小

  • ? mcrypt_generic
  • mcrypt_get_cipher_name ?
  • PHP Manual
  • Mcrypt 函数
  • 获得加密算法的分组大小

mcrypt_get_block_size

(PHP 4, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_get_block_size — 获得加密算法的分组大小

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_get_block_size ( int $cipher ) : int
mcrypt_get_block_size ( string $cipher , string $mode ) : int

第一个原型针对 libmcrypt 2.2.x， 第二个原型针对 libmcrypt 2.4.x 或 2.5.x。

mcrypt_get_block_size() 用来获取 cipher （其中包括了加密模式） 加密算法分组大小。

mcrypt_enc_get_block_size() 函数更加有用， 因为它可以使用 mcrypt_module_open() 函数所返回的资源。

参数

cipher

MCRYPT_ciphername 常量中的一个，或者是字符串值的算法名称。

mode

MCRYPT_MODE_modename 常量中的一个，或以下字符串中的一个："ecb"，"cbc"，"cfb"，"ofb"，"nofb" 和 "stream"。

返回值

返回以字节为单位的此算法的分组数据大小。 或者在失败时返回 false。

范例

Example #1 mcrypt_get_block_size() 例程

在 libmcrypt 2.4.x 和 2.5.x 下 如何使用本函数。

<?php

echo mcrypt_get_block_size('tripledes', 'ecb'); // 8

?>

参见

  • mcrypt_get_key_size() - 获取指定加密算法的密钥大小
  • mcrypt_enc_get_block_size() - 返回打开的算法的分组大小
  • mcrypt_encrypt() - 使用给定参数加密明文


获取加密算法名称

  • ? mcrypt_get_block_size
  • mcrypt_get_iv_size ?
  • PHP Manual
  • Mcrypt 函数
  • 获取加密算法名称

mcrypt_get_cipher_name

(PHP 4, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_get_cipher_name — 获取加密算法名称

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_get_cipher_name ( int $cipher ) : string
mcrypt_get_cipher_name ( string $cipher ) : string

mcrypt_get_cipher_name() 用来获取加密算法名称。

libmcrypt 2.2.x 中，mcrypt_get_cipher_name() 接受整数表达的加密算法， libmcrypt 2.4.x 及更高版本中，它接受字符串表达的加密算法名称， 返回的都是字符串表达的名称，如果算法不存在则返回 false。

参数

cipher

MCRYPT_ciphername 常量中的一个，或者是字符串值的算法名称。

返回值

本函数返回加密算法名称， 如果算法不存在返回 false。

范例

Example #1 mcrypt_get_cipher_name() 例程

<?php
   $cipher = MCRYPT_TripleDES;

   echo mcrypt_get_cipher_name($cipher);
?>

以上例程会输出：

3DES


返回指定算法/模式组合的初始向量大小

  • ? mcrypt_get_cipher_name
  • mcrypt_get_key_size ?
  • PHP Manual
  • Mcrypt 函数
  • 返回指定算法/模式组合的初始向量大小

mcrypt_get_iv_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_get_iv_size — 返回指定算法/模式组合的初始向量大小

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_get_iv_size ( string $cipher , string $mode ) : int

获取由 cipher/mode 参数指定的初始向量大小。

mcrypt_enc_get_iv_size() 更加有用， 因为它使用由 mcrypt_module_open() 返回的资源作为参数。

参数

cipher

MCRYPT_ciphername 常量中的一个，或者是字符串值的算法名称。

mode

MCRYPT_MODE_modename 常量中的一个，或以下字符串中的一个："ecb"，"cbc"，"cfb"，"ofb"，"nofb" 和 "stream"。

由于 ECB 模式不使用初始向量，所以会忽略它。 在加密和解密的过程中， 你需要使用相同的初始向量（想象成：开始点）。

返回值

返回初始向量的大小，以字节为单位。 如果发生错误，返回 false。 如果指定的算法/模式不需要初始向量，返回 0。

范例

Example #1 mcrypt_get_iv_size() 例程

<?php
    echo mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB) . "\n";

    echo mcrypt_get_iv_size('des', 'ecb') . "\n";
?>

参见

  • mcrypt_get_block_size() - 获得加密算法的分组大小
  • mcrypt_enc_get_iv_size() - 返回打开的算法的初始向量大小
  • mcrypt_create_iv() - 从随机源创建初始向量


获取指定加密算法的密钥大小

  • ? mcrypt_get_iv_size
  • mcrypt_list_algorithms ?
  • PHP Manual
  • Mcrypt 函数
  • 获取指定加密算法的密钥大小

mcrypt_get_key_size

(PHP 4, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_get_key_size — 获取指定加密算法的密钥大小

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_get_key_size ( int $cipher ) : int
mcrypt_get_key_size ( string $cipher , string $mode ) : int

第一个原型是针对 libmcrypt 2.2.x 的， 第二个原型是针对 libmcrypt 2.4.x 或 2.5.x 的。

mcrypt_get_key_size() 用来获取 由 cipher 所指定的算法和模式所需的密钥长度。

mcrypt_enc_get_key_size() 更加有用， 因为它使用由 mcrypt_module_open() 返回的资源。

参数

cipher

MCRYPT_ciphername 常量中的一个，或者是字符串值的算法名称。

mode

MCRYPT_MODE_modename 常量中的一个，或以下字符串中的一个："ecb"，"cbc"，"cfb"，"ofb"，"nofb" 和 "stream"。

返回值

返回算法所支持的最大密钥大小，以字节为单位。 或者在失败时返回 false。

范例

Example #1 mcrypt_get_key_size() 例程

<?php
    echo mcrypt_get_key_size('tripledes', 'ecb');
?>

在 libmcrypt 2.4.x 或 2.5.x 版本中， 如果使用本函数。

以上例程会输出：

24

参见

  • mcrypt_get_block_size() - 获得加密算法的分组大小
  • mcrypt_enc_get_key_size() - 返回打开的模式所能支持的最长密钥
  • mcrypt_encrypt() - 使用给定参数加密明文


获取支持的加密算法

  • ? mcrypt_get_key_size
  • mcrypt_list_modes ?
  • PHP Manual
  • Mcrypt 函数
  • 获取支持的加密算法

mcrypt_list_algorithms

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_list_algorithms — 获取支持的加密算法

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_list_algorithms ( string $lib_dir = ini_get("mcrypt.algorithms_dir") ) : array

获取 lib_dir 中 包含的受支持的算法。

参数

lib_dir

指定算法所在的位置。 如果未指定，将使用 php.ini 中的 mcrypt.algorithms_dir 指示所指定的位置。

返回值

以数组方式返回所有受支持的算法。

范例

Example #1 mcrypt_list_algorithms() 例程

<?php
$algorithms = mcrypt_list_algorithms();
print_r($algorithms);
?>

以上例程的输出类似于：

Array
(
    [0] => cast-128
    [1] => gost
    [2] => rijndael-128
    [3] => twofish
    [4] => arcfour
    [5] => cast-256
    [6] => loki97
    [7] => rijndael-192
    [8] => saferplus
    [9] => wake
    [10] => blowfish-compat
    [11] => des
    [12] => rijndael-256
    [13] => serpent
    [14] => xtea
    [15] => blowfish
    [16] => enigma
    [17] => rc2
    [18] => tripledes
)


获取所支持的模式

  • ? mcrypt_list_algorithms
  • mcrypt_module_close ?
  • PHP Manual
  • Mcrypt 函数
  • 获取所支持的模式

mcrypt_list_modes

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_list_modes — 获取所支持的模式

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_list_modes ( string $lib_dir = ini_get("mcrypt.modes_dir") ) : array

获取 lib_dir 中 包含的受支持的模式。

参数

lib_dir

指定模式所在的位置。 如果未指定，将使用 php.ini 中的 mcrypt.modes_dir 指示所指定的位置。

返回值

以数组形式返回受支持的模式。

范例

Example #1 mcrypt_list_modes() 例程

<?php
    $modes = mcrypt_list_modes();

    foreach ($modes as $mode) {
        echo "$mode <br />\n";
    }
?>

本例程列出在默认目录中 所有受支持的模式。 如果在 php.ini 中未指定 mcrypt.modes_dir， 则使用默认的 mcrypt 库 安装目录（/usr/local/lib/libmcrypt）。


关闭加密模块

  • ? mcrypt_list_modes
  • mcrypt_module_get_algo_block_size ?
  • PHP Manual
  • Mcrypt 函数
  • 关闭加密模块

mcrypt_module_close

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_close — 关闭加密模块

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_close ( resource $td ) : bool

关闭加密模块。

参数

td

加密描述符。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mcrypt_module_open() - 打开算法和模式对应的模块


返回指定算法的分组大小

  • ? mcrypt_module_close
  • mcrypt_module_get_algo_key_size ?
  • PHP Manual
  • Mcrypt 函数
  • 返回指定算法的分组大小

mcrypt_module_get_algo_block_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_get_algo_block_size — 返回指定算法的分组大小

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_get_algo_block_size ( string $algorithm , string $lib_dir = ? ) : int

返回指定算法的分组大小。

参数

algorithm

算法名称。

lib_dir

可选参数 lib_dir ， 表示在操作系统上包含模式模块的路径。

返回值

返回指定算法的分组大小，以字节为单位。


获取打开模式所支持的最大密钥大小

  • ? mcrypt_module_get_algo_block_size
  • mcrypt_module_get_supported_key_sizes ?
  • PHP Manual
  • Mcrypt 函数
  • 获取打开模式所支持的最大密钥大小

mcrypt_module_get_algo_key_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_get_algo_key_size — 获取打开模式所支持的最大密钥大小

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_get_algo_key_size ( string $algorithm , string $lib_dir = ? ) : int

获取打开模式所支持的最大密钥大小。

参数

algorithm

算法名称。

lib_dir

可选参数， 表示在操作系统上包含模式模块的路径。

返回值

本函数返回算法所支持的最大密钥大小， 以字节为单位。


以数组形式返回打开的算法所支持的密钥大小

  • ? mcrypt_module_get_algo_key_size
  • mcrypt_module_is_block_algorithm_mode ?
  • PHP Manual
  • Mcrypt 函数
  • 以数组形式返回打开的算法所支持的密钥大小

mcrypt_module_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_get_supported_key_sizes — 以数组形式返回打开的算法所支持的密钥大小

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_get_supported_key_sizes ( string $algorithm , string $lib_dir = ? ) : array

以数组形式返回指定算法所支持的密钥大小。 如果从 1 到 mcrypt_module_get_algo_key_size() 的密钥大小都支持，则返回空数组。

参数

algorithm

算法名称。

lib_dir

可选参数， 表示在操作系统上包含算法模块的路径。

返回值

以数组形式返回指定算法所支持的密钥大小。 如果从 1 到 mcrypt_module_get_algo_key_size() 的密钥大小都支持，则返回空数组。

参见

  • mcrypt_enc_get_supported_key_sizes() - 以数组方式返回打开的算法所支持的密钥长度


返回指定模块是否是分组加密模式

  • ? mcrypt_module_get_supported_key_sizes
  • mcrypt_module_is_block_algorithm ?
  • PHP Manual
  • Mcrypt 函数
  • 返回指定模块是否是分组加密模式

mcrypt_module_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_is_block_algorithm_mode — 返回指定模块是否是分组加密模式

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_is_block_algorithm_mode ( string $mode , string $lib_dir = ? ) : bool

对于分组加密模式，返回 true， 反之返回 false。 （例如，对于 STREAM 模式返回 false，对于 cbc，cfb，ofb 返回 true）

参数

mode

模式。

lib_dir

可选参数， 表示在操作系统上包含算法模块的路径。

返回值

对于分组加密模式，返回 true， 反之返回 false。 （例如，对于 STREAM 模式返回 false，对于 cbc，cfb，ofb 返回 true）


检测指定算法是否为分组加密算法

  • ? mcrypt_module_is_block_algorithm_mode
  • mcrypt_module_is_block_mode ?
  • PHP Manual
  • Mcrypt 函数
  • 检测指定算法是否为分组加密算法

mcrypt_module_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_is_block_algorithm — 检测指定算法是否为分组加密算法

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_is_block_algorithm ( string $algorithm , string $lib_dir = ? ) : bool

如果指定算法是分组加密算法，返回 true， 反之返回 false。

参数

algorithm

要检测的算法。

lib_dir

可选参数 lib_dir， 表示在操作系统上包含算法模块的路径。

返回值

如果指定算法是分组加密算法，返回 true， 反之返回 false。


检测指定模式是否以分组方式输出

  • ? mcrypt_module_is_block_algorithm
  • mcrypt_module_open ?
  • PHP Manual
  • Mcrypt 函数
  • 检测指定模式是否以分组方式输出

mcrypt_module_is_block_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_is_block_mode — 检测指定模式是否以分组方式输出

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_is_block_mode ( string $mode , string $lib_dir = ? ) : bool

如果模式是以字节块（分组）方式输出，则返回 true， 如果只是以字节方式输出，则返回 false。 （例如，对于 cbc 和 ecb 模式，返回 true，对于 cfb 和 stream 模式，返回 false）

参数

mode

MCRYPT_MODE_modename 常量中的一个，或以下字符串中的一个："ecb"，"cbc"，"cfb"，"ofb"，"nofb" 和 "stream"。

lib_dir

可选参数 lib_dir ， 表示在操作系统上包含模式模块的路径。

返回值

如果模式是以字节块（分组）方式输出，则返回 true， 如果只是以字节方式输出，则返回 false。 （例如，对于 cbc 和 ecb 模式，返回 true，对于 cfb 和 stream 模式，返回 false）


打开算法和模式对应的模块

  • ? mcrypt_module_is_block_mode
  • mcrypt_module_self_test ?
  • PHP Manual
  • Mcrypt 函数
  • 打开算法和模式对应的模块

mcrypt_module_open

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_open — 打开算法和模式对应的模块

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_open ( string $algorithm , string $algorithm_directory , string $mode , string $mode_directory ) : resource

本函数打开指定算法和模式对应的模块。 算法名称可以是字符串，例如 "twofish"， 也可以是 MCRYPT_ciphername 常量。 调用 mcrypt_module_close() 函数可以关闭模块。

参数

algorithm

MCRYPT_ciphername 常量中的一个，或者是字符串值的算法名称。

algorithm_directory

algorithm_directory 参数指示加密模块的位置。 如果你提供此参数，则使用你指定的值。 如果将此参数设置为空字符串（""），将使用 php.ini 中的 mcrypt.algorithms_dir 。 如果不指定此参数，则使用 libmcrypt 的编译路径 （通常是 /usr/local/lib/libmcrypt）。

mode

MCRYPT_MODE_modename 常量中的一个，或以下字符串中的一个："ecb"，"cbc"，"cfb"，"ofb"，"nofb" 和 "stream"。

mode_directory

algorithm_directory 参数指示加密模式的位置。 如果你提供此参数，则使用你指定的值。 如果将此参数设置为空字符串（""），将使用 php.ini 中的 mcrypt.modes_dir 。 如果不指定此参数，则使用 libmcrypt 的编译路径 （通常是 /usr/local/lib/libmcrypt）。

返回值

成功则返回加密描述符，如果发生错误则返回 false。

范例

Example #1 mcrypt_module_open() 例程

<?php
    $td = mcrypt_module_open(MCRYPT_DES, '',
        MCRYPT_MODE_ECB, '/usr/lib/mcrypt-modes');

    $td = mcrypt_module_open('rijndael-256', '', 'ofb', '');
?>

例程中的第一行从默认目录打开 DES 加密算法， 从 /usr/lib/mcrypt-modes 目录打开 ECB 模式。 第二个示例中，使用字符串形式表示算法和模式， 这种形式仅适用于 libmcrypt 2.4.x 或 2.5.x 版本。

Example #2 在加密中使用 mcrypt_module_open()

<?php
    /* 打开加密算法和模式 */
    $td = mcrypt_module_open('rijndael-256', '', 'ofb', '');

    /* 创建初始向量，并且检测密钥长度。
     * Windows 平台请使用 MCRYPT_RAND。 */
    $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td), MCRYPT_DEV_RANDOM);
    $ks = mcrypt_enc_get_key_size($td);

    /* 创建密钥 */
    $key = substr(md5('very secret key'), 0, $ks);

    /* 初始化加密 */
    mcrypt_generic_init($td, $key, $iv);

    /* 加密数据 */
    $encrypted = mcrypt_generic($td, 'This is very important data');

    /* 结束加密，执行清理工作 */
    mcrypt_generic_deinit($td);

    /* 初始化解密模块 */
    mcrypt_generic_init($td, $key, $iv);

    /* 解密数据 */
    $decrypted = mdecrypt_generic($td, $encrypted);

    /* 结束解密，执行清理工作，并且关闭模块 */
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);

    /* 显示文本 */
    echo trim($decrypted) . "\n";
?>

参见

  • mcrypt_module_close() - 关闭加密模块
  • mcrypt_generic() - 加密数据
  • mdecrypt_generic() - 解密数据
  • mcrypt_generic_init() - 初始化加密所需的缓冲区
  • mcrypt_generic_deinit() - 对加密模块进行清理工作


在指定模块上执行自检

  • ? mcrypt_module_open
  • mcrypt_ofb ?
  • PHP Manual
  • Mcrypt 函数
  • 在指定模块上执行自检

mcrypt_module_self_test

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mcrypt_module_self_test — 在指定模块上执行自检

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mcrypt_module_self_test ( string $algorithm , string $lib_dir = ? ) : bool

在指定模块上执行自检。

参数

algorithm

MCRYPT_ciphername 常量中的一个，或者是字符串值的算法名称。

lib_dir

可选参数 lib_dir， 表示包含加密算法模块的路径。

返回值

自检成功返回 true， 自检失败返回 false。

范例

Example #1 mcrypt_module_self_test() 例程

<?php
var_dump(mcrypt_module_self_test(MCRYPT_RIJNDAEL_128)) . "\n";
var_dump(mcrypt_module_self_test(MCRYPT_BOGUS_CYPHER));
?>

以上例程会输出：

bool(true)
bool(false)


使用 OFB 模式加密/解密数据

  • ? mcrypt_module_self_test
  • mdecrypt_generic ?
  • PHP Manual
  • Mcrypt 函数
  • 使用 OFB 模式加密/解密数据

mcrypt_ofb

(PHP 4, PHP 5)

mcrypt_ofb — 使用 OFB 模式加密/解密数据

Warning

This function was DEPRECATED in PHP 5.5.0, and REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • mcrypt_decrypt()
  • mcrypt_encrypt()

说明

mcrypt_ofb ( int $cipher , string $key , string $data , int $mode , string $iv ) : string
mcrypt_ofb ( string $cipher , string $key , string $data , int $mode , string $iv = ? ) : string

第一个原型是针对 libmcrypt 2.2.x 的， 第二个原型是针对 libmcrypt 2.4.x 及更高版本的。 mode 可选值为： MCRYPT_ENCRYPT 或 MCRYPT_DECRYPT。


解密数据

  • ? mcrypt_ofb
  • Mhash ?
  • PHP Manual
  • Mcrypt 函数
  • 解密数据

mdecrypt_generic

(PHP 4 >= 4.0.2, PHP 5, PHP 7 < 7.2.0, PECL mcrypt >= 1.0.0)

mdecrypt_generic — 解密数据

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

mdecrypt_generic ( resource $td , string $data ) : string

解密数据。 请注意，由于存在数据补齐的情况， 返回字符串的长度可能和明文的长度不相等。

参数

td

由 mcrypt_module_open() 函数创建的加密描述符。

data

密文。

范例

Example #1 mdecrypt_generic() 例程

<?php
    /* 数据 */
    $key = 'this is a very long key, even too long for the cipher';
    $plain_text = 'very important data';

    /* 打开加密模块，并且创建初始向量 */
    $td = mcrypt_module_open('des', '', 'ecb', '');
    $key = substr($key, 0, mcrypt_enc_get_key_size($td));
    $iv_size = mcrypt_enc_get_iv_size($td);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);

    /* 初始化加密句柄 */
    if (mcrypt_generic_init($td, $key, $iv) != -1) {

        /* 加密数据 */
        $c_t = mcrypt_generic($td, $plain_text);
        mcrypt_generic_deinit($td);

        /* 为解密重新初始化缓冲区 */
        mcrypt_generic_init($td, $key, $iv);
        $p_t = mdecrypt_generic($td, $c_t);

        /* 执行清理工作 */
        mcrypt_generic_deinit($td);
        mcrypt_module_close($td);
    }

    if (strncmp($p_t, $plain_text, strlen($plain_text)) == 0) {
        echo "ok\n";
    } else {
        echo "error\n";
    }
?>

上例中演示了如何检测 解密后的数据是否和原始明文长度一致。 需要着重提醒的是，在对数据进行机密之前， 必须使用 mcrypt_generic_init() 函数来重新初始化缓冲区。

调用本函数之前， 必须使用密钥和初始向量来调用 mcrypt_generic_init() 函数 对解密句柄进行初始化。 加解密工作完成之后，需要调用 mcrypt_generic_deinit() 来释放加解密缓冲区。 例程请参见 mcrypt_module_open()。

参见

  • mcrypt_generic() - 加密数据
  • mcrypt_generic_init() - 初始化加密所需的缓冲区
  • mcrypt_generic_deinit() - 对加密模块进行清理工作


Mhash

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Mhash 函数
    • mhash_count — Gets the highest available hash ID
    • mhash_get_block_size — Gets the block size of the specified hash
    • mhash_get_hash_name — Gets the name of the specified hash
    • mhash_keygen_s2k — Generates a key
    • mhash — Computes hash


简介

These functions are intended to work with » mhash. Mhash can be used to create checksums, message digests, message authentication codes, and more.

This is an interface to the mhash library. Mhash supports a wide variety of hash algorithms such as MD5, SHA1, GOST, and many others. For a complete list of supported hashes, refer to the constants page. The general rule is that you can access the hash algorithm from PHP with MHASH_hashname. For example, to access TIGER you use the PHP constant MHASH_TIGER.

Note:

This extension is obsoleted by Hash.

Note:

As of PHP 7.0.0 the Mhash extension has been fully integrated into the Hash extension. Therefore, it is no longer possible to detect Mhash support with extension_loaded(); use function_exists() instead. Furthermore, Mhash is no longer reported by get_loaded_extensions() and related features.


需求

To use it, download the mhash distribution from » its web site and follow the included installation instructions.


安装

You need to compile PHP with the --with-mhash[=DIR] parameter to enable this extension. DIR is the mhash installation directory.

As of PHP 5.3.0, the mhash extension is emulated thru the Hash extension. This makes the mhash installation directory have no effect, and requires the hash extension enabled to make the mhash support available.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Here is a list of hashes which are currently supported by mhash. If a hash is not listed here, but it is listed in the mhash documentation as supported, you can safely assume that this documentation is outdated.

  • MHASH_ADLER32
  • MHASH_CRC32
  • MHASH_CRC32B
  • MHASH_GOST
  • MHASH_HAVAL128
  • MHASH_HAVAL160
  • MHASH_HAVAL192
  • MHASH_HAVAL224
  • MHASH_HAVAL256
  • MHASH_MD2
  • MHASH_MD4
  • MHASH_MD5
  • MHASH_RIPEMD128
  • MHASH_RIPEMD256
  • MHASH_RIPEMD320
  • MHASH_SHA1
  • MHASH_SHA192
  • MHASH_SHA224
  • MHASH_SHA256
  • MHASH_SHA384
  • MHASH_SHA512
  • MHASH_SNEFRU128
  • MHASH_SNEFRU256
  • MHASH_TIGER
  • MHASH_TIGER128
  • MHASH_TIGER160
  • MHASH_WHIRLPOOL


范例

Example #1 Computes the MD5 digest and hmac and print it out as hex

<?php
$input = "what do ya want for nothing?";
$hash = mhash(MHASH_MD5, $input);
echo "The hash is " . bin2hex($hash) . "<br />\n";
$hash = mhash(MHASH_MD5, $input, "Jefe");
echo "The hmac is " . bin2hex($hash) . "<br />\n";
?>

以上例程会输出：

The hash is d03cb659cbf9192dcd066272249f8412
The hmac is 750c783e6ab0b503eaa86e310a5db738


Mhash 函数

Table of Contents

  • mhash_count — Gets the highest available hash ID
  • mhash_get_block_size — Gets the block size of the specified hash
  • mhash_get_hash_name — Gets the name of the specified hash
  • mhash_keygen_s2k — Generates a key
  • mhash — Computes hash


Gets the highest available hash ID

  • ? Mhash 函数
  • mhash_get_block_size ?
  • PHP Manual
  • Mhash 函数
  • Gets the highest available hash ID

mhash_count

(PHP 4, PHP 5, PHP 7, PHP 8)

mhash_count — Gets the highest available hash ID

说明

mhash_count ( ) : int

Gets the highest available hash ID.

返回值

Returns the highest available hash ID. Hashes are numbered from 0 to this hash ID.

范例

Example #1 Traversing all hashes

<?php

$nr = mhash_count();

for ($i = 0; $i <= $nr; $i++) {
    echo sprintf("The blocksize of %s is %d\n",
        mhash_get_hash_name($i),
        mhash_get_block_size($i));
}
?>


Gets the block size of the specified hash

  • ? mhash_count
  • mhash_get_hash_name ?
  • PHP Manual
  • Mhash 函数
  • Gets the block size of the specified hash

mhash_get_block_size

(PHP 4, PHP 5, PHP 7, PHP 8)

mhash_get_block_size — Gets the block size of the specified hash

说明

mhash_get_block_size ( int $algo ) : int|false

Gets the size of a block of the specified algo.

参数

algo

The hash ID. One of the MHASH_hashname constants.

返回值

Returns the size in bytes or false, if the algo does not exist.

范例

Example #1 mhash_get_block_size() Example

<?php

echo mhash_get_block_size(MHASH_MD5); // 16

?>


Gets the name of the specified hash

  • ? mhash_get_block_size
  • mhash_keygen_s2k ?
  • PHP Manual
  • Mhash 函数
  • Gets the name of the specified hash

mhash_get_hash_name

(PHP 4, PHP 5, PHP 7, PHP 8)

mhash_get_hash_name — Gets the name of the specified hash

说明

mhash_get_hash_name ( int $algo ) : string|false

Gets the name of the specified algo.

参数

algo

The hash ID. One of the MHASH_hashname constants.

返回值

Returns the name of the hash or false, if the hash does not exist.

范例

Example #1 mhash_get_hash_name() Example

<?php

echo mhash_get_hash_name(MHASH_MD5); // MD5

?>


Generates a key

  • ? mhash_get_hash_name
  • mhash ?
  • PHP Manual
  • Mhash 函数
  • Generates a key

mhash_keygen_s2k

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

mhash_keygen_s2k — Generates a key

说明

mhash_keygen_s2k ( int $algo , string $password , string $salt , int $length ) : string|false

Generates a key according to the given algo, using an user provided password.

This is the Salted S2K algorithm as specified in the OpenPGP document (» RFC 2440).

Keep in mind that user supplied passwords are not really suitable to be used as keys in cryptographic algorithms, since users normally choose keys they can write on keyboard. These passwords use only 6 to 7 bits per character (or less). It is highly recommended to use some kind of transformation (like this function) to the user supplied key.

参数

algo

The hash ID used to create the key. One of the MHASH_hashname constants.

password

An user supplied password.

salt

Must be different and random enough for every key you generate in order to create different keys. Because salt must be known when you check the keys, it is a good idea to append the key to it. Salt has a fixed length of 8 bytes and will be padded with zeros if you supply less bytes.

length

The key length, in bytes.

返回值

Returns the generated key as a string, or false on error.


Computes hash

  • ? mhash_keygen_s2k
  • OpenSSL ?
  • PHP Manual
  • Mhash 函数
  • Computes hash

mhash

(PHP 4, PHP 5, PHP 7, PHP 8)

mhash — Computes hash

说明

mhash ( int $algo , string $data , string|null $key = null ) : string|false

mhash() applies a hash function specified by algo to the data.

参数

algo

The hash ID. One of the MHASH_hashname constants.

data

The user input, as a string.

key

If specified, the function will return the resulting HMAC instead. HMAC is keyed hashing for message authentication, or simply a message digest that depends on the specified key. Not all algorithms supported in mhash can be used in HMAC mode.

返回值

Returns the resulting hash (also called digest) or HMAC as a string, or false on error.

更新日志

版本 | 说明
8.0.0 | key is now nullable.


OpenSSL

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
    • 目的检查标志
    • 非对称加密的填充标志
    • 密钥类型
    • PKCS7 标志/常量
    • Signature Algorithms
    • Ciphers
    • Version constants
    • Server Name Indication constants
  • 密钥/证书参数
  • 证书验证
  • OpenSSL 函数
    • openssl_cipher_iv_length — 获取密码iv长度
    • openssl_cms_decrypt — Decrypt a CMS message
    • openssl_cms_encrypt — Encrypt a CMS message
    • openssl_cms_read — Export the CMS file to an array of PEM certificates
    • openssl_cms_sign — Sign a file
    • openssl_cms_verify — Verify a CMS signature
    • openssl_csr_export_to_file — 将CSR导出到文件
    • openssl_csr_export — 将CSR作为字符串导出
    • openssl_csr_get_public_key — 返回CSR的公钥
    • openssl_csr_get_subject — 返回CSR的主题
    • openssl_csr_new — 生成一个 CSR
    • openssl_csr_sign — 用另一个证书签署 CSR (或者本身) 并且生成一个证书
    • openssl_decrypt — 解密数据
    • openssl_dh_compute_key — 计算远程DH密钥(公钥)和本地DH密钥的共享密钥
    • openssl_digest — 计算摘要
    • openssl_encrypt — 加密数据
    • openssl_error_string — 返回 openSSL 错误消息
    • openssl_free_key — 释放密钥资源
    • openssl_get_cert_locations — 检索可用的证书位置
    • openssl_get_cipher_methods — 获取可用的加密算法
    • openssl_get_curve_names — 获得ECC的可用曲线名称列表
    • openssl_get_md_methods — 获取可用的摘要算法
    • openssl_get_privatekey — 别名 openssl_pkey_get_private
    • openssl_get_publickey — 别名 openssl_pkey_get_public
    • openssl_open — 打开密封的数据
    • openssl_pbkdf2 — 生成一个 PKCS5 v2 PBKDF2 字符串
    • openssl_pkcs12_export_to_file — 输出一个 PKCS#12 兼容的证书存储文件
    • openssl_pkcs12_export — 将 PKCS#12 兼容证书存储文件导出到变量
    • openssl_pkcs12_read — 将 PKCS#12 证书存储区解析到数组中
    • openssl_pkcs7_decrypt — 解密一个 S/MIME 加密的消息
    • openssl_pkcs7_encrypt — 加密一个 S/MIME 消息
    • openssl_pkcs7_read — 将PKCS7文件导出为PEM格式证书的数组
    • openssl_pkcs7_sign — 对一个 S/MIME 消息进行签名
    • openssl_pkcs7_verify — 校验一个已签名的 S/MIME 消息的签名
    • openssl_pkey_derive — Computes shared secret for public value of remote and local DH or ECDH key
    • openssl_pkey_export_to_file — 将密钥导出到文件中
    • openssl_pkey_export — 将一个密钥的可输出表示转换为字符串
    • openssl_pkey_free — 释放一个私钥
    • openssl_pkey_get_details — 返回包含密钥详情的数组
    • openssl_pkey_get_private — 获取私钥
    • openssl_pkey_get_public — 从证书中解析公钥，以供使用。
    • openssl_pkey_new — 生成一个新的私钥
    • openssl_private_decrypt — 使用私钥解密数据
    • openssl_private_encrypt — 使用私钥加密数据
    • openssl_public_decrypt — 使用公钥解密数据
    • openssl_public_encrypt — 使用公钥加密数据
    • openssl_random_pseudo_bytes — 生成一个伪随机字节串
    • openssl_seal — 密封 (加密) 数据
    • openssl_sign — Generate signature
    • openssl_spki_export_challenge — 导出与签名公钥和挑战相关的挑战字符串
    • openssl_spki_export — 通过签名公钥和挑战导出一个可用的PEM格式的公钥
    • openssl_spki_new — 生成一个新的签名公钥和挑战
    • openssl_spki_verify — 验证签名公钥和挑战。
    • openssl_verify — 验证签名
    • openssl_x509_check_private_key — 检查私钥是否对应于证书
    • openssl_x509_checkpurpose — 验证是否可以为特定目的使用证书
    • openssl_x509_export_to_file — 导出证书至文件
    • openssl_x509_export — 以字符串格式导出证书
    • openssl_x509_fingerprint — 计算一个给定的x.509证书的指纹或摘要
    • openssl_x509_free — 释放证书资源
    • openssl_x509_parse — 解析一个X509证书并作为一个数组返回信息
    • openssl_x509_read — 解析一个x.509证书并返回一个资源标识符
    • openssl_x509_verify — Verifies digital signature of x509 certificate against a public key


简介

本扩展使用 » OpenSSL 库来对称/非对称加解密，以及 PBKDF2、 PKCS7、 PKCS12、 X509 和其他加密操作。除此之外还提供了 TLS 流的实现。

OpenSSL 还提供了更多本模块暂不支持的功能，某些功能以后可能会增加。


需求

要使用 Open SSL 函数，你必须安装» OpenSSL 库。 PHP 5 要求OpenSSL >= 0.9.6。 然而PHP5后续版本会有些编译上的问题，所以最好是使用OpenSSL >= 0.9.8(PHP7要求的最低版本) 。 其他版本(PHP >= 7.1.0) 要求 OpenSSL >= 1.0.1.

Warning

强烈建议你使用最新的OpenSSL版本，否则你的web服务器很容易受到攻击。


安装

要使用 PHP 的 OpenSSL 支持，你应该使用 --with-openssl[=DIR] 参数来编译 PHP。

OpenSSL 库还在运行时对正常操作有额外的要求。最明显的是，OpenSSL 需要访问随机或伪随机数生成器； 在大多数 Unix 和类 Unix 平台上(包括linux)，意味着它必须要访问 /dev/urandom 或者 /dev/random 设备。

自 PHP 5.6.3 起，--with-system-ciphers 配置选项可用于设置 PHP 使用系统密码列表，而不是硬编码。

Note: Win32 平台的用户请注意

为了使此扩展生效， DLL 文件必须能在 Windows 系统的 PATH 指示的路径下找到。如何操作的信息，请参见题为"如何在 Windows 中将 PHP 目录加到 PATH 中"的FAQ。虽然将 DLL 文件从 PHP 文件夹复制到 Windows 系统目录也行，但不建议这样做。 此扩展需要下列文件在 PATH 路径中： libeay32.dll， 或者，自 OpenSSL 1.1 起，为 libcrypto-*.dll

此外，如果打算使用密钥生成和证书签名功能，你需要在你的系统上安装一个可用的 openssl.cnf 文件。 在我们的 win32 二进制发行版本中，我们已经包含了一个示例配置文件，在 extras/openssl 文件夹中。

PHP 将会使用如下逻辑搜索 openssl.cnf 文件:

  • 如果 OPENSSL_CONF 环境变量设置了，该变量将会被当作配置文件的路径（含文件名）。
  • 如果 SSLEAY_CONF 环境变量设置了，该变量将会被当作配置文件的路径（含文件名）。
  • 假设openssl.cnf 文件将会在 openssl DLL 被编译时配置的默认证书区域被找到。这通常意味着默认的文件名是 C:\Program Files\Common Files\SSL\openssl.cnf(x64) 或者 C:\Program Files (x86)\Common Files\SSL\openssl.cnf (x86)，而 PHP 7.4.0之前，则是 C:\usr\local\ssl\openssl.cnf。

在你的安装过程中，你需要决定是否将配置文件安装在默认路径或者使用环境变量(可能是基于每个虚拟主机的基础)来定位配置文件安装到其他地方。注意，可以使用引入配置文件的函数中的 options 参数来覆盖脚本中的默认路径。
Caution

确保无权限的用户无法修改 openssl.cnf 文件。

更新日志

版本 | 说明
7.4.0 | OpenSSL 默认配置文件的路径已经从 C:\usr\local\ssl 分别改至 C:\Program Files\Common Files\SSL 和 C:\Program Files (x86)\Common Files\SSL。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

openssl 配置选项
名字 | 默认 | 可修改范围 | Changelog
openssl.cafile | "" | PHP_INI_PERDIR | 自PHP 5.6.0起可用。
openssl.capath | "" | PHP_INI_PERDIR | 自PHP 5.6.0起可用。
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

openssl.cafile string

本地文件系统上证书颁发机构文件的位置， 被用来和对等校验上下文选项一起校验远程对等方的身份。

openssl.capath string

如果没有制定证书颁发机构文件或者证书找不到，将在由capath指向的目录下搜索一个合适的证书。capath 必须是一个正确的已被散列的证书目录。

参见 SSL stream context 选项。


资源类型

在OpenSSL模块中有三种资源类型。第一种是一个 pkey(公钥或私钥)标识符，第二种是一个X509证书标识符，第三种是 CSR (证书签名请求) 标识符。


预定义常量

Table of Contents

  • 目的检查标志
  • 非对称加密的填充标志
  • 密钥类型
  • PKCS7 标志/常量
  • Signature Algorithms
  • Ciphers
  • Version constants
  • Server Name Indication constants

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。


目的检查标志

X509_PURPOSE_SSL_CLIENT (integer)
X509_PURPOSE_SSL_SERVER (integer)
X509_PURPOSE_NS_SSL_SERVER (integer)
X509_PURPOSE_SMIME_SIGN (integer)
X509_PURPOSE_SMIME_ENCRYPT (integer)
X509_PURPOSE_CRL_SIGN (integer)
X509_PURPOSE_ANY (integer)


非对称加密的填充标志

OPENSSL_PKCS1_PADDING (integer)
OPENSSL_SSLV23_PADDING (integer)
OPENSSL_NO_PADDING (integer)
OPENSSL_PKCS1_OAEP_PADDING (integer)


密钥类型

OPENSSL_KEYTYPE_RSA (integer)
OPENSSL_KEYTYPE_DSA (integer)
OPENSSL_KEYTYPE_DH (integer)
OPENSSL_KEYTYPE_EC (integer)
这个常量只有在使用OpenSSL 0.9.8+进行编译时才可用。

Note:

这个常量是在5.2.0版本中添加的.

OPENSSL_KEYTYPE_EC


PKCS7 标志/常量

S/MIME 函数使用通过一个位阈来表示的标志位，该位阈可包含如下一个或多个值:

PKCS7 常量
常量名 | 描述
PKCS7_TEXT | 把纯文本类型的header头添加到加密/签名的消息中。如果解密或者验证，将会从输出中剥离这些header头 - 如果这些被解密或验证的消息不是 MIME 类型的纯文本文件将会导致一个错误。
PKCS7_BINARY | 通常输入消息将被转成以CR和LF作行末的 "canonical" 格式(S/MIME规范中的声明)。当该选项出现时，消息将不会被转化。 当处理非MIME格式的二进制数据时，这个选项会很有用。
PKCS7_NOINTERN | 在验证消息时，在消息中包含的证书(如果有的话)通常会被搜索签名证书。 对于该选项，只有当 openssl_pkcs7_verify() 函数的参数extracerts指定了的证书才会被使用。然而提供的证书仍然被当做不受信任的证书使用。
PKCS7_NOVERIFY | 不要验证签名消息的签名者证书。
PKCS7_NOCHAIN | 不要约束验证签名者证书：不要把签名消息中的证书当做不受信任的证书。
PKCS7_NOCERTS | 在签署消息时，签名者的证书通常包括在内，但是有了这个选项后，就不需要包括证书了。这将会缩小被签名消息的大小，但是验证人在本地必须有可用的签名者证书副本(比如由openssl_pkcs7_verify()函数中的extracerts参数传递) 。
PKCS7_NOATTR | 通常当消息被签名了，一些属性的集合将会包含在内，比如签名时间和支持的对称算法。使用该选项用来设置不包含这些属性。
PKCS7_DETACHED | 当签名消息时，使用 MIME 类型("multipart/signed")的明文签名。如果你为openssl_pkcs7_sign()函数没有指定任何flags，这个将会是默认的值。 如果你关闭这个选项，消息将使用不透明的签名来签名, 这将会使消息更能抵抗邮件中继的翻译，但是不支持 S/MIME 的邮件客户端将不能读取该消息。
PKCS7_NOSIGS | 不要尝试在消息中验证签名

Note:

这些常量在 4.0.6 版本中被添加。


Signature Algorithms

OPENSSL_ALGO_DSS1 (integer)
OPENSSL_ALGO_SHA1 (integer)
openssl_sign() 和 openssl_verify() 函数使用的默认算法。
OPENSSL_ALGO_SHA224 (integer)
OPENSSL_ALGO_SHA256 (integer)
OPENSSL_ALGO_SHA384 (integer)
OPENSSL_ALGO_SHA512 (integer)
OPENSSL_ALGO_RMD160 (integer)
OPENSSL_ALGO_MD5 (integer)
OPENSSL_ALGO_MD4 (integer)
OPENSSL_ALGO_MD2 (integer)
在PHP 5.2.13和PHP 5.3.2中，只有在使用MD2支持编译PHP时，才可以使用这个常量。 当在编译PHP时需要验证通过 DHAVE_OPENSSL_MD2_H CFLAGP, 当编译 OpenSSL 1.0.0+ 版本时需要启用 enable-md2选项。

Note:

这些常量是在5.0.0版本中添加的。

OPENSSL_ALGO_MD2, OPENSSL_ALGO_MD4, OPENSSL_ALGO_MD5, OPENSSL_ALGO_SHA1, OPENSSL_ALGO_DSS1

Note:

这些常量是在5.4.8版本中添加的。

OPENSSL_ALGO_RMD160, OPENSSL_ALGO_SHA224, OPENSSL_ALGO_SHA256, OPENSSL_ALGO_SHA384, OPENSSL_ALGO_SHA512


Ciphers

OPENSSL_CIPHER_RC2_40 (integer)
OPENSSL_CIPHER_RC2_128 (integer)
OPENSSL_CIPHER_RC2_64 (integer)
OPENSSL_CIPHER_DES (integer)
OPENSSL_CIPHER_3DES (integer)

Note:

这些常量是在4.3.0版本中添加的。

OPENSSL_CIPHER_AES_128_CBC (integer)
OPENSSL_CIPHER_AES_192_CBC (integer)
OPENSSL_CIPHER_AES_256_CBC (integer)

Note:

这些常量是在5.4.0版本中添加的。


Version constants

OPENSSL_VERSION_TEXT (string)
OPENSSL_VERSION_NUMBER (integer)

Note:

这些常量是在5.2.0版本中添加的。


Server Name Indication constants

OPENSSL_TLSEXT_SERVER_NAME (string)
SNI 支持是否可用。

Note:

这个常量是在5.3.2版本中添加的，并且要求PHP是由OpenSSL 0.9.8j及以上版本构建的。


密钥/证书参数

相当一部分的 openssl 函数需要密钥或者证书参数。可通过以下途径获取这些参数。

  • 证书

    1. 一个由 openssl_x509_read() 返回的 X.509资源
    2. 如下格式的字符串 file://path/to/cert.pem; 命名文件必须包含一个PEM编码的证书
    3. 一个包含了证书内容的字符串，PEM编码，应该是以 -----BEGIN CERTIFICATE----- 开头。

  • 证书签名请求 (CSRs)

    1. 一个由 openssl_csr_new() 函数返回的 CSR 资源
    2. 如下格式的字符串file://path/to/csr.pem; 命名文件必须包含一个PEM编码的 CSR
    3. 一个包含了 CSR 内容的字符串，PEM编码，应该是以 -----BEGIN CERTIFICATE REQUEST----- 开头。

  • 公钥/私钥

    1. 一个由 openssl_get_publickey() 或者 openssl_get_privatekey() 函数返回的密钥资源
    2. 仅限公钥：一个 X.509 资源
    3. 如下格式的字符串 file://path/to/file.pem - 命名文件必须包含一个PEM编码的证书/私钥（必须包含二者）
    4. 一个包含证书/私钥内容的字符串，PEM编码，应该是以 -----BEGIN PUBLIC KEY----- 开头。
    5. 对于私钥，应该使用array($key, $passphrase) 的语法格式，这里的 $key 代表由file://格式的文件或者文本字符表示的密钥, 而 $passphrase 表示一个包含该私钥的密码的字符串。


证书验证

当调用需要验证签名/认证的函数时，cainfo 参数是一个包含可信CA文件的文件夹和文件名的数组。如果文件夹指定了，它应该是能够被openssl命令正确使用的哈希目录。


OpenSSL 函数

Table of Contents

  • openssl_cipher_iv_length — 获取密码iv长度
  • openssl_cms_decrypt — Decrypt a CMS message
  • openssl_cms_encrypt — Encrypt a CMS message
  • openssl_cms_read — Export the CMS file to an array of PEM certificates
  • openssl_cms_sign — Sign a file
  • openssl_cms_verify — Verify a CMS signature
  • openssl_csr_export_to_file — 将CSR导出到文件
  • openssl_csr_export — 将CSR作为字符串导出
  • openssl_csr_get_public_key — 返回CSR的公钥
  • openssl_csr_get_subject — 返回CSR的主题
  • openssl_csr_new — 生成一个 CSR
  • openssl_csr_sign — 用另一个证书签署 CSR (或者本身) 并且生成一个证书
  • openssl_decrypt — 解密数据
  • openssl_dh_compute_key — 计算远程DH密钥(公钥)和本地DH密钥的共享密钥
  • openssl_digest — 计算摘要
  • openssl_encrypt — 加密数据
  • openssl_error_string — 返回 openSSL 错误消息
  • openssl_free_key — 释放密钥资源
  • openssl_get_cert_locations — 检索可用的证书位置
  • openssl_get_cipher_methods — 获取可用的加密算法
  • openssl_get_curve_names — 获得ECC的可用曲线名称列表
  • openssl_get_md_methods — 获取可用的摘要算法
  • openssl_get_privatekey — 别名 openssl_pkey_get_private
  • openssl_get_publickey — 别名 openssl_pkey_get_public
  • openssl_open — 打开密封的数据
  • openssl_pbkdf2 — 生成一个 PKCS5 v2 PBKDF2 字符串
  • openssl_pkcs12_export_to_file — 输出一个 PKCS#12 兼容的证书存储文件
  • openssl_pkcs12_export — 将 PKCS#12 兼容证书存储文件导出到变量
  • openssl_pkcs12_read — 将 PKCS#12 证书存储区解析到数组中
  • openssl_pkcs7_decrypt — 解密一个 S/MIME 加密的消息
  • openssl_pkcs7_encrypt — 加密一个 S/MIME 消息
  • openssl_pkcs7_read — 将PKCS7文件导出为PEM格式证书的数组
  • openssl_pkcs7_sign — 对一个 S/MIME 消息进行签名
  • openssl_pkcs7_verify — 校验一个已签名的 S/MIME 消息的签名
  • openssl_pkey_derive — Computes shared secret for public value of remote and local DH or ECDH key
  • openssl_pkey_export_to_file — 将密钥导出到文件中
  • openssl_pkey_export — 将一个密钥的可输出表示转换为字符串
  • openssl_pkey_free — 释放一个私钥
  • openssl_pkey_get_details — 返回包含密钥详情的数组
  • openssl_pkey_get_private — 获取私钥
  • openssl_pkey_get_public — 从证书中解析公钥，以供使用。
  • openssl_pkey_new — 生成一个新的私钥
  • openssl_private_decrypt — 使用私钥解密数据
  • openssl_private_encrypt — 使用私钥加密数据
  • openssl_public_decrypt — 使用公钥解密数据
  • openssl_public_encrypt — 使用公钥加密数据
  • openssl_random_pseudo_bytes — 生成一个伪随机字节串
  • openssl_seal — 密封 (加密) 数据
  • openssl_sign — Generate signature
  • openssl_spki_export_challenge — 导出与签名公钥和挑战相关的挑战字符串
  • openssl_spki_export — 通过签名公钥和挑战导出一个可用的PEM格式的公钥
  • openssl_spki_new — 生成一个新的签名公钥和挑战
  • openssl_spki_verify — 验证签名公钥和挑战。
  • openssl_verify — 验证签名
  • openssl_x509_check_private_key — 检查私钥是否对应于证书
  • openssl_x509_checkpurpose — 验证是否可以为特定目的使用证书
  • openssl_x509_export_to_file — 导出证书至文件
  • openssl_x509_export — 以字符串格式导出证书
  • openssl_x509_fingerprint — 计算一个给定的x.509证书的指纹或摘要
  • openssl_x509_free — 释放证书资源
  • openssl_x509_parse — 解析一个X509证书并作为一个数组返回信息
  • openssl_x509_read — 解析一个x.509证书并返回一个资源标识符
  • openssl_x509_verify — Verifies digital signature of x509 certificate against a public key


获取密码iv长度

  • ? OpenSSL 函数
  • openssl_cms_decrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 获取密码iv长度

openssl_cipher_iv_length

(PHP 5 >= 5.3.3, PHP 7, PHP 8)

openssl_cipher_iv_length — 获取密码iv长度

说明

openssl_cipher_iv_length ( string $method ) : int

获取密码初始化向量(iv)长度。

参数

method

密码的方法，更多值查看 openssl_get_cipher_methods() 函数。

返回值

成功，返回密码长度, 失败返回 false .

错误／异常

当密码方法未知时，抛出一个E_WARNING 级的错误。

范例

Example #1 openssl_cipher_iv_length() 范例

<?php
$method = 'AES-128-CBC';
$ivlen = openssl_cipher_iv_length($method);

echo $ivlen;
?>

以上例程的输出类似于：

16


Decrypt a CMS message

  • ? openssl_cipher_iv_length
  • openssl_cms_encrypt ?
  • PHP Manual
  • OpenSSL 函数
  • Decrypt a CMS message

openssl_cms_decrypt

(PHP 8)

openssl_cms_decrypt — Decrypt a CMS message

说明

openssl_cms_decrypt ( string $input_filename , string $output_filename , OpenSSLCertificate|string $certificate , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string|null $private_key = null , int $encoding = OPENSSL_ENCODING_SMIME ) : bool

Decrypts a CMS message.

参数

input_filename

The name of a file containing encrypted content.

output_filename

The name of the file to deposit the decrypted content.

certificate

The name of the file containing a certificate of the recipient.

private_key

The name of the file containing a PKCS#8 key.

encoding

The encoding of the input file. One of OPENSSL_CMS_SMIME, OPENSLL_CMS_DER or OPENSSL_CMS_PEM.

返回值

成功时返回 true， 或者在失败时返回 false。


Encrypt a CMS message

  • ? openssl_cms_decrypt
  • openssl_cms_read ?
  • PHP Manual
  • OpenSSL 函数
  • Encrypt a CMS message

openssl_cms_encrypt

(PHP 8)

openssl_cms_encrypt — Encrypt a CMS message

说明

openssl_cms_encrypt ( string $input_filename , string $output_filename , OpenSSLCertificate|array|string $certificate , array|null $headers , int $flags = 0 , int $encoding = OPENSSL_ENCODING_SMIME , int $cipher_algo = OPENSSL_CIPHER_RC2_40 ) : bool

This function encrypts content to one or more recipients, based on the certificates that are passed to it.

参数

input_filename

The file to be encrypted.

output_filename

The output file.

certificate

Recipients to encrypt to.

headers

Headers to include when S/MIME is used.

flags

Flags to be passed to CMS_sign.

encoding

An encoding to output. One of OPENSSL_CMS_SMIME, OPENSLL_CMS_DER or OPENSSL_CMS_PEM.

cipher_algo

A cypher to use.

返回值

成功时返回 true， 或者在失败时返回 false。


Export the CMS file to an array of PEM certificates

  • ? openssl_cms_encrypt
  • openssl_cms_sign ?
  • PHP Manual
  • OpenSSL 函数
  • Export the CMS file to an array of PEM certificates

openssl_cms_read

(PHP 8)

openssl_cms_read — Export the CMS file to an array of PEM certificates

说明

openssl_cms_read ( string $input_filename , array &$certificates ) : bool

Performs the exact analog to openssl_pkcs7_read().

Warning

本函数还未编写文档，仅有参数列表。

参数

input_filename

certificates

返回值

成功时返回 true， 或者在失败时返回 false。


Sign a file

  • ? openssl_cms_read
  • openssl_cms_verify ?
  • PHP Manual
  • OpenSSL 函数
  • Sign a file

openssl_cms_sign

(PHP 8)

openssl_cms_sign — Sign a file

说明

openssl_cms_sign ( string $input_filename , string $output_filename , OpenSSLCertificate|string $certificate , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $private_key , array|null $headers , int $flags = 0 , int $encoding = OPENSSL_ENCODING_SMIME , string|null $untrusted_certificates_filename = null ) : bool

This function signs a file with an X.509 certificate and key.

参数

input_filename

The name of the file to be signed.

output_filename

The name of the file to deposit the results.

certificate

The name of the file containing the signing certificate.

private_key

The name of file containing the key associated with certificate.

headers

An array of headers to be included in S/MIME output.

flags

Flags to be passed to cms_sign().

encoding

The encoding of the output file. One of OPENSSL_CMS_SMIME, OPENSLL_CMS_DER or OPENSSL_CMS_PEM.

untrusted_certificates_filename

Intermediate certificates to be included in the signature.

返回值

成功时返回 true， 或者在失败时返回 false。


Verify a CMS signature

  • ? openssl_cms_sign
  • openssl_csr_export_to_file ?
  • PHP Manual
  • OpenSSL 函数
  • Verify a CMS signature

openssl_cms_verify

(PHP 8)

openssl_cms_verify — Verify a CMS signature

说明

openssl_cms_verify ( string $input_filename , int $flags = 0 , string|null $certificates = null , array $ca_info = [] , string|null $untrusted_certificates_filename = null , string|null $content = null , string|null $pk7 = null , string|null $sigfile = null , int $encoding = OPENSSL_ENCODING_SMIME ) : bool

This function verifies a CMS signature, either attached or detached, with the specified encoding.

参数

input_filename

The input file.

flags

Flags to pass to cms_verify().

certificates

A file with the signer certificate and optionally intermediate certificates.

ca_info

An array containing self-signed certificate authority certificates.

untrusted_certificates_filename

A file containing additional intermediate certificates.

content

A file pointing to the content when signatures are detached.

pk7

sigfile

A file to save the signature to.

encoding

The encoding of the input file. One of OPENSSL_CMS_SMIME, OPENSLL_CMS_DER or OPENSSL_CMS_PEM.

返回值

成功时返回 true， 或者在失败时返回 false。


将CSR导出到文件

  • ? openssl_cms_verify
  • openssl_csr_export ?
  • PHP Manual
  • OpenSSL 函数
  • 将CSR导出到文件

openssl_csr_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_csr_export_to_file — 将CSR导出到文件

说明

openssl_csr_export_to_file ( mixed $csr , string $outfilename , bool $notext = true ) : bool

openssl_csr_export_to_file() 获取证书签名请求(csr) 并将之保存在以 outfilename 命名的PEM格式文件中。

参数

csr

See CSR parameters for a list of valid values.

outfilename

输出文件的路径。

notext

可选参数 notext 影响输出的冗余度。如果设为 false，输出内容将包含附加的人类可读信息。notext 的缺省值为 true。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 openssl_csr_export_to_file() 范例

<?php
$subject = array(
    "commonName" => "example.com",
);
$private_key = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));
$csr = openssl_csr_new($subject, $private_key, array('digest_alg' => 'sha384') );
openssl_pkey_export_to_file($private_key, 'example-priv.key');
// Along with the subject, the CSR contains the public key corresponding to the private key
openssl_csr_export_to_file($csr, 'example-csr.pem');
?>

参见

  • openssl_csr_export() - 将CSR作为字符串导出
  • openssl_csr_new() - 生成一个 CSR
  • openssl_csr_sign() - 用另一个证书签署 CSR (或者本身) 并且生成一个证书


将CSR作为字符串导出

  • ? openssl_csr_export_to_file
  • openssl_csr_get_public_key ?
  • PHP Manual
  • OpenSSL 函数
  • 将CSR作为字符串导出

openssl_csr_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_csr_export — 将CSR作为字符串导出

说明

openssl_csr_export ( mixed $csr , string &$out , bool $notext = true ) : bool

openssl_csr_export() 获取证书签名请求(csr)并通过引用保存其 PEM 格式的字符串(out)。

参数

csr

See CSR parameters for a list of valid values.

out

在成功时，该字符串将包含PEM编码的CSR.

notext

可选参数 notext 影响输出的冗余度。如果设为 false，输出内容将包含附加的人类可读信息。notext 的缺省值为 true。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 openssl_csr_export() 范例

<?php
$subject = array(
    "commonName" => "example.com",
);
$private_key = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));
$configargs = array(
    'digest_alg' => 'sha256WithRSAEncryption'
);
$csr = openssl_csr_new($subject, $private_key, $configargs);
openssl_csr_export($csr, $csr_string);
echo $csr_string;
?>

参见

  • openssl_csr_export_to_file() - 将CSR导出到文件
  • openssl_csr_new() - 生成一个 CSR
  • openssl_csr_sign() - 用另一个证书签署 CSR (或者本身) 并且生成一个证书


返回CSR的公钥

  • ? openssl_csr_export
  • openssl_csr_get_subject ?
  • PHP Manual
  • OpenSSL 函数
  • 返回CSR的公钥

openssl_csr_get_public_key

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

openssl_csr_get_public_key — 返回CSR的公钥

说明

openssl_csr_get_public_key ( mixed $csr , bool $use_shortnames = true ) : resource

openssl_csr_get_public_key() 从csr中提取公钥供其他功能使用。

参数

csr

See CSR parameters for a list of valid values.

use_shortnames
Warning

该参数可以省略。

返回值

成功，返回一个私钥标识符，错误则返回FALSE.

范例

Example #1 openssl_csr_get_public_key() example

<?php
$subject = array(
    "commonName" => "example.com",
);
$private_key = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));
$csr = openssl_csr_new($subject, $private_key, array('digest_alg' => 'sha256') );
$public_key = openssl_csr_get_public_key($csr);
$info = openssl_pkey_get_details($public_key);
echo $info['key'];
?>

参见

  • openssl_csr_get_subject() - 返回CSR的主题
  • openssl_csr_new() - 生成一个 CSR
  • openssl_pkey_get_details() - 返回包含密钥详情的数组
  • openssl_pkey_export_to_file() - 将密钥导出到文件中
  • openssl_pkey_export() - 将一个密钥的可输出表示转换为字符串


返回CSR的主题

  • ? openssl_csr_get_public_key
  • openssl_csr_new ?
  • PHP Manual
  • OpenSSL 函数
  • 返回CSR的主题

openssl_csr_get_subject

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

openssl_csr_get_subject — 返回CSR的主题

说明

openssl_csr_get_subject ( mixed $csr , bool $use_shortnames = true ) : array

openssl_csr_get_subject() 返回csr中专有名称信息的主题，其中包含了通用名称 (CN), 机构名称 (O), 国家名 (C) 等字段。

参数

csr

See CSR parameters for a list of valid values.

use_shortnames

shortnames 控制着数据如何在数组中被索引 - 如果 shortnames 为 true (默认) 将使用简称形式对字段进行索引，否则将使用全称形式 - 比如： CN 就是 commonName 的简称形式。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 openssl_csr_get_subject() 范例

<?php
$subject = array(
    "countryName" => "CA",
    "stateOrProvinceName" => "Alberta",
    "localityName" => "Calgary",
    "organizationName" => "XYZ Widgets Inc",
    "organizationalUnitName" => "PHP Documentation Team",
    "commonName" => "Wez Furlong",
    "emailAddress" => "wez@example.com",
);
$private_key = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));
$configargs = array(
    'digest_alg' => 'sha512WithRSAEncryption'
);
$csr = openssl_csr_new($subject, $privkey, $configargs);
print_r(openssl_csr_get_subject($csr));
?>

以上例程的输出类似于：

Array
(
    [C] => CA
    [ST] => Alberta
    [L] => Calgary
    [O] => XYZ Widgets Inc
    [OU] => PHP Documentation Team
    [CN] => Wez Furlong
    [emailAddress] => wez@example.com
)

参见

  • openssl_csr_new() - 生成一个 CSR
  • openssl_csr_get_public_key() - 返回CSR的公钥
  • openssl_x509_parse() - 解析一个X509证书并作为一个数组返回信息


生成一个 CSR

  • ? openssl_csr_get_subject
  • openssl_csr_sign ?
  • PHP Manual
  • OpenSSL 函数
  • 生成一个 CSR

openssl_csr_new

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_csr_new — 生成一个 CSR

说明

openssl_csr_new ( array $dn , resource &$privkey , array $configargs = ? , array $extraattribs = ? ) : mixed

openssl_csr_new() 根据dn提供的信息生成新的CSR（证书签名请求）。

Note: 必须安装有效的 openssl.cnf 以保证此函数正确运行。参考有关安装的说明以获得更多信息。

参数

dn

在证书中使用的专有名称或主题字段。

privkey

privkey 应该被设置为由openssl_pkey_new()函数预先生成(或者以其他方式从openssl_pkey函数集中获得)的私钥。该密钥的相应公共部分将用于签署CSR.

configargs

默认的， 是通过你系统里的openssl.conf配置来初始化请求； 您可以通过设置configargs的config_section_section项来指定配置文件部分。 您还可以通过将config键的值设置为您想要使用的文件路径来指定另一个openssl配置文件。如果在configargs中存在下列键，它们的行为就像在openssl.conf中一样。如下表所示：

配置覆盖
configargs 键 | type | 等同于 openssl.conf | 描述
digest_alg | string | default_md | 摘要算法或签名哈希算法，通常是 openssl_get_md_methods() 之一。
x509_extensions | string | x509_extensions | 选择在创建x509证书时应该使用哪些扩展
req_extensions | string | req_extensions | 创建CSR时，选择使用哪个扩展
private_key_bits | integer | default_bits | 指定应该使用多少位来生成私钥
private_key_type | integer | none | 选择在创建CSR时应该使用哪些扩展。可选值有 OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH, OPENSSL_KEYTYPE_RSA 或 OPENSSL_KEYTYPE_EC. 默认值是 OPENSSL_KEYTYPE_RSA.
encrypt_key | boolean | encrypt_key | 是否应该对导出的密钥（带有密码短语）进行加密?
encrypt_key_cipher | integer | none | cipher constants常量之一。
curve_name | string | none | 要求PHP7.1+, openssl_get_curve_names()之一。
config | string | N/A | 自定义 openssl.conf 文件的路径。

extraattribs

extraattribs 用于为CSR指定额外的配置选项。dn 和 extraattribs 都是关联数组它们的键被转换成OIDs，并应用到请求的相关部分。

返回值

成功，返回CSR 或者在失败时返回 false.

范例

Example #1 创建一个自签名的证书

<?php
// for SSL server certificates the commonName is the domain name to be secured
// for S/MIME email certificates the commonName is the owner of the email address
// location and identification fields refer to the owner of domain or email subject to be secured
$dn = array(
    "countryName" => "GB",
    "stateOrProvinceName" => "Somerset",
    "localityName" => "Glastonbury",
    "organizationName" => "The Brain Room Limited",
    "organizationalUnitName" => "PHP Documentation Team",
    "commonName" => "Wez Furlong",
    "emailAddress" => "wez@example.com"
);

// Generate a new private (and public) key pair
$privkey = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));

// Generate a certificate signing request
$csr = openssl_csr_new($dn, $privkey, array('digest_alg' => 'sha256'));

// Generate a self-signed cert, valid for 365 days
$x509 = openssl_csr_sign($csr, null, $privkey, $days=365, array('digest_alg' => 'sha256'));

// Save your private key, CSR and self-signed cert for later use
openssl_csr_export($csr, $csrout) and var_dump($csrout);
openssl_x509_export($x509, $certout) and var_dump($certout);
openssl_pkey_export($privkey, $pkeyout, "mypassword") and var_dump($pkeyout);

// Show any errors that occurred here
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>

Example #2 在PHP 7.1+版本中创建一个自签名的ECC证书

<?php
$subject = array(
    "commonName" => "docs.php.net",
);

// Generate a new private (and public) key pair
$private_key = openssl_pkey_new(array(
    "private_key_type" => OPENSSL_KEYTYPE_EC,
    "curve_name" => 'prime256v1',
));

// Generate a certificate signing request
$csr = openssl_csr_new($subject, $private_key, array('digest_alg' => 'sha384'));

// Generate self-signed EC cert
$x509 = openssl_csr_sign($csr, null, $private_key, $days=365, array('digest_alg' => 'sha384'));
openssl_x509_export_to_file($x509, 'ecc-cert.pem');
openssl_pkey_export_to_file($private_key, 'ecc-private.key');
?>

参见

  • openssl_csr_sign() - 用另一个证书签署 CSR (或者本身) 并且生成一个证书


用另一个证书签署 CSR (或者本身) 并且生成一个证书

  • ? openssl_csr_new
  • openssl_decrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 用另一个证书签署 CSR (或者本身) 并且生成一个证书

openssl_csr_sign

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_csr_sign — 用另一个证书签署 CSR (或者本身) 并且生成一个证书

说明

openssl_csr_sign ( mixed $csr , mixed $cacert , mixed $priv_key , int $days , array $configargs = ? , int $serial = 0 ) : resource

openssl_csr_sign() 从给定的 CSR 生成一个x509证书资源

Note: 必须安装有效的 openssl.cnf 以保证此函数正确运行。参考有关安装的说明以获得更多信息。

参数

csr

由openssl_csr_new()函数生成的CSR. 也可以是由类似file://path/to/csr格式指定的指向PEM编码的CSR路径，或者是一个由openssl_csr_export()函数生成的字符串。

cacert

生成的证书将由cacert签名。 如果cacert 为 null, 生成的证书将是自签名证书。

priv_key

priv_key是cacert证书对应的私钥。

days

days 指定生成的证书在几天内有效的时间长度。

configargs

你可以通过configargs确定CSR签名。 查看openssl_csr_new() 方法获取 configargs的更多相关信息。

serial

可选的发行证书编号。如果没有指定默认值为0.

返回值

成功，返回一个 x509 证书资源，失败则返回 false .

范例

Example #1 openssl_csr_sign() example - signing a CSR (how to implement your own CA)

<?php
// Let's assume that this script is set to receive a CSR that has
// been pasted into a textarea from another page
$csrdata = $_POST["CSR"];

// We will sign the request using our own "certificate authority"
// certificate.  You can use any certificate to sign another, but
// the process is worthless unless the signing certificate is trusted
// by the software/users that will deal with the newly signed certificate

// We need our CA cert and its private key
$cacert = "file://path/to/ca.crt";
$privkey = array("file://path/to/ca.key", "your_ca_key_passphrase");

$usercert = openssl_csr_sign($csrdata, $cacert, $privkey, 365, array('digest_alg'=>'sha256') );

// Now display the generated certificate so that the user can
// copy and paste it into their local configuration (such as a file
// to hold the certificate for their SSL server)
openssl_x509_export($usercert, $certout);
echo $certout;

// Show any errors that occurred here
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>


解密数据

  • ? openssl_csr_sign
  • openssl_dh_compute_key ?
  • PHP Manual
  • OpenSSL 函数
  • 解密数据

openssl_decrypt

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_decrypt — 解密数据

说明

openssl_decrypt ( string $data , string $method , string $key , int $options = 0 , string $iv = "" , string $tag = "" , string $aad = "" ) : string

采用原始或base64编码的字符串，并使用给定的方法和密钥对其进行解密。

参数

data

将被解密的密文。

method

加密算法，使用openssl_get_cipher_methods()函数获取可用的加密算法列表。

key

密钥。

options

options can be one of OPENSSL_RAW_DATA, OPENSSL_ZERO_PADDING.

iv

非空的初始化向量。

tag

AEAD密码模式中的身份验证标签。 如果是错误的，验证失败，函数返回false.

aad

额外的认证数据。

返回值

The decrypted string on success 或者在失败时返回 false.

错误／异常

如果通过method参数传递的是一个未知的加密算法，将会抛出一个 E_WARNING 等级的错误。

如果通过iv参数传递的是一个空值，将会抛出一个 E_WARNING 等级的错误。

更新日志

版本 | 说明
5.3.3 | 添加 iv 参数。
5.4.0 | 将 raw_output 更改至 options。
7.1.0 | 添加了 tag 和 aad 参数。

参见

  • openssl_encrypt() - 加密数据


计算远程DH密钥(公钥)和本地DH密钥的共享密钥

  • ? openssl_decrypt
  • openssl_digest ?
  • PHP Manual
  • OpenSSL 函数
  • 计算远程DH密钥(公钥)和本地DH密钥的共享密钥

openssl_dh_compute_key

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_dh_compute_key — 计算远程DH密钥(公钥)和本地DH密钥的共享密钥

说明

openssl_dh_compute_key ( string $pub_key , resource $dh_key ) : string
Warning

本函数还未编写文档，仅有参数列表。

参数

pub_key

公钥

dh_key

DH 密钥

返回值

成功，返回计算的密钥， 或者在失败时返回 false.


计算摘要

  • ? openssl_dh_compute_key
  • openssl_encrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 计算摘要

openssl_digest

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_digest — 计算摘要

说明

openssl_digest ( string $data , string $method , bool $raw_output = false ) : string

使用给定的方法计算给定数据的摘要哈希值，并返回一个原始的或16进制编码的字符串。

Warning

本函数还未编写文档，仅有参数列表。

参数

data

给定的数据。

method

要使用的摘要方法，比如 "sha256", 查看 openssl_get_md_methods() 函数获取更多可用的摘要方法。

raw_output

为 true 时将会返回原始输出数据，否则返回值将会是16进制。

返回值

成功，返回摘要哈希值， 或者在失败时返回 false.

错误／异常

如果通过method参数传递的是一个未知的摘要算法，将会抛出一个E_WARNING 级的错误。

参见

  • openssl_get_md_methods() - 获取可用的摘要算法


加密数据

  • ? openssl_digest
  • openssl_error_string ?
  • PHP Manual
  • OpenSSL 函数
  • 加密数据

openssl_encrypt

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_encrypt — 加密数据

说明

openssl_encrypt ( string $data , string $method , string $key , int $options = 0 , string $iv = "" , string &$tag = NULL , string $aad = "" , int $tag_length = 16 ) : string

以指定的方式和 key 加密数据，返回原始或 base64 编码后的字符串。

参数

data

待加密的明文信息数据。

method

密码学方式。openssl_get_cipher_methods() 可获取有效密码方式列表。

key

key。

options

options 是以下标记的按位或： OPENSSL_RAW_DATA 、 OPENSSL_ZERO_PADDING。

iv

非 NULL 的初始化向量。

tag

使用 AEAD 密码模式（GCM 或 CCM）时传引用的验证标签。

aad

附加的验证数据。

tag_length

验证 tag 的长度。GCM 模式时，它的范围是 4 到 16。

返回值

成功时返回加密后的字符串， 或者在失败时返回 false。

错误／异常

method 传入未知算法时，产生 E_WARNING 级别的错误。

iv 传入空字符串时产生 E_WARNING 级别的错误。

更新日志

版本 | 说明
5.3.3 | 增加 iv 参数。
5.4.0 | raw_output 改到 options。
7.1.0 | 增加了 tag、aad、tag_length 参数

范例

Example #1 PHP 7.1+ 下 GCM 模式的 AES 认证加密例子

<?php
//$key should have been previously generated in a cryptographically safe way, like openssl_random_pseudo_bytes
$plaintext = "message to be encrypted";
$cipher = "aes-128-gcm";
if (in_array($cipher, openssl_get_cipher_methods()))
{
    $ivlen = openssl_cipher_iv_length($cipher);
    $iv = openssl_random_pseudo_bytes($ivlen);
    $ciphertext = openssl_encrypt($plaintext, $cipher, $key, $options=0, $iv, $tag);
    //store $cipher, $iv, and $tag for decryption later
    $original_plaintext = openssl_decrypt($ciphertext, $cipher, $key, $options=0, $iv, $tag);
    echo $original_plaintext."\n";
}
?>

Example #2 PHP 5.6+ 的 AES 认证加密例子

<?php
//$key previously generated safely, ie: openssl_random_pseudo_bytes
$plaintext = "message to be encrypted";
$ivlen = openssl_cipher_iv_length($cipher="AES-128-CBC");
$iv = openssl_random_pseudo_bytes($ivlen);
$ciphertext_raw = openssl_encrypt($plaintext, $cipher, $key, $options=OPENSSL_RAW_DATA, $iv);
$hmac = hash_hmac('sha256', $ciphertext_raw, $key, $as_binary=true);
$ciphertext = base64_encode( $iv.$hmac.$ciphertext_raw );

//decrypt later....
$c = base64_decode($ciphertext);
$ivlen = openssl_cipher_iv_length($cipher="AES-128-CBC");
$iv = substr($c, 0, $ivlen);
$hmac = substr($c, $ivlen, $sha2len=32);
$ciphertext_raw = substr($c, $ivlen+$sha2len);
$original_plaintext = openssl_decrypt($ciphertext_raw, $cipher, $key, $options=OPENSSL_RAW_DATA, $iv);
$calcmac = hash_hmac('sha256', $ciphertext_raw, $key, $as_binary=true);
if (hash_equals($hmac, $calcmac))//PHP 5.6+ timing attack safe comparison
{
    echo $original_plaintext."\n";
}
?>

参见

  • openssl_decrypt() - 解密数据


返回 openSSL 错误消息

  • ? openssl_encrypt
  • openssl_free_key ?
  • PHP Manual
  • OpenSSL 函数
  • 返回 openSSL 错误消息

openssl_error_string

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_error_string — 返回 openSSL 错误消息

说明

openssl_error_string ( ) : string

openssl_error_string() 从openSSL库返回最后一个错误。错误消息已被队列化，因此这个函数可以多次调用用来收集所有的信息。最后一个错误将是最近的一个。

返回值

成功，返回错误信息字符串，如果没有任何错误信息则返回 false。

范例

Example #1 openssl_error_string() example

<?php
// lets assume you just called an openssl function that failed
while ($msg = openssl_error_string())
    echo $msg . "<br />\n";
?>


释放密钥资源

  • ? openssl_error_string
  • openssl_get_cert_locations ?
  • PHP Manual
  • OpenSSL 函数
  • 释放密钥资源

openssl_free_key

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_free_key — 释放密钥资源

说明

openssl_free_key ( resource $key_identifier ) : void

openssl_free_key() 从内存中释放和指定的 key_identifier相关联的密钥。

参数

key_identifier

返回值

没有返回值。


检索可用的证书位置

  • ? openssl_free_key
  • openssl_get_cipher_methods ?
  • PHP Manual
  • OpenSSL 函数
  • 检索可用的证书位置

openssl_get_cert_locations

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_get_cert_locations — 检索可用的证书位置

说明

openssl_get_cert_locations ( ) : array

openssl_get_cert_locations() 返回一个数组，其中包含要搜索SSL证书的可用证书位置的信息。

参数

此函数没有参数。

返回值

返回一个带有可用证书位置信息的数组。

范例

Example #1 openssl_get_cert_locations() 范例

<?php
var_dump(openssl_get_cert_locations());
?>

以上例程会输出：

array(8) {
  ["default_cert_file"]=>
  string(21) "/usr/lib/ssl/cert.pem"
  ["default_cert_file_env"]=>
  string(13) "SSL_CERT_FILE"
  ["default_cert_dir"]=>
  string(18) "/usr/lib/ssl/certs"
  ["default_cert_dir_env"]=>
  string(12) "SSL_CERT_DIR"
  ["default_private_dir"]=>
  string(20) "/usr/lib/ssl/private"
  ["default_default_cert_area"]=>
  string(12) "/usr/lib/ssl"
  ["ini_cafile"]=>
  string(0) ""
  ["ini_capath"]=>
  string(0) ""
}


获取可用的加密算法

  • ? openssl_get_cert_locations
  • openssl_get_curve_names ?
  • PHP Manual
  • OpenSSL 函数
  • 获取可用的加密算法

openssl_get_cipher_methods

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_get_cipher_methods — 获取可用的加密算法

说明

openssl_get_cipher_methods ( bool $aliases = false ) : array

获取可用的加密算法的列表。

参数

aliases

如果密码别名应该包含在返回的array中，则设置为 true.

返回值

一个包含可用加密算法的array。

范例

Example #1 openssl_get_cipher_methods() example

展示了哪些加密算法能被找到，哪些别名可用。

<?php
$ciphers             = openssl_get_cipher_methods();
$ciphers_and_aliases = openssl_get_cipher_methods(true);
$cipher_aliases      = array_diff($ciphers_and_aliases, $ciphers);

//ECB mode should be avoided
$ciphers = array_filter( $ciphers, function($n) { return stripos($n,"ecb")===FALSE; } );

//At least as early as Aug 2016, Openssl declared the following weak: RC2, RC4, DES, 3DES, MD5 based
$ciphers = array_filter( $ciphers, function($c) { return stripos($c,"des")===FALSE; } );
$ciphers = array_filter( $ciphers, function($c) { return stripos($c,"rc2")===FALSE; } );
$ciphers = array_filter( $ciphers, function($c) { return stripos($c,"rc4")===FALSE; } );
$ciphers = array_filter( $ciphers, function($c) { return stripos($c,"md5")===FALSE; } );
$cipher_aliases = array_filter($cipher_aliases,function($c) { return stripos($c,"des")===FALSE; } );
$cipher_aliases = array_filter($cipher_aliases,function($c) { return stripos($c,"rc2")===FALSE; } );

print_r($ciphers);
print_r($cipher_aliases);
?>

以上例程的输出类似于：

Array
(
    [0] => AES-128-CBC
    [1] => AES-128-CFB
    [2] => AES-128-CFB1
    [3] => AES-128-CFB8
    [5] => AES-128-OFB
    [6] => AES-192-CBC
    [7] => AES-192-CFB
    [8] => AES-192-CFB1
    [9] => AES-192-CFB8
    [11] => AES-192-OFB
    [12] => AES-256-CBC
    [13] => AES-256-CFB
    [14] => AES-256-CFB1
    [15] => AES-256-CFB8
    [17] => AES-256-OFB
    [18] => BF-CBC
    [19] => BF-CFB
    [21] => BF-OFB
    [22] => CAST5-CBC
    [23] => CAST5-CFB
    [25] => CAST5-OFB
    [41] => IDEA-CBC
    [42] => IDEA-CFB
    [44] => IDEA-OFB
    [53] => aes-128-cbc
    [54] => aes-128-cfb
    [55] => aes-128-cfb1
    [56] => aes-128-cfb8
    [58] => aes-128-ofb
    [59] => aes-192-cbc
    [60] => aes-192-cfb
    [61] => aes-192-cfb1
    [62] => aes-192-cfb8
    [64] => aes-192-ofb
    [65] => aes-256-cbc
    [66] => aes-256-cfb
    [67] => aes-256-cfb1
    [68] => aes-256-cfb8
    [70] => aes-256-ofb
    [71] => bf-cbc
    [72] => bf-cfb
    [74] => bf-ofb
    [75] => cast5-cbc
    [76] => cast5-cfb
    [78] => cast5-ofb
    [94] => idea-cbc
    [95] => idea-cfb
    [97] => idea-ofb
)
Array
(
    [18] => AES128
    [19] => AES192
    [20] => AES256
    [21] => BF
    [26] => CAST
    [27] => CAST-cbc
    [50] => IDEA
    [82] => aes128
    [83] => aes192
    [84] => aes256
    [85] => bf
    [90] => blowfish
    [91] => cast
    [92] => cast-cbc
    [115] => idea
)

参见

  • openssl_get_md_methods() - 获取可用的摘要算法


获得ECC的可用曲线名称列表

  • ? openssl_get_cipher_methods
  • openssl_get_md_methods ?
  • PHP Manual
  • OpenSSL 函数
  • 获得ECC的可用曲线名称列表

openssl_get_curve_names

(PHP 7 >= 7.1.0, PHP 8)

openssl_get_curve_names — 获得ECC的可用曲线名称列表

说明

openssl_get_curve_names ( ) : array

获取用于公钥/私钥操作的椭圆曲线密码（ECC）中可用曲线名称的列表。两个最广泛的标准化/支持的曲线是prime256v1 (NIST P-256) 和 secp384r1 (NIST P-384).

AES, RSA, DSA 和 ECC 密钥长度近似等值
AES Symmetric Keysize (Bits) | RSA and DSA Keysize (Bits) | ECC Keysize (Bits)
80 | 1024 | 160
112 | 2048 | 224
128 | 3072 | 256
192 | 7680 | 384
256 | 15360 | 512
» NIST 推荐使用的 ECC 曲线最少为 256 位.

参数

此函数没有参数。

返回值

一个包含可用曲线名称的数组。

范例

Example #1 openssl_get_curve_names() 范例

<?php
$curve_names = openssl_get_curve_names();
print_r($curve_names);
?>

以上例程的输出类似于：

Array
(
    [0] => secp112r1
    [1] => secp112r2
    [2] => secp128r1
    [3] => secp128r2
    [4] => secp160k1
    [5] => secp160r1
    [6] => secp160r2
    [7] => secp192k1
    [8] => secp224k1
    [9] => secp224r1
    [10] => secp256k1
    [11] => secp384r1
    [12] => secp521r1
    [13] => prime192v1
    [14] => prime192v2
    [15] => prime192v3
    [16] => prime239v1
    [17] => prime239v2
    [18] => prime239v3
    [19] => prime256v1
    [20] => sect113r1
    [21] => sect113r2
    [22] => sect131r1
    [23] => sect131r2
    [24] => sect163k1
    [25] => sect163r1
    [26] => sect163r2
    [27] => sect193r1
    [28] => sect193r2
    [29] => sect233k1
    [30] => sect233r1
    [31] => sect239k1
    [32] => sect283k1
    [33] => sect283r1
    [34] => sect409k1
    [35] => sect409r1
    [36] => sect571k1
    [37] => sect571r1
    [38] => c2pnb163v1
    [39] => c2pnb163v2
    [40] => c2pnb163v3
    [41] => c2pnb176v1
    [42] => c2tnb191v1
    [43] => c2tnb191v2
    [44] => c2tnb191v3
    [45] => c2pnb208w1
    [46] => c2tnb239v1
    [47] => c2tnb239v2
    [48] => c2tnb239v3
    [49] => c2pnb272w1
    [50] => c2pnb304w1
    [51] => c2tnb359v1
    [52] => c2pnb368w1
    [53] => c2tnb431r1
    [54] => wap-wsg-idm-ecid-wtls1
    [55] => wap-wsg-idm-ecid-wtls3
    [56] => wap-wsg-idm-ecid-wtls4
    [57] => wap-wsg-idm-ecid-wtls5
    [58] => wap-wsg-idm-ecid-wtls6
    [59] => wap-wsg-idm-ecid-wtls7
    [60] => wap-wsg-idm-ecid-wtls8
    [61] => wap-wsg-idm-ecid-wtls9
    [62] => wap-wsg-idm-ecid-wtls10
    [63] => wap-wsg-idm-ecid-wtls11
    [64] => wap-wsg-idm-ecid-wtls12
    [65] => Oakley-EC2N-3
    [66] => Oakley-EC2N-4
    [67] => brainpoolP160r1
    [68] => brainpoolP160t1
    [69] => brainpoolP192r1
    [70] => brainpoolP192t1
    [71] => brainpoolP224r1
    [72] => brainpoolP224t1
    [73] => brainpoolP256r1
    [74] => brainpoolP256t1
    [75] => brainpoolP320r1
    [76] => brainpoolP320t1
    [77] => brainpoolP384r1
    [78] => brainpoolP384t1
    [79] => brainpoolP512r1
    [80] => brainpoolP512t1
)


获取可用的摘要算法

  • ? openssl_get_curve_names
  • openssl_get_privatekey ?
  • PHP Manual
  • OpenSSL 函数
  • 获取可用的摘要算法

openssl_get_md_methods

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_get_md_methods — 获取可用的摘要算法

说明

openssl_get_md_methods ( bool $aliases = false ) : array

获取可用的摘要算法列表

参数

aliases

设置为 true 时，返回的array中将会包含摘要的别名.

返回值

含有可用摘要算法的数组

范例

Example #1 openssl_get_md_methods() 范例：

显示了可用的摘要，以及哪些别名可能是可用的。

<?php
$digests             = openssl_get_md_methods();
$digests_and_aliases = openssl_get_md_methods(true);
$digest_aliases      = array_diff($digests_and_aliases, $digests);

print_r($digests);

print_r($digest_aliases);

?>

以上例程的输出类似于：

Array
(
    [0] => DSA
    [1] => DSA-SHA
    [2] => MD2
    [3] => MD4
    [4] => MD5
    [5] => RIPEMD160
    [6] => SHA
    [7] => SHA1
    [8] => SHA224
    [9] => SHA256
    [10] => SHA384
    [11] => SHA512
    [12] => dsaEncryption
    [13] => dsaWithSHA
    [14] => ecdsa-with-SHA1
    [15] => md2
    [16] => md4
    [17] => md5
    [18] => ripemd160
    [19] => sha
    [20] => sha1
    [21] => sha224
    [22] => sha256
    [23] => sha384
    [24] => sha512
)
Array
(
    [2] => DSA-SHA1
    [3] => DSA-SHA1-old
    [4] => DSS1
    [9] => RSA-MD2
    [10] => RSA-MD4
    [11] => RSA-MD5
    [12] => RSA-RIPEMD160
    [13] => RSA-SHA
    [14] => RSA-SHA1
    [15] => RSA-SHA1-2
    [16] => RSA-SHA224
    [17] => RSA-SHA256
    [18] => RSA-SHA384
    [19] => RSA-SHA512
    [28] => dsaWithSHA1
    [29] => dss1
    [32] => md2WithRSAEncryption
    [34] => md4WithRSAEncryption
    [36] => md5WithRSAEncryption
    [37] => ripemd
    [39] => ripemd160WithRSA
    [40] => rmd160
    [43] => sha1WithRSAEncryption
    [45] => sha224WithRSAEncryption
    [47] => sha256WithRSAEncryption
    [49] => sha384WithRSAEncryption
    [51] => sha512WithRSAEncryption
    [52] => shaWithRSAEncryption
    [53] => ssl2-md5
    [54] => ssl3-md5
    [55] => ssl3-sha1
)

参见

  • openssl_digest() - 计算摘要
  • openssl_get_cipher_methods() - 获取可用的加密算法


别名 openssl_pkey_get_private

  • ? openssl_get_md_methods
  • openssl_get_publickey ?
  • PHP Manual
  • OpenSSL 函数
  • 别名 openssl_pkey_get_private

openssl_get_privatekey

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_get_privatekey — 别名 openssl_pkey_get_private()

说明

此函数是该函数的别名： openssl_pkey_get_private().


别名 openssl_pkey_get_public

  • ? openssl_get_privatekey
  • openssl_open ?
  • PHP Manual
  • OpenSSL 函数
  • 别名 openssl_pkey_get_public

openssl_get_publickey

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_get_publickey — 别名 openssl_pkey_get_public()

说明

此函数是该函数的别名： openssl_pkey_get_public().


打开密封的数据

  • ? openssl_get_publickey
  • openssl_pbkdf2 ?
  • PHP Manual
  • OpenSSL 函数
  • 打开密封的数据

openssl_open

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_open — 打开密封的数据

说明

openssl_open ( string $sealed_data , string &$open_data , string $env_key , mixed $priv_key_id , string $method = "RC4" , string &$iv = ? ) : bool

openssl_open() 使用与密钥标识符priv_key_id和信封密钥env_key相关联的私钥打开 (解密) sealed_data 数据, 使用解密后的数据填充open_data。 当数据被密封时，就生成了信封密钥且只能由一个特定的私钥使用。更多信息参见 openssl_seal() 。

参数

sealed_data

open_data

如果调用成功，则在这个参数中返回打开的数据。

env_key

priv_key_id

method

加解密算法。

iv

初始化向量。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.0.0 | 添加了 iv 参数
5.3.0 | 添加了 method 参数

范例

Example #1 openssl_open() 范例

<?php
// $sealed and $env_key are assumed to contain the sealed data
// and our envelope key, both given to us by the sealer.

// fetch private key from file and ready it
$fp = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$priv_key = fread($fp, 8192);
fclose($fp);
$pkeyid = openssl_get_privatekey($priv_key);

// decrypt the data and store it in $open
if (openssl_open($sealed, $open, $env_key, $pkeyid)) {
    echo "here is the opened data: ", $open;
} else {
    echo "failed to open data";
}

// free the private key from memory
openssl_free_key($pkeyid);
?>

参见

  • openssl_seal() - 密封 (加密) 数据


生成一个 PKCS5 v2 PBKDF2 字符串

  • ? openssl_open
  • openssl_pkcs12_export_to_file ?
  • PHP Manual
  • OpenSSL 函数
  • 生成一个 PKCS5 v2 PBKDF2 字符串

openssl_pbkdf2

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

openssl_pbkdf2 — 生成一个 PKCS5 v2 PBKDF2 字符串

说明

openssl_pbkdf2 ( string $password , string $salt , int $key_length , int $iterations , string $digest_algorithm = "sha1" ) : string

openssl_pbkdf2() 计算 PBKDF2 (Password-Based Key Derivation Function 2), 在PKCS5 v2中定义的一个密钥的推导函数.

参数

password

派生密钥所生成的密码。

salt

PBKDF2 推荐一个不少于64位(8字节)的密码盐值。

key_length

希望输出密钥的长度。

iterations

需要的迭代次数 » NIST 建议至少10,000次.

digest_algorithm

在openssl_get_md_methods()中可选的散列或摘要算法.默认是 SHA-1.

返回值

成功，返回原始二进制字符串 或者在失败时返回 false.

范例

Example #1 openssl_pbkdf2() 范例

<?php
$password = 'yOuR-pAs5w0rd-hERe';
$salt = openssl_random_pseudo_bytes(12);
$keyLength = 40;
$iterations = 10000;
$generated_key = openssl_pbkdf2($password, $salt, $keyLength, $iterations, 'sha256');
echo bin2hex($generated_key)."\n";
echo base64_encode($generated_key)."\n";
?>

参见

  • hash_pbkdf2() - 生成所提供密码的 PBKDF2 密钥导出
  • openssl_get_md_methods() - 获取可用的摘要算法


输出一个 PKCS#12 兼容的证书存储文件

  • ? openssl_pbkdf2
  • openssl_pkcs12_export ?
  • PHP Manual
  • OpenSSL 函数
  • 输出一个 PKCS#12 兼容的证书存储文件

openssl_pkcs12_export_to_file

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

openssl_pkcs12_export_to_file — 输出一个 PKCS#12 兼容的证书存储文件

说明

openssl_pkcs12_export_to_file ( mixed $x509 , string $filename , mixed $priv_key , string $pass , array $args = ? ) : bool

openssl_pkcs12_export_to_file() 函数以 PKCS#12 格式将 x509 保存至文件名为 filename 的文件中。

参数

x509

参见密钥／证书参数以获取有效值列表。

filename

输出文件的路径。

priv_key

PKCS#12文件的私钥部分。 参见 公/私钥参数 获取可用值的列表。

pass

用于解锁 PKCS#12 文件的加密密码。

args

可选数组，其他主键将被忽略。

Key | 说明
"extracerts" | PKCS#12 文件中包含的额外证书或单个证书的数组。
"friendlyname" | 被证书和密钥使用的字符串

返回值

成功时返回 true， 或者在失败时返回 false。


将 PKCS#12 兼容证书存储文件导出到变量

  • ? openssl_pkcs12_export_to_file
  • openssl_pkcs12_read ?
  • PHP Manual
  • OpenSSL 函数
  • 将 PKCS#12 兼容证书存储文件导出到变量

openssl_pkcs12_export

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

openssl_pkcs12_export — 将 PKCS#12 兼容证书存储文件导出到变量

说明

openssl_pkcs12_export ( mixed $x509 , string &$out , mixed $priv_key , string $pass , array $args = ? ) : bool

openssl_pkcs12_export() 以 PKCS#12 文件格式 将 x509 导入到以out命名类型为字符串的变量中。

参数

x509

参见密钥／证书参数以获取有效值列表。

out

成功，该字符串将为 PKCS#12 格式。

priv_key

PKCS#12 文件的私钥部分file， 参见 公/私钥参数 获取更多可用列表。

pass

用来解锁 PKCS#12 文件的解密密码。

args

可选数组，其他主键将被忽略。

Key | 说明
"extracerts" | PKCS#12 文件中包含的额外证书或单个证书的数组。
"friendlyname" | 被证书和密钥使用的字符串

返回值

成功时返回 true， 或者在失败时返回 false。


将 PKCS#12 证书存储区解析到数组中

  • ? openssl_pkcs12_export
  • openssl_pkcs7_decrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 将 PKCS#12 证书存储区解析到数组中

openssl_pkcs12_read

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

openssl_pkcs12_read — 将 PKCS#12 证书存储区解析到数组中

说明

openssl_pkcs12_read ( string $pkcs12 , array &$certs , string $pass ) : bool

openssl_pkcs12_read() 将pkcs12提供的PKCS#12证书存储区解析到以certs命名的变量中。

参数

pkcs12

证书存储内容，而不是它的文件名。

certs

成功，将保存证书存储数据

pass

用来解锁 PKCS#12 文件的解密密码

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 openssl_pkcs12_read() 范例

<?php
if (!$cert_store = file_get_contents("/certs/file.p12")) {
    echo "Error: Unable to read the cert file\n";
    exit;
}

if (openssl_pkcs12_read($cert_store, $cert_info, "my_secret_pass")) {
    echo "Certificate Information\n";
    print_r($cert_info);
} else {
    echo "Error: Unable to read the cert store.\n";
    exit;
}
?>


解密一个 S/MIME 加密的消息

  • ? openssl_pkcs12_read
  • openssl_pkcs7_encrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 解密一个 S/MIME 加密的消息

openssl_pkcs7_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_pkcs7_decrypt — 解密一个 S/MIME 加密的消息

说明

openssl_pkcs7_decrypt ( string $infilename , string $outfilename , mixed $recipcert , mixed $recipkey = ? ) : bool

使用由 recipcert 和 recipkey 指定的证书和与之关联的私钥解密 infilename 文件中包含的 S/MIME 加密消息

参数

infilename

outfilename

解密的消息将被存入的文件中，以outfilename命名。

recipcert

recipkey

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 openssl_pkcs7_decrypt() 范例

<?php
// $cert and $key are assumed to contain your personal certificate and private
// key pair, and that you are the recipient of an S/MIME message
$infilename = "encrypted.msg";  // this file holds your encrypted message
$outfilename = "decrypted.msg"; // make sure you can write to this file

if (openssl_pkcs7_decrypt($infilename, $outfilename, $cert, $key)) {
    echo "decrypted!";
} else {
    echo "failed to decrypt!";
}
?>


加密一个 S/MIME 消息

  • ? openssl_pkcs7_decrypt
  • openssl_pkcs7_read ?
  • PHP Manual
  • OpenSSL 函数
  • 加密一个 S/MIME 消息

openssl_pkcs7_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_pkcs7_encrypt — 加密一个 S/MIME 消息

说明

openssl_pkcs7_encrypt ( string $infile , string $outfile , mixed $recipcerts , array $headers , int $flags = 0 , int $cipherid = OPENSSL_CIPHER_RC2_40 ) : bool

openssl_pkcs7_encrypt() 获取文件名为infile的文件内容并使用 RC2 40位的密码将之加密，以至于他们只能被预期的名为recipcerts的接收者阅读。

参数

infile

outfile

recipcerts

一个单独的X.509证书，或者一个X.509证书的数组。

headers

headers 是包含头信息的数组，在被加密后将对数据进行预处理。

headers 可以是以头名为键值的关联数组，也可以是一个索引数组，其中每个元素都包含一个单独的标题行

flags

flags用来指定影响编码过程的选项 - 参见 PKCS7 常量.

cipherid

密码常量之一。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 openssl_pkcs7_encrypt() 范例

<?php
// the message you want to encrypt and send to your secret agent
// in the field, known as nighthawk.  You have his certificate
// in the file nighthawk.pem
$data = <<<EOD
Nighthawk,

Top secret, for your eyes only!

The enemy is closing in! Meet me at the cafe at 8.30am
to collect your forged passport!

HQ
EOD;

// load key
$key = file_get_contents("nighthawk.pem");

// save message to file
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);

// encrypt it
if (openssl_pkcs7_encrypt("msg.txt", "enc.txt", $key,
    array("To" => "nighthawk@example.com", // keyed syntax
          "From: HQ <hq@example.com>", // indexed syntax
          "Subject" => "Eyes only"))) {
    // message encrypted - send it!
    exec(ini_get("sendmail_path") . " < enc.txt");
}
?>


将PKCS7文件导出为PEM格式证书的数组

  • ? openssl_pkcs7_encrypt
  • openssl_pkcs7_sign ?
  • PHP Manual
  • OpenSSL 函数
  • 将PKCS7文件导出为PEM格式证书的数组

openssl_pkcs7_read

(PHP 7 >= 7.2.0, PHP 8)

openssl_pkcs7_read — 将PKCS7文件导出为PEM格式证书的数组

说明

openssl_pkcs7_read ( string $infilename , array &$certs ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

infilename

certs

返回值

成功时返回 true， 或者在失败时返回 false。


对一个 S/MIME 消息进行签名

  • ? openssl_pkcs7_read
  • openssl_pkcs7_verify ?
  • PHP Manual
  • OpenSSL 函数
  • 对一个 S/MIME 消息进行签名

openssl_pkcs7_sign

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_pkcs7_sign — 对一个 S/MIME 消息进行签名

说明

openssl_pkcs7_sign ( string $infilename , string $outfilename , mixed $signcert , mixed $privkey , array $headers , int $flags = PKCS7_DETACHED , string $extracerts = ? ) : bool

openssl_pkcs7_sign()获取名为infilename的文件内容，并使用由signcert和privkey指定的证书和与之匹配的私钥对其进行加密

参数

infilename

你打算用来进行数字签名的输入文件。

outfilename

将写入数字签名的文件。

signcert

用来对输入文件进行数字签名的 X.509 证书，参见 密钥/证书参数获取可用列表。

privkey

privkey是对应signcert证书的私钥。 参见 公/私钥参数获取可用列表。

headers

headers是一个包含头信息的数组，在它被签名后，它将被预先对数据进行预处理 (参见 openssl_pkcs7_encrypt() 获取关于该参数格式的更多信息)。

flags

flags 可以用来改变输出 - 参见 PKCS7常量。

extracerts

extracerts 指定一个文件的名称，其中包含一组含有签名的额外的证书，这些证书可以用来帮助接收者验证您使用的证书。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 openssl_pkcs7_sign() 范例

<?php
// the message you want to sign so that recipient can be sure it was you that
// sent it
$data = <<<EOD

You have my authorization to spend $10,000 on dinner expenses.

The CEO
EOD;
// save message to file
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);
// encrypt it
if (openssl_pkcs7_sign("msg.txt", "signed.txt", "file://mycert.pem",
    array("file://mycert.pem", "mypassphrase"),
    array("To" => "joes@example.com", // keyed syntax
          "From: HQ <ceo@example.com>", // indexed syntax
          "Subject" => "Eyes only")
    )) {
    // message signed - send it!
    exec(ini_get("sendmail_path") . " < signed.txt");
}
?>


校验一个已签名的 S/MIME 消息的签名

  • ? openssl_pkcs7_sign
  • openssl_pkey_derive ?
  • PHP Manual
  • OpenSSL 函数
  • 校验一个已签名的 S/MIME 消息的签名

openssl_pkcs7_verify

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_pkcs7_verify — 校验一个已签名的 S/MIME 消息的签名

说明

openssl_pkcs7_verify ( string $filename , int $flags , string $outfilename = ? , array $cainfo = ? , string $extracerts = ? , string $content = ? , string $p7bfilename = ? ) : mixed

openssl_pkcs7_verify() 读取给定文件中的 S/MIME 消息并且检查数字签名。

参数

filename

消息的路径。

flags

flags 可以用来影响如何校验签名 - 参见 PKCS7 常量 获取更多信息。

outfilename

如果已指定 outfilename 输出文件，它应该是一个用以保存文件的字符串名称，签名消息的个人证书将以 PEM 的格式保存起来。

cainfo

如果 cainfo 被指定了，它应该保存关于受信任的CA证书的信息供在验证过程中使用 - 参见 证书校验 获取关于该参数的更多信息。

extracerts

如果 extracerts 被指定了，该文件包含了一堆会被作为不受信任的ca使用的证书。

content

你可以使用 content 来指定带有已被验证数据的文件名，该文件内容已去掉了签名信息。

p7bfilename

返回值

如果签名已被认证，返回 true, 如果不正确 (消息已被篡改或者签名证书不可用) 则返回 false, 或者 - 错误时返回1.

更新日志

版本 | 说明
7.2.0 | 新增 p7bfilename 参数。

注释

Note: 正如 RFC 2045 中指定的，filename 参数最多不可超过 76 个字符串。


Computes shared secret for public value of remote and local DH or ECDH key

  • ? openssl_pkcs7_verify
  • openssl_pkey_export_to_file ?
  • PHP Manual
  • OpenSSL 函数
  • Computes shared secret for public value of remote and local DH or ECDH key

openssl_pkey_derive

(PHP 7 >= 7.3.0, PHP 8)

openssl_pkey_derive — Computes shared secret for public value of remote and local DH or ECDH key

说明

openssl_pkey_derive ( OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $public_key , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $private_key , int $key_length = 0 ) : string|false

openssl_pkey_derive() takes a set of a public_key and private_key and derives a shared secret, for either DH or EC keys.

参数

public_key

public_key is the public key for the derivation. See Public/Private Key parameters for a list of valid values.

private_key

private_key is the private key for the derivation. See Public/Private Key parameters for a list of valid values.

key_length

If not zero, will set the desired length of the derived secret.

返回值

The derived secret on success 或者在失败时返回 false.

范例

Example #1 openssl_pkey_derive() example

<?php
// Load in private key
$priv = openssl_pkey_get_private("-----BEGIN PRIVATE KEY-----
MIICJgIBADCCARcGCSqGSIb3DQEDATCCAQgCggEBAJLxRCaZ933uW+AXmabHFDDy
upojBIRlbmQLJZfigDaSA1f9YOTsIv+WwVFTX/J1mtCyx9uBcz0Nt2kmVwxWuc2f
VtCEMPsmLsVXX7xRUFLpyX1Y1IYGBVXQOoOvLWYQjpZgnx47Pkh1Ok1+smffztfC
0DCNt4KorWrbsPcmqBejXHN79KvWFjZmXOksRiNu/Bn76RiqvofC4z8Ri3kHXQG2
197JGZzzFXHadGC3xbkg8UxsNbYhVMKbm0iANfafUH7/hoS9UjAVQYtvwe7YNiW/
HnyfVCrKwcc7sadd8Iphh+3lf5P1AhaQEAMytanrzq9RDXKBxuvpSJifRYasZYsC
AQIEggEEAoIBAGwAYC2E81Y1U2Aox0U7u1+vBcbht/OO87tutMvc4NTLf6NLPHsW
cPqBixs+3rSn4fADzAIvdLBmogjtiIZoB6qyHrllF/2xwTVGEeYaZIupQH3bMK2b
6eUvnpuu4Ytksiz6VpXBBRMrIsj3frM+zUtnq8vKUr+TbjV2qyKR8l3eNDwzqz30
dlbKh9kIhZafclHfRVfyp+fVSKPfgrRAcLUgAbsVjOjPeJ90xQ4DTMZ6vjiv6tHM
hkSjJIcGhRtSBzVF/cT38GyCeTmiIA/dRz2d70lWrqDQCdp9ArijgnpjNKAAulSY
CirnMsGZTDGmLOHg4xOZ5FEAzZI2sFNLlcw=
-----END PRIVATE KEY-----
");

// Load in public key
$pub = openssl_pkey_get_public("-----BEGIN PUBLIC KEY-----
MIICJDCCARcGCSqGSIb3DQEDATCCAQgCggEBAJLxRCaZ933uW+AXmabHFDDyupoj
BIRlbmQLJZfigDaSA1f9YOTsIv+WwVFTX/J1mtCyx9uBcz0Nt2kmVwxWuc2fVtCE
MPsmLsVXX7xRUFLpyX1Y1IYGBVXQOoOvLWYQjpZgnx47Pkh1Ok1+smffztfC0DCN
t4KorWrbsPcmqBejXHN79KvWFjZmXOksRiNu/Bn76RiqvofC4z8Ri3kHXQG2197J
GZzzFXHadGC3xbkg8UxsNbYhVMKbm0iANfafUH7/hoS9UjAVQYtvwe7YNiW/Hnyf
VCrKwcc7sadd8Iphh+3lf5P1AhaQEAMytanrzq9RDXKBxuvpSJifRYasZYsCAQID
ggEFAAKCAQAiCSBpxvGgsTorxAWtcAlSmzAJnJxFgSPef0g7OjhESytnc8G2QYmx
ovMt5KVergcitztWh08hZQUdAYm4rI+zMlAFDdN8LWwBT/mGKSzRkWeprd8E7mvy
ucqC1YXCMqmIwPySvLQUB/Dl8kgau7BLAnIJm8VP+MVrn8g9gghD0qRCgPgtEaDV
vocfgnOU43rhKnIgO0cHOKtw2qybSFB8QuZrYugq4j8Bwkrzh6rdMMeyMl/ej5Aj
c0wamOzuBDtXt0T9+Fx3khHaowjCc7xJZRgZCxg43SbqMWJ9lUg94I7+LTX61Gyv
dtlkbGbtoDOnxeNnN93gwQZngGYZYciu
-----END PUBLIC KEY-----
");

// Outputs the hex version of the derived key
echo bin2hex(openssl_pkey_derive($pub,$priv));


将密钥导出到文件中

  • ? openssl_pkey_derive
  • openssl_pkey_export ?
  • PHP Manual
  • OpenSSL 函数
  • 将密钥导出到文件中

openssl_pkey_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_export_to_file — 将密钥导出到文件中

说明

openssl_pkey_export_to_file ( mixed $key , string $outfilename , string $passphrase = ? , array $configargs = ? ) : bool

openssl_pkey_export_to_file() 将 ascii 格式 (PEM编码)的 key 保存到名为outfilename文件中。

Note: 必须安装有效的 openssl.cnf 以保证此函数正确运行。参考有关安装的说明以获得更多信息。

参数

key

outfilename

输出文件的路径。

passphrase

密钥可以通过值为passphrase的密码来保护。

configargs

configargs 可以用来调整导出流程，通过指定或者覆盖openssl配置文件选项。参见 openssl_csr_new() 获取更多关于 configargs 的信息。

返回值

成功时返回 true， 或者在失败时返回 false。


将一个密钥的可输出表示转换为字符串

  • ? openssl_pkey_export_to_file
  • openssl_pkey_free ?
  • PHP Manual
  • OpenSSL 函数
  • 将一个密钥的可输出表示转换为字符串

openssl_pkey_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_export — 将一个密钥的可输出表示转换为字符串

说明

openssl_pkey_export ( mixed $key , string &$out , string $passphrase = ? , array $configargs = ? ) : bool

openssl_pkey_export() 将 key 当作 PEM 编码字符串导出并且将之保存到out (通过引用传递的)中。

Note: 必须安装有效的 openssl.cnf 以保证此函数正确运行。参考有关安装的说明以获得更多信息。

参数

key

out

passphrase

密钥可以通过 passphrase 来保护。

configargs

configargs 可以用来调整导出流程，通过指定或者覆盖openssl配置文件选项。参见 openssl_csr_new() 获取更多关于 configargs 的信息。

返回值

成功时返回 true， 或者在失败时返回 false。


释放一个私钥

  • ? openssl_pkey_export
  • openssl_pkey_get_details ?
  • PHP Manual
  • OpenSSL 函数
  • 释放一个私钥

openssl_pkey_free

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_free — 释放一个私钥

说明

openssl_pkey_free ( resource $key ) : void

该函数释放由openssl_pkey_new()创建的私钥。

参数

key

持有该密钥的资源。

返回值

没有返回值。


返回包含密钥详情的数组

  • ? openssl_pkey_free
  • openssl_pkey_get_private ?
  • PHP Manual
  • OpenSSL 函数
  • 返回包含密钥详情的数组

openssl_pkey_get_details

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

openssl_pkey_get_details — 返回包含密钥详情的数组

说明

openssl_pkey_get_details ( resource $key ) : array

该函数返回密钥详情(位长度，密钥，类型).

参数

key

持有密钥的资源。

返回值

成功，返回包含密钥详情的数组，失败返回 false . 返回的数组中包含了如下索引： bits (位数), key (表示公钥的字符串) 和 type (如下密钥类型之一： OPENSSL_KEYTYPE_RSA, OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH, OPENSSL_KEYTYPE_EC 或者 未知类型返回1).

取决于所使用密钥的类型，可能会返回其他额外的信息。请注意，有些元素可能并不总是可用的。

  • OPENSSL_KEYTYPE_RSA, 一个额外的键名为 "rsa"的数组，包含了以下密钥数据：
    Key | 说明
    "n" | modulus
    "e" | public exponent
    "d" | private exponent
    "p" | prime 1
    "q" | prime 2
    "dmp1" | exponent1, d mod (p-1)
    "dmq1" | exponent2, d mod (q-1)
    "iqmp" | coefficient, (inverse of q) mod p
  • OPENSSL_KEYTYPE_DSA, 一个额外的键为 "dsa" 的数组， 包含如下的密钥数据。
    Key | 说明
    "p" | prime number (public)
    "q" | 160-bit subprime, q | p-1 (public)
    "g" | generator of subgroup (public)
    "priv_key" | private key x
    "pub_key" | public key y = g^x
  • OPENSSL_KEYTYPE_DH, 一个额外的键为 "dh" 的数组，包含如下的密钥数据。
    Key | 说明
    "p" | prime number (shared)
    "g" | generator of Z_p (shared)
    "priv_key" | private DH value x
    "pub_key" | public DH value g^x
  • OPENSSL_KEYTYPE_EC, 一个额外的键为 "ec" 的数组,包含如下的密钥数据。
    Key | 说明
    "curve_name" | name of curve, see openssl_get_curve_names()
    "curve_oid" | ASN1 Object identifier (OID) for EC curve.
    "x" | x coordinate (public)
    "y" | y coordinate (public)
    "d" | private key


获取私钥

  • ? openssl_pkey_get_details
  • openssl_pkey_get_public ?
  • PHP Manual
  • OpenSSL 函数
  • 获取私钥

openssl_pkey_get_private

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_get_private — 获取私钥

说明

openssl_pkey_get_private ( mixed $key , string $passphrase = "" ) : resource

openssl_get_privatekey() 解析 key 供其他函数使用。

参数

key

key 可以是如下密钥之一：

  1. 如下格式的字符串 file://path/to/file.pem。该文件必须包含 PEM 编码的证书或者私钥 (可能都包含了).
  2. 一个PEM格式的私钥。

passphrase

如果指定的密钥已被加密了(受密码保护)，可选参数 passphrase 是必须要的。

返回值

成功，返回真实的密钥资源标识符，失败，返回 false .


从证书中解析公钥，以供使用。

  • ? openssl_pkey_get_private
  • openssl_pkey_new ?
  • PHP Manual
  • OpenSSL 函数
  • 从证书中解析公钥，以供使用。

openssl_pkey_get_public

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_get_public — 从证书中解析公钥，以供使用。

说明

openssl_pkey_get_public ( mixed $certificate ) : resource

openssl_get_publickey() 从 certificate 中解析公钥，供其他函数使用。

参数

certificate

certificate 可以是以下之一：

  1. 一个 X.509 证书资源
  2. 一个file://path/to/file.pem格式的字符串。文件名必须包含一个PEM编码的证书或者密钥(也许二者都有).
  3. 一个 PEM 格式的公钥。

返回值

成功，返回真实的密钥资源标识符，错误，则返回 false


生成一个新的私钥

  • ? openssl_pkey_get_public
  • openssl_private_decrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 生成一个新的私钥

openssl_pkey_new

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_pkey_new — 生成一个新的私钥

说明

openssl_pkey_new ( array|null $options = null ) : OpenSSLAsymmetricKey|false

openssl_pkey_new() 生成一个新的私钥和公钥对。如何获取该密钥的公共组件参见以下示例。

Note: 必须安装有效的 openssl.cnf 以保证此函数正确运行。参考有关安装的说明以获得更多信息。

参数

options

你可以使用 options 参数微调密钥的生成（比如指定位数）。查看 openssl_csr_new() 获取更多关于 options 的信息。

返回值

成功时返回 OpenSSLAsymmetricKey 实例，错误则返回 false 。

更新日志

版本 | 说明
8.0.0 | 成功时此函数会返回 OpenSSLAsymmetricKey 的实例；在之前版本中，则会返回类似为 OpenSSL key 的 资源(resource)。
7.1.0 | 添加了 curve_name 配置参数使得可以创建 EC 密钥。

范例

Example #1 Obtain the public key from a private key

<?php
$private_key = openssl_pkey_new();
$public_key_pem = openssl_pkey_get_details($private_key)['key'];
echo $public_key_pem;
$public_key = openssl_pkey_get_public($public_key_pem);
var_dump($public_key);
?>

以上例程的输出类似于：

-----BEGIN PUBLIC KEY-----
MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEArZFsmN2P6rx1Xt7YV95o
gcdlal0k3ryiIhFNzjwtRNNTXfEfBr6lUuaIJYQ8/XqEBX0hpcfuuF6tTRlonA3t
WLME0QFD93YVsAaXcy76YqjjqcRRodIBphAbYyyMI/lXkQAdn7kbAmr7neSOsMYJ
El9Wo4Hl4oG6e52ZnYHyqW9dxh4hX93eupR2TmcCdVf+r9xoHewP0KJYSHt7vDUX
AQlWYcQiWHIadFsmL0orr6mutlXFReoHbesgKY9/3YLOu0JfxflSjIZ2JeL1NTl1
MsmODsUwgAUrwnWKKx+eQUP5g3GnSB3dPkRh9zRVRiLNWbCugyjrf3e6DgQWrW7j
pwIDAQAB
-----END PUBLIC KEY-----
resource(5) of type (OpenSSL key)


使用私钥解密数据

  • ? openssl_pkey_new
  • openssl_private_encrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 使用私钥解密数据

openssl_private_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_private_decrypt — 使用私钥解密数据

说明

openssl_private_decrypt ( string $data , string &$decrypted , mixed $key , int $padding = OPENSSL_PKCS1_PADDING ) : bool
Caution

本函数并不会生成安全加密的值，不应用于加密用途。若需要安全加密的值，考虑使用 random_int()、random_bytes() 或 openssl_random_pseudo_bytes() 替代。

openssl_private_decrypt() 解密先前通过 openssl_public_encrypt() 函数加密的 data 并将结果保存至decrypted变量中。

你可以用该函数来解密只对你可用的数据。

参数

data

decrypted

key

key 必须是和用来加密数据所用公钥对应的私钥。

padding

padding 可以是如下值： OPENSSL_PKCS1_PADDING, OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openssl_public_encrypt() - 使用公钥加密数据
  • openssl_public_decrypt() - 使用公钥解密数据


使用私钥加密数据

  • ? openssl_private_decrypt
  • openssl_public_decrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 使用私钥加密数据

openssl_private_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_private_encrypt — 使用私钥加密数据

说明

openssl_private_encrypt ( string $data , string &$crypted , mixed $key , int $padding = OPENSSL_PKCS1_PADDING ) : bool

openssl_private_encrypt() 使用私钥 key 加密数据 data 并且将结果保存至变量 crypted中。加密后的数据可以通过openssl_public_decrypt()函数来解密。

该函数用来签名数据（或者哈希）让别人相信数据并不是其他人写的。

参数

data

crypted

key

padding

padding 可以是如下之一： OPENSSL_PKCS1_PADDING, OPENSSL_NO_PADDING.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openssl_public_encrypt() - 使用公钥加密数据
  • openssl_public_decrypt() - 使用公钥解密数据


使用公钥解密数据

  • ? openssl_private_encrypt
  • openssl_public_encrypt ?
  • PHP Manual
  • OpenSSL 函数
  • 使用公钥解密数据

openssl_public_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_public_decrypt — 使用公钥解密数据

说明

openssl_public_decrypt ( string $data , string &$decrypted , mixed $key , int $padding = OPENSSL_PKCS1_PADDING ) : bool

openssl_public_decrypt() 解密先前由 openssl_private_encrypt() 加密的数据 data 并且将结果保存至变量 decrypted中。

你可以用该函数来校验消息是否是私钥拥有者写的。

参数

data

decrypted

key

key 必须是和用来加密数据的私钥配对的公钥。

padding

padding 可以是如下至 OPENSSL_PKCS1_PADDING, OPENSSL_NO_PADDING.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openssl_private_encrypt() - 使用私钥加密数据
  • openssl_private_decrypt() - 使用私钥解密数据


使用公钥加密数据

  • ? openssl_public_decrypt
  • openssl_random_pseudo_bytes ?
  • PHP Manual
  • OpenSSL 函数
  • 使用公钥加密数据

openssl_public_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_public_encrypt — 使用公钥加密数据

说明

openssl_public_encrypt ( string $data , string &$crypted , mixed $key , int $padding = OPENSSL_PKCS1_PADDING ) : bool

openssl_public_encrypt() 使用公钥key解密数据 data 并且将结果保存到变量crypted中。 加密的数据可以通过openssl_private_decrypt()函数解密。

该函数可以用来加密数据，供该公钥匹配的私钥拥有者读取。 它也可以用来在数据库中存储安全数据。

参数

data

crypted

这将保存加密的结果。

key

公钥。

padding

padding can be one of OPENSSL_PKCS1_PADDING, OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • openssl_private_encrypt() - 使用私钥加密数据
  • openssl_private_decrypt() - 使用私钥解密数据


生成一个伪随机字节串

  • ? openssl_public_encrypt
  • openssl_seal ?
  • PHP Manual
  • OpenSSL 函数
  • 生成一个伪随机字节串

openssl_random_pseudo_bytes

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

openssl_random_pseudo_bytes — 生成一个伪随机字节串

说明

openssl_random_pseudo_bytes ( int $length , bool &$crypto_strong = ? ) : string

生成一个伪随机字节串 string ，字节数由 length 参数指定。

通过 crypto_strong 参数可以表示在生成随机字节的过程中是否使用了强加密算法。返回值为false的情况很少见，但已损坏或老化的有些系统上会出现。

参数

length

所需字节串的长度，必须为正整数。PHP会试着将该参数转换为非空整数来使用它。

crypto_strong

如果传递到该函数中，将会保存为一个 boolean 值来表明是否使用了"强加密"，如果被用于GPG和密码之类的将返回true , 否则返回 false

返回值

成功，返回生成的字节串 string ， 或者在失败时返回 false.

范例

Example #1 openssl_random_pseudo_bytes() 范例：

<?php
for ($i = -1; $i <= 4; $i++) {
    $bytes = openssl_random_pseudo_bytes($i, $cstrong);
    $hex   = bin2hex($bytes);

    echo "Lengths: Bytes: $i and Hex: " . strlen($hex) . PHP_EOL;
    var_dump($hex);
    var_dump($cstrong);
    echo PHP_EOL;
}
?>

以上例程的输出类似于：

Lengths: Bytes: -1 and Hex: 0
string(0) ""
NULL

Lengths: Bytes: 0 and Hex: 0
string(0) ""
NULL

Lengths: Bytes: 1 and Hex: 2
string(2) "42"
bool(true)

Lengths: Bytes: 2 and Hex: 4
string(4) "dc6e"
bool(true)

Lengths: Bytes: 3 and Hex: 6
string(6) "288591"
bool(true)

Lengths: Bytes: 4 and Hex: 8
string(8) "ab86d144"
bool(true)

参见

  • random_bytes() - Generates cryptographically secure pseudo-random bytes
  • bin2hex() - 函数把包含数据的二进制字符串转换为十六进制值
  • crypt() - 单向字符串散列
  • mt_rand() - 生成更好的随机数
  • uniqid() - 生成一个唯一ID


密封 (加密) 数据

  • ? openssl_random_pseudo_bytes
  • openssl_sign ?
  • PHP Manual
  • OpenSSL 函数
  • 密封 (加密) 数据

openssl_seal

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_seal — 密封 (加密) 数据

说明

openssl_seal ( string $data , string &$sealed_data , array &$env_keys , array $pub_key_ids , string $method = "RC4" , string &$iv = ? ) : int

openssl_seal() 使用随机生成的密钥和给定的 method 方法密封 (加密) data 数据。 密钥用与pub_key_ids中的标识符相关联的每个公共密钥加密，并且每个加密密钥在env_keys中返回。 这意味着一个人可以将密封的数据发送给多个接收者(如果一个人已经获得了他们的公钥)。每个接收方都必须同时接收加密的数据和用接收方的公钥加密的信封密钥。

参数

data

要密封的数据。

sealed_data

被密封后的数据。

env_keys

已被加密的密钥数组。

pub_key_ids

公钥资源标识符组成的数组。

method

加密算法。

iv

初始化向量。

返回值

成功，返回密封后数据的长度，错误，返回 false . 如果密封后的数据成功地通过sealed_data变量返回，那么信封密钥也将会通过 env_keys 变量返回。

更新日志

版本 | 说明
7.0.0 | 添加 iv 变量。
5.3.0 | 添加 method 变量。

范例

Example #1 openssl_seal() 范例：

<?php
// $data is assumed to contain the data to be sealed

// fetch public keys for our recipients, and ready them
$fp = fopen("/src/openssl-0.9.6/demos/maurice/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk1 = openssl_get_publickey($cert);
// Repeat for second recipient
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk2 = openssl_get_publickey($cert);

// seal message, only owners of $pk1 and $pk2 can decrypt $sealed with keys
// $ekeys[0] and $ekeys[1] respectively.
openssl_seal($data, $sealed, $ekeys, array($pk1, $pk2));

// free the keys from memory
openssl_free_key($pk1);
openssl_free_key($pk2);
?>

参见

  • openssl_open() - 打开密封的数据


Generate signature

  • ? openssl_seal
  • openssl_spki_export_challenge ?
  • PHP Manual
  • OpenSSL 函数
  • Generate signature

openssl_sign

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_sign — Generate signature

说明

openssl_sign ( string $data , string &$signature , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $private_key , string|int $algorithm = OPENSSL_ALGO_SHA1 ) : bool

openssl_sign() computes a signature for the specified data by generating a cryptographic digital signature using the private key associated with private_key. Note that the data itself is not encrypted.

参数

data

The string of data you wish to sign

signature

If the call was successful the signature is returned in signature.

private_key

OpenSSLAsymmetricKey - a key, returned by openssl_get_privatekey()

string - a PEM formatted key

algorithm

int - one of these Signature Algorithms.

string - a valid string returned by openssl_get_md_methods() example, "sha256WithRSAEncryption" or "sha384".

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | private_key accepts an OpenSSLAsymmetricKey or OpenSSLCertificate instance now; previously, a 资源(resource) of type OpenSSL key or OpenSSL X.509 was accepted.

范例

Example #1 openssl_sign() example

<?php
// $data is assumed to contain the data to be signed

// fetch private key from file and ready it
$pkeyid = openssl_pkey_get_private("file://src/openssl-0.9.6/demos/sign/key.pem");

// compute signature
openssl_sign($data, $signature, $pkeyid);

// free the key from memory
openssl_free_key($pkeyid);
?>

Example #2 openssl_sign() example

<?php
//data you want to sign
$data = 'my data';

//create new private and public key
$new_key_pair = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));
openssl_pkey_export($new_key_pair, $private_key_pem);

$details = openssl_pkey_get_details($new_key_pair);
$public_key_pem = $details['key'];

//create signature
openssl_sign($data, $signature, $private_key_pem, OPENSSL_ALGO_SHA256);

//save for later
file_put_contents('private_key.pem', $private_key_pem);
file_put_contents('public_key.pem', $public_key_pem);
file_put_contents('signature.dat', $signature);

//verify signature
$r = openssl_verify($data, $signature, $public_key_pem, "sha256WithRSAEncryption");
var_dump($r);
?>

参见

  • openssl_verify() - 验证签名


导出与签名公钥和挑战相关的挑战字符串

  • ? openssl_sign
  • openssl_spki_export ?
  • PHP Manual
  • OpenSSL 函数
  • 导出与签名公钥和挑战相关的挑战字符串

openssl_spki_export_challenge

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_spki_export_challenge — 导出与签名公钥和挑战相关的挑战字符串

说明

openssl_spki_export_challenge ( string &$spkac ) : string

导出与签名公钥和挑战相关的挑战字符串

参数

spkac

包含一个可用的签名公钥和挑战

返回值

成功，返回相关的挑战字符串，失败返回NULL.

错误／异常

如果 spkac 传递的是一个不可用的参数，则抛出一个 E_WARNING 级的错误。

范例

Example #1 openssl_spki_export_challenge() 范例：

成功，提取相关联的挑战字符串，失败则返回 NULL.

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');
$challenge = openssl_spki_export_challenge(preg_replace('/SPKAC=/', '', $spkac));
?>

Example #2 openssl_spki_export_challenge() 来自 <keygen> 元素的范例：

从 <keygen> 元素中解压相关联的挑战字符串。

<?php
$challenge = openssl_spki_export_challenge(preg_replace('/SPKAC=/', '', $_POST['spkac']));
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

参见

  • openssl_spki_new() - 生成一个新的签名公钥和挑战
  • openssl_spki_verify() - 验证签名公钥和挑战。
  • openssl_spki_export() - 通过签名公钥和挑战导出一个可用的PEM格式的公钥
  • openssl_md_method()
  • openssl_csr_new() - 生成一个 CSR
  • openssl_csr_sign() - 用另一个证书签署 CSR (或者本身) 并且生成一个证书


通过签名公钥和挑战导出一个可用的PEM格式的公钥

  • ? openssl_spki_export_challenge
  • openssl_spki_new ?
  • PHP Manual
  • OpenSSL 函数
  • 通过签名公钥和挑战导出一个可用的PEM格式的公钥

openssl_spki_export

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_spki_export — 通过签名公钥和挑战导出一个可用的PEM格式的公钥

说明

openssl_spki_export ( string &$spkac ) : string

从编码的签名公钥和挑战导出PEM格式的公钥。

参数

spkac

期望一个有效的签名公钥和挑战字符串。

返回值

成功，返回关联的PEM格式的公钥，失败则返回 NULL.

错误／异常

如果传递给 spkac 参数是一个不可用的参数，则会抛出一个E_WARNING级的警告。

范例

Example #1 openssl_spki_export() 范例：

成功，返回关联的PEM格式的公钥，失败则返回 NULL.

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');
$pubKey = openssl_spki_export(preg_replace('/SPKAC=/', '', $spkac));

if ($pubKey) {
    echo $pubKey;
}
?>

Example #2 openssl_spki_export() example from <keygen>

通过<keygen> 元素导出关联的PEM格式的公钥：

<?php
$spkac = openssl_spki_export(preg_replace('/SPKAC=/', '', $_POST['spkac']));
if ($spkac != NULL) {
    echo $spkac;
} else {
    echo "Extraction of pub key failed";
}
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

参见

  • openssl_spki_new() - 生成一个新的签名公钥和挑战
  • openssl_spki_verify() - 验证签名公钥和挑战。
  • openssl_spki_export_challenge() - 导出与签名公钥和挑战相关的挑战字符串
  • openssl_md_method()
  • openssl_csr_new() - 生成一个 CSR
  • openssl_csr_sign() - 用另一个证书签署 CSR (或者本身) 并且生成一个证书


生成一个新的签名公钥和挑战

  • ? openssl_spki_export
  • openssl_spki_verify ?
  • PHP Manual
  • OpenSSL 函数
  • 生成一个新的签名公钥和挑战

openssl_spki_new

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_spki_new — 生成一个新的签名公钥和挑战

说明

openssl_spki_new ( resource &$privkey , string &$challenge , int $algorithm = 0 ) : string

使用指定的哈希算法生成一个新的签名公钥和挑战。

参数

privkey

privkey 应该被设置为由openssl_pkey_new()函数预先生成(或者以其他方式从openssl_pkey函数集中获得)的私钥。该密钥的相应公共部分将用于签署CSR.

challenge

与SPKAC有关的挑战。

algorithm

摘要算法。参见 openssl_get_md_method()函数。

返回值

成功，返回一个签名的公钥和挑战，失败返回 NULL .

错误／异常

如果 algorithm 参数是一个未知的签名算法，将会抛出一个 E_WARNING 级的错误。

范例

Example #1 openssl_spki_new() 范例：

使用默认的摘要算法(MD5)生成一个新的SPKAC

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'testing');

if ($spkac !== NULL) {
    echo $spkac;
} else {
    echo "SPKAC generation failed";
}
?>

以上例程的输出类似于：

MIICRzCCAS8wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDM3V3sS4o4
mB9dczziRnjGAmSp+JwPrHoYMAFGvDNmZGyiWfU586X4BKs++BAj7e/FsAfno0Hd
hN9FwpCNFSox30L03nQvLYJE7f/WqigwBeMRT7Op/xvFks4sT70xP2HRYv4KqP9a
WRcKU6cFH8VxhFhqM2txEIxZKdFLaL28yT7bEDmcglf4JLDdgNMb9rET1dkgtKE6
dOaJHPGjf1uvnOH4YwkQr7n4sLUR3Kdbh0ZJAFuQVDZulo+LLzxBBkqJJcB6FhF+
oXCdHTKZnqAhpWDz+NXYytAmevab6IYm5TWPWsJUv1YKJA5lg2mXbbloIZlN9Mgc
i9fi03bdw+crAgMBAAEWB3Rlc3RpbmcwDQYJKoZIhvcNAQEEBQADggEBALyUvP/o
pPSoWBlorFyZ2RnGwKf9qMpE0q2IJP7G3oDR4LyK/m933DUiZ+YnqThrH/CWb4Ek
y5I3OCyl3S4wCuU1ibZZwDVwYShr5ELp0J9PEf7qMQZOhNsizoC7k+Czb2xB6hYW
sKfsfTKm3cXBtH3fdgc/Z1Z7VSWnAzYo38snqm72NTf5yFRnrQdphNNXi+kn1zHA
lxXRyFDXHOcYsOnwAWfyXFA4QDHQ0ezz0UoCY8gJXovcZb4GRYqOLUAsF2HcNboy
29WN8VqE29sL9QxVZFlwMcqyoLcNnyw38GvNvAGqSvzzbnEFP2MAQXJVe0H0hdp/
MML5G2iNVgNozAo=

参见

  • openssl_spki_new()
  • openssl_spki_export_challenge() - 导出与签名公钥和挑战相关的挑战字符串
  • openssl_spki_export() - 通过签名公钥和挑战导出一个可用的PEM格式的公钥
  • openssl_csr_new() - 生成一个 CSR
  • openssl_csr_sign() - 用另一个证书签署 CSR (或者本身) 并且生成一个证书


验证签名公钥和挑战。

  • ? openssl_spki_new
  • openssl_verify ?
  • PHP Manual
  • OpenSSL 函数
  • 验证签名公钥和挑战。

openssl_spki_verify

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_spki_verify — 验证签名公钥和挑战。

说明

openssl_spki_verify ( string &$spkac ) : string

验证所提供的签名公钥和挑战。

参数

spkac

期望一个有效的签名公钥和挑战。

返回值

成功，返回true, 失败返回false.

错误／异常

如果spkac参数不是一个可用的参数，将会抛出一个 E_WARNING 等级的错误。

范例

Example #1 openssl_spki_verify() 范例：

验证现有签名公钥和挑战

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');

if (openssl_spki_verify(preg_replace('/SPKAC=/', '', $spkac))) {
    echo $spkac;
} else {
    echo "SPKAC validation failed";
}
?>

Example #2 openssl_spki_verify() example from <keygen>

通过<keygen> 元素验证现有签名公钥和挑战

<?php
if (openssl_spki_verify(preg_replace('/SPKAC=/', '', $_POST['spkac']))) {
    echo $spkac;
} else {
    echo "SPKAC validation failed";
}
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

参见

  • openssl_spki_new() - 生成一个新的签名公钥和挑战
  • openssl_spki_export_challenge() - 导出与签名公钥和挑战相关的挑战字符串
  • openssl_spki_export() - 通过签名公钥和挑战导出一个可用的PEM格式的公钥
  • openssl_md_method()
  • openssl_csr_new() - 生成一个 CSR
  • openssl_csr_sign() - 用另一个证书签署 CSR (或者本身) 并且生成一个证书


验证签名

  • ? openssl_spki_verify
  • openssl_x509_check_private_key ?
  • PHP Manual
  • OpenSSL 函数
  • 验证签名

openssl_verify

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

openssl_verify — 验证签名

说明

openssl_verify ( string $data , string $signature , mixed $pub_key_id , mixed $signature_alg = OPENSSL_ALGO_SHA1 ) : int

openssl_verify() 使用与pub_key_id关联的公钥验证指定数据data的签名signature是否正确。这必须是与用于签名的私钥相对应的公钥。

参数

data

以前用来生成签名的数据字符串。

signature

原始二进制字符串，通过openssl_sign()或类似的函数生成。

pub_key_id

resource - 一个密钥, 通过 openssl_get_publickey() 函数返回。

string - 一个 PEM 格式的密钥, 比如, "-----BEGIN PUBLIC KEY----- MIIBCgK..."

signature_alg

int - 以下签名算法之一Signature Algorithms.

string - 由openssl_get_md_methods()函数返回的可用字符串，比如， "sha1WithRSAEncryption" 或者 "sha512".

返回值

如果签名正确返回 1, 签名错误返回 0, 内部发生错误则返回-1.

更新日志

版本 | 说明
5.2.0 | 添加了 signature_alg 参数。

范例

Example #1 openssl_verify() 范例：

<?php
// $data and $signature are assumed to contain the data and the signature

// fetch public key from certificate and ready it
$pubkeyid = openssl_pkey_get_public("file://src/openssl-0.9.6/demos/sign/cert.pem");

// state whether signature is okay or not
$ok = openssl_verify($data, $signature, $pubkeyid);
if ($ok == 1) {
    echo "good";
} elseif ($ok == 0) {
    echo "bad";
} else {
    echo "ugly, error checking signature";
}
// free the key from memory
openssl_free_key($pubkeyid);
?>

Example #2 openssl_verify() 范例：

<?php
//data you want to sign
$data = 'my data';

//create new private and public key
$private_key_res = openssl_pkey_new(array(
    "private_key_bits" => 2048,
    "private_key_type" => OPENSSL_KEYTYPE_RSA,
));
$details = openssl_pkey_get_details($private_key_res);
$public_key_res = openssl_pkey_get_public($details['key']);

//create signature
openssl_sign($data, $signature, $private_key_res, "sha1WithRSAEncryption");

//verify signature
$ok = openssl_verify($data, $signature, $public_key_res, OPENSSL_ALGO_SHA1);
if ($ok == 1) {
    echo "valid";
} elseif ($ok == 0) {
    echo "invalid";
} else {
    echo "error: ".openssl_error_string();
}
?>

参见

  • openssl_sign() - Generate signature


检查私钥是否对应于证书

  • ? openssl_verify
  • openssl_x509_checkpurpose ?
  • PHP Manual
  • OpenSSL 函数
  • 检查私钥是否对应于证书

openssl_x509_check_private_key

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_x509_check_private_key — 检查私钥是否对应于证书

说明

openssl_x509_check_private_key ( mixed $cert , mixed $key ) : bool

检查给定的私钥 key 是否和证书 cert 对应。

Warning

这个函数不会检查密钥key是否真的是私钥。 它只是比较了和密钥匹配的公共材料 (比如，RSA密钥的指数和模量) 和/或密钥参数(比如，EC密钥的参数)。

这也意味着，比如，提供给key赋一个公钥值，该函数可能返回 true.

参数

cert

证书。

key

私钥。

返回值

如果给定的私钥 key 和证书 cert对应， 返回true 否则返回 false .


验证是否可以为特定目的使用证书

  • ? openssl_x509_check_private_key
  • openssl_x509_export_to_file ?
  • PHP Manual
  • OpenSSL 函数
  • 验证是否可以为特定目的使用证书

openssl_x509_checkpurpose

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_x509_checkpurpose — 验证是否可以为特定目的使用证书

说明

openssl_x509_checkpurpose ( mixed $x509cert , int $purpose , array $cainfo = array() , string $untrustedfile = ? ) : int

openssl_x509_checkpurpose() 检查证书以查看它是否可用于指定目的 purpose.

参数

x509cert

被检查的证书。

purpose

openssl_x509_checkpurpose() 目的
常量名 | 描述
X509_PURPOSE_SSL_CLIENT | 证书是否可以用于SSL连接的客户端?
X509_PURPOSE_SSL_SERVER | 证书是否可以用于SSL连接的服务器端?
X509_PURPOSE_NS_SSL_SERVER | 证书是否可以用于Netscape SSL服务器?
X509_PURPOSE_SMIME_SIGN | 证书是否可以用来签名 S/MIME 邮件?
X509_PURPOSE_SMIME_ENCRYPT | 正式是否可用用来加密 S/MIME 邮件?
X509_PURPOSE_CRL_SIGN | 证书是否可以用来签名证书撤销列表(CRL)?
X509_PURPOSE_ANY | 证书是否可以用于任何目的?
这些选项不是位字段——您只能指定一个字段!

cainfo

cainfo 应该是一个受信任的 CA 文件/文件夹组成的数组，如Certificate Verification所描述的一样。

untrustedfile

如果指定，这应该是PEM编码文件的名称，该文件持有证书，可以用来帮助验证证书,尽管从该文件中获得的证书不受信任。

返回值

如果证书可以用于预期目的，返回 true,如果不行，则返回 false 错误便会返回 -1。


导出证书至文件

  • ? openssl_x509_checkpurpose
  • openssl_x509_export ?
  • PHP Manual
  • OpenSSL 函数
  • 导出证书至文件

openssl_x509_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_x509_export_to_file — 导出证书至文件

说明

openssl_x509_export_to_file ( mixed $x509 , string $outfilename , bool $notext = true ) : bool

openssl_x509_export_to_file() 将 x509 以PEM编码的格式保存到名为 outfilename 的文件中。

参数

x509

参见密钥／证书参数以获取有效值列表。

outfilename

输出文件的路径。

notext

可选参数 notext 影响输出的冗余度。如果设为 false，输出内容将包含附加的人类可读信息。notext 的缺省值为 true。

返回值

成功时返回 true， 或者在失败时返回 false。


以字符串格式导出证书

  • ? openssl_x509_export_to_file
  • openssl_x509_fingerprint ?
  • PHP Manual
  • OpenSSL 函数
  • 以字符串格式导出证书

openssl_x509_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

openssl_x509_export — 以字符串格式导出证书

说明

openssl_x509_export ( mixed $x509 , string &$output , bool $notext = true ) : bool

openssl_x509_export() 将 x509 以PEM编码的格式导出到名为 output 的字符串类型的变量中。

参数

x509

参见密钥／证书参数以获取有效值列表。

output

成功，将会存储 PEM.

notext

可选参数 notext 影响输出的冗余度。如果设为 false，输出内容将包含附加的人类可读信息。notext 的缺省值为 true。

返回值

成功时返回 true， 或者在失败时返回 false。


计算一个给定的x.509证书的指纹或摘要

  • ? openssl_x509_export
  • openssl_x509_free ?
  • PHP Manual
  • OpenSSL 函数
  • 计算一个给定的x.509证书的指纹或摘要

openssl_x509_fingerprint

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

openssl_x509_fingerprint — 计算一个给定的x.509证书的指纹或摘要

说明

openssl_x509_fingerprint ( mixed $x509 , string $hash_algorithm = "sha1" , bool $raw_output = false ) : string

openssl_x509_fingerprint() 返回x509的字符串类型的摘要。

参数

x509

参见密钥／证书参数以获取有效值列表。

hash_algorithm

使用的摘要方法或散列算法，比如， "sha256", openssl_get_md_methods()摘要算法之一。

raw_output

设置为 true时，输出原始二进制数据。设置为 false时，输出小写的16进制字符串。

返回值

将包含计算的证书指纹的字符串返回为小写16进制格式，除非将raw_output设置为TRUE，在这种情况下会返回消息摘要的原始二进制表示形式。

失败则返回 false .


释放证书资源

  • ? openssl_x509_fingerprint
  • openssl_x509_parse ?
  • PHP Manual
  • OpenSSL 函数
  • 释放证书资源

openssl_x509_free

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_x509_free — 释放证书资源

说明

openssl_x509_free ( resource $x509cert ) : void

openssl_x509_free() 从内存中释放和指定 x509cert资源相关联的证书。

参数

x509cert

返回值

没有返回值。


解析一个X509证书并作为一个数组返回信息

  • ? openssl_x509_free
  • openssl_x509_read ?
  • PHP Manual
  • OpenSSL 函数
  • 解析一个X509证书并作为一个数组返回信息

openssl_x509_parse

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_x509_parse — 解析一个X509证书并作为一个数组返回信息

说明

openssl_x509_parse ( mixed $x509cert , bool $shortnames = true ) : array

openssl_x509_parse() 返回提供的 x509cert 证书的信息， 包括主题名称、发行方名称、目的、有效日期等字段。

参数

x509cert

shortnames

shortnames 控制数据在数组中的索引 - 如果 shortnames 为 true (默认) 字段将以短名称的形式被索引， 否则将会使用长名称的形式 - 比如： CN 就是commonName的短名称格式。

返回值

返回的数据的结构是（故意的）还没有文档化，因为它仍然会发生变化。


解析一个x.509证书并返回一个资源标识符

  • ? openssl_x509_parse
  • openssl_x509_verify ?
  • PHP Manual
  • OpenSSL 函数
  • 解析一个x.509证书并返回一个资源标识符

openssl_x509_read

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

openssl_x509_read — 解析一个x.509证书并返回一个资源标识符

说明

openssl_x509_read ( mixed $x509certdata ) : resource

openssl_x509_read() 解析x509certdata提供的证书，并返回一个资源标识符。

参数

x509certdata

X509 证书。参见 Key/Certificate parameters 获取可用的值。

返回值

成功，返回一个资源标识符， 或者在失败时返回 false.


Verifies digital signature of x509 certificate against a public key

  • ? openssl_x509_read
  • 密码散列算法 ?
  • PHP Manual
  • OpenSSL 函数
  • Verifies digital signature of x509 certificate against a public key

openssl_x509_verify

(PHP 7 >= 7.4.0, PHP 8)

openssl_x509_verify — Verifies digital signature of x509 certificate against a public key

说明

openssl_x509_verify ( OpenSSLCertificate|string $certificate , OpenSSLAsymmetricKey|OpenSSLCertificate|array|string $public_key ) : int

openssl_x509_verify() verifies that the certificate certificate was signed by the private key corresponding to public key public_key.

参数

x509

参见密钥／证书参数以获取有效值列表。

public_key

OpenSSLAsymmetricKey - a key, returned by openssl_get_publickey()

string - a PEM formatted key, example, "-----BEGIN PUBLIC KEY----- MIIBCgK..."

返回值

Returns 1 if the signature is correct, 0 if it is incorrect, and -1 on error.

更新日志

版本 | 说明
8.0.0 | certificate accepts an OpenSSLCertificate instance now; previously, a 资源(resource) of type OpenSSL X.509 was accepted.
8.0.0 | public_key accepts an OpenSSLAsymmetricKey or OpenSSLCertificate instance now; previously, a 资源(resource) of type OpenSSL key or OpenSSL X.509 was accepted.

范例

Example #1 openssl_x509_verify() example

<?php
$hostname = "news.php.net";
$ssloptions = array(
    "capture_peer_cert" => true,
    "capture_peer_cert_chain" => true,
    "allow_self_signed"=> false,
    "CN_match" => $hostname,
    "verify_peer" => true,
    "SNI_enabled" => true,
    "SNI_server_name" => $hostname,
);

$ctx = stream_context_create( array("ssl" => $ssloptions) );
$result = stream_socket_client("ssl://$hostname:443", $errno, $errstr, 30, STREAM_CLIENT_CONNECT, $ctx);
$cont = stream_context_get_params($result);
$x509 = $cont["options"]["ssl"]["peer_certificate"];
$certparsed = openssl_x509_parse($x509);

foreach($cont["options"]["ssl"]["peer_certificate_chain"] as $chaincert)
{
    $chainparsed = openssl_x509_parse($chaincert);
    $chain_public_key = openssl_get_publickey($chaincert);
    $r = openssl_x509_verify($x509, $chain_public_key);
    if ($r==1)
    {
        echo $certparsed['subject']['CN'];
        echo " was digitally signed by ";
        echo $chainparsed['subject']['CN']."\n";
    }
}
?>

参见

  • openssl_verify() - 验证签名
  • openssl_get_publickey() - 别名 openssl_pkey_get_public


密码散列算法

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 密码散列算法函数
    • password_algos — Get available password hashing algorithm IDs
    • password_get_info — 返回指定散列（hash）的相关信息
    • password_hash — 创建密码的散列（hash）
    • password_needs_rehash — 检测散列值是否匹配指定的选项
    • password_verify — 验证密码是否和散列值匹配


简介

密码散列算法 API 提供了 crypt() 等密码算法的简单易用包装， 以一种简洁易用安全的方式创建和管理密码。

PHP 5.5.0 可用，同时也有兼容 PHP >= 5.3.7 的» 用户级实现。


需求

构建此扩展不需要其他扩展。

为了支持 Argon2 密码哈希，需要 » libargon2。 PHP 7.3.0 起，需要 libargon2 为 20161029 或更高的版本。


安装

使用这些函数不需要安装，它们是 PHP 核心的一部分。

为了使用 Argon2 密码哈希，PHP 必须用 --with-password-argon2[=DIR] 配置选项和 libargon2 构建。


预定义常量

下列常量作为 PHP 核心的一部分总是可用的。

PASSWORD_BCRYPT (string)

PASSWORD_BCRYPT is used to create new password hashes using the CRYPT_BLOWFISH algorithm.

This will always result in a hash using the "$2y$" crypt format, which is always 60 characters wide.

Supported Options:

  • salt (string) - to manually provide a salt to use when hashing the password. Note that this will override and prevent a salt from being automatically generated.

    If omitted, a random salt will be generated by password_hash() for each password hashed. This is the intended mode of operation and as of PHP 7.0.0 the salt option has been deprecated.

  • cost (int) - which denotes the algorithmic cost that should be used. Examples of these values can be found on the crypt() page.

    If omitted, a default value of 10 will be used. This is a good baseline cost, but you may want to consider increasing it depending on your hardware.

PASSWORD_ARGON2I (string)

PASSWORD_ARGON2I is used to create new password hashes using the Argon2i algorithm.

Supported Options:

  • memory_cost (int) - Maximum memory (in bytes) that may be used to compute the Argon2 hash. Defaults to PASSWORD_ARGON2_DEFAULT_MEMORY_COST.

  • time_cost (int) - Maximum amount of time it may take to compute the Argon2 hash. Defaults to PASSWORD_ARGON2_DEFAULT_TIME_COST.

  • threads (int) - Number of threads to use for computing the Argon2 hash. Defaults to PASSWORD_ARGON2_DEFAULT_THREADS.

Available as of PHP 7.2.0.

PASSWORD_ARGON2ID (string)

PASSWORD_ARGON2ID is used to create new password hashes using the Argon2id algorithm. It supports the same options as PASSWORD_ARGON2I.

Available as of PHP 7.3.0.

PASSWORD_ARGON2_DEFAULT_MEMORY_COST (int)

Default amount of memory in bytes that Argon2lib will use while trying to compute a hash.

Available as of PHP 7.2.0.

PASSWORD_ARGON2_DEFAULT_TIME_COST (int)

Default amount of time that Argon2lib will spend trying to compute a hash.

Available as of PHP 7.2.0.

PASSWORD_ARGON2_DEFAULT_THREADS (int)

Default number of threads that Argon2lib will use.

Available as of PHP 7.2.0.

PASSWORD_DEFAULT (mixed)

The default algorithm to use for hashing if no algorithm is provided. This may change in newer PHP releases when newer, stronger hashing algorithms are supported.

It is worth noting that over time this constant can (and likely will) change. Therefore you should be aware that the length of the resulting hash can change. Therefore, if you use PASSWORD_DEFAULT you should store the resulting hash in a way that can store more than 60 characters (255 is the recommended width).

Values for this constant:

  • PHP 5.5.0 - PASSWORD_BCRYPT

更新日志

版本 | 说明
7.4.0 | The values of the password algo IDs (PASSWORD_BCRYPT, PASSWORD_ARGON2I, PASSWORD_ARGON2ID and PASSWORD_DEFAULT) are now strings. Previously, they have been ints.


密码散列算法函数

Table of Contents

  • password_algos — Get available password hashing algorithm IDs
  • password_get_info — 返回指定散列（hash）的相关信息
  • password_hash — 创建密码的散列（hash）
  • password_needs_rehash — 检测散列值是否匹配指定的选项
  • password_verify — 验证密码是否和散列值匹配


Get available password hashing algorithm IDs

  • ? 密码散列算法函数
  • password_get_info ?
  • PHP Manual
  • 密码散列算法函数
  • Get available password hashing algorithm IDs

password_algos

(PHP 7 >= 7.4.0, PHP 8)

password_algos — Get available password hashing algorithm IDs

说明

password_algos ( ) : array

Returns a complete list of all registered password hashing algorithm IDs as an array of strings.

参数

此函数没有参数。

返回值

Returns the available password hashing algorithm IDs.

范例

Example #1 Basic password() usage

<?php
print_r(password_algos());
?>

以上例程的输出类似于：

Array
(
    [0] => 2y
    [1] => argon2i
    [2] => argon2id
)


返回指定散列（hash）的相关信息

  • ? password_algos
  • password_hash ?
  • PHP Manual
  • 密码散列算法函数
  • 返回指定散列（hash）的相关信息

password_get_info

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

password_get_info — 返回指定散列（hash）的相关信息

说明

password_get_info ( string $hash ) : array

如果传入的散列值（hash）是由 password_hash() 支持的算法生成的， 这个函数就会返回关于此散列的信息数组。

参数

hash

一个由 password_hash() 创建的散列值。

返回值

返回三个元素的关联数组：

  • algo， 匹配 密码算法的常量
  • algoName，人类可读的算法名称
  • options，调用 password_hash() 时提供的选项。


创建密码的散列（hash）

  • ? password_get_info
  • password_needs_rehash ?
  • PHP Manual
  • 密码散列算法函数
  • 创建密码的散列（hash）

password_hash

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

password_hash — 创建密码的散列（hash）

说明

password_hash ( string $password , mixed $algo , array $options = ? ) : string|false

password_hash() 使用足够强度的单向散列算法创建密码的散列（hash）。

password_hash() 兼容 crypt()。
所以， crypt() 创建的密码散列也可用于
password_hash()。

当前支持的算法：

  • PASSWORD_DEFAULT - 使用 bcrypt 算法 (PHP 5.5.0 默认)。 注意，该常量会随着 PHP 加入更新更高强度的算法而改变。 所以，使用此常量生成结果的长度将在未来有变化。 因此，数据库里储存结果的列可超过60个字符（最好是255个字符）。
  • PASSWORD_BCRYPT - 使用 CRYPT_BLOWFISH 算法创建散列。 这会产生兼容使用 "$2y$" 的 crypt()。 结果将会是 60 个字符的字符串， 或者在失败时返回 false。
  • PASSWORD_ARGON2I - 使用 Argon2i 散列算法创建散列。 只有在 PHP 编译时加入 Argon2 支持时才能使用该算法。
  • PASSWORD_ARGON2ID - 使用 Argon2id 散列算法创建散列。 只有在 PHP 编译时加入 Argon2 支持时才能使用该算法。

PASSWORD_BCRYPT 支持的选项：

  • salt(string) - 手动提供散列密码的盐值（salt）。这将避免自动生成盐值（salt）。

    省略此值后，password_hash() 会为每个密码散列自动生成随机的盐值。这种操作是有意的模式。

    Warning

    盐值（salt）选项从 PHP 7.0.0 开始被废弃（deprecated）了。 现在最好选择简单的使用默认产生的盐值。

  • cost (int) - 代表算法使用的 cost。crypt() 页面上有 cost 值的例子。

    省略时，默认值是 10。 这个 cost 是个不错的底线，但也许可以根据自己硬件的情况，加大这个值。

PASSWORD_ARGON2I 和 PASSWORD_ARGON2ID 支持的选项：

  • memory_cost (int) - 计算 Argon2 散列时的最大内存（单位：KB）。默认值： PASSWORD_ARGON2_DEFAULT_MEMORY_COST。

  • time_cost (int) - 计算 Argon2 散列时最多的时间。默认值： PASSWORD_ARGON2_DEFAULT_TIME_COST。

  • threads (int) - 计算 Argon2 散列时最多的线程数。默认值： PASSWORD_ARGON2_DEFAULT_THREADS。

参数

password

用户的密码。

Caution

使用PASSWORD_BCRYPT 做算法，将使 password 参数最长为72个字符，超过会被截断。

algo

一个用来在散列密码时指示算法的密码算法常量。

options

一个包含有选项的关联数组。详细的参数说明，请参考文档 密码算法常数。

省略后，将使用随机盐值与默认 cost。

返回值

返回散列后的密码， 或者在失败时返回 false。

使用的算法、cost 和盐值作为散列的一部分返回。所以验证散列值的所有信息都已经包含在内。 这使 password_verify() 函数验证的时候，不需要额外储存盐值或者算法的信息。

更新日志

版本 | 说明
7.4.0 | 现在 algo 参数可支持 string 类型，但为了向后兼容也支持 int 类型。
7.3.0 | 增加 PASSWORD_ARGON2ID，支持 Argon2id 密码算法。
7.2.0 | 增加 PASSWORD_ARGON2I，支持 Argon2i 密码算法。

范例

Example #1 password_hash() 例子

<?php
/**
 * 我们想要使用默认算法散列密码
 * 当前是 BCRYPT，并会产生 60 个字符的结果。
 *
 * 请注意，随时间推移，默认算法可能会有变化，
 * 所以需要储存的空间能够超过 60 字（255字不错）
 */
echo password_hash("rasmuslerdorf", PASSWORD_DEFAULT);
?>

以上例程的输出类似于：

$2y$10$.vGA1O9wmRjrwAVXD98HNOgsNpDczlqm3Jq7KnEd1rVAGv3Fykk1a

Example #2 password_hash() 手动设置 cost 的例子

<?php
/**
 * 在这个案例里，我们为 BCRYPT 增加 cost 到 12。
 * 注意，我们已经切换到了，将始终产生 60 个字符。
 */
$options = [
    'cost' => 12,
];
echo password_hash("rasmuslerdorf", PASSWORD_BCRYPT, $options);
?>

以上例程的输出类似于：

$2y$12$QjSH496pcT5CEbzjD/vtVeH03tfHKFy36d4J0Ltp3lRtee9HDxY3K

Example #3 寻找最佳 cost 的 password_hash() 例子

<?php
/**
 * 这个例子对服务器做了基准测试（benchmark），检测服务器能承受多高的 cost
 * 在不明显拖慢服务器的情况下可以设置最高的值
 * 8-10 是个不错的底线，在服务器够快的情况下，越高越好。
 * 以下代码目标为  ≤ 50 毫秒（milliseconds），
 * 适合系统处理交互登录。
 */
$timeTarget = 0.05; // 50 毫秒（milliseconds）

$cost = 8;
do {
    $cost++;
    $start = microtime(true);
    password_hash("test", PASSWORD_BCRYPT, ["cost" => $cost]);
    $end = microtime(true);
} while (($end - $start) < $timeTarget);

echo "Appropriate Cost Found: " . $cost;
?>

以上例程的输出类似于：

Appropriate Cost Found: 10

Example #4 使用 Argon2i 的password_hash()例子

<?php
echo 'Argon2i hash: ' . password_hash('rasmuslerdorf', PASSWORD_ARGON2I);
?>

以上例程的输出类似于：

Argon2i hash: $argon2i$v=19$m=1024,t=2,p=2$YzJBSzV4TUhkMzc3d3laeg$zqU/1IN0/AogfP4cmSJI1vc8lpXRW9/S0sYY2i2jHT0

注释

Caution

强烈建议不要自己为这个函数生成盐值（salt）。只要不设置，它会自动创建安全的盐值。

就像以上提及的，在 PHP 7.0 提供 salt选项会导致废弃（deprecation）警告。 未来的 PHP 发行版里，手动提供盐值的功能可能会被删掉。

Note:

在交互的系统上，推荐在自己的服务器上测试此函数，调整 cost 参数直至函数时间开销小于 100 毫秒（milliseconds）。 上面脚本的例子会帮助选择合适硬件的最佳 cost。

Note: 这个函数更新支持的算法时（或修改默认算法），必定会遵守以下规则：

  • 任何内核中的新算法必须在经历一次 PHP 完整发行才能成为默认算法。 比如，在 PHP 7.5.5 中添加的新算法，在 PHP 7.7 之前不能成为默认算法 （由于 7.6 是第一个完整发行版）。 但如果是在 7.6.0 里添加的不同算法，在 7.7.0 里也可以成为默认算法。
  • 仅仅允许在完整发行版中修改默认算法（比如 7.3.0, 8.0.0，等等），不能是在修订版。 唯一的例外是：在当前默认算法里发现了紧急的安全威胁。

参见

  • password_verify() - 验证密码是否和散列值匹配
  • crypt() - 单向字符串散列
  • » 用户的使用
  • sodium_crypto_pwhash_str() - Get an ASCII-encoded hash


检测散列值是否匹配指定的选项

  • ? password_hash
  • password_verify ?
  • PHP Manual
  • 密码散列算法函数
  • 检测散列值是否匹配指定的选项

password_needs_rehash

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

password_needs_rehash — 检测散列值是否匹配指定的选项

说明

password_needs_rehash ( string $hash , mixed $algo , array $options = ? ) : bool

此函数检测指定的散列值是否实现了提供的算法和选项。 如果没有，需要重新生成散列值。

参数

hash

一个由 password_hash() 创建的散列值。

algo

一个用来在散列密码时指示算法的密码算法常量。

options

一个包含有选项的关联数组。详细的参数说明，请参考文档 密码算法常数。

返回值

如果散列需要重新生成才能匹配指定的 algo 和 options， 则返回 true，否则返回 false。

更新日志

版本 | 说明
7.4.0 | 现在 algo 参数可以支持 string 类型，但为了向后兼容性，同时支持 int 类型。

范例

Example #1 password_needs_rehash()用法

<?php

$password = 'rasmuslerdorf';
$hash = '$2y$10$YCFsG6elYca568hBi2pZ0.3LDL5wjgxct1N8w/oLR/jfHsiQwCqTS';

// 当硬件性能得到改善时，cost 参数可以再修改
$options = array('cost' => 11);

// 根据明文密码验证储存的散列
if (password_verify($password, $hash)) {
    // 检测是否有更新的可用散列算法
    // 或者 cost 发生变化
    if (password_needs_rehash($hash, PASSWORD_DEFAULT, $options)) {
        // 如果是这样，则创建新散列，替换旧散列
        $newHash = password_hash($password, PASSWORD_DEFAULT, $options);
    }

    // 使用户登录
}
?>


验证密码是否和散列值匹配

  • ? password_needs_rehash
  • Sodium ?
  • PHP Manual
  • 密码散列算法函数
  • 验证密码是否和散列值匹配

password_verify

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

password_verify — 验证密码是否和散列值匹配

说明

password_verify ( string $password , string $hash ) : bool

验证密码是否和指定的散列值匹配。

注意 password_hash() 返回的散列包含了算法、 cost 和盐值。 因此，所有需要的信息都包含内。使得验证函数不需要储存额外盐值等信息即可验证哈希。

时序攻击（timing attacks）对此函数不起作用。

参数

password

用户的密码。

hash

一个由 password_hash() 创建的散列值。

返回值

如果密码和散列值匹配则返回 true，否则返回 false 。

范例

Example #1 password_verify() 例子

<?php
// 想知道以下字符从哪里来，可参见 password_hash() 的例子
$hash = '$2y$07$BCryptRequires22Chrcte/VlQH0piJtjXl.0t1XkA8pw9dMXTpOq';

if (password_verify('rasmuslerdorf', $hash)) {
    echo 'Password is valid!';
} else {
    echo 'Invalid password.';
}
?>

以上例程会输出：

Password is valid!

参见

  • password_hash() - 创建密码的散列（hash）
  • » 用户使用
  • sodium_crypto_pwhash_str_verify() - Verifies that a password matches a hash


Sodium

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Sodium 函数
    • sodium_add — Add large numbers
    • sodium_base642bin — Description
    • sodium_bin2base64 — Description
    • sodium_bin2hex — Encode to hexadecimal
    • sodium_compare — Compare large numbers
    • sodium_crypto_aead_aes256gcm_decrypt — Decrypt in combined mode with precalculation
    • sodium_crypto_aead_aes256gcm_encrypt — Encrypt in combined mode with precalculation
    • sodium_crypto_aead_aes256gcm_is_available — Check if hardware supports AES256-GCM
    • sodium_crypto_aead_aes256gcm_keygen — Get random bytes for key
    • sodium_crypto_aead_chacha20poly1305_decrypt — Verify that the ciphertext includes a valid tag
    • sodium_crypto_aead_chacha20poly1305_encrypt — Encrypt a message
    • sodium_crypto_aead_chacha20poly1305_ietf_decrypt — Verify that the ciphertext includes a valid tag
    • sodium_crypto_aead_chacha20poly1305_ietf_encrypt — Encrypt a message
    • sodium_crypto_aead_chacha20poly1305_ietf_keygen — Get random bytes for key
    • sodium_crypto_aead_chacha20poly1305_keygen — Get random bytes for key
    • sodium_crypto_aead_xchacha20poly1305_ietf_decrypt — Description
    • sodium_crypto_aead_xchacha20poly1305_ietf_encrypt — Description
    • sodium_crypto_aead_xchacha20poly1305_ietf_keygen — Description
    • sodium_crypto_auth_keygen — Get random bytes for key
    • sodium_crypto_auth_verify — Verifies that the tag is valid for the message
    • sodium_crypto_auth — Compute a tag for the message
    • sodium_crypto_box_keypair_from_secretkey_and_publickey — Description
    • sodium_crypto_box_keypair — Randomly generate a secret key and a corresponding public key
    • sodium_crypto_box_open — Verify and decrypt a ciphertext
    • sodium_crypto_box_publickey_from_secretkey — Description
    • sodium_crypto_box_publickey — Description
    • sodium_crypto_box_seal_open — Decrypt the ciphertext
    • sodium_crypto_box_seal — Encrypt a message
    • sodium_crypto_box_secretkey — Description
    • sodium_crypto_box_seed_keypair — Deterministically derive the key pair from a single key
    • sodium_crypto_box — Encrypt a message
    • sodium_crypto_generichash_final — Complete the hash
    • sodium_crypto_generichash_init — Initialize a hash
    • sodium_crypto_generichash_keygen — Get random bytes for key
    • sodium_crypto_generichash_update — Add message to a hash
    • sodium_crypto_generichash — Get a hash of the message
    • sodium_crypto_kdf_derive_from_key — Derive a subkey
    • sodium_crypto_kdf_keygen — Get random bytes for key
    • sodium_crypto_kx_client_session_keys — Description
    • sodium_crypto_kx_keypair — Creates a new sodium keypair
    • sodium_crypto_kx_publickey — Description
    • sodium_crypto_kx_secretkey — Description
    • sodium_crypto_kx_seed_keypair — Description
    • sodium_crypto_kx_server_session_keys — Description
    • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify — Verify that the password is a valid password verification string
    • sodium_crypto_pwhash_scryptsalsa208sha256_str — Get an ASCII encoded hash
    • sodium_crypto_pwhash_scryptsalsa208sha256 — Derives a key from a password
    • sodium_crypto_pwhash_str_needs_rehash — Description
    • sodium_crypto_pwhash_str_verify — Verifies that a password matches a hash
    • sodium_crypto_pwhash_str — Get an ASCII-encoded hash
    • sodium_crypto_pwhash — Derive a key from a password
    • sodium_crypto_scalarmult_base — 别名 sodium_crypto_box_publickey_from_secretkey
    • sodium_crypto_scalarmult — Compute a shared secret given a user's secret key and another user's public key
    • sodium_crypto_secretbox_keygen — Get random bytes for key
    • sodium_crypto_secretbox_open — Verify and decrypt a ciphertext
    • sodium_crypto_secretbox — Encrypt a message
    • sodium_crypto_secretstream_xchacha20poly1305_init_pull — Description
    • sodium_crypto_secretstream_xchacha20poly1305_init_push — Description
    • sodium_crypto_secretstream_xchacha20poly1305_keygen — Description
    • sodium_crypto_secretstream_xchacha20poly1305_pull — Description
    • sodium_crypto_secretstream_xchacha20poly1305_push — Description
    • sodium_crypto_secretstream_xchacha20poly1305_rekey — Description
    • sodium_crypto_shorthash_keygen — Get random bytes for key
    • sodium_crypto_shorthash — Compute a fixed-size fingerprint for the message
    • sodium_crypto_sign_detached — Sign the message
    • sodium_crypto_sign_ed25519_pk_to_curve25519 — Convert an Ed25519 public key to a Curve25519 public key
    • sodium_crypto_sign_ed25519_sk_to_curve25519 — Convert an Ed25519 secret key to a Curve25519 secret key
    • sodium_crypto_sign_keypair_from_secretkey_and_publickey — Description
    • sodium_crypto_sign_keypair — Randomly generate a secret key and a corresponding public key
    • sodium_crypto_sign_open — Check that the signed message has a valid signature
    • sodium_crypto_sign_publickey_from_secretkey — Extract the public key from the secret key
    • sodium_crypto_sign_publickey — Description
    • sodium_crypto_sign_secretkey — Description
    • sodium_crypto_sign_seed_keypair — Deterministically derive the key pair from a single key
    • sodium_crypto_sign_verify_detached — Verify signature for the message
    • sodium_crypto_sign — Sign a message
    • sodium_crypto_stream_keygen — Get random bytes for key
    • sodium_crypto_stream_xor — Encrypt a message
    • sodium_crypto_stream — Generate a deterministic sequence of bytes from a seed
    • sodium_hex2bin — Decodes a hexadecimally encoded binary string
    • sodium_increment — Increment large number
    • sodium_memcmp — Test for equality in constant-time
    • sodium_memzero — Overwrite buf with zeros
    • sodium_pad — Add padding data
    • sodium_unpad — Remove padding data
  • SodiumException — The SodiumException class


  • ? Sodium
  • 安装／配置 ?
  • PHP Manual
  • Sodium
  • 简介

简介


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

This extension requires » libsodium ≥ 1.0.8.


安装

As of PHP 7.2.0 this extension is bundled with PHP. For older PHP versions this extension is available via PECL.

Linux Systems

In order to use this extension you must compile PHP with sodium support by using the --with-sodium[=DIR] configure option.

Windows

In order to use this extension you have to add extension=php_sodium.dll to php.ini.

Installation via PECL

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/libsodium


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SODIUM_LIBRARY_VERSION (string)
SODIUM_LIBRARY_MAJOR_VERSION (int)
SODIUM_LIBRARY_MINOR_VERSION (int)
SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES (int)
SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES (int)
SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES (int)
SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES (int)
SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES (int)
SODIUM_CRYPTO_AUTH_BYTES (int)
SODIUM_CRYPTO_AUTH_KEYBYTES (int)
SODIUM_CRYPTO_BOX_SEALBYTES (int)
SODIUM_CRYPTO_BOX_SECRETKEYBYTES (int)
SODIUM_CRYPTO_BOX_PUBLICKEYBYTES (int)
SODIUM_CRYPTO_BOX_KEYPAIRBYTES (int)
SODIUM_CRYPTO_BOX_MACBYTES (int)
SODIUM_CRYPTO_BOX_NONCEBYTES (int)
SODIUM_CRYPTO_BOX_SEEDBYTES (int)
SODIUM_CRYPTO_KDF_BYTES_MIN (int)
SODIUM_CRYPTO_KDF_BYTES_MAX (int)
SODIUM_CRYPTO_KDF_CONTEXTBYTES (int)
SODIUM_CRYPTO_KDF_KEYBYTES (int)
SODIUM_CRYPTO_KX_SEEDBYTES (int)
SODIUM_CRYPTO_KX_SESSIONKEYBYTES (int)
SODIUM_CRYPTO_KX_PUBLICKEYBYTES (int)
SODIUM_CRYPTO_KX_SECRETKEYBYTES (int)
SODIUM_CRYPTO_KX_KEYPAIRBYTES (int)
SODIUM_CRYPTO_GENERICHASH_BYTES (int)
SODIUM_CRYPTO_GENERICHASH_BYTES_MIN (int)
SODIUM_CRYPTO_GENERICHASH_BYTES_MAX (int)
SODIUM_CRYPTO_GENERICHASH_KEYBYTES (int)
SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN (int)
SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX (int)
SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13 (int)
SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13 (int)
SODIUM_CRYPTO_PWHASH_ALG_DEFAULT (int)
SODIUM_CRYPTO_PWHASH_SALTBYTES (int)
SODIUM_CRYPTO_PWHASH_STRPREFIX (string)
SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE (int)
SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE (int)
SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE (int)
SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE (int)
SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE (int)
SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX (string)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE (int)
SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE (int)
SODIUM_CRYPTO_SCALARMULT_BYTES (int)
SODIUM_CRYPTO_SCALARMULT_SCALARBYTES (int)
SODIUM_CRYPTO_SHORTHASH_BYTES (int)
SODIUM_CRYPTO_SHORTHASH_KEYBYTES (int)
SODIUM_CRYPTO_SECRETBOX_KEYBYTES (int)
SODIUM_CRYPTO_SECRETBOX_MACBYTES (int)
SODIUM_CRYPTO_SECRETBOX_NONCEBYTES (int)
SODIUM_CRYPTO_SIGN_BYTES (int)
SODIUM_CRYPTO_SIGN_SEEDBYTES (int)
SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES (int)
SODIUM_CRYPTO_SIGN_SECRETKEYBYTES (int)
SODIUM_CRYPTO_SIGN_KEYPAIRBYTES (int)
SODIUM_CRYPTO_STREAM_NONCEBYTES (int)
SODIUM_CRYPTO_STREAM_KEYBYTES (int)


Sodium 函数

Table of Contents

  • sodium_add — Add large numbers
  • sodium_base642bin — Description
  • sodium_bin2base64 — Description
  • sodium_bin2hex — Encode to hexadecimal
  • sodium_compare — Compare large numbers
  • sodium_crypto_aead_aes256gcm_decrypt — Decrypt in combined mode with precalculation
  • sodium_crypto_aead_aes256gcm_encrypt — Encrypt in combined mode with precalculation
  • sodium_crypto_aead_aes256gcm_is_available — Check if hardware supports AES256-GCM
  • sodium_crypto_aead_aes256gcm_keygen — Get random bytes for key
  • sodium_crypto_aead_chacha20poly1305_decrypt — Verify that the ciphertext includes a valid tag
  • sodium_crypto_aead_chacha20poly1305_encrypt — Encrypt a message
  • sodium_crypto_aead_chacha20poly1305_ietf_decrypt — Verify that the ciphertext includes a valid tag
  • sodium_crypto_aead_chacha20poly1305_ietf_encrypt — Encrypt a message
  • sodium_crypto_aead_chacha20poly1305_ietf_keygen — Get random bytes for key
  • sodium_crypto_aead_chacha20poly1305_keygen — Get random bytes for key
  • sodium_crypto_aead_xchacha20poly1305_ietf_decrypt — Description
  • sodium_crypto_aead_xchacha20poly1305_ietf_encrypt — Description
  • sodium_crypto_aead_xchacha20poly1305_ietf_keygen — Description
  • sodium_crypto_auth_keygen — Get random bytes for key
  • sodium_crypto_auth_verify — Verifies that the tag is valid for the message
  • sodium_crypto_auth — Compute a tag for the message
  • sodium_crypto_box_keypair_from_secretkey_and_publickey — Description
  • sodium_crypto_box_keypair — Randomly generate a secret key and a corresponding public key
  • sodium_crypto_box_open — Verify and decrypt a ciphertext
  • sodium_crypto_box_publickey_from_secretkey — Description
  • sodium_crypto_box_publickey — Description
  • sodium_crypto_box_seal_open — Decrypt the ciphertext
  • sodium_crypto_box_seal — Encrypt a message
  • sodium_crypto_box_secretkey — Description
  • sodium_crypto_box_seed_keypair — Deterministically derive the key pair from a single key
  • sodium_crypto_box — Encrypt a message
  • sodium_crypto_generichash_final — Complete the hash
  • sodium_crypto_generichash_init — Initialize a hash
  • sodium_crypto_generichash_keygen — Get random bytes for key
  • sodium_crypto_generichash_update — Add message to a hash
  • sodium_crypto_generichash — Get a hash of the message
  • sodium_crypto_kdf_derive_from_key — Derive a subkey
  • sodium_crypto_kdf_keygen — Get random bytes for key
  • sodium_crypto_kx_client_session_keys — Description
  • sodium_crypto_kx_keypair — Creates a new sodium keypair
  • sodium_crypto_kx_publickey — Description
  • sodium_crypto_kx_secretkey — Description
  • sodium_crypto_kx_seed_keypair — Description
  • sodium_crypto_kx_server_session_keys — Description
  • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify — Verify that the password is a valid password verification string
  • sodium_crypto_pwhash_scryptsalsa208sha256_str — Get an ASCII encoded hash
  • sodium_crypto_pwhash_scryptsalsa208sha256 — Derives a key from a password
  • sodium_crypto_pwhash_str_needs_rehash — Description
  • sodium_crypto_pwhash_str_verify — Verifies that a password matches a hash
  • sodium_crypto_pwhash_str — Get an ASCII-encoded hash
  • sodium_crypto_pwhash — Derive a key from a password
  • sodium_crypto_scalarmult_base — 别名 sodium_crypto_box_publickey_from_secretkey
  • sodium_crypto_scalarmult — Compute a shared secret given a user's secret key and another user's public key
  • sodium_crypto_secretbox_keygen — Get random bytes for key
  • sodium_crypto_secretbox_open — Verify and decrypt a ciphertext
  • sodium_crypto_secretbox — Encrypt a message
  • sodium_crypto_secretstream_xchacha20poly1305_init_pull — Description
  • sodium_crypto_secretstream_xchacha20poly1305_init_push — Description
  • sodium_crypto_secretstream_xchacha20poly1305_keygen — Description
  • sodium_crypto_secretstream_xchacha20poly1305_pull — Description
  • sodium_crypto_secretstream_xchacha20poly1305_push — Description
  • sodium_crypto_secretstream_xchacha20poly1305_rekey — Description
  • sodium_crypto_shorthash_keygen — Get random bytes for key
  • sodium_crypto_shorthash — Compute a fixed-size fingerprint for the message
  • sodium_crypto_sign_detached — Sign the message
  • sodium_crypto_sign_ed25519_pk_to_curve25519 — Convert an Ed25519 public key to a Curve25519 public key
  • sodium_crypto_sign_ed25519_sk_to_curve25519 — Convert an Ed25519 secret key to a Curve25519 secret key
  • sodium_crypto_sign_keypair_from_secretkey_and_publickey — Description
  • sodium_crypto_sign_keypair — Randomly generate a secret key and a corresponding public key
  • sodium_crypto_sign_open — Check that the signed message has a valid signature
  • sodium_crypto_sign_publickey_from_secretkey — Extract the public key from the secret key
  • sodium_crypto_sign_publickey — Description
  • sodium_crypto_sign_secretkey — Description
  • sodium_crypto_sign_seed_keypair — Deterministically derive the key pair from a single key
  • sodium_crypto_sign_verify_detached — Verify signature for the message
  • sodium_crypto_sign — Sign a message
  • sodium_crypto_stream_keygen — Get random bytes for key
  • sodium_crypto_stream_xor — Encrypt a message
  • sodium_crypto_stream — Generate a deterministic sequence of bytes from a seed
  • sodium_hex2bin — Decodes a hexadecimally encoded binary string
  • sodium_increment — Increment large number
  • sodium_memcmp — Test for equality in constant-time
  • sodium_memzero — Overwrite buf with zeros
  • sodium_pad — Add padding data
  • sodium_unpad — Remove padding data


Add large numbers

  • ? Sodium 函数
  • sodium_base642bin ?
  • PHP Manual
  • Sodium 函数
  • Add large numbers

sodium_add

(PHP 7 >= 7.2.0, PHP 8)

sodium_add — Add large numbers

说明

sodium_add ( string &$string1 , string $string2 ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

string1

string2

返回值

没有返回值。


Description

  • ? sodium_add
  • sodium_bin2base64 ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_base642bin

(PHP 7 >= 7.2.0, PHP 8)

sodium_base642bin — Description

说明

sodium_base642bin ( string $string , int $id , string $ignore = "" ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

string

id

ignore

返回值


Description

  • ? sodium_base642bin
  • sodium_bin2hex ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_bin2base64

(PHP 7 >= 7.2.0, PHP 8)

sodium_bin2base64 — Description

说明

sodium_bin2base64 ( string $string , int $id ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

string

id

返回值


Encode to hexadecimal

  • ? sodium_bin2base64
  • sodium_compare ?
  • PHP Manual
  • Sodium 函数
  • Encode to hexadecimal

sodium_bin2hex

(PHP 7 >= 7.2.0, PHP 8)

sodium_bin2hex — Encode to hexadecimal

说明

sodium_bin2hex ( string $string ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

string

返回值


Compare large numbers

  • ? sodium_bin2hex
  • sodium_crypto_aead_aes256gcm_decrypt ?
  • PHP Manual
  • Sodium 函数
  • Compare large numbers

sodium_compare

(PHP 7 >= 7.2.0, PHP 8)

sodium_compare — Compare large numbers

说明

sodium_compare ( string $string1 , string $string2 ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

string1

string2

返回值


Decrypt in combined mode with precalculation

  • ? sodium_compare
  • sodium_crypto_aead_aes256gcm_encrypt ?
  • PHP Manual
  • Sodium 函数
  • Decrypt in combined mode with precalculation

sodium_crypto_aead_aes256gcm_decrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_aes256gcm_decrypt — Decrypt in combined mode with precalculation

说明

sodium_crypto_aead_aes256gcm_decrypt ( string $ciphertext , string $additional_data , string $nonce , string $key ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

ciphertext

additional_data

nonce

key

返回值


Encrypt in combined mode with precalculation

  • ? sodium_crypto_aead_aes256gcm_decrypt
  • sodium_crypto_aead_aes256gcm_is_available ?
  • PHP Manual
  • Sodium 函数
  • Encrypt in combined mode with precalculation

sodium_crypto_aead_aes256gcm_encrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_aes256gcm_encrypt — Encrypt in combined mode with precalculation

说明

sodium_crypto_aead_aes256gcm_encrypt ( string $message , string $additional_data , string $nonce , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

additional_data

nonce

key

返回值


Check if hardware supports AES256-GCM

  • ? sodium_crypto_aead_aes256gcm_encrypt
  • sodium_crypto_aead_aes256gcm_keygen ?
  • PHP Manual
  • Sodium 函数
  • Check if hardware supports AES256-GCM

sodium_crypto_aead_aes256gcm_is_available

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_aes256gcm_is_available — Check if hardware supports AES256-GCM

说明

sodium_crypto_aead_aes256gcm_is_available ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get random bytes for key

  • ? sodium_crypto_aead_aes256gcm_is_available
  • sodium_crypto_aead_chacha20poly1305_decrypt ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_aead_aes256gcm_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_aes256gcm_keygen — Get random bytes for key

说明

sodium_crypto_aead_aes256gcm_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Verify that the ciphertext includes a valid tag

  • ? sodium_crypto_aead_aes256gcm_keygen
  • sodium_crypto_aead_chacha20poly1305_encrypt ?
  • PHP Manual
  • Sodium 函数
  • Verify that the ciphertext includes a valid tag

sodium_crypto_aead_chacha20poly1305_decrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_decrypt — Verify that the ciphertext includes a valid tag

说明

sodium_crypto_aead_chacha20poly1305_decrypt ( string $ciphertext , string $additional_data , string $nonce , string $key ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

ciphertext

additional_data

nonce

key

返回值


Encrypt a message

  • ? sodium_crypto_aead_chacha20poly1305_decrypt
  • sodium_crypto_aead_chacha20poly1305_ietf_decrypt ?
  • PHP Manual
  • Sodium 函数
  • Encrypt a message

sodium_crypto_aead_chacha20poly1305_encrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_encrypt — Encrypt a message

说明

sodium_crypto_aead_chacha20poly1305_encrypt ( string $message , string $additional_data , string $nonce , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

additional_data

nonce

key

返回值


Verify that the ciphertext includes a valid tag

  • ? sodium_crypto_aead_chacha20poly1305_encrypt
  • sodium_crypto_aead_chacha20poly1305_ietf_encrypt ?
  • PHP Manual
  • Sodium 函数
  • Verify that the ciphertext includes a valid tag

sodium_crypto_aead_chacha20poly1305_ietf_decrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_ietf_decrypt — Verify that the ciphertext includes a valid tag

说明

sodium_crypto_aead_chacha20poly1305_ietf_decrypt ( string $ciphertext , string $additional_data , string $nonce , string $key ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

ciphertext

additional_data

nonce

key

返回值


Encrypt a message

  • ? sodium_crypto_aead_chacha20poly1305_ietf_decrypt
  • sodium_crypto_aead_chacha20poly1305_ietf_keygen ?
  • PHP Manual
  • Sodium 函数
  • Encrypt a message

sodium_crypto_aead_chacha20poly1305_ietf_encrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_ietf_encrypt — Encrypt a message

说明

sodium_crypto_aead_chacha20poly1305_ietf_encrypt ( string $message , string $additional_data , string $nonce , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

additional_data

nonce

key

返回值


Get random bytes for key

  • ? sodium_crypto_aead_chacha20poly1305_ietf_encrypt
  • sodium_crypto_aead_chacha20poly1305_keygen ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_aead_chacha20poly1305_ietf_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_ietf_keygen — Get random bytes for key

说明

sodium_crypto_aead_chacha20poly1305_ietf_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get random bytes for key

  • ? sodium_crypto_aead_chacha20poly1305_ietf_keygen
  • sodium_crypto_aead_xchacha20poly1305_ietf_decrypt ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_aead_chacha20poly1305_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_chacha20poly1305_keygen — Get random bytes for key

说明

sodium_crypto_aead_chacha20poly1305_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? sodium_crypto_aead_chacha20poly1305_keygen
  • sodium_crypto_aead_xchacha20poly1305_ietf_encrypt ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_aead_xchacha20poly1305_ietf_decrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_xchacha20poly1305_ietf_decrypt — Description

说明

sodium_crypto_aead_xchacha20poly1305_ietf_decrypt ( string $ciphertext , string $additional_data , string $nonce , string $key ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

ciphertext

additional_data

nonce

key

返回值


Description

  • ? sodium_crypto_aead_xchacha20poly1305_ietf_decrypt
  • sodium_crypto_aead_xchacha20poly1305_ietf_keygen ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_aead_xchacha20poly1305_ietf_encrypt

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_xchacha20poly1305_ietf_encrypt — Description

说明

sodium_crypto_aead_xchacha20poly1305_ietf_encrypt ( string $message , string $additional_data , string $nonce , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

additional_data

nonce

key

返回值


Description

  • ? sodium_crypto_aead_xchacha20poly1305_ietf_encrypt
  • sodium_crypto_auth_keygen ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_aead_xchacha20poly1305_ietf_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_aead_xchacha20poly1305_ietf_keygen — Description

说明

sodium_crypto_aead_xchacha20poly1305_ietf_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get random bytes for key

  • ? sodium_crypto_aead_xchacha20poly1305_ietf_keygen
  • sodium_crypto_auth_verify ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_auth_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_auth_keygen — Get random bytes for key

说明

sodium_crypto_auth_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Verifies that the tag is valid for the message

  • ? sodium_crypto_auth_keygen
  • sodium_crypto_auth ?
  • PHP Manual
  • Sodium 函数
  • Verifies that the tag is valid for the message

sodium_crypto_auth_verify

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_auth_verify — Verifies that the tag is valid for the message

说明

sodium_crypto_auth_verify ( string $mac , string $message , string $key ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

mac

message

key

返回值


Compute a tag for the message

  • ? sodium_crypto_auth_verify
  • sodium_crypto_box_keypair_from_secretkey_and_publickey ?
  • PHP Manual
  • Sodium 函数
  • Compute a tag for the message

sodium_crypto_auth

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_auth — Compute a tag for the message

说明

sodium_crypto_auth ( string $message , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

key

返回值


Description

  • ? sodium_crypto_auth
  • sodium_crypto_box_keypair ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_box_keypair_from_secretkey_and_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_keypair_from_secretkey_and_publickey — Description

说明

sodium_crypto_box_keypair_from_secretkey_and_publickey ( string $secret_key , string $public_key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

secret_key

public_key

返回值


Randomly generate a secret key and a corresponding public key

  • ? sodium_crypto_box_keypair_from_secretkey_and_publickey
  • sodium_crypto_box_open ?
  • PHP Manual
  • Sodium 函数
  • Randomly generate a secret key and a corresponding public key

sodium_crypto_box_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_keypair — Randomly generate a secret key and a corresponding public key

说明

sodium_crypto_box_keypair ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Verify and decrypt a ciphertext

  • ? sodium_crypto_box_keypair
  • sodium_crypto_box_publickey_from_secretkey ?
  • PHP Manual
  • Sodium 函数
  • Verify and decrypt a ciphertext

sodium_crypto_box_open

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_open — Verify and decrypt a ciphertext

说明

sodium_crypto_box_open ( string $ciphertext , string $nonce , string $key_pair ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

ciphertext

nonce

key_pair

返回值


Description

  • ? sodium_crypto_box_open
  • sodium_crypto_box_publickey ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_box_publickey_from_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_publickey_from_secretkey — Description

说明

sodium_crypto_box_publickey_from_secretkey ( string $secret_key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

secret_key

返回值


Description

  • ? sodium_crypto_box_publickey_from_secretkey
  • sodium_crypto_box_seal_open ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_box_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_publickey — Description

说明

sodium_crypto_box_publickey ( string $key_pair ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

key_pair

返回值


Decrypt the ciphertext

  • ? sodium_crypto_box_publickey
  • sodium_crypto_box_seal ?
  • PHP Manual
  • Sodium 函数
  • Decrypt the ciphertext

sodium_crypto_box_seal_open

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_seal_open — Decrypt the ciphertext

说明

sodium_crypto_box_seal_open ( string $ciphertext , string $key_pair ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

ciphertext

key_pair

返回值


Encrypt a message

  • ? sodium_crypto_box_seal_open
  • sodium_crypto_box_secretkey ?
  • PHP Manual
  • Sodium 函数
  • Encrypt a message

sodium_crypto_box_seal

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_seal — Encrypt a message

说明

sodium_crypto_box_seal ( string $message , string $key_pair ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

key_pair

返回值


Description

  • ? sodium_crypto_box_seal
  • sodium_crypto_box_seed_keypair ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_box_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_secretkey — Description

说明

sodium_crypto_box_secretkey ( string $key_pair ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

key_pair

返回值


Deterministically derive the key pair from a single key

  • ? sodium_crypto_box_secretkey
  • sodium_crypto_box ?
  • PHP Manual
  • Sodium 函数
  • Deterministically derive the key pair from a single key

sodium_crypto_box_seed_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box_seed_keypair — Deterministically derive the key pair from a single key

说明

sodium_crypto_box_seed_keypair ( string $seed ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

seed

返回值


Encrypt a message

  • ? sodium_crypto_box_seed_keypair
  • sodium_crypto_generichash_final ?
  • PHP Manual
  • Sodium 函数
  • Encrypt a message

sodium_crypto_box

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_box — Encrypt a message

说明

sodium_crypto_box ( string $message , string $nonce , string $key_pair ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

nonce

key_pair

返回值


Complete the hash

  • ? sodium_crypto_box
  • sodium_crypto_generichash_init ?
  • PHP Manual
  • Sodium 函数
  • Complete the hash

sodium_crypto_generichash_final

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash_final — Complete the hash

说明

sodium_crypto_generichash_final ( string &$state , int $length = SODIUM_CRYPTO_GENERICHASH_BYTES ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

state

length

返回值


Initialize a hash

  • ? sodium_crypto_generichash_final
  • sodium_crypto_generichash_keygen ?
  • PHP Manual
  • Sodium 函数
  • Initialize a hash

sodium_crypto_generichash_init

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash_init — Initialize a hash

说明

sodium_crypto_generichash_init ( string $key = "" , int $length = SODIUM_CRYPTO_GENERICHASH_BYTES ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

key

length

返回值


Get random bytes for key

  • ? sodium_crypto_generichash_init
  • sodium_crypto_generichash_update ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_generichash_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash_keygen — Get random bytes for key

说明

sodium_crypto_generichash_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Add message to a hash

  • ? sodium_crypto_generichash_keygen
  • sodium_crypto_generichash ?
  • PHP Manual
  • Sodium 函数
  • Add message to a hash

sodium_crypto_generichash_update

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash_update — Add message to a hash

说明

sodium_crypto_generichash_update ( string &$state , string $message ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

state

message

返回值


Get a hash of the message

  • ? sodium_crypto_generichash_update
  • sodium_crypto_kdf_derive_from_key ?
  • PHP Manual
  • Sodium 函数
  • Get a hash of the message

sodium_crypto_generichash

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_generichash — Get a hash of the message

说明

sodium_crypto_generichash ( string $message , string $key = "" , int $length = SODIUM_CRYPTO_GENERICHASH_BYTES ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

key

length

返回值


Derive a subkey

  • ? sodium_crypto_generichash
  • sodium_crypto_kdf_keygen ?
  • PHP Manual
  • Sodium 函数
  • Derive a subkey

sodium_crypto_kdf_derive_from_key

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kdf_derive_from_key — Derive a subkey

说明

sodium_crypto_kdf_derive_from_key ( int $subkey_length , int $subkey_id , string $context , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

subkey_length

subkey_id

context

key

返回值


Get random bytes for key

  • ? sodium_crypto_kdf_derive_from_key
  • sodium_crypto_kx_client_session_keys ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_kdf_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kdf_keygen — Get random bytes for key

说明

sodium_crypto_kdf_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? sodium_crypto_kdf_keygen
  • sodium_crypto_kx_keypair ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_kx_client_session_keys

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_client_session_keys — Description

说明

sodium_crypto_kx_client_session_keys ( string $client_key_pair , string $server_key ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

client_key_pair

server_key

返回值


Creates a new sodium keypair

  • ? sodium_crypto_kx_client_session_keys
  • sodium_crypto_kx_publickey ?
  • PHP Manual
  • Sodium 函数
  • Creates a new sodium keypair

sodium_crypto_kx_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_keypair — Creates a new sodium keypair

说明

sodium_crypto_kx_keypair ( ) : string

Create a new sodium keypair consisting of the secret key (32 bytes) followed by the public key (32 bytes). The keys can be retrieved by calling sodium_crypto_kx_secretkey() and sodium_crypto_kx_publickey(), respectively.

参数

此函数没有参数。

返回值

Returns the new keypair on success; throws an exception otherwise.

范例

Example #1 sodium_crypto_kx_keypair() usage

Create a new keypair and retrieve the secret and the public key from it.

<?php
$keypair = sodium_crypto_kx_keypair();
$secret = sodium_crypto_kx_secretkey($keypair);
$public = sodium_crypto_kx_publickey($keypair);
printf("secret: %s\npublic: %s", bin2hex($secret), bin2hex($public));
?>

以上例程的输出类似于：

secret: e7c5c918fdc40762e6000542c0118f4368ce8fd242b0e48c1e17202797a25daf
public: d1f59fda8652caf40ed1a01d2b6f3802b60846986372cd8fa337b7c12c428b18


Description

  • ? sodium_crypto_kx_keypair
  • sodium_crypto_kx_secretkey ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_kx_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_publickey — Description

说明

sodium_crypto_kx_publickey ( string $key_pair ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

key_pair

返回值


Description

  • ? sodium_crypto_kx_publickey
  • sodium_crypto_kx_seed_keypair ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_kx_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_secretkey — Description

说明

sodium_crypto_kx_secretkey ( string $key_pair ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

key_pair

返回值


Description

  • ? sodium_crypto_kx_secretkey
  • sodium_crypto_kx_server_session_keys ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_kx_seed_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_seed_keypair — Description

说明

sodium_crypto_kx_seed_keypair ( string $seed ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

seed

返回值


Description

  • ? sodium_crypto_kx_seed_keypair
  • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_kx_server_session_keys

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_kx_server_session_keys — Description

说明

sodium_crypto_kx_server_session_keys ( string $server_key_pair , string $client_key ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

server_key_pair

client_key

返回值


Verify that the password is a valid password verification string

  • ? sodium_crypto_kx_server_session_keys
  • sodium_crypto_pwhash_scryptsalsa208sha256_str ?
  • PHP Manual
  • Sodium 函数
  • Verify that the password is a valid password verification string

sodium_crypto_pwhash_scryptsalsa208sha256_str_verify

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_scryptsalsa208sha256_str_verify — Verify that the password is a valid password verification string

说明

sodium_crypto_pwhash_scryptsalsa208sha256_str_verify ( string $hash , string $password ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

hash

password

返回值


Get an ASCII encoded hash

  • ? sodium_crypto_pwhash_scryptsalsa208sha256_str_verify
  • sodium_crypto_pwhash_scryptsalsa208sha256 ?
  • PHP Manual
  • Sodium 函数
  • Get an ASCII encoded hash

sodium_crypto_pwhash_scryptsalsa208sha256_str

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_scryptsalsa208sha256_str — Get an ASCII encoded hash

说明

sodium_crypto_pwhash_scryptsalsa208sha256_str ( string $password , int $opslimit , int $memlimit ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

password

opslimit

memlimit

返回值


Derives a key from a password

  • ? sodium_crypto_pwhash_scryptsalsa208sha256_str
  • sodium_crypto_pwhash_str_needs_rehash ?
  • PHP Manual
  • Sodium 函数
  • Derives a key from a password

sodium_crypto_pwhash_scryptsalsa208sha256

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_scryptsalsa208sha256 — Derives a key from a password

说明

sodium_crypto_pwhash_scryptsalsa208sha256 ( int $length , string $password , string $salt , int $opslimit , int $memlimit ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

length

password

salt

opslimit

memlimit

返回值


Description

  • ? sodium_crypto_pwhash_scryptsalsa208sha256
  • sodium_crypto_pwhash_str_verify ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_pwhash_str_needs_rehash

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_str_needs_rehash — Description

说明

sodium_crypto_pwhash_str_needs_rehash ( string $password , int $opslimit , int $memlimit ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

password

opslimit

memlimit

返回值


Verifies that a password matches a hash

  • ? sodium_crypto_pwhash_str_needs_rehash
  • sodium_crypto_pwhash_str ?
  • PHP Manual
  • Sodium 函数
  • Verifies that a password matches a hash

sodium_crypto_pwhash_str_verify

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_str_verify — Verifies that a password matches a hash

说明

sodium_crypto_pwhash_str_verify ( string $hash , string $password ) : bool

Checks that a password hash created using sodium_crypto_pwhash_str() matches a given plain-text password. Note that the parameters are in the opposite order to the same parameters in the similar password_hash() function.

参数

hash

一个由 password_hash() 创建的散列值。

password

用户的密码。

返回值

Returns true if the password and hash match, or false otherwise.

注释

Note:

Hashes are calculated using the Argon2ID algorithm, providing resistance to both GPU and side-channel attacks.

参见

  • sodium_crypto_pwhash_str() - Get an ASCII-encoded hash
  • password_hash() - 创建密码的散列（hash）
  • password_verify() - 验证密码是否和散列值匹配


Get an ASCII-encoded hash

  • ? sodium_crypto_pwhash_str_verify
  • sodium_crypto_pwhash ?
  • PHP Manual
  • Sodium 函数
  • Get an ASCII-encoded hash

sodium_crypto_pwhash_str

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash_str — Get an ASCII-encoded hash

说明

sodium_crypto_pwhash_str ( string $password , int $opslimit , int $memlimit ) : string

Uses a CPU- and memory-hard hash algorithm along with a randomly-generated salt, and memory and CPU limits to generate an ASCII-encoded hash suitable for password storage.

参数

password

string; The password to generate a hash for.

opslimit

Represents a maximum amount of computations to perform. Raising this number will make the function require more CPU cycles to compute a key. There are constants available to set the operations limit to appropriate values depending on intended use, in order of strength: SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE, SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE and SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE.

memlimit

The maximum amount of RAM that the function will use, in bytes. There are constants to help you choose an appropriate value, in order of size: SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE, SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE, and SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE. Typically these should be paired with the matching opslimit values.

返回值

Returns the hashed password.

In order to produce the same password hash from the same password, the same values for opslimit and memlimit must be used. These are embedded within the generated hash, so everything that's needed to verify the hash is included. This allows the sodium_crypto_pwhash_str_verify() function to verify the hash without needing separate storage for the other parameters.

注释

Note:

Hashes are calculated using the Argon2ID algorithm, providing resistance to both GPU and side-channel attacks. In contrast to the password_hash() function, there is no salt parameter (a salt is generated automatically), and the opslimit and memlimit parameters are not optional.

范例

Example #1 password_hash() example

<?php
$password = 'password';
echo sodium_crypto_pwhash_str(
    $password,
    SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE,
    SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE
);

以上例程的输出类似于：

$argon2id$v=19$m=65536,t=2,p=1$oWIfdaXwWwhVmovOBc2NAQ$EbsZ+JnZyyavkafS0hoc4HdaOB0ILWZESAZ7kVGa+Iw

参见

  • sodium_crypto_pwhash_str_verify() - Verifies that a password matches a hash
  • sodium_crypto_pwhash() - Derive a key from a password
  • password_hash() - 创建密码的散列（hash）
  • password_verify() - 验证密码是否和散列值匹配
  • » Libsodium Argon2 docs


Derive a key from a password

  • ? sodium_crypto_pwhash_str
  • sodium_crypto_scalarmult_base ?
  • PHP Manual
  • Sodium 函数
  • Derive a key from a password

sodium_crypto_pwhash

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_pwhash — Derive a key from a password

说明

sodium_crypto_pwhash ( int $length , string $password , string $salt , int $opslimit , int $memlimit , int $algo = SODIUM_CRYPTO_PWHASH_ALG_DEFAULT ) : string

This function provides low-level access to libsodium's crypto_pwhash key derivation function. Unless you have specific reason to use this function, you should use sodium_crypto_pwhash_str() or password_hash() functions instead.

参数

length

int; The length of the password hash to generate, in bytes.

password

string; The password to generate a hash for.

salt

string A salt to add to the password before hashing. The salt should be unpredictable, ideally generated from a good random mumber source such as random_bytes(), and have a length of at least SODIUM_CRYPTO_PWHASH_SALTBYTES bytes.

opslimit

Represents a maximum amount of computations to perform. Raising this number will make the function require more CPU cycles to compute a key. There are some constants available to set the operations limit to appropriate values depending on intended use, in order of strength: SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE, SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE and SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE.

memlimit

The maximum amount of RAM that the function will use, in bytes. There are constants to help you choose an appropriate value, in order of size: SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE, SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE, and SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE. Typically these should be paired with the matching opslimit values.

algo

int A number indicating the hash algorithm to use. By default SODIUM_CRYPTO_PWHASH_ALG_DEFAULT (the currently recommended algorithm, which can change from one version of libsodium to another), or explicitly using SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13, representing the Argon2id algorithm version 1.3.

返回值

Returns the derived key. The return value is a binary string of the hash, not an ASCII-encoded representation, and does not contain additional information about the parameters used to create the hash, so you will need to keep that information if you are ever going to verify the password in future. Use sodium_crypto_pwhash_str() to avoid needing to do all that.

范例

Example #1 password_hash() example

<?php
//Need to keep the salt if we're ever going to be able to check this password
$salt = random_bytes(SODIUM_CRYPTO_PWHASH_SALTBYTES);
//Using bin2hex to keep output readable
echo bin2hex(
    sodium_crypto_pwhash(
        16, // == 128 bits
        'password',
        $salt,
        SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE,
        SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE,
        SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13
    )
);
?>

以上例程的输出类似于：

a18f346ba57992eb7e4ae6abf3fd30ee


别名 sodium_crypto_box_publickey_from_secretkey

  • ? sodium_crypto_pwhash
  • sodium_crypto_scalarmult ?
  • PHP Manual
  • Sodium 函数
  • 别名 sodium_crypto_box_publickey_from_secretkey

sodium_crypto_scalarmult_base

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_scalarmult_base — 别名 sodium_crypto_box_publickey_from_secretkey()

说明

此函数是该函数的别名： sodium_crypto_box_publickey_from_secretkey().


Compute a shared secret given a user's secret key and another user's public key

  • ? sodium_crypto_scalarmult_base
  • sodium_crypto_secretbox_keygen ?
  • PHP Manual
  • Sodium 函数
  • Compute a shared secret given a user's secret key and another user's public key

sodium_crypto_scalarmult

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_scalarmult — Compute a shared secret given a user's secret key and another user's public key

说明

sodium_crypto_scalarmult ( string $n , string $p ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

n

p

返回值


Get random bytes for key

  • ? sodium_crypto_scalarmult
  • sodium_crypto_secretbox_open ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_secretbox_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretbox_keygen — Get random bytes for key

说明

sodium_crypto_secretbox_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Verify and decrypt a ciphertext

  • ? sodium_crypto_secretbox_keygen
  • sodium_crypto_secretbox ?
  • PHP Manual
  • Sodium 函数
  • Verify and decrypt a ciphertext

sodium_crypto_secretbox_open

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretbox_open — Verify and decrypt a ciphertext

说明

sodium_crypto_secretbox_open ( string $ciphertext , string $nonce , string $key ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

ciphertext

nonce

key

返回值


Encrypt a message

  • ? sodium_crypto_secretbox_open
  • sodium_crypto_secretstream_xchacha20poly1305_init_pull ?
  • PHP Manual
  • Sodium 函数
  • Encrypt a message

sodium_crypto_secretbox

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretbox — Encrypt a message

说明

sodium_crypto_secretbox ( string $message , string $nonce , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

nonce

key

返回值


Description

  • ? sodium_crypto_secretbox
  • sodium_crypto_secretstream_xchacha20poly1305_init_push ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_secretstream_xchacha20poly1305_init_pull

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_init_pull — Description

说明

sodium_crypto_secretstream_xchacha20poly1305_init_pull ( string $header , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

header

key

返回值


Description

  • ? sodium_crypto_secretstream_xchacha20poly1305_init_pull
  • sodium_crypto_secretstream_xchacha20poly1305_keygen ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_secretstream_xchacha20poly1305_init_push

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_init_push — Description

说明

sodium_crypto_secretstream_xchacha20poly1305_init_push ( string $key ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

key

返回值


Description

  • ? sodium_crypto_secretstream_xchacha20poly1305_init_push
  • sodium_crypto_secretstream_xchacha20poly1305_pull ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_secretstream_xchacha20poly1305_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_keygen — Description

说明

sodium_crypto_secretstream_xchacha20poly1305_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? sodium_crypto_secretstream_xchacha20poly1305_keygen
  • sodium_crypto_secretstream_xchacha20poly1305_push ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_secretstream_xchacha20poly1305_pull

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_pull — Description

说明

sodium_crypto_secretstream_xchacha20poly1305_pull ( string &$state , string $ciphertext , string $additional_data = "" ) : array|false

Warning

本函数还未编写文档，仅有参数列表。

参数

state

ciphertext

additional_data

返回值


Description

  • ? sodium_crypto_secretstream_xchacha20poly1305_pull
  • sodium_crypto_secretstream_xchacha20poly1305_rekey ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_secretstream_xchacha20poly1305_push

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_push — Description

说明

sodium_crypto_secretstream_xchacha20poly1305_push ( string &$state , string $message , string $additional_data = "" , int $tag = SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_MESSAGE ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

state

message

additional_data

tag

返回值


Description

  • ? sodium_crypto_secretstream_xchacha20poly1305_push
  • sodium_crypto_shorthash_keygen ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_secretstream_xchacha20poly1305_rekey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_secretstream_xchacha20poly1305_rekey — Description

说明

sodium_crypto_secretstream_xchacha20poly1305_rekey ( string &$state ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

state

返回值


Get random bytes for key

  • ? sodium_crypto_secretstream_xchacha20poly1305_rekey
  • sodium_crypto_shorthash ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_shorthash_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_shorthash_keygen — Get random bytes for key

说明

sodium_crypto_shorthash_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Compute a fixed-size fingerprint for the message

  • ? sodium_crypto_shorthash_keygen
  • sodium_crypto_sign_detached ?
  • PHP Manual
  • Sodium 函数
  • Compute a fixed-size fingerprint for the message

sodium_crypto_shorthash

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_shorthash — Compute a fixed-size fingerprint for the message

说明

sodium_crypto_shorthash ( string $message , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

key

返回值


Sign the message

  • ? sodium_crypto_shorthash
  • sodium_crypto_sign_ed25519_pk_to_curve25519 ?
  • PHP Manual
  • Sodium 函数
  • Sign the message

sodium_crypto_sign_detached

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_detached — Sign the message

说明

sodium_crypto_sign_detached ( string $message , string $secret_key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

secret_key

返回值


Convert an Ed25519 public key to a Curve25519 public key

  • ? sodium_crypto_sign_detached
  • sodium_crypto_sign_ed25519_sk_to_curve25519 ?
  • PHP Manual
  • Sodium 函数
  • Convert an Ed25519 public key to a Curve25519 public key

sodium_crypto_sign_ed25519_pk_to_curve25519

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_ed25519_pk_to_curve25519 — Convert an Ed25519 public key to a Curve25519 public key

说明

sodium_crypto_sign_ed25519_pk_to_curve25519 ( string $public_key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

public_key

返回值


Convert an Ed25519 secret key to a Curve25519 secret key

  • ? sodium_crypto_sign_ed25519_pk_to_curve25519
  • sodium_crypto_sign_keypair_from_secretkey_and_publickey ?
  • PHP Manual
  • Sodium 函数
  • Convert an Ed25519 secret key to a Curve25519 secret key

sodium_crypto_sign_ed25519_sk_to_curve25519

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_ed25519_sk_to_curve25519 — Convert an Ed25519 secret key to a Curve25519 secret key

说明

sodium_crypto_sign_ed25519_sk_to_curve25519 ( string $secret_key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

secret_key

返回值


Description

  • ? sodium_crypto_sign_ed25519_sk_to_curve25519
  • sodium_crypto_sign_keypair ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_sign_keypair_from_secretkey_and_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_keypair_from_secretkey_and_publickey — Description

说明

sodium_crypto_sign_keypair_from_secretkey_and_publickey ( string $secret_key , string $public_key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

secret_key

public_key

返回值


Randomly generate a secret key and a corresponding public key

  • ? sodium_crypto_sign_keypair_from_secretkey_and_publickey
  • sodium_crypto_sign_open ?
  • PHP Manual
  • Sodium 函数
  • Randomly generate a secret key and a corresponding public key

sodium_crypto_sign_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_keypair — Randomly generate a secret key and a corresponding public key

说明

sodium_crypto_sign_keypair ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Check that the signed message has a valid signature

  • ? sodium_crypto_sign_keypair
  • sodium_crypto_sign_publickey_from_secretkey ?
  • PHP Manual
  • Sodium 函数
  • Check that the signed message has a valid signature

sodium_crypto_sign_open

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_open — Check that the signed message has a valid signature

说明

sodium_crypto_sign_open ( string $ciphertext , string $public_key ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

ciphertext

public_key

返回值


Extract the public key from the secret key

  • ? sodium_crypto_sign_open
  • sodium_crypto_sign_publickey ?
  • PHP Manual
  • Sodium 函数
  • Extract the public key from the secret key

sodium_crypto_sign_publickey_from_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_publickey_from_secretkey — Extract the public key from the secret key

说明

sodium_crypto_sign_publickey_from_secretkey ( string $secret_key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

secret_key

返回值


Description

  • ? sodium_crypto_sign_publickey_from_secretkey
  • sodium_crypto_sign_secretkey ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_sign_publickey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_publickey — Description

说明

sodium_crypto_sign_publickey ( string $key_pair ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

key_pair

返回值


Description

  • ? sodium_crypto_sign_publickey
  • sodium_crypto_sign_seed_keypair ?
  • PHP Manual
  • Sodium 函数
  • Description

sodium_crypto_sign_secretkey

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_secretkey — Description

说明

sodium_crypto_sign_secretkey ( string $key_pair ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

key_pair

返回值


Deterministically derive the key pair from a single key

  • ? sodium_crypto_sign_secretkey
  • sodium_crypto_sign_verify_detached ?
  • PHP Manual
  • Sodium 函数
  • Deterministically derive the key pair from a single key

sodium_crypto_sign_seed_keypair

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_seed_keypair — Deterministically derive the key pair from a single key

说明

sodium_crypto_sign_seed_keypair ( string $seed ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

seed

返回值


Verify signature for the message

  • ? sodium_crypto_sign_seed_keypair
  • sodium_crypto_sign ?
  • PHP Manual
  • Sodium 函数
  • Verify signature for the message

sodium_crypto_sign_verify_detached

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign_verify_detached — Verify signature for the message

说明

sodium_crypto_sign_verify_detached ( string $signature , string $message , string $public_key ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

signature

message

public_key

返回值


Sign a message

  • ? sodium_crypto_sign_verify_detached
  • sodium_crypto_stream_keygen ?
  • PHP Manual
  • Sodium 函数
  • Sign a message

sodium_crypto_sign

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_sign — Sign a message

说明

sodium_crypto_sign ( string $message , string $secret_key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

secret_key

返回值


Get random bytes for key

  • ? sodium_crypto_sign
  • sodium_crypto_stream_xor ?
  • PHP Manual
  • Sodium 函数
  • Get random bytes for key

sodium_crypto_stream_keygen

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_stream_keygen — Get random bytes for key

说明

sodium_crypto_stream_keygen ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Encrypt a message

  • ? sodium_crypto_stream_keygen
  • sodium_crypto_stream ?
  • PHP Manual
  • Sodium 函数
  • Encrypt a message

sodium_crypto_stream_xor

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_stream_xor — Encrypt a message

说明

sodium_crypto_stream_xor ( string $message , string $nonce , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

message

nonce

key

返回值


Generate a deterministic sequence of bytes from a seed

  • ? sodium_crypto_stream_xor
  • sodium_hex2bin ?
  • PHP Manual
  • Sodium 函数
  • Generate a deterministic sequence of bytes from a seed

sodium_crypto_stream

(PHP 7 >= 7.2.0, PHP 8)

sodium_crypto_stream — Generate a deterministic sequence of bytes from a seed

说明

sodium_crypto_stream ( int $length , string $nonce , string $key ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

length

nonce

key

返回值


Decodes a hexadecimally encoded binary string

  • ? sodium_crypto_stream
  • sodium_increment ?
  • PHP Manual
  • Sodium 函数
  • Decodes a hexadecimally encoded binary string

sodium_hex2bin

(PHP 7 >= 7.2.0, PHP 8)

sodium_hex2bin — Decodes a hexadecimally encoded binary string

说明

sodium_hex2bin ( string $string , string $ignore = "" ) : string

Decodes a hexadecimally encoded binary string.

Like sodium_bin2hex(), sodium_hex2bin() is resistant to side-channel attacks while hex2bin() is not.

参数

string

Hexadecimal representation of data.

ignore

Optional string argument for characters to ignore.

返回值

Returns the binary representation of the given string data.


Increment large number

  • ? sodium_hex2bin
  • sodium_memcmp ?
  • PHP Manual
  • Sodium 函数
  • Increment large number

sodium_increment

(PHP 7 >= 7.2.0, PHP 8)

sodium_increment — Increment large number

说明

sodium_increment ( string &$string ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

string

返回值


Test for equality in constant-time

  • ? sodium_increment
  • sodium_memzero ?
  • PHP Manual
  • Sodium 函数
  • Test for equality in constant-time

sodium_memcmp

(PHP 7 >= 7.2.0, PHP 8)

sodium_memcmp — Test for equality in constant-time

说明

sodium_memcmp ( string $string1 , string $string2 ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

string1

string2

返回值


Overwrite buf with zeros

  • ? sodium_memcmp
  • sodium_pad ?
  • PHP Manual
  • Sodium 函数
  • Overwrite buf with zeros

sodium_memzero

(PHP 7 >= 7.2.0, PHP 8)

sodium_memzero — Overwrite buf with zeros

说明

sodium_memzero ( string &$string ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

string

返回值


Add padding data

  • ? sodium_memzero
  • sodium_unpad ?
  • PHP Manual
  • Sodium 函数
  • Add padding data

sodium_pad

(PHP 7 >= 7.2.0, PHP 8)

sodium_pad — Add padding data

说明

sodium_pad ( string $string , int $length ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

string

length

返回值


Remove padding data

  • ? sodium_pad
  • SodiumException ?
  • PHP Manual
  • Sodium 函数
  • Remove padding data

sodium_unpad

(PHP 7 >= 7.2.0, PHP 8)

sodium_unpad — Remove padding data

说明

sodium_unpad ( string $string , int $block_size ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

string

block_size

返回值


The SodiumException class

(PHP 7 >= 7.2.0, PHP 8)

简介

Exceptions thrown by the sodium functions.

类摘要

SodiumException extends Exception implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


数据库扩展

  • 数据库抽象层
    • DBA — Database (dbm-style) Abstraction Layer
    • ODBC — ODBC (Unified)
    • PDO — PHP 数据对象
  • 针对各数据库系统对应的扩展
    • CUBRID
    • DB++
    • dBase
    • filePro
    • Firebird/InterBase
    • FrontBase
    • IBM DB2 — IBM DB2, Cloudscape and Apache Derby
    • Ingres — Ingres DBMS, EDBC, and Enterprise Access Gateways
    • Mongo — MongoDB 驱动（旧版）
    • MongoDB — MongoDB driver
    • MySQL — MySQL Drivers and Plugins
    • OCI8 — Oracle OCI8
    • Paradox — Paradox File Access
    • PostgreSQL
    • SQLite3
    • SQLSRV — Microsoft SQL Server Driver for PHP
    • tokyo_tyrant


数据库抽象层

  • DBA — Database (dbm-style) Abstraction Layer
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • DBA 函数
  • ODBC — ODBC (Unified)
    • 简介
    • 安装／配置
    • 预定义常量
    • ODBC 函数
  • PDO — PHP 数据对象
    • 简介
    • 安装／配置
    • 预定义常量
    • 连接与连接管理
    • 事务与自动提交
    • 预处理语句与存储过程
    • 错误与错误处理
    • 大对象 (LOBs)
    • PDO — PDO 类
    • PDOStatement — PDOStatement 类
    • PDOException — PDOException 异常类
    • PDO 驱动


Database (dbm-style) Abstraction Layer

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic usage
  • DBA 函数
    • dba_close — Close a DBA database
    • dba_delete — Delete DBA entry specified by key
    • dba_exists — Check whether key exists
    • dba_fetch — Fetch data specified by key
    • dba_firstkey — Fetch first key
    • dba_handlers — List all the handlers available
    • dba_insert — Insert entry
    • dba_key_split — Splits a key in string representation into array representation
    • dba_list — List all open database files
    • dba_nextkey — Fetch next key
    • dba_open — Open database
    • dba_optimize — Optimize database
    • dba_popen — Open database persistently
    • dba_replace — Replace or insert entry
    • dba_sync — Synchronize database


简介

These functions build the foundation for accessing Berkeley DB style databases.

This is a general abstraction layer for several file-based databases. As such, functionality is limited to a common subset of features supported by modern databases such as » Oracle Berkeley DB.


需求

The behaviour of various aspects depends on the implementation of the underlying database. Functions such as dba_optimize() and dba_sync() will do what they promise for one database and will do nothing for others. You have to download and install supported dba-Handlers.

List of DBA handlers
Handler | Notes
dbm | Dbm is the oldest (original) type of Berkeley DB style databases. You should avoid it, if possible. We do not support the compatibility functions built into DB2 and gdbm, because they are only compatible on the source code level, but cannot handle the original dbm format.
ndbm | Ndbm is a newer type and more flexible than dbm. It still has most of the arbitrary limits of dbm (therefore it is deprecated).
gdbm | Gdbm is the » GNU database manager.
db2 | DB2 is for » Oracle Berkeley DB 2. It is described as "a programmatic toolkit that provides high-performance built-in database support for both standalone and client/server applications."
db3 | DB3 is for » Oracle Berkeley DB 3.
db4 | DB4 is for » Oracle Berkeley DB 4 or 5. This option can be used with BDB 5 as of PHP 5.3.3.
cdb | Cdb is "a fast, reliable, lightweight package for creating and reading constant databases." It is from the author of qmail and can be found at » http://cr.yp.to/cdb.html. Since it is constant, we support only reading operations. We support writing (not updating) through the internal cdb library.
cdb_make | We support creation (not updating) of cdb files when the bundled cdb library is used.
flatfile | This is available for compatibility with the deprecated dbm extension only and should be avoided. However you may use this where files were created in this format. That happens when configure could not find any external library.
inifile | This is available to be able to modify php.ini files from within PHP scripts. When working with ini files you can pass arrays of the form array(0=>group,1=>value_name) or strings of the form "[group]value_name" where group is optional. As the functions dba_firstkey() and dba_nextkey() return string representations of the key there is the function dba_key_split() which allows to convert the string keys into array keys without loosing false.
qdbm | The qdbm library can be downloaded from » http://fallabs.com/qdbm/index.html.
tcadb | This is available since PHP 5.4.0. The Tokyo Cabinet library can be downloaded from » http://fallabs.com/tokyocabinet/.
lmdb | This is available since PHP 7.2.0. The Lightning Memory-Mapped Database library can be downloaded from » https://symas.com/lmdb/.

When invoking the dba_open() or dba_popen() functions, one of the handler names must be supplied as an argument. The actually available list of handlers is displayed by invoking phpinfo() or dba_handlers().


安装

By using the --enable-dba=shared configuration option you can build a dynamic loadable module to enable PHP for basic support of dbm-style databases. You also have to add support for at least one of the following handlers by specifying the --with-XXXX or --enable-XXXX configure switch to your PHP configure line.

Warning

After configuring and compiling PHP you must execute the following test from commandline: php run-tests.php ext/dba. This shows whether your combination of handlers works. Most problematic are dbm and ndbm which conflict with many installations. The reason for this is that on several systems these libraries are part of more than one other library. The configuration test only prevents you from configuring malfunctioning single handlers but not combinations.

Supported DBA handlers
Handler | Configure Switch
dbm

To enable support for dbm add --with-dbm[=DIR].

Note:

dbm normally is a wrapper which often results in failures. This means you should only use dbm if you are sure it works and if you really need this format.

ndbm

To enable support for ndbm add --with-ndbm[=DIR].

Note:

ndbm normally is a wrapper which often results in failures. This means you should only use ndbm if you are sure it works and if you really need this format.

gdbm | To enable support for gdbm add --with-gdbm[=DIR].
db2

To enable support for Oracle Berkeley DB 2 add --with-db2[=DIR].

Note:

db2 conflicts with db3 and db4.

db3

To enable support for Oracle Berkeley DB 3 add --with-db3[=DIR].

Note:

db3 conflicts with db2 and db4.

db4

To enable support for Oracle Berkeley DB 4 or 5 add --with-db4[=DIR].

Note:

db4 conflicts with db2 and db3.

Note:

The db libraries with versions 4.1 through 4.1.24 cannot be used in any PHP version.

Support for BDB 5 was added in PHP 5.3.3.

cdb

To enable support for cdb add --with-cdb[=DIR].

Note:

You can omit DIR to use the bundled cdb library that adds the cdb_make handler which allows creation of cdb files and allows to access cdb files on the network using PHP's streams.

flatfile

To enable support for flatfile add --enable-flatfile. Before PHP 5.2.1 the --with-flatfile had to be used instead.

Note:

This was added to add compatibility with deprecated dbm extension. Use this handler only when you cannot install one of the libraries required by the other handlers and when you cannot use bundled cdb handler.

inifile

To enable support for inifile add --enable-inifile. Before PHP 5.2.1 the --with-inifile had to be used instead.

Note:

This was added to allow to read and set microsoft style .ini files (like the php.ini file).

qdbm

To enable support for qdbm add --with-qdbm[=DIR].

Note:

qdbm conflicts with dbm and gdbm.

Note:

The qdbm library can be downloaded from » http://fallabs.com/qdbm/index.html.

tcadb

To enable support for Tokyo Cabinet add --with-tcadb[=DIR].

Note:

This was added in PHP 5.4.0. The Tokyo Cabinet library can be downloaded from » http://fallabs.com/tokyocabinet/.

lmdb

To enable support for the Lightning Memory-Mapped Database add --with-lmdb[=DIR].

Note:

This was added in PHP 7.2.0. The Lightning Memory-Mapped Database library can be downloaded from » https://symas.com/lmdb/.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

DBA 配置选项
名字 | 默认 | 可修改范围 | 更新日志
dba.default_handler | DBA_DEFAULT | PHP_INI_ALL |

这是配置指令的简短说明。

dba.default_handler string

The name of the default handler


资源类型

The functions dba_open() and dba_popen() return a handle to the specified database file to access which is used by all other dba-function calls.


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • DBA
  • 预定义常量

预定义常量

此扩展没有定义常量。


  • ? 预定义常量
  • Basic usage ?
  • PHP Manual
  • DBA
  • 范例

范例

Table of Contents

  • Basic usage


Basic usage

Example #1 DBA example

<?php

$id = dba_open("/tmp/test.db", "n", "db2");

if (!$id) {
    echo "dba_open failed\n";
    exit;
}

dba_replace("key", "This is an example!", $id);

if (dba_exists("key", $id)) {
    echo dba_fetch("key", $id);
    dba_delete("key", $id);
}

dba_close($id);
?>

DBA is binary safe and does not have any arbitrary limits. However, it inherits all limits set by the underlying database implementation.

All file-based databases must provide a way of setting the file mode of a new created database, if that is possible at all. The file mode is commonly passed as the fourth argument to dba_open() or dba_popen().

You can access all entries of a database in a linear way by using the dba_firstkey() and dba_nextkey() functions. You may not change the database while traversing it.

Example #2 Traversing a database

<?php

// ...open database...

$key = dba_firstkey($id);

while ($key !== false) {
    if (true) {          // remember the key to perform some action later
        $handle_later[] = $key;
    }
    $key = dba_nextkey($id);
}

foreach ($handle_later as $val) {
    dba_delete($val, $id);
}

?>


DBA 函数

Table of Contents

  • dba_close — Close a DBA database
  • dba_delete — Delete DBA entry specified by key
  • dba_exists — Check whether key exists
  • dba_fetch — Fetch data specified by key
  • dba_firstkey — Fetch first key
  • dba_handlers — List all the handlers available
  • dba_insert — Insert entry
  • dba_key_split — Splits a key in string representation into array representation
  • dba_list — List all open database files
  • dba_nextkey — Fetch next key
  • dba_open — Open database
  • dba_optimize — Optimize database
  • dba_popen — Open database persistently
  • dba_replace — Replace or insert entry
  • dba_sync — Synchronize database


Close a DBA database

  • ? DBA 函数
  • dba_delete ?
  • PHP Manual
  • DBA 函数
  • Close a DBA database

dba_close

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_close — Close a DBA database

说明

dba_close ( resource $dba ) : void

dba_close() closes the established database and frees all resources of the specified database handle.

参数

dba

The database handler, returned by dba_open() or dba_popen().

返回值

没有返回值。

参见

  • dba_open() - Open database
  • dba_popen() - Open database persistently


Delete DBA entry specified by key

  • ? dba_close
  • dba_exists ?
  • PHP Manual
  • DBA 函数
  • Delete DBA entry specified by key

dba_delete

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_delete — Delete DBA entry specified by key

说明

dba_delete ( string|array $key , resource $dba ) : bool

dba_delete() deletes the specified entry from the database.

参数

key

The key of the entry which is deleted.

dba

The database handler, returned by dba_open() or dba_popen().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • dba_exists() - Check whether key exists
  • dba_fetch() - Fetch data specified by key
  • dba_insert() - Insert entry
  • dba_replace() - Replace or insert entry


Check whether key exists

  • ? dba_delete
  • dba_fetch ?
  • PHP Manual
  • DBA 函数
  • Check whether key exists

dba_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_exists — Check whether key exists

说明

dba_exists ( string|array $key , resource $dba ) : bool

dba_exists() checks whether the specified key exists in the database.

参数

key

The key the check is performed for.

dba

The database handler, returned by dba_open() or dba_popen().

返回值

Returns true if the key exists, false otherwise.

参见

  • dba_delete() - Delete DBA entry specified by key
  • dba_fetch() - Fetch data specified by key
  • dba_insert() - Insert entry
  • dba_replace() - Replace or insert entry


Fetch data specified by key

  • ? dba_exists
  • dba_firstkey ?
  • PHP Manual
  • DBA 函数
  • Fetch data specified by key

dba_fetch

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_fetch — Fetch data specified by key

说明

dba_fetch ( string $key , resource $handle ) : string
dba_fetch ( string $key , int $skip , resource $handle ) : string

dba_fetch() fetches the data specified by key from the database specified with handle.

参数

key

The key the data is specified by.

Note:

When working with inifiles this function accepts arrays as keys where index 0 is the group and index 1 is the value name. See: dba_key_split().

skip

The number of key-value pairs to ignore when using cdb databases. This value is ignored for all other databases which do not support multiple keys with the same name.

handle

The database handler, returned by dba_open() or dba_popen().

返回值

Returns the associated string if the key/data pair is found, false otherwise.

参见

  • dba_exists() - Check whether key exists
  • dba_delete() - Delete DBA entry specified by key
  • dba_insert() - Insert entry
  • dba_replace() - Replace or insert entry
  • dba_key_split() - Splits a key in string representation into array representation


Fetch first key

  • ? dba_fetch
  • dba_handlers ?
  • PHP Manual
  • DBA 函数
  • Fetch first key

dba_firstkey

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_firstkey — Fetch first key

说明

dba_firstkey ( resource $dba ) : string|false

dba_firstkey() returns the first key of the database and resets the internal key pointer. This permits a linear search through the whole database.

参数

dba

The database handler, returned by dba_open() or dba_popen().

返回值

Returns the key on success 或者在失败时返回 false.

参见

  • dba_nextkey() - Fetch next key
  • dba_key_split() - Splits a key in string representation into array representation
  • Example 2 in the DBA examples


List all the handlers available

  • ? dba_firstkey
  • dba_insert ?
  • PHP Manual
  • DBA 函数
  • List all the handlers available

dba_handlers

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

dba_handlers — List all the handlers available

说明

dba_handlers ( bool $full_info = false ) : array

dba_handlers() list all the handlers supported by this extension.

参数

full_info

Turns on/off full information display in the result.

返回值

Returns an array of database handlers. If full_info is set to true, the array will be associative with the handlers names as keys, and their version information as value. Otherwise, the result will be an indexed array of handlers names.

Note:

When the internal cdb library is used you will see cdb and cdb_make.

范例

Example #1 dba_handlers() Example

<?php

echo "Available DBA handlers:\n";
foreach (dba_handlers(true) as $handler_name => $handler_version) {
  // clean the versions
  $handler_version = str_replace('$', '', $handler_version);
  echo " - $handler_name: $handler_version\n";
}

?>

以上例程的输出类似于：

Available DBA handlers:
 - cdb: 0.75, Revision: 1.3.2.3
 - cdb_make: 0.75, Revision: 1.2.2.4
 - db2: Sleepycat Software: Berkeley DB 2.7.7: (08/20/99)
 - inifile: 1.0, Revision: 1.6.2.3
 - flatfile: 1.0, Revision: 1.5.2.4


Insert entry

  • ? dba_handlers
  • dba_key_split ?
  • PHP Manual
  • DBA 函数
  • Insert entry

dba_insert

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_insert — Insert entry

说明

dba_insert ( string|array $key , string $value , resource $dba ) : bool

dba_insert() inserts the entry described with key and value into the database.

参数

key

The key of the entry to be inserted. If this key already exist in the database, this function will fail. Use dba_replace() if you need to replace an existent key.

value

The value to be inserted.

dba

The database handler, returned by dba_open() or dba_popen().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • dba_exists() - Check whether key exists
  • dba_delete() - Delete DBA entry specified by key
  • dba_fetch() - Fetch data specified by key
  • dba_replace() - Replace or insert entry


Splits a key in string representation into array representation

  • ? dba_insert
  • dba_list ?
  • PHP Manual
  • DBA 函数
  • Splits a key in string representation into array representation

dba_key_split

(PHP 5, PHP 7, PHP 8)

dba_key_split — Splits a key in string representation into array representation

说明

dba_key_split ( string|false|null $key ) : array|false

dba_key_split() splits a key (string representation) into an array representation.

参数

key

The key in string representation.

返回值

Returns an array of the form array(0 => group, 1 => value_name). This function will return false if key is null or false.

参见

  • dba_firstkey() - Fetch first key
  • dba_nextkey() - Fetch next key
  • dba_fetch() - Fetch data specified by key


List all open database files

  • ? dba_key_split
  • dba_nextkey ?
  • PHP Manual
  • DBA 函数
  • List all open database files

dba_list

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

dba_list — List all open database files

说明

dba_list ( ) : array

dba_list() list all open database files.

返回值

An associative array, in the form resourceid => filename.


Fetch next key

  • ? dba_list
  • dba_open ?
  • PHP Manual
  • DBA 函数
  • Fetch next key

dba_nextkey

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_nextkey — Fetch next key

说明

dba_nextkey ( resource $dba ) : string|false

dba_nextkey() returns the next key of the database and advances the internal key pointer.

参数

dba

The database handler, returned by dba_open() or dba_popen().

返回值

Returns the key on success 或者在失败时返回 false.

参见

  • dba_firstkey() - Fetch first key
  • dba_key_split() - Splits a key in string representation into array representation
  • Example 2 in the DBA examples


Open database

  • ? dba_nextkey
  • dba_optimize ?
  • PHP Manual
  • DBA 函数
  • Open database

dba_open

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_open — Open database

说明

dba_open ( string $path , string $mode , string $handler = ? , string ...$args ) : resource|false

dba_open() establishes a database instance for path with mode using handler.

参数

path

Commonly a regular path in your filesystem.

mode

It is r for read access, w for read/write access to an already existing database, c for read/write access and database creation if it doesn't currently exist, and n for create, truncate and read/write access. The database is created in BTree mode, other modes (like Hash or Queue) are not supported.

Additionally you can set the database lock method with the next char. Use l to lock the database with a .lck file or d to lock the databasefile itself. It is important that all of your applications do this consistently.

If you want to test the access and do not want to wait for the lock you can add t as third character. When you are absolutely sure that you do not require database locking you can do so by using - instead of l or d. When none of d, l or - is used, dba will lock on the database file as it would with d.

Note:

There can only be one writer for one database file. When you use dba on a web server and more than one request requires write operations they can only be done one after another. Also read during write is not allowed. The dba extension uses locks to prevent this. See the following table:

DBA locking
already open | mode = "rl" | mode = "rlt" | mode = "wl" | mode = "wlt" | mode = "rd" | mode = "rdt" | mode = "wd" | mode = "wdt"
not open | ok | ok | ok | ok | ok | ok | ok | ok
mode = "rl" | ok | ok | wait | false | illegal | illegal | illegal | illegal
mode = "wl" | wait | false | wait | false | illegal | illegal | illegal | illegal
mode = "rd" | illegal | illegal | illegal | illegal | ok | ok | wait | false
mode = "wd" | illegal | illegal | illegal | illegal | wait | false | wait | false
  • ok: the second call will be successfull.
  • wait: the second call waits until dba_close() is called for the first.
  • false: the second call returns false.
  • illegal: you must not mix "l" and "d" modifiers for mode parameter.

handler

The name of the handler which shall be used for accessing path. It is passed all optional parameters given to dba_open() and can act on behalf of them.

args

Optional string parameters which are passed to the driver.

The cdb, cdb_make, flatfile, inifile, qdbm and tcadb drivers do not support additional parameters.

The db1, db2, db3, db4, dbm, gdbm, and ndbm drivers supports a single additional parameter $filemode, which has the same meaning as the $mode parameter of chmod(), and defaults to 0644.

The lmdb driver accepts two additional parameters. The first allows to specify the $filemode (see description above), and the second to specify the $mapsize, where the value should be a multiple of the page size of the OS, or zero, to use the default mapsize. The $mapsize parameter is supported as of PHP 7.3.14 and 7.4.2, respectively.

返回值

Returns a positive handle on success 或者在失败时返回 false.

更新日志

版本 | 说明
7.3.14, 7.4.2 | The lmdb driver now supports an additional $mapsize parameter.

参见

  • dba_popen() - Open database persistently
  • dba_close() - Close a DBA database


Optimize database

  • ? dba_open
  • dba_popen ?
  • PHP Manual
  • DBA 函数
  • Optimize database

dba_optimize

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_optimize — Optimize database

说明

dba_optimize ( resource $dba ) : bool

dba_optimize() optimizes the underlying database.

参数

dba

The database handler, returned by dba_open() or dba_popen().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • dba_sync() - Synchronize database


Open database persistently

  • ? dba_optimize
  • dba_replace ?
  • PHP Manual
  • DBA 函数
  • Open database persistently

dba_popen

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_popen — Open database persistently

说明

dba_popen ( string $path , string $mode , string $handler = ? , mixed ...$args ) : resource|false

dba_popen() establishes a persistent database instance for path with mode using handler.

参数

path

Commonly a regular path in your filesystem.

mode

It is r for read access, w for read/write access to an already existing database, c for read/write access and database creation if it doesn't currently exist, and n for create, truncate and read/write access.

handler

The name of the handler which shall be used for accessing path. It is passed all optional parameters given to dba_popen() and can act on behalf of them.

args

Optional string parameters which are passed to the driver.

The cdb, cdb_make, flatfile, inifile, qdbm and tcadb drivers do not support additional parameters.

The db1, db2, db3, db4, dbm, gdbm, and ndbm drivers supports a single additional parameter $filemode, which has the same meaning as the $mode parameter of chmod(), and defaults to 0644.

The lmdb driver accepts two additional parameters. The first allows to specify the $filemode (see description above), and the second to specify the $mapsize, where the value should be a multiple of the page size of the OS, or zero, to use the default mapsize. The $mapsize parameter is supported as of PHP 7.3.14 and 7.4.2, respectively.

返回值

Returns a positive handle on success 或者在失败时返回 false.

参见

  • dba_open() - Open database
  • dba_close() - Close a DBA database


Replace or insert entry

  • ? dba_popen
  • dba_sync ?
  • PHP Manual
  • DBA 函数
  • Replace or insert entry

dba_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_replace — Replace or insert entry

说明

dba_replace ( string|array $key , string $value , resource $dba ) : bool

dba_replace() replaces or inserts the entry described with key and value into the database specified by dba.

参数

key

The key of the entry to be replaced.

value

The value to be replaced.

dba

The database handler, returned by dba_open() or dba_popen().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • dba_exists() - Check whether key exists
  • dba_delete() - Delete DBA entry specified by key
  • dba_fetch() - Fetch data specified by key
  • dba_insert() - Insert entry


Synchronize database

  • ? dba_replace
  • ODBC ?
  • PHP Manual
  • DBA 函数
  • Synchronize database

dba_sync

(PHP 4, PHP 5, PHP 7, PHP 8)

dba_sync — Synchronize database

说明

dba_sync ( resource $dba ) : bool

dba_sync() synchronizes the database. This will probably trigger a physical write to the disk, if supported.

参数

dba

The database handler, returned by dba_open() or dba_popen().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • dba_optimize() - Optimize database


ODBC (Unified)

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • ODBC 函数
    • odbc_autocommit — Toggle autocommit behaviour
    • odbc_binmode — Handling of binary column data
    • odbc_close_all — Close all ODBC connections
    • odbc_close — Close an ODBC connection
    • odbc_columnprivileges — Lists columns and associated privileges for the given table
    • odbc_columns — Lists the column names in specified tables
    • odbc_commit — Commit an ODBC transaction
    • odbc_connect — Connect to a datasource
    • odbc_cursor — Get cursorname
    • odbc_data_source — Returns information about available DSNs
    • odbc_do — 别名 odbc_exec
    • odbc_error — Get the last error code
    • odbc_errormsg — Get the last error message
    • odbc_exec — Directly execute an SQL statement
    • odbc_execute — Execute a prepared statement
    • odbc_fetch_array — Fetch a result row as an associative array
    • odbc_fetch_into — Fetch one result row into array
    • odbc_fetch_object — Fetch a result row as an object
    • odbc_fetch_row — Fetch a row
    • odbc_field_len — Get the length (precision) of a field
    • odbc_field_name — Get the columnname
    • odbc_field_num — Return column number
    • odbc_field_precision — 别名 odbc_field_len
    • odbc_field_scale — Get the scale of a field
    • odbc_field_type — Datatype of a field
    • odbc_foreignkeys — Retrieves a list of foreign keys
    • odbc_free_result — Free resources associated with a result
    • odbc_gettypeinfo — Retrieves information about data types supported by the data source
    • odbc_longreadlen — Handling of LONG columns
    • odbc_next_result — Checks if multiple results are available
    • odbc_num_fields — Number of columns in a result
    • odbc_num_rows — Number of rows in a result
    • odbc_pconnect — Open a persistent database connection
    • odbc_prepare — Prepares a statement for execution
    • odbc_primarykeys — Gets the primary keys for a table
    • odbc_procedurecolumns — Retrieve information about parameters to procedures
    • odbc_procedures — Get the list of procedures stored in a specific data source
    • odbc_result_all — Print result as HTML table
    • odbc_result — Get result data
    • odbc_rollback — Rollback a transaction
    • odbc_setoption — Adjust ODBC settings
    • odbc_specialcolumns — Retrieves special columns
    • odbc_statistics — Retrieve statistics about a table
    • odbc_tableprivileges — Lists tables and the privileges associated with each table
    • odbc_tables — Get the list of table names stored in a specific data source


简介

In addition to normal ODBC support, the Unified ODBC functions in PHP allow you to access several databases that have borrowed the semantics of the ODBC API to implement their own API. Instead of maintaining multiple database drivers that were all nearly identical, these drivers have been unified into a single set of ODBC functions.

The following databases are supported by the Unified ODBC functions: » Adabas D, » IBM DB2, » iODBC, » Solid, and » Sybase SQL Anywhere.

Note:

With the exception of iODBC, there is no ODBC involved when connecting to the above databases. The functions that you use to speak natively to them just happen to share the same names and syntax as the ODBC functions. However, building PHP with iODBC support enables you to use any ODBC-compliant drivers with your PHP applications. More information on iODBC, is available at » www.iodbc.org with the alternative unixODBC available at » www.unixodbc.org.


需求

To access any of the supported databases you need to have the required libraries installed.


安装

--with-adabas[=DIR]

Include Adabas D support. DIR is the Adabas base install directory, defaults to /usr/local.

--with-sapdb[=DIR]

Include SAP DB support. DIR is SAP DB base install directory, defaults to /usr/local.

--with-solid[=DIR]

Include Solid support. DIR is the Solid base install directory, defaults to /usr/local/solid.

--with-ibm-db2[=DIR]

Include IBM DB2 support. DIR is the DB2 base install directory, defaults to /home/db2inst1/sqllib.

--with-empress[=DIR]

Include Empress support. DIR is the Empress base install directory, defaults to $EMPRESSPATH. This option only supports Empress Version 8.60 and above.

--with-empress-bcs[=DIR]

Include "Empress Local Access" support. DIR is the Empress base install directory, defaults to $EMPRESSPATH. This option only supports Empress Version 8.60 and above.

--with-birdstep[=DIR]

Include Birdstep support. DIR is the Birdstep base install directory, defaults to /usr/local/birdstep.

--with-custom-odbc[=DIR]

Include a user defined ODBC support. The DIR is ODBC install base directory, which defaults to /usr/local. Make sure to define CUSTOM_ODBC_LIBS and have some odbc.h in your include dirs. E.g., you should define following for Sybase SQL Anywhere 5.5.00 on QNX, prior to run configure script:

   CPPFLAGS="-DODBC_QNX -DSQLANY_BUG"
   LDFLAGS=-lunix
   CUSTOM_ODBC_LIBS="-ldblib -lodbc".

--with-iodbc[=DIR]

Include iODBC support. DIR is the iODBC base install directory, defaults to /usr/local.

--with-esoob[=DIR]

Include Easysoft OOB support. DIR is the OOB base install directory, defaults to /usr/local/easysoft/oob/client.

--with-unixODBC[=DIR]

Include unixODBC support. DIR is the unixODBC base install directory, defaults to /usr/local.

--with-openlink[=DIR]

Include OpenLink ODBC support. DIR is the OpenLink base install directory, defaults to /usr/local. This is the same as iODBC.

--with-dbmaker[=DIR]

Include DBMaker support. DIR is the DBMaker base install directory, defaults to where the latest version of DBMaker is installed (such as /home/dbmaker/3.6).

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。

As of PHP 7.0.0, however, Windows users must enable php_odbc.dll in order to use this extension.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Unified ODBC Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
odbc.default_db * | NULL | PHP_INI_ALL |
odbc.default_user * | NULL | PHP_INI_ALL |
odbc.default_pw * | NULL | PHP_INI_ALL |
odbc.allow_persistent | "1" | PHP_INI_SYSTEM |
odbc.check_persistent | "1" | PHP_INI_SYSTEM |
odbc.max_persistent | "-1" | PHP_INI_SYSTEM |
odbc.max_links | "-1" | PHP_INI_SYSTEM |
odbc.defaultlrl | "4096" | PHP_INI_ALL |
odbc.defaultbinmode | "1" | PHP_INI_ALL |
odbc.default_cursortype | "3" | PHP_INI_ALL | Available as of PHP 5.3.0

Note: Entries marked with * are not implemented yet.

有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

odbc.default_db string

ODBC data source to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.default_user string

User name to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.default_pw string

Password to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.allow_persistent bool

Whether to allow persistent ODBC connections.

odbc.check_persistent bool

Check that a connection is still valid before reuse.

odbc.max_persistent int

The maximum number of persistent ODBC connections per process.

odbc.max_links int

The maximum number of ODBC connections per process, including persistent connections.

odbc.defaultlrl int

Handling of LONG fields. Specifies the number of bytes returned to variables. See odbc_longreadlen() for details.

当使用 int 时, 其值以字节来衡量。还可以使用在FAQ中描述的速记符。
odbc.defaultbinmode int

Handling of binary data. See odbc_binmode() for details.

odbc.default_cursortype int

Controls the ODBC cursor model. Possible values are SQL_CURSOR_FORWARD_ONLY, SQL_CURSOR_KEYSET_DRIVEN, SQL_CURSOR_DYNAMIC and SQL_CURSOR_STATIC (default).


资源类型

This extension defines two resource types: an ODBC connection identifier and an ODBC result identifier.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

ODBC_TYPE (int)
ODBC_BINMODE_PASSTHRU (int)
ODBC_BINMODE_RETURN (int)
ODBC_BINMODE_CONVERT (int)
SQL_ODBC_CURSORS (int)
SQL_CUR_USE_DRIVER (int)
SQL_CUR_USE_IF_NEEDED (int)
SQL_CUR_USE_ODBC (int)
SQL_CONCURRENCY (int)
SQL_CONCUR_READ_ONLY (int)
SQL_CONCUR_LOCK (int)
SQL_CONCUR_ROWVER (int)
SQL_CONCUR_VALUES (int)
SQL_CURSOR_TYPE (int)
SQL_CURSOR_FORWARD_ONLY (int)
SQL_CURSOR_KEYSET_DRIVEN (int)
SQL_CURSOR_DYNAMIC (int)
SQL_CURSOR_STATIC (int)
SQL_KEYSET_SIZE (int)
SQL_CHAR (int)
SQL_VARCHAR (int)
SQL_LONGVARCHAR (int)
SQL_DECIMAL (int)
SQL_NUMERIC (int)
SQL_BIT (int)
SQL_TINYINT (int)
SQL_SMALLINT (int)
SQL_INTEGER (int)
SQL_BIGINT (int)
SQL_REAL (int)
SQL_FLOAT (int)
SQL_DOUBLE (int)
SQL_BINARY (int)
SQL_VARBINARY (int)
SQL_LONGVARBINARY (int)
SQL_DATE (int)
SQL_TIME (int)
SQL_TIMESTAMP (int)
SQL_TYPE_DATE (int)
SQL_TYPE_TIME (int)
SQL_TYPE_TIMESTAMP (int)
SQL_BEST_ROWID (int)
SQL_ROWVER (int)
SQL_SCOPE_CURROW (int)
SQL_SCOPE_TRANSACTION (int)
SQL_SCOPE_SESSION (int)
SQL_NO_NULLS (int)
SQL_NULLABLE (int)
SQL_INDEX_UNIQUE (int)
SQL_INDEX_ALL (int)
SQL_ENSURE (int)
SQL_QUICK (int)


ODBC 函数

Table of Contents

  • odbc_autocommit — Toggle autocommit behaviour
  • odbc_binmode — Handling of binary column data
  • odbc_close_all — Close all ODBC connections
  • odbc_close — Close an ODBC connection
  • odbc_columnprivileges — Lists columns and associated privileges for the given table
  • odbc_columns — Lists the column names in specified tables
  • odbc_commit — Commit an ODBC transaction
  • odbc_connect — Connect to a datasource
  • odbc_cursor — Get cursorname
  • odbc_data_source — Returns information about available DSNs
  • odbc_do — 别名 odbc_exec
  • odbc_error — Get the last error code
  • odbc_errormsg — Get the last error message
  • odbc_exec — Directly execute an SQL statement
  • odbc_execute — Execute a prepared statement
  • odbc_fetch_array — Fetch a result row as an associative array
  • odbc_fetch_into — Fetch one result row into array
  • odbc_fetch_object — Fetch a result row as an object
  • odbc_fetch_row — Fetch a row
  • odbc_field_len — Get the length (precision) of a field
  • odbc_field_name — Get the columnname
  • odbc_field_num — Return column number
  • odbc_field_precision — 别名 odbc_field_len
  • odbc_field_scale — Get the scale of a field
  • odbc_field_type — Datatype of a field
  • odbc_foreignkeys — Retrieves a list of foreign keys
  • odbc_free_result — Free resources associated with a result
  • odbc_gettypeinfo — Retrieves information about data types supported by the data source
  • odbc_longreadlen — Handling of LONG columns
  • odbc_next_result — Checks if multiple results are available
  • odbc_num_fields — Number of columns in a result
  • odbc_num_rows — Number of rows in a result
  • odbc_pconnect — Open a persistent database connection
  • odbc_prepare — Prepares a statement for execution
  • odbc_primarykeys — Gets the primary keys for a table
  • odbc_procedurecolumns — Retrieve information about parameters to procedures
  • odbc_procedures — Get the list of procedures stored in a specific data source
  • odbc_result_all — Print result as HTML table
  • odbc_result — Get result data
  • odbc_rollback — Rollback a transaction
  • odbc_setoption — Adjust ODBC settings
  • odbc_specialcolumns — Retrieves special columns
  • odbc_statistics — Retrieve statistics about a table
  • odbc_tableprivileges — Lists tables and the privileges associated with each table
  • odbc_tables — Get the list of table names stored in a specific data source


Toggle autocommit behaviour

  • ? ODBC 函数
  • odbc_binmode ?
  • PHP Manual
  • ODBC 函数
  • Toggle autocommit behaviour

odbc_autocommit

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_autocommit — Toggle autocommit behaviour

说明

odbc_autocommit ( resource $odbc , bool $enable = false ) : int|bool

Toggles autocommit behaviour.

By default, auto-commit is on for a connection. Disabling auto-commit is equivalent with starting a transaction.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

enable

If enable is true, auto-commit is enabled, if it is false auto-commit is disabled.

返回值

Without the enable parameter, this function returns auto-commit status for odbc. Non-zero is returned if auto-commit is on, 0 if it is off, or false if an error occurs.

If enable is set, this function returns true on success and false on failure.

参见

  • odbc_commit() - Commit an ODBC transaction
  • odbc_rollback() - Rollback a transaction


Handling of binary column data

  • ? odbc_autocommit
  • odbc_close_all ?
  • PHP Manual
  • ODBC 函数
  • Handling of binary column data

odbc_binmode

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_binmode — Handling of binary column data

说明

odbc_binmode ( resource $statement , int $mode ) : bool

Controls handling of binary column data. ODBC SQL types affected are BINARY, VARBINARY, and LONGVARBINARY. The default mode can be set using the uodbc.defaultbinmode php.ini directive.

When binary SQL data is converted to character C data (ODBC_BINMODE_CONVERT), each byte (8 bits) of source data is represented as two ASCII characters. These characters are the ASCII character representation of the number in its hexadecimal form. For example, a binary 00000001 is converted to "01" and a binary 11111111 is converted to "FF".

While the handling of BINARY and VARBINARY columns only depend on the binmode, the handling of LONGVARBINARY columns also depends on the longreadlen as well:

LONGVARBINARY handling
binmode | longreadlen | result
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_RETURN | 0 | passthru
ODBC_BINMODE_CONVERT | 0 | passthru
ODBC_BINMODE_PASSTHRU | >0 | passthru
ODBC_BINMODE_RETURN | >0 | return as is
ODBC_BINMODE_CONVERT | >0 | return as char

If odbc_fetch_into() is used, passthru means that an empty string is returned for these columns. If odbc_result() is used, passthru means that the data are sent directly to the client (i.e. printed).

参数

statement

The result identifier.

If statement is 0, the settings apply as default for new results.

mode

Possible values for mode are:

  • ODBC_BINMODE_PASSTHRU: Passthru BINARY data
  • ODBC_BINMODE_RETURN: Return as is
  • ODBC_BINMODE_CONVERT: Convert to char and return

Note: Handling of binary long columns is also affected by odbc_longreadlen().

返回值

成功时返回 true， 或者在失败时返回 false。


Close all ODBC connections

  • ? odbc_binmode
  • odbc_close ?
  • PHP Manual
  • ODBC 函数
  • Close all ODBC connections

odbc_close_all

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_close_all — Close all ODBC connections

说明

odbc_close_all ( ) : void

odbc_close_all() will close down all connections to database server(s).

参数

此函数没有参数。

返回值

没有返回值。

注释

Note:

This function will fail if there are open transactions on a connection. This connection will remain open in this case.


Close an ODBC connection

  • ? odbc_close_all
  • odbc_columnprivileges ?
  • PHP Manual
  • ODBC 函数
  • Close an ODBC connection

odbc_close

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_close — Close an ODBC connection

说明

odbc_close ( resource $odbc ) : void

Closes down the connection to the database server.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

返回值

没有返回值。

注释

Note:

This function will fail if there are open transactions on this connection. The connection will remain open in this case.


Lists columns and associated privileges for the given table

  • ? odbc_close
  • odbc_columns ?
  • PHP Manual
  • ODBC 函数
  • Lists columns and associated privileges for the given table

odbc_columnprivileges

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_columnprivileges — Lists columns and associated privileges for the given table

说明

odbc_columnprivileges ( resource $odbc , string|null $catalog , string $schema , string $table , string $column ) : resource|false

Lists columns and associated privileges for the given table.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance). 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

table

The table name. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

column

The column name. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

返回值

Returns an ODBC result identifier 或者在失败时返回 false. This result identifier can be used to fetch a list of columns and associated privileges.

The result set has the following columns:

  • TABLE_CAT
  • TABLE_SCHEM
  • TABLE_NAME
  • COLUMN_NAME
  • GRANTOR
  • GRANTEE
  • PRIVILEGE
  • IS_GRANTABLE
Drivers can report additional columns.

The result set is ordered by TABLE_CAT, TABLE_SCHEM, TABLE_NAME, COLUMN_NAME and PRIVILEGE.

范例

Example #1 List Privileges for a Column

<?php
$conn = odbc_connect($dsn, $user, $pass);
$privileges = odbc_columnprivileges($conn, 'TutorialDB', 'dbo', 'test', 'id');
while (($row = odbc_fetch_array($privileges))) {
    print_r($row);
    break; // further rows omitted for brevity
}
?>

以上例程的输出类似于：

Array
(
    [TABLE_CAT] => TutorialDB
    [TABLE_SCHEM] => dbo
    [TABLE_NAME] => test
    [COLUMN_NAME] => id
    [GRANTOR] => dbo
    [GRANTEE] => dbo
    [PRIVILEGE] => INSERT
    [IS_GRANTABLE] => YES
)


Lists the column names in specified tables

  • ? odbc_columnprivileges
  • odbc_commit ?
  • PHP Manual
  • ODBC 函数
  • Lists the column names in specified tables

odbc_columns

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_columns — Lists the column names in specified tables

说明

odbc_columns ( resource $odbc , string|null $catalog = null , string|null $schema = null , string|null $table = null , string|null $column = null ) : resource|false

Lists all columns in the requested range.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance). 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

table

The table name. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

column

The column name. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

返回值

Returns an ODBC result identifier 或者在失败时返回 false.

The result set has the following columns:

  • TABLE_CAT
  • TABLE_SCHEM
  • TABLE_NAME
  • COLUMN_NAME
  • DATA_TYPE
  • TYPE_NAME
  • COLUMN_SIZE
  • BUFFER_LENGTH
  • DECIMAL_DIGITS
  • NUM_PREC_RADIX
  • NULLABLE
  • REMARKS
  • COLUMN_DEF
  • SQL_DATA_TYPE
  • SQL_DATETIME_SUB
  • CHAR_OCTET_LENGTH
  • ORDINAL_POSITION
  • IS_NULLABLE
Drivers can report additional columns.

The result set is ordered by TABLE_CAT, TABLE_SCHEM, TABLE_NAME and ORDINAL_POSITION.

更新日志

版本 | 说明
8.0.0 | schema, table and column are now nullable.

范例

Example #1 List Columns of a Table

<?php
$conn = odbc_connect($dsn, $user, $pass);
$columns = odbc_columns($conn, 'TutorialDB', 'dbo', 'test', '%');
while (($row = odbc_fetch_array($columns))) {
    print_r($row);
    break; // further rows omitted for brevity
}
?>

以上例程的输出类似于：

Array
(
    [TABLE_CAT] => TutorialDB
    [TABLE_SCHEM] => dbo
    [TABLE_NAME] => TEST
    [COLUMN_NAME] => id
    [DATA_TYPE] => 4
    [TYPE_NAME] => int
    [COLUMN_SIZE] => 10
    [BUFFER_LENGTH] => 4
    [DECIMAL_DIGITS] => 0
    [NUM_PREC_RADIX] => 10
    [NULLABLE] => 0
    [REMARKS] =>
    [COLUMN_DEF] =>
    [SQL_DATA_TYPE] => 4
    [SQL_DATETIME_SUB] =>
    [CHAR_OCTET_LENGTH] =>
    [ORDINAL_POSITION] => 1
    [IS_NULLABLE] => NO
)

参见

  • odbc_columnprivileges() - Lists columns and associated privileges for the given table
  • odbc_procedurecolumns() - Retrieve information about parameters to procedures


Commit an ODBC transaction

  • ? odbc_columns
  • odbc_connect ?
  • PHP Manual
  • ODBC 函数
  • Commit an ODBC transaction

odbc_commit

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_commit — Commit an ODBC transaction

说明

odbc_commit ( resource $odbc ) : bool

Commits all pending transactions on the connection.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

返回值

成功时返回 true， 或者在失败时返回 false。


Connect to a datasource

  • ? odbc_commit
  • odbc_cursor ?
  • PHP Manual
  • ODBC 函数
  • Connect to a datasource

odbc_connect

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_connect — Connect to a datasource

说明

odbc_connect ( string $dsn , string $user , string $password , int $cursor_option = SQL_CUR_USE_DRIVER ) : resource|false

The connection id returned by this functions is needed by other ODBC functions. You can have multiple connections open at once as long as they either use different db or different credentials.

With some ODBC drivers, executing a complex stored procedure may fail with an error similar to: "Cannot open a cursor on a stored procedure that has anything other than a single select statement in it". Using SQL_CUR_USE_ODBC may avoid that error. Also, some drivers don't support the optional row_number parameter in odbc_fetch_row(). SQL_CUR_USE_ODBC might help in that case, too.

参数

dsn

The database source name for the connection. Alternatively, a DSN-less connection string can be used.

user

The username.

password

The password.

cursor_option

This sets the type of cursor to be used for this connection. This parameter is not normally needed, but can be useful for working around problems with some ODBC drivers.

The following constants are defined for cursortype:

  • SQL_CUR_USE_IF_NEEDED
  • SQL_CUR_USE_ODBC
  • SQL_CUR_USE_DRIVER

返回值

Returns an ODBC connection, 或者在失败时返回 false.

范例

Example #1 DSN-less connections

<?php
// Microsoft SQL Server using the SQL Native Client 10.0 ODBC Driver - allows connection to SQL 7, 2000, 2005 and 2008
$connection = odbc_connect("Driver={SQL Server Native Client 10.0};Server=$server;Database=$database;", $user, $password);

// Microsoft Access
$connection = odbc_connect("Driver={Microsoft Access Driver (*.mdb)};Dbq=$mdbFilename", $user, $password);

// Microsoft Excel
$excelFile = realpath('C:/ExcelData.xls');
$excelDir = dirname($excelFile);
$connection = odbc_connect("Driver={Microsoft Excel Driver (*.xls)};DriverId=790;Dbq=$excelFile;DefaultDir=$excelDir" , '', '');
?>

参见

  • For persistent connections: odbc_pconnect() - Open a persistent database connection


Get cursorname

  • ? odbc_connect
  • odbc_data_source ?
  • PHP Manual
  • ODBC 函数
  • Get cursorname

odbc_cursor

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_cursor — Get cursorname

说明

odbc_cursor ( resource $statement ) : string|false

Gets the cursorname for the given result_id.

参数

statement

The result identifier.

返回值

Returns the cursor name, as a string, 或者在失败时返回 false.


Returns information about available DSNs

  • ? odbc_cursor
  • odbc_do ?
  • PHP Manual
  • ODBC 函数
  • Returns information about available DSNs

odbc_data_source

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

odbc_data_source — Returns information about available DSNs

说明

odbc_data_source ( resource $odbc , int $fetch_type ) : array|false

This function will return the list of available DSN (after calling it several times).

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

fetch_type

The fetch_type can be one of two constant types: SQL_FETCH_FIRST, SQL_FETCH_NEXT. Use SQL_FETCH_FIRST the first time this function is called, thereafter use the SQL_FETCH_NEXT.

返回值

Returns false on error, an array upon success, and null after fetching the last available DSN.

范例

Example #1 List available DSNs

<?php
$conn = odbc_connect('dsn', 'user', 'pass');
$dsn_info = odbc_data_source($conn, SQL_FETCH_FIRST);
while ($dsn_info) {
    print_r($dsn_info);
    $dsn_info = odbc_data_source($conn, SQL_FETCH_NEXT);
}
?>

以上例程的输出类似于：

Array
(
    [server] => dsn
    [description] => ODBC Driver 17 for SQL Server
)
Array
(
    [server] => other_dsn
    [description] => Microsoft Access Driver (*.mdb, *.accdb)
)


别名 odbc_exec

  • ? odbc_data_source
  • odbc_error ?
  • PHP Manual
  • ODBC 函数
  • 别名 odbc_exec

odbc_do

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_do — 别名 odbc_exec()

说明

此函数是该函数的别名： odbc_exec().


Get the last error code

  • ? odbc_do
  • odbc_errormsg ?
  • PHP Manual
  • ODBC 函数
  • Get the last error code

odbc_error

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

odbc_error — Get the last error code

说明

odbc_error ( resource|null $odbc = null ) : string

Returns a six-digit ODBC state, or an empty string if there has been no errors.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

返回值

If odbc is specified, the last state of that connection is returned, else the last state of any connection is returned.

This function returns meaningful value only if last odbc query failed (i.e. odbc_exec() returned false).

更新日志

版本 | 说明
8.0.0 | odbc is nullable now.

参见

  • odbc_errormsg() - Get the last error message
  • odbc_exec() - Directly execute an SQL statement


Get the last error message

  • ? odbc_error
  • odbc_exec ?
  • PHP Manual
  • ODBC 函数
  • Get the last error message

odbc_errormsg

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

odbc_errormsg — Get the last error message

说明

odbc_errormsg ( resource|null $odbc = null ) : string

Returns a string containing the last ODBC error message, or an empty string if there has been no errors.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

返回值

If odbc is specified, the last state of that connection is returned, else the last state of any connection is returned.

This function returns meaningful value only if last odbc query failed (i.e. odbc_exec() returned false).

更新日志

版本 | 说明
8.0.0 | odbc is nullable now.

参见

  • odbc_error() - Get the last error code
  • odbc_exec() - Directly execute an SQL statement


Directly execute an SQL statement

  • ? odbc_errormsg
  • odbc_execute ?
  • PHP Manual
  • ODBC 函数
  • Directly execute an SQL statement

odbc_exec

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_exec — Directly execute an SQL statement

说明

odbc_exec ( resource $odbc , string $query ) : resource|false

Sends an SQL statement to the database server.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

query

The SQL statement.

返回值

Returns an ODBC result identifier if the SQL command was executed successfully, or false on error.

更新日志

版本 | 说明
8.0.0 | flags was removed.

参见

  • odbc_prepare() - Prepares a statement for execution
  • odbc_execute() - Execute a prepared statement


Execute a prepared statement

  • ? odbc_exec
  • odbc_fetch_array ?
  • PHP Manual
  • ODBC 函数
  • Execute a prepared statement

odbc_execute

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_execute — Execute a prepared statement

说明

odbc_execute ( resource $statement , array $params = [] ) : bool

Executes a statement prepared with odbc_prepare().

参数

statement

The result id resource, from odbc_prepare().

params

Parameters in params will be substituted for placeholders in the prepared statement in order. Elements of this array will be converted to strings by calling this function.

Any parameters in params which start and end with single quotes will be taken as the name of a file to read and send to the database server as the data for the appropriate placeholder.

If you wish to store a string which actually begins and ends with single quotes, you must add a space or other non-single-quote character to the beginning or end of the parameter, which will prevent the parameter from being taken as a file name. If this is not an option, then you must use another mechanism to store the string, such as executing the query directly with odbc_exec()).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 odbc_execute() and odbc_prepare() example

In the following code, $success will only be true if all three parameters to myproc are IN parameters:

<?php
$a = 1;
$b = 2;
$c = 3;
$stmt    = odbc_prepare($conn, 'CALL myproc(?,?,?)');
$success = odbc_execute($stmt, array($a, $b, $c));
?>

If you need to call a stored procedure using INOUT or OUT parameters, the recommended workaround is to use a native extension for your database (for example, oci8 for Oracle).

参见

  • odbc_prepare() - Prepares a statement for execution


Fetch a result row as an associative array

  • ? odbc_execute
  • odbc_fetch_into ?
  • PHP Manual
  • ODBC 函数
  • Fetch a result row as an associative array

odbc_fetch_array

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

odbc_fetch_array — Fetch a result row as an associative array

说明

odbc_fetch_array ( resource $statement , int $row = -1 ) : array|false

Fetch an associative array from an ODBC query.

参数

statement

The result resource from odbc_exec().

row

Optionally choose which row number to retrieve.

返回值

Returns an array that corresponds to the fetched row, or false if there are no more rows.

注释

Note: This function exists when compiled with DBMaker, IBM DB2 or UnixODBC support.

参见

  • odbc_fetch_row() - Fetch a row
  • odbc_fetch_object() - Fetch a result row as an object
  • odbc_num_rows() - Number of rows in a result


Fetch one result row into array

  • ? odbc_fetch_array
  • odbc_fetch_object ?
  • PHP Manual
  • ODBC 函数
  • Fetch one result row into array

odbc_fetch_into

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_fetch_into — Fetch one result row into array

说明

odbc_fetch_into ( resource $statement , array &$array , int $row = 0 ) : int|false

Fetch one result row into array.

参数

statement

The result resource.

array

The result array that can be of any type since it will be converted to type array. The array will contain the column values starting at array index 0.

row

The row number.

返回值

Returns the number of columns in the result; false on error.

范例

Example #1 odbc_fetch_into() examples

<?php
$rc = odbc_fetch_into($res_id, $my_array);
?>

or

<?php
$rc = odbc_fetch_into($res_id, $my_array, 2);
?>


Fetch a result row as an object

  • ? odbc_fetch_into
  • odbc_fetch_row ?
  • PHP Manual
  • ODBC 函数
  • Fetch a result row as an object

odbc_fetch_object

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

odbc_fetch_object — Fetch a result row as an object

说明

odbc_fetch_object ( resource $statement , int $row = -1 ) : stdClass|false

Fetch an object from an ODBC query.

参数

statement

The result resource from odbc_exec().

row

Optionally choose which row number to retrieve.

返回值

Returns an object that corresponds to the fetched row, or false if there are no more rows.

注释

Note: This function exists when compiled with DBMaker, IBM DB2 or UnixODBC support.

参见

  • odbc_fetch_row() - Fetch a row
  • odbc_fetch_array() - Fetch a result row as an associative array
  • odbc_num_rows() - Number of rows in a result


Fetch a row

  • ? odbc_fetch_object
  • odbc_field_len ?
  • PHP Manual
  • ODBC 函数
  • Fetch a row

odbc_fetch_row

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_fetch_row — Fetch a row

说明

odbc_fetch_row ( resource $statement , int|null $row = null ) : bool

Fetches a row of the data that was returned by odbc_do() or odbc_exec(). After odbc_fetch_row() is called, the fields of that row can be accessed with odbc_result().

参数

statement

The result identifier.

row

If row is not specified, odbc_fetch_row() will try to fetch the next row in the result set. Calls to odbc_fetch_row() with and without row can be mixed.

To step through the result more than once, you can call odbc_fetch_row() with row 1, and then continue doing odbc_fetch_row() without row to review the result. If a driver doesn't support fetching rows by number, the row parameter is ignored.

返回值

Returns true if there was a row, false otherwise.

更新日志

版本 | 说明
8.0.0 | row is nullable now.


Get the length (precision) of a field

  • ? odbc_fetch_row
  • odbc_field_name ?
  • PHP Manual
  • ODBC 函数
  • Get the length (precision) of a field

odbc_field_len

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_len — Get the length (precision) of a field

说明

odbc_field_len ( resource $statement , int $field ) : int|false

Gets the length of the field referenced by number in the given result identifier.

参数

statement

The result identifier.

field

The field number. Field numbering starts at 1.

返回值

Returns the field length, or false on error.

参见

  • odbc_field_scale() - Get the scale of a field to get the scale of a floating point number


Get the columnname

  • ? odbc_field_len
  • odbc_field_num ?
  • PHP Manual
  • ODBC 函数
  • Get the columnname

odbc_field_name

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_name — Get the columnname

说明

odbc_field_name ( resource $statement , int $field ) : string|false

Gets the name of the field occupying the given column number in the given result identifier.

参数

statement

The result identifier.

field

The field number. Field numbering starts at 1.

返回值

Returns the field name as a string, or false on error.


Return column number

  • ? odbc_field_name
  • odbc_field_precision ?
  • PHP Manual
  • ODBC 函数
  • Return column number

odbc_field_num

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_num — Return column number

说明

odbc_field_num ( resource $statement , string $field ) : int|false

Gets the number of the column slot that corresponds to the named field in the given result identifier.

参数

statement

The result identifier.

field

The field name.

返回值

Returns the field number as a integer, or false on error. Field numbering starts at 1.


别名 odbc_field_len

  • ? odbc_field_num
  • odbc_field_scale ?
  • PHP Manual
  • ODBC 函数
  • 别名 odbc_field_len

odbc_field_precision

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_precision — 别名 odbc_field_len()

说明

此函数是该函数的别名： odbc_field_len().

参见

  • odbc_field_scale() - Get the scale of a field to get the scale of a floating point number.


Get the scale of a field

  • ? odbc_field_precision
  • odbc_field_type ?
  • PHP Manual
  • ODBC 函数
  • Get the scale of a field

odbc_field_scale

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_scale — Get the scale of a field

说明

odbc_field_scale ( resource $statement , int $field ) : int|false

Gets the scale of the field referenced by number in the given result identifier.

参数

statement

The result identifier.

field

The field number. Field numbering starts at 1.

返回值

Returns the field scale as a integer, or false on error.


Datatype of a field

  • ? odbc_field_scale
  • odbc_foreignkeys ?
  • PHP Manual
  • ODBC 函数
  • Datatype of a field

odbc_field_type

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_field_type — Datatype of a field

说明

odbc_field_type ( resource $statement , int $field ) : string|false

Gets the SQL type of the field referenced by number in the given result identifier.

参数

statement

The result identifier.

field

The field number. Field numbering starts at 1.

返回值

Returns the field type as a string, or false on error.


Retrieves a list of foreign keys

  • ? odbc_field_type
  • odbc_free_result ?
  • PHP Manual
  • ODBC 函数
  • Retrieves a list of foreign keys

odbc_foreignkeys

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_foreignkeys — Retrieves a list of foreign keys

说明

odbc_foreignkeys ( resource $odbc , string|null $pk_catalog , string $pk_schema , string $pk_table , string $fk_catalog , string $fk_schema , string $fk_table ) : resource|false

Retrieves a list of foreign keys in the specified table or a list of foreign keys in other tables that refer to the primary key in the specified table

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

pk_catalog

The catalog ('qualifier' in ODBC 2 parlance) of the primary key table.

pk_schema

The schema ('owner' in ODBC 2 parlance) of the primary key table.

pk_table

The primary key table.

pk_catalog

The catalog ('qualifier' in ODBC 2 parlance) of the foreign key table.

fk_schema

The schema ('owner' in ODBC 2 parlance) of the foreign key table.

fk_table

The foreign key table.

返回值

Returns an ODBC result identifier 或者在失败时返回 false.

The result set has the following columns:

  • PKTABLE_CAT
  • PKTABLE_SCHEM
  • PKTABLE_NAME
  • PKCOLUMN_NAME
  • FKTABLE_CAT
  • FKTABLE_SCHEM
  • FKTABLE_NAME
  • FKCOLUMN_NAME
  • KEY_SEQ
  • UPDATE_RULE
  • DELETE_RULE
  • FK_NAME
  • PK_NAME
  • DEFERRABILITY
Drivers can report additional columns.

If the foreign keys associated with a primary key are requested, the result set is ordered by FKTABLE_CAT, FKTABLE_SCHEM, FKTABLE_NAME and KEY_SEQ. If the primary keys associated with a foreign key are requested, the result set is ordered by PKTABLE_CAT, PKTABLE_SCHEM, PKTABLE_NAME and KEY_SEQ.

If pk_table contains a table name, odbc_foreignkeys() returns a result set containing the primary key of the specified table and all of the foreign keys that refer to it.

If fk_table contains a table name, odbc_foreignkeys() returns a result set containing all of the foreign keys in the specified table and the primary keys (in other tables) to which they refer.

If both pk_table and fk_table contain table names, odbc_foreignkeys() returns the foreign keys in the table specified in fk_table that refer to the primary key of the table specified in pk_table. This should be one key at most.

参见

  • odbc_tables() - Get the list of table names stored in a specific data source
  • odbc_primarykeys() - Gets the primary keys for a table


Free resources associated with a result

  • ? odbc_foreignkeys
  • odbc_gettypeinfo ?
  • PHP Manual
  • ODBC 函数
  • Free resources associated with a result

odbc_free_result

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_free_result — Free resources associated with a result

说明

odbc_free_result ( resource $statement ) : bool

Free resources associated with a result.

odbc_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script is finished.

参数

statement

The result identifier.

返回值

Always returns true.

注释

Note:

If auto-commit is disabled (see odbc_autocommit()) and you call odbc_free_result() before committing, all pending transactions are rolled back.


Retrieves information about data types supported by the data source

  • ? odbc_free_result
  • odbc_longreadlen ?
  • PHP Manual
  • ODBC 函数
  • Retrieves information about data types supported by the data source

odbc_gettypeinfo

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_gettypeinfo — Retrieves information about data types supported by the data source

说明

odbc_gettypeinfo ( resource $odbc , int $data_type = 0 ) : resource|false

Retrieves information about data types supported by the data source.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

data_type

The data type, which can be used to restrict the information to a single data type.

返回值

Returns an ODBC result identifier or false on failure.

The result set has the following columns:

  • TYPE_NAME
  • DATA_TYPE
  • PRECISION
  • LITERAL_PREFIX
  • LITERAL_SUFFIX
  • CREATE_PARAMS
  • NULLABLE
  • CASE_SENSITIVE
  • SEARCHABLE
  • UNSIGNED_ATTRIBUTE
  • MONEY
  • AUTO_INCREMENT
  • LOCAL_TYPE_NAME
  • MINIMUM_SCALE
  • MAXIMUM_SCALE

The result set is ordered by DATA_TYPE and TYPE_NAME.


Handling of LONG columns

  • ? odbc_gettypeinfo
  • odbc_next_result ?
  • PHP Manual
  • ODBC 函数
  • Handling of LONG columns

odbc_longreadlen

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_longreadlen — Handling of LONG columns

说明

odbc_longreadlen ( resource $statement , int $length ) : bool

Controls handling of LONG, LONGVARCHAR and LONGVARBINARY columns. The default length can be set using the uodbc.defaultlrl php.ini directive.

参数

statement

The result identifier.

length

The number of bytes returned to PHP is controlled by the parameter length. If it is set to 0, long column data is passed through to the client (i.e. printed) when retrieved with odbc_result().

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

Handling of LONGVARBINARY columns is also affected by odbc_binmode().


Checks if multiple results are available

  • ? odbc_longreadlen
  • odbc_num_fields ?
  • PHP Manual
  • ODBC 函数
  • Checks if multiple results are available

odbc_next_result

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

odbc_next_result — Checks if multiple results are available

说明

odbc_next_result ( resource $statement ) : bool

Checks if there are more result sets available as well as allowing access to the next result set via odbc_fetch_array(), odbc_fetch_row(), odbc_result(), etc.

参数

statement

The result identifier.

返回值

Returns true if there are more result sets, false otherwise.

范例

Example #1 odbc_next_result()

<?php
$r_Connection = odbc_connect($dsn, $username, $password);

$s_SQL = <<<END_SQL
SELECT 'A'
SELECT 'B'
SELECT 'C'
END_SQL;

$r_Results = odbc_exec($r_Connection, $s_SQL);

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump first result set";
var_dump($a_Row1, $a_Row2);

echo "Get second results set ";
var_dump(odbc_next_result($r_Results));

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump second result set ";
var_dump($a_Row1, $a_Row2);

echo "Get third results set ";
var_dump(odbc_next_result($r_Results));

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump third result set ";
var_dump($a_Row1, $a_Row2);

echo "Try for a fourth result set ";
var_dump(odbc_next_result($r_Results));
?>

以上例程会输出：

Dump first result set array(1) {
  ["A"]=>
  string(1) "A"
}
bool(false)
Get second results set bool(true)
Dump second result set array(1) {
  ["B"]=>
  string(1) "B"
}
bool(false)
Get third results set bool(true)
Dump third result set array(1) {
  ["C"]=>
  string(1) "C"
}
bool(false)
Try for a fourth result set bool(false)


Number of columns in a result

  • ? odbc_next_result
  • odbc_num_rows ?
  • PHP Manual
  • ODBC 函数
  • Number of columns in a result

odbc_num_fields

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_num_fields — Number of columns in a result

说明

odbc_num_fields ( resource $statement ) : int

Gets the number of fields (columns) in an ODBC result.

参数

statement

The result identifier returned by odbc_exec().

返回值

Returns the number of fields, or -1 on error.


Number of rows in a result

  • ? odbc_num_fields
  • odbc_pconnect ?
  • PHP Manual
  • ODBC 函数
  • Number of rows in a result

odbc_num_rows

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_num_rows — Number of rows in a result

说明

odbc_num_rows ( resource $statement ) : int

Gets the number of rows in a result. For INSERT, UPDATE and DELETE statements odbc_num_rows() returns the number of rows affected. For a SELECT clause this can be the number of rows available.

参数

statement

The result identifier returned by odbc_exec().

返回值

Returns the number of rows in an ODBC result. This function will return -1 on error.

注释

Note:

Using odbc_num_rows() to determine the number of rows available after a SELECT will return -1 with many drivers.


Open a persistent database connection

  • ? odbc_num_rows
  • odbc_prepare ?
  • PHP Manual
  • ODBC 函数
  • Open a persistent database connection

odbc_pconnect

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_pconnect — Open a persistent database connection

说明

odbc_pconnect ( string $dsn , string $user , string $password , int $cursor_option = SQL_CUR_USE_DRIVER ) : resource|false

Opens a persistent database connection.

This function is much like odbc_connect(), except that the connection is not really closed when the script has finished. Future requests for a connection with the same dsn, user, password combination (via odbc_connect() and odbc_pconnect()) can reuse the persistent connection.

参数

See odbc_connect() for details.

返回值

Returns an ODBC connection, 或者在失败时返回 false. error.

注释

Note: Persistent connections have no effect if PHP is used as a CGI program.

参见

  • odbc_connect() - Connect to a datasource
  • Persistent Database Connections


Prepares a statement for execution

  • ? odbc_pconnect
  • odbc_primarykeys ?
  • PHP Manual
  • ODBC 函数
  • Prepares a statement for execution

odbc_prepare

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_prepare — Prepares a statement for execution

说明

odbc_prepare ( resource $odbc , string $query ) : resource|false

Prepares a statement for execution. The result identifier can be used later to execute the statement with odbc_execute().

Some databases (such as IBM DB2, MS SQL Server, and Oracle) support stored procedures that accept parameters of type IN, INOUT, and OUT as defined by the ODBC specification. However, the Unified ODBC driver currently only supports parameters of type IN to stored procedures.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

query

The query string statement being prepared.

返回值

Returns an ODBC result identifier if the SQL command was prepared successfully. Returns false on error.

范例

Example #1 odbc_execute() and odbc_prepare() example

In the following code, $success will only be true if all three parameters to myproc are IN parameters:

<?php
$a = 1;
$b = 2;
$c = 3;
$stmt    = odbc_prepare($conn, 'CALL myproc(?,?,?)');
$success = odbc_execute($stmt, array($a, $b, $c));
?>

If you need to call a stored procedure using INOUT or OUT parameters, the recommended workaround is to use a native extension for your database (for example, oci8 for Oracle).

参见

  • odbc_execute() - Execute a prepared statement


Gets the primary keys for a table

  • ? odbc_prepare
  • odbc_procedurecolumns ?
  • PHP Manual
  • ODBC 函数
  • Gets the primary keys for a table

odbc_primarykeys

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_primarykeys — Gets the primary keys for a table

说明

odbc_primarykeys ( resource $odbc , string|null $catalog , string $schema , string $table ) : resource|false

Returns a result identifier that can be used to fetch the column names that comprise the primary key for a table.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance).

table

返回值

Returns an ODBC result identifier 或者在失败时返回 false.

The result set has the following columns:

  • TABLE_CAT
  • TABLE_SCHEM
  • TABLE_NAME
  • COLUMN_NAME
  • KEY_SEQ
  • PK_NAME
Drivers can report additional columns.

The result set is ordered by TABLE_CAT, TABLE_SCHEM, TABLE_NAME and KEY_SEQ.

范例

Example #1 List primary Keys of a Column

<?php
$conn = odbc_connect($dsn, $user, $pass);
$primarykeys = odbc_primarykeys($conn, 'TutorialDB', 'dbo', 'TEST');
while (($row = odbc_fetch_array($primarykeys))) {
    print_r($row);
    break; // further rows omitted for brevity
}
?>

以上例程的输出类似于：

Array
(
    [TABLE_CAT] => TutorialDB
    [TABLE_SCHEM] => dbo
    [TABLE_NAME] => TEST
    [COLUMN_NAME] => id
    [KEY_SEQ] => 1
    [PK_NAME] => PK__TEST__3213E83FE141F843
)

参见

  • odbc_tables() - Get the list of table names stored in a specific data source
  • odbc_foreignkeys() - Retrieves a list of foreign keys


Retrieve information about parameters to procedures

  • ? odbc_primarykeys
  • odbc_procedures ?
  • PHP Manual
  • ODBC 函数
  • Retrieve information about parameters to procedures

odbc_procedurecolumns

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_procedurecolumns — Retrieve information about parameters to procedures

说明

odbc_procedurecolumns ( resource $odbc , string|null $catalog = null , string|null $schema = null , string|null $procedure = null , string|null $column = null ) : resource|false

Retrieve information about parameters to procedures.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance). 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

procedure

The proc. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

column

The column. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

返回值

Returns the list of input and output parameters, as well as the columns that make up the result set for the specified procedures. Returns an ODBC result identifier 或者在失败时返回 false.

The result set has the following columns:

  • PROCEDURE_CAT
  • PROCEDURE_SCHEM
  • PROCEDURE_NAME
  • COLUMN_NAME
  • COLUMN_TYPE
  • DATA_TYPE
  • TYPE_NAME
  • COLUMN_SIZE
  • BUFFER_LENGTH
  • DECIMAL_DIGITS
  • NUM_PREC_RADIX
  • NULLABLE
  • REMARKS
  • COLUMN_DEF
  • SQL_DATA_TYPE
  • SQL_DATETIME_SUB
  • CHAR_OCTET_LENGTH
  • ORDINAL_POSITION
  • IS_NULLABLE
Drivers can report additional columns.

The result set is ordered by PROCEDURE_CAT, PROCEDURE_SCHEM, PROCEDURE_NAME and COLUMN_TYPE.

更新日志

版本 | 说明
8.0.0 | Prior to this version, the function could only be called with either one or five arguments.

范例

Example #1 List Columns of a stored Procedure

<?php
$conn = odbc_connect($dsn, $user, $pass);
$columns = odbc_procedurecolumns($conn, 'TutorialDB', 'dbo', 'GetEmployeeSalesYTD;1', '%');
while (($row = odbc_fetch_array($columns))) {
    print_r($row);
    break; // further rows omitted for brevity
}
?>

以上例程的输出类似于：

Array
(
    [PROCEDURE_CAT] => TutorialDB
    [PROCEDURE_SCHEM] => dbo
    [PROCEDURE_NAME] => GetEmployeeSalesYTD;1
    [COLUMN_NAME] => @SalesPerson
    [COLUMN_TYPE] => 1
    [DATA_TYPE] => -9
    [TYPE_NAME] => nvarchar
    [COLUMN_SIZE] => 50
    [BUFFER_LENGTH] => 100
    [DECIMAL_DIGITS] =>
    [NUM_PREC_RADIX] =>
    [NULLABLE] => 1
    [REMARKS] =>
    [COLUMN_DEF] =>
    [SQL_DATA_TYPE] => -9
    [SQL_DATETIME_SUB] =>
    [CHAR_OCTET_LENGTH] => 100
    [ORDINAL_POSITION] => 1
    [IS_NULLABLE] => YES
)

参见

  • odbc_columns() - Lists the column names in specified tables


Get the list of procedures stored in a specific data source

  • ? odbc_procedurecolumns
  • odbc_result_all ?
  • PHP Manual
  • ODBC 函数
  • Get the list of procedures stored in a specific data source

odbc_procedures

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_procedures — Get the list of procedures stored in a specific data source

说明

odbc_procedures ( resource $odbc , string|null $catalog = null , string|null $schema = null , string|null $procedure = null ) : resource|false

Lists all procedures in the requested range.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance). 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

procedure

The name. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

返回值

Returns an ODBC result identifier containing the information 或者在失败时返回 false.

The result set has the following columns:

  • PROCEDURE_CAT
  • PROCEDURE_SCHEM
  • PROCEDURE_NAME
  • NUM_INPUT_PARAMS
  • NUM_OUTPUT_PARAMS
  • NUM_RESULT_SETS
  • REMARKS
  • PROCEDURE_TYPE
Drivers can report additional columns.

The result set is ordered by PROCEDURE_CAT, PROCEDURE_SCHEMA and PROCEDURE_NAME.

更新日志

版本 | 说明
8.0.0 | Prior to this version, the function could only be called with either one or four arguments.

范例

Example #1 List stored Procedures of a Database

<?php
$conn = odbc_connect($dsn, $user, $pass);
$procedures = odbc_procedures($conn, $catalog, $schema, '%');
while (($row = odbc_fetch_array($procedures))) {
    print_r($row);
    break; // further rows omitted for brevity
}
?>

以上例程的输出类似于：

Array
(
    [PROCEDURE_CAT] => TutorialDB
    [PROCEDURE_SCHEM] => dbo
    [PROCEDURE_NAME] => GetEmployeeSalesYTD;1
    [NUM_INPUT_PARAMS] => -1
    [NUM_OUTPUT_PARAMS] => -1
    [NUM_RESULT_SETS] => -1
    [REMARKS] =>
    [PROCEDURE_TYPE] => 2
)

参见

  • odbc_procedurecolumns() - Retrieve information about parameters to procedures
  • odbc_tables() - Get the list of table names stored in a specific data source


Print result as HTML table

  • ? odbc_procedures
  • odbc_result ?
  • PHP Manual
  • ODBC 函数
  • Print result as HTML table

odbc_result_all

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_result_all — Print result as HTML table

说明

odbc_result_all ( resource $statement , string $format = "" ) : int|false

Prints all rows from a result identifier produced by odbc_exec(). The result is printed in HTML table format. The data is not escaped.

This function is not supposed to be used in production environments; it is merely meant for development purposes, to get a result set quickly rendered.

参数

statement

The result identifier.

format

Additional overall table formatting.

返回值

Returns the number of rows in the result or false on error.


Get result data

  • ? odbc_result_all
  • odbc_rollback ?
  • PHP Manual
  • ODBC 函数
  • Get result data

odbc_result

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_result — Get result data

说明

odbc_result ( resource $statement , string|int $field ) : string|bool|null

Get result data

参数

statement

The ODBC resource.

field

The field name being retrieved. It can either be an integer containing the column number of the field you want; or it can be a string containing the name of the field.

返回值

Returns the string contents of the field, false on error, null for NULL data, or true for binary data.

范例

The first call to odbc_result() returns the value of the third field in the current record of the query result. The second function call to odbc_result() returns the value of the field whose field name is "val" in the current record of the query result. An error occurs if a column number parameter for a field is less than one or exceeds the number of columns (or fields) in the current record. Similarly, an error occurs if a field with a name that is not one of the fieldnames of the table(s) that is(are) being queried.

Example #1 odbc_result() examples

<?php
$item_3   = odbc_result($Query_ID, 3);
$item_val = odbc_result($Query_ID, "val");
?>

注释

Field indices start from 1. Regarding the way binary or long column data is returned refer to odbc_binmode() and odbc_longreadlen().


Rollback a transaction

  • ? odbc_result
  • odbc_setoption ?
  • PHP Manual
  • ODBC 函数
  • Rollback a transaction

odbc_rollback

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_rollback — Rollback a transaction

说明

odbc_rollback ( resource $odbc ) : bool

Rolls back all pending statements on the connection.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

返回值

成功时返回 true， 或者在失败时返回 false。


Adjust ODBC settings

  • ? odbc_rollback
  • odbc_specialcolumns ?
  • PHP Manual
  • ODBC 函数
  • Adjust ODBC settings

odbc_setoption

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_setoption — Adjust ODBC settings

说明

odbc_setoption ( resource $odbc , int $which , int $option , int $value ) : bool

This function allows fiddling with the ODBC options for a particular connection or query result. It was written to help find work around to problems in quirky ODBC drivers. You should probably only use this function if you are an ODBC programmer and understand the effects the various options will have. You will certainly need a good ODBC reference to explain all the different options and values that can be used. Different driver versions support different options.

Because the effects may vary depending on the ODBC driver, use of this function in scripts to be made publicly available is strongly discouraged. Also, some ODBC options are not available to this function because they must be set before the connection is established or the query is prepared. However, if on a particular job it can make PHP work so your boss doesn't tell you to use a commercial product, that's all that really matters.

参数

odbc

Is a connection id or result id on which to change the settings. For SQLSetConnectOption(), this is a connection id. For SQLSetStmtOption(), this is a result id.

which

Is the ODBC function to use. The value should be 1 for SQLSetConnectOption() and 2 for SQLSetStmtOption().

option

The option to set.

value

The value for the given option.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 odbc_setoption() examples

<?php
// 1. Option 102 of SQLSetConnectOption() is SQL_AUTOCOMMIT.
//    Value 1 of SQL_AUTOCOMMIT is SQL_AUTOCOMMIT_ON.
//    This example has the same effect as
//    odbc_autocommit($conn, true);

odbc_setoption($conn, 1, 102, 1);

// 2. Option 0 of SQLSetStmtOption() is SQL_QUERY_TIMEOUT.
//    This example sets the query to timeout after 30 seconds.

$result = odbc_prepare($conn, $sql);
odbc_setoption($result, 2, 0, 30);
odbc_execute($result);
?>


Retrieves special columns

  • ? odbc_setoption
  • odbc_statistics ?
  • PHP Manual
  • ODBC 函数
  • Retrieves special columns

odbc_specialcolumns

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_specialcolumns — Retrieves special columns

说明

odbc_specialcolumns ( resource $odbc , int $type , string|null $catalog , string $schema , string $table , int $scope , int $nullable ) : resource|false

Retrieves either the optimal set of columns that uniquely identifies a row in the table, or columns that are automatically updated when any value in the row is updated by a transaction.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

type
When the type argument is SQL_BEST_ROWID, odbc_specialcolumns() returns the column or columns that uniquely identify each row in the table. When the type argument is SQL_ROWVER, odbc_specialcolumns() returns the column or columns in the specified table, if any, that are automatically updated by the data source when any value in the row is updated by any transaction.
catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance).

table

The table.

scope

The scope, which orders the result set. One of SQL_SCOPE_CURROW, SQL_SCOPE_TRANSACTION or SQL_SCOPE_SESSION.

nullable

Determines whether to return special columns that can have a NULL value. One of SQL_NO_NULLS or SQL_NULLABLE .

返回值

Returns an ODBC result identifier or false on failure.

The result set has the following columns:

  • SCOPE
  • COLUMN_NAME
  • DATA_TYPE
  • TYPE_NAME
  • COLUMN_SIZE
  • BUFFER_LENGTH
  • DECIMAL_DIGITS
  • PSEUDO_COLUMN
Drivers can report additional columns.

The result set is ordered by SCOPE.

参见

  • odbc_tables() - Get the list of table names stored in a specific data source


Retrieve statistics about a table

  • ? odbc_specialcolumns
  • odbc_tableprivileges ?
  • PHP Manual
  • ODBC 函数
  • Retrieve statistics about a table

odbc_statistics

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_statistics — Retrieve statistics about a table

说明

odbc_statistics ( resource $odbc , string|null $catalog , string $schema , string $table , int $unique , int $accuracy ) : resource|false

Get statistics about a table and its indexes.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance).

table

The table name.

unique

The type of the index. One of SQL_INDEX_UNIQUE or SQL_INDEX_ALL.

accuracy

One of SQL_ENSURE or SQL_QUICK. The latter requests that the driver retrieve the CARDINALITY and PAGES only if they are readily available from the server.

返回值

Returns an ODBC result identifier 或者在失败时返回 false.

The result set has the following columns:

  • TABLE_CAT
  • TABLE_SCHEM
  • TABLE_NAME
  • NON_UNIQUE
  • INDEX_QUALIFIER
  • INDEX_NAME
  • TYPE
  • ORDINAL_POSITION
  • COLUMN_NAME
  • ASC_OR_DESC
  • CARDINALITY
  • PAGES
  • FILTER_CONDITION
Drivers can report additional columns.

The result set is ordered by NON_UNIQUE, TYPE, INDEX_QUALIFIER, INDEX_NAME and ORDINAL_POSITION.

范例

Example #1 List Statistics of a Table

<?php
$conn = odbc_connect($dsn, $user, $pass);
$statistics = odbc_statistics($conn, 'TutorialDB', 'dbo', 'TEST', SQL_INDEX_UNIQUE, SQL_QUICK);
while (($row = odbc_fetch_array($statistics))) {
    print_r($row);
    break; // further rows omitted for brevity
}
?>

以上例程的输出类似于：

Array
(
    [TABLE_CAT] => TutorialDB
    [TABLE_SCHEM] => dbo
    [TABLE_NAME] => TEST
    [NON_UNIQUE] =>
    [INDEX_QUALIFIER] =>
    [INDEX_NAME] =>
    [TYPE] => 0
    [ORDINAL_POSITION] =>
    [COLUMN_NAME] =>
    [ASC_OR_DESC] =>
    [CARDINALITY] => 15
    [PAGES] => 3
    [FILTER_CONDITION] =>
)

参见

  • odbc_tables() - Get the list of table names stored in a specific data source


Lists tables and the privileges associated with each table

  • ? odbc_statistics
  • odbc_tables ?
  • PHP Manual
  • ODBC 函数
  • Lists tables and the privileges associated with each table

odbc_tableprivileges

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_tableprivileges — Lists tables and the privileges associated with each table

说明

odbc_tableprivileges ( resource $odbc , string|null $catalog , string $schema , string $table ) : resource|false

Lists tables in the requested range and the privileges associated with each table.

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance). 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

table

The name. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

返回值

An ODBC result identifier 或者在失败时返回 false.

The result set has the following columns:

  • TABLE_CAT
  • TABLE_SCHEM
  • TABLE_NAME
  • GRANTOR
  • GRANTEE
  • PRIVILEGE
  • IS_GRANTABLE
Drivers can report additional columns.

The result set is ordered by TABLE_CAT, TABLE_SCHEM, TABLE_NAME, PRIVILEGE and GRANTEE.

范例

Example #1 List Privileges of a Table

<?php
$conn = odbc_connect($dsn, $user, $pass);
$privileges = odbc_tableprivileges($conn, 'SalesOrders', 'dbo', 'Orders');
while (($row = odbc_fetch_array($privileges))) {
    print_r($row);
    break; // further rows omitted for brevity
}
?>

以上例程的输出类似于：

Array
(
    [TABLE_CAT] => SalesOrders
    [TABLE_SCHEM] => dbo
    [TABLE_NAME] => Orders
    [GRANTOR] => dbo
    [GRANTEE] => dbo
    [PRIVILEGE] => DELETE
    [IS_GRANTABLE] => YES
)

参见

  • odbc_tables() - Get the list of table names stored in a specific data source


Get the list of table names stored in a specific data source

  • ? odbc_tableprivileges
  • PDO ?
  • PHP Manual
  • ODBC 函数
  • Get the list of table names stored in a specific data source

odbc_tables

(PHP 4, PHP 5, PHP 7, PHP 8)

odbc_tables — Get the list of table names stored in a specific data source

说明

odbc_tables ( resource $odbc , string|null $catalog = null , string|null $schema = null , string|null $table = null , string|null $types = null ) : resource|false

Lists all tables in the requested range.

To support enumeration of qualifiers, owners, and table types, the following special semantics for the catalog, schema, table, and table_type are available:

  • If catalog is a single percent character (%) and schema and table are empty strings, then the result set contains a list of valid qualifiers for the data source. (All columns except the TABLE_QUALIFIER column contain NULLs.)
  • If schema is a single percent character (%) and catalog and table are empty strings, then the result set contains a list of valid owners for the data source. (All columns except the TABLE_OWNER column contain NULLs.)
  • If table_type is a single percent character (%) and catalog, schema and table are empty strings, then the result set contains a list of valid table types for the data source. (All columns except the TABLE_TYPE column contain NULLs.)

参数

odbc

ODBC 连接标识符，详见 odbc_connect()。

catalog

The catalog ('qualifier' in ODBC 2 parlance).

schema

The schema ('owner' in ODBC 2 parlance). 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

table

The name. 此参数接受下列查询模式： % 来匹配零到多个字符， _ 来匹配单个字符。

types

If table_type is not an empty string, it must contain a list of comma-separated values for the types of interest; each value may be enclosed in single quotes (') or unquoted. For example, 'TABLE','VIEW' or TABLE, VIEW. If the data source does not support a specified table type, odbc_tables() does not return any results for that type.

返回值

Returns an ODBC result identifier containing the information 或者在失败时返回 false.

The result set has the following columns:

  • TABLE_CAT
  • TABLE_SCHEM
  • TABLE_NAME
  • TABLE_TYPE
  • REMARKS
Drivers can report additional columns.

The result set is ordered by TABLE_TYPE, TABLE_CAT, TABLE_SCHEM and TABLE_NAME.

更新日志

版本 | 说明
8.0.0 | schema, table and types are now nullable.

范例

Example #1 List Tables in a Catalog

<?php
$conn = odbc_connect($dsn, $user, $pass);
$tables = odbc_tables($conn, 'SalesOrders', 'dbo', '%', 'TABLE');
while (($row = odbc_fetch_array($tables))) {
    print_r($row);
    break; // further rows omitted for brevity
}
?>

以上例程的输出类似于：

Array
(
    [TABLE_CAT] => SalesOrders
    [TABLE_SCHEM] => dbo
    [TABLE_NAME] => Orders
    [TABLE_TYPE] => TABLE
    [REMARKS] =>
)

参见

  • odbc_tableprivileges() - Lists tables and the privileges associated with each table
  • odbc_columns() - Lists the column names in specified tables
  • odbc_specialcolumns() - Retrieves special columns
  • odbc_statistics() - Retrieve statistics about a table
  • odbc_procedures() - Get the list of procedures stored in a specific data source


PHP 数据对象

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 连接与连接管理
  • 事务与自动提交
  • 预处理语句与存储过程
  • 错误与错误处理
  • 大对象 (LOBs)
  • PDO — PDO 类
    • PDO::beginTransaction — 启动一个事务
    • PDO::commit — 提交一个事务
    • PDO::__construct — 创建一个表示数据库连接的 PDO 实例
    • PDO::errorCode — 获取跟数据库句柄上一次操作相关的 SQLSTATE
    • PDO::errorInfo — Fetch extended error information associated with the last operation on the database handle
    • PDO::exec — 执行一条 SQL 语句，并返回受影响的行数
    • PDO::getAttribute — 取回一个数据库连接的属性
    • PDO::getAvailableDrivers — 返回一个可用驱动的数组
    • PDO::inTransaction — 检查是否在一个事务内
    • PDO::lastInsertId — 返回最后插入行的ID或序列值
    • PDO::prepare — 准备要执行的语句，并返回语句对象
    • PDO::query — 执行 SQL 语句，以 PDOStatement 对象形式返回结果集
    • PDO::quote — 为 SQL 查询里的字符串添加引号
    • PDO::rollBack — 回滚一个事务
    • PDO::setAttribute — 设置属性
  • PDOStatement — PDOStatement 类
    • PDOStatement::bindColumn — 绑定一列到一个 PHP 变量
    • PDOStatement::bindParam — 绑定一个参数到指定的变量名
    • PDOStatement::bindValue — 把一个值绑定到一个参数
    • PDOStatement::closeCursor — 关闭游标，使语句能再次被执行。
    • PDOStatement::columnCount — 返回结果集中的列数
    • PDOStatement::debugDumpParams — 打印一条 SQL 预处理命令
    • PDOStatement::errorCode — 获取跟上一次语句句柄操作相关的 SQLSTATE
    • PDOStatement::errorInfo — 获取跟上一次语句句柄操作相关的扩展错误信息
    • PDOStatement::execute — 执行一条预处理语句
    • PDOStatement::fetch — 从结果集中获取下一行
    • PDOStatement::fetchAll — 返回一个包含结果集中所有行的数组
    • PDOStatement::fetchColumn — 从结果集中的下一行返回单独的一列。
    • PDOStatement::fetchObject — 获取下一行并作为一个对象返回。
    • PDOStatement::getAttribute — 检索一个语句属性
    • PDOStatement::getColumnMeta — 返回结果集中一列的元数据
    • PDOStatement::nextRowset — 在一个多行集语句句柄中推进到下一个行集
    • PDOStatement::rowCount — 返回受上一个 SQL 语句影响的行数
    • PDOStatement::setAttribute — 设置一个语句属性
    • PDOStatement::setFetchMode — 为语句设置默认的获取模式。
  • PDOException — PDOException 异常类
  • PDO 驱动
    • CUBRID (PDO) — CUBRID Functions (PDO_CUBRID)
    • MS SQL Server (PDO) — Microsoft SQL Server and Sybase Functions (PDO_DBLIB)
    • Firebird (PDO) — Firebird Functions (PDO_FIREBIRD)
    • IBM (PDO) — IBM Functions (PDO_IBM)
    • Informix (PDO) — Informix Functions (PDO_INFORMIX)
    • MySQL (PDO) — MySQL Functions (PDO_MYSQL)
    • MS SQL Server (PDO) — Microsoft SQL Server Functions (PDO_SQLSRV)
    • Oracle (PDO) — Oracle Functions (PDO_OCI)
    • ODBC and DB2 (PDO) — ODBC and DB2 Functions (PDO_ODBC)
    • PostgreSQL (PDO) — PostgreSQL Functions (PDO_PGSQL)
    • SQLite (PDO) — SQLite Functions (PDO_SQLITE)


简介

PHP 数据对象 （PDO） 扩展为PHP访问数据库定义了一个轻量级的一致接口。实现 PDO 接口的每个数据库驱动可以公开具体数据库的特性作为标准扩展功能。 注意利用 PDO 扩展自身并不能实现任何数据库功能；必须使用一个 具体数据库的 PDO 驱动 来访问数据库服务。

PDO 提供了一个 数据访问 抽象层，这意味着，不管使用哪种数据库，都可以用相同的函数（方法）来查询和获取数据。 PDO 不提供 数据库 抽象层；它不会重写 SQL，也不会模拟缺失的特性。如果需要的话，应该使用一个成熟的抽象层。

从 PHP 5.1 开始附带了 PDO，在 PHP 5.0 中是作为一个 PECL 扩展使用。 PDO 需要PHP 5 核心的新 OO 特性，因此不能在较早版本的 PHP 上运行。


安装

在 Unix 系统上安装 PDO

  1. 自 PHP 5.1.0 起，PDO 和 PDO_SQLITE 驱动默认可用。对于自己选择的数据库，需要启用相应的 POD 驱动； 查阅 特定数据库的 PDO 驱动 文档获取更多此内容。

    Note:

    当以共享扩展（不推荐）构建 PDO 时，所有 PDO 驱动 必须 在 PDO 自身 之后 加载。

  2. 当作为一个共享模块安装 PDO 时，需要更新 php.ini 文件以便当 PHP 运行时 PDO 扩展能被自动加载。还需要在那里启用具体的数据库驱动；确保它们被列在 pdo.so 那一行之后，因为 PDO 必须在具体的 数据库扩展被载入前初始化。如果静态地构建 PDO 和 具体数据库扩展，可以跳过此步。

    extension=pdo.so

Windows 用户

  1. PDO 和所有主要的驱动作为共享扩展随 PHP 一起发布，要激活它们只需简单地编辑 php.ini 文件：

    extension=php_pdo.dll

    Note:

    这一步在 PHP 5.3及更高版本中不是必须的，对于 PDO 不再需要做为一个 DLL 文件。

  2. 下一步，选择其他具体数据库的 DLL 文件，然后要么在运行时用 dl() 载入，要么在 php.ini 中的 php_pdo.dll 后面启用。例如：

    extension=php_pdo.dll
extension=php_pdo_firebird.dll
extension=php_pdo_informix.dll
extension=php_pdo_mssql.dll
extension=php_pdo_mysql.dll
extension=php_pdo_oci.dll
extension=php_pdo_oci8.dll
extension=php_pdo_odbc.dll
extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll

    那些 DLL 文件应该在系统的extension_dir 中存在。

Note:

记住：更改 php.ini 文件后需要重启 PHP 服务才能使新的配置指令生效。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

PDO 配置选项
名字 | 默认 | 可修改范围 | 更新日志
pdo.dsn.* |  | 仅 php.ini |

这是配置指令的简短说明。

pdo.dsn.* string

定义 DSN 别名。 参见 PDO::__construct() 详细说明。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Warning

自 PHP 5.1 起，开始使用类常量。以前的版本使用类似 PDO_PARAM_BOOL 这样的全局常量。

PDO::PARAM_BOOL (integer)
表示布尔数据类型。
PDO::PARAM_NULL (integer)
表示 SQL 中的 NULL 数据类型。
PDO::PARAM_INT (integer)
表示 SQL 中的整型。
PDO::PARAM_STR (integer)
表示 SQL 中的 CHAR、VARCHAR 或其他字符串类型。
PDO::PARAM_STR_NATL (integer)
标记了字符使用的是国家字符集（national character set）。 自 PHP 7.2.0 起。
PDO::PARAM_STR_CHAR (integer)
标记了字符使用的是常规字符集（regular character set）。 自 PHP 7.2.0 起。
PDO::PARAM_LOB (integer)
表示 SQL 中大对象数据类型。
PDO::PARAM_STMT (integer)
表示一个记录集类型。当前尚未被任何驱动支持。
PDO::PARAM_INPUT_OUTPUT (integer)
指定参数为一个存储过程的 INOUT 参数。必须用一个明确的 PDO::PARAM_* 数据类型跟此值进行按位或。
PDO::FETCH_LAZY (integer)
指定获取方式，将结果集中的每一行作为一个对象返回，此对象的变量名对应着列名。PDO::FETCH_LAZY 创建用来访问的对象变量名。在 PDOStatement::fetchAll() 中无效。
PDO::FETCH_ASSOC (integer)
指定获取方式，将对应结果集中的每一行作为一个由列名索引的数组返回。如果结果集中包含多个名称相同的列，则PDO::FETCH_ASSOC每个列名只返回一个值。
PDO::FETCH_NAMED (integer)
指定获取方式，将对应结果集中的每一行作为一个由列名索引的数组返回。如果结果集中包含多个名称相同的列，则PDO::FETCH_ASSOC每个列名 返回一个包含值的数组。
PDO::FETCH_NUM (integer)
指定获取方式，将对应结果集中的每一行作为一个由列号索引的数组返回，从第 0 列开始。
PDO::FETCH_BOTH (integer)
指定获取方式，将对应结果集中的每一行作为一个由列号和列名索引的数组返回，从第 0 列开始。
PDO::FETCH_OBJ (integer)
指定获取方式，将结果集中的每一行作为一个属性名对应列名的对象返回。
PDO::FETCH_BOUND (integer)
指定获取方式，返回 TRUE 且将结果集中的列值分配给通过 PDOStatement::bindParam() 或 PDOStatement::bindColumn() 方法绑定的 PHP 变量。
PDO::FETCH_COLUMN (integer)
指定获取方式，从结果集中的下一行返回所需要的那一列。
PDO::FETCH_CLASS (integer)
指定获取方式，返回一个所请求类的新实例，映射列到类中对应的属性名。

Note: 如果所请求的类中不存在该属性，则调用 __set() 魔术方法

PDO::FETCH_INTO (integer)
指定获取方式，更新一个请求类的现有实例，映射列到类中对应的属性名。
PDO::FETCH_FUNC (integer)
允许在运行中完全用自定义的方式处理数据。（仅在 PDOStatement::fetchAll() 中有效）。
PDO::FETCH_GROUP (integer)
根据值分组返回。通常和 PDO::FETCH_COLUMN 或 PDO::FETCH_KEY_PAIR 一起使用。
PDO::FETCH_UNIQUE (integer)
只取唯一值。
PDO::FETCH_KEY_PAIR (integer)
获取一个有两列的结果集到一个数组，其中第一列为键名，第二列为值。自 PHP 5.2.3 起可用。
PDO::FETCH_CLASSTYPE (integer)
根据第一列的值确定类名。
PDO::FETCH_SERIALIZE (integer)
类似 PDO::FETCH_INTO ，但是以一个序列化的字符串表示对象。自 PHP 5.1.0 起可用。从 PHP 5.3.0 开始，如果设置此标志，则类的构造函数从不会被调用。
PDO::FETCH_PROPS_LATE (integer)
设置属性前调用构造函数。自 PHP 5.2.0 起可用。
PDO::ATTR_AUTOCOMMIT (integer)
如果此值为 false ，PDO 将试图禁用自动提交以便数据库连接开始一个事务。
PDO::ATTR_PREFETCH (integer)
设置预取大小来为你的应用平衡速度和内存使用。并非所有的数据库/驱动组合都支持设置预取大小。较大的预取大小导致性能提高的同时也会占用更多的内存。
PDO::ATTR_TIMEOUT (integer)
设置连接数据库的超时秒数。
PDO::ATTR_ERRMODE (integer)
关于此属性的更多信息请参见 错误及错误处理 部分。
PDO::ATTR_SERVER_VERSION (integer)
此为只读属性；返回 PDO 所连接的数据库服务的版本信息。
PDO::ATTR_CLIENT_VERSION (integer)
此为只读属性；返回 PDO 驱动所用客户端库的版本信息。
PDO::ATTR_SERVER_INFO (integer)
此为只读属性。返回一些关于 PDO 所连接的数据库服务的元信息。
PDO::ATTR_CONNECTION_STATUS (integer)
PDO::ATTR_CASE (integer)
用类似 PDO::CASE_* 的常量强制列名为指定的大小写。
PDO::ATTR_CURSOR_NAME (integer)
获取或设置使用游标的名称。当使用可滚动游标和定位更新时候非常有用。
PDO::ATTR_CURSOR (integer)
选择游标类型。 PDO 当前支持 PDO::CURSOR_FWDONLY 和 PDO::CURSOR_SCROLL。一般为 PDO::CURSOR_FWDONLY，除非确实需要一个可滚动游标。
PDO::ATTR_DRIVER_NAME (string)
返回驱动名称。

Example #1 使用 PDO::ATTR_DRIVER_NAME 的例子

<?php
if ($db->getAttribute(PDO::ATTR_DRIVER_NAME) == 'mysql') {
  echo "Running on mysql; doing something mysql specific here\n";
}
?>

PDO::ATTR_ORACLE_NULLS (integer)
在获取数据时将空字符串转换成 SQL 中的 NULL 。
PDO::ATTR_PERSISTENT (integer)
请求一个持久连接，而非创建一个新连接。关于此属性的更多信息请参见 连接与连接管理 。
PDO::ATTR_STATEMENT_CLASS (integer)
设置返回的 statement 类名。
PDO::ATTR_FETCH_CATALOG_NAMES (integer)
将包含的目录名添加到结果集中的每个列名前面。目录名和列名由一个小数点分开（.）。此属性在驱动层面支持，所以有些驱动可能不支持此属性。
PDO::ATTR_FETCH_TABLE_NAMES (integer)
将包含的表名添加到结果集中的每个列名前面。表名和列名由一个小数点分开（.）。此属性在驱动层面支持，所以有些驱动可能不支持此属性。
PDO::ATTR_STRINGIFY_FETCHES (integer)
强制以字符串方式对待所有的值。
PDO::ATTR_MAX_COLUMN_LEN (integer)
设置字段名最长的尺寸。
PDO::ATTR_DEFAULT_FETCH_MODE (integer)
自 PHP 5.2.0 起可用。
PDO::ATTR_EMULATE_PREPARES (integer)
自 PHP 5.1.3 起可用。
PDO::ATTR_DEFAULT_STR_PARAM (integer)
设置默认 string 参数类型可以是 PDO::PARAM_STR_NATL 和 PDO::PARAM_STR_CHAR。 自 PHP 7.2.0 起可用
PDO::ERRMODE_SILENT (integer)
如果发生错误，则不显示错误或异常。希望开发人员显式地检查错误。此为默认模式。关于此属性的更多信息请参见 错误与错误处理 。
PDO::ERRMODE_WARNING (integer)
如果发生错误，则显示一个 PHP E_WARNING 消息。关于此属性的更多信息请参见 错误与错误处理。
PDO::ERRMODE_EXCEPTION (integer)
如果发生错误，则抛出一个 PDOException 异常。关于此属性的更多信息请参见 错误与错误处理。
PDO::CASE_NATURAL (integer)
保留数据库驱动返回的列名。
PDO::CASE_LOWER (integer)
强制列名小写。
PDO::CASE_UPPER (integer)
强制列名大写。
PDO::NULL_NATURAL (integer)
PDO::NULL_EMPTY_STRING (integer)
PDO::NULL_TO_STRING (integer)
PDO::FETCH_ORI_NEXT (integer)
在结果集中获取下一行。仅对可滚动游标有效。
PDO::FETCH_ORI_PRIOR (integer)
在结果集中获取上一行。仅对可滚动游标有效。
PDO::FETCH_ORI_FIRST (integer)
在结果集中获取第一行。仅对可滚动游标有效。
PDO::FETCH_ORI_LAST (integer)
在结果集中获取最后一行。仅对可滚动游标有效。
PDO::FETCH_ORI_ABS (integer)
根据行号从结果集中获取需要的行。仅对可滚动游标有效。
PDO::FETCH_ORI_REL (integer)
根据当前游标位置的相对位置从结果集中获取需要的行。仅对可滚动游标有效。
PDO::CURSOR_FWDONLY (integer)
创建一个只进游标的 PDOStatement 对象。此为默认的游标选项，因为此游标最快且是 PHP 中最常用的数据访问模式。
PDO::CURSOR_SCROLL (integer)
创建一个可滚动游标的 PDOStatement 对象。通过 PDO::FETCH_ORI_* 常量来控制结果集中获取的行。
PDO::ERR_NONE (string)
对应 SQLSTATE '00000'，表示 SQL 语句没有错误或警告地成功发出。当用 PDO::errorCode() 或 PDOStatement::errorCode() 来确定是否有错误发生时，此常量非常方便。在检查上述方法返回的错误状态代码时，会经常用到。
PDO::PARAM_EVT_ALLOC (integer)
分配事件
PDO::PARAM_EVT_FREE (integer)
解除分配事件
PDO::PARAM_EVT_EXEC_PRE (integer)
执行一条预处理语句之前触发事件。
PDO::PARAM_EVT_EXEC_POST (integer)
执行一条预处理语句之后触发事件。
PDO::PARAM_EVT_FETCH_PRE (integer)
从一个结果集中取出一条结果之前触发事件。
PDO::PARAM_EVT_FETCH_POST (integer)
从一个结果集中取出一条结果之后触发事件。
PDO::PARAM_EVT_NORMALIZE (integer)
在绑定参数注册允许驱动程序正常化变量名时触发事件。
PDO::SQLITE_DETERMINISTIC (integer)
设定 PDO::sqliteCreateFunction() 返回的函数是结果确定的（deterministic）。 举例说明：在同一个 SQL statement 内，函数的参数不变，则返回的结果也不变。 （PHP 7.1.4起有效）


连接与连接管理

连接是通过创建 PDO 基类的实例而建立的。不管使用哪种驱动程序，都是用 PDO 类名。构造函数接收用于指定数据库源（所谓的 DSN）以及可能还包括用户名和密码（如果有的话）的参数。

Example #1 连接到 MySQL

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
?>

如果有任何连接错误，将抛出一个 PDOException 异常对象。如果想处理错误状态，可以捕获异常，或者选择留给通过 set_exception_handler() 设置的应用程序全局异常处理程序。

Example #2 处理连接错误

<?php
try {
    $dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
    foreach($dbh->query('SELECT * from FOO') as $row) {
        print_r($row);
    }
    $dbh = null;
} catch (PDOException $e) {
    print "Error!: " . $e->getMessage() . "<br/>";
    die();
}
?>

Warning

如果应用程序不在 PDO 构造函数中捕获异常，zend 引擎采取的默认动作是结束脚本并显示一个回溯跟踪，此回溯跟踪可能泄漏完整的数据库连接细节，包括用户名和密码。因此有责任去显式（通过 catch 语句）或隐式（通过 set_exception_handler() ）地捕获异常。

连接数据成功后，返回一个 PDO 类的实例给脚本，此连接在 PDO 对象的生存周期中保持活动。要想关闭连接，需要销毁对象以确保所有剩余到它的引用都被删除，可以赋一个 null 值给对象变量。如果不明确地这么做，PHP 在脚本结束时会自动关闭连接。

Example #3 关闭一个连接

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
// 在此使用连接

// 现在运行完成，在此关闭连接
$dbh = null;
?>

很多 web 应用程序通过使用到数据库服务的持久连接获得好处。持久连接在脚本结束后不会被关闭，且被缓存，当另一个使用相同凭证的脚本连接请求时被重用。持久连接缓存可以避免每次脚本需要与数据库回话时建立一个新连接的开销，从而让 web 应用程序更快。

Example #4 持久化连接

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass, array(
    PDO::ATTR_PERSISTENT => true
));
?>

Note:

如果想使用持久连接，必须在传递给 PDO 构造函数的驱动选项数组中设置 PDO::ATTR_PERSISTENT 。如果是在对象初始化之后用 PDO::setAttribute() 设置此属性，则驱动程序将不会使用持久连接。

Note:

如果使用 PDO ODBC 驱动且 ODBC 库支持 ODBC 连接池（有unixODBC 和 Windows 两种做法；可能会有更多），建议不要使用持久的 PDO 连接，而是把连接缓存留给 ODBC 连接池层处理。 ODBC 连接池在进程中与其他模块共享；如果要求 PDO 缓存连接，则此连接绝不会被返回到 ODBC 连接池，导致创建额外的连接来服务其他模块。


事务与自动提交

现在通过 PDO 连接上了，在开始进行查询前，必须先理解 PDO 是如何管理事务的。事务支持四大特性（ACID）：原子性（Atomicity）、一致性（Consistency）、隔离性（Isolation）以及持久性（Durability）。通俗地讲，在一个事务中执行的任何操作，即使是分阶段执行的，也能保证安全地应用于数据库，并在提交时不会受到来自其他连接的干扰。事务操作也可以根据请求自动撤销（假设还没有提交），这使得在脚本中处理错误更加容易。

事务通常是通过把一批更改"积蓄"起来然后使之同时生效而实现的；这样做的好处是可以大大地提供这些更改的效率。换句话说，事务可以使脚本更快，而且可能更健壮（不过需要正确地使用事务才能获得这样的好处）。

不幸的是，并非每种数据库都支持事务，因此当第一次打开连接时，PDO 需要在所谓的"自动提交"模式下运行。自动提交模式意味着，如果数据库支持，运行的每个查询都有它自己的隐式事务，如果数据库不支持事务，则没有。如果需要一个事务，则必须用 PDO::beginTransaction() 方法来启动。如果底层驱动不支持事务，则抛出一个 PDOException 异常（不管错误处理设置是怎样的，这都是一个严重的错误状态）。一旦开始了事务，可用 PDO::commit() 或 PDO::rollBack()来完成，这取决于事务中的代码是否运行成功。

Warning

PDO 仅在驱动层检查是否具有事务处理能力。如果某些运行时条件意味着事务不可用，且数据库服务接受请求去启动一个事务，PDO::beginTransaction() 将仍然返回 true 而且没有错误。

试着在 MySQL 数据库的 MyISAM 数据表中使用事务就是一个很好的例子。

当脚本结束或连接即将被关闭时，如果尚有一个未完成的事务，那么 PDO 将自动回滚该事务。这种安全措施有助于在脚本意外终止时避免出现不一致的情况——如果没有显式地提交事务，那么假设是某个地方出错了，所以执行回滚来保证数据安全。

Warning

只有通过 PDO::beginTransaction() 启动一个事务后，才可能发生自动回滚。如果手动发出一条查询启动事务， 则 PDO 无法知晓，从而在必要时不能进行回滚。

Example #1 在事务中执行批处理

在下面例子中，假设为新员工创建一组条目，分配一个为23的ID。除了登记此人的基本数据之外，还需要记录他的工资。两个更新分别完成起来很简单，但通过封闭在 PDO::beginTransaction() 和PDO::commit() 调用中，可以保证在更改完成之前，其他人无法看到这些更改。如果发生了错误，catch 块回滚自事务启动以来发生的所有更改，并输出一条错误信息。

<?php
try {
  $dbh = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2',
      array(PDO::ATTR_PERSISTENT => true));
  echo "Connected\n";
} catch (Exception $e) {
  die("Unable to connect: " . $e->getMessage());
}

try {
  $dbh->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);

  $dbh->beginTransaction();
  $dbh->exec("insert into staff (id, first, last) values (23, 'Joe', 'Bloggs')");
  $dbh->exec("insert into salarychange (id, amount, changedate)
      values (23, 50000, NOW())");
  $dbh->commit();

} catch (Exception $e) {
  $dbh->rollBack();
  echo "Failed: " . $e->getMessage();
}
?>

并不局限于在事务中更改，也可以发出复杂的查询来提取数据，还可以使用那些信息来构建更多的更改和查询；当事务激活时，可以保证其他人在操作进行当中无法作出更改。想更进一步阅读关于事务的信息，可参考数据库服务提供的文档。


预处理语句与存储过程

很多更成熟的数据库都支持预处理语句的概念。什么是预处理语句？可以把它看作是想要运行的 SQL 的一种编译过的模板，它可以使用变量参数进行定制。预处理语句可以带来两大好处：

  • 查询仅需解析（或预处理）一次，但可以用相同或不同的参数执行多次。当查询准备好后，数据库将分析、编译和优化执行该查询的计划。对于复杂的查询，此过程要花费较长的时间，如果需要以不同参数多次重复相同的查询，那么该过程将大大降低应用程序的速度。通过使用预处理语句，可以避免重复分析/编译/优化周期。简言之，预处理语句占用更少的资源，因而运行得更快。
  • 提供给预处理语句的参数不需要用引号括起来，驱动程序会自动处理。如果应用程序只使用预处理语句，可以确保不会发生SQL 注入。（然而，如果查询的其他部分是由未转义的输入来构建的，则仍存在 SQL 注入的风险）。

预处理语句如此有用，以至于它们唯一的特性是在驱动程序不支持的时PDO 将模拟处理。这样可以确保不管数据库是否具有这样的功能，都可以确保应用程序可以用相同的数据访问模式。

Example #1 用预处理语句进行重复插入

下面例子通过用 name 和 value 替代相应的命名占位符来执行一个插入查询

<?php
$stmt = $dbh->prepare("INSERT INTO REGISTRY (name, value) VALUES (:name, :value)");
$stmt->bindParam(':name', $name);
$stmt->bindParam(':value', $value);

// 插入一行
$name = 'one';
$value = 1;
$stmt->execute();

//  用不同的值插入另一行
$name = 'two';
$value = 2;
$stmt->execute();
?>

Example #2 用预处理语句进行重复插入

下面例子通过用 name 和 value 取代 ? 占位符的位置来执行一条插入查询。

<?php
$stmt = $dbh->prepare("INSERT INTO REGISTRY (name, value) VALUES (?, ?)");
$stmt->bindParam(1, $name);
$stmt->bindParam(2, $value);

// 插入一行
$name = 'one';
$value = 1;
$stmt->execute();

// 用不同的值插入另一行
$name = 'two';
$value = 2;
$stmt->execute();
?>

Example #3 使用预处理语句获取数据

下面例子获取数据基于键值已提供的形式。用户的输入被自动用引号括起来，因此不会有 SQL 注入攻击的危险。

<?php
$stmt = $dbh->prepare("SELECT * FROM REGISTRY where name = ?");
if ($stmt->execute(array($_GET['name']))) {
  while ($row = $stmt->fetch()) {
    print_r($row);
  }
}
?>

如果数据库驱动支持，应用程序还可以绑定输出和输入参数.输出参数通常用于从存储过程获取值。输出参数使用起来比输入参数要稍微复杂一些，因为当绑定一个输出参数时，必须知道给定参数的长度。如果为参数绑定的值大于建议的长度，就会产生一个错误。

Example #4 带输出参数调用存储过程

<?php
$stmt = $dbh->prepare("CALL sp_returns_string(?)");
$stmt->bindParam(1, $return_value, PDO::PARAM_STR, 4000);

// 调用存储过程
$stmt->execute();

print "procedure returned $return_value\n";
?>

还可以指定同时具有输入和输出值的参数，其语法类似于输出参数。在下一个例子中，字符串"hello"被传递给存储过程，当存储过程返回时，hello 被替换为该存储过程返回的值。

Example #5 带输入/输出参数调用存储过程

<?php
$stmt = $dbh->prepare("CALL sp_takes_string_returns_string(?)");
$value = 'hello';
$stmt->bindParam(1, $value, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 4000);

// 调用存储过程
$stmt->execute();

print "procedure returned $value\n";
?>

Example #6 占位符的无效使用

<?php
$stmt = $dbh->prepare("SELECT * FROM REGISTRY where name LIKE '%?%'");
$stmt->execute(array($_GET['name']));

// 占位符必须被用在整个值的位置
$stmt = $dbh->prepare("SELECT * FROM REGISTRY where name LIKE ?");
$stmt->execute(array("%$_GET[name]%"));
?>


错误与错误处理

PDO 提供了三种不同的错误处理模式，以满足不同风格的应用开发：

  • PDO::ERRMODE_SILENT

    此为默认模式。 PDO 将只简单地设置错误码，可使用 PDO::errorCode() 和 PDO::errorInfo() 方法来检查语句和数据库对象。如果错误是由于对语句对象的调用而产生的，那么可以调用那个对象的 PDOStatement::errorCode() 或 PDOStatement::errorInfo() 方法。如果错误是由于调用数据库对象而产生的，那么可以在数据库对象上调用上述两个方法。

  • PDO::ERRMODE_WARNING

    除设置错误码之外，PDO 还将发出一条传统的 E_WARNING 信息。如果只是想看看发生了什么问题且不中断应用程序的流程，那么此设置在调试/测试期间非常有用。

  • PDO::ERRMODE_EXCEPTION

    除设置错误码之外，PDO 还将抛出一个 PDOException 异常类并设置它的属性来反射错误码和错误信息。此设置在调试期间也非常有用，因为它会有效地放大脚本中产生错误的点，从而可以非常快速地指出代码中有问题的潜在区域（记住：如果异常导致脚本终止，则事务被自动回滚）。

    异常模式另一个非常有用的是，相比传统 PHP 风格的警告，可以更清晰地构建自己的错误处理，而且比起静默模式和显式地检查每种数据库调用的返回值，异常模式需要的代码/嵌套更少。

    See Exceptions for more information about Exceptions in PHP.

PDO 使用 SQL-92 SQLSTATE 来规范错误码字符串；不同 PDO 驱动程序负责将它们的本地代码映射为适当的 SQLSTATE 代码。PDO::errorCode() 方法返回一个单独的 SQLSTATE 码。如果需要更多此错误的细节信息，PDO 还提供了一个 PDO::errorInfo() 方法来返回一个包含 SQLSTATE 码、特定驱动错误码以及此驱动的错误字符串的数组。

Example #1 创建 PDO 实例并设置错误模式

<?php
$dsn = 'mysql:dbname=testdb;host=127.0.0.1';
$user = 'dbuser';
$password = 'dbpass';

try {
    $dbh = new PDO($dsn, $user, $password);
    $dbh->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
} catch (PDOException $e) {
    echo 'Connection failed: ' . $e->getMessage();
}

?>

Note:

不管当前是否设置了 PDO::ATTR_ERRMODE ，如果连接失败，PDO::__construct() 将总是抛出一个 PDOException 异常。未捕获异常是致命的。

Example #2 创建 PDO 实例并在构造函数中设置错误模式

<?php
$dsn = 'mysql:dbname=test;host=127.0.0.1';
$user = 'googleguy';
$password = 'googleguy';

/*
    使用 try/catch 围绕构造函数仍然有效，即使设置了 ERRMODE 为 WARNING，
    因为如果连接失败，PDO::__construct 将总是抛出一个  PDOException 异常。
*/
try {
    $dbh = new PDO($dsn, $user, $password, array(PDO::ATTR_ERRMODE => PDO::ERRMODE_WARNING));
} catch (PDOException $e) {
    echo 'Connection failed: ' . $e->getMessage();
    exit;
}

// 这里将导致 PDO 抛出一个 E_WARNING 级别的错误，而不是 一个异常 （当数据表不存在时）
$dbh->query("SELECT wrongcolumn FROM wrongtable");
?>

以上例程会输出：

Warning: PDO::query(): SQLSTATE[42S02]: Base table or view not found: 1146 Table 'test.wrongtable' doesn't exist in
/tmp/pdo_test.php on line 18


大对象 (LOBs)

应用程序在某一时刻，可能需要在数据库中存储"大"数据。"大"通常意味着"大约 4kb 或以上"，尽管某些数据库在数据达到"大"之前可以轻松地处理多达 32kb 的数据。大对象本质上可能是文本或二进制。在 PDOStatement::bindParam() 或 PDOStatement::bindColumn()) 调用中使用 PDO::PARAM_LOB 类型码可以让 PDO 使用大数据类型。PDO::PARAM_LOB 告诉 PDO 作为流来映射数据，以便能使用 PHP Streams API 来操作。

Example #1 从数据库中显示一张图片

下面例子绑定一个 LOB 到 $lob 变量，然后用 fpassthru() 将其发送到浏览器。因为 LOB 代表一个流，所以类似 fgets()、fread() 以及 stream_get_contents() 这样的函数都可以用在它上面。

<?php
$db = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2');
$stmt = $db->prepare("select contenttype, imagedata from images where id=?");
$stmt->execute(array($_GET['id']));
$stmt->bindColumn(1, $type, PDO::PARAM_STR, 256);
$stmt->bindColumn(2, $lob, PDO::PARAM_LOB);
$stmt->fetch(PDO::FETCH_BOUND);

header("Content-Type: $type");
fpassthru($lob);
?>

Example #2 插入一张图片到数据库

下面例子打开一个文件并将文件句柄传给 PDO 来做为一个 LOB 插入。PDO尽可能地让数据库以最有效的方式获取文件内容。

<?php
$db = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2');
$stmt = $db->prepare("insert into images (id, contenttype, imagedata) values (?, ?, ?)");
$id = get_new_id(); // 调用某个函数来分配一个新 ID

// 假设处理一个文件上传
// 可以在 PHP 文档中找到更多的信息

$fp = fopen($_FILES['file']['tmp_name'], 'rb');

$stmt->bindParam(1, $id);
$stmt->bindParam(2, $_FILES['file']['type']);
$stmt->bindParam(3, $fp, PDO::PARAM_LOB);

$db->beginTransaction();
$stmt->execute();
$db->commit();
?>

Example #3 插入一张图片到数据库：Oracle

对于从文件插入一个 lob，Oracle略有不同。必须在事务之后进行插入，否则当执行查询时导致新近插入 LOB 将以0长度被隐式提交：

<?php
$db = new PDO('oci:', 'scott', 'tiger');
$stmt = $db->prepare("insert into images (id, contenttype, imagedata) " .
"VALUES (?, ?, EMPTY_BLOB()) RETURNING imagedata INTO ?");
$id = get_new_id(); // 调用某个函数来分配一个新 ID

// 假设处理一个文件上传
// 可以在 PHP 文档中找到更多的信息

$fp = fopen($_FILES['file']['tmp_name'], 'rb');

$stmt->bindParam(1, $id);
$stmt->bindParam(2, $_FILES['file']['type']);
$stmt->bindParam(3, $fp, PDO::PARAM_LOB);

$stmt->beginTransaction();
$stmt->execute();
$stmt->commit();
?>


PDO 类

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

简介

代表 PHP 和数据库服务之间的一个连接

类摘要

PDO {
__construct ( string $dsn , string $username = ? , string $password = ? , array $driver_options = ? )
beginTransaction ( ) : bool
commit ( ) : bool
errorCode ( ) : mixed
public errorInfo ( ) : array
exec ( string $statement ) : int
getAttribute ( int $attribute ) : mixed
static getAvailableDrivers ( ) : array
inTransaction ( ) : bool
lastInsertId ( string $name = null ) : string
public prepare ( string $statement , array $driver_options = array() ) : PDOStatement
public query ( string $statement ) : PDOStatement
public quote ( string $string , int $parameter_type = PDO::PARAM_STR ) : string
rollBack ( ) : bool
setAttribute ( int $attribute , mixed $value ) : bool
}

Table of Contents

  • PDO::beginTransaction — 启动一个事务
  • PDO::commit — 提交一个事务
  • PDO::__construct — 创建一个表示数据库连接的 PDO 实例
  • PDO::errorCode — 获取跟数据库句柄上一次操作相关的 SQLSTATE
  • PDO::errorInfo — Fetch extended error information associated with the last operation on the database handle
  • PDO::exec — 执行一条 SQL 语句，并返回受影响的行数
  • PDO::getAttribute — 取回一个数据库连接的属性
  • PDO::getAvailableDrivers — 返回一个可用驱动的数组
  • PDO::inTransaction — 检查是否在一个事务内
  • PDO::lastInsertId — 返回最后插入行的ID或序列值
  • PDO::prepare — 准备要执行的语句，并返回语句对象
  • PDO::query — 执行 SQL 语句，以 PDOStatement 对象形式返回结果集
  • PDO::quote — 为 SQL 查询里的字符串添加引号
  • PDO::rollBack — 回滚一个事务
  • PDO::setAttribute — 设置属性


启动一个事务

  • ? PDO
  • PDO::commit ?
  • PHP Manual
  • PDO
  • 启动一个事务

PDO::beginTransaction

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::beginTransaction — 启动一个事务

说明

PDO::beginTransaction ( ) : bool

关闭自动提交模式。自动提交模式被关闭的同时，通过 PDO 对象实例对数据库做出的更改直到调用 PDO::commit() 结束事务才被提交。调用 PDO::rollBack() 将回滚对数据库做出的更改并将数据库连接返回到自动提交模式。

包括 MySQL 在内的一些数据库，当发出一条类似 DROP TABLE 或 CREATE TABLE 这样的 DDL 语句时，会自动进行一个隐式地事务提交。隐式地提交将阻止你在此事务范围内回滚任何其他更改。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 回滚一个事务

下面例子在回滚此更改前开始一个事务并发出两条修改数据库的语句。但在 MySQL 中，DROP TABLE 语句自动提交事务，使得在此事务中的任何更改都不会被回滚。

<?php
/* 开始一个事务，关闭自动提交 */
$dbh->beginTransaction();

/*  更改数据库架构及数据 */
$sth = $dbh->exec("DROP TABLE fruit");
$sth = $dbh->exec("UPDATE dessert
    SET name = 'hamburger'");

/*  识别出错误并回滚更改 */
$dbh->rollBack();

/* 数据库连接现在返回到自动提交模式 */
?>

参见

  • PDO::commit() - 提交一个事务
  • PDO::rollBack() - 回滚一个事务
  • 事务与自动提交


提交一个事务

  • ? PDO::beginTransaction
  • PDO::__construct ?
  • PHP Manual
  • PDO
  • 提交一个事务

PDO::commit

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::commit — 提交一个事务

说明

PDO::commit ( ) : bool

提交一个事务，数据库连接返回到自动提交模式直到下次调用 PDO::beginTransaction() 开始一个新的事务为止。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 提交一个基础事务

<?php
/* 开始一个事务，关闭自动提交 */
$dbh->beginTransaction();

/* 在全有或全无的基础上插入多行记录（要么全部插入，要么全部不插入） */
$sql = 'INSERT INTO fruit
    (name, colour, calories)
    VALUES (?, ?, ?)';

$sth = $dbh->prepare($sql);

foreach ($fruits as $fruit) {
    $sth->execute(array(
        $fruit->name,
        $fruit->colour,
        $fruit->calories,
    ));
}

/* 提交更改 */
$dbh->commit();

/* 现在数据库连接返回到自动提交模式 */
?>

Example #2 提交一个DDL事务

<?php
/*  开始一个事务，关闭自动提交 */
$dbh->beginTransaction();

/* Change the database schema */
$sth = $dbh->exec("DROP TABLE fruit");

/* 更改数据库架构 */
$dbh->commit();

/* 现在数据库连接返回到自动提交模式 */
?>

Note: 并不是所有数据库都允许使用DDL语句进行事务操作：有些会产生错误，而其他一些（包括MySQL）会在遇到第一个DDL语句后就自动提交事务。

参见

  • PDO::beginTransaction() - 启动一个事务
  • PDO::rollBack() - 回滚一个事务
  • 事务和自动提交


创建一个表示数据库连接的 PDO 实例

  • ? PDO::commit
  • PDO::errorCode ?
  • PHP Manual
  • PDO
  • 创建一个表示数据库连接的 PDO 实例

PDO::__construct

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::__construct — 创建一个表示数据库连接的 PDO 实例

说明

PDO::__construct ( string $dsn , string $username = ? , string $password = ? , array $driver_options = ? )

创建一个表示连接到请求数据库的数据库连接 PDO 实例。

参数

dsn

数据源名称或叫做 DSN，包含了请求连接到数据库的信息。

通常，一个 DSN 由 PDO 驱动名、紧随其后的冒号、以及具体 PDO 驱动的连接语法组成。更深入的信息能从 PDO 具体驱动文档找到。

The dsn 参数支持三种不同的方式 创建一个数据库连接：

Driver invocation

dsn 包含完整的DSN。

URI invocation

dsn consists of uri: followed by a URI that defines the location of a file containing the DSN string. The URI can specify a local file or a remote URL.

uri:file:///path/to/dsnfile

Aliasing

dsn consists of a name name that maps to pdo.dsn.name in php.ini defining the DSN string.

Note:

别名必须得在 php.ini 中定义了，不能是在 .htaccess 或 httpd.conf 中 。

username

DSN字符串中的用户名。对于某些PDO驱动，此参数为可选项。

password

DSN字符串中的密码。对于某些PDO驱动，此参数为可选项。

driver_options

一个具体驱动的连接选项的键=>值数组。

返回值

成功则返回一个PDO对象。

错误／异常

如果试图连接到请求的数据库失败，则PDO::__construct() 抛出一个 PDO异常（PDOException） 。

范例

Example #1 Create a PDO instance via driver invocation

<?php
/* Connect to an ODBC database using driver invocation */
$dsn = 'mysql:dbname=testdb;host=127.0.0.1';
$user = 'dbuser';
$password = 'dbpass';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Connection failed: ' . $e->getMessage();
}

?>

Example #2 Create a PDO instance via URI invocation

The following example assumes that the file /usr/local/dbconnect exists with file permissions that enable PHP to read the file. The file contains the PDO DSN to connect to a DB2 database through the PDO_ODBC driver:

odbc:DSN=SAMPLE;UID=john;PWD=mypass

The PHP script can then create a database connection by simply passing the uri: parameter and pointing to the file URI:

<?php
/* Connect to an ODBC database using driver invocation */
$dsn = 'uri:file:///usr/local/dbconnect';
$user = '';
$password = '';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Connection failed: ' . $e->getMessage();
}

?>

Example #3 使用别名创建一个PDO实例

The following example assumes that php.ini contains the following entry to enable a connection to a MySQL database using only the alias mydb:

[PDO]
pdo.dsn.mydb="mysql:dbname=testdb;host=localhost"
<?php
/*  使用别名连接到一个ODBC数据库  */
$dsn = 'mydb';
$user = '';
$password = '';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Connection failed: ' . $e->getMessage();
}

?>


获取跟数据库句柄上一次操作相关的 SQLSTATE

  • ? PDO::__construct
  • PDO::errorInfo ?
  • PHP Manual
  • PDO
  • 获取跟数据库句柄上一次操作相关的 SQLSTATE

PDO::errorCode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::errorCode — 获取跟数据库句柄上一次操作相关的 SQLSTATE

说明

PDO::errorCode ( ) : mixed

返回值

返回一个 SQLSTATE，一个由5个字母或数字组成的在 ANSI SQL 标准中定义的标识符。 简要地说，一个 SQLSTATE 由前面两个字符的类值和后面三个字符的子类值组成。 class value of 01 indicates a warning and is accompanied by a return code of SQL_SUCCESS_WITH_INFO. Class values other than '01', except for the class 'IM', indicate an error. The class 'IM' is specific to warnings and errors that derive from the implementation of PDO (or perhaps ODBC, if you're using the ODBC driver) itself. The subclass value '000' in any class indicates that there is no subclass for that SQLSTATE.

PDO::errorCode() only retrieves error codes for operations performed directly on the database handle. If you create a PDOStatement object through PDO::prepare() or PDO::query() and invoke an error on the statement handle, PDO::errorCode() will not reflect that error. You must call PDOStatement::errorCode() to return the error code for an operation performed on a particular statement handle.

如果数据库句柄没有进行操作，则返回 null 。

范例

Example #1 取得一个 SQLSTATE 码

<?php
/* 引发一个错误 -- BONES 数据表不存在 */
$dbh->exec("INSERT INTO bones(skull) VALUES ('lucy')");

echo "\nPDO::errorCode(): ";
print $dbh->errorCode();
?>

以上例程会输出：

PDO::errorCode(): 42S02

参见

  • PDO::errorInfo() - Fetch extended error information associated with the last operation on the database handle
  • PDOStatement::errorCode() - 获取跟上一次语句句柄操作相关的 SQLSTATE
  • PDOStatement::errorInfo() - 获取跟上一次语句句柄操作相关的扩展错误信息


Fetch extended error information associated with the last operation on the database handle

  • ? PDO::errorCode
  • PDO::exec ?
  • PHP Manual
  • PDO
  • Fetch extended error information associated with the last operation on the database handle

PDO::errorInfo

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::errorInfo — Fetch extended error information associated with the last operation on the database handle

说明

public PDO::errorInfo ( ) : array

返回值

PDO::errorInfo() returns an array of error information about the last operation performed by this database handle. The array consists of at least the following fields:

Element | Information
0 | SQLSTATE error code (a five characters alphanumeric identifier defined in the ANSI SQL standard).
1 | Driver-specific error code.
2 | Driver-specific error message.

Note:

If the SQLSTATE error code is not set or there is no driver-specific error, the elements following element 0 will be set to null.

PDO::errorInfo() only retrieves error information for operations performed directly on the database handle. If you create a PDOStatement object through PDO::prepare() or PDO::query() and invoke an error on the statement handle, PDO::errorInfo() will not reflect the error from the statement handle. You must call PDOStatement::errorInfo() to return the error information for an operation performed on a particular statement handle.

范例

Example #1 Displaying errorInfo() fields for a PDO_ODBC connection to a DB2 database

<?php
/* Provoke an error -- bogus SQL syntax */
$stmt = $dbh->prepare('bogus sql');
if (!$stmt) {
    echo "\nPDO::errorInfo():\n";
    print_r($dbh->errorInfo());
}
?>

以上例程会输出：

PDO::errorInfo():
Array
(
    [0] => HY000
    [1] => 1
    [2] => near "bogus": syntax error
)

参见

  • PDO::errorCode() - 获取跟数据库句柄上一次操作相关的 SQLSTATE
  • PDOStatement::errorCode() - 获取跟上一次语句句柄操作相关的 SQLSTATE
  • PDOStatement::errorInfo() - 获取跟上一次语句句柄操作相关的扩展错误信息


执行一条 SQL 语句，并返回受影响的行数

  • ? PDO::errorInfo
  • PDO::getAttribute ?
  • PHP Manual
  • PDO
  • 执行一条 SQL 语句，并返回受影响的行数

PDO::exec

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::exec — 执行一条 SQL 语句，并返回受影响的行数

说明

PDO::exec ( string $statement ) : int

PDO::exec() 在一个单独的函数调用中执行一条 SQL 语句，返回受此语句影响的行数。

PDO::exec() 不会从一条 SELECT 语句中返回结果。对于在程序中只需要发出一次的 SELECT 语句，可以考虑使用 PDO::query()。对于需要发出多次的语句，可用 PDO::prepare() 来准备一个 PDOStatement 对象并用 PDOStatement::execute() 发出语句。

参数

statement

要被预处理和执行的 SQL 语句。

查询中的数据应该被 妥善地转义 。

返回值

PDO::exec() 返回受修改或删除 SQL 语句影响的行数。如果没有受影响的行，则 PDO::exec() 返回 0。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

下面例子依赖 PDO::exec() 的返回值是不正确的，其中受影响行数为 0 的语句会导致调用 die() ：

<?php
$db->exec() or die(print_r($db->errorInfo(), true));
?>

范例

Example #1 发出一条 DELETE 语句

计算由一条不带 WHERE 字句的 DELETE 语句删除的行数。

<?php
$dbh = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');

/*  删除 FRUIT 数据表中满足条件的所有行 */
$count = $dbh->exec("DELETE FROM fruit WHERE colour = 'red'");

/* 返回被删除的行数 */
print("Deleted $count rows.\n");
?>

以上例程会输出：

Deleted 1 rows.

参见

  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDO::query() - 执行 SQL 语句，以 PDOStatement 对象形式返回结果集
  • PDOStatement::execute() - 执行一条预处理语句


取回一个数据库连接的属性

  • ? PDO::exec
  • PDO::getAvailableDrivers ?
  • PHP Manual
  • PDO
  • 取回一个数据库连接的属性

PDO::getAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDO::getAttribute — 取回一个数据库连接的属性

说明

PDO::getAttribute ( int $attribute ) : mixed

此函数（方法）返回一个数据库连接的属性值。 取回 PDOStatement 属性，请参阅 PDOStatement::getAttribute()。

注意有些数据库/驱动可能不支持所有的数据库连接属性。

参数

attribute

PDO::ATTR_* 常量中的一个。下列为应用到数据库连接中的常量：

  • PDO::ATTR_AUTOCOMMIT
  • PDO::ATTR_CASE
  • PDO::ATTR_CLIENT_VERSION
  • PDO::ATTR_CONNECTION_STATUS
  • PDO::ATTR_DRIVER_NAME
  • PDO::ATTR_ERRMODE
  • PDO::ATTR_ORACLE_NULLS
  • PDO::ATTR_PERSISTENT
  • PDO::ATTR_PREFETCH
  • PDO::ATTR_SERVER_INFO
  • PDO::ATTR_SERVER_VERSION
  • PDO::ATTR_TIMEOUT

返回值

成功调用则返回请求的 PDO 属性值。不成功则返回 null。

范例

Example #1 取回数据库连接属性

<?php
$conn = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');
$attributes = array(
    "AUTOCOMMIT", "ERRMODE", "CASE", "CLIENT_VERSION", "CONNECTION_STATUS",
    "ORACLE_NULLS", "PERSISTENT", "PREFETCH", "SERVER_INFO", "SERVER_VERSION",
    "TIMEOUT"
);

foreach ($attributes as $val) {
    echo "PDO::ATTR_$val: ";
    echo $conn->getAttribute(constant("PDO::ATTR_$val")) . "\n";
}
?>

参见

  • PDO::setAttribute() - 设置属性
  • PDOStatement::getAttribute() - 检索一个语句属性
  • PDOStatement::setAttribute() - 设置一个语句属性


返回一个可用驱动的数组

  • ? PDO::getAttribute
  • PDO::inTransaction ?
  • PHP Manual
  • PDO
  • 返回一个可用驱动的数组

PDO::getAvailableDrivers

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 1.0.3)

PDO::getAvailableDrivers — 返回一个可用驱动的数组

说明

static PDO::getAvailableDrivers ( ) : array
pdo_drivers ( ) : array

此函数（方法）返回所有当前可用在 PDO::__construct() 的参数 DSN 中的 PDO 驱动。

返回值

PDO::getAvailableDrivers() 返回一个 包含可用 PDO 驱动名字的数组。如果没有可用的驱动，则返回一个空数组。

范例

Example #1 一个 PDO::getAvailableDrivers() 的例子

<?php
print_r(PDO::getAvailableDrivers());
?>

以上例程的输出类似于：

Array
(
    [0] => mysql
    [1] => sqlite
)


检查是否在一个事务内

  • ? PDO::getAvailableDrivers
  • PDO::lastInsertId ?
  • PHP Manual
  • PDO
  • 检查是否在一个事务内

PDO::inTransaction

(PHP 5 >= 5.3.3, Bundled pdo_pgsql, PHP 7)

PDO::inTransaction — 检查是否在一个事务内

说明

PDO::inTransaction ( ) : bool

检查驱动内的一个事务当前是否处于激活。此方法仅对支持事务的数据库驱动起作用。

参数

此函数没有参数。

返回值

如果当前事务处于激活，则返回 true ，否则返回 false 。


返回最后插入行的ID或序列值

  • ? PDO::inTransaction
  • PDO::prepare ?
  • PHP Manual
  • PDO
  • 返回最后插入行的ID或序列值

PDO::lastInsertId

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::lastInsertId — 返回最后插入行的ID或序列值

说明

PDO::lastInsertId ( string $name = null ) : string

返回最后插入行的ID，或者是一个序列对象最后的值，取决于底层的驱动。比如，PDO_PGSQL() 要求为 name 参数指定序列对象的名称。

Note:

在不同的 PDO 驱动之间，此方法可能不会返回一个有意义或一致的结果，因为底层数据库可能不支持自增字段或序列的概念。

参数

name

应该返回ID的那个序列对象的名称。

返回值

如果没有为参数 name 指定序列名称，PDO::lastInsertId() 则返回一个表示最后插入数据库那一行的行ID的字符串。

如果为参数 name 指定了序列名称，PDO::lastInsertId() 则返回一个表示从指定序列对象取回最后的值的字符串。

如果当前 PDO 驱动不支持此功能，则 PDO::lastInsertId() 触发一个 IM001 SQLSTATE 。


准备要执行的语句，并返回语句对象

  • ? PDO::lastInsertId
  • PDO::query ?
  • PHP Manual
  • PDO
  • 准备要执行的语句，并返回语句对象

PDO::prepare

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::prepare — 准备要执行的语句，并返回语句对象

说明

public PDO::prepare ( string $statement , array $driver_options = array() ) : PDOStatement

为 PDOStatement::execute() 方法准备待执行的 SQL 语句。 SQL 语句可以包含零个或多个参数占位标记，格式是命名（:name）或问号（?）的形式，当它执行时将用真实数据取代。 在同一个 SQL 语句里，命名形式和问号形式不能同时使用；只能选择其中一种参数形式。 请用参数形式绑定用户输入的数据，不要直接字符串拼接到查询里。

调用 PDOStatement::execute() 时，每一个值的参数占位标记，名称必须唯一。 除非启用模拟（emulation）模式，同一个语句里无法使用重名的参数。

Note:

参数占位符仅能字面上展示完整的数据。不能是字面的一部分，不能是关键词，不能是标识符，不能是其他任意的范围。 举例说明：不能把多个值绑到单个参数里，然后在 SQL 语句里用 IN() 查询。

如果用不同参数，通过 PDO::prepare() 和 PDOStatement::execute() 多次调用同一个 SQL 语句，将提升应用的性能 —— 驱动可以让客户端/服务器缓存查询和元信息，还能阻止 SQL 注入攻击，不需要手动给参数加引号。

如果内置驱动不支持参数，PDO 将模拟出参数的功能；如果驱动仅仅支持其中一种风格（命名参数和问号参数两种），也会自动重写到另外一种风格。

参数

statement

必须是对目标数据库服务器有效的 SQL 语句模板。

driver_options

数组包含一个或多个 key=>value 键值对，为返回的 PDOStatement 对象设置属性。 常见用法是：设置 PDO::ATTR_CURSOR 为 PDO::CURSOR_SCROLL，将得到可滚动的光标。 某些驱动有驱动级的选项，在 prepare 时就设置。

返回值

如果数据库服务器完成准备了语句， PDO::prepare() 返回 PDOStatement 对象。 如果数据库服务器无法准备语句， PDO::prepare() 返回 false 或抛出 PDOException (取决于 错误处理器)。

Note:

模拟模式下的 prepare 语句不会和数据库服务器交互，所以 PDO::prepare() 不会检查语句。

范例

Example #1 用命名参数形式准备 SQL 语句参数

<?php
/* 传入数组的值，并执行准备好的语句 */
$sql = 'SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour';
$sth = $dbh->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_FWDONLY));
$sth->execute(array(':calories' => 150, ':colour' => 'red'));
$red = $sth->fetchAll();
$sth->execute(array(':calories' => 175, ':colour' => 'yellow'));
$yellow = $sth->fetchAll();
?>

Example #2 用问号形式准备 SQL 语句参数

<?php
/* 传入数组的值，并执行准备好的语句 */
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->execute(array(150, 'red'));
$red = $sth->fetchAll();
$sth->execute(array(175, 'yellow'));
$yellow = $sth->fetchAll();
?>

参见

  • PDO::exec() - 执行一条 SQL 语句，并返回受影响的行数
  • PDO::query() - 执行 SQL 语句，以 PDOStatement 对象形式返回结果集
  • PDOStatement::execute() - 执行一条预处理语句


执行 SQL 语句，以 PDOStatement 对象形式返回结果集

  • ? PDO::prepare
  • PDO::quote ?
  • PHP Manual
  • PDO
  • 执行 SQL 语句，以 PDOStatement 对象形式返回结果集

PDO::query

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDO::query — 执行 SQL 语句，以 PDOStatement 对象形式返回结果集

说明

public PDO::query ( string $statement ) : PDOStatement
public PDO::query ( string $statement , int $PDO::FETCH_COLUMN , int $colno ) : PDOStatement
public PDO::query ( string $statement , int $PDO::FETCH_CLASS , string $classname , array $ctorargs ) : PDOStatement
public PDO::query ( string $statement , int $PDO::FETCH_INTO , object $object ) : PDOStatement

PDO::query() 在单次函数调用内执行 SQL 语句，以 PDOStatement 对象形式返回结果集（如果有数据的话）。

如果反复调用同一个查询，用 PDO::prepare() 准备 PDOStatement 对象，并用 PDOStatement::execute() 执行语句，将具有更好的性能。

如果没有完整获取结果集内的数据，就调用下一个 PDO::query()，将可能调用失败。 应当在执行下一个 PDO::query() 前，先用 PDOStatement::closeCursor() 释放数据库PDOStatement 关联的资源。

Note:

如果传入函数的参数数量超过一个，多余的参数将相当于调用结果对象 PDOStatement::setFetchMode() 方法。

参数

statement

需要准备、执行的 SQL 语句。

查询里的数据应该用恰当的形式转义。

返回值

PDO::query() 返回 PDOStatement 对象，或在失败时返回 false。

范例

Example #1 展示 PDO::query 的使用

PDO::query() 一个不错的功能是：执行 SELECT 语句，并能够循环遍历结果集。

<?php
function getFruit($conn) {
    $sql = 'SELECT name, color, calories FROM fruit ORDER BY name';
    foreach ($conn->query($sql) as $row) {
        print $row['name'] . "\t";
        print $row['color'] . "\t";
        print $row['calories'] . "\n";
    }
}
?>

以上例程会输出：

apple   red     150
banana  yellow  250
kiwi    brown   75
lemon   yellow  25
orange  orange  300
pear    green   150
watermelon      pink    90

参见

  • PDO::exec() - 执行一条 SQL 语句，并返回受影响的行数
  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::execute() - 执行一条预处理语句


为 SQL 查询里的字符串添加引号

  • ? PDO::query
  • PDO::rollBack ?
  • PHP Manual
  • PDO
  • 为 SQL 查询里的字符串添加引号

PDO::quote

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.1)

PDO::quote — 为 SQL 查询里的字符串添加引号

说明

public PDO::quote ( string $string , int $parameter_type = PDO::PARAM_STR ) : string

PDO::quote() 为输入的字符串添加引号（如果有需要），并对特殊字符进行转义，且引号的风格和底层驱动适配。

如果使用此函数构建 SQL 语句，强烈建议使用 PDO::prepare() 配合参数构建，而不是用 PDO::quote() 把用户输入的数据拼接进 SQL 语句。 使用 prepare 语句处理参数，不仅仅可移植性更好，而且更方便、免疫 SQL 注入；相对于拼接 SQL 更快，客户端和服务器都能缓存编译后的 SQL 查询。

不是所有的 PDO 驱动都实现了此功能（例如 PDO_ODBC）。 考虑使用 prepare 代替。

Caution

安全性：默认字符集

字符集不仅仅要在数据库服务器上设置，也要为数据库连接设置（取决于驱动），它影响了 PDO::quote()。 更多信息可参考PDO 驱动文档。

参数

string

要添加引号的字符串。

parameter_type

为驱动提示数据类型，以便选择引号风格。

返回值

返回加引号的字符串，理论上可以安全用于 SQL 语句。 如果驱动不支持这种方式，将返回 false 。

范例

Example #1 普通字符串加引号

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/* 简单字符串 */
$string = 'Nice';
print "Unquoted string: $string\n";
print "Quoted string: " . $conn->quote($string) . "\n";
?>

以上例程会输出：

Unquoted string: Nice
Quoted string: 'Nice'

Example #2 危险字符串加引号

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/* 危险字符串 */
$string = 'Naughty \' string';
print "Unquoted string: $string\n";
print "Quoted string:" . $conn->quote($string) . "\n";
?>

以上例程会输出：

Unquoted string: Naughty ' string
Quoted string: 'Naughty '' string'

Example #3 复杂字符串加引号

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/* 复杂字符串 */
$string = "Co'mpl''ex \"st'\"ring";
print "Unquoted string: $string\n";
print "Quoted string: " . $conn->quote($string) . "\n";
?>

以上例程会输出：

Unquoted string: Co'mpl''ex "st'"ring
Quoted string: 'Co''mpl''''ex "st''"ring'

参见

  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::execute() - 执行一条预处理语句


回滚一个事务

  • ? PDO::quote
  • PDO::setAttribute ?
  • PHP Manual
  • PDO
  • 回滚一个事务

PDO::rollBack

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::rollBack — 回滚一个事务

说明

PDO::rollBack ( ) : bool

回滚由 PDO::beginTransaction() 发起的当前事务。如果没有事务激活，将抛出一个 PDOException 异常。

如果数据库被设置成自动提交模式，此函数（方法）在回滚事务之后将恢复自动提交模式。

包括 MySQL 在内的一些数据库， 当在一个事务内有类似删除或创建数据表等 DLL 语句时，会自动导致一个隐式地提交。隐式地提交将无法回滚此事务范围内的任何更改。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 回滚一个事务

下面例子在回滚更改之前开始一个事务并发出两条修改数据库的语句。但在 MySQL 中，DROP TABLE 语句自动提交事务，因此在此事务内的任何更改都不会被回滚。

<?php
/* 开始一个事务，关闭自动提交 */
$dbh->beginTransaction();

/* 更改数据库架构和数据  */
$sth = $dbh->exec("DROP TABLE fruit");
$sth = $dbh->exec("UPDATE dessert
    SET name = 'hamburger'");

/*  识别错误且回滚更改  */
$dbh->rollBack();

/*  此时数据库连接恢复到自动提交模式  */
?>

参见

  • PDO::beginTransaction() - 启动一个事务
  • PDO::commit() - 提交一个事务
  • 事务和自动提交


设置属性

  • ? PDO::rollBack
  • PDOStatement ?
  • PHP Manual
  • PDO
  • 设置属性

PDO::setAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::setAttribute — 设置属性

说明

PDO::setAttribute ( int $attribute , mixed $value ) : bool

设置数据库句柄属性。下面列出了一些可用的通用属性；有些驱动可能使用另外的特定属性。

  • PDO::ATTR_CASE：强制列名为指定的大小写。

    • PDO::CASE_LOWER：强制列名小写。

    • PDO::CASE_NATURAL：保留数据库驱动返回的列名。

    • PDO::CASE_UPPER：强制列名大写。

  • PDO::ATTR_ERRMODE：错误报告。

    • PDO::ERRMODE_SILENT： 仅设置错误代码。

    • PDO::ERRMODE_WARNING: 引发 E_WARNING 错误

    • PDO::ERRMODE_EXCEPTION: 抛出 exceptions 异常。

  • PDO::ATTR_ORACLE_NULLS （在所有驱动中都可用，不仅限于Oracle）： 转换 NULL 和空字符串。

    • PDO::NULL_NATURAL: 不转换。

    • PDO::NULL_EMPTY_STRING： 将空字符串转换成 null。

    • PDO::NULL_TO_STRING: 将 NULL 转换成空字符串。

  • PDO::ATTR_STRINGIFY_FETCHES: 提取的时候将数值转换为字符串。 Requires bool.

  • PDO::ATTR_STATEMENT_CLASS： 设置从PDOStatement派生的用户提供的语句类。 不能用于持久的PDO实例。 需要 array(string 类名, array(mixed 构造函数的参数))。

  • PDO::ATTR_TIMEOUT： 指定超时的秒数。并非所有驱动都支持此选项，这意味着驱动和驱动之间可能会有差异。比如，SQLite等待的时间达到此值后就放弃获取可写锁，但其他驱动可能会将此值解释为一个连接或读取超时的间隔。 需要 int 类型。

  • PDO::ATTR_AUTOCOMMIT （在OCI，Firebird 以及 MySQL中可用）： 是否自动提交每个单独的语句。

  • PDO::ATTR_EMULATE_PREPARES 启用或禁用预处理语句的模拟。 有些驱动不支持或有限度地支持本地预处理。使用此设置强制PDO总是模拟预处理语句（如果为 true ），或试着使用本地预处理语句（如果为 false）。如果驱动不能成功预处理当前查询，它将总是回到模拟预处理语句上。 需要 bool 类型。

  • PDO::MYSQL_ATTR_USE_BUFFERED_QUERY （在MySQL中可用）： 使用缓冲查询。

  • PDO::ATTR_DEFAULT_FETCH_MODE： 设置默认的提取模式。关于模式的说明可以在 PDOStatement::fetch() 文档找到。

返回值

成功时返回 true， 或者在失败时返回 false。


PDOStatement 类

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 1.0.0)

简介

代表一条预处理语句，并在该语句被执行后代表一个相关的结果集。

类摘要

PDOStatement implements Traversable {
/* 属性 */
readonly string $queryString;
/* 方法 */
bindColumn ( mixed $column , mixed &$param , int $type = ? , int $maxlen = ? , mixed $driverdata = ? ) : bool
bindParam ( mixed $parameter , mixed &$variable , int $data_type = PDO::PARAM_STR , int $length = ? , mixed $driver_options = ? ) : bool
bindValue ( mixed $parameter , mixed $value , int $data_type = PDO::PARAM_STR ) : bool
closeCursor ( ) : bool
columnCount ( ) : int
debugDumpParams ( ) : bool
errorCode ( ) : string
errorInfo ( ) : array
execute ( array $input_parameters = ? ) : bool
fetch ( int $fetch_style = ? , int $cursor_orientation = PDO::FETCH_ORI_NEXT , int $cursor_offset = 0 ) : mixed
fetchAll ( int $fetch_style = ? , mixed $fetch_argument = ? , array $ctor_args = array() ) : array
fetchColumn ( int $column_number = 0 ) : string
fetchObject ( string $class_name = "stdClass" , array $ctor_args = ? ) : mixed
getAttribute ( int $attribute ) : mixed
getColumnMeta ( int $column ) : array
nextRowset ( ) : bool
rowCount ( ) : int
setAttribute ( int $attribute , mixed $value ) : bool
setFetchMode ( int $mode ) : bool
}

属性

queryString

所用的查询字符串

Table of Contents

  • PDOStatement::bindColumn — 绑定一列到一个 PHP 变量
  • PDOStatement::bindParam — 绑定一个参数到指定的变量名
  • PDOStatement::bindValue — 把一个值绑定到一个参数
  • PDOStatement::closeCursor — 关闭游标，使语句能再次被执行。
  • PDOStatement::columnCount — 返回结果集中的列数
  • PDOStatement::debugDumpParams — 打印一条 SQL 预处理命令
  • PDOStatement::errorCode — 获取跟上一次语句句柄操作相关的 SQLSTATE
  • PDOStatement::errorInfo — 获取跟上一次语句句柄操作相关的扩展错误信息
  • PDOStatement::execute — 执行一条预处理语句
  • PDOStatement::fetch — 从结果集中获取下一行
  • PDOStatement::fetchAll — 返回一个包含结果集中所有行的数组
  • PDOStatement::fetchColumn — 从结果集中的下一行返回单独的一列。
  • PDOStatement::fetchObject — 获取下一行并作为一个对象返回。
  • PDOStatement::getAttribute — 检索一个语句属性
  • PDOStatement::getColumnMeta — 返回结果集中一列的元数据
  • PDOStatement::nextRowset — 在一个多行集语句句柄中推进到下一个行集
  • PDOStatement::rowCount — 返回受上一个 SQL 语句影响的行数
  • PDOStatement::setAttribute — 设置一个语句属性
  • PDOStatement::setFetchMode — 为语句设置默认的获取模式。


绑定一列到一个 PHP 变量

  • ? PDOStatement
  • PDOStatement::bindParam ?
  • PHP Manual
  • PDOStatement
  • 绑定一列到一个 PHP 变量

PDOStatement::bindColumn

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::bindColumn — 绑定一列到一个 PHP 变量

说明

PDOStatement::bindColumn ( mixed $column , mixed &$param , int $type = ? , int $maxlen = ? , mixed $driverdata = ? ) : bool

安排一个特定的变量绑定到一个查询结果集中给定的列。每次调用 PDOStatement::fetch() 或 PDOStatement::fetchAll() 都将更新所有绑定到列的变量。

Note:

在语句执行前 PDO 有关列的信息并非总是可用，可移植的应用应在 PDOStatement::execute() 之后 调用此函数（方法）。

但是，当使用 PgSQL 驱动 时，要想能绑定一个 LOB 列作为流，应用程序必须在调用 PDOStatement::execute() 之前 调用此方法，否则大对象 OID 作为一个整数返回。

参数

column

结果集中的列号（从1开始索引）或列名。如果使用列名，注意名称应该与由驱动返回的列名大小写保持一致。

param

将绑定到列的 PHP 变量名称

type

通过 PDO::PARAM_* 常量指定的参数的数据类型。

maxlen

预分配提示。

driverdata

驱动的可选参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 把结果集输出绑定到 PHP 变量

绑定结果集中的列到PHP变量是一种使每行包含的数据在应用程序中立即可用的有效方法。下面的例子演示了 PDO 怎样用多种选项和缺省值绑定和检索列。

<?php
function readData($dbh) {
  $sql = 'SELECT name, colour, calories FROM fruit';
  try {
    $stmt = $dbh->prepare($sql);
    $stmt->execute();

    /*  通过列号绑定  */
    $stmt->bindColumn(1, $name);
    $stmt->bindColumn(2, $colour);

    /*  通过列名绑定  */
    $stmt->bindColumn('calories', $cals);

    while ($row = $stmt->fetch(PDO::FETCH_BOUND)) {
      $data = $name . "\t" . $colour . "\t" . $cals . "\n";
      print $data;
    }
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}
readData($dbh);
?>

以上例程会输出：

apple   red     150
banana  yellow  175
kiwi    green   75
orange  orange  150
mango   red     200
strawberry      red     25

参见

  • PDOStatement::execute() - 执行一条预处理语句
  • PDOStatement::fetch() - 从结果集中获取下一行
  • PDOStatement::fetchAll() - 返回一个包含结果集中所有行的数组
  • PDOStatement::fetchColumn() - 从结果集中的下一行返回单独的一列。


绑定一个参数到指定的变量名

  • ? PDOStatement::bindColumn
  • PDOStatement::bindValue ?
  • PHP Manual
  • PDOStatement
  • 绑定一个参数到指定的变量名

PDOStatement::bindParam

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::bindParam — 绑定一个参数到指定的变量名

说明

PDOStatement::bindParam ( mixed $parameter , mixed &$variable , int $data_type = PDO::PARAM_STR , int $length = ? , mixed $driver_options = ? ) : bool

绑定一个PHP变量到用作预处理的SQL语句中的对应命名占位符或问号占位符。 不同于 PDOStatement::bindValue() ，此变量作为引用被绑定，并只在 PDOStatement::execute() 被调用的时候才取其值。

大多数参数是输入参数，即，参数以只读的方式用来建立查询。一些驱动支持调用存储过程并作为输出参数返回数据，一些支持作为输入/输出参数，既发送数据又接收更新后的数据。

参数

parameter

参数标识符。对于使用命名占位符的预处理语句，应是类似 :name 形式的参数名。对于使用问号占位符的预处理语句，应是以1开始索引的参数位置。

variable

绑定到 SQL 语句参数的 PHP 变量名。

data_type

使用 PDO::PARAM_* 常量明确地指定参数的类型。要从一个存储过程中返回一个 INOUT 参数，需要为 data_type 参数使用按位或操作符去设置 PDO::PARAM_INPUT_OUTPUT 位。

length

数据类型的长度。为表明参数是一个存储过程的 OUT 参数，必须明确地设置此长度。

driver_options

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 执行一条使用命名占位符的预处理语句

<?php
/* 通过绑定的 PHP 变量执行一条预处理语句  */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindParam(':calories', $calories, PDO::PARAM_INT);
$sth->bindParam(':colour', $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Example #2 执行一条使用问号占位符的预处理语句

<?php
/*  通过绑定的 PHP 变量执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindParam(1, $calories, PDO::PARAM_INT);
$sth->bindParam(2, $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Example #3 使用 INOUT 参数调用一个存储过程

<?php
/* 使用 INOUT 参数调用一个存储过程 */
$colour = 'red';
$sth = $dbh->prepare('CALL puree_fruit(?)');
$sth->bindParam(1, $colour, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 12);
$sth->execute();
print("After pureeing fruit, the colour is: $colour");
?>

参见

  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::execute() - 执行一条预处理语句
  • PDOStatement::bindValue() - 把一个值绑定到一个参数


把一个值绑定到一个参数

  • ? PDOStatement::bindParam
  • PDOStatement::closeCursor ?
  • PHP Manual
  • PDOStatement
  • 把一个值绑定到一个参数

PDOStatement::bindValue

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 1.0.0)

PDOStatement::bindValue — 把一个值绑定到一个参数

说明

PDOStatement::bindValue ( mixed $parameter , mixed $value , int $data_type = PDO::PARAM_STR ) : bool

绑定一个值到用作预处理的 SQL 语句中的对应命名占位符或问号占位符。

参数

parameter

参数标识符。对于使用命名占位符的预处理语句，应是类似 :name 形式的参数名。对于使用问号占位符的预处理语句，应是以1开始索引的参数位置。

value

绑定到参数的值

data_type

使用 PDO::PARAM_* 常量明确地指定参数的类型。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 执行一条使用命名占位符的预处理语句

<?php
/* 通过绑定的 PHP 变量执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindValue(':calories', $calories, PDO::PARAM_INT);
$sth->bindValue(':colour', $colour, PDO::PARAM_STR);
$sth->execute();
?>

Example #2 执行一条使用问号占位符的预处理语句

<?php
/* 通过绑定的 PHP 变量执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindValue(1, $calories, PDO::PARAM_INT);
$sth->bindValue(2, $colour, PDO::PARAM_STR);
$sth->execute();
?>

参见

  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::execute() - 执行一条预处理语句
  • PDOStatement::bindParam() - 绑定一个参数到指定的变量名


关闭游标，使语句能再次被执行。

  • ? PDOStatement::bindValue
  • PDOStatement::columnCount ?
  • PHP Manual
  • PDOStatement
  • 关闭游标，使语句能再次被执行。

PDOStatement::closeCursor

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement::closeCursor — 关闭游标，使语句能再次被执行。

说明

PDOStatement::closeCursor ( ) : bool

PDOStatement::closeCursor() 释放到数据库服务的连接，以便发出其他 SQL 语句，但使语句处于一个可以被再次执行的状态。

当上一个执行的 PDOStatement 对象仍有未取行时，此方法对那些不支持再执行一个 PDOStatement 对象的数据库驱动非常有用。 如果数据库驱动受此限制，则可能出现失序错误的问题。

PDOStatement::closeCursor() 要么是一个可选驱动的特有方法（效率最高）来实现，要么是在没有驱动特定的功能时作为一般的PDO 备用来实现。一般的备用语义上与下面的 PHP 代码相同：

<?php
do {
    while ($stmt->fetch())
        ;
    if (!$stmt->nextRowset())
        break;
} while (true);
?>

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 一个 PDOStatement::closeCursor() 的例子

在下面例子中，$stmt PDOStatement 对象返回多行，但应用程序只取第一行，让 PDOStatement 对象处于一个有未取行的状态。为确保应用程序对所有数据库驱动都能正常运行，在执行 $otherStmt PDOStatement 对象前，$stmt 调用一次 PDOStatement::closeCursor() 。

<?php
/* 创建一个 PDOStatement 对象 */
$stmt = $dbh->prepare('SELECT foo FROM bar');

/* 创建第二个 PDOStatement 对象 */
$otherStmt = $dbh->prepare('SELECT foobaz FROM foobar');

/* 执行第一条语句 */
$stmt->execute();

/*  从结果集中只取出第一行 */
$stmt->fetch();

/* The following call to closeCursor() may be required by some drivers */
$stmt->closeCursor();

/*  现在可以执行第二条语句了 */
$otherStmt->execute();
?>

参见

  • PDOStatement::execute() - 执行一条预处理语句


返回结果集中的列数

  • ? PDOStatement::closeCursor
  • PDOStatement::debugDumpParams ?
  • PHP Manual
  • PDOStatement
  • 返回结果集中的列数

PDOStatement::columnCount

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::columnCount — 返回结果集中的列数

说明

PDOStatement::columnCount ( ) : int

使用 PDOStatement::columnCount() 返回由 PDOStatement 对象代表的结果集中的列数。

如果是由 PDO::query() 返回的 PDOStatement 对象，则列数计算立即可用。

如果是由 PDO::prepare() 返回的 PDOStatement 对象，则在调用 PDOStatement::execute() 之前都不能准确地计算出列数。

返回值

返回由 PDOStatement 对象代表的结果集中的列数。如果没有结果集，则 PDOStatement::columnCount() 返回 0。

范例

Example #1 计算列数

下面例子演示如何使用 PDOStatement::columnCount() 操作一个结果集和一个空集。

<?php
$dbh = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');

$sth = $dbh->prepare("SELECT name, colour FROM fruit");

/*  计算一个（不存在）的结果集中的列数 */
$colcount = $sth->columnCount();
print("Before execute(), result set has $colcount columns (should be 0)\n");

$sth->execute();

/* 计算结果集中的列数 */
$colcount = $sth->columnCount();
print("After execute(), result set has $colcount columns (should be 2)\n");

?>

以上例程会输出：

Before execute(), result set has 0 columns (should be 0)
After execute(), result set has 2 columns (should be 2)

参见

  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::execute() - 执行一条预处理语句
  • PDOStatement::rowCount() - 返回受上一个 SQL 语句影响的行数


打印一条 SQL 预处理命令

  • ? PDOStatement::columnCount
  • PDOStatement::errorCode ?
  • PHP Manual
  • PDOStatement
  • 打印一条 SQL 预处理命令

PDOStatement::debugDumpParams

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement::debugDumpParams — 打印一条 SQL 预处理命令

说明

PDOStatement::debugDumpParams ( ) : bool

直接打印出一条预处理语句包含的信息。提供正在使用的 SQL 查询、所用参数（Params）的数目、参数的清单、参数名、用一个整数表示的参数类型（paramtype）、键名或位置、值、以及在查询中的位置（如果当前 POD 驱动不支持，则为-1）。

此为一个用于调试的功能，在正常输出的情况下直接输出数据。

Tip

和直接将结果输出到浏览器一样，可使用输出控制函数来捕获当前函数的输出，然后(例如)保存到一个 string 中。

只打印此时此刻语句中的参数。额外的参数不存储在语句中，也就不会被输出。

返回值

没有返回值。

范例

Example #1 PDOStatement::debugDumpParams() 使用命名参数的例子

<?php
/* 通过绑定 PHP 变量执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindParam(':calories', $calories, PDO::PARAM_INT);
$sth->bindValue(':colour', $colour, PDO::PARAM_STR, 12);
$sth->execute();

$sth->debugDumpParams();

?>

以上例程会输出：

SQL: [96] SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour
Params:  2
Key: Name: [9] :calories
paramno=-1
name=[9] ":calories"
is_param=1
param_type=1
Key: Name: [7] :colour
paramno=-1
name=[7] ":colour"
is_param=1
param_type=2

Example #2 PDOStatement::debugDumpParams() 使用未命名参数的例子

<?php

/* 通过绑定 PHP 变量执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$name = 'apple';

$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindParam(1, $calories, PDO::PARAM_INT);
$sth->bindValue(2, $colour, PDO::PARAM_STR);
$sth->execute();

$sth->debugDumpParams();

?>

以上例程会输出：

SQL: [82] SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?
Params:  2
Key: Position #0:
paramno=0
name=[0] ""
is_param=1
param_type=1
Key: Position #1:
paramno=1
name=[0] ""
is_param=1
param_type=2

参见

  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::bindParam() - 绑定一个参数到指定的变量名
  • PDOStatement::bindValue() - 把一个值绑定到一个参数


获取跟上一次语句句柄操作相关的 SQLSTATE

  • ? PDOStatement::debugDumpParams
  • PDOStatement::errorInfo ?
  • PHP Manual
  • PDOStatement
  • 获取跟上一次语句句柄操作相关的 SQLSTATE

PDOStatement::errorCode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::errorCode — 获取跟上一次语句句柄操作相关的 SQLSTATE

说明

PDOStatement::errorCode ( ) : string

返回值

与 PDO::errorCode() 相同，只是 PDOStatement::errorCode() 只取回 PDOStatement 对象执行操作中的错误码。

范例

Example #1 取回一个 SQLSTATE 码

<?php
/* 引发一个错误 --  BONES 数据表不存在 */
$err = $dbh->prepare('SELECT skull FROM bones');
$err->execute();

echo "\nPDOStatement::errorCode(): ";
print $err->errorCode();
?>

以上例程会输出：

PDOStatement::errorCode(): 42S02

参见

  • PDO::errorCode() - 获取跟数据库句柄上一次操作相关的 SQLSTATE
  • PDO::errorInfo() - Fetch extended error information associated with the last operation on the database handle
  • PDOStatement::errorInfo() - 获取跟上一次语句句柄操作相关的扩展错误信息


获取跟上一次语句句柄操作相关的扩展错误信息

  • ? PDOStatement::errorCode
  • PDOStatement::execute ?
  • PHP Manual
  • PDOStatement
  • 获取跟上一次语句句柄操作相关的扩展错误信息

PDOStatement::errorInfo

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::errorInfo — 获取跟上一次语句句柄操作相关的扩展错误信息

说明

PDOStatement::errorInfo ( ) : array

返回值

PDOStatement::errorInfo() 返回一个关于上一次语句句柄执行操作的错误信息的数组 。该数组包含下列字段：

Element | Information
0 | SQLSTATE 错误码（一个由5个字母或数字组成的在 ANSI SQL 标准中定义的标识符）。
1 | 具体驱动错误码。
2 | 具体驱动错误信息。

范例

Example #1 显示连接到DB2数据库的 PDO_ODBC 连接的 errorInfo() 的字段

<?php
/* 激发一个错误 --  BONES 数据表不存在 */
$sth = $dbh->prepare('SELECT skull FROM bones');
$sth->execute();

echo "\nPDOStatement::errorInfo():\n";
$arr = $sth->errorInfo();
print_r($arr);
?>

以上例程会输出：

PDOStatement::errorInfo():
Array
(
    [0] => 42S02
    [1] => -204
    [2] => [IBM][CLI Driver][DB2/LINUX] SQL0204N  "DANIELS.BONES" is an undefined name.  SQLSTATE=42704
)

参见

  • PDO::errorCode() - 获取跟数据库句柄上一次操作相关的 SQLSTATE
  • PDO::errorInfo() - Fetch extended error information associated with the last operation on the database handle
  • PDOStatement::errorCode() - 获取跟上一次语句句柄操作相关的 SQLSTATE


执行一条预处理语句

  • ? PDOStatement::errorInfo
  • PDOStatement::fetch ?
  • PHP Manual
  • PDOStatement
  • 执行一条预处理语句

PDOStatement::execute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::execute — 执行一条预处理语句

说明

PDOStatement::execute ( array $input_parameters = ? ) : bool

执行预处理过的语句。如果预处理过的语句含有参数标记，必须选择下面其中一种做法：

  • 调用 PDOStatement::bindParam() 绑定 PHP 变量到参数标记：如果有的话，通过关联参数标记绑定的变量来传递输入值和取得输出值

  • 或传递一个只作为输入参数值的数组

参数

input_parameters

一个元素个数和将被执行的 SQL 语句中绑定的参数一样多的数组。所有的值作为 PDO::PARAM_STR 对待。

不能绑定多个值到一个单独的参数；比如，不能绑定两个值到 IN（）子句中一个单独的命名参数。

绑定的值不能超过指定的个数。如果在 input_parameters 中存在比 PDO::prepare() 预处理的SQL 指定的多的键名，则此语句将会失败并发出一个错误。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.2.0 | input_parameters 中的键名必须和 SQL 中声明的相匹配。PHP 5.2.0 之前默认忽略。

范例

Example #1 执行一条绑定变量的预处理语句

<?php
/*  通过绑定 PHP 变量执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindParam(':calories', $calories, PDO::PARAM_INT);
$sth->bindParam(':colour', $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Example #2 使用一个含有插入值的数组执行一条预处理语句（命名参数）

<?php
/* 通过传递一个含有插入值的数组执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->execute(array(':calories' => $calories, ':colour' => $colour));
?>

Example #3 使用一个含有插入值的数组执行一条预处理语句（占位符）

<?php
/*  通过传递一个插入值的数组执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->execute(array($calories, $colour));
?>

Example #4 执行一条问号占位符的预处理语句

<?php
/* 通过绑定 PHP 变量执行一条预处理语句 */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindParam(1, $calories, PDO::PARAM_INT);
$sth->bindParam(2, $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Example #5 使用数组执行一条含有 IN 子句的预处理语句

<?php
/*  使用一个数组的值执行一条含有 IN 子句的预处理语句 */
$params = array(1, 21, 63, 171);
/*  创建一个填充了和params相同数量占位符的字符串 */
$place_holders = implode(',', array_fill(0, count($params), '?'));

/*
    对于 $params 数组中的每个值，要预处理的语句包含足够的未命名占位符 。
    语句被执行时， $params 数组中的值被绑定到预处理语句中的占位符。
    这和使用 PDOStatement::bindParam() 不一样，因为它需要一个引用变量。
    PDOStatement::execute() 仅作为通过值绑定的替代。
*/
$sth = $dbh->prepare("SELECT id, name FROM contacts WHERE id IN ($place_holders)");
$sth->execute($params);
?>

注释

Note:

有些驱动在执行下一条语句前需要 关闭游标 。

参见

  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::bindParam() - 绑定一个参数到指定的变量名
  • PDOStatement::fetch() - 从结果集中获取下一行
  • PDOStatement::fetchAll() - 返回一个包含结果集中所有行的数组
  • PDOStatement::fetchColumn() - 从结果集中的下一行返回单独的一列。


从结果集中获取下一行

  • ? PDOStatement::execute
  • PDOStatement::fetchAll ?
  • PHP Manual
  • PDOStatement
  • 从结果集中获取下一行

PDOStatement::fetch

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::fetch — 从结果集中获取下一行

说明

PDOStatement::fetch ( int $fetch_style = ? , int $cursor_orientation = PDO::FETCH_ORI_NEXT , int $cursor_offset = 0 ) : mixed

从一个 PDOStatement 对象相关的结果集中获取下一行。fetch_style 参数决定 POD 如何返回行。

参数

fetch_style

控制下一行如何返回给调用者。此值必须是 PDO::FETCH_* 系列常量中的一个，缺省为 PDO::ATTR_DEFAULT_FETCH_MODE 的值 （默认为 PDO::FETCH_BOTH ）。

  • PDO::FETCH_ASSOC：返回一个索引为结果集列名的数组

  • PDO::FETCH_BOTH（默认）：返回一个索引为结果集列名和以0开始的列号的数组

  • PDO::FETCH_BOUND：返回 true ，并分配结果集中的列值给 PDOStatement::bindColumn() 方法绑定的 PHP 变量。

  • PDO::FETCH_CLASS：返回一个请求类的新实例，映射结果集中的列名到类中对应的属性名。如果 fetch_style 包含 PDO::FETCH_CLASSTYPE（例如：PDO::FETCH_CLASS | PDO::FETCH_CLASSTYPE），则类名由第一列的值决定

  • PDO::FETCH_INTO：更新一个被请求类已存在的实例，映射结果集中的列到类中命名的属性

  • PDO::FETCH_LAZY：结合使用 PDO::FETCH_BOTH 和 PDO::FETCH_OBJ，创建供用来访问的对象变量名

  • PDO::FETCH_NUM：返回一个索引为以0开始的结果集列号的数组

  • PDO::FETCH_OBJ：返回一个属性名对应结果集列名的匿名对象

cursor_orientation

对于 一个 PDOStatement 对象表示的可滚动游标，该值决定了哪一行将被返回给调用者。此值必须是 PDO::FETCH_ORI_* 系列常量中的一个，默认为 PDO::FETCH_ORI_NEXT。要想让 PDOStatement 对象使用可滚动游标，必须在用 PDO::prepare() 预处理SQL语句时，设置 PDO::ATTR_CURSOR 属性为 PDO::CURSOR_SCROLL。

offset

对于一个 cursor_orientation 参数设置为 PDO::FETCH_ORI_ABS 的PDOStatement 对象代表的可滚动游标，此值指定结果集中想要获取行的绝对行号。

对于一个 cursor_orientation 参数设置为 PDO::FETCH_ORI_REL 的PDOStatement 对象代表的可滚动游标，此值指定想要获取行相对于调用 PDOStatement::fetch() 前游标的位置

返回值

此函数（方法）成功时返回的值依赖于提取类型。在所有情况下，失败都返回 false 。

范例

Example #1 使用不同的提取方式获取行

<?php
$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* 运用 PDOStatement::fetch 风格 */
print("PDO::FETCH_ASSOC: ");
print("Return next row as an array indexed by column name\n");
$result = $sth->fetch(PDO::FETCH_ASSOC);
print_r($result);
print("\n");

print("PDO::FETCH_BOTH: ");
print("Return next row as an array indexed by both column name and number\n");
$result = $sth->fetch(PDO::FETCH_BOTH);
print_r($result);
print("\n");

print("PDO::FETCH_LAZY: ");
print("Return next row as an anonymous object with column names as properties\n");
$result = $sth->fetch(PDO::FETCH_LAZY);
print_r($result);
print("\n");

print("PDO::FETCH_OBJ: ");
print("Return next row as an anonymous object with column names as properties\n");
$result = $sth->fetch(PDO::FETCH_OBJ);
print $result->NAME;
print("\n");
?>

以上例程会输出：

PDO::FETCH_ASSOC: Return next row as an array indexed by column name
Array
(
    [NAME] => apple
    [COLOUR] => red
)

PDO::FETCH_BOTH: Return next row as an array indexed by both column name and number
Array
(
    [NAME] => banana
    [0] => banana
    [COLOUR] => yellow
    [1] => yellow
)

PDO::FETCH_LAZY: Return next row as an anonymous object with column names as properties
PDORow Object
(
    [NAME] => orange
    [COLOUR] => orange
)

PDO::FETCH_OBJ: Return next row as an anonymous object with column names as properties
kiwi

Example #2 使用一个可滚动游标获取行

<?php
function readDataForwards($dbh) {
  $sql = 'SELECT hand, won, bet FROM mynumbers ORDER BY BET';
  try {
    $stmt = $dbh->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_SCROLL));
    $stmt->execute();
    while ($row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_NEXT)) {
      $data = $row[0] . "\t" . $row[1] . "\t" . $row[2] . "\n";
      print $data;
    }
    $stmt = null;
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}
function readDataBackwards($dbh) {
  $sql = 'SELECT hand, won, bet FROM mynumbers ORDER BY bet';
  try {
    $stmt = $dbh->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_SCROLL));
    $stmt->execute();
    $row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_LAST);
    do {
      $data = $row[0] . "\t" . $row[1] . "\t" . $row[2] . "\n";
      print $data;
    } while ($row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_PRIOR));
    $stmt = null;
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}

print "Reading forwards:\n";
readDataForwards($conn);

print "Reading backwards:\n";
readDataBackwards($conn);
?>

以上例程会输出：

Reading forwards:
21    10    5
16    0     5
19    20    10

Reading backwards:
19    20    10
16    0     5
21    10    5

参见

  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::execute() - 执行一条预处理语句
  • PDOStatement::fetchAll() - 返回一个包含结果集中所有行的数组
  • PDOStatement::fetchColumn() - 从结果集中的下一行返回单独的一列。
  • PDOStatement::fetchObject() - 获取下一行并作为一个对象返回。
  • PDOStatement::setFetchMode() - 为语句设置默认的获取模式。


返回一个包含结果集中所有行的数组

  • ? PDOStatement::fetch
  • PDOStatement::fetchColumn ?
  • PHP Manual
  • PDOStatement
  • 返回一个包含结果集中所有行的数组

PDOStatement::fetchAll

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::fetchAll — 返回一个包含结果集中所有行的数组

说明

PDOStatement::fetchAll ( int $fetch_style = ? , mixed $fetch_argument = ? , array $ctor_args = array() ) : array

参数

fetch_style

控制返回数组的内容如同 PDOStatement::fetch() 文档中记载的一样。默认为 PDO::ATTR_DEFAULT_FETCH_MODE 的值（ 其缺省值为 PDO::FETCH_BOTH ）

想要返回一个包含结果集中单独一列所有值的数组，需要指定 PDO::FETCH_COLUMN 。通过指定 column-index 参数获取想要的列。

想要获取结果集中单独一列的唯一值，需要将 PDO::FETCH_COLUMN 和 PDO::FETCH_UNIQUE 按位或。

想要返回一个根据指定列把值分组后的关联数组，需要将 PDO::FETCH_COLUMN 和 PDO::FETCH_GROUP 按位或。

fetch_argument

根据 fetch_style 参数的值，此参数有不同的意义：

  • PDO::FETCH_COLUMN：返回指定以0开始索引的列。

  • PDO::FETCH_CLASS：返回指定类的实例，映射每行的列到类中对应的属性名。

  • PDO::FETCH_FUNC：将每行的列作为参数传递给指定的函数，并返回调用函数后的结果。

ctor_args

当 fetch_style 参数为 PDO::FETCH_CLASS 时，自定义类的构造函数的参数。

返回值

PDOStatement::fetchAll() 返回一个包含结果集中所有剩余行的数组。此数组的每一行要么是一个列值的数组，要么是属性对应每个列名的一个对象。

使用此方法获取大结果集将导致系统负担加重且可能占用大量网络资源。与其取回所有数据后用PHP来操作，倒不如考虑使用数据库服务来处理结果集。例如，在取回数据并通过PHP处理前，在 SQL 中使用 WHERE 和 ORDER BY 子句来限定结果。

范例

Example #1 获取结果集中所有剩余的行

<?php
$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* 获取结果集中所有剩余的行 */
print("Fetch all of the remaining rows in the result set:\n");
$result = $sth->fetchAll();
print_r($result);
?>

以上例程的输出类似于：

Fetch all of the remaining rows in the result set:
Array
(
    [0] => Array
        (
            [NAME] => pear
            [0] => pear
            [COLOUR] => green
            [1] => green
        )

    [1] => Array
        (
            [NAME] => watermelon
            [0] => watermelon
            [COLOUR] => pink
            [1] => pink
        )

)

Example #2 获取结果集中单独一列的所有值

下面例子演示了如何从一个结果集中返回单独一列所有的值，尽管 SQL 语句自身可能返回每行多列。

<?php
$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* 获取第一列所有值 */
$result = $sth->fetchAll(PDO::FETCH_COLUMN, 0);
var_dump($result);
?>

以上例程的输出类似于：

Array(3)
(
    [0] =>
    string(5) => apple
    [1] =>
    string(4) => pear
    [2] =>
    string(10) => watermelon
)

Example #3 根据单独的一列把所有值分组

下面例子演示了如何返回一个根据结果集中指定列的值分组的关联数组。该数组包含三个键：返回的 apple 和 pear 数组包含了两种不同的颜色，而返回的 watermelon 数组仅包含一种颜色。

<?php
$insert = $dbh->prepare("INSERT INTO fruit(name, colour) VALUES (?, ?)");
$insert->execute(array('apple', 'green'));
$insert->execute(array('pear', 'yellow'));

$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* 根据第一列分组  */
var_dump($sth->fetchAll(PDO::FETCH_COLUMN|PDO::FETCH_GROUP));
?>

以上例程的输出类似于：

array(3) {
  ["apple"]=>
  array(2) {
    [0]=>
    string(5) "green"
    [1]=>
    string(3) "red"
  }
  ["pear"]=>
  array(2) {
    [0]=>
    string(5) "green"
    [1]=>
    string(6) "yellow"
  }
  ["watermelon"]=>
  array(1) {
    [0]=>
    string(5) "green"
  }
}

Example #4 每行结果实例化一个类

下面列子演示了 PDO::FETCH_CLASS 获取风格的行为。

<?php
class fruit {
    public $name;
    public $colour;
}

$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

$result = $sth->fetchAll(PDO::FETCH_CLASS, "fruit");
var_dump($result);
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  object(fruit)#1 (2) {
    ["name"]=>
    string(5) "apple"
    ["colour"]=>
    string(5) "green"
  }
  [1]=>
  object(fruit)#2 (2) {
    ["name"]=>
    string(4) "pear"
    ["colour"]=>
    string(6) "yellow"
  }
  [2]=>
  object(fruit)#3 (2) {
    ["name"]=>
    string(10) "watermelon"
    ["colour"]=>
    string(4) "pink"
  }
}

Example #5 每行调用一次函数

下面列子演示了 PDO::FETCH_FUNC 获取风格的行为。

<?php
function fruit($name, $colour) {
    return "{$name}: {$colour}";
}

$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

$result = $sth->fetchAll(PDO::FETCH_FUNC, "fruit");
var_dump($result);
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  string(12) "apple: green"
  [1]=>
  string(12) "pear: yellow"
  [2]=>
  string(16) "watermelon: pink"
}

参见

  • PDO::query() - 执行 SQL 语句，以 PDOStatement 对象形式返回结果集
  • PDOStatement::fetch() - 从结果集中获取下一行
  • PDOStatement::fetchColumn() - 从结果集中的下一行返回单独的一列。
  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::setFetchMode() - 为语句设置默认的获取模式。


从结果集中的下一行返回单独的一列。

  • ? PDOStatement::fetchAll
  • PDOStatement::fetchObject ?
  • PHP Manual
  • PDOStatement
  • 从结果集中的下一行返回单独的一列。

PDOStatement::fetchColumn

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement::fetchColumn — 从结果集中的下一行返回单独的一列。

说明

PDOStatement::fetchColumn ( int $column_number = 0 ) : string

从结果集中的下一行返回单独的一列，如果没有了，则返回 false 。

参数

column_number

你想从行里取回的列的索引数字（以0开始的索引）。如果没有提供值，则 PDOStatement::fetchColumn() 获取第一列。

返回值

PDOStatement::fetchColumn() 从结果集中的下一行返回单独的一列。

Warning

如果使用 PDOStatement::fetchColumn() 取回数据，则没有办法返回同一行的另外一列。

范例

Example #1 返回下一行的第一列

<?php
$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* 从结果集中的下一行获取第一列  */
print("从结果集中的下一行获取第一列：\n");
$result = $sth->fetchColumn();
print("name = $result\n");

print("从结果集中的下一行获取第二列：\n");
$result = $sth->fetchColumn(1);
print("colour = $result\n");
?>

以上例程会输出：

从结果集中的下一行获取第一列：
name = lemon
从结果集中的下一行获取第二列：
colour = red

参见

  • PDO::query() - 执行 SQL 语句，以 PDOStatement 对象形式返回结果集
  • PDOStatement::fetch() - 从结果集中获取下一行
  • PDOStatement::fetchAll() - 返回一个包含结果集中所有行的数组
  • PDO::prepare() - 准备要执行的语句，并返回语句对象
  • PDOStatement::setFetchMode() - 为语句设置默认的获取模式。


获取下一行并作为一个对象返回。

  • ? PDOStatement::fetchColumn
  • PDOStatement::getAttribute ?
  • PHP Manual
  • PDOStatement
  • 获取下一行并作为一个对象返回。

PDOStatement::fetchObject

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.4)

PDOStatement::fetchObject — 获取下一行并作为一个对象返回。

说明

PDOStatement::fetchObject ( string $class_name = "stdClass" , array $ctor_args = ? ) : mixed

获取下一行并作为一个对象返回。此函数（方法）是使用 PDO::FETCH_CLASS 或 PDO::FETCH_OBJ 风格的 PDOStatement::fetch() 的一种替代。

参数

class_name

创建类的名称。

ctor_args

此数组的元素被传递给构造函数。

返回值

返回一个属性名对应于列名的所要求类的实例， 或者在失败时返回 false.

参见

  • PDOStatement::fetch() - 从结果集中获取下一行


检索一个语句属性

  • ? PDOStatement::fetchObject
  • PDOStatement::getColumnMeta ?
  • PHP Manual
  • PDOStatement
  • 检索一个语句属性

PDOStatement::getAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::getAttribute — 检索一个语句属性

说明

PDOStatement::getAttribute ( int $attribute ) : mixed

得到语句的一个属性。当前，不存在通用的属性，只有驱动特定的属性：

  • PDO::ATTR_CURSOR_NAME （Firebird 和 ODBC 特性）： 获取 UPDATE ... WHERE CURRENT OF 的游标名称。

返回值

返回属性值。

参见

  • PDO::getAttribute() - 取回一个数据库连接的属性
  • PDO::setAttribute() - 设置属性
  • PDOStatement::setAttribute() - 设置一个语句属性


返回结果集中一列的元数据

  • ? PDOStatement::getAttribute
  • PDOStatement::nextRowset ?
  • PHP Manual
  • PDOStatement
  • 返回结果集中一列的元数据

PDOStatement::getColumnMeta

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::getColumnMeta — 返回结果集中一列的元数据

说明

PDOStatement::getColumnMeta ( int $column ) : array
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

检索一个在结果集中以0开始索引的列的元数据作为一个关联数组。

Warning

并非所有 PDO 驱动都支持 PDOStatement::getColumnMeta()。

参数

column

结果集中以0开始索引的列。

返回值

返回一个关联数组，它包含了下列表示一个单独列的元数据的值：

列的元数据
名称 | 值
native_type | 用于表示列值的 PHP 原生类型。
driver:decl_type | 在数据库中用于表示列值的 SQL 类型。如果结果集中的列是一个函数的结果，则该值不能被 PDOStatement::getColumnMeta() 返回。
flags | 任何设置于此列的标记。
name | 通过数据库返回的列名。
table | 通过数据库返回的该列的表名
len | 该列的长度。除浮点小数外通常为 -1
precision | 该列的数值精度。除浮点小数外通常为 0 。
pdo_type | 以 PDO::PARAM_* 常量为代表的列类型。

如果结果集不存在，或者是请求的列在结果集中不存在，则返回 false 。

更新日志

版本 | 说明
5.2.3 | table 字段

范例

Example #1 检索列的元数据

下面例子展示了在一个PDO_SQLITE中，检索一个通过函数（COUNT）生成单独列的元数据的结果。

<?php
$select = $DB->query('SELECT COUNT(*) FROM fruit');
$meta = $select->getColumnMeta(0);
var_dump($meta);
?>

以上例程会输出：

array(6) {
  ["native_type"]=>
  string(7) "integer"
  ["flags"]=>
  array(0) {
  }
  ["name"]=>
  string(8) "COUNT(*)"
  ["len"]=>
  int(-1)
  ["precision"]=>
  int(0)
  ["pdo_type"]=>
  int(2)
}

参见

  • PDOStatement::columnCount() - 返回结果集中的列数
  • PDOStatement::rowCount() - 返回受上一个 SQL 语句影响的行数


在一个多行集语句句柄中推进到下一个行集

  • ? PDOStatement::getColumnMeta
  • PDOStatement::rowCount ?
  • PHP Manual
  • PDOStatement
  • 在一个多行集语句句柄中推进到下一个行集

PDOStatement::nextRowset

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::nextRowset — 在一个多行集语句句柄中推进到下一个行集

说明

PDOStatement::nextRowset ( ) : bool

一些数据库服务支持返回一个以上行集（也被称为结果集）的存储过程。PDOStatement::nextRowset() 使你能够结合一个 PDOStatement 对象访问第二个以及后续的行集。上述的每个行集可以有不同的列集合。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 获取由一个存储过程返回的多个行集

下面例子展示了怎样调用一个存储过程，返回三个行集的 MULTIPLE_ROWSETS 。用一个 do / while 循环来循环调用 PDOStatement::nextRowset() 方法， 当不再有行集返回时返回 false 并结束循环。

<?php
$sql = 'CALL multiple_rowsets()';
$stmt = $conn->query($sql);
$i = 1;
do {
    $rowset = $stmt->fetchAll(PDO::FETCH_NUM);
    if ($rowset) {
        printResultSet($rowset, $i);
    }
    $i++;
} while ($stmt->nextRowset());

function printResultSet(&$rowset, $i) {
    print "Result set $i:\n";
    foreach ($rowset as $row) {
        foreach ($row as $col) {
            print $col . "\t";
        }
        print "\n";
    }
    print "\n";
}
?>

以上例程会输出：

Result set 1:
apple    red
banana   yellow

Result set 2:
orange   orange    150
banana   yellow    175

Result set 3:
lime     green
apple    red
banana   yellow

参见

  • PDOStatement::columnCount() - 返回结果集中的列数
  • PDOStatement::execute() - 执行一条预处理语句
  • PDOStatement::getColumnMeta() - 返回结果集中一列的元数据
  • PDO::query() - 执行 SQL 语句，以 PDOStatement 对象形式返回结果集


返回受上一个 SQL 语句影响的行数

  • ? PDOStatement::nextRowset
  • PDOStatement::setAttribute ?
  • PHP Manual
  • PDOStatement
  • 返回受上一个 SQL 语句影响的行数

PDOStatement::rowCount

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement::rowCount — 返回受上一个 SQL 语句影响的行数

说明

PDOStatement::rowCount ( ) : int

PDOStatement::rowCount() 返回上一个由对应的 PDOStatement 对象执行DELETE、 INSERT、或 UPDATE 语句受影响的行数。

如果上一条由相关 PDOStatement 执行的 SQL 语句是一条 SELECT 语句，有些数据可能返回由此语句返回的行数。但这种方式不能保证对所有数据有效，且对于可移植的应用不应依赖于此方式。

返回值

返回行数。

范例

Example #1 返回删除的行数

PDOStatement::rowCount() 返回受 DELETE、INSERT、 或 UPDATE 语句影响的行数。

<?php
/*  从 FRUIT 数据表中删除所有行 */
$del = $dbh->prepare('DELETE FROM fruit');
$del->execute();

/*  返回被删除的行数 */
print("Return number of rows that were deleted:\n");
$count = $del->rowCount();
print("Deleted $count rows.\n");
?>

以上例程会输出：

Return number of rows that were deleted:
Deleted 9 rows.

Example #2 计算由一个 SELECT 语句返回的行数

对于大多数数据库，PDOStatement::rowCount() 不能返回受一条 SELECT 语句影响的行数。替代的方法是，使用 PDO::query() 来发出一条和原打算中的SELECT语句有相同条件表达式的 SELECT COUNT(*) 语句，然后用 PDOStatement::fetchColumn() 来取得返回的行数。这样应用程序才能正确执行。

<?php
$sql = "SELECT COUNT(*) FROM fruit WHERE calories > 100";
if ($res = $conn->query($sql)) {

    /* 检查符合 SELECT 语句的行数 */
  if ($res->fetchColumn() > 0) {

        /* 发出一条真正的 SELECT 语句并操作返回的结果 */
         $sql = "SELECT name FROM fruit WHERE calories > 100";
       foreach ($conn->query($sql) as $row) {
           print "Name: " .  $row['NAME'] . "\n";
         }
    }
    /* 没有匹配的行 -- 执行其他 */
  else {
      print "No rows matched the query.";
    }
}

$res = null;
$conn = null;
?>

以上例程会输出：

apple
banana
orange
pear

参见

  • PDOStatement::columnCount() - 返回结果集中的列数
  • PDOStatement::fetchColumn() - 从结果集中的下一行返回单独的一列。
  • PDO::query() - 执行 SQL 语句，以 PDOStatement 对象形式返回结果集


设置一个语句属性

  • ? PDOStatement::rowCount
  • PDOStatement::setFetchMode ?
  • PHP Manual
  • PDOStatement
  • 设置一个语句属性

PDOStatement::setAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::setAttribute — 设置一个语句属性

说明

PDOStatement::setAttribute ( int $attribute , mixed $value ) : bool

给语句设置一个属性。当前，没有通用的属性可以设置，只有驱动特定的属性：

  • PDO::ATTR_CURSOR_NAME （Firebird 和 ODBC 特性）： 为 UPDATE ... WHERE CURRENT OF 设置游标名称。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • PDO::getAttribute() - 取回一个数据库连接的属性
  • PDO::setAttribute() - 设置属性
  • PDOStatement::getAttribute() - 检索一个语句属性


为语句设置默认的获取模式。

  • ? PDOStatement::setAttribute
  • PDOException ?
  • PHP Manual
  • PDOStatement
  • 为语句设置默认的获取模式。

PDOStatement::setFetchMode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement::setFetchMode — 为语句设置默认的获取模式。

说明

PDOStatement::setFetchMode ( int $mode ) : bool
PDOStatement::setFetchMode ( int $PDO::FETCH_COLUMN , int $colno ) : bool
PDOStatement::setFetchMode ( int $PDO::FETCH_CLASS , string $classname , array $ctorargs ) : bool
PDOStatement::setFetchMode ( int $PDO::FETCH_INTO , object $object ) : bool

参数

mode

获取模式必须是 PDO::FETCH_* 系列常量中的一个。

colno

列号。

classname

类名。

ctorargs

构造函数参数。

object

对象。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 设置获取模式

The following example demonstrates how PDOStatement::setFetchMode() changes the default fetch mode for a PDOStatement object.下面的例子示范如何用 PDOStatement::setFetchMode() 来为一个 PDOStatement 对象更改默认的获取模式。

<?php
$sql = 'SELECT name, colour, calories FROM fruit';
try {
  $stmt = $dbh->query($sql);
  $result = $stmt->setFetchMode(PDO::FETCH_NUM);
  while ($row = $stmt->fetch()) {
    print $row[0] . "\t" . $row[1] . "\t" . $row[2] . "\n";
  }
}
catch (PDOException $e) {
  print $e->getMessage();
}
?>

以上例程会输出：

apple   red     150
banana  yellow  250
orange  orange  300
kiwi    brown   75
lemon   yellow  25
pear    green   150
watermelon      pink    90


PDOException 异常类

(PHP 5 >= 5.1.0, PHP 7)

简介

代表一个由 PDO 产生的错误。在自己的代码不应抛出一个 PDOException 异常。关于 PHP 异常的更多信息请参见 异常 。

类摘要

PDOException extends RuntimeException {
/* 属性 */
public array $errorInfo ;
protected string $message ;
protected string $code ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

errorInfo

相当于PDO::errorInfo() 或 PDOStatement::errorInfo()

message

文本错误信息。用 Exception::getMessage() 来访问。

code

SQLSTATE 错误码。用Exception::getCode() 来访问。


PDO 驱动

Table of Contents

  • CUBRID (PDO)
  • MS SQL Server (PDO)
  • Firebird (PDO)
  • IBM (PDO)
  • Informix (PDO)
  • MySQL (PDO)
  • MS SQL Server (PDO)
  • Oracle (PDO)
  • ODBC and DB2 (PDO)
  • PostgreSQL (PDO)
  • SQLite (PDO)

下列驱动目前实现了 PDO 接口：

驱动名称 | 支持的数据库
PDO_CUBRID | Cubrid
PDO_DBLIB | FreeTDS / Microsoft SQL Server / Sybase
PDO_FIREBIRD | Firebird
PDO_IBM | IBM DB2
PDO_INFORMIX | IBM Informix Dynamic Server
PDO_MYSQL | MySQL 3.x/4.x/5.x
PDO_OCI | Oracle Call Interface
PDO_ODBC | ODBC v3 (IBM DB2, unixODBC and win32 ODBC)
PDO_PGSQL | PostgreSQL
PDO_SQLITE | SQLite 3 及 SQLite 2
PDO_SQLSRV | Microsoft SQL Server / SQL Azure


CUBRID Functions (PDO_CUBRID)

简介

PDO_CUBRID is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to CUBRID databases.

Note:

Current version of PDO_CUBRID doesn't support persistent connection now.

安装

To build the PDO_CUBRID extension, the CUBRID DBMS must be installed on the same system as PHP. PDO_CUBRID is a » PECL extension, so follow the instructions in PECL 扩展库安装 to install the PDO_CUBRID extension. Issue the configure command to point to the location of your CUBRID base dir as follows:

   $ ./configure --with-pdo-cubrid=/path/to/CUBRID[,shared]
The configure command defaults to the value of the CUBRID environment variable.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。 Detailed information about installation on Linux and Windows manually, please read build-guide.html in PECL package CUBRID for reference.

Features

PDO_CUBRID Features
Feature | Description
Scrollable cursors | PDO_CUBRID supports scrollable cursors. The default cursor type is forward only, and you can use parameter driver_options in PDO::prepare() to change cursor type.
Timeout | PDO_CUBRID supports sql statement execution timeout setting; You can use PDO::setAttribute() to set timeout value.
Autocommit_mode and Transaction PDO_CUBRID supports both autocommit_mode and transaction, and autocommit_mode is enabled by default. You can use PDO::setAttribute() to change its state.

If you use PDO::beginTransaction() to begin a transaction, it will disable autocommit_mode automatically and restore it after PDO::commit() or PDO::rollBack(). Note that before disabling the autocommit_mode, any pending work is automatically committed.

Multiple SQL Statements | PDO_CUBRID supports Multiple SQL statements. Multiple SQL statements are separated by semicolons (;)
Schema Information | PDO_CUBRID implements a function PDO::cubrid_schema() to get schema information.
LOBs PDO_CUBRID supports BLOB/CLOB data type. The LOB in PDO is represented as a stream, so you can insert LOBs by binding a stream, and get LOBs by reading a stream returned by CUBRID PDO. For example:

Example #1 Insert LOBs in CUBRID PDO

<?php
$fp = fopen('lob_test.png', 'rb');

$sql_stmt = "INSERT INTO lob_test(name, content) VALUES('lob_test.png', ?)";

$stmt = $dbh->prepare($sql_stmt);
$ret = $stmt->bindParam(1, $fp, PDO::PARAM_LOB);
$ret = $stmt->execute();
?>

Example #2 Fetch LOBs in CUBRID PDO

<?php
$sql_stmt = "SELECT content FROM lob_test WHERE name='lob_test.png'";

$stmt = $dbh->prepare($sql_stmt);
$stmt->execute();
$result = $stmt->fetch(PDO::FETCH_NUM);

header("Content-Type: image/png");
fpassthru($result[0]);
?>

Column meta The PDOStatement::getColumnMeta() in CUBRID PDO will return an associative array containing the following values:
  • type
  • name
  • table
  • def
  • precision
  • scale
  • not_null
  • auto_increment
  • unique_key
  • multiple_key
  • primary_key
  • foreign_key
  • reverse_index
  • reverse_unique
Collection Data Type PDO_CUBRID supports SET/MULTISET/SEQUENCE data type. If you don't specify data type, the default data type is char,for example:

Example #3 Insert set in CUBRID PDO with default data type.

<?php
$conn_str ="cubrid:dbname=demodb;host=localhost;port=33000";
$cubrid_pdo = new PDO($conn_str, 'dba', '');

$cubrid_pdo->exec("DROP TABLE if exists test_tbl");
$cubrid_pdo->exec("CREATE TABLE test_tbl (col_1 SET(VARCHAR))");

$sql_stmt_insert = "INSERT INTO test_tbl VALUES (?);";
$stmt = $cubrid_pdo->prepare($sql_stmt_insert);
$data = array("abc","def","ghi");
$ret = $stmt->bindParam(1, $data, PDO::PARAM_NULL);
$ret = $stmt->execute();
var_Dump($ret);
?>

Example #4 Specify data type when insert set in CUBRID PDO

<?php
$conn_str ="cubrid:dbname=demodb;host=localhost;port=33000";
$cubrid_pdo = new PDO($conn_str, 'dba', '');

$cubrid_pdo->exec("DROP TABLE if exists test_tbl");
$cubrid_pdo->exec("CREATE TABLE test_tbl (col_1 SET(int))");

$sql_stmt_insert = "INSERT INTO test_tbl VALUES (?);";
$stmt = $cubrid_pdo->prepare($sql_stmt_insert);
$data = array(1,2,3,4);
$ret = $stmt->bindParam(1, $data, 0,0,"int");
$ret = $stmt->execute();
var_Dump($ret);
?>

CUBRID Bind Data Types:(The fifth parameter of PDOStatement::bindParam):
  • CHAR
  • STRING
  • NCHAR
  • VARNCHAR
  • BIT
  • VARBIT
  • NUMERIC
  • NUMBER
  • INT
  • SHORT
  • BIGINT
  • MONETARY
  • FLOAT
  • DOUBLE
  • DATE
  • TIME
  • DATETIME
  • TIMESTAMP

预定义常量

下列常量由此驱动定义，且仅在扩展编译入 PHP 或在运行时动态载入时可用。另外，使用此驱动时，仅会使用这些驱动特定的常量。使用其他驱动的驱动特定的常量可能会导致不可预见的情况。如果代码可运行于多个驱动，PDO::getAttribute() 可被用于获取 PDO_ATTR_DRIVER_NAME 属性以检查驱动。

The following constants can be used when setting the database attribute. They can be passed to PDO::getAttribute() or PDO::setAttribute().

PDO::CUBRID attribute flags
Constant | Description
PDO::CUBRID_ATTR_ISOLATION_LEVEL | Transaction isolation level for the database connection.
PDO::CUBRID_ATTR_LOCK_TIMEOUT | Transaction timeout in seconds.
PDO::CUBRID_ATTR_MAX_STRING_LENGTH | Read only. The maximum string length for bit, varbit, char, varchar, nchar, nchar varying data types when using CUBRID PDO API.

The following constants can be used when setting the transaction isolation level. They can be passed to PDO::getAttribute() or returned by PDO::setAttribute().

PDO::CUBRID isolation level flags
Constant | Description
PDO::TRAN_COMMIT_CLASS_UNCOMMIT_INSTANCE | The lowest isolation level (1). A dirty, non-repeatable or phantom read may occur for the tuple and a non-repeatable read may occur for the table as well.
PDO::TRAN_COMMIT_CLASS_COMMIT_INSTANCE | A relatively low isolation level (2). A dirty read does not occur, but non-repeatable or phantom read may occur.
PDO::TRAN_REP_CLASS_UNCOMMIT_INSTANCE | The default isolation of CUBRID (3). A dirty, non-repeatable or phantom read may occur for the tuple, but repeatable read is ensured for the table.
PDO::TRAN_REP_CLASS_COMMIT_INSTANCE | A relatively low isolation level (4). A dirty read does not occur, but non-repeatable or phantom read may.
PDO::TRAN_REP_CLASS_REP_INSTANCE | A relatively high isolation level (5). A dirty or non-repeatable read does not occur, but a phantom read may.
PDO::TRAN_SERIALIZABLE | The highest isolation level (6). Problems concerning concurrency (e.g. dirty read, non-repeatable read, phantom read, etc.) do not occur.

The following constants can be used when getting schema information. They can be passed to PDO::cubrid_schema().

PDO::CUBRID schema flags
Constant | Description
PDO::CUBRID_SCH_TABLE | Get name and type of table in CUBRID.
PDO::CUBRID_SCH_VIEW | Get name and type of view in CUBRID.
PDO::CUBRID_SCH_QUERY_SPEC | Get the query definition of view.
PDO::CUBRID_SCH_ATTRIBUTE | Get the attributes of table column.
PDO::CUBRID_SCH_TABLE_ATTRIBUTE | Get the attributes of table.
PDO::CUBRID_SCH_METHOD | Get the instance method. The instance method is a method called by a class instance. It is used more often than the class method because most operations are executed in the instance.
PDO::CUBRID_SCH_TABLE_METHOD | Get the class method. The class method is a method called by a class object. It is usually used to create a new class instance or to initialize it. It is also used to access or update class attributes.
PDO::CUBRID_SCH_METHOD_FILE | Get the information of the file where the method of the table is defined.
PDO::CUBRID_SCH_SUPER_TABLE | Get the name and type of table which table inherites attributes from.
PDO::CUBRID_SCH_SUB_TABLE | Get the name and type of table which inherites attributes from this table.
PDO::CUBRID_SCH_CONSTRAINT | Get the table constraints.
PDO::CUBRID_SCH_TRIGGER | Get the table triggers.
PDO::CUBRID_SCH_TABLE_PRIVILEGE | Get the privilege information of table.
PDO::CUBRID_SCH_COL_PRIVILEGE | Get the privilege information of column.
PDO::CUBRID_SCH_DIRECT_SUPER_TABLE | Get the direct super table of table.
PDO::CUBRID_SCH_PRIMARY_KEY | Get the table primary key.
PDO::CUBRID_SCH_IMPORTED_KEYS | Get imported keys of table.
PDO::CUBRID_SCH_EXPORTED_KEYS | Get exported keys of table.
PDO::CUBRID_SCH_CROSS_REFERENCE | Get reference relationship of tow tables.

Table of Contents

  • PDO_CUBRID DSN — Connecting to CUBRID databases
  • PDO::cubrid_schema — Get the requested schema information


Connecting to CUBRID databases

  • ? CUBRID (PDO)
  • PDO::cubrid_schema ?
  • PHP Manual
  • CUBRID (PDO)
  • Connecting to CUBRID databases

PDO_CUBRID DSN

(PECL PDO_CUBRID >= 8.3.0.0001)

PDO_CUBRID DSN — Connecting to CUBRID databases

说明

The PDO_CUBRID Data Source Name (DSN) is composed of the following elements, delimited by semicolons:

DSN prefix

The DSN prefix is cubrid:.

host

The hostname on which the database server resides.

port

The port on which the database server is running.

dbname

The name of the database.

注释

Note:

When you estalish the connection to CUBRID, you should give username and password except DSN.

范例

Example #1 PDO_CUBRID DSN examples

The following example shows a PDO_CUBRID DSN for connecting to a CUBRID database:

cubrid:host=localhost;port=33000;dbname=demodb


Get the requested schema information

  • ? PDO_CUBRID DSN
  • MS SQL Server (PDO) ?
  • PHP Manual
  • CUBRID (PDO)
  • Get the requested schema information

PDO::cubrid_schema

(PECL PDO_CUBRID >= 8.3.0.0001)

PDO::cubrid_schema — Get the requested schema information

说明

public PDO::cubrid_schema ( int $schema_type , string $table_name = ? , string $col_name = ? ) : array

This function is used to get the requested schema information from database. You have to designate table_name, if you want to get information on certain table, col_name, if you want to get information on certain column (can be used only with PDO::CUBRID_SCH_COL_PRIVILEGE).

The result of this function is returned as a two-dimensional array (column (associative array) * row (numeric array)). The following tables shows types of schema and the column structure of the result array to be returned based on the schema type.

Result Composition of Each Type
Schema | Column Number | Column Name | Value
PDO::CUBRID_SCH_TABLE | 1 | NAME |
 | 2 | TYPE | 0:system table 1:view 2:table
PDO::CUBRID_SCH_VIEW | 1 | NAME |
 | 2 | TYPE | 1:view
PDO::CUBRID_SCH_QUERY_SPEC | 1 | QUERY_SPEC |
PDO::CUBRID_SCH_ATTRIBUTE / PDO::CUBRID_SCH_TABLE_ATTRIBUTE | 1 | ATTR_NAME |
 | 2 | DOMAIN |
 | 3 | SCALE |
 | 4 | PRECISION |
 | 5 | INDEXED | 1:indexed
 | 6 | NOT NULL | 1:not null
 | 7 | SHARED | 1:shared
 | 8 | UNIQUE | 1:unique
 | 9 | DEFAULT |
 | 10 | ATTR_ORDER | base:1
 | 11 | CLASS_NAME |
 | 12 | SOURCE_CLASS |
 | 13 | IS_KEY | 1:key
PDO::CUBRID_SCH_METHOD / PDO::CUBRID_SCH_TABLE_METHOD | 1 | NAME |
 | 2 | RET_DOMAIN |
 | 3 | ARG_DOMAIN |
PDO::CUBRID_SCH_METHOD_FILE | 1 | METHOD_FILE |
PDO::CUBRID_SCH_SUPER_TABLE / PDO::CUBRID_SCH_DIRECT_SUPER_TABLE / PDO::CUBRID_SCH_SUB_TABLE | 1 | CLASS_NAME |
 | 2 | TYPE | 0:system table 1:view 2:table
PDO::CUBRID_SCH_CONSTRAINT | 1 | TYPE | 0:unique 1:index 2:reverse unique 3:reverse index
 | 2 | NAME |
 | 3 | ATTR_NAME |
 | 4 | NUM_PAGES |
 | 5 | NUM_KEYS |
 | 6 | PRIMARY_KEY | 1:primary key
 | 7 | KEY_ORDER | base:1
PDO::CUBRID_SCH_TRIGGER | 1 | NAME |
 | 2 | STATUS |
 | 3 | EVENT |
 | 4 | TARGET_CLASS |
 | 5 | TARGET_ATTR |
 | 6 | ACTION_TIME |
 | 7 | ACTION |
 | 8 | PRIORITY |
 | 9 | CONDITION_TIME |
 | 10 | CONDITION |
PDO::CUBRID_SCH_TABLE_PRIVILEGE / PDO::CUBRID_SCH_COL_PRIVILEGE | 1 | CLASS_NAME / ATTR_NAME |
 | 2 | PRIVILEGE |
 | 3 | GRANTABLE |
PDO::CUBRID_SCH_PRIMARY_KEY | 1 | CLASS_NAME |
 | 2 | ATTR_NAME |
 | 3 | KEY_SEQ | base:1
 | 4 | KEY_NAME |
PDO::CUBRID_SCH_IMPORTED_KEYS / PDO::CUBRID_SCH_EXPORTED_KEYS / PDO::CUBRID_SCH_CROSS_REFERENCE | 1 | PKTABLE_NAME |
 | 2 | PKCOLUMN_NAME |
 | 3 | FKTABLE_NAME | base:1
 | 4 | FKCOLUMN_NAME |
 | 5 | KEY_SEQ | base:1
 | 6 | UPDATE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 7 | DELETE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 8 | FK_NAME |
 | 9 | PK_NAME |

参数

schema_type

Schema type that you want to know.

table_name

Table you want to know the schema of.

col_name

Column you want to know the schema of.

返回值

Array containing the schema information, when process is successful;

FALSE, when process is unsuccessful

范例

Example #1 A PDO::cubrid_schema() example

This example shows how to get primary key and foreign keys of table game.

<?php
$pk_list = $dbh->cubrid_schema(PDO::CUBRID_SCH_PRIMARY_KEY, "game");
print_r($pk_list);

$fk_list = $dbh->cubrid_schema(PDO::CUBRID_SCH_IMPORTED_KEYS, "game");
print_r($fk_list);
?>

以上例程会输出：

Result:
Array
(
    [0] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => athlete_code
            [KEY_SEQ] => 3
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

    [1] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => event_code
            [KEY_SEQ] => 2
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

    [2] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => host_year
            [KEY_SEQ] => 1
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

)
Array
(
    [0] => Array
        (
            [PKTABLE_NAME] => athlete
            [PKCOLUMN_NAME] => code
            [FKTABLE_NAME] => game
            [FKCOLUMN_NAME] => athlete_code
            [KEY_SEQ] => 1
            [UPDATE_RULE] => 1
            [DELETE_RULE] => 1
            [FK_NAME] => fk_game_athlete_code
            [PK_NAME] => pk_athlete_code
        )

    [1] => Array
        (
            [PKTABLE_NAME] => event
            [PKCOLUMN_NAME] => code
            [FKTABLE_NAME] => game
            [FKCOLUMN_NAME] => event_code
            [KEY_SEQ] => 1
            [UPDATE_RULE] => 1
            [DELETE_RULE] => 1
            [FK_NAME] => fk_game_event_code
            [PK_NAME] => pk_event_code
        )

)


Microsoft SQL Server and Sybase Functions (PDO_DBLIB)

简介

PDO_DBLIB is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to Microsoft SQL Server and Sybase databases through the FreeTDS library.

This extension is not available anymore on Windows with PHP 5.3 or later.

On Windows, you should use SqlSrv, an alternative driver for MS SQL is available from Microsoft: » http://msdn.microsoft.com/en-us/sqlserver/ff657782.aspx .

If it is not possible to use SqlSrv, you can use the PDO_ODBC driver to connect to Microsoft SQL Server and Sybase databases, as the native Windows DB-LIB is ancient, thread un-safe and no longer supported by Microsoft.

Table of Contents

  • PDO_DBLIB DSN — Connecting to Microsoft SQL Server and Sybase databases


Connecting to Microsoft SQL Server and Sybase databases

  • ? MS SQL Server (PDO)
  • Firebird (PDO) ?
  • PHP Manual
  • MS SQL Server (PDO)
  • Connecting to Microsoft SQL Server and Sybase databases

PDO_DBLIB DSN

(PECL PDO_DBLIB >= 0.9.0)

PDO_DBLIB DSN — Connecting to Microsoft SQL Server and Sybase databases

说明

The PDO_DBLIB Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is sybase: if PDO_DBLIB was linked against the Sybase ct-lib libraries, mssql: if PDO_DBLIB was linked against the Microsoft SQL Server libraries, or dblib: if PDO_DBLIB was linked against the FreeTDS libraries.

host

The hostname on which the database server resides. Defaults to 127.0.0.1.

dbname

The name of the database.

charset

The client character set.

appname

The application name (used in sysprocesses). Defaults to "PHP Generic DB-lib" or "PHP freetds".

secure

Currently unused.

范例

Example #1 PDO_DBLIB DSN examples

The following examples show a PDO_DBLIB DSN for connecting to Microsoft SQL Server and Sybase databases:

mssql:host=localhost;dbname=testdb
sybase:host=localhost;dbname=testdb
dblib:host=localhost;dbname=testdb


Firebird Functions (PDO_FIREBIRD)

简介

PDO_FIREBIRD is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to Firebird database.

安装

Use --with-pdo-firebird[=DIR] to install the PDO Firebird extension, where the optional [=DIR] is the Firebird base install directory.

$ ./configure --with-pdo-firebird

预定义常量

下列常量由此驱动定义，且仅在扩展编译入 PHP 或在运行时动态载入时可用。另外，使用此驱动时，仅会使用这些驱动特定的常量。使用其他驱动的驱动特定的常量可能会导致不可预见的情况。如果代码可运行于多个驱动，PDO::getAttribute() 可被用于获取 PDO_ATTR_DRIVER_NAME 属性以检查驱动。

PDO::FB_ATTR_DATE_FORMAT (int)

Available since PHP 5.3.0.

Sets the date format.

PDO::FB_ATTR_TIME_FORMAT (int)

Sets the time format.

Available since PHP 5.3.0.

PDO::FB_ATTR_TIMESTAMP_FORMAT (int)

Sets the timestamp format.

Available since PHP 5.3.0.

Table of Contents

  • PDO_FIREBIRD DSN — Connecting to Firebird databases


Connecting to Firebird databases

  • ? Firebird (PDO)
  • IBM (PDO) ?
  • PHP Manual
  • Firebird (PDO)
  • Connecting to Firebird databases

PDO_FIREBIRD DSN

(PECL PDO_FIREBIRD >= 0.1.0)

PDO_FIREBIRD DSN — Connecting to Firebird databases

说明

The PDO_FIREBIRD Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is firebird:.

dbname

The name of the database.

charset

The character set.

role

The SQL role name.

dialect

The dialect of the database; either 1 or 3. If not specified, the dialect defaults to 3. Available as of PHP 7.4.0.

范例

Example #1 PDO_FIREBIRD DSN example with path

The following example shows a PDO_FIREBIRD DSN for connecting to Firebird databases:

firebird:dbname=/path/to/DATABASE.FDB

Example #2 PDO_FIREBIRD DSN example with port and path

The following example shows a PDO_FIREBIRD DSN for connecting to a Firebird database using hostname port and path:

firebird:dbname=hostname/port:/path/to/DATABASE.FDB

Example #3 PDO_FIREBIRD DSN example with localhost and path to employee.fdb on Debian system

The following example shows a PDO_FIREBIRD DSN for connecting to a Firebird database employee.fdb using localhost:

firebird:dbname=localhost:/var/lib/firebird/2.5/data/employee.fdb

Example #4 PDO_FIREBIRD DSN to connect to a dialect 1 database

The following example shows a PDO_FIREBIRD DSN for connecting to a Firebird database test.fdb which has been created using dialect 1. This is only supported as of PHP 7.4.0.

firebird:dbname=localhost:/var/lib/firebird/2.5/data/test.fdb;CHARSET=gb2312;dialect=1


IBM Functions (PDO_IBM)

简介

PDO_IBM is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to IBM databases.

安装

To build the PDO_IBM extension, the DB2 Client v9.1 or later must be installed on the same system as PHP. The DB2 Client can be downloaded from the IBM » Application Development Site.

Note: Note

The DB2 Client v9.1 or later supports direct access to DB2 for Linux, UNIX, and Windows v8 and v9.1 servers.

The DB2 Client v9.1 also supports access to DB2 UDB for i5 and DB2 UDB for z/OS servers using the separately purchased » DB2 Connect product.

PDO_IBM is a » PECL extension, so follow the instructions in PECL 扩展库安装 to install the PDO_IBM extension. Issue the configure command to point to the location of your DB2 Client header files and libraries as follows:

bash$ ./configure --with-pdo-ibm=/path/to/sqllib[,shared]
The configure command defaults to the value of the DB2DIR environment variable.

Table of Contents

  • PDO_IBM DSN — Connecting to IBM databases


Connecting to IBM databases

  • ? IBM (PDO)
  • Informix (PDO) ?
  • PHP Manual
  • IBM (PDO)
  • Connecting to IBM databases

PDO_IBM DSN

(PECL PDO_IBM >= 0.9.0)

PDO_IBM DSN — Connecting to IBM databases

说明

The PDO_IBM Data Source Name (DSN) is based on the IBM CLI DSN. The major components of the PDO_IBM DSN are:

DSN prefix

The DSN prefix is ibm:.

DSN

The DSN can be any of the following:

  • a) Data source setup using db2cli.ini or odbc.ini

  • b) Catalogued database name i.e. database alias in the DB2 client catalog

  • c) Complete connection string in the following format: DRIVER={IBM DB2 ODBC DRIVER};DATABASE=database;HOSTNAME=hostname;PORT=port;PROTOCOL=TCPIP;UID=username;PWD=password; where the parameters represent the following values:

    database

    The name of the database.

    hostname

    The hostname or IP address of the database server.

    port

    The TCP/IP port on which the database is listening for requests.

    username

    The username with which you are connecting to the database.

    password

    The password with which you are connecting to the database.

范例

Example #1 PDO_IBM DSN example using db2cli.ini

The following example shows a PDO_IBM DSN for connecting to an DB2 database cataloged as DB2_9 in db2cli.ini:

$db = new PDO("ibm:DSN=DB2_9", "", "");

[DB2_9]
Database=testdb
Protocol=tcpip
Hostname=11.22.33.444
Servicename=56789

Example #2 PDO_IBM DSN example using a connection string

The following example shows a PDO_IBM DSN for connecting to an DB2 database named testdb using the DB2 CLI connection string syntax.

$db = new PDO("ibm:DRIVER={IBM DB2 ODBC DRIVER};DATABASE=testdb;" .
  "HOSTNAME=11.22.33.444;PORT=56789;PROTOCOL=TCPIP;", "testuser", "tespass");


Informix Functions (PDO_INFORMIX)

简介

PDO_INFORMIX is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to Informix databases.

安装

To build the PDO_INFORMIX extension, the Informix Client SDK 2.81 UC1 or higher must be installed on the same system as PHP. The Informix Client SDK is available from the » IBM Informix Support Site.

PDO_INFORMIX is a » PECL extension, so follow the instructions in PECL 扩展库安装 to install the PDO_INFORMIX extension. Issue the configure command to point to the location of your Informix Client SDK header files and libraries as follows:

   bash$ ./configure --with-pdo-informix=/path/to/SDK[,shared]
The configure command defaults to the value of the INFORMIXDIR environment variable.

Scrollable cursors

PDO_INFORMIX supports scrollable cursors; however, they are not enabled by default. To enable scrollable cursor support, you must either set ENABLESCROLLABLECURSORS=1 in the corresponding ODBC connection settings in odbc.ini or pass the EnableScrollableCursors=1 clause in the DSN connection string.

Table of Contents

  • PDO_INFORMIX DSN — Connecting to Informix databases


Connecting to Informix databases

  • ? Informix (PDO)
  • MySQL (PDO) ?
  • PHP Manual
  • Informix (PDO)
  • Connecting to Informix databases

PDO_INFORMIX DSN

(PECL PDO_INFORMIX >= 0.1.0)

PDO_INFORMIX DSN — Connecting to Informix databases

说明

The PDO_INFORMIX Data Source Name (DSN) is based on the Informix ODBC DSN string. Details on configuring an Informix ODBC DSN are available from the » Informix Dynamic Server Information Center. The major components of the PDO_INFORMIX DSN are:

DSN prefix

The DSN prefix is informix:.

DSN

The DSN can be either a data source setup using odbc.ini or a complete » connection string.

范例

Example #1 PDO_INFORMIX DSN example using odbc.ini

The following example shows a PDO_INFORMIX DSN for connecting to an Informix database cataloged as Infdrv33 in odbc.ini:

$db = new PDO("informix:DSN=Infdrv33", "", "");

[ODBC Data Sources]
Infdrv33=INFORMIX 3.3 32-BIT

[Infdrv33]
Driver=/opt/informix/csdk_2.81.UC1G2/lib/cli/iclis09b.so
Description=INFORMIX 3.3 32-BIT
Database=common_db
LogonID=testuser
pwd=testpass
Servername=ids_server
DB_LOCALE=en_US.819
OPTIMIZEAUTOCOMMIT=1
ENABLESCROLLABLECURSORS=1

Example #2 PDO_INFORMIX DSN example using a connection string

The following example shows a PDO_INFORMIX DSN for connecting to an Informix database named common_db using the Informix connection string syntax.

$db = new PDO("informix:host=host.domain.com; service=9800;
    database=common_db; server=ids_server; protocol=onsoctcp;
    EnableScrollableCursors=1", "testuser", "tespass");


MySQL Functions (PDO_MYSQL)

简介

PDO_MYSQL is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to MySQL databases.

PDO_MYSQL uses emulated prepares by default.

MySQL 8

When running a PHP version before 7.1.16, or PHP 7.2 before 7.2.4, set MySQL 8 Server's default password plugin to mysql_native_password or else you will see errors similar to The server requested authentication method unknown to the client [caching_sha2_password] even when caching_sha2_password is not used.

This is because MySQL 8 defaults to caching_sha2_password, a plugin that is not recognized by the older PHP (mysqlnd) releases. Instead, change it by setting default_authentication_plugin=mysql_native_password in my.cnf. The caching_sha2_password plugin will be supported in a future PHP release. In the meantime, the mysql_xdevapi extension does support it.

Warning

Beware: Some MySQL table types (storage engines) do not support transactions. When writing transactional database code using a table type that does not support transactions, MySQL will pretend that a transaction was initiated successfully. In addition, any DDL queries issued will implicitly commit any pending transactions.

安装

The common Unix distributions include binary versions of PHP that can be installed. Although these binary versions are typically built with support for the MySQL extensions, the extension libraries themselves may need to be installed using an additional package. Check the package manager than comes with your chosen distribution for availability.

For example, on Ubuntu the php5-mysql package installs the ext/mysql, ext/mysqli, and PDO_MYSQL PHP extensions. On CentOS, the php-mysql package also installs these three PHP extensions.

Alternatively, you can compile this extension yourself. Building PHP from source allows you to specify the MySQL extensions you want to use, as well as your choice of client library for each extension.

When compiling, use --with-pdo-mysql[=DIR] to install the PDO MySQL extension, where the optional [=DIR] is the MySQL base library. As of PHP 5.4, mysqlnd is the default library. For details about choosing a library, see Choosing a MySQL library.

Optionally, the --with-mysql-sock[=DIR] sets to location to the MySQL unix socket pointer for all MySQL extensions, including PDO_MYSQL. If unspecified, the default locations are searched.

Optionally, the --with-zlib-dir[=DIR] is used to set the path to the libz install prefix.

$ ./configure --with-pdo-mysql --with-mysql-sock=/var/mysql/mysql.sock

SSL support is enabled using the appropriate PDO_MySQL constants, which is equivalent to calling the » MySQL C API function mysql_ssl_set(). Also, SSL cannot be enabled with PDO::setAttribute because the connection already exists. See also the MySQL documentation about » connecting to MySQL with SSL.

预定义常量

下列常量由此驱动定义，且仅在扩展编译入 PHP 或在运行时动态载入时可用。另外，使用此驱动时，仅会使用这些驱动特定的常量。使用其他驱动的驱动特定的常量可能会导致不可预见的情况。如果代码可运行于多个驱动，PDO::getAttribute() 可被用于获取 PDO_ATTR_DRIVER_NAME 属性以检查驱动。

PDO::MYSQL_ATTR_USE_BUFFERED_QUERY (int)
If this attribute is set to true on a PDOStatement, the MySQL driver will use the buffered versions of the MySQL API. If you're writing portable code, you should use PDOStatement::fetchAll() instead.

Example #1 Forcing queries to be buffered in mysql

<?php
if ($db->getAttribute(PDO::ATTR_DRIVER_NAME) == 'mysql') {
    $stmt = $db->prepare('select * from foo',
        array(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY => true));
} else {
    die("my application only works with mysql; I should use \$stmt->fetchAll() instead");
}
?>

PDO::MYSQL_ATTR_LOCAL_INFILE (int)

Enable LOAD LOCAL INFILE.

Note, this constant can only be used in the driver_options array when constructing a new database handle.

PDO::MYSQL_ATTR_LOCAL_INFILE_DIRECTORY (string)

Allows restricting LOCAL DATA loading to files located in this designated directory.

Note, this constant can only be used in the driver_options array when constructing a new database handle.

PDO::MYSQL_ATTR_INIT_COMMAND (int)

Command to execute when connecting to the MySQL server. Will automatically be re-executed when reconnecting.

Note, this constant can only be used in the driver_options array when constructing a new database handle.

PDO::MYSQL_ATTR_READ_DEFAULT_FILE (int)

Read options from the named option file instead of from my.cnf. This option is not available if mysqlnd is used, because mysqlnd does not read the mysql configuration files.

PDO::MYSQL_ATTR_READ_DEFAULT_GROUP (int)

Read options from the named group from my.cnf or the file specified with MYSQL_READ_DEFAULT_FILE. This option is not available if mysqlnd is used, because mysqlnd does not read the mysql configuration files.

PDO::MYSQL_ATTR_MAX_BUFFER_SIZE (int)

Maximum buffer size. Defaults to 1 MiB. This constant is not supported when compiled against mysqlnd.

PDO::MYSQL_ATTR_DIRECT_QUERY (int)

Perform direct queries, don't use prepared statements.

PDO::MYSQL_ATTR_FOUND_ROWS (int)

Return the number of found (matched) rows, not the number of changed rows.

PDO::MYSQL_ATTR_IGNORE_SPACE (int)

Permit spaces after function names. Makes all functions names reserved words.

PDO::MYSQL_ATTR_COMPRESS (int)

Enable network communication compression.

PDO::MYSQL_ATTR_SSL_CA (int)

The file path to the SSL certificate authority.

PDO::MYSQL_ATTR_SSL_CAPATH (int)

The file path to the directory that contains the trusted SSL CA certificates, which are stored in PEM format.

PDO::MYSQL_ATTR_SSL_CERT (int)

The file path to the SSL certificate.

PDO::MYSQL_ATTR_SSL_CIPHER (int)

A list of one or more permissible ciphers to use for SSL encryption, in a format understood by OpenSSL. For example: DHE-RSA-AES256-SHA:AES128-SHA

PDO::MYSQL_ATTR_SSL_KEY (int)

The file path to the SSL key.

PDO::MYSQL_ATTR_SSL_VERIFY_SERVER_CERT (int)

Provides a way to disable verification of the server SSL certificate.

自以下版本起 PHP 7.0.18 and PHP 7.1.4.

PDO::MYSQL_ATTR_MULTI_STATEMENTS (int)

Disables multi query execution in both PDO::prepare() and PDO::query() when set to false.

Note, this constant can only be used in the driver_options array when constructing a new database handle.

运行时配置

这些函数的行为受 php.ini 中的设置影响。

PDO_MYSQL Configuration Options
名字 | 默认 | 可修改范围
pdo_mysql.default_socket | "/tmp/mysql.sock" | PHP_INI_SYSTEM
pdo_mysql.debug | NULL | PHP_INI_SYSTEM
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

pdo_mysql.default_socket string

Sets a Unix domain socket. This value can either be set at compile time if a domain socket is found at configure. This ini setting is Unix only.

pdo_mysql.debug bool

Enables debugging for PDO_MYSQL. This setting is only available when PDO_MYSQL is compiled against mysqlnd and in PDO debug mode.

Table of Contents

  • PDO_MYSQL DSN — Connecting to MySQL databases


Connecting to MySQL databases

  • ? MySQL (PDO)
  • MS SQL Server (PDO) ?
  • PHP Manual
  • MySQL (PDO)
  • Connecting to MySQL databases

PDO_MYSQL DSN

(PECL PDO_MYSQL >= 0.1.0)

PDO_MYSQL DSN — Connecting to MySQL databases

说明

The PDO_MYSQL Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is mysql:.

host

The hostname on which the database server resides.

port

The port number where the database server is listening.

dbname

The name of the database.

unix_socket

The MySQL Unix socket (shouldn't be used with host or port).

charset

The character set. See the character set concepts documentation for more information.

范例

Example #1 PDO_MYSQL DSN examples

The following example shows a PDO_MYSQL DSN for connecting to MySQL databases:

mysql:host=localhost;dbname=testdb
More complete examples:
mysql:host=localhost;port=3307;dbname=testdb
mysql:unix_socket=/tmp/mysql.sock;dbname=testdb

注释

Note: Unix only:

When the host name is set to "localhost", then the connection to the server is made thru a domain socket. If PDO_MYSQL is compiled against libmysqlclient then the location of the socket file is at libmysqlclient's compiled in location. If PDO_MYSQL is compiled against mysqlnd a default socket can be set thru the pdo_mysql.default_socket setting.


Microsoft SQL Server Functions (PDO_SQLSRV)

简介

PDO_SQLSRV is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to MS SQL Server (starting with SQL Server 2005) and SQL Azure databases.

安装

The PDO_SQLSRV extension is enabled by adding appropriate DLL file to your PHP extension directory and the corresponding entry to the php.ini file. The PDO_SQLSRV download comes 8 driver files, four of which are for PDO support. If you are running non-thread-safe PHP (PHP 5.3), use the php_pdo_sqlsrv_53_nts.dll file. (You should use a non-thread-safe version if you are using IIS as your web server). If you are running thread-safe PHP, use the php_pdo_sqlsrv_53_ts.dll file. Similarly for PHP 5.4, use the php_pdo_sqlsrv_54_nts.dll or php_pdo_sqlsrv_54_ts.dll depending on whether your PHP installation is non-thread-safe or thread-safe.

The most recent version of the driver is available for download here: » SQLSRV download. If you need support for PHP 5.2 and/or PHP compiled with VC6, use the 2.0 release of the driver: » SQLSRV 2.0 download. The driver sources are hosted in a » public repository.

For more information about system requirements, see » SQLSRV System Requirements.

The PDO_SQLSRV extension is only compatible with PHP running on Windows. For Linux, see ODBC and » Microsoft's SQL Server ODBC Driver for Linux.

预定义常量

下列常量由此驱动定义，且仅在扩展编译入 PHP 或在运行时动态载入时可用。另外，使用此驱动时，仅会使用这些驱动特定的常量。使用其他驱动的驱动特定的常量可能会导致不可预见的情况。如果代码可运行于多个驱动，PDO::getAttribute() 可被用于获取 PDO_ATTR_DRIVER_NAME 属性以检查驱动。

PDO::SQLSRV_TXN_READ_UNCOMMITTED (int)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Read Uncommitted.
PDO::SQLSRV_TXN_READ_COMMITTED (int)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Read Committed.
PDO::SQLSRV_TXN_REPEATABLE_READ (int)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Repeateable Read.
PDO::SQLSRV_TXN_SNAPSHOT (int)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Snapshot.
PDO::SQLSRV_TXN_SERIALIZABLE (int)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Serializable.
PDO::SQLSRV_ENCODING_BINARY (int)
Specifies that data is sent/retrieved as a raw byte stream to/from the server without performing encoding or translation. This constant can be passed to PDOStatement::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_SYSTEM (int)
Specifies that data is sent/retrieved to/from the server as 8-bit characters as specified in the code page of the Windows locale that is set on the system. Any multi-byte characters or characters that do not map into this code page are substituted with a single byte question mark (?) character. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_UTF8 (int)
Specifies that data is sent/retrieved to/from the server in UTF-8 encoding. This is the default encoding. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_DEFAULT (int)
Specifies that data is sent/retrieved to/from the server according to PDO::SQLSRV_ENCODING_SYSTEM if specified during connection. The connection's encoding is used if specified in a prepare statement. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ATTR_QUERY_TIMEOUT (int)
A non-negative integer representing the timeout period, in seconds. Zero (0) is the default and means no timeout. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, and PDO::prepare.
PDO::SQLSRV_ATTR_DIRECT_QUERY (int)
Indicates that a query should be executed directly, without being prepared. This constant can be passed to PDO::setAttribute, and PDO::prepare. For more information, see » Direct and Prepared Statement Execution.

Table of Contents

  • PDO_SQLSRV DSN — Connecting to MS SQL Server and SQL Azure databases


Connecting to MS SQL Server and SQL Azure databases

  • ? MS SQL Server (PDO)
  • Oracle (PDO) ?
  • PHP Manual
  • MS SQL Server (PDO)
  • Connecting to MS SQL Server and SQL Azure databases

PDO_SQLSRV DSN

(PECL pdo_sqlsrv >= 2.0.1)

PDO_SQLSRV DSN — Connecting to MS SQL Server and SQL Azure databases

说明

The PDO_SQLSRV Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is sqlsrv:.

APP

The application name used in tracing.

ConnectionPooling

Specifies whether the connection is assigned from a connection pool (1 or true) or not (0 or false).

Database

The name of the database.

Encrypt

Specifies whether the communication with SQL Server is encrypted (1 or true) or unencrypted (0 or false).

Failover_Partner

Specifies the server and instance of the database's mirror (if enabled and configured) to use when the primary server is unavailable.

LoginTimeout

Specifies the number of seconds to wait before failing the connection attempt.

MultipleActiveResultSets

Disables or explicitly enables support for multiple active Result sets (MARS).

QuotedId

Specifies whether to use SQL-92 rules for quoted identifiers (1 or true) or to use legacy Transact-SQL rules (0 or false).

Server

The name of the database server.

TraceFile

Specifies the path for the file used for trace data.

TraceOn

Specifies whether ODBC tracing is enabled (1 or true) or disabled (0 or false) for the connection being established.

TransactionIsolation

Specifies the transaction isolation level. The accepted values for this
option are PDO::SQLSRV_TXN_READ_UNCOMMITTED, PDO::SQLSRV_TXN_READ_COMMITTED,
PDO::SQLSRV_TXN_REPEATABLE_READ, PDO::SQLSRV_TXN_SNAPSHOT, and
PDO::SQLSRV_TXN_SERIALIZABLE.

TrustServerCertificate

Specifies whether the client should trust (1 or true) or reject (0 or false) a self-signed server certificate.

WSID

Specifies the name of the computer for tracing.

范例

Example #1 PDO_SQLSRV DSN examples

The following example shows how to connecto to a specified MS SQL Server database:

$c = new PDO("sqlsrv:Server=localhost;Database=testdb", "UserName", "Password");

The following example shows how to connect to a MS SQL Server database on a specified port:

$c = new PDO("sqlsrv:Server=localhost,1521;Database=testdb", "UserName", "Password");

The following example shows how to connecto to a SQL Azure database with server ID 12345abcde. Note that when you connect to SQL Azure with PDO, your username will be UserName@12345abcde (UserName@ServerId).

$c = new PDO("sqlsrv:Server=12345abcde.database.windows.net;Database=testdb", "UserName@12345abcde", "Password");


Oracle Functions (PDO_OCI)

安装

If the Oracle Database is on the same machine as PHP, the database software already contains the necessary libraries. When PHP is on a different machine, use the free » Oracle Instant Client libraries. For details refer to the OCI8 Requirements section.

Use --with-pdo-oci[=DIR] to install the PDO Oracle OCI extension, where the optional [=DIR] is the Oracle Home directory. [=DIR] defaults to the $ORACLE_HOME environment variable.

Use --with-pdo-oci=instantclient,prefix,version for an Oracle Instant Client SDK, where prefix and version are configured.

// Using $ORACLE_HOME
$ ./configure --with-pdo-oci

// Using OIC for Linux with 10.2.0.3 RPMs with a /usr prefix
$ ./configure --with-pdo-oci=instantclient,/usr,10.2.0.3

预定义常量

下列常量由此驱动定义，且仅在扩展编译入 PHP 或在运行时动态载入时可用。另外，使用此驱动时，仅会使用这些驱动特定的常量。使用其他驱动的驱动特定的常量可能会导致不可预见的情况。如果代码可运行于多个驱动，PDO::getAttribute() 可被用于获取 PDO_ATTR_DRIVER_NAME 属性以检查驱动。

PDO::OCI_ATTR_ACTION (int)

Provides a way to specify the action on the database session.

自以下版本起 PHP 7.2.16 and 7.3.3

PDO::OCI_ATTR_CLIENT_INFO (int)

Provides a way to specify the client info on the database session.

自以下版本起 PHP 7.2.16 and 7.3.3

PDO::OCI_ATTR_CLIENT_IDENTIFIER (int)

Provides a way to specify the client identifier on the database session.

自以下版本起 PHP 7.2.16 and 7.3.3

PDO::OCI_ATTR_MODULE (int)

Provides a way to specify the module on the database session.

自以下版本起 PHP 7.2.16 and 7.3.3

Table of Contents

  • PDO_OCI DSN — Connecting to Oracle databases


Connecting to Oracle databases

  • ? Oracle (PDO)
  • ODBC and DB2 (PDO) ?
  • PHP Manual
  • Oracle (PDO)
  • Connecting to Oracle databases

PDO_OCI DSN

(PECL PDO_OCI >= 0.1.0)

PDO_OCI DSN — Connecting to Oracle databases

说明

The PDO_OCI Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is oci:.

dbname (Oracle Instant Client)

The URI for the Oracle Instant Client connection takes the form of dbname=//hostname:port-number/database. If you are connecting to a database defined in tnsnames.ora, use only the name of the database: dbname=database.

charset

The client-side character set for the current environment handle.

范例

Example #1 PDO_OCI DSN examples

The following examples show a PDO_OCI DSN for connecting to Oracle databases:

// Connect to a database defined in tnsnames.ora
oci:dbname=mydb

// Connect using the Oracle Instant Client
oci:dbname=//localhost:1521/mydb


ODBC and DB2 Functions (PDO_ODBC)

简介

PDO_ODBC is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to databases through ODBC drivers or through the IBM DB2 Call Level Interface (DB2 CLI) library. PDO_ODBC currently supports three different "flavours" of database drivers:

ibm-db2

Supports access to IBM DB2 Universal Database, Cloudscape, and Apache Derby servers through the free DB2 express-C client.

unixODBC

Supports access to database servers through the unixODBC driver manager and the database's own ODBC drivers.

generic

Offers a compile option for ODBC driver managers that are not explicitly supported by PDO_ODBC.

On Windows, php_pdo_odbc.dll has to be enabled as extension in php.ini. It is linked against the Windows ODBC Driver Manager so that PHP can connect to any database cataloged as a System DSN, and is the recommended driver for connecting to Microsoft SQL Server databases.

安装

PDO_ODBC on UNIX systems

  1. As of PHP 5.1, PDO_ODBC is included in the PHP source. You can compile the PDO_ODBC extension as either a static or shared module using the following configure commands.

    ibm_db2

    ./configure --with-pdo-odbc=ibm-db2,/opt/IBM/db2/V8.1/
    To build PDO_ODBC with the ibm-db2 flavour, you have to have previously installed the DB2 application development headers on the same machine on which you are compiling PDO_ODBC. The DB2 application development headers are an installable option in the DB2 servers, and are also available as part of the DB2 Application Development Client freely available for download from the IBM developerWorks » website.

    If you do not supply a location for the DB2 libraries and headers to the configure command, PDO_ODBC defaults to /home/db2inst1/sqllib.

    unixODBC

    ./configure --with-pdo-odbc=unixODBC,/usr/local
    If you do not supply a location for the unixODBC libraries and headers to the configure command, PDO_ODBC defaults to /usr/local.

    generic
    ./configure --with-pdo-odbc=generic,/usr/local,libname,ldflags,cflags

预定义常量

下列常量由此驱动定义，且仅在扩展编译入 PHP 或在运行时动态载入时可用。另外，使用此驱动时，仅会使用这些驱动特定的常量。使用其他驱动的驱动特定的常量可能会导致不可预见的情况。如果代码可运行于多个驱动，PDO::getAttribute() 可被用于获取 PDO_ATTR_DRIVER_NAME 属性以检查驱动。

PDO::ODBC_ATTR_USE_CURSOR_LIBRARY (int)

This option controls whether the ODBC cursor library is used. The ODBC cursor library supports some advanced ODBC features (e.g. block scrollable cursors), which may not be implemented by the driver. The following values are supported:

  • PDO::ODBC_SQL_USE_IF_NEEDED (the default): use the ODBC cursor library when needed.

  • PDO::ODBC_SQL_USE_DRIVER: never use the ODBC cursor library.

  • PDO::ODBC_SQL_USE_ODBC: always use the ODBC cursor library.

PDO::ODBC_ATTR_ASSUME_UTF8 (bool)

Windows only. If true, UTF-16 encoded character data (CHAR, VARCHAR and LONGVARCHAR) is converted to UTF-8 when reading from or writing data to the database. If false (the default), no character encoding conversion is done.

运行时配置

这些函数的行为受 php.ini 中的设置影响。

PDO_ODBC Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
pdo_odbc.connection_pooling | "strict" | PHP_INI_ALL | Available since PHP 5.1.0.
pdo_odbc.db2_instance_name | NULL | PHP_INI_SYSTEM | Available since PHP 5.1.1. 本过时特性将肯定会在未来被移除。
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

pdo_odbc.connection_pooling string

Whether to pool ODBC connections. Can be one of "strict", "relaxed" or "off" (equals to ""). The parameter describes how strict the connection manager should be when matching connection parameters to existing pooled connections. strict is the recommend default, and will result in the use of cached connections only when all the connection parameters match exactly. relaxed will result in the use of cached connections when similar connection parameters are used. This can result in increased use of the cache, at the risk of bleeding connection information between (for example) virtual hosts.

This setting can only be changed from the php.ini file, and affects the entire process; any other modules loaded into the process that use the same ODBC libraries will be affected too, including the Unified ODBC extension.

Warning

relaxed matching should not be used on a shared server, for security reasons.

Tip

Leave this setting at the default strict setting unless you have good reason to change it.

pdo_odbc.db2_instance_name string

If you compile PDO_ODBC using the db2 flavour, this setting sets the value of the DB2INSTANCE environment variable on Linux and UNIX operating systems to the specified name of the DB2 instance. This enables PDO_ODBC to resolve the location of the DB2 libraries and make cataloged connections to DB2 databases.

This setting can only be changed from the php.ini file, and affects the entire process; any other modules loaded into the process that use the same ODBC libraries will be affected too, including the Unified ODBC extension.

This setting has no effect on Windows.

Table of Contents

  • PDO_ODBC DSN — Connecting to ODBC or DB2 databases


Connecting to ODBC or DB2 databases

  • ? ODBC and DB2 (PDO)
  • PostgreSQL (PDO) ?
  • PHP Manual
  • ODBC and DB2 (PDO)
  • Connecting to ODBC or DB2 databases

PDO_ODBC DSN

(PECL PDO_ODBC >= 0.1.0)

PDO_ODBC DSN — Connecting to ODBC or DB2 databases

说明

The PDO_ODBC Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is odbc:. If you are connecting to a database cataloged in the ODBC driver manager or the DB2 catalog, you can append the cataloged name of the database to the DSN.

DSN

The name of the database as cataloged in the ODBC driver manager or the DB2 catalog. Alternately, you can provide a complete ODBC connection string to connect to a database as described at » http://www.connectionstrings.com/.

UID

The name of the user for the connection. If you specify the user name in the DSN, PDO ignores the value of the user name argument in the PDO constructor.

PWD

The password of the user for the connection. If you specify the password in the DSN, PDO ignores the value of the password argument in the PDO constructor.

范例

Example #1 PDO_ODBC DSN example (ODBC driver manager)

The following example shows a PDO_ODBC DSN for connecting to an ODBC database cataloged as testdb in the ODBC driver manager:

odbc:testdb

Example #2 PDO_ODBC DSN example (IBM DB2 uncataloged connection)

The following example shows a PDO_ODBC DSN for connecting to an IBM DB2 database named SAMPLE using the full ODBC DSN syntax:

odbc:DRIVER={IBM DB2 ODBC DRIVER};HOSTNAME=localhost;PORT=50000;DATABASE=SAMPLE;PROTOCOL=TCPIP;UID=db2inst1;PWD=ibmdb2;

Example #3 PDO_ODBC DSN example (Microsoft Access uncataloged connection)

The following example shows a PDO_ODBC DSN for connecting to a Microsoft Access database stored at C:\db.mdb using the full ODBC DSN syntax:

odbc:Driver={Microsoft Access Driver (*.mdb)};Dbq=C:\\db.mdb;Uid=Admin


PostgreSQL Functions (PDO_PGSQL)

简介

PDO_PGSQL is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to PostgreSQL databases.

资源类型

This extension defines a stream resource returned by PDO::pgsqlLOBOpen().

安装

Use --with-pdo-pgsql[=DIR] to install the PDO PostgreSQL extension, where the optional [=DIR] is the PostgreSQL base install directory, or the path to pg_config.

$ ./configure --with-pdo-pgsql

Table of Contents

  • PDO_PGSQL DSN — Connecting to PostgreSQL databases
  • PDO::pgsqlCopyFromArray — Copy data from PHP array into table
  • PDO::pgsqlCopyFromFile — Copy data from file into table
  • PDO::pgsqlCopyToArray — Copy data from database table into PHP array
  • PDO::pgsqlCopyToFile — Copy data from table into file
  • PDO::pgsqlGetNotify — Get asynchronous notification
  • PDO::pgsqlGetPid — Get the server PID
  • PDO::pgsqlLOBCreate — Creates a new large object
  • PDO::pgsqlLOBOpen — Opens an existing large object stream
  • PDO::pgsqlLOBUnlink — Deletes the large object


Connecting to PostgreSQL databases

  • ? PostgreSQL (PDO)
  • PDO::pgsqlCopyFromArray ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Connecting to PostgreSQL databases

PDO_PGSQL DSN

(PHP 5 >= 5.1.0, PHP 7, PECL PDO_PGSQL >= 0.1.0)

PDO_PGSQL DSN — Connecting to PostgreSQL databases

说明

The PDO_PGSQL Data Source Name (DSN) is composed of the following elements, delimited by spaces or semicolons:

DSN prefix

The DSN prefix is pgsql:.

host

The hostname on which the database server resides.

port

The port on which the database server is running.

dbname

The name of the database.

user

The name of the user for the connection. If you specify the user name in the DSN, PDO ignores the value of the user name argument in the PDO constructor.

password

The password of the user for the connection. If you specify the password in the DSN, PDO ignores the value of the password argument in the PDO constructor.

Note:

The bytea fields are returned as streams.

范例

Example #1 PDO_PGSQL DSN examples

The following example shows a PDO_PGSQL DSN for connecting to a PostgreSQL database:

pgsql:host=localhost;port=5432;dbname=testdb;user=bruce;password=mypass


Copy data from PHP array into table

  • ? PDO_PGSQL DSN
  • PDO::pgsqlCopyFromFile ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Copy data from PHP array into table

PDO::pgsqlCopyFromArray

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyFromArray — Copy data from PHP array into table

说明

public PDO::pgsqlCopyFromArray ( string $table_name , array $rows , string $delimiter = '\t' , string $null_as = "\\\\N" , string $fields = ? ) : bool

Copies data from rows array to table table_name using delimiter as fields delimiter and fields list

参数

table_name

String containing table name

rows

Array of strings with fields separated by delimiter

delimiter

Delimiter used in rows array

null_as

How to interpret null values

fields

List of fields to insert

返回值

Returns true on success, 或者在失败时返回 false.


Copy data from file into table

  • ? PDO::pgsqlCopyFromArray
  • PDO::pgsqlCopyToArray ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Copy data from file into table

PDO::pgsqlCopyFromFile

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyFromFile — Copy data from file into table

说明

public PDO::pgsqlCopyFromFile ( string $table_name , string $filename , string $delimiter = '\t' , string $null_as = "\\\\N" , string $fields = ? ) : bool

Copies data from file specified by filename into table table_name using delimiter as fields delimiter and fields list

参数

table_name

String containing table name

filename

Filename containing data to import

delimiter

Delimiter used in file specified by filename

null_as

How to interpret null values

fields

List of fields to insert

返回值

Returns true on success, 或者在失败时返回 false.


Copy data from database table into PHP array

  • ? PDO::pgsqlCopyFromFile
  • PDO::pgsqlCopyToFile ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Copy data from database table into PHP array

PDO::pgsqlCopyToArray

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyToArray — Copy data from database table into PHP array

说明

public PDO::pgsqlCopyToArray ( string $table_name , string $delimiter = '\t' , string $null_as = "\\\\N" , string $fields = ? ) : array|false

Copies data from table into array using delimiter as fields delimiter and fields list

参数

table_name

String containing table name

delimiter

Delimiter used in rows

null_as

How to interpret null values

fields

List of fields to export

返回值

Returns an array of rows, 或者在失败时返回 false.


Copy data from table into file

  • ? PDO::pgsqlCopyToArray
  • PDO::pgsqlGetNotify ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Copy data from table into file

PDO::pgsqlCopyToFile

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyToFile — Copy data from table into file

说明

public PDO::pgsqlCopyToFile ( string $table_name , string $filename , string $delimiter = '\t' , string $null_as = "\\\\N" , string $fields = ? ) : bool

Copies data from table into file specified by filename using delimiter as fields delimiter and fields list

参数

table_name

String containing table name

filename

Filename to export data

delimiter

Delimiter used in file specified by filename

null_as

How to interpret null values

fields

List of fields to insert

返回值

Returns true on success, 或者在失败时返回 false.


Get asynchronous notification

  • ? PDO::pgsqlCopyToFile
  • PDO::pgsqlGetPid ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Get asynchronous notification

PDO::pgsqlGetNotify

(PHP 5 >= 5.6.0, PHP 7)

PDO::pgsqlGetNotify — Get asynchronous notification

说明

public PDO::pgsqlGetNotify ( int $result_type = PDO::FETCH_USE_DEFAULT , int $ms_timeout = 0 ) : array

Returns a result set representing a pending asynchronous notification.

参数

result_type

The format the result set should be returned as, represented as a PDO::FETCH_* constant.

ms_timeout

The length of time to wait for a response, in milliseconds.

返回值

If one or more notifications is pending, returns a single row, with fields message and pid, otherwise returns false.


Get the server PID

  • ? PDO::pgsqlGetNotify
  • PDO::pgsqlLOBCreate ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Get the server PID

PDO::pgsqlGetPid

(PHP 5 >= 5.6.0, PHP 7)

PDO::pgsqlGetPid — Get the server PID

说明

public PDO::pgsqlGetPid ( ) : int

Returns the server's PID.

返回值

The server's PID.


Creates a new large object

  • ? PDO::pgsqlGetPid
  • PDO::pgsqlLOBOpen ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Creates a new large object

PDO::pgsqlLOBCreate

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBCreate — Creates a new large object

说明

public PDO::pgsqlLOBCreate ( ) : string

PDO::pgsqlLOBCreate() creates a large object and returns the OID of that object. You may then open a stream on the object using PDO::pgsqlLOBOpen() to read or write data to it. The OID can be stored in columns of type OID and be used to reference the large object, without causing the row to grow arbitrarily large. The large object will continue to live in the database until it is removed by calling PDO::pgsqlLOBUnlink().

Large objects can be up to 2GB in size, but are cumbersome to use; you need to ensure that PDO::pgsqlLOBUnlink() is called prior to deleting the last row that references its OID from your database. In addition, large objects have no access controls. As an alternative, try the bytea column type; recent versions of PostgreSQL allow bytea columns of up to 1GB in size and transparently manage the storage for optimal row size.

Note: This function must be called within a transaction.

参数

PDO::pgsqlLOBCreate() takes no parameters.

返回值

Returns the OID of the newly created large object on success, or false on failure.

范例

Example #1 A PDO::pgsqlLOBCreate() example

This example creates a new large object and copies the contents of a file into it. The OID is then stored into a table.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$oid = $db->pgsqlLOBCreate();
$stream = $db->pgsqlLOBOpen($oid, 'w');
$local = fopen($filename, 'rb');
stream_copy_to_stream($local, $stream);
$local = null;
$stream = null;
$stmt = $db->prepare("INSERT INTO BLOBS (ident, oid) VALUES (?, ?)");
$stmt->execute(array($some_id, $oid));
$db->commit();
?>

参见

  • PDO::pgsqlLOBOpen() - Opens an existing large object stream
  • PDO::pgsqlLOBUnlink() - Deletes the large object
  • pg_lo_create() - 新建一个大型对象


Opens an existing large object stream

  • ? PDO::pgsqlLOBCreate
  • PDO::pgsqlLOBUnlink ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Opens an existing large object stream

PDO::pgsqlLOBOpen

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBOpen — Opens an existing large object stream

说明

public PDO::pgsqlLOBOpen ( string $oid , string $mode = "rb" ) : resource|false

PDO::pgsqlLOBOpen() opens a stream to access the data referenced by oid. If mode is r, the stream is opened for reading, if mode is w, then the stream will be opened for writing. You can use all the usual filesystem functions, such as fread(), fwrite() and fgets() to manipulate the contents of the stream.

Note: This function, and all manipulations of the large object, must be called and carried out within a transaction.

参数

oid

A large object identifier.

mode

If mode is r, open the stream for reading. If mode is w, open the stream for writing.

返回值

Returns a stream resource on success 或者在失败时返回 false.

范例

Example #1 A PDO::pgsqlLOBOpen() example

Following on from the PDO::pgsqlLOBCreate() example, this code snippet retrieves the large object from the database and outputs it to the browser.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$stmt = $db->prepare("select oid from BLOBS where ident = ?");
$stmt->execute(array($some_id));
$stmt->bindColumn('oid', $oid, PDO::PARAM_STR);
$stmt->fetch(PDO::FETCH_BOUND);
$stream = $db->pgsqlLOBOpen($oid, 'r');
header("Content-type: application/octet-stream");
fpassthru($stream);
?>

参见

  • PDO::pgsqlLOBCreate() - Creates a new large object
  • PDO::pgsqlLOBUnlink() - Deletes the large object
  • pg_lo_open() - 打开一个大型对象


Deletes the large object

  • ? PDO::pgsqlLOBOpen
  • SQLite (PDO) ?
  • PHP Manual
  • PostgreSQL (PDO)
  • Deletes the large object

PDO::pgsqlLOBUnlink

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBUnlink — Deletes the large object

说明

public PDO::pgsqlLOBUnlink ( string $oid ) : bool

Deletes a large object from the database identified by OID.

Note: This function must be called within a transaction.

参数

oid

A large object identifier

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 A PDO::pgsqlLOBUnlink() example

This example unlinks a large object from the database prior to deleting the row that references it from the blobs table we've been using in our PDO::pgsqlLOBCreate() and PDO::pgsqlLOBOpen() examples.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$db->pgsqlLOBUnlink($oid);
$stmt = $db->prepare("DELETE FROM BLOBS where ident = ?");
$stmt->execute(array($some_id));
$db->commit();
?>

参见

  • PDO::pgsqlLOBOpen() - Opens an existing large object stream
  • PDO::pgsqlLOBCreate() - Creates a new large object


SQLite Functions (PDO_SQLITE)

简介

PDO_SQLITE is a driver that implements the PHP Data Objects (PDO) interface to enable access to SQLite 3 databases.

Note:

PDO_SQLITE allows using strings apart from streams together with PDO::PARAM_LOB.

安装

The PDO_SQLITE PDO driver is enabled by default. To disable, --without-pdo-sqlite[=DIR] may be used, where the optional [=DIR] is the sqlite base install directory. As of PHP 7.4.0 » libsqlite ≥ 3.5.0 is required. Formerly, the bundled libsqlite could have been used instead, and was the default, if [=DIR] has been omitted.

Note: Additional setup on Windows as of PHP 7.4.0

为了使此扩展生效， DLL 文件必须能在 Windows 系统的 PATH 指示的路径下找到。如何操作的信息，请参见题为"如何在 Windows 中将 PHP 目录加到 PATH 中"的FAQ。虽然将 DLL 文件从 PHP 文件夹复制到 Windows 系统目录也行，但不建议这样做。 此扩展需要下列文件在 PATH 路径中： libsqlite3.dll.

Table of Contents

  • PDO_SQLITE DSN — Connecting to SQLite databases
  • PDO::sqliteCreateAggregate — Registers an aggregating User Defined Function for use in SQL statements
  • PDO::sqliteCreateCollation — Registers a User Defined Function for use as a collating function in SQL statements
  • PDO::sqliteCreateFunction — Registers a User Defined Function for use in SQL statements


Connecting to SQLite databases

  • ? SQLite (PDO)
  • PDO::sqliteCreateAggregate ?
  • PHP Manual
  • SQLite (PDO)
  • Connecting to SQLite databases

PDO_SQLITE DSN

(PHP 5 >= 5.1.0, PHP 7, PECL PDO_SQLITE >= 0.2.0)

PDO_SQLITE DSN — Connecting to SQLite databases

说明

The PDO_SQLITE Data Source Name (DSN) is composed of the following elements:

DSN prefix (SQLite 3)

The DSN prefix is sqlite:.

  • To access a database on disk, the absolute path has to be appended to the DSN prefix.

  • To create a database in memory, :memory: has to be appended to the DSN prefix.

  • If the DSN consists of the DSN prefix only, a temporary database is used, which is deleted when the connection is closed.

范例

Example #1 PDO_SQLITE DSN examples

The following examples show PDO_SQLITE DSN for connecting to SQLite databases:

sqlite:/opt/databases/mydb.sq3
sqlite::memory:
sqlite:


Registers an aggregating User Defined Function for use in SQL statements

  • ? PDO_SQLITE DSN
  • PDO::sqliteCreateCollation ?
  • PHP Manual
  • SQLite (PDO)
  • Registers an aggregating User Defined Function for use in SQL statements

PDO::sqliteCreateAggregate

(PHP 5 >= 5.1.0, PHP 7, PECL pdo_sqlite >= 1.0.0)

PDO::sqliteCreateAggregate — Registers an aggregating User Defined Function for use in SQL statements

说明

public PDO::sqliteCreateAggregate ( string $function_name , callable $step_func , callable $finalize_func , int $num_args = ? ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

This method is similar to PDO::sqliteCreateFunction except that it registers functions that can be used to calculate a result aggregated across all the rows of a query.

The key difference between this method and PDO::sqliteCreateFunction is that two functions are required to manage the aggregate.

参数

function_name

The name of the function used in SQL statements.

step_func

Callback function called for each row of the result set. Your PHP function should accumulate the result and store it in the aggregation context.

This function need to be defined as:

step ( mixed $context , int $rownumber , mixed $value , mixed ...$values ) : mixed
context

null for the first row; on subsequent rows it will have the value that was previously returned from the step function; you should use this to maintain the aggregate state.

rownumber

The current row number.

value

The first argument passed to the aggregate.

values

Further arguments passed to the aggregate.

The return value of this function will be used as the context argument in the next call of the step or finalize functions.

finalize_func

Callback function to aggregate the "stepped" data from each row. Once all the rows have been processed, this function will be called and it should then take the data from the aggregation context and return the result. This callback function should return a type understood by SQLite (i.e. scalar type).

This function need to be defined as:

fini ( mixed $context , int $rowcount ) : mixed
context

Holds the return value from the very last call to the step function.

rowcount

Holds the number of rows over which the aggregate was performed.

The return value of this function will be used as the return value for the aggregate.

num_args

Hint to the SQLite parser if the callback function accepts a predetermined number of arguments.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 max_length aggregation function example

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$db = new PDO('sqlite::memory:');
$db->exec("CREATE TABLE strings(a)");
$insert = $db->prepare('INSERT INTO strings VALUES (?)');
foreach ($data as $str) {
    $insert->execute(array($str));
}
$insert = null;

function max_len_step($context, $rownumber, $string)
{
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
    return $context;
}

function max_len_finalize($context, $rowcount)
{
    return $context === null ? 0 : $context;
}

$db->sqliteCreateAggregate('max_len', 'max_len_step', 'max_len_finalize');

var_dump($db->query('SELECT max_len(a) from strings')->fetchAll());

?>

In this example, we are creating an aggregating function that will calculate the length of the longest string in one of the columns of the table. For each row, the max_len_step function is called and passed a $context parameter. The context parameter is just like any other PHP variable and be set to hold an array or even an object value. In this example, we are simply using it to hold the maximum length we have seen so far; if the $string has a length longer than the current maximum, we update the context to hold this new maximum length.

After all of the rows have been processed, SQLite calls the max_len_finalize function to determine the aggregate result. Here, we could perform some kind of calculation based on the data found in the $context. In our simple example though, we have been calculating the result as the query progressed, so we simply need to return the context value.

Tip

It is NOT recommended for you to store a copy of the values in the context and then process them at the end, as you would cause SQLite to use a lot of memory to process the query - just think of how much memory you would need if a million rows were stored in memory, each containing a string 32 bytes in length.

Tip

You can use PDO::sqliteCreateFunction and PDO::sqliteCreateAggregate to override SQLite native SQL functions.

参见

  • PDO::sqliteCreateFunction
  • sqlite_create_function()
  • sqlite_create_aggregate()


Registers a User Defined Function for use as a collating function in SQL statements

  • ? PDO::sqliteCreateAggregate
  • PDO::sqliteCreateFunction ?
  • PHP Manual
  • SQLite (PDO)
  • Registers a User Defined Function for use as a collating function in SQL statements

PDO::sqliteCreateCollation

(PHP 5 >= 5.3.11, PHP 7)

PDO::sqliteCreateCollation — Registers a User Defined Function for use as a collating function in SQL statements

说明

public PDO::sqliteCreateCollation ( string $name , callable $callback ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

name

Name of the SQL collating function to be created or redefined.

callback

The name of a PHP function or user-defined function to apply as a callback, defining the behavior of the collation. It should accept two strings and return as strcmp() does, i.e. it should return -1, 1, or 0 if the first string sorts before, sorts after, or is equal to the second.

This function need to be defined as:

collation ( string $string1 , string $string2 ) : int

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 PDO::sqliteCreateCollation() example

<?php
$db = new PDO('sqlite::memory:');
$db->exec("CREATE TABLE test (col1 string)");
$db->exec("INSERT INTO test VALUES ('a1')");
$db->exec("INSERT INTO test VALUES ('a10')");
$db->exec("INSERT INTO test VALUES ('a2')");

$db->sqliteCreateCollation('NATURAL_CMP', 'strnatcmp');
foreach ($db->query("SELECT col1 FROM test ORDER BY col1") as $row) {
  echo $row['col1'] . "\n";
}
echo "\n";
foreach ($db->query("SELECT col1 FROM test ORDER BY col1 COLLATE NATURAL_CMP") as $row) {
  echo $row['col1'] . "\n";
}
?>

以上例程会输出：

a1
a10
a2

a1
a2
a10


Registers a User Defined Function for use in SQL statements

  • ? PDO::sqliteCreateCollation
  • 针对各数据库系统对应的扩展 ?
  • PHP Manual
  • SQLite (PDO)
  • Registers a User Defined Function for use in SQL statements

PDO::sqliteCreateFunction

(PHP 5 >= 5.1.0, PHP 7, PECL pdo_sqlite >= 1.0.0)

PDO::sqliteCreateFunction — Registers a User Defined Function for use in SQL statements

说明

public PDO::sqliteCreateFunction ( string $function_name , callable $callback , int $num_args = -1 , int $flags = 0 ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

This method allows you to register a PHP function with SQLite as an UDF (User Defined Function), so that it can be called from within your SQL statements.

The UDF can be used in any SQL statement that can call functions, such as SELECT and UPDATE statements and also in triggers.

参数

function_name

The name of the function used in SQL statements.

callback

Callback function to handle the defined SQL function.

Note: Callback functions should return a type understood by SQLite (i.e. scalar type).

This function need to be defined as:

callback ( mixed $value , mixed ...$values ) : mixed
value

The first argument passed to the SQL function.

values

Further arguments passed to the SQL function.

num_args

The number of arguments that the SQL function takes. If this parameter is -1, then the SQL function may take any number of arguments.

flags

A bitwise conjunction of flags. Currently, only PDO::SQLITE_DETERMINISTIC is supported, which specifies that the function always returns the same result given the same inputs within a single SQL statement.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.1.4 | The flags parameter has been added.

范例

Example #1 PDO::sqliteCreateFunction() example

<?php
function md5_and_reverse($string)
{
    return strrev(md5($string));
}

$db = new PDO('sqlite:sqlitedb');
$db->sqliteCreateFunction('md5rev', 'md5_and_reverse', 1);
$rows = $db->query('SELECT md5rev(filename) FROM files')->fetchAll();
?>

In this example, we have a function that calculates the md5 sum of a string, and then reverses it. When the SQL statement executes, it returns the value of the filename transformed by our function. The data returned in $rows contains the processed result.

The beauty of this technique is that you do not need to process the result using a foreach loop after you have queried for the data.

Tip

You can use PDO::sqliteCreateFunction and PDO::sqliteCreateAggregate to override SQLite native SQL functions.

参见

  • PDO::sqliteCreateAggregate
  • sqlite_create_function()
  • sqlite_create_aggregate()


针对各数据库系统对应的扩展

  • CUBRID
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • CUBRID 函数
    • CUBRID MySQL 兼容性函数
    • CUBRID 过时的别名和函数
  • DB++
    • 简介
    • 安装／配置
    • 预定义常量
    • DB++ 函数
  • dBase
    • 简介
    • 安装／配置
    • 预定义常量
    • dBase 函数
  • filePro
    • 简介
    • 安装／配置
    • 预定义常量
    • filePro 函数
  • Firebird/InterBase
    • 简介
    • 安装／配置
    • 预定义常量
    • Firebird/InterBase 函数
  • FrontBase
    • 简介
    • 安装／配置
    • 预定义常量
    • FrontBase 函数
  • IBM DB2 — IBM DB2, Cloudscape and Apache Derby
    • 简介
    • 安装／配置
    • 预定义常量
    • IBM DB2 函数
  • Ingres — Ingres DBMS, EDBC, and Enterprise Access Gateways
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Ingres 函数
  • Mongo — MongoDB 驱动（旧版）
    • 安装／配置
    • 预定义常量
    • 手册
    • 核心类
    • Types
    • GridFS Classes
    • Miscellaneous
    • Mongo 函数
    • Exceptions
    • 更新日志
  • MongoDB — MongoDB driver
    • 安装／配置
    • Tutorials
    • Driver Architecture and Internals — Explains the driver architecture, and special features
    • Security
    • MongoDB\Driver — MongoDB 驱动类
    • MongoDB\BSON — BSON type classes and serialization functions
    • MongoDB\Driver\Monitoring — Monitoring classes and subscriber functions
    • MongoDB\Driver\Exception — Exception 类
  • MySQL — MySQL Drivers and Plugins
    • Overview of the MySQL PHP drivers
    • Mysqli — MySQL增强版扩展
    • Mysql_xdevapi
    • Mysql（原始） — 原始的 MySQL API
    • Mysqlnd — MySQL Native Driver
    • mysqlnd_ms — Mysqlnd 主从复制和负载均衡插件
    • mysqlnd_qc — Mysqlnd query result cache plugin
    • mysqlnd_uh — Mysqlnd user handler plugin
    • mysqlnd_mux — Mysqlnd connection multiplexing plugin
    • mysqlnd_memcache — Mysqlnd Memcache plugin
  • OCI8 — Oracle OCI8
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • OCI8 Connection Handling and Connection Pooling
    • OCI8 Fast Application Notification (FAN) Support
    • OCI8 Transparent Application Failover (TAF) Support
    • OCI8 and DTrace Dynamic Tracing
    • Supported Datatypes
    • OCI8 函数
    • OCICollection — The OCICollection class
    • OCILob — The OCILob class
    • OCI8 Obsolete Aliases and Functions
  • Paradox — Paradox File Access
    • 简介
    • 安装／配置
    • 预定义常量
    • Paradox 函数
  • PostgreSQL
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • PostgreSQL 函数
  • SQLite3
    • 简介
    • 安装／配置
    • 预定义常量
    • SQLite3 — SQLite3 类
    • SQLite3Stmt — SQLite3Stmt 类
    • SQLite3Result — SQLite3Result 类
  • SQLSRV — Microsoft SQL Server Driver for PHP
    • 简介
    • 安装／配置
    • 预定义常量
    • SQLSRV 函数
  • tokyo_tyrant
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • TokyoTyrant — The TokyoTyrant class
    • TokyoTyrantTable — The TokyoTyrantTable class
    • TokyoTyrantQuery — The TokyoTyrantQuery class
    • TokyoTyrantIterator — The TokyoTyrantIterator class
    • TokyoTyrantException — The TokyoTyrantException class


CUBRID

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • CUBRID 函数
    • cubrid_bind — Bind variables to a prepared statement as parameters
    • cubrid_close_prepare — Close the request handle
    • cubrid_close_request — Close the request handle
    • cubrid_col_get — Get contents of collection type column using OID
    • cubrid_col_size — Get the number of elements in collection type column using OID
    • cubrid_column_names — Get the column names in result
    • cubrid_column_types — Get column types in result
    • cubrid_commit — Commit a transaction
    • cubrid_connect_with_url — Establish the environment for connecting to CUBRID server
    • cubrid_connect — Open a connection to a CUBRID Server
    • cubrid_current_oid — Get OID of the current cursor location
    • cubrid_disconnect — Close a database connection
    • cubrid_drop — Delete an instance using OID
    • cubrid_error_code_facility — Get the facility code of error
    • cubrid_error_code — Get error code for the most recent function call
    • cubrid_error_msg — Get last error message for the most recent function call
    • cubrid_execute — Execute a prepared SQL statement
    • cubrid_fetch — Fetch the next row from a result set
    • cubrid_free_result — Free the memory occupied by the result data
    • cubrid_get_autocommit — Get auto-commit mode of the connection
    • cubrid_get_charset — Return the current CUBRID connection charset
    • cubrid_get_class_name — Get the class name using OID
    • cubrid_get_client_info — Return the client library version
    • cubrid_get_db_parameter — Returns the CUBRID database parameters
    • cubrid_get_query_timeout — Get the query timeout value of the request
    • cubrid_get_server_info — Return the CUBRID server version
    • cubrid_get — Get a column using OID
    • cubrid_insert_id — Return the ID generated for the last updated AUTO_INCREMENT column
    • cubrid_is_instance — Check whether the instance pointed by OID exists
    • cubrid_lob_close — Close BLOB/CLOB data
    • cubrid_lob_export — Export BLOB/CLOB data to file
    • cubrid_lob_get — Get BLOB/CLOB data
    • cubrid_lob_send — Read BLOB/CLOB data and send straight to browser
    • cubrid_lob_size — Get BLOB/CLOB data size
    • cubrid_lob2_bind — Bind a lob object or a string as a lob object to a prepared statement as parameters
    • cubrid_lob2_close — Close LOB object
    • cubrid_lob2_export — Export the lob object to a file
    • cubrid_lob2_import — Import BLOB/CLOB data from a file
    • cubrid_lob2_new — Create a lob object
    • cubrid_lob2_read — Read from BLOB/CLOB data
    • cubrid_lob2_seek64 — Move the cursor of a lob object
    • cubrid_lob2_seek — Move the cursor of a lob object
    • cubrid_lob2_size64 — Get a lob object's size
    • cubrid_lob2_size — Get a lob object's size
    • cubrid_lob2_tell64 — Tell the cursor position of the LOB object
    • cubrid_lob2_tell — Tell the cursor position of the LOB object
    • cubrid_lob2_write — Write to a lob object
    • cubrid_lock_read — Set a read lock on the given OID
    • cubrid_lock_write — Set a write lock on the given OID
    • cubrid_move_cursor — Move the cursor in the result
    • cubrid_next_result — Get result of next query when executing multiple SQL statements
    • cubrid_num_cols — Return the number of columns in the result set
    • cubrid_num_rows — Get the number of rows in the result set
    • cubrid_pconnect_with_url — Open a persistent connection to CUBRID server
    • cubrid_pconnect — Open a persistent connection to a CUBRID server
    • cubrid_prepare — Prepare a SQL statement for execution
    • cubrid_put — Update a column using OID
    • cubrid_rollback — Roll back a transaction
    • cubrid_schema — Get the requested schema information
    • cubrid_seq_drop — Delete an element from sequence type column using OID
    • cubrid_seq_insert — Insert an element to a sequence type column using OID
    • cubrid_seq_put — Update the element value of sequence type column using OID
    • cubrid_set_add — Insert a single element to set type column using OID
    • cubrid_set_autocommit — Set autocommit mode of the connection
    • cubrid_set_db_parameter — Sets the CUBRID database parameters
    • cubrid_set_drop — Delete an element from set type column using OID
    • cubrid_set_query_timeout — Set the timeout time of query execution
    • cubrid_version — Get the CUBRID PHP module's version
  • CUBRID MySQL 兼容性函数
    • cubrid_affected_rows — Return the number of rows affected by the last SQL statement
    • cubrid_client_encoding — Return the current CUBRID connection charset
    • cubrid_close — Close CUBRID connection
    • cubrid_data_seek — Move the internal row pointer of the CUBRID result
    • cubrid_db_name — Get db name from results of cubrid_list_dbs
    • cubrid_errno — Return the numerical value of the error message from previous CUBRID operation
    • cubrid_error — Get the error message
    • cubrid_fetch_array — Fetch a result row as an associative array, a numeric array, or both
    • cubrid_fetch_assoc — Return the associative array that corresponds to the fetched row
    • cubrid_fetch_field — Get column information from a result and return as an object
    • cubrid_fetch_lengths — Return an array with the lengths of the values of each field from the current row
    • cubrid_fetch_object — Fetch the next row and return it as an object
    • cubrid_fetch_row — Return a numerical array with the values of the current row
    • cubrid_field_flags — Return a string with the flags of the given field offset
    • cubrid_field_len — Get the maximum length of the specified field
    • cubrid_field_name — Return the name of the specified field index
    • cubrid_field_seek — Move the result set cursor to the specified field offset
    • cubrid_field_table — Return the name of the table of the specified field
    • cubrid_field_type — Return the type of the column corresponding to the given field offset
    • cubrid_list_dbs — Return an array with the list of all existing CUBRID databases
    • cubrid_num_fields — Return the number of columns in the result set
    • cubrid_ping — Ping a server connection or reconnect if there is no connection
    • cubrid_query — Send a CUBRID query
    • cubrid_real_escape_string — Escape special characters in a string for use in an SQL statement
    • cubrid_result — Return the value of a specific field in a specific row
    • cubrid_unbuffered_query — Perform a query without fetching the results into memory
  • CUBRID 过时的别名和函数
    • cubrid_load_from_glo — Read data from a GLO instance and save it in a file
    • cubrid_new_glo — Create a glo instance
    • cubrid_save_to_glo — Save requested file in a GLO instance
    • cubrid_send_glo — Read data from glo and send it to std output


简介

这些函数可以让你访问CUBRID数据库服务。更多关于CUBRID的信息可以在» CUBRID找到。

在» CUBRID 参考资料 可以找到关于CUBRID的参考资料。


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

为使这些函数可用，必须安装CUBRID和编译CUBRID PHP库，提供CUBRID支持。


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/cubrid.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。

关于在Linux和Windows系统上的安装手册信息，请阅读包含在包中的这个文件build-guide.html。


  • ? 安装
  • 资源类型 ?
  • PHP Manual
  • 安装／配置
  • 运行时配置

运行时配置

无运行时配置


资源类型

在CUBRID中使用四种资源类型。第一个用于连接数据库的链接标识符，第二个是保存一个查询结果的资源类型，以及最后两个保存BLOB/CLOB查询结果的资源数据类型。

connection 标识符

由 cubrid_connect(),
cubrid_connect_with_url(),
cubrid_pconnect() 以及
cubrid_pconnect_with_url()返回的一个连接标识符。

request 标识符

由 cubrid_prepare() 和 cubrid_execute()返回的一个请求标识符。

LOB 标识符

由cubrid_lob_get()返回的一个LOB 标识符。

LOB2 标识符

由 cubrid_lob2_new()返回或从结果集中获取的一个LOB 标识符


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

下列常量在执行SQL语句的时候可能被用到。它们可以被传递给cubrid_prepare() 和 cubrid_execute()。

CUBRID SQL 执行标志
常量 | 说明
CUBRID_INCLUDE_OID | Determine whether to get OID during query execution.
CUBRID_ASYNC | Execute the query in asynchronous mode.
CUBRID_EXEC_QUERY_ALL | Execute the query in synchronous mode. This flag must be set when executing multiple SQL statements.

The following constants can be used when fetching the results to specify fetch behaviour. They can be passed to cubrid_fetch() and cubrid_fetch_array().

CUBRID fetch flags
Constant | Description
CUBRID_NUM | Get query result as a numeric array (0-default).
CUBRID_ASSOC | Get query result as an associative array.
CUBRID_BOTH | Get query result as both numeric and associative arrays (default value).
CUBRID_OBJECT | Get query result an object.
CUBRID_LOB | The constant CUBRID_LOB can be used when you want to operate the lob object. It can be passed to cubrid_fetch(), cubrid_fetch_row(), cubrid_fetch_array(), cubrid_fetch_assoc() and cubrid_fetch_object().

The following constants can be used when positioning the cursor in query results. They can be passed to or returned by cubrid_move_cursor().

CUBRID cursor position flags
Constant | Description
CUBRID_CURSOR_FIRST | Move current cursor to the first position in the result.
CUBRID_CURSOR_CURRENT | Move current cursor as a default value if the origin is not specified.
CUBRID_CURSOR_LAST | Move current cursor to the last position in the result.
CUBRID_CURSOR_SUCCESS | Returned value of cubrid_move_cursor() function in case of success. This flag has been removed from 8.4.1.
CUBRID_NO_MORE_DATA | Returned value of cubrid_move_cursor() function in case of failure. This flag has been removed from 8.4.1.
CUBRID_CURSOR_ERROR | Returned value of cubrid_move_cursor() function in case of failure. This flag has been removed from 8.4.1.

The following constants can be used when setting the auto-commit mode for the database connection. They can be passed to cubrid_set_autocommit() or returned by cubrid_get_autocommit().

CUBRID auto-commit mode flags
Constant | Description
CUBRID_AUTOCOMMIT_TRUE | Enable the auto-commit mode.
CUBRID_AUTOCOMMIT_FALSE | Disable the auto-commit mode.

The following constants can be used when setting the database parameter. They can be passed to cubrid_set_db_parameter().

CUBRID parameter flags
Constant | Description
CUBRID_PARAM_ISOLATION_LEVEL | Transaction isolation level for the database connection.
CUBRID_PARAM_LOCK_TIMEOUT | Transaction timeout in seconds.

The following constants can be used when setting the transaction isolation level. They can be passed to cubrid_set_db_parameter() or returned by cubrid_get_db_parameter().

CUBRID isolation level flags
Constant | Description
TRAN_COMMIT_CLASS_UNCOMMIT_INSTANCE | The lowest isolation level (1). A dirty, non-repeatable or phantom read may occur for the tuple and a non-repeatable read may occur for the table as well.
TRAN_COMMIT_CLASS_COMMIT_INSTANCE | A relatively low isolation level (2). A dirty read does not occur, but non-repeatable or phantom read may occur.
TRAN_REP_CLASS_UNCOMMIT_INSTANCE | The default isolation of CUBRID (3). A dirty, non-repeatable or phantom read may occur for the tuple, but repeatable read is ensured for the table.
TRAN_REP_CLASS_COMMIT_INSTANCE | A relatively low isolation level (4). A dirty read does not occur, but non-repeatable or phantom read may.
TRAN_REP_CLASS_REP_INSTANCE | A relatively high isolation level (5). A dirty or non-repeatable read does not occur, but a phantom read may.
TRAN_SERIALIZABLE | The highest isolation level (6). Problems concerning concurrency (e.g. dirty read, non-repeatable read, phantom read, etc.) do not occur.

The following constants can be used when getting schema information. They can be passed to cubrid_schema().

CUBRID schema flags
Constant | Description
CUBRID_SCH_CLASS | Get name and type of table in CUBRID.
CUBRID_SCH_VCLASS | Get name and type of view in CUBRID.
CUBRID_SCH_QUERY_SPEC | Get the query definition of view.
CUBRID_SCH_ATTRIBUTE | Get the attributes of table column.
CUBRID_SCH_CLASS_ATTRIBUTE | Get the attributes of table.
CUBRID_SCH_METHOD | Get the instance method. The instance method is a method called by a class instance. It is used more often than the class method because most operations are executed in the instance.
CUBRID_SCH_CLASS_METHOD | Get the class method. The class method is a method called by a class object. It is usually used to create a new class instance or to initialize it. It is also used to access or update class attributes.
CUBRID_SCH_METHOD_FILE | Get the information of the file where the method of the table is defined.
CUBRID_SCH_SUPERCLASS | Get the name and type of table which table inherites attributes from.
CUBRID_SCH_SUBCLASS | Get the name and type of table which inherites attributes from this table.
CUBRID_SCH_CONSTRAINT | Get the table constraints.
CUBRID_SCH_TRIGGER | Get the table triggers.
CUBRID_SCH_CLASS_PRIVILEGE | Get the privilege information of table.
CUBRID_SCH_ATTR_PRIVILEGE | Get the privilege information of column.
CUBRID_SCH_DIRECT_SUPER_CLASS | Get the direct super table of table.
CUBRID_SCH_PRIMARY_KEY | Get the table primary key.
CUBRID_SCH_IMPORTED_KEYS | Get imported keys of table.
CUBRID_SCH_EXPORTED_KEYS | Get exported keys of table.
CUBRID_SCH_CROSS_REFERENCE | Get reference relationship of tow tables.

The following constants can be used when reporting errors. 在报告错误的时候，下列常量可能被用到。它们可能由cubrid_error_code_facility()返回。

CUBRID 错误功能代码
常量 | 说明
CUBRID_FACILITY_DBMS | The error occurred in CUBRID dbms.
CUBRID_FACILITY_CAS | The error occurred in CUBRID broker cas.
CUBRID_FACILITY_CCI | The error occurred in CUBRID cci.
CUBRID_FACILITY_CLIENT | The error occurred in CUBRID PHP client.


范例

下面是一个在PHP和CUBRID建立连接的简单的例子。本节将覆盖最基本和最显著的特性。下面的代码需要连接CUBRID数据库，这意味着 CUBRID服务和 CUBRID Broker已经运行。

下面用demodb数据库作为例子举例。默认在安装时就创建了。确认此数据库已经被创建。

Example #1 数据查询的例子

<html>
    <head>
    <meta http-equiv="content-type" content="text/html; charset=euc-kr">
    </head>
    <body>
    <center>
    <table border=2>
    <?php
        /**
         * Set server information for CUBRID connection. host_ip is the IP
         * address where the CUBRID Broker is installed (localhost in this
         * example), and host_port is the port number of the CUBRID Broker.
         * The port number is the default given during the installation.
         * For details, see "Administrator's Guide."
         */
        $host_ip = "localhost";
        $host_port = 33000;
        $db_name = "demodb";
        /**
         * Connect to CUBRID Server. Do not make the actual connection, but
         * only retain the connection information. The reason for not making
         * the actual connection is to handle transaction more efficiently
         * in the 3-tier architecture.
         */
        $cubrid_con = @cubrid_connect($host_ip, $host_port, $db_name);

        if (!$cubrid_con) {
            echo "Database Connection Error";
            exit;
        }
    ?>
    <?php
        $sql = "select sports, count(players) as players from event group by sports";
        /**
         * Request the CUBRID Server for the results of the SQL statement.
         * Now make the actual connection to the CUBRID Server.
         */
        $result = cubrid_execute($cubrid_con, $sql);

        if ($result) {
            /**
             * Get the column names from the result set created by the SQL query.
             */
            $columns = cubrid_column_names($result);
            /**
             * Get the number of columns in the result set created by the SQL query.
             */
            $num_fields = cubrid_num_cols($result);
            /**
             * List the column names of the result set on the screen.
             */
            echo("<tr>");

            while (list($key, $colname) = each($columns)) {
                echo("<td align=center>$colname</td>");
            }

            echo("</tr>");

            /**
             * Get the results from the result set.
             */
            while ($row = cubrid_fetch($result)) {
                echo("<tr>");

                for ($i = 0; $i < $num_fields; $i++) {
                    echo("<td align=center>");
                    echo($row[$i]);
                    echo("</td>");
                }

                echo("</tr>");
            }
        }
        /**
         * The PHP module in the CUBRID runs in a 3-tier architecture. Even when
         * calling SELECT for transaction processing, it is processed as a part
         * of the transaction. Therefore, the transaction needs to be rolled back
         * by calling commit or rollback even though SELECT was called for smooth
         * performance.
         */
        cubrid_commit($cubrid_con);
        cubrid_disconnect($cubrid_con);
    ?>
    </body>
    </html>

Example #2 数据插入的例子

<html>
    <head>
    <meta http-equiv="content-type" content="text/html; charset=euc- kr">
    </head>
    <body>
    <center>
    <table border=2>
    <?php
        /**
         * host_ip is the IP address where the CUBRID Broker is installed
         * host_port is the port number of the CUBRID Broker
         * db_name is the name of CUBRID Database
         */
        $host_ip = "localhost";
        $host_port = 33000;
        $db_name = "demodb";
        $cubrid_con = @cubrid_connect($host_ip, $host_port, $db_name);

        if (!$cubrid_con) {
            echo "Database Connection Error";
            exit;
        }
    ?>
    <?php
        $sql = "insert into olympic (host_year,host_nation,host_city,"
            . "opening_date,closing_date) values (2008, 'China', 'Beijing',"
            . "to_date('08-08-2008','mm-dd- yyyy'),to_date('08-24-2008','mm-dd-yyyy')) ;"
        $result = cubrid_execute($cubrid_con, $sql);
        if ($result) {
            /**
             * Handled successfully, so commit.
             */
            cubrid_commit($cubrid_con);
            echo("Inserted successfully ");
        } else {
            /**
             * Error occurred, so the error message is output and rollback is called.
             */
            echo(cubrid_error_msg());
            cubrid_rollback($cubrid_con);
        }
        cubrid_disconnect($cubrid_con);
    ?>
    </body>
    </html>


CUBRID 函数

Table of Contents

  • cubrid_bind — Bind variables to a prepared statement as parameters
  • cubrid_close_prepare — Close the request handle
  • cubrid_close_request — Close the request handle
  • cubrid_col_get — Get contents of collection type column using OID
  • cubrid_col_size — Get the number of elements in collection type column using OID
  • cubrid_column_names — Get the column names in result
  • cubrid_column_types — Get column types in result
  • cubrid_commit — Commit a transaction
  • cubrid_connect_with_url — Establish the environment for connecting to CUBRID server
  • cubrid_connect — Open a connection to a CUBRID Server
  • cubrid_current_oid — Get OID of the current cursor location
  • cubrid_disconnect — Close a database connection
  • cubrid_drop — Delete an instance using OID
  • cubrid_error_code_facility — Get the facility code of error
  • cubrid_error_code — Get error code for the most recent function call
  • cubrid_error_msg — Get last error message for the most recent function call
  • cubrid_execute — Execute a prepared SQL statement
  • cubrid_fetch — Fetch the next row from a result set
  • cubrid_free_result — Free the memory occupied by the result data
  • cubrid_get_autocommit — Get auto-commit mode of the connection
  • cubrid_get_charset — Return the current CUBRID connection charset
  • cubrid_get_class_name — Get the class name using OID
  • cubrid_get_client_info — Return the client library version
  • cubrid_get_db_parameter — Returns the CUBRID database parameters
  • cubrid_get_query_timeout — Get the query timeout value of the request
  • cubrid_get_server_info — Return the CUBRID server version
  • cubrid_get — Get a column using OID
  • cubrid_insert_id — Return the ID generated for the last updated AUTO_INCREMENT column
  • cubrid_is_instance — Check whether the instance pointed by OID exists
  • cubrid_lob_close — Close BLOB/CLOB data
  • cubrid_lob_export — Export BLOB/CLOB data to file
  • cubrid_lob_get — Get BLOB/CLOB data
  • cubrid_lob_send — Read BLOB/CLOB data and send straight to browser
  • cubrid_lob_size — Get BLOB/CLOB data size
  • cubrid_lob2_bind — Bind a lob object or a string as a lob object to a prepared statement as parameters
  • cubrid_lob2_close — Close LOB object
  • cubrid_lob2_export — Export the lob object to a file
  • cubrid_lob2_import — Import BLOB/CLOB data from a file
  • cubrid_lob2_new — Create a lob object
  • cubrid_lob2_read — Read from BLOB/CLOB data
  • cubrid_lob2_seek64 — Move the cursor of a lob object
  • cubrid_lob2_seek — Move the cursor of a lob object
  • cubrid_lob2_size64 — Get a lob object's size
  • cubrid_lob2_size — Get a lob object's size
  • cubrid_lob2_tell64 — Tell the cursor position of the LOB object
  • cubrid_lob2_tell — Tell the cursor position of the LOB object
  • cubrid_lob2_write — Write to a lob object
  • cubrid_lock_read — Set a read lock on the given OID
  • cubrid_lock_write — Set a write lock on the given OID
  • cubrid_move_cursor — Move the cursor in the result
  • cubrid_next_result — Get result of next query when executing multiple SQL statements
  • cubrid_num_cols — Return the number of columns in the result set
  • cubrid_num_rows — Get the number of rows in the result set
  • cubrid_pconnect_with_url — Open a persistent connection to CUBRID server
  • cubrid_pconnect — Open a persistent connection to a CUBRID server
  • cubrid_prepare — Prepare a SQL statement for execution
  • cubrid_put — Update a column using OID
  • cubrid_rollback — Roll back a transaction
  • cubrid_schema — Get the requested schema information
  • cubrid_seq_drop — Delete an element from sequence type column using OID
  • cubrid_seq_insert — Insert an element to a sequence type column using OID
  • cubrid_seq_put — Update the element value of sequence type column using OID
  • cubrid_set_add — Insert a single element to set type column using OID
  • cubrid_set_autocommit — Set autocommit mode of the connection
  • cubrid_set_db_parameter — Sets the CUBRID database parameters
  • cubrid_set_drop — Delete an element from set type column using OID
  • cubrid_set_query_timeout — Set the timeout time of query execution
  • cubrid_version — Get the CUBRID PHP module's version


Bind variables to a prepared statement as parameters

  • ? CUBRID 函数
  • cubrid_close_prepare ?
  • PHP Manual
  • CUBRID 函数
  • Bind variables to a prepared statement as parameters

cubrid_bind

(PECL CUBRID >= 8.3.0)

cubrid_bind — Bind variables to a prepared statement as parameters

说明

cubrid_bind ( resource $req_identifier , int $bind_index , mixed $bind_value , string $bind_value_type = ? ) : bool

The cubrid_bind() function is used to bind values to a corresponding named or question mark placeholder in the SQL statement that was passed to cubrid_prepare(). If bind_value_type is not given, string will be the default.

Note:

If the type of data to be bound is BLOB/CLOB, CUBRID will try to map the data as a PHP stream. If the actually bind value type is not stream, CUBRID will convert it to string, and use it as the full path and file name of a file on the client filesystem.

If the type of data to be bound explicitly is ENUM, the $bind_value argument should be the enum element which is in string format.

In CUBRID shard envrioment, the $bind_value_type must be included in the cubrid_bind function.

The following table shows the types of substitute values.

CUBRID Bind Date Types
Support | Bind Type | Corresponding SQL Type
Supported | STRING | CHAR, VARCHAR
 | NCHAR | NCHAR, NVARCHAR
 | BIT | BIT, VARBIT
 | NUMERIC or NUMBER | SHORT, INT, NUMERIC
 | FLOAT | FLOAT
 | DOUBLE | DOUBLE
 | TIME | TIME
 | DATE | DATE
 | TIMESTAMP | TIMESTAMP
 | OBJECT | OBJECT
 | ENUM | ENUM
 | BLOB | BLOB
 | CLOB | CLOB
 | NULL | NULL
Not supported | SET | SET
 | MULTISET | MULTISET
 | SEQUENCE | SEQUENCE

参数

req_identifier

Request identifier as a result of cubrid_prepare().

bind_index

Location of binding parameters. It starts with 1.

bind_value

Actual value for binding.

bind_value_type

A type of the value to bind. (It is omitted by default. Thus, the system internally uses string by default. However, you need to specify the exact type of the value as an argument when they are NCHAR, BIT, or BLOB/CLOB).

返回值

true, when process is successful.

false, when process is unsuccessful.

更新日志

版本 | 说明
8.3.1 | Added BLOB/CLOB data types support.

范例

Example #1 cubrid_bind() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$result = cubrid_execute($conn, "SELECT code FROM event WHERE sports='Basketball' and gender='M'");
$row = cubrid_fetch_array($result, CUBRID_ASSOC);
$event_code = $row["code"];

cubrid_close_request($result);

$game_req = cubrid_prepare($conn, "SELECT athlete_code FROM game WHERE host_year=1992 and event_code=? and nation_code='USA'");
cubrid_bind($game_req, 1, $event_code, "number");
cubrid_execute($game_req);

printf("--- Dream Team (1992 United States men's Olympic basketball team) ---\n");
while ($athlete_code = cubrid_fetch_array($game_req, CUBRID_NUM)) {
    $athlete_req = cubrid_prepare($conn, "SELECT name FROM athlete WHERE code=? AND nation_code='USA' AND event='Basketball' AND gender='M'");
    cubrid_bind($athlete_req, 1, $athlete_code[0], "number");
    cubrid_execute($athlete_req);
    $row = cubrid_fetch_assoc($athlete_req);
    printf("%s\n", $row["name"]);
}

cubrid_close_request($game_req);
cubrid_close_request($athlete_req);

cubrid_disconnect($conn);
?>

以上例程会输出：

--- Dream Team (1992 United States men's Olympic basketball team) ---
Stockton John
Robinson David
Pippen Scottie
Mullin C.
Malone Karl
Laettner C.
Jordan Michael
Johnson Earvin
Ewing Patrick
Drexler Clyde
Bird Larry
Barkley Charles

Example #2 cubrid_bind() BLOB/CLOB example

<?php
$con = cubrid_connect("localhost", 33000, "demodb", "dba", "");
if ($con) {
    cubrid_execute($con,"DROP TABLE if exists php_cubrid_lob_test");
    cubrid_execute($con,"CREATE TABLE php_cubrid_lob_test (doc_content CLOB)");
    $sql = "INSERT INTO php_cubrid_lob_test(doc_content) VALUES(?)";
    $req = cubrid_prepare($con, $sql);

    $fp = fopen("book.txt", "rb");

    cubrid_bind($req, 1, $fp, "clob");
    cubrid_execute($req);
}
?>

Example #3 cubrid_bind() BLOB/CLOB example

<?php
$con = cubrid_connect("localhost", 33000, "demodb", "dba", "");
if ($con) {
    cubrid_execute($con,"DROP TABLE if exists php_cubrid_lob_test");
    cubrid_execute($con,"CREATE TABLE php_cubrid_lob_test (image BLOB)");
    $sql = "INSERT INTO php_cubrid_lob_test(image) VALUES(?)";
    $req = cubrid_prepare($con, $sql);

    cubrid_bind($req, 1, "cubrid_logo.png", "blob");
    cubrid_execute($req);
}
?>

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_prepare() - Prepare a SQL statement for execution


Close the request handle

  • ? cubrid_bind
  • cubrid_close_request ?
  • PHP Manual
  • CUBRID 函数
  • Close the request handle

cubrid_close_prepare

(PECL CUBRID >= 8.3.0)

cubrid_close_prepare — Close the request handle

说明

cubrid_close_prepare ( resource $req_identifier ) : bool

The cubrid_close_prepare() function closes the request handle given by the req_identifier argument, and releases the memory region related to the handle. It is an alias of cubrid_close_request().

参数

req_identifier

Request identifier.

返回值

Return true on success.

范例

Example #1 cubrid_close_prepare() example

<?php
$con = cubrid_connect ("localhost", 33000, "demodb", "dba", "");
if ($con) {
   echo "connected successfully";
   $req = cubrid_execute ( $con, "select * from members",
                           CUBRID_INCLUDE_OID | CUBRID_ASYNC);
   if ($req) {
      while ( list ($id, $name) = cubrid_fetch ($req) ){
         echo $id;
         echo $name;
      }
      cubrid_close_prepare($req); // or you can use cubrid_close_request($req)
   }
   cubrid_disconnect($con);
}
?>

参见

  • cubrid_close_request() - Close the request handle


Close the request handle

  • ? cubrid_close_prepare
  • cubrid_col_get ?
  • PHP Manual
  • CUBRID 函数
  • Close the request handle

cubrid_close_request

(PECL CUBRID >= 8.3.0)

cubrid_close_request — Close the request handle

说明

cubrid_close_request ( resource $req_identifier ) : bool

The cubrid_close_request() function closes the request handle given by the req_identifier argument, and releases the memory region related to the handle. It is an alias of cubrid_close_prepare().

参数

req_identifier

Request identifier.

返回值

Return true on success.

范例

Example #1 cubrid_close_request() example

<?php
$con = cubrid_connect ("localhost", 33000, "demodb", "dba", "");
if ($con) {
   echo "connected successfully";
   $req = cubrid_execute ( $con, "select * from members",
                           CUBRID_INCLUDE_OID | CUBRID_ASYNC);
   if ($req) {
      while ( list ($id, $name) = cubrid_fetch ($req) ){
         echo $id;
         echo $name;
      }
      cubrid_close_request($req); // or you can use cubrid_close_prepare($req)
   }
   cubrid_disconnect($con);
}
?>

参见

  • cubrid_close_prepare() - Close the request handle


Get contents of collection type column using OID

  • ? cubrid_close_request
  • cubrid_col_size ?
  • PHP Manual
  • CUBRID 函数
  • Get contents of collection type column using OID

cubrid_col_get

(PECL CUBRID >= 8.3.0)

cubrid_col_get — Get contents of collection type column using OID

说明

cubrid_col_get ( resource $conn_identifier , string $oid , string $attr_name ) : array

The cubrid_col_get() function is used to get contents of the elements of the collection type (set, multiset, sequence) attribute you requested as an array.

参数

conn_identifier

Connection identifier.

oid

OID of the instance that you want to read.

attr_name

Attribute name that you want to read from the instance.

返回值

Array (0-based numerical array) containing the elements you requested, when process is successful;

false (to distinguish the error from the situation of attribute having empty collection or NULL, in case of error, a warning message is shown; in such case you can check the error by using cubrid_error_code()), when process is unsuccessful.

范例

Example #1 cubrid_col_get() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

$size = cubrid_col_size($conn, $oid, "b");
var_dump($size);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
int(3)


Get the number of elements in collection type column using OID

  • ? cubrid_col_get
  • cubrid_column_names ?
  • PHP Manual
  • CUBRID 函数
  • Get the number of elements in collection type column using OID

cubrid_col_size

(PECL CUBRID >= 8.3.0)

cubrid_col_size — Get the number of elements in collection type column using OID

说明

cubrid_col_size ( resource $conn_identifier , string $oid , string $attr_name ) : int

The cubrid_col_size() function is used to get the number of elements in a collection type (set, multiset, sequence) attribute.

参数

conn_identifier

Connection identifier.

oid

OID the instance that you want to work with.

attr_name

Name of the attribute that you want to work with.

返回值

Number of elements, when process is successful.

false, when process is unsuccessful.

更新日志

版本 | 说明
8.3.1 | Change return value: when process is unsuccessful, return false, not -1.

范例

Example #1 cubrid_col_size() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

$size = cubrid_col_size($conn, $oid, "b");
var_dump($size);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
int(3)


Get the column names in result

  • ? cubrid_col_size
  • cubrid_column_types ?
  • PHP Manual
  • CUBRID 函数
  • Get the column names in result

cubrid_column_names

(PECL CUBRID >= 8.3.0)

cubrid_column_names — Get the column names in result

说明

cubrid_column_names ( resource $req_identifier ) : array

The cubrid_column_names() function is used to get the column names of the query result by using req_identifier.

参数

req_identifier

Request identifier.

返回值

Array of string values containing the column names, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_column_names() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

以上例程会输出：

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10

参见

  • cubrid_prepare() - Prepare a SQL statement for execution
  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_column_types() - Get column types in result


Get column types in result

  • ? cubrid_column_names
  • cubrid_commit ?
  • PHP Manual
  • CUBRID 函数
  • Get column types in result

cubrid_column_types

(PECL CUBRID >= 8.3.0)

cubrid_column_types — Get column types in result

说明

cubrid_column_types ( resource $req_identifier ) : array

The cubrid_column_types() function gets column types of query results by using req_identifier.

参数

req_identifier

Request identifier.

返回值

Array of string values containing the column types, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_column_types() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

以上例程会输出：

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10

参见

  • cubrid_column_names() - Get the column names in result
  • cubrid_prepare() - Prepare a SQL statement for execution
  • cubrid_execute() - Execute a prepared SQL statement


Commit a transaction

  • ? cubrid_column_types
  • cubrid_connect_with_url ?
  • PHP Manual
  • CUBRID 函数
  • Commit a transaction

cubrid_commit

(PECL CUBRID >= 8.3.0)

cubrid_commit — Commit a transaction

说明

cubrid_commit ( resource $conn_identifier ) : bool

The cubrid_commit() function is used to execute commit on the transaction pointed by conn_identifier, currently in progress. Connection to the server is closed after the cubrid_commit() function is called; However, the connection handle is still valid.

In CUBRID PHP, auto-commit mode is disabled by default for transaction management. You can set it by using cubrid_set_autocommit(). You can get its status by using cubrid_get_autocommit(). Before you start a transaction, remember to disable the auto-commit mode.

参数

conn_identifier

Connection identifier.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_commit() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE publishers");

$sql = <<<EOD
CREATE TABLE publishers(
pub_id CHAR(3),
pub_name VARCHAR(20),
city VARCHAR(15),
state CHAR(2),
country VARCHAR(15)
)
EOD;
cubrid_set_autocommit($conn,false);
if (!cubrid_execute($conn, $sql)) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n", cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}

$req = cubrid_prepare($conn, "INSERT INTO publishers VALUES(?, ?, ?, ?, ?)");

$id_list = array("P01", "P02", "P03", "P04");
$name_list = array("Abatis Publishers", "Core Dump Books", "Schadenfreude Press", "Tenterhooks Press");
$city_list = array("New York", "San Francisco", "Hamburg", "Berkeley");
$state_list = array("NY", "CA", NULL, "CA");
$country_list = array("USA", "USA", "Germany", "USA");

for ($i = 0, $size = count($id_list); $i < $size; $i++) {
    cubrid_bind($req, 1, $id_list[$i]);
    cubrid_bind($req, 2, $name_list[$i]);
    cubrid_bind($req, 3, $city_list[$i]);
    cubrid_bind($req, 4, $state_list[$i]);
    cubrid_bind($req, 5, $country_list[$i]);

    if (!($ret = cubrid_execute($req))) {
        break;
    }
}

if (!$ret) {
    cubrid_rollback($conn);
} else {
    cubrid_commit($conn);

    $req = cubrid_execute($conn, "SELECT * FROM publishers");
    while ($result = cubrid_fetch_assoc($req)) {
        printf("%-3s %-20s %-15s %-3s %-15s\n",
            $result["pub_id"], $result["pub_name"], $result["city"], $result["state"], $result["country"]);
    }
}

cubrid_disconnect($conn);
?>

以上例程会输出：

P01 Abatis Publishers    New York        NY  USA
P02 Core Dump Books      San Francisco   CA  USA
P03 Schadenfreude Press  Hamburg             Germany
P04 Tenterhooks Press    Berkeley        CA  USA

参见

  • cubrid_rollback() - Roll back a transaction
  • cubrid_get_autocommit() - Get auto-commit mode of the connection
  • cubrid_set_autocommit() - Set autocommit mode of the connection


Establish the environment for connecting to CUBRID server

  • ? cubrid_commit
  • cubrid_connect ?
  • PHP Manual
  • CUBRID 函数
  • Establish the environment for connecting to CUBRID server

cubrid_connect_with_url

(PECL CUBRID >= 8.3.1)

cubrid_connect_with_url — Establish the environment for connecting to CUBRID server

说明

cubrid_connect_with_url ( string $conn_url , string $userid = ? , string $passwd = ? , bool $new_link = false ) : resource

The cubrid_connect_with_url() function is used to establish the environment for connecting to your server by using connection information passed with an url string argument. If the HA feature is enabled in CUBRID, you must specify the connection information of the standby server, which is used for failover when failure occurs, in the url string argument of this function. If the user name and password is not given, then the "PUBLIC" connection will be made by default.

<url> ::= CUBRID:<host>:<db_name>:<db_user>:<db_password>:[?<properties>]

<properties> ::= <property> [&<property>]

<properties> ::= alhosts=<alternative_hosts>[ &rctime=<time>]

<properties> ::= login_timeout=<milli_sec>

<properties> ::= query_timeout=<milli_sec>

<properties> ::= disconnect_on_query_timeout=true|false

<alternative_hosts> ::= <standby_broker1_host>:<port> [,<standby_broker2_host>:<port>]

<host> := HOSTNAME | IP_ADDR

<time> := SECOND

<milli_sec> := MILLI SECOND

  • host : A host name or IP address of the master database
  • db_name : A name of the database
  • db_user : A name of the database user
  • db_password : A database user password
  • alhosts : Specifies the broker information of the standby server, which is used for failover when it is impossible to connect to the active server. You can specify multiple brokers for failover, and the connection to the brokers is attempted in the order listed in alhosts
  • rctime : An interval between the attempts to connect to the active broker in which failure occurred. After a failure occurs, the system connects to the broker specified by althosts (failover), terminates the transaction, and then attempts to connect to the active broker of the master database at every rctime. The default value is 600 seconds.
  • login_timeout : Timeout value (unit: msec.) for database login. The default value is 0, which means infinite postponement.
  • query_timeout : Timeout value (unit: msec.) for query request. Upon timeout, a message to cancel requesting a query transferred to server is sent. The return value can depend on the disconnect_on_query_timeout configuration; even though the message to cancel a request is sent to server, that request may succeed.
  • disconnect_on_query_timeout : Configures a value whether to immediately return an error of function being executed upon timeout. The default value is false.

Note:

? and : that are used as identifiers in PHP connection URL can't be included in the password. The following is an example of a password that is invalid to use as connection URL because it contains "?:".

$url = "CUBRID:localhost:33000:tdb:dba:12?:?login_timeout=100";

Passwords that contain ? or : may be passed as a separate parameter.

$url = "CUBRID:localhost:33000:tbd:::?login_timeout=100";

$conn = cubrid_connect_with_url($url, "dba", "12?");

If user or password is empty,you can't delete ":",the following is an example.

$url = "CUBRID:localhost:33000:demodb:::";

参数

conn_url

A character string that contains server connection information.

userid

User name for the database.

passwd

User password.

new_link

If a second call is made to cubrid_connect_with_url() with the same arguments, no new connection will be established, but instead, the connection identifier of the already opened connection will be returned. The new_link parameter modifies this behavior and makes cubrid_connect_with_url() always open a new connection, even if cubrid_connect_with_url() was called before with the same parameters.

返回值

Connection identifier, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_connect_with_url() url without properties example

<?php
$conn_url = "CUBRID:localhost:33000:demodb:dba::";
$con = cubrid_connect_with_url($conn_url);

if ($con) {
   echo "connected successfully";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

Example #2 cubrid_connect_with_url() url with properties example

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::?login_timeout=100"
$con = cubrid_connect_with_url ($conn_url);

if ($con) {
   echo "connected successfully";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

参见

  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_pconnect() - Open a persistent connection to a CUBRID server
  • cubrid_pconnect_with_url() - Open a persistent connection to CUBRID server
  • cubrid_disconnect() - Close a database connection
  • cubrid_close() - Close CUBRID connection


Open a connection to a CUBRID Server

  • ? cubrid_connect_with_url
  • cubrid_current_oid ?
  • PHP Manual
  • CUBRID 函数
  • Open a connection to a CUBRID Server

cubrid_connect

(PECL CUBRID >= 8.3.1)

cubrid_connect — Open a connection to a CUBRID Server

说明

cubrid_connect ( string $host , int $port , string $dbname , string $userid = ? , string $passwd = ? , bool $new_link = false ) : resource

The cubrid_connect() function is used to establish the environment for connecting to your server by using your server address, port number, database name, user name, and password. If the user name and password is not given, then the "PUBLIC" connection will be made by default.

参数

host

Host name or IP address of CUBRID CAS server.

port

Port number of CUBRID CAS server (BROKER_PORT configured in $CUBRID/conf/cubrid_broker.conf).

dbname

Name of database.

userid

User name for the database. If not given, the default value is "public".

passwd

User password. If not given, the default value is "".

new_link

If a second call is made to cubrid_connect() with the same arguments, no new connection will be established, but instead, the connection identifier of the already opened connection will be returned. The new_link parameter modifies this behavior and makes cubrid_connect() always open a new connection, even if cubrid_connect() was called before with the same parameters.

返回值

Connection identifier, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_connect() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);
?>

以上例程会输出：

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

参见

  • cubrid_pconnect() - Open a persistent connection to a CUBRID server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server
  • cubrid_pconnect_with_url() - Open a persistent connection to CUBRID server
  • cubrid_disconnect() - Close a database connection
  • cubrid_close() - Close CUBRID connection


Get OID of the current cursor location

  • ? cubrid_connect
  • cubrid_disconnect ?
  • PHP Manual
  • CUBRID 函数
  • Get OID of the current cursor location

cubrid_current_oid

(PECL CUBRID >= 8.3.0)

cubrid_current_oid — Get OID of the current cursor location

说明

cubrid_current_oid ( resource $req_identifier ) : string

The cubrid_current_oid() function is used to get the oid of the current cursor location from the query result. To use cubrid_current_oid(), the query executed must be a updatable query, and the CUBRID_INCLUDE_OID option must be included during the query execution.

参数

req_identifier

Request identifier.

返回值

Oid of current cursor location, when process is successful

false, when process is unsuccessful.

范例

Example #1 cubrid_current_oid() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code", CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);
$res = cubrid_get($conn, $oid);

print_r($res);

cubrid_disconnect($conn);
?>

以上例程会输出：

Array
(
    [s_name] => X
    [f_name] => Mixed
)

参见

  • cubrid_execute() - Execute a prepared SQL statement


Close a database connection

  • ? cubrid_current_oid
  • cubrid_drop ?
  • PHP Manual
  • CUBRID 函数
  • Close a database connection

cubrid_disconnect

(PECL CUBRID >= 8.3.0)

cubrid_disconnect — Close a database connection

说明

cubrid_disconnect ( resource $conn_identifier = ? ) : bool

The cubrid_disconnect() function closes the connection handle and disconnects from server. If any request handle is not closed at this point, it will be closed. It is similar to the CUBRID MySQL compatible function cubrid_close().

参数

conn_identifier

Connection identifier.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_disconnect() example

<?php
$con = cubrid_connect ("localhost", 33000, "demodb");
if ($con) {
   echo "connected successfully";

   $req = cubrid_execute( $con, "create table person(id int,name char(10))");
   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }

   $req = cubrid_execute( $con, "insert into person values(1,'James')");
   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

参见

  • cubrid_close() - Close CUBRID connection
  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server


Delete an instance using OID

  • ? cubrid_disconnect
  • cubrid_error_code_facility ?
  • PHP Manual
  • CUBRID 函数
  • Delete an instance using OID

cubrid_drop

(PECL CUBRID >= 8.3.0)

cubrid_drop — Delete an instance using OID

说明

cubrid_drop ( resource $conn_identifier , string $oid ) : bool

The cubrid_drop() function is used to delete an instance from database by using the oid of the instance.

参数

conn_identifier

Connection identifier.

oid

Oid of the instance that you want to delete.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_drop() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

printf("--- Before Drop: ---\n");
$attr = cubrid_get($conn, $oid);
var_dump($attr);

if (cubrid_drop($conn, $oid)) {
    cubrid_commit($conn);
} else {
    cubrid_rollback($conn);
}

cubrid_close_request($req);

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

printf("\n--- After Drop: ---\n");
$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

--- Before Drop: ---
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

--- After Drop: ---
array(4) {
  ["a"]=>
  string(1) "2"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "4"
    [1]=>
    string(1) "5"
    [2]=>
    string(1) "7"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "44"
    [1]=>
    string(2) "55"
    [2]=>
    string(2) "66"
    [3]=>
    string(3) "666"
  }
  ["d"]=>
  string(10) "b         "
}

参见

  • cubrid_is_instance() - Check whether the instance pointed by OID exists


Get the facility code of error

  • ? cubrid_drop
  • cubrid_error_code ?
  • PHP Manual
  • CUBRID 函数
  • Get the facility code of error

cubrid_error_code_facility

(PECL CUBRID >= 8.3.0)

cubrid_error_code_facility — Get the facility code of error

说明

cubrid_error_code_facility ( ) : int

The cubrid_error_code_facility() function is used to get the facility code (level in which the error occurred) from the error code of the error that occurred during the API execution. Usually, you can get the error code when API returns false as its return value.

参数

此函数没有参数。

返回值

Facility code of the error code that occurred: CUBRID_FACILITY_DBMS, CUBRID_FACILITY_CAS, CUBRID_FACILITY_CCI, CUBRID_FACILITY_CLIENT

范例

Example #1 cubrid_error_code_facility() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = @cubrid_execute($conn, "SELECT * FROM unknown");
if (!$req) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

以上例程会输出：

Error facility: 1
Error code: -493
Error msg: Syntax: In line 1, column 15 before END OF STATEMENT
Syntax error: unexpected 'unknown'

参见

  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_msg() - Get last error message for the most recent function call


Get error code for the most recent function call

  • ? cubrid_error_code_facility
  • cubrid_error_msg ?
  • PHP Manual
  • CUBRID 函数
  • Get error code for the most recent function call

cubrid_error_code

(PECL CUBRID >= 8.3.0)

cubrid_error_code — Get error code for the most recent function call

说明

cubrid_error_code ( ) : int

The cubrid_error_code() function is used to get the error code of the error that occurred during the API execution. Usually, it gets the error code when API returns false as its return value.

参数

此函数没有参数。

返回值

Error code of the error that occurred, or 0 (zero) if no error occurred.

范例

Example #1 cubrid_error_code() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_prepare($conn , "SELECT * FROM code WHERE s_name=?");

$req = @cubrid_execute($req);
if (!$req) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

以上例程会输出：

Error facility: 4
Error code: -30015
Error msg: Some parameter not binded

参见

  • cubrid_error_code_facility() - Get the facility code of error
  • cubrid_error_msg() - Get last error message for the most recent function call


Get last error message for the most recent function call

  • ? cubrid_error_code
  • cubrid_execute ?
  • PHP Manual
  • CUBRID 函数
  • Get last error message for the most recent function call

cubrid_error_msg

(PECL CUBRID >= 8.3.0)

cubrid_error_msg — Get last error message for the most recent function call

说明

cubrid_error_msg ( ) : string

The cubrid_error_msg() function is used to get the error message that occurred during the use of CUBRID API. Usually, it gets error message when API returns false as its return value.

参数

此函数没有参数。

返回值

Error message that occurred.

范例

Example #1 cubrid_error_msg() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

if (!@cubrid_schema($conn, 100000)) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

以上例程会输出：

Error facility: 2
Error code: -10015
Error msg: Invalid T_CCI_SCH_TYPE value

参见

  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_code_facility() - Get the facility code of error


Execute a prepared SQL statement

  • ? cubrid_error_msg
  • cubrid_fetch ?
  • PHP Manual
  • CUBRID 函数
  • Execute a prepared SQL statement

cubrid_execute

(PECL CUBRID >= 8.3.0)

cubrid_execute — Execute a prepared SQL statement

说明

cubrid_execute ( resource $conn_identifier , string $sql , int $option = 0 ) : resource
cubrid_execute ( resource $request_identifier , int $option = 0 ) : bool

The cubrid_execute() function is used to execute the given SQL statement. It executes the query by using conn_identifier and SQL, and then returns the request identifier created. It is used for simple execution of query, where the parameter binding is not needed. In addition, the cubrid_execute() function is used to execute the prepared statement by means of cubrid_prepare() and cubrid_bind(). At this time, you need to specify arguments of request_identifier and option.

The option is used to determine whether to get OID after query execution and whether to execute the query in synchronous or asynchronous mode. CUBRID_INCLUDE_OID and CUBRID_ASYNC (or CUBRID_EXEC_QUERY_ALL if you want to execute multiple SQL statements) can be specified by using a bitwise OR operator. If not specified, neither of them isselected. If the flag CUBRID_EXEC_QUERY_ALL is set, a synchronous mode (sync_mode) is used to retrieve query results, and in such cases the following rules are applied:

  • The return value is the result of the first query.
  • If an error occurs in any query, the execution is processed as a failure.
  • In a query composed of q1 q2 q3, if an error occurs in q2 after q1 succeeds the execution, the result of q1 remains valid. That is, the previous successful query executions are not rolled back when an error occurs.
  • If a query is executed successfully, the result of the second query can be obtained using cubrid_next_result().

If the first argument is request_identifier to execute the cubrid_prepare() function, you can specify an option, CUBRID_ASYNC only.

参数

conn_identifier

Connection identifier.

sql

SQL to be executed.

option

Query execution option CUBRID_INCLUDE_OID, CUBRID_ASYNC, CUBRID_EXEC_QUERY_ALL.

request_identifier

cubrid_prepare() identifier.

返回值

Request identifier, when process is successful and first param is conn_identifier; true, when process is successful and first argument is request_identifier.

false, when process is unsuccessful.

更新日志

版本 | 说明
8.4.0 | Add new option CUBRID_EXEC_QUERY_ALL.

范例

Example #1 cubrid_execute() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$result = cubrid_execute($conn, "SELECT code FROM event WHERE name='100m Butterfly' and gender='M'", CUBRID_ASYNC);
$row = cubrid_fetch_array($result, CUBRID_ASSOC);
$event_code = $row["code"];

cubrid_close_request($result);

$history_req = cubrid_prepare($conn, "SELECT * FROM history WHERE event_code=?");
cubrid_bind($history_req, 1, $event_code, "number");
cubrid_execute($history_req);

printf("%-20s %-9s %-10s %-5s\n", "athlete", "host_year", "score", "unit");
while ($row = cubrid_fetch_array($history_req, CUBRID_ASSOC)) {
    printf("%-20s %-9s %-10s %-5s\n",
        $row["athlete"], $row["host_year"], $row["score"], $row["unit"]);
}

cubrid_close_request($history_req);

cubrid_disconnect($conn);
?>

以上例程会输出：

athlete              host_year score      unit
Phelps Michael       2004      51.25      time

参见

  • cubrid_prepare() - Prepare a SQL statement for execution
  • cubrid_bind() - Bind variables to a prepared statement as parameters
  • cubrid_next_result() - Get result of next query when executing multiple SQL statements
  • cubrid_close_request() - Close the request handle
  • cubrid_commit() - Commit a transaction
  • cubrid_rollback() - Roll back a transaction


Fetch the next row from a result set

  • ? cubrid_execute
  • cubrid_free_result ?
  • PHP Manual
  • CUBRID 函数
  • Fetch the next row from a result set

cubrid_fetch

(PECL CUBRID >= 8.3.0)

cubrid_fetch — Fetch the next row from a result set

说明

cubrid_fetch ( resource $result , int $type = CUBRID_BOTH ) : mixed

The cubrid_fetch() function is used to get a single row from the query result. The cursor automatically moves to the next row after getting the result.

参数

result

result comes from a call to cubrid_execute()

type

Array type of the fetched result CUBRID_NUM, CUBRID_ASSOC, CUBRID_BOTH, CUBRID_OBJECT. If you want to operate the lob object, you can use CUBRID_LOB.

返回值

Result array or object, when process is successful.

false, when there are no more rows; NULL, when process is unsuccessful.

The result can be received either as an array or as an object, and you can decide which data type to use by setting the type argument. The type variable can be set to one of the following values:

  • CUBRID_NUM : Numerical array (0-based)
  • CUBRID_ASSOC : Associative array
  • CUBRID_BOTH : Numerical & Associative array (default)
  • CUBRID_OBJECT : object that has the attribute name as the column name of query result

When type argument is omitted, the result will be received using CUBRID_BOTH option as default. When you want to receive query result in object data type, the column name of the result must obey the naming rules for identifiers in PHP. For example, column name such as "count(*)" cannot be received in object type.

范例

Example #1 cubrid_fetch() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT * FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($row = cubrid_fetch($req)) {
    printf("%-40s %-10s %-6s %-20s\n",
        $row["name"], $row["area"], $row["seats"], $row["address"]);
}

// if you want to operate lob object, you can use cubrid_fetch($req, CUBRID_LOB)

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

以上例程会输出：

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_row() - Return a numerical array with the values of the current row
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_fetch_object() - Fetch the next row and return it as an object


Free the memory occupied by the result data

  • ? cubrid_fetch
  • cubrid_get_autocommit ?
  • PHP Manual
  • CUBRID 函数
  • Free the memory occupied by the result data

cubrid_free_result

(PECL CUBRID >= 8.3.0)

cubrid_free_result — Free the memory occupied by the result data

说明

cubrid_free_result ( resource $req_identifier ) : bool

This function frees the memory occupied by the result data. It returns TRUE on success or FALSE on failure. Note that it can only frees the client fetch buffer now, and if you want free all memory, use function cubrid_close_request().

参数

req_identifier

This is the request identifier.

返回值

true on success.

false on failure.

范例

Example #1 cubrid_free_result() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM history WHERE host_year=2004 ORDER BY event_code");
$row = cubrid_fetch_assoc($req);
var_dump($row);

cubrid_free_result($req);
cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(5) {
  ["event_code"]=>
  string(5) "20005"
  ["athlete"]=>
  string(12) "Hayes Joanna"
  ["host_year"]=>
  string(4) "2004"
  ["score"]=>
  string(5) "12.37"
  ["unit"]=>
  string(4) "time"
}


Get auto-commit mode of the connection

  • ? cubrid_free_result
  • cubrid_get_charset ?
  • PHP Manual
  • CUBRID 函数
  • Get auto-commit mode of the connection

cubrid_get_autocommit

(PECL CUBRID >= 8.4.0)

cubrid_get_autocommit — Get auto-commit mode of the connection

说明

cubrid_get_autocommit ( resource $conn_identifier ) : bool

The cubrid_get_autocommit() function is used to get the status of CUBRID database connection auto-commit mode.

For CUBRID 8.4.0, auto-commit mode is disabled by default for transaction management.

For CUBRID 8.4.1, auto-commit mode is enabled by default for transaction management.

参数

conn_identifier

Connection identifier.

返回值

true, when auto-commit is on.

false, when auto-commit is off.

null on error.

参见

  • cubrid_set_autocommit() - Set autocommit mode of the connection
  • cubrid_commit() - Commit a transaction


Return the current CUBRID connection charset

  • ? cubrid_get_autocommit
  • cubrid_get_class_name ?
  • PHP Manual
  • CUBRID 函数
  • Return the current CUBRID connection charset

cubrid_get_charset

(PECL CUBRID >= 8.3.0)

cubrid_get_charset — Return the current CUBRID connection charset

说明

cubrid_get_charset ( resource $conn_identifier ) : string

This function returns the current CUBRID connection charset and is similar to the CUBRID MySQL compatible function cubrid_client_encoding().

参数

conn_identifier

The CUBRID connection.

返回值

A string that represents the CUBRID connection charset; on success.

false on failure.

范例

Example #1 cubrid_get_charset() example

<?php

$con = cubrid_connect("localhost", 33000, "demodb");
if (!$con)
{
    die('Could not connect.');
}

printf("CUBRID current charset: %s\n", cubrid_get_charset($con));

?>

以上例程会输出：

CUBRID current charset: iso8859-1

参见

  • cubrid_client_encoding() - Return the current CUBRID connection charset


Get the class name using OID

  • ? cubrid_get_charset
  • cubrid_get_client_info ?
  • PHP Manual
  • CUBRID 函数
  • Get the class name using OID

cubrid_get_class_name

(PECL CUBRID >= 8.3.0)

cubrid_get_class_name — Get the class name using OID

说明

cubrid_get_class_name ( resource $conn_identifier , string $oid ) : string

The cubrid_get_class_name() function is used to get the class name from oid. It doesn't work when selecting data from the system tables, for example db_class.

参数

conn_identifier

Connection identifier.

oid

OID of the instance that you want to check the existence.

返回值

Class name when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_get_class_name() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code", CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);
$class_name = cubrid_get_class_name($conn, $oid);

print_r($class_name);

cubrid_disconnect($conn);
?>

以上例程会输出：

code

参见

  • cubrid_is_instance() - Check whether the instance pointed by OID exists
  • cubrid_drop() - Delete an instance using OID


Return the client library version

  • ? cubrid_get_class_name
  • cubrid_get_db_parameter ?
  • PHP Manual
  • CUBRID 函数
  • Return the client library version

cubrid_get_client_info

(PECL CUBRID >= 8.3.0)

cubrid_get_client_info — Return the client library version

说明

cubrid_get_client_info ( ) : string

This function returns a string that represents the client library version.

参数

返回值

A string that represents the client library version; on success.

false on failure.

范例

Example #1 cubrid_get_client_info() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

以上例程会输出：

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1


Returns the CUBRID database parameters

  • ? cubrid_get_client_info
  • cubrid_get_query_timeout ?
  • PHP Manual
  • CUBRID 函数
  • Returns the CUBRID database parameters

cubrid_get_db_parameter

(PECL CUBRID >= 8.3.0)

cubrid_get_db_parameter — Returns the CUBRID database parameters

说明

cubrid_get_db_parameter ( resource $conn_identifier ) : array

This function returns the CUBRID database parameters or it returns FALSE on failure. It returns an associative array with the values for the following parameters:

  • PARAM_ISOLATION_LEVEL
  • PARAM_LOCK_TIMEOUT
  • PARAM_MAX_STRING_LENGTH
  • PARAM_AUTO_COMMIT

Database parameters
Parameter | Description
PARAM_ISOLATION_LEVEL | The transaction isolation level.
LOCK_TIMEOUT | CUBRID provides the lock timeout feature, which sets the waiting time (in seconds) for the lock until the transaction lock setting is allowed. The default value of the lock_timeout_in_secs parameter is -1, which means the application client will wait indefinitely until the transaction lock is allowed.
PARAM_AUTO_COMMIT | In CUBRID PHP, auto-commit mode is disabled by default for transaction management. It can be set by using cubrid_set_autocommit().

The following table shows the isolation levels from 1 to 6. It consists of table schema (row) and isolation level:

Levels of Isolation Supported by CUBRID
Name | Description
SERIALIZABLE (6) | In this isolation level, problems concerning concurrency (e.g. dirty read, non-repeatable read, phantom read, etc.) do not occur.
REPEATABLE READ CLASS with REPEATABLE READ INSTANCES (5) | Another transaction T2 cannot update the schema of table A while transaction T1 is viewing table A. Transaction T1 may experience phantom read for the record R that was inserted by another transaction T2 when it is repeatedly retrieving a specific record.
REPEATABLE READ CLASS with READ COMMITTED INSTANCES (or CURSOR STABILITY) (4) | Another transaction T2 cannot update the schema of table A while transaction T1 is viewing table A. Transaction T1 may experience R read (non-repeatable read) that was updated and committed by another transaction T2 when it is repeatedly retrieving the record R.
REPEATABLE READ CLASS with READ UNCOMMITTED INSTANCES (3) | Default isolation level. Another transaction T2 cannot update the schema of table A while transaction T1 is viewing table A. Transaction T1 may experience R' read (dirty read) for the record that was updated but not committed by another transaction T2.
READ COMMITTED CLASS with READ COMMITTED INSTANCES (2) | Transaction T1 may experience A' read (non-repeatable read) for the table that was updated and committed by another transaction T2 while it is viewing table A repeatedly. Transaction T1 may experience R' read (non-repeatable read) for the record that was updated and committed by another transaction T2 while it is retrieving the record R repeatedly.
READ COMMITTED CLASS with READ UNCOMMITTED INSTANCES (1) | Transaction T1 may experience A' read (non-repeatable read) for the table that was updated and committed by another transaction T2 while it is repeatedly viewing table A. Transaction T1 may experience R' read (dirty read) for the record that was updated but not committed by another transaction T2.

参数

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last link opened by cubrid_connect() is assumed.

返回值

An associative array with CUBRID database parameters; on success.

false on failure.

更新日志

版本 | 说明
8.4.0 | Change LOCK_TIMEOUT to PARAM_LOCK_TIMEOUT, and MAX_STRING_LENGTH to PARAM_MAX_STRING_LENGTH in result.

范例

Example #1 cubrid_get_db_parameter() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

以上例程会输出：

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

参见

  • cubrid_set_db_parameter() - Sets the CUBRID database parameters
  • cubrid_get_autocommit() - Get auto-commit mode of the connection


Get the query timeout value of the request

  • ? cubrid_get_db_parameter
  • cubrid_get_server_info ?
  • PHP Manual
  • CUBRID 函数
  • Get the query timeout value of the request

cubrid_get_query_timeout

(PECL CUBRID >= 8.4.1)

cubrid_get_query_timeout — Get the query timeout value of the request

说明

cubrid_get_query_timeout ( resource $req_identifier ) : int

The cubrid_get_query_timeout() function is used to get the query timeout of the request.

参数

req_identifier

Request identifier.

返回值

Success: the query timeout value of the current request. Units of msec.

Failure: FALSE

范例

Example #1 cubrid_get_query_timeout() example

<?php

$host = "localhost";
$port = 33000;
$db = "demodb";

$conn =
cubrid_connect_with_url("CUBRID:$host:$port:$db:::?login_timeout=50000&query_timeout=5000&disconnect_on_query_timeout=yes");

$req = cubrid_prepare($conn, "SELECT * FROM code");

$timeout = cubrid_get_query_timeout($req);
var_dump($timeout);

cubrid_set_query_timeout($req, 1000);
$timeout = cubrid_get_query_timeout($req);
var_dump($timeout);

cubrid_close($conn);
?>

以上例程会输出：

int(5000)
int(1000)

参见

  • cubrid_set_query_timeout() - Set the timeout time of query execution


Return the CUBRID server version

  • ? cubrid_get_query_timeout
  • cubrid_get ?
  • PHP Manual
  • CUBRID 函数
  • Return the CUBRID server version

cubrid_get_server_info

(PECL CUBRID >= 8.3.0)

cubrid_get_server_info — Return the CUBRID server version

说明

cubrid_get_server_info ( resource $conn_identifier ) : string

This function returns a string that represents the CUBRID server version.

参数

conn_identifier

The CUBRID connection.

返回值

A string that represents the CUBRID server version; on success.

false on failure.

范例

Example #1 cubrid_get_server_info() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

以上例程会输出：

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1


Get a column using OID

  • ? cubrid_get_server_info
  • cubrid_insert_id ?
  • PHP Manual
  • CUBRID 函数
  • Get a column using OID

cubrid_get

(PECL CUBRID >= 8.3.0)

cubrid_get — Get a column using OID

说明

cubrid_get ( resource $conn_identifier , string $oid , mixed $attr = ? ) : mixed

The cubrid_get() function is used to get the attribute of the instance of the given oid. You can get single attribute by using string data type for the attr argument, or many attributes by using array data type for the attr argument.

参数

conn_identifier

Connection identifier.

oid

OID of the instance that you want to read.

attr

Name of the attribute that you want to read.

返回值

Content of the requested attribute, when process is successful; When attr is set with string data type, the result is returned as a string; when attr is set with array data type (0-based numerical array), then the result is returned in associative array. When attr is omitted, then all attributes are received in array form.

false when process is unsuccessful or result is NULL (If error occurs to distinguish empty string from NULL, then it prints the warning message. You can check the error by using cubrid_error_code())

范例

Example #1 cubrid_get() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_get($conn, $oid, "b");
var_dump($attr);

$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

string(9) "{1, 2, 3}"
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

参见

  • cubrid_put() - Update a column using OID


Return the ID generated for the last updated AUTO_INCREMENT column

  • ? cubrid_get
  • cubrid_is_instance ?
  • PHP Manual
  • CUBRID 函数
  • Return the ID generated for the last updated AUTO_INCREMENT column

cubrid_insert_id

(PECL CUBRID >= 8.3.0)

cubrid_insert_id — Return the ID generated for the last updated AUTO_INCREMENT column

说明

cubrid_insert_id ( resource $conn_identifier = ? ) : string

The cubrid_insert_id() function retrieves the ID generated for the AUTO_INCREMENT column which is updated by the previous INSERT query. It returns 0 if the previous query does not generate new rows, or FALSE on failure.

Note:

CUBRID supports AUTO_INCREMENT for more than one columns in a table. In most cases, there will be a single AUTO_INCREMENT column in a table. If there are multiple AUTO_INCREMENT columns, this function should not be used even if it will return a value.

参数

conn_identifier

The connection identifier previously obtained by a call to cubrid_connect().

返回值

A string representing the ID generated for an AUTO_INCREMENT column by the previous query, on success.

0, if the previous query does not generate new rows.

false on failure.

更新日志

版本 | 说明
8.4.0 | Change the return value from an array to string; Remove the first parameter class_name.

范例

Example #1 cubrid_insert_id() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (d int AUTO_INCREMENT(1, 2), t varchar)");

for ($i = 0; $i < 10; $i++) {
    cubrid_execute($conn, "INSERT INTO cubrid_test(t) VALUES('cubrid_test')");
}

$id = cubrid_insert_id();
var_dump($id);

cubrid_disconnect($conn);
?>

以上例程会输出：

string(2) "19"


Check whether the instance pointed by OID exists

  • ? cubrid_insert_id
  • cubrid_lob_close ?
  • PHP Manual
  • CUBRID 函数
  • Check whether the instance pointed by OID exists

cubrid_is_instance

(PECL CUBRID >= 8.3.0)

cubrid_is_instance — Check whether the instance pointed by OID exists

说明

cubrid_is_instance ( resource $conn_identifier , string $oid ) : int

The cubrid_is_instance() function is used to check whether the instance pointed by the given oid exists or not.

参数

conn_identifier

Connection identifier.

oid

OID of the instance that you want to check the existence.

返回值

1, if such instance exists;

0, if such instance does not exist;

-1, in case of error

范例

Example #1 cubrid_is_instance() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$sql = <<<EOD
SELECT host_year, medal, game_date
FROM game
WHERE athlete_code IN
    (SELECT code FROM athlete WHERE name='Thorpe Ian');
EOD;

$req = cubrid_execute($conn, $sql, CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);

$res = cubrid_is_instance ($conn, $oid);
if ($res == 1) {
    echo "Instance pointed by $oid exists.\n";
} else if ($res == 0){
    echo "Instance pointed by $oid doesn't exist.\n";
} else {
    echo "error\n";
}

cubrid_disconnect($conn);
?>

以上例程会输出：

Instance pointed by @0|0|0 doesn't exist.

参见

  • cubrid_drop() - Delete an instance using OID
  • cubrid_get_class_name() - Get the class name using OID


Close BLOB/CLOB data

  • ? cubrid_is_instance
  • cubrid_lob_export ?
  • PHP Manual
  • CUBRID 函数
  • Close BLOB/CLOB data

cubrid_lob_close

(PECL CUBRID >= 8.3.1)

cubrid_lob_close — Close BLOB/CLOB data

说明

cubrid_lob_close ( array $lob_identifier_array ) : bool

cubrid_lob_close() is used to close all BLOB/CLOB returned from cubrid_lob_get().

参数

lob_identifier_array

LOB identifier array return from cubrid_lob_get.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_lob_close() example

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

参见

  • cubrid_lob_get() - Get BLOB/CLOB data
  • cubrid_lob_size() - Get BLOB/CLOB data size
  • cubrid_lob_export() - Export BLOB/CLOB data to file
  • cubrid_lob_send() - Read BLOB/CLOB data and send straight to browser


Export BLOB/CLOB data to file

  • ? cubrid_lob_close
  • cubrid_lob_get ?
  • PHP Manual
  • CUBRID 函数
  • Export BLOB/CLOB data to file

cubrid_lob_export

(PECL CUBRID >= 8.3.1)

cubrid_lob_export — Export BLOB/CLOB data to file

说明

cubrid_lob_export ( resource $conn_identifier , resource $lob_identifier , string $path_name ) : bool

cubrid_lob_export() is used to get BLOB/CLOB data from CUBRID database, and saves its contents to a file. To use this function, you must use cubrid_lob_get() first to get BLOB/CLOB info from CUBRID.

参数

conn_identifier

Connection identifier.

lob_identifier

LOB identifier.

path_name

Path name of the file.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_lob_export() example

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

参见

  • cubrid_lob_get() - Get BLOB/CLOB data
  • cubrid_lob_close() - Close BLOB/CLOB data
  • cubrid_lob_size() - Get BLOB/CLOB data size
  • cubrid_lob_send() - Read BLOB/CLOB data and send straight to browser


Get BLOB/CLOB data

  • ? cubrid_lob_export
  • cubrid_lob_send ?
  • PHP Manual
  • CUBRID 函数
  • Get BLOB/CLOB data

cubrid_lob_get

(PECL CUBRID >= 8.3.1)

cubrid_lob_get — Get BLOB/CLOB data

说明

cubrid_lob_get ( resource $conn_identifier , string $sql ) : array

cubrid_lob_get() is used to get BLOB/CLOB meta info from CUBRID database, CUBRID gets BLOB/CLOB by executing the SQL statement, and returns all LOBs as a resource array. Be sure that the SQL retrieves only one column and its data type is BLOB or CLOB.

Remember to use cubrid_lob_close() to release the LOBs if you don't need it any more.

参数

conn_identifier

Connection identifier.

sql

SQL statement to be executed.

返回值

Return an array of LOB resources, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_lob_get() example

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

参见

  • cubrid_lob_close() - Close BLOB/CLOB data
  • cubrid_lob_size() - Get BLOB/CLOB data size
  • cubrid_lob_export() - Export BLOB/CLOB data to file
  • cubrid_lob_send() - Read BLOB/CLOB data and send straight to browser


Read BLOB/CLOB data and send straight to browser

  • ? cubrid_lob_get
  • cubrid_lob_size ?
  • PHP Manual
  • CUBRID 函数
  • Read BLOB/CLOB data and send straight to browser

cubrid_lob_send

(PECL CUBRID >= 8.3.1)

cubrid_lob_send — Read BLOB/CLOB data and send straight to browser

说明

cubrid_lob_send ( resource $conn_identifier , resource $lob_identifier ) : bool

cubrid_lob_send() reads BLOB/CLOB data and passes it straight through to the browser. To use this function, you must use cubrid_lob_get() first to get BLOB/CLOB info from CUBRID.

参数

conn_identifier

Connection identifier.

lob_identifier

LOB identifier.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_lob_send() example

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");

cubrid_lob_send($conn, $lobs[0]);
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

参见

  • cubrid_lob_get() - Get BLOB/CLOB data
  • cubrid_lob_close() - Close BLOB/CLOB data
  • cubrid_lob_size() - Get BLOB/CLOB data size
  • cubrid_lob_export() - Export BLOB/CLOB data to file


Get BLOB/CLOB data size

  • ? cubrid_lob_send
  • cubrid_lob2_bind ?
  • PHP Manual
  • CUBRID 函数
  • Get BLOB/CLOB data size

cubrid_lob_size

(PECL CUBRID >= 8.3.1)

cubrid_lob_size — Get BLOB/CLOB data size

说明

cubrid_lob_size ( resource $lob_identifier ) : string

cubrid_lob_size() is used to get BLOB/CLOB data size.

参数

lob_identifier

LOB identifier.

返回值

A string representing LOB data size, when process is successful.

false, when process is unsuccessful.

更新日志

版本 | 说明
8.4.0 | Change return value type from int to string.

范例

Example #1 cubrid_lob_size() example

<?php
$lobs = cubrid_lob_get($con, "SELECT doc_content FROM doc WHERE doc_id=5");
echo "Doc size:".cubrid_lob_size($lobs[0]);
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
?>

参见

  • cubrid_lob_get() - Get BLOB/CLOB data
  • cubrid_lob_close() - Close BLOB/CLOB data
  • cubrid_lob_export() - Export BLOB/CLOB data to file
  • cubrid_lob_send() - Read BLOB/CLOB data and send straight to browser


Bind a lob object or a string as a lob object to a prepared statement as parameters

  • ? cubrid_lob_size
  • cubrid_lob2_close ?
  • PHP Manual
  • CUBRID 函数
  • Bind a lob object or a string as a lob object to a prepared statement as parameters

cubrid_lob2_bind

(PECL CUBRID >= 8.4.1)

cubrid_lob2_bind — Bind a lob object or a string as a lob object to a prepared statement as parameters

说明

cubrid_lob2_bind ( resource $req_identifier , int $bind_index , mixed $bind_value , string $bind_value_type = ? ) : bool

The cubrid_lob2_bind() function is used to bind BLOB/CLOB datas to a corresponding question mark placeholder in the SQL statement that was passed to cubrid_prepare(). If bind_value_type is not given, string will be "BLOB" as the default. But if you use cubrid_lob2_new() before, bind_value_type will be consistent with type in cubrid_lob2_new() as the default.

参数

req_identifier

Request identifier as a result of cubrid_prepare().

bind_index

Location of binding parameters. It starts with 1.

bind_value

Actual value for binding.

bind_value_type

It must be "BLOB" or "CLOB" and it won't be case-sensitive. If it not be given, the default value is "BLOB".

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_lob2_bind() example

<?php
// Table: test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES (?, ?)");

cubrid_bind($req,1, 3);

$lob = cubrid_lob2_new($conn, 'CLOB');
cubrid_lob2_bind($req, 2, $lob);

cubrid_execute($req);

cubrid_bind($req, 1, 4);

cubrid_lob2_bind($req, 2, 'CUBRID LOB2 TEST', 'CLOB');

cubrid_execute($req);

cubrid_disconnect($conn);
?>

参见

  • cubrid_lob2_new() - Create a lob object
  • cubrid_lob2_close() - Close LOB object


Close LOB object

  • ? cubrid_lob2_bind
  • cubrid_lob2_export ?
  • PHP Manual
  • CUBRID 函数
  • Close LOB object

cubrid_lob2_close

(PECL CUBRID >= 8.4.1)

cubrid_lob2_close — Close LOB object

说明

cubrid_lob2_close ( resource $lob_identifier ) : bool

The cubrid_lob2_close() function is used to close LOB object returned from cubrid_lob2_new() or got from the result set.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

返回值

true, on success.

false, on failure.

参见

  • cubrid_lob2_new() - Create a lob object


Export the lob object to a file

  • ? cubrid_lob2_close
  • cubrid_lob2_import ?
  • PHP Manual
  • CUBRID 函数
  • Export the lob object to a file

cubrid_lob2_export

(PECL CUBRID >= 8.4.1)

cubrid_lob2_export — Export the lob object to a file

说明

cubrid_lob2_export ( resource $lob_identifier , string $file_name ) : bool

The cubrid_lob2_export() function is used to save the contents of BLOB/CLOB data to a file. To use this function, you must use cubrid_lob2_new() or fetch a lob object from CUBRID database first. If the file already exists, the operation will fail. This function will not influence the cursor position of the lob object. It operates the entire lob object.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

filename

File name you want to store BLOB/CLOB data. It also supports the path of the file.

返回值

true if the process is successful and false for failure.

范例

Example #1 cubrid_lob2_export() example

<?php
// Table: test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$req = cubrid_prepare($conn, "select * from doc");

cubrid_execute($req);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);

$row = cubrid_fetch($req, CUBRID_NUM | CUBRID_LOB);

cubrid_lob2_export($row[1], "doc_3.txt");

cubrid_lob2_close($row[1]);
cubrid_disconnect($conn);
?>

参见

  • cubrid_lob2_new() - Create a lob object
  • cubrid_lob2_close() - Close LOB object
  • cubrid_lob2_import() - Import BLOB/CLOB data from a file
  • cubrid_lob2_bind() - Bind a lob object or a string as a lob object to a prepared statement as parameters


Import BLOB/CLOB data from a file

  • ? cubrid_lob2_export
  • cubrid_lob2_new ?
  • PHP Manual
  • CUBRID 函数
  • Import BLOB/CLOB data from a file

cubrid_lob2_import

(PECL CUBRID >= 8.4.1)

cubrid_lob2_import — Import BLOB/CLOB data from a file

说明

cubrid_lob2_import ( resource $lob_identifier , string $file_name ) : bool

The cubrid_lob2_import() function is used to save the contents of BLOB/CLOB data from a file. To use this function, you must use cubrid_lob2_new() or fetch a lob object from CUBRID database first. If the file already exists, the operation will fail. This function will not influence the cursor position of the lob object. It operates the entire lob object.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

filename

File name you want to import BLOB/CLOB data. It also supports the path of the file.

返回值

true if the process is successful and false for failure.

范例

Example #1 cubrid_lob2_export() example

<?php

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES (?, ?)");
cubrid_bind($req, 1, 1);

$lob = cubrid_lob2_new($conn, "clob");
cubrid_lob2_import($lob, "doc_1.txt");
cubrid_lob2_bind($req, 2, $lob, 'CLOB'); // or cubrid_lob2_bind($req, 2, $lob);

cubrid_execute($req);

cubrid_lob2_close($lob);
cubrid_disconnect($conn);
?>

参见

  • cubrid_lob2_new() - Create a lob object
  • cubrid_lob2_close() - Close LOB object
  • cubrid_lob2_export() - Export the lob object to a file
  • cubrid_lob2_bind() - Bind a lob object or a string as a lob object to a prepared statement as parameters


Create a lob object

  • ? cubrid_lob2_import
  • cubrid_lob2_read ?
  • PHP Manual
  • CUBRID 函数
  • Create a lob object

cubrid_lob2_new

(PECL CUBRID >= 8.4.1)

cubrid_lob2_new — Create a lob object

说明

cubrid_lob2_new ( resource $conn_identifier = ? , string $type = "BLOB" ) : resource

The cubrid_lob2_new() function is used to create a lob object (both BLOB and CLOB). This function should be used before you bind a lob object.

参数

conn_identifier

Connection identifier. If the connection identifier is not specified, the last connection opened by cubrid_connect() or cubrid_connect_with_url() is assumed.

type

It may be "BLOB" or "CLOB", it won't be case-sensitive. The default value is "BLOB".

返回值

Lob identifier when it is successful.

false on failure.

参见

  • cubrid_lob2_close() - Close LOB object


Read from BLOB/CLOB data

  • ? cubrid_lob2_new
  • cubrid_lob2_seek64 ?
  • PHP Manual
  • CUBRID 函数
  • Read from BLOB/CLOB data

cubrid_lob2_read

(PECL CUBRID >= 8.4.1)

cubrid_lob2_read — Read from BLOB/CLOB data

说明

cubrid_lob2_read ( resource $lob_identifier , int $len ) : string

The cubrid_lob2_read() function reads len bytes from the LOB data and returns the bytes read.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

len

Length from buffer you want to read from the lob data.

返回值

Returns the contents as a string.

false when there is no more data.

NULL on failure.

范例

Example #1 cubrid_lob2_read() example 1

<?php
// test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "public", "");

$req = cubrid_execute($conn, "select * from test_lob");

$row = cubrid_fetch_row($req, CUBRID_LOB);

print "position now is " . cubrid_lob2_tell($row[1]) . "\n";

cubrid_lob2_seek($row[1], 10, CUBRID_CURSOR_FIRST);

print "\nposition after moving farword is " . cubrid_lob2_tell($row[1]) . "\n";

$data = cubrid_lob2_read($row[1], 12);

print "\nposition after reading is " . cubrid_lob2_tell($row[1]) . "\n";

print $data . "\n";

cubrid_lob2_seek($row[1], 5, CUBRID_CURSOR_CURRENT);

print "\nposition after moving again is " . cubrid_lob2_tell($row[1]) . "\n";

$data = cubrid_lob2_read($row[1], 20);
print $data . "\n";

cubrid_disconnect($conn);
?>

Example #2 cubrid_lob2_read() example 2

<?php
// test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

$req = cubrid_execute($conn, "select * from test_lob");

$row = cubrid_fetch_row($req, CUBRID_LOB);

while (true) {
    if ($data = cubrid_lob2_read($row[1], 1024)) {
        print $data . "\n";
    }
    elseif ($data === false) {
        print "There is no more data\n";
        break;
    }
    else {
        print "There must some errors\n";
        break;
    }
}

cubrid_disconnect($conn);
?>

参见

  • cubrid_lob2_write() - Write to a lob object
  • cubrid_lob2_seek() - Move the cursor of a lob object
  • cubrid_lob2_seek64() - Move the cursor of a lob object
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object
  • cubrid_lob2_size() - Get a lob object's size
  • cubrid_lob2_size64() - Get a lob object's size


Move the cursor of a lob object

  • ? cubrid_lob2_read
  • cubrid_lob2_seek ?
  • PHP Manual
  • CUBRID 函数
  • Move the cursor of a lob object

cubrid_lob2_seek64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_seek64 — Move the cursor of a lob object

说明

cubrid_lob2_seek64 ( resource $lob_identifier , string $offset , int $origin = CUBRID_CURSOR_CURRENT ) : bool

The cubrid_lob2_seek64() function is used to move the cursor position of a lob object by the value set in the offset argument, to the direction set in the origin argument. If the offset you want to move is larger than an integer data can be stored, you can use this function.

To set the origin argument, you can use CUBRID_CURSOR_FIRST to set the cursor position moving forward offset units from the first beginning. In this case, offset must be a positive value.

If you use CUBRID_CURSOR_CURRENT for origin, you can move forward or backward. and offset can be positive or negative.

If you use CUBRID_CURSOR_LAST for origin, you can move backward offset units from the end of LOB object and offset only can be positive.

Note:

If you use this function to move the cursor position of the lob object, you should pass offset as a string.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

offset

Number of units you want to move the cursor.

origin

This parameter can be the following values:

CUBRID_CURSOR_FIRST: move forward from the first beginning.

CUBRID_CURSOR_CURRENT: move forward or backward from the current position.

CUBRID_CURSOR_LAST: move backward at the end of LOB object.

返回值

true if the process is successful and false for failure.

范例

Example #1 cubrid_lob2_seek64() example

<?php
// test_lob (id INT, contents CLOB)
// Data length of doc_1.txt should be greater than 20101029056306120215.

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES (?, ?)");
cubrid_bind($req, 1, 1);

$lob = cubrid_lob2_new($conn, "clob");
cubrid_lob2_import($lob, "doc_1.txt");
cubrid_lob2_bind($req, 2, $lob, 'CLOB'); // or cubrid_lob2_bind($req, 2, $lob);

cubrid_execute($req);

cubrid_lob2_close($lob);

$req = cubrid_execute($conn, "select * from test_lob");
$row = cubrid_fetch_row($req, CUBRID_LOB);
$lob = $row[1];

cubrid_lob2_seek64($lob, "20101029056306120215", CUBRID_CURSOR_FIRST);
$data = cubrid_lob2_read($lob, 20);
echo $data."\n";
cubrid_disconnect($conn);
?>

参见

  • cubrid_lob2_read() - Read from BLOB/CLOB data
  • cubrid_lob2_write() - Write to a lob object
  • cubrid_lob2_seek() - Move the cursor of a lob object
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object
  • cubrid_lob2_size() - Get a lob object's size
  • cubrid_lob2_size64() - Get a lob object's size


Move the cursor of a lob object

  • ? cubrid_lob2_seek64
  • cubrid_lob2_size64 ?
  • PHP Manual
  • CUBRID 函数
  • Move the cursor of a lob object

cubrid_lob2_seek

(PECL CUBRID >= 8.4.1)

cubrid_lob2_seek — Move the cursor of a lob object

说明

cubrid_lob2_seek ( resource $lob_identifier , int $offset , int $origin = CUBRID_CURSOR_CURRENT ) : bool

The cubrid_lob2_seek() function is used to move the cursor position of a lob object by the value set in the offset argument, to the direction set in the origin argument.

To set the origin argument, you can use CUBRID_CURSOR_FIRST to set the cursor position moving forward offset units from the first beginning. In this case, offset must be a positive value.

If you use CUBRID_CURSOR_CURRENT for origin, you can move forward or backward. and offset can be positive or negative.

If you use CUBRID_CURSOR_LAST for origin, you can move backward offset units from the end of LOB object and offset only can be positive.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

offset

Number of units you want to move the cursor.

origin

This parameter can be the following values:

CUBRID_CURSOR_FIRST: move forward from the first beginning.

CUBRID_CURSOR_CURRENT: move forward or backward from the current position.

CUBRID_CURSOR_LAST: move backward at the end of LOB object.

返回值

true if the process is successful and false for failure.

范例

Example #1 cubrid_lob2_seek() example

<?php
// test_lob (id INT, contents CLOB)
$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");
$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES(2, ?)");

$lob = cubrid_lob2_new($conn, 'CLOB');
$len = cubrid_lob2_write($lob, "Hello world");

cubrid_lob2_seek($lob, 0, CUBRID_CURSOR_LAST);
cubrid_lob2_write($lob, "beautiful");

cubrid_lob2_seek($lob, 15, CUBRID_CURSOR_FIRST);
$data = cubrid_lob2_read($lob, 5);

echo $data."\n";

cubrid_lob2_bind($req, 1, $lob);
cubrid_execute($req);

cubrid_disconnect($conn);
?>

参见

  • cubrid_lob2_read() - Read from BLOB/CLOB data
  • cubrid_lob2_write() - Write to a lob object
  • cubrid_lob2_seek64() - Move the cursor of a lob object
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object
  • cubrid_lob2_size() - Get a lob object's size
  • cubrid_lob2_size64() - Get a lob object's size


Get a lob object's size

  • ? cubrid_lob2_seek
  • cubrid_lob2_size ?
  • PHP Manual
  • CUBRID 函数
  • Get a lob object's size

cubrid_lob2_size64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_size64 — Get a lob object's size

说明

cubrid_lob2_size64 ( resource $lob_identifier ) : string

The cubrid_lob2_size64() function is used to get the size of a lob object. If the size of a lob object is larger than an integer data can be stored, you can use this function and it will return the size as a string.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

返回值

It will return the size of the LOB object as a string when it processes successfully.

false on failure.

参见

  • cubrid_lob2_read() - Read from BLOB/CLOB data
  • cubrid_lob2_write() - Write to a lob object
  • cubrid_lob2_seek() - Move the cursor of a lob object
  • cubrid_lob2_seek64() - Move the cursor of a lob object
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object
  • cubrid_lob2_size() - Get a lob object's size


Get a lob object's size

  • ? cubrid_lob2_size64
  • cubrid_lob2_tell64 ?
  • PHP Manual
  • CUBRID 函数
  • Get a lob object's size

cubrid_lob2_size

(PECL CUBRID >= 8.4.1)

cubrid_lob2_size — Get a lob object's size

说明

cubrid_lob2_size ( resource $lob_identifier ) : int

The cubrid_lob2_size() function is used to get the size of a lob object.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

返回值

It will return the size of the LOB object when it processes successfully.

false on failure.

参见

  • cubrid_lob2_read() - Read from BLOB/CLOB data
  • cubrid_lob2_write() - Write to a lob object
  • cubrid_lob2_seek() - Move the cursor of a lob object
  • cubrid_lob2_seek64() - Move the cursor of a lob object
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object
  • cubrid_lob2_size64() - Get a lob object's size


Tell the cursor position of the LOB object

  • ? cubrid_lob2_size
  • cubrid_lob2_tell ?
  • PHP Manual
  • CUBRID 函数
  • Tell the cursor position of the LOB object

cubrid_lob2_tell64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_tell64 — Tell the cursor position of the LOB object

说明

cubrid_lob2_tell64 ( resource $lob_identifier ) : string

The cubrid_lob2_tell64() function is used to tell the cursor position of the LOB object. If the size of a lob object is larger than an integer data can be stored, you can use this function and it will return the position information as a string.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

返回值

It will return the cursor position on the LOB object as a string when it processes successfully.

false on failure.

参见

  • cubrid_lob2_read() - Read from BLOB/CLOB data
  • cubrid_lob2_write() - Write to a lob object
  • cubrid_lob2_seek() - Move the cursor of a lob object
  • cubrid_lob2_seek64() - Move the cursor of a lob object
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object
  • cubrid_lob2_size() - Get a lob object's size
  • cubrid_lob2_size64() - Get a lob object's size


Tell the cursor position of the LOB object

  • ? cubrid_lob2_tell64
  • cubrid_lob2_write ?
  • PHP Manual
  • CUBRID 函数
  • Tell the cursor position of the LOB object

cubrid_lob2_tell

(PECL CUBRID >= 8.4.1)

cubrid_lob2_tell — Tell the cursor position of the LOB object

说明

cubrid_lob2_tell ( resource $lob_identifier ) : int

The cubrid_lob2_tell() function is used to tell the cursor position of the LOB object.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

返回值

It will return the cursor position on the LOB object when it processes successfully.

false on failure.

参见

  • cubrid_lob2_read() - Read from BLOB/CLOB data
  • cubrid_lob2_write() - Write to a lob object
  • cubrid_lob2_seek() - Move the cursor of a lob object
  • cubrid_lob2_seek64() - Move the cursor of a lob object
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object
  • cubrid_lob2_size() - Get a lob object's size
  • cubrid_lob2_size64() - Get a lob object's size


Write to a lob object

  • ? cubrid_lob2_tell
  • cubrid_lock_read ?
  • PHP Manual
  • CUBRID 函数
  • Write to a lob object

cubrid_lob2_write

(PECL CUBRID >= 8.4.1)

cubrid_lob2_write — Write to a lob object

说明

cubrid_lob2_write ( resource $lob_identifier , string $buf ) : bool

The cubrid_lob2_write() function reads as much as data from buf and stores it to the LOB object. Note that this function can only append characters now.

参数

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

buf

Data that need to be written to the lob object.

返回值

true if the process is successful and false for failure.

范例

Example #1 cubrid_lob2_write() example 1

<?php
// test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES(2, ?)");

$lob = cubrid_lob2_new($conn, 'CLOB');
$len = cubrid_lob2_write($lob, "Hello world");

cubrid_lob2_bind($req, 1, $lob);
cubrid_execute($req);

cubrid_disconnect($conn);
?>

Example #2 cubrid_lob2_write() example 2

<?php
// test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES(1, ?)");
$lob1 = cubrid_lob2_new($conn, 'CLOB');
$len = cubrid_lob2_write($lob1, "cubrid php driver");
cubrid_lob2_bind($req, 1, $lob1);
cubrid_execute($req);

$req = cubrid_execute($conn, "select * from test_lob");

$row = cubrid_fetch_row($req, CUBRID_LOB);
$lob2 = $row[1];
cubrid_lob2_seek($lob2, 0, CUBRID_CURSOR_LAST);

$pos = cubrid_lob2_tell($lob2);
print "pos before write: $pos\n";

cubrid_lob2_write($lob2, "Hello world");

$pos = cubrid_lob2_tell($lob2);
print "pos after write: $pos\n";

cubrid_disconnect($conn);
?>

参见

  • cubrid_lob2_read() - Read from BLOB/CLOB data
  • cubrid_lob2_seek() - Move the cursor of a lob object
  • cubrid_lob2_seek64() - Move the cursor of a lob object
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object
  • cubrid_lob2_size() - Get a lob object's size
  • cubrid_lob2_size64() - Get a lob object's size


Set a read lock on the given OID

  • ? cubrid_lob2_write
  • cubrid_lock_write ?
  • PHP Manual
  • CUBRID 函数
  • Set a read lock on the given OID

cubrid_lock_read

(PECL CUBRID >= 8.3.0)

cubrid_lock_read — Set a read lock on the given OID

说明

cubrid_lock_read ( resource $conn_identifier , string $oid ) : bool

The cubrid_lock_read() function is used to put read lock on the instance pointed by given oid.

参数

conn_identifier

Connection identifier.

oid

OID of the instance that you want to put read lock on.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_lock_read() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

cubrid_lock_read($conn, $oid);

$attr = cubrid_get($conn, $oid, "b");
var_dump($attr);

$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

string(9) "{1, 2, 3}"
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

参见

  • cubrid_lock_write() - Set a write lock on the given OID


Set a write lock on the given OID

  • ? cubrid_lock_read
  • cubrid_move_cursor ?
  • PHP Manual
  • CUBRID 函数
  • Set a write lock on the given OID

cubrid_lock_write

(PECL CUBRID >= 8.3.0)

cubrid_lock_write — Set a write lock on the given OID

说明

cubrid_lock_write ( resource $conn_identifier , string $oid ) : bool

The cubrid_lock_write() function is used to put write lock on the instance pointed by the given oid.

参数

conn_identifier

Connection identifier.

oid

OID of the instance that you want to put write lock on.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_lock_write() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

cubrid_lock_write($conn, $oid);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_put($conn, $oid, "b", array(2, 4, 8));

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(3) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "4"
  [2]=>
  string(1) "8"
}

参见

  • cubrid_lock_read() - Set a read lock on the given OID


Move the cursor in the result

  • ? cubrid_lock_write
  • cubrid_next_result ?
  • PHP Manual
  • CUBRID 函数
  • Move the cursor in the result

cubrid_move_cursor

(PECL CUBRID >= 8.3.0)

cubrid_move_cursor — Move the cursor in the result

说明

cubrid_move_cursor ( resource $req_identifier , int $offset , int $origin = CUBRID_CURSOR_CURRENT ) : bool

The cubrid_move_cursor() function is used to move the current cursor location of req_identifier by the value set in the offset argument, to the direction set in the origin argument. To set the origin argument, you can use CUBRID_CURSOR_FIRST for the first part of the result, CUBRID_CURSOR_CURRENT for the current location of the result, or CUBRID_CURSOR_LAST for the last part of the result. If origin argument is not explicitly designated, then the function uses CUBRID_CURSOR_CURRENT as its default value.

If the value of cursor movement range goes over the valid limit, then the cursor moves to the next location after the valid range for the cursor. For example, if you move 20 units in the result with the size of 10, then the cursor will move to 11th place and return CUBRID_NO_MORE_DATA.

参数

req_identifier

Request identifier.

offset

Number of units you want to move the cursor.

origin

Location where you want to move the cursor from CUBRID_CURSOR_FIRST, CUBRID_CURSOR_CURRENT, CUBRID_CURSOR_LAST.

返回值

true, when process is successful.

false, when process is unsucceful.

范例

Example #1 cubrid_move_cursor() example

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");
cubrid_move_cursor($req, 1, CUBRID_CURSOR_LAST);

$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_CURRENT);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(2) {
  [0]=>
  string(1) "G"
  [1]=>
  string(4) "Gold"
}
array(2) {
  [0]=>
  string(1) "X"
  [1]=>
  string(5) "Mixed"
}
array(2) {
  [0]=>
  string(1) "M"
  [1]=>
  string(3) "Man"
}

参见

  • cubrid_execute() - Execute a prepared SQL statement


Get result of next query when executing multiple SQL statements

  • ? cubrid_move_cursor
  • cubrid_num_cols ?
  • PHP Manual
  • CUBRID 函数
  • Get result of next query when executing multiple SQL statements

cubrid_next_result

(PECL CUBRID >= 8.4.0)

cubrid_next_result — Get result of next query when executing multiple SQL statements

说明

cubrid_next_result ( resource $result ) : bool

The cubrid_next_result() function is used to get results of next query if multiple SQL statements are executed and CUBRID_EXEC_QUERY_ALL flag is set upon cubrid_execute().

参数

result

result comes from a call to cubrid_execute()

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_next_result() example

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");

$sql_stmt = "SELECT * FROM code; SELECT * FROM history WHERE host_year=2004 AND event_code=20281";
$res = cubrid_execute($conn, $sql_stmt, CUBRID_EXEC_QUERY_ALL);

get_result_info($res);
cubrid_next_result($res);
get_result_info($res);

function get_result_info($req)
{
    printf("\n------------ get_result_info --------------------\n");

    $row_num = cubrid_num_rows($req);
    $col_num = cubrid_num_cols($req);

    $column_name_list = cubrid_column_names($req);
    $column_type_list = cubrid_column_types($req);

    $column_last_name = cubrid_field_name($req, $col_num - 1);
    $column_last_table = cubrid_field_table($req, $col_num - 1);

    $column_last_type = cubrid_field_type($req, $col_num - 1);
    $column_last_len = cubrid_field_len($req, $col_num - 1);

    $column_1_flags = cubrid_field_flags($req, 1);

    printf("%-30s %d\n", "Row count:", $row_num);
    printf("%-30s %d\n", "Column count:", $col_num);
    printf("\n");

    printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Len");
    printf("------------------------------------------------------------------------------\n");

    $size = count($column_name_list);
    for($i = 0; $i < $size; $i++) {
        $column_len = cubrid_field_len($req, $i);
        printf("%-30s %-30s %-15s\n", $column_name_list[$i], $column_type_list[$i], $column_len);
    }
    printf("\n\n");

    printf("%-30s %s\n", "Last Column Name:", $column_last_name);
    printf("%-30s %s\n", "Last Column Table:", $column_last_table);
    printf("%-30s %s\n", "Last Column Type:", $column_last_type);
    printf("%-30s %d\n", "Last Column Len:", $column_last_len);
    printf("%-30s %s\n", "Second Column Flags:", $column_1_flags);

    printf("\n\n");
}
?>

以上例程会输出：

------------ get_result_info --------------------
Row count:                     6
Column count:                  2

Column Names                   Column Types                   Column Len
------------------------------------------------------------------------------
s_name                         char                           1
f_name                         varchar                        6

Last Column Name:              f_name
Last Column Table:             code
Last Column Type:              varchar
Last Column Len:               6
Second Column Flags:

------------ get_result_info --------------------
Row count:                     4
Column count:                  5

Column Names                   Column Types                   Column Len
------------------------------------------------------------------------------
event_code                     integer                        11
athlete                        varchar                        40
host_year                      integer                        11
score                          varchar                        10
unit                           varchar                        5

Last Column Name:              unit
Last Column Table:             history
Last Column Type:              varchar
Last Column Len:               5
Second Column Flags:           not_null primary_key unique_key

参见

  • cubrid_execute() - Execute a prepared SQL statement


Return the number of columns in the result set

  • ? cubrid_next_result
  • cubrid_num_rows ?
  • PHP Manual
  • CUBRID 函数
  • Return the number of columns in the result set

cubrid_num_cols

(PECL CUBRID >= 8.3.0)

cubrid_num_cols — Return the number of columns in the result set

说明

cubrid_num_cols ( resource $result ) : int

The cubrid_num_cols() function is used to get the number of columns from the query result. It can only be used when the query executed is a select statement.

参数

result

Result.

返回值

Number of columns, when process is successful.

false, if SQL statement is not SELECT.

范例

Example #1 cubrid_num_cols() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_cols($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

以上例程会输出：

Row Num: 6
Column Num: 2

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_num_rows() - Get the number of rows in the result set


Get the number of rows in the result set

  • ? cubrid_num_cols
  • cubrid_pconnect_with_url ?
  • PHP Manual
  • CUBRID 函数
  • Get the number of rows in the result set

cubrid_num_rows

(PECL CUBRID >= 8.3.0)

cubrid_num_rows — Get the number of rows in the result set

说明

cubrid_num_rows ( resource $result ) : int

The cubrid_num_rows() function is used to get the number of rows from the query result. You can use it only when the query executed is a select statement. When you want to know such value for INSERT, UPDATE, or DELETE query, you have to use the cubrid_affected_rows() function.

Note: The cubrid_num_rows() function can only be used for synchronous query; it returns 0 when it is used for asynchronous query.

参数

result

result comes from a call to cubrid_execute(), cubrid_query() and cubrid_prepare()

返回值

Number of rows, when process is successful.

0 when the query was done in async mode.

-1, if SQL statement is not SELECT.

false when process is unsuccessful.

范例

Example #1 cubrid_num_rows() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_cols($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

以上例程会输出：

Row Num: 6
Column Num: 2

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_num_cols() - Return the number of columns in the result set
  • cubrid_affected_rows() - Return the number of rows affected by the last SQL statement


Open a persistent connection to CUBRID server

  • ? cubrid_num_rows
  • cubrid_pconnect ?
  • PHP Manual
  • CUBRID 函数
  • Open a persistent connection to CUBRID server

cubrid_pconnect_with_url

(PECL CUBRID >= 8.3.1)

cubrid_pconnect_with_url — Open a persistent connection to CUBRID server

说明

cubrid_pconnect_with_url ( string $conn_url , string $userid = ? , string $passwd = ? ) : resource

Establishes a persistent connection to a CUBRID server.

cubrid_pconnect_with_url() acts very much like cubrid_connect_with_url() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, port, dbname and userid. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (cubrid_close() or cubrid_disconnect() will not close links established by cubrid_pconnect_with_url()).

This type of link is therefore called 'persistent'.

<url> ::= CUBRID:<host>:<db_name>:<db_user>:<db_password>:[?<properties>]

<properties> ::= <property> [&<property>]

<properties> ::= alhosts=<alternative_hosts>[ &rctime=<time>]

<properties> ::= login_timeout=<milli_sec>

<properties> ::= query_timeout=<milli_sec>

<properties> ::= disconnect_on_query_timeout=true|false

<alternative_hosts> ::= <standby_broker1_host>:<port> [,<standby_broker2_host>:<port>]

<host> := HOSTNAME | IP_ADDR

<time> := SECOND

<milli_sec> := MILLI SECOND

  • host : A host name or IP address of the master database
  • db_name : A name of the database
  • db_user : A name of the database user
  • db_password : A database user password
  • alhosts : Specifies the broker information of the standby server, which is used for failover when it is impossible to connect to the active server. You can specify multiple brokers for failover, and the connection to the brokers is attempted in the order listed in alhosts
  • rctime : An interval between the attempts to connect to the active broker in which failure occurred. After a failure occurs, the system connects to the broker specified by althosts (failover), terminates the transaction, and then attempts to connect to the active broker of the master database at every rctime. The default value is 600 seconds.
  • login_timeout : Timeout value (unit: msec.) for database login. The default value is 0, which means infinite postponement.
  • query_timeout : Timeout value (unit: msec.) for query request. Upon timeout, a message to cancel requesting a query transferred to server is sent. The return value can depend on the disconnect_on_query_timeout configuration; even though the message to cancel a request is sent to server, that request may succeed.
  • disconnect_on_query_timeout : Configures a value whether to immediately return an error of function being executed upon timeout. The default value is false.

Note:

? and : that are used as identifiers in PHP connection URL can't be included in the password. The following is an example of a password that is invalid to use as connection URL because it contains "?:".

$url = "CUBRID:localhost:33000:tdb:dba:12?:?login_timeout=100";

Passwords that contain ? or : may be passed as a separate parameter.

$url = "CUBRID:localhost:33000:tbd:::?login_timeout=100";

$conn = cubrid_pconnect_with_url ($url, "dba", "12?");

If user or password is empty,you can't delete ":",the following is an example.

$url = "CUBRID:localhost:33000:demodb:::";

参数

conn_url

A character string that contains server connection information.

userid

User name for the database.

passwd

User password.

返回值

Connection identifier, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_pconnect_with_url() url without properties example

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::"
$con = cubrid_pconnect_with_url ($conn_url);

if ($con) {
   echo "connected successfully";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_disconnect ($con);
}
?>

Example #2 cubrid_pconnect_with_url() url with properties example

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::?althost=10.34.63.132:33088&rctime=100"
$con = cubrid_pconnect_with_url ($conn_url);

if ($con) {
   echo "connected successfully";
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_disconnect ($con);
}
?>

参见

  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server
  • cubrid_pconnect() - Open a persistent connection to a CUBRID server
  • cubrid_disconnect() - Close a database connection
  • cubrid_close() - Close CUBRID connection


Open a persistent connection to a CUBRID server

  • ? cubrid_pconnect_with_url
  • cubrid_prepare ?
  • PHP Manual
  • CUBRID 函数
  • Open a persistent connection to a CUBRID server

cubrid_pconnect

(PECL CUBRID >= 8.3.1)

cubrid_pconnect — Open a persistent connection to a CUBRID server

说明

cubrid_pconnect ( string $host , int $port , string $dbname , string $userid = ? , string $passwd = ? ) : resource

Establishes a persistent connection to a CUBRID server.

cubrid_pconnect() acts very much like cubrid_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, port, dbname and userid. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (cubrid_close() or cubrid_disconnect() will not close links established by cubrid_pconnect()).

This type of link is therefore called 'persistent'.

参数

host

Host name or IP address of CUBRID CAS server.

port

Port number of CUBRID CAS server (BROKER_PORT configured in $CUBRID/conf/cubrid_broker.conf).

dbname

Name of database.

userid

User name for the database.

passwd

User password.

返回值

Connection identifier, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_connect() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_pconnect("localhost", 33000, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);
?>

以上例程会输出：

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

参见

  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server
  • cubrid_pconnect_with_url() - Open a persistent connection to CUBRID server
  • cubrid_disconnect() - Close a database connection
  • cubrid_close() - Close CUBRID connection


Prepare a SQL statement for execution

  • ? cubrid_pconnect
  • cubrid_put ?
  • PHP Manual
  • CUBRID 函数
  • Prepare a SQL statement for execution

cubrid_prepare

(PECL CUBRID >= 8.3.0)

cubrid_prepare — Prepare a SQL statement for execution

说明

cubrid_prepare ( resource $conn_identifier , string $prepare_stmt , int $option = 0 ) : resource

The cubrid_prepare() function is a sort of API which represents SQL statements compiled previously to a given connection handle. This pre-compiled SQL statement will be included in the cubrid_prepare().

Accordingly, you can use this statement effectively to execute several times repeatedly or to process long data. Only a single statement can be used and a parameter may put a question mark (?) to appropriate area in the SQL statement. Add a parameter when you bind a value in the VALUES clause of INSERT statement or in the WHERE clause. Note that it is allowed to bind a value to a MARK(?) by using the cubrid_bind() function only.

参数

conn_identifier

Connection identifier.

prepare_stmt

Prepare query.

option

OID return option CUBRID_INCLUDE_OID.

返回值

Request identifier, if process is successful;

false, if process is unsuccessful.

范例

Example #1 cubrid_prepare() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$sql = <<<EOD
SELECT g.event_code, e.name
FROM game g
JOIN event e ON g.event_code=e.code
WHERE host_year = ? AND event_code NOT IN (SELECT event_code FROM game WHERE host_year=?) GROUP BY event_code;
EOD;

$req = cubrid_prepare($conn, $sql);

cubrid_bind($req, 1, 2004);
cubrid_bind($req, 2, 2000);
cubrid_execute($req);

$row_num = cubrid_num_rows($req);
printf("There are %d event that exits in 2004 olympic but not in 2000. For example:\n\n", $row_num);

printf("%-15s %s\n", "Event_code", "Event_name");
printf("----------------------------\n");

$row = cubrid_fetch_assoc($req);
printf("%-15d %s\n", $row["event_code"], $row["name"]);
$row = cubrid_fetch_assoc($req);
printf("%-15d %s\n", $row["event_code"], $row["name"]);

cubrid_disconnect($conn);
?>

以上例程会输出：

There are 27 event that exits in 2004 olympic but not in 2000. For example:

Event_code      Event_name
----------------------------
20063           +91kg
20070           64kg

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_bind() - Bind variables to a prepared statement as parameters


Update a column using OID

  • ? cubrid_prepare
  • cubrid_rollback ?
  • PHP Manual
  • CUBRID 函数
  • Update a column using OID

cubrid_put

(PECL CUBRID >= 8.3.0)

cubrid_put — Update a column using OID

说明

cubrid_put ( resource $conn_identifier , string $oid , string $attr = ? , mixed $value ) : bool

The cubrid_put() function is used to update an attribute of the instance of the given oid.

You can update single attribute by using string data type to set attr. In such case, you can use integer, floating point or string type data for the value argument. To update multiple number of attributes, you can disregard the attr argument, and set value argument with associative array data type.

参数

conn_identifier

Connection identifier.

oid

OID of the instance that you want to update.

attr

Name of the attribute that you want to update.

value

New value that you want to assign to the attribute.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_put() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_put($conn, $oid, "b", array(2, 4, 8));

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(3) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "4"
  [2]=>
  string(1) "8"
}

参见

  • cubrid_get() - Get a column using OID
  • cubrid_set_add() - Insert a single element to set type column using OID
  • cubrid_set_drop() - Delete an element from set type column using OID
  • cubrid_seq_insert() - Insert an element to a sequence type column using OID
  • cubrid_seq_drop() - Delete an element from sequence type column using OID
  • cubrid_seq_put() - Update the element value of sequence type column using OID


Roll back a transaction

  • ? cubrid_put
  • cubrid_schema ?
  • PHP Manual
  • CUBRID 函数
  • Roll back a transaction

cubrid_rollback

(PECL CUBRID >= 8.3.0)

cubrid_rollback — Roll back a transaction

说明

cubrid_rollback ( resource $conn_identifier ) : bool

The cubrid_rollback() function executes rollback on the transaction pointed by conn_identifier, currently in progress.

Connection to server is closed after calling cubrid_rollback(). Connection handle, however, is still valid.

参数

conn_identifier

Connection identifier.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_rollback() example

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");
cubrid_set_autocommit($conn,false);

@cubrid_execute($conn, "DROP TABLE publishers");

$sql = <<<EOD
CREATE TABLE publishers(
pub_id CHAR(3),
pub_name VARCHAR(20),
city VARCHAR(15),
state CHAR(2),
country VARCHAR(15)
)
EOD;

if (!cubrid_execute($conn, $sql)) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n", cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}

$req = cubrid_prepare($conn, "INSERT INTO publishers VALUES(?, ?, ?, ?, ?)");

$id_list = array("P01", "P02", "P03", "P04");
$name_list = array("Abatis Publishers", "Core Dump Books", "Schadenfreude Press", "Tenterhooks Press");
$city_list = array("New York", "San Francisco", "Hamburg", "Berkeley");
$state_list = array("NY", "CA", NULL, "CA");
$country_list = array("USA", "USA", "Germany", "USA");

for ($i = 0, $size = count($id_list); $i < $size; $i++) {
    cubrid_bind($req, 1, $id_list[$i]);
    cubrid_bind($req, 2, $name_list[$i]);
    cubrid_bind($req, 3, $city_list[$i]);
    cubrid_bind($req, 4, $state_list[$i]);
    cubrid_bind($req, 5, $country_list[$i]);

    if (!($ret = cubrid_execute($req))) {
        break;
    }
}

if (!$ret) {
    cubrid_rollback($conn);
} else {
    cubrid_commit($conn);

    $req = cubrid_execute($conn, "SELECT * FROM publishers");
    while ($result = cubrid_fetch_assoc($req)) {
        printf("%-3s %-20s %-15s %-3s %-15s\n",
            $result["pub_id"], $result["pub_name"], $result["city"], $result["state"], $result["country"]);
    }
}

cubrid_disconnect($conn);
?>

以上例程会输出：

P01 Abatis Publishers    New York        NY  USA
P02 Core Dump Books      San Francisco   CA  USA
P03 Schadenfreude Press  Hamburg             Germany
P04 Tenterhooks Press    Berkeley        CA  USA

参见

  • cubrid_commit() - Commit a transaction
  • cubrid_disconnect() - Close a database connection


Get the requested schema information

  • ? cubrid_rollback
  • cubrid_seq_drop ?
  • PHP Manual
  • CUBRID 函数
  • Get the requested schema information

cubrid_schema

(PECL CUBRID >= 8.3.0)

cubrid_schema — Get the requested schema information

说明

cubrid_schema ( resource $conn_identifier , int $schema_type , string $class_name = ? , string $attr_name = ? ) : array

The cubrid_schema() function is used to get the requested schema information from database. You have to designate class_name, if you want to get information on certain class, attr_name, if you want to get information on certain attribute (can be used only with CUBRID_ SCH_ATTR_PRIVILEGE).

The result of the cubrid_schema function is returned as a two-dimensional array (column (associative array) * row (numeric array)). The following tables shows types of schema and the column structure of the result array to be returned based on the schema type.

Result Composition of Each Type
Schema | Column Number | Column Name | Value
CUBRID_SCH_CLASS | 1 | NAME |
 | 2 | TYPE | 0:system class 1:vclass 2:class
CUBRID_SCH_VCLASS | 1 | NAME |
 | 2 | TYPE | 1:vclass
CUBRID_SCH_QUERY_SPEC | 1 | QUERY_SPEC |
CUBRID_SCH_ATTRIBUTE / CUBRID_SCH_CLASS_ATTRIBUTE | 1 | ATTR_NAME |
 | 2 | DOMAIN |
 | 3 | SCALE |
 | 4 | PRECISION |
 | 5 | INDEXED | 1:indexed
 | 6 | NOT NULL | 1:not null
 | 7 | SHARED | 1:shared
 | 8 | UNIQUE | 1:unique
 | 9 | DEFAULT |
 | 10 | ATTR_ORDER | base:1
 | 11 | CLASS_NAME |
 | 12 | SOURCE_CLASS |
 | 13 | IS_KEY | 1:key
CUBRID_SCH_METHOD / CUBRID_SCH_CLASS_METHOD | 1 | NAME |
 | 2 | RET_DOMAIN |
 | 3 | ARG_DOMAIN |
CUBRID_SCH_METHOD_FILE | 1 | METHOD_FILE |
CUBRID_SCH_SUPERCLASS / CUBRID_SCH_DIRECT_SUPER_CLASS / CUBRID_SCH_SUBCLASS | 1 | CLASS_NAME |
 | 2 | TYPE | 0:system class 1:vclass 2:class
CUBRID_SCH_CONSTRAINT | 1 | TYPE | 0:unique 1:index 2:reverse unique 3:reverse index
 | 2 | NAME |
 | 3 | ATTR_NAME |
 | 4 | NUM_PAGES |
 | 5 | NUM_KEYS |
 | 6 | PRIMARY_KEY | 1:primary key
 | 7 | KEY_ORDER | base:1
CUBRID_SCH_TRIGGER | 1 | NAME |
 | 2 | STATUS |
 | 3 | EVENT |
 | 4 | TARGET_CLASS |
 | 5 | TARGET_ATTR |
 | 6 | ACTION_TIME |
 | 7 | ACTION |
 | 8 | PRIORITY |
 | 9 | CONDITION_TIME |
 | 10 | CONDITION |
CUBRID_SCH_CLASS_PRIVILEGE / CUBRID_SCH_ATTR_PRIVILEGE | 1 | CLASS_NAME / ATTR_NAME |
 | 2 | PRIVILEGE |
 | 3 | GRANTABLE |
CUBRID_SCH_PRIMARY_KEY | 1 | CLASS_NAME |
 | 2 | ATTR_NAME |
 | 3 | KEY_SEQ | base:1
 | 4 | KEY_NAME |
CUBRID_SCH_IMPORTED_KEYS / CUBRID_SCH_EXPORTED_KEYS / CUBRID_SCH_CROSS_REFERENCE | 1 | PKTABLE_NAME |
 | 2 | PKCOLUMN_NAME |
 | 3 | FKTABLE_NAME | base:1
 | 4 | FKCOLUMN_NAME |
 | 5 | KEY_SEQ | base:1
 | 6 | UPDATE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 7 | DELETE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 8 | FK_NAME |
 | 9 | PK_NAME |

参数

conn_identifier

Connection identifier.

schema_type

Schema data that you want to know.

class_name

Class you want to know the schema of.

attr_name

Attribute you want to know the schema of.

返回值

Array containing the schema information, when process is successful;

false, when process is unsuccessful

更新日志

版本 | 说明
8.3.1 | Change return value: when process is unsuccessful, return false, not -1.

范例

Example #1 cubrid_schema() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

printf("\n--- Primary Key ---\n");
$pk = cubrid_schema($conn, CUBRID_SCH_PRIMARY_KEY, "game");
var_dump($pk);

printf("\n--- Foreign Keys ---\n");
$fk = cubrid_schema($conn, CUBRID_SCH_IMPORTED_KEYS, "game");
var_dump($fk);

printf("\n--- Column Attribute ---\n");
$attr = cubrid_schema($conn, CUBRID_SCH_ATTRIBUTE, "stadium", "area");
var_dump($attr);

cubrid_disconnect($conn);
?>

以上例程会输出：

--- Primary Key ---
array(3) {
  [0]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(12) "athlete_code"
    ["KEY_SEQ"]=>
    string(1) "3"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
  [1]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(10) "event_code"
    ["KEY_SEQ"]=>
    string(1) "2"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
  [2]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(9) "host_year"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
}

--- Foreign Keys ---
array(2) {
  [0]=>
  array(9) {
    ["PKTABLE_NAME"]=>
    string(7) "athlete"
    ["PKCOLUMN_NAME"]=>
    string(4) "code"
    ["FKTABLE_NAME"]=>
    string(4) "game"
    ["FKCOLUMN_NAME"]=>
    string(12) "athlete_code"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["UPDATE_RULE"]=>
    string(1) "1"
    ["DELETE_RULE"]=>
    string(1) "1"
    ["FK_NAME"]=>
    string(20) "fk_game_athlete_code"
    ["PK_NAME"]=>
    string(15) "pk_athlete_code"
  }
  [1]=>
  array(9) {
    ["PKTABLE_NAME"]=>
    string(5) "event"
    ["PKCOLUMN_NAME"]=>
    string(4) "code"
    ["FKTABLE_NAME"]=>
    string(4) "game"
    ["FKCOLUMN_NAME"]=>
    string(10) "event_code"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["UPDATE_RULE"]=>
    string(1) "1"
    ["DELETE_RULE"]=>
    string(1) "1"
    ["FK_NAME"]=>
    string(18) "fk_game_event_code"
    ["PK_NAME"]=>
    string(13) "pk_event_code"
  }
}

--- Column Attribute ---
array(1) {
  [0]=>
  array(13) {
    ["ATTR_NAME"]=>
    string(4) "area"
    ["DOMAIN"]=>
    string(1) "7"
    ["SCALE"]=>
    string(1) "2"
    ["PRECISION"]=>
    string(2) "10"
    ["INDEXED"]=>
    string(1) "0"
    ["NON_NULL"]=>
    string(1) "0"
    ["SHARED"]=>
    string(1) "0"
    ["UNIQUE"]=>
    string(1) "0"
    ["DEFAULT"]=>
    NULL
    ["ATTR_ORDER"]=>
    string(1) "4"
    ["CLASS_NAME"]=>
    string(7) "stadium"
    ["SOURCE_CLASS"]=>
    string(7) "stadium"
    ["IS_KEY"]=>
    string(1) "0"
  }
}


Delete an element from sequence type column using OID

  • ? cubrid_schema
  • cubrid_seq_insert ?
  • PHP Manual
  • CUBRID 函数
  • Delete an element from sequence type column using OID

cubrid_seq_drop

(PECL CUBRID >= 8.3.0)

cubrid_seq_drop — Delete an element from sequence type column using OID

说明

cubrid_seq_drop ( resource $conn_identifier , string $oid , string $attr_name , int $index ) : bool

The cubrid_seq_drop() function is used to delete an element you request from the given sequence type attribute in the database.

参数

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute that you want to delete an element from.

index

Index of the element that you want to delete (1-based).

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_seq_drop() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_drop($conn, $oid, "c", 4);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(3) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
}

参见

  • cubrid_seq_insert() - Insert an element to a sequence type column using OID
  • cubrid_seq_put() - Update the element value of sequence type column using OID


Insert an element to a sequence type column using OID

  • ? cubrid_seq_drop
  • cubrid_seq_put ?
  • PHP Manual
  • CUBRID 函数
  • Insert an element to a sequence type column using OID

cubrid_seq_insert

(PECL CUBRID >= 8.3.0)

cubrid_seq_insert — Insert an element to a sequence type column using OID

说明

cubrid_seq_insert ( resource $conn_identifier , string $oid , string $attr_name , int $index , string $seq_element ) : bool

The cubrid_col_insert() function is used to insert an element to a sequence type attribute in a requested location.

参数

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute you want to insert an instance to.

index

Location of the element, you want to insert the element to (1-based).

seq_element

Content of the element that you want to insert.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_seq_insert() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_insert($conn, $oid, "c", 5, "44");

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(5) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
  [4]=>
  string(2) "44"
}

参见

  • cubrid_seq_drop() - Delete an element from sequence type column using OID
  • cubrid_seq_put() - Update the element value of sequence type column using OID


Update the element value of sequence type column using OID

  • ? cubrid_seq_insert
  • cubrid_set_add ?
  • PHP Manual
  • CUBRID 函数
  • Update the element value of sequence type column using OID

cubrid_seq_put

(PECL CUBRID >= 8.3.0)

cubrid_seq_put — Update the element value of sequence type column using OID

说明

cubrid_seq_put ( resource $conn_identifier , string $oid , string $attr_name , int $index , string $seq_element ) : bool

The cubrid_seq_put() function is used to update the content of the requested element in a sequent type attribute using OID.

参数

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute that you want to update an element.

index

Index (1-based) of the element that you want to update.

seq_element

New content that you want to use for the update.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_seq_put() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_put($conn, $oid, "c", 1, "111");

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(4) {
  [0]=>
  string(3) "111"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}

参见

  • cubrid_seq_drop() - Delete an element from sequence type column using OID
  • cubrid_seq_insert() - Insert an element to a sequence type column using OID


Insert a single element to set type column using OID

  • ? cubrid_seq_put
  • cubrid_set_autocommit ?
  • PHP Manual
  • CUBRID 函数
  • Insert a single element to set type column using OID

cubrid_set_add

(PECL CUBRID >= 8.3.0)

cubrid_set_add — Insert a single element to set type column using OID

说明

cubrid_set_add ( resource $conn_identifier , string $oid , string $attr_name , string $set_element ) : bool

The cubrid_set_add() function is used to insert a single element to a set type attribute (set, multiset, sequence) you requested.

参数

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute you want to insert an element.

set_element

Content of the element you want to insert.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_set_add() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_set_add($conn, $oid, "b", "4");

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(4) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
  [3]=>
  string(1) "4"
}

参见

  • cubrid_seq_drop() - Delete an element from sequence type column using OID


Set autocommit mode of the connection

  • ? cubrid_set_add
  • cubrid_set_db_parameter ?
  • PHP Manual
  • CUBRID 函数
  • Set autocommit mode of the connection

cubrid_set_autocommit

(PECL CUBRID >= 8.4.0)

cubrid_set_autocommit — Set autocommit mode of the connection

说明

cubrid_set_autocommit ( resource $conn_identifier , bool $mode ) : bool

The cubrid_set_autocommit() function is used to set the CUBRID database auto-commit mode of the current database connection.

In CUBRID PHP, auto-commit mode is disabled by default for transaction management. When auto-commit mode is truned from off to on, any pending work is automatically committed.

参数

conn_identifier

Connection identifier.

mode

Auto-commit mode. The following constants can be used:

  • CUBRID_AUTOCOMMIT_FALSE
  • CUBRID_AUTOCOMMIT_TRUE

返回值

true, when process is successful.

false, when process is unsuccessful.

参见

  • cubrid_get_autocommit() - Get auto-commit mode of the connection
  • cubrid_commit() - Commit a transaction


Sets the CUBRID database parameters

  • ? cubrid_set_autocommit
  • cubrid_set_drop ?
  • PHP Manual
  • CUBRID 函数
  • Sets the CUBRID database parameters

cubrid_set_db_parameter

(PECL CUBRID >= 8.4.0)

cubrid_set_db_parameter — Sets the CUBRID database parameters

说明

cubrid_set_db_parameter ( resource $conn_identifier , int $param_type , int $param_value ) : bool

The cubrid_set_db_parameter() function is used to set the CUBRID database parameters. It can set the following CUBRID database parameters:

  • PARAM_ISOLATION_LEVEL
  • PARAM_LOCK_TIMEOUT

Note:

The auto-commit mode can be set by using cubrid_set_autocommit().

参数

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last link opened by cubrid_connect() is assumed.

param_type

Database parameter type.

param_value

Isolation level value (1-6) or lock timeout (in seconds) value.

返回值

true on success.

false on failure.

范例

Example #1 cubrid_get_db_parameter() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$params = cubrid_get_db_parameter($conn);
var_dump($params);

cubrid_set_autocommit($conn, CUBRID_AUTOCOMMIT_TRUE);
cubrid_set_db_parameter($conn, CUBRID_PARAM_ISOLATION_LEVEL, 2);

$params_new = cubrid_get_db_parameter($conn);
var_dump($params_new);

cubrid_disconnect($conn);
?>

以上例程会输出：

array(4) {
  ["PARAM_ISOLATION_LEVEL"]=>
  int(3)
  ["PARAM_LOCK_TIMEOUT"]=>
  int(-1)
  ["PARAM_MAX_STRING_LENGTH"]=>
  int(1073741823)
  ["PARAM_AUTO_COMMIT"]=>
  int(0)
}
array(4) {
  ["PARAM_ISOLATION_LEVEL"]=>
  int(2)
  ["PARAM_LOCK_TIMEOUT"]=>
  int(-1)
  ["PARAM_MAX_STRING_LENGTH"]=>
  int(1073741823)
  ["PARAM_AUTO_COMMIT"]=>
  int(1)
}

参见

  • cubrid_get_db_parameter() - Returns the CUBRID database parameters
  • cubrid_set_autocommit() - Set autocommit mode of the connection


Delete an element from set type column using OID

  • ? cubrid_set_db_parameter
  • cubrid_set_query_timeout ?
  • PHP Manual
  • CUBRID 函数
  • Delete an element from set type column using OID

cubrid_set_drop

(PECL CUBRID >= 8.3.0)

cubrid_set_drop — Delete an element from set type column using OID

说明

cubrid_set_drop ( resource $conn_identifier , string $oid , string $attr_name , string $set_element ) : bool

The cubrid_set_drop() function is used to delete an element that you request from the given set type (set, multiset) attribute of the database.

参数

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute you want to delete an element from.

set_element

Content of the element you want to delete.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_set_drop() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_set_drop($conn, $oid, "b", "1");

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(2) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "3"
}

参见

  • cubrid_set_add() - Insert a single element to set type column using OID


Set the timeout time of query execution

  • ? cubrid_set_drop
  • cubrid_version ?
  • PHP Manual
  • CUBRID 函数
  • Set the timeout time of query execution

cubrid_set_query_timeout

(PECL CUBRID >= 8.4.1)

cubrid_set_query_timeout — Set the timeout time of query execution

说明

cubrid_set_query_timeout ( resource $req_identifier , int $timeout ) : bool

The cubrid_set_query_timeout() function is used to set the timeout time of query execution.

参数

req_identifier

Request identifier.

timeout

Timeout time, unit of msec.

返回值

true, when process is successful.

false, when process is unsuccessful.

参见

  • cubrid_get_query_timeout() - Get the query timeout value of the request


Get the CUBRID PHP module's version

  • ? cubrid_set_query_timeout
  • CUBRID MySQL 兼容性函数 ?
  • PHP Manual
  • CUBRID 函数
  • Get the CUBRID PHP module's version

cubrid_version

(PECL CUBRID >= 8.3.0)

cubrid_version — Get the CUBRID PHP module's version

说明

cubrid_version ( ) : string

The cubrid_version() function is used to get the CUBRID PHP module's version.

参数

此函数没有参数。

返回值

Version information (eg. "8.3.1.0001").

范例

Example #1 cubrid_version() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

以上例程会输出：

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

参见

  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_code_facility() - Get the facility code of error


CUBRID MySQL 兼容性函数

Table of Contents

  • cubrid_affected_rows — Return the number of rows affected by the last SQL statement
  • cubrid_client_encoding — Return the current CUBRID connection charset
  • cubrid_close — Close CUBRID connection
  • cubrid_data_seek — Move the internal row pointer of the CUBRID result
  • cubrid_db_name — Get db name from results of cubrid_list_dbs
  • cubrid_errno — Return the numerical value of the error message from previous CUBRID operation
  • cubrid_error — Get the error message
  • cubrid_fetch_array — Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_assoc — Return the associative array that corresponds to the fetched row
  • cubrid_fetch_field — Get column information from a result and return as an object
  • cubrid_fetch_lengths — Return an array with the lengths of the values of each field from the current row
  • cubrid_fetch_object — Fetch the next row and return it as an object
  • cubrid_fetch_row — Return a numerical array with the values of the current row
  • cubrid_field_flags — Return a string with the flags of the given field offset
  • cubrid_field_len — Get the maximum length of the specified field
  • cubrid_field_name — Return the name of the specified field index
  • cubrid_field_seek — Move the result set cursor to the specified field offset
  • cubrid_field_table — Return the name of the table of the specified field
  • cubrid_field_type — Return the type of the column corresponding to the given field offset
  • cubrid_list_dbs — Return an array with the list of all existing CUBRID databases
  • cubrid_num_fields — Return the number of columns in the result set
  • cubrid_ping — Ping a server connection or reconnect if there is no connection
  • cubrid_query — Send a CUBRID query
  • cubrid_real_escape_string — Escape special characters in a string for use in an SQL statement
  • cubrid_result — Return the value of a specific field in a specific row
  • cubrid_unbuffered_query — Perform a query without fetching the results into memory


Return the number of rows affected by the last SQL statement

  • ? CUBRID MySQL 兼容性函数
  • cubrid_client_encoding ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the number of rows affected by the last SQL statement

cubrid_affected_rows

(PECL CUBRID >= 8.3.0)

cubrid_affected_rows — Return the number of rows affected by the last SQL statement

说明

cubrid_affected_rows ( resource $conn_identifier = ? ) : int
cubrid_affected_rows ( resource $req_identifier = ? ) : int

The cubrid_affected_rows() function is used to get the number of rows affected by the SQL statement (INSERT, DELETE, UPDATE).

参数

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last link opend by cubrid_connect() is assumed.

req_identifier

Request Identifier, could be returned from either cubrid_prepare() or cubrid_execute(). If the request identifier is not specified, the last identifier requested by cubrid_prepare() or cubrid_execute() is assumed.

返回值

Number of rows affected by the SQL statement, when process is successful.

-1, when SQL statement is not INSERT, DELETE or UPDATE.

false, when the request identifier is not specified, and there is no last request.

范例

Example #1 cubrid_affected_rows() example

<?php
$conn = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
cubrid_execute($conn, "DROP TABLE IF EXISTS cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (d varchar)");
$sql_stmt = "INSERT INTO cubrid_test(d) VALUES('php-test')";
$req = cubrid_prepare($conn, $sql_stmt);

for ($i = 0; $i < 10; $i++) {
    cubrid_execute($req);
}
cubrid_commit($conn);

$req = cubrid_execute($conn, "DELETE FROM cubrid_test WHERE d='php-test'", CUBRID_ASYNC);
var_dump(cubrid_affected_rows());
var_dump(cubrid_affected_rows($conn));
var_dump(cubrid_affected_rows($req));

cubrid_disconnect($conn);

print "done!";
?>

以上例程会输出：

Rows deleted: 5

参见

  • cubrid_execute() - Execute a prepared SQL statement


Return the current CUBRID connection charset

  • ? cubrid_affected_rows
  • cubrid_close ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the current CUBRID connection charset

cubrid_client_encoding

(PECL CUBRID >= 8.3.1)

cubrid_client_encoding — Return the current CUBRID connection charset

说明

cubrid_client_encoding ( resource $conn_identifier = ? ) : string

This function returns the current CUBRID connection charset and is similar to the CUBRID function cubrid_get_charset().

参数

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last link opened by cubrid_connect() is assumed.

返回值

A string that represents the CUBRID connection charset; on success.

false on failure.

范例

Example #1 cubrid_client_encoding() example

<?php

$con = cubrid_connect("localhost", 33000, "demodb");
if (!$con)
{
    die('Could not connect.');
}

printf("CUBRID current charset: %s\n", cubrid_client_encoding($con));

?>

以上例程会输出：

CUBRID current charset: iso8859-1

参见

  • cubrid_get_charset() - Return the current CUBRID connection charset


Close CUBRID connection

  • ? cubrid_client_encoding
  • cubrid_data_seek ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Close CUBRID connection

cubrid_close

(PECL CUBRID >= 8.3.1)

cubrid_close — Close CUBRID connection

说明

cubrid_close ( resource $conn_identifier = ? ) : bool

The cubrid_close() function ends the transaction currently in process, closes the connection handle and disconnects from server. If there is any request handles not closed yet at this point, they will be closed. It is similar to the CUBRID function cubrid_disconnect().

参数

conn_identifier

The CUBRID connection identifier. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_close() example

<?php
$con = cubrid_connect ("localhost", 33000, "demodb");
if ($con) {
   echo "connected successfully";
   $req = cubrid_execute ( $con, "insert into person values(1,'James')");
   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_close ($con);
}
?>

参见

  • cubrid_disconnect() - Close a database connection
  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server


Move the internal row pointer of the CUBRID result

  • ? cubrid_close
  • cubrid_db_name ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Move the internal row pointer of the CUBRID result

cubrid_data_seek

(PECL CUBRID >= 8.3.0)

cubrid_data_seek — Move the internal row pointer of the CUBRID result

说明

cubrid_data_seek ( resource $result , int $row_number ) : bool

This function performs the moving of the internal row pointer of the CUBRID result (associated with the specified result identifier) to point to a specific row number. There are functions, such as cubrid_fetch_assoc(), which use the current stored value of row number.

参数

result

The result.

row_number

This is the desired row number of the new result pointer.

返回值

Returns true on success or false on failure.

范例

Example #1 cubrid_data_seek() example

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");
cubrid_data_seek($req, 0);

$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_data_seek($req, 2);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_data_seek($req, 4);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(2) {
  [0]=>
  string(1) "X"
  [1]=>
  string(5) "Mixed"
}
array(2) {
  [0]=>
  string(1) "M"
  [1]=>
  string(3) "Man"
}
array(2) {
  [0]=>
  string(1) "S"
  [1]=>
  string(6) "Silver"
}


Get db name from results of cubrid_list_dbs

  • ? cubrid_data_seek
  • cubrid_errno ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Get db name from results of cubrid_list_dbs

cubrid_db_name

(PECL CUBRID >= 8.3.1)

cubrid_db_name — Get db name from results of cubrid_list_dbs

说明

cubrid_db_name ( array $result , int $index ) : string

Retrieve the database name from a call to cubrid_list_dbs().

参数

result

The result pointer from a call to cubrid_list_dbs().

index

The index into the result set.

返回值

Returns the database name on success, and false on failure. If false is returned, use cubrid_error() to determine the nature of the error.

范例

Example #1 cubrid_db_name() example

<?php
error_reporting(E_ALL);

$conn = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$db_list = cubrid_list_dbs($conn);

$i = 0;
$cnt = count($db_list);
while ($i < $cnt) {
    echo cubrid_db_name($db_list, $i) . "\n";
    $i++;
}
?>

以上例程会输出：

demodb

参见

  • cubrid_list_dbs() - Return an array with the list of all existing CUBRID databases


Return the numerical value of the error message from previous CUBRID operation

  • ? cubrid_db_name
  • cubrid_error ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the numerical value of the error message from previous CUBRID operation

cubrid_errno

(PECL CUBRID >= 8.3.1)

cubrid_errno — Return the numerical value of the error message from previous CUBRID operation

说明

cubrid_errno ( resource $conn_identifier = ? ) : int

Returns the error number from the last CUBRID function.

The cubrid_errno() function is used to get the error code of the error that occurred during the API execution. Usually, it gets the error code when API returns false as its return value.

参数

conn_identifier

The CUBRID connection identifier. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

返回值

Returns the error number from the last CUBRID function, or 0 (zero) if no error occurred.

范例

Example #1 cubrid_errno() example

<?php
$con = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$req = cubrid_execute($con, "select id, name from person");
if ($req) {
    while (list ($id, $name) = cubrid_fetch($req))
    echo $id, $name;
} else {
    echo "Error Code: ", cubrid_errno($con);
    echo "Error Message: ", cubrid_error($con);
}
?>

以上例程会输出：

Error Code: -493 Error Message: Syntax: Unknown class "person". select id, [name] from person

参见

  • cubrid_error() - Get the error message
  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_msg() - Get last error message for the most recent function call


Get the error message

  • ? cubrid_errno
  • cubrid_fetch_array ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Get the error message

cubrid_error

(PECL CUBRID >= 8.3.1)

cubrid_error — Get the error message

说明

cubrid_error ( resource $connection = ? ) : string

The cubrid_error() function is used to get the error message that occurred during the use of CUBRID API. Usually, it gets error message when API returns false as its return value.

参数

connection

The CUBRID connection.

返回值

Error message that occurred.

范例

Example #1 cubrid_error() example

<?php
$con = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$req = cubrid_execute($con, "select id, name from person");
if ($req) {
    while (list ($id, $name) = cubrid_fetch($req))
    echo $id, $name;
} else {
    echo "Error Code: ", cubrid_errno($con);
    echo "Error Message: ", cubrid_error($con);
}
?>

以上例程会输出：

Error Code: -493 Error Message: Syntax: Unknown class "person". select id, [name] from person

参见

  • cubrid_errno() - Return the numerical value of the error message from previous CUBRID operation
  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_msg() - Get last error message for the most recent function call


Fetch a result row as an associative array, a numeric array, or both

  • ? cubrid_error
  • cubrid_fetch_assoc ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Fetch a result row as an associative array, a numeric array, or both

cubrid_fetch_array

(PECL CUBRID >=8.3.0)

cubrid_fetch_array — Fetch a result row as an associative array, a numeric array, or both

说明

cubrid_fetch_array ( resource $result , int $type = CUBRID_BOTH ) : array

The cubrid_fetch_array() function is used to get a single row from the query result and returns an array. The cursor automatically moves to the next row after getting the result.

参数

result

Result comes from a call to cubrid_execute()

type

Array type of the fetched result CUBRID_NUM, CUBRID_ASSOC, CUBRID_BOTH. If you need to operate the lob object, you can use CUBRID_LOB.

返回值

Returns an array of strings that corresponds to the fetched row, when process is successful.

false, when there are no more rows; NULL, when process is unsuccessful.

The type of returned array depends on how type is defined. By using CUBRID_BOTH (default), you'll get an array with both associative and number indices, and you can decide which data type to use by setting the type argument. The type variable can be set to one of the following values:

  • CUBRID_NUM : Numerical array (0-based)
  • CUBRID_ASSOC : Associative array
  • CUBRID_BOTH : Numerical & Associative array (default)

范例

Example #1 cubrid_fetch_array() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($row = cubrid_fetch_array($req, CUBRID_NUM)) {
    printf("%-40s %-10s %-6s %-20s\n", $row[0], $row[1], $row[2], $row[3]);
}

// if you want to operate LOB object, you can use cubrid_fetch_array($req, CUBRID_NUM | CUBRID_LOB)

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

以上例程会输出：

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch() - Fetch the next row from a result set
  • cubrid_fetch_row() - Return a numerical array with the values of the current row
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_fetch_object() - Fetch the next row and return it as an object


Return the associative array that corresponds to the fetched row

  • ? cubrid_fetch_array
  • cubrid_fetch_field ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the associative array that corresponds to the fetched row

cubrid_fetch_assoc

(PECL CUBRID >= 8.3.0)

cubrid_fetch_assoc — Return the associative array that corresponds to the fetched row

说明

cubrid_fetch_assoc ( resource $result , int $type = ? ) : array

This function returns the associative array, that corresponds to the fetched row, and then moves the internal data pointer ahead, or returns FALSE when the end is reached.

参数

result

result comes from a call to cubrid_execute()

type

Type can only be CUBRID_LOB, this parameter will be used only when you need to operate the lob object.

返回值

Associative array, when process is successful.

false, when there are no more rows; NULL, when process is unsuccessful.

范例

Example #1 cubrid_fetch_assoc() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($row = cubrid_fetch_assoc($req)) {
    printf("%-40s %-10s %-6s %-20s\n",
        $row["name"], $row["area"], $row["seats"], $row["address"]);
}

// if you want to operate LOB object, you can use cubrid_fetch_assoc($req, CUBRID_LOB)

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

以上例程会输出：

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch() - Fetch the next row from a result set
  • cubrid_fetch_row() - Return a numerical array with the values of the current row
  • cubrid_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_object() - Fetch the next row and return it as an object


Get column information from a result and return as an object

  • ? cubrid_fetch_assoc
  • cubrid_fetch_lengths ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Get column information from a result and return as an object

cubrid_fetch_field

(PECL CUBRID >= 8.3.1)

cubrid_fetch_field — Get column information from a result and return as an object

说明

cubrid_fetch_field ( resource $result , int $field_offset = 0 ) : object

This function returns an object with certain properties of the specific column. The properties of the object are:

name

column name

table

name of the table that the column belongs to

def

default value of the column

max_length

maximum length of the column

not_null

1 if the column cannot be NULL

primary_key

1 if the column is a primary key

unique_key

1 if the column is an unique key

multiple_key

1 if the column is a non-unique key

numeric

1 if the column is numeric

blob

1 if the column is a BLOB

type

the type of the column

unsigned

1 if the column is unsigned

zerofill

1 if the column is zero-filled

参数

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. If the field offset is not specified, the next field (that was not yet retrieved by this function) is retrieved. The field_offset starts at 0.

返回值

Object with certain properties of the specific column, when process is successful.

false on failure.

范例

Example #1 cubrid_fetch_field() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT event_code,athlete_code,nation_code,game_date FROM game WHERE host_year=1988 and event_code=20001;");

var_dump(cubrid_fetch_row($req));

cubrid_field_seek($req, 1);
$field = cubrid_fetch_field($req);

printf("\n--- Field Properties ---\n");
printf("%-30s %s\n", "name:", $field->name);
printf("%-30s %s\n", "table:", $field->table);
printf("%-30s \"%s\"\n", "default value:", $field->def);
printf("%-30s %d\n", "max length:", $field->max_length);
printf("%-30s %d\n", "not null:", $field->not_null);
printf("%-30s %d\n", "primary key:", $field->primary_key);
printf("%-30s %d\n", "unique key:", $field->unique_key);
printf("%-30s %d\n", "multiple key:", $field->multiple_key);
printf("%-30s %d\n", "numeric:", $field->numeric);
printf("%-30s %d\n", "blob:", $field->blob);
printf("%-30s %s\n", "type:", $field->type);
printf("%-30s %d\n", "unsigned:", $field->unsigned);
printf("%-30s %d\n", "zerofill:", $field->zerofill);

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

以上例程会输出：

array(4) {
  [0]=>
  string(5) "20001"
  [1]=>
  string(5) "16681"
  [2]=>
  string(3) "KOR"
  [3]=>
  string(9) "1988-9-30"
}

--- Field Properties ---
name:                          athlete_code
table:                         game
default value:                 ""
max length:                    0
not null:                      1
primary key:                   1
unique key:                    1
multiple key:                  0
numeric:                       1
blob:                          0
type:                          integer
unsigned:                      0
zerofill:                      0


Return an array with the lengths of the values of each field from the current row

  • ? cubrid_fetch_field
  • cubrid_fetch_object ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return an array with the lengths of the values of each field from the current row

cubrid_fetch_lengths

(PECL CUBRID >= 8.3.0)

cubrid_fetch_lengths — Return an array with the lengths of the values of each field from the current row

说明

cubrid_fetch_lengths ( resource $result ) : array

This function returns an numeric array with the lengths of the values of each field from the current row of the result set or it returns FALSE on failure.

Note:

If field data type is BLOB/CLOB, you should get its length by using cubrid_lob_size().

参数

result

result comes from a call to cubrid_execute()

返回值

An numeric array, when process is successful.

false on failure.

范例

Example #1 cubrid_fetch_lengths() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$row = cubrid_fetch_row($result);
print_r($row);

$lens = cubrid_fetch_lengths($result);
print_r($lens);

cubrid_disconnect($conn);
?>

以上例程会输出：

Array
(
    [0] => 2004
    [1] => 20085
    [2] => 15118
    [3] => 30134
    [4] => AUS
    [5] => G
    [6] => 2004-8-20
)
Array
(
    [0] => 4
    [1] => 5
    [2] => 5
    [3] => 5
    [4] => 3
    [5] => 1
    [6] => 10
)


Fetch the next row and return it as an object

  • ? cubrid_fetch_lengths
  • cubrid_fetch_row ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Fetch the next row and return it as an object

cubrid_fetch_object

(PECL CUBRID >= 8.3.0)

cubrid_fetch_object — Fetch the next row and return it as an object

说明

cubrid_fetch_object ( resource $result , string $class_name = ? , array $params = ? , int $type = ? ) : object

This function returns an object with the column names of the result set as properties. The values of these properties are extracted from the current row of the result.

参数

result

result comes from a call to cubrid_execute()

class_name

The name of the class to instantiate. If not specified, a stdClass (stdClass is PHP's generic empty class that's used when casting other types to objects) object is returned.

params

An optional array of parameters to pass to the constructor for class_name objects.

type

Type can only be CUBRID_LOB, this parameter will be used only when you need to operate the lob object.

返回值

An object, when process is successful.

false, when there are no more rows; NULL, when process is unsuccessful.

范例

Example #1 cubrid_fetch_object() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$res = cubrid_execute($conn, "SELECT * FROM code");

var_dump(cubrid_fetch_object($res));

// if you want to operate LOB object, you can use cubrid_fetch_object($res, CUBRID_LOB)

class demodb_code {
    public $s_name = null;
    public $f_name = null;

    public function toString() {
        var_dump($this);
    }
}

var_dump(cubrid_fetch_object($res, "demodb_code"));

// if you want to operate LOB object, you can use cubrid_fetch_object($res, "demodb_code", CUBRID_LOB)

class demodb_code_construct extends demodb_code {
    public function __construct($s, $f) {
        $this->s_name = $s;
        $this->f_name = $f;
    }
}

var_dump(cubrid_fetch_object($res, 'demodb_code_construct', array('s_name', 'f_name')));

// if you want to operate LOB object, you can use cubrid_fetch_object($res, 'demodb_code_construct', array('s_name', 'f_name'), CUBRID_LOB)

var_dump(cubrid_fetch_object($res));

cubrid_close_request($res);
cubrid_disconnect($conn);
?>

以上例程会输出：

object(stdClass)#1 (2) {
  ["s_name"]=>
  string(1) "X"
  ["f_name"]=>
  string(5) "Mixed"
}
object(demodb_code)#1 (2) {
  ["s_name"]=>
  string(1) "W"
  ["f_name"]=>
  string(5) "Woman"
}
object(demodb_code_construct)#1 (2) {
  ["s_name"]=>
  string(6) "s_name"
  ["f_name"]=>
  string(6) "f_name"
}
object(stdClass)#1 (2) {
  ["s_name"]=>
  string(1) "B"
  ["f_name"]=>
  string(6) "Bronze"
}

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch() - Fetch the next row from a result set
  • cubrid_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_fetch_row() - Return a numerical array with the values of the current row


Return a numerical array with the values of the current row

  • ? cubrid_fetch_object
  • cubrid_field_flags ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return a numerical array with the values of the current row

cubrid_fetch_row

(PECL CUBRID >= 8.3.0)

cubrid_fetch_row — Return a numerical array with the values of the current row

说明

cubrid_fetch_row ( resource $result , int $type = ? ) : array

This function returns a numerical array with the values of the current row from the result set, starting from 0, and moves the internal data pointer ahead.

参数

result

result comes from a call to cubrid_execute()

type

Type can only be CUBRID_LOB, this parameter will be used only when you need to operate the lob object.

返回值

A numerical array, when process is successful.

false, when there are no more rows; NULL, when process is unsuccessful.

范例

Example #1 cubrid_fetch_row() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($row = cubrid_fetch_row($req)) {
    printf("%-40s %-10s %-6s %-20s\n", $row[0], $row[1], $row[2], $row[3]);
}

// if you want to operate LOB object, you can use cubrid_fetch_row($req, CUBRID_LOB)

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

以上例程会输出：

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

参见

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch() - Fetch the next row from a result set
  • cubrid_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_fetch_object() - Fetch the next row and return it as an object


Return a string with the flags of the given field offset

  • ? cubrid_fetch_row
  • cubrid_field_len ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return a string with the flags of the given field offset

cubrid_field_flags

(PECL CUBRID >= 8.3.0)

cubrid_field_flags — Return a string with the flags of the given field offset

说明

cubrid_field_flags ( resource $result , int $field_offset ) : string

This function returns a string with the flags of the given field offset separated by space. You can split the returned value using explode. The possible flags could be: not_null, primary_key, unique_key, foreign_key, auto_increment, shared, reverse_index, reverse_unique and timestamp.

参数

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

返回值

A string with flags, when process is successful.

false when invalid field_offset value.

-1 if SQL sentence is not SELECT.

范例

Example #1 cubrid_field_flags() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$col_num = cubrid_num_cols($result);

printf("%-30s %s\n", "Field Name", "Field Flags");
for($i = 0; $i < $col_num; $i++) {
    printf("%-30s %s\n", cubrid_field_name($result, $i), cubrid_field_flags($result, $i));
}

cubrid_disconnect($conn);
?>

以上例程会输出：

Field Name                     Field Flags
host_year                      not_null primary_key unique_key
event_code                     not_null primary_key unique_key foreign_key
athlete_code                   not_null primary_key unique_key foreign_key
stadium_code                   not_null
nation_code
medal
game_date


Get the maximum length of the specified field

  • ? cubrid_field_flags
  • cubrid_field_name ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Get the maximum length of the specified field

cubrid_field_len

(PECL CUBRID >= 8.3.0)

cubrid_field_len — Get the maximum length of the specified field

说明

cubrid_field_len ( resource $result , int $field_offset ) : int

This function returns the maximum length of the specified field on success, or it returns FALSE on failure.

参数

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

返回值

Maximum length, when process is successful.

false on failure.

范例

Example #1 cubrid_field_len() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

以上例程会输出：

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10


Return the name of the specified field index

  • ? cubrid_field_len
  • cubrid_field_seek ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the name of the specified field index

cubrid_field_name

(PECL CUBRID >= 8.3.0)

cubrid_field_name — Return the name of the specified field index

说明

cubrid_field_name ( resource $result , int $field_offset ) : string

This function returns the name of the specified field index on success or it returns FALSE on failure.

参数

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

返回值

Name of specified field index, on success.

false on failure.

范例

Example #1 cubrid_field_name() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$col_num = cubrid_num_cols($result);

printf("%-30s %s\n", "Field Name", "Field Flags");
for($i = 0; $i < $col_num; $i++) {
    printf("%-30s %s\n", cubrid_field_name($result, $i), cubrid_field_flags($result, $i));
}

cubrid_disconnect($conn);
?>

以上例程会输出：

Field Name                     Field Flags
host_year                      not_null primary_key unique_key
event_code                     not_null primary_key unique_key foreign_key
athlete_code                   not_null primary_key unique_key foreign_key
stadium_code                   not_null
nation_code
medal
game_date


Move the result set cursor to the specified field offset

  • ? cubrid_field_name
  • cubrid_field_table ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Move the result set cursor to the specified field offset

cubrid_field_seek

(PECL CUBRID >= 8.3.0)

cubrid_field_seek — Move the result set cursor to the specified field offset

说明

cubrid_field_seek ( resource $result , int $field_offset = 0 ) : bool

This function moves the result set cursor to the specified field offset. This offset is used by cubrid_fetch_field() if it doesn't include a field offset. It returns TRUE on success or FALSE on failure.

参数

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

返回值

true on success.

false on failure.

范例

Example #1 cubrid_field_seek() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT event_code,athlete_code,nation_code,game_date FROM game WHERE host_year=1988 and event_code=20001;");

var_dump(cubrid_fetch_row($req));

cubrid_field_seek($req, 1);
$field = cubrid_fetch_field($req);

printf("\n--- Field Properties ---\n");
printf("%-30s %s\n", "name:", $field->name);
printf("%-30s %s\n", "table:", $field->table);
printf("%-30s \"%s\"\n", "default value:", $field->def);
printf("%-30s %d\n", "max length:", $field->max_length);
printf("%-30s %d\n", "not null:", $field->not_null);
printf("%-30s %d\n", "unique key:", $field->unique_key);
printf("%-30s %d\n", "multiple key:", $field->multiple_key);
printf("%-30s %d\n", "numeric:", $field->numeric);
printf("%-30s %s\n", "type:", $field->type);

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

以上例程会输出：

array(4) {
  [0]=>
  string(5) "20001"
  [1]=>
  string(5) "16132"
  [2]=>
  string(3) "KOR"
  [3]=>
  string(9) "1988-09-30"
}

--- Field Properties ---
name:                          athlete_code
table:                         game
default value:                 ""
max length:                    0
not null:                      1
unique key:                    1
multiple key:                  0
numeric:                       1
type:                          integer


Return the name of the table of the specified field

  • ? cubrid_field_seek
  • cubrid_field_type ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the name of the table of the specified field

cubrid_field_table

(PECL CUBRID >= 8.3.0)

cubrid_field_table — Return the name of the table of the specified field

说明

cubrid_field_table ( resource $result , int $field_offset ) : string

This function returns the name of the table of the specified field. This is useful when using large select queries with JOINS.

参数

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

返回值

Name of the table of the specified field, on success.

false when invalid field_offset value.

-1 if SQL sentence is not SELECT.

范例

Example #1 cubrid_field_table() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM code");

$col_num = cubrid_num_cols($result);

printf("%-15s %-15s %s\n", "Field Table", "Field Name", "Field Type");
for($i = 0; $i < $col_num; $i++) {
    printf("%-15s %-15s %s\n",
        cubrid_field_table($result, $i), cubrid_field_name($result, $i), cubrid_field_type($result, $i));
}

cubrid_disconnect($conn);
?>

以上例程会输出：

Field Table     Field Name      Field Type
code            s_name          char
code            f_name          varchar


Return the type of the column corresponding to the given field offset

  • ? cubrid_field_table
  • cubrid_list_dbs ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the type of the column corresponding to the given field offset

cubrid_field_type

(PECL CUBRID >= 8.3.0)

cubrid_field_type — Return the type of the column corresponding to the given field offset

说明

cubrid_field_type ( resource $result , int $field_offset ) : string

This function returns the type of the column corresponding to the given field offset. The returned field type could be one of the following: "int", "real", "string", etc.

参数

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

返回值

Type of the column, on success.

false when invalid field_offset value.

-1 if SQL sentence is not SELECT.

范例

Example #1 cubrid_field_type() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM code");

$col_num = cubrid_num_cols($result);

printf("%-15s %-15s %s\n", "Field Table", "Field Name", "Field Type");
for($i = 0; $i < $col_num; $i++) {
    printf("%-15s %-15s %s\n",
        cubrid_field_table($result, $i), cubrid_field_name($result, $i), cubrid_field_type($result, $i));
}

cubrid_disconnect($conn);
?>

以上例程会输出：

Field Table     Field Name      Field Type
code            s_name          char
code            f_name          varchar


Return an array with the list of all existing CUBRID databases

  • ? cubrid_field_type
  • cubrid_num_fields ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return an array with the list of all existing CUBRID databases

cubrid_list_dbs

(PECL CUBRID >= 8.3.0)

cubrid_list_dbs — Return an array with the list of all existing CUBRID databases

说明

cubrid_list_dbs ( resource $conn_identifier = ? ) : array

This function returns an array with the list of all existing Cubrid databases.

参数

conn_identifier

The CUBRID connection.

返回值

An numeric array with all existing Cubrid databases; on success.

false on failure.

范例

Example #1 cubrid_list_dbs() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$db_list = cubrid_list_dbs($conn);
var_dump($db_list);

cubrid_disconnect($conn);
?>

以上例程会输出：

array(1) {
  [0]=>
  string(6) "demodb"
}


Return the number of columns in the result set

  • ? cubrid_list_dbs
  • cubrid_ping ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the number of columns in the result set

cubrid_num_fields

(PECL CUBRID >= 8.3.0)

cubrid_num_fields — Return the number of columns in the result set

说明

cubrid_num_fields ( resource $result ) : int

This function returns the number of columns in the result set, on success, or it returns FALSE on failure.

参数

result

result comes from a call to cubrid_execute(), cubrid_query() and cubrid_prepare()

返回值

Number of columns, on success.

-1 if SQL sentence is not SELECT.

false when process is unsuccessful.

范例

Example #1 cubrid_num_fields() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_fields($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

以上例程会输出：

Row Num: 6
Column Num: 2


Ping a server connection or reconnect if there is no connection

  • ? cubrid_num_fields
  • cubrid_query ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Ping a server connection or reconnect if there is no connection

cubrid_ping

(PECL CUBRID >= 8.3.1)

cubrid_ping — Ping a server connection or reconnect if there is no connection

说明

cubrid_ping ( resource $conn_identifier = ? ) : bool

Checks whether or not the connection to the server is working.

参数

conn_identifier

The CUBRID connection identifier. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

返回值

Returns true if the connection to the server CUBRID server is working, otherwise false.

范例

Example #1 cubrid_ping() example

<?php
set_time_limit(0);

$conn = cubrid_connect('localhost', 33000, 'demodb');

/* Assuming this query will take a long time */
$sql = "select * from athlete";
$result = cubrid_query($sql);
if (!$result) {
    echo 'Query #1 failed, exiting.';
    exit;
}

/* Make sure the connection is still alive, if not, try to reconnect */
if (!cubrid_ping($conn)) {
    echo 'Lost connection, exiting after query #1';
    exit;
}
cubrid_free_result($result);

/* So the connection is still alive, let's run another query */
$sql2 = "select * from code";
$result2 = cubrid_query($sql2);
?>


Send a CUBRID query

  • ? cubrid_ping
  • cubrid_real_escape_string ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Send a CUBRID query

cubrid_query

(PECL CUBRID >= 8.3.1)

cubrid_query — Send a CUBRID query

说明

cubrid_query ( string $query , resource $conn_identifier = ? ) : resource

cubrid_query() sends a unique query (multiple queries are not supported) to the currently active database on the server that's associated with the specified conn_identifier.

参数

query

An SQL query

Data inside the query should be properly escaped.

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

返回值

For SELECT, SHOW, DESCRIBE, EXPLAIN and other statements returning resultset, cubrid_query() returns a resource on success, or false on error.

For other type of SQL statements, INSERT, UPDATE, DELETE, DROP, etc, cubrid_query() returns true on success or false on error.

The returned result resource should be passed to cubrid_fetch_array(), and other functions for dealing with result tables, to access the returned data.

Use cubrid_num_rows() to find out how many rows were returned for a SELECT statement or cubrid_affected_rows() to find out how many rows were affected by a DELETE, INSERT, REPLACE, or UPDATE statement.

cubrid_query() will also fail and return false if the user does not have permission to access the table(s) referenced by the query.

范例

Example #1 Invalid Query

The following query is syntactically invalid, so cubrid_query() fails and returns false.

<?php
$conn = cubrid_connect('localhost', 33000, 'demodb');

$result = cubrid_query('SELECT * WHERE 1=1');
if (!$result) {
    die('Invalid query: ' . cubrid_error());
}

?>

Example #2 Valid Query

The following query is valid, so cubrid_query() returns a resource.

<?php
// This could be supplied by a user, for example
$firstname = 'fred';
$lastname  = 'fox';

$conn = cubrid_connect('localhost', 33000, 'demodb');

cubrid_execute($conn,"DROP TABLE if exists friends");
cubrid_execute($conn,"create table friends(firstname varchar,lastname varchar,address char(24),age int)");
cubrid_execute($conn,"insert into friends values('fred','fox','home-1','20')");
cubrid_execute($conn,"insert into friends values('blue','cat','home-2','21')");
// Formulate Query
// This is the best way to perform an SQL query
// For more examples, see cubrid_real_escape_string()
$query = sprintf("SELECT firstname, lastname, address, age FROM friends WHERE firstname='%s' AND lastname='%s'",
cubrid_real_escape_string($firstname),
cubrid_real_escape_string($lastname));

// Perform Query
$result = cubrid_query($query);

// Check result
// This shows the actual query sent to CUBRID, and the error. Useful for debugging.
if (!$result) {
    $message  = 'Invalid query: ' . cubrid_error() . "\n";
    $message .= 'Whole query: ' . $query;
    die($message);
}

// Use result
// Attempting to print $result won't allow access to information in the resource
// One of the cubrid result functions must be used
// See also cubrid_result(), cubrid_fetch_array(), cubrid_fetch_row(), etc.
while ($row = cubrid_fetch_assoc($result)) {
    echo $row['firstname'];
    echo $row['lastname'];
    echo $row['address'];
    echo $row['age'];
}

// Free the resources associated with the result set
// This is done automatically at the end of the script
cubrid_free_result($result);
?>

参见

  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_error() - Get the error message
  • cubrid_real_escape_string() - Escape special characters in a string for use in an SQL statement
  • cubrid_result() - Return the value of a specific field in a specific row
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_unbuffered_query() - Perform a query without fetching the results into memory


Escape special characters in a string for use in an SQL statement

  • ? cubrid_query
  • cubrid_result ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Escape special characters in a string for use in an SQL statement

cubrid_real_escape_string

(PECL CUBRID >= 8.3.0)

cubrid_real_escape_string — Escape special characters in a string for use in an SQL statement

说明

cubrid_real_escape_string ( string $unescaped_string , resource $conn_identifier = ? ) : string

This function returns the escaped string version of the given string. It will escape the following characters: '. In general, single quotations are used to enclose character string. Double quotations may be used as well depending on the value of ansi_quotes, which is a parameter related to SQL statement. If the ansi_quotes value is set to no, character string enclosed by double quotations is handled as character string, not as an identifier. The default value is yes. If you want to include a single quote as part of a character string, enter two single quotes in a row.

参数

unescaped_string

The string that is to be escaped.

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

返回值

Escaped string version of the given string, on success.

false on failure.

范例

Example #1 cubrid_real_escape_string() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$unescaped_str = ' !"#$%&\'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~';
$escaped_str = cubrid_real_escape_string($unescaped_str);

$len = strlen($unescaped_str);

@cubrid_execute($conn, "DROP TABLE cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (t char($len))");
cubrid_execute($conn, "INSERT INTO cubrid_test (t) VALUES('$escaped_str')");

$req = cubrid_execute($conn, "SELECT * FROM cubrid_test");
$row = cubrid_fetch_assoc($req);

var_dump($row);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

array(1) {
  ["t"]=>
  string(95) " !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~"
}


Return the value of a specific field in a specific row

  • ? cubrid_real_escape_string
  • cubrid_unbuffered_query ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Return the value of a specific field in a specific row

cubrid_result

(PECL CUBRID >= 8.3.0)

cubrid_result — Return the value of a specific field in a specific row

说明

cubrid_result ( resource $result , int $row , mixed $field = 0 ) : string

This function returns the value of a specific field in a specific row from a result set.

参数

result

result comes from a call to cubrid_execute()

row

The row number from the result that is being retrieved. Row numbers start at 0.

field

The name or offset of the field being retrieved. It can be the field's offset, the field's name, or the field's table dot field name (tablename.fieldname). If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name. If undefined, the first field is retrieved.

返回值

Value of a specific field, on success (NULL if value if null).

false on failure.

范例

Example #1 cubrid_result() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");

$result = cubrid_result($req, 0);
var_dump($result);

$result = cubrid_result($req, 0, 1);
var_dump($result);

$result = cubrid_result($req, 5, "f_name");
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

以上例程会输出：

string(1) "X"
string(5) "Mixed"
string(4) "Gold"


Perform a query without fetching the results into memory

  • ? cubrid_result
  • CUBRID 过时的别名和函数 ?
  • PHP Manual
  • CUBRID MySQL 兼容性函数
  • Perform a query without fetching the results into memory

cubrid_unbuffered_query

(PECL CUBRID >= 8.3.0)

cubrid_unbuffered_query — Perform a query without fetching the results into memory

说明

cubrid_unbuffered_query ( string $query , resource $conn_identifier = ? ) : resource

This function performs a query without waiting for that all query results have been complete. It will return when the results are being generated.

参数

query

A SQL query.

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

返回值

For SELECT, SHOW, DESCRIBE or EXPLAIN statements returns a request identifier resource on success.

For other type of SQL statements, UPDATE, DELETE, DROP, etc, returns true on success.

false on failure.

注释

Note:

The benefits of cubrid_unbuffered_query() come at a cost: you cannot use cubrid_num_rows() and cubrid_data_seek() on a result set returned from cubrid_unbuffered_query().

范例

Example #1 cubrid_unbuffered_query() example

<?php
    $link = cubrid_connect("localhost", 30000, "demodb", "dba", "");
    if (!$link)
    {
        die('Could not connect.');
    }
    $query = "select * from code";
    $result = cubrid_unbuffered_query($query, $link);

    while ($row = cubrid_fetch($result))
    {
        var_dump($row);
    }

    cubrid_close_request($result);
    cubrid_disconnect($link);
?>


CUBRID 过时的别名和函数

Table of Contents

  • cubrid_load_from_glo — Read data from a GLO instance and save it in a file
  • cubrid_new_glo — Create a glo instance
  • cubrid_save_to_glo — Save requested file in a GLO instance
  • cubrid_send_glo — Read data from glo and send it to std output


Read data from a GLO instance and save it in a file

  • ? CUBRID 过时的别名和函数
  • cubrid_new_glo ?
  • PHP Manual
  • CUBRID 过时的别名和函数
  • Read data from a GLO instance and save it in a file

cubrid_load_from_glo

(PECL CUBRID >= 8.3.0)

cubrid_load_from_glo — Read data from a GLO instance and save it in a file

说明

cubrid_load_from_glo ( resource $conn_identifier , string $oid , string $file_name ) : int

The cubrid_load_from_glo() function is used to read a data from a glo instance, and saves it in a designated file.

参数

conn_identifier

Connection identifier.

oid

Oid of the glo instance that you want to read the data from.

file_name

Name of the file where you want to save the data in.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_load_from_glo() example

<?php
$req = cubrid_execute ($con, "select image from person where id=1");
if ($req) {
   list ($oid) = cubrid_fetch($req);
   cubrid_close_request($req);
   $res = cubrid_load_from_glo ($con, $oid, "output.jpg");
   if ($res) {
      echo "image changed successfully";
   }
}
?>

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： cubrid_load_from_glo()

Note:

This function is removed from CUBRID 3.1.

参见

  • cubrid_new_glo() - Create a glo instance
  • cubrid_save_to_glo() - Save requested file in a GLO instance
  • cubrid_send_glo() - Read data from glo and send it to std output


Create a glo instance

  • ? cubrid_load_from_glo
  • cubrid_save_to_glo ?
  • PHP Manual
  • CUBRID 过时的别名和函数
  • Create a glo instance

cubrid_new_glo

(PECL CUBRID >= 8.3.0)

cubrid_new_glo — Create a glo instance

说明

cubrid_new_glo ( resource $conn_identifier , string $class_name , string $file_name ) : string

The cubrid_new_glo() function is used to create a glo instance in the requested class (glo class). The glo created is a LO type, and is stored in the file_name file.

参数

conn_identifier

Connection identifier.

class_name

Name of the class that you want to create a glo in.

file_name

The file name that you want to save in the newly created glo.

返回值

Oid of the instance created, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_new_glo() example

<?php
$oid = cubrid_new_glo ($con, "glo", "input.jpg");
if ($oid){
   // the type of column "image" is "object"
   $req = cubrid_execute ($con, "insert into person(image) values($oid)");
   if ($req) {
      echo "image inserted successfully";
      cubrid_close_request ($req);
      cubrid_commit($con);
   }
}
?>

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： cubrid_new_glo()

Note:

This function is removed from CUBRID 3.1.

参见

  • cubrid_save_to_glo() - Save requested file in a GLO instance
  • cubrid_load_from_glo() - Read data from a GLO instance and save it in a file
  • cubrid_send_glo() - Read data from glo and send it to std output


Save requested file in a GLO instance

  • ? cubrid_new_glo
  • cubrid_send_glo ?
  • PHP Manual
  • CUBRID 过时的别名和函数
  • Save requested file in a GLO instance

cubrid_save_to_glo

(PECL CUBRID >= 8.3.0)

cubrid_save_to_glo — Save requested file in a GLO instance

说明

cubrid_save_to_glo ( resource $conn_identifier , string $oid , string $file_name ) : int

The cubrid_save_to_glo() function is used to save requested file in a glo instance.

参数

conn_identifier

Connection identifier.

oid

Oid of the glo instance that you want to save a file in.

file_name

The name of the file that you want to save.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_save_to_glo() example

<?php
$req = cubrid_execute ($con, "select image from person where id=1");
if ($req) {
   list ($oid) = cubrid_fetch($req);
   cubrid_close_request($req);
   $res = cubrid_save_to_glo ($con, $oid, "input.jpg");
   if ($res) {
      echo "image changed successfully";
   }
}
?>

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： cubrid_save_to_glo()

Note:

This function is removed from CUBRID 3.1.

参见

  • cubrid_new_glo() - Create a glo instance
  • cubrid_load_from_glo() - Read data from a GLO instance and save it in a file
  • cubrid_send_glo() - Read data from glo and send it to std output


Read data from glo and send it to std output

  • ? cubrid_save_to_glo
  • DB++ ?
  • PHP Manual
  • CUBRID 过时的别名和函数
  • Read data from glo and send it to std output

cubrid_send_glo

(PECL CUBRID >= 8.3.0)

cubrid_send_glo — Read data from glo and send it to std output

说明

cubrid_send_glo ( resource $conn_identifier , string $oid ) : int

The cubrid_send_glo() function is used to read data from glo instance and sends it to the PHP standard output.

参数

conn_identifier

Connection identifier.

oid

Oid of the glo instance that you want to read data from.

返回值

true, when process is successful.

false, when process is unsuccessful.

范例

Example #1 cubrid_send_glo() example

<?php
$req = cubrid_execute ($con, "select image from person where id =1");
if ($req) {
  list ($oid) = cubrid_fetch($req);
  cubrid_close_request($req);
  Header ("Content-type: image/jpeg");
  cubrid_send_glo ($con, $oid);
}
?>

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： cubrid_send_glo()

Note:

This function is removed from CUBRID 3.1.

参见

  • cubrid_new_glo() - Create a glo instance
  • cubrid_save_to_glo() - Save requested file in a GLO instance
  • cubrid_load_from_glo() - Read data from a GLO instance and save it in a file


DB++

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
    • db++ error codes
  • DB++ 函数
    • dbplus_add — Add a tuple to a relation
    • dbplus_aql — Perform AQL query
    • dbplus_chdir — Get/Set database virtual current directory
    • dbplus_close — Close a relation
    • dbplus_curr — Get current tuple from relation
    • dbplus_errcode — Get error string for given errorcode or last error
    • dbplus_errno — Get error code for last operation
    • dbplus_find — Set a constraint on a relation
    • dbplus_first — Get first tuple from relation
    • dbplus_flush — Flush all changes made on a relation
    • dbplus_freealllocks — Free all locks held by this client
    • dbplus_freelock — Release write lock on tuple
    • dbplus_freerlocks — Free all tuple locks on given relation
    • dbplus_getlock — Get a write lock on a tuple
    • dbplus_getunique — Get an id number unique to a relation
    • dbplus_info — Get information about a relation
    • dbplus_last — Get last tuple from relation
    • dbplus_lockrel — Request write lock on relation
    • dbplus_next — Get next tuple from relation
    • dbplus_open — Open relation file
    • dbplus_prev — Get previous tuple from relation
    • dbplus_rchperm — Change relation permissions
    • dbplus_rcreate — Creates a new DB++ relation
    • dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices
    • dbplus_rcrtlike — Creates an empty copy of a relation with default indices
    • dbplus_resolve — Resolve host information for relation
    • dbplus_restorepos — Restore position
    • dbplus_rkeys — Specify new primary key for a relation
    • dbplus_ropen — Open relation file local
    • dbplus_rquery — Perform local (raw) AQL query
    • dbplus_rrename — Rename a relation
    • dbplus_rsecindex — Create a new secondary index for a relation
    • dbplus_runlink — Remove relation from filesystem
    • dbplus_rzap — Remove all tuples from relation
    • dbplus_savepos — Save position
    • dbplus_setindex — Set index
    • dbplus_setindexbynumber — Set index by number
    • dbplus_sql — Perform SQL query
    • dbplus_tcl — Execute TCL code on server side
    • dbplus_tremove — Remove tuple and return new current tuple
    • dbplus_undo — Undo
    • dbplus_undoprepare — Prepare undo
    • dbplus_unlockrel — Give up write lock on relation
    • dbplus_unselect — Remove a constraint from relation
    • dbplus_update — Update specified tuple in relation
    • dbplus_xlockrel — Request exclusive lock on relation
    • dbplus_xunlockrel — Free exclusive lock on relation


简介

db++, made by the German company » Concept asa, is a relational database system with high performance and low memory and disk usage in mind. While providing SQL as an additional language interface, it is not really an SQL database in the first place but provides its own AQL query language which is much more influenced by the relational algebra than SQL is.

Concept asa always had an interest in supporting open source languages, db++ has had Perl and Tcl call interfaces for years now and uses Tcl as its internal stored procedure language.

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。4.3.0

Warning

此扩展是实验性 的。 此扩展的表象，包括其函数名称以及其他此扩展的相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本扩展风险自担。


需求

This extension relies on external client libraries so you have to have a db++ client installed on the system you want to use this extension on.

» Concept asa provides » db++ Demo versions and » documentation for Linux, some other Unix versions. There is also a Windows version of db++, but this extension doesn't support it (yet).


安装

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。4.3.0

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/dbplus.

In order to build this extension yourself you need the db++ client libraries and header files to be installed on your system (these are included in the db++ installation archives by default). You have to run configure with option --with-dbplus to build this extension.

configure looks for the client libraries and header files under the default paths /usr/dbplus, /usr/local/dbplus and /opt/dblus. If you have installed db++ in a different place you have add the installation path to the configure option like this: --with-dbplus=/your/installation/path.


资源类型

dbplus_relation

Most db++ functions operate on or return dbplus_relation resources. A dbplus_relation is a handle to a stored relation or a relation generated as the result of a query.


预定义常量

Table of Contents

  • db++ error codes

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。


db++ error codes

DB++ Error Codes
PHP Constant | db++ constant | meaning
DBPLUS_ERR_NOERR (int) | ERR_NOERR | Null error condition
DBPLUS_ERR_DUPLICATE (int) | ERR_DUPLICATE | Tried to insert a duplicate tuple
DBPLUS_ERR_EOSCAN (int) | ERR_EOSCAN | End of scan from rget()
DBPLUS_ERR_EMPTY (int) | ERR_EMPTY | Relation is empty (server)
DBPLUS_ERR_CLOSE (int) | ERR_CLOSE | The server can't close
DBPLUS_ERR_WLOCKED (int) | ERR_WLOCKED | The record is write locked
DBPLUS_ERR_LOCKED (int) | ERR_LOCKED | Relation was already locked
DBPLUS_ERR_NOLOCK (int) | ERR_NOLOCK | Relation cannot be locked
DBPLUS_ERR_READ (int) | ERR_READ | Read error on relation
DBPLUS_ERR_WRITE (int) | ERR_WRITE | Write error on relation
DBPLUS_ERR_CREATE (int) | ERR_CREATE | Create() system call failed
DBPLUS_ERR_LSEEK (int) | ERR_LSEEK | Lseek() system call failed
DBPLUS_ERR_LENGTH (int) | ERR_LENGTH | Tuple exceeds maximum length
DBPLUS_ERR_OPEN (int) | ERR_OPEN | Open() system call failed
DBPLUS_ERR_WOPEN (int) | ERR_WOPEN | Relation already opened for writing
DBPLUS_ERR_MAGIC (int) | ERR_MAGIC | File is not a relation
DBPLUS_ERR_VERSION (int) | ERR_VERSION | File is a very old relation
DBPLUS_ERR_PGSIZE (int) | ERR_PGSIZE | Relation uses a different page size
DBPLUS_ERR_CRC (int) | ERR_CRC | Invalid crc in the superpage
DBPLUS_ERR_PIPE (int) | ERR_PIPE | Piped relation requires lseek()
DBPLUS_ERR_NIDX (int) | ERR_NIDX | Too many secondary indices
DBPLUS_ERR_MALLOC (int) | ERR_MALLOC | Malloc() call failed
DBPLUS_ERR_NUSERS (int) | ERR_NUSERS | Error use of max users
DBPLUS_ERR_PREEXIT (int) | ERR_PREEXIT | Caused by invalid usage
DBPLUS_ERR_ONTRAP (int) | ERR_ONTRAP | Caused by a signal
DBPLUS_ERR_PREPROC (int) | ERR_PREPROC | Error in the preprocessor
DBPLUS_ERR_DBPARSE (int) | ERR_DBPARSE | Error in the parser
DBPLUS_ERR_DBRUNERR (int) | ERR_DBRUNERR | Run error in db
DBPLUS_ERR_DBPREEXIT (int) | ERR_DBPREEXIT | Exit condition caused by prexit() * procedure
DBPLUS_ERR_WAIT (int) | ERR_WAIT | Wait a little (Simple only)
DBPLUS_ERR_CORRUPT_TUPLE (int) | ERR_CORRUPT_TUPLE | A client sent a corrupt tuple
DBPLUS_ERR_WARNING0 (int) | ERR_WARNING0 | The Simple routines encountered a non fatal error which was corrected
DBPLUS_ERR_PANIC (int) | ERR_PANIC | The server should not really die but after a disaster send ERR_PANIC to all its clients
DBPLUS_ERR_FIFO (int) | ERR_FIFO | Can't create a fifo
DBPLUS_ERR_PERM (int) | ERR_PERM | Permission denied
DBPLUS_ERR_TCL (int) | ERR_TCL | TCL_error
DBPLUS_ERR_RESTRICTED (int) | ERR_RESTRICTED | Only two users
DBPLUS_ERR_USER (int) | ERR_USER | An error in the use of the library by an application programmer
DBPLUS_ERR_UNKNOWN (int) | ERR_UNKNOWN |


DB++ 函数

Table of Contents

  • dbplus_add — Add a tuple to a relation
  • dbplus_aql — Perform AQL query
  • dbplus_chdir — Get/Set database virtual current directory
  • dbplus_close — Close a relation
  • dbplus_curr — Get current tuple from relation
  • dbplus_errcode — Get error string for given errorcode or last error
  • dbplus_errno — Get error code for last operation
  • dbplus_find — Set a constraint on a relation
  • dbplus_first — Get first tuple from relation
  • dbplus_flush — Flush all changes made on a relation
  • dbplus_freealllocks — Free all locks held by this client
  • dbplus_freelock — Release write lock on tuple
  • dbplus_freerlocks — Free all tuple locks on given relation
  • dbplus_getlock — Get a write lock on a tuple
  • dbplus_getunique — Get an id number unique to a relation
  • dbplus_info — Get information about a relation
  • dbplus_last — Get last tuple from relation
  • dbplus_lockrel — Request write lock on relation
  • dbplus_next — Get next tuple from relation
  • dbplus_open — Open relation file
  • dbplus_prev — Get previous tuple from relation
  • dbplus_rchperm — Change relation permissions
  • dbplus_rcreate — Creates a new DB++ relation
  • dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices
  • dbplus_rcrtlike — Creates an empty copy of a relation with default indices
  • dbplus_resolve — Resolve host information for relation
  • dbplus_restorepos — Restore position
  • dbplus_rkeys — Specify new primary key for a relation
  • dbplus_ropen — Open relation file local
  • dbplus_rquery — Perform local (raw) AQL query
  • dbplus_rrename — Rename a relation
  • dbplus_rsecindex — Create a new secondary index for a relation
  • dbplus_runlink — Remove relation from filesystem
  • dbplus_rzap — Remove all tuples from relation
  • dbplus_savepos — Save position
  • dbplus_setindex — Set index
  • dbplus_setindexbynumber — Set index by number
  • dbplus_sql — Perform SQL query
  • dbplus_tcl — Execute TCL code on server side
  • dbplus_tremove — Remove tuple and return new current tuple
  • dbplus_undo — Undo
  • dbplus_undoprepare — Prepare undo
  • dbplus_unlockrel — Give up write lock on relation
  • dbplus_unselect — Remove a constraint from relation
  • dbplus_update — Update specified tuple in relation
  • dbplus_xlockrel — Request exclusive lock on relation
  • dbplus_xunlockrel — Free exclusive lock on relation


Add a tuple to a relation

  • ? DB++ 函数
  • dbplus_aql ?
  • PHP Manual
  • DB++ 函数
  • Add a tuple to a relation

dbplus_add

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_add — Add a tuple to a relation

说明

dbplus_add ( resource $relation , array $tuple ) : int

Adds a tuple to a relation.

参数

relation

tuple

An array of attribute/value pairs to be inserted into the given relation.

After successful execution this array will contain the complete data of the newly created tuple, including all implicitly set domain fields like sequences.

返回值

The function will return DBPLUS_ERR_NOERR on success or a db++ error code on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_errcode() - Get error string for given errorcode or last error


Perform AQL query

  • ? dbplus_add
  • dbplus_chdir ?
  • PHP Manual
  • DB++ 函数
  • Perform AQL query

dbplus_aql

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_aql — Perform AQL query

说明

dbplus_aql ( string $query , string $server = ? , string $dbpath = ? ) : resource

Executes an AQL query on the given server and dbpath.

参数

query

The AQL query to be executed. Further information on the AQL (Algebraic Query Language) is provided in the original db++ manual.

server

dbpath

返回值

Returns a relation handle on success. The result data may be fetched from this relation by calling dbplus_next() and dbplus_curr(). Other relation access functions will not work on a result relation.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Get/Set database virtual current directory

  • ? dbplus_aql
  • dbplus_close ?
  • PHP Manual
  • DB++ 函数
  • Get/Set database virtual current directory

dbplus_chdir

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_chdir — Get/Set database virtual current directory

说明

dbplus_chdir ( string $newdir = ? ) : string

Changes the virtual current directory where relation files will be looked for by dbplus_open().

参数

newdir

The new directory for relation files. You can omit this parameter to query the current working directory.

返回值

Returns the absolute path of the current directory.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Close a relation

  • ? dbplus_chdir
  • dbplus_curr ?
  • PHP Manual
  • DB++ 函数
  • Close a relation

dbplus_close

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_close — Close a relation

说明

dbplus_close ( resource $relation ) : mixed

Closes a relation previously opened by dbplus_open().

参数

relation

A relation opened by dbplus_open().

返回值

Returns true on success or DBPLUS_ERR_UNKNOWN on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Get current tuple from relation

  • ? dbplus_close
  • dbplus_errcode ?
  • PHP Manual
  • DB++ 函数
  • Get current tuple from relation

dbplus_curr

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_curr — Get current tuple from relation

说明

dbplus_curr ( resource $relation , array &$tuple ) : int

Reads the data for the current tuple for the given relation.

参数

relation

A relation opened by dbplus_open().

tuple

The data will be passed back in this parameter, as an associative array.

返回值

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_first() - Get first tuple from relation
  • dbplus_prev() - Get previous tuple from relation
  • dbplus_next() - Get next tuple from relation
  • dbplus_last() - Get last tuple from relation
  • dbplus_errcode() - Get error string for given errorcode or last error


Get error string for given errorcode or last error

  • ? dbplus_curr
  • dbplus_errno ?
  • PHP Manual
  • DB++ 函数
  • Get error string for given errorcode or last error

dbplus_errcode

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_errcode — Get error string for given errorcode or last error

说明

dbplus_errcode ( int $errno = ? ) : string

Returns a clear error string for the given error code.

参数

errno

The error code. If not provided, the result code of the last db++ operation is assumed.

返回值

Returns the error message.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Get error code for last operation

  • ? dbplus_errcode
  • dbplus_find ?
  • PHP Manual
  • DB++ 函数
  • Get error code for last operation

dbplus_errno

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_errno — Get error code for last operation

说明

dbplus_errno ( ) : int

Returns the error code returned by the last db++ operation.

返回值

Returns the error code, as an integer.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_errcode() - Get error string for given errorcode or last error


Set a constraint on a relation

  • ? dbplus_errno
  • dbplus_first ?
  • PHP Manual
  • DB++ 函数
  • Set a constraint on a relation

dbplus_find

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_find — Set a constraint on a relation

说明

dbplus_find ( resource $relation , array $constraints , mixed $tuple ) : int

Places a constraint on the given relation.

Further calls to functions like dbplus_curr() or dbplus_next() will only return tuples matching the given constraints.

参数

relation

A relation opened by dbplus_open().

constraints

Constraints are triplets of strings containing of a domain name, a comparison operator and a comparison value. The constraints parameter array may consist of a collection of string arrays, each of which contains a domain, an operator and a value, or of a single string array containing a multiple of three elements.

The comparison operator may be one of the following strings: '==', '>', '>=', '<', '<=', '!=', '~' for a regular expression match and 'BAND' or 'BOR' for bitwise operations.

tuple

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_unselect() - Remove a constraint from relation


Get first tuple from relation

  • ? dbplus_find
  • dbplus_flush ?
  • PHP Manual
  • DB++ 函数
  • Get first tuple from relation

dbplus_first

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_first — Get first tuple from relation

说明

dbplus_first ( resource $relation , array &$tuple ) : int

Reads the data for the first tuple for the given relation, makes it the current tuple and pass it back as an associative array in tuple.

参数

relation

A relation opened by dbplus_open().

tuple

返回值

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Get previous tuple from relation
  • dbplus_next() - Get next tuple from relation
  • dbplus_last() - Get last tuple from relation
  • dbplus_errcode() - Get error string for given errorcode or last error


Flush all changes made on a relation

  • ? dbplus_first
  • dbplus_freealllocks ?
  • PHP Manual
  • DB++ 函数
  • Flush all changes made on a relation

dbplus_flush

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_flush — Flush all changes made on a relation

说明

dbplus_flush ( resource $relation ) : int

Writes all changes applied to relation since the last flush to disk.

参数

relation

A relation opened by dbplus_open().

返回值

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_errcode() - Get error string for given errorcode or last error


Free all locks held by this client

  • ? dbplus_flush
  • dbplus_freelock ?
  • PHP Manual
  • DB++ 函数
  • Free all locks held by this client

dbplus_freealllocks

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_freealllocks — Free all locks held by this client

说明

dbplus_freealllocks ( ) : int

Frees all tuple locks held by this client.

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_getlock() - Get a write lock on a tuple
  • dbplus_freelock() - Release write lock on tuple
  • dbplus_freerlocks() - Free all tuple locks on given relation


Release write lock on tuple

  • ? dbplus_freealllocks
  • dbplus_freerlocks ?
  • PHP Manual
  • DB++ 函数
  • Release write lock on tuple

dbplus_freelock

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_freelock — Release write lock on tuple

说明

dbplus_freelock ( resource $relation , string $tuple ) : int

Releases a write lock on the given tuple previously obtained by dbplus_getlock().

参数

relation

A relation opened by dbplus_open().

tuple

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_getlock() - Get a write lock on a tuple
  • dbplus_freerlocks() - Free all tuple locks on given relation
  • dbplus_freealllocks() - Free all locks held by this client


Free all tuple locks on given relation

  • ? dbplus_freelock
  • dbplus_getlock ?
  • PHP Manual
  • DB++ 函数
  • Free all tuple locks on given relation

dbplus_freerlocks

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_freerlocks — Free all tuple locks on given relation

说明

dbplus_freerlocks ( resource $relation ) : int

Frees all tuple locks held on the given relation.

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_getlock() - Get a write lock on a tuple
  • dbplus_freelock() - Release write lock on tuple
  • dbplus_freealllocks() - Free all locks held by this client


Get a write lock on a tuple

  • ? dbplus_freerlocks
  • dbplus_getunique ?
  • PHP Manual
  • DB++ 函数
  • Get a write lock on a tuple

dbplus_getlock

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_getlock — Get a write lock on a tuple

说明

dbplus_getlock ( resource $relation , string $tuple ) : int

Requests a write lock on the specified tuple.

参数

relation

A relation opened by dbplus_open().

tuple

返回值

Returns zero on success or a non-zero error code, especially DBPLUS_ERR_WLOCKED on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_freelock() - Release write lock on tuple
  • dbplus_freerlocks() - Free all tuple locks on given relation
  • dbplus_freealllocks() - Free all locks held by this client


Get an id number unique to a relation

  • ? dbplus_getlock
  • dbplus_info ?
  • PHP Manual
  • DB++ 函数
  • Get an id number unique to a relation

dbplus_getunique

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_getunique — Get an id number unique to a relation

说明

dbplus_getunique ( resource $relation , int $uniqueid ) : int

Obtains a number guaranteed to be unique for the given relation and will pass it back in the variable given as uniqueid.

参数

relation

A relation opened by dbplus_open().

uniqueid

返回值

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Get information about a relation

  • ? dbplus_getunique
  • dbplus_last ?
  • PHP Manual
  • DB++ 函数
  • Get information about a relation

dbplus_info

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_info — Get information about a relation

说明

dbplus_info ( resource $relation , string $key , array &$result ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

relation

A relation opened by dbplus_open().

key

result

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Get last tuple from relation

  • ? dbplus_info
  • dbplus_lockrel ?
  • PHP Manual
  • DB++ 函数
  • Get last tuple from relation

dbplus_last

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_last — Get last tuple from relation

说明

dbplus_last ( resource $relation , array &$tuple ) : int

Reads the data for the last tuple for the given relation, makes it the current tuple and pass it back as an associative array in tuple.

参数

relation

A relation opened by dbplus_open().

tuple

返回值

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_first() - Get first tuple from relation
  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Get previous tuple from relation
  • dbplus_next() - Get next tuple from relation


Request write lock on relation

  • ? dbplus_last
  • dbplus_next ?
  • PHP Manual
  • DB++ 函数
  • Request write lock on relation

dbplus_lockrel

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_lockrel — Request write lock on relation

说明

dbplus_lockrel ( resource $relation ) : int

Requests a write lock on the given relation.

Other clients may still query the relation, but can't alter it while it is locked.

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Get next tuple from relation

  • ? dbplus_lockrel
  • dbplus_open ?
  • PHP Manual
  • DB++ 函数
  • Get next tuple from relation

dbplus_next

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_next — Get next tuple from relation

说明

dbplus_next ( resource $relation , array &$tuple ) : int

Reads the data for the next tuple for the given relation, makes it the current tuple and will pass it back as an associative array in tuple.

参数

relation

A relation opened by dbplus_open().

tuple

返回值

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_first() - Get first tuple from relation
  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Get previous tuple from relation
  • dbplus_last() - Get last tuple from relation


Open relation file

  • ? dbplus_next
  • dbplus_prev ?
  • PHP Manual
  • DB++ 函数
  • Open relation file

dbplus_open

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_open — Open relation file

说明

dbplus_open ( string $name ) : resource

Opens the given relation file.

参数

name

Can be either a file name or a relative or absolute path name. This will be mapped in any case to an absolute relation file path on a specific host machine and server.

返回值

On success a relation file resource (cursor) is returned which must be used in any subsequent commands referencing the relation. Failure leads to a zero return value, the actual error code may be asked for by calling dbplus_errno().

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Get previous tuple from relation

  • ? dbplus_open
  • dbplus_rchperm ?
  • PHP Manual
  • DB++ 函数
  • Get previous tuple from relation

dbplus_prev

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_prev — Get previous tuple from relation

说明

dbplus_prev ( resource $relation , array &$tuple ) : int

Reads the data for the previous tuple for the given relation, makes it the current tuple and will pass it back as an associative array in tuple.

参数

relation

A relation opened by dbplus_open().

tuple

返回值

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_first() - Get first tuple from relation
  • dbplus_curr() - Get current tuple from relation
  • dbplus_next() - Get next tuple from relation
  • dbplus_last() - Get last tuple from relation


Change relation permissions

  • ? dbplus_prev
  • dbplus_rcreate ?
  • PHP Manual
  • DB++ 函数
  • Change relation permissions

dbplus_rchperm

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rchperm — Change relation permissions

说明

dbplus_rchperm ( resource $relation , int $mask , string $user , string $group ) : int

Changes access permissions as specified by mask, user and group. The values for these are operating system specific.

参数

relation

A relation opened by dbplus_open().

mask

user

group

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Creates a new DB++ relation

  • ? dbplus_rchperm
  • dbplus_rcrtexact ?
  • PHP Manual
  • DB++ 函数
  • Creates a new DB++ relation

dbplus_rcreate

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rcreate — Creates a new DB++ relation

说明

dbplus_rcreate ( string $name , mixed $domlist , bool $overwrite = ? ) : resource

Creates a new relation. Any existing relation sharing the same name will be overwritten if the relation is currently not in use and overwrite is set to TRUE.

参数

name

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

This parameter should contain the domain specification for the new relation within an array of domain description strings. A domain description string consists of a domain name unique to this relation, a slash and a type specification character. See the db++ documentation, especially the dbcreate(1) manpage, for a description of available type specifiers and their meanings.

Note:

This function will also accept a string with space delimited domain description strings, but it is recommended to use an array

overwrite

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Creates an exact but empty copy of a relation including indices

  • ? dbplus_rcreate
  • dbplus_rcrtlike ?
  • PHP Manual
  • DB++ 函数
  • Creates an exact but empty copy of a relation including indices

dbplus_rcrtexact

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices

说明

dbplus_rcrtexact ( string $name , resource $relation , bool $overwrite = ? ) : mixed

dbplus_rcrtexact() will create an exact but empty copy of the given relation under a new name.

参数

name

relation

The copied relation, opened by dbplus_open().

overwrite

An existing relation by the same name will only be overwritten if this parameter is set to true and no other process is currently using the relation.

返回值

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Creates an empty copy of a relation with default indices

  • ? dbplus_rcrtexact
  • dbplus_resolve ?
  • PHP Manual
  • DB++ 函数
  • Creates an empty copy of a relation with default indices

dbplus_rcrtlike

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rcrtlike — Creates an empty copy of a relation with default indices

说明

dbplus_rcrtlike ( string $name , resource $relation , int $overwrite = ? ) : mixed

dbplus_rcrtexact() will create an empty copy of the given relation under a new name, but with default indices.

参数

name

relation

The copied relation, opened by dbplus_open().

overwrite

An existing relation by the same name will only be overwritten if this parameter is set to true and no other process is currently using the relation.

返回值

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Resolve host information for relation

  • ? dbplus_rcrtlike
  • dbplus_restorepos ?
  • PHP Manual
  • DB++ 函数
  • Resolve host information for relation

dbplus_resolve

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_resolve — Resolve host information for relation

说明

dbplus_resolve ( string $relation_name ) : array

dbplus_resolve() will try to resolve the given relation_name and find out internal server id, real hostname and the database path on this host.

参数

relation_name

The relation name.

返回值

Returns an array containing these values under the keys sid, host and host_path or false on error.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_tcl() - Execute TCL code on server side


Restore position

  • ? dbplus_resolve
  • dbplus_rkeys ?
  • PHP Manual
  • DB++ 函数
  • Restore position

dbplus_restorepos

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_restorepos — Restore position

说明

dbplus_restorepos ( resource $relation , array $tuple ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

relation

A relation opened by dbplus_open().

tuple

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Specify new primary key for a relation

  • ? dbplus_restorepos
  • dbplus_ropen ?
  • PHP Manual
  • DB++ 函数
  • Specify new primary key for a relation

dbplus_rkeys

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rkeys — Specify new primary key for a relation

说明

dbplus_rkeys ( resource $relation , mixed $domlist ) : mixed

dbplus_rkeys() will replace the current primary key for relation with the combination of domains specified by domlist.

参数

relation

A relation opened by dbplus_open().

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

返回值

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Open relation file local

  • ? dbplus_rkeys
  • dbplus_rquery ?
  • PHP Manual
  • DB++ 函数
  • Open relation file local

dbplus_ropen

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_ropen — Open relation file local

说明

dbplus_ropen ( string $name ) : resource

dbplus_ropen() will open the relation file locally for quick access without any client/server overhead. Access is read only and only dbplus_curr() and dbplus_next() may be applied to the returned relation.

参数

name

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Perform local (raw) AQL query

  • ? dbplus_ropen
  • dbplus_rrename ?
  • PHP Manual
  • DB++ 函数
  • Perform local (raw) AQL query

dbplus_rquery

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rquery — Perform local (raw) AQL query

说明

dbplus_rquery ( string $query , string $dbpath = ? ) : resource

dbplus_rquery() performs a local (raw) AQL query using an AQL interpreter embedded into the db++ client library. dbplus_rquery() is faster than dbplus_aql() but will work on local data only.

参数

query

dbpath

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Rename a relation

  • ? dbplus_rquery
  • dbplus_rsecindex ?
  • PHP Manual
  • DB++ 函数
  • Rename a relation

dbplus_rrename

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rrename — Rename a relation

说明

dbplus_rrename ( resource $relation , string $name ) : int

dbplus_rrename() will change the name of relation to name.

参数

relation

A relation opened by dbplus_open().

name

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Create a new secondary index for a relation

  • ? dbplus_rrename
  • dbplus_runlink ?
  • PHP Manual
  • DB++ 函数
  • Create a new secondary index for a relation

dbplus_rsecindex

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rsecindex — Create a new secondary index for a relation

说明

dbplus_rsecindex ( resource $relation , mixed $domlist , int $type ) : mixed

dbplus_rsecindex() will create a new secondary index for relation with consists of the domains specified by domlist and is of type type

参数

relation

A relation opened by dbplus_open().

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

type

返回值

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Remove relation from filesystem

  • ? dbplus_rsecindex
  • dbplus_rzap ?
  • PHP Manual
  • DB++ 函数
  • Remove relation from filesystem

dbplus_runlink

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_runlink — Remove relation from filesystem

说明

dbplus_runlink ( resource $relation ) : int

dbplus_runlink() will close and remove the relation.

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Remove all tuples from relation

  • ? dbplus_runlink
  • dbplus_savepos ?
  • PHP Manual
  • DB++ 函数
  • Remove all tuples from relation

dbplus_rzap

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_rzap — Remove all tuples from relation

说明

dbplus_rzap ( resource $relation ) : int

dbplus_rzap() will remove all tuples from relation.

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Save position

  • ? dbplus_rzap
  • dbplus_setindex ?
  • PHP Manual
  • DB++ 函数
  • Save position

dbplus_savepos

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_savepos — Save position

说明

dbplus_savepos ( resource $relation ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Set index

  • ? dbplus_savepos
  • dbplus_setindexbynumber ?
  • PHP Manual
  • DB++ 函数
  • Set index

dbplus_setindex

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_setindex — Set index

说明

dbplus_setindex ( resource $relation , string $idx_name ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

relation

A relation opened by dbplus_open().

idx_name

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Set index by number

  • ? dbplus_setindex
  • dbplus_sql ?
  • PHP Manual
  • DB++ 函数
  • Set index by number

dbplus_setindexbynumber

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_setindexbynumber — Set index by number

说明

dbplus_setindexbynumber ( resource $relation , int $idx_number ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

relation

A relation opened by dbplus_open().

idx_number

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Perform SQL query

  • ? dbplus_setindexbynumber
  • dbplus_tcl ?
  • PHP Manual
  • DB++ 函数
  • Perform SQL query

dbplus_sql

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_sql — Perform SQL query

说明

dbplus_sql ( string $query , string $server = ? , string $dbpath = ? ) : resource
Warning

本函数还未编写文档，仅有参数列表。

参数

query

server

dbpath

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Execute TCL code on server side

  • ? dbplus_sql
  • dbplus_tremove ?
  • PHP Manual
  • DB++ 函数
  • Execute TCL code on server side

dbplus_tcl

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_tcl — Execute TCL code on server side

说明

dbplus_tcl ( int $sid , string $script ) : string

A db++ server will prepare a TCL interpreter for each client connection. This interpreter will enable the server to execute TCL code provided by the client as a sort of stored procedures to improve the performance of database operations by avoiding client/server data transfers and context switches.

dbplus_tcl() needs to pass the client connection id the TCL script code should be executed by. dbplus_resolve() will provide this connection id. The function will return whatever the TCL code returns or a TCL error message if the TCL code fails.

参数

sid

script

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_resolve() - Resolve host information for relation


Remove tuple and return new current tuple

  • ? dbplus_tcl
  • dbplus_undo ?
  • PHP Manual
  • DB++ 函数
  • Remove tuple and return new current tuple

dbplus_tremove

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_tremove — Remove tuple and return new current tuple

说明

dbplus_tremove ( resource $relation , array $tuple , array &$current = ? ) : int

dbplus_tremove() removes tuple from relation if it perfectly matches a tuple within the relation. current, if given, will contain the data of the new current tuple after calling dbplus_tremove().

参数

relation

A relation opened by dbplus_open().

tuple

current

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Undo

  • ? dbplus_tremove
  • dbplus_undoprepare ?
  • PHP Manual
  • DB++ 函数
  • Undo

dbplus_undo

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_undo — Undo

说明

dbplus_undo ( resource $relation ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Prepare undo

  • ? dbplus_undo
  • dbplus_unlockrel ?
  • PHP Manual
  • DB++ 函数
  • Prepare undo

dbplus_undoprepare

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_undoprepare — Prepare undo

说明

dbplus_undoprepare ( resource $relation ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Give up write lock on relation

  • ? dbplus_undoprepare
  • dbplus_unselect ?
  • PHP Manual
  • DB++ 函数
  • Give up write lock on relation

dbplus_unlockrel

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_unlockrel — Give up write lock on relation

说明

dbplus_unlockrel ( resource $relation ) : int

Release a write lock previously obtained by dbplus_lockrel().

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Remove a constraint from relation

  • ? dbplus_unlockrel
  • dbplus_update ?
  • PHP Manual
  • DB++ 函数
  • Remove a constraint from relation

dbplus_unselect

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_unselect — Remove a constraint from relation

说明

dbplus_unselect ( resource $relation ) : int

Calling dbplus_unselect() will remove a constraint previously set by dbplus_find() on relation.

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Update specified tuple in relation

  • ? dbplus_unselect
  • dbplus_xlockrel ?
  • PHP Manual
  • DB++ 函数
  • Update specified tuple in relation

dbplus_update

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_update — Update specified tuple in relation

说明

dbplus_update ( resource $relation , array $old , array $new ) : int

dbplus_update() replaces the old tuple with the data from the new one, only if the old completely matches a tuple within relation.

参数

relation

A relation opened by dbplus_open().

old

The old tuple.

new

The new tuple.

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Request exclusive lock on relation

  • ? dbplus_update
  • dbplus_xunlockrel ?
  • PHP Manual
  • DB++ 函数
  • Request exclusive lock on relation

dbplus_xlockrel

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_xlockrel — Request exclusive lock on relation

说明

dbplus_xlockrel ( resource $relation ) : int

Request an exclusive lock on relation preventing even read access from other clients.

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • dbplus_xunlockrel() - Free exclusive lock on relation


Free exclusive lock on relation

  • ? dbplus_xlockrel
  • dBase ?
  • PHP Manual
  • DB++ 函数
  • Free exclusive lock on relation

dbplus_xunlockrel

(PHP 4 <= 4.3.0, PECL dbplus >= 0.9)

dbplus_xunlockrel — Free exclusive lock on relation

说明

dbplus_xunlockrel ( resource $relation ) : int

Releases an exclusive lock previously obtained by dbplus_xlockrel().

参数

relation

A relation opened by dbplus_open().

返回值

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


dBase

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • dBase 函数
    • dbase_add_record — Adds a record to a database
    • dbase_close — Closes a database
    • dbase_create — Creates a database
    • dbase_delete_record — Deletes a record from a database
    • dbase_get_header_info — Gets the header info of a database
    • dbase_get_record_with_names — Gets a record from a database as an associative array
    • dbase_get_record — Gets a record from a database as an indexed array
    • dbase_numfields — Gets the number of fields of a database
    • dbase_numrecords — Gets the number of records in a database
    • dbase_open — Opens a database
    • dbase_pack — Packs a database
    • dbase_replace_record — Replaces a record in a database


简介

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.3.0.

These functions allow you to access records stored in dBase-format (dbf) databases.

Warning

We recommend against using dBase files as your production database. Use » SQLite or choose any real SQL server instead; » MySQL or » Postgres are common choices with PHP. dBase support is here to allow you to import and export data to and from your web database, because the file format is commonly understood by Windows spreadsheets and organizers.

Caution

As of dbase 7.0.0 the databases are automatically locked via flock(). There has been no support for locking earlier, so two concurrent web server processes modifying the same dBase file would have very likely ruined your database. This can happen even with dbase 7.0.0+ on systems which implement the locks at the process level with multithreaded SAPIs.

dBase files are simple sequential files of fixed length records. Records are appended to the end of the file and deleted records are kept until you call dbase_pack().

Only dbf file levels 3 (dBASE III+) - 5 (dBASE V) are supported. The types of dBase fields available are:

Available types of fields
Field | dBase Type | Format | Additional information
M | Memo | n/a | This type is not supported by PHP, such field will be ignored
D | Date | YYYYMMDD | The field length is limited to 8
T | DateTime | YYYYMMDDhhmmss.uuu | (FoxPro) No validity checks are done. Available as of dbase 7.0.0.
N | Number | A number | You must declare a length and a precision (the number of digits after the decimal point).
F | Float | A float number | Same as N. Available as of PHP 5.2.0
C | String | A string | You must declare a length. When retrieving data, the string will be right-padded with spaces to fit the declared length. Overlong strings will be silently truncated when storing data.
L | Boolean | T or Y for true, F or N for false, ? for uninitialized. | As of dbase 7.0.0, returned as a bool (true or false), or null for uninitialized fields. Formerly, returned as an int (1 or 0).

Note:

As of dbase 7.0.0 nullable fields are supported for DBASE_TYPE_FOXPRO databases. If a field is nullable, passing null will set the respective flag, and on later retrieval the field value will be null.

Note:

There is no support for indexes or memo fields.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/dbase.


资源类型

As of dbase 7.0.0, the resource type dbase is defined, which is returned by dbase_open() and dbase_create().


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

DBASE_VERSION (string)
The extension version. (Available as of dbase 7.0.0)
DBASE_RDONLY (int)
Open database for reading only. Used with dbase_open(). (Available as of dbase 7.0.0)
DBASE_RDWR (int)
Open database for reading and writing. Used with dbase_open(). (Available as of dbase 7.0.0)
DBASE_TYPE_DBASE (int)
Create dBASE style database. Used with dbase_create(). (Available as of dbase 7.0.0)
DBASE_TYPE_FOXPRO (int)
Create FoxPro style database. Used with dbase_create(). (Available as of dbase 7.0.0)


dBase 函数

范例

Many examples in this reference require a dBase database. We will use /tmp/test.dbf that will be created in the example of dbase_create().

Table of Contents

  • dbase_add_record — Adds a record to a database
  • dbase_close — Closes a database
  • dbase_create — Creates a database
  • dbase_delete_record — Deletes a record from a database
  • dbase_get_header_info — Gets the header info of a database
  • dbase_get_record_with_names — Gets a record from a database as an associative array
  • dbase_get_record — Gets a record from a database as an indexed array
  • dbase_numfields — Gets the number of fields of a database
  • dbase_numrecords — Gets the number of records in a database
  • dbase_open — Opens a database
  • dbase_pack — Packs a database
  • dbase_replace_record — Replaces a record in a database


Adds a record to a database

  • ? dBase 函数
  • dbase_close ?
  • PHP Manual
  • dBase 函数
  • Adds a record to a database

dbase_add_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_add_record — Adds a record to a database

说明

dbase_add_record ( resource $database , array $data ) : bool

Adds the given data to the database.

参数

database

The database resource, returned by dbase_open() or dbase_create().

data

An indexed array of data. The number of items must be equal to the number of fields in the database, otherwise dbase_add_record() will fail.

Note:

If you're using dbase_get_record() return value for this parameter, remember to reset the key named deleted.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

范例

Example #1 Inserting a record in a dBase database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  dbase_add_record($db, array(
      date('Ymd'),
      'Maxim Topolov',
      '23',
      'max@example.com',
      'T'));
  dbase_close($db);
}

?>

参见

  • dbase_delete_record() - Deletes a record from a database
  • dbase_replace_record() - Replaces a record in a database


Closes a database

  • ? dbase_add_record
  • dbase_create ?
  • PHP Manual
  • dBase 函数
  • Closes a database

dbase_close

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_close — Closes a database

说明

dbase_close ( resource $database ) : bool

Closes the given database resource.

参数

database

The database resource, returned by dbase_open() or dbase_create().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

范例

Example #1 Closing a dBase database file

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  // read some data ..

  dbase_close($db);
}

?>

参见

  • dbase_open() - Opens a database
  • dbase_create() - Creates a database


Creates a database

  • ? dbase_close
  • dbase_delete_record ?
  • PHP Manual
  • dBase 函数
  • Creates a database

dbase_create

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_create — Creates a database

说明

dbase_create ( string $path , array $fields , int $type = DBASE_TYPE_DBASE ) : resource

dbase_create() creates a dBase database with the given definition. If the file already exists, it is not truncated. dbase_pack() can be called to force truncation.

Note:

此函数受 open_basedir 影响。

参数

path

The path of the database. It can be a relative or absolute path to the file where dBase will store your data.

fields

An array of arrays, each array describing the format of one field of the database. Each field consists of a name, a character indicating the field type, and optionally, a length, a precision and a nullable flag. The supported field types are listed in the introduction section.

Note:

The fieldnames are limited in length and must not exceed 10 chars.

type

The type of database to be created. Either DBASE_TYPE_DBASE or DBASE_TYPE_FOXPRO.

返回值

Returns a database resource if the database is successfully created, or false if an error occurred.

更新日志

版本 | 说明
dbase 7.0.0 | The type parameter has been added.
dbase 7.0.0 | The return value is now a resource instead of an int.

范例

Example #1 Creating a dBase database file

<?php

// database "definition"
$def = array(
  array("date",     "D"),
  array("name",     "C",  50),
  array("age",      "N",   3, 0),
  array("email",    "C", 128),
  array("ismember", "L")
);

// creation
if (!dbase_create('/tmp/test.dbf', $def)) {
  echo "Error, can't create the database\n";
}

?>

参见

  • dbase_open() - Opens a database
  • dbase_close() - Closes a database


Deletes a record from a database

  • ? dbase_create
  • dbase_get_header_info ?
  • PHP Manual
  • dBase 函数
  • Deletes a record from a database

dbase_delete_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_delete_record — Deletes a record from a database

说明

dbase_delete_record ( resource $database , int $number ) : bool

Marks the given record to be deleted from the database.

Note:

To actually remove the record from the database, you must also call dbase_pack().

参数

database

The database resource, returned by dbase_open() or dbase_create().

number

An integer which spans from 1 to the number of records in the database (as returned by dbase_numrecords()).

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

参见

  • dbase_add_record() - Adds a record to a database
  • dbase_replace_record() - Replaces a record in a database


Gets the header info of a database

  • ? dbase_delete_record
  • dbase_get_record_with_names ?
  • PHP Manual
  • dBase 函数
  • Gets the header info of a database

dbase_get_header_info

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_header_info — Gets the header info of a database

说明

dbase_get_header_info ( resource $database ) : array

Returns information on the column structure of the given database resource.

参数

database

The database resource, returned by dbase_open() or dbase_create().

返回值

An indexed array with an entry for each column in the database. The array index starts at 0.

Each array element contains an associative array of column information, as described here:

name
The name of the column
type
The human-readable name for the dbase type of the column (i.e. date, boolean, etc.) The supported field types are listed in the introduction section.
length
The number of bytes this column can hold
precision
The number of digits of decimal precision for the column
format
A suggested printf() format specifier for the column
offset
The byte offset of the column from the start of the row

If the database header information cannot be read, false is returned.

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

范例

Example #1 Showing header information for a dBase database file

<?php
// Path to dbase file
$db_path = "/tmp/test.dbf";

// Open dbase file
$dbh = dbase_open($db_path, 0)
  or die("Error! Could not open dbase database file '$db_path'.");

// Get column information
$column_info = dbase_get_header_info($dbh);

// Display information
print_r($column_info);
?>


Gets a record from a database as an associative array

  • ? dbase_get_header_info
  • dbase_get_record ?
  • PHP Manual
  • dBase 函数
  • Gets a record from a database as an associative array

dbase_get_record_with_names

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_record_with_names — Gets a record from a database as an associative array

说明

dbase_get_record_with_names ( resource $database , int $number ) : array

Gets a record from a dBase database as an associative array.

参数

database

The database resource, returned by dbase_open() or dbase_create().

_number

The index of the record between 1 and dbase_numrecords($dbase_identifier).

返回值

An associative array with the record. This will also include a key named deleted which is set to 1 if the record has been marked for deletion (see dbase_delete_record()). Therefore it is not possible to retrieve the value of a field named deleted with this function.

每个字段都会被转换为对应的 PHP 类型，除了以下场景：

  • 日期会被转换成字符串。
  • DateTime 会被转换成字符串。
  • 范围之外的整数 PHP_INT_MIN..PHP_INT_MAX 将返回字符串。
  • dbase 7.0.0 之前的版本， 布尔型 (L) 将被转换为 1 或 0。

On error, dbase_get_record_with_names() will return false.

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

范例

Example #1 Listing all the registered members in the database

<?php
// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      $row = dbase_get_record_with_names($db, $i);
      if ($row['ismember'] == 1) {
          echo "Member #$i: " . trim($row['name']) . "\n";
      }
  }
}
?>

参见

  • dbase_get_record() - Gets a record from a database as an indexed array


Gets a record from a database as an indexed array

  • ? dbase_get_record_with_names
  • dbase_numfields ?
  • PHP Manual
  • dBase 函数
  • Gets a record from a database as an indexed array

dbase_get_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_record — Gets a record from a database as an indexed array

说明

dbase_get_record ( resource $database , int $number ) : array

Gets a record from a database as an indexed array.

参数

database

The database resource, returned by dbase_open() or dbase_create().

number

The index of the record between 1 and dbase_numrecords($dbase_identifier).

返回值

An indexed array with the record. This array will also include an associative key named deleted which is set to 1 if the record has been marked for deletion (see dbase_delete_record()).

每个字段都会被转换为对应的 PHP 类型，除了以下场景：

  • 日期会被转换成字符串。
  • DateTime 会被转换成字符串。
  • 范围之外的整数 PHP_INT_MIN..PHP_INT_MAX 将返回字符串。
  • dbase 7.0.0 之前的版本， 布尔型 (L) 将被转换为 1 或 0。

On error, dbase_get_record() will return false.

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

参见

  • dbase_get_record_with_names() - Gets a record from a database as an associative array


Gets the number of fields of a database

  • ? dbase_get_record
  • dbase_numrecords ?
  • PHP Manual
  • dBase 函数
  • Gets the number of fields of a database

dbase_numfields

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_numfields — Gets the number of fields of a database

说明

dbase_numfields ( resource $database ) : int

Gets the number of fields (columns) in the specified database.

Note:

Field numbers are between 0 and dbase_numfields($db)-1, while record numbers are between 1 and dbase_numrecords($db).

参数

database

The database resource, returned by dbase_open() or dbase_create().

返回值

The number of fields in the database, or false if an error occurs.

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

范例

Example #1 dbase_numfields() Example

<?php

$rec = dbase_get_record($db, $recno);
$nf  = dbase_numfields($db);
for ($i = 0; $i < $nf; $i++) {
  echo $rec[$i], "\n";
}

?>

参见

  • dbase_numrecords() - Gets the number of records in a database


Gets the number of records in a database

  • ? dbase_numfields
  • dbase_open ?
  • PHP Manual
  • dBase 函数
  • Gets the number of records in a database

dbase_numrecords

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_numrecords — Gets the number of records in a database

说明

dbase_numrecords ( resource $database ) : int

Gets the number of records (rows) in the specified database.

Note:

Records which are marked as deleted are counted as well.

Note:

Record numbers are between 1 and dbase_numrecords($db), while field numbers are between 0 and dbase_numfields($db)-1.

参数

database

The database resource, returned by dbase_open() or dbase_create().

返回值

The number of records in the database, or false if an error occurs.

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

范例

Example #1 Looping over all the records of the database

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      $record = dbase_get_record($db, $i);
      if (!$record['deleted']) {
          // do something with the $record
      } else {
          // do something with the deleted $record or ignore it
      }
  }
}

?>

参见

  • dbase_numfields() - Gets the number of fields of a database


Opens a database

  • ? dbase_numrecords
  • dbase_pack ?
  • PHP Manual
  • dBase 函数
  • Opens a database

dbase_open

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_open — Opens a database

说明

dbase_open ( string $path , int $mode ) : resource|false

dbase_open() opens a dBase database with the given access mode.

Note:

此函数受 open_basedir 影响。

参数

path

The path of the database. It can be a relative or absolute path to the file where dBase will store your data.

mode

An integer which correspond to those for the open() system call (Typically 0 means read-only, 1 means write-only, and 2 means read and write).

Note:

You can't open a dBase file in write-only mode as the function will fail to read the headers information and thus you can't use 1 as mode.

As of dbase 7.0.0 you can use DBASE_RDONLY and DBASE_RDWR, respectively, to specify the mode.

返回值

Returns a database resource on success, 或者在失败时返回 false.

更新日志

版本 | 说明
dbase 7.0.0 | The return value is now a resource instead of an int.

范例

Example #1 Opening a dBase database file

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  // read some data ..

  dbase_close($db);
}

?>

参见

  • dbase_create() - Creates a database
  • dbase_close() - Closes a database


Packs a database

  • ? dbase_open
  • dbase_replace_record ?
  • PHP Manual
  • dBase 函数
  • Packs a database

dbase_pack

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_pack — Packs a database

说明

dbase_pack ( resource $database ) : bool

Packs the specified database by permanently deleting all records marked for deletion using dbase_delete_record(). Note that the file will be truncated after successful packing (contrary to dBASE III's PACK command).

参数

database

The database resource, returned by dbase_open() or dbase_create().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

范例

Example #1 Emptying a dBase database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      dbase_delete_record($db, $i);
  }
  // expunge the database
  dbase_pack($db);
}

?>

参见

  • dbase_delete_record() - Deletes a record from a database


Replaces a record in a database

  • ? dbase_pack
  • filePro ?
  • PHP Manual
  • dBase 函数
  • Replaces a record in a database

dbase_replace_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_replace_record — Replaces a record in a database

说明

dbase_replace_record ( resource $database , array $data , int $number ) : bool

Replaces the given record in the database with the given data.

参数

database

The database resource, returned by dbase_open() or dbase_create().

data

An indexed array of data. The number of items must be equal to the number of fields in the database, otherwise dbase_replace_record() will fail.

Note:

If you're using dbase_get_record() return value for this parameter, remember to reset the key named deleted.

number

An integer which spans from 1 to the number of records in the database (as returned by dbase_numrecords()).

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
dbase 7.0.0 | database is now a resource instead of an int.

范例

Example #1 Updating a record in the database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  // gets the old row
  $row = dbase_get_record_with_names($db, 1);

  // remove the 'deleted' entry
  unset($row['deleted']);

  // Update the date field with the current timestamp
  $row['date'] = date('Ymd');

  // convert the row to an indexed array
  $row = array_values($row);

  // Replace the record
  dbase_replace_record($db, $row, 1);
  dbase_close($db);
}

?>

注释

Note:

Boolean fields result in an int element value (0 or 1) when retrieved via dbase_get_record() or dbase_get_record_with_names(). If they are written back, this results in the value becoming 0, so care has to be taken to properly adjust the values.

参见

  • dbase_add_record() - Adds a record to a database
  • dbase_delete_record() - Deletes a record from a database


filePro

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • filePro 函数
    • filepro_fieldcount — Find out how many fields are in a filePro database
    • filepro_fieldname — Gets the name of a field
    • filepro_fieldtype — Gets the type of a field
    • filepro_fieldwidth — Gets the width of a field
    • filepro_retrieve — Retrieves data from a filePro database
    • filepro_rowcount — Find out how many rows are in a filePro database
    • filepro — Read and verify the map file


简介

These functions allow read-only access to data stored in filePro databases.

filePro is a registered trademark of fP Technologies, Inc. You can find more information about filePro at » http://www.fptech.com/.

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.2.0.


安装

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.2.0

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/filepro.


  • ? 资源类型
  • filePro 函数 ?
  • PHP Manual
  • filePro
  • 预定义常量

预定义常量

此扩展没有定义常量。


filePro 函数

Table of Contents

  • filepro_fieldcount — Find out how many fields are in a filePro database
  • filepro_fieldname — Gets the name of a field
  • filepro_fieldtype — Gets the type of a field
  • filepro_fieldwidth — Gets the width of a field
  • filepro_retrieve — Retrieves data from a filePro database
  • filepro_rowcount — Find out how many rows are in a filePro database
  • filepro — Read and verify the map file


Find out how many fields are in a filePro database

  • ? filePro 函数
  • filepro_fieldname ?
  • PHP Manual
  • filePro 函数
  • Find out how many fields are in a filePro database

filepro_fieldcount

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_fieldcount — Find out how many fields are in a filePro database

说明

filepro_fieldcount ( ) : int

Returns the number of fields (columns) in the opened filePro database.

返回值

Returns the number of fields in the opened filePro database, or false on errors.

参见

  • filepro() - Read and verify the map file


Gets the name of a field

  • ? filepro_fieldcount
  • filepro_fieldtype ?
  • PHP Manual
  • filePro 函数
  • Gets the name of a field

filepro_fieldname

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_fieldname — Gets the name of a field

说明

filepro_fieldname ( int $field_number ) : string

Returns the name of the field corresponding to field_number.

参数

field_number

The field number.

返回值

Returns the name of the field as a string, or false on errors.


Gets the type of a field

  • ? filepro_fieldname
  • filepro_fieldwidth ?
  • PHP Manual
  • filePro 函数
  • Gets the type of a field

filepro_fieldtype

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_fieldtype — Gets the type of a field

说明

filepro_fieldtype ( int $field_number ) : string

Returns the edit type of the field corresponding to field_number.

参数

field_number

The field number.

返回值

Returns the edit type of the field as a string, or false on errors.


Gets the width of a field

  • ? filepro_fieldtype
  • filepro_retrieve ?
  • PHP Manual
  • filePro 函数
  • Gets the width of a field

filepro_fieldwidth

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_fieldwidth — Gets the width of a field

说明

filepro_fieldwidth ( int $field_number ) : int

Returns the width of the field corresponding to field_number.

参数

field_number

The field number.

返回值

Returns the width of the field as a integer, or false on errors.


Retrieves data from a filePro database

  • ? filepro_fieldwidth
  • filepro_rowcount ?
  • PHP Manual
  • filePro 函数
  • Retrieves data from a filePro database

filepro_retrieve

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_retrieve — Retrieves data from a filePro database

说明

filepro_retrieve ( int $row_number , int $field_number ) : string

Returns the data from the specified location in the database.

参数

row_number

The row number. Must be between zero and the total number of rows minus one (0..filepro_rowcount() - 1)

field_number

The field number. Accepts values between zero and the total number of fields minus one (0..filepro_fieldcount() - 1)

返回值

Returns the specified data, or false on errors.


Find out how many rows are in a filePro database

  • ? filepro_retrieve
  • filepro ?
  • PHP Manual
  • filePro 函数
  • Find out how many rows are in a filePro database

filepro_rowcount

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro_rowcount — Find out how many rows are in a filePro database

说明

filepro_rowcount ( ) : int

Returns the number of rows in the opened filePro database.

返回值

Returns the number of rows in the opened filePro database, or false on errors.

参见

  • filepro() - Read and verify the map file


Read and verify the map file

  • ? filepro_rowcount
  • Firebird/InterBase ?
  • PHP Manual
  • filePro 函数
  • Read and verify the map file

filepro

(PHP 4, PHP 5 < 5.2.0, PECL filepro SVN)

filepro — Read and verify the map file

说明

filepro ( string $directory ) : bool

This reads and verifies the map file, storing the field count and info.

No locking is done, so you should avoid modifying your filePro database while it may be opened in PHP.

参数

directory

The map directory.

返回值

成功时返回 true， 或者在失败时返回 false。


Firebird/InterBase

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Firebird/InterBase 函数
    • fbird_add_user — 别名 ibase_add_user
    • fbird_affected_rows — 别名 ibase_affected_rows
    • fbird_backup — 别名 ibase_backup
    • fbird_blob_add — 别名 ibase_blob_add
    • fbird_blob_cancel — Cancel creating blob
    • fbird_blob_close — 别名 ibase_blob_close
    • fbird_blob_create — 别名 ibase_blob_create
    • fbird_blob_echo — 别名 ibase_blob_echo
    • fbird_blob_get — 别名 ibase_blob_get
    • fbird_blob_import — 别名 ibase_blob_import
    • fbird_blob_info — 别名 ibase_blob_info
    • fbird_blob_open — 别名 ibase_blob_open
    • fbird_close — 别名 ibase_close
    • fbird_commit_ret — 别名 ibase_commit_ret
    • fbird_commit — 别名 ibase_commit
    • fbird_connect — 别名 ibase_connect
    • fbird_db_info — 别名 ibase_db_info
    • fbird_delete_user — 别名 ibase_delete_user
    • fbird_drop_db — 别名 ibase_drop_db
    • fbird_errcode — 别名 ibase_errcode
    • fbird_errmsg — 别名 ibase_errmsg
    • fbird_execute — 别名 ibase_execute
    • fbird_fetch_assoc — 别名 ibase_fetch_assoc
    • fbird_fetch_object — 别名 ibase_fetch_object
    • fbird_fetch_row — 别名 ibase_fetch_row
    • fbird_field_info — 别名 ibase_field_info
    • fbird_free_event_handler — 别名 ibase_free_event_handler
    • fbird_free_query — 别名 ibase_free_query
    • fbird_free_result — 别名 ibase_free_result
    • fbird_gen_id — 别名 ibase_gen_id
    • fbird_maintain_db — 别名 ibase_maintain_db
    • fbird_modify_user — 别名 ibase_modify_user
    • fbird_name_result — 别名 ibase_name_result
    • fbird_num_fields — 别名 ibase_num_fields
    • fbird_num_params — 别名 ibase_num_params
    • fbird_param_info — 别名 ibase_param_info
    • fbird_pconnect — 别名 ibase_pconnect
    • fbird_prepare — 别名 ibase_prepare
    • fbird_query — 别名 ibase_query
    • fbird_restore — 别名 ibase_restore
    • fbird_rollback_ret — 别名 ibase_rollback_ret
    • fbird_rollback — 别名 ibase_rollback
    • fbird_server_info — 别名 ibase_server_info
    • fbird_service_attach — 别名 ibase_service_attach
    • fbird_service_detach — 别名 ibase_service_detach
    • fbird_set_event_handler — 别名 ibase_set_event_handler
    • fbird_trans — 别名 ibase_trans
    • fbird_wait_event — 别名 ibase_wait_event
    • ibase_add_user — Add a user to a security database
    • ibase_affected_rows — Return the number of rows that were affected by the previous query
    • ibase_backup — Initiates a backup task in the service manager and returns immediately
    • ibase_blob_add — Add data into a newly created blob
    • ibase_blob_cancel — Cancel creating blob
    • ibase_blob_close — Close blob
    • ibase_blob_create — Create a new blob for adding data
    • ibase_blob_echo — Output blob contents to browser
    • ibase_blob_get — Get len bytes data from open blob
    • ibase_blob_import — Create blob, copy file in it, and close it
    • ibase_blob_info — Return blob length and other useful info
    • ibase_blob_open — Open blob for retrieving data parts
    • ibase_close — Close a connection to an InterBase database
    • ibase_commit_ret — Commit a transaction without closing it
    • ibase_commit — Commit a transaction
    • ibase_connect — Open a connection to a database
    • ibase_db_info — Request statistics about a database
    • ibase_delete_user — Delete a user from a security database
    • ibase_drop_db — Drops a database
    • ibase_errcode — Return an error code
    • ibase_errmsg — Return error messages
    • ibase_execute — Execute a previously prepared query
    • ibase_fetch_assoc — Fetch a result row from a query as an associative array
    • ibase_fetch_object — Get an object from a InterBase database
    • ibase_fetch_row — Fetch a row from an InterBase database
    • ibase_field_info — Get information about a field
    • ibase_free_event_handler — Cancels a registered event handler
    • ibase_free_query — Free memory allocated by a prepared query
    • ibase_free_result — Free a result set
    • ibase_gen_id — Increments the named generator and returns its new value
    • ibase_maintain_db — Execute a maintenance command on the database server
    • ibase_modify_user — Modify a user to a security database
    • ibase_name_result — Assigns a name to a result set
    • ibase_num_fields — Get the number of fields in a result set
    • ibase_num_params — Return the number of parameters in a prepared query
    • ibase_param_info — Return information about a parameter in a prepared query
    • ibase_pconnect — Open a persistent connection to an InterBase database
    • ibase_prepare — Prepare a query for later binding of parameter placeholders and execution
    • ibase_query — Execute a query on an InterBase database
    • ibase_restore — Initiates a restore task in the service manager and returns immediately
    • ibase_rollback_ret — Roll back a transaction without closing it
    • ibase_rollback — Roll back a transaction
    • ibase_server_info — Request information about a database server
    • ibase_service_attach — Connect to the service manager
    • ibase_service_detach — Disconnect from the service manager
    • ibase_set_event_handler — Register a callback function to be called when events are posted
    • ibase_trans — Begin a transaction
    • ibase_wait_event — Wait for an event to be posted by the database


简介

Firebird is a relational database offering many ISO SQL-2003 features that runs on Linux, Windows, and a variety of Unix platforms. Firebird offers excellent concurrency, high performance, and powerful language support for stored procedures and triggers. It has been used in production systems, under a variety of names since 1981.

InterBase is the name of the closed-source variant of this RDBMS that was developed by Embarcadero/Inprise. More information about InterBase is available at » http://www.embarcadero.com/products/interbase.

Firebird is a commercially independent project (fundation) of C++ programmers, technical advisors and supporters developing and enhancing a multi-platform relational database management system based on the source code released by Inprise Corp (now known as Embarcadero) under the InterBase Public License v.1.0 on 25 July, 2000. More information about Firebird is available at » http://www.firebirdsql.org/.

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。7.4.0

This extension supports InterBase versions 6 and up and Firebird version 2.0 and up.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Firebird/InterBase
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。7.4.0

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ibase.

To enable Firebird/InterBase support configure PHP --with-interbase[=DIR], where DIR is the Firebird/InterBase base install directory, which defaults to /usr.

Note: Note to Win32/Win64 Users

为了使此扩展生效， DLL 文件必须能在 Windows 系统的 PATH 指示的路径下找到。如何操作的信息，请参见题为"如何在 Windows 中将 PHP 目录加到 PATH 中"的FAQ。虽然将 DLL 文件从 PHP 文件夹复制到 Windows 系统目录也行，但不建议这样做。 此扩展需要下列文件在 PATH 路径中： fbclient.dll,gds32.dll

If you installed the Firebird/InterBase database server on the same machine PHP is running on, you will have this DLL already and fbclient.dll,gds32.dll (gds32.dll is generated from the installer for legacy applications) will already be in the PATH.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

InterBase configuration options
名字 | 默认 | 可修改范围 | 更新日志
ibase.allow_persistent | "1" | PHP_INI_SYSTEM |
ibase.max_persistent | "-1" | PHP_INI_SYSTEM |
ibase.max_links | "-1" | PHP_INI_SYSTEM |
ibase.default_db | NULL | PHP_INI_SYSTEM |
ibase.default_user | NULL | PHP_INI_ALL |
ibase.default_password | NULL | PHP_INI_ALL |
ibase.default_charset | NULL | PHP_INI_ALL |
ibase.timestampformat | "%Y-%m-%d %H:%M:%S" | PHP_INI_ALL |
ibase.dateformat | "%Y-%m-%d" | PHP_INI_ALL |
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

ibase.allow_persistent bool

Whether to allow persistent connections to Firebird/InterBase.

ibase.max_persistent int

The maximum number of persistent Firebird/InterBase connections per process. New connections created with ibase_pconnect() will be non-persistent if this number would be exceeded.

ibase.max_links int

The maximum number of Firebird/InterBase connections per process, including persistent connections.

ibase.default_db string

The default database to connect to when ibase_[p]connect() is called without specifying a database name. If this value is set and SQL safe mode is enabled, no other connections than to this database will be allowed.

ibase.default_user string

The user name to use when connecting to a database if no user name is specified.

ibase.default_password string

The password to use when connecting to a database if no password is specified.

ibase.default_charset string

The character set to use when connecting to a database if no character set is specified.

ibase.timestampformat string

ibase.dateformat string

ibase.timeformat string

These directives are used to set the date and time formats that are used when returning dates and times from a result set, or when binding arguments to date and time parameters.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

The following constants can be passed to ibase_trans() to specify transaction behaviour.

Firebird/InterBase transaction flags
Constant | Description
IBASE_DEFAULT | The default transaction settings are to be used. This default is determined by the client library, which defines it as IBASE_WRITE|IBASE_CONCURRENCY|IBASE_WAIT in most cases.
IBASE_READ | Starts a read-only transaction.
IBASE_WRITE | Starts a read-write transaction.
IBASE_CONSISTENCY | Starts a transaction with the isolation level set to 'consistency', which means the transaction cannot read from tables that are being modified by other concurrent transactions.
IBASE_CONCURRENCY | Starts a transaction with the isolation level set to 'concurrency' (or 'snapshot'), which means the transaction has access to all tables, but cannot see changes that were committed by other transactions after the transaction was started.
IBASE_COMMITTED | Starts a transaction with the isolation level set to 'read committed'. This flag should be combined with either IBASE_REC_VERSION or IBASE_REC_NO_VERSION. This isolation level allows access to changes that were committed after the transaction was started. If IBASE_REC_NO_VERSION was specified, only the latest version of a row can be read. If IBASE_REC_VERSION was specified, a row can even be read when a modification to it is pending in a concurrent transaction.
IBASE_WAIT | Indicated that a transaction should wait and retry when a conflict occurs.
IBASE_NOWAIT | Indicated that a transaction should fail immediately when a conflict occurs.

The following constants can be passed to ibase_fetch_row(), ibase_fetch_assoc() or ibase_fetch_object() to specify fetch behaviour.

Firebird/InterBase fetch flags
Constant | Description
IBASE_FETCH_BLOBS | Also available as IBASE_TEXTfor backward compatibility. Causes BLOB contents to be fetched inline, instead of being fetched as BLOB identifiers.
IBASE_FETCH_ARRAYS | Causes arrays to be fetched inline. Otherwise, array identifiers are returned. Array identifiers can only be used as arguments to INSERT operations, as no functions to handle array identifiers are currently available.
IBASE_UNIXTIME | Causes date and time fields not to be returned as strings, but as UNIX timestamps (the number of seconds since the epoch, which is 1-Jan-1970 0:00 UTC). Might be problematic if used with dates before 1970 on some systems.

The following constants are used to pass requests and options to the service
API functions (ibase_server_info(), ibase_db_info(),
ibase_backup(), ibase_restore()
and ibase_maintain_db()). Please refer to
the Firebird/InterBase manuals for the meaning of these options.

IBASE_BKP_IGNORE_CHECKSUMS
Options to ibase_backup()
IBASE_BKP_IGNORE_LIMBO
Options to ibase_backup()
IBASE_BKP_METADATA_ONLY
Options to ibase_backup()
IBASE_BKP_NO_GARBAGE_COLLECT
Options to ibase_backup()
IBASE_BKP_OLD_DESCRIPTIONS
Options to ibase_backup()
IBASE_BKP_NON_TRANSPORTABLE
Options to ibase_backup()
IBASE_BKP_CONVERT
Options to ibase_backup()
IBASE_RES_DEACTIVATE_IDX
Options to ibase_restore()
IBASE_RES_NO_SHADOW
Options to ibase_restore()
IBASE_RES_NO_VALIDITY
Options to ibase_restore()
IBASE_RES_ONE_AT_A_TIME
Options to ibase_restore()
IBASE_RES_REPLACE
IBASE_RES_CREATE
Options to ibase_restore()
IBASE_RES_USE_ALL_SPACE
Options to ibase_restore()
IBASE_PRP_PAGE_BUFFERS
IBASE_PRP_SWEEP_INTERVAL
IBASE_PRP_SHUTDOWN_DB
IBASE_PRP_DENY_NEW_TRANSACTIONS
IBASE_PRP_DENY_NEW_ATTACHMENTS
IBASE_PRP_RESERVE_SPACE
IBASE_PRP_RES_USE_FULL
IBASE_PRP_RES
IBASE_PRP_WRITE_MODE
IBASE_PRP_WM_ASYNC
IBASE_PRP_WM_SYNC
IBASE_PRP_ACCESS_MODE
IBASE_PRP_AM_READONLY
IBASE_PRP_AM_READWRITE
IBASE_PRP_SET_SQL_DIALECT
IBASE_PRP_ACTIVATE
IBASE_PRP_DB_ONLINE
IBASE_RPR_CHECK_DB
IBASE_RPR_IGNORE_CHECKSUM
IBASE_RPR_KILL_SHADOWS
IBASE_RPR_MEND_DB
IBASE_RPR_VALIDATE_DB
IBASE_RPR_FULL
IBASE_RPR_SWEEP_DB
Options to ibase_maintain_db()
IBASE_STS_DATA_PAGES
IBASE_STS_DB_LOG
IBASE_STS_HDR_PAGES
IBASE_STS_IDX_PAGES
IBASE_STS_SYS_RELATIONS
Options to ibase_db_info()
IBASE_SVC_SERVER_VERSION
Options to ibase_server_info()
IBASE_SVC_IMPLEMENTATION
Options to ibase_server_info()
IBASE_SVC_GET_ENV
Options to ibase_server_info()
IBASE_SVC_GET_ENV_LOCK
IBASE_SVC_GET_ENV_MSG
IBASE_SVC_USER_DBPATH
IBASE_SVC_SVR_DB_INFO
IBASE_SVC_GET_USERS
Options to ibase_server_info()


Firebird/InterBase 函数

Table of Contents

  • fbird_add_user — 别名 ibase_add_user
  • fbird_affected_rows — 别名 ibase_affected_rows
  • fbird_backup — 别名 ibase_backup
  • fbird_blob_add — 别名 ibase_blob_add
  • fbird_blob_cancel — Cancel creating blob
  • fbird_blob_close — 别名 ibase_blob_close
  • fbird_blob_create — 别名 ibase_blob_create
  • fbird_blob_echo — 别名 ibase_blob_echo
  • fbird_blob_get — 别名 ibase_blob_get
  • fbird_blob_import — 别名 ibase_blob_import
  • fbird_blob_info — 别名 ibase_blob_info
  • fbird_blob_open — 别名 ibase_blob_open
  • fbird_close — 别名 ibase_close
  • fbird_commit_ret — 别名 ibase_commit_ret
  • fbird_commit — 别名 ibase_commit
  • fbird_connect — 别名 ibase_connect
  • fbird_db_info — 别名 ibase_db_info
  • fbird_delete_user — 别名 ibase_delete_user
  • fbird_drop_db — 别名 ibase_drop_db
  • fbird_errcode — 别名 ibase_errcode
  • fbird_errmsg — 别名 ibase_errmsg
  • fbird_execute — 别名 ibase_execute
  • fbird_fetch_assoc — 别名 ibase_fetch_assoc
  • fbird_fetch_object — 别名 ibase_fetch_object
  • fbird_fetch_row — 别名 ibase_fetch_row
  • fbird_field_info — 别名 ibase_field_info
  • fbird_free_event_handler — 别名 ibase_free_event_handler
  • fbird_free_query — 别名 ibase_free_query
  • fbird_free_result — 别名 ibase_free_result
  • fbird_gen_id — 别名 ibase_gen_id
  • fbird_maintain_db — 别名 ibase_maintain_db
  • fbird_modify_user — 别名 ibase_modify_user
  • fbird_name_result — 别名 ibase_name_result
  • fbird_num_fields — 别名 ibase_num_fields
  • fbird_num_params — 别名 ibase_num_params
  • fbird_param_info — 别名 ibase_param_info
  • fbird_pconnect — 别名 ibase_pconnect
  • fbird_prepare — 别名 ibase_prepare
  • fbird_query — 别名 ibase_query
  • fbird_restore — 别名 ibase_restore
  • fbird_rollback_ret — 别名 ibase_rollback_ret
  • fbird_rollback — 别名 ibase_rollback
  • fbird_server_info — 别名 ibase_server_info
  • fbird_service_attach — 别名 ibase_service_attach
  • fbird_service_detach — 别名 ibase_service_detach
  • fbird_set_event_handler — 别名 ibase_set_event_handler
  • fbird_trans — 别名 ibase_trans
  • fbird_wait_event — 别名 ibase_wait_event
  • ibase_add_user — Add a user to a security database
  • ibase_affected_rows — Return the number of rows that were affected by the previous query
  • ibase_backup — Initiates a backup task in the service manager and returns immediately
  • ibase_blob_add — Add data into a newly created blob
  • ibase_blob_cancel — Cancel creating blob
  • ibase_blob_close — Close blob
  • ibase_blob_create — Create a new blob for adding data
  • ibase_blob_echo — Output blob contents to browser
  • ibase_blob_get — Get len bytes data from open blob
  • ibase_blob_import — Create blob, copy file in it, and close it
  • ibase_blob_info — Return blob length and other useful info
  • ibase_blob_open — Open blob for retrieving data parts
  • ibase_close — Close a connection to an InterBase database
  • ibase_commit_ret — Commit a transaction without closing it
  • ibase_commit — Commit a transaction
  • ibase_connect — Open a connection to a database
  • ibase_db_info — Request statistics about a database
  • ibase_delete_user — Delete a user from a security database
  • ibase_drop_db — Drops a database
  • ibase_errcode — Return an error code
  • ibase_errmsg — Return error messages
  • ibase_execute — Execute a previously prepared query
  • ibase_fetch_assoc — Fetch a result row from a query as an associative array
  • ibase_fetch_object — Get an object from a InterBase database
  • ibase_fetch_row — Fetch a row from an InterBase database
  • ibase_field_info — Get information about a field
  • ibase_free_event_handler — Cancels a registered event handler
  • ibase_free_query — Free memory allocated by a prepared query
  • ibase_free_result — Free a result set
  • ibase_gen_id — Increments the named generator and returns its new value
  • ibase_maintain_db — Execute a maintenance command on the database server
  • ibase_modify_user — Modify a user to a security database
  • ibase_name_result — Assigns a name to a result set
  • ibase_num_fields — Get the number of fields in a result set
  • ibase_num_params — Return the number of parameters in a prepared query
  • ibase_param_info — Return information about a parameter in a prepared query
  • ibase_pconnect — Open a persistent connection to an InterBase database
  • ibase_prepare — Prepare a query for later binding of parameter placeholders and execution
  • ibase_query — Execute a query on an InterBase database
  • ibase_restore — Initiates a restore task in the service manager and returns immediately
  • ibase_rollback_ret — Roll back a transaction without closing it
  • ibase_rollback — Roll back a transaction
  • ibase_server_info — Request information about a database server
  • ibase_service_attach — Connect to the service manager
  • ibase_service_detach — Disconnect from the service manager
  • ibase_set_event_handler — Register a callback function to be called when events are posted
  • ibase_trans — Begin a transaction
  • ibase_wait_event — Wait for an event to be posted by the database


别名 ibase_add_user

  • ? Firebird/InterBase 函数
  • fbird_affected_rows ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_add_user

fbird_add_user

(PHP 5, PHP 7 < 7.4.0)

fbird_add_user — 别名 ibase_add_user()

说明

此函数是该函数的别名： ibase_add_user().

参见

  • fbird_modify_user() - 别名 ibase_modify_user
  • fbird_delete_user() - 别名 ibase_delete_user


别名 ibase_affected_rows

  • ? fbird_add_user
  • fbird_backup ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_affected_rows

fbird_affected_rows

(PHP 5, PHP 7 < 7.4.0)

fbird_affected_rows — 别名 ibase_affected_rows()

说明

此函数是该函数的别名： ibase_affected_rows().

参见

  • fbird_query() - 别名 ibase_query
  • fbird_execute() - 别名 ibase_execute


别名 ibase_backup

  • ? fbird_affected_rows
  • fbird_blob_add ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_backup

fbird_backup

(PHP 5, PHP 7 < 7.4.0)

fbird_backup — 别名 ibase_backup()

说明

此函数是该函数的别名： ibase_backup().


别名 ibase_blob_add

  • ? fbird_backup
  • fbird_blob_cancel ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_blob_add

fbird_blob_add

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_add — 别名 ibase_blob_add()

说明

此函数是该函数的别名： ibase_blob_add().

参见

  • fbird_blob_cancel() - Cancel creating blob
  • fbird_blob_close() - 别名 ibase_blob_close
  • fbird_blob_create() - 别名 ibase_blob_create
  • fbird_blob_import() - 别名 ibase_blob_import


Cancel creating blob

  • ? fbird_blob_add
  • fbird_blob_close ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Cancel creating blob

fbird_blob_cancel

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_cancel — Cancel creating blob

说明

fbird_blob_cancel ( resource $blob_handle ) : bool

This function will discard a BLOB if it has not yet been closed by fbird_blob_close().

参数

blob_handle

A BLOB handle opened with fbird_blob_create().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbird_blob_close() - 别名 ibase_blob_close
  • fbird_blob_create() - 别名 ibase_blob_create
  • fbird_blob_import() - 别名 ibase_blob_import


别名 ibase_blob_close

  • ? fbird_blob_cancel
  • fbird_blob_create ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_blob_close

fbird_blob_close

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_close — 别名 ibase_blob_close()

说明

此函数是该函数的别名： ibase_blob_close().

参见

  • fbird_blob_create() - 别名 ibase_blob_create
  • fbird_blob_cancel() - Cancel creating blob
  • fbird_blob_open() - 别名 ibase_blob_open
  • fbird_blob_import() - 别名 ibase_blob_import


别名 ibase_blob_create

  • ? fbird_blob_close
  • fbird_blob_echo ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_blob_create

fbird_blob_create

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_create — 别名 ibase_blob_create()

说明

此函数是该函数的别名： ibase_blob_create().

参见

  • fbird_blob_add() - 别名 ibase_blob_add
  • fbird_blob_cancel() - Cancel creating blob
  • fbird_blob_close() - 别名 ibase_blob_close
  • fbird_blob_import() - 别名 ibase_blob_import


别名 ibase_blob_echo

  • ? fbird_blob_create
  • fbird_blob_get ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_blob_echo

fbird_blob_echo

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_echo — 别名 ibase_blob_echo()

说明

此函数是该函数的别名： ibase_blob_echo().

参见

  • fbird_blob_open() - 别名 ibase_blob_open
  • fbird_blob_close() - 别名 ibase_blob_close
  • fbird_blob_get() - 别名 ibase_blob_get


别名 ibase_blob_get

  • ? fbird_blob_echo
  • fbird_blob_import ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_blob_get

fbird_blob_get

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_get — 别名 ibase_blob_get()

说明

此函数是该函数的别名： ibase_blob_get().

参见

  • fbird_blob_open() - 别名 ibase_blob_open
  • fbird_blob_close() - 别名 ibase_blob_close
  • fbird_blob_echo() - 别名 ibase_blob_echo


别名 ibase_blob_import

  • ? fbird_blob_get
  • fbird_blob_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_blob_import

fbird_blob_import

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_import — 别名 ibase_blob_import()

说明

此函数是该函数的别名： ibase_blob_import().

参见

  • fbird_blob_add() - 别名 ibase_blob_add
  • fbird_blob_cancel() - Cancel creating blob
  • fbird_blob_close() - 别名 ibase_blob_close
  • fbird_blob_create() - 别名 ibase_blob_create


别名 ibase_blob_info

  • ? fbird_blob_import
  • fbird_blob_open ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_blob_info

fbird_blob_info

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_info — 别名 ibase_blob_info()

说明

此函数是该函数的别名： ibase_blob_info().


别名 ibase_blob_open

  • ? fbird_blob_info
  • fbird_close ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_blob_open

fbird_blob_open

(PHP 5, PHP 7 < 7.4.0)

fbird_blob_open — 别名 ibase_blob_open()

说明

此函数是该函数的别名： ibase_blob_open().

参见

  • fbird_blob_close() - 别名 ibase_blob_close
  • fbird_blob_echo() - 别名 ibase_blob_echo
  • fbird_blob_get() - 别名 ibase_blob_get


别名 ibase_close

  • ? fbird_blob_open
  • fbird_commit_ret ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_close

fbird_close

(PHP 5, PHP 7 < 7.4.0)

fbird_close — 别名 ibase_close()

说明

此函数是该函数的别名： ibase_close().

参见

  • fbird_connect() - 别名 ibase_connect
  • fbird_pconnect() - 别名 ibase_pconnect


别名 ibase_commit_ret

  • ? fbird_close
  • fbird_commit ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_commit_ret

fbird_commit_ret

(PHP 5, PHP 7 < 7.4.0)

fbird_commit_ret — 别名 ibase_commit_ret()

说明

此函数是该函数的别名： ibase_commit_ret().


别名 ibase_commit

  • ? fbird_commit_ret
  • fbird_connect ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_commit

fbird_commit

(PHP 5, PHP 7 < 7.4.0)

fbird_commit — 别名 ibase_commit()

说明

此函数是该函数的别名： ibase_commit().


别名 ibase_connect

  • ? fbird_commit
  • fbird_db_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_connect

fbird_connect

(PHP 5, PHP 7 < 7.4.0)

fbird_connect — 别名 ibase_connect()

说明

此函数是该函数的别名： ibase_connect().

参见

  • fbird_pconnect() - 别名 ibase_pconnect
  • fbird_close() - 别名 ibase_close


别名 ibase_db_info

  • ? fbird_connect
  • fbird_delete_user ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_db_info

fbird_db_info

(PHP 5, PHP 7 < 7.4.0)

fbird_db_info — 别名 ibase_db_info()

说明

此函数是该函数的别名： ibase_db_info().


别名 ibase_delete_user

  • ? fbird_db_info
  • fbird_drop_db ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_delete_user

fbird_delete_user

(PHP 5, PHP 7 < 7.4.0)

fbird_delete_user — 别名 ibase_delete_user()

说明

此函数是该函数的别名： ibase_delete_user().

参见

  • fbird_add_user() - 别名 ibase_add_user
  • fbird_modify_user() - 别名 ibase_modify_user


别名 ibase_drop_db

  • ? fbird_delete_user
  • fbird_errcode ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_drop_db

fbird_drop_db

(PHP 5, PHP 7 < 7.4.0)

fbird_drop_db — 别名 ibase_drop_db()

说明

此函数是该函数的别名： ibase_drop_db().

参见

  • fbird_connect() - 别名 ibase_connect
  • fbird_pconnect() - 别名 ibase_pconnect


别名 ibase_errcode

  • ? fbird_drop_db
  • fbird_errmsg ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_errcode

fbird_errcode

(PHP 5, PHP 7 < 7.4.0)

fbird_errcode — 别名 ibase_errcode()

说明

此函数是该函数的别名： ibase_errcode().

参见

  • fbird_errmsg() - 别名 ibase_errmsg


别名 ibase_errmsg

  • ? fbird_errcode
  • fbird_execute ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_errmsg

fbird_errmsg

(PHP 5, PHP 7 < 7.4.0)

fbird_errmsg — 别名 ibase_errmsg()

说明

此函数是该函数的别名： ibase_errmsg().

参见

  • fbird_errcode() - 别名 ibase_errcode


别名 ibase_execute

  • ? fbird_errmsg
  • fbird_fetch_assoc ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_execute

fbird_execute

(PHP 5, PHP 7 < 7.4.0)

fbird_execute — 别名 ibase_execute()

说明

此函数是该函数的别名： ibase_execute().

参见

  • fbird_query() - 别名 ibase_query


别名 ibase_fetch_assoc

  • ? fbird_execute
  • fbird_fetch_object ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_fetch_assoc

fbird_fetch_assoc

(PHP 5, PHP 7 < 7.4.0)

fbird_fetch_assoc — 别名 ibase_fetch_assoc()

说明

此函数是该函数的别名： ibase_fetch_assoc().

参见

  • fbird_fetch_row() - 别名 ibase_fetch_row
  • fbird_fetch_object() - 别名 ibase_fetch_object


别名 ibase_fetch_object

  • ? fbird_fetch_assoc
  • fbird_fetch_row ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_fetch_object

fbird_fetch_object

(PHP 5, PHP 7 < 7.4.0)

fbird_fetch_object — 别名 ibase_fetch_object()

说明

此函数是该函数的别名： ibase_fetch_object().

参见

  • fbird_fetch_row() - 别名 ibase_fetch_row
  • fbird_fetch_assoc() - 别名 ibase_fetch_assoc


别名 ibase_fetch_row

  • ? fbird_fetch_object
  • fbird_field_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_fetch_row

fbird_fetch_row

(PHP 5, PHP 7 < 7.4.0)

fbird_fetch_row — 别名 ibase_fetch_row()

说明

此函数是该函数的别名： ibase_fetch_row().

参见

  • fbird_fetch_assoc() - 别名 ibase_fetch_assoc
  • fbird_fetch_object() - 别名 ibase_fetch_object


别名 ibase_field_info

  • ? fbird_fetch_row
  • fbird_free_event_handler ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_field_info

fbird_field_info

(PHP 5, PHP 7 < 7.4.0)

fbird_field_info — 别名 ibase_field_info()

说明

此函数是该函数的别名： ibase_field_info().

参见

  • fbird_num_fields() - 别名 ibase_num_fields


别名 ibase_free_event_handler

  • ? fbird_field_info
  • fbird_free_query ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_free_event_handler

fbird_free_event_handler

(PHP 5, PHP 7 < 7.4.0)

fbird_free_event_handler — 别名 ibase_free_event_handler()

说明

此函数是该函数的别名： ibase_free_event_handler().

参见

  • fbird_set_event_handler() - 别名 ibase_set_event_handler


别名 ibase_free_query

  • ? fbird_free_event_handler
  • fbird_free_result ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_free_query

fbird_free_query

(PHP 5, PHP 7 < 7.4.0)

fbird_free_query — 别名 ibase_free_query()

说明

此函数是该函数的别名： ibase_free_query().


别名 ibase_free_result

  • ? fbird_free_query
  • fbird_gen_id ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_free_result

fbird_free_result

(PHP 5, PHP 7 < 7.4.0)

fbird_free_result — 别名 ibase_free_result()

说明

此函数是该函数的别名： ibase_free_result().


别名 ibase_gen_id

  • ? fbird_free_result
  • fbird_maintain_db ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_gen_id

fbird_gen_id

(PHP 5, PHP 7 < 7.4.0)

fbird_gen_id — 别名 ibase_gen_id()

说明

此函数是该函数的别名： ibase_gen_id().


别名 ibase_maintain_db

  • ? fbird_gen_id
  • fbird_modify_user ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_maintain_db

fbird_maintain_db

(PHP 5, PHP 7 < 7.4.0)

fbird_maintain_db — 别名 ibase_maintain_db()

说明

此函数是该函数的别名： ibase_maintain_db().


别名 ibase_modify_user

  • ? fbird_maintain_db
  • fbird_name_result ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_modify_user

fbird_modify_user

(PHP 5, PHP 7 < 7.4.0)

fbird_modify_user — 别名 ibase_modify_user()

说明

此函数是该函数的别名： ibase_modify_user().

参见

  • fbird_add_user() - 别名 ibase_add_user
  • fbird_delete_user() - 别名 ibase_delete_user


别名 ibase_name_result

  • ? fbird_modify_user
  • fbird_num_fields ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_name_result

fbird_name_result

(PHP 5, PHP 7 < 7.4.0)

fbird_name_result — 别名 ibase_name_result()

说明

此函数是该函数的别名： ibase_name_result().

参见

  • fbird_prepare() - 别名 ibase_prepare
  • fbird_execute() - 别名 ibase_execute


别名 ibase_num_fields

  • ? fbird_name_result
  • fbird_num_params ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_num_fields

fbird_num_fields

(PHP 5, PHP 7 < 7.4.0)

fbird_num_fields — 别名 ibase_num_fields()

说明

此函数是该函数的别名： ibase_num_fields().

参见

  • fbird_field_info() - 别名 ibase_field_info


别名 ibase_num_params

  • ? fbird_num_fields
  • fbird_param_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_num_params

fbird_num_params

(PHP 5, PHP 7 < 7.4.0)

fbird_num_params — 别名 ibase_num_params()

说明

此函数是该函数的别名： ibase_num_params().

参见

  • fbird_prepare() - 别名 ibase_prepare
  • fbird_param_info() - 别名 ibase_param_info


别名 ibase_param_info

  • ? fbird_num_params
  • fbird_pconnect ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_param_info

fbird_param_info

(PHP 5, PHP 7 < 7.4.0)

fbird_param_info — 别名 ibase_param_info()

说明

此函数是该函数的别名： ibase_param_info().

参见

  • fbird_field_info() - 别名 ibase_field_info
  • fbird_num_params() - 别名 ibase_num_params


别名 ibase_pconnect

  • ? fbird_param_info
  • fbird_prepare ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_pconnect

fbird_pconnect

(PHP 5, PHP 7 < 7.4.0)

fbird_pconnect — 别名 ibase_pconnect()

说明

此函数是该函数的别名： ibase_pconnect().

参见

  • fbird_close() - 别名 ibase_close
  • fbird_connect() - 别名 ibase_connect


别名 ibase_prepare

  • ? fbird_pconnect
  • fbird_query ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_prepare

fbird_prepare

(PHP 5, PHP 7 < 7.4.0)

fbird_prepare — 别名 ibase_prepare()

说明

此函数是该函数的别名： ibase_prepare().


别名 ibase_query

  • ? fbird_prepare
  • fbird_restore ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_query

fbird_query

(PHP 5, PHP 7 < 7.4.0)

fbird_query — 别名 ibase_query()

说明

此函数是该函数的别名： ibase_query().

参见

  • fbird_errmsg() - 别名 ibase_errmsg
  • fbird_fetch_row() - 别名 ibase_fetch_row
  • fbird_fetch_object() - 别名 ibase_fetch_object
  • fbird_free_result() - 别名 ibase_free_result


别名 ibase_restore

  • ? fbird_query
  • fbird_rollback_ret ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_restore

fbird_restore

(PHP 5, PHP 7 < 7.4.0)

fbird_restore — 别名 ibase_restore()

说明

此函数是该函数的别名： ibase_restore().


别名 ibase_rollback_ret

  • ? fbird_restore
  • fbird_rollback ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_rollback_ret

fbird_rollback_ret

(PHP 5, PHP 7 < 7.4.0)

fbird_rollback_ret — 别名 ibase_rollback_ret()

说明

此函数是该函数的别名： ibase_rollback_ret().


别名 ibase_rollback

  • ? fbird_rollback_ret
  • fbird_server_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_rollback

fbird_rollback

(PHP 5, PHP 7 < 7.4.0)

fbird_rollback — 别名 ibase_rollback()

说明

此函数是该函数的别名： ibase_rollback().


别名 ibase_server_info

  • ? fbird_rollback
  • fbird_service_attach ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_server_info

fbird_server_info

(PHP 5, PHP 7 < 7.4.0)

fbird_server_info — 别名 ibase_server_info()

说明

此函数是该函数的别名： ibase_server_info().


别名 ibase_service_attach

  • ? fbird_server_info
  • fbird_service_detach ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_service_attach

fbird_service_attach

(PHP 5, PHP 7 < 7.4.0)

fbird_service_attach — 别名 ibase_service_attach()

说明

此函数是该函数的别名： ibase_service_attach().


别名 ibase_service_detach

  • ? fbird_service_attach
  • fbird_set_event_handler ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_service_detach

fbird_service_detach

(PHP 5, PHP 7 < 7.4.0)

fbird_service_detach — 别名 ibase_service_detach()

说明

此函数是该函数的别名： ibase_service_detach().


别名 ibase_set_event_handler

  • ? fbird_service_detach
  • fbird_trans ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_set_event_handler

fbird_set_event_handler

(PHP 5, PHP 7 < 7.4.0)

fbird_set_event_handler — 别名 ibase_set_event_handler()

说明

此函数是该函数的别名： ibase_set_event_handler().

参见

  • fbird_free_event_handler() - 别名 ibase_free_event_handler
  • fbird_wait_event() - 别名 ibase_wait_event


别名 ibase_trans

  • ? fbird_set_event_handler
  • fbird_wait_event ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_trans

fbird_trans

(PHP 5, PHP 7 < 7.4.0)

fbird_trans — 别名 ibase_trans()

说明

此函数是该函数的别名： ibase_trans().


别名 ibase_wait_event

  • ? fbird_trans
  • ibase_add_user ?
  • PHP Manual
  • Firebird/InterBase 函数
  • 别名 ibase_wait_event

fbird_wait_event

(PHP 5, PHP 7 < 7.4.0)

fbird_wait_event — 别名 ibase_wait_event()

说明

此函数是该函数的别名： ibase_wait_event().

参见

  • fbird_set_event_handler() - 别名 ibase_set_event_handler
  • fbird_free_event_handler() - 别名 ibase_free_event_handler


Add a user to a security database

  • ? fbird_wait_event
  • ibase_affected_rows ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Add a user to a security database

ibase_add_user

(PHP 5, PHP 7 < 7.4.0)

ibase_add_user — Add a user to a security database

说明

ibase_add_user ( resource $service_handle , string $user_name , string $password , string $first_name = ? , string $middle_name = ? , string $last_name = ? ) : bool

参数

service_handle

The handle on the database server service.

user_name

The login name of the new database user.

password

The password of the new user.

first_name

The first name of the new database user.

middle_name

The middle name of the new database user.

last_name

The last name of the new database user.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ibase_modify_user() - Modify a user to a security database
  • ibase_delete_user() - Delete a user from a security database


Return the number of rows that were affected by the previous query

  • ? ibase_add_user
  • ibase_backup ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Return the number of rows that were affected by the previous query

ibase_affected_rows

(PHP 5, PHP 7 < 7.4.0)

ibase_affected_rows — Return the number of rows that were affected by the previous query

说明

ibase_affected_rows ( resource $link_identifier = ? ) : int

This function returns the number of rows that were affected by the previous query (INSERT, UPDATE or DELETE) that was executed from within the specified transaction context.

参数

link_identifier

A transaction context. If link_identifier is a connection resource, its default transaction is used.

返回值

Returns the number of rows as an integer.

参见

  • ibase_query() - Execute a query on an InterBase database
  • ibase_execute() - Execute a previously prepared query


Initiates a backup task in the service manager and returns immediately

  • ? ibase_affected_rows
  • ibase_blob_add ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Initiates a backup task in the service manager and returns immediately

ibase_backup

(PHP 5, PHP 7 < 7.4.0)

ibase_backup — Initiates a backup task in the service manager and returns immediately

说明

ibase_backup ( resource $service_handle , string $source_db , string $dest_file , int $options = 0 , bool $verbose = false ) : mixed

This function passes the arguments to the (remote) database server. There it starts a new backup process. Therefore you won't get any responses.

参数

service_handle

A previously opened connection to the database server.

source_db

The absolute file path to the database on the database server. You can also use a database alias.

dest_file

The path to the backup file on the database server.

options

Additional options to pass to the database server for backup. The options parameter can be a combination of the following constants: IBASE_BKP_IGNORE_CHECKSUMS, IBASE_BKP_IGNORE_LIMBO, IBASE_BKP_METADATA_ONLY, IBASE_BKP_NO_GARBAGE_COLLECT, IBASE_BKP_OLD_DESCRIPTIONS, IBASE_BKP_NON_TRANSPORTABLE or IBASE_BKP_CONVERT. Read the section about 预定义常量 for further information.

verbose

Since the backup process is done on the database server, you don't have any chance to get its output. This argument is useless.

返回值

成功时返回 true， 或者在失败时返回 false。

Since the backup process is done on the (remote) server, this function just passes the arguments to it. While the arguments are legal, you won't get false.

范例

Example #1 ibase_backup() example

<?php

// Attach to database server by ip address and port
$service = ibase_service_attach ('10.1.11.200/3050', 'sysdba', 'masterkey');

// Start the backup process on database server
// Backup employee database using full path to /srv/backup/employees.fbk
// Don't use any special arguments
ibase_backup($service, '/srv/firebird/employees.fdb', '/srv/backup/employees.fbk');

// Free the attached connection
ibase_service_detach ($service);
?>

Example #2 ibase_backup() example with arguments

<?php

// Attach to database server by name and default port
$service = ibase_service_attach ('fb-server.contoso.local', 'sysdba', 'masterkey');

// Start the backup process on database server
// Backup employee database using alias to /srv/backup/employees.fbk.
// Backup only the metadata. Don't create a transportable backup.
ibase_backup($service, 'employees.fdb', '/srv/backup/employees.fbk', IBASE_BKP_METADATA_ONLY | IBASE_BKP_NON_TRANSPORTABLE);

// Free the attached connection
ibase_service_detach ($service);
?>

参见

  • ibase_restore() - Initiates a restore task in the service manager and returns immediately


Add data into a newly created blob

  • ? ibase_backup
  • ibase_blob_cancel ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Add data into a newly created blob

ibase_blob_add

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_add — Add data into a newly created blob

说明

ibase_blob_add ( resource $blob_handle , string $data ) : void

ibase_blob_add() adds data into a blob created with ibase_blob_create().

参数

blob_handle

A blob handle opened with ibase_blob_create().

data

The data to be added.

返回值

没有返回值。

参见

  • ibase_blob_cancel() - Cancel creating blob
  • ibase_blob_close() - Close blob
  • ibase_blob_create() - Create a new blob for adding data
  • ibase_blob_import() - Create blob, copy file in it, and close it


Cancel creating blob

  • ? ibase_blob_add
  • ibase_blob_close ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Cancel creating blob

ibase_blob_cancel

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_cancel — Cancel creating blob

说明

ibase_blob_cancel ( resource $blob_handle ) : bool

This function will discard a BLOB if it has not yet been closed by ibase_blob_close().

参数

blob_handle

A BLOB handle opened with ibase_blob_create().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ibase_blob_close() - Close blob
  • ibase_blob_create() - Create a new blob for adding data
  • ibase_blob_import() - Create blob, copy file in it, and close it


Close blob

  • ? ibase_blob_cancel
  • ibase_blob_create ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Close blob

ibase_blob_close

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_close — Close blob

说明

ibase_blob_close ( resource $blob_handle ) : mixed

This function closes a BLOB that has either been opened for reading by ibase_blob_open() or has been opened for writing by ibase_blob_create().

参数

blob_handle

A BLOB handle opened with ibase_blob_create() or ibase_blob_open().

返回值

If the BLOB was being read, this function returns true on success, if the BLOB was being written to, this function returns a string containing the BLOB id that has been assigned to it by the database. On failure, this function returns false.

参见

  • ibase_blob_cancel() - Cancel creating blob
  • ibase_blob_open() - Open blob for retrieving data parts


Create a new blob for adding data

  • ? ibase_blob_close
  • ibase_blob_echo ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Create a new blob for adding data

ibase_blob_create

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_create — Create a new blob for adding data

说明

ibase_blob_create ( resource $link_identifier = null ) : resource|false

ibase_blob_create() creates a new BLOB for filling with data.

参数

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

返回值

Returns a BLOB handle for later use with ibase_blob_add() 或者在失败时返回 false.

参见

  • ibase_blob_add() - Add data into a newly created blob
  • ibase_blob_cancel() - Cancel creating blob
  • ibase_blob_close() - Close blob
  • ibase_blob_import() - Create blob, copy file in it, and close it


Output blob contents to browser

  • ? ibase_blob_create
  • ibase_blob_get ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Output blob contents to browser

ibase_blob_echo

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_echo — Output blob contents to browser

说明

ibase_blob_echo ( string $blob_id ) : bool
ibase_blob_echo ( resource $link_identifier , string $blob_id ) : bool

This function opens a BLOB for reading and sends its contents directly to standard output (the browser, in most cases).

参数

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ibase_blob_open() - Open blob for retrieving data parts
  • ibase_blob_close() - Close blob
  • ibase_blob_get() - Get len bytes data from open blob


Get len bytes data from open blob

  • ? ibase_blob_echo
  • ibase_blob_import ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Get len bytes data from open blob

ibase_blob_get

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_get — Get len bytes data from open blob

说明

ibase_blob_get ( resource $blob_handle , int $len ) : string

This function returns at most len bytes from a BLOB that has been opened for reading by ibase_blob_open().

Note:

It is not possible to read from a BLOB that has been opened for writing by ibase_blob_create().

参数

blob_handle

A BLOB handle opened with ibase_blob_open().

len

Size of returned data.

返回值

Returns at most len bytes from the BLOB, or false on failure.

范例

Example #1 ibase_blob_get() example

<?php
$result    = ibase_query("SELECT blob_value FROM table");
$data      = ibase_fetch_object($result);
$blob_data = ibase_blob_info($data->BLOB_VALUE);
$blob_hndl = ibase_blob_open($data->BLOB_VALUE);
echo         ibase_blob_get($blob_hndl, $blob_data[0]);
?>
Whilst this example doesn't do much more than a 'ibase_blob_echo($data->BLOB_VALUE)' would do, it does show you how to get information into a $variable to manipulate as you please.

参见

  • ibase_blob_open() - Open blob for retrieving data parts
  • ibase_blob_close() - Close blob
  • ibase_blob_echo() - Output blob contents to browser


Create blob, copy file in it, and close it

  • ? ibase_blob_get
  • ibase_blob_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Create blob, copy file in it, and close it

ibase_blob_import

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_import — Create blob, copy file in it, and close it

说明

ibase_blob_import ( resource $link_identifier , resource $file_handle ) : string
ibase_blob_import ( resource $file_handle ) : string

This function creates a BLOB, reads an entire file into it, closes it and returns the assigned BLOB id.

参数

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

file_handle

The file handle is a handle returned by fopen().

返回值

Returns the BLOB id on success, or false on error.

范例

Example #1 ibase_blob_import() example

<?php
$dbh = ibase_connect($host, $username, $password);
$filename = '/tmp/bar';

$fd = fopen($filename, 'r');
if ($fd) {

    $blob = ibase_blob_import($dbh, $fd);
    fclose($fd);

    if (!is_string($blob)) {
        // import failed
    } else {
        $query = "INSERT INTO foo (name, data) VALUES ('$filename', ?)";
        $prepared = ibase_prepare($dbh, $query);
        if (!ibase_execute($prepared, $blob)) {
            // record insertion failed
        }
    }
} else {
    // unable to open the data file
}
?>

参见

  • ibase_blob_add() - Add data into a newly created blob
  • ibase_blob_cancel() - Cancel creating blob
  • ibase_blob_close() - Close blob
  • ibase_blob_create() - Create a new blob for adding data


Return blob length and other useful info

  • ? ibase_blob_import
  • ibase_blob_open ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Return blob length and other useful info

ibase_blob_info

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_info — Return blob length and other useful info

说明

ibase_blob_info ( resource $link_identifier , string $blob_id ) : array
ibase_blob_info ( string $blob_id ) : array

Returns the BLOB length and other useful information.

参数

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

A BLOB id.

返回值

Returns an array containing information about a BLOB. The information returned consists of the length of the BLOB, the number of segments it contains, the size of the largest segment, and whether it is a stream BLOB or a segmented BLOB.


Open blob for retrieving data parts

  • ? ibase_blob_info
  • ibase_close ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Open blob for retrieving data parts

ibase_blob_open

(PHP 5, PHP 7 < 7.4.0)

ibase_blob_open — Open blob for retrieving data parts

说明

ibase_blob_open ( resource $link_identifier , string $blob_id ) : resource|false
ibase_blob_open ( string $blob_id ) : resource|false

Opens an existing BLOB for reading.

参数

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

A BLOB id.

返回值

Returns a BLOB handle for later use with ibase_blob_get() 或者在失败时返回 false.

参见

  • ibase_blob_close() - Close blob
  • ibase_blob_echo() - Output blob contents to browser
  • ibase_blob_get() - Get len bytes data from open blob


Close a connection to an InterBase database

  • ? ibase_blob_open
  • ibase_commit_ret ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Close a connection to an InterBase database

ibase_close

(PHP 5, PHP 7 < 7.4.0)

ibase_close — Close a connection to an InterBase database

说明

ibase_close ( resource $connection_id = null ) : bool

Closes the link to an InterBase database that's associated with a connection id returned from ibase_connect(). Default transaction on link is committed, other transactions are rolled back.

参数

connection_id

An InterBase link identifier returned from ibase_connect(). If omitted, the last opened link is assumed.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ibase_connect() - Open a connection to a database
  • ibase_pconnect() - Open a persistent connection to an InterBase database


Commit a transaction without closing it

  • ? ibase_close
  • ibase_commit ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Commit a transaction without closing it

ibase_commit_ret

(PHP 5, PHP 7 < 7.4.0)

ibase_commit_ret — Commit a transaction without closing it

说明

ibase_commit_ret ( resource $link_or_trans_identifier = null ) : bool

Commits a transaction without closing it.

参数

link_or_trans_identifier

If called without an argument, this function commits the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be committed. If the argument is a transaction identifier, the corresponding transaction will be committed. The transaction context will be retained, so statements executed from within this transaction will not be invalidated.

返回值

成功时返回 true， 或者在失败时返回 false。


Commit a transaction

  • ? ibase_commit_ret
  • ibase_connect ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Commit a transaction

ibase_commit

(PHP 5, PHP 7 < 7.4.0)

ibase_commit — Commit a transaction

说明

ibase_commit ( resource $link_or_trans_identifier = null ) : bool

Commits a transaction.

参数

link_or_trans_identifier

If called without an argument, this function commits the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be committed. If the argument is a transaction identifier, the corresponding transaction will be committed.

返回值

成功时返回 true， 或者在失败时返回 false。


Open a connection to a database

  • ? ibase_commit
  • ibase_db_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Open a connection to a database

ibase_connect

(PHP 5, PHP 7 < 7.4.0)

ibase_connect — Open a connection to a database

说明

ibase_connect ( string $database = ? , string $username = ? , string $password = ? , string $charset = ? , int $buffers = ? , int $dialect = ? , string $role = ? , int $sync = ? ) : resource

Establishes a connection to an Firebird/InterBase server.

In case a second call is made to ibase_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned. The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling ibase_close().

参数

database

The database argument has to be a valid path to database file on the server it resides on. If the server is not local, it must be prefixed with either 'hostname:' (TCP/IP), 'hostname/port:' (TCP/IP with interbase server on custom TCP port), '//hostname/' (NetBEUI), depending on the connection protocol used.

username

The user name. Can be set with the ibase.default_user php.ini directive.

password

The password for username. Can be set with the ibase.default_password php.ini directive.

charset

charset is the default character set for a database.

buffers

buffers is the number of database buffers to allocate for the server-side cache. If 0 or omitted, server chooses its own default.

dialect

dialect selects the default SQL dialect for any statement executed within a connection, and it defaults to the highest one supported by client libraries.

role

Functional only with InterBase 5 and up.

sync

返回值

Returns an Firebird/InterBase link identifier on success, or false on error.

错误／异常

If you get some error like "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (this occurs when you try use some character with accents) when using this and after ibase_query() you must set the character set (i.e. ISO8859_1 or your current character set).

范例

Example #1 ibase_connect() example

<?php
$host = 'localhost:/path/to/your.gdb';

$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';
$sth = ibase_query($dbh, $stmt);
while ($row = ibase_fetch_object($sth)) {
    echo $row->email, "\n";
}
ibase_free_result($sth);
ibase_close($dbh);
?>

参见

  • ibase_pconnect() - Open a persistent connection to an InterBase database
  • ibase_close() - Close a connection to an InterBase database


Request statistics about a database

  • ? ibase_connect
  • ibase_delete_user ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Request statistics about a database

ibase_db_info

(PHP 5, PHP 7 < 7.4.0)

ibase_db_info — Request statistics about a database

说明

ibase_db_info ( resource $service_handle , string $db , int $action , int $argument = 0 ) : string
Warning

本函数还未编写文档，仅有参数列表。


Delete a user from a security database

  • ? ibase_db_info
  • ibase_drop_db ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Delete a user from a security database

ibase_delete_user

(PHP 5, PHP 7 < 7.4.0)

ibase_delete_user — Delete a user from a security database

说明

ibase_delete_user ( resource $service_handle , string $user_name ) : bool

参数

service_handle

The handle on the database server service.

user_name

The login name of the user you want to delete from the database.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ibase_add_user() - Add a user to a security database
  • ibase_modify_user() - Modify a user to a security database


Drops a database

  • ? ibase_delete_user
  • ibase_errcode ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Drops a database

ibase_drop_db

(PHP 5, PHP 7 < 7.4.0)

ibase_drop_db — Drops a database

说明

ibase_drop_db ( resource $connection = null ) : bool

This functions drops a database that was opened by either ibase_connect() or ibase_pconnect(). The database is closed and deleted from the server.

参数

connection

An InterBase link identifier. If omitted, the last opened link is assumed.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ibase_connect() - Open a connection to a database
  • ibase_pconnect() - Open a persistent connection to an InterBase database


Return an error code

  • ? ibase_drop_db
  • ibase_errmsg ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Return an error code

ibase_errcode

(PHP 5, PHP 7 < 7.4.0)

ibase_errcode — Return an error code

说明

ibase_errcode ( ) : int

Returns the error code that resulted from the most recent InterBase function call.

返回值

Returns the error code as an integer, or false if no error occurred.

参见

  • ibase_errmsg() - Return error messages


Return error messages

  • ? ibase_errcode
  • ibase_execute ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Return error messages

ibase_errmsg

(PHP 5, PHP 7 < 7.4.0)

ibase_errmsg — Return error messages

说明

ibase_errmsg ( ) : string

Returns the error message that resulted from the most recent InterBase function call.

返回值

Returns the error message as a string, or false if no error occurred.

参见

  • ibase_errcode() - Return an error code


Execute a previously prepared query

  • ? ibase_errmsg
  • ibase_fetch_assoc ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Execute a previously prepared query

ibase_execute

(PHP 5, PHP 7 < 7.4.0)

ibase_execute — Execute a previously prepared query

说明

ibase_execute ( resource $query , mixed ...$values ) : resource

Execute a query prepared by ibase_prepare().

This is a lot more effective than using ibase_query() if you are repeating a same kind of query several times with only some parameters changing.

参数

query

An InterBase query prepared by ibase_prepare().

values

返回值

If the query raises an error, returns false. If it is successful and there is a (possibly empty) result set (such as with a SELECT query), returns a result identifier. If the query was successful and there were no results, returns true.

Note:

This function returns the number of rows affected by the query (if > 0 and applicable to the statement type). A query that succeeded, but did not affect any rows (e.g. an UPDATE of a non-existent record) will return true.

范例

Example #1 ibase_execute() example

<?php

$dbh = ibase_connect($host, $username, $password);

$updates = array(
    1 => 'Eric',
    5 => 'Filip',
    7 => 'Larry'
);

$query = ibase_prepare($dbh, "UPDATE FOO SET BAR = ? WHERE BAZ = ?");

foreach ($updates as $baz => $bar) {
    ibase_execute($query, $bar, $baz);
}

?>

参见

  • ibase_query() - Execute a query on an InterBase database


Fetch a result row from a query as an associative array

  • ? ibase_execute
  • ibase_fetch_object ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Fetch a result row from a query as an associative array

ibase_fetch_assoc

(PHP 5, PHP 7 < 7.4.0)

ibase_fetch_assoc — Fetch a result row from a query as an associative array

说明

ibase_fetch_assoc ( resource $result , int $fetch_flag = 0 ) : array

Fetch a result row from a query as an associative array.

ibase_fetch_assoc() fetches one row of data from the result. If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using ibase_fetch_row() or use alias names in your query.

参数

result

The result handle.

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

返回值

Returns an associative array that corresponds to the fetched row. Subsequent calls will return the next row in the result set, or false if there are no more rows.

参见

  • ibase_fetch_row() - Fetch a row from an InterBase database
  • ibase_fetch_object() - Get an object from a InterBase database


Get an object from a InterBase database

  • ? ibase_fetch_assoc
  • ibase_fetch_row ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Get an object from a InterBase database

ibase_fetch_object

(PHP 5, PHP 7 < 7.4.0)

ibase_fetch_object — Get an object from a InterBase database

说明

ibase_fetch_object ( resource $result_id , int $fetch_flag = 0 ) : object

Fetches a row as a pseudo-object from a given result identifier.

Subsequent calls to ibase_fetch_object() return the next row in the result set.

参数

result_id

An InterBase result identifier obtained either by ibase_query() or ibase_execute().

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

返回值

Returns an object with the next row information, or false if there are no more rows.

范例

Example #1 ibase_fetch_object() example

<?php
$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';
$sth = ibase_query($dbh, $stmt);
while ($row = ibase_fetch_object($sth)) {
    echo $row->email . "\n";
}
ibase_close($dbh);
?>

参见

  • ibase_fetch_row() - Fetch a row from an InterBase database
  • ibase_fetch_assoc() - Fetch a result row from a query as an associative array


Fetch a row from an InterBase database

  • ? ibase_fetch_object
  • ibase_field_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Fetch a row from an InterBase database

ibase_fetch_row

(PHP 5, PHP 7 < 7.4.0)

ibase_fetch_row — Fetch a row from an InterBase database

说明

ibase_fetch_row ( resource $result_identifier , int $fetch_flag = 0 ) : array

ibase_fetch_row() fetches one row of data from the given result set.

Subsequent calls to ibase_fetch_row() return the next row in the result set, or false if there are no more rows.

参数

result_identifier

An InterBase result identifier.

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

返回值

Returns an array that corresponds to the fetched row, or false if there are no more rows. Each result column is stored in an array offset, starting at offset 0.

参见

  • ibase_fetch_assoc() - Fetch a result row from a query as an associative array
  • ibase_fetch_object() - Get an object from a InterBase database


Get information about a field

  • ? ibase_fetch_row
  • ibase_free_event_handler ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Get information about a field

ibase_field_info

(PHP 5, PHP 7 < 7.4.0)

ibase_field_info — Get information about a field

说明

ibase_field_info ( resource $result , int $field_number ) : array

Returns an array with information about a field after a select query has been run.

参数

result

An InterBase result identifier.

field_number

Field offset.

返回值

Returns an array with the following keys: name, alias, relation, length and type.

范例

Example #1 ibase_field_info() example

<?php
$rs = ibase_query("SELECT * FROM tablename");
$coln = ibase_num_fields($rs);
for ($i = 0; $i < $coln; $i++) {
    $col_info = ibase_field_info($rs, $i);
    echo "name: ". $col_info['name']. "\n";
    echo "alias: ". $col_info['alias']. "\n";
    echo "relation: ". $col_info['relation']. "\n";
    echo "length: ". $col_info['length']. "\n";
    echo "type: ". $col_info['type']. "\n";
}
?>

参见

  • ibase_num_fields() - Get the number of fields in a result set


Cancels a registered event handler

  • ? ibase_field_info
  • ibase_free_query ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Cancels a registered event handler

ibase_free_event_handler

(PHP 5, PHP 7 < 7.4.0)

ibase_free_event_handler — Cancels a registered event handler

说明

ibase_free_event_handler ( resource $event ) : bool

This function causes the registered event handler specified by event to be cancelled. The callback function will no longer be called for the events it was registered to handle.

参数

event

An event resource, created by ibase_set_event_handler().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ibase_set_event_handler() - Register a callback function to be called when events are posted


Free memory allocated by a prepared query

  • ? ibase_free_event_handler
  • ibase_free_result ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Free memory allocated by a prepared query

ibase_free_query

(PHP 5, PHP 7 < 7.4.0)

ibase_free_query — Free memory allocated by a prepared query

说明

ibase_free_query ( resource $query ) : bool

Frees a prepared query.

参数

query

A query prepared with ibase_prepare().

返回值

成功时返回 true， 或者在失败时返回 false。


Free a result set

  • ? ibase_free_query
  • ibase_gen_id ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Free a result set

ibase_free_result

(PHP 5, PHP 7 < 7.4.0)

ibase_free_result — Free a result set

说明

ibase_free_result ( resource $result_identifier ) : bool

Frees a result set.

参数

result_identifier

A result set created by ibase_query() or ibase_execute().

返回值

成功时返回 true， 或者在失败时返回 false。


Increments the named generator and returns its new value

  • ? ibase_free_result
  • ibase_maintain_db ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Increments the named generator and returns its new value

ibase_gen_id

(PHP 5, PHP 7 < 7.4.0)

ibase_gen_id — Increments the named generator and returns its new value

说明

ibase_gen_id ( string $generator , int $increment = 1 , resource $link_identifier = null ) : mixed
Warning

本函数还未编写文档，仅有参数列表。

返回值

Returns new generator value as integer, or as string if the value is too big.


Execute a maintenance command on the database server

  • ? ibase_gen_id
  • ibase_modify_user ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Execute a maintenance command on the database server

ibase_maintain_db

(PHP 5, PHP 7 < 7.4.0)

ibase_maintain_db — Execute a maintenance command on the database server

说明

ibase_maintain_db ( resource $service_handle , string $db , int $action , int $argument = 0 ) : bool
Warning

本函数还未编写文档，仅有参数列表。

返回值

成功时返回 true， 或者在失败时返回 false。


Modify a user to a security database

  • ? ibase_maintain_db
  • ibase_name_result ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Modify a user to a security database

ibase_modify_user

(PHP 5, PHP 7 < 7.4.0)

ibase_modify_user — Modify a user to a security database

说明

ibase_modify_user ( resource $service_handle , string $user_name , string $password , string $first_name = ? , string $middle_name = ? , string $last_name = ? ) : bool

参数

service_handle

The handle on the database server service.

user_name

The login name of the database user to modify.

password

The user's new password.

first_name

The user's new first name.

middle_name

The user's new middle name.

last_name

The user's new last name.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ibase_add_user() - Add a user to a security database
  • ibase_delete_user() - Delete a user from a security database


Assigns a name to a result set

  • ? ibase_modify_user
  • ibase_num_fields ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Assigns a name to a result set

ibase_name_result

(PHP 5, PHP 7 < 7.4.0)

ibase_name_result — Assigns a name to a result set

说明

ibase_name_result ( resource $result , string $name ) : bool

This function assigns a name to a result set. This name can be used later in UPDATE|DELETE ... WHERE CURRENT OF name statements.

参数

result

An InterBase result set.

name

The name to be assigned.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ibase_name_result() example

<?php
$result = ibase_query("SELECT field1,field2 FROM table FOR UPDATE");
ibase_name_result($result, "my_cursor");

$updateqry = ibase_prepare("UPDATE table SET field2 = ? WHERE CURRENT OF my_cursor");

for ($i = 0; ibase_fetch_row($result); ++$i) {
    ibase_execute($updateqry, $i);
}
?>

参见

  • ibase_prepare() - Prepare a query for later binding of parameter placeholders and execution
  • ibase_execute() - Execute a previously prepared query


Get the number of fields in a result set

  • ? ibase_name_result
  • ibase_num_params ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Get the number of fields in a result set

ibase_num_fields

(PHP 5, PHP 7 < 7.4.0)

ibase_num_fields — Get the number of fields in a result set

说明

ibase_num_fields ( resource $result_id ) : int

Get the number of fields in a result set.

参数

result_id

An InterBase result identifier.

返回值

Returns the number of fields as an integer.

范例

Example #1 ibase_num_fields() example

<?php
$rs = ibase_query("SELECT * FROM tablename");
$coln = ibase_num_fields($rs);
for ($i = 0; $i < $coln; $i++) {
    $col_info = ibase_field_info($rs, $i);
    echo "name: " . $col_info['name'] . "\n";
    echo "alias: " . $col_info['alias'] . "\n";
    echo "relation: " . $col_info['relation'] . "\n";
    echo "length: " . $col_info['length'] . "\n";
    echo "type: " . $col_info['type'] . "\n";
}
?>

参见

  • ibase_field_info() - Get information about a field


Return the number of parameters in a prepared query

  • ? ibase_num_fields
  • ibase_param_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Return the number of parameters in a prepared query

ibase_num_params

(PHP 5, PHP 7 < 7.4.0)

ibase_num_params — Return the number of parameters in a prepared query

说明

ibase_num_params ( resource $query ) : int

This function returns the number of parameters in the prepared query specified by query. This is the number of binding arguments that must be present when calling ibase_execute().

参数

query

The prepared query handle.

返回值

Returns the number of parameters as an integer.

参见

  • ibase_prepare() - Prepare a query for later binding of parameter placeholders and execution
  • ibase_param_info() - Return information about a parameter in a prepared query


Return information about a parameter in a prepared query

  • ? ibase_num_params
  • ibase_pconnect ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Return information about a parameter in a prepared query

ibase_param_info

(PHP 5, PHP 7 < 7.4.0)

ibase_param_info — Return information about a parameter in a prepared query

说明

ibase_param_info ( resource $query , int $param_number ) : array

Returns an array with information about a parameter after a query has been prepared.

参数

query

An InterBase prepared query handle.

param_number

Parameter offset.

返回值

Returns an array with the following keys: name, alias, relation, length and type.

参见

  • ibase_field_info() - Get information about a field
  • ibase_num_params() - Return the number of parameters in a prepared query


Open a persistent connection to an InterBase database

  • ? ibase_param_info
  • ibase_prepare ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Open a persistent connection to an InterBase database

ibase_pconnect

(PHP 5, PHP 7 < 7.4.0)

ibase_pconnect — Open a persistent connection to an InterBase database

说明

ibase_pconnect ( string $database = ? , string $username = ? , string $password = ? , string $charset = ? , int $buffers = ? , int $dialect = ? , string $role = ? , int $sync = ? ) : resource

Opens a persistent connection to an InterBase database.

ibase_pconnect() acts very much like ibase_connect() with two major differences.

First, when connecting, the function will first try to find a (persistent) link that's already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the InterBase server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ibase_close() will not close links established by ibase_pconnect()). This type of link is therefore called 'persistent'.

参数

database

The database argument has to be a valid path to database file on the server it resides on. If the server is not local, it must be prefixed with either 'hostname:' (TCP/IP), '//hostname/' (NetBEUI) or 'hostname@' (IPX/SPX), depending on the connection protocol used.

username

The user name. Can be set with the ibase.default_user php.ini directive.

password

The password for username. Can be set with the ibase.default_password php.ini directive.

charset

charset is the default character set for a database.

buffers

buffers is the number of database buffers to allocate for the server-side cache. If 0 or omitted, server chooses its own default.

dialect

dialect selects the default SQL dialect for any statement executed within a connection, and it defaults to the highest one supported by client libraries. Functional only with InterBase 6 and up.

role

Functional only with InterBase 5 and up.

sync

返回值

Returns an InterBase link identifier on success, or false on error.

参见

  • ibase_close() - Close a connection to an InterBase database
  • ibase_connect() - Open a connection to a database


Prepare a query for later binding of parameter placeholders and execution

  • ? ibase_pconnect
  • ibase_query ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Prepare a query for later binding of parameter placeholders and execution

ibase_prepare

(PHP 5, PHP 7 < 7.4.0)

ibase_prepare — Prepare a query for later binding of parameter placeholders and execution

说明

ibase_prepare ( string $query ) : resource
ibase_prepare ( resource $link_identifier , string $query ) : resource
ibase_prepare ( resource $link_identifier , string $trans , string $query ) : resource

Prepare a query for later binding of parameter placeholders and execution (via ibase_execute()).

参数

query

An InterBase query.

link_identifier

An InterBase link identifier returned from ibase_connect(). If omitted, the last opened link is assumed.

trans

An InterBase transaction handle the query should be associated with. If omitted, the default transaction of the connection is assumed.

返回值

Returns a prepared query handle, or false on error.


Execute a query on an InterBase database

  • ? ibase_prepare
  • ibase_restore ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Execute a query on an InterBase database

ibase_query

(PHP 5, PHP 7 < 7.4.0)

ibase_query — Execute a query on an InterBase database

说明

ibase_query ( resource $link_identifier = ? , string $query , int $bind_args = ? ) : resource

Performs a query on an InterBase database.

参数

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

query

An InterBase query.

bind_args

返回值

If the query raises an error, returns false. If it is successful and there is a (possibly empty) result set (such as with a SELECT query), returns a result identifier. If the query was successful and there were no results, returns true.

Note:

In PHP 5.0.0 and up, this function will return the number of rows affected by the query for INSERT, UPDATE and DELETE statements. In order to retain backward compatibility, it will return true for these statements if the query succeeded without affecting any rows.

错误／异常

If you get some error like "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (this occurs when you try use some character with accents) when using this and after ibase_query() you must set the character set (i.e. ISO8859_1 or your current character set).

范例

Example #1 ibase_query() example

<?php

$host = 'localhost:/path/to/your.gdb';

$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';

$sth = ibase_query($dbh, $stmt) or die(ibase_errmsg());

?>

参见

  • ibase_errmsg() - Return error messages
  • ibase_fetch_row() - Fetch a row from an InterBase database
  • ibase_fetch_object() - Get an object from a InterBase database
  • ibase_free_result() - Free a result set


Initiates a restore task in the service manager and returns immediately

  • ? ibase_query
  • ibase_rollback_ret ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Initiates a restore task in the service manager and returns immediately

ibase_restore

(PHP 5, PHP 7 < 7.4.0)

ibase_restore — Initiates a restore task in the service manager and returns immediately

说明

ibase_restore ( resource $service_handle , string $source_file , string $dest_db , int $options = 0 , bool $verbose = false ) : mixed

This function passes the arguments to the (remote) database server. There it starts a new restore process. Therefore you won't get any responses.

参数

service_handle

A previously opened connection to the database server.

source_file

The absolute path on the server where the backup file is located.

dest_db

The path to create the new database on the server. You can also use database alias.

options

Additional options to pass to the database server for restore. The options parameter can be a combination of the following constants: IBASE_RES_DEACTIVATE_IDX, IBASE_RES_NO_SHADOW, IBASE_RES_NO_VALIDITY, IBASE_RES_ONE_AT_A_TIME, IBASE_RES_REPLACE, IBASE_RES_CREATE, IBASE_RES_USE_ALL_SPACE, IBASE_PRP_PAGE_BUFFERS, IBASE_PRP_SWEEP_INTERVAL, IBASE_RES_CREATE. Read the section about 预定义常量 for further information.

verbose

Since the restore process is done on the database server, you don't have any chance to get its output. This argument is useless.

返回值

成功时返回 true， 或者在失败时返回 false。

Since the restore process is done on the (remote) server, this function just passes the arguments to it. While the arguments are legal, you won't get false.

范例

Example #1 ibase_restore() example

<?php

// Attach to database server by ip address and port
$service = ibase_service_attach ('10.1.11.200/3050', 'sysdba', 'masterkey');

// Start the restore process on database server
// Restore employee backup to the new emps.fdb database
// Don't use any special arguments
ibase_restore($service, '/srv/backup/employees.fbk', '/srv/firebird/emps.fdb');

// Free the attached connection
ibase_service_detach ($service);
?>

Example #2 ibase_restore() example with arguments

<?php

// Attach to database server by name and default port
$service = ibase_service_attach ('fb-server.contoso.local', 'sysdba', 'masterkey');

// Start the restore process on database server
// Restore to employee database using alias.
// Restore without indixes. Replace existing database.
ibase_restore($service, '/srv/backup/employees.fbk', 'employees.fdb', IBASE_RES_DEACTIVATE_IDX | IBASE_RES_REPLACE);

// Free the attached connection
ibase_service_detach ($service);
?>

参见

  • ibase_backup() - Initiates a backup task in the service manager and returns immediately


Roll back a transaction without closing it

  • ? ibase_restore
  • ibase_rollback ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Roll back a transaction without closing it

ibase_rollback_ret

(PHP 5, PHP 7 < 7.4.0)

ibase_rollback_ret — Roll back a transaction without closing it

说明

ibase_rollback_ret ( resource $link_or_trans_identifier = null ) : bool

Rolls back a transaction without closing it.

参数

link_or_trans_identifier

If called without an argument, this function rolls back the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be rolled back. If the argument is a transaction identifier, the corresponding transaction will be rolled back. The transaction context will be retained, so statements executed from within this transaction will not be invalidated.

返回值

成功时返回 true， 或者在失败时返回 false。


Roll back a transaction

  • ? ibase_rollback_ret
  • ibase_server_info ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Roll back a transaction

ibase_rollback

(PHP 5, PHP 7 < 7.4.0)

ibase_rollback — Roll back a transaction

说明

ibase_rollback ( resource $link_or_trans_identifier = null ) : bool

Rolls back a transaction.

参数

link_or_trans_identifier

If called without an argument, this function rolls back the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be rolled back. If the argument is a transaction identifier, the corresponding transaction will be rolled back.

返回值

成功时返回 true， 或者在失败时返回 false。


Request information about a database server

  • ? ibase_rollback
  • ibase_service_attach ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Request information about a database server

ibase_server_info

(PHP 5, PHP 7 < 7.4.0)

ibase_server_info — Request information about a database server

说明

ibase_server_info ( resource $service_handle , int $action ) : string

参数

service_handle

A previously created connection to the database server.

action

A valid constant.

返回值

Returns mixed types depending on context.

范例

Example #1 ibase_service_attach() example

<?php
    // Attach to the remote Firebird server
    if (($service = ibase_service_attach('10.1.1.254/3050', 'sysdba', 'masterkey')) != FALSE) {

        // Successfully attached.

        // Output the info
        echo "Server version: " . ibase_server_info($service, IBASE_SVC_SERVER_VERSION) . "\n";
        echo "Server implementation: " . ibase_server_info($service, IBASE_SVC_IMPLEMENTATION) . "\n";
        echo "Server users: " . print_r(ibase_server_info($service, IBASE_SVC_GET_USERS), true) . "\n";
        echo "Server directory: " . ibase_server_info($service, IBASE_SVC_GET_ENV) . "\n";
        echo "Server lock path: " . ibase_server_info($service, IBASE_SVC_GET_ENV_LOCK) . "\n";
        echo "Server lib path: " . ibase_server_info($service, IBASE_SVC_GET_ENV_MSG) . "\n";
        echo "Path of user db: " . ibase_server_info($service, IBASE_SVC_USER_DBPATH) . "\n";
        echo "Established connections: " . print_r(ibase_server_info($service, IBASE_SVC_SVR_DB_INFO),true) . "\n";

        // Detach from server (disconnect)
        ibase_service_detach($service);

    }
    else {
        // Output message on error
        $conn_error = ibase_errmsg();
        die($conn_error);
    }
?>

以上例程会输出：

Server version: LI-V3.0.4.33054 Firebird 3.0
Server implementation: Firebird/Linux/AMD/Intel/x64
Server users: Array
(
    [0] => Array
        (
            [user_name] => SYSDBA
            [first_name] => Sql
            [middle_name] => Server
            [last_name] => Administrator
            [user_id] => 0
            [group_id] => 0
        )

)

Server directory: /etc/firebird/
Server lock path: /tmp/firebird/
Server lib path: /usr/lib64/firebird/lib/
Path of user db: /var/lib/firebird/secdb/security3.fdb
Established connections: Array
(
    [attachments] => 3
    [databases] => 2
    [0] => /srv/firebird/poss.fdb
    [1] => /srv/firebird/employees.fdb
)


Connect to the service manager

  • ? ibase_server_info
  • ibase_service_detach ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Connect to the service manager

ibase_service_attach

(PHP 5, PHP 7 < 7.4.0)

ibase_service_attach — Connect to the service manager

说明

ibase_service_attach ( string $host , string $dba_username , string $dba_password ) : resource|false

参数

host

The name or ip address of the database host. You can define the port by adding '/' and port number. If no port is specified, port 3050 will be used.

dba_username

The name of any valid user.

dba_password

The user's password.

返回值

Returns a Interbase / Firebird link identifier on success 或者在失败时返回 false.

范例

Example #1 ibase_service_attach() example

<?php
    // Attach to the remote Firebird server by ip address
    if (($service = ibase_service_attach('10.1.1.199', 'sysdba', 'masterkey')) != FALSE) {

        // Successfully attached.
        // Fetch server version (something like 'LI-V3.0.4.33054 Firebird 3.0')
        $server_version  = ibase_server_info($service, IBASE_SVC_SERVER_VERSION);

        // Fetch server implementation (something like 'Firebird/Linux/AMD/Intel/x64')
        $server_implementation = ibase_server_info($service, IBASE_SVC_IMPLEMENTATION);

        // Detach from server (disconnect)
        ibase_service_detach($service);

        // Output the info
        echo "Server version: " . $server_version . "<br/>";
        echo "Server implementation: " . $server_implementation;
    }
    else {
        // Output message on error
        $conn_error = ibase_errmsg();
        die($conn_error);
    }

?>

Example #2 ibase_service_attach() example using hostname/port syntax

<?php
    // Attach to the remote Firebird server by name. Use Port 3050.
    if (($service = ibase_service_attach('FB-SRV-01.contoso.local/3050', 'sysdba', 'masterkey')) != FALSE) {

        // Successfully attached.
        // Fetch server version (something like 'LI-V3.0.4.33054 Firebird 3.0')
        $server_version  = ibase_server_info($service, IBASE_SVC_SERVER_VERSION);

        // Fetch server implementation (something like 'Firebird/Linux/AMD/Intel/x64')
        $server_implementation = ibase_server_info($service, IBASE_SVC_IMPLEMENTATION);

        // Detach from server (disconnect)
        ibase_service_detach($service);

        // Output the info
        echo "Server version: " . $server_version . "<br/>";
        echo "Server implementation: " . $server_implementation;
    }
    else {
        // Output message on error
        $conn_error = ibase_errmsg();
        die($conn_error);
    }

?>

参见

  • ibase_service_detach() - Disconnect from the service manager


Disconnect from the service manager

  • ? ibase_service_attach
  • ibase_set_event_handler ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Disconnect from the service manager

ibase_service_detach

(PHP 5, PHP 7 < 7.4.0)

ibase_service_detach — Disconnect from the service manager

说明

ibase_service_detach ( resource $service_handle ) : bool

参数

service_handle

A previously created connection to the database server.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ibase_service_detach() example

<?php
    // Attach to the remote Firebird server by ip address
    if (($service = ibase_service_attach('10.1.1.199', 'sysdba', 'masterkey')) != FALSE) {

        // Successfully attached.
        // Fetch server version (something like 'LI-V3.0.4.33054 Firebird 3.0')
        $server_version  = ibase_server_info($service, IBASE_SVC_SERVER_VERSION);

        // Fetch server implementation (something like 'Firebird/Linux/AMD/Intel/x64')
        $server_implementation = ibase_server_info($service, IBASE_SVC_IMPLEMENTATION);

        // Detach from server (disconnect)
        if(ibase_service_detach($service) == FALSE) {
            echo "Error on service detach.";
        }
        else {
            echo "Successfully detached from service.";
        }

    }
    else {
        // Output message on error
        $conn_error = ibase_errmsg();
        die($conn_error);
    }

?>


Register a callback function to be called when events are posted

  • ? ibase_service_detach
  • ibase_trans ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Register a callback function to be called when events are posted

ibase_set_event_handler

(PHP 5, PHP 7 < 7.4.0)

ibase_set_event_handler — Register a callback function to be called when events are posted

说明

ibase_set_event_handler ( callable $event_handler , string $event_name , string ...$even_names ) : resource
ibase_set_event_handler ( resource $connection , callable $event_handler , string $event_name , string ...$event_names ) : resource

This function registers a PHP user function as event handler for the specified events.

参数

event_handler

The callback is called with the event name and the link resource as arguments whenever one of the specified events is posted by the database.

The callback must return false if the event handler should be canceled. Any other return value is ignored. This function accepts up to 15 event arguments.

event_name

An event name.

event_names

At most 15 events allowed.

返回值

The return value is an event resource. This resource can be used to free the event handler using ibase_free_event_handler().

范例

Example #1 ibase_set_event_handler() example

<?php

function event_handler($event_name, $link)
{
    if ($event_name == "NEW ORDER") {
        // process new order
        ibase_query($link, "UPDATE orders SET status='handled'");
    } else if ($event_name == "DB_SHUTDOWN") {
        // free event handler
        return false;
    }
}

ibase_set_event_handler($link, "event_handler", "NEW_ORDER", "DB_SHUTDOWN");
?>

参见

  • ibase_free_event_handler() - Cancels a registered event handler
  • ibase_wait_event() - Wait for an event to be posted by the database


Begin a transaction

  • ? ibase_set_event_handler
  • ibase_wait_event ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Begin a transaction

ibase_trans

(PHP 5, PHP 7 < 7.4.0)

ibase_trans — Begin a transaction

说明

ibase_trans ( int $trans_args = ? , resource $link_identifier = ? ) : resource
ibase_trans ( resource $link_identifier = ? , int $trans_args = ? ) : resource

Begins a transaction.

Note:

The first call to ibase_trans() will not return the default transaction of a connection. All transactions started by ibase_trans() will be rolled back at the end of the script if they were not committed or rolled back by either ibase_commit() or ibase_rollback().

Note:

This function will accept multiple trans_args and link_identifier arguments. This allows transactions over multiple database connections, which are committed using a 2-phase commit algorithm. This means you can rely on the updates to either succeed in every database, or fail in every database. It does NOT mean you can use tables from different databases in the same query!

If you use transactions over multiple databases, you will have to specify both the link_id and transaction_id in calls to ibase_query() and ibase_prepare().

参数

trans_args

trans_args can be a combination of IBASE_READ, IBASE_WRITE, IBASE_COMMITTED, IBASE_CONSISTENCY, IBASE_CONCURRENCY, IBASE_REC_VERSION, IBASE_REC_NO_VERSION, IBASE_WAIT and IBASE_NOWAIT.

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

返回值

Returns a transaction handle, or false on error.


Wait for an event to be posted by the database

  • ? ibase_trans
  • FrontBase ?
  • PHP Manual
  • Firebird/InterBase 函数
  • Wait for an event to be posted by the database

ibase_wait_event

(PHP 5, PHP 7 < 7.4.0)

ibase_wait_event — Wait for an event to be posted by the database

说明

ibase_wait_event ( string $event_name , string ...$event_names ) : string
ibase_wait_event ( resource $connection , string $event_name , string ...$event_names ) : string

This function suspends execution of the script until one of the specified events is posted by the database. The name of the event that was posted is returned. This function accepts up to 15 event arguments.

参数

event_name

The event name.

event_names

返回值

Returns the name of the event that was posted.

参见

  • ibase_set_event_handler() - Register a callback function to be called when events are posted
  • ibase_free_event_handler() - Cancels a registered event handler


FrontBase

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • FrontBase 函数
    • fbsql_affected_rows — Get number of affected rows in previous FrontBase operation
    • fbsql_autocommit — Enable or disable autocommit
    • fbsql_blob_size — Get the size of a BLOB
    • fbsql_change_user — Change logged in user of the active connection
    • fbsql_clob_size — Get the size of a CLOB
    • fbsql_close — Close FrontBase connection
    • fbsql_commit — Commits a transaction to the database
    • fbsql_connect — Open a connection to a FrontBase Server
    • fbsql_create_blob — Create a BLOB
    • fbsql_create_clob — Create a CLOB
    • fbsql_create_db — Create a FrontBase database
    • fbsql_data_seek — Move internal result pointer
    • fbsql_database_password — Sets or retrieves the password for a FrontBase database
    • fbsql_database — Get or set the database name used with a connection
    • fbsql_db_query — Send a FrontBase query
    • fbsql_db_status — Get the status for a given database
    • fbsql_drop_db — Drop (delete) a FrontBase database
    • fbsql_errno — Returns the error number from previous operation
    • fbsql_error — Returns the error message from previous operation
    • fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
    • fbsql_fetch_assoc — Fetch a result row as an associative array
    • fbsql_fetch_field — Get column information from a result and return as an object
    • fbsql_fetch_lengths — Get the length of each output in a result
    • fbsql_fetch_object — Fetch a result row as an object
    • fbsql_fetch_row — Get a result row as an enumerated array
    • fbsql_field_flags — Get the flags associated with the specified field in a result
    • fbsql_field_len — Returns the length of the specified field
    • fbsql_field_name — Get the name of the specified field in a result
    • fbsql_field_seek — Set result pointer to a specified field offset
    • fbsql_field_table — Get name of the table the specified field is in
    • fbsql_field_type — Get the type of the specified field in a result
    • fbsql_free_result — Free result memory
    • fbsql_get_autostart_info — 说明
    • fbsql_hostname — Get or set the host name used with a connection
    • fbsql_insert_id — Get the id generated from the previous INSERT operation
    • fbsql_list_dbs — List databases available on a FrontBase server
    • fbsql_list_fields — List FrontBase result fields
    • fbsql_list_tables — List tables in a FrontBase database
    • fbsql_next_result — Move the internal result pointer to the next result
    • fbsql_num_fields — Get number of fields in result
    • fbsql_num_rows — Get number of rows in result
    • fbsql_password — Get or set the user password used with a connection
    • fbsql_pconnect — Open a persistent connection to a FrontBase Server
    • fbsql_query — Send a FrontBase query
    • fbsql_read_blob — Read a BLOB from the database
    • fbsql_read_clob — Read a CLOB from the database
    • fbsql_result — Get result data
    • fbsql_rollback — Rollback a transaction to the database
    • fbsql_rows_fetched — Get the number of rows affected by the last statement
    • fbsql_select_db — Select a FrontBase database
    • fbsql_set_characterset — Change input/output character set
    • fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set
    • fbsql_set_password — Change the password for a given user
    • fbsql_set_transaction — Set the transaction locking and isolation
    • fbsql_start_db — Start a database on local or remote server
    • fbsql_stop_db — Stop a database on local or remote server
    • fbsql_table_name — Get table name of field
    • fbsql_tablename — 别名 fbsql_table_name
    • fbsql_username — Get or set the username for the connection
    • fbsql_warnings — Enable or disable FrontBase warnings


简介

These functions allow you to access FrontBase database servers. More information about FrontBase can be found at » http://www.frontbase.com/.

Documentation for FrontBase can be found at » http://www.frontbase.com/cgi-bin/WebObjects/FBWebSite.woa.

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.3.0.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • FrontBase
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

You must install the FrontBase database server or at least the fbsql client libraries to use this functions. You can get FrontBase from » http://www.frontbase.com/.


安装

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.3.0

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处：.

In order to have these functions available, you must compile PHP with fbsql support by using the --with-fbsql[=DIR] option. If you use this option without specifying the path to fbsql, PHP will search for the fbsql client libraries in the default installation location for the platform. Users who installed FrontBase in a non standard directory should always specify the path to fbsql: --with-fbsql=/path/to/fbsql. This will force PHP to use the client libraries installed by FrontBase, avoiding any conflicts.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

FrontBase configuration options
名字 | 默认 | 可修改范围 | 更新日志
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM |
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM |
fbsql.autocommit | "1" | PHP_INI_SYSTEM |
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM |
fbsql.max_links | "128" | PHP_INI_SYSTEM |
fbsql.max_connections | "128" | PHP_INI_SYSTEM |
fbsql.max_results | "128" | PHP_INI_SYSTEM |
fbsql.batchSize | "1000" | PHP_INI_SYSTEM | Removed in PHP 5.1.0.
fbsql.default_host | NULL | PHP_INI_SYSTEM |
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM |
fbsql.default_password | "" | PHP_INI_SYSTEM |
fbsql.default_database | "" | PHP_INI_SYSTEM |
fbsql.default_database_password | "" | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

FBSQL_ASSOC (int)
FBSQL_NUM (int)
FBSQL_BOTH (int)
FBSQL_LOCK_DEFERRED (int)
FBSQL_LOCK_OPTIMISTIC (int)
FBSQL_LOCK_PESSIMISTIC (int)
FBSQL_ISO_READ_UNCOMMITTED (int)
FBSQL_ISO_READ_COMMITTED (int)
FBSQL_ISO_REPEATABLE_READ (int)
FBSQL_ISO_SERIALIZABLE (int)
FBSQL_ISO_VERSIONED (int)
FBSQL_UNKNOWN (int)
FBSQL_STOPPED (int)
FBSQL_STARTING (int)
FBSQL_RUNNING (int)
FBSQL_STOPPING (int)
FBSQL_NOEXEC (int)
FBSQL_LOB_DIRECT (int)
FBSQL_LOB_HANDLE (int)


FrontBase 函数

Table of Contents

  • fbsql_affected_rows — Get number of affected rows in previous FrontBase operation
  • fbsql_autocommit — Enable or disable autocommit
  • fbsql_blob_size — Get the size of a BLOB
  • fbsql_change_user — Change logged in user of the active connection
  • fbsql_clob_size — Get the size of a CLOB
  • fbsql_close — Close FrontBase connection
  • fbsql_commit — Commits a transaction to the database
  • fbsql_connect — Open a connection to a FrontBase Server
  • fbsql_create_blob — Create a BLOB
  • fbsql_create_clob — Create a CLOB
  • fbsql_create_db — Create a FrontBase database
  • fbsql_data_seek — Move internal result pointer
  • fbsql_database_password — Sets or retrieves the password for a FrontBase database
  • fbsql_database — Get or set the database name used with a connection
  • fbsql_db_query — Send a FrontBase query
  • fbsql_db_status — Get the status for a given database
  • fbsql_drop_db — Drop (delete) a FrontBase database
  • fbsql_errno — Returns the error number from previous operation
  • fbsql_error — Returns the error message from previous operation
  • fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_assoc — Fetch a result row as an associative array
  • fbsql_fetch_field — Get column information from a result and return as an object
  • fbsql_fetch_lengths — Get the length of each output in a result
  • fbsql_fetch_object — Fetch a result row as an object
  • fbsql_fetch_row — Get a result row as an enumerated array
  • fbsql_field_flags — Get the flags associated with the specified field in a result
  • fbsql_field_len — Returns the length of the specified field
  • fbsql_field_name — Get the name of the specified field in a result
  • fbsql_field_seek — Set result pointer to a specified field offset
  • fbsql_field_table — Get name of the table the specified field is in
  • fbsql_field_type — Get the type of the specified field in a result
  • fbsql_free_result — Free result memory
  • fbsql_get_autostart_info — 说明
  • fbsql_hostname — Get or set the host name used with a connection
  • fbsql_insert_id — Get the id generated from the previous INSERT operation
  • fbsql_list_dbs — List databases available on a FrontBase server
  • fbsql_list_fields — List FrontBase result fields
  • fbsql_list_tables — List tables in a FrontBase database
  • fbsql_next_result — Move the internal result pointer to the next result
  • fbsql_num_fields — Get number of fields in result
  • fbsql_num_rows — Get number of rows in result
  • fbsql_password — Get or set the user password used with a connection
  • fbsql_pconnect — Open a persistent connection to a FrontBase Server
  • fbsql_query — Send a FrontBase query
  • fbsql_read_blob — Read a BLOB from the database
  • fbsql_read_clob — Read a CLOB from the database
  • fbsql_result — Get result data
  • fbsql_rollback — Rollback a transaction to the database
  • fbsql_rows_fetched — Get the number of rows affected by the last statement
  • fbsql_select_db — Select a FrontBase database
  • fbsql_set_characterset — Change input/output character set
  • fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set
  • fbsql_set_password — Change the password for a given user
  • fbsql_set_transaction — Set the transaction locking and isolation
  • fbsql_start_db — Start a database on local or remote server
  • fbsql_stop_db — Stop a database on local or remote server
  • fbsql_table_name — Get table name of field
  • fbsql_tablename — 别名 fbsql_table_name
  • fbsql_username — Get or set the username for the connection
  • fbsql_warnings — Enable or disable FrontBase warnings


Get number of affected rows in previous FrontBase operation

  • ? FrontBase 函数
  • fbsql_autocommit ?
  • PHP Manual
  • FrontBase 函数
  • Get number of affected rows in previous FrontBase operation

fbsql_affected_rows

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_affected_rows — Get number of affected rows in previous FrontBase operation

说明

fbsql_affected_rows ( resource $link_identifier = ? ) : int

fbsql_affected_rows() returns the number of rows affected by the last INSERT, UPDATE or DELETE query associated with link_identifier.

Note:

If you are using transactions, you need to call fbsql_affected_rows() after your INSERT, UPDATE, or DELETE query, not after the commit.

If the last query was a DELETE query with no WHERE clause, all of the records will have been deleted from the table but this function will return zero.

Note:

When using UPDATE, FrontBase will not update columns where the new value is the same as the old value. This creates the possibility that fbsql_affected_rows() may not actually equal the number of rows matched, only the number of rows that were literally affected by the query.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

If the last query failed, this function will return -1.

参见

  • fbsql_num_rows() - Get number of rows in result


Enable or disable autocommit

  • ? fbsql_affected_rows
  • fbsql_blob_size ?
  • PHP Manual
  • FrontBase 函数
  • Enable or disable autocommit

fbsql_autocommit

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_autocommit — Enable or disable autocommit

说明

fbsql_autocommit ( resource $link_identifier , bool $OnOff = ? ) : bool

Returns the current autocommit status.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

OnOff

If this optional parameter is given the auto commit status will be changed.

With OnOff set to true each statement will be committed automatically, if no errors was found.

With OnOff set to false the user must commit or rollback the transaction using either fbsql_commit() or fbsql_rollback().

返回值

Returns the current autocommit status, as a boolean.

参见

  • fbsql_commit() - Commits a transaction to the database
  • fbsql_rollback() - Rollback a transaction to the database


Get the size of a BLOB

  • ? fbsql_autocommit
  • fbsql_change_user ?
  • PHP Manual
  • FrontBase 函数
  • Get the size of a BLOB

fbsql_blob_size

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_blob_size — Get the size of a BLOB

说明

fbsql_blob_size ( string $blob_handle , resource $link_identifier = ? ) : int

Returns the size of the given BLOB.

参数

blob_handle

A BLOB handle, returned by fbsql_create_blob().

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns the BLOB size as an integer, or false on error.

参见

  • fbsql_clob_size() - Get the size of a CLOB


Change logged in user of the active connection

  • ? fbsql_blob_size
  • fbsql_clob_size ?
  • PHP Manual
  • FrontBase 函数
  • Change logged in user of the active connection

fbsql_change_user

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_change_user — Change logged in user of the active connection

说明

fbsql_change_user ( string $user , string $password , string $database = ? , resource $link_identifier = ? ) : bool

fbsql_change_user() changes the logged in user of the specified connection. If the new user and password authorization fails, the current connected user stays active.

参数

user

The new user name.

password

The new user password.

database

If specified, this will be the default or current database after the user has been changed.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

成功时返回 true， 或者在失败时返回 false。


Get the size of a CLOB

  • ? fbsql_change_user
  • fbsql_close ?
  • PHP Manual
  • FrontBase 函数
  • Get the size of a CLOB

fbsql_clob_size

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_clob_size — Get the size of a CLOB

说明

fbsql_clob_size ( string $clob_handle , resource $link_identifier = ? ) : int

Returns the size of the given CLOB.

参数

clob_handle

A CLOB handle, returned by fbsql_create_clob().

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns the CLOB size as an integer, or false on error.

参见

  • fbsql_blob_size() - Get the size of a BLOB


Close FrontBase connection

  • ? fbsql_clob_size
  • fbsql_commit ?
  • PHP Manual
  • FrontBase 函数
  • Close FrontBase connection

fbsql_close

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_close — Close FrontBase connection

说明

fbsql_close ( resource $link_identifier = ? ) : bool

Closes the connection to the FrontBase server that's associated with the specified link identifier.

Using fbsql_close() isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 fbsql_close() example

<?php
$link = fbsql_connect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
echo "Connected successfully";
fbsql_close($link);
?>

参见

  • fbsql_connect() - Open a connection to a FrontBase Server
  • fbsql_pconnect() - Open a persistent connection to a FrontBase Server


Commits a transaction to the database

  • ? fbsql_close
  • fbsql_connect ?
  • PHP Manual
  • FrontBase 函数
  • Commits a transaction to the database

fbsql_commit

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_commit — Commits a transaction to the database

说明

fbsql_commit ( resource $link_identifier = ? ) : bool

Ends the current transaction by writing all inserts, updates and deletes to the disk and unlocking all row and table locks held by the transaction. This command is only needed if autocommit is set to false.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbsql_autocommit() - Enable or disable autocommit
  • fbsql_rollback() - Rollback a transaction to the database


Open a connection to a FrontBase Server

  • ? fbsql_commit
  • fbsql_create_blob ?
  • PHP Manual
  • FrontBase 函数
  • Open a connection to a FrontBase Server

fbsql_connect

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_connect — Open a connection to a FrontBase Server

说明

fbsql_connect
 ( string $hostname = ini_get("fbsql.default_host")
, string $username = ini_get("fbsql.default_user")
, string $password = ini_get("fbsql.default_password")
) : resource

fbsql_connect() establishes a connection to a FrontBase server.

If a second call is made to fbsql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling fbsql_close().

参数

hostname

The server host name.

username

The user name for the connection.

password

The password for the connection.

返回值

Returns a positive FrontBase link identifier on success, or false on errors.

范例

Example #1 fbsql_connect() example

<?php

$link = fbsql_connect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
echo "Connected successfully";
fbsql_close($link);

?>

参见

  • fbsql_pconnect() - Open a persistent connection to a FrontBase Server
  • fbsql_close() - Close FrontBase connection


Create a BLOB

  • ? fbsql_connect
  • fbsql_create_clob ?
  • PHP Manual
  • FrontBase 函数
  • Create a BLOB

fbsql_create_blob

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_create_blob — Create a BLOB

说明

fbsql_create_blob ( string $blob_data , resource $link_identifier = ? ) : string

Creates a BLOB from the given data.

参数

blob_data

The BLOB data.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns a resource handle to the newly created BLOB, which can be used with insert and update commands to store the BLOB in the database.

范例

Example #1 fbsql_create_blob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$filename = "blobfile.bin";
$fp = fopen($filename, "rb");
$blobdata = fread($fp, filesize($filename));
fclose($fp);

$blobHandle = fbsql_create_blob($blobdata, $link);

$sql = "INSERT INTO BLOB_TABLE (BLOB_COLUMN) VALUES ($blobHandle);";
$rs = fbsql_query($sql, $link);
?>

参见

  • fbsql_create_clob() - Create a CLOB
  • fbsql_read_blob() - Read a BLOB from the database
  • fbsql_read_clob() - Read a CLOB from the database
  • fbsql_set_lob_mode() - Set the LOB retrieve mode for a FrontBase result set


Create a CLOB

  • ? fbsql_create_blob
  • fbsql_create_db ?
  • PHP Manual
  • FrontBase 函数
  • Create a CLOB

fbsql_create_clob

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_create_clob — Create a CLOB

说明

fbsql_create_clob ( string $clob_data , resource $link_identifier = ? ) : string

Creates a CLOB from the given data.

参数

clob_data

The CLOB data.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns a resource handle to the newly created CLOB, which can be used with insert and update commands to store the CLOB in the database.

范例

Example #1 fbsql_create_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$filename = "clob_file.txt";
$fp = fopen($filename, "rb");
$clobdata = fread($fp, filesize($filename));
fclose($fp);

$clobHandle = fbsql_create_clob($clobdata, $link);

$sql = "INSERT INTO CLOB_TABLE (CLOB_COLUMN) VALUES ($clobHandle);";
$rs = fbsql_query($sql, $link);
?>

参见

  • fbsql_create_blob() - Create a BLOB
  • fbsql_read_blob() - Read a BLOB from the database
  • fbsql_read_clob() - Read a CLOB from the database
  • fbsql_set_lob_mode() - Set the LOB retrieve mode for a FrontBase result set


Create a FrontBase database

  • ? fbsql_create_clob
  • fbsql_data_seek ?
  • PHP Manual
  • FrontBase 函数
  • Create a FrontBase database

fbsql_create_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_create_db — Create a FrontBase database

说明

fbsql_create_db ( string $database_name , resource $link_identifier = ? , string $database_options = ? ) : bool

Attempts to create a new database on the specified server.

参数

database_name

The database name, as a string.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

database_options

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 fbsql_create_db() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
if (fbsql_create_db("my_db")) {
    echo "Database created successfully\n";
} else {
    printf("Error creating database: %s\n", fbsql_error());
}
?>

参见

  • fbsql_drop_db() - Drop (delete) a FrontBase database


Move internal result pointer

  • ? fbsql_create_db
  • fbsql_database_password ?
  • PHP Manual
  • FrontBase 函数
  • Move internal result pointer

fbsql_data_seek

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_data_seek — Move internal result pointer

说明

fbsql_data_seek ( resource $result , int $row_number ) : bool

Moves the internal row pointer of the FrontBase result associated with the specified result identifier to point to the specified row number.

The next call to fbsql_fetch_row() would return that row.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

row_number

The row number. Starts at 0.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 fbsql_data_seek() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");

fbsql_select_db("samp_db")
    or die("Could not select database");

$query = "SELECT last_name, first_name FROM friends;";
$result = fbsql_query($query)
    or die("Query failed");

// fetch rows in reverse order

for ($i = fbsql_num_rows($result) - 1; $i >=0; $i--) {
    if (!fbsql_data_seek($result, $i)) {
        printf("Cannot seek to row %d\n", $i);
        continue;
    }

    if (!($row = fbsql_fetch_object($result)))
        continue;

    echo $row->last_name . $row->first_name . "<br />\n";
}

fbsql_free_result($result);
?>


Sets or retrieves the password for a FrontBase database

  • ? fbsql_data_seek
  • fbsql_database ?
  • PHP Manual
  • FrontBase 函数
  • Sets or retrieves the password for a FrontBase database

fbsql_database_password

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_database_password — Sets or retrieves the password for a FrontBase database

说明

fbsql_database_password ( resource $link_identifier , string $database_password = ? ) : string

Sets and retrieves the database password used by the connection. If a database is protected by a database password, the user must call this function before calling fbsql_select_db().

If no link is open, the function will try to establish a link as if fbsql_connect() was called, and use it.

This function does not change the database password in the database nor can it be used to retrieve the database password for a database.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

database_password

The database password, as a string. If given, the function sets the database password for the specified link identifier.

返回值

Returns the database password associated with the link identifier.

范例

Example #1 fbsql_create_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
fbsql_database_password($link, "secret db password");
fbsql_select_db($database, $link);
?>

参见

  • fbsql_connect() - Open a connection to a FrontBase Server
  • fbsql_pconnect() - Open a persistent connection to a FrontBase Server
  • fbsql_select_db() - Select a FrontBase database


Get or set the database name used with a connection

  • ? fbsql_database_password
  • fbsql_db_query ?
  • PHP Manual
  • FrontBase 函数
  • Get or set the database name used with a connection

fbsql_database

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_database — Get or set the database name used with a connection

说明

fbsql_database ( resource $link_identifier , string $database = ? ) : string

Get or set the database name used with the connection.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

database

The database name. If given, the default database of the connexion will be changed to database.

返回值

Returns the name of the database used with this connection.


Send a FrontBase query

  • ? fbsql_database
  • fbsql_db_status ?
  • PHP Manual
  • FrontBase 函数
  • Send a FrontBase query

fbsql_db_query

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_db_query — Send a FrontBase query

说明

fbsql_db_query ( string $database , string $query , resource $link_identifier = ? ) : resource

Selects a database and executes a query on it.

参数

database

The database to be selected.

query

The SQL query to be executed.

Note:

The query string shall always end with a semicolon.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns a positive FrontBase result identifier to the query result, or false on error.

参见

  • fbsql_query() - Send a FrontBase query
  • fbsql_connect() - Open a connection to a FrontBase Server


Get the status for a given database

  • ? fbsql_db_query
  • fbsql_drop_db ?
  • PHP Manual
  • FrontBase 函数
  • Get the status for a given database

fbsql_db_status

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0)

fbsql_db_status — Get the status for a given database

说明

fbsql_db_status ( string $database_name , resource $link_identifier = ? ) : int

Gets the current status of the specified database.

参数

database_name

The database name.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns an integer value with the current status. This can be one of the following constants:

  • false - The exec handler for the host was invalid. This error will occur when the link_identifier connects directly to a database by using a port number. FBExec can be available on the server but no connection has been made for it.
  • FBSQL_UNKNOWN - The Status is unknown.
  • FBSQL_STOPPED - The database is not running. Use fbsql_start_db() to start the database.
  • FBSQL_STARTING - The database is starting.
  • FBSQL_RUNNING - The database is running and can be used to perform SQL operations.
  • FBSQL_STOPPING - The database is stopping.
  • FBSQL_NOEXEC - FBExec is not running on the server and it is not possible to get the status of the database.

参见

  • fbsql_start_db() - Start a database on local or remote server
  • fbsql_stop_db() - Stop a database on local or remote server


Drop (delete) a FrontBase database

  • ? fbsql_db_status
  • fbsql_errno ?
  • PHP Manual
  • FrontBase 函数
  • Drop (delete) a FrontBase database

fbsql_drop_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_drop_db — Drop (delete) a FrontBase database

说明

fbsql_drop_db ( string $database_name , resource $link_identifier = ? ) : bool

fbsql_drop_db() attempts to drop (remove) an entire database from the server associated with the specified link identifier.

参数

database_name

The database name, as a string.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbsql_create_db() - Create a FrontBase database


Returns the error number from previous operation

  • ? fbsql_drop_db
  • fbsql_error ?
  • PHP Manual
  • FrontBase 函数
  • Returns the error number from previous operation

fbsql_errno

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_errno — Returns the error number from previous operation

说明

fbsql_errno ( resource $link_identifier = ? ) : int

Returns the numerical value of the error message from previous FrontBase operation.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_errno() to retrieve the error code. Note that this function only returns the error code from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns the error number from the last fbsql function, or 0 (zero) if no error occurred.

范例

Example #1 fbsql_errno() Example

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

参见

  • fbsql_error() - Returns the error message from previous operation
  • fbsql_warnings() - Enable or disable FrontBase warnings


Returns the error message from previous operation

  • ? fbsql_errno
  • fbsql_fetch_array ?
  • PHP Manual
  • FrontBase 函数
  • Returns the error message from previous operation

fbsql_error

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_error — Returns the error message from previous operation

说明

fbsql_error ( resource $link_identifier = ? ) : string

Returns the error message from previous FrontBase operation.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_error() to retrieve the error text. Note that this function only returns the error code from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns the error text from the last fbsql function, or '' (the empty string) if no error occurred.

范例

Example #1 fbsql_error() Example

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

参见

  • fbsql_errno() - Returns the error number from previous operation
  • fbsql_warnings() - Enable or disable FrontBase warnings


Fetch a result row as an associative array, a numeric array, or both

  • ? fbsql_error
  • fbsql_fetch_assoc ?
  • PHP Manual
  • FrontBase 函数
  • Fetch a result row as an associative array, a numeric array, or both

fbsql_fetch_array

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both

说明

fbsql_fetch_array ( resource $result , int $result_type = ? ) : array

fbsql_fetch_array() is a combination of
fbsql_fetch_row() and
fbsql_fetch_assoc().

An important thing to note is that using fbsql_fetch_array() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

result_type

A constant and can take the following values: FBSQL_ASSOC, FBSQL_NUM, or FBSQL_BOTH.

When using FBSQL_BOTH, in addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

返回值

Returns an array that corresponds to the fetched row, or false if there are no more rows.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must the numeric index of the column or make an alias for the column.

select t1.f1 as foo t2.f1 as bar from t1, t2

范例

Example #1 fbsql_fetch_array() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select user_id, fullname from table");
while ($row = fbsql_fetch_array($result)) {
    echo "user_id: " . $row["user_id"] . "<br />\n";
    echo "user_id: " . $row[0] . "<br />\n";
    echo "fullname: " . $row["fullname"] . "<br />\n";
    echo "fullname: " . $row[1] . "<br />\n";
}
fbsql_free_result($result);
?>

参见

  • fbsql_fetch_row() - Get a result row as an enumerated array
  • fbsql_fetch_assoc() - Fetch a result row as an associative array
  • fbsql_fetch_object() - Fetch a result row as an object


Fetch a result row as an associative array

  • ? fbsql_fetch_array
  • fbsql_fetch_field ?
  • PHP Manual
  • FrontBase 函数
  • Fetch a result row as an associative array

fbsql_fetch_assoc

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_assoc — Fetch a result row as an associative array

说明

fbsql_fetch_assoc ( resource $result ) : array

Calling fbsql_fetch_assoc() is equivalent to calling fbsql_fetch_array() with FBSQL_ASSOC as second parameter. It only returns an associative array.

This is the way fbsql_fetch_array() originally worked. If you need the numeric indices as well as the associative, use fbsql_fetch_array().

An important thing to note is that using fbsql_fetch_assoc() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

Returns an associative array that corresponds to the fetched row, or false if there are no more rows.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use fbsql_fetch_array() and have it return the numeric indices as well.

范例

Example #1 fbsql_fetch_assoc() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_assoc($result)) {
    echo $row["user_id"];
    echo $row["fullname"];
}
fbsql_free_result($result);
?>

参见

  • fbsql_fetch_row() - Get a result row as an enumerated array
  • fbsql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_object() - Fetch a result row as an object


Get column information from a result and return as an object

  • ? fbsql_fetch_assoc
  • fbsql_fetch_lengths ?
  • PHP Manual
  • FrontBase 函数
  • Get column information from a result and return as an object

fbsql_fetch_field

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_field — Get column information from a result and return as an object

说明

fbsql_fetch_field ( resource $result , int $field_offset = ? ) : object

Used in order to obtain information about fields in a certain query result.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

field_offset

The numerical offset of the field. The field index starts at 0. If not specified, the next field that wasn't yet retrieved by fbsql_fetch_field() is retrieved.

返回值

Returns an object containing field information, or false on errors.

The properties of the object are:

  • name - column name
  • table - name of the table the column belongs to
  • max_length - maximum length of the column
  • not_null - 1 if the column cannot be null
  • type - the type of the column

范例

Example #1 fbsql_fetch_field() example

<?php
fbsql_connect($host, $user, $password)
    or die("Could not connect");
$result = fbsql_db_query("database", "select * from table")
    or die("Query failed");
# get column metadata
$i = 0;
while ($i < fbsql_num_fields($result)) {
    echo "Information for column $i:<br />\n";
    $meta = fbsql_fetch_field($result);
    if (!$meta) {
        echo "No information available<br />\n";
    }
    echo "<pre>
max_length:   $meta->max_length
name:         $meta->name
not_null:     $meta->not_null
table:        $meta->table
type:         $meta->type
</pre>";
    $i++;
}
fbsql_free_result($result);
?>

参见

  • fbsql_field_seek() - Set result pointer to a specified field offset


Get the length of each output in a result

  • ? fbsql_fetch_field
  • fbsql_fetch_object ?
  • PHP Manual
  • FrontBase 函数
  • Get the length of each output in a result

fbsql_fetch_lengths

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_lengths — Get the length of each output in a result

说明

fbsql_fetch_lengths ( resource $result ) : array

Stores the lengths of each result column in the last row returned by
fbsql_fetch_row(),
fbsql_fetch_array() and
fbsql_fetch_object() in an array.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

Returns an array, starting at offset 0, that corresponds to the lengths of each field in the last row fetched by fbsql_fetch_row(), or false on error.

参见

  • fbsql_fetch_row() - Get a result row as an enumerated array


Fetch a result row as an object

  • ? fbsql_fetch_lengths
  • fbsql_fetch_row ?
  • PHP Manual
  • FrontBase 函数
  • Fetch a result row as an object

fbsql_fetch_object

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_object — Fetch a result row as an object

说明

fbsql_fetch_object ( resource $result ) : object

fbsql_fetch_object() is similar to fbsql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to fbsql_fetch_array(), and almost as quick as fbsql_fetch_row() (the difference is insignificant).

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

Returns an object with properties that correspond to the fetched row, or false if there are no more rows.

范例

Example #1 fbsql_fetch_object() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
fbsql_free_result($result);
?>

参见

  • fbsql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_row() - Get a result row as an enumerated array
  • fbsql_fetch_assoc() - Fetch a result row as an associative array


Get a result row as an enumerated array

  • ? fbsql_fetch_object
  • fbsql_field_flags ?
  • PHP Manual
  • FrontBase 函数
  • Get a result row as an enumerated array

fbsql_fetch_row

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_fetch_row — Get a result row as an enumerated array

说明

fbsql_fetch_row ( resource $result ) : array

fbsql_fetch_row() fetches one row of data from the result associated with the specified result identifier.

Subsequent call to fbsql_fetch_row() would return the next row in the result set, or false if there are no more rows.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

Returns an array that corresponds to the fetched row where each result column is stored in an offset, starting at offset 0, or false if there are no more rows.

参见

  • fbsql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_assoc() - Fetch a result row as an associative array
  • fbsql_fetch_object() - Fetch a result row as an object
  • fbsql_data_seek() - Move internal result pointer
  • fbsql_fetch_lengths() - Get the length of each output in a result
  • fbsql_result() - Get result data


Get the flags associated with the specified field in a result

  • ? fbsql_fetch_row
  • fbsql_field_len ?
  • PHP Manual
  • FrontBase 函数
  • Get the flags associated with the specified field in a result

fbsql_field_flags

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_flags — Get the flags associated with the specified field in a result

说明

fbsql_field_flags ( resource $result , int $field_offset = ? ) : string

Gets the flags associated with the specified field in a result.

参数

result

A result pointer returned by fbsql_list_fields().

field_offset

The numerical offset of the field. The field index starts at 0.

返回值

Returns the field flags of the specified field as a single word per flag separated by a single space, so that you can split the returned value using explode().


Returns the length of the specified field

  • ? fbsql_field_flags
  • fbsql_field_name ?
  • PHP Manual
  • FrontBase 函数
  • Returns the length of the specified field

fbsql_field_len

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_len — Returns the length of the specified field

说明

fbsql_field_len ( resource $result , int $field_offset = ? ) : int

Returns the length of the specified field.

参数

result

A result pointer returned by fbsql_list_fields().

field_offset

The numerical offset of the field. The field index starts at 0.

返回值

Returns the length of the specified field.


Get the name of the specified field in a result

  • ? fbsql_field_len
  • fbsql_field_seek ?
  • PHP Manual
  • FrontBase 函数
  • Get the name of the specified field in a result

fbsql_field_name

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_name — Get the name of the specified field in a result

说明

fbsql_field_name ( resource $result , int $field_index = ? ) : string

Returns the name of the specified field index.

参数

result

A result pointer returned by fbsql_list_fields().

field_index

The numerical offset of the field. The field index starts at 0.

返回值

Returns the name as a string, or false if the field doesn't exist.

范例

Example #1 fbsql_field_name() example

<?php
// The users table consists of three fields:
//   user_id
//   username
//   password.

$res = fbsql_db_query("users", "select * from users", $link);

echo fbsql_field_name($res, 0) . "\n";
echo fbsql_field_name($res, 2);
?>

以上例程会输出：

user_id
password

参见

  • fbsql_field_type() - Get the type of the specified field in a result


Set result pointer to a specified field offset

  • ? fbsql_field_name
  • fbsql_field_table ?
  • PHP Manual
  • FrontBase 函数
  • Set result pointer to a specified field offset

fbsql_field_seek

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_seek — Set result pointer to a specified field offset

说明

fbsql_field_seek ( resource $result , int $field_offset = ? ) : bool

Seeks to the specified field offset. If the next call to fbsql_fetch_field() doesn't include a field offset, the field offset specified in fbsql_field_seek() will be returned.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

field_offset

The numerical offset of the field. The field index starts at 0.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbsql_fetch_field() - Get column information from a result and return as an object


Get name of the table the specified field is in

  • ? fbsql_field_seek
  • fbsql_field_type ?
  • PHP Manual
  • FrontBase 函数
  • Get name of the table the specified field is in

fbsql_field_table

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_table — Get name of the table the specified field is in

说明

fbsql_field_table ( resource $result , int $field_offset = ? ) : string

Returns the name of the table that the specified field is in.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

field_offset

The numerical offset of the field. The field index starts at 0.

返回值

Returns the name of the table, as a string.


Get the type of the specified field in a result

  • ? fbsql_field_table
  • fbsql_free_result ?
  • PHP Manual
  • FrontBase 函数
  • Get the type of the specified field in a result

fbsql_field_type

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_field_type — Get the type of the specified field in a result

说明

fbsql_field_type ( resource $result , int $field_offset = ? ) : string

fbsql_field_type() is similar to the fbsql_field_name() function, but the field type is returned instead.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

field_offset

The numerical offset of the field. The field index starts at 0.

返回值

Returns the field type, as a string.

This can be one of int, real, string, blob, and others as detailed in the » FrontBase documentation.

范例

Example #1 fbsql_field_type() example

<?php

fbsql_connect("localhost", "_SYSTEM", "");
fbsql_select_db("wisconsin");
$result = fbsql_query("SELECT * FROM onek;");
$fields = fbsql_num_fields($result);
$rows   = fbsql_num_rows($result);
$i = 0;
$table = fbsql_field_table($result, $i);
echo "Your '" . $table . "' table has " . $fields . " fields and " . $rows . " records <br />";
echo "The table has the following fields <br />";
while ($i < $fields) {
    $type  = fbsql_field_type($result, $i);
    $name  = fbsql_field_name($result, $i);
    $len   = fbsql_field_len($result, $i);
    $flags = fbsql_field_flags($result, $i);
    echo $type . " " . $name . " " . $len . " " . $flags . "<br />";
    $i++;
}
fbsql_close();

?>

参见

  • fbsql_field_name() - Get the name of the specified field in a result


Free result memory

  • ? fbsql_field_type
  • fbsql_get_autostart_info ?
  • PHP Manual
  • FrontBase 函数
  • Free result memory

fbsql_free_result

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_free_result — Free result memory

说明

fbsql_free_result ( resource $result ) : bool

Frees all memory associated with the given result identifier.

fbsql_free_result() only needs to be called if you are concerned about how much memory is being used for queries that return large result sets. All associated result memory is automatically freed at the end of the script's execution.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

成功时返回 true， 或者在失败时返回 false。


说明

  • ? fbsql_free_result
  • fbsql_hostname ?
  • PHP Manual
  • FrontBase 函数
  • 说明

fbsql_get_autostart_info

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0)

fbsql_get_autostart_info —

说明

fbsql_get_autostart_info ( resource $link_identifier = ? ) : array
Warning

本函数还未编写文档，仅有参数列表。

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。


Get or set the host name used with a connection

  • ? fbsql_get_autostart_info
  • fbsql_insert_id ?
  • PHP Manual
  • FrontBase 函数
  • Get or set the host name used with a connection

fbsql_hostname

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_hostname — Get or set the host name used with a connection

说明

fbsql_hostname ( resource $link_identifier , string $host_name = ? ) : string

Gets or sets the host name used with a connection.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

host_name

If provided, this will be the new connection host name.

返回值

Returns the current host name used for the connection.

参见

  • fbsql_username() - Get or set the username for the connection
  • fbsql_password() - Get or set the user password used with a connection


Get the id generated from the previous INSERT operation

  • ? fbsql_hostname
  • fbsql_list_dbs ?
  • PHP Manual
  • FrontBase 函数
  • Get the id generated from the previous INSERT operation

fbsql_insert_id

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_insert_id — Get the id generated from the previous INSERT operation

说明

fbsql_insert_id ( resource $link_identifier = ? ) : int

Gets the id generated from the previous INSERT operation which created a DEFAULT UNIQUE value.

Note:

The value of the FrontBase SQL function fbsql_insert_id() always contains the most recently generated DEFAULT UNIQUE value, and is not reset between queries.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns the ID generated from the previous INSERT query, or 0 if the previous query does not generate an DEFAULT UNIQUE value.

If you need to save the value for later, be sure to call this function immediately after the query that generates the value.

参见

  • fbsql_affected_rows() - Get number of affected rows in previous FrontBase operation


List databases available on a FrontBase server

  • ? fbsql_insert_id
  • fbsql_list_fields ?
  • PHP Manual
  • FrontBase 函数
  • List databases available on a FrontBase server

fbsql_list_dbs

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_list_dbs — List databases available on a FrontBase server

说明

fbsql_list_dbs ( resource $link_identifier = ? ) : resource

Return a result pointer containing the databases available from the current fbsql daemon. Use the fbsql_tablename() to traverse this result pointer.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns a result pointer or false on error.

范例

Example #1 fbsql_list_dbs() example

<?php
$link = fbsql_connect('localhost', 'myname', 'secret');
$db_list = fbsql_list_dbs($link);

while ($row = fbsql_fetch_object($db_list)) {
    echo $row->Database . "\n";
}
?>

以上例程的输出类似于：

database1
database2
database3
...

Note:

The above code would just as easily work with fbsql_fetch_row() or other similar functions.

参见

  • fbsql_list_fields() - List FrontBase result fields
  • fbsql_list_tables() - List tables in a FrontBase database


List FrontBase result fields

  • ? fbsql_list_dbs
  • fbsql_list_tables ?
  • PHP Manual
  • FrontBase 函数
  • List FrontBase result fields

fbsql_list_fields

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_list_fields — List FrontBase result fields

说明

fbsql_list_fields ( string $database_name , string $table_name , resource $link_identifier = ? ) : resource

Retrieves information about the given table.

参数

database_name

The database name.

table_name

The table name.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns a result pointer which can be used with the fbsql_field_xxx functions, or false on error.

错误／异常

A string describing the error will be placed in $phperrmsg, and unless the function was called as @fbsql() then this error string will also be printed out.

范例

Example #1 fbsql_list_fields() example

<?php
$link = fbsql_connect('localhost', 'myname', 'secret');

$fields = fbsql_list_fields("database1", "table1", $link);
$columns = fbsql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
    echo fbsql_field_name($fields, $i) . "\n";;
}
?>

以上例程的输出类似于：

field1
field2
field3
...

参见

  • fbsql_field_len() - Returns the length of the specified field
  • fbsql_field_name() - Get the name of the specified field in a result
  • fbsql_field_type() - Get the type of the specified field in a result
  • fbsql_field_flags() - Get the flags associated with the specified field in a result


List tables in a FrontBase database

  • ? fbsql_list_fields
  • fbsql_next_result ?
  • PHP Manual
  • FrontBase 函数
  • List tables in a FrontBase database

fbsql_list_tables

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_list_tables — List tables in a FrontBase database

说明

fbsql_list_tables ( string $database , resource $link_identifier = ? ) : resource

Returns a result pointer describing the database.

参数

database

The database name.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns a result pointer which can be used with the fbsql_tablename() function to read the actual table names, or false on error.

参见

  • fbsql_list_fields() - List FrontBase result fields
  • fbsql_list_dbs() - List databases available on a FrontBase server


Move the internal result pointer to the next result

  • ? fbsql_list_tables
  • fbsql_num_fields ?
  • PHP Manual
  • FrontBase 函数
  • Move the internal result pointer to the next result

fbsql_next_result

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_next_result — Move the internal result pointer to the next result

说明

fbsql_next_result ( resource $result ) : bool

When sending more than one SQL statement to the server or executing a stored procedure with multiple results will cause the server to return multiple result sets. This function will test for additional results available form the server. If an additional result set exists it will free the existing result set and prepare to fetch the words from the new result set.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

Returns true if an additional result set was available or false otherwise.

范例

Example #1 fbsql_next_result() example

<?php
$link = fbsql_connect("localhost", "_SYSTEM", "secret");
fbsql_select_db("MyDB", $link);
$SQL = "Select * from table1; select * from table2;";
$rs = fbsql_query($SQL, $link);
do {
    while ($row = fbsql_fetch_row($rs)) {
    }
} while (fbsql_next_result($rs));
fbsql_free_result($rs);
fbsql_close($link);
?>


Get number of fields in result

  • ? fbsql_next_result
  • fbsql_num_rows ?
  • PHP Manual
  • FrontBase 函数
  • Get number of fields in result

fbsql_num_fields

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_num_fields — Get number of fields in result

说明

fbsql_num_fields ( resource $result ) : int

Returns the number of fields in the given result set.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

Returns the number of fields, as an integer.

参见

  • fbsql_db_query() - Send a FrontBase query
  • fbsql_query() - Send a FrontBase query
  • fbsql_fetch_field() - Get column information from a result and return as an object
  • fbsql_num_rows() - Get number of rows in result


Get number of rows in result

  • ? fbsql_num_fields
  • fbsql_password ?
  • PHP Manual
  • FrontBase 函数
  • Get number of rows in result

fbsql_num_rows

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_num_rows — Get number of rows in result

说明

fbsql_num_rows ( resource $result ) : int

Gets the number of rows in the given result set.

This function is only valid for SELECT statements. To retrieve the number of rows returned from a INSERT, UPDATE or DELETE query, use fbsql_affected_rows().

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

Returns the number of rows returned by the last SELECT statement.

范例

Example #1 fbsql_num_rows() example

<?php

$link = fbsql_connect("localhost", "username", "password");
fbsql_select_db("database", $link);

$result = fbsql_query("SELECT * FROM table1;", $link);
$num_rows = fbsql_num_rows($result);

echo "$num_rows Rows\n";

?>

参见

  • fbsql_affected_rows() - Get number of affected rows in previous FrontBase operation
  • fbsql_connect() - Open a connection to a FrontBase Server
  • fbsql_select_db() - Select a FrontBase database
  • fbsql_query() - Send a FrontBase query


Get or set the user password used with a connection

  • ? fbsql_num_rows
  • fbsql_pconnect ?
  • PHP Manual
  • FrontBase 函数
  • Get or set the user password used with a connection

fbsql_password

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_password — Get or set the user password used with a connection

说明

fbsql_password ( resource $link_identifier , string $password = ? ) : string

Get or set the user password used with a connection.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

password

If provided, this will be the new connection password.

返回值

Returns the current password used for the connection.

参见

  • fbsql_username() - Get or set the username for the connection
  • fbsql_hostname() - Get or set the host name used with a connection


Open a persistent connection to a FrontBase Server

  • ? fbsql_password
  • fbsql_query ?
  • PHP Manual
  • FrontBase 函数
  • Open a persistent connection to a FrontBase Server

fbsql_pconnect

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_pconnect — Open a persistent connection to a FrontBase Server

说明

fbsql_pconnect
 ( string $hostname = ini_get("fbsql.default_host")
, string $username = ini_get("fbsql.default_user")
, string $password = ini_get("fbsql.default_password")
) : resource

Establishes a persistent connection to a FrontBase server.

To set the server port number, use fbsql_select_db().

fbsql_pconnect() acts very much like fbsql_connect() with two major differences:

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use.

This type of links is therefore called 'persistent'.

参数

hostname

The server host name.

username

The user name for the connection.

password

The password for the connection.

返回值

Returns a positive FrontBase persistent link identifier on success, or false on error.

参见

  • fbsql_connect() - Open a connection to a FrontBase Server


Send a FrontBase query

  • ? fbsql_pconnect
  • fbsql_read_blob ?
  • PHP Manual
  • FrontBase 函数
  • Send a FrontBase query

fbsql_query

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_query — Send a FrontBase query

说明

fbsql_query ( string $query , resource $link_identifier = ? , int $batch_size = ? ) : resource

Sends a query to the currently active database on the server.

If the query succeeds, you can call fbsql_num_rows() to find out how many rows were returned for a SELECT statement or fbsql_affected_rows() to find out how many rows were affected by a DELETE, INSERT, REPLACE, or UPDATE statement.

参数

query

The SQL query to be executed.

Note:

The query string shall always end with a semicolon.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

batch_size

返回值

fbsql_query() returns true (non-zero) or false to indicate whether or not the query succeeded. A return value of true means that the query was legal and could be executed by the server. It does not indicate anything about the number of rows affected or returned. It is perfectly possible for a query to succeed but affect no rows or return no rows.

For SELECT statements, fbsql_query() returns a new result identifier that you can pass to fbsql_result().

fbsql_query() will also fail and return false if you don't have permission to access the table(s) referenced by the query.

范例

The following query is syntactically invalid, so fbsql_query() fails and returns false:

Example #1 fbsql_query() example

<?php
$result = fbsql_query("SELECT * WHERE 1=1")
    or die ("Invalid query");
?>

The following query is semantically invalid if my_col is not a column in the table my_tbl, so fbsql_query() fails and returns false:

Example #2 fbsql_query() example

<?php
$result = fbsql_query ("SELECT my_col FROM my_tbl;")
    or die ("Invalid query");
?>

参见

  • fbsql_affected_rows() - Get number of affected rows in previous FrontBase operation
  • fbsql_db_query() - Send a FrontBase query
  • fbsql_free_result() - Free result memory
  • fbsql_result() - Get result data
  • fbsql_select_db() - Select a FrontBase database
  • fbsql_connect() - Open a connection to a FrontBase Server


Read a BLOB from the database

  • ? fbsql_query
  • fbsql_read_clob ?
  • PHP Manual
  • FrontBase 函数
  • Read a BLOB from the database

fbsql_read_blob

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_read_blob — Read a BLOB from the database

说明

fbsql_read_blob ( string $blob_handle , resource $link_identifier = ? ) : string

Reads BLOB data from the database.

If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_blob() to get the actual BLOB data from the database.

参数

blob_handle

A BLOB handle, returned by fbsql_create_blob().

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns a string containing the specified BLOB data.

范例

Example #1 fbsql_read_blob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$sql = "SELECT BLOB_COLUMN FROM BLOB_TABLE;";
$rs = fbsql_query($sql, $link);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain the blob data for the first row
fbsql_free_result($rs);

$rs = fbsql_query($sql, $link);
fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain a handle to the BLOB data in the first row
$blob_data = fbsql_read_blob($row_data[0]);
fbsql_free_result($rs);

?>

参见

  • fbsql_create_blob() - Create a BLOB
  • fbsql_read_clob() - Read a CLOB from the database
  • fbsql_set_lob_mode() - Set the LOB retrieve mode for a FrontBase result set


Read a CLOB from the database

  • ? fbsql_read_blob
  • fbsql_result ?
  • PHP Manual
  • FrontBase 函数
  • Read a CLOB from the database

fbsql_read_clob

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_read_clob — Read a CLOB from the database

说明

fbsql_read_clob ( string $clob_handle , resource $link_identifier = ? ) : string

Reads CLOB data from the database.

If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_clob() to get the actual CLOB data from the database.

参数

clob_handle

A CLOB handle, returned by fbsql_create_clob().

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

Returns a string containing the specified CLOB data.

范例

Example #1 fbsql_read_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$sql = "SELECT CLOB_COLUMN FROM CLOB_TABLE;";
$rs = fbsql_query($sql, $link);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain the clob data for the first row
fbsql_free_result($rs);

$rs = fbsql_query($sql, $link);
fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain a handle to the CLOB data in the first row
$clob_data = fbsql_read_clob($row_data[0]);
fbsql_free_result($rs);

?>

参见

  • fbsql_create_clob() - Create a CLOB
  • fbsql_read_blob() - Read a BLOB from the database
  • fbsql_set_lob_mode() - Set the LOB retrieve mode for a FrontBase result set


Get result data

  • ? fbsql_read_clob
  • fbsql_rollback ?
  • PHP Manual
  • FrontBase 函数
  • Get result data

fbsql_result

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_result — Get result data

说明

fbsql_result ( resource $result , int $row = ? , mixed $field = ? ) : mixed

Returns the contents of one cell from a FrontBase result set.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than fbsql_result().

Calls to fbsql_result() should not be mixed with calls to other functions that deal with the result set.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

row

field

Can be the field's offset, or the field's name, or the field's table dot field's name (tablename.fieldname).

If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name.

Note:

Specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

返回值

参见

Recommended high-performance alternatives:

  • fbsql_fetch_row() - Get a result row as an enumerated array
  • fbsql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_assoc() - Fetch a result row as an associative array
  • fbsql_fetch_object() - Fetch a result row as an object


Rollback a transaction to the database

  • ? fbsql_result
  • fbsql_rows_fetched ?
  • PHP Manual
  • FrontBase 函数
  • Rollback a transaction to the database

fbsql_rollback

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_rollback — Rollback a transaction to the database

说明

fbsql_rollback ( resource $link_identifier = ? ) : bool

Ends the current transaction by rolling back all statements issued since last commit.

This command is only needed if autocommit is set to false.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbsql_autocommit() - Enable or disable autocommit
  • fbsql_commit() - Commits a transaction to the database


Get the number of rows affected by the last statement

  • ? fbsql_rollback
  • fbsql_select_db ?
  • PHP Manual
  • FrontBase 函数
  • Get the number of rows affected by the last statement

fbsql_rows_fetched

(PHP 5 >= 5.1.0 < 5.3.0)

fbsql_rows_fetched — Get the number of rows affected by the last statement

说明

fbsql_rows_fetched ( resource $result ) : int

Gets the number of rows affected by the last statement.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

返回值

Returns the number of rows, as an integer.


Select a FrontBase database

  • ? fbsql_rows_fetched
  • fbsql_set_characterset ?
  • PHP Manual
  • FrontBase 函数
  • Select a FrontBase database

fbsql_select_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_select_db — Select a FrontBase database

说明

fbsql_select_db ( string $database_name = ? , resource $link_identifier = ? ) : bool

Sets the current active database on the given link identifier.

The client contacts FBExec to obtain the port number to use for the connection to the database. If the database name is a number the system will use that as a port number and it will not ask FBExec for the port number. The FrontBase server can be stared as FRontBase -FBExec=No -port=<port number> <database name>.

Every subsequent call to fbsql_query() will be made on the active database.

参数

database_name

The name of the database to be selected.

If the database is protected with a database password, the you must call fbsql_database_password() before selecting the database.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbsql_connect() - Open a connection to a FrontBase Server
  • fbsql_pconnect() - Open a persistent connection to a FrontBase Server
  • fbsql_database_password() - Sets or retrieves the password for a FrontBase database
  • fbsql_query() - Send a FrontBase query


Change input/output character set

  • ? fbsql_select_db
  • fbsql_set_lob_mode ?
  • PHP Manual
  • FrontBase 函数
  • Change input/output character set

fbsql_set_characterset

(PHP 5 >= 5.1.0 < 5.3.0)

fbsql_set_characterset — Change input/output character set

说明

fbsql_set_characterset ( resource $link_identifier , int $characterset , int $in_out_both = ? ) : void
Warning

本函数还未编写文档，仅有参数列表。

返回值

没有返回值。


Set the LOB retrieve mode for a FrontBase result set

  • ? fbsql_set_characterset
  • fbsql_set_password ?
  • PHP Manual
  • FrontBase 函数
  • Set the LOB retrieve mode for a FrontBase result set

fbsql_set_lob_mode

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set

说明

fbsql_set_lob_mode ( resource $result , int $lob_mode ) : bool

Sets the mode for retrieving LOB data from the database.

When BLOB and CLOB data is retrieved in FrontBase it can be retrieved direct or indirect. Direct retrieved LOB data will always be fetched no matter the setting of the lob mode. If the LOB data is less than 512 bytes it will always be retrieved directly.

参数

result

由 fbsql_query() 或 fbsql_db_query() 返回的结果标识符。

lob_mode

Can be one of:

  • FBSQL_LOB_DIRECT - LOB data is retrieved directly. When data is fetched from the database with fbsql_fetch_row(), and other fetch functions, all CLOB and BLOB columns will be returned as ordinary columns. This is the default value on a new FrontBase result.
  • FBSQL_LOB_HANDLE - LOB data is retrieved as handles to the data. When data is fetched from the database with fbsql_fetch_row(), and other fetch functions, LOB data will be returned as a handle to the data if the data is stored indirect or the data if it is stored direct. If a handle is returned it will be a 27 byte string formatted as @'000000000000000000000000'.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbsql_create_blob() - Create a BLOB
  • fbsql_create_clob() - Create a CLOB
  • fbsql_read_blob() - Read a BLOB from the database
  • fbsql_read_clob() - Read a CLOB from the database


Change the password for a given user

  • ? fbsql_set_lob_mode
  • fbsql_set_transaction ?
  • PHP Manual
  • FrontBase 函数
  • Change the password for a given user

fbsql_set_password

(PHP 5 < 5.3.0)

fbsql_set_password — Change the password for a given user

说明

fbsql_set_password ( resource $link_identifier , string $user , string $password , string $old_password ) : bool

Changes the password for the given user.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

user

The user name.

password

The new password to be set.

old_password

The old password to be replaced.

返回值

成功时返回 true， 或者在失败时返回 false。


Set the transaction locking and isolation

  • ? fbsql_set_password
  • fbsql_start_db ?
  • PHP Manual
  • FrontBase 函数
  • Set the transaction locking and isolation

fbsql_set_transaction

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_set_transaction — Set the transaction locking and isolation

说明

fbsql_set_transaction ( resource $link_identifier , int $locking , int $isolation ) : void

Sets the transaction locking and isolation.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

locking

The type of locking to be set. It can be one of the following constants: FBSQL_LOCK_DEFERRED, FBSQL_LOCK_OPTIMISTIC, or FBSQL_LOCK_PESSIMISTIC.

isolation

The type of isolation to be set. It can be one of the following constants: FBSQL_ISO_READ_UNCOMMITTED, FBSQL_ISO_READ_COMMITTED, FBSQL_ISO_REPEATABLE_READ, FBSQL_ISO_SERIALIZABLE, or FBSQL_ISO_VERSIONED.

返回值

没有返回值。


Start a database on local or remote server

  • ? fbsql_set_transaction
  • fbsql_stop_db ?
  • PHP Manual
  • FrontBase 函数
  • Start a database on local or remote server

fbsql_start_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_start_db — Start a database on local or remote server

说明

fbsql_start_db ( string $database_name , resource $link_identifier = ? , string $database_options = ? ) : bool

Start a database on local or remote server.

参数

database_name

The database name.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

database_options

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbsql_db_status() - Get the status for a given database
  • fbsql_stop_db() - Stop a database on local or remote server


Stop a database on local or remote server

  • ? fbsql_start_db
  • fbsql_table_name ?
  • PHP Manual
  • FrontBase 函数
  • Stop a database on local or remote server

fbsql_stop_db

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_stop_db — Stop a database on local or remote server

说明

fbsql_stop_db ( string $database_name , resource $link_identifier = ? ) : bool

Stops a database on local or remote server.

参数

database_name

The database name.

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fbsql_db_status() - Get the status for a given database
  • fbsql_start_db() - Start a database on local or remote server


Get table name of field

  • ? fbsql_stop_db
  • fbsql_tablename ?
  • PHP Manual
  • FrontBase 函数
  • Get table name of field

fbsql_table_name

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_table_name — Get table name of field

说明

fbsql_table_name ( resource $result , int $index ) : string

fbsql_table_name() gets the name of the current table in the given result set.

The fbsql_num_rows() function may be used to determine the number of tables in the result pointer.

参数

result

A result pointer returned by fbsql_list_tables().

index

Integer index for the current table.

返回值

Returns the name of the table, as a string.

范例

Example #1 fbsql_table_name() example

<?php
fbsql_connect("localhost", "_SYSTEM", "");
$result = fbsql_list_tables("wisconsin");
$i = 0;
while ($i < fbsql_num_rows($result)) {
    $tb_names[$i] = fbsql_table_name($result, $i);
    echo $tb_names[$i] . "<br />";
    $i++;
}
?>


别名 fbsql_table_name

  • ? fbsql_table_name
  • fbsql_username ?
  • PHP Manual
  • FrontBase 函数
  • 别名 fbsql_table_name

fbsql_tablename

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0)

fbsql_tablename — 别名 fbsql_table_name()

说明

此函数是该函数的别名： fbsql_table_name().


Get or set the username for the connection

  • ? fbsql_tablename
  • fbsql_warnings ?
  • PHP Manual
  • FrontBase 函数
  • Get or set the username for the connection

fbsql_username

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_username — Get or set the username for the connection

说明

fbsql_username ( resource $link_identifier , string $username = ? ) : string

Get or set the username used for the connection.

参数

link_identifier

由 fbsql_connect() 或 fbsql_pconnect() 返回的 FrontBase 链接标识符.

如可选并未指定，函数会尝试查找一个到 FrontBase 服务器的开放链接，且如没有找到这样的链接，会尝试通过不带参数调用 fbsql_connect() 来创建一个。

username

If provided, this is the new username to set.

返回值

Returns the current username used with the connection, as a string.

参见

  • fbsql_password() - Get or set the user password used with a connection
  • fbsql_hostname() - Get or set the host name used with a connection


Enable or disable FrontBase warnings

  • ? fbsql_username
  • IBM DB2 ?
  • PHP Manual
  • FrontBase 函数
  • Enable or disable FrontBase warnings

fbsql_warnings

(PHP 4 >= 4.0.6, PHP 5 < 5.3.0)

fbsql_warnings — Enable or disable FrontBase warnings

说明

fbsql_warnings ( bool $OnOff = ? ) : bool

Enables or disables FrontBase warnings.

参数

OnOff

Whether to enable warnings or no.

返回值

Returns true if warnings is turned on, false otherwise.

参见

  • fbsql_errno() - Returns the error number from previous operation
  • fbsql_error() - Returns the error message from previous operation


IBM DB2, Cloudscape and Apache Derby

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • IBM DB2 函数
    • db2_autocommit — Returns or sets the AUTOCOMMIT state for a database connection
    • db2_bind_param — Binds a PHP variable to an SQL statement parameter
    • db2_client_info — Returns an object with properties that describe the DB2 database client
    • db2_close — Closes a database connection
    • db2_column_privileges — Returns a result set listing the columns and associated privileges for a table
    • db2_columns — Returns a result set listing the columns and associated metadata for a table
    • db2_commit — Commits a transaction
    • db2_conn_error — Returns a string containing the SQLSTATE returned by the last connection attempt
    • db2_conn_errormsg — Returns the last connection error message and SQLCODE value
    • db2_connect — Returns a connection to a database
    • db2_cursor_type — Returns the cursor type used by a statement resource
    • db2_escape_string — Used to escape certain characters
    • db2_exec — Executes an SQL statement directly
    • db2_execute — Executes a prepared SQL statement
    • db2_fetch_array — Returns an array, indexed by column position, representing a row in a result set
    • db2_fetch_assoc — Returns an array, indexed by column name, representing a row in a result set
    • db2_fetch_both — Returns an array, indexed by both column name and position, representing a row in a result set
    • db2_fetch_object — Returns an object with properties representing columns in the fetched row
    • db2_fetch_row — Sets the result set pointer to the next row or requested row
    • db2_field_display_size — Returns the maximum number of bytes required to display a column
    • db2_field_name — Returns the name of the column in the result set
    • db2_field_num — Returns the position of the named column in a result set
    • db2_field_precision — Returns the precision of the indicated column in a result set
    • db2_field_scale — Returns the scale of the indicated column in a result set
    • db2_field_type — Returns the data type of the indicated column in a result set
    • db2_field_width — Returns the width of the current value of the indicated column in a result set
    • db2_foreign_keys — Returns a result set listing the foreign keys for a table
    • db2_free_result — Frees resources associated with a result set
    • db2_free_stmt — Frees resources associated with the indicated statement resource
    • db2_get_option — Retrieves an option value for a statement resource or a connection resource
    • db2_last_insert_id — Returns the auto generated ID of the last insert query that successfully executed on this connection
    • db2_lob_read — Gets a user defined size of LOB files with each invocation
    • db2_next_result — Requests the next result set from a stored procedure
    • db2_num_fields — Returns the number of fields contained in a result set
    • db2_num_rows — Returns the number of rows affected by an SQL statement
    • db2_pclose — Closes a persistent database connection
    • db2_pconnect — Returns a persistent connection to a database
    • db2_prepare — Prepares an SQL statement to be executed
    • db2_primary_keys — Returns a result set listing primary keys for a table
    • db2_procedure_columns — Returns a result set listing stored procedure parameters
    • db2_procedures — Returns a result set listing the stored procedures registered in a database
    • db2_result — Returns a single column from a row in the result set
    • db2_rollback — Rolls back a transaction
    • db2_server_info — Returns an object with properties that describe the DB2 database server
    • db2_set_option — Set options for connection or statement resources
    • db2_special_columns — Returns a result set listing the unique row identifier columns for a table
    • db2_statistics — Returns a result set listing the index and statistics for a table
    • db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement
    • db2_stmt_errormsg — Returns a string containing the last SQL statement error message
    • db2_table_privileges — Returns a result set listing the tables and associated privileges in a database
    • db2_tables — Returns a result set listing the tables and associated metadata in a database


简介

These functions enable you to access IBM DB2 Universal Database, IBM Cloudscape, and Apache Derby databases using the DB2 Call Level Interface (DB2 CLI).


需求

To connect to IBM DB2 Universal Database for Linux, UNIX, and Windows, or IBM Cloudscape, or Apache Derby, you must install an IBM DB2 Universal Database client on the same computer on which you are running PHP. The extension has been developed and tested with DB2 Version 8.2.

To connect to IBM DB2 Universal Database for z/OS or iSeries, you also require IBM DB2 Connect or the equivalent DRDA gateway software.

Requirements on Linux or Unix

The user invoking the PHP executable or SAPI must specify the DB2 instance before accessing these functions. You can set the name of the DB2 instance in php.ini using the ibm_db2.instance_name configuration option, or you can source the DB2 instance profile before invoking the PHP executable.

If you created a DB2 instance named db2inst1 in /home/db2inst1/, for example, you can add the following line to php.ini:

ibm_db2.instance_name=db2inst1
If you do not set this option in php.ini, you must issue the following command to modify your environment variables to enable access to DB2:
bash$ source /home/db2inst1/sqllib/db2profile
To enable your PHP-enabled Web server to access these functions, you must either set the ibm_db2.instance_name configuration option in php.ini, or source the DB2 instance environment in your Web server start script (typically /etc/init.d/httpd or /etc/init.d/apache).


安装

To build the ibm_db2 extension, the DB2 application development header files and libraries must be installed on your system. DB2 does not install these by default, so you may have to return to your DB2 installer and add this option. The header files are included with the DB2 Application Development Client freely available for download from the IBM DB2 Universal Database » support site.

If you add the DB2 application development header files and libraries to a Linux or Unix operating system on which DB2 was already installed, you must issue the command db2iupdt -e to update the symbolic links to the header files and libraries in your DB2 instances.

ibm_db2 is a » PECL extension, so follow the instructions in PECL 扩展库安装 to install the ibm_db2 extension for PHP. Issue the configure command to point to the location of your DB2 header files and libraries as follows:

bash$ ./configure --with-IBM_DB2=/path/to/DB2
The configure command defaults to /opt/IBM/db2/V8.1.

Note: Note for IIS users

If you are using the ibm_db2 driver with Microsoft Internet Information Server (IIS) you may have to do the following:

  • Install DB2 with extended operating system security.
  • Add the PHP binary path to the PATH system environment variable (default C:\php\).
  • Create another system environment variable equal to the path where the PHP.INI file is located (eg: PHPRC = C:\php\).
  • Add the IUSR_COMPUTERNAME to the DB2USERS group.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

ibm_db2 配置选项
名字 | 默认 | 可修改范围 | Changelog
ibm_db2.binmode | "1" | PHP_INI_ALL |
ibm_db2.i5_all_pconnect | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.6.5.
ibm_db2.i5_allow_commit | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.4.9.
ibm_db2.i5_dbcs_alloc | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.5.0.
ibm_db2.instance_name | NULL | PHP_INI_SYSTEM | Available since ibm_db2 1.0.2.
ibm_db2.i5_ignore_userid | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.8.0.

这是配置指令的简短说明。

ibm_db2.binmode int

This option controls the mode used for converting to and from binary data in the PHP application.

  • 1 (DB2_BINARY)

  • 2 (DB2_CONVERT)

  • 3 (DB2_PASSTHRU)

ibm_db2.i5_all_pconnect int

This option overrides i5 db2_connect() full open and close in the PHP application. When ibm_db2.i5_all_pconnect = 1, all db2 connections become persistent (db2_pconnect()). On i5/OS, db2_pconnect() performs dramatically better with lower machine stress over db2_connect(). This is a convenience override of db2_connect() to evoke db2_pconnect() without PHP source code changes.

  • 0 db2_connect() default full open and close

  • 1 db2_connect() override to db2_pconnect() for persistent connection only

ibm_db2.i5_allow_commit int

This option controls the isolation mode used for i5 schema collections in the PHP application (see i5_commit for override).

  • 0 - commitment control is not used

  • 1 - read uncommitted, dirty reads possible.

  • 2 - read committed, dirty reads are not possible.

  • 3 - repeatable read, dirty reads and non-repeatable reads are not possible

  • 4 - serializeable, dirty reads, non-repeatable reads, and phantoms are not possible

ibm_db2.i5_dbcs_alloc int

This option controls the internal ibm_db2 allocation scheme for large DBCS column buffers.

  • 0 no expanded allocations (see i5_dbcs_alloc for override)

  • 1 use expanded allocations (see i5_dbcs_alloc for override)

ibm_db2.instance_name string

On Linux and UNIX operating systems, this option defines the name of the instance to use for cataloged database connections. If this option is set, its value overrides the DB2INSTANCE environment variable setting.

This option is ignored on Windows operating systems.

ibm_db2.i5_ignore_userid int

This option overrides i5 db2_(p)connect userid and password in the PHP application. When ibm_db2.i5_ignore_userid = 1, all db2 (p)connections become null userid and null password. Therefore Apache jobs connect with the current profile (NOBODY). Use of this override is only for simple DB2 based websites that never require profile switching and therefore can avoid all overhead of server mode additional QSQSRVR jobs. This is a convenience override of db2_(p)connect to set the userid and password values to null without PHP source code changes. This override can be used in combination with ibm_db2.i5_all_pconnect = 1.

  • 0 db2_(p)connect with specified userid and password

  • 1 db2_(p)connect override connect with null userid and null password


资源类型

The ibm_db2 extension returns connection resources, statement resources, and result set resources.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

DB2_BINARY (int)
Specifies that binary data shall be returned as is. This is the default mode.
DB2_CONVERT (int)
Specifies that binary data shall be converted to a hexadecimal encoding and returned as an ASCII string.
DB2_PASSTHRU (int)
Specifies that binary data shall be converted to a null value.
DB2_SCROLLABLE (int)
Specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.
DB2_FORWARD_ONLY (int)
Specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.
DB2_PARAM_IN (int)
Specifies the PHP variable should be bound as an IN parameter for a stored procedure.
DB2_PARAM_OUT (int)
Specifies the PHP variable should be bound as an OUT parameter for a stored procedure.
DB2_PARAM_INOUT (int)
Specifies the PHP variable should be bound as an INOUT parameter for a stored procedure.
DB2_PARAM_FILE (int)
Specifies that the column should be bound directly to a file for input.
DB2_AUTOCOMMIT_ON (int)
Specifies that autocommit should be turned on.
DB2_AUTOCOMMIT_OFF (int)
Specifies that autocommit should be turned off.
DB2_DOUBLE (int)
Specifies that the variable should be bound as a DOUBLE, FLOAT, or REAL data type.
DB2_LONG (int)
Specifies that the variable should be bound as a SMALLINT, INTEGER, or BIGINT data type.
DB2_CHAR (int)
Specifies that the variable should be bound as a CHAR or VARCHAR data type.
DB2_CASE_NATURAL (int)
Specifies that column names will be returned in their natural case.
DB2_CASE_LOWER (int)
Specifies that column names will be returned in lower case.
DB2_CASE_UPPER (int)
Specifies that column names will be returned in upper case.
DB2_DEFERRED_PREPARE_ON (int)
Specifies that deferred prepare should be turned on for the specified statement resource.
DB2_DEFERRED_PREPARE_OFF (int)
Specifies that deferred prepare should be turned off for the specified statement resource.


IBM DB2 函数

Table of Contents

  • db2_autocommit — Returns or sets the AUTOCOMMIT state for a database connection
  • db2_bind_param — Binds a PHP variable to an SQL statement parameter
  • db2_client_info — Returns an object with properties that describe the DB2 database client
  • db2_close — Closes a database connection
  • db2_column_privileges — Returns a result set listing the columns and associated privileges for a table
  • db2_columns — Returns a result set listing the columns and associated metadata for a table
  • db2_commit — Commits a transaction
  • db2_conn_error — Returns a string containing the SQLSTATE returned by the last connection attempt
  • db2_conn_errormsg — Returns the last connection error message and SQLCODE value
  • db2_connect — Returns a connection to a database
  • db2_cursor_type — Returns the cursor type used by a statement resource
  • db2_escape_string — Used to escape certain characters
  • db2_exec — Executes an SQL statement directly
  • db2_execute — Executes a prepared SQL statement
  • db2_fetch_array — Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc — Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both — Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object — Returns an object with properties representing columns in the fetched row
  • db2_fetch_row — Sets the result set pointer to the next row or requested row
  • db2_field_display_size — Returns the maximum number of bytes required to display a column
  • db2_field_name — Returns the name of the column in the result set
  • db2_field_num — Returns the position of the named column in a result set
  • db2_field_precision — Returns the precision of the indicated column in a result set
  • db2_field_scale — Returns the scale of the indicated column in a result set
  • db2_field_type — Returns the data type of the indicated column in a result set
  • db2_field_width — Returns the width of the current value of the indicated column in a result set
  • db2_foreign_keys — Returns a result set listing the foreign keys for a table
  • db2_free_result — Frees resources associated with a result set
  • db2_free_stmt — Frees resources associated with the indicated statement resource
  • db2_get_option — Retrieves an option value for a statement resource or a connection resource
  • db2_last_insert_id — Returns the auto generated ID of the last insert query that successfully executed on this connection
  • db2_lob_read — Gets a user defined size of LOB files with each invocation
  • db2_next_result — Requests the next result set from a stored procedure
  • db2_num_fields — Returns the number of fields contained in a result set
  • db2_num_rows — Returns the number of rows affected by an SQL statement
  • db2_pclose — Closes a persistent database connection
  • db2_pconnect — Returns a persistent connection to a database
  • db2_prepare — Prepares an SQL statement to be executed
  • db2_primary_keys — Returns a result set listing primary keys for a table
  • db2_procedure_columns — Returns a result set listing stored procedure parameters
  • db2_procedures — Returns a result set listing the stored procedures registered in a database
  • db2_result — Returns a single column from a row in the result set
  • db2_rollback — Rolls back a transaction
  • db2_server_info — Returns an object with properties that describe the DB2 database server
  • db2_set_option — Set options for connection or statement resources
  • db2_special_columns — Returns a result set listing the unique row identifier columns for a table
  • db2_statistics — Returns a result set listing the index and statistics for a table
  • db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg — Returns a string containing the last SQL statement error message
  • db2_table_privileges — Returns a result set listing the tables and associated privileges in a database
  • db2_tables — Returns a result set listing the tables and associated metadata in a database


Returns or sets the AUTOCOMMIT state for a database connection

  • ? IBM DB2 函数
  • db2_bind_param ?
  • PHP Manual
  • IBM DB2 函数
  • Returns or sets the AUTOCOMMIT state for a database connection

db2_autocommit

(PECL ibm_db2 >= 1.0.0)

db2_autocommit — Returns or sets the AUTOCOMMIT state for a database connection

说明

db2_autocommit ( resource $connection , bool $value = ? ) : mixed

Sets or gets the AUTOCOMMIT behavior of the specified connection resource.

参数

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

value

One of the following constants:

DB2_AUTOCOMMIT_OFF

Turns AUTOCOMMIT off.

DB2_AUTOCOMMIT_ON

Turns AUTOCOMMIT on.

返回值

When db2_autocommit() receives only the connection parameter, it returns the current state of AUTOCOMMIT for the requested connection as an integer value. A value of DB2_AUTOCOMMIT_OFF indicates that AUTOCOMMIT is off, while a value of DB2_AUTOCOMMIT_ON indicates that AUTOCOMMIT is on.

When db2_autocommit() receives both the connection parameter and autocommit parameter, it attempts to set the AUTOCOMMIT state of the requested connection to the corresponding state. 成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Retrieving the AUTOCOMMIT value for a connection

In the following example, a connection which has been created with AUTOCOMMIT turned off is tested with the db2_autocommit() function.

<?php
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);
$conn = db2_connect($database, $user, $password, $options);
$ac = db2_autocommit($conn);
if ($ac == DB2_AUTOCOMMIT_OFF) {
    print "$ac -- AUTOCOMMIT is off.";
} else {
    print "$ac -- AUTOCOMMIT is on.";
}
?>

以上例程会输出：

0 -- AUTOCOMMIT is off.

Example #2 Setting the AUTOCOMMIT value for a connection

In the following example, a connection which was initially created with AUTOCOMMIT turned off has its behavior changed to turn AUTOCOMMIT on.

<?php
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);
$conn = db2_connect($database, $user, $password, $options);

// Turn AUTOCOMMIT on
$rc = db2_autocommit($conn, DB2_AUTOCOMMIT_ON);
if ($rc) {
    print "Turning AUTOCOMMIT on succeeded.\n";
}

// Check AUTOCOMMIT state
$ac = db2_autocommit($conn);
if ($ac == DB2_AUTOCOMMIT_OFF) {
    print "$ac -- AUTOCOMMIT is off.";
} else {
    print "$ac -- AUTOCOMMIT is on.";
}
?>

以上例程会输出：

Turning AUTOCOMMIT on succeeded.
1 -- AUTOCOMMIT is on.

参见

  • db2_connect() - Returns a connection to a database
  • db2_pconnect() - Returns a persistent connection to a database


Binds a PHP variable to an SQL statement parameter

  • ? db2_autocommit
  • db2_client_info ?
  • PHP Manual
  • IBM DB2 函数
  • Binds a PHP variable to an SQL statement parameter

db2_bind_param

(PECL ibm_db2 >= 1.0.0)

db2_bind_param — Binds a PHP variable to an SQL statement parameter

说明

db2_bind_param ( resource $stmt , int $parameter_number , string $variable_name , int $parameter_type = ? , int $data_type = 0 , int $precision = -1 , int $scale = 0 ) : bool

Binds a PHP variable to an SQL statement parameter in a statement resource returned by db2_prepare(). This function gives you more control over the parameter type, data type, precision, and scale for the parameter than simply passing the variable as part of the optional input array to db2_execute().

参数

stmt

A prepared statement returned from db2_prepare().

parameter_number

Specifies the 1-indexed position of the parameter in the prepared statement.

variable_name

A string specifying the name of the PHP variable to bind to the parameter specified by parameter_number.

parameter_type

A constant specifying whether the PHP variable should be bound to the SQL parameter as an input parameter (DB2_PARAM_IN), an output parameter (DB2_PARAM_OUT), or as a parameter that accepts input and returns output (DB2_PARAM_INOUT). To avoid memory overhead, you can also specify DB2_PARAM_FILE to bind the PHP variable to the name of a file that contains large object (BLOB, CLOB, or DBCLOB) data.

data_type

A constant specifying the SQL data type that the PHP variable should be bound as: one of DB2_BINARY, DB2_CHAR, DB2_DOUBLE, or DB2_LONG .

precision

Specifies the precision with which the variable should be bound to the database. This parameter can also be used for retrieving XML output values from stored procedures. A non-negative value specifies the maximum size of the XML data that will be retrieved from the database. If this parameter is not used, a default of 1MB will be assumed for retrieving the XML output value from the stored procedure.

scale

Specifies the scale with which the variable should be bound to the database.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Binding PHP variables to a prepared statement

The SQL statement in the following example uses two input parameters in the WHERE clause. We call db2_bind_param() to bind two PHP variables to the corresponding SQL parameters. Notice that the PHP variables do not have to be declared or assigned before the call to db2_bind_param(); in the example, $lower_limit is assigned a value before the call to db2_bind_param(), but $upper_limit is assigned a value after the call to db2_bind_param(). The variables must be bound and, for parameters that accept input, must have any value assigned, before calling db2_execute().

<?php

$sql = 'SELECT name, breed, weight FROM animals
    WHERE weight > ? AND weight < ?';
$conn = db2_connect($database, $user, $password);
$stmt = db2_prepare($conn, $sql);

// We can declare the variable before calling db2_bind_param()
$lower_limit = 1;

db2_bind_param($stmt, 1, "lower_limit", DB2_PARAM_IN);
db2_bind_param($stmt, 2, "upper_limit", DB2_PARAM_IN);

// We can also declare the variable after calling db2_bind_param()
$upper_limit = 15.0;

if (db2_execute($stmt)) {
    while ($row = db2_fetch_array($stmt)) {
        print "{$row[0]}, {$row[1]}, {$row[2]}\n";
    }
}
?>

以上例程会输出：

Pook, cat, 3.2
Rickety Ride, goat, 9.7
Peaches, dog, 12.3

Example #2 Calling stored procedures with IN and OUT parameters

The stored procedure match_animal in the following example accepts three different parameters:

  1. an input (IN) parameter that accepts the name of the first animal as input

  2. an input-output (INOUT) parameter that accepts the name of the second animal as input and returns the string TRUE if an animal in the database matches that name

  3. an output (OUT) parameter that returns the sum of the weight of the two identified animals

In addition, the stored procedure returns a result set consisting of the animals listed in alphabetic order starting at the animal corresponding to the input value of the first parameter and ending at the animal corresponding to the input value of the second parameter.

<?php

$sql = 'CALL match_animal(?, ?, ?)';
$conn = db2_connect($database, $user, $password);
$stmt = db2_prepare($conn, $sql);

$name = "Peaches";
$second_name = "Rickety Ride";
$weight = 0;

db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
db2_bind_param($stmt, 2, "second_name", DB2_PARAM_INOUT);
db2_bind_param($stmt, 3, "weight", DB2_PARAM_OUT);

print "Values of bound parameters _before_ CALL:\n";
print "  1: {$name} 2: {$second_name} 3: {$weight}\n\n";

if (db2_execute($stmt)) {
    print "Values of bound parameters _after_ CALL:\n";
    print "  1: {$name} 2: {$second_name} 3: {$weight}\n\n";

    print "Results:\n";
    while ($row = db2_fetch_array($stmt)) {
        print "  {$row[0]}, {$row[1]}, {$row[2]}\n";
    }
}
?>

以上例程会输出：

Values of bound parameters _before_ CALL:
  1: Peaches 2: Rickety Ride 3: 0

Values of bound parameters _after_ CALL:
  1: Peaches 2: TRUE 3: 22

Results:
  Peaches, dog, 12.3
  Pook, cat, 3.2
  Rickety Ride, goat, 9.7

Example #3 Inserting a binary large object (BLOB) directly from a file

The data for large objects are typically stored in files, such as XML documents or audio files. Rather than reading an entire file into a PHP variable, and then binding that PHP variable into an SQL statement, you can avoid some memory overhead by binding the file directly to the input parameter of your SQL statement. The following example demonstrates how to bind a file directly into a BLOB column.

<?php
$stmt = db2_prepare($conn, "INSERT INTO animal_pictures(picture) VALUES (?)");

$picture = "/opt/albums/spook/grooming.jpg";
$rc = db2_bind_param($stmt, 1, "picture", DB2_PARAM_FILE);
$rc = db2_execute($stmt);
?>

参见

  • db2_execute() - Executes a prepared SQL statement
  • db2_prepare() - Prepares an SQL statement to be executed


Returns an object with properties that describe the DB2 database client

  • ? db2_bind_param
  • db2_close ?
  • PHP Manual
  • IBM DB2 函数
  • Returns an object with properties that describe the DB2 database client

db2_client_info

(PECL ibm_db2 >= 1.1.1)

db2_client_info — Returns an object with properties that describe the DB2 database client

说明

db2_client_info ( resource $connection ) : object

This function returns an object with read-only properties that return information about the DB2 database client. The following table lists the DB2 client properties:

DB2 client properties
Property name | Return type | Description
APPL_CODEPAGE | int | The application code page.
CONN_CODEPAGE | int | The code page for the current connection.
DATA_SOURCE_NAME | string | The data source name (DSN) used to create the current connection to the database.
DRIVER_NAME | string | The name of the library that implements the DB2 Call Level Interface (CLI) specification.
DRIVER_ODBC_VER | string | The version of ODBC that the DB2 client supports. This returns a string "MM.mm" where MM is the major version and mm is the minor version. The DB2 client always returns "03.51".
DRIVER_VER | string | The version of the client, in the form of a string "MM.mm.uuuu" where MM is the major version, mm is the minor version, and uuuu is the update. For example, "08.02.0001" represents major version 8, minor version 2, update 1.
ODBC_SQL_CONFORMANCE string

The level of ODBC SQL grammar supported by the client:

MINIMUM

Supports the minimum ODBC SQL grammar.

CORE

Supports the core ODBC SQL grammar.

EXTENDED

Supports extended ODBC SQL grammar.

ODBC_VER | string | The version of ODBC that the ODBC driver manager supports. This returns a string "MM.mm.rrrr" where MM is the major version, mm is the minor version, and rrrr is the release. The DB2 client always returns "03.01.0000".

参数

connection

Specifies an active DB2 client connection.

返回值

Returns an object on a successful call. Returns false on failure.

范例

Example #1 A db2_client_info() example

To retrieve information about the client, you must pass a valid database connection resource to db2_client_info().

<?php
$conn = db2_connect( 'SAMPLE', 'db2inst1', 'ibmdb2' );
$client = db2_client_info( $conn );

if ($client) {
    echo "DRIVER_NAME: ";           var_dump( $client->DRIVER_NAME );
    echo "DRIVER_VER: ";            var_dump( $client->DRIVER_VER );
    echo "DATA_SOURCE_NAME: ";      var_dump( $client->DATA_SOURCE_NAME );
    echo "DRIVER_ODBC_VER: ";       var_dump( $client->DRIVER_ODBC_VER );
    echo "ODBC_VER: ";              var_dump( $client->ODBC_VER );
    echo "ODBC_SQL_CONFORMANCE: ";  var_dump( $client->ODBC_SQL_CONFORMANCE );
    echo "APPL_CODEPAGE: ";         var_dump( $client->APPL_CODEPAGE );
    echo "CONN_CODEPAGE: ";         var_dump( $client->CONN_CODEPAGE );
}
else {
    echo "Error retrieving client information.
     Perhaps your database connection was invalid.";
}
db2_close($conn);

?>

以上例程会输出：

DRIVER_NAME: string(8) "libdb2.a"
DRIVER_VER: string(10) "08.02.0001"
DATA_SOURCE_NAME: string(6) "SAMPLE"
DRIVER_ODBC_VER: string(5) "03.51"
ODBC_VER: string(10) "03.01.0000"
ODBC_SQL_CONFORMANCE: string(8) "EXTENDED"
APPL_CODEPAGE: int(819)
CONN_CODEPAGE: int(819)

参见

  • db2_server_info() - Returns an object with properties that describe the DB2 database server


Closes a database connection

  • ? db2_client_info
  • db2_column_privileges ?
  • PHP Manual
  • IBM DB2 函数
  • Closes a database connection

db2_close

(PECL ibm_db2 >= 1.0.0)

db2_close — Closes a database connection

说明

db2_close ( resource $connection ) : bool

This function closes a DB2 client connection created with db2_connect() and returns the corresponding resources to the database server.

If you attempt to close a persistent DB2 client connection created with db2_pconnect(), the close request is ignored and the persistent DB2 client connection remains available for the next caller.

参数

connection

Specifies an active DB2 client connection.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Closing a connection

The following example demonstrates a successful attempt to close a connection to an IBM DB2, Cloudscape, or Apache Derby database.

<?php
$conn = db2_connect('SAMPLE', 'db2inst1', 'ibmdb2');
$rc = db2_close($conn);
if ($rc) {
    echo "Connection was successfully closed.";
}
?>

以上例程会输出：

Connection was successfully closed.

参见

  • db2_connect() - Returns a connection to a database
  • db2_pclose() - Closes a persistent database connection
  • db2_pconnect() - Returns a persistent connection to a database


Returns a result set listing the columns and associated privileges for a table

  • ? db2_close
  • db2_columns ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing the columns and associated privileges for a table

db2_column_privileges

(PECL ibm_db2 >= 1.0.0)

db2_column_privileges — Returns a result set listing the columns and associated privileges for a table

说明

db2_column_privileges ( resource $connection , string $qualifier = ? , string $schema = ? , string $table-name = ? , string $column-name = ? ) : resource

Returns a result set listing the columns and associated privileges for a table.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables. To match all schemas, pass null or an empty string.

table-name

The name of the table or view. To match all tables in the database, pass null or an empty string.

column-name

The name of the column. To match all columns in the table, pass null or an empty string.

返回值

Returns a statement resource with a result set containing rows describing the column privileges for columns matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema.
TABLE_NAME | Name of the table or view.
COLUMN_NAME | Name of the column.
GRANTOR | Authorization ID of the user who granted the privilege.
GRANTEE | Authorization ID of the user to whom the privilege was granted.
PRIVILEGE | The privilege for the column.
IS_GRANTABLE | Whether the GRANTEE is permitted to grant this privilege to other users.

参见

  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a result set listing the columns and associated metadata for a table

  • ? db2_column_privileges
  • db2_commit ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing the columns and associated metadata for a table

db2_columns

(PECL ibm_db2 >= 1.0.0)

db2_columns — Returns a result set listing the columns and associated metadata for a table

说明

db2_columns ( resource $connection , string $qualifier = ? , string $schema = ? , string $table-name = ? , string $column-name = ? ) : resource

Returns a result set listing the columns and associated metadata for a table.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables. To match all schemas, pass '%'.

table-name

The name of the table or view. To match all tables in the database, pass null or an empty string.

column-name

The name of the column. To match all columns in the table, pass null or an empty string.

返回值

Returns a statement resource with a result set containing rows describing the columns matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema.
TABLE_NAME | Name of the table or view.
COLUMN_NAME | Name of the column.
DATA_TYPE | The SQL data type for the column represented as an integer value.
TYPE_NAME | A string representing the data type for the column.
COLUMN_SIZE | An integer value representing the size of the column.
BUFFER_LENGTH | Maximum number of bytes necessary to store data from this column.
DECIMAL_DIGITS | The scale of the column, or null where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or null (representing a data type for which radix is not applicable).
NULLABLE | An integer value representing whether the column is nullable or not.
REMARKS | Description of the column.
COLUMN_DEF | Default value for the column.
SQL_DATA_TYPE | An integer value representing the size of the column.
SQL_DATETIME_SUB | Returns an integer value representing a datetime subtype code, or null for SQL data types to which this does not apply.
CHAR_OCTET_LENGTH | Maximum length in octets for a character data type column, which matches COLUMN_SIZE for single-byte character set data, or null for non-character data types.
ORDINAL_POSITION | The 1-indexed position of the column in the table.
IS_NULLABLE | A string value where 'YES' means that the column is nullable and 'NO' means that the column is not nullable.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Commits a transaction

  • ? db2_columns
  • db2_conn_error ?
  • PHP Manual
  • IBM DB2 函数
  • Commits a transaction

db2_commit

(PECL ibm_db2 >= 1.0.0)

db2_commit — Commits a transaction

说明

db2_commit ( resource $connection ) : bool

Commits an in-progress transaction on the specified connection resource and begins a new transaction. PHP applications normally default to AUTOCOMMIT mode, so db2_commit() is not necessary unless AUTOCOMMIT has been turned off for the connection resource.

参数

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • db2_autocommit() - Returns or sets the AUTOCOMMIT state for a database connection
  • db2_rollback() - Rolls back a transaction


Returns a string containing the SQLSTATE returned by the last connection attempt

  • ? db2_commit
  • db2_conn_errormsg ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a string containing the SQLSTATE returned by the last connection attempt

db2_conn_error

(PECL ibm_db2 >= 1.0.0)

db2_conn_error — Returns a string containing the SQLSTATE returned by the last connection attempt

说明

db2_conn_error ( resource $connection = ? ) : string

db2_conn_error() returns an SQLSTATE value representing the reason the last attempt to connect to a database failed. As db2_connect() returns false in the event of a failed connection attempt, you do not pass any parameters to db2_conn_error() to retrieve the SQLSTATE value.

If, however, the connection was successful but becomes invalid over time, you can pass the connection parameter to retrieve the SQLSTATE value for a specific connection.

To learn what the SQLSTATE value means, you can issue the following command at a DB2 Command Line Processor prompt: db2 '? sqlstate-value'. You can also call db2_conn_errormsg() to retrieve an explicit error message and the associated SQLCODE value.

参数

connection

A connection resource associated with a connection that initially succeeded, but which over time became invalid.

返回值

Returns the SQLSTATE value resulting from a failed connection attempt. Returns an empty string if there is no error associated with the last connection attempt.

范例

Example #1 Retrieving an SQLSTATE value for a failed connection attempt

The following example demonstrates how to return an SQLSTATE value after deliberately passing invalid parameters to db2_connect().

<?php
$conn = db2_connect('badname', 'baduser', 'badpassword');
if (!$conn) {
    print "SQLSTATE value: " . db2_conn_error();
}
?>

以上例程会输出：

SQLSTATE value: 08001

参见

  • db2_conn_errormsg() - Returns the last connection error message and SQLCODE value
  • db2_connect() - Returns a connection to a database
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message


Returns the last connection error message and SQLCODE value

  • ? db2_conn_error
  • db2_connect ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the last connection error message and SQLCODE value

db2_conn_errormsg

(PECL ibm_db2 >= 1.0.0)

db2_conn_errormsg — Returns the last connection error message and SQLCODE value

说明

db2_conn_errormsg ( resource $connection = ? ) : string

db2_conn_errormsg() returns an error message and SQLCODE value representing the reason the last database connection attempt failed. As db2_connect() returns false in the event of a failed connection attempt, do not pass any parameters to db2_conn_errormsg() to retrieve the associated error message and SQLCODE value.

If, however, the connection was successful but becomes invalid over time, you can pass the connection parameter to retrieve the associated error message and SQLCODE value for a specific connection.

参数

connection

A connection resource associated with a connection that initially succeeded, but which over time became invalid.

返回值

Returns a string containing the error message and SQLCODE value resulting from a failed connection attempt. If there is no error associated with the last connection attempt, db2_conn_errormsg() returns an empty string.

范例

Example #1 Retrieving the error message returned by a failed connection attempt

The following example demonstrates how to return an error message and SQLCODE value after deliberately passing invalid parameters to db2_connect().

<?php
$conn = db2_connect('badname', 'baduser', 'badpassword');
if (!$conn) {
    print db2_conn_errormsg();
}
?>

以上例程会输出：

[IBM][CLI Driver] SQL1013N  The database alias name
or database name "BADNAME" could not be found.  SQLSTATE=42705
 SQLCODE=-1013

参见

  • db2_conn_error() - Returns a string containing the SQLSTATE returned by the last connection attempt
  • db2_connect() - Returns a connection to a database
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message


Returns a connection to a database

  • ? db2_conn_errormsg
  • db2_cursor_type ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a connection to a database

db2_connect

(PECL ibm_db2 >= 1.0.0)

db2_connect — Returns a connection to a database

说明

db2_connect ( string $database , string $username , string $password , array $options = ? ) : resource

Creates a new connection to an IBM DB2 Universal Database, IBM Cloudscape, or Apache Derby database.

参数

database

For a cataloged connection to a database, database represents the database alias in the DB2 client catalog.

For an uncataloged connection to a database, database represents a complete connection string in the following format:

DATABASE=database;HOSTNAME=hostname;PORT=port;PROTOCOL=TCPIP;UID=username;PWD=password;
where the parameters represent the following values:
database

The name of the database.

hostname

The hostname or IP address of the database server.

port

The TCP/IP port on which the database is listening for requests.

username

The username with which you are connecting to the database.

password

The password with which you are connecting to the database.

username

The username with which you are connecting to the database.

For uncataloged connections, you must pass a null value or empty string.

password

The password with which you are connecting to the database.

For uncataloged connections, you must pass a null value or empty string.

options

An associative array of connection options that affect the behavior of the connection, where valid array keys include:

autocommit

Passing the DB2_AUTOCOMMIT_ON value turns autocommit on for this connection handle.

Passing the DB2_AUTOCOMMIT_OFF value turns autocommit off for this connection handle.

DB2_ATTR_CASE

Passing the DB2_CASE_NATURAL value specifies that column names are returned in natural case.

Passing the DB2_CASE_LOWER value specifies that column names are returned in lower case.

Passing the DB2_CASE_UPPER value specifies that column names are returned in upper case.

CURSOR

Passing the DB2_FORWARD_ONLY value specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.

Passing the DB2_SCROLLABLE value specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.

The following new option is available in ibm_db2 version 1.7.0 and later.

trustedcontext

Passing the DB2_TRUSTED_CONTEXT_ENABLE value turns trusted context on for this connection handle. This parameter cannot be set using db2_set_option().

This key works only if the database is cataloged (even if the database is local), or if you specify the full DSN when you create the connection.

To catalog the database, use following commands:

db2 catalog tcpip node loopback remote <SERVERNAME> server <SERVICENAME>
db2 catalog database <LOCALDBNAME> as <REMOTEDBNAME> at node loopback
db2 "update dbm cfg using svcename <SERVICENAME>"
db2set DB2COMM=TCPIP

The following new i5/OS options are available in ibm_db2 version 1.5.1 and later.

i5_lib

A character value that indicates the default library that will be used for resolving unqualified file references. This is not valid if the connection is using system naming mode.

i5_naming

DB2_I5_NAMING_ON value turns on DB2 UDB CLI iSeries system naming mode. Files are qualified using the slash (/) delimiter. Unqualified files are resolved using the library list for the job.

DB2_I5_NAMING_OFF value turns off DB2 UDB CLI default naming mode, which is SQL naming. Files are qualified using the period (.) delimiter. Unqualified files are resolved using either the default library or the current user ID.

i5_commit

The i5_commit attribute should be set before the db2_connect(). If the value is changed after the connection has been established, and the connection is to a remote data source, the change does not take effect until the next successful db2_connect() for the connection handle.

Note:

The php.ini setting ibm_db2.i5_allow_commit==0 or DB2_I5_TXN_NO_COMMIT is the default, but may be overridden with the i5_commit option.

DB2_I5_TXN_NO_COMMIT - Commitment control is not used.

DB2_I5_TXN_READ_UNCOMMITTED - Dirty reads, nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_READ_COMMITTED - Dirty reads are not possible. Nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_REPEATABLE_READ - Dirty reads and nonrepeatable reads are not possible. Phantoms are possible.

DB2_I5_TXN_SERIALIZABLE - Transactions are serializable. Dirty reads, non-repeatable reads, and phantoms are not possible

i5_query_optimize

DB2_FIRST_IO All queries are optimized with the goal of returning the first page of output as fast as possible. This goal works well when the output is controlled by a user who is most likely to cancel the query after viewing the first page of output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause.

DB2_ALL_IO All queries are optimized with the goal of running the entire query to completion in the shortest amount of elapsed time. This is a good option when the output of a query is being written to a file or report, or the interface is queuing the output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause. This is the default.

i5_dbcs_alloc

DB2_I5_DBCS_ALLOC_ON value turns on DB2 6X allocation scheme for DBCS translation column size growth.

DB2_I5_DBCS_ALLOC_OFF value turns off DB2 6X allocation scheme for DBCS translation column size growth.

Note: php.ini setting ibm_db2.i5_dbcs_alloc==0 or DB2_I5_DBCS_ALLOC_OFF is the default, but may be overridden with the i5_dbcs_alloc option.

i5_date_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) date format yyyy-mm-dd is used. This is the default.

DB2_I5_FMT_USA - The United States date format mm/dd/yyyy is used.

DB2_I5_FMT_EUR - The European date format dd.mm.yyyy is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard date format yyyy-mm-dd is used.

DB2_I5_FMT_MDY - The date format mm/dd/yyyy is used.

DB2_I5_FMT_DMY - The date format dd/mm/yyyy is used.

DB2_I5_FMT_YMD - The date format yy/mm/dd is used.

DB2_I5_FMT_JUL - The Julian date format yy/ddd is used.

DB2_I5_FMT_JOB - The job default is used.

i5_date_sep

DB2_I5_SEP_SLASH - A slash ( / ) is used as the date separator. This is the default.

DB2_I5_SEP_DASH - A dash ( - ) is used as the date separator.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the date separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the date separator.

DB2_I5_SEP_BLANK - A blank is used as the date separator.

DB2_I5_SEP_JOB - The job default is used

i5_time_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) time format hh.mm.ss is used. This is the default.

DB2_I5_FMT_USA - The United States time format hh:mmxx is used, where xx is AM or PM.

DB2_I5_FMT_EUR - The European time format hh.mm.ss is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard time format hh:mm:ss is used.

DB2_I5_FMT_HMS - The hh:mm:ss format is used.

i5_time_sep

DB2_I5_SEP_COLON - A colon ( : ) is used as the time separator. This is the default.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the time separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the time separator.

DB2_I5_SEP_BLANK - A blank is used as the time separator.

DB2_I5_SEP_JOB - The job default is used.

i5_decimal_sep

DB2_I5_SEP_PERIOD - A period ( . ) is used as the decimal separator. This is the default.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the decimal separator.

DB2_I5_SEP_JOB - The job default is used.

The following new i5/OS option is available in ibm_db2 version 1.8.0 and later.

i5_libl

A character value that indicates the library list that will be used for resolving unqualified file references. Specify the library list elements separated by blanks 'i5_libl'=>"MYLIB YOURLIB ANYLIB".

Note:

i5_libl calls qsys2/qcmdexc('cmd',cmdlen), which is only available in i5/OS V5R4 and later.

返回值

Returns a connection handle resource if the connection attempt is successful. If the connection attempt fails, db2_connect() returns false.

范例

Example #1 Creating a cataloged connection

Cataloged connections require you to have previously cataloged the target database through the DB2 Command Line Processor (CLP) or DB2 Configuration Assistant.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';

$conn = db2_connect($database, $user, $password);

if ($conn) {
    echo "Connection succeeded.";
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

以上例程会输出：

Connection succeeded.

Example #2 Creating an uncataloged connection

An uncataloged connection enables you to dynamically connect to a database.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';
$hostname = 'localhost';
$port = 50000;

$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;" .
  "HOSTNAME=$hostname;PORT=$port;PROTOCOL=TCPIP;UID=$user;PWD=$password;";
$conn = db2_connect($conn_string, '', '');

if ($conn) {
    echo "Connection succeeded.";
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

以上例程会输出：

Connection succeeded.

Example #3 Creating a connection with autocommit off by default

Passing an array of options to db2_connect() enables you to modify the default behavior of the connection handle.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);

$conn = db2_connect($database, $user, $password, $options);

if ($conn) {
    echo "Connection succeeded.\n";
    if (db2_autocommit($conn)) {
         echo "Autocommit is on.\n";
    }
    else {
         echo "Autocommit is off.\n";
    }
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

以上例程会输出：

Connection succeeded.
Autocommit is off.

Example #4 i5/OS best performance

To achieve best performance for your i5/OS ibm_db2 1.5.1 PHP application use the default host, userid, and password for your db2_connect().

<?php
  $library = "ADC";
  $i5 = db2_connect("", "", "", array("i5_lib"=>"qsys2"));
  $result = db2_exec($i5,
       "select * from systables where table_schema = '$library'");
  while ($row = db2_fetch_both($result)) {
     echo $row['TABLE_NAME']."</br>";
  }
  db2_close($i5);
?>

以上例程会输出：

ANIMALS
NAMES
PICTURES

Example #5 Using trusted context

The following example shows how to enable trusted context, switch users, and get the current user ID.

<?php

$database = "SAMPLE";
$hostname = "localhost";
$port = 50000;
$authID = "db2inst1";
$auth_pass = "ibmdb2";

$tc_user = "tcuser";
$tc_pass = "tcpassword";

$dsn = "DATABASE=$database;HOSTNAME=$hostname;PORT=$port;
  PROTOCOL=TCPIP;UID=$authID;PWD=$auth_pass;";
$options = array ("trustedcontext" => DB2_TRUSTED_CONTEXT_ENABLE);

$tc_conn = db2_connect($dsn, "", "", $options);
if($tc_conn) {
    echo "Explicit trusted connection succeeded.\n";

    if(db2_get_option($tc_conn, "trustedcontext")) {
        $userBefore = db2_get_option($tc_conn, "trusted_user");

        //Do some work as user 1.

        //Switching to trusted user.
        $parameters = array("trusted_user" => $tc_user,
          "trusted_password" => $tcuser_pass);
        $res = db2_set_option ($tc_conn, $parameters, 1);

        $userAfter = db2_get_option($tc_conn, "trusted_user");
        //Do more work as trusted user.

        if($userBefore != $userAfter) {
            echo "User has been switched." . "\n";
        }
    }

    db2_close($tc_conn);
}
else {
    echo "Explicit trusted connection failed.\n";
}
?>

以上例程会输出：

Explicit trusted connection succeeded.
User has been switched.

参见

  • db2_close() - Closes a database connection
  • db2_pconnect() - Returns a persistent connection to a database


Returns the cursor type used by a statement resource

  • ? db2_connect
  • db2_escape_string ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the cursor type used by a statement resource

db2_cursor_type

(PECL ibm_db2 >= 1.0.0)

db2_cursor_type — Returns the cursor type used by a statement resource

说明

db2_cursor_type ( resource $stmt ) : int

Returns the cursor type used by a statement resource. Use this to determine if you are working with a forward-only cursor or scrollable cursor.

参数

stmt

A valid statement resource.

返回值

Returns either DB2_FORWARD_ONLY if the statement resource uses a forward-only cursor or DB2_SCROLLABLE if the statement resource uses a scrollable cursor.

参见

  • db2_prepare() - Prepares an SQL statement to be executed


Used to escape certain characters

  • ? db2_cursor_type
  • db2_exec ?
  • PHP Manual
  • IBM DB2 函数
  • Used to escape certain characters

db2_escape_string

(PECL ibm_db2 >= 1.6.0)

db2_escape_string — Used to escape certain characters

说明

db2_escape_string ( string $string_literal ) : string

Prepends backslashes to special characters in the string argument.

参数

string_literal

The string that contains special characters that need to be modified. Characters that are prepended with a backslash are \x00, \n, \r, \, ', " and \x1a.

返回值

Returns string_literal with the special characters noted above prepended with backslashes.

范例

Example #1 A db2_escape_string() example

Result of using the db2_escape_string() function

<?php

$conn = db2_connect($database, $user, $password);

if ($conn) {
    $str[0] = "All characters: \x00 , \n , \r , \ , ' , \" , \x1a .";
    $str[1] = "Backslash (\). Single quote ('). Double quote (\")";
    $str[2] = "The NULL character \0 must be quoted as well";
    $str[3] = "Intersting characters: \x1a , \x00 .";
    $str[4] = "Nothing to quote";
    $str[5] = 200676;
    $str[6] = "";

    foreach( $str as $string ) {
        echo "db2_escape_string: " . db2_escape_string($string). "\n";
    }
}
?>

以上例程会输出：

db2_escape_string: All characters: \0 , \n , \r , \\ , \' , \" , \Z .
db2_escape_string: Backslash (\\). Single quote (\'). Double quote (\")
db2_escape_string: The NULL character \0 must be quoted as well
db2_escape_string: Intersting characters: \Z , \0 .
db2_escape_string: Nothing to quote
db2_escape_string: 200676
db2_escape_string:

参见

  • db2_prepare() - Prepares an SQL statement to be executed


Executes an SQL statement directly

  • ? db2_escape_string
  • db2_execute ?
  • PHP Manual
  • IBM DB2 函数
  • Executes an SQL statement directly

db2_exec

(PECL ibm_db2 >= 1.0.0)

db2_exec — Executes an SQL statement directly

说明

db2_exec ( resource $connection , string $statement , array $options = ? ) : resource

Executes an SQL statement directly.

If you plan to interpolate PHP variables into the SQL statement, understand that this is one of the more common security exposures. Consider calling db2_prepare() to prepare an SQL statement with parameter markers for input values. Then you can call db2_execute() to pass in the input values and avoid SQL injection attacks.

If you plan to repeatedly issue the same SQL statement with different parameters, consider calling db2_prepare() and db2_execute() to enable the database server to reuse its access plan and increase the efficiency of your database access.

参数

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

statement

An SQL statement. The statement cannot contain any parameter markers.

options

An associative array containing statement options. You can use this parameter to request a scrollable cursor on database servers that support this functionality.

For a description of valid statement options, see db2_set_option().

返回值

Returns a statement resource if the SQL statement was issued successfully, or false if the database failed to execute the SQL statement.

范例

Example #1 Creating a table with db2_exec()

The following example uses db2_exec() to issue a set of DDL statements in the process of creating a table.

<?php
$conn = db2_connect($database, $user, $password);

// Create the test table
$create = 'CREATE TABLE animals (id INTEGER, breed VARCHAR(32),
    name CHAR(16), weight DECIMAL(7,2))';
$result = db2_exec($conn, $create);
if ($result) {
    print "Successfully created the table.\n";
}

// Populate the test table
$animals = array(
    array(0, 'cat', 'Pook', 3.2),
    array(1, 'dog', 'Peaches', 12.3),
    array(2, 'horse', 'Smarty', 350.0),
    array(3, 'gold fish', 'Bubbles', 0.1),
    array(4, 'budgerigar', 'Gizmo', 0.2),
    array(5, 'goat', 'Rickety Ride', 9.7),
    array(6, 'llama', 'Sweater', 150)
);

foreach ($animals as $animal) {
    $rc = db2_exec($conn, "INSERT INTO animals (id, breed, name, weight)
      VALUES ({$animal[0]}, '{$animal[1]}', '{$animal[2]}', {$animal[3]})");
    if ($rc) {
        print "Insert... ";
    }
}
?>

以上例程会输出：

Successfully created the table.
Insert... Insert... Insert... Insert... Insert... Insert... Insert...

Example #2 Executing a SELECT statement with a scrollable cursor

The following example demonstrates how to request a scrollable cursor for an SQL statement issued by db2_exec().

<?php
$conn = db2_connect($database, $user, $password);
$sql = "SELECT name FROM animals
    WHERE weight < 10.0
    ORDER BY name";
if ($conn) {
    require_once('prepare.inc');
    $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
    while ($row = db2_fetch_array($stmt)) {
        print "$row[0]\n";
    }
}
?>

以上例程会输出：

Bubbles
Gizmo
Pook
Rickety Ride

Example #3 Returning XML data as an SQL ResultSet

The following example demonstrates how to work with documents stored in a XML column using the SAMPLE database. Using some pretty simple SQL/XML, this example returns some of the nodes in a XML document in an SQL ResultSet format that most users are familiar with.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = 'SELECT * FROM XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" VARCHAR (50) PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) AS T
    WHERE NAME = \'Kathy Smith\'
    ';
$stmt = db2_exec($conn, $query);

while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE\n");
}
db2_close($conn);

?>

以上例程会输出：

1000     Kathy Smith     416-555-1358
1001     Kathy Smith     905-555-7258

Example #4 Performing a "JOIN" with XML data

The following example works with documents stored in 2 different XML columns in the SAMPLE database. It creates 2 temporary tables from the XML documents from 2 different columns and returns an SQL ResultSet with information regarding shipping status for the customer.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
    SELECT A.CID, A.NAME, A.PHONE, C.PONUM, C.STATUS
    FROM
    XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" BIGINT PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) as A,
    PURCHASEORDER AS B,
    XMLTABLE (
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("PURCHASEORDER.PORDER")/PurchaseOrder\'
    COLUMNS
    "PONUM"  BIGINT PATH \'@PoNum\',
    "STATUS" VARCHAR (50) PATH \'@Status\'
    ) as C
    WHERE A.CID = B.CUSTID AND
    B.POID = C.PONUM AND
    A.NAME = \'Kathy Smith\'
';

$stmt = db2_exec($conn, $query);

while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE     $row->PONUM     $row->STATUS\n");
}

db2_close($conn);

?>

以上例程会输出：

1001     Kathy Smith     905-555-7258     5002     Shipped

Example #5 Returning SQL data as part of a larger XML document

The following example works with a portion of the PRODUCT.DESCRIPTION documents in the SAMPLE database. It creates a XML document containing product description (XML data) and pricing info (SQL data).

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT
XMLSERIALIZE(
XMLQUERY(\'
    declare boundary-space strip;
    declare default element namespace "http://posample.org";
    <promoList> {
    for $prod in $doc/product
    where $prod/description/price < 10.00
    order by $prod/description/price ascending
    return(
        <promoitem> {
        $prod,
        <startdate> {$start} </startdate>,
        <enddate> {$end} </enddate>,
        <promoprice> {$promo} </promoprice>
        } </promoitem>
    )
    } </promoList>
\' passing by ref DESCRIPTION AS "doc",
PROMOSTART as "start",
PROMOEND as "end",
PROMOPRICE as "promo"
RETURNING SEQUENCE)
AS CLOB (32000))
AS NEW_PRODUCT_INFO
FROM PRODUCT
WHERE PID = \'100-100-01\'
';

$stmt = db2_exec($conn, $query);

while($row = db2_fetch_array($stmt)){
    printf("$row[0]\n");
}
db2_close($conn);

?>

以上例程会输出：

<promoList xmlns="http://posample.org">
    <promoitem>
    <product pid="100-100-01">
        <description>
            <name>Snow Shovel, Basic 22 inch</name>
            <details>Basic Snow Shovel, 22 inches wide, straight handle with D-Grip</details>
            <price>9.99</price>
            <weight>1 kg</weight>
        </description>
    </product>
    <startdate>2004-11-19</startdate>
    <enddate>2004-12-19</enddate>
    <promoprice>7.25</promoprice>
    </promoitem>
</promoList>

参见

  • db2_execute() - Executes a prepared SQL statement
  • db2_prepare() - Prepares an SQL statement to be executed


Executes a prepared SQL statement

  • ? db2_exec
  • db2_fetch_array ?
  • PHP Manual
  • IBM DB2 函数
  • Executes a prepared SQL statement

db2_execute

(PECL ibm_db2 >= 1.0.0)

db2_execute — Executes a prepared SQL statement

说明

db2_execute ( resource $stmt , array $parameters = ? ) : bool

db2_execute() executes an SQL statement that was prepared by db2_prepare().

If the SQL statement returns a result set, for example, a SELECT statement or a CALL to a stored procedure that returns one or more result sets, you can retrieve a row as an array from the stmt resource using db2_fetch_assoc(), db2_fetch_both(), or db2_fetch_array(). Alternatively, you can use db2_fetch_row() to move the result set pointer to the next row and fetch a column at a time from that row with db2_result().

Refer to db2_prepare() for a brief discussion of the advantages of using db2_prepare() and db2_execute() rather than db2_exec().

参数

stmt

A prepared statement returned from db2_prepare().

parameters

An array of input parameters matching any parameter markers contained in the prepared statement.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Preparing and executing an SQL statement with parameter markers

The following example prepares an INSERT statement that accepts four parameter markers, then iterates over an array of arrays containing the input values to be passed to db2_execute().

<?php
$pet = array(0, 'cat', 'Pook', 3.2);

$insert = 'INSERT INTO animals (id, breed, name, weight)
    VALUES (?, ?, ?, ?)';

$stmt = db2_prepare($conn, $insert);
if ($stmt) {
    $result = db2_execute($stmt, $pet);
    if ($result) {
        print "Successfully added new pet.";
    }
}
?>

以上例程会输出：

Successfully added new pet.

Example #2 Calling a stored procedure with an OUT parameter

The following example prepares a CALL statement that accepts one parameter marker representing an OUT parameter, binds the PHP variable $my_pets to the parameter using db2_bind_param(), then issues db2_execute() to execute the CALL statement. After the CALL to the stored procedure has been made, the value of $num_pets changes to reflect the value returned by the stored procedure for that OUT parameter.

<?php
$num_pets = 0;
$res = db2_prepare($conn, "CALL count_my_pets(?)");
$rc = db2_bind_param($res, 1, "num_pets", DB2_PARAM_OUT);
$rc = db2_execute($res);
print "I have $num_pets pets!";
?>

以上例程会输出：

I have 7 pets!

Example #3 Returning XML data as an SQL ResultSet

The following example demonstrates how to work with documents stored in a XML column using the SAMPLE database. Using some pretty simple SQL/XML, this example returns some of the nodes in a XML document in an SQL ResultSet format that most users are familiar with.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = 'SELECT * FROM XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" VARCHAR (50) PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) AS T
    WHERE NAME = ?
    ';

$stmt = db2_prepare($conn, $query);

$name = 'Kathy Smith';

if ($stmt) {
    db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE\n");
    }
}
db2_close($conn);

?>

以上例程会输出：

1000     Kathy Smith     416-555-1358
1001     Kathy Smith     905-555-7258

Example #4 Performing a "JOIN" with XML data

The following example works with documents stored in 2 different XML columns in the SAMPLE database. It creates 2 temporary tables from the XML documents from 2 different columns and returns an SQL ResultSet with information regarding shipping status for the customer.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT A.CID, A.NAME, A.PHONE, C.PONUM, C.STATUS
FROM
XMLTABLE(
XMLNAMESPACES (DEFAULT \'http://posample.org\'),
\'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
COLUMNS
"CID" BIGINT PATH \'@Cid\',
"NAME" VARCHAR (50) PATH \'name\',
"PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
) as A,
PURCHASEORDER AS B,
XMLTABLE (
XMLNAMESPACES (DEFAULT \'http://posample.org\'),
\'db2-fn:xmlcolumn("PURCHASEORDER.PORDER")/PurchaseOrder\'
COLUMNS
"PONUM"  BIGINT PATH \'@PoNum\',
"STATUS" VARCHAR (50) PATH \'@Status\'
) as C
WHERE A.CID = B.CUSTID AND
    B.POID = C.PONUM AND
    A.NAME = ?
';

$stmt = db2_prepare($conn, $query);

$name = 'Kathy Smith';

if ($stmt) {
    db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE     $row->PONUM     $row->STATUS\n");
    }
}

db2_close($conn);

?>

以上例程会输出：

1001     Kathy Smith     905-555-7258     5002     Shipped

Example #5 Returning SQL data as part of a larger XML document

The following example works with a portion of the PRODUCT.DESCRIPTION documents in the SAMPLE database. It creates a XML document containing product description (XML data) and pricing info (SQL data).

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT
XMLSERIALIZE(
XMLQUERY(\'
    declare boundary-space strip;
    declare default element namespace "http://posample.org";
    <promoList> {
    for $prod in $doc/product
    where $prod/description/price < 10.00
    order by $prod/description/price ascending
    return(
        <promoitem> {
        $prod,
        <startdate> {$start} </startdate>,
        <enddate> {$end} </enddate>,
        <promoprice> {$promo} </promoprice>
            } </promoitem>
    )
    } </promoList>
\' passing by ref DESCRIPTION AS "doc",
PROMOSTART as "start",
PROMOEND as "end",
PROMOPRICE as "promo"
RETURNING SEQUENCE)
AS CLOB (32000))
AS NEW_PRODUCT_INFO
FROM PRODUCT
WHERE PID = ?
';

$stmt = db2_prepare($conn, $query);

$pid = "100-100-01";

if ($stmt) {
    db2_bind_param($stmt, 1, "pid", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_array($stmt)){
    printf("$row[0]\n");
    }
}

db2_close($conn);

?>

以上例程会输出：

<promoList xmlns="http://posample.org">
    <promoitem>
    <product pid="100-100-01">
        <description>
            <name>Snow Shovel, Basic 22 inch</name>
            <details>Basic Snow Shovel, 22 inches wide, straight handle with D-Grip</details>
            <price>9.99</price>
            <weight>1 kg</weight>
        </description>
    </product>
    <startdate>2004-11-19</startdate>
    <enddate>2004-12-19</enddate>
    <promoprice>7.25</promoprice>
    </promoitem>
</promoList>

参见

  • db2_exec() - Executes an SQL statement directly
  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_prepare() - Prepares an SQL statement to be executed
  • db2_result() - Returns a single column from a row in the result set


Returns an array, indexed by column position, representing a row in a result set

  • ? db2_execute
  • db2_fetch_assoc ?
  • PHP Manual
  • IBM DB2 函数
  • Returns an array, indexed by column position, representing a row in a result set

db2_fetch_array

(PECL ibm_db2 >= 1.0.1)

db2_fetch_array — Returns an array, indexed by column position, representing a row in a result set

说明

db2_fetch_array ( resource $stmt , int $row_number = -1 ) : array

Returns an array, indexed by column position, representing a row in a result set. The columns are 0-indexed.

参数

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

返回值

Returns a 0-indexed array with column values indexed by the column position representing the next or requested row in the result set. Returns false if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

范例

Example #1 Iterating through a forward-only cursor

If you call db2_fetch_array() without a specific row number, it automatically retrieves the next row in the result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_array($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row[1], $row[2], $row[3]);
}
?>

以上例程会输出：

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Example #2 Retrieving specific rows with db2_fetch_array() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_array() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_array($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row[1], $row[2], $row[3]);
    $i = $i + 2;
}
?>

以上例程会输出：

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

参见

  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_result() - Returns a single column from a row in the result set


Returns an array, indexed by column name, representing a row in a result set

  • ? db2_fetch_array
  • db2_fetch_both ?
  • PHP Manual
  • IBM DB2 函数
  • Returns an array, indexed by column name, representing a row in a result set

db2_fetch_assoc

(PECL ibm_db2 >= 1.0.0)

db2_fetch_assoc — Returns an array, indexed by column name, representing a row in a result set

说明

db2_fetch_assoc ( resource $stmt , int $row_number = -1 ) : array

Returns an array, indexed by column name, representing a row in a result set.

参数

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

返回值

Returns an associative array with column values indexed by the column name representing the next or requested row in the result set. Returns false if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

范例

Example #1 Iterating through a forward-only cursor

If you call db2_fetch_assoc() without a specific row number, it automatically retrieves the next row in the result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_assoc($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row['NAME'], $row['BREED'], $row['WEIGHT']);
}
?>

以上例程会输出：

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Example #2 Retrieving specific rows with db2_fetch_assoc() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_assoc() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_assoc($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row['NAME'], $row['BREED'], $row['WEIGHT']);
    $i = $i + 2;
}
?>

以上例程会输出：

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

参见

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_result() - Returns a single column from a row in the result set


Returns an array, indexed by both column name and position, representing a row in a result set

  • ? db2_fetch_assoc
  • db2_fetch_object ?
  • PHP Manual
  • IBM DB2 函数
  • Returns an array, indexed by both column name and position, representing a row in a result set

db2_fetch_both

(PECL ibm_db2 >= 1.0.0)

db2_fetch_both — Returns an array, indexed by both column name and position, representing a row in a result set

说明

db2_fetch_both ( resource $stmt , int $row_number = -1 ) : array

Returns an array, indexed by both column name and position, representing a
row in a result set. Note that the row returned by
db2_fetch_both() requires more memory than the
single-indexed arrays returned by db2_fetch_assoc() or
db2_fetch_array().

参数

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

返回值

Returns an associative array with column values indexed by both the column name and 0-indexed column number. The array represents the next or requested row in the result set. Returns false if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

范例

Example #1 Iterating through a forward-only cursor

If you call db2_fetch_both() without a specific row number, it automatically retrieves the next row in the result set. The following example accesses columns in the returned array by both column name and by numeric index.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_both($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row[0], $row['BREED'], $row[3]);
}
?>

以上例程会输出：

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Example #2 Retrieving specific rows with db2_fetch_both() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_both() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_both($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row['NAME'], $row[2], $row['WEIGHT']);
    $i = $i + 2;
}
?>

以上例程会输出：

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

参见

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_result() - Returns a single column from a row in the result set


Returns an object with properties representing columns in the fetched row

  • ? db2_fetch_both
  • db2_fetch_row ?
  • PHP Manual
  • IBM DB2 函数
  • Returns an object with properties representing columns in the fetched row

db2_fetch_object

(PECL ibm_db2 >= 1.0.0)

db2_fetch_object — Returns an object with properties representing columns in the fetched row

说明

db2_fetch_object ( resource $stmt , int $row_number = -1 ) : object

Returns an object in which each property represents a column returned in the row fetched from a result set.

参数

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

返回值

Returns an object representing a single row in the result set. The properties of the object map to the names of the columns in the result set.

The IBM DB2, Cloudscape, and Apache Derby database servers typically fold column names to upper-case, so the object properties will reflect that case.

If your SELECT statement calls a scalar function to modify the value of a column, the database servers return the column number as the name of the column in the result set. If you prefer a more descriptive column name and object property, you can use the AS clause to assign a name to the column in the result set.

Returns false if no row was retrieved.

范例

Example #1 A db2_fetch_object() example

The following example issues a SELECT statement with a scalar function, RTRIM, that removes whitespace from the end of the column. Rather than creating an object with the properties "BREED" and "2", we use the AS clause in the SELECT statement to assign the name "name" to the modified column. The database server folds the column names to upper-case, resulting in an object with the properties "BREED" and "NAME".

<?php
$conn = db2_connect($database, $user, $password);

$sql = "SELECT breed, RTRIM(name) AS name
    FROM animals
    WHERE id = ?";

if ($conn) {
    $stmt = db2_prepare($conn, $sql);
    db2_execute($stmt, array(0));

    while ($pet = db2_fetch_object($stmt)) {
        echo "Come here, {$pet->NAME}, my little {$pet->BREED}!";
    }
    db2_close($conn);
}
?>

以上例程会输出：

Come here, Pook, my little cat!

参见

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_result() - Returns a single column from a row in the result set


Sets the result set pointer to the next row or requested row

  • ? db2_fetch_object
  • db2_field_display_size ?
  • PHP Manual
  • IBM DB2 函数
  • Sets the result set pointer to the next row or requested row

db2_fetch_row

(PECL ibm_db2 >= 1.0.0)

db2_fetch_row — Sets the result set pointer to the next row or requested row

说明

db2_fetch_row ( resource $stmt , int $row_number = ? ) : bool

Use db2_fetch_row() to iterate through a result set, or to point to a specific row in a result set if you requested a scrollable cursor.

To retrieve individual fields from the result set, call the db2_result() function.

Rather than calling db2_fetch_row() and db2_result(), most applications will call one of db2_fetch_assoc(), db2_fetch_both(), or db2_fetch_array() to advance the result set pointer and return a complete row as an array.

参数

stmt

A valid stmt resource.

row_number

With scrollable cursors, you can request a specific row number in the result set. Row numbering is 1-indexed.

返回值

Returns true if the requested row exists in the result set. Returns false if the requested row does not exist in the result set.

范例

Example #1 Iterating through a result set

The following example demonstrates how to iterate through a result set with db2_fetch_row() and retrieve columns from the result set with db2_result().

<?php
$sql = 'SELECT name, breed FROM animals WHERE weight < ?';
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, array(10));
while (db2_fetch_row($stmt)) {
    $name = db2_result($stmt, 0);
    $breed = db2_result($stmt, 1);
    print "$name $breed";
}
?>

以上例程会输出：

cat Pook
gold fish Bubbles
budgerigar Gizmo
goat Rickety Ride

Example #2 i5/OS recommended alternatives to db2_fetch_row/db2_result

On i5/OS it is recommended that you use db2_fetch_both(), db2_fetch_array(), or db2_fetch_object() over db2_fetch_row()/db2_result(). In general db2_fetch_row()/db2_result() have more issues with various column types in EBCIDIC to ASCII translation, including possible truncation in DBCS applications. You may also find the performance of db2_fetch_both(), db2_fetch_array(), and db2_fetch_object() to be superior to db2_fetch_row()/db2_result().

<?php
  $conn = db2_connect("","","");
  $sql = 'SELECT SPECIFIC_SCHEMA, SPECIFIC_NAME, ROUTINE_SCHEMA, ROUTINE_NAME, ROUTINE_TYPE, ROUTINE_CREATED, ROUTINE_BODY, IN_PARMS, OUT_PARMS, INOUT_PARMS, PARAMETER_STYLE, EXTERNAL_NAME, EXTERNAL_LANGUAGE FROM QSYS2.SYSROUTINES FETCH FIRST 2 ROWS ONLY';
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_both($stmt)){
    echo "<br>db2_fetch_both {$row['SPECIFIC_NAME']} {$row['ROUTINE_CREATED']} {$row[5]}";
  }
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_array($stmt)){
    echo "<br>db2_fetch_array {$row[1]}  {$row[5]}";
  }
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_object($stmt)){
    echo "<br>db2_fetch_object {$row->SPECIFIC_NAME} {$row->ROUTINE_CREATED}";
  }
  db2_close($conn);
?>

以上例程会输出：

db2_fetch_both MATCH_ANIMAL 2006-08-25-17.10.23.775000 2006-08-25-17.10.23.775000
db2_fetch_both MULTIRESULTS 2006-10-17-10.11.05.308000 2006-10-17-10.11.05.308000
db2_fetch_array MATCH_ANIMAL 2006-08-25-17.10.23.775000
db2_fetch_array MULTIRESULTS 2006-10-17-10.11.05.308000
db2_fetch_object MATCH_ANIMAL 2006-08-25-17.10.23.775000
db2_fetch_object MULTIRESULTS 2006-10-17-10.11.05.308000

参见

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_result() - Returns a single column from a row in the result set


Returns the maximum number of bytes required to display a column

  • ? db2_fetch_row
  • db2_field_name ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the maximum number of bytes required to display a column

db2_field_display_size

(PECL ibm_db2 >= 1.0.0)

db2_field_display_size — Returns the maximum number of bytes required to display a column

说明

db2_field_display_size ( resource $stmt , mixed $column ) : int

Returns the maximum number of bytes required to display a column in a result set.

参数

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

返回值

Returns an integer value with the maximum number of bytes required to display the specified column. If the column does not exist in the result set, db2_field_display_size() returns false.

参见

  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set


Returns the name of the column in the result set

  • ? db2_field_display_size
  • db2_field_num ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the name of the column in the result set

db2_field_name

(PECL ibm_db2 >= 1.0.0)

db2_field_name — Returns the name of the column in the result set

说明

db2_field_name ( resource $stmt , mixed $column ) : string

Returns the name of the specified column in the result set.

参数

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

返回值

Returns a string containing the name of the specified column. If the specified column does not exist in the result set, db2_field_name() returns false.

参见

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set


Returns the position of the named column in a result set

  • ? db2_field_name
  • db2_field_precision ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the position of the named column in a result set

db2_field_num

(PECL ibm_db2 >= 1.0.0)

db2_field_num — Returns the position of the named column in a result set

说明

db2_field_num ( resource $stmt , mixed $column ) : int

Returns the position of the named column in a result set.

参数

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

返回值

Returns an integer containing the 0-indexed position of the named column in the result set. If the specified column does not exist in the result set, db2_field_num() returns false.

参见

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set


Returns the precision of the indicated column in a result set

  • ? db2_field_num
  • db2_field_scale ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the precision of the indicated column in a result set

db2_field_precision

(PECL ibm_db2 >= 1.0.0)

db2_field_precision — Returns the precision of the indicated column in a result set

说明

db2_field_precision ( resource $stmt , mixed $column ) : int

Returns the precision of the indicated column in a result set.

参数

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

返回值

Returns an integer containing the precision of the specified column. If the specified column does not exist in the result set, db2_field_precision() returns false.

参见

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set


Returns the scale of the indicated column in a result set

  • ? db2_field_precision
  • db2_field_type ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the scale of the indicated column in a result set

db2_field_scale

(PECL ibm_db2 >= 1.0.0)

db2_field_scale — Returns the scale of the indicated column in a result set

说明

db2_field_scale ( resource $stmt , mixed $column ) : int

Returns the scale of the indicated column in a result set.

参数

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

返回值

Returns an integer containing the scale of the specified column. If the specified column does not exist in the result set, db2_field_scale() returns false.

参见

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set


Returns the data type of the indicated column in a result set

  • ? db2_field_scale
  • db2_field_width ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the data type of the indicated column in a result set

db2_field_type

(PECL ibm_db2 >= 1.0.0)

db2_field_type — Returns the data type of the indicated column in a result set

说明

db2_field_type ( resource $stmt , mixed $column ) : string

Returns the data type of the indicated column in a result set.

参数

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

返回值

Returns a string containing the defined data type of the specified column. If the specified column does not exist in the result set, db2_field_type() returns false.

参见

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set


Returns the width of the current value of the indicated column in a result set

  • ? db2_field_type
  • db2_foreign_keys ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the width of the current value of the indicated column in a result set

db2_field_width

(PECL ibm_db2 >= 1.0.0)

db2_field_width — Returns the width of the current value of the indicated column in a result set

说明

db2_field_width ( resource $stmt , mixed $column ) : int

Returns the width of the current value of the indicated column in a result set. This is the maximum width of the column for a fixed-length data type, or the actual width of the column for a variable-length data type.

参数

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

返回值

Returns an integer containing the width of the specified character or binary data type column in a result set. If the specified column does not exist in the result set, db2_field_width() returns false.

参见

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set


Returns a result set listing the foreign keys for a table

  • ? db2_field_width
  • db2_free_result ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing the foreign keys for a table

db2_foreign_keys

(PECL ibm_db2 >= 1.0.0)

db2_foreign_keys — Returns a result set listing the foreign keys for a table

说明

db2_foreign_keys ( resource $connection , string $qualifier , string $schema , string $table-name ) : resource

Returns a result set listing the foreign keys for a table.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables. If schema is null, db2_foreign_keys() matches the schema for the current connection.

table-name

The name of the table.

返回值

Returns a statement resource with a result set containing rows describing the foreign keys for the specified table. The result set is composed of the following columns:

Column name | Description
PKTABLE_CAT | Name of the catalog for the table containing the primary key. The value is NULL if this table does not have catalogs.
PKTABLE_SCHEM | Name of the schema for the table containing the primary key.
PKTABLE_NAME | Name of the table containing the primary key.
PKCOLUMN_NAME | Name of the column containing the primary key.
FKTABLE_CAT | Name of the catalog for the table containing the foreign key. The value is NULL if this table does not have catalogs.
FKTABLE_SCHEM | Name of the schema for the table containing the foreign key.
FKTABLE_NAME | Name of the table containing the foreign key.
FKCOLUMN_NAME | Name of the column containing the foreign key.
KEY_SEQ | 1-indexed position of the column in the key.
UPDATE_RULE | Integer value representing the action applied to the foreign key when the SQL operation is UPDATE.
DELETE_RULE | Integer value representing the action applied to the foreign key when the SQL operation is DELETE.
FK_NAME | The name of the foreign key.
PK_NAME | The name of the primary key.
DEFERRABILITY | An integer value representing whether the foreign key deferrability is SQL_INITIALLY_DEFERRED, SQL_INITIALLY_IMMEDIATE, or SQL_NOT_DEFERRABLE.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Frees resources associated with a result set

  • ? db2_foreign_keys
  • db2_free_stmt ?
  • PHP Manual
  • IBM DB2 函数
  • Frees resources associated with a result set

db2_free_result

(PECL ibm_db2 >= 1.0.0)

db2_free_result — Frees resources associated with a result set

说明

db2_free_result ( resource $stmt ) : bool

Frees the system and database resources that are associated with a result set. These resources are freed implicitly when a script finishes, but you can call db2_free_result() to explicitly free the result set resources before the end of the script.

参数

stmt

A valid statement resource.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • db2_free_stmt() - Frees resources associated with the indicated statement resource


Frees resources associated with the indicated statement resource

  • ? db2_free_result
  • db2_get_option ?
  • PHP Manual
  • IBM DB2 函数
  • Frees resources associated with the indicated statement resource

db2_free_stmt

(PECL ibm_db2 >= 1.0.0)

db2_free_stmt — Frees resources associated with the indicated statement resource

说明

db2_free_stmt ( resource $stmt ) : bool

Frees the system and database resources that are associated with a statement resource. These resources are freed implicitly when a script finishes, but you can call db2_free_stmt() to explicitly free the statement resources before the end of the script.

参数

stmt

A valid statement resource.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • db2_free_result() - Frees resources associated with a result set


Retrieves an option value for a statement resource or a connection resource

  • ? db2_free_stmt
  • db2_last_insert_id ?
  • PHP Manual
  • IBM DB2 函数
  • Retrieves an option value for a statement resource or a connection resource

db2_get_option

(PECL ibm_db2 >= 1.6.0)

db2_get_option — Retrieves an option value for a statement resource or a connection resource

说明

db2_get_option ( resource $resource , string $option ) : string|false

Retrieves the value of a specified option value for a statement resource or a connection resource.

参数

resource

A valid statement resource as returned from db2_prepare() or a valid connection resource as returned from db2_connect() or db2_pconnect().

option

A valid statement or connection options. The following new options are available as of ibm_db2 version 1.6.0. They provide useful tracking information that can be set during execution with db2_get_option().

Note:

Prior versions of ibm_db2 do not support these new options.

When the value in each option is being set, some servers might not handle the entire length provided and might truncate the value.

To ensure that the data specified in each option is converted correctly when transmitted to a host system, use only the characters A through Z, 0 through 9, and the underscore (_) or period (.).

userid

SQL_ATTR_INFO_USERID - A pointer to a null-terminated character string used to identify the client user ID sent to the host database server when using DB2 Connect.

Note:

DB2 for z/OS and OS/390 servers support up to a length of 16 characters. This user-id is not to be confused with the authentication user-id, it is for identification purposes only and is not used for any authorization.

acctstr

SQL_ATTR_INFO_ACCTSTR - A pointer to a null-terminated character string used to identify the client accounting string sent to the host database server when using DB2 Connect.

Note:

DB2 for z/OS and OS/390 servers support up to a length of 200 characters.

applname

SQL_ATTR_INFO_APPLNAME - A pointer to a null-terminated character string used to identify the client application name sent to the host database server when using DB2 Connect.

Note:

DB2 for z/OS and OS/390 servers support up to a length of 32 characters.

wrkstnname

SQL_ATTR_INFO_WRKSTNNAME - A pointer to a null-terminated character string used to identify the client workstation name sent to the host database server when using DB2 Connect.

Note:

DB2 for z/OS and OS/390 servers support up to a length of 18 characters.

The following table specifies which options are compatible with the available resource types:

Resource-Parameter Matrix
Key | Value | Resource Type
 |  | Connection | Statement | Result Set
userid | SQL_ATTR_INFO_USERID | X | X | -
acctstr | SQL_ATTR_INFO_ACCTSTR | X | X | -
applname | SQL_ATTR_INFO_APPLNAME | X | X | -
wrkstnname | SQL_ATTR_INFO_WRKSTNNAME | X | X | -

返回值

Returns the current setting of the connection attribute provided on success 或者在失败时返回 false.

范例

Example #1 Setting and retrieving parameters through a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$user     = 'db2inst1';
$password = 'ibmdb2';

/* Obtain Connection Resource */
$conn = db2_connect($database, $user, $password);

echo "Client attributes passed through connection string:\n";

/* Create the associative options array with valid key-value pairs */
/* Assign the attributes through connection string */
/* Access the options specified */
$options1 = array('userid' => 'db2inst1');
$conn1 = db2_connect($database, $user, $password, $options1);
$val = db2_get_option($conn1, 'userid');
echo $val . "\n";

$options2 = array('acctstr' => 'account');
$conn2 = db2_connect($database, $user, $password, $options2);
$val = db2_get_option($conn2, 'acctstr');
echo $val . "\n";

$options3 = array('applname' => 'myapp');
$conn3 = db2_connect($database, $user, $password, $options3);
$val = db2_get_option($conn3, 'applname');
echo $val . "\n";

$options4 = array('wrkstnname' => 'workstation');
$conn4 = db2_connect($database, $user, $password, $options4);
$val = db2_get_option($conn4, 'wrkstnname');
echo $val . "\n";

echo "Client attributes passed post-connection:\n";

/* Create the associative options array with valid key-value pairs */
/* Assign the attributes after a connection is made */
/* Access the options specified */
$options5 = array('userid' => 'db2inst1');
$conn5 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn5, $options5, 1);
$val = db2_get_option($conn5, 'userid');
echo $val . "\n";

$options6 = array('acctstr' => 'account');
$conn6 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn6, $options6, 1);
$val = db2_get_option($conn6, 'acctstr');
echo $val . "\n";

$options7 = array('applname' => 'myapp');
$conn7 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn7, $options7, 1);
$val = db2_get_option($conn7, 'applname');
echo $val . "\n";

$options8 = array('wrkstnname' => 'workstation');
$conn8 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn8, $options8, 1);
$val = db2_get_option($conn8, 'wrkstnname');
echo $val . "\n";
?>

以上例程会输出：

Client attributes passed through connection string:
db2inst1
account
myapp
workstation
Client attributes passed post-connection:
db2inst1
account
myapp
workstation

参见

  • db2_connect() - Returns a connection to a database
  • db2_cursor_type() - Returns the cursor type used by a statement resource
  • db2_exec() - Executes an SQL statement directly
  • db2_set_option() - Set options for connection or statement resources
  • db2_pconnect() - Returns a persistent connection to a database
  • db2_prepare() - Prepares an SQL statement to be executed


Returns the auto generated ID of the last insert query that successfully executed on this connection

  • ? db2_get_option
  • db2_lob_read ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the auto generated ID of the last insert query that successfully executed on this connection

db2_last_insert_id

(PECL ibm_db2 >= 1.7.1)

db2_last_insert_id — Returns the auto generated ID of the last insert query that successfully executed on this connection

说明

db2_last_insert_id ( resource $resource ) : string

Returns the auto generated ID of the last insert query that successfully executed on this connection.

The result of this function is not affected by any of the following:

  • A single row INSERT statement with a VALUES clause for a table without an identity column.

  • A multiple row INSERT statement with a VALUES clause.

  • An INSERT statement with a fullselect.

  • A ROLLBACK TO SAVEPOINT statement.

参数

resource

A valid connection resource as returned from db2_connect() or db2_pconnect(). The value of this parameter cannot be a statement resource or result set resource.

返回值

Returns the auto generated ID of last insert query that successfully executed on this connection.

范例

Example #1 A db2_last_insert_id() example

The following example shows how to return the auto generated ID of last insert query that successfully executed on this connection.

<?php

$database = "SAMPLE";
$user = "db2inst1";
$password = "ibmdb2";

$conn = db2_connect($database, $user, $password);
if($conn) {
    $createTable = "CREATE TABLE lastInsertID
      (id integer GENERATED BY DEFAULT AS IDENTITY, name varchar(20))";
    $insertTable = "INSERT INTO lastInsertID (name) VALUES ('Temp Name')";

    $stmt = @db2_exec($conn, $createTable);

    /* Checking for single row inserted. */
    $stmt = db2_exec($conn, $insertTable);
    $ret =  db2_last_insert_id($conn);
    if($ret) {
        echo "Last Insert ID is : " . $ret . "\n";
    } else {
        echo "No Last insert ID.\n";
    }

    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

以上例程会输出：

Last Insert ID is : 1


Gets a user defined size of LOB files with each invocation

  • ? db2_last_insert_id
  • db2_next_result ?
  • PHP Manual
  • IBM DB2 函数
  • Gets a user defined size of LOB files with each invocation

db2_lob_read

(PECL ibm_db2 >= 1.6.0)

db2_lob_read — Gets a user defined size of LOB files with each invocation

说明

db2_lob_read ( resource $stmt , int $colnum , int $length ) : string

Use db2_lob_read() to iterate through a specified column of a result set and retrieve a user defined size of LOB data.

参数

stmt

A valid stmt resource containing LOB data.

colnum

A valid column number in the result set of the stmt resource.

length

The size of the LOB data to be retrieved from the stmt resource.

返回值

Returns the amount of data the user specifies. Returns false if the data cannot be retrieved.

范例

Example #1 Iterating through different types of data

<?php

/* Database Connection Parameters */
$db = 'SAMPLE';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Obtain Connection Resource */
$conn = db2_connect($db,$username,$password);

if ($conn) {
    $drop = 'DROP TABLE clob_stream';
    $result = @db2_exec( $conn, $drop );

    $create = 'CREATE TABLE clob_stream (id INTEGER, my_clob CLOB)';
    $result = db2_exec( $conn, $create );

    $variable = "";
    $stmt = db2_prepare($conn, "INSERT INTO clob_stream (id,my_clob) VALUES (1, ?)");
    $variable = "THIS IS A CLOB TEST. THIS IS A CLOB TEST.";
    db2_bind_param($stmt, 1, "variable", DB2_PARAM_IN);
    db2_execute($stmt);

    $sql = "SELECT id,my_clob FROM clob_stream";
    $result = db2_prepare($conn, $sql);
    db2_execute($result);
    db2_fetch_row($result);
    $i = 0;
    /* Read LOB data */
    while ($data = db2_lob_read($result, 2, 6)) {
        echo "Loop $i: $data\n";
        $i = $i + 1;
    }

    $drop = 'DROP TABLE blob_stream';
    $result = @db2_exec( $conn, $drop );

    $create = 'CREATE TABLE blob_stream (id INTEGER, my_blob CLOB)';
    $result = db2_exec( $conn, $create );

    $variable = "";
    $stmt = db2_prepare($conn, "INSERT INTO blob_stream (id,my_blob) VALUES (1, ?)");
    $variable = "THIS IS A BLOB TEST. THIS IS A BLOB TEST.";
    db2_bind_param($stmt, 1, "variable", DB2_PARAM_IN);
    db2_execute($stmt);

    $sql = "SELECT id,my_blob FROM blob_stream";
    $result = db2_prepare($conn, $sql);
    db2_execute($result);
    db2_fetch_row($result);
    $i = 0;
    /* Read LOB data */
    while ($data = db2_lob_read($result, 2, 6)) {
        echo "Loop $i: $data\n";
        $i = $i + 1;
    }
} else {
    echo 'no connection: ' . db2_conn_errormsg();
}

?>

以上例程会输出：

Loop 0: THIS I
Loop 1: S A CL
Loop 2: OB TES
Loop 3: T. THI
Loop 4: S IS A
Loop 5:  CLOB
Loop 6: TEST.
Loop 0: THIS I
Loop 1: S A BL
Loop 2: OB TES
Loop 3: T. THI
Loop 4: S IS A
Loop 5:  BLOB
Loop 6: TEST.

参见

  • db2_bind_param() - Binds a PHP variable to an SQL statement parameter
  • db2_exec() - Executes an SQL statement directly
  • db2_execute() - Executes a prepared SQL statement
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_prepare() - Prepares an SQL statement to be executed
  • db2_result() - Returns a single column from a row in the result set


Requests the next result set from a stored procedure

  • ? db2_lob_read
  • db2_num_fields ?
  • PHP Manual
  • IBM DB2 函数
  • Requests the next result set from a stored procedure

db2_next_result

(PECL ibm_db2 >= 1.0.0)

db2_next_result — Requests the next result set from a stored procedure

说明

db2_next_result ( resource $stmt ) : resource

A stored procedure can return zero or more result sets. While you handle the first result set in exactly the same way you would handle the results returned by a simple SELECT statement, to fetch the second and subsequent result sets from a stored procedure you must call the db2_next_result() function and return the result to a uniquely named PHP variable.

参数

stmt

A prepared statement returned from db2_exec() or db2_execute().

返回值

Returns a new statement resource containing the next result set if the stored procedure returned another result set. Returns false if the stored procedure did not return another result set.

范例

Example #1 Calling a stored procedure that returns multiple result sets

In the following example, we call a stored procedure that returns three result sets. The first result set is fetched directly from the same statement resource on which we invoked the CALL statement, while the second and third result sets are fetched from statement resources returned from our calls to the db2_next_result() function.

<?php
$conn = db2_connect($database, $user, $password);

if ($conn) {
  $stmt = db2_exec($conn, 'CALL multiResults()');

  print "Fetching first result set\n";
  while ($row = db2_fetch_array($stmt)) {
    var_dump($row);
  }

  print "\nFetching second result set\n";
  $res = db2_next_result($stmt);
  if ($res) {
    while ($row = db2_fetch_array($res)) {
      var_dump($row);
    }
  }

  print "\nFetching third result set\n";
  $res2 = db2_next_result($stmt);
  if ($res2) {
    while ($row = db2_fetch_array($res2)) {
      var_dump($row);
    }
  }

  db2_close($conn);
}
?>

以上例程会输出：

Fetching first result set
array(2) {
  [0]=>
  string(16) "Bubbles         "
  [1]=>
  int(3)
}
array(2) {
  [0]=>
  string(16) "Gizmo           "
  [1]=>
  int(4)
}

Fetching second result set
array(4) {
  [0]=>
  string(16) "Sweater         "
  [1]=>
  int(6)
  [2]=>
  string(5) "llama"
  [3]=>
  string(6) "150.00"
}
array(4) {
  [0]=>
  string(16) "Smarty          "
  [1]=>
  int(2)
  [2]=>
  string(5) "horse"
  [3]=>
  string(6) "350.00"
}

Fetching third result set
array(1) {
  [0]=>
  string(16) "Bubbles         "
}
array(1) {
  [0]=>
  string(16) "Gizmo           "
}


Returns the number of fields contained in a result set

  • ? db2_next_result
  • db2_num_rows ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the number of fields contained in a result set

db2_num_fields

(PECL ibm_db2 >= 1.0.0)

db2_num_fields — Returns the number of fields contained in a result set

说明

db2_num_fields ( resource $stmt ) : int

Returns the number of fields contained in a result set. This is most useful for handling the result sets returned by dynamically generated queries, or for result sets returned by stored procedures, where your application cannot otherwise know how to retrieve and use the results.

参数

stmt

A valid statement resource containing a result set.

返回值

Returns an integer value representing the number of fields in the result set associated with the specified statement resource. Returns false if the statement resource is not a valid input value.

范例

Example #1 Retrieving the number of fields in a result set

The following example demonstrates how to retrieve the number of fields returned in a result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, $sql);
$columns = db2_num_fields($stmt);

echo "There are {$columns} columns in the result set.";
?>

以上例程会输出：

There are 4 columns in the result set.

参见

  • db2_execute() - Executes a prepared SQL statement
  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set


Returns the number of rows affected by an SQL statement

  • ? db2_num_fields
  • db2_pclose ?
  • PHP Manual
  • IBM DB2 函数
  • Returns the number of rows affected by an SQL statement

db2_num_rows

(PECL ibm_db2 >= 1.0.0)

db2_num_rows — Returns the number of rows affected by an SQL statement

说明

db2_num_rows ( resource $stmt ) : int

Returns the number of rows deleted, inserted, or updated by an SQL statement.

To determine the number of rows that will be returned by a SELECT statement, issue SELECT COUNT(*) with the same predicates as your intended SELECT statement and retrieve the value.

If your application logic checks the number of rows returned by a SELECT statement and branches if the number of rows is 0, consider modifying your application to attempt to return the first row with one of db2_fetch_assoc(), db2_fetch_both(), db2_fetch_array(), or db2_fetch_row(), and branch if the fetch function returns false.

Note:

If you issue a SELECT statement using a scrollable cursor, db2_num_rows() returns the number of rows returned by the SELECT statement. However, the overhead associated with scrollable cursors significantly degrades the performance of your application, so if this is the only reason you are considering using scrollable cursors, you should use a forward-only cursor and either call SELECT COUNT(*) or rely on the bool return value of the fetch functions to achieve the equivalent functionality with much better performance.

参数

stmt

A valid stmt resource containing a result set.

返回值

Returns the number of rows affected by the last SQL statement issued by the specified statement handle.


Closes a persistent database connection

  • ? db2_num_rows
  • db2_pconnect ?
  • PHP Manual
  • IBM DB2 函数
  • Closes a persistent database connection

db2_pclose

(PECL ibm_db2 >= 1.8.0)

db2_pclose — Closes a persistent database connection

说明

db2_pclose ( resource $resource ) : bool

This function closes a DB2 client connection created with db2_pconnect() and returns the corresponding resources to the database server.

Note:

This function is only available on i5/OS in response to i5/OS system administration requests.

If you have a persistent DB2 client connection created with db2_pconnect(), you may use this function to close the connection. To avoid substantial connection performance penalties, this function should only be used in rare cases when the persistent connection has become unresponsive or the persistent connection will not be needed for a long period of time.

参数

connection

Specifies an active DB2 client connection.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Closing a persistent connection

The following example demonstrates a successful attempt to close a connection to an IBM DB2 i5/OS database.

<?php
$conn = db2_pconnect('', '', '');
$rc = db2_pclose($conn);
if ($rc) {
    echo "Connection was successfully closed.";
}
?>

以上例程会输出：

Connection was successfully closed.

参见

  • db2_close() - Closes a database connection
  • db2_pconnect() - Returns a persistent connection to a database


Returns a persistent connection to a database

  • ? db2_pclose
  • db2_prepare ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a persistent connection to a database

db2_pconnect

(PECL ibm_db2 >= 1.0.0)

db2_pconnect — Returns a persistent connection to a database

说明

db2_pconnect ( string $database , string $username , string $password , array $options = ? ) : resource

Returns a persistent connection to an IBM DB2 Universal Database, IBM Cloudscape, or Apache Derby database.

For more information on persistent connections, refer to 数据库持久连接.

Calling db2_close() on a persistent connection always returns true, but the underlying DB2 client connection remains open and waiting to serve the next matching db2_pconnect() request.

Users running version 1.9.0 or later of ibm_db2 should be aware that the extension will perform a transaction rollback on persistent connections at the end of a request, thus ending the transaction. This prevents the transaction block from carrying over to the next request which uses that connection if script execution ends before the transaction block does.

参数

database

The database alias in the DB2 client catalog.

username

The username with which you are connecting to the database.

password

The password with which you are connecting to the database.

options

An associative array of connection options that affect the behavior of the connection, where valid array keys include:

autocommit

Passing the DB2_AUTOCOMMIT_ON value turns autocommit on for this connection handle.

Passing the DB2_AUTOCOMMIT_OFF value turns autocommit off for this connection handle.

DB2_ATTR_CASE

Passing the DB2_CASE_NATURAL value specifies that column names are returned in natural case.

Passing the DB2_CASE_LOWER value specifies that column names are returned in lower case.

Passing the DB2_CASE_UPPER value specifies that column names are returned in upper case.

CURSOR

Passing the DB2_FORWARD_ONLY value specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.

Passing the DB2_SCROLLABLE value specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.

The following new option is available in ibm_db2 version 1.7.0 and later.

trustedcontext

Passing the DB2_TRUSTED_CONTEXT_ENABLE value turns trusted context on for this connection handle. This parameter cannot be set using db2_set_option().

This key works only if the database is cataloged (even if the database is local), or if you specify the full DSN when you create the connection.

To catalog the database, use following commands:

db2 catalog tcpip node loopback remote <SERVERNAME> server <SERVICENAME>
db2 catalog database <LOCALDBNAME> as <REMOTEDBNAME> at node loopback
db2 "update dbm cfg using svcename <SERVICENAME>"
db2set DB2COMM=TCPIP

The following new i5/OS options are available in ibm_db2 version 1.5.1 and later.

Tip

Conflicting connection attributes used in conjunction with persistent connections can produce indeterminate results on i5/OS. Site policies should be establish for all applications using each persistent connection user profile. The default DB2_AUTOCOMMIT_ON is suggested when using persistent connections.

i5_lib

A character value that indicates the default library that will be used for resolving unqualified file references. This is not valid if the connection is using system naming mode.

i5_naming

DB2_I5_NAMING_ON value turns on DB2 UDB CLI iSeries system naming mode. Files are qualified using the slash (/) delimiter. Unqualified files are resolved using the library list for the job.

DB2_I5_NAMING_OFF value turns off DB2 UDB CLI default naming mode, which is SQL naming. Files are qualified using the period (.) delimiter. Unqualified files are resolved using either the default library or the current user ID.

i5_commit

The i5_commit attribute should be set before the db2_pconnect(). If the value is changed after the connection has been established, and the connection is to a remote data source, the change does not take effect until the next successful db2_pconnect() for the connection handle.

Note:

The php.ini setting ibm_db2.i5_allow_commit==0 or DB2_I5_TXN_NO_COMMIT is the default, but may be overridden with the i5_commit option.

DB2_I5_TXN_NO_COMMIT - Commitment control is not used.

DB2_I5_TXN_READ_UNCOMMITTED - Dirty reads, nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_READ_COMMITTED - Dirty reads are not possible. Nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_REPEATABLE_READ - Dirty reads and nonrepeatable reads are not possible. Phantoms are possible.

DB2_I5_TXN_SERIALIZABLE - Transactions are serializable. Dirty reads, non-repeatable reads, and phantoms are not possible

i5_query_optimize

DB2_FIRST_IO All queries are optimized with the goal of returning the first page of output as fast as possible. This goal works well when the output is controlled by a user who is most likely to cancel the query after viewing the first page of output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause.

DB2_ALL_IO All queries are optimized with the goal of running the entire query to completion in the shortest amount of elapsed time. This is a good option when the output of a query is being written to a file or report, or the interface is queuing the output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause. This is the default.

i5_dbcs_alloc

DB2_I5_DBCS_ALLOC_ON value turns on DB2 6X allocation scheme for DBCS translation column size growth.

DB2_I5_DBCS_ALLOC_OFF value turns off DB2 6X allocation scheme for DBCS translation column size growth.

Note:

The php.ini setting ibm_db2.i5_dbcs_alloc==0 or DB2_I5_DBCS_ALLOC_OFF is the default, but may be overridden with the i5_dbcs_alloc option.

i5_date_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) date format yyyy-mm-dd is used. This is the default.

DB2_I5_FMT_USA - The United States date format mm/dd/yyyy is used.

DB2_I5_FMT_EUR - The European date format dd.mm.yyyy is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard date format yyyy-mm-dd is used.

DB2_I5_FMT_MDY - The date format mm/dd/yyyy is used.

DB2_I5_FMT_DMY - The date format dd/mm/yyyy is used.

DB2_I5_FMT_YMD - The date format yy/mm/dd is used.

DB2_I5_FMT_JUL - The Julian date format yy/ddd is used.

DB2_I5_FMT_JOB - The job default is used.

i5_date_sep

DB2_I5_SEP_SLASH - A slash ( / ) is used as the date separator. This is the default.

DB2_I5_SEP_DASH - A dash ( - ) is used as the date separator.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the date separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the date separator.

DB2_I5_SEP_BLANK - A blank is used as the date separator.

DB2_I5_SEP_JOB - The job default is used

i5_time_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) time format hh.mm.ss is used. This is the default.

DB2_I5_FMT_USA - The United States time format hh:mmxx is used, where xx is AM or PM.

DB2_I5_FMT_EUR - The European time format hh.mm.ss is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard time format hh:mm:ss is used.

DB2_I5_FMT_HMS - The hh:mm:ss format is used.

i5_time_sep

DB2_I5_SEP_COLON - A colon ( : ) is used as the time separator. This is the default.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the time separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the time separator.

DB2_I5_SEP_BLANK - A blank is used as the time separator.

DB2_I5_SEP_JOB - The job default is used.

i5_decimal_sep

DB2_I5_SEP_PERIOD - A period ( . ) is used as the decimal separator. This is the default.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the decimal separator.

DB2_I5_SEP_JOB - The job default is used.

The following new i5/OS option is available in ibm_db2 version 1.8.0 and later.

i5_libl

A character value that indicates the library list that will be used for resolving unqualified file references. Specify the library list elements separated by blanks 'i5_libl'=>"MYLIB YOURLIB ANYLIB".

Note:

i5_libl calls qsys2/qcmdexc('cmd',cmdlen), which is only available in i5/OS V5R4 and later.

返回值

Returns a connection handle resource if the connection attempt is successful. db2_pconnect() tries to reuse an existing connection resource that exactly matches the database, username, and password parameters. If the connection attempt fails, db2_pconnect() returns false.

更新日志

版本 | 说明
ibm_db2 1.9.0 | Active transactions within a persistent connection will be rolled back at the end of each request.
ibm_db2 1.8.0 | The i5_libl option is available for i5/OS users.
ibm_db2 1.7.0 | The trustedcontext option is available.
ibm_db2 1.5.1 | The i5_lib, i5_naming, i5_commit, i5_query_optimize, i5_dbcs_alloc, i5_date_fmt, i5_date_sep, i5_time_fmt, i5_time_sep and i5_decimal_sep options are available for i5/OS users.

范例

Example #1 A db2_pconnect() example

In the following example, the first call to db2_pconnect() returns a new persistent connection resource. The second call to db2_pconnect() returns a persistent connection resource that simply reuses the first persistent connection resource.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';

$pconn = db2_pconnect($database, $user, $password);

if ($pconn) {
    echo "Persistent connection succeeded.";
}
else {
    echo "Persistent connection failed.";
}

$pconn2 = db2_pconnect($database, $user, $password);
if ($pconn) {
    echo "Second persistent connection succeeded.";
}
else {
    echo "Second persistent connection failed.";
}
?>

以上例程会输出：

Persistent connection succeeded.
Second persistent connection succeeded.

Example #2 Using trusted context

The following example shows how to enable trusted context, switch users, and get the current user ID.

<?php

$database = "SAMPLE";
$hostname = "localhost";
$port = 50000;
$authID = "db2inst1";
$auth_pass = "ibmdb2";

$tc_user = "tcuser";
$tc_pass = "tcpassword";

$dsn = "DATABASE=$database;HOSTNAME=$hostname;PORT=$port;
  PROTOCOL=TCPIP;UID=$authID;PWD=$auth_pass;";
$options = array ("trustedcontext" => DB2_TRUSTED_CONTEXT_ENABLE);

$tc_conn = db2_pconnect($dsn, "", "", $options);
if($tc_conn) {
    echo "Explicit trusted connection succeeded.\n";

    if(db2_get_option($tc_conn, "trustedcontext")) {
        $userBefore = db2_get_option($tc_conn, "trusted_user");

        //Do some work as user 1.

        //Switching to trusted user.
        $parameters = array("trusted_user" => $tc_user,
          "trusted_password" => $tcuser_pass);
        $res = db2_set_option ($tc_conn, $parameters, 1);

        $userAfter = db2_get_option($tc_conn, "trusted_user");
        //Do more work as trusted user.

        if($userBefore != $userAfter) {
            echo "User has been switched." . "\n";
        }
    }

    db2_close($tc_conn);
}
else {
    echo "Explicit trusted connection failed.\n";
}
?>

以上例程会输出：

Explicit trusted connection succeeded.
User has been switched.

参见

  • db2_connect() - Returns a connection to a database


Prepares an SQL statement to be executed

  • ? db2_pconnect
  • db2_primary_keys ?
  • PHP Manual
  • IBM DB2 函数
  • Prepares an SQL statement to be executed

db2_prepare

(PECL ibm_db2 >= 1.0.0)

db2_prepare — Prepares an SQL statement to be executed

说明

db2_prepare ( resource $connection , string $statement , array $options = ? ) : resource

db2_prepare() creates a prepared SQL statement which can include 0 or more parameter markers (? characters) representing parameters for input, output, or input/output. You can pass parameters to the prepared statement using db2_bind_param(), or for input values only, as an array passed to db2_execute().

There are three main advantages to using prepared statements in your application:

  • Performance: when you prepare a statement, the database server creates an optimized access plan for retrieving data with that statement. Subsequently issuing the prepared statement with db2_execute() enables the statements to reuse that access plan and avoids the overhead of dynamically creating a new access plan for every statement you issue.

  • Security: when you prepare a statement, you can include parameter markers for input values. When you execute a prepared statement with input values for placeholders, the database server checks each input value to ensure that the type matches the column definition or parameter definition.

  • Advanced functionality: Parameter markers not only enable you to pass input values to prepared SQL statements, they also enable you to retrieve OUT and INOUT parameters from stored procedures using db2_bind_param().

参数

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

statement

An SQL statement, optionally containing one or more parameter markers..

options

An associative array containing statement options. You can use this parameter to request a scrollable cursor on database servers that support this functionality.

For a description of valid statement options, see db2_set_option().

返回值

Returns a statement resource if the SQL statement was successfully parsed and prepared by the database server. Returns false if the database server returned an error. You can determine which error was returned by calling db2_stmt_error() or db2_stmt_errormsg().

范例

Example #1 Preparing and executing an SQL statement with parameter markers

The following example prepares an INSERT statement that accepts four parameter markers, then iterates over an array of arrays containing the input values to be passed to db2_execute().

<?php
$animals = array(
    array(0, 'cat', 'Pook', 3.2),
    array(1, 'dog', 'Peaches', 12.3),
    array(2, 'horse', 'Smarty', 350.0),
);

$insert = 'INSERT INTO animals (id, breed, name, weight)
    VALUES (?, ?, ?, ?)';
$stmt = db2_prepare($conn, $insert);
if ($stmt) {
    foreach ($animals as $animal) {
        $result = db2_execute($stmt, $animal);
    }
}
?>

参见

  • db2_bind_param() - Binds a PHP variable to an SQL statement parameter
  • db2_execute() - Executes a prepared SQL statement
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message


Returns a result set listing primary keys for a table

  • ? db2_prepare
  • db2_procedure_columns ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing primary keys for a table

db2_primary_keys

(PECL ibm_db2 >= 1.0.0)

db2_primary_keys — Returns a result set listing primary keys for a table

说明

db2_primary_keys ( resource $connection , string $qualifier , string $schema , string $table-name ) : resource

Returns a result set listing the primary keys for a table.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables. If schema is null, db2_primary_keys() matches the schema for the current connection.

table-name

The name of the table.

返回值

Returns a statement resource with a result set containing rows describing the primary keys for the specified table. The result set is composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog for the table containing the primary key. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema for the table containing the primary key.
TABLE_NAME | Name of the table containing the primary key.
COLUMN_NAME | Name of the column containing the primary key.
KEY_SEQ | 1-indexed position of the column in the key.
PK_NAME | The name of the primary key.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a result set listing stored procedure parameters

  • ? db2_primary_keys
  • db2_procedures ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing stored procedure parameters

db2_procedure_columns

(PECL ibm_db2 >= 1.0.0)

db2_procedure_columns — Returns a result set listing stored procedure parameters

说明

db2_procedure_columns ( resource $connection , string $qualifier , string $schema , string $procedure , string $parameter ) : resource

Returns a result set listing the parameters for one or more stored procedures.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the procedures. This parameter accepts a search pattern containing _ and % as wildcards.

procedure

The name of the procedure. This parameter accepts a search pattern containing _ and % as wildcards.

parameter

The name of the parameter. This parameter accepts a search pattern containing _ and % as wildcards. If this parameter is null, all parameters for the specified stored procedures are returned.

返回值

Returns a statement resource with a result set containing rows describing the parameters for the stored procedures matching the specified parameters. The rows are composed of the following columns:

Column name | Description
PROCEDURE_CAT | The catalog that contains the procedure. The value is null if this table does not have catalogs.
PROCEDURE_SCHEM | Name of the schema that contains the stored procedure.
PROCEDURE_NAME | Name of the procedure.
COLUMN_NAME | Name of the parameter.
COLUMN_TYPE

An integer value representing the type of the parameter:

Return value | Parameter type
1 (SQL_PARAM_INPUT) | Input (IN) parameter.
2 (SQL_PARAM_INPUT_OUTPUT) | Input/output (INOUT) parameter.
3 (SQL_PARAM_OUTPUT) | Output (OUT) parameter.
DATA_TYPE | The SQL data type for the parameter represented as an integer value.
TYPE_NAME | A string representing the data type for the parameter.
COLUMN_SIZE | An integer value representing the size of the parameter.
BUFFER_LENGTH | Maximum number of bytes necessary to store data for this parameter.
DECIMAL_DIGITS | The scale of the parameter, or null where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or null (representing a data type for which radix is not applicable).
NULLABLE | An integer value representing whether the parameter is nullable or not.
REMARKS | Description of the parameter.
COLUMN_DEF | Default value for the parameter.
SQL_DATA_TYPE | An integer value representing the size of the parameter.
SQL_DATETIME_SUB | Returns an integer value representing a datetime subtype code, or null for SQL data types to which this does not apply.
CHAR_OCTET_LENGTH | Maximum length in octets for a character data type parameter, which matches COLUMN_SIZE for single-byte character set data, or null for non-character data types.
ORDINAL_POSITION | The 1-indexed position of the parameter in the CALL statement.
IS_NULLABLE | A string value where 'YES' means that the parameter accepts or returns null values and 'NO' means that the parameter does not accept or return null values.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a result set listing the stored procedures registered in a database

  • ? db2_procedure_columns
  • db2_result ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing the stored procedures registered in a database

db2_procedures

(PECL ibm_db2 >= 1.0.0)

db2_procedures — Returns a result set listing the stored procedures registered in a database

说明

db2_procedures ( resource $connection , string $qualifier , string $schema , string $procedure ) : resource

Returns a result set listing the stored procedures registered in a database.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the procedures. This parameter accepts a search pattern containing _ and % as wildcards.

procedure

The name of the procedure. This parameter accepts a search pattern containing _ and % as wildcards.

返回值

Returns a statement resource with a result set containing rows describing the stored procedures matching the specified parameters. The rows are composed of the following columns:

Column name | Description
PROCEDURE_CAT | The catalog that contains the procedure. The value is null if this table does not have catalogs.
PROCEDURE_SCHEM | Name of the schema that contains the stored procedure.
PROCEDURE_NAME | Name of the procedure.
NUM_INPUT_PARAMS | Number of input (IN) parameters for the stored procedure.
NUM_OUTPUT_PARAMS | Number of output (OUT) parameters for the stored procedure.
NUM_RESULT_SETS | Number of result sets returned by the stored procedure.
REMARKS | Any comments about the stored procedure.
PROCEDURE_TYPE | Always returns 1, indicating that the stored procedure does not return a return value.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a single column from a row in the result set

  • ? db2_procedures
  • db2_rollback ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a single column from a row in the result set

db2_result

(PECL ibm_db2 >= 1.0.0)

db2_result — Returns a single column from a row in the result set

说明

db2_result ( resource $stmt , mixed $column ) : mixed

Use db2_result() to return the value of a specified column in the current row of a result set. You must call db2_fetch_row() before calling db2_result() to set the location of the result set pointer.

参数

stmt

A valid stmt resource.

column

Either an integer mapping to the 0-indexed field in the result set, or a string matching the name of the column.

返回值

Returns the value of the requested field if the field exists in the result set. Returns NULL if the field does not exist, and issues a warning.

范例

Example #1 A db2_result() example

The following example demonstrates how to iterate through a result set with db2_fetch_row() and retrieve columns from the result set with db2_result().

<?php
$sql = 'SELECT name, breed FROM animals WHERE weight < ?';
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, array(10));
while (db2_fetch_row($stmt)) {
    $name = db2_result($stmt, 0);
    $breed = db2_result($stmt, 'BREED');
    print "$name $breed";
}
?>

以上例程会输出：

cat Pook
gold fish Bubbles
budgerigar Gizmo
goat Rickety Ride

参见

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row


Rolls back a transaction

  • ? db2_result
  • db2_server_info ?
  • PHP Manual
  • IBM DB2 函数
  • Rolls back a transaction

db2_rollback

(PECL ibm_db2 >= 1.0.0)

db2_rollback — Rolls back a transaction

说明

db2_rollback ( resource $connection ) : bool

Rolls back an in-progress transaction on the specified connection resource and begins a new transaction. PHP applications normally default to AUTOCOMMIT mode, so db2_rollback() normally has no effect unless AUTOCOMMIT has been turned off for the connection resource.

参数

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Rolling back a DELETE statement

In the following example, we count the number of rows in a table, turn off AUTOCOMMIT mode on a database connection, delete all of the rows in the table and return the count of 0 to prove that the rows have been removed. We then issue db2_rollback() and return the updated count of rows in the table to show that the number is the same as before we issued the DELETE statement. The return to the original state of the table demonstrates that the roll back of the transaction succeeded.

<?php
$conn = db2_connect($database, $user, $password);

if ($conn) {
    $stmt = db2_exec($conn, "SELECT count(*) FROM animals");
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";

    // Turn AUTOCOMMIT off
    db2_autocommit($conn, DB2_AUTOCOMMIT_OFF);

    // Delete all rows from ANIMALS
    db2_exec($conn, "DELETE FROM animals");

    $stmt = db2_exec($conn, "SELECT count(*) FROM animals");
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";

    // Roll back the DELETE statement
    db2_rollback( $conn );

    $stmt = db2_exec( $conn, "SELECT count(*) FROM animals" );
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";
    db2_close($conn);
}
?>

以上例程会输出：

7
0
7

参见

  • db2_autocommit() - Returns or sets the AUTOCOMMIT state for a database connection
  • db2_commit() - Commits a transaction


Returns an object with properties that describe the DB2 database server

  • ? db2_rollback
  • db2_set_option ?
  • PHP Manual
  • IBM DB2 函数
  • Returns an object with properties that describe the DB2 database server

db2_server_info

(PECL ibm_db2 >= 1.1.1)

db2_server_info — Returns an object with properties that describe the DB2 database server

说明

db2_server_info ( resource $connection ) : object

This function returns an object with read-only properties that return information about the IBM DB2, Cloudscape, or Apache Derby database server. The following table lists the database server properties:

Database server properties
Property name | Return type | Description
DBMS_NAME | string | The name of the database server to which you are connected. For DB2 servers this is a combination of DB2 followed by the operating system on which the database server is running.
DBMS_VER | string | The version of the database server, in the form of a string "MM.mm.uuuu" where MM is the major version, mm is the minor version, and uuuu is the update. For example, "08.02.0001" represents major version 8, minor version 2, update 1.
DB_CODEPAGE | int | The code page of the database to which you are connected.
DB_NAME | string | The name of the database to which you are connected.
DFT_ISOLATION string

The default transaction isolation level supported by the server:

UR

Uncommitted read: changes are immediately visible by all concurrent transactions.

CS

Cursor stability: a row read by one transaction can be altered and committed by a second concurrent transaction.

RS

Read stability: a transaction can add or remove rows matching a search condition or a pending transaction.

RR

Repeatable read: data affected by pending transaction is not available to other transactions.

NC

No commit: any changes are visible at the end of a successful operation. Explicit commits and rollbacks are not allowed.

IDENTIFIER_QUOTE_CHAR | string | The character used to delimit an identifier.
INST_NAME | string | The instance on the database server that contains the database.
ISOLATION_OPTION | array | An array of the isolation options supported by the database server. The isolation options are described in the DFT_ISOLATION property.
KEYWORDS | array | An array of the keywords reserved by the database server.
LIKE_ESCAPE_CLAUSE | bool | true if the database server supports the use of % and _ wildcard characters. false if the database server does not support these wildcard characters.
MAX_COL_NAME_LEN | int | Maximum length of a column name supported by the database server, expressed in bytes.
MAX_IDENTIFIER_LEN | int | Maximum length of an SQL identifier supported by the database server, expressed in characters.
MAX_INDEX_SIZE | int | Maximum size of columns combined in an index supported by the database server, expressed in bytes.
MAX_PROC_NAME_LEN | int | Maximum length of a procedure name supported by the database server, expressed in bytes.
MAX_ROW_SIZE | int | Maximum length of a row in a base table supported by the database server, expressed in bytes.
MAX_SCHEMA_NAME_LEN | int | Maximum length of a schema name supported by the database server, expressed in bytes.
MAX_STATEMENT_LEN | int | Maximum length of an SQL statement supported by the database server, expressed in bytes.
MAX_TABLE_NAME_LEN | int | Maximum length of a table name supported by the database server, expressed in bytes.
NON_NULLABLE_COLUMNS | bool | true if the database server supports columns that can be defined as NOT NULL, false if the database server does not support columns defined as NOT NULL.
PROCEDURES | bool | true if the database server supports the use of the CALL statement to call stored procedures, false if the database server does not support the CALL statement.
SPECIAL_CHARS | string | A string containing all of the characters other than a-Z, 0-9, and underscore that can be used in an identifier name.
SQL_CONFORMANCE string

The level of conformance to the ANSI/ISO SQL-92 specification offered by the database server:

ENTRY

Entry-level SQL-92 compliance.

FIPS127

FIPS-127-2 transitional compliance.

FULL

Full level SQL-92 compliance.

INTERMEDIATE

Intermediate level SQL-92 compliance.

参数

connection

Specifies an active DB2 client connection.

返回值

Returns an object on a successful call. Returns false on failure.

范例

Example #1 A db2_server_info() example

To retrieve information about the server, you must pass a valid database connection resource to db2_server_info().

<?php

$conn = db2_connect('sample', 'db2inst1', 'ibmdb2');

$server = db2_server_info( $conn );

if ($server) {
    echo "DBMS_NAME: ";                 var_dump( $server->DBMS_NAME );
    echo "DBMS_VER: ";                  var_dump( $server->DBMS_VER );
    echo "DB_CODEPAGE: ";               var_dump( $server->DB_CODEPAGE );
    echo "DB_NAME: ";                   var_dump( $server->DB_NAME );
    echo "INST_NAME: ";                 var_dump( $server->INST_NAME );
    echo "SPECIAL_CHARS: ";             var_dump( $server->SPECIAL_CHARS );
    echo "KEYWORDS: ";                  var_dump( sizeof($server->KEYWORDS) );
    echo "DFT_ISOLATION: ";             var_dump( $server->DFT_ISOLATION );
    echo "ISOLATION_OPTION: ";
    $il = '';
    foreach( $server->ISOLATION_OPTION as $opt )
    {
       $il .= $opt." ";
    }
    var_dump( $il );
    echo "SQL_CONFORMANCE: ";           var_dump( $server->SQL_CONFORMANCE );
    echo "PROCEDURES: ";                var_dump( $server->PROCEDURES );
    echo "IDENTIFIER_QUOTE_CHAR: ";     var_dump( $server->IDENTIFIER_QUOTE_CHAR );
    echo "LIKE_ESCAPE_CLAUSE: ";        var_dump( $server->LIKE_ESCAPE_CLAUSE );
    echo "MAX_COL_NAME_LEN: ";          var_dump( $server->MAX_COL_NAME_LEN );
    echo "MAX_ROW_SIZE: ";              var_dump( $server->MAX_ROW_SIZE );
    echo "MAX_IDENTIFIER_LEN: ";        var_dump( $server->MAX_IDENTIFIER_LEN );
    echo "MAX_INDEX_SIZE: ";            var_dump( $server->MAX_INDEX_SIZE );
    echo "MAX_PROC_NAME_LEN: ";         var_dump( $server->MAX_PROC_NAME_LEN );
    echo "MAX_SCHEMA_NAME_LEN: ";       var_dump( $server->MAX_SCHEMA_NAME_LEN );
    echo "MAX_STATEMENT_LEN: ";         var_dump( $server->MAX_STATEMENT_LEN );
    echo "MAX_TABLE_NAME_LEN: ";        var_dump( $server->MAX_TABLE_NAME_LEN );
    echo "NON_NULLABLE_COLUMNS: ";      var_dump( $server->NON_NULLABLE_COLUMNS );

    db2_close($conn);
}
?>

以上例程会输出：

DBMS_NAME: string(9) "DB2/LINUX"
DBMS_VER: string(10) "08.02.0000"
DB_CODEPAGE: int(1208)
DB_NAME: string(6) "SAMPLE"
INST_NAME: string(8) "db2inst1"
SPECIAL_CHARS: string(2) "@#"
KEYWORDS: int(179)
DFT_ISOLATION: string(2) "CS"
ISOLATION_OPTION: string(12) "UR CS RS RR "
SQL_CONFORMANCE: string(7) "FIPS127"
PROCEDURES: bool(true)
IDENTIFIER_QUOTE_CHAR: string(1) """
LIKE_ESCAPE_CLAUSE: bool(true)
MAX_COL_NAME_LEN: int(30)
MAX_ROW_SIZE: int(32677)
MAX_IDENTIFIER_LEN: int(18)
MAX_INDEX_SIZE: int(1024)
MAX_PROC_NAME_LEN: int(128)
MAX_SCHEMA_NAME_LEN: int(30)
MAX_STATEMENT_LEN: int(2097152)
MAX_TABLE_NAME_LEN: int(128)
NON_NULLABLE_COLUMNS: bool(true)

参见

  • db2_client_info() - Returns an object with properties that describe the DB2 database client


Set options for connection or statement resources

  • ? db2_server_info
  • db2_special_columns ?
  • PHP Manual
  • IBM DB2 函数
  • Set options for connection or statement resources

db2_set_option

(PECL ibm_db2 >= 1.0.0)

db2_set_option — Set options for connection or statement resources

说明

db2_set_option ( resource $resource , array $options , int $type ) : bool

Sets options for a statement resource or a connection resource. You cannot set options for result set resources.

参数

resource

A valid statement resource as returned from db2_prepare() or a valid connection resource as returned from db2_connect() or db2_pconnect().

options

An associative array containing valid statement or connection options. This parameter can be used to change autocommit values, cursor types (scrollable or forward), and to specify the case of the column names (lower, upper, or natural) that will appear in a result set.

autocommit

Passing DB2_AUTOCOMMIT_ON turns autocommit on for the specified connection resource.

Passing DB2_AUTOCOMMIT_OFF turns autocommit off for the specified connection resource.

cursor

Passing DB2_FORWARD_ONLY specifies a forward-only cursor for a statement resource. This is the default cursor type, and is supported by all database servers.

Passing DB2_SCROLLABLE specifies a scrollable cursor for a statement resource. Scrollable cursors enable result set rows to be accessed in non-sequential order, but are only supported by IBM DB2 Universal Database databases.

binmode

Passing DB2_BINARY specifies that binary data will be returned as is. This is the default mode. This is the equivalent of setting ibm_db2.binmode=1 in php.ini.

Passing DB2_CONVERT specifies that binary data will be converted to hexadecimal encoding, and will be returned as such. This is the equivalent of setting ibm_db2.binmode=2 in php.ini.

Passing DB2_PASSTHRU specifies that binary data will be converted to null. This is the equivalent of setting ibm_db2.binmode=3 in php.ini.

db2_attr_case

Passing DB2_CASE_LOWER specifies that column names of the result set are returned in lower case.

Passing DB2_CASE_UPPER specifies that column names of the result set are returned in upper case.

Passing DB2_CASE_NATURAL specifies that column names of the result set are returned in natural case.

deferred_prepare

Passing DB2_DEFERRED_PREPARE_ON turns deferred prepare on for the specified statement resource.

Passing DB2_DEFERRED_PREPARE_OFF turns deferred prepare off for the specified statement resource.

The following new i5/OS options are available in ibm_db2 version 1.5.1 and later. These options apply only when running PHP and ibm_db2 natively on i5 systems.

i5_fetch_only

DB2_I5_FETCH_ON - Cursors are read-only and cannot be used for positioned updates or deletes. This is the default unless SQL_ATTR_FOR_FETCH_ONLY environment has been set to SQL_FALSE.

DB2_I5_FETCH_OFF - Cursors can be used for positioned updates and deletes.

The following new option is available in ibm_db2 version 1.8.0 and later.

rowcount

DB2_ROWCOUNT_PREFETCH_ON - Client can request the full row count prior to fetching, which means that db2_num_rows() returns the number of rows selected even when a ROLLFORWARD_ONLY cursor is used.

DB2_ROWCOUNT_PREFETCH_OFF - Client cannot request the full row count prior to fetching.

The following new options are available in ibm_db2 version 1.7.0 and later.

trusted_user

To switch the user to a trusted user, pass the User ID (String) of the trusted user as the value of this key. This option can be set on a connection resource only. To use this option, trusted context must be enabled on the connection resource.

trusted_password

The password (String) that corresponds to the user specified by the trusted_user key.

The following new options are available in ibm_db2 version 1.6.0 and later. These options provide useful tracking information that can be accessed during execution with db2_get_option().

Note:

When the value in each option is being set, some servers might not handle the entire length provided and might truncate the value.

To ensure that the data specified in each option is converted correctly when transmitted to a host system, use only the characters A through Z, 0 through 9, and the underscore (_) or period (.).

userid

SQL_ATTR_INFO_USERID - A pointer to a null-terminated character string used to identify the client user ID sent to the host database server when using DB2 Connect.

Note:

DB2 for z/OS and OS/390 servers support up to a length of 16 characters. This user-id is not to be confused with the authentication user-id, it is for identification purposes only and is not used for any authorization.

acctstr

SQL_ATTR_INFO_ACCTSTR - A pointer to a null-terminated character string used to identify the client accounting string sent to the host database server when using DB2 Connect.

Note:

DB2 for z/OS and OS/390 servers support up to a length of 200 characters.

applname

SQL_ATTR_INFO_APPLNAME - A pointer to a null-terminated character string used to identify the client application name sent to the host database server when using DB2 Connect.

Note:

DB2 for z/OS and OS/390 servers support up to a length of 32 characters.

wrkstnname

SQL_ATTR_INFO_WRKSTNNAME - A pointer to a null-terminated character string used to identify the client workstation name sent to the host database server when using DB2 Connect.

Note:

DB2 for z/OS and OS/390 servers support up to a length of 18 characters.

type

An integer value that specifies the type of resource that was passed into the function. The type of resource and this value must correspond.

Passing 1 as the value specifies that a connection resource has been passed into the function.

Passing any integer not equal to 1 as the value specifies that a statement resource has been passed into the function.

The following table specifies which options are compatible with the available resource types:

Resource-Parameter Matrix
Key | Value | Resource Type
 |  | Connection | Statement | Result Set
autocommit | DB2_AUTOCOMMIT_ON | X | - | -
autocommit | DB2_AUTOCOMMIT_OFF | X | - | -
cursor | DB2_SCROLLABLE | - | X | -
cursor | DB2_FORWARD_ONLY | - | X | -
binmode | DB2_BINARY | X | X | -
binmode | DB2_CONVERT | X | X | -
binmode | DB2_PASSTHRU | X | X | -
db2_attr_case | DB2_CASE_LOWER | X | X | -
db2_attr_case | DB2_CASE_UPPER | X | X | -
db2_attr_case | DB2_CASE_NATURAL | X | X | -
deferred_prepare | DB2_DEFERRED_PREPARE_ON | - | X | -
deferred_prepare | DB2_DEFERRED_PREPARE_OFF | - | X | -
i5_fetch_only | DB2_I5_FETCH_ON | - | X | -
i5_fetch_only | DB2_I5_FETCH_OFF | - | X | -
rowcount | DB2_ROWCOUNT_PREFETCH_ON | - | X | -
rowcount | DB2_ROWCOUNT_PREFETCH_OFF | - | X | -
trusted_user | <USER NAME> (String) | X | - | -
trusted_password | <PASSWORD> (String) | X | - | -
userid | SQL_ATTR_INFO_USERID | X | X | -
acctstr | SQL_ATTR_INFO_ACCTSTR | X | X | -
applname | SQL_ATTR_INFO_APPLNAME | X | X | -
wrkstnname | SQL_ATTR_INFO_WRKSTNNAME | X | X | -

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Setting one parameter with a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_ON);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

以上例程会输出：

Options Set Successfully

Example #2 Setting multiple parameters with a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

以上例程会输出：

Options Set Successfully

Example #3 Setting multiple parameters with an invalid key

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
             'MY_INVALID_KEY' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

以上例程会输出：

Could Not Set Options

Example #4 Setting multiple parameters with an invalid value

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => 'INVALID_VALUE',
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

以上例程会输出：

Could Not Set Options

Example #5 Setting multiple parameters with a connection resource and the wrong type

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and the wrong type value */
$result = db2_set_option($conn, $options, 2);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

以上例程会输出：

Could Not Set Options

Example #6 Setting multiple parameters with the wrong resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

$stmt = db2_prepare($conn, 'SELECT * FROM EMPLOYEE');

/* Call the function using the wrong resource, and the correct options array, and type values */
$result = db2_set_option($stmt, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

以上例程会输出：

Could Not Set Options

Example #7 Putting it all together

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('db2_attr_case' => DB2_CASE_LOWER,
                        'cursor' => DB2_SCROLLABLE);

$stmt = db2_prepare($conn, 'SELECT * FROM EMPLOYEE WHERE EMPNO = ? OR EMPNO = ?');

/* Call the function using the correct resource, options array, and type values */
$option_result = db2_set_option($stmt, $options, 2);
$result = db2_execute($stmt, array('000130', '000140'));

/* Get Row 2 before Row 1 since Scrollable Cursor */
print_r(db2_fetch_assoc($stmt, 2));
print '<br /><br />';
print_r(db2_fetch_assoc($stmt, 1));

?>

以上例程会输出：

Array
(
    [empno] => 000140
    [firstnme] => HEATHER
    [midinit] => A
    [lastname] => NICHOLLS
    [workdept] => C01
    [phoneno] => 1793
    [hiredate] => 1976-12-15
    [job] => ANALYST
    [edlevel] => 18
    [sex] => F
    [birthdate] => 1946-01-19
    [salary] => 28420.00
    [bonus] => 600.00
    [comm] => 2274.00
)

Array
(
    [empno] => 000130
    [firstnme] => DELORES
    [midinit] => M
    [lastname] => QUINTANA
    [workdept] => C01
    [phoneno] => 4578
    [hiredate] => 1971-07-28
    [job] => ANALYST
    [edlevel] => 16
    [sex] => F
    [birthdate] => 1925-09-15
    [salary] => 23800.00
    [bonus] => 500.00
    [comm] => 1904.00
)

Example #8 i5/OS cursors are read-only

<?php
  $conn = db2_connect("", "", "", array("i5_lib"=>"nobody"));
  $stmt = db2_prepare($conn, 'select * from names where first = ?');
  $name = "first2";
  db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
  $options = array("i5_fetch_only"=>DB2_I5_FETCH_ON);
  db2_set_option($stmt,$options,0);
  if (db2_execute($stmt)) {
    while ($row = db2_fetch_array($stmt)) {
      echo "{$row[0]} {$row[1]}";
    }
  }
?>

以上例程会输出：

first2 last2

参见

  • db2_connect() - Returns a connection to a database
  • db2_pconnect() - Returns a persistent connection to a database
  • db2_exec() - Executes an SQL statement directly
  • db2_prepare() - Prepares an SQL statement to be executed
  • db2_cursor_type() - Returns the cursor type used by a statement resource


Returns a result set listing the unique row identifier columns for a table

  • ? db2_set_option
  • db2_statistics ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing the unique row identifier columns for a table

db2_special_columns

(PECL ibm_db2 >= 1.0.0)

db2_special_columns — Returns a result set listing the unique row identifier columns for a table

说明

db2_special_columns ( resource $connection , string $qualifier , string $schema , string $table_name , int $scope ) : resource

Returns a result set listing the unique row identifier columns for a table.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables.

table_name

The name of the table.

scope

Integer value representing the minimum duration for which the unique row identifier is valid. This can be one of the following values:

Integer value | SQL constant | Description
0 | SQL_SCOPE_CURROW | Row identifier is valid only while the cursor is positioned on the row.
1 | SQL_SCOPE_TRANSACTION | Row identifier is valid for the duration of the transaction.
2 | SQL_SCOPE_SESSION | Row identifier is valid for the duration of the connection.

返回值

Returns a statement resource with a result set containing rows with unique row identifier information for a table. The rows are composed of the following columns:

Column name | Description
SCOPE

Integer value | SQL constant | Description
0 | SQL_SCOPE_CURROW | Row identifier is valid only while the cursor is positioned on the row.
1 | SQL_SCOPE_TRANSACTION | Row identifier is valid for the duration of the transaction.
2 | SQL_SCOPE_SESSION | Row identifier is valid for the duration of the connection.
COLUMN_NAME | Name of the unique column.
DATA_TYPE | SQL data type for the column.
TYPE_NAME | Character string representation of the SQL data type for the column.
COLUMN_SIZE | An integer value representing the size of the column.
BUFFER_LENGTH | Maximum number of bytes necessary to store data from this column.
DECIMAL_DIGITS | The scale of the column, or null where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or null (representing a data type for which radix is not applicable).
PSEUDO_COLUMN | Always returns 1.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a result set listing the index and statistics for a table

  • ? db2_special_columns
  • db2_stmt_error ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing the index and statistics for a table

db2_statistics

(PECL ibm_db2 >= 1.0.0)

db2_statistics — Returns a result set listing the index and statistics for a table

说明

db2_statistics ( resource $connection , string $qualifier , string $schema , string $table-name , bool $unique ) : resource

Returns a result set listing the index and statistics for a table.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema that contains the targeted table. If this parameter is null, the statistics and indexes are returned for the schema of the current user.

table_name

The name of the table.

unique

An integer value representing the type of index information to return.

0

Return only the information for unique indexes on the table.

1

Return the information for all indexes on the table.

返回值

Returns a statement resource with a result set containing rows describing the statistics and indexes for the base tables matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is null if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
NON_UNIQUE

An integer value representing whether the index prohibits unique values, or whether the row represents statistics on the table itself:

Return value | Parameter type
0 (SQL_FALSE) | The index allows duplicate values.
1 (SQL_TRUE) | The index values must be unique.
null | This row is statistics information for the table itself.
INDEX_QUALIFIER | A string value representing the qualifier that would have to be prepended to INDEX_NAME to fully qualify the index.
INDEX_NAME | A string representing the name of the index.
TYPE

An integer value representing the type of information contained in this row of the result set:

Return value | Parameter type
0 (SQL_TABLE_STAT) | The row contains statistics about the table itself.
1 (SQL_INDEX_CLUSTERED) | The row contains information about a clustered index.
2 (SQL_INDEX_HASH) | The row contains information about a hashed index.
3 (SQL_INDEX_OTHER) | The row contains information about a type of index that is neither clustered nor hashed.
ORDINAL_POSITION | The 1-indexed position of the column in the index. null if the row contains statistics information about the table itself.
COLUMN_NAME | The name of the column in the index. null if the row contains statistics information about the table itself.
ASC_OR_DESC | A if the column is sorted in ascending order, D if the column is sorted in descending order, null if the row contains statistics information about the table itself.
CARDINALITY

If the row contains information about an index, this column contains an integer value representing the number of unique values in the index.

If the row contains information about the table itself, this column contains an integer value representing the number of rows in the table.

PAGES

If the row contains information about an index, this column contains an integer value representing the number of pages used to store the index.

If the row contains information about the table itself, this column contains an integer value representing the number of pages used to store the table.

FILTER_CONDITION | Always returns null.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a string containing the SQLSTATE returned by an SQL statement

  • ? db2_statistics
  • db2_stmt_errormsg ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a string containing the SQLSTATE returned by an SQL statement

db2_stmt_error

(PECL ibm_db2 >= 1.0.0)

db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement

说明

db2_stmt_error ( resource $stmt = ? ) : string

Returns a string containing the SQLSTATE value returned by an SQL statement.

If you do not pass a statement resource as an argument to db2_stmt_error(), the driver returns the SQLSTATE value associated with the last attempt to return a statement resource, for example, from db2_prepare() or db2_exec().

To learn what the SQLSTATE value means, you can issue the following command at a DB2 Command Line Processor prompt: db2 '? sqlstate-value'. You can also call db2_stmt_errormsg() to retrieve an explicit error message and the associated SQLCODE value.

参数

stmt

A valid statement resource.

返回值

Returns a string containing an SQLSTATE value.

参见

  • db2_conn_error() - Returns a string containing the SQLSTATE returned by the last connection attempt
  • db2_conn_errormsg() - Returns the last connection error message and SQLCODE value
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message


Returns a string containing the last SQL statement error message

  • ? db2_stmt_error
  • db2_table_privileges ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a string containing the last SQL statement error message

db2_stmt_errormsg

(PECL ibm_db2 >= 1.0.0)

db2_stmt_errormsg — Returns a string containing the last SQL statement error message

说明

db2_stmt_errormsg ( resource $stmt = ? ) : string

Returns a string containing the last SQL statement error message.

If you do not pass a statement resource as an argument to db2_stmt_errormsg(), the driver returns the error message associated with the last attempt to return a statement resource, for example, from db2_prepare() or db2_exec().

参数

stmt

A valid statement resource.

返回值

Returns a string containing the error message and SQLCODE value for the last error that occurred issuing an SQL statement.

参见

  • db2_conn_error() - Returns a string containing the SQLSTATE returned by the last connection attempt
  • db2_conn_errormsg() - Returns the last connection error message and SQLCODE value
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement


Returns a result set listing the tables and associated privileges in a database

  • ? db2_stmt_errormsg
  • db2_tables ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing the tables and associated privileges in a database

db2_table_privileges

(PECL ibm_db2 >= 1.0.0)

db2_table_privileges — Returns a result set listing the tables and associated privileges in a database

说明

db2_table_privileges ( resource $connection , string $qualifier = ? , string $schema = ? , string $table_name = ? ) : resource

Returns a result set listing the tables and associated privileges in a database.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables. This parameter accepts a search pattern containing _ and % as wildcards.

table_name

The name of the table. This parameter accepts a search pattern containing _ and % as wildcards.

返回值

Returns a statement resource with a result set containing rows describing the privileges for the tables that match the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is null if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
GRANTOR | Authorization ID of the user who granted the privilege.
GRANTEE | Authorization ID of the user to whom the privilege was granted.
PRIVILEGE | The privilege that has been granted. This can be one of ALTER, CONTROL, DELETE, INDEX, INSERT, REFERENCES, SELECT, or UPDATE.
IS_GRANTABLE | A string value of "YES" or "NO" indicating whether the grantee can grant the privilege to other users.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database


Returns a result set listing the tables and associated metadata in a database

  • ? db2_table_privileges
  • Ingres ?
  • PHP Manual
  • IBM DB2 函数
  • Returns a result set listing the tables and associated metadata in a database

db2_tables

(PECL ibm_db2 >= 1.0.0)

db2_tables — Returns a result set listing the tables and associated metadata in a database

说明

db2_tables ( resource $connection , string $qualifier = ? , string $schema = ? , string $table-name = ? , string $table-type = ? ) : resource

Returns a result set listing the tables and associated metadata in a database.

参数

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass null or an empty string.

schema

The schema which contains the tables. This parameter accepts a search pattern containing _ and % as wildcards.

table-name

The name of the table. This parameter accepts a search pattern containing _ and % as wildcards.

table-type

A list of comma-delimited table type identifiers. To match all table types, pass null or an empty string. Valid table type identifiers include: ALIAS, HIERARCHY TABLE, INOPERATIVE VIEW, NICKNAME, MATERIALIZED QUERY TABLE, SYSTEM TABLE, TABLE, TYPED TABLE, TYPED VIEW, and VIEW.

返回值

Returns a statement resource with a result set containing rows describing the tables that match the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is null if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
TABLE_TYPE | Table type identifier for the table.
REMARKS | Description of the table.

参见

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database


Ingres DBMS, EDBC, and Enterprise Access Gateways

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic usage
  • Ingres 函数
    • ingres_autocommit_state — Test if the connection is using autocommit
    • ingres_autocommit — Switch autocommit on or off
    • ingres_charset — Returns the installation character set
    • ingres_close — Close an Ingres database connection
    • ingres_commit — Commit a transaction
    • ingres_connect — Open a connection to an Ingres database
    • ingres_cursor — Get a cursor name for a given result resource
    • ingres_errno — Get the last Ingres error number generated
    • ingres_error — Get a meaningful error message for the last error generated
    • ingres_errsqlstate — Get the last SQLSTATE error code generated
    • ingres_escape_string — Escape special characters for use in a query
    • ingres_execute — Execute a prepared query
    • ingres_fetch_array — Fetch a row of result into an array
    • ingres_fetch_assoc — Fetch a row of result into an associative array
    • ingres_fetch_object — Fetch a row of result into an object
    • ingres_fetch_proc_return — Get the return value from a procedure call
    • ingres_fetch_row — Fetch a row of result into an enumerated array
    • ingres_field_length — Get the length of a field
    • ingres_field_name — Get the name of a field in a query result
    • ingres_field_nullable — Test if a field is nullable
    • ingres_field_precision — Get the precision of a field
    • ingres_field_scale — Get the scale of a field
    • ingres_field_type — Get the type of a field in a query result
    • ingres_free_result — Free the resources associated with a result identifier
    • ingres_next_error — Get the next Ingres error
    • ingres_num_fields — Get the number of fields returned by the last query
    • ingres_num_rows — Get the number of rows affected or returned by a query
    • ingres_pconnect — Open a persistent connection to an Ingres database
    • ingres_prepare — Prepare a query for later execution
    • ingres_query — Send an SQL query to Ingres
    • ingres_result_seek — Set the row position before fetching data
    • ingres_rollback — Roll back a transaction
    • ingres_set_environment — Set environment features controlling output options
    • ingres_unbuffered_query — Send an unbuffered SQL query to Ingres


简介

The Ingres driver for PHP enables you to connect to and query the Ingres DBMS, EDBC, and Enterprise Access Gateways.

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.1.0.


需求

To use or build the PHP extension for Ingres you must have a working Ingres client environment. You can download the client software for Ingres from » http://esd.ingres.com/.


安装

此 » PECL 扩展未与 PHP 捆绑。 安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ingres.

You can download the DLL for this PECL extension from » http://esd.ingres.com/product/drivers/PHP/.

To have these functions available, you must » download and compile this extension, enabling Ingres support using the --with-ingres[=DIR] option, where DIR is the Ingres base directory. If the II_SYSTEM environment variable is not set correctly you may need to use --with-ingres=DIR to specify your Ingres installation directory.

PHP code written for version 2.x and later is not backward-compatible with earlier versions of this PHP extension. However, it is possible to run two incompatible releases within the same PHP environment using the --enable-ingres2 option. This configuration option renames the extension to ingres2, changing function names, configuration settings, and constants. For example, with this option enabled, ingres_connect() becomes ingres2_connect().

To use this extension the system environment variable II_SYSTEM must be defined. Linux and UNIX users will also need to define the shared library search path, for example, LD_LIBRARY_PATH. When used with the Apache web server these variables must be set explicitly in the startup script for Apache. In addition, the PassEnv directive is required for the Ingres extension to load the correct shared libraries. For example:

Example #1 Example usage of PassEnv for Ingres

<IfModule mod_env.c>
    PassEnv II_SYSTEM
    PassEnv LD_LIBRARY_PATH
</IfModule>

Note:

For example configurations for different web servers and operating systems see » http://community.ingres.com/wiki/Ingres_Articles#Ingres_and_Web_Servers.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Ingres configuration options
名字 | 默认 | 可修改范围 | 更新日志
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.array_index_start | "1" | PHP_INI_ALL | Available since ingres 1.4.0.
ingres.auto | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.blob_segment_length | "4096" | PHP_INI_ALL | Available since ingres 1.2.0.
ingres.cursor_mode | "0" | PHP_INI_ALL | Available since ingres 1.1.0.
ingres.default_database | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.default_password | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.default_user | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.describe | 1 | PHP_INI_ALL | Available since ingres 2.1.0
ingres.fetch_buffer_size | 100 | PHP_INI_ALL | Available since ingres 2.1.0
ingres.max_links | "-1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.reuse_connection | "1" | PHP_INI_ALL | Available since ingres 2.0.0
ingres.scrollable | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.trace | "0" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.trace_connect | "0" | PHP_INI_ALL | Available since ingres 1.2.1.
ingres.utf8 | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

ingres.allow_persistent bool

Specifies whether to allow persistent connections to Ingres

ingres.array_index_start int

Specifies the start value for an integer key for arrays generated by ingres_fetch_row() or ingres_fetch_array(). By default ingres.array_index_start is set to 1. If you wish to make the ingres extension behave like other database extensions set this configuration option to 0.

ingres.auto bool

Enables or disables autocommit emulation. Ingres cannot have multiple cursors open with autocommit enabled. When enabled, the driver emulates autocommit.

ingres.blob_segment_length int

Specifies the amount of memory to use when reading BLOB data, in bytes

ingres.cursor_mode int

Specifies the default mode for cursors opened with ingres_prepare(). Valid values are INGRES_CURSOR_UPDATE or INGRES_CURSOR_READONLY.

ingres.default_database string

Specifies the default database name to use when connecting to the database server if no other name is specified. Does not apply in SQL 安全模式.

ingres.default_password string

Specifies the default password to use when connecting to the database server if no other name is specified. Does not apply in SQL 安全模式.

ingres.default_user string

Specifies the default user name to use when connecting to the database server if no other name is specified. Does not apply in SQL 安全模式.

ingres.describe bool

Enables the use of DESCRIBE INPUT to determine the expected data types for queries that use parameters. Available with Ingres 9.1.0 and later. When disabled, queries that have parameters passed may need to manually describe the types of those parameters using the types parameter in ingres_query().

Note:

Enabling this feature with ingres_query() will cause additional communications traffic between this extension and the server. To minimize this additional traffic, use ingres_prepare() and ingres_execute().

ingres.fetch_buffer_size int

Specifies the number of pre-fetch rows that ingres_fetch_array(), ingres_fetch_object() and ingres_fetch_row() will try and fetch in one fetch operation.

ingres.max_links int

Specifies the maximum number of Ingres sessions allowed per process or thread. The number of sessions should not exceed the total number of connected sessions configured within Ingres.

ingres.max_persistent int

Specifies the maximum number of persistent Ingres sessions allowed per process or thread. The number of sessions should not exceed the total number of connected sessions configured within Ingres.

ingres.reuse_connection bool

Reuses an existing active connection if connecting to the same database with the same user name

ingres.scrollable bool

Enables support for scrollable cursors. When fetching CLOB or BLOB data, this should be set to false. Available with Ingres 9.2.0 or later.

ingres.trace bool

Enables simple tracing using E_NOTICE messages

ingres.trace_connect bool

Prints E_NOTICE messages during ingres_connect() or ingres_pconnect() calls

ingres.utf8 bool

Assumes that strings being passed to National Character column types (NVARCHAR or NCHAR) are using UTF8 encoding and converts them to UTF16 for the server


资源类型

ingres_connect() and ingres_pconnect() return an Ingres link identifier.

ingres_query() and ingres_unbuffered_query() return an Ingres result identifier.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

INGRES_ASSOC (int)
Columns are returned into the array having the fieldname as the array index. Used with ingres_fetch_array().
INGRES_NUM (int)
Columns are returned into the array having a numerical index to the fields. By default this index starts at 1, the first field in the result. To change this value, see ingres.array_index_start. Used with ingres_fetch_array().
INGRES_BOTH (int)
Columns are returned into the array having both a numerical index and the fieldname as the array index. Used with ingres_fetch_array().
INGRES_EXT_VERSION (string)
Specifies the version of the Ingres Extension. Available since version 1.2.0 of the PECL extension.
INGRES_API_VERSION (int)
Specifies the version of Ingres OpenAPI that the extension was built against. Available since version 1.2.0 of the PECL extension.
INGRES_CURSOR_READONLY (int)
Specifies that Ingres cursors should be opened in "readonly" mode. Available since version 1.2.0 of the PECL extension. Used with ingres.cursor_mode.
INGRES_CURSOR_UPDATE (int)
Specifies that Ingres cursors should be opened "for update." Available since version 1.2.0 of the PECL extension. Used with ingres.cursor_mode.
INGRES_DATE_MULTINATIONAL (int)
Equivalent to the II_DATE_FORMAT setting of MULTINATIONAL. Available since version 1.2.0 of the PECL extension. Used with ingres_connect(), ingres_pconnect() and ingres_set_environment(). See options in ingres_set_environment().
INGRES_DATE_MULTINATIONAL4 (int)
Equivalent to the II_DATE_FORMAT setting of MULTINATIONAL4. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_FINNISH (int)
Equivalent to the II_DATE_FORMAT setting of FINNISH. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_ISO (int)
Equivalent to the II_DATE_FORMAT setting of ISO. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_ISO4 (int)
Equivalent to the II_DATE_FORMAT setting of ISO4. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_GERMAN (int)
Equivalent to the II_DATE_FORMAT setting of GERMAN. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_MDY (int)
Equivalent to the II_DATE_FORMAT setting of MDY. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_DMY (int)
Equivalent to the II_DATE_FORMAT setting of DMY. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_YMD (int)
Equivalent to the II_DATE_FORMAT setting of YMD. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_MONEY_LEADING (int)
Specifies the currency character that should be placed at the start of a money value. Equivalent to setting II_MONEY_FORMAT to "L:". Available since version 1.2.0 of the PECL extension. Used with ingres_connect(), ingres_pconnect() and ingres_set_environment(). See options in ingres_set_environment().
INGRES_MONEY_TRAILING (int)
Specifies the currency character that should be placed at the end of a money value. Equivalent to setting II_MONEY_FORMAT to "T:". Available since version 1.2.0 of the PECL extension. Used with ingres_connect(), ingres_pconnect() and ingres_set_environment(). See options in ingres_set_environment().
INGRES_STRUCTURE_BTREE (int)
Specifies the default table or index structure to BTREE when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_CBTREE (int)
Specifies the default table or index structure to COMPRESSED BTREE when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_HASH (int)
Specifies the default table or index structure to HASH when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_CHASH (int)
Specifies the default table or index structure to COMPRESSED HASH when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_HEAP (int)
Specifies the default table structure to HEAP when used in combination with the
options option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_CHEAP (int)
Specifies the default table structure to COMPRESSED HEAP when used in combination with the
options option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_ISAM (int)
Specifies the default table or index structure to ISAM when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_CISAM (int)
Specifies the default table or index structure to COMPRESSED ISAM when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().


  • ? 预定义常量
  • Basic usage ?
  • PHP Manual
  • Ingres
  • 范例

范例

Table of Contents

  • Basic usage


Basic usage

The following simple example shows how to connect to an Ingres database, execute a query, print resulting rows and disconnect from the database.

Example #1 Simple Ingres Example

<?php
// Connecting, selecting database
$link = ingres_connect("database", "user", "password")
    or die("Could not connect: " . ingres_error($link));
echo "Connected successfully";

// Select from a table that exists in all Ingres databases
$query = "SELECT * FROM iitables";
$result = ingres_query($link,$query) or die("Query failed: " .
ingres_error($link));

// Print results in HTML
// relid - table name
// relowner - table owner
echo "<table>\n";
while ($iitables = ingres_fetch_object($result)) {
    echo "\t<tr>\n";
    echo "\t\t<td>" . $iitables->relid . "</td>\n";
    echo "\t\t<td>" . $iitables->relowner . "</td>\n";
    echo "\t</tr>\n";
}
echo "</table>\n";

// Free results
ingres_free_result($result);

// Commit transaction
ingres_commit($link);

// Closing connection
ingres_close($link);
?>


Ingres 函数

Table of Contents

  • ingres_autocommit_state — Test if the connection is using autocommit
  • ingres_autocommit — Switch autocommit on or off
  • ingres_charset — Returns the installation character set
  • ingres_close — Close an Ingres database connection
  • ingres_commit — Commit a transaction
  • ingres_connect — Open a connection to an Ingres database
  • ingres_cursor — Get a cursor name for a given result resource
  • ingres_errno — Get the last Ingres error number generated
  • ingres_error — Get a meaningful error message for the last error generated
  • ingres_errsqlstate — Get the last SQLSTATE error code generated
  • ingres_escape_string — Escape special characters for use in a query
  • ingres_execute — Execute a prepared query
  • ingres_fetch_array — Fetch a row of result into an array
  • ingres_fetch_assoc — Fetch a row of result into an associative array
  • ingres_fetch_object — Fetch a row of result into an object
  • ingres_fetch_proc_return — Get the return value from a procedure call
  • ingres_fetch_row — Fetch a row of result into an enumerated array
  • ingres_field_length — Get the length of a field
  • ingres_field_name — Get the name of a field in a query result
  • ingres_field_nullable — Test if a field is nullable
  • ingres_field_precision — Get the precision of a field
  • ingres_field_scale — Get the scale of a field
  • ingres_field_type — Get the type of a field in a query result
  • ingres_free_result — Free the resources associated with a result identifier
  • ingres_next_error — Get the next Ingres error
  • ingres_num_fields — Get the number of fields returned by the last query
  • ingres_num_rows — Get the number of rows affected or returned by a query
  • ingres_pconnect — Open a persistent connection to an Ingres database
  • ingres_prepare — Prepare a query for later execution
  • ingres_query — Send an SQL query to Ingres
  • ingres_result_seek — Set the row position before fetching data
  • ingres_rollback — Roll back a transaction
  • ingres_set_environment — Set environment features controlling output options
  • ingres_unbuffered_query — Send an unbuffered SQL query to Ingres


Test if the connection is using autocommit

  • ? Ingres 函数
  • ingres_autocommit ?
  • PHP Manual
  • Ingres 函数
  • Test if the connection is using autocommit

ingres_autocommit_state

(PECL ingres >= 2.0.0)

ingres_autocommit_state — Test if the connection is using autocommit

说明

ingres_autocommit_state ( resource $link ) : bool

ingres_autocommit_state() is called to determine whether the current link has autocommit enabled or not.

参数

link

The connection link identifier

返回值

Returns true if autocommit is enabled or false when autocommit is disabled

参见

  • ingres_autocommit() - Switch autocommit on or off
  • ingres_query() - Send an SQL query to Ingres


Switch autocommit on or off

  • ? ingres_autocommit_state
  • ingres_charset ?
  • PHP Manual
  • Ingres 函数
  • Switch autocommit on or off

ingres_autocommit

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_autocommit — Switch autocommit on or off

说明

ingres_autocommit ( resource $link ) : bool

ingres_autocommit() is called before opening a transaction (before the first call to ingres_query() or just after a call to ingres_rollback() or ingres_commit()) to switch the autocommit mode of the server on or off (when the script begins the autocommit mode is off).

When autocommit mode is on, every query is automatically committed by the server, as if ingres_commit() was called after every call to ingres_query(). To see if autocommit is enabled use, ingres_autocommit_state().

By default Ingres will rollback any uncommitted transactions at the end of a request. Use this function or ingres_commit() to ensure your data is committed to the database.

参数

link

The connection link identifier

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ingres_autocommit_state() - Test if the connection is using autocommit
  • ingres_query() - Send an SQL query to Ingres
  • ingres_rollback() - Roll back a transaction
  • ingres_commit() - Commit a transaction


Returns the installation character set

  • ? ingres_autocommit
  • ingres_close ?
  • PHP Manual
  • Ingres 函数
  • Returns the installation character set

ingres_charset

(PECL ingres >= 2.1.0)

ingres_charset — Returns the installation character set

说明

ingres_charset ( resource $link ) : string

ingres_charset() is called to determine the character set being used by the Ingres client, from II_CHARSETxx (where xx is the installation code).

Note:

You can override the value returned by using the function putenv(). Changing the value of II_CHARSETxx in a running Ingres installation can cause data corruption.

参数

link

The connection link identifier

返回值

Returns a string with the value for II_CHARSETxx or returns NULL if the value could not be determined.

范例

Example #1 ingres_charset() - Get the installation character set

<?php
$link = ingres_connect($database, $user, $password);

echo ingres_charset($link) . "\n";

ingres_close($link);
?>

参见

  • ingres_connect() - Open a connection to an Ingres database
  • ingres_query() - Send an SQL query to Ingres


Close an Ingres database connection

  • ? ingres_charset
  • ingres_commit ?
  • PHP Manual
  • Ingres 函数
  • Close an Ingres database connection

ingres_close

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_close — Close an Ingres database connection

说明

ingres_close ( resource $link ) : bool

ingres_close() closes the connection to the Ingres server that is associated with the specified link.

ingres_close() is usually unnecessary, as it will not close persistent connections and all non-persistent connections are automatically closed at the end of the script.

参数

link

The connection link identifier

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ingres_connect() - Open a connection to an Ingres database
  • ingres_pconnect() - Open a persistent connection to an Ingres database


Commit a transaction

  • ? ingres_close
  • ingres_connect ?
  • PHP Manual
  • Ingres 函数
  • Commit a transaction

ingres_commit

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_commit — Commit a transaction

说明

ingres_commit ( resource $link ) : bool

ingres_commit() commits the currently open transaction, making all changes made to the database permanent.

This closes the transaction. A new transaction can be opened by sending a query with ingres_query().

You can also have the server commit automatically after every query by calling ingres_autocommit() before opening the transaction.

By default Ingres will roll back any uncommitted transactions at the end of a request. Use this function or ingres_autocommit() to ensure your that data is committed to the database.

参数

link

The connection link identifier

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off


Open a connection to an Ingres database

  • ? ingres_commit
  • ingres_cursor ?
  • PHP Manual
  • Ingres 函数
  • Open a connection to an Ingres database

ingres_connect

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_connect — Open a connection to an Ingres database

说明

ingres_connect ( string $database = ? , string $username = ? , string $password = ? , array $options = ? ) : resource|false

ingres_connect() opens a connection with the given Ingres database.

The connection is closed when the script ends or when ingres_close() is called on this link.

参数

If some parameters are missing, ingres_connect() uses the values in php.ini for ingres.default_database, ingres.default_user and ingres.default_password.

database

The database name. Must follow the syntax:

[vnode::]dbname[/svr_class]

username

The Ingres user name

password

The password associated with username

options

ingres_connect() options

Option name | Option type | Description | Example
date_century_boundary | int | The threshold by which a 2-digit year is determined to be in the current century or in the next century. Equivalent to II_DATE_CENTURY_BOUNDARY. | 50
group | string | Specifies the group ID of the user, equivalent to the "-G" flag | payroll
role | string | The role ID of the application. If a role password is required, the parameter value should be specified as "role/password"
effective_user | string | The ingres user account being impersonated, equivalent to the "-u" flag | another_user
dbms_password | string | The internal database password for the user connecting to Ingres | s3cr3t
table_structure string

The default structure for new tables. Valid values for table_structure are:

  • INGRES_STRUCTURE_BTREE
  • INGRES_STRUCTURE_HASH
  • INGRES_STRUCTURE_HEAP
  • INGRES_STRUCTURE_ISAM
  • INGRES_STRUCTURE_CBTREE
  • INGRES_STRUCTURE_CISAM
  • INGRES_STRUCTURE_CHASH
  • INGRES_STRUCTURE_CHEAP

 INGRES_STRUCTURE_BTREE
index_structure string

The default structure for new secondary indexes. Valid values for index_structure are:

  • INGRES_STRUCTURE_CBTREE
  • INGRES_STRUCTURE_CISAM
  • INGRES_STRUCTURE_CHASH
  • INGRES_STRUCTURE_BTREE
  • INGRES_STRUCTURE_HASH
  • INGRES_STRUCTURE_ISAM

 INGRES_STRUCTURE_HASH
login_local | bool | Determines how the connection user ID and password are used when a VNODE is included in the target database string. If set to TRUE, the user ID and password are used to locally access the VNODE, and the VNODE login information is used to establish the DBMS connection. If set to FALSE, the process user ID is used to access the VNODE, and the connection user ID and password are used in place of the VNODE login information to establish the DBMS connection. This parameter is ignored if no VNODE is included in the target database string. The default is FALSE. | TRUE
timezone | string | Controls the timezone of the session. If not set it will default to the value defined by II_TIMEZONE_NAME. If II_TIMEZONE_NAME is not defined, NA-PACIFIC (GMT-8 with Daylight Savings) is used.
date_format int

Sets the allowable input and output format for Ingres dates. Defaults to the value defined by II_DATE_FORMAT. If II_DATE_FORMAT is not set the default date format is US, e.g. mm/dd/yy. Valid values for date_format are:

  • INGRES_DATE_DMY
  • INGRES_DATE_FINISH
  • INGRES_DATE_GERMAN
  • INGRES_DATE_ISO
  • INGRES_DATE_ISO4
  • INGRES_DATE_MDY
  • INGRES_DATE_MULTINATIONAL
  • INGRES_DATE_MULTINATIONAL4
  • INGRES_DATE_YMD
  • INGRES_DATE_US

 INGRES_DATE_MULTINATIONAL4
decimal_separator string The character identifier for decimal data ","
money_lort int

Leading or trailing currency sign. Valid values for money_lort are:

  • INGRES_MONEY_LEADING
  • INGRES_MONEY_TRAILING

 INGRES_MONEY_TRAILING
money_sign string The currency symbol to be used with the MONEY datatype �
money_precision | int | The precision of the MONEY datatype | 3
float4_precision | int | Precision of the FLOAT4 datatype | 10
float8_precision | int | Precision of the FLOAT8 data | 10
blob_segment_length | int | The amount of data in bytes to fetch at a time when retrieving BLOB or CLOB data, defaults to 4096 bytes when not explicitly set | 8192

返回值

Returns a Ingres link resource on success 或者在失败时返回 false

范例

Example #1 Open a connection to an Ingres database

<?php
$link = ingres_connect("mydb", "user", "pass")
    or die("Could not connect");
echo "Connected successfully";
ingres_close($link);
?>

参见

  • ingres_pconnect() - Open a persistent connection to an Ingres database
  • ingres_close() - Close an Ingres database connection


Get a cursor name for a given result resource

  • ? ingres_connect
  • ingres_errno ?
  • PHP Manual
  • Ingres 函数
  • Get a cursor name for a given result resource

ingres_cursor

(PECL ingres >= 1.1.0)

ingres_cursor — Get a cursor name for a given result resource

说明

ingres_cursor ( resource $result ) : string

Returns a string with the active cursor name. If no cursor is active then NULL is returned.

参数

result

The query result identifier

返回值

Returns a string containing the active cursor name. If no cursor is active then NULL is returned.

范例

Example #1 Get cursor name for a query resource

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_prepare($link, "select * from table");

$cursor_name = ingres_cursor($result);

echo $cursor_name;

?>

参见

  • ingres_prepare() - Prepare a query for later execution
  • ingres_execute() - Execute a prepared query


Get the last Ingres error number generated

  • ? ingres_cursor
  • ingres_error ?
  • PHP Manual
  • Ingres 函数
  • Get the last Ingres error number generated

ingres_errno

(PECL ingres >= 1.1.0)

ingres_errno — Get the last Ingres error number generated

说明

ingres_errno ( resource $link = ? ) : int

Returns an integer containing the last error number. If no error was reported 0 is returned.

If a link resource is passed to ingres_errno() it returns the last error recorded for the link. If no link is passed, then ingres_errno() returns the last error reported using the default link.

The function, ingres_errno(), should always be called after executing a database query. Calling another function before ingres_errno() is called will reset or change any error code from the last Ingres function call.

参数

link

The connection link identifier

返回值

Returns an integer containing the last error number. If no error was reported, 0 is returned.

范例

Example #1 Get the last Ingres error number generated

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");

$error_code = ingres_errno($link);

if ( $error_code != 0 ) {
   echo "An error occurred - " . $error_code;
}
?>

参见

  • ingres_error() - Get a meaningful error message for the last error generated
  • ingres_errsqlstate() - Get the last SQLSTATE error code generated
  • ingres_next_error() - Get the next Ingres error


Get a meaningful error message for the last error generated

  • ? ingres_errno
  • ingres_errsqlstate ?
  • PHP Manual
  • Ingres 函数
  • Get a meaningful error message for the last error generated

ingres_error

(PECL ingres >= 1.1.0)

ingres_error — Get a meaningful error message for the last error generated

说明

ingres_error ( resource $link = ? ) : string

Returns a string containing the last error, or NULL if no error has occurred.

If a link resource is passed to ingres_error(), it returns the last error recorded for the link. If no link is passed then ingres_error() returns the last error reported using the default link.

The function, ingres_error(), should always be called after executing any database query. Calling another function before ingres_error() is called will reset or change any error message from the last Ingres function call.

参数

link

The connection link identifier

返回值

Returns a string containing the last error, or NULL if no error has occurred.

范例

Example #1 Get a message for the last error generated

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");

$error_text = ingres_error();

if (!is_null($error_text)) {
   echo "An error occurred - " . $error_text;
}
?>

参见

  • ingres_errno() - Get the last Ingres error number generated
  • ingres_errsqlstate() - Get the last SQLSTATE error code generated
  • ingres_next_error() - Get the next Ingres error


Get the last SQLSTATE error code generated

  • ? ingres_error
  • ingres_escape_string ?
  • PHP Manual
  • Ingres 函数
  • Get the last SQLSTATE error code generated

ingres_errsqlstate

(PECL ingres >= 1.1.0)

ingres_errsqlstate — Get the last SQLSTATE error code generated

说明

ingres_errsqlstate ( resource $link = ? ) : string

Returns a string containing the last SQLSTATE, or NULL if no error has occurred.

If a link resource is passed to ingres_errsqlstate(), it returns the last error recorded for the link. If no link is passed, then ingres_errsqlstate() returns the last error reported using the default link.

The function, ingres_errsqlstate(), should always be called after executing any database query. Calling another function before ingres_errsqlstate() is called will reset or change any error message from the last Ingres function call.

参数

link

The connection link identifier

返回值

Returns a string containing the last SQLSTATE, or NULL if no error has occurred.

范例

Example #1 Get the last SQLSTATE error code generated

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");

$error_sqlstate = ingres_errsqlstate($link);

if (!is_null($error_sqlstate)) {
   echo "An error occurred - " . $error_sqlstate;
}
?>

参见

  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated
  • ingres_next_error() - Get the next Ingres error


Escape special characters for use in a query

  • ? ingres_errsqlstate
  • ingres_execute ?
  • PHP Manual
  • Ingres 函数
  • Escape special characters for use in a query

ingres_escape_string

(PECL ingres >= 2.1.0)

ingres_escape_string — Escape special characters for use in a query

说明

ingres_escape_string ( resource $link , string $source_string ) : string

ingres_escape_string() is used to escape certain characters within a string before it is sent to the database server.

参数

link

The connection link identifier

source_string

The source string to be parsed

返回值

Returns a string containing the escaped data.

范例

Example #1 Escape special characters for use in a query

<?php
$link = ingres_connect($database, $user, $password);

$last_name = "O'Connor";

$sql = sprintf("select * from user_profile where up_last = '%s'", ingres_escape_string( $link, $last_name));

$result = ingres_query($link, $sql);

while ($user = ingres_fetch_object($result))
{
  echo $user->up_first . '<BR/>';
}

ingres_commit($link);

ingres_close($link);

?>

参见

  • ingres_query() - Send an SQL query to Ingres


Execute a prepared query

  • ? ingres_escape_string
  • ingres_fetch_array ?
  • PHP Manual
  • Ingres 函数
  • Execute a prepared query

ingres_execute

(PECL ingres >= 1.1.0)

ingres_execute — Execute a prepared query

说明

ingres_execute ( resource $result , array $params = ? , string $types = ? ) : bool

Execute a query prepared using ingres_prepare().

Note: Related Configurations

See also the ingres.describe, ingres.scrollable and ingres.utf8 directives in Runtime Configuration.

参数

result

The result query identifier

params

An array of parameter values to be used with the query

types

A string containing a sequence of types for the parameter values passed. See the types parameter in ingres_query() for the list of type codes.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ingres_unbuffered_query() - Send an unbuffered SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array
  • ingres_commit() - Commit a transaction
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off
  • ingres_set_environment() - Set environment features controlling output options
  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated


Fetch a row of result into an array

  • ? ingres_execute
  • ingres_fetch_assoc ?
  • PHP Manual
  • Ingres 函数
  • Fetch a row of result into an array

ingres_fetch_array

(PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_fetch_array — Fetch a row of result into an array

说明

ingres_fetch_array ( resource $result , int $result_type = ? ) : array

This function is an extended version of ingres_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

If two or more columns of the result have the same field names, the last column will take precedence. To access the another column or columns of the same name, you must use the numeric index of the column or make an alias for the column. For example:

<?php

$result = ingres_query($link, "select ap_place as city, ap_ccode as country from airport where ap_iatacode = 'VLL'");
$result = ingres_fetch_array($result);
$foo = $result["city"];
$bar = $result["country"];

?>

With regard to speed, the function is identical to ingres_fetch_object(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

By default, arrays created by ingres_fetch_array() start from position 1 and not 0 as with other DBMS extensions. The starting position can be adjusted to 0 using the configuration parameter ingres.array_index_start.

Note: Related Configurations

See also the ingres.array_index_start, ingres.fetch_buffer_size and ingres.utf8 directives in Runtime Configuration.

参数

result

The query result identifier

result_type

The result type. This result_type can be INGRES_NUM for enumerated array, INGRES_ASSOC for associative array, or INGRES_BOTH (default).

返回值

Returns an array that corresponds to the fetched row, or false if there are no more rows

范例

Example #1 Fetch a row of result into an array

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link,"select * from table");
while ($row = ingres_fetch_array($result)) {
    echo $row["user_id"];  // using associative array
    echo $row["fullname"];
    echo $row[1];          // using enumerated array
    echo $row[2];
}
?>

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_num_fields() - Get the number of fields returned by the last query
  • ingres_field_name() - Get the name of a field in a query result
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Fetch a row of result into an associative array

  • ? ingres_fetch_array
  • ingres_fetch_object ?
  • PHP Manual
  • Ingres 函数
  • Fetch a row of result into an associative array

ingres_fetch_assoc

(PECL ingres >= 2.2.2)

ingres_fetch_assoc — Fetch a row of result into an associative array

说明

ingres_fetch_assoc ( resource $result ) : array

This function is stores the data fetched from a query executed using ingres_query() in an associative array, using the field names as keys.

With regard to speed, the function is identical to ingres_fetch_object(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

By default, arrays created by ingres_fetch_assoc() start from position 1 and not 0 as with other DBMS extensions. The starting position can be adjusted to 0 using the configuration parameter ingres.array_index_start.

Note: Related Configurations

See also the ingres.array_index_start, ingres.fetch_buffer_size and ingres.utf8 directives in Runtime Configuration.

参数

result

The query result identifier

返回值

Returns an associative array that corresponds to the fetched row, or false if there are no more rows

范例

Example #1 Fetch a row into an associative array

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link,"select * from table");
while ($row = ingres_fetch_assoc($result)) {
    echo $row["user_id"];  // using associative array
    echo $row["fullname"];
}
?>

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_num_fields() - Get the number of fields returned by the last query
  • ingres_field_name() - Get the name of a field in a query result
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Fetch a row of result into an object

  • ? ingres_fetch_assoc
  • ingres_fetch_proc_return ?
  • PHP Manual
  • Ingres 函数
  • Fetch a row of result into an object

ingres_fetch_object

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_fetch_object — Fetch a row of result into an object

说明

ingres_fetch_object ( resource $result , int $result_type = ? ) : object

This function is similar to ingres_fetch_array(), with one difference - an object is returned instead of an array. Indirectly, this means that you can access the data only by the field names and not by their offsets (numbers are illegal property names).

With regard to speed, the function is identical to ingres_fetch_array(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

Note: Related Configurations

See also the ingres.fetch_buffer_size and ingres.utf8 directives in Runtime Configuration.

参数

link

The query result identifier

result_type

(Optional argument.) result_type is a constant and can take the following values: INGRES_ASSOC, INGRES_NUM, and INGRES_BOTH.

返回值

Returns an object that corresponds to the fetched row, or false if there are no more rows

范例

Example #1 Fetch a row into an object

<?php
$link = ingres_connect($database, $user, $password);
$result = ingres_query($link, "select * from table");
while ($row = ingres_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
?>

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_num_fields() - Get the number of fields returned by the last query
  • ingres_field_name() - Get the name of a field in a query result
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Get the return value from a procedure call

  • ? ingres_fetch_object
  • ingres_fetch_row ?
  • PHP Manual
  • Ingres 函数
  • Get the return value from a procedure call

ingres_fetch_proc_return

(PECL ingres >= 1.4.0)

ingres_fetch_proc_return — Get the return value from a procedure call

说明

ingres_fetch_proc_return ( resource $result ) : int

This function is used to retrieve the return value following the execution of an Ingres database procedure (stored procedure).

Note:

If used with a row-producing procedure, this function should be called after all the rows from the procedure have been fetched using ingres_fetch_array(), ingres_fetch_object() or ingres_fetch_row(). This function will eliminate any rows yet to be fetched should there be any left over.

参数

result

The result identifier for a query

返回值

Returns an int if there is a return value otherwise it will return null.

范例

Example #1 Get the return value from a procedure call

<?php

$link = ingres_connect($database);

if ( ingres_errno() != 0 ) {
    $error_text = ingres_error();
    die($error_text);
}

$result = ingres_query($link, "execute procedure php_proc (value = 1000)");

if ( ingres_errno() != 0 ) {
    $error_text = ingres_error();
    die($error_text);
}

echo "return value - " . ingres_fetch_proc_return($result) . "\n";

ingres_close($link);

?>

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Fetch a row of result into an enumerated array

  • ? ingres_fetch_proc_return
  • ingres_field_length ?
  • PHP Manual
  • Ingres 函数
  • Fetch a row of result into an enumerated array

ingres_fetch_row

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_fetch_row — Fetch a row of result into an enumerated array

说明

ingres_fetch_row ( resource $result ) : array

ingres_fetch_row() returns an array that corresponds to the fetched row, or false if there are no more rows. Each result column is stored in an array offset, starting at offset 1.

Subsequent calls to ingres_fetch_row() return the next row in the result set, or false if there are no more rows.

By default, arrays created by ingres_fetch_row() start from position 1 and not 0 as with other DBMS extensions. The starting position can be adjusted to 0 using the configuration parameter ingres.array_index_start.

Note: Related Configurations

See also the ingres.array_index_start, ingres.fetch_buffer_size and ingres.utf8 directives in Runtime Configuration.

参数

result

The query result identifier

返回值

Returns an array that corresponds to the fetched row, or false if there are no more rows

范例

Example #1 Fetch a row of result into an enumerated array

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

参见

  • ingres_num_fields() - Get the number of fields returned by the last query
  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object


Get the length of a field

  • ? ingres_fetch_row
  • ingres_field_name ?
  • PHP Manual
  • Ingres 函数
  • Get the length of a field

ingres_field_length

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_length — Get the length of a field

说明

ingres_field_length ( resource $result , int $index ) : int

ingres_field_length() returns the length of a field. This is the number of bytes the server uses to store the field. For detailed information, see the Ingres OpenAPI User Guide, Appendix "Data Types" in the Ingres documentation.

Note: Related Configurations

See ingres.array_index_start in Runtime Configuration

参数

result

The query result identifier

index

index is the column number whose length will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

返回值

Returns the length of a field.

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Get the name of a field in a query result

  • ? ingres_field_length
  • ingres_field_nullable ?
  • PHP Manual
  • Ingres 函数
  • Get the name of a field in a query result

ingres_field_name

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_name — Get the name of a field in a query result

说明

ingres_field_name ( resource $result , int $index ) : string|false

ingres_field_name() returns the name of a field in a query result.

Note: Related Configurations

See ingres.array_index_start in Runtime Configuration

参数

result

The query result identifier

index

index is the field whose name will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

返回值

Returns the name of a field in a query result 或者在失败时返回 false

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Test if a field is nullable

  • ? ingres_field_name
  • ingres_field_precision ?
  • PHP Manual
  • Ingres 函数
  • Test if a field is nullable

ingres_field_nullable

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_nullable — Test if a field is nullable

说明

ingres_field_nullable ( resource $result , int $index ) : bool

Test if a field is nullable.

Note: Related Configurations

See ingres.array_index_start in Runtime Configuration

参数

result

The query result identifier

index

index is the field whose nullability will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

返回值

ingres_field_nullable() returns true if the field can be set to the null value and false if it cannot

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Get the precision of a field

  • ? ingres_field_nullable
  • ingres_field_scale ?
  • PHP Manual
  • Ingres 函数
  • Get the precision of a field

ingres_field_precision

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_precision — Get the precision of a field

说明

ingres_field_precision ( resource $result , int $index ) : int

ingres_field_precision() returns the precision of a field. This value is used only for decimal, float, and money SQL data types. For detailed information, see the Ingres OpenAPI User Guide, Appendix "Data Types" in the Ingres documentation.

Note: Related Configurations

See ingres.array_index_start in Runtime Configuration

参数

result

The query result identifier

index

index is the field whose precision will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

返回值

Returns the field precision as an integer

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Get the scale of a field

  • ? ingres_field_precision
  • ingres_field_type ?
  • PHP Manual
  • Ingres 函数
  • Get the scale of a field

ingres_field_scale

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_scale — Get the scale of a field

说明

ingres_field_scale ( resource $result , int $index ) : int

ingres_field_scale() returns the scale of a field. This value is used only for the decimal SQL data type. For detailed information, see the Ingres OpenAPI User Guide, Appendix "Data Types" in the Ingres documentation.

Note: Related Configurations

See ingres.array_index_start in Runtime Configuration

参数

result

The query result identifier

index

index is the field whose scale will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

返回值

Returns the scale of the field, as an integer

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Get the type of a field in a query result

  • ? ingres_field_scale
  • ingres_free_result ?
  • PHP Manual
  • Ingres 函数
  • Get the type of a field in a query result

ingres_field_type

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_field_type — Get the type of a field in a query result

说明

ingres_field_type ( resource $result , int $index ) : string|false

Get the type of a field in a query result.

Note: Related Configurations

See ingres.array_index_start in Runtime Configuration

参数

result

The query result identifier

index

index is the field whose type will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

返回值

ingres_field_type() returns the type of a field in a query result 或者在失败时返回 false. Examples of types returned are IIAPI_BYTE_TYPE, IIAPI_CHA_TYPE, IIAPI_DTE_TYPE, IIAPI_FLT_TYPE, IIAPI_INT_TYPE, IIAPI_VCH_TYPE. Some of these types can map to more than one SQL type depending on the length of the field (see ingres_field_length()). For example IIAPI_FLT_TYPE can be a float4 or a float8. For detailed information, see the Ingres OpenAPI User Guide, Appendix "Data Types" in the Ingres documentation.

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Free the resources associated with a result identifier

  • ? ingres_field_type
  • ingres_next_error ?
  • PHP Manual
  • Ingres 函数
  • Free the resources associated with a result identifier

ingres_free_result

(PECL ingres >= 2.0.0)

ingres_free_result — Free the resources associated with a result identifier

说明

ingres_free_result ( resource $result ) : bool

参数

result

The query result identifier

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Free a result resource

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");

while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
ingres_free_result($result);

ingres_close($link)

?>

参见

  • ingres_query() - Send an SQL query to Ingres


Get the next Ingres error

  • ? ingres_free_result
  • ingres_num_fields ?
  • PHP Manual
  • Ingres 函数
  • Get the next Ingres error

ingres_next_error

(PECL ingres >= 2.0.0)

ingres_next_error — Get the next Ingres error

说明

ingres_next_error ( resource $link = ? ) : bool

Get the next Ingres error for the last executed query. Each call to ingres_next_error() can be followed by a call to ingres_errno(), ingres_error() or ingres_errsqlstate() to get the respective error number, error text, or SQL STATE. While ingres_next_error() returns true, there are more errors to fetch.

参数

link

The connection link identifier

返回值

ingres_next_error() returns true if there is another error to retrieve or false when there are no more errors

参见

  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated
  • ingres_errsqlstate() - Get the last SQLSTATE error code generated


Get the number of fields returned by the last query

  • ? ingres_next_error
  • ingres_num_rows ?
  • PHP Manual
  • Ingres 函数
  • Get the number of fields returned by the last query

ingres_num_fields

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_num_fields — Get the number of fields returned by the last query

说明

ingres_num_fields ( resource $result ) : int

ingres_num_fields() returns the number of fields in the results returned by the Ingres server after a call to ingres_query().

参数

result

The query result identifier

返回值

Returns the number of fields

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Get the number of rows affected or returned by a query

  • ? ingres_num_fields
  • ingres_pconnect ?
  • PHP Manual
  • Ingres 函数
  • Get the number of rows affected or returned by a query

ingres_num_rows

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_num_rows — Get the number of rows affected or returned by a query

说明

ingres_num_rows ( resource $result ) : int

This function primarily is meant to get the number of rows modified in the database. However, it can be used to retrieve the number of rows to fetch for a SELECT statement.

Note:

If scrollable cursors are disabled and this function is called before using ingres_fetch_array(), ingres_fetch_object(), or ingres_fetch_row(), the server will delete the result's data and the script will be unable to get them.

Instead, you should retrieve the result's data using one of these fetch functions in a loop until it returns false, indicating that no more results are available.

参数

result

The result identifier for a query

返回值

For delete, insert, or update queries, ingres_num_rows() returns the number of rows affected by the query. For other queries, ingres_num_rows() returns the number of rows in the query's result.

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Open a persistent connection to an Ingres database

  • ? ingres_num_rows
  • ingres_prepare ?
  • PHP Manual
  • Ingres 函数
  • Open a persistent connection to an Ingres database

ingres_pconnect

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_pconnect — Open a persistent connection to an Ingres database

说明

ingres_pconnect ( string $database = ? , string $username = ? , string $password = ? , array $options = ? ) : resource|false

Open a persistent connection to an Ingres database.

There are only two differences between this function and ingres_connect(): First, when connecting, the function will initially try to find a (persistent) link that is already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection. Second, the connection to the Ingres server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ingres_close() will not close links established by ingres_pconnect()). This type of link is therefore called "persistent".

参数

database

The database name. Must follow the syntax:

[vnode::]dbname[/svr_class]

username

The Ingres user name

password

The password associated with username

options

See ingres_connect() for the list of options that can be passed

返回值

Returns an Ingres link resource on success 或者在失败时返回 false

参见

  • ingres_connect() - Open a connection to an Ingres database
  • ingres_close() - Close an Ingres database connection


Prepare a query for later execution

  • ? ingres_pconnect
  • ingres_query ?
  • PHP Manual
  • Ingres 函数
  • Prepare a query for later execution

ingres_prepare

(PECL ingres >= 1.1.0)

ingres_prepare — Prepare a query for later execution

说明

ingres_prepare ( resource $link , string $query ) : mixed

Prepares a query for execution by ingres_execute().

The query becomes part of the currently open transaction. If there is no open transaction, ingres_query() opens a new transaction. To close the transaction, you can call either ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediately committed.

Note: Related Configurations

See also the ingres.describe, ingres.scrollable and ingres.utf8 directives in Runtime Configuration.

参数

link

The connection link identifier

query

A valid SQL query (see the Ingres SQL reference guide) in the Ingres documentation. See the query parameter in ingres_query() for a list of SQL statements which cannot be executed using ingres_prepare()

返回值

ingres_prepare() returns a query result identifier that
is used with ingres_execute() to execute the query. To see
if an error occurred, use ingres_errno(),
ingres_error(), or
ingres_errsqlstate().

参见

  • ingres_unbuffered_query() - Send an unbuffered SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array
  • ingres_commit() - Commit a transaction
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off
  • ingres_set_environment() - Set environment features controlling output options
  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated


Send an SQL query to Ingres

  • ? ingres_prepare
  • ingres_result_seek ?
  • PHP Manual
  • Ingres 函数
  • Send an SQL query to Ingres

ingres_query

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_query — Send an SQL query to Ingres

说明

ingres_query ( resource $link , string $query , array $params = ? , string $types = ? ) : mixed

ingres_query() sends the given query to the Ingres server.

The query becomes part of the currently open transaction. If there is no open transaction, ingres_query() opens a new transaction. To close the transaction, you can call either ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediately committed.

Note: Related Configurations

See also the ingres.describe, ingres.scrollable and ingres.utf8 directives in Runtime Configuration

参数

link

The connection link identifier.

query

A valid SQL query (see the Ingres SQL reference guide) in the Ingres documentation.

Data inside the query should be properly escaped.

The following types of SQL queries cannot be sent with this function:

  • close (see ingres_close())
  • commit (see ingres_commit())
  • connect (see ingres_connect())
  • disconnect (see ingres_close())
  • get dbevent
  • prepare to commit
  • rollback (see ingres_rollback())
  • savepoint
  • set autocommit (see ingres_autocommit())
  • all cursor-related queries are unsupported

params

An array of parameter values to be used with the query

types

A string containing a sequence of types for the parameter values passed. When ingres.describe is enabled, this parameter can be ignored as the driver automatically fetches the expected parameter types from the server.

Type code | Ingres type
a | BOOLEAN
b | BYTE
B | LONG BYTE/BLOB
c | CHAR
d | DATE/ANSIDATE/TIMESTAMP/TIME
f | FLOAT
i | INTEGER
L | LONG TEXT
m | MONEY
M | LONG NVARCHAR
n | NCHAR
N | NVARCHAR
t | TEXT
v | VARCHAR
V | LONG VARCHAR

返回值

ingres_query() returns a query result identifier on
success else it returns false. To see if an error
occurred use ingres_errno(),
ingres_error() or
ingres_errsqlstate().

范例

Example #1 Send a simple select

<?php
$link = ingres_connect("demodb");

$result = ingres_query($link, "select * from user_profile");
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Example #2 Passing query parameters to ingres_query()

<?php
$link = ingres_connect("demodb");

$params[] = "Emma";
$query = "select * from user_profile where up_first = ?";
$result = ingres_query($link, $query, $params);
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Example #3 Inserting a BLOB with parameter types

<?php
$link = ingres_connect("demodb");

//Open a photo
$fh = fopen("photo.jpg","r");
$blob_data = stream_get_contents($fh);
fclose($fh);

//Prepare parameters
$params[] = $blob_data;
$params[] = 1201;

//Define parameter types
$param_types = "Bi";

$query = "update user_profile set up_image = ? where up_id = ?";
$result = ingres_query($link, $query , $params, $param_types);

if (ingres_errno())
{
    echo ingres_errno() . "-" . ingres_error() . "\n";
}

ingres_commit($link);

ingres_close($link);
?>

参见

  • ingres_unbuffered_query() - Send an unbuffered SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array
  • ingres_commit() - Commit a transaction
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off
  • ingres_set_environment() - Set environment features controlling output options
  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated


Set the row position before fetching data

  • ? ingres_query
  • ingres_rollback ?
  • PHP Manual
  • Ingres 函数
  • Set the row position before fetching data

ingres_result_seek

(PECL ingres >= 2.1.0)

ingres_result_seek — Set the row position before fetching data

说明

ingres_result_seek ( resource $result , int $position ) : bool

This function is used to position the cursor associated with the result resource before issuing a fetch. If ingres.array_index_start is set to 0 then the first row is 0 else it is 1. ingres_result_seek() can be used only with queries that make use of scrollable cursors. It cannot be used with ingres_unbuffered_query().

Note: Related Configurations

See also the ingres.scrollable and ingres.array_index_start directives in Runtime Configuration.

参数

result

The result identifier for a query

position

The row to position the cursor on. If ingres.array_index_start is set to 0, then the first row is 0, else it is 1

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Position the cursor on the 3rd row

<?php

$result=ingres_query($link, "select * from airport where ap_ccode = 'ES' order by ap_place asc");

/* goto row 3 */
if (!ingres_result_seek($result, 3))
{
    echo ingres_errno() . " - " . ingres_error . "\n";
    die("i died");
}
else
{
    $airport = ingres_fetch_object ($result);
    {
        echo $airport->ap_iatacode . " - " .  $airport->ap_name . "\n";
    }
}

ingres_commit($link);

?>

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array


Roll back a transaction

  • ? ingres_result_seek
  • ingres_set_environment ?
  • PHP Manual
  • Ingres 函数
  • Roll back a transaction

ingres_rollback

(PHP 4 >= 4.0.2, PHP 5 < 5.1.0, PECL ingres >= 1.0.0)

ingres_rollback — Roll back a transaction

说明

ingres_rollback ( resource $link ) : bool

ingres_rollback() rolls back the currently open transaction, actually cancelling all changes made to the database during the transaction.

This closes the transaction. A new transaction can be opened by sending a query with ingres_query().

参数

link

The connection link identifier

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_commit() - Commit a transaction
  • ingres_autocommit() - Switch autocommit on or off


Set environment features controlling output options

  • ? ingres_rollback
  • ingres_unbuffered_query ?
  • PHP Manual
  • Ingres 函数
  • Set environment features controlling output options

ingres_set_environment

(PECL ingres >= 1.2.0)

ingres_set_environment — Set environment features controlling output options

说明

ingres_set_environment ( resource $link , array $options ) : bool

ingres_set_environment() is called to set environmental options that affect the output of certain values from Ingres, such as the timezone, date format, decimal character separator, and float precision.

参数

link

The connection link identifier

options

An enumerated array of option name/value pairs. The following table lists the option name and the expected type

Option name | Option type | Description | Example
date_century_boundary | int | The threshold by which a 2-digit year is determined to be in the current century or in the next century. Equivalent to II_DATE_CENTURY_BOUNDARY | 50
timezone | string | Controls the timezone of the session. If not set, it will default the value defined by II_TIMEZONE_NAME. If II_TIMEZONE_NAME is not defined, NA-PACIFIC (GMT-8 with Daylight Savings) is used. | UNITED-KINGDOM
date_format int

Sets the allowable input and output format for Ingres dates. Defaults to the value defined by II_DATE_FORMAT. If II_DATE_FORMAT is not set, the default date format is US, for example mm/dd/yy. Valid values for date_format are:

  • INGRES_DATE_DMY
  • INGRES_DATE_FINISH
  • INGRES_DATE_GERMAN
  • INGRES_DATE_ISO
  • INGRES_DATE_ISO4
  • INGRES_DATE_MDY
  • INGRES_DATE_MULTINATIONAL
  • INGRES_DATE_MULTINATIONAL4
  • INGRES_DATE_YMD
  • INGRES_DATE_US

 INGRES_DATE_ISO4
decimal_separator string The character identifier for decimal data ","
money_lort int

Leading or trailing currency sign. Valid values for money_lort are:

  • INGRES_MONEY_LEADING
  • INGRES_MONEY_TRAILING

 INGRES_MONEY_LEADING
money_sign string The currency symbol to be used with the MONEY datatype �
money_precision | int | The precision of the MONEY datatype | 2
float4_precision | int | Precision of the FLOAT4 datatype | 10
float8_precision | int | Precision of the FLOAT8 data | 10
blob_segment_length | int | The amount of data in bytes to fetch at a time when retrieving BLOB or CLOB data. Defaults to 4096 bytes when not set explicitly | 8192

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Set date_format to ISO4

<?php
$options = array( "date_format" => INGRES_DATE_ISO4 );

if (ingres_set_environment($link, $options))
{
    $result=ingres_query($link,"select date('now') as date");

    while ( $object = ingres_fetch_object ($result) ) {
        echo $object->date."\n";
    }
}
?>

Example #2 Set timezone to HONG-KONG

<?php

$options = array( "timezone" => "HONG-KONG");

if (ingres_set_environment($link, $options))
{
    $result=ingres_query($link,"select date('now') as date");

    while ( $object = ingres_fetch_object ($result) ) {
        echo $object->date."\n";
    }
}
?>

参见

  • ingres_connect() - Open a connection to an Ingres database
  • ingres_query() - Send an SQL query to Ingres


Send an unbuffered SQL query to Ingres

  • ? ingres_set_environment
  • Mongo ?
  • PHP Manual
  • Ingres 函数
  • Send an unbuffered SQL query to Ingres

ingres_unbuffered_query

(No version information available, might only be in Git)

ingres_unbuffered_query — Send an unbuffered SQL query to Ingres

说明

ingres_unbuffered_query ( resource $link , string $query , array $params = ? , string $types = ? ) : mixed

ingres_unbuffered_query() sends the given query to the Ingres server.

The query becomes part of the currently open transaction. If there is no open transaction, ingres_unbuffered_query() opens a new transaction. To close the transaction, you can call either ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediately committed. Ingres allows only a single unbuffered statement to be active at any one time. The extension will close any active unbuffered statements before executing any SQL. In addition you cannot use ingres_result_seek() to position the row before fetching.

Note: Related Configurations

See also the ingres.describe and ingres.utf8 directives in Runtime Configuration.

参数

link

The connection link identifier

query

A valid SQL query (see the Ingres SQL reference guide) in the Ingres documentation. See the query parameter in ingres_query() for a list of SQL statements that cannot be executed via ingres_unbuffered_query().

Data inside the query should be properly escaped.

params

An array of parameter values to be used with the query

types

A string containing a sequence of types for the parameter values passed. See the types parameter in ingres_query() for the list of type codes.

返回值

ingres_unbuffered_query() returns a query result identifier when there are rows to fetch; else it returns false when there are no rows, as is the case of an INSERT, UPDATE, or DELETE statement. To see if an error occurred, use ingres_errno(), ingres_error(), or ingres_errsqlstate().

范例

Example #1 Issue a simple un-buffered select

<?php
$link = ingres_connect("demodb");

$result = ingres_unbuffered_query($link, "select * from user_profile");
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Example #2 Passing query parameters to ingres_unbuffered_query()

<?php
$link = ingres_connect("demodb");

$params[] = "Emma";
$query = "select * from user_profile where up_first = ?";
$result = ingres_unbuffered_query($link, $query, $params);
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Example #3 Inserting a BLOB with parameter types

<?php
$link = ingres_connect("demodb");

//Open a photo
$fh = fopen("photo.jpg","r");
$blob_data = stream_get_contents($fh);
fclose($fh);

//Prepare parameters
$params[] = $blob_data;
$params[] = 1201;

//Define parameter types
$param_types = "Bi";

$query = "update user_profile set up_image = ? where up_id = ?";
$result = ingres_unbuffered_query($link, $query , $params, $param_types);

if (ingres_errno())
{
    echo ingres_errno() . "-" . ingres_error() . "\n";
}
?>

参见

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array
  • ingres_commit() - Commit a transaction
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off
  • ingres_set_environment() - Set environment features controlling output options
  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated


MongoDB 驱动（旧版）

  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • 手册
    • 教程
    • 读取首选项
    • Write Concerns
    • SQL 到 Mongo 的对应表
    • 链接服务器
    • Stream Context Options
    • Writes
    • Querying
    • Updates
    • Security
    • 故障排除
    • Running the Driver's Tests
  • 核心类
    • MongoClient — MongoClient 类
    • MongoDB — MongoDB 类
    • MongoCollection — The MongoCollection class
    • MongoCursor — The MongoCursor class
    • MongoCursorInterface — The MongoCursorInterface interface
    • MongoCommandCursor — The MongoCommandCursor class
  • Types
    • MongoId — MongoId 类
    • MongoCode — The MongoCode class
    • MongoDate — The MongoDate class
    • MongoRegex — MongoRegex 类
    • MongoBinData — The MongoBinData class
    • MongoInt32 — MongoInt32 类
    • MongoInt64 — MongoInt64 类
    • MongoDBRef — MongoDBRef 类
    • MongoMinKey — The MongoMinKey class
    • MongoMaxKey — The MongoMaxKey class
    • MongoTimestamp — MongoTimestamp 类
  • GridFS Classes
    • MongoGridFS — The MongoGridFS class
    • MongoGridFSFile — The MongoGridFSFile class
    • MongoGridFSCursor — The MongoGridFSCursor class
  • Miscellaneous
    • MongoLog — The MongoLog class
    • MongoPool — The MongoPool class
    • Mongo — The Mongo class [deprecated]
  • Mongo 函数
    • bson_decode — 反序列化一个 BSON 对象为 PHP 数组
    • bson_encode — 序列化一个 PHP 变量为 BSON 字符串
  • Exceptions
    • MongoException — The MongoException class
    • MongoResultException — MongoResultException 类
    • MongoCursorException — The MongoCursorException class
    • MongoCursorTimeoutException — The MongoCursorTimeoutException class
    • MongoConnectionException — The MongoConnectionException class
    • MongoGridFSException — The MongoGridFSException class
    • MongoDuplicateKeyException — The MongoDuplicateKeyException class
    • MongoProtocolException — The MongoProtocolException class
    • MongoExecutionTimeoutException — The MongoExecutionTimeoutException class
    • MongoWriteConcernException — The MongoWriteConcernException class
  • 更新日志


安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
Warning

This extension is deprecated. Instead, the MongoDB extension should be used.


安装

Warning

This extension is deprecated. Instead, the MongoDB extension should be used.

MongoDB 的 PHP 驱动程序可以工作在几乎任何系统上：Windows、Mac OS X、Unix 和 Linux；大端或小端字节序（little/big-endian）；32位和64位的机器；PHP 5.3-5.6(1.6之前的版本同时支持 PHP5.2)。

此 » PECL 扩展未与 PHP 捆绑。

  • 手动安装
  • 在 *NIX 上安装
  • 在 Windows 上安装
  • OS X
  • Gentoo
  • Red Hat
  • 第三方安装说明

手动安装

驱动开发人员和对最新 bug 修复感兴趣的人，可以从 » Github 上获取最新源码来编译驱动。 前往 Github 并点击 "download" 按钮。然后运行：

$ tar zxvf mongodb-mongodb-php-driver-<commit_id>.tar.gz
$ cd mongodb-mongodb-php-driver-<commit_id>
$ phpize
$ ./configure
$ make all
$ sudo make install

并按以下说明修改 php.ini：

  • 确保 extension_dir 变量指向了 mongo.so 的位置。 编译时会显示安装 PHP 驱动的位置，比如输出：

    Installing '/usr/lib/php/extensions/no-debug-non-zts-20060613/mongo.so'
    确保和运行的 PHP 是同一个扩展目录：
    $ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/no-debug-non-zts-20060613 =>
                   /usr/lib/php/extensions/no-debug-non-zts-20060613
    如果不一致，则需要修改 php.ini 里的 extension_dir，或者把 mongo.so 移过去。

  • 要在 PHP 启动的时候加载这个扩展，添加一行：

    extension=mongo.so

在 *NIX 上安装

执行:

$ sudo pecl install mongo

将以下内容添加到 php.ini 文件:

extension=mongo.so

如果 pecl 运行时超出了内存限制，请确认在 php.ini 中的 memory_limit 的设置至少有 128MB。

在 Windows 上安装

针对不同线程安全、VC版本的 PHP 发行版，可从 » PECL 获取到预编译的二进制文件。 解压，并把 php_mongo.dll 放到 PHP 扩展目录（默认是 "ext"）。

将以下内容添加到 php.ini 文件:

extension=php_mongo.dll

Note: 为 Windows 用户添加额外的依赖 DLL

为了使此扩展生效， DLL 文件必须能在 Windows 系统的 PATH 指示的路径下找到。如何操作的信息，请参见题为"如何在 Windows 中将 PHP 目录加到 PATH 中"的FAQ。虽然将 DLL 文件从 PHP 文件夹复制到 Windows 系统目录也行，但不建议这样做。 此扩展需要下列文件在 PATH 路径中： libsasl.dll

OS X

大部分情况下，从 pecl 安装最简单：

$ sudo pecl install mongo

如果用的是 » Homebrew，PHP 包含了驱动安装的方案。比如，安装 PHP 5.6 的驱动，可以使用以下命令：

$ brew install php56-mongo

如果使用的是 » XAMPP，请注意它有自己的 pecl 二进制文件和 php.ini 配置。 你可以通过以下命令安装驱动：

$ sudo /Applications/XAMPP/xamppfiles/bin/pecl install mongo

Note: 在 OS X 上编译时的 Xcode 依赖

在 OS X 上编译驱动需要 Xcode 开发工具，可以通过 xcode-select --install 安装。 如果命令无效，也许应该先安装 » Command Line Tools 包。

Gentoo

Gentoo 有一个 PHP 驱动的包，叫做 dev-php/pecl-mongo，可以通过以下命令安装：

$ sudo emerge -va dev-php5/mongo

如果你使用了 PECL，你可能得到 libtool 版本不正确的错误。 从源码编译，你需要运行 aclocal 和 autoconf。

$ phpize && aclocal && autoconf && ./configure && make && make install

Red Hat

同时包括 Fedora 和 CentOS。

这些系统上默认的 Apache 设置禁止请求产生网络连接，意味着当连接到数据库，驱动会得到一个 "Permission denied" 错误。当遇到这个问题，可以试试运行：

$ /usr/sbin/setsebool -P httpd_can_network_connect 1
然后重启 Apache。（在 SELinux 下也会产生这个问题。）

第三方安装说明

很多人撰写了安装 PHP 驱动的极好教程。

  • » 在 Mac OS X 上安装或重装 PHP

    Justin Hileman 撰写的文章详细描述了在 OS X 上使用 Homebrew 安装 PHP 和额外的扩展（extension）。 此文补充了早些时候此页上用 Homebrew 安装驱动的说明。

  • » Ubuntu 9.10 / Apache 2.2 下，附带 Xdebug, MongoDB 和 Lithium 的 PHP 5.3.1。

    Jon Adams 的视频录像演示了如何在 Ubuntu 9.1 的 Apache 下快速设置运行 PHP 5.3.1，Xdebug 和 MongoDB。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Mongo 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mongo.allow_empty_keys | 0 | PHP_INI_ALL |
mongo.allow_persistent | 1 | PHP_INI_ALL | Removed in 1.2.0
mongo.chunk_size | 262144 | PHP_INI_ALL |
mongo.cmd | "$" | PHP_INI_ALL |
mongo.default_host | "localhost" | PHP_INI_ALL |
mongo.default_port | 27017 | PHP_INI_ALL |
mongo.is_master_interval | 15 | PHP_INI_ALL | Added in 1.2.10, before 1.3.0 the default value was 60.
mongo.long_as_object | 0 | PHP_INI_ALL |
mongo.native_long | 1 | PHP_INI_ALL | Before 1.5.0, the default value was 0.
mongo.ping_interval | 5 | PHP_INI_ALL | Added in 1.2.10
mongo.utf8 | 1 | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

mongo.allow_empty_keys int

Added in version 1.0.11.

If empty strings ("") should be allowed as key names. By default, the driver will throw an exception if you attempt to pass the empty string as a key to the database. It is extremely easy to do this inavertently by using double quotes with $-operators, so it is recommended that you leave this setting as default. However, if you need to save keys that are empty strings, you can set this option to true and the driver will allow you to pass empty strings to the database.

mongo.allow_persistent int

If persistent connections are allowed. (Removed in 1.2.0 - all connections are now persistent).

mongo.chunk_size int

The number of bytes-per-chunk. Used in divvying up GridFS files. This number must be at least 100 less than 4 megabytes (max: 4194204) and it is recommended that it be less than that.

mongo.cmd string

A character to be used in place of $ in modifiers and comparisons.

As it is easy to forget to escape the "$", you can also choose your own special character to use instead of '$'. Choose a character that will not occur in your key names, e.g. ":":

mongo.cmd = ":"

Then, to do a comparison, for example:

<?php

$query = array( "i" => array( ":gt" => 20, ":lte" => 30 ) );

?>

You can also change it in your code using ini_set("mongo.cmd", ":"). Of course, you can also just use single quotes or backslash-escape the $.

mongo.default_host string

Default hostname when nothing is passed to the constructor.

mongo.default_port string

The default TCP port number to use when connecting to the database server if no other port is specified. The database's default is 27017.

mongo.is_master_interval int

Added in version 1.2.10.

For replicaset connections: The minimum interval with which the driver will send "isMaster" requests to the MongoDB server. If the value is lower, there will be more requests, but the driver finds faster whether the topology of the replicaset has been changed.

mongo.long_as_object int

Return a BSON_LONG as an instance of MongoInt64 (instead of a primitive type).

mongo.native_long int

The default behavior for this has been changed to true in 1.5.0, so make sure to set this variable to the value you want (probably true) so that the driver's behavior doesn't suddenly change when you upgrade.

On 64-bit platforms, the mongo.native_long setting allows for 64-bit integers to be stored in MongoDB. If it is not set, only 32-bits of the integer will be saved. The MongoDB data type that is used in this case is the BSON LONG, instead of the BSON INT that is used if this setting is turned off.

The setting also changes the way how BSON LONGs behave when they are read back from MongoDB. Without mongo.native_long enabled, the driver would convert every BSON LONG to a PHP double which can result in a loss of precision.

On 32-bit platforms, the mongo.native_long setting changes nothing for storing integers in MongoDB: the integer is stored as a BSON INT as before. However, when the setting is enabled and a BSON LONG is read from MongoDB a MongoCursorException is thrown alerting you that the data could not be read back without losing precision.

On 32-bit systems especially, it is recommended that you combine this with enabling mongo.long_as_object.

mongo.ping_interval int

Added in version 1.2.10.

For replicaset connections: The minimum interval with which the driver will send "ping" requests to the MongoDB server. If the value is lower, there will be more pings, but the driver finds faster whether a node is no longer reachable from the replicaset.

mongo.utf8 int

If an exception should be thrown for non-UTF8 strings. Until version 1.0.4, the PHP driver would ignore non-UTF8 strings, even though you're not supposed to insert them. As of 1.0.4, the driver throws a MongoException. To ease the transition for applications that insert non-UTF8 strings, you can turn this option off to emulate the old, non-exception-throwning behavior. This option will be eliminated and exceptions always thrown for non-UTF8 strings starting with version 1.1.0.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

MONGO_STREAMS (int)
Alias of MONGO_SUPPORTS_STREAMS
MONGO_SUPPORTS_STREAMS (int)
1 when compiled against PHP Streams (default since 1.4.0).
MONGO_SUPPORTS_SSL (int)
1 when OpenSSL is enabled and available.
MONGO_SUPPORTS_AUTH_MECHANISM_MONGODB_CR (int)
1 when MongoDB-Challenge/Reponse authentication is compiled in.
MONGO_SUPPORTS_AUTH_MECHANISM_MONGODB_X509 (int)
1 when x.509 authentication is compiled in.
MONGO_SUPPORTS_AUTH_MECHANISM_GSSAPI (int)
1 when GSSAPI authentication is compiled in.
MONGO_SUPPORTS_AUTH_MECHANISM_PLAIN (int)
1 when PLAIN authentication is compiled in.
MONGO_STREAM_NOTIFY_TYPE_IO_INIT (int)
MONGO_STREAM_NOTIFY_TYPE_LOG (int)
MONGO_STREAM_NOTIFY_IO_READ (int)
MONGO_STREAM_NOTIFY_IO_WRITE (int)
MONGO_STREAM_NOTIFY_IO_PROGRESS (int)
MONGO_STREAM_NOTIFY_IO_COMPLETED (int)
MONGO_STREAM_NOTIFY_LOG_INSERT (int)
MONGO_STREAM_NOTIFY_LOG_QUERY (int)
MONGO_STREAM_NOTIFY_LOG_UPDATE (int)
MONGO_STREAM_NOTIFY_LOG_DELETE (int)
MONGO_STREAM_NOTIFY_LOG_GETMORE (int)
MONGO_STREAM_NOTIFY_LOG_KILLCURSOR (int)
MONGO_STREAM_NOTIFY_LOG_BATCHINSERT (int)
MONGO_STREAM_NOTIFY_LOG_RESPONSE_HEADER (int)
MONGO_STREAM_NOTIFY_LOG_WRITE_REPLY (int)
MONGO_STREAM_NOTIFY_LOG_CMD_INSERT (int)
MONGO_STREAM_NOTIFY_LOG_CMD_UPDATE (int)
MONGO_STREAM_NOTIFY_LOG_CMD_DELETE (int)
MONGO_STREAM_NOTIFY_LOG_WRITE_BATCH (int)


手册

Table of Contents

  • 教程
  • 读取首选项
  • Write Concerns
  • SQL 到 Mongo 的对应表
  • 链接服务器
  • Stream Context Options
  • Writes
  • Querying
  • Updates
  • Security
  • 故障排除
  • Running the Driver's Tests
Warning

This extension is deprecated. Instead, the MongoDB extension should be used.

这个手册详细的描述了如何使用 MongoDB，但是它主要覆盖了 PHP 驱动的使用。关于如何设计一种模式、术语的含义以及如何架设数据库服务器，请查看 » MongoDB 文档。


教程

Table of Contents

  • 连接数据库
  • 获取数据库实例
  • 获取集合实例
  • 插入一个文档
  • 使用 MongoCollection::findOne 方法
  • 添加多个文档
  • 计算文档数量
  • 使用游标获取所有文档
  • 设置查询条件
  • 获取一个子集
  • 建立索引
Warning

This extension is deprecated. Instead, the MongoDB extension should be used.

这是官方的 MongoDB PHP 驱动

这是一个示例程序，它包含 连接数据库、插入文档、查询文档、遍历查询结果、断开链接。 实例中的每一步都有更详细的说明（注释）。

<?php

// 链接服务器
$m = new MongoClient();

// 选择一个数据库
$db = $m->comedy;

// 选择一个集合（ Mongo 的"集合"相当于关系型数据库的"表"）
$collection = $db->cartoons;

// 插入一个文档（译注："文档"相当于关系型数据库的"行"）
$document = array( "title" => "Calvin and Hobbes", "author" => "Bill Watterson" );
$collection->insert($document);

// 添加另一个文档，它的结构与之前的不同
$document = array( "title" => "XKCD", "online" => true );
$collection->insert($document);

// 查询集合中的所有文档
$cursor = $collection->find();

// 遍历查询结果
foreach ($cursor as $document) {
    echo $document["title"] . "\n";
}

?>

以上例程会输出：

Calvin and Hobbes
XKCD


连接数据库

使用下面列出的其中一种方法链接：

<?php
$connection = new MongoClient(); // 连接到 localhost:27017
$connection = new MongoClient( "mongodb://example.com" ); // 连接到远程服务器 （使用默认端口： 27017）
$connection = new MongoClient( "mongodb://example.com:65432" ); // 链接到远程服务器，使用自定义的端口
?>

你并不必须手动从服务器断开连接。这个驱动使用了持久连接，并会在下次试图链接到同一服务器时重用它。

参见

链接 中的相关章节。来获得更多链接方式的信息。

MongoClient 类和 MongoClient::__construct() 的文档中有对所有链接方式的详细说明， 并且带有一些例子。


获取数据库实例

要选择数据库，使用：

<?php
$connection = new MongoClient();
$db = $connection->dbname;
?>

这个数据库不需要提前建好，当你使用它的时候，就会自动建立。

要小心的是，你可能不小心建立了一个新的数据库，然后产生奇怪的错误。 （在下面的例子中，第二次使用"同一个"数据库时 name 被错误的拼写成 anme）

<?php
$connection = new MongoClient();

$db = $connection->mybiglongdbname;
// do some stuff

$db = $connection->mybiglongdbanme;
// now connected to a different database! 注意此时选择了另一个数据库！
?>

参见

MongoDB 类的文档中有对数据库对象的详细说明。


获取集合实例

获取一个集合的语法与获取数据库时相同：

<?php
$connection = new MongoClient();
$db = $connection->baz;

// select a collection:
$collection = $db->foobar;

// or, directly selecting a database and collection:
$collection = $connection->baz->foobar;
?>

一个集合相当于一张表。（如果你对关系型数据库比较熟悉）

参见

MongoCollection 类的文档中有对集合对象的详细说明。


插入一个文档

关联数组是能插入集合的最基本结构。 一般的"文档"结构可能是这样：

<?php
$doc = array(
    "name" => "MongoDB",
    "type" => "database",
    "count" => 1,
    "info" => (object)array( "x" => 203, "y" => 102),
    "versions" => array("0.9.7", "0.9.8", "0.9.9")
);
?>

注意：你可以嵌套数组、对象。驱动会把关联数组保存为 js对象，从0开始的连续数字下标数组保存为 js数组，不从0开始或有间断的（如0,1,4,5）数组保存为 js对象。 译注：即：只有从0开始的连续数字下标数组保存为数组，其他复杂类型均为对象。

要插入这个文档，使用 MongoCollection::insert() 方法：

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$collection->insert( $doc );
?>

参见

MongoCollection::insert() 方法的文档中有对插入数据的详细说明。


使用 MongoCollection::findOne 方法

  • ? 插入一个文档
  • 添加多个文档 ?
  • PHP Manual
  • 教程
  • 使用 MongoCollection::findOne 方法

使用 MongoCollection::findOne() 方法

要查看我们上一步插入到数据库的文档，可以简单的使用 MongoCollection::findOne() 方法从即合理获得一个简单的文档。 这个方法在只想查询一个结果的时候很有用。

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$document = $collection->findOne();
var_dump( $document );
?>

以上例程会输出：

array(6) {
  ["_id"]=>
  object(MongoId)#8 (1) {
    ["$id"]=>
    string(24) "4e2995576803fab768000000"
  }
  ["name"]=>
  string(7) "MongoDB"
  ["type"]=>
  string(8) "database"
  ["count"]=>
  int(1)
  ["info"]=>
  array(2) {
    ["x"]=>
    int(203)
    ["y"]=>
    int(102)
  }
  ["versions"]=>
  array(3) {
    [0]=>
    string(5) "0.9.7"
    [1]=>
    string(5) "0.9.8"
    [2]=>
    string(5) "0.9.9"
  }
}

注意：有一个 _id 字段被自动添加到你的文档中了。 _id 字段就是集合的"主键"。 如果插入文档的时候你没有手动指定，驱动就会自动帮你添加一个。

如果你所插入的文档定义了 _id 字段，那么它在集合中必须是唯一的。 这是一个例子：

<?php
$connection = new MongoClient();
$db = $connection->database;

$db->foo->insert(array("_id" => 1));
// this will throw an exception
$db->foo->insert(array("_id" => 1));

// this is fine, as it is a different collection
$db->bar->insert(array("_id" => 1));
?>

默认设置时，驱动会在服务器通过了写入请求后返回（译注："通过"即如果不发生崩溃等情况，待插入的文档就一定会在随后被写入，这并不意味着数据已经写入磁盘）。你可以通过将第二个参数设为 array("w" => 0) 来改变默认行为。此时你的插入请求会立即返回，并且不会抛出 _id 重复的异常。

参见

MongoCollection::findOne() 方法的文档中有对查询的详细说明。

唯一ID的信息查看 MongoId

写入 部分更详细的说明了写操作, Write Concerns 章节深入解释了一些写操作的选项。


添加多个文档

为了观察更多查询时值得关注的事情，我们来插入很多相似的文档到同一个集合里。这些文档的结构简单的类似于： array( "i" => value ); 。 通过一个循环，我们可以快速插入这些文档：

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

for ( $i = 0; $i < 100; $i++ )
{
    $collection->insert( array( 'i' => $i, "field{$i}" => $i * 2 ) );
}
?>

注意：我们可以把结构（键名）不同的数组插入同一个集合。这正是我们说 MongoDB 是一个"无结构"数据库的原因。在上面的例子中，每个文档都有一个 i 字段，但同时也有一个变化的 field + $i 字段。


计算文档数量

现在我们的集合中有101个文档（100个循环插入的，加上一开始的一个），我们可以通过 MongoCollection::count() 方法检查它。

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

echo $collection->count();
?>
这会输出 101 。


使用游标获取所有文档

要获得集合中的所有文档，我们需要 MongoCollection::find() 方法。 find() 方法返回一个 MongoCursor 对象，允许我们遍历整个结果集合来读取文档。要查询所有的文档并显示它们，使用：

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$cursor = $collection->find();
foreach ( $cursor as $id => $value )
{
    echo "$id: ";
    var_dump( $value );
}
?>
这样会输出整个集合中的101个文档。 $id 是集合的 _id 字段（被转换成字符串）， $value 是文档本身。

参见

MongoCollection::find() 方法的文档中有关于查询的详细信息。


设置查询条件

我们可以建立一个查询，然后传递给 MongoCollection::find() 方法来查询集合的一个子集。 例如：我们要查询 "i" 字段等于 71 的文档，我们可以使用：

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$query = array( 'i' => 71 );
$cursor = $collection->find( $query );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

以上例程会输出：

array(2) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["i"]=>
  int(71)
  ["_ns"]=>
  "testCollection"
}


获取一个子集

我们可以用查询条件从集合中获得多个文档。 例如：想要获得 "i" > 50 的文档，我们需要：

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$query = array( "i" => array( '$gt' => 50 ) ); //note the single quotes around '$gt'
$cursor = $collection->find( $query );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

将会显示 "i" > 50 的文档。也可以获得一个范围内的文档，比如 20 < i <= 30：

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$query = array( 'i' => array( '$gt' => 20, "\$lte" => 30 ) );
$cursor = $collection->find( $query );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

要注意美元字符始终都需要转义，或者可以用单引号代替。否则 PHP 会把它解析成对应的变量 $gt。


建立索引

MongoDB 支持索引，并且很容易给集合添加索引。你需要指定字段名和排序方向： 升序（1）或降序（-1）。例如：

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$collection->ensureIndex( array( "i" => 1 ) );  // create index on "i"
$collection->ensureIndex( array( "i" => -1, "j" => 1 ) );  // index on "i" descending, "j" ascending
?>

当你的数据量变得越来越大，创建索引对读取性能有巨大的提升。如果你不了解索引，可以参考 MongoCollection::ensureIndex() 文档和 MongoDB 的 » MongoDB indexing documentation。


读取首选项

MongoDB 2.2 和 1.3.0 版本的驱动增加了支持 » 读取首选项, 允许你指定怎样查询MongoDB复制集. 读取首选项可能被指定在连接上，或者库上，或者是集合上. 首选项规定默认要自上而下的继承 (举个例子 MongoCollection 将继承相应的 MongoDB 实例的读取首选项).

读取首选项是模式和标签集相结合的. 模式决定mongod的优先权, 而 » 标签集 为mongod实例合格指定了标准。只有那些ping附近的mongd实例时间在15毫秒内的Mongod实例是合格的。

读取首选项模式

Warning

所有的读取首选项都可能返回从节点比主节点延时的的数据，除非你选择MongoClient::RP_PRIMARY。如果你不使用MongoClient::RP_PRIMARY.模式，请确保你的应用可以容忍过时的数据。

  • MongoClient::RP_PRIMARY

    所有的读操作将使用主节点. 默认是这样，如果主节点不可用，读操作将产生一个异常。

    这个模式和使用标签集相冲突. 一个标签集指定为 MongoClient::RP_PRIMARY 将产生一个异常。

  • MongoClient::RP_PRIMARY_PREFERRED

    在大多数情况下, 读取会操作主节点. 但是，如果主节点不可用, 故障转移期间, 将从从节点读取数据。

    当读取首选项包含一个标签集, 客户端首先从主节点读取, 如果可用，去从节点匹配标签. 如果从节点没有匹配到标签, 读操作将产生一个异常。

    Warning

    2.2版本的mongos增加了完全支持读取首选项功能。当连接到mongos实例时, MongoClient::RP_PRIMARY_PREFERRED将发送查询到从节点.

  • MongoClient::RP_SECONDARY

    读操作仅仅发送给从节点. 如果没有从节点可用，将产生一个异常.

    大多数复制集至少有一个从节点, 但是可能没有可用的从节点。举个例子，有一主节点和一从节点, 还有一个仲裁节点，但是没有其它从节点了，从节点处于故障转移阶段或者不可用的时候。

    当读取首选项包括了标签集, 客户端试着找到匹配标签的从节点，直接读一个从节点。如果没有匹配标签的从节点，将导致一个异常

  • MongoClient::RP_SECONDARY_PREFERRED

    大多数情况下，从从节点读取，在只有主节点的情况下，读取主节点

    当读取首选项包括了标签集, 客户端试着找到匹配标签的从节点，直接读一个从节点。如果没有匹配标签的从节点，将导致一个异常.

  • MongoClient::RP_NEAREST

    驱动随机读取一个ping时间低于15毫秒的节点。使用 MongoClient::RP_NEAREST 模式的话，读取可能发生在主节点或者从节点。

    采用这个模式的话，读操作会发生在网络延时小的节点，不考虑读取的数据是过时的还是最新的。

    当读取首选项包括了标签集, 客户端试着找到匹配标签的节点，直接读一个最近组的随机节点。

    Note:

    对复制集的读操作都发生在符合特定读首选项的最近的节点。 MongoClient::RP_NEAREST 模式会获取主节点和从节点的状态，找到延时低的节点来读取。

标签集

» 标签集允许你自定义参数，把读操作指向特定的节点。标签集使得下面两种情况成为可能，读操作指向特定的数据节点或者指定的mongod实例给指定类型的操作使用，例如记录日志或者分析日志。

你可以指定标签集用下面的读取首选项模式：

  • MongoClient::RP_PRIMARY_PREFERRED

  • MongoClient::RP_SECONDARY

  • MongoClient::RP_SECONDARY_PREFERRED

  • MongoClient::RP_NEAREST

你不能指定标签集用 MongoClient::RP_PRIMARY 读取首选项模式。只有选择了一个从节点，标签才能用，除非是最近模式。

特殊的读取首选项

读取首选项可能指定连接URI给 MongoClient::__construct(), 使用查询串语法或者使用标签集的数组语法传递给核心类的设置方法。

当某个读取首选项使用了查询串， 标签集的 readPreferenceTags值应该是逗号分隔开的一串冒号连接的键值对。

Note:

每一个查询串定义的标签集将使用 readPreferenceTags 名称. 不像php接收URL查询串的方式，readPreferenceTags连续的值相互不覆盖。驱动将按照顺序获得标签集。

Warning

如果驱动找不到一个匹配的标签集，读取会失败！ 你有责任提供合适的回退，像空的 readPreferenceTags 值指定"没有标签集首选项".

Example #1 查询串语法的读取首选项URI链接

<?php
// Prefer the nearest server with no tag preference
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Pick the nearest server in the "east" data center
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east,use:reporting';
$uri .= '&readPreferenceTags=dc:west';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Prefer the nearest server in the "east" data center, then a server in the
// "west" data center, and finally fall back to no tag set preference
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$uri .= '&readPreferenceTags=dc:west';
$uri .= '&readPreferenceTags=';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));
?>

Example #2 Setting read preferences with array syntax for tag sets

<?php

$m = new MongoClient('mongodb://rs1.example.com,rs2.example.com', array(
    'replicaSet' => 'rs',
));

// Prefer the nearest server with no tag preference
$m->setReadPreference(MongoClient::RP_NEAREST, array());

// Pick the nearest server in the "east" data center
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east'),
));

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));

// Prefer the nearest server in the "east" data center, then a server in the
// "west" data center, and finally fall back to no tag set preference
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east'),
    array('dc' => 'west'),
    array(),
));
?>


Write Concerns

MongoDB provides several different ways of selecting how durable a write to the database should be. These ways are called Write Concerns and span everything from completely ignoring all errors, to specifically targetting which servers are required to confirm the write before returning the operation.

When a write (such as with MongoCollection::insert(), MongoCollection::update(), and MongoCollection::remove()) is given a Write Concern option ("w") the driver will send the query to MongoDB and piggy back a getLastError command (GLE) with the Write Concern option at the same time. The server only returns when the Write Concern condition is verified to be fulfilled, or the query times out (controlled with the "wtimeout" option, 10000 milliseconds is the default).

Warning

Even though a getLastError command times out the data will most likely have been written to the primary server and will be replicated to all the secondaries once they have caught up.

The typical reasons for a timeout to happen is if you specify a Write Concern which requires confirmation from more servers then you currently have available.

When using acknowledged writes and the replica set has failed over, the driver will automatically disconnect from the primary, throw an exception, and attempt to find a new primary on the next operation (your application must decide whether or not to retry the operation on the new primary).

When using unacknowledged writes (w=0) and the replica set has failed over, there will be no way for the driver to know about the change so it will continue and silently fail to write.

The default Write Concern for the MongoClient is 1: acknowledge write operations.

Available Write Concerns
Write Concern | Meaning | Description
w=0 | Unacknowledged | A write will not be followed up with a GLE call, and therefore not checked ("fire and forget")
w=1 | Acknowledged | The write will be acknowledged by the server (the primary on replica set configuration)
w=N | Replica Set Acknowledged | The write will be acknowledged by the primary server, and replicated to N-1 secondaries.
w=majority | Majority Acknowledged | The write will be acknowledged by the majority of the replica set (including the primary). This is a special reserved string.
w=<tag set> | Replica Set Tag Set Acknowledged | The write will be acknowledged by members of the entire tag set
j=true | Journaled | The write will be acknowledged by primary and the journal flushed to disk

Using WriteConcerns

Each of the methods that causes writes (MongoCollection::insert(), MongoCollection::update(), MongoCollection::remove(), and MongoCollection::batchInsert()) allow an optional argument to send a set of options to the MongoDB server. With this option array you can set the WriteConcern as the following example illustrates:

Example #1 Passing a WriteConcern to a write operation

<?php
// Setting w=0 for insert:
$collection->insert($someDoc, array("w" => 0));

// Setting w=majority for update:
$collection->update($someDoc, $someUpdates, array("w" => "majority"));

// Setting w=5 and j=true for remove:
$collection->update($someDoc, array("w" => 5, "j" => true));

// Setting w="AllDCs" for batchInsert:
$collection->update(array($someDoc1, $someDoc2), array("w" => "AllDCs"));
?>

Besides setting WriteConcerns per operation as an option argument, it is also possible to set a default WriteConcern in different ways.

The first way is through the connection string. The connection string accepts the journal, w, and wTimeoutMS options:

Example #2 Connection string WriteConcerns

<?php
$m = new MongoClient("mongodb://localhost/?journal=true&w=majority&wTimeoutMS=20000");
?>

Since driver version 1.5 it is also possible to call MongoDB::setWriteConcern() and MongoCollection::setWriteConcern() to set a default WriteConcern for all operations created from that specific MongoDB or MongoCollection object:

Example #3 MongoDB::setWriteConcern and MongoCollection::setWriteConcern

<?php
$m = new MongoClient("mongodb://localhost/");
$d = $m->demoDb;
$c = $d->demoCollection;

// Set w=3 on the database object with a timeout of 25000ms
$d->setWriteConcern(3, 25000);

// Set w=majority on the collection object without changing the timeout
$c->setWriteConcern("majority");
?>

Unacknowledged Writes

By not requiring the server to acknowledge writes the writes can be performed extremely quickly, but you don't know whether or not they actually succeeded. Writes can fail for a number of reasons: if there are network problems, if a database server goes down, or if the write was simply invalid (e.g., writing to a system collection; or duplicate key errors).

While developing, you should always use acknowledged writes (to protect against inadvertent mistakes, such as syntax errors, invalid operators, duplicate key errors and so on). In production, unacknowledged writes can be used for "unimportant" data. Unimportant data varies on application, but it's generally automatically (instead of user generated) data, such as click tracking or GPS locations, where you can get thousands of records per second.

It is strongly recommended that you do an acknowledged write at the end of series of unacknowledged writes. Doing so will not incur in a too large performance penalty, but still allow you to catch any errors that may have occurred.

Example #4 Unacknowledged WriteConcern, followed with Acknowledged Write

<?php
$collection->insert($someDoc, array("w" => 0));
$collection->update($criteria, $newObj, array("w" => 0));
$collection->insert($somethingElse, array("w" => 0));
try {
    $collection->remove($something, array("w" => 1));
} catch(MongoCursorException $e) {
    /* Handle the exception.. */
    /* Here we should issue find() queries on the IDs generated for
    $somethingElse and $someDoc to verify they got written to the database and
    attempt to figureout where in the chain something happened. */
}
?>

If the last write throws an exception, you know that there's a problem with your database.

Acknowledged Writes

These type of write operations will make sure that the database has accepted the write operation before returning success. If the write failed, it will throw a MongoCursorException with an explanation of the failure. The MongoClient default behaviour is to acknowledge the write (w=1).

It is possible to specify how many members of an replica set have to acknowledge the write (i.e. have it replicated) before the write is deemed acknowledged and the operation returns.

Example #5 Acknowledged Writes

<?php
// Force acknowledgement from the primary only
$collection->insert($doc, array("w" => 1));

// Force acknowledgement from the primary, and one other member of the
// replica set
$collection->insert($doc, array("w" => 2));

// Force acknowledgement from the primary, and six other members of the
// replica set (you probably never should do this):
$collection->insert($doc, array("w" => 7));
?>

Keep in mind to select your Write Concern carefully. If you have a replica set with 5 members, and you select Write Concern of 4 you will risk the write blocking forever when one member of the replica set goes down for maintenance or a temporary network outage happens.

Warning

Passing in a string value for Write Concern has a specific meaning (Replica Set Tag Set Acknowledged). Please be careful of NOT using string values for numbers (i.e. array("w" => "1")) as it will be treated as a tag set name.

Majority Acknowledged Writes

Using the special majority Write Concern option is the recommended way for writes that are required to survive the apocalypse, as it will ensure the majority of your replica set will have the write and will therefore be guaranteed to survive all usual suspect outage scenarios.

Example #6 Majority Acknowledged Write

<?php
$collection->insert($someDoc, array("w" => "majority"));
?>

Journaled Writes

When connecting to a replica set the default Write Concern is only to have the primary server acknowledge the write. There is however a 100ms window until the write gets journaled and flushed to disk. It is possible to force the write to be journaled before acknowledging the write by setting the j option:

Example #7 Acknowledged and Journaled Write

Forcing journal flush

<?php
$options = array(
    "w" => 1,
    "j" => true,
);
try {
    $collection->insert($document, $options);
} catch(MongoCursorException $e) {
    /* handle the exception */
}
?>

参见

  • » MongoDB WriteConcern docs

更新日志

版本 | 说明
1.3.0 | MongoClient was introduced and defaults to acknowledged writes. The deprecated Mongo defaults to unacknowledged writes.
1.3.0 | The "safe" write option has been deprecated and is not available with the new MongoClient class. Use the "w" option instead.


SQL 到 Mongo 的对应表

这个列表是 PHP 版本的 » SQL to Mongo 对应表（在MongoDB官方手册中有更加通用的版本）。

SQL查询语句 | Mongo查询语句
CREATE TABLE USERS (a Number, b Number) | 隐式的创建，或 MongoDB::createCollection().
INSERT INTO USERS VALUES(1,1) | $db->users->insert(array("a" => 1, "b" => 1));
SELECT a,b FROM users | $db->users->find(array(), array("a" => 1, "b" => 1));
SELECT * FROM users WHERE age=33 | $db->users->find(array("age" => 33));
SELECT a,b FROM users WHERE age=33 | $db->users->find(array("age" => 33), array("a" => 1, "b" => 1));
SELECT a,b FROM users WHERE age=33 ORDER BY name | $db->users->find(array("age" => 33), array("a" => 1, "b" => 1))->sort(array("name" => 1));
SELECT * FROM users WHERE age>33 | $db->users->find(array("age" => array('$gt' => 33)));
SELECT * FROM users WHERE age<33 | $db->users->find(array("age" => array('$lt' => 33)));
SELECT * FROM users WHERE name LIKE "%Joe%" | $db->users->find(array("name" => new MongoRegex("/Joe/")));
SELECT * FROM users WHERE name LIKE "Joe%" | $db->users->find(array("name" => new MongoRegex("/^Joe/")));
SELECT * FROM users WHERE age>33 AND age<=40 | $db->users->find(array("age" => array('$gt' => 33, '$lte' => 40)));
SELECT * FROM users ORDER BY name DESC | $db->users->find()->sort(array("name" => -1));
CREATE INDEX myindexname ON users(name) | $db->users->ensureIndex(array("name" => 1));
CREATE INDEX myindexname ON users(name,ts DESC) | $db->users->ensureIndex(array("name" => 1, "ts" => -1));
SELECT * FROM users WHERE a=1 and b='q' | $db->users->find(array("a" => 1, "b" => "q"));
SELECT * FROM users LIMIT 20, 10 | $db->users->find()->limit(10)->skip(20);
SELECT * FROM users WHERE a=1 or b=2 | $db->users->find(array('$or' => array(array("a" => 1), array("b" => 2))));
SELECT * FROM users LIMIT 1 | $db->users->find()->limit(1);
EXPLAIN SELECT * FROM users WHERE z=3 | $db->users->find(array("z" => 3))->explain()
SELECT DISTINCT last_name FROM users | $db->command(array("distinct" => "users", "key" => "last_name"));
SELECT COUNT(*y) FROM users | $db->users->count();
SELECT COUNT(*y) FROM users where AGE > 30 | $db->users->find(array("age" => array('$gt' => 30)))->count();
SELECT COUNT(AGE) from users | $db->users->find(array("age" => array('$exists' => true)))->count();
UPDATE users SET a=1 WHERE b='q' | $db->users->update(array("b" => "q"), array('$set' => array("a" => 1)));
UPDATE users SET a=a+2 WHERE b='q' | $db->users->update(array("b" => "q"), array('$inc' => array("a" => 2)));
DELETE FROM users WHERE z="abc" | $db->users->remove(array("z" => "abc"));


链接服务器

Table of Contents

  • 认证
  • 复制集合
  • Sharding
  • Unix Domain Socket支持
  • Connection Pooling (version 1.2.0-1.2.12 *only*)
  • Persistent Connections (version up to 1.1.4 *only*)

链接到 mongo 服务器非常简单，只需要 new MongoClient，但是还可以改变更多的选项设置。 MongoClient::__construct() 方法的文档中包括了所有的 API 参数。这个页面给出了一些详细说明，和一些实用的案例。


认证

如果 MongoDB 服务器启动时使用了 --auth 或 --keyFile 参数，你就必须在进行任何操作前进行认证。 你可以在连接时进行认证。方法是在链接字符串中指定用户名密码，或者在 MongoClient::__construct() 构造函数中指定 "username" 和 "password"。

Example #1 针对"admin"数据库的认证

<?php
// Specifying the username and password in the connection URI (preferred)
$m = new MongoClient("mongodb://${username}:${password}@localhost");

// Specifying the username and password via the options array (alternative)
$m = new MongoClient("mongodb://localhost", array("username" => $username, "password" => $password));
?>

默认状态下，驱动会针对 admin 数据库进行认证。认证也可以对其他数据库进行。方法是在连接字符串中指定数据库名，或者 MongoClient::__construct() 构造函数中指定 "db"。

Example #2 针对一般数据库的认证

<?php
// Specifying the authentication database in the connection URI (preferred)
$m = new MongoClient("mongodb://${username}:${password}@localhost/myDatabase");

// Specifying the authentication database via the options array (alternative)
$m = new MongoClient("mongodb://${username}:${password}@localhost", array("db" => "myDatabase"));
?>

如果链接中断，驱动会重新尝试链接并会自动重新认证。


复制集合

要链接到一个复制，需要指定复制中的一个或多个成员，并使用 "replicaSet" 选项指定复制的名字。多个服务器用逗号分割。

Example #1 链接到一个复制

<?php
// Using multiple servers as the seed list (prefered)
$m = new MongoClient("mongodb://rs1.example.com:27017,rs2.example.com:27017/?replicaSet=myReplSetName"));

// Using one server as the seed list
$m = new MongoClient("mongodb://rs1.example.com:27017", array("replicaSet" => "myReplSetName"));

// Using multiple servers as the seed list
$m = new MongoClient("mongodb://rs1.example.com:27017,rs2.example.com:27017", array("replicaSet" => "myReplSetName"));
?>

驱动会查询数据库服务器列表，然后找出主服务器。如果可以成功的链接到指定的服务器至少一个，并且可以找到主服务器，链接就会成功。如果它无法链接指定的任何一个服务器，或者找不到主服务器，会抛出一个 MongoConnectionException 类型的异常

Tip

你应该始终指定多个复制中的服务器。为了达到最大的可用性，你指定的服务器列表应该包含每一个数据中心的服务器至少一台。

如果主服务器变为不可用，会有一台次要服务器通过投票算法自动提升为主服务器（除非"投票"无法选出主服务器）。在一段时间里 （» 20-60 秒），链接无法进行写操作，此时写入会导致一个异常。 到次要服务器的链接仍然可以提供读取功能。

Note:

默认的 读取偏好 是只从主服务器读取。在自动选择新的主服务器的时间里，读取操作也会失败。

对于要求很高的读取可用性的应用，推荐使用 MongoClient::RP_PRIMARY_PREFERRED 读取偏好来确保主服务器出现问题的时候能正确的从次要服务器中读取。

当新的主服务器被选出后，尝试读写操作时，驱动会检测新的主服务器。然后链接到它，继续提供正常的功能。

次要服务器的健康状态每5秒（可以通过 mongo.ping_interval 调整），或5秒后的下一个操作执行时检查一次。驱动会在连接服务器出现错误时重新检查配置。

复制集会每60秒（可以通过 mongo.is_master_interval 调整），或在w=1的写入操作发生错误的时候检查故障并尝试恢复。

Caution

次要服务器中的操作相比主服务器有一定延迟，因此如果使用 MongoClient::RP_PRIMARY 之外的读取偏好，你的程序就必须能够正确处理过时的数据。

要了解更多关于复制集的信息，参考 » core documentation.

参见

  • 读取首选项
  • Write Concerns

更新日志

版本 | 说明
1.0.9 | 添加了复制集支持，和自动错误恢复。


Sharding

To connect to a shard cluster, specify the address of one or more mongos instances in the connection string. Multiple servers may be delimited by a comma.

<?php
// Using one server as the seed list
$m = new MongoClient("mongodb://mongos1.example.com:27017");

// Using multiple servers as the seed list
$m = new MongoClient("mongodb://mongos1.example.com:27017,mongos2.example.com:27017"));
?>

Regardless of whether each shard is a stand-alone mongod server or a full replica set, the driver's connection process is the same. All database communication will be routed through mongos.

For more information on sharding with MongoDB, see the » sharding documentation.


Unix Domain Socket支持

MongoDB 服务程序内置支持通过 Unix Sockets 链接，并且会在启动时建立socket，默认位置在 /tmp/mongodb-<port>.sock..

要通过socket链接，需要在连接字符串中指定socket路径，如：

<?php
$m = new MongoClient("mongodb:///tmp/mongo-27017.sock");
?>

如果要在通过socket的链接中对数据库进行认证（如上文所述），你需要指定一个端口号 0 让链接字符串解析时可以找到 socket路径 的结尾。另外，你可以在链接的时候使用options参数。

<?php
$m = new MongoClient("mongodb://username:password@/tmp/mongo-27017.sock:0/foo");
?>

更新日志

版本 | 说明
1.0.9 | 添加 Unix Sockets 的支持。


Connection Pooling (version 1.2.0-1.2.12 *only*)

Note:

This section is no longer relevant as of the 1.3.0 release of the driver and only serves as a historical information on how the pooling used to work.

The latest versions of the driver have no concept of pooling anymore and will maintain only one connection per process, for each connection type (ReplicaSet/standalone/mongos), for each credentials combination.

Creating connections is one of the most heavyweight things that the driver does. It can take hundreds of milliseconds to set up a connection correctly, even on a fast network. Thus, the driver tries to minimize the number of new connections created by reusing connections from a pool.

When a user creates a new instance of MongoClient, all necessary connections will be taken from their pools (replica sets may require multiple connections, one for each member of the set). When the MongoClient instance goes out of scope, the connections will be returned to the pool. When the PHP process exits, all connections in the pools will be closed.

"Why do I have so many open connections?"

Connection pools can generate a large number of connections. This is expected and, using a little arithmetic, you can figure out how many connections will be created. There are three factors in determining the total number of connections:

  • connections_per_pool

    Each connection pool will create, by default, an unlimited number of connections. One might assume that this is a problem: if it can create an unlimited number of connections, couldn't it create thousands and the server would run out of file descriptors? In practice, this is unlikely, as unused connections are returned to the pool to be used later, so future connections will use the same connection instead of creating a new one. Unless you create thousands of connections at once without letting any go out of scope, the number of connections open should stay at a reasonable number.

    You can see how many connections you have in a pool using the MongoPool::info() function. Add up the "in use" and "in pool" fields for a given server. That is the total number of connections for that pool.

  • pools_per_process

    Each MongoDB server address you're connecting to gets its own connection pool. For example, if your local hostname is "example.net", connecting to "example.net:27017", "localhost:27017", and "/tmp/mongodb-27017.sock" will create three connection pools. You can see how many connection pools you have open using MongoPool::info().

  • processes

    Each PHP process has a separate set of pools. PHP-FPM and Apache generally create between 6 and a couple of dozen PHP worker children. Check your settings to see what the max number of PHP processes is that can be spawned.

    If you are using PHP-FPM, estimating the number of connections can be tricky because it will spawn more PHP-FPM workers under heavy load. To be on the safe side, look at the max_children parameter or add up spare_servers + start_servers (choose whichever number is higher). That will indicate how many PHP processes (i.e. sets of pools) you should plan for.

The three variables above can be multiplied together to give the max number of connections expected: connections_per_pool * pools_per_process * processes. Note that connections_per_pool can be different for different pools, so connections_per_pool should be the max.

For example, suppose we're getting 30 connections per pool, 10 pools per PHP process, and 128 PHP processes. Then we can expect 38400 connections from this machine. Thus, we should set this machine's file descriptor limit to be high enough to handle all of these connections or it may run out of file descriptors.

See MongoPool for more information on connection pooling.


Persistent Connections (version up to 1.1.4 *only*)

Note:

This section is not relevant for 1.2.0+. In 1.2.0+, connections are always persistent and managed automatically by the driver. If you are using a 1.2.x release (but not 1.3.x or later), see MongoPool for more information on pooling.

Creating new connection to the database is very slow. To minimize the number of connections that you need to make, you can use persistent connections. A persistent connection is saved by PHP, so you can use the same connection for multiple requests.

For example, this simple program connects to the database 1000 times:

<?php

for ($i=0; $i<1000; $i++) {
  $m = new MongoClient();
}

?>

It takes approximately 18 seconds to execute. If we change it to use a persistent connection:

<?php

for ($i=0; $i<1000; $i++) {
  $m = new MongoClient("localhost:27017", array("persist" => "x"));
}

?>

...it takes less than .02 seconds to execute, as it only makes one database connection.

Persistent connections need an identifier string (which is "x" in the above example) to uniquely identify them. For a persistent connection to be used, the hostname, port, persist string, and authentication credentials (username, password and database, if given) must match an existing persistent connection. Otherwise, a new connection will be created with this identifying information.

Persistent connections are highly recommended and should always be used in production unless there is a compelling reason not to. Most of the reasons that they are not recommended for relational databases are irrelevant to MongoDB.


Stream Context Options

The PHP MongoDB extension provides Stream Context Support using the mongodb context.

A stream context must be created with stream_context_create() and passed to the MongoClient::__construct() before the actual connection to MongoDB is made. It is not possible to apply a stream context to already created streams.

Additional context options and parameters, such as ssl and notification parameters, are also supported.

The MongoDB context options provide a rich interface to log network traffic between the driver and the MongoDB servers. This interface can be used to provide query logging, profiler, debuggers, or anything that would need to inspect the underlaying commands and protocol options.

参见

  • SSL 上下文选项
  • 套接字上下文选项
  • Context 参数

Table of Contents

  • log_cmd_delete — Callback When Deleting Documents
  • log_cmd_insert — Callback When Inserting Documents
  • log_cmd_update — Callback When Updating Documents
  • log_getmore — Callback When Retrieving Next Cursor Batch
  • log_killcursor — Callback When Executing KILLCURSOR operations
  • log_reply — Callback When Reading the MongoDB reply
  • log_write_batch — Callback When Writing Batches


Callback When Deleting Documents

  • ? Stream Context Options
  • log_cmd_insert ?
  • PHP Manual
  • Stream Context Options
  • Callback When Deleting Documents

log_cmd_delete

(PECL mongo >= 1.5.0)

log_cmd_delete — Callback When Deleting Documents

说明

log_cmd_delete ( array $server , array $writeOptions , array $deleteOptions , array $protocolOptions )

A callable function, used by the log_cmd_delete context option, when deleteing a document

Note:

This is not a real function, only a prototype of how the function should be.

参数

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

writeOptions

key | value
ordered | boolean, if the operation (in case of batch operation) must be executed sequentually (ordered=true)
writeConcern | An array of writeConcern options (see below)
writeConcern array values
key | value
fsync | boolean, force flushing to disk before returning
j | boolean, force journal write before returning
wtimeout | integer, milliseconds, maximum time the primary is allowed to wait to verify replication
w | integer=server count, or string=replication-tag

deleteOptions

key | value
limit | integer, 1 or 0. If 0, delete all matching documents.
q | Array, the search criteria

protocolOptions

key | value
message_length | The total size (in bytes) of the encoded message being sent over the wire
request_id | The request identifier for this message: 42
namespace | The MongoDB namespace used for the protocol message dbname.collectionname

更新日志

版本 | 说明
PECL mongo 1.5.0 | Only available when connected to MongoDB 2.6.0+


Callback When Inserting Documents

  • ? log_cmd_delete
  • log_cmd_update ?
  • PHP Manual
  • Stream Context Options
  • Callback When Inserting Documents

log_cmd_insert

(PECL mongo >= 1.5.0)

log_cmd_insert — Callback When Inserting Documents

说明

log_cmd_insert ( array $server , array $document , array $writeOptions , array $protocolOptions )

A callable function, used by the log_cmd_insert context option, when inserting a document

Note:

This is not a real function, only a prototype of how the function should be.

参数

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

document

The document that has been prepared to be inserted

writeOptions

key | value
ordered | boolean, if the operation (in case of batch operation) must be executed sequentually (ordered=true)
writeConcern | An array of writeConcern options (see below)
writeConcern array values
key | value
fsync | boolean, force flushing to disk before returning
j | boolean, force journal write before returning
wtimeout | integer, milliseconds, maximum time the primary is allowed to wait to verify replication
w | integer=server count, or string=replication-tag

protocolOptions

key | value
message_length | The total size (in bytes) of the encoded message being sent over the wire
request_id | The request identifier for this message: 42
namespace | The MongoDB namespace used for the protocol message dbname.collectionname

更新日志

版本 | 说明
PECL mongo 1.5.0 | Only available when connected to MongoDB 2.6.0+


Callback When Updating Documents

  • ? log_cmd_insert
  • log_getmore ?
  • PHP Manual
  • Stream Context Options
  • Callback When Updating Documents

log_cmd_update

(PECL mongo >= 1.5.0)

log_cmd_update — Callback When Updating Documents

说明

log_cmd_update ( array $server , array $writeOptions , array $updateOptions , array $protocolOptions )

A callable function, used by the log_cmd_update context option, when updateing a document

Note:

This is not a real function, only a prototype of how the function should be.

参数

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

writeOptions

key | value
ordered | boolean, if the operation (in case of batch operation) must be executed sequentually (ordered=true)
writeConcern | An array of writeConcern options (see below)
writeConcern array values
key | value
fsync | boolean, force flushing to disk before returning
j | boolean, force journal write before returning
wtimeout | integer, milliseconds, maximum time the primary is allowed to wait to verify replication
w | integer=server count, or string=replication-tag

updateOptions

key | value
multi | Boolean, true if this update is allowed to update all matched criteria
upsert | Boolean, true if the document should be created if criteria does not match
q | Array, the search criteria
u | Array, the new object/modifications

protocolOptions

key | value
message_length | The total size (in bytes) of the encoded message being sent over the wire
request_id | The request identifier for this message: 42
namespace | The MongoDB namespace used for the protocol message dbname.collectionname

更新日志

版本 | 说明
PECL mongo 1.5.0 | Only available when connected to MongoDB 2.6.0+


Callback When Retrieving Next Cursor Batch

  • ? log_cmd_update
  • log_killcursor ?
  • PHP Manual
  • Stream Context Options
  • Callback When Retrieving Next Cursor Batch

log_getmore

(PECL mongo >= 1.5.0)

log_getmore — Callback When Retrieving Next Cursor Batch

说明

log_getmore ( array $server , array $info )

A callable function, used by the log_getmore context option, when executing a GET_MORE operation.

Note:

This is not a real function, only a prototype of how the function should be.

参数

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

info

key | value
request_id | integer, the driver request identifier
cursor_id | integer, the cursor identifier being used to fetch more data
batch_size | integer, maximum number of documents being requested


Callback When Executing KILLCURSOR operations

  • ? log_getmore
  • log_reply ?
  • PHP Manual
  • Stream Context Options
  • Callback When Executing KILLCURSOR operations

log_killcursor

(PECL mongo >= 1.5.0)

log_killcursor — Callback When Executing KILLCURSOR operations

说明

log_killcursor ( array $server , array $info )

A callable function, used by the log_killcursor context option, when reading a killcursor from MongoDB.

Note:

This is not a real function, only a prototype of how the function should be.

参数

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

info

key | value
cursor_id | integer, the cursor identifier to kill


Callback When Reading the MongoDB reply

  • ? log_killcursor
  • log_write_batch ?
  • PHP Manual
  • Stream Context Options
  • Callback When Reading the MongoDB reply

log_reply

(PECL mongo >= 1.5.0)

log_reply — Callback When Reading the MongoDB reply

说明

log_reply ( array $server , array $messageHeaders , array $operationHeaders )

A callable function, used by the log_reply context option, when reading a reply from MongoDB.

Note:

This is not a real function, only a prototype of how the function should be.

参数

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

messageHeaders

key | value
length | integer, bytes, message reply length
request_id | integer, the server request identifier
response_id | integer, the driver request identifier this message is a response of
opcode | integer, the opcode id

operationHeaders

key | value
flags | integer, bitmask of protocol flags
cursor_id | integer, ID of the cursor created on the server (0 if none created, or its been exhausted)
start | The starting offset of this cursor
returned | integer, how many documents are returned in this trip

参见

  • The » OP_REPLY definition in the Wire Protocol


Callback When Writing Batches

  • ? log_reply
  • Writes ?
  • PHP Manual
  • Stream Context Options
  • Callback When Writing Batches

log_write_batch

(PECL mongo >= 1.5.0)

log_write_batch — Callback When Writing Batches

说明

log_write_batch ( array $server , array $writeOptions , array $batch , array $protocolOptions )

A callable function, used by the log_write_batch context option, when executing a batch operation.

Note:

This is not a real function, only a prototype of how the function should be.

参数

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

writeOptions

key | value
ordered | boolean, if the operation (in case of batch operation) must be executed sequentually (ordered=true)
writeConcern | An array of writeConcern options (see below)
writeConcern array values
key | value
fsync | boolean, force flushing to disk before returning
j | boolean, force journal write before returning
wtimeout | integer, milliseconds, maximum time the primary is allowed to wait to verify replication
w | integer=server count, or string=replication-tag

batch

Array, the actual batch operation.

protocolOptions

key | value
message_length | The total size (in bytes) of the encoded message being sent over the wire
request_id | The request identifier for this message: 42
namespace | The MongoDB namespace used for the protocol message dbname.collectionname

更新日志

版本 | 说明
PECL mongo 1.5.0 | Only available when connected to MongoDB 2.6.0+


Writes

Updating Nested Objects

Suppose we wish to change the name of a comment's author in this document:

{
    "_id" : ObjectId("4b06c282edb87a281e09dad9"),
    "content" : "this is a blog post.",
    "comments" :
    [
        {
            "author" : "Mike",
            "comment" : "I think that blah blah blah...",
        },
        {
            "author" : "John",
            "comment" : "I disagree."
        }
    ]
}
In order to change an inner field, we use $set (so that all of the other fields are not removed!) with the index of comment to change:
<?php

$blog->update($criteria, array('$set' => array("comments.1" => array("author" => "Jim"))));

?>

The Positional Operator

The positional operator $ is useful for updating objects that are in arrays. In the example above, for instance, suppose that we did not know the index of the comment that we needed to change, merely that we needed to change "John" to "Jim". We can use $ to do so.

<?php

$blog->update(
    array('comments.author' => 'John'),
    array('$set' => array('comments.$.author' => 'Jim')));

?>


Querying

Distributing queries to secondaries

All queries (reads and writes) are only sent to the primary member of a replica set by default. This is however easily configurable by using the Read Preferences which allow you to set some generic read preferences (such as allowing secondary reads of the nearest server), and also provide ways to specifically target a server in a specific country, datacenter, or even hardware, by the use of replica set tag sets.

Read preferences can be configured at every level of the driver:

  • As a query parameter or option to MongoClient::__construct()
  • Specifically by calling MongoClient::setReadPreference()
  • At the database level with MongoDB::setReadPreference()
  • At the collection level with MongoCollection::setReadPreference()
  • At the cursor level with MongoCursor::setReadPreference() or MongoCommandCursor::setReadPreference()
Each class inherits its read preference setting from the "parent" context.

Example #1 Inheriting read preferences from the database level down to the cursor

<?php
$db->setReadPreference(MongoClient::RP_SECONDARY_PREFERRED);
$c = $db->myCollection;

$cursor = $c->find();
?>

In this example, the query will be executed against a secondary. The collection inherits MongoClient::RP_SECONDARY_PREFERRED from the database and the cursor inherits it from the collection.

How secondaries are chosen

Each instance of MongoClient chooses its own secondary using the available secondary with the lowest ping time. So, if we had a PHP client in Europe and one in Australia and we had one secondary in each of these data centers, we could do:

<?php
$options = array("replicaSet" => "setName", "readPreference" => MongoClient::RP_SECONDARY_PREFERRED);

// on the Australian client
$m = new MongoClient("mongodb://primary,australianhost.secondary,europeanhost.secondary", $options);
$cursor = $m->foo->bar->find();
$cursor->getNext();
echo "Reading from: ", $cursor->info()["server"], "\n";

// on the European client
$m = new MongoClient("mongodb://primary,australianhost.secondary,europeanhost.secondary", $options);
$cursor = $m->foo->bar->find();
$cursor->getNext();
echo "Reading from: ", $cursor->info()["server"], "\n";
?>

以上例程的输出类似于：

Reading from: australianHost
Reading from: europeanHost

Note that we have to do a query before a secondary is chosen: secondaries are chosen lazily by the driver, and for each query separately.

You can see what the driver thinks is the current status of the set members by running MongoClient::getHosts() or MongoClient::getConnections().

If no secondary is readable, the driver will send reads to the primary as we specified MongoClient::RP_SECONDARY_PREFERRED which will fallback to execute a query on a primary if no secondaries are available. A server is considered readable if its state is 2 (SECONDARY) and its health is 1. You can check this with MongoClient::getHosts() and MongoClient::getConnections().

Random notes

Writes are always sent to the primary—and by default all reads are sent to the primary too.

Querying by _id

Every object inserted is automatically assigned a unique _id field, which is often a useful field to use in queries. This works similarly to "get last insert ID" functionality, except that the _id is chosen by the client.

Suppose that we wish to find the document we just inserted. Inserting adds an _id field to the document, so we can query by that:

<?php
$person = array("name" => "joe");

$people->insert($person);

// now $joe has an _id field
$joe = $people->findOne(array("_id" => $person['_id']));
?>

Unless the user has specified otherwise, the _id field is a MongoId. The most common mistake is attempting to use a string to match a MongoId. Keep in mind that these are two different datatypes, and will not match each other in the same way that the string "array()" is not the same as an empty array. For example:

<?php
$person = array("name" => "joe");

$people->insert($person);

// convert the _id to a string
$pid = $person['_id'] . "";

// FAILS - $pid is a string, not a MongoId
$joe = $people->findOne(array("_id" => $pid));
?>

Arrays

Arrays are special in a couple ways. First, there are two types that MongoDB uses: "normal" arrays and associative arrays. Associative arrays can have any mix of key types and values. "Normal" arrays are defined as arrays with ascending numeric indexes starting at 0 and increasing by one for each element. These are, typically, just your usual PHP array.

For instance, if you want to save a list of awards in a document, you could say:

<?php

$collection->save(array("awards" => array("gold", "silver", "bronze")));

?>

Queries can reach into arrays to search for elements. Suppose that we wish to find all documents with an array element of a given value. For example, documents with a "gold" award, such as:

{ "_id" : ObjectId("4b06c282edb87a281e09dad9"), "awards" : ["gold", "silver", "bronze"]}

This can be done with a simple query, ignoring the fact that "awards" is an array:

<?php

  $cursor = $collection->find(array("awards" => "gold"));

?>

Suppose we are querying for a more complex object, if each element of the array were an object itself, such as:

{
     "_id" : ObjectId("4b06c282edb87a281e09dad9"),
     "awards" :
     [
        {
            "first place" : "gold"
        },
        {
            "second place" : "silver"
        },
        {
            "third place" :  "bronze"
        }
     ]
}

Still ignoring that this is an array, we can use dot notation to query the subobject:

<?php

$cursor = $collection->find(array("awards.first place" => "gold"));

?>

Notice that it doesn't matter that there is a space in the field name (although it may be best not to use spaces, just to make things more readable).

You can also use an array to query for a number of possible values. For instance, if we were looking for documents "gold" or "copper", we could do:

<?php

$cursor = $collection->find(array("awards" => array('$in' => array("gold", "copper"))));

?>

更新日志

版本 | 说明
1.3.0 | Introduced the Read Preferences framework to allow more fine grained control over secondary reads.
1.3.0 | Deprecated slaveOkay usage, the alternative is Read Preferences.
1.1.0 | Introduced the possiblity of routing reads to secondaries of replica set members using Mongo::setSlaveOkay()


Updates

Updates can be one of the most complicated operation available with MongoDB. They combine a query with an action, modifying documents that match the criteria. They are also extremely powerful, allowing you to change documents quickly and replace them altogether. They are done in-place (when possible) with little overhead.

Modifying vs. replacing documents

There are two types of updates you can use: modifying updates and replacing updates. Modifying updates contain $-operators and change fields in a document: they might increment counters, push new elements onto an array, or change the type of a field.

For example, a modifying update could add a new field to a document.

<?php
/** suppose documents look like:
 * {"username" : "...", "password" : "...", "email" : "..."}
 */
$coll->update(array("username" => "joe"), array('$set' => array("twitter" => "@joe4153")));

/** now the document will look like:
 * {"username" : "joe", "password" : "...", "email" : "...", "twitter" : "@joe4153"}
 */
?>

Replacing updates replace the entire matching document with a new document. They are generally not as efficient as using $-modifiers, but can be very usefully for complex operations or updates that can't be expressed in terms of $-operators.

For example, a replacing update can completely change the structure of a document.

<?php
/** suppose documents look like:
 * {"username" : "...", "password" : "...", "email" : "..."}
 */
$coll->update(array("username" => "joe"), array("userId" => 12345, "info" => array(
    "name" => "joe", "twitter" => "@joe4153", "email" => "..."), "likes" => array()));

/** now the document will look like:
 * {
 *     "userId" : 12345,
 *     "info" : {
 *         "name" : "joe",
 *         "twitter" : "@joe4153",
 *         "email" : "..."
 *     },
 *     "likes" : []
 * }
 */
?>

Updating Nested Objects

Suppose we wish to change the name of a comment's author in this document:

{
    "_id" : ObjectId("4b06c282edb87a281e09dad9"),
    "content" : "this is a blog post.",
    "comments" :
    [
        {
            "author" : "Mike",
            "comment" : "I think that blah blah blah...",
        },
        {
            "author" : "John",
            "comment" : "I disagree."
        }
    ]
}
In order to change an inner field, we use $set (so that all of the other fields are not removed!) with the index of comment to change:
<?php

$blog->update($criteria, array('$set' => array("comments.1" => array("author" => "Jim"))));

?>

The Positional Operator

The positional operator $ is useful for updating objects that are in arrays. In the example above, for instance, suppose that we did not know the index of the comment that we needed to change, merely that we needed to change "John" to "Jim". We can use $ to do so.

<?php

$blog->update(
    array("comments.author" => "John"),
    array('$set' => array('comments.$.author' => "Jim")));

?>


Security

Request Injection Attacks

If you are passing $_GET (or $_POST) parameters to your queries, make sure that they are cast to strings first. Users can insert associative arrays in GET and POST requests, which could then become unwanted $-queries.

A fairly innocuous example: suppose you are looking up a user's information with the request http://www.example.com?username=bob. Your application does the query $collection->find(array("username" => $_GET['username'])).

Someone could subvert this by getting http://www.example.com?username[$ne]=foo, which PHP will magically turn into an associative array, turning your query into $collection->find(array("username" => array('$ne' => "foo"))), which will return all users not named "foo" (all of your users, probably).

This is a fairly easy attack to defend against: make sure $_GET and $_POST parameters are the type you expect before you send them to the database (cast them to strings, in this case).

Note that this type of attack can be used with any databases interation that locates a document, including updates, upserts, find-and-modifies, and removes.

Thanks to » Phil for pointing this out.

See » the main documentation for more information about SQL-injection-like issues with MongoDB.

Script Injection Attacks

If you are using JavaScript, make sure that any variables that cross the PHP- to-JavaScript boundry are passed in the scope field of MongoCode, not interpolated into the JavaScript string. This can come up when using MongoDB::execute(), $where clauses, MapReduces, group-bys, and any other time you may pass JavaScript into the database.

Note:

MapReduce ignore the scope field of MongoCode, but there is a scope option on the command that can be used instead.

For example, suppose we have some JavaScript to greet a user in the database logs. We could do:

<?php

// don't do this!

$username = $_POST['username'];
$db->execute("print('Hello, $username!');");

?>

However, what if a malicious user passes in some JavaScript?

<?php

// don't do this!

// $username is set to "'); db.users.drop(); print('"
$db->execute("print('Hello, $username!');");

?>

Now MongoDB executes the JavaScript string "print('Hello, '); db.users.drop(); print('!');". This attack is easy to avoid: use scope to pass variables from PHP to JavaScript:

<?php

$scope = array("user" => $username);
$db->execute(new MongoCode("print('Hello, '+user+'!');", $scope));

?>

This adds a variable user to the JavaScript scope. Now if someone tries to send malicious code, MongoDB will harmlessly print Hello, '); db.dropDatabase(); print('!.

Using scope helps prevent malicious input from being executed by the database. However, you must make sure that your code does not turn around and execute the input anyway! For example, never use the JavaScript eval function on user input:

<?php

// don't do this!

// $jsShellInput is "db.users.drop();"
$scope = array("input" => $jsShellInput);
$db->execute(new MongoCode("eval(input);", $scope));

?>

Always use scope and never allow the database to execute user input as code.


故障排除

如果你有问题，这里有一些资源可以访问。

  • IRC

    MongoDB 官方的 IRC 频道是 irc.freenode.net/#mongodb 。 这是所有方式中可以最快获得帮助的地方。

  • 邮件列表

    » MongoDB's mailing list 是提问的好地方（通常回复会比较迅速）。

  • 错误追踪

    发现了BUG，希望在 MongoDB 中添加新的功能，有疑问？可以在 » PHP driver's bug tracker 中创建。

你可以让驱动把所有类型的错误记录为 E_NOTICE 级别的PHP错误。查看 MongoLog 实例。


Running the Driver's Tests

The PECL package does not come with the tests, but they are available at » Github.

.phpt Tests

.phpt tests are the standard way of testing PHP extensions. After compiling the MongoDB driver with "make" you can then issue "make test" to run the tests. These tests require MongoDB to be working, and hence, you need to configure the test suite itself.

There is more information on running the tests in the contributing guidelines on » GitHub.

Reporting Errors

Please report any failures or errors in the » bugtracker. There may be skipped tests, these are normal and can be ignored.

New tests are always welcome! Please feel free to contribute new tests of any type testing any functionality.


核心类

Table of Contents

  • MongoClient
  • MongoDB
  • MongoCollection
  • MongoCursor
  • MongoCursorInterface
  • MongoCommandCursor
Warning

This extension is deprecated. Instead, the MongoDB extension should be used.

核心类是该驱动最重要的部分。


MongoClient 类

(PECL mongo >=1.3.0)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\Driver\Manager

简介

PHP 和 MongoDB 的连接管理器。

这个类用于创建和管理连接。典型的用法：

Example #1 MongoClient 基本用法

<?php

$m = new MongoClient(); // 连接
$db = $m->foo; // 获取名称为 "foo" 的数据库

?>

关于创建连接的更多信息，参见 MongoClient::__construct() 和 connecting 的章节。

类摘要

MongoClient {
/* 常量 */
const string VERSION ;
const string DEFAULT_HOST = "localhost" ;
const int DEFAULT_PORT = 27017 ;
const string RP_PRIMARY = "primary" ;
const string RP_PRIMARY_PREFERRED = "primaryPreferred" ;
const string RP_SECONDARY = "secondary" ;
const string RP_SECONDARY_PREFERRED = "secondaryPreferred" ;
const string RP_NEAREST = "nearest" ;
/* 属性 */
public boolean $connected = false ;
public string $status = null ;
protected string $server = null ;
protected boolean $persistent = null ;
/* 方法 */
public __construct ( string $server = "mongodb://localhost:27017" , array $options = array("connect" => true) )
public close ( boolean|string $connection = ? ) : bool
public connect ( ) : bool
public dropDB ( mixed $db ) : array
public __get ( string $dbname ) : MongoDB
public static getConnections ( ) : array
public getHosts ( ) : array
public getReadPreference ( ) : array
public getWriteConcern ( ) : array
public killCursor ( string $server_hash , int|MongoInt64 $id ) : bool
public listDBs ( ) : array
public selectCollection ( string $db , string $collection ) : MongoCollection
public selectDB ( string $name ) : MongoDB
public setReadPreference ( string $read_preference , array $tags = ? ) : bool
public setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool
public __toString ( ) : string
}

预定义常量

MongoClient 常量

MongoClient::VERSION
PHP 驱动版本。有可能附加 "dev"，"+" 或 "-" 如果是在两个版本之间。
MongoClient::DEFAULT_HOST
"localhost"
如果没有指定主机，默认连接该主机。
MongoClient::DEFAULT_PORT
27017
如果没有指定端口，默认连接该端口。
MongoClient::RP_PRIMARY
"primary"
副本集活跃节点的读取选项。
MongoClient::RP_PRIMARY_PREFERRED
"primaryPreferred"
副本集活跃节点的读取选项。
MongoClient::RP_SECONDARY
"secondary"
副本集备份节点的读取选项。
MongoClient::RP_SECONDARY_PREFERRED
"secondaryPreferred"
副本集备份节点的读取选项。
MongoClient::RP_NEAREST
"nearest"
副本集最近节点的读取选项。

字段属性

connected

如果我们有一个打开的数据库连接，将会被设置为 true，否则是 false。 如果连接副本集（replica set）里一个节点并匹配当前的读取选项 ，该属性仅会是 true。 这个属性不考虑账户是否已认证。

版本 1.5.0 后该属性已经废弃（ deprecated）。

status

这个属性不会再被使用，将会被设置为 null 在驱动版本 1.1.x 及更早版本中，使用持久连接时这可能会被设置为字符串的值(比如 "recycled"， "new")。

版本 1.5.0 后该属性已经废弃（ deprecated）。

参见

  • 读取首选项
  • Write Concerns
  • 链接服务器
  • 关于 » connecting 的 MongoDB 核心文档

Table of Contents

  • MongoClient::close — 关闭连接
  • MongoClient::connect — 连接到数据库服务器
  • MongoClient::__construct — 创建一个新的数据库连接对象
  • MongoClient::dropDB — 删除一个数据库 [已废弃]
  • MongoClient::__get — 取得一个数据库
  • MongoClient::getConnections — 返回所有已打开连接的信息
  • MongoClient::getHosts — 更新所有关联主机的状态信息
  • MongoClient::getReadPreference — 获取此连接的读取首选项
  • MongoClient::getWriteConcern — Get the write concern for this connection
  • MongoClient::killCursor — Kills a specific cursor on the server
  • MongoClient::listDBs — 列出所有有效数据库
  • MongoClient::selectCollection — 获取数据库的文档集
  • MongoClient::selectDB — 获取一个数据库
  • MongoClient::setReadPreference — 为该连接设置读取选项
  • MongoClient::setWriteConcern — Set the write concern for this connection
  • MongoClient::__toString — 该连接的字符串表达方式


关闭连接

  • ? MongoClient
  • MongoClient::connect ?
  • PHP Manual
  • MongoClient
  • 关闭连接

MongoClient::close

(PECL mongo >=1.3.0)

MongoClient::close — 关闭连接

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoClient::close ( boolean|string $connection = ? ) : bool

MongoClient::close() 方法强制关闭一个数据库连接，哪怕使用的是持久连接。 在正常情况下，你绝不需要这么做。

参数

connection

如果没有指定 connection，或者是 false，将会选择关闭写作操作的连接。 如果配置为单节点，将会关闭整个连接，但是如果你连接到一个集群， close() 会仅仅关闭 primary 节点的连接。

如果 connection 是 true，连接管理器将会关闭所有由它管理的连接。 这也会包括创建对象时所引用的连接字符串之外的连接。

如果 connection 是一个字符串参数，它将仅仅关闭由该 hash 标识的连接。 Hash 是调用 MongoClient::getConnections() 所返回，能够表示一个连接。

返回值

返回连接是否成功关闭。

范例

Example #1 MongoClient::close() 例子

这个例子演示了如何选择性地仅关闭备份节点的所有连接。

<?php
// 连接到集群
$a = new MongoClient("mongodb://whisky:13000/?replicaset=seta");

$connections = $a->getConnections();

foreach ( $connections as $con )
{
    // 遍历所有连接，如果类型是 "SECONDARY" 则关闭连接
    if ( $con['connection']['connection_type_desc'] == "SECONDARY" )
    {
        echo "Closing '{$con['hash']}': ";
        $closed = $a->close( $con['hash'] );
        echo $closed ? "ok" : "failed", "\n";
    }
}
?>

以上例程会输出：

Closing 'whisky:13001;X;4948': ok

更新日志

版本 | 说明
1.3.0 | 在 1.3.0 版本中，为这个函数添加了 connection 参数。 在此之前，直邮写入连接才会被这个方法关闭。
1.2.0 | 在版本 1.2.0 之前，这个驱动默认不会使用持久连接，所有连接会在作用域结束时关闭。 由于版本 1.2.0 情况不再如此，所以调用 close 会是一个坏主意，在服务器有较高负载时可能会造成更高的压力。

参见

  • MongoClient::getConnections() - 返回所有已打开连接的信息


连接到数据库服务器

  • ? MongoClient::close
  • MongoClient::__construct ?
  • PHP Manual
  • MongoClient
  • 连接到数据库服务器

MongoClient::connect

(PECL mongo >=1.3.0)

MongoClient::connect — 连接到数据库服务器

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoClient::connect ( ) : bool

参数

此函数没有参数。

返回值

连接是否成功。

错误／异常

如果连接失败将会抛出 MongoConnectionException 的异常。


创建一个新的数据库连接对象

  • ? MongoClient::connect
  • MongoClient::dropDB ?
  • PHP Manual
  • MongoClient
  • 创建一个新的数据库连接对象

MongoClient::__construct

(PECL mongo >=1.3.0)

MongoClient::__construct — 创建一个新的数据库连接对象

说明

public MongoClient::__construct
 ( string $server = "mongodb://localhost:27017"
, array $options = array("connect" => true)
)

如果没有传入参数，它会连接到 "localhost:27017"（或者 php.ini 里指定的 mongo.default_host 和 mongo.default_port）。

server 应该是这样的形式：

mongodb://[username:password@]host1[:port1][,host2[:port2:],...]/db

连接字符串总是以 mongodb:// 开头，表示它是一个连接字符串。

如果指定了 username 和 password，构造器会在返回前尝试验证连接数据库。 用户名和密码是可选的，需要指定时必须紧随一个 @。

至少指定一个主机（端口可选，默认总是 27017），并且可以连接到想要数量的主机。 主机名由逗号分隔，构造器会成功返回，如果连接到了至少一个主机。 如果无法连接到任何主机，它将会抛出一个异常 MongoConnectionException。

如果你指定了一个用户名和密码，你可以指定一个要验证的数据库。 如果没有指定 db，将会使用 "admin"。

可选的查询字符串可以用于指定额外的选项。 同样参数也支持 options 数组。

选项的一部分指示了驱动在集群环境下对备份节点如何读取。 关于读取首选项运行的额外信息可以查找 读取首选项 文档页面。

参数

server

服务器名。

options

此连接的数组选项。当前有效的选项包括了：

  • "connect"

    构造器是否应该在返回前连接。 默认为 true。当设置为 false，驱动会在有查询必要时 自动 连接到服务器。 另外，你也可以用 MongoClient::connect() 手动运行。

    Warning

    这个选项不支持通过连接字符串来设置。

  • "db"

    要验证的数据库能在这里指定，而不是在主机列表中包含它。 能够重载主机列表中指定的数据库。

  • "password"

    能在这里指定密码，而不是在主机列表中指定。 当密码里有一个 "@" 的时候尤其有用。 此参数会覆盖主机列表中设置的密码。

  • "readPreference"

    指定读取首选项类型。 读取首选项提供了对备份数据读取的控制。

    允许的值有： MongoClient::RP_PRIMARY、
MongoClient::RP_PRIMARY_PREFERRED、
MongoClient::RP_SECONDARY、
MongoClient::RP_SECONDARY_PREFERRED 和
MongoClient::RP_NEAREST。

    更多信息参见读取首选项文档。

  • "readPreferenceTags"

    以字符串的数组指定读取选项标签。 标签能够控制 readPreference 选项来进一步控制从备份节点数据的读取。

    更多信息参见读取首选项文档。

  • "replicaSet"

    要连接的集群名称。 如果指定了，活跃节点能够自动检测到。 这意味着驱动能够最终甚至能够连接到未列出的服务器。 更多细节参见集群的例子。

  • "connectTimeoutMS"

    打开连接超时的时间。

  • "timeout"

    "connectTimeoutMS" 废弃的别名。

  • "socketTimeoutMS"

    在套接字上发送或接收超时的时间。

    Note: 这是客户端的超时时间。如果一个 insert 达到了 socketTimeoutMS， 将无法得知服务器是否确实已写入。

  • "username"

    能在这里指定用户名，而不是在主机列表中指定。 当用户名包括一个「:」时尤其有用。 它会覆盖主机列表中的设置。

  • "w"

    选项 w 指定了驱动的 Write Concern，决定了驱动在写入时阻塞的时间。 默认值是 1。

    此选项适用于单台服务器或者是集群。 一个正数值控制了在驱动继续之前，有多少个节点必须应答写入的指令。 值 1 将让单台服务器或者活跃节点（在集群里）应答写入操作。 值 3 将阻塞驱动直至写入到活跃节点和其他两个备份节点服务器（在集群里）。

    一个字符串的值用于控制考虑 write concerns 的标签集。 "majority" 是特殊用于确保写入操作被应用于大多数（大于 50%）参与的节点。

  • "wTimeout"

    此选项用于和 "w" 参数组合使用。 它控制了服务器等待多少毫秒来满足 write concern。 如果超时了，驱动会抛出 MongoCursorException 异常。

返回值

返回一个新的数据库连接对象。

错误／异常

如果给出的主机都无法连接，将会抛出 MongoConnectionException 异常。 如果提供了无效的用户名和密码将会抛出一个 MongoConnnectionException。 参见 MongoConnectionException 相关文档获取异常发生的原因。

更新日志

版本 | 说明
1.3.4

添加了 "connectTimeoutMS" 和 "socketTimeoutMS" 选项。

1.3.0

添加了 "readPreference"、 "readPreferenceTags"、"w" 和 "wTimeout" 选项。

1.2.0

添加了 "username" 和 "password" 选项。

移除了 "persist" 选项，所有的连接都是持久的。它仍旧能够使用，但是不起作用。

"persist"

是否应该是持久连接。如果设置了，连接会是持久连接。 字符形式的值将会用于连接的 ID。所以两个以 array("persist" => "foobar") 初始化的 MongoClient 实例会共享一个数据库连接，以 array("persist" => "barbaz")初始化的实例则使用不同的数据库连接。

"replicaSet" 选项现在支持一个字符串，而不是布尔值。

1.0.9 | 添加了 "replicaSet" 选项。
1.0.2

修改构造器支持选修数组。在 1.0.2 之前，构造器接受以下参数：

server

服务器名。

connect

可选的 boolean 参数指定了构造器是否应该在返回前连接到数据库。默认为 true。

persistent

连接是否应该是持久的。

paired

连接是否应该为 paired 模式。

范例

Example #1 MongoClient::__construct() 集群例子

这个例子显示了如何连接本驱动到一个集群。 它假设了有三个服务器的集群： sf1.example.com、sf2.example.com 和 ny1.example.com。 活跃节点可能是其中任意一个。

<?php

// 传递逗号分隔的服务器名称列表到构造器
// 注意我们不需要传入集群的所有成员，驱动能够获取完整的列表
$m1 = new MongoClient("mongodb://sf2.example.com,ny1.example.com", array("replicaSet" => "myReplSet"));

?>

如果当前活跃节点连接失败，驱动会计算出备用节点服务器作为新的活跃节点，并自动启用该连接。 如果没有指定 replicaSet，自动容错移转将无法正常工作。

在驱动连接的集群种子列表里，起码要有一个种子是在线的。

如果你包含的种子位于两个独立的集群，后面的行为将不可预测。

更多关于集群的信息参见» 核心文档。

Example #2 连接到一个域套接字（domain socket）

在 1.0.9+ 版本中，你可以使用一个 UNIX 域套接字来连接到一个本地的 MongoDB 实例。 这可能会比使用网络连接稍微快一点。

在版本 1.5.0，MongoDB 服务器会自动打开 /tmp/mongodb-<port>.sock 上的套接字。 你可以在连接字符串中指定位置：

<?php

// MongoDB 服务器运行在本地 20000 端口上
$m = new MongoClient("mongodb:///tmp/mongodb-20000.sock");

?>

你也可以和其他想要的连接组合：

<?php

// 尝试连接到套接字，失败时使用 localhost 连接
$m = new MongoClient("mongodb:///tmp/mongodb-27017.sock,localhost:27017");

?>

Example #3 MongoClient::__construct() 验证的例子

在尝试验证时，用户必须存在于 admin 数据库。 你可以通过终端，用 Mongo 创建一个：

> use admin
switched to db admin
> db.addUser("testUser", "testPass");
{
        "_id" : ObjectId("4b21272fd9ab21611d19095c"),
        "user" : "testUser",
        "pwd" : "03b9b27e0abf1865e2f6fcbd9845dd59"
}
>

创建一个用户后，上面的例子里用户名为 "testUser" 并且密码为 "testPass"，你可以创建一个验证后的连接：

<?php

$m = new MongoClient("mongodb://testUser:testPass@localhost");

?>

Example #4 MongoClient::__construct() 读取选项例子

<?php

// 首选 "east" 数据中心最近的服务器
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

更多信息参见本手册中读取选项一节。


删除一个数据库 [已废弃]

  • ? MongoClient::__construct
  • MongoClient::__get ?
  • PHP Manual
  • MongoClient
  • 删除一个数据库 [已废弃]

MongoClient::dropDB

(PECL mongo >=1.3.0)

MongoClient::dropDB — 删除一个数据库 [已废弃]

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::dropDatabase()

说明

public MongoClient::dropDB ( mixed $db ) : array
Warning

已废弃

请使用 MongoDB::drop() 作为替代。

参数

db

要函数的数据库。可以是一个 MongoDB对象，或者是数据库名。

返回值

返回数据库的回应。


取得一个数据库

  • ? MongoClient::dropDB
  • MongoClient::getConnections ?
  • PHP Manual
  • MongoClient
  • 取得一个数据库

MongoClient::__get

(PECL mongo >=1.3.0)

MongoClient::__get — 取得一个数据库

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::__get()

说明

public MongoClient::__get ( string $dbname ) : MongoDB

这是获取一个数据库最简洁的方法。 如果数据库名称包含任意特殊字符，需要使用 MongoClient::selectDB() 方法；但是大多数情况下这个方法就可以。

<?php

$mongo = new MongoClient();

// 以下两行是一样的
$db = $mongo->selectDB("foo");
$db = $mongo->foo;

?>

参数

dbname

数据库名

返回值

返回一个新的 db 对象。

错误／异常

如果数据库名无效，将会抛出异常。


返回所有已打开连接的信息

  • ? MongoClient::__get
  • MongoClient::getHosts ?
  • PHP Manual
  • MongoClient
  • 返回所有已打开连接的信息

MongoClient::getConnections

(PECL mongo >=1.3.0)

MongoClient::getConnections — 返回所有已打开连接的信息

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public static MongoClient::getConnections ( ) : array

返回所有已打开连接的数组，并且每个服务器的信息

参数

此函数没有参数。

返回值

打开连接的一个 array。

范例

Example #1 MongoClient::getConnections() 例子

<?php
$m = new MongoClient;
var_dump($m->getConnections());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(3) {
    ["hash"]=>
    string(26) "localhost:27017;-;X;56052"
    ["server"]=>
    array(3) {
      ["host"]=>
      string(10) "localhost"
      ["port"]=>
      int(27017)
      ["pid"]=>
      int(56052)
    }
    ["connection"]=>
    array(8) {
      ["last_ping"]=>
      int(1354076401)
      ["last_ismaster"]=>
      int(0)
      ["ping_ms"]=>
      int(0)
      ["connection_type"]=>
      int(1)
      ["connection_type_desc"]=>
      string(10) "STANDALONE"
      ["max_bson_size"]=>
      int(16777216)
      ["tag_count"]=>
      int(0)
      ["tags"]=>
      array(0) {
      }
    }
  }
}


更新所有关联主机的状态信息

  • ? MongoClient::getConnections
  • MongoClient::getReadPreference ?
  • PHP Manual
  • MongoClient
  • 更新所有关联主机的状态信息

MongoClient::getHosts

(PECL mongo >=1.3.0)

MongoClient::getHosts — 更新所有关联主机的状态信息

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\Driver\Manager::getServers()

说明

public MongoClient::getHosts ( ) : array

此方法仅在连接到副本集时有用。 它返回了集群里所有主机的状态。如果没有副本集，它只返回一个元素的数组，包含你当前连接的主机。

参见手册中查询一节关于分布式查询备份节点的信息。

参数

此函数没有参数。

返回值

返回集群中主机的信息数组。 包含了每个主机的主机名，它的健康程度（1 是很健康），它的状态（1 是活跃节点，2 是备用节点，0 是其他），ping 服务器所需的时间，以及最后一次 ping 的时间。 例如，在具有三个成员的集群中，它看上去可能是这样的：

array(3) {
  ["A:27017"]=>
  array(4) {
    ["host"]=>
    "A"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(2)
    ["ping"]=>
    int(369)
    ["lastPing"]=>
    int(1309470644)
  }
  ["B:27017"]=>
  array(4) {
    ["host"]=>
    "B"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(1)
    ["ping"]=>
    int(139)
    ["lastPing"]=>
    int(1309470644)
  }
  ["C:27017"]=>
  array(4) {
    ["host"]=>
    "C"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(2)
    ["ping"]=>
    int(1012)
    ["lastPing"]=>
    int(1309470644)
  }
}

更新日志

版本 | 说明
1.2.10 | 对非集群的支持。 返回的数组元素现在也包括了 hostname 和 port。

参见

  • MongoClient::getConnections() - 返回所有已打开连接的信息


获取此连接的读取首选项

  • ? MongoClient::getHosts
  • MongoClient::getWriteConcern ?
  • PHP Manual
  • MongoClient
  • 获取此连接的读取首选项

MongoClient::getReadPreference

(PECL mongo >=1.3.0)

MongoClient::getReadPreference — 获取此连接的读取首选项

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoClient::getReadPreference ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

更新日志

版本 | 说明
1.3.3 | 返回的值修改为兼容 MongoClient::setReadPreference()。 type 的值从数组改成字符串，删除了 type_string，并且 tagsets 现在以键值表示的标签而不是冒号分隔的字符串。

范例

Example #1 MongoClient::getReadPreference() 返回值例子

<?php

$m = new MongoClient();
$m->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($m->getReadPreference());
?>

以上例程会输出：

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

参见

  • 读取首选项的文档。
  • MongoClient::setReadPreference() - 为该连接设置读取选项


Get the write concern for this connection

  • ? MongoClient::getReadPreference
  • MongoClient::killCursor ?
  • PHP Manual
  • MongoClient
  • Get the write concern for this connection

MongoClient::getWriteConcern

(PECL mongo >=1.5.0)

MongoClient::getWriteConcern — Get the write concern for this connection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoClient::getWriteConcern ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the write concern. The array contains the values w for an integer acknowledgement level or string mode, and wtimeout denoting the maximum number of milliseconds to wait for the server to satisfy the write concern.

范例

Example #1 MongoClient::getWriteConcern() return value example

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
var_dump($mc->getWriteConcern());

$mc->setWriteConcern(1, 1000);
var_dump($mc->getWriteConcern());
?>

以上例程会输出：

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

参见

  • The write concern documentation.
  • MongoClient::setWriteConcern() - Set the write concern for this connection


Kills a specific cursor on the server

  • ? MongoClient::getWriteConcern
  • MongoClient::listDBs ?
  • PHP Manual
  • MongoClient
  • Kills a specific cursor on the server

MongoClient::killCursor

(PECL mongo >=1.5.0)

MongoClient::killCursor — Kills a specific cursor on the server

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoClient::killCursor ( string $server_hash , int|MongoInt64 $id ) : bool

In certain situations it might be needed to kill a cursor on the server. Usually cursors time out after 10 minutes of inactivity, but it is possible to create an immortal cursor with MongoCursor::immortal() that never times out. In order to be able to kill such an immortal cursor, you can call this method with the information supplied by MongoCursor::info().

参数

server_hash

The server hash that has the cursor. This can be obtained through MongoCursor::info().

id

The ID of the cursor to kill. You can either supply an int containing the 64 bit cursor ID, or an object of the MongoInt64 class. The latter is necessary on 32 bit platforms (and Windows).

返回值

Returns true if the method attempted to kill a cursor, and false if there was something wrong with the arguments (such as a wrong server_hash). The return status does not reflect where the cursor was actually killed as the server does not provide that information.

错误／异常

This method displays a warning if the supplied server_hash does not match up with an existing connection. No attempt to kill a cursor is attempted in that case either.

范例

Example #1 MongoClient::killCursor() example

This example shows how to connect, do a query, obtain the cursor information and then kill the cursor.

<?php
$m = new MongoClient();
$c = $m->testdb->collection;
$cursor = $c->find();
$result = $cursor->next();

// Now the cursor is valid, so we can get the hash and ID out:
$info = $cursor->info();

// Kill the cursor
MongoClient::killCursor( $info['server'], $info['id'] );
?>


列出所有有效数据库

  • ? MongoClient::killCursor
  • MongoClient::selectCollection ?
  • PHP Manual
  • MongoClient
  • 列出所有有效数据库

MongoClient::listDBs

(PECL mongo >=1.3.0)

MongoClient::listDBs — 列出所有有效数据库

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::listDatabases()

说明

public MongoClient::listDBs ( ) : array

参数

此函数没有参数。

返回值

返回的关联数组包括了三个字段。 第一个字段是 databases，里面包含了一个数组。每个元素对应一个数据库，给出数据库名称、尺寸以及是否为空。 另外两个字段是 totalSize（单位为字节 bytes）和 ok，如果方法成功运行，它会是 1。

范例

Example #1 MongoClient::listDBs() 例子

例子演示了如何列出数据库，并返回数据的结构。

<?php

$mongo = new MongoClient();
$dbs = $mongo->listDBs();
print_r($dbs);

?>

以上例程的输出类似于：

Array
(
    [databases] => Array
        (
            [0] => Array
                (
                    [name] => doctrine
                    [sizeOnDisk] => 218103808
                    [empty] =>
                )
        )

    [totalSize] => 218103808
    [ok] => 1
)


获取数据库的文档集

  • ? MongoClient::listDBs
  • MongoClient::selectDB ?
  • PHP Manual
  • MongoClient
  • 获取数据库的文档集

MongoClient::selectCollection

(PECL mongo >=1.3.0)

MongoClient::selectCollection — 获取数据库的文档集

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::selectCollection()

说明

public MongoClient::selectCollection ( string $db , string $collection ) : MongoCollection

参数

db

数据库名

collection

文档集名。

返回值

返回一个新的文档集对象。

错误／异常

如果数据库或文档集名称是无效的，抛出 Exception。

范例

Example #1 MongoClient::selectCollection() 例子

<?php
$m = new MongoClient();

$c1 = $m->selectCollection("foo", "bar.baz");
// 就等于
$c2 = $m->selectDB("foo")->selectCollection("bar.baz");

// $c1 和 $c2 现在表示的是同一个文档集
?>


获取一个数据库

  • ? MongoClient::selectCollection
  • MongoClient::setReadPreference ?
  • PHP Manual
  • MongoClient
  • 获取一个数据库

MongoClient::selectDB

(PECL mongo >=1.3.0)

MongoClient::selectDB — 获取一个数据库

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::selectDatabase()

说明

public MongoClient::selectDB ( string $name ) : MongoDB

参数

name

数据库名。

返回值

返回一个新的数据库对象。

错误／异常

如果数据库名无效，将会抛出 Exception。


为该连接设置读取选项

  • ? MongoClient::selectDB
  • MongoClient::setWriteConcern ?
  • PHP Manual
  • MongoClient
  • 为该连接设置读取选项

MongoClient::setReadPreference

(PECL mongo >=1.3.0)

MongoClient::setReadPreference — 为该连接设置读取选项

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoClient::setReadPreference ( string $read_preference , array $tags = ? ) : bool

参数

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

返回值

Returns true on success, or false otherwise.

错误／异常

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

范例

Example #1 MongoClient::setReadPreference() 标签集数组语法的例子

<?php

$m = new MongoClient();

// 首选最近的 "east" 数据中心的服务器，也用于报告，
// 失败时调用 "west" 数据中心的服务器
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

参见

  • 读取选修的文档。
  • MongoClient::getReadPreference() - 获取此连接的读取首选项


Set the write concern for this connection

  • ? MongoClient::setReadPreference
  • MongoClient::__toString ?
  • PHP Manual
  • MongoClient
  • Set the write concern for this connection

MongoClient::setWriteConcern

(PECL mongo >=1.5.0)

MongoClient::setWriteConcern — Set the write concern for this connection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoClient::setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool

参数

w

The write concern. This may be an integer denoting the number of servers required to acknowledge the write, or a string mode (e.g. "majority").

wtimeout

The maximum number of milliseconds to wait for the server to satisfy the write concern.

返回值

Returns true on success, or false otherwise.

错误／异常

Emits E_WARNING if the w parameter is not an integer or string value.

范例

Example #1 MongoClient::setWriteConcern() example

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');

// Require that the majority of servers in the replica set acknowledge writes
// within three seconds.
$mc->setWriteConcern('majority', 3000);
?>

参见

  • The write concern documentation.
  • MongoClient::getWriteConcern() - Get the write concern for this connection


该连接的字符串表达方式

  • ? MongoClient::setWriteConcern
  • MongoDB ?
  • PHP Manual
  • MongoClient
  • 该连接的字符串表达方式

MongoClient::__toString

(PECL mongo >=1.3.0)

MongoClient::__toString — 该连接的字符串表达方式

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoClient::__toString ( ) : string

参数

此函数没有参数。

返回值

返回此连接的主机名和端口号。


MongoDB 类

(PECL mongo >=0.9.0)

简介

该类的实例用于和数据库进行交互。要获取一个数据库：

Example #1 选择一个数据库

<?php

$m = new MongoClient(); // 连接
$db = $m->selectDB("example");

?>
数据库名可以用 ASCII 范围内的几乎任何字符。 但是，它们不能包括 " "、"."，或者是空字符串。 名称 "system" 也是被保留的。

个别特殊但有效的数据库名："null"、"[x,y]"、"3"、"\""、 "/"。

不像集合名，数据库名是可以包含 "$" 的。

类摘要

MongoDB {
/* 常量 */
const int PROFILING_OFF = 0 ;
const int PROFILING_SLOW = 1 ;
const int PROFILING_ON = 2 ;
/* Fields */
public integer $w = 1 ;
public integer $wtimeout = 10000 ;
/* 方法 */
public authenticate ( string $username , string $password ) : array
public command ( array $command , array $options = array() ) : array
public __construct ( MongoClient $conn , string $name )
public createCollection ( string $name , array $options = ? ) : MongoCollection
public createDBRef ( string $collection , mixed $document_or_id ) : array
public drop ( ) : array
public dropCollection ( mixed $coll ) : array
public execute ( mixed $code , array $args = array() ) : array
public forceError ( ) : bool
public __get ( string $name ) : MongoCollection
public getCollectionInfo ( array $options = array() ) : array
public getCollectionNames ( array $options = array() ) : array
public getDBRef ( array $ref ) : array
public getGridFS ( string $prefix = "fs" ) : MongoGridFS
public getProfilingLevel ( ) : int
public getReadPreference ( ) : array
public getSlaveOkay ( ) : bool
public getWriteConcern ( ) : array
public lastError ( ) : array
public listCollections ( array $options = array() ) : array
public prevError ( ) : array
public repair ( bool $preserve_cloned_files = false , bool $backup_original_files = false ) : array
public resetError ( ) : array
public selectCollection ( string $name ) : MongoCollection
public setProfilingLevel ( int $level ) : int
public setReadPreference ( string $read_preference , array $tags = ? ) : bool
public setSlaveOkay ( bool $ok = true ) : bool
public setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool
public __toString ( ) : string
}

预定义常量

MongoDB 日志级别

MongoDB::PROFILING_OFF
0
关闭了分析器。
MongoDB::PROFILING_SLOW
1
为慢操作开启了分析器（>100 ms）。
MongoDB::PROFILING_ON
2
为所有操作开启了分析器。

字段

w
1

在返回成功之前，复制修改到此数量的服务器。 MongoCollection 实例的设置从这里继承。 w 仅仅在 MongoDB 服务器版本 1.5.1+ 以及本驱动 1.0.8+ 有效。

w 用于你需要调整确认级别时 （MongoCollection::insert()、 MongoCollection::update()、 MongoCollection::remove()、 MongoCollection::save() 和 MongoCollection::ensureIndex() 都支持这个选项）。 默认值（1）情况下，只要数据库有操作就会确认。 如果在复制到从服务器前服务器宕机了，它将可能永久丢失本次操作。 所以，你可以为 w 指定一个比一更高的数字， 在返回成功之前确保至少一个从服务器完成了操作。

例如，如果 w 是 2，主服务器和一个从服务必须记录了本次操作， 否则驱动会抛出 MongoCursorException。 它尝试写入总计 w 个从服务器 + 主服务器，但是如果其中一个从服务器宕机了， 操作也会失败，并会抛出异常，所以通常 w=2 是最安全的（主服务器和一个从服务器）。

wtimeout
10000

等待 MongoDB::$w 复制生效的毫秒数。 MongoCollection 实例的设置从这里继承。 w 仅仅在 MongoDB 服务器版本 1.5.1+ 并且驱动版本 1.0.8+ 有效。

除非设置了 wtimeout，服务器会永久等待复制到 w 个服务器。 这个驱动默认会等待 10 秒，你可以修改这个值来改变它的行为。

参见

MongoDB 关于 » databases 的核心文档。

Table of Contents

  • MongoDB::authenticate — 登录到数据库
  • MongoDB::command — 执行一条 Mongo 指令
  • MongoDB::__construct — 选择一个数据库
  • MongoDB::createCollection — 创建一个集合
  • MongoDB::createDBRef — 创建数据库引用
  • MongoDB::drop — 删除数据库
  • MongoDB::dropCollection — Drops a collection [deprecated]
  • MongoDB::execute — 在数据库服务器上运行JavaScript
  • MongoDB::forceError — Creates a database error
  • MongoDB::__get — Gets a collection
  • MongoDB::getCollectionInfo — Returns information about collections in this database
  • MongoDB::getCollectionNames — Gets an array of names for all collections in this database
  • MongoDB::getDBRef — Fetches the document pointed to by a database reference
  • MongoDB::getGridFS — Fetches toolkit for dealing with files stored in this database
  • MongoDB::getProfilingLevel — Gets this database's profiling level
  • MongoDB::getReadPreference — Get the read preference for this database
  • MongoDB::getSlaveOkay — Get slaveOkay setting for this database
  • MongoDB::getWriteConcern — Get the write concern for this database
  • MongoDB::lastError — Check if there was an error on the most recent db operation performed
  • MongoDB::listCollections — Gets an array of MongoCollection objects for all collections in this database
  • MongoDB::prevError — Checks for the last error thrown during a database operation
  • MongoDB::repair — Repairs and compacts this database
  • MongoDB::resetError — Clears any flagged errors on the database
  • MongoDB::selectCollection — Gets a collection
  • MongoDB::setProfilingLevel — Sets this database's profiling level
  • MongoDB::setReadPreference — Set the read preference for this database
  • MongoDB::setSlaveOkay — Change slaveOkay setting for this database
  • MongoDB::setWriteConcern — Set the write concern for this database
  • MongoDB::__toString — The name of this database


登录到数据库

  • ? MongoDB
  • MongoDB::command ?
  • PHP Manual
  • MongoDB
  • 登录到数据库

MongoDB::authenticate

(PECL mongo >=1.0.1)

MongoDB::authenticate — 登录到数据库

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

需要把认证信息放在连接字符串里作为代替。

说明

public MongoDB::authenticate ( string $username , string $password ) : array

此方法能够认证它的连接。 如果数据库服务器开启了认证（默认没有开启），在做任何操作之前你需要登录。

通常情况下，你应该使用 MongoClient::__construct() 内置的参数而不是此方法。 如果你对一个连接验证了，然后在会话期间连接掉了然后重连，你会被重新验证。 如果你用这个方法手动验证，然后连接掉了，你必须在重新连接时手动调用这个方法。

该方法等同于运行：

<?php

$salted = "${username}:mongo:${password}";
$hash = md5($salted);

$nonce = $db->command(array("getnonce" => 1));

$saltedHash = md5($nonce["nonce"]."${username}${hash}");

$result = $db->command(array("authenticate" => 1,
    "user" => $username,
    "nonce" => $nonce["nonce"],
    "key" => $saltedHash
));

?>

当一个连接验证后，它仅能够通过 "logout" 数据库命令来登出：

<?php

$db->command(array("logout" => 1));

?>

参数

username

用户名。

password

密码（明文格式）。

返回值

返回数据库的响应，如果登录成功，它会返回

<?php
array("ok" => 1);
?>
如果出现了什么错误，它会返回
<?php
array("ok" => 0, "errmsg" => "auth fails");
?>
（"auth fails" 可能是另外的信息，取决于数据库版本和发生了什么错误）。

参见

MongoDB 关于 » authenticate 的核心文档。

更新日志

版本 | 说明
1.2.11 | 使用时产生 E_DEPRECATED。 请将验证细节传入到构造器。


执行一条 Mongo 指令

  • ? MongoDB::authenticate
  • MongoDB::__construct ?
  • PHP Manual
  • MongoDB
  • 执行一条 Mongo 指令

MongoDB::command

(PECL mongo >=0.9.2)

MongoDB::command — 执行一条 Mongo 指令

说明

public MongoDB::command ( array $command , array $options = array() ) : array

几乎所有不属于CRUD操作的事情都可以通过一条"数据库指令"完成。需要知道数据库的版本？有一条指令可以实现。需要进行一次聚合？有一条指令可以实现。想要提高日志级别？有一条指令可以实现。我想你已经领会到了。

该方法等同于：

<?php

public function command($data) {
    return $this->selectCollection('$cmd')->findOne($data);
}

?>

参数

command

要发送的指令

options

该参数是一个具有以下形式的关联数组： array("optionname" => <boolean>, ...)，现在支持的选项有：

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

更新日志

版本 | 说明
1.2.0 | 添加 options 参数，和一个选项:"timeout"。

返回值

返回数据库响应。每个响应都不会超过一个文档的大小，也就是不会超过16MB。 结果文档的结构与执行的指令有关,但大部分结果都有 ok 字段来表示成功还是失败。以及 results 字段包含一个结果文档数组。

范例

Example #1 MongoDB::command() "distinct"实例

查找一个键的所有不重复值

<?php

$people = $db->people;

$people->insert(array("name" => "Joe", "age" => 4));
$people->insert(array("name" => "Sally", "age" => 22));
$people->insert(array("name" => "Dave", "age" => 22));
$people->insert(array("name" => "Molly", "age" => 87));

$ages = $db->command(array("distinct" => "people", "key" => "age"));

foreach ($ages['values'] as $age) {
    echo "$age\n";
}

?>

以上例程的输出类似于：

4
22
87

Example #2 MongoDB::command() "distinct"实例

查找一个键的所有不重复值，并且这些值大于等于18

<?php

$people = $db->people;

$people->insert(array("name" => "Joe", "age" => 4));
$people->insert(array("name" => "Sally", "age" => 22));
$people->insert(array("name" => "Dave", "age" => 22));
$people->insert(array("name" => "Molly", "age" => 87));

$ages = $db->command(
    array(
        "distinct" => "people",
        "key" => "age",
        "query" => array("age" => array('$gte' => 18))
    )
);

foreach ($ages['values'] as $age) {
    echo "$age\n";
}

?>

以上例程的输出类似于：

22
87

Example #3 MongoDB::command() MapReduce实例

获取所有有type=sale这样的"event"的用户，以及他们分别有几个这样的"event"（注:此处的event是一个集合的名字）

<?php

// sample event document
$events->insert(array("user_id" => $id,
    "type" => $type,
    "time" => new MongoDate(),
    "desc" => $description));

// construct map and reduce functions
$map = new MongoCode("function() { emit(this.user_id,1); }");
$reduce = new MongoCode("function(k, vals) { ".
    "var sum = 0;".
    "for (var i in vals) {".
        "sum += vals[i];".
    "}".
    "return sum; }");

$sales = $db->command(array(
    "mapreduce" => "events",
    "map" => $map,
    "reduce" => $reduce,
    "query" => array("type" => "sale"),
    "out" => array("merge" => "eventCounts")));

$users = $db->selectCollection($sales['result'])->find();

foreach ($users as $user) {
    echo "{$user['_id']} had {$user['value']} sale(s).\n";
}

?>

以上例程的输出类似于：

User 47cc67093475061e3d9536d2 had 3 sale(s).
User 49902cde5162504500b45c2c had 14 sale(s).
User 4af467e4fd543cce7b0ea8e2 had 1 sale(s).

Note: 使用 MongoCode

这个例子使用了 MongoCode，它还可以接受一个作用域参数。然而，现在 MongoDB 还不支持在 MapReduce 中使用它， 如果你需要在MapReduce函数里用一个客户端参数，那么你可以在使用MapReduce的时候用"optional scope"字段把它们添加到全局作用域中，参考 » MapReduce文档 来获得更多信息。

Note: out 参数

1.8.0以前，out 参数是可选的，如果你不使用它，MapReduce的结果将被写入一个临时集合里，这个临时集合会在连接关闭后删除。 1.8.0以后，out 参数是必须的，参考 » MapReduce documentation 来获得更多信息。

Example #4 MongoDB::command() "textSearch"实例

在MongoDB 2.4以上版本中使用全文检索功能（之前的版本不支持全文检索）。

<?php
$m = new MongoClient();
$d = $m->demo;
$c = $d->planets;

$c->insert(array("name" => "Mercury", "desc" => "Mercury is the smallest and closest to the Sun"));
$c->insert(array("name" => "Venus", "desc" => "Venus is the second planet from the Sun, orbiting it every 224.7 Earth days."));
$c->insert(array("name" => "Earth", "desc" => "Earth is the the densest of the eight planets in the Solar System."));
$c->insert(array("name" => "Mars", "desc" => "Mars is named after the Roman god of war."));

$c->ensureIndex(array('desc' => 'text'));

$r = $d->command(array("text" => "planets", 'search' => "sun" ));
print_r($r);
?>

以上例程的输出类似于：

Array
(
[queryDebugString] => sun||||||
[language] => english
[results] => Array
(
[0] => Array
(
[score] => 0.625
[obj] => Array
(
[_id] => MongoId Object
(
[$id] => 517549d944670a4a5cb3059a
)

[name] => Mercury
[desc] => Mercury is the smallest and closest to the Sun
)

)

[1] => Array
(
[score] => 0.55
[obj] => Array
(
[_id] => MongoId Object
(
[$id] => 517549d944670a4a5cb3059b
)

[name] => Venus
[desc] => Venus is the second planet from the Sun, orbiting it every 224.7 Earth days.
)

)

)

[stats] => Array
(
[nscanned] => 2
[nscannedObjects] => 0
[n] => 2
[nfound] => 2
[timeMicros] => 95
)

[ok] => 1
)

Example #5 MongoDB::command() "geoNear"实例

这个实例说明了如何使用 geoNear 指令。

<?php
$m = new MongoClient();
$d = $m->demo;
$c = $d->poiConcat;

$r = $d->command(array(
    'geoNear' => "poiConcat",      // 在 poiConcat 集合中
    'near' => array(-0.08, 51.48), // 搜索 51.48°N, 0.08°E 附近
    'spherical' => true,           // 启用特殊搜索
    'num' => 5,                    // 最多返回5个文档
));
print_r($r);
?>

参见

  • MongoCollection::aggregate() - Perform an aggregation using the aggregation framework
  • MongoCollection::findAndModify() - Update a document and return it
  • MongoCollection::group() - Performs an operation similar to SQL's GROUP BY command

MongoDB 核心文档的 » 数据库指令 ，以及这些特定指令的文档 » findAndModify、 » getLastError、 » repairDatabase （还有很多其他指令，这只是一些例子）


选择一个数据库

  • ? MongoDB::command
  • MongoDB::createCollection ?
  • PHP Manual
  • MongoDB
  • 选择一个数据库

MongoDB::__construct

(PECL mongo >=0.9.0)

MongoDB::__construct — 选择一个数据库

说明

public MongoDB::__construct ( MongoClient $conn , string $name )

这个方法通常不直接调用。推荐的用法是通过 MongoClient::__get() 或 MongoClient::selectDB() 方法获得对象实例。

如果你确实需要直接调用，可以通过以下方式：

<?php

$m = new MongoClient();
$db = new MongoDB($m, 'mydbname');

?>

但这并不好。下面的方式更加美观：

<?php

$m = new MongoClient();
$db = $m->mydbname;

// 如果数据库名字有保留的字符：

$db = $m->selectDB('my,db:name');

?>

参数

MongoClient conn

数据库链接

name

数据库名

返回值

返回数据库对象。

错误／异常

如果数据库名称无效。抛出一个默认类型的异常


创建一个集合

  • ? MongoDB::__construct
  • MongoDB::createDBRef ?
  • PHP Manual
  • MongoDB
  • 创建一个集合

MongoDB::createCollection

(PECL mongo >=0.9.0)

MongoDB::createCollection — 创建一个集合

说明

public MongoDB::createCollection ( string $name , array $options = ? ) : MongoCollection

这个方法用于创建一个"有限集合"之类需要特殊参数的集合。它相当于执行

<?php

$collection = $db->command(array(
    "create" => $name,
    "capped" => $options["capped"],
    "size" => $options["size"],
    "max" => $options["max"],
    "autoIndexId" => $options["autoIndexId"],
));

?>
参考 MongoDB::command() 了解更多关于数据库指令的信息

参数

name

集合的名字

options

一个数组，包含集合的选项，具有以下形式： array("optionname" => "optionvalue", ...) 。支持的选项跟MongoDB服务器的版本有关。目前支持的选项有：

capped

这个集合是否是固定大小的。

size

如果是固定大小的，指定它的大小（字节）。

max

如果是固定大小的，指定集合中最多存储多少个文档。

autoIndexId

如果 capped 是 true 你可以显式定义为 false 来禁用 自增_id 特性。MongoDB 2.2以前， autoIndexId 的默认值是false。

返回值

返回新建的集合对象。

范例

Example #1 MongoDB::createCollection() 固定大小集合 实例

固定大小（capped）集合是一种磁盘容量或者文档数量固定的特殊集合。当集合"满了"的时候，最老的文档就会被新文档代替。固定大小集合在类似日志记录的应用中非常有用，比如你需要保留一定量的日志，不用担心它们占用过多的空间。

这个例子建立了一个非常小的日志集合，保存10条日志。

<?php

$log = $db->createCollection(
    "logger",
    array(
        'capped' => true,
        'size' => 10*1024,
        'max' => 10
    )
);

for ($i = 0; $i < 100; $i++) {
    $log->insert(array("level" => WARN, "msg" => "sample log message #$i", "ts" => new MongoDate()));
}

$msgs = $log->find();

foreach ($msgs as $msg) {
    echo $msg['msg']."\n";
}

?>

以上例程的输出类似于：

sample log message #90
sample log message #91
sample log message #92
sample log message #93
sample log message #94
sample log message #95
sample log message #96
sample log message #97
sample log message #98
sample log message #99

更新日志

版本 | 说明
1.4.0 | 1.4.0以前的版本里，所有选项都是这个方法的参数。之前版本这个方法的签名是这样的： public MongoDB::createCollection ( string $name , bool $capped = false , int $size = 0 , int $max = 0 ) : MongoCollection 参数的意义与现在版本的 options 参数相同。


创建数据库引用

  • ? MongoDB::createCollection
  • MongoDB::drop ?
  • PHP Manual
  • MongoDB
  • 创建数据库引用

MongoDB::createDBRef

(PECL mongo >=0.9.0)

MongoDB::createDBRef — 创建数据库引用

说明

public MongoDB::createDBRef ( string $collection , mixed $document_or_id ) : array

这个方法是一个创建数据库引用的扩展接口（参考MongoDBRef）

参数

collection

数据库引用指向的集合

document_or_id

如果是一个数组或对象，它的 _id 字段将被用做引用ID，如果是一个 MongoId 对象或简单变量，它本身将作为引用ID。

返回值

返回一个数据库引用数组。

如果一个没有 _id 字段的数组作为 document_or_id 参数，null会被返回。

范例

Example #1 MongoDB::createDBRef()实例

演示如何从程序中创建文档的数据库引用。

<?php

$articles = $db->articles;

$article = array(
 'title' => 'Test article',
 'description' => 'Test article description'
);

$articles->insert($article);
$ref = $db->createDBRef('articles', $article);

print_r($article);
print_r($ref);
?>

以上例程的输出类似于：

     Array
     (
         [title] => Test article
         [description] => Test article description
         [_id] => MongoId Object
             (
             )

     )
     Array
     (
         [$ref] => articles
         [$id] => MongoId Object
             (
             )

     )

现在$ref可以被保存到另一个文档中，并在之后通过 MongoDB::getDBRef()或MongoCollection::getDBRef() 方法取回。

Example #2 MongoDB::createDBRef()实例

演示如何在程序中值通过一个id创建数据库引用。

<?php

$id = new MongoId('47cc67093475061e3d9536d2');
$ref = $db->createDBRef('articles', $id);
?>


删除数据库

  • ? MongoDB::createDBRef
  • MongoDB::dropCollection ?
  • PHP Manual
  • MongoDB
  • 删除数据库

MongoDB::drop

(PECL mongo >=0.9.0)

MongoDB::drop — 删除数据库

说明

public MongoDB::drop ( ) : array

这个方法删除 (drop) 当前使用的整个数据库。

这相当于执行：

<?php

public function drop() {
    $this->command(array("dropDatabase" => 1));
}

?>

参数

此函数没有参数。

返回值

返回数据库响应

范例

Example #1 MongoDB::drop() 例子

这个实例演示如何删除一个数据库，以及通常的响应。

<?php

$db = $mongo->foo;
$response = $db->drop();
print_r($response);

?>

以上例程的输出类似于：

Array
(
    [dropped] => foo.$cmd
    [ok] => 1
)


Drops a collection [deprecated]

  • ? MongoDB::drop
  • MongoDB::execute ?
  • PHP Manual
  • MongoDB
  • Drops a collection [deprecated]

MongoDB::dropCollection

(PECL mongo >=0.9.0)

MongoDB::dropCollection — Drops a collection [deprecated]

说明

public MongoDB::dropCollection ( mixed $coll ) : array
Warning

Deprecated

Use MongoCollection::drop() instead.

This function leaks memory in version 1.0.7 and earlier!

参数

coll

MongoCollection or name of collection to drop.

返回值

Returns the database response.


在数据库服务器上运行JavaScript

  • ? MongoDB::dropCollection
  • MongoDB::forceError ?
  • PHP Manual
  • MongoDB
  • 在数据库服务器上运行JavaScript

MongoDB::execute

(PECL mongo >=0.9.3)

MongoDB::execute — 在数据库服务器上运行JavaScript

说明

public MongoDB::execute ( mixed $code , array $args = array() ) : array

MongoDB服务器运行着一个JavaScript引擎。这个方法允许在服务器上执行任意JavaScript代码。如果你想要利用较少资源处理大量集合，或者在服务器上处理一些结果集以减少网络传输，那么这个方法会有用。

在服务器运行JavaScript代码会创建一个写锁定，这意味着它锁定了其他操作的执行。在运行一段耗时较长的代码之前，请考虑到这一点。

这是一个数据库指令的包装，它简单的说相当于：

<?php

public function execute($code, $args) {
    return $this->command(array('$eval' => $code, 'args' => $args));
}

?>

如果所执行的代码只有一个语句，且只有一行，MongoDB隐含一个return语句。这允许一些直观的行为，比如下面的例子返回"foo"：

<?php

$db->execute('"foo";');

?>

但是下面这两个例子返回null:

<?php

$db->execute('"bar"; "foo";'); // 多个语句

$db->execute('db.foo.count(
);'); // 多行

?>

为了防止意外的行为，最好不要依赖MongoDB决定你的返回值。而是明确的提供一个return语句。上面的例子中，可以把代码改为：

<?php

$db->execute('"bar"; return "foo";');

$db->execute('return db.foo.count(
);');

?>

这样第一个语句会返回"foo"，第二个语句会返回"foo"集合的长度。

参数

code

MongoCode或要执行的字符串

args

给code的参数。

返回值

返回执行结果

范例

Example #1 简单的 MongoDB::execute() 实例

<?php

$response = $db->execute("function() { return 'Hello, world!'; }");
echo $response['retval'];

?>

以上例程的输出类似于：

Hello, world!

Example #2 带参数的 MongoDB::execute() 实例

可选的参数将被传递给JavaScrip函数

<?php

$response = $db->execute("function(greeting, name) { return greeting+', '+name+'!'; }", array("Good bye", "Joe"));
echo $response['retval'];

?>

以上例程的输出类似于：

Good bye, Joe!

Example #3 作用域实例

如果使用 MongoCode 对象代替字符串作为第一个参数。可以传递一个作用域到将要执行的JavaScript中。

<?php

$func =
    "function(greeting, name) { ".
        "return greeting+', '+name+', says '+greeter;".
    "}";
$scope = array("greeter" => "Fred");

$code = new MongoCode($func, $scope);

$response = $db->execute($code, array("Goodbye", "Joe"));
echo $response['retval'];

?>

以上例程的输出类似于：

Goodbye, Joe, says Fred


Creates a database error

  • ? MongoDB::execute
  • MongoDB::__get ?
  • PHP Manual
  • MongoDB
  • Creates a database error

MongoDB::forceError

(PECL mongo >=0.9.5)

MongoDB::forceError — Creates a database error

说明

public MongoDB::forceError ( ) : bool

This method is not very useful for normal MongoDB use. It forces a database error to occur. This means that MongoDB::lastError() will return a generic database error after running this command.

This command is identical to running:

<?php

public function forceError() {
    return $this->command(array('forceerror' => 1));
}

?>

参数

此函数没有参数。

返回值

Returns the database response.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.


Gets a collection

  • ? MongoDB::forceError
  • MongoDB::getCollectionInfo ?
  • PHP Manual
  • MongoDB
  • Gets a collection

MongoDB::__get

(PECL mongo >=1.0.2)

MongoDB::__get — Gets a collection

说明

public MongoDB::__get ( string $name ) : MongoCollection

This is the easiest way of getting a collection from a database object. If a collection name contains strange characters, you may have to use MongoDB::selectCollection() instead.

<?php

$mongo = new MongoClient();

// the following two lines are equivalent
$collection = $mongo->selectDB("foo")->selectCollection("bar");
$collection = $mongo->foo->bar;

?>

参数

name

The name of the collection.

返回值

Returns the collection.


Returns information about collections in this database

  • ? MongoDB::__get
  • MongoDB::getCollectionNames ?
  • PHP Manual
  • MongoDB
  • Returns information about collections in this database

MongoDB::getCollectionInfo

(PECL mongo >=1.6.0)

MongoDB::getCollectionInfo — Returns information about collections in this database

说明

public MongoDB::getCollectionInfo ( array $options = array() ) : array

Gets a list of all collections in the database and returns them as an array of documents, which contain their names and options.

Note: This method will use the » listCollections database command when communicating with MongoDB 2.8+. For previous database versions, the method will query the special system.namespaces collection.

参数

options

An array of options for listing the collections. Currently available options include:

  • "filter"

    Optional query criteria. If provided, this criteria will be used to filter the collections included in the result.

    Relevant fields that may be queried include "name" (collection name as a string, without the database name prefix) and "options" (object containing options used to create the collection)..

    Note: MongoDB 2.6 and earlier versions require the "name" criteria, if specified, to be a string value (i.e. equality match). This is because the driver must prefix the value with the database name in order to query the system.namespaces collection. Later versions of MongoDB do not have this limitation, as the driver will use the listCollections command.

  • "includeSystemCollections"

    Boolean, defaults to false. Determines whether system collections should be included in the result.

The following option may be used with MongoDB 2.8+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

返回值

This function returns an array where each element is an array describing a collection. Elements will contain a name key denoting the name of the collection, and optionally contain an options key denoting an array of objects used to create the collection. For example, capped collections will include capped and size options.

错误／异常

For MongoDB 2.6 and earlier, MongoException will be thrown if a non-string value was specified for the "filter" option's "name" criteria.

范例

Example #1 MongoDB::getCollectionInfo() example

<?php
$m = new MongoClient();
$db = $m->selectDB("demo");
var_dump($db->getCollectionInfo());
?>

以上例程的输出类似于：

array(2) {
  [0]=>
  array(2) {
    ["name"]=>
    string(4) "logs"
    ["options"]=>
    array(2) {
      ["capped"]=>
      bool(true)
      ["size"]=>
      int(10240)
    }
  }
  [1]=>
  array(2) {
    ["name"]=>
    string(5) "users"
    ["options"]=>
    array(1) {
      ["flags"]=>
      int(1)
    }
  }
}

参见

  • MongoDB::getCollectionNames() - Gets an array of names for all collections in this database
  • MongoDB::listCollections() - Gets an array of MongoCollection objects for all collections in this database


Gets an array of names for all collections in this database

  • ? MongoDB::getCollectionInfo
  • MongoDB::getDBRef ?
  • PHP Manual
  • MongoDB
  • Gets an array of names for all collections in this database

MongoDB::getCollectionNames

(PECL mongo >=1.3.0)

MongoDB::getCollectionNames — Gets an array of names for all collections in this database

说明

public MongoDB::getCollectionNames ( array $options = array() ) : array

Gets a list of all collections in the database and returns their names as an array of strings.

Note: This method will use the » listCollections database command when communicating with MongoDB 2.8+. For previous database versions, the method will query the special system.namespaces collection.

参数

options

An array of options for listing the collections. Currently available options include:

  • "filter"

    Optional query criteria. If provided, this criteria will be used to filter the collections included in the result.

    Relevant fields that may be queried include "name" (collection name as a string, without the database name prefix) and "options" (object containing options used to create the collection)..

    Note: MongoDB 2.6 and earlier versions require the "name" criteria, if specified, to be a string value (i.e. equality match). This is because the driver must prefix the value with the database name in order to query the system.namespaces collection. Later versions of MongoDB do not have this limitation, as the driver will use the listCollections command.

  • "includeSystemCollections"

    Boolean, defaults to false. Determines whether system collections should be included in the result.

The following option may be used with MongoDB 2.8+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

返回值

Returns the collection names as an array of strings.

错误／异常

For MongoDB 2.6 and earlier, MongoException will be thrown if a non-string value was specified for the "filter" option's "name" criteria.

更新日志

版本 | 说明
PECL mongo 1.6.0 | Changed first parameter to be an array of options. Pre-1.6.0, the first parameter was a boolean indicating the "includeSystemCollections" option.

范例

Example #1 MongoDB::getCollectionNames() example

<?php
$m = new MongoClient();
$db = $m->selectDB("demo");
$collections = $db->getCollectionNames();

foreach ($collections as $collectionName) {
    echo "Found collection: ", $collectionName, "\n";
}
?>

以上例程的输出类似于：

...
Found collection: img
Found collection: beer
Found collection: collation
...

参见

  • MongoDB::listCollections() - Gets an array of MongoCollection objects for all collections in this database
  • MongoDB::getCollectionInfo() - Returns information about collections in this database


Fetches the document pointed to by a database reference

  • ? MongoDB::getCollectionNames
  • MongoDB::getGridFS ?
  • PHP Manual
  • MongoDB
  • Fetches the document pointed to by a database reference

MongoDB::getDBRef

(PECL mongo >=0.9.0)

MongoDB::getDBRef — Fetches the document pointed to by a database reference

说明

public MongoDB::getDBRef ( array $ref ) : array

参数

ref

A database reference.

返回值

Returns the document pointed to by the reference.

范例

Example #1 MongoDB::getDBRef() example

Example demonstrating how to get a database reference and what the expected input is.

<?php

 $ref = array(
   '$ref' => 'profiles',
   '$id' => new MongoId('47cc67093475061e3d9536d2')
 );

 $profile = $db->getDBRef($ref);
 ?>

See MongoDB::createDBRef() for more information about how to programatically create DB references.


Fetches toolkit for dealing with files stored in this database

  • ? MongoDB::getDBRef
  • MongoDB::getProfilingLevel ?
  • PHP Manual
  • MongoDB
  • Fetches toolkit for dealing with files stored in this database

MongoDB::getGridFS

(PECL mongo >=0.9.0)

MongoDB::getGridFS — Fetches toolkit for dealing with files stored in this database

说明

public MongoDB::getGridFS ( string $prefix = "fs" ) : MongoGridFS

参数

prefix

The prefix for the files and chunks collections.

返回值

Returns a new gridfs object for this database.

范例

Example #1 MongoDB::getGridFS() example

This example demonstrates how get a MongoGridFS instance.

<?php

$db = $mongo->my_db;

$prefix = 'files';
$collection = $db->getGridFS($prefix);

?>

Read more about the MongoGridFS to learn how to store files with MongoDB.


Gets this database's profiling level

  • ? MongoDB::getGridFS
  • MongoDB::getReadPreference ?
  • PHP Manual
  • MongoDB
  • Gets this database's profiling level

MongoDB::getProfilingLevel

(PECL mongo >=0.9.0)

MongoDB::getProfilingLevel — Gets this database's profiling level

说明

public MongoDB::getProfilingLevel ( ) : int

This returns the current database profiling level.

The database profiler tracks query execution times. If you turn it on (say, using MongoDB::setProfilingLevel() or the shell), you can see how many queries took longer than a given number of milliseconds or the timing for all queries.

Note that profiling slows down queries, so it is better to use in development or testing than in a time-sensitive application.

This function is equivalent to running:

<?php

public function getProfilingLevel() {
    return $this->command(array('profile' => -1));
}

?>

参数

此函数没有参数。

返回值

Returns the profiling level.

参见

  • MongoDB core docs on » profiling
  • MongoDB::setProfilingLevel() - Sets this database's profiling level


Get the read preference for this database

  • ? MongoDB::getProfilingLevel
  • MongoDB::getSlaveOkay ?
  • PHP Manual
  • MongoDB
  • Get the read preference for this database

MongoDB::getReadPreference

(PECL mongo >=1.3.0)

MongoDB::getReadPreference — Get the read preference for this database

说明

public MongoDB::getReadPreference ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

更新日志

版本 | 说明
PECL mongo 1.3.3 | The return value has changed to be consistent with MongoDB::setReadPreference(). The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.

范例

Example #1 MongoDB::getReadPreference() return value example

<?php

$m = new MongoClient();
$db = $m->test;
$db->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($db->getReadPreference());
?>

以上例程会输出：

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

参见

  • The read preferences documentation.
  • MongoDB::setReadPreference() - Set the read preference for this database


Get slaveOkay setting for this database

  • ? MongoDB::getReadPreference
  • MongoDB::getWriteConcern ?
  • PHP Manual
  • MongoDB
  • Get slaveOkay setting for this database

MongoDB::getSlaveOkay

(PECL mongo >=1.1.0)

MongoDB::getSlaveOkay — Get slaveOkay setting for this database

说明

public MongoDB::getSlaveOkay ( ) : bool

See the query section of this manual for information on distributing reads to secondaries.

参数

此函数没有参数。

返回值

Returns the value of slaveOkay for this instance.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

参见

  • 读取首选项
  • MongoDB::getReadPreference() - Get the read preference for this database
  • MongoDB::setReadPreference() - Set the read preference for this database


Get the write concern for this database

  • ? MongoDB::getSlaveOkay
  • MongoDB::lastError ?
  • PHP Manual
  • MongoDB
  • Get the write concern for this database

MongoDB::getWriteConcern

(PECL mongo >=1.5.0)

MongoDB::getWriteConcern — Get the write concern for this database

说明

public MongoDB::getWriteConcern ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the write concern. The array contains the values w for an integer acknowledgement level or string mode, and wtimeout denoting the maximum number of milliseconds to wait for the server to satisfy the write concern.

范例

Example #1 MongoDB::getWriteConcern() return value example

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
$db = $mc->selectDB('test');
var_dump($db->getWriteConcern());

$db->setWriteConcern(1, 1000);
var_dump($db->getWriteConcern());
?>

以上例程会输出：

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

参见

  • The write concern documentation.
  • MongoDB::setWriteConcern() - Set the write concern for this database


Check if there was an error on the most recent db operation performed

  • ? MongoDB::getWriteConcern
  • MongoDB::listCollections ?
  • PHP Manual
  • MongoDB
  • Check if there was an error on the most recent db operation performed

MongoDB::lastError

(PECL mongo >=0.9.5)

MongoDB::lastError — Check if there was an error on the most recent db operation performed

说明

public MongoDB::lastError ( ) : array

This method is equivalent to:

<?php

public function lastError() {
    return $this->command(array('getlasterror' => 1));
}

?>

参数

此函数没有参数。

返回值

Returns the error, if there was one.

范例

Example #1 MongoDB::lastError() null error example

<?php
$db->resetError();
var_dump($db->lastError());
?>

以上例程的输出类似于：

array(3) {
  ["err"]=>
  NULL
  ["n"]=>
  int(0)
  ["ok"]=>
  float(1)
}

Example #2 MongoDB::lastError() duplicate key example

<?php
$c = $db->selectCollection("foo");

// insert two documents with the same _id
$c->insert(array("_id" => 1));
$c->insert(array("_id" => 1));

var_dump($db->lastError());
?>

以上例程的输出类似于：

array(3) {
  ["err"]=>
  string(64) "E11000 duplicate key errorindex: foo.foo.$_id_  dup key: { : 1 }"
  ["n"]=>
  int(0)
  ["ok"]=>
  float(1)
}


Gets an array of MongoCollection objects for all collections in this database

  • ? MongoDB::lastError
  • MongoDB::prevError ?
  • PHP Manual
  • MongoDB
  • Gets an array of MongoCollection objects for all collections in this database

MongoDB::listCollections

(PECL mongo >=0.9.0)

MongoDB::listCollections — Gets an array of MongoCollection objects for all collections in this database

说明

public MongoDB::listCollections ( array $options = array() ) : array

Gets a list of all collections in the database and returns them as an array of MongoCollection objects.

Note: This method will use the » listCollections database command when communicating with MongoDB 2.8+. For previous database versions, the method will query the special system.namespaces collection.

参数

options

An array of options for listing the collections. Currently available options include:

  • "filter"

    Optional query criteria. If provided, this criteria will be used to filter the collections included in the result.

    Relevant fields that may be queried include "name" (collection name as a string, without the database name prefix) and "options" (object containing options used to create the collection)..

    Note: MongoDB 2.6 and earlier versions require the "name" criteria, if specified, to be a string value (i.e. equality match). This is because the driver must prefix the value with the database name in order to query the system.namespaces collection. Later versions of MongoDB do not have this limitation, as the driver will use the listCollections command.

  • "includeSystemCollections"

    Boolean, defaults to false. Determines whether system collections should be included in the result.

The following option may be used with MongoDB 2.8+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

返回值

Returns an array of MongoCollection objects.

错误／异常

For MongoDB 2.6 and earlier, MongoException will be thrown if a non-string value was specified for the "filter" option's "name" criteria.

更新日志

版本 | 说明
PECL mongo 1.6.0 | Changed first parameter to be an array of options. Pre-1.6.0, the first parameter was a boolean indicating the "includeSystemCollections" option.
PECL mongo 1.3.0 | Added the includeSystemCollections parameter.

范例

Example #1 MongoDB::listCollections() example

The following example demonstrates running count on each collection in a database.

<?php

$m = new MongoClient();
$db = $m->selectDB("demo");
$collections = $db->listCollections();

foreach ($collections as $collection) {
    echo "amount of documents in $collection: ";
    echo $collection->count(), "\n";
}

?>

以上例程的输出类似于：

...
amount of documents in demo.pubs: 4
amount of documents in demo.elephpants: 3
amount of documents in demo.cities: 22840
...

参见

  • MongoDB::getCollectionNames() - Gets an array of names for all collections in this database
  • MongoDB::getCollectionInfo() - Returns information about collections in this database


Checks for the last error thrown during a database operation

  • ? MongoDB::listCollections
  • MongoDB::repair ?
  • PHP Manual
  • MongoDB
  • Checks for the last error thrown during a database operation

MongoDB::prevError

(PECL mongo >=0.9.5)

MongoDB::prevError — Checks for the last error thrown during a database operation

说明

public MongoDB::prevError ( ) : array

MongoDB::lastError() is usually preferred to this. This method returns the last database error that occurred and how many operations ago it occurred. It is mostly deprecated.

参数

此函数没有参数。

返回值

Returns the error and the number of operations ago it occurred.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.


Repairs and compacts this database

  • ? MongoDB::prevError
  • MongoDB::resetError ?
  • PHP Manual
  • MongoDB
  • Repairs and compacts this database

MongoDB::repair

(PECL mongo >=0.9.0)

MongoDB::repair — Repairs and compacts this database

说明

public MongoDB::repair ( bool $preserve_cloned_files = false , bool $backup_original_files = false ) : array

This creates a fresh copy of all database data. It will remove any corrupt data and compact and large stretches of free space it finds. This is a very slow operation on a large database.

This is usually run from the shell or the command line, not the driver.

It is equivalent to the function:

<?php

public function repair() {
    return $this->command(array('repairDatabase' => 1));
}

?>

参数

preserve_cloned_files

If cloned files should be kept if the repair fails.

backup_original_files

If original files should be backed up.

返回值

Returns db response.

参见

MongoDB core docs on » repairDatabase.

范例

Example #1 MongoDB::repair() example

This example demonstrates how to repare and compact a database.

<?php

$db = $mongo->foo;

$response = $db->repair();
print_r($response);

?>

以上例程的输出类似于：

Array
(
    [ok] => 1
)


Clears any flagged errors on the database

  • ? MongoDB::repair
  • MongoDB::selectCollection ?
  • PHP Manual
  • MongoDB
  • Clears any flagged errors on the database

MongoDB::resetError

(PECL mongo >=0.9.5)

MongoDB::resetError — Clears any flagged errors on the database

说明

public MongoDB::resetError ( ) : array

This method is not used in normal operations. It resets the database error tracker (which can be incremented with MongoDB::forceError(), also not normally used).

It is equivalent to running:

<?php

public function resetError() {
    return $this->command(array('reseterror' => 1));
}

?>

参数

此函数没有参数。

返回值

Returns the database response.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.


Gets a collection

  • ? MongoDB::resetError
  • MongoDB::setProfilingLevel ?
  • PHP Manual
  • MongoDB
  • Gets a collection

MongoDB::selectCollection

(PECL mongo >=0.9.0)

MongoDB::selectCollection — Gets a collection

说明

public MongoDB::selectCollection ( string $name ) : MongoCollection

参数

name

The collection name.

返回值

Returns a new collection object.

错误／异常

Throws Exception if the collection name is invalid.


Sets this database's profiling level

  • ? MongoDB::selectCollection
  • MongoDB::setReadPreference ?
  • PHP Manual
  • MongoDB
  • Sets this database's profiling level

MongoDB::setProfilingLevel

(PECL mongo >=0.9.0)

MongoDB::setProfilingLevel — Sets this database's profiling level

说明

public MongoDB::setProfilingLevel ( int $level ) : int

This changes the current database profiling level.

This function is equivalent to running:

<?php

public function setProfilingLevel($level) {
    return $this->command(array('profile' => $level));
}

?>

The options for level are 0 (off), 1 (queries > 100ms), and 2 (all queries). If you would like to profile queries that take longer than another time period, use the database command and pass it a second option, the number of milliseconds. For example, to profile all queries that take longer than one second, run:

<?php

$result = $this->command(array('profile' => 1, 'slowms' => 1000));

?>

Profiled queries will appear in the system.profile collection of this database.

参数

level

Profiling level.

返回值

Returns the previous profiling level.

参见

  • MongoDB core docs on » profiling
  • MongoDB::getProfilingLevel() - Gets this database's profiling level


Set the read preference for this database

  • ? MongoDB::setProfilingLevel
  • MongoDB::setSlaveOkay ?
  • PHP Manual
  • MongoDB
  • Set the read preference for this database

MongoDB::setReadPreference

(PECL mongo >=1.3.0)

MongoDB::setReadPreference — Set the read preference for this database

说明

public MongoDB::setReadPreference ( string $read_preference , array $tags = ? ) : bool

参数

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

返回值

Returns true on success, or false otherwise.

错误／异常

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

范例

Example #1 MongoDB::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient();
$db = $m->test;

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$db->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

参见

  • The read preferences documentation.
  • MongoDB::getReadPreference() - Get the read preference for this database


Change slaveOkay setting for this database

  • ? MongoDB::setReadPreference
  • MongoDB::setWriteConcern ?
  • PHP Manual
  • MongoDB
  • Change slaveOkay setting for this database

MongoDB::setSlaveOkay

(PECL mongo >=1.1.0)

MongoDB::setSlaveOkay — Change slaveOkay setting for this database

说明

public MongoDB::setSlaveOkay ( bool $ok = true ) : bool

See the query section of this manual for information on distributing reads to secondaries.

参数

ok

If reads should be sent to secondary members of a replica set for all possible queries using this MongoDB instance.

返回值

Returns the former value of slaveOkay for this instance.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

参见

  • 读取首选项
  • MongoDB::setReadPreference() - Set the read preference for this database
  • MongoDB::getReadPreference() - Get the read preference for this database


Set the write concern for this database

  • ? MongoDB::setSlaveOkay
  • MongoDB::__toString ?
  • PHP Manual
  • MongoDB
  • Set the write concern for this database

MongoDB::setWriteConcern

(PECL mongo >=1.5.0)

MongoDB::setWriteConcern — Set the write concern for this database

说明

public MongoDB::setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool

参数

w

The write concern. This may be an integer denoting the number of servers required to acknowledge the write, or a string mode (e.g. "majority").

wtimeout

The maximum number of milliseconds to wait for the server to satisfy the write concern.

返回值

Returns true on success, or false otherwise.

错误／异常

Emits E_WARNING if the w parameter is not an integer or string value.

范例

Example #1 MongoDB::setWriteConcern() example

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');
$db = $mc->selectDB('test');

// Require that the majority of servers in the replica set acknowledge writes
// within three seconds.
$db->setWriteConcern('majority', 3000);
?>

参见

  • The write concern documentation.
  • MongoDB::getWriteConcern() - Get the write concern for this database


The name of this database

  • ? MongoDB::setWriteConcern
  • MongoCollection ?
  • PHP Manual
  • MongoDB
  • The name of this database

MongoDB::__toString

(PECL mongo >=0.9.0)

MongoDB::__toString — The name of this database

说明

public MongoDB::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns this database's name.


The MongoCollection class

(PECL mongo >=0.9.0)

简介

Represents a MongoDB collection.

Collection names can use any character in the ASCII set. Some valid collection names are "", "...", "my collection", and "*&#@".

User-defined collection names cannot contain the $ symbol. There are certain system collections which use a $ in their names (e.g., local.oplog.$main), but it is a reserved character. If you attempt to create and use a collection with a $ in the name, MongoDB will assert.

类摘要

MongoCollection {
/* 常量 */
const int ASCENDING = 1 ;
const int DESCENDING = -1 ;
/* Fields */
public MongoDB $db = null ;
public int $w ;
public int $wtimeout ;
/* 方法 */
public aggregate ( array $pipeline , array $options = ? ) : array
public aggregateCursor ( array $command , array $options = ? ) : MongoCommandCursor
public batchInsert ( array $a , array $options = array() ) : mixed
public __construct ( MongoDB $db , string $name )
public count ( array $query = array() , int $limit = 0 , int $skip = 0 ) : int
public createDBRef ( mixed $document_or_id ) : array
public createIndex ( array $keys , array $options = array() ) : bool
public deleteIndex ( string|array $keys ) : array
public deleteIndexes ( ) : array
public distinct ( string $key , array $query = ? ) : array
public drop ( ) : array
public ensureIndex ( string|array $key|keys , array $options = array() ) : bool
public find ( array $query = array() , array $fields = array() ) : MongoCursor
public findAndModify ( array $query , array $update = ? , array $fields = ? , array $options = ? ) : array
public findOne
 ( array $query = array()
, array $fields = array()
, array $options = array()
) : array
public __get ( string $name ) : MongoCollection
public getDBRef ( array $ref ) : array
public getIndexInfo ( ) : array
public getName ( ) : string
public getReadPreference ( ) : array
public getSlaveOkay ( ) : bool
public getWriteConcern ( ) : array
public group ( mixed $keys , array $initial , MongoCode $reduce , array $options = array() ) : array
public insert ( array|object $a , array $options = array() ) : bool|array
public parallelCollectionScan ( int $num_cursors ) : array[MongoCommandCursor]
public remove ( array $criteria = array() , array $options = array() ) : bool|array
public save ( array|object $document , array $options = array() ) : mixed
public setReadPreference ( string $read_preference , array $tags = ? ) : bool
public setSlaveOkay ( bool $ok = true ) : bool
public setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool
static protected toIndexString ( mixed $keys ) : string
public __toString ( ) : string
public update ( array $criteria , array $new_object , array $options = array() ) : bool|array
public validate ( bool $scan_data = false ) : array
}

预定义常量

MongoCollection::ASCENDING
Ascending direction for sorts and index creation.
MongoCollection::DESCENDING
Descending direction for sorts and index creation.

Fields

db

The "parent" database for this collection.

w

The number of servers to replicate a change to before returning success. Value is inherited from the parent database. The MongoDB class has a more detailed description of how w works.

wtimeout

The number of milliseconds to wait for $this->w replications to take place. Value is inherited from the parent database. The MongoDB class has a more detailed description of how wtimeout works.

参见

MongoDB core docs on » collections.

Table of Contents

  • MongoCollection::aggregate — Perform an aggregation using the aggregation framework
  • MongoCollection::aggregateCursor — Execute an aggregation pipeline command and retrieve results through a cursor
  • MongoCollection::batchInsert — Inserts multiple documents into this collection
  • MongoCollection::__construct — 创建一个新的集合
  • MongoCollection::count — 返回集合中的文档数量
  • MongoCollection::createDBRef — 创建一个数据库引用
  • MongoCollection::createIndex — Creates an index on the specified field(s) if it does not already exist
  • MongoCollection::deleteIndex — Deletes an index from this collection
  • MongoCollection::deleteIndexes — 删除集合的所有索引
  • MongoCollection::distinct — 获取集合里指定键的不同值的列表。
  • MongoCollection::drop — 删除该集合
  • MongoCollection::ensureIndex — Creates an index on the specified field(s) if it does not already exist
  • MongoCollection::find — 查询该集合，并返回结果集的 MongoCursor
  • MongoCollection::findAndModify — Update a document and return it
  • MongoCollection::findOne — Queries this collection, returning a single element
  • MongoCollection::__get — Gets a collection
  • MongoCollection::getDBRef — Fetches the document pointed to by a database reference
  • MongoCollection::getIndexInfo — Returns information about indexes on this collection
  • MongoCollection::getName — 返回这个集合的名称
  • MongoCollection::getReadPreference — Get the read preference for this collection
  • MongoCollection::getSlaveOkay — Get slaveOkay setting for this collection
  • MongoCollection::getWriteConcern — Get the write concern for this collection
  • MongoCollection::group — Performs an operation similar to SQL's GROUP BY command
  • MongoCollection::insert — 插入文档到集合中
  • MongoCollection::parallelCollectionScan — Returns an array of cursors to iterator over a full collection in parallel
  • MongoCollection::remove — 从集合中删除记录
  • MongoCollection::save — 保存一个文档到集合
  • MongoCollection::setReadPreference — Set the read preference for this collection
  • MongoCollection::setSlaveOkay — Change slaveOkay setting for this collection
  • MongoCollection::setWriteConcern — Set the write concern for this database
  • MongoCollection::toIndexString — Converts keys specifying an index to its identifying string
  • MongoCollection::__toString — String representation of this collection
  • MongoCollection::update — Update records based on a given criteria
  • MongoCollection::validate — Validates this collection


Perform an aggregation using the aggregation framework

  • ? MongoCollection
  • MongoCollection::aggregateCursor ?
  • PHP Manual
  • MongoCollection
  • Perform an aggregation using the aggregation framework

MongoCollection::aggregate

(PECL mongo >=1.3.0)

MongoCollection::aggregate — Perform an aggregation using the aggregation framework

说明

public MongoCollection::aggregate ( array $pipeline , array $options = ? ) : array
public MongoCollection::aggregate ( array $op , array ...$ops ) : array

The MongoDB » aggregation framework provides a means to calculate aggregated values without having to use MapReduce. While MapReduce is powerful, it is often more difficult than necessary for many simple aggregation tasks, such as totaling or averaging field values.

This method accepts either a variable amount of pipeline operators, or a single array of operators constituting the pipeline.

参数

pipeline

An array of pipeline operators.

options

Options for the aggregation command. Valid options include:

  • "allowDiskUse"

    Allow aggregation stages to write to temporary files

  • "cursor"

    Options controlling the creation of the cursor object. This option causes the command to return a result document suitable for constructing a MongoCommandCursor. If you need to use this option, you should consider using MongoCollection::aggregateCursor().

  • "explain"

    Return information on the processing of the pipeline.

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

Or

op

First pipeline operator.

ops

Additional pipeline operators.

返回值

The result of the aggregation as an array. The ok will be set to 1 on success, 0 on failure.

错误／异常

When an error occurs an array with the following keys will be returned:

  • errmsg - containing the reason for the failure
  • code - the errorcode of the failure
  • ok - will be set to 0.

更新日志

版本 | 说明
PECL mongo 1.5.0 | Added optional options argument

范例

Example #1 MongoCollection::aggregate() example

The following example aggregation operation pivots data to create a set of author names grouped by tags applied to an article. Call the aggregation framework by issuing the following command:

<?php
$m = new MongoClient("localhost");
$c = $m->selectDB("examples")->selectCollection("article");
$data = array (
    'title' => 'this is my title',
    'author' => 'bob',
    'posted' => new MongoDate,
    'pageViews' => 5,
    'tags' => array ( 'fun', 'good', 'fun' ),
    'comments' => array (
      array (
        'author' => 'joe',
        'text' => 'this is cool',
      ),
      array (
        'author' => 'sam',
        'text' => 'this is bad',
      ),
    ),
    'other' =>array (
      'foo' => 5,
    ),
);
$d = $c->insert($data, array("w" => 1));

$ops = array(
    array(
        '$project' => array(
            "author" => 1,
            "tags"   => 1,
        )
    ),
    array('$unwind' => '$tags'),
    array(
        '$group' => array(
            "_id" => array("tags" => '$tags'),
            "authors" => array('$addToSet' => '$author'),
        ),
    ),
);
$results = $c->aggregate($ops);
var_dump($results);
?>

以上例程会输出：

array(2) {
  ["result"]=>
  array(2) {
    [0]=>
    array(2) {
      ["_id"]=>
      array(1) {
        ["tags"]=>
        string(4) "good"
      }
      ["authors"]=>
      array(1) {
        [0]=>
        string(3) "bob"
      }
    }
    [1]=>
    array(2) {
      ["_id"]=>
      array(1) {
        ["tags"]=>
        string(3) "fun"
      }
      ["authors"]=>
      array(1) {
        [0]=>
        string(3) "bob"
      }
    }
  }
  ["ok"]=>
  float(1)
}

The following examples use the » zipcode data set. Use mongoimport to load this data set into your mongod instance.

Example #2 MongoCollection::aggregate() example

To return all states with a population greater than 10 million, use the following aggregation operation:

<?php
$m = new MongoClient("localhost");
$c = $m->selectDB("test")->selectCollection("zips");

$pipeline = array(
    array(
        '$group' => array(
            '_id' => array('state' => '$state'),
            'totalPop' => array('$sum' => '$pop')
        )
    ),
    array(
        '$match' => array(
            'totalPop' => array('$gte' => 10 * 1000 * 1000)
        )
    ),
);
$out = $c->aggregate($pipeline);
var_dump($out);
?>

以上例程的输出类似于：

array(2) {
  ["result"]=>
  array(7) {
    [0]=>
    array(2) {
      ["_id"]=>
      string(2) "TX"
      ["totalPop"]=>
      int(16986510)
    }
    [1]=>
    array(2) {
      ["_id"]=>
      string(2) "PA"
      ["totalPop"]=>
      int(11881643)
    }
    [2]=>
    array(2) {
      ["_id"]=>
      string(2) "NY"
      ["totalPop"]=>
      int(17990455)
    }
    [3]=>
    array(2) {
      ["_id"]=>
      string(2) "IL"
      ["totalPop"]=>
      int(11430602)
    }
    [4]=>
    array(2) {
      ["_id"]=>
      string(2) "CA"
      ["totalPop"]=>
      int(29760021)
    }
    [5]=>
    array(2) {
      ["_id"]=>
      string(2) "OH"
      ["totalPop"]=>
      int(10847115)
    }
    [6]=>
    array(2) {
      ["_id"]=>
      string(2) "FL"
      ["totalPop"]=>
      int(12937926)
    }
  }
  ["ok"]=>
  float(1)
}

Example #3 MongoCollection::aggregate() example

To return the average populations for cities in each state, use the following aggregation operation:

<?php
$m = new MongoClient;
$c = $m->selectDB("test")->selectCollection("zips");

$out = $c->aggregate(
    array(
        '$group' => array(
            '_id' => array('state' => '$state', 'city' => '$city' ),
            'pop' => array('$sum' => '$pop' )
        )
    ),
    array(
        '$group' => array(
            '_id' => '$_id.state',
            'avgCityPop' => array('$avg' => '$pop')
        )
    )
);

var_dump($out);
?>

以上例程的输出类似于：

array(2) {
  ["result"]=>
  array(51) {
    [0]=>
    array(2) {
      ["_id"]=>
      string(2) "DC"
      ["avgCityPop"]=>
      float(303450)
    }
    [1]=>
    array(2) {
      ["_id"]=>
      string(2) "DE"
      ["avgCityPop"]=>
      float(14481.913043478)
    }
...
    [49]=>
    array(2) {
      ["_id"]=>
      string(2) "WI"
      ["avgCityPop"]=>
      float(7323.0074850299)
    }
    [50]=>
    array(2) {
      ["_id"]=>
      string(2) "WV"
      ["avgCityPop"]=>
      float(2759.1953846154)
    }
  }
  ["ok"]=>
  float(1)
}

Example #4 MongoCollection::aggregate() with command options

To return information on how the pipeline will be processed we use the explain command option:

<?php
$m = new MongoClient;
$c = $m->selectDB("test")->selectCollection("zips");

$pipeline = array(
    array(
        '$group' => array(
            '_id' => '$state',
           'totalPop' => array('$sum' => '$pop'),
        ),
    ),
    array(
        '$match' => array(
            'totalPop' => array('$gte' => 10 * 1000 * 1000)
        )
    ),
    array(
        '$sort' => array("totalPop" => -1),
    ),
);

$options = array("explain" => true);
$out = $c->aggregate($pipeline, $options);
var_dump($out);
?>

以上例程的输出类似于：

array(2) {
  ["stages"]=>
  array(4) {
    [0]=>
    array(1) {
      ["$cursor"]=>
      array(3) {
        ["query"]=>
        array(0) {
        }
        ["fields"]=>
        array(3) {
          ["pop"]=>
          int(1)
          ["state"]=>
          int(1)
          ["_id"]=>
          int(0)
        }
        ["plan"]=>
        array(4) {
          ["cursor"]=>
          string(11) "BasicCursor"
          ["isMultiKey"]=>
          bool(false)
          ["scanAndOrder"]=>
          bool(false)
          ["allPlans"]=>
          array(1) {
            [0]=>
            array(3) {
              ["cursor"]=>
              string(11) "BasicCursor"
              ["isMultiKey"]=>
              bool(false)
              ["scanAndOrder"]=>
              bool(false)
            }
          }
        }
      }
    }
    [1]=>
    array(1) {
      ["$group"]=>
      array(2) {
        ["_id"]=>
        string(6) "$state"
        ["totalPop"]=>
        array(1) {
          ["$sum"]=>
          string(4) "$pop"
        }
      }
    }
    [2]=>
    array(1) {
      ["$match"]=>
      array(1) {
        ["totalPop"]=>
        array(1) {
          ["$gte"]=>
          int(10000000)
        }
      }
    }
    [3]=>
    array(1) {
      ["$sort"]=>
      array(1) {
        ["sortKey"]=>
        array(1) {
          ["totalPop"]=>
          int(-1)
        }
      }
    }
  }
  ["ok"]=>
  float(1)
}

参见

  • MongoCollection::aggregateCursor() - Execute an aggregation pipeline command and retrieve results through a cursor
  • The MongoDB » aggregation framework


Execute an aggregation pipeline command and retrieve results through a cursor

  • ? MongoCollection::aggregate
  • MongoCollection::batchInsert ?
  • PHP Manual
  • MongoCollection
  • Execute an aggregation pipeline command and retrieve results through a cursor

MongoCollection::aggregateCursor

(PECL mongo >=1.5.0)

MongoCollection::aggregateCursor — Execute an aggregation pipeline command and retrieve results through a cursor

说明

public MongoCollection::aggregateCursor ( array $command , array $options = ? ) : MongoCommandCursor

With this method you can execute Aggregation Framework pipelines and retrieve the results through a cursor, instead of getting just one document back as you would with MongoCollection::aggregate(). This method returns a MongoCommandCursor object. This cursor object implements the Iterator interface just like the MongoCursor objects that are returned by the MongoCollection::find() method.

Note: The resulting MongoCommandCursor will inherit this collection's read preference. MongoCommandCursor::setReadPreference() may be used to change the read preference before iterating on the cursor.

参数

pipeline

The Aggregation Framework pipeline to execute.

options

Options for the aggregation command. Valid options include:

  • "allowDiskUse"

    Allow aggregation stages to write to temporary files

  • "cursor"

    It is possible to configure how many initial documents the server should return with the first result set. The default initial batch size is 101. You can change it by adding the batchSize option:

    <?php
    $collection    ->aggregateCursor(
            $pipeline,
        [     "cursor" => [ "batchSize" => 4 ] ]
    );

    This option only configures the size of the first batch. To configure the size of future batches, please use the MongoCommandCursor::batchSize() method on the returned MongoCommandCursor object.

  • "explain"

    Return information on the processing of the pipeline. This option may cause the command to return a result document that is unsuitable for constructing a MongoCommandCursor. If you need to use this option, you should consider using MongoCollection::aggregate().

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

返回值

Returns a MongoCommandCursor object. Because this implements the Iterator interface you can iterate over each of the results as returned by the command query. The MongoCommandCursor also implements the MongoCursorInterface interface which adds the MongoCommandCursor::batchSize(), MongoCommandCursor::dead(), MongoCommandCursor::info() methods.

范例

Example #1 MongoCollection::aggregateCursor() example

Finding all of the distinct values for a key.

<?php
$m = new MongoClient;
$db = $m->test;
$people = $db->people;
$people->drop();

$people->insert(array("name" => "Joe", "points" => 4));
$people->insert(array("name" => "Molly", "points" => 43));
$people->insert(array("name" => "Sally", "points" => 22));
$people->insert(array("name" => "Joe", "points" => 22));
$people->insert(array("name" => "Molly", "points" => 87));

$ages = $people->aggregateCursor( [
        [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
        [ '$sort' => [ 'points' => -1 ] ],
] );

foreach ($ages as $person) {
    echo "{$person['_id']}: {$person['points']}\n";
}

?>

以上例程的输出类似于：

Molly: 130
Joe: 26
Sally: 22

Example #2 MongoCollection::aggregateCursor() example with different initial batch size

Finding all of the distinct values for a key.

<?php
$m = new MongoClient;
$db = $m->test;
$people = $db->people;
$people->drop();

/* Insert some sample data */
$people->insert(array("name" => "Joe", "points" => 4));
$people->insert(array("name" => "Molly", "points" => 43));
$people->insert(array("name" => "Sally", "points" => 22));
$people->insert(array("name" => "Joe", "points" => 22));
$people->insert(array("name" => "Molly", "points" => 87));

/* Run the command cursor */
$ages = $people->aggregateCursor(
    [
        [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
        [ '$sort' => [ 'points' => -1 ] ],
    ],
    [ "cursor" => [ "batchSize" => 4 ] ]
);

foreach ($ages as $person) {
    echo "{$person['_id']}: {$person['points']}\n";
}

?>

以上例程的输出类似于：

Molly: 130
Joe: 26
Sally: 22

参见

  • MongoDB::command() - 执行一条 Mongo 指令
  • MongoCommandCursor
  • MongoCommandCursor::batchSize() - Limits the number of elements returned in one batch
  • MongoCollection::aggregate() - Perform an aggregation using the aggregation framework
  • The MongoDB » aggregation framework


Inserts multiple documents into this collection

  • ? MongoCollection::aggregateCursor
  • MongoCollection::__construct ?
  • PHP Manual
  • MongoCollection
  • Inserts multiple documents into this collection

MongoCollection::batchInsert

(PECL mongo >=0.9.0)

MongoCollection::batchInsert — Inserts multiple documents into this collection

说明

public MongoCollection::batchInsert ( array $a , array $options = array() ) : mixed

参数

a

An array of arrays or objects. If any objects are used, they may not have protected or private properties.

Note:

If the documents to insert do not have an _id key or property, a new MongoId instance will be created and assigned to it. See MongoCollection::insert() for additional information on this behavior.

options

An array of options for the batch of insert operations. Currently available options include:

  • "continueOnError"

    Boolean, defaults to false. If set, the database will not stop processing a bulk insert if one fails (eg due to duplicate IDs). This makes bulk insert behave similarly to a series of single inserts, except that calling MongoDB::lastError() will have an error set if any insert fails, not just the last one. If multiple errors occur, only the most recent will be reported by MongoDB::lastError().

    Note:

    Please note that continueOnError affects errors on the database side only. If you try to insert a document that has errors (for example it contains a key with an empty name), then the document is not even transferred to the database as the driver detects this error and bails out. continueOnError has no effect on errors detected in the documents by the driver.

  • "fsync"

    Boolean, defaults to false. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If true, an acknowledged insert is implied and this option will override setting "w" to 0.

    Note: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to false. Forces the write operation to block until it is synced to the journal on disk. If true, an acknowledged write is implied and this option will override setting "w" to 0.

    Note: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

返回值

If the w parameter is set to acknowledge the write, returns an associative array with the status of the inserts ("ok") and any error that may have occurred ("err"). Otherwise, returns true if the batch insert was successfully sent, false otherwise.

错误／异常

Throws MongoException if any inserted documents are empty or if they contains zero-length keys. Attempting to insert an object with protected and private properties will cause a zero-length key error.

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

更新日志

版本 | 说明
PECL mongo 1.5.0 | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
PECL mongo 1.3.4 | Added "wtimeout" option.
PECL mongo 1.3.0 | Added "w" option.
PECL mongo 1.2.7 | Added "continueOnError" option.
PECL mongo 1.0.9 | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option.
PECL mongo 1.0.5 | Added options parameter.

范例

Example #1 MongoCollection::batchInsert() example

Batch insertion is a quick way to add many elements to the database at once

<?php

$users = array();
for ($i = 0; $i<100; $i++) {
  $users[] = array('username' => 'user'.$i, 'i' => $i);
}

$mongo = new MongoClient();
$collection = $mongo->my_db->users;
$collection->drop();

$collection->batchInsert($users);

foreach ($users as $user) {
  echo $user['_id']."\n"; // populated with instanceof MongoId
}

$users = $collection->find()->sort(array('i' => 1));
foreach ($users as $user) {
    var_dump($user['username']);
}

?>

以上例程的输出类似于：

4bf43ac68ead0e1971000000
4bf43ac68ead0e1971010000
4bf43ac68ead0e1971020000
...
string(5) "user1"
string(5) "user2"
string(5) "user3"
...

Example #2 MongoCollection::batchInsert() example with ignoring errors

<?php

$con = new Mongo;
$db = $con->demo;

$doc1 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010001'),
        'id' => 1,
        'desc' => "ONE",
);
$doc2 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010002'),
        'id' => 2,
        'desc' => "TWO",
);
$doc3 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010002'), // same _id as above
        'id' => 3,
        'desc' => "THREE",
);
$doc4 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010004'),
        'id' => 4,
        'desc' => "FOUR",
);

$c = $db->selectCollection('c');
$c->batchInsert(
    array($doc1, $doc2, $doc3, $doc4),
    array('continueOnError' => true)
);

$docs = $c->find();
foreach ($docs as $doc) {
    var_dump($doc['desc']);
}
?>

以上例程的输出类似于：

string(3) "ONE"
string(3) "TWO"
string(4) "FOUR"

参见

  • MongoCollection::insert() - 插入文档到集合中
  • MongoCollection::update() - Update records based on a given criteria
  • MongoCollection::find() - 查询该集合，并返回结果集的 MongoCursor
  • MongoCollection::remove() - 从集合中删除记录
  • MongoDB core docs on » insert.


创建一个新的集合

  • ? MongoCollection::batchInsert
  • MongoCollection::count ?
  • PHP Manual
  • MongoCollection
  • 创建一个新的集合

MongoCollection::__construct

(PECL mongo >=0.9.0)

MongoCollection::__construct — 创建一个新的集合

说明

public MongoCollection::__construct ( MongoDB $db , string $name )

参数

MongoDB db

所属的父数据库。

name

集合的名称。

返回值

返回一个新的集合对象。

错误／异常

如果集合名称无效，将会抛出一个默认的异常。


返回集合中的文档数量

  • ? MongoCollection::__construct
  • MongoCollection::createDBRef ?
  • PHP Manual
  • MongoCollection
  • 返回集合中的文档数量

MongoCollection::count

(PECL mongo >=0.9.0)

MongoCollection::count — 返回集合中的文档数量

说明

public MongoCollection::count ( array $query = array() , int $limit = 0 , int $skip = 0 ) : int

参数

query

关联数组或者对象，含有需要匹配的字段。

limit

指定返回数量的上限。

skip

指定在开始统计前，需要跳过的结果数目。

返回值

返回查询匹配到的文档数目。

更新日志

版本 | 说明
1.0.7 | 添加了 limit 和 skip 参数。

范例

Example #1 MongoCollection::count() 例子

<?php

$collection->insert(array('x'=>1));
$collection->insert(array('x'=>2));
$collection->insert(array('x'=>3));

var_dump($collection->count());
var_dump($collection->count(array('x'=>1)));

?>

以上例程的输出类似于：

int(3)
int(1)


创建一个数据库引用

  • ? MongoCollection::count
  • MongoCollection::createIndex ?
  • PHP Manual
  • MongoCollection
  • 创建一个数据库引用

MongoCollection::createDBRef

(PECL mongo >=0.9.0)

MongoCollection::createDBRef — 创建一个数据库引用

说明

public MongoCollection::createDBRef ( mixed $document_or_id ) : array

参数

document_or_id

If an array or object is given, its _id field will be used as the reference ID. If a MongoId or scalar is given, it will be used as the reference ID.

返回值

返回一个数据库的引用数组。

如果提供了不包含 _id 字段的数组当做 document_or_id 参数，将会返回 null。

范例

Example #1 MongoCollection::createDBRef() 例子

<?php

$songs = $db->songs;
$playlists = $db->playlists;

// 为 song 创建引用
$manamana = $songs->findOne(array('title' => 'Ma na ma na'));
$refToSong = $songs->createDBRef($manamana);

// 添加引用到我的播放列表
$playlists->update(array('username' => 'me'), array('$push' => array('songlist' => $refToSong)));

?>

参见

  • MongoCollection::getDBRef() - Fetches the document pointed to by a database reference


Creates an index on the specified field(s) if it does not already exist

  • ? MongoCollection::createDBRef
  • MongoCollection::deleteIndex ?
  • PHP Manual
  • MongoCollection
  • Creates an index on the specified field(s) if it does not already exist

MongoCollection::createIndex

(PECL mongo >=1.5.0)

MongoCollection::createIndex — Creates an index on the specified field(s) if it does not already exist

说明

public MongoCollection::createIndex ( array $keys , array $options = array() ) : bool

Creates an index on the specified field(s) if it does not already exist. Fields may be indexed with a direction (e.g. ascending or descending) or a special type (e.g. text, geospatial, hashed).

Note:

This method will use the » createIndexes database command when communicating with MongoDB 2.6+. For previous database versions, the method will perform an insert operation on the special system.indexes collection.

参数

keys

An array specifying the index's fields as its keys. For each field, the value is either the index direction or » index type. If specifying direction, specify 1 for ascending or -1 for descending.

options

An array of options for the index creation. We pass all given options straight to the server, but a non-exhaustive list of currently available options include:

  • "unique"

    Specify true to create a unique index. The default value is false. This option applies only to ascending/descending indexes.

    Note:

    When MongoDB indexes a field, if a document does not have a value for the field, a null value is indexed. If multiple documents do not contain a field, a unique index will reject all but the first of those documents. The "sparse" option may be used to overcome this, since it will prevent documents without the field from being indexed.

  • "sparse"

    Specify true to create a sparse index, which only indexes documents containing a specified field. The default value is false.

  • "expireAfterSeconds"

    The value of this option should specify the number of seconds after which a document should be considered expired and automatically removed from the collection. This option is only compatible with single-field indexes where the field will contain MongoDate values.

    Note:

    This feature is available in MongoDB 2.2+. See » Expire Data from Collections by Setting TTL for more information.

  • "name"

    A optional name that uniquely identifies the index.

    Note:

    By default, the driver will generate an index name based on the index's field(s) and ordering or type. For example, a compound index array("x" => 1, "y" => -1) would be named "x_1_y_-1" and a geospatial index array("loc" => "2dsphere") would be named "loc_2dsphere". For indexes with many fields, it is possible that the generated name might exceed MongoDB's » limit for index names. The "name" option may be used in that case to supply a shorter name.

  • "background"

    Builds the index in the background so that building an index does not block other database activities. Specify true to build in the background. The default value is false.

    Warning

    Prior to MongoDB 2.6.0, index builds on secondaries were executed as foreground operations, irrespective of this option. See » Building Indexes with Replica Sets for more information.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

The following option may be used with MongoDB 2.6+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

The following options may be used with MongoDB versions before 2.8:

  • "dropDups"

    Specify true to force creation of a unique index where the collection may contain duplicate values for a key. MongoDB will index the first occurrence of a key and delete all subsequent documents from the collection that contain a duplicate value for that key. The default value is false.

    Warning

    "dropDups" may delete data from your database. Use with extreme caution.

    Note:

    This option is not supported on MongoDB 2.8+. Index creation will fail if the collection contains duplicate values.

The following options may be used with MongoDB versions before 2.6:

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

返回值

Returns an array containing the status of the index creation. The array contains whether the operation succeeded ("ok"), the number of indexes before and after the operation ("numIndexesBefore" and "numIndexesAfter"), and whether the collection that the index belongs to has been created ("createdCollectionAutomatically"). If the index already existed and did not need to be created, a "note" field may be present in lieu of "numIndexesAfter".

With MongoDB 2.4 and earlier, a status document is only returned if the write concern is at least 1. Otherwise, true is returned. The fields in the status document are different, except for the "ok" field, which signals whether the index creation was successful. Additional fields are described in the documentation for MongoCollection::insert().

错误／异常

Throws MongoException if the index name is longer than 128 bytes, or if the index specification is not an array.

Throws MongoDuplicateKeyException if the server could not create the unique index due to conflicting documents.

Throws MongoResultException if the server could not create the index due to an error.

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

范例

Example #1 MongoCollection::createIndex() example

<?php

$c = new MongoCollection($db, 'foo');

// create an index on 'x' ascending
$c->createIndex(array('x' => 1));

// create a unique index on 'y'
$c->createIndex(array('y' => 1), array('unique' => true));

// create a compound index on 'za' ascending and 'zb' descending
$c->createIndex(array('za' => 1, 'zb' => -1));

?>

Example #2 Geospatial Indexing

Mongo supports geospatial indexes, which allow you to search for documents near a given location or within a shape. The following example creates a geospatial index on the "loc" field:

<?php

$collection->createIndex(array('loc' => '2dsphere'));

?>

Example #3 Drop duplicates example

<?php

$collection->insert(array('username' => 'joeschmoe'));
$collection->insert(array('username' => 'joeschmoe'));

/* Index creation fails, since you cannot create a unique index on a field when
 * duplicates exist.
 */
$collection->createIndex(array('username' => 1), array('unique' => 1));

/* MongoDB will one of the conflicting documents and allow the unique index to
 * be created.
 */
$collection->createIndex(array('username' => 1), array('unique' => 1, 'dropDups' => 1));

/* We now have a unique index and subsequent inserts with the same username will
 * fail.
 */
$collection->insert(array('username' => 'joeschmoe'));

?>

参见

  • MongoCollection::deleteIndex() - Deletes an index from this collection
  • MongoCollection::deleteIndexes() - 删除集合的所有索引
  • The MongoDB » index and » index type documentation.


Deletes an index from this collection

  • ? MongoCollection::createIndex
  • MongoCollection::deleteIndexes ?
  • PHP Manual
  • MongoCollection
  • Deletes an index from this collection

MongoCollection::deleteIndex

(PECL mongo >=0.9.0)

MongoCollection::deleteIndex — Deletes an index from this collection

说明

public MongoCollection::deleteIndex ( string|array $keys ) : array

This method is identical to:

<?php

public function deleteIndexes($keys) {
  $indexName = $this->toIndexString($keys);

  return $this->db->command(array(
    "deleteIndexes" => $this->getName(),
    "index" => $indexName,
  ));
}

?>

Each index is given a unique name when it is created. This is often generated by the driver based on the index key(s) and order/type, but custom names may also be specified with MongoCollection::createIndex()'s "name" option).

Unfortunately, MongoCollection::deleteIndex() cannot delete custom-named indexes due to a backwards compatibility issue. When a string argument is provided, it is assumed to be the single field name in an ascending index (e.g. the name "x_1" would be used for the argument "x"). If an array or object is provided, an index name is generated just as if that argument was passed to MongoCollection::createIndex().

In order to delete a custom-named index with the PHP driver, the deleteIndexes database command must be used. For instance, an index named "myIndex" could be deleted with the PHP driver by running:

<?php

$db->command(array(
  "deleteIndexes" => $collection->getName(),
  "index" => "myIndex",
));

?>

To determine the name of an index with the PHP driver, you can query the system.indexes collection of a database and look for the "name" field of each result. The "ns" field will indicate the collection to which each index belongs.

参数

keys

An array specifying the index's fields as its keys. For each field, the value is either the index direction or » index type. If specifying direction, specify 1 for ascending or -1 for descending.

If a string is provided, it is assumed to be the single field name in an ascending index.

返回值

Returns the database response.

范例

Example #1 MongoCollection::deleteIndex() example

This example passes the function string and array parameters.

<?php

$m = new MongoClient();
$c = $m->example->indices;

// create and remove a simple index
$c->createIndex(array("i"=>1));
$c->deleteIndex("i");

// create and remove a multi-key index
$c->ensureIndex(array("j" => 1, "k" => 1));
$c->deleteIndex(array("j" => 1, "k" => 1));

?>

参见

  • MongoCollection::createIndex() - Creates an index on the specified field(s) if it does not already exist
  • MongoCollection::deleteIndexes() - 删除集合的所有索引
  • MongoCollection::toIndexString() - Converts keys specifying an index to its identifying string
  • The MongoDB » index and » index type documentation.


删除集合的所有索引

  • ? MongoCollection::deleteIndex
  • MongoCollection::distinct ?
  • PHP Manual
  • MongoCollection
  • 删除集合的所有索引

MongoCollection::deleteIndexes

(PECL mongo >=0.9.0)

MongoCollection::deleteIndexes — 删除集合的所有索引

说明

public MongoCollection::deleteIndexes ( ) : array

参数

此函数没有参数。

返回值

返回数据库的响应。

范例

Example #1 MongoCollection::deleteIndexes() 例子

这个例子演示了如何从集合中删除所有索引并得到响应

<?php

$collection = $mongo->my_db->articles;
$response = $collection->deleteIndexes();
print_r($response);

?>

以上例程的输出类似于：

Array
(
    [nIndexesWas] => 1
    [msg] => all indexes deleted for collection
    [ok] => 1
)

参见

  • MongoCollection::createIndex() - Creates an index on the specified field(s) if it does not already exist
  • MongoCollection::deleteIndex() - Deletes an index from this collection


获取集合里指定键的不同值的列表。

  • ? MongoCollection::deleteIndexes
  • MongoCollection::drop ?
  • PHP Manual
  • MongoCollection
  • 获取集合里指定键的不同值的列表。

MongoCollection::distinct

(PECL mongo >=1.2.11)

MongoCollection::distinct — 获取集合里指定键的不同值的列表。

说明

public MongoCollection::distinct ( string $key , array $query = ? ) : array

distinct 命令返回集合里给定键不同值的列表。

参数

key

要使用的键。

query

一个可选的查询参数

返回值

返回不同值的数组， 或者在失败时返回 false

范例

Example #1 MongoCollection::distinct() 例子

<?php
$m = new Mongo;
$db = $m->selectDB("test");
$db->dropCollection("distinct");
$c = $db->distinct;

$c->insert(array("stuff" => "bar", "zip-code" => 10010));
$c->insert(array("stuff" => "foo", "zip-code" => 10010));
$c->insert(array("stuff" => "bar", "zip-code" => 99701), array("w" => 1));

$retval = $c->distinct("zip-code");
var_dump($retval);

$retval = $c->distinct("zip-code", array("stuff" => "foo"));
var_dump($retval);

$retval = $c->distinct("zip-code", array("stuff" => "bar"));
var_dump($retval);

?>

以上例程会输出：

array(2) {
  [0]=>
  int(10010)
  [1]=>
  int(99701)
}
array(1) {
  [0]=>
  int(10010)
}
array(2) {
  [0]=>
  int(10010)
  [1]=>
  int(99701)
}

Example #2 内嵌文档的 MongoCollection::distinct() 例子

<?php
$c->insert(array("user" => array("points" => 25)));
$c->insert(array("user" => array("points" => 31)));
$c->insert(array("user" => array("points" => 25)));

$retval = $c->distinct("user.points");
var_dump($retval);

$retval = $c->distinct("user.nonexisting");
var_dump($retval);
?>

以上例程会输出：

array(2) {
  [0]=>
  int(25)
  [1]=>
  int(31)
}
array(0) {
}


删除该集合

  • ? MongoCollection::distinct
  • MongoCollection::ensureIndex ?
  • PHP Manual
  • MongoCollection
  • 删除该集合

MongoCollection::drop

(PECL mongo >=0.9.0)

MongoCollection::drop — 删除该集合

说明

public MongoCollection::drop ( ) : array

删除该集合，以及它的索引。

参数

此函数没有参数。

返回值

返回数据库的响应。

范例

Example #1 MongoCollection::drop() 例子

这个例子演示了如何删除一个集合，并且得到想要的回应。

<?php

$collection = $mongo->my_db->articles;
$response = $collection->drop();
print_r($response);

?>

以上例程的输出类似于：

Array
(
    [nIndexesWas] => 1
    [msg] => all indexes deleted for collection
    [ns] => my_db.articles
    [ok] => 1
)


Creates an index on the specified field(s) if it does not already exist

  • ? MongoCollection::drop
  • MongoCollection::find ?
  • PHP Manual
  • MongoCollection
  • Creates an index on the specified field(s) if it does not already exist

MongoCollection::ensureIndex

(PECL mongo >=0.9.0)

MongoCollection::ensureIndex — Creates an index on the specified field(s) if it does not already exist

说明

public MongoCollection::ensureIndex ( string|array $key|keys , array $options = array() ) : bool
Warning

This method is deprecated since version 1.5.0. Please use MongoCollection::createIndex() instead.

Creates an index on the specified field(s) if it does not already exist. Fields may be indexed with a direction (e.g. ascending or descending) or a special type (e.g. text, geospatial, hashed).

Note:

This method will use the » createIndexes database command when communicating with MongoDB 2.6+. For previous database versions, the method will perform an insert operation on the special system.indexes collection.

参数

keys

An array specifying the index's fields as its keys. For each field, the value is either the index direction or » index type. If specifying direction, specify 1 for ascending or -1 for descending.

options

An array of options for the index creation. Currently available options include:

  • "unique"

    Specify true to create a unique index. The default value is false. This option applies only to ascending/descending indexes.

    Note:

    When MongoDB indexes a field, if a document does not have a value for the field, a null value is indexed. If multiple documents do not contain a field, a unique index will reject all but the first of those documents. The "sparse" option may be used to overcome this, since it will prevent documents without the field from being indexed.

  • "sparse"

    Specify true to create a sparse index, which only indexes documents containing a specified field. The default value is false.

  • "expireAfterSeconds"

    The value of this option should specify the number of seconds after which a document should be considered expired and automatically removed from the collection. This option is only compatible with single-field indexes where the field will contain MongoDate values.

    Note:

    This feature is available in MongoDB 2.2+. See » Expire Data from Collections by Setting TTL for more information.

  • "name"

    A optional name that uniquely identifies the index.

    Note:

    By default, the driver will generate an index name based on the index's field(s) and ordering or type. For example, a compound index array("x" => 1, "y" => -1) would be named "x_1_y_-1" and a geospatial index array("loc" => "2dsphere") would be named "loc_2dsphere". For indexes with many fields, it is possible that the generated name might exceed MongoDB's » limit for index names. The "name" option may be used in that case to supply a shorter name.

  • "background"

    Builds the index in the background so that building an index does not block other database activities. Specify true to build in the background. The default value is false.

    Warning

    Prior to MongoDB 2.6.0, index builds on secondaries were executed as foreground operations, irrespective of this option. See » Building Indexes with Replica Sets for more information.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

The following option may be used with MongoDB 2.6+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

The following options may be used with MongoDB versions before 2.8:

  • "dropDups"

    Specify true to force creation of a unique index where the collection may contain duplicate values for a key. MongoDB will index the first occurrence of a key and delete all subsequent documents from the collection that contain a duplicate value for that key. The default value is false.

    Warning

    "dropDups" may delete data from your database. Use with extreme caution.

    Note:

    This option is not supported on MongoDB 2.8+. Index creation will fail if the collection contains duplicate values.

The following options may be used with MongoDB versions before 2.6:

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

返回值

Returns an array containing the status of the index creation. The array contains whether the operation succeeded ("ok"), the number of indexes before and after the operation ("numIndexesBefore" and "numIndexesAfter"), and whether the collection that the index belongs to has been created ("createdCollectionAutomatically"). If the index already existed and did not need to be created, a "note" field may be present in lieu of "numIndexesAfter".

With MongoDB 2.4 and earlier, a status document is only returned if the write concern is at least 1. Otherwise, true is returned. The fields in the status document are different, except for the "ok" field, which signals whether the index creation was successful. Additional fields are described in the documentation for MongoCollection::insert().

更新日志

版本 | 说明
PECL mongo 1.5.0 | Renamed the "wtimeout" option to "wTimeoutMS". Emits E_DEPRECATED when "wtimeout" is used. Renamed the "timeout" option to "socketTimeoutMS". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
PECL mongo 1.3.4 | Added "wtimeout" option.
PECL mongo 1.3.0 | Added "w" option. The options parameter no longer accepts a boolean to signify a unique index. Instead, this now has to be done with array('unique' => true).
PECL mongo 1.2.11 | Emits E_DEPRECATED when options is scalar.
PECL mongo 1.2.0 | Added "timeout" option.
PECL mongo 1.0.11 | The "safe" option will trigger a primary failover, if necessary. MongoException will be thrown if the index name (either generated or set) is longer than 128 bytes.
PECL mongo 1.0.5 | Added the "name" option to override index name creation.
PECL mongo 1.0.2 | Changed options parameter from boolean to array. Pre-1.0.2, the second parameter was an optional boolean value specifying a unique index.

错误／异常

Throws MongoException if the index name is longer than 128 bytes, or if the index specification is not an array.

Throws MongoDuplicateKeyException if the server could not create the unique index due to conflicting documents.

Throws MongoResultException if the server could not create the index due to an error.

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

范例

Example #1 MongoCollection::ensureIndex() example

<?php

$c = new MongoCollection($db, 'foo');

// create an index on 'x' ascending
$c->ensureIndex(array('x' => 1));

// create a unique index on 'y'
$c->ensureIndex(array('y' => 1), array('unique' => true));

// create a compound index on 'za' ascending and 'zb' descending
$c->ensureIndex(array('za' => 1, 'zb' => -1));

?>

Example #2 Geospatial Indexing

Mongo supports geospatial indexes, which allow you to search for documents near a given location or within a shape. The following example creates a geospatial index on the "loc" field:

<?php

$collection->ensureIndex(array('loc' => '2dsphere'));

?>

Example #3 Drop duplicates example

<?php

$collection->insert(array('username' => 'joeschmoe'));
$collection->insert(array('username' => 'joeschmoe'));

/* Index creation fails, since you cannot create a unique index on a field when
 * duplicates exist.
 */
$collection->ensureIndex(array('username' => 1), array('unique' => 1));

/* MongoDB will one of the conflicting documents and allow the unique index to
 * be created.
 */
$collection->ensureIndex(array('username' => 1), array('unique' => 1, 'dropDups' => 1));

/* We now have a unique index and subsequent inserts with the same username will
 * fail.
 */
$collection->insert(array('username' => 'joeschmoe'));

?>

参见

  • MongoCollection::createIndex() - Creates an index on the specified field(s) if it does not already exist
  • MongoCollection::deleteIndex() - Deletes an index from this collection
  • MongoCollection::deleteIndexes() - 删除集合的所有索引
  • The MongoDB » index and » index type documentation.


查询该集合，并返回结果集的 MongoCursor

  • ? MongoCollection::ensureIndex
  • MongoCollection::findAndModify ?
  • PHP Manual
  • MongoCollection
  • 查询该集合，并返回结果集的 MongoCursor

MongoCollection::find

(PECL mongo >=0.9.0)

MongoCollection::find — 查询该集合，并返回结果集的 MongoCursor

说明

public MongoCollection::find
 ( array $query = array()
, array $fields = array()
) : MongoCursor

参数

query

要搜索的字段。 MongoDB 的查询语言十分宽泛。 PHP 驱动在几乎所有的情况下会把查询直接传入服务器，所以阅读 MongoDB 关于 » find 的核心文档是个不错的主意。

Warning

请确保所有指定的查询操作符（以 $ 开头）是用单引号的，这样 PHP 才不会尝试用 $exists 变量的值来替换 "$exists" 命令。

fields

返回结果的字段。Array 的格式是 array('fieldname' => true, 'fieldname2' => true)。 _id 字段总会返回。

返回值

返回搜索结果的游标。

范例

Example #1 MongoCollection::find() 例子

该例子演示了基本的搜索选项。

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'produce');

// 搜索水果
$fruitQuery = array('Type' => 'Fruit');

$cursor = $collection->find($fruitQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

// 搜索甜的产品 Taste is a child of Details.
$sweetQuery = array('Details.Taste' => 'Sweet');
echo "Sweet\n";
$cursor = $collection->find($sweetQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

以上例程会输出：

array(4) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "50a87dd084f045a19b220dd6"
  }
  ["Name"]=>
  string(5) "Apple"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(5) "Sweet"
    ["Colour"]=>
    string(3) "Red"
  }
}
array(4) {
  ["_id"]=>
  object(MongoId)#8 (1) {
    ["$id"]=>
    string(24) "50a87de084f045a19b220dd7"
  }
  ["Name"]=>
  string(5) "Lemon"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(4) "Sour"
    ["Colour"]=>
    string(5) "Green"
  }
}

Sweet:
array(4) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "50a87dd084f045a19b220dd6"
  }
  ["Name"]=>
  string(5) "Apple"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(5) "Sweet"
    ["Colour"]=>
    string(3) "Red"
  }
}

更多关于游标如何使用的信息，参见 MongoCursor。

Example #2 MongoCollection::find() 例子

这个例子演示了如何搜索一个范围。

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'phpmanual');

// search for documents where 5 < x < 20
$rangeQuery = array('x' => array( '$gt' => 5, '$lt' => 20 ));

$cursor = $collection->find($rangeQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

以上例程会输出：

array(2) {
  ["_id"]=>
  object(MongoId)#10 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000000"
  }
  ["x"]=>
  int(12)
}
array(2) {
  ["_id"]=>
  object(MongoId)#11 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000001"
  }
  ["x"]=>
  int(12)
}

更多关于游标如何使用的信息，参见 MongoCursor。

Example #3 使用 $where 的 MongoCollection::find() 例子

这个例子演示了如何搜索一个集合，并用 javascript 代码来筛选结果集。

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'phpmanual');

$js = "function() {
    return this.name == 'Joe' || this.age == 50;
}";
$cursor = $collection->find(array('$where' => $js));
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

以上例程会输出：

array(3) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000002"
  }
  ["name"]=>
  string(3) "Joe"
  ["age"]=>
  int(20)
}

Example #4 使用 $in 的 MongoCollection::find() 例子

这个例子演示了使用 $in 操作符来搜索集合。

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'phpmanual');

$cursor = $collection->find(array(
    'name' => array('$in' => array('Joe', 'Wendy'))
));

?>

以上例程会输出：

array(3) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000002"
  }
  ["name"]=>
  string(3) "Joe"
  ["age"]=>
  int(20)
}

Example #5 以数组形式获取结果集

返回 MongoCursor。 常常在开始的时候，人们更习惯使用数组。 使用 iterator_to_array() 将游标转换成一个数组。

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'phpmanual');

$cursor = $collection->find();
$array = iterator_to_array($cursor);

?>

以上例程会输出：

array(3) {
  ["4ebc40af10b89f5149000000"]=>
  array(2) {
    ["_id"]=>
    object(MongoId)#6 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000000"
    }
    ["x"]=>
    int(12)
  }
  ["4ebc40af10b89f5149000001"]=>
  array(2) {
    ["_id"]=>
    object(MongoId)#11 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000001"
    }
    ["x"]=>
    int(12)
  }
  ["4ebc40af10b89f5149000002"]=>
  array(3) {
    ["_id"]=>
    object(MongoId)#12 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000002"
    }
    ["name"]=>
    string(3) "Joe"
    ["age"]=>
    int(20)
  }
}

使用 iterator_to_array() 会让驱动将强制载入所有搜索结果集到内存，所以对超过内存大小的结果集不要这么做！

同时，有些系统集合不具有 _id 字段。 如果你处理一个可能没有 _id 字段的集合，需要将 false 传入 iterator_to_array() 第二个参数（这样它不会尝试使用不存在的 _id 的值作为数组键）。

参见

  • MongoCollection::findOne() - Queries this collection, returning a single element
  • MongoCollection::insert() - 插入文档到集合中
  • MongoDB » find 的核心文档。


Update a document and return it

  • ? MongoCollection::find
  • MongoCollection::findOne ?
  • PHP Manual
  • MongoCollection
  • Update a document and return it

MongoCollection::findAndModify

(PECL mongo >=1.3.0)

MongoCollection::findAndModify — Update a document and return it

说明

public MongoCollection::findAndModify ( array $query , array $update = ? , array $fields = ? , array $options = ? ) : array

The findAndModify command atomically modifies and returns a single document. By default, the returned document does not include the modifications made on the update. To return the document with the modifications made on the update, use the new option.

参数

query

The query criteria to search for.

update

The update criteria.

fields

Optionally only return these fields.

options

An array of options to apply, such as remove the match document from the DB and return it.

Option | 说明
sort array | Determines which document the operation will modify if the query selects multiple documents. findAndModify will modify the first document in the sort order specified by this argument.
remove bool | Optional if update field exists. When true, removes the selected document. The default is false.
update array | Optional if remove field exists. Performs an update of the selected document.
new bool | Optional. When true, returns the modified document rather than the original. The findAndModify method ignores the new option for remove operations. The default is false.
upsert bool | Optional. Used in conjunction with the update field. When true, the findAndModify command creates a new document if the query returns no documents. The default is false. In MongoDB 2.2, the findAndModify command returns null when upsert is true.

返回值

Returns the original document, or the modified document when new is set.

错误／异常

Throws MongoResultException on failure.

范例

Example #1 MongoCollection::findAndModify() example

<?php
$m = new Mongo;
$col = $m->selectDB("test")->jobs;

$col->insert(array(
     "name" => "Next promo",
     "inprogress" => false,
     "priority" => 0,
     "tasks" => array( "select product", "add inventory", "do placement"),
) );

$col->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 1,
     "tasks" => array( "run sales report", "email report" )
) );

$col->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 2,
     "tasks" => array( "run marketing report", "email report" )
    ),
    array("w" => 1)
);

$retval = $col->findAndModify(
     array("inprogress" => false, "name" => "Biz report"),
     array('$set' => array('inprogress' => true, "started" => new MongoDate())),
     null,
     array(
        "sort" => array("priority" => -1),
        "new" => true,
    )
);

var_dump($retval);
?>

以上例程的输出类似于：

array(6) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "5091b5b244415e8cc3000002"
  }
  ["inprogress"]=>
  bool(true)
  ["name"]=>
  string(10) "Biz report"
  ["priority"]=>
  int(2)
  ["started"]=>
  object(MongoDate)#8 (2) {
    ["sec"]=>
    int(1351726514)
    ["usec"]=>
    int(925000)
  }
  ["tasks"]=>
  array(2) {
    [0]=>
    string(20) "run marketing report"
    [1]=>
    string(12) "email report"
  }
}

Example #2 MongoCollection::findAndModify() error handling

<?php
$m = new Mongo;
$col = $m->selectDB("test")->jobs;
try {
    $retval = $col->findAndModify(
         array("inprogress" => false, "name" => "Next promo"),
         array('$pop' => array("tasks" => -1)),
         array("tasks" => array('$pop' => array("stuff"))),
         array("new" => true)
    );
} catch(MongoResultException $e) {
    echo $e->getCode(), " : ", $e->getMessage(), "\n";
    var_dump($e->getDocument());
}

?>

以上例程的输出类似于：

13097 : exception: Unsupported projection option: $pop
array(3) {
  ["errmsg"]=>
  string(46) "exception: Unsupported projection option: $pop"
  ["code"]=>
  int(13097)
  ["ok"]=>
  float(0)
}

参见

  • The MongoDB » findAndModify command docs


Queries this collection, returning a single element

  • ? MongoCollection::findAndModify
  • MongoCollection::__get ?
  • PHP Manual
  • MongoCollection
  • Queries this collection, returning a single element

MongoCollection::findOne

(PECL mongo >=0.9.0)

MongoCollection::findOne — Queries this collection, returning a single element

说明

public MongoCollection::findOne
 ( array $query = array()
, array $fields = array()
, array $options = array()
) : array

As opposed to MongoCollection::find(), this method will return only the first result from the result set, and not a MongoCursor that can be iterated over.

参数

query

The fields for which to search. MongoDB's query language is quite extensive. The PHP driver will in almost all cases pass the query straight through to the server, so reading the MongoDB core docs on » find is a good idea.

Warning

Please make sure that for all special query operaters (starting with $) you use single quotes so that PHP doesn't try to replace "$exists" with the value of the variable $exists.

fields

Fields of the results to return. The array is in the format array('fieldname' => true, 'fieldname2' => true). The _id field is always returned.

options

This parameter is an associative array of the form array("name" => <value>, ...). Currently supported options are:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

返回值

Returns record matching the search or null.

错误／异常

Throws MongoConnectionException if it cannot reach the database.

更新日志

版本 | 说明
PECL mongo 1.5.0 | Added optional options argument.

范例

Example #1 MongoCollection::findOne() document by its id.

This example demonstrates how to find a single document in a collection by its id.

<?php

$articles = $mongo->my_db->articles;

$article = $articles->findOne(array('_id' => new MongoId('47cc67093475061e3d9536d2')));

?>

Example #2 MongoCollection::findOne() document by some condition.

This example demonstrates how to find a single document in a collection by some condition and limiting the returned fields.

<?php

$users = $mongo->my_db->users;
$user = $users->findOne(array('username' => 'jwage'), array('password'));
print_r($user);

?>

以上例程的输出类似于：

Array
(
    [_id] => MongoId Object
        (
        )

    [password] => test
)

Notice how even though the document does have a username field, we limited the results to only contain the password field.

参见

  • MongoCollection::find() - 查询该集合，并返回结果集的 MongoCursor
  • MongoCollection::insert() - 插入文档到集合中
  • MongoDB core docs on » find.


Gets a collection

  • ? MongoCollection::findOne
  • MongoCollection::getDBRef ?
  • PHP Manual
  • MongoCollection
  • Gets a collection

MongoCollection::__get

(PECL mongo >=1.0.2)

MongoCollection::__get — Gets a collection

说明

public MongoCollection::__get ( string $name ) : MongoCollection

A concise syntax for getting a collection with a dot-separated name. If a collection name contains strange characters, you may have to use MongoDB::selectCollection() instead.

<?php

$mongo = new MongoClient();

// the following two lines are equivalent
$collection = $mongo->selectDB("foo")->selectCollection("bar.baz");
$collection = $mongo->foo->bar->baz;

?>

参数

name

The next string in the collection name.

返回值

Returns the collection.


Fetches the document pointed to by a database reference

  • ? MongoCollection::__get
  • MongoCollection::getIndexInfo ?
  • PHP Manual
  • MongoCollection
  • Fetches the document pointed to by a database reference

MongoCollection::getDBRef

(PECL mongo >=0.9.0)

MongoCollection::getDBRef — Fetches the document pointed to by a database reference

说明

public MongoCollection::getDBRef ( array $ref ) : array

参数

ref

A database reference.

返回值

Returns the database document pointed to by the reference.

范例

Example #1 MongoCollection::getDBRef() example

<?php

$playlists = $db->playlists;

$myList = $playlists->findOne(array('username' => 'me'));

// fetch each song in the playlist
foreach ($myList['songlist'] as $songRef) {
    $song = $playlists->getDBRef($songRef);
    echo $song['title'] . "\n";
}

?>

以上例程的输出类似于：

Dazed and Confused
Ma na ma na
Bohemian Rhapsody

In the above example each $songRef looks something like the following:
    Array
    (
        [$ref] => songs
        [$id] => 49902cde5162504500b45c2c
    )

参见

  • MongoCollection::createDBRef() - 创建一个数据库引用


Returns information about indexes on this collection

  • ? MongoCollection::getDBRef
  • MongoCollection::getName ?
  • PHP Manual
  • MongoCollection
  • Returns information about indexes on this collection

MongoCollection::getIndexInfo

(PECL mongo >=0.9.0)

MongoCollection::getIndexInfo — Returns information about indexes on this collection

说明

public MongoCollection::getIndexInfo ( ) : array

参数

此函数没有参数。

返回值

This function returns an array in which each element describes an index. Elements will contain the values name for the name of the index, ns for the namespace (a combination of the database and collection name), and key for a list of all fields in the index and their ordering. Additional values may be present for special indexes, such as unique or sparse.

范例

Example #1 MongoCollection::getIndexInfo() example

<?php

$m = new MongoClient();
$c = $m->selectCollection('test', 'venues');
var_dump($c->getIndexInfo());

?>

以上例程的输出类似于：

array(4) {
  [0]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["_id"]=>
      int(1)
    }
    ["name"]=>
    string(4) "_id_"
    ["ns"]=>
    string(11) "test.venues"
  }
  [1]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["name"]=>
      float(1)
    }
    ["name"]=>
    string(6) "name_1"
    ["ns"]=>
    string(11) "test.venues"
  }
  [2]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(2) {
      ["type"]=>
      float(1)
      ["createdAt"]=>
      float(-1)
    }
    ["name"]=>
    string(19) "type_1_createdAt_-1"
    ["ns"]=>
    string(11) "test.venues"
  }
  [3]=>
  array(5) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["location"]=>
      string(8) "2dsphere"
    }
    ["name"]=>
    string(17) "location_2dsphere"
    ["ns"]=>
    string(11) "test.venues"
    ["2dsphereIndexVersion"]=>
    int(2)
  }
}

参见

MongoDB core docs on » vanilla indexes and » geospatial indexes.


返回这个集合的名称

  • ? MongoCollection::getIndexInfo
  • MongoCollection::getReadPreference ?
  • PHP Manual
  • MongoCollection
  • 返回这个集合的名称

MongoCollection::getName

(PECL mongo >=0.9.0)

MongoCollection::getName — 返回这个集合的名称

说明

public MongoCollection::getName ( ) : string

参数

此函数没有参数。

返回值

获取这个集合的名称。

范例

Example #1 MongoCollection::getName() 例子

<?php

$m = new MongoClient();
$c = $m->foo->bar->baz;

echo "Working with collection " . $c->getName() . ".\n";

// the full namespace is given by the MongoCollection::__toString() method
echo "Working in namespace $c.\n";

?>

以上例程的输出类似于：

Working with collection bar.baz.
Working in namespace foo.bar.baz.


Get the read preference for this collection

  • ? MongoCollection::getName
  • MongoCollection::getSlaveOkay ?
  • PHP Manual
  • MongoCollection
  • Get the read preference for this collection

MongoCollection::getReadPreference

(PECL mongo >=1.3.0)

MongoCollection::getReadPreference — Get the read preference for this collection

说明

public MongoCollection::getReadPreference ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

更新日志

版本 | 说明
PECL mongo 1.3.3 | The return value has changed to be consistent with MongoCollection::setReadPreference(). The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.

范例

Example #1 MongoCollection::getReadPreference() return value example

<?php

$m = new MongoClient();
$c = $m->test->users;
$c->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($c->getReadPreference());
?>

以上例程会输出：

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

参见

  • The read preferences documentation.
  • MongoCollection::setReadPreference() - Set the read preference for this collection


Get slaveOkay setting for this collection

  • ? MongoCollection::getReadPreference
  • MongoCollection::getWriteConcern ?
  • PHP Manual
  • MongoCollection
  • Get slaveOkay setting for this collection

MongoCollection::getSlaveOkay

(PECL mongo >=1.1.0)

MongoCollection::getSlaveOkay — Get slaveOkay setting for this collection

说明

public MongoCollection::getSlaveOkay ( ) : bool

See the query section of this manual for information on distributing reads to secondaries.

参数

此函数没有参数。

返回值

Returns the value of slaveOkay for this instance.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

参见

  • 读取首选项
  • MongoCollection::getReadPreference() - Get the read preference for this collection


Get the write concern for this collection

  • ? MongoCollection::getSlaveOkay
  • MongoCollection::group ?
  • PHP Manual
  • MongoCollection
  • Get the write concern for this collection

MongoCollection::getWriteConcern

(PECL mongo >=1.5.0)

MongoCollection::getWriteConcern — Get the write concern for this collection

说明

public MongoCollection::getWriteConcern ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the write concern. The array contains the values w for an integer acknowledgement level or string mode, and wtimeout denoting the maximum number of milliseconds to wait for the server to satisfy the write concern.

范例

Example #1 MongoCollection::getWriteConcern() return value example

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
$coll = $mc->selectCollection('test', 'foo');
var_dump($coll->getWriteConcern());

$coll->setWriteConcern(1, 1000);
var_dump($coll->getWriteConcern());
?>

以上例程会输出：

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

参见

  • The write concern documentation.
  • MongoCollection::setWriteConcern() - Set the write concern for this database


Performs an operation similar to SQL's GROUP BY command

  • ? MongoCollection::getWriteConcern
  • MongoCollection::insert ?
  • PHP Manual
  • MongoCollection
  • Performs an operation similar to SQL's GROUP BY command

MongoCollection::group

(PECL mongo >=0.9.2)

MongoCollection::group — Performs an operation similar to SQL's GROUP BY command

说明

public MongoCollection::group ( mixed $keys , array $initial , MongoCode $reduce , array $options = array() ) : array

参数

keys

Fields to group by. If an array or non-code object is passed, it will be the key used to group results.

1.0.4+: If keys is an instance of MongoCode, keys will be treated as a function that returns the key to group by (see the "Passing a keys function" example below).

initial

Initial value of the aggregation counter object.

reduce

A function that takes two arguments (the current document and the aggregation to this point) and does the aggregation.

options

Optional parameters to the group command. Valid options include:

  • "condition"

    Criteria for including a document in the aggregation.

  • "finalize"

    Function called once per unique key that takes the final output of the reduce function.

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation on the server (does not include idle time). If the operation is not completed by the server within the timeout period, a MongoExecutionTimeoutException will be thrown.

返回值

Returns an array containing the result.

更新日志

版本 | 说明
PECL mongo 1.5.0 | Added "maxTimeMS" option.
PECL mongo 1.2.11 | Emits E_DEPRECATED when options is scalar.

范例

Example #1 MongoCollection::group() example

This groups documents by category and creates a list of names within that category.

<?php

$collection->insert(array("category" => "fruit", "name" => "apple"));
$collection->insert(array("category" => "fruit", "name" => "peach"));
$collection->insert(array("category" => "fruit", "name" => "banana"));
$collection->insert(array("category" => "veggie", "name" => "corn"));
$collection->insert(array("category" => "veggie", "name" => "broccoli"));

$keys = array("category" => 1);

$initial = array("items" => array());

$reduce = "function (obj, prev) { prev.items.push(obj.name); }";

$g = $collection->group($keys, $initial, $reduce);

echo json_encode($g['retval']);

?>

以上例程的输出类似于：

[{"category":"fruit","items":["apple","peach","banana"]},{"category":"veggie","items":["corn","broccoli"]}]

Example #2 MongoCollection::group() example

This example doesn't use any key, so every document will be its own group. It also uses a condition: only documents that match this condition will be processed by the grouping function.

<?php

$collection->save(array("a" => 2));
$collection->save(array("b" => 5));
$collection->save(array("a" => 1));

// use all fields
$keys = array();

// set intial values
$initial = array("count" => 0);

// JavaScript function to perform
$reduce = "function (obj, prev) { prev.count++; }";

// only use documents where the "a" field is greater than 1
$condition = array('condition' => array("a" => array( '$gt' => 1)));

$g = $collection->group($keys, $initial, $reduce, $condition);

var_dump($g);

?>

以上例程的输出类似于：

array(4) {
  ["retval"]=>
  array(1) {
    [0]=>
    array(1) {
      ["count"]=>
      float(1)
    }
  }
  ["count"]=>
  float(1)
  ["keys"]=>
  int(1)
  ["ok"]=>
  float(1)
}

Example #3 Passing a keys function

If you want to group by something other than a field name, you can pass a function as the first parameter of MongoCollection::group() and it will be run against each document. The return value of the function will be used as its grouping value.

This example demonstrates grouping by the num field modulo 4.

<?php

$c->group(new MongoCode('function(doc) { return {mod : doc.num % 4}; }'),
     array("count" => 0),
     new MongoCode('function(current, total) { total.count++; }'));

?>


插入文档到集合中

  • ? MongoCollection::group
  • MongoCollection::parallelCollectionScan ?
  • PHP Manual
  • MongoCollection
  • 插入文档到集合中

MongoCollection::insert

(PECL mongo >=0.9.0)

MongoCollection::insert — 插入文档到集合中

说明

public MongoCollection::insert ( array|object $a , array $options = array() ) : bool|array

发送到数据库的所有字符串必须是 UTF-8 的。如果有字符串不是 UTF-8，将会抛出 MongoException 异常。 要插入（或者查询）一个非 UTF-8 的字符串，请使用 MongoBinData。

参数

a

一个数组或对象。如果使用的是一个对象，它不能有 protected 或 private 的属性。

Note:

如果参数不具有 _id 键或属性， 将会创建一个新的 MongoId 实例，并赋值给它。 这种特殊行为不意味着参数是传引用的。

options

插入的选项。

  • "fsync"

    Boolean, defaults to false. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If true, an acknowledged insert is implied and this option will override setting "w" to 0.

    Note: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to false. Forces the write operation to block until it is synced to the journal on disk. If true, an acknowledged write is implied and this option will override setting "w" to 0.

    Note: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

返回值

如果设置了 "w" 选项，将会返回包含插入状态的数组。 否则，将会返回一个 true 代表数组不是空的（空数组将会抛出 MongoException ）。

如果返回了一个 array，将会有以下键：

ok

它应该几乎总是 1（除非 last_error 本身出现错误）。

err

如果这个字段不是 null，说明刚才的操作出现了错误。 如果有这个字段，它将包含一个字符串，用于描述出现的错误信息。

code

如果发生了一个数据库错误，相应的错误码会传到客户端。

errmsg

如果数据库命令出现了错误，将会设置这个字段。同时 ok 也会是 0. 例如，设置了 w 并且超时了，errmsg 将会是 "timed out waiting for slaves" 并且 ok 是 0。 如果设置了这个字段，它会是发生的错误的字符串描述。

n

如果最后的操作是插入、更新或删除，将会返回受影响的对象数量。对于插入操作，这个值总是 0。

wtimeout

等待复制直到超时的时间。

waited

在超时前，要等待操作多久。

wtime

如果设置了 w 并且操作成功了，等到复制到 w 台服务器的时间。

upserted

如果发生了一次 upsert，这个字段将会包含新记录的 _id。 对于 upsert，不管是该字段还是 updatedExisting 都会被保留（除非发生了一个错误）。

updatedExisting

如果一个 upsert 更新了一个存在的元素，这个字段将会是 true。 对于 upsert，无论是这个字段 还是 upserted 都会被保留（除非发生了错误）。

错误／异常

如果插入的文档是空的，或者包含零长度的键，将会抛出 MongoException。 尝试插入包含 protected 和 private 属性的对象将会导致零长度键（zero-length key）的错误。

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

更新日志

版本 | 说明
1.3.0 | options 参数不再接受 boolean 来标识一个确认的写入。 现在，你可以通过 array('w' => 1) 设置（ MongoClient 默认的行为）
1.2.0 | 增加了 "timeout" 选项。
1.0.11 | 如果设置了 "safe"，出现 "not master" 错误时断开连接。
1.0.9 | "safe" 选项接受 integer 值，之前只接受 boolean 值。 增加 "fsync" 选项。 如果设置了 "safe" 选项，返回类型改成包含错误信息的 array。 否则，和之前一样返回 boolean。
1.0.5 | 修改第二个参数为选项数组。在 1.0.5 之前，第二个参数是 boolean，指示 "safe" 选项。
1.0.1 | 如果设置了 "safe" 选项并且插入失败了，将会抛出 MongoCursorException。

范例

Example #1 MongoCollection::insert() _id 例子

如果没有 _id，则会添加一个到插入的文档中。 基于参数传入的方式，在调用代码时可能无法产生有效 _id。

<?php

$m = new MongoClient();
$collection = $m->selectCollection('test', 'phpmanual');
// 如果使用的是 array 字面语法，将无法成功生成 _id
$collection->insert(array('x' => 1));

// 通过传 array 的变量可以生成 _id
$a = array('x' => 2);
$collection->insert($a);
var_dump($a);

// 通过传引用的 array 无法生成 _id
$b = array('x' => 3);
$ref = &$b;
$collection->insert($ref);
var_dump($ref);

// 没有在包裹的函数中触发 copy-on-write 时 _id 有效
function insert_no_cow($collection, $document)
{
    $collection->insert($document);
}

$c = array('x' => 4);
insert_no_cow($collection, $c);
var_dump($c);

// 在包裹的函数中触发 copy-on-write 时 _id 无效
function insert_cow($collection, $document)
{
    $document['y'] = 1;
    $collection->insert($document);
}

$d = array('x' => 5);
insert_cow($collection, $d);
var_dump($d);

?>

以上例程的输出类似于：

array(2) {
  ["x"]=>
  int(2)
  ["_id"]=>
  object(MongoId)#4 (0) {
  }
}
array(1) {
  ["x"]=>
  int(3)
}
array(2) {
  ["x"]=>
  int(4)
  ["_id"]=>
  object(MongoId)#5 (0) {
  }
}
array(1) {
  ["x"]=>
  int(5)
}

Example #2 MongoCollection::insert() 确认写入的例子

这个例子显示了设置了 w 后，插入两个具有相同 _id 的元素时，导致抛出 MongoCursorException 的例子。

<?php

$person = array("name" => "Joe", "age" => 20);
$collection->insert($person);

// 现在 $person 具有一个 _id 字段，所以我们再次
// 保存它的时候，将会得到一个异常
try {
    $collection->insert($person, array("w" => 1));
} catch(MongoCursorException $e) {
    echo "Can't save the same person twice!\n";
}

?>

参见

  • MongoCollection::batchInsert() - Inserts multiple documents into this collection
  • MongoCollection::update() - Update records based on a given criteria
  • MongoCollection::find() - 查询该集合，并返回结果集的 MongoCursor
  • MongoCollection::remove() - 从集合中删除记录
  • MongoDB » insert 的核心文档。


Returns an array of cursors to iterator over a full collection in parallel

  • ? MongoCollection::insert
  • MongoCollection::remove ?
  • PHP Manual
  • MongoCollection
  • Returns an array of cursors to iterator over a full collection in parallel

MongoCollection::parallelCollectionScan

(PECL mongo >=1.5.0)

MongoCollection::parallelCollectionScan — Returns an array of cursors to iterator over a full collection in parallel

说明

public MongoCollection::parallelCollectionScan ( int $num_cursors ) : array[MongoCommandCursor]

This method returns an array of a maximum of num_cursors cursors. An iteration over one of the returned cursors results in a partial set of documents for a collection. Iteration over all the returned cursors results in getting every document back from the collection.

This method is a wrapper for the parallelCollectionScan MongoDB command.

参数

num_cursors

The number of cursors to request from the server. Please note, that the server can return less cursors than you requested.

返回值

Returns an array of MongoCommandCursor objects.

范例

Example #1 MongoCollection::parallelCollectionScan() example

Returning all documents in a collection by using multiple cursors.

<?php
$m = new MongoClient;
$c = $m->demo->cities;

/* Request three cursors */
$cursors = $c->parallelCollectionScan( 3 );

/* Add all the cursors to the MultipleIterator */
$mi = new MultipleIterator( MultipleIterator::MIT_NEED_ANY );
foreach ( $cursors as $cursor )
{
    $mi->attachIterator( $cursor );
}

/* Iterate over all the associated cursors */
foreach ( $mi as $items )
{
    foreach ( $items as $item )
    {
        if ( $item !== NULL )
        {
            echo $item['name'], "\n";
        }
    }
}
?>

参见

  • MultipleIterator
  • MongoCommandCursor
  • MongoDB::command() - 执行一条 Mongo 指令


从集合中删除记录

  • ? MongoCollection::parallelCollectionScan
  • MongoCollection::save ?
  • PHP Manual
  • MongoCollection
  • 从集合中删除记录

MongoCollection::remove

(PECL mongo >=0.9.0)

MongoCollection::remove — 从集合中删除记录

说明

public MongoCollection::remove
 ( array $criteria = array()
, array $options = array()
) : bool|array

参数

criteria

待删除记录的描述。

options

删除的选项。

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "justOne"

    最多只删除一个匹配的记录。

  • "fsync"

    Boolean, defaults to false. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If true, an acknowledged insert is implied and this option will override setting "w" to 0.

    Note: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to false. Forces the write operation to block until it is synced to the journal on disk. If true, an acknowledged write is implied and this option will override setting "w" to 0.

    Note: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

返回值

如果设置了 "w" 选项，将会返回包含删除状态的 array。 否则返回 true。

状态数组字段的解释位于 MongoCollection::insert() 的文档。

错误／异常

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

更新日志

版本 | 说明
1.3.0 | options 参数不再接受 boolean 值来代表 "justOne"。 现在，必须使用 array('justOne' => true) 作为替代。
1.2.11 | 当 options 是 scalar 时产生一个 E_DEPRECATED 警告。
1.2.0 | 添加 "timeout" 选项。
1.0.11 | 在设置了 "safe" 之后，将在出现 "not master" 错误时断开连接。
1.0.9 | 添加了 "safe" 选项对 integer 的支持，之前只接受 boolean 值。 添加了 "fsync" 选项。 当使用了 "safe" 选项时将会返回包含错误信息的数组。 否则和之前一样返回一个 boolean。
1.0.5 | 修改第二个参数为选项的 array。在 1.0.5 之前，第二个选项是 boolean 值， 代表了 "safe" 选项。

范例

Example #1 MongoCollection::remove() 的 justOne 例子

<?php

$radioactive = $db->radioactive;

// 统计那有多少个钚
$remaining = $radioactive->count(array('type' => 94));

$halflife = $remaining/2;

// 删除一半
while ($halflife > 0) {
    $radioactive->remove(array('type' => 94), array("justOne" => true));
    $halflife--;
}

?>

参见

  • MongoCollection::insert() - 插入文档到集合中
  • MongoCollection::update() - Update records based on a given criteria
  • MongoDB » remove 的核心文档。


保存一个文档到集合

  • ? MongoCollection::remove
  • MongoCollection::setReadPreference ?
  • PHP Manual
  • MongoCollection
  • 保存一个文档到集合

MongoCollection::save

(PECL mongo >=0.9.0)

MongoCollection::save — 保存一个文档到集合

说明

public MongoCollection::save ( array|object $document , array $options = array() ) : mixed

如果对象来自数据库，则更新现有的数据库对象，否则插入对象。

参数

document

要保存的 Array 或 Object。 如果用的是 Object，它不能有 protected 或 private 的属性。

Note:

如果参数不具有 _id 的键或者属性，将会创建并赋值一个新的 MongoId 实例。 关于此行为的更多信息，参见 MongoCollection::insert()。

options

此次保存的选项。

  • "fsync"

    Boolean, defaults to false. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If true, an acknowledged insert is implied and this option will override setting "w" to 0.

    Note: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to false. Forces the write operation to block until it is synced to the journal on disk. If true, an acknowledged write is implied and this option will override setting "w" to 0.

    Note: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

返回值

如果设置了 w，返回包含此次保存状态的一个 array。 否则，返回一个 boolean，表示数组是否为空（空数组不会被插入）。

错误／异常

如果插入的文档时空的，或者包含零长度的键，将抛出 MongoException。 尝试插入包含 protected 和 private 属性的对象将导致零长度键的错误。

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

更新日志

版本 | 说明
1.5.0 | 增加 "wTimeoutMS" 选项来代替 "wtimeout"。 使用 "wtimeout" 时出现 E_DEPRECATED 错误。 新增 "socketTimeoutMS" 选项来代替 "timeout"。 使用 "timeout" 时出现 E_DEPRECATED 错误。 使用 "safe" 时出现 E_DEPRECATED 错误。
1.2.0 | 增加 "timeout" 选项。
1.0.11 | 设置 "safe" 时，当出现 "not master" 错误时主动断开连接。
1.0.9 | 增加 "fsync" 选项。
1.0.5 | 增加 options 参数。

范例

Example #1 MongoCollection::save() 例子

<?php

$obj = array('x' => 1);

// 插入 $obj 到 db
$collection->save($obj);
var_dump($obj);

// 增加额外的字段
$obj['foo'] = 'bar';

// $obj 不能被再次插入，导致 duplicate _id 错误
$collection->insert($obj);

// 保存、更新附带新字段的 $obj
$collection->save($obj);

?>

以上例程的输出类似于：

array(2) {
  ["x"]=>
  int(1)
  ["_id"]=>
  object(MongoId)#4 (1) {
    ["$id"]=>
    string(24) "50b6afe544415ed606000000"
  }
}


Set the read preference for this collection

  • ? MongoCollection::save
  • MongoCollection::setSlaveOkay ?
  • PHP Manual
  • MongoCollection
  • Set the read preference for this collection

MongoCollection::setReadPreference

(PECL mongo >=1.3.0)

MongoCollection::setReadPreference — Set the read preference for this collection

说明

public MongoCollection::setReadPreference ( string $read_preference , array $tags = ? ) : bool

参数

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

返回值

Returns true on success, or false otherwise.

错误／异常

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

范例

Example #1 MongoCollection::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient();
$c = $m->test->users;

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$c->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

参见

  • The read preferences documentation.
  • MongoCollection::getReadPreference() - Get the read preference for this collection


Change slaveOkay setting for this collection

  • ? MongoCollection::setReadPreference
  • MongoCollection::setWriteConcern ?
  • PHP Manual
  • MongoCollection
  • Change slaveOkay setting for this collection

MongoCollection::setSlaveOkay

(PECL mongo >=1.1.0)

MongoCollection::setSlaveOkay — Change slaveOkay setting for this collection

说明

public MongoCollection::setSlaveOkay ( bool $ok = true ) : bool

See the query section of this manual for information on distributing reads to secondaries.

参数

ok

If reads should be sent to secondary members of a replica set for all possible queries using this MongoCollection instance.

返回值

Returns the former value of slaveOkay for this instance.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

参见

  • 读取首选项
  • MongoCollection::setReadPreference() - Set the read preference for this collection


Set the write concern for this database

  • ? MongoCollection::setSlaveOkay
  • MongoCollection::toIndexString ?
  • PHP Manual
  • MongoCollection
  • Set the write concern for this database

MongoCollection::setWriteConcern

(PECL mongo >=1.5.0)

MongoCollection::setWriteConcern — Set the write concern for this database

说明

public MongoCollection::setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool

参数

w

The write concern. This may be an integer denoting the number of servers required to acknowledge the write, or a string mode (e.g. "majority").

wtimeout

The maximum number of milliseconds to wait for the server to satisfy the write concern.

返回值

Returns true on success, or false otherwise.

错误／异常

Emits E_WARNING if the w parameter is not an integer or string value.

范例

Example #1 MongoDB::setWriteConcern() example

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');
$coll = $mc->selectCollection('test', 'foo');

// Require that the majority of servers in the replica set acknowledge writes
// within three seconds.
$coll->setWriteConcern('majority', 3000);
?>

参见

  • The write concern documentation.
  • MongoCollection::getWriteConcern() - Get the write concern for this collection


Converts keys specifying an index to its identifying string

  • ? MongoCollection::setWriteConcern
  • MongoCollection::__toString ?
  • PHP Manual
  • MongoCollection
  • Converts keys specifying an index to its identifying string

MongoCollection::toIndexString

(PECL mongo >=0.9.0)

MongoCollection::toIndexString — Converts keys specifying an index to its identifying string

说明

static protected MongoCollection::toIndexString ( mixed $keys ) : string
Warning

This method is deprecated since version 1.5.0.

参数

keys

Field or fields to convert to the identifying string

返回值

Returns a string that describes the index.

范例

Example #1 MongoCollection::toIndexString() example

This example shows how you can create an index name out of keys. Because this is a protected (static) method, you need to overload it in a child class first.

<?php
// Create inherited class to make the method "public".
class MyCollection extends MongoCollection
{
    static public function toIndexString($a)
    {
        return parent::toIndexString($a);
    }
}

echo MyCollection::toIndexString("foo"), "\n";
// Outputs: foo_1

echo MyCollection::toIndexString(array('name' => 1, 'age' => -1)), "\n";
// Outputs: name_1_age_-1
?>

参见

MongoDB core docs on » indexes.

更新日志

版本 | 说明
PECL mongo 1.5.0 | This method has been deprecated.


String representation of this collection

  • ? MongoCollection::toIndexString
  • MongoCollection::update ?
  • PHP Manual
  • MongoCollection
  • String representation of this collection

MongoCollection::__toString

(PECL mongo >=0.9.0)

MongoCollection::__toString — String representation of this collection

说明

public MongoCollection::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the full name of this collection.

范例

Example #1 MongoCollection::__toString() example

<?php

$m = new MongoClient();

$c1 = $m->foo->bar->baz;
echo "Working with collection $c1.";

$c2 = $m->selectCollection('[]', '&');
echo "Working with collection $c2.";

?>

以上例程的输出类似于：

Working with collection foo.bar.baz.
Working with collection [].&.


Update records based on a given criteria

  • ? MongoCollection::__toString
  • MongoCollection::validate ?
  • PHP Manual
  • MongoCollection
  • Update records based on a given criteria

MongoCollection::update

(PECL mongo >=0.9.0)

MongoCollection::update — Update records based on a given criteria

说明

public MongoCollection::update ( array $criteria , array $new_object , array $options = array() ) : bool|array

参数

criteria

Query criteria for the documents to update.

new_object

The object used to update the matched documents. This may either contain update operators (for modifying specific fields) or be a replacement document.

options

An array of options for the update operation. Currently available options include:

  • "upsert"

    If no document matches $criteria, a new document will be inserted.

    If a new document would be inserted and $new_object contains atomic modifiers (i.e. $ operators), those operations will be applied to the $criteria parameter to create the new document. If $new_object does not contain atomic modifiers, it will be used as-is for the inserted document. See the upsert examples below for more information.

  • "multiple"

    All documents matching $criteria will be updated. MongoCollection::update() has exactly the opposite behavior of MongoCollection::remove(): it updates one document by default, not all matching documents. It is recommended that you always specify whether you want to update multiple documents or a single document, as the database may change its default behavior at some point in the future.

  • "fsync"

    Boolean, defaults to false. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If true, an acknowledged insert is implied and this option will override setting "w" to 0.

    Note: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to false. Forces the write operation to block until it is synced to the journal on disk. If true, an acknowledged write is implied and this option will override setting "w" to 0.

    Note: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

返回值

Returns an array containing the status of the update if the "w" option is set. Otherwise, returns true.

Fields in the status array are described in the documentation for MongoCollection::insert().

错误／异常

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

更新日志

版本 | 说明
PECL mongo 1.5.0 | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
PECL mongo 1.3.4 | Added "wtimeout" option.
PECL mongo 1.3.0 | Added "w" option. The options parameter no longer accepts a boolean to signify an upsert. Instead, this now has to be done with array('upsert' => true).
PECL mongo 1.2.11 | Emits E_DEPRECATED when options is scalar.
PECL mongo 1.2.0 | Added "timeout" option.
PECL mongo 1.0.11 | Disconnects on "not master" errors if "safe" is set.
PECL mongo 1.0.9 | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option. The return type was changed to be an array containing error information if the "safe" option is used. Otherwise, a boolean is returned as before.
PECL mongo 1.0.5 | Added "safe" option.
PECL mongo 1.0.1 | Changed options parameter from boolean to array. Pre-1.0.1, the second parameter was an optional boolean value specifying an upsert.

范例

Example #1 MongoCollection::update()

Adding an address field to a document.

<?php

$c->insert(array("firstname" => "Bob", "lastname" => "Jones" ));
$newdata = array('$set' => array("address" => "1 Smith Lane"));
$c->update(array("firstname" => "Bob"), $newdata);

var_dump($c->findOne(array("firstname" => "Bob")));

?>

以上例程的输出类似于：

array(4) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["firstname"]=>
  string(3) "Bob"
  ["lastname"]=>
  string(5) "Jones"
  ["address"]=>
  string(12) "1 Smith Lane"
}

Example #2 MongoCollection::update() upsert examples

Upserts can simplify code, as a single line can create the document if it does not exist (based on $criteria), or update an existing document if it matches.

In the following example, $new_object contains an atomic modifier. Since the collection is empty and upsert must insert a new document, it will apply those operations to the $criteria parameter in order to create the document.

<?php

$c->drop();
$c->update(
    array("uri" => "/summer_pics"),
    array('$inc' => array("page hits" => 1)),
    array("upsert" => true)
);
var_dump($c->findOne());

?>

以上例程的输出类似于：

array(3) {
  ["_id"]=>
  object(MongoId)#9 (0) {
  }
  ["uri"]=>
  string(12) "/summer_pics"
  ["page hits"]=>
  int(1)
}

If $new_object does not contain atomic modifiers (i.e. $ operators), upsert will use $new_object as-is for the new document. This matches the behavior of a normal update, where not using atomic modifiers causes the document to be overwritten.

<?php

$c->drop();
$c->update(
    array("name" => "joe"),
    array("username" => "joe312", "createdAt" => new MongoDate()),
    array("upsert" => true)
);
var_dump($c->findOne());

?>

以上例程的输出类似于：

array(3) {
  ["_id"]=>
  object(MongoId)#10 (0) {
  }
  ["username"]=>
  string(6) "joe312"
  ["createdAt"]=>
  object(MongoDate)#4 (0) {
  }
}

Example #3 MongoCollection::update() multiple example

By default, MongoCollection::update() will only update the first document matching $criteria that it finds. Using the "multiple" option can override this behavior, if needed.

This example adds a "gift" field to every person whose birthday is in the next day.

<?php

$today = array('$gt' => new MongoDate(), '$lt' => new MongoDate(strtotime("+1 day")));
$people->update(
    array("birthday" => $today),
    array('$set' => array('gift' => $surprise)),
    array("multiple" => true)
);

?>

参见

The PHP documentation on updates and the » MongoDB core docs.


Validates this collection

  • ? MongoCollection::update
  • MongoCursor ?
  • PHP Manual
  • MongoCollection
  • Validates this collection

MongoCollection::validate

(PECL mongo >=0.9.0)

MongoCollection::validate — Validates this collection

说明

public MongoCollection::validate ( bool $scan_data = false ) : array

参数

scan_data

Only validate indices, not the base collection.

返回值

Returns the database's evaluation of this object.


The MongoCursor class

(PECL mongo >=0.9.0)

简介

A cursor is used to iterate through the results of a database query. For example, to query the database and see all results, you could do:

Example #1 MongoCursor basic usage

<?php

$cursor = $collection->find();
var_dump(iterator_to_array($cursor));

?>

You don't generally create cursors using the MongoCursor constructor, you get a new cursor by calling MongoCollection::find() (as shown above).

Suppose that, in the example above, $collection was a 50GB collection. We certainly wouldn't want to load that into memory all at once, which is what a cursor is for: allowing the client to access the collection in dribs and drabs.

If we have a large result set, we can iterate through it, loading a few megabytes of results into memory at a time. For example, we could do:

Example #2 Iterating over MongoCursor

<?php

$cursor = $collection->find();

foreach ($cursor as $doc) {
    // do something to each document
}

?>
This will go through each document in the collection, loading and garbage collecting documents as needed.

Note that this means that a cursor does not "contain" the database results, it just manages them. Thus, if you print a cursor (with, say, var_dump() or print_r()), you'll just get the cursor object, not your documents. To get the documents themselves, you can use one of the methods shown above.

Cursor Stages

A MongoCursor has two "life stages": pre- and post- query. When a cursor is created, it has not yet contacted the database, so it is in its pre-query state. In this state, the client can further specify what they want the query to do, including adding limits, skips, sorts, and more advanced options.

When the client attempts to get a result (by calling MongoCursor::next(), directly or indirectly), the cursor moves into the post-query stage. At this point, the query has been executed by the database and cannot be modified anymore.

Example #3 Adding options to MongoCursor

<?php

$cursor = $collection->find()->limit(10);

// database has not yet been queried, so more search options can be added
$cursor = $cursor->sort(array("a" => 1));

var_dump($cursor->getNext());
// now database has been queried and more options cannot be added

// so this will throw an exception:
$cursor->skip(4);
?>

类摘要

MongoCursor implements MongoCursorInterface , Iterator {
/* Static Fields */
static bool $slaveOkay = false ;
static int $timeout = 30000 ;
/* 方法 */
public addOption ( string $key , mixed $value ) : MongoCursor
public awaitData ( bool $wait = true ) : MongoCursor
public batchSize ( int $batchSize ) : MongoCursor
public __construct ( MongoClient $connection , string $ns , array $query = array() , array $fields = array() )
public count ( bool $foundOnly = false ) : int
public current ( ) : array
public dead ( ) : bool
protected doQuery ( ) : void
public explain ( ) : array
public fields ( array $f ) : MongoCursor
public getNext ( ) : array
public getReadPreference ( ) : array
public hasNext ( ) : bool
public hint ( mixed $index ) : MongoCursor
public immortal ( bool $liveForever = true ) : MongoCursor
public info ( ) : array
public key ( ) : string|int
public limit ( int $num ) : MongoCursor
public maxTimeMS ( int $ms ) : MongoCursor
public next ( ) : array
public partial ( bool $okay = true ) : MongoCursor
public reset ( ) : void
public rewind ( ) : void
public setFlag ( int $flag , bool $set = true ) : MongoCursor
public setReadPreference ( string $read_preference , array $tags = ? ) : MongoCursor
public skip ( int $num ) : MongoCursor
public slaveOkay ( bool $okay = true ) : MongoCursor
public snapshot ( ) : MongoCursor
public sort ( array $fields ) : MongoCursor
public tailable ( bool $tail = true ) : MongoCursor
public timeout ( int $ms ) : MongoCursor
public valid ( ) : bool
}

Static Variables

slaveOkay

If the query should have the "slaveOkay" flag set, which allows reads on the secondary (secondaries are, by default, just for backup and not queried). Can be overridden with MongoCursor::slaveOkay().

This functionality is deprecated. Please use 读取首选项 instead.

timeout

Set timeout in milliseconds for all database responses. Use -1 to wait forever. Can be overridden with MongoCursor::timeout(). This does not cause the MongoDB server to cancel the operation; it only instructs the driver to stop waiting for a response and throw a MongoCursorTimeoutException after a set time.

参见

MongoDB core docs on » cursors.

Table of Contents

  • MongoCursor::addOption — Adds a top-level key/value pair to a query
  • MongoCursor::awaitData — Sets whether this cursor will wait for a while for a tailable cursor to return more data
  • MongoCursor::batchSize — Limits the number of elements returned in one batch
  • MongoCursor::__construct — Create a new cursor
  • MongoCursor::count — Counts the number of results for this query
  • MongoCursor::current — Returns the current element
  • MongoCursor::dead — Checks if there are results that have not yet been sent from the database
  • MongoCursor::doQuery — Execute the query
  • MongoCursor::explain — Return an explanation of the query, often useful for optimization and debugging
  • MongoCursor::fields — Sets the fields for a query
  • MongoCursor::getNext — Advances the cursor to the next result, and returns that result
  • MongoCursor::getReadPreference — Get the read preference for this query
  • MongoCursor::hasNext — Checks if there are any more elements in this cursor
  • MongoCursor::hint — Gives the database a hint about the query
  • MongoCursor::immortal — Sets whether this cursor will timeout
  • MongoCursor::info — Gets information about the cursor's creation and iteration
  • MongoCursor::key — Returns the current result's _id, or its index within the result set
  • MongoCursor::limit — Limits the number of results returned
  • MongoCursor::maxTimeMS — Sets a server-side timeout for this query
  • MongoCursor::next — Advances the cursor to the next result, and returns that result
  • MongoCursor::partial — If this query should fetch partial results from mongos if a shard is down
  • MongoCursor::reset — Clears the cursor
  • MongoCursor::rewind — Returns the cursor to the beginning of the result set
  • MongoCursor::setFlag — Sets arbitrary flags in case there is no method available the specific flag
  • MongoCursor::setReadPreference — Set the read preference for this query
  • MongoCursor::skip — Skips a number of results
  • MongoCursor::slaveOkay — Sets whether this query can be done on a secondary [deprecated]
  • MongoCursor::snapshot — Use snapshot mode for the query
  • MongoCursor::sort — Sorts the results by given fields
  • MongoCursor::tailable — Sets whether this cursor will be left open after fetching the last results
  • MongoCursor::timeout — Sets a client-side timeout for this query
  • MongoCursor::valid — Checks if the cursor is reading a valid result


Adds a top-level key/value pair to a query

  • ? MongoCursor
  • MongoCursor::awaitData ?
  • PHP Manual
  • MongoCursor
  • Adds a top-level key/value pair to a query

MongoCursor::addOption

(PECL mongo >=1.0.4)

MongoCursor::addOption — Adds a top-level key/value pair to a query

说明

public MongoCursor::addOption ( string $key , mixed $value ) : MongoCursor

This is an advanced function and should not be used unless you know what you're doing.

A query can optionally be nested in a "query" field if other options, such as a sort or hint, are given. For instance, adding a sort causes the query to become a subfield of a bigger query object, like:

<?php

$query = array("query" => $query, "orderby" => $sort);

?>

This method is for adding a top-level field to a query. It makes the query a subobject (if it isn't already) and adds the key/value pair of your chosing to the top level.

Warning

It cannot be used to add extra criteria to a query on the fly. For instance, this will not work:

<?php

// NOT CORRECT
$cursor = $users->find()->addOption("name", "joe")->addOption("age", 20);

?>
This does not query for a user named "joe" with an age of 20.

参数

key

Fieldname to add.

value

Value to add.

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

范例

Example #1 Adding a comment with MongoCursor::addOption() example

MongoDB supports special options to be send to the server. The shell uses the _addSpecial option to send a $comment to the server. This comment will show up in the profiling log (for slow queries f.e.). In the PHP driver, you use the MongoCursor::addOption() method.

<?php
$m = new MongoClient;
$c = $m->demo->demo;
$cursor = $c->find();
$cursor->addOption('$comment', "This comment will show up in the profiling log");

foreach ($cursor as $document) { /* empty */ }
?>

以上例程的输出类似于：

{
    "op" : "query",
    "ns" : "demo.demo",
    "query" : {
        "$query" : {

        },
        "$comment" : "This comment will show up in the profiling log"
    },
    "cursorid" : 168463566447,
    "ntoreturn" : 0,
    "ntoskip" : 0,
    "nscanned" : 101,
    "nscannedObjects" : 101,
    "keyUpdates" : 0,
    "numYield" : 0,
...

Example #2 MongoCursor::addOption() example

Using MongoCursor::skip() to skip over millions of results can become slow. One way around this is to use $min or $max options for the query. These can be handy, but they require an index on exactly the fields being searched for. This is an example of how to use $min as an alternative to MongoCursor::skip().

<?php

// make sure we have an index
$c->ensureIndex(array("ts" => 1));

// you may have to modify this to run in a reasonable amount of time on slow
// machines (should take about 30 seconds on a good machine)
for ($i = 0; $i < 30000000; $i++) {
    $c->insert(array("ts" => new MongoDate(), "i" => $i));
}

$now = strtotime("now");

// find documents inserted in the last 2 seconds
$cursor = $c->find()->addOption('$min', array("ts" => $now-2));

?>


Sets whether this cursor will wait for a while for a tailable cursor to return more data

  • ? MongoCursor::addOption
  • MongoCursor::batchSize ?
  • PHP Manual
  • MongoCursor
  • Sets whether this cursor will wait for a while for a tailable cursor to return more data

MongoCursor::awaitData

(PECL mongo >=1.2.11)

MongoCursor::awaitData — Sets whether this cursor will wait for a while for a tailable cursor to return more data

说明

public MongoCursor::awaitData ( bool $wait = true ) : MongoCursor

This method is to be used with tailable cursors. If we are at the end of the data, block for a while rather than returning no data. After a timeout period, we do return as normal.

参数

wait

If the cursor should wait for more data to become available.

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

范例

Example #1 MongoCursor::awaitData() example

In this example we tail the "oplog" and instead of sleeping during every iteration, we set the MongoCursor::awaitData() option. MongoCursor::hasNext() will now block until there is more data available.

<?php
$m = new MongoClient( 'mongodb://localhost:13000', array( 'replSet' => 'seta' ) );
$c = $m->local->selectCollection( 'oplog.rs' );
$cursor = $c->find( array( 'ns' => 'demo.article', 'op' => 'i' ) );
$cursor->tailable( true );
$cursor->awaitData( true );

while (true) {
    if (!$cursor->hasNext()) {
        // we've read all the results, exit
        if ($cursor->dead()) {
            break;
        }
    } else {
        var_dump( $cursor->getNext() );
    }
}
?>

参见

MongoDB core docs on » tailable cursors.

  • MongoCursor::tailable() - Sets whether this cursor will be left open after fetching the last results


Limits the number of elements returned in one batch

  • ? MongoCursor::awaitData
  • MongoCursor::__construct ?
  • PHP Manual
  • MongoCursor
  • Limits the number of elements returned in one batch

MongoCursor::batchSize

(PECL mongo >=1.0.11)

MongoCursor::batchSize — Limits the number of elements returned in one batch

说明

public MongoCursor::batchSize ( int $batchSize ) : MongoCursor

A cursor typically fetches a batch of result objects and store them locally. This method sets the batchSize value to configure the amount of documents retrieved from the server in one round trip. However, it will never return more documents than fit in the max batch size limit (usually 4MB).

参数

batchSize

The number of results to return per batch. Each batch requires a round-trip to the server.

If batchSize is 2 or more, it represents the size of each batch of objects retrieved. It can be adjusted to optimize performance and limit data transfer.

If batchSize is 1 or negative, it will limit of number returned documents to the absolute value of batchSize, and the cursor will be closed. For example if batchSize is -10, then the server will return a maximum of 10 documents and as many as can fit in 4MB, then close the cursor.

Warning

A batchSize of 1 is special, and means the same as -1, i.e. a value of 1 makes the cursor only capable of returning one document.

Note that this feature is different from MongoCursor::limit() in that documents must fit within a maximum size, and it removes the need to send a request to close the cursor server-side. The batch size can be changed even after a cursor is iterated, in which case the setting will apply on the next batch retrieval.

This cannot override MongoDB's limit on the amount of data it will return to the client (i.e., if you set batch size to 1,000,000,000, MongoDB will still only return 4-16MB of results per batch).

To ensure consistent behavior, the rules of MongoCursor::batchSize() and MongoCursor::limit() behave a little complex but work "as expected". The rules are: hard limits override soft limits with preference given to MongoCursor::limit() over MongoCursor::batchSize(). After that, whichever is set and lower than the other will take precedence. See below. section for some examples.

返回值

Returns this cursor.

范例

Example #1 MongoCursor::batchSize() and combinations with MongoCursor::limit()

<?php

// one batch, at most 10 items. The -10 makes the server to return 10 items,
// and then remove the cursor.
$cursor->limit(20)->batchSize(-10);

// first batch: at most 10 items
$cursor->limit(10);

// first batch: at most 10 items
$cursor->limit(10)->batchSize(20);

// results are fetched in batches of 10 each, with a maximum of 20 items
// returned (that means two batches of 10).
$cursor->limit(20)->batchSize(10);

// results are fetched in batches of 7 each, with a maximum of 30 items
// returned (that means that the driver requests 4 batches of 7, and one batch
// of 2).
$cursor->limit(30)->batchSize(7)
?>

参见

MongoDB core docs on » batchSize.

  • MongoCursor::limit() - Limits the number of results returned
  • MongoCursorInterface::batchSize() - Limits the number of elements returned in one batch

更新日志

版本 | 说明
PECL mongo 1.4.5 | Before 1.4.5, this method would throw an MongoCursorException if the cursor had already started iterating.


Create a new cursor

  • ? MongoCursor::batchSize
  • MongoCursor::count ?
  • PHP Manual
  • MongoCursor
  • Create a new cursor

MongoCursor::__construct

(PECL mongo >=0.9.0)

MongoCursor::__construct — Create a new cursor

说明

public MongoCursor::__construct ( MongoClient $connection , string $ns , array $query = array() , array $fields = array() )

参数

connection

Database connection.

ns

Full name of database and collection.

query

Database query.

fields

Fields to return.

返回值

Returns the new cursor.


Counts the number of results for this query

  • ? MongoCursor::__construct
  • MongoCursor::current ?
  • PHP Manual
  • MongoCursor
  • Counts the number of results for this query

MongoCursor::count

(PECL mongo >=0.9.2)

MongoCursor::count — Counts the number of results for this query

说明

public MongoCursor::count ( bool $foundOnly = false ) : int

This method does not affect the state of the cursor: if you haven't queried yet, you can still apply limits, skips, etc. If you have started iterating through results, it will not move the current position of the cursor. If you have exhausted the cursor, it will not reset it.

参数

foundOnly

Send cursor limit and skip information to the count function, if applicable.

返回值

The number of documents returned by this cursor's query.

范例

Example #1 MongoCursor::count() example

<?php

$collection->insert(array('x'=>1));
$collection->insert(array('x'=>2));
$collection->insert(array('x'=>3));

$cursor = $collection->find();

var_dump($cursor->count());
var_dump($cursor->count(true));

$cursor->limit(2);

var_dump($cursor->count());
var_dump($cursor->count(true));

?>

以上例程的输出类似于：

int(3)
int(3)
int(3)
int(2)

错误／异常

Throws MongoConnectionException if it cannot reach the database.


Returns the current element

  • ? MongoCursor::count
  • MongoCursor::dead ?
  • PHP Manual
  • MongoCursor
  • Returns the current element

MongoCursor::current

(PECL mongo >=0.9.0)

MongoCursor::current — Returns the current element

说明

public MongoCursor::current ( ) : array

This returns null until MongoCursor::next() is called.

参数

此函数没有参数。

返回值

The current result document as an associative array. null will be returned if there is no result.

参见

  • Iterator::current() - 返回当前元素


Checks if there are results that have not yet been sent from the database

  • ? MongoCursor::current
  • MongoCursor::doQuery ?
  • PHP Manual
  • MongoCursor
  • Checks if there are results that have not yet been sent from the database

MongoCursor::dead

(PECL mongo >=0.9.6)

MongoCursor::dead — Checks if there are results that have not yet been sent from the database

说明

public MongoCursor::dead ( ) : bool

The database sends responses in batches of documents, up to 4MB of documents per response. This method checks if the database has more batches or if the result set has been exhausted.

A cursor being "dead" does not mean that MongoCursor::hasNext() will return false, it only means that the database is done sending results to the client. The client should continue iterating through results until MongoCursor::hasNext() is false.

参数

此函数没有参数。

返回值

Returns true if there are more results that have not yet been sent to the client, and false otherwise.

参见

  • MongoCursorInterface::dead() - Checks if there are results that have not yet been sent from the database


Execute the query

  • ? MongoCursor::dead
  • MongoCursor::explain ?
  • PHP Manual
  • MongoCursor
  • Execute the query

MongoCursor::doQuery

(PECL mongo >=0.9.0 <1.6.0)

MongoCursor::doQuery — Execute the query

说明

protected MongoCursor::doQuery ( ) : void
Warning

Please do not use me.

This function actually queries the database. All queries and commands go through this function. Thus, this function can be overridden to provide custom query handling.

This handles serializing your query, sending it to the database, receiving a response, and deserializing it. Thus, if you are planning to override this, your code should probably call out to the original to use the existing functionality (see the example below).

参数

此函数没有参数。

返回值

null.

错误／异常

Throws MongoConnectionException if it cannot reach the database.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

范例

Example #1 MongoCursor::doQuery() example

You could override this function to attempt a query on a secondary and, if that fails, try it again on the primary.

<?php

class MyCursor extends MongoCursor {

    protected function doQuery() {

        $this->slaveOkay();

        try {
            MongoCursor::doQuery();
        }
        catch(MongoCursorException $e) {
            $this->slaveOkay(false);
            MongoCursor::doQuery();
        }
    }
}

?>


Return an explanation of the query, often useful for optimization and debugging

  • ? MongoCursor::doQuery
  • MongoCursor::fields ?
  • PHP Manual
  • MongoCursor
  • Return an explanation of the query, often useful for optimization and debugging

MongoCursor::explain

(PECL mongo >=0.9.2)

MongoCursor::explain — Return an explanation of the query, often useful for optimization and debugging

说明

public MongoCursor::explain ( ) : array

参数

此函数没有参数。

返回值

Returns an explanation of the query.

范例

Example #1 MongoCursor::explain() example

<?php

$cursor = $collection->find(array("x"=>1), array("y"));
$cursor->sort(array("z" => 1))->limit(4)->skip(5);

var_dump($cursor->explain());

?>

以上例程的输出类似于：

array(8) {
  ["cursor"]=>
  string(15) "BtreeCursor x_1"
  ["startKey"]=>
  array(1) {
    ["x"]=>
    int(1)
  }
  ["endKey"]=>
  array(1) {
    ["x"]=>
    int(1)
  }
  ["nscanned"]=>
  float(4)
  ["n"]=>
  int(4)
  ["scanAndOrder"]=>
  int(1)
  ["millis"]=>
  int(3)
  ["allPlans"]=>
  array(2) {
    [0]=>
    array(3) {
      ["cursor"]=>
      string(15) "BtreeCursor x_1"
      ["startKey"]=>
      array(1) {
        ["x"]=>
        int(1)
      }
      ["endKey"]=>
      array(1) {
        ["x"]=>
        int(1)
      }
    }
    [1]=>
    array(3) {
      ["cursor"]=>
      string(11) "BasicCursor"
      ["startKey"]=>
      array(0) {
      }
      ["endKey"]=>
      array(0) {
      }
    }
  }
}

错误／异常

Throws MongoConnectionException if it cannot reach the database.

参见

MongoDB core docs on » explain.


Sets the fields for a query

  • ? MongoCursor::explain
  • MongoCursor::getNext ?
  • PHP Manual
  • MongoCursor
  • Sets the fields for a query

MongoCursor::fields

(PECL mongo >=1.0.6)

MongoCursor::fields — Sets the fields for a query

说明

public MongoCursor::fields ( array $f ) : MongoCursor

Fields are specified by "fieldname" : bool. true indicates that a field should be returned, false indicates that it should not be returned. You can also use 1 and 0 instead of true and false.

Thus, to return only the "summary" field, one could say:

<?php

$cursor->fields(array("summary" => true));

?>

To return all fields except the "hidden" field:

<?php

$cursor->fields(array("hidden" => false));

?>

参数

f

Fields to return (or not return).

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating or a scalar argument is given.


Advances the cursor to the next result, and returns that result

  • ? MongoCursor::fields
  • MongoCursor::getReadPreference ?
  • PHP Manual
  • MongoCursor
  • Advances the cursor to the next result, and returns that result

MongoCursor::getNext

(PECL mongo >=0.9.0)

MongoCursor::getNext — Advances the cursor to the next result, and returns that result

说明

public MongoCursor::getNext ( ) : array

Note:

MongoCursor::getNext() is an alias of MongoCursor::next().


Get the read preference for this query

  • ? MongoCursor::getNext
  • MongoCursor::hasNext ?
  • PHP Manual
  • MongoCursor
  • Get the read preference for this query

MongoCursor::getReadPreference

(PECL mongo >=1.3.3)

MongoCursor::getReadPreference — Get the read preference for this query

说明

public MongoCursor::getReadPreference ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

范例

Example #1 MongoCursor::getReadPreference() return value example

<?php

$m = new MongoClient();
$cursor = $m->test->users->find();
$cursor->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($cursor->getReadPreference());
?>

以上例程会输出：

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

参见

  • The read preferences documentation.
  • MongoCursor::setReadPreference() - Set the read preference for this query
  • MongoCursorInterface::getReadPreference() - Get the read preference for this query


Checks if there are any more elements in this cursor

  • ? MongoCursor::getReadPreference
  • MongoCursor::hint ?
  • PHP Manual
  • MongoCursor
  • Checks if there are any more elements in this cursor

MongoCursor::hasNext

(PECL mongo >=0.9.0)

MongoCursor::hasNext — Checks if there are any more elements in this cursor

说明

public MongoCursor::hasNext ( ) : bool

参数

此函数没有参数。

返回值

Returns if there is another element.

错误／异常

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.


Gives the database a hint about the query

  • ? MongoCursor::hasNext
  • MongoCursor::immortal ?
  • PHP Manual
  • MongoCursor
  • Gives the database a hint about the query

MongoCursor::hint

(PECL mongo >=0.9.0)

MongoCursor::hint — Gives the database a hint about the query

说明

public MongoCursor::hint ( mixed $index ) : MongoCursor

参数

index

Index to use for the query. If a string is passed, it should correspond to an index name. If an array or object is passed, it should correspond to the specification used to create the index (i.e. the first argument to MongoCollection::ensureIndex()).

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

更新日志

版本 | 说明
PECL mongo 1.4.0 | The index argument now supports index names as string values. In versions before 1.4.0, only array or object values were accepted.


Sets whether this cursor will timeout

  • ? MongoCursor::hint
  • MongoCursor::info ?
  • PHP Manual
  • MongoCursor
  • Sets whether this cursor will timeout

MongoCursor::immortal

(PECL mongo >=1.0.1)

MongoCursor::immortal — Sets whether this cursor will timeout

说明

public MongoCursor::immortal ( bool $liveForever = true ) : MongoCursor

After remaining idle on the server for some amount of time, cursors, by default, "die." This is generally the behavior one wants. The database cleans up a cursor once all of its results have been sent to the client, but if the client doesn't request all of the results, the cursor will languish there, taking up resources. Thus, after a few minutes, the cursor "times out" and the database assumes the client has gotten everything it needs and cleans up its the cursor's resources.

If, for some reason, you need a cursor to hang around for a long time, you can prevent the database from cleaning it up by using this method. However, if you make a cursor immortal, you need to iterate through all of its results (or at least until MongoCursor::dead() returns true) or the cursor will hang around the database forever, taking up resources.

参数

liveForever

If the cursor should be immortal.

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.


Gets information about the cursor's creation and iteration

  • ? MongoCursor::immortal
  • MongoCursor::key ?
  • PHP Manual
  • MongoCursor
  • Gets information about the cursor's creation and iteration

MongoCursor::info

(PECL mongo >=1.0.5)

MongoCursor::info — Gets information about the cursor's creation and iteration

说明

public MongoCursor::info ( ) : array

This can be called before or after the cursor has started iterating.

参数

此函数没有参数。

返回值

Returns the namespace, batch size, limit, skip, flags, query, and projected fields for this cursor. If the cursor has started iterating, additional information about iteration and the connection will be included.

更新日志

版本 | 说明
PECL mongo 1.1.0 | Added a number of other fields, including id (the cursor id), at (the driver's counter of which document is current), numReturned (the number returned by the server in the current batch), and server (which server the query was sent to—useful in conjunction with 读取首选项.
PECL mongo 1.0.10 | Added started_iterating field, a boolean indicating if cursor is pre- or post-query.

范例

Example #1 MongoCursor::info() example

<?php
$m = new MongoClient();

$cursor = $m->test->foo->find(array("x" => 4), array("y" => 0));

echo "Before iteration started:\n";
var_dump($cursor->info());

echo "\nAfter iteration started:\n";
$cursor->rewind();
var_dump($cursor->info());

?>

以上例程的输出类似于：

Before iteration started:
array(8) {
  ["ns"]=>
  string(8) "test.foo"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["fields"]=>
  array(1) {
    ["y"]=>
    int(0)
  }
  ["started_iterating"]=>
  bool(false)
}

After iteration started:
array(15) {
  ["ns"]=>
  string(8) "test.foo"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["fields"]=>
  array(1) {
    ["y"]=>
    int(0)
  }
  ["started_iterating"]=>
  bool(true)
  ["id"]=>
  int(0)
  ["at"]=>
  int(0)
  ["numReturned"]=>
  int(1)
  ["server"]=>
  string(25) "localhost:27017;-;.;26450"
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["connection_type_desc"]=>
  string(10) "STANDALONE"
}

参见

  • MongoCursorInterface::info() - Gets information about the cursor's creation and iteration


Returns the current result's _id, or its index within the result set

  • ? MongoCursor::info
  • MongoCursor::limit ?
  • PHP Manual
  • MongoCursor
  • Returns the current result's _id, or its index within the result set

MongoCursor::key

(PECL mongo >=0.9.0)

MongoCursor::key — Returns the current result's _id, or its index within the result set

说明

public MongoCursor::key ( ) : string|int

参数

此函数没有参数。

返回值

The current result's _id as a string. If the result has no _id, its numeric index within the result set will be returned as an integer.

参见

  • Iterator::key() - 返回当前元素的键


Limits the number of results returned

  • ? MongoCursor::key
  • MongoCursor::maxTimeMS ?
  • PHP Manual
  • MongoCursor
  • Limits the number of results returned

MongoCursor::limit

(PECL mongo >=0.9.0)

MongoCursor::limit — Limits the number of results returned

说明

public MongoCursor::limit ( int $num ) : MongoCursor

参数

num

The number of results to return.

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

参见

  • MongoDB core docs on » limit.
  • MongoCursor::batchSize() - Limits the number of elements returned in one batch
  • MongoCursor::skip() - Skips a number of results


Sets a server-side timeout for this query

  • ? MongoCursor::limit
  • MongoCursor::next ?
  • PHP Manual
  • MongoCursor
  • Sets a server-side timeout for this query

MongoCursor::maxTimeMS

(PECL mongo >=1.5.0)

MongoCursor::maxTimeMS — Sets a server-side timeout for this query

说明

public MongoCursor::maxTimeMS ( int $ms ) : MongoCursor

Specifies a cumulative time limit in milliseconds to be allowed by the server for processing operations on the cursor.

参数

ms

Specifies a cumulative time limit in milliseconds to be allowed by the server for processing operations on the cursor.

返回值

This cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

Causes methods that fetch results to throw a MongoExecutionTimeoutException if the query takes longer than the specified number of milliseconds in processing time.

范例

Example #1 MongoCursor::maxTimeMS() example

In the following example, the server will abort the query if the cursor requires more than two seconds in processing time to return its results.

<?php

$cursor = $collection->find();
$cursor->maxTimeMS(2000);

try {
    $results = iterator_to_array($cursor);
} catch (MongoExecutionTimeoutException $e) {
    echo "query took too long!";
}

?>

注释

Warning

Unlike MongoCursor::timeout(), which specifies a client-side timeout, MongoCursor::maxTimeMS() can be used to cause the MongoDB server to abort long-running queries. This timeout is cumulative for the lifetime of the cursor (i.e. each batch will contribute to this time limit). The timeout only considers processing time; idle time is not considered.


Advances the cursor to the next result, and returns that result

  • ? MongoCursor::maxTimeMS
  • MongoCursor::partial ?
  • PHP Manual
  • MongoCursor
  • Advances the cursor to the next result, and returns that result

MongoCursor::next

(PECL mongo >=0.9.0)

MongoCursor::next — Advances the cursor to the next result, and returns that result

说明

public MongoCursor::next ( ) : array

参数

此函数没有参数。

返回值

Returns the next document.

错误／异常

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

参见

  • Iterator::next() - 向前移动到下一个元素


If this query should fetch partial results from mongos if a shard is down

  • ? MongoCursor::next
  • MongoCursor::reset ?
  • PHP Manual
  • MongoCursor
  • If this query should fetch partial results from mongos if a shard is down

MongoCursor::partial

(PECL mongo >=1.2.0)

MongoCursor::partial — If this query should fetch partial results from mongos if a shard is down

说明

public MongoCursor::partial ( bool $okay = true ) : MongoCursor

This option allows mongos to send partial query results if a shard is unreachable. This is only applicable when running a sharded MongoDB cluster and connecting to a mongos.

If a shard goes down and a query needs to be sent to that shard, mongos will return the results (if any) from shards it already contacted, then an error message that it could not reach the shard (a MongoCursorException in PHP). If you would like to get whatever results mongos can provide and no exception, you can use this method. Note that this means that you won't have an indication that a shard is down in your query response.

This has no effect on the query if all shards are reachable. This flag was implemented in MongoDB version 1.7.5, so will only work with that version and higher.

参数

okay

If receiving partial results is okay.

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.


Clears the cursor

  • ? MongoCursor::partial
  • MongoCursor::rewind ?
  • PHP Manual
  • MongoCursor
  • Clears the cursor

MongoCursor::reset

(PECL mongo >=0.9.0)

MongoCursor::reset — Clears the cursor

说明

public MongoCursor::reset ( ) : void

参数

此函数没有参数。

返回值

null.


Returns the cursor to the beginning of the result set

  • ? MongoCursor::reset
  • MongoCursor::setFlag ?
  • PHP Manual
  • MongoCursor
  • Returns the cursor to the beginning of the result set

MongoCursor::rewind

(PECL mongo >=0.9.0)

MongoCursor::rewind — Returns the cursor to the beginning of the result set

说明

public MongoCursor::rewind ( ) : void

This is identical to the function:

<?php

public function rewind() {
    $this->reset();
    $this->next();
}

?>

参数

此函数没有参数。

返回值

null.

错误／异常

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

参见

  • Iterator::rewind() - 返回到迭代器的第一个元素


Sets arbitrary flags in case there is no method available the specific flag

  • ? MongoCursor::rewind
  • MongoCursor::setReadPreference ?
  • PHP Manual
  • MongoCursor
  • Sets arbitrary flags in case there is no method available the specific flag

MongoCursor::setFlag

(PECL mongo >=1.2.11)

MongoCursor::setFlag — Sets arbitrary flags in case there is no method available the specific flag

说明

public MongoCursor::setFlag ( int $flag , bool $set = true ) : MongoCursor

The MongoCursor class has several methods for setting flags on the query object. This method is available in case the MongoDB wire protocol has acquired a new flag, and the driver has not been updated with a method for this new flag. In all other cases, the method should be used. See the "See also" section for available methods.

参数

flag

Which flag to set. You can not set flag 6 (EXHAUST) as the driver does not know how to handle them. You will get a warning if you try to use this flag. For available flags, please refer to the wire protocol » documentation.

set

Whether the flag should be set (true) or unset (false).

返回值

Returns this cursor.

错误／异常

Shows a warning when an unsupport flag is attempted to be set.

更新日志

版本 | 说明
PECL mongo 1.4.0 | Support for flag 3 (OPLOG_REPLAY) is added. Versions before 1.4.0 would throw a warning saying that the flag is unsupported.

范例

Example #1 MongoCursor::setFlag() example

<?php
$m = new MongoClient( 'mongodb://localhost:13000', array( 'replSet' => 'seta' ) );
$c = $m->local->selectCollection( 'oplog.rs' );
$cursor = $c->find( array( 'ns' => 'demo.article', 'op' => 'i' ) );
$cursor->setFlag( 1, true ); // sets the tailable flag
$cursor->setFlag( 5, true ); // sets the await data flag
?>

参见

  • MongoCursor::tailable() - Sets whether this cursor will be left open after fetching the last results
  • MongoCursor::immortal() - Sets whether this cursor will timeout
  • MongoCursor::awaitData() - Sets whether this cursor will wait for a while for a tailable cursor to return more data
  • MongoCursor::partial() - If this query should fetch partial results from mongos if a shard is down
  • MongoDB core docs on» wire protocol query flags


Set the read preference for this query

  • ? MongoCursor::setFlag
  • MongoCursor::skip ?
  • PHP Manual
  • MongoCursor
  • Set the read preference for this query

MongoCursor::setReadPreference

(PECL mongo >=1.3.3)

MongoCursor::setReadPreference — Set the read preference for this query

说明

public MongoCursor::setReadPreference ( string $read_preference , array $tags = ? ) : MongoCursor

参数

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

返回值

Returns this cursor.

错误／异常

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

范例

Example #1 MongoCursor::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient();
$cursor = $m->test->users->find();

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$cursor->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

参见

  • The read preferences documentation.
  • MongoCursor::getReadPreference() - Get the read preference for this query
  • MongoCursorInterface::setReadPreference() - Set the read preference for this query


Skips a number of results

  • ? MongoCursor::setReadPreference
  • MongoCursor::slaveOkay ?
  • PHP Manual
  • MongoCursor
  • Skips a number of results

MongoCursor::skip

(PECL mongo >=0.9.0)

MongoCursor::skip — Skips a number of results

说明

public MongoCursor::skip ( int $num ) : MongoCursor

参数

num

The number of results to skip.

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

参见

  • MongoCursor::limit() - Limits the number of results returned


Sets whether this query can be done on a secondary [deprecated]

  • ? MongoCursor::skip
  • MongoCursor::snapshot ?
  • PHP Manual
  • MongoCursor
  • Sets whether this query can be done on a secondary [deprecated]

MongoCursor::slaveOkay

(PECL mongo >=0.9.4)

MongoCursor::slaveOkay — Sets whether this query can be done on a secondary [deprecated]

说明

public MongoCursor::slaveOkay ( bool $okay = true ) : MongoCursor
Warning

This method is deprecated since version 1.5.0. Instead, please use MongoCursor::setReadPreference() and 读取首选项.

Calling this will make the driver route reads to secondaries if:

  • You are using a replica set, and
  • You created a MongoClient instance using the option "replicaSet" => "setName", and
  • There is a healthy secondary that can be reached by the driver.
You can check which server was used for this query by calling MongoCursor::info() after running the query. It's server field will show which server the query was sent to.

Note that you should use this function even if you do not use the automatic routing to secondaries. If you connect directly to a secondary in a replica set, you still need to call this function, which basically tells the database that you are aware that you might be getting older data and you're okay with that. If you do not call this, you'll get "not master" errors when you try to query.

This method will override the static class variable
MongoCursor::$slaveOkay.  It will also override
Mongo::setSlaveOkay(),
MongoDB::setSlaveOkay() and
MongoCollection::setSlaveOkay().

参数

okay

If it is okay to query the secondary.

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

范例

Example #1 MongoCursor::slaveOkay() example

<?php

MongoCursor::$slaveOkay = false;

// cannot query secondary
$cursor = $collection->find();

// can query secondary
$cursor = $collection->find()->slaveOkay();

MongoCursor::$slaveOkay = true;

// can query secondary
$cursor = $collection->find();

// cannot query secondary
$cursor = $collection->find()->slaveOkay(false);

?>

参见

  • 读取首选项
  • MongoCursor::setReadPreference() - Set the read preference for this query
  • MongoCursor::getReadPreference() - Get the read preference for this query

更新日志

版本 | 说明
PECL mongo 1.5.0 | This method has been deprecated in favour of MongoCursor::setReadPreference() and 读取首选项.


Use snapshot mode for the query

  • ? MongoCursor::slaveOkay
  • MongoCursor::sort ?
  • PHP Manual
  • MongoCursor
  • Use snapshot mode for the query

MongoCursor::snapshot

(PECL mongo >=0.9.4)

MongoCursor::snapshot — Use snapshot mode for the query

说明

public MongoCursor::snapshot ( ) : MongoCursor

Use snapshot mode for the query. Snapshot mode ensures that a document will not be returned more than once because an intervening write operation results in a move of the document. Documents inserted or deleted during the lifetime of the cursor may or may not be returned, irrespective of snapshot mode.

Queries with short responses (less than 1MB) are always effectively snapshotted.

Snapshot mode may not be used with sorting, explicit hints, or queries on sharded collections.

参数

此函数没有参数。

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

参见

MongoDB core docs on » $snapshot operator.


Sorts the results by given fields

  • ? MongoCursor::snapshot
  • MongoCursor::tailable ?
  • PHP Manual
  • MongoCursor
  • Sorts the results by given fields

MongoCursor::sort

(PECL mongo >=0.9.0)

MongoCursor::sort — Sorts the results by given fields

说明

public MongoCursor::sort ( array $fields ) : MongoCursor

参数

fields

An array of fields by which to sort. Each element in the array has as key the field name, and as value either 1 for ascending sort, or -1 for descending sort.

Each result is first sorted on the first field in the array, then (if it exists) on the second field in the array, etc. This means that the order of the fields in the fields array is important. See also the examples section.

返回值

Returns the same cursor that this method was called on.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

范例

Example #1 MongoCursor::sort() example

<?php
// Sort on field x, ascending
$cursor->sort(array('x' => 1));

// The order in the associative array is important. For instance, these two
// examples will yield different results:

// Sort on date ascending and age descending
$cursor->sort(array('date' => 1, 'age' => -1));

// Sort on age descending and date ascending
$cursor->sort(array('age' => -1, 'date' => 1));
?>


Sets whether this cursor will be left open after fetching the last results

  • ? MongoCursor::sort
  • MongoCursor::timeout ?
  • PHP Manual
  • MongoCursor
  • Sets whether this cursor will be left open after fetching the last results

MongoCursor::tailable

(PECL mongo >=0.9.4)

MongoCursor::tailable — Sets whether this cursor will be left open after fetching the last results

说明

public MongoCursor::tailable ( bool $tail = true ) : MongoCursor

Mongo has a feature known as tailable cursors which are similar to the Unix "tail -f" command.

Tailable means cursor is not closed when the last data is retrieved. Rather, the cursor marks the final object's position. you can resume using the cursor later, from where it was located, if more data were received.

Like any "latent cursor", the cursor may become invalid at some point -- for example if that final object it references were deleted. Thus, you should be prepared to requery if the cursor is MongoCursor::dead().

参数

tail

If the cursor should be tailable.

返回值

Returns this cursor.

错误／异常

Throws MongoCursorException if this cursor has started iterating.

范例

Example #1 MongoCursor::tailable() example

<?php

$cursor = $collection->find()->tailable();

$results = array();

while (1) {
    if (!$cursor->hasNext()) {
        // we've read all the results, exit
        if ($cursor->dead()) {
            break;
        }
        // read all results so far, wait for more
        sleep(10);
    }
    else {
        $results[] = $cursor->getNext();
    }
}

?>

参见

MongoDB core docs on » tailable cursors.

  • MongoCursor::awaitData() - Sets whether this cursor will wait for a while for a tailable cursor to return more data


Sets a client-side timeout for this query

  • ? MongoCursor::tailable
  • MongoCursor::valid ?
  • PHP Manual
  • MongoCursor
  • Sets a client-side timeout for this query

MongoCursor::timeout

(PECL mongo >=1.0.3)

MongoCursor::timeout — Sets a client-side timeout for this query

说明

public MongoCursor::timeout ( int $ms ) : MongoCursor

A timeout can be set at any time and will affect subsequent queries on the cursor, including fetching more results from the database.

参数

ms

The number of milliseconds for the cursor to wait for a response. Use -1 to wait forever. By default, the cursor will wait 30000 milliseconds (30 seconds).

返回值

This cursor.

错误／异常

Causes methods that fetch results to throw a MongoCursorTimeoutException if the query takes longer than the specified number of milliseconds.

范例

Example #1 MongoCursor::timeout() example

In the following example, the driver will wait forever for the initial database response, and then wait 100ms for subsequent responses.

<?php

$cursor = $collection->find();
$cursor->timeout(-1);

/* $cursor->hasNext() executes the query. An infinite timeout has been set, so
 * the driver will wait as long as necessary for a response.
 */
while ($cursor->hasNext()) {
    $cursor->timeout(100);

    /* A timeout has now been set, so if the cursor needs to get more results
     * from the database, it will only wait 100ms for a response.
     */
    try {
        print_r($cursor->getNext());
    } catch (MongoCursorTimeoutException $e) {
        echo "query took too long!";
    }
}

?>

注释

Warning

This does not cause the MongoDB server to cancel long-running operations; it only instructs the driver to stop waiting for a response and throw a MongoCursorTimeoutException after a set time. If you need to specify a server-side timeout for a query, consider using MongoCursor::maxTimeMS().

参见

  • MongoCursorInterface::timeout() - Sets a client-side timeout for this query
  • The socketTimeoutMS option for MongoClient::__construct()


Checks if the cursor is reading a valid result

  • ? MongoCursor::timeout
  • MongoCursorInterface ?
  • PHP Manual
  • MongoCursor
  • Checks if the cursor is reading a valid result

MongoCursor::valid

(PECL mongo >=0.9.0)

MongoCursor::valid — Checks if the cursor is reading a valid result

说明

public MongoCursor::valid ( ) : bool

参数

此函数没有参数。

返回值

true if the current result is not null, and false otherwise.

参见

  • Iterator::valid() - 检查当前位置是否有效


The MongoCursorInterface interface

(PECL mongo >=1.5.0)

简介

Interface for cursors, which can be used to iterate through results of a database query or command. This interface is implemented by the MongoCursor and MongoCommandCursor classes.

Note: Similar to Traversable, this interface cannot be implemented in PHP scripts.

类摘要

MongoCursorInterface extends Iterator {
/* 方法 */
abstract public batchSize ( int $batchSize ) : MongoCursorInterface
abstract public dead ( ) : bool
abstract public getReadPreference ( ) : array
abstract public info ( ) : array
abstract public setReadPreference ( string $read_preference , array $tags = ? ) : MongoCursorInterface
abstract public timeout ( int $ms ) : MongoCursorInterface
/* 继承的方法 */
abstract public Iterator::current ( ) : mixed
abstract public Iterator::key ( ) : scalar
abstract public Iterator::next ( ) : void
abstract public Iterator::rewind ( ) : void
abstract public Iterator::valid ( ) : bool
}

Table of Contents

  • MongoCursorInterface::batchSize — Limits the number of elements returned in one batch
  • MongoCursorInterface::dead — Checks if there are results that have not yet been sent from the database
  • MongoCursorInterface::getReadPreference — Get the read preference for this query
  • MongoCursorInterface::info — Gets information about the cursor's creation and iteration
  • MongoCursorInterface::setReadPreference — Set the read preference for this query
  • MongoCursorInterface::timeout — Sets a client-side timeout for this query


Limits the number of elements returned in one batch

  • ? MongoCursorInterface
  • MongoCursorInterface::dead ?
  • PHP Manual
  • MongoCursorInterface
  • Limits the number of elements returned in one batch

MongoCursorInterface::batchSize

(PECL mongo >=1.5.0)

MongoCursorInterface::batchSize — Limits the number of elements returned in one batch

说明

abstract public MongoCursorInterface::batchSize ( int $batchSize ) : MongoCursorInterface

A cursor typically fetches a batch of result objects and stores them locally. This method sets the batch size value to configure the amount of documents retrieved from the server in one round trip.

参数

batchSize

The number of results to return per batch.

返回值

Returns this cursor.


Checks if there are results that have not yet been sent from the database

  • ? MongoCursorInterface::batchSize
  • MongoCursorInterface::getReadPreference ?
  • PHP Manual
  • MongoCursorInterface
  • Checks if there are results that have not yet been sent from the database

MongoCursorInterface::dead

(PECL mongo >=1.5.0)

MongoCursorInterface::dead — Checks if there are results that have not yet been sent from the database

说明

abstract public MongoCursorInterface::dead ( ) : bool

This method checks whether the cursor has been exhausted and the database has no more results to send to the client. A cursor being "dead" does not necessarily mean that there are no more results available for iteration.

参数

此函数没有参数。

返回值

Returns true if there are more results that have not yet been sent to the client, and false otherwise.


Get the read preference for this query

  • ? MongoCursorInterface::dead
  • MongoCursorInterface::info ?
  • PHP Manual
  • MongoCursorInterface
  • Get the read preference for this query

MongoCursorInterface::getReadPreference

(PECL mongo >=1.6.0)

MongoCursorInterface::getReadPreference — Get the read preference for this query

说明

abstract public MongoCursorInterface::getReadPreference ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

参见

  • The read preferences documentation.
  • MongoCursorInterface::setReadPreference() - Set the read preference for this query


Gets information about the cursor's creation and iteration

  • ? MongoCursorInterface::getReadPreference
  • MongoCursorInterface::setReadPreference ?
  • PHP Manual
  • MongoCursorInterface
  • Gets information about the cursor's creation and iteration

MongoCursorInterface::info

(PECL mongo >=1.5.0)

MongoCursorInterface::info — Gets information about the cursor's creation and iteration

说明

abstract public MongoCursorInterface::info ( ) : array

Returns information about the cursor's creation and iteration. This can be called before or after the cursor has started iterating.

参数

此函数没有参数。

返回值

Returns the namespace, batch size, limit, skip, flags, query, and projected fields for this cursor. If the cursor has started iterating, additional information about iteration and the connection will be included.


Set the read preference for this query

  • ? MongoCursorInterface::info
  • MongoCursorInterface::timeout ?
  • PHP Manual
  • MongoCursorInterface
  • Set the read preference for this query

MongoCursorInterface::setReadPreference

(PECL mongo >=1.6.0)

MongoCursorInterface::setReadPreference — Set the read preference for this query

说明

abstract public MongoCursorInterface::setReadPreference ( string $read_preference , array $tags = ? ) : MongoCursorInterface

参数

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

返回值

Returns this cursor.

错误／异常

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

参见

  • The read preferences documentation.
  • MongoCursorInterface::getReadPreference() - Get the read preference for this query


Sets a client-side timeout for this query

  • ? MongoCursorInterface::setReadPreference
  • MongoCommandCursor ?
  • PHP Manual
  • MongoCursorInterface
  • Sets a client-side timeout for this query

MongoCursorInterface::timeout

(PECL mongo >=1.5.0)

MongoCursorInterface::timeout — Sets a client-side timeout for this query

说明

abstract public MongoCursorInterface::timeout ( int $ms ) : MongoCursorInterface

A timeout can be set at any time and will affect subsequent data retrieval associated with this cursor, including fetching more results from the database.

参数

ms

The number of milliseconds for the cursor to wait for a response. Use -1 to wait forever. By default, the cursor will wait 30000 milliseconds (30 seconds).

返回值

Returns this cursor.

错误／异常

Causes methods that fetch results to throw a MongoCursorTimeoutException if the data fetch takes longer than the specified number of milliseconds.

参见

  • The socketTimeoutMS option for MongoClient::__construct()


The MongoCommandCursor class

(PECL mongo >=1.5.0)

简介

A command cursor is similar to a MongoCursor except that you use it for iterating through the results of a database command instead of a normal query. Command cursors are useful for iterating over large result sets that might exceed the document size limit (currently 16MB) of a single MongoDB::command() response.

While you can create command cursors using MongoCommandCursor::__construct() or the MongoCommandCursor::createFromDocument() factory method, you will generally want to use command-specific helpers such as MongoCollection::aggregateCursor().

Note that the cursor does not "contain" the database command's results; it just manages iteration through them. Thus, if you print a cursor (f.e. with var_dump() or print_r()), you will see the cursor object but not the result documents.

Cursor Stages

A MongoCommandCursor has two "life stages": pre- and post- command. When a cursor is created, it has not yet contacted the database, so it is in its pre-command state. When the client first attempts to get a result (by calling MongoCommandCursor::rewind(), directly or indirectly), the cursor moves into the post-command state.

The command cursor's batch size and socket timeout may be configured in both the pre- and post- command states.

Example #1 Adding options to MongoCommandCursor

<?php

$cursor = new MongoCommandCursor(...);

$cursor = $cursor->batchSize( 4 );

foreach ($cursor as $result) {
    var_dump($result);
}
?>

类摘要

MongoCommandCursor implements MongoCursorInterface , Iterator {
/* 方法 */
public batchSize ( int $batchSize ) : MongoCommandCursor
public __construct ( MongoClient $connection , string $ns , array $command = array() )
public static createFromDocument ( MongoClient $connection , string $hash , array $document ) : MongoCommandCursor
public current ( ) : array
public dead ( ) : bool
public getReadPreference ( ) : array
public info ( ) : array
public key ( ) : int
public next ( ) : void
public rewind ( ) : array
public setReadPreference ( string $read_preference , array $tags = ? ) : MongoCommandCursor
public timeout ( int $ms ) : MongoCommandCursor
public valid ( ) : bool
}

参见

  • MongoDB::command()
  • MongoCollection::aggregateCursor()

Table of Contents

  • MongoCommandCursor::batchSize — Limits the number of elements returned in one batch
  • MongoCommandCursor::__construct — Create a new command cursor
  • MongoCommandCursor::createFromDocument — Create a new command cursor from an existing command response document
  • MongoCommandCursor::current — Returns the current element
  • MongoCommandCursor::dead — Checks if there are results that have not yet been sent from the database
  • MongoCommandCursor::getReadPreference — Get the read preference for this command
  • MongoCommandCursor::info — Gets information about the cursor's creation and iteration
  • MongoCommandCursor::key — Returns the current result's index within the result set
  • MongoCommandCursor::next — Advances the cursor to the next result
  • MongoCommandCursor::rewind — Executes the command and resets the cursor to the start of the result set
  • MongoCommandCursor::setReadPreference — Set the read preference for this command
  • MongoCommandCursor::timeout — Sets a client-side timeout for this command
  • MongoCommandCursor::valid — Checks if the cursor is reading a valid result


Limits the number of elements returned in one batch

  • ? MongoCommandCursor
  • MongoCommandCursor::__construct ?
  • PHP Manual
  • MongoCommandCursor
  • Limits the number of elements returned in one batch

MongoCommandCursor::batchSize

(PECL mongo >=1.5.0)

MongoCommandCursor::batchSize — Limits the number of elements returned in one batch

说明

public MongoCommandCursor::batchSize ( int $batchSize ) : MongoCommandCursor

A cursor typically fetches a batch of result objects and store them locally. This method sets the batchSize value to configure the amount of documents retrieved from the server in one round trip.

参数

batchSize

The number of results to return per batch. Each batch requires a round-trip to the server.

This cannot override MongoDB's limit on the amount of data it will return to the client (i.e., if you set batch size to 1,000,000,000, MongoDB will still only return 4-16MB of results per batch).

返回值

Returns this cursor.

范例

Example #1 MongoCommandCursor::batchSize()

<?php
$commandCursor->batchSize(20);
?>

参见

  • MongoCursorInterface::batchSize() - Limits the number of elements returned in one batch


Create a new command cursor

  • ? MongoCommandCursor::batchSize
  • MongoCommandCursor::createFromDocument ?
  • PHP Manual
  • MongoCommandCursor
  • Create a new command cursor

MongoCommandCursor::__construct

(PECL mongo >=1.5.0)

MongoCommandCursor::__construct — Create a new command cursor

说明

public MongoCommandCursor::__construct ( MongoClient $connection , string $ns , array $command = array() )

Generally, you should not have to construct a MongoCommandCursor manually, as there are helper functions such as MongoCollection::aggregateCursor() and MongoCollection::parallelCollectionScan(); however, if the server introduces new commands that can return cursors, this constructor will be useful in the absence of specific helper methods. You may also consider using MongoCommandCursor::createFromDocument().

参数

connection

Database connection.

ns

Full name of the database and collection (e.g. "test.foo")

command

Database command.

返回值

Returns the new cursor.

范例

Example #1 MongoCommandCursor example

<?php
$m = new MongoClient;

// Define the aggregation pipeline
$pipeline = [
    [ '$group' => [
        '_id' => '$country_code',
        'timezones' => [ '$addToSet' => '$timezone' ]
    ] ],
    [ '$sort' => [ '_id' => 1 ] ],
];

// Construct a MongoCommandCursor object
$cursor = new MongoCommandCursor(
    $m, // MongoClient object
    'demo.cities', // namespace
    [
        'aggregate' => 'cities',
        'pipeline' => $pipeline,
        'cursor' => [ 'batchSize' => 0 ],
    ]
);

foreach($cursor as $result) {
   ...
}
?>

参见

  • MongoCommandCursor::createFromDocument() - Create a new command cursor from an existing command response document
  • MongoCollection::aggregateCursor() - Execute an aggregation pipeline command and retrieve results through a cursor
  • MongoCollection::parallelCollectionScan() - Returns an array of cursors to iterator over a full collection in parallel


Create a new command cursor from an existing command response document

  • ? MongoCommandCursor::__construct
  • MongoCommandCursor::current ?
  • PHP Manual
  • MongoCommandCursor
  • Create a new command cursor from an existing command response document

MongoCommandCursor::createFromDocument

(PECL mongo >=1.5.0)

MongoCommandCursor::createFromDocument — Create a new command cursor from an existing command response document

说明

public static MongoCommandCursor::createFromDocument ( MongoClient $connection , string $hash , array $document ) : MongoCommandCursor

Use this method if you have a raw command result with cursor information in it. Note that cursors created with this method cannot be iterated multiple times, as they will lack the original command necessary for re-execution.

参数

connection

Database connection.

hash

The connection hash, as obtained through the third by-reference argument to MongoDB::command().

document

Document with cursor information in it. This document needs to contain the id, ns and firstBatch fields. Such a document is obtained by calling the MongoDB::command() with appropriate arguments to return a cursor, and not just an inline result. See the example below.

返回值

Returns the new cursor.

范例

Example #1 MongoCommandCursor::createFromDocument()

<?php
$m = new MongoClient;
$d = $m->demo;

// Define the aggregation pipeline
$pipeline = [
    [ '$group' => [
        '_id' => '$country_code',
        'timezones' => [ '$addToSet' => '$timezone' ]
    ] ],
    [ '$sort' => [ '_id' => 1 ] ],
];

// Execute the command. The "cursor" option instructs the server to return
// cursor information in the response instead of inline results.
$r = $d->command(
    [
        'aggregate' => 'cities',
        'pipeline' => $pipeline,
        'cursor' => [ 'batchSize' => 1 ],
    ],
    null,
    $hash
);

// Show result and hash
var_dump( $r, $hash );

// Construct the command cursor
$cursor = MongoCommandCursor::createFromDocument( $m, $hash, $r );
?>

以上例程的输出类似于：

array(2) {
  ["cursor"]=>
  array(3) {
    ["id"]=>
    object(MongoInt64)#5 (1) {
      ["value"]=>
      string(12) "392143983421"
    }
    ["ns"]=>
    string(11) "demo.cities"
    ["firstBatch"]=>
    array(1) {
      [0]=>
      array(2) {
        ["_id"]=>
        string(2) "AD"
        ["timezones"]=>
        array(1) {
          [0]=>
          string(14) "Europe/Andorra"
        }
      }
    }
  }
  ["ok"]=>
  float(1)
}
string(25) "localhost:27017;-;.;17617"

As you can see, the returned cursor information has the id, ns and firstBatch fields.

参见

  • MongoCommandCursor::__construct() - Create a new command cursor


Returns the current element

  • ? MongoCommandCursor::createFromDocument
  • MongoCommandCursor::dead ?
  • PHP Manual
  • MongoCommandCursor
  • Returns the current element

MongoCommandCursor::current

(PECL mongo >=1.5.0)

MongoCommandCursor::current — Returns the current element

说明

public MongoCommandCursor::current ( ) : array

This returns null until MongoCommandCursor::rewind() is called.

参数

此函数没有参数。

返回值

The current result document as an associative array. null will be returned if there is no result.

参见

  • Iterator::current() - 返回当前元素


Checks if there are results that have not yet been sent from the database

  • ? MongoCommandCursor::current
  • MongoCommandCursor::getReadPreference ?
  • PHP Manual
  • MongoCommandCursor
  • Checks if there are results that have not yet been sent from the database

MongoCommandCursor::dead

(PECL mongo >=1.5.0)

MongoCommandCursor::dead — Checks if there are results that have not yet been sent from the database

说明

public MongoCommandCursor::dead ( ) : bool

This method checks whether the MongoCommandCursor cursor has been exhausted and the database has no more results to send to the client. A cursor being "dead" does not necessarily mean that there are no more results available for iteration.

参数

此函数没有参数。

返回值

Returns true if there are more results that have not yet been sent to the client, and false otherwise.

参见

  • MongoCursorInterface::dead() - Checks if there are results that have not yet been sent from the database


Get the read preference for this command

  • ? MongoCommandCursor::dead
  • MongoCommandCursor::info ?
  • PHP Manual
  • MongoCommandCursor
  • Get the read preference for this command

MongoCommandCursor::getReadPreference

(PECL mongo >=1.6.0)

MongoCommandCursor::getReadPreference — Get the read preference for this command

说明

public MongoCommandCursor::getReadPreference ( ) : array

参数

此函数没有参数。

返回值

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

范例

Example #1 MongoCommandCursor::getReadPreference() return value example

<?php

$m = new MongoClient('mongodb://rs1.example.com:27017', array('replicaSet' => 'myReplSetName'));
$collection = $m->selectCollection('test', 'people');

// If a MongoCommandCursor is constructed directly, it will inherit the read
// preference of the MongoClient instance passed to its constructor; however,
// MongoCollection::aggregateCursor() will have the MongoCommandCursor inherit
// the collection's read preference.
$collection->setReadPreference(MongoClient::RP_SECONDARY);

$cursor = $collection->aggregateCursor( [
    [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
    [ '$sort' => [ 'points' => -1 ] ],
] );

var_dump($cursor->getReadPreference());

?>

以上例程会输出：

array(1) {
  ["type"]=>
  string(9) "secondary"
}

参见

  • The read preferences documentation.
  • MongoCommandCursor::setReadPreference() - Set the read preference for this command
  • MongoCursorInterface::getReadPreference() - Get the read preference for this query


Gets information about the cursor's creation and iteration

  • ? MongoCommandCursor::getReadPreference
  • MongoCommandCursor::key ?
  • PHP Manual
  • MongoCommandCursor
  • Gets information about the cursor's creation and iteration

MongoCommandCursor::info

(PECL mongo >=1.5.0)

MongoCommandCursor::info — Gets information about the cursor's creation and iteration

说明

public MongoCommandCursor::info ( ) : array

This can be called before or after the cursor has started iterating.

参数

此函数没有参数。

返回值

Returns the namespace, batch size, limit, skip, flags, query, and projected fields for this cursor. If the cursor has started iterating, additional information about iteration and the connection will be included.

范例

Example #1 MongoCommandCursor::info() example

<?php
$m = new MongoClient();

$cursor = new MongoCommandCursor(
    $m, // MongoClient object
    'demo.cities', // namespace
    [
        'aggregate' => 'cities',
        'pipeline' => [ [ '$match' => [ '_id' => [ '$exists' => true ] ] ] ],
        'cursor' => [ 'batchSize' => 1 ],
    ]
);

echo "Before iteration started:\n";
var_dump($cursor->info());

echo "\nAfter iteration started:\n";
$cursor->rewind();
var_dump($cursor->info());

?>

以上例程的输出类似于：

Before iteration started:
array(8) {
  ["ns"]=>
  string(11) "demo.cities"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(3) {
    ["aggregate"]=>
    string(6) "cities"
    ["pipeline"]=>
    array(1) {
      [0]=>
      array(1) {
        ["$match"]=>
        array(1) {
          ["_id"]=>
          array(1) {
            ["$exists"]=>
            bool(true)
          }
        }
      }
    }
    ["cursor"]=>
    array(1) {
      ["batchSize"]=>
      int(1)
    }
  }
  ["fields"]=>
  NULL
  ["started_iterating"]=>
  bool(false)
}

After iteration started:
array(17) {
  ["ns"]=>
  string(11) "demo.cities"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(3) {
    ["aggregate"]=>
    string(6) "cities"
    ["pipeline"]=>
    array(1) {
      [0]=>
      array(1) {
        ["$match"]=>
        array(1) {
          ["_id"]=>
          array(1) {
            ["$exists"]=>
            bool(true)
          }
        }
      }
    }
    ["cursor"]=>
    array(1) {
      ["batchSize"]=>
      int(1)
    }
  }
  ["fields"]=>
  NULL
  ["started_iterating"]=>
  bool(true)
  ["id"]=>
  int(185840310129)
  ["at"]=>
  int(0)
  ["numReturned"]=>
  int(0)
  ["server"]=>
  string(25) "localhost:27017;-;.;23991"
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["connection_type_desc"]=>
  string(10) "STANDALONE"
  ["firstBatchAt"]=>
  int(0)
  ["firstBatchNumReturned"]=>
  int(1)
}

参见

  • MongoCursorInterface::info() - Gets information about the cursor's creation and iteration


Returns the current result's index within the result set

  • ? MongoCommandCursor::info
  • MongoCommandCursor::next ?
  • PHP Manual
  • MongoCommandCursor
  • Returns the current result's index within the result set

MongoCommandCursor::key

(PECL mongo >=1.5.0)

MongoCommandCursor::key — Returns the current result's index within the result set

说明

public MongoCommandCursor::key ( ) : int

参数

此函数没有参数。

返回值

The current result's index within the result set.

参见

  • Iterator::key() - 返回当前元素的键


Advances the cursor to the next result

  • ? MongoCommandCursor::key
  • MongoCommandCursor::rewind ?
  • PHP Manual
  • MongoCommandCursor
  • Advances the cursor to the next result

MongoCommandCursor::next

(PECL mongo >=1.5.0)

MongoCommandCursor::next — Advances the cursor to the next result

说明

public MongoCommandCursor::next ( ) : void

参数

此函数没有参数。

返回值

null.

错误／异常

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

参见

  • Iterator::next() - 向前移动到下一个元素


Executes the command and resets the cursor to the start of the result set

  • ? MongoCommandCursor::next
  • MongoCommandCursor::setReadPreference ?
  • PHP Manual
  • MongoCommandCursor
  • Executes the command and resets the cursor to the start of the result set

MongoCommandCursor::rewind

(PECL mongo >=1.5.0)

MongoCommandCursor::rewind — Executes the command and resets the cursor to the start of the result set

说明

public MongoCommandCursor::rewind ( ) : array

If the cursor has already started iteration, the command will be re-executed.

参数

此函数没有参数。

返回值

The raw server result document.

错误／异常

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

Throws MongoCursorException if the cursor was created with MongoCommandCursor::createFromDocument() and has already started iteration. Such cursors cannot be iterated multiple times, as they lack the original command necessary for re-execution.

范例

Example #1 MongoCommandCursor::rewind()

<?php
$rawResult = $commandCursor->rewind();

// Command cursor is now reset to the start of the result set

var_dump($rawResult);
?>

以上例程的输出类似于：

array(2) {
  ["cursor"]=>
  array(3) {
    ["id"]=>
    object(MongoInt64)#5 (1) {
      ["value"]=>
      string(12) "310050110216"
    }
    ["ns"]=>
    string(9) "demo.test"
    ["firstBatch"]=>
    array(1) {
      [0]=>
      array(2) {
        ["_id"]=>
        object(MongoId)#6 (1) {
          ["$id"]=>
          string(24) "52f5691544670a8077b0dc51"
        }
        ["value"]=>
        string(2) "42"
      }
    }
  }
  ["ok"]=>
  float(1)
}

参见

  • Iterator::rewind() - 返回到迭代器的第一个元素


Set the read preference for this command

  • ? MongoCommandCursor::rewind
  • MongoCommandCursor::timeout ?
  • PHP Manual
  • MongoCommandCursor
  • Set the read preference for this command

MongoCommandCursor::setReadPreference

(PECL mongo >=1.6.0)

MongoCommandCursor::setReadPreference — Set the read preference for this command

说明

public MongoCommandCursor::setReadPreference ( string $read_preference , array $tags = ? ) : MongoCommandCursor

参数

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

返回值

Returns this cursor.

错误／异常

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

范例

Example #1 MongoCommandCursor::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient('mongodb://rs1.example.com:27017', array('replicaSet' => 'myReplSetName'));
$collection = $m->selectCollection('test', 'people');

$cursor = $collection->aggregateCursor( [
    [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
    [ '$sort' => [ 'points' => -1 ] ],
] );

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$cursor->setReadPreference(MongoClient::RP_NEAREST, [
    [ 'dc' => 'east', 'use' => 'reporting' ],
    [ 'dc' => 'west' ],
] );

foreach ($cursor as $person) {
    // ...
}

// If the read preference is changed, it will be used the next time the cursor
// is rewound and the command is re-executed.
$cursor->setReadPreference(MongoClient::RP_PRIMARY);

foreach ($cursor as $person) {
    // ...
}

?>

参见

  • The read preferences documentation.
  • MongoCommandCursor::getReadPreference() - Get the read preference for this command
  • MongoCursorInterface::setReadPreference() - Set the read preference for this query


Sets a client-side timeout for this command

  • ? MongoCommandCursor::setReadPreference
  • MongoCommandCursor::valid ?
  • PHP Manual
  • MongoCommandCursor
  • Sets a client-side timeout for this command

MongoCommandCursor::timeout

(PECL mongo >=1.6.0)

MongoCommandCursor::timeout — Sets a client-side timeout for this command

说明

public MongoCommandCursor::timeout ( int $ms ) : MongoCommandCursor

A timeout can be set at any time and will affect subsequent data retrieval associated with this cursor, including fetching more results from the database.

参数

ms

The number of milliseconds for the cursor to wait for a response. Use -1 to wait forever. By default, the cursor will wait 30000 milliseconds (30 seconds).

返回值

This cursor.

错误／异常

Causes methods that fetch results to throw a MongoCursorTimeoutException if the data fetch takes longer than the specified number of milliseconds.

范例

Example #1 MongoCommandCursor::timeout() example

In the following example, the driver will wait for 60 seconds for the first response from the aggregate command. It will also wait for 60 seconds each time the server needs to be polled for more information.

<?php

$m = new MongoClient;
$col = $m->database->collection;

$pipeline = [ ... ];

$cursor = $col->aggregateCursor( $pipeline );
$cursor->timeout( 60000 ); // for 60 seconds

foreach ( $cursor as $result ) {
   ...
}

?>

注释

Warning

This does not cause the MongoDB server to cancel long-running operations; it only instructs the driver to stop waiting for a response and throw a MongoCursorTimeoutException after a set time. If you need to specify a server-side timeout for a command, considering passing the maxTimeMS option to MongoCollection::aggregateCursor().

参见

  • MongoCollection::aggregateCursor() - Execute an aggregation pipeline command and retrieve results through a cursor
  • MongoCursorInterface::timeout() - Sets a client-side timeout for this query
  • The socketTimeoutMS option for MongoClient::__construct()


Checks if the cursor is reading a valid result

  • ? MongoCommandCursor::timeout
  • Types ?
  • PHP Manual
  • MongoCommandCursor
  • Checks if the cursor is reading a valid result

MongoCommandCursor::valid

(PECL mongo >=1.5.0)

MongoCommandCursor::valid — Checks if the cursor is reading a valid result

说明

public MongoCommandCursor::valid ( ) : bool

参数

此函数没有参数。

返回值

true if the current result is not null, and false otherwise.

参见

  • Iterator::valid() - 检查当前位置是否有效


Types

Table of Contents

  • MongoId
  • MongoCode
  • MongoDate
  • MongoRegex
  • MongoBinData
  • MongoInt32
  • MongoInt64
  • MongoDBRef
  • MongoMinKey
  • MongoMaxKey
  • MongoTimestamp

MongoDB allows programmers to save and query for data expressed in all of the basic PHP types, compound types (arrays, associative arrays, and objects), and a half-dozen classes provided by the MongoDB PHP driver (for regular expressions, dates, and other specialized applications).

Booleans and null

true, false, and null can be used as-is.

Numbers

Numbers are distinct from strings in MongoDB: "123" does not match 123. Thus, if you want to make sure numbers are sorted and matched correctly, you must make sure that they are actually saved as numbers.

<?php

$doc = array("a" => 123, "b" => "123");
$collection->insert($doc);

$doc->find(array("a" => 123));   // matches
$doc->find(array("a" => "123")); // doesn't match
$doc->find(array("a" => 123.0)); // matches
$doc->find(array("b" => 123));   // doesn't match
$doc->find(array("b" => "123")); // matches

?>

As noted above, floating point numbers do compare with/match integer numbers as one would expect.

Large Numbers

By default, on a 32-bit system, numbers are sent to the database as 32-bit integers. On a 64-bit system, they are sent as 64-bit integers. For backwards compatibility, all systems deserialize 64-bit integers as floating point numbers. Floating point numbers are not exact. If you need exact values, you must tweak your php.ini settings.

On a 32-bit system, if mongo.long_as_object is set, 64-bit integers will be returns as MongoInt64 objects. The integer will be stored in the value field with perfect precision (as a string). You can also use MongoInt64 to save 64-bit integers on 32-bit machines.

On 64-bit systems, you can either set mongo.long_as_object or set mongo.native_long. mongo.native_long will return 64-bit integers and "normal" PHP integers. You can use MongoInt32 to save 32-bit integers on 64-bit machines.

You should set the mongo.long_as_object and mongo.native_long behavior that you plan to use, even if it is the default behavior (to protect against future changes to the defaults).

See also: php.ini Options, MongoInt32, MongoInt64.

Strings

Strings must be UTF-8. Non-UTF-8 strings must either be converted to UTF-8 before being sent to the database or saved as binary data.

Regular expressions can be used to match strings, and are expressed using the MongoRegex class.

Binary Data

Non-UTF-8 strings, images, and any other binary data should be sent to the database using the MongoBinData type.

Dates

Dates can be created using the MongoDate class. They are stored as milliseconds since the epoch.

MongoTimestamp is not for saving dates or timestamps, it is used internally by MongoDB. Unless you are creating a tool that interacts with the internals of replication or sharding, you should use MongoDate, not MongoTimestamp.

Unique Ids

The driver will automatically create an _id field before inserting a document (unless one is specified by the user). This field is an instance of MongoId (called "ObjectId" in most other languages).

These ids are 12 bytes long and composed of:

  • 4 bytes of timestamp

    No two records can have the same id if they were inserted at different times.

  • 3 bytes machine id

    No two records can have the same id if they were inserted on different machines

  • 2 bytes thread id

    No two records can have the same id if they were inserted by different threads running on the same machine.

  • 3 bytes incrementing value

    Each time an id is created, a global counter is incremented and used as the increment value of the next id.

Thus, no two records can have the same id unless a single process on a single machine managed to insert 256^3 (over 16 million) documents in one second, overflowing the increment field.

JavaScript

MongoDB comes with a JavaScript engine, so you can embed JavaScript in queries (using a $where clause), send it directly to the database to be executed, and use it to perform aggregations.

For security, use MongoCode's scope field to use PHP variables in JavaScript. Code that does not require external values can either use MongoCode or just be a string. See the section on security for more information about sending JavaScript to the database.

Arrays and Objects

Arrays and objects can also be saved to the database. An array with ascending numeric keys will be saved as a an array, anything else will be saved as an object.

<?php

// $scores will be saved as an array
$scores = array(98, 100, 73, 85);
$collection->insert(array("scores" => $scores));

// $scores will be saved as an object
$scores = array("quiz1" => 98, "midterm" => 100, "quiz2" => 73, "final" => 85);
$collection->insert(array("scores" => $scores));

?>

If you query for these objects using the database shell, they will look like:

> db.students.find()
{ "_id" : ObjectId("4b06beada9ad6390dab17c43"), "scores" : [ 98, 100, 73, 85 ] }
{ "_id" : ObjectId("4b06bebea9ad6390dab17c44"), "scores" : { "quiz1" : 98, "midterm" : 100, "quiz2" : 73, "final" : 85 } }

The database can also save arbitrary PHP objects (although they will be returned as associative arrays). The fields are used for the key/value pairs. For example, a blog post might look like:

<?php

  // the blog post class
  class Post {

  var $author;
  var $content;
  var $comments = array();
  var $date;

  public function __construct($author, $content) {
  $this->author = $author;
$this->content = $content;
    $this->date = new MongoDate();
  }

  public function setTitle($title) {
    $this->title = $title;
  }
}

// create a simple blog post and insert it into the database
$post1 = new Post("Adam", "This is a blog post");

$blog->insert($post1);

// there is nothing restricting the type of the "author" field, so we can make
// it a nested object
$author = array("name" => "Fred", "karma" => 42);
$post2 = new Post($author, "This is another blog post.");

// we create an extra field by setting the title
$post2->setTitle("Second Post");

$blog->insert($post2);

?>

From the database shell, this will look something like:

> db.blog.find()
{ "_id" : ObjectId("4b06c263edb87a281e09dad8"), "author" : "Adam", "content" : "This is a blog post", "comments" : [ ], "date" : "Fri Nov 20 2009 11:22:59 GMT-0500 (EST)" }
{ "_id" : ObjectId("4b06c282edb87a281e09dad9"), "author" : { "name" : "Fred", "karma" : 42 }, "content" : "This is a blog post", "comments" : [ ], "date" : "Fri Nov 20 2009 11:23:30 GMT-0500 (EST)", "title" : "Second Post" }

The driver will not detect reference loops in arrays and objects. For example, this will give a fatal error:

<?php

$collection->insert($GLOBALS);

?>
Fatal error: Nesting level too deep - recursive dependency?
If you need to insert documents that may have recursive dependency, you have to check for it yourself before passing it to the driver.


MongoId 类

(PECL mongo >=0.8.0)

简介

为数据库对象创建的唯一标识符。 如果插入数据库的对象不具有 _id 字段，将会为 _id 字段添加一个 MongoId 实例作为值。 如果数据具有自然的唯一字段（比如说，用户名或 timestamp），用来作为 _id 字段也不错，它不会被 一个 MongoId 替换。

MongoId 类实例满足了关系数据库中自增列的角色： 如果数据不具有天然的唯一键，则提供一个。 自增列在分布式数据库中不会工作得很好，因为它无法快速找到下一个数字。 这个类能够满足在分布式下快速产生唯一值的条件。

每个 MongoId 具有 12 个字节（使它的字符串形式是 24 个十六进制字符）。 前四个字节是一个时间戳（timestamp），后三个是客户端主机名的 hash 摘要，然后两个是运行脚本的进程 ID， 最后三位是一个自增值。

MongoId 是可以序列化/反序列化的。 它们序列化后的格式和它们的字符串格式比较像：

C:7:"MongoId":24:{4af9f23d8ead0e1d32000000}

类摘要

MongoId {
public string $id = null ;
/* 方法 */
public __construct ( string|MongoId $id = null )
public static getHostname ( ) : string
public getInc ( ) : int
public getPID ( ) : int
public getTimestamp ( ) : int
public static isValid ( mixed $value ) : bool
public static __set_state ( array $props ) : MongoId
public __toString ( ) : string
}

Fields

id
这个字段包含了该对象的字符串表达形式。

参见

关于 » ids 的 MongoDB 核心文档。

Table of Contents

  • MongoId::__construct — 创建一个新的id
  • MongoId::getHostname — 获取这台机器上 id 所使用的 hostname
  • MongoId::getInc — 返回用于创建 id 所增加的值
  • MongoId::getPID — 获取进程 ID
  • MongoId::getTimestamp — 获取新纪元时间到 id 创建时的秒数。
  • MongoId::isValid — Check if a value is a valid ObjectId
  • MongoId::__set_state — 创建一个假的 MongoId
  • MongoId::__toString — 返回该 id 十六进制的表示形式


创建一个新的id

  • ? MongoId
  • MongoId::getHostname ?
  • PHP Manual
  • MongoId
  • 创建一个新的id

MongoId::__construct

(PECL mongo >= 0.8.0)

MongoId::__construct — 创建一个新的id

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\ObjectID::__construct()

说明

public MongoId::__construct ( string|MongoId $id = null )

参数

id

用于 id 的一个字符串。必须为24个十六进制的字符，或者也可以是 MongoId 实例。

返回值

返回一个新的 id。

更新日志

版本 | 说明
1.4.0 | 传入无效字符将抛出异常

范例

Example #1 MongoId::__construct() 例子

这个例子展示了如何创建一个新的 id。 这很少用到，因为在保存到数据库之前，驱动会为数组自动添加一个id。

<?php

  $id1 = new MongoId();
  echo "$id1\n";

  $id2 = new MongoId();
  echo "$id2\n";

  ?>

以上例程的输出类似于：

49a7011a05c677b9a916612a
49a702d5450046d3d515d10d

Example #2 参数的例子

这个例子展示了如何使用 string 的参数来初始化一个指定值的 MongoId。

<?php
  $id1 = new MongoId();

  // 从 $id1 创建一个新的 MongoId
  $id2 = new MongoId("$id1");

  // 显示 $id1 和 $id2 具有相同的十六进制值
  var_dump($id1 == $id2);
  ?>

以上例程的输出类似于：

bool(true)

参见

  • MongoId::__toString() - 返回该 id 十六进制的表示形式
  • MongoId::isvalid() - Check if a value is a valid ObjectId


获取这台机器上 id 所使用的 hostname

  • ? MongoId::__construct
  • MongoId::getInc ?
  • PHP Manual
  • MongoId
  • 获取这台机器上 id 所使用的 hostname

MongoId::getHostname

(PECL mongo >= 1.0.8)

MongoId::getHostname — 获取这台机器上 id 所使用的 hostname

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public static MongoId::getHostname ( ) : string

返回的 hostname 用于 MongoId 产生唯一 id。 这和 gethostname() 应该会返回同样的值。

它和以下函数是一样的：

<?php

public static function getHostname() {
    return gethostname();
}

?>

参数

此函数没有参数。

返回值

返回 hostname。


返回用于创建 id 所增加的值

  • ? MongoId::getHostname
  • MongoId::getPID ?
  • PHP Manual
  • MongoId
  • 返回用于创建 id 所增加的值

MongoId::getInc

(PECL mongo >= 1.0.11)

MongoId::getInc — 返回用于创建 id 所增加的值

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoId::getInc ( ) : int

参数

此函数没有参数。

返回值

返回增加的值，用于创建 MongoId。


获取进程 ID

  • ? MongoId::getInc
  • MongoId::getTimestamp ?
  • PHP Manual
  • MongoId
  • 获取进程 ID

MongoId::getPID

(PECL mongo >= 1.0.11)

MongoId::getPID — 获取进程 ID

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoId::getPID ( ) : int

从 Mongo ID 中提取 pid。

参数

此函数没有参数。

返回值

返回 MongoId 里的 PID。


获取新纪元时间到 id 创建时的秒数。

  • ? MongoId::getPID
  • MongoId::isValid ?
  • PHP Manual
  • MongoId
  • 获取新纪元时间到 id 创建时的秒数。

MongoId::getTimestamp

(PECL mongo >= 1.0.1)

MongoId::getTimestamp — 获取新纪元时间到 id 创建时的秒数。

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoId::getTimestamp ( ) : int

返回 id 创建时运行 time() 同样的东西。

参数

此函数没有参数。

返回值

获取新纪元时间到 id 创建时的秒数。 仅储存了四个字节的时间戳，所以 MongoDate 是储存更精准、更广范围时间的更佳选择。


Check if a value is a valid ObjectId

  • ? MongoId::getTimestamp
  • MongoId::__set_state ?
  • PHP Manual
  • MongoId
  • Check if a value is a valid ObjectId

MongoId::isValid

(PECL mongo >= 1.5.0)

MongoId::isValid — Check if a value is a valid ObjectId

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public static MongoId::isValid ( mixed $value ) : bool

This method may be used to check a variable before passing it as an argument to MongoId::__construct().

参数

value

The value to check for validity.

返回值

Returns true if value is a MongoId instance or a string consisting of exactly 24 hexadecimal characters; otherwise, false is returned.


创建一个假的 MongoId

  • ? MongoId::isValid
  • MongoId::__toString ?
  • PHP Manual
  • MongoId
  • 创建一个假的 MongoId

MongoId::__set_state

(PECL mongo >= 1.0.8)

MongoId::__set_state — 创建一个假的 MongoId

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public static MongoId::__set_state ( array $props ) : MongoId

该函数仅被 PHP 内部使用，用户不需要调用它。

它和下面的函数是一样的：

<?php

public static function __set_state($props) {
    return new MongoId("000000000000000000000000");
}

?>

参数

props

从理论上讲，要用数组的属性来创建一个新 id。但是 MongoId 示例没有属性，所以这是没用的。

返回值

具有 "000000000000000000000000" 的值的 id。


返回该 id 十六进制的表示形式

  • ? MongoId::__set_state
  • MongoCode ?
  • PHP Manual
  • MongoId
  • 返回该 id 十六进制的表示形式

MongoId::__toString

(PECL mongo >= 0.8.0)

MongoId::__toString — 返回该 id 十六进制的表示形式

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\ObjectID::__toString()

说明

public MongoId::__toString ( ) : string

参数

此函数没有参数。

返回值

该 id。

范例

Example #1 MongoId::__toString() 例子

<?php

$m = new MongoClient();
$collection = $m->selectDB("foo")->selectCollection("bar");

$collection->insert(array( "x" => "y" ));
$collection->insert(array( "x" => "y" ));

$cursor = $collection->find();
$r1 = $cursor->next();
$r2 = $cursor->next();

echo $r1["_id"] . "\n";
echo $r2["_id"] . "\n";

?>

以上例程的输出类似于：

49a7011a05c677b9a916612a
49a702d5450046d3d515d10d


The MongoCode class

(PECL mongo >=0.8.3)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\JavaScript

简介

Represents JavaScript code for the database.

MongoCode objects are composed of two parts: a string of code and an optional scope. The string of code must be valid JavaScript. The scope is a associative array of variable name/value pairs.

类摘要

MongoCode {
/* 方法 */
public __construct ( string $code , array $scope = array() )
public __toString ( ) : string
}

Table of Contents

  • MongoCode::__construct — 创建一个新的代码对象
  • MongoCode::__toString — 返回代码的字符串形式


创建一个新的代码对象

  • ? MongoCode
  • MongoCode::__toString ?
  • PHP Manual
  • MongoCode
  • 创建一个新的代码对象

MongoCode::__construct

(PECL mongo >= 0.8.3)

MongoCode::__construct — 创建一个新的代码对象

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\JavaScript::__construct()

说明

public MongoCode::__construct ( string $code , array $scope = array() )

参数

code

字符串代码。

scope

使用代码的范围。

返回值

返回一个新的代码对象。

范例

Example #1 MongoCode::__construct() 例子

<?php

$code = new MongoCode('function() { '.
    'for(i=0;i<10;i++) {'.
        'db.foo.update({z : i}, {z : x});'.
    '}'.
    'return x-1;'.
 '}', array("x" => 4));
var_dump($code);

?>

以上例程的输出类似于：

object(MongoCode)#1 (2) {
  ["scope"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["code"]=>
  string(80) "function() { for(i=0;i<10;i++) { db.foo.update({z : i}, {z : x}); } return x-1; }"
}

Example #2 使用具有 $where 的 MongoCode

这个例子查询了集合里，'x' 字段比 $y 小的元素。 注意，PHP 对象能够传入到 JavaScript 作用域，然后 JavaScript 函数返回一个 boolean。

<?php

$cursor = $collection->find(array('$where' => new MongoCode('function() { return this.x < y; }', array('y'=>$y))));

?>


返回代码的字符串形式

  • ? MongoCode::__construct
  • MongoDate ?
  • PHP Manual
  • MongoCode
  • 返回代码的字符串形式

MongoCode::__toString

(PECL mongo >= 0.8.3)

MongoCode::__toString — 返回代码的字符串形式

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

说明

public MongoCode::__toString ( ) : string

参数

此函数没有参数。

返回值

该代码，不会返回作用域。

范例

Example #1 MongoCode::__toString() 例子

<?php

$code = new MongoCode('return x;', array("x"=>"hi"));
echo "$code\n";

$code = new MongoCode('function() { for(i=0;i<10;i++) { db.foo.update({x:i}, {x:i+1}); } }');
echo "$code\n";

?>

以上例程的输出类似于：

return x;
function() { for(i=0;i<10;i++) { db.foo.update({x:i}, {x:i+1}); } }


The MongoDate class

(PECL mongo >=0.8.1)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\UTCDateTime

简介

Represent date objects for the database. This class should be used to save dates to the database and to query for dates. For example:

Example #1 Storing dates with MongoDate

<?php

// save a date to the database
$collection->save(array("ts" => new MongoDate()));

$start = new MongoDate(strtotime("2010-01-15 00:00:00"));
$end = new MongoDate(strtotime("2010-01-30 00:00:00"));

// find dates between 1/15/2010 and 1/30/2010
$collection->find(array("ts" => array('$gt' => $start, '$lte' => $end)));

?>

MongoDB stores dates as milliseconds past the epoch. This means that dates do not contain timezone information. Timezones must be stored in a separate field if needed. Second, this means that any precision beyond milliseconds will be lost when the document is sent to/from the database.

类摘要

MongoDate {
/* Fields */
public int $sec ;
public int $usec ;
/* 方法 */
public __construct ( int $sec = time() , int $usec = 0 )
public toDateTime ( ) : DateTime
public __toString ( ) : string
}

Table of Contents

  • MongoDate::__construct — 创建一个新的日期。
  • MongoDate::toDateTime — Returns a DateTime object representing this date
  • MongoDate::__toString — 返回该日期的字符串形式的表达


创建一个新的日期。

  • ? MongoDate
  • MongoDate::toDateTime ?
  • PHP Manual
  • MongoDate
  • 创建一个新的日期。

MongoDate::__construct

(PECL mongo >= 0.8.1)

MongoDate::__construct — 创建一个新的日期。

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\UTCDateTime::__construct()

说明

public MongoDate::__construct ( int $sec = time() , int $usec = 0 )

创建一个新的日期。如果没有指定参数，将会使用当前的时间。

参数

sec

自纪元时间以来的秒数(例如 1 Jan 1970 00:00:00.000 UTC)。

usec

微秒。请注意 MongoDB 的解决方案是毫秒而不是微秒，这意味着这个值会被截成毫秒的方案。

返回值

返回该新的时间。

范例

Example #1 MongoDate::__construct() 例子

这个例子演示了用当前时间创建一个新的日期以及给定时间的新日期。

<?php

$d = new MongoDate();
echo "$d\n";
$d = new MongoDate(1234567890);
echo "$d\n";
$d = new MongoDate(strtotime("2009-05-01 00:00:01"));
echo "$d\n";

?>

以上例程的输出类似于：

0.23660600 1235685067
0.00000000 1234567890
0.00000000 1241150401

参见

  • MongoDate::__toString() - 返回该日期的字符串形式的表达


Returns a DateTime object representing this date

  • ? MongoDate::__construct
  • MongoDate::__toString ?
  • PHP Manual
  • MongoDate
  • Returns a DateTime object representing this date

MongoDate::toDateTime

(PECL mongo >= 1.6.0)

MongoDate::toDateTime — Returns a DateTime object representing this date

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\UTCDateTime::toDateTime()

说明

public MongoDate::toDateTime ( ) : DateTime

Returns the DateTime representation of this date. The returned DateTime will use the UTC time zone.

参数

此函数没有参数。

返回值

This date as a DateTime object.

范例

Example #1 MongoDate::toDateTime() example

This example demonstrates creating a DateTime object from a MongoDate object.

<?php
$d = new MongoDate(strtotime("2014-11-18 11:01:25"));
var_dump( $d->toDateTime() );
?>

以上例程的输出类似于：

class DateTime#2 (3) {
  public $date =>
  string(26) "2014-11-18 11:01:25.000000"
  public $timezone_type =>
  int(1)
  public $timezone =>
  string(6) "+00:00"
}


返回该日期的字符串形式的表达

  • ? MongoDate::toDateTime
  • MongoRegex ?
  • PHP Manual
  • MongoDate
  • 返回该日期的字符串形式的表达

MongoDate::__toString

(PECL mongo >= 0.8.1)

MongoDate::__toString — 返回该日期的字符串形式的表达

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\UTCDateTime::__toString()

说明

public MongoDate::__toString ( ) : string

返回该日期的字符串表示形式，类似 microtime() 返回的表示。

参数

此函数没有参数。

返回值

该日期。


MongoRegex 类

(PECL mongo >=0.8.1)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\Regex

简介

这个类用于创建一个正则表达式。 通常这些表达式用于查询数据库中匹配的字符串。不常用的是，它们可以保存到数据库并用于检索。

正则表达式由四部分组成。 首先 / 作为起始的分隔符，然后是 pattern、另一个 / 以及最后包含 flag 的字符串。

Example #1 正则表达式

/pattern/flags

Mongo 能够识别六种正则表达式标记（flag）：

  • i：大小写不敏感

  • m：多行

  • x：能够包含注释

  • l：语言环境

  • s：dotall，"." 匹配任何字符，包括换行符。

  • u：匹配 Unicode

类摘要

MongoRegex {
/* 字段 */
public string $regex ;
public string $flags ;
/* 方法 */
public __construct ( string $regex )
public __toString ( ) : string
}

Table of Contents

  • MongoRegex::__construct — 创建一个新的正则表达式
  • MongoRegex::__toString — 正则表达式的字符串表达形式


创建一个新的正则表达式

  • ? MongoRegex
  • MongoRegex::__toString ?
  • PHP Manual
  • MongoRegex
  • 创建一个新的正则表达式

MongoRegex::__construct

(PECL mongo >= 0.8.1)

MongoRegex::__construct — 创建一个新的正则表达式

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Regex::__construct()

说明

public MongoRegex::__construct ( string $regex )

创建一个新的正则表达式。

参数

regex

以 /expr/flags 形式的正则表达式字符串。

返回值

返回一个新的正则表达式。

范例

Example #1 MongoRegex::__construct() 例子

这个例子使用了正则表达式来查询包含匹配正则表达式的所有文档，用户名字段以 (^) 开始，一个 l 和一个元音字母 ([aeiouy])，大小写不敏感 (/i)。

<?php
$luke_search = new MongoRegex("/^l[aeiouy]/i");
$cursor = $collection->find(array("username" => $luke_search));
?>

参见

  • MongoRegex::__toString() - 正则表达式的字符串表达形式


正则表达式的字符串表达形式

  • ? MongoRegex::__construct
  • MongoBinData ?
  • PHP Manual
  • MongoRegex
  • 正则表达式的字符串表达形式

MongoRegex::__toString

(PECL mongo >= 0.8.1)

MongoRegex::__toString — 正则表达式的字符串表达形式

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Regex::__toString()

说明

public MongoRegex::__toString ( ) : string

返回该正则表达式的字符串表示形式。

参数

此函数没有参数。

返回值

以 "/expr/flags" 形式的正则表达式。

范例

Example #1 MongoRegex::__toString() 例子

<?php

$r = new MongoRegex( "/[a-fA-F0-9]{16}/g" );
echo $r->regex . "\n";
echo $r->flags . "\n";
echo "$r\n";

?>

以上例程的输出类似于：

[a-fA-F0-9]{16}
g
/[a-fA-F0-9]{16}/g


The MongoBinData class

(PECL mongo >= 0.8.1)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\Binary

简介

An object that can be used to store or retrieve binary data from the database.

The maximum size of a single object that can be inserted into the database is 16MB. For data that is larger than this (movies, music, Henry Kissinger's autobiography), use MongoGridFS. For data that is smaller than 16MB, you may find it easier to embed it within the document using MongoBinData.

For example, to embed an image in a document, one could write:

<?php

$profile = array(
    "username" => "foobity",
    "pic" => new MongoBinData(file_get_contents("gravatar.jpg"), MongoBinData::GENERIC),
);

$users->save($profile);

?>

This class contains a type field, which currently gives no additional functionality in the PHP driver or the database. There are seven predefined types, which are defined as class constants below. For backwards compatibility, the PHP driver uses MongoBinData::BYTE_ARRAY as the default; however, this may change to MongoBinData::GENERIC in the future. Users are encouraged to specify a type in MongoBinData::__construct().

类摘要

MongoBinData {
/* 常量 */
const int GENERIC = 0 ;
const int FUNC = 1 ;
const int BYTE_ARRAY = 2 ;
const int UUID = 3 ;
const int UUID_RFC4122 = 4 ;
const int MD5 = 5 ;
const int CUSTOM = 128 ;
/* Fields */
public string $bin ;
public int $type = 2 ;
/* 方法 */
public __construct ( string $data , int $type = 0 )
public __toString ( ) : string
}

预定义常量

Binary Data Types

MongoBinData::GENERIC
Generic binary data.
MongoBinData::FUNC
Function.
MongoBinData::BYTE_ARRAY
Generic binary data (deprecated in favor of MongoBinData::GENERIC).
MongoBinData::UUID
Universally unique identifier (deprecated in favor of MongoBinData::UUID_RFC4122).
MongoBinData::UUID_RFC4122
Universally unique identifier (according to » RFC 4122).
MongoBinData::MD5
MD5.
MongoBinData::CUSTOM
User-defined type.

更新日志

版本 | 说明
1.5.0 | Added MongoBinData::GENERIC and MongoBinData::UUID_RFC4122 constants.

Table of Contents

  • MongoBinData::__construct — 创建一个新的二进制数据对象
  • MongoBinData::__toString — 二进制数据对象的字符串表达形式。


创建一个新的二进制数据对象

  • ? MongoBinData
  • MongoBinData::__toString ?
  • PHP Manual
  • MongoBinData
  • 创建一个新的二进制数据对象

MongoBinData::__construct

(PECL mongo >= 0.8.1)

MongoBinData::__construct — 创建一个新的二进制数据对象

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Binary::__construct()

说明

public MongoBinData::__construct ( string $data , int $type = 0 )

创建一个新的二进制数据对象。

当前有七种类型的二进制数据能被 BSON 规格所识别，在类的常量 中定义。 为了反向兼容性，PHP 默认使用 MongoBinData::BYTE_ARRAY；不过，未来可能修改成 MongoBinData::GENERIC。 用户最好指定下类型，而不该依赖默认类型。

参数

data

二进制数据。

type

数据类型。

返回值

返回一个新的二进制数据对象。

更新日志

版本 | 说明
1.5.0 | 默认值从 2 (MongoBinData::BYTE_ARRAY) 改成 0 (MongoBinData::GENERIC)。
1.2.11 | 没有使用第二个参数时产生 E_DEPRECATED。 type 的默认值在近期的功能里可能会改变。


二进制数据对象的字符串表达形式。

  • ? MongoBinData::__construct
  • MongoInt32 ?
  • PHP Manual
  • MongoBinData
  • 二进制数据对象的字符串表达形式。

MongoBinData::__toString

(PECL mongo >= 0.8.1)

MongoBinData::__toString — 二进制数据对象的字符串表达形式。

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Binary::getData()

说明

public MongoBinData::__toString ( ) : string

参数

此函数没有参数。

返回值

返回字符串 "<Mongo Binary Data>"。要获取 MongoBinData 的内容，使用 bin 字段。


MongoInt32 类

(PECL mongo >=1.0.9)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

作为替代，新的扩展会根据 Integer 的值选择合适的数据库数据类型。

简介

这个类可以在一个 64 位的操作系统上将 32 位的 integer 保存到数据库。

类摘要

MongoInt32 {
/* 字段 */
public string $value ;
/* 方法 */
public __construct ( string $value )
public __toString ( ) : string
}

字段

value
This is the string value of the 64-bit number. 例如，123 的值应该是 "123"。

Table of Contents

  • MongoInt32::__construct — 创建一个新的 32位 integer。
  • MongoInt32::__toString — 返回该 32 位 integer 的字符串表示。


创建一个新的 32位 integer。

  • ? MongoInt32
  • MongoInt32::__toString ?
  • PHP Manual
  • MongoInt32
  • 创建一个新的 32位 integer。

MongoInt32::__construct

(PECL mongo >= 1.0.9)

MongoInt32::__construct — 创建一个新的 32位 integer。

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

作为替代，新扩展会根据 Integer 的值做合适的数据库类型选择。

说明

public MongoInt32::__construct ( string $value )

创建具有指定值的 32 位数字。

参数

value

一个数字。

返回值

返回新的 integer。


返回该 32 位 integer 的字符串表示。

  • ? MongoInt32::__construct
  • MongoInt64 ?
  • PHP Manual
  • MongoInt32
  • 返回该 32 位 integer 的字符串表示。

MongoInt32::__toString

(PECL mongo >= 1.0.9)

MongoInt32::__toString — 返回该 32 位 integer 的字符串表示。

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

作为替代，新扩展会根据 Integer 的值做合适的数据库类型选择。

说明

public MongoInt32::__toString ( ) : string

参数

此函数没有参数。

返回值

返回该 integer 字符串形式的表示。


MongoInt64 类

(PECL mongo >=1.0.9)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

作为替代，新的扩展会根据 Integer 的值选择合适的数据库数据类型。

简介

这个类能够在 32 位的系统上保存一个 64 位的 integer 到数据库。

类摘要

MongoInt64 {
/* 字段 */
public string $value ;
/* 方法 */
public __construct ( string $value )
public __toString ( ) : string
}

字段

value
64 位数字的字符串值。例如 ，123 的值是 "123"。

Table of Contents

  • MongoInt64::__construct — 创建一个新的 64 位 integer。
  • MongoInt64::__toString — 返回该 64 位 integer 的字符串表示形式。


创建一个新的 64 位 integer。

  • ? MongoInt64
  • MongoInt64::__toString ?
  • PHP Manual
  • MongoInt64
  • 创建一个新的 64 位 integer。

MongoInt64::__construct

(PECL mongo >= 1.0.9)

MongoInt64::__construct — 创建一个新的 64 位 integer。

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

作为替代，新扩展会根据 Integer 的值做合适的数据库类型选择。

说明

public MongoInt64::__construct ( string $value )

创建具有指定值的新的 64 位数字。

参数

value

一个数字。

返回值

返回一个新的 integer。


返回该 64 位 integer 的字符串表示形式。

  • ? MongoInt64::__construct
  • MongoDBRef ?
  • PHP Manual
  • MongoInt64
  • 返回该 64 位 integer 的字符串表示形式。

MongoInt64::__toString

(PECL mongo >= 1.0.9)

MongoInt64::__toString — 返回该 64 位 integer 的字符串表示形式。

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

作为替代，新扩展会根据 Integer 的值做合适的数据库类型选择。

说明

public MongoInt64::__toString ( ) : string

参数

此函数没有参数。

返回值

返回该 integer 的字符串表示形式。


MongoDBRef 类

(PECL mongo >=0.9.0)

简介

这个类可以用于创建不同集合中对象间的轻量级的链接。

Motivation：如果我们需要引用其他集合中的文档。最简单的方法是在当前文档中创建一个字段。比如，有 "people" 集合和 "addresses" 集合，我们需要"关联"每个 person 和对应的 address ，可以：

Example #1 链接文档

<?php

$people = $db->people;
$addresses = $db->addresses;

$myAddress = array("line 1" => "123 Main Street",
    "line 2" => null,
    "city" => "Springfield",
    "state" => "Vermont",
    "country" => "USA");

// save the address 保存address文档
$addresses->insert($myAddress);

// save a person with a reference to the address 保存一个people，关联刚才的address
$me = array("name" => "Fred", "address" => $myAddress['_id']);
$people->insert($me);

?>

然后，我们可以：把保存在 "people" 集合中的 MongoId 作为条件，查询 "address" 集合，来获取一个人的地址。

如果我们现在有更加一般性的的情况，我们不知道哪个集合（甚至数据库）中包含我们要引用的文档。 MongoDBRef 就是个好选择，它是一个更加通用的格式，所有的驱动和数据库都可以处理它。

如果每个"人"有一系列关联到其他多个集合的信息，例如爱好、运动、书籍等，我们可以用数个 MongoDBRef 对象来跟踪每一个 爱好 来自哪个集合：

Example #2 Creating MongoDBRef links

<?php

$people = $db->selectCollection("people");

// model trains are in the "hobbies" collection
$trainRef = MongoDBRef::create("hobbies", $modelTrains['_id']);
// soccer is in the "sports" collection
$soccerRef = MongoDBRef::create("sports", $soccer['_id']);

// now we'll know what collections the items in the "likes" array came from when
// we retrieve this document
//  # 现在当我们读取这个文档的时候，就可以知道"likes"字段里的数组元素分别来自哪个集合了。
$people->insert(array("name" => "Fred", "likes" => array($trainRef, $soccerRef)));

?>

数据库引用可以被理解为超链接：它们指定了一个文档的唯一地址，但不会自动读取或者跟踪引用、链接。、

一个数据库引用仅仅是一个普通关联数组，不是 MongoDBRef 的实例，所以这个类与其他数据类型有些不同。这个类只包含静态方法，用来操作引用。 译注：上面两段的意思概括为 1.一个数据库引用与超链接相似，复制、删除、修改等操作不会影响原来的文档。 2.读取这个引用可以得知指向的文档的位置，但不能知道文档的内容，要手动解引用。 3.这个"引用"保存到Mongo的时候就是普通数组

类摘要

MongoDBRef {
/* 方法 */
public static create ( string $collection , mixed $id , string $database = ? ) : array
public static get ( MongoDB $db , array $ref ) : array
public static isRef ( mixed $ref ) : bool
}

参见

MongoDB 官方核心文档 » databases references.

Table of Contents

  • MongoDBRef::create — 创建一个新的数据库引用
  • MongoDBRef::get — 获取引用所指向的对象
  • MongoDBRef::isRef — 检测数组是否为数据库引用


创建一个新的数据库引用

  • ? MongoDBRef
  • MongoDBRef::get ?
  • PHP Manual
  • MongoDBRef
  • 创建一个新的数据库引用

MongoDBRef::create

(PECL mongo >= 0.9.0)

MongoDBRef::create — 创建一个新的数据库引用

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

数据库引用（database reference） 的概念，并且此类已经被弃用。

说明

public static MongoDBRef::create ( string $collection , mixed $id , string $database = ? ) : array

如果没有指定数据库，将会使用当前数据库。

参数

collection

集合名称（不包括数据库名）。

id

要链接的对象的 _id 字段。

database

数据库名。

返回值

返回引用。

范例

Example #1 MongoDBRef::create() 例子

这个例子为文档创建了一个 addresses 的数据库引用。 MongoCollection::getName() 函数返回集合的名字（不包括数据库名）。

<?php
$addresses = $db->addresses;
$people = $db->people;

// 保存 $address，所以它有一个 _id
$addresses->insert($address);

// 创建引用
$ref = MongoDBRef::create($addresses->getName(), $address['_id']);

//设置 $person 里的字段
$person['address'] = $ref;
$people->save($person);
?>

参见

  • MongoDB::createDBRef() - 创建数据库引用
  • MongoCollection::createDBRef() - 创建一个数据库引用


获取引用所指向的对象

  • ? MongoDBRef::create
  • MongoDBRef::isRef ?
  • PHP Manual
  • MongoDBRef
  • 获取引用所指向的对象

MongoDBRef::get

(PECL mongo >= 0.9.0)

MongoDBRef::get — 获取引用所指向的对象

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

数据库引用（database reference） 的概念，并且此类已经被弃用。

说明

public static MongoDBRef::get ( MongoDB $db , array $ref ) : array

参数

db

使用的数据库。

ref

要获取的引用。

返回值

返回引用指向的文档，如果文档不存在则返回 null（该引用已损坏）。

范例

Example #1 MongoCollection::createDBRef() 例子

<?php

// 从 db 获取 $person。
$person = $people->findOne();

// 解析引用的 address
$address = MongoDBRef::get($people->db, $person['address']);

?>

参见

  • MongoDB::getDBRef() - Fetches the document pointed to by a database reference
  • MongoCollection::getDBRef() - Fetches the document pointed to by a database reference


检测数组是否为数据库引用

  • ? MongoDBRef::get
  • MongoMinKey ?
  • PHP Manual
  • MongoDBRef
  • 检测数组是否为数据库引用

MongoDBRef::isRef

(PECL mongo >= 0.9.0)

MongoDBRef::isRef — 检测数组是否为数据库引用

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

数据库引用（database reference） 的概念，并且此类已经被弃用。

说明

public static MongoDBRef::isRef ( mixed $ref ) : bool

这个方法没有真正读取引用的数据，所以它无法检测引用是否损坏。 它仅仅检查 ref 是否为有效的数据库引用格式（一个对象或数组，并具有 $ref 和 $id 的字段）。

参数

ref

要检查的数组或对象。

返回值

成功时返回 true， 或者在失败时返回 false。


The MongoMinKey class

(PECL mongo >= 1.0.2)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\MinKey

简介

MongoMinKey is an special type used by the database that compares less than all other possible BSON values. Thus, if a query is sorted by a given field in ascending order, any document with a MongoMinKey as its value will be returned first.

MongoMinKey has no associated fields, methods, or constants. It is merely the "smallest" value that can be represented in the database.

Note: MongoMinKey is used internally by MongoDB for indexing and sharding. There is generally no reason to use this class in an application.

类摘要

MongoMinKey {
}

Using MongoMinKey as a value

<?php

$collection->insert(array("task" => "lunch", "doBy" => new MongoMinKey));
$collection->insert(array("task" => "staff meeting", "doBy" => new MongoDate(strtotime("+4 days"))));

$cursor = $collection->find()->sort(array("doBy" => 1));

?>

The cursor will return the lunch document followed by the staff meeting document. The lunch document will always be returned first, regardless of what else is added to the collection (unless other documents are added with MongoMinKey in their "doBy" field).

参见

  • MongoMaxKey


The MongoMaxKey class

(PECL mongo >= 1.0.2)

Warning

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\MaxKey

简介

MongoMaxKey is an special type used by the database that compares greater than all other possible BSON values. Thus, if a query is sorted by a given field in ascending order, any document with a MongoMaxKey as its value will be returned last.

MongoMaxKey has no associated fields, methods, or constants. It is merely the "greatest" value that can be represented in the database.

Note: MongoMaxKey is used internally by MongoDB for indexing and sharding. There is generally no reason to use this class in an application.

类摘要

MongoMaxKey {
}

Using MongoMaxKey as a value

<?php

$collection->insert(array("task" => "dishes", "doBy" => new MongoMaxKey));
$collection->insert(array("task" => "staff meeting", "doBy" => new MongoDate(strtotime("+4 days"))));

$cursor = $collection->find()->sort(array("doBy" => 1));

?>

The cursor will return the staff meeting document followed by the dishes document. The dishes document will always be returned last, regardless of what else is added to the collection (unless other documents are added with MongoMaxKey in their "doBy" field).

参见

  • MongoMinKey


MongoTimestamp 类

(PECL mongo >=1.0.1)

简介

MongoTimestamp 用于分片（sharding）。 如果你不是想写分布式工具，你需要的也许是 MongoDate。

MongoTimestamp 是 4 字节的时间戳（自新纪元以来的秒数），和 4 字节的自增长值。

这个类不用于测量时间、为文档创建时间戳或为一个文档自动增加、更新时间戳。 除非你写的是关于分片式内部的交互，否则请停下，直接前往 MongoDate， 不要再继续研究这个东西。这不是你要找的类。

如果你在写一个分片工具，继续阅读。

类摘要

MongoTimestamp {
/* 字段 */
public int $sec = 0 ;
public int $inc = 0 ;
/* 方法 */
public __construct ( int $sec = time() , int $inc = ? )
public __toString ( ) : string
}

Table of Contents

  • MongoTimestamp::__construct — 创建一个新的时间戳。
  • MongoTimestamp::__toString — 返回时间戳的字符串表示形式


创建一个新的时间戳。

  • ? MongoTimestamp
  • MongoTimestamp::__toString ?
  • PHP Manual
  • MongoTimestamp
  • 创建一个新的时间戳。

MongoTimestamp::__construct

(PECL mongo >= 1.0.1)

MongoTimestamp::__construct — 创建一个新的时间戳。

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Timestamp::__construct()

说明

public MongoTimestamp::__construct ( int $sec = time() , int $inc = ? )

创建一个新的时间戳。如果没有指定参数，将使用当前的时间戳，也会自动提供增量。 模块加载时增量设置为 0，并且在每次调用构造器时自动增加（没有传入 $inc 参数时）。

参数

sec

自纪元时间以来的秒数(比如 1 Jan 1970 00:00:00.000 UTC)。

inc

增量。

返回值

返回新的 timestamp。

参见

  • MongoTimestamp::__toString() - 返回时间戳的字符串表示形式


返回时间戳的字符串表示形式

  • ? MongoTimestamp::__construct
  • GridFS Classes ?
  • PHP Manual
  • MongoTimestamp
  • 返回时间戳的字符串表示形式

MongoTimestamp::__toString

(PECL mongo >= 1.0.1)

MongoTimestamp::__toString — 返回时间戳的字符串表示形式

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Timestamp::__toString()

说明

public MongoTimestamp::__toString ( ) : string

返回时间戳里的秒数字段。

参数

此函数没有参数。

返回值

该时间戳自新纪元时间以来的秒数。


  • ? MongoTimestamp::__toString
  • MongoGridFS ?
  • PHP Manual
  • Mongo
  • GridFS Classes

GridFS Classes

Table of Contents

  • MongoGridFS
  • MongoGridFSFile
  • MongoGridFSCursor


The MongoGridFS class

(PECL mongo >=0.9.0)

简介

Utilities for storing and retrieving files from the database.

GridFS is a storage specification all supported drivers implement. Basically, it defines two collections: files, for file metadata, and chunks, for file content. If the file is large, it will automatically be split into smaller chunks and each chunk will be saved as a document in the chunks collection.

Each document in the files collection contains the filename, upload date, and md5 hash. It also contains a unique _id field, which can be used to query the chunks collection for the file's content. Each document in the chunks collection contains a chunk of binary data, a files_id field that matches its file's _id, and the position of this chunk in the overall file.

For example, the files document is something like:

<?php
array("_id" => 123456789, "filename" => "foo.txt", "chunkSize" => 3, "length" => 12);
?>
and the chunks documents look like:
<?php
array("files_id" => 123456789, "n" => 0, "data" => new MongoBinData("abc"));
array("files_id" => 123456789, "n" => 1, "data" => new MongoBinData("def"));
array("files_id" => 123456789, "n" => 2, "data" => new MongoBinData("ghi"));
array("files_id" => 123456789, "n" => 3, "data" => new MongoBinData("jkl"));
?>
Of course, the default chunk size is thousands of bytes, but that makes an unwieldy example.

Inter-Language Compatibility

You should be able to use any files created by MongoGridFS with any other drivers, and vice versa. However, some drivers expect that all metadata associated with a file be in a "metadata" field. If you're going to be using other languages, it's a good idea to wrap info you might want them to see in a "metadata" field. For example, instead of:

<?php

$grid->storeFile("somefile.txt", array("date" => new MongoDate()));

?>

use something like:

<?php

$grid->storeFile("somefile.txt", array("metadata" => array("date" => new MongoDate())));

?>

The MongoGridFS Family

MongoGridFS represents the files and chunks collections. MongoGridFS extends MongoCollection, and an instance of MongoGridFS has access to all of MongoCollection methods, which act on the files collection:

<?php

$grid = $db->getGridFS();
$grid->update(array("filename" => "foo"), $newObj); // update on the files collection

?>

Another example of manipulating metadata:

<?php

// save a file
$id = $grid->storeFile("game.tgz");
$game = $grid->findOne();

// add a downloads counter
$game->file['downloads'] = 0;
$grid->save($game->file);

// increment the counter
$grid->update(array("_id" => $id), array('$inc' => array("downloads" => 1)));

?>

You can also access the chunks collection from an instance of MongoGridFS:

<?php

  $chunks = $grid->chunks; // $chunks is a normal MongoCollection
$chunks->insert(array("x" => 4));

?>

There are some methods for MongoGridFS with the same name as MongoCollection methods, that behave slightly differently. For example, MongoGridFS::remove() will remove any objects that match the criteria from the files collection and their content from the chunks collection.

To store something new in GridFS, there are a couple options. If you have a filename, you can say:

<?php

$grid->storeFile($filename, array("whatever" => "metadata", "you" => "want"));

?>

If you have a string of bytes that isn't a file, you can also store that using MongoGridFS::storeBytes():

<?php

$grid->storeBytes($bytes, array("whatever" => "metadata", "you" => "want"));

?>

Querying a MongoGridFS collection returns a MongoGridFSCursor, which behaves like a normal MongoCursor except that it returns MongoGridFSFiles instead of associative arrays.

MongoGridFSFiles can be written back to disc using MongoGridFSFile::write() or retrieved in memory using MongoGridFSFile::getBytes(). There is currently no method that automatically streams chunks, but it would be fairly easy to write by querying the $grid->chunks collection.

MongoGridFSFile objects contain a field file which contains any file metadata.

类摘要

extends MongoCollection {
/* Fields */
public MongoCollection $chunks = null ;
protected string $filesName = null ;
protected string $chunksName = null ;
/* 方法 */
public __construct ( MongoDB $db , string $prefix = "fs" , mixed $chunks = "fs" )
public delete ( mixed $id ) : bool|array
public drop ( ) : array
public find ( array $query = array() , array $fields = array() ) : MongoGridFSCursor
public findOne ( mixed $query = array() , mixed $fields = array() ) : MongoGridFSFile
public get ( mixed $id ) : MongoGridFSFile
public put ( string $filename , array $metadata = array() , array $options = array() ) : mixed
public remove ( array $criteria = array() , array $options = array() ) : bool|array
public storeBytes ( string $bytes , array $metadata = array() , array $options = array() ) : mixed
public storeFile ( string|resource $filename , array $metadata = array() , array $options = array() ) : mixed
public storeUpload ( string $name , array $metadata = ? ) : mixed
}

参见

  • MongoDB core docs on » GridFS
  • LightCube Solutions blog post on » saving user uploads
  • LightCube Solutions blog post on » adding metadata to files

Table of Contents

  • MongoGridFS::__construct — Creates new file collections
  • MongoGridFS::delete — Remove a file and its chunks from the database
  • MongoGridFS::drop — Drops the files and chunks collections
  • MongoGridFS::find — Queries for files
  • MongoGridFS::findOne — Returns a single file matching the criteria
  • MongoGridFS::get — Retrieve a file from the database
  • MongoGridFS::put — Stores a file in the database
  • MongoGridFS::remove — Remove files and their chunks from the database
  • MongoGridFS::storeBytes — Stores a string of bytes in the database
  • MongoGridFS::storeFile — Stores a file in the database
  • MongoGridFS::storeUpload — Stores an uploaded file in the database


Creates new file collections

  • ? MongoGridFS
  • MongoGridFS::delete ?
  • PHP Manual
  • MongoGridFS
  • Creates new file collections

MongoGridFS::__construct

(PECL mongo >=0.9.0)

MongoGridFS::__construct — Creates new file collections

说明

public MongoGridFS::__construct ( MongoDB $db , string $prefix = "fs" , mixed $chunks = "fs" )

Files as stored across two collections, the first containing file meta information, the second containing chunks of the actual file. By default, fs.files and fs.chunks are the collection names used.

Use one argument to specify a prefix other than "fs":

$fs = new MongoGridFS($db, "myfiles");
uses myfiles.files and myfiles.chunks collections.

参数

db

Database.

files

Optional collection name prefix.


Remove a file and its chunks from the database

  • ? MongoGridFS::__construct
  • MongoGridFS::drop ?
  • PHP Manual
  • MongoGridFS
  • Remove a file and its chunks from the database

MongoGridFS::delete

(PECL mongo >=1.0.8)

MongoGridFS::delete — Remove a file and its chunks from the database

说明

public MongoGridFS::delete ( mixed $id ) : bool|array

Note:

MongoGridFS::delete() is a convenience method for calling MongoGridFS::remove() with specific criteria and default options parameters.

参数

id

_id of the file to remove.

返回值

Returns an array containing the status of the removal (with respect to the files collection) if a write concern is applied. Otherwise, returns true.

Fields in the status array are described in the documentation for MongoCollection::insert().

错误／异常

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.


Drops the files and chunks collections

  • ? MongoGridFS::delete
  • MongoGridFS::find ?
  • PHP Manual
  • MongoGridFS
  • Drops the files and chunks collections

MongoGridFS::drop

(PECL mongo >=0.9.0)

MongoGridFS::drop — Drops the files and chunks collections

说明

public MongoGridFS::drop ( ) : array

参数

此函数没有参数。

返回值

The database response.


Queries for files

  • ? MongoGridFS::drop
  • MongoGridFS::findOne ?
  • PHP Manual
  • MongoGridFS
  • Queries for files

MongoGridFS::find

(PECL mongo >=0.9.0)

MongoGridFS::find — Queries for files

说明

public MongoGridFS::find
 ( array $query = array()
, array $fields = array()
) : MongoGridFSCursor

参数

query

The query.

fields

Fields to return.

返回值

A MongoGridFSCursor.


Returns a single file matching the criteria

  • ? MongoGridFS::find
  • MongoGridFS::get ?
  • PHP Manual
  • MongoGridFS
  • Returns a single file matching the criteria

MongoGridFS::findOne

(PECL mongo >=0.9.0)

MongoGridFS::findOne — Returns a single file matching the criteria

说明

public MongoGridFS::findOne
 ( mixed $query = array()
, mixed $fields = array()
) : MongoGridFSFile

参数

query

The filename or criteria for which to search.

返回值

Returns a MongoGridFSFile or null.

范例

Example #1 MongoGridFS::findOne() example

Example demonstrating how to find a single file from the MongoGridFS.

<?php

$downloads = $mongo->my_db->getGridFS('downloads');

$downloads->storeFile('filename.tgz');

$download = $downloads->findOne('filename.tgz'); // instance of MongoGridFSFile

print_r($download);
?>

See MongoGridFSFile for more information about how to work with files.

以上例程的输出类似于：

MongoGridFSFile Object
(
    [file] => Array
        (
            [_id] => MongoId Object
                (
                )

            [filename] => filename.tgz
            [uploadDate] => MongoDate Object
                (
                    [sec] => 1274288014
                    [usec] => 467000
                )

            [chunkSize] => 262144
            [md5] => d41d8cd98f00b204e9800998ecf8427e
        )

    [gridfs:protected] => MongoGridFS Object
        (
            [chunks] => MongoCollection Object
                (
                )

            [filesName:protected] => downloads.files
            [chunksName:protected] => downloads.chunks
        )

)


Retrieve a file from the database

  • ? MongoGridFS::findOne
  • MongoGridFS::put ?
  • PHP Manual
  • MongoGridFS
  • Retrieve a file from the database

MongoGridFS::get

(PECL mongo >=1.0.8)

MongoGridFS::get — Retrieve a file from the database

说明

public MongoGridFS::get ( mixed $id ) : MongoGridFSFile

参数

id

_id of the file to find.

返回值

Returns the file, if found, or null.


Stores a file in the database

  • ? MongoGridFS::get
  • MongoGridFS::remove ?
  • PHP Manual
  • MongoGridFS
  • Stores a file in the database

MongoGridFS::put

(PECL mongo >=1.0.8)

MongoGridFS::put — Stores a file in the database

说明

public MongoGridFS::put ( string $filename , array $metadata = array() , array $options = array() ) : mixed

Note:

MongoGridFS::put() is an alias of MongoGridFS::storeFile().

参数

filename

Name of the file to store.

metadata

Other metadata fields to include in the file document.

Note:

These fields may also overwrite those that would be created automatically by the driver, as described in the MongoDB core documentation for the » files collection. Some practical use cases for this behavior would be to specify a custom chunkSize or _id for the file.

options

An array of options for the insert operations executed against the chunks and files collections. See MongoCollection::insert() for documentation on these these options.

返回值

Returns the _id of the saved file document. This will be a generated MongoId unless an _id was explicitly specified in the metadata parameter.

错误／异常

Throws MongoGridFSException if there is an error reading filename or inserting into the chunks or files collections.

参见

  • MongoGridFS::storeBytes() - Stores a string of bytes in the database
  • MongoGridFS::storeFile() - Stores a file in the database
  • MongoGridFS::storeUpload() - Stores an uploaded file in the database
  • MongoDB core docs on » GridFS


Remove files and their chunks from the database

  • ? MongoGridFS::put
  • MongoGridFS::storeBytes ?
  • PHP Manual
  • MongoGridFS
  • Remove files and their chunks from the database

MongoGridFS::remove

(PECL mongo >=0.9.0)

MongoGridFS::remove — Remove files and their chunks from the database

说明

public MongoGridFS::remove
 ( array $criteria = array()
, array $options = array()
) : bool|array

参数

criteria

The filename or criteria for which to search.

options

An array of options for the remove operations executed against the chunks and files collections. See MongoCollection::remove() for documentation on these options.

返回值

Returns an array containing the status of the removal (with respect to the files collection) if the "w" option is set. Otherwise, returns true.

Fields in the status array are described in the documentation for MongoCollection::insert().

错误／异常

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.


Stores a string of bytes in the database

  • ? MongoGridFS::remove
  • MongoGridFS::storeFile ?
  • PHP Manual
  • MongoGridFS
  • Stores a string of bytes in the database

MongoGridFS::storeBytes

(PECL mongo >=0.9.2)

MongoGridFS::storeBytes — Stores a string of bytes in the database

说明

public MongoGridFS::storeBytes ( string $bytes , array $metadata = array() , array $options = array() ) : mixed

参数

bytes

String of bytes to store.

metadata

Other metadata fields to include in the file document.

Note:

These fields may also overwrite those that would be created automatically by the driver, as described in the MongoDB core documentation for the » files collection. Some practical use cases for this behavior would be to specify a custom chunkSize or _id for the file.

options

An array of options for the insert operations executed against the chunks and files collections. See MongoCollection::insert() for documentation on these these options.

返回值

Returns the _id of the saved file document. This will be a generated MongoId unless an _id was explicitly specified in the metadata parameter.

错误／异常

Throws MongoGridFSException if there is an error inserting into the chunks or files collections.

范例

Example #1 MongoGridFS::storeBytes() with additional metadata

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$bytes = 'abcdefghijklmnopqrstuvwxyz';
$id = $gridfs->storeBytes($bytes, array('_id' => 'alphabet'));
$gridfsFile = $gridfs->get($id);

var_dump($gridfsFile->file);
?>

以上例程的输出类似于：

array(7) {
  ["_id"]=>
  string(8) "alphabet"
  ["uploadDate"]=>
  object(MongoDate)#7 (0) {
  }
  ["length"]=>
  int(26)
  ["chunkSize"]=>
  int(262144)
  ["md5"]=>
  string(32) "c3fcd3d76192e4007dfb496cca67e13b"
}

参见

  • MongoGridFS::put() - Stores a file in the database
  • MongoGridFS::storeFile() - Stores a file in the database
  • MongoGridFS::storeUpload() - Stores an uploaded file in the database
  • MongoDB core docs on » GridFS


Stores a file in the database

  • ? MongoGridFS::storeBytes
  • MongoGridFS::storeUpload ?
  • PHP Manual
  • MongoGridFS
  • Stores a file in the database

MongoGridFS::storeFile

(PECL mongo >=0.9.0)

MongoGridFS::storeFile — Stores a file in the database

说明

public MongoGridFS::storeFile ( string|resource $filename , array $metadata = array() , array $options = array() ) : mixed

参数

filename

Name of the file or a readable stream to store.

metadata

Other metadata fields to include in the file document.

Note:

These fields may also overwrite those that would be created automatically by the driver, as described in the MongoDB core documentation for the » files collection. Some practical use cases for this behavior would be to specify a custom chunkSize or _id for the file.

options

An array of options for the insert operations executed against the chunks and files collections. See MongoCollection::insert() for documentation on these these options.

返回值

Returns the _id of the saved file document. This will be a generated MongoId unless an _id was explicitly specified in the metadata parameter.

错误／异常

Throws MongoGridFSException if there is an error reading filename or inserting into the chunks or files collections.

范例

Example #1 MongoGridFS::storeFile() with additional metadata

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$id = $gridfs->storeFile('example.txt', array('contentType' => 'plain/text'));
$gridfsFile = $gridfs->get($id);

var_dump($gridfsFile->file);
?>

以上例程的输出类似于：

array(7) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["contentType"]=>
  string(10) "plain/text"
  ["filename"]=>
  string(11) "example.txt"
  ["uploadDate"]=>
  object(MongoDate)#7 (0) {
  }
  ["length"]=>
  int(26)
  ["chunkSize"]=>
  int(262144)
  ["md5"]=>
  string(32) "c3fcd3d76192e4007dfb496cca67e13b"
}

参见

  • MongoGridFS::put() - Stores a file in the database
  • MongoGridFS::storeBytes() - Stores a string of bytes in the database
  • MongoGridFS::storeUpload() - Stores an uploaded file in the database
  • MongoDB core docs on » GridFS


Stores an uploaded file in the database

  • ? MongoGridFS::storeFile
  • MongoGridFSFile ?
  • PHP Manual
  • MongoGridFS
  • Stores an uploaded file in the database

MongoGridFS::storeUpload

(PECL mongo >=0.9.0)

MongoGridFS::storeUpload — Stores an uploaded file in the database

说明

public MongoGridFS::storeUpload ( string $name , array $metadata = ? ) : mixed

参数

name

The name of the uploaded file(s) to store. This should correspond to the file field's name attribute in the HTML form.

metadata

Other metadata fields to include in the file document.

Note:

These fields may also overwrite those that would be created automatically by the driver, as described in the MongoDB core documentation for the » files collection. Some practical use cases for this behavior would be to specify a custom chunkSize or _id for the file.

Note:

The filename field will be populated with the client's filename (e.g. $_FILES['foo']['name']).

返回值

Returns the _id of the saved file document. This will be a generated MongoId unless an _id was explicitly specified in the metadata parameter.

Note:

If multiple files are uploaded using the same field name, this method will not return anything; however, the files themselves will still be processed.

错误／异常

Throws MongoGridFSException if there is an error reading the uploaded file(s) or inserting into the chunks or files collections.

更新日志

版本 | 说明
PECL mongo 1.2.5 | Changed second parameter to an array of metadata. Pre-1.2.5, the second parameter was an optional string overriding the filename.

范例

Example #1 MongoGridFS::storeUpload() HTML form example

Suppose you have the following HTML form:

<form method="POST" enctype="multipart/form-data">
    <label for="username">Username:</label>
    <input type="text" name="username" id="username" />

    <label for="pic">Please upload a profile picture:</label>
    <input type="file" name="pic" id="pic" />

    <input type="submit" />
</form>

If you wanted to store the uploaded image in MongoDB, you could do the following in the script handling the form submission:

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$gridfs->storeUpload('pic', array('username' => $_POST['username']));
?>

参见

  • MongoGridFS::put() - Stores a file in the database
  • MongoGridFS::storeBytes() - Stores a string of bytes in the database
  • MongoGridFS::storeFile() - Stores a file in the database
  • MongoDB core docs on » GridFS


The MongoGridFSFile class

(PECL mongo >=0.9.0)

简介

A database file object.

类摘要

MongoGridFSFile {
/* Fields */
public array $file = null ;
protected MongoGridFS $gridfs = null ;
/* 方法 */
public MongoGridfsFile::__construct ( MongoGridFS $gridfs , array $file )
public getBytes ( ) : string
public getFilename ( ) : string
public getResource ( ) : resource
public getSize ( ) : int
public write ( string $filename = null ) : int
}

Table of Contents

  • MongoGridfsFile::__construct — Create a new GridFS file
  • MongoGridFSFile::getBytes — Returns this file's contents as a string of bytes
  • MongoGridFSFile::getFilename — Returns this file's filename
  • MongoGridFSFile::getResource — Returns a resource that can be used to read the stored file
  • MongoGridFSFile::getSize — Returns this file's size
  • MongoGridFSFile::write — Writes this file to the filesystem


Create a new GridFS file

  • ? MongoGridFSFile
  • MongoGridFSFile::getBytes ?
  • PHP Manual
  • MongoGridFSFile
  • Create a new GridFS file

MongoGridfsFile::__construct

(PECL mongo >=0.9.0)

MongoGridfsFile::__construct — Create a new GridFS file

说明

public MongoGridfsFile::__construct ( MongoGridFS $gridfs , array $file )

参数

gridfs

The parent MongoGridFS instance.

file

A file from the database.

返回值

Returns a new MongoGridFSFile.


Returns this file's contents as a string of bytes

  • ? MongoGridfsFile::__construct
  • MongoGridFSFile::getFilename ?
  • PHP Manual
  • MongoGridFSFile
  • Returns this file's contents as a string of bytes

MongoGridFSFile::getBytes

(PECL mongo >=0.9.0)

MongoGridFSFile::getBytes — Returns this file's contents as a string of bytes

说明

public MongoGridFSFile::getBytes ( ) : string

Warning: this will load the file into memory. If the file is bigger than your memory, this will cause problems!

参数

此函数没有参数。

返回值

Returns a string of the bytes in the file.

范例

Example #1 MongoGridFSFile::getBytes() example

<?php

$images = $db->my_db->getGridFS('images');

$image = $images->findOne('jwage.png');

header('Content-type: image/png;');
echo $image->getBytes();
?>


Returns this file's filename

  • ? MongoGridFSFile::getBytes
  • MongoGridFSFile::getResource ?
  • PHP Manual
  • MongoGridFSFile
  • Returns this file's filename

MongoGridFSFile::getFilename

(PECL mongo >=0.9.0)

MongoGridFSFile::getFilename — Returns this file's filename

说明

public MongoGridFSFile::getFilename ( ) : string

参数

此函数没有参数。

返回值

Returns the filename.


Returns a resource that can be used to read the stored file

  • ? MongoGridFSFile::getFilename
  • MongoGridFSFile::getSize ?
  • PHP Manual
  • MongoGridFSFile
  • Returns a resource that can be used to read the stored file

MongoGridFSFile::getResource

(PECL mongo >=1.3.0)

MongoGridFSFile::getResource — Returns a resource that can be used to read the stored file

说明

public MongoGridFSFile::getResource ( ) : resource

This method returns a stream resource that can be used with all file functions in PHP that deal with reading files. The contents of the file are pulled out of MongoDB on the fly, so that the whole file does not have to be loaded into memory first.

At most two GridFSFile chunks will be loaded in memory.

参数

此函数没有参数。

返回值

Returns a resource that can be used to read the file with

范例

Example #1 MongoGridFSFile::getResource() example

<?php
$m = new Mongo;
$images = $m->my_db->getGridFS('images');

$image = $images->findOne('mongo.png');

header('Content-type: image/png;');
$stream = $image->getResource();

while (!feof($stream)) {
    echo fread($stream, 8192);
}
?>


Returns this file's size

  • ? MongoGridFSFile::getResource
  • MongoGridFSFile::write ?
  • PHP Manual
  • MongoGridFSFile
  • Returns this file's size

MongoGridFSFile::getSize

(PECL mongo >=0.9.0)

MongoGridFSFile::getSize — Returns this file's size

说明

public MongoGridFSFile::getSize ( ) : int

参数

此函数没有参数。

返回值

Returns this file's size


Writes this file to the filesystem

  • ? MongoGridFSFile::getSize
  • MongoGridFSCursor ?
  • PHP Manual
  • MongoGridFSFile
  • Writes this file to the filesystem

MongoGridFSFile::write

(PECL mongo >=0.9.0)

MongoGridFSFile::write — Writes this file to the filesystem

说明

public MongoGridFSFile::write ( string $filename = null ) : int

参数

filename

The location to which to write the file. If none is given, the stored filename will be used.

返回值

Returns the number of bytes written.

范例

Example #1 MongoGridFSFile::write() example

<?php

$images = $db->my_db->getGridFS('images');

$image = $images->findOne('jwage.png');
$image->write('/path/to/write/jwage.png');
?>


The MongoGridFSCursor class

(PECL mongo >=0.9.0)

简介

Cursor for database file results.

类摘要

extends MongoCursor {
/* Fields */
protected MongoGridFS $gridfs = null ;
/* 方法 */
public __construct ( MongoGridFS $gridfs , resource $connection , string $ns , array $query , array $fields )
public current ( ) : MongoGridFSFile
public getNext ( ) : MongoGridFSFile
public key ( ) : string
}

Table of Contents

  • MongoGridFSCursor::__construct — Create a new cursor
  • MongoGridFSCursor::current — Returns the current file
  • MongoGridFSCursor::getNext — Return the next file to which this cursor points, and advance the cursor
  • MongoGridFSCursor::key — Returns the current result's filename


Create a new cursor

  • ? MongoGridFSCursor
  • MongoGridFSCursor::current ?
  • PHP Manual
  • MongoGridFSCursor
  • Create a new cursor

MongoGridFSCursor::__construct

(PECL mongo >=0.9.0)

MongoGridFSCursor::__construct — Create a new cursor

说明

public MongoGridFSCursor::__construct ( MongoGridFS $gridfs , resource $connection , string $ns , array $query , array $fields )

参数

gridfs

Related GridFS collection.

connection

Database connection.

ns

Full name of database and collection.

query

Database query.

fields

Fields to return.

返回值

Returns the new cursor.


Returns the current file

  • ? MongoGridFSCursor::__construct
  • MongoGridFSCursor::getNext ?
  • PHP Manual
  • MongoGridFSCursor
  • Returns the current file

MongoGridFSCursor::current

(PECL mongo >=0.9.0)

MongoGridFSCursor::current — Returns the current file

说明

public MongoGridFSCursor::current ( ) : MongoGridFSFile

参数

此函数没有参数。

返回值

The current file.


Return the next file to which this cursor points, and advance the cursor

  • ? MongoGridFSCursor::current
  • MongoGridFSCursor::key ?
  • PHP Manual
  • MongoGridFSCursor
  • Return the next file to which this cursor points, and advance the cursor

MongoGridFSCursor::getNext

(PECL mongo >=0.9.0)

MongoGridFSCursor::getNext — Return the next file to which this cursor points, and advance the cursor

说明

public MongoGridFSCursor::getNext ( ) : MongoGridFSFile

参数

此函数没有参数。

返回值

Returns the next file.


Returns the current result's filename

  • ? MongoGridFSCursor::getNext
  • Miscellaneous ?
  • PHP Manual
  • MongoGridFSCursor
  • Returns the current result's filename

MongoGridFSCursor::key

(PECL mongo >=0.9.0)

MongoGridFSCursor::key — Returns the current result's filename

说明

public MongoGridFSCursor::key ( ) : string

参数

此函数没有参数。

返回值

The current result's _id as a string.

更新日志

版本 | 说明
PECL mongo 1.3.0 | The document's _id is returned as a string value, since the key should be unique. Pre-1.3.0, filename was returned.


  • ? MongoGridFSCursor::key
  • MongoLog ?
  • PHP Manual
  • Mongo
  • Miscellaneous

Miscellaneous

Table of Contents

  • MongoLog
  • MongoPool
  • Mongo


The MongoLog class

(PECL mongo >=1.2.3)

简介

Logging can be used to get detailed information about what the driver is doing. Logging is disabled by default, but this class allows you to activate specific levels of logging for various parts of the driver. Some examples:

<?php

// print every log message possible
MongoLog::setLevel(MongoLog::ALL); // all log levels
MongoLog::setModule(MongoLog::ALL); // all parts of the driver

// print significant events about replica set failover
MongoLog::setLevel(MongoLog::INFO);
MongoLog::setModule(MongoLog::RS);

// print info- and diagnostic-level events for replica sets and connections
MongoLog::setLevel(MongoLog::INFO|MongoLog::FINE);
MongoLog::setModule(MongoLog::RS|MongoLog::CON);

?>

Note:

By default, MongoLog emits all log messages as PHP notices. Depending on the SAPI you use, messages may be sent to stderr (for CLI) or the web server's error log. If, after configuring MongoLog, log messages are not appearing as expected, ensure that the E_NOTICE bit is included in error_reporting and that display_errors is on.

类摘要

MongoLog {
/* 常量 */
const int NONE = 0 ;
const int ALL = 31 ;
level constants {
const int WARNING = 1 ;
const int INFO = 2 ;
const int FINE = 4 ;
module constants {
const int RS = 1 ;
const int POOL = 1 ;
const int CON = 2 ;
const int IO = 4 ;
const int SERVER = 8 ;
const int PARSE = 16 ;
/* Fields */
private static int $callback ;
private static int $level ;
private static int $module ;
/* 方法 */
public static getCallback ( ) : callable
public static getLevel ( ) : int
public static getModule ( ) : int
public static setCallback ( callable $log_function ) : void
public static setLevel ( int $level ) : void
public static setModule ( int $module ) : void
}

预定义常量

MongoLog Constants

These constants can be used by both MongoLog::setLevel() and MongoLog::setModule().

MongoLog::NONE
Log nothing.
MongoLog::ALL
Log everything.

MongoLog Level Constants

These constants can be used by MongoLog::setLevel().

MongoLog::WARNING
Log events that are somewhat exceptional, but not quite worthy of an actual exception (e.g. recoverable connection errors).
MongoLog::INFO
Log events that may be of interest to administrators, but are not particularly noteworthy (e.g. option parsing, authentication steps).
MongoLog::FINE
Log most events that the driver performs (e.g. server selection, socket communication). Depending on the module being logged, this can be extremely noisy and is primarily useful for debugging.

MongoLog Module Constants

These constants can be used by MongoLog::setModule().

MongoLog::CON
Log connection activity. Creating new connections, authentication, pinging, timeouts, etc.
MongoLog::IO
Log traffic to/from the database. Unless your program is trivial, this will create an enormous number of log messages.
MongoLog::PARSE
Log parsing of the connection string and options when constructing MongoClient.
MongoLog::POOL
Previously used to log connection pool activity. This option is now a deprecated alias of MongoLog::RS.
MongoLog::RS
Log replica set activity. Failovers, read preference selection, etc.
MongoLog::SERVER
Previously used to log server status changes. This option is deprecated in favor of MongoLog::RS.

更新日志

版本 | 说明
PECL mongo 1.3.0 | Added MongoLog::CON and deprecated MongoLog::POOL and MongoLog::SERVER.

Table of Contents

  • MongoLog::getCallback — Gets the previously set callback function
  • MongoLog::getLevel — Gets the level(s) currently being logged
  • MongoLog::getModule — Gets the module(s) currently being logged
  • MongoLog::setCallback — Sets a callback function to be invoked for events
  • MongoLog::setLevel — Sets the level(s) to be logged
  • MongoLog::setModule — Sets the module(s) to be logged


Gets the previously set callback function

  • ? MongoLog
  • MongoLog::getLevel ?
  • PHP Manual
  • MongoLog
  • Gets the previously set callback function

MongoLog::getCallback

(PECL mongo >= 1.3.0)

MongoLog::getCallback — Gets the previously set callback function

说明

public static MongoLog::getCallback ( ) : callable

Retrieves the callback function.

参数

此函数没有参数。

返回值

Returns the callback function, or false if not set yet.

注释

Caution

This function is only available with PHP 5.3.0 and later.


Gets the level(s) currently being logged

  • ? MongoLog::getCallback
  • MongoLog::getModule ?
  • PHP Manual
  • MongoLog
  • Gets the level(s) currently being logged

MongoLog::getLevel

(PECL mongo >= 1.2.3)

MongoLog::getLevel — Gets the level(s) currently being logged

说明

public static MongoLog::getLevel ( ) : int

This function can be used to see which log levels are currently enabled. The returned integer may be compared with the MongoLog level constants using bitwise operators to check for specific log levels.

<?php

if (MongoLog::getLevel() & MongoLog::FINE) {
    echo "lots of logs\n";
}

if (MongoLog::getLevel() ^ MongoLog::NONE) {
    echo "logging, at least a little\n";
}

if (MongoLog::getLevel() == MongoLog::ALL) {
    echo "logging at the highest levels\n";
}

?>

参数

此函数没有参数。

返回值

Returns the level(s) currently being logged.


Gets the module(s) currently being logged

  • ? MongoLog::getLevel
  • MongoLog::setCallback ?
  • PHP Manual
  • MongoLog
  • Gets the module(s) currently being logged

MongoLog::getModule

(PECL mongo >= 1.2.3)

MongoLog::getModule — Gets the module(s) currently being logged

说明

public static MongoLog::getModule ( ) : int

This function can be used to see which driver modules are currently being logged. The returned integer may be compared with the MongoLog module constants using bitwise operators to check if specific modules are being logged.

<?php

if (MongoLog::getModule() & MongoLog::RS) {
    echo "logging replica sets\n";
}

if (MongoLog::getModule() ^ MongoLog::NONE) {
    echo "logging something\n";
}

if ((MongoLog::getModule() & MongoLog::IO) == 0) {
    echo "not logging io\n";
}

?>

参数

此函数没有参数。

返回值

Returns the module(s) currently being logged.


Sets a callback function to be invoked for events

  • ? MongoLog::getModule
  • MongoLog::setLevel ?
  • PHP Manual
  • MongoLog
  • Sets a callback function to be invoked for events

MongoLog::setCallback

(PECL mongo >= 1.3.0)

MongoLog::setCallback — Sets a callback function to be invoked for events

说明

public static MongoLog::setCallback ( callable $log_function ) : void

This function will set a callback function to be invoked for events in lieu of emitting of PHP notice.

参数

log_function

The callback function to be invoked on events. It should have the following prototype:

log_function ( int $module , int $level , string $message )
module
One of the MongoLog module constants.
level
One of the MongoLog level constants.
message
The log message itself.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 MongoLog::setCallback() example

<?php

function module2string($module)
{
    switch ($module) {
        case MongoLog::RS: return "REPLSET";
        case MongoLog::CON: return "CON";
        case MongoLog::IO: return "IO";
        case MongoLog::SERVER: return "SERVER";
        case MongoLog::PARSE: return "PARSE";
        default: return "UNKNOWN";
    }
}

function level2string($level)
{
    switch ($level) {
        case MongoLog::WARNING: return "WARN";
        case MongoLog::INFO: return "INFO";
        case MongoLog::FINE: return "FINE";
        default: return "UNKNOWN";
    }
}

function callback($module, $level, $message)
{
    echo date("Y-m-d H:i:s - ");
    printf("%s (%s): %s\n", module2string($module), level2string($level), $message);
}

MongoLog::setLevel(MongoLog::ALL);
MongoLog::setModule(MongoLog::ALL);

// We specify the function name here, but any callable (e.g. anonymous function) will work
MongoLog::setCallback("callback");

new MongoClient();
?>

以上例程的输出类似于：

2013-07-09 09:41:42 - PARSE (INFO): Parsing localhost:27017
2013-07-09 09:41:42 - PARSE (INFO): - Found node: localhost:27017
2013-07-09 09:41:42 - PARSE (INFO): - Connection type: STANDALONE
2013-07-09 09:41:42 - CON (INFO): mongo_get_read_write_connection: finding a STANDALONE connection
2013-07-09 09:41:42 - CON (INFO): connection_create: creating new connection for localhost:27017
2013-07-09 09:41:42 - CON (INFO): stream_connect: Not establishing SSL for localhost:27017
2013-07-09 09:41:42 - CON (INFO): get_server_flags: start
2013-07-09 09:41:42 - CON (FINE): send_packet: read from header: 36
2013-07-09 09:41:42 - CON (FINE): send_packet: data_size: 95
2013-07-09 09:41:42 - CON (FINE): get_server_flags: setting maxBsonObjectSize to 16777216
2013-07-09 09:41:42 - CON (FINE): get_server_flags: setting maxMessageSizeBytes to 48000000
2013-07-09 09:41:42 - CON (INFO): is_ping: pinging localhost:27017;-;.;1543
2013-07-09 09:41:42 - CON (FINE): send_packet: read from header: 36
2013-07-09 09:41:42 - CON (FINE): send_packet: data_size: 17
2013-07-09 09:41:42 - CON (INFO): is_ping: last pinged at 1373359302; time: 0ms
2013-07-09 09:41:42 - REPLSET (FINE): finding candidate servers
2013-07-09 09:41:42 - REPLSET (FINE): - all servers
2013-07-09 09:41:42 - REPLSET (FINE): filter_connections: adding connections:
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): filter_connections: done
2013-07-09 09:41:42 - REPLSET (FINE): limiting by seeded/discovered servers
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): limiting by seeded/discovered servers: done
2013-07-09 09:41:42 - REPLSET (FINE): limiting by credentials
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): limiting by credentials: done
2013-07-09 09:41:42 - REPLSET (FINE): sorting servers by priority and ping time
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): sorting servers: done
2013-07-09 09:41:42 - REPLSET (FINE): selecting near servers
2013-07-09 09:41:42 - REPLSET (FINE): selecting near servers: nearest is 0ms
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): selecting near server: done
2013-07-09 09:41:42 - REPLSET (INFO): pick server: random element 0
2013-07-09 09:41:42 - REPLSET (INFO): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543

注释

Caution

This function is only available with PHP 5.3.0 and later.


Sets the level(s) to be logged

  • ? MongoLog::setCallback
  • MongoLog::setModule ?
  • PHP Manual
  • MongoLog
  • Sets the level(s) to be logged

MongoLog::setLevel

(PECL mongo >= 1.2.3)

MongoLog::setLevel — Sets the level(s) to be logged

说明

public static MongoLog::setLevel ( int $level ) : void

This function can be used to control logging verbosity and the types of activities that should be logged. The MongoLog level constants may be used with bitwise operators to specify multiple levels.

<?php

// first, specify a logging module
MongoLog::setModule(MongoLog::CON);

// log messages for every level
MongoLog::setLevel(MongoLog::ALL);

// log warning and info messages only
MongoLog::setLevel(MongoLog::WARNING|MongoLog::INFO);

// log everything except fine activity
MongoLog::setLevel(MongoLog::ALL & (~MongoLog::FINE));

?>

Note that you must also call MongoLog::setModule() to specify which modules(s) of the driver should log.

参数

level

The level(s) you would like to log.


Sets the module(s) to be logged

  • ? MongoLog::setLevel
  • MongoPool ?
  • PHP Manual
  • MongoLog
  • Sets the module(s) to be logged

MongoLog::setModule

(PECL mongo >= 1.2.3)

MongoLog::setModule — Sets the module(s) to be logged

说明

public static MongoLog::setModule ( int $module ) : void

This function can be used to set which driver modules should be logged. The MongoLog module constants may be used with bitwise operators to specify multiple modules.

<?php

// first, specify a logging level
MongoLog::setLevel(MongoLog::ALL);

// log replica set activity
MongoLog::setModule(MongoLog::RS);

// log replica sets and connection activity
MongoLog::setModule(MongoLog::RS|MongoLog::CON);

// log everything except IO activity
MongoLog::setModule(MongoLog::ALL & (~MongoLog::IO));

?>

Note that you must also call MongoLog::setLevel() to enable logging.

参数

module

The module(s) you would like to log.


The MongoPool class

(PECL mongo >= 1.2.3)

简介

Warning

The current (1.3.0+) releases of the driver no longer implements pooling. This class and its methods are therefore deprecated and should not be used.

类摘要

MongoPool {
/* 方法 */
public static getSize ( ) : int
public info ( ) : array
public static setSize ( int $size ) : bool
}

更新日志

版本 | 说明
PECL mongo 1.3.0 | This functionality has been removed and no longer does anything other than emit deprecation warnings. This class is only kept around for backwards compatibility and will be removed in the near future.
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

Table of Contents

  • MongoPool::getSize — Get pool size for connection pools
  • MongoPool::info — Returns information about all connection pools
  • MongoPool::setSize — Set the size for future connection pools


Get pool size for connection pools

  • ? MongoPool
  • MongoPool::info ?
  • PHP Manual
  • MongoPool
  • Get pool size for connection pools

MongoPool::getSize

(PECL mongo >= 1.2.3)

MongoPool::getSize — Get pool size for connection pools

说明

public static MongoPool::getSize ( ) : int

参数

此函数没有参数。

返回值

Returns the current pool size.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

范例

Example #1 Changing pool size

This returns the default pool size, sets a new pool size, then prints the new pool size and the pool debugging information. Note that changing the pool size only affects new connection pools, it does not change old ones.

<?php

$connection = new Mongo("host1");

// pool size is -1
echo "pool size is: ".MongoPool::getSize()."\n";

echo "setting pool size to 200\n";

MongoPool::setSize(200);

// pool size is 200
echo "pool size is: ".MongoPool::getSize()."\n";

$conn2 = new Mongo("host2");

// remaining for host1 is -2
// remaining for host2 is 199
var_dump(Mongo::poolDebug());

?>

参见

  • MongoPool::setSize() - Set the size for future connection pools
  • MongoPool::info() - Returns information about all connection pools
  • The connection documentation.


Returns information about all connection pools

  • ? MongoPool::getSize
  • MongoPool::setSize ?
  • PHP Manual
  • MongoPool
  • Returns information about all connection pools

MongoPool::info

(PECL mongo >= 1.2.3)

MongoPool::info — Returns information about all connection pools

说明

public MongoPool::info ( ) : array

Returns an array of information about all connection pools.

参数

此函数没有参数。

返回值

Each connection pool has an identifier, which starts with the host. For each pool, this function shows the following fields:

in use

The number of connections currently being used by Mongo instances.

in pool

The number of connections currently in the pool (not being used).

remaining

The number of connections that could be created by this pool. For example, suppose a pool had 5 connections remaining and 3 connections in the pool. We could create 8 new instances of MongoClient before we exhausted this pool (assuming no instances of MongoClient went out of scope, returning their connections to the pool).

A negative number means that this pool will spawn unlimited connections.

Before a pool is created, you can change the max number of connections by calling Mongo::setPoolSize(). Once a pool is showing up in the output of this function, its size cannot be changed.

total

The total number of connections allowed for this pool. This should be greater than or equal to "in use" + "in pool" (or -1).

timeout

The socket timeout for connections in this pool. This is how long connections in this pool will attempt to connect to a server before giving up.

waiting

If you have capped the pool size, workers requesting connections from the pool may block until other workers return their connections. This field shows how many milliseconds workers have blocked for connections to be released. If this number keeps increasing, you may want to use MongoPool::setSize() to add more connections to your pool.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.


Set the size for future connection pools

  • ? MongoPool::info
  • Mongo ?
  • PHP Manual
  • MongoPool
  • Set the size for future connection pools

MongoPool::setSize

(PECL mongo >= 1.2.3)

MongoPool::setSize — Set the size for future connection pools

说明

public static MongoPool::setSize ( int $size ) : bool

Sets the max number of connections new pools will be able to create.

参数

size

The max number of connections future pools will be able to create. Negative numbers mean that the pool will spawn an infinite number of connections.

返回值

Returns the former value of pool size.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

范例

Example #1 Mongo::setPoolSize() example

If you set the pool size to n and then create n connections, attempting to create an n+1st connection will throw a MongoConnectionException.

<?php

// only allow one connection to a server
MongoPool::setSize(1);

// creates one connection to localhost:27017
$m1 = new Mongo();

// attempt to create a second connection to localhost:27017
// only one connection is allowed, so this will throw an exception
$m2 = new Mongo();

?>

以上例程的输出类似于：

Fatal error: Uncaught exception 'MongoConnectionException' with message 'no more connections in pool' in /path/to/php/script.php:10
Stack trace:
#0 /path/to/php/script.php(10): Mongo->__construct()
#1 {main}
  thrown in /path/to/php/script.php on line 10

参见

  • MongoPool::getSize() - Get pool size for connection pools
  • MongoPool::info() - Returns information about all connection pools
  • The connection documentation.


The Mongo class [deprecated]

(PECL mongo >=0.9.0)

简介

A connection between PHP and MongoDB.

This class extends MongoClient and provides access to several deprecated methods.

For backwards compatibility, it also defaults the "w" option of its constructor argument to 0, which does not require write operations to be acknowledged by the server. See MongoClient::__construct() for more information.

Warning

This class has been DEPRECATED as of version 1.3.0. Relying on this feature is highly discouraged. Please use MongoClient instead.

类摘要

Mongo extends MongoClient {
/* 方法 */
protected connectUtil ( ) : bool
public static getPoolSize ( ) : int
public getSlave ( ) : string
public getSlaveOkay ( ) : bool
public poolDebug ( ) : array
public static setPoolSize ( int $size ) : bool
public setSlaveOkay ( bool $ok = true ) : bool
public switchSlave ( ) : string
/* 继承的方法 */
public MongoClient::close ( boolean|string $connection = ? ) : bool
public MongoClient::connect ( ) : bool
public MongoClient::dropDB ( mixed $db ) : array
public MongoClient::__get ( string $dbname ) : MongoDB
public static MongoClient::getConnections ( ) : array
public MongoClient::getHosts ( ) : array
public MongoClient::getReadPreference ( ) : array
public MongoClient::getWriteConcern ( ) : array
public MongoClient::killCursor ( string $server_hash , int|MongoInt64 $id ) : bool
public MongoClient::listDBs ( ) : array
public MongoClient::selectCollection ( string $db , string $collection ) : MongoCollection
public MongoClient::selectDB ( string $name ) : MongoDB
public MongoClient::setReadPreference ( string $read_preference , array $tags = ? ) : bool
public MongoClient::setWriteConcern ( mixed $w , int $wtimeout = ? ) : bool
public MongoClient::__toString ( ) : string
}

Table of Contents

  • Mongo::connectUtil — Connects with a database server
  • Mongo::__construct — The __construct purpose
  • Mongo::getPoolSize — Get pool size for connection pools
  • Mongo::getSlave — Returns the address being used by this for slaveOkay reads
  • Mongo::getSlaveOkay — Get slaveOkay setting for this connection
  • Mongo::poolDebug — Returns information about all connection pools
  • Mongo::setPoolSize — Set the size for future connection pools
  • Mongo::setSlaveOkay — Change slaveOkay setting for this connection
  • Mongo::switchSlave — Choose a new secondary for slaveOkay reads


Connects with a database server

  • ? Mongo
  • Mongo::__construct ?
  • PHP Manual
  • Mongo
  • Connects with a database server

Mongo::connectUtil

(PECL mongo >=0.9.0)

Mongo::connectUtil — Connects with a database server

说明

protected Mongo::connectUtil ( ) : bool
Warning

This is an internal function that you should never call yourself.

参数

此函数没有参数。

返回值

If the connection was successful.

错误／异常

Throws MongoConnectionException if it fails to connect to the databases.


The __construct purpose

  • ? Mongo::connectUtil
  • Mongo::getPoolSize ?
  • PHP Manual
  • Mongo
  • The __construct purpose

Mongo::__construct

(PECL mongo >=0.9.0)

Mongo::__construct — The __construct purpose

说明

public Mongo::__construct ( string $server = ? , array $options = ? )

This method overwrites the MongoClient constructor and turns off acknowledged writes.

Please see MongoClient::__construct() for description of the parameters.

返回值

Warning

Instanciating this class will emit E_DEPRECATED warning, and turn off acknowledged writes.

Please use the MongoClient instead.


Get pool size for connection pools

  • ? Mongo::__construct
  • Mongo::getSlave ?
  • PHP Manual
  • Mongo
  • Get pool size for connection pools

Mongo::getPoolSize

(PECL mongo >=1.2.0)

Mongo::getPoolSize — Get pool size for connection pools

说明

public static Mongo::getPoolSize ( ) : int
Warning

This feature has been DEPRECATED as of version 1.2.3. Relying on this feature is highly discouraged. Please use MongoPool::getSize() instead.

参数

此函数没有参数。

返回值

Returns the current pool size.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

范例

Example #1 Changing pool size

This returns the default pool size, sets a new pool size, then prints the new pool size and the pool debugging information. Note that changing the pool size only affects new connection pools, it does not change old ones.

<?php

$connection = new Mongo("host1");

// pool size is -1
echo "pool size is: ".Mongo::getPoolSize()."\n";

echo "setting pool size to 200\n";

Mongo::setPoolSize(200);

// pool size is 200
echo "pool size is: ".Mongo::getPoolSize()."\n";

$conn2 = new Mongo("host2");

// remaining for host1 is -2
// remaining for host2 is 199
var_dump(Mongo::poolDebug());

?>

参见

  • Mongo::setPoolSize() - Set the size for future connection pools
  • Mongo::poolDebug() - Returns information about all connection pools
  • The connection documentation.


Returns the address being used by this for slaveOkay reads

  • ? Mongo::getPoolSize
  • Mongo::getSlaveOkay ?
  • PHP Manual
  • Mongo
  • Returns the address being used by this for slaveOkay reads

Mongo::getSlave

(PECL mongo >=1.1.0)

Mongo::getSlave — Returns the address being used by this for slaveOkay reads

说明

public Mongo::getSlave ( ) : string

This finds the address of the secondary currently being used for reads. It is a read-only method: it does not change anything about the internal state of the object.

When you create a connection to the database, the driver will not immediately decide on a secondary to use. Thus, after you connect, this function will return null even if there are secondaries available. When you first do a query with slaveOkay set, at that point the driver will choose a secondary for this connection. At that point, this function will return the chosen secondary.

See the query section of this manual for information on distributing reads to secondaries.

参数

此函数没有参数。

返回值

The address of the secondary this connection is using for reads.

This returns null if this is not connected to a replica set or not yet initialized.

错误／异常

Issues E_DEPRECATED warning

The returned results aren't really useful as the secondary selection process is done on each query and database command execution.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

参见

  • MongoCursor::info() - Gets information about the cursor's creation and iteration


Get slaveOkay setting for this connection

  • ? Mongo::getSlave
  • Mongo::poolDebug ?
  • PHP Manual
  • Mongo
  • Get slaveOkay setting for this connection

Mongo::getSlaveOkay

(PECL mongo >=1.1.0)

Mongo::getSlaveOkay — Get slaveOkay setting for this connection

说明

public Mongo::getSlaveOkay ( ) : bool

See the query section of this manual for information on distributing reads to secondaries.

参数

此函数没有参数。

返回值

Returns the value of slaveOkay for this instance.

错误／异常

Issues E_DEPRECATED warning

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

参见

  • 读取首选项
  • MongoClient::getReadPreference() - 获取此连接的读取首选项


Returns information about all connection pools

  • ? Mongo::getSlaveOkay
  • Mongo::setPoolSize ?
  • PHP Manual
  • Mongo
  • Returns information about all connection pools

Mongo::poolDebug

(PECL mongo >=1.2.0)

Mongo::poolDebug — Returns information about all connection pools

说明

public Mongo::poolDebug ( ) : array
Warning

This feature has been DEPRECATED as of version 1.2.3. Relying on this feature is highly discouraged. Please use MongoPool::info() instead.

Returns an array of information about all connection pools.

参数

此函数没有参数。

返回值

Each connection pool has an identifier, which starts with the host. For each pool, this function shows the following fields:

in use

The number of connections currently being used by MongoClient instances.

in pool

The number of connections currently in the pool (not being used).

remaining

The number of connections that could be created by this pool. For example, suppose a pool had 5 connections remaining and 3 connections in the pool. We could create 8 new instances of MongoClient before we exhausted this pool (assuming no instances of MongoClient went out of scope, returning their connections to the pool).

A negative number means that this pool will spawn unlimited connections.

Before a pool is created, you can change the max number of connections by calling Mongo::setPoolSize(). Once a pool is showing up in the output of this function, its size cannot be changed.

timeout

The socket timeout for connections in this pool. This is how long connections in this pool will attempt to connect to a server before giving up.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.


Set the size for future connection pools

  • ? Mongo::poolDebug
  • Mongo::setSlaveOkay ?
  • PHP Manual
  • Mongo
  • Set the size for future connection pools

Mongo::setPoolSize

(PECL mongo >=1.2.0)

Mongo::setPoolSize — Set the size for future connection pools

说明

public static Mongo::setPoolSize ( int $size ) : bool
Warning

This method has been DEPRECATED as of version 1.2.3. Relying on this feature is highly discouraged. Please use MongoPool::setSize() instead.

Sets the max number of connections new pools will be able to create.

参数

size

The max number of connections future pools will be able to create. Negative numbers mean that the pool will spawn an infinite number of connections.

返回值

Returns the former value of pool size.

范例

Example #1 Mongo::setPoolSize() example

If you set the pool size to n and then create n connections, attempting to create an n+1st connection will throw a MongoConnectionException.

<?php

// only allow one connection to a server
Mongo::setPoolSize(1);

// creates one connection to localhost:27017
$m1 = new Mongo();

// attempt to create a second connection to localhost:27017
// only one connection is allowed, so this will throw an exception
$m2 = new Mongo();

?>

以上例程的输出类似于：

Fatal error: Uncaught exception 'MongoConnectionException' with message 'no more connections in pool' in /path/to/php/script.php:10
Stack trace:
#0 /path/to/php/script.php(10): Mongo->__construct()
#1 {main}
  thrown in /path/to/php/script.php on line 10

参见

  • Mongo::getPoolSize() - Get pool size for connection pools
  • Mongo::poolDebug() - Returns information about all connection pools
  • The connection documentation.


Change slaveOkay setting for this connection

  • ? Mongo::setPoolSize
  • Mongo::switchSlave ?
  • PHP Manual
  • Mongo
  • Change slaveOkay setting for this connection

Mongo::setSlaveOkay

(PECL mongo >=1.1.0)

Mongo::setSlaveOkay — Change slaveOkay setting for this connection

说明

public Mongo::setSlaveOkay ( bool $ok = true ) : bool

See the query section of this manual for information on distributing reads to secondaries.

参数

ok

If reads should be sent to secondary members of a replica set for all possible queries using this MongoClient instance.

返回值

Returns the former value of slaveOkay for this instance.

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

参见

  • 读取首选项
  • MongoClient::setReadPreference() - 为该连接设置读取选项


Choose a new secondary for slaveOkay reads

  • ? Mongo::setSlaveOkay
  • Mongo 函数 ?
  • PHP Manual
  • Mongo
  • Choose a new secondary for slaveOkay reads

Mongo::switchSlave

(PECL mongo >=1.1.0)

Mongo::switchSlave — Choose a new secondary for slaveOkay reads

说明

public Mongo::switchSlave ( ) : string

This choses a random secondary for a connection to read from. It is called automatically by the driver and should not need to be used. It calls MongoClient::getHosts() (to refresh the status of hosts) and Mongo::getSlave() (to get the return value).

See the query section of this manual for information on distributing reads to secondaries.

参数

此函数没有参数。

返回值

The address of the secondary this connection is using for reads. This may be the same as the previous address as addresses are randomly chosen. It may return only one address if only one secondary (or only the primary) is available.

For example, if we had a three member replica set with a primary, secondary, and arbiter this method would always return the address of the secondary. If the secondary became unavailable, this method would always return the address of the primary. If the primary also became unavailable, this method would throw an exception, as an arbiter cannot handle reads.

错误／异常

Throws a MongoException (error code 15) if it is called on a non-replica-set connection. It will also throw MongoExceptions if it cannot find anyone (primary or secondary) to read from (error code 16).

更新日志

版本 | 说明
PECL mongo 1.2.11 | Emits E_DEPRECATED when used.

参见

  • 读取首选项


Mongo 函数

Table of Contents

  • bson_decode — 反序列化一个 BSON 对象为 PHP 数组
  • bson_encode — 序列化一个 PHP 变量为 BSON 字符串


反序列化一个 BSON 对象为 PHP 数组

  • ? Mongo 函数
  • bson_encode ?
  • PHP Manual
  • Mongo 函数
  • 反序列化一个 BSON 对象为 PHP 数组

bson_decode

(PECL mongo >=1.0.1)

bson_decode — 反序列化一个 BSON 对象为 PHP 数组

说明

bson_decode ( string $bson ) : array

这个函数非常不正式，对 99% 的用户是完全没用的。 仅仅在做着一些不寻常的事的情况下有用，比如在 PHP 驱动的基础上编写自己的驱动。

参数

bson

要反序列化的 BSON。

返回值

返回反序列化后的 BSON 对象。


序列化一个 PHP 变量为 BSON 字符串

  • ? bson_decode
  • Exceptions ?
  • PHP Manual
  • Mongo 函数
  • 序列化一个 PHP 变量为 BSON 字符串

bson_encode

(PECL mongo >=1.0.1)

bson_encode — 序列化一个 PHP 变量为 BSON 字符串

说明

bson_encode ( mixed $anything ) : string

这个函数非常不正式，对 99% 的用户是完全没用的。 仅仅在做着一些不寻常的事的情况下有用，比如在 PHP 驱动的基础上编写自己的驱动。

参数

anything

要序列化的变量。

返回值

返回序列化后的字符串。


Exceptions

Table of Contents

  • MongoException
  • MongoResultException
  • MongoCursorException
  • MongoCursorTimeoutException
  • MongoConnectionException
  • MongoGridFSException
  • MongoDuplicateKeyException
  • MongoProtocolException
  • MongoExecutionTimeoutException
  • MongoWriteConcernException

VMWare Oddities

If you are running VMWare on Windows and are using CIFS, pausing the VM will cause CIFS to go out of sync and cause weird errors on un-pausing it ("The Mongo object has not been correctly initialized by its constructor"). Permanently mounting the Windows shares will fix this and you'll be able to pause and unpause at will.

To permanently mount the Windows shares, run:

$ sudo update-rc.d -f umountnfs.sh remove
$ sudo update-rc.d umountnfs.sh stop 15 0 6 .

See » the Ubuntu docs for the most up-to-date instructions.


The MongoException class

(PECL mongo >= 1.0.0)

简介

Default Mongo exception.

This covers a bunch of different error conditions that may eventually be moved to more specific exceptions, but will always extend MongoException.

  • The MongoSomething object has not been correctly initialized by its constructor

    Code: 0

    Probably your Mongo object is not connected to a database server.

  • zero-length keys are not allowed, did you use $ with double quotes?

    Code: 1

    You tried to save "" as a key. You generally should not do this. "" can mess up subobject access and is used by MongoDB internally. However, if you really want, you can set mongo.allow_empty_keys to true in your php.ini file to override this sanity check. If you override this, it is highly recommended that you set error checking to strict to avoid string interpolation errors.

  • '.' not allowed in key: <key>

    Code: 2

    You attempted to write a key with '.' in it, which is prohibited.

  • insert too large: <size>, max: <max>

    Code: 3

    You're attempting to send too much data to the database at once: the database will only accept inserts up to a certain size (currently 16 MB).

  • no elements in doc

    Code: 4

    You're attempting to save a document with no fields.

  • size of BSON doc is <size> bytes, max <max>MB

    Code: 5

    You're attempting to save a document that is larger than MongoDB can save.

  • no documents given

    Code: 6

    You're attempting to batch insert an empty array of documents.

  • MongoCollection::group takes an array, object, or MongoCode key

    Code: 7

    Wrong type parameter send to MongoCollection::group().

  • field names must be strings

    Code: 8

    You should format field selectors as array("field1" => 1, "field2" => 1, ..., "fieldN" => 1).

  • invalid regex

    Code: 9

    The regex passed to MongoRegex is not of the correct form.

  • MongoDBRef::get: $ref field must be a string

    Code: 10

  • MongoDBRef::get: $db field must be a string

    Code: 11

  • non-utf8 string: <str>

    Code: 12

    This error occurs if you attempt to send a non-utf8 string to the database. All strings going into the database should be UTF8. See php.ini options for the transition option of quieting this exception.

  • mutex error: <err>

    Code: 13

    The driver uses mutexes for synchronizing requests and responses in multithreaded environments. This is a fairly serious error and may not have a stack trace. It's unusual and should be reported to maintainers with any system information and steps to reproduce that you can provide.

  • index name too long: <len>, max <max> characters

    Code: 14

    Indexes with names longer than 128 characters cannot be created. If you get this error, you should use MongoCollection::ensureIndex()'s "name" option to create a shorter name for your index.

类摘要

MongoException extends Exception {
}


MongoResultException 类

(PECL mongo >=1.3.0)

简介

MongoResultException 由几个助手命令（例如 MongoCollection::findAndModify()）在发生失败事件时抛出。 原始的结果文档可以通过 MongoResultException::getDocument() 获取。

类摘要

MongoResultException extends MongoException {
/* 属性 */
public $document ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
public getDocument ( ) : array
}

属性

document

array 的原始结果文档。

Table of Contents

  • MongoResultException::getDocument — 获取完整的结果文档


获取完整的结果文档

  • ? MongoResultException
  • MongoCursorException ?
  • PHP Manual
  • MongoResultException
  • 获取完整的结果文档

MongoResultException::getDocument

(PECL mongo >=1.3.0)

MongoResultException::getDocument — 获取完整的结果文档

说明

public MongoResultException::getDocument ( ) : array

获取完整的错误结果文档。

参数

此函数没有参数。

返回值

完整的结果文档数组，包括是否有效的部分数据以及额外的键。

范例

Example #1 MongoResultException::getDocument() 例子

<?php
$mc = new MongoClient("localhost");
$c = $mc->selectCollection("test", "test");

$c->insert(array(
     "name" => "Next promo",
     "inprogress" => false,
     "priority" => 0,
     "tasks" => array( "select product", "add inventory", "do placement"),
) );

$c->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 1,
     "tasks" => array( "run sales report", "email report" )
) );

$c->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 2,
     "tasks" => array( "run marketing report", "email report" )
    ),
    array("w" => true)
);

try {
    $retval = $c->findAndModify(
         array("inprogress" => false, "name" => "Biz report"),
         array('$set' => array('$set' => array('inprogress' => true, "started" => new MongoDate()))),
         null,
         array(
            "sort" => array("priority" => -1),
            "new" => true,
        )
    );
} catch(MongoResultException $e) {
    echo $e->getMessage(), "\n";
    $res = $e->getDocument();
    var_dump($res);
}
?>

以上例程的输出类似于：

$set is not valid for storage.
array(3) {
  ["lastErrorObject"]=>
  array(5) {
    ["connectionId"]=>
    int(6)
    ["err"]=>
    string(30) "$set is not valid for storage."
    ["code"]=>
    int(52)
    ["n"]=>
    int(0)
    ["ok"]=>
    float(1)
  }
  ["ok"]=>
  float(0)
  ["errmsg"]=>
  string(30) "$set is not valid for storage."
}


The MongoCursorException class

(PECL mongo >= 1.0.0)

简介

Caused by accessing a cursor incorrectly or a error receiving a reply. Note that this can be thrown by any database request that receives a reply, not just queries. Writes, commands, and any other operation that sends information to the database and waits for a response can throw a MongoCursorException. The only exception is new MongoClient() (creating a new connection), which will only throw MongoConnectionExceptions.

This returns a specific error message to help diagnose the problem and a numeric error code associated with the cause of the exception.

For example, suppose you tried to insert two documents with the same _id:

<?php

try {
    $collection->insert(array("_id" => 1), array("w" => 1));
    $collection->insert(array("_id" => 1), array("w" => 1));
}
catch (MongoCursorException $e) {
    echo "error message: ".$e->getMessage()."\n";
    echo "error code: ".$e->getCode()."\n";
}

?>
This would produce output like:
error message: E11000 duplicate key error index: foo.bar.$_id_  dup key: { : 1 }
error code: 11000
Note that the MongoDB error code (11000) is used for the PHP error code. The PHP driver uses the "native" error code wherever possible.

The following is a list of common errors, codes, and causes. Exact errors are in italics, errors where the message can vary are described in obliques.

  • cannot modify cursor after beginning iteration

    Code: 0

    You are calling a method that sets up the query after executing the query. Reset the cursor and try again.

    An example:

    <?php

    try {
            $cursor = $collection->find();
            var_dump($cursor->getNext());

            // getNext() queried the database, it's too late to set a limit
            $cursor->limit(1);
    }
    catch (    MongoCursorException $e) {
        echo     "error message: ".$e->getMessage()."\n";
        echo     "error code: ".$e->getCode()."\n";
    }

    // this will work, though:
    $cursor->getNext();
    $cursor->reset();
    $cursor->limit(1);

    ?>

  • Get next batch send errors

    Code: 1

    Could not send the query to the database. Make sure the database is still up and the network is okay.

  • cursor not found

    Code: 2

    The driver was trying to fetch more results from the database, but the database did not have a record of the query. This usually means that the cursor timed out on the server side: after a few minutes of inactivity, the database will kill a cursor (see MongoCursor::immortal() for information on preventing this).

    An example:

    <?php

    try {
            $cursor = $collection->find();
            $cursor->getNext();

            // sleep for 15 minutes
            sleep(60*15);

        while (    $cursor->hasNext()) {
                $cursor->getNext();
        }
    }
    catch (    MongoCursorException $e) {
        echo     "error message: ".$e->getMessage()."\n";
        echo     "error code: ".$e->getCode()."\n";
    }

    ?>

  • cursor->buf.pos is null

    Code: 3

    This may indicate you are out of RAM or some other extraordinary circumstance.

  • couldn't get response header

    Code: 4

    A common error if the database or network goes down. This means that the driver couldn't get a response from the connection.

  • no db response

    Code: 5

    This may not even be an error, for example, the database command "shutdown" returns no response. However, if you were expecting a response, this means the database didn't give one.

  • bad response length: %d, did the db assert?

    Code: 6

    This means that the database said that its response was less than 0. This error probably indicates a network error or database corruption.

  • incomplete header

    Code: 7

    Highly unusual. Occurs if the database response started out correctly, but broke off in the middle. Probably indicates a network problem.

  • incomplete response

    Code: 8

    Highly unusual. Occurs if the database response started out correctly, but broke off in the middle. Probably indicates a network problem.

  • couldn't find a response

    Code: 9

    If the response was cached and now cannot be located.

  • error getting socket

    Code: 10

    The socket was closed or encountered an error. The driver should automatically reconnect (if possible) on the next operation.

  • couldn't find reply, please try again

    Code: 11

    The driver saves any database responses it cannot immediately match with a request. This exception occurs if the driver has already passed your request's response and cannot find your response in its cache.

  • error getting database response: errstr

    WSA error getting database response: errstr

    "errstr" is an io error reported directly from the C socket subsystem. On Windows, the error message is prefixed with "WSA".

  • Timeout error

    Code: 13

    If there was an error while waiting for a query to complete.

  • couldn't send query: <various>

    Code: 14

    C socket error on send.

  • max number of retries exhausted, couldn't send query

    Code: 19

    The driver will automatically retry "plain" queries (not commands) a couple of times if the first attempt failed for certain reasons. This is to cause fewer exceptions during replica set failover (although you will probably still have to deal with some) and gloss over transient network issues.

    This can also be caused by the driver not being able to reconnect at all to the database (if, for example, the database is unreachable).

    Version 1.2.2+.

Errors passed through by the database

Database errors should always trigger MongoCursorExceptions on queries. Error messages and codes are sent directly from the database and you should be able to see matching errors in the database log.

A few common database errors are listed below:

  • E11000 duplicate key error index: foo.bar.$X dup key: { /* ... */ }

    Code: 11000

    Database error for duplicate keys.

  • not master

    Codes: 10107, 13435, and 10058

    Not master errors, piped through by the database. ach of these will cause the driver to disconnect and attempt to find a new primary. The actual error you get on failover may not be a "not master" error, depending on when the change in primary occurs.

类摘要

MongoCursorException extends MongoException {
}

Table of Contents

  • MongoCursorException::getHost — 遇到该错误的服务器的 hostname


遇到该错误的服务器的 hostname

  • ? MongoCursorException
  • MongoCursorTimeoutException ?
  • PHP Manual
  • MongoCursorException
  • 遇到该错误的服务器的 hostname

MongoCursorException::getHost

(PECL mongo >= 1.0.0)

MongoCursorException::getHost — 遇到该错误的服务器的 hostname

说明

public MongoCursorException::getHost ( ) : string

返回发送查询到该服务器的 hostname。

参数

此函数没有参数。

返回值

返回 hostname，如果 hostname 是未知的则是 NULL。


The MongoCursorTimeoutException class

(PECL mongo >= 1.0.0)

简介

Caused by a query timing out. You can set the length of time to wait before this exception is thrown by calling MongoCursor::timeout() on the cursor or setting MongoCursor::$timeout. The static variable is useful for queries such as database commands and MongoCollection::findOne(), both of which implicitly use cursors.

类摘要

MongoCursorTimeoutException extends MongoCursorException {
}


The MongoConnectionException class

(PECL mongo >= 1.0.0)

简介

Thrown when the driver fails to connect to the database.

There are a number of possible error messages to help you diagnose the connection problem. These are:

  • No candidate servers found

    Thrown when the driver cannot establish a connection to MongoDB (fulfilling the ReadPreferences, if specified).

  • No server name given.

    This error occurs if you pass in "" as the server name, probably because of an typo with string interpolation, e.g., "$servr" instead of "$server".

  • failed to get host [hostname] or port [portnum] from [server].

    This indicated that the server string was malformed. "[hostname]" and "[portnum]" will be as much as the driver could dicipher of it.

  • Operation in progress

    Connecting to the database timed out.

  • Transport endpoint is not connected

    Generally means that the connection string isn't correct, the driver couldn't even find the database server.

  • couldn't determine master

    No server in a replica set connection was identified as the primary.

  • couldn't get host info for [server]

    This indicated that DNS could not resolve the server address you gave. This could easily be caused by a typo, for example, "server" instead of "$server".

  • Invalid Argument

    This can be caused by attempting to connect to a machine that is up but that the database isn't actually running on. Make sure that you've started the database server before connecting.

  • Permission denied

    This means that the socket could not be opened due to permissions issues. On Red Hat variants, this can be caused by a default setting that does not allow Apache to create network connections. You can override this setting by running:

    $ /usr/sbin/setsebool -P httpd_can_network_connect 1
    then restarting Apache.

If the error message is not listed above, it is probably an error from the C socket, and you can search the web for its usual cause.

类摘要

MongoConnectionException extends MongoException {
}


The MongoGridFSException class

(PECL mongo >= 1.0.0)

简介

Thrown when there are errors reading or writing files to or from the database.

类摘要

MongoGridFSException extends MongoException {
}

Error codes

MongoGridFSException error codes
Code | Message | Reason
3 | Could not open file $filename | Attempting to store an invalid file, such as directory
4 | File $filename is too large: $filesize bytes | Maximum filesize in GridFS is 4GB
5 | could not find filehandle | Resource doesn't have a filehandle
6 | no file is associate with this filehandle | Resource isn't a file resource
7 | error setting up file: $filenames | Could not open file for reading
9 | error reading file $filenames | Failed reading file
10 | error reading filehandle | Failed reading from a resource
11 | could not find uploaded file %s | Filename doesn't seem to be uploaded file
12 | Couldn't find tmp_name in the $_FILES array. Are you sure the upload worked? | Uploaded filename probably failed
13 | tmp_name was not a string or an array | Invalid filename given
14 | couldn't find file size | The length property is missing
15 | Cannot find filename | No filename provided, and no filename property set
16 | could not open destination file %s | Destination filename not writable
17 | error reading chunk of file | Chunk corruption
18 | couldn't create a php_stream | Couldn't create a stream resource
19 | couldn't find property | Chunk corruption
20 | chunk number has wrong size (size) when the max is maxchunksize | Chunk larger then expected
21 | chunk has wrong format | Chunk corruption


The MongoDuplicateKeyException class

(PECL mongo >= 1.5.0)

简介

Thrown when attempting to insert a document into a collection which already contains the same values for the unique keys.

类摘要

MongoDuplicateKeyException extends MongoWriteConcernException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public MongoWriteConcernException::getDocument ( ) : array
}

范例

Example #1 Catching MongoDuplicateKeyException

<?php
$mc = new MongoClient("localhost");

$c = $mc->selectCollection("test", "test");

$c->insert(array('_id' => 1));
try {
    $c->insert(array('_id' => 1));
} catch (MongoWriteConcernException $e) {
    echo $e->getMessage(), "\n";
}
?>

以上例程的输出类似于：

localhost:27017: insertDocument :: caused by :: 11000 E11000 duplicate key error index: test.test.$_id_  dup key: { : 1 }


The MongoProtocolException class

(PECL mongo >= 1.5.0)

简介

When talking to MongoDB 2.6.0, and later, certain operations (such as writes) may throw MongoProtocolException when the response from the server did not make sense - for example during network failure (we could read the entire response) or data corruption.

This exception is also thrown when attempting to talk newer protocols then the server supports, for example using the MongoWriteBatch when talking to a MongoDB server prior to 2.6.0.

类摘要

MongoProtocolException extends MongoException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}

范例

Example #1 Catching MongoProtocolException

Running the following example against MongoDB prior to 2.6.0 will throw an MongoProtocolException

<?php
$mc = new MongoClient("localhost");
$c = $mc->selectCollection("test", "test");

try {
    $batch = new MongoInsertBatch($c);
} catch(MongoProtocolException $e) {
    echo $e->getMessage();
}
?>

以上例程的输出类似于：

Current primary does not have a Write API


The MongoExecutionTimeoutException class

(PECL mongo >= 1.5.0)

简介

Thrown when a operation times out server side (i.e. in MongoDB).

To configure the operation timeout threshold, use MongoCursor::maxTimeMS() or the "maxTimeMS" command option.

类摘要

MongoExecutionTimeoutException extends MongoException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}


The MongoWriteConcernException class

(PECL mongo >= 1.5.0)

简介

MongoWriteConcernException is thrown when a write fails. See Write Concerns for how to set failure thresholds.

Prior to MongoDB 2.6.0, the » getLastError command would determine whether a write failed.

类摘要

MongoWriteConcernException extends MongoCursorException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
public getDocument ( ) : array
/* 继承的方法 */
public MongoCursorException::getHost ( ) : string
}

Table of Contents

  • MongoWriteConcernException::getDocument — Get the error document


Get the error document

  • ? MongoWriteConcernException
  • 更新日志 ?
  • PHP Manual
  • MongoWriteConcernException
  • Get the error document

MongoWriteConcernException::getDocument

(PECL mongo >= 1.5.0)

MongoWriteConcernException::getDocument — Get the error document

说明

public MongoWriteConcernException::getDocument ( ) : array

Returns the actual response from the server that was interperated as an error.

参数

此函数没有参数。

返回值

A MongoDB document, if available, as an array.


更新日志

对本扩展的类／函数／方法有以下更新。

MongoDB PHP Driver 1.5.0

It supports all new features for MongoDB 2.6, including:

  • Aggregate can now return a cursor
  • Aggregation pipelines can now be explained
  • Possible to set maxTimeMS for commands and queries
  • Transparent support for the new command-based MongoDB write API
  • New MongoWriteBatch classes (using the new MongoDB write API)
  • Support for MongoDB Enterprise features (e.g. Kerberos, LDAP, X509)
  • Option to tune acceptable server latency for secondary reads (secondaryAcceptableLatencyMS)

With this release, some driver functionality which was previously documented as deprecated will now formally raise deprecation notices. This includes:

  • Instantiating the Mongo class
  • Calling MongoCursor::slaveOkay()
  • "wtimeout" and "safe" options for MongoCollection write operations
  • Manipulating public properties on core classes (such as $collection->w)

Note:

No previously deprecated features have been removed.

Changes in behaviour:

  • Setting the mongo.native_long INI setting now raises an error on 32-bit platforms, and now defaults to true for 64-bit platforms.

MongoDB PHP Driver 1.4.0

The 1.4 series introduced fundemental changes in how connections are created to the MongoDB servers. The driver now utilizes PHP native streams, so all normal PHP stream options apply. Furthermore, an experimental Stream Context Support was added.

The 1.4.x series also added support for MongoDB 2.4.x.

The most important improvements however deal with the handling of replica sets, especially nodes that timeout and nodes that are unreachable for various reasons. Besides the improvements to replica set handling, this release addresses issues with read preferences through mongos nodes. It also adds support for SSL enabled connections as well as journal and fsync connection string options.

MongoDB PHP Driver 1.3.0

The 1.3 series introduced several major changes to the extension such as completely rewritten connection handling (and removal of the pooling mechanism), support for ReadPreferences and change the default WriteConcerns to be acknowledged by introducing a new class MongoClient which serves as a replacement class for the now deprecated Mongo class.

The driver now also supports connecting to multiple mongos instances (the Mongo Shard router) for loadbalancing.

Other enhancements include improved logging for easier connection handling debugging with MongoLog and support for the » Aggregation Framework via the MongoCollection::aggregate() method.

Changes to existing methods

Following is a list of all improvements to existing methods since their inception.

Version | Function | Description
PECL mongo 1.6.0 | MongoDB::getCollectionNames | Changed first parameter to be an array of options. Pre-1.6.0, the first parameter was a boolean indicating the "includeSystemCollections" option.
 | MongoDB::listCollections | Changed first parameter to be an array of options. Pre-1.6.0, the first parameter was a boolean indicating the "includeSystemCollections" option.
PECL mongo 1.5.0 | log_cmd_delete | Only available when connected to MongoDB 2.6.0+
 | log_cmd_insert | Only available when connected to MongoDB 2.6.0+
 | log_cmd_update | Only available when connected to MongoDB 2.6.0+
 | log_write_batch | Only available when connected to MongoDB 2.6.0+
 | MongoCollection::aggregate | Added optional options argument
 | MongoCollection::batchInsert | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCollection::ensureIndex | Renamed the "wtimeout" option to "wTimeoutMS". Emits E_DEPRECATED when "wtimeout" is used. Renamed the "timeout" option to "socketTimeoutMS". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCollection::findOne | Added optional options argument.
 | MongoCollection::group | Added "maxTimeMS" option.
 | MongoCollection::toIndexString | This method has been deprecated.
 | MongoCollection::update | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCursor::slaveOkay | This method has been deprecated in favour of MongoCursor::setReadPreference and .
PECL mongo 1.4.5 | MongoCursor::batchSize | Before 1.4.5, this method would throw an MongoCursorException if the cursor had already started iterating.
PECL mongo 1.4.0 | MongoCursor::hint | The index argument now supports index names as string values. In versions before 1.4.0, only array or object values were accepted.
 | MongoCursor::setFlag | Support for flag 3 (OPLOG_REPLAY) is added. Versions before 1.4.0 would throw a warning saying that the flag is unsupported.
PECL mongo 1.3.4 | MongoCollection::batchInsert | Added "wtimeout" option.
 | MongoCollection::ensureIndex | Added "wtimeout" option.
 | MongoCollection::update | Added "wtimeout" option.
PECL mongo 1.3.3 | MongoCollection::getReadPreference | The return value has changed to be consistent with MongoCollection::setReadPreference. The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.
 | MongoDB::getReadPreference | The return value has changed to be consistent with MongoDB::setReadPreference. The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.
PECL mongo 1.3.0 | MongoCollection::batchInsert | Added "w" option.
 | MongoCollection::ensureIndex | Added "w" option. The options parameter no longer accepts a boolean to signify a unique index. Instead, this now has to be done with array('unique' => true).
 | MongoCollection::update | Added "w" option. The options parameter no longer accepts a boolean to signify an upsert. Instead, this now has to be done with array('upsert' => true).
 | MongoDB::listCollections | Added the includeSystemCollections parameter.
 | MongoGridFSCursor::key | The document's _id is returned as a string value, since the key should be unique. Pre-1.3.0, filename was returned.
PECL mongo 1.2.11 | Mongo::getPoolSize | Emits E_DEPRECATED when used.
 | Mongo::getSlave | Emits E_DEPRECATED when used.
 | Mongo::getSlaveOkay | Emits E_DEPRECATED when used.
 | Mongo::poolDebug | Emits E_DEPRECATED when used.
 | Mongo::setSlaveOkay | Emits E_DEPRECATED when used.
 | Mongo::switchSlave | Emits E_DEPRECATED when used.
 | MongoCollection::ensureIndex | Emits E_DEPRECATED when options is scalar.
 | MongoCollection::getSlaveOkay | Emits E_DEPRECATED when used.
 | MongoCollection::group | Emits E_DEPRECATED when options is scalar.
 | MongoCollection::setSlaveOkay | Emits E_DEPRECATED when used.
 | MongoCollection::update | Emits E_DEPRECATED when options is scalar.
 | MongoCursor::doQuery | Emits E_DEPRECATED when used.
 | MongoDB::forceError | Emits E_DEPRECATED when used.
 | MongoDB::getSlaveOkay | Emits E_DEPRECATED when used.
 | MongoDB::prevError | Emits E_DEPRECATED when used.
 | MongoDB::resetError | Emits E_DEPRECATED when used.
 | MongoDB::setSlaveOkay | Emits E_DEPRECATED when used.
 | MongoPool::getSize | Emits E_DEPRECATED when used.
 | MongoPool::info | Emits E_DEPRECATED when used.
 | MongoPool::setSize | Emits E_DEPRECATED when used.
PECL mongo 1.2.7 | MongoCollection::batchInsert | Added "continueOnError" option.
PECL mongo 1.2.5 | MongoGridFS::storeUpload | Changed second parameter to an array of metadata. Pre-1.2.5, the second parameter was an optional string overriding the filename.
PECL mongo 1.2.0 | MongoCollection::ensureIndex | Added "timeout" option.
 | MongoCollection::update | Added "timeout" option.
PECL mongo 1.1.0 | MongoCursor::info | Added a number of other fields, including id (the cursor id), at (the driver's counter of which document is current), numReturned (the number returned by the server in the current batch), and server (which server the query was sent to—useful in conjunction with .
PECL mongo 1.0.11 | MongoCollection::ensureIndex | The "safe" option will trigger a primary failover, if necessary. MongoException will be thrown if the index name (either generated or set) is longer than 128 bytes.
 | MongoCollection::update | Disconnects on "not master" errors if "safe" is set.
PECL mongo 1.0.10 | MongoCursor::info | Added started_iterating field, a boolean indicating if cursor is pre- or post-query.
PECL mongo 1.0.9 | MongoCollection::batchInsert | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option.
 | MongoCollection::update | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option. The return type was changed to be an array containing error information if the "safe" option is used. Otherwise, a boolean is returned as before.
PECL mongo 1.0.5 | MongoCollection::batchInsert | Added options parameter.
 | MongoCollection::ensureIndex | Added the "name" option to override index name creation.
 | MongoCollection::update | Added "safe" option.
PECL mongo 1.0.2 | MongoCollection::ensureIndex | Changed options parameter from boolean to array. Pre-1.0.2, the second parameter was an optional boolean value specifying a unique index.
PECL mongo 1.0.1 | MongoCollection::update | Changed options parameter from boolean to array. Pre-1.0.1, the second parameter was an optional boolean value specifying an upsert.
1.5.0 | MongoBinData::__construct | 默认值从 2 (MongoBinData::BYTE_ARRAY) 改成 0 (MongoBinData::GENERIC)。
 | MongoCollection::save | 增加 "wTimeoutMS" 选项来代替 "wtimeout"。 使用 "wtimeout" 时出现 E_DEPRECATED 错误。 新增 "socketTimeoutMS" 选项来代替 "timeout"。 使用 "timeout" 时出现 E_DEPRECATED 错误。 使用 "safe" 时出现 E_DEPRECATED 错误。
1.4.0 | MongoDB::createCollection | 1.4.0以前的版本里，所有选项都是这个方法的参数。之前版本这个方法的签名是这样的： public MongoCollectionMongoDB::createCollection stringname boolcappedfalse intsize0 intmax0 参数的意义与现在版本的 options 参数相同。
 | MongoId::__construct | 传入无效字符将抛出异常
1.3.4 | MongoClient::__construct | 添加了 "connectTimeoutMS" 和 "socketTimeoutMS" 选项。
1.3.3 | MongoClient::getReadPreference | 返回的值修改为兼容 MongoClient::setReadPreference。 type 的值从数组改成字符串，删除了 type_string，并且 tagsets 现在以键值表示的标签而不是冒号分隔的字符串。
1.3.0 | MongoClient::close | 在 1.3.0 版本中，为这个函数添加了 connection 参数。 在此之前，直邮写入连接才会被这个方法关闭。
 | MongoClient::__construct | 添加了 "readPreference"、 "readPreferenceTags"、"w" 和 "wTimeout" 选项。
 | MongoCollection::insert | options 参数不再接受 boolean 来标识一个确认的写入。 现在，你可以通过 array('w' => 1) 设置（ MongoClient 默认的行为）
 | MongoCollection::remove | options 参数不再接受 boolean 值来代表 "justOne"。 现在，必须使用 array('justOne' => true) 作为替代。
1.2.11 | MongoBinData::__construct | 没有使用第二个参数时产生 E_DEPRECATED。 type 的默认值在近期的功能里可能会改变。
 | MongoCollection::remove | 当 options 是 scalar 时产生一个 E_DEPRECATED 警告。
 | MongoDB::authenticate | 使用时产生 E_DEPRECATED。 请将验证细节传入到构造器。
1.2.10 | MongoClient::getHosts | 对非集群的支持。 返回的数组元素现在也包括了 hostname 和 port。
1.2.0 | MongoClient::close | 在版本 1.2.0 之前，这个驱动默认不会使用持久连接，所有连接会在作用域结束时关闭。 由于版本 1.2.0 情况不再如此，所以调用 close 会是一个坏主意，在服务器有较高负载时可能会造成更高的压力。
 | MongoClient::__construct | 添加了 "username" 和 "password" 选项。 移除了 "persist" 选项，所有的连接都是持久的。它仍旧能够使用，但是不起作用。 "persist" 是否应该是持久连接。如果设置了，连接会是持久连接。 字符形式的值将会用于连接的 ID。所以两个以 array("persist" => "foobar") 初始化的 MongoClient 实例会共享一个数据库连接，以 array("persist" => "barbaz")初始化的实例则使用不同的数据库连接。 "replicaSet" 选项现在支持一个字符串，而不是布尔值。
 | MongoCollection::insert | 增加了 "timeout" 选项。
 | MongoCollection::remove | 添加 "timeout" 选项。
 | MongoCollection::save | 增加 "timeout" 选项。
 | MongoDB::command | 添加 options 参数，和一个选项:"timeout"。
1.0.11 | MongoCollection::insert | 如果设置了 "safe"，出现 "not master" 错误时断开连接。
 | MongoCollection::remove | 在设置了 "safe" 之后，将在出现 "not master" 错误时断开连接。
 | MongoCollection::save | 设置 "safe" 时，当出现 "not master" 错误时主动断开连接。
1.0.9 | MongoClient::__construct | 添加了 "replicaSet" 选项。
 | MongoCollection::insert | "safe" 选项接受 integer 值，之前只接受 boolean 值。 增加 "fsync" 选项。 如果设置了 "safe" 选项，返回类型改成包含错误信息的 array。 否则，和之前一样返回 boolean。
 | MongoCollection::remove | 添加了 "safe" 选项对 integer 的支持，之前只接受 boolean 值。 添加了 "fsync" 选项。 当使用了 "safe" 选项时将会返回包含错误信息的数组。 否则和之前一样返回一个 boolean。
 | MongoCollection::save | 增加 "fsync" 选项。
1.0.7 | MongoCollection::count | 添加了 limit 和 skip 参数。
1.0.5 | MongoCollection::insert | 修改第二个参数为选项数组。在 1.0.5 之前，第二个参数是 boolean，指示 "safe" 选项。
 | MongoCollection::remove | 修改第二个参数为选项的 array。在 1.0.5 之前，第二个选项是 boolean 值， 代表了 "safe" 选项。
 | MongoCollection::save | 增加 options 参数。
1.0.2 | MongoClient::__construct | 修改构造器支持选修数组。在 1.0.2 之前，构造器接受以下参数： server 服务器名。 connect 可选的 boolean 参数指定了构造器是否应该在返回前连接到数据库。默认为 true。 persistent 连接是否应该是持久的。 paired 连接是否应该为 paired 模式。
1.0.1 | MongoCollection::insert | 如果设置了 "safe" 选项并且插入失败了，将会抛出 MongoCursorException。


MongoDB driver

Unlike the mongo extension, this extension is developed atop the » libmongoc and » libbson libraries. It provides a minimal API for core driver functionality: commands, queries, writes, connection management, and BSON serialization.

Userland PHP libraries that depend on this extension may provide higher level APIs, such as query builders, individual command helper methods, and GridFS. Application developers should consider using this extension in conjunction with the » MongoDB PHP library, which implements the same higher level APIs found in MongoDB drivers for other languages. This separation of concerns allows the driver to focus on essential features for which an extension implementation is paramount for performance.

  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 预定义常量
  • Tutorials
    • Using the PHP Library for MongoDB (PHPLIB)
    • Application Performance Monitoring (APM)
  • Driver Architecture and Internals — Explains the driver architecture, and special features
    • Architecture — Architecture Overview
    • Connections — Connection handling and persistence
    • Persisting Data — Serialization and deserialization of PHP variables into MongoDB
  • Security
    • Request Injection Attacks
    • Script Injection Attacks
  • MongoDB\Driver — MongoDB 驱动类
    • MongoDB\Driver\Manager — The MongoDB\Driver\Manager class
    • MongoDB\Driver\Command — The MongoDB\Driver\Command class
    • MongoDB\Driver\Query — The MongoDB\Driver\Query class
    • MongoDB\Driver\BulkWrite — The MongoDB\Driver\BulkWrite class
    • MongoDB\Driver\WriteConcern — The MongoDB\Driver\WriteConcern class
    • MongoDB\Driver\ReadPreference — The MongoDB\Driver\ReadPreference class
    • MongoDB\Driver\ReadConcern — The MongoDB\Driver\ReadConcern class
    • MongoDB\Driver\Cursor — The MongoDB\Driver\Cursor class
    • MongoDB\Driver\CursorId — The MongoDB\Driver\CursorId class
    • MongoDB\Driver\Server — The MongoDB\Driver\Server class
    • MongoDB\Driver\WriteConcernError — The MongoDB\Driver\WriteConcernError class
    • MongoDB\Driver\WriteError — The MongoDB\Driver\WriteError class
    • MongoDB\Driver\WriteResult — The MongoDB\Driver\WriteResult class
  • MongoDB\BSON — BSON type classes and serialization functions
    • 函数
    • MongoDB\BSON\Binary — The MongoDB\BSON\Binary class
    • MongoDB\BSON\Decimal128 — The MongoDB\BSON\Decimal128 class
    • MongoDB\BSON\Javascript — The MongoDB\BSON\Javascript class
    • MongoDB\BSON\MaxKey — The MongoDB\BSON\MaxKey class
    • MongoDB\BSON\MinKey — The MongoDB\BSON\MinKey class
    • MongoDB\BSON\ObjectId — The MongoDB\BSON\ObjectId class
    • MongoDB\BSON\Regex — The MongoDB\BSON\Regex class
    • MongoDB\BSON\Timestamp — The MongoDB\BSON\Timestamp class
    • MongoDB\BSON\UTCDateTime — The MongoDB\BSON\UTCDateTime class
    • MongoDB\BSON\Type — The MongoDB\BSON\Type interface
    • MongoDB\BSON\Persistable — The MongoDB\BSON\Persistable interface
    • MongoDB\BSON\Serializable — The MongoDB\BSON\Serializable interface
    • MongoDB\BSON\Unserializable — The MongoDB\BSON\Unserializable interface
    • MongoDB\BSON\BinaryInterface — The MongoDB\BSON\BinaryInterface interface
    • MongoDB\BSON\Decimal128Interface — The MongoDB\BSON\Decimal128Interface interface
    • MongoDB\BSON\JavascriptInterface — The MongoDB\BSON\JavascriptInterface interface
    • MongoDB\BSON\MaxKeyInterface — The MongoDB\BSON\MaxKeyInterface interface
    • MongoDB\BSON\MinKeyInterface — The MongoDB\BSON\MinKeyInterface interface
    • MongoDB\BSON\ObjectIdInterface — The MongoDB\BSON\ObjectIdInterface interface
    • MongoDB\BSON\RegexInterface — The MongoDB\BSON\RegexInterface interface
    • MongoDB\BSON\TimestampInterface — The MongoDB\BSON\TimestampInterface interface
    • MongoDB\BSON\UTCDateTimeInterface — The MongoDB\BSON\UTCDateTimeInterface interface
    • MongoDB\BSON\DBPointer — The MongoDB\BSON\DBPointer class (deprecated)
    • MongoDB\BSON\Int64 — The MongoDB\BSON\Int64 class
    • MongoDB\BSON\Symbol — The MongoDB\BSON\Symbol class (deprecated)
    • MongoDB\BSON\Undefined — The MongoDB\BSON\Undefined class (deprecated)
  • MongoDB\Driver\Monitoring — Monitoring classes and subscriber functions
    • 函数
    • MongoDB\Driver\Monitoring\CommandFailedEvent — The MongoDB\Driver\Monitoring\CommandFailedEvent class
    • MongoDB\Driver\Monitoring\CommandStartedEvent — The MongoDB\Driver\Monitoring\CommandStartedEvent class
    • MongoDB\Driver\Monitoring\CommandSucceededEvent — The MongoDB\Driver\Monitoring\CommandSucceededEvent class
    • MongoDB\Driver\Monitoring\CommandSubscriber — The MongoDB\Driver\Monitoring\CommandSubscriber interface
    • MongoDB\Driver\Monitoring\Subscriber — The MongoDB\Driver\Monitoring\Subscriber interface
  • MongoDB\Driver\Exception — Exception 类
    • MongoDB\Driver\Exception\AuthenticationException — The MongoDB\Driver\Exception\AuthenticationException class
    • MongoDB\Driver\Exception\BulkWriteException — The MongoDB\Driver\Exception\BulkWriteException class
    • MongoDB\Driver\Exception\ConnectionException — The MongoDB\Driver\Exception\ConnectionException class
    • MongoDB\Driver\Exception\ConnectionTimeoutException — The MongoDB\Driver\Exception\ConnectionTimeoutException class
    • MongoDB\Driver\Exception\Exception — The MongoDB\Driver\Exception\Exception interface
    • MongoDB\Driver\Exception\ExecutionTimeoutException — The MongoDB\Driver\Exception\ExecutionTimeoutException class
    • MongoDB\Driver\Exception\InvalidArgumentException — The MongoDB\Driver\Exception\InvalidArgumentException class
    • MongoDB\Driver\Exception\LogicException — The MongoDB\Driver\Exception\LogicException class
    • MongoDB\Driver\Exception\RuntimeException — The MongoDB\Driver\Exception\RuntimeException class
    • MongoDB\Driver\Exception\SSLConnectionException — The MongoDB\Driver\Exception\SSLConnectionException class (deprecated)
    • MongoDB\Driver\Exception\UnexpectedValueException — The MongoDB\Driver\Exception\UnexpectedValueException class
    • MongoDB\Driver\Exception\WriteException — The MongoDB\Driver\Exception\WriteException class


安装／配置

  • 需求
  • 安装
    • Installing the MongoDB PHP Driver with PECL
    • Installing the MongoDB PHP Driver on macOS with Homebrew
    • Installing the MongoDB PHP Driver on Windows
    • Building the MongoDB PHP Driver from source
  • 运行时配置
  • 预定义常量


需求

As of version 1.8.0, the driver requires PHP 7.0 or higher. Previous versions of the driver allow compatibility with older PHP versions.

The driver requires » libbson and » libmongoc, and will use bundled versions of both libraries by default. System libraries may also be used, as discussed in the manual installation documentation.

The driver, via libmongoc, optionally depends on a TLS library (e.g. OpenSSL) and will use it if available. If the build process fails to find a TLS library, users should check that the appropriate development package (e.g. libssl-dev) and » pkg-config are both installed. The process for detecting and configuring TLS libraries is discussed in more detail in the manual installation documentation.

» Cyrus SASL is an optional dependency to support Kerberos authentication and will be used if available.

Note: Due to potential problems representing 64-bit integers on 32-bit platforms, users are advised to use 64-bit environments. When using a 32-bit platform, be aware that any 64-bit integer read from the database will be returned as a MongoDB\BSON\Int64 instance instead of a PHP integer type.


安装

Table of Contents

  • Installing the MongoDB PHP Driver with PECL
  • Installing the MongoDB PHP Driver on macOS with Homebrew
  • Installing the MongoDB PHP Driver on Windows
  • Building the MongoDB PHP Driver from source


Installing the MongoDB PHP Driver with PECL

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mongodb

Linux, Unix, and macOS users may run the following command to install the driver:

$ sudo pecl install mongodb

If your system has multiple version of PHP installed (e.g. macOS default, Homebrew, » XAMPP), note that that each version of PHP has its own pecl command and php.ini file.

Installing the driver via PECL will use bundled versions of » libbson and » libmongoc and attempt to automatically configure them.

Note: If the build process fails to find an SSL library, check that the development packages (e.g. libssl-dev) and » pkg-config are both installed. If that does not resolve the problem, consider using the manual installation process.

Finally, add the following line to your php.ini file:

extension=mongodb.so


Installing the MongoDB PHP Driver on macOS with Homebrew

» Homebrew 1.5.0 deprecated the » Homebrew/php tap and removed formulae for individual PHP extensions. Going forward, macOS users are advised to install the » php formula and follow the standard PECL installation instructions using the pecl command provided by the Homebrew PHP installation.


Installing the MongoDB PHP Driver on Windows

Precompiled binaries for each release are available from » PECL for a variety of combinations of versions, thread safety, and VC libraries. Extract the archive and put php_mongodb.dll in your PHP extension directory ("ext" by default).

Add the following line to your php.ini file:

extension=php_mongodb.dll

Note: Additional DLL dependencies for Windows Users

为了使此扩展生效， DLL 文件必须能在 Windows 系统的 PATH 指示的路径下找到。如何操作的信息，请参见题为"如何在 Windows 中将 PHP 目录加到 PATH 中"的FAQ。虽然将 DLL 文件从 PHP 文件夹复制到 Windows 系统目录也行，但不建议这样做。 此扩展需要下列文件在 PATH 路径中： libsasl.dll


Building the MongoDB PHP Driver from source

For driver developers and people interested in the latest bugfixes, you can compile the driver from the latest source code on » Github. Run the following commands to clone and build the project:

$ git clone https://github.com/mongodb/mongo-php-driver.git
$ cd mongo-php-driver
$ git submodule update --init
$ phpize
$ ./configure
$ make all
$ sudo make install

If your system has multiple version of PHP installed (e.g. macOS default and » XAMPP), note that each version of PHP has its own phpize command and php.ini file.

By default, the driver will use bundled versions of » libbson, » libmongoc, and » libmongocrypt and attempt to configure them on its own. If these libraries are already installed as system libraries, you can instruct the driver to utilize them by specifying --with-libbson=yes --with--libmongoc=yes as arguments to configure. Starting with version 1.7.0 of the extension, these arguments are deprecated and you should use --with-mongodb-system-libs=yes instead.

For a complete list of configure options, run configure --help.

When using bundled versions of libbson and libmongoc, the driver will also attempt to select an SSL library according to the --with-mongodb-ssl option for configure. The default value is --with-mongodb-ssl=auto, which will search for Secure Transport (macOS only), OpenSSL, and LibreSSL, in that order. Additionally, you may specify openssl, libressl, or darwin to force selection of a particular library, respectively.

Note:

If the build process fails to find an SSL library, check that the development packages (e.g. libssl-dev) and » pkg-config are both installed.

When using Homebrew on macOS, it is common for a system to have multiple versions of OpenSSL installed. To ensure that the desired version of OpenSSL is selected, the PKG_CONFIG_PATH environment variable may be used to control the search path for pkg-config. If pkg-config is not used, configure also supports a --with-openssl-dir=DIR argument, which can be used to specify a manual search path (for OpenSSL only).

The final build step, make install, will report where mongodb.so has been installed, similar to:

Installing shared extensions:     /usr/lib/php/extensions/debug-non-zts-20151012/

Ensure that the extension_dir option in php.ini points to the directory where mongodb.so was installed. You can query for the option by running:

$ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/debug-non-zts-20151012 =>
                   /usr/lib/php/extensions/debug-non-zts-20151012

If the directories differ, either change extension_dir in php.ini or manually move mongodb.so to the correct directory.

Finally, add the following line to your php.ini file:

extension=mongodb.so


运行时配置

这些函数的行为受 php.ini 中的设置影响。

mongodb 配置选项
名字 | 默认 | 可修改范围 | 更新日志 | Comments
mongodb.debug | "" | PHP_INI_ALL |  |

这是配置指令的简短说明。

mongodb.debug string

Store full activity debug log in this directory or stream. The special value "stderr" can be provided to write to STDERR.

Note:

Please note that the debug log can contain sensitive information, such as credentials to the MongoDB server and full documents written to or read from the server. Please review any debug logs before sharing them with other people.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

MONGODB_VERSION (string)
x.y.z style version number of the extension
MONGODB_STABILITY (string)
Current stability (alpha/beta/stable)


Tutorials

In this section you will find several tutorials on how to use the MongoDB driver for PHP.

  • Using the PHP Library for MongoDB (PHPLIB)
  • Application Performance Monitoring (APM)


Using the PHP Library for MongoDB (PHPLIB)

After the initial driver set-up, we will continue explaining how to get started with the MongoDB driver and corresponding userland library to write our first project.

Installing the PHP Library with Composer

The last thing we still need to install to get started on the application itself, is the PHP library.

The library needs to be installed with » Composer, a package manager for PHP. Instructions for installing Composer on various platforms may be found on its website.

Install the library by running:

$ composer require mongodb/mongodb

It will output something akin to:

./composer.json has been created
Loading composer repositories with package information
Updating dependencies (including require-dev)
  - Installing mongodb/mongodb (1.0.0)
    Downloading: 100%

Writing lock file
Generating autoload files

Composer will create several files: composer.json, composer.lock, and a vendor directory that will contain the library and any other dependencies your project might require.

Using the PHP Library

In addition to managing your dependencies, Composer will also provide you with an autoloader (for those dependencies' classes). Ensure that it is included at the start of your script or in your application's bootstrap code:

<?php
// This path should point to Composer's autoloader
require 'vendor/autoload.php';

With this done, you can now use any of the functionality as described in the » library documentation.

If you have previously used the old driver (i.e. mongo extension), the library's API should look familiar. It contains a » Client class for connecting to MongoDB, and » Database class for database-level operations (e.g. commands, collection management) and a » Collection class for collection-level operations (e.g. » CRUD methods, index management). Various Collection methods have been renamed for clarity, and to be in accordance with a new language-agnostic » specification.

As an example, this is how you insert a document into the beers collection of the demo database:

<?php
require 'vendor/autoload.php'; // include Composer's autoloader

$client = new MongoDB\Client("mongodb://localhost:27017");
$collection = $client->demo->beers;

$result = $collection->insertOne( [ 'name' => 'Hinterland', 'brewery' => 'BrewDog' ] );

echo "Inserted with Object ID '{$result->getInsertedId()}'";
?>

Instead of injecting the generated _id field into the input document (as was done in the old driver), it is now made available through the result object returned by the insertOne method.

After insertion, you can of course also query the data that you have just inserted. For that, you use the find method, which returns an iterable cursor:

<?php
require 'vendor/autoload.php'; // include Composer's autoloader

$client = new MongoDB\Client("mongodb://localhost:27017");
$collection = $client->demo->beers;

$result = $collection->find( [ 'name' => 'Hinterland', 'brewery' => 'BrewDog' ] );

foreach ($result as $entry) {
    echo $entry['_id'], ': ', $entry['name'], "\n";
}
?>

While it may not be apparent in the examples, BSON documents and arrays are unserialized as type classes in the library by default. These classes ensure that values preserve their type when being serialized back into BSON, which avoids a caveat in the old driver where arrays might turn into documents, and vice versa. Additionally, the classes extend ArrayObject for enhanced usability. You can find more information on how serialization and deserialization between PHP variables and BSON is handled by the driver and library by reading the Persisting Data specification.


Application Performance Monitoring (APM)

Since version 1.3, the MongoDB driver contains an API for performance monitoring. This API allows you to find out how long specific operations take by setting up subscribers. Each subscriber is required to implement one or more interfaces under the MongoDB\Driver\Monitoring namespace. Currently, only the MongoDB\Driver\Monitoring\CommandSubscriber interface is available.

The MongoDB\Driver\Monitoring\CommandSubscriber interface defines three methods: commandStarted, commandSucceeded, and commandFailed. Each of these three methods accept a single event argument of a specific class for the respective event. For example, the commandSucceeded's $event argument is a MongoDB\Driver\Monitoring\CommandSucceededEvent object.

In this tutorial we will implement a subscriber that creates a list of all the query profiles and the average time they took.

Subscriber Class Scaffolding

We start with the framework for our subscriber:

<?php

class QueryTimeCollector implements \MongoDB\Driver\Monitoring\CommandSubscriber
{
    public function commandStarted( \MongoDB\Driver\Monitoring\CommandStartedEvent $event )
    {
    }

    public function commandSucceeded( \MongoDB\Driver\Monitoring\CommandSucceededEvent $event )
    {
    }

    public function commandFailed( \MongoDB\Driver\Monitoring\CommandFailedEvent $event )
    {
    }
}

?>

Registering the Subscriber

Once a subscriber object is instantiated, it needs to be registered with the driver's monitoring system. This is done by calling MongoDB\Driver\Monitoring\addSubscriber().

<?php

\MongoDB\Driver\Monitoring\addSubscriber( new QueryTimeCollector() );

?>

Implementing the Logic

With the object registered, the only thing left is to implement the logic in the subscriber class. To correlate the two events that make up a successfully executed command (commandStarted and commandSucceeded), each event object exposes a requestId field.

To record the average time per query shape, we will start by checking for a find command in the commandStarted event. We will then add an item to the pendingCommands property indexed by its requestId and with its value representing the query shape.

If we receive a corresponding commandSucceeded event with the same requestId, we add the duration of the event (from durationMicros) to the total time and increment the operation count.

If a corresponding commandFailed event is encountered, we just remove the entry from the pendingCommands property.

<?php

class QueryTimeCollector implements \MongoDB\Driver\Monitoring\CommandSubscriber
{
    private $pendingCommands = [];
    private $queryShapeStats = [];

    /* Creates a query shape out of the filter argument. Right now it only
     * takes the top level fields into account */
    private function createQueryShape( array $filter )
    {
        return json_encode( array_keys( $filter ) );
    }

    public function commandStarted( \MongoDB\Driver\Monitoring\CommandStartedEvent $event )
    {
        if ( array_key_exists( 'find', (array) $event->getCommand() ) )
        {
            $queryShape = $this->createQueryShape( (array) $event->getCommand()->filter );
            $this->pendingCommands[$event->getRequestId()] = $queryShape;
        }
    }

    public function commandSucceeded( \MongoDB\Driver\Monitoring\CommandSucceededEvent $event )
    {
        $requestId = $event->getRequestId();
        if ( array_key_exists( $requestId, $this->pendingCommands ) )
        {
            $this->queryShapeStats[$this->pendingCommands[$requestId]]['count']++;
            $this->queryShapeStats[$this->pendingCommands[$requestId]]['duration'] += $event->getDurationMicros();
            unset( $this->pendingCommands[$requestId] );
        }
    }

    public function commandFailed( \MongoDB\Driver\Monitoring\CommandFailedEvent $event )
    {
        if ( array_key_exists( $event->getRequestId(), $this->pendingCommands ) )
        {
            unset( $this->pendingCommands[$event->getRequestId()] );
        }
    }

    public function __destruct()
    {
        foreach( $this->queryShapeStats as $shape => $stats )
        {
            echo "Shape: ", $shape, " (", $stats['count'], ")\n  ",
                $stats['duration'] / $stats['count'], "μs\n\n";
        }
    }
}

$m = new \MongoDB\Driver\Manager( 'mongodb://localhost:27016' );

/* Add the subscriber */
\MongoDB\Driver\Monitoring\addSubscriber( new QueryTimeCollector() );

/* Do a bunch of queries */
$query = new \MongoDB\Driver\Query( [
    'region_slug' => 'scotland-highlands', 'age' => [ '$gte' => 20 ]
] );
$cursor = $m->executeQuery( 'dramio.whisky', $query );

$query = new \MongoDB\Driver\Query( [
    'region_slug' => 'scotland-lowlands', 'age' => [ '$gte' => 15 ]
] );
$cursor = $m->executeQuery( 'dramio.whisky', $query );

$query = new \MongoDB\Driver\Query( [ 'region_slug' => 'scotland-lowlands' ] );
$cursor = $m->executeQuery( 'dramio.whisky', $query );

?>


Explains the driver architecture, and special features

  • Architecture — Architecture Overview
  • Connections — Connection handling and persistence
  • Persisting Data — Serialization and deserialization of PHP variables into MongoDB
    • Serialization to BSON
    • Deserialization from BSON


Architecture Overview

This section explains how all the different parts of the driver fit together. From the different language runtimes, through the extension and to the PHP libraries on top. This new architecture has replaced the old mongo extension. We refer to the new one as the mongodb extension.

At the top of this stack sits a pure » PHP library, which we will distribute as a Composer package. This library will provide an API similar to what users have come to expect from the old mongo driver (e.g. CRUD methods, database and collection objects, command helpers) and we expect it to be a common dependency for most applications built with MongoDB. This library will also implement common » specifications, in the interest of improving API consistency across all of the » drivers maintained by MongoDB (and hopefully some community drivers, too).

Sitting below that library we have the lower level driver. This extension will effectively form the glue between PHP and our system libraries (» libmongoc and » libbson). This extension will expose an identical public API for the most essential and performance-sensitive functionality:

  • Connection management
  • BSON encoding and decoding
  • Object document serialization (to support ODM libraries)
  • Executing commands and write operations
  • Handling queries and cursors

By decoupling the driver internals and a high-level API into an extension and PHP libraries, respectively, we hope to reduce our maintainence burden and allow for faster iteration on new features. As a welcome side effect, this also makes it easier for anyone to contribute to the driver. Additionally, an identical public API will make it that much easier to port an application across PHP runtimes, whether the application uses the low-level driver directly or a higher-level PHP library.

» GridFS is a great example of why we chose this direction. Although we implemented GridFS in C for our old mongo driver, it is actually quite a high-level specification. Its API is just an abstraction for accessing two collections: files (i.e. metadata) and chunks (i.e. blocks of data). Likewise, all of the syntactic sugar found in the old mongo driver, such as processing uploaded files or exposing GridFS files as PHP streams, can be implemented in pure PHP. Provided we have performant methods for reading from and writing to GridFS' collections - and thanks to our low level extensions, we will - shifting this API to PHP is win-win.

Earlier I mentioned that we expect the PHP library to be a common dependency for most applications, but not all. Some users may prefer to stick to the no-frills API offered by the extensions, or create their own high-level abstraction (akin to » Doctrine MongoDB for the old mongo driver). Future libraries could include a PHP library geared for MongoDB administration, which provides an API for various user management and ops commands. The next major version of » Doctrine MongoDB ODM will likely also sit directly atop the extensions.

While we will continue to maintain and support the old mongo driver and its users for the foreseeable future, we invite everyone to use the next-generation driver and consider it for any new projects going forward. You can find all of the essential components across GitHub and JIRA:

Driver Source Code and JIRA Locations
Project | GitHub | JIRA
PHP Library | » mongodb/mongo-php-library | » PHPLIB
PHP 5 and PHP 7 Driver (phongo) | » mongodb/mongo-php-driver | » PHPC

The existing » PHP project in JIRA will remain open for reporting bugs against the old mongo driver, but we would ask that you use the new projects above for anything pertaining to our next-generation drivers.


Connection handling and persistence

Note: On Unix platforms, the MongoDB driver is sensitive to scripts that use the fork() system call without also calling exec(). Users are advised not to re-use MongoDB\Driver\Manager instances in a forked child process.

Connection and topology persistence (PHP version since 1.2.0)

All versions of the driver since 1.2.0 persist the » libmongoc client object in the PHP worker process, which allows it to re-use database connections, authentication states, and topology information across multiple requests.

When MongoDB\Driver\Manager::__construct() is invoked, a hash is created from its arguments (i.e. URI string and array options). The driver will attempt to find a previously persisted » libmongoc client object for that hash. If an existing client cannot be found for the hash, a new client will be created (and persisted for future use).

Each client contains its own database connections and a view of the server topology (e.g. standalone, replica set, shard cluster). By persisting the client between PHP requests, the driver is able to re-use established database connections and remove the need for » discovering the server topology on each request.

Consider the following example:

<?php

$managers = [
    new MongoDB\Driver\Manager('mongodb://127.0.0.1'),
    new MongoDB\Driver\Manager('mongodb://127.0.0.1'),
    new MongoDB\Driver\Manager('mongodb://127.0.0.1:27017'),
    new MongoDB\Driver\Manager('mongodb://rs1.example.com,rs2.example.com/', ['replicaSet' => 'myReplicaSet']),
];

foreach ($managers as $manager) {
    $manager->executeCommand('test', new MongoDB\Driver\Command(['ping' => 1]));
}

?>

The first two Manager objects will share the same » libmongoc client since their constructor arguments are identical. The third and fourth objects will each use their own client. In total, three clients will be created and the PHP worker executing this script will open two connections to 127.0.0.1 and one connection to each of rs1.example.com and rs2.example.com. If the driver discovers additional members of the replica set after issuing isMaster commands, it will open additional connections to those servers as well.

If the same worker executes the script again in a second request, the three clients will be re-used and no new connections should be made. Depending on how long ago the previous request was served, the driver may need to issue additional isMaster commands to update its view of the topologies.

Socket persistence (PHP versions before 1.2.0)

Versions of the PHP driver before 1.2.0 utilize PHP's Streams API for database connections, using an API within » libmongoc to designate custom handlers for socket communication; however, a new libmongoc client is created for each MongoDB\Driver\Manager. As a result, the driver persists individual database connections but not authentication state or topology information. This means that the driver needs to issue commands at the start of each request to authenticate and » discover the server topology.

Database connections are persisted by a hash derived from the server's host, port, and the URI string used to construct the MongoDB\Driver\Manager. The constructor's array options are not included in this hash.

Note: Versions of the driver >= 1.1.8 and < 1.2.0 do not persist sockets for SSL connections. See » PHPC-720 for additional information.

Despite its shortcomings with persisting SSL connections when and topology information, this version of the driver supports all SSL context options since it uses PHP's Streams API.


Serialization and deserialization of PHP variables into MongoDB

Table of Contents

  • Serialization to BSON
  • Deserialization from BSON

This document discusses the methods how compound structures (documents, arrays, objects) are persisted through the drivers. And how they are brought back into PHP land.


Serialization to BSON

Arrays

If an array is a packed array — i.e. the keys start at 0 and are sequential without gaps: BSON array.

If the array is not packed — i.e. having associative (string) keys, the keys don't start at 0, or when there are gaps:: BSON object

A top-level (root) document, always serializes as a BSON document.

Examples

These serialize as a BSON array:

[ 8, 5, 2, 3 ] => [ 8, 5, 2, 3 ]
[ 0 => 4, 1 => 9 ] => [ 4, 9 ]

These serialize as a BSON document:

[ 0 => 1, 2 => 8, 3 => 12 ] => { "0" : 1, "2" : 8, "3" : 12 }
[ "foo" => 42 ] => { "foo" : 42 }
[ 1 => 9, 0 => 10 ] => { "1" : 9, "0" : 10 }

Note that the five examples are extracts of a full document, and represent only one value inside a document.

Objects

If an object is of the stdClass class, serialize as a BSON document.

If an object is a supported class that implements MongoDB\BSON\Type, then use the BSON serialization logic for that specific type. MongoDB\BSON\Type instances (excluding MongoDB\BSON\Serializable may only be serialized as a document field value. Attempting to serialize such an object as a root document will throw a MongoDB\Driver\Exception\UnexpectedValueException

If an object is of an unknown class implementing the MongoDB\BSON\Type interface, then throw a MongoDB\Driver\Exception\UnexpectedValueException

If an object is of any other class, without implementing any special interface, serialize as a BSON document. Keep only public properties, and ignore protected and private properties.

If an object is of a class that implements the MongoDB\BSON\Serializable interface, call MongoDB\BSON\Serializable::bsonSerialize() and use the returned array or stdClass to serialize as a BSON document or array. The BSON type will be determined by the following:

  1. Root documents must be serialized as a BSON document.

  2. MongoDB\BSON\Persistable objects must be serialized as a BSON document.

  3. If MongoDB\BSON\Serializable::bsonSerialize() returns a packed array, serialize as a BSON array.

  4. If MongoDB\BSON\Serializable::bsonSerialize() returns a non-packed array or stdClass, serialize as a BSON document.

  5. If MongoDB\BSON\Serializable::bsonSerialize() did not return an array or stdClass, throw an MongoDB\Driver\Exception\UnexpectedValueException exception.

If an object is of a class that implements the MongoDB\BSON\Persistable interface (which implies MongoDB\BSON\Serializable), obtain the properties in a similar way as in the previous paragraphs, but also add an additional property __pclass as a Binary value, with subtype 0x80 and data bearing the fully qualified class name of the object that is being serialized.

The __pclass property is added to the array or object returned by MongoDB\BSON\Serializable::bsonSerialize(), which means it will overwrite any __pclass key/property in the MongoDB\BSON\Serializable::bsonSerialize() return value. If you want to avoid this behaviour and set your own __pclass value, you must not implement MongoDB\BSON\Persistable and should instead implement MongoDB\BSON\Serializable directly.

Examples

<?php

class stdClass {
  public $foo = 42;
} // => { "foo" : 42 }

class MyClass {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
} // => { "foo" : 42 }

class AnotherClass1 implements MongoDB\BSON\Serializable {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
  function bsonSerialize() {
      return [ 'foo' => $this->foo, 'prot' => $this->prot ];
  }
} // => { "foo" : 42, "prot" : "wine" }

class AnotherClass2 implements MongoDB\BSON\Serializable {
  public $foo = 42;
  function bsonSerialize() {
      return $this;
  }
} // => MongoDB\Driver\Exception\UnexpectedValueException("bsonSerialize() did not return an array or stdClass")

class AnotherClass3 implements MongoDB\BSON\Serializable {
  private $elements = [ 'foo', 'bar' ];
  function bsonSerialize() {
      return $this->elements;
  }
} // => { "0" : "foo", "1" : "bar" }

class ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass4 implements MongoDB\BSON\Serializable {
    private $elements = [ 0 => 'foo', 2 => 'bar' ];
    function bsonSerialize() {
      return $this->elements;
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} // => { "things" : { "0" : "foo", "2" : "bar" } }

class ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass5 implements MongoDB\BSON\Serializable {
    private $elements = [ 0 => 'foo', 2 => 'bar' ];
    function bsonSerialize() {
      return array_values($this->elements);
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} // => { "things" : [ "foo", "bar" ] }

class ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass6 implements MongoDB\BSON\Serializable {
    private $elements = [ 'foo', 'bar' ];
    function bsonSerialize() {
      return (object) $this->elements;
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} // => { "things" : { "0" : "foo", "1" : "bar" } }

class UpperClass implements MongoDB\BSON\Persistable {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
  function bsonSerialize() {
      return [ 'foo' => $this->foo, 'prot' => $this->prot ];
  }
} // => { "foo" : 42, "prot" : "wine", "__pclass" : { "$type" : "80", "$binary" : "VXBwZXJDbGFzcw==" } }


Deserialization from BSON

The legacy mongo extension deserialized both BSON documents and arrays as PHP arrays. While PHP arrays are convenient to work with, this behavior was problematic because different BSON types could deserialize to the same PHP value (e.g. {"0": "foo"} and ["foo"]) and make it impossible to infer the original BSON type. By default, the current driver addresses this concern by ensuring that BSON arrays and documents are converted to PHP arrays and objects, respectively.

For compound types, there are three data types:

root

refers to the top-level BSON document only

document

refers to embedded BSON documents only

array

refers to a BSON array

Besides the three collective types, it is also possible to configure specific fields in your document to map to the data types mentioned below. As an example, the following type map allows you to map each embedded document within an "addresses" array to an Address class and each "city" field within those embedded address documents to a City class:

[
    'fieldPaths' => [
        'addresses.$' => 'MyProject\Address',
        'addresses.$.city' => 'MyProject\City',
    ],
]

Each of those three data types, as well as the field specific mappings, can be mapped against different PHP types. The possible mapping values are:

not set or NULL (default)

  • A BSON array will be deserialized as a PHP array.

  • A BSON document (root or embedded) without a __pclass property [1] becomes a PHP stdClass object, with each BSON document key set as a public stdClass property.

  • A BSON document (root or embedded) with a __pclass property [1] becomes a PHP object of the class name as defined by the __pclass property.

    If the named class implements the MongoDB\BSON\Persistable interface, then the properties of the BSON document, including the __pclass property, are sent as an associative array to the MongoDB\BSON\Unserializable::bsonUnserialize() function to initialise the object's properties.

    If the named class does not exist or does not implement the MongoDB\BSON\Persistable interface, stdClass will be used and each BSON document key (including __pclass) will be set as a public stdClass property.

    The __pclass functionality relies on the property being part of a retrieved MongoDB document. If you use a projection when querying for documents, you need to include the __pclass field in the projection for this functionality to work.

"array"

Turns a BSON array or BSON document into a PHP array. There will be no special treatment of a __pclass property [1], but it may be set as an element in the returned array if it was present in the BSON document.

"object" or "stdClass"

Turns a BSON array or BSON document into a stdClass object. There will be no special treatment of a __pclass property [1], but it may be set as a public property in the returned object if it was present in the BSON document.

any other string

Defines the class name that the BSON array or BSON object should be deserialized as. For BSON objects that include __pclass properties, that class will take priority.

If the named class does not exist, is not concrete (i.e. it is abstract or an interface), or does not implement MongoDB\BSON\Unserializable then an MongoDB\Driver\Exception\InvalidArgumentException exception is thrown.

If the BSON object has a __pclass property and that class exists and implements MongoDB\BSON\Persistable it will supersede the class provided in the type map.

The properties of the BSON document, including the __pclass property if it exists, will be sent as an associative array to the MongoDB\BSON\Unserializable::bsonUnserialize() function to initialise the object's properties.

TypeMaps

TypeMaps can be set through the MongoDB\Driver\Cursor::setTypeMap() method on a MongoDB\Driver\Cursor object, or the $typeMap argument of MongoDB\BSON\toPHP(). Each of the three classes (root, document, and array) can be individually set, in addition to the field specific types.

If the value in the map is NULL, it means the same as the default value for that item.

Examples

These examples use the following classes:

MyClass

which does not implement any interface

YourClass

which implements MongoDB\BSON\Unserializable

OurClass

which implements MongoDB\BSON\Persistable

TheirClass

which extends OurClass

The MongoDB\BSON\Unserializable::bsonUnserialize() method of YourClass, OurClass, TheirClass iterate over the array and set the properties without modifications. It also sets the $unserialized property to true:

<?php

function bsonUnserialize( array $map )
{
    foreach ( $map as $k => $value )
    {
        $this->$k = $value;
    }
    $this->unserialized = true;
}

/* typemap: [] (all defaults) */
{ "foo": "yes", "bar" : false }
  -> stdClass { $foo => 'yes', $bar => false }

{ "foo": "no", "array" : [ 5, 6 ] }
  -> stdClass { $foo => 'no', $array => [ 5, 6 ] }

{ "foo": "no", "obj" : { "embedded" : 3.14 } }
  -> stdClass { $foo => 'no', $obj => stdClass { $embedded => 3.14 } }

{ "foo": "yes", "__pclass": "MyClass" }
  -> stdClass { $foo => 'yes', $__pclass => 'MyClass' }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "MyClass" } }
  -> stdClass { $foo => 'yes', $__pclass => Binary(0x80, 'MyClass') }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "YourClass") }
  -> stdClass { $foo => 'yes', $__pclass => Binary(0x80, 'YourClass') }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "OurClass") }
  -> OurClass { $foo => 'yes', $__pclass => Binary(0x80, 'OurClass'), $unserialized => true }

{ "foo": "yes", "__pclass": { "$type" : "44", "$binary" : "YourClass") }
  -> stdClass { $foo => 'yes', $__pclass => Binary(0x44, 'YourClass') }

/* typemap: [ "root" => "MissingClass" ] */
{ "foo": "yes" }
  -> MongoDB\Driver\Exception\InvalidArgumentException("MissingClass does not exist")

/* typemap: [ "root" => "MyClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> MongoDB\Driver\Exception\InvalidArgumentException("MyClass does not implement Unserializable interface")

/* typemap: [ "root" => "MongoDB\BSON\Unserializable" ] */
{ "foo": "yes" }
  -> MongoDB\Driver\Exception\InvalidArgumentException("Unserializable is not a concrete class")

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MongoDB\BSON\Unserializable" } }
  -> YourClass { $foo => "yes", $__pclass => Binary(0x80, "MongoDB\BSON\Unserializable"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> YourClass { $foo => "yes", $__pclass => Binary(0x80, "MyClass"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "OurClass" } }
  -> OurClass { $foo => "yes", $__pclass => Binary(0x80, "OurClass"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "TheirClass" } }
  -> TheirClass { $foo => "yes", $__pclass => Binary(0x80, "TheirClass"), $unserialized => true }

/* typemap: [ "root" => "OurClass" ] */
{ foo: "yes", "__pclass" : { "$type": "80", "$binary": "TheirClass" } }
  -> TheirClass { $foo => "yes", $__pclass => Binary(0x80, "TheirClass"), $unserialized => true }

/* typemap: [ 'root' => 'YourClass' ] */
{ foo: "yes", "__pclass" : { "$type": "80", "$binary": "YourClass" } }
  -> YourClass { $foo => 'yes', $__pclass => Binary(0x80, 'YourClass'), $unserialized => true }

/* typemap: [ 'root' => 'array', 'document' => 'array' ] */
{ "foo": "yes", "bar" : false }
  -> [ "foo" => "yes", "bar" => false ]

{ "foo": "no", "array" : [ 5, 6 ] }
  -> [ "foo" => "no", "array" => [ 5, 6 ] ]

{ "foo": "no", "obj" : { "embedded" : 3.14 } }
  -> [ "foo" => "no", "obj" => [ "embedded => 3.14 ] ]

{ "foo": "yes", "__pclass": "MyClass" }
  -> [ "foo" => "yes", "__pclass" => "MyClass" ]

{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> [ "foo" => "yes", "__pclass" => Binary(0x80, "MyClass") ]

{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "OurClass" } }
  -> [ "foo" => "yes", "__pclass" => Binary(0x80, "OurClass") ]

/* typemap: [ 'root' => 'object', 'document' => 'object' ] */
{ "foo": "yes", "__pclass": { "$type": "80", "$binary": "MyClass" } }
  -> stdClass { $foo => "yes", "__pclass" => Binary(0x80, "MyClass") }


  • ? Deserialization from BSON
  • Request Injection Attacks ?
  • PHP Manual
  • MongoDB
  • Security

Security

  • Request Injection Attacks
  • Script Injection Attacks


Request Injection Attacks

If you are passing $_GET (or $_POST) parameters to your queries, make sure that they are cast to strings first. Users can insert associative arrays in GET and POST requests, which could then become unwanted $-queries.

A fairly innocuous example: suppose you are looking up a user's information with the request http://www.example.com?username=bob. Your application creates the query $q = new \MongoDB\Driver\Query( [ 'username' => $_GET['username'] ]).

Someone could subvert this by getting http://www.example.com?username[$ne]=foo, which PHP will magically turn into an associative array, turning your query into $q = new \MongoDB\Driver\Query( [ 'username' => [ '$ne' => 'foo' ] ] ), which will return all users not named "foo" (all of your users, probably).

This is a fairly easy attack to defend against: make sure $_GET and $_POST parameters are the type you expect before you send them to the database. PHP has the filter_var() function to assist with this.

Note that this type of attack can be used with any database interaction that locates a document, including updates, upserts, deletes, and findAndModify commands.

See » the main documentation for more information about SQL-injection-like issues with MongoDB.


Script Injection Attacks

If you are using JavaScript, make sure that any variables that cross the PHP- to-JavaScript boundry are passed in the scope field of MongoDB\BSON\Javascript, not interpolated into the JavaScript string. This can come up when using $where clauses in queries, mapReduce and group commands, and any other time you may pass JavaScript into the database.

For example, suppose we have some JavaScript to greet a user in the database logs. We could do:

<?php
$m = new MongoDB\Driver\Manager;

// Don't do this!!!
$username = $_GET['field'];

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "print('Hello, $username!');"
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

However, what if a malicious user passes in some JavaScript?

<?php
$m = new MongoDB\Driver\Manager;

// Don't do this!!!
$username = $_GET['field'];
// $username is set to "'); db.users.drop(); print('"

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "print('Hello, $username!');"
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

Now MongoDB executes the JavaScript string "print('Hello, '); db.users.drop(); print('!');". This attack is easy to avoid: use args to pass variables from PHP to JavaScript:

<?php
$m = new MongoDB\Driver\Manager;

$_GET['field'] = 'derick';
$args = [ $_GET['field'] ];

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "function greet(username) { print('Hello, ' + username + '!'); }",
    'args' => $args,
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

This adds an argument to the JavaScript scope, which gets used as argument for the greet function. Now if someone tries to send malicious code, MongoDB will harmlessly print Hello, '); db.dropDatabase(); print('!.

Using arguments helps to prevent malicious input from being executed by the database. However, you must make sure that your code does not turn around and execute the input anyway! It is best to avoid executing any JavaScript on the server in the first place.

You are strongly recommended to stay clear of the » $where clause with queries, as it impacts performance significantly. Where possible, use either normal query operators, or the » Aggregation Framework.

As alternative to » MapReduce, which uses JavaScript, consider using the » Aggregation Framework. Unlike Map/Reduce, it uses an idiomatic language to construct queries, without having to write, and use, the slower JavaScript approach that Map/Reduce requires.

The » eval command has been deprecated since MongoDB 3.0, and should also be avoided.


MongoDB 驱动类

  • MongoDB\Driver\Manager — The MongoDB\Driver\Manager class
    • MongoDB\Driver\Manager::__construct — Create new MongoDB Manager
    • MongoDB\Driver\Manager::createClientEncryption — Create a new ClientEncryption object
    • MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations
    • MongoDB\Driver\Manager::executeCommand — Execute a database command
    • MongoDB\Driver\Manager::executeQuery — Execute a database query
    • MongoDB\Driver\Manager::executeReadCommand — Execute a database command that reads
    • MongoDB\Driver\Manager::executeReadWriteCommand — Execute a database command that reads and writes
    • MongoDB\Driver\Manager::executeWriteCommand — Execute a database command that writes
    • MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager
    • MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager
    • MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected
    • MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager
    • MongoDB\Driver\Manager::selectServer — Select a server matching a read preference
    • MongoDB\Driver\Manager::startSession — Start a new client session for use with this client
  • MongoDB\Driver\Command — The MongoDB\Driver\Command class
    • MongoDB\Driver\Command::__construct — Create a new Command
  • MongoDB\Driver\Query — The MongoDB\Driver\Query class
    • MongoDB\Driver\Query::__construct — Create a new Query
  • MongoDB\Driver\BulkWrite — The MongoDB\Driver\BulkWrite class
    • MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite
    • MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk
    • MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk
    • MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk
    • MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk
  • MongoDB\Driver\WriteConcern — The MongoDB\Driver\WriteConcern class
    • MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\WriteConcern::__construct — Create a new WriteConcern
    • MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option
    • MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option
    • MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option
    • MongoDB\Driver\WriteConcern::isDefault — Checks if this is the default write concern
    • MongoDB\Driver\WriteConcern::serialize — Serialize a WriteConcern
    • MongoDB\Driver\WriteConcern::unserialize — Unserialize a WriteConcern
  • MongoDB\Driver\ReadPreference — The MongoDB\Driver\ReadPreference class
    • MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\ReadPreference::__construct — Create a new ReadPreference
    • MongoDB\Driver\ReadPreference::getHedge — Returns the ReadPreference's "hedge" option
    • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option
    • MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option
    • MongoDB\Driver\ReadPreference::getModeString — Returns the ReadPreference's "mode" option as a string
    • MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option
    • MongoDB\Driver\ReadPreference::serialize — Serialize a ReadPreference
    • MongoDB\Driver\ReadPreference::unserialize — Unserialize a ReadPreference
  • MongoDB\Driver\ReadConcern — The MongoDB\Driver\ReadConcern class
    • MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\ReadConcern::__construct — Create a new ReadConcern
    • MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option
    • MongoDB\Driver\ReadConcern::isDefault — Checks if this is the default read concern
    • MongoDB\Driver\ReadConcern::serialize — Serialize a ReadConcern
    • MongoDB\Driver\ReadConcern::unserialize — Unserialize a ReadConcern
  • MongoDB\Driver\Cursor — The MongoDB\Driver\Cursor class
    • MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)
    • MongoDB\Driver\Cursor::current — Returns the current element
    • MongoDB\Driver\Cursor::getId — Returns the ID for this cursor
    • MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor
    • MongoDB\Driver\Cursor::isDead — Checks if the cursor is exhausted or may have additional results
    • MongoDB\Driver\Cursor::key — Returns the current result's index within the cursor
    • MongoDB\Driver\Cursor::next — Advances the cursor to the next result
    • MongoDB\Driver\Cursor::rewind — Rewind the cursor to the first result
    • MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization
    • MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor
    • MongoDB\Driver\Cursor::valid — Checks if the current position in the cursor is valid
  • MongoDB\Driver\CursorId — The MongoDB\Driver\CursorId class
    • MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)
    • MongoDB\Driver\CursorId::serialize — Serialize a CursorId
    • MongoDB\Driver\CursorId::__toString — String representation of the cursor ID
    • MongoDB\Driver\CursorId::unserialize — Unserialize a CursorId
  • MongoDB\Driver\Server — The MongoDB\Driver\Server class
    • MongoDB\Driver\Server::__construct — Create a new Server (not used)
    • MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server
    • MongoDB\Driver\Server::executeCommand — Execute a database command on this server
    • MongoDB\Driver\Server::executeQuery — Execute a database query on this server
    • MongoDB\Driver\Server::executeReadCommand — Execute a database command that reads on this server
    • MongoDB\Driver\Server::executeReadWriteCommand — Execute a database command that reads and writes on this server
    • MongoDB\Driver\Server::executeWriteCommand — Execute a database command that writes on this server
    • MongoDB\Driver\Server::getHost — Returns the hostname of this server
    • MongoDB\Driver\Server::getInfo — Returns an array of information about this server
    • MongoDB\Driver\Server::getLatency — Returns the latency of this server
    • MongoDB\Driver\Server::getPort — Returns the port on which this server is listening
    • MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set
    • MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server
    • MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set
    • MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set
    • MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set
    • MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set
    • MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set
  • MongoDB\Driver\WriteConcernError — The MongoDB\Driver\WriteConcernError class
    • MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code
    • MongoDB\Driver\WriteConcernError::getInfo — Returns metadata document for the WriteConcernError
    • MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message
  • MongoDB\Driver\WriteError — The MongoDB\Driver\WriteError class
    • MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code
    • MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError
    • MongoDB\Driver\WriteError::getInfo — Returns metadata document for the WriteError
    • MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message
  • MongoDB\Driver\WriteResult — The MongoDB\Driver\WriteResult class
    • MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted
    • MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)
    • MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update
    • MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated
    • MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result
    • MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert
    • MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents
    • MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred
    • MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred
    • MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged


The MongoDB\Driver\Manager class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\Manager is the main entry point to the extension. It is responsible for maintaining connections to MongoDB (be it standalone server, replica set, or sharded cluster).

No connection to MongoDB is made upon instantiating the Manager. This means the MongoDB\Driver\Manager can always be constructed, even though one or more MongoDB servers are down.

Any write or query can throw connection exceptions as connections are created lazily. A MongoDB server may also become unavailable during the life time of the script. It is therefore important that all actions on the Manager to be wrapped in try/catch statements.

类摘要

final MongoDB\Driver\Manager {
/* 方法 */
final public __construct
 ( string $uri = "mongodb://127.0.0.1/"
, array $uriOptions = array()
, array $driverOptions = array()
)
final public createClientEncryption ( array $options ) : MongoDB\Driver\ClientEncryption
final public executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk , array $options = array() ) : MongoDB\Driver\WriteResult
final public executeCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeQuery ( string $namespace , MongoDB\Driver\Query $query , array $options = array() ) : MongoDB\Driver\Cursor
final public executeReadCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeReadWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public getReadConcern ( ) : MongoDB\Driver\ReadConcern
final public getReadPreference ( ) : MongoDB\Driver\ReadPreference
final public getServers ( ) : array
final public getWriteConcern ( ) : MongoDB\Driver\WriteConcern
final public selectServer ( MongoDB\Driver\ReadPreference $readPreference ) : MongoDB\Driver\Server
final public startSession ( array $options = ? ) : MongoDB\Driver\Session
}

范例

Example #1 MongoDB\Driver\Manager::__construct() basic example

var_dump()ing a MongoDB\Driver\Manager will print out various details about the manager that are otherwise not normally exposed. This can be useful to debug how the driver views your MongoDB setup, and which options are used.

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
var_dump($manager);

?>

以上例程的输出类似于：

object(MongoDB\Driver\Manager)#1 (3) {
  ["request_id"]=>
  int(1714636915)
  ["uri"]=>
  string(25) "mongodb://localhost:27017"
  ["cluster"]=>
  array(13) {
    ["mode"]=>
    string(6) "direct"
    ["state"]=>
    string(4) "born"
    ["request_id"]=>
    int(0)
    ["sockettimeoutms"]=>
    int(300000)
    ["last_reconnect"]=>
    int(0)
    ["uri"]=>
    string(25) "mongodb://localhost:27017"
    ["requires_auth"]=>
    int(0)
    ["nodes"]=>
    array(...)
    ["max_bson_size"]=>
    int(16777216)
    ["max_msg_size"]=>
    int(50331648)
    ["sec_latency_ms"]=>
    int(15)
    ["peers"]=>
    array(0) {
    }
    ["replSet"]=>
    NULL
  }
}

Table of Contents

  • MongoDB\Driver\Manager::__construct — Create new MongoDB Manager
  • MongoDB\Driver\Manager::createClientEncryption — Create a new ClientEncryption object
  • MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations
  • MongoDB\Driver\Manager::executeCommand — Execute a database command
  • MongoDB\Driver\Manager::executeQuery — Execute a database query
  • MongoDB\Driver\Manager::executeReadCommand — Execute a database command that reads
  • MongoDB\Driver\Manager::executeReadWriteCommand — Execute a database command that reads and writes
  • MongoDB\Driver\Manager::executeWriteCommand — Execute a database command that writes
  • MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager
  • MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager
  • MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected
  • MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager
  • MongoDB\Driver\Manager::selectServer — Select a server matching a read preference
  • MongoDB\Driver\Manager::startSession — Start a new client session for use with this client


Create new MongoDB Manager

  • ? MongoDB\Driver\Manager
  • MongoDB\Driver\Manager::createClientEncryption ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Create new MongoDB Manager

MongoDB\Driver\Manager::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Manager::__construct — Create new MongoDB Manager

说明

final public MongoDB\Driver\Manager::__construct
 ( string $uri = "mongodb://127.0.0.1/"
, array $uriOptions = array()
, array $driverOptions = array()
)

Constructs a new MongoDB\Driver\Manager object with the specified options.

Note: Per the » Server Discovery and Monitoring Specification, this constructor performs no I/O. Connections will be initialized on demand, when the first operation is executed.

Note: When specifying any SSL or TLS URI options via the connection string or uriOptions parameter, the driver will implicitly enable TLS for its connections. To avoid this, either explicitly disable the tls option or don't specify any TLS options.

Note: On Unix platforms, the MongoDB driver is sensitive to scripts that use the fork() system call without also calling exec(). Users are advised not to re-use MongoDB\Driver\Manager instances in a forked child process.

参数

uri

A » mongodb:// connection URI:

mongodb://[username:password@]host1[:port1][,host2[:port2],...[,hostN[:portN]]][/[defaultAuthDb][?options]]

For details on supported URI options, see » Connection String Options in the MongoDB manual. » Connection pool options are not supported, as the PHP driver does not implement connection pools.

The uri is a URL, hence any special characters in its components need to be URL encoded according to » RFC 3986. This is particularly relevant to the username and password, which can often include special characters such as @, :, or %. When connecting via a Unix domain socket, the socket path may contain special characters such as slashes and must be encoded. The rawurlencode() function may be used to encode constituent parts of the URI.

The defaultAuthDb component may be used to specify the database name associated with the user's credentials; however the authSource URI option will take priority if specified. If neither defaultAuthDb nor authSource are specified, the admin database will be used by default. The defaultAuthDb component has no effect in the absence of user credentials.

uriOptions

Additional » connection string options, which will overwrite any options with the same name in the uri parameter.

uriOptions
Option | Type | Description
appname string

MongoDB 3.4+ has the ability to annotate connections with metadata provided by the connecting client. This metadata is included in the server's logs upon establishing a connection and also recorded in slow query logs when database profiling is enabled.

This option may be used to specify an application name, which will be included in the metadata. The value cannot exceed 128 characters in length.

authMechanism string

The authentication mechanism that MongoDB will use to authenticate the connection. For additional details and a list of supported values, see » Authentication Options in the MongoDB manual.

authMechanismProperties array

Properties for the selected authentication mechanism. For additional details and a list of supported properties, see the » Driver Authentication Specification.

Note: When not specified in the URI string, this option is expressed as an array of key/value pairs. The keys and values in this array should be strings.

authSource string

The database name associated with the user's credentials. Defaults to the database component of the connection URI, or the admin database if both are unspecified.

For authentication mechanisms that delegate credential storage to other services (e.g. GSSAPI), this should be "$external".

canonicalizeHostname bool

If true, the driver will resolve the real hostname for the server IP address before authenticating via SASL. Some underlying GSSAPI layers already do this, but the functionality may be disabled in their config (e.g. krb.conf). Defaults to false.

This option is a deprecated alias for the "CANONICALIZE_HOST_NAME" property of the "authMechanismProperties" URI option.

compressors string

A prioritized, comma-delimited list of compressors that the client wants to use. Messages are only compressed if the client and server share any compressors in common, and the compressor used in each direction will depend on the individual configuration of the server or driver. See the » Driver Compression Specification for more information.

connectTimeoutMS int

The time in milliseconds to attempt a connection before timing out. Defaults to 10,000 milliseconds.

directConnection bool

This option can be used to control replica set discovery behavior when only a single host is provided in the connection string. By default, providing a single member in the connection string will establish a direct connection or discover additional members depending on whether the "replicaSet" URI option is omitted or present, respectively. Specify false to force discovery to occur (if "replicaSet" is omitted) or specify true to force a direct connection (if "replicaSet" is present).

gssapiServiceName string

Set the Kerberos service name when connecting to Kerberized MongoDB instances. This value must match the service name set on MongoDB instances (i.e. » saslServiceName server parameter). Defaults to "mongodb".

This option is a deprecated alias for the "SERVICE_NAME" property of the "authMechanismProperties" URI option.

heartbeatFrequencyMS int

Specifies the interval in milliseconds between the driver's checks of the MongoDB topology, counted from the end of the previous check until the beginning of the next one. Defaults to 60,000 milliseconds.

Per the » Server Discovery and Monitoring Specification, this value cannot be less than 500 milliseconds.

journal bool

Corresponds to the default write concern's journal parameter. If true, writes will require acknowledgement from MongoDB that the operation has been written to the journal. For details, see MongoDB\Driver\WriteConcern.

localThresholdMS int

The size in milliseconds of the latency window for selecting among multiple suitable MongoDB instances while resolving a read preference. Defaults to 15 milliseconds.

maxStalenessSeconds int

Corresponds to the read preference's "maxStalenessSeconds". Specifies, in seconds, how stale a secondary can be before the client stops using it for read operations. By default, there is no maximum staleness and clients will not consider a secondary's lag when choosing where to direct a read operation. For details, see MongoDB\Driver\ReadPreference.

If specified, the max staleness must be a signed 32-bit integer greater than or equal to MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS (i.e. 90 seconds).

password | string | The password for the user being authenticated. This option is useful if the password contains special characters, which would otherwise need to be URL encoded for the connection URI.
readConcernLevel | string | Corresponds to the read concern's level parameter. Specifies the level of read isolation. For details, see MongoDB\Driver\ReadConcern.
readPreference string

Corresponds to the read preference's mode parameter. Defaults to "primary". For details, see MongoDB\Driver\ReadPreference.

readPreferenceTags array

Corresponds to the read preference's tagSets parameter. Tag sets allow you to target read operations to specific members of a replica set. For details, see MongoDB\Driver\ReadPreference.

Note: When not specified in the URI string, this option is expressed as an array consistent with the format expected by MongoDB\Driver\ReadPreference::__construct().

replicaSet string

Specifies the name of the replica set.

retryReads bool

Specifies whether or not the driver should automatically retry certain read operations that fail due to transient network errors or replica set elections. This functionality requires MongoDB 3.6+. Defaults to true.

See the » Retryable Reads Specification for more information.

retryWrites bool

Specifies whether or not the driver should automatically retry certain write operations that fail due to transient network errors or replica set elections. This functionality requires MongoDB 3.6+. Defaults to true.

See » Retryable Writes in the MongoDB manual for more information.

safe bool

If true, specifies 1 for the default write concern's w parameter. If false, 0 is specified. For details, see MongoDB\Driver\WriteConcern.

This option is deprecated and should not be used.

serverSelectionTimeoutMS int

Specifies how long in milliseconds to block for server selection before throwing an exception. Defaults to 30,000 milliseconds.

serverSelectionTryOnce bool

When true, instructs the driver to scan the MongoDB deployment exactly once after server selection fails and then either select a server or raise an error. When false, the driver blocks and searches for a server up to the "serverSelectionTimeoutMS" value. Defaults to true.

slaveOk bool

Specifies "secondaryPreferred" for the read preference mode if true. For details, see MongoDB\Driver\ReadPreference.

This option is deprecated and should not be used.

socketCheckIntervalMS int

If a socket has not been used recently, the driver must check it via an isMaster command before using it for any operation. Defaults to 5,000 milliseconds.

socketTimeoutMS int

The time in milliseconds to attempt a send or receive on a socket before timing out. Defaults to 300,000 milliseconds (i.e. five minutes).

ssl bool

Initiates the connection with TLS/SSL if true. Defaults to false.

This option is a deprecated alias for the "tls" URI option.

tls bool

Initiates the connection with TLS/SSL if true. Defaults to false.

tlsAllowInvalidCertificates bool

Specifies whether or not the driver should error when the server's TLS certificate is invalid. Defaults to false.

Warning

Disabling certificate validation creates a vulnerability.

tlsAllowInvalidHostnames bool

Specifies whether or not the driver should error when there is a mismatch between the server's hostname and the hostname specified by the TLS certificate. Defaults to false.

Warning

Disabling certificate validation creates a vulnerability. Allowing invalid hostnames may expose the driver to a » man-in-the-middle attack.

tlsCAFile string

Path to file with either a single or bundle of certificate authorities to be considered trusted when making a TLS connection. The system certificate store will be used by default.

tlsCertificateKeyFile string

Path to the client certificate file or the client private key file; in the case that they both are needed, the files should be concatenated.

tlsCertificateKeyFilePassword string

Password to decrypt the client private key (i.e. "tlsCertificateKeyFile" URI option) to be used for TLS connections.

tlsDisableCertificateRevocationCheck bool

If true, the driver will not attempt to check certificate revocation status (e.g. OCSP, CRL). Defaults to false.

tlsDisableOCSPEndpointCheck bool

If true, the driver will not attempt to contact an OCSP responder endpoint if needed (i.e. an OCSP response is not stapled). Defaults to false.

tlsInsecure bool

Relax TLS constraints as much as possible. Specifying true for this option has the same effect as specifying true for both the "tlsAllowInvalidCertificates" and "tlsAllowInvalidHostnames" URI options. Defaults to false.

Warning

Disabling certificate validation creates a vulnerability. Allowing invalid hostnames may expose the driver to a » man-in-the-middle attack.

username | string | The username for the user being authenticated. This option is useful if the username contains special characters, which would otherwise need to be URL encoded for the connection URI.
w int|string

Corresponds to the default write concern's w parameter. For details, see MongoDB\Driver\WriteConcern.

wTimeoutMS int|string

Corresponds to the default write concern's wtimeout parameter. Specifies a time limit, in milliseconds, for the write concern. For details, see MongoDB\Driver\WriteConcern.

If specified, wTimeoutMS must be a signed 32-bit integer greater than or equal to zero.

zlibCompressionLevel int

Specifies the compression level to use for the zlib compressor. This option has no effect if zlib is not included in the "compressors" URI option. See the » Driver Compression Specification for more information.

driverOptions

driverOptions
Option | Type | Description
allow_invalid_hostname bool

Disables hostname validation if true. Defaults to false.

Allowing invalid hostnames may expose the driver to a » man-in-the-middle attack.

This option is a deprecated alias for the "tlsAllowInvalidHostnames" URI option.

autoEncryption array

Provides options to enable automatic client-side field level encryption. The following options are supported:

Options for automatic encryption
Option | Type | Description
keyVaultClient | MongoDB\Driver\Manager | The Manager used to route data key queries to a separate MongoDB cluster. By default, the current Manager and cluster is used.
keyVaultNamespace | string | A fully qualified namespace (e.g. "databaseName.collectionName") denoting the collection that contains all data keys used for encryption and decryption.
kmsProviders array

A document containing the configuration for one or more KMS providers, which are used to encrypt data keys. Currently aws or local are supported and at least one must be specified.

The format for aws is as follows:

aws: {
    accessKeyId: <string>,
    secretAccessKey: <string>
}

The format for local is as follows:

local: {
    // The master key used to encrypt/decrypt data keys
    key: <96-byte MongoDB\BSON\Binary with subtype 0>
}
schemaMap array

Allows specifying a local JSON schema that is used to configure encryption.

Note: Supplying a schemaMap provides more security than relying on JSON schemas obtained from the server. It protects against a malicious server advertising a false JSON schema, which could trick the client into sending unencrypted data that should be encrypted.

Note: Schemas supplied in the schemaMap only apply to configuring automatic encryption for client side encryption. Other validation rules in the JSON schema will not be enforced by the driver and will result in an error.

bypassAutoEncryption | bool | With this option set to true, mongocryptd will not be spawned automatically. This is used to disable automatic encryption.
extraOptions | array | The extraOptions relate to the mongocryptd process. See the » Client-Side Encryption Specification for more information.

Note: Automatic encryption is an enterprise only feature that only applies to operations on a collection. Automatic encryption is not supported for operations on a database or view, and operations that are not bypassed will result in error. To bypass automatic encryption for all operations, set bypassAutoEncryption=true in autoEncryption. For more information on whitelisted operations, see the » Client-Side Encryption Specification.

ca_dir string

Path to a correctly hashed certificate directory. The system certificate store will be used by default.

ca_file string

Path to file with either a single or bundle of certificate authorities to be considered trusted when making a TLS connection. The system certificate store will be used by default.

This option is a deprecated alias for the "tlsCAFile" URI option.

context resource

SSL context options to be used as fallbacks if a driver option or its equivalent URI option, if any, is not specified. Note that the driver does not consult the default stream context (i.e. stream_context_get_default()). The following context options are supported:

SSL context option fallbacks
Driver option | Context option (fallback)
ca_dir | capath
ca_file | cafile
pem_file | local_cert
pem_pwd | passphrase
weak_cert_validation | allow_self_signed

This option is supported for backwards compatibility, but should be considered deprecated.

crl_file | string | Path to a certificate revocation list file.
driver array

Allows custom drivers to append their own metadata to the server handshake. By default, the driver submits its own name, version, and platform (i.e. PHP version) in the handshake. Custom drivers can specify strings for the "name", "version", and "platform" keys of this array, which will be appended to the respective field(s) in the handshake document.

Note: Handshake information is limited to 512 bytes. The driver will truncate handshake data to fit within this 512-byte string. Drivers and ODMs are encouraged to keep their own metadata concise.

pem_file string

Path to a PEM encoded certificate to use for client authentication.

This option is a deprecated alias for the "tlsCertificateKeyFile" URI option.

pem_pwd string

Passphrase for the PEM encoded certificate (if applicable).

This option is a deprecated alias for the "tlsCertificateKeyFilePassword" URI option.

weak_cert_validation bool

Disables certificate validation if true. Defaults to false

This option is a deprecated alias for the "tlsAllowInvalidHostnames" URI option.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\RuntimeException if the uri format is invalid

更新日志

版本 说明
PECL mongodb 1.8.0

Added the "directConnection", "tlsDisableCertificateRevocationCheck", and "tlsDisableOCSPEndpointCheck" URI options.

Added the "driver" driver option.

PECL mongodb 1.7.0

Added the "autoEncryption" driver option.

Specifying any SSL or TLS option via the driverOptions parameter will now implicitly enable TLS, as is done for the corresponding URI options.

PECL mongodb 1.6.0

Added the "retryReads", "tls", "tlsAllowInvalidCertificates", "tlsAllowInvalidHostnames", "tlsCAFile", "tlsCertificateKeyFile", "tlsCertificateKeyFilePassword", and "tlsInsecure" URI options.

The "retryWrites" URI option defaults to true.

Specifying any SSL or TLS URI option via the connection string or uriOptions parameter will now implicitly enable TLS unless ssl or tls is false. TLS is not implicitly enabled for any options in the driverOptions parameter, which is unchanged from previous versions.

PECL mongodb 1.5.0

"wtimeoutMS" is now always validated and applied to the write concern. Previously, the option was ignored if "w" was <= 1, since the timeout only applies to replication.

PECL mongodb 1.4.0

Added the "compressors", "retryWrites", and "zlibCompressionLevel" URI options.

PECL mongodb 1.3.0

The uriOptions argument now accepts "authMechanism" and "authMechanismProperties" options. Previously, these options were only supported in the uri argument.

PECL mongodb 1.2.0

The uri argument defaults to "mongodb://127.0.0.1/". The default port remains 27017.

Added the "appname" URI option.

Added the "allow_invalid_hostname", "ca_file", "ca_dir", "clr_file", "pem_file", "pem_pwd", and "weak_cert_validation" driver options.

The PHP Streams API is no longer used for socket communication. The "connectTimeoutMS" URI option now defaults to 10 seconds instead of default_socket_timeout in previous versions. Additionally, the driver no longer supports all SSL context options via the "context" driver option.

PECL mongodb 1.1.0

The uri argument is optional and defaults to "mongodb://localhost:27017/".

范例

Example #1 MongoDB\Driver\Manager::__construct() basic examples

Connecting to standalone MongoDB node:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://example.com:27017");

?>

Connecting to standalone MongoDB node via a Unix domain socket. The socket path may include special characters such as slashes and should be encoded with rawurlencode().

<?php

$manager = new MongoDB\Driver\Manager("mongodb://" . rawurlencode("/tmp/mongodb-27017.sock"));

?>

Connecting to a replica set:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

?>

Connecting to a sharded cluster (i.e. one or more mongos instances):

<?php

$manager = new MongoDB\Driver\Manager("mongodb://mongos1.example.com,mongos2.example.com/");

?>

Connecting to MongoDB with authentication credentials for a particular user and database:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://myusername:mypassword@example.com/?authSource=databaseName");

?>

Connecting to MongoDB with authentication credentials for a particular user and database, where the username or password includes special characters (e.g. @, :, %). In the following example, the password string myp@ss:w%rd has been manually escaped; however, rawurlencode() may also be used to escape URI components that may contain special characters.

<?php

$manager = new MongoDB\Driver\Manager("mongodb://myusername:myp%40ss%3Aw%25rd@example.com/?authSource=databaseName");

?>

Connecting to MongoDB with X509 authentication:

<?php

$manager = new MongoDB\Driver\Manager(
    "mongodb://example.com/?ssl=true&authMechanism=MONGODB-X509",
    [],
    [
        "pem_file" => "/path/to/client.pem",
    ]
);
?>

参见

  • Connection handling and persistence
  • » MongoDB Connection String Format


Create a new ClientEncryption object

  • ? MongoDB\Driver\Manager::__construct
  • MongoDB\Driver\Manager::executeBulkWrite ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Create a new ClientEncryption object

MongoDB\Driver\Manager::createClientEncryption

(mongodb >=1.7.0)

MongoDB\Driver\Manager::createClientEncryption — Create a new ClientEncryption object

说明

final public MongoDB\Driver\Manager::createClientEncryption ( array $options ) : MongoDB\Driver\ClientEncryption

Constructs a new MongoDB\Driver\ClientEncryption object with the specified options.

参数

options

options
Option | Type | Description
keyVaultClient | MongoDB\Driver\Manager | The Manager used to route data key queries to a separate MongoDB cluster. By default, the current Manager and cluster is used.
keyVaultNamespace | string | A fully qualified namespace (e.g. "databaseName.collectionName") denoting the collection that contains all data keys used for encryption and decryption.
kmsProviders array

A document containing the configuration for one or more KMS providers, which are used to encrypt data keys. Currently aws or local are supported and at least one must be specified.

The format for aws is as follows:

aws: {
    accessKeyId: <string>,
    secretAccessKey: <string>
}

The format for local is as follows:

local: {
    // The master key used to encrypt/decrypt data keys
    key: <96-byte MongoDB\BSON\Binary with subtype 0>
}

返回值

Returns a new MongoDB\Driver\ClientEncryption instance.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\RuntimeException if the extension was compiled without libmongocrypt support

参见

  • MongoDB\Driver\ClientEncryption
  • » Explicit (Manual) Client-Side Field Level Encryption in the MongoDB manual


Execute one or more write operations

  • ? MongoDB\Driver\Manager::createClientEncryption
  • MongoDB\Driver\Manager::executeCommand ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute one or more write operations

MongoDB\Driver\Manager::executeBulkWrite

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations

说明

final public MongoDB\Driver\Manager::executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk , array $options = array() ) : MongoDB\Driver\WriteResult

Executes one or more write operations on the primary server.

A MongoDB\Driver\BulkWrite can be constructed with one or more write operations of varying types (e.g. updates, deletes, and inserts). The driver will attempt to send operations of the same type to the server in as few requests as possible to optimize round trips.

参数

namespace (string)

A fully qualified namespace (e.g. "databaseName.collectionName").

bulk (MongoDB\Driver\BulkWrite)

The write(s) to execute.

options

options
Option Type Description
session MongoDB\Driver\Session

A session to associate with the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

返回值

Returns MongoDB\Driver\WriteResult on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if bulk does not contain any write operations.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if bulk has already been executed. MongoDB\Driver\BulkWrite objects may not be executed multiple times.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used in combination with an unacknowledged write concern.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\BulkWriteException on any write failure (e.g. write error, failure to apply a write concern)
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors.

更新日志

版本 | 说明
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\WriteConcern object.
PECL mongodb 1.3.0 | MongoDB\Driver\Exception\InvalidArgumentException is now thrown if bulk does not contain any write operations. Previously, a MongoDB\Driver\Exception\BulkWriteException was thrown.

范例

Example #1 MongoDB\Driver\Manager::executeBulkWrite() example

<?php

$bulk = new MongoDB\Driver\BulkWrite();

$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);

$bulk->update(['x' => 2], ['$set' => ['x' => 1]], ['multi' => false, 'upsert' => false]);
$bulk->update(['x' => 3], ['$set' => ['x' => 3]], ['multi' => false, 'upsert' => true]);
$bulk->update(['_id' => 3], ['$set' => ['x' => 3]], ['multi' => false, 'upsert' => true]);

$bulk->insert(['_id' => 4, 'x' => 2]);

$bulk->delete(['x' => 1], ['limit' => 1]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 100);
$result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Matched  %d document(s)\n", $result->getMatchedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());
printf("Upserted %d document(s)\n", $result->getUpsertedCount());
printf("Deleted  %d document(s)\n", $result->getDeletedCount());

foreach ($result->getUpsertedIds() as $index => $id) {
    printf('upsertedId[%d]: ', $index);
    var_dump($id);
}

/* If the WriteConcern could not be fulfilled */
if ($writeConcernError = $result->getWriteConcernError()) {
    printf("%s (%d): %s\n", $writeConcernError->getMessage(), $writeConcernError->getCode(), var_export($writeConcernError->getInfo(), true));
}

/* If a write could not happen at all */
foreach ($result->getWriteErrors() as $writeError) {
    printf("Operation#%d: %s (%d)\n", $writeError->getIndex(), $writeError->getMessage(), $writeError->getCode());
}
?>

以上例程的输出类似于：

Inserted 3 document(s)
Matched  1 document(s)
Updated  1 document(s)
Upserted 2 document(s)
Deleted  1 document(s)
upsertedId[3]: object(MongoDB\BSON\ObjectId)#5 (1) {
  ["oid"]=>
  string(24) "54d3adc3ce7a792f4d703756"
}
upsertedId[4]: int(3)

参见

  • MongoDB\Driver\BulkWrite
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Server::executeBulkWrite() - Execute one or more write operations on this server


Execute a database command

  • ? MongoDB\Driver\Manager::executeBulkWrite
  • MongoDB\Driver\Manager::executeQuery ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database command

MongoDB\Driver\Manager::executeCommand

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeCommand — Execute a database command

说明

final public MongoDB\Driver\Manager::executeCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Selects a server according to the "readPreference" option and executes the command on that server. By default, the read preference from the MongoDB Connection URI will be used.

This method applies no special logic to the command. Although this method accepts "readConcern" and "writeConcern" options, which will be incorporated into the command document, those options will not default to corresponding values from the MongoDB Connection URI nor will the MongoDB server version be taken into account. Users are therefore encouraged to use specific read and/or write command methods if possible.

参数

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The command to execute.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

readPreference MongoDB\Driver\ReadPreference

A read preference to use for selecting a server for the operation.

session MongoDB\Driver\Session

A session to associate with the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

Warning

If you are using a "session" which has a transaction in progress, you cannot specify a "readConcern" or "writeConcern" option. This will result in an MongoDB\Driver\Exception\InvalidArgumentException being thrown. Instead, you should set these two options when you create the transaction with MongoDB\Driver\Session::startTransaction().

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used with an associated transaction in combination with a "readConcern" or "writeConcern" option.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used in combination with an unacknowledged write concern.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command, issuing a write command to a secondary).

更新日志

版本 | 说明
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\ReadPreference object.

范例

Example #1 MongoDB\Driver\Manager::executeCommand() with a command returning a single result document

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$command = new MongoDB\Driver\Command(['ping' => 1]);

try {
    $cursor = $manager->executeCommand('admin', $command);
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}

/* The ping command returns a single result document, so we need to access the
 * first result in the cursor. */
$response = $cursor->toArray()[0];

var_dump($response);

?>

以上例程会输出：

array(1) {
  ["ok"]=>
  float(1)
}

Example #2 MongoDB\Driver\Manager::executeCommand() with a command returning a cursor

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1, 'y' => 'foo']);
$bulk->insert(['x' => 2, 'y' => 'bar']);
$bulk->insert(['x' => 3, 'y' => 'bar']);
$manager->executeBulkWrite('db.collection', $bulk);

$command = new MongoDB\Driver\Command([
    'aggregate' => 'collection',
    'pipeline' => [
        ['$group' => ['_id' => '$y', 'sum' => ['$sum' => '$x']]],
    ],
    'cursor' => new stdClass,
]);
$cursor = $manager->executeCommand('db', $command);

/* The aggregate command can optionally return its results in a cursor instead
 * of a single result document. In this case, we can iterate on the cursor
 * directly to access those results. */
foreach ($cursor as $document) {
    var_dump($document);
}

?>

以上例程会输出：

object(stdClass)#6 (2) {
  ["_id"]=>
  string(3) "bar"
  ["sum"]=>
  int(10)
}
object(stdClass)#7 (2) {
  ["_id"]=>
  string(3) "foo"
  ["sum"]=>
  int(2)
}

Example #3 Limiting execution time for a command

The execution time of a command may be limited by specifying a value for "maxTimeMS" in the MongoDB\Driver\Command document. Note that this time limit is enforced on the server side and does not take network latency into account. See » Terminate Running Operations in the MongoDB manual for more information.

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');

$command = new MongoDB\Driver\Command([
    'count' => 'collection',
    'query' => ['x' => ['$gt' => 1]],
    'maxTimeMS' => 1000,
]);

$cursor = $manager->executeCommand('db', $command);

var_dump($cursor->toArray()[0]);

?>

If the command fails to complete after one second of execution time on the server, a MongoDB\Driver\Exception\ExecutionTimeoutException will be thrown.

注释

Note: If a secondary readPreference is used, it is the caller's responsibility to ensure that the command can be executed on a secondary. No validation is done by the driver.

参见

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Manager::executeReadCommand() - Execute a database command that reads
  • MongoDB\Driver\Manager::executeReadWriteCommand() - Execute a database command that reads and writes
  • MongoDB\Driver\Manager::executeWriteCommand() - Execute a database command that writes
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server


Execute a database query

  • ? MongoDB\Driver\Manager::executeCommand
  • MongoDB\Driver\Manager::executeReadCommand ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database query

MongoDB\Driver\Manager::executeQuery

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeQuery — Execute a database query

说明

final public MongoDB\Driver\Manager::executeQuery ( string $namespace , MongoDB\Driver\Query $query , array $options = array() ) : MongoDB\Driver\Cursor

Selects a server according to the "readPreference" option and executes the query on that server. By default, the read preference from the MongoDB Connection URI will be used.

参数

namespace (string)

A fully qualified namespace (e.g. "databaseName.collectionName").

query (MongoDB\Driver\Query)

The query to execute.

options

options
Option Type Description
readPreference MongoDB\Driver\ReadPreference

A read preference to use for selecting a server for the operation.

session MongoDB\Driver\Session

A session to associate with the operation.

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid query operators).

更新日志

版本 | 说明
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\ReadPreference object.

范例

Example #1 MongoDB\Driver\Manager::executeQuery() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$filter = ['x' => ['$gt' => 1]];
$options = [
    'projection' => ['_id' => 0],
    'sort' => ['x' => -1],
];

$query = new MongoDB\Driver\Query($filter, $options);
$cursor = $manager->executeQuery('db.collection', $query);

foreach ($cursor as $document) {
    var_dump($document);
}

?>

以上例程会输出：

object(stdClass)#6 (1) {
  ["x"]=>
  int(3)
}
object(stdClass)#7 (1) {
  ["x"]=>
  int(2)
}

Example #2 Limiting execution time for a query

The "maxTimeMS" MongoDB\Driver\Query option may be used to limit the execution time of a query. Note that this time limit is enforced on the server side and does not take network latency into account. See » Terminate Running Operations in the MongoDB manual for more information.

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');

$filter = ['x' => ['$gt' => 1]];
$options = [
    'maxTimeMS' => 1000,
];

$query = new MongoDB\Driver\Query($filter, $options);
$cursor = $manager->executeQuery('db.collection', $query);

foreach ($cursor as $document) {
    var_dump($document);
}

?>

If the query fails to complete after one second of execution time on the server, a MongoDB\Driver\Exception\ExecutionTimeoutException will be thrown.

参见

  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Query
  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Server::executeQuery() - Execute a database query on this server


Execute a database command that reads

  • ? MongoDB\Driver\Manager::executeQuery
  • MongoDB\Driver\Manager::executeReadWriteCommand ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database command that reads

MongoDB\Driver\Manager::executeReadCommand

(mongodb >=1.4.0)

MongoDB\Driver\Manager::executeReadCommand — Execute a database command that reads

说明

final public MongoDB\Driver\Manager::executeReadCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Selects a server according to the "readPreference" option and executes the command on that server. By default, the read preference from the MongoDB Connection URI will be used.

This method will apply logic that is specific to commands that read (e.g. » count) and take the MongoDB server version into account. The "readConcern" option will default to the corresponding value from the MongoDB Connection URI.

参数

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The command to execute.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

readPreference MongoDB\Driver\ReadPreference

A read preference to use for selecting a server for the operation.

session MongoDB\Driver\Session

A session to associate with the operation.

Warning

If you are using a "session" which has a transaction in progress, you cannot specify a "readConcern" or "writeConcern" option. This will result in an MongoDB\Driver\Exception\InvalidArgumentException being thrown. Instead, you should set these two options when you create the transaction with MongoDB\Driver\Session::startTransaction().

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used with an associated transaction in combination with a "readConcern" or "writeConcern" option.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

参见

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeReadWriteCommand() - Execute a database command that reads and writes
  • MongoDB\Driver\Manager::executeWriteCommand() - Execute a database command that writes
  • MongoDB\Driver\Server::executeReadCommand() - Execute a database command that reads on this server


Execute a database command that reads and writes

  • ? MongoDB\Driver\Manager::executeReadCommand
  • MongoDB\Driver\Manager::executeWriteCommand ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database command that reads and writes

MongoDB\Driver\Manager::executeReadWriteCommand

(mongodb >=1.4.0)

MongoDB\Driver\Manager::executeReadWriteCommand — Execute a database command that reads and writes

说明

final public MongoDB\Driver\Manager::executeReadWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on the primary server.

This method will apply logic that is specific to commands that read and write (e.g. » aggregate) and take the MongoDB server version into account. The "readConcern" and "writeConcern" options will default to the corresponding values from the MongoDB Connection URI.

参数

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The command to execute.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

session MongoDB\Driver\Session

A session to associate with the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

Warning

If you are using a "session" which has a transaction in progress, you cannot specify a "readConcern" or "writeConcern" option. This will result in an MongoDB\Driver\Exception\InvalidArgumentException being thrown. Instead, you should set these two options when you create the transaction with MongoDB\Driver\Session::startTransaction().

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used with an associated transaction in combination with a "readConcern" or "writeConcern" option.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used in combination with an unacknowledged write concern.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

更新日志

版本 | 说明
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.

参见

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeReadCommand() - Execute a database command that reads
  • MongoDB\Driver\Manager::executeWriteCommand() - Execute a database command that writes
  • MongoDB\Driver\Server::executeReadWriteCommand() - Execute a database command that reads and writes on this server


Execute a database command that writes

  • ? MongoDB\Driver\Manager::executeReadWriteCommand
  • MongoDB\Driver\Manager::getReadConcern ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Execute a database command that writes

MongoDB\Driver\Manager::executeWriteCommand

(mongodb >=1.4.0)

MongoDB\Driver\Manager::executeWriteCommand — Execute a database command that writes

说明

final public MongoDB\Driver\Manager::executeWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on the primary server.

This method will apply logic that is specific to commands that write (e.g. » drop) and take the MongoDB server version into account. The "writeConcern" option will default to the corresponding value from the MongoDB Connection URI.

Note: This method is not intended to be used to execute » insert, » update, or » delete commands. Users are encouraged to use MongoDB\Driver\Manager::executeBulkWrite() for those commands.

参数

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The command to execute.

options

options
Option Type Description
session MongoDB\Driver\Session

A session to associate with the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

Warning

If you are using a "session" which has a transaction in progress, you cannot specify a "readConcern" or "writeConcern" option. This will result in an MongoDB\Driver\Exception\InvalidArgumentException being thrown. Instead, you should set these two options when you create the transaction with MongoDB\Driver\Session::startTransaction().

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used with an associated transaction in combination with a "readConcern" or "writeConcern" option.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used in combination with an unacknowledged write concern.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

更新日志

版本 | 说明
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.

参见

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeReadCommand() - Execute a database command that reads
  • MongoDB\Driver\Manager::executeReadWriteCommand() - Execute a database command that reads and writes
  • MongoDB\Driver\Server::executeWriteCommand() - Execute a database command that writes on this server


Return the ReadConcern for the Manager

  • ? MongoDB\Driver\Manager::executeWriteCommand
  • MongoDB\Driver\Manager::getReadPreference ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Return the ReadConcern for the Manager

MongoDB\Driver\Manager::getReadConcern

(mongodb >=1.1.0)

MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager

说明

final public MongoDB\Driver\Manager::getReadConcern ( ) : MongoDB\Driver\ReadConcern

Returns the MongoDB\Driver\ReadConcern for the Manager, which is derived from its URI options. This is the default read concern for queries and commands executed on the Manager.

参数

此函数没有参数。

返回值

The MongoDB\Driver\ReadConcern for the Manager.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Manager::getReadConcern() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getReadConcern());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?readConcernLevel=local');
var_dump($manager->getReadConcern());

?>

以上例程的输出类似于：

object(MongoDB\Driver\ReadConcern)#2 (0) {
}
object(MongoDB\Driver\ReadConcern)#1 (1) {
  ["level"]=>
  string(5) "local"
}

参见

  • MongoDB\Driver\ReadConcern
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager


Return the ReadPreference for the Manager

  • ? MongoDB\Driver\Manager::getReadConcern
  • MongoDB\Driver\Manager::getServers ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Return the ReadPreference for the Manager

MongoDB\Driver\Manager::getReadPreference

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager

说明

final public MongoDB\Driver\Manager::getReadPreference ( ) : MongoDB\Driver\ReadPreference

Returns the MongoDB\Driver\ReadPreference for the Manager, which is derived from its URI options. This is the default read preference for queries and commands executed on the Manager.

参数

此函数没有参数。

返回值

The MongoDB\Driver\ReadPreference for the Manager.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Manager::getReadPreference() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getReadPreference());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?readPreference=secondaryPreferred&readPreferenceTags=dc:ny,rack:1&readPreferenceTags=dc:ny&readPreferenceTags=');
var_dump($manager->getReadPreference());

?>

以上例程的输出类似于：

object(MongoDB\Driver\ReadPreference)#2 (1) {
  ["mode"]=>
  string(7) "primary"
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(18) "secondaryPreferred"
  ["tags"]=>
  array(3) {
    [0]=>
    object(stdClass)#3 (2) {
      ["dc"]=>
      string(2) "ny"
      ["rack"]=>
      string(1) "1"
    }
    [1]=>
    object(stdClass)#4 (1) {
      ["dc"]=>
      string(2) "ny"
    }
    [2]=>
    object(stdClass)#5 (0) {
    }
  }
}

参见

  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager


Return the servers to which this manager is connected

  • ? MongoDB\Driver\Manager::getReadPreference
  • MongoDB\Driver\Manager::getWriteConcern ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Return the servers to which this manager is connected

MongoDB\Driver\Manager::getServers

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected

说明

final public MongoDB\Driver\Manager::getServers ( ) : array

Returns an array of MongoDB\Driver\Server instances to which this manager is connected.

Note: Since the driver connects to the database lazily, this method may return an empty array if called before executing an operation on the MongoDB\Driver\Manager.

参数

此函数没有参数。

返回值

Returns an array of MongoDB\Driver\Server instances to which this manager is connected.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Manager::getServers() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

/* The driver connects to the database server lazily, so Manager::getServers()
 * may initially return an empty array. */
var_dump($manager->getServers());

$command = new MongoDB\Driver\Command(['ping' => 1]);
$manager->executeCommand('db', $command);

var_dump($manager->getServers());

?>

以上例程的输出类似于：

array(0) {
}
array(1) {
  [0]=>
  object(MongoDB\Driver\Server)#3 (10) {
    ["host"]=>
    string(9) "localhost"
    ["port"]=>
    int(27017)
    ["type"]=>
    int(1)
    ["is_primary"]=>
    bool(false)
    ["is_secondary"]=>
    bool(false)
    ["is_arbiter"]=>
    bool(false)
    ["is_hidden"]=>
    bool(false)
    ["is_passive"]=>
    bool(false)
    ["last_is_master"]=>
    array(8) {
      ["ismaster"]=>
      bool(true)
      ["maxBsonObjectSize"]=>
      int(16777216)
      ["maxMessageSizeBytes"]=>
      int(48000000)
      ["maxWriteBatchSize"]=>
      int(1000)
      ["localTime"]=>
      object(MongoDB\BSON\UTCDateTime)#4 (1) {
        ["milliseconds"]=>
        int(1447267964517)
      }
      ["maxWireVersion"]=>
      int(3)
      ["minWireVersion"]=>
      int(0)
      ["ok"]=>
      float(1)
    }
    ["round_trip_time"]=>
    int(554)
  }
}

参见

  • MongoDB\Driver\Server
  • MongoDB\Driver\Manager::selectServer() - Select a server matching a read preference


Return the WriteConcern for the Manager

  • ? MongoDB\Driver\Manager::getServers
  • MongoDB\Driver\Manager::selectServer ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Return the WriteConcern for the Manager

MongoDB\Driver\Manager::getWriteConcern

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager

说明

final public MongoDB\Driver\Manager::getWriteConcern ( ) : MongoDB\Driver\WriteConcern

Returns the MongoDB\Driver\WriteConcern for the Manager, which is derived from its URI options. This is the default write concern for writes and commands executed on the Manager.

参数

此函数没有参数。

返回值

The MongoDB\Driver\WriteConcern for the Manager.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Manager::getWriteConcern() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getWriteConcern());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?w=majority&wtimeoutMS=2000');
var_dump($manager->getWriteConcern());

?>

以上例程的输出类似于：

object(MongoDB\Driver\WriteConcern)#2 (0) {
}
object(MongoDB\Driver\WriteConcern)#1 (2) {
  ["w"]=>
  string(8) "majority"
  ["wtimeout"]=>
  int(2000)
}

参见

  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager


Select a server matching a read preference

  • ? MongoDB\Driver\Manager::getWriteConcern
  • MongoDB\Driver\Manager::startSession ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Select a server matching a read preference

MongoDB\Driver\Manager::selectServer

(mongodb >=1.0.0)

MongoDB\Driver\Manager::selectServer — Select a server matching a read preference

说明

final public MongoDB\Driver\Manager::selectServer ( MongoDB\Driver\ReadPreference $readPreference ) : MongoDB\Driver\Server

Selects a MongoDB\Driver\Server matching readPreference. This may be used to preselect a server in order to perform version checking before executing an operation.

Note: Unlike MongoDB\Driver\Manager::getServers(), this method will initialize database connections and perform server discovery if necessary. See the » Server Selection Specification for additional information.

参数

readPreference (MongoDB\Driver\ReadPreference)

The read preference to use for selecting a server.

返回值

Returns a MongoDB\Driver\Server matching the read preference.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException if a server matching the read preference could not be found.

参见

  • MongoDB\Driver\Server
  • MongoDB\Driver\Manager::getServers() - Return the servers to which this manager is connected
  • » Server Selection Specification


Start a new client session for use with this client

  • ? MongoDB\Driver\Manager::selectServer
  • MongoDB\Driver\Command ?
  • PHP Manual
  • MongoDB\Driver\Manager
  • Start a new client session for use with this client

MongoDB\Driver\Manager::startSession

(mongodb >=1.4.0)

MongoDB\Driver\Manager::startSession — Start a new client session for use with this client

说明

final public MongoDB\Driver\Manager::startSession ( array $options = ? ) : MongoDB\Driver\Session

Creates a MongoDB\Driver\Session for the given options. The session may then be specified when executing commands, queries, and write operations.

Note: A MongoDB\Driver\Session can only be used with the MongoDB\Driver\Manager from which it was created.

参数

options

options
Option Type Description Default
causalConsistency bool

Configure causal consistency in a session. If true, each operation in the session will be causally ordered after the previous read or write operation. Set to false to disable causal consistency.

See » Casual Consistency in the MongoDB manual for more information.

true
defaultTransactionOptions array

Default options to apply to newly created transactions. These options are used unless they are overridden when a transaction is started with different value for each option.

options
Option Type Description
maxCommitTimeMS integer

The maximum amount of time in milliseconds to allow a single commitTransaction command to run.

If specified, maxCommitTimeMS must be a signed 32-bit integer greater than or equal to zero.

readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

readPreference MongoDB\Driver\ReadPreference

A read preference to use for selecting a server for the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

This option is available in MongoDB 4.0+.

[]

返回值

Returns a MongoDB\Driver\Session.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\RuntimeException if the session could not be created (e.g. libmongoc does not support crypto).

更新日志

版本 | 说明
PECL mongodb 1.6.0 | The "maxCommitTimeMS" option was added to "defaultTransactionOptions".
PECL mongodb 1.5.0 | The "defaultTransactionOptions" option was added.

参见

  • MongoDB\Driver\Session
  • » Casual Consistency in the MongoDB manual


The MongoDB\Driver\Command class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\Command class is a value object that represents a database command.

To provide Command Helpers the MongoDB\Driver\Command object should be composed.

类摘要

final MongoDB\Driver\Command {
/* 方法 */
final public __construct ( array|object $document , array $commandOptions = ? )
}

范例

Example #1 Composing MongoDB\Driver\Command to provide a helper to create collections

<?php
class CreateCollection {
    protected $cmd = array();

    function __construct($collectionName) {
        $this->cmd["create"] = (string)$collectionName;
    }
    function setCappedCollection($maxBytes, $maxDocuments = false) {
        $this->cmd["capped"] = true;
        $this->cmd["size"]   = (int)$maxBytes;

        if ($maxDocuments) {
            $this->cmd["max"] = (int)$maxDocuments;
        }
    }
    function usePowerOf2Sizes($bool) {
        if ($bool) {
            $this->cmd["flags"] = 1;
        } else {
            $this->cmd["flags"] = 0;
        }
    }
    function setFlags($flags) {
        $this->cmd["flags"] = (int)$flags;
    }
    function getCommand() {
        return new MongoDB\Driver\Command($this->cmd);
    }
    function getCollectionName() {
        return $this->cmd["create"];
    }
}

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$createCollection = new CreateCollection("cappedCollection");
$createCollection->setCappedCollection(64 * 1024);

try {
    $command = $createCollection->getCommand();
    $cursor = $manager->executeCommand("databaseName", $command);
    $response = $cursor->toArray()[0];
    var_dump($response);

    $collstats = ["collstats" => $createCollection->getCollectionName()];
    $cursor = $manager->executeCommand("databaseName", new MongoDB\Driver\Command($collstats));
    $response = $cursor->toArray()[0];
    var_dump($response);
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}

?>

以上例程会输出：

object(MongoDB\Driver\Command)#3 (1) {
  ["command"]=>
  array(3) {
    ["create"]=>
    string(16) "cappedCollection"
    ["capped"]=>
    bool(true)
    ["size"]=>
    int(65536)
  }
}
array(1) {
  ["ok"]=>
  float(1)
}
array(16) {
  ["ns"]=>
  string(29) "databaseName.cappedCollection"
  ["count"]=>
  int(0)
  ["size"]=>
  int(0)
  ["numExtents"]=>
  int(1)
  ["storageSize"]=>
  int(65536)
  ["nindexes"]=>
  int(1)
  ["lastExtentSize"]=>
  float(65536)
  ["paddingFactor"]=>
  float(1)
  ["paddingFactorNote"]=>
  string(101) "paddingFactor is unused and unmaintained in 2.8. It remains hard coded to 1.0 for compatibility only."
  ["userFlags"]=>
  int(0)
  ["capped"]=>
  bool(true)
  ["max"]=>
  int(9223372036854775807)
  ["maxSize"]=>
  int(65536)
  ["totalIndexSize"]=>
  int(8176)
  ["indexSizes"]=>
  object(stdClass)#4 (1) {
    ["_id_"]=>
    int(8176)
  }
  ["ok"]=>
  float(1)
}

Table of Contents

  • MongoDB\Driver\Command::__construct — Create a new Command


Create a new Command

  • ? MongoDB\Driver\Command
  • MongoDB\Driver\Query ?
  • PHP Manual
  • MongoDB\Driver\Command
  • Create a new Command

MongoDB\Driver\Command::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Command::__construct — Create a new Command

说明

final public MongoDB\Driver\Command::__construct ( array|object $document , array $commandOptions = ? )

Constructs a new MongoDB\Driver\Command, which is an immutable value object that represents a database command. The command may then be executed with MongoDB\Driver\Manager::executeCommand().

The complete command document, which includes the command name and its options, should be expressed in the document parameter. The commandOptions parameter is only used to specify options related to the execution of the command and the resulting MongoDB\Driver\Cursor.

参数

document

The complete command document, which will be sent to the server.

commandOptions

Note: Do not use this parameter to specify options described in the command's reference in the MongoDB manual. This parameter should only be used for the options explicitly listed below.

commandOptions
Option Type Description
maxAwaitTimeMS int

Positive integer denoting the time limit in milliseconds for the server to block a getMore operation if no data is available. This option should only be used in conjunction with commands that return a tailable cursor (e.g. » Change Streams).

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.4.0 | Added a second commandOptions argument, which supports the "maxAwaitTimeMS" option.

范例

Example #1 MongoDB\Driver\Command::__construct() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$command = new MongoDB\Driver\Command(array("buildinfo" => 1));

try {
    $cursor = $manager->executeCommand("admin", $command);
    $response = $cursor->toArray()[0];
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}
var_dump($response);

?>

以上例程的输出类似于：

array(13) {
  ["version"]=>
  string(14) "2.8.0-rc2-pre-"
  ["gitVersion"]=>
  string(62) "b743d7158f7642f4da6b7eac8320374b3b88dc2e modules: subscription"
  ["OpenSSLVersion"]=>
  string(25) "OpenSSL 1.0.1f 6 Jan 2014"
  ["sysInfo"]=>
  string(104) "Linux infant 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 BOOST_LIB_VERSION=1_49"
  ["loaderFlags"]=>
  string(91) "-fPIC -pthread -Wl,-z,now -rdynamic -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -Wl,-E"
  ["compilerFlags"]=>
  string(301) "-Wnon-virtual-dtor -Woverloaded-virtual -std=c++11 -fPIC -fno-strict-aliasing -ggdb -pthread -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -pipe -Werror -O3 -Wno-unused-local-typedefs -Wno-unused-function -Wno-deprecated-declarations -Wno-unused-but-set-variable -fno-builtin-memcmp -std=c99"
  ["allocator"]=>
  string(8) "tcmalloc"
  ["versionArray"]=>
  array(4) {
    [0]=>
    int(2)
    [1]=>
    int(8)
    [2]=>
    int(0)
    [3]=>
    int(-8)
  }
  ["javascriptEngine"]=>
  string(2) "V8"
  ["bits"]=>
  int(64)
  ["debug"]=>
  bool(false)
  ["maxBsonObjectSize"]=>
  int(16777216)
  ["ok"]=>
  float(1)
}

Example #2 MongoDB\Driver\Command::__construct() example

Commands can accept options as well, as part of the normal structure that you create to send to the server. For example, the maxTimeMS option can be passed with most commands to restrict the amount of time a specific command can run for on the server.

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$command = new MongoDB\Driver\Command(
    array(
        "distinct" => "beer",
        "key" => "beer_name",
        "maxTimeMS" => 10,
    )
);

try {
    $cursor = $manager->executeCommand("beerdb", $command);
    $response = $cursor->toArray()[0];
} catch(MongoDB\Driver\Exception\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}
var_dump($response);

?>

以上例程的输出类似于：

operation exceeded time limit

参见

  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Cursor


The MongoDB\Driver\Query class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\Query class is a value object that represents a database query.

类摘要

final MongoDB\Driver\Query {
/* 方法 */
final public __construct ( array|object $filter , array $queryOptions = ? )
}

Table of Contents

  • MongoDB\Driver\Query::__construct — Create a new Query


Create a new Query

  • ? MongoDB\Driver\Query
  • MongoDB\Driver\BulkWrite ?
  • PHP Manual
  • MongoDB\Driver\Query
  • Create a new Query

MongoDB\Driver\Query::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Query::__construct — Create a new Query

说明

final public MongoDB\Driver\Query::__construct ( array|object $filter , array $queryOptions = ? )

Constructs a new MongoDB\Driver\Query, which is an immutable value object that represents a database query. The query may then be executed with MongoDB\Driver\Manager::executeQuery().

参数

filter (array|object)

The » query predicate. An empty predicate will match all documents in the collection.

Note: When evaluating query criteria, MongoDB compares types and values according to its own » comparison rules for BSON types, which differs from PHP's comparison and type juggling rules. When matching a special BSON type the query criteria should use the respective BSON class (e.g. use MongoDB\BSON\ObjectId to match an » ObjectId).

queryOptions

queryOptions
Option | Type | Description
allowDiskUse bool

Allows MongoDB to use temporary disk files to store data exceeding the 100 megabyte system memory limit while processing a blocking sort operation.

allowPartialResults bool

For queries against a sharded collection, returns partial results from the mongos if some shards are unavailable instead of throwing an error.

Falls back to the deprecated "partial" option if not specified.

awaitData | bool | Use in conjunction with the "tailable" option to block a getMore operation on the cursor temporarily if at the end of data rather than returning no data. After a timeout period, the query returns as normal.
batchSize int

The number of documents to return in the first batch. Defaults to 101. A batch size of 0 means that the cursor will be established, but no documents will be returned in the first batch.

In versions of MongoDB before 3.2, where queries use the legacy wire protocol OP_QUERY, a batch size of 1 will close the cursor irrespective of the number of matched documents.

collation array|object

» Collation allows users to specify language-specific rules for string comparison, such as rules for lettercase and accent marks. When specifying collation, the "locale" field is mandatory; all other collation fields are optional. For descriptions of the fields, see » Collation Document.

If the collation is unspecified but the collection has a default collation, the operation uses the collation specified for the collection. If no collation is specified for the collection or for the operation, MongoDB uses the simple binary comparison used in prior versions for string comparisons.

This option is available in MongoDB 3.4+ and will result in an exception at execution time if specified for an older server version.

comment string

A comment to attach to the query to help interpret and trace query profile data.

Falls back to the deprecated "$comment" modifier if not specified.

exhaust bool

Stream the data down full blast in multiple "more" packages, on the assumption that the client will fully read all data queried. Faster when you are pulling a lot of data and know you want to pull it all down. Note: the client is not allowed to not read all the data unless it closes the connection.

This option is not supported by the find command in MongoDB 3.2+ and will force the driver to use the legacy wire protocol version (i.e. OP_QUERY).

explain bool

If true, the returned MongoDB\Driver\Cursor will contain a single document that describes the process and indexes used to return the query.

Falls back to the deprecated "$explain" modifier if not specified.

This option is not supported by the find command in MongoDB 3.2+ and will only be respected when using the legacy wire protocol version (i.e. OP_QUERY). The » explain command should be used on MongoDB 3.0+.

hint string|array|object

Index specification. Specify either the index name as a string or the index key pattern. If specified, then the query system will only consider plans using the hinted index.

Falls back to the deprecated "hint" option if not specified.

limit int

The maximum number of documents to return. If unspecified, then defaults to no limit. A limit of 0 is equivalent to setting no limit.

A negative limit is will be interpreted as a positive limit with the "singleBatch" option set to true. This behavior is supported for backwards compatibility, but should be considered deprecated.

max array|object

The exclusive upper bound for a specific index.

Falls back to the deprecated "$max" modifier if not specified.

maxAwaitTimeMS int

Positive integer denoting the time limit in milliseconds for the server to block a getMore operation if no data is available. This option should only be used in conjunction with the "tailable" and "awaitData" options.

maxScan int
Warning

This option is deprecated and should not be used.

Positive integer denoting the maximum number of documents or index keys to scan when executing the query.

Falls back to the deprecated "$maxScan" modifier if not specified.

maxTimeMS int

The cumulative time limit in milliseconds for processing operations on the cursor. MongoDB aborts the operation at the earliest following interrupt point.

Falls back to the deprecated "$maxTimeMS" modifier if not specified.

min array|object

The inclusive lower bound for a specific index.

Falls back to the deprecated "$min" modifier if not specified.

modifiers | array | » Meta operators modifying the output or behavior of a query. Use of these operators is deprecated in favor of named options.
noCursorTimeout | bool | Prevents the server from timing out idle cursors after an inactivity period (10 minutes).
oplogReplay bool

Internal use for replica sets. To use oplogReplay, you must include the following condition in the filter:

[ 'ts' => [ '$gte' => <timestamp> ] ]

Note: This option is deprecated as of the 1.8.0 release.
projection array|object

The » projection specification to determine which fields to include in the returned documents.

If you are using the ODM functionality to deserialise documents as their original PHP class, make sure that you include the __pclass field in the projection. This is required for the deserialization to work and without it, the driver will return (by default) a stdClass object instead.

readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation. By default, the read concern from the MongoDB Connection URI will be used.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

returnKey bool

If true, returns only the index keys in the resulting documents. Default value is false. If true and the find command does not use an index, the returned documents will be empty.

Falls back to the deprecated "$returnKey" modifier if not specified.

showRecordId bool

Determines whether to return the record identifier for each document. If true, adds a top-level "$recordId" field to the returned documents.

Falls back to the deprecated "$showDiskLoc" modifier if not specified.

singleBatch | bool | Determines whether to close the cursor after the first batch. Defaults to false.
skip | int | Number of documents to skip. Defaults to 0.
slaveOk | bool | Allow query of replica set secondaries
snapshot bool
Warning

This option is deprecated and should not be used.

Prevents the cursor from returning a document more than once because of an intervening write operation.

Falls back to the deprecated "$snapshot" modifier if not specified.

sort array|object

The sort specification for the ordering of the results.

Falls back to the deprecated "$orderby" modifier if not specified.

tailable | bool | Returns a tailable cursor for a capped collection.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.8.0

Added the "allowDiskUse" option.

The "oplogReplay" option is deprecated.

PECL mongodb 1.5.0

The "maxScan" and "snapshot" options are deprecated.

PECL mongodb 1.3.0

Added the "maxAwaitTimeMS" option.

PECL mongodb 1.2.0

Added the "allowPartialResults", "collation", "comment", "hint", "max", "maxScan", "maxTimeMS", "min", "returnKey", "showRecordId", and "snapshot" options.

Renamed the "partial" option to "allowPartialResults". For backwards compatibility, "partial" will still be read if "allowPartialResults" is not specified.

Removed the "slaveOk" option, which is obsolete. For queries using the legacy wire protocol OP_QUERY, the driver will set the slaveOk bit as needed in accordance with the » Server Selection Specification.

PECL mongodb 1.1.0 | Added the "readConcern" option.

范例

Example #1 MongoDB\Driver\Query::__construct() example

<?php
/* Select only documents authord by "bjori" with at least 100 views */
$filter = [
    'author' => 'bjori',
    'views' => [
        '$gte' => 100,
    ],
];

$options = [
    /* Only return the following fields in the matching documents */
    'projection' => [
        'title' => 1,
        'article' => 1,
    ],
    /* Return the documents in descending order of views */
    'sort' => [
        'views' => -1
    ],
];

$query = new MongoDB\Driver\Query($filter, $options);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$readPreference = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$cursor = $manager->executeQuery('databaseName.collectionName', $query, $readPreference);

foreach($cursor as $document) {
    var_dump($document);
}

?>

参见

  • MongoDB\Driver\Manager::executeQuery() - Execute a database query
  • MongoDB\Driver\Cursor


The MongoDB\Driver\BulkWrite class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\BulkWrite collects one or more write operations that should be sent to the server. After adding any number of insert, update, and delete operations, the collection may be executed via MongoDB\Driver\Manager::executeBulkWrite().

Write operations may either be ordered (default) or unordered. Ordered write operations are sent to the server, in the order provided, for serial execution. If a write fails, any remaining operations will be aborted. Unordered operations are sent to the server in an arbitrary order where they may be executed in parallel. Any errors that occur are reported after all operations have been attempted.

类摘要

final MongoDB\Driver\BulkWrite implements Countable {
/* 方法 */
public __construct ( array $options = ? )
public count ( ) : int
public delete ( array|object $filter , array $deleteOptions = ? ) : void
public insert ( array|object $document ) : mixed
public update ( array|object $filter , array|object $newObj , array $updateOptions = ? ) : void
}

范例

Example #1 Mixed write operations are grouped by type

Mixed write operations (i.e. inserts, updates, and deletes) will be assembled into typed write commands to be sent sequentially to the server.

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(['x' => 2], ['$set' => ['x' => 1]]);
$bulk->insert(['_id' => 3, 'x' => 3]);
$bulk->delete(['x' => 1]);

?>

Will result in four write commands (i.e. roundtrips) being executed. Since the operations are ordered, the third insertion cannot be sent until the preceding update is executed.

Example #2 Ordered write operations causing an error

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->delete([]);
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3, 'hello' => 'world']);
$bulk->update(['_id' => 3], ['$set' => ['hello' => 'earth']]);
$bulk->insert(['_id' => 4, 'hello' => 'pluto']);
$bulk->update(['_id' => 4], ['$set' => ['hello' => 'moon']]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 5]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 1000);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    $result = $e->getWriteResult();

    // Check if the write concern could not be fulfilled
    if ($writeConcernError = $result->getWriteConcernError()) {
        printf("%s (%d): %s\n",
            $writeConcernError->getMessage(),
            $writeConcernError->getCode(),
            var_export($writeConcernError->getInfo(), true)
        );
    }

    // Check if any write operations did not complete at all
    foreach ($result->getWriteErrors() as $writeError) {
        printf("Operation#%d: %s (%d)\n",
            $writeError->getIndex(),
            $writeError->getMessage(),
            $writeError->getCode()
        );
    }
} catch (MongoDB\Driver\Exception\Exception $e) {
    printf("Other error: %s\n", $e->getMessage());
    exit;
}

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());

?>

以上例程会输出：

Operation#7: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 3 } (11000)
Inserted 4 document(s)
Updated  2 document(s)

If the write concern could not be fullfilled, the example above would output something like:

waiting for replication timed out (64): array (
  'wtimeout' => true,
)
Operation#7: E11000 duplicate key error index: databaseName.collectionName.$_id_ dup key: { : 3 } (11000)
Inserted 4 document(s)
Updated  2 document(s)

If we execute the example above, but allow for unordered writes:

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => false]);
/* ... */

?>

以上例程会输出：

Operation#7: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 3 } (11000)
Operation#8: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 4 } (11000)
Inserted 5 document(s)
Updated  2 document(s)

参见

  • MongoDB\Driver\Manager::executeBulkWrite()
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\WriteConcernError
  • MongoDB\Driver\WriteError

Table of Contents

  • MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite
  • MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk
  • MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk
  • MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk
  • MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk


Create a new BulkWrite

  • ? MongoDB\Driver\BulkWrite
  • MongoDB\Driver\BulkWrite::count ?
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Create a new BulkWrite

MongoDB\Driver\BulkWrite::__construct

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite

说明

public MongoDB\Driver\BulkWrite::__construct ( array $options = ? )

Constructs a new MongoDB\Driver\BulkWrite, which is a mutable object to which one or more write operations may be added. The write(s) may then be executed with MongoDB\Driver\Manager::executeBulkWrite().

参数

options (array)

options
Option | Type | Description | Default
bypassDocumentValidation bool

If true, allows insert and update operations to circumvent document level validation.

This option is available in MongoDB 3.2+ and is ignored for older server versions, which do not support document level validation.

false
ordered | bool | Ordered operations (true) are executed serially on the MongoDB server, while unordered operations (false) are sent to the server in an arbitrary order and may be executed in parallel. | true

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.1.0 | Added the "bypassDocumentValidation" option.

范例

Example #1 MongoDB\Driver\BulkWrite::__construct() example

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->delete([]);
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(
    ['x' => 2],
    ['$set' => ['x' => 1]],
    ['limit' => 1, 'upsert' => false]
);
$bulk->delete(['x' => 1], ['limit' => 1]);
$bulk->update(
    ['_id' => 3],
    ['$set' => ['x' => 3]],
    ['limit' => 1, 'upsert' => true]
);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(1);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    $result = $e->getWriteResult();

    // Check if the write concern could not be fulfilled
    if ($writeConcernError = $result->getWriteConcernError()) {
        printf("%s (%d): %s\n",
            $writeConcernError->getMessage(),
            $writeConcernError->getCode(),
            var_export($writeConcernError->getInfo(), true)
        );
    }

    // Check if any write operations did not complete at all
    foreach ($result->getWriteErrors() as $writeError) {
        printf("Operation#%d: %s (%d)\n",
            $writeError->getIndex(),
            $writeError->getMessage(),
            $writeError->getCode()
        );
    }
} catch (MongoDB\Driver\Exception\Exception $e) {
    printf("Other error: %s\n", $e->getMessage());
    exit;
}

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());
printf("Upserted %d document(s)\n", $result->getUpsertedCount());
printf("Deleted  %d document(s)\n", $result->getDeletedCount());

?>

以上例程会输出：

Inserted 2 document(s)
Updated  1 document(s)
Upserted 1 document(s)
Deleted  1 document(s)

参见

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult


Count number of write operations in the bulk

  • ? MongoDB\Driver\BulkWrite::__construct
  • MongoDB\Driver\BulkWrite::delete ?
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Count number of write operations in the bulk

MongoDB\Driver\BulkWrite::count

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk

说明

public MongoDB\Driver\BulkWrite::count ( ) : int

Returns the number of write operations added to the MongoDB\Driver\BulkWrite object.

参数

此函数没有参数。

返回值

Returns number of write operations added to the MongoDB\Driver\BulkWrite object.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.2.0 | Returns the number of write operations added to the MongoDB\Driver\BulkWrite object. Earlier versions returned the expected number of client-to-server roundtrips required to execute all write operations.

范例

Example #1 MongoDB\Driver\BulkWrite::count() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(['x' => 2], ['$set' => ['x' => 1]]);
$bulk->delete(['x' => 1]);

var_dump(count($bulk));

?>

以上例程会输出：

int(4)


Add a delete operation to the bulk

  • ? MongoDB\Driver\BulkWrite::count
  • MongoDB\Driver\BulkWrite::insert ?
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Add a delete operation to the bulk

MongoDB\Driver\BulkWrite::delete

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk

说明

public MongoDB\Driver\BulkWrite::delete ( array|object $filter , array $deleteOptions = ? ) : void

Adds a delete operation to the MongoDB\Driver\BulkWrite.

参数

filter (array|object)

The » query predicate. An empty predicate will match all documents in the collection.

Note: When evaluating query criteria, MongoDB compares types and values according to its own » comparison rules for BSON types, which differs from PHP's comparison and type juggling rules. When matching a special BSON type the query criteria should use the respective BSON class (e.g. use MongoDB\BSON\ObjectId to match an » ObjectId).

deleteOptions

deleteOptions
Option | Type | Description | Default
collation array|object

» Collation allows users to specify language-specific rules for string comparison, such as rules for lettercase and accent marks. When specifying collation, the "locale" field is mandatory; all other collation fields are optional. For descriptions of the fields, see » Collation Document.

If the collation is unspecified but the collection has a default collation, the operation uses the collation specified for the collection. If no collation is specified for the collection or for the operation, MongoDB uses the simple binary comparison used in prior versions for string comparisons.

This option is available in MongoDB 3.4+ and will result in an exception at execution time if specified for an older server version.

hint string|array|object

Index specification. Specify either the index name as a string or the index key pattern. If specified, then the query system will only consider plans using the hinted index.

This option is available in MongoDB 4.4+ and will result in an exception at execution time if specified for an older server version.

limit | bool | Delete all matching documents (false), or only the first matching document (true) | false

返回值

没有返回值。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.8.0 | Added the "hint" option.
PECL mongodb 1.2.0 | Added the "collation" option.

范例

Example #1 MongoDB\Driver\BulkWrite::delete() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->delete(['x' => 1], ['limit' => 1]);
$bulk->delete(['x' => 2], ['limit' => 0]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$result = $manager->executeBulkWrite('db.collection', $bulk);

?>

参见

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult


Add an insert operation to the bulk

  • ? MongoDB\Driver\BulkWrite::delete
  • MongoDB\Driver\BulkWrite::update ?
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Add an insert operation to the bulk

MongoDB\Driver\BulkWrite::insert

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk

说明

public MongoDB\Driver\BulkWrite::insert ( array|object $document ) : mixed

Adds an insert operation to the MongoDB\Driver\BulkWrite.

参数

document (array|object)

A document to insert.

返回值

Returns the _id of the inserted document. If the document did not have an _id, the MongoDB\BSON\ObjectId generated for the insert will be returned.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.3.0 | The _id of the inserted document is always returned. Previously, the method only returned a value if a MongoDB\BSON\ObjectId was generated.

范例

Example #1 MongoDB\Driver\BulkWrite::insert() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;

$document1 = ['title' => 'one'];
$document2 = ['_id' => 'custom ID', 'title' => 'two'];
$document3 = ['_id' => new MongoDB\BSON\ObjectId, 'title' => 'three'];

$_id1 = $bulk->insert($document1);
$_id2 = $bulk->insert($document2);
$_id3 = $bulk->insert($document3);

var_dump($_id1, $_id2, $_id3);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$result = $manager->executeBulkWrite('db.collection', $bulk);

?>

以上例程的输出类似于：

object(MongoDB\BSON\ObjectId)#3 (1) {
  ["oid"]=>
  string(24) "54d51146bd21b91405401d92"
}
NULL
NULL

参见

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult
  • MongoDB\BSON\ObjectId
  • MongoDB\BSON\Persistable


Add an update operation to the bulk

  • ? MongoDB\Driver\BulkWrite::insert
  • MongoDB\Driver\WriteConcern ?
  • PHP Manual
  • MongoDB\Driver\BulkWrite
  • Add an update operation to the bulk

MongoDB\Driver\BulkWrite::update

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk

说明

public MongoDB\Driver\BulkWrite::update ( array|object $filter , array|object $newObj , array $updateOptions = ? ) : void

Adds an update operation to the MongoDB\Driver\BulkWrite.

参数

filter (array|object)

The » query predicate. An empty predicate will match all documents in the collection.

Note: When evaluating query criteria, MongoDB compares types and values according to its own » comparison rules for BSON types, which differs from PHP's comparison and type juggling rules. When matching a special BSON type the query criteria should use the respective BSON class (e.g. use MongoDB\BSON\ObjectId to match an » ObjectId).

newObj (array|object)

A document containing either update operators (e.g. $set), a replacement document (i.e. only field:value expressions), or an » aggregation pipeline.

updateOptions

updateOptions
Option | Type | Description | Default
arrayFilters array

An array of filter documents that determines which array elements to modify for an update operation on an array field. See » Specify arrayFilters for Array Update Operations in the MongoDB manual for more information.

This option is available in MongoDB 3.6+ and will result in an exception at execution time if specified for an older server version.

collation array|object

» Collation allows users to specify language-specific rules for string comparison, such as rules for lettercase and accent marks. When specifying collation, the "locale" field is mandatory; all other collation fields are optional. For descriptions of the fields, see » Collation Document.

If the collation is unspecified but the collection has a default collation, the operation uses the collation specified for the collection. If no collation is specified for the collection or for the operation, MongoDB uses the simple binary comparison used in prior versions for string comparisons.

This option is available in MongoDB 3.4+ and will result in an exception at execution time if specified for an older server version.

hint string|array|object

Index specification. Specify either the index name as a string or the index key pattern. If specified, then the query system will only consider plans using the hinted index.

This option is available in MongoDB 4.2+ and will result in an exception at execution time if specified for an older server version.

multi | bool | Update only the first matching document if false, or all matching documents true. This option cannot be true if newObj is a replacement document. | false
upsert | bool | If filter does not match an existing document, insert a single document. The document will be created from newObj if it is a replacement document (i.e. no update operators); otherwise, the operators in newObj will be applied to filter to create the new document. | false

返回值

没有返回值。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.7.0 | Added the "hint" option.
PECL mongodb 1.6.0 | The newObj parameter now accepts an aggregation pipeline. This feature requires MongoDB 4.2+ and will result in an exception at execution time if specified for an older server version.
PECL mongodb 1.5.0 | Using the "arrayFilters" option will result in an exception at execution time if unsupported by the server. Previously, no exception would be thrown and the option may have been ignored.
PECL mongodb 1.4.0 | Added the "arrayFilters" option.
PECL mongodb 1.2.0 | Added the "collation" option.

范例

Example #1 MongoDB\Driver\BulkWrite::update() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->update(
    ['x' => 2],
    ['$set' => ['y' => 3]],
    ['multi' => false, 'upsert' => false]
);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$result = $manager->executeBulkWrite('db.collection', $bulk);

?>

参见

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult


The MongoDB\Driver\WriteConcern class

(mongodb >=1.0.0)

简介

MongoDB\Driver\WriteConcern describes the level of acknowledgement requested from MongoDB for write operations to a standalone mongod or to replica sets or to sharded clusters. In sharded clusters, mongos instances will pass the write concern on to the shards.

类摘要

final MongoDB\Driver\WriteConcern implements MongoDB\BSON\Serializable , Serializable {
/* Constants */
const string MAJORITY = "majority" ;
/* 方法 */
final public bsonSerialize ( ) : object
final public __construct ( string|int $w , int $wtimeout = ? , bool $journal = ? )
final public getJournal ( ) : bool|null
final public getW ( ) : string|int|null
final public getWtimeout ( ) : int|MongoDB\BSON\Int64
final public isDefault ( ) : bool
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

预定义常量

MongoDB\Driver\WriteConcern::MAJORITY

Majority of all the members in the set; arbiters, non-voting members, passive members, hidden members and delayed members are all included in the definition of majority write concern.

更新日志

版本 | 说明
PECL mongodb 1.7.0 | Implements Serializable.
PECL mongodb 1.2.0 | Implements MongoDB\BSON\Serializable.

Table of Contents

  • MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\WriteConcern::__construct — Create a new WriteConcern
  • MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option
  • MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option
  • MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option
  • MongoDB\Driver\WriteConcern::isDefault — Checks if this is the default write concern
  • MongoDB\Driver\WriteConcern::serialize — Serialize a WriteConcern
  • MongoDB\Driver\WriteConcern::unserialize — Unserialize a WriteConcern


Returns an object for BSON serialization

  • ? MongoDB\Driver\WriteConcern
  • MongoDB\Driver\WriteConcern::__construct ?
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Returns an object for BSON serialization

MongoDB\Driver\WriteConcern::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization

说明

final public MongoDB\Driver\WriteConcern::bsonSerialize ( ) : object

参数

此函数没有参数。

返回值

Returns an object for serializing the WriteConcern as BSON.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteConcern::bsonSerialize() with majority write concern

<?php

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY);
var_dump($wc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($wc));

?>

以上例程的输出类似于：

object(stdClass)#2 (1) {
  ["w"]=>
  string(8) "majority"
}

{ "w" : "majority" }

Example #2 MongoDB\Driver\WriteConcern::bsonSerialize() with wtimeout and journal

<?php

$wc = new MongoDB\Driver\WriteConcern(2, 1000, true);
var_dump($wc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($wc));

?>

以上例程的输出类似于：

object(stdClass)#2 (3) {
  ["w"]=>
  int(2)
  ["j"]=>
  bool(true)
  ["wtimeout"]=>
  int(1000)
}

{ "w" : 2, "j" : true, "wtimeout" : 1000 }

参见

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Write Concern reference


Create a new WriteConcern

  • ? MongoDB\Driver\WriteConcern::bsonSerialize
  • MongoDB\Driver\WriteConcern::getJournal ?
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Create a new WriteConcern

MongoDB\Driver\WriteConcern::__construct

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::__construct — Create a new WriteConcern

说明

final public MongoDB\Driver\WriteConcern::__construct ( string|int $w , int $wtimeout = ? , bool $journal = ? )

Constructs a new MongoDB\Driver\WriteConcern, which is an immutable value object.

参数

w

Write concern
Value | Description
1 | Requests acknowledgement that the write operation has propagated to the standalone mongod or the primary in a replica set. This is the default write concern for MongoDB.
0 | Requests no acknowledgment of the write operation. However, this may return information about socket exceptions and networking errors to the application.
<integer greater than 1> | Numbers greater than 1 are valid only for replica sets to request acknowledgement from specified number of members, including the primary.
MongoDB\Driver\WriteConcern::MAJORITY

Requests acknowledgment that write operations have propagated to the majority of voting nodes, including the primary, and have been written to the on-disk journal for these nodes.

Prior to MongoDB 3.0, this refers to the majority of replica set members (not just voting nodes).

string | A string value is interpereted as a tag set. Requests acknowledgement that the write operations have propagated to a replica set member with the specified tag.

wtimeout

How long to wait (in milliseconds) for secondaries before failing.

wtimeout causes write operations to return with an error (WriteConcernError) after the specified limit, even if the required write concern will eventually succeed. When these write operations return, MongoDB does not undo successful data modifications performed before the write concern exceeded the wtimeout time limit.

If specified, wtimeout must be a signed 64-bit integer greater than or equal to zero.

Write concern timeout
Value | Description
0 | Block indefinitely. This is the default.
<integer greater than 0> | Milliseconds to wait until returning.

journal

Wait until mongod has applied the write to the journal.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if w is invalid or wtimeout is either negative or greater than the bounds of a signed 32-bit integer.

更新日志

版本 | 说明
PECL mongodb 1.7.0 | The wTimeout parameter now accepts 64-bit values.

范例

Example #1 MongoDB\Driver\WriteConcern::__construct() example

<?php

/* Request write acknowledgement from the majority of the replica set nodes */
$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 500);

/* Request write acknowledgement from a node configured with the "MultipleDC" tag */
$wc = new MongoDB\Driver\WriteConcern("MultipleDC", 500);

?>

参见

  • » Write Concern reference


Returns the WriteConcern's "journal" option

  • ? MongoDB\Driver\WriteConcern::__construct
  • MongoDB\Driver\WriteConcern::getW ?
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Returns the WriteConcern's "journal" option

MongoDB\Driver\WriteConcern::getJournal

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option

说明

final public MongoDB\Driver\WriteConcern::getJournal ( ) : bool|null

参数

此函数没有参数。

返回值

Returns the WriteConcern's "journal" option.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteConcern::getJournal() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getJournal());

$wc = new MongoDB\Driver\WriteConcern(1, 0, true);
var_dump($wc->getJournal());

$wc = new MongoDB\Driver\WriteConcern(1, 0, false);
var_dump($wc->getJournal());

?>

以上例程会输出：

NULL
bool(true)
bool(false)

参见

  • » Write Concern reference


Returns the WriteConcern's "w" option

  • ? MongoDB\Driver\WriteConcern::getJournal
  • MongoDB\Driver\WriteConcern::getWtimeout ?
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Returns the WriteConcern's "w" option

MongoDB\Driver\WriteConcern::getW

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option

说明

final public MongoDB\Driver\WriteConcern::getW ( ) : string|int|null

参数

此函数没有参数。

返回值

Returns the WriteConcern's "w" option.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteConcern::getW() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getW());

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY);
var_dump($wc->getW());

?>

以上例程会输出：

int(1)
string(8) "majority"

参见

  • » Write Concern reference


Returns the WriteConcern's "wtimeout" option

  • ? MongoDB\Driver\WriteConcern::getW
  • MongoDB\Driver\WriteConcern::isDefault ?
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Returns the WriteConcern's "wtimeout" option

MongoDB\Driver\WriteConcern::getWtimeout

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option

说明

final public MongoDB\Driver\WriteConcern::getWtimeout ( ) : int|MongoDB\BSON\Int64

参数

此函数没有参数。

返回值

Returns the WriteConcern's "wtimeout" option.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.7.0 | On 32-bit systems, this method will return a MongoDB\BSON\Int64 instance if the WriteConcern object was created with a wTimeout that exceeds the 32-bit range. On 64-bit systems, this method will always return an integer value.

范例

Example #1 MongoDB\Driver\WriteConcern::getWtimeout() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getWtimeout());

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 3000);
var_dump($wc->getWtimeout());

?>

以上例程会输出：

int(0)
int(3000)

参见

  • » Write Concern reference


Checks if this is the default write concern

  • ? MongoDB\Driver\WriteConcern::getWtimeout
  • MongoDB\Driver\WriteConcern::serialize ?
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Checks if this is the default write concern

MongoDB\Driver\WriteConcern::isDefault

(mongodb >=1.3.0)

MongoDB\Driver\WriteConcern::isDefault — Checks if this is the default write concern

说明

final public MongoDB\Driver\WriteConcern::isDefault ( ) : bool

Returns whether this is the default write concern (i.e. no options are specified). This method is primarily intended to be used in conjunction with MongoDB\Driver\Manager::getWriteConcern() to determine whether the Manager has been constructed without any write concern options.

The driver will not include a default write concern in its write operations (e.g. MongoDB\Driver\Manager::executeBulkWrite()) in order to allow the server to apply its own default, which may have been » modified. Libraries that access the Manager's write concern to include it in their own write commands should use this method to ensure that default write concerns are left unset.

参数

此函数没有参数。

返回值

Returns true if this is the default write concern and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteConcern::isDefault() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->isDefault());

$manager = new MongoDB\Driver\Manager('mongodb://127.0.0.1/?w=majority');
$wc = $manager->getWriteConcern();
var_dump($wc->isDefault());

$manager = new MongoDB\Driver\Manager('mongodb://127.0.0.1/');
$wc = $manager->getWriteConcern();
var_dump($wc->isDefault());

?>

以上例程会输出：

bool(false)
bool(false)
bool(true)

参见

  • MongoDB\Driver\Manager::getWriteConcern() - Return the WriteConcern for the Manager
  • » Modify Default Write Concern in the MongoDB manual
  • » Write Concern reference


Serialize a WriteConcern

  • ? MongoDB\Driver\WriteConcern::isDefault
  • MongoDB\Driver\WriteConcern::unserialize ?
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Serialize a WriteConcern

MongoDB\Driver\WriteConcern::serialize

(mongodb >=1.7.0)

MongoDB\Driver\WriteConcern::serialize — Serialize a WriteConcern

说明

final public MongoDB\Driver\WriteConcern::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\Driver\WriteConcern.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\WriteConcern::unserialize() - Unserialize a WriteConcern
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Unserialize a WriteConcern

  • ? MongoDB\Driver\WriteConcern::serialize
  • MongoDB\Driver\ReadPreference ?
  • PHP Manual
  • MongoDB\Driver\WriteConcern
  • Unserialize a WriteConcern

MongoDB\Driver\WriteConcern::unserialize

(mongodb >=1.7.0)

MongoDB\Driver\WriteConcern::unserialize — Unserialize a WriteConcern

说明

final public MongoDB\Driver\WriteConcern::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\Driver\WriteConcern.

返回值

Returns the unserialized MongoDB\Driver\WriteConcern.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\Driver\WriteConcern::serialize() - Serialize a WriteConcern
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\Driver\ReadPreference class

(mongodb >=1.0.0)

简介

类摘要

final MongoDB\Driver\ReadPreference implements MongoDB\BSON\Serializable , Serializable {
/* Constants */
const int RP_PRIMARY = 1 ;
const int RP_PRIMARY_PREFERRED = 5 ;
const int RP_SECONDARY = 2 ;
const int RP_SECONDARY_PREFERRED = 6 ;
const int RP_NEAREST = 10 ;
const string PRIMARY = primary ;
const string PRIMARY_PREFERRED = primaryPreferred ;
const string SECONDARY = secondary ;
const string SECONDARY_PREFERRED = secondaryPreferred ;
const string NEAREST = nearest ;
const int NO_MAX_STALENESS = -1 ;
const int SMALLEST_MAX_STALENESS_SECONDS = 90 ;
/* 方法 */
final public bsonSerialize ( ) : object
final public __construct ( string|int $mode , array $tagSets = null , array $options = array() )
final public getHedge ( ) : object|null
final public getMaxStalenessSeconds ( ) : int
final public getMode ( ) : int
final public getModeString ( ) : string
final public getTagSets ( ) : array
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

预定义常量

MongoDB\Driver\ReadPreference::RP_PRIMARY

All operations read from the current replica set primary. This is the default read preference for MongoDB.

MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED

In most situations, operations read from the primary but if it is unavailable, operations read from secondary members.

MongoDB\Driver\ReadPreference::RP_SECONDARY

All operations read from the secondary members of the replica set.

MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED

In most situations, operations read from secondary members but if no secondary members are available, operations read from the primary.

MongoDB\Driver\ReadPreference::RP_NEAREST

Operations read from member of the replica set with the least network latency, irrespective of the member's type.

MongoDB\Driver\ReadPreference::PRIMARY

All operations read from the current replica set primary. This is the default read preference for MongoDB.

MongoDB\Driver\ReadPreference::PRIMARY_PREFERRED

In most situations, operations read from the primary but if it is unavailable, operations read from secondary members.

MongoDB\Driver\ReadPreference::SECONDARY

All operations read from the secondary members of the replica set.

MongoDB\Driver\ReadPreference::SECONDARY_PREFERRED

In most situations, operations read from secondary members but if no secondary members are available, operations read from the primary.

MongoDB\Driver\ReadPreference::NEAREST

Operations read from member of the replica set with the least network latency, irrespective of the member's type.

MongoDB\Driver\ReadPreference::NO_MAX_STALENESS

The default value for the "maxStalenessSeconds" option is to specify no limit on maximum staleness, which means that the driver will not consider a secondary's lag when choosing where to direct a read operation.

MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS

The minimum value for the "maxStalenessSeconds" option is 90 seconds. The driver estimates secondaries' staleness by periodically checking the latest write date of each replica set member. Since these checks are infrequent, the staleness estimate is coarse. Thus, the driver cannot enforce a max staleness value of less than 90 seconds.

更新日志

版本 | 说明
PECL mongodb 1.7.0 | Added the MongoDB\Driver\ReadPreference::PRIMARY, MongoDB\Driver\ReadPreference::PRIMARY_PREFERRED, MongoDB\Driver\ReadPreference::SECONDARY, MongoDB\Driver\ReadPreference::SECONDARY_PREFERRED, MongoDB\Driver\ReadPreference::NEAREST constants. Implements Serializable.
PECL mongodb 1.2.0 | Added the MongoDB\Driver\ReadPreference::NO_MAX_STALENESS and MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS constants. Implements MongoDB\BSON\Serializable.

Table of Contents

  • MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\ReadPreference::__construct — Create a new ReadPreference
  • MongoDB\Driver\ReadPreference::getHedge — Returns the ReadPreference's "hedge" option
  • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option
  • MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option
  • MongoDB\Driver\ReadPreference::getModeString — Returns the ReadPreference's "mode" option as a string
  • MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option
  • MongoDB\Driver\ReadPreference::serialize — Serialize a ReadPreference
  • MongoDB\Driver\ReadPreference::unserialize — Unserialize a ReadPreference


Returns an object for BSON serialization

  • ? MongoDB\Driver\ReadPreference
  • MongoDB\Driver\ReadPreference::__construct ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns an object for BSON serialization

MongoDB\Driver\ReadPreference::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization

说明

final public MongoDB\Driver\ReadPreference::bsonSerialize ( ) : object

参数

此函数没有参数。

返回值

Returns an object for serializing the ReadPreference as BSON.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadPreference::bsonSerialize() with primary read preference

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

以上例程的输出类似于：

object(stdClass)#2 (1) {
  ["mode"]=>
  string(7) "primary"
}

{ "mode" : "primary" }

Example #2 MongoDB\Driver\ReadPreference::bsonSerialize() with secondary read preference and tag sets

<?php

$rp = new MongoDB\Driver\ReadPreference(
    MongoDB\Driver\ReadPreference::RP_SECONDARY,
    [
        ['dc' => 'ny'],
        ['dc' => 'sf', 'use' => 'reporting'],
        []
    ]
);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

以上例程的输出类似于：

object(stdClass)#2 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["tags"]=>
  array(3) {
    [0]=>
    object(stdClass)#1 (1) {
      ["dc"]=>
      string(2) "ny"
    }
    [1]=>
    object(stdClass)#5 (2) {
      ["dc"]=>
      string(2) "sf"
      ["use"]=>
      string(9) "reporting"
    }
    [2]=>
    object(stdClass)#4 (0) {
    }
  }
}

{ "mode" : "secondary", "tags" : [ { "dc" : "ny" }, { "dc" : "sf", "use" : "reporting" }, {  } ] }

Example #3 MongoDB\Driver\ReadPreference::bsonSerialize() with secondary read preference and max staleness

<?php

$rp = new MongoDB\Driver\ReadPreference(
    MongoDB\Driver\ReadPreference::RP_SECONDARY,
    null,
    ['maxStalenessSeconds' => 120]
);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

以上例程的输出类似于：

object(stdClass)#2 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["maxStalenessSeconds"]=>
  int(120)
}

{ "mode" : "secondary", "maxStalenessSeconds" : 120 }

参见

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Read Preference reference


Create a new ReadPreference

  • ? MongoDB\Driver\ReadPreference::bsonSerialize
  • MongoDB\Driver\ReadPreference::getHedge ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Create a new ReadPreference

MongoDB\Driver\ReadPreference::__construct

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::__construct — Create a new ReadPreference

说明

final public MongoDB\Driver\ReadPreference::__construct ( string|int $mode , array $tagSets = null , array $options = array() )

Constructs a new MongoDB\Driver\ReadPreference, which is an immutable value object.

参数

mode

Read preference mode
Value Description
MongoDB\Driver\ReadPreference::RP_PRIMARY or "primary"

All operations read from the current replica set primary. This is the default read preference for MongoDB.

MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED or "primaryPreferred"

In most situations, operations read from the primary but if it is unavailable, operations read from secondary members.

MongoDB\Driver\ReadPreference::RP_SECONDARY or "secondary"

All operations read from the secondary members of the replica set.

MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED or "secondaryPreferred"

In most situations, operations read from secondary members but if no secondary members are available, operations read from the primary.

MongoDB\Driver\ReadPreference::RP_NEAREST or "nearest"

Operations read from member of the replica set with the least network latency, irrespective of the member's type.

tagSets

Tag sets allow you to target read operations to specific members of a replica set. This parameter should be an array of associative arrays, each of which contain zero or more key/value pairs. When selecting a server for a read operation, the driver attempt to select a node having all tags in a set (i.e. the associative array of key/value pairs). If selection fails, the driver will attempt subsequent sets. An empty tag set (array()) will match any node and may be used as a fallback.

Tags are not compatible with the MongoDB\Driver\ReadPreference::RP_PRIMARY mode and, in general, only apply when selecting a secondary member of a set for a read operation. However, the MongoDB\Driver\ReadPreference::RP_NEAREST mode, when combined with a tag set, selects the matching member with the lowest network latency. This member may be a primary or secondary.

options

options
Option Type Description
hedge object|array

Specifies whether to use » hedged reads, which are supported by MongoDB 4.4+ for sharded queries.

Server hedged reads are available for all non-primary read preferences and are enabled by default when using the "nearest" mode. This option allows explicitly enabling server hedged reads for non-primary read preferences by specifying ['enabled' => true], or explicitly disabling server hedged reads for the "nearest" read preference by specifying ['enabled' => false].

maxStalenessSeconds int

Specifies a maximum replication lag, or "staleness", for reads from secondaries. When a secondary's estimated staleness exceeds this value, the driver stops using it for read operations.

If specified, the max staleness must be a signed 32-bit integer greater than or equal to MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS.

Defaults to MongoDB\Driver\ReadPreference::NO_MAX_STALENESS, which means that the driver will not consider a secondary's lag when choosing where to direct a read operation.

This option is not compatible with the MongoDB\Driver\ReadPreference::RP_PRIMARY mode. Specifying a max staleness also requires all MongoDB instances in the deployment to be using MongoDB 3.4+. An exception will be thrown at execution time if any MongoDB instances in the deployment are of an older server version.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if mode is invalid.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if tagSets is provided for a primary read preference or is malformed (i.e. not an array of zero or more documents).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "maxStalenessSeconds" option is provided for a primary read preference or is out of range.

更新日志

版本 | 说明
PECL mongodb 1.8.0 | Added the "hedge" option.
PECL mongodb 1.3.0 | The mode argument now accepts a string value, which is consistent with the "readPreference" URI option for MongoDB\Driver\Manager::__construct().
PECL mongodb 1.2.0 | Added a third options argument, which supports the "maxStalenessSeconds" option.

范例

Example #1 MongoDB\Driver\ReadPreference::__construct() example

<?php

/* Prefer a secondary node but fall back to a primary. */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED));

/* Prefer a node in the New York data center with lowest latency. */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_NEAREST, [['dc' => 'ny']]));

/* Require a secondary node whose replication lag is within two minutes of the primary */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, ['maxStalenessSeconds' => 120]));

/* Explicitly enable server hedged reads */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, ['hedge' => ['enabled' => true]]));

?>

以上例程会输出：

object(MongoDB\Driver\ReadPreference)#1 (1) {
  ["mode"]=>
  string(18) "secondaryPreferred"
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(7) "nearest"
  ["tags"]=>
  array(1) {
    [0]=>
    object(stdClass)#2 (1) {
      ["dc"]=>
      string(2) "ny"
    }
  }
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["maxStalenessSeconds"]=>
  int(120)
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["hedge"]=>
  object(stdClass)#1 (1) {
    ["enabled"]=>
    bool(true)
  }
}

参见

  • » Read Preference reference


Returns the ReadPreference's "hedge" option

  • ? MongoDB\Driver\ReadPreference::__construct
  • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "hedge" option

MongoDB\Driver\ReadPreference::getHedge

(mongodb >=1.8.0)

MongoDB\Driver\ReadPreference::getHedge — Returns the ReadPreference's "hedge" option

说明

final public MongoDB\Driver\ReadPreference::getHedge ( ) : object|null

参数

此函数没有参数。

返回值

Returns the ReadPreference's "hedge" option.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • » Read Preference reference


Returns the ReadPreference's "maxStalenessSeconds" option

  • ? MongoDB\Driver\ReadPreference::getHedge
  • MongoDB\Driver\ReadPreference::getMode ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "maxStalenessSeconds" option

MongoDB\Driver\ReadPreference::getMaxStalenessSeconds

(mongodb >=1.2.0)

MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option

说明

final public MongoDB\Driver\ReadPreference::getMaxStalenessSeconds ( ) : int

参数

此函数没有参数。

返回值

Returns the ReadPreference's "maxStalenessSeconds" option. If no max staleness has been specified, MongoDB\Driver\ReadPreference::NO_MAX_STALENESS will be returned.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadPreference::getMaxStalenessSeconds() example

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => MongoDB\Driver\ReadPreference::NO_MAX_STALENESS,
]);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS,
]);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => 1000,
]);
var_dump($rp->getMaxStalenessSeconds());

?>

以上例程会输出：

int(-1)
int(-1)
int(90)
int(1000)

参见

  • » Read Preference reference


Returns the ReadPreference's "mode" option

  • ? MongoDB\Driver\ReadPreference::getMaxStalenessSeconds
  • MongoDB\Driver\ReadPreference::getModeString ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "mode" option

MongoDB\Driver\ReadPreference::getMode

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option

说明

final public MongoDB\Driver\ReadPreference::getMode ( ) : int

参数

此函数没有参数。

返回值

Returns the ReadPreference's "mode" option.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadPreference::getMode() example

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_NEAREST);
var_dump($rp->getMode());

?>

以上例程会输出：

int(1)
int(5)
int(2)
int(6)
int(10)

参见

  • MongoDB\Driver\ReadPreference::getModeString() - Returns the ReadPreference's "mode" option as a string
  • » Read Preference reference


Returns the ReadPreference's "mode" option as a string

  • ? MongoDB\Driver\ReadPreference::getMode
  • MongoDB\Driver\ReadPreference::getTagSets ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "mode" option as a string

MongoDB\Driver\ReadPreference::getModeString

(mongodb >=1.7.0)

MongoDB\Driver\ReadPreference::getModeString — Returns the ReadPreference's "mode" option as a string

说明

final public MongoDB\Driver\ReadPreference::getModeString ( ) : string

参数

此函数没有参数。

返回值

Returns the ReadPreference's "mode" option as a string.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadPreference::getModeString() example

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::PRIMARY);
var_dump($rp->getModeString());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::PRIMARY_PREFERRED);
var_dump($rp->getModeString());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::SECONDARY);
var_dump($rp->getModeString());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::SECONDARY_PREFERRED);
var_dump($rp->getModeString());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::NEAREST);
var_dump($rp->getModeString());

?>

以上例程会输出：

string(7) "primary"
string(16) "primaryPreferred"
string(9) "secondary"
string(18) "secondaryPreferred"
string(7) "nearest"

参见

  • MongoDB\Driver\ReadPreference::getMode() - Returns the ReadPreference's "mode" option
  • » Read Preference reference


Returns the ReadPreference's "tagSets" option

  • ? MongoDB\Driver\ReadPreference::getModeString
  • MongoDB\Driver\ReadPreference::serialize ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Returns the ReadPreference's "tagSets" option

MongoDB\Driver\ReadPreference::getTagSets

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option

说明

final public MongoDB\Driver\ReadPreference::getTagSets ( ) : array

参数

此函数没有参数。

返回值

Returns the ReadPreference's "tagSets" option.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadPreference::getTagSets() example

<?php

$mode = MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED;

/* Null and an empty array both denote no tag set preference. */
$rp = new MongoDB\Driver\ReadPreference($mode, null);
var_dump($rp->getTagSets());

$rp = new MongoDB\Driver\ReadPreference($mode, []);
var_dump($rp->getTagSets());

/* Prefer a node in New York, but fall back to any available node. */
$rp = new MongoDB\Driver\ReadPreference($mode, [['dc' => 'ny']]);
var_dump($rp->getTagSets());

/* Prefer a node in the New York, followed by a node in San Francisco that is
   labeled for reporting usage, and finally fall back to any available node. */
$rp = new MongoDB\Driver\ReadPreference($mode, [
  ['dc' => 'ny'],
  ['dc' => 'sf', 'use' => 'reporting'],
  [],
]);
var_dump($rp->getTagSets());

?>

以上例程会输出：

array(0) {
}
array(0) {
}
array(2) {
  [0]=>
  array(1) {
    ["dc"]=>
    string(2) "ny"
  }
  [1]=>
  array(0) {
  }
}
array(3) {
  [0]=>
  array(1) {
    ["dc"]=>
    string(2) "ny"
  }
  [1]=>
  array(2) {
    ["dc"]=>
    string(2) "sf"
    ["use"]=>
    string(9) "reporting"
  }
  [2]=>
  array(0) {
  }
}

参见

  • » Read Preference reference


Serialize a ReadPreference

  • ? MongoDB\Driver\ReadPreference::getTagSets
  • MongoDB\Driver\ReadPreference::unserialize ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Serialize a ReadPreference

MongoDB\Driver\ReadPreference::serialize

(mongodb >=1.7.0)

MongoDB\Driver\ReadPreference::serialize — Serialize a ReadPreference

说明

final public MongoDB\Driver\ReadPreference::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\Driver\ReadPreference.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\ReadPreference::unserialize() - Unserialize a ReadPreference
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Unserialize a ReadPreference

  • ? MongoDB\Driver\ReadPreference::serialize
  • MongoDB\Driver\ReadConcern ?
  • PHP Manual
  • MongoDB\Driver\ReadPreference
  • Unserialize a ReadPreference

MongoDB\Driver\ReadPreference::unserialize

(mongodb >=1.7.0)

MongoDB\Driver\ReadPreference::unserialize — Unserialize a ReadPreference

说明

final public MongoDB\Driver\ReadPreference::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\Driver\ReadPreference.

返回值

Returns the unserialized MongoDB\Driver\ReadPreference.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\Driver\ReadPreference::serialize() - Serialize a ReadPreference
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\Driver\ReadConcern class

(mongodb >=1.1.0)

简介

MongoDB\Driver\ReadConcern controls the level of isolation for read operations for replica sets and replica set shards. This option requires MongoDB 3.2 or later.

类摘要

final MongoDB\Driver\ReadConcern implements MongoDB\BSON\Serializable , Serializable {
/* Constants */
const string AVAILABLE = "available" ;
const string LINEARIZABLE = "linearizable" ;
const string LOCAL = "local" ;
const string MAJORITY = "majority" ;
/* 方法 */
final public bsonSerialize ( ) : object
final public __construct ( string $level = ? )
final public getLevel ( ) : string|null
final public isDefault ( ) : bool
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

预定义常量

MongoDB\Driver\ReadConcern::AVAILABLE

Default for reads against secondaries when afterClusterTimeand level are unspecified.

The query returns the instance's most recent data. Provides no guarantee that the data has been written to a majority of the replica set members (i.e. may be rolled back).

For unsharded collections (including collections in a standalone deployment or a replica set deployment), "local" and "available" read concerns behave identically.

For a sharded cluster, "available" read concern provides greater tolerance for partitions since it does not wait to ensure consistency guarantees. However, a query with "available" read concern may return orphan documents if the shard is undergoing chunk migrations since the "available" read concern, unlike "local" read concern, does not contact the shard's primary nor the config servers for updated metadata.

MongoDB\Driver\ReadConcern::LINEARIZABLE

The query returns data that reflects all successful writes issued with a write concern of "majority" and acknowledged prior to the start of the read operation. For replica sets that run with writeConcernMajorityJournalDefault set to true, linearizable read concern returns data that will never be rolled back.

With writeConcernMajorityJournalDefault set to false, MongoDB will not wait for w: "majority" writes to be durable before acknowledging the writes. As such, "majority" write operations could possibly roll back in the event of a loss of a replica set member.

You can specify linearizable read concern for read operations on the primary only.

Linearizable read concern guarantees only apply if read operations specify a query filter that uniquely identifies a single document.

Tip

Always use maxTimeMS with linearizable read concern in case a majority of data bearing members are unavailable. maxTimeMS ensures that the operation does not block indefinitely and instead ensures that the operation returns an error if the read concern cannot be fulfilled.

Linearizable read concern requires MongoDB 3.4.

MongoDB\Driver\ReadConcern::LOCAL

Default for reads against primary if level is unspecified and for reads against secondaries if level is unspecified but afterClusterTime is specified.

The query returns the instance's most recent data. Provides no guarantee that the data has been written to a majority of the replica set members (i.e. may be rolled back).

MongoDB\Driver\ReadConcern::MAJORITY

The query returns the instance's most recent data acknowledged as having been written to a majority of members in the replica set.

To use read concern level of "majority", replica sets must use WiredTiger storage engine and election protocol version 1.

更新日志

版本 | 说明
PECL mongodb 1.7.0 | Implements Serializable.
PECL mongodb 1.4.0 | Added the MongoDB\Driver\ReadConcern::AVAILABLE constant.
PECL mongodb 1.2.0 | Added the MongoDB\Driver\ReadConcern::LINEARIZABLE constant. Implements MongoDB\BSON\Serializable.

参见

  • » Read Concern reference

Table of Contents

  • MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\ReadConcern::__construct — Create a new ReadConcern
  • MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option
  • MongoDB\Driver\ReadConcern::isDefault — Checks if this is the default read concern
  • MongoDB\Driver\ReadConcern::serialize — Serialize a ReadConcern
  • MongoDB\Driver\ReadConcern::unserialize — Unserialize a ReadConcern


Returns an object for BSON serialization

  • ? MongoDB\Driver\ReadConcern
  • MongoDB\Driver\ReadConcern::__construct ?
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Returns an object for BSON serialization

MongoDB\Driver\ReadConcern::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization

说明

final public MongoDB\Driver\ReadConcern::bsonSerialize ( ) : object

参数

此函数没有参数。

返回值

Returns an object for serializing the ReadConcern as BSON.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadConcern::bsonSerialize() with empty read concern

<?php

$rc = new MongoDB\Driver\ReadConcern;
var_dump($rc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rc));

?>

以上例程的输出类似于：

object(stdClass)#2 (0) {
}

{ }

Example #2 MongoDB\Driver\ReadConcern::bsonSerialize() with local read concern

<?php

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);
var_dump($rc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rc));

?>

以上例程的输出类似于：

object(stdClass)#2 (1) {
  ["level"]=>
  string(5) "local"
}

{ "level" : "local" }

参见

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Read Concern reference


Create a new ReadConcern

  • ? MongoDB\Driver\ReadConcern::bsonSerialize
  • MongoDB\Driver\ReadConcern::getLevel ?
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Create a new ReadConcern

MongoDB\Driver\ReadConcern::__construct

(mongodb >=1.0.0)

MongoDB\Driver\ReadConcern::__construct — Create a new ReadConcern

说明

final public MongoDB\Driver\ReadConcern::__construct ( string $level = ? )

Constructs a new MongoDB\Driver\ReadConcern, which is an immutable value object.

参数

level

The » read concern level. You may use, but are not limited to, one of the class constants.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadConcern::__construct() example

<?php

/* Unspecified read isolation level (uses the server's default behavior) */
$rc = new MongoDB\Driver\ReadConcern();

/* Request read isolation from a single replica set node */
$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);

/* Request read isolation from a majority of the replica set nodes */
$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::MAJORITY);

?>

参见

  • » Read Concern reference


Returns the ReadConcern's "level" option

  • ? MongoDB\Driver\ReadConcern::__construct
  • MongoDB\Driver\ReadConcern::isDefault ?
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Returns the ReadConcern's "level" option

MongoDB\Driver\ReadConcern::getLevel

(mongodb >=1.0.0)

MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option

说明

final public MongoDB\Driver\ReadConcern::getLevel ( ) : string|null

参数

此函数没有参数。

返回值

Returns the ReadConcern's "level" option.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadConcern::getLevel() example

<?php

$rc = new MongoDB\Driver\ReadConcern();
var_dump($rc->getLevel());

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);
var_dump($rc->getLevel());

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::MAJORITY);
var_dump($rc->getLevel());

?>

以上例程会输出：

NULL
string(5) "local"
string(8) "majority"

参见

  • » Read Concern reference


Checks if this is the default read concern

  • ? MongoDB\Driver\ReadConcern::getLevel
  • MongoDB\Driver\ReadConcern::serialize ?
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Checks if this is the default read concern

MongoDB\Driver\ReadConcern::isDefault

(mongodb >=1.3.0)

MongoDB\Driver\ReadConcern::isDefault — Checks if this is the default read concern

说明

final public MongoDB\Driver\ReadConcern::isDefault ( ) : bool

Returns whether this is the default read concern (i.e. no options are specified). This method is primarily intended to be used in conjunction with MongoDB\Driver\Manager::getReadConcern() to determine whether the Manager has been constructed without any read concern options.

The driver will not include a default read concern in its read operations (e.g. MongoDB\Driver\Manager::executeQuery()) in order order to allow the server to apply its own default. Libraries that access the Manager's read concern to include it in their own read commands should use this method to ensure that default read concerns are left unset.

参数

此函数没有参数。

返回值

Returns true if this is the default read concern and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\ReadConcern::isDefault() example

<?php

$rc = new MongoDB\Driver\ReadConcern(null);
var_dump($rc->isDefault());

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::MAJORITY);
var_dump($rc->isDefault());

$manager = new MongoDB\Driver\Manager('mongodb://127.0.0.1/?readConcernLevel=majority');
$rc = $manager->getReadConcern();
var_dump($rc->isDefault());

$manager = new MongoDB\Driver\Manager('mongodb://127.0.0.1/');
$rc = $manager->getReadConcern();
var_dump($rc->isDefault());

?>

以上例程会输出：

bool(true)
bool(false)
bool(false)
bool(true)

参见

  • MongoDB\Driver\Manager::getReadConcern() - Return the ReadConcern for the Manager
  • » Read Concern reference


Serialize a ReadConcern

  • ? MongoDB\Driver\ReadConcern::isDefault
  • MongoDB\Driver\ReadConcern::unserialize ?
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Serialize a ReadConcern

MongoDB\Driver\ReadConcern::serialize

(mongodb >=1.7.0)

MongoDB\Driver\ReadConcern::serialize — Serialize a ReadConcern

说明

final public MongoDB\Driver\ReadConcern::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\Driver\ReadConcern.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\ReadConcern::unserialize() - Unserialize a ReadConcern
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Unserialize a ReadConcern

  • ? MongoDB\Driver\ReadConcern::serialize
  • MongoDB\Driver\Cursor ?
  • PHP Manual
  • MongoDB\Driver\ReadConcern
  • Unserialize a ReadConcern

MongoDB\Driver\ReadConcern::unserialize

(mongodb >=1.7.0)

MongoDB\Driver\ReadConcern::unserialize — Unserialize a ReadConcern

说明

final public MongoDB\Driver\ReadConcern::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\Driver\ReadConcern.

返回值

Returns the unserialized MongoDB\Driver\ReadConcern.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\Driver\ReadConcern::serialize() - Serialize a ReadConcern
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\Driver\Cursor class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\Cursor class encapsulates the results of a MongoDB command or query and may be returned by MongoDB\Driver\Manager::executeCommand() or MongoDB\Driver\Manager::executeQuery(), respectively.

类摘要

final MongoDB\Driver\Cursor implements MongoDB\Driver\CursorInterface , Iterator {
/* 方法 */
final private __construct ( )
public current ( ) : array|object
final public getId ( ) : MongoDB\Driver\CursorId
final public getServer ( ) : MongoDB\Driver\Server
final public isDead ( ) : bool
public key ( ) : int
public next ( ) : void
public rewind ( ) : void
final public setTypeMap ( array $typemap ) : void
final public toArray ( ) : array
public valid ( ) : bool
}

更新日志

版本 | 说明
PECL mongodb 1.9.0 | Implements Iterator.
PECL mongodb 1.6.0 | Implements MongoDB\Driver\CursorInterface, which extends Traversable.

范例

Example #1 Reading a result set

MongoDB\Driver\Manager::executeCommand() and MongoDB\Driver\Manager::executeQuery() both return their result(s) as a MongoDB\Driver\Cursor object. This object can be used to iterate over the result set of the command or query.

Because MongoDB\Driver\Cursor implements the Traversable interface, you can simply iterate over the result set with foreach.

<?php

$manager = new MongoDB\Driver\Manager();

/* Insert some documents so that our query returns information */
$bulkWrite = new MongoDB\Driver\BulkWrite;
$bulkWrite->insert(['name' => 'Ceres', 'size' => 946, 'distance' => 2.766]);
$bulkWrite->insert(['name' => 'Vesta', 'size' => 525, 'distance' => 2.362]);
$manager->executeBulkWrite("test.asteroids", $bulkWrite);

/* Query for all the items in the collection */
$query = new MongoDB\Driver\Query( [] );

/* Query the "asteroids" collection of the "test" database */
$cursor = $manager->executeQuery("test.asteroids", $query);

/* $cursor now contains an object that wraps around the result set. Use
 * foreach() to iterate over all the result */
foreach($cursor as $document) {
    print_r($document);
}

?>

以上例程的输出类似于：

stdClass Object
(
    [_id] => MongoDB\BSON\ObjectId Object
        (
            [oid] => 5a4cff2f122d3321565d8cc2
        )

    [name] => Ceres
    [size] => 946
    [distance] => 2.766
)
stdClass Object
(
    [_id] => MongoDB\BSON\ObjectId Object
        (
            [oid] => 5a4cff2f122d3321565d8cc3
        )

    [name] => Vesta
    [size] => 525
    [distance] => 2.362
}

Example #2 Reading a result set for a tailable cursor

» Tailable cursors are a special type of MongoDB cursor that allows the client to read some results and then wait until more documents become available. These cursors are primarily used with » Capped Collections and » Change Streams.

While normal cursors can be iterated once with foreach, that approach will not work with tailable cursors. When foreach is used with a tailable cursor, the loop will stop upon reaching the end of the initial result set. Attempting to continue iteration on the cursor with a second foreach would throw an exception, since PHP attempts to rewind the cursor. Similar to result objects in other database drivers, cursors in MongoDB only support forward iteration, which means they cannot be rewound.

In order to continuously read from a tailable cursor, the Cursor object must be wrapped with an IteratorIterator. This allows the application to directly control the cursor's iteration, avoid inadvertently rewinding the cursor, and decide when to wait for new results or stop iteration entirely.

In order to demonstrate a tailable cursor in action, two scripts will be used: a "producer" and a "consumer". The producer script will create a new capped collection using the » create command and proceed to insert a new document into that collection each second.

<?php

$manager = new MongoDB\Driver\Manager;

$manager->executeCommand('test', new MongoDB\Driver\Command([
    'create' => 'asteroids',
    'capped' => true,
    'size' => 1048576,
]));

while (true) {
    $bulkWrite = new MongoDB\Driver\BulkWrite;
    $bulkWrite->insert(['createdAt' => new MongoDB\BSON\UTCDateTime]);
    $manager->executeBulkWrite('test.asteroids', $bulkWrite);

    sleep(1);
}

?>

With the producer script still running, a second consumer script may be executed to read the inserted documents using a tailable cursor, indicated by the tailable and awaitData options to MongoDB\Driver\Query::__construct().

<?php

$manager = new MongoDB\Driver\Manager;

$query = new MongoDB\Driver\Query([], [
    'tailable' => true,
    'awaitData' => true,
]);

$cursor = $manager->executeQuery('test.asteroids', $query);

$iterator = new IteratorIterator($cursor);

$iterator->rewind();

while (true) {
    if ($iterator->valid()) {
        $document = $iterator->current();
        printf("Consumed document created at: %s\n", $document->createdAt);
    }

    $iterator->next();
}

?>

The consumer script will start by quickly printing all available documents in the capped collection (as if foreach had been used); however, it will not terminate upon reaching the end of the initial result set. Since the cursor is tailable, calling IteratorIterator::next() will block and wait for additional results. IteratorIterator::valid() is also used to check if there is actually data available to read at each step.

Note: This example uses the awaitData query option to instruct the server to block for a short period (e.g. one second) at the end of the result set before returning a response to the driver. This is used to prevent the driver from aggressively polling the server when there are no results available. The maxAwaitTimeMS option may be used in conjunction with tailable and awaitData to specify the amount of time that the server should block when it reaches the end of the result set.

错误／异常

When iterating over the cursor object, BSON data is converted into PHP variables. This iteration can cause the following Exceptions:

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if a class in the type map cannot be instantiated or does not implement MongoDB\BSON\Unserializable.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the input did not contain exactly one BSON document. Possible reasons include, but are not limited to, invalid BSON, extra data (after reading one BSON document), or an unexpected » libbson error.

Table of Contents

  • MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)
  • MongoDB\Driver\Cursor::current — Returns the current element
  • MongoDB\Driver\Cursor::getId — Returns the ID for this cursor
  • MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor
  • MongoDB\Driver\Cursor::isDead — Checks if the cursor is exhausted or may have additional results
  • MongoDB\Driver\Cursor::key — Returns the current result's index within the cursor
  • MongoDB\Driver\Cursor::next — Advances the cursor to the next result
  • MongoDB\Driver\Cursor::rewind — Rewind the cursor to the first result
  • MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization
  • MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor
  • MongoDB\Driver\Cursor::valid — Checks if the current position in the cursor is valid


Create a new Cursor (not used)

  • ? MongoDB\Driver\Cursor
  • MongoDB\Driver\Cursor::current ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Create a new Cursor (not used)

MongoDB\Driver\Cursor::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)

说明

final private MongoDB\Driver\Cursor::__construct ( )

MongoDB\Driver\Cursor objects are returned as the result of an executed command or query and cannot be constructed directly.

参数

此函数没有参数。

参见

  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeQuery() - Execute a database query
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeQuery() - Execute a database query on this server


Returns the current element

  • ? MongoDB\Driver\Cursor::__construct
  • MongoDB\Driver\Cursor::getId ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns the current element

MongoDB\Driver\Cursor::current

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::current — Returns the current element

说明

public MongoDB\Driver\Cursor::current ( ) : array|object

参数

此函数没有参数。

返回值

Returns the current result document as an array or object, depending on the cursor's type map. If iteration has not started or the current position is not valid, null will be returned.

参见

  • Iterator::current() - 返回当前元素


Returns the ID for this cursor

  • ? MongoDB\Driver\Cursor::current
  • MongoDB\Driver\Cursor::getServer ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns the ID for this cursor

MongoDB\Driver\Cursor::getId

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::getId — Returns the ID for this cursor

说明

final public MongoDB\Driver\Cursor::getId ( ) : MongoDB\Driver\CursorId

Returns the MongoDB\Driver\CursorId associated with this cursor. A cursor ID uniquely identifies the cursor on the server.

参数

此函数没有参数。

返回值

Returns the MongoDB\Driver\CursorId for this cursor.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Cursor::getId() example

<?php

/* In this example, we insert several documents into the collection and specify
 * a smaller batchSize to ensure that the first batch contains only a subset of
 * our results and the cursor remains open on the server. */
$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([], ['batchSize' => 2]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump($cursor->getId());

?>

以上例程的输出类似于：

object(MongoDB\Driver\CursorId)#5 (1) {
  ["id"]=>
  int(94810124093)
}

参见

  • MongoDB\Driver\CursorId
  • MongoDB\Driver\CursorId::__toString() - String representation of the cursor ID


Returns the server associated with this cursor

  • ? MongoDB\Driver\Cursor::getId
  • MongoDB\Driver\Cursor::isDead ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns the server associated with this cursor

MongoDB\Driver\Cursor::getServer

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor

说明

final public MongoDB\Driver\Cursor::getServer ( ) : MongoDB\Driver\Server

Returns the MongoDB\Driver\Server associated with this cursor. This is the server that executed the MongoDB\Driver\Query or MongoDB\Driver\Command.

参数

此函数没有参数。

返回值

Returns the MongoDB\Driver\Server associated with this cursor.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Cursor::getServer() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump($cursor->getServer());

?>

以上例程的输出类似于：

object(MongoDB\Driver\Server)#5 (10) {
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["type"]=>
  int(1)
  ["is_primary"]=>
  bool(false)
  ["is_secondary"]=>
  bool(false)
  ["is_arbiter"]=>
  bool(false)
  ["is_hidden"]=>
  bool(false)
  ["is_passive"]=>
  bool(false)
  ["last_is_master"]=>
  array(8) {
    ["ismaster"]=>
    bool(true)
    ["maxBsonObjectSize"]=>
    int(16777216)
    ["maxMessageSizeBytes"]=>
    int(48000000)
    ["maxWriteBatchSize"]=>
    int(1000)
    ["localTime"]=>
    object(MongoDB\BSON\UTCDateTime)#6 (1) {
      ["milliseconds"]=>
      int(1446505367907)
    }
    ["maxWireVersion"]=>
    int(3)
    ["minWireVersion"]=>
    int(0)
    ["ok"]=>
    float(1)
  }
  ["round_trip_time"]=>
  int(584)
}

参见

  • MongoDB\Driver\Server


Checks if the cursor is exhausted or may have additional results

  • ? MongoDB\Driver\Cursor::getServer
  • MongoDB\Driver\Cursor::key ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Checks if the cursor is exhausted or may have additional results

MongoDB\Driver\Cursor::isDead

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::isDead — Checks if the cursor is exhausted or may have additional results

说明

final public MongoDB\Driver\Cursor::isDead ( ) : bool

Checks whether there are definitely no additional results available on the cursor. This method is similar to the » cursor.isExhausted() method in the MongoDB shell and is primarily useful when iterating » tailable cursors.

A cursor has no additional results and is considered "dead" when one of the following is true:

  • The current batch has been fully iterated and the cursor ID is zero (i.e. a » getMore cannot be issued).
  • An error was encountered while iterating the cursor.
  • The cursor reached its configured limit.

By design, it is not possible to always determine whether a cursor has additional results. The cases where a cursor may have more data available is as follows:

  • There are additional documents in the current batch, which are buffered on the client side. Iterating will fetch a document from the local buffer.
  • There are no additional documents in the current batch (i.e. local buffer), but the cursor ID is non-zero. Iterating will request more documents from the server via a » getMore operation, which may or may not return additional results and/or indicate that the cursor has been closed on the server by returning zero for its ID.

参数

此函数没有参数。

返回值

Returns true if there are definitely no additional results available on the cursor, and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Cursor::isDead() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);

$iterator = new IteratorIterator($cursor);

$iterator->rewind();
var_dump($cursor->isDead());

$iterator->next();
var_dump($cursor->isDead());

$iterator->next();
var_dump($cursor->isDead());

$iterator->next();
var_dump($cursor->isDead());

?>

以上例程会输出：

bool(false)
bool(false)
bool(false)
bool(true)

参见

  • » Tailable Cursors in the MongoDB manual
  • » cursor.isExhausted() in the MongoDB manual


Returns the current result's index within the cursor

  • ? MongoDB\Driver\Cursor::isDead
  • MongoDB\Driver\Cursor::next ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns the current result's index within the cursor

MongoDB\Driver\Cursor::key

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::key — Returns the current result's index within the cursor

说明

public MongoDB\Driver\Cursor::key ( ) : int

参数

此函数没有参数。

返回值

The current result's numeric index within the cursor.

参见

  • Iterator::key() - 返回当前元素的键


Advances the cursor to the next result

  • ? MongoDB\Driver\Cursor::key
  • MongoDB\Driver\Cursor::rewind ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Advances the cursor to the next result

MongoDB\Driver\Cursor::next

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::next — Advances the cursor to the next result

说明

public MongoDB\Driver\Cursor::next ( ) : void

参数

此函数没有参数。

返回值

Moves the current position to the next element in the cursor.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.

参见

  • Iterator::next() - 向前移动到下一个元素


Rewind the cursor to the first result

  • ? MongoDB\Driver\Cursor::next
  • MongoDB\Driver\Cursor::setTypeMap ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Rewind the cursor to the first result

MongoDB\Driver\Cursor::rewind

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::rewind — Rewind the cursor to the first result

说明

public MongoDB\Driver\Cursor::rewind ( ) : void

If the cursor has advanced beyond its first position, it can no longer be rewound.

参数

此函数没有参数。

返回值

null.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\LogicException if this method is called after the cursor has advanced beyond its first position.

参见

  • Iterator::rewind() - 返回到迭代器的第一个元素


Sets a type map to use for BSON unserialization

  • ? MongoDB\Driver\Cursor::rewind
  • MongoDB\Driver\Cursor::toArray ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Sets a type map to use for BSON unserialization

MongoDB\Driver\Cursor::setTypeMap

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization

说明

final public MongoDB\Driver\Cursor::setTypeMap ( array $typemap ) : void

Sets the type map configuration to use when unserializing the BSON results into PHP values.

参数

typeMap (array)

Type map configuration.

返回值

没有返回值。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

When iterating over the cursor, the following exceptions can also be thrown due to an incorrect type map configuration:

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if a class in the type map cannot be instantiated or does not implement MongoDB\BSON\Unserializable.

范例

Example #1 MongoDB\Driver\Cursor::setTypeMap() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$id = $bulk->insert(['x' => 1]);
$manager->executeBulkWrite('db.collection', $bulk);

$query = new MongoDB\Driver\Query(['_id' => $id]);
$cursor = $manager->executeQuery('db.collection', $query);
$cursor->setTypeMap(['root' => 'array']);

foreach ($cursor as $document) {
    var_dump($document);
}

?>

以上例程的输出类似于：

array(2) {
  ["_id"]=>
  object(MongoDB\BSON\ObjectId)#6 (1) {
    ["oid"]=>
    string(24) "56424fb76118fd3267180741"
  }
  ["x"]=>
  int(1)
}

参见

  • Persisting Data


Returns an array containing all results for this cursor

  • ? MongoDB\Driver\Cursor::setTypeMap
  • MongoDB\Driver\Cursor::valid ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Returns an array containing all results for this cursor

MongoDB\Driver\Cursor::toArray

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor

说明

final public MongoDB\Driver\Cursor::toArray ( ) : array

Iterates the cursor and returns its results in an array. MongoDB\Driver\Cursor::setTypeMap() may be used to control how documents are unserialized into PHP values.

参数

此函数没有参数。

返回值

Returns an array containing all results for this cursor.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Cursor::toArray() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$query = new MongoDB\Driver\Query([]);
$cursor = $manager->executeQuery('db.collection', $query);

var_dump($cursor->toArray());

?>

以上例程的输出类似于：

array(3) {
  [0]=>
  object(stdClass)#6 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectId)#5 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf61"
    }
    ["x"]=>
    int(1)
  }
  [1]=>
  object(stdClass)#8 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectId)#7 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf62"
    }
    ["x"]=>
    int(2)
  }
  [2]=>
  object(stdClass)#10 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectId)#9 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf63"
    }
    ["x"]=>
    int(3)
  }
}

参见

  • MongoDB\Driver\Cursor::setTypeMap() - Sets a type map to use for BSON unserialization


Checks if the current position in the cursor is valid

  • ? MongoDB\Driver\Cursor::toArray
  • MongoDB\Driver\CursorId ?
  • PHP Manual
  • MongoDB\Driver\Cursor
  • Checks if the current position in the cursor is valid

MongoDB\Driver\Cursor::valid

(mongodb >=1.9.0)

MongoDB\Driver\Cursor::valid — Checks if the current position in the cursor is valid

说明

public MongoDB\Driver\Cursor::valid ( ) : bool

参数

此函数没有参数。

返回值

true if the current cursor position is valid, false otherwise.

参见

  • Iterator::valid() - 检查当前位置是否有效


The MongoDB\Driver\CursorId class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\CursorID class is a value object that represents a cursor ID. Instances of this class are returned by MongoDB\Driver\Cursor::getId().

类摘要

final MongoDB\Driver\CursorId implements Serializable {
/* 方法 */
final private __construct ( )
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.7.0 | Implements Serializable.

Table of Contents

  • MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)
  • MongoDB\Driver\CursorId::serialize — Serialize a CursorId
  • MongoDB\Driver\CursorId::__toString — String representation of the cursor ID
  • MongoDB\Driver\CursorId::unserialize — Unserialize a CursorId


Create a new CursorId (not used)

  • ? MongoDB\Driver\CursorId
  • MongoDB\Driver\CursorId::serialize ?
  • PHP Manual
  • MongoDB\Driver\CursorId
  • Create a new CursorId (not used)

MongoDB\Driver\CursorId::__construct

(mongodb >=1.0.0)

MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)

说明

final private MongoDB\Driver\CursorId::__construct ( )

MongoDB\Driver\CursorId objects are returned from MongoDB\Driver\Cursor::getId() and cannot be constructed directly.

参数

此函数没有参数。

参见

  • MongoDB\Driver\Cursor::getId() - Returns the ID for this cursor


Serialize a CursorId

  • ? MongoDB\Driver\CursorId::__construct
  • MongoDB\Driver\CursorId::__toString ?
  • PHP Manual
  • MongoDB\Driver\CursorId
  • Serialize a CursorId

MongoDB\Driver\CursorId::serialize

(mongodb >=1.7.0)

MongoDB\Driver\CursorId::serialize — Serialize a CursorId

说明

final public MongoDB\Driver\CursorId::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\Driver\CursorId.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\CursorId::unserialize() - Unserialize a CursorId
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


String representation of the cursor ID

  • ? MongoDB\Driver\CursorId::serialize
  • MongoDB\Driver\CursorId::unserialize ?
  • PHP Manual
  • MongoDB\Driver\CursorId
  • String representation of the cursor ID

MongoDB\Driver\CursorId::__toString

(mongodb >=1.0.0)

MongoDB\Driver\CursorId::__toString — String representation of the cursor ID

说明

final public MongoDB\Driver\CursorId::__toString ( ) : string

Returns the string representation of the cursor ID.

参数

此函数没有参数。

返回值

Returns the string representation of the cursor ID.

范例

Example #1 MongoDB\Driver\CursorId::__toString() example

<?php

/* In this example, we insert several documents into the collection and specify
 * a smaller batchSize to ensure that the first batch contains only a subset of
 * our results and the cursor remains open on the server. */
$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([], ['batchSize' => 2]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump((string) $cursor->getId());

?>

以上例程的输出类似于：

string(11) "98061641158"

参见

  • MongoDB\Driver\Cursor::getId() - Returns the ID for this cursor


Unserialize a CursorId

  • ? MongoDB\Driver\CursorId::__toString
  • MongoDB\Driver\Server ?
  • PHP Manual
  • MongoDB\Driver\CursorId
  • Unserialize a CursorId

MongoDB\Driver\CursorId::unserialize

(mongodb >=1.7.0)

MongoDB\Driver\CursorId::unserialize — Unserialize a CursorId

说明

final public MongoDB\Driver\CursorId::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\Driver\CursorId.

返回值

Returns the unserialized MongoDB\Driver\CursorId.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\Driver\CursorId::serialize() - Serialize a CursorId
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\Driver\Server class

(mongodb >=1.0.0)

简介

类摘要

final MongoDB\Driver\Server {
/* Constants */
const int TYPE_UNKNOWN = 0 ;
const int TYPE_STANDALONE = 1 ;
const int TYPE_MONGOS = 2 ;
const int TYPE_POSSIBLE_PRIMARY = 3 ;
const int TYPE_RS_PRIMARY = 4 ;
const int TYPE_RS_SECONDARY = 5 ;
const int TYPE_RS_ARBITER = 6 ;
const int TYPE_RS_OTHER = 7 ;
const int TYPE_RS_GHOST = 8 ;
/* 方法 */
final private __construct ( )
final public executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk , array $options = array() ) : MongoDB\Driver\WriteResult
final public executeCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeQuery ( string $namespace , MongoDB\Driver\Query $query , array $options = array() ) : MongoDB\Driver\Cursor
final public executeReadCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeReadWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public executeWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor
final public getHost ( ) : string
final public getInfo ( ) : array
final public getLatency ( ) : string
final public getPort ( ) : int
final public getTags ( ) : array
final public getType ( ) : int
final public isArbiter ( ) : bool
final public isHidden ( ) : bool
final public isPassive ( ) : bool
final public isPrimary ( ) : bool
final public isSecondary ( ) : bool
}

预定义常量

MongoDB\Driver\Server::TYPE_UNKNOWN

Unknown server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_STANDALONE

Standalone server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_MONGOS

Mongos server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_POSSIBLE_PRIMARY

Replica set possible primary server type, returned by MongoDB\Driver\Server::getType().

A server may be identified as a possible primary if it has not yet been checked but another memory of the replica set thinks it is the primary.

MongoDB\Driver\Server::TYPE_RS_PRIMARY

Replica set primary server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_SECONDARY

Replica set secondary server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_ARBITER

Replica set arbiter server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_OTHER

Replica set other server type, returned by MongoDB\Driver\Server::getType().

Such servers may be hidden, starting up, or recovering. They cannot be queried, but their hosts lists are useful for discovering the current replica set configuration.

MongoDB\Driver\Server::TYPE_RS_GHOST

Replica set ghost server type, returned by MongoDB\Driver\Server::getType().

Servers may be identified as such in at least three situations: briefly during server startup; in an uninitialized replica set; or when the server is shunned (i.e. removed from the replica set config). They cannot be queried, nor can their host list be used to discover the current replica set configuration; however, the client may monitor this server in hope that it transitions to a more useful state.

Table of Contents

  • MongoDB\Driver\Server::__construct — Create a new Server (not used)
  • MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server
  • MongoDB\Driver\Server::executeCommand — Execute a database command on this server
  • MongoDB\Driver\Server::executeQuery — Execute a database query on this server
  • MongoDB\Driver\Server::executeReadCommand — Execute a database command that reads on this server
  • MongoDB\Driver\Server::executeReadWriteCommand — Execute a database command that reads and writes on this server
  • MongoDB\Driver\Server::executeWriteCommand — Execute a database command that writes on this server
  • MongoDB\Driver\Server::getHost — Returns the hostname of this server
  • MongoDB\Driver\Server::getInfo — Returns an array of information about this server
  • MongoDB\Driver\Server::getLatency — Returns the latency of this server
  • MongoDB\Driver\Server::getPort — Returns the port on which this server is listening
  • MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set
  • MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server
  • MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set
  • MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set
  • MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set
  • MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set
  • MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set


Create a new Server (not used)

  • ? MongoDB\Driver\Server
  • MongoDB\Driver\Server::executeBulkWrite ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Create a new Server (not used)

MongoDB\Driver\Server::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Server::__construct — Create a new Server (not used)

说明

final private MongoDB\Driver\Server::__construct ( )

MongoDB\Driver\Server objects are created internally by MongoDB\Driver\Manager when a database connection is established and may be returned by MongoDB\Driver\Manager::getServers() and MongoDB\Driver\Manager::selectServer().

参数

此函数没有参数。

参见

  • MongoDB\Driver\Manager::getServers() - Return the servers to which this manager is connected
  • MongoDB\Driver\Manager::selectServer() - Select a server matching a read preference


Execute one or more write operations on this server

  • ? MongoDB\Driver\Server::__construct
  • MongoDB\Driver\Server::executeCommand ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute one or more write operations on this server

MongoDB\Driver\Server::executeBulkWrite

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server

说明

final public MongoDB\Driver\Server::executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk , array $options = array() ) : MongoDB\Driver\WriteResult

Executes one or more write operations on this server.

A MongoDB\Driver\BulkWrite can be constructed with one or more write operations of varying types (e.g. updates, deletes, and inserts). The driver will attempt to send operations of the same type to the server in as few requests as possible to optimize round trips.

参数

namespace (string)

A fully qualified namespace (e.g. "databaseName.collectionName").

bulk (MongoDB\Driver\BulkWrite)

The write(s) to execute.

options

options
Option Type Description
session MongoDB\Driver\Session

A session to associate with the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

返回值

Returns MongoDB\Driver\WriteResult on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if bulk does not contain any write operations.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if bulk has already been executed. MongoDB\Driver\BulkWrite objects may not be executed multiple times.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used in combination with an unacknowledged write concern.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\BulkWriteException on any write failure (e.g. write error, failure to apply a write concern)
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors.

更新日志

版本 | 说明
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\WriteConcern object.
PECL mongodb 1.3.0 | MongoDB\Driver\Exception\InvalidArgumentException is now thrown if bulk does not contain any write operations. Previously, a MongoDB\Driver\Exception\BulkWriteException was thrown.

注释

Note: It is the caller's responsibility to ensure that the server is capable of executing the write operation. For example, executing a write operation on a secondary (excluding its "local" database) will fail.

参见

  • MongoDB\Driver\BulkWrite
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations


Execute a database command on this server

  • ? MongoDB\Driver\Server::executeBulkWrite
  • MongoDB\Driver\Server::executeQuery ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database command on this server

MongoDB\Driver\Server::executeCommand

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeCommand — Execute a database command on this server

说明

final public MongoDB\Driver\Server::executeCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on this server.

This method applies no special logic to the command. Although this method accepts "readConcern" and "writeConcern" options, which will be incorporated into the command document, those options will not default to corresponding values from the MongoDB Connection URI nor will the MongoDB server version be taken into account. Users are therefore encouraged to use specific read and/or write command methods if possible.

Note: The "readPreference" option does not control the server to which the driver issues the operation; it will always be executed on this server object. Instead, it may be used when issuing the operation to a secondary (from a replica set connection, not standalone) or mongos node to ensure that the driver sets the wire protocol accordingly or adds the read preference to the operation, respectively.

参数

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The command to execute.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

readPreference MongoDB\Driver\ReadPreference

A read preference to use for selecting a server for the operation.

session MongoDB\Driver\Session

A session to associate with the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

Warning

If you are using a "session" which has a transaction in progress, you cannot specify a "readConcern" or "writeConcern" option. This will result in an MongoDB\Driver\Exception\InvalidArgumentException being thrown. Instead, you should set these two options when you create the transaction with MongoDB\Driver\Session::startTransaction().

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used with an associated transaction in combination with a "readConcern" or "writeConcern" option.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used in combination with an unacknowledged write concern.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command, issuing a write command to a secondary).

更新日志

版本 | 说明
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\ReadPreference object.

注释

Note: It is the caller's responsibility to ensure that the server is capable of executing the write operation. For example, executing a write operation on a secondary (excluding its "local" database) will fail.

参见

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Server::executeReadCommand() - Execute a database command that reads on this server
  • MongoDB\Driver\Server::executeReadWriteCommand() - Execute a database command that reads and writes on this server
  • MongoDB\Driver\Server::executeWriteCommand() - Execute a database command that writes on this server
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command


Execute a database query on this server

  • ? MongoDB\Driver\Server::executeCommand
  • MongoDB\Driver\Server::executeReadCommand ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database query on this server

MongoDB\Driver\Server::executeQuery

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeQuery — Execute a database query on this server

说明

final public MongoDB\Driver\Server::executeQuery ( string $namespace , MongoDB\Driver\Query $query , array $options = array() ) : MongoDB\Driver\Cursor

Executes the query on this server.

Note: The "readPreference" option does not control the server to which the driver issues the operation; it will always be executed on this server object. Instead, it may be used when issuing the operation to a secondary (from a replica set connection, not standalone) or mongos node to ensure that the driver sets the wire protocol accordingly or adds the read preference to the operation, respectively.

参数

namespace (string)

A fully qualified namespace (e.g. "databaseName.collectionName").

query (MongoDB\Driver\Query)

The query to execute.

options

options
Option Type Description
readPreference MongoDB\Driver\ReadPreference

A read preference to use for selecting a server for the operation.

session MongoDB\Driver\Session

A session to associate with the operation.

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid query operators).

更新日志

版本 | 说明
PECL mongodb 1.4.0 | The third parameter is now an options array. For backwards compatibility, this paramater will still accept a MongoDB\Driver\ReadPreference object.

参见

  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Query
  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Manager::executeQuery() - Execute a database query


Execute a database command that reads on this server

  • ? MongoDB\Driver\Server::executeQuery
  • MongoDB\Driver\Server::executeReadWriteCommand ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database command that reads on this server

MongoDB\Driver\Server::executeReadCommand

(mongodb >=1.4.0)

MongoDB\Driver\Server::executeReadCommand — Execute a database command that reads on this server

说明

final public MongoDB\Driver\Server::executeReadCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on this server.

This method will apply logic that is specific to commands that read (e.g. » count) and take the MongoDB server version into account. The "readConcern" option will default to the corresponding value from the MongoDB Connection URI.

Note: The "readPreference" option does not control the server to which the driver issues the operation; it will always be executed on this server object. Instead, it may be used when issuing the operation to a secondary (from a replica set connection, not standalone) or mongos node to ensure that the driver sets the wire protocol accordingly or adds the read preference to the operation, respectively.

参数

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The command to execute.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

readPreference MongoDB\Driver\ReadPreference

A read preference to use for selecting a server for the operation.

session MongoDB\Driver\Session

A session to associate with the operation.

Warning

If you are using a "session" which has a transaction in progress, you cannot specify a "readConcern" or "writeConcern" option. This will result in an MongoDB\Driver\Exception\InvalidArgumentException being thrown. Instead, you should set these two options when you create the transaction with MongoDB\Driver\Session::startTransaction().

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used with an associated transaction in combination with a "readConcern" or "writeConcern" option.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

参见

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeReadWriteCommand() - Execute a database command that reads and writes on this server
  • MongoDB\Driver\Server::executeWriteCommand() - Execute a database command that writes on this server
  • MongoDB\Driver\Manager::executeReadCommand() - Execute a database command that reads


Execute a database command that reads and writes on this server

  • ? MongoDB\Driver\Server::executeReadCommand
  • MongoDB\Driver\Server::executeWriteCommand ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database command that reads and writes on this server

MongoDB\Driver\Server::executeReadWriteCommand

(mongodb >=1.4.0)

MongoDB\Driver\Server::executeReadWriteCommand — Execute a database command that reads and writes on this server

说明

final public MongoDB\Driver\Server::executeReadWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on this server.

This method will apply logic that is specific to commands that read and write (e.g. » aggregate) and take the MongoDB server version into account. The "readConcern" and "writeConcern" options will default to the corresponding values from the MongoDB Connection URI.

参数

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The command to execute.

options

options
Option Type Description
readConcern MongoDB\Driver\ReadConcern

A read concern to apply to the operation.

This option is available in MongoDB 3.2+ and will result in an exception at execution time if specified for an older server version.

session MongoDB\Driver\Session

A session to associate with the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

Warning

If you are using a "session" which has a transaction in progress, you cannot specify a "readConcern" or "writeConcern" option. This will result in an MongoDB\Driver\Exception\InvalidArgumentException being thrown. Instead, you should set these two options when you create the transaction with MongoDB\Driver\Session::startTransaction().

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used with an associated transaction in combination with a "readConcern" or "writeConcern" option.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used in combination with an unacknowledged write concern.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

更新日志

版本 | 说明
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.

注释

Note: It is the caller's responsibility to ensure that the server is capable of executing the write operation. For example, executing a write operation on a secondary (excluding its "local" database) will fail.

参见

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeReadCommand() - Execute a database command that reads on this server
  • MongoDB\Driver\Server::executeWriteCommand() - Execute a database command that writes on this server
  • MongoDB\Driver\Manager::executeReadWriteCommand() - Execute a database command that reads and writes


Execute a database command that writes on this server

  • ? MongoDB\Driver\Server::executeReadWriteCommand
  • MongoDB\Driver\Server::getHost ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Execute a database command that writes on this server

MongoDB\Driver\Server::executeWriteCommand

(mongodb >=1.4.0)

MongoDB\Driver\Server::executeWriteCommand — Execute a database command that writes on this server

说明

final public MongoDB\Driver\Server::executeWriteCommand ( string $db , MongoDB\Driver\Command $command , array $options = array() ) : MongoDB\Driver\Cursor

Executes the command on this server.

This method will apply logic that is specific to commands that write (e.g. » drop) and take the MongoDB server version into account. The "writeConcern" option will default to the corresponding value from the MongoDB Connection URI.

Note: This method is not intended to be used to execute » insert, » update, or » delete commands. Users are encouraged to use MongoDB\Driver\Server::executeBulkWrite() for those commands.

参数

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The command to execute.

options

options
Option Type Description
session MongoDB\Driver\Session

A session to associate with the operation.

writeConcern MongoDB\Driver\WriteConcern

A write concern to apply to the operation.

Warning

If you are using a "session" which has a transaction in progress, you cannot specify a "readConcern" or "writeConcern" option. This will result in an MongoDB\Driver\Exception\InvalidArgumentException being thrown. Instead, you should set these two options when you create the transaction with MongoDB\Driver\Session::startTransaction().

返回值

Returns MongoDB\Driver\Cursor on success.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used with an associated transaction in combination with a "readConcern" or "writeConcern" option.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "session" option is used in combination with an unacknowledged write concern.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\ConnectionException if connection to the server fails (for reasons other than authentication).
  • Throws MongoDB\Driver\Exception\AuthenticationException if authentication is needed and fails.
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command).

更新日志

版本 | 说明
PECL mongodb 1.4.4 | MongoDB\Driver\Exception\InvalidArgumentException will be thrown if the "session" option is used in combination with an unacknowledged write concern.

注释

Note: It is the caller's responsibility to ensure that the server is capable of executing the write operation. For example, executing a write operation on a secondary (excluding its "local" database) will fail.

参见

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeReadCommand() - Execute a database command that reads on this server
  • MongoDB\Driver\Server::executeReadWriteCommand() - Execute a database command that reads and writes on this server
  • MongoDB\Driver\Manager::executeWriteCommand() - Execute a database command that writes


Returns the hostname of this server

  • ? MongoDB\Driver\Server::executeWriteCommand
  • MongoDB\Driver\Server::getInfo ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns the hostname of this server

MongoDB\Driver\Server::getHost

(mongodb >=1.0.0)

MongoDB\Driver\Server::getHost — Returns the hostname of this server

说明

final public MongoDB\Driver\Server::getHost ( ) : string

Returns the hostname of this server.

参数

此函数没有参数。

返回值

Returns the hostname of this server.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Server::getHost() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getHost());

?>

以上例程会输出：

string(9) "localhost"

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Returns an array of information about this server

  • ? MongoDB\Driver\Server::getHost
  • MongoDB\Driver\Server::getLatency ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns an array of information about this server

MongoDB\Driver\Server::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\Server::getInfo — Returns an array of information about this server

说明

final public MongoDB\Driver\Server::getInfo ( ) : array

Returns an array of information about this server.

参数

此函数没有参数。

返回值

Returns an array of information about this server.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Server::getInfo() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getInfo());

?>

以上例程的输出类似于：

array(8) {
  ["ismaster"]=>
  bool(true)
  ["maxBsonObjectSize"]=>
  int(16777216)
  ["maxMessageSizeBytes"]=>
  int(48000000)
  ["maxWriteBatchSize"]=>
  int(1000)
  ["localTime"]=>
  object(MongoDB\BSON\UTCDateTime)#4 (1) {
    ["milliseconds"]=>
    int(1447276242774)
  }
  ["maxWireVersion"]=>
  int(3)
  ["minWireVersion"]=>
  int(0)
  ["ok"]=>
  float(1)
}


Returns the latency of this server

  • ? MongoDB\Driver\Server::getInfo
  • MongoDB\Driver\Server::getPort ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns the latency of this server

MongoDB\Driver\Server::getLatency

(mongodb >=1.0.0)

MongoDB\Driver\Server::getLatency — Returns the latency of this server

说明

final public MongoDB\Driver\Server::getLatency ( ) : string

Returns the latency of this server (i.e. the client's measured » round trip time of an ismaster command).

参数

此函数没有参数。

返回值

Returns the latency of this server.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Server::getLatency() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getLatency());

?>

以上例程的输出类似于：

int(592)

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
  • » Server Discovery and Monitoring Specification


Returns the port on which this server is listening

  • ? MongoDB\Driver\Server::getLatency
  • MongoDB\Driver\Server::getTags ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns the port on which this server is listening

MongoDB\Driver\Server::getPort

(mongodb >=1.0.0)

MongoDB\Driver\Server::getPort — Returns the port on which this server is listening

说明

final public MongoDB\Driver\Server::getPort ( ) : int

Returns the port on which this server is listening.

参数

此函数没有参数。

返回值

Returns the port on which this server is listening.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\Server::getPort() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getPort());

?>

以上例程会输出：

int(27017)

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Returns an array of tags describing this server in a replica set

  • ? MongoDB\Driver\Server::getPort
  • MongoDB\Driver\Server::getType ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns an array of tags describing this server in a replica set

MongoDB\Driver\Server::getTags

(mongodb >=1.0.0)

MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set

说明

final public MongoDB\Driver\Server::getTags ( ) : array

Returns an array of » tags used to describe this server in a replica set. The array will contain zero or more string key and value pairs.

参数

此函数没有参数。

返回值

Returns an array of tags used to describe this server in a replica set.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Returns an integer denoting the type of this server

  • ? MongoDB\Driver\Server::getTags
  • MongoDB\Driver\Server::isArbiter ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Returns an integer denoting the type of this server

MongoDB\Driver\Server::getType

(mongodb >=1.0.0)

MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server

说明

final public MongoDB\Driver\Server::getType ( ) : int

Returns an int denoting the type of this server. The value will correlate with a MongoDB\Driver\Server constant.

参数

此函数没有参数。

返回值

Returns an int denoting the type of this server.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is an arbiter member of a replica set

  • ? MongoDB\Driver\Server::getType
  • MongoDB\Driver\Server::isHidden ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is an arbiter member of a replica set

MongoDB\Driver\Server::isArbiter

(mongodb >=1.0.0)

MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set

说明

final public MongoDB\Driver\Server::isArbiter ( ) : bool

Returns whether this server is an » arbiter member of a replica set.

参数

此函数没有参数。

返回值

Returns true if this server is an arbiter member of a replica set, and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is a hidden member of a replica set

  • ? MongoDB\Driver\Server::isArbiter
  • MongoDB\Driver\Server::isPassive ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is a hidden member of a replica set

MongoDB\Driver\Server::isHidden

(mongodb >=1.0.0)

MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set

说明

final public MongoDB\Driver\Server::isHidden ( ) : bool

Returns whether this server is a » hidden member of a replica set.

参数

此函数没有参数。

返回值

Returns true if this server is a hidden member of a replica set, and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is a passive member of a replica set

  • ? MongoDB\Driver\Server::isHidden
  • MongoDB\Driver\Server::isPrimary ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is a passive member of a replica set

MongoDB\Driver\Server::isPassive

(mongodb >=1.0.0)

MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set

说明

final public MongoDB\Driver\Server::isPassive ( ) : bool

Returns whether this server is a » passive member of a replica set (i.e. its priority is 0).

参数

此函数没有参数。

返回值

Returns true if this server is a passive member of a replica set, and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is a primary member of a replica set

  • ? MongoDB\Driver\Server::isPassive
  • MongoDB\Driver\Server::isSecondary ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is a primary member of a replica set

MongoDB\Driver\Server::isPrimary

(mongodb >=1.0.0)

MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set

说明

final public MongoDB\Driver\Server::isPrimary ( ) : bool

Returns whether this server is a » primary member of a replica set.

参数

此函数没有参数。

返回值

Returns true if this server is a primary member of a replica set, and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


Checks if this server is a secondary member of a replica set

  • ? MongoDB\Driver\Server::isPrimary
  • MongoDB\Driver\WriteConcernError ?
  • PHP Manual
  • MongoDB\Driver\Server
  • Checks if this server is a secondary member of a replica set

MongoDB\Driver\Server::isSecondary

(mongodb >=1.0.0)

MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set

说明

final public MongoDB\Driver\Server::isSecondary ( ) : bool

Returns whether this server is a » secondary member of a replica set.

参数

此函数没有参数。

返回值

Returns true if this server is a secondary member of a replica set, and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server


The MongoDB\Driver\WriteConcernError class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\WriteConcernError class encapsulates information about a write concern error and may be returned by MongoDB\Driver\WriteResult::getWriteConcernError().

类摘要

final MongoDB\Driver\WriteConcernError {
/* 方法 */
final public getCode ( ) : int
final public getInfo ( ) : object|null
final public getMessage ( ) : string
}

Table of Contents

  • MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code
  • MongoDB\Driver\WriteConcernError::getInfo — Returns metadata document for the WriteConcernError
  • MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message


Returns the WriteConcernError's error code

  • ? MongoDB\Driver\WriteConcernError
  • MongoDB\Driver\WriteConcernError::getInfo ?
  • PHP Manual
  • MongoDB\Driver\WriteConcernError
  • Returns the WriteConcernError's error code

MongoDB\Driver\WriteConcernError::getCode

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code

说明

final public MongoDB\Driver\WriteConcernError::getCode ( ) : int

参数

此函数没有参数。

返回值

Returns the WriteConcernError's error code.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteConcernError::getCode() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getCode());
}

?>

以上例程的输出类似于：

int(64)

参见

  • » Write Concern reference


Returns metadata document for the WriteConcernError

  • ? MongoDB\Driver\WriteConcernError::getCode
  • MongoDB\Driver\WriteConcernError::getMessage ?
  • PHP Manual
  • MongoDB\Driver\WriteConcernError
  • Returns metadata document for the WriteConcernError

MongoDB\Driver\WriteConcernError::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getInfo — Returns metadata document for the WriteConcernError

说明

final public MongoDB\Driver\WriteConcernError::getInfo ( ) : object|null

参数

此函数没有参数。

返回值

Returns the metadata document for the WriteConcernError, or null if no metadata is available.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteConcernError::getInfo() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getInfo());
}

?>

以上例程的输出类似于：

object(stdClass)#1 (1) {
  ["wtimeout"]=>
  bool(true)
}

参见

  • » Write Concern reference


Returns the WriteConcernError's error message

  • ? MongoDB\Driver\WriteConcernError::getInfo
  • MongoDB\Driver\WriteError ?
  • PHP Manual
  • MongoDB\Driver\WriteConcernError
  • Returns the WriteConcernError's error message

MongoDB\Driver\WriteConcernError::getMessage

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message

说明

final public MongoDB\Driver\WriteConcernError::getMessage ( ) : string

参数

此函数没有参数。

返回值

Returns the WriteConcernError's error message.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteConcernError::getMessage() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getMessage());
}

?>

以上例程的输出类似于：

string(33) "waiting for replication timed out"

参见

  • » Write Concern reference


The MongoDB\Driver\WriteError class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\WriteError class encapsulates information about a write error and may be returned as an array element from MongoDB\Driver\WriteResult::getWriteErrors().

类摘要

final MongoDB\Driver\WriteError {
/* 方法 */
final public getCode ( ) : int
final public getIndex ( ) : int
final public getInfo ( ) : object|null
final public getMessage ( ) : string
}

Table of Contents

  • MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code
  • MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError
  • MongoDB\Driver\WriteError::getInfo — Returns metadata document for the WriteError
  • MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message


Returns the WriteError's error code

  • ? MongoDB\Driver\WriteError
  • MongoDB\Driver\WriteError::getIndex ?
  • PHP Manual
  • MongoDB\Driver\WriteError
  • Returns the WriteError's error code

MongoDB\Driver\WriteError::getCode

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code

说明

final public MongoDB\Driver\WriteError::getCode ( ) : int

参数

此函数没有参数。

返回值

Returns the WriteError's error code.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteError::getCode() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getCode());
}

?>

以上例程的输出类似于：

int(11000)


Returns the index of the write operation corresponding to this WriteError

  • ? MongoDB\Driver\WriteError::getCode
  • MongoDB\Driver\WriteError::getInfo ?
  • PHP Manual
  • MongoDB\Driver\WriteError
  • Returns the index of the write operation corresponding to this WriteError

MongoDB\Driver\WriteError::getIndex

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError

说明

final public MongoDB\Driver\WriteError::getIndex ( ) : int

参数

此函数没有参数。

返回值

Returns the index of the write operation (from MongoDB\Driver\BulkWrite) corresponding to this WriteError.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteError::getIndex() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getIndex());
}

?>

以上例程的输出类似于：

int(1)

参见

  • MongoDB\Driver\BulkWrite


Returns metadata document for the WriteError

  • ? MongoDB\Driver\WriteError::getIndex
  • MongoDB\Driver\WriteError::getMessage ?
  • PHP Manual
  • MongoDB\Driver\WriteError
  • Returns metadata document for the WriteError

MongoDB\Driver\WriteError::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getInfo — Returns metadata document for the WriteError

说明

final public MongoDB\Driver\WriteError::getInfo ( ) : object|null

参数

此函数没有参数。

返回值

Returns the metadata document for the WriteError, or null if no metadata is available.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.


Returns the WriteError's error message

  • ? MongoDB\Driver\WriteError::getInfo
  • MongoDB\Driver\WriteResult ?
  • PHP Manual
  • MongoDB\Driver\WriteError
  • Returns the WriteError's error message

MongoDB\Driver\WriteError::getMessage

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message

说明

final public MongoDB\Driver\WriteError::getMessage ( ) : string

参数

此函数没有参数。

返回值

Returns the WriteError's error message.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteError::getMessage() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getMessage());
}

?>

以上例程的输出类似于：

string(70) "E11000 duplicate key error index: db.collection.$_id_ dup key: { : 1 }"


The MongoDB\Driver\WriteResult class

(mongodb >=1.0.0)

简介

The MongoDB\Driver\WriteResult class encapsulates information about an executed MongoDB\Driver\BulkWrite and may be returned by MongoDB\Driver\Manager::executeBulkWrite().

类摘要

final MongoDB\Driver\WriteResult {
/* 方法 */
final public getDeletedCount ( ) : int|null
final public getInsertedCount ( ) : int|null
final public getMatchedCount ( ) : int|null
final public getModifiedCount ( ) : int|null
final public getServer ( ) : MongoDB\Driver\Server
final public getUpsertedCount ( ) : int|null
final public getUpsertedIds ( ) : array
final public getWriteConcernError ( ) : MongoDB\Driver\WriteConcernError|null
final public getWriteErrors ( ) : array
final public isAcknowledged ( ) : bool
}

Table of Contents

  • MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted
  • MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)
  • MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update
  • MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated
  • MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result
  • MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert
  • MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents
  • MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred
  • MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred
  • MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged


Returns the number of documents deleted

  • ? MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteResult::getInsertedCount ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of documents deleted

MongoDB\Driver\WriteResult::getDeletedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted

说明

final public MongoDB\Driver\WriteResult::getDeletedCount ( ) : int|null

参数

此函数没有参数。

返回值

Returns the number of documents deleted, or null if the write was not acknowledged.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getDeletedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getDeletedCount());

?>

以上例程会输出：

int(1)

参见

  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns the number of documents inserted (excluding upserts)

  • ? MongoDB\Driver\WriteResult::getDeletedCount
  • MongoDB\Driver\WriteResult::getMatchedCount ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of documents inserted (excluding upserts)

MongoDB\Driver\WriteResult::getInsertedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)

说明

final public MongoDB\Driver\WriteResult::getInsertedCount ( ) : int|null

参数

此函数没有参数。

返回值

Returns the number of documents inserted (excluding upserts), or null if the write was not acknowledged.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getInsertedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getInsertedCount());

?>

以上例程会输出：

int(1)

参见

  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns the number of documents selected for update

  • ? MongoDB\Driver\WriteResult::getInsertedCount
  • MongoDB\Driver\WriteResult::getModifiedCount ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of documents selected for update

MongoDB\Driver\WriteResult::getMatchedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update

说明

final public MongoDB\Driver\WriteResult::getMatchedCount ( ) : int|null

If the update operation results in no change to the document (e.g. setting the value of a field to its current value), the matched count may be greater than the value returned by MongoDB\Driver\WriteResult::getModifiedCount().

参数

此函数没有参数。

返回值

Returns the number of documents selected for update, or null if the write was not acknowledged.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getMatchedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getMatchedCount());

?>

以上例程会输出：

int(1)

参见

  • MongoDB\Driver\WriteResult::getModifiedCount() - Returns the number of existing documents updated
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns the number of existing documents updated

  • ? MongoDB\Driver\WriteResult::getMatchedCount
  • MongoDB\Driver\WriteResult::getServer ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of existing documents updated

MongoDB\Driver\WriteResult::getModifiedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated

说明

final public MongoDB\Driver\WriteResult::getModifiedCount ( ) : int|null

If the update operation results in no change to the document (e.g. setting the value of a field to its current value), the modified count may be less than the value returned by MongoDB\Driver\WriteResult::getMatchedCount().

参数

此函数没有参数。

返回值

Returns the number of existing documents updated, or null if the write was not acknowledged.

The modified count is not available on versions of MongoDB before 2.6, which used the legacy wire protocol version (i.e. OP_UPDATE). If this is the case, the modified count will also be null.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getModifiedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getModifiedCount());

?>

以上例程会输出：

int(1)

参见

  • MongoDB\Driver\WriteResult::getMatchedCount() - Returns the number of documents selected for update
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns the server associated with this write result

  • ? MongoDB\Driver\WriteResult::getModifiedCount
  • MongoDB\Driver\WriteResult::getUpsertedCount ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the server associated with this write result

MongoDB\Driver\WriteResult::getServer

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result

说明

final public MongoDB\Driver\WriteResult::getServer ( ) : MongoDB\Driver\Server

Returns the MongoDB\Driver\Server associated with this write result. This is the server that executed the MongoDB\Driver\BulkWrite.

参数

此函数没有参数。

返回值

Returns the MongoDB\Driver\Server associated with this write result.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getServer() example

<?php

$manager = new MongoDB\Driver\Manager;
$server = $manager->selectServer(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY));

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $server->executeBulkWrite('db.collection', $bulk);

var_dump($result->getServer() == $server);

?>

以上例程会输出：

bool(true)

参见

  • MongoDB\Driver\Server


Returns the number of documents inserted by an upsert

  • ? MongoDB\Driver\WriteResult::getServer
  • MongoDB\Driver\WriteResult::getUpsertedIds ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns the number of documents inserted by an upsert

MongoDB\Driver\WriteResult::getUpsertedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert

说明

final public MongoDB\Driver\WriteResult::getUpsertedCount ( ) : int|null

参数

此函数没有参数。

返回值

Returns the number of documents inserted by an upsert.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getUpsertedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getUpsertedCount());

?>

以上例程会输出：

int(2)

参见

  • MongoDB\Driver\WriteResult::getUpsertedIds() - Returns an array of identifiers for upserted documents
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns an array of identifiers for upserted documents

  • ? MongoDB\Driver\WriteResult::getUpsertedCount
  • MongoDB\Driver\WriteResult::getWriteConcernError ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns an array of identifiers for upserted documents

MongoDB\Driver\WriteResult::getUpsertedIds

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents

说明

final public MongoDB\Driver\WriteResult::getUpsertedIds ( ) : array

参数

此函数没有参数。

返回值

Returns an array of identifiers (i.e. "_id" field values) for upserted documents. The array keys will correspond to the index of the write operation (from MongoDB\Driver\BulkWrite) responsible for the upsert.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getUpsertedIds() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getUpsertedIds());

?>

以上例程的输出类似于：

array(2) {
  [2]=>
  object(MongoDB\BSON\ObjectId)#4 (1) {
    ["oid"]=>
    string(24) "580e62a224f2302f191b880b"
  }
  [3]=>
  object(MongoDB\BSON\ObjectId)#5 (1) {
    ["oid"]=>
    string(24) "580e62a224f2302f191b880c"
  }
}

参见

  • MongoDB\Driver\WriteResult::getUpsertedCount() - Returns the number of documents inserted by an upsert
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged


Returns any write concern error that occurred

  • ? MongoDB\Driver\WriteResult::getUpsertedIds
  • MongoDB\Driver\WriteResult::getWriteErrors ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns any write concern error that occurred

MongoDB\Driver\WriteResult::getWriteConcernError

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred

说明

final public MongoDB\Driver\WriteResult::getWriteConcernError ( ) : MongoDB\Driver\WriteConcernError|null

参数

此函数没有参数。

返回值

Returns a MongoDB\Driver\WriteConcernError if a write concern error was encountered during the write operation, and null otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getWriteConcernError() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError());
}

?>

以上例程的输出类似于：

object(MongoDB\Driver\WriteConcernError)#6 (3) {
  ["message"]=>
  string(33) "waiting for replication timed out"
  ["code"]=>
  int(64)
  ["info"]=>
  object(stdClass)#7 (1) {
    ["wtimeout"]=>
    bool(true)
  }
}

参见

  • MongoDB\Driver\WriteConcern
  • » Write Concern reference


Returns any write errors that occurred

  • ? MongoDB\Driver\WriteResult::getWriteConcernError
  • MongoDB\Driver\WriteResult::isAcknowledged ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns any write errors that occurred

MongoDB\Driver\WriteResult::getWriteErrors

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred

说明

final public MongoDB\Driver\WriteResult::getWriteErrors ( ) : array

参数

此函数没有参数。

返回值

Returns an array of MongoDB\Driver\WriteError objects for any write errors encountered during the write operation. The array will be empty if no write errors occurred.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::getWriteErrors() with a single error

<?php

$manager = new MongoDB\Driver\Manager;

/* By default, bulk write operations are executed serially in order and
 * execution will stop after the first error.
 */
$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 4]);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors());
}

?>

以上例程的输出类似于：

array(1) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 2 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(2)
    ["info"]=>
    NULL
  }
}

Example #2 MongoDB\Driver\WriteResult::getWriteErrors() with multiple errors

<?php

$manager = new MongoDB\Driver\Manager;

/* The "ordered" option may be used to allow bulk write operations to continue
 * executing after the first error is encountered.
 */
$bulk = new MongoDB\Driver\BulkWrite(['ordered' => false]);
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 4]);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors());
}

?>

以上例程的输出类似于：

array(2) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 2 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(2)
    ["info"]=>
    NULL
  }
  [1]=>
  object(MongoDB\Driver\WriteError)#6 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 4 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(5)
    ["info"]=>
    NULL
  }
}

参见

  • MongoDB\Driver\WriteError


Returns whether the write was acknowledged

  • ? MongoDB\Driver\WriteResult::getWriteErrors
  • MongoDB\BSON ?
  • PHP Manual
  • MongoDB\Driver\WriteResult
  • Returns whether the write was acknowledged

MongoDB\Driver\WriteResult::isAcknowledged

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged

说明

final public MongoDB\Driver\WriteResult::isAcknowledged ( ) : bool

If the write is acknowledged, other count fields will be available on the MongoDB\Driver\WriteResult object.

参数

此函数没有参数。

返回值

Returns true if the write was acknowledged, and false otherwise.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\Driver\WriteResult::isAcknowledged() with acknowledged write concern

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->isAcknowledged());

?>

以上例程会输出：

bool(true)

Example #2 MongoDB\Driver\WriteResult::isAcknowledged() with unacknowledged write concern

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk, new MongoDB\Driver\WriteConcern(0));

var_dump($result->isAcknowledged());

?>

以上例程会输出：

bool(false)

参见

  • MongoDB\Driver\WriteConcern
  • » Write Concern reference


BSON type classes and serialization functions

  • 函数
    • MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value
    • MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value
    • MongoDB\BSON\toCanonicalExtendedJSON — Returns the Canonical Extended JSON representation of a BSON value
    • MongoDB\BSON\toJSON — Returns the Legacy Extended JSON representation of a BSON value
    • MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value
    • MongoDB\BSON\toRelaxedExtendedJSON — Returns the Relaxed Extended JSON representation of a BSON value
  • MongoDB\BSON\Binary — The MongoDB\BSON\Binary class
    • MongoDB\BSON\Binary::__construct — Construct a new Binary
    • MongoDB\BSON\Binary::getData — Returns the Binary's data
    • MongoDB\BSON\Binary::getType — Returns the Binary's type
    • MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Binary::serialize — Serialize a Binary
    • MongoDB\BSON\Binary::__toString — Returns the Binary's data
    • MongoDB\BSON\Binary::unserialize — Unserialize a Binary
  • MongoDB\BSON\Decimal128 — The MongoDB\BSON\Decimal128 class
    • MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128
    • MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128
    • MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128
    • MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128
  • MongoDB\BSON\Javascript — The MongoDB\BSON\Javascript class
    • MongoDB\BSON\Javascript::__construct — Construct a new Javascript
    • MongoDB\BSON\Javascript::getCode — Returns the Javascript's code
    • MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document
    • MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Javascript::serialize — Serialize a Javascript
    • MongoDB\BSON\Javascript::__toString — Returns the Javascript's code
    • MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript
  • MongoDB\BSON\MaxKey — The MongoDB\BSON\MaxKey class
    • MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey
    • MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey
    • MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey
  • MongoDB\BSON\MinKey — The MongoDB\BSON\MinKey class
    • MongoDB\BSON\MinKey::__construct — Construct a new MinKey
    • MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\MinKey::serialize — Serialize a MinKey
    • MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey
  • MongoDB\BSON\ObjectId — The MongoDB\BSON\ObjectId class
    • MongoDB\BSON\ObjectId::__construct — Construct a new ObjectId
    • MongoDB\BSON\ObjectId::getTimestamp — Returns the timestamp component of this ObjectId
    • MongoDB\BSON\ObjectId::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\ObjectId::serialize — Serialize an ObjectId
    • MongoDB\BSON\ObjectId::__toString — Returns the hexidecimal representation of this ObjectId
    • MongoDB\BSON\ObjectId::unserialize — Unserialize an ObjectId
  • MongoDB\BSON\Regex — The MongoDB\BSON\Regex class
    • MongoDB\BSON\Regex::__construct — Construct a new Regex
    • MongoDB\BSON\Regex::getFlags — Returns the Regex's flags
    • MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern
    • MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Regex::serialize — Serialize a Regex
    • MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex
    • MongoDB\BSON\Regex::unserialize — Unserialize a Regex
  • MongoDB\BSON\Timestamp — The MongoDB\BSON\Timestamp class
    • MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp
    • MongoDB\BSON\Timestamp::getIncrement — Returns the increment component of this Timestamp
    • MongoDB\BSON\Timestamp::getTimestamp — Returns the timestamp component of this Timestamp
    • MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp
    • MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp
    • MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp
  • MongoDB\BSON\UTCDateTime — The MongoDB\BSON\UTCDateTime class
    • MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime
    • MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime
  • MongoDB\BSON\Type — The MongoDB\BSON\Type interface
  • MongoDB\BSON\Persistable — The MongoDB\BSON\Persistable interface
  • MongoDB\BSON\Serializable — The MongoDB\BSON\Serializable interface
    • MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON
  • MongoDB\BSON\Unserializable — The MongoDB\BSON\Unserializable interface
    • MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document
  • MongoDB\BSON\BinaryInterface — The MongoDB\BSON\BinaryInterface interface
    • MongoDB\BSON\BinaryInterface::getData — Returns the BinaryInterface's data
    • MongoDB\BSON\BinaryInterface::getType — Returns the BinaryInterface's type
    • MongoDB\BSON\BinaryInterface::__toString — Returns the BinaryInterface's data
  • MongoDB\BSON\Decimal128Interface — The MongoDB\BSON\Decimal128Interface interface
    • MongoDB\BSON\Decimal128Interface::__toString — Returns the string representation of this Decimal128Interface
  • MongoDB\BSON\JavascriptInterface — The MongoDB\BSON\JavascriptInterface interface
    • MongoDB\BSON\JavascriptInterface::getCode — Returns the JavascriptInterface's code
    • MongoDB\BSON\JavascriptInterface::getScope — Returns the JavascriptInterface's scope document
    • MongoDB\BSON\JavascriptInterface::__toString — Returns the JavascriptInterface's code
  • MongoDB\BSON\MaxKeyInterface — The MongoDB\BSON\MaxKeyInterface interface
  • MongoDB\BSON\MinKeyInterface — The MongoDB\BSON\MinKeyInterface interface
  • MongoDB\BSON\ObjectIdInterface — The MongoDB\BSON\ObjectIdInterface interface
    • MongoDB\BSON\ObjectIdInterface::getTimestamp — Returns the timestamp component of this ObjectIdInterface
    • MongoDB\BSON\ObjectIdInterface::__toString — Returns the hexidecimal representation of this ObjectIdInterface
  • MongoDB\BSON\RegexInterface — The MongoDB\BSON\RegexInterface interface
    • MongoDB\BSON\RegexInterface::getFlags — Returns the RegexInterface's flags
    • MongoDB\BSON\RegexInterface::getPattern — Returns the RegexInterface's pattern
    • MongoDB\BSON\RegexInterface::__toString — Returns the string representation of this RegexInterface
  • MongoDB\BSON\TimestampInterface — The MongoDB\BSON\TimestampInterface interface
    • MongoDB\BSON\TimestampInterface::getIncrement — Returns the increment component of this TimestampInterface
    • MongoDB\BSON\TimestampInterface::getTimestamp — Returns the timestamp component of this TimestampInterface
    • MongoDB\BSON\TimestampInterface::__toString — Returns the string representation of this TimestampInterface
  • MongoDB\BSON\UTCDateTimeInterface — The MongoDB\BSON\UTCDateTimeInterface interface
    • MongoDB\BSON\UTCDateTimeInterface::toDateTime — Returns the DateTime representation of this UTCDateTimeInterface
    • MongoDB\BSON\UTCDateTimeInterface::__toString — Returns the string representation of this UTCDateTimeInterface
  • MongoDB\BSON\DBPointer — The MongoDB\BSON\DBPointer class (deprecated)
    • MongoDB\BSON\DBPointer::__construct — Construct a new DBPointer (unused)
    • MongoDB\BSON\DBPointer::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\DBPointer::serialize — Serialize a DBPointer
    • MongoDB\BSON\DBPointer::__toString — Returns an empty string
    • MongoDB\BSON\DBPointer::unserialize — Unserialize a DBPointer
  • MongoDB\BSON\Int64 — The MongoDB\BSON\Int64 class
    • MongoDB\BSON\Int64::__construct — Construct a new Int64 (unused)
    • MongoDB\BSON\Int64::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Int64::serialize — Serialize an Int64
    • MongoDB\BSON\Int64::__toString — Returns the string representation of this Int64
    • MongoDB\BSON\Int64::unserialize — Unserialize an Int64
  • MongoDB\BSON\Symbol — The MongoDB\BSON\Symbol class (deprecated)
    • MongoDB\BSON\Symbol::__construct — Construct a new Symbol (unused)
    • MongoDB\BSON\Symbol::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Symbol::serialize — Serialize a Symbol
    • MongoDB\BSON\Symbol::__toString — Returns the Symbol as a string
    • MongoDB\BSON\Symbol::unserialize — Unserialize a Symbol
  • MongoDB\BSON\Undefined — The MongoDB\BSON\Undefined class (deprecated)
    • MongoDB\BSON\Undefined::__construct — Construct a new Undefined (unused)
    • MongoDB\BSON\Undefined::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Undefined::serialize — Serialize a Undefined
    • MongoDB\BSON\Undefined::__toString — Returns an empty string
    • MongoDB\BSON\Undefined::unserialize — Unserialize a Undefined


函数

Table of Contents

  • MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value
  • MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value
  • MongoDB\BSON\toCanonicalExtendedJSON — Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toJSON — Returns the Legacy Extended JSON representation of a BSON value
  • MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON — Returns the Relaxed Extended JSON representation of a BSON value


Returns the BSON representation of a JSON value

  • ? 函数
  • MongoDB\BSON\fromPHP ?
  • PHP Manual
  • 函数
  • Returns the BSON representation of a JSON value

MongoDB\BSON\fromJSON

(mongodb >=1.0.0)

MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value

说明

MongoDB\BSON\fromJSON ( string $json ) : string

Converts an » extended JSON string to its BSON representation.

参数

json (string)

JSON value to be converted.

返回值

The serialized BSON document as a binary string.

错误／异常

  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the JSON value cannot be converted to BSON (e.g. due to a syntax error).

范例

Example #1 MongoDB\BSON\fromJSON() example

<?php

$json = '{ "_id": { "$oid": "563143b280d2387c91807965" } }';
$bson = MongoDB\BSON\fromJSON($json);
$value = MongoDB\BSON\toPHP($bson);
var_dump($value);

?>

以上例程会输出：

object(stdClass)#2 (1) {
  ["_id"]=>
  object(MongoDB\BSON\ObjectId)#1 (1) {
    ["oid"]=>
    string(24) "563143b280d2387c91807965"
  }
}

参见

  • MongoDB\BSON\toJSON() - Returns the Legacy Extended JSON representation of a BSON value
  • » MongoDB Extended JSON
  • » MongoDB BSON


Returns the BSON representation of a PHP value

  • ? MongoDB\BSON\fromJSON
  • MongoDB\BSON\toCanonicalExtendedJSON ?
  • PHP Manual
  • 函数
  • Returns the BSON representation of a PHP value

MongoDB\BSON\fromPHP

(mongodb >=1.0.0)

MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value

说明

MongoDB\BSON\fromPHP ( array|object $value ) : string

Serializes a PHP array or object (e.g. document) to its » BSON representation. The returned binary string will describe a BSON document.

参数

value (array|object)

PHP value to be serialized.

返回值

The serialized BSON document as a binary string.

错误／异常

  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the PHP value cannot be converted to BSON. Possible reasons include, but are not limited to, encountering an unexpected MongoDB\BSON\Type instance or MongoDB\BSON\Serializable::bsonSerialize() failing to return an array or stdClass.

范例

Example #1 MongoDB\BSON\fromPHP() example

<?php

$bson = MongoDB\BSON\fromPHP(['foo' => 1]);
echo bin2hex($bson), "\n";

?>

以上例程会输出：

0e00000010666f6f000100000000cat

参见

  • MongoDB\BSON\toPHP() - Returns the PHP representation of a BSON value
  • » MongoDB BSON
  • Persisting Data


Returns the Canonical Extended JSON representation of a BSON value

  • ? MongoDB\BSON\fromPHP
  • MongoDB\BSON\toJSON ?
  • PHP Manual
  • 函数
  • Returns the Canonical Extended JSON representation of a BSON value

MongoDB\BSON\toCanonicalExtendedJSON

(mongodb >=1.3.0)

MongoDB\BSON\toCanonicalExtendedJSON — Returns the Canonical Extended JSON representation of a BSON value

说明

MongoDB\BSON\toCanonicalExtendedJSON ( string $bson ) : string

Converts a BSON string to its » Canonical Extended JSON representation. The canonical format prefers type fidelity at the expense of concise output and is most suited for producing output that can be converted back to BSON without any loss of type information (e.g. numeric types will remain differentiated).

参数

bson (string)

BSON value to be converted.

返回值

The converted JSON value.

错误／异常

  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the input did not contain exactly one BSON document. Possible reasons include, but are not limited to, invalid BSON, extra data (after reading one BSON document), or an unexpected » libbson error.

范例

Example #1 MongoDB\BSON\toCanonicalExtendedJSON() example

<?php

$documents = [
    [ 'null' => null ],
    [ 'boolean' => true ],
    [ 'string' => 'foo' ],
    [ 'int32' => 123 ],
    [ 'int64' => 4294967295 ],
    [ 'double' => 1.0, ],
    [ 'nan' => NAN ],
    [ 'pos_inf' => INF ],
    [ 'neg_inf' => -INF ],
    [ 'array' => [ 'foo', 'bar' ]],
    [ 'document' => [ 'foo' => 'bar' ]],
    [ 'oid' => new MongoDB\BSON\ObjectId('56315a7c6118fd1b920270b1') ],
    [ 'dec128' => new MongoDB\BSON\Decimal128('1234.5678') ],
    [ 'binary' => new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC) ],
    [ 'date' => new MongoDB\BSON\UTCDateTime(1445990400000) ],
    [ 'timestamp' => new MongoDB\BSON\Timestamp(1234, 5678) ],
    [ 'regex' => new MongoDB\BSON\Regex('pattern', 'i') ],
    [ 'code' => new MongoDB\BSON\Javascript('function() { return 1; }') ],
    [ 'code_ws' => new MongoDB\BSON\Javascript('function() { return a; }', ['a' => 1]) ],
    [ 'minkey' => new MongoDB\BSON\MinKey ],
    [ 'maxkey' => new MongoDB\BSON\MaxKey ],
];

foreach ($documents as $document) {
    $bson = MongoDB\BSON\fromPHP($document);
    echo MongoDB\BSON\toCanonicalExtendedJSON($bson), "\n";
}

?>

以上例程会输出：

{ "null" : null }
{ "boolean" : true }
{ "string" : "foo" }
{ "int32" : { "$numberInt" : "123" } }
{ "int64" : { "$numberLong" : "4294967295"} }
{ "double" : { "$numberDouble" : "1.0" } }
{ "nan" : { "$numberDouble" : "NaN" } }
{ "pos_inf" : { "$numberDouble" : "Infinity" } }
{ "neg_inf" : { "$numberDouble" : "-Infinity" } }
{ "array" : [ "foo", "bar" ] }
{ "document" : { "foo" : "bar" } }
{ "oid" : { "$oid" : "56315a7c6118fd1b920270b1" } }
{ "dec128" : { "$numberDecimal" : "1234.5678" } }
{ "binary" : { "$binary" : { "base64": "Zm9v", "subType" : "00" } } }
{ "date" : { "$date" : { "$numberLong" : "1445990400000" } } }
{ "timestamp" : { "$timestamp" : { "t" : 5678, "i" : 1234 } } }
{ "regex" : { "$regularExpression" : { "pattern" : "pattern", "options" : "i" } } }
{ "code" : { "$code" : "function() { return 1; }" } }
{ "code_ws" : { "$code" : "function() { return a; }", "$scope" : { "a" : { "$numberInt" : "1" } } } }
{ "minkey" : { "$minKey" : 1 } }
{ "maxkey" : { "$maxKey" : 1 } }

参见

  • MongoDB\BSON\fromJSON() - Returns the BSON representation of a JSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » Extended JSON Specification
  • » MongoDB BSON


Returns the Legacy Extended JSON representation of a BSON value

  • ? MongoDB\BSON\toCanonicalExtendedJSON
  • MongoDB\BSON\toPHP ?
  • PHP Manual
  • 函数
  • Returns the Legacy Extended JSON representation of a BSON value

MongoDB\BSON\toJSON

(mongodb >=1.0.0)

MongoDB\BSON\toJSON — Returns the Legacy Extended JSON representation of a BSON value

说明

MongoDB\BSON\toJSON ( string $bson ) : string

Converts a BSON string to its » Legacy Extended JSON representation.

Note: There exist several JSON formats for representing BSON. This function implements the "strict mode" defined in » MongoDB Extended JSON, which has been superseded by the canonical and relaxed formats defined in the » Extended JSON Specification and implemented by MongoDB\BSON\toCanonicalExtendedJSON() and MongoDB\BSON\toRelaxedExtendedJSON(), respectively.

Warning

» JSON does not support NAN and INF and MongoDB's Legacy Extended JSON format does not define an alternative representation for these values (» libbson will output nan and inf literals, which may not be parsed as valid JSON). If you are working with BSON that may contain non-finite numbers, please use MongoDB\BSON\toCanonicalExtendedJSON() or MongoDB\BSON\toRelaxedExtendedJSON().

参数

bson (string)

BSON value to be converted.

返回值

The converted JSON value.

错误／异常

  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the input did not contain exactly one BSON document. Possible reasons include, but are not limited to, invalid BSON, extra data (after reading one BSON document), or an unexpected » libbson error.

范例

Example #1 MongoDB\BSON\toJSON() example

<?php

$documents = [
    [ 'null' => null ],
    [ 'boolean' => true ],
    [ 'string' => 'foo' ],
    [ 'int32' => 123 ],
    [ 'int64' => 4294967295 ],
    [ 'double' => 1.0, ],
    [ 'nan' => NAN ],
    [ 'pos_inf' => INF ],
    [ 'neg_inf' => -INF ],
    [ 'array' => [ 'foo', 'bar' ]],
    [ 'document' => [ 'foo' => 'bar' ]],
    [ 'oid' => new MongoDB\BSON\ObjectId('56315a7c6118fd1b920270b1') ],
    [ 'dec128' => new MongoDB\BSON\Decimal128('1234.5678') ],
    [ 'binary' => new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC) ],
    [ 'date' => new MongoDB\BSON\UTCDateTime(1445990400000) ],
    [ 'timestamp' => new MongoDB\BSON\Timestamp(1234, 5678) ],
    [ 'regex' => new MongoDB\BSON\Regex('pattern', 'i') ],
    [ 'code' => new MongoDB\BSON\Javascript('function() { return 1; }') ],
    [ 'code_ws' => new MongoDB\BSON\Javascript('function() { return a; }', ['a' => 1]) ],
    [ 'minkey' => new MongoDB\BSON\MinKey ],
    [ 'maxkey' => new MongoDB\BSON\MaxKey ],
];

foreach ($documents as $document) {
    $bson = MongoDB\BSON\fromPHP($document);
    echo MongoDB\BSON\toJSON($bson), "\n";
}

?>

以上例程会输出：

{ "null" : null }
{ "boolean" : true }
{ "string" : "foo" }
{ "int32" : 123 }
{ "int64" : 4294967295 }
{ "double" : 1.0 }
{ "nan" : nan }
{ "pos_inf" : inf }
{ "neg_inf" : -inf }
{ "array" : [ "foo", "bar" ] }
{ "document" : { "foo" : "bar" } }
{ "oid" : { "$oid" : "56315a7c6118fd1b920270b1" } }
{ "dec128" : { "$numberDecimal" : "1234.5678" } }
{ "binary" : { "$binary" : "Zm9v", "$type" : "00" } }
{ "date" : { "$date" : 1445990400000 } }
{ "timestamp" : { "$timestamp" : { "t" : 5678, "i" : 1234 } } }
{ "regex" : { "$regex" : "pattern", "$options" : "i" } }
{ "code" : { "$code" : "function() { return 1; }" } }
{ "code_ws" : { "$code" : "function() { return a; }", "$scope" : { "a" : 1 } } }
{ "minkey" : { "$minKey" : 1 } }
{ "maxkey" : { "$maxKey" : 1 } }

参见

  • MongoDB\BSON\fromJSON() - Returns the BSON representation of a JSON value
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON
  • » MongoDB BSON


Returns the PHP representation of a BSON value

  • ? MongoDB\BSON\toJSON
  • MongoDB\BSON\toRelaxedExtendedJSON ?
  • PHP Manual
  • 函数
  • Returns the PHP representation of a BSON value

MongoDB\BSON\toPHP

(mongodb >=1.0.0)

MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value

说明

MongoDB\BSON\toPHP ( string $bson , array $typeMap = array() ) : array|object

Unserializes a BSON document (i.e. binary string) to its PHP representation. The typeMap paramater may be used to control the PHP types used for converting BSON arrays and documents (both root and embedded).

Warning

Fields containing deprecated BSON types (i.e. undefined, symbol, DBPointer) are represented only by bare-bones objects of the classes MongoDB\BSON\Undefined, MongoDB\BSON\Symbol, and MongoDB\BSON\DBPointer, when converting BSON to PHP. These objects are created from BSON data and used for storing these types back into the database, but can not be instantiated as they have a private constructor.

参数

bson (string)

BSON value to be unserialized.

typeMap (array)

Type map configuration.

返回值

The unserialized PHP value.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException if a class in the type map cannot be instantiated or does not implement MongoDB\BSON\Unserializable.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the input did not contain exactly one BSON document. Possible reasons include, but are not limited to, invalid BSON, extra data (after reading one BSON document), or an unexpected » libbson error.

更新日志

版本 | 说明
PECL mongodb 1.4.0 | If the input contains an unsupported, deprecated BSON type, the driver will now no longer log a warning to the debug log, but instead will create an object representing this type.
PECL mongodb 1.3.2 | MongoDB\Driver\Exception\UnexpectedValueException is no longer thrown if the input contains an unsupported, deprecated BSON type. Such types will be ignored (as they were in versions before 1.3.0), although the driver will now log a warning to the debug log (see: mongodb.debug).
PECL mongodb 1.3.0 | MongoDB\Driver\Exception\UnexpectedValueException is thrown if the input contains an unsupported, deprecated BSON type. Previously, such types were ignored.

范例

Example #1 MongoDB\BSON\toPHP() example

<?php

$bson = hex2bin('0e00000010666f6f000100000000');
$value = MongoDB\BSON\toPHP($bson);
var_dump($value);

?>

以上例程会输出：

object(stdClass)#1 (1) {
  ["foo"]=>
  int(1)
}

参见

  • MongoDB\BSON\fromPHP() - Returns the BSON representation of a PHP value
  • » MongoDB BSON
  • Persisting Data


Returns the Relaxed Extended JSON representation of a BSON value

  • ? MongoDB\BSON\toPHP
  • MongoDB\BSON\Binary ?
  • PHP Manual
  • 函数
  • Returns the Relaxed Extended JSON representation of a BSON value

MongoDB\BSON\toRelaxedExtendedJSON

(mongodb >=1.3.0)

MongoDB\BSON\toRelaxedExtendedJSON — Returns the Relaxed Extended JSON representation of a BSON value

说明

MongoDB\BSON\toRelaxedExtendedJSON ( string $bson ) : string

Converts a BSON string to its » Relaxed Extended JSON representation. The relaxed format prefers use of JSON type primitives at the expense of type fidelity and is most suited for producing output that can be easily consumed by web APIs and humans.

参数

bson (string)

BSON value to be converted.

返回值

The converted JSON value.

错误／异常

  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the input did not contain exactly one BSON document. Possible reasons include, but are not limited to, invalid BSON, extra data (after reading one BSON document), or an unexpected » libbson error.

范例

Example #1 MongoDB\BSON\toRelaxedExtendedJSON() example

<?php

$documents = [
    [ 'null' => null ],
    [ 'boolean' => true ],
    [ 'string' => 'foo' ],
    [ 'int32' => 123 ],
    [ 'int64' => 4294967295 ],
    [ 'double' => 1.0, ],
    [ 'nan' => NAN ],
    [ 'pos_inf' => INF ],
    [ 'neg_inf' => -INF ],
    [ 'array' => [ 'foo', 'bar' ]],
    [ 'document' => [ 'foo' => 'bar' ]],
    [ 'oid' => new MongoDB\BSON\ObjectId('56315a7c6118fd1b920270b1') ],
    [ 'dec128' => new MongoDB\BSON\Decimal128('1234.5678') ],
    [ 'binary' => new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC) ],
    [ 'date' => new MongoDB\BSON\UTCDateTime(1445990400000) ],
    [ 'timestamp' => new MongoDB\BSON\Timestamp(1234, 5678) ],
    [ 'regex' => new MongoDB\BSON\Regex('pattern', 'i') ],
    [ 'code' => new MongoDB\BSON\Javascript('function() { return 1; }') ],
    [ 'code_ws' => new MongoDB\BSON\Javascript('function() { return a; }', ['a' => 1]) ],
    [ 'minkey' => new MongoDB\BSON\MinKey ],
    [ 'maxkey' => new MongoDB\BSON\MaxKey ],
];

foreach ($documents as $document) {
    $bson = MongoDB\BSON\fromPHP($document);
    echo MongoDB\BSON\toRelaxedExtendedJSON($bson), "\n";
}

?>

以上例程会输出：

{ "null" : null }
{ "boolean" : true }
{ "string" : "foo" }
{ "int32" : 123 }
{ "int64" : 4294967295 }
{ "double" : 1.0 }
{ "nan" : { "$numberDouble" : "NaN" } }
{ "pos_inf" : { "$numberDouble" : "Infinity" } }
{ "neg_inf" : { "$numberDouble" : "-Infinity" } }
{ "array" : [ "foo", "bar" ] }
{ "document" : { "foo" : "bar" } }
{ "oid" : { "$oid" : "56315a7c6118fd1b920270b1" } }
{ "dec128" : { "$numberDecimal" : "1234.5678" } }
{ "binary" : { "$binary" : { "base64": "Zm9v", "subType" : "00" } } }
{ "date" : { "$date" : "2015-10-28T00:00:00Z" } }
{ "timestamp" : { "$timestamp" : { "t" : 5678, "i" : 1234 } } }
{ "regex" : { "$regularExpression" : { "pattern" : "pattern", "options" : "i" } } }
{ "code" : { "$code" : "function() { return 1; }" } }
{ "code_ws" : { "$code" : "function() { return a; }", "$scope" : { "a" : 1 } } }
{ "minkey" : { "$minKey" : 1 } }
{ "maxkey" : { "$maxKey" : 1 } }

参见

  • MongoDB\BSON\fromJSON() - Returns the BSON representation of a JSON value
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • » Extended JSON
  • » MongoDB BSON


The MongoDB\BSON\Binary class

(mongodb >=1.0.0)

简介

BSON type for binary data (i.e. array of bytes). Binary values also have a subtype, which is used to indicate what kind of data is in the byte array. Subtypes from zero to 127 are predefined or reserved. Subtypes from 128-255 are user-defined.

类摘要

final MongoDB\BSON\Binary implements MongoDB\BSON\BinaryInterface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Constants */
const int TYPE_GENERIC = 0 ;
const int TYPE_FUNCTION = 1 ;
const int TYPE_OLD_BINARY = 2 ;
const int TYPE_OLD_UUID = 3 ;
const int TYPE_UUID = 4 ;
const int TYPE_MD5 = 5 ;
const int TYPE_ENCRYPTED = 6 ;
const int TYPE_USER_DEFINED = 128 ;
/* 方法 */
final public __construct ( string $data , int $type )
final public getData ( ) : string
final public getType ( ) : int
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

预定义常量

MongoDB\BSON\Binary::TYPE_GENERIC

Generic binary data.

MongoDB\BSON\Binary::TYPE_FUNCTION

Function.

MongoDB\BSON\Binary::TYPE_OLD_BINARY

Generic binary data (deprecated in favor of MongoDB\BSON\Binary::TYPE_GENERIC).

MongoDB\BSON\Binary::TYPE_OLD_UUID

Universally unique identifier (deprecated in favor of MongoDB\BSON\Binary::TYPE_UUID). When using this type, the Binary's data should be 16 bytes in length.

Historically, other drivers encoded values with this type based on their language conventions (e.g. varying endianness), which makes it non-portable. The PHP driver applies no special handling for encoding or decoding data with this type.

MongoDB\BSON\Binary::TYPE_UUID

Universally unique identifier. When using this type, the Binary's data should be 16 bytes in length and encoded according to » RFC 4122.

MongoDB\BSON\Binary::TYPE_MD5

MD5 hash. When using this type, the Binary's data should be 16 bytes in length.

MongoDB\BSON\Binary::TYPE_ENCRYPTED

Encrypted value. This subtype is used for client-side encryption.

MongoDB\BSON\Binary::TYPE_USER_DEFINED

User-defined type. While types between 0 and 127 are predefined or reserved, types between 128 and 255 are user-defined and may be used for anything.

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Implements MongoDB\BSON\BinaryInterface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\Binary::__construct — Construct a new Binary
  • MongoDB\BSON\Binary::getData — Returns the Binary's data
  • MongoDB\BSON\Binary::getType — Returns the Binary's type
  • MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Binary::serialize — Serialize a Binary
  • MongoDB\BSON\Binary::__toString — Returns the Binary's data
  • MongoDB\BSON\Binary::unserialize — Unserialize a Binary


Construct a new Binary

  • ? MongoDB\BSON\Binary
  • MongoDB\BSON\Binary::getData ?
  • PHP Manual
  • MongoDB\BSON\Binary
  • Construct a new Binary

MongoDB\BSON\Binary::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Binary::__construct — Construct a new Binary

说明

final public MongoDB\BSON\Binary::__construct ( string $data , int $type )

参数

data (string)

Binary data.

type (int)

Unsigned 8-bit integer denoting the data's type.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if type is not an unsigned 8-bit integer.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if type is MongoDB\BSON\Binary::TYPE_UUID or MongoDB\BSON\Binary::TYPE_OLD_UUID and data is not exactly 16 bytes in length.

更新日志

版本 | 说明
PECL mongodb 1.3.0 | MongoDB\Driver\Exception\InvalidArgumentException is thrown if type is MongoDB\BSON\Binary::TYPE_UUID or MongoDB\BSON\Binary::TYPE_OLD_UUID and data is not exactly 16 bytes in length.
PECL mongodb 1.1.3 | MongoDB\Driver\Exception\InvalidArgumentException is thrown if type is not an unsigned 8-bit integer.

范例

Example #1 MongoDB\BSON\Binary::__construct() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary);

?>

以上例程会输出：

object(MongoDB\BSON\Binary)#1 (2) {
  ["data"]=>
  string(3) "foo"
  ["type"]=>
  int(0)
}

参见

  • » BSON Types


Returns the Binary's data

  • ? MongoDB\BSON\Binary::__construct
  • MongoDB\BSON\Binary::getType ?
  • PHP Manual
  • MongoDB\BSON\Binary
  • Returns the Binary's data

MongoDB\BSON\Binary::getData

(mongodb >=1.0.0)

MongoDB\BSON\Binary::getData — Returns the Binary's data

说明

final public MongoDB\BSON\Binary::getData ( ) : string

参数

此函数没有参数。

返回值

Returns the Binary's data.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\Binary::getData() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary->getData());

?>

以上例程会输出：

string(3) "foo"

参见

  • » BSON Types


Returns the Binary's type

  • ? MongoDB\BSON\Binary::getData
  • MongoDB\BSON\Binary::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\Binary
  • Returns the Binary's type

MongoDB\BSON\Binary::getType

(mongodb >=1.0.0)

MongoDB\BSON\Binary::getType — Returns the Binary's type

说明

final public MongoDB\BSON\Binary::getType ( ) : int

参数

此函数没有参数。

返回值

Returns the Binary's type.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\Binary::getType() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary->getType());

?>

以上例程会输出：

int(0)

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\Binary::getType
  • MongoDB\BSON\Binary::serialize ?
  • PHP Manual
  • MongoDB\BSON\Binary
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Binary::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\Binary::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Binary.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Binary

  • ? MongoDB\BSON\Binary::jsonSerialize
  • MongoDB\BSON\Binary::__toString ?
  • PHP Manual
  • MongoDB\BSON\Binary
  • Serialize a Binary

MongoDB\BSON\Binary::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::serialize — Serialize a Binary

说明

final public MongoDB\BSON\Binary::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\Binary.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Binary::unserialize() - Unserialize a Binary
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the Binary's data

  • ? MongoDB\BSON\Binary::serialize
  • MongoDB\BSON\Binary::unserialize ?
  • PHP Manual
  • MongoDB\BSON\Binary
  • Returns the Binary's data

MongoDB\BSON\Binary::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Binary::__toString — Returns the Binary's data

说明

final public MongoDB\BSON\Binary::__toString ( ) : string

此方法是该方法的别名： MongoDB\BSON\Binary::getData().

参数

此函数没有参数。

返回值

Returns the Binary's data.

范例

Example #1 MongoDB\BSON\Binary::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC));

?>

以上例程会输出：

string(3) "foo"

参见

  • MongoDB\BSON\Binary::getData() - Returns the Binary's data
  • » BSON Types


Unserialize a Binary

  • ? MongoDB\BSON\Binary::__toString
  • MongoDB\BSON\Decimal128 ?
  • PHP Manual
  • MongoDB\BSON\Binary
  • Unserialize a Binary

MongoDB\BSON\Binary::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::unserialize — Unserialize a Binary

说明

final public MongoDB\BSON\Binary::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\Binary.

返回值

Returns the unserialized MongoDB\BSON\Binary.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\BSON\Binary::serialize() - Serialize a Binary
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\Decimal128 class

(mongodb >=1.2.0)

简介

BSON type for the » Decimal128 floating-point format, which supports numbers with up to 34 decimal digits (i.e. significant digits) and an exponent range of ?6143 to +6144.

Unlike the double BSON type (i.e. float in PHP), which only stores an approximation of the decimal values, the decimal data type stores the exact value. For example, MongoDB\BSON\Decimal128('9.99') has a precise value of 9.99 where as a double 9.99 would have an approximate value of 9.9900000000000002131628....

Note: MongoDB\BSON\Decimal128 is only compatible with MongoDB 3.4+. Attempting to use the BSON type with an earlier version of MongoDB will result in an error.

类摘要

final MongoDB\BSON\Decimal128 implements MongoDB\BSON\Decimal128Interface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final public __construct ( string $value = ? )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Implements MongoDB\BSON\Decimal128Interface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128
  • MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128
  • MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128
  • MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128


Construct a new Decimal128

  • ? MongoDB\BSON\Decimal128
  • MongoDB\BSON\Decimal128::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Construct a new Decimal128

MongoDB\BSON\Decimal128::__construct

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128

说明

final public MongoDB\BSON\Decimal128::__construct ( string $value = ? )

Note: MongoDB\BSON\Decimal128 is only compatible with MongoDB 3.4+. Attempting to use the BSON type with an earlier version of MongoDB will result in an error.

参数

value (string)

A decimal string.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if value is not a valid decimal string.

范例

Example #1 MongoDB\BSON\Decimal128::__construct() example

<?php

var_dump(new MongoDB\BSON\Decimal128(1234.5678));
var_dump(new MongoDB\BSON\Decimal128(NAN));
var_dump(new MongoDB\BSON\Decimal128(INF));

?>

以上例程的输出类似于：

object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(9) "1234.5678"
}
object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(3) "NaN"
}
object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(8) "Infinity"
}

参见

  • » Decimal128 floating-point format
  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\Decimal128::__construct
  • MongoDB\BSON\Decimal128::serialize ?
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Decimal128::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\Decimal128::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Decimal128.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Decimal128

  • ? MongoDB\BSON\Decimal128::jsonSerialize
  • MongoDB\BSON\Decimal128::__toString ?
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Serialize a Decimal128

MongoDB\BSON\Decimal128::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128

说明

final public MongoDB\BSON\Decimal128::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\Decimal128.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Decimal128::unserialize() - Unserialize a Decimal128
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the string representation of this Decimal128

  • ? MongoDB\BSON\Decimal128::serialize
  • MongoDB\BSON\Decimal128::unserialize ?
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Returns the string representation of this Decimal128

MongoDB\BSON\Decimal128::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128

说明

final public MongoDB\BSON\Decimal128::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this Decimal128.

范例

Example #1 MongoDB\BSON\Decimal128::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Decimal128(1234.5678));
var_dump((string) new MongoDB\BSON\Decimal128(NAN));
var_dump((string) new MongoDB\BSON\Decimal128(INF));

?>

以上例程的输出类似于：

string(9) "1234.5678"
string(3) "NaN"
string(8) "Infinity"

参见

  • » Decimal128 floating-point format
  • » BSON Types


Unserialize a Decimal128

  • ? MongoDB\BSON\Decimal128::__toString
  • MongoDB\BSON\Javascript ?
  • PHP Manual
  • MongoDB\BSON\Decimal128
  • Unserialize a Decimal128

MongoDB\BSON\Decimal128::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128

说明

final public MongoDB\BSON\Decimal128::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\Decimal128.

返回值

Returns the unserialized MongoDB\BSON\Decimal128.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\BSON\Decimal128::serialize() - Serialize a Decimal128
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\Javascript class

(mongodb >=1.0.0)

简介

BSON type for Javascript code. An optional scope document may be specified that maps identifiers to values and defines the scope in which the code should be evaluated by the server.

Note: This BSON type is mainly used when executing database commands that take a Javascript function as a parameter, such as » mapReduce.

类摘要

final MongoDB\BSON\Javascript implements MongoDB\BSON\JavascriptInterface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final public __construct ( string $code , array|object $scope = ? )
final public getCode ( ) : string
final public getScope ( ) : object|null
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Implements MongoDB\BSON\JavascriptInterface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\Javascript::__construct — Construct a new Javascript
  • MongoDB\BSON\Javascript::getCode — Returns the Javascript's code
  • MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document
  • MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Javascript::serialize — Serialize a Javascript
  • MongoDB\BSON\Javascript::__toString — Returns the Javascript's code
  • MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript


Construct a new Javascript

  • ? MongoDB\BSON\Javascript
  • MongoDB\BSON\Javascript::getCode ?
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Construct a new Javascript

MongoDB\BSON\Javascript::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Javascript::__construct — Construct a new Javascript

说明

final public MongoDB\BSON\Javascript::__construct ( string $code , array|object $scope = ? )

参数

code (string)

Javascript code.

scope (array|object)

Javascript scope.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if code contains null bytes.

更新日志

版本 | 说明
PECL mongodb 1.2.0 | MongoDB\Driver\Exception\InvalidArgumentException is thrown if code contains null bytes. Previously, values would be truncated at the first null byte.

范例

Example #1 MongoDB\BSON\Javascript::__construct() example

<?php

$code = new MongoDB\BSON\Javascript('function() { return 1; }');
var_dump($code);

$codews = new MongoDB\BSON\Javascript('function() { return foo; }', ['foo' => 'bar']);
var_dump($codews);

?>

以上例程会输出：

object(MongoDB\BSON\Javascript)#1 (2) {
  ["javascript"]=>
  string(24) "function() { return 1; }"
  ["scope"]=>
  object(stdClass)#2 (0) {
  }
}
object(MongoDB\BSON\Javascript)#2 (2) {
  ["javascript"]=>
  string(26) "function() { return foo; }"
  ["scope"]=>
  object(stdClass)#1 (1) {
    ["foo"]=>
    string(3) "bar"
  }
}

参见

  • » BSON Types


Returns the Javascript's code

  • ? MongoDB\BSON\Javascript::__construct
  • MongoDB\BSON\Javascript::getScope ?
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Returns the Javascript's code

MongoDB\BSON\Javascript::getCode

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::getCode — Returns the Javascript's code

说明

final public MongoDB\BSON\Javascript::getCode ( ) : string

参数

此函数没有参数。

返回值

Returns the Javascript's code.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\Javascript::getCode() example

<?php

$js = new MongoDB\BSON\Javascript('function foo(bar) { return bar; }');
var_dump($js->getCode());

?>

以上例程会输出：

string(33) "function foo(bar) { return bar; }"

参见

  • » BSON Types


Returns the Javascript's scope document

  • ? MongoDB\BSON\Javascript::getCode
  • MongoDB\BSON\Javascript::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Returns the Javascript's scope document

MongoDB\BSON\Javascript::getScope

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document

说明

final public MongoDB\BSON\Javascript::getScope ( ) : object|null

参数

此函数没有参数。

返回值

Returns the Javascript's scope document, or null if the is no scope.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\Javascript::getScope() example

<?php

$js = new MongoDB\BSON\Javascript('function foo(bar) { return bar; }');
var_dump($js->getScope());

$js = new MongoDB\BSON\Javascript('function foo() { return foo; }', ['foo' => 42]);
var_dump($js->getScope());

?>

以上例程会输出：

NULL
object(stdClass)#1 (1) {
  ["foo"]=>
  int(42)
}

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\Javascript::getScope
  • MongoDB\BSON\Javascript::serialize ?
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Javascript::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\Javascript::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Javascript.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Javascript

  • ? MongoDB\BSON\Javascript::jsonSerialize
  • MongoDB\BSON\Javascript::__toString ?
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Serialize a Javascript

MongoDB\BSON\Javascript::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::serialize — Serialize a Javascript

说明

final public MongoDB\BSON\Javascript::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\Javascript.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Javascript::unserialize() - Unserialize a Javascript
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the Javascript's code

  • ? MongoDB\BSON\Javascript::serialize
  • MongoDB\BSON\Javascript::unserialize ?
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Returns the Javascript's code

MongoDB\BSON\Javascript::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::__toString — Returns the Javascript's code

说明

final public MongoDB\BSON\Javascript::__toString ( ) : string

此方法是该方法的别名： MongoDB\BSON\Javascript::getCode().

参数

此函数没有参数。

返回值

Returns the Javascript's code.

范例

Example #1 MongoDB\BSON\Javascript::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Javascript('function foo(bar) { return bar; }'));

?>

以上例程会输出：

string(33) "function foo(bar) { return bar; }"

参见

  • MongoDB\BSON\Javascript::getCode() - Returns the Javascript's code
  • » BSON Types


Unserialize a Javascript

  • ? MongoDB\BSON\Javascript::__toString
  • MongoDB\BSON\MaxKey ?
  • PHP Manual
  • MongoDB\BSON\Javascript
  • Unserialize a Javascript

MongoDB\BSON\Javascript::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript

说明

final public MongoDB\BSON\Javascript::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\Javascript.

返回值

Returns the unserialized MongoDB\BSON\Javascript.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\BSON\Javascript::serialize() - Serialize a Javascript
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\MaxKey class

(mongodb >=1.0.0)

简介

Special BSON type which compares higher than all other possible BSON element values.

Note: This is an internal MongoDB type used for indexing and sharding.

类摘要

final MongoDB\BSON\MaxKey implements MongoDB\BSON\MaxKeyInterface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final public __construct ( )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Implements MongoDB\BSON\MaxKeyInterface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey
  • MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey
  • MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey


Construct a new MaxKey

  • ? MongoDB\BSON\MaxKey
  • MongoDB\BSON\MaxKey::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\MaxKey
  • Construct a new MaxKey

MongoDB\BSON\MaxKey::__construct

(mongodb >=1.0.0)

MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey

说明

final public MongoDB\BSON\MaxKey::__construct ( )

参数

此函数没有参数。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\MaxKey::__construct() example

<?php

var_dump(new MongoDB\BSON\MaxKey());

?>

以上例程会输出：

object(MongoDB\BSON\MaxKey)#1 (0) {
}

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\MaxKey::__construct
  • MongoDB\BSON\MaxKey::serialize ?
  • PHP Manual
  • MongoDB\BSON\MaxKey
  • Returns a representation that can be converted to JSON

MongoDB\BSON\MaxKey::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\MaxKey::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\MaxKey.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a MaxKey

  • ? MongoDB\BSON\MaxKey::jsonSerialize
  • MongoDB\BSON\MaxKey::unserialize ?
  • PHP Manual
  • MongoDB\BSON\MaxKey
  • Serialize a MaxKey

MongoDB\BSON\MaxKey::serialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey

说明

final public MongoDB\BSON\MaxKey::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\MaxKey.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\MaxKey::unserialize() - Unserialize a MaxKey
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Unserialize a MaxKey

  • ? MongoDB\BSON\MaxKey::serialize
  • MongoDB\BSON\MinKey ?
  • PHP Manual
  • MongoDB\BSON\MaxKey
  • Unserialize a MaxKey

MongoDB\BSON\MaxKey::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey

说明

final public MongoDB\BSON\MaxKey::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\MaxKey.

返回值

Returns the unserialized MongoDB\BSON\MaxKey.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\MaxKey::serialize() - Serialize a MaxKey
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\MinKey class

(mongodb >=1.0.0)

简介

Special BSON type which compares lower than all other possible BSON element values.

Note: This is an internal MongoDB type used for indexing and sharding.

类摘要

final MongoDB\BSON\MinKey implements MongoDB\BSON\MinKeyInterface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final public __construct ( )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Implements MongoDB\BSON\MinKeyInterface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\MinKey::__construct — Construct a new MinKey
  • MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\MinKey::serialize — Serialize a MinKey
  • MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey


Construct a new MinKey

  • ? MongoDB\BSON\MinKey
  • MongoDB\BSON\MinKey::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\MinKey
  • Construct a new MinKey

MongoDB\BSON\MinKey::__construct

(mongodb >=1.0.0)

MongoDB\BSON\MinKey::__construct — Construct a new MinKey

说明

final public MongoDB\BSON\MinKey::__construct ( )

参数

此函数没有参数。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\MinKey::__construct() example

<?php

var_dump(new MongoDB\BSON\MinKey());

?>

以上例程会输出：

object(MongoDB\BSON\MinKey)#1 (0) {
}

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\MinKey::__construct
  • MongoDB\BSON\MinKey::serialize ?
  • PHP Manual
  • MongoDB\BSON\MinKey
  • Returns a representation that can be converted to JSON

MongoDB\BSON\MinKey::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\MinKey::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\MinKey.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a MinKey

  • ? MongoDB\BSON\MinKey::jsonSerialize
  • MongoDB\BSON\MinKey::unserialize ?
  • PHP Manual
  • MongoDB\BSON\MinKey
  • Serialize a MinKey

MongoDB\BSON\MinKey::serialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::serialize — Serialize a MinKey

说明

final public MongoDB\BSON\MinKey::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\MinKey.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\MinKey::unserialize() - Unserialize a MinKey
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Unserialize a MinKey

  • ? MongoDB\BSON\MinKey::serialize
  • MongoDB\BSON\ObjectId ?
  • PHP Manual
  • MongoDB\BSON\MinKey
  • Unserialize a MinKey

MongoDB\BSON\MinKey::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey

说明

final public MongoDB\BSON\MinKey::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\MinKey.

返回值

Returns the unserialized MongoDB\BSON\MinKey.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\MinKey::serialize() - Serialize a MinKey
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\ObjectId class

(mongodb >=1.0.0)

简介

BSON type for an » ObjectId. The value consists of 12 bytes, where the first four bytes are a timestamp that reflect the ObjectId's creation. Specifically, the value consists of:

  • a 4-byte value representing the seconds since the Unix epoch,
  • a 5-byte random number unique to a machine and process, and
  • a 3-byte counter, starting with a random value.

In MongoDB, each document stored in a collection requires a unique _id field that acts as a primary key. If an inserted document omits the _id field, the driver automatically generates an ObjectId for the _id field.

Using ObjectIds for the _id field provides the following additional benefits:

  • The creation time of the ObjectId may be accessed using the MongoDB\BSON\ObjectId::getTimestamp() method.
  • Sorting on an _id field that stores ObjectId values is roughly equivalent to sorting by creation time.

类摘要

final MongoDB\BSON\ObjectId implements MongoDB\BSON\ObjectIdInterface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final public __construct ( string $id = ? )
final public getTimestamp ( ) : int
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Renamed from MongoDB\BSON\ObjectID to MongoDB\BSON\ObjectId. Implements MongoDB\BSON\ObjectIdInterface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\ObjectId::__construct — Construct a new ObjectId
  • MongoDB\BSON\ObjectId::getTimestamp — Returns the timestamp component of this ObjectId
  • MongoDB\BSON\ObjectId::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\ObjectId::serialize — Serialize an ObjectId
  • MongoDB\BSON\ObjectId::__toString — Returns the hexidecimal representation of this ObjectId
  • MongoDB\BSON\ObjectId::unserialize — Unserialize an ObjectId


Construct a new ObjectId

  • ? MongoDB\BSON\ObjectId
  • MongoDB\BSON\ObjectId::getTimestamp ?
  • PHP Manual
  • MongoDB\BSON\ObjectId
  • Construct a new ObjectId

MongoDB\BSON\ObjectId::__construct

(mongodb >=1.0.0)

MongoDB\BSON\ObjectId::__construct — Construct a new ObjectId

说明

final public MongoDB\BSON\ObjectId::__construct ( string $id = ? )

参数

id (string)

A 24-character hexadecimal string. If not provided, the driver will generate an ObjectId.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if id is not a 24-character hexadecimal string.

范例

Example #1 MongoDB\BSON\ObjectId::__construct() example

<?php

var_dump(new MongoDB\BSON\ObjectId());

var_dump(new MongoDB\BSON\ObjectId('000000000000000000000001'));

?>

以上例程的输出类似于：

object(MongoDB\BSON\ObjectId)#1 (1) {
  ["oid"]=>
  string(24) "56732d3dda14d81214634921"
}
object(MongoDB\BSON\ObjectId)#1 (1) {
  ["oid"]=>
  string(24) "000000000000000000000001"
}

参见

  • » ObjectId Reference
  • » BSON Types: ObjectId


Returns the timestamp component of this ObjectId

  • ? MongoDB\BSON\ObjectId::__construct
  • MongoDB\BSON\ObjectId::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\ObjectId
  • Returns the timestamp component of this ObjectId

MongoDB\BSON\ObjectId::getTimestamp

(mongodb >=1.2.0)

MongoDB\BSON\ObjectId::getTimestamp — Returns the timestamp component of this ObjectId

说明

final public MongoDB\BSON\ObjectId::getTimestamp ( ) : int

The timestamp component of an ObjectId is its most significant 32 bits, which denotes the number of seconds since the Unix epoch. This value is read as an unsigned 32-bit integer with big-endian byte order.

Note: Because PHP's integer type is signed, some values returned by this method may appear as negative integers on 32-bit platforms. The "%u" formatter of sprintf() may be used to obtain a string representation of the unsigned decimal value.

参数

此函数没有参数。

返回值

Returns the timestamp component of this ObjectId.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\ObjectId::getTimestamp() example

<?php

var_dump((new MongoDB\BSON\ObjectId())->getTimestamp());

var_dump((new MongoDB\BSON\ObjectId('0000002a0000000000000000'))->getTimestamp());

?>

以上例程的输出类似于：

integer(1484854719)
integer(42)

参见

  • » ObjectId Reference
  • » BSON Types: ObjectId


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\ObjectId::getTimestamp
  • MongoDB\BSON\ObjectId::serialize ?
  • PHP Manual
  • MongoDB\BSON\ObjectId
  • Returns a representation that can be converted to JSON

MongoDB\BSON\ObjectId::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectId::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\ObjectId::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\ObjectId.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize an ObjectId

  • ? MongoDB\BSON\ObjectId::jsonSerialize
  • MongoDB\BSON\ObjectId::__toString ?
  • PHP Manual
  • MongoDB\BSON\ObjectId
  • Serialize an ObjectId

MongoDB\BSON\ObjectId::serialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectId::serialize — Serialize an ObjectId

说明

final public MongoDB\BSON\ObjectId::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\ObjectId.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\ObjectId::unserialize() - Unserialize an ObjectId
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the hexidecimal representation of this ObjectId

  • ? MongoDB\BSON\ObjectId::serialize
  • MongoDB\BSON\ObjectId::unserialize ?
  • PHP Manual
  • MongoDB\BSON\ObjectId
  • Returns the hexidecimal representation of this ObjectId

MongoDB\BSON\ObjectId::__toString

(mongodb >=1.0.0)

MongoDB\BSON\ObjectId::__toString — Returns the hexidecimal representation of this ObjectId

说明

final public MongoDB\BSON\ObjectId::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the hexidecimal representation of this ObjectId.

范例

Example #1 MongoDB\BSON\ObjectId::__toString() example

<?php

var_dump((string) new MongoDB\BSON\ObjectId());
var_dump((string) new MongoDB\BSON\ObjectId('000000000000000000000001'));

?>

以上例程的输出类似于：

string(24) "56731b49da14d8747d701211"
string(24) "000000000000000000000001"

参见

  • » ObjectId Reference
  • » BSON Types: ObjectId


Unserialize an ObjectId

  • ? MongoDB\BSON\ObjectId::__toString
  • MongoDB\BSON\Regex ?
  • PHP Manual
  • MongoDB\BSON\ObjectId
  • Unserialize an ObjectId

MongoDB\BSON\ObjectId::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectId::unserialize — Unserialize an ObjectId

说明

final public MongoDB\BSON\ObjectId::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\ObjectId.

返回值

Returns the unserialized MongoDB\BSON\ObjectId.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\BSON\ObjectId::serialize() - Serialize an ObjectId
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\Regex class

(mongodb >=1.0.0)

简介

BSON type for a regular expression pattern and optional » flags.

Note: This BSON type is mainly used when querying the database. Alternatively, the » $regex query operator may be used.

类摘要

final MongoDB\BSON\Regex implements MongoDB\BSON\RegexInterface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final public __construct ( string $pattern , string $flags = "" )
final public getFlags ( ) : string
final public getPattern ( ) : string
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Implements MongoDB\BSON\RegexInterface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\Regex::__construct — Construct a new Regex
  • MongoDB\BSON\Regex::getFlags — Returns the Regex's flags
  • MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern
  • MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Regex::serialize — Serialize a Regex
  • MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex
  • MongoDB\BSON\Regex::unserialize — Unserialize a Regex


Construct a new Regex

  • ? MongoDB\BSON\Regex
  • MongoDB\BSON\Regex::getFlags ?
  • PHP Manual
  • MongoDB\BSON\Regex
  • Construct a new Regex

MongoDB\BSON\Regex::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Regex::__construct — Construct a new Regex

说明

final public MongoDB\BSON\Regex::__construct ( string $pattern , string $flags = "" )

参数

pattern (string)

The regular expression pattern.

Note: The pattern should not be wrapped with delimiter characters.

flags (string)

The » regular expression flags. Characters in this argument will be sorted alphabetically.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if pattern or flags contain null bytes.

更新日志

版本 说明
PECL mongodb 1.2.0

The flags argument is optional and defaults to an empty string.

Characters in the flags argument will be sorted alphabetically when a Regex is constructed. Previously, the characters were stored in the order provided.

MongoDB\Driver\Exception\InvalidArgumentException is thrown if pattern or flags contain null bytes. Previously, values would be truncated at the first null byte.

范例

Example #1 MongoDB\BSON\Regex::__construct() example

<?php

$regex = new MongoDB\BSON\Regex('^foo', 'i');
var_dump($regex);

?>

以上例程会输出：

object(MongoDB\BSON\Regex)#1 (2) {
  ["pattern"]=>
  string(4) "^foo"
  ["flags"]=>
  string(1) "i"
}

参见

  • » BSON Types
  • » Supported regular expression flags


Returns the Regex's flags

  • ? MongoDB\BSON\Regex::__construct
  • MongoDB\BSON\Regex::getPattern ?
  • PHP Manual
  • MongoDB\BSON\Regex
  • Returns the Regex's flags

MongoDB\BSON\Regex::getFlags

(mongodb >=1.0.0)

MongoDB\BSON\Regex::getFlags — Returns the Regex's flags

说明

final public MongoDB\BSON\Regex::getFlags ( ) : string

参数

此函数没有参数。

返回值

Returns the Regex's flags.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\Regex::getFlags() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump($regex->getFlags());

?>

以上例程的输出类似于：

string(1) "i"

参见

  • » BSON Types
  • » Supported regular expression flags


Returns the Regex's pattern

  • ? MongoDB\BSON\Regex::getFlags
  • MongoDB\BSON\Regex::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\Regex
  • Returns the Regex's pattern

MongoDB\BSON\Regex::getPattern

(mongodb >=1.0.0)

MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern

说明

final public MongoDB\BSON\Regex::getPattern ( ) : string

参数

此函数没有参数。

返回值

Returns the Regex's pattern.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\Regex::getPattern() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump($regex->getPattern());

?>

以上例程的输出类似于：

string(5) "regex"

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\Regex::getPattern
  • MongoDB\BSON\Regex::serialize ?
  • PHP Manual
  • MongoDB\BSON\Regex
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Regex::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\Regex::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Regex.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Regex

  • ? MongoDB\BSON\Regex::jsonSerialize
  • MongoDB\BSON\Regex::__toString ?
  • PHP Manual
  • MongoDB\BSON\Regex
  • Serialize a Regex

MongoDB\BSON\Regex::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::serialize — Serialize a Regex

说明

final public MongoDB\BSON\Regex::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\Regex.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Regex::unserialize() - Unserialize a Regex
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the string representation of this Regex

  • ? MongoDB\BSON\Regex::serialize
  • MongoDB\BSON\Regex::unserialize ?
  • PHP Manual
  • MongoDB\BSON\Regex
  • Returns the string representation of this Regex

MongoDB\BSON\Regex::__toString

(mongodb >=1.0.0)

MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex

说明

final public MongoDB\BSON\Regex::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this Regex.

范例

Example #1 MongoDB\BSON\Regex::__toString() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump((string) $regex);

?>

以上例程会输出：

string(8) "/regex/i"

参见

  • » BSON Types


Unserialize a Regex

  • ? MongoDB\BSON\Regex::__toString
  • MongoDB\BSON\Timestamp ?
  • PHP Manual
  • MongoDB\BSON\Regex
  • Unserialize a Regex

MongoDB\BSON\Regex::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::unserialize — Unserialize a Regex

说明

final public MongoDB\BSON\Regex::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\Regex.

返回值

Returns the unserialized MongoDB\BSON\Regex.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\BSON\Regex::serialize() - Serialize a Regex
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\Timestamp class

(mongodb >=1.0.0)

简介

Represents a » BSON timestamp, The value consists of a 4-byte timestamp (i.e. seconds since the epoch) and a 4-byte increment.

Note: This is an internal MongoDB type used for replication and sharding. It is not intended for general date storage (MongoDB\BSON\UTCDateTime should be used instead).

类摘要

final MongoDB\BSON\Timestamp implements MongoDB\BSON\TimestampInterface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final public __construct ( int $increment , int $timestamp )
final public getIncrement ( ) : int
final public getTimestamp ( ) : int
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Implements MongoDB\BSON\TimestampInterface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp
  • MongoDB\BSON\Timestamp::getIncrement — Returns the increment component of this Timestamp
  • MongoDB\BSON\Timestamp::getTimestamp — Returns the timestamp component of this Timestamp
  • MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp
  • MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp
  • MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp


Construct a new Timestamp

  • ? MongoDB\BSON\Timestamp
  • MongoDB\BSON\Timestamp::getIncrement ?
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Construct a new Timestamp

MongoDB\BSON\Timestamp::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp

说明

final public MongoDB\BSON\Timestamp::__construct ( int $increment , int $timestamp )

参数

increment (int)

32-bit integer denoting the incrementing ordinal for operations within a given second.

timestamp (int)

32-bit integer denoting seconds since the Unix epoch.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\Timestamp::__construct() example

<?php

$timestamp = new MongoDB\BSON\Timestamp(1234, 5678);

?>

以上例程会输出：

object(MongoDB\BSON\Timestamp)#1 (2) {
  ["increment"]=>
  int(1234)
  ["timestamp"]=>
  int(5678)
}

参见

  • » BSON Types: Timestamps


Returns the increment component of this Timestamp

  • ? MongoDB\BSON\Timestamp::__construct
  • MongoDB\BSON\Timestamp::getTimestamp ?
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Returns the increment component of this Timestamp

MongoDB\BSON\Timestamp::getIncrement

(mongodb >=1.3.0)

MongoDB\BSON\Timestamp::getIncrement — Returns the increment component of this Timestamp

说明

final public MongoDB\BSON\Timestamp::getIncrement ( ) : int

The increment component of a Timestamp is its least significant 32 bits, whichs denotes the incrementing ordinal for operations within a given second. This value is read as an unsigned 32-bit integer with big-endian byte order.

Note: Because PHP's integer type is signed, some values returned by this method may appear as negative integers on 32-bit platforms. The "%u" formatter of sprintf() may be used to obtain a string representation of the unsigned decimal value.

参数

此函数没有参数。

返回值

Returns the increment component of this Timestamp.

Warning

On 32-bit systems this method may return a negative number. Although the increment and timestamp parts of the BSON timestamp type consists of two unsigned 32-bit values, PHP can not represent these on 32-bit platforms.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • » BSON Types: Timestamps


Returns the timestamp component of this Timestamp

  • ? MongoDB\BSON\Timestamp::getIncrement
  • MongoDB\BSON\Timestamp::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Returns the timestamp component of this Timestamp

MongoDB\BSON\Timestamp::getTimestamp

(mongodb >=1.3.0)

MongoDB\BSON\Timestamp::getTimestamp — Returns the timestamp component of this Timestamp

说明

final public MongoDB\BSON\Timestamp::getTimestamp ( ) : int

The timestamp component of a Timestamp is its most significant 32 bits, which denotes the number of seconds since the Unix epoch. This value is read as an unsigned 32-bit integer with big-endian byte order.

Note: Because PHP's integer type is signed, some values returned by this method may appear as negative integers on 32-bit platforms. The "%u" formatter of sprintf() may be used to obtain a string representation of the unsigned decimal value.

参数

此函数没有参数。

返回值

Returns the timestamp component of this Timestamp.

Warning

On 32-bit systems this method may return a negative number. Although the increment and timestamp parts of the BSON timestamp type consists of two unsigned 32-bit values, PHP can not represent these on 32-bit platforms.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • » BSON Types: Timestamps


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\Timestamp::getTimestamp
  • MongoDB\BSON\Timestamp::serialize ?
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Timestamp::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\Timestamp::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Timestamp.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Timestamp

  • ? MongoDB\BSON\Timestamp::jsonSerialize
  • MongoDB\BSON\Timestamp::__toString ?
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Serialize a Timestamp

MongoDB\BSON\Timestamp::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp

说明

final public MongoDB\BSON\Timestamp::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\Timestamp.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Timestamp::unserialize() - Unserialize a Timestamp
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the string representation of this Timestamp

  • ? MongoDB\BSON\Timestamp::serialize
  • MongoDB\BSON\Timestamp::unserialize ?
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Returns the string representation of this Timestamp

MongoDB\BSON\Timestamp::__toString

(mongodb >=1.0.0)

MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp

说明

final public MongoDB\BSON\Timestamp::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this Timestamp.

范例

Example #1 MongoDB\BSON\Timestamp::__toString() example

<?php

$timestamp = new MongoDB\BSON\Timestamp(1234, 5678);
var_dump((string) $timestamp);

?>

以上例程的输出类似于：

string(11) "[1234:5678]"

参见

  • » BSON Types: Timestamps


Unserialize a Timestamp

  • ? MongoDB\BSON\Timestamp::__toString
  • MongoDB\BSON\UTCDateTime ?
  • PHP Manual
  • MongoDB\BSON\Timestamp
  • Unserialize a Timestamp

MongoDB\BSON\Timestamp::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp

说明

final public MongoDB\BSON\Timestamp::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\Timestamp.

返回值

Returns the unserialized MongoDB\BSON\Timestamp.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\BSON\Timestamp::serialize() - Serialize a Timestamp
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\UTCDateTime class

(mongodb >=1.0.0)

简介

Represents a » BSON date. The value is a 64-bit integer that represents the number of milliseconds since the Unix epoch (Jan 1, 1970). Negative values represent dates before 1970.

类摘要

final MongoDB\BSON\UTCDateTime implements MongoDB\BSON\UTCDateTimeInterface , MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final public __construct ( int|float|string|DateTimeInterface $milliseconds = null )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public toDateTime ( ) : DateTime
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.3.0 | Implements MongoDB\BSON\UTCDateTimeInterface.
PECL mongodb 1.2.0 | Implements Serializable and JsonSerializable.

Table of Contents

  • MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime
  • MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime
  • MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime
  • MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime
  • MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime


Construct a new UTCDateTime

  • ? MongoDB\BSON\UTCDateTime
  • MongoDB\BSON\UTCDateTime::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Construct a new UTCDateTime

MongoDB\BSON\UTCDateTime::__construct

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime

说明

final public MongoDB\BSON\UTCDateTime::__construct ( int|float|string|DateTimeInterface $milliseconds = null )

参数

milliseconds (int|float|string|DateTimeInterface)

Number of milliseconds since the Unix epoch (Jan 1, 1970). Negative values represent dates before 1970. This value may be provided as a 64-bit int. For compatibility on 32-bit systems, this parameter may also be provided as a float or string.

If the argument is a DateTimeInterface, the number of milliseconds since the Unix epoch will be derived from that value. Note that in versions of PHP versions before 7.1.0, DateTime and DateTimeImmutable objects constructed from the current time did not incorporate sub-second precision.

If this argument is null, the current time will be used by default.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

更新日志

版本 | 说明
PECL mongodb 1.2.0 | The milliseconds argument is optional and defaults to null (i.e. current time). The argument also accepts a DateTimeInterface, which may be used to derive the number of milliseconds since the Unix epoch. Previously, only int, float, and string types were accepted.

范例

Example #1 MongoDB\BSON\UTCDateTime::__construct() example

<?php

var_dump(new MongoDB\BSON\UTCDateTime);

var_dump(new MongoDB\BSON\UTCDateTime(new DateTime));

var_dump(new MongoDB\BSON\UTCDateTime(1416445411987));

?>

以上例程的输出类似于：

object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1484852905560"
}
object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1484852905560"
}
object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1416445411987"
}

参见

  • » BSON Types: Date


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\UTCDateTime::__construct
  • MongoDB\BSON\UTCDateTime::serialize ?
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Returns a representation that can be converted to JSON

MongoDB\BSON\UTCDateTime::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\UTCDateTime::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\UTCDateTime.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a UTCDateTime

  • ? MongoDB\BSON\UTCDateTime::jsonSerialize
  • MongoDB\BSON\UTCDateTime::toDateTime ?
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Serialize a UTCDateTime

MongoDB\BSON\UTCDateTime::serialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime

说明

final public MongoDB\BSON\UTCDateTime::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\UTCDateTime.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\UTCDateTime::unserialize() - Unserialize a UTCDateTime
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the DateTime representation of this UTCDateTime

  • ? MongoDB\BSON\UTCDateTime::serialize
  • MongoDB\BSON\UTCDateTime::__toString ?
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Returns the DateTime representation of this UTCDateTime

MongoDB\BSON\UTCDateTime::toDateTime

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime

说明

final public MongoDB\BSON\UTCDateTime::toDateTime ( ) : DateTime

参数

此函数没有参数。

返回值

Returns the DateTime representation of this UTCDateTime. The returned DateTime will use the UTC time zone.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

范例

Example #1 MongoDB\BSON\UTCDatetime::toDateTime() example

<?php

$utcdatetime = new MongoDB\BSON\UTCDateTime(1416445411987);
$datetime = $utcdatetime->toDateTime();
var_dump($datetime->format('r'));
var_dump($datetime->format('U.u'));
var_dump($datetime->getTimezone());

?>

以上例程的输出类似于：

string(31) "Thu, 20 Nov 2014 01:03:31 +0000"
string(17) "1416445411.987000"
object(DateTimeZone)#3 (2) {
  ["timezone_type"]=>
  int(1)
  ["timezone"]=>
  string(6) "+00:00"
}

参见

  • » BSON Types: Date


Returns the string representation of this UTCDateTime

  • ? MongoDB\BSON\UTCDateTime::toDateTime
  • MongoDB\BSON\UTCDateTime::unserialize ?
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Returns the string representation of this UTCDateTime

MongoDB\BSON\UTCDateTime::__toString

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime

说明

final public MongoDB\BSON\UTCDateTime::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this UTCDateTime.

范例

Example #1 MongoDB\BSON\UTCDateTime::__toString() example

<?php

$utcdatetime = new MongoDB\BSON\UTCDateTime(1416445411987);
var_dump((string) $utcdatetime);

?>

以上例程会输出：

string(13) "1416445411987"

参见

  • » BSON Types: Date


Unserialize a UTCDateTime

  • ? MongoDB\BSON\UTCDateTime::__toString
  • MongoDB\BSON\Type ?
  • PHP Manual
  • MongoDB\BSON\UTCDateTime
  • Unserialize a UTCDateTime

MongoDB\BSON\UTCDateTime::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime

说明

final public MongoDB\BSON\UTCDateTime::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\UTCDateTime.

返回值

Returns the unserialized MongoDB\BSON\UTCDateTime.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\BSON\UTCDateTime::serialize() - Serialize a UTCDateTime
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\Type interface

(mongodb >=1.0.0)

简介

Abstract base interface that should not be implemented directly.

接口摘要

MongoDB\BSON\Type {
}

This interface has no methods. Its only purpose is to be the base interface for all BSON type classes.


The MongoDB\BSON\Persistable interface

(mongodb >=1.0.0)

简介

Classes may implement this interface to take advantage of automatic ODM (object document mapping) behavior in the driver. During serialization, the driver will inject a __pclass property containing the PHP class name into the data returned by MongoDB\BSON\Serializable::bsonSerialize(). During unserialization, the same __pclass property will then be used to infer the PHP class (independent of any type map configuration) to be constructed before MongoDB\BSON\Unserializable::bsonUnserialize() is invoked. See Persisting Data for additional information.

Note: Even if MongoDB\BSON\Serializable::bsonSerialize() would return a sequential array, injection of the __pclass property will cause the object to be serialized as a BSON document.

接口摘要

MongoDB\BSON\Persistable implements MongoDB\BSON\Unserializable , MongoDB\BSON\Serializable {
/* 继承的方法 */
abstract public MongoDB\BSON\Serializable::bsonSerialize ( ) : array|object
abstract public MongoDB\BSON\Unserializable::bsonUnserialize ( array $data ) : void
}


The MongoDB\BSON\Serializable interface

(mongodb >=1.0.0)

简介

Classes that implement this interface may return data to be serialized as a BSON array or document in lieu of the object's public properties.

接口摘要

MongoDB\BSON\Serializable implements MongoDB\BSON\Type {
/* 方法 */
abstract public bsonSerialize ( ) : array|object
}

Table of Contents

  • MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON


Provides an array or document to serialize as BSON

  • ? MongoDB\BSON\Serializable
  • MongoDB\BSON\Unserializable ?
  • PHP Manual
  • MongoDB\BSON\Serializable
  • Provides an array or document to serialize as BSON

MongoDB\BSON\Serializable::bsonSerialize

(mongodb >=1.0.0)

MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON

说明

abstract public MongoDB\BSON\Serializable::bsonSerialize ( ) : array|object

Called during serialization of the object to BSON. The method must return an array or stdClass.

Root documents (e.g. a MongoDB\BSON\Serializable passed to MongoDB\BSON\fromPHP()) will always be serialized as a BSON document. For field values, associative arrays and stdClass instances will be serialized as a BSON document and sequential arrays (i.e. sequential, numeric indexes starting at 0) will be serialized as a BSON array.

Users are encouraged to include an _id property (e.g. a MongoDB\BSON\ObjectId initialized in your constructor) when returning data for a BSON root document; otherwise, the driver or database will need to generate a MongoDB\BSON\ObjectId when inserting or upserting the document, respectively.

参数

此函数没有参数。

返回值

An array or stdClass to be serialized as a BSON array or document.

范例

Example #1 MongoDB\BSON\Serializable::bsonSerialize() returning an associative array for root document

<?php

class MyDocument implements MongoDB\BSON\Serializable
{
    private $id;

    function __construct()
    {
        $this->id = new MongoDB\BSON\ObjectId;
    }

    function bsonSerialize()
    {
        return ['_id' => $this->id, 'foo' => 'bar'];
    }
}

$bson = MongoDB\BSON\fromPHP(new MyDocument);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

以上例程的输出类似于：

{ "_id" : { "$oid" : "56cccdcada14d8755a58c591" }, "foo" : "bar" }

Example #2 MongoDB\BSON\Serializable::bsonSerialize() returning a sequential array for root document

<?php

class MyArray implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return [1, 2, 3];
    }
}

$bson = MongoDB\BSON\fromPHP(new MyArray);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

以上例程会输出：

{ "0" : 1, "1" : 2, "2" : 3 }

Example #3 MongoDB\BSON\Serializable::bsonSerialize() returning an associative array for document field

<?php

class MyDocument implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return ['foo' => 'bar'];
    }
}

$value = ['document' => new MyDocument];
$bson = MongoDB\BSON\fromPHP($value);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

以上例程会输出：

{ "document" : { "foo" : "bar" } }

Example #4 MongoDB\BSON\Serializable::bsonSerialize() returning a sequential array for document field

<?php

class MyArray implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return [1, 2, 3];
    }
}

$value = ['array' => new MyArray];
$bson = MongoDB\BSON\fromPHP($value);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

以上例程会输出：

{ "array" : [ 1, 2, 3 ] }

参见

  • MongoDB\BSON\Unserializable::bsonUnserialize() - Constructs the object from a BSON array or document
  • MongoDB\BSON\Persistable
  • Persisting Data


The MongoDB\BSON\Unserializable interface

(mongodb >=1.0.0)

简介

Classes that implement this interface may be specified in a type map for unserializing BSON arrays and documents (both root and embedded).

接口摘要

MongoDB\BSON\Unserializable {
/* 方法 */
abstract public bsonUnserialize ( array $data ) : void
}

Table of Contents

  • MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document


Constructs the object from a BSON array or document

  • ? MongoDB\BSON\Unserializable
  • MongoDB\BSON\BinaryInterface ?
  • PHP Manual
  • MongoDB\BSON\Unserializable
  • Constructs the object from a BSON array or document

MongoDB\BSON\Unserializable::bsonUnserialize

(mongodb >=1.0.0)

MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document

说明

abstract public MongoDB\BSON\Unserializable::bsonUnserialize ( array $data ) : void

Called during unserialization of the object from BSON. The properties of the BSON array or document will be passed to the method as an array.

Remember to check for an _id property when handling data from a BSON document.

Note: This method acts as the constructor of the object. The __construct() method will not be called after this method.

参数

data (array)

Properties within the BSON array or document.

返回值

The return value from this method is ignored.

范例

Example #1 MongoDB\BSON\Unserializable::bsonUnserialize() example

<?php

class MyDocument implements MongoDB\BSON\Unserializable
{
    private $data = [];

    function bsonUnserialize(array $data)
    {
        $this->data = $data;
    }
}

$bson = MongoDB\BSON\fromJSON('{ "foo": "bar" }');
$value = MongoDB\BSON\toPHP($bson, ['root' => 'MyDocument']);
var_dump($value);

?>

以上例程会输出：

object(MyDocument)#1 (1) {
  ["data":"MyDocument":private]=>
  array(1) {
    ["foo"]=>
    string(3) "bar"
  }
}

参见

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • MongoDB\BSON\Persistable
  • Persisting Data


The MongoDB\BSON\BinaryInterface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\Binary but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\BinaryInterface {
/* 方法 */
abstract public getData ( ) : string
abstract public getType ( ) : int
abstract public __toString ( ) : string
}

Table of Contents

  • MongoDB\BSON\BinaryInterface::getData — Returns the BinaryInterface's data
  • MongoDB\BSON\BinaryInterface::getType — Returns the BinaryInterface's type
  • MongoDB\BSON\BinaryInterface::__toString — Returns the BinaryInterface's data


Returns the BinaryInterface's data

  • ? MongoDB\BSON\BinaryInterface
  • MongoDB\BSON\BinaryInterface::getType ?
  • PHP Manual
  • MongoDB\BSON\BinaryInterface
  • Returns the BinaryInterface's data

MongoDB\BSON\BinaryInterface::getData

(mongodb >=1.3.0)

MongoDB\BSON\BinaryInterface::getData — Returns the BinaryInterface's data

说明

abstract public MongoDB\BSON\BinaryInterface::getData ( ) : string

参数

此函数没有参数。

返回值

Returns the BinaryInterface's data.

参见

  • MongoDB\BSON\Binary::getData() - Returns the Binary's data


Returns the BinaryInterface's type

  • ? MongoDB\BSON\BinaryInterface::getData
  • MongoDB\BSON\BinaryInterface::__toString ?
  • PHP Manual
  • MongoDB\BSON\BinaryInterface
  • Returns the BinaryInterface's type

MongoDB\BSON\BinaryInterface::getType

(mongodb >=1.3.0)

MongoDB\BSON\BinaryInterface::getType — Returns the BinaryInterface's type

说明

abstract public MongoDB\BSON\BinaryInterface::getType ( ) : int

参数

此函数没有参数。

返回值

Returns the BinaryInterface's type.

参见

  • MongoDB\BSON\Binary::getType() - Returns the Binary's type


Returns the BinaryInterface's data

  • ? MongoDB\BSON\BinaryInterface::getType
  • MongoDB\BSON\Decimal128Interface ?
  • PHP Manual
  • MongoDB\BSON\BinaryInterface
  • Returns the BinaryInterface's data

MongoDB\BSON\BinaryInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\BinaryInterface::__toString — Returns the BinaryInterface's data

说明

abstract public MongoDB\BSON\BinaryInterface::__toString ( ) : string

此方法是该方法的别名： MongoDB\BSON\BinaryInterface::getData().

参数

此函数没有参数。

返回值

Returns the BinaryInterface's data.

参见

  • MongoDB\BSON\BinaryInterface::getData() - Returns the BinaryInterface's data
  • MongoDB\BSON\Binary::__toString() - Returns the Binary's data


The MongoDB\BSON\Decimal128Interface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\Decimal128 but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\Decimal128Interface {
/* 方法 */
abstract public __toString ( ) : string
}

Table of Contents

  • MongoDB\BSON\Decimal128Interface::__toString — Returns the string representation of this Decimal128Interface


Returns the string representation of this Decimal128Interface

  • ? MongoDB\BSON\Decimal128Interface
  • MongoDB\BSON\JavascriptInterface ?
  • PHP Manual
  • MongoDB\BSON\Decimal128Interface
  • Returns the string representation of this Decimal128Interface

MongoDB\BSON\Decimal128Interface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\Decimal128Interface::__toString — Returns the string representation of this Decimal128Interface

说明

abstract public MongoDB\BSON\Decimal128Interface::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this Decimal128Interface.

参见

  • MongoDB\BSON\Decimal128::__toString() - Returns the string representation of this Decimal128


The MongoDB\BSON\JavascriptInterface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\Javascript but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\JavascriptInterface {
/* 方法 */
abstract public getCode ( ) : string
abstract public getScope ( ) : object|null
abstract public __toString ( ) : string
}

Table of Contents

  • MongoDB\BSON\JavascriptInterface::getCode — Returns the JavascriptInterface's code
  • MongoDB\BSON\JavascriptInterface::getScope — Returns the JavascriptInterface's scope document
  • MongoDB\BSON\JavascriptInterface::__toString — Returns the JavascriptInterface's code


Returns the JavascriptInterface's code

  • ? MongoDB\BSON\JavascriptInterface
  • MongoDB\BSON\JavascriptInterface::getScope ?
  • PHP Manual
  • MongoDB\BSON\JavascriptInterface
  • Returns the JavascriptInterface's code

MongoDB\BSON\JavascriptInterface::getCode

(mongodb >=1.3.0)

MongoDB\BSON\JavascriptInterface::getCode — Returns the JavascriptInterface's code

说明

abstract public MongoDB\BSON\JavascriptInterface::getCode ( ) : string

参数

此函数没有参数。

返回值

Returns the JavascriptInterface's code.

参见

  • MongoDB\BSON\Javascript::getCode() - Returns the Javascript's code


Returns the JavascriptInterface's scope document

  • ? MongoDB\BSON\JavascriptInterface::getCode
  • MongoDB\BSON\JavascriptInterface::__toString ?
  • PHP Manual
  • MongoDB\BSON\JavascriptInterface
  • Returns the JavascriptInterface's scope document

MongoDB\BSON\JavascriptInterface::getScope

(mongodb >=1.3.0)

MongoDB\BSON\JavascriptInterface::getScope — Returns the JavascriptInterface's scope document

说明

abstract public MongoDB\BSON\JavascriptInterface::getScope ( ) : object|null

参数

此函数没有参数。

返回值

Returns the JavascriptInterface's scope document.

参见

  • MongoDB\BSON\Javascript::getScope() - Returns the Javascript's scope document


Returns the JavascriptInterface's code

  • ? MongoDB\BSON\JavascriptInterface::getScope
  • MongoDB\BSON\MaxKeyInterface ?
  • PHP Manual
  • MongoDB\BSON\JavascriptInterface
  • Returns the JavascriptInterface's code

MongoDB\BSON\JavascriptInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\JavascriptInterface::__toString — Returns the JavascriptInterface's code

说明

abstract public MongoDB\BSON\JavascriptInterface::__toString ( ) : string

此方法是该方法的别名： MongoDB\BSON\JavascriptInterface::getCode().

参数

此函数没有参数。

返回值

Returns the JavascriptInterface's code.

参见

  • MongoDB\BSON\JavascriptInterface::getCode() - Returns the JavascriptInterface's code
  • MongoDB\BSON\Javascript::__toString() - Returns the Javascript's code


The MongoDB\BSON\MaxKeyInterface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\MaxKey but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\MaxKeyInterface {
}

This interface has no methods.


The MongoDB\BSON\MinKeyInterface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\MinKey but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\MinKeyInterface {
}

This interface has no methods.


The MongoDB\BSON\ObjectIdInterface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\ObjectId but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\ObjectIdInterface {
/* 方法 */
abstract public getTimestamp ( ) : int
abstract public __toString ( ) : string
}

Table of Contents

  • MongoDB\BSON\ObjectIdInterface::getTimestamp — Returns the timestamp component of this ObjectIdInterface
  • MongoDB\BSON\ObjectIdInterface::__toString — Returns the hexidecimal representation of this ObjectIdInterface


Returns the timestamp component of this ObjectIdInterface

  • ? MongoDB\BSON\ObjectIdInterface
  • MongoDB\BSON\ObjectIdInterface::__toString ?
  • PHP Manual
  • MongoDB\BSON\ObjectIdInterface
  • Returns the timestamp component of this ObjectIdInterface

MongoDB\BSON\ObjectIdInterface::getTimestamp

(mongodb >=1.3.0)

MongoDB\BSON\ObjectIdInterface::getTimestamp — Returns the timestamp component of this ObjectIdInterface

说明

abstract public MongoDB\BSON\ObjectIdInterface::getTimestamp ( ) : int

参数

此函数没有参数。

返回值

Returns the timestamp component of this ObjectIdInterface.

参见

  • MongoDB\BSON\ObjectId::getTimestamp() - Returns the timestamp component of this ObjectId


Returns the hexidecimal representation of this ObjectIdInterface

  • ? MongoDB\BSON\ObjectIdInterface::getTimestamp
  • MongoDB\BSON\RegexInterface ?
  • PHP Manual
  • MongoDB\BSON\ObjectIdInterface
  • Returns the hexidecimal representation of this ObjectIdInterface

MongoDB\BSON\ObjectIdInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\ObjectIdInterface::__toString — Returns the hexidecimal representation of this ObjectIdInterface

说明

abstract public MongoDB\BSON\ObjectIdInterface::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the hexidecimal representation of this ObjectIdInterface.

参见

  • MongoDB\BSON\ObjectId::__toString() - Returns the hexidecimal representation of this ObjectId


The MongoDB\BSON\RegexInterface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\Regex but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\RegexInterface {
/* 方法 */
abstract public getFlags ( ) : string
abstract public getPattern ( ) : string
abstract public __toString ( ) : string
}

Table of Contents

  • MongoDB\BSON\RegexInterface::getFlags — Returns the RegexInterface's flags
  • MongoDB\BSON\RegexInterface::getPattern — Returns the RegexInterface's pattern
  • MongoDB\BSON\RegexInterface::__toString — Returns the string representation of this RegexInterface


Returns the RegexInterface's flags

  • ? MongoDB\BSON\RegexInterface
  • MongoDB\BSON\RegexInterface::getPattern ?
  • PHP Manual
  • MongoDB\BSON\RegexInterface
  • Returns the RegexInterface's flags

MongoDB\BSON\RegexInterface::getFlags

(mongodb >=1.3.0)

MongoDB\BSON\RegexInterface::getFlags — Returns the RegexInterface's flags

说明

abstract public MongoDB\BSON\RegexInterface::getFlags ( ) : string

参数

此函数没有参数。

返回值

Returns the RegexInterface's flags.

参见

  • MongoDB\BSON\Regex::getFlags() - Returns the Regex's flags


Returns the RegexInterface's pattern

  • ? MongoDB\BSON\RegexInterface::getFlags
  • MongoDB\BSON\RegexInterface::__toString ?
  • PHP Manual
  • MongoDB\BSON\RegexInterface
  • Returns the RegexInterface's pattern

MongoDB\BSON\RegexInterface::getPattern

(mongodb >=1.3.0)

MongoDB\BSON\RegexInterface::getPattern — Returns the RegexInterface's pattern

说明

abstract public MongoDB\BSON\RegexInterface::getPattern ( ) : string

参数

此函数没有参数。

返回值

Returns the RegexInterface's pattern.

参见

  • MongoDB\BSON\Regex::getPattern() - Returns the Regex's pattern


Returns the string representation of this RegexInterface

  • ? MongoDB\BSON\RegexInterface::getPattern
  • MongoDB\BSON\TimestampInterface ?
  • PHP Manual
  • MongoDB\BSON\RegexInterface
  • Returns the string representation of this RegexInterface

MongoDB\BSON\RegexInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\RegexInterface::__toString — Returns the string representation of this RegexInterface

说明

abstract public MongoDB\BSON\RegexInterface::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this RegexInterface.

参见

  • MongoDB\BSON\Regex::__toString() - Returns the string representation of this Regex


The MongoDB\BSON\TimestampInterface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\Timestamp but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\TimestampInterface {
/* 方法 */
abstract public getIncrement ( ) : int
abstract public getTimestamp ( ) : int
abstract public __toString ( ) : string
}

Table of Contents

  • MongoDB\BSON\TimestampInterface::getIncrement — Returns the increment component of this TimestampInterface
  • MongoDB\BSON\TimestampInterface::getTimestamp — Returns the timestamp component of this TimestampInterface
  • MongoDB\BSON\TimestampInterface::__toString — Returns the string representation of this TimestampInterface


Returns the increment component of this TimestampInterface

  • ? MongoDB\BSON\TimestampInterface
  • MongoDB\BSON\TimestampInterface::getTimestamp ?
  • PHP Manual
  • MongoDB\BSON\TimestampInterface
  • Returns the increment component of this TimestampInterface

MongoDB\BSON\TimestampInterface::getIncrement

(mongodb >=1.3.0)

MongoDB\BSON\TimestampInterface::getIncrement — Returns the increment component of this TimestampInterface

说明

abstract public MongoDB\BSON\TimestampInterface::getIncrement ( ) : int

参数

此函数没有参数。

返回值

Returns the increment component of this TimestampInterface.

Warning

On 32-bit systems this method may return a negative number. Although the increment and timestamp parts of the BSON timestamp type consists of two unsigned 32-bit values, PHP can not represent these on 32-bit platforms.

参见

  • MongoDB\BSON\Timestamp::getIncrement() - Returns the increment component of this Timestamp


Returns the timestamp component of this TimestampInterface

  • ? MongoDB\BSON\TimestampInterface::getIncrement
  • MongoDB\BSON\TimestampInterface::__toString ?
  • PHP Manual
  • MongoDB\BSON\TimestampInterface
  • Returns the timestamp component of this TimestampInterface

MongoDB\BSON\TimestampInterface::getTimestamp

(mongodb >=1.3.0)

MongoDB\BSON\TimestampInterface::getTimestamp — Returns the timestamp component of this TimestampInterface

说明

abstract public MongoDB\BSON\TimestampInterface::getTimestamp ( ) : int

参数

此函数没有参数。

返回值

Returns the timestamp component of this TimestampInterface.

Warning

On 32-bit systems this method may return a negative number. Although the increment and timestamp parts of the BSON timestamp type consists of two unsigned 32-bit values, PHP can not represent these on 32-bit platforms.

参见

  • MongoDB\BSON\Timestamp::getTimestamp() - Returns the timestamp component of this Timestamp


Returns the string representation of this TimestampInterface

  • ? MongoDB\BSON\TimestampInterface::getTimestamp
  • MongoDB\BSON\UTCDateTimeInterface ?
  • PHP Manual
  • MongoDB\BSON\TimestampInterface
  • Returns the string representation of this TimestampInterface

MongoDB\BSON\TimestampInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\TimestampInterface::__toString — Returns the string representation of this TimestampInterface

说明

abstract public MongoDB\BSON\TimestampInterface::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this TimestampInterface.

参见

  • MongoDB\BSON\Timestamp::__toString() - Returns the string representation of this Timestamp


The MongoDB\BSON\UTCDateTimeInterface interface

(mongodb >=1.3.0)

简介

This interface is implemented by MongoDB\BSON\UTCDateTime but may also be used for type-hinting and userland classes.

类摘要

MongoDB\BSON\UTCDateTimeInterface {
/* 方法 */
abstract public toDateTime ( ) : DateTime
abstract public __toString ( ) : string
}

Table of Contents

  • MongoDB\BSON\UTCDateTimeInterface::toDateTime — Returns the DateTime representation of this UTCDateTimeInterface
  • MongoDB\BSON\UTCDateTimeInterface::__toString — Returns the string representation of this UTCDateTimeInterface


Returns the DateTime representation of this UTCDateTimeInterface

  • ? MongoDB\BSON\UTCDateTimeInterface
  • MongoDB\BSON\UTCDateTimeInterface::__toString ?
  • PHP Manual
  • MongoDB\BSON\UTCDateTimeInterface
  • Returns the DateTime representation of this UTCDateTimeInterface

MongoDB\BSON\UTCDateTimeInterface::toDateTime

(mongodb >=1.3.0)

MongoDB\BSON\UTCDateTimeInterface::toDateTime — Returns the DateTime representation of this UTCDateTimeInterface

说明

abstract public MongoDB\BSON\UTCDateTimeInterface::toDateTime ( ) : DateTime

参数

此函数没有参数。

返回值

Returns the DateTime representation of this UTCDateTimeInterface. The returned DateTime should use the UTC time zone.

参见

  • MongoDB\BSON\UTCDateTime::toDateTime() - Returns the DateTime representation of this UTCDateTime


Returns the string representation of this UTCDateTimeInterface

  • ? MongoDB\BSON\UTCDateTimeInterface::toDateTime
  • MongoDB\BSON\DBPointer ?
  • PHP Manual
  • MongoDB\BSON\UTCDateTimeInterface
  • Returns the string representation of this UTCDateTimeInterface

MongoDB\BSON\UTCDateTimeInterface::__toString

(mongodb >=1.3.0)

MongoDB\BSON\UTCDateTimeInterface::__toString — Returns the string representation of this UTCDateTimeInterface

说明

abstract public MongoDB\BSON\UTCDateTimeInterface::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this UTCDateTimeInterface.

参见

  • MongoDB\BSON\UTCDateTime::__toString() - Returns the string representation of this UTCDateTime


The MongoDB\BSON\DBPointer class (deprecated)

(mongodb >=1.4.0)

简介

BSON type for the "DBPointer" type. This BSON type is deprecated, and this class can not be instantiated. It will be created from a BSON DBPointer type while converting BSON to PHP, and can also be converted back into BSON while storing documents in the database.

类摘要

final MongoDB\BSON\DBPointer implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final private __construct ( )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Table of Contents

  • MongoDB\BSON\DBPointer::__construct — Construct a new DBPointer (unused)
  • MongoDB\BSON\DBPointer::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\DBPointer::serialize — Serialize a DBPointer
  • MongoDB\BSON\DBPointer::__toString — Returns an empty string
  • MongoDB\BSON\DBPointer::unserialize — Unserialize a DBPointer


Construct a new DBPointer (unused)

  • ? MongoDB\BSON\DBPointer
  • MongoDB\BSON\DBPointer::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\DBPointer
  • Construct a new DBPointer (unused)

MongoDB\BSON\DBPointer::__construct

(mongodb >=1.4.0)

MongoDB\BSON\DBPointer::__construct — Construct a new DBPointer (unused)

说明

final private MongoDB\BSON\DBPointer::__construct ( )

MongoDB\BSON\DBPointer objects are created through conversion from a deprecated BSON type and cannot be constructed directly.

参数

此函数没有参数。

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\DBPointer::__construct
  • MongoDB\BSON\DBPointer::serialize ?
  • PHP Manual
  • MongoDB\BSON\DBPointer
  • Returns a representation that can be converted to JSON

MongoDB\BSON\DBPointer::jsonSerialize

(mongodb >=1.4.0)

MongoDB\BSON\DBPointer::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\DBPointer::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\DBPointer.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a DBPointer

  • ? MongoDB\BSON\DBPointer::jsonSerialize
  • MongoDB\BSON\DBPointer::__toString ?
  • PHP Manual
  • MongoDB\BSON\DBPointer
  • Serialize a DBPointer

MongoDB\BSON\DBPointer::serialize

(mongodb >=1.4.0)

MongoDB\BSON\DBPointer::serialize — Serialize a DBPointer

说明

final public MongoDB\BSON\DBPointer::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\DBPointer.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\DBPointer::unserialize() - Unserialize a DBPointer
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns an empty string

  • ? MongoDB\BSON\DBPointer::serialize
  • MongoDB\BSON\DBPointer::unserialize ?
  • PHP Manual
  • MongoDB\BSON\DBPointer
  • Returns an empty string

MongoDB\BSON\DBPointer::__toString

(mongodb >=1.4.0)

MongoDB\BSON\DBPointer::__toString — Returns an empty string

说明

final public MongoDB\BSON\DBPointer::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns an empty string.

参见

  • » BSON Types


Unserialize a DBPointer

  • ? MongoDB\BSON\DBPointer::__toString
  • MongoDB\BSON\Int64 ?
  • PHP Manual
  • MongoDB\BSON\DBPointer
  • Unserialize a DBPointer

MongoDB\BSON\DBPointer::unserialize

(mongodb >=1.4.0)

MongoDB\BSON\DBPointer::unserialize — Unserialize a DBPointer

说明

final public MongoDB\BSON\DBPointer::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\DBPointer.

返回值

Returns the unserialized MongoDB\BSON\DBPointer.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\DBPointer::serialize() - Serialize a DBPointer
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\Int64 class

(mongodb >=1.5.0)

简介

BSON type for a 64-bit integer. This class cannot be instantiated and is only created during BSON decoding when a 64-bit integer cannot be represented as a PHP integer on a 32-bit platform. Versions of the driver before 1.5.0 would throw an exception when attempting to decode a 64-bit integer on a 32-bit platform.

During BSON encoding, objects of this class will convert back to a 64-bit integer type. This allows 64-bit integers to be roundtripped through a 32-bit PHP environment without any loss of precision. The __toString() method allows the 64-bit integer value to be accessed as a string.

Note: This class exists purely for 32-bit platforms. Applications on 64-bit platforms (i.e. PHP_INT_SIZE is 8) should never encounter this class during normal operation.

类摘要

final MongoDB\BSON\Int64 implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final private __construct ( )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Table of Contents

  • MongoDB\BSON\Int64::__construct — Construct a new Int64 (unused)
  • MongoDB\BSON\Int64::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Int64::serialize — Serialize an Int64
  • MongoDB\BSON\Int64::__toString — Returns the string representation of this Int64
  • MongoDB\BSON\Int64::unserialize — Unserialize an Int64


Construct a new Int64 (unused)

  • ? MongoDB\BSON\Int64
  • MongoDB\BSON\Int64::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\Int64
  • Construct a new Int64 (unused)

MongoDB\BSON\Int64::__construct

(mongodb >=1.5.0)

MongoDB\BSON\Int64::__construct — Construct a new Int64 (unused)

说明

final private MongoDB\BSON\Int64::__construct ( )

MongoDB\BSON\Int64 objects are created through conversion from a 64-bit integer BSON type on a 32-bit platform and cannot be constructed directly.

参数

此函数没有参数。

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\Int64::__construct
  • MongoDB\BSON\Int64::serialize ?
  • PHP Manual
  • MongoDB\BSON\Int64
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Int64::jsonSerialize

(mongodb >=1.5.0)

MongoDB\BSON\Int64::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\Int64::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Int64.

Note: The output is consistent with the MongoDB\BSON\toCanonicalExtendedJSON() function, which uses the » canonical extended JSON format. This differs from other BSON classes, which use the driver-specific legacy extended JSON format (MongoDB\BSON\toJSON()), in order to ensure that the 64-bit integer value is correctly represented on 32-bit platforms.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize an Int64

  • ? MongoDB\BSON\Int64::jsonSerialize
  • MongoDB\BSON\Int64::__toString ?
  • PHP Manual
  • MongoDB\BSON\Int64
  • Serialize an Int64

MongoDB\BSON\Int64::serialize

(mongodb >=1.5.0)

MongoDB\BSON\Int64::serialize — Serialize an Int64

说明

final public MongoDB\BSON\Int64::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\Int64.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Int64::unserialize() - Unserialize an Int64
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the string representation of this Int64

  • ? MongoDB\BSON\Int64::serialize
  • MongoDB\BSON\Int64::unserialize ?
  • PHP Manual
  • MongoDB\BSON\Int64
  • Returns the string representation of this Int64

MongoDB\BSON\Int64::__toString

(mongodb >=1.5.0)

MongoDB\BSON\Int64::__toString — Returns the string representation of this Int64

说明

final public MongoDB\BSON\Int64::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this Int64.

范例

Example #1 MongoDB\BSON\Int64::__toString() example

<?php

$int64 = unserialize('C:18:"MongoDB\BSON\Int64":47:{a:1:{s:7:"integer";s:19:"9223372036854775807";}}');

var_dump((string) $int64);

?>

以上例程的输出类似于：

string(19) "9223372036854775807"

参见

  • » BSON Types


Unserialize an Int64

  • ? MongoDB\BSON\Int64::__toString
  • MongoDB\BSON\Symbol ?
  • PHP Manual
  • MongoDB\BSON\Int64
  • Unserialize an Int64

MongoDB\BSON\Int64::unserialize

(mongodb >=1.5.0)

MongoDB\BSON\Int64::unserialize — Unserialize an Int64

说明

final public MongoDB\BSON\Int64::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\Int64.

返回值

Returns the unserialized MongoDB\BSON\Int64.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

参见

  • MongoDB\BSON\Int64::serialize() - Serialize an Int64
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\Symbol class (deprecated)

(mongodb >=1.4.0)

简介

BSON type for the "Symbol" type. This BSON type is deprecated, and this class can not be instantiated. It will be created from a BSON symbol type while converting BSON to PHP, and can also be converted back into BSON while storing documents in the database.

类摘要

final MongoDB\BSON\Symbol implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final private __construct ( )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Table of Contents

  • MongoDB\BSON\Symbol::__construct — Construct a new Symbol (unused)
  • MongoDB\BSON\Symbol::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Symbol::serialize — Serialize a Symbol
  • MongoDB\BSON\Symbol::__toString — Returns the Symbol as a string
  • MongoDB\BSON\Symbol::unserialize — Unserialize a Symbol


Construct a new Symbol (unused)

  • ? MongoDB\BSON\Symbol
  • MongoDB\BSON\Symbol::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\Symbol
  • Construct a new Symbol (unused)

MongoDB\BSON\Symbol::__construct

(mongodb >=1.4.0)

MongoDB\BSON\Symbol::__construct — Construct a new Symbol (unused)

说明

final private MongoDB\BSON\Symbol::__construct ( )

MongoDB\BSON\Symbol objects are created through conversion from a deprecated BSON type and cannot be constructed directly.

参数

此函数没有参数。

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\Symbol::__construct
  • MongoDB\BSON\Symbol::serialize ?
  • PHP Manual
  • MongoDB\BSON\Symbol
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Symbol::jsonSerialize

(mongodb >=1.4.0)

MongoDB\BSON\Symbol::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\Symbol::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Symbol.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Symbol

  • ? MongoDB\BSON\Symbol::jsonSerialize
  • MongoDB\BSON\Symbol::__toString ?
  • PHP Manual
  • MongoDB\BSON\Symbol
  • Serialize a Symbol

MongoDB\BSON\Symbol::serialize

(mongodb >=1.4.0)

MongoDB\BSON\Symbol::serialize — Serialize a Symbol

说明

final public MongoDB\BSON\Symbol::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\Symbol.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Symbol::unserialize() - Unserialize a Symbol
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns the Symbol as a string

  • ? MongoDB\BSON\Symbol::serialize
  • MongoDB\BSON\Symbol::unserialize ?
  • PHP Manual
  • MongoDB\BSON\Symbol
  • Returns the Symbol as a string

MongoDB\BSON\Symbol::__toString

(mongodb >=1.4.0)

MongoDB\BSON\Symbol::__toString — Returns the Symbol as a string

说明

final public MongoDB\BSON\Symbol::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns the string representation of this Symbol.

参见

  • » BSON Types


Unserialize a Symbol

  • ? MongoDB\BSON\Symbol::__toString
  • MongoDB\BSON\Undefined ?
  • PHP Manual
  • MongoDB\BSON\Symbol
  • Unserialize a Symbol

MongoDB\BSON\Symbol::unserialize

(mongodb >=1.4.0)

MongoDB\BSON\Symbol::unserialize — Unserialize a Symbol

说明

final public MongoDB\BSON\Symbol::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\Symbol.

返回值

Returns the unserialized MongoDB\BSON\Symbol.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Symbol::serialize() - Serialize a Symbol
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The MongoDB\BSON\Undefined class (deprecated)

(mongodb >=1.4.0)

简介

BSON type for the "Undefined" type. This BSON type is deprecated, and this class can not be instantiated. It will be created from a BSON undefined type while converting BSON to PHP, and can also be converted back into BSON while storing documents in the database.

类摘要

final MongoDB\BSON\Undefined implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* 方法 */
final private __construct ( )
final public jsonSerialize ( ) : mixed
final public serialize ( ) : string
final public __toString ( ) : string
final public unserialize ( string $serialized ) : void
}

Table of Contents

  • MongoDB\BSON\Undefined::__construct — Construct a new Undefined (unused)
  • MongoDB\BSON\Undefined::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Undefined::serialize — Serialize a Undefined
  • MongoDB\BSON\Undefined::__toString — Returns an empty string
  • MongoDB\BSON\Undefined::unserialize — Unserialize a Undefined


Construct a new Undefined (unused)

  • ? MongoDB\BSON\Undefined
  • MongoDB\BSON\Undefined::jsonSerialize ?
  • PHP Manual
  • MongoDB\BSON\Undefined
  • Construct a new Undefined (unused)

MongoDB\BSON\Undefined::__construct

(mongodb >=1.4.0)

MongoDB\BSON\Undefined::__construct — Construct a new Undefined (unused)

说明

final private MongoDB\BSON\Undefined::__construct ( )

MongoDB\BSON\Undefined objects are created through conversion from a deprecated BSON type and cannot be constructed directly.

参数

此函数没有参数。

参见

  • » BSON Types


Returns a representation that can be converted to JSON

  • ? MongoDB\BSON\Undefined::__construct
  • MongoDB\BSON\Undefined::serialize ?
  • PHP Manual
  • MongoDB\BSON\Undefined
  • Returns a representation that can be converted to JSON

MongoDB\BSON\Undefined::jsonSerialize

(mongodb >=1.4.0)

MongoDB\BSON\Undefined::jsonSerialize — Returns a representation that can be converted to JSON

说明

final public MongoDB\BSON\Undefined::jsonSerialize ( ) : mixed

参数

此函数没有参数。

返回值

Returns data which can be serialized by json_encode() to produce an extended JSON representation of the MongoDB\BSON\Undefined.

Note: The output is consistent with the MongoDB\BSON\toJSON() function, which uses the driver-specific legacy extended JSON format. This does not necessarily match the » relaxed or » canonical extended JSON representations used by MongoDB\BSON\toRelaxedExtendedJSON() and MongoDB\BSON\toCanonicalExtendedJSON(), respectively.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • JsonSerializable::jsonSerialize() - 指定需要被序列化成 JSON 的数据
  • json_encode() - 对变量进行 JSON 编码
  • MongoDB\BSON\toCanonicalExtendedJSON() - Returns the Canonical Extended JSON representation of a BSON value
  • MongoDB\BSON\toRelaxedExtendedJSON() - Returns the Relaxed Extended JSON representation of a BSON value
  • » MongoDB Extended JSON


Serialize a Undefined

  • ? MongoDB\BSON\Undefined::jsonSerialize
  • MongoDB\BSON\Undefined::__toString ?
  • PHP Manual
  • MongoDB\BSON\Undefined
  • Serialize a Undefined

MongoDB\BSON\Undefined::serialize

(mongodb >=1.4.0)

MongoDB\BSON\Undefined::serialize — Serialize a Undefined

说明

final public MongoDB\BSON\Undefined::serialize ( ) : string

参数

此函数没有参数。

返回值

Returns the serialized representation of the MongoDB\BSON\Undefined.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Undefined::unserialize() - Unserialize a Undefined
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Returns an empty string

  • ? MongoDB\BSON\Undefined::serialize
  • MongoDB\BSON\Undefined::unserialize ?
  • PHP Manual
  • MongoDB\BSON\Undefined
  • Returns an empty string

MongoDB\BSON\Undefined::__toString

(mongodb >=1.4.0)

MongoDB\BSON\Undefined::__toString — Returns an empty string

说明

final public MongoDB\BSON\Undefined::__toString ( ) : string

参数

此函数没有参数。

返回值

Returns an empty string.

参见

  • » BSON Types


Unserialize a Undefined

  • ? MongoDB\BSON\Undefined::__toString
  • MongoDB\Driver\Monitoring ?
  • PHP Manual
  • MongoDB\BSON\Undefined
  • Unserialize a Undefined

MongoDB\BSON\Undefined::unserialize

(mongodb >=1.4.0)

MongoDB\BSON\Undefined::unserialize — Unserialize a Undefined

说明

final public MongoDB\BSON\Undefined::unserialize ( string $serialized ) : void

参数

serialized

The serialized MongoDB\BSON\Undefined.

返回值

Returns the unserialized MongoDB\BSON\Undefined.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\BSON\Undefined::serialize() - Serialize a Undefined
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


Monitoring classes and subscriber functions

  • 函数
    • MongoDB\Driver\Monitoring\addSubscriber — Registers a new monitoring event subscriber
    • MongoDB\Driver\Monitoring\removeSubscriber — Unregisters an existing monitoring event subscriber
  • MongoDB\Driver\Monitoring\CommandFailedEvent — The MongoDB\Driver\Monitoring\CommandFailedEvent class
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getCommandName — Returns the command name
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getDurationMicros — Returns the command's duration in microseconds
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getError — Returns the Exception associated with the failed command
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId — Returns the command's operation ID
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getReply — Returns the command reply document
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId — Returns the command's request ID
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getServer — Returns the Server on which the command was executed
  • MongoDB\Driver\Monitoring\CommandStartedEvent — The MongoDB\Driver\Monitoring\CommandStartedEvent class
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getCommand — Returns the command document
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getCommandName — Returns the command name
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getDatabaseName — Returns the database on which the command was executed
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId — Returns the command's operation ID
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId — Returns the command's request ID
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getServer — Returns the Server on which the command was executed
  • MongoDB\Driver\Monitoring\CommandSucceededEvent — The MongoDB\Driver\Monitoring\CommandSucceededEvent class
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getCommandName — Returns the command name
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getDurationMicros — Returns the command's duration in microseconds
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId — Returns the command's operation ID
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getReply — Returns the command reply document
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId — Returns the command's request ID
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getServer — Returns the Server on which the command was executed
  • MongoDB\Driver\Monitoring\CommandSubscriber — The MongoDB\Driver\Monitoring\CommandSubscriber interface
    • MongoDB\Driver\Monitoring\CommandSubscriber::commandFailed — Notification method for a failed command
    • MongoDB\Driver\Monitoring\CommandSubscriber::commandStarted — Notification method for a started command
    • MongoDB\Driver\Monitoring\CommandSubscriber::commandSucceeded — Notification method for a successful command
  • MongoDB\Driver\Monitoring\Subscriber — The MongoDB\Driver\Monitoring\Subscriber interface


函数

Table of Contents

  • MongoDB\Driver\Monitoring\addSubscriber — Registers a new monitoring event subscriber
  • MongoDB\Driver\Monitoring\removeSubscriber — Unregisters an existing monitoring event subscriber


Registers a new monitoring event subscriber

  • ? 函数
  • MongoDB\Driver\Monitoring\removeSubscriber ?
  • PHP Manual
  • 函数
  • Registers a new monitoring event subscriber

MongoDB\Driver\Monitoring\addSubscriber

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\addSubscriber — Registers a new monitoring event subscriber

说明

MongoDB\Driver\Monitoring\addSubscriber ( MongoDB\Driver\Monitoring\Subscriber $subscriber ) : void

Registers a new monitoring event subscriber with the driver. Registered subscribers will be notified of monitoring events through specific methods.

Note: If the object is already registered, this function is a no-op.

参数

subscriber (MongoDB\Driver\Monitoring\Subscriber)

A monitoring event subscriber object to register.

返回值

没有返回值。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\Subscriber
  • MongoDB\Driver\Monitoring\CommandSubscriber
  • MongoDB\Driver\Monitoring\removeSubscriber() - Unregisters an existing monitoring event subscriber
  • Application Performance Monitoring (APM)


Unregisters an existing monitoring event subscriber

  • ? MongoDB\Driver\Monitoring\addSubscriber
  • MongoDB\Driver\Monitoring\CommandFailedEvent ?
  • PHP Manual
  • 函数
  • Unregisters an existing monitoring event subscriber

MongoDB\Driver\Monitoring\removeSubscriber

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\removeSubscriber — Unregisters an existing monitoring event subscriber

说明

MongoDB\Driver\Monitoring\removeSubscriber ( MongoDB\Driver\Monitoring\Subscriber $subscriber ) : void

Unregisters an existing monitoring event subscriber from the driver. Unregistered subscribers will no longer be notified of monitoring events.

Note: If the object is not registered, this function is a no-op.

参数

subscriber (MongoDB\Driver\Monitoring\Subscriber)

A monitoring event subscriber object to unregister.

返回值

没有返回值。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\Subscriber
  • MongoDB\Driver\Monitoring\CommandSubscriber
  • MongoDB\Driver\Monitoring\addSubscriber() - Registers a new monitoring event subscriber
  • Application Performance Monitoring (APM)


The MongoDB\Driver\Monitoring\CommandFailedEvent class

(mongodb >=1.3.0)

简介

The MongoDB\Driver\Monitoring\CommandFailedEvent class encapsulates information about a failed command.

类摘要

final MongoDB\Driver\Monitoring\CommandFailedEvent {
/* 方法 */
final public getCommandName ( ) : string
final public getDurationMicros ( ) : int
final public getError ( ) : Exception
final public getOperationId ( ) : string
final public getReply ( ) : object
final public getRequestId ( ) : string
final public getServer ( ) : MongoDB\Driver\Server
}

Table of Contents

  • MongoDB\Driver\Monitoring\CommandFailedEvent::getCommandName — Returns the command name
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getDurationMicros — Returns the command's duration in microseconds
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getError — Returns the Exception associated with the failed command
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId — Returns the command's operation ID
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getReply — Returns the command reply document
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId — Returns the command's request ID
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getServer — Returns the Server on which the command was executed


Returns the command name

  • ? MongoDB\Driver\Monitoring\CommandFailedEvent
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getDurationMicros ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandFailedEvent
  • Returns the command name

MongoDB\Driver\Monitoring\CommandFailedEvent::getCommandName

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandFailedEvent::getCommandName — Returns the command name

说明

final public MongoDB\Driver\Monitoring\CommandFailedEvent::getCommandName ( ) : string

Returns the command name (e.g. "find", "aggregate").

参数

此函数没有参数。

返回值

Returns the command name.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)


Returns the command's duration in microseconds

  • ? MongoDB\Driver\Monitoring\CommandFailedEvent::getCommandName
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getError ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandFailedEvent
  • Returns the command's duration in microseconds

MongoDB\Driver\Monitoring\CommandFailedEvent::getDurationMicros

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandFailedEvent::getDurationMicros — Returns the command's duration in microseconds

说明

final public MongoDB\Driver\Monitoring\CommandFailedEvent::getDurationMicros ( ) : int

The command's duration is a calculated value that includes the time to send the message and receive the reply from the server.

参数

此函数没有参数。

返回值

Returns the command's duration in microseconds.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)


Returns the Exception associated with the failed command

  • ? MongoDB\Driver\Monitoring\CommandFailedEvent::getDurationMicros
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandFailedEvent
  • Returns the Exception associated with the failed command

MongoDB\Driver\Monitoring\CommandFailedEvent::getError

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandFailedEvent::getError — Returns the Exception associated with the failed command

说明

final public MongoDB\Driver\Monitoring\CommandFailedEvent::getError ( ) : Exception

参数

此函数没有参数。

返回值

Returns the Exception associated with the failed command.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)


Returns the command's operation ID

  • ? MongoDB\Driver\Monitoring\CommandFailedEvent::getError
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getReply ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandFailedEvent
  • Returns the command's operation ID

MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId — Returns the command's operation ID

说明

final public MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId ( ) : string

The operation ID is generated by the driver and may be used to link events together such as bulk write operations, which may have been split across several commands at the protocol level.

Note: Since multiple commands may share the same operation ID, it is not reliable to use this value to associate event objects with each other. The request ID returned by MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId() should be used instead.

参数

此函数没有参数。

返回值

Returns the command's operation ID.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId() - Returns the command's operation ID
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId() - Returns the command's request ID
  • Application Performance Monitoring (APM)


Returns the command reply document

  • ? MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandFailedEvent
  • Returns the command reply document

MongoDB\Driver\Monitoring\CommandFailedEvent::getReply

(mongodb >=1.5.0)

MongoDB\Driver\Monitoring\CommandFailedEvent::getReply — Returns the command reply document

说明

final public MongoDB\Driver\Monitoring\CommandFailedEvent::getReply ( ) : object

The reply document will be converted from BSON to PHP using the default deserialization rules (e.g. BSON documents will be converted to stdClass).

参数

此函数没有参数。

返回值

Returns the command reply document as a stdClass object.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)
  • Persisting Data


Returns the command's request ID

  • ? MongoDB\Driver\Monitoring\CommandFailedEvent::getReply
  • MongoDB\Driver\Monitoring\CommandFailedEvent::getServer ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandFailedEvent
  • Returns the command's request ID

MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId — Returns the command's request ID

说明

final public MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId ( ) : string

The request ID is generated by the driver and may be used to associate this MongoDB\Driver\Monitoring\CommandFailedEvent with a previous MongoDB\Driver\Monitoring\CommandStartedEvent.

参数

此函数没有参数。

返回值

Returns the command's request ID.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId() - Returns the command's request ID
  • Application Performance Monitoring (APM)


Returns the Server on which the command was executed

  • ? MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId
  • MongoDB\Driver\Monitoring\CommandStartedEvent ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandFailedEvent
  • Returns the Server on which the command was executed

MongoDB\Driver\Monitoring\CommandFailedEvent::getServer

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandFailedEvent::getServer — Returns the Server on which the command was executed

说明

final public MongoDB\Driver\Monitoring\CommandFailedEvent::getServer ( ) : MongoDB\Driver\Server

Returns the MongoDB\Driver\Server on which the command was executed.

参数

此函数没有参数。

返回值

Returns the MongoDB\Driver\Server on which the command was executed.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandStartedEvent::getServer() - Returns the Server on which the command was executed
  • Application Performance Monitoring (APM)


The MongoDB\Driver\Monitoring\CommandStartedEvent class

(mongodb >=1.3.0)

简介

The MongoDB\Driver\Monitoring\CommandStartedEvent class encapsulates information about a started command.

类摘要

final MongoDB\Driver\Monitoring\CommandStartedEvent {
/* 方法 */
final public getCommand ( ) : object
final public getCommandName ( ) : string
final public getDatabaseName ( ) : string
final public getOperationId ( ) : string
final public getRequestId ( ) : string
final public getServer ( ) : MongoDB\Driver\Server
}

Table of Contents

  • MongoDB\Driver\Monitoring\CommandStartedEvent::getCommand — Returns the command document
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getCommandName — Returns the command name
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getDatabaseName — Returns the database on which the command was executed
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId — Returns the command's operation ID
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId — Returns the command's request ID
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getServer — Returns the Server on which the command was executed


Returns the command document

  • ? MongoDB\Driver\Monitoring\CommandStartedEvent
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getCommandName ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandStartedEvent
  • Returns the command document

MongoDB\Driver\Monitoring\CommandStartedEvent::getCommand

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandStartedEvent::getCommand — Returns the command document

说明

final public MongoDB\Driver\Monitoring\CommandStartedEvent::getCommand ( ) : object

The reply document will be converted from BSON to PHP using the default deserialization rules (e.g. BSON documents will be converted to stdClass).

参数

此函数没有参数。

返回值

Returns the command document as a stdClass object.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)
  • Persisting Data


Returns the command name

  • ? MongoDB\Driver\Monitoring\CommandStartedEvent::getCommand
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getDatabaseName ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandStartedEvent
  • Returns the command name

MongoDB\Driver\Monitoring\CommandStartedEvent::getCommandName

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandStartedEvent::getCommandName — Returns the command name

说明

final public MongoDB\Driver\Monitoring\CommandStartedEvent::getCommandName ( ) : string

Returns the command name (e.g. "find", "aggregate").

参数

此函数没有参数。

返回值

Returns the command name.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)


Returns the database on which the command was executed

  • ? MongoDB\Driver\Monitoring\CommandStartedEvent::getCommandName
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandStartedEvent
  • Returns the database on which the command was executed

MongoDB\Driver\Monitoring\CommandStartedEvent::getDatabaseName

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandStartedEvent::getDatabaseName — Returns the database on which the command was executed

说明

final public MongoDB\Driver\Monitoring\CommandStartedEvent::getDatabaseName ( ) : string

参数

此函数没有参数。

返回值

Returns the database on which the command was executed.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)


Returns the command's operation ID

  • ? MongoDB\Driver\Monitoring\CommandStartedEvent::getDatabaseName
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandStartedEvent
  • Returns the command's operation ID

MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId — Returns the command's operation ID

说明

final public MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId ( ) : string

The operation ID is generated by the driver and may be used to link events together such as bulk write operations, which may have been split across several commands at the protocol level.

Note: Since multiple commands may share the same operation ID, it is not reliable to use this value to associate event objects with each other. The request ID returned by MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId() should be used instead.

参数

此函数没有参数。

返回值

Returns the command's operation ID.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId() - Returns the command's operation ID
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId() - Returns the command's operation ID
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId() - Returns the command's request ID
  • Application Performance Monitoring (APM)


Returns the command's request ID

  • ? MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId
  • MongoDB\Driver\Monitoring\CommandStartedEvent::getServer ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandStartedEvent
  • Returns the command's request ID

MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId — Returns the command's request ID

说明

final public MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId ( ) : string

The request ID is generated by the driver and may be used to associate this MongoDB\Driver\Monitoring\CommandStartedEvent with a later MongoDB\Driver\Monitoring\CommandFailedEvent or MongoDB\Driver\Monitoring\CommandSucceededEvent.

参数

此函数没有参数。

返回值

Returns the command's request ID.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId() - Returns the command's request ID
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId() - Returns the command's request ID
  • Application Performance Monitoring (APM)


Returns the Server on which the command was executed

  • ? MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId
  • MongoDB\Driver\Monitoring\CommandSucceededEvent ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandStartedEvent
  • Returns the Server on which the command was executed

MongoDB\Driver\Monitoring\CommandStartedEvent::getServer

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandStartedEvent::getServer — Returns the Server on which the command was executed

说明

final public MongoDB\Driver\Monitoring\CommandStartedEvent::getServer ( ) : MongoDB\Driver\Server

Returns the MongoDB\Driver\Server on which the command was executed.

参数

此函数没有参数。

返回值

Returns the MongoDB\Driver\Server on which the command was executed.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandFailedEvent::getServer() - Returns the Server on which the command was executed
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getServer() - Returns the Server on which the command was executed
  • Application Performance Monitoring (APM)


The MongoDB\Driver\Monitoring\CommandSucceededEvent class

(mongodb >=1.3.0)

简介

The MongoDB\Driver\Monitoring\CommandSucceededEvent class encapsulates information about a successful command.

类摘要

final MongoDB\Driver\Monitoring\CommandSucceededEvent {
/* 方法 */
final public getCommandName ( ) : string
final public getDurationMicros ( ) : int
final public getOperationId ( ) : string
final public getReply ( ) : object
final public getRequestId ( ) : string
final public getServer ( ) : MongoDB\Driver\Server
}

Table of Contents

  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getCommandName — Returns the command name
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getDurationMicros — Returns the command's duration in microseconds
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId — Returns the command's operation ID
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getReply — Returns the command reply document
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId — Returns the command's request ID
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getServer — Returns the Server on which the command was executed


Returns the command name

  • ? MongoDB\Driver\Monitoring\CommandSucceededEvent
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getDurationMicros ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSucceededEvent
  • Returns the command name

MongoDB\Driver\Monitoring\CommandSucceededEvent::getCommandName

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSucceededEvent::getCommandName — Returns the command name

说明

final public MongoDB\Driver\Monitoring\CommandSucceededEvent::getCommandName ( ) : string

Returns the command name (e.g. "find", "aggregate").

参数

此函数没有参数。

返回值

Returns the command name.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)


Returns the command's duration in microseconds

  • ? MongoDB\Driver\Monitoring\CommandSucceededEvent::getCommandName
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSucceededEvent
  • Returns the command's duration in microseconds

MongoDB\Driver\Monitoring\CommandSucceededEvent::getDurationMicros

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSucceededEvent::getDurationMicros — Returns the command's duration in microseconds

说明

final public MongoDB\Driver\Monitoring\CommandSucceededEvent::getDurationMicros ( ) : int

The command's duration is a calculated value that includes the time to send the message and receive the reply from the server.

参数

此函数没有参数。

返回值

Returns the command's duration in microseconds.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)


Returns the command's operation ID

  • ? MongoDB\Driver\Monitoring\CommandSucceededEvent::getDurationMicros
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getReply ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSucceededEvent
  • Returns the command's operation ID

MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId — Returns the command's operation ID

说明

final public MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId ( ) : string

The operation ID is generated by the driver and may be used to link events together such as bulk write operations, which may have been split across several commands at the protocol level.

Note: Since multiple commands may share the same operation ID, it is not reliable to use this value to associate event objects with each other. The request ID returned by MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId() should be used instead.

参数

此函数没有参数。

返回值

Returns the command's operation ID.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId() - Returns the command's operation ID
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId() - Returns the command's request ID
  • Application Performance Monitoring (APM)


Returns the command reply document

  • ? MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSucceededEvent
  • Returns the command reply document

MongoDB\Driver\Monitoring\CommandSucceededEvent::getReply

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSucceededEvent::getReply — Returns the command reply document

说明

final public MongoDB\Driver\Monitoring\CommandSucceededEvent::getReply ( ) : object

The reply document will be converted from BSON to PHP using the default deserialization rules (e.g. BSON documents will be converted to stdClass).

参数

此函数没有参数。

返回值

Returns the command reply document as a stdClass object.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • Application Performance Monitoring (APM)
  • Persisting Data


Returns the command's request ID

  • ? MongoDB\Driver\Monitoring\CommandSucceededEvent::getReply
  • MongoDB\Driver\Monitoring\CommandSucceededEvent::getServer ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSucceededEvent
  • Returns the command's request ID

MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId — Returns the command's request ID

说明

final public MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId ( ) : string

The request ID is generated by the driver and may be used to associate this MongoDB\Driver\Monitoring\CommandSucceededEvent with a previous MongoDB\Driver\Monitoring\CommandStartedEvent.

参数

此函数没有参数。

返回值

Returns the command's request ID.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId() - Returns the command's request ID
  • Application Performance Monitoring (APM)


Returns the Server on which the command was executed

  • ? MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId
  • MongoDB\Driver\Monitoring\CommandSubscriber ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSucceededEvent
  • Returns the Server on which the command was executed

MongoDB\Driver\Monitoring\CommandSucceededEvent::getServer

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSucceededEvent::getServer — Returns the Server on which the command was executed

说明

final public MongoDB\Driver\Monitoring\CommandSucceededEvent::getServer ( ) : MongoDB\Driver\Server

Returns the MongoDB\Driver\Server on which the command was executed.

参数

此函数没有参数。

返回值

Returns the MongoDB\Driver\Server on which the command was executed.

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandStartedEvent::getServer() - Returns the Server on which the command was executed
  • MongoDB\Driver\Cursor::getServer() - Returns the server associated with this cursor
  • MongoDB\Driver\WriteResult::getServer() - Returns the server associated with this write result
  • Application Performance Monitoring (APM)


The MongoDB\Driver\Monitoring\CommandSubscriber interface

(mongodb >=1.3.0)

简介

Classes may implement this interface to register an event subscriber that is notified for each started, successful, and failed command event. See Application Performance Monitoring (APM) for additional information.

接口摘要

MongoDB\Driver\Monitoring\CommandSubscriber implements MongoDB\Driver\Monitoring\Subscriber {
/* 方法 */
abstract public commandFailed ( MongoDB\Driver\Monitoring\CommandFailedEvent $event ) : void
abstract public commandStarted ( MongoDB\Driver\Monitoring\CommandStartedEvent $event ) : void
abstract public commandSucceeded ( MongoDB\Driver\Monitoring\CommandSucceededEvent $event ) : void
}

Table of Contents

  • MongoDB\Driver\Monitoring\CommandSubscriber::commandFailed — Notification method for a failed command
  • MongoDB\Driver\Monitoring\CommandSubscriber::commandStarted — Notification method for a started command
  • MongoDB\Driver\Monitoring\CommandSubscriber::commandSucceeded — Notification method for a successful command


Notification method for a failed command

  • ? MongoDB\Driver\Monitoring\CommandSubscriber
  • MongoDB\Driver\Monitoring\CommandSubscriber::commandStarted ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSubscriber
  • Notification method for a failed command

MongoDB\Driver\Monitoring\CommandSubscriber::commandFailed

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSubscriber::commandFailed — Notification method for a failed command

说明

abstract public MongoDB\Driver\Monitoring\CommandSubscriber::commandFailed ( MongoDB\Driver\Monitoring\CommandFailedEvent $event ) : void

If the subscriber has been registered with MongoDB\Driver\Monitoring\addSubscriber(), the driver will call this method when a command has failed.

参数

event (MongoDB\Driver\Monitoring\CommandFailedEvent)

An event object encapsulating information about the failed command.

返回值

没有返回值。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandFailedEvent
  • MongoDB\Driver\Monitoring\addSubscriber() - Registers a new monitoring event subscriber
  • Application Performance Monitoring (APM)


Notification method for a started command

  • ? MongoDB\Driver\Monitoring\CommandSubscriber::commandFailed
  • MongoDB\Driver\Monitoring\CommandSubscriber::commandSucceeded ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSubscriber
  • Notification method for a started command

MongoDB\Driver\Monitoring\CommandSubscriber::commandStarted

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSubscriber::commandStarted — Notification method for a started command

说明

abstract public MongoDB\Driver\Monitoring\CommandSubscriber::commandStarted ( MongoDB\Driver\Monitoring\CommandStartedEvent $event ) : void

If the subscriber has been registered with MongoDB\Driver\Monitoring\addSubscriber(), the driver will call this method when a command has started.

参数

event (MongoDB\Driver\Monitoring\CommandStartedEvent)

An event object encapsulating information about the started command.

返回值

没有返回值。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandStartedEvent
  • MongoDB\Driver\Monitoring\addSubscriber() - Registers a new monitoring event subscriber
  • Application Performance Monitoring (APM)


Notification method for a successful command

  • ? MongoDB\Driver\Monitoring\CommandSubscriber::commandStarted
  • MongoDB\Driver\Monitoring\Subscriber ?
  • PHP Manual
  • MongoDB\Driver\Monitoring\CommandSubscriber
  • Notification method for a successful command

MongoDB\Driver\Monitoring\CommandSubscriber::commandSucceeded

(mongodb >=1.3.0)

MongoDB\Driver\Monitoring\CommandSubscriber::commandSucceeded — Notification method for a successful command

说明

abstract public MongoDB\Driver\Monitoring\CommandSubscriber::commandSucceeded ( MongoDB\Driver\Monitoring\CommandSucceededEvent $event ) : void

If the subscriber has been registered with MongoDB\Driver\Monitoring\addSubscriber(), the driver will call this method when a command has succeeded.

参数

event (MongoDB\Driver\Monitoring\CommandSucceededEvent)

An event object encapsulating information about the successful command.

返回值

没有返回值。

错误／异常

  • Throws MongoDB\Driver\Exception\InvalidArgumentException on argument parsing errors.

参见

  • MongoDB\Driver\Monitoring\CommandSucceededEvent
  • MongoDB\Driver\Monitoring\addSubscriber() - Registers a new monitoring event subscriber
  • Application Performance Monitoring (APM)


The MongoDB\Driver\Monitoring\Subscriber interface

(mongodb >=1.3.0)

简介

Base interface for event subscribers. This is used for type-hinting MongoDB\Driver\Monitoring\addSubscriber() and MongoDB\Driver\Monitoring\removeSubscriber() and should not be implemented directly.

接口摘要

MongoDB\Driver\Monitoring\Subscriber {
}

This interface has no methods. Its only purpose is to be the base interface for all event subscribers.


Exception 类

  • MongoDB\Driver\Exception\AuthenticationException — The MongoDB\Driver\Exception\AuthenticationException class
  • MongoDB\Driver\Exception\BulkWriteException — The MongoDB\Driver\Exception\BulkWriteException class
  • MongoDB\Driver\Exception\ConnectionException — The MongoDB\Driver\Exception\ConnectionException class
  • MongoDB\Driver\Exception\ConnectionTimeoutException — The MongoDB\Driver\Exception\ConnectionTimeoutException class
  • MongoDB\Driver\Exception\Exception — The MongoDB\Driver\Exception\Exception interface
  • MongoDB\Driver\Exception\ExecutionTimeoutException — The MongoDB\Driver\Exception\ExecutionTimeoutException class
  • MongoDB\Driver\Exception\InvalidArgumentException — The MongoDB\Driver\Exception\InvalidArgumentException class
  • MongoDB\Driver\Exception\LogicException — The MongoDB\Driver\Exception\LogicException class
  • MongoDB\Driver\Exception\RuntimeException — The MongoDB\Driver\Exception\RuntimeException class
    • MongoDB\Driver\Exception\RuntimeException::hasErrorLabel — Returns whether an error label is associated with an exception
  • MongoDB\Driver\Exception\SSLConnectionException — The MongoDB\Driver\Exception\SSLConnectionException class (deprecated)
  • MongoDB\Driver\Exception\UnexpectedValueException — The MongoDB\Driver\Exception\UnexpectedValueException class
  • MongoDB\Driver\Exception\WriteException — The MongoDB\Driver\Exception\WriteException class
    • MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation


The MongoDB\Driver\Exception\AuthenticationException class

(mongodb >= 1.0.0)

简介

Thrown when the driver fails to authenticate with the server.

类摘要

MongoDB\Driver\Exception\AuthenticationException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\BulkWriteException class

(mongodb >= 1.0.0)

简介

Thrown when a bulk write operation fails.

类摘要

MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected MongoDB\Driver\WriteResult $writeResult ;
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public MongoDB\Driver\Exception\WriteException::getWriteResult ( ) : MongoDB\Driver\WriteResult
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\ConnectionException class

(mongodb >= 1.0.0)

简介

Base class for exceptions thrown when the driver fails to establish a database connection.

类摘要

MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\ConnectionTimeoutException class

(mongodb >= 1.0.0)

简介

Thrown when the driver fails to establish a database connection within a specified time limit (connectTimeoutMS) or server selection fails (serverSelectionTimeoutMS).

类摘要

final MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\Exception interface

(mongodb >= 1.0.0)

简介

Common interface for all driver exceptions. This may be used to catch only exceptions originating from the driver itself.

类摘要

MongoDB\Driver\Exception\Exception {
}


The MongoDB\Driver\Exception\ExecutionTimeoutException class

(mongodb >= 1.0.0)

简介

Thrown when a query or command fails to complete within a specified time limit (e.g. » maxTimeMS).

类摘要

final MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\ServerException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

更新日志

版本 | 说明
PECL mongodb 1.5.0 | This class now extends MongoDB\Driver\Exception\ServerException instead of MongoDB\Driver\Exception\RuntimeException.


The MongoDB\Driver\Exception\InvalidArgumentException class

(mongodb >= 1.0.0)

简介

Thrown when a driver method is given invalid arguments (e.g. invalid option types).

类摘要

MongoDB\Driver\Exception\InvalidArgumentException extends InvalidArgumentException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\LogicException class

(mongodb >= 1.0.0)

简介

Thrown when the driver is incorrectly used (e.g. rewinding a cursor).

类摘要

MongoDB\Driver\Exception\LogicException extends LogicException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\RuntimeException class

(mongodb >= 1.0.0)

简介

Thrown when the driver encounters a runtime error (e.g. internal error from » libmongoc).

类摘要

MongoDB\Driver\Exception\RuntimeException extends RuntimeException implements MongoDB\Driver\Exception\Exception {
/* 属性 */
protected array|null $errorLabels ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
final public hasErrorLabel ( string $errorLabel ) : bool
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

errorLabels

Contains an array of error labels to go with an exception. For example, error labels can be used to detect whether a transaction can be retried safely if the TransientTransactionError label is present. The existence of a specific error label should be tested for with the MongoDB\Driver\Exception\RuntimeException::hasErrorLabel(), instead of interpreting this errorLabels property manually.

更新日志

版本 | 说明
PECL mongodb 1.6.0 | The MongoDB\Driver\Exception\RuntimeException::hasErrorLabel() method and MongoDB\Driver\Exception\RuntimeException::errorLabels property have been added.

Table of Contents

  • MongoDB\Driver\Exception\RuntimeException::hasErrorLabel — Returns whether an error label is associated with an exception


Returns whether an error label is associated with an exception

  • ? MongoDB\Driver\Exception\RuntimeException
  • MongoDB\Driver\Exception\SSLConnectionException ?
  • PHP Manual
  • MongoDB\Driver\Exception\RuntimeException
  • Returns whether an error label is associated with an exception

MongoDB\Driver\Exception\RuntimeException::hasErrorLabel

(mongodb >= 1.6.0)

MongoDB\Driver\Exception\RuntimeException::hasErrorLabel — Returns whether an error label is associated with an exception

说明

final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool

Returns whether the errorLabel has been set for this exception. Error labels are set by either the server or the driver to indicated specific situations on which you might want to decide on how you want to handle a specific exception. A common situation might be to find out whether you can safely retry a transaction that failed due to a transient error (like a networking issue, or a transaction conflict). Examples of error labels are TransientTransactionError and UnknownTransactionCommitResult.

参数

errorLabel

The name of the errorLabel to test for.

返回值

Whether the given errorLabel is associated with this exception.

参见

  • MongoDB\Driver\Session::commitTransaction()
  • » MongoDB documentation on transactions


The MongoDB\Driver\Exception\SSLConnectionException class (deprecated)

(mongodb >= 1.0.0)

Warning

This exception class is deprecated and may be removed in a future major version. The driver has never thrown this exception.

简介

Thrown when the driver fails to establish an SSL connection with the server.

类摘要

final MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\UnexpectedValueException class

(mongodb >= 1.0.0)

简介

Thrown when the driver encounters an unexpected value (e.g. during BSON serialization or deserialization).

类摘要

MongoDB\Driver\Exception\UnexpectedValueException extends UnexpectedValueException implements MongoDB\Driver\Exception\Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The MongoDB\Driver\Exception\WriteException class

(mongodb >= 1.0.0)

简介

Base class for exceptions thrown by a failed write operation. The exception encapsulates a MongoDB\Driver\WriteResult object.

类摘要

abstract MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\ServerException implements MongoDB\Driver\Exception\Exception {
/* 属性 */
protected MongoDB\Driver\WriteResult $writeResult ;
/* 继承的属性 */
protected array|null $errorLabels ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
final public getWriteResult ( ) : MongoDB\Driver\WriteResult
/* 继承的方法 */
final public MongoDB\Driver\Exception\RuntimeException::hasErrorLabel ( string $errorLabel ) : bool
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

writeResult

The MongoDB\Driver\WriteResult associated with the failed write operation.

更新日志

版本 | 说明
PECL mongodb 1.5.0 | This class now extends MongoDB\Driver\Exception\ServerException instead of MongoDB\Driver\Exception\RuntimeException.

Table of Contents

  • MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation


Returns the WriteResult for the failed write operation

  • ? MongoDB\Driver\Exception\WriteException
  • MySQL ?
  • PHP Manual
  • MongoDB\Driver\Exception\WriteException
  • Returns the WriteResult for the failed write operation

MongoDB\Driver\Exception\WriteException::getWriteResult

(mongodb >= 1.0.0)

MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation

说明

final public MongoDB\Driver\Exception\WriteException::getWriteResult ( ) : MongoDB\Driver\WriteResult

Returns the MongoDB\Driver\WriteResult for the failed write operation. The MongoDB\Driver\WriteResult::getWriteErrors() and MongoDB\Driver\WriteResult::getWriteConcernError() methods may be used to get more details about the failure.

参数

此函数没有参数。

返回值

The MongoDB\Driver\WriteResult for the failed write operation.

范例

Example #1 MongoDB\Driver\Exception\WriteException::getWriteResult() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost');
$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\WriteException $e) {
    $writeResult = $e->getWriteResult();

    if ($writeConcernError = $writeResult->getWriteConcernError()) {
        var_dump($writeConcernError);
    }

    if ($writeErrors = $writeResult->getWriteErrors()) {
        var_dump($writeErrors);
    }
}

?>

以上例程的输出类似于：

array(1) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(70) "E11000 duplicate key error index: db.collection.$_id_ dup key: { : 1 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(1)
    ["info"]=>
    NULL
  }
}

参见

  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations


MySQL Drivers and Plugins

PHP offers several MySQL drivers and plugins for accessing and handling MySQL.

The differences and functionality of the MySQL extensions are described within the overview of this section.

  • Overview of the MySQL PHP drivers
    • Terminology overview
    • Choosing an API
    • Choosing a library
    • Concepts
  • Mysqli — MySQL增强版扩展
    • 简介
    • Overview
    • Quick start guide
    • 安装／配置
    • mysqli 扩展和持久化连接
    • 预定义常量
    • Notes
    • MySQLi 扩展的功能概述
    • MySQLi — MySQLi类
    • MySQLi_STMT — MySQLi_STMT类
    • mysqli_result — mysqli_result类
    • MySQLi_Driver — MySQLi_Driver类
    • MySQLi_Warning — MySQLi_Warning类
    • mysqli_sql_exception — mysqli异常类
    • 别名和过时的 Mysqli 函数
  • Mysql_xdevapi
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Mysql_xdevapi 函数
    • mysql_xdevapi\BaseResult — BaseResult interface
    • mysql_xdevapi\Client — Client class
    • mysql_xdevapi\Collection — Collection class
    • mysql_xdevapi\CollectionAdd — CollectionAdd class
    • mysql_xdevapi\CollectionFind — CollectionFind class
    • mysql_xdevapi\CollectionModify — CollectionModify class
    • mysql_xdevapi\CollectionRemove — CollectionRemove class
    • mysql_xdevapi\ColumnResult — ColumnResult class
    • mysql_xdevapi\CrudOperationBindable — CrudOperationBindable interface
    • mysql_xdevapi\CrudOperationLimitable — CrudOperationLimitable interface
    • mysql_xdevapi\CrudOperationSkippable — CrudOperationSkippable interface
    • mysql_xdevapi\CrudOperationSortable — CrudOperationSortable interface
    • mysql_xdevapi\DatabaseObject — DatabaseObject interface
    • mysql_xdevapi\DocResult — DocResult class
    • mysql_xdevapi\Exception — Exception class
    • mysql_xdevapi\Executable — Executable interface
    • mysql_xdevapi\ExecutionStatus — ExecutionStatus class
    • mysql_xdevapi\Expression — Expression class
    • mysql_xdevapi\Result — Result class
    • mysql_xdevapi\RowResult — RowResult class
    • mysql_xdevapi\Schema — Schema class
    • mysql_xdevapi\SchemaObject — SchemaObject interface
    • mysql_xdevapi\Session — Session class
    • mysql_xdevapi\SqlStatement — SqlStatement class
    • mysql_xdevapi\SqlStatementResult — SqlStatementResult class
    • mysql_xdevapi\Statement — Statement class
    • mysql_xdevapi\Table — Table class
    • mysql_xdevapi\TableDelete — TableDelete class
    • mysql_xdevapi\TableInsert — TableInsert class
    • mysql_xdevapi\TableSelect — TableSelect class
    • mysql_xdevapi\TableUpdate — TableUpdate class
    • mysql_xdevapi\Warning — Warning class
  • Mysql（原始） — 原始的 MySQL API
    • 简介
    • 安装／配置
    • 更新日志
    • 预定义常量
    • 范例
    • MySQL 函数
  • Mysqlnd — MySQL Native Driver
    • 简介
    • Overview
    • Installation
    • 运行时配置
    • Incompatibilities
    • Persistent Connections
    • Statistics
    • Notes
    • Memory management
    • MySQL Native Driver Plugin API
  • mysqlnd_ms — Mysqlnd 主从复制和负载均衡插件
    • 简介
    • 快速入门与例子
    • 概念
    • 安装／配置
    • 预定义常量
    • Mysqlnd_ms 函数
    • Change History
  • mysqlnd_qc — Mysqlnd query result cache plugin
    • 简介
    • Quickstart and Examples
    • 安装／配置
    • 预定义常量
    • mysqlnd_qc 函数
    • Change History
  • mysqlnd_uh — Mysqlnd user handler plugin
    • 简介
    • Quickstart and Examples
    • 安装／配置
    • 预定义常量
    • MysqlndUhConnection — The MysqlndUhConnection class
    • MysqlndUhPreparedStatement — The MysqlndUhPreparedStatement class
    • Mysqlnd_uh 函数
    • Change History
  • mysqlnd_mux — Mysqlnd connection multiplexing plugin
    • 简介
    • Concepts
    • 安装／配置
    • 预定义常量
    • Change History
  • mysqlnd_memcache — Mysqlnd Memcache plugin
    • 简介
    • Quickstart and Examples
    • 安装／配置
    • 预定义常量
    • Mysqlnd_memcache 函数
    • Change History


Overview of the MySQL PHP drivers

Introduction

There are several PHP APIs for accessing the MySQL database. Users can choose between the mysqli or PDO_MySQL extensions.

This guide explains the terminology used to describe each API, information about choosing which API to use, and also information to help choose which MySQL library to use with the API.

  • Terminology overview
  • Choosing an API
  • Choosing a library
  • Concepts
    • Buffered and Unbuffered queries
    • Character sets


Terminology overview

This section provides an introduction to the options available to you when developing a PHP application that needs to interact with a MySQL database.

What is an API?

An Application Programming Interface, or API, defines the classes, methods, functions and variables that your application will need to call in order to carry out its desired task. In the case of PHP applications that need to communicate with databases the necessary APIs are usually exposed via PHP extensions.

APIs can be procedural or object-oriented. With a procedural API you call functions to carry out tasks, with the object-oriented API you instantiate classes and then call methods on the resulting objects. Of the two, the latter is usually the preferred interface, as it is more modern and leads to better organized code.

When writing PHP applications that need to connect to the MySQL server there are several API options available. This document discusses what is available and how to select the best solution for your application.

What is a Connector?

In the MySQL documentation, the term connector refers to a piece of software that allows your application to connect to the MySQL database server. MySQL provides connectors for a variety of languages, including PHP.

If your PHP application needs to communicate with a database server you will need to write PHP code to perform such activities as connecting to the database server, querying the database and other database-related functions. Software is required to provide the API that your PHP application will use, and also handle the communication between your application and the database server, possibly using other intermediate libraries where necessary. This software is known generically as a connector, as it allows your application to connect to a database server.

What is a Driver?

A driver is a piece of software designed to communicate with a specific type of database server. The driver may also call a library, such as the MySQL Client Library or the MySQL Native Driver. These libraries implement the low-level protocol used to communicate with the MySQL database server.

By way of an example, the PHP Data Objects (PDO) database abstraction layer may use one of several database-specific drivers. One of the drivers it has available is the PDO MYSQL driver, which allows it to interface with the MySQL server.

Sometimes people use the terms connector and driver interchangeably, this can be confusing. In the MySQL-related documentation the term driver is reserved for software that provides the database-specific part of a connector package.

What is an Extension?

In the PHP documentation, you will come across another term - extension. The PHP code consists of a core, with optional extensions to the core functionality. PHP's MySQL-related extension, mysqli, is implemented using the PHP extension framework.

An extension typically exposes an API to the PHP programmer, to allow its facilities to be used programmatically. However, some extensions which use the PHP extension framework do not expose an API to the PHP programmer.

The PDO MySQL driver extension, for example, does not expose an API to the PHP programmer, but provides an interface to the PDO layer above it.

The terms API and extension should not be taken to mean the same thing, as an extension may not necessarily expose an API to the programmer.


Choosing an API

PHP offers different APIs to connect to MySQL. Below we show the APIs provided by the mysqli and PDO extensions. Each code snippet creates a connection to a MySQL server running on "example.com" using the username "user" and the password "password". And a query is run to greet the user.

Example #1 Comparing the MySQL APIs

<?php
// mysqli
$mysqli = new mysqli("example.com", "user", "password", "database");
$result = $mysqli->query("SELECT 'Hello, dear MySQL user!' AS _message FROM DUAL");
$row = $result->fetch_assoc();
echo htmlentities($row['_message']);

// PDO
$pdo = new PDO('mysql:host=example.com;dbname=database', 'user', 'password');
$statement = $pdo->query("SELECT 'Hello, dear MySQL user!' AS _message FROM DUAL");
$row = $statement->fetch(PDO::FETCH_ASSOC);
echo htmlentities($row['_message']);

Feature comparison

The overall performance of both extensions is considered to be about the same. Although the performance of the extension contributes only a fraction of the total run time of a PHP web request. Often, the impact is as low as 0.1%.

 | ext/mysqli | PDO_MySQL
PHP version introduced | 5.0 | 5.1
Included with PHP 7.x and 8.x | Yes | Yes
Development status | Active | Active
Lifecycle | Active | Active
Recommended for new projects | Yes | Yes
OOP Interface | Yes | Yes
Procedural Interface | Yes | No
API supports non-blocking, asynchronous queries with mysqlnd | Yes | No
Persistent Connections | Yes | Yes
API supports Charsets | Yes | Yes
API supports server-side Prepared Statements | Yes | Yes
API supports client-side Prepared Statements | No | Yes
API supports Stored Procedures | Yes | Yes
API supports Multiple Statements | Yes | Most
API supports Transactions | Yes | Yes
Transactions can be controlled with SQL | Yes | Yes
Supports all MySQL 5.1+ functionality | Yes | Most


Choosing a library

The mysqli and PDO_MySQL PHP extensions are lightweight wrappers on top of a C client library. The extensions can either use the mysqlnd library or the libmysqlclient library. Choosing a library is a compile time decision.

The mysqlnd library is part of the PHP distribution. It offers features like lazy connections and query caching, features that are not available with libmysqlclient, so using the built-in mysqlnd library is highly recommended. See the mysqlnd documentation for additional details, and a listing of features and functionality that it offers.

Example #1 Configure commands for using mysqlnd or libmysqlclient

// Recommended, compiles with mysqlnd
$ ./configure --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd

// Alternatively recommended, compiles with mysqlnd
$ ./configure --with-mysqli --with-pdo-mysql

// Not recommended, compiles with libmysqlclient
$ ./configure --with-mysqli=/path/to/mysql_config --with-pdo-mysql=/path/to/mysql_config

Library feature comparison

It is recommended to use the mysqlnd library instead of the MySQL Client Server library (libmysqlclient). Both libraries are supported and constantly being improved.

 | MySQL native driver (mysqlnd) | MySQL client server library (libmysqlclient)
Part of the PHP distribution | Yes | No
PHP version introduced | 5.3.0 | N/A
License | PHP License 3.01 | Dual-License
Development status | Active | Active
Lifecycle | No end announced | No end announced
Compile default (for all MySQL extensions) | Yes | No
Compression protocol support | Yes | Yes
SSL support | Yes | Yes
Named pipe support | Yes | Yes
Non-blocking, asynchronous queries | Yes | No
Performance statistics | Yes | No
LOAD LOCAL INFILE respects the open_basedir directive | Yes | No
Uses PHP's native memory management system (e.g., follows PHP memory limits) | Yes | No
Return numeric column as double (COM_QUERY) | Yes | No
Return numeric column as string (COM_QUERY) | Yes | Yes
Plugin API | Yes | Limited
Read/Write splitting for MySQL Replication | Yes, with plugin | No
Load Balancing | Yes, with plugin | No
Fail over | Yes, with plugin | No
Lazy connections | Yes, with plugin | No
Query caching | Yes, with plugin | No
Transparent query manipulations (E.g., auto-EXPLAIN or monitoring) | Yes, with plugin | No
Automatic reconnect | No | Optional


Concepts

Table of Contents

  • Buffered and Unbuffered queries
  • Character sets

These concepts are specific to the MySQL drivers for PHP.


Buffered and Unbuffered queries

Queries are using the buffered mode by default. This means that query results are immediately transferred from the MySQL Server to PHP and then are kept in the memory of the PHP process. This allows additional operations like counting the number of rows, and moving (seeking) the current result pointer. It also allows issuing further queries on the same connection while working on the result set. The downside of the buffered mode is that larger result sets might require quite a lot memory. The memory will be kept occupied till all references to the result set are unset or the result set was explicitly freed, which will automatically happen during request end the latest. The terminology "store result" is also used for buffered mode, as the whole result set is stored at once.

Note:

When using libmysqlclient as library PHP's memory limit won't count the memory used for result sets unless the data is fetched into PHP variables. With mysqlnd the memory accounted for will include the full result set.

Unbuffered MySQL queries execute the query and then return a resource while the data is still waiting on the MySQL server for being fetched. This uses less memory on the PHP-side, but can increase the load on the server. Unless the full result set was fetched from the server no further queries can be sent over the same connection. Unbuffered queries can also be referred to as "use result".

Following these characteristics buffered queries should be used in cases where you expect only a limited result set or need to know the amount of returned rows before reading all rows. Unbuffered mode should be used when you expect larger results.

Because buffered queries are the default, the examples below will demonstrate how to execute unbuffered queries with each API.

Example #1 Unbuffered query example: mysqli

<?php
$mysqli  = new mysqli("localhost", "my_user", "my_password", "world");
$uresult = $mysqli->query("SELECT Name FROM City", MYSQLI_USE_RESULT);

if ($uresult) {
   while ($row = $uresult->fetch_assoc()) {
       echo $row['Name'] . PHP_EOL;
   }
}
?>

Example #2 Unbuffered query example: pdo_mysql

<?php
$pdo = new PDO("mysql:host=localhost;dbname=world", 'my_user', 'my_pass');
$pdo->setAttribute(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY, false);

$uresult = $pdo->query("SELECT Name FROM City");
if ($uresult) {
   while ($row = $uresult->fetch(PDO::FETCH_ASSOC)) {
       echo $row['Name'] . PHP_EOL;
   }
}
?>


Character sets

Ideally a proper character set will be set at the server level, and doing this is described within the » Character Set Configuration section of the MySQL Server manual. Alternatively, each MySQL API offers a method to set the character set at runtime.

Caution

The character set and character escaping

The character set should be understood and defined, as it has an affect on every action, and includes security implications. For example, the escaping mechanism (e.g., mysqli_real_escape_string() for mysqli and PDO::quote() for PDO_MySQL) will adhere to this setting. It is important to realize that these functions will not use the character set that is defined with a query, so for example the following will not have an effect on them:

Example #1 Problems with setting the character set with SQL

<?php

$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

// Will NOT affect $mysqli->real_escape_string();
$mysqli->query("SET NAMES utf8mb4");

// Will NOT affect $mysqli->real_escape_string();
$mysqli->query("SET CHARACTER SET utf8mb4");

// But, this will affect $mysqli->real_escape_string();
$mysqli->set_charset('utf8mb4');

// But, this will NOT affect it (UTF-8 vs utf8mb4) -- don't use dashes here
$mysqli->set_charset('UTF-8');
?>

Below are examples that demonstrate how to properly alter the character set at runtime using each API.

Note: Possible UTF-8 confusion

Because character set names in MySQL do not contain dashes, the string "utf8" is valid in MySQL to set the character set to UTF-8 (up to 3 byte UTF-8 Unicode Encoding). The string "UTF-8" is not valid, as using "UTF-8" will fail to change the character set and will throw an error.

Example #2 Setting the character set example: mysqli

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

echo 'Initial character set: ' . $mysqli->character_set_name() . "\n";

if (!$mysqli->set_charset('utf8mb4')) {
    printf("Error loading character set utf8mb4: %s\n", $mysqli->error);
    exit;
}

echo 'Your current character set is: ' . $mysqli->character_set_name() . "\n";
?>

Example #3 Setting the character set example: pdo_mysql

<?php
$pdo = new PDO("mysql:host=localhost;dbname=world;charset=utf8mb4", 'my_user', 'my_pass');
?>


MySQL增强版扩展

  • 简介
  • Overview
  • Quick start guide
    • Dual procedural and object-oriented interface
    • Connections
    • Executing statements
    • Prepared Statements
    • Stored Procedures
    • Multiple Statements
    • API support for transactions
    • Metadata
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • mysqli 扩展和持久化连接
  • 预定义常量
  • Notes
  • MySQLi 扩展的功能概述
  • MySQLi — MySQLi类
    • mysqli::$affected_rows — Gets the number of affected rows in a previous MySQL operation
    • mysqli::autocommit — 打开或关闭本次数据库连接的自动命令提交事务模式
    • mysqli::begin_transaction — Starts a transaction
    • mysqli::change_user — Changes the user of the specified database connection
    • mysqli::character_set_name — 返回当前数据库连接的默认字符编码
    • mysqli::close — 关闭先前打开的数据库连接
    • mysqli::commit — 提交一个事务
    • mysqli::$connect_errno — Returns the error code from last connect call
    • mysqli::$connect_error — Returns a string description of the last connect error
    • mysqli::__construct — Open a new connection to the MySQL server
    • mysqli::debug — Performs debugging operations
    • mysqli::dump_debug_info — 将调试信息输出到日志
    • mysqli::errno — 返回最近函数调用的错误代码
    • mysqli::$error_list — Returns a list of errors from the last command executed
    • mysqli::$error — Returns a string description of the last error
    • mysqli::$field_count — Returns the number of columns for the most recent query
    • mysqli::get_charset — Returns a character set object
    • mysqli::$client_info — 获取 MySQL 客户端信息
    • mysqli_get_client_version — 作为一个整数返回MySQL客户端的版本
    • mysqli::get_connection_stats — 返回客户端连接的统计数据
    • mysqli::$host_info — 返回一个表述使用的连接类型的字符串
    • mysqli::$protocol_version — 返回MySQL使用的协议版本号
    • mysqli::$server_info — 返回MySQL服务器的版本号
    • mysqli::$server_version — 作为一个整数返回MySQL服务器的版本
    • mysqli::get_warnings — Get result of SHOW WARNINGS
    • mysqli::$info — 返回最近执行的 SQL 语句的信息
    • mysqli::init — 初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数
    • mysqli::$insert_id — 返回最后一条插入语句产生的自增 ID
    • mysqli::kill — 让服务器杀掉一个 MySQL 线程
    • mysqli::more_results — 检查批量查询中是否还有查询结果
    • mysqli::multi_query — 执行查询
    • mysqli::next_result — 为读取 multi_query 执行之后的下一个结果集做准备
    • mysqli::options — 设置选项
    • mysqli::ping — ping 一个连接，或者如果连接处于断开状态，重新连接
    • mysqli::poll — 轮询连接
    • mysqli::prepare — 准备执行一个 SQL 语句
    • mysqli::query — 对数据库执行一次查询
    • mysqli::real_connect — 建立一个 MySQL 服务器连接
    • mysqli::real_escape_string — 根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义
    • mysqli::real_query — 执行一个mysql查询
    • mysqli::reap_async_query — 获取异步查询的结果
    • mysqli::refresh — 刷新
    • mysqli::release_savepoint — 从当前事务的保存点中移除一个命名保存点
    • mysqli::rollback — 回退当前事务
    • mysqli::savepoint — 在当前事务中增加一个命名保存点
    • mysqli::select_db — 选择用于数据库查询的默认数据库
    • mysqli::set_charset — 设置默认字符编码
    • mysqli::$sqlstate — 返回上一次 SQL 操作的 SQLSTATE 错误信息
    • mysqli::ssl_set — 使用 SSL 建立到数据库之间的安全连接
    • mysqli::stat — 获取当前系统状态信息
    • mysqli::stmt_init — 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象
    • mysqli::store_result — 转移上一次查询返回的结果集
    • mysqli::$thread_id — 返回当前连接的线程 ID
    • mysqli::thread_safe — 返回是否是线程安全的
    • mysqli::use_result — Initiate a result set retrieval
    • mysqli::$warning_count — Returns the number of warnings from the last query for the given link
  • MySQLi_STMT — MySQLi_STMT类
    • mysqli_stmt::$affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement
    • mysqli_stmt::attr_get — Used to get the current value of a statement attribute
    • mysqli_stmt::attr_set — Used to modify the behavior of a prepared statement
    • mysqli_stmt::bind_param — Binds variables to a prepared statement as parameters
    • mysqli_stmt::bind_result — Binds variables to a prepared statement for result storage
    • mysqli_stmt::close — Closes a prepared statement
    • mysqli_stmt::__construct — Constructs a new mysqli_stmt object
    • mysqli_stmt::data_seek — Seeks to an arbitrary row in statement result set
    • mysqli_stmt::$errno — Returns the error code for the most recent statement call
    • mysqli_stmt::$error_list — Returns a list of errors from the last statement executed
    • mysqli_stmt::$error — Returns a string description for last statement error
    • mysqli_stmt::execute — Executes a prepared Query
    • mysqli_stmt::fetch — Fetch results from a prepared statement into the bound variables
    • mysqli_stmt::$field_count — Returns the number of columns in the given statement
    • mysqli_stmt::free_result — Frees stored result memory for the given statement handle
    • mysqli_stmt::get_result — Gets a result set from a prepared statement
    • mysqli_stmt::get_warnings — Get result of SHOW WARNINGS
    • mysqli_stmt::$insert_id — Get the ID generated from the previous INSERT operation
    • mysqli_stmt::more_results — Check if there are more query results from a multiple query
    • mysqli_stmt::next_result — Reads the next result from a multiple query
    • mysqli_stmt::$num_rows — Return the number of rows in statements result set
    • mysqli_stmt::$param_count — Returns the number of parameters for the given statement
    • mysqli_stmt::prepare — Prepare an SQL statement for execution
    • mysqli_stmt::reset — Resets a prepared statement
    • mysqli_stmt::result_metadata — Returns result set metadata from a prepared statement
    • mysqli_stmt::send_long_data — Send data in blocks
    • mysqli_stmt::$sqlstate — Returns SQLSTATE error from previous statement operation
    • mysqli_stmt::store_result — Transfers a result set from a prepared statement
  • mysqli_result — mysqli_result类
    • mysqli_result::$current_field — Get current field offset of a result pointer
    • mysqli_result::data_seek — Adjusts the result pointer to an arbitrary row in the result
    • mysqli_result::fetch_all — Fetches all result rows as an associative array, a numeric array, or both
    • mysqli_result::fetch_array — Fetch a result row as an associative, a numeric array, or both
    • mysqli_result::fetch_assoc — Fetch a result row as an associative array
    • mysqli_result::fetch_field_direct — Fetch meta-data for a single field
    • mysqli_result::fetch_field — Returns the next field in the result set
    • mysqli_result::fetch_fields — Returns an array of objects representing the fields in a result set
    • mysqli_result::fetch_object — Returns the current row of a result set as an object
    • mysqli_result::fetch_row — Get a result row as an enumerated array
    • mysqli_result::$field_count — Get the number of fields in a result
    • mysqli_result::field_seek — Set result pointer to a specified field offset
    • mysqli_result::free — Frees the memory associated with a result
    • mysqli_result::$lengths — Returns the lengths of the columns of the current row in the result set
    • mysqli_result::$num_rows — Gets the number of rows in a result
  • MySQLi_Driver — MySQLi_Driver类
    • mysqli_driver::embedded_server_end — Stop embedded server
    • mysqli_driver::embedded_server_start — Initialize and start embedded server
    • mysqli_driver::$report_mode — Sets mysqli error reporting mode
  • MySQLi_Warning — MySQLi_Warning类
    • mysqli_warning::next — Fetch next warning
  • mysqli_sql_exception — mysqli异常类
  • 别名和过时的 Mysqli 函数
    • mysqli_connect — 别名 mysqli::__construct
    • mysqli_escape_string — 别名 mysqli_real_escape_string
    • mysqli_execute — mysqli_stmt_execute 的别名
    • mysqli_get_client_stats — 返回客户端进程统计信息
    • mysqli_get_links_stats — 返回打开和缓存的链接相关信息
    • mysqli_report — 别名 mysqli_driver->report_mode
    • mysqli::set_opt — Alias of mysqli_options


简介

mysqli扩展允许我们访问MySQL 4.1及以上版本提供的功能。关于MySQL数据库 服务端的信息请参阅» http://www.mysql.com/。

Overview是在PHP中可以用于MySQL访问的软件的一个概览。

Mysql的文档请查看» http://dev.mysql.com/doc/。

本文档中部分内容经过Oracle公司授权引自MySQL手册。 Parts of this documentation included from MySQL manual with permissions of Oracle Corporation.

示例

所有mysqli文档示例使用的都是world数据库，该数据库可以从» http://dev.mysql.com/doc/world-setup/en/index.html下载。


Overview

这一部分对在PHP应用开发过程中需要和Mysql数据库交互时可用的选择进行一个简单介绍。

什么是API?

一个应用程序接口（Application Programming Interface的缩写），定义了类，方法，函数，变量等等一切 你的应用程序中为了完成特定任务而需要调用的内容。在PHP应用程序需要和数据库进行交互的时候所需要的API 通常是通过PHP扩展暴露出来（给终端PHP程序员调用）。

API可以是面向过程的，也可以是面向对象的。对于面向过程的API，我们通过调用函数来完成任务，而对于面向对象的API， 我们实例化类，并在实例化后得到的对象上调用方法。对于这两种接口而言，后者通常是首选的，因为它更加现代化，并且 给我们带来了良好的代码结构。

当构建一个需要连接到MySQL服务端的PHP应用的时候，有好几种API可供选择。此文档就是讨论这些可用的API并讨论如何为 你的应用选择一个最佳的解决方案。

什么是连接器?

在MySQL文档中，术语connector解释为"一段允许你的应用连接到MySQL数据库服务器的软件代码"。 MySQL提供了很多语言的连接器，其中包括PHP的。

在你的PHP应用需要和一个数据库服务器交互的时候，你需要书写PHP代码去完成"连接数据库服务器"，"查询数据库"以及其他数据库相关功能 等一系列活动。你的PHP应用将会使用提供这些API的软件，或者在需要的时候使用一些中间库，来处理你的应用和数据库服务器之间的交互。 这种软件通常被认为是连接器，它允许你的引用连接到数据库服务器。

什么是驱动?

驱动是一段设计用来于一种特定类型的数据库服务器进行交互的软件代码。驱动可能会调用一些库，比如MySQL客户端库或者MySQL Native驱动库。 这些库实现了用于和MySQL数据库服务器进行交互的底层协议。

通过一个例子PDO(PHP Database Object的缩写)数据库抽象层可以 使用多种特定数据库的驱动。其中一种驱动就是PDO MYSQL驱动，它就是与MySQL服务器之间的接口。

有时大家会不加区分的使用连接器和驱动这两个术语。在MySQL相关文档中driver术语被作为一个连接器包 中提供特定数据库部分的软件代码。

什么是扩展?

在PHP文档中你还会发现很多其他的扩展。PHP代码是由一个核心，一些可选扩展组成了核心功能。PHP 的MySQL相关扩展，比如mysqli，mysql都是基于PHP扩展框架实现的。

扩展一个典型的作用就是暴露一个API给PHP程序员，允许扩展自己的功能可以被程序员使用。当然，也有一部分基于PHP扩展框架 开发的扩展不会给PHP程序员暴露API接口。

比如说PDO MySQL驱动扩展，就没有向PHP程序员暴露API接口，但是向它上层的PDO层提供了一个接口。

术语API和扩展描述的不是同一类事物，因为扩展可能并不需要暴露一个API接口给程序员。

PHP中提供的用于MySQL的主要API是什么？

当考虑连接到MySQL数据库服务器的时候，有三种主要的API可供选择：

  • PHP的MySQL扩展

  • PHP的mysqli扩展

  • PHP数据对象(PDO)

三者都有各自的优缺点。下面的讨论就是为了对每种API的关键方面给出一个简短的介绍。

什么是PHP的MySQL扩展?

这是设计开发允许PHP应用与MySQL数据库交互的早期扩展。mysql扩展提供了一个面向过程 的接口，并且是针对MySQL4.1.3或更早版本设计的。因此，这个扩展虽然可以与MySQL4.1.3或更新的数据库服务端 进行交互，但并不支持后期MySQL服务端提供的一些特性。

Note:

如果你是使用MySQL4.1.3或更新的服务端版本，强烈建议你使用mysqli 扩展替代它。

mysql扩展的源代码在PHP扩展目录ext/mysql下。

对于mysql扩展的更多信息，请参阅Mysql（原始）。

什么是PHP的mysqli扩展?

mysqli扩展，我们有时称之为MySQL增强扩展，可以用于使用 MySQL4.1.3或更新版本中新的高级特性。mysqli扩展在PHP 5及以后版本中包含。

mysqli扩展有一系列的优势，相对于mysql扩展的提升主要有：

  • 面向对象接口

  • prepared语句支持（译注：关于prepare请参阅mysql相关文档）

  • 多语句执行支持

  • 事务支持

  • 增强的调试能力

  • 嵌入式服务支持

Note:

如果你使用MySQL4.1.3或更新版本，强烈建议你使用这个扩展。

在提供了面向对象接口的同时也提供了一个面向过程的接口。

mysqli扩展是使用PHP扩展框架构建的，它的源代码在PHP源码目录下的ext/mysqli中。

对于mysqli扩展的更多信息，请参阅Mysqli。

什么是PDO?

PHP数据对象，是PHP应用中的一个数据库抽象层规范。PDO提供了一个统一的API接口可以使得你的PHP应用不去关心具体要 连接的数据库服务器系统类型。也就是说，如果你使用PDO的API，可以在任何需要的时候无缝切换数据库服务器，比如从Firebird 到MySQL，仅仅需要修改很少的PHP代码。

其他数据库抽象层的例子包括Java应用中的JDBC以及Perl中的DBI。

当然，PDO也有它自己的先进性，比如一个干净的，简单的，可移植的API，它最主要的缺点是会限制让你不能使用 后期MySQL服务端提供所有的数据库高级特性。比如，PDO不允许使用MySQL支持的多语句执行。

PDO是基于PHP扩展框架实现的，它的源码在PHP源码目录的ext/pdo下。

PDO的更多信息，请参阅PDO。

什么是PDO的MySQL驱动器?

PDO的MySQL驱动并不是一套API，至少从PHP程序员的角度来看是这样的。实际上，PDO的MySQL驱动处于PDO自己的下层， 提供了特定的Mysql功能。程序员直接调用PDO的API，而PDO使用了PDO的MySQL驱动完成与MySQL服务器端的交互。

PDO的MySQL驱动是众多PDO驱动中的一个。其他可用的PDO驱动包括Firebird，PostgreSQL等等。

PDO的MySQL驱动是基于PHP扩展框架实现的。它的源码在PHP源码目录下的ext/pdo_mysql。 它没有向PHP程序员暴露API。

PDO的MySQL扩展的更多信息请参阅MySQL (PDO)。

什么是PHP的MySQL Native 驱动?

为了与MySQL数据库服务端进行交互，mysql扩展，mysqli扩展， PDO MySQL驱动都使用了实现了必要的协议的底层库。以前，可用的库只有MySQL客户端库和libmysql。

然而，libmysql包含的接口没有针对与PHP的应用交互进行优化，libmysql 是早期为C应用程序设计的。基于这个原因，MySQL Native驱动mysqlnd，作为libmysql的一个 针对PHP应用的修改版本被开发。

mysql，mysqli以及PDO Mysql驱动都可以各自配置使用 libmysql或者mysqlnd。mysqlnd作为一个专门设计 用于PHP系统的库，它在内存和速度上都比libmysql有很大提升。非常希望你去尝试这些提升。

Note:

MySQL Native驱动仅仅可以在MySQL服务端版本为4.1.3及以后版本才可以使用。

MySQL Native驱动是基于PHP扩展框架实现的。源代码位于PHP源码目录的ext/mysqlnd下。 它没有向PHP程序员暴露接口。

特性比较

下表比较了PHP中三种主要的MySQL连接方式的功能：

 | PHP的mysqli扩展 | PDO (使用PDO MySQL驱动和MySQL Native驱动) | PHP的mysql扩展
引入的PHP版本 | 5.0 | 5.0 | 3.0之前
PHP5.x是否包含 | 是 | 是 | 是
MySQL开发状态 | 活跃 | 在PHP5.3中活跃 | 仅维护
在MySQL新项目中的建议使用程度 | 建议 - 首选 | 建议 | 不建议
API的字符集支持 | 是 | 是 | 否
服务端prepare语句的支持情况 | 是 | 是 | 否
客户端prepare语句的支持情况 | 否 | 是 | 否
存储过程支持情况 | 是 | 是 | 否
多语句执行支持情况 | 是 | 大多数 | 否
是否支持所有MySQL4.1以上功能 | 是 | 大多数 | 否


Quick start guide

Table of Contents

  • Dual procedural and object-oriented interface
  • Connections
  • Executing statements
  • Prepared Statements
  • Stored Procedures
  • Multiple Statements
  • API support for transactions
  • Metadata

This quick start guide will help with choosing and gaining familiarity with the PHP MySQL API.

This quick start gives an overview on the mysqli extension. Code examples are provided for all major aspects of the API. Database concepts are explained to the degree needed for presenting concepts specific to MySQL.

Required: A familiarity with the PHP programming language, the SQL language, and basic knowledge of the MySQL server.


Dual procedural and object-oriented interface

The mysqli extension features a dual interface. It supports the procedural and object-oriented programming paradigm.

Users migrating from the old mysql extension may prefer the procedural interface. The procedural interface is similar to that of the old mysql extension. In many cases, the function names differ only by prefix. Some mysqli functions take a connection handle as their first argument, whereas matching functions in the old mysql interface take it as an optional last argument.

Example #1 Easy migration from the old mysql extension

<?php
$mysqli = mysqli_connect("example.com", "user", "password", "database");
$res = mysqli_query($mysqli, "SELECT 'Please, do not use ' AS _msg FROM DUAL");
$row = mysqli_fetch_assoc($res);
echo $row['_msg'];

$mysql = mysql_connect("example.com", "user", "password");
mysql_select_db("test");
$res = mysql_query("SELECT 'the mysql extension for new developments.' AS _msg FROM DUAL", $mysql);
$row = mysql_fetch_assoc($res);
echo $row['_msg'];
?>

以上例程会输出：

Please, do not use the mysql extension for new developments.

The object-oriented interface

In addition to the classical procedural interface, users can choose to use the object-oriented interface. The documentation is organized using the object-oriented interface. The object-oriented interface shows functions grouped by their purpose, making it easier to get started. The reference section gives examples for both syntax variants.

There are no significant performance differences between the two interfaces. Users can base their choice on personal preference.

Example #2 Object-oriented and procedural interface

<?php
$mysqli = mysqli_connect("example.com", "user", "password", "database");
if (mysqli_connect_errno()) {
    echo "Failed to connect to MySQL: " . mysqli_connect_error();
}

$res = mysqli_query($mysqli, "SELECT 'A world full of ' AS _msg FROM DUAL");
$row = mysqli_fetch_assoc($res);
echo $row['_msg'];

$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: " . $mysqli->connect_error;
}

$res = $mysqli->query("SELECT 'choices to please everybody.' AS _msg FROM DUAL");
$row = $res->fetch_assoc();
echo $row['_msg'];
?>

以上例程会输出：

A world full of choices to please everybody.

The object oriented interface is used for the quickstart because the reference section is organized that way.

Mixing styles

It is possible to switch between styles at any time. Mixing both styles is not recommended for code clarity and coding style reasons.

Example #3 Bad coding style

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: " . $mysqli->connect_error;
}

$res = mysqli_query($mysqli, "SELECT 'Possible but bad style.' AS _msg FROM DUAL");
if (!$res) {
    echo "Failed to run query: (" . $mysqli->errno . ") " . $mysqli->error;
}

if ($row = $res->fetch_assoc()) {
    echo $row['_msg'];
}
?>

以上例程会输出：

Possible but bad style.

See also

  • mysqli::__construct()
  • mysqli::query()
  • mysqli_result::fetch_assoc()
  • $mysqli::connect_errno
  • $mysqli::connect_error
  • $mysqli::errno
  • $mysqli::error
  • The MySQLi Extension Function Summary


Connections

The MySQL server supports the use of different transport layers for connections. Connections use TCP/IP, Unix domain sockets or Windows named pipes.

The hostname localhost has a special meaning. It is bound to the use of Unix domain sockets. It is not possible to open a TCP/IP connection using the hostname localhost you must use 127.0.0.1 instead.

Example #1 Special meaning of localhost

<?php
$mysqli = new mysqli("localhost", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}
echo $mysqli->host_info . "\n";

$mysqli = new mysqli("127.0.0.1", "user", "password", "database", 3306);
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

echo $mysqli->host_info . "\n";
?>

以上例程会输出：

Localhost via UNIX socket
127.0.0.1 via TCP/IP

Connection parameter defaults

Depending on the connection function used, assorted parameters can be omitted. If a parameter is not provided, then the extension attempts to use the default values that are set in the PHP configuration file.

Example #2 Setting defaults

mysqli.default_host=192.168.2.27
mysqli.default_user=root
mysqli.default_pw=""
mysqli.default_port=3306
mysqli.default_socket=/tmp/mysql.sock

The resulting parameter values are then passed to the client library that is used by the extension. If the client library detects empty or unset parameters, then it may default to the library built-in values.

Built-in connection library defaults

If the host value is unset or empty, then the client library will default to a Unix socket connection on localhost. If socket is unset or empty, and a Unix socket connection is requested, then a connection to the default socket on /tmp/mysql.sock is attempted.

On Windows systems, the host name . is interpreted by the client library as an attempt to open a Windows named pipe based connection. In this case the socket parameter is interpreted as the pipe name. If not given or empty, then the socket (pipe name) defaults to \\.\pipe\MySQL.

If neither a Unix domain socket based not a Windows named pipe based connection is to be established and the port parameter value is unset, the library will default to port 3306.

The mysqlnd library and the MySQL Client Library (libmysqlclient) implement the same logic for determining defaults.

Connection options

Connection options are available to, for example, set init commands which are executed upon connect, or for requesting use of a certain charset. Connection options must be set before a network connection is established.

For setting a connection option, the connect operation has to be
performed in three steps: creating a connection handle with
mysqli_init(), setting the requested options using
mysqli_options(), and establishing the network
connection with mysqli_real_connect().

Connection pooling

The mysqli extension supports persistent database connections, which are a special kind of pooled connections. By default, every database connection opened by a script is either explicitly closed by the user during runtime or released automatically at the end of the script. A persistent connection is not. Instead it is put into a pool for later reuse, if a connection to the same server using the same username, password, socket, port and default database is opened. Reuse saves connection overhead.

Every PHP process is using its own mysqli connection pool. Depending on the web server deployment model, a PHP process may serve one or multiple requests. Therefore, a pooled connection may be used by one or more scripts subsequently.

Persistent connection

If a unused persistent connection for a given combination of host, username, password, socket, port and default database can not be found in the connection pool, then mysqli opens a new connection. The use of persistent connections can be enabled and disabled using the PHP directive mysqli.allow_persistent. The total number of connections opened by a script can be limited with mysqli.max_links. The maximum number of persistent connections per PHP process can be restricted with mysqli.max_persistent. Please note, that the web server may spawn many PHP processes.

A common complain about persistent connections is that their state is not reset before reuse. For example, open and unfinished transactions are not automatically rolled back. But also, authorization changes which happened in the time between putting the connection into the pool and reusing it are not reflected. This may be seen as an unwanted side-effect. On the contrary, the name persistent may be understood as a promise that the state is persisted.

The mysqli extension supports both interpretations of a persistent connection: state persisted, and state reset before reuse. The default is reset. Before a persistent connection is reused, the mysqli extension implicitly calls mysqli_change_user() to reset the state. The persistent connection appears to the user as if it was just opened. No artifacts from previous usages are visible.

The mysqli_change_user() function is an expensive operation. For best performance, users may want to recompile the extension with the compile flag MYSQLI_NO_CHANGE_USER_ON_PCONNECT being set.

It is left to the user to choose between safe behavior and best performance. Both are valid optimization goals. For ease of use, the safe behavior has been made the default at the expense of maximum performance.

See also

  • mysqli::__construct()
  • mysqli::init()
  • mysqli::options()
  • mysqli::real_connect()
  • mysqli::change_user()
  • $mysqli::host_info
  • MySQLi Configuration Options
  • Persistent Database Connections


Executing statements

Statements can be executed with the
mysqli_query(), mysqli_real_query()
and mysqli_multi_query() functions.
The mysqli_query() function is the most
common, and combines the executing statement with a
buffered fetch of its result set, if any, in one call.
Calling mysqli_query() is identical to
calling mysqli_real_query()
followed by mysqli_store_result().

Example #1 Connecting to MySQL

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Buffered result sets

After statement execution results can be retrieved at once to be buffered by the client or by read row by row. Client-side result set buffering allows the server to free resources associated with the statement results as early as possible. Generally speaking, clients are slow consuming result sets. Therefore, it is recommended to use buffered result sets. mysqli_query() combines statement execution and result set buffering.

PHP applications can navigate freely through buffered results. Navigation is fast because the result sets are held in client memory. Please, keep in mind that it is often easier to scale by client than it is to scale the server.

Example #2 Navigation through buffered results

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$res = $mysqli->query("SELECT id FROM test ORDER BY id ASC");

echo "Reverse order...\n";
for ($row_no = $res->num_rows - 1; $row_no >= 0; $row_no--) {
    $res->data_seek($row_no);
    $row = $res->fetch_assoc();
    echo " id = " . $row['id'] . "\n";
}

echo "Result set order...\n";
$res->data_seek(0);
while ($row = $res->fetch_assoc()) {
    echo " id = " . $row['id'] . "\n";
}
?>

以上例程会输出：

Reverse order...
 id = 3
 id = 2
 id = 1
Result set order...
 id = 1
 id = 2
 id = 3

Unbuffered result sets

If client memory is a short resource and freeing server resources as early as possible to keep server load low is not needed, unbuffered results can be used. Scrolling through unbuffered results is not possible before all rows have been read.

Example #3 Navigation through unbuffered results

<?php
$mysqli->real_query("SELECT id FROM test ORDER BY id ASC");
$res = $mysqli->use_result();

echo "Result set order...\n";
while ($row = $res->fetch_assoc()) {
    echo " id = " . $row['id'] . "\n";
}
?>

Result set values data types

The mysqli_query(), mysqli_real_query() and mysqli_multi_query() functions are used to execute non-prepared statements. At the level of the MySQL Client Server Protocol, the command COM_QUERY and the text protocol are used for statement execution. With the text protocol, the MySQL server converts all data of a result sets into strings before sending. This conversion is done regardless of the SQL result set column data type. The mysql client libraries receive all column values as strings. No further client-side casting is done to convert columns back to their native types. Instead, all values are provided as PHP strings.

Example #4 Text protocol returns strings by default

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$res = $mysqli->query("SELECT id, label FROM test WHERE id = 1");
$row = $res->fetch_assoc();

printf("id = %s (%s)\n", $row['id'], gettype($row['id']));
printf("label = %s (%s)\n", $row['label'], gettype($row['label']));
?>

以上例程会输出：

id = 1 (string)
label = a (string)

It is possible to convert integer and float columns back to PHP numbers by setting the MYSQLI_OPT_INT_AND_FLOAT_NATIVE connection option, if using the mysqlnd library. If set, the mysqlnd library will check the result set meta data column types and convert numeric SQL columns to PHP numbers, if the PHP data type value range allows for it. This way, for example, SQL INT columns are returned as integers.

Example #5 Native data types with mysqlnd and connection option

<?php
$mysqli = mysqli_init();
$mysqli->options(MYSQLI_OPT_INT_AND_FLOAT_NATIVE, 1);
$mysqli->real_connect("example.com", "user", "password", "database");

if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$res = $mysqli->query("SELECT id, label FROM test WHERE id = 1");
$row = $res->fetch_assoc();

printf("id = %s (%s)\n", $row['id'], gettype($row['id']));
printf("label = %s (%s)\n", $row['label'], gettype($row['label']));
?>

以上例程会输出：

id = 1 (integer)
label = a (string)

See also

  • mysqli::__construct()
  • mysqli::init()
  • mysqli::options()
  • mysqli::real_connect()
  • mysqli::query()
  • mysqli::multi_query()
  • mysqli::use_result()
  • mysqli::store_result()
  • mysqli_result::free()


Prepared Statements

The MySQL database supports prepared statements. A prepared statement or a parameterized statement is used to execute the same statement repeatedly with high efficiency.

Basic workflow

The prepared statement execution consists of two stages: prepare and execute. At the prepare stage a statement template is sent to the database server. The server performs a syntax check and initializes server internal resources for later use.

The MySQL server supports using anonymous, positional placeholder with ?.

Example #1 First stage: prepare

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

/* Non-prepared statement */
if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Prepared statement, stage 1: prepare */
if (!($stmt = $mysqli->prepare("INSERT INTO test(id) VALUES (?)"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Prepare is followed by execute. During execute the client binds parameter values and sends them to the server. The server creates a statement from the statement template and the bound values to execute it using the previously created internal resources.

Example #2 Second stage: bind and execute

<?php
/* Prepared statement, stage 2: bind and execute */
$id = 1;
if (!$stmt->bind_param("i", $id)) {
    echo "Binding parameters failed: (" . $stmt->errno . ") " . $stmt->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}
?>

Repeated execution

A prepared statement can be executed repeatedly. Upon every execution the current value of the bound variable is evaluated and sent to the server. The statement is not parsed again. The statement template is not transferred to the server again.

Example #3 INSERT prepared once, executed multiple times

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

/* Non-prepared statement */
if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Prepared statement, stage 1: prepare */
if (!($stmt = $mysqli->prepare("INSERT INTO test(id) VALUES (?)"))) {
     echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Prepared statement, stage 2: bind and execute */
$id = 1;
if (!$stmt->bind_param("i", $id)) {
    echo "Binding parameters failed: (" . $stmt->errno . ") " . $stmt->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

/* Prepared statement: repeated execution, only data transferred from client to server */
for ($id = 2; $id < 5; $id++) {
    if (!$stmt->execute()) {
        echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
    }
}

/* explicit close recommended */
$stmt->close();

/* Non-prepared statement */
$res = $mysqli->query("SELECT id FROM test");
var_dump($res->fetch_all());
?>

以上例程会输出：

array(4) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "1"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
  [3]=>
  array(1) {
    [0]=>
    string(1) "4"
  }
}

Every prepared statement occupies server resources. Statements should be closed explicitly immediately after use. If not done explicitly, the statement will be closed when the statement handle is freed by PHP.

Using a prepared statement is not always the most efficient way of executing a statement. A prepared statement executed only once causes more client-server round-trips than a non-prepared statement. This is why the SELECT is not run as a prepared statement above.

Also, consider the use of the MySQL multi-INSERT SQL syntax for INSERTs. For the example, multi-INSERT requires less round-trips between the server and client than the prepared statement shown above.

Example #4 Less round trips using multi-INSERT SQL

<?php
if (!$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3), (4)")) {
    echo "Multi-INSERT failed: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Result set values data types

The MySQL Client Server Protocol defines a different data transfer protocol for prepared statements and non-prepared statements. Prepared statements are using the so called binary protocol. The MySQL server sends result set data "as is" in binary format. Results are not serialized into strings before sending. The client libraries do not receive strings only. Instead, they will receive binary data and try to convert the values into appropriate PHP data types. For example, results from an SQL INT column will be provided as PHP integer variables.

Example #5 Native datatypes

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$stmt = $mysqli->prepare("SELECT id, label FROM test WHERE id = 1");
$stmt->execute();
$res = $stmt->get_result();
$row = $res->fetch_assoc();

printf("id = %s (%s)\n", $row['id'], gettype($row['id']));
printf("label = %s (%s)\n", $row['label'], gettype($row['label']));
?>

以上例程会输出：

id = 1 (integer)
label = a (string)

This behavior differs from non-prepared statements. By default, non-prepared statements return all results as strings. This default can be changed using a connection option. If the connection option is used, there are no differences.

Fetching results using bound variables

Results from prepared statements can either be retrieved by binding output variables, or by requesting a mysqli_result object.

Output variables must be bound after statement execution. One variable must be bound for every column of the statements result set.

Example #6 Output variable binding

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($stmt = $mysqli->prepare("SELECT id, label FROM test"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$out_id    = NULL;
$out_label = NULL;
if (!$stmt->bind_result($out_id, $out_label)) {
    echo "Binding output parameters failed: (" . $stmt->errno . ") " . $stmt->error;
}

while ($stmt->fetch()) {
    printf("id = %s (%s), label = %s (%s)\n", $out_id, gettype($out_id), $out_label, gettype($out_label));
}
?>

以上例程会输出：

id = 1 (integer), label = a (string)

Prepared statements return unbuffered result sets by default. The results of the statement are not implicitly fetched and transferred from the server to the client for client-side buffering. The result set takes server resources until all results have been fetched by the client. Thus it is recommended to consume results timely. If a client fails to fetch all results or the client closes the statement before having fetched all data, the data has to be fetched implicitly by mysqli.

It is also possible to buffer the results of a prepared statement using mysqli_stmt_store_result().

Fetching results using mysqli_result interface

Instead of using bound results, results can also be retrieved through the mysqli_result interface. mysqli_stmt_get_result() returns a buffered result set.

Example #7 Using mysqli_result to fetch results

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($stmt = $mysqli->prepare("SELECT id, label FROM test ORDER BY id ASC"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
     echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

if (!($res = $stmt->get_result())) {
    echo "Getting result set failed: (" . $stmt->errno . ") " . $stmt->error;
}

var_dump($res->fetch_all());
?>

以上例程会输出：

array(1) {
  [0]=>
  array(2) {
    [0]=>
    int(1)
    [1]=>
    string(1) "a"
  }
}

Using the mysqli_result interface offers the additional benefit of flexible client-side result set navigation.

Example #8 Buffered result set for flexible read out

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a'), (2, 'b'), (3, 'c')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($stmt = $mysqli->prepare("SELECT id, label FROM test"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
     echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

if (!($res = $stmt->get_result())) {
    echo "Getting result set failed: (" . $stmt->errno . ") " . $stmt->error;
}

for ($row_no = ($res->num_rows - 1); $row_no >= 0; $row_no--) {
    $res->data_seek($row_no);
    var_dump($res->fetch_assoc());
}
$res->close();
?>

以上例程会输出：

array(2) {
  ["id"]=>
  int(3)
  ["label"]=>
  string(1) "c"
}
array(2) {
  ["id"]=>
  int(2)
  ["label"]=>
  string(1) "b"
}
array(2) {
  ["id"]=>
  int(1)
  ["label"]=>
  string(1) "a"
}

Escaping and SQL injection

Bound variables are sent to the server separately from the query and thus cannot interfere with it. The server uses these values directly at the point of execution, after the statement template is parsed. Bound parameters do not need to be escaped as they are never substituted into the query string directly. A hint must be provided to the server for the type of bound variable, to create an appropriate conversion. See the mysqli_stmt_bind_param() function for more information.

Such a separation sometimes considered as the only security feature to prevent SQL injection, but the same degree of security can be achieved with non-prepared statements, if all the values are formatted correctly. It should be noted that correct formatting is not the same as escaping and involves more logic than simple escaping. Thus, prepared statements are simply a more convenient and less error-prone approach to this element of database security.

Client-side prepared statement emulation

The API does not include emulation for client-side prepared statement emulation.

Quick prepared - non-prepared statement comparison

The table below compares server-side prepared and non-prepared statements.

Comparison of prepared and non-prepared statements
 | Prepared Statement | Non-prepared statement
Client-server round trips, SELECT, single execution | 2 | 1
Statement string transferred from client to server | 1 | 1
Client-server round trips, SELECT, repeated (n) execution | 1 + n | n
Statement string transferred from client to server | 1 template, n times bound parameter, if any | n times together with parameter, if any
Input parameter binding API | Yes, automatic input escaping | No, manual input escaping
Output variable binding API | Yes | No
Supports use of mysqli_result API | Yes, use mysqli_stmt_get_result() | Yes
Buffered result sets | Yes, use mysqli_stmt_get_result() or binding with mysqli_stmt_store_result() | Yes, default of mysqli_query()
Unbuffered result sets | Yes, use output binding API | Yes, use mysqli_real_query() with mysqli_use_result()
MySQL Client Server protocol data transfer flavor | Binary protocol | Text protocol
Result set values SQL data types | Preserved when fetching | Converted to string or preserved when fetching
Supports all SQL statements | Recent MySQL versions support most but not all | Yes

See also

  • mysqli::__construct()
  • mysqli::query()
  • mysqli::prepare()
  • mysqli_stmt::prepare()
  • mysqli_stmt::execute()
  • mysqli_stmt::bind_param()
  • mysqli_stmt::bind_result()


Stored Procedures

The MySQL database supports stored procedures. A stored procedure is a subroutine stored in the database catalog. Applications can call and execute the stored procedure. The CALL SQL statement is used to execute a stored procedure.

Parameter

Stored procedures can have IN, INOUT and OUT parameters, depending on the MySQL version. The mysqli interface has no special notion for the different kinds of parameters.

IN parameter

Input parameters are provided with the CALL statement. Please, make sure values are escaped correctly.

Example #1 Calling a stored procedure

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query("CREATE PROCEDURE p(IN id_val INT) BEGIN INSERT INTO test(id) VALUES(id_val); END;")) {
    echo "Stored procedure creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("CALL p(1)")) {
    echo "CALL failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($res = $mysqli->query("SELECT id FROM test"))) {
    echo "SELECT failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

var_dump($res->fetch_assoc());
?>

以上例程会输出：

array(1) {
  ["id"]=>
  string(1) "1"
}

INOUT/OUT parameter

The values of INOUT/OUT parameters are accessed using session variables.

Example #2 Using session variables

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p(OUT msg VARCHAR(50)) BEGIN SELECT "Hi!" INTO msg; END;')) {
    echo "Stored procedure creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("SET @msg = ''") || !$mysqli->query("CALL p(@msg)")) {
    echo "CALL failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($res = $mysqli->query("SELECT @msg as _p_out"))) {
    echo "Fetch failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$row = $res->fetch_assoc();
echo $row['_p_out'];
?>

以上例程会输出：

Hi!

Application and framework developers may be able to provide a more convenient API using a mix of session variables and databased catalog inspection. However, please note the possible performance impact of a custom solution based on catalog inspection.

Handling result sets

Stored procedures can return result sets. Result sets returned from a stored procedure cannot be fetched correctly using mysqli_query(). The mysqli_query() function combines statement execution and fetching the first result set into a buffered result set, if any. However, there are additional stored procedure result sets hidden from the user which cause mysqli_query() to fail returning the user expected result sets.

Result sets returned from a stored procedure are fetched using mysqli_real_query() or mysqli_multi_query(). Both functions allow fetching any number of result sets returned by a statement, such as CALL. Failing to fetch all result sets returned by a stored procedure causes an error.

Example #3 Fetching results from stored procedures

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p() READS SQL DATA BEGIN SELECT id FROM test; SELECT id + 1 FROM test; END;')) {
    echo "Stored procedure creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->multi_query("CALL p()")) {
    echo "CALL failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

do {
    if ($res = $mysqli->store_result()) {
        printf("---\n");
        var_dump($res->fetch_all());
        $res->free();
    } else {
        if ($mysqli->errno) {
            echo "Store failed: (" . $mysqli->errno . ") " . $mysqli->error;
        }
    }
} while ($mysqli->more_results() && $mysqli->next_result());
?>

以上例程会输出：

---
array(3) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "1"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
}
---
array(3) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "4"
  }
}

Use of prepared statements

No special handling is required when using the prepared statement interface for fetching results from the same stored procedure as above. The prepared statement and non-prepared statement interfaces are similar. Please note, that not every MYSQL server version may support preparing the CALL SQL statement.

Example #4 Stored Procedures and Prepared Statements

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p() READS SQL DATA BEGIN SELECT id FROM test; SELECT id + 1 FROM test; END;')) {
    echo "Stored procedure creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($stmt = $mysqli->prepare("CALL p()"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

do {
    if ($res = $stmt->get_result()) {
        printf("---\n");
        var_dump(mysqli_fetch_all($res));
        mysqli_free_result($res);
    } else {
        if ($stmt->errno) {
            echo "Store failed: (" . $stmt->errno . ") " . $stmt->error;
        }
    }
} while ($stmt->more_results() && $stmt->next_result());
?>

Of course, use of the bind API for fetching is supported as well.

Example #5 Stored Procedures and Prepared Statements using bind API

<?php
if (!($stmt = $mysqli->prepare("CALL p()"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

do {

    $id_out = NULL;
    if (!$stmt->bind_result($id_out)) {
        echo "Bind failed: (" . $stmt->errno . ") " . $stmt->error;
    }

    while ($stmt->fetch()) {
        echo "id = $id_out\n";
    }
} while ($stmt->more_results() && $stmt->next_result());
?>

See also

  • mysqli::query()
  • mysqli::multi_query()
  • mysqli_result::next-result()
  • mysqli_result::more-results()


Multiple Statements

MySQL optionally allows having multiple statements in one statement string. Sending multiple statements at once reduces client-server round trips but requires special handling.

Multiple statements or multi queries must be executed with mysqli_multi_query(). The individual statements of the statement string are separated by semicolon. Then, all result sets returned by the executed statements must be fetched.

The MySQL server allows having statements that do return result sets and statements that do not return result sets in one multiple statement.

Example #1 Multiple Statements

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$sql = "SELECT COUNT(*) AS _num FROM test; ";
$sql.= "INSERT INTO test(id) VALUES (1); ";
$sql.= "SELECT COUNT(*) AS _num FROM test; ";

if (!$mysqli->multi_query($sql)) {
    echo "Multi query failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

do {
    if ($res = $mysqli->store_result()) {
        var_dump($res->fetch_all(MYSQLI_ASSOC));
        $res->free();
    }
} while ($mysqli->more_results() && $mysqli->next_result());
?>

以上例程会输出：

array(1) {
  [0]=>
  array(1) {
    ["_num"]=>
    string(1) "0"
  }
}
array(1) {
  [0]=>
  array(1) {
    ["_num"]=>
    string(1) "1"
  }
}

Security considerations

The API functions mysqli_query() and mysqli_real_query() do not set a connection flag necessary for activating multi queries in the server. An extra API call is used for multiple statements to reduce the likeliness of accidental SQL injection attacks. An attacker may try to add statements such as ; DROP DATABASE mysql or ; SELECT SLEEP(999). If the attacker succeeds in adding SQL to the statement string but mysqli_multi_query is not used, the server will not execute the second, injected and malicious SQL statement.

Example #2 SQL Injection

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
$res    = $mysqli->query("SELECT 1; DROP TABLE mysql.user");
if (!$res) {
    echo "Error executing query: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

以上例程会输出：

Error executing query: (1064) You have an error in your SQL syntax;
check the manual that corresponds to your MySQL server version for the right syntax
to use near 'DROP TABLE mysql.user' at line 1

Prepared statements

Use of the multiple statement with prepared statements is not supported.

See also

  • mysqli::query()
  • mysqli::multi_query()
  • mysqli_result::next-result()
  • mysqli_result::more-results()


API support for transactions

The MySQL server supports transactions depending on the storage engine used. Since MySQL 5.5, the default storage engine is InnoDB. InnoDB has full ACID transaction support.

Transactions can either be controlled using SQL or API calls. It is recommended to use API calls for enabling and disabling the autocommit mode and for committing and rolling back transactions.

Example #1 Setting autocommit mode with SQL and through the API

<?php
mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = new mysqli("example.com", "user", "password", "database");

/* Recommended: using API to control transactional settings */
$mysqli->autocommit(false);

/* Won't be monitored and recognized by the replication and the load balancing plugin */
$mysqli->query('SET AUTOCOMMIT = 0');

Optional feature packages, such as the replication and load balancing plugin, can easily monitor API calls. The replication plugin offers transaction aware load balancing, if transactions are controlled with API calls. Transaction aware load balancing is not available if SQL statements are used for setting autocommit mode, committing or rolling back a transaction.

Example #2 Commit and rollback

<?php
mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = new mysqli("example.com", "user", "password", "database");
$mysqli->autocommit(false);

$mysqli->query("INSERT INTO test(id) VALUES (1)");
$mysqli->rollback();

$mysqli->query("INSERT INTO test(id) VALUES (2)");
$mysqli->commit();

Please note, that the MySQL server cannot roll back all statements. Some statements cause an implicit commit.

See also

  • mysqli::autocommit()
  • mysqli::begin_transaction()
  • mysqli::commit()
  • mysqli::rollback()


Metadata

A MySQL result set contains metadata. The metadata describes the columns found in the result set. All metadata sent by MySQL is accessible through the mysqli interface. The extension performs no or negligible changes to the information it receives. Differences between MySQL server versions are not aligned.

Meta data is access through the mysqli_result interface.

Example #1 Accessing result set meta data

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

$res = $mysqli->query("SELECT 1 AS _one, 'Hello' AS _two FROM DUAL");
var_dump($res->fetch_fields());
?>

以上例程会输出：

array(2) {
  [0]=>
  object(stdClass)#3 (13) {
    ["name"]=>
    string(4) "_one"
    ["orgname"]=>
    string(0) ""
    ["table"]=>
    string(0) ""
    ["orgtable"]=>
    string(0) ""
    ["def"]=>
    string(0) ""
    ["db"]=>
    string(0) ""
    ["catalog"]=>
    string(3) "def"
    ["max_length"]=>
    int(1)
    ["length"]=>
    int(1)
    ["charsetnr"]=>
    int(63)
    ["flags"]=>
    int(32897)
    ["type"]=>
    int(8)
    ["decimals"]=>
    int(0)
  }
  [1]=>
  object(stdClass)#4 (13) {
    ["name"]=>
    string(4) "_two"
    ["orgname"]=>
    string(0) ""
    ["table"]=>
    string(0) ""
    ["orgtable"]=>
    string(0) ""
    ["def"]=>
    string(0) ""
    ["db"]=>
    string(0) ""
    ["catalog"]=>
    string(3) "def"
    ["max_length"]=>
    int(5)
    ["length"]=>
    int(5)
    ["charsetnr"]=>
    int(8)
    ["flags"]=>
    int(1)
    ["type"]=>
    int(253)
    ["decimals"]=>
    int(31)
  }
}

Prepared statements

Meta data of result sets created using prepared statements are accessed the same way. A suitable mysqli_result handle is returned by mysqli_stmt_result_metadata().

Example #2 Prepared statements metadata

<?php
$stmt = $mysqli->prepare("SELECT 1 AS _one, 'Hello' AS _two FROM DUAL");
$stmt->execute();
$res = $stmt->result_metadata();
var_dump($res->fetch_fields());
?>

See also

  • mysqli::query()
  • mysqli_result::fetch_fields()


  • ? Metadata
  • 需求 ?
  • PHP Manual
  • Mysqli
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

要使用 mysqli 相关的函数， 你必须以启用 mysqli 扩展的方式编译 PHP。

MySQL 8

使用 PHP 7.1.16 之前的版本或者 PHP 7.2（PHP 7.2.4 之前的版本）， 需要将 MySQL 服务器的默认密码插件设置为：mysql_native_password。 否则，当你连接的时候就会看到类似这样的错误： The server requested authentication method unknown to the client [caching_sha2_password]。 即使你未使用 caching_sha2_password 也会这样。

发生这种错误的原因是，MySQL 8 服务器默认会使用 caching_sha2_password 扩展， 老版本的 PHP 驱动（mysqlnd）无法识别这个扩展。 所以需要在 MySQL 的配置文件 my.cnf 中，设置 default_authentication_plugin=mysql_native_password。 在后续的 PHP 发行版本中，会提供对 MySQL caching_sha2_password 扩展的支持。 目前只有 mysql_xdevapi 扩展是 支持 MySQL 的 caching_sha2_password 扩展的。


安装

mysqli扩展在PHP5.0.0中被引入。Mysql Native驱动在PHP5.3.0版本中被引入。

在linux上安装

通用的Unix分发包中会包含PHP可安装的二进制版本。虽然这些二进制版本通常会被构建为支持启用mysql扩展的， 蚕食扩展库自身可能需要依赖其他附加包的安装。因此对包管理的检查会比选择可用的发行版本更重要。

除非你的Unix分发包包含的PHP二进制包的mysqli扩展可用，否则你就需要 从源码构建PHP。如果你希望使用mysql扩展，从PHP源代码构建允许你这样做，并且可以指定每个扩展 使用什么客户端库。

使用Mysql Native Driver 是推荐的选项，会提升性能并且会带来一些Mysql Client Library不允许的访问特性。 什么是Mysql自然驱动器？中对Mysql Native Driver 的优势做了一个简要概述。

/path/to/mysql_config代表了要用来编译mysql客户端/连接mysql服务端的mysql_config程序位置。

mysqli 编译时支持表
PHP 版本 | 默认 | 配置选项: mysqlnd | 配置选项: libmysql | 更新日志
5.0.x, 5.1.x, 5.2.x | libmysql | 不适用 | --with-mysqli=/path/to/mysql_config |
5.3.x | libmysql | --with-mysqli=mysqlnd | --with-mysqli=/path/to/mysql_config | mysqlnd is now supported
5.4.x | mysqlnd | --with-mysqli | --with-mysqli=/path/to/mysql_config | mysqlnd is now the default

请注意Mysql扩展和客户端库是可以自由混合的。比如，可以使用libmysql这个mysql客户端库来启用Mysql扩展，使用 Mysql Native Driver来配置mysqli扩展。所有的扩展和客户端库的顺序都是可能的。

下面的示例使用Mysql Client Library（libmysql）构建了mysql扩展，并且mysqli和 PDO Mysql扩展使用Mysql Native Dirver（作为客户端库）：

./configure --with-mysql=/usr/bin/mysql_config  \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd
[other options]

在windows系统安装

在windows上，PHP通常使用二进制安装包进行安装。

PHP 5.0, 5.1, 5.2

当PHP安装后，如果期望使用则可以通过一些配置来开启mysqli并指定客户端库。

mysqli扩展默认并不会开启，因此php.ini中php_mysqli.dll这个DLL 必须开启。为此你需要找到php.ini文件（通常在c:\php），并且你需要确认删除了 [PHP_MYSQLI]部分中的extension=php_mysqli.dll一行行首的注释符号（分号）。

另外，如果你希望使用Mysql client library（libmysql）作为mysqli的驱动器，你需要确保PHP可以访问 客户端库的文件。Mysql Client Library作为文件libmysql.dll包含在windows的PHP分发包中。 这个文件需要在windows系统的PATH环境变量中才可以被成功加载。查看FAQ文档 怎样增加我的PHP目录到Windows的PATH中了解怎样配置环境变量PATH。 把libmysql.dll拷贝到Windows的系统目录（通常是c:\Windows\system）也是适用的， 通常系统目录默认就在系统的PATH环境变量下。然而，我们强烈反对这种做法。

就像开启任何PHP扩展（比如php_mysqli.dll），PHP指令 extension_dir可以被设置为PHP扩展位置的目录路径。 查看windows安装介绍手册。关于此的一个例子是PHP 5中 extension_dir指令的值是c:\php\ext。

Note:

如果启动web服务器的时候发生了类似下面这样的错误"Unable to load dynamic library './php_mysqli.dll'"， 这就是因为在系统中无法找到php_mysqli.dll或者libmysql.dll。

PHP 5.3.0+

在windows上，对于PHP 5.3或更新版本，mysqli扩展默认开启并使用Mysql Native Driver。 这就是说你不需要担心关于访问libmysql.dll的配置。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

MySQLi配置选项
名字 | 默认 | 可修改范围 | 更新日志
mysqli.allow_local_infile | "0" | PHP_INI_SYSTEM | 自PHP 5.2.4起可用。在 PHP 7.2.16 和 7.3.3 之前，默认值为 "1"
mysqli.local_infile_directory |  | PHP_INI_SYSTEM |
mysqli.allow_persistent | "1" | PHP_INI_SYSTEM | 自PHP 5.3.0起可用。
mysqli.max_persistent | "-1" | PHP_INI_SYSTEM | 自PHP 5.3.0起可用。
mysqli.max_links | "-1" | PHP_INI_SYSTEM |
mysqli.default_port | "3306" | PHP_INI_ALL |
mysqli.default_socket | NULL | PHP_INI_ALL |
mysqli.default_host | NULL | PHP_INI_ALL |
mysqli.default_user | NULL | PHP_INI_ALL | 自PHP 5.0.0起可用。
mysqli.default_pw | NULL | PHP_INI_ALL |
mysqli.reconnect | "0" | PHP_INI_SYSTEM |
mysqli.rollback_on_cached_plink | TRUE | PHP_INI_SYSTEM | 自 PHP 5.6.0 起可用。

关于前面出现的PHP_INI_*系列常量的详细定义，请参阅配置的修改一章。

这是配置指令的简短说明。

mysqli.allow_local_infile integer

允许Mysql的Load Data语句访问PHP角度看的本地文件。

mysqli.local_infile_directory string

限制加载 LOCAL DATA 文件为指定的目录。

mysqli.allow_persistent integer

开启使用mysqli_connect()函数创建持久化连接的能力。

mysqli.max_persistent integer

可以创建的持久化连接的最大数量，设置为0表明不限制。

mysqli.max_links integer

每个进程中Mysql连接的最大数量。

mysqli.default_port integer

当没有指定其他端口号时使用的默认的用于连接数据库服务器的TCP端口号。如果没有设置默认值， 端口号将会按照顺序从环境变量MYSQL_TCP_PORT，/etc/services 文件中的mysql-tcp条目或编译期的MYSQL_PORT常量等位置获取。 Win32仅使用MYSQL_PORT常量。

mysqli.default_socket string

当连接到本地数据库服务器时如果没有指定其他socket名称，使用的默认socket名称。

mysqli.default_host string

当连接到数据库服务器时， 如果没有指定其他主机地址，使用的默认服务器主机。

mysqli.default_user string

当连接到数据库服务器时，如果没有指定其他用户名，使用的默认用户名。

mysqli.default_pw string

当连接到数据库服务器时，如果没有指定其他密码，使用的默认密码。

mysqli.reconnect integer

连接丢失时是否自动重新连接。

Note: mysqlnd 驱动会此忽略 php.ini 设置。

mysqli.rollback_on_cached_plink bool

If this option is enabled, closing a persistent connection will rollback any pending transactions of this connection before it is put back into the persistent connection pool. Otherwise, pending transactions will be rolled back only when the connection is reused, or when it is actually closed.

用户不能通过API调用或运行时配置来设置MYSQL_OPT_READ_TIMEOUT。 注意，如果可能这样做那么libmysqlclient和流对MYSQL_OPT_READ_TIMEOUT 的值将会有不同的解释。


  • ? 运行时配置
  • mysqli 扩展和持久化连接 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


mysqli 扩展和持久化连接

从 PHP 5.3 mysqli 扩展开始支持持久化连接。 持久化连接已经在 PDO MYSQL 和 ext/mysql 中提供支持。 持久化连接的目的在于重用客户端到服务器之间的连接， 而不是每次在需要的时候都重新建立一个连接。 由于持久化连接可以将已经建立的连接缓存起来，以备后续的使用， 所以省去了建立新的连接的开销， 因此可以带来性能上的提升。

不像 mysql 扩展，mysqli 没有提供一个特殊的方法用于打开持久化连接。 需要打开一个持久化连接时，你必须在 连接时在主机名前增加p:。

使用持久化连接也会存在一些风险， 因为在缓存中的连接可能处于一种不可预测的状态。 例如，如果客户端未能正常关闭连接， 可能在这个连接上残留了对库表的锁， 那么当这个连接被其他请求重用的时候，这个连接还是处于 有锁的状态。 所以，如果要很好的使用持久化连接，那么要求代码在和数据库进行交互的时候， 确保做好清理工作，保证被缓存的连接是一个干净的，没有残留的状态。

mysqli 扩展的持久化连接提供了内建的清理处理代码。 mysqli 所做的清理工作包括：

  • 回滚处于活动状态的事务

  • 关闭并且删除临时表

  • 对表解锁

  • 重置会话变量

  • 关闭预编译 SQL 语句（在PHP中经常发生）

  • 关闭处理程序

  • 释放通过 GET_LOCK() 获得的锁

这确保了将连接返回到连接池的时候， 它处于一种"干净"的状态，可以被其他客户端进程所使用。

mysqli 扩展 通过自动调用 C-API 函数 mysql_change_user() 来完成这个清理工作。

自动清理的特性有优点也有缺点。 优点是程序员不再需要担心附加的清理代码， 因为它们会自动调用。 然而缺点就是 性能 可能会 慢一点， 因为每次从连接池返回一个连接都需要执行这些清理代码。

这个自动清理的代码可以通过在编译 php 时定义 MYSQLI_NO_CHANGE_USER_ON_PCONNECT 来关闭。

Note:

mysqli 扩展在使用 MySQL Native Driver 或 Mysql Client Library（libmysql）时都支持持久化连接。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

MYSQLI_READ_DEFAULT_GROUP

Read options from the named group from my.cnf or the file specified with MYSQLI_READ_DEFAULT_FILE

MYSQLI_READ_DEFAULT_FILE

Read options from the named option file instead of from my.cnf

MYSQLI_OPT_CONNECT_TIMEOUT

Connect timeout in seconds

MYSQLI_OPT_LOCAL_INFILE

Enables command LOAD LOCAL INFILE

MYSQLI_INIT_COMMAND

Command to execute when connecting to MySQL server. Will automatically be re-executed when reconnecting.

MYSQLI_CLIENT_SSL

Use SSL (encrypted protocol). This option should not be set by application programs; it is set internally in the MySQL client library

MYSQLI_CLIENT_COMPRESS

Use compression protocol

MYSQLI_CLIENT_INTERACTIVE

Allow interactive_timeout seconds (instead of wait_timeout seconds) of inactivity before closing the connection. The client's session wait_timeout variable will be set to the value of the session interactive_timeout variable.

MYSQLI_CLIENT_IGNORE_SPACE

Allow spaces after function names. Makes all functions names reserved words.

MYSQLI_CLIENT_NO_SCHEMA

Don't allow the db_name.tbl_name.col_name syntax.

MYSQLI_CLIENT_MULTI_QUERIES

Allows multiple semicolon-delimited queries in a single mysqli_query() call.

MYSQLI_STORE_RESULT

For using buffered resultsets

MYSQLI_USE_RESULT

For using unbuffered resultsets

MYSQLI_ASSOC

Columns are returned into the array having the fieldname as the array index.

MYSQLI_NUM

Columns are returned into the array having an enumerated index.

MYSQLI_BOTH

Columns are returned into the array having both a numerical index and the fieldname as the associative index.

MYSQLI_NOT_NULL_FLAG

Indicates that a field is defined as NOT NULL

MYSQLI_PRI_KEY_FLAG

Field is part of a primary index

MYSQLI_UNIQUE_KEY_FLAG

Field is part of a unique index.

MYSQLI_MULTIPLE_KEY_FLAG

Field is part of an index.

MYSQLI_BLOB_FLAG

Field is defined as BLOB

MYSQLI_UNSIGNED_FLAG

Field is defined as UNSIGNED

MYSQLI_ZEROFILL_FLAG

Field is defined as ZEROFILL

MYSQLI_AUTO_INCREMENT_FLAG

Field is defined as AUTO_INCREMENT

MYSQLI_TIMESTAMP_FLAG

Field is defined as TIMESTAMP

MYSQLI_SET_FLAG

Field is defined as SET

MYSQLI_NUM_FLAG

Field is defined as NUMERIC

MYSQLI_PART_KEY_FLAG

Field is part of an multi-index

MYSQLI_GROUP_FLAG

Field is part of GROUP BY

MYSQLI_TYPE_DECIMAL

Field is defined as DECIMAL

MYSQLI_TYPE_NEWDECIMAL

Precision math DECIMAL or NUMERIC field (MySQL 5.0.3 and up)

MYSQLI_TYPE_BIT

Field is defined as BIT (MySQL 5.0.3 and up)

MYSQLI_TYPE_TINY

Field is defined as TINYINT

MYSQLI_TYPE_SHORT

Field is defined as SMALLINT

MYSQLI_TYPE_LONG

Field is defined as INT

MYSQLI_TYPE_FLOAT

Field is defined as FLOAT

MYSQLI_TYPE_DOUBLE

Field is defined as DOUBLE

MYSQLI_TYPE_NULL

Field is defined as DEFAULT NULL

MYSQLI_TYPE_TIMESTAMP

Field is defined as TIMESTAMP

MYSQLI_TYPE_LONGLONG

Field is defined as BIGINT

MYSQLI_TYPE_INT24

Field is defined as MEDIUMINT

MYSQLI_TYPE_DATE

Field is defined as DATE

MYSQLI_TYPE_TIME

Field is defined as TIME

MYSQLI_TYPE_DATETIME

Field is defined as DATETIME

MYSQLI_TYPE_YEAR

Field is defined as YEAR

MYSQLI_TYPE_NEWDATE

Field is defined as DATE

MYSQLI_TYPE_INTERVAL

Field is defined as INTERVAL

MYSQLI_TYPE_ENUM

Field is defined as ENUM

MYSQLI_TYPE_SET

Field is defined as SET

MYSQLI_TYPE_TINY_BLOB

Field is defined as TINYBLOB

MYSQLI_TYPE_MEDIUM_BLOB

Field is defined as MEDIUMBLOB

MYSQLI_TYPE_LONG_BLOB

Field is defined as LONGBLOB

MYSQLI_TYPE_BLOB

Field is defined as BLOB

MYSQLI_TYPE_VAR_STRING

Field is defined as VARCHAR

MYSQLI_TYPE_STRING

Field is defined as STRING

MYSQLI_TYPE_CHAR

Field is defined as CHAR

MYSQLI_TYPE_GEOMETRY

Field is defined as GEOMETRY

MYSQLI_NEED_DATA

More data available for bind variable

MYSQLI_NO_DATA

No more data available for bind variable

MYSQLI_DATA_TRUNCATED

Data truncation occurred. Available since PHP 5.1.0 and MySQL 5.0.5.

MYSQLI_ENUM_FLAG

Field is defined as ENUM. Available since PHP 5.3.0.

MYSQLI_CURSOR_TYPE_FOR_UPDATE

MYSQLI_CURSOR_TYPE_NO_CURSOR

MYSQLI_CURSOR_TYPE_READ_ONLY

MYSQLI_CURSOR_TYPE_SCROLLABLE

MYSQLI_STMT_ATTR_CURSOR_TYPE

MYSQLI_STMT_ATTR_PREFETCH_ROWS

MYSQLI_STMT_ATTR_UPDATE_MAX_LENGTH

MYSQLI_SET_CHARSET_NAME

MYSQLI_REPORT_INDEX

Report if no index or bad index was used in a query.

MYSQLI_REPORT_ERROR

Report errors from mysqli function calls.

MYSQLI_REPORT_STRICT

Throw a mysqli_sql_exception for errors instead of warnings.

MYSQLI_REPORT_ALL

Set all options on (report all).

MYSQLI_REPORT_OFF

Turns reporting off.

MYSQLI_DEBUG_TRACE_ENABLED

Is set to 1 if mysqli_debug() functionality is enabled.

MYSQLI_SERVER_QUERY_NO_GOOD_INDEX_USED

MYSQLI_SERVER_QUERY_NO_INDEX_USED

MYSQLI_REFRESH_GRANT

Refreshes the grant tables.

MYSQLI_REFRESH_LOG

Flushes the logs, like executing the FLUSH LOGS SQL statement.

MYSQLI_REFRESH_TABLES

Flushes the table cache, like executing the FLUSH TABLES SQL statement.

MYSQLI_REFRESH_HOSTS

Flushes the host cache, like executing the FLUSH HOSTS SQL statement.

MYSQLI_REFRESH_STATUS

Reset the status variables, like executing the FLUSH STATUS SQL statement.

MYSQLI_REFRESH_THREADS

Flushes the thread cache.

MYSQLI_REFRESH_SLAVE

On a slave replication server: resets the master server information, and restarts the slave. Like executing the RESET SLAVE SQL statement.

MYSQLI_REFRESH_MASTER

On a master replication server: removes the binary log files listed in the binary log index, and truncates the index file. Like executing the RESET MASTER SQL statement.


Notes

Some implementation notes:

  1. Support was added for MYSQL_TYPE_GEOMETRY to the MySQLi extension in PHP 5.3.

  2. Note there are different internal implementations within libmysqlclient and mysqlnd for handling columns of type MYSQL_TYPE_GEOMETRY. Generally speaking, mysqlnd will allocate significantly less memory. For example, if there is a POINT column in a result set, libmysqlclient may pre-allocate up to 4GB of RAM although less than 50 bytes are needed for holding a POINT column in memory. Memory allocation is much lower, less than 50 bytes, if using mysqlnd.


MySQLi 扩展的功能概述

mysqli 方法的概述
mysqli 类
面向对象接口 | 面向过程接口 | 别名 (勿使用) | 描述
属性
$mysqli::affected_rows | mysqli_affected_rows() | N/A | 获取上次 Mysql 操作受影响的行数
$mysqli::client_info | mysqli_get_client_info() | N/A | 返回 Mysql 客户端版本信息，类型为 string
$mysqli::client_version | mysqli_get_client_version() | N/A | 返回 Mysql 客户端版本信息，类型为 integer
$mysqli::connect_errno | mysqli_connect_errno() | N/A | 返回最后一次连接数据库的错误代码
$mysqli::connect_error | mysqli_connect_error() | N/A | 返回最后一次连接数据库的错误描述，类型为字符串
$mysqli::errno | mysqli_errno() | N/A | 返回最近一次函数调用所产生的错误代码
$mysqli::error | mysqli_error() | N/A | 返回最近一次错误代码的描述，类型是字符串
$mysqli::field_count | mysqli_field_count() | N/A | 返回最近一次查询中，包含的列的数量
$mysqli::host_info | mysqli_get_host_info() | N/A | 返回字符串，表示数据库连接所使用的类型
$mysqli::protocol_version | mysqli_get_proto_info() | N/A | 返回使用的 MySQL 协议的版本信息
$mysqli::server_info | mysqli_get_server_info() | N/A | 返回 MySQL 服务器的版本
$mysqli::server_version | mysqli_get_server_version() | N/A | 返回 MySQL 服务器的版本，类型为 integer
$mysqli::info | mysqli_info() | N/A | 获取最近一次数据库查询的信息
$mysqli::insert_id | mysqli_insert_id() | N/A | 返回上次查询中所使用的自动生成的 ID
$mysqli::sqlstate | mysqli_sqlstate() | N/A | 返回上次 MySQL 操作的数据库状态错误（SQLSTATE error）
$mysqli::warning_count | mysqli_warning_count() | N/A | 根据数据库链接，返回最后一次数据库查询内警告的数量
Methods
mysqli::autocommit() | mysqli_autocommit() | N/A | 打开或关闭数据库的自动提交（auto-committing）功能
mysqli::change_user() | mysqli_change_user() | N/A | 更改指定数据库连接所使用的用户
mysqli::character_set_name(), mysqli::client_encoding | mysqli_character_set_name() | mysqli_client_encoding() | 返回数据库连接的默认字符集
mysqli::close() | mysqli_close() | N/A | 关闭先前打开的数据库连接
mysqli::commit() | mysqli_commit() | N/A | 提交当前的数据库事务
mysqli::__construct() | mysqli_connect() | N/A | 打开新连接到 MySQL 服务器［注意：静态方法]
mysqli::debug() | mysqli_debug() | N/A | 执行调试操作
mysqli::dump_debug_info() | mysqli_dump_debug_info() | N/A | 将调试信息转储到日志中
mysqli::get_charset() | mysqli_get_charset() | N/A | 返回包含字符集信息的对象
mysqli::get_connection_stats() | mysqli_get_connection_stats() | N/A | 返回客户端连接的统计信息。仅可用于 mysqlnd。
mysqli::get_client_info() | mysqli_get_client_info() | N/A | 返回 MySQL 客户端版本的字符串信息
mysqli::get_client_stats() | mysqli_get_client_stats() | N/A | 返回每个客户端进程的统计信息。 仅可用于 mysqlnd。
mysqli::get_cache_stats() | mysqli_get_cache_stats() | N/A | 返回客户端的 Zval 缓存统计信息。 仅可用于 mysqlnd。
mysqli::get_server_info() | mysqli_get_server_info() | N/A | 返回 MySQLi 连接上的 MySQL 服务器的版本字符串
mysqli::get_warnings() | mysqli_get_warnings() | N/A | 文档暂缺
mysqli::init() | mysqli_init() | N/A | 初始化 MySQLi，返回资源类型的值，可供 mysqli_real_connect 使用。 [不要在对象上调用，它返回了 $mysqli 对象]
mysqli::kill() | mysqli_kill() | N/A | 请求服务器杀死一个 MySQL 线程
mysqli::more_results() | mysqli_more_results() | N/A | 检查多语句查询内是否还有更多查询结果
mysqli::multi_query() | mysqli_multi_query() | N/A | 在数据库内执行多语句查询
mysqli::next_result() | mysqli_next_result() | N/A | 从 multi_query 中准备下一个结果集
mysqli::options() | mysqli_options() | mysqli_set_opt() | 设置选项
mysqli::ping() | mysqli_ping() | N/A | Ping 服务器链接，如果链接已经断开，尝试重连
mysqli::prepare() | mysqli_prepare() | N/A | 准备（prepare）需要执行的 SQL 语句
mysqli::query() | mysqli_query() | N/A | 在数据库内执行查询
mysqli::real_connect() | mysqli_real_connect() | N/A | 打开一个 MySQL 服务端的连接
mysqli::real_escape_string(), mysqli::escape_string() | mysqli_real_escape_string() | mysqli_escape_string() | 转义特殊字符，用于 SQL 语句，该转换会考虑连接中当前的字符集
mysqli::real_query() | mysqli_real_query() | N/A | 执行 SQL 查询
mysqli::refresh() | mysqli_refresh() | N/A | 刷新表或缓存，或重置复制（replication）服务器信息
mysqli::rollback() | mysqli_rollback() | N/A | 回滚当前事务
mysqli::select_db() | mysqli_select_db() | N/A | 为数据库查询设置默认数据库
mysqli::set_charset() | mysqli_set_charset() | N/A | 设置默认的客户端字符集
mysqli::set_local_infile_default() | mysqli_set_local_infile_default() | N/A | 清除用户设置的 load data local infile 命令的处理程序
mysqli::set_local_infile_handler() | mysqli_set_local_infile_handler() | N/A | 设置 LOAD DATA LOCAL INFILE 命令执行的回调函数
mysqli::ssl_set() | mysqli_ssl_set() | N/A | 使用 SSL 建立安全连接
mysqli::stat() | mysqli_stat() | N/A | 获取当前系统状态
mysqli::stmt_init() | mysqli_stmt_init() | N/A | 初始化语句并且返回供 mysqli_stmt_prepare 使用的对象
mysqli::store_result() | mysqli_store_result() | N/A | 传输最后一个查询的结果集
mysqli::thread_id() | mysqli_thread_id() | N/A | 返回当前连接的线程ID
mysqli::thread_safe() | mysqli_thread_safe() | N/A | 返回是否设定了线程安全
mysqli::use_result() | mysqli_use_result() | N/A | 初始化一个结果集的取回
mysqli_stmt 的方法概述
MySQL_STMT
面向对象接口 | 面向过程接口 | 别名 (勿使用) | 描述
属性
$mysqli_stmt::affected_rows | mysqli_stmt_affected_rows() | N/A | 返回受上次执行语句影响的总行数：修改、删除或插入
$mysqli_stmt::errno | mysqli_stmt_errno() | N/A | 返回最近一次语句调用的错误代码
$mysqli_stmt::error | mysqli_stmt_error() | N/A | 返回最后一条语句错误的字符串描述
$mysqli_stmt::field_count | mysqli_stmt_field_count() | N/A | 返回语句内的字段数量 - 文档暂缺
$mysqli_stmt::insert_id | mysqli_stmt_insert_id() | N/A | 获取上次 INSERT 操作生成的ID
$mysqli_stmt::num_rows | mysqli_stmt_num_rows() | N/A | 返回语句结果集中的行数
$mysqli_stmt::param_count | mysqli_stmt_param_count() | mysqli_param_count() | 返回语句中参数的数量
$mysqli_stmt::sqlstate | mysqli_stmt_sqlstate() | N/A | 返回上次执行 SQL 语句的 SQLSTATE 错误代码
方法
mysqli_stmt::attr_get() | mysqli_stmt_attr_get() | N/A | 用于获取语句属性的当前值
mysqli_stmt::attr_set() | mysqli_stmt_attr_set() | N/A | 用于修改 prepared 语句的行为
mysqli_stmt::bind_param() | mysqli_stmt_bind_param() | mysqli_bind_param() | 绑定变量参数到 prepared 语句
mysqli_stmt::bind_result() | mysqli_stmt_bind_result() | mysqli_bind_result() | 绑定变量参数到 prepared 语句，用于结果存储
mysqli_stmt::close() | mysqli_stmt_close() | N/A | 关闭 prepared 语句
mysqli_stmt::data_seek() | mysqli_stmt_data_seek() | N/A | 定位到结果集中的任意行
mysqli_stmt::execute() | mysqli_stmt_execute() | mysqli_execute() | 执行 prepared 查询
mysqli_stmt::fetch() | mysqli_stmt_fetch() | mysqli_fetch() | 获取 prepared 语句中的结果，到指定变量中
mysqli_stmt::free_result() | mysqli_stmt_free_result() | N/A | 释放给定语句处理存储的结果集所占内存
mysqli_stmt::get_result() | mysqli_stmt_get_result() | N/A | 获取 prepared 语句中的结果。 仅可用于 mysqlnd。
mysqli_stmt::get_warnings() | mysqli_stmt_get_warnings() | N/A | 暂无文档
mysqli_stmt::more_results() | mysqli_stmt_more_results() | N/A | 检查多语句查询中是否还有更多结果
mysqli_stmt::next_result() | mysqli_stmt_next_result() | N/A | 读取多语句查询中下一条结果
mysqli_stmt::num_rows() | mysqli_stmt_num_rows() | N/A | 参见 $mysqli_stmt::num_rows 中的属性
mysqli_stmt::prepare() | mysqli_stmt_prepare() | N/A | 准备执行 SQL 语句
mysqli_stmt::reset() | mysqli_stmt_reset() | N/A | 重置 prepare 语句
mysqli_stmt::result_metadata() | mysqli_stmt_result_metadata() | mysqli_get_metadata() | 返回 prepare 语句结果集内的元数据
mysqli_stmt::send_long_data() | mysqli_stmt_send_long_data() | mysqli_send_long_data() | 以块形式发送数据
mysqli_stmt::store_result() | mysqli_stmt_store_result() | N/A | 从 prepare 语句中传输储存结果集
mysqli_result 方法概述
mysqli_result
面向对象接口 | 面向过程接口 | 别名 (勿使用) | 描述
属性
$mysqli_result::current_field | mysqli_field_tell() | N/A | 获取当前字段在结果集指针中的开始位置
$mysqli_result::field_count | mysqli_num_fields() | N/A | 获取结果中字段数量
$mysqli_result::lengths | mysqli_fetch_lengths() | N/A | 返回结果集中当前行的列长度
$mysqli_result::num_rows | mysqli_num_rows() | N/A | 获取结果中行的数量
方法
mysqli_result::data_seek() | mysqli_data_seek() | N/A | 将结果中的结果指针调整到任意行
mysqli_result::fetch_all() | mysqli_fetch_all() | N/A | 抓取所有的结果行并且以关联数据，数值索引数组，或者两者皆有的方式返回结果集。 仅可用于 mysqlnd。
mysqli_result::fetch_array() | mysqli_fetch_array() | N/A | 以一个关联数组，数值索引数组，或者两者皆有的方式抓取一行结果
mysqli_result::fetch_assoc() | mysqli_fetch_assoc() | N/A | 以一个关联数组方式抓取一行结果
mysqli_result::fetch_field_direct() | mysqli_fetch_field_direct() | N/A | 抓取一个单字段的元数据
mysqli_result::fetch_field() | mysqli_fetch_field() | N/A | 返回结果集中的下一个字段
mysqli_result::fetch_fields() | mysqli_fetch_fields() | N/A | 返回一个代表结果集字段的对象数组
mysqli_result::fetch_object() | mysqli_fetch_object() | N/A | 以一个对象的方式返回一个结果集中的当前行
mysqli_result::fetch_row() | mysqli_fetch_row() | N/A | 以一个枚举数组方式返回一行结果
mysqli_result::field_seek() | mysqli_field_seek() | N/A | 设置结果指针到特定的字段开始位置
mysqli_result::free(), mysqli_result::close, mysqli_result::free_result | mysqli_free_result() | N/A | 释放与一个结果集相关的内存
mysqli_driver 的方法概述
MySQL_Driver
面向对象接口 | 面向过程接口 | 别名 (勿使用) | 描述
属性
N/A
方法
mysqli_driver::embedded_server_end() | mysqli_embedded_server_end() | N/A | 文档暂缺
mysqli_driver::embedded_server_start() | mysqli_embedded_server_start() | N/A | 文档暂缺

Note:

提供函数的别名，目的仅为向下兼容。不要在新项目中使用！


MySQLi类

(PHP 5, PHP 7)

简介

代表PHP和Mysql数据库之间的一个连接。

类摘要

mysqli {
/* 属性 */
int $affected_rows;
static int $connect_errno;
static string $connect_error;
int $errno;
array $error_list;
string $error;
int $field_count;
string $client_info;
int $client_version;
string $host_info;
string $protocol_version;
string $server_info;
int $server_version;
string $info;
mixed $insert_id;
string $sqlstate;
int $thread_id;
int $warning_count;
/* 方法 */
mysqli_affected_rows ( mysqli $link ) : int
autocommit ( bool $mode ) : bool
public begin_transaction ( int $flags = 0 , string $name = ? ) : bool
public change_user ( string $user , string $password , string $database ) : bool
character_set_name ( ) : string
close ( ) : bool
commit ( ) : bool
mysqli_connect_errno ( ) : int
mysqli_connect_error ( ) : string
public connect
 ( string $host = ini_get("mysqli.default_host")
, string $username = ini_get("mysqli.default_user")
, string $passwd = ini_get("mysqli.default_pw")
, string $dbname = ""
, int $port = ini_get("mysqli.default_port")
, string $socket = ini_get("mysqli.default_socket")
) : void
public debug ( string $message ) : bool
dump_debug_info ( ) : bool
mysqli_errno ( mysqli $link ) : int
mysqli_error_list ( mysqli $link ) : array
mysqli_error ( mysqli $link ) : string
mysqli_field_count ( mysqli $link ) : int
public get_charset ( ) : object
get_client_info ( ) : string
mysqli_get_client_version ( mysqli $link ) : int
get_connection_stats ( ) : bool
mysqli_get_host_info ( mysqli $link ) : string
mysqli_get_proto_info ( mysqli $link ) : int
mysqli_get_server_info ( mysqli $link ) : string
mysqli_get_server_version ( mysqli $link ) : int
public get_warnings ( ) : mysqli_warning
mysqli_info ( mysqli $link ) : string
init ( ) : mysqli
mysqli_insert_id ( mysqli $link ) : mixed
kill ( int $processid ) : bool
more_results ( ) : bool
multi_query ( string $query ) : bool
next_result ( ) : bool
options ( int $option , mixed $value ) : bool
ping ( ) : bool
public static poll ( array &$read , array &$error , array &$reject , int $sec , int $usec = 0 ) : int
prepare ( string $query ) : mysqli_stmt
query ( string $query , int $resultmode = MYSQLI_STORE_RESULT ) : mixed
real_connect ( string $host = ? , string $username = ? , string $passwd = ? , string $dbname = ? , int $port = ? , string $socket = ? , int $flags = ? ) : bool
escape_string ( string $escapestr ) : string
real_query ( string $query ) : bool
public reap_async_query ( ) : mysqli_result
public refresh ( int $options ) : bool
public release_savepoint ( string $name ) : bool
rollback ( ) : bool
public savepoint ( string $name ) : bool
select_db ( string $dbname ) : bool
set_charset ( string $charset ) : bool
mysqli_sqlstate ( mysqli $link ) : string
ssl_set ( string $key , string $cert , string $ca , string $capath , string $cipher ) : bool
stat ( ) : string
stmt_init ( ) : mysqli_stmt
store_result ( int $option = ? ) : mysqli_result
mysqli_thread_id ( mysqli $link ) : int
mysqli_thread_safe ( ) : bool
public use_result ( ) : mysqli_result
mysqli_warning_count ( mysqli $link ) : int
}

Table of Contents

  • mysqli::$affected_rows — Gets the number of affected rows in a previous MySQL operation
  • mysqli::autocommit — 打开或关闭本次数据库连接的自动命令提交事务模式
  • mysqli::begin_transaction — Starts a transaction
  • mysqli::change_user — Changes the user of the specified database connection
  • mysqli::character_set_name — 返回当前数据库连接的默认字符编码
  • mysqli::close — 关闭先前打开的数据库连接
  • mysqli::commit — 提交一个事务
  • mysqli::$connect_errno — Returns the error code from last connect call
  • mysqli::$connect_error — Returns a string description of the last connect error
  • mysqli::__construct — Open a new connection to the MySQL server
  • mysqli::debug — Performs debugging operations
  • mysqli::dump_debug_info — 将调试信息输出到日志
  • mysqli::errno — 返回最近函数调用的错误代码
  • mysqli::$error_list — Returns a list of errors from the last command executed
  • mysqli::$error — Returns a string description of the last error
  • mysqli::$field_count — Returns the number of columns for the most recent query
  • mysqli::get_charset — Returns a character set object
  • mysqli::$client_info — 获取 MySQL 客户端信息
  • mysqli_get_client_version — 作为一个整数返回MySQL客户端的版本
  • mysqli::get_connection_stats — 返回客户端连接的统计数据
  • mysqli::$host_info — 返回一个表述使用的连接类型的字符串
  • mysqli::$protocol_version — 返回MySQL使用的协议版本号
  • mysqli::$server_info — 返回MySQL服务器的版本号
  • mysqli::$server_version — 作为一个整数返回MySQL服务器的版本
  • mysqli::get_warnings — Get result of SHOW WARNINGS
  • mysqli::$info — 返回最近执行的 SQL 语句的信息
  • mysqli::init — 初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数
  • mysqli::$insert_id — 返回最后一条插入语句产生的自增 ID
  • mysqli::kill — 让服务器杀掉一个 MySQL 线程
  • mysqli::more_results — 检查批量查询中是否还有查询结果
  • mysqli::multi_query — 执行查询
  • mysqli::next_result — 为读取 multi_query 执行之后的下一个结果集做准备
  • mysqli::options — 设置选项
  • mysqli::ping — ping 一个连接，或者如果连接处于断开状态，重新连接
  • mysqli::poll — 轮询连接
  • mysqli::prepare — 准备执行一个 SQL 语句
  • mysqli::query — 对数据库执行一次查询
  • mysqli::real_connect — 建立一个 MySQL 服务器连接
  • mysqli::real_escape_string — 根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义
  • mysqli::real_query — 执行一个mysql查询
  • mysqli::reap_async_query — 获取异步查询的结果
  • mysqli::refresh — 刷新
  • mysqli::release_savepoint — 从当前事务的保存点中移除一个命名保存点
  • mysqli::rollback — 回退当前事务
  • mysqli::savepoint — 在当前事务中增加一个命名保存点
  • mysqli::select_db — 选择用于数据库查询的默认数据库
  • mysqli::set_charset — 设置默认字符编码
  • mysqli::$sqlstate — 返回上一次 SQL 操作的 SQLSTATE 错误信息
  • mysqli::ssl_set — 使用 SSL 建立到数据库之间的安全连接
  • mysqli::stat — 获取当前系统状态信息
  • mysqli::stmt_init — 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象
  • mysqli::store_result — 转移上一次查询返回的结果集
  • mysqli::$thread_id — 返回当前连接的线程 ID
  • mysqli::thread_safe — 返回是否是线程安全的
  • mysqli::use_result — Initiate a result set retrieval
  • mysqli::$warning_count — Returns the number of warnings from the last query for the given link


Gets the number of affected rows in a previous MySQL operation

  • ? MySQLi
  • mysqli::autocommit ?
  • PHP Manual
  • MySQLi
  • Gets the number of affected rows in a previous MySQL operation

mysqli::$affected_rows

mysqli_affected_rows

(PHP 5, PHP 7)

mysqli::$affected_rows -- mysqli_affected_rows — Gets the number of affected rows in a previous MySQL operation

说明

面向对象风格

int $mysqli->affected_rows;

过程化风格

mysqli_affected_rows ( mysqli $link ) : int

Returns the number of rows affected by the last INSERT, UPDATE, REPLACE or DELETE query.

For SELECT statements mysqli_affected_rows() works like mysqli_num_rows().

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records were updated for an UPDATE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query returned an error.

Note:

If the number of affected rows is greater than the maximum integer value( PHP_INT_MAX ), the number of affected rows will be returned as a string.

范例

Example #1 $mysqli->affected_rows example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Insert rows */
$mysqli->query("CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", $mysqli->affected_rows);

$mysqli->query("ALTER TABLE Language ADD Status int default 0");

/* update rows */
$mysqli->query("UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", $mysqli->affected_rows);

/* delete rows */
$mysqli->query("DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", $mysqli->affected_rows);

/* select all rows */
$result = $mysqli->query("SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", $mysqli->affected_rows);

$result->close();

/* Delete table Language */
$mysqli->query("DROP TABLE Language");

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* Insert rows */
mysqli_query($link, "CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", mysqli_affected_rows($link));

mysqli_query($link, "ALTER TABLE Language ADD Status int default 0");

/* update rows */
mysqli_query($link, "UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", mysqli_affected_rows($link));

/* delete rows */
mysqli_query($link, "DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", mysqli_affected_rows($link));

/* select all rows */
$result = mysqli_query($link, "SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", mysqli_affected_rows($link));

mysqli_free_result($result);

/* Delete table Language */
mysqli_query($link, "DROP TABLE Language");

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Affected rows (INSERT): 984
Affected rows (UPDATE): 168
Affected rows (DELETE): 815
Affected rows (SELECT): 169

参见

  • mysqli_num_rows() - Gets the number of rows in a result
  • mysqli_info() - 返回最近执行的 SQL 语句的信息


打开或关闭本次数据库连接的自动命令提交事务模式

  • ? mysqli::$affected_rows
  • mysqli::begin_transaction ?
  • PHP Manual
  • MySQLi
  • 打开或关闭本次数据库连接的自动命令提交事务模式

mysqli::autocommit

mysqli_autocommit

(PHP 5, PHP 7)

mysqli::autocommit -- mysqli_autocommit — 打开或关闭本次数据库连接的自动命令提交事务模式

说明

面向对象风格

mysqli::autocommit ( bool $mode ) : bool

过程化风格

mysqli_autocommit ( mysqli $link , bool $mode ) : bool

打开或关闭本次数据库连接的自动命令提交事务模式。

如需要确认当前连接的自动事务提交状态，可执行这个SQL请求SELECT @@autocommit.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

mode

Whether to turn on auto-commit or not.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

这个方法不会在不支持事务处理的表单查询中生效，如MyISAM或 ISAM。

范例

Example #1 mysqli::autocommit() example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* turn autocommit on */
$mysqli->autocommit(TRUE);

if ($result = $mysqli->query("SELECT @@autocommit")) {
    $row = $result->fetch_row();
    printf("Autocommit is %s\n", $row[0]);
    $result->free();
}

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* turn autocommit on */
mysqli_autocommit($link, TRUE);

if ($result = mysqli_query($link, "SELECT @@autocommit")) {
    $row = mysqli_fetch_row($result);
    printf("Autocommit is %s\n", $row[0]);
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Autocommit is 1

参见

  • mysqli_commit() - 提交一个事务
  • mysqli_rollback() - 回退当前事务


Starts a transaction

  • ? mysqli::autocommit
  • mysqli::change_user ?
  • PHP Manual
  • MySQLi
  • Starts a transaction

mysqli::begin_transaction

mysqli_begin_transaction

(PHP 5 >= 5.5.0, PHP 7)

mysqli::begin_transaction -- mysqli_begin_transaction — Starts a transaction

说明

面向对象风格

public mysqli::begin_transaction ( int $flags = 0 , string $name = ? ) : bool

过程化风格:

mysqli_begin_transaction ( mysqli $link , int $flags = 0 , string $name = ? ) : bool

Begins a transaction. Requires the InnoDB engine (it is enabled by default). For additional details about how MySQL transactions work, see » http://dev.mysql.com/doc/mysql/en/commit.html.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

flags

Valid flags are:

  • MYSQLI_TRANS_START_READ_ONLY: Start the transaction as "START TRANSACTION READ ONLY". Requires MySQL 5.6 and above.

  • MYSQLI_TRANS_START_READ_WRITE: Start the transaction as "START TRANSACTION READ WRITE". Requires MySQL 5.6 and above.

  • MYSQLI_TRANS_START_WITH_CONSISTENT_SNAPSHOT: Start the transaction as "START TRANSACTION WITH CONSISTENT SNAPSHOT".

name

Savepoint name for the transaction.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function does not work with non transactional table types (like MyISAM or ISAM).

范例

Example #1 mysqli::begin_transaction() example

面向对象风格

<?php

/* Tell mysqli to throw an exception if an error occurs */
mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);

$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* The table engine has to support transactions */
$mysqli->query("CREATE TABLE IF NOT EXISTS language (
    Code text NOT NULL,
    Speakers int(11) NOT NULL
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4;");

/* Start transaction */
$mysqli->begin_transaction();

try {
    /* Insert some values */
    $mysqli->query("INSERT INTO language(Code, Speakers) VALUES ('DE', 42000123)");

    /* Try to insert invalid values */
    $language_code = 'FR';
    $native_speakers = 'Unknown';
    $stmt = $mysqli->prepare('INSERT INTO language(Code, Speakers) VALUES (?,?)');
    $stmt->bind_param('ss', $language_code, $native_speakers);
    $stmt->execute();

    /* If code reaches this point without errors then commit the data in the database */
    $mysqli->commit();
} catch (mysqli_sql_exception $exception) {
    $mysqli->rollback();

    throw $exception;
}

过程化风格

<?php

/* Tell mysqli to throw an exception if an error occurs */
mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);

$mysqli = mysqli_connect("localhost", "my_user", "my_password", "world");

/* The table engine has to support transactions */
mysqli_query($mysqli, "CREATE TABLE IF NOT EXISTS language (
    Code text NOT NULL,
    Speakers int(11) NOT NULL
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4;");

/* Start transaction */
mysqli_begin_transaction($mysqli);

try {
    /* Insert some values */
    mysqli_query($mysqli, "INSERT INTO language(Code, Speakers) VALUES ('DE', 42000123)");

    /* Try to insert invalid values */
    $language_code = 'FR';
    $native_speakers = 'Unknown';
    $stmt = mysqli_prepare($mysqli, 'INSERT INTO language(Code, Speakers) VALUES (?,?)');
    mysqli_stmt_bind_param($stmt, 'ss', $language_code, $native_speakers);
    mysqli_stmt_execute($stmt);

    /* If code reaches this point without errors then commit the data in the database */
    mysqli_commit($mysqli);
} catch (mysqli_sql_exception $exception) {
    mysqli_rollback($mysqli);

    throw $exception;
}

参见

  • mysqli_autocommit() - 打开或关闭本次数据库连接的自动命令提交事务模式
  • mysqli_commit() - 提交一个事务
  • mysqli_rollback() - 回退当前事务


Changes the user of the specified database connection

  • ? mysqli::begin_transaction
  • mysqli::character_set_name ?
  • PHP Manual
  • MySQLi
  • Changes the user of the specified database connection

mysqli::change_user

mysqli_change_user

(PHP 5, PHP 7)

mysqli::change_user -- mysqli_change_user — Changes the user of the specified database connection

说明

面向对象风格

public mysqli::change_user ( string $user , string $password , string $database ) : bool

过程化风格

mysqli_change_user ( mysqli $link , string $user , string $password , string $database ) : bool

Changes the user of the specified database connection and sets the current database.

In order to successfully change users a valid username and password parameters must be provided and that user must have sufficient permissions to access the desired database. If for any reason authorization fails, the current user authentication will remain.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

user

The MySQL user name.

password

The MySQL password.

database

The database to change to.

If desired, the null value may be passed resulting in only changing the user and not selecting a database. To select a database in this case use the mysqli_select_db() function.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

Using this command will always cause the current database connection to behave as if was a completely new database connection, regardless of if the operation was completed successfully. This reset includes performing a rollback on any active transactions, closing all temporary tables, and unlocking all locked tables.

范例

Example #1 mysqli::change_user() example

面向对象风格

<?php

/* connect database test */
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
$mysqli->query("SET @a:=1");

/* reset all and select a new database */
$mysqli->change_user("my_user", "my_password", "world");

if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database: %s\n", $row[0]);
    $result->close();
}

if ($result = $mysqli->query("SELECT @a")) {
    $row = $result->fetch_row();
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
/* connect database test */
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
mysqli_query($link, "SET @a:=1");

/* reset all and select a new database */
mysqli_change_user($link, "my_user", "my_password", "world");

if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database: %s\n", $row[0]);
    mysqli_free_result($result);
}

if ($result = mysqli_query($link, "SELECT @a")) {
    $row = mysqli_fetch_row($result);
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Default database: world
Value of variable a is NULL

参见

  • mysqli_connect() - 别名 mysqli::__construct
  • mysqli_select_db() - 选择用于数据库查询的默认数据库


返回当前数据库连接的默认字符编码

  • ? mysqli::change_user
  • mysqli::close ?
  • PHP Manual
  • MySQLi
  • 返回当前数据库连接的默认字符编码

mysqli::character_set_name

mysqli_character_set_name

(PHP 5, PHP 7)

mysqli::character_set_name -- mysqli_character_set_name — 返回当前数据库连接的默认字符编码

说明

面向对象风格

mysqli::character_set_name ( ) : string

过程化风格

mysqli_character_set_name ( mysqli $link ) : string

返回当前数据库连接的默认字符编码。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

The default character set for the current connection

范例

Example #1 mysqli::character_set_name() example

面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = $mysqli->character_set_name();
printf ("Current character set is %s\n", $charset);

$mysqli->close();
?>

过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = mysqli_character_set_name($link);
printf ("Current character set is %s\n",$charset);

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Current character set is latin1_swedish_ci

参见

  • mysqli_set_charset() - 设置默认字符编码
  • mysqli_client_encoding()
  • mysqli_real_escape_string() - 根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义


关闭先前打开的数据库连接

  • ? mysqli::character_set_name
  • mysqli::commit ?
  • PHP Manual
  • MySQLi
  • 关闭先前打开的数据库连接

mysqli::close

mysqli_close

(PHP 5, PHP 7)

mysqli::close -- mysqli_close — 关闭先前打开的数据库连接

说明

面向对象风格

mysqli::close ( ) : bool

过程化风格

mysqli_close ( mysqli $link ) : bool

关闭先前打开的数据库连接

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

See mysqli_connect().

参见

  • mysqli::__construct() - Open a new connection to the MySQL server
  • mysqli_init() - 初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数
  • mysqli_real_connect() - 建立一个 MySQL 服务器连接


提交一个事务

  • ? mysqli::close
  • mysqli::$connect_errno ?
  • PHP Manual
  • MySQLi
  • 提交一个事务

mysqli::commit

mysqli_commit

(PHP 5, PHP 7)

mysqli::commit -- mysqli_commit — 提交一个事务

说明

面向对象风格

mysqli::commit ( ) : bool

过程化风格

mysqli_commit ( mysqli $link ) : bool

提交数据库连接的当前事务

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysqli::commit() example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE Language LIKE CountryLanguage");

/* set autocommit to off */
$mysqli->autocommit(FALSE);

/* Insert some values */
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* commit transaction */
$mysqli->commit();

/* drop table */
$mysqli->query("DROP TABLE Language");

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* set autocommit to off */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE Language LIKE CountryLanguage");

/* Insert some values */
mysqli_query($link, "INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
mysqli_query($link, "INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* commit transaction */
mysqli_commit($link);

/* close connection */
mysqli_close($link);
?>

参见

  • mysqli_autocommit() - 打开或关闭本次数据库连接的自动命令提交事务模式
  • mysqli_rollback() - 回退当前事务


Returns the error code from last connect call

  • ? mysqli::commit
  • mysqli::$connect_error ?
  • PHP Manual
  • MySQLi
  • Returns the error code from last connect call

mysqli::$connect_errno

mysqli_connect_errno

(PHP 5, PHP 7)

mysqli::$connect_errno -- mysqli_connect_errno — Returns the error code from last connect call

说明

面向对象风格

static int $mysqli->connect_errno;

过程化风格

mysqli_connect_errno ( ) : int

Returns the last error code number from the last call to mysqli_connect().

Note:

Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

返回值

An error code value for the last call to mysqli_connect(), if it failed. zero means no error occurred.

范例

Example #1 $mysqli->connect_errno example

面向对象风格

<?php
$mysqli = @new mysqli('localhost', 'fake_user', 'my_password', 'my_db');

if ($mysqli->connect_errno) {
    die('Connect Error: ' . $mysqli->connect_errno);
}
?>

过程化风格

<?php
$link = @mysqli_connect('localhost', 'fake_user', 'my_password', 'my_db');

if (!$link) {
    die('Connect Error: ' . mysqli_connect_errno());
}
?>

以上例程会输出：

Connect Error: 1045

参见

  • mysqli_connect() - 别名 mysqli::__construct
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_errno() - 返回最近函数调用的错误代码
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - 返回上一次 SQL 操作的 SQLSTATE 错误信息


Returns a string description of the last connect error

  • ? mysqli::$connect_errno
  • mysqli::__construct ?
  • PHP Manual
  • MySQLi
  • Returns a string description of the last connect error

mysqli::$connect_error

mysqli_connect_error

(PHP 5, PHP 7)

mysqli::$connect_error -- mysqli_connect_error — Returns a string description of the last connect error

说明

面向对象风格

static string $mysqli->connect_error;

过程化风格

mysqli_connect_error ( ) : string

Returns the last error message string from the last call to mysqli_connect().

返回值

A string that describes the error. null is returned if no error occurred.

范例

Example #1 $mysqli->connect_error example

面向对象风格

<?php
$mysqli = @new mysqli('localhost', 'fake_user', 'my_password', 'my_db');

if ($mysqli->connect_error) {
    die('Connect Error: ' . $mysqli->connect_error);
}
?>

过程化风格

<?php
$link = @mysqli_connect('localhost', 'fake_user', 'my_password', 'my_db');

if (!$link) {
    die('Connect Error: ' . mysqli_connect_error());
}
?>

以上例程会输出：

Connect Error: Access denied for user 'fake_user'@'localhost' (using password: YES)

参见

  • mysqli_connect() - 别名 mysqli::__construct
  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_errno() - 返回最近函数调用的错误代码
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - 返回上一次 SQL 操作的 SQLSTATE 错误信息


Open a new connection to the MySQL server

  • ? mysqli::$connect_error
  • mysqli::debug ?
  • PHP Manual
  • MySQLi
  • Open a new connection to the MySQL server

mysqli::__construct

mysqli::connect

mysqli_connect

(PHP 5, PHP 7)

mysqli::__construct -- mysqli::connect -- mysqli_connect — Open a new connection to the MySQL server

说明

面向对象风格

public mysqli::__construct
 ( string $host = ini_get("mysqli.default_host")
, string $username = ini_get("mysqli.default_user")
, string $passwd = ini_get("mysqli.default_pw")
, string $dbname = ""
, int $port = ini_get("mysqli.default_port")
, string $socket = ini_get("mysqli.default_socket")
)
public mysqli::connect
 ( string $host = ini_get("mysqli.default_host")
, string $username = ini_get("mysqli.default_user")
, string $passwd = ini_get("mysqli.default_pw")
, string $dbname = ""
, int $port = ini_get("mysqli.default_port")
, string $socket = ini_get("mysqli.default_socket")
) : void

过程化风格

mysqli_connect
 ( string $host = ini_get("mysqli.default_host")
, string $username = ini_get("mysqli.default_user")
, string $passwd = ini_get("mysqli.default_pw")
, string $dbname = ""
, int $port = ini_get("mysqli.default_port")
, string $socket = ini_get("mysqli.default_socket")
) : mysqli|false

Opens a connection to the MySQL Server.

参数

host

Can be either a host name or an IP address. The local host is assumed when passing the null value or the string "localhost" to this parameter. When possible, pipes will be used instead of the TCP/IP protocol. The TCP/IP protocol is used if a host name and port number are provided together e.g. localhost:3308.

Prepending host by p: opens a persistent connection. mysqli_change_user() is automatically called on connections opened from the connection pool.

username

The MySQL user name.

passwd

If not provided or null, the MySQL server will attempt to authenticate the user against those user records which have no password only. This allows one username to be used with different permissions (depending on if a password is provided or not).

dbname

If provided will specify the default database to be used when performing queries.

port

Specifies the port number to attempt to connect to the MySQL server.

socket

Specifies the socket or named pipe that should be used.

Note:

Specifying the socket parameter will not explicitly determine the type of connection to be used when connecting to the MySQL server. How the connection is made to the MySQL database is determined by the host parameter.

返回值

mysqli::__construct() always returns an object which represents the connection to a MySQL Server, regardless of it being successful or not.

mysqli_connect() returns an object which represents the connection to a MySQL Server, 或者在失败时返回 false.

mysqli::connect() returns null on success 或者在失败时返回 false.

错误／异常

If MYSQLI_REPORT_STRICT is enabled and the attempt to connect to the requested database fails, a mysqli_sql_exception is thrown.

范例

Example #1 mysqli::__construct() example

面向对象风格

<?php

/* You should enable error reporting for mysqli before attempting to make a connection */
mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);

$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'my_db');

/* Set the desired charset after establishing a connection */
$mysqli->set_charset('utf8mb4');

printf("Success... %s\n", $mysqli->host_info);

过程化风格

<?php

/* You should enable error reporting for mysqli before attempting to make a connection */
mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);

$mysqli = mysqli_connect('localhost', 'my_user', 'my_password', 'my_db');

/* Set the desired charset after establishing a connection */
mysqli_set_charset($mysqli, 'utf8mb4');

printf("Success... %s\n", mysqli_get_host_info($mysqli));

以上例程的输出类似于：

Success... localhost via TCP/IP

Example #2 Extending mysqli class

<?php

class FooMysqli extends mysqli {
    public function __construct($host, $user, $pass, $db, $port, $socket, $charset) {
        mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
        parent::__construct($host, $user, $pass, $db, $port, $socket);
        $this->set_charset($charset);
    }
}

$db = new FooMysqli('localhost', 'my_user', 'my_password', 'my_db', 3306, null, 'utf8mb4');

Example #3 Manual error handling

If error reporting is disabled, the developer is responsible for checking and handling failures

面向对象风格

<?php

error_reporting(0);
mysqli_report(MYSQLI_REPORT_OFF);
$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'my_db');
if ($mysqli->connect_errno) {
    throw new RuntimeException('mysqli connection error: ' . $mysqli->connect_error);
}

/* Set the desired charset after establishing a connection */
$mysqli->set_charset('utf8mb4');
if ($mysqli->errno) {
    throw new RuntimeException('mysqli error: ' . $mysqli->error);
}

过程化风格

<?php

error_reporting(0);
mysqli_report(MYSQLI_REPORT_OFF);
$mysqli = mysqli_connect('localhost', 'my_user', 'my_password', 'my_db');
if (mysqli_connect_errno()) {
    throw new RuntimeException('mysqli connection error: ' . mysqli_connect_error());
}

/* Set the desired charset after establishing a connection */
mysqli_set_charset($mysqli, 'utf8mb4');
if (mysqli_errno($mysqli)) {
    throw new RuntimeException('mysqli error: ' . mysqli_error($mysqli));
}

注释

Note:

MySQLnd 总是使用服务器的默认字符集。此字符集在连接握手／认证时发送，并被 mysqlnd 使用。

Libmysqlclient 使用 my.cnf 中的默认字符集或者由在调用 mysqli_init() 之后，mysqli_real_connect() 之前先调用 mysqli_options() 来指定。

Note:

面向对象风格 only: If the connection fails, an object is still returned. To check whether the connection failed, use either the mysqli_connect_error() function or the mysqli->connect_error property as in the preceding examples.

Note:

If it is necessary to set options, such as the connection timeout, mysqli_real_connect() must be used instead.

Note:

Calling the constructor with no parameters is the same as calling mysqli_init().

Note:

Error "Can't create TCP/IP socket (10106)" usually means that the variables_order configure directive doesn't contain character E. On Windows, if the environment is not copied the SYSTEMROOT environment variable won't be available and PHP will have problems loading Winsock.

参见

  • mysqli_real_connect() - 建立一个 MySQL 服务器连接
  • mysqli_options() - 设置选项
  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_close() - 关闭先前打开的数据库连接


Performs debugging operations

  • ? mysqli::__construct
  • mysqli::dump_debug_info ?
  • PHP Manual
  • MySQLi
  • Performs debugging operations

mysqli::debug

mysqli_debug

(PHP 5, PHP 7)

mysqli::debug -- mysqli_debug — Performs debugging operations

说明

面向对象风格

public mysqli::debug ( string $message ) : bool

过程化风格

mysqli_debug ( string $message ) : bool

Performs debugging operations using the Fred Fish debugging library.

参数

message

A string representing the debugging operation to perform

返回值

Returns true.

注释

Note:

To use the mysqli_debug() function you must compile the MySQL client library to support debugging.

范例

Example #1 Generating a Trace File

<?php

/* Create a trace file in '/tmp/client.trace' on the local (client) machine: */
mysqli_debug("d:t:o,/tmp/client.trace");

?>

参见

  • mysqli_dump_debug_info() - 将调试信息输出到日志
  • mysqli_report() - 别名 mysqli_driver->report_mode


将调试信息输出到日志

  • ? mysqli::debug
  • mysqli::errno ?
  • PHP Manual
  • MySQLi
  • 将调试信息输出到日志

mysqli::dump_debug_info

mysqli_dump_debug_info

(PHP 5, PHP 7)

mysqli::dump_debug_info -- mysqli_dump_debug_info — 将调试信息输出到日志

说明

面向对象风格

mysqli::dump_debug_info ( ) : bool

过程化风格

mysqli_dump_debug_info ( mysqli $link ) : bool

这个函数设计用于超级权限用户执行将调试信息输出到连接相关的MySQL服务端日志

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mysqli_debug() - Performs debugging operations


返回最近函数调用的错误代码

  • ? mysqli::dump_debug_info
  • mysqli::$error_list ?
  • PHP Manual
  • MySQLi
  • 返回最近函数调用的错误代码

mysqli::errno

mysqli_errno

(PHP 5, PHP 7)

mysqli::errno -- mysqli_errno — 返回最近函数调用的错误代码

说明

面向对象风格

int $errno;

过程化风格

mysqli_errno ( mysqli $link ) : int

返回最近的mysqli函数调用产生的错误代码.

客户端错误在Mysqlerrmsg.h头文件中列出, 服务端错误好在mysqld_error.h中列出. 在mysql源码分发包中的Docs/mysqld_error.txt你可以发现一个完整的错误消息和错误号.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

最后一次调用产生的错误代码, 返回0代表没有错误发生.

范例

Example #1 mysqli->errno example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Errorcode: %d\n", $mysqli->errno);
}

/* 关闭连接 */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errorcode: %d\n", mysqli_errno($link));
}

/* 关闭连接 */
mysqli_close($link);
?>

以上例程会输出：

Errorcode: 1193

参见

  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - 返回上一次 SQL 操作的 SQLSTATE 错误信息


Returns a list of errors from the last command executed

  • ? mysqli::errno
  • mysqli::$error ?
  • PHP Manual
  • MySQLi
  • Returns a list of errors from the last command executed

mysqli::$error_list

mysqli_error_list

(PHP 5 >= 5.4.0, PHP 7)

mysqli::$error_list -- mysqli_error_list — Returns a list of errors from the last command executed

说明

面向对象风格

array $mysqli->error_list;

过程化风格

mysqli_error_list ( mysqli $link ) : array

Returns a array of errors for the most recent MySQLi function call that can succeed or fail.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

A list of errors, each as an associative array containing the errno, error, and sqlstate.

范例

Example #1 $mysqli->error_list example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "nobody", "");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!$mysqli->query("SET a=1")) {
    print_r($mysqli->error_list);
}

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    print_r(mysqli_error_list($link));
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [errno] => 1193
            [sqlstate] => HY000
            [error] => Unknown system variable 'a'
        )

)

参见

  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - 返回上一次 SQL 操作的 SQLSTATE 错误信息


Returns a string description of the last error

  • ? mysqli::$error_list
  • mysqli::$field_count ?
  • PHP Manual
  • MySQLi
  • Returns a string description of the last error

mysqli::$error

mysqli_error

(PHP 5, PHP 7)

mysqli::$error -- mysqli_error — Returns a string description of the last error

说明

面向对象风格

string $mysqli->error;

过程化风格

mysqli_error ( mysqli $link ) : string

Returns the last error message for the most recent MySQLi function call that can succeed or fail.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

A string that describes the error. An empty string if no error occurred.

范例

Example #1 $mysqli->error example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Error message: %s\n", $mysqli->error);
}

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Error message: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Error message: Unknown system variable 'a'

参见

  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_errno() - 返回最近函数调用的错误代码
  • mysqli_sqlstate() - 返回上一次 SQL 操作的 SQLSTATE 错误信息


Returns the number of columns for the most recent query

  • ? mysqli::$error
  • mysqli::get_charset ?
  • PHP Manual
  • MySQLi
  • Returns the number of columns for the most recent query

mysqli::$field_count

mysqli_field_count

(PHP 5, PHP 7)

mysqli::$field_count -- mysqli_field_count — Returns the number of columns for the most recent query

说明

面向对象风格

int $mysqli->field_count;

过程化风格

mysqli_field_count ( mysqli $link ) : int

Returns the number of columns for the most recent query on the connection represented by the link parameter. This function can be useful when using the mysqli_store_result() function to determine if the query should have produced a non-empty result set or not without knowing the nature of the query.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

An integer representing the number of fields in a result set.

范例

Example #1 $mysqli->field_count example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query( "DROP TABLE IF EXISTS friends");
$mysqli->query( "CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query( "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$mysqli->real_query("SELECT * FROM friends");

if ($mysqli->field_count) {
    /* this was a select/show or describe query */
    $result = $mysqli->store_result();

    /* process resultset */
    $row = $result->fetch_row();

    /* free resultset */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

mysqli_real_query($link, "SELECT * FROM friends");

if (mysqli_field_count($link)) {
    /* this was a select/show or describe query */
    $result = mysqli_store_result($link);

    /* process resultset */
    $row = mysqli_fetch_row($result);

    /* free resultset */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>


Returns a character set object

  • ? mysqli::$field_count
  • mysqli::$client_info ?
  • PHP Manual
  • MySQLi
  • Returns a character set object

mysqli::get_charset

mysqli_get_charset

(PHP 5 >= 5.1.0, PHP 7)

mysqli::get_charset -- mysqli_get_charset — Returns a character set object

说明

面向对象风格

public mysqli::get_charset ( ) : object

过程化风格

mysqli_get_charset ( mysqli $link ) : object

Returns a character set object providing several properties of the current active character set.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

The function returns a character set object with the following properties:

charset

Character set name

collation

Collation name

dir

Directory the charset description was fetched from (?) or "" for built-in character sets

min_length

Minimum character length in bytes

max_length

Maximum character length in bytes

number

Internal character set number

state

Character set status (?)

范例

Example #1 mysqli::get_charset() example

面向对象风格

<?php
  $db = mysqli_init();
  $db->real_connect("localhost","root","","test");
  var_dump($db->get_charset());
?>

过程化风格

<?php
  $db = mysqli_init();
  mysqli_real_connect($db, "localhost","root","","test");
  var_dump(mysqli_get_charset($db));
?>

以上例程会输出：

object(stdClass)#2 (7) {
  ["charset"]=>
  string(6) "latin1"
  ["collation"]=>
  string(17) "latin1_swedish_ci"
  ["dir"]=>
  string(0) ""
  ["min_length"]=>
  int(1)
  ["max_length"]=>
  int(1)
  ["number"]=>
  int(8)
  ["state"]=>
  int(801)
}

参见

  • mysqli_character_set_name() - 返回当前数据库连接的默认字符编码
  • mysqli_set_charset() - 设置默认字符编码


获取 MySQL 客户端信息

  • ? mysqli::get_charset
  • mysqli_get_client_version ?
  • PHP Manual
  • MySQLi
  • 获取 MySQL 客户端信息

mysqli::$client_info

mysqli::get_client_info

mysqli_get_client_info

(PHP 5, PHP 7)

mysqli::$client_info -- mysqli::get_client_info -- mysqli_get_client_info — 获取 MySQL 客户端信息

说明

面向对象风格

string $mysqli->client_info;
mysqli::get_client_info ( ) : string

过程化风格

mysqli_get_client_info ( mysqli $link ) : string

返回 MySQL 客户端库的版本信息。

返回值

返回 MySQL 客户端库的版本信息。

范例

Example #1 mysqli_get_client_info

<?php

/* 获取客户端版本新的时候，
   无需建立到数据库的连接 */

printf("Client library version: %s\n", mysqli_get_client_info());
?>

参见

  • mysqli_get_client_version() - 作为一个整数返回MySQL客户端的版本
  • mysqli_get_server_info() - 返回MySQL服务器的版本号
  • mysqli_get_server_version() - 作为一个整数返回MySQL服务器的版本


作为一个整数返回MySQL客户端的版本

  • ? mysqli::$client_info
  • mysqli::get_connection_stats ?
  • PHP Manual
  • MySQLi
  • 作为一个整数返回MySQL客户端的版本

mysqli_get_client_version

mysqli::$client_version

(PHP 5, PHP 7)

mysqli_get_client_version -- mysqli::$client_version — 作为一个整数返回MySQL客户端的版本

说明

面向对象风格

int $mysqli->client_version;

过程化风格

mysqli_get_client_version ( mysqli $link ) : int

作为一个整数返回客户端版本号.

返回值

一个表述MySQL客户端库版本的数字的格式: main_version*10000 + minor_version *100 + sub_version. 举个例子： 4.1.0 将返回 40100.

这有助于快速确定客户端库的版本来辨别是否有某些特性存在.

范例

Example #1 mysqli_get_client_version

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %d\n", mysqli_get_client_version());
?>

参见

  • mysqli_get_client_info() - 获取 MySQL 客户端信息
  • mysqli_get_server_info() - 返回MySQL服务器的版本号
  • mysqli_get_server_version() - 作为一个整数返回MySQL服务器的版本


返回客户端连接的统计数据

  • ? mysqli_get_client_version
  • mysqli::$host_info ?
  • PHP Manual
  • MySQLi
  • 返回客户端连接的统计数据

mysqli::get_connection_stats

mysqli_get_connection_stats

(PHP 5 >= 5.3.0, PHP 7)

mysqli::get_connection_stats -- mysqli_get_connection_stats — 返回客户端连接的统计数据

说明

面向对象风格

mysqli::get_connection_stats ( ) : bool

过程化风格

mysqli_get_connection_stats ( mysqli $link ) : array

返回客户端连接的统计数据， 仅可用于 mysqlnd。。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

返回一个数组，包含客户端连接的统计数据，否则 false。

范例

Example #1 A mysqli_get_connection_stats() 例程

<?php
$link = mysqli_connect();
print_r(mysqli_get_connection_stats($link));
?>

以上例程的输出类似于：

Array
(
    [bytes_sent] => 43
    [bytes_received] => 80
    [packets_sent] => 1
    [packets_received] => 2
    [protocol_overhead_in] => 8
    [protocol_overhead_out] => 4
    [bytes_received_ok_packet] => 11
    [bytes_received_eof_packet] => 0
    [bytes_received_rset_header_packet] => 0
    [bytes_received_rset_field_meta_packet] => 0
    [bytes_received_rset_row_packet] => 0
    [bytes_received_prepare_response_packet] => 0
    [bytes_received_change_user_packet] => 0
    [packets_sent_command] => 0
    [packets_received_ok] => 1
    [packets_received_eof] => 0
    [packets_received_rset_header] => 0
    [packets_received_rset_field_meta] => 0
    [packets_received_rset_row] => 0
    [packets_received_prepare_response] => 0
    [packets_received_change_user] => 0
    [result_set_queries] => 0
    [non_result_set_queries] => 0
    [no_index_used] => 0
    [bad_index_used] => 0
    [slow_queries] => 0
    [buffered_sets] => 0
    [unbuffered_sets] => 0
    [ps_buffered_sets] => 0
    [ps_unbuffered_sets] => 0
    [flushed_normal_sets] => 0
    [flushed_ps_sets] => 0
    [ps_prepared_never_executed] => 0
    [ps_prepared_once_executed] => 0
    [rows_fetched_from_server_normal] => 0
    [rows_fetched_from_server_ps] => 0
    [rows_buffered_from_client_normal] => 0
    [rows_buffered_from_client_ps] => 0
    [rows_fetched_from_client_normal_buffered] => 0
    [rows_fetched_from_client_normal_unbuffered] => 0
    [rows_fetched_from_client_ps_buffered] => 0
    [rows_fetched_from_client_ps_unbuffered] => 0
    [rows_fetched_from_client_ps_cursor] => 0
    [rows_skipped_normal] => 0
    [rows_skipped_ps] => 0
    [copy_on_write_saved] => 0
    [copy_on_write_performed] => 0
    [command_buffer_too_small] => 0
    [connect_success] => 1
    [connect_failure] => 0
    [connection_reused] => 0
    [reconnect] => 0
    [pconnect_success] => 0
    [active_connections] => 1
    [active_persistent_connections] => 0
    [explicit_close] => 0
    [implicit_close] => 0
    [disconnect_close] => 0
    [in_middle_of_command_close] => 0
    [explicit_free_result] => 0
    [implicit_free_result] => 0
    [explicit_stmt_close] => 0
    [implicit_stmt_close] => 0
    [mem_emalloc_count] => 0
    [mem_emalloc_ammount] => 0
    [mem_ecalloc_count] => 0
    [mem_ecalloc_ammount] => 0
    [mem_erealloc_count] => 0
    [mem_erealloc_ammount] => 0
    [mem_efree_count] => 0
    [mem_malloc_count] => 0
    [mem_malloc_ammount] => 0
    [mem_calloc_count] => 0
    [mem_calloc_ammount] => 0
    [mem_realloc_count] => 0
    [mem_realloc_ammount] => 0
    [mem_free_count] => 0
    [proto_text_fetched_null] => 0
    [proto_text_fetched_bit] => 0
    [proto_text_fetched_tinyint] => 0
    [proto_text_fetched_short] => 0
    [proto_text_fetched_int24] => 0
    [proto_text_fetched_int] => 0
    [proto_text_fetched_bigint] => 0
    [proto_text_fetched_decimal] => 0
    [proto_text_fetched_float] => 0
    [proto_text_fetched_double] => 0
    [proto_text_fetched_date] => 0
    [proto_text_fetched_year] => 0
    [proto_text_fetched_time] => 0
    [proto_text_fetched_datetime] => 0
    [proto_text_fetched_timestamp] => 0
    [proto_text_fetched_string] => 0
    [proto_text_fetched_blob] => 0
    [proto_text_fetched_enum] => 0
    [proto_text_fetched_set] => 0
    [proto_text_fetched_geometry] => 0
    [proto_text_fetched_other] => 0
    [proto_binary_fetched_null] => 0
    [proto_binary_fetched_bit] => 0
    [proto_binary_fetched_tinyint] => 0
    [proto_binary_fetched_short] => 0
    [proto_binary_fetched_int24] => 0
    [proto_binary_fetched_int] => 0
    [proto_binary_fetched_bigint] => 0
    [proto_binary_fetched_decimal] => 0
    [proto_binary_fetched_float] => 0
    [proto_binary_fetched_double] => 0
    [proto_binary_fetched_date] => 0
    [proto_binary_fetched_year] => 0
    [proto_binary_fetched_time] => 0
    [proto_binary_fetched_datetime] => 0
    [proto_binary_fetched_timestamp] => 0
    [proto_binary_fetched_string] => 0
    [proto_binary_fetched_blob] => 0
    [proto_binary_fetched_enum] => 0
    [proto_binary_fetched_set] => 0
    [proto_binary_fetched_geometry] => 0
    [proto_binary_fetched_other] => 0
)

参见

  • 统计数据描述


返回一个表述使用的连接类型的字符串

  • ? mysqli::get_connection_stats
  • mysqli::$protocol_version ?
  • PHP Manual
  • MySQLi
  • 返回一个表述使用的连接类型的字符串

mysqli::$host_info

mysqli_get_host_info

(PHP 5, PHP 7)

mysqli::$host_info -- mysqli_get_host_info — 返回一个表述使用的连接类型的字符串

说明

面向对象风格

string $mysqli->host_info;

过程化风格

mysqli_get_host_info ( mysqli $link ) : string

返回一个字符串，描述被link 参数所表述的连接 (包括服务器主机名).

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

一个特征字符串，表述服务器主机名和连接类型.

范例

Example #1 $mysqli->host_info example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print host information */
printf("Host info: %s\n", $mysqli->host_info);

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print host information */
printf("Host info: %s\n", mysqli_get_host_info($link));

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Host info: Localhost via UNIX socket

参见

  • mysqli_get_proto_info() - 返回MySQL使用的协议版本号


返回MySQL使用的协议版本号

  • ? mysqli::$host_info
  • mysqli::$server_info ?
  • PHP Manual
  • MySQLi
  • 返回MySQL使用的协议版本号

mysqli::$protocol_version

mysqli_get_proto_info

(PHP 5, PHP 7)

mysqli::$protocol_version -- mysqli_get_proto_info — 返回MySQL使用的协议版本号

说明

面向对象风格

string $mysqli->protocol_version;

过程化风格

mysqli_get_proto_info ( mysqli $link ) : int

返回一个整数，表述 被link参数所表述的连接 所使用的MySQL协议的版本号.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

返回一个整数来表述协议的版本号.

范例

Example #1 $mysqli->protocol_version example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print protocol version */
printf("Protocol version: %d\n", $mysqli->protocol_version);

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print protocol version */
printf("Protocol version: %d\n", mysqli_get_proto_info($link));

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Protocol version: 10

参见

  • mysqli_get_host_info() - 返回一个表述使用的连接类型的字符串


返回MySQL服务器的版本号

  • ? mysqli::$protocol_version
  • mysqli::$server_version ?
  • PHP Manual
  • MySQLi
  • 返回MySQL服务器的版本号

mysqli::$server_info

mysqli_get_server_info

(PHP 5, PHP 7)

mysqli::$server_info -- mysqli_get_server_info — 返回MySQL服务器的版本号

说明

面向对象风格

string $mysqli->server_info;

过程化风格

mysqli_get_server_info ( mysqli $link ) : string

返回一个字符串，表述MySQLi扩展连接的MySQL服务器的版本号.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

一个特征字符串，表述服务器的版本.

范例

Example #1 $mysqli->server_info example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %s\n", $mysqli->server_info);

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %s\n", mysqli_get_server_info($link));

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Server version: 4.1.2-alpha-debug

参见

  • mysqli_get_client_info() - 获取 MySQL 客户端信息
  • mysqli_get_client_version() - 作为一个整数返回MySQL客户端的版本
  • mysqli_get_server_version() - 作为一个整数返回MySQL服务器的版本


作为一个整数返回MySQL服务器的版本

  • ? mysqli::$server_info
  • mysqli::get_warnings ?
  • PHP Manual
  • MySQLi
  • 作为一个整数返回MySQL服务器的版本

mysqli::$server_version

mysqli_get_server_version

(PHP 5, PHP 7)

mysqli::$server_version -- mysqli_get_server_version — 作为一个整数返回MySQL服务器的版本

说明

面向对象风格

int $mysqli->server_version;

过程化风格

mysqli_get_server_version ( mysqli $link ) : int

mysqli_get_server_version()函数以整数的形式返回被连接的link参数所表述的服务器的版本.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

一个整数表述的服务器版本.

版本号的格式是 main_version * 10000 + minor_version * 100 + sub_version (例如： 版本 4.1.0 是 40100).

范例

Example #1 $mysqli->server_version example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %d\n", $mysqli->server_version);

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %d\n", mysqli_get_server_version($link));

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Server version: 40102

参见

  • mysqli_get_client_info() - 获取 MySQL 客户端信息
  • mysqli_get_client_version() - 作为一个整数返回MySQL客户端的版本
  • mysqli_get_server_info() - 返回MySQL服务器的版本号


Get result of SHOW WARNINGS

  • ? mysqli::$server_version
  • mysqli::$info ?
  • PHP Manual
  • MySQLi
  • Get result of SHOW WARNINGS

mysqli::get_warnings

mysqli_get_warnings

(PHP 5 >= 5.1.0, PHP 7)

mysqli::get_warnings -- mysqli_get_warnings — Get result of SHOW WARNINGS

说明

面向对象风格

public mysqli::get_warnings ( ) : mysqli_warning

过程化风格

mysqli_get_warnings ( mysqli $link ) : mysqli_warning
Warning

本函数还未编写文档，仅有参数列表。


返回最近执行的 SQL 语句的信息

  • ? mysqli::get_warnings
  • mysqli::init ?
  • PHP Manual
  • MySQLi
  • 返回最近执行的 SQL 语句的信息

mysqli::$info

mysqli_info

(PHP 5, PHP 7)

mysqli::$info -- mysqli_info — 返回最近执行的 SQL 语句的信息

说明

面向对象风格

string $mysqli->info;

过程化风格

mysqli_info ( mysqli $link ) : string

mysqli_info() 函数返回一个包含 最近执行的 SQL 语句信息的字符串。 下面有一些参考样例：

mysqli_info 可能的返回值
SQL 语句类型 | 返回结果字符串示例
INSERT INTO...SELECT... | Records: 100 Duplicates: 0 Warnings: 0
INSERT INTO...VALUES (...),(...),(...) | Records: 3 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ... | Records: 1 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE ... | Records: 3 Duplicates: 0 Warnings: 0
UPDATE ... | Rows matched: 40 Changed: 40 Warnings: 0

Note:

如果所执行的 SQL 语句不是上面列出来的这几种类型的， mysqli_info() 函数会返回一个空字符串。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

最近执行的 SQL 语句的相关信息。

范例

Example #1 $mysqli->info 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
$mysqli->query("INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", $mysqli->info);

/* 关闭连接 */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
mysqli_query($link, "INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", mysqli_info($link));

/* 关闭连接 */
mysqli_close($link);
?>

以上例程会输出：

Records: 150  Duplicates: 0  Warnings: 0

参见

  • mysqli_affected_rows() - Gets the number of affected rows in a previous MySQL operation
  • mysqli_warning_count() - Returns the number of warnings from the last query for the given link
  • mysqli_num_rows() - Gets the number of rows in a result


初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数

  • ? mysqli::$info
  • mysqli::$insert_id ?
  • PHP Manual
  • MySQLi
  • 初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数

mysqli::init

mysqli_init

(PHP 5, PHP 7)

mysqli::init -- mysqli_init — 初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数

说明

面向对象风格

mysqli::init ( ) : mysqli

过程化风格

mysqli_init ( ) : mysqli

分配，或者初始化一个 MYSQL 对象，可以作为 mysqli_options() 和 mysqli_real_connect() 函数的传入参数使用。

Note:

在调用 mysqli_real_connect() 函数之前调用其他的 mysqli 函数可能会调用失败。 （mysqli_options() 函数除外）。

返回值

返回一个对象。

范例

参见 mysqli_real_connect().

参见

  • mysqli_options() - 设置选项
  • mysqli_close() - 关闭先前打开的数据库连接
  • mysqli_real_connect() - 建立一个 MySQL 服务器连接
  • mysqli_connect() - 别名 mysqli::__construct


返回最后一条插入语句产生的自增 ID

  • ? mysqli::init
  • mysqli::kill ?
  • PHP Manual
  • MySQLi
  • 返回最后一条插入语句产生的自增 ID

mysqli::$insert_id

mysqli_insert_id

(PHP 5, PHP 7)

mysqli::$insert_id -- mysqli_insert_id — 返回最后一条插入语句产生的自增 ID

说明

面向对象风格

mixed $mysqli->insert_id;

过程化风格

mysqli_insert_id ( mysqli $link ) : mixed

mysqli_insert_id() 函数返回最后一个 SQL 语句（通常是 INSERT 语句） 所操作的表中设置为 AUTO_INCREMENT 的列的值。 如果最后一个 SQL 语句不是 INSERT 或者 UPDATE 语句， 或者所操作的表中没有设置为 AUTO_INCREMENT 的列， 返回值为 0。

Note:

如果在所执行的 INSERT 或者 UPDATE 语句中使用了数据库函数 LAST_INSERT_ID()。 有可能会影响 mysqli_insert_id() 函数的返回值。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

最后一条 SQL（INSERT 或者 UPDATE）所操作的表中设置为 AUTO_INCREMENT 属性的列的值。 如果指定的连接上尚未执行 SQL 语句，或者最后一条 SQL 语句所操作的表中没有设为 AUTO_INCREMENT 的列，返回 0。

Note:

如果返回值超出了 php 允许的最大整数值， mysqli_insert_id() 函数会以字符串形式返回这个值。

范例

Example #1 $mysqli->insert_id 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
$mysqli->query($query);

printf ("New Record has id %d.\n", $mysqli->insert_id);

/* 删除表 */
$mysqli->query("DROP TABLE myCity");

/* 关闭连接 */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
mysqli_query($link, $query);

printf ("New Record has id %d.\n", mysqli_insert_id($link));

/* 删除表 */
mysqli_query($link, "DROP TABLE myCity");

/* 关闭连接 */
mysqli_close($link);
?>

以上例程会输出：

New Record has id 1.


让服务器杀掉一个 MySQL 线程

  • ? mysqli::$insert_id
  • mysqli::more_results ?
  • PHP Manual
  • MySQLi
  • 让服务器杀掉一个 MySQL 线程

mysqli::kill

mysqli_kill

(PHP 5, PHP 7)

mysqli::kill -- mysqli_kill — 让服务器杀掉一个 MySQL 线程

说明

面向对象风格

mysqli::kill ( int $processid ) : bool

过程化风格

mysqli_kill ( mysqli $link , int $processid ) : bool

本函数可以用来让服务器杀掉 processid 参数指定的 线程 ID。数据库连接对应的线程 ID 可以通过 调用 mysqli_thread_id() 函数得到。

如果仅仅想中止某个查询，请使用这个 SQL 语句： KILL QUERY processid。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysqli::kill() 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接是否成功 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* 获得连接对应的线程 ID */
$thread_id = $mysqli->thread_id;

/* 杀掉连接 */
$mysqli->kill($thread_id);

/* 下面的代码应该会发生错误 */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* 关闭连接 */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接是否成功 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* 获得连接对应的线程 ID */
$thread_id = mysqli_thread_id($link);

/* 杀掉连接 */
mysqli_kill($link, $thread_id);

/* 下面的代码应该会发生错误 */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* 关闭连接 */
mysqli_close($link);
?>

以上例程会输出：

Error: MySQL server has gone away

参见

  • mysqli_thread_id() - 返回当前连接的线程 ID


检查批量查询中是否还有查询结果

  • ? mysqli::kill
  • mysqli::multi_query ?
  • PHP Manual
  • MySQLi
  • 检查批量查询中是否还有查询结果

mysqli::more_results

mysqli_more_results

(PHP 5, PHP 7)

mysqli::more_results -- mysqli_more_results — 检查批量查询中是否还有查询结果

说明

面向对象风格

mysqli::more_results ( ) : bool

过程化风格

mysqli_more_results ( mysqli $link ) : bool

检查上一次调用 mysqli_multi_query() 函数之后， 是否还有更多的查询结果集。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

如果上一次调用 mysqli_multi_query() 函数之后， 还有更多的结果集可以读取，返回 true，否则返回 false。

范例

参见 mysqli_multi_query()。

参见

  • mysqli_multi_query() - 执行查询
  • mysqli_next_result() - 为读取 multi_query 执行之后的下一个结果集做准备
  • mysqli_store_result() - 转移上一次查询返回的结果集
  • mysqli_use_result() - Initiate a result set retrieval


执行查询

  • ? mysqli::more_results
  • mysqli::next_result ?
  • PHP Manual
  • MySQLi
  • 执行查询

mysqli::multi_query

mysqli_multi_query

(PHP 5, PHP 7)

mysqli::multi_query -- mysqli_multi_query — 执行查询

说明

面向对象风格

mysqli::multi_query ( string $query ) : bool

过程化风格

mysqli_multi_query ( mysqli $link , string $query ) : bool

执行一个 SQL 语句，或者多个使用分号分隔的 SQL 语句。

要获得执行结果中的第一个结果集，请使用 mysqli_use_result() 或 mysqli_store_result() 函数。 要读取后续的结果集， 请使用 mysqli_more_results() 和 mysqli_next_result() 函数。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

query

查询语句。

查询语句中的数据一定要正确的进行 转义。

返回值

如果第一个 SQL 语句就失败了，返回 false。 如果是批量执行 SQL 语句， 必须首先调用 mysqli_next_result() 函数，才可以获取后续语句的错误信息。

范例

Example #1 mysqli::multi_query() 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* 批量执行查询 */
if ($mysqli->multi_query($query)) {
    do {
        /* store first result set */
        if ($result = $mysqli->store_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->free();
        }
        /* print divider */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* 关闭连接 */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* 批量执行查询 */
if (mysqli_multi_query($link, $query)) {
    do {
        /* store first result set */
        if ($result = mysqli_store_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* 关闭连接 */
mysqli_close($link);
?>

以上例程的输出类似于：

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

参见

  • mysqli_query() - 对数据库执行一次查询
  • mysqli_use_result() - Initiate a result set retrieval
  • mysqli_store_result() - 转移上一次查询返回的结果集
  • mysqli_next_result() - 为读取 multi_query 执行之后的下一个结果集做准备
  • mysqli_more_results() - 检查批量查询中是否还有查询结果


为读取 multi_query 执行之后的下一个结果集做准备

  • ? mysqli::multi_query
  • mysqli::options ?
  • PHP Manual
  • MySQLi
  • 为读取 multi_query 执行之后的下一个结果集做准备

mysqli::next_result

mysqli_next_result

(PHP 5, PHP 7)

mysqli::next_result -- mysqli_next_result — 为读取 multi_query 执行之后的下一个结果集做准备

说明

面向对象风格

mysqli::next_result ( ) : bool

过程化风格

mysqli_next_result ( mysqli $link ) : bool

mysqli_multi_query() 函数执行之后， 为读取下一个结果集做准备， 然后可以使用 mysqli_store_result() 或 mysqli_use_result() 函数读取下一个结果集。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

See mysqli_multi_query().

参见

  • mysqli_multi_query() - 执行查询
  • mysqli_more_results() - 检查批量查询中是否还有查询结果
  • mysqli_store_result() - 转移上一次查询返回的结果集
  • mysqli_use_result() - Initiate a result set retrieval


设置选项

  • ? mysqli::next_result
  • mysqli::ping ?
  • PHP Manual
  • MySQLi
  • 设置选项

mysqli::options

mysqli_options

(PHP 5, PHP 7)

mysqli::options -- mysqli_options — 设置选项

说明

面向对象风格

mysqli::options ( int $option , mixed $value ) : bool

过程化风格

mysqli_options ( mysqli $link , int $option , mixed $value ) : bool

设置一个连接的扩展选项，这些选项可以改变这个连接的行为。

如果要对多个选项进行设置，可以多次调用此函数来。

mysqli_options() 需要在
mysqli_init() 函数之后、
mysqli_real_connect() 函数之前被调用。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

option

要进行设置的选项，可以是下列中的某一项：

有效的选项
名称 | 描述
MYSQLI_OPT_CONNECT_TIMEOUT | 连接超时设置，以秒为单位（在 Windows 平台上，PHP 5.3.1 之后才支持此选项）。
MYSQLI_OPT_LOCAL_INFILE | 启用或禁用 LOAD LOCAL INFILE 语句
MYSQLI_INIT_COMMAND | 成功建立 MySQL 连接之后要执行的 SQL 语句
MYSQLI_READ_DEFAULT_FILE | 从指定的文件中读取选项，而不是使用 my.cnf 中的选项
MYSQLI_READ_DEFAULT_GROUP | 从 my.cnf 或者 MYSQL_READ_DEFAULT_FILE 指定的文件中 读取指定的组中的选项。
MYSQLI_SERVER_PUBLIC_KEY | SHA-256 认证模式下，要使用的 RSA 公钥文件。
MYSQLI_OPT_NET_CMD_BUFFER_SIZE | 内部命令/网络缓冲大小， 仅在 mysqlnd 驱动下有效。
MYSQLI_OPT_NET_READ_BUFFER_SIZE | 以字节为单位，读取 MySQL 命令报文时候的块大小， 仅在 mysqlnd 驱动下有效。
MYSQLI_OPT_INT_AND_FLOAT_NATIVE | 将整数和浮点数类型的列转换成 PHP 的数值类型， 仅在 mysqlnd 驱动下有效。
MYSQLI_OPT_SSL_VERIFY_SERVER_CERT

value

选项值。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.5.0 | 新增 MYSQLI_SERVER_PUBLIC_KEY 和 MYSQLI_SERVER_PUBLIC_KEY 选项。
5.3.0 | 新增 MYSQLI_OPT_INT_AND_FLOAT_NATIVE， MYSQLI_OPT_NET_CMD_BUFFER_SIZE， MYSQLI_OPT_NET_READ_BUFFER_SIZE 和 MYSQLI_OPT_SSL_VERIFY_SERVER_CERT 选项。

范例

参见 mysqli_real_connect()。

注释

Note:

MySQLnd 总是使用服务器的默认字符集。此字符集在连接握手／认证时发送，并被 mysqlnd 使用。

Libmysqlclient 使用 my.cnf 中的默认字符集或者由在调用 mysqli_init() 之后，mysqli_real_connect() 之前先调用 mysqli_options() 来指定。

参见

  • mysqli_init() - 初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数
  • mysqli_real_connect() - 建立一个 MySQL 服务器连接


ping 一个连接，或者如果连接处于断开状态，重新连接

  • ? mysqli::options
  • mysqli::poll ?
  • PHP Manual
  • MySQLi
  • ping 一个连接，或者如果连接处于断开状态，重新连接

mysqli::ping

mysqli_ping

(PHP 5, PHP 7)

mysqli::ping -- mysqli_ping — ping 一个连接，或者如果连接处于断开状态，重新连接

说明

面向对象风格

mysqli::ping ( ) : bool

过程化风格

mysqli_ping ( mysqli $link ) : bool

检查到服务器的连接是否还正常。 在启用 mysqli.reconnect 选项的前提下， 如果连接已经断开， ping 操作会尝试重新建立连接。

Note: mysqlnd 驱动会忽略 php.ini 中的 mysqli.reconnect 选项， 所以它不会自动重连。

客户端建立连接之后，长时间处于闲置状态， 可以用此函数来检查服务器是否关闭了这个连接， 如有必要，将会自动重新建立到服务器的连接。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysqli::ping() 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

/* 检查连接是否还活跃 */
if ($mysqli->ping()) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", $mysqli->error);
}

/* 关闭连接 */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* 检查连接是否还活跃 */
if (mysqli_ping($link)) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", mysqli_error($link));
}

/* 关闭连接 */
mysqli_close($link);
?>

以上例程会输出：

Our connection is ok!


轮询连接

  • ? mysqli::ping
  • mysqli::prepare ?
  • PHP Manual
  • MySQLi
  • 轮询连接

mysqli::poll

mysqli_poll

(PHP 5 >= 5.3.0, PHP 7)

mysqli::poll -- mysqli_poll — 轮询连接

说明

面向对象风格

public static mysqli::poll ( array &$read , array &$error , array &$reject , int $sec , int $usec = 0 ) : int

过程化风格

mysqli_poll ( array &$read , array &$error , array &$reject , int $sec , int $usec = 0 ) : int

轮询连接。 仅可用于 mysqlnd。 此方法是 static 的。

参数

read

要检测是否存在可以读取的结果集的连接的数组。

error

发生错误的，例如：SQL 语句执行失败或者已经断开的 连接的数组。

reject

没有可以读取的结果集的连接 的数组。

sec

秒为单位的最大等待时间，不可以为负数。

usec

微秒为单位的最大等待时间，不可以为负数。

返回值

成功执行则返回存在可以读取结果集的连接数量， 否则 false。

范例

Example #1 A mysqli_poll() 例程

<?php
$link1 = mysqli_connect();
$link1->query("SELECT 'test'", MYSQLI_ASYNC);
$all_links = array($link1);
$processed = 0;
do {
    $links = $errors = $reject = array();
    foreach ($all_links as $link) {
        $links[] = $errors[] = $reject[] = $link;
    }
    if (!mysqli_poll($links, $errors, $reject, 1)) {
        continue;
    }
    foreach ($links as $link) {
        if ($result = $link->reap_async_query()) {
            print_r($result->fetch_row());
            if (is_object($result))
                mysqli_free_result($result);
        } else die(sprintf("MySQLi Error: %s", mysqli_error($link)));
        $processed++;
    }
} while ($processed < count($all_links));
?>

以上例程会输出：

Array
(
    [0] => test
)

参见

  • mysqli_query() - 对数据库执行一次查询
  • mysqli_reap_async_query() - 获取异步查询的结果


准备执行一个 SQL 语句

  • ? mysqli::poll
  • mysqli::query ?
  • PHP Manual
  • MySQLi
  • 准备执行一个 SQL 语句

mysqli::prepare

mysqli_prepare

(PHP 5, PHP 7)

mysqli::prepare -- mysqli_prepare — 准备执行一个 SQL 语句

说明

面向对象风格

mysqli::prepare ( string $query ) : mysqli_stmt

过程化风格

mysqli_prepare ( mysqli $link , string $query ) : mysqli_stmt

做好执行 SQL 语句的准备，返回一个语句句柄，可以对这个句柄进行后续的操作。 这里仅仅支持单一的 SQL 语句，不支持多 SQL 语句。

在执行语句之前，需要使用 mysqli_stmt_bind_param() 函数 对占位符参数进行绑定。 同样，在获取结果之前，必须使用 mysqli_stmt_bind_result() 函数对返回的列值进行绑定。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

query

SQL 语句。

Note:

不需要在语句末尾增加分号（;） 或者 \g 结束符。

SQL 语句中可以包含一个或者多个问号（?） 表示语句的参数。

Note:

SQL 语句中，仅允许在特定的位置出现问号参数占位符。 例如，在 INSERT 语句中的 VALUES() 子句中可以使用参数占位符，来表示对应列的值。 也可以在 WHERE 字句中使用参数来表示 要进行比较的值。

但是，并不是所有的地方都允许使用参数占位符， 例如对于表名、列名这样的 SQL 语句中的标识位置， 就不可以使用参数占位。 SELECT 语句中的列名就不可以使用参数。 另外，对于 = 这样的逻辑比较操作也不可以在两侧都使用参数， 否则服务器在解析 SQL 的时候就不知道该如何检测参数类型了。 也不可以在 NULL 条件中使用问号， 也就是说不可以写成：? IS NULL。 一般而言，参数也只能用在数据操作（DML）语句中， 不可以用在数据定义（DDL）语句中。

返回值

mysqli_prepare() 返回一个 statement 对象，如果发生错误则返回 false。

范例

Example #1 mysqli::prepare() 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* 创建一个预编译 SQL 语句 */
if ($stmt = $mysqli->prepare("SELECT District FROM City WHERE Name=?")) {

    /* 对于参数占位符进行参数值绑定 */
    $stmt->bind_param("s", $city);

    /* 执行查询 */
    $stmt->execute();

    /* 将查询结果绑定到变量 */
    $stmt->bind_result($district);

    /* 获取查询结果值 */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* 关于语句对象 */
    $stmt->close();
}

/* 关闭连接 */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* 创建一个预编译 SQL 语句 */
if ($stmt = mysqli_prepare($link, "SELECT District FROM City WHERE Name=?")) {

    /* 对于参数占位符进行参数值绑定 */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* 执行查询 */
    mysqli_stmt_execute($stmt);

    /* 将查询结果绑定到变量 */
    mysqli_stmt_bind_result($stmt, $district);

    /* 获取查询结果值 */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* 关闭语句句柄 */
    mysqli_stmt_close($stmt);
}

/* 关闭连接 */
mysqli_close($link);
?>

以上例程会输出：

Amersfoort is in district Utrecht

参见

  • mysqli_stmt_execute() - Executes a prepared Query
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • mysqli_stmt_close() - Closes a prepared statement


对数据库执行一次查询

  • ? mysqli::prepare
  • mysqli::real_connect ?
  • PHP Manual
  • MySQLi
  • 对数据库执行一次查询

mysqli::query

mysqli_query

(PHP 5, PHP 7)

mysqli::query -- mysqli_query — 对数据库执行一次查询

说明

面向对象风格

mysqli::query ( string $query , int $resultmode = MYSQLI_STORE_RESULT ) : mixed

过程化风格

mysqli_query ( mysqli $link , string $query , int $resultmode = MYSQLI_STORE_RESULT ) : mixed

Performs a query against the database.

For non-DML queries (not INSERT, UPDATE or DELETE),
this function is similar to calling
mysqli_real_query() followed by either
mysqli_use_result() or
mysqli_store_result().

Note:

In the case where you pass a statement to mysqli_query() that is longer than max_allowed_packet of the server, the returned error codes are different depending on whether you are using MySQL Native Driver (mysqlnd) or MySQL Client Library (libmysqlclient). The behavior is as follows:

  • mysqlnd on Linux returns an error code of 1153. The error message means got a packet bigger than max_allowed_packet bytes.

  • mysqlnd on Windows returns an error code 2006. This error message means server has gone away.

  • libmysqlclient on all platforms returns an error code 2006. This error message means server has gone away.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

query

The query string.

Data inside the query should be properly escaped.

resultmode

Either the constant MYSQLI_USE_RESULT or MYSQLI_STORE_RESULT depending on the desired behavior. By default, MYSQLI_STORE_RESULT is used.

If you use MYSQLI_USE_RESULT all subsequent calls will return error Commands out of sync unless you call mysqli_free_result()

With MYSQLI_ASYNC (available with mysqlnd), it is possible to perform query asynchronously. mysqli_poll() is then used to get results from such queries.

返回值

失败时返回 false，通过mysqli_query() 成功执行SELECT, SHOW, DESCRIBE或 EXPLAIN查询会返回一个mysqli_result 对象，其他查询则返回true。

更新日志

版本 | 说明
5.3.0 | Added the ability of async queries.

范例

Example #1 mysqli::query() example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

/* Create table doesn't return a resultset */
if ($mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Table myCity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = $mysqli->query("SELECT Name FROM City LIMIT 10")) {
    printf("Select returned %d rows.\n", $result->num_rows);

    /* free result set */
    $result->close();
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($result = $mysqli->query("SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Note, that we can't execute any functions which interact with the
       server until result set was closed. All calls will return an
       'out of sync' error */
    if (!$mysqli->query("SET @a:='this will not work'")) {
        printf("Error: %s\n", $mysqli->error);
    }
    $result->close();
}

$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Create table doesn't return a resultset */
if (mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Table myCity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = mysqli_query($link, "SELECT Name FROM City LIMIT 10")) {
    printf("Select returned %d rows.\n", mysqli_num_rows($result));

    /* free result set */
    mysqli_free_result($result);
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($result = mysqli_query($link, "SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Note, that we can't execute any functions which interact with the
       server until result set was closed. All calls will return an
       'out of sync' error */
    if (!mysqli_query($link, "SET @a:='this will not work'")) {
        printf("Error: %s\n", mysqli_error($link));
    }
    mysqli_free_result($result);
}

mysqli_close($link);
?>

以上例程会输出：

Table myCity successfully created.
Select returned 10 rows.
Error: Commands out of sync;  You can't run this command now

参见

  • mysqli_real_query() - 执行一个mysql查询
  • mysqli_multi_query() - 执行查询
  • mysqli_free_result() - Frees the memory associated with a result


建立一个 MySQL 服务器连接

  • ? mysqli::query
  • mysqli::real_escape_string ?
  • PHP Manual
  • MySQLi
  • 建立一个 MySQL 服务器连接

mysqli::real_connect

mysqli_real_connect

(PHP 5, PHP 7)

mysqli::real_connect -- mysqli_real_connect — 建立一个 MySQL 服务器连接

说明

面向对象风格

mysqli::real_connect ( string $host = ? , string $username = ? , string $passwd = ? , string $dbname = ? , int $port = ? , string $socket = ? , int $flags = ? ) : bool

过程化风格

mysqli_real_connect ( mysqli $link , string $host = ? , string $username = ? , string $passwd = ? , string $dbname = ? , int $port = ? , string $socket = ? , int $flags = ? ) : bool

建立一个到 MySQL 服务器的链接。

与 mysqli_connect() 的不同点：

  • mysqli_real_connect() 需要一个有效的对象，这个对象由 mysqli_init() 创建。

  • 可以使用 mysqli_options() 设置各种连接设置。

  • 提供 flags 参数。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

host

可以使用域名、IP 地址。如果传送 null 或者字符串 "localhost" 那么会使用 通道替代 TCP/IP 连接本地服务器。

username

MySQL 登录用户名

passwd

如果设置 null，那么会使用没有密码验证的方式尝试登录。这样可以为一个用户 提供不同的权限，基于他是否提供了密码。

dbname

设置执行查询语句的默认数据库。

port

指定 MySQL 服务器的端口

socket

指定使用的 socket 或者命名通道。

Note:

指定 socket 参数并不能说明要采用何种方式连接数据库。 连接数据的方式由 host 设定。

flags

这里可以设置连接参数：

Supported flags
Name | Description
MYSQLI_CLIENT_COMPRESS | 使用压缩协议
MYSQLI_CLIENT_FOUND_ROWS | 返回语句匹配的行数，而不是影响的行数
MYSQLI_CLIENT_IGNORE_SPACE | 允许函数名称后有空格，这将使所有的函数名称成为保留字。
MYSQLI_CLIENT_INTERACTIVE | 在关闭连接之前允许等待 interactive_timeout 秒， 他替代 wait_timeout 设定。
MYSQLI_CLIENT_SSL | 使用 SSL 加密

Note:

从安全角度考虑，在 PHP 中不可以使用 MULTI_STATEMENT， 若要执行多查询语句，请使用 mysqli_multi_query()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysqli::real_connect() 例子

面向对象风格

<?php

$mysqli = mysqli_init();
if (!$mysqli) {
    die('mysqli_init failed');
}

if (!$mysqli->options(MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
    die('Setting MYSQLI_INIT_COMMAND failed');
}

if (!$mysqli->options(MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
    die('Setting MYSQLI_OPT_CONNECT_TIMEOUT failed');
}

if (!$mysqli->real_connect('localhost', 'my_user', 'my_password', 'my_db')) {
    die('Connect Error (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Success... ' . $mysqli->host_info . "\n";

$mysqli->close();
?>

面向对象风格 when extending mysqli class

<?php

class foo_mysqli extends mysqli {
    public function __construct($host, $user, $pass, $db) {
        parent::init();

        if (!parent::options(MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
            die('Setting MYSQLI_INIT_COMMAND failed');
        }

        if (!parent::options(MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
            die('Setting MYSQLI_OPT_CONNECT_TIMEOUT failed');
        }

        if (!parent::real_connect($host, $user, $pass, $db)) {
            die('Connect Error (' . mysqli_connect_errno() . ') '
                    . mysqli_connect_error());
        }
    }
}

$db = new foo_mysqli('localhost', 'my_user', 'my_password', 'my_db');

echo 'Success... ' . $db->host_info . "\n";

$db->close();
?>

过程化风格

<?php

$link = mysqli_init();
if (!$link) {
    die('mysqli_init failed');
}

if (!mysqli_options($link, MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
    die('Setting MYSQLI_INIT_COMMAND failed');
}

if (!mysqli_options($link, MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
    die('Setting MYSQLI_OPT_CONNECT_TIMEOUT failed');
}

if (!mysqli_real_connect($link, 'localhost', 'my_user', 'my_password', 'my_db')) {
    die('Connect Error (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Success... ' . mysqli_get_host_info($link) . "\n";

mysqli_close($link);
?>

以上例程会输出：

Success... MySQL host info: localhost via TCP/IP

注释

Note:

MySQLnd 总是使用服务器的默认字符集。此字符集在连接握手／认证时发送，并被 mysqlnd 使用。

Libmysqlclient 使用 my.cnf 中的默认字符集或者由在调用 mysqli_init() 之后，mysqli_real_connect() 之前先调用 mysqli_options() 来指定。

参见

  • mysqli_connect() - 别名 mysqli::__construct
  • mysqli_init() - 初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数
  • mysqli_options() - 设置选项
  • mysqli_ssl_set() - 使用 SSL 建立到数据库之间的安全连接
  • mysqli_close() - 关闭先前打开的数据库连接


根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义

  • ? mysqli::real_connect
  • mysqli::real_query ?
  • PHP Manual
  • MySQLi
  • 根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义

mysqli::real_escape_string

mysqli::escape_string

mysqli_real_escape_string

(PHP 5, PHP 7)

mysqli::real_escape_string -- mysqli::escape_string -- mysqli_real_escape_string — 根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义

说明

面向对象风格

mysqli::escape_string ( string $escapestr ) : string
mysqli::real_escape_string ( string $escapestr ) : string

过程化风格

mysqli_real_escape_string ( mysqli $link , string $escapestr ) : string

此函数用来对字符串中的特殊字符进行转义， 以使得这个字符串是一个合法的 SQL 语句。 传入的字符串会根据当前连接的字符集进行转义，得到一个编码后的合法的 SQL 语句。

Caution

安全：默认字符集

在调用 mysqli_real_escape_string() 函数之前， 必须先通过调用 mysqli_set_charset() 函数或者在 MySQL 服务器端设置字符集。 更多信息请参考 字符集。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

escapestr

需要进行转义的字符串。

会被进行转义的字符包括： NUL （ASCII 0），\n，\r，\，'，" 和 Control-Z.

返回值

转义后的字符串。

错误／异常

在无效的连接上调用此函数会返回 null 并发出一个 E_WARNING 级别的错误。

范例

Example #1 mysqli::real_escape_string() 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City");

$city = "'s Hertogenbosch";

/* 由于未对 $city 进行转义，此次查询会失败 */
if (!$mysqli->query("INSERT into myCity (Name) VALUES ('$city')")) {
    printf("Error: %s\n", $mysqli->sqlstate);
}

$city = $mysqli->real_escape_string($city);

/* 对 $city 进行转义之后，查询可以正常执行 */
if ($mysqli->query("INSERT into myCity (Name) VALUES ('$city')")) {
    printf("%d Row inserted.\n", $mysqli->affected_rows);
}

$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City");

$city = "'s Hertogenbosch";

/* 由于未对 $city 进行转义，此次查询会失败 */
if (!mysqli_query($link, "INSERT into myCity (Name) VALUES ('$city')")) {
    printf("Error: %s\n", mysqli_sqlstate($link));
}

$city = mysqli_real_escape_string($link, $city);

/* 对 $city 进行转义之后，查询可以正常执行 */
if (mysqli_query($link, "INSERT into myCity (Name) VALUES ('$city')")) {
    printf("%d Row inserted.\n", mysqli_affected_rows($link));
}

mysqli_close($link);
?>

以上例程会输出：

Error: 42000
1 Row inserted.

注释

Note:

如果你之前都是使用 mysql_real_escape_string() 函数来转义 SQL 语句的，
那么需要注意的是 mysqli_real_escape_string() 和
mysql_real_escape_string() 两个函数的参数顺序不同。
mysqli_real_escape_string() 中，
link 是第一个参数，
而在 mysql_real_escape_string() 函数中，要转义的字符串是第一个参数。

参见

  • mysqli_set_charset() - 设置默认字符编码
  • mysqli_character_set_name() - 返回当前数据库连接的默认字符编码


执行一个mysql查询

  • ? mysqli::real_escape_string
  • mysqli::reap_async_query ?
  • PHP Manual
  • MySQLi
  • 执行一个mysql查询

mysqli::real_query

mysqli_real_query

(PHP 5, PHP 7)

mysqli::real_query -- mysqli_real_query — 执行一个mysql查询

说明

面向对象风格

mysqli::real_query ( string $query ) : bool

过程化风格

mysqli_real_query ( mysqli $link , string $query ) : bool

执行一个单条数据库查询, 其结果可以使用mysqli_store_result()或mysqli_use_result()检索或存储.

为了确定给定的查询是否真的返回一个结果集, 可以查看mysqli_field_count().

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

query

查询字符串

查询中的数据可以进行属性转义.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mysqli_query() - 对数据库执行一次查询
  • mysqli_store_result() - 转移上一次查询返回的结果集
  • mysqli_use_result() - Initiate a result set retrieval


获取异步查询的结果

  • ? mysqli::real_query
  • mysqli::refresh ?
  • PHP Manual
  • MySQLi
  • 获取异步查询的结果

mysqli::reap_async_query

mysqli_reap_async_query

(PHP 5 >= 5.3.0, PHP 7)

mysqli::reap_async_query -- mysqli_reap_async_query — 获取异步查询的结果

说明

面向对象风格

public mysqli::reap_async_query ( ) : mysqli_result

过程化风格

mysqli_reap_async_query ( mysqli $link ) : mysqli_result

获取异步查询的结果， 仅可用于 mysqlnd。。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

如果成功则返回 mysqli_result，否则返回 false。

参见

  • mysqli_poll() - 轮询连接


刷新

  • ? mysqli::reap_async_query
  • mysqli::release_savepoint ?
  • PHP Manual
  • MySQLi
  • 刷新

mysqli::refresh

mysqli_refresh

(PHP 5 >= 5.3.0, PHP 7)

mysqli::refresh -- mysqli_refresh — 刷新

说明

面向对象风格

public mysqli::refresh ( int $options ) : bool

过程化风格

mysqli_refresh ( resource $link , int $options ) : bool

刷新表或者缓存，或者重置主从服务器信息。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

options

使用 MySQLi 常量 中的 MYSQLI_REFRESH_* 常量作为刷新选项。

参见 MySQL 官方文档： » MySQL Refresh

返回值

成功返回 true，否则返回 false。

参见

  • mysqli_poll() - 轮询连接


从当前事务的保存点中移除一个命名保存点

  • ? mysqli::refresh
  • mysqli::rollback ?
  • PHP Manual
  • MySQLi
  • 从当前事务的保存点中移除一个命名保存点

mysqli::release_savepoint

mysqli_release_savepoint

(PHP 5 >= 5.5.0, PHP 7)

mysqli::release_savepoint -- mysqli_release_savepoint — 从当前事务的保存点中移除一个命名保存点

说明

面向对象风格 (method):

public mysqli::release_savepoint ( string $name ) : bool

过程化风格:

mysqli_release_savepoint ( mysqli $link , string $name ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

name

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mysqli_rollback() - 回退当前事务


回退当前事务

  • ? mysqli::release_savepoint
  • mysqli::savepoint ?
  • PHP Manual
  • MySQLi
  • 回退当前事务

mysqli::rollback

mysqli_rollback

(PHP 5, PHP 7)

mysqli::rollback -- mysqli_rollback — 回退当前事务

说明

面向对象风格

mysqli::rollback ( ) : bool

过程化风格

mysqli_rollback ( mysqli $link ) : bool

回退当前数据库的事务。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysqli::rollback() example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* disable autocommit */
$mysqli->autocommit(FALSE);

$mysqli->query("CREATE TABLE myCity LIKE City");
$mysqli->query("ALTER TABLE myCity Type=InnoDB");
$mysqli->query("INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* commit insert */
$mysqli->commit();

/* delete all rows */
$mysqli->query("DELETE FROM myCity");

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity.\n", $row[0]);
    /* Free result */
    $result->close();
}

/* Rollback */
$mysqli->rollback();

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Free result */
    $result->close();
}

/* Drop table myCity */
$mysqli->query("DROP TABLE myCity");

$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* disable autocommit */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE myCity LIKE City");
mysqli_query($link, "ALTER TABLE myCity Type=InnoDB");
mysqli_query($link, "INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* commit insert */
mysqli_commit($link);

/* delete all rows */
mysqli_query($link, "DELETE FROM myCity");

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity.\n", $row[0]);
    /* Free result */
    mysqli_free_result($result);
}

/* Rollback */
mysqli_rollback($link);

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Free result */
    mysqli_free_result($result);
}

/* Drop table myCity */
mysqli_query($link, "DROP TABLE myCity");

mysqli_close($link);
?>

以上例程会输出：

0 rows in table myCity.
50 rows in table myCity (after rollback).

参见

  • mysqli_commit() - 提交一个事务
  • mysqli_autocommit() - 打开或关闭本次数据库连接的自动命令提交事务模式


在当前事务中增加一个命名保存点

  • ? mysqli::rollback
  • mysqli::select_db ?
  • PHP Manual
  • MySQLi
  • 在当前事务中增加一个命名保存点

mysqli::savepoint

mysqli_savepoint

(PHP 5 >= 5.5.0, PHP 7)

mysqli::savepoint -- mysqli_savepoint — 在当前事务中增加一个命名保存点

说明

面向对象风格 (method):

public mysqli::savepoint ( string $name ) : bool

过程化风格:

mysqli_savepoint ( mysqli $link , string $name ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

name

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mysqli_commit() - 提交一个事务


选择用于数据库查询的默认数据库

  • ? mysqli::savepoint
  • mysqli::set_charset ?
  • PHP Manual
  • MySQLi
  • 选择用于数据库查询的默认数据库

mysqli::select_db

mysqli_select_db

(PHP 5, PHP 7)

mysqli::select_db -- mysqli_select_db — 选择用于数据库查询的默认数据库

说明

面向对象风格

mysqli::select_db ( string $dbname ) : bool

过程化风格

mysqli_select_db ( mysqli $link , string $dbname ) : bool

针对本次数据库连接用于数据库查询的默认数据库。

Note:

本函数应该只被用在改变本次链接的数据库，你也能在mysqli_connect()第四个参数确认默认数据库。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

dbname

数据库名称

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysqli::select_db() example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* return name of current default database */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

/* change db to world db */
$mysqli->select_db("world");

/* return name of current default database */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* return name of current default database */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

/* change db to world db */
mysqli_select_db($link, "world");

/* return name of current default database */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

mysqli_close($link);
?>

以上例程会输出：

Default database is test.
Default database is world.

参见

  • mysqli_connect() - 别名 mysqli::__construct
  • mysqli_real_connect() - 建立一个 MySQL 服务器连接


设置默认字符编码

  • ? mysqli::select_db
  • mysqli::$sqlstate ?
  • PHP Manual
  • MySQLi
  • 设置默认字符编码

mysqli::set_charset

mysqli_set_charset

(PHP 5 >= 5.0.5, PHP 7)

mysqli::set_charset -- mysqli_set_charset — 设置默认字符编码

说明

面向对象风格

mysqli::set_charset ( string $charset ) : bool

过程化风格

mysqli_set_charset ( mysqli $link , string $charset ) : bool

设置在数据库间传输字符时所用的默认字符编码。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

charset

被设为默认的字符编码名。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

如果在Windows平台上使用该方法，需要4.1.11版或以上的MySQL客户端库，且MySQL版本为5.0.6以上。

Note:

这应该是首选的用于改变字符编码的方法，不建议使用mysqli_query()执行SQL请求的SET NAMES ...（如 SET NAMES utf8）。 详见MySQL字符集的概念

范例

Example #1 mysqli::set_charset() example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* change character set to utf8 */
if (!$mysqli->set_charset("utf8")) {
    printf("Error loading character set utf8: %s\n", $mysqli->error);
} else {
    printf("Current character set: %s\n", $mysqli->character_set_name());
}

$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'test');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* change character set to utf8 */
if (!mysqli_set_charset($link, "utf8")) {
    printf("Error loading character set utf8: %s\n", mysqli_error($link));
} else {
    printf("Current character set: %s\n", mysqli_character_set_name($link));
}

mysqli_close($link);
?>

以上例程会输出：

Current character set: utf8

参见

  • mysqli_character_set_name() - 返回当前数据库连接的默认字符编码
  • mysqli_real_escape_string() - 根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义
  • » 关于MySQL支持字符集的列表


返回上一次 SQL 操作的 SQLSTATE 错误信息

  • ? mysqli::set_charset
  • mysqli::ssl_set ?
  • PHP Manual
  • MySQLi
  • 返回上一次 SQL 操作的 SQLSTATE 错误信息

mysqli::$sqlstate

mysqli_sqlstate

(PHP 5, PHP 7)

mysqli::$sqlstate -- mysqli_sqlstate — 返回上一次 SQL 操作的 SQLSTATE 错误信息

说明

面向对象风格

string $mysqli->sqlstate;

过程化风格

mysqli_sqlstate ( mysqli $link ) : string

返回一个包含 SQLSTATE 错误码的字符串，表示上一次 SQL 操作的错误。 错误码是由 5 个字符构成，'00000' 表示没有发生错误。 错误码是由 ANSI SQL 和 ODBC 定义的， 详细的清单请参见：» http://dev.mysql.com/doc/mysql/en/error-handling.html。

Note:

需要注意的是，并不是所有的 MySQL 错误都映射到 SQLSTATE 了， 未映射的错误消息使用 HY000（综合错误）表示。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

返回一个包含 SQLSTATE 错误码的字符串，表示上一次 SQL 操作的错误。 错误码是由 5 个字符构成，'00000' 表示没有发生错误。

范例

Example #1 $mysqli->sqlstate 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* City 表已经存在，所以我们会遇到一个错误 */
if (!$mysqli->query("CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", $mysqli->sqlstate);
}

$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* City 表已经存在，所以我们会遇到一个错误 */
if (!mysqli_query($link, "CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", mysqli_sqlstate($link));
}

mysqli_close($link);
?>

以上例程会输出：

Error - SQLSTATE 42S01.

参见

  • mysqli_errno() - 返回最近函数调用的错误代码
  • mysqli_error() - Returns a string description of the last error


使用 SSL 建立到数据库之间的安全连接

  • ? mysqli::$sqlstate
  • mysqli::stat ?
  • PHP Manual
  • MySQLi
  • 使用 SSL 建立到数据库之间的安全连接

mysqli::ssl_set

mysqli_ssl_set

(PHP 5, PHP 7)

mysqli::ssl_set -- mysqli_ssl_set — 使用 SSL 建立到数据库之间的安全连接

说明

面向对象风格

mysqli::ssl_set ( string $key , string $cert , string $ca , string $capath , string $cipher ) : bool

过程化风格

mysqli_ssl_set ( mysqli $link , string $key , string $cert , string $ca , string $capath , string $cipher ) : bool

使用 SSL 建立到数据库之间的安全连接， 必须在调用 mysqli_real_connect() 函数之前调用此函数。 除非启用 OpenSSL 支持，否则此函数无任何作用。

需要注意的是，在 PHP 5.3.3 之前的版本中， MySQL 原生驱动不支持建立 SSL 连接， 所以，在使用 MySQL 原生驱动的时候，调用此函数会产生错误。 从 PHP 5.3 开始，在 Windows 平台上，默认是启用 MySQL 原生驱动的。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

key

密钥文件的路径

cert

证书文件的路径

ca

签发机构的证书文件路径

capath

指向一个目录的路径， 该目录下存放的是受信任的 CA 机构证书 PEM 格式的文件。

cipher

SSL 加密允许使用的算法清单

任何未使用的 SSL 参数，可以设置为 null。

返回值

此函数永远会返回 true。 如果 SSL 的设置有误，那么在调用 mysqli_real_connect() 函数建立连接的时候才会报错。

参见

  • mysqli_options() - 设置选项
  • mysqli_real_connect() - 建立一个 MySQL 服务器连接


获取当前系统状态信息

  • ? mysqli::ssl_set
  • mysqli::stmt_init ?
  • PHP Manual
  • MySQLi
  • 获取当前系统状态信息

mysqli::stat

mysqli_stat

(PHP 5, PHP 7)

mysqli::stat -- mysqli_stat — 获取当前系统状态信息

说明

面向对象风格

mysqli::stat ( ) : string

过程化风格

mysqli_stat ( mysqli $link ) : string

mysqli_stat() 函数返回一个表示系统状态信息的字符串， 字符串中的内容和 'mysqladmin status' 命令的输出结果类似， 包含以秒为单位的运行时间、运行中的线程数、问题数、重新加载数以及打开的表数量等信息。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

成功则返回表示系统状态信息的字符串，失败则返回 false。

范例

Example #1 mysqli::stat() 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf ("System status: %s\n", $mysqli->stat());

$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("System status: %s\n", mysqli_stat($link));

mysqli_close($link);
?>

以上例程会输出：

System status: Uptime: 272  Threads: 1  Questions: 5340  Slow queries: 0
Opens: 13  Flush tables: 1  Open tables: 0  Queries per second avg: 19.632
Memory in use: 8496K  Max memory used: 8560K

参见

  • mysqli_get_server_info() - 返回MySQL服务器的版本号


初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象

  • ? mysqli::stat
  • mysqli::store_result ?
  • PHP Manual
  • MySQLi
  • 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象

mysqli::stmt_init

mysqli_stmt_init

(PHP 5, PHP 7)

mysqli::stmt_init -- mysqli_stmt_init — 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象

说明

面向对象风格

mysqli::stmt_init ( ) : mysqli_stmt

过程化风格

mysqli_stmt_init ( mysqli $link ) : mysqli_stmt

分配并初始化一个语句对象用于mysqli_stmt_prepare().

Note:

任何其后调用的mysqli_stmt函数都会失败直到mysqli_stmt_prepare()被调用.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

Returns an object.

参见

  • mysqli_stmt_prepare() - Prepare an SQL statement for execution


转移上一次查询返回的结果集

  • ? mysqli::stmt_init
  • mysqli::$thread_id ?
  • PHP Manual
  • MySQLi
  • 转移上一次查询返回的结果集

mysqli::store_result

mysqli_store_result

(PHP 5, PHP 7)

mysqli::store_result -- mysqli_store_result — 转移上一次查询返回的结果集

说明

面向对象风格

mysqli::store_result ( int $option = ? ) : mysqli_result

过程化风格

mysqli_store_result ( mysqli $link , int $option = ? ) : mysqli_result

迁移 link 参数所指定的连接上的上一次查询返回的结果集， 迁移之后的结果集可以 在 mysqli_data_seek() 函数中使用。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

option

指定的选项，可以是下列中的某一值：

Valid options
Name | Description
MYSQLI_STORE_RESULT_COPY_DATA | 将结果集从 mysqlnd 的内部缓冲区复制到 PHP 变量中。 默认情况下，mysqlnd 采取一种引用策略尽量避免在内容中复制多份同样的结果集。 例如，对于一个包含了很多行的结果集，每个行中的内容又不是很大，那么复制结果集的过程会导致内存使用率下降， 因为用来保存结果集数据的 PHP 变量可能提前被释放掉。 （此选项仅在使用 mysqlnd 驱动且 PHP 5.6.0 之后可用）。

返回值

成功则返回一个缓冲的结果集对象，失败则返回 false。

Note:

如果上一查询并不产生结果集（例如，执行了一个 INSERT 语句）， 那么 mysqli_store_result() 会返回 false。 如果读取结果集失败了，也会返回 false。 如何区分是上面哪种情况导致此函数的调用返回了 false？ 你可以通过下面的方法来检测： mysqli_error() 返回了非空的字符串， mysqli_errno() 返回了非零值， 或者 mysqli_field_count() 返回了非零值， 都表示发生错误了。 还有一种可能的情况会导致此函数的调用返回 false：上一次查询 mysqli_query() 本身是成功的， 但是由于返回的结果集太大，无法为其分配足够的内存来进行结果集转移。 如果 mysqli_field_count() 函数返回了一个非零值，那么表示 SQL 语句产生了一个非空的结果集。

注释

Note:

执行查询之后， 使用 mysqli_free_result() 函数来释放结果集所占用的内存， 是一个很有用的实战经验。 尤其是当使用 mysqli_store_result() 函数来转移数量较大的结果集的时候， 释放结果集内存的操作尤为重要。

范例

See mysqli_multi_query().

参见

  • mysqli_real_query() - 执行一个mysql查询
  • mysqli_use_result() - Initiate a result set retrieval


返回当前连接的线程 ID

  • ? mysqli::store_result
  • mysqli::thread_safe ?
  • PHP Manual
  • MySQLi
  • 返回当前连接的线程 ID

mysqli::$thread_id

mysqli_thread_id

(PHP 5, PHP 7)

mysqli::$thread_id -- mysqli_thread_id — 返回当前连接的线程 ID

说明

面向对象风格

int $mysqli->thread_id;

过程化风格

mysqli_thread_id ( mysqli $link ) : int

mysqli_thread_id() 函数返回当前连接的线程 ID， 这个线程 ID 可以在 mysqli_kill() 函数中使用。 如果 PHP 到数据库的连接中断了， 然后使用 mysqli_ping() 函数重新建立连接的话， 新的连接的线程 ID 会发生改变。所以，仅在需要的时候，调用本函数获取连接的线程 ID。

Note:

线程 ID 是每次连接都重新分配的，也就是说它和连接是紧密相关的， 如果某个连接异常断开了，然后重新建立了到数据库的连接， 这个线程 ID 就不再是原来的那个了，它会发生变化。

可以通过执行 SQL 语句：KILL QUERY processid 来杀掉对应连接上正在执行的 SQL 语句。

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

返回当前连接的线程 ID

范例

Example #1 $mysqli->thread_id 例程

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* 检查连接是否成功 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* 获取连接的线程 ID */
$thread_id = $mysqli->thread_id;

/* 杀掉这个连接 */
$mysqli->kill($thread_id);

/* 这句代码应该会报错 */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* 关闭连接 */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* 检查连接是否成功 */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* 获取连接的线程 ID */
$thread_id = mysqli_thread_id($link);

/* 杀掉这个连接 */
mysqli_kill($link, $thread_id);

/* 这句代码应该会报错 */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Error: MySQL server has gone away

参见

  • mysqli_kill() - 让服务器杀掉一个 MySQL 线程


返回是否是线程安全的

  • ? mysqli::$thread_id
  • mysqli::use_result ?
  • PHP Manual
  • MySQLi
  • 返回是否是线程安全的

mysqli::thread_safe

mysqli_thread_safe

(PHP 5, PHP 7)

mysqli::thread_safe -- mysqli_thread_safe — 返回是否是线程安全的

说明

过程化风格

mysqli_thread_safe ( ) : bool

告知本数据库客户端库是否编译为线程安全的。 Tells whether the client library is compiled as thread-safe.

返回值

如果是的话，返回true，否则返回false。


Initiate a result set retrieval

  • ? mysqli::thread_safe
  • mysqli::$warning_count ?
  • PHP Manual
  • MySQLi
  • Initiate a result set retrieval

mysqli::use_result

mysqli_use_result

(PHP 5, PHP 7)

mysqli::use_result -- mysqli_use_result — Initiate a result set retrieval

说明

面向对象风格

public mysqli::use_result ( ) : mysqli_result

过程化风格

mysqli_use_result ( mysqli $link ) : mysqli_result

Used to initiate the retrieval of a result set from the last query executed using the mysqli_real_query() function on the database connection.

Either this or the mysqli_store_result() function must be called before the results of a query can be retrieved, and one or the other must be called to prevent the next query on that database connection from failing.

Note:

The mysqli_use_result() function does not transfer the entire result set from the database and hence cannot be used functions such as mysqli_data_seek() to move to a particular row within the set. To use this functionality, the result set must be stored using mysqli_store_result(). One should not use mysqli_use_result() if a lot of processing on the client side is performed, since this will tie up the server and prevent other threads from updating any tables from which the data is being fetched.

返回值

Returns an unbuffered result object or false if an error occurred.

范例

Example #1 mysqli::use_result() example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if ($mysqli->multi_query($query)) {
    do {
        /* store first result set */
        if ($result = $mysqli->use_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->close();
        }
        /* print divider */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if (mysqli_multi_query($link, $query)) {
    do {
        /* store first result set */
        if ($result = mysqli_use_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

参见

  • mysqli_real_query() - 执行一个mysql查询
  • mysqli_store_result() - 转移上一次查询返回的结果集


Returns the number of warnings from the last query for the given link

  • ? mysqli::use_result
  • MySQLi_STMT ?
  • PHP Manual
  • MySQLi
  • Returns the number of warnings from the last query for the given link

mysqli::$warning_count

mysqli_warning_count

(PHP 5, PHP 7)

mysqli::$warning_count -- mysqli_warning_count — Returns the number of warnings from the last query for the given link

说明

面向对象风格

int $mysqli->warning_count;

过程化风格

mysqli_warning_count ( mysqli $link ) : int

Returns the number of warnings from the last query in the connection.

Note:

For retrieving warning messages you can use the SQL command SHOW WARNINGS [limit row_count].

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

返回值

Number of warnings or zero if there are no warnings.

范例

Example #1 $mysqli->warning_count example

面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* a remarkable city in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

$mysqli->query($query);

if ($mysqli->warning_count) {
    if ($result = $mysqli->query("SHOW WARNINGS")) {
        $row = $result->fetch_row();
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        $result->close();
    }
}

/* close connection */
$mysqli->close();
?>

过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* a remarkable long city name in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

mysqli_query($link, $query);

if (mysqli_warning_count($link)) {
    if ($result = mysqli_query($link, "SHOW WARNINGS")) {
        $row = mysqli_fetch_row($result);
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        mysqli_free_result($result);
    }
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Warning (1264): Data truncated for column 'Name' at row 1

参见

  • mysqli_errno() - 返回最近函数调用的错误代码
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - 返回上一次 SQL 操作的 SQLSTATE 错误信息


MySQLi_STMT类

(PHP 5, PHP 7)

简介

代表一个预编译 SQL 语句。

类摘要

mysqli_stmt {
/* 属性 */
int $affected_rows;
int $errno;
array $error_list;
string $error;
int $field_count;
int $insert_id;
int $num_rows;
int $param_count;
string $sqlstate;
/* 方法 */
mysqli_stmt_affected_rows ( mysqli_stmt $stmt ) : int
public attr_get ( int $attr ) : int
public attr_set ( int $attr , int $mode ) : bool
public bind_param ( string $types , mixed &$var , mixed &...$vars ) : bool
public bind_result ( mixed &$var , mixed &...$vars ) : bool
public close ( ) : bool
public data_seek ( int $offset ) : void
mysqli_stmt_errno ( mysqli_stmt $stmt ) : int
mysqli_stmt_error_list ( mysqli_stmt $stmt ) : array
mysqli_stmt_error ( mysqli_stmt $stmt ) : string
public execute ( ) : bool
public fetch ( ) : bool
mysqli_stmt_field_count ( mysqli_stmt $stmt ) : int
public free_result ( ) : void
public get_result ( ) : mysqli_result
public get_warnings ( ) : object
mysqli_stmt_insert_id ( mysqli_stmt $stmt ) : mixed
public more_results ( ) : bool
public next_result ( ) : bool
public num_rows ( ) : int
mysqli_stmt_param_count ( mysqli_stmt $stmt ) : int
public prepare ( string $query ) : mixed
public reset ( ) : bool
public result_metadata ( ) : mysqli_result
public send_long_data ( int $param_nr , string $data ) : bool
mysqli_stmt_sqlstate ( mysqli_stmt $stmt ) : string
public store_result ( ) : bool
}

Table of Contents

  • mysqli_stmt::$affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement
  • mysqli_stmt::attr_get — Used to get the current value of a statement attribute
  • mysqli_stmt::attr_set — Used to modify the behavior of a prepared statement
  • mysqli_stmt::bind_param — Binds variables to a prepared statement as parameters
  • mysqli_stmt::bind_result — Binds variables to a prepared statement for result storage
  • mysqli_stmt::close — Closes a prepared statement
  • mysqli_stmt::__construct — Constructs a new mysqli_stmt object
  • mysqli_stmt::data_seek — Seeks to an arbitrary row in statement result set
  • mysqli_stmt::$errno — Returns the error code for the most recent statement call
  • mysqli_stmt::$error_list — Returns a list of errors from the last statement executed
  • mysqli_stmt::$error — Returns a string description for last statement error
  • mysqli_stmt::execute — Executes a prepared Query
  • mysqli_stmt::fetch — Fetch results from a prepared statement into the bound variables
  • mysqli_stmt::$field_count — Returns the number of columns in the given statement
  • mysqli_stmt::free_result — Frees stored result memory for the given statement handle
  • mysqli_stmt::get_result — Gets a result set from a prepared statement
  • mysqli_stmt::get_warnings — Get result of SHOW WARNINGS
  • mysqli_stmt::$insert_id — Get the ID generated from the previous INSERT operation
  • mysqli_stmt::more_results — Check if there are more query results from a multiple query
  • mysqli_stmt::next_result — Reads the next result from a multiple query
  • mysqli_stmt::$num_rows — Return the number of rows in statements result set
  • mysqli_stmt::$param_count — Returns the number of parameters for the given statement
  • mysqli_stmt::prepare — Prepare an SQL statement for execution
  • mysqli_stmt::reset — Resets a prepared statement
  • mysqli_stmt::result_metadata — Returns result set metadata from a prepared statement
  • mysqli_stmt::send_long_data — Send data in blocks
  • mysqli_stmt::$sqlstate — Returns SQLSTATE error from previous statement operation
  • mysqli_stmt::store_result — Transfers a result set from a prepared statement


Returns the total number of rows changed, deleted, or inserted by the last executed statement

  • ? MySQLi_STMT
  • mysqli_stmt::attr_get ?
  • PHP Manual
  • MySQLi_STMT
  • Returns the total number of rows changed, deleted, or inserted by the last executed statement

mysqli_stmt::$affected_rows

mysqli_stmt_affected_rows

(PHP 5, PHP 7)

mysqli_stmt::$affected_rows -- mysqli_stmt_affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement

说明

面向对象风格

int $mysqli_stmt->affected_rows;

过程化风格

mysqli_stmt_affected_rows ( mysqli_stmt $stmt ) : int

Returns the number of rows affected by INSERT, UPDATE, or DELETE query.

This function only works with queries which update a table. In order to get the number of rows from a SELECT query, use mysqli_stmt_num_rows() instead.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE/DELETE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query has returned an error. NULL indicates an invalid argument was supplied to the function.

Note:

If the number of affected rows is greater than maximal PHP int value, the number of affected rows will be returned as a string value.

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* create temp table */
$mysqli->query("CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* prepare statement */
if ($stmt = $mysqli->prepare($query)) {

    /* Bind variable for placeholder */
    $code = 'A%';
    $stmt->bind_param("s", $code);

    /* execute statement */
    $stmt->execute();

    printf("rows inserted: %d\n", $stmt->affected_rows);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* create temp table */
mysqli_query($link, "CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* prepare statement */
if ($stmt = mysqli_prepare($link, $query)) {

    /* Bind variable for placeholder */
    $code = 'A%';
    mysqli_stmt_bind_param($stmt, "s", $code);

    /* execute statement */
    mysqli_stmt_execute($stmt);

    printf("rows inserted: %d\n", mysqli_stmt_affected_rows($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

rows inserted: 17

参见

  • mysqli_stmt_num_rows() - Return the number of rows in statements result set
  • mysqli_prepare() - 准备执行一个 SQL 语句


Used to get the current value of a statement attribute

  • ? mysqli_stmt::$affected_rows
  • mysqli_stmt::attr_set ?
  • PHP Manual
  • MySQLi_STMT
  • Used to get the current value of a statement attribute

mysqli_stmt::attr_get

mysqli_stmt_attr_get

(PHP 5, PHP 7)

mysqli_stmt::attr_get -- mysqli_stmt_attr_get — Used to get the current value of a statement attribute

说明

面向对象风格

public mysqli_stmt::attr_get ( int $attr ) : int

过程化风格

mysqli_stmt_attr_get ( mysqli_stmt $stmt , int $attr ) : int

Gets the current value of a statement attribute.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

attr

The attribute that you want to get.

返回值

Returns false if the attribute is not found, otherwise returns the value of the attribute.


Used to modify the behavior of a prepared statement

  • ? mysqli_stmt::attr_get
  • mysqli_stmt::bind_param ?
  • PHP Manual
  • MySQLi_STMT
  • Used to modify the behavior of a prepared statement

mysqli_stmt::attr_set

mysqli_stmt_attr_set

(PHP 5, PHP 7)

mysqli_stmt::attr_set -- mysqli_stmt_attr_set — Used to modify the behavior of a prepared statement

说明

面向对象风格

public mysqli_stmt::attr_set ( int $attr , int $mode ) : bool

过程化风格

mysqli_stmt_attr_set ( mysqli_stmt $stmt , int $attr , int $mode ) : bool

Used to modify the behavior of a prepared statement. This function may be called multiple times to set several attributes.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

attr

The attribute that you want to set. It can have one of the following values:

Attribute values
Character | Description
MYSQLI_STMT_ATTR_UPDATE_MAX_LENGTH | Setting to true causes mysqli_stmt_store_result() to update the metadata MYSQL_FIELD->max_length value.
MYSQLI_STMT_ATTR_CURSOR_TYPE | Type of cursor to open for statement when mysqli_stmt_execute() is invoked. mode can be MYSQLI_CURSOR_TYPE_NO_CURSOR (the default) or MYSQLI_CURSOR_TYPE_READ_ONLY.
MYSQLI_STMT_ATTR_PREFETCH_ROWS | Number of rows to fetch from server at a time when using a cursor. mode can be in the range from 1 to the maximum value of unsigned long. The default is 1.

If you use the MYSQLI_STMT_ATTR_CURSOR_TYPE option with MYSQLI_CURSOR_TYPE_READ_ONLY, a cursor is opened for the statement when you invoke mysqli_stmt_execute(). If there is already an open cursor from a previous mysqli_stmt_execute() call, it closes the cursor before opening a new one. mysqli_stmt_reset() also closes any open cursor before preparing the statement for re-execution. mysqli_stmt_free_result() closes any open cursor.

If you open a cursor for a prepared statement, mysqli_stmt_store_result() is unnecessary.

mode

The value to assign to the attribute.

参见

  • » Connector/MySQL mysql_stmt_attr_set()


Binds variables to a prepared statement as parameters

  • ? mysqli_stmt::attr_set
  • mysqli_stmt::bind_result ?
  • PHP Manual
  • MySQLi_STMT
  • Binds variables to a prepared statement as parameters

mysqli_stmt::bind_param

mysqli_stmt_bind_param

(PHP 5, PHP 7)

mysqli_stmt::bind_param -- mysqli_stmt_bind_param — Binds variables to a prepared statement as parameters

说明

面向对象风格

public mysqli_stmt::bind_param ( string $types , mixed &$var , mixed &...$vars ) : bool

过程化风格

mysqli_stmt_bind_param ( mysqli_stmt $stmt , string $types , mixed &$var , mixed &...$vars ) : bool

Bind variables for the parameter markers in the SQL statement that was passed to mysqli_prepare().

Note:

If data size of a variable exceeds max. allowed packet size (max_allowed_packet), you have to specify b in types and use mysqli_stmt_send_long_data() to send the data in packets.

Note:

Care must be taken when using mysqli_stmt_bind_param() in conjunction with call_user_func_array(). Note that mysqli_stmt_bind_param() requires parameters to be passed by reference, whereas call_user_func_array() can accept as a parameter a list of variables that can represent references or values.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

types

A string that contains one or more characters which specify the types for the corresponding bind variables:

Type specification chars
Character | Description
i | corresponding variable has type integer
d | corresponding variable has type double
s | corresponding variable has type string
b | corresponding variable is a blob and will be sent in packets

var
vars

The number of variables and length of string types must match the parameters in the statement.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$stmt = $mysqli->prepare("INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
$stmt->bind_param('sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", $stmt->affected_rows);

/* close statement and connection */
$stmt->close();

/* Clean up table CountryLanguage */
$mysqli->query("DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Row deleted.\n", $mysqli->affected_rows);

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$stmt = mysqli_prepare($link, "INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
mysqli_stmt_bind_param($stmt, 'sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* execute prepared statement */
mysqli_stmt_execute($stmt);

printf("%d Row inserted.\n", mysqli_stmt_affected_rows($stmt));

/* close statement and connection */
mysqli_stmt_close($stmt);

/* Clean up table CountryLanguage */
mysqli_query($link, "DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Row deleted.\n", mysqli_affected_rows($link));

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

1 Row inserted.
1 Row deleted.

参见

  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • mysqli_stmt_execute() - Executes a prepared Query
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_send_long_data() - Send data in blocks
  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_error() - Returns a string description for last statement error


Binds variables to a prepared statement for result storage

  • ? mysqli_stmt::bind_param
  • mysqli_stmt::close ?
  • PHP Manual
  • MySQLi_STMT
  • Binds variables to a prepared statement for result storage

mysqli_stmt::bind_result

mysqli_stmt_bind_result

(PHP 5, PHP 7)

mysqli_stmt::bind_result -- mysqli_stmt_bind_result — Binds variables to a prepared statement for result storage

说明

面向对象风格

public mysqli_stmt::bind_result ( mixed &$var , mixed &...$vars ) : bool

过程化风格

mysqli_stmt_bind_result ( mysqli_stmt $stmt , mixed &$var , mixed &...$vars ) : bool

Binds columns in the result set to variables.

When mysqli_stmt_fetch() is called to fetch data, the MySQL client/server protocol places the data for the bound columns into the specified variables var/vars.

Note:

Note that all columns must be bound after mysqli_stmt_execute() and prior to calling mysqli_stmt_fetch(). Depending on column types bound variables can silently change to the corresponding PHP type.

A column can be bound or rebound at any time, even after a result set has been partially retrieved. The new binding takes effect the next time mysqli_stmt_fetch() is called.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

var

The first variable to be bound.

vars

Further variables to be bound.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* prepare statement */
if ($stmt = $mysqli->prepare("SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    $stmt->execute();

    /* bind variables to prepared statement */
    $stmt->bind_result($col1, $col2);

    /* fetch values */
    while ($stmt->fetch()) {
        printf("%s %s\n", $col1, $col2);
    }

    /* close statement */
    $stmt->close();
}
/* close connection */
$mysqli->close();

?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* prepare statement */
if ($stmt = mysqli_prepare($link, "SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    mysqli_stmt_execute($stmt);

    /* bind variables to prepared statement */
    mysqli_stmt_bind_result($stmt, $col1, $col2);

    /* fetch values */
    while (mysqli_stmt_fetch($stmt)) {
        printf("%s %s\n", $col1, $col2);
    }

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

AFG Afghanistan
ALB Albania
DZA Algeria
ASM American Samoa
AND Andorra

参见

  • mysqli_stmt_get_result() - Gets a result set from a prepared statement
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • mysqli_stmt_execute() - Executes a prepared Query
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_init() - 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象
  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_error() - Returns a string description for last statement error


Closes a prepared statement

  • ? mysqli_stmt::bind_result
  • mysqli_stmt::__construct ?
  • PHP Manual
  • MySQLi_STMT
  • Closes a prepared statement

mysqli_stmt::close

mysqli_stmt_close

(PHP 5, PHP 7)

mysqli_stmt::close -- mysqli_stmt_close — Closes a prepared statement

说明

面向对象风格

public mysqli_stmt::close ( ) : bool

过程化风格

mysqli_stmt_close ( mysqli_stmt $stmt ) : bool

Closes a prepared statement. mysqli_stmt_close() also deallocates the statement handle. If the current statement has pending or unread results, this function cancels them so that the next query can be executed.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句


Constructs a new mysqli_stmt object

  • ? mysqli_stmt::close
  • mysqli_stmt::data_seek ?
  • PHP Manual
  • MySQLi_STMT
  • Constructs a new mysqli_stmt object

mysqli_stmt::__construct

(PHP 5, PHP 7)

mysqli_stmt::__construct — Constructs a new mysqli_stmt object

说明

public mysqli_stmt::__construct ( mysqli $link , string $query = ? )

This method constructs a new mysqli_stmt object.

参数

link

仅以过程化样式：由mysqli_connect() 或 mysqli_init() 返回的链接标识。

query

The query, as a string. If this parameter is omitted, then the constructor behaves identically to mysqli_stmt_init(), if provided, then it behaves as per mysqli_prepare().

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_init() - 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象


Seeks to an arbitrary row in statement result set

  • ? mysqli_stmt::__construct
  • mysqli_stmt::$errno ?
  • PHP Manual
  • MySQLi_STMT
  • Seeks to an arbitrary row in statement result set

mysqli_stmt::data_seek

mysqli_stmt_data_seek

(PHP 5, PHP 7)

mysqli_stmt::data_seek -- mysqli_stmt_data_seek — Seeks to an arbitrary row in statement result set

说明

面向对象风格

public mysqli_stmt::data_seek ( int $offset ) : void

过程化风格

mysqli_stmt_data_seek ( mysqli_stmt $stmt , int $offset ) : void

Seeks to an arbitrary result pointer in the statement result set.

mysqli_stmt_store_result() must be called prior to mysqli_stmt_data_seek().

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

offset

Must be between zero and the total number of rows minus one (0.. mysqli_stmt_num_rows() - 1).

返回值

没有返回值。

范例

Example #1 面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($name, $code);

    /* store result */
    $stmt->store_result();

    /* seek to row no. 400 */
    $stmt->data_seek(399);

    /* fetch values */
    $stmt->fetch();

    printf ("City: %s  Countrycode: %s\n", $name, $code);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $name, $code);

    /* store result */
    mysqli_stmt_store_result($stmt);

    /* seek to row no. 400 */
    mysqli_stmt_data_seek($stmt, 399);

    /* fetch values */
    mysqli_stmt_fetch($stmt);

    printf ("City: %s  Countrycode: %s\n", $name, $code);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

City: Benin City  Countrycode: NGA

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句


Returns the error code for the most recent statement call

  • ? mysqli_stmt::data_seek
  • mysqli_stmt::$error_list ?
  • PHP Manual
  • MySQLi_STMT
  • Returns the error code for the most recent statement call

mysqli_stmt::$errno

mysqli_stmt_errno

(PHP 5, PHP 7)

mysqli_stmt::$errno -- mysqli_stmt_errno — Returns the error code for the most recent statement call

说明

面向对象风格

int $mysqli_stmt->errno;

过程化风格

mysqli_stmt_errno ( mysqli_stmt $stmt ) : int

Returns the error code for the most recently invoked statement function that can succeed or fail.

Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

An error code value. Zero means no error occurred.

范例

Example #1 面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %d.\n", $stmt->errno);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %d.\n", mysqli_stmt_errno($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Error: 1146.

参见

  • mysqli_stmt_error() - Returns a string description for last statement error
  • mysqli_stmt_sqlstate() - Returns SQLSTATE error from previous statement operation


Returns a list of errors from the last statement executed

  • ? mysqli_stmt::$errno
  • mysqli_stmt::$error ?
  • PHP Manual
  • MySQLi_STMT
  • Returns a list of errors from the last statement executed

mysqli_stmt::$error_list

mysqli_stmt_error_list

(PHP 5 >= 5.4.0, PHP 7)

mysqli_stmt::$error_list -- mysqli_stmt_error_list — Returns a list of errors from the last statement executed

说明

面向对象风格

array $mysqli_stmt->error_list;

过程化风格

mysqli_stmt_error_list ( mysqli_stmt $stmt ) : array

Returns an array of errors for the most recently invoked statement function that can succeed or fail.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

A list of errors, each as an associative array containing the errno, error, and sqlstate.

范例

Example #1 面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    echo "Error:\n";
    print_r($stmt->error_list);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    echo "Error:\n";
    print_r(mysql_stmt_error_list($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [errno] => 1146
            [sqlstate] => 42S02
            [error] => Table 'world.myCountry' doesn't exist
        )

)

参见

  • mysqli_stmt_error() - Returns a string description for last statement error
  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_sqlstate() - Returns SQLSTATE error from previous statement operation


Returns a string description for last statement error

  • ? mysqli_stmt::$error_list
  • mysqli_stmt::execute ?
  • PHP Manual
  • MySQLi_STMT
  • Returns a string description for last statement error

mysqli_stmt::$error

mysqli_stmt_error

(PHP 5, PHP 7)

mysqli_stmt::$error -- mysqli_stmt_error — Returns a string description for last statement error

说明

面向对象风格

string $mysqli_stmt->error;

过程化风格

mysqli_stmt_error ( mysqli_stmt $stmt ) : string

Returns a string containing the error message for the most recently invoked statement function that can succeed or fail.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

A string that describes the error. An empty string if no error occurred.

范例

Example #1 面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %s.\n", $stmt->error);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %s.\n", mysqli_stmt_error($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Error: Table 'world.myCountry' doesn't exist.

参见

  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_sqlstate() - Returns SQLSTATE error from previous statement operation


Executes a prepared Query

  • ? mysqli_stmt::$error
  • mysqli_stmt::fetch ?
  • PHP Manual
  • MySQLi_STMT
  • Executes a prepared Query

mysqli_stmt::execute

mysqli_stmt_execute

(PHP 5, PHP 7)

mysqli_stmt::execute -- mysqli_stmt_execute — Executes a prepared Query

说明

面向对象风格

public mysqli_stmt::execute ( ) : bool

过程化风格

mysqli_stmt_execute ( mysqli_stmt $stmt ) : bool

Executes a query that has been previously prepared using the mysqli_prepare() function. When executed any parameter markers which exist will automatically be replaced with the appropriate data.

If the statement is UPDATE, DELETE, or INSERT, the total number of affected rows can be determined by using the mysqli_stmt_affected_rows() function. Likewise, if the query yields a result set the mysqli_stmt_fetch() function is used.

Note:

When using mysqli_stmt_execute(), the mysqli_stmt_fetch() function must be used to fetch the data prior to performing any additional queries.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* Prepare an insert statement */
$query = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$stmt = $mysqli->prepare($query);

$stmt->bind_param("sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Execute the statement */
$stmt->execute();

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Execute the statement */
$stmt->execute();

/* close statement */
$stmt->close();

/* retrieve all rows from myCity */
$query = "SELECT Name, CountryCode, District FROM myCity";
if ($result = $mysqli->query($query)) {
    while ($row = $result->fetch_row()) {
        printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
    }
    /* free result set */
    $result->close();
}

/* remove table */
$mysqli->query("DROP TABLE myCity");

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* Prepare an insert statement */
$query = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$stmt = mysqli_prepare($link, $query);

mysqli_stmt_bind_param($stmt, "sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Execute the statement */
mysqli_stmt_execute($stmt);

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Execute the statement */
mysqli_stmt_execute($stmt);

/* close statement */
mysqli_stmt_close($stmt);

/* retrieve all rows from myCity */
$query = "SELECT Name, CountryCode, District FROM myCity";
if ($result = mysqli_query($link, $query)) {
    while ($row = mysqli_fetch_row($result)) {
        printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
    }
    /* free result set */
    mysqli_free_result($result);
}

/* remove table */
mysqli_query($link, "DROP TABLE myCity");

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Stuttgart (DEU,Baden-Wuerttemberg)
Bordeaux (FRA,Aquitaine)

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • mysqli_stmt_get_result() - Gets a result set from a prepared statement


Fetch results from a prepared statement into the bound variables

  • ? mysqli_stmt::execute
  • mysqli_stmt::$field_count ?
  • PHP Manual
  • MySQLi_STMT
  • Fetch results from a prepared statement into the bound variables

mysqli_stmt::fetch

mysqli_stmt_fetch

(PHP 5, PHP 7)

mysqli_stmt::fetch -- mysqli_stmt_fetch — Fetch results from a prepared statement into the bound variables

说明

面向对象风格

public mysqli_stmt::fetch ( ) : bool

过程化风格

mysqli_stmt_fetch ( mysqli_stmt $stmt ) : bool

Fetch the result from a prepared statement into the variables bound by mysqli_stmt_bind_result().

Note:

Note that all columns must be bound by the application before calling mysqli_stmt_fetch().

Note:

Data are transferred unbuffered without calling mysqli_stmt_store_result() which can decrease performance (but reduces memory cost).

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

返回值
Value | Description
true | Success. Data has been fetched
false | Error occurred
null | No more rows/data exists or data truncation occurred

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($stmt = $mysqli->prepare($query)) {

    /* execute statement */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($name, $code);

    /* fetch values */
    while ($stmt->fetch()) {
        printf ("%s (%s)\n", $name, $code);
    }

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($stmt = mysqli_prepare($link, $query)) {

    /* execute statement */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $name, $code);

    /* fetch values */
    while (mysqli_stmt_fetch($stmt)) {
        printf ("%s (%s)\n", $name, $code);
    }

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Rockford (USA)
Tallahassee (USA)
Salinas (USA)
Santa Clarita (USA)
Springfield (USA)

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_error() - Returns a string description for last statement error
  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage


Returns the number of columns in the given statement

  • ? mysqli_stmt::fetch
  • mysqli_stmt::free_result ?
  • PHP Manual
  • MySQLi_STMT
  • Returns the number of columns in the given statement

mysqli_stmt::$field_count

mysqli_stmt_field_count

(PHP 5, PHP 7)

mysqli_stmt::$field_count -- mysqli_stmt_field_count — Returns the number of columns in the given statement

说明

面向对象风格

int $mysqli_stmt->field_count;

过程化风格

mysqli_stmt_field_count ( mysqli_stmt $stmt ) : int

Returns the number of columns in the prepared statement.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

Returns an integer representing the number of columns.

范例

Example #1 面向对象风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

$code = 'FR';

$stmt = $mysqli->prepare("SELECT Name FROM Country WHERE Code=?");
$stmt->bind_param('s', $code);
$stmt->execute();
$row = $stmt->get_result()->fetch_row();
for ($i = 0; $i < $stmt->field_count; $i++) {
    printf("Value of column number %d is %s", $i, $row[$i]);
}

Example #2 过程化风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = mysqli_connect("localhost", "my_user", "my_password", "world");

$code = 'FR';

$stmt = mysqli_prepare($mysqli, "SELECT Name FROM Country WHERE Code=?");
mysqli_stmt_bind_param($stmt, 's', $code);
mysqli_stmt_execute($stmt);
$result = mysqli_stmt_get_result($stmt);
$row = mysqli_fetch_row($result);
for ($i = 0; $i < mysqli_stmt_field_count($stmt); $i++) {
    printf("Value of column number %d is %s", $i, $row[$i]);
}

以上例程的输出类似于：

Value of column number 0 is France

参见

  • mysqli_stmt_num_rows() - Return the number of rows in statements result set


Frees stored result memory for the given statement handle

  • ? mysqli_stmt::$field_count
  • mysqli_stmt::get_result ?
  • PHP Manual
  • MySQLi_STMT
  • Frees stored result memory for the given statement handle

mysqli_stmt::free_result

mysqli_stmt_free_result

(PHP 5, PHP 7)

mysqli_stmt::free_result -- mysqli_stmt_free_result — Frees stored result memory for the given statement handle

说明

面向对象风格

public mysqli_stmt::free_result ( ) : void

过程化风格

mysqli_stmt_free_result ( mysqli_stmt $stmt ) : void

Frees the result memory associated with the statement, which was allocated by mysqli_stmt_store_result().

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

没有返回值。

参见

  • mysqli_stmt_store_result() - Transfers a result set from a prepared statement


Gets a result set from a prepared statement

  • ? mysqli_stmt::free_result
  • mysqli_stmt::get_warnings ?
  • PHP Manual
  • MySQLi_STMT
  • Gets a result set from a prepared statement

mysqli_stmt::get_result

mysqli_stmt_get_result

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::get_result -- mysqli_stmt_get_result — Gets a result set from a prepared statement

说明

面向对象风格

public mysqli_stmt::get_result ( ) : mysqli_result

过程化风格

mysqli_stmt_get_result ( mysqli_stmt $stmt ) : mysqli_result

Call to return a result set from a prepared statement query.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

Returns false on failure. For successful queries which produce a result set, such as SELECT, SHOW, DESCRIBE or EXPLAIN, mysqli_stmt_get_result() will return a mysqli_result object. For other successful queries, mysqli_stmt_get_result() will return false. The mysqli_stmt_errno() function can be used to distinguish between the two reasons for false; due to a bug, prior to PHP 7.4.13, mysqli_errno() had to be used for this purpose.

仅 MySQL 原生驱动

仅可用于 mysqlnd。

范例

Example #1 面向对象风格

<?php

$mysqli = new mysqli("127.0.0.1", "user", "password", "world");

if($mysqli->connect_error)
{
    die("$mysqli->connect_errno: $mysqli->connect_error");
}

$query = "SELECT Name, Population, Continent FROM Country WHERE Continent=? ORDER BY Name LIMIT 1";

$stmt = $mysqli->stmt_init();
if(!$stmt->prepare($query))
{
    print "Failed to prepare statement\n";
}
else
{
    $stmt->bind_param("s", $continent);

    $continent_array = array('Europe','Africa','Asia','North America');

    foreach($continent_array as $continent)
    {
        $stmt->execute();
        $result = $stmt->get_result();
        while ($row = $result->fetch_array(MYSQLI_NUM))
        {
            foreach ($row as $r)
            {
                print "$r ";
            }
            print "\n";
        }
    }
}

$stmt->close();
$mysqli->close();
?>

Example #2 过程化风格

<?php

$link = mysqli_connect("127.0.0.1", "user", "password", "world");

if (!$link)
{
    $error = mysqli_connect_error();
    $errno = mysqli_connect_errno();
    print "$errno: $error\n";
    exit();
}

$query = "SELECT Name, Population, Continent FROM Country WHERE Continent=? ORDER BY Name LIMIT 1";

$stmt = mysqli_stmt_init($link);
if(!mysqli_stmt_prepare($stmt, $query))
{
    print "Failed to prepare statement\n";
}
else
{
    mysqli_stmt_bind_param($stmt, "s", $continent);

    $continent_array = array('Europe','Africa','Asia','North America');

    foreach($continent_array as $continent)
    {
        mysqli_stmt_execute($stmt);
        $result = mysqli_stmt_get_result($stmt);
        while ($row = mysqli_fetch_array($result, MYSQLI_NUM))
        {
            foreach ($row as $r)
            {
                print "$r ";
            }
            print "\n";
        }
    }
}
mysqli_stmt_close($stmt);
mysqli_close($link);
?>

以上例程会输出：

Albania 3401200 Europe
Algeria 31471000 Africa
Afghanistan 22720000 Asia
Anguilla 8000 North America

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_result_metadata() - Returns result set metadata from a prepared statement
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_stmt_store_result() - Transfers a result set from a prepared statement
  • mysqli_errno() - 返回最近函数调用的错误代码


Get result of SHOW WARNINGS

  • ? mysqli_stmt::get_result
  • mysqli_stmt::$insert_id ?
  • PHP Manual
  • MySQLi_STMT
  • Get result of SHOW WARNINGS

mysqli_stmt::get_warnings

mysqli_stmt_get_warnings

(PHP 5 >= 5.1.0, PHP 7)

mysqli_stmt::get_warnings -- mysqli_stmt_get_warnings — Get result of SHOW WARNINGS

说明

面向对象风格

public mysqli_stmt::get_warnings ( ) : object

过程化风格

mysqli_stmt_get_warnings ( mysqli_stmt $stmt ) : object
Warning

本函数还未编写文档，仅有参数列表。


Get the ID generated from the previous INSERT operation

  • ? mysqli_stmt::get_warnings
  • mysqli_stmt::more_results ?
  • PHP Manual
  • MySQLi_STMT
  • Get the ID generated from the previous INSERT operation

mysqli_stmt::$insert_id

mysqli_stmt_insert_id

(PHP 5, PHP 7)

mysqli_stmt::$insert_id -- mysqli_stmt_insert_id — Get the ID generated from the previous INSERT operation

说明

面向对象风格

int $mysqli_stmt->insert_id;

过程化风格

mysqli_stmt_insert_id ( mysqli_stmt $stmt ) : mixed
Warning

本函数还未编写文档，仅有参数列表。


Check if there are more query results from a multiple query

  • ? mysqli_stmt::$insert_id
  • mysqli_stmt::next_result ?
  • PHP Manual
  • MySQLi_STMT
  • Check if there are more query results from a multiple query

mysqli_stmt::more_results

mysqli_stmt_more_results

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::more_results -- mysqli_stmt_more_results — Check if there are more query results from a multiple query

说明

面向对象风格

public mysqli_stmt::more_results ( ) : bool

过程化风格:

mysqli_stmt_more_results ( mysql_stmt $stmt ) : bool

Checks if there are more query results from a multiple query.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

Returns true if more results exist, otherwise false.

仅 MySQL 原生驱动

仅可用于 mysqlnd。

参见

  • mysqli_stmt::next_result() - Reads the next result from a multiple query
  • mysqli::multi_query() - 执行查询


Reads the next result from a multiple query

  • ? mysqli_stmt::more_results
  • mysqli_stmt::$num_rows ?
  • PHP Manual
  • MySQLi_STMT
  • Reads the next result from a multiple query

mysqli_stmt::next_result

mysqli_stmt_next_result

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::next_result -- mysqli_stmt_next_result — Reads the next result from a multiple query

说明

面向对象风格

public mysqli_stmt::next_result ( ) : bool

过程化风格:

mysqli_stmt_next_result ( mysql_stmt $stmt ) : bool

Reads the next result from a multiple query.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Emits an E_STRICT level error if a result set does not exist, and suggests using mysqli_stmt::more_results() in these cases, before calling mysqli_stmt::next_result().

仅 MySQL 原生驱动

仅可用于 mysqlnd。

参见

  • mysqli_stmt::more_results() - Check if there are more query results from a multiple query
  • mysqli::multi_query() - 执行查询


Return the number of rows in statements result set

  • ? mysqli_stmt::next_result
  • mysqli_stmt::$param_count ?
  • PHP Manual
  • MySQLi_STMT
  • Return the number of rows in statements result set

mysqli_stmt::$num_rows

mysqli_stmt::num_rows

mysqli_stmt_num_rows

(PHP 5, PHP 7)

mysqli_stmt::$num_rows -- mysqli_stmt::num_rows -- mysqli_stmt_num_rows — Return the number of rows in statements result set

说明

面向对象风格

int $mysqli_stmt->num_rows;
public mysqli_stmt::num_rows ( ) : int

过程化风格

mysqli_stmt_num_rows ( mysqli_stmt $stmt ) : int

Returns the number of rows in the result set. The use of mysqli_stmt_num_rows() depends on whether or not you used mysqli_stmt_store_result() to buffer the entire result set in the statement handle.

If you use mysqli_stmt_store_result(), mysqli_stmt_num_rows() may be called immediately.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

An integer representing the number of rows in result set.

范例

Example #1 面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* store result */
    $stmt->store_result();

    printf("Number of rows: %d.\n", $stmt->num_rows);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* store result */
    mysqli_stmt_store_result($stmt);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Number of rows: 20.

参见

  • mysqli_stmt_affected_rows() - Returns the total number of rows changed, deleted, or inserted by the last executed statement
  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_store_result() - Transfers a result set from a prepared statement


Returns the number of parameters for the given statement

  • ? mysqli_stmt::$num_rows
  • mysqli_stmt::prepare ?
  • PHP Manual
  • MySQLi_STMT
  • Returns the number of parameters for the given statement

mysqli_stmt::$param_count

mysqli_stmt_param_count

(PHP 5, PHP 7)

mysqli_stmt::$param_count -- mysqli_stmt_param_count — Returns the number of parameters for the given statement

说明

面向对象风格

int $mysqli_stmt->param_count;

过程化风格

mysqli_stmt_param_count ( mysqli_stmt $stmt ) : int

Returns the number of parameter markers present in the prepared statement.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

Returns an integer representing the number of parameters.

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($stmt = $mysqli->prepare("SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marker = $stmt->param_count;
    printf("Statement has %d markers.\n", $marker);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($stmt = mysqli_prepare($link, "SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marker = mysqli_stmt_param_count($stmt);
    printf("Statement has %d markers.\n", $marker);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Statement has 2 markers.

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句


Prepare an SQL statement for execution

  • ? mysqli_stmt::$param_count
  • mysqli_stmt::reset ?
  • PHP Manual
  • MySQLi_STMT
  • Prepare an SQL statement for execution

mysqli_stmt::prepare

mysqli_stmt_prepare

(PHP 5, PHP 7)

mysqli_stmt::prepare -- mysqli_stmt_prepare — Prepare an SQL statement for execution

说明

面向对象风格

public mysqli_stmt::prepare ( string $query ) : mixed

过程化风格

mysqli_stmt_prepare ( mysqli_stmt $stmt , string $query ) : bool

Prepares the SQL query pointed to by the null-terminated string query.

The parameter markers must be bound to application variables using mysqli_stmt_bind_param() and/or mysqli_stmt_bind_result() before executing the statement or fetching rows.

Note:

In the case where you pass a statement to mysqli_stmt_prepare() that is longer than max_allowed_packet of the server, the returned error codes are different depending on whether you are using MySQL Native Driver (mysqlnd) or MySQL Client Library (libmysqlclient). The behavior is as follows:

  • mysqlnd on Linux returns an error code of 1153. The error message means got a packet bigger than max_allowed_packet bytes.

  • mysqlnd on Windows returns an error code 2006. This error message means server has gone away.

  • libmysqlclient on all platforms returns an error code 2006. This error message means server has gone away.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

query

The query, as a string. It must consist of a single SQL statement.

You can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Note:

You should not add a terminating semicolon or \g to the statement.

Note:

The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Language (DML) statements, and not in Data Definition Language (DDL) statements.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
$stmt =  $mysqli->stmt_init();
if ($stmt->prepare("SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    $stmt->bind_param("s", $city);

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($district);

    /* fetch value */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
$stmt = mysqli_stmt_init($link);
if (mysqli_stmt_prepare($stmt, 'SELECT District FROM City WHERE Name=?')) {

    /* bind parameters for markers */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $district);

    /* fetch value */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Amersfoort is in district Utrecht

参见

  • mysqli_stmt_init() - 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象
  • mysqli_stmt_execute() - Executes a prepared Query
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • mysqli_stmt_get_result() - Gets a result set from a prepared statement
  • mysqli_stmt_close() - Closes a prepared statement


Resets a prepared statement

  • ? mysqli_stmt::prepare
  • mysqli_stmt::result_metadata ?
  • PHP Manual
  • MySQLi_STMT
  • Resets a prepared statement

mysqli_stmt::reset

mysqli_stmt_reset

(PHP 5, PHP 7)

mysqli_stmt::reset -- mysqli_stmt_reset — Resets a prepared statement

说明

面向对象风格

public mysqli_stmt::reset ( ) : bool

过程化风格

mysqli_stmt_reset ( mysqli_stmt $stmt ) : bool

Resets a prepared statement on client and server to state after prepare.

It resets the statement on the server, data sent using mysqli_stmt_send_long_data(), unbuffered result sets and current errors. It does not clear bindings or stored result sets. Stored result sets will be cleared when executing the prepared statement (or closing it).

To prepare a statement with another query use function mysqli_stmt_prepare().

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句


Returns result set metadata from a prepared statement

  • ? mysqli_stmt::reset
  • mysqli_stmt::send_long_data ?
  • PHP Manual
  • MySQLi_STMT
  • Returns result set metadata from a prepared statement

mysqli_stmt::result_metadata

mysqli_stmt_result_metadata

(PHP 5, PHP 7)

mysqli_stmt::result_metadata -- mysqli_stmt_result_metadata — Returns result set metadata from a prepared statement

说明

面向对象风格

public mysqli_stmt::result_metadata ( ) : mysqli_result

过程化风格

mysqli_stmt_result_metadata ( mysqli_stmt $stmt ) : mysqli_result

If a statement passed to mysqli_prepare() is one that produces a result set, mysqli_stmt_result_metadata() returns the result object that can be used to process the meta information such as total number of fields and individual field information.

Note:

This result set pointer can be passed as an argument to any of the field-based functions that process result set metadata, such as:

  • mysqli_num_fields()

  • mysqli_fetch_field()

  • mysqli_fetch_field_direct()

  • mysqli_fetch_fields()

  • mysqli_field_count()

  • mysqli_field_seek()

  • mysqli_field_tell()

  • mysqli_free_result()

The result set structure should be freed when you are done with it, which you can do by passing it to mysqli_free_result()

Note:

The result set returned by mysqli_stmt_result_metadata() contains only metadata. It does not contain any row results. The rows are obtained by using the statement handle with mysqli_stmt_fetch().

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

Returns a result object or false if an error occurred.

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query("DROP TABLE IF EXISTS friends");
$mysqli->query("CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query("INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$stmt = $mysqli->prepare("SELECT id, name FROM friends");
$stmt->execute();

/* get resultset for metadata */
$result = $stmt->result_metadata();

/* retrieve field information from metadata result set */
$field = $result->fetch_field();

printf("Fieldname: %s\n", $field->name);

/* close resultset */
$result->close();

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$stmt = mysqli_prepare($link, "SELECT id, name FROM friends");
mysqli_stmt_execute($stmt);

/* get resultset for metadata */
$result = mysqli_stmt_result_metadata($stmt);

/* retrieve field information from metadata result set */
$field = mysqli_fetch_field($result);

printf("Fieldname: %s\n", $field->name);

/* close resultset */
mysqli_free_result($result);

/* close connection */
mysqli_close($link);
?>

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_free_result() - Frees the memory associated with a result


Send data in blocks

  • ? mysqli_stmt::result_metadata
  • mysqli_stmt::$sqlstate ?
  • PHP Manual
  • MySQLi_STMT
  • Send data in blocks

mysqli_stmt::send_long_data

mysqli_stmt_send_long_data

(PHP 5, PHP 7)

mysqli_stmt::send_long_data -- mysqli_stmt_send_long_data — Send data in blocks

说明

面向对象风格

public mysqli_stmt::send_long_data ( int $param_nr , string $data ) : bool

过程化风格

mysqli_stmt_send_long_data ( mysqli_stmt $stmt , int $param_nr , string $data ) : bool

Allows to send parameter data to the server in pieces (or chunks), e.g. if the size of a blob exceeds the size of max_allowed_packet. This function can be called multiple times to send the parts of a character or binary data value for a column, which must be one of the TEXT or BLOB datatypes.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

param_nr

Indicates which parameter to associate the data with. Parameters are numbered beginning with 0.

data

A string containing data to be sent.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 面向对象风格

<?php
$stmt = $mysqli->prepare("INSERT INTO messages (message) VALUES (?)");
$null = NULL;
$stmt->bind_param("b", $null);
$fp = fopen("messages.txt", "r");
while (!feof($fp)) {
    $stmt->send_long_data(0, fread($fp, 8192));
}
fclose($fp);
$stmt->execute();
?>

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters


Returns SQLSTATE error from previous statement operation

  • ? mysqli_stmt::send_long_data
  • mysqli_stmt::store_result ?
  • PHP Manual
  • MySQLi_STMT
  • Returns SQLSTATE error from previous statement operation

mysqli_stmt::$sqlstate

mysqli_stmt_sqlstate

(PHP 5, PHP 7)

mysqli_stmt::$sqlstate -- mysqli_stmt_sqlstate — Returns SQLSTATE error from previous statement operation

说明

面向对象风格

string $mysqli_stmt->sqlstate;

过程化风格

mysqli_stmt_sqlstate ( mysqli_stmt $stmt ) : string

Returns a string containing the SQLSTATE error code for the most recently invoked prepared statement function that can succeed or fail. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC. For a list of possible values, see » http://dev.mysql.com/doc/mysql/en/error-handling.html.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

注释

Note:

Note that not all MySQL errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

范例

Example #1 面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %s.\n", $stmt->sqlstate);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %s.\n", mysqli_stmt_sqlstate($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Error: 42S02.

参见

  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_error() - Returns a string description for last statement error


Transfers a result set from a prepared statement

  • ? mysqli_stmt::$sqlstate
  • mysqli_result ?
  • PHP Manual
  • MySQLi_STMT
  • Transfers a result set from a prepared statement

mysqli_stmt::store_result

mysqli_stmt_store_result

(PHP 5, PHP 7)

mysqli_stmt::store_result -- mysqli_stmt_store_result — Transfers a result set from a prepared statement

说明

面向对象风格

public mysqli_stmt::store_result ( ) : bool

过程化风格

mysqli_stmt_store_result ( mysqli_stmt $stmt ) : bool

You must call mysqli_stmt_store_result() for every query that successfully produces a result set (SELECT, SHOW, DESCRIBE, EXPLAIN), if and only if you want to buffer the complete result set by the client, so that the subsequent mysqli_stmt_fetch() call returns buffered data.

Note:

It is unnecessary to call mysqli_stmt_store_result() for other queries, but if you do, it will not harm or cause any notable performance loss in all cases. You can detect whether the query produced a result set by checking if mysqli_stmt_result_metadata() returns false.

参数

stmt

仅以过程化样式：由 mysqli_stmt_init() 返回的 statement 标识。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* store result */
    $stmt->store_result();

    printf("Number of rows: %d.\n", $stmt->num_rows);

    /* free result */
    $stmt->free_result();

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* store result */
    mysqli_stmt_store_result($stmt);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($stmt));

    /* free result */
    mysqli_stmt_free_result($stmt);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Number of rows: 20.

参见

  • mysqli_prepare() - 准备执行一个 SQL 语句
  • mysqli_stmt_result_metadata() - Returns result set metadata from a prepared statement
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables


mysqli_result类

(PHP 5, PHP 7)

简介

代表从一个数据库查询中获取的结果集。

更新日志

更新日志
版本 | 说明
5.4.0 | Iterator support was added, as mysqli_result now implements Traversable.

类摘要

mysqli_result {
/* 属性 */
int $current_field ;
int $field_count;
array $lengths;
int $num_rows;
/* 方法 */
mysqli_field_tell ( mysqli_result $result ) : int
public data_seek ( int $offset ) : bool
public fetch_all ( int $resulttype = MYSQLI_NUM ) : mixed
public fetch_array ( int $resulttype = MYSQLI_BOTH ) : mixed
public fetch_assoc ( ) : array
public fetch_field_direct ( int $fieldnr ) : object
public fetch_field ( ) : object
public fetch_fields ( ) : array
public fetch_object ( string $class_name = "stdClass" , array $params = ? ) : object
public fetch_row ( ) : mixed
mysqli_num_fields ( mysqli_result $result ) : int
public field_seek ( int $fieldnr ) : bool
public free ( ) : void
mysqli_fetch_lengths ( mysqli_result $result ) : array
mysqli_num_rows ( mysqli_result $result ) : int
}

Table of Contents

  • mysqli_result::$current_field — Get current field offset of a result pointer
  • mysqli_result::data_seek — Adjusts the result pointer to an arbitrary row in the result
  • mysqli_result::fetch_all — Fetches all result rows as an associative array, a numeric array, or both
  • mysqli_result::fetch_array — Fetch a result row as an associative, a numeric array, or both
  • mysqli_result::fetch_assoc — Fetch a result row as an associative array
  • mysqli_result::fetch_field_direct — Fetch meta-data for a single field
  • mysqli_result::fetch_field — Returns the next field in the result set
  • mysqli_result::fetch_fields — Returns an array of objects representing the fields in a result set
  • mysqli_result::fetch_object — Returns the current row of a result set as an object
  • mysqli_result::fetch_row — Get a result row as an enumerated array
  • mysqli_result::$field_count — Get the number of fields in a result
  • mysqli_result::field_seek — Set result pointer to a specified field offset
  • mysqli_result::free — Frees the memory associated with a result
  • mysqli_result::$lengths — Returns the lengths of the columns of the current row in the result set
  • mysqli_result::$num_rows — Gets the number of rows in a result


Get current field offset of a result pointer

  • ? mysqli_result
  • mysqli_result::data_seek ?
  • PHP Manual
  • mysqli_result
  • Get current field offset of a result pointer

mysqli_result::$current_field

mysqli_field_tell

(PHP 5, PHP 7)

mysqli_result::$current_field -- mysqli_field_tell — Get current field offset of a result pointer

说明

面向对象风格

int $mysqli_result->current_field ;

过程化风格

mysqli_field_tell ( mysqli_result $result ) : int

Returns the position of the field cursor used for the last mysqli_fetch_field() call. This value can be used as an argument to mysqli_field_seek().

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

Returns current offset of field cursor.

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    while ($finfo = $result->fetch_field()) {

        /* get fieldpointer offset */
        $currentfield = $result->current_field;

        printf("Column %d:\n", $currentfield);
        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all fields */
    while ($finfo = mysqli_fetch_field($result)) {

        /* get fieldpointer offset */
        $currentfield = mysqli_field_tell($result);

        printf("Column %d:\n", $currentfield);
        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Column 1:
Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Column 2:
Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

参见

  • mysqli_fetch_field() - Returns the next field in the result set
  • mysqli_field_seek() - Set result pointer to a specified field offset


Adjusts the result pointer to an arbitrary row in the result

  • ? mysqli_result::$current_field
  • mysqli_result::fetch_all ?
  • PHP Manual
  • mysqli_result
  • Adjusts the result pointer to an arbitrary row in the result

mysqli_result::data_seek

mysqli_data_seek

(PHP 5, PHP 7)

mysqli_result::data_seek -- mysqli_data_seek — Adjusts the result pointer to an arbitrary row in the result

说明

面向对象风格

public mysqli_result::data_seek ( int $offset ) : bool

过程化风格

mysqli_data_seek ( mysqli_result $result , int $offset ) : bool

The mysqli_data_seek() function seeks to an arbitrary result pointer specified by the offset in the result set.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

offset

The field offset. Must be between zero and the total number of rows minus one (0..mysqli_num_rows() - 1).

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function can only be used with buffered results attained from the use of the mysqli_store_result() or mysqli_query() functions.

范例

Example #1 面向对象风格

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($result = $mysqli->query($query)) {

    /* seek to row no. 400 */
    $result->data_seek(399);

    /* fetch row */
    $row = $result->fetch_row();

    printf ("City: %s  Countrycode: %s\n", $row[0], $row[1]);

    /* free result set*/
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";

if ($result = mysqli_query($link, $query)) {

    /* seek to row no. 400 */
    mysqli_data_seek($result, 399);

    /* fetch row */
    $row = mysqli_fetch_row($result);

    printf ("City: %s  Countrycode: %s\n", $row[0], $row[1]);

    /* free result set*/
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

City: Benin City  Countrycode: NGA

参见

  • mysqli_store_result() - 转移上一次查询返回的结果集
  • mysqli_fetch_row() - Get a result row as an enumerated array
  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_fetch_assoc() - Fetch a result row as an associative array
  • mysqli_fetch_object() - Returns the current row of a result set as an object
  • mysqli_query() - 对数据库执行一次查询
  • mysqli_num_rows() - Gets the number of rows in a result


Fetches all result rows as an associative array, a numeric array, or both

  • ? mysqli_result::data_seek
  • mysqli_result::fetch_array ?
  • PHP Manual
  • mysqli_result
  • Fetches all result rows as an associative array, a numeric array, or both

mysqli_result::fetch_all

mysqli_fetch_all

(PHP 5 >= 5.3.0, PHP 7)

mysqli_result::fetch_all -- mysqli_fetch_all — Fetches all result rows as an associative array, a numeric array, or both

说明

面向对象风格

public mysqli_result::fetch_all ( int $resulttype = MYSQLI_NUM ) : mixed

过程化风格

mysqli_fetch_all ( mysqli_result $result , int $resulttype = MYSQLI_NUM ) : mixed

mysqli_fetch_all() fetches all result rows and returns the result set as an associative array, a numeric array, or both.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

resulttype

This optional parameter is a constant indicating what type of array should be produced from the current row data. The possible values for this parameter are the constants MYSQLI_ASSOC, MYSQLI_NUM, or MYSQLI_BOTH.

返回值

Returns an array of associative or numeric arrays holding result rows.

仅 MySQL 原生驱动

仅可用于 mysqlnd。

As mysqli_fetch_all() returns all the rows as an array in a single step, it may consume more memory than some similar functions such as mysqli_fetch_array(), which only returns one row at a time from the result set. Further, if you need to iterate over the result set, you will need a looping construct that will further impact performance. For these reasons mysqli_fetch_all() should only be used in those situations where the fetched result set will be sent to another layer for processing.

参见

  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_query() - 对数据库执行一次查询


Fetch a result row as an associative, a numeric array, or both

  • ? mysqli_result::fetch_all
  • mysqli_result::fetch_assoc ?
  • PHP Manual
  • mysqli_result
  • Fetch a result row as an associative, a numeric array, or both

mysqli_result::fetch_array

mysqli_fetch_array

(PHP 5, PHP 7)

mysqli_result::fetch_array -- mysqli_fetch_array — Fetch a result row as an associative, a numeric array, or both

说明

面向对象风格

public mysqli_result::fetch_array ( int $resulttype = MYSQLI_BOTH ) : mixed

过程化风格

mysqli_fetch_array ( mysqli_result $result , int $resulttype = MYSQLI_BOTH ) : mixed

Returns an array that corresponds to the fetched row or null if there are no more rows for the result set.

In addition to storing the data in the numeric indices of the result array, this function can also store the data in associative indices by using the field names of the result set as keys.

Note: 此函数返回的字段名大小写敏感。

Note: 此函数将 NULL 字段设置为 PHP null 值。

If two or more columns of the result have the same field names, the last column will take precedence and overwrite the earlier data. In order to access multiple columns with the same name, the numerically indexed version of the row must be used.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

resulttype

This optional parameter is a constant indicating what type of array should be produced from the current row data. The possible values for this parameter are the constants MYSQLI_ASSOC, MYSQLI_NUM, or MYSQLI_BOTH.

By using the MYSQLI_ASSOC constant this function will behave identically to the mysqli_fetch_assoc(), while MYSQLI_NUM will behave identically to the mysqli_fetch_row() function. The final option MYSQLI_BOTH will create a single array with the attributes of both.

返回值

Returns an array of values that corresponds to the fetched row or null if there are no more rows in result set.

范例

Example #1 mysqli_result::fetch_array() example

面向对象风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

$query = "SELECT Name, CountryCode FROM City ORDER BY ID LIMIT 3";
$result = $mysqli->query($query);

/* numeric array */
$row = $result->fetch_array(MYSQLI_NUM);
printf("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = $result->fetch_array(MYSQLI_ASSOC);
printf("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* associative and numeric array */
$row = $result->fetch_array(MYSQLI_BOTH);
printf("%s (%s)\n", $row[0], $row["CountryCode"]);

过程化风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = mysqli_connect("localhost", "my_user", "my_password", "world");

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = mysqli_query($mysqli, $query);

/* numeric array */
$row = mysqli_fetch_array($result, MYSQLI_NUM);
printf("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = mysqli_fetch_array($result, MYSQLI_ASSOC);
printf("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* associative and numeric array */
$row = mysqli_fetch_array($result, MYSQLI_BOTH);
printf("%s (%s)\n", $row[0], $row["CountryCode"]);

以上例程的输出类似于：

Kabul (AFG)
Qandahar (AFG)
Herat (AFG)

参见

  • mysqli_fetch_assoc() - Fetch a result row as an associative array
  • mysqli_fetch_row() - Get a result row as an enumerated array
  • mysqli_fetch_object() - Returns the current row of a result set as an object
  • mysqli_query() - 对数据库执行一次查询
  • mysqli_data_seek() - Adjusts the result pointer to an arbitrary row in the result


Fetch a result row as an associative array

  • ? mysqli_result::fetch_array
  • mysqli_result::fetch_field_direct ?
  • PHP Manual
  • mysqli_result
  • Fetch a result row as an associative array

mysqli_result::fetch_assoc

mysqli_fetch_assoc

(PHP 5, PHP 7)

mysqli_result::fetch_assoc -- mysqli_fetch_assoc — Fetch a result row as an associative array

说明

面向对象风格

public mysqli_result::fetch_assoc ( ) : array

过程化风格

mysqli_fetch_assoc ( mysqli_result $result ) : array

Returns an associative array that corresponds to the fetched row or null if there are no more rows.

Note: 此函数返回的字段名大小写敏感。

Note: 此函数将 NULL 字段设置为 PHP null 值。

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

Returns an associative array of values representing the fetched row in the result set, where each key in the array represents the name of one of the result set's columns or null if there are no more rows in result set.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using mysqli_fetch_row() or add alias names.

范例

Example #1 mysqli_result::fetch_assoc() example

面向对象风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

$query = "SELECT Name, CountryCode FROM City ORDER BY ID DESC";

$result = $mysqli->query($query);

/* fetch associative array */
while ($row = $result->fetch_assoc()) {
    printf("%s (%s)\n", $row["Name"], $row["CountryCode"]);
}

过程化风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = mysqli_connect("localhost", "my_user", "my_password", "world");

$query = "SELECT Name, CountryCode FROM City ORDER BY ID DESC";

$result = mysqli_query($mysqli, $query);

/* fetch associative array */
while ($row = mysqli_fetch_assoc($result)) {
    printf("%s (%s)\n", $row["Name"], $row["CountryCode"]);
}

以上例程的输出类似于：

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Example #2 Comparison of mysqli_result iterator and mysqli_result::fetch_assoc() usage

mysqli_result can be iterated using foreach. The result set will always be iterated from the first row, regardless of the current position.

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

$query = 'SELECT Name, CountryCode FROM City ORDER BY ID DESC';

// Using iterators
$result = $mysqli->query($query);
foreach ($result as $row) {
    printf("%s (%s)\n", $row["Name"], $row["CountryCode"]);
}

echo "\n==================\n";

// Not using iterators
$result = $mysqli->query($query);
while ($row = $result->fetch_assoc()) {
    printf("%s (%s)\n", $row["Name"], $row["CountryCode"]);
}

以上例程的输出类似于：

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

==================
Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

参见

  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_fetch_row() - Get a result row as an enumerated array
  • mysqli_fetch_object() - Returns the current row of a result set as an object
  • mysqli_query() - 对数据库执行一次查询
  • mysqli_data_seek() - Adjusts the result pointer to an arbitrary row in the result


Fetch meta-data for a single field

  • ? mysqli_result::fetch_assoc
  • mysqli_result::fetch_field ?
  • PHP Manual
  • mysqli_result
  • Fetch meta-data for a single field

mysqli_result::fetch_field_direct

mysqli_fetch_field_direct

(PHP 5, PHP 7)

mysqli_result::fetch_field_direct -- mysqli_fetch_field_direct — Fetch meta-data for a single field

说明

面向对象风格

public mysqli_result::fetch_field_direct ( int $fieldnr ) : object

过程化风格

mysqli_fetch_field_direct ( mysqli_result $result , int $fieldnr ) : object

Returns an object which contains field definition information from the specified result set.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

fieldnr

The field number. This value must be in the range from 0 to number of fields - 1.

返回值

Returns an object which contains field definition information or false if no field information for specified fieldnr is available.

Object attributes
Attribute | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | The default value for this field, represented as a string
max_length | The maximum width of the field for the result set.
length | The width of the field, as specified in the table definition.
charsetnr | The character set number for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for numeric fields)

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for column 'SurfaceArea' */
    $finfo = $result->fetch_field_direct(1);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n", $finfo->type);

    $result->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for column 'SurfaceArea' */
    $finfo = mysqli_fetch_field_direct($result, 1);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n", $finfo->type);

    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

参见

  • mysqli_num_fields() - Get the number of fields in a result
  • mysqli_fetch_field() - Returns the next field in the result set
  • mysqli_fetch_fields() - Returns an array of objects representing the fields in a result set


Returns the next field in the result set

  • ? mysqli_result::fetch_field_direct
  • mysqli_result::fetch_fields ?
  • PHP Manual
  • mysqli_result
  • Returns the next field in the result set

mysqli_result::fetch_field

mysqli_fetch_field

(PHP 5, PHP 7)

mysqli_result::fetch_field -- mysqli_fetch_field — Returns the next field in the result set

说明

面向对象风格

public mysqli_result::fetch_field ( ) : object

过程化风格

mysqli_fetch_field ( mysqli_result $result ) : object

Returns the definition of one column of a result set as an object. Call this function repeatedly to retrieve information about all columns in the result set.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

Returns an object which contains field definition information or false if no field information is available.

Object properties
Property | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | Reserved for default value, currently always ""
db | The name of the database
catalog | The catalog name, always "def"
max_length | The maximum width of the field for the result set.
length | The width of the field, as specified in the table definition.
charsetnr | The character set number for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    while ($finfo = $result->fetch_field()) {

        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all fields */
    while ($finfo = mysqli_fetch_field($result)) {

        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

参见

  • mysqli_num_fields() - Get the number of fields in a result
  • mysqli_fetch_field_direct() - Fetch meta-data for a single field
  • mysqli_fetch_fields() - Returns an array of objects representing the fields in a result set
  • mysqli_field_seek() - Set result pointer to a specified field offset


Returns an array of objects representing the fields in a result set

  • ? mysqli_result::fetch_field
  • mysqli_result::fetch_object ?
  • PHP Manual
  • mysqli_result
  • Returns an array of objects representing the fields in a result set

mysqli_result::fetch_fields

mysqli_fetch_fields

(PHP 5, PHP 7)

mysqli_result::fetch_fields -- mysqli_fetch_fields — Returns an array of objects representing the fields in a result set

说明

面向对象风格

public mysqli_result::fetch_fields ( ) : array

过程化风格

mysqli_fetch_fields ( mysqli_result $result ) : array

This function serves an identical purpose to the mysqli_fetch_field() function with the single difference that, instead of returning one object at a time for each field, the columns are returned as an array of objects.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

Returns an array of objects which contains field definition information or false if no field information is available.

Object properties
Property | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
max_length | The maximum width of the field for the result set.
length | The width of the field, in bytes, as specified in the table definition. Note that this number (bytes) might differ from your table definition value (characters), depending on the character set you use. For example, the character set utf8 has 3 bytes per character, so varchar(10) will return a length of 30 for utf8 (10*3), but return 10 for latin1 (10*1).
charsetnr | The character set number (id) for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("127.0.0.1", "root", "foofoo", "sakila");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

foreach (array('latin1', 'utf8') as $charset) {

    // Set character set, to show its impact on some values (e.g., length in bytes)
    $mysqli->set_charset($charset);

    $query = "SELECT actor_id, last_name from actor ORDER BY actor_id";

    echo "======================\n";
    echo "Character Set: $charset\n";
    echo "======================\n";

    if ($result = $mysqli->query($query)) {

        /* Get field information for all columns */
        $finfo = $result->fetch_fields();

        foreach ($finfo as $val) {
            printf("Name:      %s\n",   $val->name);
            printf("Table:     %s\n",   $val->table);
            printf("Max. Len:  %d\n",   $val->max_length);
            printf("Length:    %d\n",   $val->length);
            printf("charsetnr: %d\n",   $val->charsetnr);
            printf("Flags:     %d\n",   $val->flags);
            printf("Type:      %d\n\n", $val->type);
        }
        $result->free();
    }
}
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("127.0.0.1", "my_user", "my_password", "sakila");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

foreach (array('latin1', 'utf8') as $charset) {

    // Set character set, to show its impact on some values (e.g., length in bytes)
    mysqli_set_charset($link, $charset);

    $query = "SELECT actor_id, last_name from actor ORDER BY actor_id";

    echo "======================\n";
    echo "Character Set: $charset\n";
    echo "======================\n";

    if ($result = mysqli_query($link, $query)) {

        /* Get field information for all columns */
        $finfo = mysqli_fetch_fields($result);

        foreach ($finfo as $val) {
            printf("Name:      %s\n",   $val->name);
            printf("Table:     %s\n",   $val->table);
            printf("Max. Len:  %d\n",   $val->max_length);
            printf("Length:    %d\n",   $val->length);
            printf("charsetnr: %d\n",   $val->charsetnr);
            printf("Flags:     %d\n",   $val->flags);
            printf("Type:      %d\n\n", $val->type);
        }
        mysqli_free_result($result);
    }
}

mysqli_close($link);
?>

以上例程会输出：

======================
Character Set: latin1
======================
Name:      actor_id
Table:     actor
Max. Len:  3
Length:    5
charsetnr: 63
Flags:     49699
Type:      2

Name:      last_name
Table:     actor
Max. Len:  12
Length:    45
charsetnr: 8
Flags:     20489
Type:      253

======================
Character Set: utf8
======================
Name:      actor_id
Table:     actor
Max. Len:  3
Length:    5
charsetnr: 63
Flags:     49699
Type:      2

Name:      last_name
Table:     actor
Max. Len:  12
Length:    135
charsetnr: 33
Flags:     20489

参见

  • mysqli_num_fields() - Get the number of fields in a result
  • mysqli_fetch_field_direct() - Fetch meta-data for a single field
  • mysqli_fetch_field() - Returns the next field in the result set


Returns the current row of a result set as an object

  • ? mysqli_result::fetch_fields
  • mysqli_result::fetch_row ?
  • PHP Manual
  • mysqli_result
  • Returns the current row of a result set as an object

mysqli_result::fetch_object

mysqli_fetch_object

(PHP 5, PHP 7)

mysqli_result::fetch_object -- mysqli_fetch_object — Returns the current row of a result set as an object

说明

面向对象风格

public mysqli_result::fetch_object ( string $class_name = "stdClass" , array $params = ? ) : object

过程化风格

mysqli_fetch_object ( mysqli_result $result , string $class_name = "stdClass" , array $params = ? ) : object

Returns the current row result set as an object where the attributes of the object represent the names of the fields found within the result set.

Note: This function sets the properties of the object before calling the object constructor.

Note: 此函数返回的字段名大小写敏感。

Note: 此函数将 NULL 字段设置为 PHP null 值。

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

class_name

The name of the class to instantiate, set the properties of and return. If not specified, a stdClass object is returned.

params

An optional array of parameters to pass to the constructor for class_name objects.

返回值

Returns an object that corresponds to the fetched row or null if there are no more rows in result set.

范例

Example #1 mysqli_result::fetch_object() example

面向对象风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

$query = "SELECT Name, CountryCode FROM City ORDER BY ID DESC";

$result = $mysqli->query($query);

/* fetch object array */
while ($obj = $result->fetch_object()) {
    printf("%s (%s)\n", $obj->Name, $obj->CountryCode);
}

过程化风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

$query = "SELECT Name, CountryCode FROM City ORDER BY ID DESC";

$result = mysqli_query($link, $query);

/* fetch associative array */
while ($obj = mysqli_fetch_object($result)) {
    printf("%s (%s)\n", $obj->Name, $obj->CountryCode);
}

以上例程的输出类似于：

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

参见

  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_fetch_assoc() - Fetch a result row as an associative array
  • mysqli_fetch_row() - Get a result row as an enumerated array
  • mysqli_query() - 对数据库执行一次查询
  • mysqli_data_seek() - Adjusts the result pointer to an arbitrary row in the result


Get a result row as an enumerated array

  • ? mysqli_result::fetch_object
  • mysqli_result::$field_count ?
  • PHP Manual
  • mysqli_result
  • Get a result row as an enumerated array

mysqli_result::fetch_row

mysqli_fetch_row

(PHP 5, PHP 7)

mysqli_result::fetch_row -- mysqli_fetch_row — Get a result row as an enumerated array

说明

面向对象风格

public mysqli_result::fetch_row ( ) : mixed

过程化风格

mysqli_fetch_row ( mysqli_result $result ) : mixed

Fetches one row of data from the result set and returns it as an enumerated array, where each column is stored in an array offset starting from 0 (zero). Each subsequent call to this function will return the next row within the result set, or null if there are no more rows.

Note: 此函数将 NULL 字段设置为 PHP null 值。

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

mysqli_fetch_row() returns an array of values that corresponds to the fetched row or null if there are no more rows in result set.

范例

Example #1 mysqli_result::fetch_row() example

面向对象风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

$query = "SELECT Name, CountryCode FROM City ORDER BY ID DESC";

$result = $mysqli->query($query);

/* fetch object array */
while ($row = $result->fetch_row()) {
    printf("%s (%s)\n", $row[0], $row[1]);
}

过程化风格

<?php

mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);
$mysqli = mysqli_connect("localhost", "my_user", "my_password", "world");

$query = "SELECT Name, CountryCode FROM City ORDER BY ID DESC";

$result = mysqli_query($mysqli, $query);

/* fetch associative array */
while ($row = mysqli_fetch_row($result)) {
    printf("%s (%s)\n", $row[0], $row[1]);
}

以上例程的输出类似于：

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

参见

  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_fetch_assoc() - Fetch a result row as an associative array
  • mysqli_fetch_object() - Returns the current row of a result set as an object
  • mysqli_query() - 对数据库执行一次查询
  • mysqli_data_seek() - Adjusts the result pointer to an arbitrary row in the result


Get the number of fields in a result

  • ? mysqli_result::fetch_row
  • mysqli_result::field_seek ?
  • PHP Manual
  • mysqli_result
  • Get the number of fields in a result

mysqli_result::$field_count

mysqli_num_fields

(PHP 5, PHP 7)

mysqli_result::$field_count -- mysqli_num_fields — Get the number of fields in a result

说明

面向对象风格

int $mysqli_result->field_count;

过程化风格

mysqli_num_fields ( mysqli_result $result ) : int

Returns the number of fields from specified result set.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

The number of fields from a result set.

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determine number of fields in result set */
    $field_cnt = $result->field_count;

    printf("Result set has %d fields.\n", $field_cnt);

    /* close result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determine number of fields in result set */
    $field_cnt = mysqli_num_fields($result);

    printf("Result set has %d fields.\n", $field_cnt);

    /* close result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Result set has 5 fields.

参见

  • mysqli_fetch_field() - Returns the next field in the result set


Set result pointer to a specified field offset

  • ? mysqli_result::$field_count
  • mysqli_result::free ?
  • PHP Manual
  • mysqli_result
  • Set result pointer to a specified field offset

mysqli_result::field_seek

mysqli_field_seek

(PHP 5, PHP 7)

mysqli_result::field_seek -- mysqli_field_seek — Set result pointer to a specified field offset

说明

面向对象风格

public mysqli_result::field_seek ( int $fieldnr ) : bool

过程化风格

mysqli_field_seek ( mysqli_result $result , int $fieldnr ) : bool

Sets the field cursor to the given offset. The next call to mysqli_fetch_field() will retrieve the field definition of the column associated with that offset.

Note:

To seek to the beginning of a row, pass an offset value of zero.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

fieldnr

The field number. This value must be in the range from 0 to number of fields - 1.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for 2nd column */
    $result->field_seek(1);
    $finfo = $result->fetch_field();

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n\n", $finfo->type);

    $result->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for 2nd column */
    mysqli_field_seek($result, 1);
    $finfo = mysqli_fetch_field($result);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n\n", $finfo->type);

    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

参见

  • mysqli_fetch_field() - Returns the next field in the result set


Frees the memory associated with a result

  • ? mysqli_result::field_seek
  • mysqli_result::$lengths ?
  • PHP Manual
  • mysqli_result
  • Frees the memory associated with a result

mysqli_result::free

mysqli_result::close

mysqli_result::free_result

mysqli_free_result

(PHP 5, PHP 7)

mysqli_result::free -- mysqli_result::close -- mysqli_result::free_result -- mysqli_free_result — Frees the memory associated with a result

说明

面向对象风格

public mysqli_result::free ( ) : void
public mysqli_result::close ( ) : void
public mysqli_result::free_result ( ) : void

过程化风格

mysqli_free_result ( mysqli_result $result ) : void

Frees the memory associated with the result.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

没有返回值。

参见

  • mysqli_query() - 对数据库执行一次查询
  • mysqli_stmt_get_result() - Gets a result set from a prepared statement
  • mysqli_store_result() - 转移上一次查询返回的结果集
  • mysqli_use_result() - Initiate a result set retrieval


Returns the lengths of the columns of the current row in the result set

  • ? mysqli_result::free
  • mysqli_result::$num_rows ?
  • PHP Manual
  • mysqli_result
  • Returns the lengths of the columns of the current row in the result set

mysqli_result::$lengths

mysqli_fetch_lengths

(PHP 5, PHP 7)

mysqli_result::$lengths -- mysqli_fetch_lengths — Returns the lengths of the columns of the current row in the result set

说明

面向对象风格

array $mysqli_result->lengths;

过程化风格

mysqli_fetch_lengths ( mysqli_result $result ) : array

The mysqli_fetch_lengths() function returns an array containing the lengths of every column of the current row within the result set.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

An array of integers representing the size of each column (not including any terminating null characters). false if an error occurred.

mysqli_fetch_lengths() is valid only for the current row of the result set. It returns false if you call it before calling mysqli_fetch_row/array/object or after retrieving all rows in the result.

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = $mysqli->query($query)) {

    $row = $result->fetch_row();

    /* display column lengths */
    foreach ($result->lengths as $i => $val) {
        printf("Field %2d has Length %2d\n", $i+1, $val);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = mysqli_query($link, $query)) {

    $row = mysqli_fetch_row($result);

    /* display column lengths */
    foreach (mysqli_fetch_lengths($result) as $i => $val) {
        printf("Field %2d has Length %2d\n", $i+1, $val);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Field  1 has Length  3
Field  2 has Length  5
Field  3 has Length 13
Field  4 has Length  9
Field  5 has Length  6
Field  6 has Length  1
Field  7 has Length  6
Field  8 has Length  4
Field  9 has Length  6
Field 10 has Length  6
Field 11 has Length  5
Field 12 has Length 44
Field 13 has Length  7
Field 14 has Length  3
Field 15 has Length  2


Gets the number of rows in a result

  • ? mysqli_result::$lengths
  • MySQLi_Driver ?
  • PHP Manual
  • mysqli_result
  • Gets the number of rows in a result

mysqli_result::$num_rows

mysqli_num_rows

(PHP 5, PHP 7)

mysqli_result::$num_rows -- mysqli_num_rows — Gets the number of rows in a result

说明

面向对象风格

int $mysqli_result->num_rows;

过程化风格

mysqli_num_rows ( mysqli_result $result ) : int

Returns the number of rows in the result set.

The behaviour of mysqli_num_rows() depends on whether buffered or unbuffered result sets are being used. For unbuffered result sets, mysqli_num_rows() will not return the correct number of rows until all the rows in the result have been retrieved.

参数

result

仅以过程化样式：由 mysqli_query()，mysqli_store_result() 或 mysqli_use_result()返回的结果集标识。

返回值

Returns number of rows in the result set.

Note:

If the number of rows is greater than PHP_INT_MAX, the number will be returned as a string.

范例

Example #1 面向对象风格

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determine number of rows result set */
    $row_cnt = $result->num_rows;

    printf("Result set has %d rows.\n", $row_cnt);

    /* close result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Example #2 过程化风格

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determine number of rows result set */
    $row_cnt = mysqli_num_rows($result);

    printf("Result set has %d rows.\n", $row_cnt);

    /* close result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

以上例程会输出：

Result set has 239 rows.

参见

  • mysqli_affected_rows() - Gets the number of affected rows in a previous MySQL operation
  • mysqli_store_result() - 转移上一次查询返回的结果集
  • mysqli_use_result() - Initiate a result set retrieval
  • mysqli_query() - 对数据库执行一次查询


MySQLi_Driver类

(PHP 5, PHP 7)

简介

MySQLi 驱动.

类摘要

MySQLi_Driver {
/* 属性 */
public readonly string $client_info ;
public readonly string $client_version ;
public readonly string $driver_version ;
public readonly string $embedded ;
public bool $reconnect ;
public int $report_mode ;
/* 方法 */
public mysqli_driver::embedded_server_end ( ) : void
public mysqli_driver::embedded_server_start ( int $start , array $arguments , array $groups ) : bool
mysqli_report ( int $flags ) : bool
}

属性

client_info

客户端API头版本（比如：(string)"5.1.49"）

client_version

客户端版本（比如：(int)50149）

driver_version

Mysqli驱动版本（比如：(int)101009）

embedded

是否开启了MySQLi嵌入式支持。

reconnect

允许或阻止重连接（查看INI指令中的mysqli.reconnect）

report_mode

设置为MYSQLI_REPORT_OFF, MYSQLI_REPORT_ALL或者 MYSQLI_REPORT_STRICT （为错误抛出异常，译注：需要和MYSQLI_REPORT_ERROR联合使用）, MYSQLI_REPORT_ERROR (报告MYSQL错误)和 MYSQLI_REPORT_INDEX (报告索引相关的错误)的任意组合。 参阅mysqli_report().

Table of Contents

  • mysqli_driver::embedded_server_end — Stop embedded server
  • mysqli_driver::embedded_server_start — Initialize and start embedded server
  • mysqli_driver::$report_mode — Sets mysqli error reporting mode


Stop embedded server

  • ? MySQLi_Driver
  • mysqli_driver::embedded_server_start ?
  • PHP Manual
  • MySQLi_Driver
  • Stop embedded server

mysqli_driver::embedded_server_end

mysqli_embedded_server_end

(PHP 5 >= 5.1.0, PHP 7 < 7.4.0)

mysqli_driver::embedded_server_end -- mysqli_embedded_server_end — Stop embedded server

Warning

该函数已在 PHP 7.4.0 中 移除。

说明

面向对象风格

public mysqli_driver::embedded_server_end ( ) : void

过程化风格

mysqli_embedded_server_end ( ) : void
Warning

本函数还未编写文档，仅有参数列表。


Initialize and start embedded server

  • ? mysqli_driver::embedded_server_end
  • mysqli_driver::$report_mode ?
  • PHP Manual
  • MySQLi_Driver
  • Initialize and start embedded server

mysqli_driver::embedded_server_start

mysqli_embedded_server_start

(PHP 5 >= 5.1.0, PHP 7 < 7.4.0)

mysqli_driver::embedded_server_start -- mysqli_embedded_server_start — Initialize and start embedded server

Warning

该函数已在 PHP 7.4.0 中 移除。

说明

面向对象风格

public mysqli_driver::embedded_server_start ( int $start , array $arguments , array $groups ) : bool

过程化风格

mysqli_embedded_server_start ( int $start , array $arguments , array $groups ) : bool
Warning

本函数还未编写文档，仅有参数列表。


Sets mysqli error reporting mode

  • ? mysqli_driver::embedded_server_start
  • MySQLi_Warning ?
  • PHP Manual
  • MySQLi_Driver
  • Sets mysqli error reporting mode

mysqli_driver::$report_mode

mysqli_report

(PHP 5, PHP 7)

mysqli_driver::$report_mode -- mysqli_report — Sets mysqli error reporting mode

说明

面向对象风格

int $mysqli_driver->report_mode ;

过程化风格

mysqli_report ( int $flags ) : bool

Depending on the flags, it sets mysqli error reporting mode to exception, warning or none. When set to MYSQLI_REPORT_ALL or MYSQLI_REPORT_INDEX it will also inform about queries that don't use an index (or use a bad index).

The default setting is MYSQLI_REPORT_OFF.

参数

flags

Supported flags
Name | Description
MYSQLI_REPORT_OFF | Turns reporting off (the default)
MYSQLI_REPORT_ERROR | Report errors from mysqli function calls
MYSQLI_REPORT_STRICT | Throw mysqli_sql_exception for errors instead of warnings
MYSQLI_REPORT_INDEX | Report if no index or bad index was used in a query
MYSQLI_REPORT_ALL | Set all options (report all)

返回值

Returns true.

范例

Example #1 面向对象风格

<?php

/* activate reporting */
$driver = new mysqli_driver();
$driver->report_mode = MYSQLI_REPORT_ALL;

try {
    /* if the connection fails, a mysqli_sql_exception will be thrown */
    $mysqli = new mysqli("localhost", "my_user", "my_password", "my_db");

    /* this query should report an error */
    $result = $mysqli->query("SELECT Name FROM Nonexistingtable WHERE population > 50000");

    /* this query should report a bad index if the column population doesn't have an index */
    $result = $mysqli->query("SELECT Name FROM City WHERE population > 50000");
} catch (mysqli_sql_exception $e) {
    error_log($e->__toString());
}

Example #2 过程化风格

<?php

/* activate reporting */
mysqli_report(MYSQLI_REPORT_ALL);

try {
    $link = mysqli_connect("localhost", "my_user", "my_password", "my_db");

    /* this query should report an error */
    $result = mysqli_query($link, "SELECT Name FROM Nonexistingtable WHERE population > 50000");

    /* this query should report a bad index if the column population doesn't have an index */
    $result = mysqli_query($link, "SELECT Name FROM City WHERE population > 50000");
} catch (mysqli_sql_exception $e) {
    error_log($e->__toString());
}

Example #3 Error reporting except bad index errors

<?php

/* activate reporting */
mysqli_report(MYSQLI_REPORT_ERROR | MYSQLI_REPORT_STRICT);

try {
    /* if the connection fails, a mysqli_sql_exception will be thrown */
    $mysqli = new mysqli("localhost", "my_user", "my_password", "my_db");

    /* this query should report an error */
    $result = $mysqli->query("SELECT Name FROM Nonexistingtable WHERE population > 50000");

    /* this WILL NOT report any errors even if index is not available */
    $result = $mysqli->query("SELECT Name FROM City WHERE population > 50000");
} catch (mysqli_sql_exception $e) {
    error_log($e->__toString());
}

参见

  • mysqli_sql_exception
  • set_exception_handler() - 设置用户自定义的异常处理函数
  • error_reporting() - 设置应该报告何种 PHP 错误


MySQLi_Warning类

(PHP 5, PHP 7)

简介

表示一个 MySQL 警告。

类摘要

mysqli_warning {
/* 属性 */
public $message ;
public $sqlstate ;
public $errno ;
/* 方法 */
public next ( ) : bool
}

属性

message

消息字符串

sqlstate

SQL状态

errno

错误编号

Table of Contents

  • mysqli_warning::next — Fetch next warning


Fetch next warning

  • ? MySQLi_Warning
  • mysqli_sql_exception ?
  • PHP Manual
  • MySQLi_Warning
  • Fetch next warning

mysqli_warning::next

(PHP 5, PHP 7)

mysqli_warning::next — Fetch next warning

说明

public mysqli_warning::next ( ) : bool

Change warning information to the next warning if possible.

Once the warning has been set to the next warning, new values of properties message, sqlstate and errno of mysqli_warning are available.

参数

此函数没有参数。

返回值

Returns true if next warning was fetched successfully. If there are no more warnings, it will return false


mysqli异常类

(PHP 5, PHP 7)

简介

mysqli异常类

类摘要

mysqli_sql_exception extends RuntimeException {
/* 属性 */
protected string $sqlstate ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}

属性

sqlstate

出现错误的sql状态


别名和过时的 Mysqli 函数

Table of Contents

  • mysqli_connect — 别名 mysqli::__construct
  • mysqli_escape_string — 别名 mysqli_real_escape_string
  • mysqli_execute — mysqli_stmt_execute 的别名
  • mysqli_get_client_stats — 返回客户端进程统计信息
  • mysqli_get_links_stats — 返回打开和缓存的链接相关信息
  • mysqli_report — 别名 mysqli_driver->report_mode
  • mysqli::set_opt — Alias of mysqli_options


别名 mysqli::__construct

  • ? 别名和过时的 Mysqli 函数
  • mysqli_escape_string ?
  • PHP Manual
  • 别名和过时的 Mysqli 函数
  • 别名 mysqli::__construct

mysqli_connect

(PHP 5, PHP 7)

mysqli_connect — 别名 mysqli::__construct()

说明

此函数是该函数的别名： mysqli::__construct()

虽然说在 mysqli::__construct() 的文档 对 mysqli_connect() 函数也进行了详细的说明， 这里依然给出一个简单的示例：

范例

Example #1 mysqli_connect() 例程

<?php
$link = mysqli_connect("127.0.0.1", "my_user", "my_password", "my_db");

if (!$link) {
    echo "Error: Unable to connect to MySQL." . PHP_EOL;
    echo "Debugging errno: " . mysqli_connect_errno() . PHP_EOL;
    echo "Debugging error: " . mysqli_connect_error() . PHP_EOL;
    exit;
}

echo "Success: A proper connection to MySQL was made! The my_db database is great." . PHP_EOL;
echo "Host information: " . mysqli_get_host_info($link) . PHP_EOL;

mysqli_close($link);
?>

以上例程的输出类似于：

Success: A proper connection to MySQL was made! The my_db database is great.
Host information: localhost via TCP/IP


别名 mysqli_real_escape_string

  • ? mysqli_connect
  • mysqli_execute ?
  • PHP Manual
  • 别名和过时的 Mysqli 函数
  • 别名 mysqli_real_escape_string

mysqli_escape_string

(PHP 5, PHP 7)

mysqli_escape_string — 别名 mysqli_real_escape_string()

说明

此函数是该函数的别名： mysqli_real_escape_string().


mysqli_stmt_execute 的别名

  • ? mysqli_escape_string
  • mysqli_get_client_stats ?
  • PHP Manual
  • 别名和过时的 Mysqli 函数
  • mysqli_stmt_execute 的别名

mysqli_execute

(PHP 5, PHP 7)

mysqli_execute — mysqli_stmt_execute() 的别名

说明

此函数是该函数的别名： 这个函数是 mysqli_stmt_execute() 的一个别名。

注释

Note:

mysqli_execute() 已经被废弃并且将会被移除。

参见

  • mysqli_stmt_execute() - Executes a prepared Query


返回客户端进程统计信息

  • ? mysqli_execute
  • mysqli_get_links_stats ?
  • PHP Manual
  • 别名和过时的 Mysqli 函数
  • 返回客户端进程统计信息

mysqli_get_client_stats

(PHP 5 >= 5.3.0, PHP 7)

mysqli_get_client_stats — 返回客户端进程统计信息

说明

mysqli_get_client_stats ( ) : array

返回客户端进程统计信息 仅可用于 mysqlnd。

参数

返回值

如果成功，则返回一个数组包含客户端进程的统计信息，否则返回 false。

范例

Example #1 A mysqli_get_client_stats() 例程

<?php
$link = mysqli_connect();
print_r(mysqli_get_client_stats());
?>

以上例程的输出类似于：

Array
(
    [bytes_sent] => 43
    [bytes_received] => 80
    [packets_sent] => 1
    [packets_received] => 2
    [protocol_overhead_in] => 8
    [protocol_overhead_out] => 4
    [bytes_received_ok_packet] => 11
    [bytes_received_eof_packet] => 0
    [bytes_received_rset_header_packet] => 0
    [bytes_received_rset_field_meta_packet] => 0
    [bytes_received_rset_row_packet] => 0
    [bytes_received_prepare_response_packet] => 0
    [bytes_received_change_user_packet] => 0
    [packets_sent_command] => 0
    [packets_received_ok] => 1
    [packets_received_eof] => 0
    [packets_received_rset_header] => 0
    [packets_received_rset_field_meta] => 0
    [packets_received_rset_row] => 0
    [packets_received_prepare_response] => 0
    [packets_received_change_user] => 0
    [result_set_queries] => 0
    [non_result_set_queries] => 0
    [no_index_used] => 0
    [bad_index_used] => 0
    [slow_queries] => 0
    [buffered_sets] => 0
    [unbuffered_sets] => 0
    [ps_buffered_sets] => 0
    [ps_unbuffered_sets] => 0
    [flushed_normal_sets] => 0
    [flushed_ps_sets] => 0
    [ps_prepared_never_executed] => 0
    [ps_prepared_once_executed] => 0
    [rows_fetched_from_server_normal] => 0
    [rows_fetched_from_server_ps] => 0
    [rows_buffered_from_client_normal] => 0
    [rows_buffered_from_client_ps] => 0
    [rows_fetched_from_client_normal_buffered] => 0
    [rows_fetched_from_client_normal_unbuffered] => 0
    [rows_fetched_from_client_ps_buffered] => 0
    [rows_fetched_from_client_ps_unbuffered] => 0
    [rows_fetched_from_client_ps_cursor] => 0
    [rows_skipped_normal] => 0
    [rows_skipped_ps] => 0
    [copy_on_write_saved] => 0
    [copy_on_write_performed] => 0
    [command_buffer_too_small] => 0
    [connect_success] => 1
    [connect_failure] => 0
    [connection_reused] => 0
    [reconnect] => 0
    [pconnect_success] => 0
    [active_connections] => 1
    [active_persistent_connections] => 0
    [explicit_close] => 0
    [implicit_close] => 0
    [disconnect_close] => 0
    [in_middle_of_command_close] => 0
    [explicit_free_result] => 0
    [implicit_free_result] => 0
    [explicit_stmt_close] => 0
    [implicit_stmt_close] => 0
    [mem_emalloc_count] => 0
    [mem_emalloc_ammount] => 0
    [mem_ecalloc_count] => 0
    [mem_ecalloc_ammount] => 0
    [mem_erealloc_count] => 0
    [mem_erealloc_ammount] => 0
    [mem_efree_count] => 0
    [mem_malloc_count] => 0
    [mem_malloc_ammount] => 0
    [mem_calloc_count] => 0
    [mem_calloc_ammount] => 0
    [mem_realloc_count] => 0
    [mem_realloc_ammount] => 0
    [mem_free_count] => 0
    [proto_text_fetched_null] => 0
    [proto_text_fetched_bit] => 0
    [proto_text_fetched_tinyint] => 0
    [proto_text_fetched_short] => 0
    [proto_text_fetched_int24] => 0
    [proto_text_fetched_int] => 0
    [proto_text_fetched_bigint] => 0
    [proto_text_fetched_decimal] => 0
    [proto_text_fetched_float] => 0
    [proto_text_fetched_double] => 0
    [proto_text_fetched_date] => 0
    [proto_text_fetched_year] => 0
    [proto_text_fetched_time] => 0
    [proto_text_fetched_datetime] => 0
    [proto_text_fetched_timestamp] => 0
    [proto_text_fetched_string] => 0
    [proto_text_fetched_blob] => 0
    [proto_text_fetched_enum] => 0
    [proto_text_fetched_set] => 0
    [proto_text_fetched_geometry] => 0
    [proto_text_fetched_other] => 0
    [proto_binary_fetched_null] => 0
    [proto_binary_fetched_bit] => 0
    [proto_binary_fetched_tinyint] => 0
    [proto_binary_fetched_short] => 0
    [proto_binary_fetched_int24] => 0
    [proto_binary_fetched_int] => 0
    [proto_binary_fetched_bigint] => 0
    [proto_binary_fetched_decimal] => 0
    [proto_binary_fetched_float] => 0
    [proto_binary_fetched_double] => 0
    [proto_binary_fetched_date] => 0
    [proto_binary_fetched_year] => 0
    [proto_binary_fetched_time] => 0
    [proto_binary_fetched_datetime] => 0
    [proto_binary_fetched_timestamp] => 0
    [proto_binary_fetched_string] => 0
    [proto_binary_fetched_blob] => 0
    [proto_binary_fetched_enum] => 0
    [proto_binary_fetched_set] => 0
    [proto_binary_fetched_geometry] => 0
    [proto_binary_fetched_other] => 0
)

参见

  • 统计信息描述


返回打开和缓存的链接相关信息

  • ? mysqli_get_client_stats
  • mysqli_report ?
  • PHP Manual
  • 别名和过时的 Mysqli 函数
  • 返回打开和缓存的链接相关信息

mysqli_get_links_stats

(PHP 5 >= 5.6.0, PHP 7)

mysqli_get_links_stats — 返回打开和缓存的链接相关信息

说明

mysqli_get_links_stats ( ) : array

mysqli_get_links_stats() 返回已经打开和缓存的MySQL链接的相关信息。

参数

此函数没有参数。

返回值

mysqli_get_links_stats() 返回一个有三个元素的关联数组, 键如下:

total

类型 integer 所有状态链接的总数

active_plinks

类型 integer 不活跃的持久链接数

cached_plinks

类型 integer 不活跃的持久链接数


别名 mysqli_driver->report_mode

  • ? mysqli_get_links_stats
  • mysqli::set_opt ?
  • PHP Manual
  • 别名和过时的 Mysqli 函数
  • 别名 mysqli_driver->report_mode

mysqli_report

(PHP 5, PHP 7)

mysqli_report — 别名 mysqli_driver->report_mode

说明

此函数是该函数的别名： mysqli_driver->report_mode


Alias of mysqli_options

  • ? mysqli_report
  • Mysql_xdevapi ?
  • PHP Manual
  • 别名和过时的 Mysqli 函数
  • Alias of mysqli_options

mysqli::set_opt

mysqli_set_opt

(PHP 5, PHP 7)

mysqli::set_opt -- mysqli_set_opt — Alias of mysqli_options()

说明

此函数是该函数的别名： 这个函数是 mysqli_options() 的一个别名。


Mysql_xdevapi

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • Building / Compiling From Source
  • 预定义常量
  • 范例
  • Mysql_xdevapi 函数
    • expression — Bind prepared statement variables as parameters
    • getSession — Connect to a MySQL server
  • mysql_xdevapi\BaseResult — BaseResult interface
    • BaseResult::getWarnings — Fetch warnings from last operation
    • BaseResult::getWarningsCount — Fetch warning count from last operation
  • mysql_xdevapi\Client — Client class
    • mysql_xdevapi\Client::close — Close client
    • Client::__construct — Client constructor
    • Client::getClient — Get client session
  • mysql_xdevapi\Collection — Collection class
    • Collection::add — Add collection document
    • Collection::addOrReplaceOne — Add or replace collection document
    • Collection::__construct — Collection constructor
    • Collection::count — Get document count
    • Collection::createIndex — Create collection index
    • Collection::dropIndex — Drop collection index
    • Collection::existsInDatabase — Check if collection exists in database
    • Collection::find — Search for document
    • Collection::getName — Get collection name
    • Collection::getOne — Get one document
    • Collection::getSchema — Get schema object
    • Collection::getSession — Get session object
    • Collection::modify — Modify collection documents
    • Collection::remove — Remove collection documents
    • Collection::removeOne — Remove one collection document
    • Collection::replaceOne — Replace one collection document
  • mysql_xdevapi\CollectionAdd — CollectionAdd class
    • CollectionAdd::__construct — CollectionAdd constructor
    • CollectionAdd::execute — Execute the statement
  • mysql_xdevapi\CollectionFind — CollectionFind class
    • CollectionFind::bind — Bind value to query placeholder
    • CollectionFind::__construct — CollectionFind constructor
    • CollectionFind::execute — Execute the statement
    • CollectionFind::fields — Set document field filter
    • CollectionFind::groupBy — Set grouping criteria
    • CollectionFind::having — Set condition for aggregate functions
    • CollectionFind::limit — Limit number of returned documents
    • CollectionFind::lockExclusive — Execute operation with EXCLUSIVE LOCK
    • CollectionFind::lockShared — Execute operation with SHARED LOCK
    • CollectionFind::offset — Skip given number of elements to be returned
    • CollectionFind::sort — Set the sorting criteria
  • mysql_xdevapi\CollectionModify — CollectionModify class
    • CollectionModify::arrayAppend — Append element to an array field
    • CollectionModify::arrayInsert — Insert element into an array field
    • CollectionModify::bind — Bind value to query placeholder
    • CollectionModify::__construct — CollectionModify constructor
    • CollectionModify::execute — Execute modify operation
    • CollectionModify::limit — Limit number of modified documents
    • CollectionModify::patch — Patch document
    • CollectionModify::replace — Replace document field
    • CollectionModify::set — Set document attribute
    • CollectionModify::skip — Skip elements
    • CollectionModify::sort — Set the sorting criteria
    • CollectionModify::unset — Unset the value of document fields
  • mysql_xdevapi\CollectionRemove — CollectionRemove class
    • CollectionRemove::bind — Bind value to placeholder
    • CollectionRemove::__construct — CollectionRemove constructor
    • CollectionRemove::execute — Execute remove operation
    • CollectionRemove::limit — Limit number of documents to remove
    • CollectionRemove::sort — Set the sorting criteria
  • mysql_xdevapi\ColumnResult — ColumnResult class
    • ColumnResult::__construct — ColumnResult constructor
    • ColumnResult::getCharacterSetName — Get character set
    • ColumnResult::getCollationName — Get collation name
    • ColumnResult::getColumnLabel — Get column label
    • ColumnResult::getColumnName — Get column name
    • ColumnResult::getFractionalDigits — Get fractional digit length
    • ColumnResult::getLength — Get column field length
    • ColumnResult::getSchemaName — Get schema name
    • ColumnResult::getTableLabel — Get table label
    • ColumnResult::getTableName — Get table name
    • ColumnResult::getType — Get column type
    • ColumnResult::isNumberSigned — Check if signed type
    • ColumnResult::isPadded — Check if padded
  • mysql_xdevapi\CrudOperationBindable — CrudOperationBindable interface
    • CrudOperationBindable::bind — Bind value to placeholder
  • mysql_xdevapi\CrudOperationLimitable — CrudOperationLimitable interface
    • CrudOperationLimitable::limit — Set result limit
  • mysql_xdevapi\CrudOperationSkippable — CrudOperationSkippable interface
    • CrudOperationSkippable::skip — Number of operations to skip
  • mysql_xdevapi\CrudOperationSortable — CrudOperationSortable interface
    • CrudOperationSortable::sort — Sort results
  • mysql_xdevapi\DatabaseObject — DatabaseObject interface
    • DatabaseObject::existsInDatabase — Check if object exists in database
    • DatabaseObject::getName — Get object name
    • DatabaseObject::getSession — Get session name
  • mysql_xdevapi\DocResult — DocResult class
    • DocResult::__construct — DocResult constructor
    • DocResult::fetchAll — Get all rows
    • DocResult::fetchOne — Get one row
    • DocResult::getWarnings — Get warnings from last operation
    • DocResult::getWarningsCount — Get warning count from last operation
  • mysql_xdevapi\Exception — Exception class
  • mysql_xdevapi\Executable — Executable interface
    • Executable::execute — Execute statement
  • mysql_xdevapi\ExecutionStatus — ExecutionStatus class
    • ExecutionStatus::__construct — ExecutionStatus constructor
  • mysql_xdevapi\Expression — Expression class
    • Expression::__construct — Expression constructor
  • mysql_xdevapi\Result — Result class
    • Result::__construct — Result constructor
    • Result::getAffectedItemsCount — Get affected row count
    • Result::getAutoIncrementValue — Get autoincremented value
    • Result::getGeneratedIds — Get generated ids
    • Result::getWarnings — Get warnings from last operation
    • Result::getWarningsCount — Get warning count from last operation
  • mysql_xdevapi\RowResult — RowResult class
    • RowResult::__construct — RowResult constructor
    • RowResult::fetchAll — Get all rows from result
    • RowResult::fetchOne — Get row from result
    • RowResult::getColumnsCount — Get column count
    • RowResult::getColumnNames — Get all column names
    • RowResult::getColumns — Get column metadata
    • RowResult::getWarnings — Get warnings from last operation
    • RowResult::getWarningsCount — Get warning count from last operation
  • mysql_xdevapi\Schema — Schema class
    • Schema::__construct — constructor
    • Schema::createCollection — Add collection to schema
    • Schema::dropCollection — Drop collection from schema
    • Schema::existsInDatabase — Check if exists in database
    • Schema::getCollection — Get collection from schema
    • Schema::getCollectionAsTable — Get collection table object
    • Schema::getCollections — Get all schema collections
    • Schema::getName — Get schema name
    • Schema::getSession — Get schema session
    • Schema::getTable — Get schema table
    • Schema::getTables — Get schema tables
  • mysql_xdevapi\SchemaObject — SchemaObject interface
    • SchemaObject::getSchema — Get schema object
  • mysql_xdevapi\Session — Session class
    • Session::close — Close session
    • Session::commit — Commit transaction
    • Session::__construct — Description constructor
    • Session::createSchema — Create new schema
    • Session::dropSchema — Drop a schema
    • Session::generateUUID — Get new UUID
    • Session::getDefaultSchema — Get default schema name
    • Session::getSchema — Get a new schema object
    • Session::getSchemas — Get the schemas
    • Session::getServerVersion — Get server version
    • Session::listClients — Get client list
    • Session::quoteName — Add quotes
    • Session::releaseSavepoint — Release set savepoint
    • Session::rollback — Rollback transaction
    • Session::rollbackTo — Rollback transaction to savepoint
    • Session::setSavepoint — Create savepoint
    • Session::sql — Execute SQL query
    • Session::startTransaction — Start transaction
  • mysql_xdevapi\SqlStatement — SqlStatement class
    • SqlStatement::bind — Bind statement parameters
    • SqlStatement::__construct — Description constructor
    • SqlStatement::execute — Execute the operation
    • SqlStatement::getNextResult — Get next result
    • SqlStatement::getResult — Get result
    • SqlStatement::hasMoreResults — Check for more results
  • mysql_xdevapi\SqlStatementResult — SqlStatementResult class
    • SqlStatementResult::__construct — Description constructor
    • SqlStatementResult::fetchAll — Get all rows from result
    • SqlStatementResult::fetchOne — Get single row
    • SqlStatementResult::getAffectedItemsCount — Get affected row count
    • SqlStatementResult::getColumnsCount — Get column count
    • SqlStatementResult::getColumnNames — Get column names
    • SqlStatementResult::getColumns — Get columns
    • SqlStatementResult::getGeneratedIds — Get generated ids
    • SqlStatementResult::getLastInsertId — Get last insert id
    • SqlStatementResult::getWarnings — Get warnings from last operation
    • SqlStatementResult::getWarningsCount — Get warning count from last operation
    • SqlStatementResult::hasData — Check if result has data
    • SqlStatementResult::nextResult — Get next result
  • mysql_xdevapi\Statement — Statement class
    • Statement::__construct — Description constructor
    • Statement::getNextResult — Get next result
    • Statement::getResult — Get result
    • Statement::hasMoreResults — Check if more results
  • mysql_xdevapi\Table — Table class
    • Table::__construct — Table constructor
    • Table::count — Get row count
    • Table::delete — Delete rows from table
    • Table::existsInDatabase — Check if table exists in database
    • Table::getName — Get table name
    • Table::getSchema — Get table schema
    • Table::getSession — Get table session
    • Table::insert — Insert table rows
    • Table::isView — Check if table is view
    • Table::select — Select rows from table
    • Table::update — Update rows in table
  • mysql_xdevapi\TableDelete — TableDelete class
    • TableDelete::bind — Bind delete query parameters
    • TableDelete::__construct — TableDelete constructor
    • TableDelete::execute — Execute delete query
    • TableDelete::limit — Limit deleted rows
    • TableDelete::orderby — Set delete sort criteria
    • TableDelete::where — Set delete search condition
  • mysql_xdevapi\TableInsert — TableInsert class
    • TableInsert::__construct — TableInsert constructor
    • TableInsert::execute — Execute insert query
    • TableInsert::values — Add insert row values
  • mysql_xdevapi\TableSelect — TableSelect class
    • TableSelect::bind — Bind select query parameters
    • TableSelect::__construct — TableSelect constructor
    • TableSelect::execute — Execute select statement
    • TableSelect::groupBy — Set select grouping criteria
    • TableSelect::having — Set select having condition
    • TableSelect::limit — Limit selected rows
    • TableSelect::lockExclusive — Execute EXCLUSIVE LOCK
    • TableSelect::lockShared — Execute SHARED LOCK
    • TableSelect::offset — Set limit offset
    • TableSelect::orderby — Set select sort criteria
    • TableSelect::where — Set select search condition
  • mysql_xdevapi\TableUpdate — TableUpdate class
    • TableUpdate::bind — Bind update query parameters
    • TableUpdate::__construct — TableUpdate constructor
    • TableUpdate::execute — Execute update query
    • TableUpdate::limit — Limit update row count
    • TableUpdate::orderby — Set sorting criteria
    • TableUpdate::set — Add field to be updated
    • TableUpdate::where — Set search filter
  • mysql_xdevapi\Warning — Warning class
    • Warning::__construct — Warning constructor


简介

This extension provides access to the MySQL Document Store via the X DevAPI. The X DevAPI is a common API provided by multiple MySQL Connectors providing easy access to relational tables as well as collections of documents, which are represented in JSON, from a API with CRUD-style operations.

The X DevAPI uses the X Protocol, the new generation client-server protocol of the MySQL 8.0 server.

For general information about the MySQL Document Store, please refer to the » MySQL Document Store chapter in the MySQL manual.


安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • Building / Compiling From Source


需求

This extension requires a MySQL 8+ server with the X plugin enabled (default).

Prerequisite libraries for compiling this extension are: Boost (1.53.0 or higher), OpenSSL, and Protobuf.


安装

此 » PECL 扩展未与 PHP 捆绑。

An example installation procedure on Ubuntu 18.04 with PHP 7.2:

// Dependencies
$ apt install build-essential libprotobuf-dev libboost-dev openssl protobuf-compiler liblz4-tool zstd

// PHP with the desired extensions; php7.2-dev is required to compile
$ apt install php7.2-cli php7.2-dev php7.2-mysql php7.2-pdo php7.2-xml

// Compile the extension
$ pecl install mysql_xdevapi

The pecl install command does not enable PHP extensions (by default) and enabling PHP extensions can be done in several ways. Another PHP 7.2 on Ubuntu 18.04 example:

// Create its own ini file
$ echo "extension=mysql_xdevapi.so" > /etc/php/7.2/mods-available/mysql_xdevapi.ini

// Use the 'phpenmod' command (note: it's Debian/Ubuntu specific)
$ phpenmod -v 7.2 -s ALL mysql_xdevapi

// A 'phpenmod' alternative is to manually symlink it
// $ ln -s /etc/php/7.2/mods-available/mysql_xdevapi.ini /etc/php/7.2/cli/conf.d/20-mysql_xdevapi.ini

// Let's see which MySQL extensions are enabled now
$ php -m |grep mysql

mysql_xdevapi
mysqli
mysqlnd
pdo_mysql

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mysql_xdevapi.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Mysql_xdevapi 配置选项
名字 | 默认 | 可修改范围 | 更新日志
xmysqlnd.collect_memory_statistics | 0 | PHP_INI_SYSTEM |
xmysqlnd.collect_statistics | 1 | PHP_INI_ALL |
xmysqlnd.debug |  | PHP_INI_SYSTEM |
xmysqlnd.mempool_default_size | 16000 | PHP_INI_ALL |
xmysqlnd.net_read_timeout | 31536000 | PHP_INI_SYSTEM |
xmysqlnd.trace_alloc |  | PHP_INI_SYSTEM |

这是配置指令的简短说明。

xmysqlnd.collect_memory_statistics int

xmysqlnd.collect_statistics int

xmysqlnd.debug string

xmysqlnd.mempool_default_size int

xmysqlnd.net_read_timeout int

xmysqlnd.trace_alloc string


Building / Compiling From Source

Considerations for compiling this extension from source.

  • The extension name is 'mysql_xdevapi', so use --enable-mysql-xdevapi.

  • Boost: required, optionally use the --with-boost=DIR configure option or set the MYSQL_XDEVAPI_BOOST_ROOT environment variable. Only the boost header files are required; not the binaries.

  • Google Protocol Buffers (protobuf): required, optionally use the --with-protobuf=DIR configure option or set the MYSQL_XDEVAPI_PROTOBUF_ROOT environment variable.

    Optionally use make protobufs to generate protobuf files (*.pb.cc/.h), and make clean-protobufs to delete generate protobuf files.

    Windows specific protobuf note: depending on your environment, the static library with a multi-threaded DLL runtime may be needed. To prepare, use the following options: -Dprotobuf_MSVC_STATIC_RUNTIME=OFF -Dprotobuf_BUILD_SHARED_LIBS=OFF

  • Google Protocol Buffers / protocol compiler (protoc): required, ensure that proper 'protoc' is available in the PATH while building. It is especially important as Windows PHP SDK batch scripts may overwrite the environment.

  • Bison: required, and available from the PATH.

    Windows specific bison note: we strongly recommended that bison delivered with the chosen PHP SDKis used else an error similar to "zend_globals_macros.h(39): error C2375: 'zendparse': redefinition; different linkage Zend/zend_language_parser.h(214): note: see declaration of 'zendparse'" may be the result. Also, Windows PHP SDK batch scripts may overwrite the environment.

  • Windows Specific Notes: To prepare the environment, see the official Windows build documentation for » the current SDK.

    We recommend using the backslash '\\' instead of a slash '/' for all paths.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

MYSQLX_CLIENT_SSL (int)
MYSQLX_TYPE_DECIMAL (int)
MYSQLX_TYPE_TINY (int)
MYSQLX_TYPE_SHORT (int)
MYSQLX_TYPE_SMALLINT (int)
MYSQLX_TYPE_MEDIUMINT (int)
MYSQLX_TYPE_INT (int)
MYSQLX_TYPE_BIGINT (int)
MYSQLX_TYPE_LONG (int)
MYSQLX_TYPE_FLOAT (int)
MYSQLX_TYPE_DOUBLE (int)
MYSQLX_TYPE_NULL (int)
MYSQLX_TYPE_TIMESTAMP (int)
MYSQLX_TYPE_LONGLONG (int)
MYSQLX_TYPE_INT24 (int)
MYSQLX_TYPE_DATE (int)
MYSQLX_TYPE_TIME (int)
MYSQLX_TYPE_DATETIME (int)
MYSQLX_TYPE_YEAR (int)
MYSQLX_TYPE_NEWDATE (int)
MYSQLX_TYPE_ENUM (int)
MYSQLX_TYPE_SET (int)
MYSQLX_TYPE_TINY_BLOB (int)
MYSQLX_TYPE_MEDIUM_BLOB (int)
MYSQLX_TYPE_LONG_BLOB (int)
MYSQLX_TYPE_BLOB (int)
MYSQLX_TYPE_VAR_STRING (int)
MYSQLX_TYPE_STRING (int)
MYSQLX_TYPE_CHAR (int)
MYSQLX_TYPE_BYTES (int)
MYSQLX_TYPE_INTERVAL (int)
MYSQLX_TYPE_GEOMETRY (int)
MYSQLX_TYPE_JSON (int)
MYSQLX_TYPE_NEWDECIMAL (int)
MYSQLX_TYPE_BIT (int)
MYSQLX_LOCK_DEFAULT (int)
MYSQLX_LOCK_NOWAIT (int)
MYSQLX_LOCK_SKIP_LOCKED (int)


范例

The central entry point to the X DevAPI is the mysql_xdevapi\getSession() function, which receives a URI to a MySQL 8.0 Server and returns a mysql_xdevap\Session object.

Example #1 Connecting to a MySQL Server

<?php
try {
    $session = mysql_xdevapi\getSession("mysqlx://user:password@host");
} catch(Exception $e) {
    die("Connection could not be established: " . $e->getMessage());
}

// ... use $session
?>

The session provides full access to the API. For a new MySQL Server installation, the first step is to create a database schema with a collection to store data:

Example #2 Creating a Schema and Collection on the MySQL Server

<?php
$schema = $session->createSchema("test");
$collection = $schema->createCollection("example");
?>

When storing data, typically json_encode() is used to encode the data into JSON, which can then be stored inside a collection.

The following example stores data into the collection we created earlier, and then retrieve parts of it again.

Example #3 Storing and Retrieving Data

<?php
$marco = [
  "name" => "Marco",
  "age"  => 19,
  "job"  => "Programmer"
];
$mike = [
  "name" => "Mike",
  "age"  => 39,
  "job"  => "Manager"
];

$schema = $session->getSchema("test");
$collection = $schema->getCollection("example");

$collection->add($marco, $mike)->execute();

var_dump($collection->find("name = 'Mike'")->execute()->fetchOne());
?>

以上例程的输出类似于：

array(4) {
  ["_id"]=>
  string(28) "00005ad66aaf0000000000000003"
  ["age"]=>
  int(39)
  ["job"]=>
  string(7) "Manager"
  ["name"]=>
  string(4) "Mike"
}

The example demonstrates that the MySQL Server adds an extra field named _id, which serves as primary key to the document.

The example also demonstrates that retrieved data is sorted alphabetically. That specific order comes from the efficient binary storage inside the MySQL server, but it should not be relied upon. Refer to the MySQL JSON datatype documentation for details.

Optionally use PHP's iterators fetch multiple documents:

Example #4 Fetching and Iterating Multiple Documents

<?php
$result = $collection->find()->execute();
foreach ($result as $doc) {
  echo "${doc["name"]} is a ${doc["job"]}.\n";
}
?>

以上例程的输出类似于：

Marco is a Programmer.
Mike is a Manager.


Mysql_xdevapi 函数

Table of Contents

  • expression — Bind prepared statement variables as parameters
  • getSession — Connect to a MySQL server


Bind prepared statement variables as parameters

  • ? Mysql_xdevapi 函数
  • getSession ?
  • PHP Manual
  • Mysql_xdevapi 函数
  • Bind prepared statement variables as parameters

expression

(No version information available, might only be in Git)

expression — Bind prepared statement variables as parameters

说明

mysql_xdevapi\expression ( string $expression ) : object

Warning

本函数还未编写文档，仅有参数列表。

参数

expression

返回值

范例

Example #1 mysql_xdevapi\Expression() example

<?php
$expression = mysql_xdevapi\Expression("[age,job]");

$res  = $coll->find("age > 30")->fields($expression)->limit(3)->execute();
$data = $res->fetchAll();

print_r($data);
?>

以上例程的输出类似于：

<?php


Connect to a MySQL server

  • ? expression
  • mysql_xdevapi\BaseResult ?
  • PHP Manual
  • Mysql_xdevapi 函数
  • Connect to a MySQL server

getSession

(No version information available, might only be in Git)

getSession — Connect to a MySQL server

说明

mysql_xdevapi\getSession ( string $uri ) : mysql_xdevapi\Session

Connects to the MySQL server.

参数

uri

The URI to the MySQL server, such as mysqlx://user:password@host.

URI format:

scheme://[user[:[password]]@]target[:port][?attribute1=value1&attribute2=value2...

  • scheme: required, the connection protocol

    In mysql_xdevapi it is always 'mysqlx' (for X Protocol)

  • user: optional, the MySQL user account for authentication

  • password: optional, the MySQL user's password for authentication

  • target: required, the server instance the connection refers to:

    * TCP connection (host name, IPv4 address, or IPv6 address)

    * Unix socket path (local file path)

    * Windows named-pipe (local file path)

  • port: optional, network port of MySQL server.

    by default port for X Protocol is 33060

  • ?attribute=value: this element is optional and specifies a data dictionary that contains different options, including:

    • The auth (authentication mechanism) attribute as it relates to encrypted connections. For additional information, see » Command Options for Encrypted Connections. The following 'auth' values are supported: plain, mysql41, external, and sha256_mem.

    • The connect-timeout attribute affects the connection and not subsequent operations. It is set per connection whether on a single or multiple hosts.

      Pass in a positive integer to define the connection timeout in seconds, or pass in 0 (zero) to disable the timeout (infinite). Not defining connect-timeout uses the default value of 10.

      Related, the MYSQLX_CONNECTION_TIMEOUT (timeout in seconds) and MYSQLX_TEST_CONNECTION_TIMEOUT (used while running tests) environment variables can be set and used instead of connect-timeout in the URI. The connect-timeout URI option has precedence over these environment variables.

    • The optional compression attribute accepts these values: preferred (client negotiates with server to find a supported algorithm; connection is uncompressed if a mutually supported algorithm is not found), required (like "preferred", but connection is terminated if a mutually supported algorithm is not found), or disabled (connection is uncompressed). Defaults to preferred.

      This option was added in version 8.0.20.

    • The optional compression-algorithms attribute defines the desired compression algorithms (and their preferred usage order): zstd_stream (alias: zstd), lz4_message (alias: lz4), or deflate_stream (aliases: deflate or zlib). By default, the order used (depending on system availability) is lz4_message, zstd_stream, then deflate_stream. For example, passing in compression-algorithms=[lz4,zstd_stream] uses lz4 if it's available, otherwise zstd_stream is used. If both are unavailable then behavior depends on the compression value e.g., if compression=required then it'll fail with an error.

      This option was added in version 8.0.22.

Example #1 URI examples

mysqlx://foobar
mysqlx://root@localhost?socket=%2Ftmp%2Fmysqld.sock%2F
mysqlx://foo:bar@localhost:33060
mysqlx://foo:bar@localhost:33160?ssl-mode=disabled
mysqlx://foo:bar@localhost:33260?ssl-mode=required
mysqlx://foo:bar@localhost:33360?ssl-mode=required&auth=mysql41
mysqlx://foo:bar@(/path/to/socket)
mysqlx://foo:bar@(/path/to/socket)?auth=sha256_mem
mysqlx://foo:bar@[localhost:33060, 127.0.0.1:33061]
mysqlx://foobar?ssl-ca=(/path/to/ca.pem)&ssl-crl=(/path/to/crl.pem)
mysqlx://foo:bar@[localhost:33060, 127.0.0.1:33061]?ssl-mode=disabled
mysqlx://foo:bar@localhost:33160/?connect-timeout=0
mysqlx://foo:bar@localhost:33160/?connect-timeout=10&compression=required
mysqlx://foo:bar@localhost:33160/?connect-timeout=10&compression=required&compression-algorithms=[lz4,zstd_stream]

For related information, see MySQL Shell's » Connecting using a URI String.

返回值

A Session object.

错误／异常

A connection failure throws an Exception.

范例

Example #2 mysql_xdevapi\getSession() example

<?php
try {
    $session = mysql_xdevapi\getSession("mysqlx://user:password@host");
} catch(Exception $e) {
    die("Connection could not be established: " . $e->getMessage());
}

$schemas = $session->getSchemas();
print_r($schemas);

$mysql_version = $session->getServerVersion();
print_r($mysql_version);

var_dump($collection->find("name = 'Alfred'")->execute()->fetchOne());
?>

以上例程的输出类似于：

Array
(
    [0] => mysql_xdevapi\Schema Object
        (
            [name] => helloworld
        )
    [1] => mysql_xdevapi\Schema Object
        (
            [name] => information_schema
        )
    [2] => mysql_xdevapi\Schema Object
        (
            [name] => mysql
        )
    [3] => mysql_xdevapi\Schema Object
        (
            [name] => performance_schema
        )
    [4] => mysql_xdevapi\Schema Object
        (
            [name] => sys
        )
)

80012

array(4) {
  ["_id"]=>
  string(28) "00005ad66abf0001000400000003"
  ["age"]=>
  int(42)
  ["job"]=>
  string(7) "Butler"
  ["name"]=>
  string(4) "Alfred"
}


BaseResult interface

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\BaseResult {
/* 方法 */
abstract public getWarnings ( ) : array
abstract public getWarningsCount ( ) : int
}

Table of Contents

  • BaseResult::getWarnings — Fetch warnings from last operation
  • BaseResult::getWarningsCount — Fetch warning count from last operation


Fetch warnings from last operation

  • ? mysql_xdevapi\BaseResult
  • BaseResult::getWarningsCount ?
  • PHP Manual
  • mysql_xdevapi\BaseResult
  • Fetch warnings from last operation

BaseResult::getWarnings

(No version information available, might only be in Git)

BaseResult::getWarnings — Fetch warnings from last operation

说明

abstract public mysql_xdevapi\BaseResult::getWarnings ( ) : array

Fetches warnings generated by MySQL server's last operation.

参数

此函数没有参数。

返回值

An array of Warning objects from the last operation. Each object defines an error 'message', error 'level', and error 'code'. An empty array is returned if no errors are present.

范例

Example #1 mysql_xdevapi\RowResult::getWarnings() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();

$schema = $session->getSchema("foo");
$table  = $schema->getTable("test_table");

$table->insert(['x'])->values([1])->values([2])->execute();

$res = $table->select(['x/0 as bad_x'])->execute();
$warnings = $res->getWarnings();

print_r($warnings);
?>

以上例程的输出类似于：

Array
(
    [0] => mysql_xdevapi\Warning Object
        (
            [message] => Division by 0
            [level] => 2
            [code] => 1365
        )
    [1] => mysql_xdevapi\Warning Object
        (
            [message] => Division by 0
            [level] => 2
            [code] => 1365
        )
)


Fetch warning count from last operation

  • ? BaseResult::getWarnings
  • mysql_xdevapi\Client ?
  • PHP Manual
  • mysql_xdevapi\BaseResult
  • Fetch warning count from last operation

BaseResult::getWarningsCount

(No version information available, might only be in Git)

BaseResult::getWarningsCount — Fetch warning count from last operation

说明

abstract public mysql_xdevapi\BaseResult::getWarningsCount ( ) : int

Returns the number of warnings raised by the last operation. Specifically, these warnings are raised by the MySQL server.

参数

此函数没有参数。

返回值

The number of warnings from the last operation.

范例

Example #1 mysql_xdevapi\RowResult::getWarningsCount() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS foo")->execute();
$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();

$schema = $session->getSchema("foo");
$table  = $schema->getTable("test_table");

$table->insert(['x'])->values([1])->values([2])->execute();

$res = $table->select(['x/0 as bad_x'])->execute();

echo $res->getWarningsCount();
?>

以上例程的输出类似于：

2


Client class

(No version information available, might only be in Git)

简介

Provides access to the connection pool.

类摘要

mysql_xdevapi\Client {
/* 方法 */
public close ( ) : bool
public getSession ( ) : mysql_xdevapi\Session
}

Table of Contents

  • mysql_xdevapi\Client::close — Close client
  • Client::__construct — Client constructor
  • Client::getClient — Get client session


Close client

  • ? mysql_xdevapi\Client
  • Client::__construct ?
  • PHP Manual
  • mysql_xdevapi\Client
  • Close client

mysql_xdevapi\Client::close

(No version information available, might only be in Git)

mysql_xdevapi\Client::close — Close client

说明

public mysql_xdevapi\Client::close ( ) : bool

Close all client connections with the server.

参数

此函数没有参数。

返回值

true if connections are closed.


Client constructor

  • ? mysql_xdevapi\Client::close
  • Client::getClient ?
  • PHP Manual
  • mysql_xdevapi\Client
  • Client constructor

Client::__construct

(No version information available, might only be in Git)

Client::__construct — Client constructor

说明

private mysql_xdevapi\Client::__construct ( )

Construct a client object.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\Client::__construct() example

<?php
$pooling_options = '{
  "enabled": true,
    "maxSize": 10,
    "maxIdleTime": 3600,
    "queueTimeOut": 1000
}';
$client = mysql_xdevapi\getClient($connection_uri, $pooling_options);
$session = $client->getSession();


Get client session

  • ? Client::__construct
  • mysql_xdevapi\Collection ?
  • PHP Manual
  • mysql_xdevapi\Client
  • Get client session

Client::getClient

(No version information available, might only be in Git)

Client::getClient — Get client session

说明

public mysql_xdevapi\Client::getSession ( ) : mysql_xdevapi\Session

Get session associated with the client.

参数

此函数没有参数。

返回值

A Session object.


Collection class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Collection implements mysql_xdevapi\SchemaObject {
/* 属性 */
public $name ;
/* 方法 */
public add ( mixed $document ) : mysql_xdevapi\CollectionAdd
public addOrReplaceOne ( string $id , string $doc ) : mysql_xdevapi\Result
public count ( ) : int
public createIndex ( string $index_name , string $index_desc_json ) : void
public dropIndex ( string $index_name ) : bool
public existsInDatabase ( ) : bool
public find ( string $search_condition = ? ) : mysql_xdevapi\CollectionFind
public getName ( ) : string
public getOne ( string $id ) : Document
public getSchema ( ) : Schema Object
public getSession ( ) : Session
public modify ( string $search_condition ) : mysql_xdevapi\CollectionModify
public remove ( string $search_condition ) : mysql_xdevapi\CollectionRemove
public removeOne ( string $id ) : mysql_xdevapi\Result
public replaceOne ( string $id , string $doc ) : mysql_xdevapi\Result
}

属性

name

Table of Contents

  • Collection::add — Add collection document
  • Collection::addOrReplaceOne — Add or replace collection document
  • Collection::__construct — Collection constructor
  • Collection::count — Get document count
  • Collection::createIndex — Create collection index
  • Collection::dropIndex — Drop collection index
  • Collection::existsInDatabase — Check if collection exists in database
  • Collection::find — Search for document
  • Collection::getName — Get collection name
  • Collection::getOne — Get one document
  • Collection::getSchema — Get schema object
  • Collection::getSession — Get session object
  • Collection::modify — Modify collection documents
  • Collection::remove — Remove collection documents
  • Collection::removeOne — Remove one collection document
  • Collection::replaceOne — Replace one collection document


Add collection document

  • ? mysql_xdevapi\Collection
  • Collection::addOrReplaceOne ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Add collection document

Collection::add

(No version information available, might only be in Git)

Collection::add — Add collection document

说明

public mysql_xdevapi\Collection::add ( mixed $document ) : mysql_xdevapi\CollectionAdd

Triggers the insertion of the given document(s) into the collection, and multiple variants of this method are supported. Options include:

  1. Add a single document as a JSON string.

  2. Add a single document as an array as: [ 'field' => 'value', 'field2' => 'value2' ... ]

  3. A mix of both, and multiple documents can be added in the same operation.

参数

document

One or multiple documents, and this can be either JSON or an array of fields with their associated values. This cannot be an empty array.

The MySQL server automatically generates unique _id values for each document (recommended), although this can be manually added as well. This value must be unique as otherwise the add operation will fail.

返回值

A CollectionAdd object. Use execute() to return a Result that can be used to query the number of affected items, the number warnings generated by the operation, or to fetch a list of generated IDs for the inserted documents.

范例

Example #1 mysql_xdevapi\Collection::add() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$collection = $schema->getCollection("people");

// Add two documents
$collection->add('{"name": "Fred",  "age": 21, "job": "Construction"}')->execute();
$collection->add('{"name": "Wilma", "age": 23, "job": "Teacher"}')->execute();

// Add two documents using a single JSON object
$result = $collection->add(
  '{"name": "Bernie",
    "jobs": [{"title":"Cat Herder","Salary":42000}, {"title":"Father","Salary":0}],
    "hobbies": ["Sports","Making cupcakes"]}',
  '{"name": "Jane",
    "jobs": [{"title":"Scientist","Salary":18000}, {"title":"Mother","Salary":0}],
    "hobbies": ["Walking","Making pies"]}')->execute();

// Fetch a list of generated ID's from the last add()
$ids = $result->getGeneratedIds();
print_r($ids);
?>

以上例程的输出类似于：

Array
(
    [0] => 00005b6b53610000000000000056
    [1] => 00005b6b53610000000000000057
)

注释

Note:

A unique _id is generated by MySQL Server 8.0 or higher, as demonstrated in the example. The _id field must be manually defined if using MySQL Server 5.7.


Add or replace collection document

  • ? Collection::add
  • Collection::__construct ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Add or replace collection document

Collection::addOrReplaceOne

(No version information available, might only be in Git)

Collection::addOrReplaceOne — Add or replace collection document

说明

public mysql_xdevapi\Collection::addOrReplaceOne ( string $id , string $doc ) : mysql_xdevapi\Result

Add a new document, or replace a document if it already exists.

Here are several scenarios for this method:

  • If neither the id or any unique key values conflict with any document in the collection, then the document is added.

  • If the id does not match any document but one or more unique key values conflict with a document in the collection, then an error is raised.

  • If id matches an existing document and no unique keys are defined for the collection, then the document is replaced.

  • If id matches an existing document, and either all unique keys in the replacement document match that same document or they don't conflict with any other documents in the collection, then the document is replaced.

  • If id matches an existing document and one or more unique keys match a different document from the collection, then an error is raised.

参数

id

This is the filter id. If this id or any other field that has a unique index already exists in the collection, then it will update the matching document instead.

By default, this id is automatically generated by MySQL Server when the record was added, and is referenced as a field named '_id'.

doc

This is the document to add or replace, which is a JSON string.

返回值

A Result object.

范例

Example #1 mysql_xdevapi\Collection::addOrReplaceOne() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$collection = $schema->getCollection("people");

// Using add()
$result = $collection->add('{"name": "Wilma", "age": 23, "job": "Teacher"}')->execute();

// Using addOrReplaceOne()
// Note: we're passing in a known _id value here
$result = $collection->addOrReplaceOne('00005b6b53610000000000000056', '{"name": "Fred",  "age": 21, "job": "Construction"}');

?>


Collection constructor

  • ? Collection::addOrReplaceOne
  • Collection::count ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Collection constructor

Collection::__construct

(No version information available, might only be in Git)

Collection::__construct — Collection constructor

说明

private mysql_xdevapi\Collection::__construct ( )

Construct a Collection object.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\Collection::getOne() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection->add('{"name": "Alfred", "age": 42, "job": "Butler"}')->execute();

// A unique _id is (by default, and recommended) generated by MySQL Server
// This retrieves the generated _id's; only one in this example, so $ids[0]
$ids        = $result->getGeneratedIds();
$alfreds_id = $ids[0];

// ...

print_r($alfreds_id);
print_r($collection->getOne($alfreds_id));
?>

以上例程的输出类似于：

00005b6b536100000000000000b1

Array
(
    [_id] => 00005b6b536100000000000000b1
    [age] => 42
    [job] => Butler
    [name] => Alfred
)


Get document count

  • ? Collection::__construct
  • Collection::createIndex ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Get document count

Collection::count

(No version information available, might only be in Git)

Collection::count — Get document count

说明

public mysql_xdevapi\Collection::count ( ) : int

This functionality is similar to a SELECT COUNT(*) SQL operation against the MySQL server for the current schema and collection. In other words, it counts the number of documents in the collection.

参数

此函数没有参数。

返回值

The number of documents in the collection.

范例

Example #1 mysql_xdevapi\Collection::count() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$collection = $schema->getCollection("people");

$result = $collection
  ->add(
  '{"name": "Bernie",
    "jobs": [
      {"title":"Cat Herder","Salary":42000},
      {"title":"Father","Salary":0}
    ],
    "hobbies": ["Sports","Making cupcakes"]}',
  '{"name": "Jane",
    "jobs": [
      {"title":"Scientist","Salary":18000},
      {"title":"Mother","Salary":0}
    ],
    "hobbies": ["Walking","Making pies"]}')
  ->execute();

var_dump($collection->count());
?>

以上例程会输出：

int(2)


Create collection index

  • ? Collection::count
  • Collection::dropIndex ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Create collection index

Collection::createIndex

(No version information available, might only be in Git)

Collection::createIndex — Create collection index

说明

public mysql_xdevapi\Collection::createIndex ( string $index_name , string $index_desc_json ) : void

Creates an index on the collection.

An exception is thrown if an index with the same name already exists, or if index definition is not correctly formed.

参数

index_name

The name of the index that to create. This name must be a valid index name as accepted by the CREATE INDEX SQL query.

index_desc_json

Definition of the index to create. It contains an array of IndexField objects, and each object describes a single document member to include in the index, and an optional string for the type of index that might be INDEX (default) or SPATIAL.

A single IndexField description consists of the following fields:

  • field: string, the full document path to the document member or field to be indexed.

  • type: string, one of the supported SQL column types to map the field into. For numeric types, the optional UNSIGNED keyword may follow. For the TEXT type, the length to consider for indexing may be added.

  • required: bool, (optional) true if the field is required to exist in the document. Defaults to false, except for GEOJSON where it defaults to true.

  • options: integer, (optional) special option flags for use when decoding GEOJSON data.

  • srid: integer, (optional) srid value for use when decoding GEOJSON data.

It is an error to include other fields not described above in IndexDefinition or IndexField documents.

返回值

范例

Example #1 mysql_xdevapi\Collection::createIndex() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

// Creating a text index
$collection->createIndex(
  'myindex1',
  '{"fields": [{
    "field": "$.name",
    "type": "TEXT(25)",
    "required": true}],
    "unique": false}'
);

// A spatial index
$collection->createIndex(
  'myindex2',
  '{"fields": [{
    "field": "$.home",
    "type": "GEOJSON",
    "required": true}],
    "type": "SPATIAL"}'
);

// Index with multiple fields
$collection->createIndex(
  'myindex3',
  '{"fields": [
    {
      "field": "$.name",
      "type": "TEXT(20)",
      "required": true
    },
    {
      "field": "$.age",
      "type": "INTEGER"
    },
    {
      "field": "$.job",
      "type": "TEXT(30)",
      "required": false
    }
  ],
  "unique": true
  }'
);


Drop collection index

  • ? Collection::createIndex
  • Collection::existsInDatabase ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Drop collection index

Collection::dropIndex

(No version information available, might only be in Git)

Collection::dropIndex — Drop collection index

说明

public mysql_xdevapi\Collection::dropIndex ( string $index_name ) : bool

Drop a collection index.

This operation does not yield an error if the index does not exist, but false is returned in that case.

参数

index_name

Name of collection index to drop.

返回值

true if the DROP INDEX operation succeeded, otherwise false.

范例

Example #1 mysql_xdevapi\Collection::dropIndex() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

// ...

$collection = $schema->getCollection("people");

$collection->createIndex(
  'myindex',
  '{"fields": [{"field": "$.name", "type": "TEXT(25)", "required": true}], "unique": false}'
);

// ...

if ($collection->dropIndex('myindex')) {
    echo 'An index named 'myindex' was found, and dropped.';
}
?>

以上例程会输出：

An index named 'myindex' was found, and dropped.


Check if collection exists in database

  • ? Collection::dropIndex
  • Collection::find ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Check if collection exists in database

Collection::existsInDatabase

(No version information available, might only be in Git)

Collection::existsInDatabase — Check if collection exists in database

说明

public mysql_xdevapi\Collection::existsInDatabase ( ) : bool

Checks if the Collection object refers to a collection in the database (schema).

参数

此函数没有参数。

返回值

Returns true if collection exists in the database, else false if it does not.

A table defined with two columns (doc and _id) is considered a collection, and a third _json_schema column as of MySQL 8.0.21. Adding an additional column means existsInDatabase() will no longer see it as a collection.

范例

Example #1 mysql_xdevapi\Collection::existsInDatabase() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

// ...

$collection = $schema->getCollection("people");

// ...

if (!$collection->existsInDatabase()) {
    echo "The collection no longer exists in the database named addressbook. What happened?";
}
?>


Search for document

  • ? Collection::existsInDatabase
  • Collection::getName ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Search for document

Collection::find

(No version information available, might only be in Git)

Collection::find — Search for document

说明

public mysql_xdevapi\Collection::find ( string $search_condition = ? ) : mysql_xdevapi\CollectionFind

Search a database collection for a document or set of documents. The found documents are returned as a CollectionFind object is to further modify or fetch results from.

参数

search_condition

Although optional, normally a condition is defined to limit the results to a subset of documents.

Multiple elements might build the condition and the syntax supports parameter binding. The expression used as search condition must be a valid SQL expression. If no search condition is provided (field empty) then find('true') is assumed.

返回值

A CollectionFind object to verify the operation, or fetch the found documents.

范例

Example #1 mysql_xdevapi\Collection::find() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$collection->add('{"name": "Alfred",     "age": 18, "job": "Butler"}')->execute();
$collection->add('{"name": "Bob",        "age": 19, "job": "Swimmer"}')->execute();
$collection->add('{"name": "Fred",       "age": 20, "job": "Construction"}')->execute();
$collection->add('{"name": "Wilma",      "age": 21, "job": "Teacher"}')->execute();
$collection->add('{"name": "Suki",       "age": 22, "job": "Teacher"}')->execute();

$find   = $collection->find('job LIKE :job AND age > :age');
$result = $find
  ->bind(['job' => 'Teacher', 'age' => 20])
  ->sort('age DESC')
  ->limit(2)
  ->execute();

print_r($result->fetchAll());
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [_id] => 00005b6b536100000000000000a8
            [age] => 22
            [job] => Teacher
            [name] => Suki
        )
    [1] => Array
        (
            [_id] => 00005b6b536100000000000000a7
            [age] => 21
            [job] => Teacher
            [name] => Wilma
        )
)


Get collection name

  • ? Collection::find
  • Collection::getOne ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Get collection name

Collection::getName

(No version information available, might only be in Git)

Collection::getName — Get collection name

说明

public mysql_xdevapi\Collection::getName ( ) : string

Retrieve the collection's name.

参数

此函数没有参数。

返回值

The collection name, as a string.

范例

Example #1 mysql_xdevapi\Collection::getName() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

// ...

var_dump($collection->getName());
?>

以上例程的输出类似于：

string(6) "people"


Get one document

  • ? Collection::getName
  • Collection::getSchema ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Get one document

Collection::getOne

(No version information available, might only be in Git)

Collection::getOne — Get one document

说明

public mysql_xdevapi\Collection::getOne ( string $id ) : Document

Fetches one document from the collection.

This is a shortcut for: Collection.find("_id = :id").bind("id", id).execute().fetchOne();

参数

id

The document _id in the collection.

返回值

The collection object, or null if the _id does not match a document.

范例

Example #1 mysql_xdevapi\Collection::getOne() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection->add('{"name": "Alfred", "age": 42, "job": "Butler"}')->execute();

// A unique _id is (by default, and recommended) generated by MySQL Server
// This retrieves the generated _id's; only one in this example, so $ids[0]
$ids        = $result->getGeneratedIds();
$alfreds_id = $ids[0];

// ...

print_r($alfreds_id);
print_r($collection->getOne($alfreds_id));
?>

以上例程的输出类似于：

00005b6b536100000000000000b1

Array
(
    [_id] => 00005b6b536100000000000000b1
    [age] => 42
    [job] => Butler
    [name] => Alfred
)


Get schema object

  • ? Collection::getOne
  • Collection::getSession ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Get schema object

Collection::getSchema

(No version information available, might only be in Git)

Collection::getSchema — Get schema object

说明

public mysql_xdevapi\Collection::getSchema ( ) : Schema Object

Retrieve the schema object that contains the collection.

参数

此函数没有参数。

返回值

The schema object on success, or null if the object cannot be retrieved for the given collection.

范例

Example #1 mysql_xdevapi\Collection::getSchema() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

var_dump($collection->getSchema());
?>

以上例程的输出类似于：

object(mysql_xdevapi\Schema)#9 (1) {
  ["name"]=>
  string(11) "addressbook"
}


Get session object

  • ? Collection::getSchema
  • Collection::modify ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Get session object

Collection::getSession

(No version information available, might only be in Git)

Collection::getSession — Get session object

说明

public mysql_xdevapi\Collection::getSession ( ) : Session

Get a new Session object from the Collection object.

参数

此函数没有参数。

返回值

A Session object.

范例

Example #1 mysql_xdevapi\Collection::getSession() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

// ...

$newsession = $collection->getSession();

var_dump($session);
var_dump($newsession);
?>

以上例程的输出类似于：

object(mysql_xdevapi\Session)#1 (0) {
}
object(mysql_xdevapi\Session)#4 (0) {
}


Modify collection documents

  • ? Collection::getSession
  • Collection::remove ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Modify collection documents

Collection::modify

(No version information available, might only be in Git)

Collection::modify — Modify collection documents

说明

public mysql_xdevapi\Collection::modify ( string $search_condition ) : mysql_xdevapi\CollectionModify

Modify collections that meet specific search conditions. Multiple operations are allowed, and parameter binding is supported.

参数

search_condition

Must be a valid SQL expression used to match the documents to modify. This expression might be as simple as true, which matches all documents, or it might use functions and operators such as 'CAST(_id AS SIGNED) >= 10', 'age MOD 2 = 0 OR age MOD 3 = 0', or '_id IN ["2","5","7","10"]'.

返回值

If the operation is not executed, then the function will return a Modify object that can be used to add additional modify operations.

If the modify operation is executed, then the returned object will contain the result of the operation.

范例

Example #1 mysql_xdevapi\Collection::modify() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$collection->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();
$collection->add('{"name": "Bob",    "age": 19, "job": "Painter"}')->execute();

// Add two new jobs for all Painters: Artist and Crafter
$collection
  ->modify("job in ('Butler', 'Painter')")
  ->arrayAppend('job', 'Artist')
  ->arrayAppend('job', 'Crafter')
  ->execute();

// Remove the 'beer' field from all documents with the age 21
$collection
  ->modify('age < 21')
  ->unset(['beer'])
  ->execute();
?>


Remove collection documents

  • ? Collection::modify
  • Collection::removeOne ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Remove collection documents

Collection::remove

(No version information available, might only be in Git)

Collection::remove — Remove collection documents

说明

public mysql_xdevapi\Collection::remove ( string $search_condition ) : mysql_xdevapi\CollectionRemove

Remove collections that meet specific search conditions. Multiple operations are allowed, and parameter binding is supported.

参数

search_condition

Must be a valid SQL expression used to match the documents to modify. This expression might be as simple as true, which matches all documents, or it might use functions and operators such as 'CAST(_id AS SIGNED) >= 10', 'age MOD 2 = 0 OR age MOD 3 = 0', or '_id IN ["2","5","7","10"]'.

返回值

If the operation is not executed, then the function will return a Remove object that can be used to add additional remove operations.

If the remove operation is executed, then the returned object will contain the result of the operation.

范例

Example #1 mysql_xdevapi\Collection::remove() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$collection->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();
$collection->add('{"name": "Bob",    "age": 19, "job": "Painter"}')->execute();

// Remove all painters
$collection
  ->remove("job in ('Painter')")
  ->execute();

// Remove the oldest butler
$collection
  ->remove("job in ('Butler')")
  ->sort('age desc')
  ->limit(1)
  ->execute();

// Remove record with lowest age
$collection
  ->remove('true')
  ->sort('age desc')
  ->limit(1)
  ->execute();
?>


Remove one collection document

  • ? Collection::remove
  • Collection::replaceOne ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Remove one collection document

Collection::removeOne

(No version information available, might only be in Git)

Collection::removeOne — Remove one collection document

说明

public mysql_xdevapi\Collection::removeOne ( string $id ) : mysql_xdevapi\Result

Remove one document from the collection with the correspending ID. This is a shortcut for Collection.remove("_id = :id").bind("id", id).execute().

参数

id

The ID of the collection document to remove. Typically this is the _id that was generated by MySQL Server when the record was added.

返回值

A Result object that can be used to query the number of affected items or the number warnings generated by the operation.

范例

Example #1 mysql_xdevapi\Collection::removeOne() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();

// Normally the _id is known by other means,
// but for this example let's fetch the generated id and use it
$ids       = $result->getGeneratedIds();
$alfred_id = $ids[0];

$result = $collection->removeOne($alfred_id);

if(!$result->getAffectedItemsCount()) {
    echo "Alfred with id $alfred_id was not removed.";
} else {
    echo "Goodbye, Alfred, you can take _id $alfred_id with you.";
}
?>

以上例程的输出类似于：

Goodbye, Alfred, you can take _id 00005b6b536100000000000000cb with you.


Replace one collection document

  • ? Collection::removeOne
  • mysql_xdevapi\CollectionAdd ?
  • PHP Manual
  • mysql_xdevapi\Collection
  • Replace one collection document

Collection::replaceOne

(No version information available, might only be in Git)

Collection::replaceOne — Replace one collection document

说明

public mysql_xdevapi\Collection::replaceOne ( string $id , string $doc ) : mysql_xdevapi\Result

Updates (or replaces) the document identified by ID, if it exists.

参数

id

ID of the document to replace or update. Typically this is the _id that was generated by MySQL Server when the record was added.

doc

Collection document to update or replace the document matching the id parameter.

This document can be either a document object or a valid JSON string describing the new document.

返回值

A Result object that can be used to query the number of affected items and the number warnings generated by the operation.

范例

Example #1 mysql_xdevapi\Collection::replaceOne() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();

// Normally the _id is known by other means,
// but for this example let's fetch the generated id and use it
$ids       = $result->getGeneratedIds();
$alfred_id = $ids[0];

// ...

$alfred = $collection->getOne($alfred_id);
$alfred['age'] = 81;
$alfred['job'] = 'Guru';

$collection->replaceOne($alfred_id, $alfred);

?>


CollectionAdd class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\CollectionAdd implements mysql_xdevapi\Executable {
/* 方法 */
public execute ( ) : mysql_xdevapi\Result
}

Table of Contents

  • CollectionAdd::__construct — CollectionAdd constructor
  • CollectionAdd::execute — Execute the statement


CollectionAdd constructor

  • ? mysql_xdevapi\CollectionAdd
  • CollectionAdd::execute ?
  • PHP Manual
  • mysql_xdevapi\CollectionAdd
  • CollectionAdd constructor

CollectionAdd::__construct

(No version information available, might only be in Git)

CollectionAdd::__construct — CollectionAdd constructor

说明

private mysql_xdevapi\CollectionAdd::__construct ( )

Use to add a document to a collection; called from a Collection object.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\CollectionAdd::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$collection = $schema->getCollection("people");

// Add two documents
$collection
  ->add('{"name": "Fred",  "age": 21, "job": "Construction"}')
  ->execute();

$collection
  ->add('{"name": "Wilma", "age": 23, "job": "Teacher"}')
  ->execute();

// Add two documents using a single JSON object
$result = $collection
  ->add(
    '{"name": "Bernie",
      "jobs": [{"title":"Cat Herder","Salary":42000}, {"title":"Father","Salary":0}],
      "hobbies": ["Sports","Making cupcakes"]}',
    '{"name": "Jane",
      "jobs": [{"title":"Scientist","Salary":18000}, {"title":"Mother","Salary":0}],
      "hobbies": ["Walking","Making pies"]}')
  ->execute();

// Fetch a list of generated ID's from the last add()
$ids = $result->getGeneratedIds();
print_r($ids);

?>

以上例程的输出类似于：

Array
(
    [0] => 00005b6b53610000000000000056
    [1] => 00005b6b53610000000000000057
)

注释

Note:

A unique _id is generated by MySQL Server 8.0 or higher, as demonstrated in the example. The _id field must be manually defined if using MySQL Server 5.7.


Execute the statement

  • ? CollectionAdd::__construct
  • mysql_xdevapi\CollectionFind ?
  • PHP Manual
  • mysql_xdevapi\CollectionAdd
  • Execute the statement

CollectionAdd::execute

(No version information available, might only be in Git)

CollectionAdd::execute — Execute the statement

说明

public mysql_xdevapi\CollectionAdd::execute ( ) : mysql_xdevapi\Result

The execute method is required to send the CRUD operation request to the MySQL server.

参数

此函数没有参数。

返回值

A Result object that can be used to verify the status of the operation, such as the number of affected rows.

范例

Example #1 mysql_xdevapi\CollectionAdd::execute() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$collection = $schema->getCollection("people");

// Add two documents
$collection
  ->add('{"name": "Fred",  "age": 21, "job": "Construction"}')
  ->execute();

$collection
  ->add('{"name": "Wilma", "age": 23, "job": "Teacher"}')
  ->execute();

// Add two documents using a single JSON object
$result = $collection
  ->add(
    '{"name": "Bernie",
      "jobs": [{"title":"Cat Herder","Salary":42000}, {"title":"Father","Salary":0}],
      "hobbies": ["Sports","Making cupcakes"]}',
    '{"name": "Jane",
      "jobs": [{"title":"Scientist","Salary":18000}, {"title":"Mother","Salary":0}],
      "hobbies": ["Walking","Making pies"]}')
  ->execute();

// Fetch a list of generated ID's from the last add()
$ids = $result->getGeneratedIds();
print_r($ids);
?>

以上例程的输出类似于：

Array
(
    [0] => 00005b6b53610000000000000056
    [1] => 00005b6b53610000000000000057
)


CollectionFind class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\CollectionFind implements mysql_xdevapi\Executable , mysql_xdevapi\CrudOperationBindable , mysql_xdevapi\CrudOperationLimitable , mysql_xdevapi\CrudOperationSortable {
/* 方法 */
public bind ( array $placeholder_values ) : mysql_xdevapi\CollectionFind
public execute ( ) : mysql_xdevapi\DocResult
public fields ( string $projection ) : mysql_xdevapi\CollectionFind
public groupBy ( string $sort_expr ) : mysql_xdevapi\CollectionFind
public having ( string $sort_expr ) : mysql_xdevapi\CollectionFind
public limit ( int $rows ) : mysql_xdevapi\CollectionFind
public lockExclusive ( int $lock_waiting_option = ? ) : mysql_xdevapi\CollectionFind
public lockShared ( int $lock_waiting_option = ? ) : mysql_xdevapi\CollectionFind
public offset ( int $position ) : mysql_xdevapi\CollectionFind
public sort ( string $sort_expr ) : mysql_xdevapi\CollectionFind
}

Table of Contents

  • CollectionFind::bind — Bind value to query placeholder
  • CollectionFind::__construct — CollectionFind constructor
  • CollectionFind::execute — Execute the statement
  • CollectionFind::fields — Set document field filter
  • CollectionFind::groupBy — Set grouping criteria
  • CollectionFind::having — Set condition for aggregate functions
  • CollectionFind::limit — Limit number of returned documents
  • CollectionFind::lockExclusive — Execute operation with EXCLUSIVE LOCK
  • CollectionFind::lockShared — Execute operation with SHARED LOCK
  • CollectionFind::offset — Skip given number of elements to be returned
  • CollectionFind::sort — Set the sorting criteria


Bind value to query placeholder

  • ? mysql_xdevapi\CollectionFind
  • CollectionFind::__construct ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Bind value to query placeholder

CollectionFind::bind

(No version information available, might only be in Git)

CollectionFind::bind — Bind value to query placeholder

说明

public mysql_xdevapi\CollectionFind::bind ( array $placeholder_values ) : mysql_xdevapi\CollectionFind

It allows the user to bind a parameter to the placeholder in the search condition of the find operation. The placeholder has the form of :NAME where ':' is a common prefix that must always exists before any NAME, NAME is the actual name of the placeholder. The bind function accepts a list of placeholders if multiple entities have to be substituted in the search condition.

参数

placeholder_values

Values to substitute in the search condition; multiple values are allowed and are passed as an array where "PLACEHOLDER_NAME => PLACEHOLDER_VALUE".

返回值

A CollectionFind object, or chain with execute() to return a Result object.

范例

Example #1 mysql_xdevapi\CollectionFind::bind() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");
$result = $create
  ->add('{"name": "Alfred", "age": 18, "job": "Butler"}')
  ->execute();

// ...

$collection = $schema->getCollection("people");

$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b536100000000000000cf"
    ["age"]=>
    int(18)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(6) "Alfred"
  }
}


CollectionFind constructor

  • ? CollectionFind::bind
  • CollectionFind::execute ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • CollectionFind constructor

CollectionFind::__construct

(No version information available, might only be in Git)

CollectionFind::__construct — CollectionFind constructor

说明

private mysql_xdevapi\CollectionFind::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

范例

Example #1 CollectionFind example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");
$result = $create
  ->add('{"name": "Alfred", "age": 18, "job": "Butler"}')
  ->execute();

// ...

$collection = $schema->getCollection("people");

$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b536100000000000000cf"
    ["age"]=>
    int(18)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(6) "Alfred"
  }
}


Execute the statement

  • ? CollectionFind::__construct
  • CollectionFind::fields ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Execute the statement

CollectionFind::execute

(No version information available, might only be in Git)

CollectionFind::execute — Execute the statement

说明

public mysql_xdevapi\CollectionFind::execute ( ) : mysql_xdevapi\DocResult

Execute the find operation; this functionality allows for method chaining.

参数

此函数没有参数。

返回值

A DocResult object that to either fetch results from, or to query the status of the operation.

范例

Example #1 CollectionFind example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$create
  ->add('{"name": "Alfred", "age": 18, "job": "Butler"}')
  ->execute();

// ...

$collection = $schema->getCollection("people");

$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b536100000000000000cf"
    ["age"]=>
    int(18)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(6) "Alfred"
  }
}


Set document field filter

  • ? CollectionFind::execute
  • CollectionFind::groupBy ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Set document field filter

CollectionFind::fields

(No version information available, might only be in Git)

CollectionFind::fields — Set document field filter

说明

public mysql_xdevapi\CollectionFind::fields ( string $projection ) : mysql_xdevapi\CollectionFind

Defined the columns for the query to return. If not defined then all columns are used.

参数

projection

Can either be a single string or an array of string, those strings are identifying the columns that have to be returned for each document that match the search condition.

返回值

A CollectionFind object that can be used for further processing.

范例

Example #1 mysql_xdevapi\CollectionFind::fields() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$create
  ->add('{"name": "Alfred", "age": 18, "job": "Butler"}')
  ->execute();

// ...

$collection = $schema->getCollection("people");

$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->fields('name')
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(1) {
    ["name"]=>
    string(6) "Alfred"
  }
}


Set grouping criteria

  • ? CollectionFind::fields
  • CollectionFind::having ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Set grouping criteria

CollectionFind::groupBy

(No version information available, might only be in Git)

CollectionFind::groupBy — Set grouping criteria

说明

public mysql_xdevapi\CollectionFind::groupBy ( string $sort_expr ) : mysql_xdevapi\CollectionFind

This function can be used to group the result-set by one more columns, frequently this is used with aggregate functions like COUNT,MAX,MIN,SUM etc.

参数

sort_expr

The columns or columns that have to be used for the group operation, this can either be a single string or an array of string arguments, one for each column.

返回值

A CollectionFind that can be used for further processing

范例

Example #1 mysql_xdevapi\CollectionFind::groupBy() example

<?php

//Assuming $coll is a valid Collection object

//Extract all the documents from the Collection and group the results by the 'name' field
$res = $coll->find()->groupBy('name')->execute();

?>


Set condition for aggregate functions

  • ? CollectionFind::groupBy
  • CollectionFind::limit ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Set condition for aggregate functions

CollectionFind::having

(No version information available, might only be in Git)

CollectionFind::having — Set condition for aggregate functions

说明

public mysql_xdevapi\CollectionFind::having ( string $sort_expr ) : mysql_xdevapi\CollectionFind

This function can be used after the 'field' operation in order to make a selection on the documents to extract.

参数

sort_expr

This must be a valid SQL expression, the use of aggreate functions is allowed

返回值

CollectionFind object that can be used for further processing

范例

Example #1 mysql_xdevapi\CollectionFind::having() example

<?php

//Assuming $coll is a valid Collection object

//Find all the documents for which the 'age' is greather than 40,
//Only the columns 'name' and 'age' are returned in the Result object
$res = $coll->find()->fields(['name','age'])->having('age > 40')->execute();

?>


Limit number of returned documents

  • ? CollectionFind::having
  • CollectionFind::lockExclusive ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Limit number of returned documents

CollectionFind::limit

(No version information available, might only be in Git)

CollectionFind::limit — Limit number of returned documents

说明

public mysql_xdevapi\CollectionFind::limit ( int $rows ) : mysql_xdevapi\CollectionFind

Set the maximum number of documents to return.

参数

rows

Maximum number of documents.

返回值

A CollectionFind object that can be used for additional processing; chain with the execute() method to return a DocResult object.

范例

Example #1 mysql_xdevapi\CollectionFind::limit() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");
$create
  ->add('{"name": "Alfred", "age": 18, "job": "Butler"}')
  ->execute();
$create
  ->add('{"name": "Reginald", "age": 42, "job": "Butler"}')
  ->execute();

// ...

$collection = $schema->getCollection("people");

$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->sort('age desc')
  ->limit(1)
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b536100000000000000f3"
    ["age"]=>
    int(42)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(8) "Reginald"
  }
}


Execute operation with EXCLUSIVE LOCK

  • ? CollectionFind::limit
  • CollectionFind::lockShared ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Execute operation with EXCLUSIVE LOCK

CollectionFind::lockExclusive

(No version information available, might only be in Git)

CollectionFind::lockExclusive — Execute operation with EXCLUSIVE LOCK

说明

public mysql_xdevapi\CollectionFind::lockExclusive ( int $lock_waiting_option = ? ) : mysql_xdevapi\CollectionFind

Lock exclusively the document, other transactions are blocked from updating the document until the document is locked While the document is locked, other transactions are blocked from updating those docs, from doing SELECT ... LOCK IN SHARE MODE, or from reading the data in certain transaction isolation levels. Consistent reads ignore any locks set on the records that exist in the read view.

This feature is directly useful with the modify() command, to avoid concurrency problems. Basically, it serializes access to a row through row locking

参数

lock_waiting_option

Optional waiting option. By default it is MYSQLX_LOCK_DEFAULT. Valid values are these constants:

  • MYSQLX_LOCK_DEFAULT

  • MYSQLX_LOCK_NOWAIT

  • MYSQLX_LOCK_SKIP_LOCKED

返回值

Returns a CollectionFind object that can be used for further processing

范例

Example #1 mysql_xdevapi\CollectionFind::lockExclusive() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$session->startTransaction();

$result = $collection
  ->find("age > 50")
  ->lockExclusive()
  ->execute();

// ... do an operation on the object

// Complete the transaction and unlock the document
$session->commit();
?>


Execute operation with SHARED LOCK

  • ? CollectionFind::lockExclusive
  • CollectionFind::offset ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Execute operation with SHARED LOCK

CollectionFind::lockShared

(No version information available, might only be in Git)

CollectionFind::lockShared — Execute operation with SHARED LOCK

说明

public mysql_xdevapi\CollectionFind::lockShared ( int $lock_waiting_option = ? ) : mysql_xdevapi\CollectionFind

Allows to share the documents between multiple transactions which are locking in shared mode.

Other sessions can read the rows, but cannot modify them until your transaction commits.

If any of these rows were changed by another transaction that has not yet committed,

your query waits until that transaction ends and then uses the latest values.

参数

lock_waiting_option

Optional waiting option. By default it is MYSQLX_LOCK_DEFAULT. Valid values are these constants:

  • MYSQLX_LOCK_DEFAULT

  • MYSQLX_LOCK_NOWAIT

  • MYSQLX_LOCK_SKIP_LOCKED

返回值

A CollectionFind object that can be used for further processing

范例

Example #1 mysql_xdevapi\CollectionFind::lockShared() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$session->startTransaction();

$result = $collection
  ->find("age > 50")
  ->lockShared()
  ->execute();

// ... read the object in shared mode

// Complete the transaction and unlock the document
$session->commit();
?>


Skip given number of elements to be returned

  • ? CollectionFind::lockShared
  • CollectionFind::sort ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Skip given number of elements to be returned

CollectionFind::offset

(No version information available, might only be in Git)

CollectionFind::offset — Skip given number of elements to be returned

说明

public mysql_xdevapi\CollectionFind::offset ( int $position ) : mysql_xdevapi\CollectionFind

Skip (offset) these number of elements that otherwise would be returned by the find operation. Use with the limit() method.

Defining an offset larger than the result set size results in an empty set.

参数

position

Number of elements to skip for the limit() operation.

返回值

A CollectionFind object that can be used for additional processing.

范例

Example #1 mysql_xdevapi\CollectionFind::offset() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");
$create
  ->add('{"name": "Alfred", "age": 18, "job": "Butler"}')
  ->execute();
$create
  ->add('{"name": "Reginald", "age": 42, "job": "Butler"}')
  ->execute();

// ...

$collection = $schema->getCollection("people");

$result = $collection
  ->find()
  ->sort('age asc')
  ->offset(1)
  ->limit(1)
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b536100000000000000f3"
    ["age"]=>
    int(42)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(8) "Reginald"
  }
}


Set the sorting criteria

  • ? CollectionFind::offset
  • mysql_xdevapi\CollectionModify ?
  • PHP Manual
  • mysql_xdevapi\CollectionFind
  • Set the sorting criteria

CollectionFind::sort

(No version information available, might only be in Git)

CollectionFind::sort — Set the sorting criteria

说明

public mysql_xdevapi\CollectionFind::sort ( string $sort_expr ) : mysql_xdevapi\CollectionFind

Sort the result set by the field selected in the sort_expr argument. The allowed orders are ASC (Ascending) or DESC (Descending). This operation is equivalent to the 'ORDER BY' SQL operation and it follows the same set of rules.

参数

sort_expr

One or more sorting expressions can be provided. The evaluation is from left to right, and each expression is separated by a comma.

返回值

A CollectionFind object that can be used to execute the command, or to add additional operations.

范例

Example #1 mysql_xdevapi\CollectionFind::sort() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");
$create
  ->add('{"name": "Alfred", "age": 18, "job": "Butler"}')
  ->execute();
$create
  ->add('{"name": "Reginald", "age": 42, "job": "Butler"}')
  ->execute();

// ...

$collection = $schema->getCollection("people");

$result = $collection
  ->find()
  ->sort('job desc', 'age asc')
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(2) {
  [0]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b53610000000000000106"
    ["age"]=>
    int(18)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(6) "Alfred"
  }
  [1]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b53610000000000000107"
    ["age"]=>
    int(42)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(8) "Reginald"
  }
}


CollectionModify class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\CollectionModify implements mysql_xdevapi\Executable , mysql_xdevapi\CrudOperationBindable , mysql_xdevapi\CrudOperationLimitable , mysql_xdevapi\CrudOperationSkippable , mysql_xdevapi\CrudOperationSortable {
/* 方法 */
public arrayAppend ( string $collection_field , string $expression_or_literal ) : mysql_xdevapi\CollectionModify
public arrayInsert ( string $collection_field , string $expression_or_literal ) : mysql_xdevapi\CollectionModify
public bind ( array $placeholder_values ) : mysql_xdevapi\CollectionModify
public execute ( ) : mysql_xdevapi\Result
public limit ( int $rows ) : mysql_xdevapi\CollectionModify
public patch ( string $document ) : mysql_xdevapi\CollectionModify
public replace ( string $collection_field , string $expression_or_literal ) : mysql_xdevapi\CollectionModify
public set ( string $collection_field , string $expression_or_literal ) : mysql_xdevapi\CollectionModify
public skip ( int $position ) : mysql_xdevapi\CollectionModify
public sort ( string $sort_expr ) : mysql_xdevapi\CollectionModify
public unset ( array $fields ) : mysql_xdevapi\CollectionModify
}

Table of Contents

  • CollectionModify::arrayAppend — Append element to an array field
  • CollectionModify::arrayInsert — Insert element into an array field
  • CollectionModify::bind — Bind value to query placeholder
  • CollectionModify::__construct — CollectionModify constructor
  • CollectionModify::execute — Execute modify operation
  • CollectionModify::limit — Limit number of modified documents
  • CollectionModify::patch — Patch document
  • CollectionModify::replace — Replace document field
  • CollectionModify::set — Set document attribute
  • CollectionModify::skip — Skip elements
  • CollectionModify::sort — Set the sorting criteria
  • CollectionModify::unset — Unset the value of document fields


Append element to an array field

  • ? mysql_xdevapi\CollectionModify
  • CollectionModify::arrayInsert ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Append element to an array field

CollectionModify::arrayAppend

(No version information available, might only be in Git)

CollectionModify::arrayAppend — Append element to an array field

说明

public mysql_xdevapi\CollectionModify::arrayAppend ( string $collection_field , string $expression_or_literal ) : mysql_xdevapi\CollectionModify

Add an element to a document's field, as multiple elements of a field are represented as an array. Unlike arrayInsert(), arrayAppend() always appends the new element at the end of the array, whereas arrayInsert() can define the location.

参数

collection_field

The identifier of the field where the new element is inserted.

expression_or_literal

The new element to insert at the end of the document field array.

返回值

A CollectionModify object that can be used to execute the command, or to add additional operations.

范例

Example #1 mysql_xdevapi\CollectionModify::arrayAppend() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection
  ->add(
  '{"name":   "Bernie",
    "traits": ["Friend", "Brother", "Human"]}')
  ->execute();

$collection
  ->modify("name in ('Bernie', 'Jane')")
  ->arrayAppend('traits', 'Happy')
  ->execute();

$result = $collection
  ->find()
  ->execute();

print_r($result->fetchAll());
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [_id] => 00005b6b5361000000000000010c
            [name] => Bernie
            [traits] => Array
                (
                    [0] => Friend
                    [1] => Brother
                    [2] => Human
                    [3] => Happy
                )
        )
)


Insert element into an array field

  • ? CollectionModify::arrayAppend
  • CollectionModify::bind ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Insert element into an array field

CollectionModify::arrayInsert

(No version information available, might only be in Git)

CollectionModify::arrayInsert — Insert element into an array field

说明

public mysql_xdevapi\CollectionModify::arrayInsert ( string $collection_field , string $expression_or_literal ) : mysql_xdevapi\CollectionModify

Add an element to a document's field, as multiple elements of a field are represented as an array. Unlike arrayAppend(), arrayInsert() allows you to specify where the new element is inserted by defining which item it is after, whereas arrayAppend() always appends the new element at the end of the array.

参数

collection_field

Identify the item in the array that the new element is inserted after. The format of this parameter is FIELD_NAME[ INDEX ] where FIELD_NAME is the name of the document field to remove the element from, and INDEX is the INDEX of the element within the field.

The INDEX field is zero based, so the leftmost item from the array has an index of 0.

expression_or_literal

The new element to insert after FIELD_NAME[ INDEX ]

返回值

A CollectionModify object that can be used to execute the command, or to add additional operations

范例

Example #1 mysql_xdevapi\CollectionModify::arrayInsert() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection
  ->add(
  '{"name":   "Bernie",
    "traits": ["Friend", "Brother", "Human"]}')
  ->execute();

$collection
  ->modify("name in ('Bernie', 'Jane')")
  ->arrayInsert('traits[1]', 'Happy')
  ->execute();

$result = $collection
  ->find()
  ->execute();

print_r($result->fetchAll());
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [_id] => 00005b6b5361000000000000010d
            [name] => Bernie
            [traits] => Array
                (
                    [0] => Friend
                    [1] => Happy
                    [2] => Brother
                    [3] => Human
                )
        )
)


Bind value to query placeholder

  • ? CollectionModify::arrayInsert
  • CollectionModify::__construct ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Bind value to query placeholder

CollectionModify::bind

(No version information available, might only be in Git)

CollectionModify::bind — Bind value to query placeholder

说明

public mysql_xdevapi\CollectionModify::bind ( array $placeholder_values ) : mysql_xdevapi\CollectionModify

Bind a parameter to the placeholder in the search condition of the modify operation.

The placeholder has the form of :NAME where ':' is a common prefix that must always exists before any NAME where NAME is the name of the placeholder. The bind method accepts a list of placeholders if multiple entities have to be substituted in the search condition of the modify operation.

参数

placeholder_values

Placeholder values to substitute in the search condition. Multiple values are allowed and have to be passed as an array of mappings PLACEHOLDER_NAME->PLACEHOLDER_VALUE.

返回值

A CollectionModify object that can be used to execute the command, or to add additional operations.

范例

Example #1 mysql_xdevapi\CollectionModify::bind() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection
  ->add(
  '{"name":   "Bernie",
    "traits": ["Friend", "Brother", "Human"]}')
  ->execute();

$collection
  ->modify("name = :name")
  ->bind(['name' => 'Bernie'])
  ->arrayAppend('traits', 'Happy')
  ->execute();

$result = $collection
  ->find()
  ->execute();

print_r($result->fetchAll());
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [_id] => 00005b6b53610000000000000110
            [name] => Bernie
            [traits] => Array
                (
                    [0] => Friend
                    [1] => Brother
                    [2] => Human
                    [3] => Happy
                )
        )
)


CollectionModify constructor

  • ? CollectionModify::bind
  • CollectionModify::execute ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • CollectionModify constructor

CollectionModify::__construct

(No version information available, might only be in Git)

CollectionModify::__construct — CollectionModify constructor

说明

private mysql_xdevapi\CollectionModify::__construct ( )

Modify (update) a collection, and is instantiated by the Collection::modify() method.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\CollectionModify::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection
  ->add(
  '{"name":   "Bernie",
    "traits": ["Friend", "Brother", "Human"]}')
  ->execute();

$collection
  ->modify("name in ('Bernie', 'Jane')")
  ->arrayAppend('traits', 'Happy')
  ->execute();

$result = $collection
  ->find()
  ->execute();

print_r($result->fetchAll());
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [_id] => 00005b6b5361000000000000010c
            [name] => Bernie
            [traits] => Array
                (
                    [0] => Friend
                    [1] => Brother
                    [2] => Human
                    [3] => Happy
                )
        )
)


Execute modify operation

  • ? CollectionModify::__construct
  • CollectionModify::limit ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Execute modify operation

CollectionModify::execute

(No version information available, might only be in Git)

CollectionModify::execute — Execute modify operation

说明

public mysql_xdevapi\CollectionModify::execute ( ) : mysql_xdevapi\Result

The execute method is required to send the CRUD operation request to the MySQL server.

参数

此函数没有参数。

返回值

A Result object that can be used to verify the status of the operation, such as the number of affected rows.

范例

Example #1 mysql_xdevapi\CollectionModify::execute() example

<?php

/* ... */

?>


Limit number of modified documents

  • ? CollectionModify::execute
  • CollectionModify::patch ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Limit number of modified documents

CollectionModify::limit

(No version information available, might only be in Git)

CollectionModify::limit — Limit number of modified documents

说明

public mysql_xdevapi\CollectionModify::limit ( int $rows ) : mysql_xdevapi\CollectionModify

Limit the number of documents modified by this operation. Optionally combine with skip() to define an offset value.

参数

rows

The maximum number of documents to modify.

返回值

A CollectionModify object.

范例

Example #1 mysql_xdevapi\CollectionModify::limit() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$collection->add('{"name": "Fred",  "age": 21, "job": "Construction"}')->execute();
$collection->add('{"name": "Wilma", "age": 23, "job": "Teacher"}')->execute();
$collection->add('{"name": "Betty", "age": 24, "job": "Teacher"}')->execute();

$collection
  ->modify("job = :job")
  ->bind(['job' => 'Teacher'])
  ->set('job', 'Principal')
  ->limit(1)
  ->execute();

$result = $collection
  ->find()
  ->execute();

print_r($result->fetchAll());
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [_id] => 00005b6b53610000000000000118
            [age] => 21
            [job] => Construction
            [name] => Fred
        )
    [1] => Array
        (
            [_id] => 00005b6b53610000000000000119
            [age] => 23
            [job] => Principal
            [name] => Wilma
        )
    [2] => Array
        (
            [_id] => 00005b6b5361000000000000011a
            [age] => 24
            [job] => Teacher
            [name] => Betty
        )
)


Patch document

  • ? CollectionModify::limit
  • CollectionModify::replace ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Patch document

CollectionModify::patch

(No version information available, might only be in Git)

CollectionModify::patch — Patch document

说明

public mysql_xdevapi\CollectionModify::patch ( string $document ) : mysql_xdevapi\CollectionModify

Takes a patch object and applies it on one or more documents, and can update multiple document properties.

Warning

本函数还未编写文档，仅有参数列表。

参数

document

A document with the properties to apply to the matching documents.

返回值

A CollectionModify object.

范例

Example #1 mysql_xdevapi\CollectionModify::patch() example

<?php

$res = $coll->modify('"Programmatore" IN job')->patch('{"Hobby" : "Programmare"}')->execute();

?>


Replace document field

  • ? CollectionModify::patch
  • CollectionModify::set ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Replace document field

CollectionModify::replace

(No version information available, might only be in Git)

CollectionModify::replace — Replace document field

说明

public mysql_xdevapi\CollectionModify::replace ( string $collection_field , string $expression_or_literal ) : mysql_xdevapi\CollectionModify

Replace (update) a given field value with a new one.

参数

collection_field

The document path of the item to set.

expression_or_literal

The value to set on the specified attribute.

返回值

A CollectionModify object.

范例

Example #1 mysql_xdevapi\CollectionModify::replace() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection
  ->add(
  '{"name":   "Bernie",
    "traits": ["Friend", "Brother", "Human"]}')
  ->execute();

$collection
  ->modify("name = :name")
  ->bind(['name' => 'Bernie'])
  ->replace("name", "Bern")
  ->execute();

$result = $collection
  ->find()
  ->execute();

print_r($result->fetchAll());
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [_id] => 00005b6b5361000000000000011b
            [name] => Bern
            [traits] => Array
                (
                    [0] => Friend
                    [1] => Brother
                    [2] => Human
                )
        )
)


Set document attribute

  • ? CollectionModify::replace
  • CollectionModify::skip ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Set document attribute

CollectionModify::set

(No version information available, might only be in Git)

CollectionModify::set — Set document attribute

说明

public mysql_xdevapi\CollectionModify::set ( string $collection_field , string $expression_or_literal ) : mysql_xdevapi\CollectionModify

Sets or updates attributes on documents in a collection.

参数

collection_field

The document path (name) of the item to set.

expression_or_literal

The value to set it to.

返回值

A CollectionModify object.

范例

Example #1 mysql_xdevapi\CollectionModify::set() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$result = $collection
  ->add(
  '{"name":   "Bernie",
    "traits": ["Friend", "Brother", "Human"]}')
  ->execute();

$collection
  ->modify("name = :name")
  ->bind(['name' => 'Bernie'])
  ->set("name", "Bern")
  ->execute();

$result = $collection
  ->find()
  ->execute();

print_r($result->fetchAll());
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [_id] => 00005b6b53610000000000000111
            [name] => Bern
            [traits] => Array
                (
                    [0] => Friend
                    [1] => Brother
                    [2] => Human
                )
        )
)


Skip elements

  • ? CollectionModify::set
  • CollectionModify::sort ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Skip elements

CollectionModify::skip

(No version information available, might only be in Git)

CollectionModify::skip — Skip elements

说明

public mysql_xdevapi\CollectionModify::skip ( int $position ) : mysql_xdevapi\CollectionModify

Skip the first N elements that would otherwise be returned by a find operation. If the number of elements skipped is larger than the size of the result set, then the find operation returns an empty set.

Warning

本函数还未编写文档，仅有参数列表。

参数

position

Number of elements to skip.

返回值

A CollectionModify object to use for further processing.

范例

Example #1 mysql_xdevapi\CollectionModify::skip() example

<?php

$coll->modify('age > :age')->sort('age desc')->unset(['age'])->bind(['age' => 20])->limit(4)->skip(1)->execute();

?>


Set the sorting criteria

  • ? CollectionModify::skip
  • CollectionModify::unset ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Set the sorting criteria

CollectionModify::sort

(No version information available, might only be in Git)

CollectionModify::sort — Set the sorting criteria

说明

public mysql_xdevapi\CollectionModify::sort ( string $sort_expr ) : mysql_xdevapi\CollectionModify

Sort the result set by the field selected in the sort_expr argument. The allowed orders are ASC (Ascending) or DESC (Descending). This operation is equivalent to the 'ORDER BY' SQL operation and it follows the same set of rules.

Warning

本函数还未编写文档，仅有参数列表。

参数

sort_expr

One or more sorting expression can be provided, the evaluation of these will be from the leftmost to the rightmost, each expression must be separated by a comma.

返回值

CollectionModify object that can be used for further processing.

范例

Example #1 mysql_xdevapi\CollectionModify::sort() example

<?php

$res = $coll->modify('true')->sort('name desc', 'age asc')->limit(4)->set('Married', 'NO')->execute();

?>


Unset the value of document fields

  • ? CollectionModify::sort
  • mysql_xdevapi\CollectionRemove ?
  • PHP Manual
  • mysql_xdevapi\CollectionModify
  • Unset the value of document fields

CollectionModify::unset

(No version information available, might only be in Git)

CollectionModify::unset — Unset the value of document fields

说明

public mysql_xdevapi\CollectionModify::unset ( array $fields ) : mysql_xdevapi\CollectionModify

Removes attributes from documents in a collection.

Warning

本函数还未编写文档，仅有参数列表。

参数

fields

The attributes to remove from documents in a collection.

返回值

CollectionModify object that can be used for further processing.

范例

Example #1 mysql_xdevapi\CollectionModify::unset() example

<?php

$res = $coll->modify('job like :job_name')->unset(["age", "name"])->bind(['job_name' => 'Plumber'])->execute();

?>


CollectionRemove class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\CollectionRemove implements mysql_xdevapi\Executable , mysql_xdevapi\CrudOperationBindable , mysql_xdevapi\CrudOperationLimitable , mysql_xdevapi\CrudOperationSortable {
/* 方法 */
public bind ( array $placeholder_values ) : mysql_xdevapi\CollectionRemove
public execute ( ) : mysql_xdevapi\Result
public limit ( int $rows ) : mysql_xdevapi\CollectionRemove
public sort ( string $sort_expr ) : mysql_xdevapi\CollectionRemove
}

Table of Contents

  • CollectionRemove::bind — Bind value to placeholder
  • CollectionRemove::__construct — CollectionRemove constructor
  • CollectionRemove::execute — Execute remove operation
  • CollectionRemove::limit — Limit number of documents to remove
  • CollectionRemove::sort — Set the sorting criteria


Bind value to placeholder

  • ? mysql_xdevapi\CollectionRemove
  • CollectionRemove::__construct ?
  • PHP Manual
  • mysql_xdevapi\CollectionRemove
  • Bind value to placeholder

CollectionRemove::bind

(No version information available, might only be in Git)

CollectionRemove::bind — Bind value to placeholder

说明

public mysql_xdevapi\CollectionRemove::bind ( array $placeholder_values ) : mysql_xdevapi\CollectionRemove

Bind a parameter to the placeholder in the search condition of the remove operation.

The placeholder has the form of :NAME where ':' is a common prefix that must always exists before any NAME where NAME is the name of the placeholder. The bind method accepts a list of placeholders if multiple entities have to be substituted in the search condition of the remove operation.

Warning

本函数还未编写文档，仅有参数列表。

参数

placeholder_values

Placeholder values to substitute in the search condition. Multiple values are allowed and have to be passed as an array of mappings PLACEHOLDER_NAME->PLACEHOLDER_VALUE.

返回值

A CollectionRemove object that can be used to execute the command, or to add additional operations.

范例

Example #1 mysql_xdevapi\CollectionRemove::bind() example

<?php

$res = $coll->remove('age > :age_from and age < :age_to')->bind(['age_from' => 20, 'age_to' => 50])->limit(7)->execute();

?>


CollectionRemove constructor

  • ? CollectionRemove::bind
  • CollectionRemove::execute ?
  • PHP Manual
  • mysql_xdevapi\CollectionRemove
  • CollectionRemove constructor

CollectionRemove::__construct

(No version information available, might only be in Git)

CollectionRemove::__construct — CollectionRemove constructor

说明

private mysql_xdevapi\CollectionRemove::__construct ( )

Remove collection documents, and is instantiated by the Collection::remove() method.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\Collection::remove() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("people");

$collection->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();
$collection->add('{"name": "Bob",    "age": 19, "job": "Painter"}')->execute();

// Remove all painters
$collection
  ->remove("job in ('Painter')")
  ->execute();

// Remove the oldest butler
$collection
  ->remove("job in ('Butler')")
  ->sort('age desc')
  ->limit(1)
  ->execute();

// Remove record with lowest age
$collection
  ->remove('true')
  ->sort('age desc')
  ->limit(1)
  ->execute();
?>


Execute remove operation

  • ? CollectionRemove::__construct
  • CollectionRemove::limit ?
  • PHP Manual
  • mysql_xdevapi\CollectionRemove
  • Execute remove operation

CollectionRemove::execute

(No version information available, might only be in Git)

CollectionRemove::execute — Execute remove operation

说明

public mysql_xdevapi\CollectionRemove::execute ( ) : mysql_xdevapi\Result

The execute function needs to be invoked in order to trigger the client to send the CRUD operation request to the server.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Result object.

范例

Example #1 mysql_xdevapi\CollectionRemove::execute() example

<?php

$res = $coll->remove('true')->sort('age desc')->limit(2)->execute();

?>


Limit number of documents to remove

  • ? CollectionRemove::execute
  • CollectionRemove::sort ?
  • PHP Manual
  • mysql_xdevapi\CollectionRemove
  • Limit number of documents to remove

CollectionRemove::limit

(No version information available, might only be in Git)

CollectionRemove::limit — Limit number of documents to remove

说明

public mysql_xdevapi\CollectionRemove::limit ( int $rows ) : mysql_xdevapi\CollectionRemove

Sets the maximum number of documents to remove.

Warning

本函数还未编写文档，仅有参数列表。

参数

rows

The maximum number of documents to remove.

返回值

Returns a CollectionRemove object that can be used to execute the command, or to add additional operations.

范例

Example #1 mysql_xdevapi\CollectionRemove::limit() example

<?php

$res = $coll->remove('job in (\'Barista\', \'Programmatore\', \'Ballerino\', \'Programmatrice\')')->limit(5)->sort(['age desc', 'name asc'])->execute();

?>


Set the sorting criteria

  • ? CollectionRemove::limit
  • mysql_xdevapi\ColumnResult ?
  • PHP Manual
  • mysql_xdevapi\CollectionRemove
  • Set the sorting criteria

CollectionRemove::sort

(No version information available, might only be in Git)

CollectionRemove::sort — Set the sorting criteria

说明

public mysql_xdevapi\CollectionRemove::sort ( string $sort_expr ) : mysql_xdevapi\CollectionRemove

Sort the result set by the field selected in the sort_expr argument. The allowed orders are ASC (Ascending) or DESC (Descending). This operation is equivalent to the 'ORDER BY' SQL operation and it follows the same set of rules.

Warning

本函数还未编写文档，仅有参数列表。

参数

sort_expr

One or more sorting expressions can be provided. The evaluation is from left to right, and each expression is separated by a comma.

返回值

A CollectionRemove object that can be used to execute the command, or to add additional operations.

范例

Example #1 mysql_xdevapi\CollectionRemove::sort() example

<?php

$res = $coll->remove('true')->sort('age desc')->limit(2)->execute();

?>


ColumnResult class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\ColumnResult {
/* 方法 */
public getCharacterSetName ( ) : string
public getCollationName ( ) : string
public getColumnLabel ( ) : string
public getColumnName ( ) : string
public getFractionalDigits ( ) : int
public getLength ( ) : int
public getSchemaName ( ) : string
public getTableLabel ( ) : string
public getTableName ( ) : string
public getType ( ) : int
public isNumberSigned ( ) : int
public isPadded ( ) : int
}

Table of Contents

  • ColumnResult::__construct — ColumnResult constructor
  • ColumnResult::getCharacterSetName — Get character set
  • ColumnResult::getCollationName — Get collation name
  • ColumnResult::getColumnLabel — Get column label
  • ColumnResult::getColumnName — Get column name
  • ColumnResult::getFractionalDigits — Get fractional digit length
  • ColumnResult::getLength — Get column field length
  • ColumnResult::getSchemaName — Get schema name
  • ColumnResult::getTableLabel — Get table label
  • ColumnResult::getTableName — Get table name
  • ColumnResult::getType — Get column type
  • ColumnResult::isNumberSigned — Check if signed type
  • ColumnResult::isPadded — Check if padded


ColumnResult constructor

  • ? mysql_xdevapi\ColumnResult
  • ColumnResult::getCharacterSetName ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • ColumnResult constructor

ColumnResult::__construct

(No version information available, might only be in Git)

ColumnResult::__construct — ColumnResult constructor

说明

private mysql_xdevapi\ColumnResult::__construct ( )

Retrieve column metadata, such as its character set; this is instantiated by the RowResult::getColumns() method.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\ColumnResult::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS nonsense")->execute();
$session->sql("CREATE DATABASE nonsense")->execute();
$session->sql("CREATE TABLE nonsense.numbers (hello int, world float unsigned)")->execute();
$session->sql("INSERT INTO  nonsense.numbers values (42, 42)")->execute();

$schema = $session->getSchema("nonsense");
$table  = $schema->getTable("numbers");

$result1 = $table->select('hello','world')->execute();

// Returns an array of ColumnResult objects
$columns = $result1->getColumns();

foreach ($columns as $column) {
    echo "\nColumn label " , $column->getColumnLabel();
    echo " is type "       , $column->getType();
    echo " and is ", ($column->isNumberSigned() === 0) ? "Unsigned." : "Signed.";
}

// Alternatively
$result2 = $session->sql("SELECT * FROM nonsense.numbers")->execute();

// Returns an array of FieldMetadata objects
print_r($result2->getColumns());

以上例程的输出类似于：

Column label hello is type 19 and is Signed.
Column label world is type 4  and is Unsigned.

Array
(
    [0] => mysql_xdevapi\FieldMetadata Object
        (
            [type] => 1
            [type_name] => SINT
            [name] => hello
            [original_name] => hello
            [table] => numbers
            [original_table] => numbers
            [schema] => nonsense
            [catalog] => def
            [collation] => 0
            [fractional_digits] => 0
            [length] => 11
            [flags] => 0
            [content_type] => 0
        )
    [1] => mysql_xdevapi\FieldMetadata Object
        (
            [type] => 6
            [type_name] => FLOAT
            [name] => world
            [original_name] => world
            [table] => numbers
            [original_table] => numbers
            [schema] => nonsense
            [catalog] => def
            [collation] => 0
            [fractional_digits] => 31
            [length] => 12
            [flags] => 1
            [content_type] => 0
        )
)


Get character set

  • ? ColumnResult::__construct
  • ColumnResult::getCollationName ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get character set

ColumnResult::getCharacterSetName

(No version information available, might only be in Git)

ColumnResult::getCharacterSetName — Get character set

说明

public mysql_xdevapi\ColumnResult::getCharacterSetName ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getCharacterSetName() example

<?php

/* ... */

?>


Get collation name

  • ? ColumnResult::getCharacterSetName
  • ColumnResult::getColumnLabel ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get collation name

ColumnResult::getCollationName

(No version information available, might only be in Git)

ColumnResult::getCollationName — Get collation name

说明

public mysql_xdevapi\ColumnResult::getCollationName ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getCollationName() example

<?php

/* ... */

?>


Get column label

  • ? ColumnResult::getCollationName
  • ColumnResult::getColumnName ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get column label

ColumnResult::getColumnLabel

(No version information available, might only be in Git)

ColumnResult::getColumnLabel — Get column label

说明

public mysql_xdevapi\ColumnResult::getColumnLabel ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getColumnLabel() example

<?php

/* ... */

?>


Get column name

  • ? ColumnResult::getColumnLabel
  • ColumnResult::getFractionalDigits ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get column name

ColumnResult::getColumnName

(No version information available, might only be in Git)

ColumnResult::getColumnName — Get column name

说明

public mysql_xdevapi\ColumnResult::getColumnName ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getColumnName() example

<?php

/* ... */

?>


Get fractional digit length

  • ? ColumnResult::getColumnName
  • ColumnResult::getLength ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get fractional digit length

ColumnResult::getFractionalDigits

(No version information available, might only be in Git)

ColumnResult::getFractionalDigits — Get fractional digit length

说明

public mysql_xdevapi\ColumnResult::getFractionalDigits ( ) : int

Fetch the number of fractional digits for column.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getFractionalDigits() example

<?php

/* ... */

?>


Get column field length

  • ? ColumnResult::getFractionalDigits
  • ColumnResult::getSchemaName ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get column field length

ColumnResult::getLength

(No version information available, might only be in Git)

ColumnResult::getLength — Get column field length

说明

public mysql_xdevapi\ColumnResult::getLength ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getLength() example

<?php

/* ... */

?>


Get schema name

  • ? ColumnResult::getLength
  • ColumnResult::getTableLabel ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get schema name

ColumnResult::getSchemaName

(No version information available, might only be in Git)

ColumnResult::getSchemaName — Get schema name

说明

public mysql_xdevapi\ColumnResult::getSchemaName ( ) : string

Fetch the schema name where the column is stored.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getSchemaName() example

<?php

/* ... */

?>


Get table label

  • ? ColumnResult::getSchemaName
  • ColumnResult::getTableName ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get table label

ColumnResult::getTableLabel

(No version information available, might only be in Git)

ColumnResult::getTableLabel — Get table label

说明

public mysql_xdevapi\ColumnResult::getTableLabel ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getTableLabel() example

<?php

/* ... */

?>


Get table name

  • ? ColumnResult::getTableLabel
  • ColumnResult::getType ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get table name

ColumnResult::getTableName

(No version information available, might only be in Git)

ColumnResult::getTableName — Get table name

说明

public mysql_xdevapi\ColumnResult::getTableName ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Name of the table for the column.

范例

Example #1 mysql_xdevapi\ColumnResult::getTableName() example

<?php

/* ... */

?>


Get column type

  • ? ColumnResult::getTableName
  • ColumnResult::isNumberSigned ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Get column type

ColumnResult::getType

(No version information available, might only be in Git)

ColumnResult::getType — Get column type

说明

public mysql_xdevapi\ColumnResult::getType ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\ColumnResult::getType() example

<?php

/* ... */

?>


Check if signed type

  • ? ColumnResult::getType
  • ColumnResult::isPadded ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Check if signed type

ColumnResult::isNumberSigned

(No version information available, might only be in Git)

ColumnResult::isNumberSigned — Check if signed type

说明

public mysql_xdevapi\ColumnResult::isNumberSigned ( ) : int

Retrieve a table's column information, and is instantiated by the RowResult::getColumns() method.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if a given column as a signed type.

范例

Example #1 mysql_xdevapi\ColumnResult::isNumberSigned() example

<?php

/* ... */

?>


Check if padded

  • ? ColumnResult::isNumberSigned
  • mysql_xdevapi\CrudOperationBindable ?
  • PHP Manual
  • mysql_xdevapi\ColumnResult
  • Check if padded

ColumnResult::isPadded

(No version information available, might only be in Git)

ColumnResult::isPadded — Check if padded

说明

public mysql_xdevapi\ColumnResult::isPadded ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if a given column is padded.

范例

Example #1 mysql_xdevapi\ColumnResult::isPadded() example

<?php

/* ... */

?>


CrudOperationBindable interface

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\CrudOperationBindable {
/* 方法 */
abstract public bind ( array $placeholder_values ) : mysql_xdevapi\CrudOperationBindable
}

Table of Contents

  • CrudOperationBindable::bind — Bind value to placeholder


Bind value to placeholder

  • ? mysql_xdevapi\CrudOperationBindable
  • mysql_xdevapi\CrudOperationLimitable ?
  • PHP Manual
  • mysql_xdevapi\CrudOperationBindable
  • Bind value to placeholder

CrudOperationBindable::bind

(No version information available, might only be in Git)

CrudOperationBindable::bind — Bind value to placeholder

说明

abstract public mysql_xdevapi\CrudOperationBindable::bind ( array $placeholder_values ) : mysql_xdevapi\CrudOperationBindable

Binds a value to a specific placeholder.

Warning

本函数还未编写文档，仅有参数列表。

参数

placeholder_values

The name of the placeholders and the values to bind.

返回值

A CrudOperationBindable object.

范例

Example #1 mysql_xdevapi\CrudOperationBindable::bind() example

<?php

$res = $coll->modify('name like :name')->arrayInsert('job[0]', 'Calciatore')->bind(['name' => 'ENTITY'])->execute();
$res = $table->delete()->orderby('age desc')->where('age < 20 and age > 12 and name != :name')->bind(['name' => 'Tierney'])->limit(2)->execute();

?>


CrudOperationLimitable interface

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\CrudOperationLimitable {
/* 方法 */
abstract public limit ( int $rows ) : mysql_xdevapi\CrudOperationLimitable
}

Table of Contents

  • CrudOperationLimitable::limit — Set result limit


Set result limit

  • ? mysql_xdevapi\CrudOperationLimitable
  • mysql_xdevapi\CrudOperationSkippable ?
  • PHP Manual
  • mysql_xdevapi\CrudOperationLimitable
  • Set result limit

CrudOperationLimitable::limit

(No version information available, might only be in Git)

CrudOperationLimitable::limit — Set result limit

说明

abstract public mysql_xdevapi\CrudOperationLimitable::limit ( int $rows ) : mysql_xdevapi\CrudOperationLimitable

Sets the maximum number of records or documents to return.

Warning

本函数还未编写文档，仅有参数列表。

参数

rows

The maximum number of records or documents.

返回值

A CrudOperationLimitable object.

范例

Example #1 mysql_xdevapi\CrudOperationLimitable::limit() example

<?php

$res = $coll->find()->fields(['name as n','age as a','job as j'])->groupBy('j')->limit(11)->execute();
$res = $table->update()->set('age',69)->where('age > 15 and age < 22')->limit(4)->orderby(['age asc','name desc'])->execute();

?>


CrudOperationSkippable interface

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\CrudOperationSkippable {
/* 方法 */
abstract public skip ( int $skip ) : mysql_xdevapi\CrudOperationSkippable
}

Table of Contents

  • CrudOperationSkippable::skip — Number of operations to skip


Number of operations to skip

  • ? mysql_xdevapi\CrudOperationSkippable
  • mysql_xdevapi\CrudOperationSortable ?
  • PHP Manual
  • mysql_xdevapi\CrudOperationSkippable
  • Number of operations to skip

CrudOperationSkippable::skip

(No version information available, might only be in Git)

CrudOperationSkippable::skip — Number of operations to skip

说明

abstract public mysql_xdevapi\CrudOperationSkippable::skip ( int $skip ) : mysql_xdevapi\CrudOperationSkippable

Skip this number of records in the returned operation.

Warning

本函数还未编写文档，仅有参数列表。

参数

skip

Number of elements to skip.

返回值

A CrudOperationSkippable object.

范例

Example #1 mysql_xdevapi\CrudOperationSkippable::skip() example

<?php

$res = $coll->find('job like \'Programmatore\'')->limit(1)->skip(3)->sort('age asc')->execute();

?>


CrudOperationSortable interface

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\CrudOperationSortable {
/* 方法 */
abstract public sort ( string $sort_expr ) : mysql_xdevapi\CrudOperationSortable
}

Table of Contents

  • CrudOperationSortable::sort — Sort results


Sort results

  • ? mysql_xdevapi\CrudOperationSortable
  • mysql_xdevapi\DatabaseObject ?
  • PHP Manual
  • mysql_xdevapi\CrudOperationSortable
  • Sort results

CrudOperationSortable::sort

(No version information available, might only be in Git)

CrudOperationSortable::sort — Sort results

说明

abstract public mysql_xdevapi\CrudOperationSortable::sort ( string $sort_expr ) : mysql_xdevapi\CrudOperationSortable

Sort the result set by the field selected in the sort_expr argument. The allowed orders are ASC (Ascending) or DESC (Descending). This operation is equivalent to the 'ORDER BY' SQL operation and it follows the same set of rules.

Warning

本函数还未编写文档，仅有参数列表。

参数

sort_expr

One or more sorting expressions can be provided. The evaluation is from left to right, and each expression is separated by a comma.

返回值

A CrudOperationSortable object.

范例

Example #1 mysql_xdevapi\CrudOperationSortable::sort() example

<?php

$res = $coll->find('job like \'Cavia\'')->sort('age desc', '_id desc')->execute();

?>


DatabaseObject interface

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\DatabaseObject {
/* 方法 */
abstract public existsInDatabase ( ) : bool
abstract public getName ( ) : string
abstract public getSession ( ) : mysql_xdevapi\Session
}

Table of Contents

  • DatabaseObject::existsInDatabase — Check if object exists in database
  • DatabaseObject::getName — Get object name
  • DatabaseObject::getSession — Get session name


Check if object exists in database

  • ? mysql_xdevapi\DatabaseObject
  • DatabaseObject::getName ?
  • PHP Manual
  • mysql_xdevapi\DatabaseObject
  • Check if object exists in database

DatabaseObject::existsInDatabase

(No version information available, might only be in Git)

DatabaseObject::existsInDatabase — Check if object exists in database

说明

abstract public mysql_xdevapi\DatabaseObject::existsInDatabase ( ) : bool

Verifies if the database object refers to an object that exists in the database.

参数

此函数没有参数。

返回值

Returns true if object exists in the database, else false if it does not.

范例

Example #1 mysql_xdevapi\DatabaseObject::existsInDatabase() example

<?php

$existInDb = $dbObj->existsInDatabase();

?>


Get object name

  • ? DatabaseObject::existsInDatabase
  • DatabaseObject::getSession ?
  • PHP Manual
  • mysql_xdevapi\DatabaseObject
  • Get object name

DatabaseObject::getName

(No version information available, might only be in Git)

DatabaseObject::getName — Get object name

说明

abstract public mysql_xdevapi\DatabaseObject::getName ( ) : string

Fetch name of this database object.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The name of this database object.

范例

Example #1 mysql_xdevapi\DatabaseObject::getName() example

<?php

$dbObjName = $dbObj->getName();

?>


Get session name

  • ? DatabaseObject::getName
  • mysql_xdevapi\DocResult ?
  • PHP Manual
  • mysql_xdevapi\DatabaseObject
  • Get session name

DatabaseObject::getSession

(No version information available, might only be in Git)

DatabaseObject::getSession — Get session name

说明

abstract public mysql_xdevapi\DatabaseObject::getSession ( ) : mysql_xdevapi\Session

Fetch session associated to the database object.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The Session object.

范例

Example #1 mysql_xdevapi\DatabaseObject::getSession() example

<?php

$session = $dbObj->getSession();

?>


DocResult class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\DocResult implements mysql_xdevapi\BaseResult , Traversable {
/* 方法 */
public fetchAll ( ) : array
public fetchOne ( ) : array
public getWarnings ( ) : Array
public getWarningsCount ( ) : int
}

Table of Contents

  • DocResult::__construct — DocResult constructor
  • DocResult::fetchAll — Get all rows
  • DocResult::fetchOne — Get one row
  • DocResult::getWarnings — Get warnings from last operation
  • DocResult::getWarningsCount — Get warning count from last operation


DocResult constructor

  • ? mysql_xdevapi\DocResult
  • DocResult::fetchAll ?
  • PHP Manual
  • mysql_xdevapi\DocResult
  • DocResult constructor

DocResult::__construct

(No version information available, might only be in Git)

DocResult::__construct — DocResult constructor

说明

private mysql_xdevapi\DocResult::__construct ( )

Fetch document results and warnings, and is instantiated by CollectionFind.

参数

此函数没有参数。

范例

Example #1 A DocResult example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$create->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();
$create->add('{"name": "Reginald", "age": 42, "job": "Butler"}')->execute();

// ...

$collection = $schema->getCollection("people");

// Yields a DocResult object
$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->sort('age desc')
  ->limit(1)
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b536100000000000000f3"
    ["age"]=>
    int(42)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(8) "Reginald"
  }
}


Get all rows

  • ? DocResult::__construct
  • DocResult::fetchOne ?
  • PHP Manual
  • mysql_xdevapi\DocResult
  • Get all rows

DocResult::fetchAll

(No version information available, might only be in Git)

DocResult::fetchAll — Get all rows

说明

public mysql_xdevapi\DocResult::fetchAll ( ) : array

Fetch all results from a result set.

参数

此函数没有参数。

返回值

A numerical array with all results from the query; each result is an associative array. An empty array is returned if no rows are present.

范例

Example #1 mysql_xdevapi\DocResult::fetchAll() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$create->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();
$create->add('{"name": "Reginald", "age": 42, "job": "Butler"}')->execute();

// ...

$collection = $schema->getCollection("people");

// Yields a DocResult object
$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->sort('age desc')
  ->execute();

var_dump($result->fetchAll());
?>

以上例程的输出类似于：

array(2) {

  [0]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b53610000000000000123"
    ["age"]=>
    int(42)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(8) "Reginald"
  }

  [1]=>
  array(4) {
    ["_id"]=>
    string(28) "00005b6b53610000000000000122"
    ["age"]=>
    int(18)
    ["job"]=>
    string(6) "Butler"
    ["name"]=>
    string(6) "Alfred"
  }

}


Get one row

  • ? DocResult::fetchAll
  • DocResult::getWarnings ?
  • PHP Manual
  • mysql_xdevapi\DocResult
  • Get one row

DocResult::fetchOne

(No version information available, might only be in Git)

DocResult::fetchOne — Get one row

说明

public mysql_xdevapi\DocResult::fetchOne ( ) : array

Fetch one result from a result set.

参数

此函数没有参数。

返回值

The result, as an associative array or null if no results are present.

范例

Example #1 mysql_xdevapi\DocResult::fetchOne() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$create->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();
$create->add('{"name": "Reginald", "age": 42, "job": "Butler"}')->execute();

// ...

$collection = $schema->getCollection("people");

// Yields a DocResult object
$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->sort('age desc')
  ->execute();

var_dump($result->fetchOne());
?>

以上例程的输出类似于：

array(4) {
  ["_id"]=>
  string(28) "00005b6b53610000000000000125"
  ["age"]=>
  int(42)
  ["job"]=>
  string(6) "Butler"
  ["name"]=>
  string(8) "Reginald"
}


Get warnings from last operation

  • ? DocResult::fetchOne
  • DocResult::getWarningsCount ?
  • PHP Manual
  • mysql_xdevapi\DocResult
  • Get warnings from last operation

DocResult::getWarnings

(No version information available, might only be in Git)

DocResult::getWarnings — Get warnings from last operation

说明

public mysql_xdevapi\DocResult::getWarnings ( ) : Array

Fetches warnings generated by MySQL server's last operation.

参数

此函数没有参数。

返回值

An array of Warning objects from the last operation. Each object defines an error 'message', error 'level', and error 'code'. An empty array is returned if no errors are present.

范例

Example #1 mysql_xdevapi\DocResult::getWarnings() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$create->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();
$create->add('{"name": "Reginald", "age": 42, "job": "Butler"}')->execute();

// ...

$collection = $schema->getCollection("people");

// Yields a DocResult object
$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->sort('age desc')
  ->execute();

if (!$result->getWarningsCount()) {
    echo "There was an error:\n";
    print_r($result->getWarnings());
    exit;
}

var_dump($result->fetchOne());
?>

以上例程的输出类似于：

There was an error:

Array
(
    [0] => mysql_xdevapi\Warning Object
        (
            [message] => Something bad and so on
            [level] => 2
            [code] => 1365
        )
    [1] => mysql_xdevapi\Warning Object
        (
            [message] => Something bad and so on
            [level] => 2
            [code] => 1365
        )
)


Get warning count from last operation

  • ? DocResult::getWarnings
  • mysql_xdevapi\Exception ?
  • PHP Manual
  • mysql_xdevapi\DocResult
  • Get warning count from last operation

DocResult::getWarningsCount

(No version information available, might only be in Git)

DocResult::getWarningsCount — Get warning count from last operation

说明

public mysql_xdevapi\DocResult::getWarningsCount ( ) : int

Returns the number of warnings raised by the last operation. Specifically, these warnings are raised by the MySQL server.

参数

此函数没有参数。

返回值

The number of warnings from the last operation.

范例

Example #1 mysql_xdevapi\DocResult::getWarningsCount() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$create->add('{"name": "Alfred", "age": 18, "job": "Butler"}')->execute();
$create->add('{"name": "Reginald", "age": 42, "job": "Butler"}')->execute();

// ...

$collection = $schema->getCollection("people");

// Yields a DocResult object
$result = $collection
  ->find('job like :job and age > :age')
  ->bind(['job' => 'Butler', 'age' => 16])
  ->sort('age desc')
  ->execute();

if (!$result->getWarningsCount()) {
    echo "There was an error:\n";
    print_r($result->getWarnings());
    exit;
}

var_dump($result->fetchOne());
?>

以上例程的输出类似于：

array(4) {
  ["_id"]=>
  string(28) "00005b6b53610000000000000135"
  ["age"]=>
  int(42)
  ["job"]=>
  string(6) "Butler"
  ["name"]=>
  string(8) "Reginald"
}


Exception class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Exception extends RuntimeException implements Throwable {
}


Executable interface

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Executable {
/* 方法 */
abstract public execute ( ) : mysql_xdevapi\Result
}

Table of Contents

  • Executable::execute — Execute statement


Execute statement

  • ? mysql_xdevapi\Executable
  • mysql_xdevapi\ExecutionStatus ?
  • PHP Manual
  • mysql_xdevapi\Executable
  • Execute statement

Executable::execute

(No version information available, might only be in Git)

Executable::execute — Execute statement

说明

abstract public mysql_xdevapi\Executable::execute ( ) : mysql_xdevapi\Result

Execute the statement from either a collection operation or a table query; this functionality allows for method chaining.

参数

此函数没有参数。

返回值

One of the Result objects, such as Result or SqlStatementResult.

范例

Example #1 execute() examples

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$result_sql = $session->sql("CREATE DATABASE addressbook")->execute();

var_dump($result_sql);

$schema     = $session->getSchema("addressbook");
$collection = $schema->createCollection("humans");

$result_collection = $collection->add(
  '{"name": "Jane",
    "jobs": [{"title":"Scientist","Salary":18000}, {"title":"Mother","Salary":0}],
    "hobbies": ["Walking","Making pies"]}');

$result_collection_executed = $result_collection->execute();

var_dump($result_collection);
var_dump($result_collection_executed);
?>

以上例程的输出类似于：

object(mysql_xdevapi\SqlStatementResult)#3 (0) {
}

object(mysql_xdevapi\CollectionAdd)#5 (0) {
}

object(mysql_xdevapi\Result)#7 (0) {
}


ExecutionStatus class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\ExecutionStatus {
/* 属性 */
public $affectedItems ;
public $matchedItems ;
public $foundItems ;
public $lastInsertId ;
public $lastDocumentId ;
/* Constructor */
private __construct ( )
}

属性

affectedItems

matchedItems

foundItems

lastInsertId

lastDocumentId

Table of Contents

  • ExecutionStatus::__construct — ExecutionStatus constructor


ExecutionStatus constructor

  • ? mysql_xdevapi\ExecutionStatus
  • mysql_xdevapi\Expression ?
  • PHP Manual
  • mysql_xdevapi\ExecutionStatus
  • ExecutionStatus constructor

ExecutionStatus::__construct

(No version information available, might only be in Git)

ExecutionStatus::__construct — ExecutionStatus constructor

说明

private mysql_xdevapi\ExecutionStatus::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\ExecutionStatus::__construct() example

<?php

/* ... */

?>


Expression class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Expression {
/* 属性 */
public $name ;
/* Constructor */
public __construct ( string $expression )
}

属性

name

Table of Contents

  • Expression::__construct — Expression constructor


Expression constructor

  • ? mysql_xdevapi\Expression
  • mysql_xdevapi\Result ?
  • PHP Manual
  • mysql_xdevapi\Expression
  • Expression constructor

Expression::__construct

(No version information available, might only be in Git)

Expression::__construct — Expression constructor

说明

public mysql_xdevapi\Expression::__construct ( string $expression )

Warning

本函数还未编写文档，仅有参数列表。

参数

expression

范例

Example #1 mysql_xdevapi\Expression::__construct() example

<?php

/* ... */

?>


Result class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Result implements mysql_xdevapi\BaseResult , Traversable {
/* 方法 */
public getAffectedItemsCount ( ) : int
public getAutoIncrementValue ( ) : int
public getGeneratedIds ( ) : array
public getWarnings ( ) : array
public getWarningsCount ( ) : int
}

Table of Contents

  • Result::__construct — Result constructor
  • Result::getAffectedItemsCount — Get affected row count
  • Result::getAutoIncrementValue — Get autoincremented value
  • Result::getGeneratedIds — Get generated ids
  • Result::getWarnings — Get warnings from last operation
  • Result::getWarningsCount — Get warning count from last operation


Result constructor

  • ? mysql_xdevapi\Result
  • Result::getAffectedItemsCount ?
  • PHP Manual
  • mysql_xdevapi\Result
  • Result constructor

Result::__construct

(No version information available, might only be in Git)

Result::__construct — Result constructor

说明

private mysql_xdevapi\Result::__construct ( )

An object that retrieves generated IDs, AUTO_INCREMENT values, and warnings, for a Result set.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\Result::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("
  CREATE TABLE addressbook.names
    (id INT NOT NULL AUTO_INCREMENT, name VARCHAR(30), age INT, PRIMARY KEY (id))
  ")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->insert("name", "age")->values(["Suzanne", 31],["Julie", 43])->execute();
$result = $table->insert("name", "age")->values(["Suki", 34])->execute();

$ai = $result->getAutoIncrementValue();
var_dump($ai);
?>

以上例程会输出：

int(3)


Get affected row count

  • ? Result::__construct
  • Result::getAutoIncrementValue ?
  • PHP Manual
  • mysql_xdevapi\Result
  • Get affected row count

Result::getAffectedItemsCount

(No version information available, might only be in Git)

Result::getAffectedItemsCount — Get affected row count

说明

public mysql_xdevapi\Result::getAffectedItemsCount ( ) : int

Get the number of affected rows by the previous operation.

参数

此函数没有参数。

返回值

The number (as an integer) of affected rows.

范例

Example #1 mysql_xdevapi\Result::getAffectedItemsCount() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$collection = $schema->getCollection("people");

$result = $collection->add('{"name": "Wilma", "age": 23, "job": "Teacher"}')->execute();

var_dump( $res->getAffectedItemsCount() );
?>

以上例程会输出：

int(1)


Get autoincremented value

  • ? Result::getAffectedItemsCount
  • Result::getGeneratedIds ?
  • PHP Manual
  • mysql_xdevapi\Result
  • Get autoincremented value

Result::getAutoIncrementValue

(No version information available, might only be in Git)

Result::getAutoIncrementValue — Get autoincremented value

说明

public mysql_xdevapi\Result::getAutoIncrementValue ( ) : int

Get the last AUTO_INCREMENT value (last insert id).

参数

此函数没有参数。

返回值

The last AUTO_INCREMENT value.

范例

Example #1 mysql_xdevapi\Result::getAutoIncrementValue() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("
  CREATE TABLE addressbook.names
    (id INT NOT NULL AUTO_INCREMENT, name VARCHAR(30), age INT, PRIMARY KEY (id))
  ")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->insert("name", "age")->values(["Suzanne", 31],["Julie", 43])->execute();
$result = $table->insert("name", "age")->values(["Suki", 34])->execute();

$ai = $result->getAutoIncrementValue();
var_dump($ai);
?>

以上例程会输出：

int(3)


Get generated ids

  • ? Result::getAutoIncrementValue
  • Result::getWarnings ?
  • PHP Manual
  • mysql_xdevapi\Result
  • Get generated ids

Result::getGeneratedIds

(No version information available, might only be in Git)

Result::getGeneratedIds — Get generated ids

说明

public mysql_xdevapi\Result::getGeneratedIds ( ) : array

Fetch the generated _id values from the last operation. The unique _id field is generated by the MySQL server.

参数

此函数没有参数。

返回值

An array of generated _id's from the last operation, or an empty array if there are none.

范例

Example #1 mysql_xdevapi\Result::getGeneratedIds() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema = $session->getSchema("addressbook");
$create = $schema->createCollection("people");

$collection = $schema->getCollection("people");

$result = $collection->add(
  '{"name": "Bernie",
    "jobs": [{"title":"Cat Herder","Salary":42000}, {"title":"Father","Salary":0}],
    "hobbies": ["Sports","Making cupcakes"]}',
  '{"name": "Jane",
    "jobs": [{"title":"Scientist","Salary":18000}, {"title":"Mother","Salary":0}],
    "hobbies": ["Walking","Making pies"]}')->execute();

$ids = $result->getGeneratedIds();
var_dump($ids);
?>

以上例程的输出类似于：

array(2) {
  [0]=>
  string(28) "00005b6b53610000000000000064"
  [1]=>
  string(28) "00005b6b53610000000000000065"
}


Get warnings from last operation

  • ? Result::getGeneratedIds
  • Result::getWarningsCount ?
  • PHP Manual
  • mysql_xdevapi\Result
  • Get warnings from last operation

Result::getWarnings

(No version information available, might only be in Git)

Result::getWarnings — Get warnings from last operation

说明

public mysql_xdevapi\Result::getWarnings ( ) : array

Retrieve warnings from the last Result operation.

参数

此函数没有参数。

返回值

An array of Warning objects from the last operation. Each object defines an error 'message', error 'level', and error 'code'. An empty array is returned if no errors are present.

范例

Example #1 mysql_xdevapi\RowResult::getWarnings() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();

$schema = $session->getSchema("foo");
$table  = $schema->getTable("test_table");

$table->insert(['x'])->values([1])->values([2])->execute();

$res = $table->select(['x/0 as bad_x'])->execute();
$warnings = $res->getWarnings();

print_r($warnings);
?>

以上例程的输出类似于：

Array
(
    [0] => mysql_xdevapi\Warning Object
        (
            [message] => Division by 0
            [level] => 2
            [code] => 1365
        )
    [1] => mysql_xdevapi\Warning Object
        (
            [message] => Division by 0
            [level] => 2
            [code] => 1365
        )
)


Get warning count from last operation

  • ? Result::getWarnings
  • mysql_xdevapi\RowResult ?
  • PHP Manual
  • mysql_xdevapi\Result
  • Get warning count from last operation

Result::getWarningsCount

(No version information available, might only be in Git)

Result::getWarningsCount — Get warning count from last operation

说明

public mysql_xdevapi\Result::getWarningsCount ( ) : int

Retrieve the number of warnings from the last Result operation.

参数

此函数没有参数。

返回值

The number of warnings generated by the last operation.

范例

Example #1 mysql_xdevapi\RowResult::getWarningsCount() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS foo")->execute();
$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();

$schema = $session->getSchema("foo");
$table  = $schema->getTable("test_table");

$table->insert(['x'])->values([1])->values([2])->execute();

$res = $table->select(['x/0 as bad_x'])->execute();

echo $res->getWarningsCount();
?>

以上例程的输出类似于：

2


RowResult class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\RowResult implements mysql_xdevapi\BaseResult , Traversable {
/* 方法 */
public fetchAll ( ) : array
public fetchOne ( ) : array
public getColumnsCount ( ) : int
public getColumnNames ( ) : array
public getColumns ( ) : array
public getWarnings ( ) : array
public getWarningsCount ( ) : int
}

Table of Contents

  • RowResult::__construct — RowResult constructor
  • RowResult::fetchAll — Get all rows from result
  • RowResult::fetchOne — Get row from result
  • RowResult::getColumnsCount — Get column count
  • RowResult::getColumnNames — Get all column names
  • RowResult::getColumns — Get column metadata
  • RowResult::getWarnings — Get warnings from last operation
  • RowResult::getWarningsCount — Get warning count from last operation


RowResult constructor

  • ? mysql_xdevapi\RowResult
  • RowResult::fetchAll ?
  • PHP Manual
  • mysql_xdevapi\RowResult
  • RowResult constructor

RowResult::__construct

(No version information available, might only be in Git)

RowResult::__construct — RowResult constructor

说明

private mysql_xdevapi\RowResult::__construct ( )

Represents the result set obtained from querying the database.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\RowResult::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$row = $table->select('name', 'age')->where('age > 18')->execute()->fetchAll();

print_r($row);

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
    [1] => Array
        (
            [name] => Sam
            [age] => 33
        )
)


Get all rows from result

  • ? RowResult::__construct
  • RowResult::fetchOne ?
  • PHP Manual
  • mysql_xdevapi\RowResult
  • Get all rows from result

RowResult::fetchAll

(No version information available, might only be in Git)

RowResult::fetchAll — Get all rows from result

说明

public mysql_xdevapi\RowResult::fetchAll ( ) : array

Fetch all the rows from the result set.

参数

此函数没有参数。

返回值

A numerical array with all results from the query; each result is an associative array. An empty array is returned if no rows are present.

范例

Example #1 mysql_xdevapi\RowResult::fetchAll() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$row = $table->select('name', 'age')->execute()->fetchAll();

print_r($row);

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
    [1] => Array
        (
            [name] => Sam
            [age] => 33
        )
)


Get row from result

  • ? RowResult::fetchAll
  • RowResult::getColumnsCount ?
  • PHP Manual
  • mysql_xdevapi\RowResult
  • Get row from result

RowResult::fetchOne

(No version information available, might only be in Git)

RowResult::fetchOne — Get row from result

说明

public mysql_xdevapi\RowResult::fetchOne ( ) : array

Fetch one result from the result set.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The result, as an associative array or null if no results are present.

范例

Example #1 mysql_xdevapi\RowResult::fetchOne() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$row = $table->select('name', 'age')->where('age < 40')->execute()->fetchOne();

print_r($row);

以上例程的输出类似于：

Array
(
    [name] => Sam
    [age] => 33
)


Get column count

  • ? RowResult::fetchOne
  • RowResult::getColumnNames ?
  • PHP Manual
  • mysql_xdevapi\RowResult
  • Get column count

RowResult::getColumnsCount

(No version information available, might only be in Git)

RowResult::getColumnsCount — Get column count

说明

public mysql_xdevapi\RowResult::getColumnsCount ( ) : int

Retrieve the column count for columns present in the result set.

参数

此函数没有参数。

返回值

The number of columns; 0 if there are none.

更新日志

版本 | 说明
8.0.14 | Method renamed from getColumnCount() to getColumnsCount().

范例

Example #1 mysql_xdevapi\RowResult::getColumnsCount() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE addressbook")->execute();
$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$sql = $session->sql("SELECT * from addressbook.names")->execute();

echo $sql->getColumnsCount();

以上例程的输出类似于：

2


Get all column names

  • ? RowResult::getColumnsCount
  • RowResult::getColumns ?
  • PHP Manual
  • mysql_xdevapi\RowResult
  • Get all column names

RowResult::getColumnNames

(No version information available, might only be in Git)

RowResult::getColumnNames — Get all column names

说明

public mysql_xdevapi\RowResult::getColumnNames ( ) : array

Retrieve column names for columns present in the result set.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A numerical array of table columns names, or an empty array if the result set is empty.

范例

Example #1 mysql_xdevapi\RowResult::getColumnNames() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE addressbook")->execute();
$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$sql = $session->sql("SELECT * from addressbook.names")->execute();

$colnames = $sql->getColumnNames();

print_r($colnames);

以上例程的输出类似于：

Array
(
    [0] => name
    [1] => age
)


Get column metadata

  • ? RowResult::getColumnNames
  • RowResult::getWarnings ?
  • PHP Manual
  • mysql_xdevapi\RowResult
  • Get column metadata

RowResult::getColumns

(No version information available, might only be in Git)

RowResult::getColumns — Get column metadata

说明

public mysql_xdevapi\RowResult::getColumns ( ) : array

Retrieve column metadata for columns present in the result set.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

An array of FieldMetadata objects representing the columns in the result, or an empty array if the result set is empty.

范例

Example #1 mysql_xdevapi\RowResult::getColumns() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE addressbook")->execute();
$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$sql = $session->sql("SELECT * from addressbook.names")->execute();

$cols = $sql->getColumns();

print_r($cols);

以上例程的输出类似于：

Array
(
    [0] => mysql_xdevapi\FieldMetadata Object
        (
            [type] => 7
            [type_name] => BYTES
            [name] => name
            [original_name] => name
            [table] => names
            [original_table] => names
            [schema] => addressbook
            [catalog] => def
            [collation] => 255
            [fractional_digits] => 0
            [length] => 65535
            [flags] => 0
            [content_type] => 0
        )
    [1] => mysql_xdevapi\FieldMetadata Object
        (
            [type] => 1
            [type_name] => SINT
            [name] => age
            [original_name] => age
            [table] => names
            [original_table] => names
            [schema] => addressbook
            [catalog] => def
            [collation] => 0
            [fractional_digits] => 0
            [length] => 11
            [flags] => 0
            [content_type] => 0
        )
)


Get warnings from last operation

  • ? RowResult::getColumns
  • RowResult::getWarningsCount ?
  • PHP Manual
  • mysql_xdevapi\RowResult
  • Get warnings from last operation

RowResult::getWarnings

(No version information available, might only be in Git)

RowResult::getWarnings — Get warnings from last operation

说明

public mysql_xdevapi\RowResult::getWarnings ( ) : array

Retrieve warnings from the last RowResult operation.

参数

此函数没有参数。

返回值

An array of Warning objects from the last operation. Each object defines an error 'message', error 'level', and error 'code'. An empty array is returned if no errors are present.

范例

Example #1 mysql_xdevapi\RowResult::getWarnings() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();

$schema = $session->getSchema("foo");
$table  = $schema->getTable("test_table");

$table->insert(['x'])->values([1])->values([2])->execute();

$res = $table->select(['x/0 as bad_x'])->execute();
$warnings = $res->getWarnings();

print_r($warnings);
?>

以上例程的输出类似于：

Array
(
    [0] => mysql_xdevapi\Warning Object
        (
            [message] => Division by 0
            [level] => 2
            [code] => 1365
        )
    [1] => mysql_xdevapi\Warning Object
        (
            [message] => Division by 0
            [level] => 2
            [code] => 1365
        )
)


Get warning count from last operation

  • ? RowResult::getWarnings
  • mysql_xdevapi\Schema ?
  • PHP Manual
  • mysql_xdevapi\RowResult
  • Get warning count from last operation

RowResult::getWarningsCount

(No version information available, might only be in Git)

RowResult::getWarningsCount — Get warning count from last operation

说明

public mysql_xdevapi\RowResult::getWarningsCount ( ) : int

Retrieve the number of warnings from the last RowResult operation.

参数

此函数没有参数。

返回值

The number of warnings generated by the last operation.

范例

Example #1 mysql_xdevapi\RowResult::getWarningsCount() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS foo")->execute();
$session->sql("CREATE DATABASE foo")->execute();
$session->sql("CREATE TABLE foo.test_table(x int)")->execute();

$schema = $session->getSchema("foo");
$table  = $schema->getTable("test_table");

$table->insert(['x'])->values([1])->values([2])->execute();

$res = $table->select(['x/0 as bad_x'])->execute();

echo $res->getWarningsCount();
?>

以上例程的输出类似于：

2


Schema class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Schema implements mysql_xdevapi\DatabaseObject {
/* 属性 */
public $name ;
/* 方法 */
public createCollection ( string $name ) : mysql_xdevapi\Collection
public dropCollection ( string $collection_name ) : bool
public existsInDatabase ( ) : bool
public getCollection ( string $name ) : mysql_xdevapi\Collection
public getCollectionAsTable ( string $name ) : mysql_xdevapi\Table
public getCollections ( ) : array
public getName ( ) : string
public getSession ( ) : mysql_xdevapi\Session
public getTable ( string $name ) : mysql_xdevapi\Table
public getTables ( ) : array
}

属性

name

Table of Contents

  • Schema::__construct — constructor
  • Schema::createCollection — Add collection to schema
  • Schema::dropCollection — Drop collection from schema
  • Schema::existsInDatabase — Check if exists in database
  • Schema::getCollection — Get collection from schema
  • Schema::getCollectionAsTable — Get collection table object
  • Schema::getCollections — Get all schema collections
  • Schema::getName — Get schema name
  • Schema::getSession — Get schema session
  • Schema::getTable — Get schema table
  • Schema::getTables — Get schema tables


constructor

  • ? mysql_xdevapi\Schema
  • Schema::createCollection ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • constructor

Schema::__construct

(No version information available, might only be in Git)

Schema::__construct — constructor

说明

private mysql_xdevapi\Schema::__construct ( )

The Schema object provides full access to the schema (database).

参数

此函数没有参数。

范例

Example #1 Schema::__construct example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS food")->execute();
$session->sql("CREATE DATABASE food")->execute();
$session->sql("CREATE TABLE food.fruit(name text, rating text)")->execute();

$schema = $session->getSchema("food");
$schema->createCollection("trees");

print_r($schema->gettables());
print_r($schema->getcollections());

以上例程的输出类似于：

Array
(
    [fruit] => mysql_xdevapi\Table Object
        (
            [name] => fruit
        )
)
Array
(
    [trees] => mysql_xdevapi\Collection Object
        (
            [name] => trees
        )
)


Add collection to schema

  • ? Schema::__construct
  • Schema::dropCollection ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Add collection to schema

Schema::createCollection

(No version information available, might only be in Git)

Schema::createCollection — Add collection to schema

说明

public mysql_xdevapi\Schema::createCollection ( string $name ) : mysql_xdevapi\Collection

Create a collection within the schema.

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值

范例

Example #1 Schema::createCollection example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS food")->execute();
$session->sql("CREATE DATABASE food")->execute();
$session->sql("CREATE TABLE food.fruit(name text, rating text)")->execute();

$schema = $session->getSchema("food");
$schema->createCollection("trees");

print_r($schema->gettables());
print_r($schema->getcollections());

以上例程的输出类似于：

Array
(
    [fruit] => mysql_xdevapi\Table Object
        (
            [name] => fruit
        )
)
Array
(
    [trees] => mysql_xdevapi\Collection Object
        (
            [name] => trees
        )
)


Drop collection from schema

  • ? Schema::createCollection
  • Schema::existsInDatabase ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Drop collection from schema

Schema::dropCollection

(No version information available, might only be in Git)

Schema::dropCollection — Drop collection from schema

说明

public mysql_xdevapi\Schema::dropCollection ( string $collection_name ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

collection_name

返回值

范例

Example #1 Schema::dropCollection example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS food")->execute();
$session->sql("CREATE DATABASE food")->execute();
$session->sql("CREATE TABLE food.fruit(name text, rating text)")->execute();

$schema = $session->getSchema("food");

$schema->createCollection("trees");
$schema->dropCollection("trees");
$schema->createCollection("buildings");

print_r($schema->gettables());
print_r($schema->getcollections());

以上例程的输出类似于：

Array
(
    [fruit] => mysql_xdevapi\Table Object
        (
            [name] => fruit
        )
)
Array
(
    [buildings] => mysql_xdevapi\Collection Object
        (
            [name] => buildings
        )
)


Check if exists in database

  • ? Schema::dropCollection
  • Schema::getCollection ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Check if exists in database

Schema::existsInDatabase

(No version information available, might only be in Git)

Schema::existsInDatabase — Check if exists in database

说明

public mysql_xdevapi\Schema::existsInDatabase ( ) : bool

Checks if the current object (schema, table, collection, or view) exists in the schema object.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the schema, table, collection, or view still exists in the schema, else false.

范例

Example #1 Schema::existsInDatabase example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS food")->execute();
$session->sql("CREATE DATABASE food")->execute();
$session->sql("CREATE TABLE food.fruit(name text, rating text)")->execute();

$schema = $session->getSchema("food");
$schema->createCollection("trees");

// ...

$trees = $schema->getCollection("trees");

// ...

// Is this collection still in the database (schema)?
if ($trees->existsInDatabase()) {
    echo "Yes, the 'trees' collection is still present.";
}

以上例程的输出类似于：

Yes, the 'trees' collection is still present.


Get collection from schema

  • ? Schema::existsInDatabase
  • Schema::getCollectionAsTable ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Get collection from schema

Schema::getCollection

(No version information available, might only be in Git)

Schema::getCollection — Get collection from schema

说明

public mysql_xdevapi\Schema::getCollection ( string $name ) : mysql_xdevapi\Collection

Get a collection from the schema.

参数

name

Collection name to retrieve.

返回值

The Collection object for the selected collection.

范例

Example #1 Schema::getCollection example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS food")->execute();
$session->sql("CREATE DATABASE food")->execute();

$schema = $session->getSchema("food");
$schema->createCollection("trees");

// ...

$trees = $schema->getCollection("trees");

var_dump($trees);

以上例程的输出类似于：

object(mysql_xdevapi\Collection)#3 (1) {
  ["name"]=>
  string(5) "trees"
}


Get collection table object

  • ? Schema::getCollection
  • Schema::getCollections ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Get collection table object

Schema::getCollectionAsTable

(No version information available, might only be in Git)

Schema::getCollectionAsTable — Get collection table object

说明

public mysql_xdevapi\Schema::getCollectionAsTable ( string $name ) : mysql_xdevapi\Table

Get a collection, but as a Table object instead of a Collection object.

参数

name

Name of the collection to instantiate a Table object from.

返回值

A table object for the collection.

范例

Example #1 Schema::getCollectionAsTable example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema  = $session->getSchema("addressbook");
$collect = $schema->createCollection("people");
$collect->add('{"name": "Fred",  "age": 21, "job": "Construction"}')->execute();
$collect->add('{"name": "Wilma", "age": 23, "job": "Teacher"}')->execute();

$table      = $schema->getCollectionAsTable("people");
$collection = $schema->getCollection("people");

var_dump($table);
var_dump($collection);

以上例程的输出类似于：

object(mysql_xdevapi\Table)#4 (1) {
  ["name"]=>
  string(6) "people"
}

object(mysql_xdevapi\Collection)#5 (1) {
  ["name"]=>
  string(6) "people"
}


Get all schema collections

  • ? Schema::getCollectionAsTable
  • Schema::getName ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Get all schema collections

Schema::getCollections

(No version information available, might only be in Git)

Schema::getCollections — Get all schema collections

说明

public mysql_xdevapi\Schema::getCollections ( ) : array

Fetch a list of collections for this schema.

参数

此函数没有参数。

返回值

Array of all collections in this schema, where each array element value is a Collection object with the collection name as the key.

范例

Example #1 mysql_xdevapi\Schema::getCollections() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema  = $session->getSchema("addressbook");
$collect = $schema->createCollection("people");
$collect->add('{"name": "Fred",  "age": 21, "job": "Construction"}')->execute();
$collect->add('{"name": "Wilma", "age": 23, "job": "Teacher"}')->execute();

$collections = $schema->getCollections();
var_dump($collections);
?>

以上例程的输出类似于：

array(1) {
  ["people"]=>
  object(mysql_xdevapi\Collection)#4 (1) {
    ["name"]=>
    string(6) "people"
  }
}


Get schema name

  • ? Schema::getCollections
  • Schema::getSession ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Get schema name

Schema::getName

(No version information available, might only be in Git)

Schema::getName — Get schema name

说明

public mysql_xdevapi\Schema::getName ( ) : string

Get the name of the schema.

参数

此函数没有参数。

返回值

The name of the schema connected to the schema object, as a string.

范例

Example #1 mysql_xdevapi\Schema::getName() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema  = $session->getSchema("addressbook");

// ...

var_dump($schema->getName());
?>

以上例程的输出类似于：

string(11) "addressbook"


Get schema session

  • ? Schema::getName
  • Schema::getTable ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Get schema session

Schema::getSession

(No version information available, might only be in Git)

Schema::getSession — Get schema session

说明

public mysql_xdevapi\Schema::getSession ( ) : mysql_xdevapi\Session

Get a new Session object from the Schema object.

参数

此函数没有参数。

返回值

A Session object.

范例

Example #1 mysql_xdevapi\Schema::getSession() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$schema  = $session->getSchema("addressbook");

// ...

$newsession = $schema->getSession();

var_dump($session);
var_dump($newsession);
?>

以上例程的输出类似于：

object(mysql_xdevapi\Session)#1 (0) {
}

object(mysql_xdevapi\Session)#3 (0) {
}


Get schema table

  • ? Schema::getSession
  • Schema::getTables ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Get schema table

Schema::getTable

(No version information available, might only be in Git)

Schema::getTable — Get schema table

说明

public mysql_xdevapi\Schema::getTable ( string $name ) : mysql_xdevapi\Table

Fetch a Table object for the provided table in the schema.

参数

name

Name of the table.

返回值

A Table object.

范例

Example #1 mysql_xdevapi\Schema::getTable() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$row = $table->select('name', 'age')->execute()->fetchAll();

print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
    [1] => Array
        (
            [name] => Sam
            [age] => 33
        )
)


Get schema tables

  • ? Schema::getTable
  • mysql_xdevapi\SchemaObject ?
  • PHP Manual
  • mysql_xdevapi\Schema
  • Get schema tables

Schema::getTables

(No version information available, might only be in Git)

Schema::getTables — Get schema tables

说明

public mysql_xdevapi\Schema::getTables ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Array of all tables in this schema, where each array element value is a Table object with the table name as the key.

范例

Example #1 mysql_xdevapi\Schema::getTables() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();

$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$session->sql("CREATE TABLE addressbook.cities(name text, population int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('Portland', 639863), ('Seattle', 704352)")->execute();

$schema = $session->getSchema("addressbook");
$tables = $schema->getTables();

var_dump($tables);
?>

以上例程的输出类似于：

array(2) {
  ["cities"]=>
  object(mysql_xdevapi\Table)#3 (1) {
    ["name"]=>
    string(6) "cities"
  }

  ["names"]=>
  object(mysql_xdevapi\Table)#4 (1) {
    ["name"]=>
    string(5) "names"
  }
}


SchemaObject interface

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\SchemaObject implements mysql_xdevapi\DatabaseObject {
/* 方法 */
abstract getSchema ( ) : mysql_xdevapi\Schema
}

Table of Contents

  • SchemaObject::getSchema — Get schema object


Get schema object

  • ? mysql_xdevapi\SchemaObject
  • mysql_xdevapi\Session ?
  • PHP Manual
  • mysql_xdevapi\SchemaObject
  • Get schema object

SchemaObject::getSchema

(No version information available, might only be in Git)

SchemaObject::getSchema — Get schema object

说明

abstract mysql_xdevapi\SchemaObject::getSchema ( ) : mysql_xdevapi\Schema

Used by other objects to retrieve a schema object.

参数

此函数没有参数。

返回值

The current Schema object.

范例

Example #1 mysql_xdevapi\Session::getSchema() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$schema  = $session->getSchema("addressbook");

print_r($schema);

以上例程的输出类似于：

mysql_xdevapi\Schema Object
(
    [name] => addressbook
)


Session class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Session {
/* 方法 */
public close ( ) : bool
public commit ( ) : Object
public createSchema ( string $schema_name ) : mysql_xdevapi\Schema
public dropSchema ( string $schema_name ) : bool
public generateUUID ( ) : string
public getDefaultSchema ( ) : string
public getSchema ( string $schema_name ) : mysql_xdevapi\Schema
public getSchemas ( ) : array
public getServerVersion ( ) : int
public listClients ( ) : array
public quoteName ( string $name ) : string
public releaseSavepoint ( string $name ) : void
public rollback ( ) : void
public rollbackTo ( string $name ) : void
public setSavepoint ( string $name = ? ) : string
public sql ( string $query ) : mysql_xdevapi\SqlStatement
public startTransaction ( ) : void
}

Table of Contents

  • Session::close — Close session
  • Session::commit — Commit transaction
  • Session::__construct — Description constructor
  • Session::createSchema — Create new schema
  • Session::dropSchema — Drop a schema
  • Session::generateUUID — Get new UUID
  • Session::getDefaultSchema — Get default schema name
  • Session::getSchema — Get a new schema object
  • Session::getSchemas — Get the schemas
  • Session::getServerVersion — Get server version
  • Session::listClients — Get client list
  • Session::quoteName — Add quotes
  • Session::releaseSavepoint — Release set savepoint
  • Session::rollback — Rollback transaction
  • Session::rollbackTo — Rollback transaction to savepoint
  • Session::setSavepoint — Create savepoint
  • Session::sql — Execute SQL query
  • Session::startTransaction — Start transaction


Close session

  • ? mysql_xdevapi\Session
  • Session::commit ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Close session

Session::close

(No version information available, might only be in Git)

Session::close — Close session

说明

public mysql_xdevapi\Session::close ( ) : bool

Close the session with the server.

参数

此函数没有参数。

返回值

true if the session closed.

范例

Example #1 mysql_xdevapi\Session::close() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$session->close();


Commit transaction

  • ? Session::close
  • Session::__construct ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Commit transaction

Session::commit

(PHP 4 >= 4.4.0, PHP 5, PHP 7, PHP 8)

Session::commit — Commit transaction

说明

public mysql_xdevapi\Session::commit ( ) : Object

Commit the transaction.

参数

此函数没有参数。

返回值

An SqlStatementResult object.

范例

Example #1 mysql_xdevapi\Session::commit() example

<?php
$session    = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$collection = $session->getSchema("addressbook")->getCollection("friends");

$session->startTransaction();

$collection->add('{"John":42, "Sam":33}')->execute();
$savepoint = $session->setSavepoint();

$session->commit();
$session->close();


Description constructor

  • ? Session::commit
  • Session::createSchema ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Description constructor

Session::__construct

(No version information available, might only be in Git)

Session::__construct — Description constructor

说明

private mysql_xdevapi\Session::__construct ( )

A Session object, as initiated by getSession().

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\Session::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->close();
?>


Create new schema

  • ? Session::__construct
  • Session::dropSchema ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Create new schema

Session::createSchema

(No version information available, might only be in Git)

Session::createSchema — Create new schema

说明

public mysql_xdevapi\Session::createSchema ( string $schema_name ) : mysql_xdevapi\Schema

Creates a new schema.

参数

schema_name

Name of the schema to create.

返回值

A Schema object on success, and emits an exception on failure.

范例

Example #1 mysql_xdevapi\Session::createSchema() example

<?php
$uri  = 'mysqlx://happyuser:password@127.0.0.1:33060/';
$sess = mysql_xdevapi\getSession($uri);

try {

    if ($schema = $sess->createSchema('fruit')) {
        echo "Info: I created a schema named 'fruit'\n";
    }

} catch (Exception $e) {

   echo $e->getMessage();

}
?>

以上例程的输出类似于：

Info: I created a schema named 'fruit'


Drop a schema

  • ? Session::createSchema
  • Session::generateUUID ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Drop a schema

Session::dropSchema

(No version information available, might only be in Git)

Session::dropSchema — Drop a schema

说明

public mysql_xdevapi\Session::dropSchema ( string $schema_name ) : bool

Drop a schema (database).

参数

schema_name

Name of the schema to drop.

返回值

true if the schema is dropped, or false if it does not exist or can't be dropped.

An E_WARNING level error is generated if the schema does not exist.

范例

Example #1 mysql_xdevapi\Session::dropSchema() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->dropSchema("addressbook");

$session->close();
?>


Get new UUID

  • ? Session::dropSchema
  • Session::getDefaultSchema ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Get new UUID

Session::generateUUID

(No version information available, might only be in Git)

Session::generateUUID — Get new UUID

说明

public mysql_xdevapi\Session::generateUUID ( ) : string

Generate a Universal Unique IDentifier (UUID) generated according to » RFC 4122.

参数

此函数没有参数。

返回值

The UUID; a string with a length of 32.

范例

Example #1 mysql_xdevapi\Session::generateUuid() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$uuid = $session->generateUuid();

var_dump($uuid);

以上例程的输出类似于：

string(32) "484B18AC7980F8D4FE84613CDA5EE84B"


Get default schema name

  • ? Session::generateUUID
  • Session::getSchema ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Get default schema name

Session::getDefaultSchema

(No version information available, might only be in Git)

Session::getDefaultSchema — Get default schema name

说明

public mysql_xdevapi\Session::getDefaultSchema ( ) : string

Retrieve name of the default schema that's typically set in the connection URI.

参数

此函数没有参数。

返回值

Name of the default schema defined by the connection, or null if one was not set.

范例

Example #1 mysql_xdevapi\Session::getSchema() example

<?php
$uri = "mysqlx://testuser:testpasswd@localhost:33160/testx?ssl-mode=disabled";
$session = mysql_xdevapi\getSession($uri);

$schema = $session->getDefaultSchema();
echo $schema;
?>

以上例程会输出：

testx


Get a new schema object

  • ? Session::getDefaultSchema
  • Session::getSchemas ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Get a new schema object

Session::getSchema

(No version information available, might only be in Git)

Session::getSchema — Get a new schema object

说明

public mysql_xdevapi\Session::getSchema ( string $schema_name ) : mysql_xdevapi\Schema

A new Schema object for the provided schema name.

参数

schema_name

Name of the schema (database) to fetch a Schema object for.

返回值

A Schema object.

范例

Example #1 mysql_xdevapi\Session::getSchema() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$schema  = $session->getSchema("addressbook");

print_r($schema);

以上例程的输出类似于：

mysql_xdevapi\Schema Object
(
    [name] => addressbook
)


Get the schemas

  • ? Session::getSchema
  • Session::getServerVersion ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Get the schemas

Session::getSchemas

(No version information available, might only be in Git)

Session::getSchemas — Get the schemas

说明

public mysql_xdevapi\Session::getSchemas ( ) : array

Get schema objects for all schemas available to the session.

参数

此函数没有参数。

返回值

An array containing objects that represent all of the schemas available to the session.

范例

Example #1 mysql_xdevapi\Session::getSchemas() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$schemas  = $session->getSchemas();

print_r($schemas);

以上例程的输出类似于：

Array
(
    [0] => mysql_xdevapi\Schema Object
        (
            [name] => addressbook
        )
    [1] => mysql_xdevapi\Schema Object
        (
            [name] => information_schema
        )
    ...


Get server version

  • ? Session::getSchemas
  • Session::listClients ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Get server version

Session::getServerVersion

(No version information available, might only be in Git)

Session::getServerVersion — Get server version

说明

public mysql_xdevapi\Session::getServerVersion ( ) : int

Retrieve the MySQL server version for the session.

参数

此函数没有参数。

返回值

The MySQL server version for the session, as an integer such as "80012".

范例

Example #1 mysql_xdevapi\Session::getServerVersion() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$version = $session->getServerVersion();

var_dump($version);

以上例程的输出类似于：

int(80012)


Get client list

  • ? Session::getServerVersion
  • Session::quoteName ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Get client list

Session::listClients

(No version information available, might only be in Git)

Session::listClients — Get client list

说明

public mysql_xdevapi\Session::listClients ( ) : array

Get a list of client connections to the session's MySQL server.

参数

此函数没有参数。

返回值

An array containing the currently logged clients. The array elements are "client_id", "user", "host", and "sql_session".

范例

Example #1 mysql_xdevapi\Session::listClients() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$ids = $session->listClients();

var_dump($ids);
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(4) {
    ["client_id"]=>
    int(61)
    ["user"]=>
    string(4) "root"
    ["host"]=>
    string(9) "localhost"
    ["sql_session"]=>
    int(72)
  }
}


Add quotes

  • ? Session::listClients
  • Session::releaseSavepoint ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Add quotes

Session::quoteName

(No version information available, might only be in Git)

Session::quoteName — Add quotes

说明

public mysql_xdevapi\Session::quoteName ( string $name ) : string

A quoting function to escape SQL names and identifiers. It escapes the identifier given in accordance to the settings of the current connection. This escape function should not be used to escape values.

参数

name

The string to quote.

返回值

The quoted string.

范例

Example #1 mysql_xdevapi\Session::quoteName() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$first = "MySQL's test";
var_dump($first);
var_dump($session->quoteName($first));

$second = 'Another `test` "like" `this`';
var_dump($second);
var_dump($session->quoteName($second));
?>

以上例程的输出类似于：

string(12) "MySQL's test"
string(14) "`MySQL's test`"

string(28) "Another `test` "like" `this`"
string(34) "`Another ``test`` "like" ``this```"


Release set savepoint

  • ? Session::quoteName
  • Session::rollback ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Release set savepoint

Session::releaseSavepoint

(No version information available, might only be in Git)

Session::releaseSavepoint — Release set savepoint

说明

public mysql_xdevapi\Session::releaseSavepoint ( string $name ) : void

Release a previously set savepoint.

参数

name

Name of the savepoint to release.

返回值

An SqlStatementResult object.

范例

Example #1 mysql_xdevapi\Session::releaseSavepoint() example

<?php
$session    = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$collection = $session->getSchema("addressbook")->getCollection("friends");

$session->startTransaction();
$collection->add( '{"test1":1, "test2":2}' )->execute();

$savepoint = $session->setSavepoint();

$collection->add( '{"test3":3, "test4":4}' )->execute();

$session->releaseSavepoint($savepoint);
$session->rollback();
?>


Rollback transaction

  • ? Session::releaseSavepoint
  • Session::rollbackTo ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Rollback transaction

Session::rollback

(No version information available, might only be in Git)

Session::rollback — Rollback transaction

说明

public mysql_xdevapi\Session::rollback ( ) : void

Rollback the transaction.

参数

此函数没有参数。

返回值

An SqlStatementResult object.

范例

Example #1 mysql_xdevapi\Session::rollback() example

<?php
$session    = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$collection = $session->getSchema("addressbook")->getCollection("names");

$session->startTransaction();
$collection->add( '{"test1":1, "test2":2}' )->execute();

$savepoint = $session->setSavepoint();

$collection->add( '{"test3":3, "test4":4}' )->execute();

$session->releaseSavepoint($savepoint);
$session->rollback();
?>


Rollback transaction to savepoint

  • ? Session::rollback
  • Session::setSavepoint ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Rollback transaction to savepoint

Session::rollbackTo

(No version information available, might only be in Git)

Session::rollbackTo — Rollback transaction to savepoint

说明

public mysql_xdevapi\Session::rollbackTo ( string $name ) : void

Rollback the transaction back to the savepoint.

参数

name

Name of the savepoint to rollback to; case-insensitive.

返回值

An SqlStatementResult object.

范例

Example #1 mysql_xdevapi\Session::rollbackTo() example

<?php
$session    = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$collection = $session->getSchema("addressbook")->getCollection("names");

$session->startTransaction();
$collection->add( '{"test1":1, "test2":2}' )->execute();

$savepoint1 = $session->setSavepoint();

$collection->add( '{"test3":3, "test4":4}' )->execute();

$savepoint2 = $session->setSavepoint();

$session->rollbackTo($savepoint1);
?>


Create savepoint

  • ? Session::rollbackTo
  • Session::sql ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Create savepoint

Session::setSavepoint

(No version information available, might only be in Git)

Session::setSavepoint — Create savepoint

说明

public mysql_xdevapi\Session::setSavepoint ( string $name = ? ) : string

Create a new savepoint for the transaction.

Warning

本函数还未编写文档，仅有参数列表。

参数

name

The name of the savepoint. The name is auto-generated if the optional name parameter is not defined as 'SAVEPOINT1', 'SAVEPOINT2', and so on.

返回值

The name of the save point.

范例

Example #1 mysql_xdevapi\Session::setSavepoint() example

<?php
$session    = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$collection = $session->getSchema("addressbook")->getCollection("names");

$session->startTransaction();
$collection->add( '{"test1":1, "test2":2}' )->execute();

$savepoint = $session->setSavepoint();

$collection->add( '{"test3":3, "test4":4}' )->execute();

$session->releaseSavepoint($savepoint);
$session->rollback();
?>


Execute SQL query

  • ? Session::setSavepoint
  • Session::startTransaction ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Execute SQL query

Session::sql

(No version information available, might only be in Git)

Session::sql — Execute SQL query

说明

public mysql_xdevapi\Session::sql ( string $query ) : mysql_xdevapi\SqlStatement

Create a native SQL statement. Placeholders are supported using the native "?" syntax. Use the execute method to execute the SQL statement.

参数

query

SQL statement to execute.

返回值

An SqlStatement object.

范例

Example #1 mysql_xdevapi\Session::sql() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("CREATE DATABASE addressbook")->execute();
?>


Start transaction

  • ? Session::sql
  • mysql_xdevapi\SqlStatement ?
  • PHP Manual
  • mysql_xdevapi\Session
  • Start transaction

Session::startTransaction

(No version information available, might only be in Git)

Session::startTransaction — Start transaction

说明

public mysql_xdevapi\Session::startTransaction ( ) : void

Start a new transaction.

参数

此函数没有参数。

返回值

An SqlStatementResult object.

范例

Example #1 mysql_xdevapi\Session::startTransaction() example

<?php
$session    = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$collection = $session->getSchema("addressbook")->getCollection("friends");

$session->startTransaction();
$collection->add( '{"test1":1, "test2":2}' )->execute();

$savepoint = $session->setSavepoint();

$collection->add( '{"test3":3, "test4":4}' )->execute();

$session->releaseSavepoint($savepoint);
$session->rollback();
?>


SqlStatement class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\SqlStatement {
/* Constants */
const int EXECUTE_ASYNC = 1 ;
const int BUFFERED = 2 ;
/* 属性 */
public $statement ;
/* 方法 */
public bind ( string $param ) : mysql_xdevapi\SqlStatement
public execute ( ) : mysql_xdevapi\Result
public getNextResult ( ) : mysql_xdevapi\Result
public getResult ( ) : mysql_xdevapi\Result
public hasMoreResults ( ) : bool
}

属性

statement

预定义常量

mysql_xdevapi\SqlStatement::EXECUTE_ASYNC

mysql_xdevapi\SqlStatement::BUFFERED

Table of Contents

  • SqlStatement::bind — Bind statement parameters
  • SqlStatement::__construct — Description constructor
  • SqlStatement::execute — Execute the operation
  • SqlStatement::getNextResult — Get next result
  • SqlStatement::getResult — Get result
  • SqlStatement::hasMoreResults — Check for more results


Bind statement parameters

  • ? mysql_xdevapi\SqlStatement
  • SqlStatement::__construct ?
  • PHP Manual
  • mysql_xdevapi\SqlStatement
  • Bind statement parameters

SqlStatement::bind

(No version information available, might only be in Git)

SqlStatement::bind — Bind statement parameters

说明

public mysql_xdevapi\SqlStatement::bind ( string $param ) : mysql_xdevapi\SqlStatement

Warning

本函数还未编写文档，仅有参数列表。

参数

param

返回值

范例

Example #1 mysql_xdevapi\SqlStatement::bind() example

<?php

/* ... */

?>


Description constructor

  • ? SqlStatement::bind
  • SqlStatement::execute ?
  • PHP Manual
  • mysql_xdevapi\SqlStatement
  • Description constructor

SqlStatement::__construct

(No version information available, might only be in Git)

SqlStatement::__construct — Description constructor

说明

private mysql_xdevapi\SqlStatement::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\SqlStatement::__construct() example

<?php

/* ... */

?>


Execute the operation

  • ? SqlStatement::__construct
  • SqlStatement::getNextResult ?
  • PHP Manual
  • mysql_xdevapi\SqlStatement
  • Execute the operation

SqlStatement::execute

(No version information available, might only be in Git)

SqlStatement::execute — Execute the operation

说明

public mysql_xdevapi\SqlStatement::execute ( ) : mysql_xdevapi\Result

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\SqlStatement::execute() example

<?php

/* ... */

?>


Get next result

  • ? SqlStatement::execute
  • SqlStatement::getResult ?
  • PHP Manual
  • mysql_xdevapi\SqlStatement
  • Get next result

SqlStatement::getNextResult

(No version information available, might only be in Git)

SqlStatement::getNextResult — Get next result

说明

public mysql_xdevapi\SqlStatement::getNextResult ( ) : mysql_xdevapi\Result

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\SqlStatement::getNextResult() example

<?php

/* ... */

?>


Get result

  • ? SqlStatement::getNextResult
  • SqlStatement::hasMoreResults ?
  • PHP Manual
  • mysql_xdevapi\SqlStatement
  • Get result

SqlStatement::getResult

(No version information available, might only be in Git)

SqlStatement::getResult — Get result

说明

public mysql_xdevapi\SqlStatement::getResult ( ) : mysql_xdevapi\Result

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\SqlStatement::getResult() example

<?php

/* ... */

?>


Check for more results

  • ? SqlStatement::getResult
  • mysql_xdevapi\SqlStatementResult ?
  • PHP Manual
  • mysql_xdevapi\SqlStatement
  • Check for more results

SqlStatement::hasMoreResults

(No version information available, might only be in Git)

SqlStatement::hasMoreResults — Check for more results

说明

public mysql_xdevapi\SqlStatement::hasMoreResults ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the result set has more objects to fetch.

范例

Example #1 mysql_xdevapi\SqlStatement::hasMoreResults() example

<?php

/* ... */

?>


SqlStatementResult class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\SqlStatementResult implements mysql_xdevapi\BaseResult , Traversable {
/* 方法 */
public fetchAll ( ) : array
public fetchOne ( ) : array
public getAffectedItemsCount ( ) : int
public getColumnsCount ( ) : int
public getColumnNames ( ) : array
public getColumns ( ) : Array
public getGeneratedIds ( ) : array
public getLastInsertId ( ) : String
public getWarnings ( ) : array
public getWarningCounts ( ) : int
public hasData ( ) : bool
public nextResult ( ) : mysql_xdevapi\Result
}

Table of Contents

  • SqlStatementResult::__construct — Description constructor
  • SqlStatementResult::fetchAll — Get all rows from result
  • SqlStatementResult::fetchOne — Get single row
  • SqlStatementResult::getAffectedItemsCount — Get affected row count
  • SqlStatementResult::getColumnsCount — Get column count
  • SqlStatementResult::getColumnNames — Get column names
  • SqlStatementResult::getColumns — Get columns
  • SqlStatementResult::getGeneratedIds — Get generated ids
  • SqlStatementResult::getLastInsertId — Get last insert id
  • SqlStatementResult::getWarnings — Get warnings from last operation
  • SqlStatementResult::getWarningsCount — Get warning count from last operation
  • SqlStatementResult::hasData — Check if result has data
  • SqlStatementResult::nextResult — Get next result


Description constructor

  • ? mysql_xdevapi\SqlStatementResult
  • SqlStatementResult::fetchAll ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Description constructor

SqlStatementResult::__construct

(No version information available, might only be in Git)

SqlStatementResult::__construct — Description constructor

说明

private mysql_xdevapi\SqlStatementResult::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\SqlStatementResult::__construct() example

<?php

/* ... */

?>


Get all rows from result

  • ? SqlStatementResult::__construct
  • SqlStatementResult::fetchOne ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get all rows from result

SqlStatementResult::fetchAll

(No version information available, might only be in Git)

SqlStatementResult::fetchAll — Get all rows from result

说明

public mysql_xdevapi\SqlStatementResult::fetchAll ( ) : array

Fetch all the rows from the result set.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A numerical array with all results from the query; each result is an associative array. An empty array is returned if no rows are present.

范例

Example #1 mysql_xdevapi\SqlStatementResult::fetchAll() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS dbtest")->execute();
$session->sql("CREATE DATABASE dbtest")->execute();
$session->sql("CREATE TABLE dbtest.workers(name text, age int, job text)")->execute();
$session->sql("INSERT INTO dbtest.workers values ('John', 42, 'bricklayer'), ('Sam', 33, 'carpenter')")->execute();

$schema = $session->getSchema("dbtest");
$table  = $schema->getTable("workers");

$rows = $session->sql("SELECT * FROM dbtest.workers")->execute()->fetchAll();

print_r($rows);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
    [1] => Array
        (
            [name] => Sam
            [age] => 33
        )
)


Get single row

  • ? SqlStatementResult::fetchAll
  • SqlStatementResult::getAffectedItemsCount ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get single row

SqlStatementResult::fetchOne

(No version information available, might only be in Git)

SqlStatementResult::fetchOne — Get single row

说明

public mysql_xdevapi\SqlStatementResult::fetchOne ( ) : array

Fetch one row from the result set.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The result, as an associative array. In case there is not any result, null will be returned.

范例

Example #1 mysql_xdevapi\SqlStatementResult::fetchOne() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");
$session->sql("DROP DATABASE IF EXISTS dbtest")->execute();
$session->sql("CREATE DATABASE dbtest")->execute();
$session->sql("CREATE TABLE dbtest.workers(name text, age int, job text)")->execute();
$session->sql("INSERT INTO dbtest.workers values ('John', 42, 'bricklayer'), ('Sam', 33, 'carpenter')")->execute();

$schema = $session->getSchema("dbtest");
$table  = $schema->getTable("workers");

$rows = $session->sql("SELECT * FROM dbtest.workers")->execute()->fetchOne();

print_r($rows);
?>

以上例程的输出类似于：

Array
(
    [name] => John
    [age] => 42
    [job] => bricklayer
)


Get affected row count

  • ? SqlStatementResult::fetchOne
  • SqlStatementResult::getColumnsCount ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get affected row count

SqlStatementResult::getAffectedItemsCount

(No version information available, might only be in Git)

SqlStatementResult::getAffectedItemsCount — Get affected row count

说明

public mysql_xdevapi\SqlStatementResult::getAffectedItemsCount ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\SqlStatementResult::getAffectedItemsCount() example

<?php

/* ... */

?>


Get column count

  • ? SqlStatementResult::getAffectedItemsCount
  • SqlStatementResult::getColumnNames ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get column count

SqlStatementResult::getColumnsCount

(No version information available, might only be in Git)

SqlStatementResult::getColumnsCount — Get column count

说明

public mysql_xdevapi\SqlStatementResult::getColumnsCount ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The number of columns; 0 if there are none.

更新日志

版本 | 说明
8.0.14 | Method renamed from getColumnCount() to getColumnsCount().

范例

Example #1 mysql_xdevapi\SqlStatementResult::getColumnsCount() example

<?php

/* ... */

?>


Get column names

  • ? SqlStatementResult::getColumnsCount
  • SqlStatementResult::getColumns ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get column names

SqlStatementResult::getColumnNames

(No version information available, might only be in Git)

SqlStatementResult::getColumnNames — Get column names

说明

public mysql_xdevapi\SqlStatementResult::getColumnNames ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\SqlStatementResult::getColumnNames() example

<?php

/* ... */

?>


Get columns

  • ? SqlStatementResult::getColumnNames
  • SqlStatementResult::getGeneratedIds ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get columns

SqlStatementResult::getColumns

(No version information available, might only be in Git)

SqlStatementResult::getColumns — Get columns

说明

public mysql_xdevapi\SqlStatementResult::getColumns ( ) : Array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\SqlStatementResult::getColumns() example

<?php

/* ... */

?>


Get generated ids

  • ? SqlStatementResult::getColumns
  • SqlStatementResult::getLastInsertId ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get generated ids

SqlStatementResult::getGeneratedIds

(No version information available, might only be in Git)

SqlStatementResult::getGeneratedIds — Get generated ids

说明

public mysql_xdevapi\SqlStatementResult::getGeneratedIds ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

An array of generated _id's from the last operation, or an empty array if there are none.

范例

Example #1 mysql_xdevapi\SqlStatementResult::getGeneratedIds() example

<?php

/* ... */

?>


Get last insert id

  • ? SqlStatementResult::getGeneratedIds
  • SqlStatementResult::getWarnings ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get last insert id

SqlStatementResult::getLastInsertId

(No version information available, might only be in Git)

SqlStatementResult::getLastInsertId — Get last insert id

说明

public mysql_xdevapi\SqlStatementResult::getLastInsertId ( ) : String

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The ID for the last insert operation.

范例

Example #1 mysql_xdevapi\SqlStatementResult::getLastInsertId() example

<?php

/* ... */

?>


Get warnings from last operation

  • ? SqlStatementResult::getLastInsertId
  • SqlStatementResult::getWarningsCount ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get warnings from last operation

SqlStatementResult::getWarnings

(No version information available, might only be in Git)

SqlStatementResult::getWarnings — Get warnings from last operation

说明

public mysql_xdevapi\SqlStatementResult::getWarnings ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

An array of Warning objects from the last operation. Each object defines an error 'message', error 'level', and error 'code'. An empty array is returned if no errors are present.

范例

Example #1 mysql_xdevapi\SqlStatementResult::getWarnings() example

<?php

/* ... */

?>


Get warning count from last operation

  • ? SqlStatementResult::getWarnings
  • SqlStatementResult::hasData ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get warning count from last operation

SqlStatementResult::getWarningsCount

(No version information available, might only be in Git)

SqlStatementResult::getWarningsCount — Get warning count from last operation

说明

public mysql_xdevapi\SqlStatementResult::getWarningCounts ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The number of warnings raised during the last CRUD operation.

范例

Example #1 mysql_xdevapi\SqlStatementResult::getWarningsCount() example

<?php

/* ... */

?>


Check if result has data

  • ? SqlStatementResult::getWarningsCount
  • SqlStatementResult::nextResult ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Check if result has data

SqlStatementResult::hasData

(No version information available, might only be in Git)

SqlStatementResult::hasData — Check if result has data

说明

public mysql_xdevapi\SqlStatementResult::hasData ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the result set has data.

范例

Example #1 mysql_xdevapi\SqlStatementResult::hasData() example

<?php

/* ... */

?>


Get next result

  • ? SqlStatementResult::hasData
  • mysql_xdevapi\Statement ?
  • PHP Manual
  • mysql_xdevapi\SqlStatementResult
  • Get next result

SqlStatementResult::nextResult

(No version information available, might only be in Git)

SqlStatementResult::nextResult — Get next result

说明

public mysql_xdevapi\SqlStatementResult::nextResult ( ) : mysql_xdevapi\Result

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The next Result object from the result set.

范例

Example #1 mysql_xdevapi\SqlStatementResult::nextResult() example

<?php

/* ... */

?>


Statement class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Statement {
/* Constants */
const int EXECUTE_ASYNC = 1 ;
const int BUFFERED = 2 ;
/* 方法 */
public getNextResult ( ) : mysql_xdevapi\Result
public getResult ( ) : mysql_xdevapi\Result
public hasMoreResults ( ) : bool
}

预定义常量

mysql_xdevapi\Statement::EXECUTE_ASYNC

mysql_xdevapi\Statement::BUFFERED

Table of Contents

  • Statement::__construct — Description constructor
  • Statement::getNextResult — Get next result
  • Statement::getResult — Get result
  • Statement::hasMoreResults — Check if more results


Description constructor

  • ? mysql_xdevapi\Statement
  • Statement::getNextResult ?
  • PHP Manual
  • mysql_xdevapi\Statement
  • Description constructor

Statement::__construct

(No version information available, might only be in Git)

Statement::__construct — Description constructor

说明

private mysql_xdevapi\Statement::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\Statement::__construct() example

<?php

/* ... */

?>


Get next result

  • ? Statement::__construct
  • Statement::getResult ?
  • PHP Manual
  • mysql_xdevapi\Statement
  • Get next result

Statement::getNextResult

(No version information available, might only be in Git)

Statement::getNextResult — Get next result

说明

public mysql_xdevapi\Statement::getNextResult ( ) : mysql_xdevapi\Result

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\Statement::getNextResult() example

<?php

/* ... */

?>


Get result

  • ? Statement::getNextResult
  • Statement::hasMoreResults ?
  • PHP Manual
  • mysql_xdevapi\Statement
  • Get result

Statement::getResult

(No version information available, might only be in Git)

Statement::getResult — Get result

说明

public mysql_xdevapi\Statement::getResult ( ) : mysql_xdevapi\Result

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\Statement::getResult() example

<?php

/* ... */

?>


Check if more results

  • ? Statement::getResult
  • mysql_xdevapi\Table ?
  • PHP Manual
  • mysql_xdevapi\Statement
  • Check if more results

Statement::hasMoreResults

(No version information available, might only be in Git)

Statement::hasMoreResults — Check if more results

说明

public mysql_xdevapi\Statement::hasMoreResults ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 mysql_xdevapi\Statement::hasMoreResults() example

<?php

/* ... */

?>


Table class

(PECL mysql-xdevapi >= 8.0.11)

简介

Provides access to the table through INSERT/SELECT/UPDATE/DELETE statements.

类摘要

mysql_xdevapi\Table implements mysql_xdevapi\SchemaObject {
/* 属性 */
public $name ;
/* 方法 */
public count ( ) : int
public delete ( ) : mysql_xdevapi\TableDelete
public existsInDatabase ( ) : bool
public getName ( ) : string
public getSchema ( ) : mysql_xdevapi\Schema
public getSession ( ) : mysql_xdevapi\Session
public insert ( mixed $columns , mixed ...$more_columns ) : mysql_xdevapi\TableInsert
public isView ( ) : bool
public select ( mixed $columns , mixed ...$more_columns ) : mysql_xdevapi\TableSelect
public update ( ) : mysql_xdevapi\TableUpdate
}

属性

name

Table of Contents

  • Table::__construct — Table constructor
  • Table::count — Get row count
  • Table::delete — Delete rows from table
  • Table::existsInDatabase — Check if table exists in database
  • Table::getName — Get table name
  • Table::getSchema — Get table schema
  • Table::getSession — Get table session
  • Table::insert — Insert table rows
  • Table::isView — Check if table is view
  • Table::select — Select rows from table
  • Table::update — Update rows in table


Table constructor

  • ? mysql_xdevapi\Table
  • Table::count ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Table constructor

Table::__construct

(No version information available, might only be in Git)

Table::__construct — Table constructor

说明

private mysql_xdevapi\Table::__construct ( )

Construct a table object.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\Table::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");
?>


Get row count

  • ? Table::__construct
  • Table::delete ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Get row count

Table::count

(No version information available, might only be in Git)

Table::count — Get row count

说明

public mysql_xdevapi\Table::count ( ) : int

Fetch the number of rows in the table.

参数

此函数没有参数。

返回值

The total number of rows in the table.

范例

Example #1 mysql_xdevapi\Table::count() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

var_dump($table->count());
?>

以上例程会输出：

int(2)


Delete rows from table

  • ? Table::count
  • Table::existsInDatabase ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Delete rows from table

Table::delete

(No version information available, might only be in Git)

Table::delete — Delete rows from table

说明

public mysql_xdevapi\Table::delete ( ) : mysql_xdevapi\TableDelete

Deletes rows from a table.

参数

此函数没有参数。

返回值

A TableDelete object; use the execute() method to execute the delete query.

范例

Example #1 mysql_xdevapi\Table::delete() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->delete()->where("name = :name")->orderby("age DESC")->limit(1)->bind(['name' => 'John'])->execute();
?>


Check if table exists in database

  • ? Table::delete
  • Table::getName ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Check if table exists in database

Table::existsInDatabase

(No version information available, might only be in Git)

Table::existsInDatabase — Check if table exists in database

说明

public mysql_xdevapi\Table::existsInDatabase ( ) : bool

Verifies if this table exists in the database.

参数

此函数没有参数。

返回值

Returns true if table exists in the database, else false if it does not.

范例

Example #1 mysql_xdevapi\Table::existsInDatabase() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

if ($table->existsInDatabase()) {
  echo "Yes, this table still exists in the session's schema.";
}
?>

以上例程的输出类似于：

Yes, this table still exists in the session's schema.


Get table name

  • ? Table::existsInDatabase
  • Table::getSchema ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Get table name

Table::getName

(No version information available, might only be in Git)

Table::getName — Get table name

说明

public mysql_xdevapi\Table::getName ( ) : string

Returns the name of this database object.

参数

此函数没有参数。

返回值

The name of this database object.

范例

Example #1 mysql_xdevapi\Table::getName() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

var_dump($table->getName());
?>

以上例程的输出类似于：

string(5) "names"


Get table schema

  • ? Table::getName
  • Table::getSession ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Get table schema

Table::getSchema

(No version information available, might only be in Git)

Table::getSchema — Get table schema

说明

public mysql_xdevapi\Table::getSchema ( ) : mysql_xdevapi\Schema

Fetch the schema associated with the table.

参数

此函数没有参数。

返回值

A Schema object.

范例

Example #1 mysql_xdevapi\Table::getSchema() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

var_dump($table->getSchema());
?>

以上例程的输出类似于：

object(mysql_xdevapi\Schema)#9 (1) {
  ["name"]=>
  string(11) "addressbook"
}


Get table session

  • ? Table::getSchema
  • Table::insert ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Get table session

Table::getSession

(No version information available, might only be in Git)

Table::getSession — Get table session

说明

public mysql_xdevapi\Table::getSession ( ) : mysql_xdevapi\Session

Get session associated with the table.

参数

此函数没有参数。

返回值

A Session object.

范例

Example #1 mysql_xdevapi\Table::getSession() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

var_dump($table->getSession());
?>

以上例程的输出类似于：

object(mysql_xdevapi\Session)#9 (0) {
}


Insert table rows

  • ? Table::getSession
  • Table::isView ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Insert table rows

Table::insert

(No version information available, might only be in Git)

Table::insert — Insert table rows

说明

public mysql_xdevapi\Table::insert ( mixed $columns , mixed ...$more_columns ) : mysql_xdevapi\TableInsert

Inserts rows into a table.

参数

columns

The columns to insert data into. Can be an array with one or more values, or a string.

more_columns

Additional columns definitions.

返回值

A TableInsert object; use the execute() method to execute the insert statement.

范例

Example #1 mysql_xdevapi\Table::insert() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table ->insert("name", "age")
  ->values(["Suzanne", 31],["Julie", 43])
  ->execute();
?>


Check if table is view

  • ? Table::insert
  • Table::select ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Check if table is view

Table::isView

(No version information available, might only be in Git)

Table::isView — Check if table is view

说明

public mysql_xdevapi\Table::isView ( ) : bool

Determine if the underlying object is a view or not.

参数

此函数没有参数。

返回值

true if the underlying object is a view, otherwise false.

范例

Example #1 mysql_xdevapi\Table::isView() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names

if ($table->isView()) {
    echo "This is a view.";
} else {
    echo "This is not a view.";
}
?>

以上例程会输出：

int(2)


Select rows from table

  • ? Table::isView
  • Table::update ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Select rows from table

Table::select

(No version information available, might only be in Git)

Table::select — Select rows from table

说明

public mysql_xdevapi\Table::select ( mixed $columns , mixed ...$more_columns ) : mysql_xdevapi\TableSelect

Fetches data from a table.

参数

columns

The columns to select data from. Can be an array with one or more values, or a string.

more_columns

Additional columns parameter definitions.

返回值

A TableSelect object; use the execute() method to execute the select and return a RowResult object.

范例

Example #1 mysql_xdevapi\Table::count() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$row = $table->select('name', 'age')->execute()->fetchAll();

print_r($row);

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
    [1] => Array
        (
            [name] => Sam
            [age] => 33
        )
)


Update rows in table

  • ? Table::select
  • mysql_xdevapi\TableDelete ?
  • PHP Manual
  • mysql_xdevapi\Table
  • Update rows in table

Table::update

(No version information available, might only be in Git)

Table::update — Update rows in table

说明

public mysql_xdevapi\Table::update ( ) : mysql_xdevapi\TableUpdate

Updates columns in a table.

参数

此函数没有参数。

返回值

A TableUpdate object; use the execute() method to execute the update statement.

范例

Example #1 mysql_xdevapi\Table::update() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->update()->set('age',34)->where('name = "Sam"')->limit(1)->execute();
?>


TableDelete class

(PECL mysql-xdevapi >= 8.0.11)

简介

A statement for delete operations on Table.

类摘要

mysql_xdevapi\TableDelete implements mysql_xdevapi\Executable {
/* 方法 */
public bind ( array $placeholder_values ) : mysql_xdevapi\TableDelete
public execute ( ) : mysql_xdevapi\Result
public limit ( int $rows ) : mysql_xdevapi\TableDelete
public orderby ( string $orderby_expr ) : mysql_xdevapi\TableDelete
public where ( string $where_expr ) : mysql_xdevapi\TableDelete
}

Table of Contents

  • TableDelete::bind — Bind delete query parameters
  • TableDelete::__construct — TableDelete constructor
  • TableDelete::execute — Execute delete query
  • TableDelete::limit — Limit deleted rows
  • TableDelete::orderby — Set delete sort criteria
  • TableDelete::where — Set delete search condition


Bind delete query parameters

  • ? mysql_xdevapi\TableDelete
  • TableDelete::__construct ?
  • PHP Manual
  • mysql_xdevapi\TableDelete
  • Bind delete query parameters

TableDelete::bind

(No version information available, might only be in Git)

TableDelete::bind — Bind delete query parameters

说明

public mysql_xdevapi\TableDelete::bind ( array $placeholder_values ) : mysql_xdevapi\TableDelete

Binds a value to a specific placeholder.

参数

placeholder_values

The name of the placeholder and the value to bind.

返回值

A TableDelete object.

范例

Example #1 mysql_xdevapi\TableDelete::bind() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->delete()
  ->where("name = :name")
  ->bind(['name' => 'John'])
  ->orderby("age DESC")
  ->limit(1)
  ->execute();

?>


TableDelete constructor

  • ? TableDelete::bind
  • TableDelete::execute ?
  • PHP Manual
  • mysql_xdevapi\TableDelete
  • TableDelete constructor

TableDelete::__construct

(No version information available, might only be in Git)

TableDelete::__construct — TableDelete constructor

说明

private mysql_xdevapi\TableDelete::__construct ( )

Initiated by using the delete() method.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\TableDelete::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->delete()
  ->where("name = :name")
  ->bind(['name' => 'John'])
  ->orderby("age DESC")
  ->limit(1)
  ->execute();

?>


Execute delete query

  • ? TableDelete::__construct
  • TableDelete::limit ?
  • PHP Manual
  • mysql_xdevapi\TableDelete
  • Execute delete query

TableDelete::execute

(No version information available, might only be in Git)

TableDelete::execute — Execute delete query

说明

public mysql_xdevapi\TableDelete::execute ( ) : mysql_xdevapi\Result

Execute the delete query.

参数

此函数没有参数。

返回值

A Result object.

范例

Example #1 mysql_xdevapi\TableDelete::execute() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->delete()
  ->where("name = :name")
  ->bind(['name' => 'John'])
  ->orderby("age DESC")
  ->limit(1)
  ->execute();

?>


Limit deleted rows

  • ? TableDelete::execute
  • TableDelete::orderby ?
  • PHP Manual
  • mysql_xdevapi\TableDelete
  • Limit deleted rows

TableDelete::limit

(No version information available, might only be in Git)

TableDelete::limit — Limit deleted rows

说明

public mysql_xdevapi\TableDelete::limit ( int $rows ) : mysql_xdevapi\TableDelete

Sets the maximum number of records or documents to delete.

参数

rows

The maximum number of records or documents to delete.

返回值

TableDelete object.

范例

Example #1 mysql_xdevapi\TableDelete::limit() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->delete()
  ->where("name = :name")
  ->bind(['name' => 'John'])
  ->orderby("age DESC")
  ->limit(1)
  ->execute();

?>


Set delete sort criteria

  • ? TableDelete::limit
  • TableDelete::where ?
  • PHP Manual
  • mysql_xdevapi\TableDelete
  • Set delete sort criteria

TableDelete::orderby

(No version information available, might only be in Git)

TableDelete::orderby — Set delete sort criteria

说明

public mysql_xdevapi\TableDelete::orderby ( string $orderby_expr ) : mysql_xdevapi\TableDelete

Set the order options for a result set.

参数

orderby_expr

The sort definition.

返回值

A TableDelete object.

范例

Example #1 mysql_xdevapi\TableDelete::orderBy() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->delete()
  ->where("age = :age")
  ->bind(['age' => 42])
  ->orderby("name DESC")
  ->limit(1)
  ->execute();

?>


Set delete search condition

  • ? TableDelete::orderby
  • mysql_xdevapi\TableInsert ?
  • PHP Manual
  • mysql_xdevapi\TableDelete
  • Set delete search condition

TableDelete::where

(No version information available, might only be in Git)

TableDelete::where — Set delete search condition

说明

public mysql_xdevapi\TableDelete::where ( string $where_expr ) : mysql_xdevapi\TableDelete

Sets the search condition to filter.

参数

where_expr

Define the search condition to filter documents or records.

返回值

TableDelete object.

范例

Example #1 mysql_xdevapi\TableDelete::where() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->delete()
  ->where("id = :id")
  ->bind(['id' => 42])
  ->limit(1)
  ->execute();

?>


TableInsert class

(PECL mysql-xdevapi >= 8.0.11)

简介

A statement for insert operations on Table.

类摘要

mysql_xdevapi\TableInsert implements mysql_xdevapi\Executable {
/* 方法 */
public execute ( ) : mysql_xdevapi\Result
public values ( array $row_values ) : mysql_xdevapi\TableInsert
}

Table of Contents

  • TableInsert::__construct — TableInsert constructor
  • TableInsert::execute — Execute insert query
  • TableInsert::values — Add insert row values


TableInsert constructor

  • ? mysql_xdevapi\TableInsert
  • TableInsert::execute ?
  • PHP Manual
  • mysql_xdevapi\TableInsert
  • TableInsert constructor

TableInsert::__construct

(No version information available, might only be in Git)

TableInsert::__construct — TableInsert constructor

说明

private mysql_xdevapi\TableInsert::__construct ( )

Initiated by using the insert() method.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\TableInsert::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table
  ->insert("name", "age")
  ->values(["Suzanne", 31],["Julie", 43])
  ->execute();
?>


Execute insert query

  • ? TableInsert::__construct
  • TableInsert::values ?
  • PHP Manual
  • mysql_xdevapi\TableInsert
  • Execute insert query

TableInsert::execute

(No version information available, might only be in Git)

TableInsert::execute — Execute insert query

说明

public mysql_xdevapi\TableInsert::execute ( ) : mysql_xdevapi\Result

Execute the statement.

参数

此函数没有参数。

返回值

A Result object.

范例

Example #1 mysql_xdevapi\TableInsert::execute() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table
  ->insert("name", "age")
  ->values(["Suzanne", 31],["Julie", 43])
  ->execute();
?>


Add insert row values

  • ? TableInsert::execute
  • mysql_xdevapi\TableSelect ?
  • PHP Manual
  • mysql_xdevapi\TableInsert
  • Add insert row values

TableInsert::values

(No version information available, might only be in Git)

TableInsert::values — Add insert row values

说明

public mysql_xdevapi\TableInsert::values ( array $row_values ) : mysql_xdevapi\TableInsert

Set the values to be inserted.

参数

row_values

Values (an array) of columns to insert.

返回值

A TableInsert object.

范例

Example #1 mysql_xdevapi\TableInsert::values() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table
  ->insert("name", "age")
  ->values(["Suzanne", 31],["Julie", 43])
  ->execute();
?>


TableSelect class

(PECL mysql-xdevapi >= 8.0.11)

简介

A statement for record retrieval operations on a Table.

类摘要

mysql_xdevapi\TableSelect implements mysql_xdevapi\Executable {
/* 方法 */
public bind ( array $placeholder_values ) : mysql_xdevapi\TableSelect
public execute ( ) : mysql_xdevapi\RowResult
public groupBy ( mixed $sort_expr ) : mysql_xdevapi\TableSelect
public having ( string $sort_expr ) : mysql_xdevapi\TableSelect
public limit ( int $rows ) : mysql_xdevapi\TableSelect
public lockExclusive ( int $lock_waiting_option = ? ) : mysql_xdevapi\TableSelect
public lockShared ( int $lock_waiting_option = ? ) : mysql_xdevapi\TableSelect
public offset ( int $position ) : mysql_xdevapi\TableSelect
public orderby ( mixed $sort_expr , mixed ...$sort_exprs ) : mysql_xdevapi\TableSelect
public where ( string $where_expr ) : mysql_xdevapi\TableSelect
}

Table of Contents

  • TableSelect::bind — Bind select query parameters
  • TableSelect::__construct — TableSelect constructor
  • TableSelect::execute — Execute select statement
  • TableSelect::groupBy — Set select grouping criteria
  • TableSelect::having — Set select having condition
  • TableSelect::limit — Limit selected rows
  • TableSelect::lockExclusive — Execute EXCLUSIVE LOCK
  • TableSelect::lockShared — Execute SHARED LOCK
  • TableSelect::offset — Set limit offset
  • TableSelect::orderby — Set select sort criteria
  • TableSelect::where — Set select search condition


Bind select query parameters

  • ? mysql_xdevapi\TableSelect
  • TableSelect::__construct ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Bind select query parameters

TableSelect::bind

(No version information available, might only be in Git)

TableSelect::bind — Bind select query parameters

说明

public mysql_xdevapi\TableSelect::bind ( array $placeholder_values ) : mysql_xdevapi\TableSelect

Binds a value to a specific placeholder.

参数

placeholder_values

The name of the placeholder, and the value to bind.

返回值

A TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::bind() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('name','age')
  ->where('name like :name and age > :age')
  ->bind(['name' => 'John', 'age' => 42])
  ->execute();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
)


TableSelect constructor

  • ? TableSelect::bind
  • TableSelect::execute ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • TableSelect constructor

TableSelect::__construct

(No version information available, might only be in Git)

TableSelect::__construct — TableSelect constructor

说明

private mysql_xdevapi\TableSelect::__construct ( )

An object returned by the select() method; use execute() to execute the query.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\TableSelect::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 33)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('name','age')
  ->where('name like :name and age > :age')
  ->bind(['name' => 'John', 'age' => 42])
  ->orderBy('age desc')
  ->execute();

$row = $result->fetchAll();
print_r($row);

?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
)


Execute select statement

  • ? TableSelect::__construct
  • TableSelect::groupBy ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Execute select statement

TableSelect::execute

(No version information available, might only be in Git)

TableSelect::execute — Execute select statement

说明

public mysql_xdevapi\TableSelect::execute ( ) : mysql_xdevapi\RowResult

Execute the select statement by chaining it with the execute() method.

参数

此函数没有参数。

返回值

A RowResult object.

范例

Example #1 mysql_xdevapi\TableSelect::execute() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('name','age')
  ->where('name like :name and age > :age')
  ->bind(['name' => 'John', 'age' => 42])
  ->orderBy('age desc')
  ->execute();

$row = $result->fetchAll();
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
)


Set select grouping criteria

  • ? TableSelect::execute
  • TableSelect::having ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Set select grouping criteria

TableSelect::groupBy

(No version information available, might only be in Git)

TableSelect::groupBy — Set select grouping criteria

说明

public mysql_xdevapi\TableSelect::groupBy ( mixed $sort_expr ) : mysql_xdevapi\TableSelect

Sets a grouping criteria for the result set.

参数

sort_expr

The grouping criteria.

返回值

A TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::groupBy() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 42)")->execute();
$session->sql("INSERT INTO addressbook.names values ('Suki', 31)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('count(*) as count', 'age')
  ->groupBy('age')->orderBy('age asc')
  ->execute();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [count] => 1
            [age] => 31
        )
    [1] => Array
        (
            [count] => 2
            [age] => 42
        )
)


Set select having condition

  • ? TableSelect::groupBy
  • TableSelect::limit ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Set select having condition

TableSelect::having

(No version information available, might only be in Git)

TableSelect::having — Set select having condition

说明

public mysql_xdevapi\TableSelect::having ( string $sort_expr ) : mysql_xdevapi\TableSelect

Sets a condition for records to consider in aggregate function operations.

参数

sort_expr

A condition on the aggregate functions used on the grouping criteria.

返回值

A TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::having() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 42)")->execute();
$session->sql("INSERT INTO addressbook.names values ('Suki', 31)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('count(*) as count', 'age')
  ->groupBy('age')->orderBy('age asc')
  ->having('count > 1')
  ->execute();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [count] => 2
            [age] => 42
        )
)


Limit selected rows

  • ? TableSelect::having
  • TableSelect::lockExclusive ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Limit selected rows

TableSelect::limit

(No version information available, might only be in Git)

TableSelect::limit — Limit selected rows

说明

public mysql_xdevapi\TableSelect::limit ( int $rows ) : mysql_xdevapi\TableSelect

Sets the maximum number of records or documents to return.

参数

rows

The maximum number of records or documents.

返回值

A TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::limit() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('name', 'age')
  ->limit(1)
  ->execute();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
)


Execute EXCLUSIVE LOCK

  • ? TableSelect::limit
  • TableSelect::lockShared ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Execute EXCLUSIVE LOCK

TableSelect::lockExclusive

(No version information available, might only be in Git)

TableSelect::lockExclusive — Execute EXCLUSIVE LOCK

说明

public mysql_xdevapi\TableSelect::lockExclusive ( int $lock_waiting_option = ? ) : mysql_xdevapi\TableSelect

Execute a read operation with EXCLUSIVE LOCK. Only one lock can be active at a time.

参数

lock_waiting_option

The optional waiting option that defaults to MYSQLX_LOCK_DEFAULT. Valid values are:

  • MYSQLX_LOCK_DEFAULT

  • MYSQLX_LOCK_NOWAIT

  • MYSQLX_LOCK_SKIP_LOCKED

返回值

TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::lockExclusive() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$session->startTransaction();

$result = $table->select('name', 'age')
  ->lockExclusive(MYSQLX_LOCK_NOWAIT)
  ->execute();

$session->commit();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
    [1] => Array
        (
            [name] => Sam
            [age] => 42
        )
)


Execute SHARED LOCK

  • ? TableSelect::lockExclusive
  • TableSelect::offset ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Execute SHARED LOCK

TableSelect::lockShared

(No version information available, might only be in Git)

TableSelect::lockShared — Execute SHARED LOCK

说明

public mysql_xdevapi\TableSelect::lockShared ( int $lock_waiting_option = ? ) : mysql_xdevapi\TableSelect

Execute a read operation with SHARED LOCK. Only one lock can be active at a time.

参数

lock_waiting_option

The optional waiting option that defaults to MYSQLX_LOCK_DEFAULT. Valid values are:

  • MYSQLX_LOCK_DEFAULT

  • MYSQLX_LOCK_NOWAIT

  • MYSQLX_LOCK_SKIP_LOCKED

返回值

A TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::lockShared() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$session->startTransaction();

$result = $table->select('name', 'age')
  ->lockShared(MYSQLX_LOCK_NOWAIT)
  ->execute();

$session->commit();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
    [1] => Array
        (
            [name] => Sam
            [age] => 42
        )
)


Set limit offset

  • ? TableSelect::lockShared
  • TableSelect::orderby ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Set limit offset

TableSelect::offset

(No version information available, might only be in Git)

TableSelect::offset — Set limit offset

说明

public mysql_xdevapi\TableSelect::offset ( int $position ) : mysql_xdevapi\TableSelect

Skip given number of rows in result.

参数

position

The limit offset.

返回值

A TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::offset() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$session->sql("DROP DATABASE IF EXISTS addressbook")->execute();
$session->sql("CREATE DATABASE addressbook")->execute();
$session->sql("CREATE TABLE addressbook.names(name text, age int)")->execute();
$session->sql("INSERT INTO addressbook.names values ('John', 42), ('Sam', 42)")->execute();

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('name', 'age')
  ->limit(1)
  ->offset(1)
  ->execute();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => Sam
            [age] => 42
        )
)


Set select sort criteria

  • ? TableSelect::offset
  • TableSelect::where ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Set select sort criteria

TableSelect::orderby

(No version information available, might only be in Git)

TableSelect::orderby — Set select sort criteria

说明

public mysql_xdevapi\TableSelect::orderby ( mixed $sort_expr , mixed ...$sort_exprs ) : mysql_xdevapi\TableSelect

Sets the order by criteria.

参数

sort_expr

The expressions that define the order by criteria. Can be an array with one or more expressions, or a string.

sort_exprs

Additional sort_expr parameters.

返回值

A TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::orderBy() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('name', 'age')
  ->orderBy('name desc')
  ->execute();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => Sam
            [age] => 42
        )
    [1] => Array
        (
            [name] => John
            [age] => 42
        )
)


Set select search condition

  • ? TableSelect::orderby
  • mysql_xdevapi\TableUpdate ?
  • PHP Manual
  • mysql_xdevapi\TableSelect
  • Set select search condition

TableSelect::where

(No version information available, might only be in Git)

TableSelect::where — Set select search condition

说明

public mysql_xdevapi\TableSelect::where ( string $where_expr ) : mysql_xdevapi\TableSelect

Sets the search condition to filter.

参数

where_expr

Define the search condition to filter documents or records.

返回值

A TableSelect object.

范例

Example #1 mysql_xdevapi\TableSelect::where() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$result = $table->select('name','age')
  ->where('name like :name and age > :age')
  ->bind(['name' => 'John', 'age' => 42])
  ->execute();

$row = $result->fetchAll();
print_r($row);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [name] => John
            [age] => 42
        )
)


TableUpdate class

(PECL mysql-xdevapi >= 8.0.11)

简介

A statement for record update operations on a Table.

类摘要

mysql_xdevapi\TableUpdate implements mysql_xdevapi\Executable {
/* 方法 */
public bind ( array $placeholder_values ) : mysql_xdevapi\TableUpdate
public execute ( ) : mysql_xdevapi\TableUpdate
public limit ( int $rows ) : mysql_xdevapi\TableUpdate
public orderby ( mixed $orderby_expr , mixed ...$orderby_exprs ) : mysql_xdevapi\TableUpdate
public set ( string $table_field , string $expression_or_literal ) : mysql_xdevapi\TableUpdate
public where ( string $where_expr ) : mysql_xdevapi\TableUpdate
}

Table of Contents

  • TableUpdate::bind — Bind update query parameters
  • TableUpdate::__construct — TableUpdate constructor
  • TableUpdate::execute — Execute update query
  • TableUpdate::limit — Limit update row count
  • TableUpdate::orderby — Set sorting criteria
  • TableUpdate::set — Add field to be updated
  • TableUpdate::where — Set search filter


Bind update query parameters

  • ? mysql_xdevapi\TableUpdate
  • TableUpdate::__construct ?
  • PHP Manual
  • mysql_xdevapi\TableUpdate
  • Bind update query parameters

TableUpdate::bind

(No version information available, might only be in Git)

TableUpdate::bind — Bind update query parameters

说明

public mysql_xdevapi\TableUpdate::bind ( array $placeholder_values ) : mysql_xdevapi\TableUpdate

Binds a value to a specific placeholder.

参数

placeholder_values

The name of the placeholder, and the value to bind, defined as a JSON array.

返回值

A TableUpdate object.

范例

Example #1 mysql_xdevapi\TableUpdate::bind() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$table->update()
  ->set('status', 'admin')
  ->where('name = :name and age > :age')
  ->bind(['name' => 'Bernie', 'age' => 2000])
  ->execute();

?>


TableUpdate constructor

  • ? TableUpdate::bind
  • TableUpdate::execute ?
  • PHP Manual
  • mysql_xdevapi\TableUpdate
  • TableUpdate constructor

TableUpdate::__construct

(No version information available, might only be in Git)

TableUpdate::__construct — TableUpdate constructor

说明

private mysql_xdevapi\TableUpdate::__construct ( )

Initiated by using the update() method.

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\TableUpdate::__construct() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$res = $table->update()
  ->set('level', 3)
  ->where('age > 15 and age < 22')
  ->limit(4)
  ->orderby(['age asc','name desc'])
  ->execute();

?>


Execute update query

  • ? TableUpdate::__construct
  • TableUpdate::limit ?
  • PHP Manual
  • mysql_xdevapi\TableUpdate
  • Execute update query

TableUpdate::execute

(No version information available, might only be in Git)

TableUpdate::execute — Execute update query

说明

public mysql_xdevapi\TableUpdate::execute ( ) : mysql_xdevapi\TableUpdate

Executes the update statement.

参数

此函数没有参数。

返回值

A TableUpdate object.

范例

Example #1 mysql_xdevapi\TableUpdate::execute() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$res = $table->update()
  ->set('level', 3)
  ->where('age > 15 and age < 22')
  ->limit(4)
  ->orderby(['age asc','name desc'])
  ->execute();

?>


Limit update row count

  • ? TableUpdate::execute
  • TableUpdate::orderby ?
  • PHP Manual
  • mysql_xdevapi\TableUpdate
  • Limit update row count

TableUpdate::limit

(No version information available, might only be in Git)

TableUpdate::limit — Limit update row count

说明

public mysql_xdevapi\TableUpdate::limit ( int $rows ) : mysql_xdevapi\TableUpdate

Set the maximum number of records or documents update.

参数

rows

The maximum number of records or documents to update.

返回值

A TableUpdate object.

范例

Example #1 mysql_xdevapi\TableUpdate::limit() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$res = $table->update()
  ->set('level', 3)
  ->where('age > 15 and age < 22')
  ->limit(4)
  ->orderby(['age asc','name desc'])
  ->execute();

?>


Set sorting criteria

  • ? TableUpdate::limit
  • TableUpdate::set ?
  • PHP Manual
  • mysql_xdevapi\TableUpdate
  • Set sorting criteria

TableUpdate::orderby

(No version information available, might only be in Git)

TableUpdate::orderby — Set sorting criteria

说明

public mysql_xdevapi\TableUpdate::orderby ( mixed $orderby_expr , mixed ...$orderby_exprs ) : mysql_xdevapi\TableUpdate

Sets the sorting criteria.

参数

orderby_expr

The expressions that define the order by criteria. Can be an array with one or more expressions, or a string.

orderby_exprs

Additional sort_expr parameters.

返回值

TableUpdate object.

范例

Example #1 mysql_xdevapi\TableUpdate::orderby() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$res = $table->update()
  ->set('level', 3)
  ->where('age > 15 and age < 22')
  ->limit(4)
  ->orderby(['age asc','name desc'])
  ->execute();
?>


Add field to be updated

  • ? TableUpdate::orderby
  • TableUpdate::where ?
  • PHP Manual
  • mysql_xdevapi\TableUpdate
  • Add field to be updated

TableUpdate::set

(No version information available, might only be in Git)

TableUpdate::set — Add field to be updated

说明

public mysql_xdevapi\TableUpdate::set ( string $table_field , string $expression_or_literal ) : mysql_xdevapi\TableUpdate

Updates the column value on records in a table.

参数

table_field

The column name to be updated.

expression_or_literal

The value to be set on the specified column.

返回值

TableUpdate object.

范例

Example #1 mysql_xdevapi\TableUpdate::set() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$res = $table->update()
  ->set('level', 3)
  ->where('age > 15 and age < 22')
  ->limit(4)
  ->orderby(['age asc','name desc'])
  ->execute();

?>


Set search filter

  • ? TableUpdate::set
  • mysql_xdevapi\Warning ?
  • PHP Manual
  • mysql_xdevapi\TableUpdate
  • Set search filter

TableUpdate::where

(No version information available, might only be in Git)

TableUpdate::where — Set search filter

说明

public mysql_xdevapi\TableUpdate::where ( string $where_expr ) : mysql_xdevapi\TableUpdate

Set the search condition to filter.

参数

where_expr

The search condition to filter documents or records.

返回值

A TableUpdate object.

范例

Example #1 mysql_xdevapi\TableUpdate::where() example

<?php
$session = mysql_xdevapi\getSession("mysqlx://user:password@localhost");

$schema = $session->getSchema("addressbook");
$table  = $schema->getTable("names");

$res = $table->update()
  ->set('level', 3)
  ->where('age > 15 and age < 22')
  ->limit(4)
  ->orderby(['age asc','name desc'])
  ->execute();

?>


Warning class

(PECL mysql-xdevapi >= 8.0.11)

简介

类摘要

mysql_xdevapi\Warning {
/* 属性 */
public $message ;
public $level ;
public $code ;
/* Constructor */
private __construct ( )
}

属性

message

level

code

Table of Contents

  • Warning::__construct — Warning constructor


Warning constructor

  • ? mysql_xdevapi\Warning
  • Mysql（原始） ?
  • PHP Manual
  • mysql_xdevapi\Warning
  • Warning constructor

Warning::__construct

(No version information available, might only be in Git)

Warning::__construct — Warning constructor

说明

private mysql_xdevapi\Warning::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

范例

Example #1 mysql_xdevapi\Warning::__construct() example

<?php

/* ... */

?>


原始的 MySQL API

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 更新日志
  • 预定义常量
  • 范例
    • MySQL 扩展概述范例
  • MySQL 函数
    • mysql_affected_rows — 取得前一次 MySQL 操作所影响的记录行数
    • mysql_client_encoding — 返回字符集的名称
    • mysql_close — 关闭 MySQL 连接
    • mysql_connect — 打开一个到 MySQL 服务器的连接
    • mysql_create_db — 新建一个 MySQL 数据库
    • mysql_data_seek — 移动内部结果的指针
    • mysql_db_name — 取得 mysql_list_dbs 返回的结果数据
    • mysql_db_query — 发送一条 MySQL 查询
    • mysql_drop_db — 丢弃（删除）一个 MySQL 数据库
    • mysql_errno — 返回上一个 MySQL 操作中的错误信息的数字编码
    • mysql_error — 返回上一个 MySQL 操作产生的文本错误信息
    • mysql_escape_string — 转义一个字符串用于 mysql_query
    • mysql_fetch_array — 从结果集中取得一行作为关联数组
    • mysql_fetch_assoc — 从结果集中取得一行作为关联数组
    • mysql_fetch_field — 从结果集中取得列信息并作为对象返回
    • mysql_fetch_lengths — 取得结果集中每个输出的长度
    • mysql_fetch_object — 从结果集中取得一行作为对象返回
    • mysql_fetch_row — 从结果集中取得一行作为枚举数组
    • mysql_field_flags — 从结果中取得和指定字段关联的标志
    • mysql_field_len — 返回指定字段的长度
    • mysql_field_name — 取得结果中指定字段的字段名
    • mysql_field_seek — 将结果集中的指针设定为制定的字段偏移量
    • mysql_field_table — 取得指定字段所在的表名
    • mysql_field_type — 取得结果集中指定字段的类型
    • mysql_free_result — 释放结果内存
    • mysql_get_client_info — 取得 MySQL 客户端信息
    • mysql_get_host_info — 取得 MySQL 主机信息
    • mysql_get_proto_info — 取得 MySQL 协议信息
    • mysql_get_server_info — 取得 MySQL 服务器信息
    • mysql_info — 取得最近一条查询的信息
    • mysql_insert_id — 取得上一步 INSERT 操作产生的 ID
    • mysql_list_dbs — 列出 MySQL 服务器中所有的数据库
    • mysql_list_fields — 列出 MySQL 结果中的字段
    • mysql_list_processes — 列出 MySQL 进程
    • mysql_list_tables — 列出 MySQL 数据库中的表
    • mysql_num_fields — 取得结果集中字段的数目
    • mysql_num_rows — 取得结果集中行的数目
    • mysql_pconnect — 打开一个到 MySQL 服务器的持久连接
    • mysql_ping — Ping 一个服务器连接，如果没有连接则重新连接
    • mysql_query — 发送一条 MySQL 查询
    • mysql_real_escape_string — 转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集
    • mysql_result — 取得结果数据
    • mysql_select_db — 选择 MySQL 数据库
    • mysql_set_charset — 设置客户端的字符集
    • mysql_stat — 取得当前系统状态
    • mysql_tablename — 取得表名
    • mysql_thread_id — 返回当前线程的 ID
    • mysql_unbuffered_query — 向 MySQL 发送一条 SQL 查询，并不获取和缓存结果的行


简介

从 PHP 5.5.0 起这个扩展已经被废弃，并且从 PHP 7.0.0. 开始被移除。作为替代，可以使用 mysqli 或者 PDO_MySQL 扩展代替。 参见 MySQL API 概览 寻找关于选择 MySQL API 的更多帮助。

这些函数允许你接入 MySQL 数据库服务器。更多关于 MySQL 的信息： » http://www.mysql.com/。

关于 MySQL 的文档能在此找到： » http://dev.mysql.com/doc/。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Mysql（原始）
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

为了使这些函数能够使用，你必须编译加入 PHP 对 MySQL 的支持。

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：


安装

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

编译时，只要使用 --with-mysql[=DIR] 配置选项即可，其中可选的 [DIR] 指向 MySQL 的安装目录。

虽然本 MySQL 扩展库兼容 MySQL 4.1.0 及其以后版本，但是它不支持这些版本提供的额外功能。要使用这些功能，请使用 MySQLi 扩展库。

如果要同时安装 mysql 扩展库和 mysqli 扩展库，必须使用同一个客户端库以避免任何冲突。

在 Linux 系统下安装

Note: [DIR] is the path to the MySQL client library files (headers and libraries), which can be downloaded from » MySQL.

ext/mysql compile time support matrix
PHP 版本 | 默认 | 配置选项: mysqlnd | 配置选项: libmysql | 更新日志
4.x.x | libmysql | 不适用 | --without-mysql to disable | MySQL enabled by default, MySQL client libraries are bundled
5.0.x, 5.1.x, 5.2.x | libmysql | 不适用 | --with-mysql=[DIR] | MySQL is no longer enabled by default, and the MySQL client libraries are no longer bundled
5.3.x | libmysql | --with-mysql=mysqlnd | --with-mysql=[DIR] | mysqlnd is now available
5.4.x | mysqlnd | --with-mysql | --with-mysql=[DIR] | mysqlnd is now the default

在 Windows 系统下安装

PHP 4

PHP MySQL 扩展已经编译入 PHP。

PHP 5+

MySQL 默认未启用，因此必须在 php.ini 中激活 php_mysql.dll 动态连接库。此外，PHP 还需要访问 MySQL 客户端连接库。PHP 的 Windows 发行版包括了一个 libmysql.dll，为了让 PHP 能和 MySQL 对话，此文件必须放在 Windows 的系统路径 PATH 中。怎样做见 FAQ 中的"怎样把 PHP 目录加入到 Windows PATH中"。尽管将 libmysql.dll 拷贝到 Windows 系统目录中也可以（因为系统目录默认在系统路径 PATH 中），但不推荐这样做。

要激活任何 PHP 扩展库（例如 php_mysql.dll），PHP 指令 extension_dir 要被设为 PHP 扩展库所在的目录。参见手工 Windows 安装指南。PHP 5 下 extension_dir 取值的一个例子是 c:\php\ext。

Note:

如果启动 web 服务器时出现类似如下的错误："Unable to load dynamic library './php_mysql.dll'"，这是因为系统找不到 php_mysql.dll 和／或 libmysql.dll。

PHP 5.3.0+

The MySQL Native Driver is enabled by default. Include php_mysql.dll, but libmysql.dll is no longer required or used.

MySQL 安装注意事项

Warning

当同时加在本扩展库和 recode 扩展库时 PHP 可能会崩溃。更多信息见 recode 扩展库。

Note:

如果需要不同于 latin（默认值）的字符集，必须安装外部的（非绑定的）已编译入所需字符集支持的 libmysql。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

MySQL 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mysql.allow_local_infile | "1" | PHP_INI_SYSTEM |
mysql.allow_persistent | "1" | PHP_INI_SYSTEM |
mysql.max_persistent | "-1" | PHP_INI_SYSTEM |
mysql.max_links | "-1" | PHP_INI_SYSTEM |
mysql.trace_mode | "0" | PHP_INI_ALL | 自 PHP 4.3.0 起可用
mysql.default_port | NULL | PHP_INI_ALL |
mysql.default_socket | NULL | PHP_INI_ALL | 自 PHP 4.0.1 起可用
mysql.default_host | NULL | PHP_INI_ALL |
mysql.default_user | NULL | PHP_INI_ALL |
mysql.default_password | NULL | PHP_INI_ALL |
mysql.connect_timeout | "60" | PHP_INI_ALL | 自 PHP 4.3.0 起可用。在 PHP <= 4.3.2 时为 PHP_INI_SYSTEM
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

mysql.allow_local_infile integer

Allow accessing, from PHP's perspective, local files with LOAD DATA statements

mysql.allow_persistent boolean

是否允许 MySQL 的持久连接。

mysql.max_persistent integer

每个进程中最大的持久连接数目。

mysql.max_links integer

每个进程中最大的连接数，包括持久连接。

mysql.trace_mode boolean

跟踪模式。当激活 mysql.trace_mode 时，将会显示 table/index 扫描的警告，未释放的结果集以及 SQL 错误。（PHP 4.3.0 引进）

mysql.default_port string

指定默认连接数据库的 TCP 端口号。如果没有指定默认端口号，则按顺序从 MYSQL_TCP_PORT 环境变量，/etc/services 文件中的 mysql-tcp 项或者编译时指定的 MYSQL_PORT 常量中取得。Win32 环境下只会使用 MYSQL_PORT 常量。

mysql.default_socket string

当使用本地连接的时候，默认的 socket 名称。

mysql.default_host string

默认连接的数据库服务器地址。不适用于 SQL 安全模式。

mysql.default_user string

默认连接数据库时使用的用户名。不适用于 SQL 安全模式。

mysql.default_password string

默认连接数据库时使用的密码。不适用于 SQL 安全模式。

mysql.connect_timeout integer

连接超时秒数。在 Linux 中，此参数设定了等候来自服务器的响应的时长。


资源类型

在 MySQL 模块中用到了两种资源类型。第一种是数据库链接的链接标识符，第二种是资源标识符，包含了查询结果集。


更新日志

对本扩展的类／函数／方法有以下更新。

ext/mysql 扩展更新日志概要

ext/mysql 扩展相关的更新日志。

全局 ext/mysql 的变更

以下列表是整个 ext/mysql 扩展的变动更新。

版本 | 说明
7.0.0 | 此扩展已从 PHP 中移除。详见 Choosing an API.
5.5.0 | 此扩展已经不建议使用。通过 mysql_connect()、mysql_pconnect() 或任何由 mysql_* 函数实现的 MySQL 数据库连接将产生 E_DEPRECATED 错误。
5.5.0 | 所有旧的废弃函数和别名现在会产生 E_DEPRECATED 错误。这些函数分别是： mysql(), mysql_fieldname(), mysql_fieldtable(), mysql_fieldlen(), mysql_fieldtype(), mysql_fieldflags(), mysql_selectdb(), mysql_createdb(), mysql_dropdb(), mysql_freeresult(), mysql_numfields(), mysql_numrows(), mysql_listdbs(), mysql_listtables(), mysql_listfields(), mysql_db_name(), mysql_dbname(), mysql_tablename() 和 mysql_table_name()。

函数的变更项

以下列表为 ext/mysql 函数完整的更新历史项。

Version Function Description


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

在 PHP 4.3.0 以后的版本中，允许在 mysql_connect() 函数和 mysql_pconnect() 函数中指定更多的客户端标记。下面列出所定义的常量：

MySQL 客户端常量
常量 | 说明
MYSQL_CLIENT_COMPRESS | 使用压缩的通讯协议
MYSQL_CLIENT_IGNORE_SPACE | 允许在函数名后留空格位
MYSQL_CLIENT_INTERACTIVE | 允许设置断开连接之前所空闲等候的 interactive_timeout 时间（代替 wait_timeout）。
MYSQL_CLIENT_SSL | 使用 SSL 加密。本标志仅在 MySQL 客户端库版本为 4.x 或更高版本时可用。在 PHP 4 和 Windows 版的 PHP 5 安装包中绑定的都是 3.23.x。

mysql_fetch_array() 函数使用一个常量来表示所返回数组的类型。下面是常量的定义：

MySQL fetch 常量
常量 | 说明
MYSQL_ASSOC | 返回的数据列使用字段名作为数组的索引名。
MYSQL_BOTH | 返回的数据列使用字段名及数字索引作为数组的索引名。
MYSQL_NUM | 返回的数据列使用数字索引作为数组的索引名。索引从 0 开始，表示返回结果的第一个字段。


  • ? 预定义常量
  • MySQL 扩展概述范例 ?
  • PHP Manual
  • Mysql（原始）
  • 范例

范例

Table of Contents

  • MySQL 扩展概述范例


MySQL 扩展概述范例

这个简单的范例展示了如何连接、执行一个查询，打印结果集后断开 MySQL 数据库的连接。

Example #1 MySQL 扩展概述范例

<?php
// 连接、选择数据库
$link = mysql_connect('mysql_host', 'mysql_user', 'mysql_password')
    or die('Could not connect: ' . mysql_error());
echo 'Connected successfully';
mysql_select_db('my_database') or die('Could not select database');

// 执行 SQL 查询
$query = 'SELECT * FROM my_table';
$result = mysql_query($query) or die('Query failed: ' . mysql_error());

// 以 HTML 打印查询结果
echo "<table>\n";
while ($line = mysql_fetch_array($result, MYSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($line as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

// 释放结果集
mysql_free_result($result);

// 关闭连接
mysql_close($link);
?>


MySQL 函数

注释

Note:

大多数 MySQL 函数的最后一个可选参数是 link_identifier。 如果没有提供这个参数，则会使用最后一个打开的连接。 若不存在这个最后打开的连接，则会尝试用 php.ini 里定义的默认参数来连接。 如果没有成功连接，函数会返回 false。

Table of Contents

  • mysql_affected_rows — 取得前一次 MySQL 操作所影响的记录行数
  • mysql_client_encoding — 返回字符集的名称
  • mysql_close — 关闭 MySQL 连接
  • mysql_connect — 打开一个到 MySQL 服务器的连接
  • mysql_create_db — 新建一个 MySQL 数据库
  • mysql_data_seek — 移动内部结果的指针
  • mysql_db_name — 取得 mysql_list_dbs 返回的结果数据
  • mysql_db_query — 发送一条 MySQL 查询
  • mysql_drop_db — 丢弃（删除）一个 MySQL 数据库
  • mysql_errno — 返回上一个 MySQL 操作中的错误信息的数字编码
  • mysql_error — 返回上一个 MySQL 操作产生的文本错误信息
  • mysql_escape_string — 转义一个字符串用于 mysql_query
  • mysql_fetch_array — 从结果集中取得一行作为关联数组
  • mysql_fetch_assoc — 从结果集中取得一行作为关联数组
  • mysql_fetch_field — 从结果集中取得列信息并作为对象返回
  • mysql_fetch_lengths — 取得结果集中每个输出的长度
  • mysql_fetch_object — 从结果集中取得一行作为对象返回
  • mysql_fetch_row — 从结果集中取得一行作为枚举数组
  • mysql_field_flags — 从结果中取得和指定字段关联的标志
  • mysql_field_len — 返回指定字段的长度
  • mysql_field_name — 取得结果中指定字段的字段名
  • mysql_field_seek — 将结果集中的指针设定为制定的字段偏移量
  • mysql_field_table — 取得指定字段所在的表名
  • mysql_field_type — 取得结果集中指定字段的类型
  • mysql_free_result — 释放结果内存
  • mysql_get_client_info — 取得 MySQL 客户端信息
  • mysql_get_host_info — 取得 MySQL 主机信息
  • mysql_get_proto_info — 取得 MySQL 协议信息
  • mysql_get_server_info — 取得 MySQL 服务器信息
  • mysql_info — 取得最近一条查询的信息
  • mysql_insert_id — 取得上一步 INSERT 操作产生的 ID
  • mysql_list_dbs — 列出 MySQL 服务器中所有的数据库
  • mysql_list_fields — 列出 MySQL 结果中的字段
  • mysql_list_processes — 列出 MySQL 进程
  • mysql_list_tables — 列出 MySQL 数据库中的表
  • mysql_num_fields — 取得结果集中字段的数目
  • mysql_num_rows — 取得结果集中行的数目
  • mysql_pconnect — 打开一个到 MySQL 服务器的持久连接
  • mysql_ping — Ping 一个服务器连接，如果没有连接则重新连接
  • mysql_query — 发送一条 MySQL 查询
  • mysql_real_escape_string — 转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集
  • mysql_result — 取得结果数据
  • mysql_select_db — 选择 MySQL 数据库
  • mysql_set_charset — 设置客户端的字符集
  • mysql_stat — 取得当前系统状态
  • mysql_tablename — 取得表名
  • mysql_thread_id — 返回当前线程的 ID
  • mysql_unbuffered_query — 向 MySQL 发送一条 SQL 查询，并不获取和缓存结果的行


取得前一次 MySQL 操作所影响的记录行数

  • ? MySQL 函数
  • mysql_client_encoding ?
  • PHP Manual
  • MySQL 函数
  • 取得前一次 MySQL 操作所影响的记录行数

mysql_affected_rows

(PHP 4, PHP 5)

mysql_affected_rows — 取得前一次 MySQL 操作所影响的记录行数

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_affected_rows()
  • PDOStatement::rowCount()

说明

mysql_affected_rows ( resource $link_identifier = NULL ) : int

取得最近一次与 link_identifier 关联的 INSERT，UPDATE 或 DELETE 查询所影响的记录行数。

参数

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

执行成功则返回受影响的行的数目，如果最近一次查询失败的话，函数返回 -1。

如果最近一次操作是没有任何条件（WHERE）的 DELETE 查询，在表中所有的记录都会被删除，但本函数返回值在 4.1.2 版之前都为 0。

当使用 UPDATE 查询，MySQL 不会将原值和新值一样的列更新。这样使得 mysql_affected_rows() 函数返回值不一定就是查询条件所符合的记录数，只有真正被修改的记录数才会被返回。

REPLACE 语句首先删除具有相同主键的记录，然后插入一个新记录。本函数返回的是被删除的记录数加上被插入的记录数。

"INSERT ... ON DUPLICATE KEY UPDATE" 这种情况的查询，当执行了一次 INSERT 返回的值会是 1；如果是对已经存在的记录执行一次 UPDATE 将返回 2。

范例

Example #1 mysql_affected_rows() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
mysql_select_db('mydb');

/* 本例返回被删除记录的准确数目 */
mysql_query('DELETE FROM mytable WHERE id < 10');
printf("Records deleted: %d\n", mysql_affected_rows());

/* 对于非真值的 WHERE 子句，应返回 0 */
mysql_query('DELETE FROM mytable WHERE 0');
printf("Records deleted: %d\n", mysql_affected_rows());
?>

以上例程的输出类似于：

Records deleted: 10
Records deleted: 0

Example #2 使用事务处理的 mysql_affected_rows() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
mysql_select_db('mydb');

/* Update records */
mysql_query("UPDATE mytable SET used=1 WHERE id < 10");
printf ("Updated records: %d\n", mysql_affected_rows());
mysql_query("COMMIT");
?>

以上例程的输出类似于：

Updated Records: 10

注释

Note: 事务处理

如果使用事务处理（transactions），需要在 INSERT，UPDATE 或 DELETE 查询后调用 mysql_affected_rows() 函数，而不是在 COMMIT 命令之后。

Note: SELECT 语句

要获取 SELECT 所返回的行数，可以用 mysql_num_rows()。

Note: Cascaded 外键

mysql_affected_rows() does not count rows affected implicitly through the use of ON DELETE CASCADE and/or ON UPDATE CASCADE in foreign key constraints.

参见

  • mysql_num_rows() - 取得结果集中行的数目
  • mysql_info() - 取得最近一条查询的信息


返回字符集的名称

  • ? mysql_affected_rows
  • mysql_close ?
  • PHP Manual
  • MySQL 函数
  • 返回字符集的名称

mysql_client_encoding

(PHP 4 >= 4.3.0, PHP 5)

mysql_client_encoding — 返回字符集的名称

说明

mysql_client_encoding ( resource $link_identifier = ? ) : string

从 MySQL 中取得 character_set 变量的值。

参数

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

返回当前连接的默认字符集名称。

范例

Example #1 mysql_client_encoding() 例子

<?php
$link    = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$charset = mysql_client_encoding($link);

echo "The current character set is: $charset\n";
?>

以上例程的输出类似于：

The current character set is: latin1

注释

Note:

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_character_set_name()
  • PDO::setAttribute() (e.g., $db->setAttribute(PDO::MYSQL_ATTR_INIT_COMMAND, "SET NAMES 'utf8'");)

参见

  • mysql_real_escape_string() - 转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集


关闭 MySQL 连接

  • ? mysql_client_encoding
  • mysql_connect ?
  • PHP Manual
  • MySQL 函数
  • 关闭 MySQL 连接

mysql_close

(PHP 4, PHP 5)

mysql_close — 关闭 MySQL 连接

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_close()
  • PDO: 为 PDO 对象设置一个 null 值

说明

mysql_close ( resource $link_identifier = NULL ) : bool

mysql_close() 关闭指定的连接标识所关联的到 MySQL 服务器的非持久连接。如果没有指定 link_identifier，则关闭上一个打开的连接。

通常不需要使用 mysql_close()，因为已打开的非持久连接会在脚本执行完毕后自动关闭。参见释放资源。

参数

link_identifier

MySQL 连接. 如果该连接标识符未给出, 将使用最近一次mysql_connect()建立的连接. 如果没有找到可使用的连接, 将产生一个 E_WARNING 错误.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysql_close() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>

以上例程会输出：

Connected successfully

注释

Note:

mysql_close() 不会关闭由 mysql_pconnect() 建立的持久连接。

参见

  • mysql_connect() - 打开一个到 MySQL 服务器的连接
  • mysql_free_result() - 释放结果内存


打开一个到 MySQL 服务器的连接

  • ? mysql_close
  • mysql_create_db ?
  • PHP Manual
  • MySQL 函数
  • 打开一个到 MySQL 服务器的连接

mysql_connect

(PHP 4, PHP 5)

mysql_connect — 打开一个到 MySQL 服务器的连接

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_connect()
  • PDO::__construct()

说明

mysql_connect ( string $server = ini_get("mysql.default_host") , string $username = ini_get("mysql.default_user") , string $password = ini_get("mysql.default_password") , bool $new_link = false , int $client_flags = 0 ) : resource|false

打开或重复使用一个到 MySQL 服务器的连接。

参数

server

MySQL 服务器。可以包括端口号，例如 "hostname:port"，或者到本地套接字的路径，例如对于 localhost 的 ":/path/to/socket"。

如果 PHP 指令 mysql.default_host 未定义（默认情况），则默认值是 'localhost:3306'。 在 SQL 安全模式 时，参数被忽略，总是使用 'localhost:3306'。

username

用户名。默认值由 mysql.default_user 定义。 在 SQL 安全模式 时，参数被忽略，总是使用服务器进程所有者的用户名。

password

密码。默认值由mysql.default_password定义。在 SQL 安全模式 时，参数被忽略，总是使用空密码。

new_link

如果用同样的参数第二次调用 mysql_connect()，将不会建立新连接，而将返回已经打开的连接标识。参数 new_link 改变此行为并使 mysql_connect() 总是打开新的连接，甚至当 mysql_connect() 曾在前面被用同样的参数调用过。

client_flags

client_flags 参数可以是以下常量的组合：MYSQL_CLIENT_SSL，MYSQL_CLIENT_COMPRESS，MYSQL_CLIENT_IGNORE_SPACE 或 MYSQL_CLIENT_INTERACTIVE。进一步信息见 MySQL 客户端常量。

返回值

如果成功则返回一个 MySQL 连接标识， 或者在失败时返回 false。

更新日志

版本 | 说明
5.5.0 | 此函数会生成一个 E_DEPRECATED 错误。

范例

Example #1 mysql_connect() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>

Example #2 mysql_connect() 例子：使用 hostname:port 语法

<?php
// we connect to example.com and port 3307
$link = mysql_connect('example.com:3307', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);

// we connect to localhost at port 3307
$link = mysql_connect('127.0.0.1:3307', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>

Example #3 mysql_connect() 例子：使用 ":/path/to/socket" 语法

<?php
// we connect to localhost and socket e.g. /tmp/mysql.sock

// variant 1: omit localhost
$link = mysql_connect(':/tmp/mysql', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);

// variant 2: with localhost
$link = mysql_connect('localhost:/tmp/mysql.sock', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';
mysql_close($link);
?>

注释

Note:

只要将 server 指定为 "localhost" 或 "localhost:port"，MySQL 客户端库会越过此值并尝试连接到本地套接字（Windows 中的名字管道）。如果想用 TCP/IP，应该用 "127.0.0.1" 代替 "localhost"。如果 MySQL 客户端库试图连接到一个错误的本地套接字，则应该在 PHP 配置中设定 的正确路径并把 server 留空。

Note:

脚本一结束，到服务器的连接就被关闭，除非之前已经明确调用 mysql_close() 关闭了。

Note:

Error "Can't create TCP/IP socket (10106)" usually means that the variables_order configure directive doesn't contain character E. On Windows, if the environment is not copied the SYSTEMROOT environment variable won't be available and PHP will have problems loading Winsock.

参见

  • mysql_pconnect() - 打开一个到 MySQL 服务器的持久连接
  • mysql_close() - 关闭 MySQL 连接


新建一个 MySQL 数据库

  • ? mysql_connect
  • mysql_data_seek ?
  • PHP Manual
  • MySQL 函数
  • 新建一个 MySQL 数据库

mysql_create_db

(PHP 4, PHP 5)

mysql_create_db — 新建一个 MySQL 数据库

说明

mysql_create_db ( string $database name , resource $link_identifier = ? ) : bool

mysql_create_db() 尝试在指定的连接标识所关联的服务器上建立一个新数据库。

参数

database_name

要创建的数据库名。

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 替代 mysql_create_db() 的例子

mysql_create_db() 函数已废弃。最好用 mysql_query() 来提交一条 SQL 的 CREATE DATABASE 语句来代替。

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}

$sql = 'CREATE DATABASE my_db';
if (mysql_query($sql, $link)) {
    echo "Database my_db created successfully\n";
} else {
    echo 'Error creating database: ' . mysql_error() . "\n";
}
?>

以上例程的输出类似于：

Database my_db created successfully

注释

Note:

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_query()
  • PDO::query()

Note:

为了向下兼容，可以使用下列已废弃的别名： mysql_createdb()

Note:

如果 MySQL 扩展是基于 MySQL 4.x 客户端库编译的话则本函数不可用。

参见

  • mysql_query() - 发送一条 MySQL 查询
  • mysql_select_db() - 选择 MySQL 数据库


移动内部结果的指针

  • ? mysql_create_db
  • mysql_db_name ?
  • PHP Manual
  • MySQL 函数
  • 移动内部结果的指针

mysql_data_seek

(PHP 4, PHP 5)

mysql_data_seek — 移动内部结果的指针

说明

mysql_data_seek ( resource $result , int $row_number ) : bool

mysql_data_seek() 将指定的结果标识所关联的 MySQL 结果内部的行指针移动到指定的行号。接着调用 mysql_fetch_row() 将返回那一行。

row_number 从 0 开始。row_number 的取值范围应该从 0 到 mysql_num_rows - 1。但是如果结果集为空（mysql_num_rows() == 0），要将指针移动到 0 会失败并发出 E_WARNING 级的错误，mysql_data_seek() 将返回 false。

参数

result

resource 型的结果集。此结果集来自对 mysql_query() 的调用。

row_number

想要设定的新的结果集指针的行数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysql_data_seek() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
$db_selected = mysql_select_db('sample_db');
if (!$db_selected) {
    die('Could not select database: ' . mysql_error());
}
$query = 'SELECT last_name, first_name FROM friends';
$result = mysql_query($query);
if (!$result) {
    die('Query failed: ' . mysql_error());
}
/* fetch rows in reverse order */
for ($i = mysql_num_rows($result) - 1; $i >= 0; $i--) {
    if (!mysql_data_seek($result, $i)) {
        echo "Cannot seek to row $i: " . mysql_error() . "\n";
        continue;
    }

    if (!($row = mysql_fetch_assoc($result))) {
        continue;
    }

    echo $row['last_name'] . ' ' . $row['first_name'] . "<br />\n";
}

mysql_free_result($result);
?>

注释

Note:

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_data_seek()
  • PDO::FETCH_ORI_ABS

Note:

mysql_data_seek() 只能和
mysql_query() 结合起来使用，而不能用于
mysql_unbuffered_query()。

参见

  • mysql_query() - 发送一条 MySQL 查询
  • mysql_num_rows() - 取得结果集中行的数目
  • mysql_fetch_row() - 从结果集中取得一行作为枚举数组
  • mysql_fetch_assoc() - 从结果集中取得一行作为关联数组
  • mysql_fetch_array() - 从结果集中取得一行作为关联数组
  • mysql_fetch_object() - 从结果集中取得一行作为对象返回


取得 mysql_list_dbs 返回的结果数据

  • ? mysql_data_seek
  • mysql_db_query ?
  • PHP Manual
  • MySQL 函数
  • 取得 mysql_list_dbs 返回的结果数据

mysql_db_name

(PHP 4, PHP 5)

mysql_db_name — 取得 mysql_list_dbs() 返回的结果数据

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • Query: SELECT DATABASE()

说明

mysql_db_name ( resource $result , int $row , mixed $field = NULL ) : string

取得 mysql_list_dbs() 调用所返回的数据库名。

参数

result

mysql_list_dbs() 调用所返回的结果指针。

row

结果集中的行号。

field

字段名。

返回值

如果成功则返回数据库名，失败返回 false。如果返回了 false，用 mysql_error() 来判断错误的种类。

更新日志

版本 | 说明
5.5.0 | mysql_list_dbs() 函数已废弃，调用时会抛出 E_DEPRECATED 级别的错误。

范例

Example #1 mysql_db_name() 例子

<?php
error_reporting(E_ALL);

$link = mysql_connect('dbhost', 'username', 'password');
$db_list = mysql_list_dbs($link);

$i = 0;
$cnt = mysql_num_rows($db_list);
while ($i < $cnt) {
    echo mysql_db_name($db_list, $i) . "\n";
    $i++;
}
?>

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： mysql_dbname()

参见

  • mysql_list_dbs() - 列出 MySQL 服务器中所有的数据库
  • mysql_tablename() - 取得表名


发送一条 MySQL 查询

  • ? mysql_db_name
  • mysql_drop_db ?
  • PHP Manual
  • MySQL 函数
  • 发送一条 MySQL 查询

mysql_db_query

(PHP 4, PHP 5)

mysql_db_query — 发送一条 MySQL 查询

说明

mysql_db_query ( string $database , string $query , resource $ link_identifier = ? ) : resource

根据查询结果返回一个正的 MySQL 结果资源号，出错时返回 false。本函数会对 INSERT/UPDATE/DELETE 查询返回 true/false 来指示成功或失败。

mysql_db_query() 选择一个数据库并在其上执行查询。如果没有提供可选的连接标识，本函数会去找一个到 MySQL 服务器的已打开的连接，如果找不到已打开连接则会尝试无参数调用 mysql_connect() 来建立一个。

注意此函数不会切换回先前连接到的数据库。换句话说，不能用此函数临时在另一个数据库上执行 sql 查询，只能手工切换回来。强烈建议用户在 sql 查询中使用 database.table 语法来替代此函数。

参见 mysql_connect() 和 mysql_query()。

Note: 自 PHP 4.0.6 起不提倡使用此函数。不要用此函数，用 mysql_select_db() 和 mysql_query() 来替代。


丢弃（删除）一个 MySQL 数据库

  • ? mysql_db_query
  • mysql_errno ?
  • PHP Manual
  • MySQL 函数
  • 丢弃（删除）一个 MySQL 数据库

mysql_drop_db

(PHP 4, PHP 5)

mysql_drop_db — 丢弃（删除）一个 MySQL 数据库

说明

mysql_drop_db ( string $database_name , resource $ link_identifier = ? ) : bool

mysql_drop_db() 尝试丢弃（删除）指定连接标识所关联的服务器上的一整个数据库。

成功时返回 true， 或者在失败时返回 false。

为向下兼容也可以用 mysql_dropdb()，但反对这样做。

Note:

不提倡使用 mysql_drop_db() 函数。最好用 mysql_query() 提交一条 SQL DROP DATABASE 语句来替代。

Warning

如果 MySQL 扩展库是基于 MySQL 4.x 客户端库建立的，则本函数不可用。

参见 mysql_create_db() 和 mysql_query()。

参数

database_name

The name of the database that will be deleted.

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysql_drop_db() alternative example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}

$sql = 'DROP DATABASE my_db';
if (mysql_query($sql, $link)) {
    echo "Database my_db was successfully dropped\n";
} else {
    echo 'Error dropping database: ' . mysql_error() . "\n";
}
?>

注释

Note:

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • Execute a DROP DATABASE query

Warning

This function will not be available if the MySQL extension was built against a MySQL 4.x client library.

Note:

为了向下兼容，可以使用下列已废弃的别名： mysql_dropdb()

参见

  • mysql_query() - 发送一条 MySQL 查询


返回上一个 MySQL 操作中的错误信息的数字编码

  • ? mysql_drop_db
  • mysql_error ?
  • PHP Manual
  • MySQL 函数
  • 返回上一个 MySQL 操作中的错误信息的数字编码

mysql_errno

(PHP 4, PHP 5)

mysql_errno — 返回上一个 MySQL 操作中的错误信息的数字编码

说明

mysql_errno ( resource $link_identifier = ? ) : int

返回上一个 MySQL 函数的错误号码，如果没有出错则返回 0（零）。

从 MySQL 数据库后端来的错误不再发出警告，要用
mysql_errno() 来提取错误代码。注意本函数仅返回最近一次
MySQL 函数的执行（不包括 mysql_error() 和
mysql_errno()）的错误代码，因此如果要使用此函数，确保在调用另一个
MySQL 函数之前检查它的值。

Example #1 mysql_errno() 例子

<?php
    mysql_connect("localhost", "mysql_user", "mysql_password");

    mysql_select_db("nonexistentdb");
    echo mysql_errno() . ": " . mysql_error(). "\n";

    mysql_select_db("kossu");
    mysql_query("SELECT * FROM nonexistenttable");
    echo mysql_errno() . ": " . mysql_error() . "\n";
?>

以上例子将产生如下输出：

1049: Unknown database 'nonexistentdb'
1146: Table 'kossu.nonexistenttable' doesn't exist

Note:

如果指定了可选参数则用给定的连接提取错误代码。否则使用上一个打开的连接。

参见 mysql_error()。


返回上一个 MySQL 操作产生的文本错误信息

  • ? mysql_errno
  • mysql_escape_string ?
  • PHP Manual
  • MySQL 函数
  • 返回上一个 MySQL 操作产生的文本错误信息

mysql_error

(PHP 4, PHP 5)

mysql_error — 返回上一个 MySQL 操作产生的文本错误信息

说明

mysql_error ( resource $link_identifier = ? ) : string

返回上一个 MySQL 函数的错误文本，如果没有出错则返回 ''（空字符串）。如果没有指定连接资源号，则使用上一个成功打开的连接从 MySQL 服务器提取错误信息。

从 MySQL 数据库后端来的错误不再发出警告，要用
mysql_error() 来提取错误文本。注意本函数仅返回最近一次
MySQL 函数的执行（不包括 mysql_error() 和
mysql_errno()）的错误文本，因此如果要使用此函数，确保在调用另一个
MySQL 函数之前检查它的值。

Example #1 mysql_error 例子

<?php
    mysql_connect("localhost", "mysql_user", "mysql_password");

    mysql_select_db("nonexistentdb");
    echo mysql_errno() . ": " . mysql_error(). "\n";

    mysql_select_db("kossu");
    mysql_query("SELECT * FROM nonexistenttable");
    echo mysql_errno() . ": " . mysql_error() . "\n";
?>

以上例子将产生如下输出：

1049: Unknown database 'nonexistentdb'
1146: Table 'kossu.nonexistenttable' doesn't exist

参见 mysql_errno()。


转义一个字符串用于 mysql_query

  • ? mysql_error
  • mysql_fetch_array ?
  • PHP Manual
  • MySQL 函数
  • 转义一个字符串用于 mysql_query

mysql_escape_string

(PHP 4 >= 4.0.3, PHP 5)

mysql_escape_string — 转义一个字符串用于 mysql_query

说明

mysql_escape_string ( string $unescaped_string ) : string

本函数将 unescaped_string 转义，使之可以安全用于 mysql_query()。

Note: mysql_escape_string() 并不转义 % 和 _。 本函数和 mysql_real_escape_string() 完全一样，除了 mysql_real_escape_string() 接受的是一个连接句柄并根据当前字符集转移字符串之外。mysql_escape_string() 并不接受连接参数，也不管当前字符集设定。

Example #1 mysql_escape_string() 例子

<?php
    $item = "Zak's Laptop";
    $escaped_item = mysql_escape_string($item);
    printf ("Escaped string: %s\n", $escaped_item);
?>

以上例子将产生如下输出：

Escaped string: Zak\'s Laptop

参见 mysql_real_escape_string()，addslashes() 和 magic_quotes_gpc 指令。


从结果集中取得一行作为关联数组

  • ? mysql_escape_string
  • mysql_fetch_assoc ?
  • PHP Manual
  • MySQL 函数
  • 从结果集中取得一行作为关联数组

mysql_fetch_array

(PHP 4, PHP 5)

mysql_fetch_array — 从结果集中取得一行作为关联数组

说明

mysql_fetch_array ( resource $result , int $result_type = ? ) : array

mysql_fetch_array() 是 mysql_fetch_row() 的扩展版本。除了将数据以数字索引方式储存在数组中之外，还可以将数据作为关联索引储存，用字段名作为键名。

有一点很重要必须指出，用 mysql_fetch_array() 并不明显 比用 mysql_fetch_row() 慢，而且还提供了明显更多的值。

参数

result

resource 型的结果集。此结果集来自对 msql_query() 的调用。

result_type

接受以下常量值： MSQL_ASSOC，MSQL_NUM 和 MSQL_BOTH，默认为 MSQL_BOTH。如果用了 MYSQL_BOTH，将得到一个同时包含关联和数字索引的数组。用 MYSQL_ASSOC 只得到关联索引（如同 mysql_fetch_assoc() 那样），用 MYSQL_NUM 只得到数字索引（如同 mysql_fetch_row() 那样）。

返回值

返回根据从结果集取得的行生成的数组，如果没有更多行则返回 false。

范例

Example #1 msql_fetch_array() 示例

<?php
$con = msql_connect();
if (!$con) {
    die('Server connection problem: ' . msql_error());
}

if (!msql_select_db('test', $con)) {
    die('Database connection problem: ' . msql_error());
}

$result = msql_query('SELECT id, name FROM people', $con);
if (!$result) {
    die('Query execution problem: ' . msql_error());
}

while ($row = msql_fetch_array($result, MSQL_ASSOC)) {
    echo $row['id'] . ': ' . $row['name'] . "\n";
}

msql_free_result($result);
?>

参见

  • msql_fetch_row()
  • msql_fetch_object()
  • msql_data_seek()
  • msql_result()


从结果集中取得一行作为关联数组

  • ? mysql_fetch_array
  • mysql_fetch_field ?
  • PHP Manual
  • MySQL 函数
  • 从结果集中取得一行作为关联数组

mysql_fetch_assoc

(PHP 4 >= 4.0.3, PHP 5)

mysql_fetch_assoc — 从结果集中取得一行作为关联数组

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_fetch_assoc()
  • PDOStatement::fetch(PDO::FETCH_ASSOC)

说明

mysql_fetch_assoc ( resource $result ) : array

返回对应结果集的关联数组，并且继续移动内部数据指针。 mysql_fetch_assoc() 和用 mysql_fetch_array() 加上第二个可选参数 MYSQL_ASSOC 完全相同。它仅仅返回关联数组。

参数

result

resource 型的结果集。此结果集来自对 mysql_query() 的调用。

返回值

返回根据从结果集取得的行生成的关联数组；如果没有更多行则返回 false。

如果结果中的两个或以上的列具有相同字段名，最后一列将优先。要访问同名的其它列，要么用 mysql_fetch_row() 来取得数字索引或给该列起个别名。 参见 mysql_fetch_array() 例子中有关别名说明。

范例

Example #1 扩展的 mysql_fetch_assoc() 例子

<?php

$conn = mysql_connect("localhost", "mysql_user", "mysql_password");

if (!$conn) {
    echo "Unable to connect to DB: " . mysql_error();
    exit;
}

if (!mysql_select_db("mydbname")) {
    echo "Unable to select mydbname: " . mysql_error();
    exit;
}

$sql = "SELECT id as userid, fullname, userstatus
        FROM   sometable
        WHERE  userstatus = 1";

$result = mysql_query($sql);

if (!$result) {
    echo "Could not successfully run query ($sql) from DB: " . mysql_error();
    exit;
}

if (mysql_num_rows($result) == 0) {
    echo "No rows found, nothing to print so am exiting";
    exit;
}

// While a row of data exists, put that row in $row as an associative array
// Note: If you're expecting just one row, no need to use a loop
// Note: If you put extract($row); inside the following loop, you'll
//       then create $userid, $fullname, and $userstatus
while ($row = mysql_fetch_assoc($result)) {
    echo $row["userid"];
    echo $row["fullname"];
    echo $row["userstatus"];
}

mysql_free_result($result);

?>

注释

Note: 性能

必须指出一个要点： mysql_fetch_assoc() 比 mysql_fetch_row() 并不明显 慢，而且还提供了更多有用的值。

Note: 此函数返回的字段名大小写敏感。

Note: 此函数将 NULL 字段设置为 PHP null 值。

参见

  • mysql_fetch_row() - 从结果集中取得一行作为枚举数组
  • mysql_fetch_array() - 从结果集中取得一行作为关联数组
  • mysql_data_seek() - 移动内部结果的指针
  • mysql_query() - 发送一条 MySQL 查询
  • mysql_error() - 返回上一个 MySQL 操作产生的文本错误信息


从结果集中取得列信息并作为对象返回

  • ? mysql_fetch_assoc
  • mysql_fetch_lengths ?
  • PHP Manual
  • MySQL 函数
  • 从结果集中取得列信息并作为对象返回

mysql_fetch_field

(PHP 4, PHP 5)

mysql_fetch_field — 从结果集中取得列信息并作为对象返回

说明

mysql_fetch_field ( resource $result , int $field_offset = ? ) : object

返回一个包含字段信息的对象。

mysql_fetch_field() 可以用来从某个查询结果中取得字段的信息。如果没有指定字段偏移量，则下一个尚未被 mysql_fetch_field() 取得的字段被提取。

对象的属性为：

  • name - 列名
  • table - 该列所在的表名
  • max_length - 该列最大长度
  • not_null - 1，如果该列不能为 null
  • primary_key - 1，如果该列是 primary key
  • unique_key - 1，如果该列是 unique key
  • multiple_key - 1，如果该列是 non-unique key
  • numeric - 1，如果该列是 numeric
  • blob - 1，如果该列是 BLOB
  • type - 该列的类型
  • unsigned - 1，如果该列是无符号数
  • zerofill - 1，如果该列是 zero-filled

Note: 此函数返回的字段名大小写敏感。

Example #1 mysql_fetch_field()

<?php
mysql_connect('localhost:3306', $user, $password)
    or die("Could not connect: " . mysql_error());
mysql_select_db("database");
$result = mysql_query("select * from table")
    or die("Query failed: " . mysql_error());
/* get column metadata */
$i = 0;
while ($i < mysql_num_fields($result)) {
    echo "Information for column $i:<br />\n";
    $meta = mysql_fetch_field($result);
    if (!$meta) {
        echo "No information available<br />\n";
    }
    echo "<pre>
blob:         $meta->blob
max_length:   $meta->max_length
multiple_key: $meta->multiple_key
name:         $meta->name
not_null:     $meta->not_null
numeric:      $meta->numeric
primary_key:  $meta->primary_key
table:        $meta->table
type:         $meta->type
unique_key:   $meta->unique_key
unsigned:     $meta->unsigned
zerofill:     $meta->zerofill
</pre>";
    $i++;
}
mysql_free_result($result);
?>

参见 mysql_field_seek()。

参数

result

resource 型的结果集。此结果集来自对 mysql_query() 的调用。

field_offset

The numerical field offset. If the field offset is not specified, the next field that was not yet retrieved by this function is retrieved. The field_offset starts at 0.

返回值

Returns an object containing field information. The properties of the object are:

  • name - column name
  • table - name of the table the column belongs to
  • max_length - maximum length of the column
  • not_null - 1 if the column cannot be null
  • primary_key - 1 if the column is a primary key
  • unique_key - 1 if the column is a unique key
  • multiple_key - 1 if the column is a non-unique key
  • numeric - 1 if the column is numeric
  • blob - 1 if the column is a BLOB
  • type - the type of the column
  • unsigned - 1 if the column is unsigned
  • zerofill - 1 if the column is zero-filled

范例

Example #2 mysql_fetch_field() example

<?php
$conn = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$conn) {
    die('Could not connect: ' . mysql_error());
}
mysql_select_db('database');
$result = mysql_query('select * from table');
if (!$result) {
    die('Query failed: ' . mysql_error());
}
/* get column metadata */
$i = 0;
while ($i < mysql_num_fields($result)) {
    echo "Information for column $i:<br />\n";
    $meta = mysql_fetch_field($result, $i);
    if (!$meta) {
        echo "No information available<br />\n";
    }
    echo "<pre>
blob:         $meta->blob
max_length:   $meta->max_length
multiple_key: $meta->multiple_key
name:         $meta->name
not_null:     $meta->not_null
numeric:      $meta->numeric
primary_key:  $meta->primary_key
table:        $meta->table
type:         $meta->type
unique_key:   $meta->unique_key
unsigned:     $meta->unsigned
zerofill:     $meta->zerofill
</pre>";
    $i++;
}
mysql_free_result($result);
?>

注释

Note: 此函数返回的字段名大小写敏感。

参见

  • mysql_field_seek() - 将结果集中的指针设定为制定的字段偏移量


取得结果集中每个输出的长度

  • ? mysql_fetch_field
  • mysql_fetch_object ?
  • PHP Manual
  • MySQL 函数
  • 取得结果集中每个输出的长度

mysql_fetch_lengths

(PHP 4, PHP 5)

mysql_fetch_lengths — 取得结果集中每个输出的长度

说明

mysql_fetch_lengths ( resource $result ) : array

以数组返回上一次用 mysql_fetch_row() 取得的行中每个字段的长度，如果出错返回 false。

mysql_fetch_lengths() 将上一次
mysql_fetch_row()，mysql_fetch_array()
和 mysql_fetch_object()
所返回的每个列的长度储存到一个数组中，偏移量从 0 开始。

参见 mysql_fetch_row()。


从结果集中取得一行作为对象返回

  • ? mysql_fetch_lengths
  • mysql_fetch_row ?
  • PHP Manual
  • MySQL 函数
  • 从结果集中取得一行作为对象返回

mysql_fetch_object

(PHP 4, PHP 5)

mysql_fetch_object — 从结果集中取得一行作为对象返回

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_fetch_object()
  • PDOStatement::fetch(PDO::FETCH_OBJ)

说明

mysql_fetch_object ( resource $result , string $class_name = ? , array $params = ? ) : object

返回一个对象，其属性与获取的行相对应，并将内部数据指针向前移动。

参数

result

resource 型的结果集。此结果集来自对 mysql_query() 的调用。

class_name

要实例化、设置属性并返回的类的名称，如果不指定，默认返回 stdClass 对象。

params

可选 array 数组参数，会传递给 class_name 类的构造函数。

返回值

返回根据所取得的行生成的对象 object，如果没有更多行则返回 false。

范例

Example #1 mysql_fetch_object() example

<?php
mysql_connect("hostname", "user", "password");
mysql_select_db("mydb");
$result = mysql_query("select * from mytable");
while ($row = mysql_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
mysql_free_result($result);
?>

Example #2 mysql_fetch_object() example

<?php
class foo {
    public $name;
}

mysql_connect("hostname", "user", "password");
mysql_select_db("mydb");

$result = mysql_query("select name from mytable limit 1");
$obj = mysql_fetch_object($result, 'foo');
var_dump($obj);
?>

注释

Note: Performance

速度上，本函数和 mysql_fetch_array() 一样，也几乎和 mysql_fetch_row() 一样快（差别很不明显）。

Note:

mysql_fetch_object() 和 mysql_fetch_array() 类似，只有一点区别 - 返回一个对象而不是数组。间接地也意味着只能通过字段名来访问数组，而不是偏移量（数字是合法的属性名）。

Note: 此函数返回的字段名大小写敏感。

Note: 此函数将 NULL 字段设置为 PHP null 值。

参见

  • mysql_fetch_array() - 从结果集中取得一行作为关联数组
  • mysql_fetch_assoc() - 从结果集中取得一行作为关联数组
  • mysql_fetch_row() - 从结果集中取得一行作为枚举数组
  • mysql_data_seek() - 移动内部结果的指针
  • mysql_query() - 发送一条 MySQL 查询


从结果集中取得一行作为枚举数组

  • ? mysql_fetch_object
  • mysql_field_flags ?
  • PHP Manual
  • MySQL 函数
  • 从结果集中取得一行作为枚举数组

mysql_fetch_row

(PHP 4, PHP 5)

mysql_fetch_row — 从结果集中取得一行作为枚举数组

说明

mysql_fetch_row ( resource $result ) : array

返回根据所取得的行生成的数组，如果没有更多行则返回 false。

mysql_fetch_row() 从和指定的结果标识关联的结果集中取得一行数据并作为数组返回。每个结果的列储存在一个数组的单元中，偏移量从 0 开始。

依次调用 mysql_fetch_row() 将返回结果集中的下一行，如果没有更多行则返回 false。

参见 mysql_fetch_array()，mysql_fetch_assoc()，mysql_fetch_object()，mysql_data_seek()，mysql_fetch_lengths() 和 mysql_result()。

参数

result

resource 型的结果集。此结果集来自对 mysql_query() 的调用。

返回值

Returns an numerical array of strings that corresponds to the fetched row, or false if there are no more rows.

mysql_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

范例

Example #1 Fetching one row with mysql_fetch_row()

<?php
$result = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$result) {
    echo 'Could not run query: ' . mysql_error();
    exit;
}
$row = mysql_fetch_row($result);

echo $row[0]; // 42
echo $row[1]; // the email value
?>

注释

Note: 此函数将 NULL 字段设置为 PHP null 值。

参见

  • mysql_fetch_array() - 从结果集中取得一行作为关联数组
  • mysql_fetch_assoc() - 从结果集中取得一行作为关联数组
  • mysql_fetch_object() - 从结果集中取得一行作为对象返回
  • mysql_data_seek() - 移动内部结果的指针
  • mysql_fetch_lengths() - 取得结果集中每个输出的长度
  • mysql_result() - 取得结果数据


从结果中取得和指定字段关联的标志

  • ? mysql_fetch_row
  • mysql_field_len ?
  • PHP Manual
  • MySQL 函数
  • 从结果中取得和指定字段关联的标志

mysql_field_flags

(PHP 4, PHP 5)

mysql_field_flags — 从结果中取得和指定字段关联的标志

说明

mysql_field_flags ( resource $result , int $field_offset ) : string

mysql_field_flags() 返回指定字段的字段标志。每个标志都用一个单词表示，之间用一个空格分开，因此可以用 explode() 将其分开。

如果 MySQL 版本足够新，则会支持以下的标志："not_null", "primary_key", "unique_key", "multiple_key", "blob", "unsigned", "zerofill", "binary", "enum", "auto_increment", "timestamp"。

为向下兼容仍然可以使用 mysql_fieldflags()，但反对这样做。


返回指定字段的长度

  • ? mysql_field_flags
  • mysql_field_name ?
  • PHP Manual
  • MySQL 函数
  • 返回指定字段的长度

mysql_field_len

(PHP 4, PHP 5)

mysql_field_len — 返回指定字段的长度

说明

mysql_field_len ( resource $result , int $field_offset ) : int

mysql_field_len() 返回指定字段的长度。

为向下兼容仍然可以使用 mysql_fieldlen()，但反对这样做。


取得结果中指定字段的字段名

  • ? mysql_field_len
  • mysql_field_seek ?
  • PHP Manual
  • MySQL 函数
  • 取得结果中指定字段的字段名

mysql_field_name

(PHP 4, PHP 5)

mysql_field_name — 取得结果中指定字段的字段名

说明

mysql_field_name ( resource $result , int $field_index ) : string

mysql_field_name() 返回指定字段索引的字段名。result 必须是一个合法的结果标识符，field_index 是该字段的数字偏移量。

Note:

field_index 从 0 开始。

例如，第三个字段的索引值其实是 2，第四个字段的索引值是 3，以此类推。

Note: 此函数返回的字段名大小写敏感。

Example #1 mysql_field_name() 例子

<?php
/* The users table consists of three fields:
 *   user_id
 *   username
 *   password.
 */
$link = mysql_connect('localhost', "mysql_user", "mysql_password");
$dbname = "mydb";
mysql_select_db($dbname, $link)
    or die("Could not set $dbname: " . mysql_error());
$res = mysql_query("select * from users", $link);

echo mysql_field_name($res, 0) . "\n";
echo mysql_field_name($res, 2);
?>

以上例子将产生如下输出：

user_id
password

为向下兼容仍然可以使用 mysql_fieldname()，但反对这样做。

参数

result

resource 型的结果集。此结果集来自对 mysql_query() 的调用。

field_offset

数值型字段偏移量。 field_offset 从 0 开始。如果 field_offset 不存在，则会发出一个 E_WARNING 级别的错误

返回值

The name of the specified field index on success 或者在失败时返回 false.

范例

Example #2 mysql_field_name() example

<?php
/* The users table consists of three fields:
 *   user_id
 *   username
 *   password.
 */
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect to MySQL server: ' . mysql_error());
}
$dbname = 'mydb';
$db_selected = mysql_select_db($dbname, $link);
if (!$db_selected) {
    die("Could not set $dbname: " . mysql_error());
}
$res = mysql_query('select * from users', $link);

echo mysql_field_name($res, 0) . "\n";
echo mysql_field_name($res, 2);
?>

以上例程会输出：

user_id
password

注释

Note: 此函数返回的字段名大小写敏感。

Note:

为了向下兼容，可以使用下列已废弃的别名： mysql_fieldname()

参见

  • mysql_field_type() - 取得结果集中指定字段的类型
  • mysql_field_len() - 返回指定字段的长度


将结果集中的指针设定为制定的字段偏移量

  • ? mysql_field_name
  • mysql_field_table ?
  • PHP Manual
  • MySQL 函数
  • 将结果集中的指针设定为制定的字段偏移量

mysql_field_seek

(PHP 4, PHP 5)

mysql_field_seek — 将结果集中的指针设定为制定的字段偏移量

说明

mysql_field_seek ( resource $result , int $field_offset ) : int

用指定的字段偏移量检索。如果下一个 mysql_fetch_field() 的调用不包括字段偏移量，则会返回本次 mysql_field_seek() 中指定的偏移量的字段。

参见 mysql_fetch_field()。


取得指定字段所在的表名

  • ? mysql_field_seek
  • mysql_field_type ?
  • PHP Manual
  • MySQL 函数
  • 取得指定字段所在的表名

mysql_field_table

(PHP 4, PHP 5)

mysql_field_table — 取得指定字段所在的表名

说明

mysql_field_table ( resource $result , int $field_offset ) : string

返回指定字段所在的表的名字。

为向下兼容仍然可以使用 mysql_fieldtable()，但反对这样做。


取得结果集中指定字段的类型

  • ? mysql_field_table
  • mysql_free_result ?
  • PHP Manual
  • MySQL 函数
  • 取得结果集中指定字段的类型

mysql_field_type

(PHP 4, PHP 5)

mysql_field_type — 取得结果集中指定字段的类型

说明

mysql_field_type ( resource $result , int $field_offset ) : string

mysql_field_type() 和 mysql_field_name() 函数相似。参数完全相同，但返回的是字段类型而不是字段名。字段类型有"int"，"real"，"string"，"blob"以及其它，详见 » MySQL 手册。

Example #1 mysql_field_type() 例子

<?php
    mysql_connect("localhost", "mysql_username", "mysql_password");
    mysql_select_db("mysql");
    $result = mysql_query("SELECT * FROM func");
    $fields = mysql_num_fields($result);
    $rows   = mysql_num_rows($result);
    $table = mysql_field_table($result, 0);
    echo "Your '".$table."' table has ".$fields." fields and ".$rows." record(s)\n";
    echo "The table has the following fields:\n";
    for ($i=0; $i < $fields; $i++) {
        $type  = mysql_field_type($result, $i);
        $name  = mysql_field_name($result, $i);
        $len   = mysql_field_len($result, $i);
        $flags = mysql_field_flags($result, $i);
        echo $type." ".$name." ".$len." ".$flags."\n";
    }
    mysql_free_result($result);
    mysql_close();
?>

以上例子将产生如下输出：

Your 'func' table has 4 fields and 1 record(s)
The table has the following fields:
string name 64 not_null primary_key binary
int ret 1 not_null
string dl 128 not_null
string type 9 not_null enum

为向下兼容仍然可以使用 mysql_fieldtype()，但反对这样做。

参数

result

resource 型的结果集。此结果集来自对 mysql_query() 的调用。

field_offset

数值型字段偏移量。 field_offset 从 0 开始。如果 field_offset 不存在，则会发出一个 E_WARNING 级别的错误

返回值

The returned field type will be one of "int", "real", "string", "blob", and others as detailed in the » MySQL documentation.

范例

Example #2 mysql_field_type() example

<?php
mysql_connect("localhost", "mysql_username", "mysql_password");
mysql_select_db("mysql");
$result = mysql_query("SELECT * FROM func");
$fields = mysql_num_fields($result);
$rows   = mysql_num_rows($result);
$table  = mysql_field_table($result, 0);
echo "Your '" . $table . "' table has " . $fields . " fields and " . $rows . " record(s)\n";
echo "The table has the following fields:\n";
for ($i=0; $i < $fields; $i++) {
    $type  = mysql_field_type($result, $i);
    $name  = mysql_field_name($result, $i);
    $len   = mysql_field_len($result, $i);
    $flags = mysql_field_flags($result, $i);
    echo $type . " " . $name . " " . $len . " " . $flags . "\n";
}
mysql_free_result($result);
mysql_close();
?>

以上例程的输出类似于：

Your 'func' table has 4 fields and 1 record(s)
The table has the following fields:
string name 64 not_null primary_key binary
int ret 1 not_null
string dl 128 not_null
string type 9 not_null enum

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： mysql_fieldtype()

参见

  • mysql_field_name() - 取得结果中指定字段的字段名
  • mysql_field_len() - 返回指定字段的长度


释放结果内存

  • ? mysql_field_type
  • mysql_get_client_info ?
  • PHP Manual
  • MySQL 函数
  • 释放结果内存

mysql_free_result

(PHP 4, PHP 5)

mysql_free_result — 释放结果内存

说明

mysql_free_result ( resource $result ) : bool

mysql_free_result() 将释放所有与结果标识符 result 所关联的内存。

mysql_free_result() 仅需要在考虑到返回很大的结果集时会占用多少内存时调用。在脚本结束后所有关联的内存都会被自动释放。

成功时返回 true， 或者在失败时返回 false。

为向下兼容仍然可以使用 mysql_freeresult()，但反对这样做。

参数

result

resource 型的结果集。此结果集来自对 mysql_query() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

If a non-resource is used for the result, an error of level E_WARNING will be emitted. It's worth noting that mysql_query() only returns a resource for SELECT, SHOW, EXPLAIN, and DESCRIBE queries.

范例

Example #1 A mysql_free_result() example

<?php
$result = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$result) {
    echo 'Could not run query: ' . mysql_error();
    exit;
}
/* Use the result, assuming we're done with it afterwards */
$row = mysql_fetch_assoc($result);

/* Now we free up the result and continue on with our script */
mysql_free_result($result);

echo $row['id'];
echo $row['email'];
?>

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： mysql_freeresult()

参见

  • mysql_query() - 发送一条 MySQL 查询
  • is_resource() - 检测变量是否为资源类型


取得 MySQL 客户端信息

  • ? mysql_free_result
  • mysql_get_host_info ?
  • PHP Manual
  • MySQL 函数
  • 取得 MySQL 客户端信息

mysql_get_client_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_client_info — 取得 MySQL 客户端信息

说明

mysql_get_client_info ( ) : string

mysql_get_client_info() 返回一个字符串指出了客户端库的版本。

Example #1 mysql_get_client_info() 例子

<?php
    printf ("MySQL client info: %s\n", mysql_get_client_info());
?>

以上例子将产生如下输出：

MySQL client info: 3.23.39

参见 mysql_get_host_info()，mysql_get_proto_info() 和 mysql_get_server_info()。


取得 MySQL 主机信息

  • ? mysql_get_client_info
  • mysql_get_proto_info ?
  • PHP Manual
  • MySQL 函数
  • 取得 MySQL 主机信息

mysql_get_host_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_host_info — 取得 MySQL 主机信息

说明

mysql_get_host_info ( resource $link_identifier = ? ) : string

mysql_get_host_info() 返回一个字符串说明了连接 link_identifier 所使用的连接方式，包括服务器的主机名。如果省略 link_identifier，则使用上一个打开的连接。

Example #1 mysql_get_host_info() 例子

<?php
    mysql_connect("localhost", "mysql_user", "mysql_password") or
        die("Could not connect: " . mysql_error());
    printf ("MySQL host info: %s\n", mysql_get_host_info());
?>

以上例子将产生如下输出：

MySQL host info: Localhost via UNIX socket

参见 mysql_get_client_info()，mysql_get_proto_info() 和 mysql_get_server_info()。


取得 MySQL 协议信息

  • ? mysql_get_host_info
  • mysql_get_server_info ?
  • PHP Manual
  • MySQL 函数
  • 取得 MySQL 协议信息

mysql_get_proto_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_proto_info — 取得 MySQL 协议信息

说明

mysql_get_proto_info ( resource $link_identifier = ? ) : int

mysql_get_proto_info() 返回 link_identifier 所使用的协议版本。如果省略 link_identifier，则使用上一个打开的连接。

Example #1 mysql_get_proto_info() 例子

<?php
    mysql_connect("localhost", "mysql_user", "mysql_password") or
        die("Could not connect: " . mysql_error());
    printf ("MySQL protocol version: %s\n", mysql_get_proto_info());
?>

以上例子将产生如下输出：

MySQL protocol version: 10

参见 mysql_get_client_info()，mysql_get_host_info() 和 mysql_get_server_info()。


取得 MySQL 服务器信息

  • ? mysql_get_proto_info
  • mysql_info ?
  • PHP Manual
  • MySQL 函数
  • 取得 MySQL 服务器信息

mysql_get_server_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_server_info — 取得 MySQL 服务器信息

说明

mysql_get_server_info ( resource $link_identifier = ? ) : string

mysql_get_server_info() 返回 link_identifier 所使用的服务器版本。如果省略 link_identifier，则使用上一个打开的连接。

Example #1 mysql_get_server_info() 例子

<?php
    mysql_connect("localhost", "mysql_user", "mysql_password") or
        die("Could not connect: " . mysql_error());
    printf ("MySQL server version: %s\n", mysql_get_server_info());
?>

以上例子将产生如下输出：

MySQL server version: 4.0.1-alpha

参见 mysql_get_client_info()，mysql_get_host_info() 和 mysql_get_proto_info()。


取得最近一条查询的信息

  • ? mysql_get_server_info
  • mysql_insert_id ?
  • PHP Manual
  • MySQL 函数
  • 取得最近一条查询的信息

mysql_info

(PHP 4 >= 4.3.0, PHP 5)

mysql_info — 取得最近一条查询的信息

说明

mysql_info ( resource $link_identifier = ? ) : string

mysql_info() 返回通过给定的 link_identifier 所进行的最新一条查询的详细信息。如果没有指定 link_identifier，则假定为上一个打开的连接。

mysql_info() 对以下列出的所有语句返回一个字符串。对于其它任何语句返回 false。字符串的格式取决于给出的语句。

Example #1 相关的 MySQL 语句

INSERT INTO ... SELECT ...
字符串格式：Records: 23 Duplicates: 0 Warnings: 0
INSERT INTO ... VALUES (...),(...),(...)...
字符串格式：Records: 37 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ...
字符串格式：Records: 42 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE
字符串格式：Records: 60 Duplicates: 0 Warnings: 0
UPDATE
字符串格式：Rows matched: 65 Changed: 65 Warnings: 0
上例中的数字只是为了演示的目的，实际的值取决于查询。

Note:

mysql_info() 对于 INSERT ... VALUES 语句仅在该语句中列出了多个值的情况下返回一个非 false 的值。

参见 mysql_affected_rows()。


取得上一步 INSERT 操作产生的 ID

  • ? mysql_info
  • mysql_list_dbs ?
  • PHP Manual
  • MySQL 函数
  • 取得上一步 INSERT 操作产生的 ID

mysql_insert_id

(PHP 4, PHP 5)

mysql_insert_id — 取得上一步 INSERT 操作产生的 ID

说明

mysql_insert_id ( resource $link_identifier = ? ) : int

mysql_insert_id() 返回给定的 link_identifier 中上一步 INSERT 查询中产生的 AUTO_INCREMENT 的 ID 号。如果没有指定 link_identifier，则使用上一个打开的连接。

如果上一查询没有产生 AUTO_INCREMENT 的值，则 mysql_insert_id() 返回 0。如果需要保存该值以后使用，要确保在产生了值的查询之后立即调用 mysql_insert_id()。

Note:

MySQL 中的 SQL 函数 LAST_INSERT_ID() 总是保存着最新产生的 AUTO_INCREMENT 值，并且不会在查询语句之间被重置。

Warning

mysql_insert_id() 将 MySQL 内部的 C API 函数 mysql_insert_id() 的返回值转换成 long（PHP 中命名为 int）。如果 AUTO_INCREMENT 的列的类型是 BIGINT，则 mysql_insert_id() 返回的值将不正确。可以在 SQL 查询中用 MySQL 内部的 SQL 函数 LAST_INSERT_ID() 来替代。

Example #1 mysql_insert_id() 例子

<?php
    mysql_connect("localhost", "mysql_user", "mysql_password") or
        die("Could not connect: " . mysql_error());
    mysql_select_db("mydb");

    mysql_query("INSERT INTO mytable (product) values ('kossu')");
    printf ("Last inserted record has id %d\n", mysql_insert_id());
?>

参见 mysql_query()。


列出 MySQL 服务器中所有的数据库

  • ? mysql_insert_id
  • mysql_list_fields ?
  • PHP Manual
  • MySQL 函数
  • 列出 MySQL 服务器中所有的数据库

mysql_list_dbs

(PHP 4, PHP 5)

mysql_list_dbs — 列出 MySQL 服务器中所有的数据库

说明

mysql_list_dbs ( resource $link_identifier = ? ) : resource

mysql_list_dbs() 将返回一个结果指针，包含了当前 MySQL 进程中所有可用的数据库。用 mysql_tablename() 函数来遍历此结果指针，或者任何使用结果表的函数，例如 mysql_fetch_array()。

Example #1 mysql_list_dbs() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$db_list = mysql_list_dbs($link);

while ($row = mysql_fetch_object($db_list)) {
    echo $row->Database . "\n";
}
?>

以上例子将产生如下输出：

database1
database2
database3
...

Note:

以上代码用起来和 mysql_fetch_row() 或类似函数一样简单。

为向下兼容仍然可以使用 mysql_listdbs()，但反对这样做。

参见 mysql_db_name()。


列出 MySQL 结果中的字段

  • ? mysql_list_dbs
  • mysql_list_processes ?
  • PHP Manual
  • MySQL 函数
  • 列出 MySQL 结果中的字段

mysql_list_fields

(PHP 4, PHP 5)

mysql_list_fields — 列出 MySQL 结果中的字段

说明

mysql_list_fields ( string $database_name , string $table_name , resource $link_identifier = ? ) : resource

mysql_list_fields() 取得给定表名的信息。参数是数据库名和表名。返回一个结果指针，可以用于 mysql_field_flags()，mysql_field_len()，mysql_field_name() 和 mysql_field_type()。

Example #1 mysql_list_fields() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');

$fields = mysql_list_fields("database1", "table1", $link);
$columns = mysql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
    echo mysql_field_name($fields, $i) . "\n";
}

以上例子将产生如下输出：

field1
field2
field3
...

为向下兼容仍然可以使用 mysql_listfields()，但反对这样做。

Note:

mysql_list_fields() 函数已过时。最好用 mysql_query() 来发出一条 SHOW COLUMNS FROM table [LIKE 'name'] 的 SQL 语句来代替。


列出 MySQL 进程

  • ? mysql_list_fields
  • mysql_list_tables ?
  • PHP Manual
  • MySQL 函数
  • 列出 MySQL 进程

mysql_list_processes

(PHP 4 >= 4.3.0, PHP 5)

mysql_list_processes — 列出 MySQL 进程

说明

mysql_list_processes ( resource $link_identifier = ? ) : resource

mysql_list_processes() 返回一个结果指针，说明了当前服务器的线程。

Example #1 mysql_list_processes() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');

$result = mysql_list_processes($link);
while ($row = mysql_fetch_assoc($result)){
    printf("%s %s %s %s %s\n", $row["Id"], $row["Host"], $row["db"],
       $row["Command"], $row["Time"]);
}
mysql_free_result ($result);
?>

以上例子将产生如下输出：

1 localhost test Processlist 0
4 localhost mysql sleep 5

参见 mysql_thread_id()。


列出 MySQL 数据库中的表

  • ? mysql_list_processes
  • mysql_num_fields ?
  • PHP Manual
  • MySQL 函数
  • 列出 MySQL 数据库中的表

mysql_list_tables

(PHP 4, PHP 5)

mysql_list_tables — 列出 MySQL 数据库中的表

Warning

本函数自 PHP 4.3.0 起已废弃，并且它和整个MySQL 扩展自 PHP 7.0.0 开始被移除。 可以选择出于活跃开发中的MySQLi或PDO_MySQL扩展来作为替代。 参见MySQL：选择 API 指南以及 相关 FAQ来获取更多信息。 用以替代本函数的有：

  • SQL Query: SHOW TABLES FROM dbname

说明

mysql_list_tables ( string $database , resource $link_identifier = ? ) : resource|false

列出 MySQL 数据库中的表。

此函数已废弃。推荐使用 mysql_query() 来执行 SQL SHOW TABLES [FROM db_name] [LIKE 'pattern'] 来实现同样的操作。

参数

database

数据库名称

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

成功时返回结果指针 resource 或者在失败时返回 false。

可以使用 mysql_tablename() 函数来遍历该结果指针，或者使用任何针对表操作的函数，类似 mysql_fetch_array()。

更新日志

版本 | 说明
4.3.7 | 此函数已废弃。

范例

Example #1 mysql_list_tables() 例子

<?php
$dbname = 'mysql_dbname';

if (!mysql_connect('mysql_host', 'mysql_user', 'mysql_password')) {
    echo 'Could not connect to mysql';
    exit;
}

$sql = "SHOW TABLES FROM $dbname";
$result = mysql_query($sql);

if (!$result) {
    echo "DB Error, could not list tables\n";
    echo 'MySQL Error: ' . mysql_error();
    exit;
}

while ($row = mysql_fetch_row($result)) {
    echo "Table: {$row[0]}\n";
}

mysql_free_result($result);
?>

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： mysql_listtables()

参见

  • mysql_list_dbs() - 列出 MySQL 服务器中所有的数据库
  • mysql_tablename() - 取得表名


取得结果集中字段的数目

  • ? mysql_list_tables
  • mysql_num_rows ?
  • PHP Manual
  • MySQL 函数
  • 取得结果集中字段的数目

mysql_num_fields

(PHP 4, PHP 5)

mysql_num_fields — 取得结果集中字段的数目

说明

mysql_num_fields ( resource $result ) : int

mysql_num_fields() 返回结果集中字段的数目。

参见 mysql_select_db()，mysql_query()，mysql_fetch_field() 和 mysql_num_rows()。

为向下兼容仍然可以使用 mysql_numfields()，但反对这样做。


取得结果集中行的数目

  • ? mysql_num_fields
  • mysql_pconnect ?
  • PHP Manual
  • MySQL 函数
  • 取得结果集中行的数目

mysql_num_rows

(PHP 4, PHP 5)

mysql_num_rows — 取得结果集中行的数目

说明

mysql_num_rows ( resource $result ) : int

mysql_num_rows() 返回结果集中行的数目。此命令仅对 SELECT 语句有效。要取得被 INSERT，UPDATE 或者 DELETE 查询所影响到的行的数目，用 mysql_affected_rows()。

Example #1 mysql_num_rows() 例子

<?php

$link = mysql_connect("localhost", "mysql_user", "mysql_password");
mysql_select_db("database", $link);

$result = mysql_query("SELECT * FROM table1", $link);
$num_rows = mysql_num_rows($result);

echo "$num_rows Rows\n";

?>

Note:

如果使用 mysql_unbuffered_query()，则直到结果集中的所有行都被提取后 mysql_num_rows() 才能返回正确的值。

参见 mysql_affected_rows()，mysql_connect()，mysql_data_seek()，mysql_select_db() 和 mysql_query()。

为向下兼容仍然可以使用 mysql_numrows()，但反对这样做。


打开一个到 MySQL 服务器的持久连接

  • ? mysql_num_rows
  • mysql_ping ?
  • PHP Manual
  • MySQL 函数
  • 打开一个到 MySQL 服务器的持久连接

mysql_pconnect

(PHP 4, PHP 5)

mysql_pconnect — 打开一个到 MySQL 服务器的持久连接

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_connect() with p: host prefix
  • PDO::__construct() with PDO::ATTR_PERSISTENT as a driver option

说明

mysql_pconnect ( string $server = ini_get("mysql.default_host") , string $username = ini_get("mysql.default_user") , string $password = ini_get("mysql.default_password") , int $client_flags = 0 ) : resource

打开一个到 MySQL 服务器的持久连接。

mysql_pconnect() 和 mysql_connect() 非常相似，但有两个主要区别。

首先，当连接的时候本函数将先尝试寻找一个在同一个主机上用同样的用户名和密码已经打开的（持久）连接，如果找到，则返回此连接标识而不打开新连接。

其次，当脚本执行完毕后到 SQL 服务器的连接不会被关闭，此连接将保持打开以备以后使用（mysql_close() 不会关闭由 mysql_pconnect() 建立的连接）。

此种连接称为"持久的"。

参数

server

MySQL 服务器地址，参数也可以包括端口号，例如 "hostname:port" 或者是本机套接字的的路径，例如 ":/path/to/socket"

如果 PHP 配置文件中 mysql.default_host 的值未设置（默认情况下），则默认值为 'localhost:3306'

username

数据库连接使用的用户名。默认为当前服务器进程的用户。

password

数据库连接使用的密码。默认为空密码。

client_flags

参数 client_flags 可以为以下常量： 128 (enable LOAD DATA LOCAL handling), MYSQL_CLIENT_SSL, MYSQL_CLIENT_COMPRESS, MYSQL_CLIENT_IGNORE_SPACE 或 MYSQL_CLIENT_INTERACTIVE。

返回值

如果成功则返回一个正的 MySQL 持久连接标识符，出错则返回 false。

更新日志

版本 | 说明
5.5.0 | 函数会抛出一个 E_DEPRECATED 错误。

注释

Note:

需要注意的是，此函数仅当在 PHP 模块化运行时才会生效。更多信息请参阅 持久数据库连接 章节。

Warning

使用持久连接可能需要对 Apache 和 MySQL 配置进行一些调整，以确保不超过 MySQL 服务器允许的最大连接数。

参见

  • mysql_connect() - 打开一个到 MySQL 服务器的连接
  • Persistent Database Connections


Ping 一个服务器连接，如果没有连接则重新连接

  • ? mysql_pconnect
  • mysql_query ?
  • PHP Manual
  • MySQL 函数
  • Ping 一个服务器连接，如果没有连接则重新连接

mysql_ping

(PHP 4 >= 4.3.0, PHP 5)

mysql_ping — Ping 一个服务器连接，如果没有连接则重新连接

说明

mysql_ping ( resource $ link_identifier = ? ) : bool

mysql_ping() 检查到服务器的连接是否正常。如果断开，则自动尝试连接。本函数可用于空闲很久的脚本来检查服务器是否关闭了连接，如果有必要则重新连接上。如果到服务器的连接可用则 mysql_ping() 返回 true，否则返回 false。

参见 mysql_thread_id() 和 mysql_list_processes()。


发送一条 MySQL 查询

  • ? mysql_ping
  • mysql_real_escape_string ?
  • PHP Manual
  • MySQL 函数
  • 发送一条 MySQL 查询

mysql_query

(PHP 4, PHP 5)

mysql_query — 发送一条 MySQL 查询

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_query()
  • PDO::query()

说明

mysql_query ( string $query , resource $link_identifier = NULL ) : resource

mysql_query() 向与指定的 link_identifier 关联的服务器中的当前活动数据库发送一条查询（不支持多条查询）。

参数

query

SQL 查询语句

查询字符串不应以分号结束。 查询中被嵌入的数据应该正确地转义。

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

mysql_query() 仅对 SELECT，SHOW，DESCRIBE, EXPLAIN 和其他语句 语句返回一个 resource，如果查询出现错误则返回 false。

对于其它类型的 SQL 语句，比如INSERT, UPDATE, DELETE, DROP 之类， mysql_query() 在执行成功时返回 true，出错时返回 false。

返回的结果资源应该传递给 mysql_fetch_array() 和其他函数来处理结果表,取出返回的数据。

假定查询成功，可以调用 mysql_num_rows() 来查看对应于 SELECT 语句返回了多少行，或者调用 mysql_affected_rows() 来查看对应于 DELETE，INSERT，REPLACE 或 UPDATE 语句影响到了多少行。

如果没有权限访问查询语句中引用的表时，mysql_query() 也会返回 false。

范例

Example #1 无效的查询

以下查询语法上有错，因此 mysql_query() 失败并返回 false。

<?php
$result = mysql_query('SELECT * WHERE 1=1');
if (!$result) {
    die('Invalid query: ' . mysql_error());
}

?>

Example #2 有效的查询

以下查询语法正确，所以 mysql_query() 返回了一个 resource。

<?php
// 这应该由用户提供,下面是一个示例
$firstname = 'fred';
$lastname  = 'fox';

// 构造查询
// 这是执行 SQL 最好的方式
// 更多例子参见 mysql_real_escape_string()
$query = sprintf("SELECT firstname, lastname, address, age FROM friends
    WHERE firstname='%s' AND lastname='%s'",
    mysql_real_escape_string($firstname),
    mysql_real_escape_string($lastname));

// 执行查询
$result = mysql_query($query);

// 检查结果
// 下面显示了实际发送给 MySQL 的查询，以及出现的错误。这对调试很有帮助。
if (!$result) {
    $message  = 'Invalid query: ' . mysql_error() . "\n";
    $message .= 'Whole query: ' . $query;
    die($message);
}

// 结果的使用
// 尝试 print $result 并不会取出结果资源中的信息
// 所以必须至少使用其中一个 mysql 结果函数
// 参见 mysql_result(), mysql_fetch_array(), mysql_fetch_row() 等。
while ($row = mysql_fetch_assoc($result)) {
    echo $row['firstname'];
    echo $row['lastname'];
    echo $row['address'];
    echo $row['age'];
}

// 释放关联结果集的资源
// 在脚本结束的时候会自动进行
mysql_free_result($result);
?>

参见

  • mysql_connect() - 打开一个到 MySQL 服务器的连接
  • mysql_error() - 返回上一个 MySQL 操作产生的文本错误信息
  • mysql_real_escape_string() - 转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集
  • mysql_result() - 取得结果数据
  • mysql_fetch_assoc() - 从结果集中取得一行作为关联数组
  • mysql_unbuffered_query() - 向 MySQL 发送一条 SQL 查询，并不获取和缓存结果的行


转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集

  • ? mysql_query
  • mysql_result ?
  • PHP Manual
  • MySQL 函数
  • 转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集

mysql_real_escape_string

(PHP 4 >= 4.3.0, PHP 5)

mysql_real_escape_string — 转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_real_escape_string()
  • PDO::quote()

说明

mysql_real_escape_string ( string $unescaped_string , resource $link_identifier = NULL ) : string

本函数将 unescaped_string 中的特殊字符转义，并计及连接的当前字符集，因此可以安全用于 mysql_query()。

mysql_real_escape_string() 调用mysql库的函数 mysql_real_escape_string, 在以下字符前添加反斜杠: \x00, \n, \r, \, ', " 和 \x1a.

为了安全起见，在像MySQL传送查询前，必须调用这个函数（除了少数例外情况）。

Caution

安全提示: 默认字符集

The character set must be set either at the server level, or with the API function mysql_set_charset() for it to affect mysql_real_escape_string(). See the concepts section on character sets for more information.

参数

unescaped_string

The string that is to be escaped.

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

Returns the escaped string, or false on error.

错误／异常

Executing this function without a MySQL connection present will also emit E_WARNING level PHP errors. Only execute this function with a valid MySQL connection present.

范例

Example #1 mysql_real_escape_string() 例子

<?php
// Connect
$link = mysql_connect('mysql_host', 'mysql_user', 'mysql_password')
    OR die(mysql_error());

// Query
$query = sprintf("SELECT * FROM users WHERE user='%s' AND password='%s'",
            mysql_real_escape_string($user),
            mysql_real_escape_string($password));
?>

Example #2 mysql_real_escape_string() requires a connection example

This example demonstrates what happens if a MySQL connection is not present when calling this function.

<?php
// We have not connected to MySQL

$lastname  = "O'Reilly";
$_lastname = mysql_real_escape_string($lastname);

$query = "SELECT * FROM actors WHERE last_name = '$_lastname'";

var_dump($_lastname);
var_dump($query);
?>

以上例程的输出类似于：

Warning: mysql_real_escape_string(): No such file or directory in /this/test/script.php on line 5
Warning: mysql_real_escape_string(): A link to the server could not be established in /this/test/script.php on line 5

bool(false)
string(41) "SELECT * FROM actors WHERE last_name = ''"

Example #3 An example SQL Injection Attack

<?php
// We didn't check $_POST['password'], it could be anything the user wanted! For example:
$_POST['username'] = 'aidan';
$_POST['password'] = "' OR ''='";

// Query database to check if there are any matching users
$query = "SELECT * FROM users WHERE user='{$_POST['username']}' AND password='{$_POST['password']}'";
mysql_query($query);

// This means the query sent to MySQL would be:
echo $query;
?>

The query sent to MySQL:

SELECT * FROM users WHERE user='aidan' AND password='' OR ''=''

This would allow anyone to log in without a valid password.

注释

Note:

A MySQL connection is required before using mysql_real_escape_string() otherwise an error of level E_WARNING is generated, and false is returned. If link_identifier isn't defined, the last MySQL connection is used.

Note:

If magic_quotes_gpc is enabled, first apply stripslashes() to the data. Using this function on data which has already been escaped will escape the data twice.

Note:

If this function is not used to escape data, the query is vulnerable to SQL Injection Attacks.

Note: mysql_real_escape_string() does not escape % and _. These are wildcards in MySQL if combined with LIKE, GRANT, or REVOKE.

参见

  • mysql_set_charset() - 设置客户端的字符集
  • mysql_client_encoding() - 返回字符集的名称
  • addslashes() - 使用反斜线引用字符串
  • stripslashes() - 反引用一个引用字符串
  • The magic_quotes_gpc directive
  • The magic_quotes_runtime directive


取得结果数据

  • ? mysql_real_escape_string
  • mysql_select_db ?
  • PHP Manual
  • MySQL 函数
  • 取得结果数据

mysql_result

(PHP 4, PHP 5)

mysql_result — 取得结果数据

说明

mysql_result ( resource $result , int $row , mixed $field = ? ) : mixed

mysql_result() 返回 MySQL 结果集中一个单元的内容。字段参数可以是字段的偏移量或者字段名，或者是字段表点字段名（tablename.fieldname）。如果给列起了别名（'select foo as bar from...'），则用别名替代列名。

当作用于很大的结果集时，应该考虑使用能够取得整行的函数（在下边指出）。这些函数在一次函数调用中返回了多个单元的内容，比 mysql_result() 快得多。此外注意在字段参数中指定数字偏移量比指定字段名或者 tablename.fieldname 要快得多。

调用 mysql_result() 不能和其它处理结果集的函数混合调用。

Example #1 mysql_result() 例子

<?php
    $link = mysql_connect("localhost", "mysql_user", "mysql_password")
            or die("Could not connect: " . mysql_error());

    $result = mysql_query("SELECT name FROM work.employee")
            or die("Could not query: . mysql_error());

    echo mysql_result($result,2); // outputs third employee's name

    mysql_close($link);
?>

推荐使用高性能的替代函数：mysql_fetch_row()，mysql_fetch_array()，mysql_fetch_assoc() 和 mysql_fetch_object()。


选择 MySQL 数据库

  • ? mysql_result
  • mysql_set_charset ?
  • PHP Manual
  • MySQL 函数
  • 选择 MySQL 数据库

mysql_select_db

(PHP 4, PHP 5)

mysql_select_db — 选择 MySQL 数据库

说明

mysql_select_db ( string $database_name , resource $ link_identifier = ? ) : bool

成功时返回 true， 或者在失败时返回 false。

mysql_select_db() 设定与指定的连接标识符所关联的服务器上的当前激活数据库。如果没有指定连接标识符，则使用上一个打开的连接。如果没有打开的连接，本函数将无参数调用 mysql_connect() 来尝试打开一个并使用之。

每个其后的 mysql_query() 调用都会作用于活动数据库。

Example #1 mysql_select_db() 例子

<?php

$lnk = mysql_connect('localhost', 'mysql_user', 'mysql_password')
       or die ('Not connected : ' . mysql_error());

// make foo the current db
mysql_select_db('foo', $lnk) or die ('Can\'t use foo : ' . mysql_error());

?>

参见 mysql_connect()，mysql_pconnect() 和 mysql_query()。

为向下兼容仍然可以使用 mysql_selectdb()，但反对这样做。

参数

database_name

The name of the database that is to be selected.

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #2 mysql_select_db() example

<?php

$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Not connected : ' . mysql_error());
}

// make foo the current db
$db_selected = mysql_select_db('foo', $link);
if (!$db_selected) {
    die ('Can\'t use foo : ' . mysql_error());
}
?>

注释

Note:

为了向下兼容，可以使用下列已废弃的别名： mysql_selectdb()

参见

  • mysql_connect() - 打开一个到 MySQL 服务器的连接
  • mysql_pconnect() - 打开一个到 MySQL 服务器的持久连接
  • mysql_query() - 发送一条 MySQL 查询


设置客户端的字符集

  • ? mysql_select_db
  • mysql_stat ?
  • PHP Manual
  • MySQL 函数
  • 设置客户端的字符集

mysql_set_charset

(PHP 5 >= 5.2.3)

mysql_set_charset — 设置客户端的字符集

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • mysqli_character_set_name()
  • PDO: 添加 charset 到连接字符串，比如 charset=utf8

说明

mysql_set_charset ( string $charset , resource $link_identifier = NULL ) : bool

设置当前连接的默认字符集。

参数

charset

一个有效的字符集名称。

link_identifier

MySQL 连接。如不指定连接标识，则使用由 mysql_connect() 最近打开的连接。如果没有找到该连接，会尝试不带参数调用 mysql_connect() 来创建。如没有找到连接或无法建立连接，则会生成 E_WARNING 级别的错误。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

本函数需要 MySQL 5.0.7 或更高版本。

Note:

这是改变字符集的最佳方式。不推荐您使用 mysql_query() 来设置 (比如 SET NAMES utf8)。 更多信息参见 MySQL character set concepts 一节。

参见

  • mysql_client_encoding() - 返回字符集的名称
  • Setting character sets in MySQL
  • » List of character sets that MySQL supports


取得当前系统状态

  • ? mysql_set_charset
  • mysql_tablename ?
  • PHP Manual
  • MySQL 函数
  • 取得当前系统状态

mysql_stat

(PHP 4 >= 4.3.0, PHP 5)

mysql_stat — 取得当前系统状态

说明

mysql_stat ( resource $link_identifier = ? ) : string

mysql_stat() 返回当前服务器状态。

Note:

mysql_stat() 目前只返回 uptime，threads，queries，open tables，flush tables 和 queries per second。要得到其它状态变量的完整列表，只能使用 SQL 命令 SHOW STATUS。

Example #1 mysql_stat() 例子

<?php
$link = mysql_connect('localhost', "mysql_user", "mysql_password");
$status = explode('  ', mysql_stat($link));
print_r($status);
?>

以上例子将产生如下输出：

Array
(
    [0] => Uptime: 5380
    [1] => Threads: 2
    [2] => Questions: 1321299
    [3] => Slow queries: 0
    [4] => Opens: 26
    [5] => Flush tables: 1
    [6] => Open tables: 17
    [7] => Queries per second avg: 245.595
)


取得表名

  • ? mysql_stat
  • mysql_thread_id ?
  • PHP Manual
  • MySQL 函数
  • 取得表名

mysql_tablename

(PHP 4, PHP 5)

mysql_tablename — 取得表名

Warning

本扩展自 PHP 5.5.0 起已废弃，并在自 PHP 7.0.0 开始被移除。应使用 MySQLi 或 PDO_MySQL 扩展来替换之。参见 MySQL：选择 API 指南以及相关 FAQ 来获取更多信息。用以替代本函数的有：

  • SQL Query: SHOW TABLES

说明

mysql_tablename ( resource $result , int $i ) : string|false

从 result 中取得表名。

此函数已废弃，推荐使用 mysql_query() 函数来执行 SQL SHOW TABLES [FROM db_name] [LIKE 'pattern'] 替代。

参数

result

接受 mysql_list_tables() 返回的结果指针以及一个整数索引作为参数并返回表名。

i

The integer index (row/table number)

返回值

成功时返回表名 或者在失败时返回 false。

Use the mysql_tablename() function to traverse this result pointer, or any function for result tables, such as mysql_fetch_array().

更新日志

版本 | 说明
5.5.0 | mysql_tablename() 函数已废弃，调用时会抛出 E_DEPRECATED 级别的错误。

范例

Example #1 mysql_tablename() example

<?php
mysql_connect("localhost", "mysql_user", "mysql_password");
$result = mysql_list_tables("mydb");
$num_rows = mysql_num_rows($result);
for ($i = 0; $i < $num_rows; $i++) {
    echo "Table: ", mysql_tablename($result, $i), "\n";
}

mysql_free_result($result);
?>

注释

Note:

The mysql_num_rows() function may be used to determine the number of tables in the result pointer.

参见

  • mysql_list_tables() - 列出 MySQL 数据库中的表
  • mysql_field_table() - 取得指定字段所在的表名
  • mysql_db_name() - 取得 mysql_list_dbs 返回的结果数据


返回当前线程的 ID

  • ? mysql_tablename
  • mysql_unbuffered_query ?
  • PHP Manual
  • MySQL 函数
  • 返回当前线程的 ID

mysql_thread_id

(PHP 4 >= 4.3.0, PHP 5)

mysql_thread_id — 返回当前线程的 ID

说明

mysql_thread_id ( resource $link_identifier = ? ) : int

mysql_thread_id() 返回当前线程的 ID。如果连接丢失了并用 mysql_ping() 重新连接上，线程 ID 会改变。这意味着不能取得线程的 ID 后保存起来备用。当需要的时候再去获取之。

Example #1 mysql_thread_id() 例子

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$thread_id = mysql_thread_id($link);
if ($thread_id){
    printf ("current thread id is %d\n", $thread_id);
}
?>

以上例子将产生如下输出：

current thread id is 73

参见 mysql_ping() 和 mysql_list_processes()。


向 MySQL 发送一条 SQL 查询，并不获取和缓存结果的行

  • ? mysql_thread_id
  • Mysqlnd ?
  • PHP Manual
  • MySQL 函数
  • 向 MySQL 发送一条 SQL 查询，并不获取和缓存结果的行

mysql_unbuffered_query

(PHP 4 >= 4.0.6, PHP 5)

mysql_unbuffered_query — 向 MySQL 发送一条 SQL 查询，并不获取和缓存结果的行

说明

mysql_unbuffered_query ( string $query , resource $link_identifier = ? ) : resource

mysql_unbuffered_query() 向 MySQL 发送一条 SQL 查询 query，但不像 mysql_query() 那样自动获取并缓存结果集。一方面，这在处理很大的结果集时会节省可观的内存。另一方面，可以在获取第一行后立即对结果集进行操作，而不用等到整个 SQL 语句都执行完毕。当使用多个数据库连接时，必须指定可选参数 link_identifier。

Note:

mysql_unbuffered_query() 的好处是有代价的：在 mysql_unbuffered_query() 返回的结果集之上不能使用 mysql_num_rows() 和 mysql_data_seek()。此外在向 MySQL 发送一条新的 SQL 查询之前，必须提取掉所有未缓存的 SQL 查询所产生的结果行。

参见 mysql_query()。


MySQL Native Driver

  • 简介
  • Overview
  • Installation
  • 运行时配置
  • Incompatibilities
  • Persistent Connections
  • Statistics
  • Notes
  • Memory management
  • MySQL Native Driver Plugin API
    • A comparison of mysqlnd plugins with MySQL Proxy
    • Obtaining the mysqlnd plugin API
    • MySQL Native Driver Plugin Architecture
    • The mysqlnd plugin API
    • Getting started building a mysqlnd plugin


简介

MySQL Native Driver is a replacement for the MySQL Client Library (libmysqlclient). MySQL Native Driver is part of the official PHP sources as of PHP 5.3.0.

The MySQL database extensions MySQL extension, mysqli and PDO MYSQL all communicate with the MySQL server. In the past, this was done by the extension using the services provided by the MySQL Client Library. The extensions were compiled against the MySQL Client Library in order to use its client-server protocol.

With MySQL Native Driver there is now an alternative, as the MySQL database extensions can be compiled to use MySQL Native Driver instead of the MySQL Client Library.

MySQL Native Driver is written in C as a PHP extension.


Overview

What it is not

Although MySQL Native Driver is written as a PHP extension, it is important to note that it does not provide a new API to the PHP programmer. The programmer APIs for MySQL database connectivity are provided by the MySQL extension, mysqli and PDO MYSQL. These extensions can now use the services of MySQL Native Driver to communicate with the MySQL Server. Therefore, you should not think of MySQL Native Driver as an API.

Why use it?

Using the MySQL Native Driver offers a number of advantages over using the MySQL Client Library.

The older MySQL Client Library was written by MySQL AB (now Oracle Corporation) and so was released under the MySQL license. This ultimately led to MySQL support being disabled by default in PHP. However, the MySQL Native Driver has been developed as part of the PHP project, and is therefore released under the PHP license. This removes licensing issues that have been problematic in the past.

Also, in the past, you needed to build the MySQL database extensions against a copy of the MySQL Client Library. This typically meant you needed to have MySQL installed on a machine where you were building the PHP source code. Also, when your PHP application was running, the MySQL database extensions would call down to the MySQL Client library file at run time, so the file needed to be installed on your system. With MySQL Native Driver that is no longer the case as it is included as part of the standard distribution. So you do not need MySQL installed in order to build PHP or run PHP database applications.

Because MySQL Native Driver is written as a PHP extension, it is tightly coupled to the workings of PHP. This leads to gains in efficiency, especially when it comes to memory usage, as the driver uses the PHP memory management system. It also supports the PHP memory limit. Using MySQL Native Driver leads to comparable or better performance than using MySQL Client Library, it always ensures the most efficient use of memory. One example of the memory efficiency is the fact that when using the MySQL Client Library, each row is stored in memory twice, whereas with the MySQL Native Driver each row is only stored once in memory.

Note: Reporting memory usage

Because MySQL Native Driver uses the PHP memory management system, its memory usage can be tracked with memory_get_usage(). This is not possible with libmysqlclient because it uses the C function malloc() instead.

Special features

MySQL Native Driver also provides some special features not available when the MySQL database extensions use MySQL Client Library. These special features are listed below:

  • Improved persistent connections

  • The special function mysqli_fetch_all()

  • Performance statistics calls: mysqli_get_client_stats(), mysqli_get_connection_stats()

The performance statistics facility can prove to be very useful in identifying performance bottlenecks.

MySQL Native Driver also allows for persistent connections when used with the mysqli extension.

SSL Support

MySQL Native Driver supports SSL.

Compressed Protocol Support

MySQL Native Driver supports the compressed client server protocol. Extension ext/mysqli, if configured to use MySQL Native Driver, can also take advantage of this feature. Note that PDO_MYSQL does NOT support compression when used together with mysqlnd.

Named Pipes Support

Named pipes can be used to connect on Windows environments.


Installation

Installation on Unix

The MySQL database extensions must be configured to use the MySQL Client Library. In order to use the MySQL Native Driver, PHP needs to be built specifying that the MySQL database extensions are compiled with MySQL Native Driver support. This is done through configuration options prior to building the PHP source code.

For example, to build the MySQL extension, mysqli and PDO MYSQL using the MySQL Native Driver, the following command would be given:

./configure --with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
[other options]

Installation on Windows

In the official PHP Windows distributions, MySQL Native Driver is enabled by default, so no additional configuration is required to use it. All MySQL database extensions will use MySQL Native Driver in this case.

SHA-256 Authentication Plugin support

The MySQL Native Driver requires the OpenSSL functionality of PHP to be loaded and enabled to connect to MySQL through accounts that use the MySQL SHA-256 Authentication Plugin. For example, PHP could be configured using:

./configure --with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
--with-openssl
[other options]


运行时配置

这些函数的行为受 php.ini 中的设置影响。

MySQL Native Driver Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
mysqlnd.collect_statistics | "1" | PHP_INI_SYSTEM |
mysqlnd.collect_memory_statistics | "0" | PHP_INI_SYSTEM |
mysqlnd.debug | "" | PHP_INI_SYSTEM |
mysqlnd.log_mask | 0 | PHP_INI_ALL |
mysqlnd.mempool_default_size | 16000 | PHP_INI_ALL |
mysqlnd.net_read_timeout | "86400" | PHP_INI_ALL | Before PHP 7.2.0 the default value was "31536000" and the changeability was PHP_INI_SYSTEM
mysqlnd.net_cmd_buffer_size | "4096" | PHP_INI_SYSTEM |
mysqlnd.net_read_buffer_size | "32768" | PHP_INI_SYSTEM |
mysqlnd.sha256_server_public_key | "" | PHP_INI_PERDIR |
mysqlnd.trace_alloc | "" | PHP_INI_SYSTEM |
mysqlnd.fetch_data_copy | 0 | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

mysqlnd.collect_statistics bool

Enables the collection of various client statistics which can be accessed through mysqli_get_client_stats(), mysqli_get_connection_stats(), and are shown in mysqlnd section of the output of the phpinfo() function as well.

This configuration setting enables all MySQL Native Driver statistics except those relating to memory management.

mysqlnd.collect_memory_statistics bool

Enable the collection of various memory statistics which can be accessed through mysqli_get_client_stats(), mysqli_get_connection_stats(), and are shown in mysqlnd section of the output of the phpinfo() function as well.

This configuration setting enables the memory management statistics within the overall set of MySQL Native Driver statistics.

mysqlnd.debug string

Records communication from all extensions using mysqlnd to the specified log file.

The format of the directive is mysqlnd.debug = "option1[,parameter_option1][:option2[,parameter_option2]]".

The options for the format string are as follows:

  • A[,file] - Appends trace output to specified file. Also ensures that data is written after each write. This is done by closing and reopening the trace file (this is slow). It helps ensure a complete log file should the application crash.

  • a[,file] - Appends trace output to the specified file.

  • d - Enables output from DBUG_<N> macros for the current state. May be followed by a list of keywords which selects output only for the DBUG macros with that keyword. An empty list of keywords implies output for all macros.

  • f[,functions] - Limits debugger actions to the specified list of functions. An empty list of functions implies that all functions are selected.

  • F - Marks each debugger output line with the name of the source file containing the macro causing the output.

  • i - Marks each debugger output line with the PID of the current process.

  • L - Marks each debugger output line with the name of the source file line number of the macro causing the output.

  • n - Marks each debugger output line with the current function nesting depth

  • o[,file] - Similar to a[,file] but overwrites old file, and does not append.

  • O[,file] - Similar to A[,file] but overwrites old file, and does not append.

  • t[,N] - Enables function control flow tracing. The maximum nesting depth is specified by N, and defaults to 200.

  • x - This option activates profiling.

  • m - Trace memory allocation and deallocation related calls.

Example:

d:t:x:O,/tmp/mysqlnd.trace

Note:

This feature is only available with a debug build of PHP. Works on Microsoft Windows if using a debug build of PHP and PHP was built using Microsoft Visual C version 9 and above.

mysqlnd.log_mask int

Defines which queries will be logged. The default 0, which disables logging. Define using an integer, and not with PHP constants. For example, a value of 48 (16 + 32) will log slow queries which either use 'no good index' (SERVER_QUERY_NO_GOOD_INDEX_USED = 16) or no index at all (SERVER_QUERY_NO_INDEX_USED = 32). A value of 2043 (1 + 2 + 8 + ... + 1024) will log all slow query types.

The types are as follows: SERVER_STATUS_IN_TRANS=1, SERVER_STATUS_AUTOCOMMIT=2,
SERVER_MORE_RESULTS_EXISTS=8, SERVER_QUERY_NO_GOOD_INDEX_USED=16, SERVER_QUERY_NO_INDEX_USED=32,
SERVER_STATUS_CURSOR_EXISTS=64, SERVER_STATUS_LAST_ROW_SENT=128, SERVER_STATUS_DB_DROPPED=256,
SERVER_STATUS_NO_BACKSLASH_ESCAPES=512, and SERVER_QUERY_WAS_SLOW=1024.

mysqlnd.mempool_default_size int

Default size of the mysqlnd memory pool, which is used by result sets.

mysqlnd.net_read_timeout int

mysqlnd and the MySQL Client Library, libmysqlclient use different networking APIs. mysqlnd uses PHP streams, whereas libmysqlclient uses its own wrapper around the operating level network calls. PHP, by default, sets a read timeout of 60s for streams. This is set via php.ini, default_socket_timeout. This default applies to all streams that set no other timeout value. mysqlnd does not set any other value and therefore connections of long running queries can be disconnected after default_socket_timeout seconds resulting in an error message 2006 - MySQL Server has gone away. The MySQL Client Library sets a default timeout of 24 * 3600 seconds (1 day) and waits for other timeouts to occur, such as TCP/IP timeouts. mysqlnd now uses the same very long timeout. The value is configurable through a new php.ini setting: mysqlnd.net_read_timeout. mysqlnd.net_read_timeout gets used by any extension (ext/mysql, ext/mysqli, PDO_MySQL) that uses mysqlnd. mysqlnd tells PHP Streams to use mysqlnd.net_read_timeout. Please note that there may be subtle differences between MYSQL_OPT_READ_TIMEOUT from the MySQL Client Library and PHP Streams, for example MYSQL_OPT_READ_TIMEOUT is documented to work only for TCP/IP connections and, prior to MySQL 5.1.2, only for Windows. PHP streams may not have this limitation. Please check the streams documentation, if in doubt.

mysqlnd.net_cmd_buffer_size int

mysqlnd allocates an internal command/network buffer of mysqlnd.net_cmd_buffer_size (in php.ini) bytes for every connection. If a MySQL Client Server protocol command, for example, COM_QUERY (normal query), does not fit into the buffer, mysqlnd will grow the buffer to the size required for sending the command. Whenever the buffer gets extended for one connection, command_buffer_too_small will be incremented by one.

If mysqlnd has to grow the buffer beyond its initial size of mysqlnd.net_cmd_buffer_size bytes for almost every connection, you should consider increasing the default size to avoid re-allocations.

The default buffer size is 4096 bytes, which is the smallest value possible.

The value can also be set using mysqli_options(link, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, size).

mysqlnd.net_read_buffer_size int

Maximum read chunk size in bytes when reading the body of a MySQL command packet. The MySQL client server protocol encapsulates all its commands in packets. The packets consist of a small header and a body with the actual payload. The size of the body is encoded in the header. mysqlnd reads the body in chunks of MIN(header.size, mysqlnd.net_read_buffer_size) bytes. If a packet body is larger than mysqlnd.net_read_buffer_size bytes, mysqlnd has to call read() multiple times.

The value can also be set using mysqli_options(link, MYSQLI_OPT_NET_READ_BUFFER_SIZE, size).

mysqlnd.sha256_server_public_key string

SHA-256 Authentication Plugin related. File with the MySQL server public RSA key.

Clients can either omit setting a public RSA key, specify the key through this PHP configuration setting or set the key at runtime using mysqli_options(). If not public RSA key file is given by the client, then the key will be exchanged as part of the standard SHA-256 Authentication Plugin authentication procedure.

mysqlnd.trace_alloc string

mysqlnd.fetch_data_copy int

Enforce copying result sets from the internal result set buffers into PHP variables instead of using the default reference and copy-on-write logic. Please, see the memory management implementation notes for further details.

Copying result sets instead of having PHP variables reference them allows releasing the memory occupied for the PHP variables earlier. Depending on the user API code, the actual database quries and the size of their result sets this may reduce the memory footprint of mysqlnd.

Do not set if using PDO_MySQL. PDO_MySQL has not yet been updated to support the new fetch mode.


Incompatibilities

MySQL Native Driver is in most cases compatible with MySQL Client Library (libmysql). This section documents incompatibilities between these libraries.

  • Values of bit data type are returned as binary strings (e.g. "\0" or "\x1F") with libmysql and as decimal strings (e.g. "0" or "31") with mysqlnd. If you want the code to be compatible with both libraries then always return bit fields as numbers from MySQL with a query like this: SELECT bit + 0 FROM table.


Persistent Connections

Using Persistent Connections

If mysqli is used with mysqlnd, when a persistent connection is created it generates a COM_CHANGE_USER (mysql_change_user()) call on the server. This ensures that re-authentication of the connection takes place.

As there is some overhead associated with the COM_CHANGE_USER call, it is possible to switch this off at compile time. Reusing a persistent connection will then generate a COM_PING (mysql_ping) call to simply test the connection is reusable.

Generation of COM_CHANGE_USER can be switched off with the compile flag MYSQLI_NO_CHANGE_USER_ON_PCONNECT. For example:

shell# CFLAGS="-DMYSQLI_NO_CHANGE_USER_ON_PCONNECT" ./configure --with-mysql=/usr/local/mysql/ --with-mysqli=/usr/local/mysql/bin/mysql_config --with-pdo-mysql=/usr/local/mysql/bin/mysql_config --enable-debug && make clean && make -j6

Or alternatively:

shell# export CFLAGS="-DMYSQLI_NO_CHANGE_USER_ON_PCONNECT"
shell# configure --whatever-option
shell# make clean
shell# make

Note that only mysqli on mysqlnd uses COM_CHANGE_USER. Other extension-driver combinations use COM_PING on initial use of a persistent connection.


Statistics

Using Statistical Data

MySQL Native Driver contains support for gathering statistics on the communication between the client and the server. The statistics gathered are of two main types:

  • Client statistics

  • Connection statistics

If you are using the mysqli extension, these statistics can be obtained through two API calls:

  • mysqli_get_client_stats()

  • mysqli_get_connection_stats()

Note:

Statistics are aggregated among all extensions that use MySQL Native Driver. For example, when compiling both ext/mysql and ext/mysqli against MySQL Native Driver, both function calls of ext/mysql and ext/mysqli will change the statistics. There is no way to find out how much a certain API call of any extension that has been compiled against MySQL Native Driver has impacted a certain statistic. You can configure the PDO MySQL Driver, ext/mysql and ext/mysqli to optionally use the MySQL Native Driver. When doing so, all three extensions will change the statistics.

Accessing Client Statistics

To access client statistics, you need to call mysqli_get_client_stats(). The function call does not require any parameters.

The function returns an associative array that contains the name of the statistic as the key and the statistical data as the value.

Client statistics can also be accessed by calling the phpinfo() function.

Accessing Connection Statistics

To access connection statistics call mysqli_get_connection_stats(). This takes the database connection handle as the parameter.

The function returns an associative array that contains the name of the statistic as the key and the statistical data as the value.

Buffered and Unbuffered Result Sets

Result sets can be buffered or unbuffered. Using default settings, ext/mysql and ext/mysqli work with buffered result sets for normal (non prepared statement) queries. Buffered result sets are cached on the client. After the query execution all results are fetched from the MySQL Server and stored in a cache on the client. The big advantage of buffered result sets is that they allow the server to free all resources allocated to a result set, once the results have been fetched by the client.

Unbuffered result sets on the other hand are kept much longer on the server. If you want to reduce memory consumption on the client, but increase load on the server, use unbuffered results. If you experience a high server load and the figures for unbuffered result sets are high, you should consider moving the load to the clients. Clients typically scale better than servers. Load does not only refer to memory buffers - the server also needs to keep other resources open, for example file handles and threads, before a result set can be freed.

Prepared Statements use unbuffered result sets by default. However, you can use mysqli_stmt_store_result() to enable buffered result sets.

Statistics returned by MySQL Native Driver

The following tables show a list of statistics returned by the mysqli_get_client_stats() and mysqli_get_connection_stats() functions.

Returned mysqlnd statistics: Network
Statistic | Scope | Description | Notes
bytes_sent | Connection | Number of bytes sent from PHP to the MySQL server | Can be used to check the efficiency of the compression protocol
bytes_received | Connection | Number of bytes received from MySQL server | Can be used to check the efficiency of the compression protocol
packets_sent | Connection | Number of MySQL Client Server protocol packets sent | Used for debugging Client Server protocol implementation
packets_received | Connection | Number of MySQL Client Server protocol packets received | Used for debugging Client Server protocol implementation
protocol_overhead_in | Connection | MySQL Client Server protocol overhead in bytes for incoming traffic. Currently only the Packet Header (4 bytes) is considered as overhead. protocol_overhead_in = packets_received * 4 | Used for debugging Client Server protocol implementation
protocol_overhead_out | Connection | MySQL Client Server protocol overhead in bytes for outgoing traffic. Currently only the Packet Header (4 bytes) is considered as overhead. protocol_overhead_out = packets_sent * 4 | Used for debugging Client Server protocol implementation
bytes_received_ok_packet | Connection | Total size of bytes of MySQL Client Server protocol OK packets received. OK packets can contain a status message. The length of the status message can vary and thus the size of an OK packet is not fixed. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_ok | Connection | Number of MySQL Client Server protocol OK packets received. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_eof_packet | Connection | Total size in bytes of MySQL Client Server protocol EOF packets received. EOF can vary in size depending on the server version. Also, EOF can transport an error message. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_eof | Connection | Number of MySQL Client Server protocol EOF packets. Like with other packet statistics the number of packets will be increased even if PHP does not receive the expected packet but, for example, an error message. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_rset_header_packet | Connection | Total size in bytes of MySQL Client Server protocol result set header packets. The size of the packets varies depending on the payload (LOAD LOCAL INFILE, INSERT, UPDATE, SELECT, error message). | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_rset_header | Connection | Number of MySQL Client Server protocol result set header packets. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_rset_field_meta_packet | Connection | Total size in bytes of MySQL Client Server protocol result set meta data (field information) packets. Of course the size varies with the fields in the result set. The packet may also transport an error or an EOF packet in case of COM_LIST_FIELDS. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_rset_field_meta | Connection | Number of MySQL Client Server protocol result set meta data (field information) packets. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_rset_row_packet | Connection | Total size in bytes of MySQL Client Server protocol result set row data packets. The packet may also transport an error or an EOF packet. You can reverse engineer the number of error and EOF packets by subtracting rows_fetched_from_server_normal and rows_fetched_from_server_ps from bytes_received_rset_row_packet. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_rset_row | Connection | Number of MySQL Client Server protocol result set row data packets and their total size in bytes. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_prepare_response_packet | Connection | Total size in bytes of MySQL Client Server protocol OK for Prepared Statement Initialization packets (prepared statement init packets). The packet may also transport an error. The packet size depends on the MySQL version: 9 bytes with MySQL 4.1 and 12 bytes from MySQL 5.0 on. There is no safe way to know how many errors happened. You may be able to guess that an error has occurred if, for example, you always connect to MySQL 5.0 or newer and, bytes_received_prepare_response_packet != packets_received_prepare_response * 12. See also ps_prepared_never_executed, ps_prepared_once_executed. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_prepare_response | Connection | Number of MySQL Client Server protocol OK for Prepared Statement Initialization packets (prepared statement init packets). | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_change_user_packet | Connection | Total size in bytes of MySQL Client Server protocol COM_CHANGE_USER packets. The packet may also transport an error or EOF. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_change_user | Connection | Number of MySQL Client Server protocol COM_CHANGE_USER packets | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_sent_command | Connection | Number of MySQL Client Server protocol commands sent from PHP to MySQL. There is no way to know which specific commands and how many of them have been sent. At its best you can use it to check if PHP has sent any commands to MySQL to know if you can consider to disable MySQL support in your PHP binary. There is also no way to reverse engineer the number of errors that may have occurred while sending data to MySQL. The only error that is recorded is command_buffer_too_small (see below). | Only useful for debugging CS protocol implementation.
bytes_received_real_data_normal Connection Number of bytes of payload fetched by the PHP client from mysqlnd using the text protocol. This is the size of the actual data contained in result sets that do not originate from prepared statements and which have been fetched by the PHP client. Note that although a full result set may have been pulled from MySQL by mysqlnd, this statistic only counts actual data pulled from mysqlnd by the PHP client. An example of a code sequence that will increase the value is as follows:
$mysqli = new mysqli();
$res = $mysqli->query("SELECT 'abc'");
$res->fetch_assoc();
$res->close();

Every fetch operation will increase the value.

The statistic will not be increased if the result set is only buffered on the client, but not fetched, such as in the following example:

$mysqli = new mysqli();
$res = $mysqli->query("SELECT 'abc'");
$res->close();
bytes_received_real_data_ps | Connection | Number of bytes of the payload fetched by the PHP client from mysqlnd using the prepared statement protocol. | This is the size of the actual data contained in result sets that originate from prepared statements and which has been fetched by the PHP client. The value will not be increased if the result set is not subsequently read by the PHP client. Note that although a full result set may have been pulled from MySQL by mysqlnd, this statistic only counts actual data pulled from mysqlnd by the PHP client. See also bytes_received_real_data_normal.

Result Set

Returned mysqlnd statistics: Result Set
Statistic | Scope | Description | Notes
result_set_queries | Connection | Number of queries that have generated a result set. Examples of queries that generate a result set: SELECT, SHOW. The statistic will not be incremented if there is an error reading the result set header packet from the line. | You may use it as an indirect measure for the number of queries PHP has sent to MySQL, for example, to identify a client that causes a high database load.
non_result_set_queries | Connection | Number of queries that did not generate a result set. Examples of queries that do not generate a result set: INSERT, UPDATE, LOAD DATA. The statistic will not be incremented if there is an error reading the result set header packet from the line. | You may use it as an indirect measure for the number of queries PHP has sent to MySQL, for example, to identify a client that causes a high database load.
no_index_used | Connection | Number of queries that have generated a result set but did not use an index (see also mysqld start option -log-queries-not-using-indexes). If you want these queries to be reported you can use mysqli_report(MYSQLI_REPORT_INDEX) to make ext/mysqli throw an exception. If you prefer a warning instead of an exception use mysqli_report(MYSQLI_REPORT_INDEX ^ MYSQLI_REPORT_STRICT).
bad_index_used | Connection | Number of queries that have generated a result set and did not use a good index (see also mysqld start option -log-slow-queries). | If you want these queries to be reported you can use mysqli_report(MYSQLI_REPORT_INDEX) to make ext/mysqli throw an exception. If you prefer a warning instead of an exception use mysqli_report(MYSQLI_REPORT_INDEX ^ MYSQLI_REPORT_STRICT)
slow_queries | Connection | SQL statements that took more than long_query_time seconds to execute and required at least min_examined_row_limit rows to be examined. | Not reported through mysqli_report()
buffered_sets | Connection | Number of buffered result sets returned by normal queries. Normal means not prepared statement in the following notes. | Examples of API calls that will buffer result sets on the client: mysql_query(), mysqli_query(), mysqli_store_result(), mysqli_stmt_get_result(). Buffering result sets on the client ensures that server resources are freed as soon as possible and it makes result set scrolling easier. The downside is the additional memory consumption on the client for buffering data. Note that mysqlnd (unlike the MySQL Client Library) respects the PHP memory limit because it uses PHP internal memory management functions to allocate memory. This is also the reason why memory_get_usage() reports a higher memory consumption when using mysqlnd instead of the MySQL Client Library. memory_get_usage() does not measure the memory consumption of the MySQL Client Library at all because the MySQL Client Library does not use PHP internal memory management functions monitored by the function!
unbuffered_sets | Connection | Number of unbuffered result sets returned by normal (non prepared statement) queries. | Examples of API calls that will not buffer result sets on the client: mysqli_use_result()
ps_buffered_sets | Connection | Number of buffered result sets returned by prepared statements. By default prepared statements are unbuffered. | Examples of API calls that will buffer result sets on the client: mysqli_stmt_store_result
ps_unbuffered_sets | Connection | Number of unbuffered result sets returned by prepared statements. | By default prepared statements are unbuffered.
flushed_normal_sets Connection Number of result sets from normal (non prepared statement) queries with unread data which have been flushed silently for you. Flushing happens only with unbuffered result sets. Unbuffered result sets must be fetched completely before a new query can be run on the connection otherwise MySQL will throw an error. If the application does not fetch all rows from an unbuffered result set, mysqlnd does implicitly fetch the result set to clear the line. See also rows_skipped_normal, rows_skipped_ps. Some possible causes for an implicit flush:

  • Faulty client application

  • Client stopped reading after it found what it was looking for but has made MySQL calculate more records than needed

  • Client application has stopped unexpectedly

flushed_ps_sets Connection Number of result sets from prepared statements with unread data which have been flushed silently for you. Flushing happens only with unbuffered result sets. Unbuffered result sets must be fetched completely before a new query can be run on the connection otherwise MySQL will throw an error. If the application does not fetch all rows from an unbuffered result set, mysqlnd does implicitly fetch the result set to clear the line. See also rows_skipped_normal, rows_skipped_ps. Some possible causes for an implicit flush:

  • Faulty client application

  • Client stopped reading after it found what it was looking for but has made MySQL calculate more records than needed

  • Client application has stopped unexpectedly

ps_prepared_never_executed | Connection | Number of statements prepared but never executed. | Prepared statements occupy server resources. You should not prepare a statement if you do not plan to execute it.
ps_prepared_once_executed | Connection | Number of prepared statements executed only one. | One of the ideas behind prepared statements is that the same query gets executed over and over again (with different parameters) and some parsing and other preparation work can be saved, if statement execution is split up in separate prepare and execute stages. The idea is to prepare once and cache results, for example, the parse tree to be reused during multiple statement executions. If you execute a prepared statement only once the two stage processing can be inefficient compared to normal queries because all the caching means extra work and it takes (limited) server resources to hold the cached information. Consequently, prepared statements that are executed only once may cause performance hurts.
rows_fetched_from_server_normal, rows_fetched_from_server_ps | Connection | Total number of result set rows successfully fetched from MySQL regardless if the client application has consumed them or not. Some of the rows may not have been fetched by the client application but have been flushed implicitly. | See also packets_received_rset_row
rows_buffered_from_client_normal, rows_buffered_from_client_ps | Connection | Total number of successfully buffered rows originating from a "normal" query or a prepared statement. This is the number of rows that have been fetched from MySQL and buffered on client. Note that there are two distinct statistics on rows that have been buffered (MySQL to mysqlnd internal buffer) and buffered rows that have been fetched by the client application (mysqlnd internal buffer to client application). If the number of buffered rows is higher than the number of fetched buffered rows it can mean that the client application runs queries that cause larger result sets than needed resulting in rows not read by the client. | Examples of queries that will buffer results: mysqli_query(), mysqli_store_result()
rows_fetched_from_client_normal_buffered, rows_fetched_from_client_ps_buffered | Connection | Total number of rows fetched by the client from a buffered result set created by a normal query or a prepared statement.
rows_fetched_from_client_normal_unbuffered, rows_fetched_from_client_ps_unbuffered | Connection | Total number of rows fetched by the client from a unbuffered result set created by a "normal" query or a prepared statement.
rows_fetched_from_client_ps_cursor | Connection | Total number of rows fetch by the client from a cursor created by a prepared statement.
rows_skipped_normal, rows_skipped_ps | Connection | Reserved for future use (currently not supported)
copy_on_write_saved, copy_on_write_performed | Process | With mysqlnd, variables returned by the extensions point into mysqlnd internal network result buffers. If you do not change the variables, fetched data will be kept only once in memory. If you change the variables, mysqlnd has to perform a copy-on-write to protect the internal network result buffers from being changed. With the MySQL Client Library you always hold fetched data twice in memory. Once in the internal MySQL Client Library buffers and once in the variables returned by the extensions. In theory mysqlnd can save up to 40% memory. However, note that the memory saving cannot be measured using memory_get_usage().
explicit_free_result, implicit_free_result | Connection, Process (only during prepared statement cleanup) | Total number of freed result sets. | The free is always considered explicit but for result sets created by an init command, for example, mysqli_options(MYSQLI_INIT_COMMAND , ...)
proto_text_fetched_null, proto_text_fetched_bit, proto_text_fetched_tinyint proto_text_fetched_short, proto_text_fetched_int24, proto_text_fetched_int proto_text_fetched_bigint, proto_text_fetched_decimal, proto_text_fetched_float proto_text_fetched_double, proto_text_fetched_date, proto_text_fetched_year proto_text_fetched_time, proto_text_fetched_datetime, proto_text_fetched_timestamp proto_text_fetched_string, proto_text_fetched_blob, proto_text_fetched_enum proto_text_fetched_set, proto_text_fetched_geometry, proto_text_fetched_other Connection Total number of columns of a certain type fetched from a normal query (MySQL text protocol). Mapping from C API / MySQL meta data type to statistics name:

  • MYSQL_TYPE_NULL - proto_text_fetched_null

  • MYSQL_TYPE_BIT - proto_text_fetched_bit

  • MYSQL_TYPE_TINY - proto_text_fetched_tinyint

  • MYSQL_TYPE_SHORT - proto_text_fetched_short

  • MYSQL_TYPE_INT24 - proto_text_fetched_int24

  • MYSQL_TYPE_LONG - proto_text_fetched_int

  • MYSQL_TYPE_LONGLONG - proto_text_fetched_bigint

  • MYSQL_TYPE_DECIMAL, MYSQL_TYPE_NEWDECIMAL - proto_text_fetched_decimal

  • MYSQL_TYPE_FLOAT - proto_text_fetched_float

  • MYSQL_TYPE_DOUBLE - proto_text_fetched_double

  • MYSQL_TYPE_DATE, MYSQL_TYPE_NEWDATE - proto_text_fetched_date

  • MYSQL_TYPE_YEAR - proto_text_fetched_year

  • MYSQL_TYPE_TIME - proto_text_fetched_time

  • MYSQL_TYPE_DATETIME - proto_text_fetched_datetime

  • MYSQL_TYPE_TIMESTAMP - proto_text_fetched_timestamp

  • MYSQL_TYPE_STRING, MYSQL_TYPE_VARSTRING, MYSQL_TYPE_VARCHAR - proto_text_fetched_string

  • MYSQL_TYPE_TINY_BLOB, MYSQL_TYPE_MEDIUM_BLOB, MYSQL_TYPE_LONG_BLOB, MYSQL_TYPE_BLOB - proto_text_fetched_blob

  • MYSQL_TYPE_ENUM - proto_text_fetched_enum

  • MYSQL_TYPE_SET - proto_text_fetched_set

  • MYSQL_TYPE_GEOMETRY - proto_text_fetched_geometry

  • Any MYSQL_TYPE_* not listed before (there should be none) - proto_text_fetched_other

Note that the MYSQL_*-type constants may not be associated with the very same SQL column types in every version of MySQL.

proto_binary_fetched_null, proto_binary_fetched_bit, proto_binary_fetched_tinyint proto_binary_fetched_short, proto_binary_fetched_int24, proto_binary_fetched_int, proto_binary_fetched_bigint, proto_binary_fetched_decimal, proto_binary_fetched_float, proto_binary_fetched_double, proto_binary_fetched_date, proto_binary_fetched_year, proto_binary_fetched_time, proto_binary_fetched_datetime, proto_binary_fetched_timestamp, proto_binary_fetched_string, proto_binary_fetched_blob, proto_binary_fetched_enum, proto_binary_fetched_set, proto_binary_fetched_geometry, proto_binary_fetched_other | Connection | Total number of columns of a certain type fetched from a prepared statement (MySQL binary protocol). | For type mapping see proto_text_* described in the preceding text.
Returned mysqlnd statistics: Connection
Statistic | Scope | Description | Notes
connect_success, connect_failure | Connection | Total number of successful / failed connection attempt. | Reused connections and all other kinds of connections are included.
reconnect | Process | Total number of (real_)connect attempts made on an already opened connection handle. | The code sequence $link = new mysqli(...); $link->real_connect(...) will cause a reconnect. But $link = new mysqli(...); $link->connect(...) will not because $link->connect(...) will explicitly close the existing connection before a new connection is established.
pconnect_success | Connection | Total number of successful persistent connection attempts. | Note that connect_success holds the sum of successful persistent and non-persistent connection attempts. The number of successful non-persistent connection attempts is connect_success - pconnect_success.
active_connections | Connection | Total number of active persistent and non-persistent connections.
active_persistent_connections | Connection | Total number of active persistent connections. | The total number of active non-persistent connections is active_connections - active_persistent_connections.
explicit_close Connection Total number of explicitly closed connections (ext/mysqli only). Examples of code snippets that cause an explicit close :
$link = new mysqli(...); $link->close(...)
$link = new mysqli(...); $link->connect(...)
implicit_close Connection Total number of implicitly closed connections (ext/mysqli only). Examples of code snippets that cause an implicit close :

  • $link = new mysqli(...); $link->real_connect(...)

  • unset($link)

  • Persistent connection: pooled connection has been created with real_connect and there may be unknown options set - close implicitly to avoid returning a connection with unknown options

  • Persistent connection: ping/change_user fails and ext/mysqli closes the connection

  • end of script execution: close connections that have not been closed by the user

disconnect_close | Connection | Connection failures indicated by the C API call mysql_real_connect() during an attempt to establish a connection. | It is called disconnect_close because the connection handle passed to the C API call will be closed.
in_middle_of_command_close | Process | A connection has been closed in the middle of a command execution (outstanding result sets not fetched, after sending a query and before retrieving an answer, while fetching data, while transferring data with LOAD DATA). | Unless you use asynchronous queries this should only happen if your script stops unexpectedly and PHP shuts down the connections for you.
init_command_executed_count | Connection | Total number of init command executions, for example, mysqli_options(MYSQLI_INIT_COMMAND , ...). | The number of successful executions is init_command_executed_count - init_command_failed_count.
init_command_failed_count | Connection | Total number of failed init commands.
Returned mysqlnd statistics: COM_* Command
Statistic Scope Description Notes
com_quit, com_init_db, com_query, com_field_list, com_create_db, com_drop_db, com_refresh, com_shutdown, com_statistics, com_process_info, com_connect, com_process_kill, com_debug, com_ping, com_time, com_delayed_insert, com_change_user, com_binlog_dump, com_table_dump, com_connect_out, com_register_slave, com_stmt_prepare, com_stmt_execute, com_stmt_send_long_data, com_stmt_close, com_stmt_reset, com_stmt_set_option, com_stmt_fetch, com_daemon Connection Total number of attempts to send a certain COM_* command from PHP to MySQL.

The statistics are incremented after checking the line and immediately before sending the corresponding MySQL client server protocol packet. If mysqlnd fails to send the packet over the wire the statistics will not be decremented. In case of a failure mysqlnd emits a PHP warning Error while sending %s packet. PID=%d.

Usage examples:

  • Check if PHP sends certain commands to MySQL, for example, check if a client sends COM_PROCESS_KILL

  • Calculate the average number of prepared statement executions by comparing COM_EXECUTE with COM_PREPARE

  • Check if PHP has run any non-prepared SQL statements by checking if COM_QUERY is zero

  • Identify PHP scripts that run an excessive number of SQL statements by checking COM_QUERY and COM_EXECUTE

Miscellaneous

Returned mysqlnd statistics: Miscellaneous
Statistic | Scope | Description | Notes
explicit_stmt_close, implicit_stmt_close | Process | Total number of close prepared statements. | A close is always considered explicit but for a failed prepare.
mem_emalloc_count, mem_emalloc_ammount, mem_ecalloc_count, mem_ecalloc_ammount, mem_erealloc_count, mem_erealloc_ammount, mem_efree_count, mem_malloc_count, mem_malloc_ammount, mem_calloc_count, mem_calloc_ammount, mem_realloc_count, mem_realloc_ammount, mem_free_count | Process | Memory management calls. | Development only.
command_buffer_too_small Connection Number of network command buffer extensions while sending commands from PHP to MySQL.

mysqlnd allocates an internal command/network buffer of mysqlnd.net_cmd_buffer_size (php.ini) bytes for every connection. If a MySQL Client Server protocol command, for example, COM_QUERY (normal query), does not fit into the buffer, mysqlnd will grow the buffer to what is needed for sending the command. Whenever the buffer gets extended for one connection command_buffer_too_small will be incremented by one.

If mysqlnd has to grow the buffer beyond its initial size of mysqlnd.net_cmd_buffer_size (php.ini) bytes for almost every connection, you should consider to increase the default size to avoid re-allocations.

The default buffer size is 4096 bytes, which is the smallest value possible. The default can changed either through the php.ini setting mysqlnd.net_cmd_buffer_size or using mysqli_options(MYSQLI_OPT_NET_CMD_BUFFER_SIZE, int size).

connection_reused


Notes

This section provides a collection of miscellaneous notes on MySQL Native Driver usage.

  • Using mysqlnd means using PHP streams for underlying connectivity. For mysqlnd, the PHP streams documentation (Streams) should be consulted on such details as timeout settings, not the documentation for the MySQL Client Library.


Memory management

Introduction

The MySQL Native Driver manages memory different than the MySQL Client Library. The libraries differ in the way memory is allocated and released, how memory is allocated in chunks while reading results from MySQL, which debug and development options exist, and how results read from MySQL are linked to PHP user variables.

The following notes are intended as an introduction and summary to users interested at understanding the MySQL Native Driver at the C code level.

Memory management functions used

All memory allocation and deallocation is done using the PHP memory management functions. Therefore, the memory consumption of mysqlnd can be tracked using PHP API calls, such as memory_get_usage(). Because memory is allocated and released using the PHP memory management, the changes may not immediately become visible at the operating system level. The PHP memory management acts as a proxy which may delay releasing memory towards the system. Due to this, comparing the memory usage of the MySQL Native Driver and the MySQL Client Library is difficult. The MySQL Client Library is using the operating system memory management calls directly, hence the effects can be observed immediately at the operating system level.

Any memory limit enforced by PHP also affects the MySQL Native Driver. This may cause out of memory errors when fetching large result sets that exceed the size of the remaining memory made available by PHP. Because the MySQL Client Library is not using PHP memory management functions, it does not comply to any PHP memory limit set. If using the MySQL Client Library, depending on the deployment model, the memory footprint of the PHP process may grow beyond the PHP memory limit. But also PHP scripts may be able to process larger result sets as parts of the memory allocated to hold the result sets are beyond the control of the PHP engine.

PHP memory management functions are invoked by the MySQL Native Driver through a lightweight wrapper. Among others, the wrapper makes debugging easier.

Handling of result sets

The various MySQL Server and the various client APIs differentiate between buffered and unbuffered result sets. Unbuffered result sets are transferred row-by-row from MySQL to the client as the client iterates over the results. Buffered results are fetched in their entirety by the client library before passing them on to the client.

The MySQL Native Driver is using PHP Streams for the network communication with the MySQL Server. Results sent by MySQL are fetched from the PHP Streams network buffers into the result buffer of mysqlnd. The result buffer is made of zvals. In a second step the results are made available to the PHP script. This final transfer from the result buffer into PHP variables impacts the memory consumption and is mostly noticeable when using buffered result sets.

By default the MySQL Native Driver tries to avoid holding buffered results twice in memory. Results are kept only once in the internal result buffers and their zvals. When results are fetched into PHP variables by the PHP script, the variables will reference the internal result buffers. Database query results are not copied and kept in memory only once. Should the user modify the contents of a variable holding the database results a copy-on-write must be performed to avoid changing the referenced internal result buffer. The contents of the buffer must not be modified because the user may decide to read the result set a second time. The copy-on-write mechanism is implemented using an additional reference management list and the use of standard zval reference counters. Copy-on-write must also be done if the user reads a result set into PHP variables and frees a result set before the variables are unset.

Generally speaking, this pattern works well for scripts that read a result set once and do not modify variables holding results. Its major drawback is the memory overhead caused by the additional reference management which comes primarily from the fact that user variables holding results cannot be entirely released until the mysqlnd reference management stops referencing them. The MySQL Native driver removes the reference to the user variables when the result set is freed or a copy-on-write is performed. An observer will see the total memory consumption grow until the result set is released. Use the statistics to check whether a script does release result sets explicitly or the driver is does implicit releases and thus memory is used for a time longer than necessary. Statistics also help to see how many copy-on-write operations happened.

A PHP script reading many small rows of a buffered result set using a code snippet equal or equivalent to while ($row = $res->fetch_assoc()) { ... } may optimize memory consumption by requesting copies instead of references. Albeit requesting copies means keeping results twice in memory, it allows PHP to free the copy contained in $row as the result set is being iterated and prior to releasing the result set itself. On a loaded server optimizing peak memory usage may help improving the overall system performance although for an individual script the copy approach may be slower due to additional allocations and memory copy operations.

The copy mode can be enforced by setting mysqlnd.fetch_data_copy=1.

Monitoring and debugging

There are multiple ways of tracking the memory usage of the MySQL Native Driver. If the goal is to get a quick high level overview or to verify the memory efficiency of PHP scripts, then check the statistics collected by the library. The statistics allow you, for example, to catch SQL statements which generate more results than are processed by a PHP script.

The debug trace log can be configured to record memory management calls. This helps to see when memory is allocated or free'd. However, the size of the requested memory chunks may not be listed.

Some, recent versions of the MySQL Native Driver feature the emulation of random out of memory situations. This feature is meant to be used by the C developers of the library or mysqlnd plugin authors only. Please, search the source code for corresponding PHP configuration settings and further details. The feature is considered private and may be modified at any time without prior notice.


MySQL Native Driver Plugin API

Table of Contents

  • A comparison of mysqlnd plugins with MySQL Proxy
  • Obtaining the mysqlnd plugin API
  • MySQL Native Driver Plugin Architecture
  • The mysqlnd plugin API
  • Getting started building a mysqlnd plugin

The MySQL Native Driver Plugin API is a feature of MySQL Native Driver, or mysqlnd. Mysqlnd plugins operate in the layer between PHP applications and the MySQL server. This is comparable to MySQL Proxy. MySQL Proxy operates on a layer between any MySQL client application, for example, a PHP application and, the MySQL server. Mysqlnd plugins can undertake typical MySQL Proxy tasks such as load balancing, monitoring and performance optimizations. Due to the different architecture and location, mysqlnd plugins do not have some of MySQL Proxy's disadvantages. For example, with plugins, there is no single point of failure, no dedicated proxy server to deploy, and no new programming language to learn (Lua).

A mysqlnd plugin can be thought of as an extension to mysqlnd. Plugins can intercept the majority of mysqlnd functions. The mysqlnd functions are called by the PHP MySQL extensions such as ext/mysql, ext/mysqli, and PDO_MYSQL. As a result, it is possible for a mysqlnd plugin to intercept all calls made to these extensions from the client application.

Internal mysqlnd function calls can also be intercepted, or replaced. There are no restrictions on manipulating mysqlnd internal function tables. It is possible to set things up so that when certain mysqlnd functions are called by the extensions that use mysqlnd, the call is directed to the appropriate function in the mysqlnd plugin. The ability to manipulate mysqlnd internal function tables in this way allows maximum flexibility for plugins.

Mysqlnd plugins are in fact PHP Extensions, written in C, that use the mysqlnd plugin API (which is built into MySQL Native Driver, mysqlnd). Plugins can be made 100% transparent to PHP applications. No application changes are needed because plugins operate on a different layer. The mysqlnd plugin can be thought of as operating in a layer below mysqlnd.

The following list represents some possible applications of mysqlnd plugins.

  • Load Balancing

    • Read/Write Splitting. An example of this is the PECL/mysqlnd_ms (Master Slave) extension. This extension splits read/write queries for a replication setup.

    • Failover

    • Round-Robin, least loaded

  • Monitoring

    • Query Logging

    • Query Analysis

    • Query Auditing. An example of this is the PECL/mysqlnd_sip (SQL Injection Protection) extension. This extension inspects queries and executes only those that are allowed according to a ruleset.

  • Performance

    • Caching. An example of this is the PECL/mysqlnd_qc (Query Cache) extension.

    • Throttling

    • Sharding. An example of this is the PECL/mysqlnd_mc (Multi Connect) extension. This extension will attempt to split a SELECT statement into n-parts, using SELECT ... LIMIT part_1, SELECT LIMIT part_n. It sends the queries to distinct MySQL servers and merges the result at the client.

MySQL Native Driver Plugins Available

There are a number of mysqlnd plugins already available. These include:

  • PECL/mysqlnd_mc - Multi Connect plugin.

  • PECL/mysqlnd_ms - Master Slave plugin.

  • PECL/mysqlnd_qc - Query Cache plugin.

  • PECL/mysqlnd_pscache - Prepared Statement Handle Cache plugin.

  • PECL/mysqlnd_sip - SQL Injection Protection plugin.

  • PECL/mysqlnd_uh - User Handler plugin.


A comparison of mysqlnd plugins with MySQL Proxy

Mysqlnd plugins and MySQL Proxy are different technologies using different approaches. Both are valid tools for solving a variety of common tasks such as load balancing, monitoring, and performance enhancements. An important difference is that MySQL Proxy works with all MySQL clients, whereas mysqlnd plugins are specific to PHP applications.

As a PHP Extension, a mysqlnd plugin gets installed on the PHP application server, along with the rest of PHP. MySQL Proxy can either be run on the PHP application server or can be installed on a dedicated machine to handle multiple PHP application servers.

Deploying MySQL Proxy on the application server has two advantages:

  1. No single point of failure

  2. Easy to scale out (horizontal scale out, scale by client)

MySQL Proxy (and mysqlnd plugins) can solve problems easily which otherwise would have required changes to existing applications.

However, MySQL Proxy does have some disadvantages:

  • MySQL Proxy is a new component and technology to master and deploy.

  • MySQL Proxy requires knowledge of the Lua scripting language.

MySQL Proxy can be customized with C and Lua programming. Lua is the preferred scripting language of MySQL Proxy. For most PHP experts Lua is a new language to learn. A mysqlnd plugin can be written in C. It is also possible to write plugins in PHP using » PECL/mysqlnd_uh.

MySQL Proxy runs as a daemon - a background process. MySQL Proxy can recall earlier decisions, as all state can be retained. However, a mysqlnd plugin is bound to the request-based lifecycle of PHP. MySQL Proxy can also share one-time computed results among multiple application servers. A mysqlnd plugin would need to store data in a persistent medium to be able to do this. Another daemon would need to be used for this purpose, such as Memcache. This gives MySQL Proxy an advantage in this case.

MySQL Proxy works on top of the wire protocol. With MySQL Proxy you have to parse and reverse engineer the MySQL Client Server Protocol. Actions are limited to those that can be achieved by manipulating the communication protocol. If the wire protocol changes (which happens very rarely) MySQL Proxy scripts would need to be changed as well.

Mysqlnd plugins work on top of the C API, which mirrors the libmysqlclient client. This C API is basically a wrapper around the MySQL Client Server protocol, or wire protocol, as it is sometimes called. You can intercept all C API calls. PHP makes use of the C API, therefore you can hook all PHP calls, without the need to program at the level of the wire protocol.

Mysqlnd implements the wire protocol. Plugins can therefore parse, reverse engineer, manipulate and even replace the communication protocol. However, this is usually not required.

As plugins allow you to create implementations that use two levels (C API and wire protocol), they have greater flexibility than MySQL Proxy. If a mysqlnd plugin is implemented using the C API, any subsequent changes to the wire protocol do not require changes to the plugin itself.


Obtaining the mysqlnd plugin API

The mysqlnd plugin API is simply part of the MySQL Native Driver PHP extension, ext/mysqlnd. Development started on the mysqlnd plugin API in December 2009. It is developed as part of the PHP source repository, and as such is available to the public either via Git, or through source snapshot downloads.

Plugin developers can determine the mysqlnd version through accessing MYSQLND_VERSION, which is a string of the format mysqlnd 5.0.7-dev - 091210 - $Revision: 300535, or through MYSQLND_VERSION_ID, which is an integer such as 50007. Developers can calculate the version number as follows:

MYSQLND_VERSION_ID calculation table
Version (part) | Example
Major*10000 | 5*10000 = 50000
Minor*100 | 0*100 = 0
Patch | 7 = 7
MYSQLND_VERSION_ID | 50007

During development, developers should refer to the mysqlnd version number for compatibility and version tests, as several iterations of mysqlnd could occur during the lifetime of a PHP development branch with a single PHP version number.


MySQL Native Driver Plugin Architecture

This section provides an overview of the mysqlnd plugin architecture.

MySQL Native Driver Overview

Before developing mysqlnd plugins, it is useful to know a little of how mysqlnd itself is organized. Mysqlnd consists of the following modules:

The mysqlnd organization chart, per module
Modules Statistics | mysqlnd_statistics.c
Connection | mysqlnd.c
Resultset | mysqlnd_result.c
Resultset Metadata | mysqlnd_result_meta.c
Statement | mysqlnd_ps.c
Network | mysqlnd_net.c
Wire protocol | mysqlnd_wireprotocol.c

C Object Oriented Paradigm

At the code level, mysqlnd uses a C pattern for implementing object orientation.

In C you use a struct to represent an object. Members of the struct represent object properties. Struct members pointing to functions represent methods.

Unlike with other languages such as C++ or Java, there are no fixed rules on inheritance in the C object oriented paradigm. However, there are some conventions that need to be followed that will be discussed later.

The PHP Life Cycle

When considering the PHP life cycle there are two basic cycles:

  • PHP engine startup and shutdown cycle

  • Request cycle

When the PHP engine starts up it will call the module initialization (MINIT) function of each registered extension. This allows each module to setup variables and allocate resources that will exist for the lifetime of the PHP engine process. When the PHP engine shuts down it will call the module shutdown (MSHUTDOWN) function of each extension.

During the lifetime of the PHP engine it will receive a number of requests. Each request constitutes another life cycle. On each request the PHP engine will call the request initialization function of each extension. The extension can perform any variable setup and resource allocation required for request processing. As the request cycle ends the engine calls the request shutdown (RSHUTDOWN) function of each extension so the extension can perform any cleanup required.

How a plugin works

A mysqlnd plugin works by intercepting calls made to mysqlnd by extensions that use mysqlnd. This is achieved by obtaining the mysqlnd function table, backing it up, and replacing it by a custom function table, which calls the functions of the plugin as required.

The following code shows how the mysqlnd function table is replaced:

/* a place to store original function table */
struct st_mysqlnd_conn_methods org_methods;

void minit_register_hooks(TSRMLS_D) {
  /* active function table */
  struct st_mysqlnd_conn_methods * current_methods
    = mysqlnd_conn_get_methods();

  /* backup original function table */
  memcpy(&org_methods, current_methods,
    sizeof(struct st_mysqlnd_conn_methods);

  /* install new methods */
  current_methods->query = MYSQLND_METHOD(my_conn_class, query);
}

Connection function table manipulations must be done during Module Initialization (MINIT). The function table is a global shared resource. In an multi-threaded environment, with a TSRM build, the manipulation of a global shared resource during the request processing will almost certainly result in conflicts.

Note:

Do not use any fixed-size logic when manipulating the mysqlnd function table: new methods may be added at the end of the function table. The function table may change at any time in the future.

Calling parent methods

If the original function table entries are backed up, it is still possible to call the original function table entries - the parent methods.

In some cases, such as for Connection::stmt_init(), it is vital to call the parent method prior to any other activity in the derived method.

MYSQLND_METHOD(my_conn_class, query)(MYSQLND *conn,
  const char *query, unsigned int query_len TSRMLS_DC) {

  php_printf("my_conn_class::query(query = %s)\n", query);

  query = "SELECT 'query rewritten' FROM DUAL";
  query_len = strlen(query);

  return org_methods.query(conn, query, query_len); /* return with call to parent */
}

Extending properties

A mysqlnd object is represented by a C struct. It is not possible to add a member to a C struct at run time. Users of mysqlnd objects cannot simply add properties to the objects.

Arbitrary data (properties) can be added to a mysqlnd objects using an appropriate function of the mysqlnd_plugin_get_plugin_<object>_data() family. When allocating an object mysqlnd reserves space at the end of the object to hold a void * pointer to arbitrary data. mysqlnd reserves space for one void * pointer per plugin.

The following table shows how to calculate the position of the pointer for a specific plugin:

Pointer calculations for mysqlnd
Memory address | Contents
0 | Beginning of the mysqlnd object C struct
n | End of the mysqlnd object C struct
n + (m x sizeof(void*)) | void* to object data of the m-th plugin

If you plan to subclass any of the mysqlnd object constructors, which is allowed, you must keep this in mind!

The following code shows extending properties:

/* any data we want to associate */
typedef struct my_conn_properties {
  unsigned long query_counter;
} MY_CONN_PROPERTIES;

/* plugin id */
unsigned int my_plugin_id;

void minit_register_hooks(TSRMLS_D) {
  /* obtain unique plugin ID */
  my_plugin_id = mysqlnd_plugin_register();
  /* snip - see Extending Connection: methods */
}

static MY_CONN_PROPERTIES** get_conn_properties(const MYSQLND *conn TSRMLS_DC) {
  MY_CONN_PROPERTIES** props;
  props = (MY_CONN_PROPERTIES**)mysqlnd_plugin_get_plugin_connection_data(
    conn, my_plugin_id);
  if (!props || !(*props)) {
    *props = mnd_pecalloc(1, sizeof(MY_CONN_PROPERTIES), conn->persistent);
    (*props)->query_counter = 0;
  }
  return props;
}

The plugin developer is responsible for the management of plugin data memory.

Use of the mysqlnd memory allocator is recommended for plugin data. These functions are named using the convention: mnd_*loc(). The mysqlnd allocator has some useful features, such as the ability to use a debug allocator in a non-debug build.

When and how to subclass
 | When to subclass? | Each instance has its own private function table? | How to subclass?
Connection (MYSQLND) | MINIT | No | mysqlnd_conn_get_methods()
Resultset (MYSQLND_RES) | MINIT or later | Yes | mysqlnd_result_get_methods() or object method function table manipulation
Resultset Meta (MYSQLND_RES_METADATA) | MINIT | No | mysqlnd_result_metadata_get_methods()
Statement (MYSQLND_STMT) | MINIT | No | mysqlnd_stmt_get_methods()
Network (MYSQLND_NET) | MINIT or later | Yes | mysqlnd_net_get_methods() or object method function table manipulation
Wire protocol (MYSQLND_PROTOCOL) | MINIT or later | Yes | mysqlnd_protocol_get_methods() or object method function table manipulation

You must not manipulate function tables at any time later than MINIT if it is not allowed according to the above table.

Some classes contain a pointer to the method function table. All instances of such a class will share the same function table. To avoid chaos, in particular in threaded environments, such function tables must only be manipulated during MINIT.

Other classes use copies of a globally shared function table. The class function table copy is created together with the object. Each object uses its own function table. This gives you two options: you can manipulate the default function table of an object at MINIT, and you can additionally refine methods of an object without impacting other instances of the same class.

The advantage of the shared function table approach is performance. There is no need to copy a function table for each and every object.

Constructor status
Type | Allocation, construction, reset | Can be modified? | Caller
Connection (MYSQLND) | mysqlnd_init() | No | mysqlnd_connect()
Resultset(MYSQLND_RES)

Allocation:

  • Connection::result_init()

Reset and re-initialized during:

  • Result::use_result()

  • Result::store_result

Yes, but call parent!

  • Connection::list_fields()

  • Statement::get_result()

  • Statement::prepare() (Metadata only)

  • Statement::resultMetaData()

Resultset Meta (MYSQLND_RES_METADATA) | Connection::result_meta_init() | Yes, but call parent! | Result::read_result_metadata()
Statement (MYSQLND_STMT) | Connection::stmt_init() | Yes, but call parent! | Connection::stmt_init()
Network (MYSQLND_NET) | mysqlnd_net_init() | No | Connection::init()
Wire protocol (MYSQLND_PROTOCOL) | mysqlnd_protocol_init() | No | Connection::init()

It is strongly recommended that you do not entirely replace a constructor. The constructors perform memory allocations. The memory allocations are vital for the mysqlnd plugin API and the object logic of mysqlnd. If you do not care about warnings and insist on hooking the constructors, you should at least call the parent constructor before doing anything in your constructor.

Regardless of all warnings, it can be useful to subclass constructors. Constructors are the perfect place for modifying the function tables of objects with non-shared object tables, such as Resultset, Network, Wire Protocol.

Destruction status
Type | Derived method must call parent? | Destructor
Connection | yes, after method execution | free_contents(), end_psession()
Resultset | yes, after method execution | free_result()
Resultset Meta | yes, after method execution | free()
Statement | yes, after method execution | dtor(), free_stmt_content()
Network | yes, after method execution | free()
Wire protocol | yes, after method execution | free()

The destructors are the appropriate place to free properties, mysqlnd_plugin_get_plugin_<object>_data().

The listed destructors may not be equivalent to the actual mysqlnd method freeing the object itself. However, they are the best possible place for you to hook in and free your plugin data. As with constructors you may replace the methods entirely but this is not recommended. If multiple methods are listed in the above table you will need to hook all of the listed methods and free your plugin data in whichever method is called first by mysqlnd.

The recommended method for plugins is to simply hook the methods, free your memory and call the parent implementation immediately following this.


The mysqlnd plugin API

The following is a list of functions provided in the mysqlnd plugin API:

  • mysqlnd_plugin_register()

  • mysqlnd_plugin_count()

  • mysqlnd_plugin_get_plugin_connection_data()

  • mysqlnd_plugin_get_plugin_result_data()

  • mysqlnd_plugin_get_plugin_stmt_data()

  • mysqlnd_plugin_get_plugin_net_data()

  • mysqlnd_plugin_get_plugin_protocol_data()

  • mysqlnd_conn_get_methods()

  • mysqlnd_result_get_methods()

  • mysqlnd_result_meta_get_methods()

  • mysqlnd_stmt_get_methods()

  • mysqlnd_net_get_methods()

  • mysqlnd_protocol_get_methods()

There is no formal definition of what a plugin is and how a plugin mechanism works.

Components often found in plugins mechanisms are:

  • A plugin manager

  • A plugin API

  • Application services (or modules)

  • Application service APIs (or module APIs)

The mysqlnd plugin concept employs these features, and additionally enjoys an open architecture.

No Restrictions

A plugin has full access to the inner workings of mysqlnd. There are no security limits or restrictions. Everything can be overwritten to implement friendly or hostile algorithms. It is recommended you only deploy plugins from a trusted source.

As discussed previously, plugins can use pointers freely. These pointers are not restricted in any way, and can point into another plugin's data. Simple offset arithmetic can be used to read another plugin's data.

It is recommended that you write cooperative plugins, and that you always call the parent method. The plugins should always cooperate with mysqlnd itself.

Issues: an example of chaining and cooperation
Extension | mysqlnd.query() pointer | call stack if calling parent
ext/mysqlnd | mysqlnd.query() | mysqlnd.query
ext/mysqlnd_cache mysqlnd_cache.query()

  1. mysqlnd_cache.query()

  2. mysqlnd.query

ext/mysqlnd_monitor mysqlnd_monitor.query()

  1. mysqlnd_monitor.query()

  2. mysqlnd_cache.query()

  3. mysqlnd.query

In this scenario, a cache (ext/mysqlnd_cache) and a monitor (ext/mysqlnd_monitor) plugin are loaded. Both subclass Connection::query(). Plugin registration happens at MINIT using the logic shown previously. PHP calls extensions in alphabetical order by default. Plugins are not aware of each other and do not set extension dependencies.

By default the plugins call the parent implementation of the query method in their derived version of the method.

PHP Extension Recap

This is a recap of what happens when using an example plugin, ext/mysqlnd_plugin, which exposes the mysqlnd C plugin API to PHP:

  • Any PHP MySQL application tries to establish a connection to 192.168.2.29

  • The PHP application will either use ext/mysql, ext/mysqli or PDO_MYSQL. All three PHP MySQL extensions use mysqlnd to establish the connection to 192.168.2.29.

  • Mysqlnd calls its connect method, which has been subclassed by ext/mysqlnd_plugin.

  • ext/mysqlnd_plugin calls the userspace hook proxy::connect() registered by the user.

  • The userspace hook changes the connection host IP from 192.168.2.29 to 127.0.0.1 and returns the connection established by parent::connect().

  • ext/mysqlnd_plugin performs the equivalent of parent::connect(127.0.0.1) by calling the original mysqlnd method for establishing a connection.

  • ext/mysqlnd establishes a connection and returns to ext/mysqlnd_plugin. ext/mysqlnd_plugin returns as well.

  • Whatever PHP MySQL extension had been used by the application, it receives a connection to 127.0.0.1. The PHP MySQL extension itself returns to the PHP application. The circle is closed.


Getting started building a mysqlnd plugin

It is important to remember that a mysqlnd plugin is itself a PHP extension.

The following code shows the basic structure of the MINIT function that will be used in the typical mysqlnd plugin:

/* my_php_mysqlnd_plugin.c */

 static PHP_MINIT_FUNCTION(mysqlnd_plugin) {
  /* globals, ini entries, resources, classes */

  /* register mysqlnd plugin */
  mysqlnd_plugin_id = mysqlnd_plugin_register();

  conn_m = mysqlnd_get_conn_methods();
  memcpy(org_conn_m, conn_m,
    sizeof(struct st_mysqlnd_conn_methods));

  conn_m->query = MYSQLND_METHOD(mysqlnd_plugin_conn, query);
  conn_m->connect = MYSQLND_METHOD(mysqlnd_plugin_conn, connect);
}

/* my_mysqlnd_plugin.c */

 enum_func_status MYSQLND_METHOD(mysqlnd_plugin_conn, query)(/* ... */) {
  /* ... */
}
enum_func_status MYSQLND_METHOD(mysqlnd_plugin_conn, connect)(/* ... */) {
  /* ... */
}

Task analysis: from C to userspace

 class proxy extends mysqlnd_plugin_connection {
  public function connect($host, ...) { .. }
}
mysqlnd_plugin_set_conn_proxy(new proxy());

Process:

  1. PHP: user registers plugin callback

  2. PHP: user calls any PHP MySQL API to connect to MySQL

  3. C: ext/*mysql* calls mysqlnd method

  4. C: mysqlnd ends up in ext/mysqlnd_plugin

  5. C: ext/mysqlnd_plugin

    1. Calls userspace callback

    2. Or original mysqlnd method, if userspace callback not set

You need to carry out the following:

  1. Write a class "mysqlnd_plugin_connection" in C

  2. Accept and register proxy object through "mysqlnd_plugin_set_conn_proxy()"

  3. Call userspace proxy methods from C (optimization - zend_interfaces.h)

Userspace object methods can either be called using call_user_function() or you can operate at a level closer to the Zend Engine and use zend_call_method().

Optimization: calling methods from C using zend_call_method

The following code snippet shows the prototype for the zend_call_method function, taken from zend_interfaces.h.

 ZEND_API zval* zend_call_method(
  zval **object_pp, zend_class_entry *obj_ce,
  zend_function **fn_proxy, char *function_name,
  int function_name_len, zval **retval_ptr_ptr,
  int param_count, zval* arg1, zval* arg2 TSRMLS_DC
);

Zend API supports only two arguments. You may need more, for example:

 enum_func_status (*func_mysqlnd_conn__connect)(
  MYSQLND *conn, const char *host,
  const char * user, const char * passwd,
  unsigned int passwd_len, const char * db,
  unsigned int db_len, unsigned int port,
  const char * socket, unsigned int mysql_flags TSRMLS_DC
);

To get around this problem you will need to make a copy of zend_call_method() and add a facility for additional parameters. You can do this by creating a set of MY_ZEND_CALL_METHOD_WRAPPER macros.

Calling PHP userspace

This code snippet shows the optimized method for calling a userspace function from C:

/* my_mysqlnd_plugin.c */

MYSQLND_METHOD(my_conn_class,connect)(
  MYSQLND *conn, const char *host /* ... */ TSRMLS_DC) {
  enum_func_status ret = FAIL;
  zval * global_user_conn_proxy = fetch_userspace_proxy();
  if (global_user_conn_proxy) {
    /* call userspace proxy */
    ret = MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, host, /*...*/);
  } else {
    /* or original mysqlnd method = do nothing, be transparent */
    ret = org_methods.connect(conn, host, user, passwd,
          passwd_len, db, db_len, port,
          socket, mysql_flags TSRMLS_CC);
  }
  return ret;
}

Calling userspace: simple arguments

/* my_mysqlnd_plugin.c */

 MYSQLND_METHOD(my_conn_class,connect)(
  /* ... */, const char *host, /* ...*/) {
  /* ... */
  if (global_user_conn_proxy) {
    /* ... */
    zval* zv_host;
    MAKE_STD_ZVAL(zv_host);
    ZVAL_STRING(zv_host, host, 1);
    MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, zv_retval, zv_host /*, ...*/);
    zval_ptr_dtor(&zv_host);
    /* ... */
  }
  /* ... */
}

Calling userspace: structs as arguments

/* my_mysqlnd_plugin.c */

MYSQLND_METHOD(my_conn_class, connect)(
  MYSQLND *conn, /* ...*/) {
  /* ... */
  if (global_user_conn_proxy) {
    /* ... */
    zval* zv_conn;
    ZEND_REGISTER_RESOURCE(zv_conn, (void *)conn, le_mysqlnd_plugin_conn);
    MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, zv_retval, zv_conn, zv_host /*, ...*/);
    zval_ptr_dtor(&zv_conn);
    /* ... */
  }
  /* ... */
}

The first argument of many mysqlnd methods is a C "object". For example, the first argument of the connect() method is a pointer to MYSQLND. The struct MYSQLND represents a mysqlnd connection object.

The mysqlnd connection object pointer can be compared to a standard I/O file handle. Like a standard I/O file handle a mysqlnd connection object shall be linked to the userspace using the PHP resource variable type.

From C to userspace and back

 class proxy extends mysqlnd_plugin_connection {
  public function connect($conn, $host, ...) {
    /* "pre" hook */
    printf("Connecting to host = '%s'\n", $host);
    debug_print_backtrace();
    return parent::connect($conn);
  }

  public function query($conn, $query) {
    /* "post" hook */
    $ret = parent::query($conn, $query);
    printf("Query = '%s'\n", $query);
    return $ret;
  }
}
mysqlnd_plugin_set_conn_proxy(new proxy());

PHP users must be able to call the parent implementation of an overwritten method.

As a result of subclassing it is possible to refine only selected methods and you can choose to have "pre" or "post" hooks.

Buildin class: mysqlnd_plugin_connection::connect()

/*  my_mysqlnd_plugin_classes.c */

 PHP_METHOD("mysqlnd_plugin_connection", connect) {
  /* ... simplified! ... */
  zval* mysqlnd_rsrc;
  MYSQLND* conn;
  char* host; int host_len;
  if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rs",
    &mysqlnd_rsrc, &host, &host_len) == FAILURE) {
    RETURN_NULL();
  }
  ZEND_FETCH_RESOURCE(conn, MYSQLND* conn, &mysqlnd_rsrc, -1,
    "Mysqlnd Connection", le_mysqlnd_plugin_conn);
  if (PASS == org_methods.connect(conn, host, /* simplified! */ TSRMLS_CC))
    RETVAL_TRUE;
  else
    RETVAL_FALSE;
}


Mysqlnd 主从复制和负载均衡插件

  • 简介
  • 快速入门与例子
    • Setup
    • Running statements
    • 连接状态
    • SQL Hints (SQL 优化器)
    • 事务
    • XA/Distributed Transactions
    • 服务级别和一致性
    • Global transaction IDs (GTID)
    • Cache integration
    • 故障转移
    • 分区和分片
    • MySQL Fabric
  • 概念
    • Architecture
    • 连接池与切换
    • 事务控制
    • 错误处理
    • 短错误
    • 错误处理
    • 负载均衡
    • Read-write splitting
    • Filter
    • Service level and consistency
    • Global transaction IDs
    • Cache integration
    • Supported clusters
    • XA/Distributed transactions
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • Plugin configuration file (>=1.1.x)
  • 预定义常量
  • Mysqlnd_ms 函数
    • mysqlnd_ms_dump_servers — Returns a list of currently configured servers
    • mysqlnd_ms_fabric_select_global — Switch to global sharding server for a given table
    • mysqlnd_ms_fabric_select_shard — Switch to shard
    • mysqlnd_ms_get_last_gtid — 返回最后的全局同步 ID (GTID)
    • mysqlnd_ms_get_last_used_connection — Returns an array which describes the last used connection
    • mysqlnd_ms_get_stats — Returns query distribution and connection statistics
    • mysqlnd_ms_match_wild — Finds whether a table name matches a wildcard pattern or not
    • mysqlnd_ms_query_is_select — 查询给定的 SQL 会发送给 master、slave 还是最后使用的 MySQL server 执行。
    • mysqlnd_ms_set_qos — Sets the quality of service needed from the cluster
    • mysqlnd_ms_set_user_pick_server — Sets a callback for user-defined read/write splitting
    • mysqlnd_ms_xa_begin — Starts a distributed/XA transaction among MySQL servers
    • mysqlnd_ms_xa_commit — Commits a distributed/XA transaction among MySQL servers
    • mysqlnd_ms_xa_gc — Garbage collects unfinished XA transactions after severe errors
    • mysqlnd_ms_xa_rollback — Rolls back a distributed/XA transaction among MySQL servers
  • Change History
    • PECL/mysqlnd_ms 1.6 series
    • PECL/mysqlnd_ms 1.5 series
    • PECL/mysqlnd_ms 1.4 series
    • PECL/mysqlnd_ms 1.3 series
    • PECL/mysqlnd_ms 1.2 series
    • PECL/mysqlnd_ms 1.1 series
    • PECL/mysqlnd_ms 1.0 series


简介

Mysql 主从复制和负载均衡插件 (mysqlnd_ms) 可以帮助我们很简单的支 持所有使用 mysqlnd 的 PHP MySQL 扩展。

自从 PHP 5.3.3 版本，MySQL native driver 以一个 C API 接口的方式存在。这个 C 插件， 可以通过 mysqlnd 完成对 MySQL 主从复制和负载均衡 的相关功能扩展。

从 PHP 5.3.0 以后，MySQL native driver 可以以 C 库的方式工作。它以插入的方式替代 MySQL Client 库 (libmysqlclient) 的作用。使用 mysqlnd 有几个好处: 不需要特别下载内容， 他已经被内置在 PHP 当中; 他基于 PHP 许可协议; 他会消耗更小的内存; 并且他包含很多新的 函数方法 (例如：异步查询).

Mysqlnd 插件 (例如 mysqlnd_ms) 都是从用户的使用要求中提炼出来. mysqlnd_ms 支持所有的 PHP 应用, 和所有的 MySQL PHP 扩展. 他并不改变现有的 APIs, 所以他可以很容易的在现有的 PHP 应用环境中使用.

Key Features

主要功能

  • 透明使用, 并且容易使用.

    • 支持所有的 PHP MySQL 扩展

    • 支持 SSL

    • 一致的 API 接口

    • 只需要很小的基于使用需要的方案设定

    • 被动连接，只有实际的 SQL 执行时，才会与 Master 和 Slaver 进行连接

    • 可选：从 Web request 的第一个写以后自动使用 Master, 降低可能的主从复制的延时影响

  • 可以在 MySQL Cluster 中使用

    • MySQL Replication: 实现读写分离, 插件主要为 MySQL Replication 编写

    • MySQL Cluster: 可以禁用读写分离, 可以使用多个 Master

    • 第三方解决方案: 插件为 MySQL Replication 定制开发, 但是也可以适用于其他的 MySQL Cluster 解决方案

  • 读写分离策略

    • 自动检测 SELECT 语句

    • Supports SQL hints to overrule automatism.

    • 用户自定义

    • 可以被禁用，例如在使用同步 Cluster 时

  • 负载均衡策略

    • Round Robin: 针对每一个 slave 查询，使用不同的 slave，轮循方式

    • Random: 随机选择 slave

    • Random once (sticky): 随机选取一个 slave, 在这个页面的请求过程中, 都是用这个 slave

    • User-defined: 应用可以在 mysqlnd_ms 中注册一个 callback

    • 从 PHP 5.4.0 以后版本，事务可以通过事务控制的 API 调用进行处理。

    • Weighted load balancing: Slave 可以被分配不同的优先级, 例如; 可以让更多的查询在一个更好的设备上执行, 或者在一个更近的设备查询以降低延时影响

  • Global transaction ID

    • Client-side emulation. Makes manual master server failover and slave promotion easier with asynchronous clusters, such as MySQL Replication.

    • 支持 MySQL 5.6.5 以上版本内置的 GTID.

    • 在 Session 一致性策略下，可以通过 GTID 完成异步 slave 读取最新的数据。

    • Throttling: optionally, the plugin can wait for a slave to become "synchronous" before continuing.

  • 服务和一致性级别

    • 应用可以在连接中选择：最终、session 和强一致性服务级别。最合适的通讯节点 将自动进行选择。

    • 最终一致性时，MySQL 主从同步的 slave 可以被本地 cache 替换，用于降低服务器负载。

  • 分区和共享

    • 数据库群组中的服务器，可以被定义到组中，利用 SQL hints 可以手动的指定在特定的组中进行查询。 组可以完成数据分区，或者完成数据热点的更新。

    • MySQL 主从同步过滤可以通过表过滤器支持。

限制

内置的读写分离机制非常基础, 任何一个以 SELECT 开头的查询, 都被认为是读操作, 从而发送给 slave 服务器. 所有其他的查询 (包括 SHOW) 都会被认为是写操作， 而被发送给 master 服务器. 内置的操作方法可以通过重写 SQL hints 改变, 或者使用一个用户定义的 callback 实现.

读写分离不能提供对于多查询的结构支持, 多查询结果会被认为是一个单一查询. 通过开头的字符串来决定如何执行这些查询. 例如, 如果使用 mysqli_multi_query() 执行多查询 SELECT id FROM test; INSERT INTO test(id) VALUES (1) 将会被认为是一个查询操作， 而被发送给 slave 服务器, 以为他开头使用了 SELECT. 其中的 INSERT 结构，将不会被发送给 master 服务器.

Note:

应用必须知道连接切换的重要性, 他是负载均衡的墓地. 可以查看相关说明: connection pooling and switching, transaction handling, failover load balancing 和 read-write splitting.

On the name

The shortcut mysqlnd_ms stands for mysqlnd master slave plugin. The name was chosen for a quick-and-dirty proof-of-concept. In the beginning the developers did not expect to continue using the code base.


快速入门与例子

Table of Contents

  • Setup
  • Running statements
  • 连接状态
  • SQL Hints (SQL 优化器)
  • 事务
  • XA/Distributed Transactions
  • 服务级别和一致性
  • Global transaction IDs (GTID)
  • Cache integration
  • 故障转移
  • 分区和分片
  • MySQL Fabric

mysqlnd 是非常容易使用的 MySQL 主从复制负载均衡插件。 这里会给出用户使用的典型例子，并会提供开始使用的实用建议。

我们强烈建议您阅读相关在 Quickstart 中的相关章节。这里可以避免在理论、 概念和限制等方便的混淆。我们力劝您一定要阅读相关说明章节中的背景信息， 以避免在实际使用过程中遇到严重的问题。

焦点是将 PECL mysqlnd_ms 用于异步的 MySQL Cluster，也就是 MySQL replication (MySQL 主从复制)。一般来说，使用主从复制要比同步的 MySQL Cluster 要复杂，难用。所以这里能够为使用 MySQL Cluster 的用户提供更多的信息。


Setup

插件是一个 PHP 的扩展, 可以查看 installation instructions 学习如何安装 » PECL/mysqlnd_ms 扩展。

编译或配置 PHP MySQL 扩展 (API) (mysqli、 PDO_MYSQL、 mysql)，也就是你打算使用的、支持 mysqlnd 的库。 PECL/mysqlnd_ms 是一个 mysqlnd 库的插件。使用任意 PHP MySQL 扩展时，要使用 mysqlnd 必须使用该插件。

然后，使用 mysqlnd_ms.enable 在 PHP 配置文件中装载和激活插件。

Example #1 启用插件(php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini

插件使用他自己的配置文件。使用 PHP 指令 mysqlnd_ms.config_file 定义插件配置文件的完整路径。 该文件必须能被 PHP 读取(比如 web 服务器的用户)。 请注意，从 1.4.0 版本开始配置文件变量使用 mysqlnd_ms.config_file, 以前的 mysqlnd_ms.ini_file 不再使用。 使用旧的、不再有效的指令是一个很常见的错误。

在 mysqlnd_ms.config_file 指定的目录中，创建保存插件的配置文件。

插件的 配置文件 基于 JSON 格式。 配置写在一个或者多个章节中。每个章节都包含一个名称，例如： myapp。 每个章节包含自己的配置信息。

一个章节的配置中，至少要包含 MySQL 主从复制中的 master 服务器和相关 slave 服务器。 每个章节只能使用一个 master 服务器。 目前还不能完全支持多 master(Multi-master)的设置。 master 用于设定 MySQL master 服务器的 hostname、port 或 socket。 而 MySQL slave 服务器信息使用 slave 来设定。

Example #2 最基本的插件配置文件 (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": [

        ]
    }
}

必须配置 MySQL slave 服务器列表，当然它也可以是空的列表。我们建议至少配置一个 slave 服务器。

服务器列表可以使用 匿名或者非匿名语法。 非匿名列表包含一个别名，例如 master_0 可用于上面的例子。 在这里，将使用更详细的非匿名语法。

Example #3 建议最基本的插件配置文件 (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

如果这里至少有两个服务器，插件可以负载均衡、切换连接。切换链接并不总是透明的，在某些具体条件下会导致问题。本参考中包含 连接池和切换， 事务处理， 故障转移 负载均衡 和 读写分离。稍后在本指南中将具体描述更多潜在的陷阱。

应用需要处理连接切换过程中潜在的问题，配置一个 master 和至少一个 slave，这样就可以切换，因此能发现相关问题。

MySQL 主从同步并不需要你配置 master 和 slave。 为了测试的目的，你可以使用单个 MySQL 服务器，让插件认为是 master 和 slave 服务器，就像以下的设置。这样可以帮助你在连接切换中检测到很多潜在问题。 不过，这样的设置不容易发生因为主从同步延迟而导致的问题。

Example #4 使用一个服务器同时作为 master 和 slave（仅用于测试！）

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

插件将尝试通知你不合理的配置. 从 1.5.0 版本开始, 下列情况它抛出一个 PHP warning, 配置文件不可读; 空配置或者 JSON 配置语法错误. 通过 PHP 本身的配置，可能这些报警信息 会被放置在某些错误 LOG 文件当中。在验证完毕后，通过配置文件中有效的章节，连接会被建立。 设置 mysqlnd_ms.force_config_usage 可以帮助你进行 DEBUG。可以参考 配置文件 DEBUG 说明.


Running statements

这个插件可以配合 (mysqli, mysql, 和 PDO_MYSQL) 使用, 他们都是基于 mysqlnd library 工作的。 PECL/mysqlnd_ms 插件是 mysqlnd library 的一部分, 他并不改变这些扩展的 API 或者行为。

当 MySQL 链接打开的时候，插件会在配置文件中根据章节设定匹配 host 参数。 例如，插件配置文件中指定 myapp，那么可以使用 myapp 作为 host 打开 MySQL 链接。

Example #1 插件指定的配置文件 (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Example #2 开启一个负载均衡链接

<?php
/* 根据配置针对 myapp 开启一个负载均衡的链接 */
$mysqli = new mysqli("myapp", "username", "password", "database");
$pdo = new PDO('mysql:host=myapp;dbname=database', 'username', 'password');
$mysql = mysql_connect("myapp", "username", "password");
?>

上面的连接范例是负载均衡方式的。插件将发送只读查询给 192.168.2.27 端口 3306。其他的所有查询，将发送给 localhost 指定的 master 服务器。在 Linux 设备中， /tmp/mysql.sock 指定了本机的 MySQL 服务；在 Windows 系统中将使用默认的 TCP/IP 通讯。 插件将使用 username 和 password 连接任何一个 在 myapp 章节中指定的数据库。在连接以后，将选择 database 设定的数据库作为当前操作数据库。

username, password 和默认数据库将在所有设定的数据库中做统一设定。 换句话说，就是所有的数据库必须使用同样的用户名口令登录。 从 1.1.0 版本以后，这个限制将不再存在，可以针对任何一个服务器通过 username 和 password 进行登录鉴权设定。

插件在不改变查询结构的基础上，提供 读写分离。 下面的范例假定 master 和 slave 之间并没有很大的延迟。

Example #3 Executing statements

<?php
/* myapp 负载均衡设定 */
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 查询将在 master 上运行 */
if (!$mysqli->query("DROP TABLE IF EXISTS test")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
if (!$mysqli->query("CREATE TABLE test(id INT)")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
if (!$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* 只读查询将在 slave 上运行 */
if (!($res = $mysqli->query("SELECT id FROM test")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
 $row = $res->fetch_assoc();
 $res->close();
 printf("Slave returns id = '%s'\n", $row['id'];
}
$mysqli->close();
?>

以上例程的输出类似于：

Slave returns id = '1'


连接状态

插件改变了 PHP MySQL 连接的控制，新建连接会从一个连接池中获取，用于替代 client-server 的单一连接方式。连接池包含一组 master 连接，和可选数目的 slave 连接。

连接池中的每一个连接都有自己的状态，例如：SQL 用户变量、临时表、事物状态。 所有的链接状态可以参考 连接池与切换 说明。 如果插件决定要为负载均衡切换连接，应用可能得到一个不同状态的链接。 应用必须能够处理这些问题。

Example #1 配置了一个 master 和一个 slave 的插件

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Example #2 陷阱：连接状态和 SQL 用户变量

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 链接 1：绑定 SQL 用户变量，因为没有 SELECT 所以在 master 上执行 */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* 连接 2：因为有 SELECT 所以在 slave 上执行 */
if (!($res = $mysqli->query("SELECT @myrole AS _role"))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
 $row = $res->fetch_assoc();
 $res->close();
 printf("@myrole = '%s'\n", $row['_role']);
}
$mysqli->close();
?>

以上例程会输出：

@myrole = ''

范例打开了负载均衡连接，并且执行两个查询。 第一个查询 SET @myrole='master' 没有以 SELECT 开头。然而并不能识别这是一个应该在 slave 中执行的查询，所以他被在 master 中执行。 所以这个变量被绑定在 master 连接中，master 连接设定被改变了。

然后执行 SELECT @myrole AS _role 查询，差将将其识别为只读查询， 并且发送给 slave 服务器。这样这个查询不会获得任何已经设定的 SQL 用户变量。 这个变量被设定在了第一次使用的 master 连接上面。所以范例将打印 @myrole = ''。

这是开发人员必须注意的问题，插件并不会监控所有连接的变化情况。 若要监控所有的变化，将消耗大量的 CPU 资源。

当然这种陷阱，可以通过 SQL hints 解决。


SQL Hints (SQL 优化器)

SQL 优化器可以强行指定连接池中特定的链接。可以给定插件一个优化器去使用特定的服务器连接， 这样可以解决由于链接切换引起的链接状态变化问题。

SQL hints 是基于 SQL 语句的。因为 SQL 注释会被 SQL 执行器忽略， 他并不会妨碍 MySQL 服务器、MySQL proxy 或者任何防火墙的工作。

插件支持 SQL hints，MYSQLND_MS_MASTER_SWITCH hints 可以指定语句在 master 上运行，MYSQLND_MS_SLAVE_SWITCH 可以指定在 slave 上运行，MYSQLND_MS_LAST_USED_SWITCH 可以指定语句在上一条语句执行的 slave 上运行。

插件会扫描语句的内容，查询是否有 SQL hints。他只能在语句的开头被识别。

Example #1 配置一个 master 和一个 slave 的插件

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Example #2 SQL hints 禁止连接切换

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 连接 1：设置一个 SQL 用户变量，没有 SELECT 所以运行在 master 上 */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* 连接 1：因为指定了 SQL hint */
if (!($res = $mysqli->query(sprintf("/*%s*/SELECT @myrole AS _role", MYSQLND_MS_LAST_USED_SWITCH)))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
 $row = $res->fetch_assoc();
 $res->close();
 printf("@myrole = '%s'\n", $row['_role']);
}
$mysqli->close();
?>

以上例程会输出：

@myrole = 'master'

上面的范例使用 MYSQLND_MS_LASTER_USED_SWITCH 来防止在 master 和 slave 之间进行切换，即使运行了 SELECT 开头的语句。

SQL hints 也可以用于在 master 上运行 SELECT 语句。 这经常发生于 slave 中的数据落后于 master，但是希望获取当前数据的时候。

在 1.2.0 版本中，引入了服务级别的概念，用于处理即时数据获取的问题。 使用服务级别，可以降低对这个问题的关注，替代 SQL hints 的使用。 可以在服务级别和一致性的章节中找到更多的说明。

Example #3 与同步延迟斗争

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Force use of master, master has always fresh and current data */
if (!$mysqli->query(sprintf("/*%s*/SELECT critical_data FROM important_table", MYSQLND_MS_MASTER_SWITCH))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
?>

在使用中，slave 中应该有同样的表单。当没有给定 SQL hints 的时候，插件在发送 CREATE INSERT 语句到 master 服务器。 可以通过设定 MYSQLND_MS_SLAVE_SWITCH 来让这些语句在 slave 中运行。例如建立一个临时表单：

Example #4 Table creation on a slave

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 强迫在 slave 运行 */
if (!$mysqli->query(sprintf("/*%s*/CREATE TABLE slave_reporting(id INT)", MYSQLND_MS_SLAVE_SWITCH))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
/* 使用刚刚使用的 slave 连接 */
if (!$mysqli->query(sprintf("/*%s*/INSERT INTO slave_reporting(id) VALUES (1), (2), (3)", MYSQLND_MS_LAST_USED_SWITCH))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
/* 不使用 MYSQLND_MS_SLAVE_SWITCH 将会切换到另外一台 slave */
if ($res = $mysqli->query(sprintf("/*%s*/SELECT COUNT(*) AS _num FROM slave_reporting", MYSQLND_MS_LAST_USED_SWITCH))) {
  $row = $res->fetch_assoc();
  $res->close();
  printf("There are %d rows in the table 'slave_reporting'", $row['_num']);
} else {
  printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
$mysqli->close();
?>

SQL hint MYSQLND_MS_LAST_USED 禁止切换连接， 他将使用上一次使用的链接。


事务

当前版本的插件并不是事务安全的，因为他并没有识别全部的事务操作。 SQL 事务单元是在单一服务器中运行的。插件并不能有效的知道事务单元 何时开始，何时终止。所以，在事务单元中，可能数据库连接会被切换。

如果应用没有设定事务单元编辑，那么没有任何 MySQL 负载均衡能够检测他。

可以通过 SQL hints 来解除这个限制。可以选择性的调用事务 API 进行监控， 然后嗲用 API 执行控制事务。下面给出范例：

Example #1 配置一个 master 和一个 slave 的插件

[myapp]
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Example #2 在事务中使用 SQL hints

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 不是 SELECT 开头，所以使用 master */
if (!$mysqli->query("START TRANSACTION")) {
 /* Please use better error handling in your code */
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* 禁止连接切换*/
if (!$mysqli->query(sprintf("/*%s*/INSERT INTO test(id) VALUES (1)", MYSQLND_MS_LAST_USED_SWITCH)))) {
 /* Please do proper ROLLBACK in your code, don't just die */
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if ($res = $mysqli->query(sprintf("/*%s*/SELECT COUNT(*) AS _num FROM test", MYSQLND_MS_LAST_USED_SWITCH)))) {
  $row = $res->fetch_assoc();
  $res->close();
  if ($row['_num'] > 1000) {
   if (!$mysqli->query(sprintf("/*%s*/INSERT INTO events(task) VALUES ('cleanup')", MYSQLND_MS_LAST_USED_SWITCH)))) {
     die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
   }
  }
} else {
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query(sprintf("/*%s*/UPDATE log SET last_update = NOW()", MYSQLND_MS_LAST_USED_SWITCH)))) {
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query(sprintf("/*%s*/COMMIT", MYSQLND_MS_LAST_USED_SWITCH)))) {
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

$mysqli->close();
?>

自从 PHP 5.4.0 版本开始，mysqlnd library 允许插件监控 autocommit 模式下的状态，例如调用 SET AUTOCOMMIT=0 这样的语句，这将让插件开始关心事务处理。这样你就可以不用使用 SQl hints。

从 PHP 5.4.0 版本开始，调用 API autocommit 模式，插件设定中有 trx_stickiness=master， 那么插件将在事务中自动禁止负载均衡和连接切换。在 autocommit 禁用的配置当中， 插件将在事务过程中将所有的语句发送给 master，禁用负载均衡。当 autocommit 重新启用以后，插件将重新开始负载均衡所有的语句。

在 PHP 5.5.0 和 PECL/mysqlnd_ms 1.5.0 版本后，这种检查将不仅仅检查 mysqli_autocommit() 还会检查 mysql_commit() 和 mysql_rollback()。

Example #3 事务相关负载均衡下的 trx_stickiness 设置

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "trx_stickiness": "master"
    }
}

Example #4 Transaction aware

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 禁用 autocommit，插件将所有语句发送给 master */
$mysqli->autocommit(FALSE);

if (!$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
 /* Please do proper ROLLBACK in your code, don't just die */
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if ($res = $mysqli->query("SELECT COUNT(*) AS _num FROM test")) {
  $row = $res->fetch_assoc();
  $res->close();
  if ($row['_num'] > 1000) {
   if (!$mysqli->query("INSERT INTO events(task) VALUES ('cleanup')")) {
     die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
   }
  }
} else {
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query("UPDATE log SET last_update = NOW()")) {
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->commit()) {
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* 插件判定事务终止，重新启用负载均衡 */
$mysqli->autocommit(TRUE);
$mysqli->close();
?>

Note: 版本需求

trx_stickiness=master 参数需要 PHP 5.4.0 以上版本。

可以参考相关限制在 transaction handling 章节中。


XA/Distributed Transactions

Note: Version requirement

XA related functions have been introduced in PECL mysqlnd_ms version 1.6.0-alpha.

Note: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

XA transactions are a standardized method for executing transactions across multiple resources. Those resources can be databases or other transactional systems. The MySQL server supports XA SQL statements which allows users to carry out a distributed SQL transaction that spawns multiple database servers or any kind as long as they support the SQL statements too. In such a scenario it is in the responsibility of the user to coordinate the participating servers.

PECL/mysqlnd_ms can act as a transaction coordinator for a global (distributed, XA) transaction carried out on MySQL servers only. As a transaction coordinator, the plugin tracks all servers involved in a global transaction and transparently issues appropriate SQL statements on the participants. The global transactions are controlled with mysqlnd_ms_xa_begin(), mysqlnd_ms_xa_commit() and mysqlnd_ms_xa_rollback(). SQL details are mostly hidden from the application as is the need to track and coordinate participants.

Example #1 General pattern for XA transactions

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* start a global transaction */
$gtrid_id = "12345";
if (!mysqlnd_ms_xa_begin($mysqli, $gtrid_id)) {
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* run queries as usual: XA BEGIN will be injected upon running a query */
if (!$mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')")) {
   /* Either INSERT failed or the injected XA BEGIN failed */
  if ('XA' == substr($mysqli->sqlstate, 0, 2)) {
    printf("Global transaction/XA related failure, [%d] %s\n", $mysqli->errno, $mysqli->error);
  } else {
    printf("INSERT failed, [%d] %s\n", $mysqli->errno, $mysqli->error);
  }
  /* rollback global transaction */
  mysqlnd_ms_xa_rollback($mysqli, $xid);
  die("Stopping.");
}

/* continue carrying out queries on other servers, e.g. other shards */

/* commit the global transaction */
if (!mysqlnd_ms_xa_commit($mysqli, $xa_id)) {
  printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
?>

Unlike with local transactions, which are carried out on a single server, XA transactions have an identifier (xid) associated with them. The XA transaction identifier is composed of a global transaction identifier (gtrid), a branch qualifier (bqual) a format identifier (formatID). Only the global transaction identifier can and must be given when calling any of the plugins XA functions.

Once a global transaction has been started, the plugin begins tracking servers until the global transaction ends. When a server is picked for query execution, the plugin injects the SQL statement XA BEGIN prior to executing the actual SQL statement on the server. XA BEGIN makes the server participate in the global transaction. If the injected SQL statement fails, the plugin will report the issue in reply to the query execution function that was used. In the above example, $mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')") would indicate such an error. You may want to check the errors SQL state code to determine whether the actual query (here: INSERT) has failed or the error is related to the global transaction. It is up to you to ignore the failure to start the global transaction on a server and continue execution without having the server participate in the global transaction.

Example #2 Local and global transactions are mutually exclusive

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* start a local transaction */
if (!$mysqli->begin_transaction())
  die(sprintf("[%d/%s] %s\n", $mysqli->errno, $mysqli->sqlstate, $mysqli->error));

/* cannot start global transaction now - must end local transaction first */
$gtrid_id = "12345";
if (!mysqlnd_ms_xa_begin($mysqli, $gtrid_id)) {
  die(sprintf("[%d/%s] %s\n", $mysqli->errno, $mysqli->sqlstate, $mysqli->error));
}
?>

以上例程会输出：

Warning: mysqlnd_ms_xa_begin(): (mysqlnd_ms) Some work is done outside global transaction. You must end the active local transaction first in ... on line ...
[1400/XAE09] (mysqlnd_ms) Some work is done outside global transaction. You must end the active local transaction first

A global transaction cannot be started when a local transaction is active. The plugin tries to detect this situation as early as possible, that is when mysqlnd_ms_xa_begin() is called. If using API calls only to control transactions, the plugin will know that a local transaction is open and return an error for mysqlnd_ms_xa_begin(). However, note the plugins limitations on detecting transaction boundaries.. In the worst case, if using direct SQL for local transactions (BEGIN, COMMIT, ...), it may happen that an error is delayed until some SQL is executed on a server.

To end a global transaction invoke mysqlnd_ms_xa_commit() or mysqlnd_ms_xa_rollback(). When a global transaction is ended all participants must be informed of the end. Therefore, PECL/mysqlnd_ms transparently issues appropriate XA related SQL statements on some or all of them. Any failure during this phase will cause an implicit rollback. The XA related API is intentionally kept simple here. A more complex API that gave more control would bare few, if any, advantages over a user implementation that issues all lower level XA SQL statements itself.

XA transactions use the two-phase commit protocol. The two-phase commit protocol is a blocking protocol. There are cases when no progress can be made, not even when using timeouts. Transaction coordinators should survive their own failure, be able to detect blockades and break ties. PECL/mysqlnd_ms takes the role of a transaction coordinator and can be configured to survive its own crash to avoid issues with blocked MySQL servers. Therefore, the plugin can and should be configured to use a persistent and crash-safe state to allow garbage collection of unfinished, aborted global transactions. A global transaction can be aborted in an open state if either the plugin fails (crashes) or a connection from the plugin to a global transaction participant fails.

Example #3 Transaction coordinator state store

{
    "myapp": {
        "xa": {
            "state_store": {
                "participant_localhost_ip": "192.168.2.12",
                "mysql": {
                    "host": "192.168.2.13",
                    "user": "root",
                    "password": "",
                    "db": "test",
                    "port": "3312",
                    "socket": null
                }
            }
        },
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.14",
                "port": "3306"
            }
        }
    }
}

Currently, PECL/mysqlnd_ms supports only using MySQL database tables as a state store. The SQL definitions of the tables are given in the plugin configuration section. Please, make sure to use a transactional and crash-safe storage engine for the tables, such as InnoDB. InnoDB is the default table engine in recent versions of the MySQL server. Make also sure the database server itself is higly available.

If a state store has been configured, the plugin can perform a garbage collection. During garbage collection it may be necessary to connect to a participant of a failed global transaction. Thus, the state store holds a list of participants and, among others, their host names. If the garbage collection is run on another host but the one that has written a participant entry with the host name localhost, then localhost resolves to different machines. There are two solutions to the problem. Either you do not configure any servers with the host name localhost but configure an IP address (and port) or, you hint the garbage collection. In the above example, localhost is used for master_0, hence it may not resolve to the correct host during garbage collection. However, participant_localhost_ip is also set to hint the garbage collection that localhost stands for the IP 192.168.2.12.


服务级别和一致性

Note: 版本需求

服务级别是从 1.2.0-alpha版本引入的，mysqlnd_ms_set_qos() 从 PHP 5.4.0 版本开始可以使用。

不同类型的 MySQL 群组提供了，不同的服务和数据一致性级别。异步的 MySQL 主从同步 提供最终的数据一致性，一个读操作是否能够得到当前的数据、状态，一类与 slave 是否已经从 master 获取了最后的更新。

使用 MySQL 主从同步依赖于网络的有效性，最终会获得数据的一致性。然而， 状态数据是不能同步的。这样，只有指定的 slave 或者 master 连接才能得到所有内容。

从 1.2.0 版本开始，插件能够自动的进行 MySQL 主从同步的节点，来完成 session 一致性 或者完成很强的一致性要求。session 一致性是指一个客户端可以读取他的写入内容， 其他客户端可能不能看到他的写入内容。很强的一致性要求是指所有客户端都能够看到 其他所有客户端的写入内容。

Example #1 session 一致性：读取写入内容

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

Example #2 Requesting session consistency

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 使用 master 完成读写分离 */
if (!$mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')")) {
   /* Please use better error handling in your code */
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* 要求 session 一致性，读取写入内容 */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* 插件选择一个改变数据的节点，这里是 master */
if (!$res = $mysqli->query("SELECT item FROM orders WHERE order_id = 1"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

var_dump($res->fetch_assoc());

/* 返回到最终数据一致性状态，允许陈旧数据 */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* 插件选择任何一个 slaver 完成允许陈旧数据的读取 */
if (!$res = $mysqli->query("SELECT item, price FROM specials"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
?>

服务级别可以被写在插件的配置文件中，也可以在运行时使用 mysqlnd_ms_set_qos() 设定。 在范例中，使用这个函数强制 session 一致性，直到再次通知改变。 orders 表单中的 SELECT 语句在前面写入使用的 连接中执行。读写分离逻辑被服务级别策略改变。

在从 orders 表单读取数据以后，恢复到默认的服务级别 (最终数据一致性)。 这时，语句执行选择的服务器将不再被限制，因而在 specials 表单上做的 SELECT 查询将在一个 slave 服务器中进行。

一个新的替代 SQL hint的功能，master_on_write 配置设定。 在绝大部分情况下 mysqlnd_ms_set_qos() 更容易使用， 使用它移植性更好。

Example #3 Maximum age/slave lag

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "failover" : "master"
    }
}

Example #4 限制 slave 延迟

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 若 slave 延迟不超过 4 秒，则从 Slave 读取 */
$ret = mysqlnd_ms_set_qos($mysqli,
         MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL,
         MYSQLND_MS_QOS_OPTION_AGE, 4);

if (!$ret)
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* 选择一个 slave，他可能没有改变 */
if (!$res = $mysqli->query("SELECT item, price FROM daytrade"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* 恢复默认状态，使用所有的 slave 和 master */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
?>

最终一致性服务级别可以使用一个可选的参数设定最大允许的延迟，用于选择 slave。 如果设定这个值，插件会检查所有 slave 的 SHOW SLAVE STATUS。 在范例中，只有满足 Slave_IO_Running=Yes, Slave_SQL_Running=Yes 和 Seconds_Behind_Master <= 4 的 slave 会被执行语句 SELECT item, price FROM daytrade。

在应用运行时，会透明的执行 SHOW SLAVE STATUS 命令。 任何错误会以 warning 的方式报警，但是错误信息不会被保存在连接中。 即使所有的 SHOW SLAVE STATUS 都失败了，用户的执行请求也不会被终止， 给定的 master 作为最后的选择。然而应用不需要做任何调整。

Note: 耗时和缓慢的操作

在任何程序的开始，对所有的 slave 进行 SHOW SLAVE STATUS 查询，是一个非常耗时和缓慢的操作。不要经常这样操作。MySQL 主从同步集群并没有 提供一个客户端从一个中心控制器获取备选方案的能力。 然而，没有更多有效的方式获取 slave 延迟。

请注意，关于 SHOW SLAVE STATUS 的各种限制和参数说明， 请参考 MySQl 的参考手册。

若要禁止插件，在没有找到满足延迟条件的 slave 时产生报警，需要在配置文件 当中设定 master 作为故障处理。如果没有 slave 满足条件，那么故障处理开始启动， 插件会使用 master 去执行语句。

如果没有 slave 满足条件，并且没有启动故障处理，插件将会报警。 这时，语句不会被执行，并且错误信息会被写入连接当中。

Example #5 不设置故障处理

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

Example #6 No slave within time limit

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 若 slave 延迟不超过 4 秒，则从 slave 执行 */
$ret = mysqlnd_ms_set_qos($mysqli,
         MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL,
         MYSQLND_MS_QOS_OPTION_AGE, 4);

if (!$ret)
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Plugin picks any slave, which may or may not have the changes */
if (!$res = $mysqli->query("SELECT item, price FROM daytrade"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Back to default: use of all slaves and masters permitted */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
?>

以上例程会输出：

PHP Warning:  mysqli::query(): (mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. Something is wrong in %s on line %d
PHP Warning:  mysqli::query(): (mysqlnd_ms) No connection selected by the last filter in %s on line %d
[2000] (mysqlnd_ms) No connection selected by the last filter


Global transaction IDs (GTID)

Note: 版本需求

从 1.2.0-alpha 版本开始客户端 GTID 可以使用，这个功能并不需要在同步集群中使用， 例如 MySQL Cluster。他用于异步集群，例如 MySQL 主从同步。

从 MySQL 5.6.5-m8 版本开始，MySQL 使用内置的 GTID，这需要 1.3.0-alpha 以后版本支持。

PECL/mysqlnd_ms 可以使用自己的 GTID 仿真，或者使用 MySQL 内置的 GTID。无论使用哪种方式， 对于使用服务级别来说都是一样的。他们的区别，在 concepts section 进行说明。

这里先使用插件内部的 GTID 模拟来展示如何使用服务端的副本。

概念和客户端模拟

GTID 是 slave 需要同步的 table 在 master 上基于这个 table 的一个计数器，每当事务提交他都会增加。 这个计数器有两个作用，如果 master 产生故障，他帮助数据库管理员确定使用最新的 slave 来 恢复新的 master。最新的 slave 就是那个数值最高的。应用可以使用 GTID 查询某一次写入， 是否已经在 slave 被同步。

插件可以在每次提交事务的时候，增加 GTID。当然这个 GTID 也可以让应用判断写操作是否同步。 这样就可以实现在 session 一致性服务级别中，不一定从 master 读取数据，也可以从已经同步 的 slave 中获取数据，从而减轻 master 的读负载。

客户端 GTID 模拟有一些限制，可以参考 concepts section 说明。在生产换金钟使用前，请细致全面的理解他的工作原理和概念。相关背景的支持， 不在本参考中进行说明。

首先在 master 建立一个计数器表，并且插入一条记录。插件并不会帮助你建立这个表， 数据库管理员需要帮助你操作。如果表不存在或者有问题，基于错误报告机制， 你可能得不到任何错误信息。

Example #1 在 master 创建计数器表

CREATE TABLE `trx` (
  `trx_id` int(11) DEFAULT NULL,
  `last_update` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP
) ENGINE=InnoDB DEFAULT CHARSET=latin1
INSERT INTO `trx`(`trx_id`) VALUES (1);

在插件的配置文件中，需要在 global_transaction_id_injection 章节中设定 on_commit 参数。一定要确认在 UPDATE 中使用的表明是可达的，例如：使用上一步创建的表， test.trx 要比 trx 更合适。 这一点非常重要，因为不同的数据库连接，可能的默认数据库选择并不相同。 并且确认，使用连接的用户，有权限对这个表执行 UPDATE 命令。

当 GTID 更新时，打开错误报告。

Example #2 Plugin config: SQL for client-side GTID injection

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "report_error":true
        }
    }
}

Example #3 Transparent global transaction ID injection

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("DROP TABLE IF EXISTS test"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("CREATE TABLE test(id INT)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("INSERT INTO test(id) VALUES (1)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* auto commit mode, read on slave, no increment */
if (!($res = $mysqli->query("SELECT id FROM test")))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

var_dump($res->fetch_assoc());
?>

以上例程会输出：

array(1) {
  ["id"]=>
  string(1) "1"
}

上面的范例运行 3 条语句在 master 上，他们都是在 autocommit 下执行，这样会引起 3 次 GTID 的增加。每次插件都会在执行语句以前，根据配置中的 UPDATE 设定 增加 GTID。

第四条语句，因为是 SELECT 语句，并不会在 master 上执行， 所以不会引发 master 增加 GTID。

Note: 基于 SQL 的 GTID 如何有效率的工作

在客户端通过 GTID 模拟在每个 SQL 执行的时候处理是很没有效率的做法。 这样做，是为了能够清楚的说明情况，而不是为了执行效率，不要在实际的 生产环境中这样使用。可以在本文中找到更有效率的做法。

Example #4 Plugin config: SQL for fetching GTID

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "fetch_last_gtid" : "SELECT MAX(trx_id) FROM test.trx",
            "report_error":true
        }
    }
}

Example #5 Obtaining GTID after injection

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("DROP TABLE IF EXISTS test"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

printf("GTID after transaction %s\n", mysqlnd_ms_get_last_gtid($mysqli));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("CREATE TABLE test(id INT)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

printf("GTID after transaction %s\n", mysqlnd_ms_get_last_gtid($mysqli));
?>

以上例程会输出：

GTID after transaction 7
GTID after transaction 8

应用可以通过插件获取最后一次写操作产生的 GTID。函数mysqlnd_ms_get-last-gtid() 通过在配置文件中 global_transaction_id_injection 章节中 定义的 fetch_last-gtid 方法，返回最后一次 写操作产生的 GTID。函数应该在 GTID 增加后调用。

不建议应用运行自己运行哪些可能产生风险的 SQL 语句，从而增加 GTID。并且，使用函数 可以轻松的将查询 GTID 迁移到其他应用中。例如，使用任何 MySQL 内置的 GTID。

这里展现了一个 SQL 语句获得了他的 GTID 或者比实际执行得到的 GTID 更大的数据。 在 SELECT 和 查询 GTID 之间，可能有其他的客户端执行 SQL 语句，从而增加了 GTID，所以获得的 GTID 可能比实际数据大。

Example #6 Plugin config: Checking for a certain GTID

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "fetch_last_gtid" : "SELECT MAX(trx_id) FROM test.trx",
            "check_for_gtid" : "SELECT trx_id FROM test.trx WHERE trx_id >= #GTID",
            "report_error":true
        }
    }
}

Example #7 Session consistency service level and GTID combined

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* autocommit 模式下，在 master 执行，用于增加 GTID */
if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* 获取最后一次写入的 GTID */
$gtid = mysqlnd_ms_get_last_gtid($mysqli);

/* Session 一致性，尝试从 slave 读取，而不只从 master 读取 */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION, MYSQLND_MS_QOS_OPTION_GTID, $gtid)) {
    die(sprintf("[006] [%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Either run on master or a slave which has replicated the INSERT */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

var_dump($res->fetch_assoc());
?>

通过 mysqlnd_ms_get_last_gtid() 获取的 GTID 可以被用于 Session 一致性服务级别。通过 mysqlnd_ms_set_qos() 设定 Session 一致性服务级别，他决定从哪里读取写入的数据。在范例中， 通过判断 INSERT 是否已经被同步，来决定 SELECT 从哪个服务器中读取数据，

插件检查配置中的所有 slave 服务器，通过查看 GTID 表中的值，判断是否 INSERT 已经被同步。检查的方法在 global_transaction_id_injection 章节中，使用 check_for_gtid 参数定义。 请注意，这是一种低效，浪费资源的方法。 在 master 的读取压力很大的时候，应用可以零星的采用这种方式，来降低读取压力。

使用服务器端的 GTID

自从 MySQL 5.6.5-m8 版本开始，MySQL 主从同步开始支持服务器端的 GTID。GTID 的 创建和增长由服务器控制，用户可以不再关心这些问题。这也就是说，不需要再添加任何 数据库表用于记录 GTID，也不用设置 on_commit 方法。客户端模拟 的 GTID 不再需要使用。

客户端可以顺畅使用 GTID 完成 Session 一致性服务，运算的方式与上面描述的 GTID 模拟 是一样的。不同的是 check_for_gtid 和 fetch_last_gtid 还是需要进行配置。 请注意，MySQL 5.6.5-m8 是一个研发版本，具体执行细节在实际的运行版本对于这些功能可能有改变。

使用下面的配置，可以上上面讨论过的任何一个脚本，能够利用服务器端的 GTID 正常工作。 函数 mysqlnd_ms_get_last_gtid() 和 mysqlnd_ms_set_qos() 工作也一样正常。不同点在于， 服务器并不采用简单的顺序序列，而是采用一个包含服务器标识号和序列数字的字符串。 所以，用户并不能简单的通过 mysqlnd_ms_get_last_gtid() 得到的顺序判断 GTID。 译者注：从 MySQL 5.6.9 版本开始 GTID_DONE 已经被 GTID_EXECUTED 替代，所以下面的 范例中，应该做相应变更。

Example #8 使用 MySQL 5.6.5-m8 内置 GTID

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "fetch_last_gtid" : "SELECT @@GLOBAL.GTID_DONE AS trx_id FROM DUAL",
            "check_for_gtid" : "SELECT GTID_SUBSET('#GTID', @@GLOBAL.GTID_DONE) AS trx_id FROM DUAL",
            "report_error":true
        }
    }
}


Cache integration

Note: 版本需求、依赖性和状态

可以从 concepts section 获取更多的内容。

数据库群组可以设定不同的一致性级别。从 1.2.0 版本，我们建议插件仅仅从群组节点选择上 考虑使用的一致性级别。例如，如果使用异步的 MySQL 主从同步，他采用群组的最终一致性， 建议在任何时间通过 mysqlnd_ms_set_quos() 使用 Session 一致性。 这可以参考 服务级别与一致性

Example #1 Recap: quality of service to request read your writes

/* 设定采用 Session 一致性 */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

假设插件使用最终一致性服务级别，而不采用其他更高要求的一致性策略。那么插件可能使用 通过 TTL 失效策略控制的缓存来替代从数据库节点读取数据。数据库节点和缓存都采用 最终一致性策略，他们可能保存的不是最新的数据。

通过本地缓存替代数据库操作，可以有效的提升性能，降低数据库压力。 如果其他客户端比创建这个缓存条目的客户端更频繁使用他，那么数据库的访问就被降低下来， 从而降低数据库压力。并且，由于本地缓存的速度快于数据库查询，那么整体计算性能就被提升。

Example #2 Plugin config: no special entries for caching

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
    }
}

Example #3 Caching a slave request

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* 确认允许最终一致性，并且设定缓存有效期 (TTL <= 60 seconds) */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_OPTION_CACHE, 60)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* 为了让范例工作，我们采用强制性的循环捕捉 slave 操作 */
$attempts = 0;
do {
  /* check if slave has the table */
  if ($res = $mysqli->query("SELECT id FROM test")) {
    break;
  } else if ($mysqli->errno) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
  }
  /* wait for slave to catch up */
  usleep(200000);
} while ($attempts++ < 10);

/* Query has been run on a slave, result is in the cache */
assert($res);
var_dump($res->fetch_assoc());

/* Served from cache */
$res = $mysqli->query("SELECT id FROM test");
?>

上面的范例说明如何使用缓存功能。通过 mysqlnd_ms_set_qos() 设定最终一致性服务器级别，并且允许使用缓存。然后任何只读的操作都会被放入 缓存中，存活时间通过 mysqlnd_ms_set_qos() 指定。

实际的 TTL 要比通过 mysqlnd_ms_set_qos() 设定的要小，设定值 是他的最大值。插件会在 TTL 上扣除 slave 同步延迟，用于计算实际的 TTL。在范例中， 如果 slave 的同步延迟是 10 秒，TTL 的最大值是 60 秒，那么计算的 TTL 值是 50 秒。 TTL 的计算，对于每一个缓存条目是独立的。

Example #4 Read your writes and caching combined

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Explicitly allow eventual consistency and caching (TTL <= 60 seconds) */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_OPTION_CACHE, 60)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* To make this example work, we must wait for a slave to catch up. Brute force style. */
$attempts = 0;
do {
  /* check if slave has the table */
  if ($res = $mysqli->query("SELECT id FROM test")) {
    break;
  } else if ($mysqli->errno) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
  }
  /* wait for slave to catch up */
  usleep(200000);
} while ($attempts++ < 10);

assert($res);

/* Query has been run on a slave, result is in the cache */
var_dump($res->fetch_assoc());

/* Served from cache */
if (!($res = $mysqli->query("SELECT id FROM test")))
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
var_dump($res->fetch_assoc());

/* Update on master */
if (!$mysqli->query("UPDATE test SET id = 2"))
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Read your writes */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Fetch latest data */
if (!($res = $mysqli->query("SELECT id FROM test")))
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
var_dump($res->fetch_assoc());
?>

服务设定可以随时改变，用于屏蔽缓存的使用。如果需要，你可以变更为 Session 一致性策略， 这时缓存将不会被使用，并且被更新为最新的数据结果。


故障转移

默认情况下，插件并不会在连接一个服务器失败的时候进行故障处理。这是为了防止 连接状态中的陷阱。 这里建议手动的对连接错误进行处理，你可以捕获这个错误，重新建立连接，执行的你的查询，如同下面展示的那样。

如果连接状态并不是由于你的操作引起的，你可以选择自动进行错误处理或者无视他。 通过配置可以实现，当 master 出现故障，可以在重新连接 master 之前，自动尝试连接 一台 slave 去自动处理故障，或者无视这个错误。因为 自动故障转移 并不是一个十分安全的方式，这里就不做过多讨论了，在 concepts section 中会有更多的说明。

Example #1 手动故障转移，可选自动

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "simulate_slave_failure",
                "port": "0"
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
       "filters": { "roundrobin": [] }
    }
 }

Example #2 手动故障转移

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

$sql = "SELECT 1 FROM DUAL";

/* error handling as it should be done regardless of the plugin */
if (!($res = $link->query($sql))) {
  /* plugin specific: check for connection error */
  switch ($link->errno) {
    case 2002:
    case 2003:
    case 2005:
      printf("Connection error - trying next slave!\n");
      /* load balancer will pick next slave */
      $res = $link->query($sql);
      break;
    default:
      /* no connection error, failover is unlikely to help */
      die(sprintf("SQL error: [%d] %s", $link->errno, $link->error));
      break;
  }
}
if ($res) {
  var_dump($res->fetch_assoc());
}
?>


分区和分片

数据库群组是由于各种各样的原因建立的，他可以提升处理能力、容忍错误，并且 提升大量服务器同时工作的的性能。群组有时会组合分区和共享功能，来将大量复杂的任务 分拆成更加简单的任务，更加可控的单元。

插件可以支持各种各样的 MySQL 群组，一些群组会内置一些分区和共享的方法，他们可以 被透明的使用。插件支持最常用的 MySQL 主从同步表过滤和共享 (应用级分区)。

MySQL 主从同步支持过滤方式的分区，他可以让你创建所有数据库同步，或者部分数据库同步。 这样就要求应用能够拥有同样的策略，你可以通过 node_groups 手动的支持这个策略，或者使用实验性质的表过滤器。

从 1.5.0 版本开始，可以通过节点组过滤和 SQL hints 完成手动的分区和共享。 节点组过滤器可以让你将 master 和 slave 命名成一个符号。 范例中， master_0 和 slave_0 被放在一个命名为 Partition_A 的组中。他们能够完全的组成一个群组。 例如，你可以使用一个节点群组用于共享，并且使用使用群组名称作为一个地址共享， 就像 Shard_A_Range_0_100

Example #1 Cluster node groups

{
  "myapp": {
       "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "simulate_slave_failure",
                "port": "0"
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
        "filters": {
            "node_groups": {
                "Partition_A" : {
                    "master": ["master_0"],
                    "slave": ["slave_0"]
                }
            },
           "roundrobin": []
        }
    }
}

Example #2 通过 SQL hints 完成手动分区

<?php
function select($mysqli, $msg, $hint = '') {
  /* Note: weak test, two connections to two servers may have the same thread id */
  $sql = sprintf("SELECT CONNECTION_ID() AS _thread, '%s' AS _hint FROM DUAL", $msg);
  if ($hint) {
    $sql = $hint . $sql;
  }
  if (!($res = $mysqli->query($sql))) {
    printf("[%d] %s", $mysqli->errno, $mysqli->error);
    return false;
  }
  $row =  $res->fetch_assoc();
  printf("%d - %s - %s\n", $row['_thread'], $row['_hint'], $sql);
  return true;
}

$mysqli = new mysqli("myapp", "user", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* All slaves allowed */
select($mysqli, "slave_0");
select($mysqli, "slave_1");

/* only servers of node group "Partition_A" allowed */
select($mysqli, "slave_1", "/*Partition_A*/");
select($mysqli, "slave_1", "/*Partition_A*/");
?>
6804 - slave_0 - SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL
2442 - slave_1 - SELECT CONNECTION_ID() AS _thread, 'slave2' AS _hint FROM DUAL
6804 - slave_0 - /*Partition_A*/SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL
6804 - slave_0 - /*Partition_A*/SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL

默认的，插件使用所有配置的 master 和 slave 进行查询操作。但是如果一个查询，使用 /*node_group*/ 的 SQL hint，那么插件将只使用在 node_group 列出的服务器进行查询操作。所以，SELECT 查询操作，只会在 /*Partition_A*/ 列出的 slave_0 中进行。


MySQL Fabric

Note: Version requirement and status

Work on supporting MySQL Fabric started in version 1.6. Please, consider the support to be of pre-alpha quality. The manual may not list all features or feature limitations. This is work in progress.

Sharding is the only use case supported by the plugin to date.

Note: MySQL Fabric concepts

Please, check the MySQL reference manual for more information about MySQL Fabric and how to set it up. The PHP manual assumes that you are familiar with the basic concepts and ideas of MySQL Fabric.

MySQL Fabric is a system for managing farms of MySQL servers to achive High Availability and optionally support sharding. Technically, it is a middleware to manage and monitor MySQL servers.

Clients query MySQL Fabric to obtain lists of MySQL servers, their state and their roles. For example, clients can can request a list of slaves for a MySQL Replication group and whether they are ready to handle SQL requests. Another example is a cluster of sharded MySQL servers where the client seeks to know which shard to query for a given table and shard key. If configured to use Fabric, the plugin uses XML RCP over HTTP to obtain the list at runtime from a MySQL Fabric host. The XML remote procedure call itself is done in the background and transparent from a developers point of view.

Instead of listing MySQL servers directly in the plugins configuration file it contains a list of one or more MySQL Fabric hosts

Example #1 Plugin config: Fabric hosts instead of MySQL servers

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ]
        }
    }
}

Users utilize the new functions mysqlnd_ms_fabric_select_shard() and mysqlnd_ms_fabric_select_global() to switch to the set of servers responsible for a given shard key. Then, the plugin picks an appropriate server for running queries on. When doing so, the plugin takes care of additional load balancing rules set.

The below example assumes that MySQL Fabric has been setup to shard the table test.fabrictest using the id column of the table as a shard key.

Example #2 Manual partitioning using SQL hints

<?php
$mysqli = new mysqli("myapp", "user", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Create a global table - a table available on all shards */
mysqlnd_ms_fabric_select_global($mysqli, "test.fabrictest");
if (!$mysqli->query("CREATE TABLE test.fabrictest(id INT NOT NULL PRIMARY KEY)"))
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Switch connection to appropriate shard and insert record */
mysqlnd_ms_fabric_select_shard($mysqli, "test.fabrictest", 10);
if (!($res = $mysqli->query("INSERT INTO fabrictest(id) VALUES (10)")))
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Try to read newly inserted record */
mysqlnd_ms_fabric_select_shard($mysqli, "test.fabrictest", 10);
if (!($res = $mysqli->query("SELECT id FROM test WHERE id = 10")))
 die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
?>

The example creates the sharded table, inserts a record and reads the record thereafter. All SQL data definition language (DDL) operations on a sharded table must be applied to the so called global server group. Prior to creatingor altering a sharded table, mysqlnd_ms_fabric_select_global() is called to switch the given connection to the corresponsing servers of the global group. Data manipulation (DML) SQL statements must be sent to the shards directly. The mysqlnd_ms_fabric_select_shard() switches a connection to shards handling a certain shard key.


概念

Table of Contents

  • Architecture
  • 连接池与切换
  • 事务控制
  • 错误处理
  • 短错误
  • 错误处理
  • 负载均衡
  • Read-write splitting
  • Filter
  • Service level and consistency
  • Global transaction IDs
  • Cache integration
  • Supported clusters
  • XA/Distributed transactions

这里说明关于插件的一些相关概念，与使用数据库集群的 MySQL 主从同步对于开发 的一些影响。为了能够让插件更好的工作，需要阅读和理解这些概念。


Architecture

mysqlnd 作为一个 PHP 扩展完成主从同步和负载均衡。他使用 C 语言编写， 从底层嵌入 PHP。伴随 PHP 解释器的启动，他以模块的方式嵌入 PHP 引擎。 他使用 mysqlnd 名称注册在引擎中， 并且使用 mysqlnd 自己的 C 方法替换系统默认操作。

在 PHP 脚本运行期间，他检查所有通过 mysqlnd 发送给 MySQL 服务器的指令。 如果指令时只读的，那么将会发送给排至的 slave 服务器。通过判断语句 是否以 SELECT 开头，决定他是否是只读指令。或者通过 SQL hints /*ms=slave*/ 指定 slave 运行，或者通过 SQL hints /*ms=last_used*/ 指定通过上一条查询的连接运行。 其他情况下，指令会被发送到 MySQL 主从同步的 master 服务器执行。

为了更好的移植性，应用应该使用 MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH, 和 MYSQLND_MS_LAST_USED_SWITCH mysqlnd_ms 预定义常量, 替代 SQL hints 的使用，例如：/*ms=slave*/。

插件控制所有到 master 和 slave 的链接。对于应用来说，只需要控制一个连接。 然而这个应用控制的链接，其实是插件管理的连接池中的一个。插件代理了这些 到 master 的链接，并且管理很多的到达 slave 的链接。

数据库连接的状态，由事务、状态、事务设定、字符集设定、临时表等内容组成。 插件在事务执行的过程中和自动提交指令执行中，维护同样的链接状态。有效维护这些 状态并不容易，当运行 BEGIN TRANSACTION 指令后，插件将 控制权移交给用户。


连接池与切换

插件控制 PHP MySQL 链接，完成同步和负载均衡，他并不会改变现有的 PHP MySQL 扩展的方法使用 (mysqli, mysql, 和 PDO_MYSQL) 现有的应用并不需要 更新他们代码，或者使用新的 API，但是若操作行为改变，还是需要一些修改的。

插件结果下面这些扩展对于 MySQL 连接的控制， mysqli, mysql, 和 PDO_MYSQL。 并且为 mysqli, mysql, 和 PDO_MYSQL 提供一个本地的连接池 完成 MySQL 主从同步的 master 和 slave 通讯控制。插件会代理所有的 到达 master 和 slave 的查询请求。 在某一时刻一个连接到 master 的链接，会在稍后变更为 slave 连接，或者 依然保持 master 连接。在执行非事务处理中，控制和替换 PHP MySQL 的网络链接。

每个 MySQL 连接都有他的状态，在连接池中的每个连接可以有不同的状态。 当插件将一个写入连接变更为另外一个的时候，链接状态可能被改变。应用 需要关注这个问题。

下面列出连接状态的内容，他可能并不完整。

  • 事务状态
  • 临时表
  • 表锁
  • Session 系统变量和用户变量
  • 当前使用的数据库 USE 和其他束缚 SQL 指令的状态
  • 预执行语句
  • HANDLER 变量
  • 通过 GET_LOCK () 获得的锁

连接替换将在语句执行前进行，在下一个语句执行以前，插件不会变更连接。

Note: 同步的问题

请参考 MySQL 参考手册中关于 » replication features 的相关内容。一些限制跟这个 PHP 插件无感，但是与 MySQL 的主从同步相关。

广播消息

插件的设计哲学是只有完全控制的链接，插件会在连接池排列连接的状态，或者由于 一些安全因素也会这么做。只有很少的操作改变连接状态会失败，在这样的分类当中。

下面列出了哪些客户端的库，会改变连接状态，并且会将它广播到连接池中所有 打开的链接当中。

任何下面列出的内容被执行，插件会轮循所有打开的 master 和 slave 连接， 轮循会在操作了所有的服务器后停止。这个轮循不会影响服务器连接失败的状态。 库函数的触发器可能以备检测到失败，并且通过用户 API 函数广播。

Library call | Notes | Version
change_user() | Called by the mysqli_change_user() user API call. Also triggered upon reuse of a persistent mysqli connection. | Since 1.0.0.
select_db | Called by the following user API calls: mysql_select_db(), mysql_list_tables(), mysql_db_query(), mysql_list_fields(), mysqli_select_db(). Note, that SQL USE is not monitored. | Since 1.0.0.
set_charset() | Called by the following user API calls: mysql_set_charset(). mysqli_set_charset(). Note, that SQL SET NAMES is not monitored. | Since 1.0.0.
set_server_option() | Called by the following user API calls: mysqli_multi_query(), mysqli_real_query(), mysqli_query(), mysql_query(). | Since 1.0.0.
set_client_option() | Called by the following user API calls: mysqli_options(), mysqli_ssl_set(), mysqli_connect(), mysql_connect(), mysql_pconnect(). | Since 1.0.0.
set_autocommit() | Called by the following user API calls: mysqli_autocommit(), PDO::setAttribute(PDO::ATTR_AUTOCOMMIT). | Since 1.0.0. PHP >= 5.4.0.
ssl_set() | Called by the following user API calls: mysqli_ssl_set(). | Since 1.1.0.

广播和被动连接

连接打开以后，插件无法代理或者记录其上所有的设定。如果采用 lazy connections. 这非常重要。被动连接方式，客户端在发起第一次指令的时候，连接才被建立。 插件默认的采用这种被动连接方式。

下面的这些库调用，将在被动连接建立以后执行。这有助于确信所有连接池中 连接的状态存在可比性。

Library call | Notes | Version
change_user() | User, password and database recorded for future use. | Since 1.1.0.
select_db | Database recorded for future use. | Since 1.1.0.
set_charset() | Calls set_client_option(MYSQL_SET_CHARSET_NAME, charset) on lazy connection to ensure charset will be used upon opening the lazy connection. | Since 1.1.0.
set_autocommit() | Adds SET AUTOCOMMIT=0|1 to the list of init commands of a lazy connection using set_client_option(MYSQL_INIT_COMMAND, "SET AUTOCOMMIT=...%quot;). | Since 1.1.0. PHP >= 5.4.0.
Caution

连接状态

连接状态不仅仅会被 API 调用改变。所以，即使插件监控了所有的 API 调用， 应用也要在这方面关注变化。最后，对于连接状态的维护，是应用应该完成的事情。

字符集和字符串换码

当使用默认的被动连接时，若应用尝试在连接建立以前对 SQL 语句中的字符进行转码， 是不可能完成的。因为连接建立以前，并不知道连接需要的字符集是甚么。

在 1.4.0 以后版本中，通过配置中的 server_charset 设置可以解决这个问题。

需要注意已经转换为某种字符集，但是连接的结果采用了另外一种不同的字符集。 插件控制的链接和连接池中的每个连接可能采用了不同的默认字符集，所以建议配置 服务器采用统一的默认字符集设定。配置文件中的 server_charset 可以很好的处理这种情况，如果使用它，插件将对每一个新打开的链接设定默认的字符集。


事务控制

事务控制已经从根本上被改变了，一个 SQL 事务是运行在一个数据库服务器中的 一个或者一组 SQL 语句。

默认情况下，插件并不关心 SQL 事务处理，插件会在每个 SQL 执行时进行负载均衡， 这就可能在事务执行的中间更换了连接。这对事务执行来说是不可以的，所以默认 配置的插件并不是事务安全的。

MySQL 负载均衡需要从事务开始到终止时，处于连续的状态。这种连续控制，可以使用 监控 API 调用，或者使用 SQL hints。具体插件可以支持哪种方式，基于您使用的 PHP 版本。API 调用监控，需要 PHP 5.4.0 以上版本。就像其他的 MySQL 负载均衡控制 一样，本插件无法自动识别事务的起始和终止边界。采用 API 监控方式是对现有应用 改变最小的方式。

可以在 examples section 找到使用 SQL hints 和 API 监控的范例。在 API 监控作用下，插件会关注事务的执行。

从 PHP 5.4.0 版本开始，mysqlnd 库允许调用 set_autocommit() 他用于检测 autocommit 设定。

PHP MySQL 扩展调用查询语句 (例如 SET AUTOCOMMIT=0|1) 或者 set_autocommit() 来控制 autocommit 设置。 如果通过 set_autocommit() 来设置，那么插件能够识别事务。 插件无法知道通过查询语句设定的 autocommit 状态。 set_autocommit() 会被 mysqli_autocommit() 和 PDO::setAttribute(PDO::ATTR_AUTOCOMMIT) 调用。

插件的配置 trx_stickiness=master 可以用来让插件识别事务处理。在这种情况下，如果 autocommit 被禁用，那么插件将终止负载均衡， 所有的语句都将交给 master执行，直到 autocommit 被启用。

应用程序若不想针对事务执行设置 SQL hints，那么就需要使用 API 监控来完成对 事务处理的支持，那么请注意一定要使用上面列出的，可以识别 autocommit 状态变化 的 API 调用。

基于 API 的事务处理边界识别，是从 PHP 5.5.0 和 本插件 1.5.0 版本开始的，并且
不仅仅识别 mysqli_autocommit() 也可以识别
mysqli_begin(),mysqli_commit() 和
mysqli_rollback()。


错误处理

应用程序使用本插件，应该针对用户的 API 调用实现一些错误处理。并且由于插件 改变了连接控制，API 调用可能返回不可预期的错误。如果插件被用于连接控制中， 那么连接将不在代表一个独立的网络链接，他是一个连接池。那么一个错误编号和 错误消息将被设置在连接控制中，那么他可能被设置在任何一个实际的连接中。

如果使用默认的被动连接，那么连接再实际查询执行以前是不建立实际连接的。 这样一个执行语句的 API 调用会产生一个连接错误。下面的范例中，当尝试在 slave 中执行一个语句的时候将产生一个错误。连接错误的产生是因为在配置文件中 没有设定一个有效的 slave。

Example #1 Provoking a connection error

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "invalid_host_name",
            }
        },
        "lazy_connections": 1
    }
}

明确的指定被动连接设定只是为了范例目的使用。

Example #2 在查询执行时产生连接错误

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* 连接 1：在连接中绑定 SQL 用户定义变量，没有 SELECT 所以在 master 上运行 */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* 连接 2：运行 SELECT 在 slave，产生一个连接错误 */
if (!($res = $mysqli->query("SELECT @myrole AS _role"))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
 $row = $res->fetch_assoc();
 $res->close();
 printf("@myrole = '%s'\n", $row['_role']);
}
$mysqli->close();
?>

以上例程的输出类似于：

PHP Warning:  mysqli::query(): php_network_getaddresses: getaddrinfo failed: Name or service not known in %s on line %d
PHP Warning:  mysqli::query(): [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known (trying to connect via tcp://invalid_host_name:3306) in %s on line %d
[2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

应用程序希望通过有效的错误处理控制这种连接错误。

处于使用的目的，应用程序应该希望控制这些错误，典型的错误内容 2002 (CR_CONNECTION_ERROR) - Can't connect to local MySQL server through socket '%s' (%d), 2003 (CR_CONN_HOST_ERROR) - Can't connect to MySQL server on '%s' (%d) 和 2005 (CR_UNKNOWN_HOST) - Unknown MySQL server host '%s' (%d)。 例如，应用程序可以判断这些错误编号，进而手动的执行某些错误处理。插件并不会自动的进行 这些错误处理，包括 master 错误处理，因为这些并不是透明的操作。

Example #3 产生一个连接错误

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "invalid_host_name"
            },
            "slave_1": {
                "host": "192.168.78.136"
            }
        },
        "lazy_connections": 1,
        "filters": {
            "roundrobin": [

            ]
        }
    }
}

明确的指定被动连接只为了进行范例使用，包括使用默认的负载均衡策略 random once。

Example #4 非常基础的错误处理

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Connection 1, connection bound SQL user variable, no SELECT thus run on master */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* 连接 2：第一个 Slave 执行 */
$res = $mysqli->query("SELECT VERSION() AS _version");
/* 强硬的进行错误处理 */
if (2002 == $mysqli->errno || 2003 == $mysqli->errno || 2004 == $mysqli->errno) {
  /* 连接 3：第一个 slave 连接失败，尝试下一个 slave 连接 */
  $res = $mysqli->query("SELECT VERSION() AS _version");
}

if (!$res) {
  printf("ERROR, [%d] '%s'\n", $mysqli->errno, $mysqli->error);
} else {
 /* 从连接 3 中获取错误信息，他并没有错误 */
 printf("SUCCESS, [%d] '%s'\n", $mysqli->errno, $mysqli->error);
 $row = $res->fetch_assoc();
 $res->close();
 printf("version = %s\n", $row['_version']);
}
$mysqli->close();
?>

以上例程的输出类似于：

[1045] Access denied for user 'username'@'localhost' (using password: YES)
PHP Warning:  mysqli::query(): php_network_getaddresses: getaddrinfo failed: Name or service not known in %s on line %d
PHP Warning:  mysqli::query(): [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known (trying to connect via tcp://invalid_host_name:3306) in %s on line %d
SUCCESS, [0] ''
version = 5.6.2-m5-log

由于一些原因，连接控制并不可能很容易在所有网络连接中检查所有的错误。 例如，我们假设在连接池中有 3 个网络链接，一个连接是 master 连接，2个是 slave 链接。 应用程序通过 mysqli_select_db() API 调用改变当前操作数据库， 插件监控到这个函数，并且尝试更改当前的所有连接来统一他们的链接状态。如果 master 已经成功的更改了数据库，两个 slave 连接更改失败，那么在使用第一个 slave 连接的时候， 其中会包含一个连接错误。对于第二个 slave 链接也是一样的，那么在第一个 slave 上的 错误信息将被丢失。

这种情况下，可以通过检查 E_WARNING 类型的错误，或者检查 mysqlnd_ms debug and trace log。


短错误

一些分布式的数据库群组使用短错误。一个短错误只是一段时间内的一个临时错误。 在一定的顶一下，这种忽略短错误并且重新在同一个数据库服务器中进行尝试是 安全的，尝试处理对客户端不产生影响。客户端将不会被迫终止他们的工作，或者去处理 另外一个数据库服务器的错误。他们将进入一个尝试处理错误的循环，而不需要等待错误 信息消失。例如，当使用 MySQL Cluster时，可以看到这种短错误信息。他们并不会被 绑定在特定的群组解决方案中。

插件可以提供在短错误中的自动尝试处理循环。这将提高分布处理的透明度，并且对于 应用程序从一个单独服务器运行一直到数据库服务群组执行变得更加简单。

自动的尝试循环，将不断的尝试，直到用户配置文件指定的次数，并且根据配置指定的 间隔时间进行短暂的等待。如果错误在循环过程中消失，应用程序将不会再看到这个 错误信息。如果错误没有消失，错误将被提交给应用程序进行处理。

下面的范例中，duplicate key 的错误内容在提交给应用程序以前，会被尝试处理 2 次， 两次尝试之间间隔 100 ms。

Example #1 Provoking a transient error

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
       },
       "transient_error": {
          "mysql_error_codes": [
            1062
          ],
          "max_retries": 2,
          "usleep_retry": 100
       }
    }
}

Example #2 短错误尝试循环

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT PRIMARY KEY)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1))")) {
  printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Retry loop is completely transparent. Checking statistics is
 the only way to know about implicit retries */
$stats = mysqlnd_ms_get_stats();
printf("Transient error retries before error: %d\n", $stats['transient_error_retries']);

/* Provoking duplicate key error to see statistics change */
if (!$mysqli->query("INSERT INTO test(id) VALUES (1))")) {
  printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

$stats = mysqlnd_ms_get_stats();
printf("Transient error retries after error: %d\n", $stats['transient_error_retries']);

$mysqli->close();
?>

以上例程的输出类似于：

Transient error retries before error: 0
[1062] Duplicate entry '1' for key 'PRIMARY'
Transient error retries before error: 2

Because the execution of the retry loop is transparent from a users point of view, the example checks the statistics provided by the plugin to learn about it.

As the example shows, the plugin can be instructed to consider any error transient regardless of the database servers error semantics. The only error that a stock MySQL server considers temporary has the error code 1297. When configuring other error codes but 1297 make sure your configuration reflects the semantics of your clusters error codes.

The following mysqlnd C API calls are monitored by the plugin to check
for transient errors: query(),
change_user(), select_db(),
set_charset(), set_server_option()
prepare(), execute(),
set_autocommit(),
tx_begin(), tx_commit(),
tx_rollback(), tx_commit_or_rollback().
The corresponding user API calls have similar names.

The maximum time the plugin may sleep during the retry loop depends on the function in question. The a retry loop for query(), prepare() or execute() will sleep for up to max_retries * usleep_retry milliseconds.

However, functions that control connection state are dispatched to all all connections. The retry loop settings are applied to every connection on which the command is to be run. Thus, such a function may interrupt program execution for longer than a function that is run on one server only. For example, set_autocommit() is dispatched to connections and may sleep up to (max_retries * usleep_retry) * number_of_open_connections) milliseconds. Please, keep this in mind when setting long sleep times and large retry numbers. Using the default settings of max_retries=1, usleep_retry=100 and lazy_connections=1 it is unlikely that you will ever see a delay of more than 1 second.


错误处理

默认情况下，错误处理应该由用户来处理，应用程序应该检查数据库函数的返回值并且 处理其中可能产生的错误内容。例如，如果插件为一个只读查询选择了一个已经不可用 的 slave，那么将会在执行以后产生一个错误。

默认：手动处理错误

It is up to the application to handle the error and, if required, re-issue the query to trigger the selection of another slave server for statement execution. The plugin will make no attempts to failover automatically, because the plugin cannot ensure that an automatic failover will not change the state of the connection. For example, the application may have issued a query which depends on SQL user variables which are bound to a specific connection. Such a query might return incorrect results if the plugin would switch the connection implicitly as part of automatic failover. To ensure correct results, the application must take care of the failover, and rebuild the required connection state. Therefore, by default, no automatic failover is performed by the plugin.

A user that does not change the connection state after opening a connection may activate automatic failover. Please note, that automatic failover logic is limited to connection attempts. Automatic failover is not used for already established connections. There is no way to instruct the plugin to attempt failover on a connection that has been connected to MySQL already in the past.

Automatic failover

The failover policy is configured in the plugins configuration file, by using the failover configuration directive.

Automatic and silent failover can be enabled through the failover configuration directive. Automatic failover can either be configured to try exactly one master after a slave failure or, alternatively, loop over slaves and masters before returning an error to the user. The number of connection attempts can be limited and failed hosts can be excluded from future load balancing attempts. Limiting the number of retries and remembering failed hosts are considered experimental features, albeit being reasonable stable. Syntax and semantics may change in future versions.

Please note, since version 1.5.0 automatic failover is disabled for the duration of a transaction if transaction stickiness is enabled and transaction boundaries have been detected. The plugin will not switch connections for the duration of a transaction. It will also not perform automatic and silent failover. Instead an error will be thrown. It is then left to the user to handle the failure of the transaction. Please check, the trx_stickiness documentation how to do this.

A basic manual failover example is provided within the error handling section.

Standby servers

Using weighted load balancing, introduced in PECL/mysqlnd 1.4.0, it is possible to configure standby servers that are sparsely used during normal operations. A standby server that is primarily used as a worst-case standby failover target can be assigned a very low weight/priority in relation to all other servers. As long as all servers are up and running the majority of the workload is assigned to the servers which have hight weight values. Few requests will be directed to the standby system which has a very low weight value.

Upon failure of the servers with a high priority, you can still failover to the standby, which has been given a low load balancing priority by assigning a low weight to it. Failover can be some manually or automatically. If done automatically, you may want to combine it with the remember_failed option.

At this point, it is not possible to instruct the load balancer to direct no requests at all to a standby. This may not be much of a limitation given that the highest weight you can assign to a server is 65535. Given two slaves, of which one shall act as a standby and has been assigned a weight of 1, the standby will have to handle far less than one percent of the overall workload.

Failover and primary copy

Please note, if using a primary copy cluster, such as MySQL Replication, it is difficult to do connection failover in case of a master failure. At any time there is only one master in the cluster for a given dataset. The master is a single point of failure. If the master fails, clients have no target to fail over write requests. In case of a master outage the database administrator must take care of the situation and update the client configurations, if need be.


负载均衡

有 4 中复杂均衡策略，可以用于支持 MySQL slave 的配置。

random

当执行语句的时候随机选择一个服务器。

random once (默认值)

当第一个查询执行的时候，随机选择一个服务器，在本页面随后的查询中， 使用相同的一个服务器连接。

这是默认值，并且这种方式对于连接状态信息可能产生的变数影响最小。

round robin

轮循配置中的所有服务器。

user-defined via callback

可以用于制定任何一种其他的策略。

可以使用 random, roundrobin, 和 user filters 在插件的配置中，指定使用的 负载均衡策略。

服务器可以被设定权重。若果一个服务器的权重被设定为 2，那么在大量的操作后，可以看到 他使用的次数将是那些权重为 1 的服务器使用的 2 倍。这种优先级信息可以被非常方便的 在 heterogenous 环境中设定。例如，希望在一个更好的设备上执行更多查询， 或者希望在就近的设备中进行更多的查询，等等这些各种各样的不同原因使用。


Read-write splitting

The plugin executes read-only statements on the configured MySQL slaves, and all other queries on the MySQL master. Statements are considered read-only if they either start with SELECT, the SQL hint /*ms=slave*/, or if a slave had been chosen for running the previous query and the query starts with the SQL hint /*ms=last_used*/. In all other cases, the query will be sent to the MySQL replication master server. It is recommended to use the constants MYSQLND_MS_SLAVE_SWITCH, MYSQLND_MS_MASTER_SWITCH and MYSQLND_MS_LAST_USED_SWITCH instead of /*ms=slave*/. See also the list of mysqlnd_ms constants.

SQL hints are a special kind of standard compliant SQL comments. The plugin does check every statement for certain SQL hints. The SQL hints are described within the mysqlnd_ms constants documentation, constants that are exported by the extension. Other systems involved with the statement processing, such as the MySQL server, SQL firewalls, and SQL proxies, are unaffected by the SQL hints, because those systems are designed to ignore SQL comments.

The built-in read-write splitter can be replaced by a user-defined filter, see also the user filter documentation.

A user-defined read-write splitter can request the built-in logic to send a statement to a specific location, by invoking mysqlnd_ms_is_select().

Note:

The built-in read-write splitter is not aware of multi-statements. Multi-statements are seen as one statement. The splitter will check the beginning of the statement to decide where to run the statement. If, for example, a multi-statement begins with SELECT 1 FROM DUAL; INSERT INTO test(id) VALUES (1); ... the plugin will run it on a slave although the statement is not read-only.


Filter

Note: Version requirement

Filters exist as of mysqlnd_ms version 1.1.0-beta.

filters. PHP applications that implement a MySQL replication cluster must first identify a group of servers in the cluster which could execute a statement before the statement is executed by one of the candidates. In other words: a defined list of servers must be filtered until only one server is available.

The process of filtering may include using one or more filters, and filters can be chained. And they are executed in the order they are defined in the plugins configuration file.

Note: Explanation: comparing filter chaining to pipes

The concept of chained filters can be compared to using pipes to connect command line utilities on an operating system command shell. For example, an input stream is passed to a processor, filtered, and then transferred to be output. Then, the output is passed as input to the next command, which is connected to the previous using the pipe operator.

Available filters:

  • Load balancing filters: random and roundrobin.
  • Selection filter: user, user_multi, quality_of_service.

The random filter implements the 'random' and 'random once' load balancing policies. The 'round robin' load balancing can be configured through the roundrobin filter. Setting a 'user defined callback' for server selection is possible with the user filter. The quality_of_service filter finds cluster nodes capable of delivering a certain service, for example, read-your-writes or, not lagging more seconds behind the master than allowed.

Filters can accept parameters to change their behaviour. The random filter accepts an optional sticky parameter. If set to true, the filter changes load balancing from random to random once. Random picks a random server every time a statement is to be executed. Random once picks a random server when the first statement is to be executed and uses the same server for the rest of the PHP request.

One of the biggest strength of the filter concept is the possibility to chain filters. This strength does not become immediately visible because tje random, roundrobin and user filters are supposed to output no more than one server. If a filter reduces the list of candidates for running a statement to only one server, it makes little sense to use that one server as input for another filter for further reduction of the list of candidates.

An example filter sequence that will fail:

  • Statement to be executed: SELECT 1 FROM DUAL. Passed to all filters.
  • All configured nodes are passed as input to the first filter. Master nodes: master_0. Slave nodes:slave_0, slave_1
  • Filter: random, argument sticky=1. Picks a random slave once to be used for the rest of the PHP request. Output: slave_0.
  • Output of slave_0 and the statement to be executed is passed as input to the next filter. Here: roundrobin, server list passed to filter is: slave_0.
  • Filter: roundrobin. Server list consists of one server only, round robin will always return the same server.
If trying to use such a filter sequence, the plugin may emit a warning like (mysqlnd_ms) Error while creating filter '%s' . Non-multi filter '%s' already created. Stopping in %s on line %d. Furthermore, an appropriate error on the connection handle may be set.

A second type of filter exists: multi filter. A multi filter emits zero, one or multiple servers after processing. The quality_of_service filter is an example. If the service quality requested sets an upper limit for the slave lag and more than one slave is lagging behind less than the allowed number of seconds, the filter returns more than one cluster node. A multi filter must be followed by other to further reduce the list of candidates for statement execution until a candidate is found.

A filter sequence with the quality_of_service multi filter followed by a load balancing filter.

  • Statement to be executed: SELECT sum(price) FROM orders WHERE order_id = 1. Passed to all filters.
  • All configured nodes are passed as input to the first filter. Master nodes: master_0. Slave nodes: slave_0, slave_1, slave_2, slave_3
  • Filter: quality_of_service, rule set: session_consistency (read-your-writes) Output: master_0
  • Output of master_0 and the statement to be executed is passed as input to the next filter, which is roundrobin.
  • Filter: roundrobin. Server list consists of one server. Round robin selects master_0.

A filter sequence must not end with a multi filter. If trying to use a filter sequence which ends with a multi filter the plugin may emit a warning like (mysqlnd_ms) Error in configuration. Last filter is multi filter. Needs to be non-multi one. Stopping in %s on line %d. Furthermore, an appropriate error on the connection handle may be set.

Note: Speculation towards the future: MySQL replication filtering

In future versions, there may be additional multi filters. For example, there may be a table filter to support MySQL replication filtering. This would allow you to define rules for which database or table is to be replicated to which node of a replication cluster. Assume your replication cluster consists of four slaves (slave_0, slave_1, slave_2, slave_3) two of which replicate a database named sales (slave_0, slave_1). If the application queries the database slaves, the hypothetical table filter reduces the list of possible servers to slave_0 and slave_1. Because the output and list of candidates consists of more than one server, it is necessary and possible to add additional filters to the candidate list, for example, using a load balancing filter to identify a server for statement execution.


Service level and consistency

Note: Version requirement

Service levels have been introduced in mysqlnd_ms version 1.2.0-alpha. mysqlnd_ms_set_qos() requires PHP 5.4.0 or newer.

The plugin can be used with different kinds of MySQL database clusters. Different clusters can deliver different levels of service to applications. The service levels can be grouped by the data consistency levels that can be achieved. The plugin knows about:

  • eventual consistency
  • session consistency
  • strong consistency

Depending how a cluster is used it may be possible to achieve higher service levels than the default one. For example, a read from an asynchronous MySQL replication slave is eventual consistent. Thus, one may say the default consistency level of a MySQL replication cluster is eventual consistency. However, if the master only is used by a client for reading and writing during a session, session consistency (read your writes) is given. PECL mysqlnd 1.2.0 abstracts the details of choosing an appropriate node for any of the above service levels from the user.

Service levels can be set through the qualify-of-service filter in the plugins configuration file and at runtime using the function mysqlnd_ms_set_qos().

The plugin defines the different service levels as follows.

Eventual consistency is the default service provided by an asynchronous cluster, such as classical MySQL replication. A read operation executed on an arbitrary node may or may not return stale data. The applications view of the data is eventual consistent.

Session consistency is given if a client can always read its own writes. An asynchronous MySQL replication cluster can deliver session consistency if clients always use the master after the first write or never query a slave which has not yet replicated the clients write operation.

The plugins understanding of strong consistency is that all clients always see the committed writes of all other clients. This is the default when using MySQL Cluster or any other cluster offering synchronous data distribution.

Service level parameters

Eventual consistency and session consistency service level accept parameters.

Eventual consistency is the service provided by classical MySQL replication. By default, all nodes qualify for read requests. An optional age parameter can be given to filter out nodes which lag more than a certain number of seconds behind the master. The plugin is using SHOW SLAVE STATUS to measure the lag. Please, see the MySQL reference manual to learn about accuracy and reliability of the SHOW SLAVE STATUS command.

Session consistency (read your writes) accepts an optional GTID parameter to consider reading not only from the master but also from slaves which already have replicated a certain write described by its transaction identifier. This way, when using asynchronous MySQL replication, read requests may be load balanced over slaves while still ensuring session consistency.

The latter requires the use of client-side global transaction id injection.

Advantages of the new approach

The new approach supersedes the use of SQL hints and the configuration option master_on_write in some respects. If an application running on top of an asynchronous MySQL replication cluster cannot accept stale data for certain reads, it is easier to tell the plugin to choose appropriate nodes than prefixing all read statements in question with the SQL hint to enforce the use of the master. Furthermore, the plugin may be able to use selected slaves for reading.

The master_on_write configuration option makes the plugin use the master after the first write (session consistency, read your writes). In some cases, session consistency may not be needed for the rest of the session but only for some, few read operations. Thus, master_on_write may result in more read load on the master than necessary. In those cases it is better to request a higher than default service level only for those reads that actually need it. Once the reads are done, the application can return to default service level. Switching between service levels is only possible using mysqlnd_ms_set_qos().

Performance considerations

A MySQL replication cluster cannot tell clients which slaves are capable of delivering which level of service. Thus, in some cases, clients need to query the slaves to check their status. PECL mysqlnd_ms transparently runs the necessary SQL in the background. However, this is an expensive and slow operation. SQL statements are run if eventual consistency is combined with an age (slave lag) limit and if session consistency is combined with a global transaction ID.

If eventual consistency is combined with an maximum age (slave lag), the plugin selects candidates for statement execution and load balancing for each statement as follows. If the statement is a write all masters are considered as candidates. Slaves are not checked and not considered as candidates. If the statement is a read, the plugin transparently executes SHOW SLAVE STATUS on every slaves connection. It will loop over all connections, send the statement and then start checking for results. Usually, this is slightly faster than a loop over all connections in which for every connection a query is send and the plugin waits for its results. A slave is considered a candidate if SHOW SLAVE STATUS reports Slave_IO_Running=Yes, Slave_SQL_Running=Yes and Seconds_Behind_Master is less or equal than the allowed maximum age. In case of an SQL error, the plugin emits a warning but does not set an error on the connection. The error is not set to make it possible to use the plugin as a drop-in.

If session consistency is combined with a global transaction ID, the plugin executes the SQL statement set with the fetch_last_gtid entry of the global_transaction_id_injection section from the plugins configuration file. Further details are identical to those described above.

In version 1.2.0 no additional optimizations are done for executing background queries. Future versions may contain optimizations, depending on user demand.

If no parameters and options are set, no SQL is needed. In that case, the plugin consider all nodes of the type shown below.

  • eventual consistency, no further options set: all masters, all slaves
  • session consistency, no further options set: all masters
  • strong consistency (no options allowed): all masters

Throttling

The quality of service filter can be combined with Global transaction IDs to throttle clients. Throttling does reduce the write load on the master by slowing down clients. If session consistency is requested and global transactions idenentifier are used to check the status of a slave, the check can be done in two ways. By default a slave is checked and skipped immediately if it does not match the criteria for session consistency. Alternatively, the plugin can wait for a slave to catch up to the master until session consistency is possible. To enable the throttling, you have to set wait_for_gtid_timeout configuration option.


Global transaction IDs

Note: Version requirement

Client side global transaction ID injection exists as of mysqlnd_ms version 1.2.0-alpha. Transaction boundaries are detected by monitoring API calls. This is possible as of PHP 5.4.0. Please, see also Transaction handling.

As of MySQL 5.6.5-m8 the MySQL server features built-in global transaction identifiers. The MySQL built-in global transaction ID feature is supported by PECL/mysqlnd_ms 1.3.0-alpha or later. Neither are client-side transaction boundary monitoring nor any setup activities required if using the server feature.

Idea and client-side emulation

PECL/mysqlnd_ms can do client-side transparent global transaction ID injection. In its most basic form, a global transaction identifier is a counter which is incremented for every transaction executed on the master. The counter is held in a table on the master. Slaves replicate the counter table.

In case of a master failure a database administrator can easily identify the most recent slave for promiting it as a new master. The most recent slave has the highest transaction identifier.

Application developers can ask the plugin for the global transaction identifier (GTID) for their last successful write operation. The plugin will return an identifier that refers to an transaction no older than that of the clients last write operation. Then, the GTID can be passed as a parameter to the quality of service (QoS) filter as an option for session consistency. Session consistency ensures read your writes. The filter ensures that all reads are either directed to a master or a slave which has replicated the write referenced by the GTID.

When injection is done

The plugin transparently maintains the GTID table on the master. In autocommit mode the plugin injects an UPDATE statement before executing the users statement for every master use. In manual transaction mode, the injection is done before the application calls commit() to close a transaction. The configuration option report_error of the GTID section in the plugins configuration file is used to control whether a failed injection shall abort the current operation or be ignored silently (default).

Please note, the PHP version requirements for transaction boundary monitoring and their limits.

Limitations

Client-side global transaction ID injection has shortcomings. The potential issues are not specific to PECL/mysqlnd_ms but are rather of general nature.

  • Global transaction ID tables must be deployed on all masters and replicas.
  • The GTID can have holes. Only PHP clients using the plugin will maintain the table. Other clients will not.
  • Client-side transaction boundary detection is based on API calls only.
  • Client-side transaction boundary detection does not take implicit commit into account. Some MySQL SQL statements cause an implicit commit and cannot be rolled back.

Using server-side global transaction identifier

Starting with PECL/mysqlnd_ms 1.3.0-alpha the MySQL 5.6.5-m8 or newer built-in global transaction identifier feature is supported. Use of the server feature lifts all of the above listed limitations. Please, see the MySQL Reference Manual for limitations and preconditions for using server built-in global transaction identifiers.

Whether to use the client-side emulation or the server built-in functionality is a question not directly related to the plugin, thus it is not discussed in depth. There are no plans to remove the client-side emulation and you can continue to use it, if the server-side solution is no option. This may be the case in heterogenous environments with old MySQL server or, if any of the server-side solution limitations is not acceptable.

From an applications perspective there is hardly a difference in using one or the other approach. The following properties differ.

  • Client-side emulation, as shown in the manual, is using an easy to compare sequence number for global transactions. Multi-master is not handled to keep the manual examples easy. Server-side built-in feature is using a combination of a server identifier and a sequence number as a global transaction identifier. Comparison cannot use numeric algebra. Instead a SQL function must be used. Please, see the MySQL Reference Manual for details.
  • Plugin global transaction ID statistics are only available with client-side emulation because they monitor the emulation.

Note: Global transaction identifiers in distributed systems

Global transaction identifiers can serve multiple purposes in the context of distributed systems, such as a database cluster. Global transaction identifiers can be used for, for example, system wide identification of transactions, global ordering of transactions, heartbeat mechanism and for checking the replication status of replicas. PECL/mysqlnd_ms, a clientside driver based software, does focus on using GTIDs for tasks that can be handled at the client, such as checking the replication status of replicas for asynchronous replication setups.


Cache integration

Note: 版本需求

功能需要 PECL/mysqlnd_ms 1.3.0-beta 以上版本，和 PECL/mysqlnd_qc 1.1.0-alpha 以上版本。PECL/mysqlnd_ms 必须编译的时候支持这个功能，需要 PHP 5.4.0 以上版本。

Note: Setup: extension load order

PECL/mysqlnd_ms 必须在 PECL/mysqlnd_qc 前面装载。

Note: 功能稳定性

继承的缓存提供 beta 品质。

Note: 适用的 MySQL 集群

这个功能主要为 MySQL 主从同步提供支持，目前不支持其他的 MySQL 集群方式。如果用它 替代客户端查询缓存，用户必须手动控制 PECL/mysqlnd_qc。

Support for MySQL replication clusters (asynchronous primary copy) is the main focus of PECL/mysqlnd_ms. The slaves of a MySQL replication cluster may or may not reflect the latest updates from the master. Slaves are asynchronous and can lag behind the master. A read from a slave is eventual consistent from a cluster-wide perspective.

The same level of consistency is offered by a local cache using time-to-live (TTL) invalidation strategy. Current data or stale data may be served. Eventually, data searched for in the cache is not available and the source of the cache needs to be accessed.

Given that both a MySQL Replication slave (asynchronous secondary) and a local TTL-driven cache deliver the same level of service it is possible to transparently replace a remote database access with a local cache access to gain better possibility.

As of PECL/mysqlnd_ms 1.3.0-beta the plugin is capable of transparently controlling PECL/mysqlnd_ms 1.1.0-alpha or newer to cache a read-only query if explicitly allowed by setting an appropriate quality of service through mysqlnd_ms_set_qos(). Please, see the quickstart for a code example. Both plugins must be installed, PECL/mysqlnd_ms must be compiled to support the cache feature and PHP 5.4.0 or newer has to be used.

Applications have full control of cache usage and can request fresh data at any time, if need be. Thec ache usage can be enabled and disabled time during the execution of a script. The cache will be used if mysqlnd_ms_set_qos() sets the quality of service to eventual consistency and enables cache usage. Cache usage is disabled by requesting higher consistency levels, for example, session consistency (read your writes). Once the quality of service has been relaxed to eventual consistency the cache can be used again.

If caching is enabled for a read-only statement, PECL/mysqlnd_ms may inject SQL hints to control caching by PECL/mysqlnd_qc. It may modify the SQL statement it got from the application. Subsequent SQL processors are supposed to ignore the SQL hints. A SQL hint is a SQL comment. Comments must not be ignored, for example, by the database server.

The TTL of a cache entry is computed on a per statement basis. Applications set an maximum age for the data they want to retrieve using mysqlnd_ms_set_qos(). The age sets an approximate upper limit of how many seconds the data returned may lag behind the master.

The following logic is used to compute the actual TTL if caching is enabled. The logic takes the estimated slave lag into account for choosing a TTL. If, for example, there are two slaves lagging 5 and 10 seconds behind and the maximum age allowed is 60 seconds, the TTL is set to 50 seconds. Please note, the age setting is no more than an estimated guess.

  • Check whether the statement is read-only. If not, don't cache.
  • If caching is enabled, check the slave lag of all configured slaves. Establish slave connections if none exist so far and lazy connections are used.
  • Send SHOW SLAVE STATUS to all slaves. Do not wait for the first slave to reply before sending to the second slave. Clients often wait long for replies, thus we send out all requests in a burst before fetching in a second stage.
  • Loop over all slaves. For every slave wait for its reply. Do not start checking another slave before the currently waited for slave has replied. Check for Slave_IO_Running=Yes and Slave_SQL_Running=Yes. If both conditions hold true, fetch the value of Seconds_Behind_Master. In case of any errors or if conditions fail, set an error on the slave connection. Skip any such slave connection for the rest of connection filtering.
  • Search for the maximum value of Seconds_Behind_Master from all slaves that passed the previous conditions. Subtract the value from the maximum age provided by the user with mysqlnd_ms_set_qos(). Use the result as a TTL.
  • The filtering may sort out all slaves. If so, the maximum age is used as TTL, because the maximum lag found equals zero. It is perfectly valid to sort out all slaves. In the following it is up to subsequent filter to decide what to do. The built-in load balancing filter will pick the master.
  • Inject the appropriate SQL hints to enable caching by PECL/mysqlnd_qc.
  • Proceed with the connection filtering, e.g. apply load balancing rules to pick a slave.
  • PECL/mysqlnd_qc is loaded after PECL/mysqlnd_ms by PHP. Thus, it will see all query modifications of PECL/mysqlnd_ms and cache the query if instructed to do so.

The algorithm may seem expensive. SHOW SLAVE STATUS is a very fast operation. Given a sufficient number of requests and cache hits per second the cost of checking the slaves lag can easily outweight the costs of the cache decision.

Suggestions on a better algorithm are always welcome.


Supported clusters

Any application using any kind of MySQL cluster is faced with the same tasks:

  • Identify nodes capable of executing a given statement with the required service level
  • Load balance requests within the list of candidates
  • Automatic fail over within candidates, if needed

The plugin is optimized for fulfilling these tasks in the context of a classical asynchronous MySQL replication cluster consisting of a single master and many slaves (primary copy). When using classical, asynchronous MySQL replication all of the above listed tasks need to be mastered at the client side.

Other types of MySQL cluster may have lower requirements on the application side. For example, if all nodes in the cluster can answer read and write requests, no read-write splitting needs to be done (multi-master, update-all). If all nodes in the cluster are synchronous, they automatically provide the highest possible quality of service which makes choosing a node easier. In this case, the plugin may serve the application after some reconfiguration to disable certain features, such as built-in read-write splitting.

Note: Documentation focus

The documentation focusses describing the use of the plugin with classical asynchronous MySQL replication clusters (primary copy). Support for this kind of cluster has been the original development goal. Use of other clusters is briefly described below. Please note, that this is still work in progress.

Primary copy (MySQL Replication)

This is the primary use case of the plugin. Follow the hints given in the descriptions of each feature.

  • Configure one master and one or more slaves. Server configuration details are given in the setup section.
  • Use random load balancing policy together with the sticky flag.
  • If you do not plan to use the service level API calls, add the master on write flag.
  • Please, make yourself aware of the properties of automatic failover before adding a failover directive.
  • Consider the use of trx_stickiness to execute transactions on the primary only. Please, read carefully how it works before you rely on it.

Example #1 Enabling the plugin (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini

Example #2 Basic plugin configuration (mysqlnd_ms_plugin.ini) for MySQL Replication

{
  "myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      }
    },
    "slave": {
      "slave_0": {
        "host": "127.0.0.1",
        "port": 3308
      },
      "slave_1": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "filters": {
      "random": {
        "sticky": "1"
      }
    }
  }
}

Primary copy with multi primaries (MMM - MySQL Multi Master)

MySQL Replication allows you to create cluster topologies with multiple masters (primaries). Write-write conflicts are not handled by the replication system. This is no update anywhere setup. Thus, data must be partitioned manually and clients must redirected in accordance to the partitioning rules. The recommended setup is equal to the sharding setup below.

Manual sharding, possibly combined with primary copy and multiple primaries

Use SQL hints and the node group filter for clusters that use data partitioning but leave query redirection to the client. The example configuration shows a multi master setup with two shards.

Example #3 Multiple primaries - multi master (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini
mysqlnd_ms.multi_master=1

Example #4 Primary copy with multiple primaries and paritioning

{
  "myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      }
      "master_2": {
        "host": "192.168.2.27",
        "socket": "3306"
      }
    },
    "slave": {
      "slave_1": {
        "host": "127.0.0.1",
        "port": 3308
      },
      "slave_2": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "filters": {
      "node_groups": {
        "Partition_A" : {
          "master": ["master_1"],
          "slave": ["slave_1"]
        },
        "Partition_B" : {
          "master": ["master_2"],
          "slave": ["slave_2"]
        }
      },
      "roundrobin": []
    }
  }
}

The plugin can also be used with a loose collection of unrelated shards. For such a cluster, configure masters only and disable read write splitting. The nodes of such a cluster are called masters in the plugin configuration as they accept both reads and writes for their partition.

Using synchronous update everywhere clusters such as MySQL Cluster

MySQL Cluster is a synchronous cluster solution. All cluster nodes accept read and write requests. In the context of the plugin, all nodes shall be considered as masters.

Use the load balancing and fail over features only.

  • Disable the plugins built-in read-write splitting.
  • Configure masters only.
  • Consider random once load balancing strategy, which is the plugins default. If random once is used, only masters are configured and no SQL hints are used to force using a certain node, no connection switches will happen for the duration of a web request. Thus, no special handling is required for transactions. The plugin will pick one master at the beginning of the PHP script and use it until the script terminates.
  • Do not set the quality of service. All nodes have all the data. This automatically gives you the highest possible service quality (strong consistency).
  • Do not enable client-side global transaction injection. It is neither required to help with server-side fail over nor to assist the quality of service filter choosing an appropriate node.

Disabling built-in read-write splitting.

  • Set mysqlnd_ms.disable_rw_split=1
  • Do not use SQL hints to enforce the use of slaves

Configure masters only.

  • Set mysqlnd_ms.multi_master=1.
  • Do not configure any slaves.
  • Set failover=loop_before_master in the plugins configuration file to avoid warnings about the empty slave list and to make the failover logic loop over all configured masters before emitting an error. Please, note the warnings about automatic failover given in the previous sections.

Example #5 Multiple primaries - multi master (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini
mysqlnd_ms.multi_master=1
mysqlnd_ms.disable_rw_split=1

Example #6 Synchronous update anywhere cluster

"myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      },
      "master_2": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "slave": {
    },
    "filters": {
      "roundrobin": {
      }
    },
    "failover": {
      "strategy": "loop_before_master",
      "remember_failed": true
    }
  }
}

If running an update everywhere cluster that has no built-in partitioning to avoid hot spots and high collision rates, consider using the node groups filter to keep updates on a frequently accessed table on one of the nodes. This may help to reduce collision rates and thus improve performance.


XA/Distributed transactions

Note: Version requirement

XA related functions have been introduced in PECL/mysqlnd_ms version 1.6.0-alpha.

Note: Early adaptors wanted

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments, although early lab tests indicate reasonable quality.

Please, contact the development team if you are interested in this feature. We are looking for real life feedback to complement the feature.

Below is a list of some feature restrictions.

  • The feature is not yet compatible with the MySQL Fabric support . This limitation is soon to be lifted.

    XA transaction identifier are currently restricted to numbers. This limitation will be lifted upon request, it is a simplification used during the initial implementation.

Note: MySQL server restrictions

The XA support by the MySQL server has some restrictions. Most noteably, the servers binary log may lack changes made by XA transactions in case of certain errors. Please, see the MySQL manual for details.

XA/Distributed transactions can spawn multiple MySQL servers. Thus, they may seem like a perfect tool for sharded MySQL clusters, for example, clusters managed with MySQL Fabric. PECL/mysqlnd_ms hides most of the SQL commands to control XA transactions and performs automatic administrative tasks in cases of errors, to provide the user with a comprehensive API. Users should setup the plugin carefully and be well aware of server restrictions prior to using the feature.

Example #1 General pattern for XA transactions

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");

/* BEGIN */
mysqlnd_ms_xa_begin($mysqli, 1 /* xa id */);

/* run queries on various servers */
$mysqli->query("UPDATE some_table SET col_a = 1");
...

/* COMMIT */
mysqlnd_ms_xa_commit($link, 1);
?>

XA transactions use the two-phase commit protocol. The two-phase commit protocol is a blocking protocol. During the first phase participating servers begin a transaction and the client carries out its work. This phase is followed by a second voting phase. During voting, the servers first make a firm promise that they are ready to commit the work even in case of their possible unexpected failure. Should a server crash in this phase, it will still recall the aborted transaction after recover and wait for the client to decide on whether it shall be committed or rolled back.

Should a client that has initiated a global transaction crash after all the participating servers gave their promise to be ready to commit, then the servers must wait for a decision. The servers are not allowed to uniliterally decide on the transaction.

A client crash or disconnect from a participant, a server crash or server error during the fist phase of the protocol is uncritical. In most cases, the server will forget about the XA transaction and its work is rolled back. Additionally, the plugin tries to reach out to as many participants as it can to instruct the server to roll back the work immediately. It is not possible to disable this implicit rollback carried out by PECL/mysqlnd_ms in case of errors during the first phase of the protocol. This design decision has been made to keep the implementation simple.

An error during the second phase of the commit protocol can develop into a more severe situation. The servers will not forget about prepared but unfinished transactions in all cases. The plugin will not attempt to solve these cases immediately but waits for optional background garbage collection to ensure progress of the commit protocol. It is assumed that a solution will take significant time as it may include waiting for a participating server to recover from a crash. This time span may be longer than a developer and end user expects when trying to commit a global transaction with mysqlnd_ms_xa_commit(). Thus, the function returns with the unfinished global transaction still requiring attention. Please, be warned that at this point, it is not yet clear whether the global transaction will be committed or rolled back later on.

Errors during the second phase can be ignored, handled by yourself or solved by the build-int garbage collection logic. Ignoring them is not recommended as you may experience unfinished global transactions on your servers that block resources virtually indefinetly. Handling the errors requires knowing the participants, checking their state and issueing appropriate SQL commands on them. There are no user API calls to expose this very information. You will have to configure a state store and make the plugin record its actions in it to receive the desired facts.

Please, see the quickstart and related plugin configuration file settings for an example how to configure a state. In addition to configuring a state store, you have to setup some SQL tables. The table definitions are given in the description of the plugin configuration settings.

Setting up and configuring a state store is also a precondition for using the built-in garbage collection for XA transactions that fail during the second commit phase. Recording information about ongoing XA transactions is an unavoidable extra task. The extra task consists of updating the state store after each and every operation that changes the state of the global transaction itself (started, committed, rolled back, errors and aborts), the addition of participants (host, optionally user and password required to connect) and any changes to a participants state. Please note, depending on configuration and your security policies, these recordings may be considered sensitive. It is therefore recommended to restrict access to the state store. Unless the state store itself becomes overloaded, writing the state information may contribute noteworthy to the runtime but should overall be only a minor factor.

It is possible that the effort it takes to implement your own routines for handling XA transactions that failed during the second commit phase exceeds the benefits of using the XA feature of PECL/mysqlnd_ms in the first place. Thus, the manual focussed on using the built-on garbage collection only.

Garbage collection can be triggered manually or automatically in the background. You may want to call mysqlnd_ms_xa_gc() immediately after a commit failure to attempt to solve any failed but still open global transactions as soon as possible. You may also decide to disable the automatic background garbage collection, implement your own rule set for invoking the built-in garbage collection and trigger it when desired.

By default the plugin will start the garbage collection with a certain probability in the extensions internal RSHUTDOWN method. The request shutdown is called after your script finished. Whether the garbage collection will be triggered is determined by computing a random value between 1...1000 and comparing it with the configuration setting probability (default: 5). If the setting is greater or equal to the random value, the garbage collection will be triggered.

Once started, the garbage collection acts upon up to max_transactions_per_run (default: 100) global transactions recorded. Records include successfully finished but also unfinished XA transactions. Records for successful transactions are removed and unfinished transactions are attempted to be solved. There are no statistics that help you finding the right balance between keeping garbage collection runs short by limiting the number of transactions considered per run and preventing the garbage collection to fall behind, resulting in many records.

For each failed XA transaction the garbage collection makes max_retries (default: 5) attempts to finish it. After that PECL/mysqlnd_ms gives up. There are two possible reasons for this. Either a participating server crashed and has not become accessible again within max_retries invocations of the garbage collection, or there is a situation that the built-in garbage collection cannot cope with. Likely, the latter would be considered a bug. However, you can manually force more garbage collection runs calling mysqlnd_ms_xa_gc() with the appropriate parameter set. Should even those function runs fail to solve the situation, then the problem must be solved by an operator.

The function mysqlnd_ms_get_stats() provides some statistics on how many XA transactions have been started, committed, failed or rolled back.


安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • Plugin configuration file (>=1.1.x)


需求

PHP 5.3.6 或更高版本，一些建议使用的功能，需要 PHP 5.4.0 或更高版本。

mysqlnd_ms 主从同步和负载均衡插件，可以支持所有的 PHP 应用程序，并且支持所有的 PHP MySQL 扩展 (mysqli, mysql, PDO_MYSQL)。 所有的 PHP MySQL 扩展必须配置为使用 mysqlnd 并且在 mysqlnd 中使用 mysqlnd_ms。


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mysqlnd_ms

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Mysqlnd_ms 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mysqlnd_ms.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.force_config_usage | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.ini_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.config_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.collect_statistics | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.multi_master | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.disable_rw_split | 0 | PHP_INI_SYSTEM |

这是配置指令的简短说明。

mysqlnd_ms.enable integer

是否启动插件，如果禁用插件将不会嵌入 mysqlnd 库中内部 PROXY 调用的 mysqlnd C API 接口。

mysqlnd_ms.force_config_usage integer

如果启用，插件会在每次尝试 MySQL 连接的时候通过配置文件检查服务器参数。如果存在问题， 连接将被阻塞。

这个参数对于运行中的系统没有什么用处，用于调试配置文件。配置文件的作用分为两个阶段。 首先是 PHP 开始接收 WEB 请求时执行，这时插件会读取并且解析配置文件，在这个较早的阶段 中错误信息可能被陷入循环而不会展现给用户。因此缓存这些错误，并且在 MySQL 连接建立的 时候展现给用户。默认情况下，启动时被缓存的错误会产生一个 E_WARNING 级别的错误。如果设定了 force_config_usage 参数，错误类型会变为 E_RECOVERABLE_ERROR 级别。

可以参考 configuration file debugging notes 说明。

mysqlnd_ms.ini_file string

从 1.4.0 版本已经作废，被 mysqlnd_ms.config_file 替代， 指定插件配置文件。

mysqlnd_ms.config_file string

插件的配置文件名称，mysqlnd_ms.ini_file 从 1.4.0 版本作废。

mysqlnd_ms.collect_statistics integer

启动或者禁用统计信息手机，考虑到性能问题默认是禁用的。统计信息可以使用 mysqlnd_ms_get_stats() 获取。

mysqlnd_ms.multi_master integer

是否启动 MySQL multi master 集群，可以参考 supported clusters。

mysqlnd_ms.disable_rw_split integer

启动还是禁用读写分离。

控制负载均衡和连接切换是否会基于读写分离。如果禁用读写分离，只有 master 列表 中的服务器会被用于执行语句，所有 slave 列表中的服务器会被忽略。

SQL hint 中 MYSQLND_MS_USE_SLAVE 不会被识别，语句还是会被 发送个 master 执行。

禁用读写分离会影响 mysqlnd_ms_query_is_select() 的返回值， 函数将不会再返回在 slave 运行的返回值。

Note: Multiple master servers

设置 mysqlnd_ms.multi_master=1 将允许插件使用多台 master 服务器，否则 master 列表中只能有一个服务器。

可以参考 supported clusters 中的说明


Plugin configuration file (>=1.1.x)

The following documentation applies to PECL/mysqlnd_ms >= 1.1.0-beta. It is not valid for prior versions. For documentation covering earlier versions, see the configuration documentation for mysqlnd_ms 1.0.x and below.

Introduction

Note: Changelog: Feature was added in PECL/mysqlnd_ms 1.1.0-beta

The below description applies to PECL/mysqlnd_ms >= 1.1.0-beta. It is not valid for prior versions.

The plugin uses its own configuration file. The configuration file holds information about the MySQL replication master server, the MySQL replication slave servers, the server pick (load balancing) policy, the failover strategy, and the use of lazy connections.

The plugin loads its configuration file at the beginning of a web request. It is then cached in memory and used for the duration of the web request. This way, there is no need to restart PHP after deploying the configuration file. Configuration file changes will become active almost instantly.

The PHP configuration directive mysqlnd_ms.config_file is used to set the plugins configuration file. Please note, that the PHP configuration directive may not be evaluated for every web request. Therefore, changing the plugins configuration file name or location may require a PHP restart. However, no restart is required to read changes if an already existing plugin configuration file is updated.

Using and parsing JSON is efficient, and using JSON makes it easier to express hierarchical data structures than the standard php.ini format.

Example #1 Converting a PHP array (hash) into JSON format

Or alternatively, a developer may be more familiar with the PHP array syntax, and prefer it. This example demonstrates how a developer might convert a PHP array to JSON.

<?php
$config = array(
  "myapp" => array(
    "master" => array(
      "master_0" => array(
        "host"   => "localhost",
        "socket" => "/tmp/mysql.sock",
      ),
    ),
    "slave" => array(),
  ),
);

file_put_contents("mysqlnd_ms.ini", json_encode($config, JSON_PRETTY_PRINT));
printf("mysqlnd_ms.ini file created...\n");
printf("Dumping file contents...\n");
printf("%s\n", str_repeat("-", 80));
echo file_get_contents("mysqlnd_ms.ini");
printf("\n%s\n", str_repeat("-", 80));
?>

以上例程会输出：

mysqlnd_ms.ini file created...
Dumping file contents...
--------------------------------------------------------------------------------
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": [

        ]
    }
}
--------------------------------------------------------------------------------

A plugin configuration file consists of one or more sections. Sections are represented by the top-level object properties of the object encoded in the JSON file. Sections could also be called configuration names.

Applications reference sections by their name. Applications use section names as the host (server) parameter to the various connect methods of the mysqli, mysql and PDO_MYSQL extensions. Upon connect, the mysqlnd plugin compares the hostname with all of the section names from the plugin configuration file. If the hostname and section name match, then the plugin will load the settings for that section.

Example #2 Using section names example

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27"
            },
            "slave_1": {
                "host": "192.168.2.27",
                "port": 3306
            }
        }
    },
    "localhost": {
        "master": [
            {
                "host": "localhost",
                "socket": "\/path\/to\/mysql.sock"
            }
        ],
        "slave": [
            {
                "host": "192.168.3.24",
                "port": "3305"
            },
            {
                "host": "192.168.3.65",
                "port": "3309"
            }
        ]
    }
}
<?php
/* All of the following connections will be load balanced */
$mysqli = new mysqli("myapp", "username", "password", "database");
$pdo = new PDO('mysql:host=myapp;dbname=database', 'username', 'password');
$mysql = mysql_connect("myapp", "username", "password");

$mysqli = new mysqli("localhost", "username", "password", "database");
?>

Section names are strings. It is valid to use a section name such as 192.168.2.1, 127.0.0.1 or localhost. If, for example, an application connects to localhost and a plugin configuration section localhost exists, the semantics of the connect operation are changed. The application will no longer only use the MySQL server running on the host localhost, but the plugin will start to load balance MySQL queries following the rules from the localhost configuration section. This way you can load balance queries from an application without changing the applications source code. Please keep in mind, that such a configuration may not contribute to overall readability of your applications source code. Using section names that can be mixed up with host names should be seen as a last resort.

Each configuration section contains, at a minimum, a list of master servers and a list of slave servers. The master list is configured with the keyword master, while the slave list is configured with the slave keyword. Failing to provide a slave list will result in a fatal E_ERROR level error, although a slave list may be empty. It is possible to allow no slaves. However, this is only recommended with synchronous clusters, please see also supported clusters. The main part of the documentation focusses on the use of asynchronous MySQL replication clusters.

The master and slave server lists can be optionally indexed by symbolic names for the servers they describe. Alternatively, an array of descriptions for slave and master servers may be used.

Example #3 List of anonymous slaves

"slave": [
    {
        "host": "192.168.3.24",
        "port": "3305"
    },
    {
        "host": "192.168.3.65",
        "port": "3309"
    }
]

An anonymous server list is encoded by the JSON array type. Optionally, symbolic names may be used for indexing the slave or master servers of a server list, and done so using the JSON object type.

Example #4 Master list using symbolic names

"master": {
    "master_0": {
        "host": "localhost"
    }
}

It is recommended to index the server lists with symbolic server names. The alias names will be shown in error messages.

The order of servers is preserved and taken into account by mysqlnd_ms. If, for example, you configure round robin load balancing strategy, the first SELECT statement will be executed on the slave that appears first in the slave server list.

A configured server can be described with the host, port, socket, db, user, password and connect_flags. It is mandatory to set the database server host using the host keyword. All other settings are optional.

Example #5 Keywords to configure a server

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "db_server_host",
                "port": "db_server_port",
                "socket": "db_server_socket",
                "db": "database_resp_schema",
                "user": "user",
                "password": "password",
                "connect_flags": 0
            }
        },
        "slave": {
            "slave_0": {
                "host": "db_server_host",
                "port": "db_server_port",
                "socket": "db_server_socket"
            }
        }
    }
}

If a setting is omitted, the plugin will use the value provided by the user API call used to open a connection. Please, see the using section names example above.

The configuration file format has been changed in version 1.1.0-beta to allow for chained filters. Filters are responsible for filtering the configured list of servers to identify a server for execution of a given statement. Filters are configured with the filter keyword. Filters are executed by mysqlnd_ms in the order of their appearance. Defining filters is optional. A configuration section in the plugins configuration file does not need to have a filters entry.

Filters replace the pick[] setting from prior versions. The new random and roundrobin provide the same functionality.

Example #6 New roundrobin filter, old functionality

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.137",
                "port": "3306"
            }
        },
        "filters": {
            "roundrobin": [

            ]
        }
    }
}

The function mysqlnd_ms_set_user_pick_server() has been removed. Setting a callback is now done with the user filter. Some filters accept parameters. The user filter requires and accepts a mandatory callback parameter to set the callback previously set through the function mysqlnd_ms_set_user_pick_server().

Example #7 The user filter replaces mysqlnd_ms_set_user_pick_server()

"filters": {
    "user": {
        "callback": "pick_server"
    }
}

The validity of the configuration file is checked both when reading the configuration file and later when establishing a connection. The configuration file is read during PHP request startup. At this early stage a PHP extension may not display error messages properly. In the worst case, no error is shown and a connection attempt fails without an adequate error message. This problem has been cured in version 1.5.0.

Example #8 Common error message in case of configuration file issues (upto version 1.5.0)

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
?>

以上例程会输出：

Warning: mysqli::mysqli(): (mysqlnd_ms) (mysqlnd_ms) Failed to parse config file [s1.json]. Please, verify the JSON in Command line code

Warning: mysqli::mysqli(): (HY000/2002): php_network_getaddresses: getaddrinfo failed: Name or service not known in Command line code on line 1

Warning: mysqli::query(): Couldn't fetch mysqli in Command line code on line 1

Fatal error: Call to a member function fetch_assoc() on a non-object in Command line code on line 1

Since version 1.5.0 startup errors are additionally buffered and emitted when a connection attempt is made. Use the configuration directive mysqlnd_ms.force_config_usage to set the error type used to display buffered errors. By default an error of type E_WARNING will be emitted.

Example #9 Improved configuration file validation since 1.5.0

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
?>

以上例程会输出：

Warning: mysqli::mysqli(): (mysqlnd_ms) (mysqlnd_ms) Failed to parse config file [s1.json]. Please, verify the JSON in Command line code on line 1

It can be useful to set mysqlnd_ms.force_config_usage = 1 when debugging potential configuration file errors. This will not only turn the type of buffered startup errors into E_RECOVERABLE_ERROR but also help detecting misspelled section names.

Example #10 Possibly more precise error due to mysqlnd_ms.force_config_usage=1

mysqlnd_ms.force_config_usage=1
<?php
$mysqli = new mysqli("invalid_section", "username", "password", "database");
?>

以上例程会输出：

Warning: mysqli::mysqli(): (mysqlnd_ms) Exclusive usage of configuration enforced but did not find the correct INI file section (invalid_section) in Command line code on line 1 line 1

Configuration Directives

Here is a short explanation of the configuration directives that can be used.

master array or object

List of MySQL replication master servers. The list of either of the JSON type array to declare an anonymous list of servers or of the JSON type object. Please, see above for examples.

Setting at least one master server is mandatory. The plugin will issue an error of type E_ERROR if the user has failed to provide a master server list for a configuration section. The fatal error may read (mysqlnd_ms) Section [master] doesn't exist for host [name_of_a_config_section] in %s on line %d.

A server is described with the host, port, socket, db, user, password and connect_flags. It is mandatory to provide at a value for host. If any of the other values is not given, it will be taken from the user API connect call, please, see also: using section names example.

Table of server configuration keywords.

Keyword Description Version
host

Database server host. This is a mandatory setting. Failing to provide, will cause an error of type E_RECOVERABLE_ERROR when the plugin tries to connect to the server. The error message may read (mysqlnd_ms) Cannot find [host] in [%s] section in config in %s on line %d.

Since 1.1.0.
port

Database server TCP/IP port.

Since 1.1.0.
socket

Database server Unix domain socket.

Since 1.1.0.
db

Database (schemata).

Since 1.1.0.
user

MySQL database user.

Since 1.1.0.
password

MySQL database user password.

Since 1.1.0.
connect_flags

Connection flags.

Since 1.1.0.

The plugin supports using only one master server. An experimental setting exists to enable multi-master support. The details are not documented. The setting is meant for development only.

slave array or object

List of one or more MySQL replication slave servers. The syntax is identical to setting master servers, please, see master above for details.

The plugin supports using one or more slave servers.

Setting a list of slave servers is mandatory. The plugin will report an error of the type E_ERROR if slave is not given for a configuration section. The fatal error message may read (mysqlnd_ms) Section [slave] doesn't exist for host [%s] in %s on line %d. Note, that it is valid to use an empty slave server list. The error has been introduced to prevent accidently setting no slaves by forgetting about the slave setting. A master-only setup is still possible using an empty slave server list.

If an empty slave list is configured and an attempt is made to execute a statement on a slave the plugin may emit a warning like mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. upon statement execution. It is possible that another warning follows such as (mysqlnd_ms) No connection selected by the last filter.

global_transaction_id_injection array or object

Global transaction identifier configuration related to both the use of the server built-in global transaction ID feature and the client-side emulation.

Keyword Description Version
fetch_last_gtid

SQL statement for accessing the latest global transaction identifier. The SQL statement is run if the plugin needs to know the most recent global transaction identifier. This can be the case, for example, when checking MySQL Replication slave status. Also used with mysqlnd_ms_get_last_gtid().

Since 1.2.0.
check_for_gtid

SQL statement for checking if a replica has replicated all transactions up to and including ones searched for. The SQL statement is run when searching for replicas which can offer a higher level of consistency than eventual consistency. The statement must contain a placeholder #GTID which is to be replaced with the global transaction identifier searched for by the plugin. Please, check the quickstart for examples.

Since 1.2.0.
report_errors

Whether to emit an error of type warning if an issue occurs while executing any of the configured SQL statements.

Since 1.2.0.
on_commit

Client-side global transaction ID emulation only. SQL statement to run when a transaction finished to update the global transaction identifier sequence number on the master. Please, see the quickstart for examples.

Since 1.2.0.
wait_for_gtid_timeout

Instructs the plugin to wait up to wait_for_gtid_timeout seconds for a slave to catch up when searching for slaves that can deliver session consistency. The setting limits the time spend for polling the slave status. If polling the status takes very long, the total clock time spend waiting may exceed wait_for_gtid_timeout. The plugin calls sleep(1) to sleep one second between each two polls.

The setting can be used both with the plugins client-side emulation and the server-side global transaction identifier feature of MySQL 5.6.

Waiting for a slave to replicate a certain GTID needed for session consistency also means throttling the client. By throttling the client the write load on the master is reduced indirectly. A primary copy based replication system, such as MySQL Replication, is given more time to reach a consistent state. This can be desired, for example, to increase the number of data copies for high availability considerations or to prevent the master from being overloaded.

Since 1.4.0.
fabric object

MySQL Fabric related settings. If the plugin is used together with MySQL Fabric, then the plugins configuration file no longer contains lists of MySQL servers. Instead, the plugin will ask MySQL Fabric which list of servers to use to perform a certain task.

A minimum plugin configuration for use with MySQL Fabric contains a list of one or more MySQL Fabric hosts that the plugin can query. If more than one MySQL Fabric host is configured, the plugin will use a roundrobin strategy to choose among them. Other strategies are currently not available.

Example #11 Minimum pluging configuration for use with MySQL Fabric

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ]
        }
    }
}

Each MySQL Fabric host is described using a JSON object with the following members.

Keyword Description Version
host

Host name of the MySQL Fabric host.

Since 1.6.0.
port

The TCP/IP port on which the MySQL Fabric host listens for remote procedure calls sent by clients such as the plugin.

Since 1.6.0.

The plugin is using PHP streams to communicate with MySQL Fabric through XML RPC over HTTP. By default no timeouts are set for the network communication. Thus, the plugin defaults to PHP stream default timeouts. Those defaults are out of control of the plugin itself.

An optional timeout value can be set to overrule the PHP streams default timeout setting. Setting the timeout in the plugins configuration file has the same effect as setting a timeout for a PHP user space HTTP connection established through PHP streams.

The plugins Fabric timeout value unit is seconds. The allowed value range is from 0 to 65535. The setting exists since version 1.6.

Example #12 Optional timeout for communication with Fabric

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ],
            "timeout": 2
        }
    }
}

Transaction stickiness and MySQL Fabric logic can collide. The stickiness option disables switching between servers for the duration of a transaction. When using Fabric and sharding the user may (erroneously) start a local transaction on one share and then attempt to switch to a different shard using either mysqlnd_ms_fabric_select_shard() or mysqlnd_ms_fabric_select_global(). In this case, the plugin will not reject the request to switch servers in the middle of a transaction but allow the user to switch to another server regardless of the transaction stickiness setting used. It is clearly a user error to write such code.

If transaction stickiness is enabled and you would like to get an error of type warning when calling mysqlnd_ms_fabric_select_shard() or mysqlnd_ms_fabric_select_global(), set the boolean flag trx_warn_server_list_changes.

Example #13 Warnings about the violation of transaction boundaries

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ],
            "trx_warn_serverlist_changes": 1
        },
        "trx_stickiness": "on"
    }
}
<?php
$link = new mysqli("myapp", "root", "", "test");
/*
  For the demo the call may fail.
  Failed or not we get into the state
  needed for the example.
*/
@mysqlnd_ms_fabric_select_global($link, 1);
$link->begin_transaction();
@$link->query("DROP TABLE IF EXISTS test");
/*
  Switching servers/shards is a mistake due to open
  local transaction!
*/
mysqlnd_ms_select_global($link, 1);
?>

以上例程会输出：

PHP Warning: mysqlnd_ms_fabric_select_global(): (mysqlnd_ms) Fabric server exchange in the middle of a transaction in %s on line %d

Please, consider the feature experimental. Changes to syntax and semantics may happen.

filters object

List of filters. A filter is responsible to filter the list of available servers for executing a given statement. Filters can be chained. The random and roundrobin filter replace the pick[] directive used in prior version to select a load balancing policy. The user filter replaces the mysqlnd_ms_set_user_pick_server() function.

Filters may accept parameters to refine their actions.

If no load balancing policy is set, the plugin will default to random_once. The random_once policy picks a random slave server when running the first read-only statement. The slave server will be used for all read-only statements until the PHP script execution ends. No load balancing policy is set and thus, defaulting takes place, if neither the random nor the roundrobin are part of a configuration section.

If a filter chain is configured so that a filter which output no more than once server is used as input for a filter which should be given more than one server as input, the plugin may emit a warning upon opening a connection. The warning may read: (mysqlnd_ms) Error while creating filter '%s' . Non-multi filter '%s' already created. Stopping in %s on line %d. Furthermore, an error of the error code 2000, the sql state HY000 and an error message similar to the warning may be set on the connection handle.

Example #14 Invalid filter sequence

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": [
            "roundrobin",
            "random"
        ]
    }
}
<?php
$link = new mysqli("myapp", "root", "", "test");
printf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error());
$link->query("SELECT 1 FROM DUAL");
?>

以上例程会输出：

PHP Warning:  mysqli::mysqli(): (HY000/2000): (mysqlnd_ms) Error while creating filter 'random' . Non-multi filter 'roundrobin' already created. Stopping in filter_warning.php on line 1
[2000] (mysqlnd_ms) Error while creating filter 'random' . Non-multi filter 'roundrobin' already created. Stopping
PHP Warning:  mysqli::query(): Couldn't fetch mysqli in filter_warning.php on line 3

Filter: random object

The random filter features the random and random once load balancing policies, set through the pick[] directive in older versions.

The random policy will pick a random server whenever a read-only statement is to be executed. The random once strategy picks a random slave server once and continues using the slave for the rest of the PHP web request. Random once is a default, if load balancing is not configured through a filter.

If the random filter is not given any arguments, it stands for random load balancing policy.

Example #15 Random load balancing with random filter

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.137",
                "port": "3306"
            }
        },
        "filters": [
            "random"
        ]
    }
}

Optionally, the sticky argument can be passed to the filter. If the parameter sticky is set to the string 1, the filter follows the random once load balancing strategy.

Example #16 Random once load balancing with random filter

{
    "filters": {
        "random": {
            "sticky": "1"
        }
    }
}

Both the random and roundrobin filters support setting a priority, a weight for a server, since PECL/mysqlnd_ms 1.4.0. If the weight argument is passed to the filter, it must assign a weight for all servers. Servers must be given an alias name in the slave respectively master server lists. The alias must be used to reference servers for assigning a priority with weight.

Example #17 Referencing error

[E_RECOVERABLE_ERROR] mysqli_real_connect(): (mysqlnd_ms) Unknown server 'slave3' in 'random' filter configuration. Stopping in %s on line %d

Using a wrong alias name with weight may result in an error similar to the shown above.

If weight is omitted, the default weight of all servers is one.

Example #18 Assigning a weight for load balancing

{
   "myapp": {
       "master": {
           "master1":{
               "host":"localhost",
               "socket":"\/var\/run\/mysql\/mysql.sock"
           }
       },
       "slave": {
           "slave1": {
               "host":"192.168.2.28",
               "port":3306
           },
           "slave2": {
               "host":"192.168.2.29",
               "port":3306
           },
           "slave3": {
               "host":"192.0.43.10",
               "port":3306
           },
       },
       "filters": {
           "random": {
               "weights": {
                   "slave1":8,
                   "slave2":4,
                   "slave3":1,
                   "master1":1
               }
           }
       }
   }
}

At the average a server assigned a weight of two will be selected twice as often as a server assigned a weight of one. Different weights can be assigned to reflect differently sized machines, to prefer co-located slaves which have a low network latency or, to configure a standby failover server. In the latter case, you may want to assign the standby server a very low weight in relation to the other servers. For example, given the configuration above slave3 will get only some eight percent of the requests in the average. As long as slave1 and slave2 are running, it will be used sparsely, similar to a standby failover server. Upon failure of slave1 and slave2, the usage of slave3 increases. Please, check the notes on failover before using weight this way.

Valid weight values range from 1 to 65535.

Unknown arguments are ignored by the filter. No warning or error is given.

The filter expects one or more servers as input. Outputs one server. A filter sequence such as random, roundrobin may cause a warning and an error message to be set on the connection handle when executing a statement.

List of filter arguments.

Keyword Description Version
sticky

Enables or disabled random once load balancing policy. See above.

Since 1.2.0.
weight

Assigns a load balancing weight/priority to a server. Please, see above for a description.

Since 1.4.0.
Filter: roundrobin object

If using the roundrobin filter, the plugin iterates over the list of configured slave servers to pick a server for statement execution. If the plugin reaches the end of the list, it wraps around to the beginning of the list and picks the first configured slave server.

Example #19 roundrobin filter

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": [
            "roundrobin"
        ]
    }
}

Expects one or more servers as input. Outputs one server. A filter sequence such as roundrobin, random may cause a warning and an error message to be set on the connection handle when executing a statement.

List of filter arguments.

Keyword Description Version
weight

Assigns a load balancing weight/priority to a server. Please, find a description above.

Since 1.4.0.
Filter: user object

The user replaces mysqlnd_ms_set_user_pick_server() function, which was removed in 1.1.0-beta. The filter sets a callback for user-defined read/write splitting and server selection.

The plugins built-in read/write query split mechanism decisions can be overwritten in two ways. The easiest way is to prepend a query string with the SQL hints MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH or MYSQLND_MS_LAST_USED_SWITCH. Using SQL hints one can control, for example, whether a query shall be send to the MySQL replication master server or one of the slave servers. By help of SQL hints it is not possible to pick a certain slave server for query execution.

Full control on server selection can be gained using a callback function. Use of a callback is recommended to expert users only because the callback has to cover all cases otherwise handled by the plugin.

The plugin will invoke the callback function for selecting a server from the lists of configured master and slave servers. The callback function inspects the query to run and picks a server for query execution by returning the hosts URI, as found in the master and slave list.

If the lazy connections are enabled and the callback chooses a slave server for which no connection has been established so far and establishing the connection to the slave fails, the plugin will return an error upon the next action on the failed connection, for example, when running a query. It is the responsibility of the application developer to handle the error. For example, the application can re-run the query to trigger a new server selection and callback invocation. If so, the callback must make sure to select a different slave, or check slave availability, before returning to the plugin to prevent an endless loop.

Example #20 Setting a callback

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "user": {
                "callback": "pick_server"
            }
        }
    }
}

The callback is supposed to return a host to run the query on. The host URI is to be taken from the master and slave connection lists passed to the callback function. If callback returns a value neither found in the master nor in the slave connection lists the plugin will emit an error of the type E_RECOVERABLE_ERROR The error may read like (mysqlnd_ms) User filter callback has returned an unknown server. The server 'server that is not in master or slave list' can neither be found in the master list nor in the slave list. If the application catches the error to ignore it, follow up errors may be set on the connection handle, for example, (mysqlnd_ms) No connection selected by the last filter with the error code 2000 and the sqlstate HY000. Furthermore a warning may be emitted.

Referencing a non-existing function as a callback will result in any error of the type E_RECOVERABLE_ERROR whenever the plugin tries to callback function. The error message may reads like: (mysqlnd_ms) Specified callback (pick_server) is not a valid callback. If the application catches the error to ignore it, follow up errors may be set on the connection handle, for example, (mysqlnd_ms) Specified callback (pick_server) is not a valid callback with the error code 2000 and the sqlstate HY000. Furthermore a warning may be emitted.

The following parameters are passed from the plugin to the callback.

Parameter Description Version
connected_host

URI of the currently connected database server.

Since 1.1.0.
query

Query string of the statement for which a server needs to be picked.

Since 1.1.0.
masters

List of master servers to choose from. Note, that the list of master servers may not be identical to the list of configured master servers if the filter is not the first in the filter chain. Previously run filters may have reduced the master list already.

Since 1.1.0.
slaves

List of slave servers to choose from. Note, that the list of master servers may not be identical to the list of configured master servers if the filter is not the first in the filter chain. Previously run filters may have reduced the master list already.

Since 1.1.0.
last_used_connection

URI of the server of the connection used to execute the previous statement on.

Since 1.1.0.
in_transaction

Boolean flag indicating whether the statement is part of an open transaction. If autocommit mode is turned off, this will be set to true. Otherwise it is set to false.

Transaction detection is based on monitoring the mysqlnd library call set_autocommit. Monitoring is not possible before PHP 5.4.0. Please, see connection pooling and switching concepts discussion for further details.

Since 1.1.0.

Example #21 Using a callback

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "user": {
                "callback": "pick_server"
            }
        }
    }
}
<?php
function pick_server($connected, $query, $masters, $slaves, $last_used_connection, $in_transaction)
{
 static $slave_idx = 0;
 static $num_slaves = NULL;
 if (is_null($num_slaves))
  $num_slaves = count($slaves);

 /* default: fallback to the plugins build-in logic */
 $ret = NULL;

 printf("User has connected to '%s'...\n", $connected);
 printf("... deciding where to run '%s'\n", $query);

 $where = mysqlnd_ms_query_is_select($query);
 switch ($where)
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("... using master\n");
   $ret = $masters[0];
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   /* SELECT or SQL hint for using slave */
   if (stristr($query, "FROM table_on_slave_a_only"))
   {
    /* a table which is only on the first configured slave  */
    printf("... access to table available only on slave A detected\n");
    $ret = $slaves[0];
   }
   else
   {
    /* round robin */
    printf("... some read-only query for a slave\n");
    $ret = $slaves[$slave_idx++ % $num_slaves];
   }
   break;
  case MYSQLND_MS_QUERY_LAST_USED:
   printf("... using last used server\n");
   $ret = $last_used_connection;
   break;
 }

 printf("... ret = '%s'\n", $ret);
 return $ret;
}

$mysqli = new mysqli("myapp", "root", "", "test");

if (!($res = $mysqli->query("SELECT 1 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT 2 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT * FROM table_on_slave_a_only")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

$mysqli->close();
?>

以上例程会输出：

User has connected to 'myapp'...
... deciding where to run 'SELECT 1 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.2.27:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT 2 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.78.136:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT * FROM table_on_slave_a_only'
... access to table available only on slave A detected
... ret = 'tcp://192.168.2.27:3306'

Filter: user_multi object

The user_multi differs from the user only in one aspect. Otherwise, their syntax is identical. The user filter must pick and return exactly one node for statement execution. A filter chain usually ends with a filter that emits only one node. The filter chain shall reduce the list of candidates for statement execution down to one. This, only one node left, is the case after the user filter has been run.

The user_multi filter is a multi filter. It returns a list of slave and a list of master servers. This list needs further filtering to identify exactly one node for statement execution. A multi filter is typically placed at the top of the filter chain. The quality_of_service filter is another example of a multi filter.

The return value of the callback set for user_multi must be an array with two elements. The first element holds a list of selected master servers. The second element contains a list of selected slave servers. The lists shall contain the keys of the slave and master servers as found in the slave and master lists passed to the callback. The below example returns random master and slave lists extracted from the functions input.

Example #22 Returning random masters and slaves

<?php
function pick_server($connected, $query, $masters, $slaves, $last_used_connection, $in_transaction)
{
  $picked_masters = array()
  foreach ($masters as $key => $value) {
    if (mt_rand(0, 2) > 1)
      $picked_masters[] = $key;
  }
  $picked_slaves = array()
  foreach ($slaves as $key => $value) {
    if (mt_rand(0, 2) > 1)
      $picked_slaves[] = $key;
  }
  return array($picked_masters, $picked_slaves);
}
?>

The plugin will issue an error of type E_RECOVERABLE if the callback fails to return a server list. The error may read (mysqlnd_ms) User multi filter callback has not returned a list of servers to use. The callback must return an array in %s on line %d. In case the server list is not empty but has invalid servers key/ids in it, an error of type E_RECOVERABLE will the thrown with an error message like (mysqlnd_ms) User multi filter callback has returned an invalid list of servers to use. Server id is negative in %s on line %d, or similar.

Whether an error is emitted in case of an empty slave or master list depends on the configuration. If an empty master list is returned for a write operation, it is likely that the plugin will emit a warning that may read (mysqlnd_ms) Couldn't find the appropriate master connection. 0 masters to choose from. Something is wrong in %s on line %d. Typically a follow up error of type E_ERROR will happen. In case of a read operation and an empty slave list the behavior depends on the fail over configuration. If fail over to master is enabled, no error should appear. If fail over to master is deactivated the plugin will emit a warning that may read (mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. Something is wrong in %s on line %d.

Filter: node_groups object

The node_groups filter lets you group cluster nodes and query selected groups, for example, to support data partitioning. Data partitioning can be required for manual sharding, primary copy based clusters running multiple masters, or to avoid hot spots in update everywhere clusters that have no built-in partitioning. The filter is a multi filter which returns zero, one or multiple of its input servers. Thus, it must be followed by other filters to reduce the number of candidates down to one for statement execution.

Keyword Description Version
user defined node group name

One or more node groups must be defined. A node group can have an arbitrary user defined name. The name is used in combination with a SQL hint to restrict query execution to the nodes listed for the node group. To run a query on any of the servers of a node group, the query must begin with the SQL hint /*user defined node group name*/. Please note, no white space is allowed around user defined node group name. Because user defined node group name is used as-is as part of a SQL hint, you should choose the name that is compliant with the SQL language.

Each node group entry must contain a list of master servers. Additional slave servers are allowed. Failing to provide a list of master for a node group name_of_group may cause an error of type E_RECOVERABLE_ERROR like (mysqlnd_ms) No masters configured in node group 'name_of_group' for 'node_groups' filter.

The list of master and slave servers must reference corresponding entries in the global master respectively slave server list. Referencing an unknown server in either of the both server lists may cause an E_RECOVERABLE_ERROR error like (mysqlnd_ms) Unknown master 'server_alias_name' (section 'name_of_group') in 'node_groups' filter configuration.

Example #23 Manual partitioning

{
  "myapp": {
       "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.28",
                "port": 3306
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
        "filters": {
            "node_groups": {
                "Partition_A" : {
                    "master": ["master_0"],
                    "slave": ["slave_0"]
                }
            },
           "roundrobin": []
        }
    }
}

Please note, if a filter chain generates an empty slave list and the PHP configuration directive mysqlnd_ms.multi_master=0 is used, the plugin may emit a warning.

Since 1.5.0.
Filter: quality_of_service object

The quality_of_service identifies cluster nodes capable of delivering a certain quality of service. It is a multi filter which returns zero, one or multiple of its input servers. Thus, it must be followed by other filters to reduce the number of candidates down to one for statement execution.

The quality_of_service filter has been introduced in 1.2.0-alpha. In the 1.2 series the filters focus is on the consistency aspect of service quality. Different types of clusters offer different default data consistencies. For example, an asynchronous MySQL replication slave offers eventual consistency. The slave may not be able to deliver requested data because it has not replicated the write, it may serve stale database because its lagging behind or it may serve current information. Often, this is acceptable. In some cases higher consistency levels are needed for the application to work correct. In those cases, the quality_of_service can filter out cluster nodes which cannot deliver the necessary quality of service.

The quality_of_service filter can be replaced or created at runtime. A successful call to mysqlnd_ms_set_qos() removes all existing qos filter entries from the filter list and installs a new one at the very beginning. All settings that can be made through mysqlnd_ms_set_qos() can also be in the plugins configuration file. However, use of the function is by far the most common use case. Instead of setting session consistency and strong consistency service levels in the plugins configuration file it is recommended to define only masters and no slaves. Both service levels will force the use of masters only. Using an empty slave list shortens the configuration file, thus improving readability. The only service level for which there is a case of defining in the plugins configuration file is the combination of eventual consistency and maximum slave lag.

Keyword Description Version
eventual_consistency

Request eventual consistency. Allows the use of all master and slave servers. Data returned may or may not be current.

Eventual consistency accepts an optional age parameter. If age is given the plugin considers only slaves for reading for which MySQL replication reports a slave lag less or equal to age. The replication lag is measure using SHOW SLAVE STATUS. If the plugin fails to fetch the replication lag, the slave tested is skipped. Implementation details and tips are given in the quality of service concepts section.

Please note, if a filter chain generates an empty slave list and the PHP configuration directive mysqlnd_ms.multi_master=0 is used, the plugin may emit a warning.

Example #24 Global limit on slave lag

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "quality_of_service": {
                "eventual_consistency": {
                    "age":123
                }
            }
        }
    }
}

 Since 1.2.0.
session_consistency

Request session consistency (read your writes). Allows use of all masters and all slaves which are in sync with the master. If no further parameters are given slaves are filtered out as there is no reliable way to test if a slave has caught up to the master or is lagging behind. Please note, if a filter chain generates an empty slave list and the PHP configuration directive mysqlnd_ms.multi_master=0 is used, the plugin may emit a warning.

Session consistency temporarily requested using mysqlnd_ms_set_qos() is a valuable alternative to using master_on_write. master_on_write is likely to send more statements to the master than needed. The application may be able to continue operation at a lower consistency level after it has done some critical reads.

Since 1.1.0.
strong_consistency

Request strong consistency. Only masters will be used.

Since 1.2.0.
failover Up to and including 1.3.x: string. Since 1.4.0: object.

Failover policy. Supported policies: disabled (default), master, loop_before_master (Since 1.4.0).

If no failover policy is set, the plugin will not do any automatic failover (failover=disabled). Whenever the plugin fails to connect a server it will emit a warning and set the connections error code and message. Thereafter it is up to the application to handle the error and, for example, resent the last statement to trigger the selection of another server.

Please note, the automatic failover logic is applied when opening connections only. Once a connection has been opened no automatic attempts are made to reopen it in case of an error. If, for example, the server a connection is connected to is shut down and the user attempts to run a statement on the connection, no automatic failover will be tried. Instead, an error will be reported.

If using failover=master the plugin will implicitly failover to a master, if available. Please check the concepts documentation to learn about potential pitfalls and risks of using failover=master.

Example #25 Optional master failover when failing to connect to slave (PECL/mysqlnd_ms < 1.4.0)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "failover": "master"
    }
}

Since PECL/mysqlnd_ms 1.4.0 the failover configuration keyword refers to an object.

Example #26 New syntax since 1.4.0

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "failover": {"strategy": "master" }
    }
}

Keyword Description Version
strategy

Failover policy. Possible values: disabled (default), master, loop_before_master

A value of disabled disables automatic failover.

Setting master instructs the plugin to try to connect to a master in case of a slave connection error. If the master connection attempt fails, the plugin exists the failover loop and returns an error to the user.

If using loop_before_master and a slave request is made, the plugin tries to connect to other slaves before failing over to a master. If multiple master are given and multi master is enabled, the plugin also loops over the list of masters and attempts to connect before returning an error to the user.

Since 1.4.0.
remember_failed

Remember failures for the duration of a web request. Default: false.

If set to true the plugin will remember failed hosts and skip the hosts in all future load balancing made for the duration of the current web request.

Since 1.4.0. The feature is only available together with the random and roundrobin load balancing filter. Use of the setting is recommended.
max_retries

Maximum number of connection attempts before skipping host. Default: 0 (no limit).

The setting is used to prevent hosts from being dropped of the host list upon the first failure. If set to n > 0, the plugin will keep the node in the node list even after a failed connection attempt. The node will not be removed immediately from the slave respectively master lists after the first connection failure but instead be tried to connect to up to n times in future load balancing rounds before being removed.

Since 1.4.0. The feature is only available together with the random and roundrobin load balancing filter.

Setting failover to any other value but disabled, master or loop_before_master will not emit any warning or error.

lazy_connections bool

Controls the use of lazy connections. Lazy connections are connections which are not opened before the client sends the first connection. Lazy connections are a default.

It is strongly recommended to use lazy connections. Lazy connections help to keep the number of open connections low. If you disable lazy connections and, for example, configure one MySQL replication master server and two MySQL replication slaves, the plugin will open three connections upon the first call to a connect function although the application might use the master connection only.

Lazy connections bare a risk if you make heavy use of actions which change the state of a connection. The plugin does not dispatch all state changing actions to all connections from the connection pool. The few dispatched actions are applied to already opened connections only. Lazy connections opened in the future are not affected. Only some settings are "remembered" and applied when lazy connections are opened.

Example #27 Disabling lazy connection

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "lazy_connections": 0
    }
}

Please, see also server_charset to overcome potential problems with string escaping and servers using different default charsets.

server_charset string

The setting has been introduced in 1.4.0. It is recommended to set it if using lazy connections.

The server_charset setting serves two purposes. It acts as a fallback charset to be used for string escaping done before a connection has been established and it helps to avoid escaping pitfalls in heterogeneous environments which servers using different default charsets.

String escaping takes a connections charset into account. String escaping is not possible before a connection has been opened and the connections charset is known. The use of lazy connections delays the actual opening of connections until a statement is send.

An application using lazy connections may attempt to escape a string before sending a statement. In fact, this should be a common case as the statement string may contain the string that is to be escaped. However, due to the lazy connection feature no connection has been opened yet and escaping fails. The plugin may report an error of the type E_WARNING and a message like (mysqlnd_ms) string escaping doesn't work without established connection. Possible solution is to add server_charset to your configuration to inform you of the pitfall.

Setting server_charset makes the plugin use the given charset for string escaping done on lazy connection handles before establishing a network connection to MySQL. Furthermore, the plugin will enforce the use of the charset when the connection is established.

Enforcing the use of the configured charset used for escaping is done to prevent tapping into the pitfall of using a different charset for escaping than used later for the connection. This has the additional benefit of removing the need to align the charset configuration of all servers used. No matter what the default charset on any of the servers is, the plugin will set the configured one as a default.

The plugin does not stop the user from changing the charset at any time using the set_charset() call or corresponding SQL statements. Please, note that the use of SQL is not recommended as it cannot be monitored by the plugin. The user can, for example, change the charset on a lazy connection handle after escaping a string and before the actual connection is opened. The charset set by the user will be used for any subsequent escaping before the connection is established. The connection will be established using the configured charset, no matter what the server charset is or what the user has set before. Once a connection has been opened, set_charset is of no meaning anymore.

Example #28 String escaping on a lazy connection handle

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "lazy_connections": 1,
        "server_charset" : "utf8"
    }
}
<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
$mysqli->real_escape("this will be escaped using the server_charset setting - utf8");
$mysqli->set_charset("latin1");
$mysqli->real_escape("this will be escaped using latin1");
/* server_charset implicitly set - utf8 connection */
$mysqli->query("SELECT 'This connection will be set to server_charset upon establishing' AS _msg FROM DUAL");
/* latin1 used from now on */
$mysqli->set_charset("latin1");
?>

master_on_write bool

If set, the plugin will use the master server only after the first statement has been executed on the master. Applications can still send statements to the slaves using SQL hints to overrule the automatic decision.

The setting may help with replication lag. If an application runs an INSERT the plugin will, by default, use the master to execute all following statements, including SELECT statements. This helps to avoid problems with reads from slaves which have not replicated the INSERT yet.

Example #29 Master on write for consistent reads

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "master_on_write": 1
    }
}

Please, note the quality_of_service filter introduced in version 1.2.0-alpha. It gives finer control, for example, for achieving read-your-writes and, it offers additional functionality introducing service levels.

All transaction stickiness settings, including trx_stickiness=on, are overruled by master_on_write=1.

trx_stickiness string

Transaction stickiness policy. Supported policies: disabled (default), master.

The setting requires 5.4.0 or newer. If used with PHP older than 5.4.0, the plugin will emit a warning like (mysqlnd_ms) trx_stickiness strategy is not supported before PHP 5.3.99.

If no transaction stickiness policy is set or, if setting trx_stickiness=disabled, the plugin is not transaction aware. Thus, the plugin may load balance connections and switch connections in the middle of a transaction. The plugin is not transaction safe. SQL hints must be used avoid connection switches during a transaction.

As of PHP 5.4.0 the mysqlnd library allows the plugin to monitor the autocommit mode set by calls to the libraries set_autocommit() function. If setting set_stickiness=master and autocommit gets disabled by a PHP MySQL extension invoking the mysqlnd library internal function call set_autocommit(), the plugin is made aware of the begin of a transaction. Then, the plugin stops load balancing and directs all statements to the master server until autocommit is enabled. Thus, no SQL hints are required.

An example of a PHP MySQL API function calling the mysqlnd library internal function call set_autocommit() is mysqli_autocommit().

Although setting trx_stickiness=master, the plugin cannot be made aware of autocommit mode changes caused by SQL statements such as SET AUTOCOMMIT=0 or BEGIN.

As of PHP 5.5.0, the mysqlnd library features additional C API calls to control transactions. The level of control matches the one offered by SQL statements. The mysqli API has been modified to use these calls. Since version 1.5.0, PECL/mysqlnd_ms can monitor not only mysqli_autocommit(), but also mysqli_begin(), mysqli_commit() and mysqli_rollback() to detect transaction boundaries and stop load balancing for the duration of a transaction.

Example #30 Using master to execute transactions

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "trx_stickiness": "master"
    }
}

Since version 1.5.0 automatic and silent failover is disabled for the duration of a transaction. If the boundaries of a transaction have been properly detected, transaction stickiness is enabled and a server fails, the plugin will not attempt to fail over to the next server, if any, regardless of the failover policy configured. The user must handle the error manually. Depending on the configuration, the plugin may emit an error of type E_WARNING reading like (mysqlnd_ms) Automatic failover is not permitted in the middle of a transaction. This error may then be overwritten by follow up errors such as (mysqlnd_ms) No connection selected by the last filter. Those errors will be generated by the failing query function.

Example #31 No automatic failover, error handling pitfall

<?php
/* assumption: automatic failover configured */
$mysqli = new mysqli("myapp", "username", "password", "database");

/* sets plugin internal state in_trx = 1 */
$mysqli->autocommit(false);

/* assumption: server fails */
if (!($res = $mysqli->query("SELECT 'Assume this query fails' AS _msg FROM DUAL"))) {
 /* handle failure of transaction, plugin internal state is still in_trx = 1 */
 printf("[%d] %s", $mysqli->errno, $mysqli->error);
 /*
  If using autocommit() based transaction detection it is a
  MUST to call autocommit(true). Otherwise the plugin assumes
  the current transaction continues and connection
  changes remain forbidden.
 */
 $mysqli->autocommit(true);
 /* Likewise, you'll want to start a new transaction */
 $mysqli->autocommit(false);
}
/* latin1 used from now on */
$mysqli->set_charset("latin1");
?>

If a server fails in the middle of a transaction the plugin continues to refuse to switch connections until the current transaction has been finished. Recall that the plugin monitors API calls to detect transaction boundaries. Thus, you have to, for example, enable auto commit mode to end the current transaction before the plugin continues load balancing and switches the server. Likewise, you will want to start a new transaction immediately thereafter and disable auto commit mode again.

Not handling failed queries and not ending a failed transaction using API calls may cause all following commands emit errors such as Commands out of sync; you can't run this command now. Thus, it is important to handle all errors.

transient_error object

The setting has been introduced in 1.6.0.

A database cluster node may reply a transient error to a client. The client can then repeat the operation on the same node, fail over to a different node or abort the operation. Per definition is it safe for a client to retry the same operation on the same node before giving up.

PECL/mysqlnd_ms can perform the retry loop on behalf of the application. By configuring transient_error the plugin can be instructed to repeat operations failing with a certain error code for a certain maximum number of times with a pause between the retries. If the transient error disappears during loop execution, it is hidden from the application. Otherwise, the error is forwarded to the application by the end of the loop.

Example #32 Retry loop for transient errors

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
       },
       "transient_error": {
          "mysql_error_codes": [
            1297
          ],
          "max_retries": 2,
          "usleep_retry": 100
       }
    }
}

Keyword Description Version
mysql_error_codes

List of transient error codes. You may add any MySQL error code to the list. It is possible to consider any error as transient not only 1297 (HY000 (ER_GET_TEMPORARY_ERRMSG), Message: Got temporary error %d '%s' from %s). Before adding other codes but 1297 to the list, make sure your cluster supports a new attempt without impacting the state of your application.

Since 1.6.0.
max_retries

How often to retry an operation which fails with a transient error before forwarding the failure to the user.

Default: 1

Since 1.6.0.
usleep_retry

Milliseconds to sleep between transient error retries. The value is passed to the C function usleep(), hence the name.

Default: 100

Since 1.6.0.
xa object

The setting has been introduced in 1.6.0.

Note: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

state_store
record_participant_credentials

Whether to store the username and password of a global transaction participant in the participants table. If disabled, the garbage collection will use the default username and password when connecting to the participants. Unless you are using a different username and password for each of your MySQL servers, you can use the default and avoid storing the sensible information in state store.

Please note, username and password are stored in clear text when using the MySQL state store, which is the only one available. It is in your responsibility to protect this sensible information.

Default: false

participant_localhost_ip

During XA garbage collection the plugin may find a participant server for which the host localhost has been recorded. If the garbage collection takes place on another host but the host that has written the participant record to the state store, the host name localhost now resolves to a different host. Therefore, when recording a participant servers host name in the state store, a value of localhost must be replaced with the actual IP address of localhost.

Setting participant_localhost_ip should be considered only if using localhost cannot be avoided. From a garbage collection point of view only, it is preferrable not to configure any socket connection but to provide an IP address and port for a node.

mysql

The MySQL state store is the only state store available.

global_trx_table

Name of the MySQL table used to store the state of an ongoing or aborted global transaction. Use the below SQL statement to create the table. Make sure to edit the table name to match your configuration.

Default: mysqlnd_ms_xa_trx

Example #33 SQL definition for the MySQL state store transaction table

CREATE TABLE mysqlnd_ms_xa_trx (
  store_trx_id int(11) NOT NULL AUTO_INCREMENT,
  gtrid int(11) NOT NULL,
  format_id int(10) unsigned NOT NULL DEFAULT '1',
  state enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK') NOT NULL DEFAULT 'XA_NON_EXISTING',
  intend enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK') DEFAULT 'XA_NON_EXISTING',
  finished enum('NO','SUCCESS','FAILURE') NOT NULL DEFAULT 'NO',
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  started datetime DEFAULT NULL,
  timeout datetime DEFAULT NULL,
  PRIMARY KEY (store_trx_id),
  KEY idx_xa_id (gtrid,format_id,finished),
  KEY idx_state (state)
) ENGINE=InnoDB

participant_table

Name of the MySQL table used to store participants of an ongoing or aborted global transaction. Use the below SQL statement to create the table. Make sure to edit the table name to match your configuration.

Storing credentials can be enabled and disabled using record_participant_credentials

Default: mysqlnd_ms_xa_participants

Example #34 SQL definition for the MySQL state store transaction table

CREATE TABLE mysqlnd_ms_xa_participants (
  fk_store_trx_id int(11) NOT NULL,
  bqual varbinary(64) NOT NULL DEFAULT '',
  participant_id int(10) unsigned NOT NULL AUTO_INCREMENT,
  server_uuid varchar(127) DEFAULT NULL,
  scheme varchar(1024) NOT NULL,
  host varchar(127) DEFAULT NULL,
  port smallint(5) unsigned DEFAULT NULL,
  socket varchar(127) DEFAULT NULL,
  user varchar(127) DEFAULT NULL,
  password varchar(127) DEFAULT NULL,
  state enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK')
   NOT NULL DEFAULT 'XA_NON_EXISTING',
  health enum('OK','GC_DONE','CLIENT ERROR','SERVER ERROR') NOT NULL DEFAULT 'OK',
  connection_id int(10) unsigned DEFAULT NULL,
  client_errno smallint(5) unsigned DEFAULT NULL,
  client_error varchar(1024) DEFAULT NULL,
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  PRIMARY KEY (participant_id),
  KEY idx_xa_bqual (bqual),
  KEY idx_store_trx (fk_store_trx_id),
  CONSTRAINT mysqlnd_ms_xa_participants_ibfk_1 FOREIGN KEY (fk_store_trx_id)
    REFERENCES mysqlnd_ms_xa_trx (store_trx_id) ON DELETE CASCADE ON UPDATE CASCADE
) ENGINE=InnoDB
garbage_collection_table

Name of the MySQL table used to track and synchronize garbage collection runs. Use the below SQL statement to create the table. Make sure to edit the table name to match your configuration.

Default: mysqlnd_ms_xa_gc

Example #35 SQL definition for the MySQL state store garbage collection table

CREATE TABLE mysqlnd_ms_xa_gc (
  gc_id int(10) unsigned NOT NULL AUTO_INCREMENT,
  gtrid int(11) NOT NULL,
  format_id int(10) unsigned NOT NULL DEFAULT '1',
  fk_store_trx_id int(11) DEFAULT NULL,
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  attempts smallint(5) unsigned NOT NULL DEFAULT '0',
  PRIMARY KEY (gc_id),
  KEY idx_store_trx (gtrid,format_id,fk_store_trx_id)
) ENGINE=InnoDB
host

Host name of the MySQL server.

user

Name of the user used to connect to the MySQL server.

password

Password for the MySQL server user.

db

Database that holds the garbage collection tables. Please note, you have to create the garbage collection tables prior to using the plugin. The tables will not be created implicitly during runtime but garbage collection will fail if the tables to not exist.

port

Port of the MySQL server.

socket

Unix domain socket of the MySQL server. Please note, if you have multiple PHP servers each of them will try to carry out garbage collection and need to be able to connect to the state store. In this case, you may prefer configuring an IP address and a port for the MySQL state store server to ensure all PHP servers can reach it.

rollback_on_close

Whether to automatically rollback an open global transaction when a connection is closed. If enabled, it mimics the default behaviour of local transactions. Should a client disconnect, the server rolls back any open and unfinished transactions.

Default: true

garbage_collection
max_retries

Maximum number of garbage collection runs before giving up. Allowed values are from 0 to 100. A setting of 0 means no limit, unless the state store enforces a limit. Should the state store enforce a limit, it can be supposed to be significantly higher than 100. Available since 1.6.0.

Please note, it is important to end failed XA transactions within reasonable time to make participating servers free resources bound to the transaction. The built-in garbage collection is not expected to fail for a long period as long as crashed servers become available again quickly. Still, a situation may arise where a human is required to act because the built-in garbage collection stopped or failed. In this case, you may first want to check if the transaction still cannot be fixed by forcing mysqlnd_ms_xa_gc() to ignore the setting, prior to handling it manually.

Default: 5

probability

Garbage collection probability. Allowed values are from 0 to 1000. A setting of 0 disables automatic background garbage collection. Despite a setting of 0 it is still possible to trigger garbage collection by calling mysqlnd_ms_gc(). Available since 1.6.0.

The automatic garbage collection of stalled XA transaction is only available if a state store have been configured. The state store is responsible to keep track of XA transactions. Based on its recordings it can find blocked XA transactions where the client has crashed, connect to the participants and rollback the unfinished transactions.

The garbage collection is triggered as part of PHP's request shutdown procedure at the end of a web request. That is after your PHP script has finished working. Do decide whether to run the garbage collection a random value between 0 and 1000 is computed. If the probability value is higher or equal to the random value, the state stores garbage collection routines are invoked.

Default: 5

max_transactions_per_run

Maximum number of unfinished XA transactions considered by the garbage collection during one run. Allowed values are from 1 to 32768. Available since 1.6.0.

Cleaning up an unfinished XA transaction takes considerable amounts of time and resources. The garbage collection routine may have to connect to several participants of a failed global transaction to issue the SQL commands for rolling back the unfinished tranaction.

Default: 100

Plugin configuration file (<= 1.0.x)

Note:

The below description applies to PECL/mysqlnd_ms < 1.1.0-beta. It is not valid for later versions.

The plugin is using its own configuration file. The configuration file holds information on the MySQL replication master server, the MySQL replication slave servers, the server pick (load balancing) policy, the failover strategy and the use of lazy connections.

The PHP configuration directive mysqlnd_ms.ini_file is used to set the plugins configuration file.

The configuration file mimics standard the php.ini format. It consists of one or more sections. Every section defines its own unit of settings. There is no global section for setting defaults.

Applications reference sections by their name. Applications use section names as the host (server) parameter to the various connect methods of the mysqli, mysql and PDO_MYSQL extensions. Upon connect the mysqlnd plugin compares the hostname with all section names from the plugin configuration file. If hostname and section name match, the plugin will load the sections settings.

Example #36 Using section names example

[myapp]
master[] = localhost
slave[] = 192.168.2.27
slave[] = 192.168.2.28:3306
[localhost]
master[] = localhost:/tmp/mysql/mysql.sock
slave[] = 192.168.3.24:3305
slave[] = 192.168.3.65:3309
<?php
/* All of the following connections will be load balanced */
$mysqli = new mysqli("myapp", "username", "password", "database");
$pdo = new PDO('mysql:host=myapp;dbname=database', 'username', 'password');
$mysql = mysql_connect("myapp", "username", "password");

$mysqli = new mysqli("localhost", "username", "password", "database");
?>

Section names are strings. It is valid to use a section name such as 192.168.2.1, 127.0.0.1 or localhost. If, for example, an application connects to localhost and a plugin configuration section [localhost] exists, the semantics of the connect operation are changed. The application will no longer only use the MySQL server running on the host localhost but the plugin will start to load balance MySQL queries following the rules from the [localhost] configuration section. This way you can load balance queries from an application without changing the applications source code.

The master[], slave[] and pick[] configuration directives use a list-like syntax. Configuration directives supporting list-like syntax may appear multiple times in a configuration section. The plugin maintains the order in which entries appear when interpreting them. For example, the below example shows two slave[] configuration directives in the configuration section [myapp]. If doing round-robin load balancing for read-only queries, the plugin will send the first read-only query to the MySQL server mysql_slave_1 because it is the first in the list. The second read-only query will be send to the MySQL server mysql_slave_2 because it is the second in the list. Configuration directives supporting list-like syntax result are ordered from top to bottom in accordance to their appearance within a configuration section.

Example #37 List-like syntax

[myapp]
master[] = mysql_master_server
slave[] = mysql_slave_1
slave[] = mysql_slave_2

Here is a short explanation of the configuration directives that can be used.

master[] string

URI of a MySQL replication master server. The URI follows the syntax hostname[:port|unix_domain_socket].

The plugin supports using only one master server.

Setting a master server is mandatory. The plugin will report a warning upon connect if the user has failed to provide a master server for a configuration section. The warning may read (mysqlnd_ms) Cannot find master section in config. Furthermore the plugin may set an error code for the connection handle such as HY000/2000 (CR_UNKNOWN_ERROR). The corresponding error message depends on your language settings.

slave[] string

URI of one or more MySQL replication slave servers. The URI follows the syntax hostname[:port|unix_domain_socket].

The plugin supports using one or more slave servers.

Setting a slave server is mandatory. The plugin will report a warning upon connect if the user has failed to provide at least one slave server for a configuration section. The warning may read (mysqlnd_ms) Cannot find slaves section in config. Furthermore the plugin may set an error code for the connection handle such as HY000/2000 (CR_UNKNOWN_ERROR). The corresponding error message depends on your language settings.

pick[] string

Load balancing (server picking) policy. Supported policies: random, random_once (default), roundrobin, user.

If no load balancing policy is set, the plugin will default to random_once. The random_once policy picks a random slave server when running the first read-only statement. The slave server will be used for all read-only statements until the PHP script execution ends.

The random policy will pick a random server whenever a read-only statement is to be executed.

If using roundrobin the plugin iterates over the list of configured slave servers to pick a server for statement execution. If the plugin reaches the end of the list, it wraps around to the beginning of the list and picks the first configured slave server.

Setting more than one load balancing policy for a configuration section makes only sense in conjunction with user and mysqlnd_ms_set_user_pick_server(). If the user defined callback fails to pick a server, the plugin falls back to the second configured load balancing policy.

failover string

Failover policy. Supported policies: disabled (default), master.

If no failover policy is set, the plugin will not do any automatic failover (failover=disabled). Whenever the plugin fails to connect a server it will emit a warning and set the connections error code and message. Thereafter it is up to the application to handle the error and, for example, resent the last statement to trigger the selection of another server.

If using failover=master the plugin will implicitly failover to a slave, if available. Please check the concepts documentation to learn about potential pitfalls and risks of using failover=master.

lazy_connections bool

Controls the use of lazy connections. Lazy connections are connections which are not opened before the client sends the first connection.

It is strongly recommended to use lazy connections. Lazy connections help to keep the number of open connections low. If you disable lazy connections and, for example, configure one MySQL replication master server and two MySQL replication slaves, the plugin will open three connections upon the first call to a connect function although the application might use the master connection only.

Lazy connections bare a risk if you make heavy use of actions which change the state of a connection. The plugin does not dispatch all state changing actions to all connections from the connection pool. The few dispatched actions are applied to already opened connections only. Lazy connections opened in the future are not affected. If, for example, the connection character set is changed using a PHP MySQL API call, the plugin will change the character set of all currently opened connection. It will not remember the character set change to apply it on lazy connections opened in the future. As a result the internal connection pool would hold connections using different character sets. This is not desired. Remember that character sets are taken into account for escaping.

master_on_write bool

If set, the plugin will use the master server only after the first statement has been executed on the master. Applications can still send statements to the slaves using SQL hints to overrule the automatic decision.

The setting may help with replication lag. If an application runs an INSERT the plugin will, by default, use the master to execute all following statements, including SELECT statements. This helps to avoid problems with reads from slaves which have not replicated the INSERT yet.

trx_stickiness string

Transaction stickiness policy. Supported policies: disabled (default), master.

Experimental feature.

The setting requires 5.4.0 or newer. If used with PHP older than 5.4.0, the plugin will emit a warning like (mysqlnd_ms) trx_stickiness strategy is not supported before PHP 5.3.99.

If no transaction stickiness policy is set or, if setting trx_stickiness=disabled, the plugin is not transaction aware. Thus, the plugin may load balance connections and switch connections in the middle of a transaction. The plugin is not transaction safe. SQL hints must be used avoid connection switches during a transaction.

As of PHP 5.4.0 the mysqlnd library allows the plugin to monitor the autocommit mode set by calls to the libraries trx_autocommit() function. If setting trx_stickiness=master and autocommit gets disabled by a PHP MySQL extension invoking the mysqlnd library internal function call trx_autocommit(), the plugin is made aware of the begin of a transaction. Then, the plugin stops load balancing and directs all statements to the master server until autocommit is enabled. Thus, no SQL hints are required.

An example of a PHP MySQL API function calling the mysqlnd library internal function call trx_autocommit() is mysqli_autocommit().

Although setting trx_stickiness=master, the plugin cannot be made aware of autocommit mode changes caused by SQL statements such as SET AUTOCOMMIT=0.

Testing

Note:

The section applies to mysqlnd_ms 1.1.0 or newer, not the 1.0 series.

The PECL/mysqlnd_ms test suite is in the tests/ directory of the source distribution. The test suite consists of standard phpt tests, which are described on the PHP Quality Assurance Teams website.

Running the tests requires setting up one to four MySQL servers. Some tests don't connect to MySQL at all. Others require one server for testing. Some require two distinct servers. In some cases two servers are used to emulate a replication setup. In other cases a master and a slave of an existing MySQL replication setup are required for testing. The tests will try to detect how many servers and what kind of servers are given. If the required servers are not found, the test will be skipped automatically.

Before running the tests, edit tests/config.inc to configure the MySQL servers to be used for testing.

The most basic configuration is as follows.

 putenv("MYSQL_TEST_HOST=localhost");
 putenv("MYSQL_TEST_PORT=3306");
 putenv("MYSQL_TEST_USER=root");
 putenv("MYSQL_TEST_PASSWD=");
 putenv("MYSQL_TEST_DB=test");
 putenv("MYSQL_TEST_ENGINE=MyISAM");
 putenv("MYSQL_TEST_SOCKET=");

 putenv("MYSQL_TEST_SKIP_CONNECT_FAILURE=1");
 putenv("MYSQL_TEST_CONNECT_FLAGS=0");
 putenv("MYSQL_TEST_EXPERIMENTAL=0");

 /* replication cluster emulation */
 putenv("MYSQL_TEST_EMULATED_MASTER_HOST=". getenv("MYSQL_TEST_HOST"));
 putenv("MYSQL_TEST_EMULATED_SLAVE_HOST=". getenv("MYSQL_TEST_HOST"));

 /* real replication cluster */
 putenv("MYSQL_TEST_MASTER_HOST=". getenv("MYSQL_TEST_EMULATED_MASTER_HOST"));
 putenv("MYSQL_TEST_SLAVE_HOST=". getenv("MYSQL_TEST_EMULATED_SLAVE_HOST"));

MYSQL_TEST_HOST, MYSQL_TEST_PORT and MYSQL_TEST_SOCKET define the hostname, TCP/IP port and Unix domain socket of the default database server. MYSQL_TEST_USER and MYSQL_TEST_PASSWD contain the user and password needed to connect to the database/schema configured with MYSQL_TEST_DB. All configured servers must have the same database user configured to give access to the test database.

Using host, host:port or host:/path/to/socket syntax one can set an alternate host, host and port or host and socket for any of the servers.

putenv("MYSQL_TEST_SLAVE_HOST=192.168.78.136:3307"));
putenv("MYSQL_TEST_MASTER_HOST=myserver_hostname:/path/to/socket"));

Debugging and Tracing

The mysqlnd debug log can be used to debug and trace the actitivities of PECL/mysqlnd_ms. As a mysqlnd PECL/mysqlnd_ms adds trace information to the mysqlnd library debug file. Please, see the mysqlnd.debug PHP configuration directive documentation for a detailed description on how to configure the debug log.

Configuration setting example to activate the debug log:

mysqlnd.debug=d:t:x:O,/tmp/mysqlnd.trace

Note:

This feature is only available with a debug build of PHP. Works on Microsoft Windows if using a debug build of PHP and PHP was built using Microsoft Visual C version 9 and above.

The debug log shows mysqlnd library and PECL/mysqlnd_ms plugin function calls, similar to a trace log. Mysqlnd library calls are usually prefixed with mysqlnd_. PECL/mysqlnd internal calls begin with mysqlnd_ms.

Example excerpt from the debug log (connect):

[...]
>mysqlnd_connect
| info : host=myapp user=root db=test port=3306 flags=131072
| >mysqlnd_ms::connect
| | >mysqlnd_ms_config_json_section_exists
| | | info : section=[myapp] len=[5]
| | | >mysqlnd_ms_config_json_sub_section_exists
| | | | info : section=[myapp] len=[5]
| | | | info : ret=1
| | | <mysqlnd_ms_config_json_sub_section_exists
| | | info : ret=1
| | <mysqlnd_ms_config_json_section_exists
[...]

The debug log is not only useful for plugin developers but also to find the cause of user errors. For example, if your application does not do proper error handling and fails to record error messages, checking the debug and trace log may help finding the cause. Use of the debug log to debug application issues should be considered only if no other option is available. Writing the debug log to disk is a slow operation and may have negative impact on the application performance.

Example excerpt from the debug log (connection failure):

[...]
| | | | | | | info : adding error [Access denied for user 'root'@'localhost' (using password: YES)] to the list
| | | | | | | info : PACKET_FREE(0)
| | | | | | | info : PACKET_FREE(0x7f3ef6323f50)
| | | | | | | info : PACKET_FREE(0x7f3ef6324080)
| | | | | | <mysqlnd_auth_handshake
| | | | | | info : switch_to_auth_protocol=n/a
| | | | | | info : conn->error_info.error_no = 1045
| | | | | <mysqlnd_connect_run_authentication
| | | | | info : PACKET_FREE(0x7f3ef63236d8)
| | | | | >mysqlnd_conn::free_contents
| | | | | | >mysqlnd_net::free_contents
| | | | | | <mysqlnd_net::free_contents
| | | | | | info : Freeing memory of members
| | | | | | info : scheme=unix:///tmp/mysql.sock
| | | | | | >mysqlnd_error_list_pdtor
| | | | | | <mysqlnd_error_list_pdtor
| | | | | <mysqlnd_conn::free_contents
| | | | <mysqlnd_conn::connect
[...]

The trace log can also be used to verify correct behaviour of PECL/mysqlnd_ms itself, for example, to check which server has been selected for query execution and why.

Example excerpt from the debug log (plugin decision):

[...]
>mysqlnd_ms::query
| info : query=DROP TABLE IF EXISTS test
| >_mysqlnd_plugin_get_plugin_connection_data
| | info : plugin_id=5
| <_mysqlnd_plugin_get_plugin_connection_data
| >mysqlnd_ms_pick_server_ex
| | info : conn_data=0x7fb6a7d3e5a0 *conn_data=0x7fb6a7d410d0
| | >mysqlnd_ms_select_servers_all
| | <mysqlnd_ms_select_servers_all
| | >mysqlnd_ms_choose_connection_rr
| | | >mysqlnd_ms_query_is_select
[...]
| | | <mysqlnd_ms_query_is_select
[...]
| | | info : Init the master context
| | | info : list(0x7fb6a7d3f598) has 1
| | | info : Using master connection
| | | >mysqlnd_ms_advanced_connect
| | | | >mysqlnd_conn::connect
| | | | | info : host=localhost user=root db=test port=3306 flags=131072 persistent=0 state=0

In this case the statement DROP TABLE IF EXISTS test has been executed. Note that the statement string is shown in the log file. You may want to take measures to restrict access to the log for security considerations.

The statement has been load balanced using round robin policy, as you can easily guess from the functions name >mysqlnd_ms_choose_connection_rr. It has been sent to a master server running on host=localhost user=root db=test port=3306 flags=131072 persistent=0 state=0.

Monitoring

Plugin activity can be monitored using the mysqlnd trace log, mysqlnd statistics, mysqlnd_ms plugin statistics and external PHP debugging tools. Use of the trace log should be limited to debugging. It is recommended to use the plugins statistics for monitoring.

Writing a trace log is a slow operation. If using an external PHP debugging tool, please refer to the vendors manual about its performance impact and the type of information collected. In many cases, external debugging tools will provide call stacks. Often, a call stack or a trace log is more difficult to interpret than the statistics provided by the plugin.

Plugin statistics tell how often which kind of cluster node has been used (slave or master), why the node was used, if lazy connections have been used and if global transaction ID injection has been performed. The monitoring information provided enables user to verify plugin decisions and to plan their cluster resources based on usage pattern. The function mysqlnd_ms_get_stats() is used to access the statistics. Please, see the functions description for a list of available statistics.

Statistics are collected on a per PHP process basis. Their scope is a PHP process. Depending on the PHP deployment model a process may serve one or multiple web requests. If using CGI model, a PHP process serves one web request. If using FastCGI or pre-fork web server models, a PHP process usually serves multiple web requests. The same is the case with a threaded web server. Please, note that threads running in parallel can update the statistics in parallel. Thus, if using a threaded PHP deployment model, statistics can be changed by more than one script at a time. A script cannot rely on the fact that it sees only its own changes to statistics.

Example #38 Verify plugin activity in a non-threaded deployment model

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
<?php
/* Load balanced following "myapp" section rules from the plugins config file (not shown) */
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

$stats_before = mysqlnd_ms_get_stats();
if ($res = $mysqli->query("SELECT 'Read request' FROM DUAL")) {
  var_dump($res->fetch_all());
}
$stats_after = mysqlnd_ms_get_stats();
if ($stats_after['use_slave'] <= $stats_before['use_slave']) {
  echo "According to the statistics the read request has not been run on a slave!";
}
?>

Statistics are aggregated for all plugin activities and all connections handled by the plugin. It is not possible to tell how much a certain connection handle has contributed to the overall statistics.

Utilizing PHPs register_shutdown_function() function or the auto_append_file PHP configuration directive it is easily possible to dump statistics into, for example, a log file when a script finishes. Instead of using a log file it is also possible to send the statistics to an external monitoring tool for recording and display.

Example #39 Recording statistics during shutdown

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
error_log=/tmp/php_errors.log
<?php
function check_stats() {
  $msg = str_repeat("-", 80) . "\n";
  $msg .= var_export(mysqlnd_ms_get_stats(), true) . "\n";
  $msg .= str_repeat("-", 80) . "\n";
  error_log($msg);
}
register_shutdown_function("check_stats");
?>


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SQL hint related

Example #1 Example demonstrating the usage of mysqlnd_ms constants

The mysqlnd replication and load balancing plugin (mysqlnd_ms) performs read/write splitting. This directs write queries to a MySQL master server, and read-only queries to the MySQL slave servers. The plugin has a built-in read/write split logic. All queries which start with SELECT are considered read-only queries, which are then sent to a MySQL slave server that is listed in the plugin configuration file. All other queries are directed to the MySQL master server that is also specified in the plugin configuration file.

User supplied SQL hints can be used to overrule automatic read/write splitting, to gain full control on the process. SQL hints are standards compliant SQL comments. The plugin will scan the beginning of a query string for an SQL comment for certain commands, which then control query redirection. Other systems involved in the query processing are unaffected by the SQL hints because other systems will ignore the SQL comments.

The plugin supports three SQL hints to direct queries to either the MySQL slave servers, the MySQL master server, or the last used MySQL server. SQL hints must be placed at the beginning of a query to be recognized by the plugin.

For better portability, it is recommended to use the string constants MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH and MYSQLND_MS_LAST_USED_SWITCH instead of their literal values.

<?php
/* Use constants for maximum portability */
$master_query = "/*" . MYSQLND_MS_MASTER_SWITCH . "*/SELECT id FROM test";

/* Valid but less portable: using literal instead of constant */
$slave_query = "/*ms=slave*/SHOW TABLES";

printf("master_query = '%s'\n", $master_query);
printf("slave_query = '%s'\n", $slave_query);
?>

以上例程会输出：

master_query = /*ms=master*/SELECT id FROM test
slave_query = /*ms=slave*/SHOW TABLES

MYSQLND_MS_MASTER_SWITCH (string)
SQL hint used to send a query to the MySQL replication master server.
MYSQLND_MS_SLAVE_SWITCH (string)
SQL hint used to send a query to one of the MySQL replication slave servers.
MYSQLND_MS_LAST_USED_SWITCH (string)
SQL hint used to send a query to the last used MySQL server. The last used MySQL server can either be a master or a slave server in a MySQL replication setup.

mysqlnd_ms_query_is_select() related

MYSQLND_MS_QUERY_USE_MASTER (int)
If mysqlnd_ms_is_select() returns MYSQLND_MS_QUERY_USE_MASTER for a given query, the built-in read/write split mechanism recommends sending the query to a MySQL replication master server.
MYSQLND_MS_QUERY_USE_SLAVE (int)
If mysqlnd_ms_is_select() returns MYSQLND_MS_QUERY_USE_SLAVE for a given query, the built-in read/write split mechanism recommends sending the query to a MySQL replication slave server.
MYSQLND_MS_QUERY_USE_LAST_USED (int)
If mysqlnd_ms_is_select() returns MYSQLND_MS_QUERY_USE_LAST_USED for a given query, the built-in read/write split mechanism recommends sending the query to the last used server.

mysqlnd_ms_set_qos(), quality of service filter and service level related

MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL (int)
Use to request the service level eventual consistency from the mysqlnd_ms_set_qos(). Eventual consistency is the default quality of service when reading from an asynchronous MySQL replication slave. Data returned in this service level may or may not be stale, depending on whether the selected slaves happen to have replicated the latest changes from the MySQL replication master or not.
MYSQLND_MS_QOS_CONSISTENCY_SESSION (int)
Use to request the service level session consistency from the mysqlnd_ms_set_qos(). Session consistency is defined as read your writes. The client is guaranteed to see his latest changes.
MYSQLND_MS_QOS_CONSISTENCY_STRONG (int)
Use to request the service level strong consistency from the mysqlnd_ms_set_qos(). Strong consistency is used to ensure all clients see each others changes.
MYSQLND_MS_QOS_OPTION_GTID (int)
Used as a service level option with mysqlnd_ms_set_qos() to parameterize session consistency.
MYSQLND_MS_QOS_OPTION_AGE (int)
Used as a service level option with mysqlnd_ms_set_qos() to parameterize eventual consistency.

Other

The plugins version number can be obtained using MYSQLND_MS_VERSION or MYSQLND_MS_VERSION_ID. MYSQLND_MS_VERSION is the string representation of the numerical version number MYSQLND_MS_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_MS_VERSION_ID | 10000

MYSQLND_MS_VERSION (string)
Plugin version string, for example, 1.0.0-prototype.
MYSQLND_MS_VERSION_ID (int)
Plugin version number, for example, 10000.


Mysqlnd_ms 函数

Table of Contents

  • mysqlnd_ms_dump_servers — Returns a list of currently configured servers
  • mysqlnd_ms_fabric_select_global — Switch to global sharding server for a given table
  • mysqlnd_ms_fabric_select_shard — Switch to shard
  • mysqlnd_ms_get_last_gtid — 返回最后的全局同步 ID (GTID)
  • mysqlnd_ms_get_last_used_connection — Returns an array which describes the last used connection
  • mysqlnd_ms_get_stats — Returns query distribution and connection statistics
  • mysqlnd_ms_match_wild — Finds whether a table name matches a wildcard pattern or not
  • mysqlnd_ms_query_is_select — 查询给定的 SQL 会发送给 master、slave 还是最后使用的 MySQL server 执行。
  • mysqlnd_ms_set_qos — Sets the quality of service needed from the cluster
  • mysqlnd_ms_set_user_pick_server — Sets a callback for user-defined read/write splitting
  • mysqlnd_ms_xa_begin — Starts a distributed/XA transaction among MySQL servers
  • mysqlnd_ms_xa_commit — Commits a distributed/XA transaction among MySQL servers
  • mysqlnd_ms_xa_gc — Garbage collects unfinished XA transactions after severe errors
  • mysqlnd_ms_xa_rollback — Rolls back a distributed/XA transaction among MySQL servers


Returns a list of currently configured servers

  • ? Mysqlnd_ms 函数
  • mysqlnd_ms_fabric_select_global ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Returns a list of currently configured servers

mysqlnd_ms_dump_servers

(No version information available, might only be in Git)

mysqlnd_ms_dump_servers — Returns a list of currently configured servers

说明

mysqlnd_ms_dump_servers ( mixed $connection ) : array

Returns a list of currently configured servers.

参数

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

返回值

false on error. Otherwise, returns an array with two entries masters and slaves each of which contains an array listing all corresponding servers.

The function can be used to check and debug the list of servers currently used by the plugin. It is mostly useful when the list of servers changes at runtime, for example, when using MySQL Fabric.

masters and slaves server entries

Key | Description | Version
name_from_config | Server entry name from config, if appliciable. NULL if no configuration name is available. | Since 1.6.0.
hostname | Host name of the server. | Since 1.6.0.
user | Database user used to authenticate against the server. | Since 1.6.0.
port | TCP/IP port of the server. | Since 1.6.0.
socket | Unix domain socket of the server. | Since 1.6.0.

注释

Note:

mysqlnd_ms_dump_servers() requires PECL mysqlnd_ms >> 1.6.0.

范例

Example #1 mysqlnd_ms_dump_servers() example

{
    "myapp": {
        "master": {
            "master1": {
                "host":"master1_host",
                "port":"master1_port",
                "socket":"master1_socket",
                "db":"master1_db",
                "user":"master1_user",
                "password":"master1_pw"
            }
        },
        "slave": {
             "slave_0": {
                 "host":"slave0_host",
                 "port":"slave0_port",
                 "socket":"slave0_socket",
                 "db":"slave0_db",
                 "user":"slave0_user",
                 "password":"slave0_pw"
             },
             "slave_1": {
                 "host":"slave1_host"
             }
        }
    }
}
<?php
$link = mysqli_connect("myapp", "global_user", "global_pass", "global_db", 1234, "global_socket");
var_dump(mysqlnd_ms_dump_servers($link);
?>

以上例程会输出：

array(2) {
  ["masters"]=>
  array(1) {
    [0]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "master1"
      ["hostname"]=>
      string(12) "master1_host"
      ["user"]=>
      string(12) "master1_user"
      ["port"]=>
      int(3306)
      ["socket"]=>
      string(14) "master1_socket"
    }
  }
  ["slaves"]=>
  array(2) {
    [0]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "slave_0"
      ["hostname"]=>
      string(11) "slave0_host"
      ["user"]=>
      string(11) "slave0_user"
      ["port"]=>
      int(3306)
      ["socket"]=>
      string(13) "slave0_socket"
    }
    [1]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "slave_1"
      ["hostname"]=>
      string(11) "slave1_host"
      ["user"]=>
      string(12) "gloabal_user"
      ["port"]=>
      int(1234)
      ["socket"]=>
      string(13) "global_socket"
    }
  }
}


Switch to global sharding server for a given table

  • ? mysqlnd_ms_dump_servers
  • mysqlnd_ms_fabric_select_shard ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Switch to global sharding server for a given table

mysqlnd_ms_fabric_select_global

(No version information available, might only be in Git)

mysqlnd_ms_fabric_select_global — Switch to global sharding server for a given table

说明

mysqlnd_ms_fabric_select_global ( mixed $connection , mixed $table_name ) : array
Warning

本函数还未编写文档，仅有参数列表。

MySQL Fabric related.

Switch the connection to the nodes handling global sharding queries for the given table name.

参数

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

table_name

The table name to ask Fabric about.

返回值

false on error. Otherwise, true

注释

Note:

mysqlnd_ms_fabric_select_global() requires PECL mysqlnd_ms >> 1.6.0.


Switch to shard

  • ? mysqlnd_ms_fabric_select_global
  • mysqlnd_ms_get_last_gtid ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Switch to shard

mysqlnd_ms_fabric_select_shard

(No version information available, might only be in Git)

mysqlnd_ms_fabric_select_shard — Switch to shard

说明

mysqlnd_ms_fabric_select_shard ( mixed $connection , mixed $table_name , mixed $shard_key ) : array
Warning

本函数还未编写文档，仅有参数列表。

MySQL Fabric related.

Switch the connection to the shards responsible for the given table name and shard key.

参数

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

table_name

The table name to ask Fabric about.

shard_key

The shard key to ask Fabric about.

返回值

false on error. Otherwise, true

注释

Note:

mysqlnd_ms_fabric_select_shard() requires PECL mysqlnd_ms >> 1.6.0.


返回最后的全局同步 ID (GTID)

  • ? mysqlnd_ms_fabric_select_shard
  • mysqlnd_ms_get_last_used_connection ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • 返回最后的全局同步 ID (GTID)

mysqlnd_ms_get_last_gtid

(PECL mysqlnd_ms >= 1.2.0)

mysqlnd_ms_get_last_gtid — 返回最后的全局同步 ID (GTID)

说明

mysqlnd_ms_get_last_gtid ( mixed $connection ) : string

返回最后一次写操作以后的 GTID，他并不能保证一定是那次写操作产生的 GTID，但是得到的 GTID 一定比这次写操作产生的 GTID 大。

参数

connection

由 PDO_MYSQL, mysqli> 或者 ext/mysql 产生的 MySQL 服务器连接， 这些链接受 PECL/mysqlnd_ms 连接控制。连接的创建是通过 mysqlnd_ms 配置文件中 约定的群组名称建立的。

返回值

成功返回 GTID，失败返回 false。

函数通过配置文件中 global_transaction_id_injection 章节定义的 fetch_last_gtid 参数来获取 GTID。

在函数调用的时候，GTID 可能已经增加了。

注释

Note:

函数需要 PHP >= 5.4.0 版本，PECL/mysqlnd_ms >= 1.2.0 版本，在 PHP 5.3 版本中 mysqlnd 库不能使用。

范例

Example #1 mysqlnd_ms_get_last_gtid() example

<?php
/* Open mysqlnd_ms connection using mysqli, PDO_MySQL or mysql extension */
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("DROP TABLE IF EXISTS test"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

printf("GTID after transaction %s\n", mysqlnd_ms_get_last_gtid($mysqli));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("CREATE TABLE test(id INT)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

printf("GTID after transaction %s\n", mysqlnd_ms_get_last_gtid($mysqli));
?>

参见

  • Global Transaction IDs


Returns an array which describes the last used connection

  • ? mysqlnd_ms_get_last_gtid
  • mysqlnd_ms_get_stats ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Returns an array which describes the last used connection

mysqlnd_ms_get_last_used_connection

(PECL mysqlnd_ms >= 1.1.0)

mysqlnd_ms_get_last_used_connection — Returns an array which describes the last used connection

说明

mysqlnd_ms_get_last_used_connection ( mixed $connection ) : array

Returns an array which describes the last used connection from the plugins connection pool currently pointed to by the user connection handle. If using the plugin, a user connection handle represents a pool of database connections. It is not possible to tell from the user connection handles properties to which database server from the pool the user connection handle points.

The function can be used to debug or monitor PECL mysqlnd_ms.

参数

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

返回值

false on error. Otherwise, an array which describes the connection used to execute the last statement on.

Array which describes the connection.

Property | Description | Version
scheme | Connection scheme. Either tcp://host:port or unix://host:socket. If you want to distinguish connections from each other use a combination of scheme and thread_id as a unique key. Neither scheme nor thread_id alone are sufficient to distinguish two connections from each other. Two servers may assign the same thread_id to two different connections. Thus, connections in the pool may have the same thread_id. Also, do not rely on uniqueness of scheme in a pool. Your QA engineers may use the same MySQL server instance for two distinct logical roles and add it multiple times to the pool. This hack is used, for example, in the test suite. | Since 1.1.0.
host | Database server host used with the connection. The host is only set with TCP/IP connections. It is empty with Unix domain or Windows named pipe connections, | Since 1.1.0.
host_info | A character string representing the server hostname and the connection type. | Since 1.1.2.
port | Database server port used with the connection. | Since 1.1.0.
socket_or_pipe | Unix domain socket or Windows named pipe used with the connection. The value is empty for TCP/IP connections. | Since 1.1.2.
thread_id | Connection thread id. | Since 1.1.0.
last_message | Info message obtained from the MySQL C API function mysql_info(). Please, see mysqli_info() for a description. | Since 1.1.0.
errno | Error code. | Since 1.1.0.
error | Error message. | Since 1.1.0.
sqlstate | Error SQLstate code. | Since 1.1.0.

注释

Note:

mysqlnd_ms_get_last_used_connection() requires PHP >= 5.4.0 and PECL mysqlnd_ms >> 1.1.0. Internally, it is using a mysqlnd library C call not available with PHP 5.3.

范例

The example assumes that myapp refers to a plugin configuration file section and represents a connection pool.

Example #1 mysqlnd_ms_get_last_used_connection() example

<?php
$link = new mysqli("myapp", "user", "password", "database");
$res = $link->query("SELECT 1 FROM DUAL");
var_dump(mysqlnd_ms_get_last_used_connection($link));
?>

以上例程会输出：

array(10) {
  ["scheme"]=>
  string(22) "unix:///tmp/mysql.sock"
  ["host_info"]=>
  string(25) "Localhost via UNIX socket"
  ["host"]=>
  string(0) ""
  ["port"]=>
  int(3306)
  ["socket_or_pipe"]=>
  string(15) "/tmp/mysql.sock"
  ["thread_id"]=>
  int(46253)
  ["last_message"]=>
  string(0) ""
  ["errno"]=>
  int(0)
  ["error"]=>
  string(0) ""
  ["sqlstate"]=>
  string(5) "00000"
}


Returns query distribution and connection statistics

  • ? mysqlnd_ms_get_last_used_connection
  • mysqlnd_ms_match_wild ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Returns query distribution and connection statistics

mysqlnd_ms_get_stats

(PECL mysqlnd_ms >= 1.0.0)

mysqlnd_ms_get_stats — Returns query distribution and connection statistics

说明

mysqlnd_ms_get_stats ( ) : array

Returns an array of statistics collected by the replication and load balancing plugin.

The PHP configuration setting mysqlnd_ms.collect_statistics controls the collection of statistics. The collection of statistics is disabled by default for performance reasons.

The scope of the statistics is the PHP process. Depending on your deployment model a PHP process may handle one or multiple requests.

Statistics are aggregated for all connections and all storage handler. It is not possible to tell how much queries originating from mysqli, PDO_MySQL or mysql API calls have contributed to the aggregated data values.

参数

此函数没有参数。

返回值

Returns null if the PHP configuration directive mysqlnd_ms.enable has disabled the plugin. Otherwise, returns array of statistics.

Array of statistics

Statistic | Description | Version
use_slave

The semantics of this statistic has changed between 1.0.1 - 1.1.0.

The meaning for version 1.0.1 is as follows. Number of statements considered as read-only by the built-in query analyzer. Neither statements which begin with a SQL hint to force use of slave nor statements directed to a slave by an user-defined callback are included. The total number of statements sent to the slaves is use_slave + use_slave_sql_hint + use_slave_callback.

PECL/mysqlnd_ms 1.1.0 introduces a new concept of chained filters. The statistics is now set by the internal load balancing filter. With version 1.1.0 the load balancing filter is always the last in the filter chain, if used. In future versions a load balancing filter may be followed by other filters causing another change in the meaning of the statistic. If, in the future, a load balancing filter is followed by another filter it is no longer guaranteed that the statement, which increments use_slave, will be executed on the slaves.

The meaning for version 1.1.0 is as follows. Number of statements sent to the slaves. Statements directed to a slave by the user filter (an user-defined callback) are not included. The latter are counted by use_slave_callback.

Since 1.0.0.
use_master

The semantics of this statistic has changed between 1.0.1 - 1.1.0.

The meaning for version 1.0.1 is as follows. Number of statements not considered as read-only by the built-in query analyzer. Neither statements which begin with a SQL hint to force use of master nor statements directed to a master by an user-defined callback are included. The total number of statements sent to the master is use_master + use_master_sql_hint + use_master_callback.

PECL/mysqlnd_ms 1.1.0 introduces a new concept of chained filters. The statictics is now set by the internal load balancing filter. With version 1.1.0 the load balancing filter is always the last in the filter chain, if used. In future versions a load balancing filter may be followed by other filters causing another change in the meaning of the statistic. If, in the future, a load balancing filter is followed by another filter it is no longer guaranteed that the statement, which increments use_master, will be executed on the slaves.

The meaning for version 1.1.0 is as follows. Number of statements sent to the masters. Statements directed to a master by the user filter (an user-defined callback) are not included. The latter are counted by use_master_callback.

Since 1.0.0.
use_slave_guess | Number of statements the built-in query analyzer recommends sending to a slave because they contain no SQL hint to force use of a certain server. The recommendation may be overruled in the following. It is not guaranteed whether the statement will be executed on a slave or not. This is how often the internal is_select function has guessed that a slave shall be used. Please, see also the user space function mysqlnd_ms_query_is_select(). | Since 1.1.0.
use_master_guess | Number of statements the built-in query analyzer recommends sending to a master because they contain no SQL hint to force use of a certain server. The recommendation may be overruled in the following. It is not guaranteed whether the statement will be executed on a slave or not. This is how often the internal is_select function has guessed that a master shall be used. Please, see also the user space function mysqlnd_ms_query_is_select(). | Since 1.1.0.
use_slave_sql_hint | Number of statements sent to a slave because statement begins with the SQL hint to force use of slave. | Since 1.0.0.
use_master_sql_hint | Number of statements sent to a master because statement begins with the SQL hint to force use of master. | Since 1.0.0.
use_last_used_sql_hint | Number of statements sent to server which has run the previous statement, because statement begins with the SQL hint to force use of previously used server. | Since 1.0.0.
use_slave_callback | Number of statements sent to a slave because an user-defined callback has chosen a slave server for statement execution. | Since 1.0.0.
use_master_callback | Number of statements sent to a master because an user-defined callback has chosen a master server for statement execution. | Since 1.0.0.
non_lazy_connections_slave_success | Number of successfully opened slave connections from configurations not using lazy connections. The total number of successfully opened slave connections is non_lazy_connections_slave_success + lazy_connections_slave_success | Since 1.0.0.
non_lazy_connections_slave_failure | Number of failed slave connection attempts from configurations not using lazy connections. The total number of failed slave connection attempts is non_lazy_connections_slave_failure + lazy_connections_slave_failure | Since 1.0.0.
non_lazy_connections_master_success | Number of successfully opened master connections from configurations not using lazy connections. The total number of successfully opened master connections is non_lazy_connections_master_success + lazy_connections_master_success | Since 1.0.0.
non_lazy_connections_master_failure | Number of failed master connection attempts from configurations not using lazy connections. The total number of failed master connection attempts is non_lazy_connections_master_failure + lazy_connections_master_failure | Since 1.0.0.
lazy_connections_slave_success | Number of successfully opened slave connections from configurations using lazy connections. | Since 1.0.0.
lazy_connections_slave_failure | Number of failed slave connection attempts from configurations using lazy connections. | Since 1.0.0.
lazy_connections_master_success | Number of successfully opened master connections from configurations using lazy connections. | Since 1.0.0.
lazy_connections_master_failure | Number of failed master connection attempts from configurations using lazy connections. | Since 1.0.0.
trx_autocommit_on | Number of autocommit mode activations via API calls. This figure may be used to monitor activity related to the plugin configuration setting trx_stickiness. If, for example, you want to know if a certain API call invokes the mysqlnd library function trx_autocommit(), which is a requirement for trx_stickiness, you may call the user API function in question and check if the statistic has changed. The statistic is modified only by the plugins internal subclassed trx_autocommit() method. | Since 1.0.0.
trx_autocommit_off | Number of autocommit mode deactivations via API calls. | Since 1.0.0.
trx_master_forced | Number of statements redirected to the master while trx_stickiness=master and autocommit mode is disabled. | Since 1.0.0.
gtid_autocommit_injections_success | Number of successful SQL injections in autocommit mode as part of the plugins client-side global transaction id emulation. | Since 1.2.0.
gtid_autocommit_injections_failure | Number of failed SQL injections in autocommit mode as part of the plugins client-side global transaction id emulation. | Since 1.2.0.
gtid_commit_injections_success | Number of successful SQL injections in commit mode as part of the plugins client-side global transaction id emulation. | Since 1.2.0.
gtid_commit_injections_failure | Number of failed SQL injections in commit mode as part of the plugins client-side global transaction id emulation. | Since 1.2.0.
gtid_implicit_commit_injections_success | Number of successful SQL injections when implicit commit is detected as part of the plugins client-side global transaction id emulation. Implicit commit happens, for example, when autocommit has been turned off, a query is executed and autocommit is enabled again. In that case, the statement will be committed by the server and SQL to maintain is injected before the autocommit is re-enabled. Another sequence causing an implicit commit is begin(), query(), begin(). The second call to begin() will implicitly commit the transaction started by the first call to begin(). begin() refers to internal library calls not actual PHP user API calls. | Since 1.2.0.
gtid_implicit_commit_injections_failure | Number of failed SQL injections when implicit commit is detected as part of the plugins client-side global transaction id emulation. Implicit commit happens, for example, when autocommit has been turned off, a query is executed and autocommit is enabled again. In that case, the statement will be committed by the server and SQL to maintain is injected before the autocommit is re-enabled. | Since 1.2.0.
transient_error_retries | How often an operation has been retried when a transient error was detected. See also, transient_error plugin configuration file setting. | Since 1.6.0.
fabric_sharding_lookup_servers_success | Number of successful sharding.lookup_servers remote procedure calls to MySQL Fabric. A call is considered successful if the plugin could reach MySQL Fabric and got any reply. The reply itself may or may not be understood by the plugin. Success refers to the network transport only. If the reply was not understood or indicates a valid error condition, fabric_sharding_lookup_servers_xml_failure gets incremented. | Since 1.6.0.
fabric_sharding_lookup_servers_failure | Number of failed sharding.lookup_servers remote procedure calls to MySQL Fabric. A remote procedure call is considered failed if there was a network error in connecting to, writing to or reading from MySQL Fabric. | Since 1.6.0.
fabric_sharding_lookup_servers_time_total | Time spent connecting to,writing to and reading from MySQL Fabrich during the sharding.lookup_servers remote procedure call. The value is aggregated for all calls. Time is measured in microseconds. | Since 1.6.0.
fabric_sharding_lookup_servers_bytes_total | Total number of bytes received from MySQL Fabric in reply to sharding.lookup_servers calls. | Since 1.6.0.
fabric_sharding_lookup_servers_xml_failure | How often a reply from MySQL Fabric to sharding.lookup_servers calls was not understood. Please note, the current experimental implementation does not distinguish between valid errors returned and malformed replies. | Since 1.6.0.
xa_begin | How many XA/distributed transactions have been started using mysqlnd_ms_xa_begin(). | Since 1.6.0.
xa_commit_success | How many XA/distributed transactions have been successfully committed using mysqlnd_ms_xa_commit(). | Since 1.6.0.
xa_commit_failure | How many XA/distributed transactions failed to commit during mysqlnd_ms_xa_commit(). | Since 1.6.0.
xa_rollback_success | How many XA/distributed transactions have been successfully rolled back using mysqlnd_ms_xa_rollback(). The figure does not include implict rollbacks performed as a result of mysqlnd_ms_xa_commit() failure. | Since 1.6.0.
xa_rollback_failure | How many XA/distributed transactions could not be rolled back. This includes failures of mysqlnd_ms_xa_rollback() but also failured during rollback when closing a connection, if rollback_on_close is set. Please, see also xa_rollback_on_close below. | Since 1.6.0.
xa_participants | Total number of participants in any XA transaction started with mysqlnd_ms_xa_begin(). | Since 1.6.0.
xa_rollback_on_close | How many XA transactions have been rolled back implicitly when a connection was close and rollback_on_close is set. Depending on your coding policies, this may hint a flaw in your code as you may prefer to explicitly clean up resources. | Since 1.6.0.
pool_masters_total | Number of master servers (connections) in the internal connection pool. | Since 1.6.0.
pool_slaves_total | Number of slave servers (connections) in the internal connection pool. | Since 1.6.0.
pool_masters_active | Number of master servers (connections) from the internal connection pool which are currently used for picking a connection. | Since 1.6.0.
pool_slaves_active | Number of slave servers (connections) from the internal connection pool which are currently used for picking a connection. | Since 1.6.0.
pool_updates | How often the active connection list has been replaced and a new set of master and slave servers had been installed. | Since 1.6.0.
pool_master_reactivated | How often a master connection has been reused after being flushed from the active list. | Since 1.6.0.
pool_slave_reactivated | How often a slave connection has been reused after being flushed from the active list. | Since 1.6.0.

范例

Example #1 mysqlnd_ms_get_stats() example

<?php
printf("mysqlnd_ms.enable = %d\n", ini_get("mysqlnd_ms.enable"));
printf("mysqlnd_ms.collect_statistics = %d\n", ini_get("mysqlnd_ms.collect_statistics"));
var_dump(mysqlnd_ms_get_stats());
?>

以上例程会输出：

mysqlnd_ms.enable = 1
mysqlnd_ms.collect_statistics = 1
array(26) {
  ["use_slave"]=>
  string(1) "0"
  ["use_master"]=>
  string(1) "0"
  ["use_slave_guess"]=>
  string(1) "0"
  ["use_master_guess"]=>
  string(1) "0"
  ["use_slave_sql_hint"]=>
  string(1) "0"
  ["use_master_sql_hint"]=>
  string(1) "0"
  ["use_last_used_sql_hint"]=>
  string(1) "0"
  ["use_slave_callback"]=>
  string(1) "0"
  ["use_master_callback"]=>
  string(1) "0"
  ["non_lazy_connections_slave_success"]=>
  string(1) "0"
  ["non_lazy_connections_slave_failure"]=>
  string(1) "0"
  ["non_lazy_connections_master_success"]=>
  string(1) "0"
  ["non_lazy_connections_master_failure"]=>
  string(1) "0"
  ["lazy_connections_slave_success"]=>
  string(1) "0"
  ["lazy_connections_slave_failure"]=>
  string(1) "0"
  ["lazy_connections_master_success"]=>
  string(1) "0"
  ["lazy_connections_master_failure"]=>
  string(1) "0"
  ["trx_autocommit_on"]=>
  string(1) "0"
  ["trx_autocommit_off"]=>
  string(1) "0"
  ["trx_master_forced"]=>
  string(1) "0"
  ["gtid_autocommit_injections_success"]=>
  string(1) "0"
  ["gtid_autocommit_injections_failure"]=>
  string(1) "0"
  ["gtid_commit_injections_success"]=>
  string(1) "0"
  ["gtid_commit_injections_failure"]=>
  string(1) "0"
  ["gtid_implicit_commit_injections_success"]=>
  string(1) "0"
  ["gtid_implicit_commit_injections_failure"]=>
  string(1) "0"
  ["transient_error_retries"]=>
  string(1) "0"
}

参见

  • Runtime configuration
  • mysqlnd_ms.collect_statistics
  • mysqlnd_ms.enable
  • Monitoring


Finds whether a table name matches a wildcard pattern or not

  • ? mysqlnd_ms_get_stats
  • mysqlnd_ms_query_is_select ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Finds whether a table name matches a wildcard pattern or not

mysqlnd_ms_match_wild

(PECL mysqlnd_ms >= 1.1.0)

mysqlnd_ms_match_wild — Finds whether a table name matches a wildcard pattern or not

说明

mysqlnd_ms_match_wild ( string $table_name , string $wildcard ) : bool

Finds whether a table name matches a wildcard pattern or not.

This function is not of much practical relevance with PECL mysqlnd_ms 1.1.0 because the plugin does not support MySQL replication table filtering yet.

参数

table_name

The table name to check if it is matched by the wildcard.

wildcard

The wildcard pattern to check against the table name. The wildcard pattern supports the same placeholders as MySQL replication filters do.

MySQL replication filters can be configured by using the MySQL Server configuration options --replicate-wild-do-table and --replicate-wild-do-db. Please, consult the MySQL Reference Manual to learn more about this MySQL Server feature.

The supported placeholders are:

  • % - zero or more literals
  • _ - one literal

Placeholders can be escaped using \.

返回值

Returns true table_name is matched by wildcard. Otherwise, returns false

范例

Example #1 mysqlnd_ms_match_wild() example

<?php
var_dump(mysqlnd_ms_match_wild("schema_name.table_name", "schema%"));
var_dump(mysqlnd_ms_match_wild("abc", "_"));
var_dump(mysqlnd_ms_match_wild("table1", "table_"));
var_dump(mysqlnd_ms_match_wild("asia_customers", "%customers"));
var_dump(mysqlnd_ms_match_wild("funny%table","funny\%table"));
var_dump(mysqlnd_ms_match_wild("funnytable", "funny%table"));
?>

以上例程会输出：

bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)


查询给定的 SQL 会发送给 master、slave 还是最后使用的 MySQL server 执行。

  • ? mysqlnd_ms_match_wild
  • mysqlnd_ms_set_qos ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • 查询给定的 SQL 会发送给 master、slave 还是最后使用的 MySQL server 执行。

mysqlnd_ms_query_is_select

(PECL mysqlnd_ms >= 1.0.0)

mysqlnd_ms_query_is_select — 查询给定的 SQL 会发送给 master、slave 还是最后使用的 MySQL server 执行。

说明

mysqlnd_ms_query_is_select ( string $query ) : int

查询给定的 SQL 会发送给 master、slave 还是最后使用的 MySQL server 执行。

插件内置的读写分离会分析 SQL，然后决定到底把他发送到哪里执行。这个读写分离器非常 的基本和简单。插件会将所有的查询发送给 master，除非他以 SELECT 开头，或者使用 SQL hints 指定要去 slave 执行。因为这个读写分离很简单， 所以会将一些只读查询发送给主从同步的 master，例如：SHOW TABLES。

参数

query

要测试的 SQL 字符串。

返回值

返回 MYSQLND_MS_QUERY_USE_MASTER 说明发送给 master。 返回 MYSQLND_MS_QUERY_USE_SLAVE 说明是一个只读语句， 将发送给 slave 执行。返回 MYSQLND_MS_QUERY_USE_LAST_USED 说明会在上一次执行的服务器连接中执行，这可能是 master 也可能是 slave。

如果通过设定 mysqlnd_ms.disable_rw_split 禁用了读写分离， 那么函数可能返回 MYSQLND_MS_QUERY_USE_MASTER 或者返回 MYSQLND_MS_QUERY_USE_LAST_USED。

范例

Example #1 mysqlnd_ms_query_is_select() example

<?php
function is_select($query)
{
 switch (mysqlnd_ms_query_is_select($query))
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("'%s' should be run on the master.\n", $query);
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   printf("'%s' should be run on a slave.\n", $query);
   break;
  case MYSQLND_MS_QUERY_USE_LAST_USED:
   printf("'%s' should be run on the server that has run the previous query\n", $query);
   break;
  default:
   printf("No suggestion where to run the '%s', fallback to master recommended\n", $query);
   break;
 }
}

is_select("INSERT INTO test(id) VALUES (1)");
is_select("SELECT 1 FROM DUAL");
is_select("/*" . MYSQLND_MS_LAST_USED_SWITCH . "*/SELECT 2 FROM DUAL");
?>

以上例程会输出：

INSERT INTO test(id) VALUES (1) should be run on the master.
SELECT 1 FROM DUAL should be run on a slave.
/*ms=last_used*/SELECT 2 FROM DUAL should be run on the server that has run the previous query

参见

  • Predefined Constants
  • user filter
  • Runtime configuration
  • mysqlnd_ms.disable_rw_split
  • mysqlnd_ms.enable


Sets the quality of service needed from the cluster

  • ? mysqlnd_ms_query_is_select
  • mysqlnd_ms_set_user_pick_server ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Sets the quality of service needed from the cluster

mysqlnd_ms_set_qos

(PECL mysqlnd_ms < 1.2.0)

mysqlnd_ms_set_qos — Sets the quality of service needed from the cluster

说明

mysqlnd_ms_set_qos ( mixed $connection , int $service_level , int $service_level_option = ? , mixed $option_value = ? ) : bool

Sets the quality of service needed from the cluster. A database cluster delivers a certain quality of service to the user depending on its architecture. A major aspect of the quality of service is the consistency level the cluster can offer. An asynchronous MySQL replication cluster defaults to eventual consistency for slave reads: a slave may serve stale data, current data, or it may have not the requested data at all, because it is not synchronous to the master. In a MySQL replication cluster, only master accesses can give strong consistency, which promises that all clients see each others changes.

PECL/mysqlnd_ms hides the complexity of choosing appropriate nodes to achieve a certain level of service from the cluster. The "Quality of Service" filter implements the necessary logic. The filter can either be configured in the plugins configuration file, or at runtime using mysqlnd_ms_set_qos().

Similar results can be achieved with PECL mysqlnd_ms < 1.2.0, if using SQL hints to force the use of a certain type of node or using the master_on_write plugin configuration option. The first requires more code and causes more work on the application side. The latter is less refined than using the quality of service filter. Settings made through the function call can be reversed, as shown in the example below. The example temporarily switches to a higher service level (session consistency, read your writes) and returns back to the clusters default after it has performed all operations that require the better service. This way, read load on the master can be minimized compared to using master_on_write, which would continue using the master after the first write.

Since 1.5.0 calls will fail when done in the middle of a transaction if transaction stickiness is enabled and transaction boundaries have been detected. properly.

参数

connection

A PECL/mysqlnd_ms connection handle to a MySQL server of the type PDO_MYSQL, mysqli or ext/mysql for which a service level is to be set. The connection handle is obtained when opening a connection with a host name that matches a mysqlnd_ms configuration file entry using any of the above three MySQL driver extensions.

service_level

The requested service level: MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_CONSISTENCY_SESSION or MYSQLND_MS_QOS_CONSISTENCY_STRONG.

service_level_option

An option to parameterize the requested service level. The option can either be MYSQLND_MS_QOS_OPTION_GTID or MYSQLND_MS_QOS_OPTION_AGE.

The option MYSQLND_MS_QOS_OPTION_GTID can be used to refine the service level MYSQLND_MS_QOS_CONSISTENCY_SESSION. It must be combined with a fourth function parameter, the option_value. The option_value shall be a global transaction ID obtained from mysqlnd_ms_get_last_gtid(). If set, the plugin considers both master servers and asynchronous slaves for session consistency (read your writes). Otherwise, only masters are used to achieve session consistency. A slave is considered up-to-date and checked if it has already replicated the global transaction ID from option_value. Please note, searching appropriate slaves is an expensive and slow operation. Use the feature sparsely, if the master cannot handle the read load alone.

The MYSQLND_MS_QOS_OPTION_AGE option can be combined with the MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL service level, to filter out asynchronous slaves that lag more seconds behind the master than option_value. If set, the plugin will only consider slaves for reading if SHOW SLAVE STATUS reports Slave_IO_Running=Yes, Slave_SQL_Running=Yes and Seconds_Behind_Master <= option_value. Please note, searching appropriate slaves is an expensive and slow operation. Use the feature sparsely in version 1.2.0. Future versions may improve the algorithm used to identify candidates. Please, see the MySQL reference manual about the precision, accuracy and limitations of the MySQL administrative command SHOW SLAVE STATUS.

option_value

Parameter value for the service level option. See also the service_level_option parameter.

返回值

Returns true if the connections service level has been switched to the requested. Otherwise, returns false

注释

Note:

mysqlnd_ms_set_qos() requires PHP >= 5.4.0 and PECL mysqlnd_ms >= 1.2.0. Internally, it is using a mysqlnd library C functionality not available with PHP 5.3.

Please note, all MySQL 5.6 production versions do not provide clients with enough information to use GTIDs for enforcing session consistency. In the worst case, the plugin will choose the master only.

范例

Example #1 mysqlnd_ms_set_qos() example

<?php
/* Open mysqlnd_ms connection using mysqli, PDO_MySQL or mysql extension */
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Session consistency: read your writes */
$ret = mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION);
if (!$ret)
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Will use master and return fresh data, client can see his last write */
if (!$res = $mysqli->query("SELECT item, price FROM orders WHERE order_id = 1"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Back to default: use of all slaves and masters permitted, stale data can happen */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
?>

参见

  • mysqlnd_ms_get_last_gtid() - 返回最后的全局同步 ID (GTID)
  • Service level and consistency concept
  • Filter concept


Sets a callback for user-defined read/write splitting

  • ? mysqlnd_ms_set_qos
  • mysqlnd_ms_xa_begin ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Sets a callback for user-defined read/write splitting

mysqlnd_ms_set_user_pick_server

(PECL mysqlnd_ms < 1.1.0)

mysqlnd_ms_set_user_pick_server — Sets a callback for user-defined read/write splitting

说明

mysqlnd_ms_set_user_pick_server ( string $function ) : bool

Sets a callback for user-defined read/write splitting. The plugin will call the callback only if pick[]=user is the default rule for server picking in the relevant section of the plugins configuration file.

The plugins built-in read/write query split mechanism decisions can be overwritten in two ways. The easiest way is to prepend the query string with the SQL hints MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH or MYSQLND_MS_LAST_USED_SWITCH. Using SQL hints one can control, for example, whether a query shall be send to the MySQL replication master server or one of the slave servers. By help of SQL hints it is not possible to pick a certain slave server for query execution.

Full control on server selection can be gained using a callback function. Use of a callback is recommended to expert users only because the callback has to cover all cases otherwise handled by the plugin.

The plugin will invoke the callback function for selecting a server from the lists of configured master and slave servers. The callback function inspects the query to run and picks a server for query execution by returning the hosts URI, as found in the master and slave list.

If the lazy connections are enabled and the callback chooses a slave server for which no connection has been established so far and establishing the connection to the slave fails, the plugin will return an error upon the next action on the failed connection, for example, when running a query. It is the responsibility of the application developer to handle the error. For example, the application can re-run the query to trigger a new server selection and callback invocation. If so, the callback must make sure to select a different slave, or check slave availability, before returning to the plugin to prevent an endless loop.

参数

function

The function to be called. Class methods may also be invoked statically using this function by passing array($classname, $methodname) to this parameter. Additionally class methods of an object instance may be called by passing array($objectinstance, $methodname) to this parameter.

返回值

Host to run the query on. The host URI is to be taken from the master and slave connection lists passed to the callback function. If callback returns a value neither found in the master nor in the slave connection lists the plugin will fallback to the second pick method configured via the pick[] setting in the plugin configuration file. If not second pick method is given, the plugin falls back to the build-in default pick method for server selection.

注释

Note:

mysqlnd_ms_set_user_pick_server() is available with PECL mysqlnd_ms < 1.1.0. It has been replaced by the user filter. Please, check the Change History for upgrade notes.

范例

Example #1 mysqlnd_ms_set_user_pick_server() example

[myapp]
master[] = localhost
slave[] = 192.168.2.27:3306
slave[] = 192.168.78.136:3306
pick[] = user
<?php

function pick_server($connected, $query, $master, $slaves, $last_used)
{
 static $slave_idx = 0;
 static $num_slaves = NULL;
 if (is_null($num_slaves))
  $num_slaves = count($slaves);

 /* default: fallback to the plugins build-in logic */
 $ret = NULL;

 printf("User has connected to '%s'...\n", $connected);
 printf("... deciding where to run '%s'\n", $query);

 $where = mysqlnd_ms_query_is_select($query);
 switch ($where)
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("... using master\n");
   $ret = $master[0];
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   /* SELECT or SQL hint for using slave */
   if (stristr($query, "FROM table_on_slave_a_only"))
   {
    /* a table which is only on the first configured slave  */
    printf("... access to table available only on slave A detected\n");
    $ret = $slaves[0];
   }
   else
   {
    /* round robin */
    printf("... some read-only query for a slave\n");
    $ret = $slaves[$slave_idx++ % $num_slaves];
   }
   break;
  case MYSQLND_MS_QUERY_LAST_USED:
   printf("... using last used server\n");
   $ret = $last_used;
   break;
 }

 printf("... ret = '%s'\n", $ret);
 return $ret;
}

mysqlnd_ms_set_user_pick_server("pick_server");

$mysqli = new mysqli("myapp", "root", "root", "test");

if (!($res = $mysqli->query("SELECT 1 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT 2 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT * FROM table_on_slave_a_only")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

$mysqli->close();
?>

以上例程会输出：

User has connected to 'myapp'...
... deciding where to run 'SELECT 1 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.2.27:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT 2 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.78.136:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT * FROM table_on_slave_a_only'
... access to table available only on slave A detected
... ret = 'tcp://192.168.2.27:3306'

参见

  • mysqlnd_ms_query_is_select() - 查询给定的 SQL 会发送给 master、slave 还是最后使用的 MySQL server 执行。
  • Filter concept
  • user filter


Starts a distributed/XA transaction among MySQL servers

  • ? mysqlnd_ms_set_user_pick_server
  • mysqlnd_ms_xa_commit ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Starts a distributed/XA transaction among MySQL servers

mysqlnd_ms_xa_begin

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_begin — Starts a distributed/XA transaction among MySQL servers

说明

mysqlnd_ms_xa_begin ( mixed $connection , string $gtrid , int $timeout = ? ) : int

Starts a XA transaction among MySQL servers. PECL/mysqlnd_ms acts as a transaction coordinator the distributed transaction.

Once a global transaction has been started, the plugin injects appropriate XA BEGIN SQL statements on all MySQL servers used in the following. The global transaction is either ended by calling mysqlnd_ms_xa_commit(), mysqlnd_ms_xa_rollback() or by an implicit rollback in case of an error.

During a global transaction, the plugin tracks all server switches, for example, when switching from one MySQL shard to another MySQL shard. Immediately before a query is run on a server that has not been participating in the global transaction yet, XA BEGIN is executed on the server. From a users perspective the injection happens during a call to a query execution function such as mysqli_query(). Should the injection fail an error is reported to the caller of the query execution function. The failing server does not become a participant in the global transaction. The user may retry executing a query on the server and hereby retry injecting XA BEGIN, abort the global transaction because not all required servers can participate, or ignore and continue the global without the failed server.

Reasons to fail executing XA BEGIN include but are not limited to a server being unreachable or the server having an open, concurrent XA transaction using the same xid.

Please note, global and local transactions are mutually exclusive. You cannot start a XA transaction when you have a local transaction open. The local transaction must be ended first. The plugin tries to detect this conflict as early as possible. It monitors API calls for controlling local transactions to learn about the current state. However, if using SQL statements for local transactions such as BEGIN, the plugin may not know the current state and the conflict is not detected before XA BEGIN is injected and executed.

The use of other XA resources but MySQL servers is not supported by the function. To carry out a global transaction among, for example, a MySQL server and another vendors database system, you should issue the systems SQL commands yourself.

Note: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

参数

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

gtrid

Global transaction identifier (gtrid). The gtrid is a binary string up to 64 bytes long. Please note, depending on your character set settings, 64 characters may require more than 64 bytes to store.

In accordance with the MySQL SQL syntax, XA transactions use identifiers made of three parts. An xid consists of a global transaction identifier (gtrid), a branch qualifier (bqual) and a format identifier (formatID). Only the global transaction identifier can and needs to be set.

The branch qualifier and format identifier are set automatically. The details should be considered implementation dependent, which may change without prior notice. In version 1.6 the branch qualifier is consecutive number which is incremented whenever a participant joins the global transaction.

timeout

Timeout in seconds. The default value is 60 seconds.

The timeout is a hint to the garbage collection. If a transaction is recorded to take longer than expected, the garbage collection begins checking the transactions status.

Setting a low value may make the garbage collection check the progress too often. Please note, checking the status of a global transaction may involve connecting to all recorded participants and possibly issuing queries on the servers.

返回值

Returns true if there is no open local or global transaction and a new global transaction can be started. Otherwise, returns false

参见

  • Quickstart XA/Distributed transactions
  • Runtime configuration
  • mysqlnd_ms_get_stats() - Returns query distribution and connection statistics


Commits a distributed/XA transaction among MySQL servers

  • ? mysqlnd_ms_xa_begin
  • mysqlnd_ms_xa_gc ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Commits a distributed/XA transaction among MySQL servers

mysqlnd_ms_xa_commit

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_commit — Commits a distributed/XA transaction among MySQL servers

说明

mysqlnd_ms_xa_commit ( mixed $connection , string $gtrid ) : bool

Commits a global transaction among MySQL servers started by mysqlnd_ms_xa_begin().

If any of the global transaction participants fails to commit an implicit rollback is performed. It may happen that not all cases can be handled during the rollback. For example, no attempts will be made to reconnect to a participant after the connection to the participant has been lost. Solving cases that cannot easily be rolled back is left to the garbage collection.

Note: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

参数

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

gtrid

Global transaction identifier (gtrid).

返回值

Returns true if the global transaction has been committed. Otherwise, returns false

参见

  • Quickstart XA/Distributed transactions
  • Runtime configuration
  • mysqlnd_ms_get_stats() - Returns query distribution and connection statistics


Garbage collects unfinished XA transactions after severe errors

  • ? mysqlnd_ms_xa_commit
  • mysqlnd_ms_xa_rollback ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Garbage collects unfinished XA transactions after severe errors

mysqlnd_ms_xa_gc

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_gc — Garbage collects unfinished XA transactions after severe errors

说明

mysqlnd_ms_xa_gc ( mixed $connection , string $gtrid = ? , bool $ignore_max_retries = ? ) : int

Garbage collects unfinished XA transactions.

The XA protocol is a blocking protocol. There exist cases when servers participating in a global transaction cannot make progress when the transaction coordinator crashes or disconnects. In such a case, the MySQL servers keep waiting for instructions to finish the XA transaction in question. Because transactions occupy resources, transactions should always be terminated properly.

Garbage collection requires configuring a state store to track global transactions. Should a PHP client crash in the middle of a transaction and a new PHP client be started, then the built-in garbage collection can learn about the aborted global transaction and terminate it. If you do not configure a state store, the garbage collection cannot perform any cleanup tasks.

The state store should be crash-safe and be highly available to survive its own crash. Currently, only MySQL is supported as a state store.

Garbage collection can also be performed automatically in the background. See the plugin configuration directive garbage_collection for details.

Note: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

参数

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

gtrid

Global transaction identifier (gtrid). If given, the garbage collection considers the transaction only. Otherwise, the state store is scanned for any unfinished transaction.

ignore_max_retries

Whether to ignore the plugin configuration max_retries setting. If garbage collection continuously fails and the max_retries limit is reached prior to finishing the failed global transaction, you can attempt further runs prior to investigating the cause and solving the issue manually by issuing appropriate SQL statements on the participants. Setting the parameter has the same effect as temporarily setting max_retries = 0.

返回值

Returns true if garbage collection was successful. Otherwise, returns false

参见

  • Quickstart XA/Distributed transactions
  • Runtime configuration
  • State store configuration
  • mysqlnd_ms_get_stats() - Returns query distribution and connection statistics


Rolls back a distributed/XA transaction among MySQL servers

  • ? mysqlnd_ms_xa_gc
  • Change History ?
  • PHP Manual
  • Mysqlnd_ms 函数
  • Rolls back a distributed/XA transaction among MySQL servers

mysqlnd_ms_xa_rollback

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_rollback — Rolls back a distributed/XA transaction among MySQL servers

说明

mysqlnd_ms_xa_rollback ( mixed $connection , string $gtrid ) : int

Rolls back a global transaction among MySQL servers started by mysqlnd_ms_xa_begin().

If any of the global transaction participants fails to rollback the situation is left to be solved by the garbage collection.

Note: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

参数

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

gtrid

Global transaction identifier (gtrid).

返回值

Returns true if the global transaction has been rolled back. Otherwise, returns false

参见

  • Quickstart XA/Distributed transactions
  • Runtime configuration
  • mysqlnd_ms_get_stats() - Returns query distribution and connection statistics


Change History

Table of Contents

  • PECL/mysqlnd_ms 1.6 series
  • PECL/mysqlnd_ms 1.5 series
  • PECL/mysqlnd_ms 1.4 series
  • PECL/mysqlnd_ms 1.3 series
  • PECL/mysqlnd_ms 1.2 series
  • PECL/mysqlnd_ms 1.1 series
  • PECL/mysqlnd_ms 1.0 series

This change history is a high level summary of selected changes that may impact applications and/or break backwards compatibility.

See also the CHANGES file in the source distribution for a complete list of changes.


PECL/mysqlnd_ms 1.6 series

1.6.0-alpha

  • Release date: TBD
  • Motto/theme: Maintenance and initial MySQL Fabric support

Note:

This is the current development series. All features are at an early stage. Changes may happen at any time without prior notice. Please, do not use this version in production environments.

The documentation may not reflect all changes yet.

Bug fixes

  • Won't fix: #66616 R/W split fails: QOS with mysqlnd_get_last_gtid with built-in MySQL GTID

    This is not a bug in the plugins implementation but a server side feature limitation not considered and documented before. MySQL 5.6 built-in GTIDs cannot be used to ensure session consistency when reading from slaves in all cases. In the worst case the plugin will not consider using the slaves and fallback to using the master. There will be no wrong results but no benefit from doing GTID checks either.

  • Fixed #66064 - Random once load balancer ignoring weights

    Due to a config parsing bug random load balancing has ignored node weights if, and only if, the sticky flag was set (random once).

  • Fixed #65496 - Wrong check for slave delay

    The quality of service filter has erroneously ignored slaves that lag for zero (0) seconds if a any maximum lag had been set. Although a slave was not lagging behind, it was excluded from the load balancing list if a maximum age was set by the QoS filter. This was due to using the wrong comparison operator in the source of the filter.

  • Fixed #65408 - Compile failure with -Werror=format-security

Feature changes

  • Introduced an internal connection pool. When using Fabric and switching from shard group A to shard group B, we are replacing the entire list of masters and slaves. This troubles the connections state alignment logic and some filters. Some filters cache information on the master and slave lists. The new internal connection pool abstraction allows us to inform the filters of changes, hence they can update their caches.

    Later on, the pool can also be used to reduce connection overhead. Assume you are switching from a shard group to another and back again. Whenever the switch is done, the pool's active server (and connection) lists are replaced. However, no longer used connections are not necessarily closed immediately but can be kept in the pool for later reuse.

    Please note, the connection pool is internalat this point. There are some new statistics to monitor it. However, you cannot yet configure pool size of behaviour.

  • Added a basic distributed transaction abstraction. XA transactions can are supported ever since using standard SQL calls. This is inconvenient as XA participants must be managed manually. PECL/mysqlnd_ms introduces API calls to control XA transaction among MySQL servers. When using the new functions, PECL/mysqlnd_ms acts as a transaction coordinator. After starting a distributed transaction, the plugin tracks all servers involved until the transaction is ended and issues appropriate SQL statements on the XA participants.

    This is useful, for example, when using Fabric and sharding. When using Fabric the actual shard servers involved in a business transaction may not be known in advance. Thus, manually controlling a transaction that spawns multiple shards becomes difficult. Please, be warned about current limitations.

  • Introduced automatic retry loop for transient errors and corresponding statistic to count the number of implicit retries. Some distributed database clusters use transient errors to hint a client to retry its operation in a bit. Most often, the client is then supposed to halt execution (sleep) for a short moment before retrying the desired operation. Immediately failing over to another node is not necessary in response to the error. Instead, a retry loop can be performed. Common situation when using MySQL Cluster.

  • Introduced automatic retry loop for transient errors and corresponding statistic to count the number of implicit retries. Some distributed database clusters use transient errors to hint a client to retry its operation in a bit. Most often, the client is then supposed to halt execution (sleep) for a short moment before retrying the desired operation. Immediately failing over to another node is not necessary in response to the error. Instead, a retry loop can be performed. Common situation when using MySQL Cluster.

  • Introduced most basic support for the MySQL Fabric High Availability and sharding framework.

    Please, consider this pre-alpha quality. Both the server side framework and the client side code is supposed to work flawless considering the MySQL Fabric quickstart examples only. However, testing has not been performed to the level of prior plugin alpha releases. Either sides are moving targets, API changes may happen at any time without prior warning.

    As this is work in progress, the manual may not yet reflect allow feature limitations and known bugs.

  • New statistics to monitor the Fabric XML RPC call sharding.lookup_servers: fabric_sharding_lookup_servers_success, fabric_sharding_lookup_servers_failure, fabric_sharding_lookup_servers_time_total, fabric_sharding_lookup_servers_bytes_total, fabric_sharding_lookup_servers_xml_failure.

  • New functions related to MySQL Fabric:
mysqlnd_ms_fabric_select_shard(),
mysqlnd_ms_fabric_select_global(),
mysqlnd_ms_dump_servers().


PECL/mysqlnd_ms 1.5 series

1.5.1-stable

  • Release date: 06/2013
  • Motto/theme: Sharding support, improved transaction support

Note:

This is the current stable series. Use this version in production environments.

The documentation is complete.

1.5.0-alpha

  • Release date: 03/2013
  • Motto/theme: Sharding support, improved transaction support

Bug fixes

  • Fixed #60605 PHP segmentation fault when mysqlnd_ms is enabled.

  • Setting transaction stickiness disables all load balancing, including automatic failover, for the duration of a transaction. So far connection switches could have happened in the middle of a transaction in multi-master configurations and during automatic failover although transaction monitoring had detected transaction boundaries properly.

  • BC break and bug fix. SQL hints enforcing the use of a specific kind of server (MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH, MYSQLND_MS_LAST_USED_SWITCH) are ignored for the duration of a transaction of transaction stickiness is enabled and transaction boundaries have been detected properly.

    This is a change in behaviour. However, it is also a bug fix and a step to align behaviour. If, in previous versions, transaction stickiness, one of the above listed SQL hints and the quality of service filtering was combined it could happened that the SQL hints got ignored. In some case the SQL hints did work, in other cases they did not. The new behaviour is more consistent. SQL hints will always be ignore for the duration of a transaction, if transaction stickiness is enabled.

    Please note, transaction boundary detection continues to be based on API call monitoring. SQL commands controlling transactions are not monitored.

  • BC break and bug fix. Calls to mysqlnd_ms_set_qos() will fail when done in the middle of a transaction if transaction stickiness is enabled. Connection switches are not allowed for the duration of a transaction. Changing the quality of service likely results on a different set of servers qualifying for query execution, possibly making it necessary to switch connections. Thus, the call is not allowed in during an active transaction. The quality of server can, however, be changed in between transactions.

Feature changes

  • Introduced the node_group filter. The filter lets you organize servers (master and slaves) into groups. Queries can be directed to a certain group of servers by prefixing the query statement with a SQL hint/comment that contains the groups configured name. Grouping can be used for partitioning and sharding, and also to optimize for local caching. In the case of sharding, a group name can be thought of like a shard key. All queries for a given shard key will be executed on the configured shard. Note: both the client and server must support sharding for sharding to function with mysqlnd_ms.

  • Extended configuration file validation during PHP startup (RINIT). An E_WARNING level error will be thrown if the configuration file can not be read (permissions), is empty, or the file (JSON) could not be parsed. Warnings may appear in log files, which depending on how PHP is configured.

    Distributions that aim to provide a pre-configured setup, including a configuration file stub, are asked to put {} into the configuration file to prevent this warning about an invalid configuration file.

    Further configuration file validation is done when parsing sections upon opening a connection. Please, note that there may still be situations when an invalid plugin configuration file does not lead to proper error messages but a failure to connect.

  • As of PHP 5.5.0, improved support for transaction boundaries detection was added for mysqli. The mysqli extension has been modified to use the new C API calls of the mysqlnd library to begin, commit, and rollback a transaction or savepoint. If trx_stickiness is used to enable transaction aware load balancing, the mysqli_begin(), mysqli_commit() and mysqli_rollback() functions will now be monitered by the plugin, to go along with the mysqli_autocommit() function that was already supported. All SQL features to control transactions are also available through the improved mysqli transaction control related functions. This means that it is not required to issue SQL statements instead of using API calls. Applications using the appropriate API calls can be load balanced by PECL/mysqlnd_ms in a completely transaction-aware way.

    Please note, PDO_MySQL has not been updated yet to utilize the new mysqlnd API calls. Thus, transaction boundary detection with PDO_MySQL continues to be limited to the monitoring by passing in PDO::ATTR_AUTOCOMMIT to PDO::setAttribute().

  • Introduced trx_stickiness=on. This trx_stickiness option differs from trx_stickiness=master as it tries to execute a read-only transaction on a slave, if quality of service (consistency level) allows the use of a slave. Read-only transactions were introduced in MySQL 5.6, and they offer performance gains.

  • Query cache support is considered beta if used with the mysqli API. It should work fine with primary copy based clusters. For all other APIs, this feature continues to be called experimental.

  • The code examples in the mysqlnd_ms source were updated.


PECL/mysqlnd_ms 1.4 series

1.4.2-stable

  • Release date: 08/2012
  • Motto/theme: Tweaking based on user feedback

1.4.1-beta

  • Release date: 08/2012
  • Motto/theme: Tweaking based on user feedback

Bug fixes

  • Fixed build with PHP 5.5

1.4.0-alpha

  • Release date: 07/2012
  • Motto/theme: Tweaking based on user feedback

Feature changes

  • BC break: Renamed plugin configuration setting ini_file to config_file. In early versions the plugin configuration file used ini style. Back then the configuration setting was named accordingly. It has now been renamed to reflect the newer file format and to distinguish it from PHP's own ini file (configuration directives file).

  • Introduced new default charset setting server_charset to allow proper escaping before a connection is opened. This is most useful when using lazy connections, which are a default.

  • Introduced wait_for_gtid_timeout setting to throttle slave reads that need session consistency. If global transaction identifier are used and the service level is set to session consistency, the plugin tries to find up-to-date slaves. The slave status check is done by a SQL statement. If nothing else is set, the slave status is checked only one can the search for more up-to-date slaves continues immediately thereafter. Setting wait_for_gtid_timeout instructs the plugin to poll a slaves status for wait_for_gtid_timeout seconds if the first execution of the SQL statement has shown that the slave is not up-to-date yet. The poll will be done once per second. This way, the plugin will wait for slaves to catch up and throttle the client.

  • New failover strategy loop_before_master. By default the plugin does no failover. It is possible to enable automatic failover if a connection attempt fails. Upto version 1.3 only master strategy existed to failover to a master if a slave connection fails. loop_before_master is similar but tries all other slaves before attempting to connect to the master if a slave connection fails.

    The number of attempts can be limited using the max_retries option. Failed hosts can be remembered and skipped in load balancing for the rest of the web request. max_retries and remember_failed are considered experimental although decent stability is given. Syntax and semantics may change in the future without prior notice.


PECL/mysqlnd_ms 1.3 series

1.3.2-stable

  • Release date: 04/2012
  • Motto/theme: see 1.3.0-alpha

Bug fixes

  • Fixed problem with multi-master where although in a transaction the queries to the master weren't sticky and were spread all over the masters (RR). Still not sticky for Random. Random_once is not affected.

1.3.1-beta

  • Release date: 04/2012
  • Motto/theme: see 1.3.0-alpha

Bug fixes

  • Fixed problem with building together with QC.

1.3.0-alpha

  • Release date: 04/2012
  • Motto/theme: Query caching through quality-of-service concept

The 1.3 series aims to improve the performance of applications and the overall load of an asynchronous MySQL cluster, for example, a MySQL cluster using MySQL Replication. This is done by transparently replacing a slave access with a local cache access, if the application allows it by setting an appropriate quality of service flag. When using MySQL replication a slave can serve stale data. An application using MySQL replication must continue to work correctly with stale data. Given that the application is know to work correctly with stale data, the slave access can transparently be replace with a local cache access.

PECL/mysqlnd_qc serves as a cache backend. PECL/mysqlnd_qc supports use of various storage locations, among others main memory, APC and MEMCACHE.

Feature changes

  • Added cache option to quality-of-service (QoS) filter.

    • New configure option enable-mysqlnd-ms-cache-support
    • New constant MYSQLND_MS_HAVE_CACHE_SUPPORT.
    • New constant MYSQLND_MS_QOS_OPTION_CACHE to be used with mysqlnd_ms_set_qos().

  • Support for built-in global transaction identifier feature of MySQL 5.6.5-m8 or newer.


PECL/mysqlnd_ms 1.2 series

1.2.1-beta

  • Release date: 01/2012
  • Motto/theme: see 1.2.0-alpha

Minor test changes.

1.2.0-alpha

  • Release date: 11/2011
  • Motto/theme: Global Transaction ID injection and quality-of-service concept

In version 1.2 the focus continues to be on supporting MySQL database clusters with asynchronous replication. The plugin tries to make using the cluster introducing a quality-of-service filter which applications can use to define what service quality they need from the cluster. Service levels provided are eventual consistency with optional maximum age/slave slag, session consistency and strong consistency.

Additionally the plugin can do client-side global transaction id injection to make manual master failover easier.

Feature changes

  • Introduced quality-of-service (QoS) filter. Service levels provided by QoS filter:

    • eventual consistency, optional option slave lag
    • session consistency, optional option GTID
    • strong consistency

  • Added the mysqlnd_ms_set_qos() function to set the required connection quality at runtime. The new constants related to mysqlnd_ms_set_qos() are:

    • MYSQLND_MS_QOS_CONSISTENCY_STRONG
    • MYSQLND_MS_QOS_CONSISTENCY_SESSION
    • MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL
    • MYSQLND_MS_QOS_OPTION_GTID
    • MYSQLND_MS_QOS_OPTION_AGE

  • Added client-side global transaction id injection (GTID).

  • New statistics related to GTID:

    • gtid_autocommit_injections_success
    • gtid_autocommit_injections_failure
    • gtid_commit_injections_success
    • gtid_commit_injections_failure
    • gtid_implicit_commit_injections_success
    • gtid_implicit_commit_injections_failure

  • Added mysqlnd_ms_get_last_gtid() to fetch the last global transaction id.

  • Enabled support for multi master without slaves.


PECL/mysqlnd_ms 1.1 series

1.1.0

  • Release date: 09/2011
  • Motto/theme: Cover replication basics with production quality

The 1.1 and 1.0 series expose a similar feature set. Internally, the 1.1 series has been refactored to plan for future feature additions. A new configuration file format has been introduced, and limitations have been lifted. And the code quality and quality assurance has been improved.

Feature changes

  • Added the (chainable) filter concept:

    • BC break: mysqlnd_ms_set_user_pick_server() has been removed. Thehttp://svn.php.net/viewvc/pecl/mysqlnd_ms/trunk/ user filter has been introduced to replace it. The filter offers similar functionality, but see below for an explanation of the differences.

  • New powerful JSON based configuration syntax.
  • Lazy connections improved: security relevant, and state changing commands are covered.
  • Support for (native) prepared statements.

  • New statistics: use_master_guess, use_slave_guess.

    • BC break: Semantics of statistics changed for use_slave, use_master. Future changes are likely. Please see, mysqlnd_ms_get_stats().

  • List of broadcasted messages extended by ssl_set.
  • Library calls now monitored to remember settings for lazy connections: change_user, select_db, set_charset, set_autocommit.
  • Introduced mysqlnd_ms.disable_rw_split. The configuration setting allows using the load balancing and lazy connection functionality independently of read write splitting.

Bug fixes

  • Fixed PECL #22724 - Server switching (mysqlnd_ms_query_is_select() case sensitive)
  • Fixed PECL #22784 - Using mysql_connect and mysql_select_db did not work
  • Fixed PECL #59982 - Unusable extension with --enable-mysqlnd-ms-table-filter. Use of the option is NOT supported. You must not used it. Added note to m4.
  • Fixed Bug #60119 - host="localhost" lost in mysqlnd_ms_get_last_used_connection()

The mysqlnd_ms_set_user_pick_server() function was removed, and replaced in favor of a new user filter. You can no longer set a callback function using mysqlnd_ms_set_user_pick_server() at runtime, but instead have to configure it in the plugins configuration file. The user filter will pass the same arguments to the callback as before. Therefore, you can continue to use the same procedural function as a callback.callback It is no longer possible to use static class methods, or class methods of an object instance, as a callback. Doing so will cause the function executing a statement handled by the plugin to emit an E_RECOVERABLE_ERROR level error, which might look like: "(mysqlnd_ms) Specified callback (picker) is not a valid callback." Note: this may halt your application.


PECL/mysqlnd_ms 1.0 series

1.0.1-alpha

  • Release date: 04/2011
  • Motto/theme: bug fix release

1.0.0-alpha

  • Release date: 04/2011
  • Motto/theme: Cover replication basics to test user feedback

The first release of practical use. It features basic automatic read-write splitting, SQL hints to overrule automatic redirection, load balancing of slave requests, lazy connections, and optional, automatic use of the master after the first write.

The public feature set is close to that of the 1.1 release.

1.0.0-pre-alpha

  • Release date: 09/2010
  • Motto/theme: Proof of concept

Initial check-in. Essentially a demo of the mysqlnd plugin API.


Mysqlnd query result cache plugin

  • 简介
  • Quickstart and Examples
    • Architecture and Concepts
    • Setup
    • Caching queries
    • Setting the TTL
    • Pattern based caching
    • Slam defense
    • Finding cache candidates
    • Measuring cache efficiency
    • Beyond TTL: user-defined storage
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • mysqlnd_qc 函数
    • mysqlnd_qc_clear_cache — Flush all cache contents
    • mysqlnd_qc_get_available_handlers — Returns a list of available storage handler
    • mysqlnd_qc_get_cache_info — Returns information on the current handler, the number of cache entries and cache entries, if available
    • mysqlnd_qc_get_core_stats — Statistics collected by the core of the query cache
    • mysqlnd_qc_get_normalized_query_trace_log — Returns a normalized query trace log for each query inspected by the query cache
    • mysqlnd_qc_get_query_trace_log — Returns a backtrace for each query inspected by the query cache
    • mysqlnd_qc_set_cache_condition — Set conditions for automatic caching
    • mysqlnd_qc_set_is_select — Installs a callback which decides whether a statement is cached
    • mysqlnd_qc_set_storage_handler — Change current storage handler
    • mysqlnd_qc_set_user_handlers — Sets the callback functions for a user-defined procedural storage handler
  • Change History
    • PECL/mysqlnd_qc 1.2 series
    • PECL/mysqlnd_qc 1.1 series
    • PECL/mysqlnd_qc 1.0 series


简介

The mysqlnd query result cache plugin adds easy to use client-side query caching to all PHP MySQL extensions using mysqlnd.

As of version PHP 5.3.3 the MySQL native driver for PHP ( mysqlnd) features an internal plugin C API. C plugins, such as the query cache plugin, can extend the functionality of mysqlnd.

Mysqlnd plugins such as the query cache plugin operate transparent from a user perspective. The cache plugin supports all PHP applications and all PHP MySQL extensions ( mysqli, mysql, PDO_MYSQL). It does not change existing APIs.

No significant application changes are required to cache a query. The cache has two operation modes. It will either cache all queries (not recommended) or only those queries marked with a certain SQL hint (recommended).

Key Features

  • Transparent and therefore easy to use

    • supports all PHP MySQL extensions

    • no API changes

    • very little application changes required

  • Flexible invalidation strategy

    • Time-to-Live (TTL)

    • user-defined

  • Storage with different scope and life-span

    • Default (Hash, process memory)

    • APC

    • MEMCACHE

    • sqlite

    • user-defined

  • Built-in slam defense to prevent cache stampeding.

Limitations

The current 1.0.1 release of PECL mysqlnd_qc does not support PHP 5.4. Version 1.1.0-alpha lifts this limitation.

Prepared statements and unbuffered queries are fully supported. Thus, the plugin is capable of caching all statements issued with mysqli or PDO_MySQL, which are the only two PHP MySQL APIs to offer prepared statement support.

On the name

The shortcut mysqlnd_qc stands for mysqlnd query cache plugin. The name was chosen for a quick-and-dirty proof-of-concept. In the beginning the developers did not expect to continue using the code base. Sometimes PECL/mysqlnd_qc has also been called client-side query result set cache.


Quickstart and Examples

Table of Contents

  • Architecture and Concepts
  • Setup
  • Caching queries
  • Setting the TTL
  • Pattern based caching
  • Slam defense
  • Finding cache candidates
  • Measuring cache efficiency
  • Beyond TTL: user-defined storage

The mysqlnd query cache plugin is easy to use. This quickstart will demo typical use-cases, and provide practical advice on getting started.

It is strongly recommended to read the reference sections in addition to the quickstart. It is safe to begin with the quickstart. However, before using the plugin in mission critical environments we urge you to read additionally the background information from the reference sections.

Most of the examples use the mysqli extension because it is the most feature complete PHP MySQL extension. However, the plugin can be used with any PHP MySQL extension that is using the mysqlnd library.


Architecture and Concepts

The query cache plugin is implemented as a PHP extension. It is written in C and operates under the hood of PHP. During the startup of the PHP interpreter, it gets registered as a mysqlnd plugin to replace selected mysqlnd C methods. Hereby, it can change the behaviour of any PHP MySQL extension (mysqli, PDO_MYSQL, mysql) compiled to use the mysqlnd library without changing the extensions API. This makes the plugin compatible with each and every PHP MySQL application. Because existing APIs are not changed, it is almost transparent to use. Please, see the mysqlnd plugin API description for a discussion of the advantages of the plugin architecture and a comparison with proxy based solutions.

Transparent to use

At PHP run time PECL/mysqlnd_qc can proxy queries send from PHP (mysqlnd) to the MySQL server. It then inspects the statement string to find whether it shall cache its results. If so, result set is cached using a storage handler and further executions of the statement are served from the cache for a user-defined period. The Time to Live (TTL) of the cache entry can either be set globally or on a per statement basis.

A statement is either cached if the plugin is instructed to cache all statements globally using a or, if the query string starts with the SQL hint (/*qc=on*/). The plugin is capable of caching any query issued by calling appropriate API calls of any of the existing PHP MySQL extensions.

Flexible storage: various storage handler

Various storage handler are supported to offer different scopes for cache entries. Different scopes allow for different degrees in sharing cache entries among clients.

  • default (built-in): process memory, scope: process, one or more web requests depending on PHP deployment model used

  • APC: shared memory, scope: single server, multiple web requests

  • SQLite: memory or file, scope: single server, multiple web requests

  • MEMCACHE: main memory, scope: single or multiple server, multiple web requests

  • user (built-in): user-defined - any, scope: user-defined - any

Support for the APC, SQLite and MEMCACHE storage handler has to be enabled at compile time. The default and user handler are built-in. It is possible to switch between compiled-in storage handlers on a per query basis at run time. However, it is recommended to pick one storage handler and use it for all cache entries.

Built-in slam defense to avoid overloading

To avoid overload situations the cache plugin has a built-in slam defense mechanism. If a popular cache entries expires many clients using the cache entries will try to refresh the cache entry. For the duration of the refresh many clients may access the database server concurrently. In the worst case, the database server becomes overloaded and it takes more and more time to refresh the cache entry, which in turn lets more and more clients try to refresh the cache entry. To prevent this from happening the plugin has a slam defense mechanism. If slam defense is enabled and the plugin detects an expired cache entry it extends the life time of the cache entry before it refreshes the cache entry. This way other concurrent accesses to the expired cache entry are still served from the cache for a certain time. The other concurrent accesses to not trigger a concurrent refresh. Ideally, the cache entry gets refreshed by the client which extended the cache entries lifespan before other clients try to refresh the cache and potentially cause an overload situation.

Unique approach to caching

PECL/mysqlnd_qc has a unique approach to caching result sets that is superior to application based cache solutions. Application based solutions first fetch a result set into PHP variables. Then, the PHP variables are serialized for storage in a persistent cache, and then unserialized when fetching. The mysqlnd query cache stores the raw wire protocol data sent from MySQL to PHP in its cache and replays it, if still valid, on a cache hit. This way, it saves an extra serialization step for a cache put that all application based solutions have to do. It can store the raw wire protocol data in the cache without having to serialize into a PHP variable first and deserializing the PHP variable for storing in the cache again.


Setup

The plugin is implemented as a PHP extension. See also the installation instructions to install the » PECL/mysqlnd_qc extension.

Compile or configure the PHP MySQL extension (mysqli, PDO_MYSQL, mysql) that you plan to use with support for the mysqlnd library. PECL/mysqlnd_qc is a plugin for the mysqlnd library. To use the plugin with any of the existing PHP MySQL extensions (APIs), the extension has to use the mysqlnd library.

Then, load the extension into PHP and activate the plugin in the PHP configuration file using the PHP configuration directive named mysqlnd_qc.enable_qc.

Example #1 Enabling the plugin (php.ini)

mysqlnd_qc.enable_qc=1


Caching queries

There are four ways to trigger caching of a query.

  • Use of SQL hints on a per query basis
  • User supplied callbacks to decide on a per query basis, for example, using mysqlnd_qc_is_select()
  • mysqlnd_set_cache_condition() for rule based automatic per query decisions
  • mysqlnd_qc.cache_by_default = 1 to cache all queries blindly

Use of SQL hints and mysqlnd_qc.cache_by_default = 1 are explained below. Please, refer to the function reference on mysqlnd_qc_is_select() for a description of using a callback and, mysqlnd_qc_set_cache_condition() on how to set rules for automatic caching.

A SQL hint is a SQL standards compliant comment. As a SQL comment it is ignored by the database. A statement is considered eligible for caching if it either begins with the SQL hint enabling caching or it is a SELECT statement.

An individual query which shall be cached must begin with the SQL hint /*qc=on*/. It is recommended to use the PHP constant MYSQLND_QC_ENABLE_SWITCH instead of using the string value.

  • not eligible for caching and not cached: INSERT INTO test(id) VALUES (1)

  • not eligible for caching and not cached: SHOW ENGINES

  • eligible for caching but uncached: SELECT id FROM test

  • eligible for caching and cached: /*qc=on*/SELECT id FROM test

The examples SELECT statement string is prefixed with the MYSQLND_QC_ENABLE_SWITCH SQL hint to enable caching of the statement. The SQL hint must be given at the very beginning of the statement string to enable caching.

Example #1 Using the MYSQLND_QC_ENABLE_SWITCH SQL hint

mysqlnd_qc.enable_qc=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* Will be cached because of the SQL hint */
$start = microtime(true);
$res   = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 1");

var_dump($res->fetch_assoc());
$res->free();

printf("Total time uncached query: %.6fs\n", microtime(true) - $start);

/* Cache hit */
$start = microtime(true);
$res   = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 1");

var_dump($res->fetch_assoc());
$res->free();

printf("Total time cached query: %.6fs\n", microtime(true) - $start);
?>

以上例程的输出类似于：

array(1) {
  ["id"]=>
  string(1) "1"
}
Total time uncached query: 0.000740s
array(1) {
  ["id"]=>
  string(1) "1"
}
Total time cached query: 0.000098s

If nothing else is configured, as it is the case in the quickstart example, the plugin will use the built-in default storage handler. The default storage handler uses process memory to hold a cache entry. Depending on the PHP deployment model, a PHP process may serve one or more web requests. Please, consult the web server manual for details. Details make no difference for the examples given in the quickstart.

The query cache plugin will cache all queries regardless if the query string begins with the SQL hint which enables caching or not, if the PHP configuration directive mysqlnd_qc.cache_by_default is set to 1. The setting mysqlnd_qc.cache_by_default is evaluated by the core of the query cache plugins. Neither the built-in nor user-defined storage handler can overrule the setting.

The SQL hint /*qc=off*/ can be used to disable caching of individual queries if mysqlnd_qc.cache_by_default = 1 It is recommended to use the PHP constant MYSQLND_QC_DISABLE_SWITCH instead of using the string value.

Example #2 Using the MYSQLND_QC_DISABLE_SWITCH SQL hint

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* Will be cached although no SQL hint is present because of mysqlnd_qc.cache_by_default = 1*/
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

$mysqli->query("DELETE FROM test WHERE id = 1");

/* Cache hit - no automatic invalidation and still valid! */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* Cache miss - query must not be cached because of the SQL hint */
$res = $mysqli->query("/*" . MYSQLND_QC_DISABLE_SWITCH . "*/SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();
?>

以上例程会输出：

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "1"
}
NULL

PECL/mysqlnd_qc forbids caching of statements for which at least one column from the statements result set shows no table name in its meta data by default. This is usually the case for columns originating from SQL functions such as NOW() or LAST_INSERT_ID(). The policy aims to prevent pitfalls if caching by default is used.

Example #3 Example showing which type of statements are not cached

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");

for ($i = 0; $i < 3; $i++) {

    $start = microtime(true);

    /* Note: statement will not be cached because of NOW() use */
    $res = $mysqli->query("SELECT id, NOW() AS _time FROM test");
    $row = $res->fetch_assoc();

    /* dump results */
    var_dump($row);

    printf("Total time: %.6fs\n", microtime(true) - $start);

    /* pause one second */
    sleep(1);
}
?>

以上例程的输出类似于：

array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:10"
}
Total time: 0.000540s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:11"
}
Total time: 0.000555s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:12"
}
Total time: 0.000549s

It is possible to enable caching for all statements including those which has columns in their result set for which MySQL reports no table, such as the statement from the example. Set mysqlnd_qc.cache_no_table = 1 to enable caching of such statements. Please, note the difference in the measured times for the above and below examples.

Example #4 Enabling caching for all statements using the mysqlnd_qc.cache_no_table ini setting

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
mysqlnd_qc.cache_no_table=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");

for ($i = 0; $i < 3; $i++) {

    $start = microtime(true);

    /* Note: statement will not be cached because of NOW() use */
    $res = $mysqli->query("SELECT id, NOW() AS _time FROM test");
    $row = $res->fetch_assoc();

    /* dump results */
    var_dump($row);

    printf("Total time: %.6fs\n", microtime(true) - $start);

    /* pause one second */
    sleep(1);
}
?>

以上例程的输出类似于：

array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Total time: 0.000546s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Total time: 0.000187s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Total time: 0.000167s

Note:

Although mysqlnd_qc.cache_no_table = 1 has been created for use with mysqlnd_qc.cache_by_default = 1 it is bound it. The plugin will evaluate the mysqlnd_qc.cache_no_table whenever a query is to be cached, no matter whether caching has been enabled using a SQL hint or any other measure.


Setting the TTL

The default invalidation strategy of the query cache plugin is Time to Live (TTL). The built-in storage handlers will use the default TTL defined by the PHP configuration value mysqlnd_qc.ttl unless the query string contains a hint for setting a different TTL. The TTL is specified in seconds. By default cache entries expire after 30 seconds

The example sets mysqlnd_qc.ttl=3 to cache statements for three seconds by default. Every second it updates a database table record to hold the current time and executes a SELECT statement to fetch the record from the database. The SELECT statement is cached for three seconds because it is prefixed with the SQL hint enabling caching. The output verifies that the query results are taken from the cache for the duration of three seconds before they are refreshed.

Example #1 Setting the TTL with the mysqlnd_qc.ttl ini setting

mysqlnd_qc.enable_qc=1
mysqlnd_qc.ttl=3
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id VARCHAR(255))");

for ($i = 0; $i < 7; $i++) {

    /* update DB row  */
    if (!$mysqli->query("DELETE FROM test") ||
        !$mysqli->query("INSERT INTO test(id) VALUES (NOW())"))
      /* Of course, a real-life script should do better error handling */
      die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

    /* select latest row but cache results */
    $query  = "/*" . MYSQLND_QC_ENABLE_SWITCH . "*/";
    $query .= "SELECT id AS _time FROM test";
    if (!($res = $mysqli->query($query)) ||
        !($row = $res->fetch_assoc()))
    {
      printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
    }
    $res->free();
    printf("Wall time %s - DB row time %s\n", date("H:i:s"), $row['_time']);

    /* pause one second */
    sleep(1);
}
?>

以上例程的输出类似于：

Wall time 14:55:59 - DB row time 2012-01-11 14:55:59
Wall time 14:56:00 - DB row time 2012-01-11 14:55:59
Wall time 14:56:01 - DB row time 2012-01-11 14:55:59
Wall time 14:56:02 - DB row time 2012-01-11 14:56:02
Wall time 14:56:03 - DB row time 2012-01-11 14:56:02
Wall time 14:56:04 - DB row time 2012-01-11 14:56:02
Wall time 14:56:05 - DB row time 2012-01-11 14:56:05

As can be seen from the example, any TTL based cache can serve stale data. Cache entries are not automatically invalidated, if underlying data changes. Applications using the default TTL invalidation strategy must be able to work correctly with stale data.

A user-defined cache storage handler can implement any invalidation strategy to work around this limitation.

The default TTL can be overruled using the SQL hint /*qc_tt=seconds*/. The SQL hint must be appear immediately after the SQL hint which enables caching. It is recommended to use the PHP constant MYSQLND_QC_TTL_SWITCH instead of using the string value.

Example #2 Setting TTL with SQL hints

<?php
$start = microtime(true);

/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

printf("Default TTL\t: %d seconds\n", ini_get("mysqlnd_qc.ttl"));

/* Will be cached for 2 seconds */
$sql = sprintf("/*%s*//*%s%d*/SELECT id FROM test WHERE id = 1", MYSQLND_QC_ENABLE_SWITCH, MYSQLND_QC_TTL_SWITCH, 2);
$res = $mysqli->query($sql);

var_dump($res->fetch_assoc());
$res->free();

$mysqli->query("DELETE FROM test WHERE id = 1");
sleep(1);

/* Cache hit - no automatic invalidation and still valid! */
$res = $mysqli->query($sql);
var_dump($res->fetch_assoc());
$res->free();

sleep(2);

/* Cache miss - cache entry has expired */
$res = $mysqli->query($sql);
var_dump($res->fetch_assoc());
$res->free();

printf("Script runtime\t: %d seconds\n", microtime(true) - $start);
?>

以上例程的输出类似于：

Default TTL     : 30 seconds
array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "1"
}
NULL
Script runtime  : 3 seconds


Pattern based caching

An application has three options for telling PECL/mysqlnd_qc whether a particular statement shall be used. The most basic approach is to cache all statements by setting mysqlnd_qc.cache_by_default = 1. This approach is often of little practical value. But it enables users to make a quick estimation about the maximum performance gains from caching. An application designed to use a cache may be able to prefix selected statements with the appropriate SQL hints. However, altering an applications source code may not always be possible or desired, for example, to avoid problems with software updates. Therefore, PECL/mysqlnd_qc allows setting a callback which decides if a query is to be cached.

The callback is installed with the mysqlnd_qc_set_is_select() function. The callback is given the statement string of every statement inspected by the plugin. Then, the callback can decide whether to cache the function. The callback is supposed to return false if the statement shall not be cached. A return value of true makes the plugin try to add the statement into the cache. The cache entry will be given the default TTL ( mysqlnd_qc.ttl). If the callback returns a numerical value it is used as the TTL instead of the global default.

Example #1 Setting a callback with mysqlnd_qc_set_is_select()

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_statistics=1
<?php
/* callback which decides if query is cached */
function is_select($query) {
    static $patterns = array(
      /* true - use default from mysqlnd_qc.ttl */
      "@SELECT\s+.*\s+FROM\s+test@ismU" => true,
      /* 3 - use TTL = 3 seconds */
      "@SELECT\s+.*\s+FROM\s+news@ismU" => 3
    );

    /* check if query does match pattern */
    foreach ($patterns as $pattern => $ttl) {
        if (preg_match($pattern, $query)) {
            printf("is_select(%45s): cache\n", $query);
            return $ttl;
        }
    }
    printf("is_select(%45s): do not cache\n", $query);
    return false;
}
/* install callback */
mysqlnd_qc_set_is_select("is_select");

/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* cache put */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* cache hit */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* cache put */
$mysqli->query("SELECT * FROM test");

$stats = mysqlnd_qc_get_core_stats();
printf("Cache put: %d\n", $stats['cache_put']);
printf("Cache hit: %d\n", $stats['cache_hit']);
?>

以上例程的输出类似于：

is_select(                    DROP TABLE IF EXISTS test): do not cache
is_select(                    CREATE TABLE test(id INT)): do not cache
is_select(    INSERT INTO test(id) VALUES (1), (2), (3)): do not cache
is_select(             SELECT id FROM test WHERE id = 1): cache
is_select(             SELECT id FROM test WHERE id = 1): cache
is_select(                           SELECT * FROM test): cache
Cache put: 2
Cache hit: 1

The examples callback tests if a statement string matches a pattern. If this is the case, it either returns true to cache the statement using the global default TTL or an alternative TTL.

To minimize application changes the callback can put into and registered in an auto prepend file.


Slam defense

A badly designed cache can do more harm than good. In the worst case a cache can increase database server load instead of minimizing it. An overload situation can occur if a highly shared cache entry expires (cache stampeding).

Cache entries are shared and reused to a different degree depending on the storage used. The default storage handler stores cache entries in process memory. Thus, a cache entry can be reused for the life-span of a process. Other PHP processes cannot access it. If Memcache is used, a cache entry can be shared among multiple PHP processes and even among multiple machines, depending on the set up being used.

If a highly shared cache entry stored, for example, in Memcache expires, many clients gets a cache miss. Many client requests can no longer be served from the cache but try to run the underlying query on the database server. Until the cache entry is refreshed, more and more clients contact the database server. In the worst case, a total lost of service is the result.

The overload can be avoided using a storage handler which limits the reuse of cache entries to few clients. Then, at the average, its likely that only a limited number of clients will try to refresh a cache entry concurrently.

Additionally, the built-in slam defense mechanism can and should be used. If slam defense is activated an expired cache entry is given an extended life time. The first client getting a cache miss for the expired cache entry tries to refresh the cache entry within the extended life time. All other clients requesting the cache entry are temporarily served from the cache although the original TTL of the cache entry has expired. The other clients will not experience a cache miss before the extended life time is over.

Example #1 Enabling the slam defense mechanism

mysqlnd_qc.slam_defense=1
mysqlnd_qc.slam_defense_ttl=1

The slam defense mechanism is enabled with the PHP configuration directive mysqlnd_qc.slam_defense. The extended life time of a cache entry is set with mysqlnd_qc.slam_defense_ttl.

The function mysqlnd_qc_get_core_stats() returns an array of statistics. The statistics slam_stale_refresh and slam_stale_hit are incremented if slam defense takes place.

It is not possible to give a one-fits-all recommendation on the slam defense configuration. Users are advised to monitor and test their setup and derive settings accordingly.


Finding cache candidates

A statement should be considered for caching if it is executed often and has a long run time. Cache candidates are found by creating a list of statements sorted by the product of the number of executions multiplied by the statements run time. The function mysqlnd_qc_get_query_trace_log() returns a query log which help with the task.

Collecting a query trace is a slow operation. Thus, it is disabled by default. The PHP configuration directive mysqlnd_qc.collect_query_trace is used to enable it. The functions trace contains one entry for every query issued before the function is called.

Example #1 Collecting a query trace

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_query_trace=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");

/* dummy queries to fill the query trace */
for ($i = 0; $i < 2; $i++) {
    $res = $mysqli->query("SELECT 1 AS _one FROM DUAL");
    $res->free();
}

/* dump trace */
var_dump(mysqlnd_qc_get_query_trace_log());
?>

以上例程会输出：

array(2) {
  [0]=>
  array(8) {
    ["query"]=>
    string(26) "SELECT 1 AS _one FROM DUAL"
    ["origin"]=>
    string(102) "#0 qc.php(7): mysqli->query('SELECT 1 AS _on...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(25)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [1]=>
  array(8) {
    ["query"]=>
    string(26) "SELECT 1 AS _one FROM DUAL"
    ["origin"]=>
    string(102) "#0 qc.php(7): mysqli->query('SELECT 1 AS _on...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(8)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
}

Assorted information is given in the trace. Among them timings and the origin of the query call. The origin property holds a code backtrace to identify the source of the query. The depth of the backtrace can be limited with the PHP configuration directive mysqlnd_qc.query_trace_bt_depth. The default depth is 3.

Example #2 Setting the backtrace depth with the mysqlnd_qc.query_trace_bt_depth ini setting

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_query_trace=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* dummy queries to fill the query trace */
for ($i = 0; $i < 3; $i++) {
    $res = $mysqli->query("SELECT id FROM test WHERE id = " . $mysqli->real_escape_string($i));
    $res->free();
}

$trace = mysqlnd_qc_get_query_trace_log();
$summary = array();
foreach ($trace as $entry) {
    if (!isset($summary[$entry['query']])) {
        $summary[$entry['query']] = array(
            "executions" => 1,
            "time"       => $entry['run_time'] + $entry['store_time'],
        );
    } else {
        $summary[$entry['query']]['executions']++;
        $summary[$entry['query']]['time'] += $entry['run_time'] + $entry['store_time'];
    }
}

foreach ($summary as $query => $details) {
    printf("%45s: %5dms (%dx)\n",
    $query, $details['time'], $details['executions']);
}
?>

以上例程的输出类似于：

                    DROP TABLE IF EXISTS test:     0ms (1x)
                    CREATE TABLE test(id INT):     0ms (1x)
    INSERT INTO test(id) VALUES (1), (2), (3):     0ms (1x)
             SELECT id FROM test WHERE id = 0:    25ms (1x)
             SELECT id FROM test WHERE id = 1:    10ms (1x)
             SELECT id FROM test WHERE id = 2:     9ms (1x)


Measuring cache efficiency

PECL/mysqlnd_qc offers three ways to measure the cache efficiency. The function mysqlnd_qc_get_normalized_query_trace_log() returns statistics aggregated by the normalized query string, mysqlnd_qc_get_cache_info() gives storage handler specific information which includes a list of all cached items, depending on the storage handler. Additionally, the core of PECL/mysqlnd_qc collects high-level summary statistics aggregated per PHP process. The high-level statistics are returned by mysqlnd_qc_get_core_stats().

The functions mysqlnd_qc_get_normalized_query_trace_log() and mysqlnd_qc_get_core_stats() will not collect data unless data collection has been enabled through their corresponding PHP configuration directives. Data collection is disabled by default for performance considerations. It is configurable with the mysqlnd_qc.time_statistics option, which determines if timing information should be collected. Collection of time statistics is enabled by default but only performed if data collection as such has been enabled. Recording time statistics causes extra system calls. In most cases, the benefit of the monitoring outweighs any potential performance penalty of the additional system calls.

Example #1 Collecting statistics data with the mysqlnd_qc.time_statistics ini setting

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_statistics=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* dummy queries */
for ($i = 1; $i <= 4; $i++) {
    $query = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($query);

    $res->free();
}

var_dump(mysqlnd_qc_get_core_stats());
?>

以上例程的输出类似于：

array(26) {
  ["cache_hit"]=>
  string(1) "2"
  ["cache_miss"]=>
  string(1) "2"
  ["cache_put"]=>
  string(1) "2"
  ["query_should_cache"]=>
  string(1) "4"
  ["query_should_not_cache"]=>
  string(1) "3"
  ["query_not_cached"]=>
  string(1) "3"
  ["query_could_cache"]=>
  string(1) "4"
  ["query_found_in_cache"]=>
  string(1) "2"
  ["query_uncached_other"]=>
  string(1) "0"
  ["query_uncached_no_table"]=>
  string(1) "0"
  ["query_uncached_no_result"]=>
  string(1) "0"
  ["query_uncached_use_result"]=>
  string(1) "0"
  ["query_aggr_run_time_cache_hit"]=>
  string(2) "28"
  ["query_aggr_run_time_cache_put"]=>
  string(3) "900"
  ["query_aggr_run_time_total"]=>
  string(3) "928"
  ["query_aggr_store_time_cache_hit"]=>
  string(2) "14"
  ["query_aggr_store_time_cache_put"]=>
  string(2) "40"
  ["query_aggr_store_time_total"]=>
  string(2) "54"
  ["receive_bytes_recorded"]=>
  string(3) "136"
  ["receive_bytes_replayed"]=>
  string(3) "136"
  ["send_bytes_recorded"]=>
  string(2) "84"
  ["send_bytes_replayed"]=>
  string(2) "84"
  ["slam_stale_refresh"]=>
  string(1) "0"
  ["slam_stale_hit"]=>
  string(1) "0"
  ["request_counter"]=>
  int(1)
  ["process_hash"]=>
  int(1929695233)
}

For a quick overview, call mysqlnd_qc_get_core_stats(). It delivers cache usage, cache timing and traffic related statistics. Values are aggregated on a per process basis for all queries issued by any PHP MySQL API call.

Some storage handler, such as the default handler, can report cache entries, statistics related to the entries and meta data for the underlying query through the mysqlnd_qc_get_cache_info() function. Please note, that the information returned depends on the storage handler. Values are aggregated on a per process basis.

Example #2 Example mysqlnd_qc_get_cache_info() usage

mysqlnd_qc.enable_qc=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* dummy queries to fill the query trace */
for ($i = 1; $i <= 4; $i++) {
    $query = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($query);

    $res->free();
}

var_dump(mysqlnd_qc_get_cache_info());
?>

以上例程的输出类似于：

array(4) {
  ["num_entries"]=>
  int(2)
  ["handler"]=>
  string(7) "default"
  ["handler_version"]=>
  string(5) "1.0.0"
  ["data"]=>
  array(2) {
    ["Localhost via UNIX socket
3306
root
test|/*qc=on*/SELECT id FROM test WHERE id = 1"]=>
    array(2) {
      ["statistics"]=>
      array(11) {
        ["rows"]=>
        int(1)
        ["stored_size"]=>
        int(71)
        ["cache_hits"]=>
        int(1)
        ["run_time"]=>
        int(391)
        ["store_time"]=>
        int(27)
        ["min_run_time"]=>
        int(16)
        ["max_run_time"]=>
        int(16)
        ["min_store_time"]=>
        int(8)
        ["max_store_time"]=>
        int(8)
        ["avg_run_time"]=>
        int(8)
        ["avg_store_time"]=>
        int(4)
      }
      ["metadata"]=>
      array(1) {
        [0]=>
        array(8) {
          ["name"]=>
          string(2) "id"
          ["orig_name"]=>
          string(2) "id"
          ["table"]=>
          string(4) "test"
          ["orig_table"]=>
          string(4) "test"
          ["db"]=>
          string(4) "test"
          ["max_length"]=>
          int(1)
          ["length"]=>
          int(11)
          ["type"]=>
          int(3)
        }
      }
    }
    ["Localhost via UNIX socket
3306
root
test|/*qc=on*/SELECT id FROM test WHERE id = 0"]=>
    array(2) {
      ["statistics"]=>
      array(11) {
        ["rows"]=>
        int(0)
        ["stored_size"]=>
        int(65)
        ["cache_hits"]=>
        int(1)
        ["run_time"]=>
        int(299)
        ["store_time"]=>
        int(13)
        ["min_run_time"]=>
        int(11)
        ["max_run_time"]=>
        int(11)
        ["min_store_time"]=>
        int(6)
        ["max_store_time"]=>
        int(6)
        ["avg_run_time"]=>
        int(5)
        ["avg_store_time"]=>
        int(3)
      }
      ["metadata"]=>
      array(1) {
        [0]=>
        array(8) {
          ["name"]=>
          string(2) "id"
          ["orig_name"]=>
          string(2) "id"
          ["table"]=>
          string(4) "test"
          ["orig_table"]=>
          string(4) "test"
          ["db"]=>
          string(4) "test"
          ["max_length"]=>
          int(0)
          ["length"]=>
          int(11)
          ["type"]=>
          int(3)
        }
      }
    }
  }
}

It is possible to further break down the granularity of statistics to the level of the normalized statement string. The normalized statement string is the statements string with all parameters replaced with question marks. For example, the two statements SELECT id FROM test WHERE id = 0 and SELECT id FROM test WHERE id = 1 are normalized into SELECT id FROM test WHERE id = ?. Their both statistics are aggregated into one entry for SELECT id FROM test WHERE id = ?.

Example #3 Example mysqlnd_qc_get_normalized_query_trace_log() usage

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_normalized_query_trace=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* dummy queries to fill the query trace */
for ($i = 1; $i <= 4; $i++) {
    $query = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($query);

    $res->free();
}

var_dump(mysqlnd_qc_get_normalized_query_trace_log());
?>

以上例程的输出类似于：

array(4) {
  [0]=>
  array(9) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [1]=>
  array(9) {
    ["query"]=>
    string(27) "CREATE TABLE test (id INT )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [2]=>
  array(9) {
    ["query"]=>
    string(46) "INSERT INTO test (id ) VALUES (? ), (? ), (? )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [3]=>
  array(9) {
    ["query"]=>
    string(31) "SELECT id FROM test WHERE id =?"
    ["occurences"]=>
    int(4)
    ["eligible_for_caching"]=>
    bool(true)
    ["avg_run_time"]=>
    int(179)
    ["min_run_time"]=>
    int(11)
    ["max_run_time"]=>
    int(393)
    ["avg_store_time"]=>
    int(12)
    ["min_store_time"]=>
    int(7)
    ["max_store_time"]=>
    int(25)
  }
}

The source distribution of PECL/mysqlnd_qc contains a directory web/ in which web based monitoring scripts can be found which give an example how to write a cache monitor. Please, follow the instructions given in the source.

Since PECL/mysqlnd_qc 1.1.0 it is possible to write statistics into a log file. Please, see mysqlnd_qc.collect_statistics_log_file.


Beyond TTL: user-defined storage

The query cache plugin supports the use of user-defined storage handler. User-defined storage handler can use arbitrarily complex invalidation algorithms and support arbitrary storage media.

All user-defined storage handlers have to provide a certain interface. The functions of the user-defined storage handler will be called by the core of the cache plugin. The necessary interface consists of seven public functions. Both procedural and object oriented user-defined storage handler must implement the same set of functions.

Example #1 Using a user-defined storage handler

<?php
/* Enable default caching of all statements */
ini_set("mysqlnd_qc.cache_by_default", 1);

/* Procedural user defined storage handler functions */

$__cache = array();

function get_hash($host_info, $port, $user, $db, $query) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    return md5(sprintf("%s%s%s%s%s", $host_info, $port, $user, $db, $query));
}

function find_query_in_cache($key) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if (isset($__cache[$key])) {
        $tmp = $__cache[$key];
        if ($tmp["valid_until"] < time()) {
            unset($__cache[$key]);
            $ret = NULL;
        } else {
            $ret = $__cache[$key]["data"];
        }
    } else {
        $ret = NULL;
    }

    return $ret;
}

function return_to_cache($key) {
    /*
     Called on cache hit after cached data has been processed,
     may be used for reference counting
    */
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());
}

function add_query_to_cache_if_not_exists($key, $data, $ttl, $run_time, $store_time, $row_count) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    $__cache[$key] = array(
        "data"               => $data,
        "row_count"          => $row_count,
        "valid_until"        => time() + $ttl,
        "hits"               => 0,
        "run_time"           => $run_time,
        "store_time"         => $store_time,
        "cached_run_times"   => array(),
        "cached_store_times" => array(),
    );

    return TRUE;
}

function query_is_select($query) {
    printf("\t%s('%s'): ", __FUNCTION__, $query);

    $ret = FALSE;
    if (stristr($query, "SELECT") !== FALSE) {
        /* cache for 5 seconds */
        $ret = 5;
    }

    printf("%s\n", (FALSE === $ret) ? "FALSE" : $ret);
    return $ret;
}

function update_query_run_time_stats($key, $run_time, $store_time) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if (isset($__cache[$key])) {
        $__cache[$key]['hits']++;
        $__cache[$key]["cached_run_times"][] = $run_time;
        $__cache[$key]["cached_store_times"][] = $store_time;
    }
}

function get_stats($key = NULL) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if ($key && isset($__cache[$key])) {
        $stats = $__cache[$key];
    } else {
        $stats = array();
        foreach ($__cache as $key => $details) {
            $stats[$key] = array(
               'hits'              => $details['hits'],
               'bytes'             => strlen($details['data']),
               'uncached_run_time' => $details['run_time'],
               'cached_run_time'   => (count($details['cached_run_times']))
                                      ? array_sum($details['cached_run_times']) / count($details['cached_run_times'])
                                      : 0,
            );
        }
    }

    return $stats;
}

function clear_cache() {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    $__cache = array();
    return TRUE;
}

/* Install procedural user-defined storage handler */
if (!mysqlnd_qc_set_user_handlers("get_hash", "find_query_in_cache",
    "return_to_cache", "add_query_to_cache_if_not_exists",
    "query_is_select", "update_query_run_time_stats", "get_stats", "clear_cache")) {

        printf("Failed to install user-defined storage handler\n");
}

/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

printf("\nCache put/cache miss\n");

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* Delete record to verify we get our data from the cache */
$mysqli->query("DELETE FROM test WHERE id = 1");

printf("\nCache hit\n");

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

printf("\nDisplay cache statistics\n");
var_dump(mysqlnd_qc_get_cache_info());

printf("\nFlushing cache, cache put/cache miss");
var_dump(mysqlnd_qc_clear_cache());

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();
?>

以上例程的输出类似于：

        query_is_select('DROP TABLE IF EXISTS test'): FALSE
        query_is_select('CREATE TABLE test(id INT)'): FALSE
        query_is_select('INSERT INTO test(id) VALUES (1), (2)'): FALSE

Cache put/cache miss
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        add_query_to_cache_if_not_exists(6)
array(1) {
  ["id"]=>
  string(1) "1"
}
        query_is_select('DELETE FROM test WHERE id = 1'): FALSE

Cache hit
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        return_to_cache(1)
        update_query_run_time_stats(3)
array(1) {
  ["id"]=>
  string(1) "1"
}

Display cache statistics
        get_stats(0)
array(4) {
  ["num_entries"]=>
  int(1)
  ["handler"]=>
  string(4) "user"
  ["handler_version"]=>
  string(5) "1.0.0"
  ["data"]=>
  array(1) {
    ["18683c177dc89bb352b29965d112fdaa"]=>
    array(4) {
      ["hits"]=>
      int(1)
      ["bytes"]=>
      int(71)
      ["uncached_run_time"]=>
      int(398)
      ["cached_run_time"]=>
      int(4)
    }
  }
}

Flushing cache, cache put/cache miss    clear_cache(0)
bool(true)
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        add_query_to_cache_if_not_exists(6)
NULL


  • ? Beyond TTL: user-defined storage
  • 需求 ?
  • PHP Manual
  • mysqlnd_qc
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

PHP 5.3.3 or a newer version of PHP.

PECL/mysqlnd_qc is a mysqlnd plugin. It plugs into the mysqlnd library. To use you this plugin with a PHP MySQL extension, the extension (mysqli, mysql, or PDO_MYSQL) must enable the mysqlnd library.

For using MEMCACHE storage handler: Use libmemcache 0.38 or newer. PECL/mysqlnd_qc 1.2 has been tested with libmemcache 1.4.0.

For using sqlite storage handler: Use the sqlite3 extension that bundled with PHP.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mysqlnd_qc

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

mysqlnd_qc 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mysqlnd_qc.enable_qc | 1 | PHP_INI_SYSTEM |
mysqlnd_qc.ttl | 30 | PHP_INI_ALL |
mysqlnd_qc.cache_by_default | 0 | PHP_INI_ALL |
mysqlnd_qc.cache_no_table | 0 | PHP_INI_ALL |
mysqlnd_qc.use_request_time | 0 | PHP_INI_ALL |
mysqlnd_qc.time_statistics | 1 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics | 0 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics_log_file | /tmp/mysqlnd_qc.stats | PHP_INI_SYSTEM |
mysqlnd_qc.collect_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.query_trace_bt_depth | 3 | PHP_INI_SYSTEM |
mysqlnd_qc.collect_normalized_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.ignore_sql_comments | 1 | PHP_INI_ALL |
mysqlnd_qc.slam_defense | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.slam_defense_ttl | 30 | PHP_INI_SYSTEM |
mysqlnd_qc.std_data_copy | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.apc_prefix | qc_ | PHP_INI_ALL |
mysqlnd_qc.memc_server | 127.0.0.1 | PHP_INI_ALL |
mysqlnd_qc.memc_port | 11211 | PHP_INI_ALL |
mysqlnd_qc.sqlite_data_file | :memory: | PHP_INI_ALL |

这是配置指令的简短说明。

mysqlnd_qc.enable_qc int

Enables or disables the plugin. If disabled the extension will not plug into mysqlnd to proxy internal mysqlnd C API calls.

mysqlnd_qc.ttl int

Default Time-to-Live (TTL) for cache entries in seconds.

mysqlnd_qc.cache_by_default int

Cache all queries regardless if they begin with the SQL hint that enables caching of a query or not. Storage handler cannot overrule the setting. It is evaluated by the core of the plugin.

mysqlnd_qc.cache_no_table int

Whether to cache queries with no table name in any of columns meta data of their result set, for example, SELECT SLEEP(1), SELECT NOW(), SELECT SUBSTRING().

mysqlnd_qc.use_request_time int

Use PHP global request time to avoid gettimeofday() system calls? If using APC storage handler it should be set to the value of apc.use_request_time, if not warnings will be generated.

mysqlnd_qc.time_statistics int

Collect run time and store time statistics using gettimeofday() system call? Data will be collected only if you also set mysqlnd_qc.collect_statistics = 1,

mysqlnd_qc.collect_statistics int

Collect statistics for mysqlnd_qc_get_core_stats()? Does not influence storage handler statistics! Handler statistics can be an integral part of the handler internal storage format. Therefore, collection of some handler statistics cannot be disabled.

mysqlnd_qc.collect_statistics-log-file int

If mysqlnd_qc.collect_statistics and mysqlnd_qc.collect_statistics_log_file are set, the plugin will dump statistics into the specified log file at every 10th web request during PHP request shutdown. The log file needs to be writable by the web server user.

Since 1.1.0.

mysqlnd_qc.collect_query_trace int

Collect query back traces?

mysqlnd_qc.query_trace_bt_depth int

Maximum depth/level of a query code backtrace.

mysqlnd_qc.ignore_sql_comments int

Whether to remove SQL comments from a query string before hashing it to generate a cache key. Disable if you do not want two statemts such as SELECT /*my_source_ip=123*/ id FROM test and SELECT /*my_source_ip=456*/ id FROM test to refer to the same cache entry.

Since 1.1.0.

mysqlnd_qc.slam_defense int

Activates handler based slam defense (cache stampeding protection) if available. Supported by Default and APC storage handler

mysqlnd_qc.slam_defense_ttl int

TTL for stale cache entries which are served while another client updates the entries. Supported by APC storage handler.

mysqlnd_qc.collect_normalized_query_trace int

Collect aggregated normalized query traces? The setting has no effect by default. You compile the extension using the define NORM_QUERY_TRACE_LOG to make use of the setting.

mysqlnd_qc.std_data_copy int

Default storage handler: copy cached wire data? EXPERIMENTAL - use default setting!

mysqlnd_qc.apc_prefix string

The APC storage handler stores data in the APC user cache. The setting sets a prefix to be used for cache entries.

mysqlnd_qc.memc_server string

MEMCACHE storage handler: memcache server host.

mysqlnd_qc.memc_port int

MEMCACHE storage handler: memcached server port.

mysqlnd_qc.sqlite_data_file string

sqlite storage handler: data file. Any setting but :memory: may be of little practical value.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SQL hint related

Example #1 Using SQL hint constants

The query cache is controlled by SQL hints. SQL hints are used to enable and disable caching. SQL hints can be used to set the TTL of a query.

The SQL hints recognized by the query cache can be manually changed at compile time. This makes it possible to use mysqlnd_qc in environments in which the default SQL hints are already taken and interpreted by other systems. Therefore it is recommended to use the SQL hint string constants instead of manually adding the default SQL hints to the query string.

<?php
/* Use constants for maximum portability */
$query = "/*" . MYSQLND_QC_ENABLE_SWITCH . "*/SELECT id FROM test";

/* Valid but less portable: default TTL */
$query = "/*qc=on*/SELECT id FROM test";

/* Valid but less portable: per statement TTL */
$query = "/*qc=on*//*qc_ttl=5*/SELECT id FROM test";

printf("MYSQLND_QC_ENABLE_SWITCH: %s\n", MYSQLND_QC_ENABLE_SWITCH);
printf("MYSQLND_QC_DISABLE_SWITCH: %s\n", MYSQLND_QC_DISABLE_SWITCH);
printf("MYSQLND_QC_TTL_SWITCH: %s\n", MYSQLND_QC_TTL_SWITCH);
?>

以上例程会输出：

MYSQLND_QC_ENABLE_SWITCH: qc=on
MYSQLND_QC_DISABLE_SWITCH: qc=off
MYSQLND_QC_TTL_SWITCH: qc_ttl=

MYSQLND_QC_ENABLE_SWITCH (string)
SQL hint used to enable caching of a query.
MYSQLND_QC_DISABLE_SWITCH (string)
SQL hint used to disable caching of a query if mysqlnd_qc.cache_by_default = 1.
MYSQLND_QC_TTL_SWITCH (string)
SQL hint used to set the TTL of a result set.
MYSQLND_QC_SERVER_ID_SWITCH (string)
This SQL hint should not be used in general. It is needed by PECL/mysqlnd_ms to group cache entries for one statement but originating from different physical connections. If the hint is used connection settings such as user, hostname and charset are not considered for generating a cache key of a query. Instead the given value and the query string are used as input to the hashing function that generates the key. PECL/mysqlnd_ms may, if instructed, cache results from MySQL Replication slaves. Because it can hold many connections to the slave the cache key shall not be formed from the user, hostname or other settings that may vary for the various slave connections. Instead, PECL/mysqlnd_ms provides an identifier which refers to the group of slave connections that shall be enabled to share cache entries no matter which physical slave connection was to generate the cache entry. Use of this feature outside of PECL/mysqlnd_ms is not recommended.

mysqlnd_qc_set_cache_condition() related

Example #2 Example mysqlnd_qc_set_cache_condition() usage

The function mysqlnd_qc_set_cache_condition() allows setting conditions for automatic caching of statements which don't begin with the SQL hints necessary to manually enable caching.

<?php
/* Cache all accesses to tables with the name "new%" in schema/database "db_example" for 1 second */
if (!mysqlnd_qc_set_cache_condition(MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN, "db_example.new%", 1)) {
  die("Failed to set cache condition!");
}

$mysqli = new mysqli("host", "user", "password", "db_example", "port");
/* cached although no SQL hint given  */
$mysqli->query("SELECT id, title FROM news");

$pdo_mysql = new PDO("mysql:host=host;dbname=db_example;port=port", "user", "password");
/* not cached: no SQL hint, no pattern match */
$pdo_mysql->query("SELECT id, title FROM latest_news");
/* cached: TTL 1 second, pattern match */
$pdo_mysql->query("SELECT id, title FROM news");
?>

MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN (int)
Used as a parameter of mysqlnd_qc_set_cache_condition() to set conditions for schema based automatic caching.

Other

The plugin version number can be obtained using either MYSQLND_QC_VERSION, which is the string representation of the numerical version number, or MYSQLND_QC_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_QC_VERSION_ID | 10000

MYSQLND_QC_VERSION (string)
Plugin version string, for example, 1.0.0-prototype.

MYSQLND_QC_VERSION_ID (int)
Plugin version number, for example, 10000.


mysqlnd_qc 函数

Table of Contents

  • mysqlnd_qc_clear_cache — Flush all cache contents
  • mysqlnd_qc_get_available_handlers — Returns a list of available storage handler
  • mysqlnd_qc_get_cache_info — Returns information on the current handler, the number of cache entries and cache entries, if available
  • mysqlnd_qc_get_core_stats — Statistics collected by the core of the query cache
  • mysqlnd_qc_get_normalized_query_trace_log — Returns a normalized query trace log for each query inspected by the query cache
  • mysqlnd_qc_get_query_trace_log — Returns a backtrace for each query inspected by the query cache
  • mysqlnd_qc_set_cache_condition — Set conditions for automatic caching
  • mysqlnd_qc_set_is_select — Installs a callback which decides whether a statement is cached
  • mysqlnd_qc_set_storage_handler — Change current storage handler
  • mysqlnd_qc_set_user_handlers — Sets the callback functions for a user-defined procedural storage handler


Flush all cache contents

  • ? mysqlnd_qc 函数
  • mysqlnd_qc_get_available_handlers ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Flush all cache contents

mysqlnd_qc_clear_cache

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_clear_cache — Flush all cache contents

说明

mysqlnd_qc_clear_cache ( ) : bool

Flush all cache contents.

Flushing the cache is a storage handler responsibility. All built-in storage handler but the memcache storage handler support flushing the cache. The memcache storage handler cannot flush its cache contents.

User-defined storage handler may or may not support the operation.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

A return value of false indicates that flushing all cache contents has failed or the operation is not supported by the active storage handler. Applications must not expect that calling the function will always flush the cache.


Returns a list of available storage handler

  • ? mysqlnd_qc_clear_cache
  • mysqlnd_qc_get_cache_info ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Returns a list of available storage handler

mysqlnd_qc_get_available_handlers

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_available_handlers — Returns a list of available storage handler

说明

mysqlnd_qc_get_available_handlers ( ) : array

Which storage are available depends on the compile time configuration of the query cache plugin. The default storage handler is always available. All other storage handler must be enabled explicitly when building the extension.

参数

此函数没有参数。

返回值

Returns an array of available built-in storage handler. For each storage handler the version number and version string is given.

范例

Example #1 mysqlnd_qc_get_available_handlers() example

<?php
var_dump(mysqlnd_qc_get_available_handlers());
?>

以上例程会输出：

array(5) {
  ["default"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["user"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["APC"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["MEMCACHE"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["sqlite"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
}

参见

  • Installation
  • mysqlnd_qc_set_storage_handler() - Change current storage handler


Returns information on the current handler, the number of cache entries and cache entries, if available

  • ? mysqlnd_qc_get_available_handlers
  • mysqlnd_qc_get_core_stats ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Returns information on the current handler, the number of cache entries and cache entries, if available

mysqlnd_qc_get_cache_info

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_cache_info — Returns information on the current handler, the number of cache entries and cache entries, if available

说明

mysqlnd_qc_get_cache_info ( ) : array

参数

此函数没有参数。

返回值

Returns information on the current handler, the number of cache entries and cache entries, if available. If and what data will be returned for the cache entries is subject to the active storage handler. Storage handler are free to return any data. Storage handler are recommended to return at least the data provided by the default handler, if technically possible.

The scope of the information is the PHP process. Depending on the PHP deployment model a process may serve one or more web requests.

Values are aggregated for all cache activities on a per storage handler basis. It is not possible to tell how much queries originating from mysqli, PDO_MySQL or mysql.API calls have contributed to the aggregated data values. Use mysqlnd_qc_get_core_stats() to get timing data aggregated for all storage handlers.

Array of cache information

handler string

The active storage handler.

All storage handler. Since 1.0.0.

handler_version string

The version of the active storage handler.

All storage handler. Since 1.0.0.

num_entries int

The number of cache entries. The value depends on the storage handler in use.

The default, APC and SQLite storage handler provide the actual number of cache entries.

The MEMCACHE storage handler always returns 0. MEMCACHE does not support counting the number of cache entries.

If a user defined handler is used, the number of entries of the data property is reported.

Since 1.0.0.

data array

The version of the active storage handler.

Additional storage handler dependent data on the cache entries. Storage handler are requested to provide similar and comparable information. A user defined storage handler is free to return any data.

Since 1.0.0.

The following information is provided by the default storage handler for the data property.

The data property holds a hash. The hash is indexed by the internal cache entry identifier of the storage handler. The cache entry identifier is human-readable and contains the query string leading to the cache entry. Please, see also the example below. The following data is given for every cache entry.

statistics array

Statistics of the cache entry.

Since 1.0.0.

Property | Description | Version
rows | Number of rows of the cached result set. | Since 1.0.0.
stored_size | The size of the cached result set in bytes. This is the size of the payload. The value is not suited for calculating the total memory consumption of all cache entries including the administrative overhead of the cache entries. | Since 1.0.0.
cache_hits | How often the cached entry has been returned. | Since 1.0.0.
run_time | Run time of the statement to which the cache entry belongs. This is the run time of the uncached statement. It is the time between sending the statement to MySQL receiving a reply from MySQL. Run time saved by using the query cache plugin can be calculated like this: cache_hits * ((run_time - avg_run_time) + (store_time - avg_store_time)). | Since 1.0.0.
store_time | Store time of the statements result set to which the cache entry belongs. This is the time it took to fetch and store the results of the uncached statement. | Since 1.0.0.
min_run_time | Minimum run time of the cached statement. How long it took to find the statement in the cache. | Since 1.0.0.
min_store_time | Minimum store time of the cached statement. The time taken for fetching the cached result set from the storage medium and decoding | Since 1.0.0.
avg_run_time | Average run time of the cached statement. | Since 1.0.0.
avg_store_time | Average store time of the cached statement. | Since 1.0.0.
max_run_time | Average run time of the cached statement. | Since 1.0.0.
max_store_time | Average store time of the cached statement. | Since 1.0.0.
valid_until | Timestamp when the cache entry expires. | Since 1.1.0.
metadata array

Metadata of the cache entry. This is the metadata provided by MySQL together with the result set of the statement in question. Different versions of the MySQL server may return different metadata. Unlike with some of the PHP MySQL extensions no attempt is made to hide MySQL server version dependencies and version details from the caller. Please, refer to the MySQL C API documentation that belongs to the MySQL server in use for further details.

The metadata list contains one entry for every column.

Since 1.0.0.

Property | Description | Version
name | The field name. Depending on the MySQL version this may be the fields alias name. | Since 1.0.0.
org_name | The field name. | Since 1.0.0.
table | The table name. If an alias name was used for the table, this usually holds the alias name. | Since 1.0.0.
org_table | The table name. | Since 1.0.0.
db | The database/schema name. | Since 1.0.0.
max_length | The maximum width of the field. Details may vary by MySQL server version. | Since 1.0.0.
length | The width of the field. Details may vary by MySQL server version. | Since 1.0.0.
type | The data type of the field. Details may vary by the MySQL server in use. This is the MySQL C API type constants value. It is recommended to use type constants provided by the mysqli extension to test for its meaning. You should not test for certain type values by comparing with certain numbers. | Since 1.0.0.

The APC storage handler returns the same information for the data property but no metadata. The metadata of a cache entry is set to NULL.

The MEMCACHE storage handler does not fill the data property. Statistics are not available on a per cache entry basis with the MEMCACHE storage handler.

A user defined storage handler is free to provide any data.

范例

Example #1 mysqlnd_qc_get_cache_info() example

The example shows the output from the built-in default storage handler. Other storage handler may report different data.

<?php
/* Populate the cache, e.g. using mysqli */
$mysqli = new mysqli("host", "user", "password", "schema");
$mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/SELECT id FROM test");

/* Display cache information */
var_dump(mysqlnd_qc_get_cache_info());
?>

以上例程会输出：

array(4) {
 ["num_entries"]=>
 int(1)
 ["handler"]=>
 string(7) "default"
 ["handler_version"]=>
 string(5) "1.0.0"
 ["data"]=>
 array(1) {
   ["Localhost via UNIX socket 3306 user schema|/*qc=on*/SELECT id FROM test"]=>
   array(2) {
     ["statistics"]=>
     array(11) {
       ["rows"]=>
       int(6)
       ["stored_size"]=>
       int(101)
       ["cache_hits"]=>
       int(0)
       ["run_time"]=>
       int(471)
       ["store_time"]=>
       int(27)
       ["min_run_time"]=>
       int(0)
       ["max_run_time"]=>
       int(0)
       ["min_store_time"]=>
       int(0)
       ["max_store_time"]=>
       int(0)
       ["avg_run_time"]=>
       int(0)
       ["avg_store_time"]=>
       int(0)
     }
     ["metadata"]=>
     array(1) {
       [0]=>
       array(8) {
         ["name"]=>
         string(2) "id"
         ["orig_name"]=>
         string(2) "id"
         ["table"]=>
         string(4) "test"
         ["orig_table"]=>
         string(4) "test"
         ["db"]=>
         string(4) "schema"
         ["max_length"]=>
         int(1)
         ["length"]=>
         int(11)
         ["type"]=>
         int(3)
       }
     }
   }
 }
}

参见

  • mysqlnd_qc_get_core_stats() - Statistics collected by the core of the query cache


Statistics collected by the core of the query cache

  • ? mysqlnd_qc_get_cache_info
  • mysqlnd_qc_get_normalized_query_trace_log ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Statistics collected by the core of the query cache

mysqlnd_qc_get_core_stats

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_core_stats — Statistics collected by the core of the query cache

说明

mysqlnd_qc_get_core_stats ( ) : array

Returns an array of statistics collected by the core of the cache plugin. The same data fields will be reported for any storage handler because the data is collected by the core.

The PHP configuration setting mysqlnd_qc.collect_statistics controls the collection of statistics. The collection of statistics is disabled by default for performance reasons. Disabling the collection of statistics will also disable the collection of time related statistics.

The PHP configuration setting mysqlnd_qc.collect_time_statistics controls the collection of time related statistics.

The scope of the core statistics is the PHP process. Depending on your deployment model a PHP process may handle one or multiple requests.

Statistics are aggregated for all cache entries and all storage handler. It is not possible to tell how much queries originating from mysqli, PDO_MySQL or mysql API calls have contributed to the aggregated data values.

参数

此函数没有参数。

返回值

Array of core statistics

Statistic | Description | Version
cache_hit | Statement is considered cacheable and cached data has been reused. Statement is considered cacheable and a cache miss happened but the statement got cached by someone else while we process it and thus we can fetch the result from the refreshed cache. | Since 1.0.0.
cache_miss Statement is considered cacheable...

  • ... and has been added to the cache

  • ... but the PHP configuration directive setting of mysqlnd_qc.cache_no_table = 1 has prevented caching.

  • ... but an unbuffered result set is requested.

  • ... but a buffered result set was empty.

Since 1.0.0.
cache_put | Statement is considered cacheable and has been added to the cache. Take care when calculating derived statistics. Storage handler with a storage life time beyond process scope may report cache_put = 0 together with cache_hit > 0, if another process has filled the cache. You may want to use num_entries from mysqlnd_qc_get_cache_info() if the handler supports it ( default, APC). | Since 1.0.0.
query_should_cache | Statement is considered cacheable based on query string analysis. The statement may or may not be added to the cache. See also cache_put. | Since 1.0.0.
query_should_not_cache | Statement is considered not cacheable based on query string analysis. | Since 1.0.0.
query_not_cached | Statement is considered not cacheable or it is considered cachable but the storage handler has not returned a hash key for it. | Since 1.0.0.
query_could_cache Statement is considered cacheable...

  • ... and statement has been run without errors

  • ... and meta data shows at least one column in the result set

The statement may or may not be in the cache already. It may or may not be added to the cache later on. 		Since 1.0.0.
query_found_in_cache | Statement is considered cacheable and we have found it in the cache but we have not replayed the cached data yet and we have not send the result set to the client yet. This is not considered a cache hit because the client might not fetch the result or the cached data may be faulty. | Since 1.0.0.
query_uncached_other | Statement is considered cacheable and it may or may not be in the cache already but either replaying cached data has failed, no result set is available or some other error has happened.
query_uncached_no_table | Statement has not been cached because the result set has at least one column which has no table name in its meta data. An example of such a query is SELECT SLEEP(1). To cache those statements you have to change default value of the PHP configuration directive mysqlnd_qc.cache_no_table and set mysqlnd_qc.cache_no_table = 1. Often, it is not desired to cache such statements. | Since 1.0.0.
query_uncached_use_result | Statement would have been cached if a buffered result set had been used. The situation is also considered as a cache miss and cache_miss will be incremented as well. | Since 1.0.0.
query_aggr_run_time_cache_hit | Aggregated run time (ms) of all cached queries. Cached queries are those which have incremented cache_hit. | Since 1.0.0.
query_aggr_run_time_cache_put | Aggregated run time (ms) of all uncached queries that have been put into the cache. See also cache_put. | Since 1.0.0.
query_aggr_run_time_total | Aggregated run time (ms) of all uncached and cached queries that have been inspected and executed by the query cache. | Since 1.0.0.
query_aggr_store_time_cache_hit | Aggregated store time (ms) of all cached queries. Cached queries are those which have incremented cache_hit. | Since 1.0.0.
query_aggr_store_time_cache_put | Aggregated store time ( ms) of all uncached queries that have been put into the cache. See also cache_put. | Since 1.0.0.
query_aggr_store_time_total | Aggregated store time (ms) of all uncached and cached queries that have been inspected and executed by the query cache. | Since 1.0.0.
receive_bytes_recorded | Recorded incoming network traffic ( bytes) send from MySQL to PHP. The traffic may or may not have been added to the cache. The traffic is the total for all queries regardless if cached or not. | Since 1.0.0.
receive_bytes_replayed | Network traffic replayed during cache. This is the total amount of incoming traffic saved because of the usage of the query cache plugin. | Since 1.0.0.
send_bytes_recorded | Recorded outgoing network traffic ( bytes) send from MySQL to PHP. The traffic may or may not have been added to the cache. The traffic is the total for all queries regardless if cached or not. | Since 1.0.0.
send_bytes_replayed | Network traffic replayed during cache. This is the total amount of outgoing traffic saved because of the usage of the query cache plugin. | Since 1.0.0.
slam_stale_refresh | Number of cache misses which triggered serving stale data until the client causing the cache miss has refreshed the cache entry. | Since 1.0.0.
slam_stale_hit | Number of cache hits while a stale cache entry gets refreshed. | Since 1.0.0.

范例

Example #1 mysqlnd_qc_get_core_stats() example

<?php
/* Enable collection of statistics - default: disabled */
ini_set("mysqlnd_qc.collect_statistics", 1);

/* Enable collection of all timing related statistics -
default: enabled but overruled by mysqlnd_qc.collect_statistics = 0 */
ini_set("mysqlnd_qc.collect_time_statistics", 1);

/* Populate the cache, e.g. using mysqli */
$mysqli = new mysqli('host', 'user', 'password', 'schema');

/* Cache miss and cache put */
$mysqli->query("/*qc=on*/SELECT id FROM test");
/* Cache hit */
$mysqli->query("/*qc=on*/SELECT id FROM test");

/* Display core statistics */
var_dump(mysqlnd_qc_get_core_stats());
?>

以上例程会输出：

array(26) {
  ["cache_hit"]=>
  string(1) "1"
  ["cache_miss"]=>
  string(1) "1"
  ["cache_put"]=>
  string(1) "1"
  ["query_should_cache"]=>
  string(1) "2"
  ["query_should_not_cache"]=>
  string(1) "0"
  ["query_not_cached"]=>
  string(1) "0"
  ["query_could_cache"]=>
  string(1) "2"
  ["query_found_in_cache"]=>
  string(1) "1"
  ["query_uncached_other"]=>
  string(1) "0"
  ["query_uncached_no_table"]=>
  string(1) "0"
  ["query_uncached_no_result"]=>
  string(1) "0"
  ["query_uncached_use_result"]=>
  string(1) "0"
  ["query_aggr_run_time_cache_hit"]=>
  string(1) "4"
  ["query_aggr_run_time_cache_put"]=>
  string(3) "395"
  ["query_aggr_run_time_total"]=>
  string(3) "399"
  ["query_aggr_store_time_cache_hit"]=>
  string(1) "2"
  ["query_aggr_store_time_cache_put"]=>
  string(1) "8"
  ["query_aggr_store_time_total"]=>
  string(2) "10"
  ["receive_bytes_recorded"]=>
  string(2) "65"
  ["receive_bytes_replayed"]=>
  string(2) "65"
  ["send_bytes_recorded"]=>
  string(2) "29"
  ["send_bytes_replayed"]=>
  string(2) "29"
  ["slam_stale_refresh"]=>
  string(1) "0"
  ["slam_stale_hit"]=>
  string(1) "0"
  ["request_counter"]=>
  int(1)
  ["process_hash"]=>
  int(3547549858)
}

参见

  • Runtime configuration
  • mysqlnd_qc.collect_statistics
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc_get_cache_info() - Returns information on the current handler, the number of cache entries and cache entries, if available


Returns a normalized query trace log for each query inspected by the query cache

  • ? mysqlnd_qc_get_core_stats
  • mysqlnd_qc_get_query_trace_log ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Returns a normalized query trace log for each query inspected by the query cache

mysqlnd_qc_get_normalized_query_trace_log

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_normalized_query_trace_log — Returns a normalized query trace log for each query inspected by the query cache

说明

mysqlnd_qc_get_normalized_query_trace_log ( ) : array

Returns a normalized query trace log for each query inspected by the query cache. The collection of the trace log is disabled by default. To collect the trace log you have to set the PHP configuration directive mysqlnd_qc.collect_normalized_query_trace to 1

Entries in the trace log are grouped by the normalized query statement. The normalized query statement is the query statement with all statement parameter values being replaced with a question mark. For example, the two statements SELECT id FROM test WHERE id = 1 and SELECT id FROM test WHERE id = 2 are normalized as SELECT id FROM test WHERE id = ?. Whenever a statement is inspected by the query cache which matches the normalized statement pattern, its statistics are grouped by the normalized statement string.

参数

此函数没有参数。

返回值

An array of query log. Every list entry contains the normalized query stringand further detail information.

Key | Description
query | Normalized statement string.
occurences | How many statements have matched the normalized statement string in addition to the one which has created the log entry. The value is zero if a statement has been normalized, its normalized representation has been added to the log but no further queries inspected by PECL/mysqlnd_qc have the same normalized statement string.
eligible_for_caching | Whether the statement could be cached. An statement eligible for caching has not necessarily been cached. It not possible to tell for sure if or how many cached statement have contributed to the aggregated normalized statement log entry. However, comparing the minimum and average run time one can make an educated guess.
avg_run_time | The average run time of all queries contributing to the query log entry. The run time is the time between sending the query statement to MySQL and receiving an answer from MySQL.
avg_store_time | The average store time of all queries contributing to the query log entry. The store time is the time needed to fetch a statements result set from the server to the client and, storing it on the client.
min_run_time | The minimum run time of all queries contributing to the query log entry.
min_store_time | The minimum store time of all queries contributing to the query log entry.
max_run_time | The maximum run time of all queries contributing to the query log entry.
max_store_time | The maximum store time of all queries contributing to the query log entry.

范例

Example #1 mysqlnd_qc_get_normalized_query_trace_log() example

mysqlnd_qc.collect_normalized_query_trace=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* not cached */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* cache put */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

/* cache hit */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

var_dump(mysqlnd_qc_get_normalized_query_trace_log());
?>

以上例程会输出：

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(4) {
  [0]=>
  array(9) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [1]=>
  array(9) {
    ["query"]=>
    string(27) "CREATE TABLE test (id INT )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [2]=>
  array(9) {
    ["query"]=>
    string(40) "INSERT INTO test (id ) VALUES (? ), (? )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [3]=>
  array(9) {
    ["query"]=>
    string(31) "SELECT id FROM test WHERE id =?"
    ["occurences"]=>
    int(2)
    ["eligible_for_caching"]=>
    bool(true)
    ["avg_run_time"]=>
    int(159)
    ["min_run_time"]=>
    int(12)
    ["max_run_time"]=>
    int(307)
    ["avg_store_time"]=>
    int(10)
    ["min_store_time"]=>
    int(8)
    ["max_store_time"]=>
    int(13)
  }
}

参见

  • Runtime configuration
  • mysqlnd_qc.collect_normalized_query_trace
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc_get_query_trace_log() - Returns a backtrace for each query inspected by the query cache


Returns a backtrace for each query inspected by the query cache

  • ? mysqlnd_qc_get_normalized_query_trace_log
  • mysqlnd_qc_set_cache_condition ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Returns a backtrace for each query inspected by the query cache

mysqlnd_qc_get_query_trace_log

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_query_trace_log — Returns a backtrace for each query inspected by the query cache

说明

mysqlnd_qc_get_query_trace_log ( ) : array

Returns a backtrace for each query inspected by the query cache. The collection of the backtrace is disabled by default. To collect the backtrace you have to set the PHP configuration directive mysqlnd_qc.collect_query_trace to 1

The maximum depth of the backtrace is limited to the depth set with the PHP configuration directive mysqlnd_qc.query_trace_bt_depth.

参数

此函数没有参数。

返回值

An array of query backtrace. Every list entry contains the query string, a backtrace and further detail information.

Key | Description
query | Query string.
origin | Code backtrace.
run_time | Query run time in milliseconds. The collection of all times and the necessary gettimeofday system calls can be disabled by setting the PHP configuration directive mysqlnd_qc.time_statistics to 0
store_time | Query result set store time in milliseconds. The collection of all times and the necessary gettimeofday system calls can be disabled by setting the PHP configuration directive mysqlnd_qc.time_statistics to 0
eligible_for_caching | true if query is cacheable otherwise false.
no_table | true if the query has generated a result set and at least one column from the result set has no table name set in its metadata. This is usually the case with queries which one probably do not want to cache such as SELECT SLEEP(1). By default any such query will not be added to the cache. See also PHP configuration directive mysqlnd_qc.cache_no_table.
was_added | true if the query result has been put into the cache, otherwise false.
was_already_in_cache | true if the query result would have been added to the cache if it was not already in the cache (cache hit). Otherwise false.

范例

Example #1 mysqlnd_qc_get_query_trace_log() example

mysqlnd_qc.collect_query_trace=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* not cached */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* cache put */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

/* cache hit */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

var_dump(mysqlnd_qc_get_query_trace_log());
?>

以上例程会输出：

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(6) {
  [0]=>
  array(8) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["origin"]=>
    string(102) "#0 qc.php(4): mysqli->query('DROP TABLE IF E...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [1]=>
  array(8) {
    ["query"]=>
    string(25) "CREATE TABLE test(id INT)"
    ["origin"]=>
    string(102) "#0 qc.php(5): mysqli->query('CREATE TABLE te...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [2]=>
  array(8) {
    ["query"]=>
    string(36) "INSERT INTO test(id) VALUES (1), (2)"
    ["origin"]=>
    string(102) "#0 qc.php(6): mysqli->query('INSERT INTO tes...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [3]=>
  array(8) {
    ["query"]=>
    string(32) "SELECT id FROM test WHERE id = 1"
    ["origin"]=>
    string(102) "#0 qc.php(9): mysqli->query('SELECT id FROM ...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(25)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [4]=>
  array(8) {
    ["query"]=>
    string(41) "/*qc=on*/SELECT id FROM test WHERE id = 2"
    ["origin"]=>
    string(103) "#0 qc.php(14): mysqli->query('/*qc=on*/SELECT...')
#1 {main}"
    ["run_time"]=>
    int(311)
    ["store_time"]=>
    int(13)
    ["eligible_for_caching"]=>
    bool(true)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(true)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [5]=>
  array(8) {
    ["query"]=>
    string(41) "/*qc=on*/SELECT id FROM test WHERE id = 2"
    ["origin"]=>
    string(103) "#0 qc.php(19): mysqli->query('/*qc=on*/SELECT...')
#1 {main}"
    ["run_time"]=>
    int(13)
    ["store_time"]=>
    int(8)
    ["eligible_for_caching"]=>
    bool(true)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(true)
  }
}

参见

  • Runtime configuration
  • mysqlnd_qc.collect_query_trace
  • mysqlnd_qc.query_trace_bt_depth
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc.cache_no_table
  • mysqlnd_qc_get_normalized_query_trace_log() - Returns a normalized query trace log for each query inspected by the query cache


Set conditions for automatic caching

  • ? mysqlnd_qc_get_query_trace_log
  • mysqlnd_qc_set_is_select ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Set conditions for automatic caching

mysqlnd_qc_set_cache_condition

(PECL mysqlnd_qc >= 1.1.0)

mysqlnd_qc_set_cache_condition — Set conditions for automatic caching

说明

mysqlnd_qc_set_cache_condition ( int $condition_type , mixed $condition , mixed $condition_option ) : bool

Sets a condition for automatic caching of statements which do not contain the necessary SQL hints to enable caching of them.

参数

condition_type

Type of the condition. The only allowed value is MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN.

condition

Parameter for the condition set with condition_type. Parameter type and structure depend on condition_type

If condition_type equals MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN condition must be a string. The string sets a pattern. Statements are cached if table and database meta data entry of their result sets match the pattern. The pattern is checked for a match with the db and org_table meta data entries provided by the underlying MySQL client server library. Please, check the MySQL Reference manual for details about the two entries. The db and org_table values are concatenated with a dot (.) before matched against condition. Pattern matching supports the wildcards % and _. The wildcard % will match one or many arbitrary characters. _ will match one arbitrary character. The escape symbol is backslash.

condition_option

Option for condition. Type and structure depend on condition_type.

If condition_type equals MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN condition_options is the TTL to be used.

范例

Example #1 mysqlnd_qc_set_cache_condition() example

<?php
/* Cache all accesses to tables with the name "new%" in schema/database "db_example" for 1 second */
if (!mysqlnd_qc_set_cache_condition(MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN, "db_example.new%", 1)) {
  die("Failed to set cache condition!");
}

$mysqli = new mysqli("host", "user", "password", "db_example", "port");
/* cached although no SQL hint given  */
$mysqli->query("SELECT id, title FROM news");

$pdo_mysql = new PDO("mysql:host=host;dbname=db_example;port=port", "user", "password");
/* not cached: no SQL hint, no pattern match */
$pdo_mysql->query("SELECT id, title FROM latest_news");
/* cached: TTL 1 second, pattern match */
$pdo_mysql->query("SELECT id, title FROM news");
?>

返回值

Returns TRUE on success or FALSE on FAILURE.

参见

  • Quickstart: pattern based caching


Installs a callback which decides whether a statement is cached

  • ? mysqlnd_qc_set_cache_condition
  • mysqlnd_qc_set_storage_handler ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Installs a callback which decides whether a statement is cached

mysqlnd_qc_set_is_select

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_is_select — Installs a callback which decides whether a statement is cached

说明

mysqlnd_qc_set_is_select ( string $callback ) : mixed

Installs a callback which decides whether a statement is cached.

There are several ways of hinting PELC/mysqlnd_qc to cache a query. By default, PECL/mysqlnd_qc attempts to cache a if caching of all statements is enabled or the query string begins with a certain SQL hint. The plugin internally calls a function named is_select() to find out. This internal function can be replaced with a user-defined callback. Then, the user-defined callback is responsible to decide whether the plugin attempts to cache a statement. Because the internal function is replaced with the callback, the callback gains full control. The callback is free to ignore the configuration setting mysqlnd_qc.cache_by_default and SQL hints.

The callback is invoked for every statement inspected by the plugin. It is given the statements string as a parameter. The callback returns false if the statement shall not be cached. It returns true to make the plugin attempt to cache the statements result set, if any. A so-created cache entry is given the default TTL set with the PHP configuration directive mysqlnd_qc.ttl. If a different TTL shall be used, the callback returns a numeric value to be used as the TTL.

The internal is_select function is part of the internal cache storage handler interface. Thus, a user-defined storage handler offers the same capabilities.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mysqlnd_qc_set_is_select() example

<?php
/* callback which decides if query is cached */
function is_select($query) {
  static $patterns = array(
   /* true - use default from mysqlnd_qc.ttl */
   "@SELECT\s+.*\s+FROM\s+test@ismU" => true,
   /* 3 - use TTL = 3 seconds */
   "@SELECT\s+.*\s+FROM\s+news@ismU" => 3
  );
  /* check if query does match pattern */
  foreach ($patterns as $pattern => $ttl) {
    if (preg_match($pattern, $query)) {
      printf("is_select(%45s): cache\n", $query);
      return $ttl;
    }
  }
  printf("is_select(%45s): do not cache\n", $query);
  return false;
}
mysqlnd_qc_set_is_select("is_select");

/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* cache put */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* cache hit */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* cache put */
$mysqli->query("SELECT * FROM test");
?>

以上例程会输出：

is_select(                    DROP TABLE IF EXISTS test): do not cache
is_select(                    CREATE TABLE test(id INT)): do not cache
is_select(    INSERT INTO test(id) VALUES (1), (2), (3)): do not cache
is_select(             SELECT id FROM test WHERE id = 1): cache
is_select(             SELECT id FROM test WHERE id = 1): cache
is_select(                           SELECT * FROM test): cache

参见

  • Runtime configuration
  • mysqlnd_qc.ttl
  • mysqlnd_qc.cache_by_default
  • mysqlnd_qc_set_user_handlers() - Sets the callback functions for a user-defined procedural storage handler


Change current storage handler

  • ? mysqlnd_qc_set_is_select
  • mysqlnd_qc_set_user_handlers ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Change current storage handler

mysqlnd_qc_set_storage_handler

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_storage_handler — Change current storage handler

说明

mysqlnd_qc_set_storage_handler ( string $handler ) : bool

Sets the storage handler used by the query cache. A list of available storage handler can be obtained from mysqlnd_qc_get_available_handlers(). Which storage are available depends on the compile time configuration of the query cache plugin. The default storage handler is always available. All other storage handler must be enabled explicitly when building the extension.

参数

handler

Handler can be of type string representing the name of a built-in storage handler or an object of type mysqlnd_qc_handler_default. The names of the built-in storage handler are default, APC, MEMCACHE, sqlite.

返回值

成功时返回 true， 或者在失败时返回 false。

If changing the storage handler fails a catchable fatal error will be thrown. The query cache cannot operate if the previous storage handler has been shutdown but no new storage handler has been installed.

范例

Example #1 mysqlnd_qc_set_storage_handler() example

The example shows the output from the built-in default storage handler. Other storage handler may report different data.

<?php
var_dump(mysqlnd_qc_set_storage_handler("memcache"));

if (true === mysqlnd_qc_set_storage_handler("default"))
  printf("Default storage handler activated");

/* Catchable fatal error */
var_dump(mysqlnd_qc_set_storage_handler("unknown"));
?>

以上例程会输出：

bool(true)
Default storage handler activated
Catchable fatal error: mysqlnd_qc_set_storage_handler(): Unknown handler 'unknown' in (file) on line (line)

参见

  • Installation
  • mysqlnd_qc_get_available_handlers() - Returns a list of available storage handler


Sets the callback functions for a user-defined procedural storage handler

  • ? mysqlnd_qc_set_storage_handler
  • Change History ?
  • PHP Manual
  • mysqlnd_qc 函数
  • Sets the callback functions for a user-defined procedural storage handler

mysqlnd_qc_set_user_handlers

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_user_handlers — Sets the callback functions for a user-defined procedural storage handler

说明

mysqlnd_qc_set_user_handlers ( string $get_hash , string $find_query_in_cache , string $return_to_cache , string $add_query_to_cache_if_not_exists , string $query_is_select , string $update_query_run_time_stats , string $get_stats , string $clear_cache ) : bool

Sets the callback functions for a user-defined procedural storage handler.

参数

get_hash

Name of the user function implementing the storage handler get_hash functionality.

find_query_in_cache

Name of the user function implementing the storage handler find_in_cache functionality.

return_to_cache

Name of the user function implementing the storage handler return_to_cache functionality.

add_query_to_cache_if_not_exists

Name of the user function implementing the storage handler add_query_to_cache_if_not_exists functionality.

query_is_select

Name of the user function implementing the storage handler query_is_select functionality.

update_query_run_time_stats

Name of the user function implementing the storage handler update_query_run_time_stats functionality.

get_stats

Name of the user function implementing the storage handler get_stats functionality.

clear_cache

Name of the user function implementing the storage handler clear_cache functionality.

返回值

Returns TRUE on success or FALSE on FAILURE.

参见

  • Procedural user-defined storage handler example


Change History

Table of Contents

  • PECL/mysqlnd_qc 1.2 series
  • PECL/mysqlnd_qc 1.1 series
  • PECL/mysqlnd_qc 1.0 series

This change history is a high level summary of selected changes that may impact applications and/or break backwards compatibility.

See also the CHANGES file in the source distribution for a complete list of changes.


PECL/mysqlnd_qc 1.2 series

1.2.0 - alpha

  • Release date: 03/2013
  • Motto/theme: PHP 5.5 compatibility

Feature changes

  • Update build for PHP 5.5 (Credits: Remi Collet)

  • APC storage handler update

    • Fix build for APC 3.1.13-beta and trunk

  • Introduced MYSQLND_QC_VERSION and MYSQLND_QC_VERSION_ID.


PECL/mysqlnd_qc 1.1 series

1.1.0 - stable

  • Release date: 04/2012
  • Motto/theme: PHP 5.4 compatibility, schema pattern based caching and mysqlnd_ms support

1.1.0 - beta

  • Release date: 04/2012
  • Motto/theme: PHP 5.4 compatibility, schema pattern based caching and mysqlnd_ms support

1.1.0 - alpha

  • Release date: 04/2012
  • Motto/theme: PHP 5.4 compatibility, schema pattern based caching and mysqlnd_ms support

Feature changes

  • APC storage handler update

    • Fix build for APC 3.1.9+
    • Note: Use of the APC storage handler is currently not recommended due to stability issues of APC itself.

  • New PHP configuration directives

    • mysqlnd_qc.collect_statistics_log_file. Aggregated cache statistics log file written after every 10th request served by the PHP process.
    • mysqlnd_qc.ignore_sql_comments. Control whether SQL comments are ignored for cache key hash generation.

  • New constants and SQL hints

    • MYSQLND_QC_SERVER_ID_SWITCH allows grouping of cache entries from different physical connections. This is needed by PECL/mysqlnd_ms.
    • MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN to be used with mysqlnd_qc_set_cache_condition().

  • New function mysqlnd_qc_set_cache_condition() for built-in schema pattern based caching. Likely to support a wider range of conditions in the future.

  • Report valid_until timestamp for cache entries of the default handler through mysqlnd_qc_get_cache_info().

  • Include charset number for cache entry hashing. This should prevent serving result sets which have the wrong charset.

    API change: get_hash_key expects new "charsetnr" (int) parameter after "port".

  • API change: changing is_select() signature from bool is_select() to mixed is_select(). Mixed can be either boolean or array(long ttl, string server_id). This is needed by PECL/mysqlnd_ms.

Other

  • Support acting as a cache backend for PECL/mysqlnd_ms 1.3.0-beta or later to transparently replace MySQL Replication slave reads with cache accesses, if the user explicitly allows.

Bug fixes

  • Fixed Bug #59959 (config.m4, wrong library - 64bit memcached handler builds) (Credits: Remi Collet)


PECL/mysqlnd_qc 1.0 series

1.0.1-stable

  • Release date: 12/2010
  • Motto/theme: Prepared statement support

Added support for Prepared statements and unbuffered queries.

1.0.0-beta

  • Release date: 07/2010
  • Motto/theme: TTL-based cache with various storage options (Memcache, APC, SQLite, user-defined)

Initial public release of the transparent TTL-based query result cache. Flexible storage of cached results. Various storage media supported.


Mysqlnd user handler plugin

  • 简介
  • Quickstart and Examples
    • Setup
    • How it works
    • Installing a proxy
    • Basic query monitoring
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • MysqlndUhConnection — The MysqlndUhConnection class
    • MysqlndUhConnection::changeUser — Changes the user of the specified mysqlnd database connection
    • MysqlndUhConnection::charsetName — Returns the default character set for the database connection
    • MysqlndUhConnection::close — Closes a previously opened database connection
    • MysqlndUhConnection::connect — Open a new connection to the MySQL server
    • MysqlndUhConnection::__construct — The __construct purpose
    • MysqlndUhConnection::endPSession — End a persistent connection
    • MysqlndUhConnection::escapeString — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
    • MysqlndUhConnection::getAffectedRows — Gets the number of affected rows in a previous MySQL operation
    • MysqlndUhConnection::getErrorNumber — Returns the error code for the most recent function call
    • MysqlndUhConnection::getErrorString — Returns a string description of the last error
    • MysqlndUhConnection::getFieldCount — Returns the number of columns for the most recent query
    • MysqlndUhConnection::getHostInformation — Returns a string representing the type of connection used
    • MysqlndUhConnection::getLastInsertId — Returns the auto generated id used in the last query
    • MysqlndUhConnection::getLastMessage — Retrieves information about the most recently executed query
    • MysqlndUhConnection::getProtocolInformation — Returns the version of the MySQL protocol used
    • MysqlndUhConnection::getServerInformation — Returns the version of the MySQL server
    • MysqlndUhConnection::getServerStatistics — Gets the current system status
    • MysqlndUhConnection::getServerVersion — Returns the version of the MySQL server as an integer
    • MysqlndUhConnection::getSqlstate — Returns the SQLSTATE error from previous MySQL operation
    • MysqlndUhConnection::getStatistics — Returns statistics about the client connection
    • MysqlndUhConnection::getThreadId — Returns the thread ID for the current connection
    • MysqlndUhConnection::getWarningCount — Returns the number of warnings from the last query for the given link
    • MysqlndUhConnection::init — Initialize mysqlnd connection
    • MysqlndUhConnection::killConnection — Asks the server to kill a MySQL thread
    • MysqlndUhConnection::listFields — List MySQL table fields
    • MysqlndUhConnection::listMethod — Wrapper for assorted list commands
    • MysqlndUhConnection::moreResults — Check if there are any more query results from a multi query
    • MysqlndUhConnection::nextResult — Prepare next result from multi_query
    • MysqlndUhConnection::ping — Pings a server connection, or tries to reconnect if the connection has gone down
    • MysqlndUhConnection::query — Performs a query on the database
    • MysqlndUhConnection::queryReadResultsetHeader — Read a result set header
    • MysqlndUhConnection::reapQuery — Get result from async query
    • MysqlndUhConnection::refreshServer — Flush or reset tables and caches
    • MysqlndUhConnection::restartPSession — Restart a persistent mysqlnd connection
    • MysqlndUhConnection::selectDb — Selects the default database for database queries
    • MysqlndUhConnection::sendClose — Sends a close command to MySQL
    • MysqlndUhConnection::sendQuery — Sends a query to MySQL
    • MysqlndUhConnection::serverDumpDebugInformation — Dump debugging information into the log for the MySQL server
    • MysqlndUhConnection::setAutocommit — Turns on or off auto-committing database modifications
    • MysqlndUhConnection::setCharset — Sets the default client character set
    • MysqlndUhConnection::setClientOption — Sets a client option
    • MysqlndUhConnection::setServerOption — Sets a server option
    • MysqlndUhConnection::shutdownServer — The shutdownServer purpose
    • MysqlndUhConnection::simpleCommand — Sends a basic COM_* command
    • MysqlndUhConnection::simpleCommandHandleResponse — Process a response for a basic COM_* command send to the client
    • MysqlndUhConnection::sslSet — Used for establishing secure connections using SSL
    • MysqlndUhConnection::stmtInit — Initializes a statement and returns a resource for use with mysqli_statement::prepare
    • MysqlndUhConnection::storeResult — Transfers a result set from the last query
    • MysqlndUhConnection::txCommit — Commits the current transaction
    • MysqlndUhConnection::txRollback — Rolls back current transaction
    • MysqlndUhConnection::useResult — Initiate a result set retrieval
  • MysqlndUhPreparedStatement — The MysqlndUhPreparedStatement class
    • MysqlndUhPreparedStatement::__construct — The __construct purpose
    • MysqlndUhPreparedStatement::execute — Executes a prepared Query
    • MysqlndUhPreparedStatement::prepare — Prepare an SQL statement for execution
  • Mysqlnd_uh 函数
    • mysqlnd_uh_convert_to_mysqlnd — Converts a MySQL connection handle into a mysqlnd connection handle
    • mysqlnd_uh_set_connection_proxy — Installs a proxy for mysqlnd connections
    • mysqlnd_uh_set_statement_proxy — Installs a proxy for mysqlnd statements
  • Change History
    • PECL/mysqlnd_uh 1.0 series


简介

The mysqlnd user handler plugin (mysqlnd_uh) allows users to set hooks for most internal calls of the MySQL native driver for PHP (mysqlnd). Mysqlnd and its plugins, including PECL/mysqlnd_uh, operate on a layer beneath the PHP MySQL extensions. A mysqlnd plugin can be considered as a proxy between the PHP MySQL extensions and the MySQL server as part of the PHP executable on the client-side. Because the plugins operates on their own layer below the PHP MySQL extensions, they can monitor and change application actions without requiring application changes. If the PHP MySQL extensions (mysqli, mysql, PDO_MYSQL) are compiled to use mysqlnd this can be used for:

  • Monitoring

    • Queries executed by any of the PHP MySQL extensions

    • Prepared statements executing by any of the PHP MySQL extensions

  • Auditing

    • Detection of database usage

    • SQL injection protection using black and white lists

  • Assorted

    • Load Balancing connections

The MySQL native driver for PHP (mysqlnd) features an internal plugin C API. C plugins, such as the mysqlnd user handler plugin, can extend the functionality of mysqlnd. PECL/mysqlnd_uh makes parts of the internal plugin C API available to the PHP user for plugin development with PHP.

Note: Status

The mysqlnd user handler plugin is in alpha status. Take appropriate care before using it in production environments.

Security considerations

PECL/mysqlnd_uh gives users access to MySQL user names, MySQL password used by any of the PHP MySQL extensions to connect to MySQL. It allows monitoring of all queries and prepared statements exposing the statement string to the user. Therefore, the extension should be installed with care. The PHP_INI_SYSTEM configuration setting mysqlnd_uh.enable can be used to prevent users from hooking mysqlnd calls.

Code obfuscators and similar technologies are not suitable to prevent monitoring of mysqlnd library activities if PECL/mysqlnd_uh is made available and the user can install a proxy, for example, using auto_prepend_file.

Documentation note

Many of the mysqlnd_uh functions are briefly described because the mysqli extension is a thin abstraction layer on top of the MySQL C API that the mysqlnd library provides. Therefore, the corresponding mysqli documentation (along with the MySQL reference manual) can be consulted to receive more information about a particular function.

On the name

The shortcut mysqlnd_uh stands for mysqlnd user handler, and has been the name since early development.


Quickstart and Examples

Table of Contents

  • Setup
  • How it works
  • Installing a proxy
  • Basic query monitoring

The mysqlnd user handler plugin can be understood as a client-side proxy for all PHP MySQL extensions (mysqli, mysql, PDO_MYSQL), if they are compiled to use the mysqlnd library. The extensions use the mysqlnd library internally, at the C level, to communicate with the MySQL server. PECL/mysqlnd_uh allows it to hook many mysqlnd calls. Therefore, most activities of the PHP MySQL extensions can be monitored.

Because monitoring happens at the level of the library, at a layer below the application, it is possible to monitor applications without changing them.

On the C level, the mysqlnd library is structured in modules or classes. The extension hooks almost all methods of the mysqlnd internal connection class and exposes them through the user space class MysqlndUhConnection. Some few methods of the mysqlnd internal statement class are made available to the PHP user with the class MysqlndUhPreparedStatement. By subclassing the classes MysqlndUhConnection and MysqlndUhPreparedStatement users get access to mysqlnd internal function calls.

Note:

The internal mysqlnd function calls are not designed to be exposed to the PHP user. Manipulating their activities may cause PHP to crash or leak memory. Often, this is not considered a bug. Please, keep in mind that you are accessing C library functions through PHP which are expected to take certain actions, which you may not be able to emulate in user space. Therefore, it is strongly recommended to always call the parent method implementation when subclassing MysqlndUhConnection or MysqlndUhPreparedStatement. To prevent the worst case, the extension performs some sanity checks. Please, see also the Mysqlnd_uh 配置选项.


Setup

The plugin is implemented as a PHP extension. See the installation instructions to install the » PECL/mysqlnd_uh extension. Then, load the extension into PHP and activate the plugin in the PHP configuration file using the PHP configuration directive named mysqlnd_uh.enable. The below example shows the default settings of the extension.

Example #1 Enabling the plugin (php.ini)

mysqlnd_uh.enable=1
mysqlnd_uh.report_wrong_types=1


How it works

This describes the background and inner workings of the mysqlnd_uh extension.

Two classes are provided by the extension: MysqlndUhConnection and MysqlndUhPreparedStatement. MysqlndUhConnection lets you access almost all methods of the mysqlnd internal connection class. The latter exposes some selected methods of the mysqlnd internal statement class. For example, MysqlndUhConnection::connect() maps to the mysqlnd library C function mysqlnd_conn__connect.

As a mysqlnd plugin, the PECL/mysqlnd_uh extension replaces mysqlnd library C functions with its own functions. Whenever a PHP MySQL extension compiled to use mysqlnd calls a mysqlnd function, the functions installed by the plugin are executed instead of the original mysqlnd ones. For example, mysqli_connect() invokes mysqlnd_conn__connect, so the connect function installed by PECL/mysqlnd_uh will be called. The functions installed by PECL/mysqlnd_uh are the methods of the built-in classes.

The built-in PHP classes and their methods do nothing but call their mysqlnd C library counterparts, to behave exactly like the original mysqlnd function they replace. The code below illustrates in pseudo-code what the extension does.

Example #1 Pseudo-code: what a built-in class does

class MysqlndUhConnection {
  public function connect(($conn, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
    MYSQLND* c_mysqlnd_connection = convert_from_php_to_c($conn);
    ...
    return call_c_function(mysqlnd_conn__connect(c_mysqlnd_connection, ...));
  }
}

The build-in classes behave like a transparent proxy. It is possible for you to replace the proxy with your own. This is done by subclassing MysqlndUhConnection or MysqlndUhPreparedStatement to extend the functionality of the proxy, followed by registering a new proxy object. Proxy objects are installed by mysqlnd_uh_set_connection_proxy() and mysqlnd_uh_set_statement_proxy().

Example #2 Installing a proxy

<?php
class proxy extends MysqlndUhConnection {
 public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

以上例程会输出：

proxy::connect(array (
  0 => NULL,
  1 => 'localhost',
  2 => 'root',
  3 => '',
  4 => 'test',
  5 => 3306,
  6 => NULL,
  7 => 131072,
))
proxy::connect returns true


Installing a proxy

The extension provides two built-in classes: MysqlndUhConnection and MysqlndUhPreparedStatement. The classes are used for hooking mysqlnd library calls. Their methods correspond to mysqlnd internal functions. By default they act like a transparent proxy and do nothing but call their mysqlnd counterparts. By subclassing the classes you can install your own proxy to monitor mysqlnd.

See also the How it works guide to learn about the inner workings of this extension.

Connection proxies are objects of the type MysqlndUhConnection. Connection proxy objects are installed by mysqlnd_uh_set_connection_proxy(). If you install the built-in class MysqlndUhConnection as a proxy, nothing happens. It behaves like a transparent proxy.

Example #1 Proxy registration, mysqlnd_uh.enable=1

<?php
mysqlnd_uh_set_connection_proxy(new MysqlndUhConnection());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

The PHP_INI_SYSTEM configuration setting mysqlnd_uh.enable controls whether a proxy may be set. If disabled, the extension will throw errors of type E_WARNING

Example #2 Proxy installation disabled

mysqlnd_uh.enable=0
<?php
mysqlnd_uh_set_connection_proxy(new MysqlndUhConnection());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

以上例程会输出：

PHP Warning:  MysqlndUhConnection::__construct(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enabled = false.  You must not use any of the base classes in %s on line %d
PHP Warning:  mysqlnd_uh_set_connection_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed  in %s on line %d

To monitor mysqlnd, you have to write your own proxy object subclassing MysqlndUhConnection. Please, see the function reference for a the list of methods that can be subclassed. Alternatively, you can use reflection to inspect the built-in MysqlndUhConnection.

Create a new class proxy. Derive it from the built-in class MysqlndUhConnection. Replace the MysqlndUhConnection::connect(). method. Print out the host parameter value passed to the method. Make sure that you call the parent implementation of the connect method. Failing to do so may give unexpected and undesired results, including memory leaks and crashes.

Register your proxy and open three connections using the PHP MySQL extensions mysqli, mysql, PDO_MYSQL. If the extensions have been compiled to use the mysqlnd library, the proxy::connect method will be called three times, once for each connection opened.

Example #3 Connection proxy

<?php
class proxy extends MysqlndUhConnection {
  public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("Connection opened to '%s'\n", $host);
   /* Always call the parent implementation! */
   return parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
  }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysql = mysql_connect("localhost", "root", "");
$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
?>

以上例程会输出：

Connection opened to 'localhost'
Connection opened to 'localhost'
Connection opened to 'localhost'

The use of prepared statement proxies follows the same pattern: create a proxy object of the type MysqlndUhPreparedStatement and install the proxy using mysqlnd_uh_set_statement_proxy().

Example #4 Prepared statement proxy

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  printf("%s(%s)\n", __METHOD__, $query);
  return parent::prepare($res, $query);
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'mysqlnd hacking made easy' AS _msg FROM DUAL");
?>

以上例程会输出：

stmt_proxy::prepare(SELECT 'mysqlnd hacking made easy' AS _msg FROM DUAL)


Basic query monitoring

Basic monitoring of a query statement is easy with PECL/mysqlnd_uh. Combined with debug_print_backtrace() it can become a powerful tool, for example, to find the origin of certain statement. This may be desired when searching for slow queries but also after database refactoring to find code still accessing deprecated databases or tables. The latter may be a complicated matter to do otherwise, especially if the application uses auto-generated queries.

Example #1 Basic Monitoring

<?php
class conn_proxy extends MysqlndUhConnection {
 public function query($res, $query) {
  debug_print_backtrace();
  return parent::query($res, $query);
 }
}
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  debug_print_backtrace();
  return parent::prepare($res, $query);
 }
}
mysqlnd_uh_set_connection_proxy(new conn_proxy());
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

printf("Proxies installed...\n");
$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
var_dump($pdo->query("SELECT 1 AS _one FROM DUAL")->fetchAll(PDO::FETCH_ASSOC));

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->prepare("SELECT 1 AS _two FROM DUAL");
?>

以上例程会输出：

#0  conn_proxy->query(Resource id #19, SELECT 1 AS _one FROM DUAL)
#1  PDO->query(SELECT 1 AS _one FROM DUAL) called at [example.php:19]
array(1) {
  [0]=>
  array(1) {
    ["_one"]=>
    string(1) "1"
  }
}
#0  stmt_proxy->prepare(Resource id #753, SELECT 1 AS _two FROM DUAL)
#1  mysqli->prepare(SELECT 1 AS _two FROM DUAL) called at [example.php:22]

For basic query monitoring you should install a connection and a prepared statement proxy. The connection proxy should subclass MysqlndUhConnection::query(). All database queries not using native prepared statements will call this method. In the example the query function is invoked by a PDO call. By default, PDO_MySQL is using prepared statement emulation.

All native prepared statements are prepared with the prepare method of mysqlnd exported through MysqlndUhPreparedStatement::prepare(). Subclass MysqlndUhPreparedStatement and overwrite prepare for native prepared statement monitoring.


  • ? Basic query monitoring
  • 需求 ?
  • PHP Manual
  • mysqlnd_uh
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

PHP 5.3.3 or later. It is recommended to use PHP 5.4.0 or later to get access to the latest mysqlnd features.

The mysqlnd_uh user handler plugin supports all PHP applications and all available PHP MySQL extensions (mysqli, mysql, PDO_MYSQL). The PHP MySQL extension must be configured to use mysqlnd in order to be able to use the mysqlnd_uh plugin for mysqlnd.

The alpha versions makes use of some mysqli features. You must enable mysqli to compile the plugin. This requirement may be removed in the future. Note, that this requirement does not restrict you to use the plugin only with mysqli. You can use the plugin to monitor mysql, mysqli and PDO_MYSQL.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mysqlnd-uh

PECL/mysqlnd_uh is currently not available on Windows. The source code of the extension makes use of C99 constructs not allowed with PHP Windows builds.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Mysqlnd_uh 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mysqlnd_uh.enable | 1 | PHP_INI_SYSTEM |
mysqlnd_uh.report_wrong_types | 1 | PHP_INI_ALL |

这是配置指令的简短说明。

mysqlnd_uh.enable int

Enables or disables the plugin. If set to disabled, the extension will not allow users to plug into mysqlnd to hook mysqlnd calls.

mysqlnd_uh.report_wrong_types int

Whether to report wrong return value types of user hooks as E_WARNING level errors. This is recommended for detecting errors.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Most of the constants refer to details of the MySQL Client Server Protocol. Please, refer to the MySQL reference manual to learn about their meaning. To avoid content duplication, only short descriptions are given.

MysqlndUhConnection::simpleCommand() related

The following constants can be used to detect what command is to be send through MysqlndUhConnection::simpleCommand().

MYSQLND_UH_MYSQLND_COM_SLEEP (int)
MySQL Client Server protocol command: COM_SLEEP.
MYSQLND_UH_MYSQLND_COM_QUIT (int)
MySQL Client Server protocol command: COM_QUIT.
MYSQLND_UH_MYSQLND_COM_INIT_DB (int)
MySQL Client Server protocol command: COM_INIT_DB.
MYSQLND_UH_MYSQLND_COM_QUERY (int)
MySQL Client Server protocol command: COM_QUERY.
MYSQLND_UH_MYSQLND_COM_FIELD_LIST (int)
MySQL Client Server protocol command: COM_FIELD_LIST.
MYSQLND_UH_MYSQLND_COM_CREATE_DB (int)
MySQL Client Server protocol command: COM_CREATE_DB.
MYSQLND_UH_MYSQLND_COM_DROP_DB (int)
MySQL Client Server protocol command: COM_DROP_DB.
MYSQLND_UH_MYSQLND_COM_REFRESH (int)
MySQL Client Server protocol command: COM_REFRESH.
MYSQLND_UH_MYSQLND_COM_SHUTDOWN (int)
MySQL Client Server protocol command: COM_SHUTDOWN.
MYSQLND_UH_MYSQLND_COM_STATISTICS (int)
MySQL Client Server protocol command: COM_STATISTICS.
MYSQLND_UH_MYSQLND_COM_PROCESS_INFO (int)
MySQL Client Server protocol command: COM_PROCESS_INFO.
MYSQLND_UH_MYSQLND_COM_CONNECT (int)
MySQL Client Server protocol command: COM_CONNECT.
MYSQLND_UH_MYSQLND_COM_PROCESS_KILL (int)
MySQL Client Server protocol command: COM_PROCESS_KILL.
MYSQLND_UH_MYSQLND_COM_DEBUG (int)
MySQL Client Server protocol command: COM_DEBUG.
MYSQLND_UH_MYSQLND_COM_PING (int)
MySQL Client Server protocol command: COM_PING.
MYSQLND_UH_MYSQLND_COM_TIME (int)
MySQL Client Server protocol command: COM_TIME.
MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT (int)
MySQL Client Server protocol command: COM_DELAYED_INSERT.
MYSQLND_UH_MYSQLND_COM_CHANGE_USER (int)
MySQL Client Server protocol command: COM_CHANGE_USER.
MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP (int)
MySQL Client Server protocol command: COM_BINLOG_DUMP.
MYSQLND_UH_MYSQLND_COM_TABLE_DUMP (int)
MySQL Client Server protocol command: COM_TABLE_DUMP.
MYSQLND_UH_MYSQLND_COM_CONNECT_OUT (int)
MySQL Client Server protocol command: COM_CONNECT_OUT.
MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED (int)
MySQL Client Server protocol command: COM_REGISTER_SLAVED.
MYSQLND_UH_MYSQLND_COM_STMT_PREPARE (int)
MySQL Client Server protocol command: COM_STMT_PREPARE.
MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE (int)
MySQL Client Server protocol command: COM_STMT_EXECUTE.
MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA (int)
MySQL Client Server protocol command: COM_STMT_SEND_LONG_DATA.
MYSQLND_UH_MYSQLND_COM_STMT_CLOSE (int)
MySQL Client Server protocol command: COM_STMT_CLOSE.
MYSQLND_UH_MYSQLND_COM_STMT_RESET (int)
MySQL Client Server protocol command: COM_STMT_RESET.
MYSQLND_UH_MYSQLND_COM_SET_OPTION (int)
MySQL Client Server protocol command: COM_SET_OPTION.
MYSQLND_UH_MYSQLND_COM_STMT_FETCH (int)
MySQL Client Server protocol command: COM_STMT_FETCH.
MYSQLND_UH_MYSQLND_COM_DAEMON (int)
MySQL Client Server protocol command: COM_DAEMON.
MYSQLND_UH_MYSQLND_COM_END (int)
MySQL Client Server protocol command: COM_END.

The following constants can be used to analyze the ok_packet argument of MysqlndUhConnection::simpleCommand().

MYSQLND_UH_MYSQLND_PROT_GREET_PACKET (int)
MySQL Client Server protocol packet: greeting.
MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET (int)
MySQL Client Server protocol packet: authentication.
MYSQLND_UH_MYSQLND_PROT_OK_PACKET (int)
MySQL Client Server protocol packet: OK.
MYSQLND_UH_MYSQLND_PROT_EOF_PACKET (int)
MySQL Client Server protocol packet: EOF.
MYSQLND_UH_MYSQLND_PROT_CMD_PACKET (int)
MySQL Client Server protocol packet: command.
MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET (int)
MySQL Client Server protocol packet: result set header.
MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET (int)
MySQL Client Server protocol packet: resultset field.
MYSQLND_UH_MYSQLND_PROT_ROW_PACKET (int)
MySQL Client Server protocol packet: row.
MYSQLND_UH_MYSQLND_PROT_STATS_PACKET (int)
MySQL Client Server protocol packet: stats.
MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET (int)
MySQL Client Server protocol packet: prepare response.
MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET (int)
MySQL Client Server protocol packet: change user response.
MYSQLND_UH_MYSQLND_PROT_LAST (int)
No practical meaning. Last entry marker of internal C data structure list.

MysqlndUhConnection::close() related

The following constants can be used to detect why a connection has been closed through MysqlndUhConnection::close().

MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT (int)
User has called mysqlnd to close the connection.
MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT (int)
Implicitly closed, for example, during garbage connection.
MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED (int)
Connection error.
MYSQLND_UH_MYSQLND_CLOSE_LAST (int)
No practical meaning. Last entry marker of internal C data structure list.

MysqlndUhConnection::setServerOption() related

The following constants can be used to detect which option is set through MysqlndUhConnection::setServerOption().

MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON (int)
Option: enables multi statement support.
MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_OFF (int)
Option: disables multi statement support.

MysqlndUhConnection::setClientOption() related

The following constants can be used to detect which option is set through MysqlndUhConnection::setClientOption().

MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT (int)
Option: connection timeout.
MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS (int)
Option: whether the MySQL compressed protocol is to be used.
MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE (int)
Option: named pipe to use for connection (Windows).
MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND (int)
Option: init command to execute upon connect.
MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE (int)
Option: MySQL server default file to read upon connect.
MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP (int)
Option: MySQL server default file group to read upon connect.
MYSQLND_UH_MYSQLND_SET_CHARSET_DIR (int)
Option: charset description files directory.
MYSQLND_UH_MYSQLND_SET_CHARSET_NAME (int)
Option: charset name.
MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE (int)
Option: Whether to allow LOAD DATA LOCAL INFILE use.
MYSQLND_UH_MYSQLND_OPT_PROTOCOL (int)
Option: supported protocol version.
MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME (int)
Option: shared memory base name for shared memory connections.
MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT (int)
Option: connection read timeout.
MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT (int)
Option: connection write timeout.
MYSQLND_UH_MYSQLND_OPT_USE_RESULT (int)
Option: unbuffered result sets.
MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION (int)
Embedded server related.
MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION (int)
Embedded server related.
MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION (int)
TODO
MYSQLND_UH_MYSQLND_SET_CLIENT_IP (int)
TODO
MYSQLND_UH_MYSQLND_SECURE_AUTH (int)
TODO
MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION (int)
Option: Whether to report data truncation.
MYSQLND_UH_MYSQLND_OPT_RECONNECT (int)
Option: Whether to reconnect automatically.
MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT (int)
Option: TODO
MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE (int)
Option: mysqlnd network buffer size for commands.
MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE (int)
Option: mysqlnd network buffer size for reading from the server.
MYSQLND_UH_MYSQLND_OPT_SSL_KEY (int)
Option: SSL key.
MYSQLND_UH_MYSQLND_OPT_SSL_CERT (int)
Option: SSL certificate.
MYSQLND_UH_MYSQLND_OPT_SSL_CA (int)
Option: SSL CA.
MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH (int)
Option: Path to SSL CA.
MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER (int)
Option: SSL cipher.
MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE (int)
Option: SSL passphrase.
MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR (int)
Option: server plugin directory.
MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH (int)
Option: default authentication method.
MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP (int)
TODO
MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET (int)
Option: maximum allowed packet size. Available as of PHP 5.4.0.
MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL (int)
Option: TODO. Available as of PHP 5.4.0.
MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE (int)
Option: make mysqlnd return integer and float columns as long even when using the MySQL Client Server text protocol. Only available with a custom build of mysqlnd.

Other

The plugins version number can be obtained using MYSQLND_UH_VERSION or MYSQLND_UH_VERSION_ID. MYSQLND_UH_VERSION is the string representation of the numerical version number MYSQLND_UH_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_UH_VERSION_ID | 10000

MYSQLND_UH_VERSION (string)
Plugin version string, for example, 1.0.0-alpha.
MYSQLND_UH_VERSION_ID (int)
Plugin version number, for example, 10000.


The MysqlndUhConnection class

(PECL mysqlnd-uh >= 1.0.0-alpha)

简介

类摘要

MysqlndUhConnection {
/* 方法 */
public changeUser ( mysqlnd_connection $connection , string $user , string $password , string $database , bool $silent , int $passwd_len ) : bool
public charsetName ( mysqlnd_connection $connection ) : string
public close ( mysqlnd_connection $connection , int $close_type ) : bool
public connect ( mysqlnd_connection $connection , string $host , string $use" , string $password , string $database , int $port , string $socket , int $mysql_flags ) : bool
public __construct ( )
public endPSession ( mysqlnd_connection $connection ) : bool
public escapeString ( mysqlnd_connection $connection , string $escape_string ) : string
public getAffectedRows ( mysqlnd_connection $connection ) : int
public getErrorNumber ( mysqlnd_connection $connection ) : int
public getErrorString ( mysqlnd_connection $connection ) : string
public getFieldCount ( mysqlnd_connection $connection ) : int
public getHostInformation ( mysqlnd_connection $connection ) : string
public getLastInsertId ( mysqlnd_connection $connection ) : int
public getLastMessage ( mysqlnd_connection $connection ) : void
public getProtocolInformation ( mysqlnd_connection $connection ) : string
public getServerInformation ( mysqlnd_connection $connection ) : string
public getServerStatistics ( mysqlnd_connection $connection ) : string
public getServerVersion ( mysqlnd_connection $connection ) : int
public getSqlstate ( mysqlnd_connection $connection ) : string
public getStatistics ( mysqlnd_connection $connection ) : array
public getThreadId ( mysqlnd_connection $connection ) : int
public getWarningCount ( mysqlnd_connection $connection ) : int
public init ( mysqlnd_connection $connection ) : bool
public killConnection ( mysqlnd_connection $connection , int $pid ) : bool
public listFields ( mysqlnd_connection $connection , string $table , string $achtung_wild ) : array
public listMethod ( mysqlnd_connection $connection , string $query , string $achtung_wild , string $par1 ) : void
public moreResults ( mysqlnd_connection $connection ) : bool
public nextResult ( mysqlnd_connection $connection ) : bool
public ping ( mysqlnd_connection $connection ) : bool
public query ( mysqlnd_connection $connection , string $query ) : bool
public queryReadResultsetHeader ( mysqlnd_connection $connection , mysqlnd_statement $mysqlnd_stmt ) : bool
public reapQuery ( mysqlnd_connection $connection ) : bool
public refreshServer ( mysqlnd_connection $connection , int $options ) : bool
public restartPSession ( mysqlnd_connection $connection ) : bool
public selectDb ( mysqlnd_connection $connection , string $database ) : bool
public sendClose ( mysqlnd_connection $connection ) : bool
public sendQuery ( mysqlnd_connection $connection , string $query ) : bool
public serverDumpDebugInformation ( mysqlnd_connection $connection ) : bool
public setAutocommit ( mysqlnd_connection $connection , int $mode ) : bool
public setCharset ( mysqlnd_connection $connection , string $charset ) : bool
public setClientOption ( mysqlnd_connection $connection , int $option , int $value ) : bool
public setServerOption ( mysqlnd_connection $connection , int $option ) : void
public shutdownServer ( string $MYSQLND_UH_RES_MYSQLND_NAME , string $level ) : void
public simpleCommand ( mysqlnd_connection $connection , int $command , string $arg , int $ok_packet , bool $silent , bool $ignore_upsert_status ) : bool
public simpleCommandHandleResponse ( mysqlnd_connection $connection , int $ok_packet , bool $silent , int $command , bool $ignore_upsert_status ) : bool
public sslSet ( mysqlnd_connection $connection , string $key , string $cert , string $ca , string $capath , string $cipher ) : bool
public stmtInit ( mysqlnd_connection $connection ) : resource
public storeResult ( mysqlnd_connection $connection ) : resource
public txCommit ( mysqlnd_connection $connection ) : bool
public txRollback ( mysqlnd_connection $connection ) : bool
public useResult ( mysqlnd_connection $connection ) : resource
}

Table of Contents

  • MysqlndUhConnection::changeUser — Changes the user of the specified mysqlnd database connection
  • MysqlndUhConnection::charsetName — Returns the default character set for the database connection
  • MysqlndUhConnection::close — Closes a previously opened database connection
  • MysqlndUhConnection::connect — Open a new connection to the MySQL server
  • MysqlndUhConnection::__construct — The __construct purpose
  • MysqlndUhConnection::endPSession — End a persistent connection
  • MysqlndUhConnection::escapeString — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
  • MysqlndUhConnection::getAffectedRows — Gets the number of affected rows in a previous MySQL operation
  • MysqlndUhConnection::getErrorNumber — Returns the error code for the most recent function call
  • MysqlndUhConnection::getErrorString — Returns a string description of the last error
  • MysqlndUhConnection::getFieldCount — Returns the number of columns for the most recent query
  • MysqlndUhConnection::getHostInformation — Returns a string representing the type of connection used
  • MysqlndUhConnection::getLastInsertId — Returns the auto generated id used in the last query
  • MysqlndUhConnection::getLastMessage — Retrieves information about the most recently executed query
  • MysqlndUhConnection::getProtocolInformation — Returns the version of the MySQL protocol used
  • MysqlndUhConnection::getServerInformation — Returns the version of the MySQL server
  • MysqlndUhConnection::getServerStatistics — Gets the current system status
  • MysqlndUhConnection::getServerVersion — Returns the version of the MySQL server as an integer
  • MysqlndUhConnection::getSqlstate — Returns the SQLSTATE error from previous MySQL operation
  • MysqlndUhConnection::getStatistics — Returns statistics about the client connection
  • MysqlndUhConnection::getThreadId — Returns the thread ID for the current connection
  • MysqlndUhConnection::getWarningCount — Returns the number of warnings from the last query for the given link
  • MysqlndUhConnection::init — Initialize mysqlnd connection
  • MysqlndUhConnection::killConnection — Asks the server to kill a MySQL thread
  • MysqlndUhConnection::listFields — List MySQL table fields
  • MysqlndUhConnection::listMethod — Wrapper for assorted list commands
  • MysqlndUhConnection::moreResults — Check if there are any more query results from a multi query
  • MysqlndUhConnection::nextResult — Prepare next result from multi_query
  • MysqlndUhConnection::ping — Pings a server connection, or tries to reconnect if the connection has gone down
  • MysqlndUhConnection::query — Performs a query on the database
  • MysqlndUhConnection::queryReadResultsetHeader — Read a result set header
  • MysqlndUhConnection::reapQuery — Get result from async query
  • MysqlndUhConnection::refreshServer — Flush or reset tables and caches
  • MysqlndUhConnection::restartPSession — Restart a persistent mysqlnd connection
  • MysqlndUhConnection::selectDb — Selects the default database for database queries
  • MysqlndUhConnection::sendClose — Sends a close command to MySQL
  • MysqlndUhConnection::sendQuery — Sends a query to MySQL
  • MysqlndUhConnection::serverDumpDebugInformation — Dump debugging information into the log for the MySQL server
  • MysqlndUhConnection::setAutocommit — Turns on or off auto-committing database modifications
  • MysqlndUhConnection::setCharset — Sets the default client character set
  • MysqlndUhConnection::setClientOption — Sets a client option
  • MysqlndUhConnection::setServerOption — Sets a server option
  • MysqlndUhConnection::shutdownServer — The shutdownServer purpose
  • MysqlndUhConnection::simpleCommand — Sends a basic COM_* command
  • MysqlndUhConnection::simpleCommandHandleResponse — Process a response for a basic COM_* command send to the client
  • MysqlndUhConnection::sslSet — Used for establishing secure connections using SSL
  • MysqlndUhConnection::stmtInit — Initializes a statement and returns a resource for use with mysqli_statement::prepare
  • MysqlndUhConnection::storeResult — Transfers a result set from the last query
  • MysqlndUhConnection::txCommit — Commits the current transaction
  • MysqlndUhConnection::txRollback — Rolls back current transaction
  • MysqlndUhConnection::useResult — Initiate a result set retrieval


Changes the user of the specified mysqlnd database connection

  • ? MysqlndUhConnection
  • MysqlndUhConnection::charsetName ?
  • PHP Manual
  • MysqlndUhConnection
  • Changes the user of the specified mysqlnd database connection

MysqlndUhConnection::changeUser

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::changeUser — Changes the user of the specified mysqlnd database connection

说明

public MysqlndUhConnection::changeUser ( mysqlnd_connection $connection , string $user , string $password , string $database , bool $silent , int $passwd_len ) : bool

Changes the user of the specified mysqlnd database connection

参数

connection

Mysqlnd connection handle. Do not modify!

user

The MySQL user name.

password

The MySQL password.

database

The MySQL database to change to.

silent

Controls if mysqlnd is allowed to emit errors or not.

passwd_len

Length of the MySQL password.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::changeUser() example

<?php
class proxy extends MysqlndUhConnection {
 /* Hook mysqlnd's connection::change_user call */
 public function changeUser($res, $user, $passwd, $db, $silent, $passwd_len) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::changeUser($res, $user, $passwd, $db, $silent, $passwd_len);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
/* Install proxy/hooks to be used with all future mysqlnd connection */
mysqlnd_uh_set_connection_proxy(new proxy());

/* Create mysqli connection which is using the mysqlnd library */
$mysqli = new mysqli("localhost", "root", "", "test");

/* Example of a user API call which triggers the hooked mysqlnd call */
var_dump($mysqli->change_user("root", "bar", "test"));
?>

以上例程会输出：

proxy::changeUser(array (
  0 => NULL,
  1 => 'root',
  2 => 'bar',
  3 => 'test',
  4 => false,
  5 => 3,
))
proxy::changeUser returns false
bool(false)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_change_user() - Changes the user of the specified database connection


Returns the default character set for the database connection

  • ? MysqlndUhConnection::changeUser
  • MysqlndUhConnection::close ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the default character set for the database connection

MysqlndUhConnection::charsetName

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::charsetName — Returns the default character set for the database connection

说明

public MysqlndUhConnection::charsetName ( mysqlnd_connection $connection ) : string

Returns the default character set for the database connection.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

The default character set.

范例

Example #1 MysqlndUhConnection::charsetName() example

<?php
class proxy extends MysqlndUhConnection {
  public function charsetName($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::charsetName($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump(mysqli_character_set_name($mysqli));
?>

以上例程会输出：

proxy::charsetName(array (
  0 => NULL,
))
proxy::charsetName returns 'latin1'
string(6) "latin1"

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_character_set_name() - 返回当前数据库连接的默认字符编码


Closes a previously opened database connection

  • ? MysqlndUhConnection::charsetName
  • MysqlndUhConnection::connect ?
  • PHP Manual
  • MysqlndUhConnection
  • Closes a previously opened database connection

MysqlndUhConnection::close

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::close — Closes a previously opened database connection

说明

public MysqlndUhConnection::close ( mysqlnd_connection $connection , int $close_type ) : bool

Closes a previously opened database connection.

Note:

Failing to call the parent implementation may cause memory leaks or crash PHP. This is not considered a bug. Please, keep in mind that the mysqlnd library functions have never been designed to be exposed to the user space.

参数

connection

The connection to be closed. Do not modify!

close_type

Why the connection is to be closed. The value of close_type is one of MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT, MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT, MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED or MYSQLND_UH_MYSQLND_CLOSE_LAST. The latter should never be seen, unless the default behaviour of the mysqlnd library has been changed by a plugin.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::close() example

<?php
function close_type_to_string($close_type) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED => "MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED",
  MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT => "MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT",
  MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT => "MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT",
  MYSQLND_UH_MYSQLND_CLOSE_LAST => "MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT"
 );
 return (isset($mapping[$close_type])) ? $mapping[$close_type] : 'unknown';
}

class proxy extends MysqlndUhConnection {
  public function close($res, $close_type) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   printf("close_type = %s\n", close_type_to_string($close_type));
   /* WARNING: you must call the parent */
   $ret = parent::close($res, $close_type);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->close();
?>

以上例程会输出：

proxy::close(array (
  0 => NULL,
  1 => 0,
))
close_type = MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT
proxy::close returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_close() - 关闭先前打开的数据库连接
  • mysql_close() - 关闭 MySQL 连接


Open a new connection to the MySQL server

  • ? MysqlndUhConnection::close
  • MysqlndUhConnection::__construct ?
  • PHP Manual
  • MysqlndUhConnection
  • Open a new connection to the MySQL server

MysqlndUhConnection::connect

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::connect — Open a new connection to the MySQL server

说明

public MysqlndUhConnection::connect ( mysqlnd_connection $connection , string $host , string $use" , string $password , string $database , int $port , string $socket , int $mysql_flags ) : bool

Open a new connection to the MySQL server.

参数

connection

Mysqlnd connection handle. Do not modify!

host

Can be either a host name or an IP address. Passing the NULL value or the string "localhost" to this parameter, the local host is assumed. When possible, pipes will be used instead of the TCP/IP protocol.

user

The MySQL user name.

password

If not provided or null, the MySQL server will attempt to authenticate the user against those user records which have no password only. This allows one username to be used with different permissions (depending on if a password as provided or not).

database

If provided will specify the default database to be used when performing queries.

port

Specifies the port number to attempt to connect to the MySQL server.

socket

Specifies the socket or named pipe that should be used. If null, mysqlnd will default to /tmp/mysql.sock.

mysql_flags

Connection options.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::connect() example

<?php
class proxy extends MysqlndUhConnection {
 public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

以上例程会输出：

proxy::connect(array (
  0 => NULL,
  1 => 'localhost',
  2 => 'root',
  3 => '',
  4 => 'test',
  5 => 3306,
  6 => NULL,
  7 => 131072,
))
proxy::connect returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_connect() - 别名 mysqli::__construct
  • mysql_connect() - 打开一个到 MySQL 服务器的连接


The __construct purpose

  • ? MysqlndUhConnection::connect
  • MysqlndUhConnection::endPSession ?
  • PHP Manual
  • MysqlndUhConnection
  • The __construct purpose

MysqlndUhConnection::__construct

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::__construct — The __construct purpose

说明

public MysqlndUhConnection::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


End a persistent connection

  • ? MysqlndUhConnection::__construct
  • MysqlndUhConnection::escapeString ?
  • PHP Manual
  • MysqlndUhConnection
  • End a persistent connection

MysqlndUhConnection::endPSession

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::endPSession — End a persistent connection

说明

public MysqlndUhConnection::endPSession ( mysqlnd_connection $connection ) : bool

End a persistent connection

Warning

本函数还未编写文档，仅有参数列表。

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::endPSession() example

<?php
class proxy extends MysqlndUhConnection {
 public function endPSession($conn) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::endPSession($conn);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("p:localhost", "root", "", "test");
$mysqli->close();
?>

以上例程会输出：

proxy::endPSession(array (
  0 => NULL,
))
proxy::endPSession returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

  • ? MysqlndUhConnection::endPSession
  • MysqlndUhConnection::getAffectedRows ?
  • PHP Manual
  • MysqlndUhConnection
  • Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

MysqlndUhConnection::escapeString

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::escapeString — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

说明

public MysqlndUhConnection::escapeString ( mysqlnd_connection $connection , string $escape_string ) : string

Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection.

参数

MYSQLND_UH_RES_MYSQLND_NAME

Mysqlnd connection handle. Do not modify!

escape_string

The string to be escaped.

返回值

The escaped string.

范例

Example #1 MysqlndUhConnection::escapeString() example

<?php
class proxy extends MysqlndUhConnection {
 public function escapeString($res, $string) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::escapeString($res, $string);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->set_charset("latin1");
$mysqli->real_escape_string("test0'test");
?>

以上例程会输出：

proxy::escapeString(array (
  0 => NULL,
  1 => 'test0\'test',
))
proxy::escapeString returns 'test0\\\'test'

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_real_escape_string() - 根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义
  • mysql_real_escape_string() - 转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集


Gets the number of affected rows in a previous MySQL operation

  • ? MysqlndUhConnection::escapeString
  • MysqlndUhConnection::getErrorNumber ?
  • PHP Manual
  • MysqlndUhConnection
  • Gets the number of affected rows in a previous MySQL operation

MysqlndUhConnection::getAffectedRows

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getAffectedRows — Gets the number of affected rows in a previous MySQL operation

说明

public MysqlndUhConnection::getAffectedRows ( mysqlnd_connection $connection ) : int

Gets the number of affected rows in a previous MySQL operation.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Number of affected rows.

范例

Example #1 MysqlndUhConnection::getAffectedRows() example

<?php
class proxy extends MysqlndUhConnection {
 public function getAffectedRows($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getAffectedRows($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");
var_dump($mysqli->affected_rows);
?>

以上例程会输出：

proxy::getAffectedRows(array (
  0 => NULL,
))
proxy::getAffectedRows returns 1
int(1)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_affected_rows() - Gets the number of affected rows in a previous MySQL operation
  • mysql_affected_rows() - 取得前一次 MySQL 操作所影响的记录行数


Returns the error code for the most recent function call

  • ? MysqlndUhConnection::getAffectedRows
  • MysqlndUhConnection::getErrorString ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the error code for the most recent function call

MysqlndUhConnection::getErrorNumber

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getErrorNumber — Returns the error code for the most recent function call

说明

public MysqlndUhConnection::getErrorNumber ( mysqlnd_connection $connection ) : int

Returns the error code for the most recent function call.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Error code for the most recent function call.

范例

MysqlndUhConnection::getErrorNumber() is not only executed after the invocation of a user space API call which maps directly to it but also called internally.

Example #1 MysqlndUhConnection::getErrorNumber() example

<?php
class proxy extends MysqlndUhConnection {
 public function getErrorNumber($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getErrorNumber($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

printf("connect...\n");
$mysqli = new mysqli("localhost", "root", "", "test");
printf("query...\n");
$mysqli->query("PLEASE_LET_THIS_BE_INVALID_SQL");
printf("errno...\n");
var_dump($mysqli->errno);
printf("close...\n");
$mysqli->close();
?>

以上例程会输出：

connect...
proxy::getErrorNumber(array (
  0 => NULL,
))
proxy::getErrorNumber returns 0
query...
errno...
proxy::getErrorNumber(array (
  0 => NULL,
))
proxy::getErrorNumber returns 1064
int(1064)
close...

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • MysqlndUhConnection::getErrorString() - Returns a string description of the last error
  • mysqli_errno() - 返回最近函数调用的错误代码
  • mysql_errno() - 返回上一个 MySQL 操作中的错误信息的数字编码


Returns a string description of the last error

  • ? MysqlndUhConnection::getErrorNumber
  • MysqlndUhConnection::getFieldCount ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns a string description of the last error

MysqlndUhConnection::getErrorString

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getErrorString — Returns a string description of the last error

说明

public MysqlndUhConnection::getErrorString ( mysqlnd_connection $connection ) : string

Returns a string description of the last error.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Error string for the most recent function call.

范例

MysqlndUhConnection::getErrorString() is not only executed after the invocation of a user space API call which maps directly to it but also called internally.

Example #1 MysqlndUhConnection::getErrorString() example

<?php
class proxy extends MysqlndUhConnection {
 public function getErrorString($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getErrorString($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

printf("connect...\n");
$mysqli = new mysqli("localhost", "root", "", "test");
printf("query...\n");
$mysqli->query("WILL_I_EVER_LEARN_SQL?");
printf("errno...\n");
var_dump($mysqli->error);
printf("close...\n");
$mysqli->close();
?>

以上例程会输出：

connect...
proxy::getErrorString(array (
  0 => NULL,
))
proxy::getErrorString returns ''
query...
errno...
proxy::getErrorString(array (
  0 => NULL,
))
proxy::getErrorString returns 'You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'WILL_I_EVER_LEARN_SQL?\' at line 1'
string(168) "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WILL_I_EVER_LEARN_SQL?' at line 1"
close...

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • MysqlndUhConnection::getErrorNumber() - Returns the error code for the most recent function call
  • mysqli_error() - Returns a string description of the last error
  • mysql_error() - 返回上一个 MySQL 操作产生的文本错误信息


Returns the number of columns for the most recent query

  • ? MysqlndUhConnection::getErrorString
  • MysqlndUhConnection::getHostInformation ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the number of columns for the most recent query

MysqlndUhConnection::getFieldCount

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getFieldCount — Returns the number of columns for the most recent query

说明

public MysqlndUhConnection::getFieldCount ( mysqlnd_connection $connection ) : int

Returns the number of columns for the most recent query.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Number of columns.

范例

MysqlndUhConnection::getFieldCount() is not only executed after the invocation of a user space API call which maps directly to it but also called internally.

Example #1 MysqlndUhConnection::getFieldCount() example

<?php
class proxy extends MysqlndUhConnection {
 public function getFieldCount($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getFieldCount($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("WILL_I_EVER_LEARN_SQL?");
var_dump($mysqli->field_count);
$mysqli->query("SELECT 1, 2, 3 FROM DUAL");
var_dump($mysqli->field_count);
?>

以上例程会输出：

proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 0
int(0)
proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 3
proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 3
int(3)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_field_count() - Returns the number of columns for the most recent query


Returns a string representing the type of connection used

  • ? MysqlndUhConnection::getFieldCount
  • MysqlndUhConnection::getLastInsertId ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns a string representing the type of connection used

MysqlndUhConnection::getHostInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getHostInformation — Returns a string representing the type of connection used

说明

public MysqlndUhConnection::getHostInformation ( mysqlnd_connection $connection ) : string

Returns a string representing the type of connection used.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Connection description.

范例

Example #1 MysqlndUhConnection::getHostInformation() example

<?php
class proxy extends MysqlndUhConnection {
 public function getHostInformation($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getHostInformation($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->host_info);
?>

以上例程会输出：

proxy::getHostInformation(array (
  0 => NULL,
))
proxy::getHostInformation returns 'Localhost via UNIX socket'
string(25) "Localhost via UNIX socket"

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_host_info() - 返回一个表述使用的连接类型的字符串
  • mysql_get_host_info() - 取得 MySQL 主机信息


Returns the auto generated id used in the last query

  • ? MysqlndUhConnection::getHostInformation
  • MysqlndUhConnection::getLastMessage ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the auto generated id used in the last query

MysqlndUhConnection::getLastInsertId

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getLastInsertId — Returns the auto generated id used in the last query

说明

public MysqlndUhConnection::getLastInsertId ( mysqlnd_connection $connection ) : int

Returns the auto generated id used in the last query.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Last insert id.

范例

Example #1 MysqlndUhConnection::getLastInsertId() example

<?php
class proxy extends MysqlndUhConnection {
 public function getLastInsertId($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getLastInsertId($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT AUTO_INCREMENT PRIMARY KEY, col VARCHAR(255))");
$mysqli->query("INSERT INTO test(col) VALUES ('a')");
var_dump($mysqli->insert_id);
?>

以上例程会输出：

proxy::getLastInsertId(array (
  0 => NULL,
))
proxy::getLastInsertId returns 1
int(1)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_insert_id() - 返回最后一条插入语句产生的自增 ID
  • mysql_insert_id() - 取得上一步 INSERT 操作产生的 ID


Retrieves information about the most recently executed query

  • ? MysqlndUhConnection::getLastInsertId
  • MysqlndUhConnection::getProtocolInformation ?
  • PHP Manual
  • MysqlndUhConnection
  • Retrieves information about the most recently executed query

MysqlndUhConnection::getLastMessage

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getLastMessage — Retrieves information about the most recently executed query

说明

public MysqlndUhConnection::getLastMessage ( mysqlnd_connection $connection ) : void

Retrieves information about the most recently executed query.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Last message. Trying to return a string longer than 511 bytes will cause an error of the type E_WARNING and result in the string being truncated.

范例

Example #1 MysqlndUhConnection::getLastMessage() example

<?php
class proxy extends MysqlndUhConnection {
 public function getLastMessage($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getLastMessage($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->info);
$mysqli->query("DROP TABLE IF EXISTS test");
var_dump($mysqli->info);
?>

以上例程会输出：

proxy::getLastMessage(array (
  0 => NULL,
))
proxy::getLastMessage returns ''
string(0) ""
proxy::getLastMessage(array (
  0 => NULL,
))
proxy::getLastMessage returns ''
string(0) ""

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_info() - 返回最近执行的 SQL 语句的信息
  • mysql_info() - 取得最近一条查询的信息


Returns the version of the MySQL protocol used

  • ? MysqlndUhConnection::getLastMessage
  • MysqlndUhConnection::getServerInformation ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the version of the MySQL protocol used

MysqlndUhConnection::getProtocolInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getProtocolInformation — Returns the version of the MySQL protocol used

说明

public MysqlndUhConnection::getProtocolInformation ( mysqlnd_connection $connection ) : string

Returns the version of the MySQL protocol used.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

The protocol version.

范例

Example #1 MysqlndUhConnection::getProtocolInformation() example

<?php
class proxy extends MysqlndUhConnection {
 public function getProtocolInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getProtocolInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->protocol_version);
?>

以上例程会输出：

proxy::getProtocolInformation(array (
  0 => NULL,
))
proxy::getProtocolInformation returns 10
int(10)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_proto_info() - 返回MySQL使用的协议版本号
  • mysql_get_proto_info() - 取得 MySQL 协议信息


Returns the version of the MySQL server

  • ? MysqlndUhConnection::getProtocolInformation
  • MysqlndUhConnection::getServerStatistics ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the version of the MySQL server

MysqlndUhConnection::getServerInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerInformation — Returns the version of the MySQL server

说明

public MysqlndUhConnection::getServerInformation ( mysqlnd_connection $connection ) : string

Returns the version of the MySQL server.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

The server version.

范例

Example #1 MysqlndUhConnection::getServerInformation() example

<?php
class proxy extends MysqlndUhConnection {
 public function getServerInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->server_info);
?>

以上例程会输出：

proxy::getServerInformation(array (
  0 => NULL,
))
proxy::getServerInformation returns '5.1.45-debug-log'
string(16) "5.1.45-debug-log"

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_server_info() - 返回MySQL服务器的版本号
  • mysql_get_server_info() - 取得 MySQL 服务器信息


Gets the current system status

  • ? MysqlndUhConnection::getServerInformation
  • MysqlndUhConnection::getServerVersion ?
  • PHP Manual
  • MysqlndUhConnection
  • Gets the current system status

MysqlndUhConnection::getServerStatistics

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerStatistics — Gets the current system status

说明

public MysqlndUhConnection::getServerStatistics ( mysqlnd_connection $connection ) : string

Gets the current system status.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

The system status message.

范例

Example #1 MysqlndUhConnection::getServerStatistics() example

<?php
class proxy extends MysqlndUhConnection {
 public function getServerStatistics($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerStatistics($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump(mysqli_stat($mysqli));
?>

以上例程会输出：

proxy::getServerStatistics(array (
  0 => NULL,
))
proxy::getServerStatistics returns 'Uptime: 2059995  Threads: 1  Questions: 126157  Slow queries: 0  Opens: 6377  Flush tables: 1  Open tables: 18  Queries per second avg: 0.61'
string(140) "Uptime: 2059995  Threads: 1  Questions: 126157  Slow queries: 0  Opens: 6377  Flush tables: 1  Open tables: 18  Queries per second avg: 0.61"

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_stat() - 获取当前系统状态信息
  • mysql_stat() - 取得当前系统状态


Returns the version of the MySQL server as an integer

  • ? MysqlndUhConnection::getServerStatistics
  • MysqlndUhConnection::getSqlstate ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the version of the MySQL server as an integer

MysqlndUhConnection::getServerVersion

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerVersion — Returns the version of the MySQL server as an integer

说明

public MysqlndUhConnection::getServerVersion ( mysqlnd_connection $connection ) : int

Returns the version of the MySQL server as an integer.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

The MySQL version.

范例

Example #1 MysqlndUhConnection::getServerVersion() example

<?php
class proxy extends MysqlndUhConnection {
 public function getServerVersion($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerVersion($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->server_version);
?>

以上例程会输出：

proxy::getServerVersion(array (
  0 => NULL,
))
proxy::getServerVersion returns 50145
int(50145)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_server_version() - 作为一个整数返回MySQL服务器的版本
  • mysql_get_server_version()


Returns the SQLSTATE error from previous MySQL operation

  • ? MysqlndUhConnection::getServerVersion
  • MysqlndUhConnection::getStatistics ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the SQLSTATE error from previous MySQL operation

MysqlndUhConnection::getSqlstate

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getSqlstate — Returns the SQLSTATE error from previous MySQL operation

说明

public MysqlndUhConnection::getSqlstate ( mysqlnd_connection $connection ) : string

Returns the SQLSTATE error from previous MySQL operation.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

The SQLSTATE code.

范例

Example #1 MysqlndUhConnection::getSqlstate() example

<?php
class proxy extends MysqlndUhConnection {
 public function getSqlstate($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getSqlstate($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->sqlstate);
$mysqli->query("AN_INVALID_REQUEST_TO_PROVOKE_AN_ERROR");
var_dump($mysqli->sqlstate);
?>

以上例程会输出：

proxy::getSqlstate(array (
  0 => NULL,
))
proxy::getSqlstate returns '00000'
string(5) "00000"
proxy::getSqlstate(array (
  0 => NULL,
))
proxy::getSqlstate returns '42000'
string(5) "42000"

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_sql_state()


Returns statistics about the client connection

  • ? MysqlndUhConnection::getSqlstate
  • MysqlndUhConnection::getThreadId ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns statistics about the client connection

MysqlndUhConnection::getStatistics

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getStatistics — Returns statistics about the client connection

说明

public MysqlndUhConnection::getStatistics ( mysqlnd_connection $connection ) : array

Returns statistics about the client connection.

Warning

本函数还未编写文档，仅有参数列表。

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Connection statistics collected by mysqlnd.

范例

Example #1 MysqlndUhConnection::getStatistics() example

<?php
class proxy extends MysqlndUhConnection {
 public function getStatistics($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getStatistics($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->get_connection_stats());
?>

以上例程会输出：

proxy::getStatistics(array (
  0 => NULL,
))
proxy::getStatistics returns array (
  'bytes_sent' => '73',
  'bytes_received' => '77',
  'packets_sent' => '2',
  'packets_received' => '2',
  'protocol_overhead_in' => '8',
  'protocol_overhead_out' => '8',
  'bytes_received_ok_packet' => '0',
  'bytes_received_eof_packet' => '0',
  'bytes_received_rset_header_packet' => '0',
  'bytes_received_rset_field_meta_packet' => '0',
  'bytes_received_rset_row_packet' => '0',
  'bytes_received_prepare_response_packet' => '0',
  'bytes_received_change_user_packet' => '0',
  'packets_sent_command' => '0',
  'packets_received_ok' => '0',
  'packets_received_eof' => '0',
  'packets_received_rset_header' => '0',
  'packets_received_rset_field_meta' => '0',
  'packets_received_rset_row' => '0',
  'packets_received_prepare_response' => '0',
  'packets_received_change_user' => '0',
  'result_set_queries' => '0',
  'non_result_set_queries' => '0',
  'no_index_used' => '0',
  'bad_index_used' => '0',
  'slow_queries' => '0',
  'buffered_sets' => '0',
  'unbuffered_sets' => '0',
  'ps_buffered_sets' => '0',
  'ps_unbuffered_sets' => '0',
  'flushed_normal_sets' => '0',
  'flushed_ps_sets' => '0',
  'ps_prepared_never_executed' => '0',
  'ps_prepared_once_executed' => '0',
  'rows_fetched_from_server_normal' => '0',
  'rows_fetched_from_server_ps' => '0',
  'rows_buffered_from_client_normal' => '0',
  'rows_buffered_from_client_ps' => '0',
  'rows_fetched_from_client_normal_buffered' => '0',
  'rows_fetched_from_client_normal_unbuffered' => '0',
  'rows_fetched_from_client_ps_buffered' => '0',
  'rows_fetched_from_client_ps_unbuffered' => '0',
  'rows_fetched_from_client_ps_cursor' => '0',
  'rows_affected_normal' => '0',
  'rows_affected_ps' => '0',
  'rows_skipped_normal' => '0',
  'rows_skipped_ps' => '0',
  'copy_on_write_saved' => '0',
  'copy_on_write_performed' => '0',
  'command_buffer_too_small' => '0',
  'connect_success' => '1',
  'connect_failure' => '0',
  'connection_reused' => '0',
  'reconnect' => '0',
  'pconnect_success' => '0',
  'active_connections' => '1',
  'active_persistent_connections' => '0',
  'explicit_close' => '0',
  'implicit_close' => '0',
  'disconnect_close' => '0',
  'in_middle_of_command_close' => '0',
  'explicit_free_result' => '0',
  'implicit_free_result' => '0',
  'explicit_stmt_close' => '0',
  'implicit_stmt_close' => '0',
  'mem_emalloc_count' => '0',
  'mem_emalloc_amount' => '0',
  'mem_ecalloc_count' => '0',
  'mem_ecalloc_amount' => '0',
  'mem_erealloc_count' => '0',
  'mem_erealloc_amount' => '0',
  'mem_efree_count' => '0',
  'mem_efree_amount' => '0',
  'mem_malloc_count' => '0',
  'mem_malloc_amount' => '0',
  'mem_calloc_count' => '0',
  'mem_calloc_amount' => '0',
  'mem_realloc_count' => '0',
  'mem_realloc_amount' => '0',
  'mem_free_count' => '0',
  'mem_free_amount' => '0',
  'mem_estrndup_count' => '0',
  'mem_strndup_count' => '0',
  'mem_estndup_count' => '0',
  'mem_strdup_count' => '0',
  'proto_text_fetched_null' => '0',
  'proto_text_fetched_bit' => '0',
  'proto_text_fetched_tinyint' => '0',
  'proto_text_fetched_short' => '0',
  'proto_text_fetched_int24' => '0',
  'proto_text_fetched_int' => '0',
  'proto_text_fetched_bigint' => '0',
  'proto_text_fetched_decimal' => '0',
  'proto_text_fetched_float' => '0',
  'proto_text_fetched_double' => '0',
  'proto_text_fetched_date' => '0',
  'proto_text_fetched_year' => '0',
  'proto_text_fetched_time' => '0',
  'proto_text_fetched_datetime' => '0',
  'proto_text_fetched_timestamp' => '0',
  'proto_text_fetched_string' => '0',
  'proto_text_fetched_blob' => '0',
  'proto_text_fetched_enum' => '0',
  'proto_text_fetched_set' => '0',
  'proto_text_fetched_geometry' => '0',
  'proto_text_fetched_other' => '0',
  'proto_binary_fetched_null' => '0',
  'proto_binary_fetched_bit' => '0',
  'proto_binary_fetched_tinyint' => '0',
  'proto_binary_fetched_short' => '0',
  'proto_binary_fetched_int24' => '0',
  'proto_binary_fetched_int' => '0',
  'proto_binary_fetched_bigint' => '0',
  'proto_binary_fetched_decimal' => '0',
  'proto_binary_fetched_float' => '0',
  'proto_binary_fetched_double' => '0',
  'proto_binary_fetched_date' => '0',
  'proto_binary_fetched_year' => '0',
  'proto_binary_fetched_time' => '0',
  'proto_binary_fetched_datetime' => '0',
  'proto_binary_fetched_timestamp' => '0',
  'proto_binary_fetched_string' => '0',
  'proto_binary_fetched_blob' => '0',
  'proto_binary_fetched_enum' => '0',
  'proto_binary_fetched_set' => '0',
  'proto_binary_fetched_geometry' => '0',
  'proto_binary_fetched_other' => '0',
  'init_command_executed_count' => '0',
  'init_command_failed_count' => '0',
  'com_quit' => '0',
  'com_init_db' => '0',
  'com_query' => '0',
  'com_field_list' => '0',
  'com_create_db' => '0',
  'com_drop_db' => '0',
  'com_refresh' => '0',
  'com_shutdown' => '0',
  'com_statistics' => '0',
  'com_process_info' => '0',
  'com_connect' => '0',
  'com_process_kill' => '0',
  'com_debug' => '0',
  'com_ping' => '0',
  'com_time' => '0',
  'com_delayed_insert' => '0',
  'com_change_user' => '0',
  'com_binlog_dump' => '0',
  'com_table_dump' => '0',
  'com_connect_out' => '0',
  'com_register_slave' => '0',
  'com_stmt_prepare' => '0',
  'com_stmt_execute' => '0',
  'com_stmt_send_long_data' => '0',
  'com_stmt_close' => '0',
  'com_stmt_reset' => '0',
  'com_stmt_set_option' => '0',
  'com_stmt_fetch' => '0',
  'com_deamon' => '0',
  'bytes_received_real_data_normal' => '0',
  'bytes_received_real_data_ps' => '0',
)
array(160) {
  ["bytes_sent"]=>
  string(2) "73"
  ["bytes_received"]=>
  string(2) "77"
  ["packets_sent"]=>
  string(1) "2"
  ["packets_received"]=>
  string(1) "2"
  ["protocol_overhead_in"]=>
  string(1) "8"
  ["protocol_overhead_out"]=>
  string(1) "8"
  ["bytes_received_ok_packet"]=>
  string(1) "0"
  ["bytes_received_eof_packet"]=>
  string(1) "0"
  ["bytes_received_rset_header_packet"]=>
  string(1) "0"
  ["bytes_received_rset_field_meta_packet"]=>
  string(1) "0"
  ["bytes_received_rset_row_packet"]=>
  string(1) "0"
  ["bytes_received_prepare_response_packet"]=>
  string(1) "0"
  ["bytes_received_change_user_packet"]=>
  string(1) "0"
  ["packets_sent_command"]=>
  string(1) "0"
  ["packets_received_ok"]=>
  string(1) "0"
  ["packets_received_eof"]=>
  string(1) "0"
  ["packets_received_rset_header"]=>
  string(1) "0"
  ["packets_received_rset_field_meta"]=>
  string(1) "0"
  ["packets_received_rset_row"]=>
  string(1) "0"
  ["packets_received_prepare_response"]=>
  string(1) "0"
  ["packets_received_change_user"]=>
  string(1) "0"
  ["result_set_queries"]=>
  string(1) "0"
  ["non_result_set_queries"]=>
  string(1) "0"
  ["no_index_used"]=>
  string(1) "0"
  ["bad_index_used"]=>
  string(1) "0"
  ["slow_queries"]=>
  string(1) "0"
  ["buffered_sets"]=>
  string(1) "0"
  ["unbuffered_sets"]=>
  string(1) "0"
  ["ps_buffered_sets"]=>
  string(1) "0"
  ["ps_unbuffered_sets"]=>
  string(1) "0"
  ["flushed_normal_sets"]=>
  string(1) "0"
  ["flushed_ps_sets"]=>
  string(1) "0"
  ["ps_prepared_never_executed"]=>
  string(1) "0"
  ["ps_prepared_once_executed"]=>
  string(1) "0"
  ["rows_fetched_from_server_normal"]=>
  string(1) "0"
  ["rows_fetched_from_server_ps"]=>
  string(1) "0"
  ["rows_buffered_from_client_normal"]=>
  string(1) "0"
  ["rows_buffered_from_client_ps"]=>
  string(1) "0"
  ["rows_fetched_from_client_normal_buffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_normal_unbuffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_buffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_unbuffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_cursor"]=>
  string(1) "0"
  ["rows_affected_normal"]=>
  string(1) "0"
  ["rows_affected_ps"]=>
  string(1) "0"
  ["rows_skipped_normal"]=>
  string(1) "0"
  ["rows_skipped_ps"]=>
  string(1) "0"
  ["copy_on_write_saved"]=>
  string(1) "0"
  ["copy_on_write_performed"]=>
  string(1) "0"
  ["command_buffer_too_small"]=>
  string(1) "0"
  ["connect_success"]=>
  string(1) "1"
  ["connect_failure"]=>
  string(1) "0"
  ["connection_reused"]=>
  string(1) "0"
  ["reconnect"]=>
  string(1) "0"
  ["pconnect_success"]=>
  string(1) "0"
  ["active_connections"]=>
  string(1) "1"
  ["active_persistent_connections"]=>
  string(1) "0"
  ["explicit_close"]=>
  string(1) "0"
  ["implicit_close"]=>
  string(1) "0"
  ["disconnect_close"]=>
  string(1) "0"
  ["in_middle_of_command_close"]=>
  string(1) "0"
  ["explicit_free_result"]=>
  string(1) "0"
  ["implicit_free_result"]=>
  string(1) "0"
  ["explicit_stmt_close"]=>
  string(1) "0"
  ["implicit_stmt_close"]=>
  string(1) "0"
  ["mem_emalloc_count"]=>
  string(1) "0"
  ["mem_emalloc_amount"]=>
  string(1) "0"
  ["mem_ecalloc_count"]=>
  string(1) "0"
  ["mem_ecalloc_amount"]=>
  string(1) "0"
  ["mem_erealloc_count"]=>
  string(1) "0"
  ["mem_erealloc_amount"]=>
  string(1) "0"
  ["mem_efree_count"]=>
  string(1) "0"
  ["mem_efree_amount"]=>
  string(1) "0"
  ["mem_malloc_count"]=>
  string(1) "0"
  ["mem_malloc_amount"]=>
  string(1) "0"
  ["mem_calloc_count"]=>
  string(1) "0"
  ["mem_calloc_amount"]=>
  string(1) "0"
  ["mem_realloc_count"]=>
  string(1) "0"
  ["mem_realloc_amount"]=>
  string(1) "0"
  ["mem_free_count"]=>
  string(1) "0"
  ["mem_free_amount"]=>
  string(1) "0"
  ["mem_estrndup_count"]=>
  string(1) "0"
  ["mem_strndup_count"]=>
  string(1) "0"
  ["mem_estndup_count"]=>
  string(1) "0"
  ["mem_strdup_count"]=>
  string(1) "0"
  ["proto_text_fetched_null"]=>
  string(1) "0"
  ["proto_text_fetched_bit"]=>
  string(1) "0"
  ["proto_text_fetched_tinyint"]=>
  string(1) "0"
  ["proto_text_fetched_short"]=>
  string(1) "0"
  ["proto_text_fetched_int24"]=>
  string(1) "0"
  ["proto_text_fetched_int"]=>
  string(1) "0"
  ["proto_text_fetched_bigint"]=>
  string(1) "0"
  ["proto_text_fetched_decimal"]=>
  string(1) "0"
  ["proto_text_fetched_float"]=>
  string(1) "0"
  ["proto_text_fetched_double"]=>
  string(1) "0"
  ["proto_text_fetched_date"]=>
  string(1) "0"
  ["proto_text_fetched_year"]=>
  string(1) "0"
  ["proto_text_fetched_time"]=>
  string(1) "0"
  ["proto_text_fetched_datetime"]=>
  string(1) "0"
  ["proto_text_fetched_timestamp"]=>
  string(1) "0"
  ["proto_text_fetched_string"]=>
  string(1) "0"
  ["proto_text_fetched_blob"]=>
  string(1) "0"
  ["proto_text_fetched_enum"]=>
  string(1) "0"
  ["proto_text_fetched_set"]=>
  string(1) "0"
  ["proto_text_fetched_geometry"]=>
  string(1) "0"
  ["proto_text_fetched_other"]=>
  string(1) "0"
  ["proto_binary_fetched_null"]=>
  string(1) "0"
  ["proto_binary_fetched_bit"]=>
  string(1) "0"
  ["proto_binary_fetched_tinyint"]=>
  string(1) "0"
  ["proto_binary_fetched_short"]=>
  string(1) "0"
  ["proto_binary_fetched_int24"]=>
  string(1) "0"
  ["proto_binary_fetched_int"]=>
  string(1) "0"
  ["proto_binary_fetched_bigint"]=>
  string(1) "0"
  ["proto_binary_fetched_decimal"]=>
  string(1) "0"
  ["proto_binary_fetched_float"]=>
  string(1) "0"
  ["proto_binary_fetched_double"]=>
  string(1) "0"
  ["proto_binary_fetched_date"]=>
  string(1) "0"
  ["proto_binary_fetched_year"]=>
  string(1) "0"
  ["proto_binary_fetched_time"]=>
  string(1) "0"
  ["proto_binary_fetched_datetime"]=>
  string(1) "0"
  ["proto_binary_fetched_timestamp"]=>
  string(1) "0"
  ["proto_binary_fetched_string"]=>
  string(1) "0"
  ["proto_binary_fetched_blob"]=>
  string(1) "0"
  ["proto_binary_fetched_enum"]=>
  string(1) "0"
  ["proto_binary_fetched_set"]=>
  string(1) "0"
  ["proto_binary_fetched_geometry"]=>
  string(1) "0"
  ["proto_binary_fetched_other"]=>
  string(1) "0"
  ["init_command_executed_count"]=>
  string(1) "0"
  ["init_command_failed_count"]=>
  string(1) "0"
  ["com_quit"]=>
  string(1) "0"
  ["com_init_db"]=>
  string(1) "0"
  ["com_query"]=>
  string(1) "0"
  ["com_field_list"]=>
  string(1) "0"
  ["com_create_db"]=>
  string(1) "0"
  ["com_drop_db"]=>
  string(1) "0"
  ["com_refresh"]=>
  string(1) "0"
  ["com_shutdown"]=>
  string(1) "0"
  ["com_statistics"]=>
  string(1) "0"
  ["com_process_info"]=>
  string(1) "0"
  ["com_connect"]=>
  string(1) "0"
  ["com_process_kill"]=>
  string(1) "0"
  ["com_debug"]=>
  string(1) "0"
  ["com_ping"]=>
  string(1) "0"
  ["com_time"]=>
  string(1) "0"
  ["com_delayed_insert"]=>
  string(1) "0"
  ["com_change_user"]=>
  string(1) "0"
  ["com_binlog_dump"]=>
  string(1) "0"
  ["com_table_dump"]=>
  string(1) "0"
  ["com_connect_out"]=>
  string(1) "0"
  ["com_register_slave"]=>
  string(1) "0"
  ["com_stmt_prepare"]=>
  string(1) "0"
  ["com_stmt_execute"]=>
  string(1) "0"
  ["com_stmt_send_long_data"]=>
  string(1) "0"
  ["com_stmt_close"]=>
  string(1) "0"
  ["com_stmt_reset"]=>
  string(1) "0"
  ["com_stmt_set_option"]=>
  string(1) "0"
  ["com_stmt_fetch"]=>
  string(1) "0"
  ["com_deamon"]=>
  string(1) "0"
  ["bytes_received_real_data_normal"]=>
  string(1) "0"
  ["bytes_received_real_data_ps"]=>
  string(1) "0"
}

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_connection_stats() - 返回客户端连接的统计数据


Returns the thread ID for the current connection

  • ? MysqlndUhConnection::getStatistics
  • MysqlndUhConnection::getWarningCount ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the thread ID for the current connection

MysqlndUhConnection::getThreadId

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getThreadId — Returns the thread ID for the current connection

说明

public MysqlndUhConnection::getThreadId ( mysqlnd_connection $connection ) : int

Returns the thread ID for the current connection.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Connection thread id.

范例

Example #1 MysqlndUhConnection::getThreadId() example

<?php
class proxy extends MysqlndUhConnection {
 public function getThreadId($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getThreadId($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->thread_id);
?>

以上例程会输出：

proxy::getThreadId(array (
  0 => NULL,
))
proxy::getThreadId returns 27646
int(27646)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_thread_id() - 返回当前连接的线程 ID
  • mysql_thread_id() - 返回当前线程的 ID


Returns the number of warnings from the last query for the given link

  • ? MysqlndUhConnection::getThreadId
  • MysqlndUhConnection::init ?
  • PHP Manual
  • MysqlndUhConnection
  • Returns the number of warnings from the last query for the given link

MysqlndUhConnection::getWarningCount

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getWarningCount — Returns the number of warnings from the last query for the given link

说明

public MysqlndUhConnection::getWarningCount ( mysqlnd_connection $connection ) : int

Returns the number of warnings from the last query for the given link.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Number of warnings.

范例

Example #1 MysqlndUhConnection::getWarningCount() example

<?php
class proxy extends MysqlndUhConnection {
 public function getWarningCount($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getWarningCount($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->warning_count);
?>

以上例程会输出：

proxy::getWarningCount(array (
  0 => NULL,
))
proxy::getWarningCount returns 0
int(0)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_warning_count() - Returns the number of warnings from the last query for the given link


Initialize mysqlnd connection

  • ? MysqlndUhConnection::getWarningCount
  • MysqlndUhConnection::killConnection ?
  • PHP Manual
  • MysqlndUhConnection
  • Initialize mysqlnd connection

MysqlndUhConnection::init

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::init — Initialize mysqlnd connection

说明

public MysqlndUhConnection::init ( mysqlnd_connection $connection ) : bool

Initialize mysqlnd connection. This is an mysqlnd internal call to initialize the connection object.

Note:

Failing to call the parent implementation may cause memory leaks or crash PHP. This is not considered a bug. Please, keep in mind that the mysqlnd library functions have never been designed to be exposed to the user space.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::init() example

<?php
class proxy extends MysqlndUhConnection {
 public function init($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::init($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

以上例程会输出：

proxy::init(array (
  0 => NULL,
))
proxy::init returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Asks the server to kill a MySQL thread

  • ? MysqlndUhConnection::init
  • MysqlndUhConnection::listFields ?
  • PHP Manual
  • MysqlndUhConnection
  • Asks the server to kill a MySQL thread

MysqlndUhConnection::killConnection

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::killConnection — Asks the server to kill a MySQL thread

说明

public MysqlndUhConnection::killConnection ( mysqlnd_connection $connection , int $pid ) : bool

Asks the server to kill a MySQL thread.

参数

connection

Mysqlnd connection handle. Do not modify!

pid

Thread Id of the connection to be killed.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::kill() example

<?php
class proxy extends MysqlndUhConnection {
 public function killConnection($res, $pid) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::killConnection($res, $pid);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->kill($mysqli->thread_id);
?>

以上例程会输出：

proxy::killConnection(array (
  0 => NULL,
  1 => 27650,
))
proxy::killConnection returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_kill() - 让服务器杀掉一个 MySQL 线程


List MySQL table fields

  • ? MysqlndUhConnection::killConnection
  • MysqlndUhConnection::listMethod ?
  • PHP Manual
  • MysqlndUhConnection
  • List MySQL table fields

MysqlndUhConnection::listFields

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::listFields — List MySQL table fields

说明

public MysqlndUhConnection::listFields ( mysqlnd_connection $connection , string $table , string $achtung_wild ) : array

List MySQL table fields.

Warning

本函数还未编写文档，仅有参数列表。

参数

connection

Mysqlnd connection handle. Do not modify!

table

The name of the table that's being queried.

pattern

Name pattern.

返回值

范例

Example #1 MysqlndUhConnection::listFields() example

<?php
class proxy extends MysqlndUhConnection {
 public function listFields($res, $table, $pattern) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::listFields($res, $table, $pattern);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysql = mysql_connect("localhost", "root", "");
mysql_select_db("test", $mysql);
mysql_query("DROP TABLE IF EXISTS test_a", $mysql);
mysql_query("CREATE TABLE test_a(id INT, col1 VARCHAR(255))", $mysql);
$res = mysql_list_fields("test", "test_a", $mysql);
printf("num_rows = %d\n", mysql_num_rows($res));
while ($row = mysql_fetch_assoc($res))
 var_dump($row);
?>

以上例程会输出：

proxy::listFields(array (
  0 => NULL,
  1 => 'test_a',
  2 => '',
))
proxy::listFields returns NULL
num_rows = 0

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysql_list_fields() - 列出 MySQL 结果中的字段


Wrapper for assorted list commands

  • ? MysqlndUhConnection::listFields
  • MysqlndUhConnection::moreResults ?
  • PHP Manual
  • MysqlndUhConnection
  • Wrapper for assorted list commands

MysqlndUhConnection::listMethod

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::listMethod — Wrapper for assorted list commands

说明

public MysqlndUhConnection::listMethod ( mysqlnd_connection $connection , string $query , string $achtung_wild , string $par1 ) : void

Wrapper for assorted list commands.

Warning

本函数还未编写文档，仅有参数列表。

参数

connection

Mysqlnd connection handle. Do not modify!

query

SHOW command to be executed.

achtung_wild

par1

返回值

返回值

TODO

范例

Example #1 MysqlndUhConnection::listMethod() example

<?php
class proxy extends MysqlndUhConnection {
 public function listMethod($res, $query, $pattern, $par1) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::listMethod($res, $query, $pattern, $par1);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysql = mysql_connect("localhost", "root", "");
$res = mysql_list_dbs($mysql);
printf("num_rows = %d\n", mysql_num_rows($res));
while ($row = mysql_fetch_assoc($res))
 var_dump($row);
?>

以上例程会输出：

proxy::listMethod(array (
  0 => NULL,
  1 => 'SHOW DATABASES',
  2 => '',
  3 => '',
))
proxy::listMethod returns NULL
num_rows = 6
array(1) {
  ["Database"]=>
  string(18) "information_schema"
}
array(1) {
  ["Database"]=>
  string(5) "mysql"
}
array(1) {
  ["Database"]=>
  string(8) "oxid_new"
}
array(1) {
  ["Database"]=>
  string(7) "phptest"
}
array(1) {
  ["Database"]=>
  string(7) "pushphp"
}
array(1) {
  ["Database"]=>
  string(4) "test"
}

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysql_list_dbs() - 列出 MySQL 服务器中所有的数据库


Check if there are any more query results from a multi query

  • ? MysqlndUhConnection::listMethod
  • MysqlndUhConnection::nextResult ?
  • PHP Manual
  • MysqlndUhConnection
  • Check if there are any more query results from a multi query

MysqlndUhConnection::moreResults

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::moreResults — Check if there are any more query results from a multi query

说明

public MysqlndUhConnection::moreResults ( mysqlnd_connection $connection ) : bool

Check if there are any more query results from a multi query.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::moreResults() example

<?php
class proxy extends MysqlndUhConnection {
 public function moreResults($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::moreResults($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1 AS _one; SELECT 2 AS _two");
do {
  $res = $mysqli->store_result();
  var_dump($res->fetch_assoc());
  printf("%s\n", str_repeat("-", 40));
} while ($mysqli->more_results() && $mysqli->next_result());
?>

以上例程会输出：

array(1) {
  ["_one"]=>
  string(1) "1"
}
----------------------------------------
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns true
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns true
array(1) {
  ["_two"]=>
  string(1) "2"
}
----------------------------------------
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns false

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_more_results() - 检查批量查询中是否还有查询结果


Prepare next result from multi_query

  • ? MysqlndUhConnection::moreResults
  • MysqlndUhConnection::ping ?
  • PHP Manual
  • MysqlndUhConnection
  • Prepare next result from multi_query

MysqlndUhConnection::nextResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::nextResult — Prepare next result from multi_query

说明

public MysqlndUhConnection::nextResult ( mysqlnd_connection $connection ) : bool

Prepare next result from multi_query.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::nextResult() example

<?php
class proxy extends MysqlndUhConnection {
 public function nextResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::nextResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1 AS _one; SELECT 2 AS _two");
do {
  $res = $mysqli->store_result();
  var_dump($res->fetch_assoc());
  printf("%s\n", str_repeat("-", 40));
} while ($mysqli->more_results() && $mysqli->next_result());
?>

以上例程会输出：

array(1) {
  ["_one"]=>
  string(1) "1"
}
----------------------------------------
proxy::nextResult(array (
  0 => NULL,
))
proxy::nextResult returns true
array(1) {
  ["_two"]=>
  string(1) "2"
}
----------------------------------------

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_next_result() - 为读取 multi_query 执行之后的下一个结果集做准备


Pings a server connection, or tries to reconnect if the connection has gone down

  • ? MysqlndUhConnection::nextResult
  • MysqlndUhConnection::query ?
  • PHP Manual
  • MysqlndUhConnection
  • Pings a server connection, or tries to reconnect if the connection has gone down

MysqlndUhConnection::ping

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::ping — Pings a server connection, or tries to reconnect if the connection has gone down

说明

public MysqlndUhConnection::ping ( mysqlnd_connection $connection ) : bool

Pings a server connection, or tries to reconnect if the connection has gone down.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::ping() example

<?php
class proxy extends MysqlndUhConnection {
 public function ping($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::ping($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ping();
?>

以上例程会输出：

proxy::ping(array (
  0 => NULL,
))
proxy::ping returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_ping() - ping 一个连接，或者如果连接处于断开状态，重新连接
  • mysql_ping() - Ping 一个服务器连接，如果没有连接则重新连接


Performs a query on the database

  • ? MysqlndUhConnection::ping
  • MysqlndUhConnection::queryReadResultsetHeader ?
  • PHP Manual
  • MysqlndUhConnection
  • Performs a query on the database

MysqlndUhConnection::query

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::query — Performs a query on the database

说明

public MysqlndUhConnection::query ( mysqlnd_connection $connection , string $query ) : bool

Performs a query on the database (COM_QUERY).

参数

connection

Mysqlnd connection handle. Do not modify!

query

The query string.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::query() example

<?php
class proxy extends MysqlndUhConnection {
 public function query($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $query = "SELECT 'How about query rewriting?'";
  $ret = parent::query($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Welcome mysqlnd_uh!' FROM DUAL");
var_dump($res->fetch_assoc());
?>

以上例程会输出：

proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Welcome mysqlnd_uh!\' FROM DUAL',
))
proxy::query returns true
array(1) {
  ["How about query rewriting?"]=>
  string(26) "How about query rewriting?"
}

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_query() - 对数据库执行一次查询
  • mysql_query() - 发送一条 MySQL 查询


Read a result set header

  • ? MysqlndUhConnection::query
  • MysqlndUhConnection::reapQuery ?
  • PHP Manual
  • MysqlndUhConnection
  • Read a result set header

MysqlndUhConnection::queryReadResultsetHeader

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::queryReadResultsetHeader — Read a result set header

说明

public MysqlndUhConnection::queryReadResultsetHeader ( mysqlnd_connection $connection , mysqlnd_statement $mysqlnd_stmt ) : bool

Read a result set header.

参数

connection

Mysqlnd connection handle. Do not modify!

mysqlnd_stmt

Mysqlnd statement handle. Do not modify! Set to null, if function is not used in the context of a prepared statement.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::queryReadResultsetHeader() example

<?php
class proxy extends MysqlndUhConnection {
 public function queryReadResultsetHeader($res, $stmt) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::queryReadResultsetHeader($res, $stmt);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Welcome mysqlnd_uh!' FROM DUAL");
var_dump($res->fetch_assoc());
?>

以上例程会输出：

proxy::queryReadResultsetHeader(array (
  0 => NULL,
  1 => NULL,
))
proxy::queryReadResultsetHeader returns true
array(1) {
  ["Welcome mysqlnd_uh!"]=>
  string(19) "Welcome mysqlnd_uh!"
}

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Get result from async query

  • ? MysqlndUhConnection::queryReadResultsetHeader
  • MysqlndUhConnection::refreshServer ?
  • PHP Manual
  • MysqlndUhConnection
  • Get result from async query

MysqlndUhConnection::reapQuery

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::reapQuery — Get result from async query

说明

public MysqlndUhConnection::reapQuery ( mysqlnd_connection $connection ) : bool

Get result from async query.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::reapQuery() example

<?php
class proxy extends MysqlndUhConnection {
 public function reapQuery($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::reapQuery($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$conn1 = new mysqli("localhost", "root", "", "test");
$conn2 = new mysqli("localhost", "root", "", "test");

$conn1->query("SELECT 1 as 'one', SLEEP(1) AS _sleep FROM DUAL", MYSQLI_ASYNC |  MYSQLI_USE_RESULT);
$conn2->query("SELECT 1.1 as 'one dot one' FROM DUAL", MYSQLI_ASYNC |  MYSQLI_USE_RESULT);

$links = array(
 $conn1->thread_id => array('link' => $conn1, 'processed' => false),
 $conn2->thread_id => array('link' => $conn2, 'processed' => false)
);

$saved_errors = array();
do {
 $poll_links = $poll_errors = $poll_reject = array();
 foreach ($links as $thread_id => $link) {
  if (!$link['processed']) {
   $poll_links[] = $link['link'];
   $poll_errors[] = $link['link'];
   $poll_reject[] = $link['link'];
  }
 }
 if (0 == count($poll_links))
  break;

 if (0 == ($num_ready = mysqli_poll($poll_links, $poll_errors, $poll_reject, 0, 200000)))
  continue;

 if (!empty($poll_errors)) {
  die(var_dump($poll_errors));
 }

 foreach ($poll_links as $link) {
  $thread_id = mysqli_thread_id($link);
  $links[$thread_id]['processed'] = true;

  if (is_object($res = mysqli_reap_async_query($link))) {
   // result set object
   while ($row = mysqli_fetch_assoc($res)) {
    // eat up all results
    var_dump($row);
   }
   mysqli_free_result($res);
  } else {
   // either there is no result (no SELECT) or there is an error
   if (mysqli_errno($link) > 0) {
    $saved_errors[$thread_id] = mysqli_errno($link);
    printf("'%s' caused %d\n", $links[$thread_id]['query'],     mysqli_errno($link));
   }
  }
 }
} while (true);
?>

以上例程会输出：

proxy::reapQuery(array (
  0 => NULL,
))
proxy::reapQuery returns true
array(1) {
  ["one dot one"]=>
  string(3) "1.1"
}
proxy::reapQuery(array (
  0 => NULL,
))
proxy::reapQuery returns true
array(2) {
  ["one"]=>
  string(1) "1"
  ["_sleep"]=>
  string(1) "0"
}

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_real_async_query()


Flush or reset tables and caches

  • ? MysqlndUhConnection::reapQuery
  • MysqlndUhConnection::restartPSession ?
  • PHP Manual
  • MysqlndUhConnection
  • Flush or reset tables and caches

MysqlndUhConnection::refreshServer

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::refreshServer — Flush or reset tables and caches

说明

public MysqlndUhConnection::refreshServer ( mysqlnd_connection $connection , int $options ) : bool

Flush or reset tables and caches.

Warning

本函数还未编写文档，仅有参数列表。

参数

connection

Mysqlnd connection handle. Do not modify!

options

What to refresh.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::refreshServer() example

<?php
class proxy extends MysqlndUhConnection {
 public function refreshServer($res, $option) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::refreshServer($res, $option);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
mysqli_refresh($mysqli, 1);
?>

以上例程会输出：

proxy::refreshServer(array (
  0 => NULL,
  1 => 1,
))
proxy::refreshServer returns false

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Restart a persistent mysqlnd connection

  • ? MysqlndUhConnection::refreshServer
  • MysqlndUhConnection::selectDb ?
  • PHP Manual
  • MysqlndUhConnection
  • Restart a persistent mysqlnd connection

MysqlndUhConnection::restartPSession

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::restartPSession — Restart a persistent mysqlnd connection

说明

public MysqlndUhConnection::restartPSession ( mysqlnd_connection $connection ) : bool

Restart a persistent mysqlnd connection.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::restartPSession() example

<?php
class proxy extends MysqlndUhConnection {
 public function ping($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::ping($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ping();
?>

以上例程会输出：

proxy::restartPSession(array (
  0 => NULL,
))
proxy::restartPSession returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Selects the default database for database queries

  • ? MysqlndUhConnection::restartPSession
  • MysqlndUhConnection::sendClose ?
  • PHP Manual
  • MysqlndUhConnection
  • Selects the default database for database queries

MysqlndUhConnection::selectDb

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::selectDb — Selects the default database for database queries

说明

public MysqlndUhConnection::selectDb ( mysqlnd_connection $connection , string $database ) : bool

Selects the default database for database queries.

参数

connection

Mysqlnd connection handle. Do not modify!

database

The database name.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::selectDb() example

<?php
class proxy extends MysqlndUhConnection {
 public function selectDb($res, $database) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::selectDb($res, $database);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->select_db("mysql");
?>

以上例程会输出：

proxy::selectDb(array (
  0 => NULL,
  1 => 'mysql',
))
proxy::selectDb returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_select_db() - 选择用于数据库查询的默认数据库
  • mysql_select_db() - 选择 MySQL 数据库


Sends a close command to MySQL

  • ? MysqlndUhConnection::selectDb
  • MysqlndUhConnection::sendQuery ?
  • PHP Manual
  • MysqlndUhConnection
  • Sends a close command to MySQL

MysqlndUhConnection::sendClose

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sendClose — Sends a close command to MySQL

说明

public MysqlndUhConnection::sendClose ( mysqlnd_connection $connection ) : bool

Sends a close command to MySQL.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::sendClose() example

<?php
class proxy extends MysqlndUhConnection {
 public function sendClose($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sendClose($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->close();
?>

以上例程会输出：

proxy::sendClose(array (
  0 => NULL,
))
proxy::sendClose returns true
proxy::sendClose(array (
  0 => NULL,
))
proxy::sendClose returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Sends a query to MySQL

  • ? MysqlndUhConnection::sendClose
  • MysqlndUhConnection::serverDumpDebugInformation ?
  • PHP Manual
  • MysqlndUhConnection
  • Sends a query to MySQL

MysqlndUhConnection::sendQuery

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sendQuery — Sends a query to MySQL

说明

public MysqlndUhConnection::sendQuery ( mysqlnd_connection $connection , string $query ) : bool

Sends a query to MySQL.

参数

connection

Mysqlnd connection handle. Do not modify!

query

The query string.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::sendQuery() example

<?php
class proxy extends MysqlndUhConnection {
 public function sendQuery($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sendQuery($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 1");
?>

以上例程会输出：

proxy::sendQuery(array (
  0 => NULL,
  1 => 'SELECT 1',
))
proxy::sendQuery returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Dump debugging information into the log for the MySQL server

  • ? MysqlndUhConnection::sendQuery
  • MysqlndUhConnection::setAutocommit ?
  • PHP Manual
  • MysqlndUhConnection
  • Dump debugging information into the log for the MySQL server

MysqlndUhConnection::serverDumpDebugInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::serverDumpDebugInformation — Dump debugging information into the log for the MySQL server

说明

public MysqlndUhConnection::serverDumpDebugInformation ( mysqlnd_connection $connection ) : bool

Dump debugging information into the log for the MySQL server.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::serverDumpDebugInformation() example

<?php
class proxy extends MysqlndUhConnection {
 public function serverDumpDebugInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::serverDumpDebugInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->dump_debug_info();
?>

以上例程会输出：

proxy::serverDumpDebugInformation(array (
  0 => NULL,
))
proxy::serverDumpDebugInformation returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_dump_debug_info() - 将调试信息输出到日志


Turns on or off auto-committing database modifications

  • ? MysqlndUhConnection::serverDumpDebugInformation
  • MysqlndUhConnection::setCharset ?
  • PHP Manual
  • MysqlndUhConnection
  • Turns on or off auto-committing database modifications

MysqlndUhConnection::setAutocommit

(PECL mysqlnd-uh >= 1.0.1-alpha)

MysqlndUhConnection::setAutocommit — Turns on or off auto-committing database modifications

说明

public MysqlndUhConnection::setAutocommit ( mysqlnd_connection $connection , int $mode ) : bool

Turns on or off auto-committing database modifications

参数

connection

Mysqlnd connection handle. Do not modify!

mode

Whether to turn on auto-commit or not.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::setAutocommit() example

<?php
class proxy extends MysqlndUhConnection {
 public function setAutocommit($res, $mode) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::setAutocommit($res, $mode);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->autocommit(false);
$mysqli->autocommit(true);
?>

以上例程会输出：

proxy::setAutocommit(array (
  0 => NULL,
  1 => 0,
))
proxy::setAutocommit returns true
proxy::setAutocommit(array (
  0 => NULL,
  1 => 1,
))
proxy::setAutocommit returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_autocommit() - 打开或关闭本次数据库连接的自动命令提交事务模式


Sets the default client character set

  • ? MysqlndUhConnection::setAutocommit
  • MysqlndUhConnection::setClientOption ?
  • PHP Manual
  • MysqlndUhConnection
  • Sets the default client character set

MysqlndUhConnection::setCharset

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setCharset — Sets the default client character set

说明

public MysqlndUhConnection::setCharset ( mysqlnd_connection $connection , string $charset ) : bool

Sets the default client character set.

参数

connection

Mysqlnd connection handle. Do not modify!

charset

The charset to be set as default.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::setCharset() example

<?php
class proxy extends MysqlndUhConnection {
 public function setCharset($res, $charset) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::setCharset($res, $charset);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->set_charset("latin1");
?>

以上例程会输出：

proxy::setCharset(array (
  0 => NULL,
  1 => 'latin1',
))
proxy::setCharset returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_set_charset() - 设置默认字符编码


Sets a client option

  • ? MysqlndUhConnection::setCharset
  • MysqlndUhConnection::setServerOption ?
  • PHP Manual
  • MysqlndUhConnection
  • Sets a client option

MysqlndUhConnection::setClientOption

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setClientOption — Sets a client option

说明

public MysqlndUhConnection::setClientOption ( mysqlnd_connection $connection , int $option , int $value ) : bool

Sets a client option.

参数

connection

Mysqlnd connection handle. Do not modify!

option

The option to be set.

value

Optional option value, if required.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::setClientOption() example

<?php
function client_option_to_string($option) {
 static $mapping = array(
  MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT => "MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS => "MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS",
  MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE => "MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE",
  MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND => "MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND",
  MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE => "MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE",
  MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP => "MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP",
  MYSQLND_UH_MYSQLND_SET_CHARSET_DIR => "MYSQLND_UH_MYSQLND_SET_CHARSET_DIR",
  MYSQLND_UH_MYSQLND_SET_CHARSET_NAME => "MYSQLND_UH_MYSQLND_SET_CHARSET_NAME",
  MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE => "MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE",
  MYSQLND_UH_MYSQLND_OPT_PROTOCOL => "MYSQLND_UH_MYSQLND_OPT_PROTOCOL",
  MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME => "MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME",
  MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT => "MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT => "MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPT_USE_RESULT => "MYSQLND_UH_MYSQLND_OPT_USE_RESULT",
  MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION",
  MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION",
  MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION",
  MYSQLND_UH_MYSQLND_SET_CLIENT_IP => "MYSQLND_UH_MYSQLND_SET_CLIENT_IP",
  MYSQLND_UH_MYSQLND_SECURE_AUTH => "MYSQLND_UH_MYSQLND_SECURE_AUTH",
  MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION => "MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION",
  MYSQLND_UH_MYSQLND_OPT_RECONNECT => "MYSQLND_UH_MYSQLND_OPT_RECONNECT",
  MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT => "MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT",
  MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE => "MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE",
  MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE => "MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE",
  MYSQLND_UH_MYSQLND_OPT_SSL_KEY => "MYSQLND_UH_MYSQLND_OPT_SSL_KEY",
  MYSQLND_UH_MYSQLND_OPT_SSL_CERT => "MYSQLND_UH_MYSQLND_OPT_SSL_CERT",
  MYSQLND_UH_MYSQLND_OPT_SSL_CA => "MYSQLND_UH_MYSQLND_OPT_SSL_CA",
  MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH => "MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH",
  MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER => "MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER",
  MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE => "MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE",
  MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR => "MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR",
  MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH => "MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH",
  MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP => "MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP"
 );
 if (version_compare(PHP_VERSION, '5.3.99-dev', '>')) {
  $mapping[MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET] = "MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET";
  $mapping[MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL] = "MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL";
 }
 if (defined("MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE")) {
  /* special mysqlnd build */
  $mapping["MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE"] = "MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE";
 }
 return (isset($mapping[$option])) ? $mapping[$option] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function setClientOption($res, $option, $value) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Option '%s' set to %s\n", client_option_to_string($option), var_export($value, true));
  $ret = parent::setClientOption($res, $option, $value);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

以上例程会输出：

proxy::setClientOption(array (
  0 => NULL,
  1 => 210,
  2 => 3221225472,
))
Option 'MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET' set to 3221225472
proxy::setClientOption returns true
proxy::setClientOption(array (
  0 => NULL,
  1 => 211,
  2 => 'mysql_native_password',
))
Option 'MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL' set to 'mysql_native_password'
proxy::setClientOption returns true
proxy::setClientOption(array (
  0 => NULL,
  1 => 8,
  2 => 1,
))
Option 'MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE' set to 1
proxy::setClientOption returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_real_connect() - 建立一个 MySQL 服务器连接
  • mysqli_options() - 设置选项


Sets a server option

  • ? MysqlndUhConnection::setClientOption
  • MysqlndUhConnection::shutdownServer ?
  • PHP Manual
  • MysqlndUhConnection
  • Sets a server option

MysqlndUhConnection::setServerOption

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setServerOption — Sets a server option

说明

public MysqlndUhConnection::setServerOption ( mysqlnd_connection $connection , int $option ) : void

Sets a server option.

参数

connection

Mysqlnd connection handle. Do not modify!

option

The option to be set.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::setServerOption() example

<?php
function server_option_to_string($option) {
 $ret = 'unknown';
 switch ($option) {
  case MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON:
   $ret = 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON';
   break;
  case MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_OFF:
   $ret = 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON';
   break;
 }
 return $ret;
}

class proxy extends MysqlndUhConnection {
 public function setServerOption($res, $option) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Option '%s' set\n", server_option_to_string($option));
  $ret = parent::setServerOption($res, $option);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1; SELECT 2");
?>

以上例程会输出：

proxy::setServerOption(array (
  0 => NULL,
  1 => 0,
))
Option 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON' set
proxy::setServerOption returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_real_connect() - 建立一个 MySQL 服务器连接
  • mysqli_options() - 设置选项
  • mysqli_multi_query() - 执行查询


The shutdownServer purpose

  • ? MysqlndUhConnection::setServerOption
  • MysqlndUhConnection::simpleCommand ?
  • PHP Manual
  • MysqlndUhConnection
  • The shutdownServer purpose

MysqlndUhConnection::shutdownServer

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::shutdownServer — The shutdownServer purpose

说明

public MysqlndUhConnection::shutdownServer ( string $MYSQLND_UH_RES_MYSQLND_NAME , string $level ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

MYSQLND_UH_RES_MYSQLND_NAME

level

返回值


Sends a basic COM_* command

  • ? MysqlndUhConnection::shutdownServer
  • MysqlndUhConnection::simpleCommandHandleResponse ?
  • PHP Manual
  • MysqlndUhConnection
  • Sends a basic COM_* command

MysqlndUhConnection::simpleCommand

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::simpleCommand — Sends a basic COM_* command

说明

public MysqlndUhConnection::simpleCommand ( mysqlnd_connection $connection , int $command , string $arg , int $ok_packet , bool $silent , bool $ignore_upsert_status ) : bool

Sends a basic COM_* command to MySQL.

参数

connection

Mysqlnd connection handle. Do not modify!

command

The COM command to be send.

arg

Optional COM command arguments.

ok_packet

The OK packet type.

silent

Whether mysqlnd may emit errors.

ignore_upsert_status

Whether to ignore UPDATE/INSERT status.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::simpleCommand() example

<?php
function server_cmd_2_string($command) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_COM_SLEEP => "MYSQLND_UH_MYSQLND_COM_SLEEP",
  MYSQLND_UH_MYSQLND_COM_QUIT => "MYSQLND_UH_MYSQLND_COM_QUIT",
  MYSQLND_UH_MYSQLND_COM_INIT_DB => "MYSQLND_UH_MYSQLND_COM_INIT_DB",
  MYSQLND_UH_MYSQLND_COM_QUERY => "MYSQLND_UH_MYSQLND_COM_QUERY",
  MYSQLND_UH_MYSQLND_COM_FIELD_LIST => "MYSQLND_UH_MYSQLND_COM_FIELD_LIST",
  MYSQLND_UH_MYSQLND_COM_CREATE_DB => "MYSQLND_UH_MYSQLND_COM_CREATE_DB",
  MYSQLND_UH_MYSQLND_COM_DROP_DB => "MYSQLND_UH_MYSQLND_COM_DROP_DB",
  MYSQLND_UH_MYSQLND_COM_REFRESH => "MYSQLND_UH_MYSQLND_COM_REFRESH",
  MYSQLND_UH_MYSQLND_COM_SHUTDOWN => "MYSQLND_UH_MYSQLND_COM_SHUTDOWN",
  MYSQLND_UH_MYSQLND_COM_STATISTICS => "MYSQLND_UH_MYSQLND_COM_STATISTICS",
  MYSQLND_UH_MYSQLND_COM_PROCESS_INFO => "MYSQLND_UH_MYSQLND_COM_PROCESS_INFO",
  MYSQLND_UH_MYSQLND_COM_CONNECT => "MYSQLND_UH_MYSQLND_COM_CONNECT",
  MYSQLND_UH_MYSQLND_COM_PROCESS_KILL => "MYSQLND_UH_MYSQLND_COM_PROCESS_KILL",
  MYSQLND_UH_MYSQLND_COM_DEBUG => "MYSQLND_UH_MYSQLND_COM_DEBUG",
  MYSQLND_UH_MYSQLND_COM_PING => "MYSQLND_UH_MYSQLND_COM_PING",
  MYSQLND_UH_MYSQLND_COM_TIME => "MYSQLND_UH_MYSQLND_COM_TIME",
  MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT => "MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT",
  MYSQLND_UH_MYSQLND_COM_CHANGE_USER => "MYSQLND_UH_MYSQLND_COM_CHANGE_USER",
  MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP => "MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP",
  MYSQLND_UH_MYSQLND_COM_TABLE_DUMP => "MYSQLND_UH_MYSQLND_COM_TABLE_DUMP",
  MYSQLND_UH_MYSQLND_COM_CONNECT_OUT => "MYSQLND_UH_MYSQLND_COM_CONNECT_OUT",
  MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED => "MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED",
  MYSQLND_UH_MYSQLND_COM_STMT_PREPARE => "MYSQLND_UH_MYSQLND_COM_STMT_PREPARE",
  MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE => "MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE",
  MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA => "MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA",
  MYSQLND_UH_MYSQLND_COM_STMT_CLOSE => "MYSQLND_UH_MYSQLND_COM_STMT_CLOSE",
  MYSQLND_UH_MYSQLND_COM_STMT_RESET => "MYSQLND_UH_MYSQLND_COM_STMT_RESET",
  MYSQLND_UH_MYSQLND_COM_SET_OPTION => "MYSQLND_UH_MYSQLND_COM_SET_OPTION",
  MYSQLND_UH_MYSQLND_COM_STMT_FETCH => "MYSQLND_UH_MYSQLND_COM_STMT_FETCH",
  MYSQLND_UH_MYSQLND_COM_DAEMON => "MYSQLND_UH_MYSQLND_COM_DAEMON",
  MYSQLND_UH_MYSQLND_COM_END => "MYSQLND_UH_MYSQLND_COM_END",
 );
 return (isset($mapping[$command])) ? $mapping[$command] : 'unknown';
}

function ok_packet_2_string($ok_packet) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_PROT_GREET_PACKET => "MYSQLND_UH_MYSQLND_PROT_GREET_PACKET",
  MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET => "MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET",
  MYSQLND_UH_MYSQLND_PROT_OK_PACKET => "MYSQLND_UH_MYSQLND_PROT_OK_PACKET",
  MYSQLND_UH_MYSQLND_PROT_EOF_PACKET => "MYSQLND_UH_MYSQLND_PROT_EOF_PACKET",
  MYSQLND_UH_MYSQLND_PROT_CMD_PACKET => "MYSQLND_UH_MYSQLND_PROT_CMD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_ROW_PACKET => "MYSQLND_UH_MYSQLND_PROT_ROW_PACKET",
  MYSQLND_UH_MYSQLND_PROT_STATS_PACKET => "MYSQLND_UH_MYSQLND_PROT_STATS_PACKET",
  MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET => "MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET",
  MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET => "MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET",
  MYSQLND_UH_MYSQLND_PROT_LAST => "MYSQLND_UH_MYSQLND_PROT_LAST",
 );
 return (isset($mapping[$ok_packet])) ? $mapping[$ok_packet] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function simpleCommand($conn, $command, $arg, $ok_packet, $silent, $ignore_upsert_status) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Command '%s'\n", server_cmd_2_string($command));
  printf("OK packet '%s'\n",  ok_packet_2_string($ok_packet));
  $ret = parent::simpleCommand($conn, $command, $arg, $ok_packet, $silent, $ignore_upsert_status);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 1");
?>

以上例程会输出：

proxy::simpleCommand(array (
  0 => NULL,
  1 => 3,
  2 => 'SELECT 1',
  3 => 13,
  4 => false,
  5 => false,
))
Command 'MYSQLND_UH_MYSQLND_COM_QUERY'
OK packet 'MYSQLND_UH_MYSQLND_PROT_LAST'
proxy::simpleCommand returns true
:)proxy::simpleCommand(array (
  0 => NULL,
  1 => 1,
  2 => '',
  3 => 13,
  4 => true,
  5 => true,
))
Command 'MYSQLND_UH_MYSQLND_COM_QUIT'
OK packet 'MYSQLND_UH_MYSQLND_PROT_LAST'
proxy::simpleCommand returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Process a response for a basic COM_* command send to the client

  • ? MysqlndUhConnection::simpleCommand
  • MysqlndUhConnection::sslSet ?
  • PHP Manual
  • MysqlndUhConnection
  • Process a response for a basic COM_* command send to the client

MysqlndUhConnection::simpleCommandHandleResponse

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::simpleCommandHandleResponse — Process a response for a basic COM_* command send to the client

说明

public MysqlndUhConnection::simpleCommandHandleResponse ( mysqlnd_connection $connection , int $ok_packet , bool $silent , int $command , bool $ignore_upsert_status ) : bool

Process a response for a basic COM_* command send to the client.

参数

connection

Mysqlnd connection handle. Do not modify!

ok_packet

The OK packet type.

silent

Whether mysqlnd may emit errors.

command

The COM command to process results from.

ignore_upsert_status

Whether to ignore UPDATE/INSERT status.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::simpleCommandHandleResponse() example

<?php
function server_cmd_2_string($command) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_COM_SLEEP => "MYSQLND_UH_MYSQLND_COM_SLEEP",
  MYSQLND_UH_MYSQLND_COM_QUIT => "MYSQLND_UH_MYSQLND_COM_QUIT",
  MYSQLND_UH_MYSQLND_COM_INIT_DB => "MYSQLND_UH_MYSQLND_COM_INIT_DB",
  MYSQLND_UH_MYSQLND_COM_QUERY => "MYSQLND_UH_MYSQLND_COM_QUERY",
  MYSQLND_UH_MYSQLND_COM_FIELD_LIST => "MYSQLND_UH_MYSQLND_COM_FIELD_LIST",
  MYSQLND_UH_MYSQLND_COM_CREATE_DB => "MYSQLND_UH_MYSQLND_COM_CREATE_DB",
  MYSQLND_UH_MYSQLND_COM_DROP_DB => "MYSQLND_UH_MYSQLND_COM_DROP_DB",
  MYSQLND_UH_MYSQLND_COM_REFRESH => "MYSQLND_UH_MYSQLND_COM_REFRESH",
  MYSQLND_UH_MYSQLND_COM_SHUTDOWN => "MYSQLND_UH_MYSQLND_COM_SHUTDOWN",
  MYSQLND_UH_MYSQLND_COM_STATISTICS => "MYSQLND_UH_MYSQLND_COM_STATISTICS",
  MYSQLND_UH_MYSQLND_COM_PROCESS_INFO => "MYSQLND_UH_MYSQLND_COM_PROCESS_INFO",
  MYSQLND_UH_MYSQLND_COM_CONNECT => "MYSQLND_UH_MYSQLND_COM_CONNECT",
  MYSQLND_UH_MYSQLND_COM_PROCESS_KILL => "MYSQLND_UH_MYSQLND_COM_PROCESS_KILL",
  MYSQLND_UH_MYSQLND_COM_DEBUG => "MYSQLND_UH_MYSQLND_COM_DEBUG",
  MYSQLND_UH_MYSQLND_COM_PING => "MYSQLND_UH_MYSQLND_COM_PING",
  MYSQLND_UH_MYSQLND_COM_TIME => "MYSQLND_UH_MYSQLND_COM_TIME",
  MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT => "MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT",
  MYSQLND_UH_MYSQLND_COM_CHANGE_USER => "MYSQLND_UH_MYSQLND_COM_CHANGE_USER",
  MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP => "MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP",
  MYSQLND_UH_MYSQLND_COM_TABLE_DUMP => "MYSQLND_UH_MYSQLND_COM_TABLE_DUMP",
  MYSQLND_UH_MYSQLND_COM_CONNECT_OUT => "MYSQLND_UH_MYSQLND_COM_CONNECT_OUT",
  MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED => "MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED",
  MYSQLND_UH_MYSQLND_COM_STMT_PREPARE => "MYSQLND_UH_MYSQLND_COM_STMT_PREPARE",
  MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE => "MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE",
  MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA => "MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA",
  MYSQLND_UH_MYSQLND_COM_STMT_CLOSE => "MYSQLND_UH_MYSQLND_COM_STMT_CLOSE",
  MYSQLND_UH_MYSQLND_COM_STMT_RESET => "MYSQLND_UH_MYSQLND_COM_STMT_RESET",
  MYSQLND_UH_MYSQLND_COM_SET_OPTION => "MYSQLND_UH_MYSQLND_COM_SET_OPTION",
  MYSQLND_UH_MYSQLND_COM_STMT_FETCH => "MYSQLND_UH_MYSQLND_COM_STMT_FETCH",
  MYSQLND_UH_MYSQLND_COM_DAEMON => "MYSQLND_UH_MYSQLND_COM_DAEMON",
  MYSQLND_UH_MYSQLND_COM_END => "MYSQLND_UH_MYSQLND_COM_END",
 );
 return (isset($mapping[$command])) ? $mapping[$command] : 'unknown';
}

function ok_packet_2_string($ok_packet) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_PROT_GREET_PACKET => "MYSQLND_UH_MYSQLND_PROT_GREET_PACKET",
  MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET => "MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET",
  MYSQLND_UH_MYSQLND_PROT_OK_PACKET => "MYSQLND_UH_MYSQLND_PROT_OK_PACKET",
  MYSQLND_UH_MYSQLND_PROT_EOF_PACKET => "MYSQLND_UH_MYSQLND_PROT_EOF_PACKET",
  MYSQLND_UH_MYSQLND_PROT_CMD_PACKET => "MYSQLND_UH_MYSQLND_PROT_CMD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_ROW_PACKET => "MYSQLND_UH_MYSQLND_PROT_ROW_PACKET",
  MYSQLND_UH_MYSQLND_PROT_STATS_PACKET => "MYSQLND_UH_MYSQLND_PROT_STATS_PACKET",
  MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET => "MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET",
  MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET => "MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET",
  MYSQLND_UH_MYSQLND_PROT_LAST => "MYSQLND_UH_MYSQLND_PROT_LAST",
 );
 return (isset($mapping[$ok_packet])) ? $mapping[$ok_packet] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function simpleCommandHandleResponse($conn, $ok_packet, $silent, $command, $ignore_upsert_status) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Command '%s'\n", server_cmd_2_string($command));
  printf("OK packet '%s'\n",  ok_packet_2_string($ok_packet));
  $ret = parent::simpleCommandHandleResponse($conn, $ok_packet, $silent, $command, $ignore_upsert_status);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysql = mysql_connect("localhost", "root", "");
mysql_query("SELECT 1 FROM DUAL", $mysql);
?>

以上例程会输出：

proxy::simpleCommandHandleResponse(array (
  0 => NULL,
  1 => 5,
  2 => false,
  3 => 27,
  4 => true,
))
Command 'MYSQLND_UH_MYSQLND_COM_SET_OPTION'
OK packet 'MYSQLND_UH_MYSQLND_PROT_EOF_PACKET'
proxy::simpleCommandHandleResponse returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections


Used for establishing secure connections using SSL

  • ? MysqlndUhConnection::simpleCommandHandleResponse
  • MysqlndUhConnection::stmtInit ?
  • PHP Manual
  • MysqlndUhConnection
  • Used for establishing secure connections using SSL

MysqlndUhConnection::sslSet

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sslSet — Used for establishing secure connections using SSL

说明

public MysqlndUhConnection::sslSet ( mysqlnd_connection $connection , string $key , string $cert , string $ca , string $capath , string $cipher ) : bool

Used for establishing secure connections using SSL.

参数

connection

Mysqlnd connection handle. Do not modify!

key

The path name to the key file.

cert

The path name to the certificate file.

ca

The path name to the certificate authority file.

capath

The pathname to a directory that contains trusted SSL CA certificates in PEM format.

cipher

A list of allowable ciphers to use for SSL encryption.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::sslSet() example

<?php
class proxy extends MysqlndUhConnection {
 public function sslSet($conn, $key, $cert, $ca, $capath, $cipher) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sslSet($conn, $key, $cert, $ca, $capath, $cipher);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ssl_set("key", "cert", "ca", "capath", "cipher");
?>

以上例程会输出：

proxy::sslSet(array (
  0 => NULL,
  1 => 'key',
  2 => 'cert',
  3 => 'ca',
  4 => 'capath',
  5 => 'cipher',
))
proxy::sslSet returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_ssl_set() - 使用 SSL 建立到数据库之间的安全连接


Initializes a statement and returns a resource for use with mysqli_statement::prepare

  • ? MysqlndUhConnection::sslSet
  • MysqlndUhConnection::storeResult ?
  • PHP Manual
  • MysqlndUhConnection
  • Initializes a statement and returns a resource for use with mysqli_statement::prepare

MysqlndUhConnection::stmtInit

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::stmtInit — Initializes a statement and returns a resource for use with mysqli_statement::prepare

说明

public MysqlndUhConnection::stmtInit ( mysqlnd_connection $connection ) : resource

Initializes a statement and returns a resource for use with mysqli_statement::prepare.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Resource of type Mysqlnd Prepared Statement (internal only - you must not modify it!). The documentation may also refer to such resources using the alias name mysqlnd_prepared_statement.

范例

Example #1 MysqlndUhConnection::stmtInit() example

<?php
class proxy extends MysqlndUhConnection {
 public function stmtInit($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  var_dump($res);
  $ret = parent::stmtInit($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 1 AS _one FROM DUAL");
$stmt->execute();
$one = NULL;
$stmt->bind_result($one);
$stmt->fetch();
var_dump($one);
?>

以上例程会输出：

proxy::stmtInit(array (
  0 => NULL,
))
resource(19) of type (Mysqlnd Connection)
proxy::stmtInit returns NULL
resource(246) of type (Mysqlnd Prepared Statement (internal only - you must not modify it!))
int(1)

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_stmt_init() - 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象


Transfers a result set from the last query

  • ? MysqlndUhConnection::stmtInit
  • MysqlndUhConnection::txCommit ?
  • PHP Manual
  • MysqlndUhConnection
  • Transfers a result set from the last query

MysqlndUhConnection::storeResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::storeResult — Transfers a result set from the last query

说明

public MysqlndUhConnection::storeResult ( mysqlnd_connection $connection ) : resource

Transfers a result set from the last query.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Resource of type Mysqlnd Resultset (internal only - you must not modify it!). The documentation may also refer to such resources using the alias name mysqlnd_resultset.

范例

Example #1 MysqlndUhConnection::storeResult() example

<?php
class proxy extends MysqlndUhConnection {
 public function storeResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::storeResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Also called buffered result' AS _msg FROM DUAL");
var_dump($res->fetch_assoc());

$mysqli->real_query("SELECT 'Good morning!' AS _msg FROM DUAL");
$res = $mysqli->store_result();
var_dump($res->fetch_assoc());
?>

以上例程会输出：

proxy::storeResult(array (
  0 => NULL,
))
proxy::storeResult returns NULL
resource(475) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(27) "Also called buffered result"
}
proxy::storeResult(array (
  0 => NULL,
))
proxy::storeResult returns NULL
resource(730) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(13) "Good morning!"
}

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_store_result() - 转移上一次查询返回的结果集
  • mysqli_real_query() - 执行一个mysql查询


Commits the current transaction

  • ? MysqlndUhConnection::storeResult
  • MysqlndUhConnection::txRollback ?
  • PHP Manual
  • MysqlndUhConnection
  • Commits the current transaction

MysqlndUhConnection::txCommit

(PECL mysqlnd-uh >= 1.0.1-alpha)

MysqlndUhConnection::txCommit — Commits the current transaction

说明

public MysqlndUhConnection::txCommit ( mysqlnd_connection $connection ) : bool

Commits the current transaction.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::txCommit() example

<?php
class proxy extends MysqlndUhConnection {
 public function txCommit($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::txCommit($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->commit();
?>

以上例程会输出：

proxy::txCommit(array (
  0 => NULL,
))
proxy::txCommit returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_commit() - 提交一个事务


Rolls back current transaction

  • ? MysqlndUhConnection::txCommit
  • MysqlndUhConnection::useResult ?
  • PHP Manual
  • MysqlndUhConnection
  • Rolls back current transaction

MysqlndUhConnection::txRollback

(PECL mysqlnd-uh >= 1.0.1-alpha)

MysqlndUhConnection::txRollback — Rolls back current transaction

说明

public MysqlndUhConnection::txRollback ( mysqlnd_connection $connection ) : bool

Rolls back current transaction.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhConnection::txRollback() example

<?php
class proxy extends MysqlndUhConnection {
 public function txRollback($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::txRollback($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->rollback();
?>

以上例程会输出：

proxy::txRollback(array (
  0 => NULL,
))
proxy::txRollback returns true

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_commit() - 提交一个事务


Initiate a result set retrieval

  • ? MysqlndUhConnection::txRollback
  • MysqlndUhPreparedStatement ?
  • PHP Manual
  • MysqlndUhConnection
  • Initiate a result set retrieval

MysqlndUhConnection::useResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::useResult — Initiate a result set retrieval

说明

public MysqlndUhConnection::useResult ( mysqlnd_connection $connection ) : resource

Initiate a result set retrieval.

参数

connection

Mysqlnd connection handle. Do not modify!

返回值

Resource of type Mysqlnd Resultset (internal only - you must not modify it!). The documentation may also refer to such resources using the alias name mysqlnd_resultset.

范例

Example #1 MysqlndUhConnection::useResult() example

<?php
class proxy extends MysqlndUhConnection {
 public function useResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::useResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->real_query("SELECT 'Good morning!' AS _msg FROM DUAL");
$res = $mysqli->use_result();
var_dump($res->fetch_assoc());
?>

以上例程会输出：

proxy::useResult(array (
  0 => NULL,
))
proxy::useResult returns NULL
resource(425) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(13) "Good morning!"
}

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_use_result() - Initiate a result set retrieval
  • mysqli_real_query() - 执行一个mysql查询


The MysqlndUhPreparedStatement class

(PECL mysqlnd-uh >= 1.0.0-alpha)

简介

类摘要

MysqlndUhPreparedStatement {
/* 方法 */
public __construct ( )
public execute ( mysqlnd_prepared_statement $statement ) : bool
public prepare ( mysqlnd_prepared_statement $statement , string $query ) : bool
}

Table of Contents

  • MysqlndUhPreparedStatement::__construct — The __construct purpose
  • MysqlndUhPreparedStatement::execute — Executes a prepared Query
  • MysqlndUhPreparedStatement::prepare — Prepare an SQL statement for execution


The __construct purpose

  • ? MysqlndUhPreparedStatement
  • MysqlndUhPreparedStatement::execute ?
  • PHP Manual
  • MysqlndUhPreparedStatement
  • The __construct purpose

MysqlndUhPreparedStatement::__construct

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::__construct — The __construct purpose

说明

public MysqlndUhPreparedStatement::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Executes a prepared Query

  • ? MysqlndUhPreparedStatement::__construct
  • MysqlndUhPreparedStatement::prepare ?
  • PHP Manual
  • MysqlndUhPreparedStatement
  • Executes a prepared Query

MysqlndUhPreparedStatement::execute

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::execute — Executes a prepared Query

说明

public MysqlndUhPreparedStatement::execute ( mysqlnd_prepared_statement $statement ) : bool

Executes a prepared Query.

参数

statement

Mysqlnd prepared statement handle. Do not modify! Resource of type Mysqlnd Prepared Statement (internal only - you must not modify it!).

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhPreparedStatement::execute() example

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function execute($res) {
  printf("%s(", __METHOD__);
  var_dump($res);
  printf(")\n");
  $ret = parent::execute($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'Labskaus' AS _msg FROM DUAL");
$stmt->execute();
$msg = NULL;
$stmt->bind_result($msg);
$stmt->fetch();
var_dump($msg);
?>

以上例程会输出：

stmt_proxy::execute(resource(256) of type (Mysqlnd Prepared Statement (internal only - you must not modify it!))
)
stmt_proxy::execute returns true
bool(true)
string(8) "Labskaus"

参见

  • mysqlnd_uh_set_statement_proxy() - Installs a proxy for mysqlnd statements
  • mysqli_stmt_execute() - Executes a prepared Query


Prepare an SQL statement for execution

  • ? MysqlndUhPreparedStatement::execute
  • Mysqlnd_uh 函数 ?
  • PHP Manual
  • MysqlndUhPreparedStatement
  • Prepare an SQL statement for execution

MysqlndUhPreparedStatement::prepare

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::prepare — Prepare an SQL statement for execution

说明

public MysqlndUhPreparedStatement::prepare ( mysqlnd_prepared_statement $statement , string $query ) : bool

Prepare an SQL statement for execution.

参数

statement

Mysqlnd prepared statement handle. Do not modify! Resource of type Mysqlnd Prepared Statement (internal only - you must not modify it!).

query

The query to be prepared.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 MysqlndUhPreparedStatement::prepare() example

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $query = "SELECT 'No more you-know-what-I-mean for lunch, please' AS _msg FROM DUAL";
  $ret = parent::prepare($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'Labskaus' AS _msg FROM DUAL");
$stmt->execute();
$msg = NULL;
$stmt->bind_result($msg);
$stmt->fetch();
var_dump($msg);
?>

以上例程会输出：

stmt_proxy::prepare(array (
  0 => NULL,
  1 => 'SELECT \'Labskaus\' AS _msg FROM DUAL',
))
stmt_proxy::prepare returns true
bool(true)
string(46) "No more you-know-what-I-mean for lunch, please"

参见

  • mysqlnd_uh_set_statement_proxy() - Installs a proxy for mysqlnd statements
  • mysqli_stmt_prepare() - Prepare an SQL statement for execution
  • mysqli_prepare() - 准备执行一个 SQL 语句


Mysqlnd_uh 函数

Table of Contents

  • mysqlnd_uh_convert_to_mysqlnd — Converts a MySQL connection handle into a mysqlnd connection handle
  • mysqlnd_uh_set_connection_proxy — Installs a proxy for mysqlnd connections
  • mysqlnd_uh_set_statement_proxy — Installs a proxy for mysqlnd statements


Converts a MySQL connection handle into a mysqlnd connection handle

  • ? Mysqlnd_uh 函数
  • mysqlnd_uh_set_connection_proxy ?
  • PHP Manual
  • Mysqlnd_uh 函数
  • Converts a MySQL connection handle into a mysqlnd connection handle

mysqlnd_uh_convert_to_mysqlnd

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_convert_to_mysqlnd — Converts a MySQL connection handle into a mysqlnd connection handle

说明

mysqlnd_uh_convert_to_mysqlnd ( mysqli &$mysql_connection ) : resource

Converts a MySQL connection handle into a mysqlnd connection handle. After conversion you can execute mysqlnd library calls on the connection handle. This can be used to access mysqlnd functionality not made available through user space API calls.

The function can be disabled with mysqlnd_uh.enable. If mysqlnd_uh.enable is set to false the function will not install the proxy and always return true. Additionally, an error of the type E_WARNING may be emitted. The error message may read like PHP Warning: mysqlnd_uh_convert_to_mysqlnd(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. You are not allowed to call this function [...].

参数

MySQL connection handle

A MySQL connection handle of type mysql, mysqli or PDO_MySQL.

返回值

A mysqlnd connection handle.

更新日志

版本 | 说明
5.4.0 | The mysql_connection parameter can now be of type mysql, PDO_MySQL, or mysqli. Before, only the mysqli type was allowed.

范例

Example #1 mysqlnd_uh_convert_to_mysqlnd() example

<?php
/* PDO user API gives no access to connection thread id */
$mysql_connection = new PDO("mysql:host=localhost;dbname=test", "root", "");

/* Convert PDO MySQL handle to mysqlnd handle */
$mysqlnd = mysqlnd_uh_convert_to_mysqlnd($mysql_connection);

/* Create Proxy to call mysqlnd connection class methods */
$obj = new MySQLndUHConnection();
/* Call mysqlnd_conn::get_thread_id */
var_dump($obj->getThreadId($mysqlnd));

/* Use SQL to fetch connection thread id */
var_dump($mysql_connection->query("SELECT CONNECTION_ID()")->fetchAll());
?>

以上例程会输出：

int(27054)
array(1) {
  [0]=>
  array(2) {
    ["CONNECTION_ID()"]=>
    string(5) "27054"
    [0]=>
    string(5) "27054"
  }
}

参见

  • mysqlnd_uh.enable


Installs a proxy for mysqlnd connections

  • ? mysqlnd_uh_convert_to_mysqlnd
  • mysqlnd_uh_set_statement_proxy ?
  • PHP Manual
  • Mysqlnd_uh 函数
  • Installs a proxy for mysqlnd connections

mysqlnd_uh_set_connection_proxy

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_set_connection_proxy — Installs a proxy for mysqlnd connections

说明

mysqlnd_uh_set_connection_proxy ( MysqlndUhConnection &$connection_proxy , mysqli &$mysqli_connection = ? ) : bool

Installs a proxy object to hook mysqlnd's connection objects methods. Once installed, the proxy will be used for all MySQL connections opened with mysqli, mysql or PDO_MYSQL, assuming that the listed extensions are compiled to use the mysqlnd library.

The function can be disabled with mysqlnd_uh.enable. If mysqlnd_uh.enable is set to false the function will not install the proxy and always return true. Additionally, an error of the type E_WARNING may be emitted. The error message may read like PHP Warning: mysqlnd_uh_set_connection_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed [...].

参数

connection_proxy

A proxy object of type MysqlndUhConnection.

mysqli_connection

Object of type mysqli. If given, the proxy will be set for this particular connection only.

返回值

Returns true on success. Otherwise, returns false

范例

Example #1 mysqlnd_uh_set_connection_proxy() example

<?php
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 'No proxy installed, yet'");

class proxy extends MysqlndUhConnection {
 public function query($res, $query) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::query($res, $query);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli->query("SELECT 'mysqlnd rocks!'");

$mysql = mysql_connect("localhost", "root", "", "test");
mysql_query("SELECT 'Ahoy Andrey!'", $mysql);

$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
$pdo->query("SELECT 'Moin Johannes!'");
?>

以上例程会输出：

proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'mysqlnd rocks!\'',
))
proxy::query returns true
proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Ahoy Andrey!\'',
))
proxy::query returns true
proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Moin Johannes!\'',
))
proxy::query returns true

参见

  • mysqlnd_uh_set_statement_proxy() - Installs a proxy for mysqlnd statements
  • mysqlnd_uh.enable


Installs a proxy for mysqlnd statements

  • ? mysqlnd_uh_set_connection_proxy
  • Change History ?
  • PHP Manual
  • Mysqlnd_uh 函数
  • Installs a proxy for mysqlnd statements

mysqlnd_uh_set_statement_proxy

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_set_statement_proxy — Installs a proxy for mysqlnd statements

说明

mysqlnd_uh_set_statement_proxy ( MysqlndUhStatement &$statement_proxy ) : bool

Installs a proxy for mysqlnd statements. The proxy object will be used for all mysqlnd prepared statement objects, regardless which PHP MySQL extension (mysqli, mysql, PDO_MYSQL) has created them as long as the extension is compiled to use the mysqlnd library.

The function can be disabled with mysqlnd_uh.enable. If mysqlnd_uh.enable is set to false the function will not install the proxy and always return true. Additionally, an error of the type E_WARNING may be emitted. The error message may read like PHP Warning: mysqlnd_uh_set_statement_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed [...].

参数

statement_proxy

The mysqlnd statement proxy object of type MysqlndUhStatement

返回值

Returns true on success. Otherwise, returns false

参见

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqlnd_uh.enable


Change History

Table of Contents

  • PECL/mysqlnd_uh 1.0 series

The Change History lists major changes users need to be aware if upgrading from one version to another. It is a high level summary of selected changes that may impact applications or might even break backwards compatibility. See also the CHANGES file contained in the source for additional changelog information. The commit history is also available.


PECL/mysqlnd_uh 1.0 series

1.0.1-alpha

  • Release date: TBD
  • Motto/theme: bug fix release

Feature changes

  • Support of PHP 5.4.0 or later.
  • BC break: MysqlndUhConnection::changeUser() requires additional passwd_len parameter.
  • BC break: MYSQLND_UH_VERSION_STR renamed to MYSQLND_UH_VERSION. MYSQLND_UH_VERSION renamed to MYSQLND_UH_VERSION_ID.
  • BC break: mysqlnd_uh.enabled configuration setting renamed to mysqlnd_uh.enable.

1.0.0-alpha

  • Release date: 08/2010
  • Motto/theme: Initial release


Mysqlnd connection multiplexing plugin

  • 简介
  • Concepts
    • Architecture
    • Connection pool
    • Sharing connections
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • Change History
    • PECL/mysqlnd_mux 1.0 series


简介

The mysqlnd multiplexing plugin (mysqlnd_mux) multiplexes MySQL connections established by all PHP MySQL extensions that use the MySQL native driver (mysqlnd) for PHP.

The MySQL native driver for PHP features an internal C API for plugins, such as the connection multiplexing plugin, which can extend the functionality of mysqlnd. See the mysqlnd for additional details about its benefits over the MySQL Client Library libmysqlclient.

Mysqlnd plugins like mysqlnd_mux operate, for the most part, transparently from a user perspective. The connection multiplexing plugin supports all PHP applications, and all MySQL PHP extensions. It does not change existing APIs. Therefore, it can easily be used with existing PHP applications.

Note:

This is a proof-of-concept. All features are at an early stage. Not all kinds of queries are handled by the plugin yet. Thus, it cannot be used in a drop-in fashion at the moment.

Please, do not use this version in production environments.

Key Features

The key features of mysqlnd_mux are as follows:

  • Transparent and therefore easy to use:

    • Supports all of the PHP MySQL extensions.

    • Little to no application changes are required, dependent on the required usage scenario.

  • Reduces server load and connection establishment latency:

    • Opens less connections to the MySQL server.

    • Less connections to MySQL mean less work for the MySQL server. In a client-server environment scaling the server is often more difficult than scaling the client. Multiplexing helps with horizontal scale-out (scale-by-client).

    • Pooling saves connection time.

    • Multiplexed connection: multiple user handles share the same network connection. Once opened, a network connection is cached and shared among multiple user handles. There is a 1:n relationship between internal network connection and user connection handles.

    • Persistent connection: a network connection is kept open at the end of the web request, if the PHP deployment model allows. Thus, subsequently web requests can reuse a previously opened connection. Like other resources, network connections are bound to the scope of a process. Thus, they can be reused for all web requests served by a process.

Limitations

The proof-of-concept does not support unbuffered queries, prepared statements, and asynchronous queries.

The connection pool is using a combination of the transport method and hostname as keys. As a consequence, two connections to the same host using the same transport method (TCP/IP, Unix socket, Windows named pipe) will be linked to the same pooled connection even if username and password differ. Be aware of the possible security implications.

The proof-of-concept is transaction agnostic. It does not know about SQL transactions.

Note:

Applications must be aware of the consequences of connection sharing connections.

About the name mysqlnd_mux

The shortcut mysqlnd_mux stands for mysqlnd connection multiplexing plugin.


Concepts

Table of Contents

  • Architecture
  • Connection pool
  • Sharing connections

This explains the architecture and related concepts for this plugin. Reading and understanding these concepts is required to successfully use this plugin.


Architecture

The mysqlnd connection multiplexing plugin is implemented as a PHP extension. It is written in C and operates under the hood of PHP. During the startup of the PHP interpreter, in the module initialization phase of the PHP engine, it gets registered as a mysqlnd plugin to replace specific mysqlnd C methods.

The mysqlnd library uses PHP streams to communicate with the MySQL server. PHP streams are accessed by the mysqlnd library through its net module. The mysqlnd connection multiplexing plugin proxies methods of the mysqlnd library net module to control opening and closing of network streams.

Upon opening a user connection to MySQL using the appropriate connection functions of either mysqli, PDO_MYSQL or ext/mysql, the plugin will search its connection pool for an open network connection. If the pool contains a network connection to the host specified by the connect function using the transport method requested (TCP/IP, Unix domain socket, Windows named pipe), the pooled connection is linked to the user handle. Otherwise, a new network connection is opened, put into the poolm and associated with the user connection handle. This way, multiple user handles can be linked to the same network connection.


Connection pool

The plugins connection pool is created when PHP initializes its modules (MINIT) and free'd when PHP shuts down the modules (MSHUTDOWN). This is the same as for persistent MySQL connections.

Depending on the deployment model, the pool is used for the duration of one or multiple web requests. Network connections are bound to the lifespan of an operating system level process. If the PHP process serves multiple web requests as it is the case for Fast-CGI or threaded web server deployments, then the pooled connections can be reused over multiple connections. Because multiplexing means sharing connections, it can even happen with a threaded deployment that two threads or two distinct web requests are linked to one pooled network connections.

A pooled connection is explicitly closed once the last reference to it is released. An implicit close happens when PHP shuts down its modules.


Sharing connections

The PHP mysqlnd connection multiplexing plugin changes the relationship between a users connection handle and the underlying MySQL connection. Without the plugin, every MySQL connection belongs to exactly one user connection at a time. The multiplexing plugin changes. A MySQL connection is shared among multiple user handles. There no one-to-one relation if using the plugin.

Sharing pooled connections has an impact on the connection state. State changing operations from multiple user handles pointing to one MySQL connection are not isolated from each other. If, for example, a session variable is set through one user connection handle, the session variable becomes visible to all other user handles that reference the same underlying MySQL connection.

This is similar in concept to connection state related phenomens described for the PHP mysqlnd replication and load balancing plugin. Please, check the PECL/mysqlnd_ms documentation for more details on the state of a connection.

The proof-of-concept takes no measures to isolate multiplexed connections from each other.


  • ? Sharing connections
  • 需求 ?
  • PHP Manual
  • mysqlnd_mux
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

PHP 5.5.0 or newer. Some advanced functionality requires PHP 5.5.0 or newer.

The mysqlnd_mux replication and load balancing plugin supports all PHP applications and all available PHP MySQL extensions (mysqli, mysql, PDO_MYSQL). The PHP MySQL extension must be configured to use mysqlnd in order to be able to use the mysqlnd_mux plugin for mysqlnd.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mysqlnd_mux


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Mysqlnd_mux 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mysqlnd_mux.enable | 0 | PHP_INI_SYSTEM |

这是配置指令的简短说明。

mysqlnd_mux.enable int

Enables or disables the plugin. If disabled, the extension will not plug into mysqlnd to proxy internal mysqlnd C API calls.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Other

The plugins version number can be obtained using MYSQLND_MUX_VERSION or MYSQLND_MUX_VERSION_ID. MYSQLND_MUX_VERSION is the string representation of the numerical version number MYSQLND_MUX_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_MUX_VERSION_ID | 10000

MYSQLND_MUX_VERSION (string)
Plugin version string, for example, 1.0.0-prototype.
MYSQLND_MUX_VERSION_ID (int)
Plugin version number, for example, 10000.


Change History

Table of Contents

  • PECL/mysqlnd_mux 1.0 series

This change history is a high level summary of selected changes that may impact applications and/or break backwards compatibility.

See also the CHANGES file in the source distribution for a complete list of changes.


PECL/mysqlnd_mux 1.0 series

1.0.0-pre-alpha

  • Release date: no package released, initial check-in 09/2012
  • Motto/theme: Proof of concept

Initial check-in. Essentially a demo of the mysqlnd plugin API.

Note:

This is the current development series. All features are at an early stage. Changes may happen at any time without prior notice. Please, do not use this version in production environments.

The documentation may not reflect all changes yet.


Mysqlnd Memcache plugin

  • 简介
  • Quickstart and Examples
    • Setup
    • Usage
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • Mysqlnd_memcache 函数
    • mysqlnd_memcache_get_config — Returns information about the plugin configuration
    • mysqlnd_memcache_set — Associate a MySQL connection with a Memcache connection
  • Change History
    • PECL/mysqlnd_memcache 1.0 series


简介

The mysqlnd memcache plugin (mysqlnd_memcache) is an PHP extension for transparently translating SQL into requests for the MySQL InnoDB Memcached Daemon Plugin (server plugin). It includes experimental support for the MySQL Cluster Memcached Daemon. The server plugin provides access to data stored inside MySQL InnoDB (respectively MySQL Cluster NDB) tables using the Memcache protocol. This PHP extension, which supports all PHP MySQL extensions that use mysqlnd, will identify tables exported in this way and will translate specific SELECT queries into Memcache requests.

mysqlnd_memcache data flow

Note:

This plugin depends on the MySQL InnoDB Memcached Daemon Plugin. It is not provided to be used with a stand-alone Memcached. For a generic query cache using Memcached look at the mysqlnd query cache plugin. For direct Memcache access look at the memcache and memcached extensions.

The MySQL native driver for PHP is a C library that ships together with PHP. It serves as a drop-in replacement for the MySQL Client Library (libmysqlclient). Using mysqlnd has several advantages: no extra downloads are required because it's bundled with PHP, it's under the PHP license, there is lower memory consumption in certain cases, and it contains new functionality such as asynchronous queries.

The mysqlnd_mmemcache operates, for the most part, transparently from a user perspective. The mysqlnd memcache plugin supports all PHP applications, and all MySQL PHP extensions. It does not change existing APIs. Therefore, it can easily be used with existing PHP applications.

The MySQL Memcache plugins add key-value style access method for data stored in InnoDB resp. NDB (MySQL Cluster) SQL tables through the Memcache protocol. This type of key-value access if often faster than using SQL.

Key Features

The key features of PECL/mysqlnd_memcache are as follows.

  • Possible performance benefits

    • Client-side: light-weight protocol.

    • Server-side: no SQL parsing, direct access to the storage.

    • Please, run your own benchmarks! Actual performance results are highly dependent on setup and hardware used.

Limitations

The initial version is not binary safe. Due to the way the MySQL Memcache plugins works there are restrictions related to separators.

Prepared statements and asynchronous queries are not supported. Result set meta data support is limited.

The mapping information for tables accessible via Memcache is not cached in the plugin between requests but fetched from the MySQL server each time a MySQL connection is associated with a Memcache connection. See mysqlnd_memcache_set() for details.

On the name

The shortcut mysqlnd_memcache stands for mysqlnd memcache plugin. Memcache refers to support of the MySQL Memcache plugins for InnoDB and NDB (MySQL Cluster). The plugin is not related to the Memcached cache server.


Quickstart and Examples

Table of Contents

  • Setup
  • Usage

The mysqlnd memcache plugin is easy to use. This quickstart will demo typical use-cases, and provide practical advice on getting started.

It is strongly recommended to read the reference sections in addition to the quickstart. The quickstart tries to avoid discussing theoretical concepts and limitations. Instead, it will link to the reference sections. It is safe to begin with the quickstart. However, before using the plugin in mission critical environments we urge you to read additionally the background information from the reference sections.


Setup

The plugin is implemented as a PHP extension. See also the installation instructions to install this extension.

Compile or configure the PHP MySQL extension (API) (mysqli, PDO_MYSQL, mysql). That extension must use the mysqlnd library as because mysqlnd_memcache is a plugin for the mysqlnd library. For additional information, refer to the mysqlnd_memcache installation instructions.

Then, load this extension into PHP and activate the plugin in the PHP configuration file using the PHP configuration directive named mysqlnd_memcache.enable.

Example #1 Enabling the plugin (php.ini)

; On Windows the filename is php_mysqnd_memcache.dll
; Load the extension
extension=mysqlnd_memcache.so
; Enable it
mysqlnd_memcache.enable=1

Follow the instructions given in the » MySQL Reference Manual on installing the Memcache plugins for the MySQL server. Activate the plugins and configure Memcache access for SQL tables.

The examples in this quickguide assume that the following table exists, and that Memcache is configured with access to it.

Example #2 SQL table used for the Quickstart

CREATE TABLE test(
  id CHAR(16),
  f1 VARCHAR(255),
  f2 VARCHAR(255),
  f3 VARCHAR(255),
  flags INT NOT NULL,
  cas_column INT,
  expire_time_column INT,
  PRIMARY KEY(id)
  ) ENGINE=InnoDB;

INSERT INTO test (id, f1, f2, f3) VALUES (1, 'Hello', 'World', '!');
INSERT INTO test (id, f1, f2, f3) VALUES (2, 'Lady', 'and', 'the tramp');

INSERT INTO innodb_memcache.containers(
  name, db_schema, db_table, key_columns, value_columns,
  flags, cas_column, expire_time_column, unique_idx_name_on_key)
VALUES (
  'plugin_test', 'test', 'test', 'id', 'f1,f2,f3',
  'flags', 'cas_column', 'expire_time_column', 'PRIMARY KEY');


Usage

After associating a MySQL connection with a Memcache connection using mysqnd_memcache_set() the plugin attempts to transparently replace SQL SELECT statements by a memcache access. For that purpose the plugin monitors all SQL statements executed and tries to match the statement string against MYSQLND_MEMCACHE_DEFAULT_REGEXP. In case of a match, the mysqlnd memcache plugin checks whether the SELECT is accessing only columns of a mapped table and the WHERE clause is limited to a single key lookup.

In case of the example SQL table, the plugin will use the Memcache interface of the MySQL server to fetch results for a SQL query like SELECT f1, f2, f3 WHERE id = n.

Example #1 Basic example.

<?php
$mysqli = new mysqli("host", "user", "passwd", "database");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc);

/*
   This is a query which queries table test using id as key in the WHERE part
   and is accessing fields f1, f2 and f3. Therefore, mysqlnd_memcache
   will intercept it and route it via memcache.
*/
$result = $mysqli->query("SELECT f1, f2, f3 FROM test WHERE id = 1");
while ($row = $result->fetch_row()) {
    print_r($row);
}

/*
   This is a query which queries table test but using f1 in the WHERE clause.
   Therefore, mysqlnd_memcache can't intercept it. This will be executed
   using the MySQL protocol
*/
$mysqli->query("SELECT id FROM test WHERE f1 = 'Lady'");
while ($row = $result->fetch_row()) {
    print_r($row);
}
?>

以上例程会输出：

array(
    [f1] => Hello
    [f2] => World
    [f3] => !
)
array(
    [id] => 2
)


  • ? Usage
  • 需求 ?
  • PHP Manual
  • mysqlnd_memcache
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

PHP: this extension requires PHP 5.4+, version PHP 5.4.4 or never. The required PHP extensions are PCRE (enabled by default), and the memcached extension version 2.0.x.

The mysqlnd_memcache Memcache plugin supports all PHP applications and all available PHP MySQL extensions (mysqli, mysql, PDO_MYSQL). The PHP MySQL extension must be configured with mysqlnd support.

For accessing InnoDB tables, this PHP extension requires MySQL Server 5.6.6 or newer with the InnoDB Memcache Daemon Plugin enabled.

For accessing MySQL Cluster NDB tables, this PHP extension requires MySQL Cluster 7.2 or newer with the NDB Memcache API nodes enabled.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mysqlnd_memcache

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Mysqlnd_memcache 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mysqlnd_memcache.enable | 1 | PHP_INI_SYSTEM | Available since 1.0.0

这是配置指令的简短说明。

mysqlnd_memcache.enable int

Enables or disables the plugin. If disabled, the extension will not plug into mysqlnd to proxy internal mysqlnd C API calls.

Note:

This option is mainly used by developers to build this extension statically into PHP. General users are encouraged to build this extension as a shared object, and to unload it completely when it is not needed.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

MySQL Memcache Plugin related

MYSQLND_MEMCACHE_DEFAULT_REGEXP (string)
Default regular expression (PCRE style) used for matching SELECT statements that will be mapped into a MySQL Memcache Plugin access point, if possible. It is also possible to use mysqlnd_memcache_set(), but the default approach is using this regular expression for pattern matching.

Assorted

The version number of this plugin can be obtained by using MYSQLND_MEMCACHE_VERSION or MYSQLND_MEMCACHE_VERSION_ID. MYSQLND_MEMCACHE_VERSION is the string representation of the numerical version number MYSQLND_MEMCACHE_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_MEMCACHE_VERSION_ID | 10000

MYSQLND_MEMCACHE_VERSION (string)
Plugin version string, for example, 1.0.0-alpha.
MYSQLND_MEMCACHE_VERSION_ID (int)
Plugin version number, for example, 10000.


Mysqlnd_memcache 函数

Table of Contents

  • mysqlnd_memcache_get_config — Returns information about the plugin configuration
  • mysqlnd_memcache_set — Associate a MySQL connection with a Memcache connection


Returns information about the plugin configuration

  • ? Mysqlnd_memcache 函数
  • mysqlnd_memcache_set ?
  • PHP Manual
  • Mysqlnd_memcache 函数
  • Returns information about the plugin configuration

mysqlnd_memcache_get_config

(PECL mysqlnd_memcache >= 1.0.0)

mysqlnd_memcache_get_config — Returns information about the plugin configuration

说明

mysqlnd_memcache_get_config ( mixed $connection ) : array

This function returns an array of all mysqlnd_memcache related configuration information that is attached to the MySQL connection. This includes MySQL, the Memcache object provided via mysqlnd_memcache_set(), and the table mapping configuration that was automatically collected from the MySQL Server.

参数

connection

A handle to a MySQL Server using one of the MySQL API extensions for PHP, which are PDO_MYSQL, mysqli or ext/mysql.

返回值

An array of mysqlnd_memcache configuration information on success, otherwise false.

The returned array has these elements:

mysqlnd_memcache_get_config() array structure
Array Key | Description
memcached | Instance of Memcached associated to this MySQL connection by mysqlnd_memcache_set(). You can use this to change settings of the memcache connection, or directly by querying the server on this connection.
pattern | The PCRE regular expression used to match the SQL query sent to the server. Queries matching this pattern will be further analyzed to decide whether the query can be intercepted and sent via the memcache interface or whether the query is sent using the general MySQL protocol to the server. The pattern is either the default pattern (MYSQLND_MEMCACHE_DEFAULT_REGEXP) or it is set via mysqlnd_memcache_set().
mappings | An associative array with a list of all configured containers as they were discovered by this plugin. The key for these elements is the name of the container in the MySQL configuration. The value is described below. The contents of this field is created by querying the MySQL Server during association to MySQL and a memcache connection using mysqlnd_memcache_set().
mapping_query | An SQL query used during mysqlnd_memcache_set() to identify the available containers and mappings. The result of that query is provided in the mappings element.
Mapping entry structure
Array Key | Description
prefix | A prefix used while accessing data via memcache. With the MySQL InnoDB Memcache Deamon plugin, this usually begins with @@ and ends with a configurable separator. This prefix is placed in front of the key value while using the memcache protocol.
schema_name | Name of the schema (database) which contains the table being accessed.
table_name | Name of the table which contains the data accessible via memcache protocol.
id_field_name | Name of the database field (column) with the id used as key when accessing the table via memcache. Often this is the database field having a primary key.
separator The separator used to split the different field values. This is needed as memcache only provides access to a single value while MySQL can map multiple columns to this value.

Note:

The separator, which can be set in the MySQL Server configuration, should not be part of any value retrieved via memcache because proper mapping can't be guaranteed.

fields | An array with the name of all fields available for this mapping.

范例

Example #1 mysqlnd_memcache_get_config() example

<?php
$mysqli = new mysqli("host", "user", "passwd", "database");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc);

var_dump(mysqlnd_memcache_get_config($mysqli));
?>

以上例程会输出：

array(4) {
  ["memcached"]=>
  object(Memcached)#2 (0) {
  }
  ["pattern"]=>
  string(125) "/^\s*SELECT\s*(.+?)\s*FROM\s*`?([a-z0-9_]+)`?\s*WHERE\s*`?([a-z0-9_]+)`?\s*=\s*(?(?=["'])["']([^"']*)["']|([0-9e\.]*))\s*$/is"
  ["mappings"]=>
  array(1) {
    ["mymem_test"]=>
    array(6) {
      ["prefix"]=>
      string(13) "@@mymem_test."
      ["schema_name"]=>
      string(4) "test"
      ["table_name"]=>
      string(10) "mymem_test"
      ["id_field_name"]=>
      string(2) "id"
      ["separator"]=>
      string(1) "|"
      ["fields"]=>
      array(3) {
        [0]=>
        string(2) "f1"
        [1]=>
        string(2) "f2"
        [2]=>
        string(2) "f3"
      }
    }
  }
  ["mapping_query"]=>
  string(209) "    SELECT c.name,
                          CONCAT('@@', c.name, (SELECT value FROM innodb_memcache.config_options WHERE name = 'table_map_delimiter')) AS key_prefix,
                          c.db_schema,
                          c.db_table,
                          c.key_columns,
                          c.value_columns,
                          (SELECT value FROM innodb_memcache.config_options WHERE name = 'separator') AS sep
                     FROM innodb_memcache.containers c"
}

参见

  • mysqlnd_memcache_set() - Associate a MySQL connection with a Memcache connection


Associate a MySQL connection with a Memcache connection

  • ? mysqlnd_memcache_get_config
  • Change History ?
  • PHP Manual
  • Mysqlnd_memcache 函数
  • Associate a MySQL connection with a Memcache connection

mysqlnd_memcache_set

(PECL mysqlnd_memcache >= 1.0.0)

mysqlnd_memcache_set — Associate a MySQL connection with a Memcache connection

说明

mysqlnd_memcache_set ( mixed $mysql_connection , Memcached $memcache_connection = ? , string $pattern = ? , callable $callback = ? ) : bool

Associate mysql_connection with memcache_connection using pattern as a PCRE regular expression, and callback as a notification callback or to unset the association of mysql_connection.

While associating a MySQL connection with a Memcache connection, this function will query the MySQL Server for its configuration. It will automatically detect whether the server is configured to use the InnoDB Memcache Daemon Plugin or MySQL Cluster NDB Memcache support. It will also query the server to automatically identify exported tables and other configuration options. The results of this automatic configuration can be retrieved using mysqlnd_memcache_get_config().

参数

mysql_connection

A handle to a MySQL Server using one of the MySQL API extensions for PHP, which are PDO_MYSQL, mysqli or ext/mysql.

memcache_connection

A Memcached instance with a connection to the MySQL Memcache Daemon plugin. If this parameter is omitted, then mysql_connection will be unassociated from any memcache connection. And if a previous association exists, then it will be replaced.

pattern

A regular expression in Perl Compatible Regular Expression syntax used to identify potential Memcache-queries. The query should have three sub patterns. The first subpattern contains the requested field list, the second the name of the ID column from the query and the third the requested value. If this parameter is omitted or os set to null, then a default pattern will be used.

callback

A callback which will be used whenever a query is being sent to MySQL. The callback will receive a single bool parameter telling if a query was sent via Memcache.

返回值

true if the association or disassociation is successful, otherwise false if there is an error.

范例

Example #1 mysqlnd_memcache_set() example with var_dump() as a simple debugging callback.

<?php
$mysqli = new mysqli("host", "user", "passwd", "database");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc, NULL, 'var_dump');

/* This query will be intercepted and executed via Memcache protocol */
echo "Sending query for id via Memcache: ";
$mysqli->query("SELECT f1, f2, f3 FROM test WHERE id = 1");

/* f1 is not configured as valid key field, this won't be sent via Memcache */
echo "Sending query for f1 via Memcache: ";
$mysqli->query("SELECT id FROM test WHERE f1 = 1");

mysqlnd_memcache_set($mysqli);

/* Now the regular MySQL protocol will be used */
echo "var_dump won't be invoked: ";
$mysqli->query("SELECT f1, f2, f3 WHERE id = 1");

?>

以上例程会输出：

Sending query for id via Memcache: bool(true)
Sending query for f1 via Memcache: bool(false)
var_dump won't be invoked:

参见

  • mysqlnd_memcache_get_config() - Returns information about the plugin configuration


Change History

Table of Contents

  • PECL/mysqlnd_memcache 1.0 series

This change history is a high level summary of selected changes that may impact applications and/or break backwards compatibility.

See also the CHANGES file in the source distribution for a complete list of changes.


PECL/mysqlnd_memcache 1.0 series

1.0.0-alpha

  • Release date: TBD
  • Motto/theme: Basic mapping of SQL SELECT to a MySQL Memcache plugin access.

The initial release does map basic SQL SELECT statements to a MySQL Memcache plugin access. This bares potential performance benefits as the direct key-value access to MySQL storage using the Memcache protocol is usually faster than using SQL access.


Oracle OCI8

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • Testing
    • 运行时配置
  • 预定义常量
  • 范例
  • OCI8 Connection Handling and Connection Pooling
  • OCI8 Fast Application Notification (FAN) Support
  • OCI8 Transparent Application Failover (TAF) Support
  • OCI8 and DTrace Dynamic Tracing
  • Supported Datatypes
  • OCI8 函数
    • oci_bind_array_by_name — Binds a PHP array to an Oracle PL/SQL array parameter
    • oci_bind_by_name — 绑定一个 PHP 变量到一个 Oracle 位置标志符
    • oci_cancel — 中断游标读取数据
    • oci_client_version — Returns the Oracle client library version
    • oci_close — 关闭 Oracle 连接
    • oci_commit — 提交未执行的事务处理
    • oci_connect — 建立一个到 Oracle 服务器的连接
    • oci_define_by_name — 在 SELECT 中使用 PHP 变量作为定义的步骤
    • oci_error — 返回上一个错误
    • oci_execute — 执行一条语句
    • oci_fetch_all — 获取结果数据的所有行到一个数组
    • oci_fetch_array — Returns the next row from a query as an associative or numeric array
    • oci_fetch_assoc — Returns the next row from a query as an associative array
    • oci_fetch_object — Returns the next row from a query as an object
    • oci_fetch_row — Returns the next row from a query as a numeric array
    • oci_fetch — Fetches the next row into result-buffer
    • oci_field_is_null — 检查字段是否为 null
    • oci_field_name — 返回字段名
    • oci_field_precision — 返回字段精度
    • oci_field_scale — 返回字段范围
    • oci_field_size — 返回字段大小
    • oci_field_type_raw — 返回字段的原始 Oracle 数据类型
    • oci_field_type — 返回字段的数据类型
    • oci_free_descriptor — Frees a descriptor
    • oci_free_statement — 释放关联于语句或游标的所有资源
    • oci_get_implicit_resultset — Returns the next child statement resource from a parent statement resource that has Oracle Database Implicit Result Sets
    • oci_lob_copy — Copies large object
    • oci_lob_is_equal — Compares two LOB/FILE locators for equality
    • oci_new_collection — 分配新的 collection 对象
    • oci_new_connect — 建定一个到 Oracle 服务器的新连接
    • oci_new_cursor — 分配并返回一个新的游标（语句句柄）
    • oci_new_descriptor — 初始化一个新的空 LOB 或 FILE 描述符
    • oci_num_fields — 返回结果列的数目
    • oci_num_rows — 返回语句执行后受影响的行数
    • oci_parse — 配置 Oracle 语句预备执行
    • oci_password_change — 修改 Oracle 用户的密码
    • oci_pconnect — 使用一个持久连接连到 Oracle 数据库
    • oci_register_taf_callback — Register a user-defined callback function for Oracle Database TAF
    • oci_result — 返回所取得行中字段的值
    • oci_rollback — 回滚未提交的事务
    • oci_server_version — 返回服务器版本信息
    • oci_set_action — Sets the action name
    • oci_set_call_timeout — Sets a millisecond timeout for database calls
    • oci_set_client_identifier — Sets the client identifier
    • oci_set_client_info — Sets the client information
    • oci_set_db_operation — Sets the database operation
    • oci_set_edition — Sets the database edition
    • oci_set_module_name — Sets the module name
    • oci_set_prefetch — 设置预提取行数
    • oci_statement_type — 返回 OCI 语句的类型
    • oci_unregister_taf_callback — Unregister a user-defined callback function for Oracle Database TAF
  • OCICollection — The OCICollection class
    • OCICollection::append — Appends element to the collection
    • OCICollection::assign — Assigns a value to the collection from another existing collection
    • OCICollection::assignElem — Assigns a value to the element of the collection
    • OCICollection::free — Frees the resources associated with the collection object
    • OCICollection::getElem — Returns value of the element
    • OCICollection::max — Returns the maximum number of elements in the collection
    • OCICollection::size — Returns size of the collection
    • OCICollection::trim — Trims elements from the end of the collection
  • OCILob — The OCILob class
    • OCILob::append — Appends data from the large object to another large object
    • OCILob::close — Closes LOB descriptor
    • OCILob::eof — Tests for end-of-file on a large object's descriptor
    • OCILob::erase — Erases a specified portion of the internal LOB data
    • OCILob::export — Exports LOB's contents to a file
    • OCILob::flush — Flushes/writes buffer of the LOB to the server
    • OCILob::free — Frees resources associated with the LOB descriptor
    • OCILob::getBuffering — Returns current state of buffering for the large object
    • OCILob::import — Imports file data to the LOB
    • OCILob::load — Returns large object's contents
    • OCILob::read — Reads part of the large object
    • OCILob::rewind — Moves the internal pointer to the beginning of the large object
    • OCILob::save — Saves data to the large object
    • OCILob::saveFile — 别名 OCILob::import
    • OCILob::seek — Sets the internal pointer of the large object
    • OCILob::setBuffering — Changes current state of buffering for the large object
    • OCILob::size — Returns size of large object
    • OCILob::tell — Returns the current position of internal pointer of large object
    • OCILob::truncate — Truncates large object
    • OCILob::write — Writes data to the large object
    • OCILob::writeTemporary — Writes a temporary large object
    • OCILob::writeToFile — 别名 OCILob::export
  • OCI8 Obsolete Aliases and Functions
    • oci_internal_debug — Enables or disables internal debug output
    • ocibindbyname — 别名 oci_bind_by_name
    • ocicancel — 别名 oci_cancel
    • ocicloselob — 别名 OCI-Lob::close
    • ocicollappend — 别名 OCICollection::append
    • ocicollassign — 别名 OCICollection::assign
    • ocicollassignelem — 别名 OCICollection::assignElem
    • ocicollgetelem — 别名 OCICollection::getElem
    • ocicollmax — 别名 OCICollection::max
    • ocicollsize — 别名 OCICollection::size
    • ocicolltrim — 别名 OCICollection::trim
    • ocicolumnisnull — 别名 oci_field_is_null
    • ocicolumnname — 别名 oci_field_name
    • ocicolumnprecision — 别名 oci_field_precision
    • ocicolumnscale — 别名 oci_field_scale
    • ocicolumnsize — 别名 oci_field_size
    • ocicolumntype — 别名 oci_field_type
    • ocicolumntyperaw — 别名 oci_field_type_raw
    • ocicommit — 别名 oci_commit
    • ocidefinebyname — 别名 oci_define_by_name
    • ocierror — 别名 oci_error
    • ociexecute — 别名 oci_execute
    • ocifetch — 别名 oci_fetch
    • ocifetchinto — Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row
    • ocifetchstatement — 别名 oci_fetch_all
    • ocifreecollection — 别名 OCICollection::free
    • ocifreecursor — 别名 oci_free_statement
    • ocifreedesc — 别名 OCI-Lob::free
    • ocifreestatement — 别名 oci_free_statement
    • ociinternaldebug — 别名 oci_internal_debug
    • ociloadlob — 别名 OCI-Lob::load
    • ocilogoff — 别名 oci_close
    • ocilogon — 别名 oci_connect
    • ocinewcollection — 别名 oci_new_collection
    • ocinewcursor — 别名 oci_new_cursor
    • ocinewdescriptor — 别名 oci_new_descriptor
    • ocinlogon — 别名 oci_new_connect
    • ocinumcols — 别名 oci_num_fields
    • ociparse — 别名 oci_parse
    • ociplogon — 别名 oci_pconnect
    • ociresult — 别名 oci_result
    • ocirollback — 别名 oci_rollback
    • ocirowcount — 别名 oci_num_rows
    • ocisavelob — 别名 OCI-Lob::save
    • ocisavelobfile — 别名 OCI-Lob::import
    • ociserverversion — 别名 oci_server_version
    • ocisetprefetch — 别名 oci_set_prefetch
    • ocistatementtype — 别名 oci_statement_type
    • ociwritelobtofile — 别名 OCI-Lob::export
    • ociwritetemporarylob — 别名 OCI-Lob::writeTemporary


简介

These functions allow you to access Oracle Database. They support SQL and PL/SQL statements. Basic features include transaction control, binding of PHP variables to Oracle placeholders, and support for large object (LOB) types and collections. Oracle's scalability features such as Database Resident Connection Pooling (DRCP) and result caching are also supported.


安装／配置

Table of Contents

  • 需求
  • 安装
  • Testing
  • 运行时配置


需求

OCI8 3.0 is included with PHP 8. It is also available from » PECL. For PHP 7, use OCI8 2.2 from » PECL. OCI8 requires Oracle 10g or later Oracle client libraries.

If the Oracle Database is on the same machine as PHP, the database software already contains the necessary libraries and header files. When PHP is on a different machine, use the free » Oracle Instant Client libraries.

To use Oracle Instant Client, install the Basic or Basic Light Oracle Instant Client ZIP file, RPM package, or DMG package. When building OCI8 from source code, also install the Instant Client SDK.

You must run PHP with the same, or a more recent, version of the Oracle libraries that OCI8 was built with.

Note:

Oracle's standard client-server network interoperability allows connections between different versions of Oracle Client and Oracle Database. For certified configurations see Oracle Support's Doc ID 207303.1. In summary, Oracle Client 19, 18 and 12.2 can connect to Oracle Database 11.2 or greater. Oracle Client 12.1 can connect to Oracle Database 10.2 or greater. Oracle Client 11.2 can connect to Oracle Database 9.2 or greater.

Note:

Full OCI8 feature support is only available when using the most recent versions of the Oracle client libraries and database.


安装

Configuring PHP with OCI8

Review the previous Requirements section before configuring OCI8.

To enable the OCI8 extension, configure PHP with the option --with-oci8.

Before starting the web server, OCI8 typically requires several Oracle environment variables (see below) to locate libraries, point to configuration files, and set some basic properties such as the character set used by Oracle libraries. The variables should be set before any PHP process starts.

PHP should be run with the same, or more recent, major version of Oracle libraries as it was configured with. For example, if you build OCI8 with Oracle 11.2 libraries, then PHP should also be deployed and run with Oracle 11.2 libraries.

Installing OCI8 as a Shared Extension

The configuration shared option builds OCI8 as a shared library that can be dynamically loaded into PHP. Building a shared extension allows OCI8 to be upgraded easily without impacting the rest of PHP.

Configure OCI8 using one of the following configure options.

  • If using Oracle Instant Client, then do:

    ./configure --with-oci8=shared,instantclient,/path/to/instant/client/lib

    If Instant Client is installed from ZIP files, make sure to create the library symbolic link, for example ln -s libclntsh.so.11.1 libclntsh.so.

    If using an RPM-based installation of Oracle Instant Client, the configure line will look like this:

    ./configure --with-oci8=shared,instantclient,/usr/lib/oracle/<version>/client/lib

    For example, --with-oci8=shared,instantclient,/usr/lib/oracle/11.2/client/lib.

    Note that Oracle Instant Client support first appeared in PHP 4.3.11 and 5.0.4 and originally used the option --with-oci8-instant-client to configure PHP.

  • If using an Oracle database or full Oracle Client installation then do:

    ./configure --with-oci8=shared,$ORACLE_HOME

    Make sure the web server user (nobody, www) has access to the libraries, initialization files and tnsnames.ora (if used) under the $ORACLE_HOME directory. With Oracle 10gR2, you may need to run the $ORACLE_HOME/install/changePerm.sh utility to give directory access.

After configuration, follow the usual PHP building procedure, e.g. make install. The OCI8 shared extension oci8.so library will be created. It may need to be manually moved to the PHP extension directory, specified by the extension_dir option in your php.ini file.

To complete installation of OCI8, edit php.ini and add the line:

extension=oci8.so

Installing OCI8 as a Statically Compiled Extension

Configure OCI8 using one of the following configure options.

  • If using Oracle Instant Client, then do:

    ./configure --with-oci8=instantclient,/path/to/instant/client/lib

  • If using an Oracle database or full Oracle Client installation then do:

    ./configure --with-oci8=$ORACLE_HOME

After configuration, follow the usual PHP building procedure, e.g. make install. After successful compilation, you do not need to add oci8.so to php.ini. No additional build steps are required.

Installing OCI8 from PECL

The OCI8 extension can be added to an existing PHP installation either automatically or manually from » https://pecl.php.net/. 安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/oci8.

For an automated install follow these steps:

  • If you are behind a firewall, set PEAR's proxy, for example:

    pear config-set http_proxy http://my-proxy.example.com:80/

  • Run

    pecl install oci8

    When prompted, enter either the value of $ORACLE_HOME, or instantclient,/path/to/instant/client/lib.

    Note: Do not enter the variable $ORACLE_HOME because it will not be expanded. Instead, enter the actual path of the Oracle home directory.

For a manual install, download the PECL OCI8 package, e.g. oci8-1.3.5.tgz.

  • Extract the package:

    tar -zxf oci8-1.3.5.tgz
cd oci8-1.3.5

  • Prepare the package:

    phpize

  • Configure the package, either using $ORACLE_HOME or Instant Client

    ./configure -with-oci8=shared,$ORACLE_HOME

    or

    ./configure -with-oci8=shared,instantclient,/path/to/instant/client/lib

  • Install the package:

    make install

After either an automatic or manual install, edit your php.ini file and add the line:

extension=oci8.so

Make sure the php.ini directive extension_dir is set to the directory that oci8.so was installed in.

Installing OCI8 on Windows

On Windows, uncomment the php.ini line extension=php_oci8.dll when using Oracle 10gR2 client libraries. Uncomment extension=php_oci8_11g.dll when using Oracle 11g client libraries. These two DLLs contain equivalent functionality and only one may be enabled at a time. Make sure extension_dir is set to the directory containing the PHP extension DLLs.

If using Instant Client, set the system PATH environment variable to the Oracle library directory.

Setting the Oracle Environment

Before using this extension, make sure that the Oracle environment variables are properly set for the web daemon user. If your web server is automatically started at boot time then make sure that the boot-time environment is also configured correctly.

Note:

Do not set Oracle environment variables using putenv() in a PHP script because Oracle libraries may be loaded and initialized before your script runs. Variables set with putenv() may then cause conflicts, crashes, or unpredictable behavior. Some functions may work but others might give subtle errors. The variables should be set up before the web server is started.

On Red Hat Linux and variants, export variables at the end of /etc/sysconfig/httpd. Other systems with Apache 2 may use an envvars script in the Apache bin directory. A third option, the Apache SetEnv directive in httpd.conf, may work in some systems but is known to be insufficient in others.

To check that environment variables are set correctly, use phpinfo() and check the Environment (not the Apache Environment) section contains the expected variables.

The variables that might be needed are included in the following table. Refer to the Oracle documentation for more information on all the variables.

Common Oracle Environment Variables
Name | Purpose
ORACLE_HOME | Contains the directory of the full Oracle Database software. Do not set this when using Oracle Instant Client as it is unnecessary and may cause installation problems.
ORACLE_SID | Contains the name of the database on the local machine to be connected to. There is no need to set this if you using Oracle Instant Client, or always pass the connection parameter to oci_connect().
LD_LIBRARY_PATH | Set this (or its platform equivalent, such as DYLD_LIBRARY_PATH, LIBPATH, or SHLIB_PATH) to the location of the Oracle libraries, for example $ORACLE_HOME/lib or /usr/lib/oracle/11.1/client/lib. This variable is not needed if the libraries are located by a different search mechanism, such as with ldconfig or with LD_PRELOAD.
NLS_LANG | This is the primary variable for setting the character set and globalization information used by the Oracle libraries.
ORA_SDTZ | Sets the Oracle session timezone.
TNS_ADMIN | Contains the directory where the Oracle Net Services configuration files such as tnsnames.ora and sqlnet.ora are kept. Not needed if the oci_connect() connection string uses the Easy Connect naming syntax such as localhost/XE. Not needed if the network configuration files are in one of the default locations such as $ORACLE_HOME/network/admin or /etc.
Less frequently used Oracle environment variables include TWO_TASK, ORA_TZFILE, and the various Oracle globalization settings like NLS* and the ORA_NLS_* variables.

Troubleshooting

The most common problem with installing OCI8 is not having the Oracle environment correctly set. This typically appears as a problem using oci_connect() or oci_pconnect(). The error may be a PHP error such as Call to undefined function oci_connect(), an Oracle error such as ORA-12705, or even an Apache crash. Check the Apache log files for startup errors and see the sections above to resolve this problem.

While network errors like ORA-12154 or ORA-12514 indicate an Oracle network naming or configuration issue, the root cause may be because the PHP environment is incorrectly set up and Oracle libraries are unable to locate the tnsnames.ora configuration file.

On Windows, having multiple versions of Oracle on the one machine can easily cause library clashes unless care is taken to make sure PHP only uses the correct version of Oracle.

A utility to examine what libraries are being looked for and loaded can help resolve missing or clashing library issues, particularly on Windows.

Note: If the web server doesn't start or crashes at startup

Check that Apache is linked with the pthread library:

# ldd /www/apache/bin/httpd
  libpthread.so.0 => /lib/libpthread.so.0 (0x4001c000)
  libm.so.6 => /lib/libm.so.6 (0x4002f000)
  libcrypt.so.1 => /lib/libcrypt.so.1 (0x4004c000)
  libdl.so.2 => /lib/libdl.so.2 (0x4007a000)
  libc.so.6 => /lib/libc.so.6 (0x4007e000)
  /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

If the libpthread is not listed, then reinstall Apache:

# cd /usr/src/apache_1.3.xx
# make clean
# LIBS=-lpthread ./config.status
# make
# make install

Please note that on some systems like UnixWare, it is libthread instead of libpthread. PHP and Apache have to be configured with EXTRA_LIBS=-lthread.


Testing

The OCI8 test suite is in ext/oci8/tests. After OCI8 tests are run this directory will also contain logs of any failures.

Before running PHP's tests, edit details.inc and set $user, $password and the $dbase connection string. The OCI8 test suite has been developed using the SYSTEM account. Some tests will fail if the test user does not have equivalent permissions.

If Oracle Database Resident Connection Pooling is being tested, set $test_drcp to true and ensure the connection string uses an appropriate DRCP pooled server.

An alternative to editing details.inc is the set environment variables, for example:

    $ export PHP_OCI8_TEST_USER=system
    $ export PHP_OCI8_TEST_PASS=oracle
    $ export PHP_OCI8_TEST_DB=localhost/XE
    $ export PHP_OCI8_TEST_DRCP=FALSE
Note in some shells these variables are not propagated correctly to the PHP process and tests will fail to connect if this method is used.

Next, set any necessary environment for the Oracle database. If you are running PHP on the same machines as Oracle Database, you can run:

    $ . /usr/local/bin/oraenv

With Oracle 11gR2 XE do:

    $ . /u01/app/oracle/product/11.2.0/xe/bin/oracle_env.sh

Some shells require that php.ini has E in the variables_order parameter, for example:

    variables_order = "EGPCS"

Run all the PHP tests with:

    $ cd your_php_src_directory
    $ make test
or run only the OCI8 tests with
    $ cd your_php_src_directory
    $ make test TESTS=ext/oci8

When the tests have completed, review any test failures. On slow systems, some tests may take longer than the default test timeout in run-tests.php. To correct this, set the environment variable TEST_TIMEOUT to a larger number of seconds.

On fast machines with a local database configured for light load (e.g. Oracle 11gR2 XE) some tests might fail with ORA-12516 or ORA-12520 errors. To prevent this, increase the database PROCESSES parameter using the following steps:

Connect as the oracle software owner:

    $ su - oracle

Set the necessary Oracle environment with oracle_env.sh or oraenv, as described above.

Start the SQL*Plus command line tool and increase PROCESSES

    $ sqlplus / as sysdba
    SQL> alter system set processes=100 scope=spfile

Restart the database:

    SQL> startup force


运行时配置

这些函数的行为受 php.ini 中的设置影响。

OCI8 Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
oci8.connection_class | "" | PHP_INI_ALL | Available since PHP 5.3 (PECL OCI8 1.3).
oci8.default_prefetch | "100" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.events | Off | PHP_INI_SYSTEM | Available since PHP 5.3 (PECL OCI8 1.3).
oci8.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.old_oci_close_semantics | Off | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.persistent_timeout | "-1" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.ping_interval | "60" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.privileged_connect | Off | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.statement_cache_size | "20" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).

这是配置指令的简短说明。

oci8.connection_class string

This user defined text should always be set when using Oracle Database Resident Connection Pooling (DRCP). It allows sub-partitioning of the DRCP connection pool, allowing OCI8 persistent connections from an application to reuse database sessions from a previous PHP script, giving better scalability. When an application uses a database pooled process previously used with a different connection class, the session settings such as the default Oracle date format are reset. This prevents accidental sharing of information between different applications.

The value can be set at runtime with ini_set() prior to connecting.

To use DRCP, OCI8 must be linked with Oracle 11g (or later) libraries and the database must be Oracle 11g (or later). The DRCP connection pool must be enabled in the database, the oci8.connection_class should be set to the same string for all web servers running the same application, and the OCI8 connection string must specify to use a pooled server. The application should use persistent connections.

oci8.default_prefetch int

This option sets the default number of extra rows that will be fetched and cached automatically whenever a low-level request for data from the database is made. Setting a value of 0 turns off prefetching.

The prefetch value does not alter the number of rows that functions like oci_fetch_array() return to the user; the prefetching and caching of rows is handled internally in OCI8.

The value can be set per-statement with oci_set_prefetch() prior to statement execution.

In PHP 5.3 (PECL OCI8 1.3.4) the default value was increased from 10 to 100.

In PHP 5.3.2 (PECL OCI8 1.4) the minimum value settable was reduced from 1 to 0, allowing prefetching to be turned off.

When using Oracle Database 12c (or later), the prefetch value set by PHP can be overridden by Oracle's client oraaccess.xml configuration file. Refer to Oracle documentation for more detail.

Note: A larger prefetch can result in improved performance, at the cost of some increased memory usage. For queries that return large amounts of data, the performance benefit can be significant.

oci8.events bool

Using On allows PHP to be notified of database Fast Application Notification (FAN) events.

Without FAN, when a database instance or machine node fails unexpectedly, PHP applications may be blocked waiting for a database response until a TCP timeout expires. With FAN events, PHP applications are quickly notified of failures that affect their established database connections. The OCI8 extension will clean up unusable connections in the persistent connection cache.

When using On, the database must also be configured to post FAN events.

FAN support is available when OCI8 is linked with Oracle 10gR2 (or later) libraries and connected to Oracle Database 10gR2 (or later).

oci8.max_persistent int

The maximum number of persistent OCI8 connections per PHP process. Setting this option to -1 means that there is no limit.

oci8.old_oci_close_semantics bool

This option controls oci_close() behaviour. Enabling it means that oci_close() will do nothing; the connection will not be closed until the end of the script. This is for backward compatibility only. If you find that you need to enable this setting, you are strongly encouraged to adjust the oci_close() calls in your application instead of enabling this option.

oci8.persistent_timeout int

The maximum number of seconds that a PHP process is allowed to keep an idle persistent connection open. Setting this option to -1 means that idle persistent connections will be retained until the PHP process terminates or the connection is explicitly closed with oci_close().

Note: In PHP, the expiry of idle resources is not alarm-based. It occurs when PHP finishes processing a script and checks the last-used timestamp of resources. Hence there is a paradox that idle connections can only be closed when there is some activity (though not necessarily OCI8 related) in the PHP process. If there is more than one PHP process then each must individually be activated in order to trigger expiry of its idle resources. The introduction of Database Resident Connection Pooling (DRCP) in Oracle 11g resolves the memory and resource issues that oci8.max_persistent and oci8.persistent_timeout previously attempted to overcome.

Note: In PHP 5.3 (PECL OCI8 1.3), persistent connections can be closed with oci_close().

oci8.ping_interval int

The number of seconds that must pass before issuing a ping during oci_pconnect(). A ping ensures that the database connection is valid. When set to 0, persistent connections will be pinged every time oci_pconnect() is called. To disable pings completely, set this option to -1.

Note: Disabling pings allows oci_pconnect() to operate at the highest efficiency, but PHP may not be able to detect unusable connections, such as caused by network dropout, or if the Oracle database has gone down since PHP connected, until the connection is used later in the script. Consult the oci_pconnect() documentation for more information.

oci8.privileged_connect bool

This option allows connections to use the privileged external credentials OCI_SYSOPER or OCI_SYSDBA.

Note: Seting this On can allow scripts on web servers running with the appropriate OS user privileges to connect as privileged database users without requiring a database password. This can be a security risk.

oci8.statement_cache_size int

This option enables statement caching, and specifies how many statements to cache. To disable statement caching just set this option to 0.

Statement caching removes the need to transmit the statement text to the database and removes the need to transmit any meta data about the statement back to PHP. This can significantly improve overall system performance in applications which reuse statements during the lifetime of a connection. Some extra database "cursors" may be held open under the assumption that statements will be reused.

Set this value to the size of the working set of statements used by your application. Setting too small a value can cause statements to be flushed from the cache before they are reused.

This option is of most use with persistent connections.

When using Oracle Database 12c (or later), this value can be overridden and automatically tuned by Oracle's client oraaccess.xml file. Refer to Oracle documentation for more detail.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

OCI8 Function and Method Modes
Constant | Description
OCI_ASSOC | Used with oci_fetch_all() and oci_fetch_array() to get results as an associative array.
OCI_BOTH | Used with oci_fetch_all() and oci_fetch_array() to get results as an array with both associative and number indices.
OCI_COMMIT_ON_SUCCESS | Statement execution mode for oci_execute() call. Automatically commit changes when the statement has succeeded.
OCI_CRED_EXT | Used with oci_connect() for using Oracles' External or OS authentication. Introduced in PHP 5.3 and PECL OCI8 1.3.4.
OCI_DEFAULT | See OCI_NO_AUTO_COMMIT.
OCI_DESCRIBE_ONLY | Statement execution mode for oci_execute(). Use this mode if you want meta data such as the column names but don't want to fetch rows from the query.
OCI_EXACT_FETCH | Obsolete. Statement fetch mode. Used when the application knows in advance exactly how many rows it will be fetching. This mode turns prefetching off for Oracle release 8 or later mode. The cursor is canceled after the desired rows are fetched which may result in reduced server-side resource usage.
OCI_FETCHSTATEMENT_BY_COLUMN | Default mode of oci_fetch_all().
OCI_FETCHSTATEMENT_BY_ROW | Alternative mode of oci_fetch_all().
OCI_LOB_BUFFER_FREE | Used with OCILob::flush to free buffers used.
OCI_NO_AUTO_COMMIT | Statement execution mode for oci_execute(). The transaction is not automatically committed when using this mode. For readability in new code, use this value instead of the older, equivalent OCI_DEFAULT constant. Introduced in PHP 5.3.2 (PECL OCI8 1.4).
OCI_NUM | Used with oci_fetch_all() and oci_fetch_array() to get results as an enumerated array.
OCI_RETURN_LOBS | Used with oci_fetch_array() to get the data value of the LOB instead of the descriptor.
OCI_RETURN_NULLS | Used with oci_fetch_array() to get empty array elements if the row items value is null.
OCI_SEEK_CUR | Used with OCILob::seek to set the seek position.
OCI_SEEK_END | Used with OCILob::seek to set the seek position.
OCI_SEEK_SET | Used with OCILob::seek to set the seek position.
OCI_SYSDATE | Obsolete.
OCI_SYSDBA | Used with oci_connect() to connect with the SYSDBA privilege. The php.ini setting oci8.privileged_connect should be enabled to use this.
OCI_SYSOPER | Used with oci_connect() to connect with the SYSOPER privilege. The php.ini setting oci8.privileged_connect should be enabled to use this.
OCI_TEMP_BLOB | Used with OCILob::writeTemporary to indicate that a temporary BLOB should be created.
OCI_TEMP_CLOB | Used with OCILob::writeTemporary to indicate that a temporary CLOB should be created.
OCI8 Bind and Define Types
Constant | Description
OCI_B_BFILE | Used with oci_bind_by_name() when binding BFILEs.
OCI_B_BIN | Used with oci_bind_by_name() to bind RAW values.
OCI_B_BLOB | Used with oci_bind_by_name() when binding BLOBs.
OCI_B_BOL | Used with oci_bind_by_name() to bind a PL/SQL BOOLEAN variable.
OCI_B_CFILEE | Used with oci_bind_by_name() when binding CFILEs.
OCI_B_CLOB | Used with oci_bind_by_name() when binding CLOBs.
OCI_B_CURSOR | Used with oci_bind_by_name() when binding cursors, previously allocated with oci_new_descriptor().
OCI_B_INT | Used with oci_bind_array_by_name() to bind arrays of INTEGER.
OCI_B_NTY | Used with oci_bind_by_name() when binding named data types. Note: in PHP < 5.0 it was called OCI_B_SQLT_NTY.
OCI_B_NUM | Used with oci_bind_array_by_name() to bind arrays of NUMBER.
OCI_B_ROWID | Used with oci_bind_by_name() when binding ROWIDs.
SQLT_AFC | Used with oci_bind_array_by_name() to bind arrays of CHAR.
SQLT_AVC | Used with oci_bind_array_by_name() to bind arrays of VARCHAR2.
SQLT_BDOUBLE | Not supported.
SQLT_BFILEE | The same as OCI_B_BFILE.
SQLT_BFLOAT | Not supported.
SQLT_BIN | The same as OCI_B_BIN.
SQLT_BLOB | The same as OCI_B_BLOB.
SQLT_BOL | The same as OCI_B_BOL.
SQLT_CFILEE | The same as OCI_B_CFILEE.
SQLT_CHR | Used with oci_bind_array_by_name() to bind arrays of VARCHAR2. Also used with oci_bind_by_name().
SQLT_CLOB | The same as OCI_B_CLOB.
SQLT_FLT | Used with oci_bind_array_by_name() to bind arrays of FLOAT.
SQLT_INT | The same as OCI_B_INT.
SQLT_LBI | Used with oci_bind_by_name() to bind LONG RAW values.
SQLT_LNG | Used with oci_bind_by_name() to bind LONG values.
SQLT_LVC | Used with oci_bind_array_by_name() to bind arrays of LONG VARCHAR.
SQLT_NTY | The same as OCI_B_NTY.
SQLT_NUM | The same as OCI_B_NUM.
SQLT_ODT | Used with oci_bind_array_by_name() to bind arrays of LONG.
SQLT_RDD | The same as OCI_B_ROWID.
SQLT_RSET | The same as OCI_B_CURSOR.
SQLT_STR | Used with oci_bind_array_by_name() to bind arrays of STRING.
SQLT_UIN | Not supported.
SQLT_VCS | Used with oci_bind_array_by_name() to bind arrays of VARCHAR.
OCI8 Descriptor Types
Constant | Description
OCI_DTYPE_FILE | This flag tells oci_new_descriptor() to initialize a new FILE descriptor.
OCI_DTYPE_LOB | This flag tells oci_new_descriptor() to initialize a new LOB descriptor.
OCI_DTYPE_ROWID | This flag tells oci_new_descriptor() to initialize a new ROWID descriptor.
OCI_D_FILE | The same as OCI_DTYPE_FILE.
OCI_D_LOB | The same as OCI_DTYPE_LOB.
OCI_D_ROWID | The same as OCI_DTYPE_ROWID.


范例

These examples connect as the HR user, which is the sample "Human Resources" schema supplied with the Oracle database. The account may need to be unlocked and the password reset before you can use it.

The examples connect to the XE database on your machine. Change the connect string to your database before running the examples.

Example #1 Basic query

This shows querying and displaying results. Statements in OCI8 use a prepare-execute-fetch sequence of steps.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Prepare the statement
$stid = oci_parse($conn, 'SELECT * FROM departments');
if (!$stid) {
    $e = oci_error($conn);
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Perform the logic of the query
$r = oci_execute($stid);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Fetch the results of the query
print "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    print "<tr>\n";
    foreach ($row as $item) {
        print "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    print "</tr>\n";
}
print "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Example #2 Inserting with bind variables

Bind variables improve performance by allowing reuse of execution contexts and caches. Bind variables improve security by preventing some kinds of SQL Injection problems.

<?php

// Before running, create the table:
//   CREATE TABLE MYTABLE (mid NUMBER, myd VARCHAR2(20));

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'INSERT INTO MYTABLE (mid, myd) VALUES(:myid, :mydata)');

$id = 60;
$data = 'Some data';

oci_bind_by_name($stid, ':myid', $id);
oci_bind_by_name($stid, ':mydata', $data);

$r = oci_execute($stid);  // executes and commits

if ($r) {
    print "One row inserted";
}

oci_free_statement($stid);
oci_close($conn);

?>

Example #3 Binding in the WHERE clause of a query

This shows a single scalar bind.

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE department_id = :didbv ORDER BY last_name';
$stid = oci_parse($conn, $sql);
$didbv = 60;
oci_bind_by_name($stid, ':didbv', $didbv);
oci_execute($stid);
while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['LAST_NAME'] ."<br>\n";
}

// Output is
//    Austin
//    Ernst
//    Hunold
//    Lorentz
//    Pataballa

oci_free_statement($stid);
oci_close($conn);

?>

Example #4 Inserting and fetching a CLOB

For large data use binary long object (BLOB) or character long object (CLOB) types. This example uses CLOB.

<?php

// Before running, create the table:
//     CREATE TABLE MYTABLE (mykey NUMBER, myclob CLOB);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$mykey = 12343;  // arbitrary key for this example;

$sql = "INSERT INTO mytable (mykey, myclob)
        VALUES (:mykey, EMPTY_CLOB())
        RETURNING myclob INTO :myclob";

$stid = oci_parse($conn, $sql);
$clob = oci_new_descriptor($conn, OCI_D_LOB);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_bind_by_name($stid, ":myclob", $clob, -1, OCI_B_CLOB);
oci_execute($stid, OCI_NO_AUTO_COMMIT); // use OCI_DEFAULT for PHP <= 5.3.1
$clob->save("A very long string");

oci_commit($conn);

// Fetching CLOB data

$query = 'SELECT myclob FROM mytable WHERE mykey = :mykey';

$stid = oci_parse ($conn, $query);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_execute($stid);

print '<table border="1">';
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) {
    print '<tr><td>'.$row['MYCLOB'].'</td></tr>';
    // In a loop, freeing the large variable before the 2nd fetch reduces PHP's peak memory usage
    unset($row);
}
print '</table>';

?>

Example #5 Using a PL/SQL stored function

You must bind a variable for the return value and optionally for any PL/SQL function arguments.

<?php

/*
  Before running the PHP program, create a stored function in
  SQL*Plus or SQL Developer:

  CREATE OR REPLACE FUNCTION myfunc(p IN NUMBER) RETURN NUMBER AS
  BEGIN
      RETURN p * 3;
  END;

*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$p = 8;

$stid = oci_parse($conn, 'begin :r := myfunc(:p); end;');
oci_bind_by_name($stid, ':p', $p);
oci_bind_by_name($stid, ':r', $r, 40);

oci_execute($stid);

print "$r\n";   // prints 24

oci_free_statement($stid);
oci_close($conn);

?>

Example #6 Using a PL/SQL stored procedure

With stored procedures, you should bind variables for any arguments.

<?php

/*
  Before running the PHP program, create a stored procedure in
  SQL*Plus or SQL Developer:

  CREATE OR REPLACE PROCEDURE myproc(p1 IN NUMBER, p2 OUT NUMBER) AS
  BEGIN
      p2 := p1 * 2;
  END;

*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$p1 = 8;

$stid = oci_parse($conn, 'begin myproc(:p1, :p2); end;');
oci_bind_by_name($stid, ':p1', $p1);
oci_bind_by_name($stid, ':p2', $p2, 40);

oci_execute($stid);

print "$p2\n";   // prints 16

oci_free_statement($stid);
oci_close($conn);

?>

Example #7 Calling a PL/SQL function that returns a REF CURSOR

Each returned value from the query is a REF CURSOR that can be fetched from.

<?php
/*
  Create the PL/SQL stored function as:

  CREATE OR REPLACE FUNCTION myfunc(p1 IN NUMBER) RETURN SYS_REFCURSOR AS
      rc SYS_REFCURSOR;
  BEGIN
      OPEN rc FOR SELECT city FROM locations WHERE ROWNUM < p1;
      RETURN rc;
  END;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT myfunc(5) AS mfrc FROM dual');
oci_execute($stid);

echo "<table border='1'>\n";
while (($row = oci_fetch_array($stid, OCI_ASSOC))) {
    echo "<tr>\n";
    $rc = $row['MFRC'];
    oci_execute($rc);  // returned column value from the query is a ref cursor
    while (($rc_row = oci_fetch_array($rc, OCI_ASSOC))) {
        echo "    <td>" . $rc_row['CITY'] . "</td>\n";
    }
    oci_free_statement($rc);
    echo "</tr>\n";
}
echo "</table>\n";

// Output is:
//   Beijing
//   Bern
//   Bombay
//   Geneva

oci_free_statement($stid);
oci_close($conn);

?>


OCI8 Connection Handling and Connection Pooling

Connection Functions

The OCI8 extension provides three different functions for connecting to Oracle. The standard connection function is oci_connect(). This creates a connection to an Oracle database and returns a resource used by subsequent database calls.

Connecting to an Oracle server is a reasonably expensive operation in terms of the time that it takes to complete. The oci_pconnect() function uses a persistent cache of connections that can be re-used across different script requests. This means that the connection overhead will typically only occur once per PHP process (or Apache child).

If the application connects to Oracle using a different set of database credentials for each web user, the persistent cache employed by oci_pconnect() will become less useful as the number of concurrent users increases, to the point where it may start to adversely affect the overall performance of the Oracle server due to maintaining too many idle connections. If the application is structured in this way, it is recommended to either tune the application using the oci8.max_persistent and oci8.persistent_timeout configuration settings (these will give control over the persistent connection cache size and lifetime), use Oracle Database Resident Connection Pooling (in Oracle Database 11g or later), or use oci_connect() instead.

Both oci_connect() and oci_pconnect() employ a connection cache; if multiple calls to oci_connect() use the same parameters in a given script, the second and subsequent calls return the existing connection handle. The cache used by oci_connect() is cleaned up at the end of the script run, or when the connection handle is explicitly closed. The function oci_pconnect() has similar behavior, although its cache is maintained separately and survives between HTTP requests.

This caching feature means the two handles are not transactionally isolated (they are in fact the same connection handle, so there is no isolation of any kind). If the application needs two separate, transactionally isolated connections, then use oci_new_connect().

The oci_pconnect() cache is cleared and any database connections closed when the PHP process terminates, so effective use of persistent connections requires that PHP be an Apache module or used with FPM, or similar. Persistent connections will not have any benefits over oci_connect() when PHP is used with CGI or via the command-line.

The function oci_new_connect() always creates a new connection to the Oracle server, regardless of what other connections might already exist. High traffic web applications should avoid using oci_new_connect(), especially in the busiest sections of the application.

From OCI8 1.3, persistent connections can be closed by the user, allowing greater control over connection resource usage. Persistent connections will now also be closed automatically when there is no PHP variable referencing them, such as at the end of scope of a PHP user function. This will rollback any uncommitted transaction. These changes to persistent connections make them behave similarly to non-persistent connections, simplifying the interface, allowing for greater application consistency and predictability. Use oci8.old_oci_close_semantics set to On to retain the historical behavior.

The automatic re-establishment of PHP persistent connections after an Apache or FPM process respawns means Oracle Database LOGON triggers are only recommended for setting session attributes and not for per-application user connection requests.

DRCP Connection Pooling

PHP from 5.3 (PECL OCI8 1.3) supports Oracle Database Resident Connection Pooling (DRCP). DRCP allows more efficient use of database machine memory and provides high scalability. No, or minimal, application changes are needed to use DRCP.

DRCP is suited for applications that connect using few database schemas and hold database connections open for a short period of time. Other applications should use Oracle's default Dedicated database server processes, or use Shared servers.

DRCP benefits all three connection functions, but gives the highest scalability when connections are created with oci_pconnect().

For DRCP to be available in OCI8, Oracle client libraries used by PHP and the version of the Oracle Database must both be 11g or greater.

Documentation on DRCP is found in several Oracle manuals. For example, see » Configuring Database Resident Connection Pooling in the Oracle documentation for usage information. A » DRCP white paper contains background information on DRCP.

To use DRCP, install the OCI8 1.3 (or later) extension and Oracle 11g (or later) libraries and then follow these steps:

  • As a privileged database administrator, use a program like SQL*Plus to start the connection pool in the database:

        SQL> execute dbms_connection_pool.start_pool;

  • Optionally use dbms_connection_pool.alter_param() to configure DRCP settings. The current pool settings can be queried from the DBA_CPOOL_INFO view.

  • Update the connection strings used. For PHP applications that currently connect using a Network Connect Name like MYDB:

        $c = oci_pconnect("myuser", "mypassword", "MYDB");

    modify the tnsnames.ora file and add a (SERVER=POOLED) clause, for example:

        MYDB = (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp) (HOST=myhost.dom.com)
           (PORT=1521))(CONNECT_DATA=(SERVICE_NAME=sales)
           (SERVER=POOLED)))

    Alternatively, modify the Easy Connect syntax in PHP and add :POOLED after the service name:

        $c = oci_pconnect("myuser", "mypassword", "myhost.dom.com:1521/sales:POOLED");

  • Edit php.ini and choose a connection class name. This name indicates a logical division of the connection pool and can be used to isolate pooling for separate applications. Any PHP applications with the same user name and connection class value will be able to share connections in the pool, giving greater scalability.

        oci8.connection_class = "MY_APPLICATION_NAME"

  • Run the application, connecting to the 11g (or later) database.

Note:

Applications using Oracle Client libraries 10g that require the performance of persistent connections can reduce the amount of database server memory needed by using Oracle Shared servers (previously known as Multi Threaded Servers). Refer to Oracle documentation for information.

Note:

Changing a password over DRCP connections will fail with the error ORA-56609: Usage not supported with DRCP. This is a documented restriction of Oracle Database 11g.


OCI8 Fast Application Notification (FAN) Support

FAN support gives fast connection failover, an Oracle Database high availability feature. This allows PHP OCI8 scripts to be notified when a database machine or database instance becomes unavailable. Without FAN, OCI8 can hang until a TCP timeout occurs and an error is returned, which might be several minutes. Enabling FAN in OCI8 can allow applications to detect errors and re-connect to an available database instance without the web user being aware of an outage.

FAN support is available when the Oracle client libraries that PHP links with and the Oracle Database are either version 10gR2 or later.

FAN benefits users of Oracle's clustering technology (RAC) because connections to surviving database instances can be immediately made. Users of Oracle's Data Guard with a broker will see the FAN events generated when the standby database goes online. Standalone databases will send FAN events when the database restarts.

For active connections, when a machine or database instance becomes unavailable, a connection failure error will be returned by the OCI8 extension function currently being called. On a subsequent PHP script re-connect, a connection to a surviving database instance will be established. The OCI8 extension also transparently cleans up any idle connections affected by a database machine or instance failure so PHP connect calls will establish a fresh connection without the script being aware of any service disruption.

When oci8.events is On, it is suggested to set oci8.ping_interval to -1 to disable pinging, since enabling FAN events provide pro-active connection management of idle connections made invalid by a service disruption.

To enable FAN support in PHP OCI8, build PHP OCI8 with Oracle 10gR2 or later libraries and then follow these steps:

  • As a privileged database administrator, use a program like SQL*Plus to enable the database service to post FAN events, for example:

        SQL> execute dbms_service.modify_service(
                   SERVICE_NAME        => 'sales',
                   AQ_HA_NOTIFICATIONS => TRUE);

  • Edit php.ini and add

        oci8.events = On

  • If the application does not already handle OCI8 error conditions, modify it to detect failures and take appropriate action. This may include re-connecting and re-executing statements.
  • Run the application, connecting to Oracle Database 10gR2 or later.


OCI8 Transparent Application Failover (TAF) Support

TAF is an Oracle Database feature that provides high availability. It enables PHP OCI8 applications to automatically reconnect to a preconfigured database when database connectivity fails due to instance or network failure.

In a configured Oracle Database system, TAF occurs when the PHP application detects that the database instance is down or unreachable. It establishes a connection to another node in an Oracle » RAC configuration, a hot standby database, or the same database instance itself. See » Oracle Call Interface Programmer's Guide for more information about OCI TAF.

An application callback can be registered with oci_register_taf_callback(). During failover, normal application processing stops and the registered callback is invoked. The callback notifies the application of the failover events. If the failover succeeds, normal processing will be resumed. If the failover aborts, any following database operations in the application will fail due to no connection being available.

When a connection fails over to another database, the callback can reset any necessary connection state, for example replaying any necessary ALTER SESSION commands if the database service did not have -failover_restore enabled.

An application callback can be removed by calling oci_unregister_taf_callback().

Configuring Transparent Application Failover

TAF can be configured on the PHP OCI8 side or in the database configuration. If both are configured, database-side settings take precedence.

Configure TAF in PHP OCI8 (the client side) by including the FAILOVER_MODE parameter in the CONNECT_DATA portion of a connect descriptor. See Configuring Transparent Application Failover in » Oracle Database Net Services Administrator's Guide for more information about client side configuration of TAF.

An example tnsnames.ora to configure TAF reconnecting to the same database instance:

    ORCL =
      (DESCRIPTION =
        (ADDRESS = (PROTOCOL = TCP)(HOST = 127.0.0.1)(PORT = 1521))
        (CONNECT_DATA =
          (SERVICE_NAME = orclpdb1)
          (FAILOVER_MODE =
            (TYPE = SELECT)
            (METHOD = BASIC)
            (RETRIES = 20)
            (DELAY = 15))))

Alternatively configure TAF on the database side by modifying the target service with » srvctl (for RAC) or the » DBMS_SERVICE.MODIFY_SERVICE packaged procedure (for single instance databases).

Using TAF Callbacks in OCI8

A TAF callback is an application function that can be registered to be called during failover. It is called several times while re-establishing the application's connection.

Callback first occurs when a loss of connection is detected. This allows the application to act accordingly for the upcoming delay of the failover. If the failover is successful, the callback is invoked after connection is re-established and usable. At this time, the application can resynchronize session settings and take actions such as informing the user that failover occurred. If failover is unsuccessful, a callback occurs to inform the application that a failover did not take place and the connection is unusable.

The interface of a TAF user-defined callback function is as follows:

userCallbackFn ( resource $connection , int $event , int $type ) : int

connection

The Oracle connection on which the TAF callback was registered via oci_register_taf_callback(). The connection is not valid until the failover completes successfully.

event

The failover event indicates the current status of the failover.

  • OCI_FO_BEGIN indicates that failover has detected a lost connection and failover is starting.

  • OCI_FO_END indicates successful completion of failover.

  • OCI_FO_ABORT indicates that failover was unsuccessful, and there is no option of retrying.

  • OCI_FO_ERROR also indicates that failover was unsuccessful, but it gives the application the opportunity to handle the error and return OCI_FO_RETRY to retry failover.

  • OCI_FO_REAUTH indicates that an Oracle user has been re-authenticated.

type

The failover type. This lets the callback know what type of failover the application has requested. The usual values are as follows:

  • OCI_FO_SESSION indicates that the user has requested only session failover. For example, if a user's connection is lost, then a new session is automatically created for the user on the backup. This type of failover does not attempt to recover SELECTs.

  • OCI_FO_SELECT indicates that the user has requested SELECT failover as well. It allows users with open cursors to continue fetching from them after failure.

return value

  • 0 indicates the failover steps should continue normally.

  • OCI_FO_RETRY indicates that the failover should be attempted again by Oracle. In case of an error while failing over to a new connection, TAF is able to retry the failover. Typically, the application code should sleep for a while before returning OCI_FO_RETRY.

The following example registers a TAF callback

<?php

// Define userspace callback
class MyClass {
    public static $retry_count;
    public static function TAFCallback($conn, $event, $type)
    {
        switch ($event) {
            case OCI_FO_BEGIN:
                printf(" Failing Over ... Please stand by\n");
                printf(" Failover type was found to be %s \n",
                       (($type==OCI_FO_SESSION) ? "SESSION"
                        :(($type==OCI_FO_SELECT) ? "SELECT" : "UNKNOWN!")));
                self::$retry_count = 0;
                break;
            case OCI_FO_ABORT:
                // The application cannot continue using the database
                printf(" Failover aborted. Failover will not take place.\n");
                break;
            case OCI_FO_END:
                // Failover completes successfully. Inform users a failover occurs.
                printf(" Failover ended ... resuming services\n");
                break;
            case OCI_FO_REAUTH:
                printf(" Failed over user ... resuming services\n");
                // Replay any ALTER SESSION commands associated with this connection
                // eg. oci_parse($conn, 'ALTER SESSION ...') ;
                break;
            case OCI_FO_ERROR:
                // Stop retrying if we have already attempted for 20 times.
                if (self::$retry_count >= 20)
                    return 0;
                printf(" Failover error received. Sleeping...\n");
                sleep(10);
                self::$retry_count++;
                return OCI_FO_RETRY; // retry failover
                break;
            default:
                printf("Bad Failover Event: %d.\n", $event);
                break;
        }
        return 0;
    }
}

$fn_name = 'MyClass::TAFCallback';

$conn = oci_connect('hr', 'welcome', 'orcl');
$sysconn = oci_connect('system', 'oracle', 'orcl');

// Use a privileged connection to construct a SQL statement that will initiate failover
$sql = <<< 'END'
select unique 'alter system disconnect session '''||sid||','||serial#||''''
from v$session_connect_info
where sid = sys_context('USERENV', 'SID')
END;

$s = oci_parse($conn, $sql);
oci_execute($s);
$r = oci_fetch_array($s);
$disconnectssql = $r[0];

oci_register_taf_callback($conn, $fn_name); // Register TAFCallback to Oracle TAF

print("Parsing user query\n");
$sql = "select systimestamp from dual";
$stmt = oci_parse($conn, $sql);

// For example, if a connection loss occurs at this point, oci_execute() will
// detect the loss and failover begins. During failover, oci_execute() will
// invoke the TAF callback function several times. If the failover is successful,
// a new connection is transparently created and oci_execute() will continue as
// usual. The connection session settings can be reset in the TAF callback
// function. If the failover is aborted, oci_execute() will return an error
// because a valid connection is not available.

// Disconnect the user, which initiates failover
print("Disconnecting the user\n");
$discsql = oci_parse($sysconn, $disconnectssql);
oci_execute($discsql);

print("Executing user query\n");
$e = oci_execute($stmt);
if (!$e) {
    $m = oci_error($stmt);
    trigger_error("Could not execute statement: ". $m['message'], E_USER_ERROR);
}
$row = oci_fetch_array($stmt);
print($row[0] . "\n");

// do other SQL statements with the new connection, if it is valid
// $stmt = oci_parse($conn,  . . .);

?>

See Also

  • oci_register_taf_callback()
  • oci_unregister_taf_callback()


OCI8 and DTrace Dynamic Tracing

OCI8 2.0 introduced static DTrace probes that can be used on operating systems that support DTrace. See DTrace Dynamic Tracing for an overview of PHP and DTrace.

Installing OCI8 with DTrace Support

To enable DTrace support in PHP OCI8, build OCI8 as a shared extension after setting PHP_DTRACE.

$ export PHP_DTRACE=yes
$ pecl install oci8

Edit php.ini, set extension_dir to the directory with the created oci8.so and also enable the extension by adding:

extension=oci8.so

If you install PHP OCI8 from PECL using phpize and configure (instead of pecl), you will still need to set PHP_DTRACE=yes. This is because the --enable-dtrace option will be ignored by the limited configure script of a PECL bundle.

See Installation of PECL extensions for general PECL installation instructions.

DTrace Static Probes in PHP OCI8

The following static probes are available in PHP OCI8
Probe Name | Probe Description | Probe Arguments
oci8-connect-entry | Initiated by oci_connect(), oci_pconnect() and oci_new_connect(). Fires before database connection is established. | char *username, char *dbname, char *charset, long session_mode, int persistent, int exclusive
oci8-connect-return | Fires at the end of connection. | void *connection
oci8-check-connection | Fires if an Oracle error might have caused the connection to become invalid. | void *connection, char *client_id, int is_open, long errcode, unsigned long server_status
oci8-sqltext | Fires when oci_parse() is executed. | void *connection, char *client_id, void *statement, char *sql
oci8-connection-close | Fires when the connection to the database is completely destroyed. | void *connection
oci8-error | Fires if an Oracle error occurs. | int status, long errcode
oci8-execute-mode | Fires at oci_execute() to show the execution mode. | void *connection, char *client_id, void *statement, unsigned int mode

These probes are useful for tracing OCI8 scripts.

The connection and statement are the pointers to internal structures used for tracking PHP connections and executed statements.

The client_id is the value set by oci_set_client_identifier().

Core PHP also has static probes. See DTrace Static Probes in Core PHP.

Internal Debugging DTrace Probes in OCI8
Probe Name
oci8-connect-expiry
oci8-connect-lookup
oci8-connect-p-dtor-close
oci8-connect-p-dtor-release
oci8-connect-type
oci8-sesspool-create
oci8-sesspool-stats
oci8-sesspool-type

These probes are useful for OCI8 maintainers. Refer to the OCI8 source code for arguments and to see when the will fire.

Listing DTrace Static Probes in PHP OCI8

To list available probes, start a PHP process and then run:

# dtrace -l

The output will be similar to:

   ID   PROVIDER            MODULE                          FUNCTION NAME
   [ . . . ]
   17 phpoci22116           oci8.so   php_oci_dtrace_check_connection oci8-check-connection
   18 phpoci22116           oci8.so                php_oci_do_connect oci8-connect-entry
   19 phpoci22116           oci8.so         php_oci_persistent_helper oci8-connect-expiry
   20 phpoci22116           oci8.so             php_oci_do_connect_ex oci8-connect-lookup
   21 phpoci22116           oci8.so  php_oci_pconnection_list_np_dtor oci8-connect-p-dtor-close
   22 phpoci22116           oci8.so  php_oci_pconnection_list_np_dtor oci8-connect-p-dtor-release
   23 phpoci22116           oci8.so                php_oci_do_connect oci8-connect-return
   24 phpoci22116           oci8.so             php_oci_do_connect_ex oci8-connect-type
   25 phpoci22116           oci8.so          php_oci_connection_close oci8-connection-close
   26 phpoci22116           oci8.so                     php_oci_error oci8-error
   27 phpoci22116           oci8.so         php_oci_statement_execute oci8-execute-mode
   28 phpoci22116           oci8.so              php_oci_create_spool oci8-sesspool-create
   29 phpoci22116           oci8.so            php_oci_create_session oci8-sesspool-stats
   30 phpoci22116           oci8.so            php_oci_create_session oci8-sesspool-type
   31 phpoci22116           oci8.so          php_oci_statement_create oci8-sqltext

The Provider column values consist of phpoci and the process id of the currently running PHP process.

The Function column refers to PHP's internal C implementation function names where each provider is located.

If a PHP process is not running, then no PHP probes will be shown.

DTrace with PHP OCI8 Example

This example shows the basics of the DTrace D scripting language.

Example #1 user_oci8_probes.d for tracing all user-level PHP OCI8 Static Probes with DTrace

#!/usr/sbin/dtrace -Zs

#pragma D option quiet

php*:::oci8-connect-entry
{
    printf("%lld: PHP connect-entry\n", walltimestamp);
    printf("  credentials=\"%s@%s\"\n", arg0 ? copyinstr(arg0) : "", arg1 ? copyinstr(arg1) : "");
    printf("  charset=\"%s\"\n", arg2 ? copyinstr(arg2) : "");
    printf("  session_mode=%ld\n", (long)arg3);
    printf("  persistent=%d\n", (int)arg4);
    printf("  exclusive=%d\n", (int)arg5);
}

php*:::oci8-connect-return
{
    printf("%lld: PHP oci8-connect-return\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
}

php*:::oci8-connection-close
{
    printf("%lld: PHP oci8-connect-close\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
}

php*:::oci8-error
{
    printf("%lld: PHP oci8-error\n", walltimestamp);
    printf("  status=%d\n", (int)arg0);
    printf("  errcode=%ld\n", (long)arg1);
}

php*:::oci8-check-connection
{
    printf("%lld: PHP oci8-check-connection\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  is_open=%d\n", arg2);
    printf("  errcode=%ld\n", (long)arg3);
    printf("  server_status=%lu\n", (unsigned long)arg4);
}

php*:::oci8-sqltext
{
    printf("%lld: PHP oci8-sqltext\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  statement=0x%p\n", (void *)arg2);
    printf("  sql=\"%s\"\n", arg3 ? copyinstr(arg3) : "");
}

php*:::oci8-execute-mode
{
    printf("%lld: PHP oci8-execute-mode\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  statement=0x%p\n", (void *)arg2);
    printf("  mode=0x%x\n", arg3);
}

This script uses the -Z option to dtrace, allowing it to be run when there is no PHP process executing. If this option were omitted the script would immediately terminate when no PHP executable was running because it knows none of the probes to be monitored are in existence.

On multi-CPU machines the probe ordering might not appear to be sequential. This depends on which CPU was processing the probes, and how threads migrate across CPUs. Displaying probe time stamps helps reduce confusion.

The script traces all user-level PHP OCI8 static probe points throughout the duration of a running PHP script. Run the D script:

# ./user_oci8_probes.d

Run a PHP script or application. The monitoring D script will output each probe's arguments as it fires. For example, a simple PHP script that queries a table might produce the following trace output:

1381794982092854582: PHP connect-entry
  credentials="hr@localhost/pdborcl"
  charset=""
  session_mode=0
  persistent=0
  exclusive=0
1381794982183158766: PHP oci8-connect-return
  connection=0x7f4a7907bfb8
1381794982183594576: PHP oci8-sqltext
  connection=0x7f4a7907bfb8
  client_id="Chris"
  statement=0x7f4a7907c2a0
  sql="select * from employees"
1381794982183783706: PHP oci8-execute-mode
  connection=0x7f4a7907bfb8
  client_id="Chris"
  statement=0x7f4a7907c2a0
  mode=0x20
1381794982444344390: PHP oci8-connect-close
  connection=0x7f4a7907bfb8

When monitoring is complete, the D script can be terminated with a ^C.

See Also

  • DTrace Dynamic Tracing


Supported Datatypes

The driver supports the following types when binding parameters using the oci_bind_by_name() function:
Type | Mapping
SQLT_NTY | Maps a native collection type from a PHP collection object, such as those created by oci_new_collection().
SQLT_BFILEE | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_CFILEE | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_CLOB | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_BLOB | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_RDD | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_NUM | Converts the PHP parameter to a 'C' long type, and binds to that value.
SQLT_RSET | Maps a native statement handle, such as those created by oci_parse() or those retrieved from other OCI queries.
SQLT_BOL | Bind the PHP parameter to a PL/SQL BOOLEAN
SQLT_CHR and any other type | Converts the PHP parameter to a string type and binds as a string.
The following types are supported when retrieving columns from a result set:
Type | Mapping
SQLT_RSET | Creates an oci statement resource to represent the cursor.
SQLT_RDD | Creates a ROWID object.
SQLT_BLOB | Creates a LOB object.
SQLT_CLOB | Creates a LOB object.
SQLT_BFILE | Creates a LOB object.
SQLT_LNG | Bound as SQLT_CHR, returned as a string
SQLT_LBI | Bound as SQLT_BIN, returned as a string
Any other type | Bound as SQLT_CHR, returned as a string


OCI8 函数

Table of Contents

  • oci_bind_array_by_name — Binds a PHP array to an Oracle PL/SQL array parameter
  • oci_bind_by_name — 绑定一个 PHP 变量到一个 Oracle 位置标志符
  • oci_cancel — 中断游标读取数据
  • oci_client_version — Returns the Oracle client library version
  • oci_close — 关闭 Oracle 连接
  • oci_commit — 提交未执行的事务处理
  • oci_connect — 建立一个到 Oracle 服务器的连接
  • oci_define_by_name — 在 SELECT 中使用 PHP 变量作为定义的步骤
  • oci_error — 返回上一个错误
  • oci_execute — 执行一条语句
  • oci_fetch_all — 获取结果数据的所有行到一个数组
  • oci_fetch_array — Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc — Returns the next row from a query as an associative array
  • oci_fetch_object — Returns the next row from a query as an object
  • oci_fetch_row — Returns the next row from a query as a numeric array
  • oci_fetch — Fetches the next row into result-buffer
  • oci_field_is_null — 检查字段是否为 null
  • oci_field_name — 返回字段名
  • oci_field_precision — 返回字段精度
  • oci_field_scale — 返回字段范围
  • oci_field_size — 返回字段大小
  • oci_field_type_raw — 返回字段的原始 Oracle 数据类型
  • oci_field_type — 返回字段的数据类型
  • oci_free_descriptor — Frees a descriptor
  • oci_free_statement — 释放关联于语句或游标的所有资源
  • oci_get_implicit_resultset — Returns the next child statement resource from a parent statement resource that has Oracle Database Implicit Result Sets
  • oci_lob_copy — Copies large object
  • oci_lob_is_equal — Compares two LOB/FILE locators for equality
  • oci_new_collection — 分配新的 collection 对象
  • oci_new_connect — 建定一个到 Oracle 服务器的新连接
  • oci_new_cursor — 分配并返回一个新的游标（语句句柄）
  • oci_new_descriptor — 初始化一个新的空 LOB 或 FILE 描述符
  • oci_num_fields — 返回结果列的数目
  • oci_num_rows — 返回语句执行后受影响的行数
  • oci_parse — 配置 Oracle 语句预备执行
  • oci_password_change — 修改 Oracle 用户的密码
  • oci_pconnect — 使用一个持久连接连到 Oracle 数据库
  • oci_register_taf_callback — Register a user-defined callback function for Oracle Database TAF
  • oci_result — 返回所取得行中字段的值
  • oci_rollback — 回滚未提交的事务
  • oci_server_version — 返回服务器版本信息
  • oci_set_action — Sets the action name
  • oci_set_call_timeout — Sets a millisecond timeout for database calls
  • oci_set_client_identifier — Sets the client identifier
  • oci_set_client_info — Sets the client information
  • oci_set_db_operation — Sets the database operation
  • oci_set_edition — Sets the database edition
  • oci_set_module_name — Sets the module name
  • oci_set_prefetch — 设置预提取行数
  • oci_statement_type — 返回 OCI 语句的类型
  • oci_unregister_taf_callback — Unregister a user-defined callback function for Oracle Database TAF


Binds a PHP array to an Oracle PL/SQL array parameter

  • ? OCI8 函数
  • oci_bind_by_name ?
  • PHP Manual
  • OCI8 函数
  • Binds a PHP array to an Oracle PL/SQL array parameter

oci_bind_array_by_name

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL OCI8 >= 1.2.0)

oci_bind_array_by_name — Binds a PHP array to an Oracle PL/SQL array parameter

说明

oci_bind_array_by_name ( resource $statement , string $name , array &$var_array , int $max_table_length , int $max_item_length = -1 , int $type = SQLT_AFC ) : bool

Binds the PHP array var_array to the Oracle placeholder name, which points to an Oracle PL/SQL array. Whether it will be used for input or output will be determined at run-time.

参数

statement

A valid OCI statement identifier.

name

The Oracle placeholder.

var_array

An array.

max_table_length

Sets the maximum length both for incoming and result arrays.

max_item_length

Sets maximum length for array items. If not specified or equals to -1, oci_bind_array_by_name() will find the longest element in the incoming array and will use it as the maximum length.

type

Should be used to set the type of PL/SQL array items. See list of available types below:

  • SQLT_NUM - for arrays of NUMBER.

  • SQLT_INT - for arrays of INTEGER (Note: INTEGER it is actually a synonym for NUMBER(38), but SQLT_NUM type won't work in this case even though they are synonyms).

  • SQLT_FLT - for arrays of FLOAT.

  • SQLT_AFC - for arrays of CHAR.

  • SQLT_CHR - for arrays of VARCHAR2.

  • SQLT_VCS - for arrays of VARCHAR.

  • SQLT_AVC - for arrays of CHARZ.

  • SQLT_STR - for arrays of STRING.

  • SQLT_LVC - for arrays of LONG VARCHAR.

  • SQLT_ODT - for arrays of DATE.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 oci_bind_array_by_name() example

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$create = "CREATE TABLE bind_example(name VARCHAR(20))";
$stid = oci_parse($conn, $create);
oci_execute($stid);

$create_pkg = "
CREATE OR REPLACE PACKAGE ARRAYBINDPKG1 AS
  TYPE ARRTYPE IS TABLE OF VARCHAR(20) INDEX BY BINARY_INTEGER;
  PROCEDURE iobind(c1 IN OUT ARRTYPE);
END ARRAYBINDPKG1;";
$stid = oci_parse($conn, $create_pkg);
oci_execute($stid);

$create_pkg_body = "
CREATE OR REPLACE PACKAGE BODY ARRAYBINDPKG1 AS
  CURSOR CUR IS SELECT name FROM bind_example;
  PROCEDURE iobind(c1 IN OUT ARRTYPE) IS
    BEGIN
    -- Bulk Insert
    FORALL i IN INDICES OF c1
      INSERT INTO bind_example VALUES (c1(i));

    -- Fetch and reverse
    IF NOT CUR%ISOPEN THEN
      OPEN CUR;
    END IF;
    FOR i IN REVERSE 1..5 LOOP
      FETCH CUR INTO c1(i);
      IF CUR%NOTFOUND THEN
        CLOSE CUR;
        EXIT;
      END IF;
    END LOOP;
  END iobind;
END ARRAYBINDPKG1;";
$stid = oci_parse($conn, $create_pkg_body);
oci_execute($stid);

$stid = oci_parse($conn, "BEGIN arraybindpkg1.iobind(:c1); END;");
$array = array("one", "two", "three", "four", "five");
oci_bind_array_by_name($stid, ":c1", $array, 5, -1, SQLT_CHR);
oci_execute($stid);

var_dump($array);

?>


绑定一个 PHP 变量到一个 Oracle 位置标志符

  • ? oci_bind_array_by_name
  • oci_cancel ?
  • PHP Manual
  • OCI8 函数
  • 绑定一个 PHP 变量到一个 Oracle 位置标志符

oci_bind_by_name

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_bind_by_name — 绑定一个 PHP 变量到一个 Oracle 位置标志符

说明

oci_bind_by_name ( resource $statement , string $bv_name , mixed &$variable , int $maxlength = -1 , int $type = SQLT_CHR ) : bool

将 PHP 变量 variable 绑定到 Oracle 位置标志符 bv_name。绑定操作对 Oracle 数据库性能很重要，同时也是避免 SQL 注入安全问题的一种方式。

oci_bind_by_name() 将 PHP 变量 variable 绑定到 Oracle 的位置标志符 ph_name。该变量是否会被用作输入输出是在运行时决定的，并且函数给该变量分配必要的存储空间。length 参数确定该绑定的最大长度，如果将 length 设为 -1，oci_bind_by_name() 会用 variable 变量的当前长度确定绑定的最大长度。

如果要绑定一个抽象数据类型（LOB/ROWID/BFILE），需要先用 oci_new_descriptor() 函数分配空间。length 没有用于抽象数据类型，应被设为 -1。type 参数告诉 Oracle 要使用什么样的描述符。可能的值为：

  • SQLT_FILE - 对应于 BFILE；

  • SQLT_CFILE - 对应于 CFILE；

  • SQLT_CLOB - 对应于 CLOB；

  • SQLT_BLOB - 对应于 BLOB；

  • SQLT_ROWID - 对应于 ROWID；

  • SQLT_NTY - 对应于有名字的数据类型；

  • SQLT_INT - 对应于 integers；

  • SQLT_CHR - 对应于 VARCHARs；

  • SQLT_BIN - 对应于 RAW 列；

  • SQLT_LNG - 对应于 LONG 列；

  • SQLT_LBI - 对应于 LONG RAW 列；

  • SQLT_RSET - 对应于游标，是之前由 oci_new_cursor() 创建的。

Example #1 oci_bind_by_name() 例子

<?php
/* oci_bind_by_name example thies at thieso dot net (980221)
  inserts 3 records into emp, and uses the ROWID for updating the
  records just after the insert.
*/

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "
                          INSERT INTO
                                     emp (empno, ename)
                                              VALUES
                                     (:empno,:ename)
                            RETURNING
                                     ROWID
                                 INTO
                                     :rid
                                         ");

$data = array(
              1111 => "Larry",
              2222 => "Bill",
              3333 => "Jim"
             );

$rowid = oci_new_descriptor($conn, OCI_D_ROWID);

oci_bind_by_name($stmt, ":empno", $empno, 32);
oci_bind_by_name($stmt, ":ename", $ename, 32);
oci_bind_by_name($stmt, ":rid",   $rowid, -1, OCI_B_ROWID);

$update = oci_parse($conn, "
                            UPDATE
                                  emp
                               SET
                                  sal = :sal
                             WHERE
                                  ROWID = :rid
                             ");
oci_bind_by_name($update, ":rid", $rowid, -1, OCI_B_ROWID);
oci_bind_by_name($update, ":sal", $sal,   32);

$sal = 10000;

foreach ($data as $empno => $ename) {
    oci_execute($stmt);
    oci_execute($update);
}

$rowid->free();

oci_free_statement($update);
oci_free_statement($stmt);

$stmt = oci_parse($conn, "
                          SELECT
                                *
                            FROM
                                emp
                           WHERE
                                empno
                              IN
                                (1111,2222,3333)
                              ");
oci_execute($stmt);

while ($row = oci_fetch_assoc($stmt)) {
    var_dump($row);
}

oci_free_statement($stmt);

/* delete our "junk" from the emp table.... */
$stmt = oci_parse($conn, "
                          DELETE FROM
                                     emp
                                WHERE
                                     empno
                                   IN
                                     (1111,2222,3333)
                                   ");
oci_execute($stmt);
oci_free_statement($stmt);

oci_close($conn);
?>

记住，本函数删除了行尾的空白字符。见以下例子：

Example #2 oci_bind_by_name() 例子

<?php
$connection = oci_connect('apelsin','kanistra');
$query = "INSERT INTO test_table VALUES(:id, :text)";

$statement = oci_parse($query);
oci_bind_by_name($statement, ":id", 1);
oci_bind_by_name($statement, ":text", "trailing spaces follow     ");
oci_execute($statement);
/*
 This code will insert into DB string 'trailing spaces follow', without
 trailing spaces
*/
?>

Example #3 oci_bind_by_name() 例子

<?php
$connection = oci_connect('apelsin','kanistra');
$query = "INSERT INTO test_table VALUES(:id, 'trailing spaces follow      ')";

$statement = oci_parse($query);
oci_bind_by_name($statement, ":id", 1);
oci_execute($statement);
/*
 And this code will add 'trailing spaces follow      ', preserving
 trailing whitespaces
*/
?>

Warning

不要将 magic_quotes_gpc 或 addslashes() 与 oci_bind_by_name() 同时使用，因为不需要转义，任何自动加上的引号都会被写入数据库中，因为 oci_bind_by_name() 不能分辨有意加上的引号和魔术引号。

成功时返回 true， 或者在失败时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocibindbyname() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_bind_by_name() 的别名。不过其已被废弃，不推荐使用。

参数

statement

A valid OCI8 statement identifer.

bv_name

The colon-prefixed bind variable placeholder used in the statement. The colon is optional in bv_name. Oracle does not use question marks for placeholders.

variable

The PHP variable to be associated with bv_name

maxlength

Sets the maximum length for the data. If you set it to -1, this function will use the current length of variable to set the maximum length. In this case the variable must exist and contain data when oci_bind_by_name() is called.

type

The datatype that Oracle will treat the data as. The default type used is SQLT_CHR. Oracle will convert the data between this type and the database column (or PL/SQL variable type), when possible.

If you need to bind an abstract datatype (LOB/ROWID/BFILE) you need to allocate it first using the oci_new_descriptor() function. The length is not used for abstract datatypes and should be set to -1.

Possible values for type are:

  • SQLT_BFILEE or OCI_B_BFILE - for BFILEs;

  • SQLT_CFILEE or OCI_B_CFILEE - for CFILEs;

  • SQLT_CLOB or OCI_B_CLOB - for CLOBs;

  • SQLT_BLOB or OCI_B_BLOB - for BLOBs;

  • SQLT_RDD or OCI_B_ROWID - for ROWIDs;

  • SQLT_NTY or OCI_B_NTY - for named datatypes;

  • SQLT_INT or OCI_B_INT - for integers;

  • SQLT_CHR - for VARCHARs;

  • SQLT_BIN or OCI_B_BIN - for RAW columns;

  • SQLT_LNG - for LONG columns;

  • SQLT_LBI - for LONG RAW columns;

  • SQLT_RSET - for cursors created with oci_new_cursor().

  • SQLT_BOL or OCI_B_BOL - for PL/SQL BOOLEANs (Requires OCI8 2.0.7 and Oracle Database 12c)

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #4 Inserting data with oci_bind_by_name()

<?php

// Create the table with:
//   CREATE TABLE mytab (id NUMBER, text VARCHAR2(40));

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn,"INSERT INTO mytab (id, text) VALUES(:id_bv, :text_bv)");

$id = 1;
$text = "Data to insert     ";
oci_bind_by_name($stid, ":id_bv", $id);
oci_bind_by_name($stid, ":text_bv", $text);
oci_execute($stid);

// Table now contains: 1, 'Data to insert     '

?>

Example #5 Binding once for multiple executions

<?php

// Create the table with:
//   CREATE TABLE mytab (id NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$a = array(1,3,5,7,11);  // data to insert

$stid = oci_parse($conn, 'INSERT INTO mytab (id) VALUES (:bv)');
oci_bind_by_name($stid, ':bv', $v, 20);
foreach ($a as $v) {
    $r = oci_execute($stid, OCI_DEFAULT);  // don't auto commit
}
oci_commit($conn); // commit everything at once

// Table contains five rows: 1, 3, 5, 7, 11

oci_free_statement($stid);
oci_close($conn);

?>

Example #6 Binding with a foreach() loop

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT * FROM departments WHERE department_name = :dname AND location_id = :loc';
$stid = oci_parse($conn, $sql);

$ba = array(':dname' => 'IT Support', ':loc' => 1700);

foreach ($ba as $key => $val) {

    // oci_bind_by_name($stid, $key, $val) does not work
    // because it binds each placeholder to the same location: $val
    // instead use the actual location of the data: $ba[$key]
    oci_bind_by_name($stid, $key, $ba[$key]);
}

oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);
foreach ($row as $item) {
    print $item."<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Example #7 Binding in a WHERE clause

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE department_id = :didbv ORDER BY last_name';
$stid = oci_parse($conn, $sql);
$didbv = 60;
oci_bind_by_name($stid, ':didbv', $didbv);
oci_execute($stid);
while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['LAST_NAME'] ."<br>\n";
}

// Output is
//    Austin
//    Ernst
//    Hunold
//    Lorentz
//    Pataballa

oci_free_statement($stid);
oci_close($conn);

?>

Example #8 Binding with a LIKE clause

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

// Find all cities that begin with 'South'
$stid = oci_parse($conn, "SELECT city FROM locations WHERE city LIKE :bv");
$city = 'South%';  // '%' is a wildcard in SQL
oci_bind_by_name($stid, ":bv", $city);
oci_execute($stid);
oci_fetch_all($stid, $res);

foreach ($res['CITY'] as $c) {
    print $c . "<br>\n";
}
// Output is
//   South Brunswick
//   South San Francisco
//   Southlake

oci_free_statement($stid);
oci_close($conn);

?>

Example #9 Binding with REGEXP_LIKE

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

// Find all cities that contain 'ing'
$stid = oci_parse($conn, "SELECT city FROM locations WHERE REGEXP_LIKE(city, :bv)");
$city = '.*ing.*';
oci_bind_by_name($stid, ":bv", $city);
oci_execute($stid);
oci_fetch_all($stid, $res);

foreach ($res['CITY'] as $c) {
    print $c . "<br>\n";
}
// Output is
//   Beijing
//   Singapore

oci_free_statement($stid);
oci_close($conn);

?>

For a small, fixed number of IN clause conditions, use individual bind variables. Values unknown at run time can be set to NULL. This allows a single statement to be used by all application users, maximizing Oracle DB cache efficiency.

Example #10 Binding Multiple Values in an IN Clause

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE employee_id in (:e1, :e2, :e3)';
$stid = oci_parse($conn, $sql);
$mye1 = 103;
$mye2 = 104;
$mye3 = NULL; // pretend we were not given this value
oci_bind_by_name($stid, ':e1', $mye1);
oci_bind_by_name($stid, ':e2', $mye2);
oci_bind_by_name($stid, ':e3', $mye3);
oci_execute($stid);
oci_fetch_all($stid, $res);
foreach ($res['LAST_NAME'] as $name) {
    print $name ."<br>\n";
}

// Output is
//   Ernst
//   Hunold

oci_free_statement($stid);
oci_close($conn);

?>

Example #11 Binding a ROWID returned by a query

<?php

// Create the table with:
//   CREATE TABLE mytab (id NUMBER, salary NUMBER, name VARCHAR2(40));
//   INSERT INTO mytab (id, salary, name) VALUES (1, 100, 'Chris');
//   COMMIT;

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT ROWID, name FROM mytab WHERE id = :id_bv FOR UPDATE');
$id = 1;
oci_bind_by_name($stid, ':id_bv', $id);
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);
$rid = $row['ROWID'];
$name = $row['NAME'];

// Change name to upper case & save the changes
$name = strtoupper($name);
$stid = oci_parse($conn, 'UPDATE mytab SET name = :n_bv WHERE ROWID = :r_bv');
oci_bind_by_name($stid, ':n_bv', $name);
oci_bind_by_name($stid, ':r_bv', $rid, -1, OCI_B_ROWID);
oci_execute($stid);

// The table now contains 1, 100, CHRIS

oci_free_statement($stid);
oci_close($conn);

?>

Example #12 Binding a ROWID on INSERT

<?php

// This example inserts an id & name, and then updates the salary
// Create the table with:
//   CREATE TABLE mytab (id NUMBER, salary NUMBER, name VARCHAR2(40));
//
// Based on original ROWID example by thies at thieso dot net (980221)

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = "INSERT INTO mytab (id, name) VALUES(:id_bv, :name_bv)
        RETURNING ROWID INTO :rid";

$ins_stid = oci_parse($conn, $sql);

$rowid = oci_new_descriptor($conn, OCI_D_ROWID);
oci_bind_by_name($ins_stid, ":id_bv",   $id,    10);
oci_bind_by_name($ins_stid, ":name_bv", $name,  32);
oci_bind_by_name($ins_stid, ":rid",     $rowid, -1, OCI_B_ROWID);

$sql = "UPDATE mytab SET salary = :salary WHERE ROWID = :rid";
$upd_stid = oci_parse($conn, $sql);
oci_bind_by_name($upd_stid, ":rid", $rowid, -1, OCI_B_ROWID);
oci_bind_by_name($upd_stid, ":salary", $salary,   32);

// ids and names to insert
$data = array(1111 => "Larry",
              2222 => "Bill",
              3333 => "Jim");

// Salary of each person
$salary = 10000;

// Insert and immediately update each row
foreach ($data as $id => $name) {
    oci_execute($ins_stid);
    oci_execute($upd_stid);
}

$rowid->free();
oci_free_statement($upd_stid);
oci_free_statement($ins_stid);

// Show the new rows
$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid);
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    var_dump($row);
}

oci_free_statement($stid);
oci_close($conn);

?>

Example #13 Binding for a PL/SQL stored function

<?php

//  Before running the PHP program, create a stored function in
//  SQL*Plus or SQL Developer:
//
//  CREATE OR REPLACE FUNCTION myfunc(p IN NUMBER) RETURN NUMBER AS
//  BEGIN
//      RETURN p * 3;
//  END;

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$p = 8;

$stid = oci_parse($conn, 'begin :r := myfunc(:p); end;');
oci_bind_by_name($stid, ':p', $p);

// The return value is an OUT bind. The default type will be a string
// type so binding a length 40 means that at most 40 digits will be
// returned.
oci_bind_by_name($stid, ':r', $r, 40);

oci_execute($stid);

print "$r\n";   // prints 24

oci_free_statement($stid);
oci_close($conn);

?>

Example #14 Binding parameters for a PL/SQL stored procedure

<?php

//  Before running the PHP program, create a stored procedure in
//  SQL*Plus or SQL Developer:
//
//  CREATE OR REPLACE PROCEDURE myproc(p1 IN NUMBER, p2 OUT NUMBER) AS
//  BEGIN
//      p2 := p1 * 2;
//  END;

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$p1 = 8;

$stid = oci_parse($conn, 'begin myproc(:p1, :p2); end;');
oci_bind_by_name($stid, ':p1', $p1);

// The second procedure parameter is an OUT bind. The default type
// will be a string type so binding a length 40 means that at most 40
// digits will be returned.
oci_bind_by_name($stid, ':p2', $p2, 40);

oci_execute($stid);

print "$p2\n";   // prints 16

oci_free_statement($stid);
oci_close($conn);

?>

Example #15 Binding a CLOB column

<?php

// Before running, create the table:
//     CREATE TABLE mytab (mykey NUMBER, myclob CLOB);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$mykey = 12343;  // arbitrary key for this example;

$sql = "INSERT INTO mytab (mykey, myclob)
        VALUES (:mykey, EMPTY_CLOB())
        RETURNING myclob INTO :myclob";

$stid = oci_parse($conn, $sql);
$clob = oci_new_descriptor($conn, OCI_D_LOB);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_bind_by_name($stid, ":myclob", $clob, -1, OCI_B_CLOB);
oci_execute($stid, OCI_DEFAULT);
$clob->save("A very long string");

oci_commit($conn);

// Fetching CLOB data

$query = 'SELECT myclob FROM mytab WHERE mykey = :mykey';

$stid = oci_parse ($conn, $query);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_execute($stid);

print '<table border="1">';
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) {
    print '<tr><td>'.$row['MYCLOB'].'</td></tr>';
    // In a loop, freeing the large variable before the 2nd fetch reduces PHP's peak memory usage
    unset($row);
}
print '</table>';

?>

Example #16 Binding a PL/SQL BOOLEAN

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$plsql =
  "begin
    :output1 := true;
    :output2 := false;
   end;";

$s = oci_parse($c, $plsql);
oci_bind_by_name($s, ':output1', $output1, -1, OCI_B_BOL);
oci_bind_by_name($s, ':output2', $output2, -1, OCI_B_BOL);
oci_execute($s);
var_dump($output1);  // true
var_dump($output2);  // false

?>

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Warning

Do not use magic_quotes_gpc or addslashes() and oci_bind_by_name() simultaneously as no quoting is needed. Any magically applied quotes will be written into your database because oci_bind_by_name() inserts data verbatim and does not remove quotes or escape characters.

Note:

If you bind a string to a CHAR column in a WHERE clause, remember that Oracle uses blank-padded comparison semantics for CHAR columns. Your PHP variable should be blank padded to the same width as the column for the WHERE clause to succeed.

Note:

The PHP variable argument is a reference. Some forms of loops do not work as expected:

<?php
foreach ($myarray as $key => $value)  {
    oci_bind_by_name($stid, $key, $value);
}
?>

This binds each key to the location of $value, so all bound variables end up pointing to the last loop iteration's value. Instead use the following:

<?php
foreach ($myarray as $key => $value) {
    oci_bind_by_name($stid, $key, $myarray[$key]);
}
?>

参见

  • oci_bind_array_by_name() - Binds a PHP array to an Oracle PL/SQL array parameter
  • oci_parse() - 配置 Oracle 语句预备执行


中断游标读取数据

  • ? oci_bind_by_name
  • oci_client_version ?
  • PHP Manual
  • OCI8 函数
  • 中断游标读取数据

oci_cancel

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_cancel — 中断游标读取数据

说明

oci_cancel ( resource $statement ) : bool

oci_cancel() 使一个游标无效，释放所有与之关联的资源并取消了从中读取的能力。

参数

statement

OCI 语句。

返回值

成功时返回 true， 或者在失败时返回 false。


Returns the Oracle client library version

  • ? oci_cancel
  • oci_close ?
  • PHP Manual
  • OCI8 函数
  • Returns the Oracle client library version

oci_client_version

(PHP 5 >= 5.3.7, PHP 7, PHP 8, PECL OCI8 >= 1.4.6)

oci_client_version — Returns the Oracle client library version

说明

oci_client_version ( ) : string

Returns a string containing the version number of the Oracle C client library that PHP is linked with.

参数

None

返回值

Returns the version number as a string.

范例

Example #1 oci_client_version() example

<?php
    echo "Client Version: " . oci_client_version(); // Client version: 19.9.0.0.0
?>

注释

Note:

Oracle libraries before 10gR2 do not have the underlying functionality to get the client library version number. The string "Unknown" will be returned in this case.

参见

  • oci_server_version() - 返回服务器版本信息


关闭 Oracle 连接

  • ? oci_client_version
  • oci_commit ?
  • PHP Manual
  • OCI8 函数
  • 关闭 Oracle 连接

oci_close

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_close — 关闭 Oracle 连接

说明

oci_close ( resource $connection ) : bool

oci_close() 将 Oracle 连接 connection 关闭。

Note:

自版本 1.1 起 oci_close() 正确关闭 Oracle 连接。使用 oci8.old_oci_close_semantics 选项来恢复本函数的旧行为。

成功时返回 true， 或者在失败时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocilogoff() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_close() 的别名。不过其已被废弃，不推荐使用。

参数

connection

An Oracle connection identifier returned by oci_connect(), oci_pconnect(), or oci_new_connect().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Closing a connection

Resources associated with a connection should be closed to ensure the underlying database connection is properly terminated and the database resources are released.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM departments');
$r = oci_execute($stid);
oci_fetch_all($stid, $res);
var_dump($res);

// Free the statement identifier when closing the connection
oci_free_statement($stid);
oci_close($conn);

?>

Example #2 Database connections are not closed until all references are closed

The internal refcount of a connection identifier must be zero before the underlying connection to the database is closed.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM departments');  // this increases the refcount on $conn
oci_execute($stid);
oci_fetch_all($stid, $res);
var_dump($res);

oci_close($conn);

// $conn is no long usable in the script but the underlying database
// connection is still held open until $stid is freed.
var_dump($conn);  // prints NULL

// While PHP sleeps, querying the Oracle V$SESSION view in a
// terminal window will show that the database user is still connected.
sleep(10);

// When $stid is freed, the database connection is physically closed
oci_free_statement($stid);

// While PHP sleeps, querying the Oracle V$SESSION view in a
// terminal window will show that the database user has disconnected.
sleep(10);

?>

Example #3 Closing a connection opened more than once

When database credentials are reused, both connections must be closed before the underlying database connection is closed.

<?php

$conn1 = oci_connect('hr', 'welcome', 'localhost/XE');

// Using the same credentials reuses the same underlying database connection
// Any uncommitted changes done on $conn1 will be visible in $conn2
$conn2 = oci_connect('hr', 'welcome', 'localhost/XE');

// While PHP sleeps, querying the Oracle V$SESSION view in a
// terminal window will show that only one database user is connected.
sleep(10);

oci_close($conn1); // doesn't close the underlying database connection
var_dump($conn1);  // prints NULL because the variable $conn1 is no longer usable
var_dump($conn2);  // displays that $conn2 is still a valid connection resource

?>

Example #4 Connections are closed when variables go out of scope

When all variables referencing a connection go out of scope and are freed by PHP, a rollback occurs (if necessary) and the underlying connection to the database is closed.

<?php

function myfunc() {
    $conn = oci_connect('hr', 'hrpwd', 'localhost/XE');
    if (!$conn) {
        $e = oci_error();
        trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
    }

    $stid = oci_parse($conn, 'UPDATE mytab SET id = 100');
    oci_execute($stid, OCI_NO_AUTO_COMMIT);
    return "Finished";
}

$r = myfunc();
// At this point a rollback occurred and the underlying database connection was released.

print $r;  // displays the function return value "Finished"

?>

注释

Note:

Variables that have a dependency on the connection identifier, such as statement identifiers returned by oci_parse(), must also be freed before the underlying database connection is closed.

Note:

Prior to version PHP 5.1.2 (PECL OCI8 1.1) oci_close() was a no-op. In more recent versions it correctly closes the Oracle connection. Use oci8.old_oci_close_semantics option to restore old behavior of this function.

Note:

The oci_close() function does not close the underlying database connections created with oci_pconnect().

Note:

In PHP versions before 5.0.0 you must use ocilogoff() instead.

参见

  • oci_connect() - 建立一个到 Oracle 服务器的连接
  • oci_free_statement() - 释放关联于语句或游标的所有资源


提交未执行的事务处理

  • ? oci_close
  • oci_connect ?
  • PHP Manual
  • OCI8 函数
  • 提交未执行的事务处理

oci_commit

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_commit — 提交未执行的事务处理

说明

oci_commit ( resource $connection ) : bool

oci_commit() 将 Oracle 连接 connection 上正在运行的事务中所有未执行的语句提交处理。

Example #1 oci_commit() 例子

<?php
    // Login to Oracle server
    $conn = oci_connect('scott', 'tiger');

    // Parse SQL
    $stmt = oci_parse($conn, "
                              INSERT INTO
                                         employees (name, surname)
                                   VALUES
                                         ('Maxim', 'Maletsky')
                             ");

    /* Execute statement
       OCI_DEFAULT tells oci_execute()
       not to commit statement immediately */
    oci_execute($stmt, OCI_DEFAULT);

    /*
    ....
    Parsing and executing other statements here ...
    ....
    */

    // Commit transaction
    $committed = oci_commit($conn);

    // Test whether commit was successful. If error occurred, return error message
    if (!$committed) {
        $error = oci_error($conn);
        echo 'Commit failed. Oracle reports: ' . $error['message'];
    }

?>

成功时返回 true， 或者在失败时返回 false。

Note:

当关闭连接或脚本结束时（看哪个先）事务会自动回卷。需要明确地调用 oci_commit() 来提交事务，或 oci_rollback() 来中止事务。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocicommit() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_commit() 的别名。不过其已被废弃，不推荐使用。

参见 oci_rollback() 和 oci_execute()。

参数

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect(), or oci_new_connect().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #2 oci_commit() example

<?php

// Insert into several tables, rolling back the changes if an error occurs

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, "INSERT INTO mysalary (id, name) VALUES (1, 'Chris')");

// The OCI_NO_AUTO_COMMIT flag tells Oracle not to commit the INSERT immediately
// Use OCI_DEFAULT as the flag for PHP <= 5.3.1.  The two flags are equivalent
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'INSERT INTO myschedule (startday) VALUES (12)');
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    oci_rollback($conn);  // rollback changes to both tables
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

// Commit the changes to both tables
$r = oci_commit($conn);
if (!r) {
    $e = oci_error($conn);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

?>

注释

Note:

Transactions are automatically rolled back when you close the connection, or when the script ends, whichever is soonest. You need to explicitly call oci_commit() to commit the transaction.

Any call to oci_execute() that uses OCI_COMMIT_ON_SUCCESS mode explicitly or by default will commit any previous uncommitted transaction.

Any Oracle DDL statement such as CREATE or DROP will automatically commit any uncommitted transaction.

Note:

In PHP versions before 5.0.0 you must use ocicommit() instead.

参见

  • oci_execute() - 执行一条语句
  • oci_rollback() - 回滚未提交的事务


建立一个到 Oracle 服务器的连接

  • ? oci_commit
  • oci_define_by_name ?
  • PHP Manual
  • OCI8 函数
  • 建立一个到 Oracle 服务器的连接

oci_connect

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_connect — 建立一个到 Oracle 服务器的连接

说明

oci_connect ( string $username , string $password , string $db = ? , string $charset = ? , int $session_mode = ? ) : resource

oci_connect() 返回一个大多数 OCI 调用都需要的连接标识符。可选的第三个参数可以包含想要连接的本地 Oracle 的实例的或者在 tnsnames.ora 中的条目的名字。如果没有指定可选的第三个参数，PHP 使用环境变量 ORACLE_SID（Oracle 实例）或 TWO_TASK（tnsnames.ora）来确定连接哪一个数据库。

session_mode 参数自版本 1.1 起可用并接受如下值：OCI_DEFAULT，OCI_SYSOPER 和 OCI_SYSDBA。如果指定了 OCI_SYSOPER 或 OCI_SYSDBA 其中之一，oci_connect() 将尝试使用外部认证信息建立特权连接。特权连接默认被禁止。要启用，需要将 oci8.privileged_connect 设为 On。

Note: 对 oci_connect() 用同样的参数第二次及之后的调用将返回第一次调用所返回的连接句柄。也就是说对一个句柄发出的查询也适用于另一个句柄，因为它们是同一个句柄。此行为演示于下面的例 1。如果需要两个句柄在事务上互相隔离开，应该使用 oci_new_connect() 来替代。

使用 Oracle 客户端库来确定字符集。字符集不需要与数据库的字符集相匹配。如果不匹配，Oracle 会尽可能地将数据从数据库字符集进行转换。因为依赖于字符集，可能不能给出可用的结果。转换也增加一些时间开销。

如果不指定，Oracle 客户端用 NLS_LANG 环境变量来决定字符集。

传递此参数可减少连接时间。

Example #1 oci_connect() 例子

<?php
echo "<pre>";
$db = "";

$c1 = oci_connect("scott", "tiger", $db);
$c2 = oci_connect("scott", "tiger", $db);

function create_table($conn)
{
  $stmt = oci_parse($conn, "create table scott.hallo (test varchar2(64))");
  oci_execute($stmt);
  echo $conn . " created table\n\n";
}

function drop_table($conn)
{
  $stmt = oci_parse($conn, "drop table scott.hallo");
  oci_execute($stmt);
  echo $conn . " dropped table\n\n";
}

function insert_data($conn)
{
  $stmt = oci_parse($conn, "insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " inserted hallo\n\n";
}

function delete_data($conn)
{
  $stmt = oci_parse($conn, "delete from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " deleted hallo\n\n";
}

function commit($conn)
{
  oci_commit($conn);
  echo $conn . " committed\n\n";
}

function rollback($conn)
{
  oci_rollback($conn);
  echo $conn . " rollback\n\n";
}

function select_data($conn)
{
  $stmt = oci_parse($conn, "select * from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn."----selecting\n\n";
  while (oci_fetch($stmt)) {
    echo $conn . " [" . oci_result($stmt, "TEST") . "]\n\n";
  }
  echo $conn . "----done\n\n";
}

create_table($c1);
insert_data($c1);   // Insert a row using c1
insert_data($c2);   // Insert a row using c2

select_data($c1);   // Results of both inserts are returned
select_data($c2);

rollback($c1);      // Rollback using c1

select_data($c1);   // Both inserts have been rolled back
select_data($c2);

insert_data($c2);   // Insert a row using c2
commit($c2);        // Commit using c2

select_data($c1);   // Result of c2 insert is returned

delete_data($c1);   // Delete all rows in table using c1
select_data($c1);   // No rows returned
select_data($c2);   // No rows returned
commit($c1);        // Commit using c1

select_data($c1);   // No rows returned
select_data($c2);   // No rows returned

drop_table($c1);
echo "</pre>";
?>

oci_connect() 如果出错则返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocilogon() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_connect() 的别名。不过其已被废弃，不推荐使用。

参见 oci_pconnect()，oci_new_connect() 和 oci_close()。

参数

username

The Oracle user name.

password

The password for username.

connection_string

包含要连接的 Oracle 实例。可以是 » Easy Connect 串，或是 tnsnames.ora 文件中的连接名，或是本地 Oracle 实例名。

如果不指定，PHP 使用环境变量来确定连接的 Oracle 实例，诸如 TWO_TASK（Linux 下）或 LOCAL（Windows 下）与 ORACLE_SID 等。

要使用 Easy Connect 命名方法，PHP 必须与 Oracle 10g 或更高版本的客户端库进行链接。Oracle 10g 的 Easy Connect 串格式：[//]host_name[:port][/service_name]。Oracle 11g 则为：[//]host_name[:port][/service_name][:server_type][/instance_name]。 在 Oracle 19c 加入类更多选项，例如 timeout 和 keep-alive 设置。 请参考 Oracle 文档。 服务名可在数据库服务器机器上运行 Oracle 实用程序 lsnrctl status 找到。

tnsnames.ora 文件可在 Oracle Net 查找路径中，此路径包括 /your/path/to/instantclient/network/admin、$ORACLE_HOME/network/admin 、/etc。 另一种方法是设置 TNS_ADMIN 以便通过 $TNS_ADMIN/tnsnames.ora 来读取。表确认 web 守护进程可读取此文件。

character_set

使用 Oracle 客户端库来确定字符集。字符集不需要与数据库的字符集相匹配。如果不匹配，Oracle 会尽可能地将数据从数据库字符集进行转换。因为依赖于字符集，可能不能给出可用的结果。转换也增加一些时间开销。

如果不指定，Oracle 客户端用 NLS_LANG 环境变量来决定字符集。

传递此参数可减少连接时间。

session_mode

此参数在 PHP 5（PECL OCI8 1.1）版本开始可用，并收受下列值：OCI_DEFAULT，OCI_SYSOPER 和 OCI_SYSDBA。如为 OCI_SYSOPER 或 OCI_SYSDBA 其中之一，此函数将会使用外部的证书建立有特权的连接。有特权的连接默认是禁用的。需要将 oci8.privileged_connect 设为 On 来启用。

PHP 5.3（PECL OCI8 1.3.4）引进了 OCI_CRED_EXT 模式值。使用外部或操作系统认证必需在 Oracle 数据库中进行配置。OCI_CRED_EXT 标志只可用于用户为 "/"，密码为空的情况。oci8.privileged_connect 可为 On 或 Off。

OCI_CRED_EXT 可与 OCI_SYSOPER 或 OCI_SYSDBA 模式组合使用。

OCI_CRED_EXT 由于安全的原因不支持 Windows 系统。

返回值

Returns a connection identifier or false on error.

范例

Example #2 Basic oci_connect() using Easy Connect syntax

<?php

// Connects to the XE service (i.e. database) on the "localhost" machine
$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Example #3 Basic oci_connect() using a Network Connect name

<?php

// Connects to the MYDB database described in tnsnames.ora file,
// One example tnsnames.ora entry for MYDB could be:
//   MYDB =
//     (DESCRIPTION =
//       (ADDRESS = (PROTOCOL = TCP)(HOST = mymachine.oracle.com)(PORT = 1521))
//       (CONNECT_DATA =
//         (SERVER = DEDICATED)
//         (SERVICE_NAME = XE)
//       )
//     )

$conn = oci_connect('hr', 'welcome', 'MYDB');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Example #4 oci_connect() with an explicit character set

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE', 'AL32UTF8');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Example #5 Using multiple calls to oci_connect()

<?php

$c1 = oci_connect("hr", "welcome", 'localhost/XE');
$c2 = oci_connect("hr", "welcome", 'localhost/XE');

// Both $c1 and $c2 show the same PHP resource id meaning they use the
// same underlying database connection
echo "c1 is $c1<br>\n";
echo "c2 is $c2<br>\n";

function create_table($conn)
{
    $stmt = oci_parse($conn, "create table hallo (test varchar2(64))");
    oci_execute($stmt);
    echo "Created table<br>\n";
}

function drop_table($conn)
{
    $stmt = oci_parse($conn, "drop table hallo");
    oci_execute($stmt);
    echo "Dropped table<br>\n";
}

function insert_data($connname, $conn)
{
    $stmt = oci_parse($conn, "insert into hallo
              values(to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
    oci_execute($stmt, OCI_DEFAULT);
    echo "$connname inserted row without committing<br>\n";
}

function rollback($connname, $conn)
{
    oci_rollback($conn);
    echo "$connname rollback<br>\n";
}

function select_data($connname, $conn)
{
    $stmt = oci_parse($conn, "select * from hallo");
    oci_execute($stmt, OCI_DEFAULT);
    echo "$connname ----selecting<br>\n";
    while (oci_fetch($stmt)) {
        echo "    " . oci_result($stmt, "TEST") . "<br>\n";
    }
    echo "$connname ----done<br>\n";
}

create_table($c1);

insert_data('c1', $c1);   // Insert a row using c1
sleep(2);                 // sleep to show a different timestamp for the 2nd row
insert_data('c2', $c2);   // Insert a row using c2

select_data('c1', $c1);   // Results of both inserts are returned
select_data('c2', $c2);   // Results of both inserts are returned

rollback('c1', $c1);      // Rollback using c1

select_data('c1', $c1);   // Both inserts have been rolled back
select_data('c2', $c2);

drop_table($c1);

// Closing one of the connections makes the PHP variable unusable, but
// the other could be used
oci_close($c1);
echo "c1 is $c1<br>\n";
echo "c2 is $c2<br>\n";

// Output is:
//    c1 is Resource id #5
//    c2 is Resource id #5
//    Created table
//    c1 inserted row without committing
//    c2 inserted row without committing
//    c1 ----selecting
//        09-DEC-09 12:14:43
//        09-DEC-09 12:14:45
//    c1 ----done
//    c2 ----selecting
//        09-DEC-09 12:14:43
//        09-DEC-09 12:14:45
//    c2 ----done
//    c1 rollback
//    c1 ----selecting
//    c1 ----done
//    c2 ----selecting
//    c2 ----done
//    Dropped table
//    c1 is
//    c2 is Resource id #5

?>

注释

Note:

An incorrectly installed or configured OCI8 extension will often manifest itself as a connection problem or error. See Installing/Configuring for troubleshooting information.

Note:

In PHP versions before 5.0.0 use ocilogon() instead.

参见

  • oci_pconnect() - 使用一个持久连接连到 Oracle 数据库
  • oci_new_connect() - 建定一个到 Oracle 服务器的新连接
  • oci_close() - 关闭 Oracle 连接


在 SELECT 中使用 PHP 变量作为定义的步骤

  • ? oci_connect
  • oci_error ?
  • PHP Manual
  • OCI8 函数
  • 在 SELECT 中使用 PHP 变量作为定义的步骤

oci_define_by_name

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_define_by_name — 在 SELECT 中使用 PHP 变量作为定义的步骤

说明

oci_define_by_name ( resource $statement , string $column_name , mixed &$variable , int $type = ? ) : bool

oci_define_by_name() 绑定 PHP 到获取的 SQL 列。 需要注意的是，Oracle 使用大写字母的列名，而用户在 select 中也可以用小写字母。oci_define_by_name() 期望 column_name 是大写字母。如果定义一个变量不存在于 select 语句中，将没有错误被给出。

如果需要定义一个抽象数据类型（LOB/ROWID/BFILE），必须先用 oci_new_descriptor() 分配空间。参见 oci_bind_by_name() 函数。

Example #1 oci_define_by_name() 例子

<?php
/* oci_define_by_name example - thies at thieso dot net (980219) */

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "SELECT empno, ename FROM emp");

/* the define MUST be done BEFORE oci_execute! */

oci_define_by_name($stmt, "EMPNO", $empno);
oci_define_by_name($stmt, "ENAME", $ename);

oci_execute($stmt);

while (oci_fetch($stmt)) {
    echo "empno:" . $empno . "\n";
    echo "ename:" . $ename . "\n";
}

oci_free_statement($stmt);
oci_close($conn);
?>

Note:

在 PHP 5.0.0 之前的版本必须使用 ocidefinebyname() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_define_by_name() 的别名。不过其已被废弃，不推荐使用。


返回上一个错误

  • ? oci_define_by_name
  • oci_execute ?
  • PHP Manual
  • OCI8 函数
  • 返回上一个错误

oci_error

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_error — 返回上一个错误

说明

oci_error ( resource $source = ? ) : array

对于大多数错误，参数是最适合的资源句柄。对于 oci_connect()，oci_new_connect() 或 oci_pconnect() 的连接错误，不要传递参数。如果没有发现错误，oci_error() 返回 false。oci_error() 以一个关联数组返回错误。在此数组中，code 是 oracle 错误代码而 message 是 oracle 的错误字符串。

Note: 自 PHP 4.3 起

offset 和 sqltext 也包括在返回的数组中，用来指出错误发生的位置以及造成错误的原始的 SQL 文本。

Example #1 连接错误后显示 Oracle 错误信息

$conn = @oci_connect("scott", "tiger", "mydb");
if (!$conn) {
  $e = oci_error();   // For oci_connect errors pass no handle
  echo htmlentities($e['message']);
}

Example #2 语法解析错误后显示 Oracle 错误信息

$stmt = @oci_parse($conn, "select ' from dual");  // note mismatched quote
if (!$stmt) {
  $e = oci_error($conn);  // For oci_parse errors pass the connection handle
  echo htmlentities($e['message']);
}

Example #3 执行错误后显示 Oracle 错误信息和出错的语句

$r = oci_execute($stmt);
if (!$r) {
  $e = oci_error($stmt); // For oci_execute errors pass the statementhandle
  echo htmlentities($e['message']);
  echo "<pre>";
  echo htmlentities($e['sqltext']);
  printf("\n%".($e['offset']+1)."s", "^");
  echo "</pre>";
}

Note:

在 PHP 5.0.0 之前的版本必须使用 ocierror() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_error() 的别名。不过其已被废弃，不推荐使用。


执行一条语句

  • ? oci_error
  • oci_fetch_all ?
  • PHP Manual
  • OCI8 函数
  • 执行一条语句

oci_execute

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_execute — 执行一条语句

说明

oci_execute ( resource $stmt , int $mode = ? ) : bool

oci_execute() 执行一条之前被解析过的语句（见 oci_parse()）。可选参数 mode 允许定义执行模式（默认是 OCI_COMMIT_ON_SUCCESS）。如果不需要将语句自动提交，则需要把 mode 设为 OCI_DEFAULT。

用 OCI_DEFAULT 模式时，将建立一个事务。事务会在关闭连接或脚本结束时（看哪个先）自动回卷。需要明确调用 oci_commit() 来提交事务，或者 oci_rollback() 中止事务。

成功时返回 true， 或者在失败时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ociexecute() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_execute() 的别名。不过其已被废弃，不推荐使用。

参数

statement

A valid OCI statement identifier.

mode

An optional second parameter can be one of the following constants:

Execution Modes
Constant | Description
OCI_COMMIT_ON_SUCCESS | Automatically commit all outstanding changes for this connection when the statement has succeeded. This is the default.
OCI_DEFAULT | Obsolete as of PHP 5.3.2 (PECL OCI8 1.4) but still available for backward compatibility. Use the equivalent OCI_NO_AUTO_COMMIT in new code.
OCI_DESCRIBE_ONLY | Make query meta data available to functions like oci_field_name() but do not create a result set. Any subsequent fetch call such as oci_fetch_array() will fail.
OCI_NO_AUTO_COMMIT | Do not automatically commit changes. Prior to PHP 5.3.2 (PECL OCI8 1.4) use OCI_DEFAULT which is an alias for OCI_NO_AUTO_COMMIT.

Using OCI_NO_AUTO_COMMIT mode starts a transaction. Transactions are automatically rolled back when the connection is closed, or when the script ends. Explicitly call oci_commit() to commit a transaction, or oci_rollback() to abort it.

When inserting or updating data, using transactions is recommended for relational data consistency and for performance reasons.

If OCI_NO_AUTO_COMMIT mode is used for any statement including queries, and oci_commit() or oci_rollback() is not subsequently called, then OCI8 will perform a rollback at the end of the script even if no data was changed. To avoid an unnecessary rollback, many scripts do not use OCI_NO_AUTO_COMMIT mode for queries or PL/SQL. Be careful to ensure the appropriate transactional consistency for the application when using oci_execute() with different modes in the same script.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 oci_execute() for queries

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Example #2 oci_execute() without specifying a mode example

<?php

// Before running, create the table:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (123)');

oci_execute($stid); // The row is committed and immediately visible to other users

?>

Example #3 oci_execute() with OCI_NO_AUTO_COMMIT example

<?php

// Before running, create the table:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (:bv)');
oci_bind_by_name($stid, ':bv', $i, 10);
for ($i = 1; $i <= 5; ++$i) {
    oci_execute($stid, OCI_NO_AUTO_COMMIT);  // use OCI_DEFAULT for PHP <= 5.3.1
}
oci_commit($conn);  // commits all new values: 1, 2, 3, 4, 5

?>

Example #4 oci_execute() with different commit modes example

<?php

// Before running, create the table:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (123)');
oci_execute($stid, OCI_NO_AUTO_COMMIT);  // data not committed

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (456)');
oci_execute($stid);  // commits both 123 and 456 values

?>

Example #5 oci_execute() with OCI_DESCRIBE_ONLY example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM locations');
oci_execute($s, OCI_DESCRIBE_ONLY);
for ($i = 1; $i <= oci_num_fields($stid); ++$i) {
    echo oci_field_name($stid, $i) . "<br>\n";
}

?>

注释

Note:

Transactions are automatically rolled back when connections are closed, or when the script ends, whichever is soonest. Explicitly call oci_commit() to commit a transaction.

Any call to oci_execute() that uses OCI_COMMIT_ON_SUCCESS mode explicitly or by default will commit any previous uncommitted transaction.

Any Oracle DDL statement such as CREATE or DROP will automatically commit any uncommitted transaction.

Note:

Because the oci_execute() function generally sends the statement to the database, oci_execute() can identify some statement syntax errors that the lightweight, local oci_parse() function does not.

Note:

In PHP versions before 5.0.0 use ociexecute() instead.

参见

  • oci_parse() - 配置 Oracle 语句预备执行


获取结果数据的所有行到一个数组

  • ? oci_execute
  • oci_fetch_array ?
  • PHP Manual
  • OCI8 函数
  • 获取结果数据的所有行到一个数组

oci_fetch_all

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_all — 获取结果数据的所有行到一个数组

说明

oci_fetch_all ( resource $statement , array &$output , int $skip = ? , int $maxrows = ? , int $flags = ? ) : int

oci_fetch_all() 从一个结果中获取所有的行到一个用户定义的数组。oci_fetch_all() 返回获取的行数，出错则返回 false。skip 是从结果中获取数据时，最开始忽略的行数（默认值是 0，即从第一行开始）。maxrows 是要读取的行数，从第 skip 行开始（默认值是 -1，即所有行）。

flags 参数可以是下列值的任意组合：

  • OCI_FETCHSTATEMENT_BY_ROW
  • OCI_FETCHSTATEMENT_BY_COLUMN（默认值）
  • OCI_NUM
  • OCI_ASSOC

Example #1 oci_fetch_all() 例子

<?php
/* oci_fetch_all example mbritton at verinet dot com (990624) */

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "select * from emp");

oci_execute($stmt);

$nrows = oci_fetch_all($stmt, $results);
if ($nrows > 0) {
   echo "<table border=\"1\">\n";
   echo "<tr>\n";
   foreach ($results as $key => $val) {
      echo "<th>$key</th>\n";
   }
   echo "</tr>\n";

   for ($i = 0; $i < $nrows; $i++) {
      echo "<tr>\n";
      foreach ($results as $data) {
         echo "<td>$data[$i]</td>\n";
      }
      echo "</tr>\n";
   }
   echo "</table>\n";
} else {
   echo "No data found<br />\n";
}
echo "$nrows Records Selected<br />\n";

oci_free_statement($stmt);
oci_close($conn);
?>

oci_fetch_all() 如果出错则返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocifetchstatement() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_fetch_all() 的别名。不过其已被废弃，不推荐使用。

参数

statement

有效的 OCI8 报表标识符 由 oci_parse() 创建，被 oci_execute() 或 REF CURSOR statement 标识执行。

output

The variable to contain the returned rows.

LOB columns are returned as strings, where Oracle supports conversion.

See oci_fetch_array() for more information on how data and types are fetched.

skip

The number of initial rows to discard when fetching the result. The default value is 0, so the first row onwards is returned.

maxrows

The number of rows to return. The default is -1 meaning return all the rows from skip + 1 onwards.

flags

Parameter flags indicates the array structure and whether associative arrays should be used.

oci_fetch_all() Array Structure Modes
Constant | Description
OCI_FETCHSTATEMENT_BY_ROW | The outer array will contain one sub-array per query row.
OCI_FETCHSTATEMENT_BY_COLUMN | The outer array will contain one sub-array per query column. This is the default.

Arrays can be indexed by column heading or numerically.

oci_fetch_all() Array Index Modes
Constant | Description
OCI_NUM | Numeric indexes are used for each column's array.
OCI_ASSOC | Associative indexes are used for each column's array. This is the default.

Use the addition operator "+" to choose a combination of array structure and index modes.

Oracle's default, non-case sensitive column names will have uppercase array keys. Case-sensitive column names will have array keys using the exact column case. Use var_dump() on output to verify the appropriate case to use for each query.

Queries that have more than one column with the same name should use column aliases. Otherwise only one of the columns will appear in an associative array.

返回值

Returns the number of rows in output, which may be 0 or more, 或者在失败时返回 false.

范例

Example #2 oci_fetch_all() example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res);

echo "$nrows rows fetched<br>\n";
var_dump($res);

// var_dump output is:
//    2 rows fetched
//    array(2) {
//      ["POSTAL_CODE"]=>
//      array(2) {
//        [0]=>
//        string(6) "00989x"
//        [1]=>
//        string(6) "10934x"
//      }
//      ["CITY"]=>
//      array(2) {
//        [0]=>
//        string(4) "Roma"
//        [1]=>
//        string(6) "Venice"
//      }
//    }

// Pretty-print the results
echo "<table border='1'>\n";
foreach ($res as $col) {
    echo "<tr>\n";
    foreach ($col as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Example #3 oci_fetch_all() example with OCI_FETCHSTATEMENT_BY_ROW

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res, null, null, OCI_FETCHSTATEMENT_BY_ROW);

echo "$nrows rows fetched<br>\n";
var_dump($res);

// Output is:
//    2 rows fetched
//    array(2) {
//      [0]=>
//      array(2) {
//        ["POSTAL_CODE"]=>
//        string(6) "00989x"
//        ["CITY"]=>
//        string(4) "Roma"
//      }
//      [1]=>
//      array(2) {
//        ["POSTAL_CODE"]=>
//        string(6) "10934x"
//        ["CITY"]=>
//        string(6) "Venice"
//      }
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Example #4 oci_fetch_all() with OCI_NUM

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res, null, null, OCI_FETCHSTATEMENT_BY_ROW + OCI_NUM);

echo "$nrows rows fetched<br>\n";
var_dump($res);

// Output is:
//    2 rows fetched
//    array(2) {
//      [0]=>
//      array(2) {
//        [0]=>
//        string(6) "00989x"
//        [1]=>
//        string(4) "Roma"
//      }
//      [1]=>
//      array(2) {
//        [0]=>
//        string(6) "10934x"
//        [1]=>
//        string(6) "Venice"
//      }
//    }

oci_free_statement($stid);
oci_close($conn);

?>

注释

Note:

Using skip is very inefficient. All the rows to be skipped are included in the result set that is returned from the database to PHP. They are then discarded. It is more efficient to use SQL to restrict the offset and range of rows in the query. See oci_fetch_array() for an example.

Note:

Queries that return a large number of rows can be more memory efficient if a single-row fetching function like oci_fetch_array() is used.

Note:

查询返回巨大数量的数据行时，通过增大 oci8.default_prefetch 值或使用 oci_set_prefetch() 可显著提高性能。

Note:

In PHP versions before 5.0.0 you must use ocifetchstatement() instead.

参见

  • oci_fetch() - Fetches the next row into result-buffer
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array
  • oci_set_prefetch() - 设置预提取行数


Returns the next row from a query as an associative or numeric array

  • ? oci_fetch_all
  • oci_fetch_assoc ?
  • PHP Manual
  • OCI8 函数
  • Returns the next row from a query as an associative or numeric array

oci_fetch_array

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_array — Returns the next row from a query as an associative or numeric array

说明

oci_fetch_array ( resource $statement , int $mode = ? ) : array

Returns an array containing the next result-set row of a query. Each array entry corresponds to a column of the row. This function is typically called in a loop until it returns false, indicating no more rows exist.

If statement corresponds to a PL/SQL block returning Oracle Database Implicit Result Sets, then rows from all sets are consecutively fetched. If statement is returned by oci_get_implicit_resultset(), then only the subset of rows for one child query are returned.

要获取 OCI8 扩展进行数据类型映射的细节，请参见驱动所支持的数据类型。

参数

statement

有效的 OCI8 报表标识符 由 oci_parse() 创建，被 oci_execute() 或 REF CURSOR statement 标识执行。

Can also be a statement identifier returned by oci_get_implicit_resultset().

mode

An optional second parameter can be any combination of the following constants:

oci_fetch_array() Modes
Constant | Description
OCI_BOTH | Returns an array with both associative and numeric indices. This is the same as OCI_ASSOC + OCI_NUM and is the default behavior.
OCI_ASSOC | Returns an associative array.
OCI_NUM | Returns a numeric array.
OCI_RETURN_NULLS | Creates elements for null fields. The element values will be a PHP null.
OCI_RETURN_LOBS | Returns the contents of LOBs instead of the LOB descriptors.

The default mode is OCI_BOTH.

Use the addition operator "+" to specify more than one mode at a time.

返回值

Returns an array with associative and/or numeric indices. If there are no more rows in the statement then false is returned.

By default, LOB columns are returned as LOB descriptors.

DATE columns are returned as strings formatted to the current date format. The default format can be changed with Oracle environment variables such as NLS_LANG or by a previously executed ALTER SESSION SET NLS_DATE_FORMAT command.

Oracle's default, non-case sensitive column names will have uppercase associative indices in the result array. Case-sensitive column names will have array indices using the exact column case. Use var_dump() on the result array to verify the appropriate case to use for each query.

The table name is not included in the array index. If your query contains two different columns with the same name, use OCI_NUM or add a column alias to the query to ensure name uniqueness, see example #7. Otherwise only one column will be returned via PHP.

范例

Example #1 oci_fetch_array() with OCI_BOTH

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_BOTH)) != false) {
    // Use the uppercase column names for the associative array indices
    echo $row[0] . " and " . $row['DEPARTMENT_ID']   . " are the same<br>\n";
    echo $row[1] . " and " . $row['DEPARTMENT_NAME'] . " are the same<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Example #2 oci_fetch_array() with OCI_NUM

<?php

/*
  Before running, create the table:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'A very long string');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_NUM)) != false) {
    echo $row[0] . "<br>\n";
    echo $row[1]->read(11) . "<br>\n"; // this will output first 11 bytes from DESCRIPTION
}

// Output is:
//    1
//    A very long

oci_free_statement($stid);
oci_close($conn);

?>

Example #3 oci_fetch_array() with OCI_ASSOC

<?php

/*
  Before running, create the table:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'A very long string');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['ID'] . "<br>\n";
    echo $row['DESCRIPTION']->read(11) . "<br>\n"; // this will output first 11 bytes from DESCRIPTION
}

// Output is:
//    1
//    A very long

oci_free_statement($stid);
oci_close($conn);

?>

Example #4 oci_fetch_array() with OCI_RETURN_NULLS

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT 1, null FROM dual');
oci_execute($stid);
while (($row = oci_fetch_array ($stid, OCI_ASSOC)) != false) { // Ignore NULLs
    var_dump($row);
}

/*
The above code prints:
  array(1) {
    [1]=>
    string(1) "1"
  }
*/

$stid = oci_parse($conn, 'SELECT 1, null FROM dual');
oci_execute($stid);
while (($row = oci_fetch_array ($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) { // Fetch NULLs
    var_dump($row);
}

/*
The above code prints:
  array(2) {
    [1]=>
    string(1) "1"
    ["NULL"]=>
    NULL
  }
*/

?>

Example #5 oci_fetch_array() with OCI_RETURN_LOBS

<?php

/*
  Before running, create the table:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'A very long string');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) != false) {
    echo $row['ID'] . "<br>\n";
    echo $row['DESCRIPTION'] . "<br>\n"; // this contains all of DESCRIPTION
    // In a loop, freeing the large variable before the 2nd fetch reduces PHP's peak memory usage
    unset($row);
}

// Output is:
//    1
//    A very long string

oci_free_statement($stid);
oci_close($conn);

?>

Example #6 oci_fetch_array() with case sensitive column names

<?php

/*
   Before running, create the table:
      CREATE TABLE mytab ("Name" VARCHAR2(20), city VARCHAR2(20));
      INSERT INTO mytab ("Name", city) values ('Chris', 'Melbourne');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'select * from mytab');
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);

// Because 'Name' was created as a case-sensitive column, that same
// case is used for the array index.  However uppercase 'CITY' must
// be used for the case-insensitive column index
print $row['Name'] . "<br>\n";   //  prints Chris
print $row['CITY'] . "<br>\n";   //  prints Melbourne

oci_free_statement($stid);
oci_close($conn);

?>

Example #7 oci_fetch_array() with columns having duplicate names

<?php

/*
  Before running, create the tables:
      CREATE TABLE mycity (id NUMBER, name VARCHAR2(20));
      INSERT INTO mycity (id, name) values (1, 'Melbourne');
      CREATE TABLE mycountry (id NUMBER, name VARCHAR2(20));
      INSERT INTO mycountry (id, name) values (1, 'Australia');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT mycity.name, mycountry.name
        FROM mycity, mycountry
        WHERE mycity.id = mycountry.id';
$stid = oci_parse($conn, $sql);
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
var_dump($row);

// Output only contains one "NAME" entry:
//    array(1) {
//      ["NAME"]=>
//      string(9) "Australia"
//    }

// To query a repeated column name, use an SQL column alias like "AS ctnm":
$sql = 'SELECT mycity.name AS ctnm, mycountry.name
        FROM mycity, mycountry
        WHERE mycity.id = mycountry.id';
$stid = oci_parse($conn, $sql);
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
var_dump($row);

// Output now contains both columns selected:
//    array(2) {
//      ["CTNM"]=>
//      string(9) "Melbourne"
//      ["NAME"]=>
//      string(9) "Australia"
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Example #8 oci_fetch_array() with DATE columns

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Set the date format for this connection.
// For performance reasons, consider changing the format
// in a trigger or with environment variables instead
$stid = oci_parse($conn, "ALTER SESSION SET NLS_DATE_FORMAT = 'YYYY-MM-DD'");
oci_execute($stid);

$stid = oci_parse($conn, 'SELECT hire_date FROM employees WHERE employee_id = 188');
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
echo $row['HIRE_DATE'] . "<br>\n";  // prints 1997-06-14

oci_free_statement($stid);
oci_close($conn);

?>

Example #9 oci_fetch_array() with REF CURSOR

<?php
/*
  Create the PL/SQL stored procedure as:

  CREATE OR REPLACE PROCEDURE myproc(p1 OUT SYS_REFCURSOR) AS
  BEGIN
    OPEN p1 FOR SELECT * FROM all_objects WHERE ROWNUM < 5000;
  END;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'BEGIN myproc(:rc); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Execute the returned REF CURSOR and fetch from it like a statement identifier
oci_execute($refcur);
echo "<table border='1'>\n";
while (($row = oci_fetch_array($refcur, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($refcur);
oci_free_statement($stid);
oci_close($conn);

?>

Example #10 Pagination with oci_fetch_array() using a LIMIT-like query

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Find the version of the database
preg_match('/Release ([0-9]+)\./', oci_server_version($conn), $matches);
$oracleversion = $matches[1];

// This is the query you want to "page" through
$sql = 'SELECT city, postal_code FROM locations ORDER BY city';

if ($oracleversion >= 12) {
    // Make use of Oracle 12c OFFSET / FETCH NEXT syntax
    $sql = $sql . ' OFFSET :offset ROWS FETCH NEXT :numrows ROWS ONLY';
} else {
    // Older Oracle versions need a nested query selecting a subset
    // from $sql.  Or, if the SQL statement is known at development
    // time, consider using a row_number() function instead of this
    // nested solution.  In production environments, be careful to
    // avoid SQL Injection issues with concatenation.
    $sql = "SELECT * FROM (SELECT a.*, ROWNUM AS my_rnum
                           FROM ($sql) a
                           WHERE ROWNUM <= :offset + :numrows)
            WHERE my_rnum > :offset";
}

$offset  = 0;  // skip this many rows
$numrows = 5;  // return 5 rows
$stid = oci_parse($conn, $sql);
oci_bind_by_name($stid, ':numrows', $numrows);
oci_bind_by_name($stid, ':offset', $offset);
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC + OCI_RETURN_NULLS)) != false) {
    echo $row['CITY'] . " " . $row['POSTAL_CODE'] . "<br>\n";
}

// Output is:
//    Beijing 190518
//    Bern 3095
//    Bombay 490231
//    Geneva 1730
//    Hiroshima 6823

oci_free_statement($stid);
oci_close($conn);

?>

Example #11 oci_fetch_array() with Oracle Database Implicit Result Sets

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Requires OCI8 2.0 (or later) and Oracle Database 12c (or later)
// Also see oci_get_implicit_resultset()
$sql = 'DECLARE
           c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

// Note: oci_fetch_all and oci_fetch() cannot be used in this manner
echo "<table>\n";
while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

// Output is:
//    Beijing 190518
//    Bern    3095
//    Bombay  490231
//    CN
//    CH
//    IN

oci_free_statement($stid);
oci_close($conn);

?>

注释

Note:

Associative array indices need to be in uppercase for standard Oracle columns that were created with case insensitive names.

Note:

查询返回巨大数量的数据行时，通过增大 oci8.default_prefetch 值或使用 oci_set_prefetch() 可显著提高性能。

Note:

The function oci_fetch_array() is insignificantly slower than oci_fetch_assoc() or oci_fetch_row(), but is more flexible.

参见

  • oci_fetch() - Fetches the next row into result-buffer
  • oci_fetch_all() - 获取结果数据的所有行到一个数组
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array
  • oci_set_prefetch() - 设置预提取行数


Returns the next row from a query as an associative array

  • ? oci_fetch_array
  • oci_fetch_object ?
  • PHP Manual
  • OCI8 函数
  • Returns the next row from a query as an associative array

oci_fetch_assoc

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_assoc — Returns the next row from a query as an associative array

说明

oci_fetch_assoc ( resource $statement ) : array

Returns an associative array containing the next result-set row of a query. Each array entry corresponds to a column of the row. This function is typically called in a loop until it returns false, indicating no more rows exist.

Calling oci_fetch_assoc() is identical to calling oci_fetch_array() with OCI_ASSOC + OCI_RETURN_NULLS.

参数

statement

有效的 OCI8 报表标识符 由 oci_parse() 创建，被 oci_execute() 或 REF CURSOR statement 标识执行。

返回值

Returns an associative array. If there are no more rows in the statement then false is returned.

范例

Example #1 oci_fetch_assoc() Example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_assoc($stid)) != false) {
    echo $row['DEPARTMENT_ID'] . " " . $row['DEPARTMENT_NAME'] . "<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

注释

Note:

See oci_fetch_array() for more examples of fetching rows.

参见

  • oci_fetch() - Fetches the next row into result-buffer
  • oci_fetch_all() - 获取结果数据的所有行到一个数组
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array


Returns the next row from a query as an object

  • ? oci_fetch_assoc
  • oci_fetch_row ?
  • PHP Manual
  • OCI8 函数
  • Returns the next row from a query as an object

oci_fetch_object

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_object — Returns the next row from a query as an object

说明

oci_fetch_object ( resource $statement ) : object

Returns an object containing the next result-set row of a query. Each attribute of the object corresponds to a column of the row. This function is typically called in a loop until it returns false, indicating no more rows exist.

要获取 OCI8 扩展进行数据类型映射的细节，请参见驱动所支持的数据类型。

参数

statement

有效的 OCI8 报表标识符 由 oci_parse() 创建，被 oci_execute() 或 REF CURSOR statement 标识执行。

返回值

Returns an object. Each attribute of the object corresponds to a column of the row. If there are no more rows in the statement then false is returned.

Any LOB columns are returned as LOB descriptors.

DATE columns are returned as strings formatted to the current date format. The default format can be changed with Oracle environment variables such as NLS_LANG or by a previously executed ALTER SESSION SET NLS_DATE_FORMAT command.

Oracle's default, non-case sensitive column names will have uppercase attribute names. Case-sensitive column names will have attribute names using the exact column case. Use var_dump() on the result object to verify the appropriate case for attribute access.

Attribute values will be null for any NULL data fields.

范例

Example #1 oci_fetch_object() example

<?php

/*
  Before running, create the table:
    CREATE TABLE mytab (id NUMBER, description VARCHAR2(30));
    INSERT INTO mytab (id, description) values (1, 'Fish and Chips');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    // Use upper case attribute names for each standard Oracle column
    echo $row->ID . "<br>\n";
    echo $row->DESCRIPTION . "<br>\n";
}

// Output is:
//    1
//    Fish and Chips

oci_free_statement($stid);
oci_close($conn);

?>

Example #2 oci_fetch_object() with case sensitive column names

<?php

/*
  Before running, create the table with a case sensitive column name:
    CREATE TABLE mytab (id NUMBER, "MyDescription" VARCHAR2(30));
    INSERT INTO mytab (id, "MyDescription") values (1, 'Iced Coffee');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, "MyDescription" FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    // Use upper case attribute names for each standard Oracle column
    echo $row->ID . "<br>\n";
    // Use the exact case for the case sensitive column name
    echo $row->MyDescription . "<br>\n";
}

// Output is:
//    1
//    Iced Coffee

oci_free_statement($stid);
oci_close($conn);

?>

Example #3 oci_fetch_object() with LOBs

<?php

/*
  Before running, create the table:
    CREATE TABLE mytab (id NUMBER, description CLOB);
    INSERT INTO mytab (id, description) values (1, 'A very long string');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    echo $row->ID . "<br>\n";
    // The following will output the first 11 bytes from DESCRIPTION
    echo $row->DESCRIPTION->read(11) . "<br>\n";
}

// Output is:
//    1
//    A very long

oci_free_statement($stid);
oci_close($conn);

?>

参见

  • oci_fetch() - Fetches the next row into result-buffer
  • oci_fetch_all() - 获取结果数据的所有行到一个数组
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_row() - Returns the next row from a query as a numeric array


Returns the next row from a query as a numeric array

  • ? oci_fetch_object
  • oci_fetch ?
  • PHP Manual
  • OCI8 函数
  • Returns the next row from a query as a numeric array

oci_fetch_row

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch_row — Returns the next row from a query as a numeric array

说明

oci_fetch_row ( resource $statement ) : array

Returns a numerically indexed array containing the next result-set row of a query. Each array entry corresponds to a column of the row. This function is typically called in a loop until it returns false, indicating no more rows exist.

Calling oci_fetch_row() is identical to calling oci_fetch_array() with OCI_NUM + OCI_RETURN_NULLS.

参数

statement

有效的 OCI8 报表标识符 由 oci_parse() 创建，被 oci_execute() 或 REF CURSOR statement 标识执行。

返回值

Returns a numerically indexed array. If there are no more rows in the statement then false is returned.

范例

Example #1 oci_fetch_row() Example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_row($stid)) != false) {
    echo $row[0] . " " . $row[1] . "<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

注释

Note:

See oci_fetch_array() for more examples of fetching rows.

参见

  • oci_fetch() - Fetches the next row into result-buffer
  • oci_fetch_all() - 获取结果数据的所有行到一个数组
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object


Fetches the next row into result-buffer

  • ? oci_fetch_row
  • oci_field_is_null ?
  • PHP Manual
  • OCI8 函数
  • Fetches the next row into result-buffer

oci_fetch

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_fetch — Fetches the next row into result-buffer

说明

oci_fetch ( resource $statement ) : bool

oci_fetch() 获取下一行（对于 SELECT 语句）到内部结果缓冲区。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocifetch() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_fetch() 的别名。不过其已被废弃，不推荐使用。

参数

statement

有效的 OCI8 报表标识符 由 oci_parse() 创建，被 oci_execute() 或 REF CURSOR statement 标识执行。

返回值

Returns true on success or false if there are no more rows in the statement.

范例

Example #1 oci_fetch() with defined variables

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);

// The defines MUST be done before executing
oci_define_by_name($stid, 'LOCATION_ID', $locid);
oci_define_by_name($stid, 'CITY', $city);

oci_execute($stid);

// Each fetch populates the previously defined variables with the next row's data
while (oci_fetch($stid)) {
    echo "Location id $locid is $city<br>\n";
}

// Displays:
//   Location id 1000 is Roma
//   Location id 1100 is Venice

oci_free_statement($stid);
oci_close($conn);

?>

Example #2 oci_fetch() with oci_result()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);
oci_execute($stid);

while (oci_fetch($stid)) {
    echo oci_result($stid, 'LOCATION_ID') . " is ";
    echo oci_result($stid, 'CITY') . "<br>\n";
}

// Displays:
//   1000 is Roma
//   1100 is Venice

oci_free_statement($stid);
oci_close($conn);

?>

注释

Note:

In PHP versions before 5.0.0 use ocifetch() instead.

参见

  • oci_define_by_name() - 在 SELECT 中使用 PHP 变量作为定义的步骤
  • oci_fetch_all() - 获取结果数据的所有行到一个数组
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array
  • oci_result() - 返回所取得行中字段的值


检查字段是否为 null

  • ? oci_fetch
  • oci_field_name ?
  • PHP Manual
  • OCI8 函数
  • 检查字段是否为 null

oci_field_is_null

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_is_null — 检查字段是否为 null

说明

oci_field_is_null ( resource $statement , mixed $field ) : bool

如果 statement 语句结果中返回的 field 字段的值是 null，oci_field_is_null() 返回 true。field 参数可以是字段的索引或字段名（大写字母）。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocicolumnisnull() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_field_is_null() 的别名。不过其已被废弃，不推荐使用。


返回字段名

  • ? oci_field_is_null
  • oci_field_precision ?
  • PHP Manual
  • OCI8 函数
  • 返回字段名

oci_field_name

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_name — 返回字段名

说明

oci_field_name ( resource $statement , int $field ) : string

oci_field_name() 返回与字段数字索引（从 1 开始）相对应的字段名。

Example #1 oci_field_name() 例子

<?php
    $conn = oci_connect("scott", "tiger");
    $stmt = oci_parse($conn, "SELECT * FROM emp");
    oci_execute($stmt);

    echo "<table border=\"1\">";
    echo "<tr>";
    echo "<th>Name</th>";
    echo "<th>Type</th>";
    echo "<th>Length</th>";
    echo "</tr>";

    $ncols = oci_num_fields($stmt);

    for ($i = 1; $i <= $ncols; $i++) {
        $column_name  = oci_field_name($stmt, $i);
        $column_type  = oci_field_type($stmt, $i);
        $column_size  = oci_field_size($stmt, $i);

        echo "<tr>";
        echo "<td>$column_name</td>";
        echo "<td>$column_type</td>";
        echo "<td>$column_size</td>";
        echo "</tr>";
    }

    echo "</table>\n";
    oci_free_statement($stmt);
    oci_close($conn);
?>

Note:

在 PHP 5.0.0 之前的版本必须使用 ocicolumnname() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_field_name() 的别名。不过其已被废弃，不推荐使用。

参见 oci_num_fields()，oci_field_type() 和 oci_field_size()。


返回字段精度

  • ? oci_field_name
  • oci_field_scale ?
  • PHP Manual
  • OCI8 函数
  • 返回字段精度

oci_field_precision

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_precision — 返回字段精度

说明

oci_field_precision ( resource $statement , int $field ) : int

返回索引为 field（从 1 开始）的字段的精度。

对于 FLOAT 字段，精度为非零值且范围为 -127。如果精度为 0，则字段为 NUMBER。其它类型为 NUMBER(precision, scale)。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocicolumnprecision() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_field_precision() 的别名。不过其已被废弃，不推荐使用。

参见 oci_field_scale() 和 oci_field_type()。


返回字段范围

  • ? oci_field_precision
  • oci_field_size ?
  • PHP Manual
  • OCI8 函数
  • 返回字段范围

oci_field_scale

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_scale — 返回字段范围

说明

oci_field_scale ( resource $statement , int $field ) : int

返回索引为 field（从 1 开始）的字段的范围。如果无此字段则返回 false。

对于 FLOAT 字段，精度为非零值且范围为 -127。如果精度为 0，则字段为 NUMBER。其它类型为 NUMBER(precision, scale)。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocicolumnscale() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_field_scale() 的别名。不过其已被废弃，不推荐使用。

参见 oci_field_precision() 和 oci_field_type()。


返回字段大小

  • ? oci_field_scale
  • oci_field_type_raw ?
  • PHP Manual
  • OCI8 函数
  • 返回字段大小

oci_field_size

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_size — 返回字段大小

说明

oci_field_size ( resource $stmt , mixed $field ) : int

oci_field_size() 以字节为单位返回字段的大小。field 参数的值可以是字段的索引（从 1 开始）或者字段名。

Example #1 oci_field_size()例子

<?php
    $conn = oci_connect("scott", "tiger");
    $stmt = oci_parse($conn, "SELECT * FROM emp");
    oci_execute($stmt);

    echo "<table border=\"1\">";
    echo "<tr>";
    echo "<th>Name</th>";
    echo "<th>Type</th>";
    echo "<th>Length</th>";
    echo "</tr>";

    $ncols = oci_num_fields($stmt);

    for ($i = 1; $i <= $ncols; $i++) {
        $column_name  = oci_field_name($stmt, $i);
        $column_type  = oci_field_type($stmt, $i);
        $column_size  = oci_field_size($stmt, $i);
        echo "<tr>";
        echo "<td>$column_name</td>";
        echo "<td>$column_type</td>";
        echo "<td>$column_size</td>";
        echo "</tr>";
    }

    echo "</table>";

    oci_free_statement($stmt);
    oci_close($conn);
?>

Note:

在 PHP 5.0.0 之前的版本必须使用 ocicolumnsize() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_field_size() 的别名。不过其已被废弃，不推荐使用。

参见 oci_num_fields() 和 oci_field_name()。


返回字段的原始 Oracle 数据类型

  • ? oci_field_size
  • oci_field_type ?
  • PHP Manual
  • OCI8 函数
  • 返回字段的原始 Oracle 数据类型

oci_field_type_raw

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_type_raw — 返回字段的原始 Oracle 数据类型

说明

oci_field_type_raw ( resource $statement , int $field ) : int

oci_field_type_raw() 返回字段的原始 Oracle 数据类型。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocicolumntyperaw() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_field_type_raw() 的别名。不过其已被废弃，不推荐使用。

不过，如果需要取得字段的类型，oci_field_type() 更为适合。更多信息见 oci_field_type()。


返回字段的数据类型

  • ? oci_field_type_raw
  • oci_free_descriptor ?
  • PHP Manual
  • OCI8 函数
  • 返回字段的数据类型

oci_field_type

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_field_type — 返回字段的数据类型

说明

oci_field_type ( resource $stmt , int $field ) : mixed

oci_field_type() 返回字段的数据类型。field 参数是字段的索引（从 1 开始）。

Example #1 oci_field_type() 例子

<?php
    $conn = oci_connect("scott", "tiger");
    $stmt = oci_parse($conn, "SELECT * FROM emp");
    oci_execute($stmt);

    echo "<table border=\"1\">";
    echo "<tr>";
    echo "<th>Name</th>";
    echo "<th>Type</th>";
    echo "<th>Length</th>";
    echo "</tr>";

    $ncols = oci_num_fields($stmt);

    for ($i = 1; $i <= $ncols; $i++) {
        $column_name  = oci_field_name($stmt, $i);
        $column_type  = oci_field_type($stmt, $i);
        $column_size  = oci_field_size($stmt, $i);

        echo "<tr>";
        echo "<td>$column_name</td>";
        echo "<td>$column_type</td>";
        echo "<td>$column_size</td>";
        echo "</tr>";
    }

    echo "</table>\n";

    oci_free_statement($stmt);
    oci_close($conn);
?>

Note:

在 PHP 5.0.0 之前的版本必须使用 ocicolumntype() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_field_type() 的别名。不过其已被废弃，不推荐使用。

参见 oci_num_fields()，oci_field_name() 和 oci_field_size()。


Frees a descriptor

  • ? oci_field_type
  • oci_free_statement ?
  • PHP Manual
  • OCI8 函数
  • Frees a descriptor

oci_free_descriptor

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_free_descriptor — Frees a descriptor

说明

oci_free_descriptor ( resource $descriptor ) : bool

Frees a descriptor allocated by oci_new_descriptor().

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function is commonly used as a method OCILOB::free.

参见

  • OCILOB::free


释放关联于语句或游标的所有资源

  • ? oci_free_descriptor
  • oci_get_implicit_resultset ?
  • PHP Manual
  • OCI8 函数
  • 释放关联于语句或游标的所有资源

oci_free_statement

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_free_statement — 释放关联于语句或游标的所有资源

说明

oci_free_statement ( resource $statement ) : bool

oci_free_statement() 释放关联于 Oracle 游标或语句的资源，该资源是作为 oci_parse() 的结果或者是从 Oracle 取得。

参数

statement

有效的 OCI 语句。

返回值

成功时返回 true， 或者在失败时返回 false。


Returns the next child statement resource from a parent statement resource that has Oracle Database Implicit Result Sets

  • ? oci_free_statement
  • oci_lob_copy ?
  • PHP Manual
  • OCI8 函数
  • Returns the next child statement resource from a parent statement resource that has Oracle Database Implicit Result Sets

oci_get_implicit_resultset

(PHP 5 >= 5.6.0, PHP 7, PHP 8, PECL OCI8 >= 2.0.0)

oci_get_implicit_resultset — Returns the next child statement resource from a parent statement resource that has Oracle Database Implicit Result Sets

说明

oci_get_implicit_resultset ( resource $statement ) : resource

Used to fetch consectutive sets of query results after the execution of a stored or anonymous Oracle PL/SQL block where that block returns query results with the Oracle Database 12 (or later) DBMS_SQL.RETURN_RESULT PL/SQL function. This allows PL/SQL blocks to easily return query results.

The child statement can be used with any of the OCI8 fetching
functions: oci_fetch(), oci_fetch_all(),
oci_fetch_array(), oci_fetch_object(),
oci_fetch_assoc() or oci_fetch_row()

Child statements inherit their parent statement's prefetch value, or it can be explicitly set with oci_set_prefetch().

参数

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(). The statement identifier may or may not be associated with a SQL statement that returns Implicit Result Sets.

返回值

Returns a statement handle for the next child statement available on statement. Returns false when child statements do not exist, or all child statements have been returned by previous calls to oci_get_implicit_resultset().

范例

Example #1 Fetching Implicit Result Sets in a loop

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

while (($stid_c = oci_get_implicit_resultset($stid))) {
    echo "<h2>New Implicit Result Set:</h2>\n";
    echo "<table>\n";
    while (($row = oci_fetch_array($stid_c, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
        echo "<tr>\n";
        foreach ($row as $item) {
            echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"&nbsp;")."</td>\n";
        }
        echo "</tr>\n";
    }
    echo "</table>\n";
}

// Output is:
//    New Implicit Result Set:
//     Beijing 190518
//     Bern    3095
//     Bombay  490231
//    New Implicit Result Set:
//     CN
//     CH
//     IN

oci_free_statement($stid);
oci_close($conn);

?>

Example #2 Getting child statement handles individually

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

$stid_1 = oci_get_implicit_resultset($stid);
$stid_2 = oci_get_implicit_resultset($stid);

$row = oci_fetch_array($stid_1, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_2, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_1, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_2, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);

// Output is:
//    array(2) {
//      ["CITY"]=>
//      string(7) "Beijing"
//      ["POSTAL_CODE"]=>
//      string(6) "190518"
//    }
//    array(1) {
//      ["COUNTRY_ID"]=>
//      string(2) "CN"
//    }
//    array(2) {
//      ["CITY"]=>
//      string(4) "Bern"
//      ["POSTAL_CODE"]=>
//      string(4) "3095"
//    }
//    array(1) {
//      ["COUNTRY_ID"]=>
//      string(2) "CH"
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Example #3 Explicitly setting the Prefetch Count

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

$stid_c = oci_get_implicit_resultset($stid);
oci_set_prefetch($stid_c, 200);   // Set the prefetch before fetching from the child statement
echo "<table>\n";
while (($row = oci_fetch_array($stid_c, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Example #4 Implicit Result Set example without using oci_get_implicit_resultset()

All results from all queries are returned consecutively.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

// Note: oci_fetch_all and oci_fetch() cannot be used in this manner
echo "<table>\n";
while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

// Output is:
//    Beijing 190518
//    Bern 3095
//    Bombay 490231
//    CN
//    CH
//    IN

oci_free_statement($stid);
oci_close($conn);

?>

注释

Note:

查询返回巨大数量的数据行时，通过增大 oci8.default_prefetch 值或使用 oci_set_prefetch() 可显著提高性能。


Copies large object

  • ? oci_get_implicit_resultset
  • oci_lob_is_equal ?
  • PHP Manual
  • OCI8 函数
  • Copies large object

oci_lob_copy

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_lob_copy — Copies large object

说明

oci_lob_copy ( OCILob $lob_to , OCILob $lob_from , int $length = 0 ) : bool

Copies a large object or a part of a large object to another large object. Old LOB-recipient data will be overwritten.

If you need to copy a particular part of a LOB to a particular position of a LOB, use OCILob::seek() to move LOB internal pointers.

参数

lob_to

The destination LOB.

lob_from

The copied LOB.

length

Indicates the length of data to be copied.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

The OCILob class was called OCI-Lob prior to PHP 8 and PECL OCI8 3.0.0.


Compares two LOB/FILE locators for equality

  • ? oci_lob_copy
  • oci_new_collection ?
  • PHP Manual
  • OCI8 函数
  • Compares two LOB/FILE locators for equality

oci_lob_is_equal

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_lob_is_equal — Compares two LOB/FILE locators for equality

说明

oci_lob_is_equal ( OCI-Lob $lob1 , OCI-Lob $lob2 ) : bool

Compares two LOB/FILE locators.

参数

lob1

A LOB identifier.

lob2

A LOB identifier.

返回值

Returns true if these objects are equal, false otherwise.

注释

Note:

The OCILob class was called OCI-Lob prior to PHP 8 and PECL OCI8 3.0.0.


分配新的 collection 对象

  • ? oci_lob_is_equal
  • oci_new_connect ?
  • PHP Manual
  • OCI8 函数
  • 分配新的 collection 对象

oci_new_collection

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_new_collection — 分配新的 collection 对象

说明

oci_new_collection ( resource $connection , string $tdo , string $schema = ? ) : OCI-Collection

分配一个新的 collection 对象。tdo 参数应为一个有效的名字类型（大写）。第三个可选参数 schema 应指向建立名字对象的架构。oci_new_collection() 使用当前用户作为 schema 的默认值。

oci_new_collection() 如果出错返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocinewcollection() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_new_collection() 的别名。不过其已被废弃，不推荐使用。


建定一个到 Oracle 服务器的新连接

  • ? oci_new_collection
  • oci_new_cursor ?
  • PHP Manual
  • OCI8 函数
  • 建定一个到 Oracle 服务器的新连接

oci_new_connect

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_new_connect — 建定一个到 Oracle 服务器的新连接

说明

oci_new_connect ( string $username , string $password , string $db = ? , string $charset = ? , int $session_mode = ? ) : resource

oci_new_connect() 创建一个到 Oracle
服务器的新连接并登录。与 oci_connect()
和 oci_pconnect() 不同，oci_new_connect()
不会缓冲连接，总是会返回一个全新的刚打开的连接句柄。这在应用程序需要在两组查询之间实现事务隔离很有用。

可选的第三个参数可以是本地 Oracle 实例的名字或者是在 tnsnames.ora 的条目中的名字。如果没有指定第三个参数， PHP 使用环境变量 ORACLE_SID 和 TWO_TASK 来分别确定本地 Oracle 实例的名字和 tnsnames.ora 的位置。

session_mode 参数自版本 1.1 起可用并接受如下值：OCI_DEFAULT，OCI_SYSOPER 和 OCI_SYSDBA。如果指定了 OCI_SYSOPER 或 OCI_SYSDBA 其中之一，oci_new_connect() 将尝试使用外部认证信息建立特权连接。特权连接默认被禁止。要启用，需要将 oci8.privileged_connect 设为 On。

使用 Oracle 客户端库来确定字符集。字符集不需要与数据库的字符集相匹配。如果不匹配，Oracle 会尽可能地将数据从数据库字符集进行转换。因为依赖于字符集，可能不能给出可用的结果。转换也增加一些时间开销。

如果不指定，Oracle 客户端用 NLS_LANG 环境变量来决定字符集。

传递此参数可减少连接时间。

下面例子演示了怎样隔离连接。

Example #1 oci_new_connect() 例子

<?php
echo "<html><pre>";
$db = "";

$c1 = oci_connect("scott", "tiger", $db);
$c2 = oci_new_connect("scott", "tiger", $db);

function create_table($conn)
{
  $stmt = oci_parse($conn, "create table scott.hallo (test
varchar2(64))");
  oci_execute($stmt);
  echo $conn . " created table\n\n";
}

function drop_table($conn)
{
  $stmt = oci_parse($conn, "drop table scott.hallo");
  oci_execute($stmt);
  echo $conn . " dropped table\n\n";
}

function insert_data($conn)
{
  $stmt = oci_parse($conn, "insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " inserted hallo\n\n";
}

function delete_data($conn)
{
  $stmt = oci_parse($conn, "delete from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " deleted hallo\n\n";
}

function commit($conn)
{
  oci_commit($conn);
  echo $conn . " committed\n\n";
}

function rollback($conn)
{
  oci_rollback($conn);
  echo $conn . " rollback\n\n";
}

function select_data($conn)
{
  $stmt = oci_parse($conn, "select * from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . "----selecting\n\n";
  while (oci_fetch($stmt)) {
    echo $conn . " <" . oci_result($stmt, "TEST") . ">\n\n";
  }
  echo $conn . "----done\n\n";
}

create_table($c1);
insert_data($c1);

select_data($c1);
select_data($c2);

rollback($c1);

select_data($c1);
select_data($c2);

insert_data($c2);
commit($c2);

select_data($c1);

delete_data($c1);
select_data($c1);
select_data($c2);
commit($c1);

select_data($c1);
select_data($c2);

drop_table($c1);
echo "</pre></html>";
?>

oci_new_connect() 在出错时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocinlogon() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_new_connect() 的别名。不过其已被废弃，不推荐使用。

参见 oci_connect() 和 oci_pconnect()。

参数

username

The Oracle user name.

password

The password for username.

connection_string

包含要连接的 Oracle 实例。可以是 » Easy Connect 串，或是 tnsnames.ora 文件中的连接名，或是本地 Oracle 实例名。

如果不指定，PHP 使用环境变量来确定连接的 Oracle 实例，诸如 TWO_TASK（Linux 下）或 LOCAL（Windows 下）与 ORACLE_SID 等。

要使用 Easy Connect 命名方法，PHP 必须与 Oracle 10g 或更高版本的客户端库进行链接。Oracle 10g 的 Easy Connect 串格式：[//]host_name[:port][/service_name]。Oracle 11g 则为：[//]host_name[:port][/service_name][:server_type][/instance_name]。 在 Oracle 19c 加入类更多选项，例如 timeout 和 keep-alive 设置。 请参考 Oracle 文档。 服务名可在数据库服务器机器上运行 Oracle 实用程序 lsnrctl status 找到。

tnsnames.ora 文件可在 Oracle Net 查找路径中，此路径包括 /your/path/to/instantclient/network/admin、$ORACLE_HOME/network/admin 、/etc。 另一种方法是设置 TNS_ADMIN 以便通过 $TNS_ADMIN/tnsnames.ora 来读取。表确认 web 守护进程可读取此文件。

character_set

使用 Oracle 客户端库来确定字符集。字符集不需要与数据库的字符集相匹配。如果不匹配，Oracle 会尽可能地将数据从数据库字符集进行转换。因为依赖于字符集，可能不能给出可用的结果。转换也增加一些时间开销。

如果不指定，Oracle 客户端用 NLS_LANG 环境变量来决定字符集。

传递此参数可减少连接时间。

session_mode

此参数在 PHP 5（PECL OCI8 1.1）版本开始可用，并收受下列值：OCI_DEFAULT，OCI_SYSOPER 和 OCI_SYSDBA。如为 OCI_SYSOPER 或 OCI_SYSDBA 其中之一，此函数将会使用外部的证书建立有特权的连接。有特权的连接默认是禁用的。需要将 oci8.privileged_connect 设为 On 来启用。

PHP 5.3（PECL OCI8 1.3.4）引进了 OCI_CRED_EXT 模式值。使用外部或操作系统认证必需在 Oracle 数据库中进行配置。OCI_CRED_EXT 标志只可用于用户为 "/"，密码为空的情况。oci8.privileged_connect 可为 On 或 Off。

OCI_CRED_EXT 可与 OCI_SYSOPER 或 OCI_SYSDBA 模式组合使用。

OCI_CRED_EXT 由于安全的原因不支持 Windows 系统。

返回值

Returns a connection identifier or false on error.

范例

The following demonstrates how you can separate connections.

Example #2 oci_new_connect() example

<?php
echo "<html><pre>";
$db = "";

$c1 = oci_connect("scott", "tiger", $db);
$c2 = oci_new_connect("scott", "tiger", $db);

function create_table($conn)
{
  $stmt = oci_parse($conn, "create table scott.hallo (test
varchar2(64))");
  oci_execute($stmt);
  echo $conn . " created table\n\n";
}

function drop_table($conn)
{
  $stmt = oci_parse($conn, "drop table scott.hallo");
  oci_execute($stmt);
  echo $conn . " dropped table\n\n";
}

function insert_data($conn)
{
  $stmt = oci_parse($conn, "insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " inserted hallo\n\n";
}

function delete_data($conn)
{
  $stmt = oci_parse($conn, "delete from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " deleted hallo\n\n";
}

function commit($conn)
{
  oci_commit($conn);
  echo $conn . " committed\n\n";
}

function rollback($conn)
{
  oci_rollback($conn);
  echo $conn . " rollback\n\n";
}

function select_data($conn)
{
  $stmt = oci_parse($conn, "select * from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . "----selecting\n\n";
  while (oci_fetch($stmt)) {
    echo $conn . " <" . oci_result($stmt, "TEST") . ">\n\n";
  }
  echo $conn . "----done\n\n";
}

create_table($c1);
insert_data($c1);

select_data($c1);
select_data($c2);

rollback($c1);

select_data($c1);
select_data($c2);

insert_data($c2);
commit($c2);

select_data($c1);

delete_data($c1);
select_data($c1);
select_data($c2);
commit($c1);

select_data($c1);
select_data($c2);

drop_table($c1);
echo "</pre></html>";
?>

注释

Note:

In PHP versions before 5.0.0 you must use ocinlogon() instead.

参见

  • oci_connect() - 建立一个到 Oracle 服务器的连接
  • oci_pconnect() - 使用一个持久连接连到 Oracle 数据库


分配并返回一个新的游标（语句句柄）

  • ? oci_new_connect
  • oci_new_descriptor ?
  • PHP Manual
  • OCI8 函数
  • 分配并返回一个新的游标（语句句柄）

oci_new_cursor

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_new_cursor — 分配并返回一个新的游标（语句句柄）

说明

oci_new_cursor ( resource $connection ) : resource

oci_new_cursor() 在指定的连接上分配一个新的语句句柄。

Example #1 在 Oracle 的存储过程中使用 REF CURSOR

<?php
// suppose your stored procedure info.output returns a ref cursor in :data

$conn = oci_connect("scott", "tiger");
$curs = oci_new_cursor($conn);
$stmt = oci_parse($conn, "begin info.output(:data); end;");

oci_bind_by_name($stmt, "data", $curs, -1, OCI_B_CURSOR);
oci_execute($stmt);
oci_execute($curs);

while ($data = oci_fetch_row($curs)) {
    var_dump($data);
}

oci_free_statement($stmt);
oci_free_statement($curs);
oci_close($conn);
?>

Example #2 在 Oracle 的 select 语句中使用 REF CURSOR

<?php
echo "<html><body>";
$conn = oci_connect("scott", "tiger");
$count_cursor = "CURSOR(select count(empno) num_emps from emp " .
                "where emp.deptno = dept.deptno) as EMPCNT from dept";
$stmt = oci_parse($conn, "select deptno,dname,$count_cursor");

oci_execute($stmt);
echo "<table border=\"1\">";
echo "<tr>";
echo "<th>DEPT NAME</th>";
echo "<th>DEPT #</th>";
echo "<th># EMPLOYEES</th>";
echo "</tr>";

while ($data = oci_fetch_assoc($stmt)) {
    echo "<tr>";
    $dname  = $data["DNAME"];
    $deptno = $data["DEPTNO"];
    echo "<td>$dname</td>";
    echo "<td>$deptno</td>";
    oci_execute($data["EMPCNT"]);
    while ($subdata = oci_fetch_assoc($data["EMPCNT"])) {
        $num_emps = $subdata["NUM_EMPS"];
        echo  "<td>$num_emps</td>";
    }
    echo "</tr>";
}
echo "</table>";
echo "</body></html>";
oci_free_statement($stmt);
oci_close($conn);
?>

oci_new_cursor() 如果出错返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocinewcursor() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_new_cursor() 的别名。不过其已被废弃，不推荐使用。


初始化一个新的空 LOB 或 FILE 描述符

  • ? oci_new_cursor
  • oci_num_fields ?
  • PHP Manual
  • OCI8 函数
  • 初始化一个新的空 LOB 或 FILE 描述符

oci_new_descriptor

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_new_descriptor — 初始化一个新的空 LOB 或 FILE 描述符

说明

oci_new_descriptor ( resource $connection , int $type = ? ) : OCI-Lob

oci_new_descriptor() 分配资源以保存描述符或 LOB 定位器。有效的 type 值是：OCI_D_FILE，OCI_D_LOB 以及 OCI_D_ROWID。

Example #1 oci_new_descriptor() 例子

<?php
    /* This script is designed to be called from a HTML form.
     * It expects $user, $password, $table, $where, and $commitsize
     * to be passed in from the form.  The script then deletes
     * the selected rows using the ROWID and commits after each
     * set of $commitsize rows. (Use with care, there is no rollback)
     */
    $conn = oci_connect($user, $password);
    $stmt = oci_parse($conn, "select rowid from $table $where");
    $rowid = oci_new_descriptor($conn, OCI_D_ROWID);
    oci_define_by_name($stmt, "ROWID", $rowid);
    oci_execute($stmt);
    while (oci_fetch($stmt)) {
       $nrows = oci_num_rows($stmt);
       $delete = oci_parse($conn, "delete from $table where ROWID = :rid");
       oci_bind_by_name($delete, ":rid", $rowid, -1, OCI_B_ROWID);
       oci_execute($delete);
       echo "$nrows\n";
       if (($nrows % $commitsize) == 0) {
           oci_commit($conn);
       }
    }
    $nrows = oci_num_rows($stmt);
    echo "$nrows deleted...\n";
    oci_free_statement($stmt);
    oci_close($conn);
?>
<?php
    /* This script demonstrates file upload to LOB columns
     * The formfield used for this example looks like this
     * <form action="upload.php" method="post" enctype="multipart/form-data">
     * <input type="file" name="lob_upload" />
     * ...
     */
  if (!isset($lob_upload) || $lob_upload == 'none'){
?>
<form action="upload.php" method="post" enctype="multipart/form-data">
Upload file: <input type="file" name="lob_upload" /><br />
<input type="submit" value="Upload" /> - <input type="reset" value="Reset" />
</form>
<?php
  } else {

     // $lob_upload contains the temporary filename of the uploaded file

     // see also the features section on file upload,
     // if you would like to use secure uploads

     $conn = oci_connect($user, $password);
     $lob = oci_new_descriptor($conn, OCI_D_LOB);
     $stmt = oci_parse($conn, "insert into $table (id, the_blob)
               values(my_seq.NEXTVAL, EMPTY_BLOB()) returning the_blob into :the_blob");
     oci_bind_by_name($stmt, ':the_blob', $lob, -1, OCI_B_BLOB);
     oci_execute($stmt, OCI_DEFAULT);
     if ($lob->savefile($lob_upload)){
        oci_commit($conn);
        echo "Blob successfully uploaded\n";
     }else{
        echo "Couldn't upload Blob\n";
     }
     oci_free_descriptor($lob);
     oci_free_statement($stmt);
     oci_close($conn);
  }
?>

Example #2 oci_new_descriptor() 例子

<?php
    /* Calling PL/SQL stored procedures which contain clobs as input
     * parameters (PHP 4 >= 4.0.6).
     * Example PL/SQL stored procedure signature is:
     *
     * PROCEDURE save_data
     *   Argument Name                  Type                    In/Out Default?
     *   ------------------------------ ----------------------- ------ --------
     *   KEY                            NUMBER(38)              IN
     *   DATA                           CLOB                    IN
     *
     */

    $conn = oci_connect($user, $password);
    $stmt = oci_parse($conn, "begin save_data(:key, :data); end;");
    $clob = oci_new_descriptor($conn, OCI_D_LOB);
    oci_bind_by_name($stmt, ':key', $key);
    oci_bind_by_name($stmt, ':data', $clob, -1, OCI_B_CLOB);
    $clob->write($data);
    oci_execute($stmt, OCI_DEFAULT);
    oci_commit($conn);
    $clob->free();
    oci_free_statement($stmt);
?>

oci_new_descriptor() 如果出错返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocinewdescriptor() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_new_descriptor() 的别名。不过其已被废弃，不推荐使用。


返回结果列的数目

  • ? oci_new_descriptor
  • oci_num_rows ?
  • PHP Manual
  • OCI8 函数
  • 返回结果列的数目

oci_num_fields

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_num_fields — 返回结果列的数目

说明

oci_num_fields ( resource $statement ) : int

oci_num_fields() 返回 statement 中的列的数目。

Example #1 oci_num_fields() 例子

<?php
    echo "<pre>\n";
    $conn = oci_connect("scott", "tiger");
    $stmt = oci_parse($conn, "select * from emp");

    oci_execute($stmt);

    while (oci_fetch($stmt)) {
        echo "\n";
        $ncols = oci_num_fields($stmt);
        for ($i = 1; $i <= $ncols; $i++) {
            $column_name  = oci_field_name($stmt, $i);
            $column_value = oci_result($stmt, $i);
            echo $column_name . ': ' . $column_value . "\n";
        }
        echo "\n";
    }

    oci_free_statement($stmt);
    oci_close($conn);

    echo "</pre>";
?>

oci_num_fields() 在出错时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocinumcols() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_num_fields() 的别名。不过其已被废弃，不推荐使用。


返回语句执行后受影响的行数

  • ? oci_num_fields
  • oci_parse ?
  • PHP Manual
  • OCI8 函数
  • 返回语句执行后受影响的行数

oci_num_rows

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_num_rows — 返回语句执行后受影响的行数

说明

oci_num_rows ( resource $stmt ) : int

oci_num_rows() 返回语句执行后受影响的行数。

Note:

本函数并不返回 SELECT 查询出来的行数！对于 SELECT 语句本函数将返回用 oci_fetch*() 函数取到缓冲区的行数。

Example #1 oci_num_rows() 例子

<?php
    echo "<pre>";
    $conn = oci_connect("scott", "tiger");

    $stmt = oci_parse($conn, "create table emp2 as select * from emp");
    oci_execute($stmt);
    echo oci_num_rows($stmt) . " rows inserted.<br />";
    oci_free_statement($stmt);

    $stmt = oci_parse($conn, "delete from emp2");
    oci_execute($stmt, OCI_DEFAULT);
    echo oci_num_rows($stmt) . " rows deleted.<br />";
    oci_commit($conn);
    oci_free_statement($stmt);

    $stmt = oci_parse($conn, "drop table emp2");
    oci_execute($stmt);
    oci_free_statement($stmt);

    oci_close($conn);
    echo "</pre>";
?>

oci_num_rows() 在出错时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocirowcount() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_num_rows() 的别名。不过其已被废弃，不推荐使用。


配置 Oracle 语句预备执行

  • ? oci_num_rows
  • oci_password_change ?
  • PHP Manual
  • OCI8 函数
  • 配置 Oracle 语句预备执行

oci_parse

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_parse — 配置 Oracle 语句预备执行

说明

oci_parse ( resource $connection , string $query ) : resource

oci_parse() 在 connection 上配置 query 并返回语句标识符以用于 oci_bind_by_name()，oci_execute() 以及其它函数。

Note:

本函数并不验证 query。要知道 query 是否是合法的 SQL 或 PL/SQL 语句的唯一方法是执行它。

oci_parse() 在出错时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ociparse() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_parse() 的别名。不过其已被废弃，不推荐使用。


修改 Oracle 用户的密码

  • ? oci_parse
  • oci_pconnect ?
  • PHP Manual
  • OCI8 函数
  • 修改 Oracle 用户的密码

oci_password_change

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_password_change — 修改 Oracle 用户的密码

说明

oci_password_change ( resource $connection , string $username , string $old_password , string $new_password ) : bool
oci_password_change ( string $dbname , string $username , string $old_password , string $new_password ) : resource

修改用户 username 的密码。old_password 和 new_password 应分别指定旧密码和新密码。

Note: 第二种 oci_password_change() 的语法自版本 1.1（OCI8 扩展库版本）起可用。

成功时返回 true， 或者在失败时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocipasswordchange() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_password_change() 的别名。不过其已被废弃，不推荐使用。

参数

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

username

The Oracle user name.

old_password

The old password.

new_password

The new password to be set.

dbname

The database name.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

Changing the password either with this function or directly in Oracle should be done carefully. This is because PHP applications may continue to successfully reuse persistent connections by authenticating with the old password. The best practice is to restart all web servers whenever the user password is changed.

Note:

If upgrading the Oracle client libraries or the database from a release prior to 11.2.0.3 to version 11.2.0.3 or higher, oci_password_change() may give the error "ORA-1017: invalid username/password" unless both client and server versions are upgraded at the same time.

Note: The second oci_password_change() syntax is available since OCI8 version 1.1.

Note:

In PHP versions before 5.0.0 you must use ocipasswordchange() instead. This name still can be used, it was left as alias of oci_password_change() for downwards compatability. This, however, is deprecated and not recommended.


使用一个持久连接连到 Oracle 数据库

  • ? oci_password_change
  • oci_register_taf_callback ?
  • PHP Manual
  • OCI8 函数
  • 使用一个持久连接连到 Oracle 数据库

oci_pconnect

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_pconnect — 使用一个持久连接连到 Oracle 数据库

说明

oci_pconnect ( string $username , string $password , string $db = ? , string $charset = ? , int $session_mode = ? ) : resource

oci_pconnect() 创建一个到 Oracle 服务器的持久连接并登录。持久连接会被缓冲并在请求之间重复使用，可以降低每个页面加载的消耗。一个典型的 PHP 应用程序对于每个 Apache 子进程（或者 PHP FastCGI/CGI 进程）会有一个打开的持久连接到 Oracle 服务器。更多信息见数据库持久连接一节。

Note: 自 OCI8 扩展库版本 1.1 起，持久 Oracle 连接的生命周期和最大数目可以通过设定以下配置选项来调整：oci8.persistent_timeout，oci8.ping_interval 和 oci8.max_persistent。

可选的第三个参数可以是本地 Oracle 实例的名字或者是在 tnsnames.ora 的条目中的名字。如果没有指定第三个参数， PHP 使用环境变量 ORACLE_SID 和 TWO_TASK 来分别确定本地 Oracle 实例的名字和 tnsnames.ora 的位置。

session_mode 参数自版本 1.1 起可用并接受如下值：OCI_DEFAULT，OCI_SYSOPER 和 OCI_SYSDBA。如果指定了 OCI_SYSOPER 或 OCI_SYSDBA 其中之一，oci_new_connect() 将尝试使用外部认证信息建立特权连接。特权连接默认被禁止。要启用，需要将 oci8.privileged_connect 设为 On。

使用 Oracle 客户端库来确定字符集。字符集不需要与数据库的字符集相匹配。如果不匹配，Oracle 会尽可能地将数据从数据库字符集进行转换。因为依赖于字符集，可能不能给出可用的结果。转换也增加一些时间开销。

如果不指定，Oracle 客户端用 NLS_LANG 环境变量来决定字符集。

传递此参数可减少连接时间。

oci_pconnect() 返回连接标识符，出错则返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ociplogon() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_pconnect() 的别名。不过其已被废弃，不推荐使用。

参见 oci_connect() 和 oci_new_connect()。

参数

username

The Oracle user name.

password

The password for username.

connection_string

包含要连接的 Oracle 实例。可以是 » Easy Connect 串，或是 tnsnames.ora 文件中的连接名，或是本地 Oracle 实例名。

如果不指定，PHP 使用环境变量来确定连接的 Oracle 实例，诸如 TWO_TASK（Linux 下）或 LOCAL（Windows 下）与 ORACLE_SID 等。

要使用 Easy Connect 命名方法，PHP 必须与 Oracle 10g 或更高版本的客户端库进行链接。Oracle 10g 的 Easy Connect 串格式：[//]host_name[:port][/service_name]。Oracle 11g 则为：[//]host_name[:port][/service_name][:server_type][/instance_name]。 在 Oracle 19c 加入类更多选项，例如 timeout 和 keep-alive 设置。 请参考 Oracle 文档。 服务名可在数据库服务器机器上运行 Oracle 实用程序 lsnrctl status 找到。

tnsnames.ora 文件可在 Oracle Net 查找路径中，此路径包括 /your/path/to/instantclient/network/admin、$ORACLE_HOME/network/admin 、/etc。 另一种方法是设置 TNS_ADMIN 以便通过 $TNS_ADMIN/tnsnames.ora 来读取。表确认 web 守护进程可读取此文件。

character_set

使用 Oracle 客户端库来确定字符集。字符集不需要与数据库的字符集相匹配。如果不匹配，Oracle 会尽可能地将数据从数据库字符集进行转换。因为依赖于字符集，可能不能给出可用的结果。转换也增加一些时间开销。

如果不指定，Oracle 客户端用 NLS_LANG 环境变量来决定字符集。

传递此参数可减少连接时间。

session_mode

此参数在 PHP 5（PECL OCI8 1.1）版本开始可用，并收受下列值：OCI_DEFAULT，OCI_SYSOPER 和 OCI_SYSDBA。如为 OCI_SYSOPER 或 OCI_SYSDBA 其中之一，此函数将会使用外部的证书建立有特权的连接。有特权的连接默认是禁用的。需要将 oci8.privileged_connect 设为 On 来启用。

PHP 5.3（PECL OCI8 1.3.4）引进了 OCI_CRED_EXT 模式值。使用外部或操作系统认证必需在 Oracle 数据库中进行配置。OCI_CRED_EXT 标志只可用于用户为 "/"，密码为空的情况。oci8.privileged_connect 可为 On 或 Off。

OCI_CRED_EXT 可与 OCI_SYSOPER 或 OCI_SYSDBA 模式组合使用。

OCI_CRED_EXT 由于安全的原因不支持 Windows 系统。

返回值

Returns a connection identifier or false on error.

注释

Note: Starting with PHP 5.1.2 and PECL oci8 1.1, the lifetime and maximum number of persistent Oracle connections can be tuned by setting the following configuration values: oci8.persistent_timeout, oci8.ping_interval and oci8.max_persistent.

Note:

In PHP versions before 5.0.0 you must use ociplogon() instead.

参见

  • oci_connect() - 建立一个到 Oracle 服务器的连接
  • oci_new_connect() - 建定一个到 Oracle 服务器的新连接


Register a user-defined callback function for Oracle Database TAF

  • ? oci_pconnect
  • oci_result ?
  • PHP Manual
  • OCI8 函数
  • Register a user-defined callback function for Oracle Database TAF

oci_register_taf_callback

(PHP 7.0 >= 7.0.21, PHP 8, PHP 7 >= 7.1.7, PHP 8, PECL OCI8 >= 2.1.7)

oci_register_taf_callback — Register a user-defined callback function for Oracle Database TAF

说明

oci_register_taf_callback ( resource $connection , mixed $callbackFn = ? ) : bool

Registers a user-defined callback function to connection. If connection fails due to instance or network failure, the registered callback function will be invoked for several times during failover. See OCI8 Transparent Application Failover (TAF) Support for information.

When oci_register_taf_callback() is called multiple times, each registration overwrites the previous one.

Use oci_unregister_taf_callback() to explicitly unregister a user-defined callback.

TAF callback registration will NOT be saved across persistent connections, therefore the callback needs to be re-registered for a new persistent connection.

参数

connection

An Oracle connection identifier.

callbackFn

A user-defined callback to register for Oracle TAF. It can be a string of the function name or a Closure (anonymous function).

The interface of a TAF user-defined callback function is as follows:

userCallbackFn ( resource $connection , int $event , int $type ) : int

See the parameter description and an example on OCI8 Transparent Application Failover (TAF) Support page.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • oci_unregister_taf_callback() - Unregister a user-defined callback function for Oracle Database TAF


返回所取得行中字段的值

  • ? oci_register_taf_callback
  • oci_rollback ?
  • PHP Manual
  • OCI8 函数
  • 返回所取得行中字段的值

oci_result

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_result — 返回所取得行中字段的值

说明

oci_result ( resource $statement , mixed $field ) : mixed

oci_result() 返回由 oci_fetch() 所取得的当前行中 field 字段的数据。oci_result() 对所有类型都返回字符串只除了抽象类型（ROWID，LOB 和 FILE）。oci_result() 在出错时返回 false。

可以使用列序号（从 1 开始）或列名（大写）作为 col 的参数。

Note:

在 PHP 5.0.0 之前的版本必须使用 ociresult() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_result() 的别名。不过其已被废弃，不推荐使用。

要获取 OCI8 扩展进行数据类型映射的细节，请参见驱动所支持的数据类型。

参见 oci_fetch_array()，oci_fetch_assoc()，oci_fetch_object()，oci_fetch_row() 和 oci_fetch_all()。

参数

statement

field

Can be either use the column number (1-based) or the column name (in uppercase).

返回值

Returns everything as strings except for abstract types (ROWIDs, LOBs and FILEs). Returns false on error.

注释

Note:

In PHP versions before 5.0.0 you must use ociresult() instead. This name still can be used, it was left as alias of oci_result() for downwards compatability. This, however, is deprecated and not recommended.

参见

  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array
  • oci_fetch_all() - 获取结果数据的所有行到一个数组


回滚未提交的事务

  • ? oci_result
  • oci_server_version ?
  • PHP Manual
  • OCI8 函数
  • 回滚未提交的事务

oci_rollback

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_rollback — 回滚未提交的事务

说明

oci_rollback ( resource $connection ) : bool

oci_rollback() 回滚 Oracle 连接 connection 上所有未提交的语句。

成功时返回 true， 或者在失败时返回 false。

Note:

当关闭连接或脚本结束时（看哪个先）事务会自动回卷。需要明确地调用 oci_commit() 来提交事务，或 oci_rollback() 来中止事务。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocirollback() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_rollback() 的别名。不过其已被废弃，不推荐使用。

参见 oci_commit()。

参数

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect() or oci_new_connect().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 oci_rollback() example

<?php

// Insert into several tables, rolling back the changes if an error occurs

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, "INSERT INTO mysalary (id, name) VALUES (1, 'Chris')");

// The OCI_NO_AUTO_COMMIT flag tells Oracle not to commit the INSERT immediately
// Use OCI_DEFAULT as the flag for PHP <= 5.3.1.  The two flags are equivalent
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'INSERT INTO myschedule (startday) VALUES (12)');
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    oci_rollback($conn);  // rollback changes to both tables
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

// Commit the changes to both tables
$r = oci_commit($conn);
if (!r) {
    $e = oci_error($conn);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

?>

Example #2 Rolling back to a SAVEPOINT example

<?php
$stid = oci_parse($conn, 'UPDATE mytab SET id = 1111');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

// Create the savepoint
$stid = oci_parse($conn, 'SAVEPOINT mysavepoint');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

$stid = oci_parse($conn, 'UPDATE mytab SET id = 2222');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

// Use an explicit SQL statement to rollback to the savepoint
$stid = oci_parse($conn, 'ROLLBACK TO SAVEPOINT mysavepoint');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

oci_commit($conn);  // mytab now has id of 1111
?>

注释

Note:

Transactions are automatically rolled back when you close the connection, or when the script ends, whichever is soonest. You need to explicitly call oci_commit() to commit the transaction.

Any call to oci_execute() that uses OCI_COMMIT_ON_SUCCESS mode explicitly or by default will commit any previous uncommitted transaction.

Any Oracle DDL statement such as CREATE or DROP will automatically commit any uncommitted transaction.

Note:

In PHP versions before 5.0.0 you must use ocirollback() instead.

参见

  • oci_commit() - 提交未执行的事务处理
  • oci_execute() - 执行一条语句


返回服务器版本信息

  • ? oci_rollback
  • oci_set_action ?
  • PHP Manual
  • OCI8 函数
  • 返回服务器版本信息

oci_server_version

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_server_version — 返回服务器版本信息

说明

oci_server_version ( resource $connection ) : string

以字符串返回 connection 所连接的 Oracle 服务器的版本信息。出错则返回 false。

Example #1 oci_server_version() 例子

<?php
    $conn = oci_connect("scott", "tiger");
    echo "Server Version: " . oci_server_version($conn);
    oci_close($conn);
?>

Note:

在 PHP 5.0.0 之前的版本必须使用 ociserverversion() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_server_version() 的别名。不过其已被废弃，不推荐使用。


Sets the action name

  • ? oci_server_version
  • oci_set_call_timeout ?
  • PHP Manual
  • OCI8 函数
  • Sets the action name

oci_set_action

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_action — Sets the action name

说明

oci_set_action ( resource $connection , string $action_name ) : bool

Sets the action name for Oracle tracing.

The action name is registered with the database when the next 'round-trip' from PHP to the database occurs, typically when an SQL statement is executed.

The action name can subsequently be queried from database administration views such as V$SESSION. It can be used for tracing and monitoring such as with V$SQLAREA and DBMS_MONITOR.SERV_MOD_ACT_STAT_ENABLE.

The value may be retained across persistent connections.

参数

connection

Oracle 连接标识，由 oci_connect()，oci_pconnect()，或 oci_new_connect() 返回。

action_name

User chosen string up to 32 bytes long.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Setting the action

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Record the action
oci_set_action($c, 'Friend Lookup');

// Code that causes a round-trip, for example a query:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);

?>
// While the script is running, the administrator can see the actions
// being performed:

sqlplus system/welcome
SQL> select action from v$session;

注释

Note: Oracle 版本需求

当 PHP 是与 Oracle 数据库 10g 及更新版本的 扩展库链接时，此函数可用。

Tip

性能

使用旧版的 OCI8 或 ORACLE 数据库，可使用 Oracle DBMS_APPLICATION_INFO 包来设置客户端信息。这比使用 oci_set_client_info() 较低效。

Caution

Roundtrip Gotcha

一些 OCI8 函数会导致 Roundtrips. 对数据库来说当启用结果缓存时，查询可能不产生 Roundtrips。

参见

  • oci_set_module_name() - Sets the module name
  • oci_set_client_info() - Sets the client information
  • oci_set_client_identifier() - Sets the client identifier
  • oci_set_db_operation() - Sets the database operation


Sets a millisecond timeout for database calls

  • ? oci_set_action
  • oci_set_client_identifier ?
  • PHP Manual
  • OCI8 函数
  • Sets a millisecond timeout for database calls

oci_set_call_timeout

(PHP 7.2 >= 7.2.14, PHP 8, PHP 7 >= 7.3.1, PHP 8, PECL OCI8 >= 2.2.0)

oci_set_call_timeout — Sets a millisecond timeout for database calls

说明

oci_set_call_timeout ( resource $connection , int $time_out ) : bool

Sets a timeout limiting the maxium time a database round-trip using this connection may take.

Each OCI8 operation may make zero or more calls to Oracle's client library. These internal calls may then may make zero or more round-trips to Oracle Database. If any one of those round-trips takes more than time_out milliseconds, then the operation is cancelled and an error is returned to the application.

The time_out value applies to each round-trip individually, not to the sum of all round-trips. Time spent processing in PHP OCI8 before or after the completion of each round-trip is not counted.

When a call is interrupted, Oracle will attempt to clean up the connection for reuse. This operation is allowed to run for another time_out period. Depending on the outcome of the cleanup, the connection may or may not be reusable.

When persistent connections are used, the timeout value will be retained across PHP requests.

The oci_set_call_timeout() function is available when OCI8 uses Oracle 18 (or later) Client libraries.

参数

connection

Oracle 连接标识，由 oci_connect()，oci_pconnect()，或 oci_new_connect() 返回。

time_out

The maximum time in milliseconds that any single round-trip between PHP and Oracle Database may take.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Setting the timeout

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
oci_set_call_timeout($conn, 5000);

?>


Sets the client identifier

  • ? oci_set_call_timeout
  • oci_set_client_info ?
  • PHP Manual
  • OCI8 函数
  • Sets the client identifier

oci_set_client_identifier

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_client_identifier — Sets the client identifier

说明

oci_set_client_identifier ( resource $connection , string $client_identifier ) : bool

Sets the client identifier used by various database components to identify lightweight application users who authenticate as the same database user.

The client identifier is registered with the database when the next 'round-trip' from PHP to the database occurs, typically when an SQL statement is executed.

The identifier can subsequently be queried, for example with SELECT SYS_CONTEXT('USERENV','CLIENT_IDENTIFIER') FROM DUAL. Database administration views such as V$SESSION will also contain the value. It can be used with DBMS_MONITOR.CLIENT_ID_TRACE_ENABLE for tracing and can also be used for auditing.

The value may be retained across page requests that use the same persistent connection.

参数

connection

Oracle 连接标识，由 oci_connect()，oci_pconnect()，或 oci_new_connect() 返回。

client_identifier

User chosen string up to 64 bytes long.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Setting the client identifier to the application user

<?php

// Find the application user's login name
session_start();
$un = my_validate_session($_SESSION['username']);
$c = oci_connect('myschema', 'welcome', 'localhost/XE');

// Tell Oracle who that user is
oci_set_client_identifier($c, $un);

// The next round-trip to the database will piggyback the identifier
$s = oci_parse($c, 'select mydata from mytable');
oci_execute($s);

// ...

?>

注释

Caution

Roundtrip Gotcha

一些 OCI8 函数会导致 Roundtrips. 对数据库来说当启用结果缓存时，查询可能不产生 Roundtrips。

参见

  • oci_set_module_name() - Sets the module name
  • oci_set_action() - Sets the action name
  • oci_set_client_info() - Sets the client information
  • oci_set_db_operation() - Sets the database operation


Sets the client information

  • ? oci_set_client_identifier
  • oci_set_db_operation ?
  • PHP Manual
  • OCI8 函数
  • Sets the client information

oci_set_client_info

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_client_info — Sets the client information

说明

oci_set_client_info ( resource $connection , string $client_info ) : bool

Sets the client information for Oracle tracing.

The client information is registered with the database when the next 'round-trip' from PHP to the database occurs, typically when an SQL statement is executed.

The client information can subsequently be queried from database administration views such as V$SESSION.

The value may be retained across persistent connections.

参数

connection

Oracle 连接标识，由 oci_connect()，oci_pconnect()，或 oci_new_connect() 返回。

client_info

User chosen string up to 64 bytes long.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Setting the client information

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Record the client information
oci_set_client_info($c, 'My Application Version 2');

// Code that causes a round-trip, for example a query:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);

?>
// While the script is running, the administrator can see the client
// information:

sqlplus system/welcome
SQL> select client_info from v$session;

注释

Note: Oracle 版本需求

当 PHP 是与 Oracle 数据库 10g 及更新版本的 扩展库链接时，此函数可用。

Tip

性能

使用旧版的 OCI8 或 ORACLE 数据库，可使用 Oracle DBMS_APPLICATION_INFO 包来设置客户端信息。这比使用 oci_set_client_info() 较低效。

Caution

Roundtrip Gotcha

一些 OCI8 函数会导致 Roundtrips. 对数据库来说当启用结果缓存时，查询可能不产生 Roundtrips。

参见

  • oci_set_module_name() - Sets the module name
  • oci_set_action() - Sets the action name
  • oci_set_client_identifier() - Sets the client identifier
  • oci_set_db_operation() - Sets the database operation


Sets the database operation

  • ? oci_set_client_info
  • oci_set_edition ?
  • PHP Manual
  • OCI8 函数
  • Sets the database operation

oci_set_db_operation

(PHP 7 >= 7.2.14, PHP 8, PHP 7 >= 7.3.1, PHP 8, PECL OCI8 >= 2.2.0)

oci_set_db_operation — Sets the database operation

说明

oci_set_db_operation ( resource $connection , string $dbop ) : bool

Sets the DBOP for Oracle tracing.

The database operation name is registered with the database when the next 'round-trip' from PHP to the database occurs, typically when a SQL statement is executed.

The database operation can subsequently be queried from database administration views such as V$SQL_MONITOR.

The oci_set_db_operation() function is available when OCI8 uses Oracle 12 (or later) Client libraries and Oracle Database 12 (or later).

参数

connection

Oracle 连接标识，由 oci_connect()，oci_pconnect()，或 oci_new_connect() 返回。

dbop

User chosen string.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Setting the DBOP

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Record the operation
oci_set_db_operation($c, 'main query');

// Code that causes a round-trip, for example a query:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);

?>
// While the script is running, the administrator can see the database operations
// being performed:

sqlplus system/welcome
SQL> select dbop_name from v$sql_monitor;

注释

Caution

Roundtrip Gotcha

一些 OCI8 函数会导致 Roundtrips. 对数据库来说当启用结果缓存时，查询可能不产生 Roundtrips。

参见

  • oci_set_action() - Sets the action name
  • oci_set_module_name() - Sets the module name
  • oci_set_client_info() - Sets the client information
  • oci_set_client_identifier() - Sets the client identifier


Sets the database edition

  • ? oci_set_db_operation
  • oci_set_module_name ?
  • PHP Manual
  • OCI8 函数
  • Sets the database edition

oci_set_edition

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_edition — Sets the database edition

说明

oci_set_edition ( string $edition ) : bool

Sets the database "edition" of objects to be used by a subsequent connections.

Oracle Editions allow concurrent versions of applications to run using the same schema and object names. This is useful for upgrading live systems.

Call oci_set_edition() before calling
oci_connect(), oci_pconnect()
or oci_new_connect().

If an edition is set that is not valid in the database, connection will fail even if oci_set_edition() returns success.

When using persistent connections, if a connection with the requested edition setting already exists, it is reused. Otherwise, a different persistent connection is created

参数

edition

Oracle Database edition name previously created with the SQL "CREATE EDITION" command.

注释

Note: Oracle version requirement

This function is available from Oracle 11gR2 onwards.

Caution

Persistent connections

To avoid inconsistencies and unexpected errors, do not use ALTER SESSION SET EDITION to change the edition on persistent connections.

Caution

DRCP Connection Pooling

To avoid inconsistencies and unexpected errors when using editions and DRCP with Oracle 11.2.0.1, keep a one-to-one correspondence between the oci8.connection_class and the edition name used by applications. Each pooled server of a given connection class should only be used with one edition. This restriction has been removed with Oracle 11.2.0.2.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Two scripts can use different versions of myfunc() at the same time

<?php

// File 1

echo "Version 1 of application\n";

oci_set_edition('ORA$BASE');
$c = oci_connect('hr', 'welcome', 'localhost/XE');

$s = oci_parse($c, "begin :r := myfunc(); end;");
oci_bind_by_name($s, ":r", $r, 20);
oci_execute($s);
echo "The result is $r\n";

?>
<?php

// File 2

echo "Version 2 of application\n";

oci_set_edition('E1');
$c = oci_connect('hr', 'welcome', 'localhost/XE');

$s = oci_parse($c, "begin :r := myfunc(); end;");
oci_bind_by_name($s, ":r", $r, 20);
oci_execute($s);
echo "The result is $r\n";

?>


Sets the module name

  • ? oci_set_edition
  • oci_set_prefetch ?
  • PHP Manual
  • OCI8 函数
  • Sets the module name

oci_set_module_name

(PHP 5 >= 5.3.2, PHP 7, PHP 8, PECL OCI8 >= 1.4.0)

oci_set_module_name — Sets the module name

说明

oci_set_module_name ( resource $connection , string $module_name ) : bool

Sets the module name for Oracle tracing.

The module name is registered with the database when the next 'round-trip' from PHP to the database occurs, typically when an SQL statement is executed.

The name can subsequently be queried from database administration views such as V$SESSION. It can be used for tracing and monitoring such as with V$SQLAREA and DBMS_MONITOR.SERV_MOD_ACT_STAT_ENABLE.

The value may be retained across persistent connections.

参数

connection

Oracle 连接标识，由 oci_connect()，oci_pconnect()，或 oci_new_connect() 返回。

module_name

User chosen string up to 48 bytes long.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note: Oracle 版本需求

当 PHP 是与 Oracle 数据库 10g 及更新版本的 扩展库链接时，此函数可用。

Tip

性能

使用旧版的 OCI8 或 ORACLE 数据库，可使用 Oracle DBMS_APPLICATION_INFO 包来设置客户端信息。这比使用 oci_set_client_info() 较低效。

Caution

Roundtrip Gotcha

一些 OCI8 函数会导致 Roundtrips. 对数据库来说当启用结果缓存时，查询可能不产生 Roundtrips。

范例

Example #1 Setting the module name

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Record the module
oci_set_module_name($c, 'Home Page');

// Code that causes a round-trip, for example a query:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);
?>
// While the script is running, the administrator can see the
// modules in use:

sqlplus system/welcome
SQL> select module from v$session;

参见

  • oci_set_action() - Sets the action name
  • oci_set_client_info() - Sets the client information
  • oci_set_client_identifier() - Sets the client identifier
  • oci_set_db_operation() - Sets the database operation


设置预提取行数

  • ? oci_set_module_name
  • oci_statement_type ?
  • PHP Manual
  • OCI8 函数
  • 设置预提取行数

oci_set_prefetch

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_set_prefetch — 设置预提取行数

说明

oci_set_prefetch ( resource $statement , int $rows = ? ) : bool

在成功调用 oci_execute() 之后设定预提取的行数。rows 的默认值为 1。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocisetprefetch() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_set_prefetch() 的别名。不过其已被废弃，不推荐使用。

成功时返回 true， 或者在失败时返回 false。

参见 oci8_.default_prefetch INI 选项。

参数

statement

有效的 OCI8 报表标识符 由 oci_parse() 创建，被 oci_execute() 或 REF CURSOR statement 标识执行。

rows

The number of rows to be prefetched, >= 0

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
PHP 5.3.2 (PECL OCI8 1.4) | Before this release, rows must be >= 1.
PHP 5.3 (PECL OCI8 1.3.4) | Before this release, prefetching was limited to the lesser of rows rows and 1024 * rows bytes. The byte size restriction has now been removed.

范例

Example #1 Changing the default prefetch value for a query

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM myverybigtable');
oci_set_prefetch($stid, 300);  // Set before calling oci_execute()
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Example #2 Changing the default prefetch for a REF CURSOR fetch

<?php
/*
  Create the PL/SQL stored procedure as:

  CREATE OR REPLACE PROCEDURE myproc(p1 OUT SYS_REFCURSOR) AS
  BEGIN
    OPEN p1 FOR SELECT * FROM all_objects WHERE ROWNUM < 5000;
  END;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'BEGIN myproc(:rc); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Change the prefetch before executing the cursor.
// REF CURSOR prefetching works when PHP is linked with Oracle 11gR2 Client libraries
oci_set_prefetch($refcur, 200);
oci_execute($refcur);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($refcur, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($refcur);
oci_free_statement($stid);
oci_close($conn);

?>

If PHP OCI8 fetches from a REF CURSOR and then passes the REF CURSOR back to a second PL/SQL procedure for further processing, then set the REF CURSOR prefetch count to 0 to avoid rows being "lost" from the result set. The prefetch value is the number of extra rows fetched in each OCI8 internal request to the database, so setting it to 0 means only fetch one row at a time.

Example #3 Setting the prefetch value when passing a REF CURSOR back to Oracle

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/orcl');

// get the REF CURSOR
$stid = oci_parse($conn, 'BEGIN myproc(:rc_out); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc_out', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Display two rows, but don't prefetch any extra rows otherwise
// those extra rows would not be passed back to myproc_use_rc().
// A prefetch value of 0 is allowed in PHP 5.3.2 and PECL OCI8 1.4
oci_set_prefetch($refcur, 0);
oci_execute($refcur);
$row = oci_fetch_array($refcur);
var_dump($row);
$row = oci_fetch_array($refcur);
var_dump($row);

// pass the REF CURSOR to myproc_use_rc() to do more data processing
// with the result set
$stid = oci_parse($conn, 'begin myproc_use_rc(:rc_in); end;');
oci_bind_by_name($stid, ':rc_in', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

?>

注释

Note:

In PHP versions before 5.0.0 use ocisetprefetch() instead.

参见

  • oci8.default_prefetch ini option


返回 OCI 语句的类型

  • ? oci_set_prefetch
  • oci_unregister_taf_callback ?
  • PHP Manual
  • OCI8 函数
  • 返回 OCI 语句的类型

oci_statement_type

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

oci_statement_type — 返回 OCI 语句的类型

说明

oci_statement_type ( resource $statement ) : string

oci_statement_type() 返回语句 statement 的查询类型，其值为下列之一：

  1. SELECT
  2. UPDATE
  3. DELETE
  4. INSERT
  5. CREATE
  6. DROP
  7. ALTER
  8. BEGIN
  9. DECLARE
  10. UNKNOWN

statement 参数是一个由 oci_parse() 所返回的有效的 OCI 语句标识符。

Example #1 oci_statement_type() 例子

<?php
    $conn = oci_connect("scott", "tiger");
    $sql  = "delete from emp where deptno = 10";

    $stmt = oci_parse($conn, $sql);
    if (oci_statement_type($stmt) == "DELETE") {
        die("You are not allowed to delete from this table<br />");
    }

    oci_close($conn);
?>

oci_statement_type() 在出错时返回 false。

Note:

在 PHP 5.0.0 之前的版本必须使用 ocistatementtype() 替代本函数。该函数名仍然可用，为向下兼容作为 oci_statement_type() 的别名。不过其已被废弃，不推荐使用。


Unregister a user-defined callback function for Oracle Database TAF

  • ? oci_statement_type
  • OCICollection ?
  • PHP Manual
  • OCI8 函数
  • Unregister a user-defined callback function for Oracle Database TAF

oci_unregister_taf_callback

(PHP 7.0 >= 7.0.23, PHP 8, PHP 7 >= 7.1.9, PHP 8, PECL OCI8 >= 2.1.7)

oci_unregister_taf_callback — Unregister a user-defined callback function for Oracle Database TAF

说明

oci_unregister_taf_callback ( resource $connection ) : bool

Unregister the user-defined callback function registered to connection by oci_register_taf_callback(). See OCI8 Transparent Application Failover (TAF) Support for information.

参数

connection

An Oracle connection identifier.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • oci_register_taf_callback() - Register a user-defined callback function for Oracle Database TAF


The OCICollection class

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

简介

OCI8 Collection functionality.

Note:

The OCI-Collection class was renamed to OCICollection in PHP 8 OCI8 3.0.0 to align with PHP naming standards.

类摘要

OCICollection {
/* 方法 */
append ( mixed $value ) : bool
assign ( OCICollection $from ) : bool
assignElem ( int $index , mixed $value ) : bool
free ( ) : bool
getElem ( int $index ) : mixed
max ( ) : int
size ( ) : int
trim ( int $num ) : bool
}

Table of Contents

  • OCICollection::append — Appends element to the collection
  • OCICollection::assign — Assigns a value to the collection from another existing collection
  • OCICollection::assignElem — Assigns a value to the element of the collection
  • OCICollection::free — Frees the resources associated with the collection object
  • OCICollection::getElem — Returns value of the element
  • OCICollection::max — Returns the maximum number of elements in the collection
  • OCICollection::size — Returns size of the collection
  • OCICollection::trim — Trims elements from the end of the collection


Appends element to the collection

  • ? OCICollection
  • OCICollection::assign ?
  • PHP Manual
  • OCICollection
  • Appends element to the collection

OCICollection::append

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCICollection::append — Appends element to the collection

说明

OCICollection::append ( mixed $value ) : bool

Appends element to the end of the collection.

参数

value

The value to be added to the collection. Can be a string or a number.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.

参见

  • OCICollection::assign


Assigns a value to the collection from another existing collection

  • ? OCICollection::append
  • OCICollection::assignElem ?
  • PHP Manual
  • OCICollection
  • Assigns a value to the collection from another existing collection

OCICollection::assign

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCICollection::assign — Assigns a value to the collection from another existing collection

说明

OCICollection::assign ( OCICollection $from ) : bool

Assigns a value to the collection from another, previously created collection. Both collections must be created with oci_new_collection() prior to using them.

参数

from

An instance of OCI-Collection.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.

参见

  • OCICollection::append


Assigns a value to the element of the collection

  • ? OCICollection::assign
  • OCICollection::free ?
  • PHP Manual
  • OCICollection
  • Assigns a value to the element of the collection

OCICollection::assignElem

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCICollection::assignElem — Assigns a value to the element of the collection

说明

OCICollection::assignElem ( int $index , mixed $value ) : bool

Assigns a value to the element with index index.

参数

index

The element index. First index is 0.

value

Can be a string or a number.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.

参见

  • OCICollection::getElem


Frees the resources associated with the collection object

  • ? OCICollection::assignElem
  • OCICollection::getElem ?
  • PHP Manual
  • OCICollection
  • Frees the resources associated with the collection object

OCICollection::free

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCICollection::free — Frees the resources associated with the collection object

说明

OCICollection::free ( ) : bool

Frees the resources associated with the collection object.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.

参见

  • oci_new_collection


Returns value of the element

  • ? OCICollection::free
  • OCICollection::max ?
  • PHP Manual
  • OCICollection
  • Returns value of the element

OCICollection::getElem

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCICollection::getElem — Returns value of the element

说明

OCICollection::getElem ( int $index ) : mixed

Returns element's value with the index index (0-based).

参数

index

The element index. First index is 0.

返回值

Returns false if such element doesn't exist; null if element is null; string if element is column of a string datatype or number if element is numeric field.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.

参见

  • OCICollection::assignElem


Returns the maximum number of elements in the collection

  • ? OCICollection::getElem
  • OCICollection::size ?
  • PHP Manual
  • OCICollection
  • Returns the maximum number of elements in the collection

OCICollection::max

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCICollection::max — Returns the maximum number of elements in the collection

说明

OCICollection::max ( ) : int

Returns the maximum number of elements in the collection.

返回值

Returns the maximum number as an integer, or false on errors.

If the returned value is 0, then the number of elements is not limited.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.

参见

  • OCICollection::size


Returns size of the collection

  • ? OCICollection::max
  • OCICollection::trim ?
  • PHP Manual
  • OCICollection
  • Returns size of the collection

OCICollection::size

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCICollection::size — Returns size of the collection

说明

OCICollection::size ( ) : int

Returns the size of the collection.

返回值

Returns the number of elements in the collection or false on error.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.

参见

  • OCICollection::max


Trims elements from the end of the collection

  • ? OCICollection::size
  • OCILob ?
  • PHP Manual
  • OCICollection
  • Trims elements from the end of the collection

OCICollection::trim

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCICollection::trim — Trims elements from the end of the collection

说明

OCICollection::trim ( int $num ) : bool

Trims num of elements from the end of the collection.

参数

num

The number of elements to be trimmed.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.

参见

  • OCICollection::size


The OCILob class

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

简介

OCI8 LOB functionality for large binary (BLOB) and character (CLOB) objects.

Note:

The OCI-Lob class was renamed to OCILob in PHP 8 and PECL OCI8 3.0.0 to align with PHP naming standards.

类摘要

OCILob {
/* 方法 */
append ( OCILob $lob_from ) : bool
close ( ) : bool
eof ( ) : bool
erase ( int $offset = ? , int $length = ? ) : int|false
export ( string $filename , int $start = ? , int $length = ? ) : bool
flush ( int $flag = ? ) : bool
free ( ) : bool
getBuffering ( ) : bool
import ( string $filename ) : bool
load ( ) : string
read ( int $length ) : string|false
rewind ( ) : bool
save ( string $data , int $offset = ? ) : bool
seek ( int $offset , int $whence = OCI_SEEK_SET ) : bool
setBuffering ( bool $on_off ) : bool
size ( ) : int|false
tell ( ) : int
Lob::truncate ( int $length = 0 ) : bool
write ( string $data , int $length = ? ) : int|false
writeTemporary ( string $data , int $lob_type = OCI_TEMP_CLOB ) : bool
}

Table of Contents

  • OCILob::append — Appends data from the large object to another large object
  • OCILob::close — Closes LOB descriptor
  • OCILob::eof — Tests for end-of-file on a large object's descriptor
  • OCILob::erase — Erases a specified portion of the internal LOB data
  • OCILob::export — Exports LOB's contents to a file
  • OCILob::flush — Flushes/writes buffer of the LOB to the server
  • OCILob::free — Frees resources associated with the LOB descriptor
  • OCILob::getBuffering — Returns current state of buffering for the large object
  • OCILob::import — Imports file data to the LOB
  • OCILob::load — Returns large object's contents
  • OCILob::read — Reads part of the large object
  • OCILob::rewind — Moves the internal pointer to the beginning of the large object
  • OCILob::save — Saves data to the large object
  • OCILob::saveFile — 别名 OCILob::import
  • OCILob::seek — Sets the internal pointer of the large object
  • OCILob::setBuffering — Changes current state of buffering for the large object
  • OCILob::size — Returns size of large object
  • OCILob::tell — Returns the current position of internal pointer of large object
  • OCILob::truncate — Truncates large object
  • OCILob::write — Writes data to the large object
  • OCILob::writeTemporary — Writes a temporary large object
  • OCILob::writeToFile — 别名 OCILob::export


Appends data from the large object to another large object

  • ? OCILob
  • OCILob::close ?
  • PHP Manual
  • OCILob
  • Appends data from the large object to another large object

OCILob::append

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::append — Appends data from the large object to another large object

说明

OCILob::append ( OCILob $lob_from ) : bool

Appends data from the large object to the end of another large object.

Writing to the large object with this method will fail if buffering was previously enabled. You must disable buffering before appending. You may need to flush buffers with OCILob::flush before disabling buffering.

参数

lob_from

The copied LOB.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::flush
  • OCILob::setBuffering
  • OCILob::getBuffering


Closes LOB descriptor

  • ? OCILob::append
  • OCILob::eof ?
  • PHP Manual
  • OCILob
  • Closes LOB descriptor

OCILob::close

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::close — Closes LOB descriptor

说明

OCILob::close ( ) : bool

Closes descriptor of LOB or FILE. This function should be used only with OCILob::writeTemporary.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::writeTemporary


Tests for end-of-file on a large object's descriptor

  • ? OCILob::close
  • OCILob::erase ?
  • PHP Manual
  • OCILob
  • Tests for end-of-file on a large object's descriptor

OCILob::eof

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::eof — Tests for end-of-file on a large object's descriptor

说明

OCILob::eof ( ) : bool

Tells whether the internal pointer of large object is at the end of LOB.

返回值

Returns true if internal pointer of large object is at the end of LOB. Otherwise returns false.

注释

Note:

This function will return an Oracle error if OCILob::setBuffering is enabled on the LOB.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::size


Erases a specified portion of the internal LOB data

  • ? OCILob::eof
  • OCILob::export ?
  • PHP Manual
  • OCILob
  • Erases a specified portion of the internal LOB data

OCILob::erase

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::erase — Erases a specified portion of the internal LOB data

说明

OCILob::erase ( int $offset = ? , int $length = ? ) : int|false

Erases a specified portion of the internal LOB data starting at a specified offset. If called without parameters, it erases all LOB data.

For BLOBs, erasing means that the existing LOB value is overwritten with zero-bytes. For CLOBs, the existing LOB value is overwritten with spaces.

参数

offset

length

返回值

Returns the actual number of characters/bytes erased 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::truncate


Exports LOB's contents to a file

  • ? OCILob::erase
  • OCILob::flush ?
  • PHP Manual
  • OCILob
  • Exports LOB's contents to a file

OCILob::export

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::export — Exports LOB's contents to a file

说明

OCILob::export ( string $filename , int $start = ? , int $length = ? ) : bool

Exports LOB contents to a file.

参数

filename

Path to the file.

start

Indicates from where to start exporting.

length

Indicates the length of data to be exported.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::import


Flushes/writes buffer of the LOB to the server

  • ? OCILob::export
  • OCILob::free ?
  • PHP Manual
  • OCILob
  • Flushes/writes buffer of the LOB to the server

OCILob::flush

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::flush — Flushes/writes buffer of the LOB to the server

说明

OCILob::flush ( int $flag = ? ) : bool

OCILob::flush() actually writes data to the server.

参数

flag

By default, resources are not freed, but using flag OCI_LOB_BUFFER_FREE you can do it explicitly. Be sure you know what you're doing - next read/write operation to the same part of LOB will involve a round-trip to the server and initialize new buffer resources. It is recommended to use OCI_LOB_BUFFER_FREE flag only when you are not going to work with the LOB anymore.

返回值

成功时返回 true， 或者在失败时返回 false。

Returns false if buffering was not enabled or an error occurred.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::getBuffering
  • OCILob::setBuffering


Frees resources associated with the LOB descriptor

  • ? OCILob::flush
  • OCILob::getBuffering ?
  • PHP Manual
  • OCILob
  • Frees resources associated with the LOB descriptor

OCILob::free

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::free — Frees resources associated with the LOB descriptor

说明

OCILob::free ( ) : bool

Frees resources associated with the descriptor, previously allocated with oci_new_descriptor().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.


Returns current state of buffering for the large object

  • ? OCILob::free
  • OCILob::import ?
  • PHP Manual
  • OCILob
  • Returns current state of buffering for the large object

OCILob::getBuffering

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::getBuffering — Returns current state of buffering for the large object

说明

OCILob::getBuffering ( ) : bool

Tells whether the buffering for the large object is on or off.

返回值

Returns false if buffering for the large object is off and true if buffering is used.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::setBuffering


Imports file data to the LOB

  • ? OCILob::getBuffering
  • OCILob::load ?
  • PHP Manual
  • OCILob
  • Imports file data to the LOB

OCILob::import

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::import — Imports file data to the LOB

说明

OCILob::import ( string $filename ) : bool

Writes data from the filename in to the current position of large object.

参数

filename

Path to the file.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::export
  • OCILob::write


Returns large object's contents

  • ? OCILob::import
  • OCILob::read ?
  • PHP Manual
  • OCILob
  • Returns large object's contents

OCILob::load

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::load — Returns large object's contents

说明

OCILob::load ( ) : string

Returns large object's contents. As script execution is terminated when the memory_limit is reached, ensure that the LOB does not exceed this limit. In most cases it's recommended to use OCILob::read instead.

返回值

Returns the contents of the object, or false on errors.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::read


Reads part of the large object

  • ? OCILob::load
  • OCILob::rewind ?
  • PHP Manual
  • OCILob
  • Reads part of the large object

OCILob::read

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::read — Reads part of the large object

说明

OCILob::read ( int $length ) : string|false

Reads length bytes from the current position of LOB's internal pointer.

Reading stops when length bytes have been read or end of the large object is reached. Internal pointer of the large object will be shifted on the amount of bytes read.

参数

length

The length of data to read, in bytes. Large values will be rounded down to 1 MB.

返回值

Returns the contents as a string, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::load
  • OCILob::write


Moves the internal pointer to the beginning of the large object

  • ? OCILob::read
  • OCILob::save ?
  • PHP Manual
  • OCILob
  • Moves the internal pointer to the beginning of the large object

OCILob::rewind

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::rewind — Moves the internal pointer to the beginning of the large object

说明

OCILob::rewind ( ) : bool

Sets the internal pointer to the beginning of the large object.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::seek
  • OCILob::tell


Saves data to the large object

  • ? OCILob::rewind
  • OCILob::saveFile ?
  • PHP Manual
  • OCILob
  • Saves data to the large object

OCILob::save

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::save — Saves data to the large object

说明

OCILob::save ( string $data , int $offset = ? ) : bool

Saves data to the large object.

参数

data

The data to be saved.

offset

Can be used to indicate offset from the beginning of the large object.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::write
  • OCILob::import


别名 OCILob::import

  • ? OCILob::save
  • OCILob::seek ?
  • PHP Manual
  • OCILob
  • 别名 OCILob::import

OCILob::saveFile

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::saveFile — 别名 OCILob::import()

说明

此函数是该函数的别名： OCILob::import().

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.


Sets the internal pointer of the large object

  • ? OCILob::saveFile
  • OCILob::setBuffering ?
  • PHP Manual
  • OCILob
  • Sets the internal pointer of the large object

OCILob::seek

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::seek — Sets the internal pointer of the large object

说明

OCILob::seek ( int $offset , int $whence = OCI_SEEK_SET ) : bool

Sets the internal pointer of the large object.

参数

offset

Indicates the amount of bytes, on which internal pointer should be moved from the position, pointed by whence.

whence

May be one of:

  • OCI_SEEK_SET - sets the position equal to offset
  • OCI_SEEK_CUR - adds offset bytes to the current position
  • OCI_SEEK_END - adds offset bytes to the end of large object (use negative value to move to a position before the end of large object)

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::rewind
  • OCILob::tell
  • OCILob::eof


Changes current state of buffering for the large object

  • ? OCILob::seek
  • OCILob::size ?
  • PHP Manual
  • OCILob
  • Changes current state of buffering for the large object

OCILob::setBuffering

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::setBuffering — Changes current state of buffering for the large object

说明

OCILob::setBuffering ( bool $on_off ) : bool

Sets the buffering for the large object, depending on the value of the on_off parameter.

Use of this function may provide performance improvements by buffering small reads and writes of LOBs by reducing the number of network round-trips and LOB versions. OCILob::flush() should be used to flush buffers, when you have finished working with the large object.

参数

on_off

true for on and false for off.

返回值

成功时返回 true， 或者在失败时返回 false。 Repeated calls to this method with the same flag will return true.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::getBuffering


Returns size of large object

  • ? OCILob::setBuffering
  • OCILob::tell ?
  • PHP Manual
  • OCILob
  • Returns size of large object

OCILob::size

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::size — Returns size of large object

说明

OCILob::size ( ) : int|false

Gets the size of the large object.

返回值

Returns length of large object value 或者在失败时返回 false. Empty objects have zero length.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.


Returns the current position of internal pointer of large object

  • ? OCILob::size
  • OCILob::truncate ?
  • PHP Manual
  • OCILob
  • Returns the current position of internal pointer of large object

OCILob::tell

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::tell — Returns the current position of internal pointer of large object

说明

OCILob::tell ( ) : int

Gets the current position of a LOB's internal pointer.

返回值

Returns current position of a LOB's internal pointer or false if an error occurred.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::rewind
  • OCILob::size
  • OCILob::eof


Truncates large object

  • ? OCILob::tell
  • OCILob::write ?
  • PHP Manual
  • OCILob
  • Truncates large object

OCILob::truncate

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::truncate — Truncates large object

说明

Lob::truncate ( int $length = 0 ) : bool

Truncates the LOB.

参数

length

If provided, this method will truncate the LOB to length bytes. Otherwise, it will completely purge the LOB.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::erase


Writes data to the large object

  • ? OCILob::truncate
  • OCILob::writeTemporary ?
  • PHP Manual
  • OCILob
  • Writes data to the large object

OCILob::write

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::write — Writes data to the large object

说明

OCILob::write ( string $data , int $length = ? ) : int|false

Writes data from the parameter data into the current position of LOB's internal pointer.

参数

data

The data to write in the LOB.

length

If this parameter is given, writing will stop after length bytes have been written or the end of data is reached, whichever comes first.

返回值

Returns the number of bytes written 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::read


Writes a temporary large object

  • ? OCILob::write
  • OCILob::writeToFile ?
  • PHP Manual
  • OCILob
  • Writes a temporary large object

OCILob::writeTemporary

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::writeTemporary — Writes a temporary large object

说明

OCILob::writeTemporary ( string $data , int $lob_type = OCI_TEMP_CLOB ) : bool

Creates a temporary large object and writes data to it.

You should use OCILob::close when you are done with this object.

参数

data

The data to write.

lob_type

Can be one of the following:

  • OCI_TEMP_BLOB is used to create temporary BLOBs
  • OCI_TEMP_CLOB is used to create temporary CLOBs

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.

参见

  • OCILob::close


别名 OCILob::export

  • ? OCILob::writeTemporary
  • OCI8 Obsolete Aliases and Functions ?
  • PHP Manual
  • OCILob
  • 别名 OCILob::export

OCILob::writeToFile

(PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.1.0)

OCILob::writeToFile — 别名 OCILob::export()

说明

此函数是该函数的别名： OCILob::export().

更新日志

版本 | 说明
8.0.0, PECL OCI8 3.0.0 | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.


OCI8 Obsolete Aliases and Functions

Table of Contents

  • oci_internal_debug — Enables or disables internal debug output
  • ocibindbyname — 别名 oci_bind_by_name
  • ocicancel — 别名 oci_cancel
  • ocicloselob — 别名 OCI-Lob::close
  • ocicollappend — 别名 OCICollection::append
  • ocicollassign — 别名 OCICollection::assign
  • ocicollassignelem — 别名 OCICollection::assignElem
  • ocicollgetelem — 别名 OCICollection::getElem
  • ocicollmax — 别名 OCICollection::max
  • ocicollsize — 别名 OCICollection::size
  • ocicolltrim — 别名 OCICollection::trim
  • ocicolumnisnull — 别名 oci_field_is_null
  • ocicolumnname — 别名 oci_field_name
  • ocicolumnprecision — 别名 oci_field_precision
  • ocicolumnscale — 别名 oci_field_scale
  • ocicolumnsize — 别名 oci_field_size
  • ocicolumntype — 别名 oci_field_type
  • ocicolumntyperaw — 别名 oci_field_type_raw
  • ocicommit — 别名 oci_commit
  • ocidefinebyname — 别名 oci_define_by_name
  • ocierror — 别名 oci_error
  • ociexecute — 别名 oci_execute
  • ocifetch — 别名 oci_fetch
  • ocifetchinto — Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row
  • ocifetchstatement — 别名 oci_fetch_all
  • ocifreecollection — 别名 OCICollection::free
  • ocifreecursor — 别名 oci_free_statement
  • ocifreedesc — 别名 OCI-Lob::free
  • ocifreestatement — 别名 oci_free_statement
  • ociinternaldebug — 别名 oci_internal_debug
  • ociloadlob — 别名 OCI-Lob::load
  • ocilogoff — 别名 oci_close
  • ocilogon — 别名 oci_connect
  • ocinewcollection — 别名 oci_new_collection
  • ocinewcursor — 别名 oci_new_cursor
  • ocinewdescriptor — 别名 oci_new_descriptor
  • ocinlogon — 别名 oci_new_connect
  • ocinumcols — 别名 oci_num_fields
  • ociparse — 别名 oci_parse
  • ociplogon — 别名 oci_pconnect
  • ociresult — 别名 oci_result
  • ocirollback — 别名 oci_rollback
  • ocirowcount — 别名 oci_num_rows
  • ocisavelob — 别名 OCI-Lob::save
  • ocisavelobfile — 别名 OCI-Lob::import
  • ociserverversion — 别名 oci_server_version
  • ocisetprefetch — 别名 oci_set_prefetch
  • ocistatementtype — 别名 oci_statement_type
  • ociwritelobtofile — 别名 OCI-Lob::export
  • ociwritetemporarylob — 别名 OCI-Lob::writeTemporary


Enables or disables internal debug output

  • ? OCI8 Obsolete Aliases and Functions
  • ocibindbyname ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • Enables or disables internal debug output

oci_internal_debug

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0, PECL OCI8 <= 2.2.0)

oci_internal_debug — Enables or disables internal debug output

说明

oci_internal_debug ( bool $onoff ) : void

Enables or disables internal debug output.

参数

onoff

Set this to false to turn debug output off or true to turn it on.

返回值

没有返回值。

注释

Note:

This function was removed in PHP 8 and PECL OCI8 3.0.

Note:

This function is a no-op in PHP 5.6 and PECL OCI8 2.0. Use DTrace instead.

Note:

In PHP versions before 5.0.0 you must use ociinternaldebug() instead. This name still can be used, it was left as alias of oci_internal_debug() for downwards compatability. This, however, is deprecated and not recommended.


别名 oci_bind_by_name

  • ? oci_internal_debug
  • ocicancel ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_bind_by_name

ocibindbyname

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocibindbyname — 别名 oci_bind_by_name()

说明

别名 oci_bind_by_name()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_cancel

  • ? ocibindbyname
  • ocicloselob ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_cancel

ocicancel

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicancel — 别名 oci_cancel()

说明

别名 oci_cancel()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCI-Lob::close

  • ? ocicancel
  • ocicollappend ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCI-Lob::close

ocicloselob

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 1.0)

ocicloselob — 别名 OCI-Lob::close()

说明

别名 OCI-Lob::close()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCICollection::append

  • ? ocicloselob
  • ocicollassign ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCICollection::append

ocicollappend

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollappend — 别名 OCICollection::append()

说明

别名 OCICollection::append()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCICollection::assign

  • ? ocicollappend
  • ocicollassignelem ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCICollection::assign

ocicollassign

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicollassign — 别名 OCICollection::assign()

说明

别名 OCICollection::assign()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCICollection::assignElem

  • ? ocicollassign
  • ocicollgetelem ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCICollection::assignElem

ocicollassignelem

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollassignelem — 别名 OCICollection::assignElem()

说明

别名 OCICollection::assignElem()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCICollection::getElem

  • ? ocicollassignelem
  • ocicollmax ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCICollection::getElem

ocicollgetelem

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollgetelem — 别名 OCICollection::getElem()

说明

别名 OCICollection::getElem()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCICollection::max

  • ? ocicollgetelem
  • ocicollsize ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCICollection::max

ocicollmax

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollmax — 别名 OCICollection::max()

说明

别名 OCICollection::max()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCICollection::size

  • ? ocicollmax
  • ocicolltrim ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCICollection::size

ocicollsize

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicollsize — 别名 OCICollection::size()

说明

别名 OCICollection::size()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCICollection::trim

  • ? ocicollsize
  • ocicolumnisnull ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCICollection::trim

ocicolltrim

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolltrim — 别名 OCICollection::trim()

说明

别名 OCICollection::trim()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_field_is_null

  • ? ocicolltrim
  • ocicolumnname ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_field_is_null

ocicolumnisnull

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnisnull — 别名 oci_field_is_null()

说明

别名 oci_field_is_null()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_field_name

  • ? ocicolumnisnull
  • ocicolumnprecision ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_field_name

ocicolumnname

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnname — 别名 oci_field_name()

说明

别名 oci_field_name()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_field_precision

  • ? ocicolumnname
  • ocicolumnscale ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_field_precision

ocicolumnprecision

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnprecision — 别名 oci_field_precision()

说明

别名 oci_field_precision()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_field_scale

  • ? ocicolumnprecision
  • ocicolumnsize ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_field_scale

ocicolumnscale

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnscale — 别名 oci_field_scale()

说明

别名 oci_field_scale()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_field_size

  • ? ocicolumnscale
  • ocicolumntype ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_field_size

ocicolumnsize

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumnsize — 别名 oci_field_size()

说明

别名 oci_field_size()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_field_type

  • ? ocicolumnsize
  • ocicolumntyperaw ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_field_type

ocicolumntype

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumntype — 别名 oci_field_type()

说明

别名 oci_field_type()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_field_type_raw

  • ? ocicolumntype
  • ocicommit ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_field_type_raw

ocicolumntyperaw

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicolumntyperaw — 别名 oci_field_type_raw()

说明

别名 oci_field_type_raw()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_commit

  • ? ocicolumntyperaw
  • ocidefinebyname ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_commit

ocicommit

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocicommit — 别名 oci_commit()

说明

别名 oci_commit()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_define_by_name

  • ? ocicommit
  • ocierror ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_define_by_name

ocidefinebyname

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocidefinebyname — 别名 oci_define_by_name()

说明

别名 oci_define_by_name()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_error

  • ? ocidefinebyname
  • ociexecute ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_error

ocierror

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocierror — 别名 oci_error()

说明

别名 oci_error()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_execute

  • ? ocierror
  • ocifetch ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_execute

ociexecute

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociexecute — 别名 oci_execute()

说明

别名 oci_execute()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_fetch

  • ? ociexecute
  • ocifetchinto ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_fetch

ocifetch

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifetch — 别名 oci_fetch()

说明

别名 oci_fetch()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row

  • ? ocifetch
  • ocifetchstatement ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row

ocifetchinto

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifetchinto — Obsolete variant of oci_fetch_array(), oci_fetch_object(), oci_fetch_assoc() and oci_fetch_row()

说明

Obsolete variant of oci_fetch_array(), oci_fetch_object(),
  oci_fetch_assoc() and
  oci_fetch_row()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_fetch_all

  • ? ocifetchinto
  • ocifreecollection ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_fetch_all

ocifetchstatement

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifetchstatement — 别名 oci_fetch_all()

说明

别名 oci_fetch_all()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCICollection::free

  • ? ocifetchstatement
  • ocifreecursor ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCICollection::free

ocifreecollection

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifreecollection — 别名 OCICollection::free()

说明

别名 OCICollection::free()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_free_statement

  • ? ocifreecollection
  • ocifreedesc ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_free_statement

ocifreecursor

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifreecursor — 别名 oci_free_statement()

说明

别名 oci_free_statement()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCI-Lob::free

  • ? ocifreecursor
  • ocifreestatement ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCI-Lob::free

ocifreedesc

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifreedesc — 别名 OCI-Lob::free()

说明

别名 OCI-Lob::free()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_free_statement

  • ? ocifreedesc
  • ociinternaldebug ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_free_statement

ocifreestatement

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocifreestatement — 别名 oci_free_statement()

说明

别名 oci_free_statement()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_internal_debug

  • ? ocifreestatement
  • ociloadlob ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_internal_debug

ociinternaldebug

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0, PECL OCI8 <= 2.2.0)

ociinternaldebug — 别名 oci_internal_debug()

说明

别名 oci_internal_debug()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCI-Lob::load

  • ? ociinternaldebug
  • ocilogoff ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCI-Lob::load

ociloadlob

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociloadlob — 别名 OCI-Lob::load()

说明

别名 OCI-Lob::load()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_close

  • ? ociloadlob
  • ocilogon ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_close

ocilogoff

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocilogoff — 别名 oci_close()

说明

别名 oci_close()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_connect

  • ? ocilogoff
  • ocinewcollection ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_connect

ocilogon

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocilogon — 别名 oci_connect()

说明

别名 oci_connect()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_new_collection

  • ? ocilogon
  • ocinewcursor ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_new_collection

ocinewcollection

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinewcollection — 别名 oci_new_collection()

说明

别名 oci_new_collection()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_new_cursor

  • ? ocinewcollection
  • ocinewdescriptor ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_new_cursor

ocinewcursor

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinewcursor — 别名 oci_new_cursor()

说明

别名 oci_new_cursor()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_new_descriptor

  • ? ocinewcursor
  • ocinlogon ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_new_descriptor

ocinewdescriptor

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinewdescriptor — 别名 oci_new_descriptor()

说明

别名 oci_new_descriptor()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_new_connect

  • ? ocinewdescriptor
  • ocinumcols ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_new_connect

ocinlogon

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinlogon — 别名 oci_new_connect()

说明

别名 oci_new_connect()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_num_fields

  • ? ocinlogon
  • ociparse ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_num_fields

ocinumcols

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocinumcols — 别名 oci_num_fields()

说明

别名 oci_num_fields()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_parse

  • ? ocinumcols
  • ociplogon ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_parse

ociparse

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociparse — 别名 oci_parse()

说明

别名 oci_parse()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_pconnect

  • ? ociparse
  • ociresult ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_pconnect

ociplogon

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociplogon — 别名 oci_pconnect()

说明

别名 oci_pconnect()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_result

  • ? ociplogon
  • ocirollback ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_result

ociresult

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociresult — 别名 oci_result()

说明

别名 oci_result()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_rollback

  • ? ociresult
  • ocirowcount ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_rollback

ocirollback

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocirollback — 别名 oci_rollback()

说明

别名 oci_rollback()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_num_rows

  • ? ocirollback
  • ocisavelob ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_num_rows

ocirowcount

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocirowcount — 别名 oci_num_rows()

说明

别名 oci_num_rows()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCI-Lob::save

  • ? ocirowcount
  • ocisavelobfile ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCI-Lob::save

ocisavelob

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocisavelob — 别名 OCI-Lob::save()

说明

别名 OCI-Lob::save()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCI-Lob::import

  • ? ocisavelob
  • ociserverversion ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCI-Lob::import

ocisavelobfile

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocisavelobfile — 别名 OCI-Lob::import()

说明

别名 OCI-Lob::import()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_server_version

  • ? ocisavelobfile
  • ocisetprefetch ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_server_version

ociserverversion

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociserverversion — 别名 oci_server_version()

说明

别名 oci_server_version()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_set_prefetch

  • ? ociserverversion
  • ocistatementtype ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_set_prefetch

ocisetprefetch

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocisetprefetch — 别名 oci_set_prefetch()

说明

别名 oci_set_prefetch()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 oci_statement_type

  • ? ocisetprefetch
  • ociwritelobtofile ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 oci_statement_type

ocistatementtype

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ocistatementtype — 别名 oci_statement_type()

说明

别名 oci_statement_type()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCI-Lob::export

  • ? ocistatementtype
  • ociwritetemporarylob ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCI-Lob::export

ociwritelobtofile

(PHP 4, PHP 5, PHP 7, PHP 8, PECL OCI8 >= 1.0.0)

ociwritelobtofile — 别名 OCI-Lob::export()

说明

别名 OCI-Lob::export()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


别名 OCI-Lob::writeTemporary

  • ? ociwritelobtofile
  • Paradox ?
  • PHP Manual
  • OCI8 Obsolete Aliases and Functions
  • 别名 OCI-Lob::writeTemporary

ociwritetemporarylob

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 1.0)

ociwritetemporarylob — 别名 OCI-Lob::writeTemporary()

说明

别名 OCI-Lob::writeTemporary()

Warning

自 PHP 5.4.0 起，已经废弃此别名。强烈建议不要应用此别名。


Paradox File Access

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Paradox 函数
    • px_close — Closes a paradox database
    • px_create_fp — Create a new paradox database
    • px_date2string — Converts a date into a string
    • px_delete_record — Deletes record from paradox database
    • px_delete — Deletes resource of paradox database
    • px_get_field — Returns the specification of a single field
    • px_get_info — Return lots of information about a paradox file
    • px_get_parameter — Gets a parameter
    • px_get_record — Returns record of paradox database
    • px_get_schema — Returns the database schema
    • px_get_value — Gets a value
    • px_insert_record — Inserts record into paradox database
    • px_new — Create a new paradox object
    • px_numfields — Returns number of fields in a database
    • px_numrecords — Returns number of records in a database
    • px_open_fp — Open paradox database
    • px_put_record — Stores record into paradox database
    • px_retrieve_record — Returns record of paradox database
    • px_set_blob_file — Sets the file where blobs are read from
    • px_set_parameter — Sets a parameter
    • px_set_tablename — Sets the name of a table (deprecated)
    • px_set_targetencoding — Sets the encoding for character fields (deprecated)
    • px_set_value — Sets a value
    • px_timestamp2string — Converts the timestamp into a string
    • px_update_record — Updates record in paradox database


简介

This module allows to read and write Paradox databases, primary index files and blob files. Write support has been proven to be quite reliable, though due to lack of documentation the produced files may not in any case be readable by other applications. Encrypted databases can be read without specifying a password if pxlib >= 0.5.0 is used.

Note:

This module is also in development and may change, though major changes to the API are not expected.

Warning

此扩展是实验性 的。 此扩展的表象，包括其函数名称以及其他此扩展的相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本扩展风险自担。


需求

You need at least PHP 5.0.0 and pxlib >= 0.4.4 for the basic set of functions. Some newer functions are only available with pxlib >= 0.6.0. Reading and writing of encrypted databases requires at least pxlib >= 0.5.0. The paradox library (pxlib) is available at » http://pxlib.sourceforge.net.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/paradox

Make sure you have pxlib installed before. If you install pxlib from an rpm or debian package, do not forget to install the development package as well.


资源类型

px_new() creates a new Paradox object required by all Paradox functions.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

The following two tables lists all constants defined by the paradox extension.

Contants for field types
Name | Meaning
PX_FIELD_ALPHA | Character data with fixed length
PX_FIELD_DATE | Date, number of days since 1.1.0000
PX_FIELD_SHORT | Short integer (2 Bytes)
PX_FIELD_LONG | Long integer (4 Bytes)
PX_FIELD_CURRENCY | same as PX_FIELD_NUMBER
PX_FIELD_NUMBER | Double
PX_FIELD_LOGICAL | Boolean
PX_FIELD_MEMOBLOB | Binary large object
PX_FIELD_BLOB | Binary large object (not supported)
PX_FIELD_FMTMEMOBLOB | Binary large object
PX_FIELD_OLE | OLE object (basically a blob, not supported)
PX_FIELD_GRAPHIC | Graphic (basically a blob, not supported)
PX_FIELD_TIME | time, number of milli seconds since midnight
PX_FIELD_TIMESTAMP | timestamp, number of milli seconds since 1.1.0000
PX_FIELD_AUTOINC | Auto incrementing interger (like PX_FIELD_LONG)
PX_FIELD_BCD | Decimal number stored in bcd format (not supported)
PX_FIELD_BYTES | Array of Bytes with not more than 255 bytes (not supported)
PX_KEYTOLOWER | Turn all field names into lower case
PX_KEYTOUPPER | Turn all field names into upper case
Contants for file types
Name | Meaning
PX_FILE_INDEX_DB | Indexed database
PX_FILE_PRIM_INDEX | Primary index
PX_FILE_NON_INDEX_DB | None indexed database
PX_FILE_NON_INC_SEC_INDEX | None incremental secondary index
PX_FILE_SEC_INDEX | Secondary index
PX_FILE_INC_SEC_INDEX | Incremental secondary index
PX_FILE_NON_INC_SEC_INDEX_G | Non incremental secondary index
PX_FILE_SEC_INDEX_G | Secondary index
PX_FILE_INC_SEC_INDEX_G | Non incremental secondary index


Paradox 函数

Object oriented API

The paradox extension provides also an object oriented API. It consists of only one class called paradox_db. Its methods only differ from the functions in its name and of course the missing first parameter. The following table will list all methods and its equivalent functions.

Methods of class paradox_db
Name of method | Equivalent function
Constructor | px_new()
Destructor | px_delete()
open_fp() | px_open_fp()
create_fp() | px_create_fp()
close() | px_close()
numrecords() | px_numrecords()
numfields() | px_numfields()
get_record() | px_get_record()
put_record() | px_put_record()
retrieve_record() | px_retrieve_record()
delete_record() | px_delete_record()
insert_record() | px_insert_record()
update_record() | px_update_record()
get_field() | px_get_field()
get_schema() | px_get_schema()
get_info() | px_get_info()
set_parameter() | px_set_parameter()
get_parameter() | px_get_parameter()
set_value() | px_set_value()
get_value() | px_get_value()
get_info() | px_get_info()
set_targetencoding() | px_set_targetencoding()
set_tablename() | px_set_tablename()
set_blob_file() | px_set_blob_file()
date2string() | px_date2string()
timestamp2string() | px_timestamp2string()

Table of Contents

  • px_close — Closes a paradox database
  • px_create_fp — Create a new paradox database
  • px_date2string — Converts a date into a string
  • px_delete_record — Deletes record from paradox database
  • px_delete — Deletes resource of paradox database
  • px_get_field — Returns the specification of a single field
  • px_get_info — Return lots of information about a paradox file
  • px_get_parameter — Gets a parameter
  • px_get_record — Returns record of paradox database
  • px_get_schema — Returns the database schema
  • px_get_value — Gets a value
  • px_insert_record — Inserts record into paradox database
  • px_new — Create a new paradox object
  • px_numfields — Returns number of fields in a database
  • px_numrecords — Returns number of records in a database
  • px_open_fp — Open paradox database
  • px_put_record — Stores record into paradox database
  • px_retrieve_record — Returns record of paradox database
  • px_set_blob_file — Sets the file where blobs are read from
  • px_set_parameter — Sets a parameter
  • px_set_tablename — Sets the name of a table (deprecated)
  • px_set_targetencoding — Sets the encoding for character fields (deprecated)
  • px_set_value — Sets a value
  • px_timestamp2string — Converts the timestamp into a string
  • px_update_record — Updates record in paradox database


Closes a paradox database

  • ? Paradox 函数
  • px_create_fp ?
  • PHP Manual
  • Paradox 函数
  • Closes a paradox database

px_close

(PECL paradox >= 1.0.0)

px_close — Closes a paradox database

说明

px_close ( resource $pxdoc ) : bool

Closes the paradox database. This function will not close the file. You will have to call fclose() afterwards.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • px_open_fp() - Open paradox database
  • The example at px_new() - Create a new paradox object


Create a new paradox database

  • ? px_close
  • px_date2string ?
  • PHP Manual
  • Paradox 函数
  • Create a new paradox database

px_create_fp

(PECL paradox >= 1.0.0)

px_create_fp — Create a new paradox database

说明

px_create_fp ( resource $pxdoc , resource $file , array $fielddesc ) : bool

Create a new paradox database file. The actual file has to be opened before with fopen(). Make sure the file is writable.

Note:

Calling this functions issues a warning about an empty tablename which can be safely ignored. Just set the tablename afterwards with px_set_parameter().

Note:

This function is highly experimental, due to insufficient documentation of the paradox file format. Database files created with this function can be opened by px_open_fp() and has been successfully opened by the Paradox software, but your milage may vary.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

file

File handle as returned by fopen().

fielddesc

fielddesc is an array containing one element for each field specification. A field specification is an array itself with either two or three elements.The first element is always a string value used as the name of the field. It may not be larger than ten characters. The second element contains the field type which is one of the constants listed in the table Constants for field types. In the case of a character field or bcd field, you will have to provide a third element specifying the length respectively the precesion of the field. If your field specification contains blob fields, you will have to make sure to either make the field large enough for all field values to fit or specify a blob file with px_set_blob_file() for storing the blobs. If this is not done the field data is truncated.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Creating a Paradox database with two fields

<?php
if(!$pxdoc = px_new()) {
  /* Error handling */
}
$fp = fopen("test.db", "w+");
$fields = array(array("col1", "S"), array("col2", "I"));
if(!px_create_fp($pxdoc, $fp, $fields)) {
  /* Error handling */
}
px_set_parameter($pxdoc, "tablename", "testtable");
for($i=-50; $i<50; $i++) {
  $rec = array($i, -$i);
  px_put_record($pxdoc, $rec);
}
px_close($pxdoc);
px_delete($pxdoc);
fclose($fp);
?>

参见

  • px_new() - Create a new paradox object
  • px_put_record() - Stores record into paradox database
  • fopen() - 打开文件或者 URL


Converts a date into a string

  • ? px_create_fp
  • px_delete_record ?
  • PHP Manual
  • Paradox 函数
  • Converts a date into a string

px_date2string

(PECL paradox >= 1.4.0)

px_date2string — Converts a date into a string

说明

px_date2string ( resource $pxdoc , int $value , string $format ) : string

Turns a date as it stored in the paradox file into human readable format. Paradox dates are the number of days since 1.1.0000. This function is just for convenience. It can be easily replaced by some math and the calendar functions as demonstrated in the example below.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

value

Value as stored in paradox database field of type PX_FIELD_DATE.

format

String format similar to the format used by date(). The placeholders support by this function is a subset of those supported by date() (Y, y, m, n, d, j, L).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Turn a paradox date into a human readable form

<?php
$px = px_new();

/* make up a date as it could be stored in */
/* a date field of a paradox db. */
/* 700000 days since 1.1.0000. */
$days = 700000;

/* Use the calendar functions to print a */
/* human readable format of the date */
echo jdtogregorian($days+1721425)."\n";
/* px_date2string() outputs the same */
echo px_date2string($px, $days, "n/d/Y")."\n";

px_delete($px);
?>

以上例程会输出：

7/15/1917
7/15/1917

参见

  • px_timestamp2string() - Converts the timestamp into a string
  • jdtogregorian() - 转变一个Julian Day计数为Gregorian历法日期


Deletes record from paradox database

  • ? px_date2string
  • px_delete ?
  • PHP Manual
  • Paradox 函数
  • Deletes record from paradox database

px_delete_record

(PECL paradox >= 1.4.0)

px_delete_record — Deletes record from paradox database

说明

px_delete_record ( resource $pxdoc , int $num ) : bool

This function deletes a record from the database. It does not free the space in the database file but just marks it as deleted. Inserting a new record afterwards will reuse the space.

Note:

This function is only available if pxlib >= 0.6.0 is used.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

返回值

成功时返回 true， 或者在失败时返回 false。


Deletes resource of paradox database

  • ? px_delete_record
  • px_get_field ?
  • PHP Manual
  • Paradox 函数
  • Deletes resource of paradox database

px_delete

(PECL paradox >= 1.0.0)

px_delete — Deletes resource of paradox database

说明

px_delete ( resource $pxdoc ) : bool

Deletes the resource of the paradox file and frees all memory.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

返回值

成功时返回 true， 或者在失败时返回 false。


Returns the specification of a single field

  • ? px_delete
  • px_get_info ?
  • PHP Manual
  • Paradox 函数
  • Returns the specification of a single field

px_get_field

(PECL paradox >= 1.0.0)

px_get_field — Returns the specification of a single field

说明

px_get_field ( resource $pxdoc , int $fieldno ) : array

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

fieldno

Number of the field. The first field has number 0. Specifying a field number less than 0 and greater or equal the number of fields will trigger an error.

返回值

Returns the specification of the fieldno'th database field as an associated array. The array contains three fields named name, type, and size.


Return lots of information about a paradox file

  • ? px_get_field
  • px_get_parameter ?
  • PHP Manual
  • Paradox 函数
  • Return lots of information about a paradox file

px_get_info

(PECL paradox >= 1.0.0)

px_get_info — Return lots of information about a paradox file

说明

px_get_info ( resource $pxdoc ) : array

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

返回值

Returns an associated array with lots of information about a paradox file. This array is likely to be extended in the future.

fileversion

Version of file multiplied by 10, e.g. 70.

tablename

Name of table as stored in the file. If the database was created by pxlib, then this will be the name of the file without the extension.

numrecords

Number of records in this table.

numfields

Number of fields in this table.

headersize

Number of bytes used for the header. This is usually 0x800.

recordsize

Number of bytes used for each record. This is the sum of all field sizes (available since version 1.4.2).

maxtablesize

This value multiplied by 0x400 is the size of a data block in bytes. The maximum number of records in a datablock is the integer part of (maxtablesize * 0x400 - 8) / recordsize.

numdatablocks

The number of data blocks in the file. Each data block contains a certain number of records which depends on the record size and the data block size (maxtablesize). Data blocks may not necessarily be completely filled.

numindexfields

Number of fields used for the primary index. The fields do always start with field number 1.

codepage

The DOS codepage which was used for encoding fields with character data. If the target encoding is not set with px_set_targetencoding() this will be the encoding for character fields when records are being accessed with px_get_record() or px_retrieve_record().

参见

  • px_numfields() - Returns number of fields in a database
  • px_numrecords() - Returns number of records in a database


Gets a parameter

  • ? px_get_info
  • px_get_record ?
  • PHP Manual
  • Paradox 函数
  • Gets a parameter

px_get_parameter

(PECL paradox >= 1.1.0)

px_get_parameter — Gets a parameter

说明

px_get_parameter ( resource $pxdoc , string $name ) : string|false

Gets various parameters.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

The name can be one of the following:

tablename

The name of the table as it will be stored in the database header.

targetencoding

The encoding for the output. Data which is being read from character fields with px_get_record() or px_retrieve_record() is recoded into the targetencoding. If it is not set, then the data will be delivered as stored in the database file.

inputencoding

The encoding of the input data which is to be stored into the database. When storing data of character fields in the database, the data is expected to be delivered in this encoding.

返回值

Returns the value of the parameter 或者在失败时返回 false.


Returns record of paradox database

  • ? px_get_parameter
  • px_get_schema ?
  • PHP Manual
  • Paradox 函数
  • Returns record of paradox database

px_get_record

(PECL paradox >= 1.0.0)

px_get_record — Returns record of paradox database

说明

px_get_record ( resource $pxdoc , int $num , int $mode = 0 ) : array

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

mode

The optional mode can be PX_KEYTOLOWER or PX_KEYTOUPPER in order to convert the keys of the returned array into lower or upper case. If mode is not passed or is 0, then the key will be exactly like the field name. The element values will contain the field values. NULL values will be retained and are different from 0.0, 0 or the empty string. Fields of type PX_FIELD_TIME will be returned as an integer counting the number of milliseconds starting at midnight. A timestamp (PX_FIELD_TIMESTAMP) and date (PX_FIELD_DATE) are floating point respectively int values counting milliseconds respectively days starting at the beginning of julian calendar. Use the functions px-timestamp2string() and px-date2string() to convert them into a character representation.

返回值

Returns the num'th record from the paradox database. The record is returned as an associated array with its keys being the field names.

参见

  • px_retrieve_record() - Returns record of paradox database


Returns the database schema

  • ? px_get_record
  • px_get_value ?
  • PHP Manual
  • Paradox 函数
  • Returns the database schema

px_get_schema

(PECL paradox >= 1.0.0)

px_get_schema — Returns the database schema

说明

px_get_schema ( resource $pxdoc , int $mode = 0 ) : array

px_get_schema() returns the database schema.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

mode

If the optional mode is PX_KEYTOLOWER or PX_KEYTOUPPER the keys of the returned array will be converted to lower or upper case. If mode is 0 or not passed at all, then the key name will be identical to the field name.

返回值

Returns the schema of a database file as an associated array. The key name is equal to the field name. Each array element is itself an associated array containing the two fields type and size. type is one of the constants in table Constants for field types. size is the number of bytes this field consumes in the record. The total of all field sizes is equal to the record size as it can be retrieved with px-get-info().


Gets a value

  • ? px_get_schema
  • px_insert_record ?
  • PHP Manual
  • Paradox 函数
  • Gets a value

px_get_value

(PECL paradox >= 1.1.0)

px_get_value — Gets a value

说明

px_get_value ( resource $pxdoc , string $name ) : float|false

Gets various values.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

name can be one of the following.

numprimkeys

The number of primary keys. Paradox databases always use the first numprimkeys fields for the primary index.

返回值

Returns the value of the parameter 或者在失败时返回 false.


Inserts record into paradox database

  • ? px_get_value
  • px_new ?
  • PHP Manual
  • Paradox 函数
  • Inserts record into paradox database

px_insert_record

(PECL paradox >= 1.4.0)

px_insert_record — Inserts record into paradox database

说明

px_insert_record ( resource $pxdoc , array $data ) : int

Inserts a new record into the database. The record is not necessarily inserted at the end of the database, but may be inserted at any position depending on where the first free slot is found.

The record data is passed as an array of field values. The elements in the array must correspond to the fields in the database. If the array has less elements than fields in the database, the remaining fields will be set to null.

Most field values can be passed as its equivalent php type e.g. a long value is used for fields of type PX_FIELD_LONG, PX_FIELD_SHORT and PX_FIELD_AUTOINC, a double values is used for fields of type PX_FIELD_CURRENCY and PX_FIELD_NUMBER. Field values for blob and alpha fields are passed as strings.

Fields of type PX_FIELD_TIME and PX_FIELD_DATE both require a long value. In the first case this is the number of milliseconds since midnight. In the second case this is the number of days since 1.1.0000. Below there are two examples to convert the current date or timestamp into a value suitable for one of paradox's date/time fields.

Note:

This function is only available if pxlib >= 0.6.0 is used.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

data

Associated or indexed array containing the field values as e.g. returned by px_retrieve_record().

返回值

Returns false on failure or the record number in case of success.

范例

Example #1 Set the date/time fields in a paradox database to the current date/time

<?php
$px = px_new();
$fp = fopen("test.db", "w+");
px_create_fp($px, $fp, array(array("timestamp", "@"), array("time", "T"), array("date", "D")));

$curdate = getdate();
$jd = gregoriantojd($curdate["mon"], $curdate["mday"], $curdate["year"]);
$days = $jd - 1721425; /* Number of days between 1.1.4714 b.c. and 1.1.0000 */
$secs = $curdate["hours"]*3600 + $curdate["minutes"]*60 + $curdate["seconds"];
px_insert_record($px, array($days*86400000.0 + $secs*1000.0, $secs*1000.0, $days));

$curtimestamp = microtime(true);
$days = (int) ($curtimestamp/86400);
$secs = $curtimestamp - ($days * 86400.0);
$days += 2440588; /* Number of days between 1.1.4714 b.c. and 1.1.1970 */
$days -= 1721425; /* Number of days between 1.1.4714 b.c. and 1.1.0000 */
px_insert_record($px, array($days*86400000.0 + $secs*1000.0, $secs*1000.0, $days));
for($i=0; $i<2; $i++) {
    $rec = px_retrieve_record($px, $i);
    echo px_timestamp2string($px, $rec["timestamp"], "n/d/Y H:i:s")."\n";
    echo px_date2string($px, $rec["date"], "n/d/Y")."\n";
}
px_close($px);
px_delete($px);
?>

以上例程会输出：

2/21/2006 21:42:30
2/21/2006
2/21/2006 20:42:30
2/21/2006

The Julian day count as passed to jdtogregorian() has a different base of 1.1.4714 b.c. and must therefore be calculated by adding 1721425 to the day count used in the paradox file. Turning the day count into a timestamp is easily done by multiplying with 86400000.0 to obtain milli seconds.

参见

px_update_record() - Updates record in paradox database


Create a new paradox object

  • ? px_insert_record
  • px_numfields ?
  • PHP Manual
  • Paradox 函数
  • Create a new paradox object

px_new

(PECL paradox >= 1.0.0)

px_new — Create a new paradox object

说明

px_new ( ) : resource

Create a new paradox object. You will have to call this function before any further functions. px_new() does not create any file on the disk, it just creates an instance of a paradox object. This function must not be called if the object oriented interface is used. Use new paradox_db() instead.

返回值

Returns false on failure.

范例

Example #1 Opening a Paradox database

<?php
if(!$pxdoc = px_new()) {
  /* Error handling */
}
$fp = fopen("test.db", "r");
if(!px_open_fp($pxdoc, $fp)) {
  /* Error handling */
}
// ...
px_close($pxdoc);
px_delete($pxdoc);
fclose($fp);
?>

If you prefer the object oriented API, then the above example will look like the following.

Example #2 Opening a Paradox database

<?php
$fp = fopen("test.db", "r");
$pxdoc = new paradox_db();
if(!$pxdoc->open_fp($fp)) {
  /* Error handling */
}
// ...
$pxdoc->close();
fclose($fp);
?>

参见

  • px_delete() - Deletes resource of paradox database
  • px_open_fp() - Open paradox database


Returns number of fields in a database

  • ? px_new
  • px_numrecords ?
  • PHP Manual
  • Paradox 函数
  • Returns number of fields in a database

px_numfields

(PECL paradox >= 1.0.0)

px_numfields — Returns number of fields in a database

说明

px_numfields ( resource $pxdoc ) : int

Get the number of fields in a database file.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

返回值

Returns the number of fields in a database file. The return value of this function is identical to the element numfields in the array returned by px_get_info().


Returns number of records in a database

  • ? px_numfields
  • px_open_fp ?
  • PHP Manual
  • Paradox 函数
  • Returns number of records in a database

px_numrecords

(PECL paradox >= 1.0.0)

px_numrecords — Returns number of records in a database

说明

px_numrecords ( resource $pxdoc ) : int

Get the number of records in a database file.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

返回值

Returns the number of records in a database file. The return value of this function is identical to the element numrecords in the array returned by px_get_info().


Open paradox database

  • ? px_numrecords
  • px_put_record ?
  • PHP Manual
  • Paradox 函数
  • Open paradox database

px_open_fp

(PECL paradox >= 1.0.0)

px_open_fp — Open paradox database

说明

px_open_fp ( resource $pxdoc , resource $file ) : bool

Open an existing paradox database file. The actual file has to be opened before with fopen(). This function can also be used to open primary index files and tread them like a paradox database. This is supported for those who would like to investigate a primary index. It cannot be used to accelerate access to a database file.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

file

file is the return value from fopen() with the actual database file as parameter. Make sure the database is writable if you plan to update or insert records.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fopen() - 打开文件或者 URL
  • The example at px_new() - Create a new paradox object


Stores record into paradox database

  • ? px_open_fp
  • px_retrieve_record ?
  • PHP Manual
  • Paradox 函数
  • Stores record into paradox database

px_put_record

(PECL paradox >= 1.0.0)

px_put_record — Stores record into paradox database

说明

px_put_record ( resource $pxdoc , array $record , int $recpos = -1 ) : bool

Stores a record into a paradox database. The record is always added at the end of the database, regardless of any free slots. Use px_insert_record() to add a new record into the first free slot found in the database.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

record

Associated or indexed array containing the field values as e.g. returned by px_retrieve_record().

recpos

This optional parameter may be used to specify a record number greater than the current number of records in the database. The function will add as many empty records as needed. There is hardly any need for this parameter.

返回值

成功时返回 true， 或者在失败时返回 false。


Returns record of paradox database

  • ? px_put_record
  • px_set_blob_file ?
  • PHP Manual
  • Paradox 函数
  • Returns record of paradox database

px_retrieve_record

(PECL paradox >= 1.4.0)

px_retrieve_record — Returns record of paradox database

说明

px_retrieve_record ( resource $pxdoc , int $num , int $mode = 0 ) : array

This function is very similar to px_get_record() but uses internally a different approach to retrieve the data. It relies on pxlib for reading each single field value, which usually results in support for more field types.

Note:

This function is only available if pxlib >= 0.6.0 is used.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

mode

The optional mode can be PX_KEYTOLOWER or PX_KEYTOUPPER in order to convert the keys into lower or upper case. If mode is not passed or is 0, then the key will be exactly like the field name. The element values will contain the field values. NULL values will be retained and are different from 0.0, 0 or the empty string. Fields of type PX_FIELD_TIME will be returned as an integer counting the number of milliseconds starting at midnight. A timestamp is a floating point value also counting milliseconds starting at the beginning of julian calendar.

返回值

Returns the num'th record from the paradox database. The record is returned as an associated array with its keys being the field names.

参见

  • px_get_record() - Returns record of paradox database


Sets the file where blobs are read from

  • ? px_retrieve_record
  • px_set_parameter ?
  • PHP Manual
  • Paradox 函数
  • Sets the file where blobs are read from

px_set_blob_file

(PECL paradox >= 1.3.0)

px_set_blob_file — Sets the file where blobs are read from

说明

px_set_blob_file ( resource $pxdoc , string $filename ) : bool

Sets the name of the file where blobs are going to be read from or written into. Without calling this function, px_get_record() or px_retrieve_record() will only return data in blob fields if the data is part of the record and not stored in the blob file. Blob data is stored in the record if it is small enough to fit in the size of the blob field.

Calling px_put_record(),
px_insert_record(), or
px_update_record() without calling
px_set_blob_file() will result in truncated blob fields
unless the data fits into the database file.

Calling this function twice will close the first blob file and open the new one.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

filename

The name of the file. Its extension should be .MB.

返回值

成功时返回 true， 或者在失败时返回 false。


Sets a parameter

  • ? px_set_blob_file
  • px_set_tablename ?
  • PHP Manual
  • Paradox 函数
  • Sets a parameter

px_set_parameter

(PECL paradox >= 1.1.0)

px_set_parameter — Sets a parameter

说明

px_set_parameter ( resource $pxdoc , string $name , string $value ) : bool

Sets various parameters.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

Depending on the parameter you want to set, name can be one of the following.

tablename

The name of the table as it will be stored in the database header.

targetencoding

The encoding for the output. Data which is being read from character fields is recoded into the targetencoding.

inputencoding

The encoding of the input data which is to be stored into the database.

value

The value of parameter to set. For inputencoding and targetencoding this must be the name of the encoding as understood by iconv or recode, e.g. iso-8859-1, utf-8, cp850.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • px_get_info() - Return lots of information about a paradox file to determine the DOS code page.


Sets the name of a table (deprecated)

  • ? px_set_parameter
  • px_set_targetencoding ?
  • PHP Manual
  • Paradox 函数
  • Sets the name of a table (deprecated)

px_set_tablename

(PECL paradox >= 1.0.0)

px_set_tablename — Sets the name of a table (deprecated)

说明

px_set_tablename ( resource $pxdoc , string $name ) : void|false

Sets the table name of a paradox database, which was created with px_create_fp(). This function is deprecated use px_set_parameter() instead.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

tablename

The name of the table. If it is not set explicitly it will be set to the name of the database file.

返回值

Returns null on success 或者在失败时返回 false.

参见

px_set_parameter() - Sets a parameter


Sets the encoding for character fields (deprecated)

  • ? px_set_tablename
  • px_set_value ?
  • PHP Manual
  • Paradox 函数
  • Sets the encoding for character fields (deprecated)

px_set_targetencoding

(PECL paradox >= 1.0.0)

px_set_targetencoding — Sets the encoding for character fields (deprecated)

说明

px_set_targetencoding ( resource $pxdoc , string $encoding ) : bool

Set the encoding for data retrieved from a character field. All character fields will be recoded to the encoding set by this function. If the encoding is not set, the character data will be returned in the DOS code page encoding as specified in the database file. The encoding can be any string identifier known to iconv or recode. On Unix systems run iconv -l for a list of available encodings.

This function is deprecated and should be replaced by calling px_set_parameter().

See also px_get_info() to determine the DOS code page as stored in the database file.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

encoding

The encoding for the output. Data which is being read from character fields is recoded into the targetencoding.

返回值

Returns false if the encoding could not be set, e.g. the encoding is unknown, or pxlib does not support recoding at all. In the second case a warning will be issued.

参见

px_set_parameter() - Sets a parameter


Sets a value

  • ? px_set_targetencoding
  • px_timestamp2string ?
  • PHP Manual
  • Paradox 函数
  • Sets a value

px_set_value

(PECL paradox >= 1.1.0)

px_set_value — Sets a value

说明

px_set_value ( resource $pxdoc , string $name , float $value ) : bool

Sets various values.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

name can be one of the following.

numprimkeys

The number of primary keys. Paradox databases always use the first numprimkeys fields for the primary index.

value

返回值

成功时返回 true， 或者在失败时返回 false。

参见

px_set_parameter() - Sets a parameter


Converts the timestamp into a string

  • ? px_set_value
  • px_update_record ?
  • PHP Manual
  • Paradox 函数
  • Converts the timestamp into a string

px_timestamp2string

(PECL paradox >= 1.4.0)

px_timestamp2string — Converts the timestamp into a string

说明

px_timestamp2string ( resource $pxdoc , float $value , string $format ) : string

Turns a timestamp as it stored in the paradox file into human readable format. Paradox timestamps are the number of miliseconds since 0001-01-02. This function is just for convenience. It can be easily replaced by some math and the calendar functions as demonstrated in the following example.

参数

pxdoc

Resource identifier of the paradox database.

value

Value as stored in paradox database field of type PX_FIELD_TIME, or PX_FIELD_TIMESTAMP.

format

String format similar to the format used by date(). The placeholders support by this function is a subset of those supported by date() (Y, y, m, n, d, j, H, h, G, g, i, s, A, a, L).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Turn a paradox timestamp into a human readable form

<?php
$px = px_new();

/* make up a date as it could be stored in */
/* a date field of a paradox db. */
/* 700000 days since 1.1.0000. */
$days = 700000;

/* Use the calendar functions to print a */
/* human readable format of the date */
echo jdtogregorian($days+1721425)."\n";

/* Turn it into a timestamp as it stored in a paradox database */
/* Timestamps are stored in miliseconds since 0001-01-02 */
$stamp = $days * 86400.0 * 1000.0;
/* Add one hour */
$stamp += 3600000.0;
/* The following will output '7/15/1917 01:00:00'. */
echo px_timestamp2string($px, $stamp, "n/d/Y H:i:s")."\n";

px_delete($px);
?>

以上例程会输出：

7/15/1917
7/15/1917 01:00:00

The Julian day count as passed to jdtogregorian() has a different base of 1.1.4714 b.c. and must therefore be calculated by adding 1721425 to the day count used in the paradox file. Turning the day count into a timestamp is easily done by multiplying with 86400000.0 to obtain miliseconds.

参见

  • px_date2string() - Converts a date into a string
  • jdtogregorian() - 转变一个Julian Day计数为Gregorian历法日期


Updates record in paradox database

  • ? px_timestamp2string
  • PostgreSQL ?
  • PHP Manual
  • Paradox 函数
  • Updates record in paradox database

px_update_record

(PECL paradox >= 1.4.0)

px_update_record — Updates record in paradox database

说明

px_update_record ( resource $pxdoc , array $data , int $num ) : bool

Updates an exiting record in the database. The record starts at 0.

The record data is passed as an array of field values. The elements in the array must correspond to the fields in the database. If the array has less elements than fields in the database, the remaining fields will be set to null.

Note:

This function is only available if pxlib >= 0.6.0 is used.

参数

pxdoc

Resource identifier of the paradox database as returned by px_new().

data

Associated array containing the field values as returned by px_retrieve_record().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

px_insert_record() - Inserts record into paradox database


PostgreSQL

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic usage
    • Basic usage
  • PostgreSQL 函数
    • pg_affected_rows — 返回受影响的记录数目
    • pg_cancel_query — 取消异步查询
    • pg_client_encoding — 取得客户端编码方式
    • pg_close — 关闭一个 PostgreSQL 连接
    • pg_connect_poll — 正在进行尝试轮询 PostgreSQL 链接状态。
    • pg_connect — 打开一个 PostgreSQL 连接
    • pg_connection_busy — 获知连接是否为忙
    • pg_connection_reset — 重置连接（再次连接）
    • pg_connection_status — 获得连接状态
    • pg_consume_input — Reads input on the connection
    • pg_convert — 将关联的数组值转换为适合 SQL 语句的格式。
    • pg_copy_from — 根据数组将记录插入表中
    • pg_copy_to — 将一个表拷贝到数组中
    • pg_dbname — 获得数据库名
    • pg_delete — 删除记录
    • pg_end_copy — 与 PostgreSQL 后端同步
    • pg_escape_bytea — 转义 bytea 类型的二进制数据
    • pg_escape_identifier — Escape a identifier for insertion into a text field
    • pg_escape_literal — Escape a literal for insertion into a text field
    • pg_escape_string — 转义 text/char 类型的字符串
    • pg_execute — Sends a request to execute a prepared statement with given parameters, and waits for the result
    • pg_fetch_all_columns — Fetches all rows in a particular result column as an array
    • pg_fetch_all — 从结果中提取所有行作为一个数组
    • pg_fetch_array — 提取一行作为数组
    • pg_fetch_assoc — 提取一行作为关联数组
    • pg_fetch_object — 提取一行作为对象
    • pg_fetch_result — 从结果资源中返回值
    • pg_fetch_row — 提取一行作为枚举数组
    • pg_field_is_null — 测试字段是否为 null
    • pg_field_name — 返回字段的名字
    • pg_field_num — 返回字段的编号
    • pg_field_prtlen — 返回打印出来的长度
    • pg_field_size — 返回指定字段占用内部存储空间的大小
    • pg_field_table — Returns the name or oid of the tables field
    • pg_field_type_oid — Returns the type ID (OID) for the corresponding field number
    • pg_field_type — 返回相应字段的类型名称
    • pg_flush — 刷新链接中已处理的数据查询
    • pg_free_result — 释放查询结果占用的内存
    • pg_get_notify — Ping 数据库连接
    • pg_get_pid — Ping 数据库连接
    • pg_get_result — 取得异步查询结果
    • pg_host — 返回和某连接关联的主机名
    • pg_insert — 将数组插入到表中
    • pg_last_error — 得到某连接的最后一条错误信息
    • pg_last_notice — 返回 PostgreSQL 服务器最新一条公告信息
    • pg_last_oid — 返回上一个对象的 oid
    • pg_lo_close — 关闭一个大型对象
    • pg_lo_create — 新建一个大型对象
    • pg_lo_export — 将大型对象导出到文件
    • pg_lo_import — 将文件导入为大型对象
    • pg_lo_open — 打开一个大型对象
    • pg_lo_read_all — 读入整个大型对象并直接发送给浏览器
    • pg_lo_read — 从大型对象中读入数据
    • pg_lo_seek — 移动大型对象中的指针
    • pg_lo_tell — 返回大型对象的当前指针位置
    • pg_lo_truncate — Truncates a large object
    • pg_lo_unlink — 删除一个大型对象
    • pg_lo_write — 向大型对象写入数据
    • pg_meta_data — 获得表的元数据
    • pg_num_fields — 返回字段的数目
    • pg_num_rows — 返回行的数目
    • pg_options — 获得和连接有关的选项
    • pg_parameter_status — Looks up a current parameter setting of the server
    • pg_pconnect — 打开一个持久的 PostgreSQL 连接
    • pg_ping — Ping 数据库连接
    • pg_port — 返回该连接的端口号
    • pg_prepare — Submits a request to create a prepared statement with the given parameters, and waits for completion
    • pg_put_line — 向 PostgreSQL 后端发送以 NULL 结尾的字符串
    • pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
    • pg_query — 执行查询
    • pg_result_error_field — Returns an individual field of an error report
    • pg_result_error — 获得查询结果的错误信息
    • pg_result_seek — 在结果资源中设定内部行偏移量
    • pg_result_status — 获得查询结果的状态
    • pg_select — 选择记录
    • pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)
    • pg_send_prepare — Sends a request to create a prepared statement with the given parameters, without waiting for completion
    • pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s)
    • pg_send_query — 发送异步查询
    • pg_set_client_encoding — 设定客户端编码
    • pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error and pg_result_error
    • pg_socket — Get a read only handle to the socket underlying a PostgreSQL connection
    • pg_trace — 启动一个 PostgreSQL 连接的追踪功能
    • pg_transaction_status — Returns the current in-transaction status of the server
    • pg_tty — 返回该连接的 tty 号
    • pg_unescape_bytea — 取消 bytea 类型中的字符串转义
    • pg_untrace — 关闭 PostgreSQL 连接的追踪功能
    • pg_update — 更新表
    • pg_version — Returns an array with client, protocol and server version (when available)


简介

PostgreSQL database is an Open Source product and available without cost. Postgres, developed originally in the UC Berkeley Computer Science Department, pioneered many of the object-relational concepts now becoming available in some commercial databases. It provides SQL92/SQL99 language support, transactions, referential integrity, stored procedures and type extensibility. PostgreSQL is an open source descendant of this original Berkeley code.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • PostgreSQL
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

To use PostgreSQL support, you need PostgreSQL 6.5 or later, PostgreSQL 8.0 or later to enable all PostgreSQL module features. PostgreSQL supports many character encodings including multibyte character encoding. The current version and more information about PostgreSQL is available at » http://www.postgresql.org/ and the » PostgreSQL Documentation.


安装

为添加 PostgreSQL 支持，在编译 PHP 时需要加上 --with-pgsql[=DIR] 选项。如果可以用共享模块方式，PostgreSQL 模块可以在 php.ini 用 extension 指令或者 dl() 函数加载。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

PostgreSQL 配置选项
名字 | 默认 | 可修改范围 | 更新日志
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM |
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM |
pgsql.max_links | "-1" | PHP_INI_SYSTEM |
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM | 从 PHP 4.2.0 起开始存在
pgsql.ignore_notice | "0" | PHP_INI_ALL | 从 PHP 4.3.0 起开始存在
pgsql.log_notice | "0" | PHP_INI_ALL | 从 PHP 4.3.0 起开始存在
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

pgsql.allow_persistent bool

是否允许持久的 Postgres 连接。

pgsql.max_persistent int

每个进程所能有的持久 Postgres 连接数目。

pgsql.max_links int

每个进程所能有的 Postgres 连接数目，包括持久连接。

pgsql.auto_reset_persistent int

检测用在 pg_pconnect() 上的中断了的持久连接。需要一些损耗。

pgsql.ignore_notice int

是否忽略 PostgreSQL 后端的通告。

pgsql.log_notice int

是否记录 PostgreSQL 后端的通告消息。要记录通告消息日志，PHP 指令 pgsql.ignore_notice 必须为 off。


资源类型

There are two resource types used in the PostgreSQL module. The first one is the link identifier for a database connection, the second a resource which holds the result of a query.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

PGSQL_ASSOC (integer)
Passed to pg_fetch_array(). Return an associative array of field names and values.
PGSQL_NUM (integer)
Passed to pg_fetch_array(). Return a numerically indexed array of field numbers and values.
PGSQL_BOTH (integer)
Passed to pg_fetch_array(). Return an array of field values that is both numerically indexed (by field number) and associated (by field name).
PGSQL_CONNECT_FORCE_NEW (integer)
Passed to pg_connect() to force the creation of a new connection, rather then re-using an existing identical connection.
PGSQL_CONNECTION_BAD (integer)
Returned by pg_connection_status() indicating that the database connection is in an invalid state.
PGSQL_CONNECTION_OK (integer)
Returned by pg_connection_status() indicating that the database connection is in a valid state.
PGSQL_SEEK_SET (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the start of the object.
PGSQL_SEEK_CUR (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the current position.
PGSQL_SEEK_END (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the end of the object.
PGSQL_EMPTY_QUERY (integer)
Returned by pg_result_status(). The string sent to the server was empty.
PGSQL_COMMAND_OK (integer)
Returned by pg_result_status(). Successful completion of a command returning no data.
PGSQL_TUPLES_OK (integer)
Returned by pg_result_status(). Successful completion of a command returning data (such as a SELECT or SHOW).
PGSQL_COPY_OUT (integer)
Returned by pg_result_status(). Copy Out (from server) data transfer started.
PGSQL_COPY_IN (integer)
Returned by pg_result_status(). Copy In (to server) data transfer started.
PGSQL_BAD_RESPONSE (integer)
Returned by pg_result_status(). The server's response was not understood.
PGSQL_NONFATAL_ERROR (integer)
Returned by pg_result_status(). A nonfatal error (a notice or warning) occurred.
PGSQL_FATAL_ERROR (integer)
Returned by pg_result_status(). A fatal error occurred.
PGSQL_TRANSACTION_IDLE (integer)
Returned by pg_transaction_status(). Connection is currently idle, not in a transaction.
PGSQL_TRANSACTION_ACTIVE (integer)
Returned by pg_transaction_status(). A command is in progress on the connection. A query has been sent via the connection and not yet completed.
PGSQL_TRANSACTION_INTRANS (integer)
Returned by pg_transaction_status(). The connection is idle, in a transaction block.
PGSQL_TRANSACTION_INERROR (integer)
Returned by pg_transaction_status(). The connection is idle, in a failed transaction block.
PGSQL_TRANSACTION_UNKNOWN (integer)
Returned by pg_transaction_status(). The connection is bad.
PGSQL_DIAG_SEVERITY (integer)
Passed to pg_result_error_field(). The severity; the field contents are ERROR, FATAL, or PANIC (in an error message), or WARNING, NOTICE, DEBUG, INFO, or LOG (in a notice message), or a localized translation of one of these. Always present.
PGSQL_DIAG_SQLSTATE (integer)
Passed to pg_result_error_field(). The SQLSTATE code for the error. The SQLSTATE code identifies the type of error that has occurred; it can be used by front-end applications to perform specific operations (such as error handling) in response to a particular database error. This field is not localizable, and is always present.
PGSQL_DIAG_MESSAGE_PRIMARY (integer)
Passed to pg_result_error_field(). The primary human-readable error message (typically one line). Always present.
PGSQL_DIAG_MESSAGE_DETAIL (integer)
Passed to pg_result_error_field(). Detail: an optional secondary error message carrying more detail about the problem. May run to multiple lines.
PGSQL_DIAG_MESSAGE_HINT (integer)
Passed to pg_result_error_field(). Hint: an optional suggestion what to do about the problem. This is intended to differ from detail in that it offers advice (potentially inappropriate) rather than hard facts. May run to multiple lines.
PGSQL_DIAG_STATEMENT_POSITION (integer)
Passed to pg_result_error_field(). A string containing a decimal integer indicating an error cursor position as an index into the original statement string. The first character has index 1, and positions are measured in characters not bytes.
PGSQL_DIAG_INTERNAL_POSITION (integer)
Passed to pg_result_error_field(). This is defined the same as the PG_DIAG_STATEMENT_POSITION field, but it is used when the cursor position refers to an internally generated command rather than the one submitted by the client. The PG_DIAG_INTERNAL_QUERY field will always appear when this field appears.
PGSQL_DIAG_INTERNAL_QUERY (integer)
Passed to pg_result_error_field(). The text of a failed internally-generated command. This could be, for example, a SQL query issued by a PL/pgSQL function.
PGSQL_DIAG_CONTEXT (integer)
Passed to pg_result_error_field(). An indication of the context in which the error occurred. Presently this includes a call stack traceback of active procedural language functions and internally-generated queries. The trace is one entry per line, most recent first.
PGSQL_DIAG_SOURCE_FILE (integer)
Passed to pg_result_error_field(). The file name of the PostgreSQL source-code location where the error was reported.
PGSQL_DIAG_SOURCE_LINE (integer)
Passed to pg_result_error_field(). The line number of the PostgreSQL source-code location where the error was reported.
PGSQL_DIAG_SOURCE_FUNCTION (integer)
Passed to pg_result_error_field(). The name of the PostgreSQL source-code function reporting the error.
PGSQL_ERRORS_TERSE (integer)
Passed to pg_set_error_verbosity(). Specified that returned messages include severity, primary text, and position only; this will normally fit on a single line.
PGSQL_ERRORS_DEFAULT (integer)
Passed to pg_set_error_verbosity(). The default mode produces messages that include the above plus any detail, hint, or context fields (these may span multiple lines).
PGSQL_ERRORS_VERBOSE (integer)
Passed to pg_set_error_verbosity(). The verbose mode includes all available fields.
PGSQL_STATUS_LONG (integer)
Passed to pg_result_status(). Indicates that numerical result code is desired.
PGSQL_STATUS_STRING (integer)
Passed to pg_result_status(). Indicates that textual result command tag is desired.
PGSQL_CONV_IGNORE_DEFAULT (integer)
Passed to pg_convert(). Ignore default values in the table during conversion.
PGSQL_CONV_FORCE_NULL (integer)
Passed to pg_convert(). Use SQL NULL in place of an empty string.
PGSQL_CONV_IGNORE_DEFAULT (integer)
Passed to pg_convert(). Ignore conversion of null into SQL NOT NULL columns.


  • ? 预定义常量
  • Basic usage ?
  • PHP Manual
  • PostgreSQL
  • 范例

范例

Table of Contents

  • Basic usage
  • Basic usage


Basic usage

This simple example shows how to connect, execute a query, print resulting rows and disconnect from a PostgreSQL database.

Example #1 PostgreSQL extension overview example

<?php
// Connecting, selecting database
$dbconn = pg_connect("host=localhost dbname=publishing user=www password=foo")
    or die('Could not connect: ' . pg_last_error());

// Performing SQL query
$query = 'SELECT * FROM authors';
$result = pg_query($query) or die('Query failed: ' . pg_last_error());

// Printing results in HTML
echo "<table>\n";
while ($line = pg_fetch_array($result, null, PGSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($line as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

// Free resultset
pg_free_result($result);

// Closing connection
pg_close($dbconn);
?>


Basic usage

These examples contain user defined functions similar to legacy MySQL functions.

Example #1 PostgreSQL user defined functions example

<?php
// This function should be needed, since PostgreSQL connection binds database.
function pg_list_dbs($db)
{
    assert(is_resource($db));
    $query = '
SELECT
 d.datname as "Name",
 u.usename as "Owner",
 pg_encoding_to_char(d.encoding) as "Encoding"
FROM
 pg_database d LEFT JOIN pg_user u ON d.datdba = u.usesysid
ORDER BY 1;
';
    return pg_query($db, $query);
}

// List tables.
function pg_list_tables($db)
{
    assert(is_resource($db));
    $query = "
SELECT
 c.relname as \"Name\",
 CASE c.relkind WHEN 'r' THEN 'table' WHEN 'v' THEN 'view' WHEN 'i' THEN 'index' WHEN 'S' THEN 'sequence' WHEN 's' THEN 'special' END as \"Type\",
  u.usename as \"Owner\"
FROM
 pg_class c LEFT JOIN pg_user u ON c.relowner = u.usesysid
WHERE
 c.relkind IN ('r','v','S','')
 AND c.relname !~ '^pg_'
ORDER BY 1;
";
    return pg_query($db, $query);
}

// See also pg_meta_data(). It returns field definition as array.
function pg_list_fields($db, $table)
{
    assert(is_resource($db));
    $query = "
SELECT
 a.attname,
 format_type(a.atttypid, a.atttypmod),
 a.attnotnull,
 a.atthasdef,
 a.attnum
FROM
 pg_class c,
 pg_attribute a
WHERE
 c.relname = '".$table."'
 AND a.attnum > 0 AND a.attrelid = c.oid
ORDER BY a.attnum;
";
    return pg_query($db, $query);
}
?>


PostgreSQL 函数

注释

Note:

Not all functions are supported by all builds. It depends on your libpq (The PostgreSQL C client library) version and how libpq is compiled. If PHP PostgreSQL extensions are missing, then it is because your libpq version does not support them.

Note:

Most PostgreSQL functions accept connection as the optional first parameter. If it is not provided, the last opened connection is used. If it doesn't exist, functions return false.

Note:

PostgreSQL automatically folds all identifiers (e.g. table/column names) to lower-case values at object creation time and at query time. To force the use of mixed or upper case identifiers, you must escape the identifier using double quotes ("").

Note:

PostgreSQL does not have special commands for fetching database schema information (eg. all the tables in the current database). Instead, there is a standard schema named information_schema in PostgreSQL 7.4 and above containing system views with all the necessary information, in an easily queryable form. See the » PostgreSQL Documentation for full details.

Table of Contents

  • pg_affected_rows — 返回受影响的记录数目
  • pg_cancel_query — 取消异步查询
  • pg_client_encoding — 取得客户端编码方式
  • pg_close — 关闭一个 PostgreSQL 连接
  • pg_connect_poll — 正在进行尝试轮询 PostgreSQL 链接状态。
  • pg_connect — 打开一个 PostgreSQL 连接
  • pg_connection_busy — 获知连接是否为忙
  • pg_connection_reset — 重置连接（再次连接）
  • pg_connection_status — 获得连接状态
  • pg_consume_input — Reads input on the connection
  • pg_convert — 将关联的数组值转换为适合 SQL 语句的格式。
  • pg_copy_from — 根据数组将记录插入表中
  • pg_copy_to — 将一个表拷贝到数组中
  • pg_dbname — 获得数据库名
  • pg_delete — 删除记录
  • pg_end_copy — 与 PostgreSQL 后端同步
  • pg_escape_bytea — 转义 bytea 类型的二进制数据
  • pg_escape_identifier — Escape a identifier for insertion into a text field
  • pg_escape_literal — Escape a literal for insertion into a text field
  • pg_escape_string — 转义 text/char 类型的字符串
  • pg_execute — Sends a request to execute a prepared statement with given parameters, and waits for the result
  • pg_fetch_all_columns — Fetches all rows in a particular result column as an array
  • pg_fetch_all — 从结果中提取所有行作为一个数组
  • pg_fetch_array — 提取一行作为数组
  • pg_fetch_assoc — 提取一行作为关联数组
  • pg_fetch_object — 提取一行作为对象
  • pg_fetch_result — 从结果资源中返回值
  • pg_fetch_row — 提取一行作为枚举数组
  • pg_field_is_null — 测试字段是否为 null
  • pg_field_name — 返回字段的名字
  • pg_field_num — 返回字段的编号
  • pg_field_prtlen — 返回打印出来的长度
  • pg_field_size — 返回指定字段占用内部存储空间的大小
  • pg_field_table — Returns the name or oid of the tables field
  • pg_field_type_oid — Returns the type ID (OID) for the corresponding field number
  • pg_field_type — 返回相应字段的类型名称
  • pg_flush — 刷新链接中已处理的数据查询
  • pg_free_result — 释放查询结果占用的内存
  • pg_get_notify — Ping 数据库连接
  • pg_get_pid — Ping 数据库连接
  • pg_get_result — 取得异步查询结果
  • pg_host — 返回和某连接关联的主机名
  • pg_insert — 将数组插入到表中
  • pg_last_error — 得到某连接的最后一条错误信息
  • pg_last_notice — 返回 PostgreSQL 服务器最新一条公告信息
  • pg_last_oid — 返回上一个对象的 oid
  • pg_lo_close — 关闭一个大型对象
  • pg_lo_create — 新建一个大型对象
  • pg_lo_export — 将大型对象导出到文件
  • pg_lo_import — 将文件导入为大型对象
  • pg_lo_open — 打开一个大型对象
  • pg_lo_read_all — 读入整个大型对象并直接发送给浏览器
  • pg_lo_read — 从大型对象中读入数据
  • pg_lo_seek — 移动大型对象中的指针
  • pg_lo_tell — 返回大型对象的当前指针位置
  • pg_lo_truncate — Truncates a large object
  • pg_lo_unlink — 删除一个大型对象
  • pg_lo_write — 向大型对象写入数据
  • pg_meta_data — 获得表的元数据
  • pg_num_fields — 返回字段的数目
  • pg_num_rows — 返回行的数目
  • pg_options — 获得和连接有关的选项
  • pg_parameter_status — Looks up a current parameter setting of the server
  • pg_pconnect — 打开一个持久的 PostgreSQL 连接
  • pg_ping — Ping 数据库连接
  • pg_port — 返回该连接的端口号
  • pg_prepare — Submits a request to create a prepared statement with the given parameters, and waits for completion
  • pg_put_line — 向 PostgreSQL 后端发送以 NULL 结尾的字符串
  • pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
  • pg_query — 执行查询
  • pg_result_error_field — Returns an individual field of an error report
  • pg_result_error — 获得查询结果的错误信息
  • pg_result_seek — 在结果资源中设定内部行偏移量
  • pg_result_status — 获得查询结果的状态
  • pg_select — 选择记录
  • pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)
  • pg_send_prepare — Sends a request to create a prepared statement with the given parameters, without waiting for completion
  • pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s)
  • pg_send_query — 发送异步查询
  • pg_set_client_encoding — 设定客户端编码
  • pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error and pg_result_error
  • pg_socket — Get a read only handle to the socket underlying a PostgreSQL connection
  • pg_trace — 启动一个 PostgreSQL 连接的追踪功能
  • pg_transaction_status — Returns the current in-transaction status of the server
  • pg_tty — 返回该连接的 tty 号
  • pg_unescape_bytea — 取消 bytea 类型中的字符串转义
  • pg_untrace — 关闭 PostgreSQL 连接的追踪功能
  • pg_update — 更新表
  • pg_version — Returns an array with client, protocol and server version (when available)


返回受影响的记录数目

  • ? PostgreSQL 函数
  • pg_cancel_query ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回受影响的记录数目

pg_affected_rows

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_affected_rows — 返回受影响的记录数目

说明

pg_affected_rows ( resource $result ) : int

pg_affected_rows() 返回在 pg_query() 中执行 INSERT，UPDATE 和 DELETE 查询后受到影响的记录数目（包括实例／记录／行）。如果本函数没有影响到任何记录，则返回 0。

Example #1 pg_affected_rows() 例子

<?php
$result = pg_query($conn, "INSERT INTO authors VALUES ('Orwell', 2002, 'Animal Farm')");
$cmdtuples = pg_affected_rows($result);
echo $cmdtuples . " tuples are affected.\n";
?>

Note:

本函数以前被称为 pg_cmdtuples()。

参见 pg_query() 和 pg_num_rows()。


取消异步查询

  • ? pg_affected_rows
  • pg_client_encoding ?
  • PHP Manual
  • PostgreSQL 函数
  • 取消异步查询

pg_cancel_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_cancel_query — 取消异步查询

说明

pg_cancel_query ( resource $connection ) : bool

pg_cancel_query() 取消由 pg_send_query() 发送的异步查询。不能取消由 pg_query() 执行的查询。

参见 pg_send_query() 和 pg_connection_busy()。


取得客户端编码方式

  • ? pg_cancel_query
  • pg_close ?
  • PHP Manual
  • PostgreSQL 函数
  • 取得客户端编码方式

pg_client_encoding

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pg_client_encoding — 取得客户端编码方式

说明

pg_client_encoding ( resource $connection = ? ) : string

pg_client_encoding() 以字符串形式返回客户端编码。所返回的字符串为以下之一：SQL_ASCII，EUC_JP，EUC_CN，EUC_KR，EUC_TW，UNICODE，MULE_INTERNAL，LATINX (X=1...9)，KOI8，WIN，ALT，SJIS，BIG5，WIN1250。

Note:

本函数需要 PHP-4.0.3 或以上版本以及 PostgreSQL-7.0 或以上版本。如果在编译 libpq 时没有加入多字节编码支持，则 pg_set_client_encoding() 总是返回 "SQL_ASCII"。所支持的编码方式取决于 PostgreSQL 的版本。详情参见 PostgreSQL 手册如何加入多字节支持以及所支持的编码方式。

本函数以前被称为 pg_clientencoding()。

参见 pg_set_client_encoding()。


关闭一个 PostgreSQL 连接

  • ? pg_client_encoding
  • pg_connect_poll ?
  • PHP Manual
  • PostgreSQL 函数
  • 关闭一个 PostgreSQL 连接

pg_close

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_close — 关闭一个 PostgreSQL 连接

说明

pg_close ( resource $connection = ? ) : bool

pg_close() 关闭由所给资源 connection 指定的到 PostgreSQL 数据库的非持久连接。

Note:

使用 pg_close() 并不很必要，因为非持久连接在本脚本执行结束后会自动关闭。

如果在此连接中打开了 large object 资源，则在关闭所有 large object 资源之前不要关闭连接。

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_close() 例子

<?php
$dbconn = pg_connect("host=localhost port=5432 dbname=mary")
   or die("Could not connect");
echo "Connected successfully";
pg_close($dbconn);
?>

以上例程会输出：

Connected successfully

参见

  • pg_connect() - 打开一个 PostgreSQL 连接


正在进行尝试轮询 PostgreSQL 链接状态。

  • ? pg_close
  • pg_connect ?
  • PHP Manual
  • PostgreSQL 函数
  • 正在进行尝试轮询 PostgreSQL 链接状态。

pg_connect_poll

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_connect_poll — 正在进行尝试轮询 PostgreSQL 链接状态。

说明

pg_connect_poll ( resource $connection = ? ) : int

pg_connect_poll() 轮询使用 pg_connect() 创建的 PostgreSQL 链接状态，根据 PGSQL_CONNECT_ASYNC 选项

参数

connection

PostgreSQL 数据库链接资源

返回值

返回常量 PGSQL_POLLING_FAILED, PGSQL_POLLING_READING, PGSQL_POLLING_WRITING, PGSQL_POLLING_OK, 或者 PGSQL_POLLING_ACTIVE.


打开一个 PostgreSQL 连接

  • ? pg_connect_poll
  • pg_connection_busy ?
  • PHP Manual
  • PostgreSQL 函数
  • 打开一个 PostgreSQL 连接

pg_connect

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_connect — 打开一个 PostgreSQL 连接

说明

pg_connect ( string $connection_string ) : resource

pg_connect() 返回其它 PostgreSQL 函数所需要的资源。

pg_connect() 打开一个由 connection_string 所指定的 PostgreSQL 数据库的连接。如果成功则返回连接资源，如果不能连接则返回 false。connection_string 应该是用引号引起来的字符串。

Example #1 使用 pg_connect()

<?php
$dbconn = pg_connect("dbname=mary");
//connect to a database named "mary"
$dbconn2 = pg_connect("host=localhost port=5432 dbname=mary");
// connect to a database named "mary" on "localhost" at port "5432"
$dbconn3 = pg_connect("host=sheep port=5432 dbname=mary user=lamb password=foo");
//connect to a database named "mary" on the host "sheep" with a username and password

$conn_string = "host=sheep port=5432 dbname=test user=lamb password=bar";
$dbconn4 = pg_connect($conn_string);
//connect to a database named "test" on the host "sheep" with a username and password
?>
connection_string 所包括的参数有 host，port，tty, options，dbname, user 和 password。

如果用同样的 connection_string 再次调用 pg_connect()，不会建立新连接，而是返回前面已经打开的连接资源。如果使用不同的连接字符串，则可以和同一个数据库建立多个连接。

旧的多参数语法 $conn = pg_connect("host", "port", "options", "tty", "dbname") 已经不提倡使用。

参见 pg_pconnect()，pg_close()，pg_host()，pg_port(), pg_tty()，pg_options() 和 pg_dbname()。


获知连接是否为忙

  • ? pg_connect
  • pg_connection_reset ?
  • PHP Manual
  • PostgreSQL 函数
  • 获知连接是否为忙

pg_connection_busy

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_connection_busy — 获知连接是否为忙

说明

pg_connection_busy ( resource $connection ) : bool

pg_connection_busy() 在此连接状态为忙的时候返回 true。如果连接状态为忙，说明前一个查询仍然在执行。如果调用 pg_get_result() 函数的话，则会被锁死。

Example #1 pg_connection_busy() 例子

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
    $bs = pg_connection_busy($dbconn);
    if ($bs) {
        echo 'connection is busy';
    }
    else {
       echo 'connection is not busy';
    }
?>

参见 pg_connection_status() 和 pg_get_result()。


重置连接（再次连接）

  • ? pg_connection_busy
  • pg_connection_status ?
  • PHP Manual
  • PostgreSQL 函数
  • 重置连接（再次连接）

pg_connection_reset

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_connection_reset — 重置连接（再次连接）

说明

pg_connection_reset ( resource $connection ) : bool

pg_connection_reset() 重置一个连接，用于错误恢复。

参数

connection

PostgreSQL database connection resource.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_connection_reset() 例子

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $dbconn2 = pg_connection_reset($dbconn);
  if ($dbconn2) {
      echo "reset successful\n";
  } else {
      echo "reset failed\n";
  }
?>

参见

  • pg_connect() - 打开一个 PostgreSQL 连接
  • pg_pconnect() - 打开一个持久的 PostgreSQL 连接
  • pg_connection_status() - 获得连接状态


获得连接状态

  • ? pg_connection_reset
  • pg_consume_input ?
  • PHP Manual
  • PostgreSQL 函数
  • 获得连接状态

pg_connection_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_connection_status — 获得连接状态

说明

pg_connection_status ( resource $connection ) : int

pg_connection_status() 返回一个连接的状态。可能的状态为 PGSQL_CONNECTION_OK 和 PGSQL_CONNECTION_BAD。

Example #1 pg_connection_status() 例子

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
    $stat = pg_connection_status($dbconn);
    echo 'connection_status: '.$stat;
?>

Example #2 pg_connection_status() 例子

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
    $stat = pg_connection_status($dbconn);
    echo 'connection_status: '.$stat;
?>

参见 pg_connection_busy()。


Reads input on the connection

  • ? pg_connection_status
  • pg_convert ?
  • PHP Manual
  • PostgreSQL 函数
  • Reads input on the connection

pg_consume_input

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_consume_input — Reads input on the connection

说明

pg_consume_input ( resource $connection ) : bool

pg_consume_input() consumes any input waiting to be read from the database server.

参数

connection

PostgreSQL database connection resource.

返回值

true if no error occurred, or false if there was an error. Note that true does not necessarily indicate that input was waiting to be read.


将关联的数组值转换为适合 SQL 语句的格式。

  • ? pg_consume_input
  • pg_copy_from ?
  • PHP Manual
  • PostgreSQL 函数
  • 将关联的数组值转换为适合 SQL 语句的格式。

pg_convert

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_convert — 将关联的数组值转换为适合 SQL 语句的格式。

说明

pg_convert ( resource $connection , string $table_name , array $assoc_array , int $options = 0 ) : array

pg_convert() 检查 assoc_array 中的值并将其转换为为适用于 SQL 语句的值。pg_convert() 的前提条件是现有的表 table_name 中具有的列至少有 assoc_array 中的单元那么多。table_name 中的字段名以及字段值必须和 assoc_array 中的键名及值匹配。如果成功则返回一个包括转换后的值的数组，否则返回 false。

Note:

If there are boolean fields in table_name don't use the constant true in assoc_array. It will be converted to the string 'TRUE' which is no valid entry for boolean fields in PostgreSQL. Use one of t, true, 1, y, yes instead.

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

connection

PostgreSQL database connection resource.

table_name

Name of the table against which to convert types.

assoc_array

Data to be converted.

options

Any number of PGSQL_CONV_IGNORE_DEFAULT, PGSQL_CONV_FORCE_NULL or PGSQL_CONV_IGNORE_NOT_NULL, combined.

返回值

An array of converted values, or false on error.

范例

Example #1 pg_convert() example

<?php
  $dbconn = pg_connect('dbname=foo');

  $tmp = array(
      'author' => 'Joe Thackery',
      'year' => 2005,
      'title' => 'My Life, by Joe Thackery'
  );

  $vals = pg_convert($dbconn, 'authors', $tmp);
?>

参见

  • pg_meta_data() - 获得表的元数据


根据数组将记录插入表中

  • ? pg_convert
  • pg_copy_to ?
  • PHP Manual
  • PostgreSQL 函数
  • 根据数组将记录插入表中

pg_copy_from

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_copy_from — 根据数组将记录插入表中

说明

pg_copy_from ( resource $connection , string $table_name , array $rows , string $delimiter = ? , string $null_as = ? ) : bool

pg_copy_from() 将数组 rows 的内容作为记录插入表中。它在内部使用了 COPY FROM SQL 命令来插入记录。

参数

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to copy the rows.

rows

An array of data to be copied into table_name. Each value in rows becomes a row in table_name. Each value in rows should be a delimited string of the values to insert into each field. Values should be linefeed terminated.

delimiter

The token that separates values for each field in each element of rows. Default is TAB.

null_as

How SQL NULL values are represented in the rows. Default is \N ("\N").

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_copy_from() example

<?php
   $db = pg_connect("dbname=publisher") or die("Could not connect");

   $rows = pg_copy_to($db, $table_name);

   pg_query($db, "DELETE FROM $table_name");

   pg_copy_from($db, $table_name, $rows);
?>

参见

  • pg_copy_to() - 将一个表拷贝到数组中


将一个表拷贝到数组中

  • ? pg_copy_from
  • pg_dbname ?
  • PHP Manual
  • PostgreSQL 函数
  • 将一个表拷贝到数组中

pg_copy_to

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_copy_to — 将一个表拷贝到数组中

说明

pg_copy_to ( resource $connection , string $table_name , string $delimiter = ? , string $null_as = ? ) : array

pg_copy_to() 将一个表拷贝到数组中，该数组作为结果返回。它在内部使用了 COPY FROM SQL 命令来插入记录，并返回结果数组。如果失败则返回 false。

参见 pg_copy_from()。


获得数据库名

  • ? pg_copy_to
  • pg_delete ?
  • PHP Manual
  • PostgreSQL 函数
  • 获得数据库名

pg_dbname

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_dbname — 获得数据库名

说明

pg_dbname ( resource $connection ) : string

pg_dbname() 返回给定 PostgreSQL connection 资源的数据库名称。如果 connection 不是有效的 PostgreSQL 连接资源则返回 false。

Example #1 pg_dbname() 例子

<?php
    error_reporting(E_ALL);

    pg_connect("host=localhost port=5432 dbname=mary");
    echo pg_dbname(); // mary
?>


删除记录

  • ? pg_dbname
  • pg_end_copy ?
  • PHP Manual
  • PostgreSQL 函数
  • 删除记录

pg_delete

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_delete — 删除记录

说明

pg_delete ( resource $connection , string $table_name , array $assoc_array , int $options = PGSQL_DML_EXEC ) : mixed

pg_delete() 删除符合条件的记录，条件在 assoc_array 中以 field=>value 格式给出。如果指定了 option，则 pg_convert() 按照该选项作用于 assoc_array 之上。

参数

connection

PostgreSQL database connection resource.

table_name

Name of the table from which to delete rows.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the values of those fields that are to be deleted.

options

Any number of PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_EXEC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned.

返回值

成功时返回 true， 或者在失败时返回 false。 Returns string if PGSQL_DML_STRING is passed via options.

范例

Example #1 pg_delete() 例子

<?php
  $db = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $res = pg_delete($db, 'post_log', $_POST);
  if ($res) {
      echo "POST data is deleted: $res\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • pg_convert() - 将关联的数组值转换为适合 SQL 语句的格式。


与 PostgreSQL 后端同步

  • ? pg_delete
  • pg_escape_bytea ?
  • PHP Manual
  • PostgreSQL 函数
  • 与 PostgreSQL 后端同步

pg_end_copy

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pg_end_copy — 与 PostgreSQL 后端同步

说明

pg_end_copy ( resource $connection = ? ) : bool

pg_end_copy() 在处理完 pg_put_line() 所执行的拷贝操作之后将 PostgreSQL 前端（通常为 web server 进程）与 PostgreSQL 服务器进行同步。pg_end_copy() 必须被调用，否则 PostgreSQL 服务器可能会和前端失去同步并报错。

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_end_copy() 例子

<?php
  $conn = pg_pconnect("dbname=foo");
  pg_query($conn, "create table bar (a int4, b char(16), d float8)");
  pg_query($conn, "copy bar from stdin");
  pg_put_line($conn, "3\thello world\t4.5\n");
  pg_put_line($conn, "4\tgoodbye world\t7.11\n");
  pg_put_line($conn, "\.\n");
  pg_end_copy($conn);
?>

参见

  • pg_put_line() - 向 PostgreSQL 后端发送以 NULL 结尾的字符串


转义 bytea 类型的二进制数据

  • ? pg_end_copy
  • pg_escape_identifier ?
  • PHP Manual
  • PostgreSQL 函数
  • 转义 bytea 类型的二进制数据

pg_escape_bytea

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_escape_bytea — 转义 bytea 类型的二进制数据

说明

pg_escape_bytea ( string $data ) : string

pg_escape_bytea() 转义 bytea 数据类型的二进制字符串，返回转义后的字符串。

Note:

当对 bytea 类型字段进行 SELECT 操作时，PostgreSQL 返回前导 \ 的八进制字节值（例如 \032）。用户需要自己将结果转换为二进制格式。

本函数需要 PostgreSQL 7.2 或以上版本。在 PostgreSQL 7.2.0 和 7.2.1 版中，如果使用了多字节支持，bytea 类型必须被强制转换。例如 INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea);。PostgreSQL 7.2.2 或以上版本不需要强制转换。异常情况是当客户端和后端字符编码不匹配时，可能会有多字节流错误。用户必须强制转换 bytea 以避免此错误。

参见 pg_unescape_bytea() 和 pg_escape_string()。


Escape a identifier for insertion into a text field

  • ? pg_escape_bytea
  • pg_escape_literal ?
  • PHP Manual
  • PostgreSQL 函数
  • Escape a identifier for insertion into a text field

pg_escape_identifier

(PHP 5 >= 5.4.4, PHP 7, PHP 8)

pg_escape_identifier — Escape a identifier for insertion into a text field

说明

pg_escape_identifier ( resource $connection = ? , string $data ) : string

pg_escape_identifier() escapes a identifier (e.g. table, field names) for querying the database. It returns an escaped identifier string for PostgreSQL server. pg_escape_identifier() adds double quotes before and after data. Users should not add double quotes. Use of this function is recommended for identifier parameters in query. For SQL literals (i.e. parameters except bytea), pg_escape_literal() or pg_escape_string() must be used. For bytea type fields, pg_escape_bytea() must be used instead.

Note:

This function has internal escape code and can also be used with PostgreSQL 8.4 or less.

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A string containing text to be escaped.

返回值

A string containing the escaped data.

范例

Example #1 pg_escape_identifier() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Escape the table name data
  $escaped = pg_escape_identifier($table_name);

  // Select rows from $table_name
  pg_query("SELECT * FROM {$escaped};");
?>

参见

  • pg_escape_literal() - Escape a literal for insertion into a text field
  • pg_escape_bytea() - 转义 bytea 类型的二进制数据
  • pg_escape_string() - 转义 text/char 类型的字符串


Escape a literal for insertion into a text field

  • ? pg_escape_identifier
  • pg_escape_string ?
  • PHP Manual
  • PostgreSQL 函数
  • Escape a literal for insertion into a text field

pg_escape_literal

(PHP 5 >= 5.4.4, PHP 7, PHP 8)

pg_escape_literal — Escape a literal for insertion into a text field

说明

pg_escape_literal ( resource $connection = ? , string $data ) : string

pg_escape_literal() escapes a literal for querying the PostgreSQL database. It returns an escaped literal in the PostgreSQL format. pg_escape_literal() adds quotes before and after data. Users should not add quotes. Use of this function is recommended instead of pg_escape_string(). If the type of the column is bytea, pg_escape_bytea() must be used instead. For escaping identifiers (e.g. table, field names), pg_escape_identifier() must be used.

Note:

This function has internal escape code and can also be used with PostgreSQL 8.4 or less.

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect(). When there is no default connection, it raises E_WARNING and returns false.

data

A string containing text to be escaped.

返回值

A string containing the escaped data.

范例

Example #1 pg_escape_literal() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Read in a text file (containing apostrophes and backslashes)
  $data = file_get_contents('letter.txt');

  // Escape the text data
  $escaped = pg_escape_literal($data);

  // Insert it into the database. Note that no quotes around {$escaped}
  pg_query("INSERT INTO correspondence (name, data) VALUES ('My letter', {$escaped})");
?>

参见

  • pg_escape_identifier() - Escape a identifier for insertion into a text field
  • pg_escape_bytea() - 转义 bytea 类型的二进制数据
  • pg_escape_string() - 转义 text/char 类型的字符串


转义 text/char 类型的字符串

  • ? pg_escape_literal
  • pg_execute ?
  • PHP Manual
  • PostgreSQL 函数
  • 转义 text/char 类型的字符串

pg_escape_string

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_escape_string — 转义 text/char 类型的字符串

说明

pg_escape_string ( string $data ) : string

pg_escape_string() 转义 text/char 数据类型的字符串，返回转义后的字符串。建议用此函数替代 addslashes()。

Note:

本函数需要 PostgreSQL 7.2 或以上版本。

参见 pg_escape_bytea()。


Sends a request to execute a prepared statement with given parameters, and waits for the result

  • ? pg_escape_string
  • pg_fetch_all_columns ?
  • PHP Manual
  • PostgreSQL 函数
  • Sends a request to execute a prepared statement with given parameters, and waits for the result

pg_execute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_execute — Sends a request to execute a prepared statement with given parameters, and waits for the result

说明

pg_execute ( resource $connection = ? , string $stmtname , array $params ) : resource|false

Sends a request to execute a prepared statement with given parameters, and waits for the result.

pg_execute() is like pg_query_params(), but the command to be executed is specified by naming a previously-prepared statement, instead of giving a query string. This feature allows commands that will be used repeatedly to be parsed and planned just once, rather than each time they are executed. The statement must have been prepared previously in the current session. pg_execute() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

The parameters are identical to pg_query_params(), except that the name of a prepared statement is given instead of a query string.

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name of the prepared statement to execute. if "" is specified, then the unnamed statement is executed. The name must have been previously prepared using pg_prepare(), pg_send_prepare() or a PREPARE SQL command.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Warning

Elements are converted to strings by calling this function.

返回值

A query result resource on success 或者在失败时返回 false.

范例

Example #1 Using pg_execute()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Prepare a query for execution
$result = pg_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');

// Execute the prepared query.  Note that it is not necessary to escape
// the string "Joe's Widgets" in any way
$result = pg_execute($dbconn, "my_query", array("Joe's Widgets"));

// Execute the same prepared query, this time with a different parameter
$result = pg_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));

?>

参见

  • pg_prepare() - Submits a request to create a prepared statement with the given parameters, and waits for completion
  • pg_send_prepare() - Sends a request to create a prepared statement with the given parameters, without waiting for completion
  • pg_query_params() - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text


Fetches all rows in a particular result column as an array

  • ? pg_execute
  • pg_fetch_all ?
  • PHP Manual
  • PostgreSQL 函数
  • Fetches all rows in a particular result column as an array

pg_fetch_all_columns

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_fetch_all_columns — Fetches all rows in a particular result column as an array

说明

pg_fetch_all_columns ( resource $result , int $column = 0 ) : array

pg_fetch_all_columns() returns an array that contains all rows (records) in a particular column of the result resource.

Note: 此函数将 NULL 字段设置为 PHP null 值。

参数

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

column

Column number, zero-based, to be retrieved from the result resource. Defaults to the first column if not specified.

返回值

An array with all values in the result column.

false is returned if column is larger than the number of columns in the result, or on any other error.

范例

Example #1 pg_fetch_all_columns() example

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT title, name, address FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

// Get an array of all author names
$arr = pg_fetch_all_columns($result, 1);

var_dump($arr);

?>

参见

  • pg_fetch_all() - 从结果中提取所有行作为一个数组


从结果中提取所有行作为一个数组

  • ? pg_fetch_all_columns
  • pg_fetch_array ?
  • PHP Manual
  • PostgreSQL 函数
  • 从结果中提取所有行作为一个数组

pg_fetch_all

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_fetch_all — 从结果中提取所有行作为一个数组

说明

pg_fetch_all ( resource $result ) : array

pg_fetch_all() 从结果资源中返回一个包含有所有的行（元组/记录）的数组。如果没有更多行可供提取，则返回 false。

Example #1 pg_fetch_all() 例子

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}
$result = pg_query($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}
$arr = pg_fetch_all($result);
var_dump($arr);
?>

参见 pg_fetch_row()，pg_fetch_array()，pg_fetch_object() 和 pg_fetch_result()。


提取一行作为数组

  • ? pg_fetch_all
  • pg_fetch_assoc ?
  • PHP Manual
  • PostgreSQL 函数
  • 提取一行作为数组

pg_fetch_array

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_fetch_array — 提取一行作为数组

说明

pg_fetch_array ( resource $result , int $row = ? , int $result_type = ? ) : array

pg_fetch_array() 返回一个与所提取的行（元组/记录）相一致的数组。如果没有更多行可供提取，则返回 false。

pg_fetch_array() 是 pg_fetch_row() 的扩展版本。在返回的数组中不仅以数字索引方式存放数据（字段编号），默认情况下还用字段名做索引存放数据（字段名）。

row 是想要取得的行（记录）的编号。第一行为 0。

result_type 是可选参数，控制着怎样初始化返回值。result_type 是一个常量，可以有以下取值：PGSQL_ASSOC，PGSQL_NUM 和 PGSQL_BOTH。取值为 PGSQL_ASSOC 时 pg_fetch_array() 返回用字段名作为键值索引的关联数组，取值为 PGSQL_NUM 时用字段编号作为键值，取值为 PGSQL_BOTH 时则同时用两者作为键值。默认值是 PGSQL_BOTH。

Note:

result_type 是在 PHP 4.0 中才加入的参数。

pg_fetch_array() 并不明显比使用 pg_fetch_row() 慢，而且在使用中提供了更大的方便。

Example #1 pg_fetch_array()

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

$result = pg_query($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}

$arr = pg_fetch_array($result, 0, PGSQL_NUM);
echo $arr[0] . " <- array\n";

$arr = pg_fetch_array($result, 1, PGSQL_ASSOC);
echo $arr["author"] . " <- array\n";

?>

Note:

从 4.1.0 开始，row 成为可选参数。每次调用 pg_fetch_array()，内部的行计数器都会加一。

参见 pg_fetch_row() 和 pg_fetch_object() 以及 pg_fetch_result()。


提取一行作为关联数组

  • ? pg_fetch_array
  • pg_fetch_object ?
  • PHP Manual
  • PostgreSQL 函数
  • 提取一行作为关联数组

pg_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_fetch_assoc — 提取一行作为关联数组

说明

pg_fetch_assoc ( resource $result , int $row = ? ) : array

pg_fetch_assoc() 和调用 pg_fetch_array() 加上第三个可选参数 PGSQL_ASSOC 是等价的。它只返回一个关联数组。如果需要数字索引，用 pg_fetch_row()。

pg_fetch_assoc() 是 pg_fetch_row() 的扩展版本。除了将数据存储在数字索引（字段编号）之外，默认还将数组存储在关联索引（字段名）中。

row 是要被提取的行（记录）编号。第一行为 0。

pg_fetch_assoc() 并不明显比 pg_fetch_row() 慢，而且还显著更便于使用。

Example #1 pg_fetch_assoc() 例子

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

$result = pg_query($conn, "SELECT id, author, email FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}
while ($row = pg_fetch_assoc($result)) {
    echo $row['id'];
    echo $row['author'];
    echo $row['email'];
}
?>

参见 pg_fetch_row()，pg_fetch_array()，pg_fetch_object() 和 pg_fetch_result()。


提取一行作为对象

  • ? pg_fetch_assoc
  • pg_fetch_result ?
  • PHP Manual
  • PostgreSQL 函数
  • 提取一行作为对象

pg_fetch_object

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_fetch_object — 提取一行作为对象

说明

pg_fetch_object ( resource $result , int $row = ? , int $result_type = ? ) : object

pg_fetch_object() 返回与所提取行的属性相一致的一个对象。如果出错或者没有更多行可供提取时则返回 false。

pg_fetch_object() 和 pg_fetch_array() 相似，只有一点区别 － 返回一个对象而不是数组。间接的，这意味着只能通过字段名来访问数据而不能通过偏移量来访问（数字是非法的属性名）。

row 是想要取得的行（记录）的编号。第一行为 0。

除了速度之外，本函数和 pg_fetch_array() 完全一样，而且几乎和 pg_fetch_row() 一样快（速度上的差别很小）。

Note:

从 4.1.0 版本开始，参数 row 变为可选参数。

从 4.3.0 开始，result_type 默认值为 PGSQL_ASSOC，而旧版本的默认值是 PGSQL_BOTH。数字属性在这里没有用处，因为在 PHP 中对象的属性不能是数字。

result_type 参数在以后的版本中可能会删除。

Example #1 pg_fetch_object()

<?php

$database = "store";

$db_conn = pg_connect("host=localhost port=5432 dbname=$database");
if (!$db_conn) {
    echo "Failed connecting to postgres database $database\n";
    exit;
}

$qu = pg_query($db_conn, "SELECT * FROM books ORDER BY author");

$row = 0; // postgres needs a row counter

while ($data = pg_fetch_object($qu, $row)) {
    echo $data->author . " (";
    echo $data->year . "): ";
    echo $data->title . "<br />";
    $row++;
}

pg_free_result ($qu);
pg_close ($db_conn);

?>

Note:

从 4.1.0 开始，row 成为可选参数。每次调用 pg_fetch_object()，内部的行计数器都会加一。

参见 pg_query()，pg_fetch_array()，pg_fetch_row() 和 pg_fetch_result()。


从结果资源中返回值

  • ? pg_fetch_object
  • pg_fetch_row ?
  • PHP Manual
  • PostgreSQL 函数
  • 从结果资源中返回值

pg_fetch_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_fetch_result — 从结果资源中返回值

说明

pg_fetch_result ( resource $result , int $row , mixed $field ) : mixed

pg_fetch_result() 根据由 pg_query() 返回的 result 资源返回相应的值。row 为整型数。field 为字段名（字符串）或字段索引（整数）。row 和 field 指明了查询结果中的哪个单元被返回。行编号从 0 开始。除了用字段名之外，还可以用不带引号的数字作为字段索引。字段索引从 0 开始。

PostgreSQL 有很多内置的类型，这里只直接支持基本类型。所有形式的 integer，boolean 和 void 类型都被返回为 integer 值。所有形式的 float 和 real 类型都被返回为 float 值。Boolean 类型被返回为 "t" 或者 "f"。所有其它类型包括数组都被返回为字符串，该字符串的格式和默认的 PostgreSQL 风格一样，可以在 psql 程序中看到。


提取一行作为枚举数组

  • ? pg_fetch_result
  • pg_field_is_null ?
  • PHP Manual
  • PostgreSQL 函数
  • 提取一行作为枚举数组

pg_fetch_row

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_fetch_row — 提取一行作为枚举数组

说明

pg_fetch_row ( resource $result , int $row = ? ) : array

pg_fetch_row() 根据指定的 result 资源提取一行数据（记录）作为数组返回。每个得到的列依次存放在数组中，从偏移量 0 开始。

Note: 此函数将 NULL 字段设置为 PHP null 值。

参数

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or null, the next row is fetched.

返回值

An array, indexed from 0 upwards, with each value represented as a string. Database NULL values are returned as null.

返回的数组和提取的行相一致。如果没有更多行 row 可提取，则返回 false。

更新日志

版本 | 说明
4.1.0 | 参数 row 成为可选参数。

范例

Example #1 pg_fetch_row() 例子

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occured.\n";
  exit;
}

while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

参见

  • pg_query() - 执行查询
  • pg_fetch_array() - 提取一行作为数组
  • pg_fetch_object() - 提取一行作为对象
  • pg_fetch_result() - 从结果资源中返回值


测试字段是否为 null

  • ? pg_fetch_row
  • pg_field_name ?
  • PHP Manual
  • PostgreSQL 函数
  • 测试字段是否为 null

pg_field_is_null

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_is_null — 测试字段是否为 null

说明

pg_field_is_null ( resource $result , int $row , mixed $field ) : int

pg_field_is_null() 测试字段是否为 null。如果字段在给出的行中为 null 则返回 1，如果字段在给出的行中不是 null 则返回 0。字段可以以列的索引号（数字）方式给出，也可以以字段名（字符串）方式给出。行的编号从 0 开始。

Example #1 pg_field_is_null() 例子

<?php
    $dbconn = pg_connect("dbname=publisher") or die ("Could not connect");
    $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
    if ($res) {
        if (pg_field_is_null($res, 0, "year") == 1) {
            echo "The value of the field year is null.\n";
        }
        if (pg_field_is_null($res, 0, "year") == 0) {
            echo "The value of the field year is not null.\n";
      }
   }
?>

Note:

本函数以前的名字为 pg_fieldisnull()。


返回字段的名字

  • ? pg_field_is_null
  • pg_field_num ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回字段的名字

pg_field_name

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_name — 返回字段的名字

说明

pg_field_name ( resource $result , int $field_number ) : string

pg_field_name() 返回给定 PostgreSQL result 资源中的 field_number 所代表的字段名。字段编号从 0 开始。

Example #1 获取字段信息

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
    $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
    $i = pg_num_fields($res);
    for ($j = 0; $j < $i; $j++) {
        echo "column $j\n";
        $fieldname = pg_field_name($res, $j);
        echo "fieldname: $fieldname\n";
        echo "printed length: ".pg_field_prtlen($res, $fieldname)." characters\n";
        echo "storage length: ".pg_field_size($res, $j)." bytes\n";
        echo "field type: ".pg_field_type($res, $j)." \n\n";
}
?>

上例的输出如下：

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Note:

本函数以前的名字为 pg_fieldname()。

参见 pg_field_num()。


返回字段的编号

  • ? pg_field_name
  • pg_field_prtlen ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回字段的编号

pg_field_num

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_num — 返回字段的编号

说明

pg_field_num ( resource $result , string $field_name ) : int

pg_field_num() 返回给定 PostgreSQL result 资源中的 field_name 所代表的列（字段）的编号。字段编号从 0 开始。如果出错本函数返回 -1。

例子参见 pg_field_name() 页。

Note:

本函数以前的名字为 pg_fieldnum()。

参见 pg_field_name()。


返回打印出来的长度

  • ? pg_field_num
  • pg_field_size ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回打印出来的长度

pg_field_prtlen

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_prtlen — 返回打印出来的长度

说明

pg_field_prtlen ( resource $result , int $row_number , string $field_name ) : int

pg_field_prtlen() 返回 PostgreSQL result 中得到的值实际上打印出来的长度（字符数）。行编号从 0 开始。如果出错本函数返回 -1。

例子参见 pg_field_name() 页。

Note:

本函数以前的名字为 pg_field_prtlen()。

参见 pg_field_size()。


返回指定字段占用内部存储空间的大小

  • ? pg_field_prtlen
  • pg_field_table ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回指定字段占用内部存储空间的大小

pg_field_size

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_size — 返回指定字段占用内部存储空间的大小

说明

pg_field_size ( resource $result , int $field_number ) : int

pg_field_size() 返回 PostgreSQL result 中指定字段占用内部存储空间的大小（字节数）。字段编号从 0 开始。字段大小为 -1 表示可变长度字段。如果出错本函数返回 false。

参考 pg_field_name() 页面中的例子。

Note:

本函数以前的名字为 pg_fieldsize()。

参见 pg_field_prtlen() 和 pg_field_type()。


Returns the name or oid of the tables field

  • ? pg_field_size
  • pg_field_type_oid ?
  • PHP Manual
  • PostgreSQL 函数
  • Returns the name or oid of the tables field

pg_field_table

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

pg_field_table — Returns the name or oid of the tables field

说明

pg_field_table ( resource $result , int $field_number , bool $oid_only = false ) : mixed

pg_field_table() returns the name of the table that field belongs to, or the table's oid if oid_only is true.

参数

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

oid_only

By default the tables name that field belongs to is returned but if oid_only is set to true, then the oid will instead be returned.

返回值

On success either the fields table name or oid. Or, false on failure.

范例

Example #1 Getting table information about a field

<?php
$dbconn = pg_connect("dbname=publisher") or die("Could not connect");

$res = pg_query($dbconn, "SELECT bar FROM foo");

echo pg_field_table($res, 0);
echo pg_field_table($res, 0, true);

$res = pg_query($dbconn, "SELECT version()");
var_dump(pg_field_table($res, 0));
?>

以上例程的输出类似于：

foo
14379580

bool(false)

注释

Note:

Returning the oid is much faster than returning the table name because fetching the table name requires a query to the database system table.

参见

  • pg_field_name() - 返回字段的名字
  • pg_field_type() - 返回相应字段的类型名称


Returns the type ID (OID) for the corresponding field number

  • ? pg_field_table
  • pg_field_type ?
  • PHP Manual
  • PostgreSQL 函数
  • Returns the type ID (OID) for the corresponding field number

pg_field_type_oid

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_field_type_oid — Returns the type ID (OID) for the corresponding field number

说明

pg_field_type_oid ( resource $result , int $field_number ) : int

pg_field_type_oid() returns an integer containing the OID of the base type of the given field_number in the given PostgreSQL result resource.

You can get more information about the field type by querying PostgreSQL's pg_type system table using the OID obtained with this function. The PostgreSQL format_type() function will convert a type OID into an SQL standard type name.

Note:

If the field uses a PostgreSQL domain (rather than a basic type), it is the OID of the domain's underlying type that is returned, rather than the OID of the domain itself.

参数

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

返回值

The OID of the field's base type. false is returned on error.

范例

Example #1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Assume 'title' is a varchar type
  $res = pg_query($dbconn, "select title from authors where author = 'Orwell'");

  echo "Title field type OID: ", pg_field_type_oid($res, 0);
?>

以上例程会输出：

Title field type OID: 1043

参见

  • pg_field_type() - 返回相应字段的类型名称
  • pg_field_prtlen() - 返回打印出来的长度
  • pg_field_name() - 返回字段的名字


返回相应字段的类型名称

  • ? pg_field_type_oid
  • pg_flush ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回相应字段的类型名称

pg_field_type

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_field_type — 返回相应字段的类型名称

说明

pg_field_type ( resource $result , int $field_number ) : string

pg_field_type() 以字符串返回 PostgreSQL result 资源中指定 field_number 字段的类型。字段编号从 0 开始。

参考 pg_field_name() 页面中的例子。

Note:

本函数以前的名字为 pg_fieldtype()。

参见 pg_field_prtlen() 和 pg_field_name()。


刷新链接中已处理的数据查询

  • ? pg_field_type
  • pg_free_result ?
  • PHP Manual
  • PostgreSQL 函数
  • 刷新链接中已处理的数据查询

pg_flush

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_flush — 刷新链接中已处理的数据查询

说明

pg_flush ( resource $connection ) : mixed

pg_flush() 刷新任何已经处理的等待发送到链接的数据查询。

参数

connection

PostgreSQL 数据库链接资源

返回值

如果刷新成功或者没有数据等待刷新返回 true ， 如果返回 0 为部分刷新或者更多未被刷新,刷新失败为 false


释放查询结果占用的内存

  • ? pg_flush
  • pg_get_notify ?
  • PHP Manual
  • PostgreSQL 函数
  • 释放查询结果占用的内存

pg_free_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_free_result — 释放查询结果占用的内存

说明

pg_free_result ( resource $result ) : bool

pg_free_result() 仅在当你担心脚本执行时占用了过多内存时调用。脚本执行完毕后所有的查询结果占用的内存都会被自动释放。不过如果你确认在脚本中不会再用到查询结果了，你可以用 result 作为参数调用 pg_free_result() 来释放有关的内存。成功时返回 true， 或者在失败时返回 false。

Note:

本函数以前的名字为 pg_freeresult()。

参见 pg_query()。

参数

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_free_result() example

<?php
$db = pg_connect("dbname=users user=me") || die();

$res = pg_query($db, "SELECT 1 UNION ALL SELECT 2");

$val = pg_fetch_result($res, 1, 0);

echo "First field in the second row is: ", $val, "\n";

pg_free_result($res);
?>

以上例程会输出：

First field in the second row is: 2

参见

  • pg_query() - 执行查询
  • pg_query_params() - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result


Ping 数据库连接

  • ? pg_free_result
  • pg_get_pid ?
  • PHP Manual
  • PostgreSQL 函数
  • Ping 数据库连接

pg_get_notify

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_get_notify — Ping 数据库连接

说明

pg_get_notify ( resource $connection , int $result_type = ? ) : array

pg_get_notify() 取得 SQL 命令 NOTIFY 发送的通告消息。要接收通告消息，必须发送 SQL 命令 LISTEN。如果连接中有通告消息，则数组包含消息名并且返回后端的 PID。如果没有消息则返回 false。

参见 pg_get_pid()。

Example #1 PostgreSQL NOTIFY 消息

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

// Listen 'author_updated' message from other processes
pq_query($conn, 'LISTEN author_updated;');
$notify = pg_get_notify($conn);
if (!$notify)
    print("No messages\n");
else
    print_r($notify);
?>


Ping 数据库连接

  • ? pg_get_notify
  • pg_get_result ?
  • PHP Manual
  • PostgreSQL 函数
  • Ping 数据库连接

pg_get_pid

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_get_pid — Ping 数据库连接

说明

pg_get_pid ( resource $connection ) : int

pg_get_pid() 取得后端（数据库服务器进程）的 PID。PID 用来检查其它进程是否发送了 NOTIFY 消息。

Example #1 PostgreSQL 后端 PID

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

// Backend process PID. Use PID with pg_get_notify()
$pid = pg_get_pid($conn);
?>

参见 pg_get_notify()。


取得异步查询结果

  • ? pg_get_pid
  • pg_host ?
  • PHP Manual
  • PostgreSQL 函数
  • 取得异步查询结果

pg_get_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_get_result — 取得异步查询结果

说明

pg_get_result ( resource $connection = ? ) : resource

pg_get_result() 取得执行 pg_send_query() 而得到的查询结果资源。pg_send_query() 可以向 PostgreSQL 发送多个查询， pg_get_result() 则用来逐个得到查询结果。返回值为查询结果资源号。如果没有更多查询结果，则返回 false。


返回和某连接关联的主机名

  • ? pg_get_result
  • pg_insert ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回和某连接关联的主机名

pg_host

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_host — 返回和某连接关联的主机名

说明

pg_host ( resource $connection ) : string

pg_host() 返回指定的 PostgreSQL connection 资源号所连接到的主机名称。

参见 pg_connect() 和 pg_pconnect()。


将数组插入到表中

  • ? pg_host
  • pg_last_error ?
  • PHP Manual
  • PostgreSQL 函数
  • 将数组插入到表中

pg_insert

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_insert — 将数组插入到表中

说明

pg_insert ( resource $connection , string $table_name , array $assoc_array , int $options = PGSQL_DML_EXEC ) : mixed

pg_insert() 将 assoc_array 数组中的值插入到由 table_name 指定的表中。 如果给出了参数 options ，则函数 pg_convert() 会按照给定选项被作用到 assoc_array 上

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to insert rows. table_name 中的列必须至少要有 assoc_array 中的单元那么多。

assoc_array

table_name 中的字段名以及字段值必须和 array 参数 中的键名及值匹配。

options

Any number of PGSQL_CONV_OPTS, PGSQL_DML_NO_CONV, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned.

返回值

成功时返回 true， 或者在失败时返回 false。 Returns string if PGSQL_DML_STRING is passed via options.

范例

Example #1 pg_insert() example

<?php
  $dbconn = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $res = pg_insert($dbconn, 'post_log', $_POST);
  if ($res) {
      echo "POST data is successfully logged\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

参见

  • pg_convert() - 将关联的数组值转换为适合 SQL 语句的格式。


得到某连接的最后一条错误信息

  • ? pg_insert
  • pg_last_notice ?
  • PHP Manual
  • PostgreSQL 函数
  • 得到某连接的最后一条错误信息

pg_last_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_last_error — 得到某连接的最后一条错误信息

说明

pg_last_error ( resource $connection = ? ) : string

pg_last_error() 返回指定连接 connection 的最后一条错误信息。

错误信息可能会被 PostgreSQL(libpq) 的内部函数调用所覆盖。如果 PostgreSQL 的内部模块函数产生了多个错误，则可能不能返回适当的错误信息。

使用 pg_result_error()，pg_result_status() 和 pg_connection_status() 来取得更好的错误处理。

Note:

本函数以前的名字为 pg_errormessage()。

参见 pg_result_error()。


返回 PostgreSQL 服务器最新一条公告信息

  • ? pg_last_error
  • pg_last_oid ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回 PostgreSQL 服务器最新一条公告信息

pg_last_notice

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

pg_last_notice — 返回 PostgreSQL 服务器最新一条公告信息

说明

pg_last_notice ( resource $connection ) : string

pg_last_notice() 返回由 connection 指定的 PostgreSQL 服务器最新的一条公告信息。PostgreSQL 服务器在某些情况下会发送公告信息，例如在表里创建 SERIAL 列。

有了 pg_last_notice()，只要检查公告是否和该事务有关，就可以避免提交无用的查询。

可以通过在 php.ini 中把 pgsql.ignore_notice 置为 1 来使公告信息追踪成为可选项。

可以通过在 php.ini 中把 pgsql.log_notice 置为 0 来使公告信息日志成为可选项。 除非 pgsql.ignore_notice 为 0，否则公告信息不能被日志记录。

参数

connection

PostgreSQL database connection resource.

返回值

A string containing the last notice on the given connection, or false on error.

更新日志

版本 | 说明
4.3.0 | 本函数在 PHP 4.3.0 中完全实现。低于 PHP 4.3.0 的版本中都忽略了数据库连接参数。
4.3.0 | The pgsql.ignore_notice and pgsql.log_notice php.ini directives were added.
4.0.6 | PHP 4.0.6 本身在公告信息处理上有问题。即使不使用 pg_last_notice() 函数，也不推荐在 PHP 4.0.6 中使用 PostgreSQL 模块。

范例

Example #1 pg_last_notice() example

<?php
  $pgsql_conn = pg_connect("dbname=mark host=localhost");

  $res = pg_query("CREATE TABLE test (id SERIAL)");

  $notice = pg_last_notice($pgsql_conn);

  echo $notice;
?>

以上例程会输出：

CREATE TABLE will create implicit sequence "test_id_seq" for "serial" column "test.id"

参见

  • pg_query() - 执行查询
  • pg_last_error() - 得到某连接的最后一条错误信息


返回上一个对象的 oid

  • ? pg_last_notice
  • pg_lo_close ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回上一个对象的 oid

pg_last_oid

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_last_oid — 返回上一个对象的 oid

说明

pg_last_oid ( resource $result ) : int

pg_last_oid() 在上一条通过 pg_query() 发送的命令是 SQL INSERT 的情况下用来取得分配给所插入记录的 oid。如果存在有效的 oid 则返回一个正整数，如果出错或者上一条通过 pg_query() 发送的命令不是 INSERT 或者该 INSERT 失败则返回 false。

从 PostgreSQL 7.2 版开始 OID 字段成为可选项。如果一个表中没有定义 OID 字段，程序员必须用 pg_result_status() 函数来检查记录是否被成功插入。

Note:

本函数以前的名字为 pg_getlastoid()。

参见 pg_query() 和 pg_result_status()。


关闭一个大型对象

  • ? pg_last_oid
  • pg_lo_create ?
  • PHP Manual
  • PostgreSQL 函数
  • 关闭一个大型对象

pg_lo_close

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_close — 关闭一个大型对象

说明

pg_lo_close ( resource $large_object ) : bool

pg_lo_close() 关闭一个大型对象。参数 large_object 是 pg_lo_open() 函数所返回的资源号。

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_loclose()。

参见 pg_lo_open()，pg_lo_create() 和 pg_lo_import()。


新建一个大型对象

  • ? pg_lo_close
  • pg_lo_export ?
  • PHP Manual
  • PostgreSQL 函数
  • 新建一个大型对象

pg_lo_create

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_create — 新建一个大型对象

说明

pg_lo_create ( resource $connection ) : int

pg_lo_create() 新建一个大型对象并返回该大型对象的 oid。connection 指定了由 pg_connect() 或 pg_pconnect() 打开的有效的数据库连接号。不支持 PostgreSQL 访问模式 INV_READ，INV_WRITE 和 INV_ARCHIVE，该对象总是以读写方式访问。INV_ARCHIVE 已经从 PostgreSQL 中删除了（6.3 及以上版本）。本函数返回大型对象的 oid，如果出错则返回 false。

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_locreate()。


将大型对象导出到文件

  • ? pg_lo_create
  • pg_lo_import ?
  • PHP Manual
  • PostgreSQL 函数
  • 将大型对象导出到文件

pg_lo_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_export — 将大型对象导出到文件

说明

pg_lo_export ( resource $connection = ? , int $oid , string $pathname ) : bool

pg_lo_export() takes a large object in a PostgreSQL database and saves its contents to a file on the local filesystem.

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_loexport()。

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

要导出的数据库里的大型对象的 OID。

pathname

要导出的数据库里的大型对象的文件在客户端上完整路径和文件名。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_lo_export() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   $handle = pg_lo_open($database, $oid, "w");
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_lo_export($database, $oid, '/tmp/lob.dat');
   pg_query($database, "commit");
?>

参见

  • pg_lo_import() - 将文件导入为大型对象


将文件导入为大型对象

  • ? pg_lo_export
  • pg_lo_open ?
  • PHP Manual
  • PostgreSQL 函数
  • 将文件导入为大型对象

pg_lo_import

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_import — 将文件导入为大型对象

说明

pg_lo_import ( resource $connection = ? , string $pathname , mixed $object_id = ? ) : int

pg_lo_import() creates a new large object in the database using a file on the filesystem as its data source.

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_loimport()。

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

pathname

变量指明了要导入为大型对象的文件名。

object_id

If an object_id is given the function will try to create a large object with this id, else a free object id is assigned by the server. The parameter was added in PHP 5.3 and relies on functionality that first appeared in PostgreSQL 8.1.

返回值

导入成功则返回新建的大型对象的 OID，如果出错则返回 false。

范例

Example #1 pg_lo_import() 例子

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_import($database, '/tmp/lob.dat');
   pg_query($database, "commit");
?>

参见

  • pg_lo_export() - 将大型对象导出到文件
  • pg_lo_open() - 打开一个大型对象


打开一个大型对象

  • ? pg_lo_import
  • pg_lo_read_all ?
  • PHP Manual
  • PostgreSQL 函数
  • 打开一个大型对象

pg_lo_open

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_open — 打开一个大型对象

说明

pg_lo_open ( resource $connection , int $oid , string $mode ) : resource

pg_lo_open() 打开一个大型对象并返回大型对象资源号。该资源号内封装了连接号。oid 指定了有效的大型对象的 oid，mode 可以为 "r"，"w" 或者 "rw"。如果失败则返回 false。

Warning

在关闭大型对象资源之前不要关闭数据库连接。

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_loopen()。

参见 pg_lo_close() 和 pg_lo_create()。


读入整个大型对象并直接发送给浏览器

  • ? pg_lo_open
  • pg_lo_read ?
  • PHP Manual
  • PostgreSQL 函数
  • 读入整个大型对象并直接发送给浏览器

pg_lo_read_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_read_all — 读入整个大型对象并直接发送给浏览器

说明

pg_lo_read_all ( resource $large_object ) : int

pg_lo_read_all() 读入一个大型对象并在（PHP）发送完所有待发的 header 之后将其直接发送给浏览器。主要目的是发送图片或声音等二进制数据。返回值为读入的字节数，如果出错则返回 false。

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_loreadall()。

参见 pg_lo_read()。


从大型对象中读入数据

  • ? pg_lo_read_all
  • pg_lo_seek ?
  • PHP Manual
  • PostgreSQL 函数
  • 从大型对象中读入数据

pg_lo_read

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_read — 从大型对象中读入数据

说明

pg_lo_read ( resource $large_object , int $len ) : string

pg_lo_read() 从大型对象中读入最多 len 字节的数据并以字符串返回。large_object 指定了有效的大型对象的资源号，len 则指定了大型对象的段所允许的最大长度。如果出错则返回 false。

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_loread()。

参见 pg_lo_read_all()。


移动大型对象中的指针

  • ? pg_lo_read
  • pg_lo_tell ?
  • PHP Manual
  • PostgreSQL 函数
  • 移动大型对象中的指针

pg_lo_seek

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_seek — 移动大型对象中的指针

说明

pg_lo_seek ( resource $large_object , int $offset , int $whence = ? ) : bool

pg_lo_seek() 在大型对象资源中移动指针位置。whence 参数为 PGSQL_SEEK_SET，PGSQL_SEEK_CUR 或 PGSQL_SEEK_END。

参见 pg_lo_tell()。


返回大型对象的当前指针位置

  • ? pg_lo_seek
  • pg_lo_truncate ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回大型对象的当前指针位置

pg_lo_tell

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_tell — 返回大型对象的当前指针位置

说明

pg_lo_tell ( resource $large_object ) : int

pg_lo_tell() 返回当前指针位置（大型对象中从头开始的偏移量）。

参见 pg_lo_seek()。


Truncates a large object

  • ? pg_lo_tell
  • pg_lo_unlink ?
  • PHP Manual
  • PostgreSQL 函数
  • Truncates a large object

pg_lo_truncate

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_lo_truncate — Truncates a large object

说明

pg_lo_truncate ( resource $large_object , int $size ) : bool

pg_lo_truncate() truncates a large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

参数

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

size

The number of bytes to truncate.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_lo_truncate() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Truncate to 0
   pg_lo_truncate($handle, 0);
   pg_query($database, "commit");
   echo $data;
?>

更新日志

版本 | 说明
5.6.0 | Added truncate function. It supports PostgreSQL 9.3's 64bit large object. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.

参见

  • pg_lo_tell() - 返回大型对象的当前指针位置


删除一个大型对象

  • ? pg_lo_truncate
  • pg_lo_write ?
  • PHP Manual
  • PostgreSQL 函数
  • 删除一个大型对象

pg_lo_unlink

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_unlink — 删除一个大型对象

说明

pg_lo_unlink ( resource $connection , int $oid ) : bool

pg_lo_unlink() 删除由 oid 指定的大型对象。成功时返回 true， 或者在失败时返回 false。

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_lo_unlink()。

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_lo_unlink() example

<?php
   // OID of the large object to delete
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   pg_lo_unlink($database, $doc_oid);
   pg_query($database, "commit");
?>

参见

  • pg_lo_create() - 新建一个大型对象
  • pg_lo_import() - 将文件导入为大型对象


向大型对象写入数据

  • ? pg_lo_unlink
  • pg_meta_data ?
  • PHP Manual
  • PostgreSQL 函数
  • 向大型对象写入数据

pg_lo_write

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_lo_write — 向大型对象写入数据

说明

pg_lo_write ( resource $large_object , string $data ) : int

pg_lo_write() 把 data 参数中的数据尽可能多地写入大型对象并返回实际写入的字节数。如果出错则返回 false。large_object 参数是 pg_lo_open() 函数所返回的大型对象资源号。

要使用大型对象（lo）接口，需要将其放置在事务块中。

Note:

本函数以前的名字为 pg_lo_write()。

参见 pg_lo_create() 和 pg_lo_open()。


获得表的元数据

  • ? pg_lo_write
  • pg_num_fields ?
  • PHP Manual
  • PostgreSQL 函数
  • 获得表的元数据

pg_meta_data

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_meta_data — 获得表的元数据

说明

pg_meta_data ( resource $connection , string $table_name ) : array

pg_metadata() 以数组形式返回 table_name 表的定义。

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

connection

PostgreSQL database connection resource.

table_name

The name of the table.

返回值

以数组 array 形式返回表的定义，如果出错则返回 false。

范例

Example #1 取得表的元数据

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $meta = pg_meta_data($dbconn, 'authors');
  if (is_array($meta)) {
      echo '<pre>';
      var_dump($meta);
      echo '</pre>';
  }
?>

以上例程会输出：

array(3) {
["author"]=>
array(5) {
  ["num"]=>
  int(1)
  ["type"]=>
  string(7) "varchar"
  ["len"]=>
  int(-1)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
["year"]=>
array(5) {
  ["num"]=>
  int(2)
  ["type"]=>
  string(4) "int2"
  ["len"]=>
  int(2)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
["title"]=>
array(5) {
  ["num"]=>
  int(3)
  ["type"]=>
  string(7) "varchar"
  ["len"]=>
  int(-1)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
}

参见

  • pg_convert() - 将关联的数组值转换为适合 SQL 语句的格式。


返回字段的数目

  • ? pg_meta_data
  • pg_num_rows ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回字段的数目

pg_num_fields

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_num_fields — 返回字段的数目

说明

pg_num_fields ( resource $result ) : int

pg_num_fields() 返回 PostgreSQL result 中的字段（列）数目。参数是由 pg_query() 函数返回的查询结果资源号。如果出错则返回 -1。

Note:

本函数以前的名字为 pg_numfields()。

参见 pg_num_rows() 和 pg_affected_rows()。


返回行的数目

  • ? pg_num_fields
  • pg_options ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回行的数目

pg_num_rows

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_num_rows — 返回行的数目

说明

pg_num_rows ( resource $result ) : int

pg_num_rows() 返回 PostgreSQL result 中的行的数目。result 参数是由 pg_query() 函数返回的查询结果资源号。如果出错则返回 -1。

Note:

用 pg_affected_rows() 函数获得被 INSERT，UPDATE 和 DELETE 命令影响到的行的数目。

Note:

本函数以前的名字为 pg_numrows()。

参见 pg_num_fields() 和 pg_affected_rows()。


获得和连接有关的选项

  • ? pg_num_rows
  • pg_parameter_status ?
  • PHP Manual
  • PostgreSQL 函数
  • 获得和连接有关的选项

pg_options

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_options — 获得和连接有关的选项

说明

pg_options ( resource $connection ) : string

pg_options() 以字符串形式返回指定 PostgreSQL connection 资源的连接选项。


Looks up a current parameter setting of the server

  • ? pg_options
  • pg_pconnect ?
  • PHP Manual
  • PostgreSQL 函数
  • Looks up a current parameter setting of the server

pg_parameter_status

(PHP 5, PHP 7, PHP 8)

pg_parameter_status — Looks up a current parameter setting of the server

说明

pg_parameter_status ( resource $connection = ? , string $param_name ) : string

Looks up a current parameter setting of the server.

Certain parameter values are reported by the server automatically at connection startup or whenever their values change. pg_parameter_status() can be used to interrogate these settings. It returns the current value of a parameter if known, or false if the parameter is not known.

Parameters reported as of PostgreSQL 8.0 include server_version, server_encoding, client_encoding, is_superuser, session_authorization, DateStyle, TimeZone, and integer_datetimes. (server_encoding, TimeZone, and integer_datetimes were not reported by releases before 8.0.) Note that server_version, server_encoding and integer_datetimes cannot change after PostgreSQL startup.

PostgreSQL 7.3 or lower servers do not report parameter settings, pg_parameter_status() includes logic to obtain values for server_version and client_encoding anyway. Applications are encouraged to use pg_parameter_status() rather than ad hoc code to determine these values.

Caution

On a pre-7.4 PostgreSQL server, changing client_encoding via SET after connection startup will not be reflected by pg_parameter_status().

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

param_name

Possible param_name values include server_version, server_encoding, client_encoding, is_superuser, session_authorization, DateStyle, TimeZone, and integer_datetimes. Note that this value is case-sensitive.

返回值

A string containing the value of the parameter, false on failure or invalid param_name.

范例

Example #1 pg_parameter_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  echo "Server encoding: ", pg_parameter_status($dbconn, "server_encoding");
?>

以上例程会输出：

Server encoding: SQL_ASCII


打开一个持久的 PostgreSQL 连接

  • ? pg_parameter_status
  • pg_ping ?
  • PHP Manual
  • PostgreSQL 函数
  • 打开一个持久的 PostgreSQL 连接

pg_pconnect

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_pconnect — 打开一个持久的 PostgreSQL 连接

说明

pg_pconnect ( string $connection_string , int $connect_type = ? ) : resource

pg_pconnect() 打开一个到 PostgreSQL 数据库的持久连接。返回其它 PostgreSQL 函数所需要的连接资源号。

If a second call is made to pg_pconnect() with the same connection_string as an existing connection, the existing connection will be returned unless you pass PGSQL_CONNECT_FORCE_NEW as connect_type.

要打开持久连接功能，php.ini 中的 pgsql.allow_persistent 参数必须为 "On"（也是默认值）。 最大持久连接数目由 php.ini 中的 pgsql.max_persistent 参数定义（默认为 -1 表示没有限制）。所有连接的数目可由 php.ini 中的 pgsql.max_links 参数设置。

pg_close() 不能关闭由 pg_pconnect() 打开的持久连接。

参数

connection_string

The connection_string can be empty to use all default parameters, or it can contain one or more parameter settings separated by whitespace. Each parameter setting is in the form keyword = value. Spaces around the equal sign are optional. To write an empty value or a value containing spaces, surround it with single quotes, e.g., keyword = 'a value'. Single quotes and backslashes within the value must be escaped with a backslash, i.e., \' and \.

The currently recognized parameter keywords are: host, hostaddr, port, dbname, user, password, connect_timeout, options, tty (ignored), sslmode, requiressl (deprecated in favor of sslmode), and service. Which of these arguments exist depends on your PostgreSQL version.

connect_type

If PGSQL_CONNECT_FORCE_NEW is passed, then a new connection is created, even if the connection_string is identical to an existing connection.

返回值

PostgreSQL connection resource on success, false on failure.

范例

Example #1 Using pg_pconnect()

<?php
$dbconn = pg_pconnect("dbname=mary");
//connect to a database named "mary"

$dbconn2 = pg_pconnect("host=localhost port=5432 dbname=mary");
// connect to a database named "mary" on "localhost" at port "5432"

$dbconn3 = pg_pconnect("host=sheep port=5432 dbname=mary user=lamb password=foo");
//connect to a database named "mary" on the host "sheep" with a username and password

$conn_string = "host=sheep port=5432 dbname=test user=lamb password=bar";
$dbconn4 = pg_pconnect($conn_string);
//connect to a database named "test" on the host "sheep" with a username and password
?>

参见

  • pg_connect() - 打开一个 PostgreSQL 连接
  • 持久数据库连接


Ping 数据库连接

  • ? pg_pconnect
  • pg_port ?
  • PHP Manual
  • PostgreSQL 函数
  • Ping 数据库连接

pg_ping

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_ping — Ping 数据库连接

说明

pg_ping ( resource $connection ) : bool

pg_ping() ping 数据库连接，如果中断则尝试重新连接。如果连接在活动状态返回 true，否则返回 false。

Example #1 pg_ping()

<?php
$conn = pg_pconnect ("dbname=publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

if (!pg_ping($conn))
    die("Connection is broken\n");
?>
参见 pg_connection_status() 和 pg_connection_reset()。


返回该连接的端口号

  • ? pg_ping
  • pg_prepare ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回该连接的端口号

pg_port

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_port — 返回该连接的端口号

说明

pg_port ( resource $connection ) : int

pg_port() 返回给定的 PostgreSQL connection 资源所连接的端口号。


Submits a request to create a prepared statement with the given parameters, and waits for completion

  • ? pg_port
  • pg_put_line ?
  • PHP Manual
  • PostgreSQL 函数
  • Submits a request to create a prepared statement with the given parameters, and waits for completion

pg_prepare

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_prepare — Submits a request to create a prepared statement with the given parameters, and waits for completion

说明

pg_prepare ( resource $connection = ? , string $stmtname , string $query ) : resource|false

pg_prepare() creates a prepared statement for later execution with pg_execute() or pg_send_execute(). This feature allows commands that will be used repeatedly to be parsed and planned just once, rather than each time they are executed. pg_prepare() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

The function creates a prepared statement named stmtname from the query string, which must contain a single SQL command. stmtname may be "" to create an unnamed statement, in which case any pre-existing unnamed statement is automatically replaced; otherwise it is an error if the statement name is already defined in the current session. If any parameters are used, they are referred to in the query as $1, $2, etc.

Prepared statements for use with pg_prepare() can also be created by executing SQL PREPARE statements. (But pg_prepare() is more flexible since it does not require parameter types to be pre-specified.) Also, although there is no PHP function for deleting a prepared statement, the SQL DEALLOCATE statement can be used for that purpose.

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name to give the prepared statement. Must be unique per-connection. If "" is specified, then an unnamed statement is created, overwriting any previously defined unnamed statement.

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

返回值

A query result resource on success 或者在失败时返回 false.

范例

Example #1 Using pg_prepare()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Prepare a query for execution
$result = pg_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');

// Execute the prepared query.  Note that it is not necessary to escape
// the string "Joe's Widgets" in any way
$result = pg_execute($dbconn, "my_query", array("Joe's Widgets"));

// Execute the same prepared query, this time with a different parameter
$result = pg_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));

?>

参见

  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result
  • pg_send_execute() - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)


向 PostgreSQL 后端发送以 NULL 结尾的字符串

  • ? pg_prepare
  • pg_query_params ?
  • PHP Manual
  • PostgreSQL 函数
  • 向 PostgreSQL 后端发送以 NULL 结尾的字符串

pg_put_line

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pg_put_line — 向 PostgreSQL 后端发送以 NULL 结尾的字符串

说明

pg_put_line ( resource $connection = ? , string $data ) : bool

pg_put_line() 向 PostgreSQL 后端服务器发送以 NULL 结尾的字符串。例如可以通过 PostgreSQL 的 COPY 操作来向表中高速插入数据。结尾的 NULL 字符会自动加入。

COPY is a high-speed data loading interface supported by PostgreSQL. Data is passed in without being parsed, and in a single transaction.

An alternative to using raw pg_put_line() commands is to use pg_copy_from(). This is a far simpler interface.

Note:

应用程序必须明确地在 pg_end_copy() 之前最后一行发送两个字符 "\." 来向后端指明发送数据结束。

Warning

Use of the pg_put_line() causes most large object operations, including pg_lo_read() and pg_lo_tell(), to subsequently fail. You can use pg_copy_from() and pg_copy_to() instead.

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A line of text to be sent directly to the PostgreSQL backend. A NULL terminator is added automatically.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pg_put_line() 例子

<?php
  $conn = pg_pconnect("dbname=foo");
  pg_query($conn, "create table bar (a int4, b char(16), d float8)");
  pg_query($conn, "copy bar from stdin");
  pg_put_line($conn, "3\thello world\t4.5\n");
  pg_put_line($conn, "4\tgoodbye world\t7.11\n");
  pg_put_line($conn, "\.\n");
  pg_end_copy($conn);
?>

参见

  • pg_end_copy() - 与 PostgreSQL 后端同步


Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text

  • ? pg_put_line
  • pg_query ?
  • PHP Manual
  • PostgreSQL 函数
  • Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text

pg_query_params

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text

说明

pg_query_params ( resource $connection = ? , string $query , array $params ) : resource|false

Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.

pg_query_params() is like pg_query(), but offers additional functionality: parameter values can be specified separately from the command string proper. pg_query_params() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

If parameters are used, they are referred to in the query string as $1, $2, etc. The same parameter may appear more than once in the query; the same value will be used in that case. params specifies the actual values of the parameters. A null value in this array means the corresponding parameter is SQL NULL.

The primary advantage of pg_query_params() over pg_query() is that parameter values may be separated from the query string, thus avoiding the need for tedious and error-prone quoting and escaping. Unlike pg_query(), pg_query_params() allows at most one SQL command in the given string. (There can be semicolons in it, but not more than one nonempty command.)

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

User-supplied values should always be passed as parameters, not interpolated into the query string, where they form possible SQL injection attack vectors and introduce bugs when handling data containing quotes. If for some reason you cannot use a parameter, ensure that interpolated values are properly escaped.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Values intended for bytea fields are not supported as parameters. Use pg_escape_bytea() instead, or use the large object functions.

返回值

A query result resource on success 或者在失败时返回 false.

范例

Example #1 Using pg_query_params()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Find all shops named Joe's Widgets.  Note that it is not necessary to
// escape "Joe's Widgets"
$result = pg_query_params($dbconn, 'SELECT * FROM shops WHERE name = $1', array("Joe's Widgets"));

// Compare against just using pg_query
$str = pg_escape_string("Joe's Widgets");
$result = pg_query($dbconn, "SELECT * FROM shops WHERE name = '{$str}'");

?>

参见

  • pg_query() - 执行查询


执行查询

  • ? pg_query_params
  • pg_result_error_field ?
  • PHP Manual
  • PostgreSQL 函数
  • 执行查询

pg_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_query — 执行查询

说明

pg_query ( resource $connection , string $query ) : resource

pg_query() 在查询可以执行时返回查询结果资源号。如果查询失败或者提供的连接号无效则返回 false。如果连接号有效，则可以用 pg_last_error() 函数来提取详细的错误信息。pg_query() 发送一条 SQL 语句到 connection 资源指定的 PostgreSQL 数据库。connection 必须是由 pg_connect() 或 pg_pconnect() 返回的合法连接号。本函数返回值是一个其它 PostgreSQL 函数例如 pg_fetch_array() 可以用来访问查询结果的查询结果资源号。

Note: connection 是 pg_query() 中的可选参数。如果没有指定 connection，则使用默认连接。默认连接是 pg_connect() 或 pg_pconnect() 所打开的最后一个连接。 尽管 connection 参数可以省略，但不推荐这样做。因为这样可能会导致很难发现脚本中的错误。

Note:

本函数以前的名字为 pg_exec()。pg_exec() 函数为了兼容性的原因仍然可以使用，但是鼓励用户使用新的名字。

参见 pg_connect()，pg_pconnect()，pg_fetch_array()，pg_fetch_object()，pg_num_rows() 和 pg_affected_rows()。


Returns an individual field of an error report

  • ? pg_query
  • pg_result_error ?
  • PHP Manual
  • PostgreSQL 函数
  • Returns an individual field of an error report

pg_result_error_field

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_result_error_field — Returns an individual field of an error report

说明

pg_result_error_field ( resource $result , int $fieldcode ) : string

pg_result_error_field() returns one of the detailed error message fields associated with result resource. It is only available against a PostgreSQL 7.4 or above server. The error field is specified by the fieldcode.

Because pg_query() and pg_query_params() return false if the query fails, you must use pg_send_query() and pg_get_result() to get the result handle.

If you need to get additional error information from failed pg_query() queries, use pg_set_error_verbosity() and pg_last_error() and then parse the result.

参数

result

A PostgreSQL query result resource from a previously executed statement.

fieldcode

Possible fieldcode values are: PGSQL_DIAG_SEVERITY, PGSQL_DIAG_SQLSTATE, PGSQL_DIAG_MESSAGE_PRIMARY, PGSQL_DIAG_MESSAGE_DETAIL, PGSQL_DIAG_MESSAGE_HINT, PGSQL_DIAG_STATEMENT_POSITION, PGSQL_DIAG_INTERNAL_POSITION (PostgreSQL 8.0+ only), PGSQL_DIAG_INTERNAL_QUERY (PostgreSQL 8.0+ only), PGSQL_DIAG_CONTEXT, PGSQL_DIAG_SOURCE_FILE, PGSQL_DIAG_SOURCE_LINE or PGSQL_DIAG_SOURCE_FUNCTION.

返回值

A string containing the contents of the error field, null if the field does not exist or false on failure.

范例

Example #1 pg_result_error_field() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  $res1 = pg_get_result($dbconn);
  echo pg_result_error_field($res1, PGSQL_DIAG_SQLSTATE);
?>

参见

  • pg_result_error() - 获得查询结果的错误信息


获得查询结果的错误信息

  • ? pg_result_error_field
  • pg_result_seek ?
  • PHP Manual
  • PostgreSQL 函数
  • 获得查询结果的错误信息

pg_result_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_result_error — 获得查询结果的错误信息

说明

pg_result_error ( resource $result ) : string

pg_result_error() 返回和 result 资源关联的错误信息。因此用户更有机会可以得到比 pg_last_error() 更好的错误信息。

参见 pg_query()，pg_send_query()，pg_get_result()，pg_last_error() 和 pg_last_notice()。


在结果资源中设定内部行偏移量

  • ? pg_result_error
  • pg_result_status ?
  • PHP Manual
  • PostgreSQL 函数
  • 在结果资源中设定内部行偏移量

pg_result_seek

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_result_seek — 在结果资源中设定内部行偏移量

说明

pg_result_seek ( resource $result , int $offset ) : array

pg_result_seek() 在结果资源中设定内部行偏移量。如果出错则返回 false。

参见 pg_fetch_row()，pg_fetch_assoc()，pg_fetch_array()，pg_fetch_object() 和 pg_fetch_result()。


获得查询结果的状态

  • ? pg_result_seek
  • pg_select ?
  • PHP Manual
  • PostgreSQL 函数
  • 获得查询结果的状态

pg_result_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_result_status — 获得查询结果的状态

说明

pg_result_status ( resource $result ) : int

pg_result_status() 返回该查询结果资源的状态。可能的返回值有 PGSQL_EMPTY_QUERY，PGSQL_COMMAND_OK，PGSQL_TUPLES_OK，PGSQL_COPY_TO，PGSQL_COPY_FROM，PGSQL_BAD_RESPONSE，PGSQL_NONFATAL_ERROR 和 PGSQL_FATAL_ERROR。

参见 pg_connection_status()。


选择记录

  • ? pg_result_status
  • pg_send_execute ?
  • PHP Manual
  • PostgreSQL 函数
  • 选择记录

pg_select

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_select — 选择记录

说明

pg_select ( resource $connection , string $table_name , array $assoc_array , int $options = PGSQL_DML_EXEC ) : mixed

pg_select() 根据 assoc_array 数组中的 field=>value 值来选择记录。成功的查询返回和 assoc_array 指定的条件相匹配的包括记录和字段的数组。

如果指定了 options，pg_convert() 会按照指定选项作用于 assoc_array 之上。

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

connection

PostgreSQL 数据库连接资源。

table_name

Name of the table from which to select rows.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the conditions that a row must meet to be retrieved.

options

Any number of PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned.

返回值

成功时返回 true， 或者在失败时返回 false。 Returns string if PGSQL_DML_STRING is passed via options.

范例

Example #1 pg_select() example

<?php
  $db = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $rec = pg_select($db, 'post_log', $_POST);
  if ($rec) {
      echo "Records selected\n";
      var_dump($rec);
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

参见

  • pg_convert() - 将关联的数组值转换为适合 SQL 语句的格式。


Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)

  • ? pg_select
  • pg_send_prepare ?
  • PHP Manual
  • PostgreSQL 函数
  • Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)

pg_send_execute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)

说明

pg_send_execute ( resource $connection , string $stmtname , array $params ) : bool

Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).

This is similar to pg_send_query_params(), but the command to be executed is specified by naming a previously-prepared statement, instead of giving a query string. The function's parameters are handled identically to pg_execute(). Like pg_execute(), it will not work on pre-7.4 versions of PostgreSQL.

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name of the prepared statement to execute. if "" is specified, then the unnamed statement is executed. The name must have been previously prepared using pg_prepare(), pg_send_prepare() or a PREPARE SQL command.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

返回值

Returns true on success, false on failure. Use pg_get_result() to determine the query result.

范例

Example #1 Using pg_send_execute()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Prepare a query for execution
  if (!pg_connection_busy($dbconn)) {
    pg_send_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');
    $res1 = pg_get_result($dbconn);
  }

  // Execute the prepared query.  Note that it is not necessary to escape
  // the string "Joe's Widgets" in any way
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Joe's Widgets"));
    $res2 = pg_get_result($dbconn);
  }

  // Execute the same prepared query, this time with a different parameter
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));
    $res3 = pg_get_result($dbconn);
  }

?>

参见

  • pg_prepare() - Submits a request to create a prepared statement with the given parameters, and waits for completion
  • pg_send_prepare() - Sends a request to create a prepared statement with the given parameters, without waiting for completion
  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result


Sends a request to create a prepared statement with the given parameters, without waiting for completion

  • ? pg_send_execute
  • pg_send_query_params ?
  • PHP Manual
  • PostgreSQL 函数
  • Sends a request to create a prepared statement with the given parameters, without waiting for completion

pg_send_prepare

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_send_prepare — Sends a request to create a prepared statement with the given parameters, without waiting for completion

说明

pg_send_prepare ( resource $connection , string $stmtname , string $query ) : bool

Sends a request to create a prepared statement with the given parameters, without waiting for completion.

This is an asynchronous version of pg_prepare(): it returns true if it was able to dispatch the request, and false if not. After a successful call, call pg_get_result() to determine whether the server successfully created the prepared statement. The function's parameters are handled identically to pg_prepare(). Like pg_prepare(), it will not work on pre-7.4 versions of PostgreSQL.

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name to give the prepared statement. Must be unique per-connection. If "" is specified, then an unnamed statement is created, overwriting any previously defined unnamed statement.

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

返回值

Returns true on success, false on failure. Use pg_get_result() to determine the query result.

范例

Example #1 Using pg_send_prepare()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Prepare a query for execution
  if (!pg_connection_busy($dbconn)) {
    pg_send_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');
    $res1 = pg_get_result($dbconn);
  }

  // Execute the prepared query.  Note that it is not necessary to escape
  // the string "Joe's Widgets" in any way
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Joe's Widgets"));
    $res2 = pg_get_result($dbconn);
  }

  // Execute the same prepared query, this time with a different parameter
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));
    $res3 = pg_get_result($dbconn);
  }

?>

参见

  • pg_connect() - 打开一个 PostgreSQL 连接
  • pg_pconnect() - 打开一个持久的 PostgreSQL 连接
  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result
  • pg_send_execute() - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)
  • pg_send_query_params() - Submits a command and separate parameters to the server without waiting for the result(s)


Submits a command and separate parameters to the server without waiting for the result(s)

  • ? pg_send_prepare
  • pg_send_query ?
  • PHP Manual
  • PostgreSQL 函数
  • Submits a command and separate parameters to the server without waiting for the result(s)

pg_send_query_params

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s)

说明

pg_send_query_params ( resource $connection , string $query , array $params ) : bool

Submits a command and separate parameters to the server without waiting for the result(s).

This is equivalent to pg_send_query() except that query parameters can be specified separately from the query string. The function's parameters are handled identically to pg_query_params(). Like pg_query_params(), it will not work on pre-7.4 PostgreSQL connections, and it allows only one command in the query string.

参数

connection

PostgreSQL database connection resource.

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

返回值

成功时返回 true， 或者在失败时返回 false。

Use pg_get_result() to determine the query result.

范例

Example #1 Using pg_send_query_params()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Using parameters.  Note that it is not necessary to quote or escape
  // the parameter.
  pg_send_query_params($dbconn, 'select count(*) from authors where city = $1', array('Perth'));

  // Compare against basic pg_send_query usage
  $str = pg_escape_string('Perth');
  pg_send_query($dbconn, "select count(*) from authors where city = '${str}'");
?>

参见

  • pg_send_query() - 发送异步查询


发送异步查询

  • ? pg_send_query_params
  • pg_set_client_encoding ?
  • PHP Manual
  • PostgreSQL 函数
  • 发送异步查询

pg_send_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pg_send_query — 发送异步查询

说明

pg_send_query ( resource $connection , string $query ) : bool
pg_send_query ( string $query ) : bool

pg_send_query() 向 connection
连接发送异步查询。和 pg_query() 不同，它可以向 PostgreSQL
发送多个查询并用 pg_get_result()
依次得到结果。当执行查询时脚本的执行不会被锁定。用
pg_connection_busy() 来检查连接连接是否为忙（即查询正在执行中）。调用
pg_cancel_query() 则有可能取消查询。

尽管用户可以一次发送多个查询，但用户不能通过正忙的连接发送多个查询。如果向正忙的连接发送了查询，则会等待上一条查询结束并丢弃所有结果。

Example #1 异步查询

<?php
    $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
    if (!pg_connection_busy($dbconn)) {
        pg_send_query($dbconn,"select * from authors; select count(*) from authors;");
    }
    $res1 = pg_get_result($dbconn);
    echo "First call to pg_get_result(): $res1\n";
    $rows1 = pg_num_rows($res1);
    echo "$res1 has $rows1 records\n\n";
    $res2 = pg_get_result($dbconn);
    echo "second call to pg_get_result(): $res2\n";
    $rows2 = pg_num_rows($res2);
    echo "$res2 has $rows2 records\n";
?>

上例输出如下：

first call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

second call to pg_get_result(): Resource id #4
Resource id #4 has 1 records

参见 pg_query()，pg_cancel_query()，pg_get_result() 和 pg_connection_busy()。


设定客户端编码

  • ? pg_send_query
  • pg_set_error_verbosity ?
  • PHP Manual
  • PostgreSQL 函数
  • 设定客户端编码

pg_set_client_encoding

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pg_set_client_encoding — 设定客户端编码

说明

pg_set_client_encoding ( resource $connection = ? , string $encoding ) : int

pg_set_client_encoding() 设定客户端编码方式，成功返回 0，出错返回 -1。

encoding 是客户端的编码方式，可以为：SQL_ASCII，EUC_JP，EUC_CN，EUC_KR，EUC_TW，UNICODE，MULE_INTERNAL，LATINX (X=1...9)，KOI8，WIN，ALT，SJIS，BIG5，WIN1250。可用的编码取决于 PostgreSQL 和 libpq 的版本。参考 PostgreSQL 手册查看你的 PostgreSQL 所支持的编码方式。

Note:

本函数需要 PHP 4.0.3 或以上版本以及 PostgreSQL 7.0 或以上版本。所支持的编码方式取决于 PostgreSQL 的版本，详情参考 PostgreSQL 手册。

本函数以前的名字为 pg_setclientencoding()。

参见 pg_client_encoding()。


Determines the verbosity of messages returned by pg_last_error and pg_result_error

  • ? pg_set_client_encoding
  • pg_socket ?
  • PHP Manual
  • PostgreSQL 函数
  • Determines the verbosity of messages returned by pg_last_error and pg_result_error

pg_set_error_verbosity

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error() and pg_result_error()

说明

pg_set_error_verbosity ( resource $connection = ? , int $verbosity ) : int

Determines the verbosity of messages returned by pg_last_error() and pg_result_error().

pg_set_error_verbosity() sets the verbosity mode, returning the connection's previous setting. In PGSQL_ERRORS_TERSE mode, returned messages include severity, primary text, and position only; this will normally fit on a single line. The default mode (PGSQL_ERRORS_DEFAULT) produces messages that include the above plus any detail, hint, or context fields (these may span multiple lines). The PGSQL_ERRORS_VERBOSE mode includes all available fields. Changing the verbosity does not affect the messages available from already-existing result objects, only subsequently-created ones.

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

verbosity

The required verbosity: PGSQL_ERRORS_TERSE, PGSQL_ERRORS_DEFAULT or PGSQL_ERRORS_VERBOSE.

返回值

The previous verbosity level: PGSQL_ERRORS_TERSE, PGSQL_ERRORS_DEFAULT or PGSQL_ERRORS_VERBOSE.

范例

Example #1 pg_set_error_verbosity() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  pg_set_error_verbosity($dbconn, PGSQL_ERRORS_VERBOSE);
  $res1 = pg_get_result($dbconn);
  echo pg_result_error($res1);
?>

参见

  • pg_last_error() - 得到某连接的最后一条错误信息
  • pg_result_error() - 获得查询结果的错误信息


Get a read only handle to the socket underlying a PostgreSQL connection

  • ? pg_set_error_verbosity
  • pg_trace ?
  • PHP Manual
  • PostgreSQL 函数
  • Get a read only handle to the socket underlying a PostgreSQL connection

pg_socket

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

pg_socket — Get a read only handle to the socket underlying a PostgreSQL connection

说明

pg_socket ( resource $connection ) : resource|false

pg_socket() returns a read only resource corresponding to the socket underlying the given PostgreSQL connection.

Warning

本函数还未编写文档，仅有参数列表。

参数

connection

PostgreSQL database connection resource.

返回值

A socket resource on success 或者在失败时返回 false.


启动一个 PostgreSQL 连接的追踪功能

  • ? pg_socket
  • pg_transaction_status ?
  • PHP Manual
  • PostgreSQL 函数
  • 启动一个 PostgreSQL 连接的追踪功能

pg_trace

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

pg_trace — 启动一个 PostgreSQL 连接的追踪功能

说明

pg_trace ( string $pathname , string $mode = ? , resource $connection = ? ) : bool

pg_trace() 启动 PostgreSQL 前端／后端通讯的追踪并记录到 pathname 指定的文件中。要完全理解结果，用户需要熟悉 PostgreSQL 通讯协议的本质。对不熟悉的用户来说，追踪发送到服务器的查询错误依然有用，例如可以用 grep '^To backend' trace.log 来查看哪些查询实际上被发送到了 PostgreSQL 服务器。更多信息参考 PostgreSQL 手册。

参数 pathname 和 mode 和 fopen()(mode 默认为 'w') 中的一样。connection 指定了要追踪的连接，默认为上一个打开的连接。

如果 pathname 可以作为日志文件打开，则 pg_trace() 返回 true，否则返回 false。

参见 fopen() 和 pg_untrace()。


Returns the current in-transaction status of the server

  • ? pg_trace
  • pg_tty ?
  • PHP Manual
  • PostgreSQL 函数
  • Returns the current in-transaction status of the server

pg_transaction_status

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

pg_transaction_status — Returns the current in-transaction status of the server

说明

pg_transaction_status ( resource $connection ) : int

Returns the current in-transaction status of the server.

Caution

pg_transaction_status() will give incorrect results when using a PostgreSQL 7.3 server that has the parameter autocommit set to off. The server-side autocommit feature has been deprecated and does not exist in later server versions.

参数

connection

PostgreSQL database connection resource.

返回值

The status can be PGSQL_TRANSACTION_IDLE (currently idle), PGSQL_TRANSACTION_ACTIVE (a command is in progress), PGSQL_TRANSACTION_INTRANS (idle, in a valid transaction block), or PGSQL_TRANSACTION_INERROR (idle, in a failed transaction block). PGSQL_TRANSACTION_UNKNOWN is reported if the connection is bad. PGSQL_TRANSACTION_ACTIVE is reported only when a query has been sent to the server and not yet completed.

范例

Example #1 pg_transaction_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $stat = pg_transaction_status($dbconn);
  if ($stat === PGSQL_TRANSACTION_UNKNOWN) {
      echo 'Connection is bad';
  } else if ($stat === PGSQL_TRANSACTION_IDLE) {
      echo 'Connection is currently idle';
  } else {
      echo 'Connection is in a transaction state';
  }
?>


返回该连接的 tty 号

  • ? pg_transaction_status
  • pg_unescape_bytea ?
  • PHP Manual
  • PostgreSQL 函数
  • 返回该连接的 tty 号

pg_tty

(PHP 4, PHP 5, PHP 7, PHP 8)

pg_tty — 返回该连接的 tty 号

说明

pg_tty ( resource $connection ) : string

pg_tty() 返回指定 PostgreSQL connection 资源在服务器端输出调试信息的 tty 号。


取消 bytea 类型中的字符串转义

  • ? pg_tty
  • pg_untrace ?
  • PHP Manual
  • PostgreSQL 函数
  • 取消 bytea 类型中的字符串转义

pg_unescape_bytea

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_unescape_bytea — 取消 bytea 类型中的字符串转义

说明

pg_unescape_bytea ( string $data ) : string

pg_unescape_bytea() 将 bytea 数据类型中的字符串取消转义。返回未转义的字符串（二进制）。

Note:

当 SELECT bytea 类型，PostgreSQL 返回用 \ 前导的八进制字节值（例如 \032）。用户需要自行将其转换回二进制格式。

本函数需要 PostgreSQL 7.2 或更新版本。在 PostgreSQL 7.2.0 和 7.2.1 中，当激活了多字节支持时必须强制转换为 bytea 类型，例如 INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea);。PostgreSQL 7.2.2 或更新版本不需要强制转换。例外是当客户端和后端的字符编码不匹配时，有可能出现多字节流错误。用户必须强制转换为 bytea 来避免此错误。

参见 pg_escape_bytea() 和 pg_escape_string()。


关闭 PostgreSQL 连接的追踪功能

  • ? pg_unescape_bytea
  • pg_update ?
  • PHP Manual
  • PostgreSQL 函数
  • 关闭 PostgreSQL 连接的追踪功能

pg_untrace

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

pg_untrace — 关闭 PostgreSQL 连接的追踪功能

说明

pg_untrace ( resource $connection = ? ) : bool

停止由 pg_trace() 启动的追踪功能。connection 指定了被追踪的连接号，默认为上一个打开的连接。

本函数总是返回 true。

参见 pg_trace()。


更新表

  • ? pg_untrace
  • pg_version ?
  • PHP Manual
  • PostgreSQL 函数
  • 更新表

pg_update

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pg_update — 更新表

说明

pg_update ( resource $connection , string $table_name , array $data , array $condition , int $options = PGSQL_DML_EXEC ) : mixed

pg_update() 用 condition 作为条件查询数据库，用 data 中的数据更新符合条件的记录。如果指定了 options，则 pg_convert() 会按照指定选项作用到 data 上。

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to update rows.

data

An array whose keys are field names in the table table_name, and whose values are what matched rows are to be updated to.

condition

An array whose keys are field names in the table table_name, and whose values are the conditions that a row must meet to be updated.

options

Any number of PGSQL_CONV_OPTS, PGSQL_DML_NO_CONV, PGSQL_DML_EXEC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned.

返回值

成功时返回 true， 或者在失败时返回 false。 Returns string if PGSQL_DML_STRING is passed via options.

范例

Example #1 pg_update() example

<?php
  $db = pg_connect('dbname=foo');
  $data = array('field1'=>'AA', 'field2'=>'BB');

  // This is safe, since $_POST is converted automatically
  $res = pg_update($db, 'post_log', $_POST, $data);
  if ($res) {
      echo "Data is updated: $res\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

参见

  • pg_convert() - 将关联的数组值转换为适合 SQL 语句的格式。


Returns an array with client, protocol and server version (when available)

  • ? pg_update
  • SQLite3 ?
  • PHP Manual
  • PostgreSQL 函数
  • Returns an array with client, protocol and server version (when available)

pg_version

(PHP 5, PHP 7, PHP 8)

pg_version — Returns an array with client, protocol and server version (when available)

说明

pg_version ( resource $connection = ? ) : array

pg_version() returns an array with the client, protocol and server version. Protocol and server versions are only available if PHP was compiled with PostgreSQL 7.4 or later.

For more detailed server information, use pg_parameter_status().

参数

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

返回值

Returns an array with client, protocol and server keys and values (if available). Returns false on error or invalid connection.

范例

Example #1 pg_version() example

<?php
  $dbconn = pg_connect("host=localhost port=5432 dbname=mary")
     or die("Could not connect");

  $v = pg_version($dbconn);

  echo $v['client'];
?>

以上例程会输出：

7.4

参见

  • pg_parameter_status() - Looks up a current parameter setting of the server


SQLite3

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • SQLite3 — SQLite3 类
    • SQLite3::backup — Backup one database to another database
    • SQLite3::busyTimeout — Sets the busy connection handler
    • SQLite3::changes — Returns the number of database rows that were changed (or inserted or deleted) by the most recent SQL statement
    • SQLite3::close — Closes the database connection
    • SQLite3::__construct — Instantiates an SQLite3 object and opens an SQLite 3 database
    • SQLite3::createAggregate — Registers a PHP function for use as an SQL aggregate function
    • SQLite3::createCollation — Registers a PHP function for use as an SQL collating function
    • SQLite3::createFunction — Registers a PHP function for use as an SQL scalar function
    • SQLite3::enableExceptions — Enable throwing exceptions
    • SQLite3::escapeString — Returns a string that has been properly escaped
    • SQLite3::exec — Executes a result-less query against a given database
    • SQLite3::lastErrorCode — Returns the numeric result code of the most recent failed SQLite request
    • SQLite3::lastErrorMsg — Returns English text describing the most recent failed SQLite request
    • SQLite3::lastInsertRowID — Returns the row ID of the most recent INSERT into the database
    • SQLite3::loadExtension — Attempts to load an SQLite extension library
    • SQLite3::open — Opens an SQLite database
    • SQLite3::openBlob — Opens a stream resource to read a BLOB
    • SQLite3::prepare — Prepares an SQL statement for execution
    • SQLite3::query — Executes an SQL query
    • SQLite3::querySingle — Executes a query and returns a single result
    • SQLite3::setAuthorizer — Configures a callback to be used as an authorizer to limit what a statement can do
    • SQLite3::version — Returns the SQLite3 library version as a string constant and as a number
  • SQLite3Stmt — SQLite3Stmt 类
    • SQLite3Stmt::bindParam — Binds a parameter to a statement variable
    • SQLite3Stmt::bindValue — Binds the value of a parameter to a statement variable
    • SQLite3Stmt::clear — Clears all current bound parameters
    • SQLite3Stmt::close — Closes the prepared statement
    • SQLite3Stmt::execute — Executes a prepared statement and returns a result set object
    • SQLite3Stmt::getSQL — Get the SQL of the statement
    • SQLite3Stmt::paramCount — Returns the number of parameters within the prepared statement
    • SQLite3Stmt::readOnly — Returns whether a statement is definitely read only
    • SQLite3Stmt::reset — Resets the prepared statement
  • SQLite3Result — SQLite3Result 类
    • SQLite3Result::columnName — Returns the name of the nth column
    • SQLite3Result::columnType — Returns the type of the nth column
    • SQLite3Result::fetchArray — Fetches a result row as an associative or numerically indexed array or both
    • SQLite3Result::finalize — Closes the result set
    • SQLite3Result::numColumns — Returns the number of columns in the result set
    • SQLite3Result::reset — Resets the result set back to the first row


  • ? SQLite3
  • 安装／配置 ?
  • PHP Manual
  • SQLite3
  • 简介

简介

对 SQLite v3 数据库的支持信息。


安装

SQLite3 扩展自 PHP 5.3.0 起已默认启用。 允许在编译时使用 --without-sqlite3 禁用之。

Windows 用户必须启用 php_sqlite3.dll 方可使用该扩展。自 PHP 5.3.0 起，此扩展的 DLL 文件 已包含于 Windows 版的 PHP 发行包中。

Note:

该扩展是 PECL 扩展的简化版本， 但后者仅建议用于实验性用途。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

SQLite3 配置选项
名字 | 默认 | 可修改范围 | 更新日志
sqlite3.extension_dir | "" | PHP_INI_SYSTEM | PHP 5.3.11 起可用
sqlite3.defensive | 1 | PHP_INI_SYSTEM | PHP 7.2.17 和 7.3.4 起可用，libsqlite ≥ 3.26.0。

这是配置指令的简短说明。

sqlite3.extension_dir string

Path to the directory where the loadable extensions for SQLite reside.

sqlite3.defensive bool

When the defensive flag is enabled, language features that allow ordinary SQL to deliberately corrupt the database file are disabled. This forbids writing directly to the schema, shadow tables (eg. FTS data tables), or the sqlite_dbpage virtual table. This php.ini setting is only effective for libsqlite ≥ 3.26.0.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SQLITE3_ASSOC (integer)
指定 Sqlite3Result::fetchArray() 方法返回按列名称索引的数组，其中列名即相应结果集返回的列名。
SQLITE3_NUM (integer)
指定 Sqlite3Result::fetchArray() 方法返回按列序号索引的数组，其中列号即相应结果集返回的列号，从第 0 列开始计数。
SQLITE3_BOTH (integer)
指定 Sqlite3Result::fetchArray() 方法返回同时按列名称与列序号索引的数组，其中列名即相应结果集返回的列名，列号即相应结果集返回的列号，从第 0 列开始计数。
SQLITE3_INTEGER (integer)
表示 SQLite3 INTEGER (整型) 存储类。
SQLITE3_FLOAT (integer)
表示 SQLite3 REAL (FLOAT) (实型) 存储类。
SQLITE3_TEXT (integer)
表示 SQLite3 TEXT (文本) 存储类。
SQLITE3_BLOB (integer)
表示 SQLite3 BLOB (二进制对象) 存储类。
SQLITE3_NULL (integer)
表示 SQLite3 NULL 存储类。
SQLITE3_OPEN_READONLY (integer)
指定 SQLite3 数据库以只读模式打开。
SQLITE3_OPEN_READWRITE (integer)
指定 SQLite3 数据库以读写模式打开。
SQLITE3_OPEN_CREATE (integer)
指定 SQLite3 数据库若不存在，则创建并打开。


SQLite3 类

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

简介

实现与 SQLite 3 数据库对接的类。

类摘要

SQLite3 {
/* 方法 */
public backup ( SQLite3 $destination , string $sourceDatabase = "main" , string $destinationDatabase = "main" ) : bool
public busyTimeout ( int $milliseconds ) : bool
public changes ( ) : int
public close ( ) : bool
public createAggregate ( string $name , callable $stepCallback , callable $finalCallback , int $argCount = -1 ) : bool
public createCollation ( string $name , callable $callback ) : bool
public createFunction ( string $name , callable $callback , int $argCount = -1 , int $flags = 0 ) : bool
public enableExceptions ( bool $enable = false ) : bool
public static escapeString ( string $string ) : string
public exec ( string $query ) : bool
public lastErrorCode ( ) : int
public lastErrorMsg ( ) : string
public lastInsertRowID ( ) : int
public loadExtension ( string $name ) : bool
public open ( string $filename , int $flags = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE , string $encryptionKey = "" ) : void
public openBlob ( string $table , string $column , int $rowid , string $database = "main" , int $flags = SQLITE3_OPEN_READONLY ) : resource|false
public prepare ( string $query ) : SQLite3Stmt|false
public query ( string $query ) : SQLite3Result|false
public querySingle ( string $query , bool $entireRow = false ) : mixed
public setAuthorizer ( callable|null $callback ) : bool
public static version ( ) : array
}

Table of Contents

  • SQLite3::backup — Backup one database to another database
  • SQLite3::busyTimeout — Sets the busy connection handler
  • SQLite3::changes — Returns the number of database rows that were changed (or inserted or deleted) by the most recent SQL statement
  • SQLite3::close — Closes the database connection
  • SQLite3::__construct — Instantiates an SQLite3 object and opens an SQLite 3 database
  • SQLite3::createAggregate — Registers a PHP function for use as an SQL aggregate function
  • SQLite3::createCollation — Registers a PHP function for use as an SQL collating function
  • SQLite3::createFunction — Registers a PHP function for use as an SQL scalar function
  • SQLite3::enableExceptions — Enable throwing exceptions
  • SQLite3::escapeString — Returns a string that has been properly escaped
  • SQLite3::exec — Executes a result-less query against a given database
  • SQLite3::lastErrorCode — Returns the numeric result code of the most recent failed SQLite request
  • SQLite3::lastErrorMsg — Returns English text describing the most recent failed SQLite request
  • SQLite3::lastInsertRowID — Returns the row ID of the most recent INSERT into the database
  • SQLite3::loadExtension — Attempts to load an SQLite extension library
  • SQLite3::open — Opens an SQLite database
  • SQLite3::openBlob — Opens a stream resource to read a BLOB
  • SQLite3::prepare — Prepares an SQL statement for execution
  • SQLite3::query — Executes an SQL query
  • SQLite3::querySingle — Executes a query and returns a single result
  • SQLite3::setAuthorizer — Configures a callback to be used as an authorizer to limit what a statement can do
  • SQLite3::version — Returns the SQLite3 library version as a string constant and as a number


Backup one database to another database

  • ? SQLite3
  • SQLite3::busyTimeout ?
  • PHP Manual
  • SQLite3
  • Backup one database to another database

SQLite3::backup

(PHP 7 >= 7.4.0, PHP 8)

SQLite3::backup — Backup one database to another database

说明

public SQLite3::backup ( SQLite3 $destination , string $sourceDatabase = "main" , string $destinationDatabase = "main" ) : bool

SQLite3::backup() copies the contents of one database into another, overwriting the contents of the destination database. It is useful either for creating backups of databases or for copying in-memory databases to or from persistent files.

参数

destination

A database connection opened with SQLite3::open().

sourceDatabase

The database name is "main" for the main database, "temp" for the temporary database, or the name specified after the AS keyword in an ATTACH statement for an attached database.

destinationDatabase

Analogous to sourceDatabase but for the destination.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Backup an existing database

<?php
// $conn is a connection to an already opened sqlite3 database

$backup = new SQLite3('backup.sqlite');
$conn->backup($backup);
?>


Sets the busy connection handler

  • ? SQLite3::backup
  • SQLite3::changes ?
  • PHP Manual
  • SQLite3
  • Sets the busy connection handler

SQLite3::busyTimeout

(PHP 5 >= 5.3.3, PHP 7, PHP 8)

SQLite3::busyTimeout — Sets the busy connection handler

说明

public SQLite3::busyTimeout ( int $milliseconds ) : bool

Sets a busy handler that will sleep until the database is not locked or the timeout is reached.

参数

milliseconds

The milliseconds to sleep. Setting this value to a value less than or equal to zero, will turn off an already set timeout handler.

返回值

Returns true on success, 或者在失败时返回 false.


Returns the number of database rows that were changed (or inserted or deleted) by the most recent SQL statement

  • ? SQLite3::busyTimeout
  • SQLite3::close ?
  • PHP Manual
  • SQLite3
  • Returns the number of database rows that were changed (or inserted or deleted) by the most recent SQL statement

SQLite3::changes

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::changes — Returns the number of database rows that were changed (or inserted or deleted) by the most recent SQL statement

说明

public SQLite3::changes ( ) : int

Returns the number of database rows that were changed (or inserted or deleted) by the most recent SQL statement.

参数

此函数没有参数。

返回值

Returns an int value corresponding to the number of database rows changed (or inserted or deleted) by the most recent SQL statement.

范例

Example #1 SQLite3::changes() example

<?php
$db = new SQLite3('mysqlitedb.db');

$query = $db->exec('UPDATE counter SET views=0 WHERE page="test"');
if ($query) {
    echo 'Number of rows modified: ', $db->changes();
}
?>


Closes the database connection

  • ? SQLite3::changes
  • SQLite3::__construct ?
  • PHP Manual
  • SQLite3
  • Closes the database connection

SQLite3::close

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::close — Closes the database connection

说明

public SQLite3::close ( ) : bool

Closes the database connection.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SQLite3::close() example

<?php
$db = new SQLite3('mysqlitedb.db');
$db->close();
?>


Instantiates an SQLite3 object and opens an SQLite 3 database

  • ? SQLite3::close
  • SQLite3::createAggregate ?
  • PHP Manual
  • SQLite3
  • Instantiates an SQLite3 object and opens an SQLite 3 database

SQLite3::__construct

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::__construct — Instantiates an SQLite3 object and opens an SQLite 3 database

说明

public SQLite3::__construct ( string $filename , int $flags = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE , string $encryptionKey = "" )

Instantiates an SQLite3 object and opens a connection to an SQLite 3 database. If the build includes encryption, then it will attempt to use the key.

参数

filename

Path to the SQLite database, or :memory: to use in-memory database. If filename is an empty string, then a private, temporary on-disk database will be created. This private database will be automatically deleted as soon as the database connection is closed.

flags

Optional flags used to determine how to open the SQLite database. By default, open uses SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE.

  • SQLITE3_OPEN_READONLY: Open the database for reading only.

  • SQLITE3_OPEN_READWRITE: Open the database for reading and writing.

  • SQLITE3_OPEN_CREATE: Create the database if it does not exist.

encryptionKey

An optional encryption key used when encrypting and decrypting an SQLite database. If the SQLite encryption module is not installed, this parameter will have no effect.

返回值

Returns an SQLite3 object on success.

错误／异常

Throws an Exception on failure.

更新日志

版本 | 说明
7.0.10 | The filename can now be empty to use a private, temporary on-disk database.

范例

Example #1 SQLite3::__construct() example

<?php
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE foo (bar TEXT)');
$db->exec("INSERT INTO foo (bar) VALUES ('This is a test')");

$result = $db->query('SELECT bar FROM foo');
var_dump($result->fetchArray());
?>


Registers a PHP function for use as an SQL aggregate function

  • ? SQLite3::__construct
  • SQLite3::createCollation ?
  • PHP Manual
  • SQLite3
  • Registers a PHP function for use as an SQL aggregate function

SQLite3::createAggregate

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::createAggregate — Registers a PHP function for use as an SQL aggregate function

说明

public SQLite3::createAggregate ( string $name , callable $stepCallback , callable $finalCallback , int $argCount = -1 ) : bool

Registers a PHP function or user-defined function for use as an SQL aggregate function for use within SQL statements.

参数

name

Name of the SQL aggregate to be created or redefined.

stepCallback

Callback function called for each row of the result set. Your PHP function should accumulate the result and store it in the aggregation context.

This function need to be defined as:

step ( mixed $context , int $rownumber , mixed $value , mixed ...$values ) : mixed
context

null for the first row; on subsequent rows it will have the value that was previously returned from the step function; you should use this to maintain the aggregate state.

rownumber

The current row number.

value

The first argument passed to the aggregate.

values

Further arguments passed to the aggregate.

The return value of this function will be used as the context argument in the next call of the step or finalize functions.

finalCallback

Callback function to aggregate the "stepped" data from each row. Once all the rows have been processed, this function will be called and it should then take the data from the aggregation context and return the result. This callback function should return a type understood by SQLite (i.e. scalar type).

This function need to be defined as:

fini ( mixed $context , int $rownumber ) : mixed
context

Holds the return value from the very last call to the step function.

rownumber

Always 0.

The return value of this function will be used as the return value for the aggregate.

argCount

The number of arguments that the SQL aggregate takes. If this parameter is negative, then the SQL aggregate may take any number of arguments.

返回值

Returns true upon successful creation of the aggregate, 或者在失败时返回 false.

范例

Example #1 max_length aggregation function example

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$db = new SQLite3(':memory:');
$db->exec("CREATE TABLE strings(a)");
$insert = $db->prepare('INSERT INTO strings VALUES (?)');
foreach ($data as $str) {
    $insert->bindValue(1, $str);
    $insert->execute();
}
$insert = null;

function max_len_step($context, $rownumber, $string)
{
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
    return $context;
}

function max_len_finalize($context, $rownumber)
{
    return $context === null ? 0 : $context;
}

$db->createAggregate('max_len', 'max_len_step', 'max_len_finalize');

var_dump($db->querySingle('SELECT max_len(a) from strings'));
?>

以上例程会输出：

int(5)

In this example, we are creating an aggregating function that will calculate the length of the longest string in one of the columns of the table. For each row, the max_len_step function is called and passed a $context parameter. The context parameter is just like any other PHP variable and be set to hold an array or even an object value. In this example, we are simply using it to hold the maximum length we have seen so far; if the $string has a length longer than the current maximum, we update the context to hold this new maximum length.

After all of the rows have been processed, SQLite calls the max_len_finalize function to determine the aggregate result. Here, we could perform some kind of calculation based on the data found in the $context. In our simple example though, we have been calculating the result as the query progressed, so we simply need to return the context value.

Tip

It is NOT recommended for you to store a copy of the values in the context and then process them at the end, as you would cause SQLite to use a lot of memory to process the query - just think of how much memory you would need if a million rows were stored in memory, each containing a string 32 bytes in length.

Tip

You can use SQLite3::createAggregate() to override SQLite native SQL functions.


Registers a PHP function for use as an SQL collating function

  • ? SQLite3::createAggregate
  • SQLite3::createFunction ?
  • PHP Manual
  • SQLite3
  • Registers a PHP function for use as an SQL collating function

SQLite3::createCollation

(PHP 5 >= 5.3.11, PHP 7, PHP 8)

SQLite3::createCollation — Registers a PHP function for use as an SQL collating function

说明

public SQLite3::createCollation ( string $name , callable $callback ) : bool

Registers a PHP function or user-defined function for use as a collating function within SQL statements.

参数

name

Name of the SQL collating function to be created or redefined

callback

The name of a PHP function or user-defined function to apply as a callback, defining the behavior of the collation. It should accept two values and return as strcmp() does, i.e. it should return -1, 1, or 0 if the first string sorts before, sorts after, or is equal to the second.

This function need to be defined as:

collation ( mixed $value1 , mixed $value2 ) : int

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SQLite3::createCollation() example

Register the PHP function strnatcmp() as a collating sequence in the SQLite3 database.

<?php

$db = new SQLite3(":memory:");
$db->exec("CREATE TABLE test (col1 string)");
$db->exec("INSERT INTO test VALUES ('a1')");
$db->exec("INSERT INTO test VALUES ('a10')");
$db->exec("INSERT INTO test VALUES ('a2')");

$db->createCollation('NATURAL_CMP', 'strnatcmp');

$defaultSort = $db->query("SELECT col1 FROM test ORDER BY col1");
$naturalSort = $db->query("SELECT col1 FROM test ORDER BY col1 COLLATE NATURAL_CMP");

echo "default:\n";
while ($row = $defaultSort->fetchArray()){
    echo $row['col1'], "\n";
}

echo "\nnatural:\n";
while ($row = $naturalSort->fetchArray()){
    echo $row['col1'], "\n";
}

$db->close();

?>

以上例程会输出：

default:
a1
a10
a2

natural:
a1
a2
a10

参见

  • The SQLite collation documentation: » http://sqlite.org/datatype3.html#collation


Registers a PHP function for use as an SQL scalar function

  • ? SQLite3::createCollation
  • SQLite3::enableExceptions ?
  • PHP Manual
  • SQLite3
  • Registers a PHP function for use as an SQL scalar function

SQLite3::createFunction

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::createFunction — Registers a PHP function for use as an SQL scalar function

说明

public SQLite3::createFunction ( string $name , callable $callback , int $argCount = -1 , int $flags = 0 ) : bool

Registers a PHP function or user-defined function for use as an SQL scalar function for use within SQL statements.

参数

name

Name of the SQL function to be created or redefined.

callback

The name of a PHP function or user-defined function to apply as a callback, defining the behavior of the SQL function.

This function need to be defined as:

callback ( mixed $value , mixed ...$values ) : mixed
value

The first argument passed to the SQL function.

values

Further arguments passed to the SQL function.

argCount

The number of arguments that the SQL function takes. If this parameter is -1, then the SQL function may take any number of arguments.

flags

A bitwise conjunction of flags. Currently, only SQLITE3_DETERMINISTIC is supported, which specifies that the function always returns the same result given the same inputs within a single SQL statement.

返回值

Returns true upon successful creation of the function, false on failure.

更新日志

版本 | 说明
7.1.4 | The flags parameter has been added.

范例

Example #1 SQLite3::createFunction() example

<?php
function my_udf_md5($string) {
    return md5($string);
}

$db = new SQLite3('mysqlitedb.db');
$db->createFunction('my_udf_md5', 'my_udf_md5');

var_dump($db->querySingle('SELECT my_udf_md5("test")'));
?>

以上例程的输出类似于：

string(32) "098f6bcd4621d373cade4e832627b4f6"


Enable throwing exceptions

  • ? SQLite3::createFunction
  • SQLite3::escapeString ?
  • PHP Manual
  • SQLite3
  • Enable throwing exceptions

SQLite3::enableExceptions

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::enableExceptions — Enable throwing exceptions

说明

public SQLite3::enableExceptions ( bool $enable = false ) : bool

Controls whether the SQLite3 instance will throw exceptions or warnings on error.

参数

enable

When true, the SQLite3 instance, and SQLite3Stmt and SQLite3Result instances derived from it, will throw exceptions on error.

When false, the SQLite3 instance, and SQLite3Stmt and SQLite3Result instances derived from it, will raise warnings on error.

For either mode, the error code and message, if any, will be available via SQLite3::lastErrorCode() and SQLite3::lastErrorMsg() respectively.

返回值

Returns the old value; true if exceptions were enabled, false otherwise.

范例

Example #1 SQLite3::enableExceptions() example

<?php
$sqlite = new SQLite3(':memory:');
try {
    $sqlite->exec('create table foo');
    $sqlite->enableExceptions(true);
    $sqlite->exec('create table bar');
} catch (Exception $e) {
    echo 'Caught exception: ' . $e->getMessage();
}
?>

以上例程的输出类似于：

Warning: SQLite3::exec(): near "foo": syntax error in example.php on line 4
Caught exception: near "bar": syntax error


Returns a string that has been properly escaped

  • ? SQLite3::enableExceptions
  • SQLite3::exec ?
  • PHP Manual
  • SQLite3
  • Returns a string that has been properly escaped

SQLite3::escapeString

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::escapeString — Returns a string that has been properly escaped

说明

public static SQLite3::escapeString ( string $string ) : string

Returns a string that has been properly escaped for safe inclusion in an SQL statement.

Warning

此函数（还）不能安全地适用于二进制对象！

To properly handle BLOB fields which may contain NUL characters, use SQLite3Stmt::bindParam() instead.

参数

string

The string to be escaped.

返回值

Returns a properly escaped string that may be used safely in an SQL statement.

注释

Warning

addslashes() should NOT be used to quote your strings for SQLite queries; it will lead to strange results when retrieving your data.


Executes a result-less query against a given database

  • ? SQLite3::escapeString
  • SQLite3::lastErrorCode ?
  • PHP Manual
  • SQLite3
  • Executes a result-less query against a given database

SQLite3::exec

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::exec — Executes a result-less query against a given database

说明

public SQLite3::exec ( string $query ) : bool

Executes a result-less query against a given database.

Note: SQLite3 may need to create » temporary files during the execution of queries, so the respective directories may have to be writable.

参数

query

The SQL query to execute (typically an INSERT, UPDATE, or DELETE query).

返回值

Returns true if the query succeeded, false on failure.

范例

Example #1 SQLite3::exec() example

<?php
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE bar (bar STRING)');
?>


Returns the numeric result code of the most recent failed SQLite request

  • ? SQLite3::exec
  • SQLite3::lastErrorMsg ?
  • PHP Manual
  • SQLite3
  • Returns the numeric result code of the most recent failed SQLite request

SQLite3::lastErrorCode

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::lastErrorCode — Returns the numeric result code of the most recent failed SQLite request

说明

public SQLite3::lastErrorCode ( ) : int

Returns the numeric result code of the most recent failed SQLite request.

参数

此函数没有参数。

返回值

Returns an integer value representing the numeric result code of the most recent failed SQLite request.


Returns English text describing the most recent failed SQLite request

  • ? SQLite3::lastErrorCode
  • SQLite3::lastInsertRowID ?
  • PHP Manual
  • SQLite3
  • Returns English text describing the most recent failed SQLite request

SQLite3::lastErrorMsg

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::lastErrorMsg — Returns English text describing the most recent failed SQLite request

说明

public SQLite3::lastErrorMsg ( ) : string

Returns English text describing the most recent failed SQLite request.

参数

此函数没有参数。

返回值

Returns an English string describing the most recent failed SQLite request.


Returns the row ID of the most recent INSERT into the database

  • ? SQLite3::lastErrorMsg
  • SQLite3::loadExtension ?
  • PHP Manual
  • SQLite3
  • Returns the row ID of the most recent INSERT into the database

SQLite3::lastInsertRowID

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::lastInsertRowID — Returns the row ID of the most recent INSERT into the database

说明

public SQLite3::lastInsertRowID ( ) : int

Returns the row ID of the most recent INSERT into the database.

参数

此函数没有参数。

返回值

Returns the row ID of the most recent INSERT into the database


Attempts to load an SQLite extension library

  • ? SQLite3::lastInsertRowID
  • SQLite3::open ?
  • PHP Manual
  • SQLite3
  • Attempts to load an SQLite extension library

SQLite3::loadExtension

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::loadExtension — Attempts to load an SQLite extension library

说明

public SQLite3::loadExtension ( string $name ) : bool

Attempts to load an SQLite extension library.

参数

name

The name of the library to load. The library must be located in the directory specified in the configure option sqlite3.extension_dir.

返回值

Returns true if the extension is successfully loaded, false on failure.

范例

Example #1 SQLite3::loadExtension() example

<?php
$db = new SQLite3('mysqlitedb.db');
$db->loadExtension('libagg.so');
?>


Opens an SQLite database

  • ? SQLite3::loadExtension
  • SQLite3::openBlob ?
  • PHP Manual
  • SQLite3
  • Opens an SQLite database

SQLite3::open

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::open — Opens an SQLite database

说明

public SQLite3::open ( string $filename , int $flags = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE , string $encryptionKey = "" ) : void

Opens an SQLite 3 Database. If the build includes encryption, then it will attempt to use the key.

参数

filename

Path to the SQLite database, or :memory: to use in-memory database.

flags

Optional flags used to determine how to open the SQLite database. By default, open uses SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE.

  • SQLITE3_OPEN_READONLY: Open the database for reading only.

  • SQLITE3_OPEN_READWRITE: Open the database for reading and writing.

  • SQLITE3_OPEN_CREATE: Create the database if it does not exist.

encryptionKey

An optional encryption key used when encrypting and decrypting an SQLite database. If the SQLite encryption module is not installed, this parameter will have no effect.

返回值

没有返回值。

范例

Example #1 SQLite3::open() example

<?php
/**
 * Simple example of extending the SQLite3 class and changing the __construct
 * parameters, then using the open method to initialize the DB.
 */
class MyDB extends SQLite3
{
    function __construct()
    {
        $this->open('mysqlitedb.db');
    }
}

$db = new MyDB();

$db->exec('CREATE TABLE foo (bar STRING)');
$db->exec("INSERT INTO foo (bar) VALUES ('This is a test')");

$result = $db->query('SELECT bar FROM foo');
var_dump($result->fetchArray());
?>


Opens a stream resource to read a BLOB

  • ? SQLite3::open
  • SQLite3::prepare ?
  • PHP Manual
  • SQLite3
  • Opens a stream resource to read a BLOB

SQLite3::openBlob

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::openBlob — Opens a stream resource to read a BLOB

说明

public SQLite3::openBlob ( string $table , string $column , int $rowid , string $database = "main" , int $flags = SQLITE3_OPEN_READONLY ) : resource|false

Opens a stream resource to read or write a BLOB, which would be selected by:

SELECT column FROM database.table WHERE rowid = rowid

Note: It is not possible to change the size of a BLOB by writing to the stream. Instead, an UPDATE statement has to be executed, possibly using SQLite's zeroblob() function to set the desired BLOB size.

参数

table

The table name.

column

The column name.

rowid

The row ID.

database

The symbolic name of the DB

flags

Either SQLITE3_OPEN_READONLY or SQLITE3_OPEN_READWRITE to open the stream for reading only, or for reading and writing, respectively.

返回值

Returns a stream resource, 或者在失败时返回 false.

更新日志

版本 | 说明
7.2.0 | The flags parameter has been added, allowing to write BLOBs; formerly only reading was supported.

范例

Example #1 SQLite3::openBlob() example

<?php
$conn = new SQLite3(':memory:');
$conn->exec('CREATE TABLE test (text text)');
$conn->exec("INSERT INTO test VALUES ('Lorem ipsum')");
$stream = $conn->openBlob('test', 'text', 1);
echo stream_get_contents($stream);
fclose($stream); // mandatory, otherwise the next line would fail
$conn->close();
?>

以上例程会输出：

Lorem ipsum

Example #2 Incrementally writing a BLOB

<?php
$conn = new SQLite3(':memory:');
$conn->exec('CREATE TABLE test (text text)');
$conn->exec("INSERT INTO test VALUES (zeroblob(36))");
$stream = $conn->openBlob('test', 'text', 1, 'main', SQLITE3_OPEN_READWRITE);
for ($i = 0; $i < 3; $i++) {
    fwrite($stream,  "Lorem ipsum\n");
}
fclose($stream);
echo $conn->querySingle("SELECT text FROM test");
$conn->close();
?>

以上例程会输出：

Lorem ipsum
Lorem ipsum
Lorem ipsum


Prepares an SQL statement for execution

  • ? SQLite3::openBlob
  • SQLite3::query ?
  • PHP Manual
  • SQLite3
  • Prepares an SQL statement for execution

SQLite3::prepare

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::prepare — Prepares an SQL statement for execution

说明

public SQLite3::prepare ( string $query ) : SQLite3Stmt|false

Prepares an SQL statement for execution and returns an SQLite3Stmt object.

参数

query

The SQL query to prepare.

返回值

Returns an SQLite3Stmt object on success 或者在失败时返回 false.

范例

Example #1 SQLite3::prepare() example

<?php
unlink('mysqlitedb.db');
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE foo (id INTEGER, bar STRING)');
$db->exec("INSERT INTO foo (id, bar) VALUES (1, 'This is a test')");

$stmt = $db->prepare('SELECT bar FROM foo WHERE id=:id');
$stmt->bindValue(':id', 1, SQLITE3_INTEGER);

$result = $stmt->execute();
var_dump($result->fetchArray());
?>

参见

  • SQLite3Stmt::paramCount() - Returns the number of parameters within the prepared statement
  • SQLite3Stmt::bindValue() - Binds the value of a parameter to a statement variable
  • SQLite3Stmt::bindParam() - Binds a parameter to a statement variable


Executes an SQL query

  • ? SQLite3::prepare
  • SQLite3::querySingle ?
  • PHP Manual
  • SQLite3
  • Executes an SQL query

SQLite3::query

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::query — Executes an SQL query

说明

public SQLite3::query ( string $query ) : SQLite3Result|false

Executes an SQL query, returning an SQLite3Result object. If the query does not yield a result (such as DML statements) the returned SQLite3Result object is not really usable. Use SQLite3::exec() for such queries instead.

参数

query

The SQL query to execute.

返回值

Returns an SQLite3Result object, 或者在失败时返回 false.

范例

Example #1 SQLite3::query() example

<?php
$db = new SQLite3('mysqlitedb.db');

$results = $db->query('SELECT bar FROM foo');
while ($row = $results->fetchArray()) {
    var_dump($row);
}
?>


Executes a query and returns a single result

  • ? SQLite3::query
  • SQLite3::setAuthorizer ?
  • PHP Manual
  • SQLite3
  • Executes a query and returns a single result

SQLite3::querySingle

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::querySingle — Executes a query and returns a single result

说明

public SQLite3::querySingle ( string $query , bool $entireRow = false ) : mixed

Executes a query and returns a single result.

参数

query

The SQL query to execute.

entireRow

By default, querySingle() returns the value of the first column returned by the query. If entireRow is true, then it returns an array of the entire first row.

返回值

Returns the value of the first column of results or an array of the entire first row (if entireRow is true).

If the query is valid but no results are returned, then null will be returned if entireRow is false, otherwise an empty array is returned.

Invalid or failing queries will return false.

范例

Example #1 SQLite3::querySingle() example

<?php
$db = new SQLite3('mysqlitedb.db');

var_dump($db->querySingle('SELECT username FROM user WHERE userid=1'));
print_r($db->querySingle('SELECT username, email FROM user WHERE userid=1', true));
?>

以上例程的输出类似于：

string(5) "Scott"
Array
(
    [username] => Scott
    [email] => scott@example.com
)


Configures a callback to be used as an authorizer to limit what a statement can do

  • ? SQLite3::querySingle
  • SQLite3::version ?
  • PHP Manual
  • SQLite3
  • Configures a callback to be used as an authorizer to limit what a statement can do

SQLite3::setAuthorizer

(PHP 8)

SQLite3::setAuthorizer — Configures a callback to be used as an authorizer to limit what a statement can do

说明

public SQLite3::setAuthorizer ( callable|null $callback ) : bool

Sets a callback that will be called by SQLite every time an action is performed (reading, deleting, updating, etc.). This is used when preparing a SQL statement from an untrusted source to ensure that the SQL statements do not try to access data they are not allowed to see, or that they do not try to execute malicious statements that damage the database. For example, an application may allow a user to enter arbitrary SQL queries for evaluation by a database. But the application does not want the user to be able to make arbitrary changes to the database. An authorizer could then be put in place while the user-entered SQL is being prepared that disallows everything except SELECT statements.

The authorizer callback may be called multiple times for each statement prepared by SQLite. A SELECT or UPDATE query will call the authorizer for every column that would be read or updated.

The authorizer is called with up to five parameters. The first parameter is always given, and is an int (action code) matching a constant from SQLite3. The other parameters are only passed for some actions. The following table describes the second and third parameters according to the action:

List of action codes and parameters
Action | Second parameter | Third parameter
SQLite3::CREATE_INDEX | Index Name | Table Name
SQLite3::CREATE_TABLE | Table Name | null
SQLite3::CREATE_TEMP_INDEX | Index Name | Table Name
SQLite3::CREATE_TEMP_TABLE | Table Name | null
SQLite3::CREATE_TEMP_TRIGGER | Trigger Name | Table Name
SQLite3::CREATE_TEMP_VIEW | View Name | null
SQLite3::CREATE_TRIGGER | Trigger Name | Table Name
SQLite3::CREATE_VIEW | View Name | null
SQLite3::DELETE | Table Name | null
SQLite3::DROP_INDEX | Index Name | Table Name
SQLite3::DROP_TABLE | Table Name | null
SQLite3::DROP_TEMP_INDEX | Index Name | Table Name
SQLite3::DROP_TEMP_TABLE | Table Name | null
SQLite3::DROP_TEMP_TRIGGER | Trigger Name | Table Name
SQLite3::DROP_TEMP_VIEW | View Name | null
SQLite3::DROP_TRIGGER | Trigger Name | Table Name
SQLite3::DROP_VIEW | View Name | null
SQLite3::INSERT | Table Name | null
SQLite3::PRAGMA | Pragma Name | First argument passed to the pragma, or null
SQLite3::READ | Table Name | Column Name
SQLite3::SELECT | null | null
SQLite3::TRANSACTION | Operation | null
SQLite3::UPDATE | Table Name | Column Name
SQLite3::ATTACH | Filename | null
SQLite3::DETACH | Database Name | null
SQLite3::ALTER_TABLE | Database Name | Table Name
SQLite3::REINDEX | Index Name | null
SQLite3::ANALYZE | Table Name | null
SQLite3::CREATE_VTABLE | Table Name | Module Name
SQLite3::DROP_VTABLE | Table Name | Module Name
SQLite3::FUNCTION | null | Function Name
SQLite3::SAVEPOINT | Operation | Savepoint Name
SQLite3::RECURSIVE | null | null

The 5th parameter will be the name of the database ("main", "temp", etc.) if applicable.

The 6th parameter to the authorizer callback is the name of the inner-most trigger or view that is responsible for the access attempt or null if this access attempt is directly from top-level SQL code.

When the callback returns SQLite3::OK, that means the operation requested is accepted. When the callback returns SQLite3::DENY, the call that triggered the authorizer will fail with an error message explaining that access is denied.

If the action code is SQLite3::READ and the callback returns SQLite3::IGNORE then the prepared statement statement is constructed to substitute a null value in place of the table column that would have been read if SQLite3::OK had been returned. The SQLite3::IGNORE return can be used to deny an untrusted user access to individual columns of a table.

When a table is referenced by a SELECT but no column values are extracted from that table (for example in a query like "SELECT count(*) FROM table") then the SQLite3::READ authorizer callback is invoked once for that table with a column name that is an empty string.

If the action code is SQLite3::DELETE and the callback returns SQLite3::IGNORE then the DELETE operation proceeds but the truncate optimization is disabled and all rows are deleted individually.

Only a single authorizer can be in place on a database connection at a time. Each call to SQLite3::setAuthorizer() overrides the previous call. Disable the authorizer by installing a null callback. The authorizer is disabled by default.

The authorizer callback must not do anything that will modify the database connection that invoked the authorizer callback.

Note that the authorizer is only called when a statement is prepared, not when it's executed.

More details can be found in the » SQLite3 documentation.

参数

callback

The callable to be called.

If null is passed instead, this will disable the current authorizer callback.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method doesn't throw any error, but if an authorizer is enabled and returns an invalid value, the statement preparation will throw an error (or exception, depending on the use of the SQLite3::enableExceptions() method).

范例

Example #1 SQLite3::setAuthorizer() example

This only allows access to reading, and only some columns of the users table will be returned. Other columns will be replaced with null.

<?php
$db = new SQLite3('data.sqlite');
$db->exec('CREATE TABLE users (id, name, password);');
$db->exec('INSERT INTO users VALUES (1, \'Pauline\', \'Snails4eva\');');

$allowed_columns = ['id', 'name'];

$db->setAuthorizer(function (int $action, ...$args) use ($allowed_columns) {
    if ($action === SQLite3::READ) {
        list($table, $column) = $args;

        if ($table === 'users' && in_array($column, $allowed_columns) {
            return SQLite3::OK;
        }

        return SQLite3::IGNORE;
    }

    return SQLite3::DENY;
});

print_r($db->querySingle('SELECT * FROM users WHERE id = 1;'));

以上例程会输出：

Array
(
    [id] => 1
    [name] => Pauline
    [password] =>
)


Returns the SQLite3 library version as a string constant and as a number

  • ? SQLite3::setAuthorizer
  • SQLite3Stmt ?
  • PHP Manual
  • SQLite3
  • Returns the SQLite3 library version as a string constant and as a number

SQLite3::version

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3::version — Returns the SQLite3 library version as a string constant and as a number

说明

public static SQLite3::version ( ) : array

Returns the SQLite3 library version as a string constant and as a number.

参数

此函数没有参数。

返回值

Returns an associative array with the keys "versionString" and "versionNumber".

范例

Example #1 SQLite3::version() example

<?php
print_r(SQLite3::version());
?>

以上例程的输出类似于：

Array
(
    [versionString] => 3.5.9
    [versionNumber] => 3005009
)


SQLite3Stmt 类

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

简介

处理 SQLite 3 扩展语句模板的类。

类摘要

SQLite3Stmt {
/* 方法 */
public bindParam ( string|int $param , mixed &$var , int $type = SQLITE3_TEXT ) : bool
public bindValue ( string|int $param , mixed $value , int $type = SQLITE3_TEXT ) : bool
public clear ( ) : bool
public close ( ) : bool
public execute ( ) : SQLite3Result|false
public getSQL ( bool $expand = false ) : string|false
public paramCount ( ) : int
public readOnly ( ) : bool
public reset ( ) : bool
}

Table of Contents

  • SQLite3Stmt::bindParam — Binds a parameter to a statement variable
  • SQLite3Stmt::bindValue — Binds the value of a parameter to a statement variable
  • SQLite3Stmt::clear — Clears all current bound parameters
  • SQLite3Stmt::close — Closes the prepared statement
  • SQLite3Stmt::execute — Executes a prepared statement and returns a result set object
  • SQLite3Stmt::getSQL — Get the SQL of the statement
  • SQLite3Stmt::paramCount — Returns the number of parameters within the prepared statement
  • SQLite3Stmt::readOnly — Returns whether a statement is definitely read only
  • SQLite3Stmt::reset — Resets the prepared statement


Binds a parameter to a statement variable

  • ? SQLite3Stmt
  • SQLite3Stmt::bindValue ?
  • PHP Manual
  • SQLite3Stmt
  • Binds a parameter to a statement variable

SQLite3Stmt::bindParam

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::bindParam — Binds a parameter to a statement variable

说明

public SQLite3Stmt::bindParam ( string|int $param , mixed &$var , int $type = SQLITE3_TEXT ) : bool

Binds a parameter to a statement variable.

Caution

Before PHP 7.2.14 and 7.3.0, respectively, SQLite3Stmt::reset() must be called after the first call to SQLite3Stmt::execute() if the bound value should be properly updated on following calls to SQLite3Stmt::execute(). If SQLite3Stmt::reset() is not called, the bound value will not change, even if the value assigned to the variable passed to SQLite3Stmt::bindParam() has changed, or SQLite3Stmt::bindParam() has been called again.

参数

param

Either a string (for named parameters) or an int (for positional parameters) identifying the statement variable to which the value should be bound. If a named parameter does not start with a colon (:) or an at sign (@), a colon (:) is automatically preprended. Positional parameters start with 1.

var

The parameter to bind to a statement variable.

type

The data type of the parameter to bind.

  • SQLITE3_INTEGER: The value is a signed integer, stored in 1, 2, 3, 4, 6, or 8 bytes depending on the magnitude of the value.

  • SQLITE3_FLOAT: The value is a floating point value, stored as an 8-byte IEEE floating point number.

  • SQLITE3_TEXT: The value is a text string, stored using the database encoding (UTF-8, UTF-16BE or UTF-16-LE).

  • SQLITE3_BLOB: The value is a blob of data, stored exactly as it was input.

  • SQLITE3_NULL: The value is a NULL value.

As of PHP 7.0.7, if type is omitted, it is automatically detected from the type of the var: bool and int are treated as SQLITE3_INTEGER, float as SQLITE3_FLOAT, null as SQLITE3_NULL and all others as SQLITE3_TEXT. Formerly, if type has been omitted, it has defaulted to SQLITE3_TEXT.

Note:

If var is null, it is always treated as SQLITE3_NULL, regardless of the given type.

返回值

Returns true if the parameter is bound to the statement variable, false on failure.

更新日志

版本 | 说明
7.4.0 | param now also supports the @param notation.

范例

Example #1 SQLite3Stmt::bindParam() Usage

This example shows how a single prepared statement with a single parameter binding can be used to insert multiple rows with different values.

<?php
$db = new SQLite3(':memory:');
$db->exec("CREATE TABLE foo (bar TEXT)");

$stmt = $db->prepare("INSERT INTO foo VALUES (:bar)");
$stmt->bindParam(':bar', $bar, SQLITE3_TEXT);

$bar = 'baz';
$stmt->execute();

$bar = 42;
$stmt->execute();

$res = $db->query("SELECT * FROM foo");
while (($row = $res->fetchArray(SQLITE3_ASSOC))) {
    var_dump($row);
}
?>

以上例程会输出：

array(1) {
  ["bar"]=>
  string(3) "baz"
}
array(1) {
  ["bar"]=>
  string(2) "42"
}

参见

  • SQLite3Stmt::bindValue() - Binds the value of a parameter to a statement variable
  • SQLite3::prepare() - Prepares an SQL statement for execution


Binds the value of a parameter to a statement variable

  • ? SQLite3Stmt::bindParam
  • SQLite3Stmt::clear ?
  • PHP Manual
  • SQLite3Stmt
  • Binds the value of a parameter to a statement variable

SQLite3Stmt::bindValue

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::bindValue — Binds the value of a parameter to a statement variable

说明

public SQLite3Stmt::bindValue ( string|int $param , mixed $value , int $type = SQLITE3_TEXT ) : bool

Binds the value of a parameter to a statement variable.

Caution

Before PHP 7.2.14 and 7.3.0, respectively, once the statement has been executed, SQLite3Stmt::reset() needs to be called to be able to change the value of bound parameters.

参数

param

Either a string (for named parameters) or an int (for positional parameters) identifying the statement variable to which the value should be bound. If a named parameter does not start with a colon (:) or an at sign (@), a colon (:) is automatically preprended. Positional parameters start with 1.

value

The value to bind to a statement variable.

type

The data type of the value to bind.

  • SQLITE3_INTEGER: The value is a signed integer, stored in 1, 2, 3, 4, 6, or 8 bytes depending on the magnitude of the value.

  • SQLITE3_FLOAT: The value is a floating point value, stored as an 8-byte IEEE floating point number.

  • SQLITE3_TEXT: The value is a text string, stored using the database encoding (UTF-8, UTF-16BE or UTF-16-LE).

  • SQLITE3_BLOB: The value is a blob of data, stored exactly as it was input.

  • SQLITE3_NULL: The value is a NULL value.

As of PHP 7.0.7, if type is omitted, it is automatically detected from the type of the value: bool and int are treated as SQLITE3_INTEGER, float as SQLITE3_FLOAT, null as SQLITE3_NULL and all others as SQLITE3_TEXT. Formerly, if type has been omitted, it has defaulted to SQLITE3_TEXT.

Note:

If value is null, it is always treated as SQLITE3_NULL, regardless of the given type.

返回值

Returns true if the value is bound to the statement variable, 或者在失败时返回 false.

更新日志

版本 | 说明
7.4.0 | param now also supports the @param notation.

范例

Example #1 SQLite3Stmt::bindValue() example

<?php
$db = new SQLite3(':memory:');

$db->exec('CREATE TABLE foo (id INTEGER, bar STRING)');
$db->exec("INSERT INTO foo (id, bar) VALUES (1, 'This is a test')");

$stmt = $db->prepare('SELECT bar FROM foo WHERE id=:id');
$stmt->bindValue(':id', 1, SQLITE3_INTEGER);

$result = $stmt->execute();
var_dump($result->fetchArray(SQLITE3_ASSOC));
?>

以上例程会输出：

array(1) {
  ["bar"]=>
  string(14) "This is a test"
}

参见

  • SQLite3Stmt::bindParam() - Binds a parameter to a statement variable
  • SQLite3::prepare() - Prepares an SQL statement for execution


Clears all current bound parameters

  • ? SQLite3Stmt::bindValue
  • SQLite3Stmt::close ?
  • PHP Manual
  • SQLite3Stmt
  • Clears all current bound parameters

SQLite3Stmt::clear

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::clear — Clears all current bound parameters

说明

public SQLite3Stmt::clear ( ) : bool

Clears all current bound parameters (sets them to null).

Caution

This method needs to be used with SQLite3Stmt::reset(). If used alone, any call to SQLite3Stmt::bindValue() or SQLite3Stmt::bindParam() will be of no effect and all bound parameters will have the null value.

参数

此函数没有参数。

返回值

Returns true on successful clearing of bound parameters, false on failure.


Closes the prepared statement

  • ? SQLite3Stmt::clear
  • SQLite3Stmt::execute ?
  • PHP Manual
  • SQLite3Stmt
  • Closes the prepared statement

SQLite3Stmt::close

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::close — Closes the prepared statement

说明

public SQLite3Stmt::close ( ) : bool

Closes the prepared statement.

Note: Note that all SQLite3Results that have been retrieved by executing this statement will be invalidated when the statement is closed.

参数

此函数没有参数。

返回值

Returns true


Executes a prepared statement and returns a result set object

  • ? SQLite3Stmt::close
  • SQLite3Stmt::getSQL ?
  • PHP Manual
  • SQLite3Stmt
  • Executes a prepared statement and returns a result set object

SQLite3Stmt::execute

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::execute — Executes a prepared statement and returns a result set object

说明

public SQLite3Stmt::execute ( ) : SQLite3Result|false

Executes a prepared statement and returns a result set object.

Caution

Result set objects retrieved by calling this method on the same statement object are not independent, but rather share the same underlying structure. Therefore it is recommended to call SQLite3Result::finalize(), before calling SQLite3Stmt::execute() on the same statement object again.

参数

此函数没有参数。

返回值

Returns an SQLite3Result object on successful execution of the prepared statement, false on failure.

参见

  • SQLite3::prepare() - Prepares an SQL statement for execution
  • SQLite3Stmt::bindValue() - Binds the value of a parameter to a statement variable
  • SQLite3Stmt::bindParam() - Binds a parameter to a statement variable


Get the SQL of the statement

  • ? SQLite3Stmt::execute
  • SQLite3Stmt::paramCount ?
  • PHP Manual
  • SQLite3Stmt
  • Get the SQL of the statement

SQLite3Stmt::getSQL

(PHP 7 >= 7.4.0, PHP 8)

SQLite3Stmt::getSQL — Get the SQL of the statement

说明

public SQLite3Stmt::getSQL ( bool $expand = false ) : string|false

Retrieves the SQL of the prepared statement. If expand is false, the unmodified SQL is retrieved. If expand is true, all query parameters are replaced with their bound values, or with an SQL NULL, if not already bound.

参数

expand

Whether to retrieve the expanded SQL. Passing true is only supported as of libsqlite 3.14.

返回值

Returns the SQL of the prepared statement, 或者在失败时返回 false.

错误／异常

If expand is true, but the libsqlite version is less than 3.14, an error of level E_WARNING or an Exception is issued, according to SQLite3::enableExceptions().

范例

Example #1 Inspecting the expanded SQL

<?php
$db = new SQLite3(':memory:');
$stmt = $db->prepare("SELECT :a, ?, :c");
$stmt->bindValue(':a', 'foo');
$answer = 42;
$stmt->bindParam(2, $answer);
var_dump($stmt->getSQL(true));
?>

以上例程的输出类似于：

string(24) "SELECT 'foo', '42', NULL"


Returns the number of parameters within the prepared statement

  • ? SQLite3Stmt::getSQL
  • SQLite3Stmt::readOnly ?
  • PHP Manual
  • SQLite3Stmt
  • Returns the number of parameters within the prepared statement

SQLite3Stmt::paramCount

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::paramCount — Returns the number of parameters within the prepared statement

说明

public SQLite3Stmt::paramCount ( ) : int

Returns the number of parameters within the prepared statement.

参数

此函数没有参数。

返回值

Returns the number of parameters within the prepared statement.

参见

  • SQLite3::prepare() - Prepares an SQL statement for execution


Returns whether a statement is definitely read only

  • ? SQLite3Stmt::paramCount
  • SQLite3Stmt::reset ?
  • PHP Manual
  • SQLite3Stmt
  • Returns whether a statement is definitely read only

SQLite3Stmt::readOnly

(PHP 5 >= 5.3.6, PHP 7, PHP 8)

SQLite3Stmt::readOnly — Returns whether a statement is definitely read only

说明

public SQLite3Stmt::readOnly ( ) : bool

Returns whether a statement is definitely read only. A statement is considered read only, if it makes no direct changes to the content of the database file. Note that user defined SQL functions might change the database indirectly as a side effect.

参数

此函数没有参数。

返回值

Returns true if a statement is definitely read only, false otherwise.


Resets the prepared statement

  • ? SQLite3Stmt::readOnly
  • SQLite3Result ?
  • PHP Manual
  • SQLite3Stmt
  • Resets the prepared statement

SQLite3Stmt::reset

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Stmt::reset — Resets the prepared statement

说明

public SQLite3Stmt::reset ( ) : bool

Resets the prepared statement to its state prior to execution. All bindings remain intact after reset.

参数

此函数没有参数。

返回值

Returns true if the statement is successfully reset, 或者在失败时返回 false.


SQLite3Result 类

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

简介

处理 SQLite 3 扩展返回结果集的类。

类摘要

SQLite3Result {
/* 方法 */
public columnName ( int $column ) : string|false
public columnType ( int $column ) : int|false
public fetchArray ( int $mode = SQLITE3_BOTH ) : array|false
public finalize ( ) : bool
public numColumns ( ) : int
public reset ( ) : bool
}

Table of Contents

  • SQLite3Result::columnName — Returns the name of the nth column
  • SQLite3Result::columnType — Returns the type of the nth column
  • SQLite3Result::fetchArray — Fetches a result row as an associative or numerically indexed array or both
  • SQLite3Result::finalize — Closes the result set
  • SQLite3Result::numColumns — Returns the number of columns in the result set
  • SQLite3Result::reset — Resets the result set back to the first row


Returns the name of the nth column

  • ? SQLite3Result
  • SQLite3Result::columnType ?
  • PHP Manual
  • SQLite3Result
  • Returns the name of the nth column

SQLite3Result::columnName

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::columnName — Returns the name of the nth column

说明

public SQLite3Result::columnName ( int $column ) : string|false

Returns the name of the column specified by the column. Note that the name of a result column is the value of the AS clause for that column, if there is an AS clause. If there is no AS clause then the name of the column is unspecified and may change from one release of libsqlite3 to the next.

参数

column

The numeric zero-based index of the column.

返回值

Returns the string name of the column identified by column, or false if the column does not exist.


Returns the type of the nth column

  • ? SQLite3Result::columnName
  • SQLite3Result::fetchArray ?
  • PHP Manual
  • SQLite3Result
  • Returns the type of the nth column

SQLite3Result::columnType

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::columnType — Returns the type of the nth column

说明

public SQLite3Result::columnType ( int $column ) : int|false

Returns the type of the column identified by column.

参数

column

The numeric zero-based index of the column.

返回值

Returns the data type index of the column identified by column (one of SQLITE3_INTEGER, SQLITE3_FLOAT, SQLITE3_TEXT, SQLITE3_BLOB, or SQLITE3_NULL), or false if the column does not exist.


Fetches a result row as an associative or numerically indexed array or both

  • ? SQLite3Result::columnType
  • SQLite3Result::finalize ?
  • PHP Manual
  • SQLite3Result
  • Fetches a result row as an associative or numerically indexed array or both

SQLite3Result::fetchArray

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::fetchArray — Fetches a result row as an associative or numerically indexed array or both

说明

public SQLite3Result::fetchArray ( int $mode = SQLITE3_BOTH ) : array|false

Fetches a result row as an associative or numerically indexed array or both. By default, fetches as both.

参数

mode

Controls how the next row will be returned to the caller. This value must be one of either SQLITE3_ASSOC, SQLITE3_NUM, or SQLITE3_BOTH.

  • SQLITE3_ASSOC: returns an array indexed by column name as returned in the corresponding result set

  • SQLITE3_NUM: returns an array indexed by column number as returned in the corresponding result set, starting at column 0

  • SQLITE3_BOTH: returns an array indexed by both column name and number as returned in the corresponding result set, starting at column 0

返回值

Returns a result row as an associatively or numerically indexed array or both. Alternately will return false if there are no more rows.

The types of the values of the returned array are mapped from SQLite3 types as follows: integers are mapped to int if they fit into the range PHP_INT_MIN..PHP_INT_MAX, and to string otherwise. Floats are mapped to float, NULL values are mapped to null, and strings and blobs are mapped to string.


Closes the result set

  • ? SQLite3Result::fetchArray
  • SQLite3Result::numColumns ?
  • PHP Manual
  • SQLite3Result
  • Closes the result set

SQLite3Result::finalize

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::finalize — Closes the result set

说明

public SQLite3Result::finalize ( ) : bool

Closes the result set.

参数

此函数没有参数。

返回值

Returns true.


Returns the number of columns in the result set

  • ? SQLite3Result::finalize
  • SQLite3Result::reset ?
  • PHP Manual
  • SQLite3Result
  • Returns the number of columns in the result set

SQLite3Result::numColumns

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::numColumns — Returns the number of columns in the result set

说明

public SQLite3Result::numColumns ( ) : int

Returns the number of columns in the result set.

参数

此函数没有参数。

返回值

Returns the number of columns in the result set.


Resets the result set back to the first row

  • ? SQLite3Result::numColumns
  • SQLSRV ?
  • PHP Manual
  • SQLite3Result
  • Resets the result set back to the first row

SQLite3Result::reset

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SQLite3Result::reset — Resets the result set back to the first row

说明

public SQLite3Result::reset ( ) : bool

Resets the result set back to the first row.

参数

此函数没有参数。

返回值

Returns true if the result set is successfully reset back to the first row, false on failure.


Microsoft SQL Server Driver for PHP

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • SQLSRV 函数
    • sqlsrv_begin_transaction — Begins a database transaction
    • sqlsrv_cancel — Cancels a statement
    • sqlsrv_client_info — Returns information about the client and specified connection
    • sqlsrv_close — Closes an open connection and releases resourses associated with the connection
    • sqlsrv_commit — Commits a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_configure — Changes the driver error handling and logging configurations
    • sqlsrv_connect — Opens a connection to a Microsoft SQL Server database
    • sqlsrv_errors — Returns error and warning information about the last SQLSRV operation performed
    • sqlsrv_execute — Executes a statement prepared with sqlsrv_prepare
    • sqlsrv_fetch_array — Returns a row as an array
    • sqlsrv_fetch_object — Retrieves the next row of data in a result set as an object
    • sqlsrv_fetch — Makes the next row in a result set available for reading
    • sqlsrv_field_metadata — Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query
    • sqlsrv_free_stmt — Frees all resources for the specified statement
    • sqlsrv_get_config — Returns the value of the specified configuration setting
    • sqlsrv_get_field — Gets field data from the currently selected row
    • sqlsrv_has_rows — Indicates whether the specified statement has rows
    • sqlsrv_next_result — Makes the next result of the specified statement active
    • sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement
    • sqlsrv_num_rows — Retrieves the number of rows in a result set
    • sqlsrv_prepare — Prepares a query for execution
    • sqlsrv_query — Prepares and executes a query
    • sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
    • sqlsrv_send_stream_data — Sends data from parameter streams to the server
    • sqlsrv_server_info — Returns information about the server


简介

The SQLSRV extension allows you to access Microsoft SQL Server and SQL Azure databases. The 3.0 release of the driver supports SQL Server, beginning with SQL Server 2005, including SQL Server 2012 and SQL Server 2012 LocalDB. (For more information about LocalDB, see » PHP Driver for SQL Server Support for LocalDB and » SQL Server 2012 Express LocalDB.)

The SQLSRV extension is supported by Microsoft and available for download here: » http://msdn.microsoft.com/en-us/sqlserver/ff657782.aspx. SQL Server 2012 LocalDB can be downloaded here: » http://go.microsoft.com/fwlink/?LinkID=237665.


需求

The SQLSRV extension can be used on the following operating systems:

  • Windows Vista Service Pack 2 or later
  • Windows Server 2008 Service Pack 2 or later
  • Windows Server 2008 R2
  • Windows 7

The SQLSRV extension requires that the Microsoft SQL Server 2012 Native Client be installed on the same computer that is running PHP. If the Microsoft SQL Server 2012 Native Client is not already installed, click the appropriate link below to download it:

  • » Download the x86 package
  • » Download the x64 package

The SQLSRV download comes 8 driver files, four of which are for PDO support. If you are running non-thread-safe PHP (PHP 5.3), use the php_sqlsrv_53_nts.dll file. (You should use a non-thread-safe version if you are using IIS as your web server). If you are running thread-safe PHP, use the php_sqlsrv_53_ts.dll file. Similarly for PHP 5.4, use the php_sqlsrv_54_nts.dll or php_sqlsrv_54_ts.dll depending on whether your PHP installation is non-thread-safe or thread-safe.

The most recent version of the driver is available for download here: » SQLSRV 4.0 download. If you need support for PHP 5.2 and/or PHP compiled with VC6, use the 2.0 release of the driver: » SQLSRV 2.0 download.

For more information about SQLSRV requirements, see » SQLSRV System Requirements.


安装

The SQLSRV extension is enabled by adding appropriate DLL file to your PHP extension directory and the corresponding entry to the php.ini file. The SQLSRV download comes 8 driver files, four of which are for PDO support. If you are running non-thread-safe PHP (PHP 5.3), use the php_sqlsrv_53_nts.dll file. (You should use a non-thread-safe version if you are using IIS as your web server). If you are running thread-safe PHP, use the php_sqlsrv_53_ts.dll file. Similarly for PHP 5.4, use the php_sqlsrv_54_nts.dll or php_sqlsrv_54_ts.dll depending on whether your PHP installation is non-thread-safe or thread-safe.

The most recent version of the driver is available for download here: » SQLSRV 4.0 download. If you need support for PHP 5.2 and/or PHP compiled with VC6, use the 2.0 release of the driver: » SQLSRV 2.0 download.

For more information about SQLSRV requirements, see » SQLSRV System Requirements.

The SQLSRV extension is only compatible with PHP 5 running on Windows. Since version 4.0 the SQLSRV extension is compatilbe only with PHP 7.0 running on Linux or Windows.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

The following table lists the configuration options available in the SQLSRV extension. For more information about these options, see » Handling SQLSRV Warnings and Errors.

SQLSRV 配置选项
名字 | 默认 | 可修改范围 | Changelog
sqlsrv.WarningsReturnAsErrors | 1 (true) | PHP_INI_ALL | Available since SQLSRV 1.0
sqlsrv.LogSubsystems | 0 | PHP_INI_ALL | Available since SQLSRV 1.0
sqlsrv.LogSeverity | 1 | PHP_INI_ALL | Available since SQLSRV 1.0


资源类型

Connection resource

A connection resource returned by sqlsrv_connect().

Statement resource

A statement resource returned by sqlsrv_query() or by sqlsrv_prepare().


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SQLSRV_FETCH_ASSOC (int)
Forces sqlsrv_fetch_array() to return an associative array when passed as a parameter.
SQLSRV_FETCH_NUMERIC (int)
Forces sqlsrv_fetch_array() to return an array with numeric when passed as a parameter.
SQLSRV_FETCH_BOTH (int)
Forces sqlsrv_fetch_array() to return an array with both associative and numeric keys when passed as a parameter (the default behavior).
SQLSRV_ERR_ALL (int)
Forces sqlsrv_errors() to return both errors and warings when passed as a parameter (the default behavior).
SQLSRV_ERR_ERRORS (int)
Forces sqlsrv_errors() to return errors only (no warnings) when passed as a parameter.
SQLSRV_ERR_WARNINGS (int)
Forces sqlsrv_errors() to return warnings only (no errors) when passed as a parameter.
SQLSRV_LOG_SYSTEM_ALL (int)
Turns on logging of all subsystems when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_CONN (int)
Turns on logging of connection activity when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_INIT (int)
Turns on logging of initialization activity when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_OFF (int)
Turns off logging of all subsystems when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_STMT (int)
Turns on logging of statement activity when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_UTIL (int)
Turns on logging of error function activity when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_ALL (int)
Specifies that errors, warnings, and notices will be logged when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_ERROR (int)
Specifies that errors will be logged when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_NOTICE (int)
Specifies that notices will be logged when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_WARNING (int)
Specifies that warnings will be logged when passed to sqlsrv_configure() as a parameter.
SQLSRV_NULLABLE_YES (int)
Indicates that a column is nullable.
SQLSRV_NULLABLE_NO (int)
Indicates that a column is not nullable.
SQLSRV_NULLABLE_UNKNOWN (int)
Indicates that it is not known if a column is nullable.
SQLSRV_PARAM_IN (int)
Indicates an input parameter when passed to sqlsrv_query() or sqlsrv_prepare().
SQLSRV_PARAM_INOUT (int)
Indicates a bidirectional parameter when passed to sqlsrv_query() or sqlsrv_prepare().
SQLSRV_PARAM_OUT (int)
Indicates an output parameter when passed to sqlsrv_query() or sqlsrv_prepare().
SQLSRV_PHPTYPE_INT (int)
Specifies an integer PHP data type. For usage information, see » How to: Specify PHP Types.
SQLSRV_PHPTYPE_DATETIME (int)
Specifies a datetime PHP data type. For usage information, see » How to: Specify PHP Types.
SQLSRV_PHPTYPE_FLOAT (int)
Specifies a float PHP data type. For usage information, see » How to: Specify PHP Types.
SQLSRV_PHPTYPE_STREAM (int)
Specifies a PHP stream. This constant works like a function and accepts an encoding constant. See the SQLSRV_ENC_* constants. For usage information, see » How to: Specify PHP Types.
SQLSRV_PHPTYPE_STRING (int)
Specifies a string PHP data type. This constant works like a function and accepts an encoding constant. See the SQLSRV_ENC_* constants. For usage information, see » How to: Specify PHP Types.
SQLSRV_ENC_BINARY (int)
Specifies that data is returned as a raw byte stream from the server without performing encoding or translation. For usage information, see » How to: Specify PHP Types.
SQLSRV_ENC_CHAR (int)
Data is returned in 8-bit characters as specified in the code page of the Windows locale that is set on the system. Any multi-byte characters or characters that do not map into this code page are substituted with a single byte question mark (?) character. This is the default encoding. For usage information, see » How to: Specify PHP Types.
UTF-8 (int)
Specifies that data is returned with UTF-8 encoding. For usage information, see » How to: Specify PHP Types.
SQLSRV_SQLTYPE_BIGINT (int)
Describes the bigint SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_BINARY (int)
Describes the binary SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_BIT (int)
Describes the bit SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_CHAR (int)
Describes the char SQL Server data type. This constant works like a function and accepts a parameter indicating the number characters. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DATE (int)
Describes the date SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DATETIME (int)
Describes the datetime SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DATETIME2 (int)
Describes the datetime2 SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DATETIMEOFFSET (int)
Describes the datetimeoffset SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DECIMAL (int)
Describes the decimal SQL Server data type. This constant works like a function and accepts two parameters indicating (in order) precision and scale. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_FLOAT (int)
Describes the float SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_IMAGE (int)
Describes the image SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_INT (int)
Describes the int SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_MONEY (int)
Describes the money SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NCHAR (int)
Describes the nchar SQL Server data type. This constant works like a function and accepts a single parameter indicating the character count. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NUMERIC (int)
Describes the numeric SQL Server data type. This constant works like a function and accepts two parameter indicating (in order) precision and scale. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NVARCHAR (int)
Describes the nvarchar SQL Server data type. This constant works like a function and accepts a single parameter indicating the character count. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NVARCHAR('max') (int)
Describes the nvarchar(MAX) SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NTEXT (int)
Describes the ntext SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_REAL (int)
Describes the real SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_SMALLDATETIME (int)
Describes the smalldatetime SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_SMALLINT (int)
Describes the smallint SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_SMALLMONEY (int)
Describes the smallmoney SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_TEXT (int)
Describes the text SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_TIME (int)
Describes the time SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_TIMESTAMP (int)
Describes the timestamp SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_TINYINT (int)
Describes the tinyint SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_UNIQUEIDENTIFIER (int)
Describes the uniqueidentifier SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_UDT (int)
Describes the UDT SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_VARBINARY (int)
Describes the varbinary SQL Server data type. This constant works like a function and accepts a single parameter indicating the byte count. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_VARBINARY('max') (int)
Describes the varbinary(MAX) SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_VARCHAR (int)
Describes the varchar SQL Server data type. This constant works like a function and accepts a single parameter indicating the character count. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_VARCHAR('max') (int)
Describes the varchar(MAX) SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_XML (int)
Describes the XML SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_TXN_READ_UNCOMMITTED (int)
Indicates a transaction isolation level of READ UNCOMMITTED. This value is used to set the TransactionIsolation level in the $connectionOptions array passed to sqlsrv_connect().
SQLSRV_TXN_READ_COMMITTED (int)
Indicates a transaction isolation level of READ COMMITTED. This value is used to set the TransactionIsolation level in the $connectionOptions array passed to sqlsrv_connect().
SQLSRV_TXN_REPEATABLE_READ (int)
Indicates a transaction isolation level of REPEATABLE READ. This value is used to set the TransactionIsolation level in the $connectionOptions array passed to sqlsrv_connect().
SQLSRV_TXN_SNAPSHOT (int)
Indicates a transaction isolation level of SNAPSHOT. This value is used to set the TransactionIsolation level in the $connectionOptions array passed to sqlsrv_connect().
SQLSRV_TXN_READ_SERIALIZABLE (int)
Indicates a transaction isolation level of SERIALIZABLE. This value is used to set the TransactionIsolation level in the $connectionOptions array passed to sqlsrv_connect().
SQLSRV_CURSOR_FORWARD (int)
Indicates a forward-only cursor. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_CURSOR_STATIC (int)
Indicates a static cursor. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_CURSOR_DYNAMIC (int)
Indicates a dynamic cursor. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_CURSOR_KEYSET (int)
Indicates a keyset cursor. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_CURSOR_BUFFERED (int)
Creates a client-side cursor query. Lets you access rows in any order. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_NEXT (int)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_PRIOR (int)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_FIRST (int)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_LAST (int)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_ABSOLUTE (int)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_RELATIVE (int)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.


SQLSRV 函数

Table of Contents

  • sqlsrv_begin_transaction — Begins a database transaction
  • sqlsrv_cancel — Cancels a statement
  • sqlsrv_client_info — Returns information about the client and specified connection
  • sqlsrv_close — Closes an open connection and releases resourses associated with the connection
  • sqlsrv_commit — Commits a transaction that was begun with sqlsrv_begin_transaction
  • sqlsrv_configure — Changes the driver error handling and logging configurations
  • sqlsrv_connect — Opens a connection to a Microsoft SQL Server database
  • sqlsrv_errors — Returns error and warning information about the last SQLSRV operation performed
  • sqlsrv_execute — Executes a statement prepared with sqlsrv_prepare
  • sqlsrv_fetch_array — Returns a row as an array
  • sqlsrv_fetch_object — Retrieves the next row of data in a result set as an object
  • sqlsrv_fetch — Makes the next row in a result set available for reading
  • sqlsrv_field_metadata — Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query
  • sqlsrv_free_stmt — Frees all resources for the specified statement
  • sqlsrv_get_config — Returns the value of the specified configuration setting
  • sqlsrv_get_field — Gets field data from the currently selected row
  • sqlsrv_has_rows — Indicates whether the specified statement has rows
  • sqlsrv_next_result — Makes the next result of the specified statement active
  • sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement
  • sqlsrv_num_rows — Retrieves the number of rows in a result set
  • sqlsrv_prepare — Prepares a query for execution
  • sqlsrv_query — Prepares and executes a query
  • sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction
  • sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
  • sqlsrv_send_stream_data — Sends data from parameter streams to the server
  • sqlsrv_server_info — Returns information about the server


Begins a database transaction

  • ? SQLSRV 函数
  • sqlsrv_cancel ?
  • PHP Manual
  • SQLSRV 函数
  • Begins a database transaction

sqlsrv_begin_transaction

(No version information available, might only be in Git)

sqlsrv_begin_transaction — Begins a database transaction

说明

sqlsrv_begin_transaction ( resource $conn ) : bool

The transaction begun by sqlsrv_begin_transaction() includes all statements that were executed after the call to sqlsrv_begin_transaction() and before calls to sqlsrv_rollback() or sqlsrv_commit(). Explicit transactions should be started and committed or rolled back using these functions instead of executing SQL statements that begin and commit/roll back transactions. For more information, see » SQLSRV Transactions.

参数

conn

The connection resource returned by a call to sqlsrv_connect().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sqlsrv_begin_transaction() example

The following example demonstrates how to use sqlsrv_begin_transaction() together with sqlsrv_commit() and sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Begin the transaction. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Initialize parameter values. */
$orderId = 1; $qty = 10; $productId = 100;

/* Set up and execute the first query. */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
          VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Set up and execute the second query. */
$sql2 = "UPDATE InventoryTable
          SET Quantity = (Quantity - ?)
          WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* If both queries were successful, commit the transaction. */
/* Otherwise, rollback the transaction. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transaction committed.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transaction rolled back.<br />";
}
?>

以上例程的输出类似于：

参见

  • sqlsrv_commit() - Commits a transaction that was begun with sqlsrv_begin_transaction
  • sqlsrv_rollback() - Rolls back a transaction that was begun with sqlsrv_begin_transaction


Cancels a statement

  • ? sqlsrv_begin_transaction
  • sqlsrv_client_info ?
  • PHP Manual
  • SQLSRV 函数
  • Cancels a statement

sqlsrv_cancel

(No version information available, might only be in Git)

sqlsrv_cancel — Cancels a statement

说明

sqlsrv_cancel ( resource $stmt ) : bool

Cancels a statement. Any results associated with the statement that have not been consumed are deleted. After sqlsrv_cancel() has been called, the specified statement can be re-executed if it was created with sqlsrv_prepare(). Calling sqlsrv_cancel() is not necessary if all the results associated with the statement have been consumed.

参数

stmt

The statement resource to be cancelled.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sqlsrv_cancel() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Sales FROM Table_1";

$stmt = sqlsrv_prepare( $conn, $sql);

if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

if( sqlsrv_execute( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

$salesTotal = 0;
$count = 0;

while( ($row = sqlsrv_fetch_array( $stmt)) && $salesTotal <=100000)
{
     $qty = $row[0];
     $price = $row[1];
     $salesTotal += ( $price * $qty);
     $count++;
}

echo "$count sales accounted for the first $$salesTotal in revenue.<br />";

// Cancel the pending results. The statement can be reused.
sqlsrv_cancel( $stmt);
?>

注释

The main difference between sqlsrv_cancel() and sqlsrv_free_stmt() is that a statement resource cancelled with sqlsrv_cancel() can be re-executed if it was created with sqlsrv_prepare(). A statement resource cancelled with sqlsrv_free_statement() cannot be re-executed.

参见

  • sqlsrv_free_stmt() - Frees all resources for the specified statement
  • sqlsrv_prepare() - Prepares a query for execution


Returns information about the client and specified connection

  • ? sqlsrv_cancel
  • sqlsrv_close ?
  • PHP Manual
  • SQLSRV 函数
  • Returns information about the client and specified connection

sqlsrv_client_info

(No version information available, might only be in Git)

sqlsrv_client_info — Returns information about the client and specified connection

说明

sqlsrv_client_info ( resource $conn ) : array

Returns information about the client and specified connection

参数

conn

The connection about which information is returned.

返回值

Returns an associative array with keys described in the table below. Returns false otherwise.

Array returned by sqlsrv_client_info
Key | Description
DriverDllName | SQLNCLI10.DLL
DriverODBCVer | ODBC version (xx.yy)
DriverVer | SQL Server Native Client DLL version (10.5.xxx)
ExtensionVer | php_sqlsrv.dll version (2.0.xxx.x)

范例

Example #1 sqlsrv_client_info() example

<?php
$serverName = "serverName\sqlexpress";
$connOptions = array("UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connOptions );

if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

if( $client_info = sqlsrv_client_info( $conn)) {
    foreach( $client_info as $key => $value) {
        echo $key.": ".$value."<br />";
    }
} else {
    echo "Error in retrieving client info.<br />";
}
?>

参见

  • sqlsrv_server_info() - Returns information about the server


Closes an open connection and releases resourses associated with the connection

  • ? sqlsrv_client_info
  • sqlsrv_commit ?
  • PHP Manual
  • SQLSRV 函数
  • Closes an open connection and releases resourses associated with the connection

sqlsrv_close

(No version information available, might only be in Git)

sqlsrv_close — Closes an open connection and releases resourses associated with the connection

说明

sqlsrv_close ( resource $conn ) : bool

Closes an open connection and releases resourses associated with the connection.

参数

conn

The connection to be closed.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sqlsrv_close() example

<?php
$serverName = "serverName\sqlexpres";
$connOptions = array("UID"=>"username", "PWD"=>"password", "Database"=>"dbname");
$conn = sqlsrv_connect( $serverName, $connOptions );
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

//-------------------------------------
// Perform database operations here.
//-------------------------------------

// Close the connection.
sqlsrv_close( $conn );
?>

参见

  • sqlsrv_connect() - Opens a connection to a Microsoft SQL Server database


Commits a transaction that was begun with sqlsrv_begin_transaction

  • ? sqlsrv_close
  • sqlsrv_configure ?
  • PHP Manual
  • SQLSRV 函数
  • Commits a transaction that was begun with sqlsrv_begin_transaction

sqlsrv_commit

(No version information available, might only be in Git)

sqlsrv_commit — Commits a transaction that was begun with sqlsrv_begin_transaction()

说明

sqlsrv_commit ( resource $conn ) : bool

Commits a transaction that was begun with sqlsrv_begin_transaction(). The connection is returned to auto-commit mode after sqlsrv_commit() is called. The transaction that is committed includes all statements that were executed after the call to sqlsrv_begin_transaction(). Explicit transactions should be started and committed or rolled back using these functions instead of executing SQL statements that begin and commit/roll back transactions. For more information, see » SQLSRV Transactions.

参数

conn

The connection on which the transaction is to be committed.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sqlsrv_commit() example

The following example demonstrates how to use sqlsrv_commit() together with sqlsrv_begin_transaction() and sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Begin the transaction. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Initialize parameter values. */
$orderId = 1; $qty = 10; $productId = 100;

/* Set up and execute the first query. */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
         VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Set up and execute the second query. */
$sql2 = "UPDATE InventoryTable
         SET Quantity = (Quantity - ?)
         WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* If both queries were successful, commit the transaction. */
/* Otherwise, rollback the transaction. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transaction committed.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transaction rolled back.<br />";
}
?>

参见

  • sqlsrv_begin_transaction() - Begins a database transaction
  • sqlsrv_rollback() - Rolls back a transaction that was begun with sqlsrv_begin_transaction


Changes the driver error handling and logging configurations

  • ? sqlsrv_commit
  • sqlsrv_connect ?
  • PHP Manual
  • SQLSRV 函数
  • Changes the driver error handling and logging configurations

sqlsrv_configure

(No version information available, might only be in Git)

sqlsrv_configure — Changes the driver error handling and logging configurations

说明

sqlsrv_configure ( string $setting , mixed $value ) : bool

Changes the driver error handling and logging configurations.

参数

setting

The name of the setting to set. The possible values are "WarningsReturnAsErrors", "LogSubsystems", and "LogSeverity".

value

The value of the specified setting. The following table shows possible values:

Error and Logging Setting Options
Setting | Options
WarningsReturnAsErrors | 1 (true) or 0 (false)
LogSubsystems | SQLSRV_LOG_SYSTEM_ALL (-1) SQLSRV_LOG_SYSTEM_CONN (2) SQLSRV_LOG_SYSTEM_INIT (1) SQLSRV_LOG_SYSTEM_OFF (0) SQLSRV_LOG_SYSTEM_STMT (4) SQLSRV_LOG_SYSTEM_UTIL (8)
LogSeverity | SQLSRV_LOG_SEVERITY_ALL (-1) SQLSRV_LOG_SEVERITY_ERROR (1) SQLSRV_LOG_SEVERITY_NOTICE (4) SQLSRV_LOG_SEVERITY_WARNING (2)

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • » SQLSRV Error Handling.
  • » Logging SQLSRV Activity.


Opens a connection to a Microsoft SQL Server database

  • ? sqlsrv_configure
  • sqlsrv_errors ?
  • PHP Manual
  • SQLSRV 函数
  • Opens a connection to a Microsoft SQL Server database

sqlsrv_connect

(No version information available, might only be in Git)

sqlsrv_connect — Opens a connection to a Microsoft SQL Server database

说明

sqlsrv_connect ( string $serverName , array $connectionInfo = ? ) : resource

Opens a connection to a Microsoft SQL Server database. By default, the connection is attempted using Windows Authentication. To connect using SQL Server Authentication, include "UID" and "PWD" in the connection options array.

参数

serverName

The name of the server to which a connection is established. To connect to a specific instance, follow the server name with a backward slash and the instance name (e.g. serverName\sqlexpress).

connectionInfo

An associative array that specifies options for connecting to the server. If values for the UID and PWD keys are not specified, the connection will be attempted using Windows Authentication. For a complete list of supported keys, see » SQLSRV Connection Options.

返回值

A connection resource. If a connection cannot be successfully opened, false is returned.

范例

Example #1 Connect using Windows Authentication.

<?php
$serverName = "serverName\\sqlexpress"; //serverName\instanceName

// Since UID and PWD are not specified in the $connectionInfo array,
// The connection will be attempted using Windows Authentication.
$connectionInfo = array( "Database"=>"dbName");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Connection established.<br />";
}else{
     echo "Connection could not be established.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

Example #2 Connect by specifying a user name and password.

<?php
$serverName = "serverName\\sqlexpress"; //serverName\instanceName
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Connection established.<br />";
}else{
     echo "Connection could not be established.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

Example #3 Connect on a specified port.

<?php
$serverName = "serverName\\sqlexpress, 1542"; //serverName\instanceName, portNumber (default is 1433)
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Connection established.<br />";
}else{
     echo "Connection could not be established.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

注释

By default, the sqlsrv_connect() uses connection pooling to improve connection performance. To turn off connection pooling (i.e. force a new connection on each call), set the "ConnectionPooling" option in the $connectionOptions array to 0 (or false). For more information, see » SQLSRV Connection Pooling.

The SQLSRV extension does not have a dedicated function for changing which database is connected to. The target database is specified in the $connectionOptions array that is passed to sqlsrv_connect. To change the database on an open connection, execute the following query "USE dbName" (e.g. sqlsrv_query($conn, "USE dbName")).

参见

  • sqlsrv_close() - Closes an open connection and releases resourses associated with the connection
  • sqlsrv_errors() - Returns error and warning information about the last SQLSRV operation performed
  • sqlsrv_query() - Prepares and executes a query


Returns error and warning information about the last SQLSRV operation performed

  • ? sqlsrv_connect
  • sqlsrv_execute ?
  • PHP Manual
  • SQLSRV 函数
  • Returns error and warning information about the last SQLSRV operation performed

sqlsrv_errors

(No version information available, might only be in Git)

sqlsrv_errors — Returns error and warning information about the last SQLSRV operation performed

说明

sqlsrv_errors ( int $errorsOrWarnings = ? ) : mixed

Returns error and warning information about the last SQLSRV operation performed.

参数

errorsOrWarnings

Determines whether error information, warning information, or both are returned. If this parameter is not supplied, both error information and warning information are returned. The following are the supported values for this parameter: SQLSRV_ERR_ALL, SQLSRV_ERR_ERRORS, SQLSRV_ERR_WARNINGS.

返回值

If errors and/or warnings occurred on the last sqlsrv operation, an array of arrays containing error information is returned. If no errors and/or warnings occurred on the last sqlsrv operation, null is returned. The following table describes the structure of the returned arrays:

Array returned by sqlsrv_errors
Key | Description
SQLSTATE | For errors that originate from the ODBC driver, the SQLSTATE returned by ODBC. For errors that originate from the Microsoft Drivers for PHP for SQL Server, a SQLSTATE of IMSSP. For warnings that originate from the Microsoft Drivers for PHP for SQL Server, a SQLSTATE of 01SSP.
code | For errors that originate from SQL Server, the native SQL Server error code. For errors that originate from the ODBC driver, the error code returned by ODBC. For errors that originate from the Microsoft Drivers for PHP for SQL Server, the Microsoft Drivers for PHP for SQL Server error code.
message | A description of the error.

范例

Example #1 functionname() example

<?php
$serverName = "serverName/sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

/* Set up a query to select an invalid column name. */
$sql = "SELECT BadColumnName FROM Table_1";

/* Execution of the query will fail because of the bad column name. */
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false ) {
    if( ($errors = sqlsrv_errors() ) != null) {
        foreach( $errors as $error ) {
            echo "SQLSTATE: ".$error[ 'SQLSTATE']."<br />";
            echo "code: ".$error[ 'code']."<br />";
            echo "message: ".$error[ 'message']."<br />";
        }
    }
}
?>

注释

By default, warnings generated on a call to any SQLSRV function are treated as errors. This means that if a warning occurs on a call to a SQLSRV function, the function returns false. However, warnings that correspond to SQLSTATE values 01000, 01001, 01003, and 01S02 are never treated as errors. For information about changing this behavior, see sqlsrv_configure() and the WarningsReturnAsErrors setting.

参见

  • sqlsrv_configure() - Changes the driver error handling and logging configurations


Executes a statement prepared with sqlsrv_prepare

  • ? sqlsrv_errors
  • sqlsrv_fetch_array ?
  • PHP Manual
  • SQLSRV 函数
  • Executes a statement prepared with sqlsrv_prepare

sqlsrv_execute

(No version information available, might only be in Git)

sqlsrv_execute — Executes a statement prepared with sqlsrv_prepare()

说明

sqlsrv_execute ( resource $stmt ) : bool

Executes a statement prepared with sqlsrv_prepare(). This function is ideal for executing a prepared statement multiple times with different parameter values.

参数

stmt

A statement resource returned by sqlsrv_prepare().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sqlsrv_execute() example

This example demonstrates how to prepare a statement with sqlsrv_prepare() and re-execute it multiple times (with different parameter values) using sqlsrv_execute().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1
        SET OrderQty = ?
        WHERE SalesOrderID = ?";

// Initialize parameters and prepare the statement.
// Variables $qty and $id are bound to the statement, $stmt.
$qty = 0; $id = 0;
$stmt = sqlsrv_prepare( $conn, $sql, array( &$qty, &$id));
if( !$stmt ) {
    die( print_r( sqlsrv_errors(), true));
}

// Set up the SalesOrderDetailID and OrderQty information.
// This array maps the order ID to order quantity in key=>value pairs.
$orders = array( 1=>10, 2=>20, 3=>30);

// Execute the statement for each order.
foreach( $orders as $id => $qty) {
    // Because $id and $qty are bound to $stmt1, their updated
    // values are used with each execution of the statement.
    if( sqlsrv_execute( $stmt ) === false ) {
          die( print_r( sqlsrv_errors(), true));
    }
}
?>

注释

When you prepare a statement that uses variables as parameters, the variables are bound to the statement. This means that if you update the values of the variables, the next time you execute the statement it will run with updated parameter values. For statements that you plan to execute only once, use sqlsrv_query().

参见

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_query() - Prepares and executes a query


Returns a row as an array

  • ? sqlsrv_execute
  • sqlsrv_fetch_object ?
  • PHP Manual
  • SQLSRV 函数
  • Returns a row as an array

sqlsrv_fetch_array

(No version information available, might only be in Git)

sqlsrv_fetch_array — Returns a row as an array

说明

sqlsrv_fetch_array ( resource $stmt , int $fetchType = ? , int $row = ? , int $offset = ? ) : array

Returns the next available row of data as an associative array, a numeric array, or both (the default).

参数

stmt

A statement resource returned by sqlsrv_query or sqlsrv_prepare.

fetchType

A predefined constant specifying the type of array to return. Possible values are SQLSRV_FETCH_ASSOC, SQLSRV_FETCH_NUMERIC, and SQLSRV_FETCH_BOTH (the default).

A fetch type of SQLSRV_FETCH_ASSOC should not be used when consuming a result set with multiple columns of the same name.

row

Specifies the row to access in a result set that uses a scrollable cursor. Possible values are SQLSRV_SCROLL_NEXT, SQLSRV_SCROLL_PRIOR, SQLSRV_SCROLL_FIRST, SQLSRV_SCROLL_LAST, SQLSRV_SCROLL_ABSOLUTE and, SQLSRV_SCROLL_RELATIVE (the default). When this parameter is specified, the fetchType must be explicitly defined.

offset

Specifies the row to be accessed if the row parameter is set to SQLSRV_SCROLL_ABSOLUTE or SQLSRV_SCROLL_RELATIVE. Note that the first row in a result set has index 0.

返回值

Returns an array on success, null if there are no more rows to return, and false if an error occurs.

范例

Example #1 Retrieving an associative array.

<?php
$serverName = "serverName\instanceName";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo );
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT FirstName, LastName FROM SomeTable";
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false) {
    die( print_r( sqlsrv_errors(), true) );
}

while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC) ) {
      echo $row['LastName'].", ".$row['FirstName']."<br />";
}

sqlsrv_free_stmt( $stmt);
?>

Example #2 Retrieving a numeric array.

<?php
$serverName = "serverName\instanceName";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo );
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT FirstName, LastName FROM SomeTable";
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false) {
    die( print_r( sqlsrv_errors(), true) );
}

while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_NUMERIC) ) {
      echo $row[0].", ".$row[1]."<br />";
}

sqlsrv_free_stmt( $stmt);
?>

注释

Not specifying the fetchType or explicitly using the SQLSRV_FETCH_TYPE constant in the examples above will return an array that has both associative and numeric keys.

If more than one column is returned with the same name, the last column will take precedence. To avoid field name collisions, use aliases.

If a column with no name is returned, the associative key for the array element will be an empty string ("").

参见

  • sqlsrv_connect() - Opens a connection to a Microsoft SQL Server database
  • sqlsrv_query() - Prepares and executes a query
  • sqlsrv_errors() - Returns error and warning information about the last SQLSRV operation performed
  • sqlsrv_fetch() - Makes the next row in a result set available for reading


Retrieves the next row of data in a result set as an object

  • ? sqlsrv_fetch_array
  • sqlsrv_fetch ?
  • PHP Manual
  • SQLSRV 函数
  • Retrieves the next row of data in a result set as an object

sqlsrv_fetch_object

(No version information available, might only be in Git)

sqlsrv_fetch_object — Retrieves the next row of data in a result set as an object

说明

sqlsrv_fetch_object ( resource $stmt , string $className = ? , array $ctorParams = ? , int $row = ? , int $offset = ? ) : mixed

Retrieves the next row of data in a result set as an instance of the specified class with properties that match the row field names and values that correspond to the row field values.

参数

stmt

A statement resource created by sqlsrv_query() or sqlsrv_execute().

className

The name of the class to instantiate. If no class name is specified, stdClass is instantiated.

ctorParams

Values passed to the constructor of the specified class. If the constructor of the specified class takes parameters, the ctorParams array must be supplied.

row

The row to be accessed. This parameter can only be used if the specified statement was prepared with a scrollable cursor. In that case, this parameter can take on one of the following values:

  • SQLSRV_SCROLL_NEXT
  • SQLSRV_SCROLL_PRIOR
  • SQLSRV_SCROLL_FIRST
  • SQLSRV_SCROLL_LAST
  • SQLSRV_SCROLL_ABSOLUTE
  • SQLSRV_SCROLL_RELATIVE

offset

Specifies the row to be accessed if the row parameter is set to SQLSRV_SCROLL_ABSOLUTE or SQLSRV_SCROLL_RELATIVE. Note that the first row in a result set has index 0.

返回值

Returns an object on success, null if there are no more rows to return, and false if an error occurs or if the specified class does not exist.

范例

Example #1 sqlsrv_fetch_object() example

The following example demonstrates how to retrieve a row as a stdClass object.

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT fName, lName FROM Table_1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Retrieve each row as an object.
// Because no class is specified, each row will be retrieved as a stdClass object.
// Property names correspond to field names.
while( $obj = sqlsrv_fetch_object( $stmt)) {
      echo $obj->fName.", ".$obj->lName."<br />";
}
?>

注释

If a class name is specified with the optional $className parameter and the class has properties whose names match the result set field names, the corresponding result set values are applied to the properties. If a result set field name does not match a class property, a property with the result set field name is added to the object and the result set value is applied to the property. The following rules apply when using the $className parameter:

  • Field-property name matching is case-sensitive.
  • Field-property matching occurs regardless of access modifiers.
  • Class property data types are ignored when applying a field value to a property.
  • If the class does not exist, the function returns false and adds an error to the error collection.
Regardless of whether the $className parameter is supplied, if a field with no name is returned, the field value will be ignored and a warning will be added to the error collection.

When consuming a result set that has multiple columns with the same name, it may be better to use sqlsrv_fetch_array() or the combination of sqlsrv_fetch() and sqlsrv_get_field().

参见

  • sqlsrv_fetch() - Makes the next row in a result set available for reading
  • sqlsrv_fetch_array() - Returns a row as an array


Makes the next row in a result set available for reading

  • ? sqlsrv_fetch_object
  • sqlsrv_field_metadata ?
  • PHP Manual
  • SQLSRV 函数
  • Makes the next row in a result set available for reading

sqlsrv_fetch

(No version information available, might only be in Git)

sqlsrv_fetch — Makes the next row in a result set available for reading

说明

sqlsrv_fetch ( resource $stmt , int $row = ? , int $offset = ? ) : mixed

Makes the next row in a result set available for reading. Use sqlsrv_get_field() to read the fields of the row.

参数

stmt

A statement resource created by executing sqlsrv_query() or sqlsrv_execute().

row

The row to be accessed. This parameter can only be used if the specified statement was prepared with a scrollable cursor. In that case, this parameter can take on one of the following values:

  • SQLSRV_SCROLL_NEXT
  • SQLSRV_SCROLL_PRIOR
  • SQLSRV_SCROLL_FIRST
  • SQLSRV_SCROLL_LAST
  • SQLSRV_SCROLL_ABSOLUTE
  • SQLSRV_SCROLL_RELATIVE

offset

Specifies the row to be accessed if the row parameter is set to SQLSRV_SCROLL_ABSOLUTE or SQLSRV_SCROLL_RELATIVE. Note that the first row in a result set has index 0.

返回值

Returns true if the next row of a result set was successfully retrieved, false if an error occurs, and null if there are no more rows in the result set.

范例

Example #1 sqlsrv_fetch() example

The following example demonstrates how to retrieve a row with sqlsrv_fetch() and get the row fields with sqlsrv_get_field().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Name, Comment
        FROM Table_1
        WHERE ReviewID=1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Make the first (and in this case, only) row of the result set available for reading.
if( sqlsrv_fetch( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

// Get the row fields. Field indices start at 0 and must be retrieved in order.
// Retrieving row fields by name is not supported by sqlsrv_get_field.
$name = sqlsrv_get_field( $stmt, 0);
echo "$name: ";

$comment = sqlsrv_get_field( $stmt, 1);
echo $comment;
?>

参见

  • sqlsrv_get_field() - Gets field data from the currently selected row
  • sqlsrv_fetch_array() - Returns a row as an array
  • sqlsrv_fetch_object() - Retrieves the next row of data in a result set as an object


Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query

  • ? sqlsrv_fetch
  • sqlsrv_free_stmt ?
  • PHP Manual
  • SQLSRV 函数
  • Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query

sqlsrv_field_metadata

(No version information available, might only be in Git)

sqlsrv_field_metadata — Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare() or sqlsrv_query()

说明

sqlsrv_field_metadata ( resource $stmt ) : mixed

Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare() or sqlsrv_query(). sqlsrv_field_metadata() can be called on a statement before or after statement execution.

参数

stmt

The statement resource for which metadata is returned.

返回值

Returns an array of arrays on success. Otherwise, false is returned. Each returned array is described by the following table:

Array returned by sqlsrv_field_metadata
Key | Description
Name | The name of the field.
Type | The numeric value for the SQL type.
Size | The number of characters for fields of character type, the number of bytes for fields of binary type, or null for other types.
Precision | The precision for types of variable precision, null for other types.
Scale | The scale for types of variable scale, null for other types.
Nullable | An enumeration indicating whether the column is nullable, not nullable, or if it is not known.
For more information, see » sqlsrv_field_metadata in the Microsoft SQLSRV documentation.

范例

Example #1 sqlsrv_field_metadata() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"AdventureWorks", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
   die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT * FROM Table_1";
$stmt = sqlsrv_prepare( $conn, $sql );

foreach( sqlsrv_field_metadata( $stmt ) as $fieldMetadata ) {
    foreach( $fieldMetadata as $name => $value) {
       echo "$name: $value<br />";
    }
      echo "<br />";
}
?>

参见

  • sqlsrv_client_info() - Returns information about the client and specified connection


Frees all resources for the specified statement

  • ? sqlsrv_field_metadata
  • sqlsrv_get_config ?
  • PHP Manual
  • SQLSRV 函数
  • Frees all resources for the specified statement

sqlsrv_free_stmt

(No version information available, might only be in Git)

sqlsrv_free_stmt — Frees all resources for the specified statement

说明

sqlsrv_free_stmt ( resource $stmt ) : bool

Frees all resources for the specified statement. The statement cannot be used after sqlsrv_free_stmt() has been called on it. If sqlsrv_free_stmt() is called on an in-progress statement that alters server state, statement execution is terminated and the statement is rolled back.

参数

stmt

The statement for which resources are freed. Note that null is a valid parameter value. This allows the function to be called multiple times in a script.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sqlsrv_free_stmt() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$stmt = sqlsrv_query( $conn, "SELECT * FROM Table_1");
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

/*-------------------------------
     Process query results here.
-------------------------------*/

/* Free the statement resources. */
sqlsrv_free_stmt( $stmt);

?>

注释

The main difference between sqlsrv_free_stmt() and sqlsrv_cancel() is that a statement resource cancelled with sqlsrv_cancel() can be re-executed if it was created with sqlsrv_prepare(). A statement resource cancelled with sqlsrv_free_statement() cannot be re-executed.

参见

  • sqlsrv_cancel() - Cancels a statement


Returns the value of the specified configuration setting

  • ? sqlsrv_free_stmt
  • sqlsrv_get_field ?
  • PHP Manual
  • SQLSRV 函数
  • Returns the value of the specified configuration setting

sqlsrv_get_config

(No version information available, might only be in Git)

sqlsrv_get_config — Returns the value of the specified configuration setting

说明

sqlsrv_get_config ( string $setting ) : mixed

Returns the value of the specified configuration setting.

参数

setting

The name of the setting for which the value is returned. For a list of configurable settings, see sqlsrv_configure().

返回值

Returns the value of the specified setting. If an invalid setting is specified, false is returned.

参见

  • sqlsrv_configure() - Changes the driver error handling and logging configurations


Gets field data from the currently selected row

  • ? sqlsrv_get_config
  • sqlsrv_has_rows ?
  • PHP Manual
  • SQLSRV 函数
  • Gets field data from the currently selected row

sqlsrv_get_field

(No version information available, might only be in Git)

sqlsrv_get_field — Gets field data from the currently selected row

说明

sqlsrv_get_field ( resource $stmt , int $fieldIndex , int $getAsType = ? ) : mixed

Gets field data from the currently selected row. Fields must be accessed in order. Field indices start at 0.

参数

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

fieldIndex

The index of the field to be retrieved. Field indices start at 0. Fields must be accessed in order. i.e. If you access field index 1, then field index 0 will not be available.

getAsType

The PHP data type for the returned field data. If this parameter is not set, the field data will be returned as its default PHP data type. For information about default PHP data types, see » Default PHP Data Types in the Microsoft SQLSRV documentation.

返回值

Returns data from the specified field on success. Returns false otherwise.

范例

Example #1 sqlsrv_get_field() example

The following example demonstrates how to retrieve a row with sqlsrv_fetch() and get the row fields with sqlsrv_get_field().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Name, Comment
        FROM Table_1
        WHERE ReviewID=1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Make the first (and in this case, only) row of the result set available for reading.
if( sqlsrv_fetch( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

// Get the row fields. Field indices start at 0 and must be retrieved in order.
// Retrieving row fields by name is not supported by sqlsrv_get_field.
$name = sqlsrv_get_field( $stmt, 0);
echo "$name: ";

$comment = sqlsrv_get_field( $stmt, 1);
echo $comment;
?>

参见

  • sqlsrv_fetch() - Makes the next row in a result set available for reading
  • sqlsrv_fetch_array() - Returns a row as an array
  • sqlsrv_fetch_object() - Retrieves the next row of data in a result set as an object


Indicates whether the specified statement has rows

  • ? sqlsrv_get_field
  • sqlsrv_next_result ?
  • PHP Manual
  • SQLSRV 函数
  • Indicates whether the specified statement has rows

sqlsrv_has_rows

(No version information available, might only be in Git)

sqlsrv_has_rows — Indicates whether the specified statement has rows

说明

sqlsrv_has_rows ( resource $stmt ) : bool

Indicates whether the specified statement has rows.

参数

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

返回值

Returns true if the specified statement has rows and false if the statement does not have rows or if an error occurred.

范例

Example #1 sqlsrv_has_rows() example

<?php
$server = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" )
$conn = sqlsrv_connect( $server, $connectionInfo );

$stmt = sqlsrv_query( $conn, "SELECT * FROM Table_1");

if ($stmt) {
   $rows = sqlsrv_has_rows( $stmt );
   if ($rows === true)
      echo "There are rows. <br />";
   else
      echo "There are no rows. <br />";
}
?>

参见

  • sqlsrv_num_rows() - Retrieves the number of rows in a result set
  • sqlsrv_query() - Prepares and executes a query


Makes the next result of the specified statement active

  • ? sqlsrv_has_rows
  • sqlsrv_num_fields ?
  • PHP Manual
  • SQLSRV 函数
  • Makes the next result of the specified statement active

sqlsrv_next_result

(No version information available, might only be in Git)

sqlsrv_next_result — Makes the next result of the specified statement active

说明

sqlsrv_next_result ( resource $stmt ) : mixed

Makes the next result of the specified statement active. Results include result sets, row counts, and output parameters.

参数

stmt

The statement on which the next result is being called.

返回值

Returns true if the next result was successfully retrieved, false if an error occurred, and null if there are no more results to retrieve.

范例

Example #1 sqlsrv_next_result() example

The following example executes a batch query that inserts into a table and then selects from the table. This produces two results on the statement: one for the rows affected by the INSERT and one for the rows returned by the SELECT. To get to the rows returned by the SELECT, sqlsrv_next_result() must be called to move past the first result.

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array("Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

$query = "INSERT INTO Table_1 (id, data) VALUES (?,?); SELECT * FROM TABLE_1;";
$params = array(1, "some data");
$stmt = sqlsrv_query($conn, $query, $params);

// Consume the first result (rows affected by INSERT) without calling sqlsrv_next_result.
echo "Rows affected: ".sqlsrv_rows_affected($stmt)."<br />";

// Move to the next result and display results.
$next_result = sqlsrv_next_result($stmt);
if( $next_result ) {
   while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC)){
      echo $row['id'].": ".$row['data']."<br />";
   }
} elseif( is_null($next_result)) {
     echo "No more results.<br />";
} else {
     die(print_r(sqlsrv_errors(), true));
}
?>

参见

  • sqlsrv_query() - Prepares and executes a query
  • sqlsrv_fetch_array() - Returns a row as an array
  • sqlsrv_rows_affected() - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed


Retrieves the number of fields (columns) on a statement

  • ? sqlsrv_next_result
  • sqlsrv_num_rows ?
  • PHP Manual
  • SQLSRV 函数
  • Retrieves the number of fields (columns) on a statement

sqlsrv_num_fields

(No version information available, might only be in Git)

sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement

说明

sqlsrv_num_fields ( resource $stmt ) : mixed

Retrieves the number of fields (columns) on a statement.

参数

stmt

The statement for which the number of fields is returned. sqlsrv_num_fields() can be called on a statement before or after statement execution.

返回值

Returns the number of fields on success. Returns false otherwise.

范例

Example #1 sqlsrv_num_fields() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
   die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT * FROM Table_1";
$stmt = sqlsrv_query($conn, $sql);
if( $stmt === false) {
   die( print_r( sqlsrv_errors(), true));
}

$numFields = sqlsrv_num_fields( $stmt );

while( sqlsrv_fetch( $stmt )) {
   // Iterate through the fields of each row.
   for($i = 0; $i < $numFields; $i++) {
      echo sqlsrv_get_field($stmt, $i)." ";
   }
   echo "<br />";
}
?>

参见

  • sqlsrv_field_metadata() - Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query
  • sqlsrv_fetch() - Makes the next row in a result set available for reading
  • sqlsrv_get_field() - Gets field data from the currently selected row


Retrieves the number of rows in a result set

  • ? sqlsrv_num_fields
  • sqlsrv_prepare ?
  • PHP Manual
  • SQLSRV 函数
  • Retrieves the number of rows in a result set

sqlsrv_num_rows

(No version information available, might only be in Git)

sqlsrv_num_rows — Retrieves the number of rows in a result set

说明

sqlsrv_num_rows ( resource $stmt ) : mixed

Retrieves the number of rows in a result set. This function requires that the statement resource be created with a static or keyset cursor. For more information, see sqlsrv_query(), sqlsrv_prepare(), or » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

参数

stmt

The statement for which the row count is returned. The statement resource must be created with a static or keyset cursor. For more information, see sqlsrv_query(), sqlsrv_prepare(), or » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

返回值

Returns the number of rows retrieved on success and false if an error occurred. If a forward cursor (the default) or dynamic cursor is used, false is returned.

范例

Example #1 sqlsrv_num_rows() example

<?php
$server = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $server, $connectionInfo );

$sql = "SELECT * FROM Table_1";
$params = array();
$options =  array( "Scrollable" => SQLSRV_CURSOR_KEYSET );
$stmt = sqlsrv_query( $conn, $sql , $params, $options );

$row_count = sqlsrv_num_rows( $stmt );

if ($row_count === false)
   echo "Error in retrieveing row count.";
else
   echo $row_count;
?>

参见

  • sqlsrv_has_rows() - Indicates whether the specified statement has rows
  • sqlsrv_rows_affected() - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed


Prepares a query for execution

  • ? sqlsrv_num_rows
  • sqlsrv_query ?
  • PHP Manual
  • SQLSRV 函数
  • Prepares a query for execution

sqlsrv_prepare

(No version information available, might only be in Git)

sqlsrv_prepare — Prepares a query for execution

说明

sqlsrv_prepare ( resource $conn , string $sql , array $params = ? , array $options = ? ) : mixed

Prepares a query for execution. This function is ideal for preparing a query that will be executed multiple times with different parameter values.

参数

conn

A connection resource returned by sqlsrv_connect().

sql

The string that defines the query to be prepared and executed.

params

An array specifying parameter information when executing a parameterized query. Array elements can be any of the following:

  • A literal value
  • A PHP variable
  • An array with this structure: array($value [, $direction [, $phpType [, $sqlType]]])
The following table describes the elements in the array structure above:

Array structure
Element | Description
$value | A literal value, a PHP variable, or a PHP by-reference variable.
$direction (optional) | One of the following SQLSRV constants used to indicate the parameter direction: SQLSRV_PARAM_IN, SQLSRV_PARAM_OUT, SQLSRV_PARAM_INOUT. The default value is SQLSRV_PARAM_IN.
$phpType (optional) | A SQLSRV_PHPTYPE_* constant that specifies PHP data type of the returned value.
$sqlType (optional) | A SQLSRV_SQLTYPE_* constant that specifies the SQL Server data type of the input value.
options

An array specifying query property options. The supported keys are described in the following table:

Query Options
Key | Values | Description
QueryTimeout | A positive integer value. | Sets the query timeout in seconds. By default, the driver will wait indefinitely for results.
SendStreamParamsAtExec | true or false (the default is true) | Configures the driver to send all stream data at execution (true), or to send stream data in chunks (false). By default, the value is set to true. For more information, see sqlsrv_send_stream_data().
Scrollable | SQLSRV_CURSOR_FORWARD, SQLSRV_CURSOR_STATIC, SQLSRV_CURSOR_DYNAMIC, or SQLSRV_CURSOR_KEYSET | See » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

返回值

Returns a statement resource on success and false if an error occurred.

范例

Example #1 sqlsrv_prepare() example

This example demonstrates how to prepare a statement with sqlsrv_prepare() and re-execute it multiple times (with different parameter values) using sqlsrv_execute().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1
        SET OrderQty = ?
        WHERE SalesOrderID = ?";

// Initialize parameters and prepare the statement.
// Variables $qty and $id are bound to the statement, $stmt.
$qty = 0; $id = 0;
$stmt = sqlsrv_prepare( $conn, $sql, array( &$qty, &$id));
if( !$stmt ) {
    die( print_r( sqlsrv_errors(), true));
}

// Set up the SalesOrderDetailID and OrderQty information.
// This array maps the order ID to order quantity in key=>value pairs.
$orders = array( 1=>10, 2=>20, 3=>30);

// Execute the statement for each order.
foreach( $orders as $id => $qty) {
    // Because $id and $qty are bound to $stmt1, their updated
    // values are used with each execution of the statement.
    if( sqlsrv_execute( $stmt ) === false ) {
          die( print_r( sqlsrv_errors(), true));
    }
}
?>

注释

When you prepare a statement that uses variables as parameters, the variables are bound to the statement. This means that if you update the values of the variables, the next time you execute the statement it will run with updated parameter values. For statements that you plan to execute only once, use sqlsrv_query().

参见

  • sqlsrv_execute() - Executes a statement prepared with sqlsrv_prepare
  • sqlsrv_query() - Prepares and executes a query


Prepares and executes a query

  • ? sqlsrv_prepare
  • sqlsrv_rollback ?
  • PHP Manual
  • SQLSRV 函数
  • Prepares and executes a query

sqlsrv_query

(No version information available, might only be in Git)

sqlsrv_query — Prepares and executes a query

说明

sqlsrv_query ( resource $conn , string $sql , array $params = ? , array $options = ? ) : mixed

Prepares and executes a query.

参数

conn

A connection resource returned by sqlsrv_connect().

sql

The string that defines the query to be prepared and executed.

params

An array specifying parameter information when executing a parameterized query. Array elements can be any of the following:

  • A literal value
  • A PHP variable
  • An array with this structure: array($value [, $direction [, $phpType [, $sqlType]]])
The following table describes the elements in the array structure above:

Array structure
Element | Description
$value | A literal value, a PHP variable, or a PHP by-reference variable.
$direction (optional) | One of the following SQLSRV constants used to indicate the parameter direction: SQLSRV_PARAM_IN, SQLSRV_PARAM_OUT, SQLSRV_PARAM_INOUT. The default value is SQLSRV_PARAM_IN.
$phpType (optional) | A SQLSRV_PHPTYPE_* constant that specifies PHP data type of the returned value.
$sqlType (optional) | A SQLSRV_SQLTYPE_* constant that specifies the SQL Server data type of the input value.
options

An array specifying query property options. The supported keys are described in the following table:

Query Options
Key | Values | Description
QueryTimeout | A positive integer value. | Sets the query timeout in seconds. By default, the driver will wait indefinitely for results.
SendStreamParamsAtExec | true or false (the default is true) | Configures the driver to send all stream data at execution (true), or to send stream data in chunks (false). By default, the value is set to true. For more information, see sqlsrv_send_stream_data().
Scrollable | SQLSRV_CURSOR_FORWARD, SQLSRV_CURSOR_STATIC, SQLSRV_CURSOR_DYNAMIC, or SQLSRV_CURSOR_KEYSET | See » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

返回值

Returns a statement resource on success and false if an error occurred.

范例

Example #1 sqlsrv_query() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "INSERT INTO Table_1 (id, data) VALUES (?, ?)";
$params = array(1, "some data");

$stmt = sqlsrv_query( $conn, $sql, $params);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}
?>

注释

For statements that you plan to execute only once, use sqlsrv_query(). If you intend to re-execute a statement with different parameter values, use the combination of sqlsrv_prepare() and sqlsrv_execute().

参见

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_execute() - Executes a statement prepared with sqlsrv_prepare


Rolls back a transaction that was begun with sqlsrv_begin_transaction

  • ? sqlsrv_query
  • sqlsrv_rows_affected ?
  • PHP Manual
  • SQLSRV 函数
  • Rolls back a transaction that was begun with sqlsrv_begin_transaction

sqlsrv_rollback

(No version information available, might only be in Git)

sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction()

说明

sqlsrv_rollback ( resource $conn ) : bool

Rolls back a transaction that was begun with sqlsrv_begin_transaction() and returns the connection to auto-commit mode.

参数

conn

The connection resource returned by a call to sqlsrv_connect().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sqlsrv_rollback() example

The following example demonstrates how to use sqlsrv_begin_transaction() together with sqlsrv_commit() and sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Begin the transaction. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Initialize parameter values. */
$orderId = 1; $qty = 10; $productId = 100;

/* Set up and execute the first query. */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
         VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Set up and execute the second query. */
$sql2 = "UPDATE InventoryTable
         SET Quantity = (Quantity - ?)
         WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* If both queries were successful, commit the transaction. */
/* Otherwise, rollback the transaction. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transaction committed.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transaction rolled back.<br />";
}
?>

参见

  • sqlsrv_begin_transaction() - Begins a database transaction
  • sqlsrv_commit() - Commits a transaction that was begun with sqlsrv_begin_transaction


Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

  • ? sqlsrv_rollback
  • sqlsrv_send_stream_data ?
  • PHP Manual
  • SQLSRV 函数
  • Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

sqlsrv_rows_affected

(No version information available, might only be in Git)

sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

说明

sqlsrv_rows_affected ( resource $stmt ) : int

Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed. For information about the number of rows returned by a SELECT query, see sqlsrv_num_rows().

参数

stmt

The executed statement resource for which the number of affected rows is returned.

返回值

Returns the number of rows affected by the last INSERT, UPDATE, or DELETE query. If no rows were affected, 0 is returned. If the number of affected rows cannot be determined, -1 is returned. If an error occurred, false is returned.

范例

Example #1 sqlsrv_rows_affected() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1 SET data = ? WHERE id = ?";

$params = array("updated data", 1);

$stmt = sqlsrv_query( $conn, $sql, $params);

$rows_affected = sqlsrv_rows_affected( $stmt);
if( $rows_affected === false) {
     die( print_r( sqlsrv_errors(), true));
} elseif( $rows_affected == -1) {
      echo "No information available.<br />";
} else {
      echo $rows_affected." rows were updated.<br />";
}
?>

参见

  • sqlsrv_num_rows() - Retrieves the number of rows in a result set


Sends data from parameter streams to the server

  • ? sqlsrv_rows_affected
  • sqlsrv_server_info ?
  • PHP Manual
  • SQLSRV 函数
  • Sends data from parameter streams to the server

sqlsrv_send_stream_data

(No version information available, might only be in Git)

sqlsrv_send_stream_data — Sends data from parameter streams to the server

说明

sqlsrv_send_stream_data ( resource $stmt ) : bool

Send data from parameter streams to the server. Up to 8 KB of data is sent with each call.

参数

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

返回值

Returns true if there is more data to send and false if there is not.

范例

Example #1 sqlsrv_send_stream_data() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1 SET data = ( ?) WHERE id = 100";

// Open parameter data as a stream and put it in the $params array.
$data = fopen( "data://text/plain,[ Lengthy content here. ]", "r");
$params = array( &$data);

// Prepare the statement. Use the $options array to turn off the
// default behavior, which is to send all stream data at the time of query
// execution.
$options = array("SendStreamParamsAtExec"=>0);
$stmt = sqlsrv_prepare( $conn, $sql, $params, $options);

sqlsrv_execute( $stmt);

// Send up to 8K of parameter data to the server
// with each call to sqlsrv_send_stream_data.
$i = 1;
while( sqlsrv_send_stream_data( $stmt)) {
      $i++;
}
echo "$i calls were made.";
?>

参见

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_query() - Prepares and executes a query


Returns information about the server

  • ? sqlsrv_send_stream_data
  • tokyo_tyrant ?
  • PHP Manual
  • SQLSRV 函数
  • Returns information about the server

sqlsrv_server_info

(No version information available, might only be in Git)

sqlsrv_server_info — Returns information about the server

说明

sqlsrv_server_info ( resource $conn ) : array

Returns information about the server.

参数

conn

The connection resource that connects the client and the server.

返回值

Returns an array as described in the following table:

Returned Array
CurrentDatabase | The connected-to database.
SQLServerVersion | The SQL Server version.
SQLServerName | The name of the server.

范例

Example #1 sqlsrv_server_info() example

<?php
$serverName = "serverName\sqlexpress";
$conn = sqlsrv_connect( $serverName);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$server_info = sqlsrv_server_info( $conn);
if( $server_info )
{
    foreach( $server_info as $key => $value) {
       echo $key.": ".$value."<br />";
    }
} else {
      die( print_r( sqlsrv_errors(), true));
}
?>

参见

  • sqlsrv_client_info() - Returns information about the client and specified connection


tokyo_tyrant

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • TokyoTyrant — The TokyoTyrant class
    • TokyoTyrant::add — Adds to a numeric key
    • TokyoTyrant::connect — Connect to a database
    • TokyoTyrant::connectUri — Connects to a database
    • TokyoTyrant::__construct — Construct a new TokyoTyrant object
    • TokyoTyrant::copy — Copies the database
    • TokyoTyrant::ext — Execute a remote script
    • TokyoTyrant::fwmKeys — Returns the forward matching keys
    • TokyoTyrant::get — The get purpose
    • TokyoTyrant::getIterator — Get an iterator
    • TokyoTyrant::num — Number of records in the database
    • TokyoTyrant::out — Removes records
    • TokyoTyrant::put — Puts values
    • TokyoTyrant::putCat — Concatenates to a record
    • TokyoTyrant::putKeep — Puts a record
    • TokyoTyrant::putNr — Puts value
    • TokyoTyrant::putShl — Concatenates to a record
    • TokyoTyrant::restore — Restore the database
    • TokyoTyrant::setMaster — Set the replication master
    • TokyoTyrant::size — Returns the size of the value
    • TokyoTyrant::stat — Get statistics
    • TokyoTyrant::sync — Synchronize the database
    • TokyoTyrant::tune — Tunes connection values
    • TokyoTyrant::vanish — Empties the database
  • TokyoTyrantTable — The TokyoTyrantTable class
    • TokyoTyrantTable::add — Adds a record
    • TokyoTyrantTable::genUid — Generate unique id
    • TokyoTyrantTable::get — Get a row
    • TokyoTyrantTable::getIterator — Get an iterator
    • TokyoTyrantTable::getQuery — Get a query object
    • TokyoTyrantTable::out — Remove records
    • TokyoTyrantTable::put — Store a row
    • TokyoTyrantTable::putCat — Concatenates to a row
    • TokyoTyrantTable::putKeep — Put a new record
    • TokyoTyrantTable::putNr — Puts value
    • TokyoTyrantTable::putShl — Concatenates to a record
    • TokyoTyrantTable::setIndex — Sets index
  • TokyoTyrantQuery — The TokyoTyrantQuery class
    • TokyoTyrantQuery::addCond — Adds a condition to the query
    • TokyoTyrantQuery::__construct — Construct a new query
    • TokyoTyrantQuery::count — Counts records
    • TokyoTyrantQuery::current — Returns the current element
    • TokyoTyrantQuery::hint — Get the hint string of the query
    • TokyoTyrantQuery::key — Returns the current key
    • TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries
    • TokyoTyrantQuery::next — Moves the iterator to next entry
    • TokyoTyrantQuery::out — Removes records based on query
    • TokyoTyrantQuery::rewind — Rewinds the iterator
    • TokyoTyrantQuery::search — Searches records
    • TokyoTyrantQuery::setLimit — Limit results
    • TokyoTyrantQuery::setOrder — Orders results
    • TokyoTyrantQuery::valid — Checks the validity of current item
  • TokyoTyrantIterator — The TokyoTyrantIterator class
    • TokyoTyrantIterator::__construct — Construct an iterator
    • TokyoTyrantIterator::current — Get the current value
    • TokyoTyrantIterator::key — Returns the current key
    • TokyoTyrantIterator::next — Move to next key
    • TokyoTyrantIterator::rewind — Rewinds the iterator
    • TokyoTyrantIterator::valid — Rewinds the iterator
  • TokyoTyrantException — The TokyoTyrantException class


简介

tokyo_tyrant extension provides a wrapper for Tokyo Tyrant client libraries. The extension contains the normal key-value API and the table API.

"Tokyo Tyrant is a package of network interface to the DBM called Tokyo Cabinet. Though the DBM has high performance, you might bother in case that multiple processes share the same database, or remote processes access the database. Thus, Tokyo Tyrant is provided for concurrent and remote connections to Tokyo Cabinet. It is composed of the server process managing a database and its access library for client applications." --Tokyo Tyrant documentation

Tokyo Tyrant is written by Mikio Hirabayashi and is licensed under GNU Lesser General Public License.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • tokyo_tyrant
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

Before using this extension Tokyo Cabinet and Tokyo Tyrant must be installed.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/tokyo_tyrant

Configure options

  • --with-tokyo-tyrant[=DIR] DIR is the prefix to the Tokyo Tyrant installation
  • --with-tokyo-cabinet-dir[=DIR] DIR is the prefix to the Tokyo Cabinet installation
  • --disable-tokyo-tyrant-session Disable Tokyo Tyrant session handler support

Enabling the extension

The extension can be enabled by adding extension=tokyo_tyrant.so to the INI-configuration

Running Tokyo Tyrant for the session handler

ttserver -port 2000 -ext /path/to/expire.lua -extpc expire 30.0 '/tmp/sessions.tct#idx=ts:dec'

Note: expire.lua is included in the tokyo_tyrant extension source distribution

Configuring session handler

  • tokyo_tyrant.session_salt="randomlongstring"
  • session.save_handler=tokyo_tyrant
  • session.save_path="tcp://hostname1:2000,tcp://hostname2:2000"

Note: It is important to make sure that tokyo_tyrant.session_salt matches on all servers.

How it works?

The session handler creates a session id like the following: 8b0e27a823fa4a6cf7246945b82c1d51-a5eadbbed1f2075952900628456bfd6830541629-0-5460

The parts from left to right:

  • Session id - Generated session id
  • Checksum - Checksum of session salt, session id, node id and primary key
  • Node id - The id of the node where the session maps to
  • Primary key - The primary key of the row where the session is stored

The checksum contains SHA1 sum of the node id, primary key, session id and the salt which is known only on the server side. This allows quick mapping of session id to node and primary key since there is no need to do an additional search. During session id regeneration only the parts 1 and 2 change but the mapping to the node and primary key stays constant.

In case some of the nodes fail tokyo_tyrant.allow_failover, tokyo_tyrant.fail_threshold and tokyo_tyrant.health_check_divisor INI-settings control the behavior during failover. If failover is allowed the session handler will map the session to a healthy node and creates a new empty session.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

tokyo_tyrant 配置选项
名字 | 默认 | 可修改范围 | 更新日志
tokyo_tyrant.default_timeout | 2.0 | PHP_INI_ALL |
tokyo_tyrant.session_salt | null | PHP_INI_ALL |
tokyo_tyrant.key_prefix | null | PHP_INI_ALL |
tokyo_tyrant.allow_failover | 1 | PHP_INI_ALL |
tokyo_tyrant.fail_threshold | 5 | PHP_INI_ALL |
tokyo_tyrant.health_check_divisor | 1000 | PHP_INI_ALL |
tokyo_tyrant.php_expiration | 0 | PHP_INI_ALL |

这是配置指令的简短说明。

tokyo_tyrant.default_timeout int

Default timeout when connecting to databases

tokyo_tyrant.session_salt string

The secret that is used to salt session id

tokyo_tyrant.key_prefix string

Prefix all keys with this string. The prefix is transparent to the developer but helps making sure that keys won't collide if multiple applications are using the same database.

tokyo_tyrant.allow_failover int

Whether to allow session failover in case a server dies.

tokyo_tyrant.fail_threshold int

How many read/write or connection failures is allowed before server is marked as failed.

tokyo_tyrant.health_check_divisor int

Defines the divisor for the health check probability. If there are failed servers and the probability matches, the servers are health checked and in case the server seems healthy, it will be added back to the pool.

tokyo_tyrant.php_expiration int

Whether to use built in session expiration mechanism or delegate the expiration to a lua-script on the server-side.


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • tokyo_tyrant
  • 预定义常量

预定义常量

TokyoTyrant constants


范例

Basic usage

Example #1 Putting and getting a key-value pair

<?php
$tt = new TokyoTyrant("localhost");
$tt->put("key", "value");
echo $tt->get("key");
?>

以上例程会输出：

value


The TokyoTyrant class

(PECL tokyo_tyrant >= 0.1.0)

简介

The main Tokyo Tyrant class

类摘要

TokyoTyrant {
/* 常量 */
const int RDBDEF_PORT = 1978 ;
const int RDBQC_STREQ = 0 ;
const int RDBQC_STRINC = 1 ;
const int RDBQC_STRBW = 2 ;
const int RDBQC_STREW = 3 ;
const int RDBQC_STRAND = 4 ;
const int RDBQC_STROR = 5 ;
const int RDBQC_STROREQ = 6 ;
const int RDBQC_STRRX = 7 ;
const int RDBQC_NUMEQ = 8 ;
const int RDBQC_NUMGT = 9 ;
const int RDBQC_NUMGE = 10 ;
const int RDBQC_NUMLT = 11 ;
const int RDBQC_NUMLE = 12 ;
const int RDBQC_NUMBT = 13 ;
const int RDBQC_NUMOREQ = 14 ;
const int RDBQC_NEGATE = 16777216 ;
const int RDBQC_NOIDX = 33554432 ;
const int RDBQO_STRASC = 0 ;
const int RDBQO_STRDESC = 1 ;
const int RDBQO_NUMASC = 2 ;
const int RDBQO_NUMDESC = 3 ;
const int RDBIT_LEXICAL = 0 ;
const int RDBIT_DECIMAL = 1 ;
const int RDBIT_TOKEN = 2 ;
const int RDBIT_QGRAM = 3 ;
const int RDBIT_OPT = 9998 ;
const int RDBIT_VOID = 9999 ;
const int RDBIT_KEEP = 16777216 ;
const int RDBQCFTS_PH = 15 ;
const int RDBQCFTS_AND = 16 ;
const int RDBQCFTS_OR = 17 ;
const int RDBQCFTS_EX = 18 ;
const int RDBXO_LCKREC = 1 ;
const int RDBXOLCK_GLB = 2 ;
const int RDBREC_INT = 1 ;
const int RDBREC_DBL = 2 ;
const int RDBMS_UNION = 0 ;
const int RDBMS_ISECT = 1 ;
const int RDBMS_DIFF = 2 ;
const int RDBT_RECON = 1 ;
/* 方法 */
public add ( string $key , int|float $increment , int $type = 0 ) : int|float
public connect ( string $host , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? ) : TokyoTyrant
public connectUri ( string $uri ) : TokyoTyrant
public __construct ( string $host = ? , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? )
public copy ( string $path ) : TokyoTyrant
public ext ( string $name , int $options , string $key , string $value ) : string
public fwmKeys ( string $prefix , int $max_recs ) : array
public get ( mixed $keys ) : mixed
public getIterator ( ) : TokyoTyrantIterator
public num ( ) : int
public out ( mixed $keys ) : TokyoTyrant
public put ( mixed $keys , string $value = NULL ) : TokyoTyrant
public putCat ( mixed $keys , string $value = ? ) : TokyoTyrant
public putKeep ( mixed $keys , string $value = ? ) : TokyoTyrant
public putNr ( mixed $keys , string $value = NULL ) : TokyoTyrant
public putShl ( string $key , string $value , int $width ) : mixed
public restore ( string $log_dir , int $timestamp , bool $check_consistency = true ) : mixed
public setMaster ( string $host , int $port , int $timestamp , bool $check_consistency = true ) : mixed
public size ( string $key ) : int
public stat ( ) : array
public sync ( ) : mixed
public tune ( float $timeout , int $options = TokyoTyrant::RDBT_RECON ) : TokyoTyrant
public vanish ( ) : mixed
}

预定义常量

TokyoTyrant Constants

TokyoTyrant::RDBDEF_PORT

The default port of the Tokyo Tyrant database

TokyoTyrant::RDBQC_STREQ

string is equal to

TokyoTyrant::RDBQC_STRINC

string is included in

TokyoTyrant::RDBQC_STRBW

string begins with

TokyoTyrant::RDBQC_STREW

string ends with

TokyoTyrant::RDBQC_STRAND

string includes all tokens in

TokyoTyrant::RDBQC_STROR

string includes at least one token in

TokyoTyrant::RDBQC_STROREQ

string is equal to at least one token in

TokyoTyrant::RDBQC_STRRX

string matches regular expressions of

TokyoTyrant::RDBQC_NUMEQ

number is equal to

TokyoTyrant::RDBQC_NUMGT

number is greater than

TokyoTyrant::RDBQC_NUMGE

number is greater than or equal to

TokyoTyrant::RDBQC_NUMLT

number is less than

TokyoTyrant::RDBQC_NUMLE

number is less than or equal to

TokyoTyrant::RDBQC_NUMBT

number is between two tokens of

TokyoTyrant::RDBQC_NUMOREQ

number is equal to at least one token in

TokyoTyrant::RDBQC_NEGATE

negation flag

TokyoTyrant::RDBQC_NOIDX

no index flag

TokyoTyrant::RDBQO_STRASC

string ascending

TokyoTyrant::RDBQO_STRDESC

string descending

TokyoTyrant::RDBQO_NUMASC

number ascending

TokyoTyrant::RDBQO_NUMDESC

number descending

TokyoTyrant::RDBIT_LEXICAL

lexical string

TokyoTyrant::RDBIT_DECIMAL

decimal string

TokyoTyrant::RDBIT_TOKEN

token inverted index (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBIT_QGRAM

QGRAM inverted index (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBIT_OPT

optimize

TokyoTyrant::RDBIT_VOID

void

TokyoTyrant::RDBIT_KEEP

keep existing index

TokyoTyrant::RDBQCFTS_PH

full-text search with the phrase of (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_AND

full-text search with all tokens in (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_OR

full-text search with at least one token in (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_EX

full-text search with the compound expression of (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_AND

Metasearch union between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBQCFTS_OR

Metasearch intersection between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBQCFTS_EX

Metasearch difference between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBT_RECON

Whether to reconnect on connection failure. It is recommended to have this parameter on for persistent connections

TokyoTyrant::RDBXOLCK_REC

record locking

TokyoTyrant::RDBXOLCK_GLB

global locking

TokyoTyrant::RDBREC_INT

record type int

TokyoTyrant::RDBREC_DBL

record type float (double)

TokyoTyrant::TTE_SUCCESS

success

TokyoTyrant::TTE_INVALID

invalid operation

TokyoTyrant::TTE_NOHOST

host not found

TokyoTyrant::TTE_REFUSED

connection refused

TokyoTyrant::TTE_SEND

send error

TokyoTyrant::TTE_RECV

recv error

TokyoTyrant::TTE_KEEP

record exist

TokyoTyrant::TTE_NOREC

no record found

TokyoTyrant::TTE_MISC

miscellaneous error

Table of Contents

  • TokyoTyrant::add — Adds to a numeric key
  • TokyoTyrant::connect — Connect to a database
  • TokyoTyrant::connectUri — Connects to a database
  • TokyoTyrant::__construct — Construct a new TokyoTyrant object
  • TokyoTyrant::copy — Copies the database
  • TokyoTyrant::ext — Execute a remote script
  • TokyoTyrant::fwmKeys — Returns the forward matching keys
  • TokyoTyrant::get — The get purpose
  • TokyoTyrant::getIterator — Get an iterator
  • TokyoTyrant::num — Number of records in the database
  • TokyoTyrant::out — Removes records
  • TokyoTyrant::put — Puts values
  • TokyoTyrant::putCat — Concatenates to a record
  • TokyoTyrant::putKeep — Puts a record
  • TokyoTyrant::putNr — Puts value
  • TokyoTyrant::putShl — Concatenates to a record
  • TokyoTyrant::restore — Restore the database
  • TokyoTyrant::setMaster — Set the replication master
  • TokyoTyrant::size — Returns the size of the value
  • TokyoTyrant::stat — Get statistics
  • TokyoTyrant::sync — Synchronize the database
  • TokyoTyrant::tune — Tunes connection values
  • TokyoTyrant::vanish — Empties the database


Adds to a numeric key

  • ? TokyoTyrant
  • TokyoTyrant::connect ?
  • PHP Manual
  • TokyoTyrant
  • Adds to a numeric key

TokyoTyrant::add

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::add — Adds to a numeric key

说明

public TokyoTyrant::add ( string $key , int|float $increment , int $type = 0 ) : int|float

Adds to an int or double value. This increments the value by the given amount and returns the new value. If the key does not exist a new key is created with initial value of the increment parameter.

参数

key

The string key

increment

The amount to increment

type

TokyoTyrant::RDBREC_INT or TokyoTyrant::RDBREC_DBL constant. If this parameter is omitted the type is guessed from the increment parameters type.

返回值

Returns the new value on success

范例

Example #1 TokyoTyrant::add() example

<?php
$tt = new TokyoTyrant("localhost", TokyoTyrant::RDBDEF_PORT);
/* Adds integer 3 to key and creates a new key */
$tt->add("test", 3);

/* String value is converted to double */
echo $tt->add("test", "3.5", TokyoTyrant::RDBREC_DBL);
?>

以上例程的输出类似于：

6.5

参见

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putcat() - Concatenates to a record
  • TokyoTyrant::putkeep() - Puts a record


Connect to a database

  • ? TokyoTyrant::add
  • TokyoTyrant::connectUri ?
  • PHP Manual
  • TokyoTyrant
  • Connect to a database

TokyoTyrant::connect

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::connect — Connect to a database

说明

public TokyoTyrant::connect ( string $host , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? ) : TokyoTyrant

Connects to a remote database

参数

host

The hostname

port

The port. Default: 1978

options

Connection options: timeout (default: 5.0), reconnect (default: true) and persistent (default: true)

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::connect() example

<?php
$tt = new TokyoTyrant();
$tt->connect("localhost", TokyoTyrant::RDBDEF_PORT)->put("test", "value");
?>

参见

  • TokyoTyrant::connectUri() - Connects to a database


Connects to a database

  • ? TokyoTyrant::connect
  • TokyoTyrant::__construct ?
  • PHP Manual
  • TokyoTyrant
  • Connects to a database

TokyoTyrant::connectUri

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::connectUri — Connects to a database

说明

public TokyoTyrant::connectUri ( string $uri ) : TokyoTyrant

Connects to a database using an uri

参数

uri

An URI to the database. For example tcp://localhost:1979/

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::connectUri() example

<?php
$tt = new TokyoTyrant();
$tt->connectUri("tcp://localhost:1978/")->put("test", "hi");
?>

参见

  • TokyoTyrant::connect() - Connect to a database


Construct a new TokyoTyrant object

  • ? TokyoTyrant::connectUri
  • TokyoTyrant::copy ?
  • PHP Manual
  • TokyoTyrant
  • Construct a new TokyoTyrant object

TokyoTyrant::__construct

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::__construct — Construct a new TokyoTyrant object

说明

public TokyoTyrant::__construct ( string $host = ? , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? )

Constructs a new TokyoTyrant object and optionally connects to the database

参数

host

The hostname. Default: null

port

port number. Default: 1978

options

Connection options: timeout (default: 5.0), reconnect (default: true) and persistent (default: true)

返回值

Throws TokyoTyrantException if connection to database fails

参见

  • TokyoTyrant::connect() - Connect to a database
  • TokyoTyrant::connectUri() - Connects to a database


Copies the database

  • ? TokyoTyrant::__construct
  • TokyoTyrant::ext ?
  • PHP Manual
  • TokyoTyrant
  • Copies the database

TokyoTyrant::copy

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::copy — Copies the database

说明

public TokyoTyrant::copy ( string $path ) : TokyoTyrant

Makes a copy of the current database

参数

path

Path to where to copy the database. The user running the remote database must have a write access to the directory.

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::copy() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
$tt->copy("/tmp/foobar.tct");
?>

参见

  • TokyoTyrant::restore() - Restore the database


Execute a remote script

  • ? TokyoTyrant::copy
  • TokyoTyrant::fwmKeys ?
  • PHP Manual
  • TokyoTyrant
  • Execute a remote script

TokyoTyrant::ext

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::ext — Execute a remote script

说明

public TokyoTyrant::ext ( string $name , int $options , string $key , string $value ) : string

Executes a remote script extension.

参数

name

Name of the function to execute

options

Either TokyoTyrant::RDBXO_LCKREC for record locking and TokyoTyrant::RDBXO_LCKGLB for global locking.

key

The key to pass to the function

value

The value to pass to the function

返回值

Returns the result of the script function

范例

Example #1 TokyoTyrant::ext() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
echo $tt->ext("somefunc", TokyoTyrant::RDBXO_LCKREC, "some_key", "some_value");
?>


Returns the forward matching keys

  • ? TokyoTyrant::ext
  • TokyoTyrant::get ?
  • PHP Manual
  • TokyoTyrant
  • Returns the forward matching keys

TokyoTyrant::fwmKeys

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::fwmKeys — Returns the forward matching keys

说明

public TokyoTyrant::fwmKeys ( string $prefix , int $max_recs ) : array

Returns the forward matching keys from the database

参数

prefix

Prefix of the keys

max_recs

Maximum records to return

返回值

Returns an array of matching keys. The values are not returned

范例

Example #1 TokyoTyrant::fwmKeys() example

<?php

$tt = new TokyoTyrant("localhost");

/* Create 20 macthing keys */
for ($i = 0; $i < 20; $i++) {
    $tt->put("key_" . $i, "value_" . $i);
}

/* Create 20 non-macthing keys */
for ($i = 0; $i < 20; $i++) {
    $tt->put("something_" . $i, "data_" . $i);
}

/* Get five matching keys */
var_dump($tt->fwmKeys("key_", 5));
?>

以上例程的输出类似于：

array(5) {
  [0]=>
  string(5) "key_5"
  [1]=>
  string(6) "key_14"
  [2]=>
  string(5) "key_6"
  [3]=>
  string(6) "key_15"
  [4]=>
  string(5) "key_7"
}


The get purpose

  • ? TokyoTyrant::fwmKeys
  • TokyoTyrant::getIterator ?
  • PHP Manual
  • TokyoTyrant
  • The get purpose

TokyoTyrant::get

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::get — The get purpose

说明

public TokyoTyrant::get ( mixed $keys ) : mixed

This method is used to return a value or multiple values. This method accepts a string or an array as a value.

参数

keys

A string key or an array of string keys

返回值

Returns a string or an array based on the given parameters. Throws a TokyoTyrantException on error. If string is passed null is returned if the key is not found. In case an array is given as an parameter only existing keys will be returned. It is not an error to pass a key that does not exist.

范例

Example #1 TokyoTyrant::get() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
$tt->put("key1", "value1");
$tt->put("key2", "value2");
var_dump($tt->get(array("key1", "key2")));
var_dump($tt->get("key1"));
?>

以上例程会输出：

array(2) {
  ["key1"]=>
  string(6) "value1"
  ["key2"]=>
  string(6) "value2"
}
string(6) "value1"

参见

  • TokyoTyrant::put() - Puts values


Get an iterator

  • ? TokyoTyrant::get
  • TokyoTyrant::num ?
  • PHP Manual
  • TokyoTyrant
  • Get an iterator

TokyoTyrant::getIterator

(No version information available, might only be in Git)

TokyoTyrant::getIterator — Get an iterator

说明

public TokyoTyrant::getIterator ( ) : TokyoTyrantIterator

Gets an iterator for iterating all keys / values in the database.

参数

此函数没有参数。

返回值

This method returns TokyoTyrantIterator object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::getIterator() example

<?php
$tt = new TokyoTyrant("localhost");
$it = $tt->getIterator();

foreach ($it as $k => $v) {

}
?>

参见

  • TokyoTyrantTable::getQuery() - Get a query object
  • TokyoTyrantTable::getIterator() - Get an iterator


Number of records in the database

  • ? TokyoTyrant::getIterator
  • TokyoTyrant::out ?
  • PHP Manual
  • TokyoTyrant
  • Number of records in the database

TokyoTyrant::num

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::num — Number of records in the database

说明

public TokyoTyrant::num ( ) : int

Returns the number of records in the database

参数

此函数没有参数。

返回值

Returns number of records in the database

范例

Example #1 TokyoTyrant::num() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Echo the number of records */
echo $tt->num();
?>

以上例程的输出类似于：

1234

参见

  • TokyoTyrant::stat() - Get statistics


Removes records

  • ? TokyoTyrant::num
  • TokyoTyrant::put ?
  • PHP Manual
  • TokyoTyrant
  • Removes records

TokyoTyrant::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::out — Removes records

说明

public TokyoTyrant::out ( mixed $keys ) : TokyoTyrant

Removes a record or multiple records. This method accepts a string for a single key or an array of keys for multiple records.

参数

keys

A string key or an array of string keys

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::out() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

$tt->put("test1", "value1");
$tt->put("test2", "value2");

$tt->out(array("test1", "test2"));
?>

参见

  • TokyoTyrant::put() - Puts values


Puts values

  • ? TokyoTyrant::out
  • TokyoTyrant::putCat ?
  • PHP Manual
  • TokyoTyrant
  • Puts values

TokyoTyrant::put

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::put — Puts values

说明

public TokyoTyrant::put ( mixed $keys , string $value = NULL ) : TokyoTyrant

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. If the key exists the value will be replaced with new value.

参数

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

返回值

This method returns a reference to the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::put() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Put single key-value pair */
$tt->put("key", "value");

/* Put key-value pairs, new value overwrites the old */
$tt->put(array("key1" => "value1", "key" => "value2"));

/* Get back one key */
echo $tt->get("key");
?>

以上例程会输出：

value2

参见

  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record


Concatenates to a record

  • ? TokyoTyrant::put
  • TokyoTyrant::putKeep ?
  • PHP Manual
  • TokyoTyrant
  • Concatenates to a record

TokyoTyrant::putCat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putCat — Concatenates to a record

说明

public TokyoTyrant::putCat ( mixed $keys , string $value = ? ) : TokyoTyrant

Appends a value into existing key or multiple values if keys is an array. The second parameter is mandatory if keys is a string. If the record does not exist a new record is created.

参数

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

返回值

This method returns a reference to the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::putCat() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "value");

/* Concatenate single key-value pair */
$tt->putCat("key", " has more data");

/* Echo the key */
echo $tt->get("key");
?>

以上例程会输出：

value has more data

参见

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record


Puts a record

  • ? TokyoTyrant::putCat
  • TokyoTyrant::putNr ?
  • PHP Manual
  • TokyoTyrant
  • Puts a record

TokyoTyrant::putKeep

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putKeep — Puts a record

说明

public TokyoTyrant::putKeep ( mixed $keys , string $value = ? ) : TokyoTyrant

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. If the key already exists this method throws an exception indicating that the records exists.

参数

keys

A string key or an array of key-value pairs

value

The string value

返回值

This method returns a reference to the current object and throws TokyoTyrantException on failure.

范例

Example #1 tokyotyrant::putKeep() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "value");

try {
    $tt->putKeep("key", "new value");
} catch (TokyoTyrantException $e) {
    if ($e->getCode() === TokyoTyrant::TTE_KEEP) {
        echo "Existing record! Not modified\n";
    } else {
        echo "Error: " , $e->getMessage() , "\n";
    }
}
echo $tt->get("key");
?>

以上例程会输出：

Existing record! Not modified
value

参见

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putCat() - Concatenates to a record


Puts value

  • ? TokyoTyrant::putKeep
  • TokyoTyrant::putShl ?
  • PHP Manual
  • TokyoTyrant
  • Puts value

TokyoTyrant::putNr

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putNr — Puts value

说明

public TokyoTyrant::putNr ( mixed $keys , string $value = NULL ) : TokyoTyrant

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. This method does not wait for the response from the server.

参数

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

返回值

This method returns a reference to the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::putNr() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Put single key-value pair */
$tt->putNr("key", "value");

/* Put key-value pairs */
$tt->putNr(array("key1" => "value1", "key2" => "value2"));

/* Get back one key */
echo $tt->get("key1");
?>

以上例程会输出：

value1

参见

  • TokyoTyrant::putNr()
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record


Concatenates to a record

  • ? TokyoTyrant::putNr
  • TokyoTyrant::restore ?
  • PHP Manual
  • TokyoTyrant
  • Concatenates to a record

TokyoTyrant::putShl

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putShl — Concatenates to a record

说明

public TokyoTyrant::putShl ( string $key , string $value , int $width ) : mixed

Concatenate to a record and shift to left.

参数

key

A string key

value

The value to concatenate

width

The width of the record

返回值

This method returns a reference to the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::putShl() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "just a long piece of data");

/* Concatenate and shift to left */
$tt->putShl("key", " and string", 15);

/* Echo the key */
echo $tt->get("key");
?>

以上例程会输出：

data and string

参见

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record


Restore the database

  • ? TokyoTyrant::putShl
  • TokyoTyrant::setMaster ?
  • PHP Manual
  • TokyoTyrant
  • Restore the database

TokyoTyrant::restore

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::restore — Restore the database

说明

public TokyoTyrant::restore ( string $log_dir , int $timestamp , bool $check_consistency = true ) : mixed

Restore the database from the update log.

Warning

This method is not supported on 32bit platforms.

参数

log_dir

Directory where the log is

timestamp

Beginning timestamp with microseconds

check_consistency

Whether to check consistency: Default: true

返回值

This method returns the current object and throws TokyoTyrantException on failure.


Set the replication master

  • ? TokyoTyrant::restore
  • TokyoTyrant::size ?
  • PHP Manual
  • TokyoTyrant
  • Set the replication master

TokyoTyrant::setMaster

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::setMaster — Set the replication master

说明

public TokyoTyrant::setMaster ( string $host , int $port , int $timestamp , bool $check_consistency = true ) : mixed

Sets the replication master of the database

Warning

This method is not supported on 32bit platforms.

参数

host

Hostname of the replication master. If null the replication is disabled.

port

Port of the replication master

timestamp

Beginning timestamp with microseconds

check_consistency

Whether to check consistency.

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::setMaster() example

<?php
/* Connect to a database */
$tt = new TokyoTyrant("tokyotyrant.example.com");

/* Disable the replication */
$tt->setMaster(NULL, 0, 0);
?>

参见

  • Classname::Method()


Returns the size of the value

  • ? TokyoTyrant::setMaster
  • TokyoTyrant::stat ?
  • PHP Manual
  • TokyoTyrant
  • Returns the size of the value

TokyoTyrant::size

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::size — Returns the size of the value

说明

public TokyoTyrant::size ( string $key ) : int

Returns the size of a value by key

参数

key

The key of which size to fetch

返回值

Returns the size of the key or throw TokyoTyrantException on error

范例

Example #1 TokyoTyrant::size() example

<?php
$tt = new TokyoTyrant("localhost");

$tt->put("test_key", "12345");

echo $tt->size("test_key");
?>

以上例程会输出：

5


Get statistics

  • ? TokyoTyrant::size
  • TokyoTyrant::sync ?
  • PHP Manual
  • TokyoTyrant
  • Get statistics

TokyoTyrant::stat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::stat — Get statistics

说明

public TokyoTyrant::stat ( ) : array

Returns statistics of the remote database

参数

此函数没有参数。

返回值

Returns an array of key value pairs describing the statistics

范例

Example #1 TokyoTyrant::stat() example

<?php
$tt = new TokyoTyrant("localhost");

var_dump($tt->stat());
?>

以上例程的输出类似于：

array(19) {
  ["version"]=>
  string(6) "1.1.28"
  ["libver"]=>
  string(3) "311"
  ["protver"]=>
  string(4) "0.91"
  ["os"]=>
  string(5) "Linux"
  ["time"]=>
  string(17) "1247358357.665630"
  ["pid"]=>
  string(5) "14348"
  ["sid"]=>
  string(8) "59025947"
  ["type"]=>
  string(9) "on-memory"
  ["path"]=>
  string(1) "*"
  ["rnum"]=>
  string(1) "4"
  ["size"]=>
  string(6) "262856"
  ["bigend"]=>
  string(1) "0"
  ["fd"]=>
  string(1) "5"
  ["loadavg"]=>
  string(8) "0.000000"
  ["memsize"]=>
  string(8) "77328384"
  ["memrss"]=>
  string(7) "1183744"
  ["ru_real"]=>
  string(13) "162776.042152"
  ["ru_user"]=>
  string(8) "0.476029"
  ["ru_sys"]=>
  string(8) "8.652540"
}

参见

  • Classname::Method()


Synchronize the database

  • ? TokyoTyrant::stat
  • TokyoTyrant::tune ?
  • PHP Manual
  • TokyoTyrant
  • Synchronize the database

TokyoTyrant::sync

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::sync — Synchronize the database

说明

public TokyoTyrant::sync ( ) : mixed

Synchronizes the database on to the physical device

参数

此函数没有参数。

返回值

This method returns the current object and throws TokyoTyrantException on failure.


Tunes connection values

  • ? TokyoTyrant::sync
  • TokyoTyrant::vanish ?
  • PHP Manual
  • TokyoTyrant
  • Tunes connection values

TokyoTyrant::tune

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrant::tune — Tunes connection values

说明

public TokyoTyrant::tune ( float $timeout , int $options = TokyoTyrant::RDBT_RECON ) : TokyoTyrant

Tunes database connection options.

参数

timeout

The objects timeout value (default: 5.0)

options

Bitmask of options to tune. This can be either 0 or TokyoTyrant::RDBT_RECON. It is recommended not to change the second parameter.

返回值

This method returns a reference to the current object and throws TokyoTyrantException on failure.


Empties the database

  • ? TokyoTyrant::tune
  • TokyoTyrantTable ?
  • PHP Manual
  • TokyoTyrant
  • Empties the database

TokyoTyrant::vanish

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::vanish — Empties the database

说明

public TokyoTyrant::vanish ( ) : mixed

Empties a remote database

参数

此函数没有参数。

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrant::vanish() example

<?php
$tt = new TokyoTyrant("localhost");
$tt->vanish();
?>

参见

  • TokyoTyrant::out() - Removes records


The TokyoTyrantTable class

(PECL tokyo_tyrant >= 0.1.0)

简介

Provides an API to the table databases. A table database can be create using the following command: ttserver -port 1979 /tmp/tt_table.tct. In Tokyo Tyrant the table API is a schemaless database which can store arbitrary amount of key-value pairs under a single primary key.

类摘要

TokyoTyrantTable extends TokyoTyrant {
/* 方法 */
public add ( string $key , mixed $increment , string $type = ? ) : void
public genUid ( ) : int
public get ( mixed $keys ) : array
public getIterator ( ) : TokyoTyrantIterator
public getQuery ( ) : TokyoTyrantQuery
public out ( mixed $keys ) : void
public put ( string $key , array $columns ) : int
public putCat ( string $key , array $columns ) : void
public putKeep ( string $key , array $columns ) : void
public putNr ( mixed $keys , string $value = ? ) : void
public putShl ( string $key , string $value , int $width ) : void
public setIndex ( string $column , int $type ) : mixed
/* 继承的方法 */
public TokyoTyrant::add ( string $key , int|float $increment , int $type = 0 ) : int|float
public TokyoTyrant::connect ( string $host , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? ) : TokyoTyrant
public TokyoTyrant::connectUri ( string $uri ) : TokyoTyrant
public TokyoTyrant::__construct ( string $host = ? , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? )
public TokyoTyrant::copy ( string $path ) : TokyoTyrant
public TokyoTyrant::ext ( string $name , int $options , string $key , string $value ) : string
public TokyoTyrant::fwmKeys ( string $prefix , int $max_recs ) : array
public TokyoTyrant::get ( mixed $keys ) : mixed
public TokyoTyrant::getIterator ( ) : TokyoTyrantIterator
public TokyoTyrant::num ( ) : int
public TokyoTyrant::out ( mixed $keys ) : TokyoTyrant
public TokyoTyrant::put ( mixed $keys , string $value = NULL ) : TokyoTyrant
public TokyoTyrant::putCat ( mixed $keys , string $value = ? ) : TokyoTyrant
public TokyoTyrant::putKeep ( mixed $keys , string $value = ? ) : TokyoTyrant
public TokyoTyrant::putNr ( mixed $keys , string $value = NULL ) : TokyoTyrant
public TokyoTyrant::putShl ( string $key , string $value , int $width ) : mixed
public TokyoTyrant::restore ( string $log_dir , int $timestamp , bool $check_consistency = true ) : mixed
public TokyoTyrant::setMaster ( string $host , int $port , int $timestamp , bool $check_consistency = true ) : mixed
public TokyoTyrant::size ( string $key ) : int
public TokyoTyrant::stat ( ) : array
public TokyoTyrant::sync ( ) : mixed
public TokyoTyrant::tune ( float $timeout , int $options = TokyoTyrant::RDBT_RECON ) : TokyoTyrant
public TokyoTyrant::vanish ( ) : mixed
}

Table of Contents

  • TokyoTyrantTable::add — Adds a record
  • TokyoTyrantTable::genUid — Generate unique id
  • TokyoTyrantTable::get — Get a row
  • TokyoTyrantTable::getIterator — Get an iterator
  • TokyoTyrantTable::getQuery — Get a query object
  • TokyoTyrantTable::out — Remove records
  • TokyoTyrantTable::put — Store a row
  • TokyoTyrantTable::putCat — Concatenates to a row
  • TokyoTyrantTable::putKeep — Put a new record
  • TokyoTyrantTable::putNr — Puts value
  • TokyoTyrantTable::putShl — Concatenates to a record
  • TokyoTyrantTable::setIndex — Sets index


Adds a record

  • ? TokyoTyrantTable
  • TokyoTyrantTable::genUid ?
  • PHP Manual
  • TokyoTyrantTable
  • Adds a record

TokyoTyrantTable::add

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::add — Adds a record

说明

public TokyoTyrantTable::add ( string $key , mixed $increment , string $type = ? ) : void

This method is not supported with table databases.

参数

key

The string key

increment

The amount to increment

type

TokyoTyrant::RDB_RECINT or TokyoTyrant::RDB_RECDBL constant. If this parameter is omitted the type is guessed from the increment parameters type.

返回值

This method throws an TokyoTyrantException if used through this class.

参见

  • TokyoTyrant::add() - Adds to a numeric key


Generate unique id

  • ? TokyoTyrantTable::add
  • TokyoTyrantTable::get ?
  • PHP Manual
  • TokyoTyrantTable
  • Generate unique id

TokyoTyrantTable::genUid

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::genUid — Generate unique id

说明

public TokyoTyrantTable::genUid ( ) : int

Generates an unique id inside the table database. In table databases rows are referenced using a numeric primary key.

参数

此函数没有参数。

返回值

Returns an unique id or throws TokyoTyrantException on error

范例

Example #1 TokyoTyrantTable::genUid() example

<?php
$tt = new TokyoTyrantTable("localhost", 1122);

echo $tt->genUid();
?>

以上例程的输出类似于：

4

参见

  • TokyoTyrantTable::put() - Store a row


Get a row

  • ? TokyoTyrantTable::genUid
  • TokyoTyrantTable::getIterator ?
  • PHP Manual
  • TokyoTyrantTable
  • Get a row

TokyoTyrantTable::get

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::get — Get a row

说明

public TokyoTyrantTable::get ( mixed $keys ) : array

Gets a row from table database. keys is a single integer for the primary key of the row or an array of integers for multiple rows.

参数

keys

The primary key, can be a string or an integer

返回值

Returns the row as an array

范例

Example #1 TokyoTyrantTable::get() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));
?>

以上例程会输出：

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

注释

Note:

Starting from version 0.3.0 this method accepts array as parameter. Please note that multi-get on tables is not binary-safe.

参见

  • TokyoTyrantTable::put() - Store a row


Get an iterator

  • ? TokyoTyrantTable::get
  • TokyoTyrantTable::getQuery ?
  • PHP Manual
  • TokyoTyrantTable
  • Get an iterator

TokyoTyrantTable::getIterator

(No version information available, might only be in Git)

TokyoTyrantTable::getIterator — Get an iterator

说明

public TokyoTyrantTable::getIterator ( ) : TokyoTyrantIterator

Gets an iterator for iterating all keys / values in the database.

参数

此函数没有参数。

返回值

This method returns TokyoTyrantIterator object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrantTable::getIterator() example

<?php
$tt = new TokyoTyrantTable("localhost");
$it = $tt->getIterator();

foreach ($it as $k => $v) {
  var_dump($k, $v);
}
?>

参见

  • TokyoTyrantTable::getQuery() - Get a query object
  • TokyoTyrant::getIterator() - Get an iterator


Get a query object

  • ? TokyoTyrantTable::getIterator
  • TokyoTyrantTable::out ?
  • PHP Manual
  • TokyoTyrantTable
  • Get a query object

TokyoTyrantTable::getQuery

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::getQuery — Get a query object

说明

public TokyoTyrantTable::getQuery ( ) : TokyoTyrantQuery

Get a query object to execute searches on the database

参数

此函数没有参数。

返回值

Returns TokyoTyrantQuery on success and throws TokyoTyrantException on error

范例

Example #1 TokyoTyrantTable::getQuery() example

<?php
/* Connect to a table database */
$table = new TokyoTyrantTable("localhost", 1979);

/* Put a few rows */
$table->put(null, array("column1" => "some data", "column2" => "more data"));
$table->put(null, array("something" => "value", "data" => "good data"));

/* Get query object */
$query = $table->getQuery();

/* Add condition to query */
$query->addCond('data', TokyoTyrant::RDBQC_STREQ, 'good data');

/* Get matching rows */
var_dump($query->search());
?>

以上例程的输出类似于：

array(1) {
  [11]=>
  array(2) {
    ["something"]=>
    string(5) "value"
    ["data"]=>
    string(9) "good data"
  }
}

参见

  • TokyoTyrantQuery::search() - Searches records
  • TokyoTyrantQuery::out() - Removes records based on query


Remove records

  • ? TokyoTyrantTable::getQuery
  • TokyoTyrantTable::put ?
  • PHP Manual
  • TokyoTyrantTable
  • Remove records

TokyoTyrantTable::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::out — Remove records

说明

public TokyoTyrantTable::out ( mixed $keys ) : void

Removes records from a table database.

参数

keys

A single integer key or an array of integers

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrantTable::out() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Delete the row */
$tt->out($index);
?>

参见

  • TokyoTyrantTable::put() - Store a row


Store a row

  • ? TokyoTyrantTable::out
  • TokyoTyrantTable::putCat ?
  • PHP Manual
  • TokyoTyrantTable
  • Store a row

TokyoTyrantTable::put

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::put — Store a row

说明

public TokyoTyrantTable::put ( string $key , array $columns ) : int

Puts a new row into the database. This method parameters are key which is the primary key of the row, passing null will generate a new unique id. value is an array containing the row contents which is usually key value pairs.

参数

key

The primary key of the row

columns

The row contents

返回值

Returns the primary key on success and throws TokyoTyrantException on error

范例

Example #1 TokyoTyrantTable::put() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

/* Modify an existing row */
$tt->put($index, array("column1" => "other data", "column2" => "better data"));

/* Get the row back */
var_dump($tt->get($index));
?>

以上例程会输出：

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
array(2) {
  ["column1"]=>
  string(10) "other data"
  ["column2"]=>
  string(11) "better data"
}

参见

  • TokyoTyrantTable::get() - Get a row


Concatenates to a row

  • ? TokyoTyrantTable::put
  • TokyoTyrantTable::putKeep ?
  • PHP Manual
  • TokyoTyrantTable
  • Concatenates to a row

TokyoTyrantTable::putCat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putCat — Concatenates to a row

说明

public TokyoTyrantTable::putCat ( string $key , array $columns ) : void

This method can be used to add new columns to existing records. Existing keys will be left unmodified but any new columns will be appended to the row. Passing null as key will generate a new row.

参数

key

The primary key of the row or null

columns

Array of row contents

返回值

Returns the primary key and throws TokyoTyrantException on error.

范例

Example #1 TokyoTyrantTable::putCat() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

/* Modify an existing row */
$tt->putcat($index, array("column1" => "something new", "new_column" => "other data"));

/* Get the row back */
var_dump($tt->get($index));
?>

以上例程会输出：

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
array(3) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
  ["new_column"]=>
  string(10) "other data"
}

参见

  • TokyoTyrantTable::put() - Store a row


Put a new record

  • ? TokyoTyrantTable::putCat
  • TokyoTyrantTable::putNr ?
  • PHP Manual
  • TokyoTyrantTable
  • Put a new record

TokyoTyrantTable::putKeep

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putKeep — Put a new record

说明

public TokyoTyrantTable::putKeep ( string $key , array $columns ) : void

Puts a new record into the database. If the key already exists this method throws an exception indicating that the records exists.

参数

key

The primary key of the row or null

columns

Array of the row contents

返回值

Returns the primary key and throws TokyoTyrantException on error.

范例

Example #1 TokyoTyrantTable::putKeep() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

try {
    $tt->putKeep($index, array("column1" => "something new", "new_column" => "other data"));
} catch (TokyoTyrantException $e) {
    if ($e->getCode() === TokyoTyrant::TTE_KEEP) {
        echo "Existing record! Not modified\n";
    } else {
        echo "Error: " , $e->getMessage() , "\n";
    }
}

/* Get the row back */
var_dump($tt->get($index));
?>

以上例程的输出类似于：

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
Existing record! Not modified
array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

参见

  • TokyoTyrantTable::put() - Store a row


Puts value

  • ? TokyoTyrantTable::putKeep
  • TokyoTyrantTable::putShl ?
  • PHP Manual
  • TokyoTyrantTable
  • Puts value

TokyoTyrantTable::putNr

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putNr — Puts value

说明

public TokyoTyrantTable::putNr ( mixed $keys , string $value = ? ) : void

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

参数

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

返回值

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

参见

  • TokyoTyrant::putNr() - Puts value
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record


Concatenates to a record

  • ? TokyoTyrantTable::putNr
  • TokyoTyrantTable::setIndex ?
  • PHP Manual
  • TokyoTyrantTable
  • Concatenates to a record

TokyoTyrantTable::putShl

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putShl — Concatenates to a record

说明

public TokyoTyrantTable::putShl ( string $key , string $value , int $width ) : void

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

参数

key

A string key

value

The value to concatenate

width

The width of the record

返回值

This method is not supported on table databases.

参见

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record
  • TokyoTyrantTable::put() - Store a row
  • TokyoTyrantTable::putKeep() - Put a new record
  • TokyoTyrantTable::putCat() - Concatenates to a row


Sets index

  • ? TokyoTyrantTable::putShl
  • TokyoTyrantQuery ?
  • PHP Manual
  • TokyoTyrantTable
  • Sets index

TokyoTyrantTable::setIndex

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::setIndex — Sets index

说明

public TokyoTyrantTable::setIndex ( string $column , int $type ) : mixed

Sets an index on a specified column. The index type is one of the TokyoTyrant::RDBIT_* constants. Passing TokyoTyrant::RDBIT_VOID removes the index.

参数

column

The name of the column

type

The index type

返回值

This method returns the current object and throws TokyoTyrantException on failure.


The TokyoTyrantQuery class

(PECL tokyo_tyrant >= 0.1.0)

简介

This class is used to query the table databases

类摘要

TokyoTyrantQuery implements Iterator {
/* 方法 */
public addCond ( string $name , int $op , string $expr ) : mixed
public __construct ( TokyoTyrantTable $table )
public count ( ) : int
public current ( ) : array
public hint ( ) : string
public key ( ) : string
public metaSearch ( array $queries , int $type ) : array
public next ( ) : array
public out ( ) : TokyoTyrantQuery
public rewind ( ) : bool
public search ( ) : array
public setLimit ( int $max = ? , int $skip = ? ) : mixed
public setOrder ( string $name , int $type ) : mixed
public valid ( ) : bool
}

Table of Contents

  • TokyoTyrantQuery::addCond — Adds a condition to the query
  • TokyoTyrantQuery::__construct — Construct a new query
  • TokyoTyrantQuery::count — Counts records
  • TokyoTyrantQuery::current — Returns the current element
  • TokyoTyrantQuery::hint — Get the hint string of the query
  • TokyoTyrantQuery::key — Returns the current key
  • TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries
  • TokyoTyrantQuery::next — Moves the iterator to next entry
  • TokyoTyrantQuery::out — Removes records based on query
  • TokyoTyrantQuery::rewind — Rewinds the iterator
  • TokyoTyrantQuery::search — Searches records
  • TokyoTyrantQuery::setLimit — Limit results
  • TokyoTyrantQuery::setOrder — Orders results
  • TokyoTyrantQuery::valid — Checks the validity of current item


Adds a condition to the query

  • ? TokyoTyrantQuery
  • TokyoTyrantQuery::__construct ?
  • PHP Manual
  • TokyoTyrantQuery
  • Adds a condition to the query

TokyoTyrantQuery::addCond

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::addCond — Adds a condition to the query

说明

public TokyoTyrantQuery::addCond ( string $name , int $op , string $expr ) : mixed

Adds a condition to the query. Condition can be something like: get all keys which value matches expr.

参数

name

Name of the column in the condition

op

The operator. One of the TokyoTyrant::RDBQC_* constants

expr

The expression

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrantQuery::addCond() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Dump the search results */
var_dump($query->search());
?>

以上例程会输出：

array(2) {
  [1]=>
  array(2) {
    ["column1"]=>
    string(9) "some data"
    ["column2"]=>
    string(14) "something here"
  }
  [4]=>
  array(2) {
    ["column45"]=>
    string(11) "random data"
    ["column2"]=>
    string(25) "something along the lines"
  }
}

参见

  • Classname::Method()


Construct a new query

  • ? TokyoTyrantQuery::addCond
  • TokyoTyrantQuery::count ?
  • PHP Manual
  • TokyoTyrantQuery
  • Construct a new query

TokyoTyrantQuery::__construct

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::__construct — Construct a new query

说明

public TokyoTyrantQuery::__construct ( TokyoTyrantTable $table )

Construct a new query object

参数

table

TokyoTyrantTable object with active database connection

返回值

Returns a new TokyoTyrantQuery object and throws TokyoTyrantException on error

范例

Example #1 TokyoTyrantQuery::__construct() example

<?php
$tt = new TokyoTyrantTable("localhost", 1979);

$query = new TokyoTyrantQuery($tt);

/* Work with $query */
?>

参见

  • TokyoTyrantTable::getQuery() - Get a query object


Counts records

  • ? TokyoTyrantQuery::__construct
  • TokyoTyrantQuery::current ?
  • PHP Manual
  • TokyoTyrantQuery
  • Counts records

TokyoTyrantQuery::count

(No version information available, might only be in Git)

TokyoTyrantQuery::count — Counts records

说明

public TokyoTyrantQuery::count ( ) : int

Returns a count of how many records a query returns.

参数

此函数没有参数。

返回值

Returns a count of matching rows and throws TokyoTyrantException on error

范例

Example #1 TokyoTyrantQuery::count() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Count the results */
var_dump($query->count());
?>

以上例程会输出：

int(2)

参见

  • TokyoTyrantQuery::out() - Removes records based on query
  • TokyoTyrantQuery::search() - Searches records
  • TokyoTyrantQuery::metaSearch() - Retrieve records with multiple queries


Returns the current element

  • ? TokyoTyrantQuery::count
  • TokyoTyrantQuery::hint ?
  • PHP Manual
  • TokyoTyrantQuery
  • Returns the current element

TokyoTyrantQuery::current

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::current — Returns the current element

说明

public TokyoTyrantQuery::current ( ) : array

Returns the current element. Part of Iterator interface

参数

此函数没有参数。

返回值

Returns the current row

范例

Example #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

以上例程的输出类似于：

pk: 1, columns: 2
pk: 4, columns: 2

参见

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Get the hint string of the query

  • ? TokyoTyrantQuery::current
  • TokyoTyrantQuery::key ?
  • PHP Manual
  • TokyoTyrantQuery
  • Get the hint string of the query

TokyoTyrantQuery::hint

(No version information available, might only be in Git)

TokyoTyrantQuery::hint — Get the hint string of the query

说明

public TokyoTyrantQuery::hint ( ) : string

Get the hint string of the query. The hint string contains information about an executed query and it could be compared to for example MySQL EXPLAIN statement.

参数

此函数没有参数。

返回值

This method always returns a string

范例

Example #1 TokyoTyrantQuery::hint example

<?php
$tt = new TokyoTyrantTable("localhost", 1979);
$tt->vanish();

for ($i = 0; $i < 11; $i++) {
     $tt->put(null, array('a_col' => 'a' . $i, 'b_col' => 'b' . $i));
}

$query = $tt->getQuery();
$query->addCond('a_col', TokyoTyrant::RDBQC_STRBW, 'a');

$query->search();
var_dump($query->hint());
?>

以上例程的输出类似于：

string(72) "
scanning the whole table
result set size: 11
leaving the natural order
"

参见

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Returns the current key

  • ? TokyoTyrantQuery::hint
  • TokyoTyrantQuery::metaSearch ?
  • PHP Manual
  • TokyoTyrantQuery
  • Returns the current key

TokyoTyrantQuery::key

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::key — Returns the current key

说明

public TokyoTyrantQuery::key ( ) : string

Returns the current key. Part of the Iterator interface

参数

此函数没有参数。

返回值

Returns the current key and throws TokyoTyrantException on error

范例

Example #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

以上例程的输出类似于：

pk: 1, columns: 2
pk: 4, columns: 2

参见

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Retrieve records with multiple queries

  • ? TokyoTyrantQuery::key
  • TokyoTyrantQuery::next ?
  • PHP Manual
  • TokyoTyrantQuery
  • Retrieve records with multiple queries

TokyoTyrantQuery::metaSearch

(No version information available, might only be in Git)

TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries

说明

public TokyoTyrantQuery::metaSearch ( array $queries , int $type ) : array

Executes multiple queries on a database and returns matching records. The current object is always the left most object in the search.

参数

queries

Array of TokyoTyrantQuery objects

type

One of the TokyoTyrant::RDBMS_* constants

返回值

Returns the matching rows and throws TokyoTyrantException on error

范例

Example #1 TokyoTyrantQuery::metaSearch() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add test data */
$tt->put('cherry',     array('color' => 'red'));
$tt->put('strawberry', array('color' => 'red'));
$tt->put('apple',      array('color' => 'green'));
$tt->put('lemon',      array('color' => 'yellow'));

/* First query */
$query = $tt->getQuery();
$query->addCond('color', TokyoTyrant::RDBQC_STREQ, 'red')->setOrder('color', TokyoTyrant::RDBQO_STRASC);

/* Second query */
$query1 = $tt->getQuery();
$query1->addCond('color', TokyoTyrant::RDBQC_STREQ, 'yellow');

/* Get union between the queries */
var_dump($query->metaSearch(array($query1), TokyoTyrant::RDBMS_UNION));
?>

以上例程会输出：

array(3) {
  ["cherry"]=>
  array(1) {
    ["color"]=>
    string(3) "red"
  }
  ["strawberry"]=>
  array(1) {
    ["color"]=>
    string(3) "red"
  }
  ["lemon"]=>
  array(1) {
    ["color"]=>
    string(6) "yellow"
  }
}

参见

  • TokyoTyrantQuery::search() - Searches records


Moves the iterator to next entry

  • ? TokyoTyrantQuery::metaSearch
  • TokyoTyrantQuery::out ?
  • PHP Manual
  • TokyoTyrantQuery
  • Moves the iterator to next entry

TokyoTyrantQuery::next

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::next — Moves the iterator to next entry

说明

public TokyoTyrantQuery::next ( ) : array

Returns the next result in the resultset. Part of the Iterator interface.

参数

此函数没有参数。

返回值

Returns the next row and throws TokyoTyrantException on error.

范例

Example #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

以上例程的输出类似于：

pk: 1, columns: 2
pk: 4, columns: 2

参见

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Removes records based on query

  • ? TokyoTyrantQuery::next
  • TokyoTyrantQuery::rewind ?
  • PHP Manual
  • TokyoTyrantQuery
  • Removes records based on query

TokyoTyrantQuery::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::out — Removes records based on query

说明

public TokyoTyrantQuery::out ( ) : TokyoTyrantQuery

Removes all records that match the query. Works exactly like search but removes the records instead of returning them.

参数

此函数没有参数。

返回值

This method returns the current object and throws TokyoTyrantException on failure.

范例

Example #1 TokyoTyrantQuery::out() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Remove matching records */
$query->out();
?>

参见

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Rewinds the iterator

  • ? TokyoTyrantQuery::out
  • TokyoTyrantQuery::search ?
  • PHP Manual
  • TokyoTyrantQuery
  • Rewinds the iterator

TokyoTyrantQuery::rewind

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::rewind — Rewinds the iterator

说明

public TokyoTyrantQuery::rewind ( ) : bool

Rewind the resultset and executes the query if it has not been executed. Part of the Iterator interface.

参数

此函数没有参数。

返回值

Returns true

范例

Example #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

以上例程的输出类似于：

pk: 1, columns: 2
pk: 4, columns: 2

参见

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


Searches records

  • ? TokyoTyrantQuery::rewind
  • TokyoTyrantQuery::setLimit ?
  • PHP Manual
  • TokyoTyrantQuery
  • Searches records

TokyoTyrantQuery::search

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::search — Searches records

说明

public TokyoTyrantQuery::search ( ) : array

Executes a search on the table database. Returns an array of arrays containing the matching records. In the returned array the first level is the primary key of the data and the second level is the row data.

参数

此函数没有参数。

返回值

Returns the matching rows and throws TokyoTyrantException on error

范例

Example #1 TokyoTyrantQuery::search() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Dump the search results */
var_dump($query->search());
?>

以上例程会输出：

array(2) {
  [1]=>
  array(2) {
    ["column1"]=>
    string(9) "some data"
    ["column2"]=>
    string(14) "something here"
  }
  [4]=>
  array(2) {
    ["column45"]=>
    string(11) "random data"
    ["column2"]=>
    string(25) "something along the lines"
  }
}

参见

  • TokyoTyrantQuery::out() - Removes records based on query
  • TokyoTyrantQuery::metaSearch() - Retrieve records with multiple queries


Limit results

  • ? TokyoTyrantQuery::search
  • TokyoTyrantQuery::setOrder ?
  • PHP Manual
  • TokyoTyrantQuery
  • Limit results

TokyoTyrantQuery::setLimit

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::setLimit — Limit results

说明

public TokyoTyrantQuery::setLimit ( int $max = ? , int $skip = ? ) : mixed

Set the maximum amount of records to return on a query.

参数

max

Maximum amount of records. Default: -1

skip

How many records to skip from the start. Default: -1

返回值

This method returns the current object and throws TokyoTyrantException on failure.


Orders results

  • ? TokyoTyrantQuery::setLimit
  • TokyoTyrantQuery::valid ?
  • PHP Manual
  • TokyoTyrantQuery
  • Orders results

TokyoTyrantQuery::setOrder

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::setOrder — Orders results

说明

public TokyoTyrantQuery::setOrder ( string $name , int $type ) : mixed

Sets the order of a query

参数

name

The column name to apply the ordering on.

type

The type can be one of the following constants:

  • TokyoTyrant::RDBQO_STRASC - String ascending
  • TokyoTyrant::RDBQO_STRDESC - String descending
  • TokyoTyrant::RDBQO_NUMASC - Numberic ascending
  • TokyoTyrant::RDBQO_NUMDESC - String descending

返回值

This method returns the current object.


Checks the validity of current item

  • ? TokyoTyrantQuery::setOrder
  • TokyoTyrantIterator ?
  • PHP Manual
  • TokyoTyrantQuery
  • Checks the validity of current item

TokyoTyrantQuery::valid

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::valid — Checks the validity of current item

说明

public TokyoTyrantQuery::valid ( ) : bool

Checks if the current item is valid. Part of the Iterator interface

参数

此函数没有参数。

返回值

Returns true if the current item is valid and false if not.

范例

Example #1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

以上例程的输出类似于：

pk: 1, columns: 2
pk: 4, columns: 2

参见

  • TokyoTyrantQuery::addCond() - Adds a condition to the query


The TokyoTyrantIterator class

(PECL tokyo_tyrant >= 0.2.0)

简介

Provides an iterator for TokyoTyrant and TokyoTyrantTable objects. The iterator iterates over all keys and values in the database. TokyoTyrantIterator was added in version 0.2.0.

类摘要

TokyoTyrantIterator implements Iterator {
/* Methods */
public __construct ( mixed $object )
public current ( ) : mixed
public key ( ) : mixed
public next ( ) : mixed
public rewind ( ) : void
public valid ( ) : bool
/* Inherited methods */
public TokyoTyrant::add ( string $key , int|float $increment , int $type = 0 ) : int|float
public TokyoTyrant::connect ( string $host , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? ) : TokyoTyrant
public TokyoTyrant::connectUri ( string $uri ) : TokyoTyrant
public TokyoTyrant::__construct ( string $host = ? , int $port = TokyoTyrant::RDBDEF_PORT , array $options = ? )
public TokyoTyrant::copy ( string $path ) : TokyoTyrant
public TokyoTyrant::ext ( string $name , int $options , string $key , string $value ) : string
public TokyoTyrant::fwmKeys ( string $prefix , int $max_recs ) : array
public TokyoTyrant::get ( mixed $keys ) : mixed
public TokyoTyrant::getIterator ( ) : TokyoTyrantIterator
public TokyoTyrant::num ( ) : int
public TokyoTyrant::out ( mixed $keys ) : TokyoTyrant
public TokyoTyrant::put ( mixed $keys , string $value = NULL ) : TokyoTyrant
public TokyoTyrant::putCat ( mixed $keys , string $value = ? ) : TokyoTyrant
public TokyoTyrant::putKeep ( mixed $keys , string $value = ? ) : TokyoTyrant
public TokyoTyrant::putNr ( mixed $keys , string $value = NULL ) : TokyoTyrant
public TokyoTyrant::putShl ( string $key , string $value , int $width ) : mixed
public TokyoTyrant::restore ( string $log_dir , int $timestamp , bool $check_consistency = true ) : mixed
public TokyoTyrant::setMaster ( string $host , int $port , int $timestamp , bool $check_consistency = true ) : mixed
public TokyoTyrant::size ( string $key ) : int
public TokyoTyrant::stat ( ) : array
public TokyoTyrant::sync ( ) : mixed
public TokyoTyrant::tune ( float $timeout , int $options = TokyoTyrant::RDBT_RECON ) : TokyoTyrant
public TokyoTyrant::vanish ( ) : mixed
}

Table of Contents

  • TokyoTyrantIterator::__construct — Construct an iterator
  • TokyoTyrantIterator::current — Get the current value
  • TokyoTyrantIterator::key — Returns the current key
  • TokyoTyrantIterator::next — Move to next key
  • TokyoTyrantIterator::rewind — Rewinds the iterator
  • TokyoTyrantIterator::valid — Rewinds the iterator


Construct an iterator

  • ? TokyoTyrantIterator
  • TokyoTyrantIterator::current ?
  • PHP Manual
  • TokyoTyrantIterator
  • Construct an iterator

TokyoTyrantIterator::__construct

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::__construct — Construct an iterator

说明

public TokyoTyrantIterator::__construct ( mixed $object )

Construct a new TokyoTyrantIterator object. One connection can have multiple iterators but it is not quaranteed that all items are traversed in that case. object parameter can be either an of instance TokyoTyrant or TokyoTyrantTable.

参数

此函数没有参数。

返回值

Throws an exception if iterator initialization fails.

范例

Example #1 TokyoTyrantIterator::__construct() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Construct an iterator */
$it = new TokyoTyrantIterator($tt);

foreach ($it as $value) {
    var_dump($value);
}
?>

以上例程会输出：

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

参见

  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key


Get the current value

  • ? TokyoTyrantIterator::__construct
  • TokyoTyrantIterator::key ?
  • PHP Manual
  • TokyoTyrantIterator
  • Get the current value

TokyoTyrantIterator::current

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::current — Get the current value

说明

public TokyoTyrantIterator::current ( ) : mixed

Returns the current value during iteration.

参数

此函数没有参数。

返回值

Returns the current value on success and false on failure.

参见

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator


Returns the current key

  • ? TokyoTyrantIterator::current
  • TokyoTyrantIterator::next ?
  • PHP Manual
  • TokyoTyrantIterator
  • Returns the current key

TokyoTyrantIterator::key

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::key — Returns the current key

说明

public TokyoTyrantIterator::key ( ) : mixed

Returns the current key.

参数

此函数没有参数。

返回值

Returns the current key on success and false on failure.

参见

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator


Move to next key

  • ? TokyoTyrantIterator::key
  • TokyoTyrantIterator::rewind ?
  • PHP Manual
  • TokyoTyrantIterator
  • Move to next key

TokyoTyrantIterator::next

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::next — Move to next key

说明

public TokyoTyrantIterator::next ( ) : mixed

Move to next key during iteration and return it's value.

参数

此函数没有参数。

返回值

Returns the next value on success and false on failure.

参见

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::rewind() - Rewinds the iterator


Rewinds the iterator

  • ? TokyoTyrantIterator::next
  • TokyoTyrantIterator::valid ?
  • PHP Manual
  • TokyoTyrantIterator
  • Rewinds the iterator

TokyoTyrantIterator::rewind

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::rewind — Rewinds the iterator

说明

public TokyoTyrantIterator::rewind ( ) : void

Rewinds the iterator for new iteration. Called automatically at the beginning of foreach.

参数

此函数没有参数。

返回值

Throws TokyoTyrantException if iterator initialization fails.

参见

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind()


Rewinds the iterator

  • ? TokyoTyrantIterator::rewind
  • TokyoTyrantException ?
  • PHP Manual
  • TokyoTyrantIterator
  • Rewinds the iterator

TokyoTyrantIterator::valid

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::valid — Rewinds the iterator

说明

public TokyoTyrantIterator::valid ( ) : bool

Checks whether the internal pointer points to valid element.

参数

此函数没有参数。

返回值

Returns true if the current item is valid and false if not.

参见

  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator


The TokyoTyrantException class

(PECL tokyo_tyrant >= 0.1.0)

简介

TokyoTyrantException

类摘要

tokyotyrantexception extends Exception {
/* 属性 */
protected int $code ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

code

The exception code. This can be compared to TokyoTyrant::TTE_* constants


日期与时间相关扩展

  • Calendar
    • 简介
    • 安装／配置
    • 预定义常量
    • 日历 函数
  • 日期/时间 — 日期和时间
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • DateTime — DateTime 类
    • DateTimeImmutable — The DateTimeImmutable class
    • DateTimeInterface — The DateTimeInterface interface
    • DateTimeZone — The DateTimeZone class
    • DateInterval — DateInterval 类
    • DatePeriod — DatePeriod 类
    • Date/Time 函数
    • Supported Date and Time Formats
    • 所支持的时区列表
  • HRTime — High resolution timing
    • 简介
    • 安装／配置
    • 范例
    • HRTime\PerformanceCounter — The HRTime\PerformanceCounter class
    • HRTime\StopWatch — The HRTime\StopWatch class
    • HRTime\Unit — The HRTime\Unit class


Calendar

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 日历 函数
    • cal_days_in_month — 返回某个历法中某年中某月的天数
    • cal_from_jd — 转换Julian Day计数到一个支持的历法。
    • cal_info — 返回选定历法的信息
    • cal_to_jd — 从一个支持的历法转变为Julian Day计数。
    • easter_date — 得到指定年份的复活节午夜时的Unix时间戳。
    • easter_days — 得到指定年份的3月21日到复活节之间的天数
    • FrenchToJD — 从一个French Republican历法的日期得到Julian Day计数。
    • GregorianToJD — 转变一个Gregorian历法日期到Julian Day计数
    • JDDayOfWeek — 返回星期的日期
    • JDMonthName — 返回月份的名称
    • JDToFrench — 转变一个Julian Day计数到French Republican历法的日期
    • JDToGregorian — 转变一个Julian Day计数为Gregorian历法日期
    • jdtojewish — 转换一个julian天数为Jewish历法的日期
    • JDToJulian — 转变一个Julian Day计数到Julian历法的日期
    • jdtounix — 转变Julian Day计数为一个Unix时间戳
    • JewishToJD — 转变一个Jewish历法的日期为一个Julian Day计数
    • JulianToJD — 转变一个Julian历法的日期为Julian Day计数
    • unixtojd — 转变Unix时间戳为Julian Day计数


简介

历法扩展集包括了一系列用于在不同历法间进行转换的函数，它是以Julian Day计数为中介或标准来进行的。Julian Day计数是以公元前的4713年的1月1日为起点的一种计数法。为了在不同历法间进行转换，你首先要转换成Julian Day计数，然后再转换为你所需要的历法。Julian Day计数和Julian历法是非常不同的！Julian Day计数的更多信息可以参考» http://www.hermetic.ch/cal_stud/jdn.htm，历法系统的更多信息可以参考» http://www.fourmilab.ch/documents/calendar/本页中的引用包括在相应的文章中。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Calendar
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

要使用本类函数，需要在编译 PHP 时加上 --enable-calendar。

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

CAL_GREGORIAN (integer)
CAL_JULIAN (integer)
CAL_JEWISH (integer)
CAL_FRENCH (integer)
CAL_NUM_CALS (integer)
CAL_DOW_DAYNO (integer)
CAL_DOW_SHORT (integer)
CAL_DOW_LONG (integer)
CAL_MONTH_GREGORIAN_SHORT (integer)
CAL_MONTH_GREGORIAN_LONG (integer)
CAL_MONTH_JULIAN_SHORT (integer)
CAL_MONTH_JULIAN_LONG (integer)
CAL_MONTH_JEWISH (integer)
CAL_MONTH_FRENCH (integer)

以下常量自 PHP 4.3.0 起可用：

CAL_EASTER_DEFAULT (integer)
CAL_EASTER_ROMAN (integer)
CAL_EASTER_ALWAYS_GREGORIAN (integer)
CAL_EASTER_ALWAYS_JULIAN (integer)

以下常量自 PHP 5.0.0 起可用：

CAL_JEWISH_ADD_ALAFIM_GERESH (integer)
CAL_JEWISH_ADD_ALAFIM (integer)
CAL_JEWISH_ADD_GERESHAYIM (integer)


日历 函数

Table of Contents

  • cal_days_in_month — 返回某个历法中某年中某月的天数
  • cal_from_jd — 转换Julian Day计数到一个支持的历法。
  • cal_info — 返回选定历法的信息
  • cal_to_jd — 从一个支持的历法转变为Julian Day计数。
  • easter_date — 得到指定年份的复活节午夜时的Unix时间戳。
  • easter_days — 得到指定年份的3月21日到复活节之间的天数
  • FrenchToJD — 从一个French Republican历法的日期得到Julian Day计数。
  • GregorianToJD — 转变一个Gregorian历法日期到Julian Day计数
  • JDDayOfWeek — 返回星期的日期
  • JDMonthName — 返回月份的名称
  • JDToFrench — 转变一个Julian Day计数到French Republican历法的日期
  • JDToGregorian — 转变一个Julian Day计数为Gregorian历法日期
  • jdtojewish — 转换一个julian天数为Jewish历法的日期
  • JDToJulian — 转变一个Julian Day计数到Julian历法的日期
  • jdtounix — 转变Julian Day计数为一个Unix时间戳
  • JewishToJD — 转变一个Jewish历法的日期为一个Julian Day计数
  • JulianToJD — 转变一个Julian历法的日期为Julian Day计数
  • unixtojd — 转变Unix时间戳为Julian Day计数


返回某个历法中某年中某月的天数

  • ? 日历 函数
  • cal_from_jd ?
  • PHP Manual
  • 日历 函数
  • 返回某个历法中某年中某月的天数

cal_days_in_month

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cal_days_in_month — 返回某个历法中某年中某月的天数

说明

cal_days_in_month ( int $calendar , int $month , int $year ) : int

该函数返回特定历法中的某年中的某月的天数。

参数

calendar

用来计算的某个历法

month

选定历法中的某月

year

选定历法中的某年

返回值

指定历法中选定的某月的天数。

范例

Example #1 cal_days_in_month() example

<?php
$num = cal_days_in_month(CAL_GREGORIAN, 8, 2003); // 31
echo "There was $num days in August 2003";
?>


转换Julian Day计数到一个支持的历法。

  • ? cal_days_in_month
  • cal_info ?
  • PHP Manual
  • 日历 函数
  • 转换Julian Day计数到一个支持的历法。

cal_from_jd

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cal_from_jd — 转换Julian Day计数到一个支持的历法。

说明

cal_from_jd ( int $jd , int $calendar ) : array

cal_from_jd()函数根据给定的Julian day的jd 天数转换成特定历法calendar中的日期。calendar支持的值有CAL_GREGORIAN，CAL_JULIAN，CAL_JEWISH 和CAL_FRENCH。

参数

jd

一个Julian day天数的整数数字

calendar

要转换成的历法

返回值

返回一个数组，包含的历法信息有月，日，年，星期，星期的缩写和全写，月份的缩写和全写，日期的形式是"月/日/年"。

范例

Example #1 cal_from_jd() example

<?php
$today = unixtojd(mktime(0, 0, 0, 8, 16, 2003));
print_r(cal_from_jd($today, CAL_GREGORIAN));
?>

以上例程会输出：

Array
(
    [date] => 8/16/2003
    [month] => 8
    [day] => 16
    [year] => 2003
    [dow] => 6
    [abbrevdayname] => Sat
    [dayname] => Saturday
    [abbrevmonth] => Aug
    [monthname] => August
)

参见

  • cal_to_jd() - 从一个支持的历法转变为Julian Day计数。
  • jdtofrench() - 转变一个Julian Day计数到French Republican历法的日期
  • jdtogregorian() - 转变一个Julian Day计数为Gregorian历法日期
  • jdtojewish() - 转换一个julian天数为Jewish历法的日期
  • jdtojulian() - 转变一个Julian Day计数到Julian历法的日期
  • jdtounix() - 转变Julian Day计数为一个Unix时间戳


返回选定历法的信息

  • ? cal_from_jd
  • cal_to_jd ?
  • PHP Manual
  • 日历 函数
  • 返回选定历法的信息

cal_info

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cal_info — 返回选定历法的信息

说明

cal_info ( int $calendar = -1 ) : array

cal_info()返回选定 calendar的作息。

历法信息以一个数组的形式返回，包含的元素有历法名称，历法代码，月份，月份的缩写和单月的最多天数。作为参数的calendar历法名字可以有：

  • 0 or CAL_GREGORIAN - Gregorian Calendar
  • 1 or CAL_JULIAN - Julian Calendar
  • 2 or CAL_JEWISH - Jewish Calendar
  • 3 or CAL_FRENCH - French Revolutionary Calendar

如果没有指定参数calendar，所支持的所有历法将以数组形式返回。

参数

calendar

返回信息所指定的历法名称，如果没有指定历法，将返回所有历法。

返回值

更新日志

版本 | 说明
Since 5.0 | 参数calendar作为可选项，缺省时默认值为"所有历法"。

范例

Example #1 cal_info() example

<?php
$info = cal_info(0);
print_r($info);
?>

以上例程会输出：

Array
(
    [months] => Array
        (
            [1] => January
            [2] => February
            [3] => March
            [4] => April
            [5] => May
            [6] => June
            [7] => July
            [8] => August
            [9] => September
            [10] => October
            [11] => November
            [12] => December
        )

    [abbrevmonths] => Array
        (
            [1] => Jan
            [2] => Feb
            [3] => Mar
            [4] => Apr
            [5] => May
            [6] => Jun
            [7] => Jul
            [8] => Aug
            [9] => Sep
            [10] => Oct
            [11] => Nov
            [12] => Dec
        )

    [maxdaysinmonth] => 31
    [calname] => Gregorian
    [calsymbol] => CAL_GREGORIAN
)


从一个支持的历法转变为Julian Day计数。

  • ? cal_info
  • easter_date ?
  • PHP Manual
  • 日历 函数
  • 从一个支持的历法转变为Julian Day计数。

cal_to_jd

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cal_to_jd — 从一个支持的历法转变为Julian Day计数。

说明

cal_to_jd ( int $calendar , int $month , int $day , int $year ) : int

cal_to_jd()函数从一个给定的历法日期计算出Julian天数，支持的历法有 CAL_GREGORIAN，CAL_JULIAN，CAL_JEWISH和CAL_FRENCH。

参数

calendar

选定的历法，可以是CAL_GREGORIAN，CAL_JULIAN，CAL_JEWISH或CAL_FRENCH中的某一个。

month

数字形式的月份，根据选定的calendar历法来确定范围。

day

数字形式的日期，根据选定的calendar历法来确定范围。

year

数字形式的年份，根据选定的calendar历法来确定范围。

返回值

一个Julian天数。

参见

  • cal_from_jd() - 转换Julian Day计数到一个支持的历法。
  • frenchtojd() - 从一个French Republican历法的日期得到Julian Day计数。
  • gregoriantojd() - 转变一个Gregorian历法日期到Julian Day计数
  • jewishtojd() - 转变一个Jewish历法的日期为一个Julian Day计数
  • juliantojd() - 转变一个Julian历法的日期为Julian Day计数
  • unixtojd() - 转变Unix时间戳为Julian Day计数


得到指定年份的复活节午夜时的Unix时间戳。

  • ? cal_to_jd
  • easter_days ?
  • PHP Manual
  • 日历 函数
  • 得到指定年份的复活节午夜时的Unix时间戳。

easter_date

(PHP 4, PHP 5, PHP 7, PHP 8)

easter_date — 得到指定年份的复活节午夜时的Unix时间戳。

说明

easter_date ( int $year = ? ) : int

返回指定年份的复活节午夜时的Unix时间戳。

Warning

如果给定的年份超出Unix时间戳的范围（比如1970年以前或2037年以后），该函数将返回一个警告。

复活节的日期是由尼西亚议会在AD325年确定的为每年春分月圆后的第一个星期日。春分一般是在3月21日，这就简化为只要计算满月的日期和紧挨的星期日的日期。这里所用的算法是在532年由Dionysius Exiguus所介绍的，参考了Julian历法和Gregorian历法这两个历法来提高精确度。（在1753年以前用Julian历法计算，该历法是一个以19年为周期来确定月亮的相位的历法。在1753年以后用Gregorian历法计算，该历法由Clavius和Lilius发明，由Pope Gregory 8世在1582年推广）

参数

year

1970年至2037年之间的数字形式的年份。

返回值

复活节日期的Unix时间戳。

更新日志

版本 | 说明
Since 4.3.0 | year参数可选，缺省的默认值是当年。

范例

Example #1 easter_date() example

<?php

echo date("M-d-Y", easter_date(1999));        // Apr-04-1999
echo date("M-d-Y", easter_date(2000));        // Apr-23-2000
echo date("M-d-Y", easter_date(2001));        // Apr-15-2001

?>

参见

  • easter_days() - 得到指定年份的3月21日到复活节之间的天数 for calculating Easter before 1970 or after 2037


得到指定年份的3月21日到复活节之间的天数

  • ? easter_date
  • FrenchToJD ?
  • PHP Manual
  • 日历 函数
  • 得到指定年份的3月21日到复活节之间的天数

easter_days

(PHP 4, PHP 5, PHP 7, PHP 8)

easter_days — 得到指定年份的3月21日到复活节之间的天数

说明

easter_days ( int $year = ? , int $method = CAL_EASTER_DEFAULT ) : int

返回指定年份的3月21日到复活节之间的天数，如果没有指定年份，默认是当年。

这个函数可以用来代替easter_date()函数来计算Unix时间戳以外年份的复活节日期。（比如1970年以前或2037年以后）

复活节的日期是由尼西亚议会在AD325年确定的为每年春分月圆后的第一个星期日。春分一般是在3月21日，这就简化为只要计算满月的日期和紧挨的星期日的日期。这里所用的算法是在532年由Dionysius Exiguus所介绍的，参考了Julian历法和Gregorian历法这两个历法来提高精确度。（在1753年以前用Julian历法计算，该历法是一个以19年为周期来确定月亮的相位的历法。在1753年以后用Gregorian历法计算，该历法由Clavius和Lilius发明，由Pope Gregory 8世在1582年推广）

参数

year

正数形式的年份

method

当设置为CAL_EASTER_ROMAN时可以用Gregorian历法来计算1582－1752之间的复活节日期。更多可用的常量参考calendar constants。

返回值

根据给定参数year年份而返回的3月21日至复活节的天数。

更新日志

版本 | 说明
Since 4.3.0 | 参数year 可选，缺省默认值是当年。
Since 4.3.0 | 引入参数 method。

范例

Example #1 easter_days() example

<?php

echo easter_days(1999);        // 14, i.e. April 4
echo easter_days(1492);        // 32, i.e. April 22
echo easter_days(1913);        //  2, i.e. March 23

?>

参见

  • easter_date() - 得到指定年份的复活节午夜时的Unix时间戳。


从一个French Republican历法的日期得到Julian Day计数。

  • ? easter_days
  • GregorianToJD ?
  • PHP Manual
  • 日历 函数
  • 从一个French Republican历法的日期得到Julian Day计数。

FrenchToJD

(PHP 4, PHP 5, PHP 7, PHP 8)

FrenchToJD — 从一个French Republican历法的日期得到Julian Day计数。

说明

frenchtojd ( int $month , int $day , int $year ) : int

从一个French Republican历法的日期得到Julian Day计数。

年份所能用的范围是1到14（Gregorian历法的1792年9月22日到1806年9月22日）。

参数

month

月份的范围是1到13。

day

日期的范围是1到30。

year

年份的范围是1到14。

返回值

返回指定french revolution日期的julian天数。

参见

  • jdtofrench() - 转变一个Julian Day计数到French Republican历法的日期
  • cal_to_jd() - 从一个支持的历法转变为Julian Day计数。


转变一个Gregorian历法日期到Julian Day计数

  • ? FrenchToJD
  • JDDayOfWeek ?
  • PHP Manual
  • 日历 函数
  • 转变一个Gregorian历法日期到Julian Day计数

GregorianToJD

(PHP 4, PHP 5, PHP 7, PHP 8)

GregorianToJD — 转变一个Gregorian历法日期到Julian Day计数

说明

gregoriantojd ( int $month , int $day , int $year ) : int

Gregorian历法的合理范围是4714 B.C. 至 9999 A.D.

虽然这个函数可以处理4714 B.C.以前的日期，但是没有意义。Gregorian历法直到1582年10年15日（或是Julian历法的1582年10月5日）才被发明，很久以后一些国家也没有接受它。比如，英国是在1752年开始使用Gregorian历法，苏联是在1918年，希腊是在1923年，大部分的欧洲国家使用Julian历法。

参数

month

月份的范围是 1（January）到 12（December）。

day

日期的范围是 1到 31。

year

年份的范围是 -4714 到 9999。

返回值

给定gregorian历法日期的julian天数。

范例

Example #1 Calendar functions

<?php
$jd = GregorianToJD(10, 11, 1970);
echo "$jd\n";
$gregorian = JDToGregorian($jd);
echo "$gregorian\n";
?>

参见

  • jdtogregorian() - 转变一个Julian Day计数为Gregorian历法日期
  • cal_to_jd() - 从一个支持的历法转变为Julian Day计数。


返回星期的日期

  • ? GregorianToJD
  • JDMonthName ?
  • PHP Manual
  • 日历 函数
  • 返回星期的日期

JDDayOfWeek

(PHP 4, PHP 5, PHP 7, PHP 8)

JDDayOfWeek — 返回星期的日期

说明

jddayofweek ( int $julianday , int $mode = CAL_DOW_DAYNO ) : mixed

返回星期的日期，根据模式不同可能是字符串或是整数。

参数

julianday

一个julian天数。

mode
历法星期模式
Mode | Meaning
0 (默认) | 返回数字形式(0=Sunday, 1=Monday, etc)
1 | 返回字符串形式 (English-Gregorian)
2 | 返回缩写形式的字符串 (English-Gregorian)

返回值

数字或字符串形式的星期数。


返回月份的名称

  • ? JDDayOfWeek
  • JDToFrench ?
  • PHP Manual
  • 日历 函数
  • 返回月份的名称

JDMonthName

(PHP 4, PHP 5, PHP 7, PHP 8)

JDMonthName — 返回月份的名称

说明

jdmonthname ( int $julianday , int $mode ) : string

返回一个月份名称的字符串，mode参数指定使用哪种历法和月份名称的形式。

Calendar modes
Mode | Meaning | Values
0 | Gregorian - abbreviated | Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
1 | Gregorian | January, February, March, April, May, June, July, August, September, October, November, December
2 | Julian - abbreviated | Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
3 | Julian | January, February, March, April, May, June, July, August, September, October, November, December
4 | Jewish | Tishri, Heshvan, Kislev, Tevet, Shevat, AdarI, AdarII, Nisan, Iyyar, Sivan, Tammuz, Av, Elul
5 | French Republican | Vendemiaire, Brumaire, Frimaire, Nivose, Pluviose, Ventose, Germinal, Floreal, Prairial, Messidor, Thermidor, Fructidor, Extra

参数

jday

用来计算的julian天数

calendar

历法的月份的名字

返回值

根据指定的julian天数和calendar历法参数而得到月份的名称。


转变一个Julian Day计数到French Republican历法的日期

  • ? JDMonthName
  • JDToGregorian ?
  • PHP Manual
  • 日历 函数
  • 转变一个Julian Day计数到French Republican历法的日期

JDToFrench

(PHP 4, PHP 5, PHP 7, PHP 8)

JDToFrench — 转变一个Julian Day计数到French Republican历法的日期

说明

jdtofrench ( int $juliandaycount ) : string

转变一个Julian Day计数到French Republican历法的日期。

参数

julianday

一个julian天数

返回值

以"月/日/年"形式的french revolution日期

参见

  • frenchtojd() - 从一个French Republican历法的日期得到Julian Day计数。
  • cal_from_jd() - 转换Julian Day计数到一个支持的历法。


转变一个Julian Day计数为Gregorian历法日期

  • ? JDToFrench
  • jdtojewish ?
  • PHP Manual
  • 日历 函数
  • 转变一个Julian Day计数为Gregorian历法日期

JDToGregorian

(PHP 4, PHP 5, PHP 7, PHP 8)

JDToGregorian — 转变一个Julian Day计数为Gregorian历法日期

说明

jdtogregorian ( int $julianday ) : string

转变一个julian天数为gregorian历法的"月/日/年"形式的日期

参数

julianday

一个julian天数

返回值

"月/日/年"形式的gregorian日期

参见

  • gregoriantojd() - 转变一个Gregorian历法日期到Julian Day计数
  • cal_from_jd() - 转换Julian Day计数到一个支持的历法。


转换一个julian天数为Jewish历法的日期

  • ? JDToGregorian
  • JDToJulian ?
  • PHP Manual
  • 日历 函数
  • 转换一个julian天数为Jewish历法的日期

jdtojewish

(PHP 4, PHP 5, PHP 7, PHP 8)

jdtojewish — 转换一个julian天数为Jewish历法的日期

说明

jdtojewish ( int $juliandaycount , bool $hebrew = false , int $fl = 0 ) : string

转换一个julian天数为Jewish历法的日期。

参数

julianday

一个julian天数

hebrew

如果参数 hebrew设置为 true，参数fl可用于希伯莱语的格式。

fl

可用的格式有： CAL_JEWISH_ADD_ALAFIM_GERESH, CAL_JEWISH_ADD_ALAFIM, CAL_JEWISH_ADD_GERESHAYIM.

返回值

以"月/日/年"的格式显示jewish日期。

更新日志

版本 | 说明
5.0.0 | 增加了参数 fl。
4.3.0 | 增加了参数 hebrew 。

范例

Example #1 jdtojewish() Example

<?php
echo jdtojewish(gregoriantojd(10, 8, 2002), true,
       CAL_JEWISH_ADD_GERESHAYIM + CAL_JEWISH_ADD_ALAFIM + CAL_JEWISH_ADD_ALAFIM_GERESH);
?>

参见

  • jewishtojd() - 转变一个Jewish历法的日期为一个Julian Day计数
  • cal_from_jd() - 转换Julian Day计数到一个支持的历法。


转变一个Julian Day计数到Julian历法的日期

  • ? jdtojewish
  • jdtounix ?
  • PHP Manual
  • 日历 函数
  • 转变一个Julian Day计数到Julian历法的日期

JDToJulian

(PHP 4, PHP 5, PHP 7, PHP 8)

JDToJulian — 转变一个Julian Day计数到Julian历法的日期

说明

jdtojulian ( int $julianday ) : string

转变一个Julian Day计数到以"月/日/年"形式显示的Julian历法的日期。

参数

julianday

一个julian天数

返回值

以"月/日/年"形式显示的Julian历法的日期

参见

  • juliantojd() - 转变一个Julian历法的日期为Julian Day计数
  • cal_from_jd() - 转换Julian Day计数到一个支持的历法。


转变Julian Day计数为一个Unix时间戳

  • ? JDToJulian
  • JewishToJD ?
  • PHP Manual
  • 日历 函数
  • 转变Julian Day计数为一个Unix时间戳

jdtounix

(PHP 4, PHP 5, PHP 7, PHP 8)

jdtounix — 转变Julian Day计数为一个Unix时间戳

说明

jdtounix ( int $jday ) : int

这个函数根据给定的julian天数返回一个Unix时间戳，或如果参数jday不在Unix时间（Gregorian历法的1970年至2037年，或2440588 <= jday <= 2465342）范围内返回 false 。返回的时间是本地时间（不是GMT）。

参数

jday

一个在 2440588 到 2465342 之间的julian天数

返回值

指定的julian天数的开始时的时间戳。

参见

  • unixtojd() - 转变Unix时间戳为Julian Day计数


转变一个Jewish历法的日期为一个Julian Day计数

  • ? jdtounix
  • JulianToJD ?
  • PHP Manual
  • 日历 函数
  • 转变一个Jewish历法的日期为一个Julian Day计数

JewishToJD

(PHP 4, PHP 5, PHP 7, PHP 8)

JewishToJD — 转变一个Jewish历法的日期为一个Julian Day计数

说明

jewishtojd ( int $month , int $day , int $year ) : int

尽管这个函数可以处理1（3761 B.C.）以前的年份，但这是没有意义的。Jewish历法被用了几千年，但早期的时候一个月的开始没有固定的准则，通常是观察到一个新月后定为一个月份的开始。

参数

month

在1到13之间的月份

day

在1到30日之间的日子

year

在1到9999之间的年份

返回值

指定的jewish历法的日期的julian天数。

参见

  • jdtojewish() - 转换一个julian天数为Jewish历法的日期
  • cal_to_jd() - 从一个支持的历法转变为Julian Day计数。


转变一个Julian历法的日期为Julian Day计数

  • ? JewishToJD
  • unixtojd ?
  • PHP Manual
  • 日历 函数
  • 转变一个Julian历法的日期为Julian Day计数

JulianToJD

(PHP 4, PHP 5, PHP 7, PHP 8)

JulianToJD — 转变一个Julian历法的日期为Julian Day计数

说明

juliantojd ( int $month , int $day , int $year ) : int

Julian历法的合理年份为 4713 B.C. 到 9999 A.D.

尽管这个函数也可以处理4713 B.C.以前的日期，但是没有意义。这个历法是在46 B.C.创立，但是到了8 A.D.还没有稳定，可能直到第4世纪才最终完善。而且，每年的开始也不相同，不是所有的国家都认定January为第一个月份的。

Caution

记住，当今世界最广泛使用的历法是Gregorian历法，函数gregoriantojd()可以转变日期为Julian Day计数。

参数

month

月份的范围从 1 (January) 到 12 ( December)

day

日期的范围从 1 到 31

year

年份的范围从 -4713 到 9999

返回值

指定julian历法中的日期所对应的julian天数。

参见

  • jdtojulian() - 转变一个Julian Day计数到Julian历法的日期
  • cal_to_jd() - 从一个支持的历法转变为Julian Day计数。


转变Unix时间戳为Julian Day计数

  • ? JulianToJD
  • 日期/时间 ?
  • PHP Manual
  • 日历 函数
  • 转变Unix时间戳为Julian Day计数

unixtojd

(PHP 4, PHP 5, PHP 7, PHP 8)

unixtojd — 转变Unix时间戳为Julian Day计数

说明

unixtojd ( int $timestamp = time() ) : int

根据指定的Unix时间戳timestamp，返回Julian天数。如果没有指定时间戳则返回当前日期的天数。

参数

timestamp

一个用于转变的时间戳。

返回值

一个julian天数。

参见

  • jdtounix() - 转变Julian Day计数为一个Unix时间戳


日期和时间

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Date/Time Arithmetic
  • DateTime — DateTime 类
    • DateTime::add — 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。
    • DateTime::__construct — 返回一个新的 DateTime 对象
    • DateTime::createFromFormat — 根据给定的格式解析日期时间字符串
    • DateTime::createFromImmutable — Returns new DateTime object encapsulating the given DateTimeImmutable object
    • DateTime::createFromInterface — Returns new DateTime object encapsulating the given DateTimeInterface object
    • DateTime::getLastErrors — 获取警告和错误信息
    • DateTime::modify — 修改日期时间对象的值
    • DateTime::__set_state — __set_state 魔术方法处理函数
    • DateTime::setDate — 设置 DateTime 对象的日期
    • DateTime::setISODate — 设置 ISO 日期
    • DateTime::setTime — 设置 DateTime 对象的时间
    • DateTime::setTimestamp — 以 Unix 时间戳的方式设置 DateTime 对象
    • DateTime::setTimezone — 设置 DateTime 对象的时区
    • DateTime::sub — 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。
  • DateTimeImmutable — The DateTimeImmutable class
    • DateTimeImmutable::add — Adds an amount of days, months, years, hours, minutes and seconds
    • DateTimeImmutable::__construct — Returns new DateTimeImmutable object
    • DateTimeImmutable::createFromFormat — Parses a time string according to a specified format
    • DateTimeImmutable::createFromInterface — Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object
    • DateTimeImmutable::createFromMutable — Returns new DateTimeImmutable object encapsulating the given DateTime object
    • DateTimeImmutable::getLastErrors — Returns the warnings and errors
    • DateTimeImmutable::modify — Creates a new object with modified timestamp
    • DateTimeImmutable::__set_state — The __set_state handler
    • DateTimeImmutable::setDate — Sets the date
    • DateTimeImmutable::setISODate — Sets the ISO date
    • DateTimeImmutable::setTime — Sets the time
    • DateTimeImmutable::setTimestamp — Sets the date and time based on a Unix timestamp
    • DateTimeImmutable::setTimezone — Sets the time zone
    • DateTimeImmutable::sub — Subtracts an amount of days, months, years, hours, minutes and seconds
  • DateTimeInterface — The DateTimeInterface interface
    • DateTime::diff — Returns the difference between two DateTime objects
    • DateTime::format — Returns date formatted according to given format
    • DateTime::getOffset — Returns the timezone offset
    • DateTime::getTimestamp — Gets the Unix timestamp
    • DateTime::getTimezone — Return time zone relative to given DateTime
    • DateTime::__wakeup — The __wakeup handler
  • DateTimeZone — The DateTimeZone class
    • DateTimeZone::__construct — 创建新的DateTimeZone对象
    • DateTimeZone::getLocation — 返回与时区相关的定位信息。
    • DateTimeZone::getName — 返回时区名称。
    • DateTimeZone::getOffset — 返回相对于 GMT 的时差。
    • DateTimeZone::getTransitions — Returns all transitions for the timezone
    • DateTimeZone::listAbbreviations — 返回一个包含 dst (夏令时)，时差和时区信息的关联数组。
    • DateTimeZone::listIdentifiers — 返回一个包含了所有时区标示符的索引数组。
  • DateInterval — DateInterval 类
    • DateInterval::__construct — Creates a new DateInterval object
    • DateInterval::createFromDateString — Sets up a DateInterval from the relative parts of the string
    • DateInterval::format — Formats the interval
  • DatePeriod — DatePeriod 类
    • DatePeriod::__construct — Creates a new DatePeriod object
    • DatePeriod::getDateInterval — Gets the interval
    • DatePeriod::getEndDate — Gets the end date
    • DatePeriod::getRecurrences — Gets the number of recurrences
    • DatePeriod::getStartDate — Gets the start date
  • Date/Time 函数
    • checkdate — 验证一个格里高里日期
    • date_add — 别名 DateTime::add
    • date_create_from_format — 别名 DateTime::createFromFormat
    • date_create_immutable_from_format — 别名 DateTimeImmutable::createFromFormat
    • date_create_immutable — 别名 DateTimeImmutable::__construct
    • date_create — 别名 DateTime::__construct
    • date_date_set — 别名 DateTime::setDate
    • date_default_timezone_get — 取得一个脚本中所有日期时间函数所使用的默认时区
    • date_default_timezone_set — 设定用于一个脚本中所有日期时间函数的默认时区
    • date_diff — 别名 DateTime::diff
    • date_format — 别名 DateTime::format
    • date_get_last_errors — 别名 DateTime::getLastErrors
    • date_interval_create_from_date_string — 别名 DateInterval::createFromDateString
    • date_interval_format — 别名 DateInterval::format
    • date_isodate_set — 别名 DateTime::setISODate
    • date_modify — 别名 DateTime::modify
    • date_offset_get — 别名 DateTime::getOffset
    • date_parse_from_format — Get info about given date formatted according to the specified format
    • date_parse — 返回指定日期/时间的详细信息的关联数组
    • date_sub — 别名 DateTime::sub
    • date_sun_info — Returns an array with information about sunset/sunrise and twilight begin/end
    • date_sunrise — 返回给定的日期与地点的日出时间
    • date_sunset — 返回给定的日期与地点的日落时间
    • date_time_set — 别名 DateTime::setTime
    • date_timestamp_get — 别名 DateTime::getTimestamp
    • date_timestamp_set — 别名 DateTime::setTimestamp
    • date_timezone_get — 别名 DateTime::getTimezone
    • date_timezone_set — 别名 DateTime::setTimezone
    • date — 格式化一个本地时间／日期
    • getdate — 取得日期／时间信息
    • gettimeofday — 取得当前时间
    • gmdate — 格式化一个 GMT/UTC 日期／时间
    • gmmktime — 取得 GMT 日期的 UNIX 时间戳
    • gmstrftime — 根据区域设置格式化 GMT/UTC 时间／日期
    • idate — 将本地时间日期格式化为整数
    • localtime — 取得本地时间
    • microtime — 返回当前 Unix 时间戳和微秒数
    • mktime — 取得一个日期的 Unix 时间戳
    • strftime — 根据区域设置格式化本地时间／日期
    • strptime — 解析由 strftime 生成的日期／时间
    • strtotime — 将任何字符串的日期时间描述解析为 Unix 时间戳
    • time — 返回当前的 Unix 时间戳
    • timezone_abbreviations_list — 别名 DateTimeZone::listAbbreviations
    • timezone_identifiers_list — 别名 DateTimeZone::listIdentifiers
    • timezone_location_get — 别名 DateTimeZone::getLocation
    • timezone_name_from_abbr — Returns the timezone name from abbreviation
    • timezone_name_get — 别名 DateTimeZone::getName
    • timezone_offset_get — 别名 DateTimeZone::getOffset
    • timezone_open — 别名 DateTimeZone::__construct
    • timezone_transitions_get — 别名 DateTimeZone::getTransitions
    • timezone_version_get — 获取 timezonedb 的版本
  • Supported Date and Time Formats
    • Time Formats
    • Date Formats
    • Compound Formats
    • Relative Formats
  • 所支持的时区列表
    • 非洲
    • 美洲
    • 南极洲
    • 北极
    • 亚洲
    • 大西洋
    • 澳洲
    • 欧洲
    • 印度
    • 太平洋地区
    • 其他


简介

你可以使用这些函数获取运行 PHP 的服务器的日期和时间， 也可以使用这些函数把日期和时间 格式化成不同格式的字符串。

日期和时间信息在 PHP 内部是以 64 位数字存储的， 它可以覆盖当前时间前后 2920 亿年的时间，这个范围之广，足以满足现有应用的实际需求。

Note: 需要注意的是， 这些函数都是依赖服务器的区域设置的， 所以在使用它们的时候，要考虑夏令时 （例如：使用 $date = strtotime('+7 days', $date) 而不是 $date += 7*24*60*60） 和闰年的情况。

Note: 本节中用到的时区可以从 所支持的时区列表 获取。


安装

使用这些函数不需要安装，它们是 PHP 核心的一部分。

Note: 获取最新版的时区数据

可以通过安装 PECL 的 » timezonedb 模块来获取最新的时区数据。

Note: 在 PHP 5.1.x 中支持的试验性时区

虽然 DateTime 类及其相关函数自 PHP 5.2.0 版本开始 就是默认启用的，也可以通过设置 CFLAGS=-DEXPERIMENTAL_DATE_SUPPORT=1 参数来配置/编译 PHP 5.1.x 版本来实现试验性的支持。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

日期／时间配置选项
名字 | 默认 | 可修改范围 | 更新日志
date.default_latitude | "31.7667" | PHP_INI_ALL |
date.default_longitude | "35.2333" | PHP_INI_ALL |
date.sunrise_zenith | "90.83" | PHP_INI_ALL |
date.sunset_zenith | "90.83" | PHP_INI_ALL |
date.timezone | "" | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

date.default_latitude float

默认纬度。

date.default_longitude float

默认经度。

date.sunrise_zenith float

默认日出天顶。

date.sunset_zenith float

默认日落天顶。

date.timezone string

在未设定 TZ 环境变量时用于所有日期／时间函数的默认时区。优先顺序在 date_default_timezone_get() 页面中有说明。 支持的时区可参见 所支持的时区列表。

Note: 前四个配置选项目前仅用于 date_sunrise() 和 date_sunset()。


预定义常量

DATE_ constants 从 PHP 5.1.1 开始定义， 提供了一些标准的日期时间的表达， 可以用在日期时间格式化的函数中（例如 date()）。

下列常量从 PHP 5.1.2 开始可用， 设定了 date_sunrise() 和 date_sunset() 函数返回的格式。

SUNFUNCS_RET_TIMESTAMP (integer)
时间戳
SUNFUNCS_RET_STRING (integer)
小时:分钟（例如：08:02）
SUNFUNCS_RET_DOUBLE (integer)
浮点数表示的小时（例如：8.75）


  • ? 预定义常量
  • Date/Time Arithmetic ?
  • PHP Manual
  • 日期/时间
  • 范例

范例

Table of Contents

  • Date/Time Arithmetic


Date/Time Arithmetic

The following examples show some pitfalls of Date/Time arithmetic with regard to DST transitions and months having different numbers of days.

Example #1 DateTimeImmutable::add/sub add intervals which cover elapsed time

Adding PT24H over a DST transition will appear to add 23/25 hours (for most timezones).

<?php
$dt = new DateTimeImmutable("2015-11-01 00:00:00", new DateTimeZone("America/New_York"));
echo "Start: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt = $dt->add(new DateInterval("PT3H"));
echo "End:   ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
?>

以上例程会输出：

Start: 2015-11-01 00:00:00 -04:00
End:   2015-11-01 02:00:00 -05:00

Example #2 DateTimeImmutable::modify and strtotime increment or decrement individual component values

Adding +24 hours over a DST transition will add exactly 24 hours as seen in the date/time string (unless the start or end time is on a transition point).

<?php
$dt = new DateTimeImmutable("2015-11-01 00:00:00", new DateTimeZone("America/New_York"));
echo "Start: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt = $dt->modify("+24 hours");
echo "End:   ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
?>

以上例程会输出：

Start: 2015-11-01 00:00:00 -04:00
End:   2015-11-02 00:00:00 -05:00

Example #3 Adding or subtracting times can over- or underflow dates

Like where January 31st + 1 month will result in March 2nd (leap year) or 3rd (normal year).

<?php
echo "Normal year:\n"; // February has 28 days
$dt = new DateTimeImmutable("2015-01-31 00:00:00", new DateTimeZone("America/New_York"));
echo "Start: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt = $dt->modify("+1 month");
echo "End:   ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;

echo "Leap year:\n"; // February has 29 days
$dt = new DateTimeImmutable("2016-01-31 00:00:00", new DateTimeZone("America/New_York"));
echo "Start: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt = $dt->modify("+1 month");
echo "End:   ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
?>

以上例程会输出：

Normal year:
Start: 2015-01-31 00:00:00 -05:00
End:   2015-03-03 00:00:00 -05:00
Leap year:
Start: 2016-01-31 00:00:00 -05:00
End:   2016-03-02 00:00:00 -05:00

To get the last day of the next month (i.e. to prevent the overflow), the last day of format is available as of PHP 5.3.0.

<?php
echo "Normal year:\n"; // February has 28 days
$dt = new DateTimeImmutable("2015-01-31 00:00:00", new DateTimeZone("America/New_York"));
echo "Start: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt = $dt->modify("last day of next month");
echo "End:   ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;

echo "Leap year:\n"; // February has 29 days
$dt = new DateTimeImmutable("2016-01-31 00:00:00", new DateTimeZone("America/New_York"));
echo "Start: ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
$dt = $dt->modify("last day of next month");
echo "End:   ", $dt->format("Y-m-d H:i:s P"), PHP_EOL;
?>

以上例程会输出：

Normal year:
Start: 2015-01-31 00:00:00 -05:00
End:   2015-02-28 00:00:00 -05:00
Leap year:
Start: 2016-01-31 00:00:00 -05:00
End:   2016-02-29 00:00:00 -05:00


DateTime 类

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

简介

日期和时间。

类摘要

DateTime implements DateTimeInterface {
/* 继承的常量 */
const string DateTimeInterface::ATOM = "Y-m-d\TH:i:sP" ;
const string DateTimeInterface::COOKIE = "l, d-M-Y H:i:s T" ;
const string DateTimeInterface::ISO8601 = "Y-m-d\TH:i:sO" ;
const string DateTimeInterface::RFC822 = "D, d M y H:i:s O" ;
const string DateTimeInterface::RFC850 = "l, d-M-y H:i:s T" ;
const string DateTimeInterface::RFC1036 = "D, d M y H:i:s O" ;
const string DateTimeInterface::RFC1123 = "D, d M Y H:i:s O" ;
const string DateTimeInterface::RFC7231 = "D, d M Y H:i:s \G\M\T" ;
const string DateTimeInterface::RFC2822 = "D, d M Y H:i:s O" ;
const string DateTimeInterface::RFC3339 = "Y-m-d\TH:i:sP" ;
const string DateTimeInterface::RFC3339_EXTENDED = "Y-m-d\TH:i:s.vP" ;
const string DateTimeInterface::RSS = "D, d M Y H:i:s O" ;
const string DateTimeInterface::W3C = "Y-m-d\TH:i:sP" ;
/* 方法 */
public __construct ( string $time = "now" , DateTimeZone $timezone = null )
public add ( DateInterval $interval ) : DateTime
public static createFromFormat ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTime
public static createFromImmutable ( DateTimeImmutable $object ) : DateTime
public static createFromInterface ( DateTimeInterface $object ) : DateTime
public static getLastErrors ( ) : array
public modify ( string $modifier ) : DateTime
public static __set_state ( array $array ) : DateTime
public setDate ( int $year , int $month , int $day ) : DateTime
public setISODate ( int $year , int $week , int $dayOfWeek = 1 ) : DateTime
public setTime ( int $hour , int $minute , int $second = 0 , int $microsecond = 0 ) : DateTime
public setTimestamp ( int $unixtimestamp ) : DateTime
public setTimezone ( DateTimeZone $timezone ) : DateTime
public sub ( DateInterval $interval ) : DateTime
public diff ( DateTimeInterface $targetObject , bool $absolute = false ) : DateInterval
public format ( string $format ) : string
public getOffset ( ) : int
public getTimestamp ( ) : int
public getTimezone ( ) : DateTimeZone|false
public __wakeup ( ) : void
}

更新日志

版本 | 说明
7.2.0 | DateTime 的类常量现在定义在 DateTimeInterface 上。
7.0.0 | 新增常量：DATE_RFC3339_EXTENDED 和 DateTime::RFC3339_EXTENDED。
5.5.0 | 实现 DateTimeInterface 接口。
5.4.24 | COOKIE 格式从 2 位数字表示年份（RFC 850） 修改为 4 位数字表示年份（RFC 1036）。
5.2.2 | DateTime 对象进行比较操作（comparison operators）的时候 可以正常工作了。 在之前的版本中，当使用 == 进行相等比较的时候， 所有的 DateTime 对象都会被视为是相等的。

Table of Contents

  • DateTime::add — 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。
  • DateTime::__construct — 返回一个新的 DateTime 对象
  • DateTime::createFromFormat — 根据给定的格式解析日期时间字符串
  • DateTime::createFromImmutable — Returns new DateTime object encapsulating the given DateTimeImmutable object
  • DateTime::createFromInterface — Returns new DateTime object encapsulating the given DateTimeInterface object
  • DateTime::getLastErrors — 获取警告和错误信息
  • DateTime::modify — 修改日期时间对象的值
  • DateTime::__set_state — __set_state 魔术方法处理函数
  • DateTime::setDate — 设置 DateTime 对象的日期
  • DateTime::setISODate — 设置 ISO 日期
  • DateTime::setTime — 设置 DateTime 对象的时间
  • DateTime::setTimestamp — 以 Unix 时间戳的方式设置 DateTime 对象
  • DateTime::setTimezone — 设置 DateTime 对象的时区
  • DateTime::sub — 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。


给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。

  • ? DateTime
  • DateTime::__construct ?
  • PHP Manual
  • DateTime
  • 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。

DateTime::add

date_add

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::add -- date_add — 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。

说明

面向对象风格

public DateTime::add ( DateInterval $interval ) : DateTime

过程化风格

date_add ( DateTime $object , DateInterval $interval ) : DateTime

将给定的 DateInterval 对象 加到 DateTime 对象上。

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

interval

DateInterval 对象。

返回值

返回被修改的 DateTime 对象， 或者在失败时返回 false.

范例

Example #1 DateTime::add() 例程

面向对象风格

<?php
$date = new DateTime('2000-01-01');
$date->add(new DateInterval('P10D'));
echo $date->format('Y-m-d') . "\n";
?>

过程化风格

<?php
$date = date_create('2000-01-01');
date_add($date, date_interval_create_from_date_string('10 days'));
echo date_format($date, 'Y-m-d');
?>

以上例程会输出：

2000-01-11

Example #2 Further DateTime::add() 例程

<?php
$date = new DateTime('2000-01-01');
$date->add(new DateInterval('PT10H30S'));
echo $date->format('Y-m-d H:i:s') . "\n";

$date = new DateTime('2000-01-01');
$date->add(new DateInterval('P7Y5M4DT4H3M2S'));
echo $date->format('Y-m-d H:i:s') . "\n";
?>

以上例程会输出：

2000-01-01 10:00:30
2007-06-05 04:03:02

Example #3 当在 DateTime 上加月的时候要注意

<?php
$date = new DateTime('2000-12-31');
$interval = new DateInterval('P1M');

$date->add($interval);
echo $date->format('Y-m-d') . "\n";

$date->add($interval);
echo $date->format('Y-m-d') . "\n";
?>

以上例程会输出：

2001-01-31
2001-03-03

注释

在 PHP 5.2 的版本中， 也可以使用 DateTime::modify() 方法来替代本方法。

参见

  • DateTime::sub() - 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。
  • DateTime::diff() - Returns the difference between two DateTime objects
  • DateTime::modify() - 修改日期时间对象的值


返回一个新的 DateTime 对象

  • ? DateTime::add
  • DateTime::createFromFormat ?
  • PHP Manual
  • DateTime
  • 返回一个新的 DateTime 对象

DateTime::__construct

date_create

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::__construct -- date_create — 返回一个新的 DateTime 对象

说明

面向对象风格

public DateTime::__construct ( string $time = "now" , DateTimeZone $timezone = null )

过程化风格

date_create ( string $time = "now" , DateTimeZone $timezone = null ) : DateTime

返回一个新的 DateTime 对象。

参数

time

日期/时间字符串。正确格式的说明详见 日期与时间格式。

如果这个参数为字符串 "now" 表示获取当前时间。 如果同时指定了 $timezone 参数，那么获取指定时区的当前时间。

timezone

DateTimeZone 对象， 表示要获取哪个时区的 $time。

如果省略了 $timezone 参数， 那么会使用当前时区。

Note:

当 $time 参数是 UNIX 时间戳 （例如 @946684800）， 或者已经包含时区信息 （例如 2010-01-28T15:00:00+02:00）的时候， $timezone 参数 和当前时区都将被忽略。

返回值

返回一个新的 DateTime 对象实例，或者在发生错误的时候返回 过程化风格在失败时返回 false。。

错误／异常

如果发生错误，会抛出 Exception。

更新日志

版本 | 说明
7.1 | 微秒部分不再是 '00000' 了，而是真实的微秒数据。
5.3.0 | 如果 time 参数不是一个有效的 日期/时间格式， 会抛出异常。 在之前的版本中是会发出一个错误。

范例

Example #1 DateTime::__construct() 例程

面向对象风格

<?php
try {
    $date = new DateTime('2000-01-01');
} catch (Exception $e) {
    echo $e->getMessage();
    exit(1);
}

echo $date->format('Y-m-d');
?>

过程化风格

<?php
$date = date_create('2000-01-01');
if (!$date) {
    $e = date_get_last_errors();
    foreach ($e['errors'] as $error) {
        echo "$error\n";
    }
    exit(1);
}

echo date_format($date, 'Y-m-d');
?>

以上例程会输出：

2000-01-01

Example #2 DateTime::__construct() 的复杂用法

<?php
// 指定时间，但是使用电脑的时区
$date = new DateTime('2000-01-01');
echo $date->format('Y-m-d H:i:sP') . "\n";

// 指定时间和时区
$date = new DateTime('2000-01-01', new DateTimeZone('Pacific/Nauru'));
echo $date->format('Y-m-d H:i:sP') . "\n";

// 使用当前时间以及电脑的时区
$date = new DateTime();
echo $date->format('Y-m-d H:i:sP') . "\n";

// 使用当前时间和指定的时区
$date = new DateTime(null, new DateTimeZone('Pacific/Nauru'));
echo $date->format('Y-m-d H:i:sP') . "\n";

// 使用 UNIX 时间戳作为时间，请注意这里的生成的 DateTime 对象对应的是 UTC 时区
$date = new DateTime('@946684800');
echo $date->format('Y-m-d H:i:sP') . "\n";

// 指定一个无效的时间，会自动对应到有效的时间
$date = new DateTime('2000-02-30');
echo $date->format('Y-m-d H:i:sP') . "\n";
?>

以上例程的输出类似于：

2000-01-01 00:00:00-05:00
2000-01-01 00:00:00+12:00
2010-04-24 10:24:16-04:00
2010-04-25 02:24:16+12:00
2000-01-01 00:00:00+00:00
2000-03-01 00:00:00-05:00

参见

  • DateTime::createFromFormat() - 根据给定的格式解析日期时间字符串
  • DateTimeZone::__construct() - 创建新的DateTimeZone对象
  • 日期时间格式
  • date.timezone ini 设置
  • date_default_timezone_set() - 设定用于一个脚本中所有日期时间函数的默认时区
  • DateTime::getLastErrors() - 获取警告和错误信息
  • checkdate() - 验证一个格里高里日期


根据给定的格式解析日期时间字符串

  • ? DateTime::__construct
  • DateTime::createFromImmutable ?
  • PHP Manual
  • DateTime
  • 根据给定的格式解析日期时间字符串

DateTime::createFromFormat

date_create_from_format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::createFromFormat -- date_create_from_format — 根据给定的格式解析日期时间字符串

说明

面向对象风格

public static DateTime::createFromFormat ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTime

过程化风格

date_create_from_format ( string $format , string $time , DateTimeZone $timezone = ? ) : DateTime

将 time 参数给定的日期时间字符串， 根据 format 参数给定的格式 解析为一个新的 DateTime 对象。

参数

format

在解析日期时间字符串的时候使用的格式 string。 参加下列的格式清单。 大部分格式和 date() 函数中的格式是一致的。

format 参数中支持的字符
format 中的字符 | 解释 | 示例
日 --- ---
d 和 j | 一个月中的第几天，2 位数字表示，有前导 0 或者无前导 0 | 01 到 31 或者 1 到 31
D 和 l | 星期几的文字表示 | Mon 到 Sun 或者 Sunday 到 Saturday
S | 2 个字母表示的一个月中的第几天（序数词）， 在进行解析的时候会被忽略 | st，nd，rd 或者 th。
z | 一年中的第几天，从 0 开始 | 0 到 365
月 --- ---
F 和 M | 文本表示的月份，例如 January 或者 Sept | January 到 December 或者 Jan 到 Dec
m 和 n | 数值表示的月份，有前导 0 或者无前导 0 | 01 到 12 or 1 到 12
年 --- ---
Y | 4 位数字表示的年 | 例如：1999 或 2003
y | 2 位数字表示的年， 可用的范围是 1970 至 2069（不含） | 例如： 99 或 03 （表示 1999 和 2003）
时间 --- ---
a 和 A | 上午、下午 | am 或 pm
g and h | 12 小时制的小时，有前导 0 或者无前导 0 | 1 到 12 或者 01 到 12
G 和 H | 24 小时制的小时，有前导 0 或者无前导 0 | 0 到 23 或 00 到 23
i | 分钟，有前导 0 | 00 到 59
s | 秒，有前导 0 | 00 到 59
u | 微秒，最多到 6 位数字 | 示例：45，654321
时区 --- ---
e，O, P 和 T | 时区名称，或者是以 UTC 时区为基准的小时偏移量， 或者是以 UTC 为基准的小时和分钟的偏移量， 小时和分钟之间用冒号（:）分隔。 | 示例：UTC，GMT， Atlantic/Azores 或 +0200 或 +02:00 或 EST，MDT
完整的日期和时间 --- ---
U | 从 Unix Epoch (January 1 1970 00:00:00 GMT) 开始计算的时间，以秒为单位 | 示例：1292177455
空白字符和分隔字符 --- ---
（空格） | 一个空格字符或者一个 tab 字符 | 示例：
# 可以是一下分隔符号中的任意一个： ;， :，/，.， ,，-，( 或 ) 示例：/
;， :，/，.， ,，-，( 或 ) | 特殊字符 | 示例：-
? 随机字节 示例：^ （需要注意的是， 对于 UTF-8 字符，可能会需要多个 ?。 这种情况下，请使用 *）
* 随机字节，直到遇到下一个有效的分隔符号或者数值 示例：使用 Y-*-d 格式用来解析 2009-aWord-08 字符串的时候， * 会匹配 aWord
! 将所有的字段（年、月、日、时、分、秒、微秒以及时区）重置到 Unix Epoch 时间。 如果不使用 !, 格式， 那么所有的字段会被设置为系统当前的日期和时间。
| 将尚未被解析的字段，也即格式字符串中未明确指定的字段 （年、月、日、时、分、秒、微秒以及时区） 重置到 Unix Epoch 时间。 Y-m-d| 会解析日期时间字符串中的年、月和日， 但是对于时、分、秒字段会设置为 0.
+ 在格式字符串中使用这个格式表示字符， 并且所提供的日期时间字符串中包含除了格式字符之外的其他数据的话，不会发出一个错误，而是发出一个警告。 使用 DateTime::getLastErrors() 方法 来检测所给定的日期时间字符串中是否包含格式字符串指定的内容之外的数据。

如果在格式字符串中包含不可识别的字符， 那么会导致解析失败，并且在返回的结构中附加一个错误信息。 可以通过 DateTime::getLastErrors() 来探查解析是否存在错误。

如果需要在格式字符串 format 参数中使用 上述表示格式的字符作为一个普通字符，请对其使用反斜线（\）进行转义。

如果格式字符串参数 format 中不包含 ! 字符， 那么没有在 format 参数中指明的字段， 在解析结果中将会被设置为系统当前时间对应的字段值。

如果格式字符串参数 format 包含了 ! 字符， 那么没有在 format 参数中指明的字段， 以及在 ! 左侧对应的字段， 在解析结果中将会被设置为 Unix epoch 时间对应的字段。

The Unix epoch 为 1970-01-01 00:00:00 UTC。

time

用来表示日期时间的字符串。

timezone

DateTimeZone 对象， 表示在解析日期时间字符串的时候需要使用的时区。

如果忽略 timezone 参数， 并且表示日期时间的字符串 time 中也不包含时区信息， 那么将会使用系统当前时区作为解析结果对象的时区。

Note:

如果 time 参数 是 UNIX 时间戳格式（例如：946684800）， 或者其中已经包含了时区信息（例如：2010-01-28T15:00:00+02:00）， 那么 timezone 以及系统当前时区 都将会被忽略。

返回值

返回一个 DateTime 对象。 或者在失败时返回 false。

更新日志

版本 | 说明
5.3.9 | 新增 format 格式字符串中对于 + 格式字符的支持。

范例

Example #1 DateTime::createFromFormat() 例程

面向对象风格

<?php
$date = DateTime::createFromFormat('j-M-Y', '15-Feb-2009');
echo $date->format('Y-m-d');
?>

过程化风格

<?php
$date = date_create_from_format('j-M-Y', '15-Feb-2009');
echo date_format($date, 'Y-m-d');
?>

以上例程会输出：

2009-02-15

Example #2 DateTime::createFromFormat() 的复杂用法

<?php
echo 'Current time: ' . date('Y-m-d H:i:s') . "\n";

$format = 'Y-m-d';
$date = DateTime::createFromFormat($format, '2009-02-15');
echo "Format: $format; " . $date->format('Y-m-d H:i:s') . "\n";

$format = 'Y-m-d H:i:s';
$date = DateTime::createFromFormat($format, '2009-02-15 15:16:17');
echo "Format: $format; " . $date->format('Y-m-d H:i:s') . "\n";

$format = 'Y-m-!d H:i:s';
$date = DateTime::createFromFormat($format, '2009-02-15 15:16:17');
echo "Format: $format; " . $date->format('Y-m-d H:i:s') . "\n";

$format = '!d';
$date = DateTime::createFromFormat($format, '15');
echo "Format: $format; " . $date->format('Y-m-d H:i:s') . "\n";
?>

以上例程的输出类似于：

Current time: 2010-04-23 10:29:35
Format: Y-m-d; 2009-02-15 10:29:35
Format: Y-m-d H:i:s; 2009-02-15 15:16:17
Format: Y-m-!d H:i:s; 1970-01-15 15:16:17
Format: !d; 1970-01-15 00:00:00

Example #3 格式化字符串中包含了需要进行转义的字符

<?php
echo DateTime::createFromFormat('H\h i\m s\s','23h 15m 03s')->format('H:i:s');
?>

以上例程的输出类似于：

23:15:03

参见

  • DateTime::__construct() - 返回一个新的 DateTime 对象
  • DateTime::getLastErrors() - 获取警告和错误信息
  • checkdate() - 验证一个格里高里日期
  • strptime() - 解析由 strftime 生成的日期／时间


Returns new DateTime object encapsulating the given DateTimeImmutable object

  • ? DateTime::createFromFormat
  • DateTime::createFromInterface ?
  • PHP Manual
  • DateTime
  • Returns new DateTime object encapsulating the given DateTimeImmutable object

DateTime::createFromImmutable

(PHP 7 >= 7.3.0, PHP 8)

DateTime::createFromImmutable — Returns new DateTime object encapsulating the given DateTimeImmutable object

说明

public static DateTime::createFromImmutable ( DateTimeImmutable $object ) : DateTime

参数

object

The immutable DateTimeImmutable object that needs to be converted to a mutable version. This object is not modified, but instead a new DateTime object is created containing the same date, time, and timezone information.

范例

Example #1 Creating a mutable date time object

<?php
$date = new DateTimeImmutable("2014-06-20 11:45 Europe/London");

$mutable = DateTime::createFromImmutable( $date );
?>

返回值

Returns a new DateTime instance.


Returns new DateTime object encapsulating the given DateTimeInterface object

  • ? DateTime::createFromImmutable
  • DateTime::getLastErrors ?
  • PHP Manual
  • DateTime
  • Returns new DateTime object encapsulating the given DateTimeInterface object

DateTime::createFromInterface

(PHP 8)

DateTime::createFromInterface — Returns new DateTime object encapsulating the given DateTimeInterface object

说明

public static DateTime::createFromInterface ( DateTimeInterface $object ) : DateTime

参数

object

The DateTimeInterface object that needs to be converted to a mutable version. This object is not modified, but instead a new DateTime object is created containing the same date, time, and timezone information.

返回值

Returns a new DateTime instance.

范例

Example #1 Creating a mutable date time object

<?php
$date = new DateTimeImmutable("2014-06-20 11:45 Europe/London");

$mutable = DateTime::createFromInterface($date);

$date = new DateTime("2014-06-20 11:45 Europe/London");
$also_mutable = DateTime::createFromInterface($date);
?>


获取警告和错误信息

  • ? DateTime::createFromInterface
  • DateTime::modify ?
  • PHP Manual
  • DateTime
  • 获取警告和错误信息

DateTime::getLastErrors

date_get_last_errors

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::getLastErrors -- date_get_last_errors — 获取警告和错误信息

说明

面向对象风格

public static DateTime::getLastErrors ( ) : array

过程化风格

date_get_last_errors ( ) : array

返回在解析日期时间字符串的过程中发生的警告和错误信息。

参数

此函数没有参数。

返回值

返回一个数组，其中包含在解析日期时间字符串的过程中发生的警告和错误信息。

范例

Example #1 DateTime::getLastErrors() 例程

面向对象风格

<?php
try {
    $date = new DateTime('asdfasdf');
} catch (Exception $e) {
    // 仅出于演示的目的...
    print_r(DateTime::getLastErrors());

    // 实际的代码中你应该这样使用返回对象
    // echo $e->getMessage();
}
?>

过程化风格

<?php
$date = date_create('asdfasdf');
print_r(date_get_last_errors());
?>

以上例程会输出：

Array
(
   [warning_count] => 1
   [warnings] => Array
       (
           [6] => Double timezone specification
       )

   [error_count] => 1
   [errors] => Array
       (
           [0] => The timezone could not be found in the database
       )

)

返回数组中的索引 6 和 0 表示在解析过程中，所提供的日期时间字符串中无法正确解析的字符位置。


修改日期时间对象的值

  • ? DateTime::getLastErrors
  • DateTime::__set_state ?
  • PHP Manual
  • DateTime
  • 修改日期时间对象的值

DateTime::modify

date_modify

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::modify -- date_modify — 修改日期时间对象的值

说明

面向对象风格

public DateTime::modify ( string $modifier ) : DateTime

过程化风格

date_modify ( DateTime $object , string $modifier ) : DateTime

修改一个日期时间对象的值。 支持 DateTimeImmutable::__construct() 函数所允许的字符串。

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

modifier

日期/时间字符串。正确格式的说明详见 日期与时间格式。

返回值

返回被修改的 DateTime 对象， 或者在失败时返回 false.

范例

Example #1 DateTime::modify() 例程

面向对象风格

<?php
$date = new DateTime('2006-12-12');
$date->modify('+1 day');
echo $date->format('Y-m-d');
?>

过程化风格

<?php
$date = date_create('2006-12-12');
date_modify($date, '+1 day');
echo date_format($date, 'Y-m-d');
?>

以上例程会输出：

2006-12-13

Example #2 增加或者减少月份的时候需要注意

<?php
$date = new DateTime('2000-12-31');

$date->modify('+1 month');
echo $date->format('Y-m-d') . "\n";

$date->modify('+1 month');
echo $date->format('Y-m-d') . "\n";
?>

以上例程会输出：

2001-01-31
2001-03-03

参见

  • strtotime() - 将任何字符串的日期时间描述解析为 Unix 时间戳
  • DateTime::add() - 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。
  • DateTime::sub() - 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。
  • DateTime::setDate() - 设置 DateTime 对象的日期
  • DateTime::setISODate() - 设置 ISO 日期
  • DateTime::setTime() - 设置 DateTime 对象的时间
  • DateTime::setTimestamp() - 以 Unix 时间戳的方式设置 DateTime 对象


__set_state 魔术方法处理函数

  • ? DateTime::modify
  • DateTime::setDate ?
  • PHP Manual
  • DateTime
  • __set_state 魔术方法处理函数

DateTime::__set_state

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::__set_state — __set_state 魔术方法处理函数

说明

public static DateTime::__set_state ( array $array ) : DateTime

__set_state() 魔术方法处理函数。

参数

array

用来初始化对象属性值的数组。

返回值

返回 DateTime 对象实例。


设置 DateTime 对象的日期

  • ? DateTime::__set_state
  • DateTime::setISODate ?
  • PHP Manual
  • DateTime
  • 设置 DateTime 对象的日期

DateTime::setDate

date_date_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::setDate -- date_date_set — 设置 DateTime 对象的日期

说明

面向对象风格

public DateTime::setDate ( int $year , int $month , int $day ) : DateTime

过程化风格

date_date_set ( DateTime $object , int $year , int $month , int $day ) : DateTime

设置 DateTime 对象的日期。

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

year

年份。

month

月份。

day

日。

返回值

返回被修改的 DateTime 对象， 或者在失败时返回 false.

范例

Example #1 DateTime::setDate() 例程

面向对象风格

<?php
$date = new DateTime();
$date->setDate(2001, 2, 3);
echo $date->format('Y-m-d');
?>

过程化风格

<?php
$date = date_create();
date_date_set($date, 2001, 2, 3);
echo date_format($date, 'Y-m-d');
?>

以上例程会输出：

2001-02-03

Example #2 超出范围的部分会向上一级增加

<?php
$date = new DateTime();

$date->setDate(2001, 2, 28);
echo $date->format('Y-m-d') . "\n";

$date->setDate(2001, 2, 29);
echo $date->format('Y-m-d') . "\n";

$date->setDate(2001, 14, 3);
echo $date->format('Y-m-d') . "\n";
?>

以上例程会输出：

2001-02-28
2001-03-01
2002-02-03

参见

  • DateTime::setISODate() - 设置 ISO 日期
  • DateTime::setTime() - 设置 DateTime 对象的时间


设置 ISO 日期

  • ? DateTime::setDate
  • DateTime::setTime ?
  • PHP Manual
  • DateTime
  • 设置 ISO 日期

DateTime::setISODate

date_isodate_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::setISODate -- date_isodate_set — 设置 ISO 日期

说明

面向对象风格

public DateTime::setISODate ( int $year , int $week , int $dayOfWeek = 1 ) : DateTime

过程化风格

date_isodate_set ( DateTime $object , int $year , int $week , int $dayOfWeek = 1 ) : DateTime

以 ISO 8601 规范的格式设置日期， 使用周和日的偏移量作为参数，而不是使用月和日。

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

year

年份。

week

周。

dayOfWeek

从周的第一天计算，日在一周内的偏移量。

返回值

返回被修改的 DateTime 对象， 或者在失败时返回 false.

范例

Example #1 DateTime::setISODate() 例程

面向对象风格

<?php
$date = new DateTime();

$date->setISODate(2008, 2);
echo $date->format('Y-m-d') . "\n";

$date->setISODate(2008, 2, 7);
echo $date->format('Y-m-d') . "\n";
?>

过程化风格

<?php
$date = date_create();

date_isodate_set($date, 2008, 2);
echo date_format($date, 'Y-m-d') . "\n";

date_isodate_set($date, 2008, 2, 7);
echo date_format($date, 'Y-m-d') . "\n";
?>

以上例程会输出：

2008-01-07
2008-01-13

Example #2 超出有效范围的部分，会加到上一级

<?php
$date = new DateTime();

$date->setISODate(2008, 2, 7);
echo $date->format('Y-m-d') . "\n";

$date->setISODate(2008, 2, 8);
echo $date->format('Y-m-d') . "\n";

$date->setISODate(2008, 53, 7);
echo $date->format('Y-m-d') . "\n";
?>

以上例程会输出：

2008-01-13
2008-01-14
2009-01-04

Example #3 找出来某个周所属的月份

<?php
$date = new DateTime();
$date->setISODate(2008, 14);
echo $date->format('n');
?>

以上例程会输出：

3

参见

  • DateTime::setDate() - 设置 DateTime 对象的日期
  • DateTime::setTime() - 设置 DateTime 对象的时间


设置 DateTime 对象的时间

  • ? DateTime::setISODate
  • DateTime::setTimestamp ?
  • PHP Manual
  • DateTime
  • 设置 DateTime 对象的时间

DateTime::setTime

date_time_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::setTime -- date_time_set — 设置 DateTime 对象的时间

说明

面向对象风格

public DateTime::setTime ( int $hour , int $minute , int $second = 0 , int $microsecond = 0 ) : DateTime

过程化风格

date_time_set ( DateTime $object , int $hour , int $minute , int $second = 0 , int $microsecond = 0 ) : DateTime

设置 DateTime 对象的时间。

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

hour

小时。

minute

分钟。

second

秒。

microsecond

微秒。

返回值

返回被修改的 DateTime 对象， 或者在失败时返回 false.

更新日志

版本 | 说明
7.1.0 | 新增 microsecond 参数。

范例

Example #1 DateTime::setTime() 例程

面向对象风格

<?php
$date = new DateTime('2001-01-01');

$date->setTime(14, 55);
echo $date->format('Y-m-d H:i:s') . "\n";

$date->setTime(14, 55, 24);
echo $date->format('Y-m-d H:i:s') . "\n";
?>

过程化风格

<?php
$date = date_create('2001-01-01');

date_time_set($date, 14, 55);
echo date_format($date, 'Y-m-d H:i:s') . "\n";

date_time_set($date, 14, 55, 24);
echo date_format($date, 'Y-m-d H:i:s') . "\n";
?>

以上例程的输出类似于：

2001-01-01 14:55:00
2001-01-01 14:55:24

Example #2 超出有效范围的部分会增加到上一级

<?php
$date = new DateTime('2001-01-01');

$date->setTime(14, 55, 24);
echo $date->format('Y-m-d H:i:s') . "\n";

$date->setTime(14, 55, 65);
echo $date->format('Y-m-d H:i:s') . "\n";

$date->setTime(14, 65, 24);
echo $date->format('Y-m-d H:i:s') . "\n";

$date->setTime(25, 55, 24);
echo $date->format('Y-m-d H:i:s') . "\n";
?>

以上例程会输出：

2001-01-01 14:55:24
2001-01-01 14:56:05
2001-01-01 15:05:24
2001-01-02 01:55:24

参见

  • DateTime::setDate() - 设置 DateTime 对象的日期
  • DateTime::setISODate() - 设置 ISO 日期


以 Unix 时间戳的方式设置 DateTime 对象

  • ? DateTime::setTime
  • DateTime::setTimezone ?
  • PHP Manual
  • DateTime
  • 以 Unix 时间戳的方式设置 DateTime 对象

DateTime::setTimestamp

date_timestamp_set

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::setTimestamp -- date_timestamp_set — 以 Unix 时间戳的方式设置 DateTime 对象

说明

面向对象风格

public DateTime::setTimestamp ( int $unixtimestamp ) : DateTime

过程化风格

date_timestamp_set ( DateTime $object , int $unixtimestamp ) : DateTime

以 Unix 时间戳的方式设置 DateTime 对象的日期和时间。

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

unixtimestamp

表示日期时间的 Unix 时间戳。

返回值

返回被修改的 DateTime 对象， 或者在失败时返回 false.

范例

Example #1 DateTime::setTimestamp() 例程

面向对象风格

<?php
$date = new DateTime();
echo $date->format('U = Y-m-d H:i:s') . "\n";

$date->setTimestamp(1171502725);
echo $date->format('U = Y-m-d H:i:s') . "\n";
?>

过程化风格

<?php
$date = date_create();
echo date_format($date, 'U = Y-m-d H:i:s') . "\n";

date_timestamp_set($date, 1171502725);
echo date_format($date, 'U = Y-m-d H:i:s') . "\n";
?>

以上例程的输出类似于：

1272508903 = 2010-04-28 22:41:43
1171502725 = 2007-02-14 20:25:25

注释

PHP 5.2 之后的版本中， 可以使用 Unix 时间戳作为构造函数的参数生成新的 DateTime 对象，例如：

Example #2 PHP 5.2 之后的版本中，DateTime::setTimestamp() 替代方案

<?php
$ts = 1171502725;
$date = new DateTime("@$ts");
echo $date->format('U = Y-m-d H:i:s') . "\n";
?>

以上例程的输出类似于：

1171502725 = 2007-02-14 20:25:25

参见

  • DateTime::getTimestamp() - Gets the Unix timestamp


设置 DateTime 对象的时区

  • ? DateTime::setTimestamp
  • DateTime::sub ?
  • PHP Manual
  • DateTime
  • 设置 DateTime 对象的时区

DateTime::setTimezone

date_timezone_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTime::setTimezone -- date_timezone_set — 设置 DateTime 对象的时区

说明

面向对象风格

public DateTime::setTimezone ( DateTimeZone $timezone ) : DateTime

过程化风格

date_timezone_set ( DateTime $object , DateTimeZone $timezone ) : DateTime

设置 DateTime object 的时区。

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

timezone

DateTimeZone 对象， 表示要设置为时区。

返回值

返回被修改的 DateTime 对象， 或者在失败时返回 false.

范例

Example #1 DateTime::setTimeZone() 例程

面向对象风格

<?php
$date = new DateTime('2000-01-01', new DateTimeZone('Pacific/Nauru'));
echo $date->format('Y-m-d H:i:sP') . "\n";

$date->setTimezone(new DateTimeZone('Pacific/Chatham'));
echo $date->format('Y-m-d H:i:sP') . "\n";
?>

过程化风格

<?php
$date = date_create('2000-01-01', timezone_open('Pacific/Nauru'));
echo date_format($date, 'Y-m-d H:i:sP') . "\n";

date_timezone_set($date, timezone_open('Pacific/Chatham'));
echo date_format($date, 'Y-m-d H:i:sP') . "\n";
?>

以上例程会输出：

2000-01-01 00:00:00+12:00
2000-01-01 01:45:00+13:45

参见

  • DateTime::getTimezone() - Return time zone relative to given DateTime
  • DateTimeZone::__construct() - 创建新的DateTimeZone对象


对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。

  • ? DateTime::setTimezone
  • DateTimeImmutable ?
  • PHP Manual
  • DateTime
  • 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。

DateTime::sub

date_sub

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::sub -- date_sub — 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。

说明

面向对象风格

public DateTime::sub ( DateInterval $interval ) : DateTime

过程化风格

date_sub ( DateTime $object , DateInterval $interval ) : DateTime

DateInterval 对象， 表示要减去多少量的时间。

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

interval

DateInterval 对象

返回值

返回被修改的 DateTime 对象， 或者在失败时返回 false.

范例

Example #1 DateTime::sub() 例程

面向对象风格

<?php
$date = new DateTime('2000-01-20');
$date->sub(new DateInterval('P10D'));
echo $date->format('Y-m-d') . "\n";
?>

过程化风格

<?php
$date = date_create('2000-01-20');
date_sub($date, date_interval_create_from_date_string('10 days'));
echo date_format($date, 'Y-m-d');
?>

以上例程会输出：

2000-01-10

Example #2 Further DateTime::sub() 例程

<?php
$date = new DateTime('2000-01-20');
$date->sub(new DateInterval('PT10H30S'));
echo $date->format('Y-m-d H:i:s') . "\n";

$date = new DateTime('2000-01-20');
$date->sub(new DateInterval('P7Y5M4DT4H3M2S'));
echo $date->format('Y-m-d H:i:s') . "\n";
?>

以上例程会输出：

2000-01-19 13:59:30
1992-08-15 19:56:58

Example #3 减去一定量的月份的时候需要注意

<?php
$date = new DateTime('2001-04-30');
$interval = new DateInterval('P1M');

$date->sub($interval);
echo $date->format('Y-m-d') . "\n";

$date->sub($interval);
echo $date->format('Y-m-d') . "\n";
?>

以上例程会输出：

2001-03-30
2001-03-02

注释

在 PHP 5.2 之后，可以使用 DateTime::modify() 作为替代。

参见

  • DateTime::add() - 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。
  • DateTime::diff() - Returns the difference between two DateTime objects
  • DateTime::modify() - 修改日期时间对象的值


The DateTimeImmutable class

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

简介

Representation of date and time.

类摘要

DateTimeImmutable implements DateTimeInterface {
/* 继承的常量 */
const string DateTimeInterface::ATOM = "Y-m-d\TH:i:sP" ;
const string DateTimeInterface::COOKIE = "l, d-M-Y H:i:s T" ;
const string DateTimeInterface::ISO8601 = "Y-m-d\TH:i:sO" ;
const string DateTimeInterface::RFC822 = "D, d M y H:i:s O" ;
const string DateTimeInterface::RFC850 = "l, d-M-y H:i:s T" ;
const string DateTimeInterface::RFC1036 = "D, d M y H:i:s O" ;
const string DateTimeInterface::RFC1123 = "D, d M Y H:i:s O" ;
const string DateTimeInterface::RFC7231 = "D, d M Y H:i:s \G\M\T" ;
const string DateTimeInterface::RFC2822 = "D, d M Y H:i:s O" ;
const string DateTimeInterface::RFC3339 = "Y-m-d\TH:i:sP" ;
const string DateTimeInterface::RFC3339_EXTENDED = "Y-m-d\TH:i:s.vP" ;
const string DateTimeInterface::RSS = "D, d M Y H:i:s O" ;
const string DateTimeInterface::W3C = "Y-m-d\TH:i:sP" ;
/* 方法 */
public __construct ( string $datetime = "now" , DateTimeZone|null $timezone = null )
public add ( DateInterval $interval ) : DateTimeImmutable
public static createFromFormat ( string $format , string $datetime , DateTimeZone|null $timezone = null ) : DateTimeImmutable|false
public static createFromInterface ( DateTimeInterface $object ) : DateTimeImmutable
public static createFromMutable ( DateTime $object ) : DateTimeImmutable
public static getLastErrors ( ) : array|false
public modify ( string $modifier ) : DateTimeImmutable|false
public static __set_state ( array $array ) : DateTimeImmutable
public setDate ( int $year , int $month , int $day ) : DateTimeImmutable
public setISODate ( int $year , int $week , int $dayOfWeek = 1 ) : DateTimeImmutable
public setTime ( int $hour , int $minute , int $second = 0 , int $microsecond = 0 ) : DateTimeImmutable
public setTimestamp ( int $timestamp ) : DateTimeImmutable
public setTimezone ( DateTimeZone $timezone ) : DateTimeImmutable
public sub ( DateInterval $interval ) : DateTimeImmutable
public diff ( DateTimeInterface $targetObject , bool $absolute = false ) : DateInterval
public format ( string $format ) : string
public getOffset ( ) : int
public getTimestamp ( ) : int
public getTimezone ( ) : DateTimeZone|false
public __wakeup ( ) : void
}

Table of Contents

  • DateTimeImmutable::add — Adds an amount of days, months, years, hours, minutes and seconds
  • DateTimeImmutable::__construct — Returns new DateTimeImmutable object
  • DateTimeImmutable::createFromFormat — Parses a time string according to a specified format
  • DateTimeImmutable::createFromInterface — Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object
  • DateTimeImmutable::createFromMutable — Returns new DateTimeImmutable object encapsulating the given DateTime object
  • DateTimeImmutable::getLastErrors — Returns the warnings and errors
  • DateTimeImmutable::modify — Creates a new object with modified timestamp
  • DateTimeImmutable::__set_state — The __set_state handler
  • DateTimeImmutable::setDate — Sets the date
  • DateTimeImmutable::setISODate — Sets the ISO date
  • DateTimeImmutable::setTime — Sets the time
  • DateTimeImmutable::setTimestamp — Sets the date and time based on a Unix timestamp
  • DateTimeImmutable::setTimezone — Sets the time zone
  • DateTimeImmutable::sub — Subtracts an amount of days, months, years, hours, minutes and seconds


Adds an amount of days, months, years, hours, minutes and seconds

  • ? DateTimeImmutable
  • DateTimeImmutable::__construct ?
  • PHP Manual
  • DateTimeImmutable
  • Adds an amount of days, months, years, hours, minutes and seconds

DateTimeImmutable::add

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::add — Adds an amount of days, months, years, hours, minutes and seconds

说明

public DateTimeImmutable::add ( DateInterval $interval ) : DateTimeImmutable

Like DateTime::add() but works with DateTimeImmutable.


Returns new DateTimeImmutable object

  • ? DateTimeImmutable::add
  • DateTimeImmutable::createFromFormat ?
  • PHP Manual
  • DateTimeImmutable
  • Returns new DateTimeImmutable object

DateTimeImmutable::__construct

date_create_immutable

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::__construct -- date_create_immutable — Returns new DateTimeImmutable object

说明

面向对象风格

public DateTimeImmutable::__construct ( string $datetime = "now" , DateTimeZone|null $timezone = null )

过程化风格

date_create_immutable ( string $datetime = "now" , DateTimeZone|null $timezone = null ) : DateTimeImmutable|false

Like DateTime::__construct() but works with DateTimeImmutable.


Parses a time string according to a specified format

  • ? DateTimeImmutable::__construct
  • DateTimeImmutable::createFromInterface ?
  • PHP Manual
  • DateTimeImmutable
  • Parses a time string according to a specified format

DateTimeImmutable::createFromFormat

date_create_immutable_from_format

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::createFromFormat -- date_create_immutable_from_format — Parses a time string according to a specified format

说明

面向对象风格

public static DateTimeImmutable::createFromFormat ( string $format , string $datetime , DateTimeZone|null $timezone = null ) : DateTimeImmutable|false

过程化风格

date_create_immutable_from_format ( string $format , string $datetime , DateTimeZone|null $timezone = null ) : DateTimeImmutable|false

Like DateTime::createFromFormat() but works with DateTimeImmutable.


Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object

  • ? DateTimeImmutable::createFromFormat
  • DateTimeImmutable::createFromMutable ?
  • PHP Manual
  • DateTimeImmutable
  • Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object

DateTimeImmutable::createFromInterface

(PHP 8)

DateTimeImmutable::createFromInterface — Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object

说明

public static DateTimeImmutable::createFromInterface ( DateTimeInterface $object ) : DateTimeImmutable

参数

object

The DateTimeInterface object that needs to be converted to an immutable version. This object is not modified, but instead a new DateTimeImmutable object is created containing the same date, time, and timezone information.

返回值

Returns a new DateTimeImmutable instance.

范例

Example #1 Creating an immutable date time object

<?php
$date = new DateTime("2014-06-20 11:45 Europe/London");

$immutable = DateTimeImmutable::createFromInterface($date);

$date = new DateTimeImmutable("2014-06-20 11:45 Europe/London");
$also_immutable = DateTimeImmutable::createFromInterface($date);
?>


Returns new DateTimeImmutable object encapsulating the given DateTime object

  • ? DateTimeImmutable::createFromInterface
  • DateTimeImmutable::getLastErrors ?
  • PHP Manual
  • DateTimeImmutable
  • Returns new DateTimeImmutable object encapsulating the given DateTime object

DateTimeImmutable::createFromMutable

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

DateTimeImmutable::createFromMutable — Returns new DateTimeImmutable object encapsulating the given DateTime object

说明

public static DateTimeImmutable::createFromMutable ( DateTime $object ) : DateTimeImmutable

参数

object

The mutable DateTime object that you want to convert to an immutable version. This object is not modified, but instead a new DateTimeImmutable object is created containing the same date time and timezone information.

范例

Example #1 Creating an immutable date time object

<?php
$date = new DateTime("2014-06-20 11:45 Europe/London");

$immutable = DateTimeImmutable::createFromMutable( $date );
?>

返回值

Returns a new DateTimeImmutable instance.


Returns the warnings and errors

  • ? DateTimeImmutable::createFromMutable
  • DateTimeImmutable::modify ?
  • PHP Manual
  • DateTimeImmutable
  • Returns the warnings and errors

DateTimeImmutable::getLastErrors

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::getLastErrors — Returns the warnings and errors

说明

public static DateTimeImmutable::getLastErrors ( ) : array|false

Like DateTime::getLastErrors() but works with DateTimeImmutable.


Creates a new object with modified timestamp

  • ? DateTimeImmutable::getLastErrors
  • DateTimeImmutable::__set_state ?
  • PHP Manual
  • DateTimeImmutable
  • Creates a new object with modified timestamp

DateTimeImmutable::modify

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::modify — Creates a new object with modified timestamp

说明

public DateTimeImmutable::modify ( string $modifier ) : DateTimeImmutable|false

Creates a new DateTimeImmutable object with modified timestamp. The original object is not modified.

参数

object

仅过程化风格：由 date_create() 返回的 DateTime 类型的对象。此函数会修改这个对象。

modifier

日期/时间字符串。正确格式的说明详见 日期与时间格式。

返回值

Returns the newly created object 或者在失败时返回 false.


The __set_state handler

  • ? DateTimeImmutable::modify
  • DateTimeImmutable::setDate ?
  • PHP Manual
  • DateTimeImmutable
  • The __set_state handler

DateTimeImmutable::__set_state

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::__set_state — The __set_state handler

说明

public static DateTimeImmutable::__set_state ( array $array ) : DateTimeImmutable

Like DateTime::__set_state() but works with DateTimeImmutable.


Sets the date

  • ? DateTimeImmutable::__set_state
  • DateTimeImmutable::setISODate ?
  • PHP Manual
  • DateTimeImmutable
  • Sets the date

DateTimeImmutable::setDate

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setDate — Sets the date

说明

public DateTimeImmutable::setDate ( int $year , int $month , int $day ) : DateTimeImmutable

Like DateTime::setDate() but works with DateTimeImmutable.


Sets the ISO date

  • ? DateTimeImmutable::setDate
  • DateTimeImmutable::setTime ?
  • PHP Manual
  • DateTimeImmutable
  • Sets the ISO date

DateTimeImmutable::setISODate

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setISODate — Sets the ISO date

说明

public DateTimeImmutable::setISODate ( int $year , int $week , int $dayOfWeek = 1 ) : DateTimeImmutable

Like DateTime::setISODate() but works with DateTimeImmutable.


Sets the time

  • ? DateTimeImmutable::setISODate
  • DateTimeImmutable::setTimestamp ?
  • PHP Manual
  • DateTimeImmutable
  • Sets the time

DateTimeImmutable::setTime

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setTime — Sets the time

说明

public DateTimeImmutable::setTime ( int $hour , int $minute , int $second = 0 , int $microsecond = 0 ) : DateTimeImmutable

Like DateTime::setTime() but works with DateTimeImmutable.


Sets the date and time based on a Unix timestamp

  • ? DateTimeImmutable::setTime
  • DateTimeImmutable::setTimezone ?
  • PHP Manual
  • DateTimeImmutable
  • Sets the date and time based on a Unix timestamp

DateTimeImmutable::setTimestamp

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setTimestamp — Sets the date and time based on a Unix timestamp

说明

public DateTimeImmutable::setTimestamp ( int $timestamp ) : DateTimeImmutable

Like DateTime::setTimestamp() but works with DateTimeImmutable.


Sets the time zone

  • ? DateTimeImmutable::setTimestamp
  • DateTimeImmutable::sub ?
  • PHP Manual
  • DateTimeImmutable
  • Sets the time zone

DateTimeImmutable::setTimezone

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::setTimezone — Sets the time zone

说明

public DateTimeImmutable::setTimezone ( DateTimeZone $timezone ) : DateTimeImmutable

Like DateTime::setTimezone() but works with DateTimeImmutable.


Subtracts an amount of days, months, years, hours, minutes and seconds

  • ? DateTimeImmutable::setTimezone
  • DateTimeInterface ?
  • PHP Manual
  • DateTimeImmutable
  • Subtracts an amount of days, months, years, hours, minutes and seconds

DateTimeImmutable::sub

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

DateTimeImmutable::sub — Subtracts an amount of days, months, years, hours, minutes and seconds

说明

public DateTimeImmutable::sub ( DateInterval $interval ) : DateTimeImmutable

Like DateTime::sub() but works with DateTimeImmutable.


The DateTimeInterface interface

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

简介

DateTimeInterface 的意思是可以约束类型为 DateTime 或 DateTimeImmutable。此接口不能让用户自己的 class 去实现（implements）。

类摘要

DateTimeInterface {
/* 常量 */
const string ATOM = "Y-m-d\TH:i:sP" ;
const string COOKIE = "l, d-M-Y H:i:s T" ;
const string ISO8601 = "Y-m-d\TH:i:sO" ;
const string RFC822 = "D, d M y H:i:s O" ;
const string RFC850 = "l, d-M-y H:i:s T" ;
const string RFC1036 = "D, d M y H:i:s O" ;
const string RFC1123 = "D, d M Y H:i:s O" ;
const string RFC7231 = "D, d M Y H:i:s \G\M\T" ;
const string RFC2822 = "D, d M Y H:i:s O" ;
const string RFC3339 = "Y-m-d\TH:i:sP" ;
const string RFC3339_EXTENDED = "Y-m-d\TH:i:s.vP" ;
const string RSS = "D, d M Y H:i:s O" ;
const string W3C = "Y-m-d\TH:i:sP" ;
/* 方法 */
public diff ( DateTimeInterface $targetObject , bool $absolute = false ) : DateInterval
public format ( string $format ) : string
public getOffset ( ) : int
public getTimestamp ( ) : int
public getTimezone ( ) : DateTimeZone|false
public __wakeup ( ) : void
}

预定义常量

DateTimeInterface::ATOM
DATE_ATOM
Atom 格式（示例：2005-08-15T15:52:01+00:00）
DateTimeInterface::COOKIE
DATE_COOKIE
HTTP Cookies 格式（示例：Monday, 15-Aug-2005 15:52:01 UTC）
DateTimeInterface::ISO8601
DATE_ISO8601
ISO-8601 格式（示例：2005-08-15T15:52:01+0000）

Note: 这种格式和 ISO-8601 的格式并不兼容，只是出于向后兼容的原因才保留的。 如果要使用和 ISO-8601 兼容的格式， 请使用 DateTime::ATOM 或 DATE_ATOM 两个常量。

DateTimeInterface::RFC822
DATE_RFC822
RFC 822 格式（示例：Mon, 15 Aug 05 15:52:01 +0000）
DateTimeInterface::RFC850
DATE_RFC850
RFC 850 格式（示例：Monday, 15-Aug-05 15:52:01 UTC）
DateTimeInterface::RFC1036
DATE_RFC1036
RFC 1036（示例：Mon, 15 Aug 05 15:52:01 +0000）
DateTimeInterface::RFC1123
DATE_RFC1123
RFC 1123 格式（示例：Mon, 15 Aug 2005 15:52:01 +0000）
DateTimeInterface::RFC7231
DATE_RFC7231
RFC 7231 格式 (自 PHP 7.0.19 和 7.1.5 可用) (示例：Sat, 30 Apr 2016 17:52:13 GMT)
DateTimeInterface::RFC2822
DATE_RFC2822
RFC 2822 格式（示例：Mon, 15 Aug 2005 15:52:01 +0000）
DateTimeInterface::RFC3339
DATE_RFC3339
同 DATE_ATOM（自 PHP 5.1.3 版本可用）
DateTimeInterface::RFC3339_EXTENDED
DATE_RFC3339_EXTENDED
RFC 3339 EXTENDED 格式（自 PHP 7.0.0 可用）（示例：2005-08-15T15:52:01.000+00:00）
DateTimeInterface::RSS
DATE_RSS
RSS（示例：Mon, 15 Aug 2005 15:52:01 +0000）
DateTimeInterface::W3C
DATE_W3C
RSS 格式（示例：2005-08-15T15:52:01+00:00）

更新日志

版本 | 说明
7.2.0 | DateTime 的类常量现在定义在了 DateTimeInterface 上。
5.5.8 | 尝试实现（implement）DateTimeInterface 时，会抛出严重错误。 之前此举不会产生错误，但这种做法是不对的。

Table of Contents

  • DateTime::diff — Returns the difference between two DateTime objects
  • DateTime::format — Returns date formatted according to given format
  • DateTime::getOffset — Returns the timezone offset
  • DateTime::getTimestamp — Gets the Unix timestamp
  • DateTime::getTimezone — Return time zone relative to given DateTime
  • DateTime::__wakeup — The __wakeup handler


Returns the difference between two DateTime objects

  • ? DateTimeInterface
  • DateTime::format ?
  • PHP Manual
  • DateTimeInterface
  • Returns the difference between two DateTime objects

DateTime::diff

DateTimeImmutable::diff

DateTimeInterface::diff

date_diff

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::diff -- DateTimeImmutable::diff -- DateTimeInterface::diff -- date_diff — Returns the difference between two DateTime objects

说明

面向对象风格

public DateTime::diff ( DateTimeInterface $targetObject , bool $absolute = false ) : DateInterval
public DateTimeImmutable::diff ( DateTimeInterface $targetObject , bool $absolute = false ) : DateInterval
public DateTimeInterface::diff ( DateTimeInterface $targetObject , bool $absolute = false ) : DateInterval

过程化风格

date_diff ( DateTimeInterface $baseObject , DateTimeInterface $targetObject , bool $absolute = false ) : DateInterval

Returns the difference between two DateTimeInterface objects.

参数

datetime

The date to compare to.

absolute

Should the interval be forced to be positive?

返回值

The DateInterval object represents the difference between the two dates 或者在失败时返回 false.

The return value more specifically represents the interval to apply to the original object ($this or $originObject) to arrive at the $targetObject. This process is not always reversible.

范例

Example #1 DateTime::diff() example

面向对象风格

<?php
$origin = new DateTime('2009-10-11');
$target = new DateTime('2009-10-13');
$interval = $origin->diff($target);
echo $interval->format('%R%a days');
?>

过程化风格

<?php
$origin = date_create('2009-10-11');
$target = date_create('2009-10-13');
$interval = date_diff($origin, $target);
echo $interval->format('%R%a days');
?>

以上例程会输出：

+2 days

Example #2 DateTime object comparison

Note:

As of PHP 5.2.2, DateTime objects can be compared using comparison operators.

<?php
$date1 = new DateTime("now");
$date2 = new DateTime("tomorrow");

var_dump($date1 == $date2);
var_dump($date1 < $date2);
var_dump($date1 > $date2);
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)

参见

  • DateInterval::format() - Formats the interval
  • DateTime::add() - 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。
  • DateTime::sub() - 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。


Returns date formatted according to given format

  • ? DateTime::diff
  • DateTime::getOffset ?
  • PHP Manual
  • DateTimeInterface
  • Returns date formatted according to given format

DateTime::format

DateTimeImmutable::format

DateTimeInterface::format

date_format

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

DateTime::format -- DateTimeImmutable::format -- DateTimeInterface::format -- date_format — Returns date formatted according to given format

说明

面向对象风格

public DateTime::format ( string $format ) : string
public DateTimeImmutable::format ( string $format ) : string
public DateTimeInterface::format ( string $format ) : string

过程化风格

date_format ( DateTimeInterface $object , string $format ) : string

Returns date formatted according to given format.

参数

object

仅为过程化风格：由 date_create() 返回的 DateTime 类型的对象。

format

The format of the outputted date string. See the formatting options below. There are also several predefined date constants that may be used instead, so for example DATE_RSS contains the format string 'D, d M Y H:i:s'.

The following characters are recognized in the format parameter string
format character | Description | Example returned values
Day --- ---
d | Day of the month, 2 digits with leading zeros | 01 to 31
D | A textual representation of a day, three letters | Mon through Sun
j | Day of the month without leading zeros | 1 to 31
l (lowercase 'L') | A full textual representation of the day of the week | Sunday through Saturday
N | ISO-8601 numeric representation of the day of the week | 1 (for Monday) through 7 (for Sunday)
S | English ordinal suffix for the day of the month, 2 characters | st, nd, rd or th. Works well with j
w | Numeric representation of the day of the week | 0 (for Sunday) through 6 (for Saturday)
z | The day of the year (starting from 0) | 0 through 365
Week --- ---
W | ISO-8601 week number of year, weeks starting on Monday | Example: 42 (the 42nd week in the year)
Month --- ---
F | A full textual representation of a month, such as January or March | January through December
m | Numeric representation of a month, with leading zeros | 01 through 12
M | A short textual representation of a month, three letters | Jan through Dec
n | Numeric representation of a month, without leading zeros | 1 through 12
t | Number of days in the given month | 28 through 31
Year --- ---
L | Whether it's a leap year | 1 if it is a leap year, 0 otherwise.
o | ISO-8601 week-numbering year. This has the same value as Y, except that if the ISO week number (W) belongs to the previous or next year, that year is used instead. | Examples: 1999 or 2003
Y | A full numeric representation of a year, 4 digits | Examples: 1999 or 2003
y | A two digit representation of a year | Examples: 99 or 03
Time --- ---
a | Lowercase Ante meridiem and Post meridiem | am or pm
A | Uppercase Ante meridiem and Post meridiem | AM or PM
B | Swatch Internet time | 000 through 999
g | 12-hour format of an hour without leading zeros | 1 through 12
G | 24-hour format of an hour without leading zeros | 0 through 23
h | 12-hour format of an hour with leading zeros | 01 through 12
H | 24-hour format of an hour with leading zeros | 00 through 23
i | Minutes with leading zeros | 00 to 59
s | Seconds with leading zeros | 00 through 59
u | Microseconds. Note that date() will always generate 000000 since it takes an int parameter, whereas DateTime::format() does support microseconds if DateTime was created with microseconds. | Example: 654321
v | Milliseconds (added in PHP 7.0.0). Same note applies as for u. | Example: 654
Timezone --- ---
e | Timezone identifier | Examples: UTC, GMT, Atlantic/Azores
I (capital i) | Whether or not the date is in daylight saving time | 1 if Daylight Saving Time, 0 otherwise.
O | Difference to Greenwich time (GMT) without colon between hours and minutes | Example: +0200
P | Difference to Greenwich time (GMT) with colon between hours and minutes | Example: +02:00
p | The same as P, but returns Z instead of +00:00 | Example: +02:00
T | Timezone abbreviation | Examples: EST, MDT ...
Z | Timezone offset in seconds. The offset for timezones west of UTC is always negative, and for those east of UTC is always positive. | -43200 through 50400
Full Date/Time --- ---
c | ISO 8601 date | 2004-02-12T15:19:21+00:00
r | » RFC 2822 formatted date | Example: Thu, 21 Dec 2000 16:01:07 +0200
U | Seconds since the Unix Epoch (January 1 1970 00:00:00 GMT) | See also time()

Unrecognized characters in the format string will be printed as-is. The Z format will always return 0 when using gmdate().

Note:

Since this function only accepts int timestamps the u format character is only useful when using the date_format() function with user based timestamps created with date_create().

返回值

Returns the formatted date string on success.

更新日志

版本 | 说明
8.0.0 | Prior to this version, false was returned on failure.
8.0.0 | The format character p has been added.

范例

Example #1 DateTime::format() example

面向对象风格

<?php
$date = new DateTime('2000-01-01');
echo $date->format('Y-m-d H:i:s');
?>

过程化风格

<?php
$date = date_create('2000-01-01');
echo date_format($date, 'Y-m-d H:i:s');
?>

以上例程会输出：

2000-01-01 00:00:00

注释

This method does not use locales. All output is in English.

参见

  • date() - 格式化一个本地时间／日期


Returns the timezone offset

  • ? DateTime::format
  • DateTime::getTimestamp ?
  • PHP Manual
  • DateTimeInterface
  • Returns the timezone offset

DateTime::getOffset

DateTimeImmutable::getOffset

DateTimeInterface::getOffset

date_offset_get

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

DateTime::getOffset -- DateTimeImmutable::getOffset -- DateTimeInterface::getOffset -- date_offset_get — Returns the timezone offset

说明

面向对象风格

public DateTime::getOffset ( ) : int
public DateTimeImmutable::getOffset ( ) : int
public DateTimeInterface::getOffset ( ) : int

过程化风格

date_offset_get ( DateTimeInterface $object ) : int

Returns the timezone offset.

参数

object

仅为过程化风格：由 date_create() 返回的 DateTime 类型的对象。

返回值

Returns the timezone offset in seconds from UTC on success.

更新日志

版本 | 说明
8.0.0 | Prior to this version, false was returned on failure.

范例

Example #1 DateTime::getOffset() example

面向对象风格

<?php
$winter = new DateTime('2010-12-21', new DateTimeZone('America/New_York'));
$summer = new DateTime('2008-06-21', new DateTimeZone('America/New_York'));

echo $winter->getOffset() . "\n";
echo $summer->getOffset() . "\n";
?>

过程化风格

<?php
$winter = date_create('2010-12-21', timezone_open('America/New_York'));
$summer = date_create('2008-06-21', timezone_open('America/New_York'));

echo date_offset_get($winter) . "\n";
echo date_offset_get($summer) . "\n";
?>

以上例程会输出：

-18000
-14400

Note: -18000 = -5 hours, -14400 = -4 hours.


Gets the Unix timestamp

  • ? DateTime::getOffset
  • DateTime::getTimezone ?
  • PHP Manual
  • DateTimeInterface
  • Gets the Unix timestamp

DateTime::getTimestamp

DateTimeImmutable::getTimestamp

DateTimeInterface::getTimestamp

date_timestamp_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::getTimestamp -- DateTimeImmutable::getTimestamp -- DateTimeInterface::getTimestamp -- date_timestamp_get — Gets the Unix timestamp

说明

面向对象风格

public DateTime::getTimestamp ( ) : int
public DateTimeImmutable::getTimestamp ( ) : int
public DateTimeInterface::getTimestamp ( ) : int

过程化风格

date_timestamp_get ( DateTimeInterface $object ) : int

Gets the Unix timestamp.

参数

此函数没有参数。

返回值

Returns the Unix timestamp representing the date.

更新日志

版本 | 说明
8.0.0 | These functions no longer return false on failure.

范例

Example #1 DateTime::getTimestamp() example

面向对象风格

<?php
$date = new DateTime();
echo $date->getTimestamp();
?>

过程化风格

<?php
$date = date_create();
echo date_timestamp_get($date);
?>

以上例程的输出类似于：

1272509157

注释

Using U as the parameter to DateTime::format() is an alternative when using PHP 5.2.

参见

  • DateTime::setTimestamp() - 以 Unix 时间戳的方式设置 DateTime 对象
  • DateTime::format() - Returns date formatted according to given format


Return time zone relative to given DateTime

  • ? DateTime::getTimestamp
  • DateTime::__wakeup ?
  • PHP Manual
  • DateTimeInterface
  • Return time zone relative to given DateTime

DateTime::getTimezone

DateTimeImmutable::getTimezone

DateTimeInterface::getTimezone

date_timezone_get

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

DateTime::getTimezone -- DateTimeImmutable::getTimezone -- DateTimeInterface::getTimezone -- date_timezone_get — Return time zone relative to given DateTime

说明

面向对象风格

public DateTime::getTimezone ( ) : DateTimeZone|false
public DateTimeImmutable::getTimezone ( ) : DateTimeZone|false
public DateTimeInterface::getTimezone ( ) : DateTimeZone|false

过程化风格

date_timezone_get ( DateTimeInterface $object ) : DateTimeZone|false

Return time zone relative to given DateTime.

参数

object

仅为过程化风格：由 date_create() 返回的 DateTime 类型的对象。

返回值

Returns a DateTimeZone object on success 或者在失败时返回 false.

范例

Example #1 DateTime::getTimezone() example

面向对象风格

<?php
$date = new DateTime(null, new DateTimeZone('Europe/London'));
$tz = $date->getTimezone();
echo $tz->getName();
?>

过程化风格

<?php
$date = date_create(null, timezone_open('Europe/London'));
$tz = date_timezone_get($date);
echo timezone_name_get($tz);
?>

以上例程会输出：

Europe/London

参见

  • DateTime::setTimezone() - 设置 DateTime 对象的时区


The __wakeup handler

  • ? DateTime::getTimezone
  • DateTimeZone ?
  • PHP Manual
  • DateTimeInterface
  • The __wakeup handler

DateTime::__wakeup

DateTimeImmutable::__wakeup

DateTimeInterface::__wakeup

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTime::__wakeup -- DateTimeImmutable::__wakeup -- DateTimeInterface::__wakeup — The __wakeup handler

说明

public DateTime::__wakeup ( ) : void
public DateTimeImmutable::__wakeup ( ) : void
public DateTimeInterface::__wakeup ( ) : void

The __wakeup() handler.

参数

此函数没有参数。

返回值

Initializes a DateTime object.


The DateTimeZone class

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

简介

Representation of time zone.

类摘要

DateTimeZone {
/* 常量 */
const int AFRICA = 1 ;
const int AMERICA = 2 ;
const int ANTARCTICA = 4 ;
const int ARCTIC = 8 ;
const int ASIA = 16 ;
const int ATLANTIC = 32 ;
const int AUSTRALIA = 64 ;
const int EUROPE = 128 ;
const int INDIAN = 256 ;
const int PACIFIC = 512 ;
const int UTC = 1024 ;
const int ALL = 2047 ;
const int ALL_WITH_BC = 4095 ;
const int PER_COUNTRY = 4096 ;
/* 方法 */
public __construct ( string $timezone )
public getLocation ( ) : array
public getName ( ) : string
public getOffset ( DateTime $datetime ) : int
public getTransitions ( int $timestampBegin = PHP_INT_MIN , int $timestampEnd = PHP_INT_MAX ) : array|false
public static listAbbreviations ( ) : array
public static listIdentifiers ( int $what = DateTimeZone::ALL , string $country = null ) : array
}

预定义常量

DateTimeZone::AFRICA

Africa time zones.

DateTimeZone::AMERICA

America time zones.

DateTimeZone::ANTARCTICA

Antarctica time zones.

DateTimeZone::ARCTIC

Arctic time zones.

DateTimeZone::ASIA

Asia time zones.

DateTimeZone::ATLANTIC

Atlantic time zones.

DateTimeZone::AUSTRALIA

Australia time zones.

DateTimeZone::EUROPE

Europe time zones.

DateTimeZone::INDIAN

Indian time zones.

DateTimeZone::PACIFIC

Pacific time zones.

DateTimeZone::UTC

UTC time zones.

DateTimeZone::ALL

All time zones.

DateTimeZone::ALL_WITH_BC

All time zones including backwards compatible.

DateTimeZone::PER_COUNTRY

Time zones per country.

Table of Contents

  • DateTimeZone::__construct — 创建新的DateTimeZone对象
  • DateTimeZone::getLocation — 返回与时区相关的定位信息。
  • DateTimeZone::getName — 返回时区名称。
  • DateTimeZone::getOffset — 返回相对于 GMT 的时差。
  • DateTimeZone::getTransitions — Returns all transitions for the timezone
  • DateTimeZone::listAbbreviations — 返回一个包含 dst (夏令时)，时差和时区信息的关联数组。
  • DateTimeZone::listIdentifiers — 返回一个包含了所有时区标示符的索引数组。


创建新的DateTimeZone对象

  • ? DateTimeZone
  • DateTimeZone::getLocation ?
  • PHP Manual
  • DateTimeZone
  • 创建新的DateTimeZone对象

DateTimeZone::__construct

timezone_open

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::__construct -- timezone_open — 创建新的DateTimeZone对象

说明

面向对象风格

public DateTimeZone::__construct ( string $timezone )

过程化风格

timezone_open ( string $timezone ) : DateTimeZone

创建新的DateTimeZone对象.

参数

timezone

所支持的 timezone names之一.

返回值

成功时返回 DateTimeZone对象. 过程化风格在失败时返回 false。

错误／异常

如果提供的时区无效，此方法将抛出 Exception异常.

范例

Example #1 Catching errors when instantiating DateTimeZone

<?php
// Error handling by catching exceptions
$timezones = array('Europe/London', 'Mars/Phobos', 'Jupiter/Europa');

foreach ($timezones as $tz) {
    try {
        $mars = new DateTimeZone($tz);
    } catch(Exception $e) {
        echo $e->getMessage() . '<br />';
    }
}
?>

以上例程会输出：

DateTimeZone::__construct() [datetimezone.--construct]: Unknown or bad timezone (Mars/Phobos)
DateTimeZone::__construct() [datetimezone.--construct]: Unknown or bad timezone (Jupiter/Europa)


返回与时区相关的定位信息。

  • ? DateTimeZone::__construct
  • DateTimeZone::getName ?
  • PHP Manual
  • DateTimeZone
  • 返回与时区相关的定位信息。

DateTimeZone::getLocation

timezone_location_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateTimeZone::getLocation -- timezone_location_get — 返回与时区相关的定位信息。

说明

面向对象风格

public DateTimeZone::getLocation ( ) : array

过程化风格

timezone_location_get ( DateTimeZone $object ) : array

返回与时区相关的定位信息，包括国家代码，纬度/经度和解释。

参数

object

仅过程化风格：由 timezone_open() 返回的 DateTimeZone 对象。

返回值

数组，包含与时区相关的定位信息。

范例

Example #1 DateTimeZone::getLocation() 函数的范例：

<?php
$tz = new DateTimeZone("Europe/Prague");
print_r($tz->getLocation());
print_r(timezone_location_get($tz));
?>

以上例程会输出：

Array
(
    [country_code] => CZ
    [latitude] => 50.08333
    [longitude] => 14.43333
    [comments] =>
)
Array
(
    [country_code] => CZ
    [latitude] => 50.08333
    [longitude] => 14.43333
    [comments] =>
)


返回时区名称。

  • ? DateTimeZone::getLocation
  • DateTimeZone::getOffset ?
  • PHP Manual
  • DateTimeZone
  • 返回时区名称。

DateTimeZone::getName

timezone_name_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::getName -- timezone_name_get — 返回时区名称。

说明

面向对象风格

public DateTimeZone::getName ( ) : string

过程化风格

timezone_name_get ( DateTimeZone $object ) : string

返回时区名称。

参数

object

DateTimeZone对象。

返回值

时区名称列表之一。


返回相对于 GMT 的时差。

  • ? DateTimeZone::getName
  • DateTimeZone::getTransitions ?
  • PHP Manual
  • DateTimeZone
  • 返回相对于 GMT 的时差。

DateTimeZone::getOffset

timezone_offset_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::getOffset -- timezone_offset_get — 返回相对于 GMT 的时差。

说明

面向对象风格

public DateTimeZone::getOffset ( DateTime $datetime ) : int

过程化风格

timezone_offset_get ( DateTimeZone $object , DateTime $datetime ) : int

该函数返回 datetime日期 相对于 GMT 的时差。 GMT 时差是通过 DateTimeZone 对象的时区信息计算出来的。

参数

object

仅过程化风格：由 timezone_open() 返回的 DateTimeZone 对象。

datetime

用来计算时差的日期对象。

返回值

成功时返回精确到秒的时差， 或者在失败时返回 false。

范例

Example #1 DateTimeZone::getOffset() 例子

<?php
// Create two timezone objects, one for Taipei (Taiwan) and one for
// Tokyo (Japan)
$dateTimeZoneTaipei = new DateTimeZone("Asia/Taipei");
$dateTimeZoneJapan = new DateTimeZone("Asia/Tokyo");

// Create two DateTime objects that will contain the same Unix timestamp, but
// have different timezones attached to them.
$dateTimeTaipei = new DateTime("now", $dateTimeZoneTaipei);
$dateTimeJapan = new DateTime("now", $dateTimeZoneJapan);

// Calculate the GMT offset for the date/time contained in the $dateTimeTaipei
// object, but using the timezone rules as defined for Tokyo
// ($dateTimeZoneJapan).
$timeOffset = $dateTimeZoneJapan->getOffset($dateTimeTaipei);

// Should show int(32400) (for dates after Sat Sep 8 01:00:00 1951 JST).
var_dump($timeOffset);
?>


Returns all transitions for the timezone

  • ? DateTimeZone::getOffset
  • DateTimeZone::listAbbreviations ?
  • PHP Manual
  • DateTimeZone
  • Returns all transitions for the timezone

DateTimeZone::getTransitions

timezone_transitions_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::getTransitions -- timezone_transitions_get — Returns all transitions for the timezone

说明

面向对象风格

public DateTimeZone::getTransitions ( int $timestampBegin = PHP_INT_MIN , int $timestampEnd = PHP_INT_MAX ) : array|false

过程化风格

timezone_transitions_get ( DateTimeZone $object , int $timestampBegin = PHP_INT_MIN , int $timestampEnd = PHP_INT_MAX ) : array|false

参数

object

仅过程化风格：由 timezone_open() 返回的 DateTimeZone 对象。

timestampBegin

Begin timestamp.

timestampEnd

End timestamp.

返回值

Returns a numerically indexed array of transition arrays on success, 或者在失败时返回 false.

Transition Array Structure
Key | Type | Description
ts | int | Unix timestamp
time | string | DateTimeInterface::ISO8601 time string
offset | int | Offset to UTC in seconds
isdst | bool | Whether daylight saving time is active
abbr | string | Timezone abbreviation

范例

Example #1 A timezone_transitions_get() example

<?php
$timezone = new DateTimeZone("Europe/London");
$transitions = $timezone->getTransitions();
print_r(array_slice($transitions, 0, 3));
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [ts] => -9223372036854775808
            [time] => -292277022657-01-27T08:29:52+0000
            [offset] => 3600
            [isdst] => 1
            [abbr] => BST
        )

    [1] => Array
        (
            [ts] => -1691964000
            [time] => 1916-05-21T02:00:00+0000
            [offset] => 3600
            [isdst] => 1
            [abbr] => BST
        )

    [2] => Array
        (
            [ts] => -1680472800
            [time] => 1916-10-01T02:00:00+0000
            [offset] => 0
            [isdst] =>
            [abbr] => GMT
        )

)


返回一个包含 dst (夏令时)，时差和时区信息的关联数组。

  • ? DateTimeZone::getTransitions
  • DateTimeZone::listIdentifiers ?
  • PHP Manual
  • DateTimeZone
  • 返回一个包含 dst (夏令时)，时差和时区信息的关联数组。

DateTimeZone::listAbbreviations

timezone_abbreviations_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::listAbbreviations -- timezone_abbreviations_list — 返回一个包含 dst (夏令时)，时差和时区信息的关联数组。

说明

面向对象风格

public static DateTimeZone::listAbbreviations ( ) : array

过程化风格

timezone_abbreviations_list ( ) : array

返回值

成功，返回数组， 或者在失败时返回 false。

范例

Example #1 timezone_abbreviations_list() 函数的范例：

<?php
$timezone_abbreviations = DateTimeZone::listAbbreviations();
print_r($timezone_abbreviations["acst"]);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Porto_Acre
        )

    [1] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Eirunepe
        )

    [2] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Rio_Branco
        )

    [3] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => Brazil/Acre
        )

)

参见

  • timezone_identifiers_list() - 别名 DateTimeZone::listIdentifiers


返回一个包含了所有时区标示符的索引数组。

  • ? DateTimeZone::listAbbreviations
  • DateInterval ?
  • PHP Manual
  • DateTimeZone
  • 返回一个包含了所有时区标示符的索引数组。

DateTimeZone::listIdentifiers

timezone_identifiers_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

DateTimeZone::listIdentifiers -- timezone_identifiers_list — 返回一个包含了所有时区标示符的索引数组。

说明

面向对象风格

public static DateTimeZone::listIdentifiers ( int $what = DateTimeZone::ALL , string $country = null ) : array

过程化风格

timezone_identifiers_list ( int $what = DateTimeZone::ALL , string $country = null ) : array

参数

what

DateTimeZone 类中的常量之一。

country

由两个字母组成，ISO 3166-1 兼容的国家代码。

Note: 只有当 what 被设置为DateTimeZone::PER_COUNTRY时,该选项才会被使用。

返回值

成功，返回数组，失败则返回false.

更新日志

版本 | 说明
5.3.0 | 添加可选的 what 和 country 参数。

范例

Example #1 timezone_identifiers_list() 函数的范例：

<?php
$timezone_identifiers = DateTimeZone::listIdentifiers();
for ($i=0; $i < 5; $i++) {
    echo "$timezone_identifiers[$i]\n";
}
?>

以上例程的输出类似于：

Africa/Abidjan
Africa/Accra
Africa/Addis_Ababa
Africa/Algiers
Africa/Asmara

参见

  • timezone_abbreviations_list() - 别名 DateTimeZone::listAbbreviations


DateInterval 类

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

简介

表示一个时间周期的类。

一个时间周期表示固定量的时间（多少年，月，天，小时等）， 也可以表示一个字符串格式的相对时间， 当表示相对时间的时候，字符串格式是 DateTime 类的构造函数所支持的格式。

类摘要

DateInterval {
/* 属性 */
public integer $y ;
public integer $m ;
public integer $d ;
public integer $h ;
public integer $i ;
public integer $s ;
public float $f ;
public integer $invert ;
public mixed $days ;
/* 方法 */
public __construct ( string $duration )
public static createFromDateString ( string $datetime ) : DateInterval|false
public format ( string $format ) : string
}

属性

y

多少年。

m

多少月。

d

多少天。

h

多少小时。

i

多少分钟。

s

多少秒。

f

多少微秒。

invert

1 表示一个负的时间周期， 0 表示一个正的时间周期。 请参见： DateInterval::format().

days

如果 DateInterval 对象是由 DateTime::diff() 函数创建的， 那么它表示开始日期和结束日期之间包含了多少天。 否则，days 属性为 false。

在 PHP 5.4.20/5.5.4 之前版本中，此属性不会为 false， 而是 -99999。

更新日志

版本 | 说明
7.1.0 | 增加 f 属性。

Table of Contents

  • DateInterval::__construct — Creates a new DateInterval object
  • DateInterval::createFromDateString — Sets up a DateInterval from the relative parts of the string
  • DateInterval::format — Formats the interval


Creates a new DateInterval object

  • ? DateInterval
  • DateInterval::createFromDateString ?
  • PHP Manual
  • DateInterval
  • Creates a new DateInterval object

DateInterval::__construct

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateInterval::__construct — Creates a new DateInterval object

说明

public DateInterval::__construct ( string $duration )

Creates a new DateInterval object.

参数

duration

An interval specification.

The format starts with the letter P, for period. Each duration period is represented by an integer value followed by a period designator. If the duration contains time elements, that portion of the specification is preceded by the letter T.

duration Period Designators
Period Designator | Description
Y | years
M | months
D | days
W | weeks. These get converted into days, so can not be combined with D.
H | hours
M | minutes
S | seconds

Here are some simple examples. Two days is P2D. Two seconds is PT2S. Six years and five minutes is P6YT5M.

Note:

The unit types must be entered from the largest scale unit on the left to the smallest scale unit on the right. So years before months, months before days, days before minutes, etc. Thus one year and four days must be represented as P1Y4D, not P4D1Y.

The specification can also be represented as a date time. A sample of one year and four days would be P0001-00-04T00:00:00. But the values in this format can not exceed a given period's roll-over-point (e.g. 25 hours is invalid).

These formats are based on the » ISO 8601 duration specification.

错误／异常

Throws an Exception when the duration cannot be parsed as an interval.

范例

Example #1 DateInterval example

<?php

$interval = new DateInterval('P2Y4DT6H8M');
var_dump($interval);

?>

以上例程会输出：

object(DateInterval)#1 (8) {
  ["y"]=>
  int(2)
  ["m"]=>
  int(0)
  ["d"]=>
  int(4)
  ["h"]=>
  int(6)
  ["i"]=>
  int(8)
  ["s"]=>
  int(0)
  ["invert"]=>
  int(0)
  ["days"]=>
  bool(false)
}

参见

  • DateInterval::format() - Formats the interval
  • DateTime::add() - 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。
  • DateTime::sub() - 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。
  • DateTime::diff() - Returns the difference between two DateTime objects


Sets up a DateInterval from the relative parts of the string

  • ? DateInterval::__construct
  • DateInterval::format ?
  • PHP Manual
  • DateInterval
  • Sets up a DateInterval from the relative parts of the string

DateInterval::createFromDateString

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateInterval::createFromDateString — Sets up a DateInterval from the relative parts of the string

说明

public static DateInterval::createFromDateString ( string $datetime ) : DateInterval|false

Uses the normal date parsers and sets up a DateInterval from the relative parts of the parsed string.

参数

datetime

A date with relative parts. Specifically, the relative formats supported by the parser used for strtotime() and DateTime will be used to construct the DateInterval.

范例

Example #1 Parsing valid date intervals

<?php
// Each set of intervals is equal.
$i = new DateInterval('P1D');
$i = DateInterval::createFromDateString('1 day');

$i = new DateInterval('P2W');
$i = DateInterval::createFromDateString('2 weeks');

$i = new DateInterval('P3M');
$i = DateInterval::createFromDateString('3 months');

$i = new DateInterval('P4Y');
$i = DateInterval::createFromDateString('4 years');

$i = new DateInterval('P1Y1D');
$i = DateInterval::createFromDateString('1 year + 1 day');

$i = new DateInterval('P1DT12H');
$i = DateInterval::createFromDateString('1 day + 12 hours');

$i = new DateInterval('PT3600S');
$i = DateInterval::createFromDateString('3600 seconds');
?>

返回值

Returns a new DateInterval instance on success, 或者在失败时返回 false.


Formats the interval

  • ? DateInterval::createFromDateString
  • DatePeriod ?
  • PHP Manual
  • DateInterval
  • Formats the interval

DateInterval::format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DateInterval::format — Formats the interval

说明

public DateInterval::format ( string $format ) : string

Formats the interval.

参数

format

The following characters are recognized in the format parameter string. Each format character must be prefixed by a percent sign (%).
format character | Description | Example values
% Literal % %
Y | Years, numeric, at least 2 digits with leading 0 | 01, 03
y | Years, numeric | 1, 3
M | Months, numeric, at least 2 digits with leading 0 | 01, 03, 12
m | Months, numeric | 1, 3, 12
D | Days, numeric, at least 2 digits with leading 0 | 01, 03, 31
d | Days, numeric | 1, 3, 31
a | Total number of days as a result of a DateTime::diff() or (unknown) otherwise | 4, 18, 8123
H | Hours, numeric, at least 2 digits with leading 0 | 01, 03, 23
h | Hours, numeric | 1, 3, 23
I | Minutes, numeric, at least 2 digits with leading 0 | 01, 03, 59
i | Minutes, numeric | 1, 3, 59
S | Seconds, numeric, at least 2 digits with leading 0 | 01, 03, 57
s | Seconds, numeric | 1, 3, 57
F | Microseconds, numeric, at least 6 digits with leading 0 | 007701, 052738, 428291
f | Microseconds, numeric | 7701, 52738, 428291
R Sign "-" when negative, "+" when positive -, +
r Sign "-" when negative, empty when positive -,

返回值

Returns the formatted interval.

注释

Note:

The DateInterval::format() method does not recalculate carry over points in time strings nor in date segments. This is expected because it is not possible to overflow values like "32 days" which could be interpreted as anything from "1 month and 4 days" to "1 month and 1 day".

更新日志

版本 | 说明
7.1.0 | The F and f format characters were added.

范例

Example #1 DateInterval example

<?php

$interval = new DateInterval('P2Y4DT6H8M');
echo $interval->format('%d days');

?>

以上例程会输出：

4 days

Example #2 DateInterval and carry over points

<?php

$interval = new DateInterval('P32D');
echo $interval->format('%d days');

?>

以上例程会输出：

32 days

Example #3 DateInterval and DateTime::diff() with the %a and %d modifiers

<?php

$january = new DateTime('2010-01-01');
$february = new DateTime('2010-02-01');
$interval = $february->diff($january);

// %a will output the total number of days.
echo $interval->format('%a total days')."\n";

// While %d will only output the number of days not already covered by the
// month.
echo $interval->format('%m month, %d days');

?>

以上例程会输出：

31 total days
1 month, 0 days

参见

  • DateTime::diff() - Returns the difference between two DateTime objects


DatePeriod 类

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

简介

DatePeriod 类表示一个时间周期。

一个时间周期可以用来在给定的一段时间之内， 以一定的时间间隔进行迭代。

类摘要

DatePeriod implements Traversable {
/* 常量 */
const integer EXCLUDE_START_DATE = 1 ;
/* 属性 */
public integer $recurrences ;
public boolean $include_start_date ;
public DateTimeInterface $start ;
public DateTimeInterface $current ;
public DateTimeInterface $end ;
public DateInterval $interval ;
/* 方法 */
public __construct ( DateTimeInterface $start , DateInterval $interval , int $recurrences , int $options = 0 )
public __construct ( DateTimeInterface $start , DateInterval $interval , DateTimeInterface $end , int $options = 0 )
public __construct ( string $isostr , int $options = 0 )
public getDateInterval ( ) : DateInterval
public getEndDate ( ) : DateTimeInterface|null
public getRecurrences ( ) : int|null
public getStartDate ( ) : DateTimeInterface
}

预定义常量

DatePeriod::EXCLUDE_START_DATE

在 DatePeriod::__construct() 构造函数中使用，表示不包含开始时间。

属性

recurrences

如果通过显式的传入 $recurrences 来创建的 DatePeriod 实例， 那么这个参数表示循环次数。 参见：DatePeriod::getRecurrences()。

include_start_date

在循环过程中，是否包含开始时间。

start

时间周期的开始时间。

current

表示在时间周期内迭代的时候，当前的时间。

end

时间周期的结束时间。

interval

ISO 8601 格式的间隔。

更新日志

版本 | 说明
5.3.27, 5.4.17 | 公开以下属性：recurrences， include_start_date，start， current，end 和 interval。

Table of Contents

  • DatePeriod::__construct — Creates a new DatePeriod object
  • DatePeriod::getDateInterval — Gets the interval
  • DatePeriod::getEndDate — Gets the end date
  • DatePeriod::getRecurrences — Gets the number of recurrences
  • DatePeriod::getStartDate — Gets the start date


Creates a new DatePeriod object

  • ? DatePeriod
  • DatePeriod::getDateInterval ?
  • PHP Manual
  • DatePeriod
  • Creates a new DatePeriod object

DatePeriod::__construct

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

DatePeriod::__construct — Creates a new DatePeriod object

说明

public DatePeriod::__construct ( DateTimeInterface $start , DateInterval $interval , int $recurrences , int $options = 0 )
public DatePeriod::__construct ( DateTimeInterface $start , DateInterval $interval , DateTimeInterface $end , int $options = 0 )
public DatePeriod::__construct ( string $isostr , int $options = 0 )

Creates a new DatePeriod object.

参数

start

The start date of the period.

interval

The interval between recurrences within the period.

recurrences

The number of recurrences. Must be greater than 0.

end

The end date of the period.

isostr

An ISO 8601 repeating interval specification. Zero occurences (R0/) are not supported.

options

Can be set to DatePeriod::EXCLUDE_START_DATE to exclude the start date from the set of recurring dates within the period.

更新日志

版本 | 说明
7.2.19, 7.3.6, 7.4.0 | recurrences must be greater than 0 now.

范例

Example #1 DatePeriod example

<?php
$start = new DateTime('2012-07-01');
$interval = new DateInterval('P7D');
$end = new DateTime('2012-07-31');
$recurrences = 4;
$iso = 'R4/2012-07-01T00:00:00Z/P7D';

// All of these periods are equivalent.
$period = new DatePeriod($start, $interval, $recurrences);
$period = new DatePeriod($start, $interval, $end);
$period = new DatePeriod($iso);

// By iterating over the DatePeriod object, all of the
// recurring dates within that period are printed.
foreach ($period as $date) {
    echo $date->format('Y-m-d')."\n";
}
?>

以上例程会输出：

2012-07-01
2012-07-08
2012-07-15
2012-07-22
2012-07-29

Example #2 DatePeriod example with DatePeriod::EXCLUDE_START_DATE

<?php
$start = new DateTime('2012-07-01');
$interval = new DateInterval('P7D');
$end = new DateTime('2012-07-31');

$period = new DatePeriod($start, $interval, $end,
                         DatePeriod::EXCLUDE_START_DATE);

// By iterating over the DatePeriod object, all of the
// recurring dates within that period are printed.
// Note that, in this case, 2012-07-01 is not printed.
foreach ($period as $date) {
    echo $date->format('Y-m-d')."\n";
}
?>

以上例程会输出：

2012-07-08
2012-07-15
2012-07-22
2012-07-29

注释

Unbound numbers of repetitions as specified by ISO 8601 section 4.5 "Recurring time interval" are not supported, i.e. neither passing "R/..." as isostr nor passing null as end would work.


Gets the interval

  • ? DatePeriod::__construct
  • DatePeriod::getEndDate ?
  • PHP Manual
  • DatePeriod
  • Gets the interval

DatePeriod::getDateInterval

(PHP 5 >= 5.6.5, PHP 7, PHP 8)

DatePeriod::getDateInterval — Gets the interval

说明

面向对象风格

public DatePeriod::getDateInterval ( ) : DateInterval

Gets a DateInterval object representing the interval used for the period.

参数

此函数没有参数。

返回值

Returns a DateInterval object

范例

Example #1 DatePeriod::getDateInterval() example

<?php
$period = new DatePeriod('R7/2016-05-16T00:00:00Z/P1D');
$interval = $period->getDateInterval();
echo $interval->format('%d day');
?>

以上例程会输出：

1 day

参见

  • DatePeriod::getStartDate() - Gets the start date
  • DatePeriod::getEndDate() - Gets the end date


Gets the end date

  • ? DatePeriod::getDateInterval
  • DatePeriod::getRecurrences ?
  • PHP Manual
  • DatePeriod
  • Gets the end date

DatePeriod::getEndDate

(PHP 5 >= 5.6.5, PHP 7, PHP 8)

DatePeriod::getEndDate — Gets the end date

说明

面向对象风格

public DatePeriod::getEndDate ( ) : DateTimeInterface|null

Gets the end date of the period.

参数

此函数没有参数。

返回值

Returns null if the DatePeriod does not have an end date. For example, when initialized with the recurrences parameter, or the isostr parameter without an end date.

Returns a DateTimeImmutable object when the DatePeriod is initialized with a DateTimeImmutable object as the end parameter.

Returns a DateTime object otherwise.

范例

Example #1 DatePeriod::getEndDate() example

<?php
$period = new DatePeriod(
    new DateTime('2016-05-16T00:00:00Z'),
    new DateInterval('P1D'),
    new DateTime('2016-05-20T00:00:00Z')
);
$start = $period->getEndDate();
echo $start->format(DateTime::ISO8601);
?>

以上例程会输出：

2016-05-20T00:00:00+0000

Example #2 DatePeriod::getEndDate() without an end date

<?php
$period = new DatePeriod(
    new DateTime('2016-05-16T00:00:00Z'),
    new DateInterval('P1D'),
    7
);
var_dump($period->getEndDate());
?>

以上例程会输出：

NULL

参见

  • DatePeriod::getStartDate() - Gets the start date
  • DatePeriod::getDateInterval() - Gets the interval


Gets the number of recurrences

  • ? DatePeriod::getEndDate
  • DatePeriod::getStartDate ?
  • PHP Manual
  • DatePeriod
  • Gets the number of recurrences

DatePeriod::getRecurrences

(PHP 7 >= 7.2.17/7.3.4, PHP 8)

DatePeriod::getRecurrences — Gets the number of recurrences

说明

面向对象风格

public DatePeriod::getRecurrences ( ) : int|null

Get the number of recurrences.

参数

此函数没有参数。

返回值

Returns the number of recurrences.

参见

  • DatePeriod::$recurrences


Gets the start date

  • ? DatePeriod::getRecurrences
  • Date/Time 函数 ?
  • PHP Manual
  • DatePeriod
  • Gets the start date

DatePeriod::getStartDate

(PHP 5 >= 5.6.5, PHP 7, PHP 8)

DatePeriod::getStartDate — Gets the start date

说明

面向对象风格

public DatePeriod::getStartDate ( ) : DateTimeInterface

Gets the start date of the period.

参数

此函数没有参数。

返回值

Returns a DateTimeImmutable object when the DatePeriod is initialized with a DateTimeImmutable object as the start parameter.

Returns a DateTime object otherwise.

范例

Example #1 DatePeriod::getStartDate() example

<?php
$period = new DatePeriod('R7/2016-05-16T00:00:00Z/P1D');
$start = $period->getStartDate();
echo $start->format(DateTime::ISO8601);
?>

以上例程会输出：

2016-05-16T00:00:00+0000

参见

  • DatePeriod::getEndDate() - Gets the end date
  • DatePeriod::getDateInterval() - Gets the interval


Date/Time 函数

Table of Contents

  • checkdate — 验证一个格里高里日期
  • date_add — 别名 DateTime::add
  • date_create_from_format — 别名 DateTime::createFromFormat
  • date_create_immutable_from_format — 别名 DateTimeImmutable::createFromFormat
  • date_create_immutable — 别名 DateTimeImmutable::__construct
  • date_create — 别名 DateTime::__construct
  • date_date_set — 别名 DateTime::setDate
  • date_default_timezone_get — 取得一个脚本中所有日期时间函数所使用的默认时区
  • date_default_timezone_set — 设定用于一个脚本中所有日期时间函数的默认时区
  • date_diff — 别名 DateTime::diff
  • date_format — 别名 DateTime::format
  • date_get_last_errors — 别名 DateTime::getLastErrors
  • date_interval_create_from_date_string — 别名 DateInterval::createFromDateString
  • date_interval_format — 别名 DateInterval::format
  • date_isodate_set — 别名 DateTime::setISODate
  • date_modify — 别名 DateTime::modify
  • date_offset_get — 别名 DateTime::getOffset
  • date_parse_from_format — Get info about given date formatted according to the specified format
  • date_parse — 返回指定日期/时间的详细信息的关联数组
  • date_sub — 别名 DateTime::sub
  • date_sun_info — Returns an array with information about sunset/sunrise and twilight begin/end
  • date_sunrise — 返回给定的日期与地点的日出时间
  • date_sunset — 返回给定的日期与地点的日落时间
  • date_time_set — 别名 DateTime::setTime
  • date_timestamp_get — 别名 DateTime::getTimestamp
  • date_timestamp_set — 别名 DateTime::setTimestamp
  • date_timezone_get — 别名 DateTime::getTimezone
  • date_timezone_set — 别名 DateTime::setTimezone
  • date — 格式化一个本地时间／日期
  • getdate — 取得日期／时间信息
  • gettimeofday — 取得当前时间
  • gmdate — 格式化一个 GMT/UTC 日期／时间
  • gmmktime — 取得 GMT 日期的 UNIX 时间戳
  • gmstrftime — 根据区域设置格式化 GMT/UTC 时间／日期
  • idate — 将本地时间日期格式化为整数
  • localtime — 取得本地时间
  • microtime — 返回当前 Unix 时间戳和微秒数
  • mktime — 取得一个日期的 Unix 时间戳
  • strftime — 根据区域设置格式化本地时间／日期
  • strptime — 解析由 strftime 生成的日期／时间
  • strtotime — 将任何字符串的日期时间描述解析为 Unix 时间戳
  • time — 返回当前的 Unix 时间戳
  • timezone_abbreviations_list — 别名 DateTimeZone::listAbbreviations
  • timezone_identifiers_list — 别名 DateTimeZone::listIdentifiers
  • timezone_location_get — 别名 DateTimeZone::getLocation
  • timezone_name_from_abbr — Returns the timezone name from abbreviation
  • timezone_name_get — 别名 DateTimeZone::getName
  • timezone_offset_get — 别名 DateTimeZone::getOffset
  • timezone_open — 别名 DateTimeZone::__construct
  • timezone_transitions_get — 别名 DateTimeZone::getTransitions
  • timezone_version_get — 获取 timezonedb 的版本


验证一个格里高里日期

  • ? Date/Time 函数
  • date_add ?
  • PHP Manual
  • Date/Time 函数
  • 验证一个格里高里日期

checkdate

(PHP 4, PHP 5, PHP 7, PHP 8)

checkdate — 验证一个格里高里日期

说明

checkdate ( int $month , int $day , int $year ) : bool

检查由参数构成的日期的合法性。如果每个参数都正确定义了则会被认为是有效的。

参数

month

month 的值是从 1 到 12。

day

Day 的值在给定的 month 所应该具有的天数范围之内，闰年已经考虑进去了。

year

year 的值是从 1 到 32767。

返回值

如果给出的日期有效则返回 true，否则返回 false。

范例

Example #1 checkdate() 例子

<?php
var_dump(checkdate(12, 31, 2000));
var_dump(checkdate(2, 29, 2001));
?>

以上例程会输出：

bool(true)
bool(false)

参见

  • mktime() - 取得一个日期的 Unix 时间戳
  • strtotime() - 将任何字符串的日期时间描述解析为 Unix 时间戳


别名 DateTime::add

  • ? checkdate
  • date_create_from_format ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::add

date_add

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_add — 别名 DateTime::add()

说明

此函数是该函数的别名： DateTime::add()


别名 DateTime::createFromFormat

  • ? date_add
  • date_create_immutable_from_format ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::createFromFormat

date_create_from_format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_create_from_format — 别名 DateTime::createFromFormat()

说明

此函数是该函数的别名： DateTime::createFromFormat()


别名 DateTimeImmutable::createFromFormat

  • ? date_create_from_format
  • date_create_immutable ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeImmutable::createFromFormat

date_create_immutable_from_format

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

date_create_immutable_from_format — 别名 DateTimeImmutable::createFromFormat()

说明

此函数是该函数的别名： DateTimeImmutable::createFromFormat()


别名 DateTimeImmutable::__construct

  • ? date_create_immutable_from_format
  • date_create ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeImmutable::__construct

date_create_immutable

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

date_create_immutable — 别名 DateTimeImmutable::__construct()

说明

此函数是该函数的别名： DateTimeImmutable::__construct()


别名 DateTime::__construct

  • ? date_create_immutable
  • date_date_set ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::__construct

date_create

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_create — 别名 DateTime::__construct()

说明

此函数是该函数的别名： DateTime::__construct()


别名 DateTime::setDate

  • ? date_create
  • date_default_timezone_get ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::setDate

date_date_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_date_set — 别名 DateTime::setDate()

说明

此函数是该函数的别名： DateTime::setDate()


取得一个脚本中所有日期时间函数所使用的默认时区

  • ? date_date_set
  • date_default_timezone_set ?
  • PHP Manual
  • Date/Time 函数
  • 取得一个脚本中所有日期时间函数所使用的默认时区

date_default_timezone_get

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

date_default_timezone_get — 取得一个脚本中所有日期时间函数所使用的默认时区

说明

date_default_timezone_get ( ) : string

本函数返回默认时区，使用如下"假定"的顺序：

  • 用 date_default_timezone_set() 函数设定的时区（如果设定了的话）

  • 仅仅在 PHP 5.4.0 之前： TZ 环境变量（如果非空）

  • date.timezone 配置选项（如果设定了的话）

  • 仅仅在 PHP 5.4.0 之前： 查询操作系统主机 (如果操作系统支持并允许)。 This uses an algorithm that has to guess the timezone. This is by no means going to work correctly for every situation. A warning is shown when this stage is reached. Do not rely on it to be guessed correctly, and set date.timezone to the correct timezone instead.

  • 如果以上选择都不成功，date_default_timezone_get() 会则返回 UTC 的默认时区。

返回值

返回一个 string。

更新日志

版本 | 说明
5.4.0 | 不再使用 TZ 来推测时区。
5.4.0 | 不再根据操作系统的信息来推测时区，因为这是不可靠的。

范例

Example #1 获取默认时区

<?php
date_default_timezone_set('Europe/London');

if (date_default_timezone_get()) {
    echo 'date_default_timezone_set: ' . date_default_timezone_get() . '<br />';
}

if (ini_get('date.timezone')) {
    echo 'date.timezone: ' . ini_get('date.timezone');
}

?>

以上例程的输出类似于：

date_default_timezone_set: Europe/London
date.timezone: Europe/London

Example #2 获取一个时区的简写

<?php
date_default_timezone_set('America/Los_Angeles');
echo date_default_timezone_get() . ' => ' . date('e') . ' => ' . date('T');
?>

以上例程会输出：

America/Los_Angeles => America/Los_Angeles => PST

参见

  • date_default_timezone_set() - 设定用于一个脚本中所有日期时间函数的默认时区
  • 所支持的时区列表


设定用于一个脚本中所有日期时间函数的默认时区

  • ? date_default_timezone_get
  • date_diff ?
  • PHP Manual
  • Date/Time 函数
  • 设定用于一个脚本中所有日期时间函数的默认时区

date_default_timezone_set

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

date_default_timezone_set — 设定用于一个脚本中所有日期时间函数的默认时区

说明

date_default_timezone_set ( string $timezone_identifier ) : bool

date_default_timezone_set() 设定用于所有日期时间函数的默认时区。

Note:

自 PHP 5.1.0 起（此版本日期时间函数被重写了），如果时区不合法则每个对日期时间函数的调用都会产生一条 E_NOTICE 级别的错误信息，如果使用系统设定或 TZ 环境变量则还会产生 E_STRICT 级别的信息。

除了用此函数，你还可以通过 INI 设置 date.timezone 来设置默认时区。

参数

timezone_identifier

时区标识符，例如 UTC 或 Europe/Lisbon。合法标识符列表见所支持的时区列表。

返回值

如果 timezone_identifier 参数无效则返回 false，否则返回 true。

范例

Example #1 获取默认时区

<?php
date_default_timezone_set('America/Los_Angeles');

$script_tz = date_default_timezone_get();

if (strcmp($script_tz, ini_get('date.timezone'))){
    echo 'Script timezone differs from ini-set timezone.';
} else {
    echo 'Script timezone and ini-set timezone match.';
}
?>

更新日志

版本 | 说明
5.3.0 | 现在会抛出 E_WARNING 而不是 E_STRICT。
5.1.2 | 本版本开始验证 timezone_identifier 参数。

参见

  • date_default_timezone_get() - 取得一个脚本中所有日期时间函数所使用的默认时区
  • 所支持的时区列表


别名 DateTime::diff

  • ? date_default_timezone_set
  • date_format ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::diff

date_diff

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_diff — 别名 DateTime::diff()

说明

此函数是该函数的别名： DateTime::diff()


别名 DateTime::format

  • ? date_diff
  • date_get_last_errors ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::format

date_format

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_format — 别名 DateTime::format()

说明

此函数是该函数的别名： DateTime::format()


别名 DateTime::getLastErrors

  • ? date_format
  • date_interval_create_from_date_string ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::getLastErrors

date_get_last_errors

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_get_last_errors — 别名 DateTime::getLastErrors()

说明

此函数是该函数的别名： DateTime::getLastErrors()


别名 DateInterval::createFromDateString

  • ? date_get_last_errors
  • date_interval_format ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateInterval::createFromDateString

date_interval_create_from_date_string

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_interval_create_from_date_string — 别名 DateInterval::createFromDateString()

说明

此函数是该函数的别名： DateInterval::createFromDateString()


别名 DateInterval::format

  • ? date_interval_create_from_date_string
  • date_isodate_set ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateInterval::format

date_interval_format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_interval_format — 别名 DateInterval::format()

说明

此函数是该函数的别名： DateInterval::format()


别名 DateTime::setISODate

  • ? date_interval_format
  • date_modify ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::setISODate

date_isodate_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_isodate_set — 别名 DateTime::setISODate()

说明

此函数是该函数的别名： DateTime::setISODate()


别名 DateTime::modify

  • ? date_isodate_set
  • date_offset_get ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::modify

date_modify

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_modify — 别名 DateTime::modify()

说明

此函数是该函数的别名： DateTime::modify()


别名 DateTime::getOffset

  • ? date_modify
  • date_parse_from_format ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::getOffset

date_offset_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_offset_get — 别名 DateTime::getOffset()

说明

此函数是该函数的别名： DateTime::getOffset()


Get info about given date formatted according to the specified format

  • ? date_offset_get
  • date_parse ?
  • PHP Manual
  • Date/Time 函数
  • Get info about given date formatted according to the specified format

date_parse_from_format

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_parse_from_format — Get info about given date formatted according to the specified format

说明

date_parse_from_format ( string $format , string $datetime ) : array

Returns associative array with detailed info about given date/time.

参数

format

Format accepted by DateTime::createFromFormat().

datetime

String representing the date/time.

返回值

Returns associative array with detailed info about given date/time.

更新日志

版本 | 说明
7.2.0 | The zone element of the returned array represents seconds instead of minutes now, and its sign is inverted. For instance -120 is now 7200.

范例

Example #1 date_parse_from_format() example

<?php
$date = "6.1.2009 13:00+01:00";
print_r(date_parse_from_format("j.n.Y H:iP", $date));
?>

以上例程会输出：

Array
(
    [year] => 2009
    [month] => 1
    [day] => 6
    [hour] => 13
    [minute] => 0
    [second] => 0
    [fraction] =>
    [warning_count] => 0
    [warnings] => Array
        (
        )

    [error_count] => 0
    [errors] => Array
        (
        )

    [is_localtime] => 1
    [zone_type] => 1
    [zone] => 3600
    [is_dst] =>
)

参见

  • DateTime::createFromFormat() - 根据给定的格式解析日期时间字符串
  • checkdate() - 验证一个格里高里日期


返回指定日期/时间的详细信息的关联数组

  • ? date_parse_from_format
  • date_sub ?
  • PHP Manual
  • Date/Time 函数
  • 返回指定日期/时间的详细信息的关联数组

date_parse

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_parse — 返回指定日期/时间的详细信息的关联数组

说明

date_parse ( string $datetime ) : array

参数

datetime

Date/time 接受的格式以 DateTimeImmutable::__construct() 为准。

返回值

成功时返回 array，数组中包含指定日期/时间的信息。 或者在失败时返回 false。

错误／异常

如果 date/time 的格式有错误，则返回数组的 'errors' 键将包含错误信息。

更新日志

版本 | 说明
7.2.0 | 返回数组的 zone 键现在代表秒，而不是分钟。 并且正负符号已反转，例如：之前是 -120 现在是 7200。

范例

Example #1 date_parse() 示例

<?php
print_r(date_parse("2006-12-12 10:00:00.5"));
?>

以上例程会输出：

Array
(
    [year] => 2006
    [month] => 12
    [day] => 12
    [hour] => 10
    [minute] => 0
    [second] => 0
    [fraction] => 0.5
    [warning_count] => 0
    [warnings] => Array()
    [error_count] => 0
    [errors] => Array()
    [is_localtime] =>
)

解析后返回的关联数组不受 相对格式 影响，相对格式的信息会被解析到 "relative" 键。

Example #2 date_parse() 使用相对格式

<?php
print_r(date_parse("2006-12-12 10:00:00.5 +1 week +1 hour"));
?>

以上例程会输出：

Array
(
    [year] => 2006
    [month] => 12
    [day] => 12
    [hour] => 10
    [minute] => 0
    [second] => 0
    [fraction] => 0.5
    [warning_count] => 0
    [warnings] => Array
        (
        )

    [error_count] => 0
    [errors] => Array
        (
        )

    [is_localtime] =>
    [relative] => Array
        (
            [year] => 0
            [month] => 0
            [day] => 7
            [hour] => 1
            [minute] => 0
            [second] => 0
        )

)

参见

  • checkdate() - 验证一个格里高里日期
  • getdate() - 取得日期／时间信息


别名 DateTime::sub

  • ? date_parse
  • date_sun_info ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::sub

date_sub

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_sub — 别名 DateTime::sub()

说明

此函数是该函数的别名： DateTime::sub()


Returns an array with information about sunset/sunrise and twilight begin/end

  • ? date_sub
  • date_sunrise ?
  • PHP Manual
  • Date/Time 函数
  • Returns an array with information about sunset/sunrise and twilight begin/end

date_sun_info

(PHP 5 >= 5.1.2, PHP 7, PHP 8)

date_sun_info — Returns an array with information about sunset/sunrise and twilight begin/end

说明

date_sun_info ( int $timestamp , float $latitude , float $longitude ) : array

参数

timestamp

Unix timestamp.

latitude

Latitude in degrees.

longitude

Longitude in degrees.

返回值

Returns array on success 或者在失败时返回 false. The structure of the array is detailed in the following list:

sunrise
The timestamp of the sunrise (zenith angle = 90°35').
sunset
The timestamp of the sunset (zenith angle = 90°35').
transit
The timestamp when the sun is at its zenith, i.e. has reached its topmost point.
civil_twilight_begin
The start of the civil dawn (zenith angle = 96°). It ends at sunrise.
civil_twilight_end
The end of the civil dusk (zenith angle = 96°). It starts at sunset.
nautical_twilight_begin
The start of the nautical dawn (zenith angle = 102°). It ends at civil_twilight_begin.
nautical_twilight_end
The end of the nautical dusk (zenith angle = 102°). It starts at civil_twilight_end.
astronomical_twilight_begin
The start of the astronomical dawn (zenith angle = 108°). It ends at nautical_twilight_begin.
astronomical_twilight_end
The end of the astronomical dusk (zenith angle = 108°). It starts at nautical_twilight_end.

The values of the array elements are either UNIX timestamps, false if the sun is below the respective zenith for the whole day, or true if the sun is above the respective zenith for the whole day.

范例

Example #1 A date_sun_info() example

<?php
$sun_info = date_sun_info(strtotime("2006-12-12"), 31.7667, 35.2333);
foreach ($sun_info as $key => $val) {
    echo "$key: " . date("H:i:s", $val) . "\n";
}
?>

以上例程会输出：

sunrise: 05:52:11
sunset: 15:41:21
transit: 10:46:46
civil_twilight_begin: 05:24:08
civil_twilight_end: 16:09:24
nautical_twilight_begin: 04:52:25
nautical_twilight_end: 16:41:06
astronomical_twilight_begin: 04:21:32
astronomical_twilight_end: 17:12:00

Example #2 Polar night

<?php
var_dump(date_sun_info(strtotime("2017-12-21"), 90, 0));
?>

以上例程会输出：

array(9) {
  ["sunrise"]=>
  bool(false)
  ["sunset"]=>
  bool(false)
  ["transit"]=>
  int(1513857490)
  ["civil_twilight_begin"]=>
  bool(false)
  ["civil_twilight_end"]=>
  bool(false)
  ["nautical_twilight_begin"]=>
  bool(false)
  ["nautical_twilight_end"]=>
  bool(false)
  ["astronomical_twilight_begin"]=>
  bool(false)
  ["astronomical_twilight_end"]=>
  bool(false)
}

Example #3 Midnight sun

<?php
var_dump(date_sun_info(strtotime("2017-06-21"), 90, 0));
?>

以上例程会输出：

array(9) {
  ["sunrise"]=>
  bool(true)
  ["sunset"]=>
  bool(true)
  ["transit"]=>
  int(1498046510)
  ["civil_twilight_begin"]=>
  bool(true)
  ["civil_twilight_end"]=>
  bool(true)
  ["nautical_twilight_begin"]=>
  bool(true)
  ["nautical_twilight_end"]=>
  bool(true)
  ["astronomical_twilight_begin"]=>
  bool(true)
  ["astronomical_twilight_end"]=>
  bool(true)
}

参见

  • date_sunrise() - 返回给定的日期与地点的日出时间
  • date_sunset() - 返回给定的日期与地点的日落时间


返回给定的日期与地点的日出时间

  • ? date_sun_info
  • date_sunset ?
  • PHP Manual
  • Date/Time 函数
  • 返回给定的日期与地点的日出时间

date_sunrise

(PHP 5, PHP 7, PHP 8)

date_sunrise — 返回给定的日期与地点的日出时间

说明

date_sunrise ( int $timestamp , int $format = SUNFUNCS_RET_STRING , float $latitude = ini_get("date.default_latitude") , float $longitude = ini_get("date.default_longitude") , float $zenith = ini_get("date.sunrise_zenith") , float $gmt_offset = 0 ) : mixed

date_sunrise() 返回给定的日期（以 timestamp 指定）与地点的日出时间。

参数

timestamp

取 timestamp所在日期的日出时间。

format

format 常量
常量 | 说明 | 取值举例
SUNFUNCS_RET_STRING | 以 string 格式返回结果 | 16:46
SUNFUNCS_RET_DOUBLE | 以 float 格式返回结果 | 16.78243132
SUNFUNCS_RET_TIMESTAMP | 以 integer 格式（时间戳）返回结果 | 1095034606

latitude

默认是指北纬。因此如果要指定南纬，必须传递一个负值。 参见 date.default_latitude。

longitude

默认是指东经。因此如果要指定西经，必须传递一个负值。 参见 date.default_longitude。

zenith

默认： date.sunrise_zenith。

gmtoffset

单位是小时。

返回值

按指定格式 format 返回的日出时间， 或者在失败时返回 false。

错误／异常

在每 次调用日期/时间函数时，如果时区无效则会引发 E_NOTICE 错误，如果使用系统设定值或 TZ 环境变量，则会引发 E_STRICT 或 E_WARNING 消息。参见 date_default_timezone_set()。

更新日志

版本 | 说明
5.1.0 | 现在发布 E_STRICT 和 E_NOTICE 时区错误。

范例

Example #1 date_sunrise() 例子

<?php

/* 计算葡萄牙里斯本的日出时间
Latitude:  北纬 38.4 度
Longitude: 西经 9 度
Zenith ~= 90
offset: +1 GMT
*/

echo date("D M d Y"). ', sunrise time : ' .date_sunrise(time(), SUNFUNCS_RET_STRING, 38.4, -9, 90, 1);

?>

以上例程的输出类似于：

Mon Dec 20 2004, sunrise time : 08:54

参见

  • date_sunset() - 返回给定的日期与地点的日落时间


返回给定的日期与地点的日落时间

  • ? date_sunrise
  • date_time_set ?
  • PHP Manual
  • Date/Time 函数
  • 返回给定的日期与地点的日落时间

date_sunset

(PHP 5, PHP 7, PHP 8)

date_sunset — 返回给定的日期与地点的日落时间

说明

date_sunset ( int $timestamp , int $format = SUNFUNCS_RET_STRING , float $latitude = ini_get("date.default_latitude") , float $longitude = ini_get("date.default_longitude") , float $zenith = ini_get("date.sunset_zenith") , float $gmt_offset = 0 ) : mixed

date_sunset() 返回给定的日期（以 timestamp 指定）与地点的日落时间。

参数

timestamp

返回给定的日期（以 timestamp 指定）的日落时间。

format

format 常量
常量 | 说明 | 取值举例
SUNFUNCS_RET_STRING | 以 string 格式返回结果 | 16:46
SUNFUNCS_RET_DOUBLE | 以 float 格式返回结果 | 16.78243132
SUNFUNCS_RET_TIMESTAMP | 以 integer 格式（时间戳）返回结果 | 1095034606

latitude

默认是指北纬。因此如果要指定南纬，必须传递一个负值。参见： date.default_latitude。

longitude

默认是指东经。因此如果要指定西经，必须传递一个负值。参见： date.default_longitude

zenith

默认： date.sunset_zenith。

gmtoffset

单位是小时。

错误／异常

在每 次调用日期/时间函数时，如果时区无效则会引发 E_NOTICE 错误，如果使用系统设定值或 TZ 环境变量，则会引发 E_STRICT 或 E_WARNING 消息。参见 date_default_timezone_set()。

更新日志

版本 | 说明
5.1.0 | 现在发布 E_STRICT 和 E_NOTICE 时区错误。

返回值

用指定的格式 format 返回日落时间， 或者在失败时返回 false。

范例

Example #1 date_sunset() 例子

<?php

/* calculate the sunset time for Lisbon, Portugal
Latitude: 38.4 North
Longitude: 9 West
Zenith ~= 90
offset: +1 GMT
*/

echo date("D M d Y"). ', sunset time : ' .date_sunset(time(), SUNFUNCS_RET_STRING, 38.4, -9, 90, 1);

?>

以上例程的输出类似于：

Mon Dec 20 2004, sunset time : 18:13

参见

  • date_sunrise() - 返回给定的日期与地点的日出时间


别名 DateTime::setTime

  • ? date_sunset
  • date_timestamp_get ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::setTime

date_time_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_time_set — 别名 DateTime::setTime()

说明

此函数是该函数的别名： DateTime::setTime()


别名 DateTime::getTimestamp

  • ? date_time_set
  • date_timestamp_set ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::getTimestamp

date_timestamp_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_timestamp_get — 别名 DateTime::getTimestamp()

说明

此函数是该函数的别名： DateTime::getTimestamp()


别名 DateTime::setTimestamp

  • ? date_timestamp_get
  • date_timezone_get ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::setTimestamp

date_timestamp_set

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

date_timestamp_set — 别名 DateTime::setTimestamp()

说明

此函数是该函数的别名： DateTime::setTimestamp()


别名 DateTime::getTimezone

  • ? date_timestamp_set
  • date_timezone_set ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::getTimezone

date_timezone_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_timezone_get — 别名 DateTime::getTimezone()

说明

此函数是该函数的别名： DateTime::getTimezone()


别名 DateTime::setTimezone

  • ? date_timezone_get
  • date ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTime::setTimezone

date_timezone_set

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

date_timezone_set — 别名 DateTime::setTimezone()

说明

此函数是该函数的别名： DateTime::setTimezone()


格式化一个本地时间／日期

  • ? date_timezone_set
  • getdate ?
  • PHP Manual
  • Date/Time 函数
  • 格式化一个本地时间／日期

date

(PHP 4, PHP 5, PHP 7, PHP 8)

date — 格式化一个本地时间／日期

说明

date ( string $format , int $timestamp = ? ) : string

返回将整数 timestamp 按照给定的格式字串而产生的字符串。如果没有给出时间戳则使用本地当前时间。换句话说，timestamp 是可选的，默认值为 time()。

Tip

自 PHP 5.1.1 起有几个有用的常量可用作标准的日期／时间格式来指定 format 参数。

Tip

自 PHP 5.1 起在 $_SERVER['REQUEST_TIME'] 中保存了发起该请求时刻的时间戳。

Note:

有效的时间戳典型范围是格林威治时间 1901 年 12 月 13 日 20:45:54 到 2038 年 1 月 19 日 03:14:07。（此范围符合 32 位有符号整数的最小值和最大值）。不过在 PHP 5.1 之前此范围在某些系统（如 Windows）中限制为从 1970 年 1 月 1 日到 2038 年 1 月 19 日。

Note:

要将字符串表达的时间转换成时间戳，应该使用 strtotime()。此外一些数据库有一些函数将其时间格式转换成时间戳（例如 MySQL 的 » UNIX_TIMESTAMP 函数）。

格式字串可以识别以下 format 参数的字符串
format 字符 | 说明 | 返回值例子
日 | --- | ---
d | 月份中的第几天，有前导零的 2 位数字 | 01 到 31
D | 星期中的第几天，文本表示，3 个字母 | Mon 到 Sun
j | 月份中的第几天，没有前导零 | 1 到 31
l（"L"的小写字母） | 星期几，完整的文本格式 | Sunday 到 Saturday
N | ISO-8601 格式数字表示的星期中的第几天（PHP 5.1.0 新加） | 1（表示星期一）到 7（表示星期天）
S | 每月天数后面的英文后缀，2 个字符 | st，nd，rd 或者 th。可以和 j 一起用
w | 星期中的第几天，数字表示 | 0（表示星期天）到 6（表示星期六）
z | 年份中的第几天 | 0 到 365
星期 | --- | ---
W | ISO-8601 格式年份中的第几周，每周从星期一开始（PHP 4.1.0 新加的） | 例如：42（当年的第 42 周）
月 | --- | ---
F | 月份，完整的文本格式，例如 January 或者 March | January 到 December
m | 数字表示的月份，有前导零 | 01 到 12
M | 三个字母缩写表示的月份 | Jan 到 Dec
n | 数字表示的月份，没有前导零 | 1 到 12
t | 指定的月份有几天 | 28 到 31
年 | --- | ---
L | 是否为闰年 | 如果是闰年为 1，否则为 0
o | ISO-8601 格式年份数字。这和 Y 的值相同，只除了如果 ISO 的星期数（W）属于前一年或下一年，则用那一年。（PHP 5.1.0 新加） | Examples: 1999 or 2003
Y | 4 位数字完整表示的年份 | 例如：1999 或 2003
y | 2 位数字表示的年份 | 例如：99 或 03
时间 | --- | ---
a | 小写的上午和下午值 | am 或 pm
A | 大写的上午和下午值 | AM 或 PM
B | Swatch Internet 标准时 | 000 到 999
g | 小时，12 小时格式，没有前导零 | 1 到 12
G | 小时，24 小时格式，没有前导零 | 0 到 23
h | 小时，12 小时格式，有前导零 | 01 到 12
H | 小时，24 小时格式，有前导零 | 00 到 23
i | 有前导零的分钟数 | 00 到 59>
s | 秒数，有前导零 | 00 到 59>
u | 毫秒 （PHP 5.2.2 新加）。需要注意的是 date() 函数总是返回 000000 因为它只接受 integer 参数， 而 DateTime::format() 才支持毫秒。 | 示例: 654321
时区 | --- | ---
e | 时区标识（PHP 5.1.0 新加） | 例如：UTC，GMT，Atlantic/Azores
I | 是否为夏令时 | 如果是夏令时为 1，否则为 0
O | 与格林威治时间相差的小时数 | 例如：+0200
P | 与格林威治时间（GMT）的差别，小时和分钟之间有冒号分隔（PHP 5.1.3 新加） | 例如：+02:00
T | 本机所在的时区 | 例如：EST，MDT（【译者注】在 Windows 下为完整文本格式，例如"Eastern Standard Time"，中文版会显示"中国标准时间"）。
Z | 时差偏移量的秒数。UTC 西边的时区偏移量总是负的，UTC 东边的时区偏移量总是正的。 | -43200 到 43200
完整的日期／时间 | --- | ---
c | ISO 8601 格式的日期（PHP 5 新加） | 2004-02-12T15:19:21+00:00
r | RFC 822 格式的日期 | 例如：Thu, 21 Dec 2000 16:01:07 +0200
U | 从 Unix 纪元（January 1 1970 00:00:00 GMT）开始至今的秒数 | 参见 time()

格式字串中不能被识别的字符将原样显示。Z 格式在使用 gmdate() 时总是返回 0。

Example #1 date() 例子

<?php
// 设定要用的默认时区。自 PHP 5.1 可用
date_default_timezone_set('UTC');

// 输出类似：Monday
echo date("l");

// 输出类似：Monday 15th of August 2005 03:12:46 PM
echo date('l dS \of F Y h:i:s A');

// 输出：July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date("l", mktime(0, 0, 0, 7, 1, 2000));

/* 在格式参数中使用常量 */
// 输出类似：Wed, 25 Sep 2013 15:28:57 -0700
echo date(DATE_RFC2822);

// 输出类似：2000-07-01T00:00:00+00:00
echo date(DATE_ATOM, mktime(0, 0, 0, 7, 1, 2000));
?>

在格式字串中的字符前加上反斜线来转义可以避免它被按照上表解释。如果加上反斜线后的字符本身就是一个特殊序列，那还要转义反斜线。

Example #2 在 date() 中转义字符

<?php
// prints something like: Wednesday the 15th
echo date("l \\t\h\e jS");
?>

可以把 date() 和 mktime() 函数结合使用来得到未来或过去的日期。

Example #3 date() 和 mktime() 例子

<?php
$tomorrow  = mktime(0, 0, 0, date("m")  , date("d")+1, date("Y"));
$lastmonth = mktime(0, 0, 0, date("m")-1, date("d"),   date("Y"));
$nextyear  = mktime(0, 0, 0, date("m"),   date("d"),   date("Y")+1);
?>

Note:

由于夏令时的缘故，这种方法比简单地在时间戳上加减一天或者一个月的秒数更可靠。

一些使用 date() 格式化日期的例子。注意要转义所有其它的字符，因为目前有特殊含义的字符会产生不需要的结果，而其余字符在 PHP 将来的版本中可能会被用上。当转义时，注意用单引号以避免类似 \n 的字符变成了换行符。

Example #4 date() 格式举例

<?php
// 假定今天是：March 10th, 2001, 5:16:18 pm
$today = date("F j, Y, g:i a");                 // March 10, 2001, 5:16 pm
$today = date("m.d.y");                         // 03.10.01
$today = date("j, n, Y");                       // 10, 3, 2001
$today = date("Ymd");                           // 20010310
$today = date('h-i-s, j-m-y, it is w Day z ');  // 05-16-17, 10-03-01, 1631 1618 6 Fripm01
$today = date('\i\t \i\s \t\h\e jS \d\a\y.');   // It is the 10th day.
$today = date("D M j G:i:s T Y");               // Sat Mar 10 15:16:08 MST 2001
$today = date('H:m:s \m \i\s\ \m\o\n\t\h');     // 17:03:17 m is month
$today = date("H:i:s");                         // 17:16:17
$today = date("Y-m-d H:i:s");                   // 2001-03-10 17:16:18 （MySQL DATETIME 格式）
?>

要格式化其它语种的日期，应该用 setlocale() 和 strftime() 函数来代替 date()。

参见 getlastmod()，gmdate()，mktime()，strftime() 和 time()。

参数

format

输出的日期 string 格式。 参见下文中的 格式化选项。 同时，还可以使用 预定义日期常量 ，例如：常量 DATE_RSS 表示格式化字符串 'D, d M Y H:i:s'。

format 参数字符串中可识别下列字符
format 字符 | 描述 | 返回值示例
天 --- ---
d | 一个月中的第几天，有前导 0 的 2 位数字 | 从 01 到 31
D | 3 个字符表示的星期几 | 从 Mon 到 Sun
j | 一个月中的第几天，无前导 0 | 从 1 到 31
l (lowercase 'L') | 星期几，英文全称 | 从 Sunday 到 Saturday
N | ISO-8601 规定的数字表示的星期几（PHP 5.1.0 新加 ） | 从 1 （表示星期一）到 7 （表示星期日）
S | 一个月中的第几天，带有 2 个字符表示的英语序数词。 | st， nd， rd 或者 th。 可以和 j 联合使用。
w | 数字表示的星期几 | 从 0 （星期日） 到 6 （星期六）
z | 一年中的第几天，从 0 开始计数 | 从 0 到 365
周 --- ---
W | ISO-8601 规范的一年中的第几周，周一视为一周开始。（PHP 4.1.0 新加） | 示例： 42 （本年第42周）
月 --- ---
F | 月份英文全拼，例如：January 或 March | 从 January 到 December
m | 带有 0 前导的数字表示的月份 | 从 01 到 12
M | 3 个字符表示的月份的英文简拼 | 从 Jan 到 Dec
n | 月份的数字表示，无前导 0 | 1 through 12
t | 给定月份中包含多少天 | 从 28 到 31
年 --- ---
L | 是否为闰年 | 如果是闰年，则返回 1，反之返回 0。
o | ISO-8601 规范的年份，同 Y 格式。有一种情况除外：当 ISO 的周数（W）属于前一年或者后一年时，会返回前一年或者后一年的年份数字表达。 属于前一年或者后一年时，会返回前一年或者后一年的年份数字表达。 （PHP 5.1.0 新加） | 示例：1999 或 2003
Y | 4 位数字的年份 | 示例：1999 或 2003
y | 2 位数字的年份 | 示例： 99 或 03
时间 --- ---
a | 上午还是下午，2 位小写字符 | am 或 pm
A | 上午还是下午，2 位大写字符 | AM 或 PM
B | 斯沃琪因特网时间 | 从 000 到 999
g | 小时，12时制，无前导 0 | 从 1 到 12
G | 小时，24时制，无前导 0 | 从 0 到 23
h | 小时，12时制，有前导 0 的 2 位数字 | 从 01 到 12
H | 小时，24时制，有前导 0 的 2 位数字 | 00 through 23
i | 分钟，有前导 0 的 2 位数字 | 从 00 到 59
s | 秒，有前导 0 的 2 位数字 | 从 00 到 59
u | 毫秒 （PHP 5.2.2 新加） | 示例： 654321
时区 --- ---
e | 时区标识（PHP 5.1.0 新加） | 示例: UTC, GMT, Atlantic/Azores
I （大写字母 i） | 是否夏令时 | 如果是夏令时则返回 1，反之返回 0。
O | 和格林威治时间（GMT）的时差，以小时为单位 | 示例： +0200
P | 和格林威治时间（GMT）的时差，包括小时和分钟，小时和分钟之间使用冒号（:）分隔（PHP 5.1.3 新加） | 示例： +02:00
T | 时区缩写 | 示例：EST, MDT ...
Z | 以秒为单位的时区偏移量。UTC 以西的时区返回负数，UTC 以东的时区返回正数。 | 从 -43200 到 50400
完整的日期/时间 --- ---
c | ISO 8601 日期及时间（PHP 5 新加） | 2004-02-12T15:19:21+00:00
r | » RFC 2822 格式的日期和时间 | 示例：Thu, 21 Dec 2000 16:01:07 +0200
U | 自 1970 年 1 月 1 日 0 时 0 分 0 秒（GMT 时间）以来的时间，以秒为单位 | 参见time()

格式化字符串中的不可识别字符将原样输出。 当使用 gmdate() 函数时， Z 格式永远返回 0。

Note:

由于本函数仅接受 integer 类型的时间戳参数，所以 u 格式仅在使用 date_format() 函数并且使用 date_create() 函数创建时间戳时才是有用的。

timestamp

可选的 timestamp 参数是一个 int 的 Unix 时间戳，如未指定或是 null，参数值默认为当前本地时间。也就是说，其值默认为 time() 的返回值。

返回值

返回格式化后的日期时间的字符串表达。 如果 timestamp 参数不是一个有效数值，则返回 false 并引发 E_WARNING 级别的错误。

错误／异常

在每 次调用日期/时间函数时，如果时区无效则会引发 E_NOTICE 错误，如果使用系统设定值或 TZ 环境变量，则会引发 E_STRICT 或 E_WARNING 消息。参见 date_default_timezone_set()。

更新日志

版本 | 说明
5.1.0 | 时间戳的有效取值范围为 GMT 时间的 1901 年 12 月 13 日至 GMT 时间的 2038 年 1 月 19 日。 （32 位有符号整数的取值范围）。 但是，在 PHP 5.1.0 之前的版本，在某些系统（例如 Windows）上有效取值范围为 1970 年 1 月 1 日至 2038 年 1 月 19 日。
5.1.0 | 现在发布 E_STRICT 和 E_NOTICE 时区错误。
5.1.1 | format 参数标准的可用日期/时间格式常量见： 常量

范例

Example #5 date() 函数示例

<?php
// 设置默认时区。PHP 5.1 之后版本可用
date_default_timezone_set('UTC');

// 输出类似： Monday
echo date("l");

// 输出类似：Monday 8th of August 2005 03:12:46 PM
echo date('l jS \of F Y h:i:s A');

// 输出：July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date("l", mktime(0, 0, 0, 7, 1, 2000));

/* 使用格式常量 */
// 输出类似： Mon, 15 Aug 2005 15:12:46 UTC
echo date(DATE_RFC822);

// 输出类似：2000-07-01T00:00:00+00:00
echo date(DATE_ATOM, mktime(0, 0, 0, 7, 1, 2000));
?>

可以使用反斜线进行转义来阻止函数解析格式字符串中的可识别字符。 如果反斜线和要转义的字符连在一起依然是一个有效的字符序列，那么需要对 反斜线再次进行转义。

Example #6 对 date() 函数中的格式字符串进行转义

<?php
// 输出类似： Wednesday the 15th
echo date('l \t\h\e jS');
?>

可以联合使用 date() 和 mktime() 函数 来构造之前或者之后的日期时间。

Example #7 date() 和 mktime() 联合使用示例

<?php
$tomorrow  = mktime(0, 0, 0, date("m")  , date("d")+1, date("Y"));
$lastmonth = mktime(0, 0, 0, date("m")-1, date("d"),   date("Y"));
$nextyear  = mktime(0, 0, 0, date("m"),   date("d"),   date("Y")+1);
?>

Note:

由于存在夏令时时间， 所以此方案相对于直接在时间戳上加/减秒数 要更加可靠。

date() 函数格式化的一些示例。 需要注意的是，即使是对于当前来说并不具有特殊含义的字符， 也要像对待具有特殊含义的字符那样进行转义，以避免函数返回非预期的值。 因为可能在将来的 PHP 版本中，这些字符会被赋予特殊的含义。 进行转义的时候，请确保使用单引号，以避免 \n 被解释为换行符号。

Example #8 date() 函数格式化

<?php
// 假设今天是 2001 年 3 月 10 日下午 5 点 16 分 18 秒，
// 并且位于山区标准时间（MST）时区

$today = date("F j, Y, g:i a");                 // March 10, 2001, 5:16 pm
$today = date("m.d.y");                         // 03.10.01
$today = date("j, n, Y");                       // 10, 3, 2001
$today = date("Ymd");                           // 20010310
$today = date('h-i-s, j-m-y, it is w Day');     // 05-16-18, 10-03-01, 1631 1618 6 Satpm01
$today = date('\i\t \i\s \t\h\e jS \d\a\y.');   // it is the 10th day.
$today = date("D M j G:i:s T Y");               // Sat Mar 10 17:16:18 MST 2001
$today = date('H:m:s \m \i\s\ \m\o\n\t\h');     // 17:03:18 m is month
$today = date("H:i:s");                         // 17:16:18
?>

如果需要将日期时间格式化为其他语言，你应该使用 setlocale() 和 strftime() 函数 来替代 date() 函数。

注释

Note:

使用 strtotime() 函数将一个字符串表达的日期时间转换为时间戳。 另外，一些数据库产品也提供了将日期时间格式转换为时间戳的函数。 （例如 MySQL 中的 » UNIX_TIMESTAMP 函数）。

Tip

从 PHP 5.1 版本开始，请求的开始时间可以从变量 $_SERVER['REQUEST_TIME'] 中获取。

参见

  • gmdate() - 格式化一个 GMT/UTC 日期／时间
  • idate() - 将本地时间日期格式化为整数
  • getdate() - 取得日期／时间信息
  • getlastmod() - 获取页面最后修改的时间
  • mktime() - 取得一个日期的 Unix 时间戳
  • strftime() - 根据区域设置格式化本地时间／日期
  • time() - 返回当前的 Unix 时间戳
  • strtotime() - 将任何字符串的日期时间描述解析为 Unix 时间戳
  • 预定义的日期时间常量


取得日期／时间信息

  • ? date
  • gettimeofday ?
  • PHP Manual
  • Date/Time 函数
  • 取得日期／时间信息

getdate

(PHP 4, PHP 5, PHP 7, PHP 8)

getdate — 取得日期／时间信息

说明

getdate ( int $timestamp = time() ) : array

返回一个根据 timestamp 得出的包含有日期信息的关联数组 array。如果没有给出时间戳则认为是当前本地时间。

参数

timestamp

可选的 timestamp 参数是一个 int 的 Unix 时间戳，如未指定或是 null，参数值默认为当前本地时间。也就是说，其值默认为 time() 的返回值。

返回值

返回一个根据 timestamp 得出的包含有日期信息的关联数组 array。 返回的关联数组中的键名单元有以下几个：

返回的关联数组中的键名单元
键名 | 说明 | 返回值例子
"seconds" | 秒的数字表示 | 0 到 59
"minutes" | 分钟的数字表示 | 0 到 59
"hours" | 小时的数字表示 | 0 到 23
"mday" | 月份中第几天的数字表示 | 1 到 31
"wday" | 星期中第几天的数字表示 | 0 (周日) 到 6 (周六)
"mon" | 月份的数字表示 | 1 到 12
"year" | 4 位数字表示的完整年份 | 比如： 1999 或 2003
"yday" | 一年中第几天的数字表示 | 0 到 365
"weekday" | 星期几的完整文本表示 | Sunday 到 Saturday
"month" | 月份的完整文本表示，比如 January 或 March | January 到 December
0 | 自从 Unix 纪元开始至今的秒数，和 time() 的返回值以及用于 date() 的值类似。 | 系统相关，典型值为从 -2147483648 到 2147483647。

范例

Example #1 getdate() 例子

<?php
$today = getdate();
print_r($today);
?>

以上例程的输出类似于：

Array
(
    [seconds] => 40
    [minutes] => 58
    [hours]   => 21
    [mday]    => 17
    [wday]    => 2
    [mon]     => 6
    [year]    => 2003
    [yday]    => 167
    [weekday] => Tuesday
    [month]   => June
    [0]       => 1055901520
)

参见

  • date() - 格式化一个本地时间／日期
  • idate() - 将本地时间日期格式化为整数
  • localtime() - 取得本地时间
  • time() - 返回当前的 Unix 时间戳
  • setlocale() - 设置地区信息


取得当前时间

  • ? getdate
  • gmdate ?
  • PHP Manual
  • Date/Time 函数
  • 取得当前时间

gettimeofday

(PHP 4, PHP 5, PHP 7, PHP 8)

gettimeofday — 取得当前时间

说明

gettimeofday ( bool $return_float = false ) : mixed

本函数是 gettimeofday(2) 的接口。返回一个关联数组，包含有系统调用返回的数据。

参数

return_float

当其设为 true 时，会返回一个浮点数而不是一个数组。

返回值

默认返回一个 array。如果 return_float 设置了则会返回一个 float。

数组中的键为：

  • "sec" - 自 Unix 纪元起的秒数
  • "usec" - 微秒数
  • "minuteswest" - 格林威治向西的分钟数
  • "dsttime" - 夏令时修正的类型

更新日志

版本 | 说明
5.1.0 | 增加了参数 return_float。

范例

Example #1 gettimeofday() 例子

<?php
print_r(gettimeofday());

echo gettimeofday(true);
?>

以上例程的输出类似于：

Array
(
    [sec] => 1073504408
    [usec] => 238215
    [minuteswest] => 0
    [dsttime] => 1
)

1073504408.23910


格式化一个 GMT/UTC 日期／时间

  • ? gettimeofday
  • gmmktime ?
  • PHP Manual
  • Date/Time 函数
  • 格式化一个 GMT/UTC 日期／时间

gmdate

(PHP 4, PHP 5, PHP 7, PHP 8)

gmdate — 格式化一个 GMT/UTC 日期／时间

说明

gmdate ( string $format , int $timestamp = ? ) : string

同 date() 函数完全一样，只除了返回的时间是格林威治标准时（GMT）。例如当在中国（GMT +0800）运行以下程序时，第一行显示"Jan 01 2000 00:00:00"而第二行显示"Dec 31 1999 16:00:00"。

Example #1 gmdate() 例子

<?php
echo date("M d Y H:i:s", mktime (0,0,0,1,1,2000));
echo gmdate("M d Y H:i:s", mktime (0,0,0,1,1,2000));
?>

Note:

在 PHP 5.1.0 之前，负的时间戳（1970 年之前的日期）在某些系统下（例如 Windows）不能工作。

参见 date()，mktime()，gmmktime() 和 strftime()。


取得 GMT 日期的 UNIX 时间戳

  • ? gmdate
  • gmstrftime ?
  • PHP Manual
  • Date/Time 函数
  • 取得 GMT 日期的 UNIX 时间戳

gmmktime

(PHP 4, PHP 5, PHP 7, PHP 8)

gmmktime — 取得 GMT 日期的 UNIX 时间戳

说明

gmmktime ( int $hour = ? , int $minute = ? , int $second = ? , int $month = ? , int $day = ? , int $year = ? , int $is_dst = ? ) : int

和 mktime() 完全一样，只除了返回值是格林威治标准时的时间戳。

参数总是表示 GMT 日期，因此 is_dst 对结果没有影响。

和 mktime() 一样，参数可以从右到左依次空着，空着的参数会被设为相应的当前 GMT 值。

Note:

自 5.1.0 起，is_dst 参数被废弃。因此应该用新的时区处理特性。

Note: gmmktime() 内部使用了 mktime()，因此只有转换成本地时间也合法的时间才能用在其中。 so only times valid in derived local time can be used.

Example #1 gmmktime() 在 Windows 中的边界

<?php
gmmktime(0, 0, 0, 1, 1, 1970); // 在 GMT 和西方合法，在东方不合法
?>

参见 mktime()，date() 和 time()。


根据区域设置格式化 GMT/UTC 时间／日期

  • ? gmmktime
  • idate ?
  • PHP Manual
  • Date/Time 函数
  • 根据区域设置格式化 GMT/UTC 时间／日期

gmstrftime

(PHP 4, PHP 5, PHP 7, PHP 8)

gmstrftime — 根据区域设置格式化 GMT/UTC 时间／日期

说明

gmstrftime ( string $format , int $timestamp = ? ) : string

和 strftime() 的行为相同，只除了返回时间是格林威治标准时（GMT）。例如，当在东部标准时（EST，GMT -500）运行时，下面第一行显示"Dec 31 1998 20:00:00"，而第二行显示"Jan 01 1999 01:00:00"。

Example #1 gmstrftime() 例子

<?php
setlocale(LC_TIME, 'en_US');
echo strftime("%b %d %Y %H:%M:%S", mktime (20,0,0,12,31,98))."\n";
echo gmstrftime("%b %d %Y %H:%M:%S", mktime (20,0,0,12,31,98))."\n";
?>

参见 strftime()。


将本地时间日期格式化为整数

  • ? gmstrftime
  • localtime ?
  • PHP Manual
  • Date/Time 函数
  • 将本地时间日期格式化为整数

idate

(PHP 5, PHP 7, PHP 8)

idate — 将本地时间日期格式化为整数

说明

idate ( string $format , int $timestamp = ? ) : int

根据给定的格式字符对 timestamp 格式化并返回数字结果。timestamp 为可选项，默认值为本地当前时间，即 time() 的值。

和 date() 不同，idate() 只接受一个字符作为 format 参数。

format 参数可识别以下字符
format 字符 | 说明
B | Swatch Beat/Internet Time
d | 月份中的第几天
h | 小时（12 小时格式）
H | 小时（24 小时格式）
i | 分钟
I | 如果启用夏时制则返回 1，否则返回 0
L | 如果是闰年则返回 1，否则返回 0
m | 月份的数字
s | 秒数
t | 本月的总天数
U | 自 Unix 纪元（January 1 1970 00:00:00 GMT）起的秒数——这和 time() 作用相同
w | 星期中的第几天（星期天是 0）
W | ISO-8601 格式年份中的第几个星期，每星期从星期一开始
y | 年份（1 或 2 位数字——见下面说明）
Y | 年份（4 位数字）
z | 年份中的第几天
Z | 以秒为单位的时区偏移量

Note:

因为 idate() 总是返回 integer，不能以"0"开头，因此 idate() 可能会返回比用户期望中要少的数字。见下面例子：

<?php
$timestamp = strtotime('1st January 2004'); //1072915200

// 下面以两位数字格式显示年份，但是因为
// 以"0"打头，因此只会显示"4"
echo idate('y', $timestamp);
?>

参见 date() 和 time()。


取得本地时间

  • ? idate
  • microtime ?
  • PHP Manual
  • Date/Time 函数
  • 取得本地时间

localtime

(PHP 4, PHP 5, PHP 7, PHP 8)

localtime — 取得本地时间

说明

localtime ( int $timestamp = time() , bool $is_associative = false ) : array

localtime() 函数返回一个数组，其结构和 C 函数调用返回的完全一样。

参数

timestamp

可选的 timestamp 参数是一个 int 的 Unix 时间戳，如未指定或是 null，参数值默认为当前本地时间。也就是说，其值默认为 time() 的返回值。

is_associative

如果设为 false 或未提供则返回的是普通的数字索引数组。如果该参数设为 true 则 localtime() 函数返回包含有所有从 C 的 localtime 函数调用所返回的不同单元的关联数组。关联数组中不同的键名为：

  • "tm_sec" - 秒数， 0 到 59
  • "tm_min" - 分钟数， 0 到 59
  • "tm_hour" - 小时， 0 到 23
  • "tm_mday" - 月份中的第几日， 1 到 31
  • "tm_mon" - 年份中的第几个月， 0 (Jan) 到 11 (Dec)
  • "tm_year" - 年份，从 1900 开始
  • "tm_wday" - 星期中的第几天， 0 (Sun) 到 6 (Sat)
  • "tm_yday" - 一年中的第几天， 0 到 365
  • "tm_isdst" - 夏令时当前是否生效？ 如果是生效的是正数， 0 代表未生效，负数代表未知。

错误／异常

在每 次调用日期/时间函数时，如果时区无效则会引发 E_NOTICE 错误，如果使用系统设定值或 TZ 环境变量，则会引发 E_STRICT 或 E_WARNING 消息。参见 date_default_timezone_set()。

更新日志

版本 | 说明
5.1.0 | 现在发布 E_STRICT 和 E_NOTICE 时区错误。

范例

Example #1 localtime() 例子

<?php
$localtime = localtime();
$localtime_assoc = localtime(time(), true);
print_r($localtime);
print_r($localtime_assoc);
?>

以上例程的输出类似于：

Array
(
    [0] => 24
    [1] => 3
    [2] => 19
    [3] => 3
    [4] => 3
    [5] => 105
    [6] => 0
    [7] => 92
    [8] => 1
)

Array
(
    [tm_sec] => 24
    [tm_min] => 3
    [tm_hour] => 19
    [tm_mday] => 3
    [tm_mon] => 3
    [tm_year] => 105
    [tm_wday] => 0
    [tm_yday] => 92
    [tm_isdst] => 1
)

参见

  • getdate() - 取得日期／时间信息


返回当前 Unix 时间戳和微秒数

  • ? localtime
  • mktime ?
  • PHP Manual
  • Date/Time 函数
  • 返回当前 Unix 时间戳和微秒数

microtime

(PHP 4, PHP 5, PHP 7, PHP 8)

microtime — 返回当前 Unix 时间戳和微秒数

说明

microtime ( bool $get_as_float = ? ) : mixed

microtime() 当前 Unix 时间戳以及微秒数。本函数仅在支持 gettimeofday() 系统调用的操作系统下可用。

如果调用时不带可选参数，本函数以 "msec sec" 的格式返回一个字符串，其中 sec 是自 Unix 纪元（0:00:00 January 1, 1970 GMT）起到现在的秒数，msec 是微秒部分。字符串的两部分都是以秒为单位返回的。

如果给出了 get_as_float 参数并且其值等价于 true，microtime() 将返回一个浮点数。

Note: get_as_float 参数是 PHP 5.0.0 新加的。

Example #1 用 microtime() 对脚本的运行计时

<?php
/**
 * Simple function to replicate PHP 5 behaviour
 */
function microtime_float()
{
    list($usec, $sec) = explode(" ", microtime());
    return ((float)$usec + (float)$sec);
}

$time_start = microtime_float();

// Sleep for a while
usleep(100);

$time_end = microtime_float();
$time = $time_end - $time_start;

echo "Did nothing in $time seconds\n";
?>

参见 time()。


取得一个日期的 Unix 时间戳

  • ? microtime
  • strftime ?
  • PHP Manual
  • Date/Time 函数
  • 取得一个日期的 Unix 时间戳

mktime

(PHP 4, PHP 5, PHP 7, PHP 8)

mktime — 取得一个日期的 Unix 时间戳

说明

mktime
 ( int $hour = date("H")
, int $minute = date("i")
, int $second = date("s")
, int $month = date("n")
, int $day = date("j")
, int $year = date("Y")
, int $is_dst = -1
) : int

根据给出的参数返回 Unix 时间戳。时间戳是一个长整数，包含了从 Unix 纪元（January 1 1970 00:00:00 GMT）到给定时间的秒数。

参数可以从右向左省略，任何省略的参数会被设置成本地日期和时间的当前值。

注释

Note:

As of PHP 5.1, when called with no arguments, mktime() throws an E_STRICT notice: use the time() function instead.

参数

hour

小时数。 The number of the hour relative to the start of the day determined by month, day and year. Negative values reference the hour before midnight of the day in question. Values greater than 23 reference the appropriate hour in the following day(s).

minute

分钟数。 The number of the minute relative to the start of the hour. Negative values reference the minute in the previous hour. Values greater than 59 reference the appropriate minute in the following hour(s).

second

秒数（一分钟之内）。 The number of seconds relative to the start of the minute. Negative values reference the second in the previous minute. Values greater than 59 reference the appropriate second in the following minute(s).

month

月份数。 The number of the month relative to the end of the previous year. Values 1 to 12 reference the normal calendar months of the year in question. Values less than 1 (including negative values) reference the months in the previous year in reverse order, so 0 is December, -1 is November, etc. Values greater than 12 reference the appropriate month in the following year(s).

day

天数。 The number of the day relative to the end of the previous month. Values 1 to 28, 29, 30 or 31 (depending upon the month) reference the normal days in the relevant month. Values less than 1 (including negative values) reference the days in the previous month, so 0 is the last day of the previous month, -1 is the day before that, etc. Values greater than the number of days in the relevant month reference the appropriate day in the following month(s).

year

年份数，可以是两位或四位数字，0-69 对应于 2000-2069，70-100 对应于 1970-2000。在如今系统中普遍把 time_t 作为一个 32 位有符号整数的情况下，year 的合法范围是 1901 到 2038 之间，不过此限制自 PHP 5.1.0 起已被克服了。

is_dst

本参数可以设为 1，表示正处于夏时制时间（DST），0 表示不是夏时制，或者 -1（默认值）表示不知道是否是夏时制。如果未知，PHP 会尝试自己搞明白。这可能产生不可预知（但并非不正确）的结果。如果 PHP 运行的系统中启用了 DST 或者 is_dst 设为 1，某些时间是无效的。例如 DST 自 2:00 生效，则所有处于 2:00 到 3:00 之间的时间都无效，mktime() 会返回一个未定义（通常为负）的值。某些系统（例如 Solaris 8）的 DST 在午夜生效，则 DST 生效当天的 0:30 会被计算为前一天的 23:30。

Note:

自 PHP 5.1.0 起，本参数已被废弃。应该使用新的时区处理特性来替代。

Note:

PHP 7.0.0 起，此参数已经被移除。

返回值

mktime() 根据给出的参数返回 Unix 时间戳。如果参数非法，本函数返回 false（在 PHP 5.1 之前返回 -1）。

错误／异常

在每 次调用日期/时间函数时，如果时区无效则会引发 E_NOTICE 错误，如果使用系统设定值或 TZ 环境变量，则会引发 E_STRICT 或 E_WARNING 消息。参见 date_default_timezone_set()。

更新日志

版本 | 说明
7.0.0 | is_dst参数已经被移除。
5.3.0 | mktime() now throws E_DEPRECATED notice if the is_dst parameter is used.
5.1.0 | is_dst 参数被废弃。出错时函数返回 false 而不再是 -1。修正了本函数可以接受年月日参数全为零。
5.1.0 | When called with no arguments, mktime() throws E_STRICT notice. Use the time() function instead.
5.1.0 | 现在发布 E_STRICT 和 E_NOTICE 时区错误。

范例

Example #1 基本例子

<?php
// Set the default timezone to use. Available as of PHP 5.1
date_default_timezone_set('UTC');

// Prints: July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date("l", mktime(0, 0, 0, 7, 1, 2000));

// Prints something like: 2006-04-05T01:02:03+00:00
echo date('c', mktime(1, 2, 3, 4, 5, 2006));
?>

Example #2 mktime() 例子

mktime() 在做日期计算和验证方面很有用，它会自动计算超出范围的输入的正确值。例如下面例子中每一行都会产生字符串 "Jan-01-1998"。

<?php
echo date("M-d-Y", mktime(0, 0, 0, 12, 32, 1997));
echo date("M-d-Y", mktime(0, 0, 0, 13, 1, 1997));
echo date("M-d-Y", mktime(0, 0, 0, 1, 1, 1998));
echo date("M-d-Y", mktime(0, 0, 0, 1, 1, 98));
?>

Example #3 下个月的最后一天

任何给定月份的最后一天都可以被表示为下个月的第 "0" 天，而不是 -1 天。下面两个例子都会产生字符串 "The last day in Feb 2000 is: 29"。

<?php
$lastday = mktime(0, 0, 0, 3, 0, 2000);
echo strftime("Last day in Feb 2000 is: %d", $lastday);
$lastday = mktime(0, 0, 0, 4, -31, 2000);
echo strftime("Last day in Feb 2000 is: %d", $lastday);
?>

注释

Caution

在 PHP 5.1.0 之前，在任何已知 Windows 版本以及一些其它系统下不支持负的时间戳。因此年份的有效范围限制为 1970 到 2038。

参见

  • checkdate() - 验证一个格里高里日期
  • gmmktime() - 取得 GMT 日期的 UNIX 时间戳
  • date() - 格式化一个本地时间／日期
  • time() - 返回当前的 Unix 时间戳


根据区域设置格式化本地时间／日期

  • ? mktime
  • strptime ?
  • PHP Manual
  • Date/Time 函数
  • 根据区域设置格式化本地时间／日期

strftime

(PHP 4, PHP 5, PHP 7, PHP 8)

strftime — 根据区域设置格式化本地时间／日期

说明

strftime ( string $format , int $timestamp = time() ) : string

返回用给定的格式字串对给出的 timestamp 进行格式输出后的字符串。如果没有给出时间戳则用当前的本地时间。月份和星期几以及其它和语言有关的字符串写法和用 setlocale() 设定的当前的区域有关。

可能不是所有的转换标记都被 C 库文件支持，这种情况下 PHP 的 strftime() 也不支持。此外，不是所有的平台都支持负的时间戳，因此日期的范围可能限定在不早于 Unix 纪元。这意味着例如 %e, %T，%R 和 %D（可能更多）以及早于 Jan 1, 1970 的时间在 Windows，一些 Linux 发行版本，以及其它几个操作系统中无效。对于 Windows 系统，所支持的转换标记可在 » MSDN 网站找到。

参数

format

format 里能够识别的格式字串有以下标记：
格式 | 描述 | 返回值示例
日 --- ---
%a | 当前区域星期几的简写 | Sun 到 Sat
%A | 当前区域星期几的全称 | Sunday 到 Saturday
%d | 月份中的第几天，十进制数字（范围从 01 到 31） | 01 到 31
%e | 月份中的第几天，十进制数字，一位的数字前会加上一个空格（范围从 ' 1' 到 '31'） 在 Windows 上尚未按描述实现。更多信息见下方。 | 1 到 31
%j | 年份中的第几天，带前导零的三位十进制数（范围从 001 到 366） | 001 到 366
%u | 符合 ISO-8601 星期几的十进制数表达 [1,7]，1 表示星期一 | 1 (星期一) 到 7 (星期日)
%w | 星期中的第几天，星期天为 0 | 0 (星期天) 到 6 (星期六)
周 --- ---
%U | 本年的第几周，从第一周的第一个星期天作为第一天开始 | 13 (for the 13th full week of the year)
%V | %V - 本年第几周的 ISO-8601:1988 格式，范围从 01 到 53，第 1 周是本年第一个至少还有 4 天的星期，星期一作为每周的第一天。（用 %G 或者 %g 作为指定时间戳相应周数的年份组成。） | 01 到 53 (where 53 accounts for an overlapping week)
%W | 本年的第几周数，从第一周的第一个星期一作为第一天开始 | 46 (for the 46th week of the year beginning with a Monday)
月 --- ---
%b | 当前区域月份的简写 | Jan 到 Dec
%B | 当前区域月份的全称 | January 到 December
%h | 当前区域月份的简写（%b 的别名） | Jan 到 Dec
%m | 两位数的月份 | 01 (是一月份) 到 12 (是十二月份)
年 --- ---
%C | 两位数显示世纪（年份除以 100，截成整数） | 19 是 20 世纪
%g | 2 位数的年份，符合 ISO-8601:1988 星期数（参见 %V）。和 %V 的格式和值一样，只除了如果 ISO 星期数属于前一年或者后一年，则使用那一年。 | 比如：2009年1月6日那一周是 09。
%G | %g 的完整四位数版本 | 比如：2009年1月3日那一周是 2008.
%y | 两位数显示年份 | 比如： 09 是 2009，79 是 1979
%Y | 四位数显示年份 | 比如： 2038
时间 --- ---
%H | 以 24 小时格式显示两位小时数 | 00 到 23
%I | 以 12 小时格式显示两位小时数 | 01 到 12
%l（'L' 的小写） | 以 12 小时格式显示小时数，单个数字前含空格 | 1 到 12
%M | 两位的分钟数 | 00 到 59
%p | 指定时间的大写 "AM" 或 "PM" | 比如： 00:31 是 AM ，22:23 是PM
%P | 指定时间的小写 "am" 或 "pm" | 比如：00:31 是 am ，22:23 是pm
%r | 和 "%I:%M:%S %p" 一样 | 比如： 21:34:17 是 09:34:17 PM
%R | 和 "%H:%M" 一样 | 比如： 12:35 AM 是 00:35，4:44 PM 是 16:44
%S | 两位数字表示秒 | 00 到 59
%T | 和 "%H:%M:%S" 一样 | 比如： 09:34:17 PM 是 21:34:17
%X | 当前区域首选的时间表示法，不包括日期 | 例如： 03:59:16 或 15:59:16
%z | 从 UTC 的时区偏移 或 简写（由操作系统决定） | 比如： 东部时间是 -0500 或 EST
%Z | %z 没有给出的 UTC 的时区偏移 或 简写（由操作系统决定） | 比如： -0500 或 EST 是东部时间
时间和日期戳 --- ---
%c | 当前区域首选的日期时间表达 | 比如： 2009 年 2 月 5 日上午 12:45:10 是 Tue Feb 5 00:45:10 2009
%D | 和 "%m/%d/%y" 一样 | 比如： 2009 年 2 月 5 日是 02/05/09
%F | Same as "%Y-%m-%d" (commonly used in database datestamps) | 比如：2009 年 2 月 5 日是 2009-02-05
%s | Unix纪元的时间戳（和 time() 函数一样） | 比如： 1979 年 9 月 10 日上午 8 点 40 分 00 秒是 305815200
%x | 当前区域首选的时间表示法，不包括时间 | 比如： 2009 年 2 月 5 日是 02/05/09
其他 --- ---
%n 换行符("\n") ---
%t Tab 字符("\t") ---
%% 文字上的百分字符("%") ---

这个参数的最大长度是 1023 个字符。

Warning

尽管 ISO 9889:1999（当前的 C 标准）明确指出一周从星期一开始，但是 Sun Solaris 的一周似乎从星期天开始并作为 1。所以 %u 的结果也许不会和手册里描述得一样。

Warning

仅针对 Windows：这个函数里 %e 修饰符修饰符还不能支持 Windows。 为了得到这个值可以用 %#d 修饰符来代替。下例说明了如何写一个跨平台支持的函数。

Warning

仅针对 Mac OS X：这个函数里 %P 修饰符还不能支持 Mac OS X。

timestamp

可选的 timestamp 参数是一个 int 的 Unix 时间戳，如未指定或是 null，参数值默认为当前本地时间。也就是说，其值默认为 time() 的返回值。

返回值

根据指定的 timestamp 或未给出 timestamp 是使用当前本地时间， 返回 format 格式化的字符。 月份、星期名和其他与语言相关的字符串遵守 setlocale() 设置的当前区域设置。

错误／异常

在每 次调用日期/时间函数时，如果时区无效则会引发 E_NOTICE 错误，如果使用系统设定值或 TZ 环境变量，则会引发 E_STRICT 或 E_WARNING 消息。参见 date_default_timezone_set()。

由于输出依赖于 C 库，所以一些转换标记并不被支持。 在 Windows 上，使用未知的转换标记将导致 5 E_WARNING 信息，并返回 false。 在其他的操作系统上，你可能不能得到任何 E_WARNING 信息， 并且可能输出未经转换的转换标记。

更新日志

版本 | 说明
5.1.0 | 现在发布 E_STRICT 和 E_NOTICE 时区错误。

范例

如果你的系统里安装了各自的语言环境则下例能够正常运行。

Example #1 strftime() 区域的例子

<?php
setlocale(LC_TIME, "C");
echo strftime("%A");
setlocale(LC_TIME, "fi_FI");
echo strftime(" in Finnish is %A,");
setlocale(LC_TIME, "fr_FR");
echo strftime(" in French %A and");
setlocale(LC_TIME, "de_DE");
echo strftime(" in German %A.\n");
?>

Example #2 ISO 8601:1988 week number example

<?php
/*     December 2002 / January 2003
ISOWk  M   Tu  W   Thu F   Sa  Su
----- ----------------------------
51     16  17  18  19  20  21  22
52     23  24  25  26  27  28  29
1      30  31   1   2   3   4   5
2       6   7   8   9  10  11  12
3      13  14  15  16  17  18  19   */

// 输出： 12/28/2002 - %V,%G,%Y = 52,2002,2002
echo "12/28/2002 - %V,%G,%Y = " . strftime("%V,%G,%Y", strtotime("12/28/2002")) . "\n";

// 输出： 12/30/2002 - %V,%G,%Y = 1,2003,2002
echo "12/30/2002 - %V,%G,%Y = " . strftime("%V,%G,%Y", strtotime("12/30/2002")) . "\n";

// 输出： 1/3/2003 - %V,%G,%Y = 1,2003,2003
echo "1/3/2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2003")) . "\n";

// 输出： 1/10/2003 - %V,%G,%Y = 2,2003,2003
echo "1/10/2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/10/2003")) . "\n";

/*     December 2004 / January 2005
ISOWk  M   Tu  W   Thu F   Sa  Su
----- ----------------------------
51     13  14  15  16  17  18  19
52     20  21  22  23  24  25  26
53     27  28  29  30  31   1   2
1       3   4   5   6   7   8   9
2      10  11  12  13  14  15  16   */

// 输出： 12/23/2004 - %V,%G,%Y = 52,2004,2004
echo "12/23/2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/23/2004")) . "\n";

// 输出： 12/31/2004 - %V,%G,%Y = 53,2004,2004
echo "12/31/2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/31/2004")) . "\n";

// 输出： 1/2/2005 - %V,%G,%Y = 53,2004,2005
echo "1/2/2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/2/2005")) . "\n";

// 输出： 1/3/2005 - %V,%G,%Y = 1,2005,2005
echo "1/3/2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2005")) . "\n";

?>

Example #3 %e 修改器跨平台兼容的例子

<?php

// Jan 1: results in: '%e%1%' (%%, e, %%, %e, %%)
$format = '%%e%%%e%%';

// Check for Windows to find and replace the %e
// modifier correctly
if (strtoupper(substr(PHP_OS, 0, 3)) == 'WIN') {
    $format = preg_replace('#(?<!%)((?:%%)*)%e#', '</refsect1>%#d', $format);
}

echo strftime($format);
?>

Example #4 显示所有已知和未知的格式

<?php
// Describe the formats.
$strftimeFormats = array(
    'A' => 'A full textual representation of the day',
    'B' => 'Full month name, based on the locale',
    'C' => 'Two digit representation of the century (year divided by 100, truncated to an integer)',
    'D' => 'Same as "%m/%d/%y"',
    'E' => '',
    'F' => 'Same as "%Y-%m-%d"',
    'G' => 'The full four-digit version of %g',
    'H' => 'Two digit representation of the hour in 24-hour format',
    'I' => 'Two digit representation of the hour in 12-hour format',
    'J' => '',
    'K' => '',
    'L' => '',
    'M' => 'Two digit representation of the minute',
    'N' => '',
    'O' => '',
    'P' => 'lower-case "am" or "pm" based on the given time',
    'Q' => '',
    'R' => 'Same as "%H:%M"',
    'S' => 'Two digit representation of the second',
    'T' => 'Same as "%H:%M:%S"',
    'U' => 'Week number of the given year, starting with the first Sunday as the first week',
    'V' => 'ISO-8601:1988 week number of the given year, starting with the first week of the year with at least 4 weekdays, with Monday being the start of the week',
    'W' => 'A numeric representation of the week of the year, starting with the first Monday as the first week',
    'X' => 'Preferred time representation based on locale, without the date',
    'Y' => 'Four digit representation for the year',
    'Z' => 'The time zone offset/abbreviation option NOT given by %z (depends on operating system)',
    'a' => 'An abbreviated textual representation of the day',
    'b' => 'Abbreviated month name, based on the locale',
    'c' => 'Preferred date and time stamp based on local',
    'd' => 'Two-digit day of the month (with leading zeros)',
    'e' => 'Day of the month, with a space preceding single digits',
    'f' => '',
    'g' => 'Two digit representation of the year going by ISO-8601:1988 standards (see %V)',
    'h' => 'Abbreviated month name, based on the locale (an alias of %b)',
    'i' => '',
    'j' => 'Day of the year, 3 digits with leading zeros',
    'k' => '',
    'l' => 'Hour in 12-hour format, with a space preceeding single digits',
    'm' => 'Two digit representation of the month',
    'n' => 'A newline character ("\n")',
    'o' => '',
    'p' => 'UPPER-CASE "AM" or "PM" based on the given time',
    'q' => '',
    'r' => 'Same as "%I:%M:%S %p"',
    's' => 'Unix Epoch Time timestamp',
    't' => 'A Tab character ("\t")',
    'u' => 'ISO-8601 numeric representation of the day of the week',
    'v' => '',
    'w' => 'Numeric representation of the day of the week',
    'x' => 'Preferred date representation based on locale, without the time',
    'y' => 'Two digit representation of the year',
    'z' => 'Either the time zone offset from UTC or the abbreviation (depends on operating system)',
    '%' => 'A literal percentage character ("%")',
);

// Results.
$strftimeValues = array();

// Evaluate the formats whilst suppressing any errors.
foreach($strftimeFormats as $format => $description){
    if (False !== ($value = @strftime("%{$format}"))){
        $strftimeValues[$format] = $value;
    }
}

// Find the longest value.
$maxValueLength = 2 + max(array_map('strlen', $strftimeValues));

// Report known formats.
foreach($strftimeValues as $format => $value){
    echo "Known format   : '{$format}' = ", str_pad("'{$value}'", $maxValueLength), " ( {$strftimeFormats[$format]} )\n";
}

// Report unknown formats.
foreach(array_diff_key($strftimeFormats, $strftimeValues) as $format => $description){
    echo "Unknown format : '{$format}'   ", str_pad(' ', $maxValueLength), ($description ? " ( {$description} )" : ''), "\n";
}
?>

以上例程的输出类似于：

Known format   : 'A' = 'Friday'            ( A full textual representation of the day )
Known format   : 'B' = 'December'          ( Full month name, based on the locale )
Known format   : 'H' = '11'                ( Two digit representation of the hour in 24-hour format )
Known format   : 'I' = '11'                ( Two digit representation of the hour in 12-hour format )
Known format   : 'M' = '24'                ( Two digit representation of the minute )
Known format   : 'S' = '44'                ( Two digit representation of the second )
Known format   : 'U' = '48'                ( Week number of the given year, starting with the first Sunday as the first week )
Known format   : 'W' = '48'                ( A numeric representation of the week of the year, starting with the first Monday as the first week )
Known format   : 'X' = '11:24:44'          ( Preferred time representation based on locale, without the date )
Known format   : 'Y' = '2010'              ( Four digit representation for the year )
Known format   : 'Z' = 'GMT Standard Time' ( The time zone offset/abbreviation option NOT given by %z (depends on operating system) )
Known format   : 'a' = 'Fri'               ( An abbreviated textual representation of the day )
Known format   : 'b' = 'Dec'               ( Abbreviated month name, based on the locale )
Known format   : 'c' = '12/03/10 11:24:44' ( Preferred date and time stamp based on local )
Known format   : 'd' = '03'                ( Two-digit day of the month (with leading zeros) )
Known format   : 'j' = '337'               ( Day of the year, 3 digits with leading zeros )
Known format   : 'm' = '12'                ( Two digit representation of the month )
Known format   : 'p' = 'AM'                ( UPPER-CASE "AM" or "PM" based on the given time )
Known format   : 'w' = '5'                 ( Numeric representation of the day of the week )
Known format   : 'x' = '12/03/10'          ( Preferred date representation based on locale, without the time )
Known format   : 'y' = '10'                ( Two digit representation of the year )
Known format   : 'z' = 'GMT Standard Time' ( Either the time zone offset from UTC or the abbreviation (depends on operating system) )
Known format   : '%' = '%'                 ( A literal percentage character ("%") )
Unknown format : 'C'                       ( Two digit representation of the century (year divided by 100, truncated to an integer) )
Unknown format : 'D'                       ( Same as "%m/%d/%y" )
Unknown format : 'E'
Unknown format : 'F'                       ( Same as "%Y-%m-%d" )
Unknown format : 'G'                       ( The full four-digit version of %g )
Unknown format : 'J'
Unknown format : 'K'
Unknown format : 'L'
Unknown format : 'N'
Unknown format : 'O'
Unknown format : 'P'                       ( lower-case "am" or "pm" based on the given time )
Unknown format : 'Q'
Unknown format : 'R'                       ( Same as "%H:%M" )
Unknown format : 'T'                       ( Same as "%H:%M:%S" )
Unknown format : 'V'                       ( ISO-8601:1988 week number of the given year, starting with the first week of the year with at least 4 weekdays, with Monday being the start of the week )
Unknown format : 'e'                       ( Day of the month, with a space preceding single digits )
Unknown format : 'f'
Unknown format : 'g'                       ( Two digit representation of the year going by ISO-8601:1988 standards (see %V) )
Unknown format : 'h'                       ( Abbreviated month name, based on the locale (an alias of %b) )
Unknown format : 'i'
Unknown format : 'k'
Unknown format : 'l'                       ( Hour in 12-hour format, with a space preceeding single digits )
Unknown format : 'n'                       ( A newline character ("\n") )
Unknown format : 'o'
Unknown format : 'q'
Unknown format : 'r'                       ( Same as "%I:%M:%S %p" )
Unknown format : 's'                       ( Unix Epoch Time timestamp )
Unknown format : 't'                       ( A Tab character ("\t") )
Unknown format : 'u'                       ( ISO-8601 numeric representation of the day of the week )
Unknown format : 'v'

注释

Note: %G 和 %V，如果数字编号系统未能充分理解，基于 ISO 8601:1988 的星期数可能得出未预期的结果。见上面的 %V 和以下的例子。

参见

  • » 在线 strftime() 格式设计工具
  • setlocale() - 设置地区信息
  • mktime() - 取得一个日期的 Unix 时间戳
  • strptime() - 解析由 strftime 生成的日期／时间
  • gmstrftime() - 根据区域设置格式化 GMT/UTC 时间／日期
  • » Open Group specification of strftime()


解析由 strftime 生成的日期／时间

  • ? strftime
  • strtotime ?
  • PHP Manual
  • Date/Time 函数
  • 解析由 strftime 生成的日期／时间

strptime

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

strptime — 解析由 strftime() 生成的日期／时间

说明

strptime ( string $date , string $format ) : array

strptime() 返回一个将 date 解析后的数组，如果出错返回 false。

月份和星期几的名字以及其它与语种有关的字符串对应于 setlocale()设定的当前区域（LC_TIME）。

参数

date（string）

被解析的字符串（例如从 strftime() 返回的）

format（string）

date 所使用的格式（例如同 strftime() 中所使用的相同）。

更多有关格式选项的信息见 strftime() 页面。

返回值

返回一个数组 或者在失败时返回 false

数组中包含以下单元
键名 | 说明
tm_sec | 当前分钟内的秒数（0-61）
tm_min | 当前小时内的分钟数（0-59）
tm_hour | 午夜起的小时数（0-23）
tm_mday | 月份中的第几天（1-31）
tm_mon | 自一月起过了几个月（0-11）
tm_year | 自 1900 年起过了几年
tm_wday | 自星期天起过了几天（0-6）
tm_yday | 本年自一月一日起过了多少天（0-365）
unparsed | date 中未能通过指定的 format 识别的部分

范例

Example #1 strptime() 例子

<?php
$format = '%d/%m/%Y %H:%M:%S';
$strf = strftime($format);

echo "$strf\n";

print_r(strptime($strf, $format));
?>

以上例程的输出类似于：

03/10/2004 15:54:19

Array
(
    [tm_sec] => 19
    [tm_min] => 54
    [tm_hour] => 15
    [tm_mday] => 3
    [tm_mon] => 9
    [tm_year] => 104
    [tm_wday] => 0
    [tm_yday] => 276
    [unparsed] =>
)

注释

Note: 此函数未在 Windows 平台下实现。

Note:

Internally, this function calls the strptime() function provided by the system's C library. This function can exhibit noticeably different behaviour across different operating systems. The use of date_parse_from_format(), which does not suffer from these issues, is recommended on PHP 5.3.0 and later.

Note:

"tm_sec" includes any leap seconds (currently upto 2 a year). For more information on leap seconds, see the » Wikipedia article on leap seconds.

Note:

Prior to PHP 5.2.0, this function could return undefined behaviour. Notably, the "tm_sec", "tm_min" and "tm_hour" entries would return undefined values.

参见

  • checkdate() - 验证一个格里高里日期
  • strftime() - 根据区域设置格式化本地时间／日期
  • date_parse_from_format() - Get info about given date formatted according to the specified format
  • DateTime::createFromFormat() - 根据给定的格式解析日期时间字符串


将任何字符串的日期时间描述解析为 Unix 时间戳

  • ? strptime
  • time ?
  • PHP Manual
  • Date/Time 函数
  • 将任何字符串的日期时间描述解析为 Unix 时间戳

strtotime

(PHP 4, PHP 5, PHP 7, PHP 8)

strtotime — 将任何字符串的日期时间描述解析为 Unix 时间戳

说明

strtotime ( string $datetime , int $now = time() ) : int

本函数预期接受一个包含美国英语日期格式的字符串并尝试将其解析为 Unix 时间戳（自 January 1 1970 00:00:00 UTC 起的秒数），其值相对于 now 参数给出的时间，如果没有提供 now 参数则用系统当前时间。

Warning

本函数返回的 Unix 时间戳不包含时区信息，为了实现对 "日期/时间" 进行计算，推荐使用功能更强大的 DateTimeImmutable 类。

本函数将使用 TZ 环境变量（如果有的话）来计算时间戳。自 PHP 5.1.0 起有更容易的方法来定义时区用于所有的日期／时间函数。此过程在 date_default_timezone_get() 函数页面中有说明。

参数

datetime

日期/时间字符串。正确格式的说明详见 日期与时间格式。

now

用来计算返回值的时间戳。

返回值

成功则返回时间戳，否则返回 false。在 PHP 5.1.0 之前本函数在失败时返回 -1。

错误／异常

在每 次调用日期/时间函数时，如果时区无效则会引发 E_NOTICE 错误，如果使用系统设定值或 TZ 环境变量，则会引发 E_STRICT 或 E_WARNING 消息。参见 date_default_timezone_set()。

范例

Example #1 strtotime() 例子

<?php
echo strtotime("now"), "\n";
echo strtotime("10 September 2000"), "\n";
echo strtotime("+1 day"), "\n";
echo strtotime("+1 week"), "\n";
echo strtotime("+1 week 2 days 4 hours 2 seconds"), "\n";
echo strtotime("next Thursday"), "\n";
echo strtotime("last Monday"), "\n";
?>

Example #2 失败检查

<?php
$str = 'Not Good';

// PHP 5.1.0 之前的版本中和应该改成和 -1 进行比较
if (($timestamp = strtotime($str)) === false) {
    echo "The string ($str) is bogus";
} else {
    echo "$str == " . date('l dS of F Y h:i:s A', $timestamp);
}
?>

注释

Note:

如果给定的年份是两位数字的格式，则其值 0-69 表示 2000-2069，70-100 表示 1970-2000。 See the notes below for possible differences on 32bit systems (possible dates might end on 2038-01-19 03:14:07).

Note:

有效的时间戳通常从 Fri, 13 Dec 1901 20:45:54 UTC 到 Tue, 19 Jan 2038 03:14:07 UTC（对应于 32 位有符号整数的最小值和最大值）。

PHP 5.1.0 之前，不是所有的平台都支持负的时间戳，那么日记范围就被限制为不能早于 Unix 纪元。这意味着在 1970 年 1 月 1 日之前的日期将不能用在 Windows，一些 Linux 版本，以及几个其它的操作系统中。

在 64 位的 PHP 版本中，时间戳的有效范围实际上是无限的，因为 64 位可以覆盖最多 2930 亿年的范围。

Note:

不同的分隔符，比如 m/d/y 或 d-m-y 会影响到解析结果：若以反斜线 (/) 为分隔，将会做为美洲日期 m/d/y 来解析；而当分隔符为短横线 (-) 或点 (.) 时，则将做为欧洲日期 d-m-y 格式来解析。当年份只有两位数字，且分隔符为短横线 (-时，日期字符串将被解析为 y-m-d 格式。

为了避免潜在的歧义，最好使用 ISO 8601 标准格式 (YYYY-MM-DD) 或 DateTime::createFromFormat() 来表达。

Note:

不建议使用此函数对日期进行数学运算。在 PHP 5.3 及以后版本中，推荐使用
DateTime::add() 和
DateTime::sub() 函数，PHP 5.2 中可以使用
DateTime::modify()。

参见

  • 日期时间格式
  • DateTime::createFromFormat() - 根据给定的格式解析日期时间字符串
  • checkdate() - 验证一个格里高里日期
  • strptime() - 解析由 strftime 生成的日期／时间


返回当前的 Unix 时间戳

  • ? strtotime
  • timezone_abbreviations_list ?
  • PHP Manual
  • Date/Time 函数
  • 返回当前的 Unix 时间戳

time

(PHP 4, PHP 5, PHP 7, PHP 8)

time — 返回当前的 Unix 时间戳

说明

time ( ) : int

返回自从 Unix 纪元（格林威治时间 1970 年 1 月 1 日 00:00:00）到当前时间的秒数。

范例

Example #1 time() 例子

<?php
$nextWeek = time() + (7 * 24 * 60 * 60);
                   // 7 days; 24 hours; 60 mins; 60 secs
echo 'Now:       '. date('Y-m-d') ."\n";
echo 'Next Week: '. date('Y-m-d', $nextWeek) ."\n";
// or using strtotime():
echo 'Next Week: '. date('Y-m-d', strtotime('+1 week')) ."\n";
?>

以上例程的输出类似于：

Now:       2005-03-30
Next Week: 2005-04-06
Next Week: 2005-04-06

注释

Tip

自 PHP 5.1 起在 $_SERVER['REQUEST_TIME'] 中保存了发起该请求时刻的时间戳。

参见

  • date() - 格式化一个本地时间／日期
  • microtime() - 返回当前 Unix 时间戳和微秒数


别名 DateTimeZone::listAbbreviations

  • ? time
  • timezone_identifiers_list ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeZone::listAbbreviations

timezone_abbreviations_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_abbreviations_list — 别名 DateTimeZone::listAbbreviations()

说明

此函数是该函数的别名： DateTimeZone::listAbbreviations()


别名 DateTimeZone::listIdentifiers

  • ? timezone_abbreviations_list
  • timezone_location_get ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeZone::listIdentifiers

timezone_identifiers_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_identifiers_list — 别名 DateTimeZone::listIdentifiers()

说明

此函数是该函数的别名： DateTimeZone::listIdentifiers()


别名 DateTimeZone::getLocation

  • ? timezone_identifiers_list
  • timezone_name_from_abbr ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeZone::getLocation

timezone_location_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

timezone_location_get — 别名 DateTimeZone::getLocation()

说明

此函数是该函数的别名： DateTimeZone::getLocation()


Returns the timezone name from abbreviation

  • ? timezone_location_get
  • timezone_name_get ?
  • PHP Manual
  • Date/Time 函数
  • Returns the timezone name from abbreviation

timezone_name_from_abbr

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

timezone_name_from_abbr — Returns the timezone name from abbreviation

说明

timezone_name_from_abbr ( string $abbr , int $utcOffset = -1 , int $isDST = -1 ) : string|false

参数

abbr

Time zone abbreviation.

utcOffset

Offset from GMT in seconds. Defaults to -1 which means that first found time zone corresponding to abbr is returned. Otherwise exact offset is searched and only if not found then the first time zone with any offset is returned.

isDST

Daylight saving time indicator. Defaults to -1, which means that whether the time zone has daylight saving or not is not taken into consideration when searching. If this is set to 1, then the utcOffset is assumed to be an offset with daylight saving in effect; if 0, then utcOffset is assumed to be an offset without daylight saving in effect. If abbr doesn't exist then the time zone is searched solely by the utcOffset and isDST.

返回值

Returns time zone name on success 或者在失败时返回 false.

范例

Example #1 A timezone_name_from_abbr() example

<?php
echo timezone_name_from_abbr("CET") . "\n";
echo timezone_name_from_abbr("", 3600, 0) . "\n";
?>

以上例程的输出类似于：

Europe/Berlin
Europe/Paris

参见

  • timezone_abbreviations_list() - 别名 DateTimeZone::listAbbreviations


别名 DateTimeZone::getName

  • ? timezone_name_from_abbr
  • timezone_offset_get ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeZone::getName

timezone_name_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_name_get — 别名 DateTimeZone::getName()

说明

此函数是该函数的别名： DateTimeZone::getName()


别名 DateTimeZone::getOffset

  • ? timezone_name_get
  • timezone_open ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeZone::getOffset

timezone_offset_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_offset_get — 别名 DateTimeZone::getOffset()

说明

此函数是该函数的别名： DateTimeZone::getOffset()


别名 DateTimeZone::__construct

  • ? timezone_offset_get
  • timezone_transitions_get ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeZone::__construct

timezone_open

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_open — 别名 DateTimeZone::__construct()

说明

此函数是该函数的别名： DateTimeZone::__construct()


别名 DateTimeZone::getTransitions

  • ? timezone_open
  • timezone_version_get ?
  • PHP Manual
  • Date/Time 函数
  • 别名 DateTimeZone::getTransitions

timezone_transitions_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

timezone_transitions_get — 别名 DateTimeZone::getTransitions()

说明

此函数是该函数的别名： DateTimeZone::getTransitions()


获取 timezonedb 的版本

  • ? timezone_transitions_get
  • Supported Date and Time Formats ?
  • PHP Manual
  • Date/Time 函数
  • 获取 timezonedb 的版本

timezone_version_get

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

timezone_version_get — 获取 timezonedb 的版本

说明

timezone_version_get ( ) : string

返回当前 timezonedb 的版本。

返回值

返回一个 string。

范例

Example #1 获取 timezonedb 版本

<?php
echo timezone_version_get();
?>

以上例程的输出类似于：

2009.7

参见

  • 支持的时区列表


Supported Date and Time Formats

Table of Contents

  • Time Formats
  • Date Formats
  • Compound Formats
  • Relative Formats

This section describes all the different formats that the DateTimeImmutable, DateTime, date_create(), date_create_immutable(), and strtotime() parser understands. The formats are grouped by section. In most cases formats from different sections, separated by whitespace, comma or dot, can be used in the same date/time string. For each of the supported formats, one or more examples are given, as well as a description for the format. Characters in single quotes in the formats are case-insensitive ('t' could be t or T), characters in double quotes are case-sensitive ("T" is only T).


Time Formats

 This page describes the different date/time formats that the
 DateTimeImmutable, DateTime,
date_create(),
date_create_immutable(), and
strtotime() parser understands.

Used Symbols
Description | Formats | Examples
frac | . [0-9]+ | ".21342", ".85"
hh | "0"?[1-9] | "1"[0-2] | "04", "7", "12"
HH | [01][0-9] | "2"[0-4] | "04", "07", "19"
meridian | [AaPp] .? [Mm] .? [\0\t ] | "A.m.", "pM", "am."
MM | [0-5][0-9] | "00", "12", "59"
II | [0-5][0-9] | "00", "12", "59"
space | [ \t] |
tz | "("? [A-Za-z]{1,6} ")"? | [A-Z][a-z]+([_/][A-Z][a-z]+)+ | "CEST", "Europe/Amsterdam", "America/Indiana/Knox"
tzcorrection | "GMT"? [+-] hh ":"? MM? | "+0400", "GMT-07:00", "-07:00"
12 Hour Notation
Description | Format | Examples
Hour only, with meridian | hh space? meridian | "4 am", "5PM"
Hour and minutes, with meridian | hh [.:] MM space? meridian | "4:08 am", "7:19P.M."
Hour, minutes and seconds, with meridian | hh [.:] MM [.:] II space? meridian | "4:08:37 am", "7:19:19P.M."
MS SQL (Hour, minutes, seconds and fraction with meridian) | hh ":" MM ":" II [.:] [0-9]+ meridian | "4:08:39:12313am"
24 Hour Notation
Description | Format | Examples
Hour and minutes | 't'? HH [.:] MM | "04:08", "19.19", "T23:43"
Hour and minutes, no colon | 't'? HH MM | "0408", "t1919", "T2343"
Hour, minutes and seconds | 't'? HH [.:] MM [.:] II | "04.08.37", "t19:19:19"
Hour, minutes and seconds, no colon | 't'? HH MM II | "040837", "T191919"
Hour, minutes, seconds and timezone | 't'? HH [.:] MM [.:] II space? ( tzcorrection | tz ) | "040837CEST", "T191919-0700"
Hour, minutes, seconds and fraction | 't'? HH [.:] MM [.:] II frac | "04.08.37.81412", "19:19:19.532453"
Time zone information | tz | tzcorrection | "CEST", "Europe/Amsterdam", "+0430", "GMT-06:00"


Date Formats

This page describes the different date formats that the strtotime(), DateTime and date_create() parser understands.

Used Symbols
Description | Format | Examples
daysuf | "st" | "nd" | "rd" | "th" |
dd | ([0-2]?[0-9] | "3"[01]) daysuf? | "7th", "22nd", "31"
DD | "0" [0-9] | [1-2][0-9] | "3" [01] | "07", "31"
m | 'january' | 'february' | 'march' | 'april' | 'may' | 'june' | 'july' | 'august' | 'september' | 'october' | 'november' | 'december' | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' | "I" | "II" | "III" | "IV" | "V" | "VI" | "VII" | "VIII" | "IX" | "X" | "XI" | "XII" |
M | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' |
mm | "0"? [0-9] | "1"[0-2] | "0", "04", "7", "12"
MM | "0" [0-9] | "1"[0-2] | "00", "04", "07", "12"
y | [0-9]{1,4} | "00", "78", "08", "8", "2008"
yy | [0-9]{2} | "00", "08", "78"
YY | [0-9]{4} | "2000", "2008", "1978"
Localized Notations
Description | Format | Examples
American month and day | mm "/" dd | "5/12", "10/27"
American month, day and year | mm "/" dd "/" y | "12/22/78", "1/17/2006", "1/17/6"
Four digit year, month and day with slashes | YY "/" mm "/" dd | "2008/6/30", "1978/12/22"
Four digit year and month (GNU) | YY "-" mm | "2008-6", "2008-06", "1978-12"
Year, month and day with dashes | y "-" mm "-" dd | "2008-6-30", "78-12-22", "8-6-21"
Day, month and four digit year, with dots, tabs or dashes | dd [.\t-] mm [.-] YY | "30-6-2008", "22.12.1978"
Day, month and two digit year, with dots or tabs | dd [.\t] mm "." yy | "30.6.08", "22\t12.78"
Day, textual month and year | dd ([ \t.-])* m ([ \t.-])* y | "30-June 2008", "22DEC78", "14 III 1879"
Textual month and four digit year (Day reset to 1) | m ([ \t.-])* YY | "June 2008", "DEC1978", "March 1879"
Four digit year and textual month (Day reset to 1) | YY ([ \t.-])* m | "2008 June", "1978-XII", "1879.MArCH"
Textual month, day and year | m ([ .\t-])* dd [,.stndrh\t ]+ y | "July 1st, 2008", "April 17, 1790", "May.9,78"
Textual month and day | m ([ .\t-])* dd [,.stndrh\t ]* | "July 1st,", "Apr 17", "May.9"
Day and textual month | d ([ .\t-])* m | "1 July", "17 Apr", "9.May"
Month abbreviation, day and year | M "-" DD "-" y | "May-09-78", "Apr-17-1790"
Year, month abbreviation and day | y "-" M "-" DD | "78-Dec-22", "1814-MAY-17"
Year (and just the year) | YY | "1978", "2008"
Textual month (and just the month) | m | "March", "jun", "DEC"
ISO8601 Notations
Description | Format | Examples
Eight digit year, month and day | YY MM DD | "15810726", "19780417", "18140517"
Four digit year, month and day with slashes | YY "/" MM "/" DD | "2008/06/30", "1978/12/22"
Two digit year, month and day with dashes | yy "-" MM "-" DD | "08-06-30", "78-12-22"
Four digit year with optional sign, month and day | [+-]? YY "-" MM "-" DD | "-0002-07-26", "+1978-04-17", "1814-05-17"

Note:

For the y and yy formats, years below 100 are handled in a special way when the y or yy symbol is used. If the year falls in the range 0 (inclusive) to 69 (inclusive), 2000 is added. If the year falls in the range 70 (inclusive) to 99 (inclusive) then 1900 is added. This means that "00-01-01" is interpreted as "2000-01-01".

Note:

The "Day, month and two digit year, with dots or tabs" format (dd [.\t] mm "." yy) only works for the year values 61 (inclusive) to 99 (inclusive) - outside those years the time format "HH [.:] MM [.:] SS" has precedence.

Note:

The "Year (and just the year)" format only works if a time string has already been found -- otherwise this format is recognised as HH MM.

Caution

It is possible to over- and underflow the dd and DD format. Day 0 means the last day of previous month, whereas overflows count into the next month. This makes "2008-08-00" equivalent to "2008-07-31" and "2008-06-31" equivalent to "2008-07-01" (June only has 30 days).

Note that the day range is restricted to 0-31 as indicated by the regular expression above. Thus "2008-06-32" is not a valid date string, for instance.

It is also possible to underflow the mm and MM formats with the value 0. A month value of 0 means December of the previous year. As example "2008-00-22" is equivalent to "2007-12-22".

If you combine the previous two facts and underflow both the day and the month, the following happens: "2008-00-00" first gets converted to "2007-12-00" which then gets converted to "2007-11-30". This also happens with the string "0000-00-00", which gets transformed into "-0001-11-30" (the year -1 in the ISO 8601 calendar, which is 2 BC in the proleptic Gregorian calendar).


Compound Formats

This page describes the different compound date/time formats that the strtotime(), DateTime and date_create() parser understands.

Used Symbols
Description | Formats | Examples
DD | "0" [0-9] | [1-2][0-9] | "3" [01] | "02", "12", "31"
doy | "00"[1-9] | "0"[1-9][0-9] | [1-2][0-9][0-9] | "3"[0-5][0-9] | "36"[0-6] | "001", "012", "180", "350", "366"
frac | . [0-9]+ | ".21342", ".85"
hh | "0"?[1-9] | "1"[0-2] | "04", "7", "12"
HH | [01][0-9] | "2"[0-4] | "04", "07", "19"
meridian | [AaPp] .? [Mm] .? [\0\t ] | "A.m.", "pM", "am."
ii | [0-5]?[0-9] | "04", "8", "59"
II | [0-5][0-9] | "04", "08", "59"
M | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' |
MM | [0-1][0-9] | "00", "12"
space | [ \t] |
ss | ([0-5]?[0-9])|60 | "04", "8", "59", "60" (leap second)
SS | [0-5][0-9] | "04", "08", "59"
W | "0"[1-9] | [1-4][0-9] | "5"[0-3] | "05", "17", "53"
tzcorrection | "GMT"? [+-] hh ":"? II? | "+0400", "GMT-07:00", "-07:00"
YY | [0-9]{4} | "2000", "2008", "1978"
Localized Notations
Description | Format | Examples
Common Log Format | dd "/" M "/" YY : HH ":" II ":" SS space tzcorrection | "10/Oct/2000:13:55:36 -0700"
EXIF | YY ":" MM ":" DD " " HH ":" II ":" SS | "2008:08:07 18:11:31"
ISO year with ISO week | YY "-"? "W" W | "2008W27", "2008-W28"
ISO year with ISO week and day | YY "-"? "W" W "-"? [0-7] | "2008W273", "2008-W28-3"
MySQL | YY "-" MM "-" DD " " HH ":" II ":" SS | "2008-08-07 18:11:31"
PostgreSQL: Year with day-of-year | YY "."? doy | "2008.197", "2008197"
SOAP | YY "-" MM "-" DD "T" HH ":" II ":" SS frac tzcorrection? | "2008-07-01T22:35:17.02", "2008-07-01T22:35:17.03+08:00"
Unix Timestamp | "@" "-"? [0-9]+ | "@1215282385"
XMLRPC | YY MM DD "T" hh ":" II ":" SS | "20080701T22:38:07", "20080701T9:38:07"
XMLRPC (Compact) | YY MM DD 't' hh II SS | "20080701t223807", "20080701T093807"
WDDX | YY "-" mm "-" dd "T" hh ":" ii ":" ss | "2008-7-1T9:3:37"

Note:

The "W" in the "ISO year with ISO week" and "ISO year with ISO week and day" formats is case-sensitive, you can only use the upper case "W".

The "T" in the SOAP, XMRPC and WDDX formats is case-sensitive, you can only use the upper case "T".

The "Unix Timestamp" format sets the timezone to UTC.


Relative Formats

This page describes the different relative date/time formats that the strtotime(), DateTime and date_create() parser understands.

Used Symbols
Description | Format
dayname | 'sunday' | 'monday' | 'tuesday' | 'wednesday' | 'thursday' | 'friday' | 'saturday' | 'sun' | 'mon' | 'tue' | 'wed' | 'thu' | 'fri' | 'sat'
daytext | 'weekday' | 'weekdays'
number | [+-]?[0-9]+
ordinal | 'first' | 'second' | 'third' | 'fourth' | 'fifth' | 'sixth' | 'seventh' | 'eighth' | 'ninth' | 'tenth' | 'eleventh' | 'twelfth' | 'next' | 'last' | 'previous' | 'this'
reltext | 'next' | 'last' | 'previous' | 'this'
space | [ \t]+
unit | (('sec' | 'second' | 'min' | 'minute' | 'hour' | 'day' | 'fortnight' | 'forthnight' | 'month' | 'year') 's'?) | 'weeks' | daytext
Day-based Notations
Format | Description | Examples
'yesterday' | Midnight of yesterday | "yesterday 14:00"
'midnight' | The time is set to 00:00:00 |
'today' | The time is set to 00:00:00 |
'now' | Now - this is simply ignored |
'noon' | The time is set to 12:00:00 | "yesterday noon"
'tomorrow' | Midnight of tomorrow |
'back of' hour | 15 minutes past the specified hour | "back of 7pm", "back of 15"
'front of' hour | 15 minutes before the specified hour | "front of 5am", "front of 23"
'first day of' | Sets the day of the first of the current month. This phrase is best used together with a month name following it. | "first day of January 2008"
'last day of' | Sets the day to the last day of the current month. This phrase is best used together with a month name following it. | "last day of next month"
ordinal space dayname space 'of' | Calculates the x-th week day of the current month. | "first sat of July 2008"
'last' space dayname space 'of' | Calculates the last week day of the current month. | "last sat of July 2008"
number space? (unit | 'week') | Handles relative time items where the value is a number. | "+5 weeks", "12 day", "-7 weekdays"
ordinal space unit | Handles relative time items where the value is text. | "fifth day", "second month"
'ago' | Negates all the values of previously found relative time items. | "2 days ago", "8 days ago 14:00", "2 months 5 days ago", "2 months ago 5 days", "2 days ago"
dayname | Moves to the next day of this name. | "Monday"
reltext space 'week' | Handles the special format "weekday + last/this/next week". | "Monday next week"

Note:

Relative statements are always processed after non-relative statements. This makes "+1 week july 2008" and "july 2008 +1 week" equivalent.

Exceptions to this rule are: "yesterday", "midnight", "today", "noon" and "tomorrow". Note that "tomorrow 11:00" and "11:00 tomorrow" are different. Considering today's date of "July 23rd, 2008" the first one produces "2008-07-24 11:00" where as the second one produces "2008-07-24 00:00". The reason for this is that those five statements directly influence the current time.

Note:

Observe the following remarks when the current day-of-week is the same as the day-of-week used in the date/time string. The current day-of-week could have been (re-)calculated by non-relative parts of the date/time string however.

  1. "dayname" does not advance to another day. (Example: "Wed July 23rd, 2008" means "2008-07-23").
  2. "number dayname" does not advance to another day. (Example: "1 wednesday july 23rd, 2008" means "2008-07-23").
  3. "number week dayname" will first add the number of weeks, but does not advance to another day. In this case "number week" and "dayname" are two distinct blocks. (Example: "+1 week wednesday july 23rd, 2008" means "2008-07-30").
  4. "ordinal dayname" does advance to another day. (Example "first wednesday july 23rd, 2008" means "2008-07-30").
  5. "number week ordinal dayname" will first add the number of weeks, and then advances to another day. In this case "number week" and "ordinal dayname" are two distinct blocks. (Example: "+1 week first wednesday july 23rd, 2008" means "2008-08-06").
  6. "ordinal dayname 'of' " does not advance to another day. (Example: "first wednesday of july 23rd, 2008" means "2008-07-02" because the specific phrase with 'of' resets the day-of-month to '1' and the '23rd' is ignored here).

Also observe that the "of" in "ordinal space dayname space 'of' " and "'last' space dayname space 'of' " does something special.

  1. It sets the day-of-month to 1.
  2. "ordinal dayname 'of' " does not advance to another day. (Example: "first tuesday of july 2008" means "2008-07-01").
  3. "ordinal dayname " does advance to another day. (Example: "first tuesday july 2008" means "2008-07-08", see also point 4 in the list above).
  4. "'last' dayname 'of' " takes the last dayname of the current month. (Example: "last wed of july 2008" means "2008-07-30")
  5. "'last' dayname" takes the last dayname from the current day. (Example: "last wed july 2008" means "2008-06-25"; "july 2008" first sets the current date to "2008-07-01" and then "last wed" moves to the previous Wednesday which is "2008-06-25").

Note:

Relative month values are calculated based on the length of months that they pass through. An example would be "+2 month 2011-11-30", which would produce "2012-01-30". This is due to November being 30 days in length, and December being 31 days in length, producing a total of 61 days.

Note:

number is an integer number; if a decimal number is given, the dot (or comma) is likely interpreted as delimiter. For instance, '+1.5 hours' is parsed like '+1 5 hours', not as '+1 hour +30 minutes'.

更新日志

版本 | 说明
5.6.23, 7.0.8 | Weeks always start on monday. Formerly, sunday would also be considered to start a week.
5.3.3 | "first day" and "last day" changed to behave has "+1 day" and "-1 day", respectively. Previously, the behaviour was as "first day of" and "last day of".


所支持的时区列表

Table of Contents

  • 非洲
  • 美洲
  • 南极洲
  • 北极
  • 亚洲
  • 大西洋
  • 澳洲
  • 欧洲
  • 印度
  • 太平洋地区
  • 其他

在这你可找到 PHP 所支持的所有时区的列表，可用于诸如 date_default_timezone_set() 等函数。

Caution

这里没有列出的时区是未定义的。

Note: 最新版的时区数据库可从 PECL 的 » timezonedb 进行安装。

Note: 基于时区数据库版本的列表 2021.1.


非洲

非洲
Africa/Abidjan | Africa/Accra | Africa/Addis_Ababa | Africa/Algiers
Africa/Asmara | Africa/Bamako | Africa/Bangui | Africa/Banjul
Africa/Bissau | Africa/Blantyre | Africa/Brazzaville | Africa/Bujumbura
Africa/Cairo | Africa/Casablanca | Africa/Ceuta | Africa/Conakry
Africa/Dakar | Africa/Dar_es_Salaam | Africa/Djibouti | Africa/Douala
Africa/El_Aaiun | Africa/Freetown | Africa/Gaborone | Africa/Harare
Africa/Johannesburg | Africa/Juba | Africa/Kampala | Africa/Khartoum
Africa/Kigali | Africa/Kinshasa | Africa/Lagos | Africa/Libreville
Africa/Lome | Africa/Luanda | Africa/Lubumbashi | Africa/Lusaka
Africa/Malabo | Africa/Maputo | Africa/Maseru | Africa/Mbabane
Africa/Mogadishu | Africa/Monrovia | Africa/Nairobi | Africa/Ndjamena
Africa/Niamey | Africa/Nouakchott | Africa/Ouagadougou | Africa/Porto-Novo
Africa/Sao_Tome | Africa/Tripoli | Africa/Tunis | Africa/Windhoek


美洲

美洲
America/Adak | America/Anchorage | America/Anguilla | America/Antigua
America/Araguaina | America/Argentina/Buenos_Aires | America/Argentina/Catamarca | America/Argentina/Cordoba
America/Argentina/Jujuy | America/Argentina/La_Rioja | America/Argentina/Mendoza | America/Argentina/Rio_Gallegos
America/Argentina/Salta | America/Argentina/San_Juan | America/Argentina/San_Luis | America/Argentina/Tucuman
America/Argentina/Ushuaia | America/Aruba | America/Asuncion | America/Atikokan
America/Bahia | America/Bahia_Banderas | America/Barbados | America/Belem
America/Belize | America/Blanc-Sablon | America/Boa_Vista | America/Bogota
America/Boise | America/Cambridge_Bay | America/Campo_Grande | America/Cancun
America/Caracas | America/Cayenne | America/Cayman | America/Chicago
America/Chihuahua | America/Costa_Rica | America/Creston | America/Cuiaba
America/Curacao | America/Danmarkshavn | America/Dawson | America/Dawson_Creek
America/Denver | America/Detroit | America/Dominica | America/Edmonton
America/Eirunepe | America/El_Salvador | America/Fort_Nelson | America/Fortaleza
America/Glace_Bay | America/Goose_Bay | America/Grand_Turk | America/Grenada
America/Guadeloupe | America/Guatemala | America/Guayaquil | America/Guyana
America/Halifax | America/Havana | America/Hermosillo | America/Indiana/Indianapolis
America/Indiana/Knox | America/Indiana/Marengo | America/Indiana/Petersburg | America/Indiana/Tell_City
America/Indiana/Vevay | America/Indiana/Vincennes | America/Indiana/Winamac | America/Inuvik
America/Iqaluit | America/Jamaica | America/Juneau | America/Kentucky/Louisville
America/Kentucky/Monticello | America/Kralendijk | America/La_Paz | America/Lima
America/Los_Angeles | America/Lower_Princes | America/Maceio | America/Managua
America/Manaus | America/Marigot | America/Martinique | America/Matamoros
America/Mazatlan | America/Menominee | America/Merida | America/Metlakatla
America/Mexico_City | America/Miquelon | America/Moncton | America/Monterrey
America/Montevideo | America/Montserrat | America/Nassau | America/New_York
America/Nipigon | America/Nome | America/Noronha | America/North_Dakota/Beulah
America/North_Dakota/Center | America/North_Dakota/New_Salem | America/Nuuk | America/Ojinaga
America/Panama | America/Pangnirtung | America/Paramaribo | America/Phoenix
America/Port-au-Prince | America/Port_of_Spain | America/Porto_Velho | America/Puerto_Rico
America/Punta_Arenas | America/Rainy_River | America/Rankin_Inlet | America/Recife
America/Regina | America/Resolute | America/Rio_Branco | America/Santarem
America/Santiago | America/Santo_Domingo | America/Sao_Paulo | America/Scoresbysund
America/Sitka | America/St_Barthelemy | America/St_Johns | America/St_Kitts
America/St_Lucia | America/St_Thomas | America/St_Vincent | America/Swift_Current
America/Tegucigalpa | America/Thule | America/Thunder_Bay | America/Tijuana
America/Toronto | America/Tortola | America/Vancouver | America/Whitehorse
America/Winnipeg | America/Yakutat | America/Yellowknife |


南极洲

南极洲
Antarctica/Casey | Antarctica/Davis | Antarctica/DumontDUrville | Antarctica/Macquarie
Antarctica/Mawson | Antarctica/McMurdo | Antarctica/Palmer | Antarctica/Rothera
Antarctica/Syowa | Antarctica/Troll | Antarctica/Vostok |


  • ? 南极洲
  • 亚洲 ?
  • PHP Manual
  • 所支持的时区列表
  • 北极

北极

北极
Arctic/Longyearbyen


亚洲

亚洲
Asia/Aden | Asia/Almaty | Asia/Amman | Asia/Anadyr
Asia/Aqtau | Asia/Aqtobe | Asia/Ashgabat | Asia/Atyrau
Asia/Baghdad | Asia/Bahrain | Asia/Baku | Asia/Bangkok
Asia/Barnaul | Asia/Beirut | Asia/Bishkek | Asia/Brunei
Asia/Chita | Asia/Choibalsan | Asia/Colombo | Asia/Damascus
Asia/Dhaka | Asia/Dili | Asia/Dubai | Asia/Dushanbe
Asia/Famagusta | Asia/Gaza | Asia/Hebron | Asia/Ho_Chi_Minh
Asia/Hong_Kong | Asia/Hovd | Asia/Irkutsk | Asia/Jakarta
Asia/Jayapura | Asia/Jerusalem | Asia/Kabul | Asia/Kamchatka
Asia/Karachi | Asia/Kathmandu | Asia/Khandyga | Asia/Kolkata
Asia/Krasnoyarsk | Asia/Kuala_Lumpur | Asia/Kuching | Asia/Kuwait
Asia/Macau | Asia/Magadan | Asia/Makassar | Asia/Manila
Asia/Muscat | Asia/Nicosia | Asia/Novokuznetsk | Asia/Novosibirsk
Asia/Omsk | Asia/Oral | Asia/Phnom_Penh | Asia/Pontianak
Asia/Pyongyang | Asia/Qatar | Asia/Qostanay | Asia/Qyzylorda
Asia/Riyadh | Asia/Sakhalin | Asia/Samarkand | Asia/Seoul
Asia/Shanghai | Asia/Singapore | Asia/Srednekolymsk | Asia/Taipei
Asia/Tashkent | Asia/Tbilisi | Asia/Tehran | Asia/Thimphu
Asia/Tokyo | Asia/Tomsk | Asia/Ulaanbaatar | Asia/Urumqi
Asia/Ust-Nera | Asia/Vientiane | Asia/Vladivostok | Asia/Yakutsk
Asia/Yangon | Asia/Yekaterinburg | Asia/Yerevan |


大西洋

大西洋
Atlantic/Azores | Atlantic/Bermuda | Atlantic/Canary | Atlantic/Cape_Verde
Atlantic/Faroe | Atlantic/Madeira | Atlantic/Reykjavik | Atlantic/South_Georgia
Atlantic/St_Helena | Atlantic/Stanley |  |


澳洲

澳洲
Australia/Adelaide | Australia/Brisbane | Australia/Broken_Hill | Australia/Darwin
Australia/Eucla | Australia/Hobart | Australia/Lindeman | Australia/Lord_Howe
Australia/Melbourne | Australia/Perth | Australia/Sydney |


欧洲

欧洲
Europe/Amsterdam | Europe/Andorra | Europe/Astrakhan | Europe/Athens
Europe/Belgrade | Europe/Berlin | Europe/Bratislava | Europe/Brussels
Europe/Bucharest | Europe/Budapest | Europe/Busingen | Europe/Chisinau
Europe/Copenhagen | Europe/Dublin | Europe/Gibraltar | Europe/Guernsey
Europe/Helsinki | Europe/Isle_of_Man | Europe/Istanbul | Europe/Jersey
Europe/Kaliningrad | Europe/Kiev | Europe/Kirov | Europe/Lisbon
Europe/Ljubljana | Europe/London | Europe/Luxembourg | Europe/Madrid
Europe/Malta | Europe/Mariehamn | Europe/Minsk | Europe/Monaco
Europe/Moscow | Europe/Oslo | Europe/Paris | Europe/Podgorica
Europe/Prague | Europe/Riga | Europe/Rome | Europe/Samara
Europe/San_Marino | Europe/Sarajevo | Europe/Saratov | Europe/Simferopol
Europe/Skopje | Europe/Sofia | Europe/Stockholm | Europe/Tallinn
Europe/Tirane | Europe/Ulyanovsk | Europe/Uzhgorod | Europe/Vaduz
Europe/Vatican | Europe/Vienna | Europe/Vilnius | Europe/Volgograd
Europe/Warsaw | Europe/Zagreb | Europe/Zaporozhye | Europe/Zurich


印度

印度
Indian/Antananarivo | Indian/Chagos | Indian/Christmas | Indian/Cocos
Indian/Comoro | Indian/Kerguelen | Indian/Mahe | Indian/Maldives
Indian/Mauritius | Indian/Mayotte | Indian/Reunion |


太平洋地区

太平洋地区
Pacific/Apia | Pacific/Auckland | Pacific/Bougainville | Pacific/Chatham
Pacific/Chuuk | Pacific/Easter | Pacific/Efate | Pacific/Enderbury
Pacific/Fakaofo | Pacific/Fiji | Pacific/Funafuti | Pacific/Galapagos
Pacific/Gambier | Pacific/Guadalcanal | Pacific/Guam | Pacific/Honolulu
Pacific/Kiritimati | Pacific/Kosrae | Pacific/Kwajalein | Pacific/Majuro
Pacific/Marquesas | Pacific/Midway | Pacific/Nauru | Pacific/Niue
Pacific/Norfolk | Pacific/Noumea | Pacific/Pago_Pago | Pacific/Palau
Pacific/Pitcairn | Pacific/Pohnpei | Pacific/Port_Moresby | Pacific/Rarotonga
Pacific/Saipan | Pacific/Tahiti | Pacific/Tarawa | Pacific/Tongatapu
Pacific/Wake | Pacific/Wallis |  |


其他

Warning

在此请不要使用任何时区列表（除 UTC 外），仅用于向后兼容，可能会引起某些错误行为。

Warning

If you disregard the above warning, please also note that the IANA timezone database that provides PHP's timezone support uses POSIX style signs, which results in the Etc/GMT+n and Etc/GMT-n time zones being reversed from common usage.

For example, the time zone 8 hours ahead of GMT that is used in China and Western Australia (among other places) is actually Etc/GMT-8 in this database, not Etc/GMT+8 as you would normally expect.

Once again, it is strongly recommended that you use the correct time zone for your location, such as Asia/Shanghai or Australia/Perth for the above examples.

其他
Africa/Asmera | Africa/Timbuktu | America/Argentina/ComodRivadavia | America/Atka
America/Buenos_Aires | America/Catamarca | America/Coral_Harbour | America/Cordoba
America/Ensenada | America/Fort_Wayne | America/Godthab | America/Indianapolis
America/Jujuy | America/Knox_IN | America/Louisville | America/Mendoza
America/Montreal | America/Porto_Acre | America/Rosario | America/Santa_Isabel
America/Shiprock | America/Virgin | Antarctica/South_Pole | Asia/Ashkhabad
Asia/Calcutta | Asia/Chongqing | Asia/Chungking | Asia/Dacca
Asia/Harbin | Asia/Istanbul | Asia/Kashgar | Asia/Katmandu
Asia/Macao | Asia/Rangoon | Asia/Saigon | Asia/Tel_Aviv
Asia/Thimbu | Asia/Ujung_Pandang | Asia/Ulan_Bator | Atlantic/Faeroe
Atlantic/Jan_Mayen | Australia/ACT | Australia/Canberra | Australia/Currie
Australia/LHI | Australia/North | Australia/NSW | Australia/Queensland
Australia/South | Australia/Tasmania | Australia/Victoria | Australia/West
Australia/Yancowinna | Brazil/Acre | Brazil/DeNoronha | Brazil/East
Brazil/West | Canada/Atlantic | Canada/Central | Canada/Eastern
Canada/Mountain | Canada/Newfoundland | Canada/Pacific | Canada/Saskatchewan
Canada/Yukon | CET | Chile/Continental | Chile/EasterIsland
CST6CDT | Cuba | EET | Egypt
Eire | EST | EST5EDT | Etc/GMT
Etc/GMT+0 | Etc/GMT+1 | Etc/GMT+10 | Etc/GMT+11
Etc/GMT+12 | Etc/GMT+2 | Etc/GMT+3 | Etc/GMT+4
Etc/GMT+5 | Etc/GMT+6 | Etc/GMT+7 | Etc/GMT+8
Etc/GMT+9 | Etc/GMT-0 | Etc/GMT-1 | Etc/GMT-10
Etc/GMT-11 | Etc/GMT-12 | Etc/GMT-13 | Etc/GMT-14
Etc/GMT-2 | Etc/GMT-3 | Etc/GMT-4 | Etc/GMT-5
Etc/GMT-6 | Etc/GMT-7 | Etc/GMT-8 | Etc/GMT-9
Etc/GMT0 | Etc/Greenwich | Etc/UCT | Etc/Universal
Etc/UTC | Etc/Zulu | Europe/Belfast | Europe/Nicosia
Europe/Tiraspol | Factory | GB | GB-Eire
GMT | GMT+0 | GMT-0 | GMT0
Greenwich | Hongkong | HST | Iceland
Iran | Israel | Jamaica | Japan
Kwajalein | Libya | MET | Mexico/BajaNorte
Mexico/BajaSur | Mexico/General | MST | MST7MDT
Navajo | NZ | NZ-CHAT | Pacific/Johnston
Pacific/Ponape | Pacific/Samoa | Pacific/Truk | Pacific/Yap
Poland | Portugal | PRC | PST8PDT
ROC | ROK | Singapore | Turkey
UCT | Universal | US/Alaska | US/Aleutian
US/Arizona | US/Central | US/East-Indiana | US/Eastern
US/Hawaii | US/Indiana-Starke | US/Michigan | US/Mountain
US/Pacific | US/Samoa | UTC | W-SU
WET | Zulu |  |


High resolution timing

  • 简介
  • 安装／配置
    • 安装
  • 范例
    • Basic usage
  • HRTime\PerformanceCounter — The HRTime\PerformanceCounter class
    • HRTime\PerformanceCounter::getFrequency — Timer frequency in ticks per second
    • HRTime\PerformanceCounter::getTicks — Current ticks from the system
    • HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value
  • HRTime\StopWatch — The HRTime\StopWatch class
    • HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals
    • HRTime\StopWatch::getElapsedTime — Get elapsed time for all intervals
    • HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval
    • HRTime\StopWatch::getLastElapsedTime — Get elapsed time for the last interval
    • HRTime\StopWatch::isRunning — Whether the measurement is running
    • HRTime\StopWatch::start — Start time measurement
    • HRTime\StopWatch::stop — Stop time measurement
  • HRTime\Unit — The HRTime\Unit class


简介

The HRTime extension implements a high resolution StopWatch class. It uses the best possible APIs on different platforms which brings resolution up to nanoseconds. It also makes possible to implement a custom stopwatch using low level ticks delivered by the underlaying APIs.

Note: As of PHP 7.3.0 the related function hrtime() is part of the core.


  • ? 简介
  • 安装 ?
  • PHP Manual
  • HRTime
  • 安装／配置

安装／配置

Table of Contents

  • 安装


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/hrtime.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/hrtime/.


  • ? 安装
  • Basic usage ?
  • PHP Manual
  • HRTime
  • 范例

范例

Table of Contents

  • Basic usage


Basic usage

The example illustrates the basic StopWatch class usage

Example #1 Measure several code blocks execution and get the total

<?php

$c = new HRTime\StopWatch;

$c->start();
/* measure this code block execution */
for ($i = 0; $i < 1024*1024; $i++);
$c->stop();
$elapsed0 = $c->getLastElapsedTime(HRTime\Unit::NANOSECOND);

/* measurement is not running here*/
for ($i = 0; $i < 1024*1024; $i++);

$c->start();
/* measure this code block execution */
for ($i = 0; $i < 1024*1024; $i++);
$c->stop();
$elapsed1 = $c->getLastElapsedTime(HRTime\Unit::NANOSECOND);

$elapsed_total = $c->getElapsedTime(HRTime\Unit::NANOSECOND);

?>


The HRTime\PerformanceCounter class

(PECL hrtime >= 0.4.3)

简介

类摘要

HRTime\PerformanceCounter {
/* 方法 */
public static getFrequency ( ) : int
public static getTicks ( ) : int
public static getTicksSince ( int $start ) : int
}

Table of Contents

  • HRTime\PerformanceCounter::getFrequency — Timer frequency in ticks per second
  • HRTime\PerformanceCounter::getTicks — Current ticks from the system
  • HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value


Timer frequency in ticks per second

  • ? HRTime\PerformanceCounter
  • HRTime\PerformanceCounter::getTicks ?
  • PHP Manual
  • HRTime\PerformanceCounter
  • Timer frequency in ticks per second

HRTime\PerformanceCounter::getFrequency

(PECL hrtime >= 0.4.3)

HRTime\PerformanceCounter::getFrequency — Timer frequency in ticks per second

说明

public static HRTime\PerformanceCounter::getFrequency ( ) : int

Returns the timer frequency in ticks per second. This value is constant after the system start on almost any operating system.

参数

此函数没有参数。

返回值

Returns int indicating the timer frequency.


Current ticks from the system

  • ? HRTime\PerformanceCounter::getFrequency
  • HRTime\PerformanceCounter::getTicksSince ?
  • PHP Manual
  • HRTime\PerformanceCounter
  • Current ticks from the system

HRTime\PerformanceCounter::getTicks

(PECL hrtime >= 0.6.0)

HRTime\PerformanceCounter::getTicks — Current ticks from the system

说明

public static HRTime\PerformanceCounter::getTicks ( ) : int

Returns the ticks count.

参数

此函数没有参数。

返回值

Returns int indicating the ticks count.


Ticks elapsed since the given value

  • ? HRTime\PerformanceCounter::getTicks
  • HRTime\StopWatch ?
  • PHP Manual
  • HRTime\PerformanceCounter
  • Ticks elapsed since the given value

HRTime\PerformanceCounter::getTicksSince

(PECL hrtime >= 0.6.0)

HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value

说明

public static HRTime\PerformanceCounter::getTicksSince ( int $start ) : int

Returns the ticks count elapsed since the given start value.

参数

start

Starting ticks value.

返回值

Returns int indicating the ticks count.


The HRTime\StopWatch class

(PECL hrtime >= 0.4.3)

简介

类摘要

HRTime\StopWatch extends HRTime\PerformanceCounter {
/* 方法 */
public getElapsedTicks ( ) : int
public getElapsedTime ( int $unit = ? ) : float
public getLastElapsedTicks ( ) : int
public getLastElapsedTime ( int $unit = ? ) : float
public isRunning ( ) : bool
public start ( ) : void
public stop ( ) : void
/* 继承的方法 */
public static HRTime\PerformanceCounter::getFrequency ( ) : int
public static HRTime\PerformanceCounter::getTicks ( ) : int
public static HRTime\PerformanceCounter::getTicksSince ( int $start ) : int
}

Table of Contents

  • HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals
  • HRTime\StopWatch::getElapsedTime — Get elapsed time for all intervals
  • HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval
  • HRTime\StopWatch::getLastElapsedTime — Get elapsed time for the last interval
  • HRTime\StopWatch::isRunning — Whether the measurement is running
  • HRTime\StopWatch::start — Start time measurement
  • HRTime\StopWatch::stop — Stop time measurement


Get elapsed ticks for all intervals

  • ? HRTime\StopWatch
  • HRTime\StopWatch::getElapsedTime ?
  • PHP Manual
  • HRTime\StopWatch
  • Get elapsed ticks for all intervals

HRTime\StopWatch::getElapsedTicks

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals

说明

public HRTime\StopWatch::getElapsedTicks ( ) : int

Get elapsed ticks for all the previously closed intervals.

参数

此函数没有参数。

返回值

Returns int indicating elapsed ticks.


Get elapsed time for all intervals

  • ? HRTime\StopWatch::getElapsedTicks
  • HRTime\StopWatch::getLastElapsedTicks ?
  • PHP Manual
  • HRTime\StopWatch
  • Get elapsed time for all intervals

HRTime\StopWatch::getElapsedTime

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getElapsedTime — Get elapsed time for all intervals

说明

public HRTime\StopWatch::getElapsedTime ( int $unit = ? ) : float

Get elapsed time for all the previously closed intervals.

参数

unit

Time unit represented by a HRTime\Unit constant. Default is HRTime\Unit::SECOND.

返回值

Returns float indicating elapsed time.


Get elapsed ticks for the last interval

  • ? HRTime\StopWatch::getElapsedTime
  • HRTime\StopWatch::getLastElapsedTime ?
  • PHP Manual
  • HRTime\StopWatch
  • Get elapsed ticks for the last interval

HRTime\StopWatch::getLastElapsedTicks

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval

说明

public HRTime\StopWatch::getLastElapsedTicks ( ) : int

Get elapsed ticks for the previously closed interval.

参数

此函数没有参数。

返回值

Returns int indicating elapsed ticks.


Get elapsed time for the last interval

  • ? HRTime\StopWatch::getLastElapsedTicks
  • HRTime\StopWatch::isRunning ?
  • PHP Manual
  • HRTime\StopWatch
  • Get elapsed time for the last interval

HRTime\StopWatch::getLastElapsedTime

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getLastElapsedTime — Get elapsed time for the last interval

说明

public HRTime\StopWatch::getLastElapsedTime ( int $unit = ? ) : float

Get elapsed time for the previously closed interval.

参数

unit

Time unit represented by a HRTime\Unit constant. Default is HRTime\Unit::SECOND.

返回值

Returns float indicating elapsed time.


Whether the measurement is running

  • ? HRTime\StopWatch::getLastElapsedTime
  • HRTime\StopWatch::start ?
  • PHP Manual
  • HRTime\StopWatch
  • Whether the measurement is running

HRTime\StopWatch::isRunning

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::isRunning — Whether the measurement is running

说明

public HRTime\StopWatch::isRunning ( ) : bool

Reveals whether the measurement was started.

参数

此函数没有参数。

返回值

Returns bool indicating whetehr the measurement is running.


Start time measurement

  • ? HRTime\StopWatch::isRunning
  • HRTime\StopWatch::stop ?
  • PHP Manual
  • HRTime\StopWatch
  • Start time measurement

HRTime\StopWatch::start

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::start — Start time measurement

说明

public HRTime\StopWatch::start ( ) : void

Starts the time measurement. It has no effect if the measurement was already started. The measurement will be continued if it was previously stopped.

参数

此函数没有参数。

返回值

Returns void.


Stop time measurement

  • ? HRTime\StopWatch::start
  • HRTime\Unit ?
  • PHP Manual
  • HRTime\StopWatch
  • Stop time measurement

HRTime\StopWatch::stop

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::stop — Stop time measurement

说明

public HRTime\StopWatch::stop ( ) : void

Stop the time measurement for the previously started interval.

参数

此函数没有参数。

返回值

Returns void.


The HRTime\Unit class

(PECL hrtime >= 0.4.3)

简介

类摘要

HRTime\Unit {
/* Constants */
const int SECOND = 0 ;
const int MILLISECOND = 1 ;
const int MICROSECOND = 2 ;
const int NANOSECOND = 3 ;
/* 方法 */
}

预定义常量

HRTime\Unit::SECOND

HRTime\Unit::MILLISECOND

HRTime\Unit::MICROSECOND

HRTime\Unit::NANOSECOND


文件系统相关扩展

  • Direct IO
    • 简介
    • 安装／配置
    • 预定义常量
    • Direct IO 函数
  • 目录
    • 安装／配置
    • 预定义常量
    • Directory — Directory 类
    • 目录函数函数
  • Fileinfo — 文件信息
    • 简介
    • 安装／配置
    • 预定义常量
    • Fileinfo 函数
    • finfo — finfo 类
  • 文件系统
    • 简介
    • 安装／配置
    • 预定义常量
    • 文件系统函数
  • Inotify
    • 简介
    • 安装／配置
    • 预定义常量
    • Inotify 函数
  • Proctitle
    • 简介
    • 安装／配置
    • 预定义常量
    • Proctitle 函数
  • xattr
    • 简介
    • 安装／配置
    • 预定义常量
    • xattr 函数
  • xdiff
    • 简介
    • 安装／配置
    • 预定义常量
    • xdiff 函数


Direct IO

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Direct IO 函数
    • dio_close — Closes the file descriptor given by fd
    • dio_fcntl — Performs a c library fcntl on fd
    • dio_open — Opens a file (creating it if necessary) at a lower level than the C library input/ouput stream functions allow
    • dio_read — Reads bytes from a file descriptor
    • dio_seek — Seeks to pos on fd from whence
    • dio_stat — Gets stat information about the file descriptor fd
    • dio_tcsetattr — Sets terminal attributes and baud rate for a serial port
    • dio_truncate — Truncates file descriptor fd to offset bytes
    • dio_write — Writes data to fd with optional truncation at length


简介

PHP supports the direct io functions as described in the Posix Standard (Section 6) for performing I/O functions at a lower level than the C-Language stream I/O functions (fopen(), fread(),..). The use of the DIO functions should be considered only when direct control of a device is needed. In all other cases, the standard filesystem functions are more than adequate.

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.1.0.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Direct IO
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/dio.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


资源类型

One resource type is defined by this extension: a file descriptor returned by dio_open().


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

F_DUPFD (int)

F_GETFD (int)

F_GETFL (int)

F_GETLK (int)

F_GETOWN (int)

F_RDLCK (int)

F_SETFL (int)

F_SETLK (int)

F_SETLKW (int)

F_SETOWN (int)

F_UNLCK (int)

F_WRLCK (int)

O_APPEND (int)

O_ASYNC (int)

O_CREAT (int)

O_EXCL (int)

O_NDELAY (int)

O_NOCTTY (int)

O_NONBLOCK (int)

O_RDONLY (int)

O_RDWR (int)

O_SYNC (int)

O_TRUNC (int)

O_WRONLY (int)

S_IRGRP (int)

S_IROTH (int)

S_IRUSR (int)

S_IRWXG (int)

S_IRWXO (int)

S_IRWXU (int)

S_IWGRP (int)

S_IWOTH (int)

S_IWUSR (int)

S_IXGRP (int)

S_IXOTH (int)

S_IXUSR (int)


Direct IO 函数

Table of Contents

  • dio_close — Closes the file descriptor given by fd
  • dio_fcntl — Performs a c library fcntl on fd
  • dio_open — Opens a file (creating it if necessary) at a lower level than the C library input/ouput stream functions allow
  • dio_read — Reads bytes from a file descriptor
  • dio_seek — Seeks to pos on fd from whence
  • dio_stat — Gets stat information about the file descriptor fd
  • dio_tcsetattr — Sets terminal attributes and baud rate for a serial port
  • dio_truncate — Truncates file descriptor fd to offset bytes
  • dio_write — Writes data to fd with optional truncation at length


Closes the file descriptor given by fd

  • ? Direct IO 函数
  • dio_fcntl ?
  • PHP Manual
  • Direct IO 函数
  • Closes the file descriptor given by fd

dio_close

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_close — Closes the file descriptor given by fd

说明

dio_close ( resource $fd ) : void

The function dio_close() closes the file descriptor fd.

参数

fd

The file descriptor returned by dio_open().

返回值

没有返回值。

范例

Example #1 Closing an open file descriptor

<?php
$fd = dio_open('/dev/ttyS0', O_RDWR);

dio_close($fd);
?>

参见

  • dio_open() - Opens a file (creating it if necessary) at a lower level than the C library input/ouput stream functions allow


Performs a c library fcntl on fd

  • ? dio_close
  • dio_open ?
  • PHP Manual
  • Direct IO 函数
  • Performs a c library fcntl on fd

dio_fcntl

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_fcntl — Performs a c library fcntl on fd

说明

dio_fcntl ( resource $fd , int $cmd , mixed $args = ? ) : mixed

The dio_fcntl() function performs the operation specified by cmd on the file descriptor fd. Some commands require additional arguments args to be supplied.

参数

fd

The file descriptor returned by dio_open().

cmd

Can be one of the following operations:

  • F_SETLK - Lock is set or cleared. If the lock is held by someone else dio_fcntl() returns -1.

  • F_SETLKW - like F_SETLK, but in case the lock is held by someone else, dio_fcntl() waits until the lock is released.

  • F_GETLK - dio_fcntl() returns an associative array (as described below) if someone else prevents lock. If there is no obstruction key "type" will set to F_UNLCK.

  • F_DUPFD - finds the lowest numbered available file descriptor greater than or equal to args and returns them.

  • F_SETFL - Sets the file descriptors flags to the value specified by args, which can be O_APPEND, O_NONBLOCK or O_ASYNC. To use O_ASYNC you will need to use the PCNTL extension.

args

args is an associative array, when cmd is F_SETLK or F_SETLLW, with the following keys:

  • start - offset where lock begins

  • length - size of locked area. zero means to end of file

  • whence - Where l_start is relative to: can be SEEK_SET, SEEK_END and SEEK_CUR

  • type - type of lock: can be F_RDLCK (read lock), F_WRLCK (write lock) or F_UNLCK (unlock)

返回值

Returns the result of the C call.

范例

Example #1 Setting and clearing a lock

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR);

if (dio_fcntl($fd, F_SETLK, Array("type"=>F_WRLCK)) == -1) {
   // the file descriptor appears locked
   echo "The lock can not be cleared. It is held by someone else.";
} else {
   echo "Lock successfully set/cleared";
}

dio_close($fd);
?>

注释

Note: 此函数未在 Windows 平台下实现。


Opens a file (creating it if necessary) at a lower level than the C library input/ouput stream functions allow

  • ? dio_fcntl
  • dio_read ?
  • PHP Manual
  • Direct IO 函数
  • Opens a file (creating it if necessary) at a lower level than the C library input/ouput stream functions allow

dio_open

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_open — Opens a file (creating it if necessary) at a lower level than the C library input/ouput stream functions allow

说明

dio_open ( string $filename , int $flags , int $mode = 0 ) : resource

dio_open() opens a file and returns a new file descriptor for it.

参数

filename

The pathname of the file to open.

flags

The flags parameter is a bitwise-ORed value comprising flags from the following list. This value must include one of O_RDONLY, O_WRONLY, or O_RDWR. Additionally, it may include any combination of the other flags from this list.

  • O_RDONLY - opens the file for read access.

  • O_WRONLY - opens the file for write access.

  • O_RDWR - opens the file for both reading and writing.

  • O_CREAT - creates the file, if it doesn't already exist.

  • O_EXCL - if both O_CREAT and O_EXCL are set and the file already exists, dio_open() will fail.

  • O_TRUNC - if the file exists and is opened for write access, the file will be truncated to zero length.

  • O_APPEND - write operations write data at the end of the file.

  • O_NONBLOCK - sets non blocking mode.

  • O_NOCTTY - prevent the OS from assigning the opened file as the process's controlling terminal when opening a TTY device file.

mode

If flags contains O_CREAT, mode will set the permissions of the file (creation permissions). mode is required for correct operation when O_CREAT is specified in flags and is ignored otherwise.

The actual permissions assigned to the created file will be affected by the process's umask setting as per usual.

返回值

A file descriptor or false on error.

范例

Example #1 Opening a file descriptor

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_close($fd);
?>

参见

  • dio_close() - Closes the file descriptor given by fd


Reads bytes from a file descriptor

  • ? dio_open
  • dio_seek ?
  • PHP Manual
  • Direct IO 函数
  • Reads bytes from a file descriptor

dio_read

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_read — Reads bytes from a file descriptor

说明

dio_read ( resource $fd , int $len = 1024 ) : string

The function dio_read() reads and returns len bytes from file with descriptor fd.

参数

fd

The file descriptor returned by dio_open().

len

The number of bytes to read. If not specified, dio_read() reads 1K sized block.

返回值

The bytes read from fd.

参见

  • dio_write() - Writes data to fd with optional truncation at length


Seeks to pos on fd from whence

  • ? dio_read
  • dio_stat ?
  • PHP Manual
  • Direct IO 函数
  • Seeks to pos on fd from whence

dio_seek

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_seek — Seeks to pos on fd from whence

说明

dio_seek ( resource $fd , int $pos , int $whence = SEEK_SET ) : int

The function dio_seek() is used to change the file position of the given file descriptor.

参数

fd

The file descriptor returned by dio_open().

pos

The new position.

whence

Specifies how the position pos should be interpreted:

  • SEEK_SET (default) - specifies that pos is specified from the beginning of the file.

  • SEEK_CUR - Specifies that pos is a count of characters from the current file position. This count may be positive or negative.

  • SEEK_END - Specifies that pos is a count of characters from the end of the file. A negative count specifies a position within the current extent of the file; a positive count specifies a position past the current end. If you set the position past the current end, and actually write data, you will extend the file with zeros up to that position.

返回值

范例

Example #1 Positioning in a file

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR);

dio_seek($fd, 10, SEEK_SET);
// position is now at 10 characters from the start of the file

dio_seek($fd, -2, SEEK_CUR);
// position is now at 8 characters from the start of the file

dio_seek($fd, -5, SEEK_END);
// position is now at 5 characters from the end of the file

dio_seek($fd, 10, SEEK_END);
// position is now at 10 characters past the end of the file.
// The 10 characters between the end of the file and the current
// position are filled with zeros.

dio_close($fd);
?>


Gets stat information about the file descriptor fd

  • ? dio_seek
  • dio_tcsetattr ?
  • PHP Manual
  • Direct IO 函数
  • Gets stat information about the file descriptor fd

dio_stat

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_stat — Gets stat information about the file descriptor fd

说明

dio_stat ( resource $fd ) : array

dio_stat() returns information about the given file descriptor.

参数

fd

The file descriptor returned by dio_open().

返回值

Returns an associative array with the following keys:

  • "device" - device

  • "inode" - inode

  • "mode" - mode

  • "nlink" - number of hard links

  • "uid" - user id

  • "gid" - group id

  • "device_type" - device type (if inode device)

  • "size" - total size in bytes

  • "blocksize" - blocksize

  • "blocks" - number of blocks allocated

  • "atime" - time of last access

  • "mtime" - time of last modification

  • "ctime" - time of last change

On error dio_stat() returns null.


Sets terminal attributes and baud rate for a serial port

  • ? dio_stat
  • dio_truncate ?
  • PHP Manual
  • Direct IO 函数
  • Sets terminal attributes and baud rate for a serial port

dio_tcsetattr

(PHP 4 >= 4.3.0, PHP 5 < 5.1.0)

dio_tcsetattr — Sets terminal attributes and baud rate for a serial port

说明

dio_tcsetattr ( resource $fd , array $options ) : bool

dio_tcsetattr() sets the terminal attributes and baud rate of the open fd.

参数

fd

The file descriptor returned by dio_open().

options

The currently available options are:

  • 'baud' - baud rate of the port - can be 38400,19200,9600,4800,2400,1800, 1200,600,300,200,150,134,110,75 or 50, default value is 9600.

  • 'bits' - data bits - can be 8,7,6 or 5. Default value is 8.

  • 'stop' - stop bits - can be 1 or 2. Default value is 1.

  • 'parity' - can be 0,1 or 2. Default value is 0.

返回值

没有返回值。

范例

Example #1 Setting the baud rate on a serial port

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_fcntl($fd, F_SETFL, O_SYNC);

dio_tcsetattr($fd, array(
  'baud' => 9600,
  'bits' => 8,
  'stop'  => 1,
  'parity' => 0
));

while (1) {

  $data = dio_read($fd, 256);

  if ($data) {
      echo $data;
  }
}

?>

注释

Note: 此函数未在 Windows 平台下实现。


Truncates file descriptor fd to offset bytes

  • ? dio_tcsetattr
  • dio_write ?
  • PHP Manual
  • Direct IO 函数
  • Truncates file descriptor fd to offset bytes

dio_truncate

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_truncate — Truncates file descriptor fd to offset bytes

说明

dio_truncate ( resource $fd , int $offset ) : bool

dio_truncate() truncates a file to at most offset bytes in size.

If the file previously was larger than this size, the extra data is lost. If the file previously was shorter, it is unspecified whether the file is left unchanged or is extended. In the latter case the extended part reads as zero bytes.

参数

fd

The file descriptor returned by dio_open().

offset

The offset in bytes.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note: 此函数未在 Windows 平台下实现。


Writes data to fd with optional truncation at length

  • ? dio_truncate
  • 目录 ?
  • PHP Manual
  • Direct IO 函数
  • Writes data to fd with optional truncation at length

dio_write

(PHP 4 >= 4.2.0, PHP 5 < 5.1.0)

dio_write — Writes data to fd with optional truncation at length

说明

dio_write ( resource $fd , string $data , int $len = 0 ) : int

dio_write() writes up to len bytes from data to file fd.

参数

fd

The file descriptor returned by dio_open().

data

The written data.

len

The length of data to write in bytes. If not specified, the function writes all the data to the specified file.

返回值

Returns the number of bytes written to fd.

参见

  • dio_read() - Reads bytes from a file descriptor


目录

  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Directory — Directory 类
    • Directory::close — 释放目录句柄
    • Directory::read — 从目录句柄中读取条目
    • Directory::rewind — 倒回目录句柄
  • 目录函数函数
    • chdir — 改变目录
    • chroot — 改变根目录
    • closedir — 关闭目录句柄
    • dir — 返回一个 Directory 类实例
    • getcwd — 取得当前工作目录
    • opendir — 打开目录句柄
    • readdir — 从目录句柄中读取条目
    • rewinddir — 倒回目录句柄
    • scandir — 列出指定路径中的文件和目录


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

DIRECTORY_SEPARATOR (string)
PATH_SEPARATOR (string)

Note: PATH_SEPARATOR 是在 PHP 4.3.0-RC2 中引入。


Directory 类

(PHP 4, PHP 5, PHP 7, PHP 8)

简介

Directory 实例是通过调用 dir() 函数创建的，而不是 new 操作符。

类摘要

Directory {
/* 属性 */
public string $path ;
public resource $handle ;
/* 方法 */
public close ( resource $dir_handle = ? ) : void
public read ( resource $dir_handle = ? ) : string
public rewind ( resource $dir_handle = ? ) : void
}

属性

path

被打开目录的地址

handle

目录句柄。可以被其他的目录操作函数使用，例如 readdir(), rewinddir() and closedir()。

Table of Contents

  • Directory::close — 释放目录句柄
  • Directory::read — 从目录句柄中读取条目
  • Directory::rewind — 倒回目录句柄


释放目录句柄

  • ? Directory
  • Directory::read ?
  • PHP Manual
  • Directory
  • 释放目录句柄

Directory::close

(PHP 4, PHP 5, PHP 7, PHP 8)

Directory::close — 释放目录句柄

说明

public Directory::close ( resource $dir_handle = ? ) : void

与 closedir() 函数功能一样，只是 dir_handle 默认为 $this 变量。


从目录句柄中读取条目

  • ? Directory::close
  • Directory::rewind ?
  • PHP Manual
  • Directory
  • 从目录句柄中读取条目

Directory::read

(PHP 4, PHP 5, PHP 7, PHP 8)

Directory::read — 从目录句柄中读取条目

说明

public Directory::read ( resource $dir_handle = ? ) : string

与 readdir() 函数功能一样, 只是 dir_handle 默认为 $this 变量。


倒回目录句柄

  • ? Directory::read
  • 目录函数函数 ?
  • PHP Manual
  • Directory
  • 倒回目录句柄

Directory::rewind

(PHP 4, PHP 5, PHP 7, PHP 8)

Directory::rewind — 倒回目录句柄

说明

public Directory::rewind ( resource $dir_handle = ? ) : void

与 rewinddir() 函数功能一样, 只是 dir_handle 默认为 $this 变量。


目录函数函数

参见

相关函数，例如：dirname()、
is_dir()、 mkdir() 和
rmdir()，
请查看文件系统章节。

Table of Contents

  • chdir — 改变目录
  • chroot — 改变根目录
  • closedir — 关闭目录句柄
  • dir — 返回一个 Directory 类实例
  • getcwd — 取得当前工作目录
  • opendir — 打开目录句柄
  • readdir — 从目录句柄中读取条目
  • rewinddir — 倒回目录句柄
  • scandir — 列出指定路径中的文件和目录


改变目录

  • ? 目录函数函数
  • chroot ?
  • PHP Manual
  • 目录函数函数
  • 改变目录

chdir

(PHP 4, PHP 5, PHP 7, PHP 8)

chdir — 改变目录

说明

chdir ( string $directory ) : bool

将 PHP 的当前目录改为 directory。

参数

directory

新的当前目录

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws an error of level E_WARNING on failure.

范例

Example #1 chdir() 例子

<?php

// current directory
echo getcwd() . "\n";

chdir('public_html');

// current directory
echo getcwd() . "\n";

?>

以上例程的输出类似于：

/home/vincent
/home/vincent/public_html

注释

Caution

If the PHP interpreter has been built with ZTS (Zend Thread Safety) enabled, any changes to the current directory made through chdir() will be invisible to the operating system. All built-in PHP functions will still respect the change in current directory; but external library functions called using FFI will not. You can tell whether your copy of PHP was built with ZTS enabled using php -i or the built-in constant PHP_ZTS.

参见

  • getcwd() - 取得当前工作目录


改变根目录

  • ? chdir
  • closedir ?
  • PHP Manual
  • 目录函数函数
  • 改变根目录

chroot

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

chroot — 改变根目录

说明

chroot ( string $directory ) : bool

将当前进程的根目录改变为 directory。

本函数仅在系统支持且运行于 CLI，CGI 或嵌入 SAPI 版本时才能正确工作。此外本函数还需要 root 权限。

参数

directory

新目录

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 chroot() example

<?php
chroot("/path/to/your/chroot/");
echo getcwd();
?>

以上例程会输出：

/

注释

Note: 此函数未在 Windows 平台下实现。


关闭目录句柄

  • ? chroot
  • dir ?
  • PHP Manual
  • 目录函数函数
  • 关闭目录句柄

closedir

(PHP 4, PHP 5, PHP 7, PHP 8)

closedir — 关闭目录句柄

说明

closedir ( resource $dir_handle = ? ) : void

关闭由 dir_handle 指定的目录流。流必须之前被 opendir() 所打开。

参数

dir_handle

目录句柄的 resource，之前由 opendir() 所打开的。如果目录句柄没有指定，那么会假定为是opendir()所打开的最后一个句柄。

范例

Example #1 closedir() 例子

<?php
$dir = "/etc/php5/";

// Open a known directory, read directory into variable and then close
if (is_dir($dir)) {
    if ($dh = opendir($dir)) {
        $directory = readdir($dh);
        closedir($dh);
    }
}
?>


返回一个 Directory 类实例

  • ? closedir
  • getcwd ?
  • PHP Manual
  • 目录函数函数
  • 返回一个 Directory 类实例

dir

(PHP 4, PHP 5, PHP 7, PHP 8)

dir — 返回一个 Directory 类实例

说明

dir ( string $directory , resource $context = ? ) : Directory

以面向对象的方式访问目录。打开 directory 参数指定的目录。

参数

directory

被打开的目录

context

Note: 在 PHP 5.0.0 中增加了对上下文（Context）的支持。有关上下文（Context）的说明参见 Streams。

返回值

成功的话，返回一个 Directory 类实例, 参数错误的情况下返回 null ， 其它错误情况返回 false 。

范例

Example #1 dir() 示例

请特别注意下面示例中 Directory::read() 函数返回值的判断方式。 我们严格测试（值相等，并且类型相同，请参考 比较运算符 ）返回值等于 false ，因为有些情况下，目录名可能"等于" false ，导致 跳出循环。

<?php
$d = dir("/etc/php5");
echo "Handle: " . $d->handle . "\n";
echo "Path: " . $d->path . "\n";
while (false !== ($entry = $d->read())) {
   echo $entry."\n";
}
$d->close();
?>

以上例程的输出类似于：

Handle: Resource id #2
Path: /etc/php5
.
..
apache
cgi
cli

注释

Note:

目录条目返回的顺序依赖于系统。


取得当前工作目录

  • ? dir
  • opendir ?
  • PHP Manual
  • 目录函数函数
  • 取得当前工作目录

getcwd

(PHP 4, PHP 5, PHP 7, PHP 8)

getcwd — 取得当前工作目录

说明

getcwd ( ) : string|false

取得当前工作目录。

返回值

成功则返回当前工作目录，失败返回 false。

在某些 Unix 的变种下，如果任何父目录没有设定可读或搜索模式，即使当前目录设定了，getcwd() 还是会返回 false。有关模式与权限的更多信息见 chmod()。

Caution

如果在编译 PHP 时启用了 ZTS（Zend Thread Safety）选项，则 getcwd() 函数返回的当前工作目录可能与操作系统接口返回的目录不同。依赖于当前工作目录的外部库（通过 FFI 调用）将受到影响。

范例

Example #1 getcwd() 例子

<?php

// current directory
echo getcwd() . "\n";

chdir('cvs');

// current directory
echo getcwd() . "\n";

?>

以上例程的输出类似于：

/home/didou
/home/didou/cvs

参见

  • chdir() - 改变目录
  • chmod() - 改变文件模式


打开目录句柄

  • ? getcwd
  • readdir ?
  • PHP Manual
  • 目录函数函数
  • 打开目录句柄

opendir

(PHP 4, PHP 5, PHP 7, PHP 8)

opendir — 打开目录句柄

说明

opendir ( string $path , resource $context = ? ) : resource

打开一个目录句柄，可用于之后的 closedir()，readdir() 和 rewinddir() 调用中。

参数

path

要打开的目录路径

context

context 参数的说明见手册中的 Streams API 一章。

返回值

如果成功则返回目录句柄的 resource，失败则返回 false。

如果 path 不是一个合法的目录或者因为权限限制或文件系统错误而不能打开目录，opendir() 返回 false 并产生一个 E_WARNING 级别的 PHP 错误信息。可以在 opendir() 前面加上"@"符号来抑制错误信息的输出。

更新日志

版本 | 说明
5.0.0 | path 支持 ftp:// URL wrapper
4.3.0 | path 可以是任何支持目录列表的 URL，不过在 PHP 4 中只有 file:// URL wrapper 支持此功能

范例

Example #1 opendir() 例子

<?php
$dir = "/etc/php5/";

// Open a known directory, and proceed to read its contents
if (is_dir($dir)) {
    if ($dh = opendir($dir)) {
        while (($file = readdir($dh)) !== false) {
            echo "filename: $file : filetype: " . filetype($dir . $file) . "\n";
        }
        closedir($dh);
    }
}
?>

以上例程的输出类似于：

filename: . : filetype: dir
filename: .. : filetype: dir
filename: apache : filetype: dir
filename: cgi : filetype: dir
filename: cli : filetype: dir

参见

  • is_dir() - 判断给定文件名是否是一个目录
  • readdir() - 从目录句柄中读取条目
  • dir() - 返回一个 Directory 类实例


从目录句柄中读取条目

  • ? opendir
  • rewinddir ?
  • PHP Manual
  • 目录函数函数
  • 从目录句柄中读取条目

readdir

(PHP 4, PHP 5, PHP 7, PHP 8)

readdir — 从目录句柄中读取条目

说明

readdir ( resource $dir_handle = ? ) : string

返回目录中下一个文件的文件名。文件名以在文件系统中的排序返回。

参数

dir_handle

目录句柄的 resource，之前由 opendir() 打开

返回值

成功则返回文件名 或者在失败时返回 false

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 列出目录中的所有文件

请留意下面例子中检查 readdir() 返回值的风格。这里明确地测试返回值是否全等于（值和类型都相同——更多信息参见比较运算符）false，否则任何目录项的名称求值为 false 的都会导致循环停止（例如一个目录名为"0"）。

<?php
// 注意在 4.0.0-RC2 之前不存在 !== 运算符

if ($handle = opendir('/path/to/files')) {
    echo "Directory handle: $handle\n";
    echo "Files:\n";

    /* 这是正确地遍历目录方法 */
    while (false !== ($file = readdir($handle))) {
        echo "$file\n";
    }

    /* 这是错误地遍历目录的方法 */
    while ($file = readdir($handle)) {
        echo "$file\n";
    }

    closedir($handle);
}
?>

Example #2 列出当前目录的所有文件并去掉 . 和 ..

<?php
if ($handle = opendir('.')) {
    while (false !== ($file = readdir($handle))) {
        if ($file != "." && $file != "..") {
            echo "$file\n";
        }
    }
    closedir($handle);
}
?>

参见

  • is_dir() - 判断给定文件名是否是一个目录
  • glob() - 寻找与模式匹配的文件路径
  • opendir() - 打开目录句柄
  • scandir() - 列出指定路径中的文件和目录


倒回目录句柄

  • ? readdir
  • scandir ?
  • PHP Manual
  • 目录函数函数
  • 倒回目录句柄

rewinddir

(PHP 4, PHP 5, PHP 7, PHP 8)

rewinddir — 倒回目录句柄

说明

rewinddir ( resource $dir_handle ) : void

将 dir_handle 指定的目录流重置到目录的开头。

参数

dir_handle

目录句柄的 resource，之前由 opendir() 打开


列出指定路径中的文件和目录

  • ? rewinddir
  • Fileinfo ?
  • PHP Manual
  • 目录函数函数
  • 列出指定路径中的文件和目录

scandir

(PHP 5, PHP 7, PHP 8)

scandir — 列出指定路径中的文件和目录

说明

scandir ( string $directory , int $sorting_order = ? , resource $context = ? ) : array

返回一个 array，包含有 directory 中的文件和目录。

参数

directory

要被浏览的目录

sorting_order

默认的排序顺序是按字母升序排列。如果使用了可选参数 sorting_order（设为 1），则排序顺序是按字母降序排列。

context

context 参数的说明见手册中的 Streams API 一章。

返回值

成功则返回包含有文件名的 array，如果失败则返回 false。如果 directory 不是个目录，则返回布尔值 false 并生成一条 E_WARNING 级的错误。

更新日志

版本 | 说明
5.4.0 | sorting_order now accepts constants. Any nonzero value caused descending order in previous versions.

范例

Example #1 一个简单的 scandir() 例子

<?php
$dir    = '/tmp';
$files1 = scandir($dir);
$files2 = scandir($dir, 1);

print_r($files1);
print_r($files2);
?>

以上例程的输出类似于：

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

Example #2 scandir() 在 PHP 4 中的实现

<?php
$dir = "/tmp";
$dh  = opendir($dir);
while (false !== ($filename = readdir($dh))) {
    $files[] = $filename;
}

sort($files);

print_r($files);

rsort($files);

print_r($files);

?>

以上例程的输出类似于：

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

注释

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参见

  • opendir() - 打开目录句柄
  • readdir() - 从目录句柄中读取条目
  • glob() - 寻找与模式匹配的文件路径
  • is_dir() - 判断给定文件名是否是一个目录
  • sort() - 对数组排序


文件信息

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Fileinfo 函数
    • finfo_buffer — 返回一个字符串缓冲区的信息
    • finfo_close — 关闭 fileinfo 资源
    • finfo_file — 返回一个文件的信息
    • finfo_open — 创建一个 fileinfo 资源
    • finfo_set_flags — 设置 libmagic 配置选项
    • mime_content_type — 检测文件的 MIME 类型
  • finfo — finfo 类
    • finfo::buffer — 别名 finfo_buffer()
    • finfo::__construct — 别名 finfo_open
    • finfo::file — 别名 finfo_file()
    • finfo::set_flags — 别名 finfo_set_flags()


简介

本模块中的函数通过在文件的给定位置查找特定的 魔术 字节序列 来猜测文件的内容类型以及编码。 虽然不是百分百的精确， 但是通常情况下能够很好的工作。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Fileinfo
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

PHP 5.3.0 之前的版本，需要 magic_open 库来 构建此扩展。


安装

从 PHP 5.3.0 开始，本扩展是默认开启的。 在之前的版本中，fileinfo 是一个 PECL 扩展，但是已经不再持续维护。 5.3+ 之前的版本， 可以使用 » 停止使用的 PECL 扩展。

Windows 用户需要在 php.ini 中开启绑定的 php_fileinfo.dll DLL 来启用本扩展。

PHP 中绑定了 libmagic 库，某些 PHP 版本变更中也可能包含此库。 在 PHP fileinfo 扩展的源代码中，有 libmagic.patch 文件， 这是 libmagic 库的补丁包文件。

绑定的 libmagic 库的更新历史
PHP 版本 | 更新的 libmagic 版本 | 说明
5.3.2 | 5.03 |
5.3.0 | 5.02 |


资源类型

Fileinfo 扩展中用到了 1 个资源： finfo_open() 函数返回的魔数数据库文件描述符。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

FILEINFO_NONE (integer)
无特殊处理。
FILEINFO_SYMLINK (integer)
跟随符号链接。
FILEINFO_MIME_TYPE (integer)
返回 mime 类型。 自 PHP 5.3.0 可用。
FILEINFO_MIME_ENCODING (integer)
返回文件的 mime 编码。 自 PHP 5.3.0 可用。
FILEINFO_MIME (integer)
按照 RFC 2045 定义的格式返回文件 mime 类型和编码。
FILEINFO_COMPRESS (integer)
解压缩压缩文件。 由于线程安全问题，自 PHP 5.3.0 禁用。
FILEINFO_DEVICES (integer)
查看设备的块内容或字符。
FILEINFO_CONTINUE (integer)
返回全部匹配的类型。
FILEINFO_PRESERVE_ATIME (integer)
如果可以的话，尽可能保持原始的访问时间。
FILEINFO_RAW (integer)
对于不可打印字符不转换成 \ooo 八进制表示格式。
FILEINFO_EXTENSION (integer)
根据 MIME 类型返回适当的文件扩展名。 有的文件类型具有多种扩展名，例如 JPEG 将会返回多个扩展名， 以斜杠分隔，比如 "jpeg/jpg/jpe/jfif"。 如果在 magic.mime 数据库里类型未知，则返回的是 "???"。 PHP 7.2.0 起有效。


Fileinfo 函数

Table of Contents

  • finfo_buffer — 返回一个字符串缓冲区的信息
  • finfo_close — 关闭 fileinfo 资源
  • finfo_file — 返回一个文件的信息
  • finfo_open — 创建一个 fileinfo 资源
  • finfo_set_flags — 设置 libmagic 配置选项
  • mime_content_type — 检测文件的 MIME 类型


返回一个字符串缓冲区的信息

  • ? Fileinfo 函数
  • finfo_close ?
  • PHP Manual
  • Fileinfo 函数
  • 返回一个字符串缓冲区的信息

finfo_buffer

finfo::buffer

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_buffer -- finfo::buffer — 返回一个字符串缓冲区的信息

说明

过程化风格

finfo_buffer ( resource $finfo , string $string = null , int $options = FILEINFO_NONE , resource $context = null ) : string

面向对象风格

public finfo::buffer ( string $string = null , int $options = FILEINFO_NONE , resource $context = null ) : string

本函数用来获取字符串中二进制数据的信息。

参数

finfo

finfo_open() 函数返回的 Fileinfo 资源。

string

要检查的文件内容。

options

一个 Fileinfo 常量 或多个 Fileinfo 常量 进行逻辑或运算。

context

返回值

返回 string 参数所指定内容的类型描述。 发生错误时返回 false 。

范例

Example #1 finfo_buffer() 函数例程

<?php
$finfo = new finfo(FILEINFO_MIME);
echo $finfo->buffer($_POST["script"]) . "\n";
?>

以上例程的输出类似于：

application/x-sh; charset=us-ascii

参见

  • finfo_file() - 别名 finfo_file()


关闭 fileinfo 资源

  • ? finfo_buffer
  • finfo_file ?
  • PHP Manual
  • Fileinfo 函数
  • 关闭 fileinfo 资源

finfo_close

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_close — 关闭 fileinfo 资源

说明

finfo_close ( resource $finfo ) : bool

关闭 finfo_open() 函数所返回的 fileinfo 资源。

参数

finfo

finfo_open() 函数所返回的 fileinfo 资源。

返回值

成功时返回 true， 或者在失败时返回 false。


返回一个文件的信息

  • ? finfo_close
  • finfo_open ?
  • PHP Manual
  • Fileinfo 函数
  • 返回一个文件的信息

finfo_file

finfo::file

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_file -- finfo::file — 返回一个文件的信息

说明

过程化风格

finfo_file ( resource $finfo , string $file_name = null , int $options = FILEINFO_NONE , resource $context = null ) : string

面向对象风格

public finfo::file ( string $file_name = null , int $options = FILEINFO_NONE , resource $context = null ) : string

本函数用来获取一个文件的信息。

参数

finfo

finfo_open() 函数所返回的 fileinfo 资源。

file_name

要检查的文件名。

options

一个 Fileinfo 常量 或多个 Fileinfo 常量 进行逻辑或运算。

context

关于 contexts 的更多描述，请参考 Stream 函数。

返回值

返回 file_name 参数指定的文件信息。 发生错误时返回 false 。

范例

Example #1 finfo_file() 例程

<?php
$finfo = finfo_open(FILEINFO_MIME_TYPE); // 返回 mime 类型
foreach (glob("*") as $filename) {
    echo finfo_file($finfo, $filename) . "\n";
}
finfo_close($finfo);
?>

以上例程的输出类似于：

text/html
image/gif
application/vnd.ms-excel

参见

  • finfo_buffer() - 别名 finfo_buffer()


创建一个 fileinfo 资源

  • ? finfo_file
  • finfo_set_flags ?
  • PHP Manual
  • Fileinfo 函数
  • 创建一个 fileinfo 资源

finfo_open

finfo::__construct

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_open -- finfo::__construct — 创建一个 fileinfo 资源

说明

过程化风格

finfo_open ( int $options = FILEINFO_NONE , string $magic_file = null ) : resource

面向对象风格 （构造器）：

public finfo::__construct ( int $options = FILEINFO_NONE , string $magic_file = null )

本函数打开一个魔数数据库并且返回它的资源。

参数

options

一个 Fileinfo 常量 或多个 Fileinfo 常量 进行逻辑或运算。

magic_file

魔数数据库文件名称， 通常是 /path/to/magic.mime。 如果未指定，则使用 MAGIC 环境变量。 如果未指定此环境变量， 则使用 PHP 绑定的魔数数据库。

传入 null 或者空字符串，等同于使用默认值。

返回值

（仅适用于过程化风格） 如果成功则返回一个表示魔数数据库的资源， 或者在失败时返回 false。

注释

Warning

在 PHP 5.3.11 和 5.4.1 中预期的魔数数据库格式发生了变动， 所以，内置的魔数数据库被更新。 如果使用了外部魔数数据库， 可能会由于格式不同导致读取失败。 同时，一些 mime 类型的文字表示也发生了变化， 例如，PHP 文件的 mime 类型由 ""PHP script text" 变为"PHP script, ASCII text"。

Note:

通常来说，使用 PHP 绑定的魔数数据库（设置 magic_file 参数为空， 不设置 MAGIC 环境变量）是最好的选择， 除非你确实需要一个自定义的魔数数据库。

范例

Example #1 面向对象风格

<?php
$finfo = new finfo(FILEINFO_MIME, "/usr/share/misc/magic"); // 返回 mime 类型

/* get mime-type for a specific file */
$filename = "/usr/local/something.txt";
echo $finfo->file($filename);

?>

Example #2 过程化风格

<?php
$finfo = finfo_open(FILEINFO_MIME, "/usr/share/misc/magic"); // 返回 mime 类型

if (!$finfo) {
    echo "Opening fileinfo database failed";
    exit();
}

/* 获取指定文件的 mime 类型 */
$filename = "/usr/local/something.txt";
echo finfo_file($finfo, $filename);

/* 关闭资源 */
finfo_close($finfo);
?>

以上例程会输出：

text/plain; charset=us-ascii

参见

  • finfo_close() - 关闭 fileinfo 资源


设置 libmagic 配置选项

  • ? finfo_open
  • mime_content_type ?
  • PHP Manual
  • Fileinfo 函数
  • 设置 libmagic 配置选项

finfo_set_flags

finfo::set_flags

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo_set_flags -- finfo::set_flags — 设置 libmagic 配置选项

说明

过程化风格

finfo_set_flags ( resource $finfo , int $options ) : bool

面向对象风格

public finfo::set_flags ( int $options ) : bool

此函数用来设置 Fileinfo 选项。 这些选项也可以在调用 finfo_open() 或者其他 Fileinfo 函数时直接指定。

参数

finfo

finfo_open() 返回的资源。

options

一个 Fileinfo 常量 或多个 Fileinfo 常量 进行逻辑或运算。

返回值

成功时返回 true， 或者在失败时返回 false。


检测文件的 MIME 类型

  • ? finfo_set_flags
  • finfo ?
  • PHP Manual
  • Fileinfo 函数
  • 检测文件的 MIME 类型

mime_content_type

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mime_content_type — 检测文件的 MIME 类型

说明

mime_content_type ( string $filename ) : string

返回通过使用 magic.mime 检测到的文件 MIME 类型。

参数

filename

要检测的文件名。

返回值

返回文件的 MIME 内容类型，例如 text/plain 或 application/octet-stream。 或者在失败时返回 false。

错误／异常

失败时抛出E_WARNING警告。

范例

Example #1 mime_content_type() 示例

<?php
echo mime_content_type('php.gif') . "\n";
echo mime_content_type('test.php');
?>

以上例程会输出：

image/gif
text/plain

参见

  • finfo_file() - 别名 finfo_file()
  • finfo_buffer() - 别名 finfo_buffer()


finfo 类

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

简介

该类在 fileinfo 函数集中提供了一个面向对象的接口。

类摘要

finfo {
public __construct ( int $flags = FILEINFO_NONE , string $magic_database = "" )
public buffer ( string $string , int $flags = FILEINFO_NONE , resource|null $context = null ) : string|false
public file ( string $filename , int $flags = FILEINFO_NONE , resource|null $context = null ) : string|false
public set_flags ( int $flags ) : bool
}

Table of Contents

  • finfo::buffer — 别名 finfo_buffer()
  • finfo::__construct — 别名 finfo_open
  • finfo::file — 别名 finfo_file()
  • finfo::set_flags — 别名 finfo_set_flags()


别名 finfo_buffer()

  • ? finfo
  • finfo::__construct ?
  • PHP Manual
  • finfo
  • 别名 finfo_buffer()

finfo::buffer

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo::buffer — 别名 finfo_buffer()

说明

public finfo::buffer ( string $string , int $flags = FILEINFO_NONE , resource|null $context = null ) : string|false

此函数是该函数的别名： finfo_buffer()


别名 finfo_open

  • ? finfo::buffer
  • finfo::file ?
  • PHP Manual
  • finfo
  • 别名 finfo_open

finfo::__construct

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo::__construct — 别名 finfo_open()

说明

public finfo::__construct ( int $flags = FILEINFO_NONE , string $magic_database = "" )

此函数是该函数的别名： finfo_open()


别名 finfo_file()

  • ? finfo::__construct
  • finfo::set_flags ?
  • PHP Manual
  • finfo
  • 别名 finfo_file()

finfo::file

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo::file — 别名 finfo_file()

说明

public finfo::file ( string $filename , int $flags = FILEINFO_NONE , resource|null $context = null ) : string|false

此函数是该函数的别名： finfo_file()


别名 finfo_set_flags()

  • ? finfo::file
  • 文件系统 ?
  • PHP Manual
  • finfo
  • 别名 finfo_set_flags()

finfo::set_flags

(PHP >= 5.3.0, PHP 7, PHP 8, PECL fileinfo >= 0.1.0)

finfo::set_flags — 别名 finfo_set_flags()

说明

public finfo::set_flags ( int $flags ) : bool

此函数是该函数的别名： finfo_set_flags()


文件系统

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 文件系统函数
    • basename — 返回路径中的文件名部分
    • chgrp — 改变文件所属的组
    • chmod — 改变文件模式
    • chown — 改变文件的所有者
    • clearstatcache — 清除文件状态缓存
    • copy — 拷贝文件
    • delete — 参见 unlink 或 unset
    • dirname — 返回路径中的目录部分
    • disk_free_space — 返回目录中的可用空间
    • disk_total_space — 返回一个目录的磁盘总大小
    • diskfreespace — disk_free_space 的别名
    • fclose — 关闭一个已打开的文件指针
    • feof — 测试文件指针是否到了文件结束的位置
    • fflush — 将缓冲内容输出到文件
    • fgetc — 从文件指针中读取字符
    • fgetcsv — 从文件指针中读入一行并解析 CSV 字段
    • fgets — 从文件指针中读取一行
    • fgetss — 从文件指针中读取一行并过滤掉 HTML 标记
    • file_exists — 检查文件或目录是否存在
    • file_get_contents — 将整个文件读入一个字符串
    • file_put_contents — 将一个字符串写入文件
    • file — 把整个文件读入一个数组中
    • fileatime — 取得文件的上次访问时间
    • filectime — 取得文件的 inode 修改时间
    • filegroup — 取得文件的组
    • fileinode — 取得文件的 inode
    • filemtime — 取得文件修改时间
    • fileowner — 取得文件的所有者
    • fileperms — 取得文件的权限
    • filesize — 取得文件大小
    • filetype — 取得文件类型
    • flock — 轻便的咨询文件锁定
    • fnmatch — 用模式匹配文件名
    • fopen — 打开文件或者 URL
    • fpassthru — 输出文件指针处的所有剩余数据
    • fputcsv — 将行格式化为 CSV 并写入文件指针
    • fputs — fwrite 的别名
    • fread — 读取文件（可安全用于二进制文件）
    • fscanf — 从文件中格式化输入
    • fseek — 在文件指针中定位
    • fstat — 通过已打开的文件指针取得文件信息
    • ftell — 返回文件指针读/写的位置
    • ftruncate — 将文件截断到给定的长度
    • fwrite — 写入文件（可安全用于二进制文件）
    • glob — 寻找与模式匹配的文件路径
    • is_dir — 判断给定文件名是否是一个目录
    • is_executable — 判断给定文件名是否可执行
    • is_file — 判断给定文件名是否为一个正常的文件
    • is_link — 判断给定文件名是否为一个符号连接
    • is_readable — 判断给定文件名是否可读
    • is_uploaded_file — 判断文件是否是通过 HTTP POST 上传的
    • is_writable — 判断给定的文件名是否可写
    • is_writeable — is_writable 的别名
    • lchgrp — 修改符号链接的所有组
    • lchown — 修改符号链接的所有者
    • link — 建立一个硬连接
    • linkinfo — 获取一个连接的信息
    • lstat — 给出一个文件或符号连接的信息
    • mkdir — 新建目录
    • move_uploaded_file — 将上传的文件移动到新位置
    • parse_ini_file — 解析一个配置文件
    • parse_ini_string — 解析配置字符串
    • pathinfo — 返回文件路径的信息
    • pclose — 关闭进程文件指针
    • popen — 打开进程文件指针
    • readfile — 输出文件
    • readlink — 返回符号连接指向的目标
    • realpath_cache_get — 获取真实目录缓存的详情
    • realpath_cache_size — 获取真实路径缓冲区的大小
    • realpath — 返回规范化的绝对路径名
    • rename — 重命名一个文件或目录
    • rewind — 倒回文件指针的位置
    • rmdir — 删除目录
    • set_file_buffer — stream_set_write_buffer 的别名
    • stat — 给出文件的信息
    • symlink — 建立符号连接
    • tempnam — 建立一个具有唯一文件名的文件
    • tmpfile — 建立一个临时文件
    • touch — 设定文件的访问和修改时间
    • umask — 改变当前的 umask
    • unlink — 删除文件


简介

编译此扩展无需任何额外的库，但想要 PHP 支持 Linux 的 LFS（large files），需要最新的 glibc，并在编译 PHP 时带上以下标记： -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

文件系统和流配置选项
名字 | 默认 | 可修改范围 | 更新日志
allow_url_fopen | "1" | PHP_INI_SYSTEM | 在 PHP <= 4.3.4 时是 PHP_INI_ALL。PHP 4.0.4 版以后可用。
user_agent | NULL | PHP_INI_ALL | PHP 4.3.0 版以后可用。
default_socket_timeout | "60" | PHP_INI_ALL | PHP 4.3.0 版以后可用。
from | "" | PHP_INI_ALL |
auto_detect_line_endings | "0" | PHP_INI_ALL | PHP 4.3.0 版以后可用。

这是配置指令的简短说明。

allow_url_fopen boolean

本选项激活了 URL 形式的 fopen 封装协议使得可以访问 URL 对象例如文件。默认的封装协议提供用 ftp 和 http 协议来访问远程文件，一些扩展库例如 zlib 可能会注册更多的封装协议。

Note:

出于安全性考虑，此选项只能在 php.ini 中设置。

Note:

此选项是紧接着版本 4.0.3 发布后引进的。版本 4.0.3 以及之前的版本只能在编译时通过配置项 --disable-url-fopen-wrapper 来取消此特性。

Warning

Windows 版在 PHP 4.3.0 之前，以下函数不支持远程文件访问：include，include_once, require，require_once 和GD 和图像处理 函数中的 imagecreatefromXXX 函数。

allow_url_include boolean

This option allows the use of URL-aware fopen wrappers with the following functions: include, include_once, require, require_once.

Note:

This setting requires allow_url_fopen to be on.

user_agent string

定义 PHP 发送的 User-Agent。

default_socket_timeout integer

基于 socket 的流的默认超时时间（秒）。

Note: 本配置参数是 PHP 4.3.0 引进的。

from string

定义匿名 ftp 的密码（email 地址）。

auto_detect_line_endings boolean

当设为 On 时，PHP 将检查通过 fgets() 和 file() 取得的数据中的行结束符号是符合 Unix，MS-DOS，还是 Macintosh 的习惯。

这使得 PHP 可以和 Macintosh 系统交互操作，但是默认值是 Off，因为在检测第一行的 EOL 习惯时会有很小的性能损失，而且在 Unix 系统下使用回车符号作为项目分隔符的人们会遭遇向下不兼容的行为。

Note: 本配置参数是 PHP 4.3.0 引进的。


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

文件系统使用 streams 作为资源类型。 Streams 的文档有专门的章节：Streams。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SEEK_SET (integer)
SEEK_CUR (integer)
SEEK_END (integer)
LOCK_SH (integer)
LOCK_EX (integer)
LOCK_UN (integer)
LOCK_NB (integer)
GLOB_BRACE (integer)
GLOB_ONLYDIR (integer)
GLOB_MARK (integer)
GLOB_NOSORT (integer)
GLOB_NOCHECK (integer)
GLOB_NOESCAPE (integer)
GLOB_AVAILABLE_FLAGS (integer)
PATHINFO_DIRNAME (integer)
PATHINFO_BASENAME (integer)
PATHINFO_EXTENSION (integer)
PATHINFO_FILENAME (integer)
自 PHP 5.2.0 起
FILE_USE_INCLUDE_PATH (integer)
在 include_path 里搜索 filename。
FILE_NO_DEFAULT_CONTEXT (integer)
FILE_APPEND (integer)
为存在的文件添加内容。
FILE_IGNORE_NEW_LINES (integer)
过滤换行（EOL）字符。
FILE_SKIP_EMPTY_LINES (integer)
过滤空行。
FILE_BINARY (integer)

二进制模式（自 PHP 5.2.7 起）。

Note:

此常量无效，仅仅用于向后兼容（forward compatibility）。

FILE_TEXT (integer)

文本模式 (自 PHP 5.2.7 起)。

Note:

此常量无效，仅仅用于向后兼容（forward compatibility）。

INI_SCANNER_NORMAL (integer)
普通的 INI 扫描模式（自 PHP 5.3 起）。
INI_SCANNER_RAW (integer)
原始（Raw） INI 扫描模式（自 PHP 5.3 起）。
INI_SCANNER_TYPED (integer)
Typed INI 扫描模式（自 PHP 5.5.6.1 起）。
FNM_NOESCAPE (integer)
禁用反斜线转义
FNM_PATHNAME (integer)
字符串里的斜杠只匹配指定模式里的斜杠。
FNM_PERIOD (integer)
字符串里的起始点号必须完全匹配指定模式里的点号。
FNM_CASEFOLD (integer)
大小写不敏感的匹配，GNU 扩展的一部分。


文件系统函数

参见

相关函数参见目录和程序执行章节。

远程文件能使用的 URL 包装器（ wrapper）列表和详细解释，可参见 支持的协议和封装协议。

Table of Contents

  • basename — 返回路径中的文件名部分
  • chgrp — 改变文件所属的组
  • chmod — 改变文件模式
  • chown — 改变文件的所有者
  • clearstatcache — 清除文件状态缓存
  • copy — 拷贝文件
  • delete — 参见 unlink 或 unset
  • dirname — 返回路径中的目录部分
  • disk_free_space — 返回目录中的可用空间
  • disk_total_space — 返回一个目录的磁盘总大小
  • diskfreespace — disk_free_space 的别名
  • fclose — 关闭一个已打开的文件指针
  • feof — 测试文件指针是否到了文件结束的位置
  • fflush — 将缓冲内容输出到文件
  • fgetc — 从文件指针中读取字符
  • fgetcsv — 从文件指针中读入一行并解析 CSV 字段
  • fgets — 从文件指针中读取一行
  • fgetss — 从文件指针中读取一行并过滤掉 HTML 标记
  • file_exists — 检查文件或目录是否存在
  • file_get_contents — 将整个文件读入一个字符串
  • file_put_contents — 将一个字符串写入文件
  • file — 把整个文件读入一个数组中
  • fileatime — 取得文件的上次访问时间
  • filectime — 取得文件的 inode 修改时间
  • filegroup — 取得文件的组
  • fileinode — 取得文件的 inode
  • filemtime — 取得文件修改时间
  • fileowner — 取得文件的所有者
  • fileperms — 取得文件的权限
  • filesize — 取得文件大小
  • filetype — 取得文件类型
  • flock — 轻便的咨询文件锁定
  • fnmatch — 用模式匹配文件名
  • fopen — 打开文件或者 URL
  • fpassthru — 输出文件指针处的所有剩余数据
  • fputcsv — 将行格式化为 CSV 并写入文件指针
  • fputs — fwrite 的别名
  • fread — 读取文件（可安全用于二进制文件）
  • fscanf — 从文件中格式化输入
  • fseek — 在文件指针中定位
  • fstat — 通过已打开的文件指针取得文件信息
  • ftell — 返回文件指针读/写的位置
  • ftruncate — 将文件截断到给定的长度
  • fwrite — 写入文件（可安全用于二进制文件）
  • glob — 寻找与模式匹配的文件路径
  • is_dir — 判断给定文件名是否是一个目录
  • is_executable — 判断给定文件名是否可执行
  • is_file — 判断给定文件名是否为一个正常的文件
  • is_link — 判断给定文件名是否为一个符号连接
  • is_readable — 判断给定文件名是否可读
  • is_uploaded_file — 判断文件是否是通过 HTTP POST 上传的
  • is_writable — 判断给定的文件名是否可写
  • is_writeable — is_writable 的别名
  • lchgrp — 修改符号链接的所有组
  • lchown — 修改符号链接的所有者
  • link — 建立一个硬连接
  • linkinfo — 获取一个连接的信息
  • lstat — 给出一个文件或符号连接的信息
  • mkdir — 新建目录
  • move_uploaded_file — 将上传的文件移动到新位置
  • parse_ini_file — 解析一个配置文件
  • parse_ini_string — 解析配置字符串
  • pathinfo — 返回文件路径的信息
  • pclose — 关闭进程文件指针
  • popen — 打开进程文件指针
  • readfile — 输出文件
  • readlink — 返回符号连接指向的目标
  • realpath_cache_get — 获取真实目录缓存的详情
  • realpath_cache_size — 获取真实路径缓冲区的大小
  • realpath — 返回规范化的绝对路径名
  • rename — 重命名一个文件或目录
  • rewind — 倒回文件指针的位置
  • rmdir — 删除目录
  • set_file_buffer — stream_set_write_buffer 的别名
  • stat — 给出文件的信息
  • symlink — 建立符号连接
  • tempnam — 建立一个具有唯一文件名的文件
  • tmpfile — 建立一个临时文件
  • touch — 设定文件的访问和修改时间
  • umask — 改变当前的 umask
  • unlink — 删除文件


返回路径中的文件名部分

  • ? 文件系统函数
  • chgrp ?
  • PHP Manual
  • 文件系统函数
  • 返回路径中的文件名部分

basename

(PHP 4, PHP 5, PHP 7, PHP 8)

basename — 返回路径中的文件名部分

说明

basename ( string $path , string $suffix = ? ) : string

给出一个包含有指向一个文件的全路径的字符串，本函数返回基本的文件名。

Note:

basename() 纯粹基于输入字符串操作， 它不会受实际文件系统和类似 ".." 的路径格式影响。

Caution

basename() 是本地化的， 所以如果要正确处理多字节字符的路径， 需要用 setlocale() 正确设置匹配的 locale。

参数

path

一个路径。

在 Windows 中，斜线（/）和反斜线（\）都可以用作目录分隔符。在其它环境下是斜线（/）。

suffix

如果文件名是以 suffix 结束的，那这一部分也会被去掉。

返回值

Returns the base name of the given path. 返回 path 的基本的文件名。

范例

Example #1 basename() 例子

<?php
echo "1) ".basename("/etc/sudoers.d", ".d").PHP_EOL;
echo "2) ".basename("/etc/sudoers.d").PHP_EOL;
echo "3) ".basename("/etc/passwd").PHP_EOL;
echo "4) ".basename("/etc/").PHP_EOL;
echo "5) ".basename(".").PHP_EOL;
echo "6) ".basename("/");
?>

以上例程会输出：

1) sudoers
2) sudoers.d
3) passwd
4) etc
5) .
6)

参见

  • dirname() - 返回路径中的目录部分
  • pathinfo() - 返回文件路径的信息


改变文件所属的组

  • ? basename
  • chmod ?
  • PHP Manual
  • 文件系统函数
  • 改变文件所属的组

chgrp

(PHP 4, PHP 5, PHP 7, PHP 8)

chgrp — 改变文件所属的组

说明

chgrp ( string $filename , mixed $group ) : bool

尝试将文件 filename 所属的组改成 group（通过组名或组 ID 指定）。

只有超级用户可以任意修改文件的组，其它用户可能只能将文件的组改成该用户自己所在的组。

参数

filename

文件的路径。

group

组的名称或数字。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 改变文件所属的组

<?php
$filename = 'shared_file.txt';
$format = "%s's Group ID @ %s: %d\n";
printf($format, $filename, date('r'), filegroup($filename));
chgrp($filename, 8);
clearstatcache(); // do not cache filegroup() results
printf($format, $filename, date('r'), filegroup($filename));
?>

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

Note: On Windows, this function fails silently when applied on a regular file.

参见

  • chown() - 改变文件的所有者
  • chmod() - 改变文件模式


改变文件模式

  • ? chgrp
  • chown ?
  • PHP Manual
  • 文件系统函数
  • 改变文件模式

chmod

(PHP 4, PHP 5, PHP 7, PHP 8)

chmod — 改变文件模式

说明

chmod ( string $filename , int $mode ) : bool

尝试将 filename 所指定文件的模式改成 mode 所给定的。

参数

filename

文件的路径。

mode

注意 mode 不会被自动当成八进制数值，而且也不能用字符串（例如 "g+w"）。要确保正确操作，需要给 mode 前面加上 0：

<?php
chmod("/somedir/somefile", 755);   // 十进制数，可能不对
chmod("/somedir/somefile", "u+rwx,go+rx"); // 字符串，不对
chmod("/somedir/somefile", 0755);  // 八进制数，正确的 mode 值
?>

mode 参数包含三个八进制数按顺序分别指定了所有者、所有者所在的组以及所有人的访问限制。每一部分都可以通过加入所需的权限来计算出所要的权限。数字 1 表示使文件可执行，数字 2 表示使文件可写，数字 4 表示使文件可读。加入这些数字来制定所需要的权限。有关 UNIX 系统的文件权限可以阅读手册"man 1 chmod"和"man 2 chmod"。

<?php
// Read and write for owner, nothing for everybody else
chmod("/somedir/somefile", 0600);

// Read and write for owner, read for everybody else
chmod("/somedir/somefile", 0644);

// Everything for owner, read and execute for others
chmod("/somedir/somefile", 0755);

// Everything for owner, read and execute for owner's group
chmod("/somedir/somefile", 0750);
?>

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

当前用户指的是执行 PHP 的用户。很可能和通常的 shell 或者 FTP 用户不是同一个。在大多数系统下文件模式只能被文件所有者的用户改变。

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

参见

  • chown() - 改变文件的所有者
  • chgrp() - 改变文件所属的组
  • fileperms() - 取得文件的权限
  • stat() - 给出文件的信息


改变文件的所有者

  • ? chmod
  • clearstatcache ?
  • PHP Manual
  • 文件系统函数
  • 改变文件的所有者

chown

(PHP 4, PHP 5, PHP 7, PHP 8)

chown — 改变文件的所有者

说明

chown ( string $filename , mixed $user ) : bool

尝试将文件 filename 的所有者改成用户 user（由用户名或用户 ID 指定）。 只有超级用户可以改变文件的所有者。

参数

filename

文件路径。

user

用户名或数字。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 简单的 chown() 用法

<?php

// File name and username to use
$file_name= "foo.php";
$path = "/home/sites/php.net/public_html/sandbox/" . $file_name ;
$user_name = "root";

// Set the user
chown($path, $user_name);

// Check the result
$stat = stat($path);
print_r(posix_getpwuid($stat['uid']));

?>

以上例程的输出类似于：

Array
(
    [name] => root
    [passwd] => x
    [uid] => 0
    [gid] => 0
    [gecos] => root
    [dir] => /root
    [shell] => /bin/bash
)

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

Note: 在 Windows 上对普通文件使用此函数会静默失败。

参见

  • chmod() - 改变文件模式
  • chgrp() - 改变文件所属的组


清除文件状态缓存

  • ? chown
  • copy ?
  • PHP Manual
  • 文件系统函数
  • 清除文件状态缓存

clearstatcache

(PHP 4, PHP 5, PHP 7, PHP 8)

clearstatcache — 清除文件状态缓存

说明

clearstatcache ( bool $clear_realpath_cache = false , string $filename = ? ) : void

当使用 stat()，lstat() 或者任何列在受影响函数表（见下面）中的函数时，PHP 将缓存这些函数的返回信息以提供更快的性能。然而在某些情况下，你可能想清除被缓存的信息。例如如果在一个脚本中多次检查同一个文件，而该文件在此脚本执行期间有被删除或修改的危险时，你需要清除文件状态缓存。这种情况下，可以用 clearstatcache() 函数来清除被 PHP 缓存的该文件信息。

必须注意的是，对于不存在的文件，PHP 并不会缓存其信息。所以如果调用 file_exists() 来检查不存在的文件，在该文件没有被创建之前，它都会返回 false。如果该文件被创建了，就算以后被删除，它都会返回 true 函数 unlink() 会自动清除该缓存.

Note:

本函数缓存特定文件名的信息，因此只在对同一个文件名进行多次操作并且需要该文件信息不被缓存时才需要调用 clearstatcache()。

受影响的函数包括
stat()，
lstat()，
file_exists()，
is_writable()，
is_readable()，
is_executable()，
is_file()，
is_dir()，
is_link()，
filectime()，
fileatime()，
filemtime()，
fileinode()，
filegroup()，
fileowner()，
filesize()，
filetype()
和 fileperms()。

参数

clear_realpath_cache

是否清除真实路径缓存

filename

清除文件名指定的文件的真实路径缓存; 只在 clear_realpath_cache 为 true 时启用

返回值

没有返回值。

更新日志

版本 | 说明
5.3.0 | 增加了可选的 clear_realpath_cache 和 filename 参数.

范例

Example #1 clearstatcache() 例子

<?php
$file = 'output_log.txt';

function get_owner($file)
{
    $stat = stat($file);
    $user = posix_getpwuid($stat['uid']);
    return $user['name'];
}

$format = "UID @ %s: %s\n";

printf($format, date('r'), get_owner($file));

chown($file, 'ross');
printf($format, date('r'), get_owner($file));

clearstatcache();
printf($format, date('r'), get_owner($file));
?>

以上例程的输出类似于：

UID @ Sun, 12 Oct 2008 20:48:28 +0100: root
UID @ Sun, 12 Oct 2008 20:48:28 +0100: root
UID @ Sun, 12 Oct 2008 20:48:28 +0100: ross


拷贝文件

  • ? clearstatcache
  • delete ?
  • PHP Manual
  • 文件系统函数
  • 拷贝文件

copy

(PHP 4, PHP 5, PHP 7, PHP 8)

copy — 拷贝文件

说明

copy ( string $source , string $dest , resource $context = ? ) : bool

将文件从 source 拷贝到 dest。

如果要移动文件的话，请使用 rename() 函数。

参数

source

源文件路径。

dest

目标路径。如果 dest 是一个 URL，则如果封装协议不支持覆盖已有的文件时拷贝操作会失败。

Warning

如果目标文件已存在，将会被覆盖。

context

A valid context resource created with stream_context_create().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 copy() 例子

<?php
$file = 'example.txt';
$newfile = 'example.txt.bak';

if (!copy($file, $newfile)) {
    echo "failed to copy $file...\n";
}
?>

参见

  • move_uploaded_file() - 将上传的文件移动到新位置
  • rename() - 重命名一个文件或目录
  • The section of the manual about handling file uploads


参见 unlink 或 unset

  • ? copy
  • dirname ?
  • PHP Manual
  • 文件系统函数
  • 参见 unlink 或 unset

delete

(None)

delete — 参见 unlink() 或 unset()

说明

在 PHP 语言里，没有 delete 关键词或函数。在这里，你若要删除文件，可以使用 unlink()。在本地作用域删除变量可使用 unset()。

参见

  • unlink() - 删除文件
  • unset() - 释放给定的变量


返回路径中的目录部分

  • ? delete
  • disk_free_space ?
  • PHP Manual
  • 文件系统函数
  • 返回路径中的目录部分

dirname

(PHP 4, PHP 5, PHP 7, PHP 8)

dirname — 返回路径中的目录部分

说明

dirname ( string $path , int $levels = 1 ) : string

给出一个包含有指向一个文件的全路径的字符串，本函数返回去掉文件名后的目录名，且目录深度为 levels 级。

Note:

dirname() 纯粹基于输入字符串操作， 它不会受实际文件系统和类似 ".." 的路径格式影响。

Caution

dirname() 是本地化的，所以如果要正确处理多字节字符的路径，需要用 setlocale() 正确设置匹配的 locale。

参数

path

一个路径。

在 Windows 中，斜线（/）和反斜线（\）都可以用作目录分隔符。在其它环境下是斜线（/）。

levels

要向上的父目录数量。

整型，必须大于 0。

返回值

返回 path 的父目录。 如果在 path 中没有斜线，则返回一个点（'.'），表示当前目录。否则返回的是把 path 中结尾的 /component（最后一个斜线以及后面部分）去掉之后的字符串。

更新日志

版本 | 说明
7.0.0 | 添加可选的 levels 参数。

范例

Example #1 dirname() 例子

<?php
echo dirname("/etc/passwd") . PHP_EOL;
echo dirname("/etc/") . PHP_EOL;
echo dirname(".") . PHP_EOL;
echo dirname("C:\\") . PHP_EOL;
echo dirname("/usr/local/lib", 2);

以上例程的输出类似于：

/etc
/ (or \ on Windows)
.
C:\
/usr

参见

  • basename() - 返回路径中的文件名部分
  • pathinfo() - 返回文件路径的信息
  • realpath() - 返回规范化的绝对路径名


返回目录中的可用空间

  • ? dirname
  • disk_total_space ?
  • PHP Manual
  • 文件系统函数
  • 返回目录中的可用空间

disk_free_space

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

disk_free_space — 返回目录中的可用空间

说明

disk_free_space ( string $directory ) : float

给出一个包含有一个目录的字符串，本函数将根据相应的文件系统或磁盘分区返回可用的字节数。

参数

directory

文件系统目录或者磁盘分区。

Note:

如果指定了文件名而不是文件目录，这个函数的行为将并不统一，会因操作系统和 PHP 版本而异。

返回值

以浮点返回可用的字节数， 或者在失败时返回 false。

范例

Example #1 disk_free_space() 例子

<?php
// $df 包含根目录下可用的字节数
$df = disk_free_space("/");

//在 Windows 下:
$df_c = disk_free_space("C:");
$df_d = disk_free_space("D:");
?>

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

参见

  • disk_total_space() - 返回一个目录的磁盘总大小


返回一个目录的磁盘总大小

  • ? disk_free_space
  • diskfreespace ?
  • PHP Manual
  • 文件系统函数
  • 返回一个目录的磁盘总大小

disk_total_space

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

disk_total_space — 返回一个目录的磁盘总大小

说明

disk_total_space ( string $directory ) : float

给出一个包含有一个目录的字符串，本函数将根据相应的文件系统或磁盘分区返回所有的字节数。 【译者注】本函数返回的是该目录所在的磁盘分区的总大小，因此在给出同一个磁盘分区的不同目录作为参数所得到的结果完全相同。 在 Unix 和 Windows 200x/XP 中都支持将一个磁盘分区加载为一个子目录，这时正确使用本函数就很有意义。

参数

directory

文件系统的目录或者磁盘分区。

返回值

以浮点返回一个目录的磁盘总大小字节数， 或者在失败时返回 false。

范例

Example #1 disk_total_space() 例子

<?php
// $df 包含 "/" 目录的磁盘大小
$ds = disk_total_space("/");

//在 Windows 下:
$ds = disk_total_space("C:");
$ds = disk_total_space("D:");
?>

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

参见

  • disk_free_space() - 返回目录中的可用空间


disk_free_space 的别名

  • ? disk_total_space
  • fclose ?
  • PHP Manual
  • 文件系统函数
  • disk_free_space 的别名

diskfreespace

(PHP 4, PHP 5, PHP 7, PHP 8)

diskfreespace — disk_free_space() 的别名

说明

此函数是该函数的别名：disk_free_space()。


关闭一个已打开的文件指针

  • ? diskfreespace
  • feof ?
  • PHP Manual
  • 文件系统函数
  • 关闭一个已打开的文件指针

fclose

(PHP 4, PHP 5, PHP 7, PHP 8)

fclose — 关闭一个已打开的文件指针

说明

fclose ( resource $handle ) : bool

将 handle 指向的文件关闭。

参数

handle

文件指针必须有效，并且是通过 fopen() 或 fsockopen() 成功打开的。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 一个简单 fclose() 例子

<?php

$handle = fopen('somefile.txt', 'r');

fclose($handle);

?>

参见

  • fopen() - 打开文件或者 URL
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接


测试文件指针是否到了文件结束的位置

  • ? fclose
  • fflush ?
  • PHP Manual
  • 文件系统函数
  • 测试文件指针是否到了文件结束的位置

feof

(PHP 4, PHP 5, PHP 7, PHP 8)

feof — 测试文件指针是否到了文件结束的位置

说明

feof ( resource $handle ) : bool

测试文件指针是否到了文件结束的位。

参数

handle

文件指针必须是有效的，必须指向由 fopen() 或 fsockopen() 成功打开的文件(并还未由 fclose() 关闭)。

返回值

如果文件指针到了 EOF 或者出错时则返回 true，否则返回一个错误（包括 socket 超时），其它情况则返回 false。

注释

Warning

如果服务器没有关闭由 fsockopen() 所打开的连接，feof() 会一直等待直到超时。要解决这个问题可参见以下范例：

Example #1 处理 feof() 的超时

<?php
function safe_feof($fp, &$start = NULL) {
 $start = microtime(true);

 return feof($fp);
}

/* $fp 的赋值是由之前 fsockopen() 打开  */

$start = NULL;
$timeout = ini_get('default_socket_timeout');

while(!safe_feof($fp, $start) && (microtime(true) - $start) < $timeout)
{
 /* Handle */
}
?>

Warning

如果传递的文件指针无效可能会陷入无限循环中，因为 feof() 不会返回 true。

Example #2 使用无效文件指针的 feof() 例子

<?php
// 如果文件不可读取或者不存在，fopen 函数返回 FALSE
$file = @fopen("no_such_file", "r");

// 来自 fopen 的 FALSE 会发出一条警告信息并在这里陷入无限循环
while (!feof($file)) {
}

fclose($file);
?>


将缓冲内容输出到文件

  • ? feof
  • fgetc ?
  • PHP Manual
  • 文件系统函数
  • 将缓冲内容输出到文件

fflush

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

fflush — 将缓冲内容输出到文件

说明

fflush ( resource $handle ) : bool

本函数强制将所有缓冲的输出写入 handle 文件句柄所指向的资源。 成功时返回 true， 或者在失败时返回 false。

文件指针必须是有效的，必须指向由 fopen() 或 fsockopen() 成功打开的文件(并还未由 fclose() 关闭)。

参数

handle

文件指针必须是有效的，必须指向由 fopen() 或 fsockopen() 成功打开的文件(并还未由 fclose() 关闭)。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 File write example using fflush()

<?php
$filename = 'bar.txt';

$file = fopen($filename, 'r+');
rewind($file);
fwrite($file, 'Foo');
fflush($file);
ftruncate($file, ftell($file));
fclose($file);
?>

参见

  • clearstatcache() - 清除文件状态缓存
  • fwrite() - 写入文件（可安全用于二进制文件）


从文件指针中读取字符

  • ? fflush
  • fgetcsv ?
  • PHP Manual
  • 文件系统函数
  • 从文件指针中读取字符

fgetc

(PHP 4, PHP 5, PHP 7, PHP 8)

fgetc — 从文件指针中读取字符

说明

fgetc ( resource $handle ) : string

从文件句柄中获取一个字符。

参数

handle

文件指针必须是有效的，必须指向由 fopen() 或 fsockopen() 成功打开的文件(并还未由 fclose() 关闭)。

返回值

返回一个包含有一个字符的字符串，该字符从 handle 指向的文件中得到。 碰到 EOF 则返回 false。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 一个 fgetc() 例子

<?php
$fp = fopen('somefile.txt', 'r');
if (!$fp) {
    echo 'Could not open file somefile.txt';
}
while (false !== ($char = fgetc($fp))) {
    echo "$char\n";
}
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • fread() - 读取文件（可安全用于二进制文件）
  • fopen() - 打开文件或者 URL
  • popen() - 打开进程文件指针
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接
  • fgets() - 从文件指针中读取一行


从文件指针中读入一行并解析 CSV 字段

  • ? fgetc
  • fgets ?
  • PHP Manual
  • 文件系统函数
  • 从文件指针中读入一行并解析 CSV 字段

fgetcsv

(PHP 4, PHP 5, PHP 7, PHP 8)

fgetcsv — 从文件指针中读入一行并解析 CSV 字段

说明

fgetcsv ( resource $handle , int $length = 0 , string $delimiter = ',' , string $enclosure = '"' , string $escape = '\\' ) : array

和 fgets() 类似，只除了 fgetcsv() 解析读入的行并找出 CSV 格式的字段然后返回一个包含这些字段的数组。

参数

handle

一个由 fopen()、popen() 或 fsockopen() 产生的有效文件指针。

length

必须大于 CVS 文件内最长的一行。在 PHP 5 中该参数是可选的。如果忽略（在 PHP 5.0.4 以后的版本中设为 0）该参数的话，那么长度就没有限制，不过可能会影响执行效率。

delimiter

设置字段分界符（只允许一个字符）。

enclosure

设置字段环绕符（只允许一个字符）。

escape

设置转义字符（只允许一个字符），默认是一个反斜杠。

返回值

返回包含读取字段的索引数组。

Note:

CSV 文件中的空行将被返回为一个包含有单个 null 字段的数组，不会被当成错误。

Note: 在读取在 Macintosh 电脑中或由其创建的文件时， 如果 PHP 不能正确的识别行结束符，启用运行时配置可选项 auto_detect_line_endings 也许可以解决此问题。

如果提供了无效的文件指针，fgetcsv() 会返回 null。 其他错误，包括碰到文件结束时返回 false，。

更新日志

版本 | 说明
5.3.0 | 增加了 escape 参数。
4.3.5 | 现在起 fgetcsv() 的操作是二进制安全的。
4.3.0 | 增加了 enclosure 参数。

范例

Example #1 读取并显示 CSV 文件的整个内容

<?php
$row = 1;
if (($handle = fopen("test.csv", "r")) !== FALSE) {
    while (($data = fgetcsv($handle, 1000, ",")) !== FALSE) {
        $num = count($data);
        echo "<p> $num fields in line $row: <br /></p>\n";
        $row++;
        for ($c=0; $c < $num; $c++) {
            echo $data[$c] . "<br />\n";
        }
    }
    fclose($handle);
}
?>

注释

Note:

该函数对区域设置是敏感的。比如说 LANG 设为 en_US.UTF-8 的话，单字节编码的文件就会出现读取错误。

参见

  • str_getcsv() - 解析 CSV 字符串为一个数组
  • explode() - 使用一个字符串分割另一个字符串
  • file() - 把整个文件读入一个数组中
  • pack() - 将数据打包成二进制字符串
  • fputcsv() - 将行格式化为 CSV 并写入文件指针


从文件指针中读取一行

  • ? fgetcsv
  • fgetss ?
  • PHP Manual
  • 文件系统函数
  • 从文件指针中读取一行

fgets

(PHP 4, PHP 5, PHP 7, PHP 8)

fgets — 从文件指针中读取一行

说明

fgets ( resource $handle , int $length = ? ) : string

从文件指针中读取一行。

参数

handle

文件指针必须是有效的，必须指向由 fopen() 或 fsockopen() 成功打开的文件(并还未由 fclose() 关闭)。

length

从 handle 指向的文件中读取一行并返回长度最多为 length - 1 字节的字符串。碰到换行符（包括在返回值中）、EOF 或者已经读取了 length - 1 字节后停止（看先碰到那一种情况）。如果没有指定 length，则默认为 1K，或者说 1024 字节。

返回值

从指针 handle 指向的文件中读取了 length - 1 字节后返回字符串。 如果文件指针中没有更多的数据了则返回 false。

错误发生时返回 false。

范例

Example #1 逐行读取文件

<?php
$handle = @fopen("/tmp/inputfile.txt", "r");
if ($handle) {
    while (($buffer = fgets($handle, 4096)) !== false) {
        echo $buffer;
    }
    if (!feof($handle)) {
        echo "Error: unexpected fgets() fail\n";
    }
    fclose($handle);
}
?>

注释

Note: 在读取在 Macintosh 电脑中或由其创建的文件时， 如果 PHP 不能正确的识别行结束符，启用运行时配置可选项 auto_detect_line_endings 也许可以解决此问题。

Note:

习惯了 C 语言中 fgets() 语法的人应该注意到 EOF 是怎样被返回的。

参见

  • fgetss() - 从文件指针中读取一行并过滤掉 HTML 标记
  • fread() - 读取文件（可安全用于二进制文件）
  • fgetc() - 从文件指针中读取字符
  • stream_get_line() - 从资源流里读取一行直到给定的定界符
  • fopen() - 打开文件或者 URL
  • popen() - 打开进程文件指针
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接
  • stream_set_timeout() - Set timeout period on a stream


从文件指针中读取一行并过滤掉 HTML 标记

  • ? fgets
  • file_exists ?
  • PHP Manual
  • 文件系统函数
  • 从文件指针中读取一行并过滤掉 HTML 标记

fgetss

(PHP 4, PHP 5, PHP 7)

fgetss — 从文件指针中读取一行并过滤掉 HTML 标记

说明

fgetss ( resource $handle , int $length = ? , string $allowable_tags = ? ) : string

和 fgets() 相同，只除了 fgetss() 尝试从读取的文本中去掉任何 HTML 和 PHP 标记。

参数

handle

文件指针必须是有效的，必须指向由 fopen() 或 fsockopen() 成功打开的文件(并还未由 fclose() 关闭)。

length

取回该长度的数据。

allowable_tags

可以用可选的第三个参数指定哪些标记不被去掉。

返回值

从 handle 指向的文件中大读取 length - 1 个字节的字符，并过滤了所有的 HTML 和 PHP 代码。

错误发生时返回 false。

更新日志

版本 | 说明
5.0.0 | 参数 length 从 此开始可选。

Example #1 一行行读取一个 PHP 文件

<?php
$str = <<<EOD
<html><body>
 <p>Welcome! Today is the <?php echo(date('jS')); ?> of <?= date('F'); ?>.</p>
</body></html>
Text outside of the HTML block.
EOD;
file_put_contents('sample.php', $str);

$handle = @fopen("sample.php", "r");
if ($handle) {
    while (!feof($handle)) {
        $buffer = fgetss($handle, 4096);
        echo $buffer;
    }
    fclose($handle);
}
?>

以上例程的输出类似于：

 Welcome! Today is the  of .

Text outside of the HTML block.

注释

Note: 在读取在 Macintosh 电脑中或由其创建的文件时， 如果 PHP 不能正确的识别行结束符，启用运行时配置可选项 auto_detect_line_endings 也许可以解决此问题。

参见

  • fgets() - 从文件指针中读取一行
  • fopen() - 打开文件或者 URL
  • popen() - 打开进程文件指针
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接
  • strip_tags() - 从字符串中去除 HTML 和 PHP 标记


检查文件或目录是否存在

  • ? fgetss
  • file_get_contents ?
  • PHP Manual
  • 文件系统函数
  • 检查文件或目录是否存在

file_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

file_exists — 检查文件或目录是否存在

说明

file_exists ( string $filename ) : bool

检查文件或目录是否存在。

参数

filename

文件或目录的路径。

在 Windows 中要用 //computername/share/filename 或者 \\computername\share\filename 来检查网络中的共享文件。

返回值

如果由 filename 指定的文件或目录存在则返回 true，否则返回 false。

Note:

This function will return false for symlinks pointing to non-existing files.

Note:

The check is done using the real UID/GID instead of the effective one.

Note: 因为 PHP 的整数类型是有符号整型而且很多平台使用 32 位整型，对 2GB 以上的文件，一些文件系统函数可能返回无法预期的结果。

范例

Example #1 测试一个文件是否存在

<?php
$filename = '/path/to/foo.txt';

if (file_exists($filename)) {
    echo "The file $filename exists";
} else {
    echo "The file $filename does not exist";
}
?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • is_readable() - 判断给定文件名是否可读
  • is_writable() - 判断给定的文件名是否可写
  • is_file() - 判断给定文件名是否为一个正常的文件
  • file() - 把整个文件读入一个数组中


将整个文件读入一个字符串

  • ? file_exists
  • file_put_contents ?
  • PHP Manual
  • 文件系统函数
  • 将整个文件读入一个字符串

file_get_contents

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

file_get_contents — 将整个文件读入一个字符串

说明

file_get_contents ( string $filename , bool $use_include_path = false , resource $context = ? , int $offset = -1 , int $maxlen = ? ) : string

和 file() 一样，只除了 file_get_contents() 把文件读入一个字符串。将在参数 offset 所指定的位置开始读取长度为 maxlen 的内容。如果失败，file_get_contents() 将返回 false。

file_get_contents() 函数是用来将文件的内容读入到一个字符串中的首选方法。如果操作系统支持还会使用内存映射技术来增强性能。

Note:

如果要打开有特殊字符的 URL （比如说有空格），就需要使用 urlencode() 进行 URL 编码。

参数

filename

要读取的文件的名称。

use_include_path

Note:

As of PHP 5 the FILE_USE_INCLUDE_PATH can be used to trigger include path search.

context

A valid context resource created with stream_context_create(). 如果你不需要自定义 context，可以用 null 来忽略。

offset

The offset where the reading starts on the original stream.

Seeking (offset) is not supported with remote files. Attempting to seek on non-local files may work with small offsets, but this is unpredictable because it works on the buffered stream.

maxlen

Maximum length of data read. The default is to read until end of file is reached. Note that this parameter is applied to the stream processed by the filters.

返回值

The function returns the read data 或者在失败时返回 false.

错误／异常

An E_WARNING level error is generated if either maxlength is less than zero, or if seeking to the specified offset in the stream fails.

范例

Example #1 Get and output the source of the homepage of a website

<?php
$homepage = file_get_contents('http://www.example.com/');
echo $homepage;
?>

Example #2 Searching within the include_path

<?php
// <= PHP 5
$file = file_get_contents('./people.txt', true);
// > PHP 5
$file = file_get_contents('./people.txt', FILE_USE_INCLUDE_PATH);
?>

Example #3 Reading a section of a file

<?php
// Read 14 characters starting from the 21st character
$section = file_get_contents('./people.txt', NULL, NULL, 20, 14);
var_dump($section);
?>

以上例程的输出类似于：

string(14) "lle Bjori Ro"

Example #4 Using stream contexts

<?php
// Create a stream
$opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar\r\n"
  )
);

$context = stream_context_create($opts);

// Open the file using the HTTP headers set above
$file = file_get_contents('http://www.example.com/', false, $context);
?>

更新日志

版本 | 说明
5.1.0 | Added the offset and maxlen parameters.
5.0.0 | Added context support.

注释

Note: 此函数可安全用于二进制对象。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

Warning

使用 SSL 时，Microsoft IIS 会违反协议不发送close_notify标记就关闭连接。PHP 会在到达数据尾端时报告"SSL: Fatal Protocol Error"。 要解决此问题，error_reporting 应设定为降低级别至不包含警告。 PHP 4.3.7 及更高版本可以在使用 https:// 包装器打开流时检测出有问题的 IIS 服务器软件 并抑制警告。在使用 fsockopen() 创建 ssl:// 套接字时, 开发者需检测并抑制此警告。

参见

  • file() - 把整个文件读入一个数组中
  • fgets() - 从文件指针中读取一行
  • fread() - 读取文件（可安全用于二进制文件）
  • readfile() - 输出文件
  • file_put_contents() - 将一个字符串写入文件
  • stream_get_contents() - 读取资源流到一个字符串
  • stream_context_create() - 创建资源流上下文
  • $http_response_header


将一个字符串写入文件

  • ? file_get_contents
  • file ?
  • PHP Manual
  • 文件系统函数
  • 将一个字符串写入文件

file_put_contents

(PHP 5, PHP 7, PHP 8)

file_put_contents — 将一个字符串写入文件

说明

file_put_contents ( string $filename , mixed $data , int $flags = 0 , resource $context = ? ) : int

和依次调用 fopen()，fwrite() 以及 fclose() 功能一样。

If filename does not exist, the file is created. Otherwise, the existing file is overwritten, unless the FILE_APPEND flag is set.

参数

filename

要被写入数据的文件名。

data

要写入的数据。类型可以是 string，array 或者是 stream 资源（如上面所说的那样）。

如果 data 指定为 stream 资源，这里 stream 中所保存的缓存数据将被写入到指定文件中，这种用法就相似于使用 stream_copy_to_stream() 函数。

参数 data 可以是数组（但不能为多维数组），这就相当于 file_put_contents($filename, join('', $array))。

flags

flags 的值可以是 以下 flag 使用 OR (|) 运算符进行的组合。

Available flags
Flag | 描述
FILE_USE_INCLUDE_PATH | 在 include 目录里搜索 filename。 更多信息可参见 include_path。
FILE_APPEND | 如果文件 filename 已经存在，追加数据而不是覆盖。
LOCK_EX | 在写入时获得一个独占锁。

context

一个 context 资源。

返回值

该函数将返回写入到文件内数据的字节数，失败时返回false

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 Simple usage example

<?php
$file = 'people.txt';
// Open the file to get existing content
$current = file_get_contents($file);
// Append a new person to the file
$current .= "John Smith\n";
// Write the contents back to the file
file_put_contents($file, $current);
?>

Example #2 Using flags

<?php
$file = 'people.txt';
// The new person to add to the file
$person = "John Smith\n";
// Write the contents to the file,
// using the FILE_APPEND flag to append the content to the end of the file
// and the LOCK_EX flag to prevent anyone else writing to the file at the same time
file_put_contents($file, $person, FILE_APPEND | LOCK_EX);
?>

更新日志

版本 | 说明
5.0.0 | Added context support
5.1.0 | 添加了对 LOCK_EX 的支持和 data 参数处理 stream 资源的功能。

注释

Note: 此函数可安全用于二进制对象。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参见

  • fopen() - 打开文件或者 URL
  • fwrite() - 写入文件（可安全用于二进制文件）
  • file_get_contents() - 将整个文件读入一个字符串
  • stream_context_create() - 创建资源流上下文


把整个文件读入一个数组中

  • ? file_put_contents
  • fileatime ?
  • PHP Manual
  • 文件系统函数
  • 把整个文件读入一个数组中

file

(PHP 4, PHP 5, PHP 7, PHP 8)

file — 把整个文件读入一个数组中

说明

file ( string $filename , int $flags = 0 , resource $context = ? ) : array

把整个文件读入一个数组中。

Note:

你可以通过 file_get_contents() 以字符串形式获取文件的内容。

参数

filename

文件的路径。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

flags

可选参数 flags 可以是以下一个或多个常量：

FILE_USE_INCLUDE_PATH
在 include_path 中查找文件。
FILE_IGNORE_NEW_LINES
省略数组中每个元素末尾的换行符
FILE_SKIP_EMPTY_LINES
跳过空行

context

使用 stream_context_create() 函数创建的上下文资源（resource）。

Note: 在 PHP 5.0.0 中增加了对上下文（Context）的支持。有关上下文（Context）的说明参见 Streams。

返回值

返回数组形式的文件内容。数组的每个元素对应于文件中的一行（结尾会附加换行符）。 失败时，file() 返回 false。

Note:

除非使用了 FILE_IGNORE_NEW_LINES ，否则结果数组中的每一行都将包含行尾。

Note: 在读取在 Macintosh 电脑中或由其创建的文件时， 如果 PHP 不能正确的识别行结束符，启用运行时配置可选项 auto_detect_line_endings 也许可以解决此问题。

错误／异常

如果文件不存在，则发出 E_WARNING 级错误。

范例

Example #1 file() 例子

<?php
// 将一个文件读入数组。本例中通过 HTTP 从 URL 中取得 HTML 源文件。

$lines = file('http://www.example.com/');

// 在数组中循环，显示 HTML 的源文件并加上行号。

foreach ($lines as $line_num => $line) {
    echo "Line #<b>{$line_num}</b> : " . htmlspecialchars($line) . "<br />\n";
}

// 另一个例子将 web 页面读入字符串。参见 file_get_contents()。

$html = implode('', file('http://www.example.com/'));

// 从 PHP 5 开始可以使用可选标记参数
$trimmed = file('somefile.txt', FILE_IGNORE_NEW_LINES | FILE_SKIP_EMPTY_LINES);
?>

注释

Warning

使用 SSL 时，Microsoft IIS 会违反协议不发送close_notify标记就关闭连接。PHP 会在到达数据尾端时报告"SSL: Fatal Protocol Error"。 要解决此问题，error_reporting 应设定为降低级别至不包含警告。 PHP 4.3.7 及更高版本可以在使用 https:// 包装器打开流时检测出有问题的 IIS 服务器软件 并抑制警告。在使用 fsockopen() 创建 ssl:// 套接字时, 开发者需检测并抑制此警告。

参见

  • readfile() - 输出文件
  • fopen() - 打开文件或者 URL
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接
  • popen() - 打开进程文件指针
  • file_get_contents() - 将整个文件读入一个字符串
  • include - include
  • stream_context_create() - 创建资源流上下文


取得文件的上次访问时间

  • ? file
  • filectime ?
  • PHP Manual
  • 文件系统函数
  • 取得文件的上次访问时间

fileatime

(PHP 4, PHP 5, PHP 7, PHP 8)

fileatime — 取得文件的上次访问时间

说明

fileatime ( string $filename ) : int

取得文件的上次访问时间。

参数

filename

文件的路径。

返回值

返回文件上次被访问的时间， 或者在失败时返回 false。时间以 Unix 时间戳的方式返回。

范例

Example #1 fileatime() 例子

<?php

// 输出类似：somefile.txt was last accessed: December 29 2002 22:16:23.

$filename = 'somefile.txt';
if (file_exists($filename)) {
    echo "$filename was last accessed: " . date("F d Y H:i:s.", fileatime($filename));
}

?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note:

注意：一个文件的 atime 应该在不论何时读取了此文件中的数据块时被更改。当一个应用程序定期访问大量文件或目录时很影响性能。

有些 Unix 文件系统可以在加载时关闭 atime 的更新以提高这类程序的性能。USENET 新闻组假脱机是一个常见的例子。在这种文件系统下本函数没有用处。

Note:

注意：不同文件系统对时间的判断方法可能是不相同的。

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • filemtime() - 取得文件修改时间
  • fileinode() - 取得文件的 inode
  • date() - 格式化一个本地时间／日期


取得文件的 inode 修改时间

  • ? fileatime
  • filegroup ?
  • PHP Manual
  • 文件系统函数
  • 取得文件的 inode 修改时间

filectime

(PHP 4, PHP 5, PHP 7, PHP 8)

filectime — 取得文件的 inode 修改时间

说明

filectime ( string $filename ) : int

取得文件的 inode 修改时间。

参数

filename

文件的路径。

返回值

返回文件上次 inode 被修改的时间， 或者在失败时返回 false。 时间以 Unix 时间戳的方式返回。

范例

Example #1 filectime() 例子

<?php

// 输出类似：  somefile.txt was last changed: December 29 2002 22:16:23.

$filename = 'somefile.txt';
if (file_exists($filename)) {
    echo "$filename was last changed: " . date("F d Y H:i:s.", filectime($filename));
}

?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note:

注意：在大多数 Unix 文件系统中，当一个文件的 inode 数据被改变时则该文件被认为是修改了。也就是说，当文件的权限，所有者，所有组或其它 inode 中的元数据被更新时。参见 filemtime()（这才是你想用于在 Web 页面中建立"最后更新时间"脚注的函数）和 fileatime()。

Note:

注意某些 Unix 说明文本中把 ctime 说成是该文件建立的时间，这是错的。在大多数 Unix 文件系统中没有 Unix 文件的建立时间。

Note:

注意：不同文件系统对时间的判断方法可能是不相同的。

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • filemtime() - 取得文件修改时间


取得文件的组

  • ? filectime
  • fileinode ?
  • PHP Manual
  • 文件系统函数
  • 取得文件的组

filegroup

(PHP 4, PHP 5, PHP 7, PHP 8)

filegroup — 取得文件的组

说明

filegroup ( string $filename ) : int

取得该文件所属组的 ID。组 ID 以数字格式返回，用 posix_getgrgid() 来将其解析为组名。

参数

filename

文件的路径。

返回值

返回该文件所属组的 ID。或在错误时返回 false。 组 ID 以数字格式返回，用 posix_getgrgid() 来将其解析为组名。如果出错则返回 false。

范例

Example #1 查找文件所在的组

<?php
$filename = 'index.php';
print_r(posix_getgrgid(filegroup($filename)));
?>

错误／异常

如果失败返回 false 以及一个 E_WARNING 级别的错误。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • fileowner() - 取得文件的所有者
  • posix_getgrgid() - Return info about a group by group id


取得文件的 inode

  • ? filegroup
  • filemtime ?
  • PHP Manual
  • 文件系统函数
  • 取得文件的 inode

fileinode

(PHP 4, PHP 5, PHP 7, PHP 8)

fileinode — 取得文件的 inode

说明

fileinode ( string $filename ) : int

取得文件的 inode。

参数

filename

文件的路径。

返回值

返回文件的 inode 节点号， 或者在失败时返回 false。

范例

Example #1 将某个文件和当前文件的 inode 进行对比

<?php
$filename = 'index.php';
if (getmyinode() == fileinode($filename)) {
    echo 'You are checking the current file.';
}
?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • getmyinode() - 获取当前脚本的索引节点（inode）
  • stat() - 给出文件的信息


取得文件修改时间

  • ? fileinode
  • fileowner ?
  • PHP Manual
  • 文件系统函数
  • 取得文件修改时间

filemtime

(PHP 4, PHP 5, PHP 7, PHP 8)

filemtime — 取得文件修改时间

说明

filemtime ( string $filename ) : int

本函数返回文件中的数据块上次被写入的时间，也就是说，文件的内容上次被修改的时间。

参数

filename

文件的路径。

返回值

返回文件上次被修改的时间， 或者在失败时返回 false。时间以 Unix 时间戳的方式返回，可用于 date()。

范例

Example #1 filemtime() 例子

<?php
// outputs e.g.  somefile.txt was last modified: December 29 2002 22:16:23.

$filename = 'somefile.txt';
if (file_exists($filename)) {
    echo "$filename was last modified: " . date ("F d Y H:i:s.", filemtime($filename));
}
?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note:

注意：不同文件系统对时间的判断方法可能是不相同的。

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • filectime() - 取得文件的 inode 修改时间
  • stat() - 给出文件的信息
  • touch() - 设定文件的访问和修改时间
  • getlastmod() - 获取页面最后修改的时间


取得文件的所有者

  • ? filemtime
  • fileperms ?
  • PHP Manual
  • 文件系统函数
  • 取得文件的所有者

fileowner

(PHP 4, PHP 5, PHP 7, PHP 8)

fileowner — 取得文件的所有者

说明

fileowner ( string $filename ) : int

取得文件的所有者。

参数

filename

文件的路径。

返回值

返回文件所有的用户 ID，如果出错则返回 false。用户 ID 以数字格式返回，用 posix_getpwuid() 来将其解析为用户名。

范例

Example #1 找到文件的所有者

<?php
$filename = 'index.php';
print_r(posix_getpwuid(fileowner($filename)));
?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • filegroup() - 取得文件的组
  • stat() - 给出文件的信息
  • posix_getpwuid() - Return info about a user by user id


取得文件的权限

  • ? fileowner
  • filesize ?
  • PHP Manual
  • 文件系统函数
  • 取得文件的权限

fileperms

(PHP 4, PHP 5, PHP 7, PHP 8)

fileperms — 取得文件的权限

说明

fileperms ( string $filename ) : int

取得文件的权限。

参数

filename

文件的路径。

返回值

以数字模式返回文件的访问权限。 Returns the file's permissions as a numeric mode. Lower bits of this mode are the same as the permissions expected by chmod(), however on most platforms the return value will also include information on the type of file given as filename. The examples below demonstrate how to test the return value for specific permissions and file types on POSIX systems, including Linux and Mac OS X.

For local files, the specific return value is that of the st_mode member of the structure returned by the C library's stat() function. Exactly which bits are set can vary from platform to platform, and looking up your specific platform's documentation is recommended if parsing the non-permission bits of the return value is required.

范例

Example #1 以八进制的形式显示文件的权限

<?php
echo substr(sprintf('%o', fileperms('/tmp')), -4);
echo substr(sprintf('%o', fileperms('/etc/passwd')), -4);
?>

以上例程会输出：

1777
0644

Example #2 输出全部权限

<?php
$perms = fileperms('/etc/passwd');

if (($perms & 0xC000) == 0xC000) {
    // Socket
    $info = 's';
} elseif (($perms & 0xA000) == 0xA000) {
    // Symbolic Link
    $info = 'l';
} elseif (($perms & 0x8000) == 0x8000) {
    // Regular
    $info = '-';
} elseif (($perms & 0x6000) == 0x6000) {
    // Block special
    $info = 'b';
} elseif (($perms & 0x4000) == 0x4000) {
    // Directory
    $info = 'd';
} elseif (($perms & 0x2000) == 0x2000) {
    // Character special
    $info = 'c';
} elseif (($perms & 0x1000) == 0x1000) {
    // FIFO pipe
    $info = 'p';
} else {
    // Unknown
    $info = 'u';
}

// Owner
$info .= (($perms & 0x0100) ? 'r' : '-');
$info .= (($perms & 0x0080) ? 'w' : '-');
$info .= (($perms & 0x0040) ?
            (($perms & 0x0800) ? 's' : 'x' ) :
            (($perms & 0x0800) ? 'S' : '-'));

// Group
$info .= (($perms & 0x0020) ? 'r' : '-');
$info .= (($perms & 0x0010) ? 'w' : '-');
$info .= (($perms & 0x0008) ?
            (($perms & 0x0400) ? 's' : 'x' ) :
            (($perms & 0x0400) ? 'S' : '-'));

// World
$info .= (($perms & 0x0004) ? 'r' : '-');
$info .= (($perms & 0x0002) ? 'w' : '-');
$info .= (($perms & 0x0001) ?
            (($perms & 0x0200) ? 't' : 'x' ) :
            (($perms & 0x0200) ? 'T' : '-'));

echo $info;
?>

以上例程会输出：

-rw-r--r--

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • chmod() - 改变文件模式
  • is_readable() - 判断给定文件名是否可读
  • stat() - 给出文件的信息


取得文件大小

  • ? fileperms
  • filetype ?
  • PHP Manual
  • 文件系统函数
  • 取得文件大小

filesize

(PHP 4, PHP 5, PHP 7, PHP 8)

filesize — 取得文件大小

说明

filesize ( string $filename ) : int

取得指定文件的大小。

参数

filename

文件的路径。

返回值

返回文件大小的字节数，如果出错返回 false 并生成一条 E_WARNING 级的错误。

Note: 因为 PHP 的整数类型是有符号整型而且很多平台使用 32 位整型，对 2GB 以上的文件，一些文件系统函数可能返回无法预期的结果。

范例

Example #1 filesize() 例子

<?php

// 输出类似：somefile.txt: 1024 bytes

$filename = 'somefile.txt';
echo $filename . ': ' . filesize($filename) . ' bytes';

?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • file_exists() - 检查文件或目录是否存在


取得文件类型

  • ? filesize
  • flock ?
  • PHP Manual
  • 文件系统函数
  • 取得文件类型

filetype

(PHP 4, PHP 5, PHP 7, PHP 8)

filetype — 取得文件类型

说明

filetype ( string $filename ) : string

返回文件的类型。

参数

filename

文件的路径。

返回值

返回文件的类型。 可能的值有 fifo，char，dir，block，link，file 和 unknown。

如果出错则返回 false。如果 stat 调用失败或者文件类型未知的话 filetype() 还会产生一个 E_NOTICE 消息。

范例

Example #1 filetype() 例子

<?php

echo filetype('/etc/passwd');  // file
echo filetype('/etc/');        // dir

?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • is_dir() - 判断给定文件名是否是一个目录
  • is_file() - 判断给定文件名是否为一个正常的文件
  • is_link() - 判断给定文件名是否为一个符号连接
  • file_exists() - 检查文件或目录是否存在
  • mime_content_type() - 检测文件的 MIME 类型
  • pathinfo() - 返回文件路径的信息
  • stat() - 给出文件的信息


轻便的咨询文件锁定

  • ? filetype
  • fnmatch ?
  • PHP Manual
  • 文件系统函数
  • 轻便的咨询文件锁定

flock

(PHP 4, PHP 5, PHP 7, PHP 8)

flock — 轻便的咨询文件锁定

说明

flock ( resource $handle , int $operation , int &$wouldblock = ? ) : bool

flock() 允许执行一个简单的可以在任何平台中使用的读取/写入模型（包括大部分的 Unix 派生版和甚至是 Windows）。

在 PHP 5.3.2版本之前，锁也会被 fclose() 释放（在脚本结束后会自动调用）。

PHP 支持以咨询方式（也就是说所有访问程序必须使用同一方式锁定, 否则它不会工作）锁定全部文件的一种轻便方法。 默认情况下，这个函数会阻塞到获取锁；这可以通过下面文档中 LOCK_NB 选项来控制（在非 Windows 平台上）。

参数

handle

文件系统指针，是典型地由 fopen() 创建的 resource(资源)。

operation

operation 可以是以下值之一：

  • LOCK_SH取得共享锁定（读取的程序）。
  • LOCK_EX 取得独占锁定（写入的程序。
  • LOCK_UN 释放锁定（无论共享或独占）。

如果不希望 flock() 在锁定时堵塞，则是 LOCK_NB（Windows 上还不支持）。

wouldblock

如果锁定会堵塞的话（EWOULDBLOCK 错误码情况下），可选的第三个参数会被设置为 true。（Windows 上不支持）

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.3.2 | 在文件资源句柄关闭时不再自动解锁。现在要解锁必须手动进行。
4.0.1 | 增加了常量 LOCK_XXX。 之前你必须使用 1 代表 LOCK_SH，2 代表 LOCK_EX，3 代表LOCK_UN，4 代表 LOCK_NB。

范例

Example #1 flock() 例子

<?php

$fp = fopen("/tmp/lock.txt", "r+");

if (flock($fp, LOCK_EX)) {  // 进行排它型锁定
    ftruncate($fp, 0);      // truncate file
    fwrite($fp, "Write something here\n");
    fflush($fp);            // flush output before releasing the lock
    flock($fp, LOCK_UN);    // 释放锁定
} else {
    echo "Couldn't get the lock!";
}

fclose($fp);

?>

Example #2 flock() 使用 LOCK_NB 选项

<?php
$fp = fopen('/tmp/lock.txt', 'r+');

/* Activate the LOCK_NB option on an LOCK_EX operation */
if(!flock($fp, LOCK_EX | LOCK_NB)) {
    echo 'Unable to obtain lock';
    exit(-1);
}

/* ... */

fclose($fp);
?>

注释

Note:

flock() uses mandatory locking instead of advisory locking on Windows. Mandatory locking is also supported on Linux and System V based operating systems via the usual mechanism supported by the fcntl() system call: that is, if the file in question has the setgid permission bit set and the group execution bit cleared. On Linux, the file system will also need to be mounted with the mand option for this to work.

Note:

由于 flock() 需要一个文件指针， 因此可能不得不用一个特殊的锁定文件来保护打算通过写模式打开的文件的访问（在 fopen() 函数中加入 "w" 或 "w+"）。

Note:

May only be used on file pointers returned by fopen() for local files, or file pointers pointing to userspace streams that implement the streamWrapper::stream_lock() method.

Warning

Assigning another value to handle argument in subsequent code will release the lock.

Warning

在部分操作系统中 flock() 以进程级实现。当用一个多线程服务器 API（比如 ISAPI）时，可能不可以依靠 flock() 来保护文件，因为运行于同一服务器实例中其它并行线程的 PHP 脚本可以对该文件进行处理。

flock() 不支持旧的文件系统，如 FAT 以及它的派生系统。因此，此环境下总是返回 false（尤其是对 Windows 98 用户来说）。


用模式匹配文件名

  • ? flock
  • fopen ?
  • PHP Manual
  • 文件系统函数
  • 用模式匹配文件名

fnmatch

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

fnmatch — 用模式匹配文件名

说明

fnmatch ( string $pattern , string $string , int $flags = 0 ) : bool

fnmatch() 检查传入的 string 是否匹配给出的 shell 统配符 pattern。

参数

pattern

shell 统配符。

string

要检查的字符串。 此函数对于文件名尤其有用，但也可以用于普通的字符串。

普通用户可能习惯于 shell 模式或者至少其中最简单的形式 '?' 和 '*' 通配符，因此使用 fnmatch() 来代替 preg_match() 来进行前端搜索表达式输入对于非程序员用户更加方便。

flags

The value of flags can be any combination of the following flags, joined with the binary OR (|) operator.

A list of possible flags for fnmatch()
Flag | Description
FNM_NOESCAPE | Disable backslash escaping.
FNM_PATHNAME | Slash in string only matches slash in the given pattern.
FNM_PERIOD | Leading period in string must be exactly matched by period in the given pattern.
FNM_CASEFOLD | Caseless match. Part of the GNU extension.

返回值

匹配则返回 true，否则返回 false。

更新日志

版本 | 说明
5.3.0 | 此函数开始在 Windows 平台上生效。

范例

Example #1 用 shell 中的通配符模式匹配来检查颜色名称

<?php
if (fnmatch("*gr[ae]y", $color)) {
  echo "some form of gray ...";
}
?>

注释

Warning

目前该函数无法在 Windows 或其它非 POSIX 兼容的系统上使用。

参见

  • glob() - 寻找与模式匹配的文件路径
  • preg_match() - 执行匹配正则表达式
  • sscanf() - 根据指定格式解析输入的字符
  • printf() - 输出格式化字符串
  • sprintf() - Return a formatted string


打开文件或者 URL

  • ? fnmatch
  • fpassthru ?
  • PHP Manual
  • 文件系统函数
  • 打开文件或者 URL

fopen

(PHP 4, PHP 5, PHP 7, PHP 8)

fopen — 打开文件或者 URL

说明

fopen ( string $filename , string $mode , bool $use_include_path = false , resource $context = ? ) : resource

fopen() 将 filename 指定的名字资源绑定到一个流上。

参数

filename

如果 filename 是 "scheme://..." 的格式，则被当成一个 URL，PHP 将搜索协议处理器（也被称为封装协议）来处理此模式。如果该协议尚未注册封装协议，PHP 将发出一条消息来帮助检查脚本中潜在的问题并将 filename 当成一个普通的文件名继续执行下去。

如果 PHP 认为 filename 指定的是一个本地文件，将尝试在该文件上打开一个流。该文件必须是 PHP 可以访问的，因此需要确认文件访问权限允许该访问。如果激活了 open_basedir 则会应用进一步的限制。

如果 PHP 认为 filename 指定的是一个已注册的协议，而该协议被注册为一个网络 URL，PHP 将检查并确认 allow_url_fopen 已被激活。如果关闭了，PHP 将发出一个警告，而 fopen 的调用则失败。

Note:

所支持的协议列表见支持的协议和封装协议。某些协议（也被称为 wrappers）支持 context 和／或 php.ini 选项。参见相应的页面哪些选项可以被设定（例如 php.ini 中用于 http wrapper 的 user_agent 值）。

On the Windows platform, be careful to escape any backslashes used in the path to the file, or use forward slashes.

<?php
$handle = fopen("c:\\folder\\resource.txt", "r");
?>

mode

mode 参数指定了所要求到该流的访问类型。可以是以下：

fopen() 中 mode 的可能值列表
mode | 说明
'r' | 只读方式打开，将文件指针指向文件头。
'r+' | 读写方式打开，将文件指针指向文件头。
'w' | 写入方式打开，将文件指针指向文件头并将文件大小截为零。如果文件不存在则尝试创建之。
'w+' | 读写方式打开，将文件指针指向文件头并将文件大小截为零。如果文件不存在则尝试创建之。
'a' | 写入方式打开，将文件指针指向文件末尾。如果文件不存在则尝试创建之。
'a+' | 读写方式打开，将文件指针指向文件末尾。如果文件不存在则尝试创建之。
'x' | 创建并以写入方式打开，将文件指针指向文件头。如果文件已存在，则 fopen() 调用失败并返回 false，并生成一条 E_WARNING 级别的错误信息。如果文件不存在则尝试创建之。这和给 底层的 open(2) 系统调用指定 O_EXCL|O_CREAT 标记是等价的。
'x+' | 创建并以读写方式打开，其他的行为和 'x' 一样。
'c' | Open the file for writing only. If the file does not exist, it is created. If it exists, it is neither truncated (as opposed to 'w'), nor the call to this function fails (as is the case with 'x'). The file pointer is positioned on the beginning of the file. This may be useful if it's desired to get an advisory lock (see flock()) before attempting to modify the file, as using 'w' could truncate the file before the lock was obtained (if truncation is desired, ftruncate() can be used after the lock is requested).
'c+' | Open the file for reading and writing; otherwise it has the same behavior as 'c'.

Note:

不同的操作系统家族具有不同的行结束习惯。当写入一个文本文件并想插入一个新行时，需要使用符合操作系统的行结束符号。基于 Unix 的系统使用 \n 作为行结束字符，基于 Windows 的系统使用 \r\n 作为行结束字符，基于 Macintosh 的系统使用 \r 作为行结束字符。

如果写入文件时使用了错误的行结束符号，则其它应用程序打开这些文件时可能会表现得很怪异。

Windows 下提供了一个文本转换标记（'t'）可以透明地将 \n 转换为 \r\n。与此对应还可以使用 'b' 来强制使用二进制模式，这样就不会转换数据。要使用这些标记，要么用 'b' 或者用 't' 作为 mode 参数的最后一个字符。

默认的转换模式依赖于 SAPI 和所使用的 PHP 版本，因此为了便于移植鼓励总是指定恰当的标记。如果是操作纯文本文件并在脚本中使用了 \n 作为行结束符，但还要期望这些文件可以被其它应用程序例如 Notepad 读取，则在 mode 中使用 't'。在所有其它情况下使用 'b'。

在操作二进制文件时如果没有指定 'b' 标记，可能会碰到一些奇怪的问题，包括坏掉的图片文件以及关于 \r\n 字符的奇怪问题。

Note:

为移植性考虑，强烈建议在用 fopen() 打开文件时总是使用 'b' 标记。

Note:

再一次，为移植性考虑，强烈建议你重写那些依赖于 't' 模式的代码使其使用正确的行结束符并改成 'b' 模式。

use_include_path

如果也需要在 include_path 中搜寻文件的话，可以将可选的第三个参数 use_include_path 设为 '1' 或 true。

context

Note: 在 PHP 5.0.0 中增加了对上下文（Context）的支持。有关上下文（Context）的说明参见 Streams。

返回值

成功时返回文件指针资源，如果打开失败，本函数返回 false。

错误／异常

如果打开失败，会产生一个 E_WARNING 错误。可以通过 @ 来屏蔽错误。

更新日志

版本 | 说明
4.3.2 | 自 PHP 4.3.2 起，对所有区别二进制和文本模式的平台默认模式都被设为二进制模式。如果在升级后脚本碰到问题，尝试暂时使用 't' 标记，直到所有的脚本都照以下所说的改为更具移植性以后。
4.3.2 | 增加了选项 'x' 和 'x+'
5.2.6 | 增加了选项 'c' 和 'c+'

范例

Example #1 fopen() 例子

<?php
$handle = fopen("/home/rasmus/file.txt", "r");
$handle = fopen("/home/rasmus/file.gif", "wb");
$handle = fopen("http://www.example.com/", "r");
$handle = fopen("ftp://user:password@example.com/somefile.txt", "w");
?>

注释

Warning

使用 SSL 时，Microsoft IIS 会违反协议不发送close_notify标记就关闭连接。PHP 会在到达数据尾端时报告"SSL: Fatal Protocol Error"。 要解决此问题，error_reporting 应设定为降低级别至不包含警告。 PHP 4.3.7 及更高版本可以在使用 https:// 包装器打开流时检测出有问题的 IIS 服务器软件 并抑制警告。在使用 fsockopen() 创建 ssl:// 套接字时, 开发者需检测并抑制此警告。

Note:

如果在用服务器模块版本的 PHP 时在打开和写入文件上遇到问题，记住要确保所使用的文件和目录是服务器进程所能够访问的。

Note:

This function may also succeed when filename is a directory. If you are unsure whether filename is a file or a directory, you may need to use the is_dir() function before calling fopen().

参见

  • 支持的协议和封装协议
  • fclose() - 关闭一个已打开的文件指针
  • fgets() - 从文件指针中读取一行
  • fread() - 读取文件（可安全用于二进制文件）
  • fwrite() - 写入文件（可安全用于二进制文件）
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接
  • file() - 把整个文件读入一个数组中
  • file_exists() - 检查文件或目录是否存在
  • is_readable() - 判断给定文件名是否可读
  • stream_set_timeout() - Set timeout period on a stream
  • popen() - 打开进程文件指针
  • stream_context_create() - 创建资源流上下文
  • umask() - 改变当前的 umask
  • SplFileObject


输出文件指针处的所有剩余数据

  • ? fopen
  • fputcsv ?
  • PHP Manual
  • 文件系统函数
  • 输出文件指针处的所有剩余数据

fpassthru

(PHP 4, PHP 5, PHP 7, PHP 8)

fpassthru — 输出文件指针处的所有剩余数据

说明

fpassthru ( resource $handle ) : int

将给定的文件指针从当前的位置读取到 EOF 并把结果写到输出缓冲区。

如果已经向文件写入数据，就必须调用 rewind() 来将文件指针指向文件头。

如果既不修改文件也不在特定位置检索，只想将文件的内容下载到输出缓冲区，应该使用 readfile()，这样可以省去 fopen() 调用。

参数

handle

文件指针必须是有效的，必须指向由 fopen() 或 fsockopen() 成功打开的文件(并还未由 fclose() 关闭)。

返回值

如果发生错误， fpassthru() 返回 false。否则 fpassthru() 返回从 handle 读取并传递到输出的字符数目。

范例

Example #1 对二进制文件使用 fpassthru()

<?php

// 以二进制格式打开文件
$name = './img/ok.png';
$fp = fopen($name, 'rb');

// 发送合适的报头
header("Content-Type: image/png");
header("Content-Length: " . filesize($name));

// 发送图片并终止脚本
fpassthru($fp);
exit;

?>

注释

Note:

当在 Windows 系统中将 fpassthru() 用于二进制文件，要确保在用 fopen() 打开文件时在 mode 中附加了 b 来将文件以二进制方式打开。

鼓励在处理二进制文件时使用 b 标志，即使系统并不需要，这样可以使脚本的移植性更好。

参见

  • readfile() - 输出文件
  • fopen() - 打开文件或者 URL
  • popen() - 打开进程文件指针
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接


将行格式化为 CSV 并写入文件指针

  • ? fpassthru
  • fputs ?
  • PHP Manual
  • 文件系统函数
  • 将行格式化为 CSV 并写入文件指针

fputcsv

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

fputcsv — 将行格式化为 CSV 并写入文件指针

说明

fputcsv ( resource $handle , array $fields , string $delimiter = ',' , string $enclosure = '"' ) : int

fputcsv() 将一行（用 fields 数组传递）格式化为 CSV 格式并写入由 handle 指定的文件。

参数

handle

文件指针必须是有效的，必须指向由 fopen() 或 fsockopen() 成功打开的文件(并还未由 fclose() 关闭)。

fields

值的一个数组。

delimiter

可选的 delimiter 参数设定字段分界符（只允许一个字符）。

enclosure

可选的 enclosure 参数设定字段字段环绕符（只允许一个字符）。

返回值

返回写入字符串的长度， 或者在失败时返回 false。

范例

Example #1 fputcsv() 例子

<?php

$list = array (
    array('aaa', 'bbb', 'ccc', 'dddd'),
    array('123', '456', '789'),
    array('"aaa"', '"bbb"')
);

$fp = fopen('file.csv', 'w');

foreach ($list as $fields) {
    fputcsv($fp, $fields);
}

fclose($fp);
?>

以上例子会写入以下的file.csv：

aaa,bbb,ccc,dddd
123,456,789
"""aaa""","""bbb"""

注释

Note: 在读取在 Macintosh 电脑中或由其创建的文件时， 如果 PHP 不能正确的识别行结束符，启用运行时配置可选项 auto_detect_line_endings 也许可以解决此问题。

参见

  • fgetcsv() - 从文件指针中读入一行并解析 CSV 字段


fwrite 的别名

  • ? fputcsv
  • fread ?
  • PHP Manual
  • 文件系统函数
  • fwrite 的别名

fputs

(PHP 4, PHP 5, PHP 7, PHP 8)

fputs — fwrite() 的别名

说明

此函数是该函数的别名：fwrite()。


读取文件（可安全用于二进制文件）

  • ? fputs
  • fscanf ?
  • PHP Manual
  • 文件系统函数
  • 读取文件（可安全用于二进制文件）

fread

(PHP 4, PHP 5, PHP 7, PHP 8)

fread — 读取文件（可安全用于二进制文件）

说明

fread ( resource $handle , int $length ) : string

fread() 从文件指针 handle 读取最多 length 个字节。 该函数在遇上以下几种情况时停止读取文件：

  • 读取了 length 个字节
  • 到达了文件末尾（EOF）
  • a packet becomes available or the socket timeout occurs (for network streams)
  • if the stream is read buffered and it does not represent a plain file, at most one read of up to a number of bytes equal to the chunk size (usually 8192) is made; depending on the previously buffered data, the size of the returned data may be larger than the chunk size.

参数

handle

文件系统指针，是典型地由 fopen() 创建的 resource(资源)。

length

最多读取 length 个字节。

返回值

返回所读取的字符串， 或者在失败时返回 false。

范例

Example #1 一个简单的 fread() 例子

<?php
// get contents of a file into a string
$filename = "/usr/local/something.txt";
$handle = fopen($filename, "r");
$contents = fread($handle, filesize($filename));
fclose($handle);
?>

Example #2 Binary fread() example

Warning

在区分二进制文件和文本文件的系统上（如 Windows）打开文件时，fopen() 函数的 mode 参数要加上 'b'。

<?php
$filename = "c:\\files\\somepic.gif";
$handle = fopen($filename, "rb");
$contents = fread($handle, filesize($filename));
fclose($handle);
?>

Example #3 Remote fread() examples

Warning

当从任何不是普通本地文件读取时，例如在读取从远程文件或 popen() 以及 fsockopen() 返回的流时，读取会在一个包可用之后停止。这意味着应该如下例所示将数据收集起来合并成大块。

<?php
// 对 PHP 5 及更高版本
$handle = fopen("http://www.example.com/", "rb");
$contents = stream_get_contents($handle);
fclose($handle);
?>
<?php
$handle = fopen("http://www.example.com/", "rb");
$contents = '';
while (!feof($handle)) {
  $contents .= fread($handle, 8192);
}
fclose($handle);
?>

注释

Note:

如果只是想将一个文件的内容读入到一个字符串中，用 file_get_contents()，它的性能比上面的代码好得多。

Note:

Note that fread() reads from the current position of the file pointer. Use ftell() to find the current position of the pointer and rewind() to rewind the pointer position.

参见

  • fwrite() - 写入文件（可安全用于二进制文件）
  • fopen() - 打开文件或者 URL
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接
  • popen() - 打开进程文件指针
  • fgets() - 从文件指针中读取一行
  • fgetss() - 从文件指针中读取一行并过滤掉 HTML 标记
  • fscanf() - 从文件中格式化输入
  • file() - 把整个文件读入一个数组中
  • fpassthru() - 输出文件指针处的所有剩余数据
  • ftell() - 返回文件指针读/写的位置
  • rewind() - 倒回文件指针的位置


从文件中格式化输入

  • ? fread
  • fseek ?
  • PHP Manual
  • 文件系统函数
  • 从文件中格式化输入

fscanf

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

fscanf — 从文件中格式化输入

说明

fscanf ( resource $handle , string $format , mixed &$... = ? ) : mixed

fscanf() 函数和 sscanf() 相似，但是它从与 handle 关联的文件中接受输入并根据指定的 format（定义于 sprintf() 的文档中）来解释输入。

格式字符串中的任何空白会与输入流中的任何空白匹配。这意味着甚至格式字符串中的制表符 \t 也会与输入流中的一个空格字符匹配。

每次调用 fscanf() 都会从文件中读取一行。

参数

handle

文件系统指针，是典型地由 fopen() 创建的 resource(资源)。

format

参数格式是 sprintf() 文档中所描述的格式。

...

The optional assigned values.

返回值

如果只给此函数传递了两个参数，解析后的值会被作为数组返回。否则，如果提供了可选参数，此函数将返回被赋值的数目。 可选参数必须用引用传递。

更新日志

版本 | 说明
4.3.0 | 在 PHP 4.3.0 之前，从文件中读入的最大字符数是 512（或者第一个 \n，看先碰到哪种情况）。从 PHP 4.3.0 起可以读取任意长的行。

范例

Example #1 fscanf() 例子

<?php
$handle = fopen("users.txt", "r");
while ($userinfo = fscanf($handle, "%s\t%s\t%s\n")) {
    list ($name, $profession, $countrycode) = $userinfo;
    //... do something with the values
}
fclose($handle);
?>

Example #2 users.txt 的内容

javier  argonaut        pe
hiroshi sculptor        jp
robert  slacker us
luigi   florist it

参见

  • fread() - 读取文件（可安全用于二进制文件）
  • fgets() - 从文件指针中读取一行
  • fgetss() - 从文件指针中读取一行并过滤掉 HTML 标记
  • sscanf() - 根据指定格式解析输入的字符
  • printf() - 输出格式化字符串
  • sprintf() - Return a formatted string


在文件指针中定位

  • ? fscanf
  • fstat ?
  • PHP Manual
  • 文件系统函数
  • 在文件指针中定位

fseek

(PHP 4, PHP 5, PHP 7, PHP 8)

fseek — 在文件指针中定位

说明

fseek ( resource $handle , int $offset , int $whence = SEEK_SET ) : int

在与 handle 关联的文件中设定文件指针位置。 新位置从文件头开始以字节数度量，是以 whence 指定的位置加上 offset。

In general, it is allowed to seek past the end-of-file; if data is then written, reads in any unwritten region between the end-of-file and the sought position will yield bytes with value 0. However, certain streams may not support this behavior, especially when they have an underlying fixed size storage.

参数

handle

文件系统指针，是典型地由 fopen() 创建的 resource(资源)。

offset

偏移量。

要移动到文件尾之前的位置，需要给 offset 传递一个负值，并设置 whence 为 SEEK_END。

whence

whence values are:

  • SEEK_SET - 设定位置等于 offset 字节。
  • SEEK_CUR - 设定位置为当前位置加上 offset。
  • SEEK_END - 设定位置为文件尾加上 offset。

返回值

成功则返回 0；否则返回 -1。注意移动到 EOF 之后的位置不算错误。

范例

Example #1 fseek() 例子

<?php

$fp = fopen('somefile.txt', 'r');

// read some data
$data = fgets($fp, 4096);

// move back to the beginning of the file
// same as rewind($fp);
fseek($fp, 0);

?>

注释

Note:

如果使用附加模试（a 或 a+），任何写入文件数据都会被附加上去，而文件的位置将会被忽略，调用 fseek() 的结果尚未定义。

Note:

Not all streams support seeking. For those that do not support seeking, forward seeking from the current position is accomplished by reading and discarding data; other forms of seeking will fail.

参见

  • ftell() - 返回文件指针读/写的位置
  • rewind() - 倒回文件指针的位置


通过已打开的文件指针取得文件信息

  • ? fseek
  • ftell ?
  • PHP Manual
  • 文件系统函数
  • 通过已打开的文件指针取得文件信息

fstat

(PHP 4, PHP 5, PHP 7, PHP 8)

fstat — 通过已打开的文件指针取得文件信息

说明

fstat ( resource $handle ) : array

获取由文件指针 handle 所打开文件的统计信息。本函数和 stat() 函数相似，除了它是作用于已打开的文件指针而不是文件名。

参数

handle

文件系统指针，是典型地由 fopen() 创建的 resource(资源)。

返回值

返回一个数组具有该文件的统计信息，该数组的格式详细说明于手册中 stat() 页面里。

范例

Example #1 fstat() 例子

<?php

// 打开文件
$fp = fopen("/etc/passwd", "r");

// 取得统计信息
$fstat = fstat($fp);

// 关闭文件
fclose($fp);

// 只显示关联数组部分
print_r(array_slice($fstat, 13));
?>

以上例程的输出类似于：

Array
(
    [dev] => 771
    [ino] => 488704
    [mode] => 33188
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 1114
    [atime] => 1061067181
    [mtime] => 1056136526
    [ctime] => 1056136526
    [blksize] => 4096
    [blocks] => 8
)

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。


返回文件指针读/写的位置

  • ? fstat
  • ftruncate ?
  • PHP Manual
  • 文件系统函数
  • 返回文件指针读/写的位置

ftell

(PHP 4, PHP 5, PHP 7, PHP 8)

ftell — 返回文件指针读/写的位置

说明

ftell ( resource $handle ) : int

返回由 handle 指定的文件指针的位置，也就是文件流中的偏移量。

参数

handle

文件指针必须是有效的，且必须指向一个通过 fopen() 或 popen() 成功打开的文件。在附加模式（加参数 "a" 打开文件）中 ftell() 会返回未定义错误。

返回值

Returns the position of the file pointer referenced by handle as an integer; i.e., its offset into the file stream.

如果出错，返回 false。

范例

Example #1 ftell() 例子

<?php

// opens a file and read some data
$fp = fopen("/etc/passwd", "r");
$data = fgets($fp, 12);

// where are we ?
echo ftell($fp); // 11

fclose($fp);

?>

参见

  • fopen() - 打开文件或者 URL
  • popen() - 打开进程文件指针
  • fseek() - 在文件指针中定位
  • rewind() - 倒回文件指针的位置


将文件截断到给定的长度

  • ? ftell
  • fwrite ?
  • PHP Manual
  • 文件系统函数
  • 将文件截断到给定的长度

ftruncate

(PHP 4, PHP 5, PHP 7, PHP 8)

ftruncate — 将文件截断到给定的长度

说明

ftruncate ( resource $handle , int $size ) : bool

接受文件指针 handle 作为参数，并将文件大小截取为 size。

参数

handle

文件指针。

Note:

The handle must be open for writing.

size

The size to truncate to.

Note:

If size is larger than the file then the file is extended with null bytes.

If size is smaller than the file then the file is truncated to that size.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
4.3.3 | 在 PHP 4.3.3 之前，ftruncate() 在成功时返回一个 integer 值 1，而不是 boolean 的 true。

范例

Example #1 File truncation example

<?php
$filename = 'lorem_ipsum.txt';

$handle = fopen($filename, 'r+');
ftruncate($handle, rand(1, filesize($filename)));
rewind($handle);
echo fread($handle, filesize($filename));
fclose($handle);
?>

注释

Note:

The file pointer is not changed.

参见

  • fopen() - 打开文件或者 URL
  • fseek() - 在文件指针中定位


写入文件（可安全用于二进制文件）

  • ? ftruncate
  • glob ?
  • PHP Manual
  • 文件系统函数
  • 写入文件（可安全用于二进制文件）

fwrite

(PHP 4, PHP 5, PHP 7, PHP 8)

fwrite — 写入文件（可安全用于二进制文件）

说明

fwrite ( resource $handle , string $string , int $length = ? ) : int

fwrite() 把 string 的内容写入 文件指针 handle 处。

参数

handle

文件系统指针，是典型地由 fopen() 创建的 resource(资源)。

string

The string that is to be written.

length

如果指定了 length，当写入了 length 个字节或者写完了 string 以后，写入就会停止，视乎先碰到哪种情况。

注意如果给出了 length 参数，则 magic_quotes_runtime 配置选项将被忽略，而 string 中的斜线将不会被抽去。

返回值

fwrite() 返回写入的字符数，出现错误时则返回 false 。

注释

Note:

Writing to a network stream may end before the whole string is written. Return value of fwrite() may be checked:

<?php
function fwrite_stream($fp, $string) {
    for ($written = 0; $written < strlen($string); $written += $fwrite) {
        $fwrite = fwrite($fp, substr($string, $written));
        if ($fwrite === false) {
            return $written;
        }
    }
    return $written;
}
?>

Note:

在区分二进制文件和文本文件的系统上（如 Windows） 打开文件时，fopen() 函数的 mode 参数要加上 'b'。

Note:

If handle was fopen()ed in append mode, fwrite()s are atomic (unless the size of string exceeds the filesystem's block size, on some platforms, and as long as the file is on a local filesystem). That is, there is no need to flock() a resource before calling fwrite(); all of the data will be written without interruption.

Note:

If writing twice to the file pointer, then the data will be appended to the end of the file content:

<?php
$fp = fopen('data.txt', 'w');
fwrite($fp, '1');
fwrite($fp, '23');
fclose($fp);

// the content of 'data.txt' is now 123 and not 23!
?>

范例

Example #1 一个简单的 fwrite() 例子

<?php
$filename = 'test.txt';
$somecontent = "添加这些文字到文件\n";

// 首先我们要确定文件存在并且可写。
if (is_writable($filename)) {

    // 在这个例子里，我们将使用添加模式打开$filename，
    // 因此，文件指针将会在文件的末尾，
    // 那就是当我们使用fwrite()的时候，$somecontent将要写入的地方。
    if (!$handle = fopen($filename, 'a')) {
         echo "不能打开文件 $filename";
         exit;
    }

    // 将$somecontent写入到我们打开的文件中。
    if (fwrite($handle, $somecontent) === FALSE) {
        echo "不能写入到文件 $filename";
        exit;
    }

    echo "成功地将 $somecontent 写入到文件$filename";

    fclose($handle);

} else {
    echo "文件 $filename 不可写";
}
?>

参见

  • fread() - 读取文件（可安全用于二进制文件）
  • fopen() - 打开文件或者 URL
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接
  • popen() - 打开进程文件指针
  • file_get_contents() - 将整个文件读入一个字符串


寻找与模式匹配的文件路径

  • ? fwrite
  • is_dir ?
  • PHP Manual
  • 文件系统函数
  • 寻找与模式匹配的文件路径

glob

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

glob — 寻找与模式匹配的文件路径

说明

glob ( string $pattern , int $flags = 0 ) : array

glob() 函数依照 libc glob() 函数使用的规则寻找所有与 pattern 匹配的文件路径，类似于一般 shells 所用的规则一样。

参数

pattern

匹配模式（pattern）。 不进行缩写扩展或参数替代。

特殊字符：

  • * - 匹配零个或多个字符。
  • ? - 只匹配单个字符（任意字符）。
  • [...] - 匹配一组字符中的一个字符。 如果第一个字符是 !，则为否定模式， 即匹配不在这组字符中的任意字符。
  • \ - 只要没有使用 GLOB_NOESCAPE 标记，该字符会转义后面的字符。

flags

有效标记有：

  • GLOB_MARK - 在每个返回的项目中加一个斜线
  • GLOB_NOSORT - 按照文件在目录中出现的原始顺序返回（不排序）
  • GLOB_NOCHECK - 如果没有文件匹配则返回用于搜索的模式
  • GLOB_NOESCAPE - 反斜线不转义元字符
  • GLOB_BRACE - 扩充 {a,b,c} 来匹配 'a'，'b' 或 'c'
  • GLOB_ONLYDIR - 仅返回与模式匹配的目录项
  • GLOB_ERR - 停止并读取错误信息（比如说不可读的目录），默认的情况下忽略所有错误

返回值

返回包含有匹配文件和目录的数组，没有匹配文件时返回空数组，出错返回 false。

Note:

在个别操作系统上，无法区分是否为空匹配或错误。

范例

Example #1 怎样用 glob() 方便地替代 opendir() 和相关函数

<?php
foreach (glob("*.txt") as $filename) {
    echo "$filename size " . filesize($filename) . "\n";
}
?>

以上例程的输出类似于：

funclist.txt size 44686
funcsummary.txt size 267625
quickref.txt size 137820

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

Note: 此函数在一些系统上还不能工作（例如一些旧的 Sun OS）。

Note: GLOB_BRACE 在一些非 GNU 系统上无效，比如 Solaris。

参见

  • opendir() - 打开目录句柄
  • readdir() - 从目录句柄中读取条目
  • closedir() - 关闭目录句柄
  • fnmatch() - 用模式匹配文件名


判断给定文件名是否是一个目录

  • ? glob
  • is_executable ?
  • PHP Manual
  • 文件系统函数
  • 判断给定文件名是否是一个目录

is_dir

(PHP 4, PHP 5, PHP 7, PHP 8)

is_dir — 判断给定文件名是否是一个目录

说明

is_dir ( string $filename ) : bool

判断给定文件名是否是一个目录。

参数

filename

如果文件名存在并且为目录则返回 true。如果 filename 是一个相对路径，则按照当前工作目录检查其相对路径。 If filename is a symbolic or hard link then the link will be resolved and checked.If you have enabled open_basedir further restrictions may apply.

返回值

如果文件名存在，并且是个目录，返回 true，否则返回false。

范例

Example #1 is_dir() 例子

<?php
var_dump(is_dir('a_file.txt'));
var_dump(is_dir('bogus_dir/abc'));

var_dump(is_dir('..')); //one dir up
?>

以上例程会输出：

bool(false)
bool(false)
bool(true)

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • chdir() - 改变目录
  • dir() - 返回一个 Directory 类实例
  • opendir() - 打开目录句柄
  • is_file() - 判断给定文件名是否为一个正常的文件
  • is_link() - 判断给定文件名是否为一个符号连接


判断给定文件名是否可执行

  • ? is_dir
  • is_file ?
  • PHP Manual
  • 文件系统函数
  • 判断给定文件名是否可执行

is_executable

(PHP 4, PHP 5, PHP 7, PHP 8)

is_executable — 判断给定文件名是否可执行

说明

is_executable ( string $filename ) : bool

判断给定文件名是否可执行。

参数

filename

文件的路径。

返回值

如果文件存在且可执行则返回 true，错误时返回false。

更新日志

版本 | 说明
5.0.0 | is_executable() 开始可用以于 Windows。

范例

Example #1 is_executable() 例子

<?php

$file = '/home/vincent/somefile.sh';

if (is_executable($file)) {
    echo $file.' is executable';
} else {
    echo $file.' is not executable';
}

?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • is_file() - 判断给定文件名是否为一个正常的文件
  • is_link() - 判断给定文件名是否为一个符号连接


判断给定文件名是否为一个正常的文件

  • ? is_executable
  • is_link ?
  • PHP Manual
  • 文件系统函数
  • 判断给定文件名是否为一个正常的文件

is_file

(PHP 4, PHP 5, PHP 7, PHP 8)

is_file — 判断给定文件名是否为一个正常的文件

说明

is_file ( string $filename ) : bool

判断给定文件名是否为一个正常的文件。

参数

filename

文件的路径。

返回值

如果文件存在且为正常的文件则返回 true，否则返回 false。

Note: 因为 PHP 的整数类型是有符号整型而且很多平台使用 32 位整型，对 2GB 以上的文件，一些文件系统函数可能返回无法预期的结果。

范例

Example #1 is_file() 例子

<?php
var_dump(is_file('a_file.txt')) . "\n";
var_dump(is_file('/usr/bin/')) . "\n";
?>

以上例程会输出：

bool(true)
bool(false)

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • is_dir() - 判断给定文件名是否是一个目录
  • is_link() - 判断给定文件名是否为一个符号连接


判断给定文件名是否为一个符号连接

  • ? is_file
  • is_readable ?
  • PHP Manual
  • 文件系统函数
  • 判断给定文件名是否为一个符号连接

is_link

(PHP 4, PHP 5, PHP 7, PHP 8)

is_link — 判断给定文件名是否为一个符号连接

说明

is_link ( string $filename ) : bool

判断给定文件名是否为一个符号连接。

参数

filename

文件的路径。

返回值

如果文件存在并且是一个符号连接则返回 true，否则返回 false。

范例

Example #1 创建并确认一个文件是否为符号连接

<?php
$link = 'uploads';

if (is_link($link)) {
    echo(readlink($link));
} else {
    symlink('uploads.php', $link);
}
?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • is_dir() - 判断给定文件名是否是一个目录
  • is_file() - 判断给定文件名是否为一个正常的文件
  • readlink() - 返回符号连接指向的目标


判断给定文件名是否可读

  • ? is_link
  • is_uploaded_file ?
  • PHP Manual
  • 文件系统函数
  • 判断给定文件名是否可读

is_readable

(PHP 4, PHP 5, PHP 7, PHP 8)

is_readable — 判断给定文件名是否可读

说明

is_readable ( string $filename ) : bool

判断给定文件名是否存在并且可读。

参数

filename

文件的路径。

返回值

如果由 filename 指定的文件或目录存在并且可读则返回 true，否则返回 false。

范例

Example #1 is_readable() 例子

<?php
$filename = 'test.txt';
if (is_readable($filename)) {
    echo 'The file is readable';
} else {
    echo 'The file is not readable';
}
?>

错误／异常

失败时抛出E_WARNING警告。

注释

记住 PHP 也许只能以运行 webserver 的用户名（通常为 'nobody'）来访问文件。不计入安全模式的限制。 Safe mode limitations are not taken into account before PHP 5.1.5.

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

Note:

The check is done using the real UID/GID instead of the effective one.

对于目录这个函数可能会返回 true。请使用 is_dir() 来区分文件和目录。

参见

  • is_writable() - 判断给定的文件名是否可写
  • file_exists() - 检查文件或目录是否存在
  • fgets() - 从文件指针中读取一行


判断文件是否是通过 HTTP POST 上传的

  • ? is_readable
  • is_writable ?
  • PHP Manual
  • 文件系统函数
  • 判断文件是否是通过 HTTP POST 上传的

is_uploaded_file

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

is_uploaded_file — 判断文件是否是通过 HTTP POST 上传的

说明

is_uploaded_file ( string $filename ) : bool

如果 filename 所给出的文件是通过 HTTP POST 上传的则返回 true。这可以用来确保恶意的用户无法欺骗脚本去访问本不能访问的文件，例如 /etc/passwd。

这种检查显得格外重要，如果上传的文件有可能会造成对用户或本系统的其他用户显示其内容的话。

为了能使 is_uploaded_file() 函数正常工作，必段指定类似于 $_FILES['userfile']['tmp_name'] 的变量，而在从客户端上传的文件名 $_FILES['userfile']['name'] 不能正常运作。

参数

filename

要检查的文件名。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 is_uploaded_file() 例子

<?php

if (is_uploaded_file($_FILES['userfile']['tmp_name'])) {
   echo "File ". $_FILES['userfile']['name'] ." uploaded successfully.\n";
   echo "Displaying contents\n";
   readfile($_FILES['userfile']['tmp_name']);
} else {
   echo "Possible file upload attack: ";
   echo "filename '". $_FILES['userfile']['tmp_name'] . "'.";
}

?>

参见

  • move_uploaded_file() - 将上传的文件移动到新位置
  • $_FILES
  • 关于用法的简单例子 文件上传处理


判断给定的文件名是否可写

  • ? is_uploaded_file
  • is_writeable ?
  • PHP Manual
  • 文件系统函数
  • 判断给定的文件名是否可写

is_writable

(PHP 4, PHP 5, PHP 7, PHP 8)

is_writable — 判断给定的文件名是否可写

说明

is_writable ( string $filename ) : bool

如果文件存在并且可写则返回 true。filename 参数可以是一个允许进行是否可写检查的目录名。

记住 PHP 也许只能以运行 webserver 的用户名（通常为 'nobody'）来访问文件。不计入安全模式的限制。

参数

filename

要检查的文件名称。

返回值

如果文件 filename 存在并且可写则返回 true。

范例

Example #1 is_writable() 例子

<?php
$filename = 'test.txt';
if (is_writable($filename)) {
    echo 'The file is writable';
} else {
    echo 'The file is not writable';
}
?>

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • is_readable() - 判断给定文件名是否可读
  • file_exists() - 检查文件或目录是否存在
  • fwrite() - 写入文件（可安全用于二进制文件）


is_writable 的别名

  • ? is_writable
  • lchgrp ?
  • PHP Manual
  • 文件系统函数
  • is_writable 的别名

is_writeable

(PHP 4, PHP 5, PHP 7, PHP 8)

is_writeable — is_writable() 的别名

说明

此函数是该函数的别名：is_writable()。


修改符号链接的所有组

  • ? is_writeable
  • lchown ?
  • PHP Manual
  • 文件系统函数
  • 修改符号链接的所有组

lchgrp

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

lchgrp — 修改符号链接的所有组

说明

lchgrp ( string $filename , mixed $group ) : bool

尝试修改符号链接 filename 的所有组 group

只有超级用户可以任意修改符号链接的所有组;其他用户可能需要有修改目标组的权限才能修改至目标所有组。

参数

filename

符号链接路径

group

所有组的名字或者编号

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 更改符号链接的所有组

<?php
$target = 'output.php';
$link = 'output.html';
symlink($target, $link);

lchgrp($link, 8);
?>

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

Note: 此函数未在 Windows 平台下实现。

参见

  • chgrp() - 改变文件所属的组
  • lchown() - 修改符号链接的所有者
  • chown() - 改变文件的所有者
  • chmod() - 改变文件模式


修改符号链接的所有者

  • ? lchgrp
  • link ?
  • PHP Manual
  • 文件系统函数
  • 修改符号链接的所有者

lchown

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

lchown — 修改符号链接的所有者

说明

lchown ( string $filename , mixed $user ) : bool

尝试修改符号链接 filename 的 所有者 user

只有超级用户任意修改符号链接的所有者。

参数

filename

文件路径。

user

所有者名称或编号

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Changing the owner of a symbolic link

<?php
$target = 'output.php';
$link = 'output.html';
symlink($target, $link);

lchown($link, 8);
?>

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

Note: 此函数未在 Windows 平台下实现。

参见

  • chown() - 改变文件的所有者
  • lchgrp() - 修改符号链接的所有组
  • chgrp() - 改变文件所属的组
  • chmod() - 改变文件模式


建立一个硬连接

  • ? lchown
  • linkinfo ?
  • PHP Manual
  • 文件系统函数
  • 建立一个硬连接

link

(PHP 4, PHP 5, PHP 7, PHP 8)

link — 建立一个硬连接

说明

link ( string $target , string $link ) : bool

link() 建立一个硬连接。

参数

target

要链接的目标。

link

链接的名称。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note: Windows下：该功能需要以 elevated 模式运行，或者关闭 UAC。

更新日志

版本 | 说明
5.3.0 | 该功能在 Windows 平台下开始有效（Vista、 Server 2008 或更高版本）。

范例

Example #1 Creating a simple hard link

<?php
$target = 'source.ext'; // This is the file that already exists
$link = 'newfile.ext'; // This the filename that you want to link it to

link($target, $link);
?>

注释

Note: 此函数不能作用于远程文件，被检查的文件必须是可通过服务器的文件系统访问的。

参见

  • symlink() - 建立符号连接
  • readlink() - 返回符号连接指向的目标
  • linkinfo() - 获取一个连接的信息


获取一个连接的信息

  • ? link
  • lstat ?
  • PHP Manual
  • 文件系统函数
  • 获取一个连接的信息

linkinfo

(PHP 4, PHP 5, PHP 7, PHP 8)

linkinfo — 获取一个连接的信息

说明

linkinfo ( string $path ) : int

获取一个连接的信息。

本函数用来验证一个连接（由 path 所指向的）是否确实存在（使用 stat.h 中的 S_ISLNK 宏同样的方法）。

参数

path

连接的路径。

返回值

linkinfo() 返回 lstat 系统调用所返回的 UNIX C stat 结构中的 st_dev 字段。 如果出错则返回 0 或 false。

更新日志

版本 | 说明
5.3.0 | Windows 平台上开始可用（Vista、Server 2008 或更高版本）。

范例

Example #1 linkinfo() 例子

<?php

echo linkinfo('/vmlinuz'); // 835

?>

参见

  • symlink() - 建立符号连接
  • link() - 建立一个硬连接
  • readlink() - 返回符号连接指向的目标


给出一个文件或符号连接的信息

  • ? linkinfo
  • mkdir ?
  • PHP Manual
  • 文件系统函数
  • 给出一个文件或符号连接的信息

lstat

(PHP 4, PHP 5, PHP 7, PHP 8)

lstat — 给出一个文件或符号连接的信息

说明

lstat ( string $filename ) : array

获取由 filename 指定的文件或符号连接的统计信息。

参数

filename

文件或符号连接的路径。

返回值

有关 lstat() 返回的数组结构见手册中 stat() 函数的页面。 本函数和 stat() 函数相同，只除了如果 filename 参数是符号连接的话，则该符号连接的状态被返回，而不是该符号连接所指向的文件的状态。

范例

Example #1 stat() 和 lstat() 的对照

<?php
symlink('uploads.php', 'uploads');

// Contrast information for uploads.php and uploads
array_diff(stat('uploads'), lstat('uploads'));
?>

以上例程的输出类似于：

Information that differs between the two files.

Array
(
    [ino] => 97236376
    [mode] => 33188
    [size] => 34
    [atime] => 1223580003
    [mtime] => 1223581848
    [ctime] => 1223581848
    [blocks] => 8
)

错误／异常

失败时抛出E_WARNING警告。

注释

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • stat() - 给出文件的信息


新建目录

  • ? lstat
  • move_uploaded_file ?
  • PHP Manual
  • 文件系统函数
  • 新建目录

mkdir

(PHP 4, PHP 5, PHP 7, PHP 8)

mkdir — 新建目录

说明

mkdir ( string $pathname , int $mode = 0777 , bool $recursive = false , resource $context = ? ) : bool

尝试新建一个由 pathname 指定的目录。

参数

pathname

目录的路径。

mode

默认的 mode 是 0777，意味着最大可能的访问权。有关 mode 的更多信息请阅读 chmod() 页面。

Note:

mode 在 Windows 下被忽略。

注意也许想用八进制数指定模式，也就是说该数应以零打头。模式也会被当前的 umask 修改，可以用 umask() 来改变。

recursive

允许递归创建由 pathname 所指定的多级嵌套目录。

context

Note: 在 PHP 5.0.0 中增加了对上下文（Context）的支持。有关上下文（Context）的说明参见 Streams。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mkdir() 例子

<?php
mkdir("/path/to/my/dir", 0700);
?>

Example #2 通过 recursive 参数使用 mkdir()

<?php
// Desired folder structure
$structure = './depth1/depth2/depth3/';

// To create the nested structure, the $recursive parameter
// to mkdir() must be specified.

if (!mkdir($structure, 0777, true)) {
    die('Failed to create folders...');
}

// ...
?>

错误／异常

目录已存在时，产生 E_WARNING错误。

如果因为权限问题无法创建目录，导致 E_WARNING错误。

参见

  • is_dir() - 判断给定文件名是否是一个目录
  • rmdir() - 删除目录


将上传的文件移动到新位置

  • ? mkdir
  • parse_ini_file ?
  • PHP Manual
  • 文件系统函数
  • 将上传的文件移动到新位置

move_uploaded_file

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

move_uploaded_file — 将上传的文件移动到新位置

说明

move_uploaded_file ( string $filename , string $destination ) : bool

本函数检查并确保由 filename 指定的文件是合法的上传文件（即通过 PHP 的 HTTP POST 上传机制所上传的）。如果文件合法，则将其移动为由 destination 指定的文件。

这种检查显得格外重要，如果上传的文件有可能会造成对用户或本系统的其他用户显示其内容的话。

参数

filename

上传的文件的文件名。

destination

移动文件到这个位置。

返回值

成功时返回 true。

如果 filename 不是合法的上传文件，不会出现任何操作，move_uploaded_file() 将返回 false。

如果 filename 是合法的上传文件，但出于某些原因无法移动，不会出现任何操作，move_uploaded_file() 将返回 false。此外还会发出一条警告。

范例

Example #1 Uploading multiple files

<?php
$uploads_dir = '/uploads';
foreach ($_FILES["pictures"]["error"] as $key => $error) {
    if ($error == UPLOAD_ERR_OK) {
        $tmp_name = $_FILES["pictures"]["tmp_name"][$key];
        $name = $_FILES["pictures"]["name"][$key];
        move_uploaded_file($tmp_name, "$uploads_dir/$name");
    }
}
?>

注释

Note:

move_uploaded_file() 对 open_basedir 是敏感的。不过，限制只针对 destination 路径，因为允许移动上传的文件名 filename 可能会与这些限制产生冲突。move_uploaded_file() 仅作用于通过 PHP 上传的文件以确保这个操作的安全性。

Warning

如果目标文件已经存在，将会被覆盖。

参见

  • is_uploaded_file() - 判断文件是否是通过 HTTP POST 上传的
  • rename() - 重命名一个文件或目录
  • 参见文件上传处理一章中的简单使用例子。


解析一个配置文件

  • ? move_uploaded_file
  • parse_ini_string ?
  • PHP Manual
  • 文件系统函数
  • 解析一个配置文件

parse_ini_file

(PHP 4, PHP 5, PHP 7, PHP 8)

parse_ini_file — 解析一个配置文件

说明

parse_ini_file ( string $filename , bool $process_sections = false , int $scanner_mode = INI_SCANNER_NORMAL ) : array

parse_ini_file() 载入一个由 filename 指定的 ini 文件，并将其中的设置作为一个联合数组返回。

ini 文件的结构和 php.ini 的相似。

参数

filename

要解析的 ini 文件的文件名。

process_sections

如果将最后的 process_sections 参数设为 true，将得到一个多维数组，包括了配置文件中每一节的名称和设置。process_sections 的默认值是 false。

scanner_mode

Can either be INI_SCANNER_NORMAL (default) or INI_SCANNER_RAW. If INI_SCANNER_RAW is supplied, then option values will not be parsed.

返回值

成功时以关联数组 array 返回设置，失败时返回 false。

范例

Example #1 sample.ini 的内容

; This is a sample configuration file
; Comments start with ';', as in php.ini

[first_section]
one = 1
five = 5
animal = BIRD

[second_section]
path = "/usr/local/bin"
URL = "http://www.example.com/~username"

[third_section]
phpversion[] = "5.0"
phpversion[] = "5.1"
phpversion[] = "5.2"
phpversion[] = "5.3"

Example #2 parse_ini_file() 例子

常量也可以在 ini 文件中被解析，因此如果在运行 parse_ini_file() 之前定义了常量作为 ini 的值，将会被集成到结果中去。只有 ini 的值会被求值。例如：

<?php

define('BIRD', 'Dodo bird');

// Parse without sections
$ini_array = parse_ini_file("sample.ini");
print_r($ini_array);

// Parse with sections
$ini_array = parse_ini_file("sample.ini", true);
print_r($ini_array);

?>

以上例程的输出类似于：

Array
(
    [one] => 1
    [five] => 5
    [animal] => Dodo bird
    [path] => /usr/local/bin
    [URL] => http://www.example.com/~username
    [phpversion] => Array
        (
            [0] => 5.0
            [1] => 5.1
            [2] => 5.2
            [3] => 5.3
        )

)
Array
(
    [first_section] => Array
        (
            [one] => 1
            [five] => 5
            [animal] => Dodo bird
        )

    [second_section] => Array
        (
            [path] => /usr/local/bin
            [URL] => http://www.example.com/~username
        )

    [third_section] => Array
        (
            [phpversion] => Array
                (
                    [0] => 5.0
                    [1] => 5.1
                    [2] => 5.2
                    [3] => 5.3
                )

        )

)

Example #3 parse_ini_file() parsing a php.ini file

<?php
// A simple function used for comparing the results below
function yesno($expression)
{
    return($expression ? 'Yes' : 'No');
}

// Get the path to php.ini using the php_ini_loaded_file()
// function available as of PHP 5.2.4
$ini_path = php_ini_loaded_file();

// Parse php.ini
$ini = parse_ini_file($ini_path);

// Print and compare the values, note that using get_cfg_var()
// will give the same results for parsed and loaded here
echo '(parsed) magic_quotes_gpc = ' . yesno($ini['magic_quotes_gpc']) . PHP_EOL;
echo '(loaded) magic_quotes_gpc = ' . yesno(get_cfg_var('magic_quotes_gpc')) . PHP_EOL;
?>

以上例程的输出类似于：

(parsed) magic_quotes_gpc = Yes
(loaded) magic_quotes_gpc = Yes

注释

Note:

本函数和 php.ini 文件没有关系，该文件在运行脚本时就已经处理过了。本函数可以用来读取你自己的应用程序的配置文件。

Note:

如果 ini 文件中的值包含任何非字母数字的字符，需要将其括在双引号中（"）。

Note: 有些保留字不能作为 ini 文件中的键名，包括：null，yes，no，true 和 false。值为 null，no 和 false 等效于 ""，值为 yes 和 true 等效于 "1"。字符 {}|&~![()" 也不能用在键名的任何地方，而且这些字符在选项值中有着特殊的意义。

参见

  • parse_ini_string() - 解析配置字符串


解析配置字符串

  • ? parse_ini_file
  • pathinfo ?
  • PHP Manual
  • 文件系统函数
  • 解析配置字符串

parse_ini_string

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

parse_ini_string — 解析配置字符串

说明

parse_ini_string ( string $ini , bool $process_sections = false , int $scanner_mode = INI_SCANNER_NORMAL ) : array

parse_ini_string() 返回 ini 字符串解析后的关联数组

ini 字符串的格式参考 php.ini

参数

ini

ini 字符串内容

process_sections

设置 process_sections 参数为 true,得到一个多维数组,包含名称和设置。process_sections 默认为 false

scanner_mode

可以是 INI_SCANNER_NORMAL (默认)或 INI_SCANNER_RAW 。如果是 INI_SCANNER_RAW,那么选项值不会被解析。

As of PHP 5.6.1 can also be specified as INI_SCANNER_TYPED. In this mode boolean, null and integer types are preserved when possible. String values "true", "on" and "yes" are converted to true. "false", "off", "no" and "none" are considered false. "null" is converted to null in typed mode. Also, all numeric strings are converted to integer type if it is possible.

返回值

执行成功返回一个关联数组,返回 false 为失败

注释

Note: 保留关键字不能作为 ini 的键，包括 null, yes, no, true, false, on, off, none以及空值，off，no 和错误的结果集，值为 yes 和 正确的结果集。除非使用 INI_SCANNER_TYPED 模式。 字符 ?{}|&~![()^" 不能在任何地方使用作为键和有特殊意义的值。

参见

  • parse_ini_file() - 解析一个配置文件


返回文件路径的信息

  • ? parse_ini_string
  • pclose ?
  • PHP Manual
  • 文件系统函数
  • 返回文件路径的信息

pathinfo

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

pathinfo — 返回文件路径的信息

说明

pathinfo ( string $path , int $options = PATHINFO_DIRNAME | PATHINFO_BASENAME | PATHINFO_EXTENSION | PATHINFO_FILENAME ) : mixed

pathinfo() 返回一个关联数组包含有 path 的信息。返回关联数组还是字符串取决于 options。

参数

path

要解析的路径。

options

如果指定了，将会返回指定元素；它们包括：PATHINFO_DIRNAME，PATHINFO_BASENAME 和 PATHINFO_EXTENSION 或 PATHINFO_FILENAME。

如果没有指定 options 默认是返回全部的单元。

返回值

如果没有传入 options ，将会返回包括以下单元的数组 array：dirname，basename 和 extension（如果有），以 及filename。

Note:

If the path does not have an extension, no extension element will be returned（以下第二个案例）。

If options is present, returns a string containing the requested element.

更新日志

版本 | 说明
5.2.0 | 添加了常量 PATHINFO_FILENAME。

范例

Example #1 pathinfo() 例子

<?php
$path_parts = pathinfo('/www/htdocs/inc/lib.inc.php');

echo $path_parts['dirname'], "\n";
echo $path_parts['basename'], "\n";
echo $path_parts['extension'], "\n";
echo $path_parts['filename'], "\n"; // since PHP 5.2.0
?>

以上例程会输出：

/www/htdocs/inc
lib.inc.php
php
lib.inc

Example #2 pathinfo() example showing difference between null and no extension

<?php
$path_parts = pathinfo('/path/emptyextension.');
var_dump($path_parts['extension']);

$path_parts = pathinfo('/path/noextension');
var_dump($path_parts['extension']);
?>

以上例程的输出类似于：

string(0) ""

Notice: Undefined index: extension in test.php on line 6
NULL

注释

Note:

有关取得当前路径信息的说明，请阅读预定义变量一节。

Note:

pathinfo() is locale aware, so for it to parse a path containing multibyte characters correctly, the matching locale must be set using the setlocale() function.

参见

  • dirname() - 返回路径中的目录部分
  • basename() - 返回路径中的文件名部分
  • parse_url() - 解析 URL，返回其组成部分
  • realpath() - 返回规范化的绝对路径名


关闭进程文件指针

  • ? pathinfo
  • popen ?
  • PHP Manual
  • 文件系统函数
  • 关闭进程文件指针

pclose

(PHP 4, PHP 5, PHP 7, PHP 8)

pclose — 关闭进程文件指针

说明

pclose ( resource $handle ) : int

关闭用 popen() 打开的指向管道的文件指针。

参数

handle

文件指针必须有效，且必须是成功调用 popen() 所返回的。

返回值

返回运行的进程的终止状态。发生错误时会返回 -1。

范例

Example #1 pclose() 例子

<?php
$handle = popen('/bin/ls', 'r');
pclose($handle);
?>

注释

Note: Unix Only:

proc_close() is internally implemented using the waitpid(3) system call. To obtain the real exit status code the pcntl_wexitstatus() function should be used.

参见

  • popen() - 打开进程文件指针


打开进程文件指针

  • ? pclose
  • readfile ?
  • PHP Manual
  • 文件系统函数
  • 打开进程文件指针

popen

(PHP 4, PHP 5, PHP 7, PHP 8)

popen — 打开进程文件指针

说明

popen ( string $command , string $mode ) : resource

打开一个指向进程的管道，该进程由派生给定的 command 命令执行而产生。

参数

command

命令。

mode

模式。

返回值

返回一个和 fopen()
所返回的相同的文件指针，只不过它是单向的（只能用于读或写）并且必须用
pclose() 来关闭。此指针可以用于
fgets()，fgetss() 和
fwrite()。
当模式为 'r'，返回的文件指针等于命令的 STDOUT，当模式为 'w'，返回的文件指针等于命令的 STDIN。

如果出错返回 false。

范例

Example #1 popen() 例子

<?php
$handle = popen("/bin/ls", "r");
?>

如果未找到要执行的命令，会返回一个合法的资源。这看上去很怪，但有道理。它允许访问 shell 返回的任何错误信息：

Example #2 popen() 例子

<?php
error_reporting(E_ALL);

/* 加入重定向以得到标准错误输出 stderr。 */
$handle = popen('/path/to/executable 2>&1', 'r');
echo "'$handle'; " . gettype($handle) . "\n";
$read = fread($handle, 2096);
echo $read;
pclose($handle);
?>

注释

Note:

如果需要双向支持，使用 proc_open()。

参见

  • pclose() - 关闭进程文件指针
  • fopen() - 打开文件或者 URL
  • proc_open() - 执行一个命令，并且打开用来输入/输出的文件指针。


输出文件

  • ? popen
  • readlink ?
  • PHP Manual
  • 文件系统函数
  • 输出文件

readfile

(PHP 4, PHP 5, PHP 7, PHP 8)

readfile — 输出文件

说明

readfile ( string $filename , bool $use_include_path = false , resource $context = ? ) : int

读取文件并写入到输出缓冲。

参数

filename

要读取的文件名。

use_include_path

想要在 include_path 中搜索文件，可使用这个可选的第二个参数，设为 true。

context

Stream 上下文（context） resource。

返回值

成功时返回从文件中读入的字节数， 或者在失败时返回 false

错误／异常

失败时抛出E_WARNING警告。

范例

Example #1 使用 readfile() 强制下载

<?php
$file = 'monkey.gif';

if (file_exists($file)) {
    header('Content-Description: File Transfer');
    header('Content-Type: application/octet-stream');
    header('Content-Disposition: attachment; filename="'.basename($file).'"');
    header('Expires: 0');
    header('Cache-Control: must-revalidate');
    header('Pragma: public');
    header('Content-Length: ' . filesize($file));
    readfile($file);
    exit;
}
?>

以上例程的输出类似于：

打开 / 保存对话框

注释

Note:

readfile() 自身不会导致任何内存问题。 如果出现内存不足的错误，使用 ob_get_level() 确保输出缓存已经关闭。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

Note: 在 PHP 5.0.0 中增加了对上下文（Context）的支持。有关上下文（Context）的说明参见 Streams。

参见

  • fpassthru() - 输出文件指针处的所有剩余数据
  • file() - 把整个文件读入一个数组中
  • fopen() - 打开文件或者 URL
  • include - include
  • require - require
  • virtual() - 执行 Apache 子请求
  • file_get_contents() - 将整个文件读入一个字符串
  • 支持的协议和封装协议


返回符号连接指向的目标

  • ? readfile
  • realpath_cache_get ?
  • PHP Manual
  • 文件系统函数
  • 返回符号连接指向的目标

readlink

(PHP 4, PHP 5, PHP 7, PHP 8)

readlink — 返回符号连接指向的目标

说明

readlink ( string $path ) : string

readlink() 和同名的 C 函数做同样的事，返回符号连接的内容。

参数

path

链接符号的路径。

更新日志

版本 | 说明
5.3.0 | 此函数在 Windows 平台下可用（Vista、Server 2008 或更高版本）。

返回值

返回链接的路径内容，出错则返回 false。

范例

Example #1 readlink() 例

<?php

// output e.g. /boot/vmlinux-2.4.20-xfs
echo readlink('/vmlinuz');

?>

参见

  • is_link() - 判断给定文件名是否为一个符号连接
  • symlink() - 建立符号连接
  • linkinfo() - 获取一个连接的信息


获取真实目录缓存的详情

  • ? readlink
  • realpath_cache_size ?
  • PHP Manual
  • 文件系统函数
  • 获取真实目录缓存的详情

realpath_cache_get

(PHP 5 >= 5.3.2, PHP 7, PHP 8)

realpath_cache_get — 获取真实目录缓存的详情

说明

realpath_cache_get ( ) : array

获得真实路径缓存的详情。

返回值

返回真实路径缓存详情的数组。键是原始路径以及值为具体信息数组，含有该解析的路径，过期时间以及其他的更多选项。

范例

Example #1 realpath_cache_get() example

<?php
var_dump(realpath_cache_get());
?>

以上例程的输出类似于：

array(2) {
  ["/test"]=>
  array(4) {
    ["key"]=>
    int(123456789)
    ["is_dir"]=>
    bool(true)
    ["realpath"]=>
    string(5) "/test"
    ["expires"]=>
    int(1260318939)
  }
  ["/test/test.php"]=>
  array(4) {
    ["key"]=>
    int(987654321)
    ["is_dir"]=>
    bool(false)
    ["realpath"]=>
    string(12) "/root/test.php"
    ["expires"]=>
    int(1260318939)
  }
}

参见

  • realpath_cache_size() - 获取真实路径缓冲区的大小


获取真实路径缓冲区的大小

  • ? realpath_cache_get
  • realpath ?
  • PHP Manual
  • 文件系统函数
  • 获取真实路径缓冲区的大小

realpath_cache_size

(PHP 5 >= 5.3.2, PHP 7, PHP 8)

realpath_cache_size — 获取真实路径缓冲区的大小

说明

realpath_cache_size ( ) : int

获取真实路径缓存区大小在内存中的使用量。

返回值

返回真实路径缓存区使用内存的用量。

范例

Example #1 realpath_cache_size() example

<?php
var_dump(realpath_cache_size());
?>

以上例程的输出类似于：

int(412)

参见

  • realpath_cache_get() - 获取真实目录缓存的详情
  • realpath_cache_size 方法的配置选项


返回规范化的绝对路径名

  • ? realpath_cache_size
  • rename ?
  • PHP Manual
  • 文件系统函数
  • 返回规范化的绝对路径名

realpath

(PHP 4, PHP 5, PHP 7, PHP 8)

realpath — 返回规范化的绝对路径名

说明

realpath ( string $path ) : string|false

realpath() 扩展所有符号连接，并处理输入 path 中的 /./、/../ 和多余的 /，并返回规范化的绝对路径名。

参数

path

要处理的路径。

Note:

虽然必须提供路径，但该值可以是一个空字符串。 在这种情况下，该值将被解释为当前目录。

返回值

成功时返回规范化的绝对路径名。返回的路径中没有符号连接（symbolic link）、/./ 或 /../ 成分。 例如 \ 和 / 这样的尾随分隔符也将被删除。

realpath() 失败时返回 false，例如文件不存在。

Note:

当前运行的脚本必须对要处理的路径中的每层目录都具有可执行权限，否则 realpath() 将返回 false。

Note:

对于不区分大小写的文件系统，realpath() 不一定会规范字符大小写。

Note:

realpath() 函数不适用于 Phar 内的文件，因为该路径是虚拟路径，而不是真实路径。

Note:

在 Windows 上，目录的结点和符号链接仅扩展一级。

Note: 因为 PHP 的整数类型是有符号整型而且很多平台使用 32 位整型，对 2GB 以上的文件，一些文件系统函数可能返回无法预期的结果。

范例

Example #1 realpath() 例子

<?php
chdir('/var/www/');
echo realpath('./../../etc/passwd') . PHP_EOL;

echo realpath('/tmp/') . PHP_EOL;
?>

以上例程会输出：

/etc/passwd
/tmp

Example #2 Windows 上的 realpath()

在 Windows 上，realpath() 会将 unix 风格的路径改成 Windows 风格。

<?php
echo realpath('/windows/system32'), PHP_EOL;

echo realpath('C:\Program Files\\'), PHP_EOL;
?>

以上例程会输出：

C:\WINDOWS\System32
C:\Program Files

参见

  • basename() - 返回路径中的文件名部分
  • dirname() - 返回路径中的目录部分
  • pathinfo() - 返回文件路径的信息


重命名一个文件或目录

  • ? realpath
  • rewind ?
  • PHP Manual
  • 文件系统函数
  • 重命名一个文件或目录

rename

(PHP 4, PHP 5, PHP 7, PHP 8)

rename — 重命名一个文件或目录

说明

rename ( string $oldname , string $newname , resource $context = ? ) : bool

尝试把 oldname 重命名为 newname，必要时会在不同目录间移动。 如果重命名文件时 newname 已经存在，将会覆盖掉它。 如果重命名文件夹时 newname 已经存在，本函数将导致一个警告。

参数

oldname

原名

Note:

用于 oldname 中的封装协议必须和用于 newname 中的相匹配。

newname

新的名字。

Note: 在 Windows 上，如果 newname 已经存在，它必须是可写的。 否则 rename() 将失败，并导致 E_WARNING。

context

Note: 在 PHP 5.0.0 中增加了对上下文（Context）的支持。有关上下文（Context）的说明参见 Streams。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 rename() 例子

<?php
rename("/tmp/tmp_file.txt", "/home/user/login/docs/my_file.txt");
?>

参见

  • copy() - 拷贝文件
  • unlink() - 删除文件
  • move_uploaded_file() - 将上传的文件移动到新位置


倒回文件指针的位置

  • ? rename
  • rmdir ?
  • PHP Manual
  • 文件系统函数
  • 倒回文件指针的位置

rewind

(PHP 4, PHP 5, PHP 7, PHP 8)

rewind — 倒回文件指针的位置

说明

rewind ( resource $handle ) : bool

将 handle 的文件位置指针设为文件流的开头。

Note:

如果将文件以附加（"a" 或者 "a+"）模式打开，写入文件的任何数据总是会被附加在后面，不管文件指针的位置。

参数

handle

文件指针必须合法，并且指向由 fopen() 成功打开的文件。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 rewind() overwriting example

<?php
$handle = fopen('output.txt', 'r+');

fwrite($handle, 'Really long sentence.');
rewind($handle);
fwrite($handle, 'Foo');
rewind($handle);

echo fread($handle, filesize('output.txt'));

fclose($handle);
?>

以上例程的输出类似于：

Foolly long sentence.

参见

  • fread() - 读取文件（可安全用于二进制文件）
  • fseek() - 在文件指针中定位
  • ftell() - 返回文件指针读/写的位置
  • fwrite() - 写入文件（可安全用于二进制文件）


删除目录

  • ? rewind
  • set_file_buffer ?
  • PHP Manual
  • 文件系统函数
  • 删除目录

rmdir

(PHP 4, PHP 5, PHP 7, PHP 8)

rmdir — 删除目录

说明

rmdir ( string $dirname , resource $context = ? ) : bool

尝试删除 dirname 所指定的目录。 该目录必须是空的，而且要有相应的权限。 失败时会产生一个 E_WARNING 级别的错误。

参数

dirname

目录的路径。

context

Note: 在 PHP 5.0.0 中增加了对上下文（Context）的支持。有关上下文（Context）的说明参见 Streams。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 rmdir() 例子

<?php
if (!is_dir('examples')) {
    mkdir('examples');
}

rmdir('examples');
?>

参见

  • is_dir() - 判断给定文件名是否是一个目录
  • mkdir() - 新建目录
  • unlink() - 删除文件


stream_set_write_buffer 的别名

  • ? rmdir
  • stat ?
  • PHP Manual
  • 文件系统函数
  • stream_set_write_buffer 的别名

set_file_buffer

(PHP 4, PHP 5, PHP 7, PHP 8)

set_file_buffer — stream_set_write_buffer() 的别名

说明

此函数是该函数的别名：stream_set_write_buffer()。


给出文件的信息

  • ? set_file_buffer
  • symlink ?
  • PHP Manual
  • 文件系统函数
  • 给出文件的信息

stat

(PHP 4, PHP 5, PHP 7, PHP 8)

stat — 给出文件的信息

说明

stat ( string $filename ) : array

获取由 filename 指定的文件的统计信息。如果 filename 是符号连接，则统计信息是关于被连接文件本身的，而不是符号连接。

lstat() 和 stat() 相同，只除了它会返回符号连接的状态。

参数

filename

文件的路径。

返回值

stat() 和 fstat() 返回格式
数字下标 | 关联键名（自 PHP 4.0.6） | 说明
0 | dev | device number - 设备名
1 | ino | inode number - inode 号码
2 | mode | inode protection mode - inode 保护模式
3 | nlink | number of links - 被连接数目
4 | uid | userid of owner - 所有者的用户 id
5 | gid | groupid of owner- 所有者的组 id
6 | rdev | device type, if inode device * - 设备类型，如果是 inode 设备的话
7 | size | size in bytes - 文件大小的字节数
8 | atime | time of last access (unix timestamp) - 上次访问时间（Unix 时间戳）
9 | mtime | time of last modification (unix timestamp) - 上次修改时间（Unix 时间戳）
10 | ctime | time of last change (unix timestamp) - 上次改变时间（Unix 时间戳）
11 | blksize | blocksize of filesystem IO * - 文件系统 IO 的块大小
12 | blocks | number of blocks allocated - 所占据块的数目
* Windows 下总是 0。

* - 仅在支持 st_blksize 类型的系统下有效。其它系统（如 Windows）返回 -1。

如果出错，stat() 返回 false。

Note: 因为 PHP 的整数类型是有符号整型而且很多平台使用 32 位整型，对 2GB 以上的文件，一些文件系统函数可能返回无法预期的结果。

错误／异常

错误时会产生 E_WARNING 级别的错误。

更新日志

版本 | 说明
4.0.6 | 返回一个数组包含有文件的统计信息，该数组具有以下列出的单元，数组下标从零开始。除了数字索引之外自还可以通过关联索引来访问。

范例

Example #1 stat() 例子

<?php
/* Get file stat */
$stat = stat('C:\php\php.exe');

/*
 * Print file access time, this is the same
 * as calling fileatime()
 */
echo 'Access time: ' . $stat['atime'];

/*
 * Print file modification time, this is the
 * same as calling filemtime()
 */
echo 'Modification time: ' . $stat['mtime'];

/* Print the device number */
echo 'Device number: ' . $stat['dev'];
?>

Example #2 Using stat() information together with touch()

<?php
/* Get file stat */
$stat = stat('C:\php\php.exe');

/* Did we failed to get stat information? */
if (!$stat) {
    echo 'stat() call failed...';
} else {
    /*
     * We want the access time to be 1 week
     * after the current access time.
     */
    $atime = $stat['atime'] + 604800;

    /* Touch the file */
    if (!touch('some_file.txt', time(), $atime)) {
        echo 'Failed to touch file...';
    } else {
        echo 'touch() returned success...';
    }
}
?>

注释

Note:

注意：不同文件系统对时间的判断方法可能是不相同的。

Note: 此函数的结果会被缓存。参见 clearstatcache() 以获得更多细节。

Tip

自 PHP 5.0.0 起, 此函数也用于某些 URL 包装器。请参见 支持的协议和封装协议以获得支持 stat() 系列函数功能的包装器列表。

参见

  • lstat() - 给出一个文件或符号连接的信息
  • fstat() - 通过已打开的文件指针取得文件信息
  • filemtime() - 取得文件修改时间
  • filegroup() - 取得文件的组


建立符号连接

  • ? stat
  • tempnam ?
  • PHP Manual
  • 文件系统函数
  • 建立符号连接

symlink

(PHP 4, PHP 5, PHP 7, PHP 8)

symlink — 建立符号连接

说明

symlink ( string $target , string $link ) : bool

symlink() 对于已有的 target 建立一个名为 link 的符号连接。

参数

target

连接的目标。

link

连接的名称。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.3.0 | 此函数在 Windows 平台上可用（Vista、Server 2008 或更高版本）。

范例

Example #1 创建一个符号连接

<?php
$target = 'uploads.php';
$link = 'uploads';
symlink($target, $link);

echo readlink($link);
?>

注释

Note: 仅针对 Windows：运行 PHP 于Vista、Server 2008 或更高版本才能正常使用。 之前版本的 Windows 不支持符号连接。

参见

  • link() - 建立一个硬连接
  • readlink() - 返回符号连接指向的目标
  • linkinfo() - 获取一个连接的信息


建立一个具有唯一文件名的文件

  • ? symlink
  • tmpfile ?
  • PHP Manual
  • 文件系统函数
  • 建立一个具有唯一文件名的文件

tempnam

(PHP 4, PHP 5, PHP 7, PHP 8)

tempnam — 建立一个具有唯一文件名的文件

说明

tempnam ( string $dir , string $prefix ) : string

在指定目录中建立一个具有唯一文件名的文件。如果该目录不存在，tempnam() 会在系统临时目录中生成一个文件，并返回其文件名。

参数

dir

The directory where the temporary filename will be created.

prefix

产生临时文件的前缀。

Note: Windows uses only the first three characters of prefix.

返回值

返回新的临时文件名，出错返回 false。

更新日志

版本 | 说明
4.0.6 | 在 PHP 4.0.6 之前，tempnam() 函数的行为取决于系统。在 Windows 下 TMP 环境变量会越过 dir 参数，在 Linux 下 TMPDIR 环境变量优先，而在 SVR4 下总是使用 dir 参数，如果其指向的目录存在的话。如果有疑问请参考系统文档中的 tempnam(3) 函数。
4.0.3 | 本函数的行为在 4.0.3 版中改变了。也会建立一个临时文件以避免竞争情形，即有可能会在产生出作为文件名的字符串与脚本真正建立该文件之间会在文件系统中存在同名文件。注意，如果不再需要该文件则要删除此文件，不会自动删除的。

范例

Example #1 tempnam() 例子

<?php
$tmpfname = tempnam("/tmp", "FOO");

$handle = fopen($tmpfname, "w");
fwrite($handle, "writing to tempfile");
fclose($handle);

// do here something

unlink($tmpfname);
?>

注释

Note: 如果 PHP 不能在指定的 dir 参数中创建文件，则退回到系统默认值。 在 NTFS 文件系统中，同样的情况也发生在 dir 中文件数超过 65534 个的时候。

参见

  • tmpfile() - 建立一个临时文件
  • sys_get_temp_dir() - 返回用于临时文件的目录
  • unlink() - 删除文件


建立一个临时文件

  • ? tempnam
  • touch ?
  • PHP Manual
  • 文件系统函数
  • 建立一个临时文件

tmpfile

(PHP 4, PHP 5, PHP 7, PHP 8)

tmpfile — 建立一个临时文件

说明

tmpfile ( ) : resource|false

以读写（w+）模式创建一个具有唯一文件名的临时文件，然后返回该文件的句柄。

文件在关闭后（例如，调用 fclose() 或 tmpfile() 返回的文件句柄已无引用的情况）或脚本运行结束后，会自动删除。

Caution

如果脚本运行被意外终止，可能不会删除该临时文件。

返回值

返回新文件的句柄，类似于 fopen() 返回的文件句柄， 或者在失败时返回 false。

范例

Example #1 tmpfile() 例子

<?php
$temp = tmpfile();
fwrite($temp, "writing to tempfile");
fseek($temp, 0);
echo fread($temp, 1024);
fclose($temp); // this removes the file
?>

以上例程会输出：

writing to tempfile

参见

  • tempnam() - 建立一个具有唯一文件名的文件
  • sys_get_temp_dir() - 返回用于临时文件的目录


设定文件的访问和修改时间

  • ? tmpfile
  • umask ?
  • PHP Manual
  • 文件系统函数
  • 设定文件的访问和修改时间

touch

(PHP 4, PHP 5, PHP 7, PHP 8)

touch — 设定文件的访问和修改时间

说明

touch ( string $filename , int $time = time() , int $atime = ? ) : bool

尝试将由 filename 给出的文件的访问和修改时间设定为给出的 time。 注意访问时间总是会被修改的，不论有几个参数。

如果文件不存在，则会被创建。

参数

filename

要设定的文件名。

time

要设定的时间。如果没有提供参数 time 则会使用当前系统的时间。

atime

如果给出了这个参数，则给定文件的访问时间会被设为 atime，否则会设置 为time。如果没有给出这两个参数，则使用当前系统时间。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 touch() 例子

<?php
if (touch($filename)) {
    echo $filename . ' modification time has been changed to present time';
} else {
    echo 'Sorry, could not change modification time of ' . $filename;
}
?>

Example #2 使用 time 参数的 touch()

<?php
// This is the touch time, we'll set it to one hour in the past.
$time = time() - 3600;

// Touch the file
if (!touch('some_file.txt', $time)) {
    echo 'Whoops, something went wrong...';
} else {
    echo 'Touched file with success';
}
?>

注释

Note:

注意：不同文件系统对时间的判断方法可能是不相同的。

Warning

在 PHP 5.3.0 之前无法修改 Windows 下目录的最后修改时间。


改变当前的 umask

  • ? touch
  • unlink ?
  • PHP Manual
  • 文件系统函数
  • 改变当前的 umask

umask

(PHP 4, PHP 5, PHP 7, PHP 8)

umask — 改变当前的 umask

说明

umask ( int $mask = ? ) : int

umask() 将 PHP 的 umask 设定为 mask & 0777 并返回原来的 umask。当 PHP 被作为服务器模块使用时，在每个请求结束后 umask 会被恢复。

参数

mask

The new umask.

返回值

无参数调用 umask() 会返回当前的 umask，有参数则返回原来的 umask。

范例

Example #1 umask() 例子

<?php
$old = umask(0);
chmod("/path/some_dir/some_file.txt", 0755);
umask($old);

// Checking
if ($old != umask()) {
    die('An error occured while changing back the umask');
}
?>

注释

Note:

在多线程的服务器上尽量避免使用这个函数。创建文件后要改变其权限最好还是使用 chmod()。使用 umask() 会导致并发程序和服务器发生不可预知的情况，因为它们是使用相同的 umask 的。


删除文件

  • ? umask
  • Inotify ?
  • PHP Manual
  • 文件系统函数
  • 删除文件

unlink

(PHP 4, PHP 5, PHP 7, PHP 8)

unlink — 删除文件

说明

unlink ( string $filename , resource $context = ? ) : bool

删除 filename。和 Unix C 的 unlink() 函数相似。 发生错误时会产生一个 E_WARNING 级别的错误。

参数

filename

文件的路径。

context

Note: 在 PHP 5.0.0 中增加了对上下文（Context）的支持。有关上下文（Context）的说明参见 Streams。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.3.0 | 现在 Windows 也可以用 unlink() 删除文件句柄还在使用中的文件了，在此之前是无法删除的。 然而，还是无法重新创建文件，需要等到所有句柄都关闭才可以。

范例

Example #1 基本的 unlink() 用法

<?php
$fh = fopen('test.html', 'a');
fwrite($fh, '<h1>Hello world!</h1>');
fclose($fh);

unlink('test.html');
?>

参见

  • rmdir() - 删除目录


Inotify

  • 简介
  • 安装／配置
    • 需求
    • 安装／配置
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Inotify 函数
    • inotify_add_watch — Add a watch to an initialized inotify instance
    • inotify_init — Initialize an inotify instance
    • inotify_queue_len — Return a number upper than zero if there are pending events
    • inotify_read — Read events from an inotify instance
    • inotify_rm_watch — Remove an existing watch from an inotify instance


简介

Inotify 扩展提供了一系列 inotify 函数： inotify_init()、 inotify_add_watch() 、 inotify_rm_watch()。

类似 C 语言里的 inotify_init() 函数会返回文件描述符，PHP 的 inotify_init()则返回 stream 资源。可以被标准的 Steam 函数使用，例如 stream_select()、 stream_set_blocking() 以及 fclose()。 inotify_read() 函数取代里 C 语言里读取 inotify 事件的那种方式。


安装／配置

Table of Contents

  • 需求
  • 安装／配置
  • 运行时配置
  • 资源类型


需求

This extension requires Linux 2.6.13 or newer, and a recent libC.


安装／配置

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/inotify.


  • ? 安装／配置
  • 资源类型 ?
  • PHP Manual
  • 安装／配置
  • 运行时配置

运行时配置

此扩展没有在 php.ini 中定义配置指令。


资源类型

This extension defines a stream resource returned by inotify_init().


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Inotify constants usable with inotify_add_watch() and/or returned by inotify_read()
IN_ACCESS (int)
File was accessed (read) (*)
IN_MODIFY (int)
File was modified (*)
IN_ATTRIB (int)
Metadata changed (e.g. permissions, mtime, etc.) (*)
IN_CLOSE_WRITE (int)
File opened for writing was closed (*)
IN_CLOSE_NOWRITE (int)
File not opened for writing was closed (*)
IN_OPEN (int)
File was opened (*)
IN_MOVED_TO (int)
File moved into watched directory (*)
IN_MOVED_FROM (int)
File moved out of watched directory (*)
IN_CREATE (int)
File or directory created in watched directory (*)
IN_DELETE (int)
File or directory deleted in watched directory (*)
IN_DELETE_SELF (int)
Watched file or directory was deleted
IN_MOVE_SELF (int)
Watch file or directory was moved
IN_CLOSE (int)
Equals to IN_CLOSE_WRITE | IN_CLOSE_NOWRITE
IN_MOVE (int)
Equals to IN_MOVED_FROM | IN_MOVED_TO
IN_ALL_EVENTS (int)
Bitmask of all the above constants
IN_UNMOUNT (int)
File system containing watched object was unmounted
IN_Q_OVERFLOW (int)
Event queue overflowed (wd is -1 for this event)
IN_IGNORED (int)
Watch was removed (explicitly by inotify_rm_watch() or because file was removed or filesystem unmounted
IN_ISDIR (int)
Subject of this event is a directory
IN_ONLYDIR (int)
Only watch pathname if it is a directory (Since Linux 2.6.15)
IN_DONT_FOLLOW (int)
Do not dereference pathname if it is a symlink (Since Linux 2.6.15)
IN_MASK_ADD (int)
Add events to watch mask for this pathname if it already exists (instead of replacing mask).
IN_ONESHOT (int)
Monitor pathname for one event, then remove from watch list.

Note: The events marked with an asterisk (*) above can occur for files in watched directories.


Inotify 函数

Table of Contents

  • inotify_add_watch — Add a watch to an initialized inotify instance
  • inotify_init — Initialize an inotify instance
  • inotify_queue_len — Return a number upper than zero if there are pending events
  • inotify_read — Read events from an inotify instance
  • inotify_rm_watch — Remove an existing watch from an inotify instance


Add a watch to an initialized inotify instance

  • ? Inotify 函数
  • inotify_init ?
  • PHP Manual
  • Inotify 函数
  • Add a watch to an initialized inotify instance

inotify_add_watch

(PECL inotify >= 0.1.2)

inotify_add_watch — Add a watch to an initialized inotify instance

说明

inotify_add_watch ( resource $inotify_instance , string $pathname , int $mask ) : int

inotify_add_watch() adds a new watch or modify an existing watch for the file or directory specified in pathname.

Using inotify_add_watch() on a watched object replaces the existing watch. Using the IN_MASK_ADD constant adds (OR) events to the existing watch.

参数

inotify_instance

inotify_init()返回的资源

pathname

File or directory to watch

mask

Events to watch for. See 预定义常量.

返回值

The return value is a unique (inotify instance wide) watch descriptor.

参见

  • inotify_init() - Initialize an inotify instance


Initialize an inotify instance

  • ? inotify_add_watch
  • inotify_queue_len ?
  • PHP Manual
  • Inotify 函数
  • Initialize an inotify instance

inotify_init

(PECL inotify >= 0.1.2)

inotify_init — Initialize an inotify instance

说明

inotify_init ( ) : resource

Initialize an inotify instance for use with inotify_add_watch()

返回值

A stream resource or false on error.

范例

Example #1 Example usage of inotify

<?php
// Open an inotify instance
$fd = inotify_init();

// Watch __FILE__ for metadata changes (e.g. mtime)
$watch_descriptor = inotify_add_watch($fd, __FILE__, IN_ATTRIB);

// generate an event
touch(__FILE__);

// Read events
$events = inotify_read($fd);
print_r($events);

// The following methods allows to use inotify functions without blocking on inotify_read():

// - Using stream_select() on $fd:
$read = array($fd);
$write = null;
$except = null;
stream_select($read,$write,$except,0);

// - Using stream_set_blocking() on $fd
stream_set_blocking($fd, 0);
inotify_read($fd); // Does no block, and return false if no events are pending

// - Using inotify_queue_len() to check if event queue is not empty
$queue_len = inotify_queue_len($fd); // If > 0, inotify_read() will not block

// Stop watching __FILE__ for metadata changes
inotify_rm_watch($fd, $watch_descriptor);

// Close the inotify instance
// This may have closed all watches if this was not already done
fclose($fd);

?>

以上例程的输出类似于：

array(
  array(
    'wd' => 1,     // Equals $watch_descriptor
    'mask' => 4,   // IN_ATTRIB bit is set
    'cookie' => 0, // unique id to connect related events (e.g.
                   // IN_MOVE_FROM and IN_MOVE_TO events)
    'name' => '',  // the name of a file (e.g. if we monitored changes
                   // in a directory)
  ),
);

参见

  • inotify_add_watch() - Add a watch to an initialized inotify instance
  • inotify_rm_watch() - Remove an existing watch from an inotify instance
  • inotify_queue_len() - Return a number upper than zero if there are pending events
  • inotify_read() - Read events from an inotify instance
  • fclose() - 关闭一个已打开的文件指针


Return a number upper than zero if there are pending events

  • ? inotify_init
  • inotify_read ?
  • PHP Manual
  • Inotify 函数
  • Return a number upper than zero if there are pending events

inotify_queue_len

(PECL inotify >= 0.1.2)

inotify_queue_len — Return a number upper than zero if there are pending events

说明

inotify_queue_len ( resource $inotify_instance ) : int

This function allows to know if inotify_read() will block or not. If a number upper than zero is returned, there are pending events and inotify_read() will not block.

参数

inotify_instance

inotify_init()返回的资源

返回值

Returns a number upper than zero if there are pending events.

参见

  • inotify_init() - Initialize an inotify instance
  • stream_select() - Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式


Read events from an inotify instance

  • ? inotify_queue_len
  • inotify_rm_watch ?
  • PHP Manual
  • Inotify 函数
  • Read events from an inotify instance

inotify_read

(PECL inotify >= 0.1.2)

inotify_read — Read events from an inotify instance

说明

inotify_read ( resource $inotify_instance ) : array

Read inotify events from an inotify instance.

参数

inotify_instance

inotify_init()返回的资源

返回值

An array of inotify events or false if no events was pending and inotify_instance is non-blocking. Each event is an array with the following keys:

  • wd is a watch descriptor returned by inotify_add_watch()
  • mask is a bit mask of events
  • cookie is a unique id to connect related events (e.g. IN_MOVE_FROM and IN_MOVE_TO)
  • name is the name of a file (e.g. if a file was modified in a watched directory)

参见

  • inotify_init() - Initialize an inotify instance
  • stream_select() - Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式
  • inotify_queue_len() - Return a number upper than zero if there are pending events


Remove an existing watch from an inotify instance

  • ? inotify_read
  • Proctitle ?
  • PHP Manual
  • Inotify 函数
  • Remove an existing watch from an inotify instance

inotify_rm_watch

(PECL inotify >= 0.1.2)

inotify_rm_watch — Remove an existing watch from an inotify instance

说明

inotify_rm_watch ( resource $inotify_instance , int $watch_descriptor ) : bool

inotify_rm_watch() removes the watch watch_descriptor from the inotify instance inotify_instance.

参数

inotify_instance

inotify_init()返回的资源

watch_descriptor

Watch to remove from the instance

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • inotify_init() - Initialize an inotify instance


Proctitle

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Proctitle 函数
    • setproctitle — Set the process title
    • setthreadtitle — Set the thread title


简介

This extension allows changing the current process', and thread, name on Linux and *BSD systems. This is useful when using pcntl_fork() to identify running processes in process list


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Proctitle
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

Nothing special.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/proctitle.


  • ? 资源类型
  • Proctitle 函数 ?
  • PHP Manual
  • Proctitle
  • 预定义常量

预定义常量

此扩展没有定义常量。


Proctitle 函数

Table of Contents

  • setproctitle — Set the process title
  • setthreadtitle — Set the thread title


Set the process title

  • ? Proctitle 函数
  • setthreadtitle ?
  • PHP Manual
  • Proctitle 函数
  • Set the process title

setproctitle

(PECL proctitle >= 0.1.0)

setproctitle — Set the process title

说明

setproctitle ( string $title ) : void

Sets the process title of the current process.

参数

title

The title to use as the process title.

返回值

没有返回值。

范例

Example #1 setproctitle() example

Running the example below will change the process title (visible with ps a for example).

<?php
setproctitle("myscript");
?>

以上例程的输出类似于：

$ ps a
  PID TTY      STAT   TIME COMMAND
 1168 pts/3    S      0:00 myscript

参见

  • cli_set_process_title() - Sets the process title
  • pcntl_fork() - 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。
  • setthreadtitle() - Set the thread title


Set the thread title

  • ? setproctitle
  • xattr ?
  • PHP Manual
  • Proctitle 函数
  • Set the thread title

setthreadtitle

(PECL proctitle >= 0.1.2)

setthreadtitle — Set the thread title

说明

setthreadtitle ( string $title ) : bool

Sets the thread title.

参数

title

The title to use as the thread title.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 setthreadtitle() example

Running the example below will change the thread title (visible with ps c for example).

<?php
setthreadtitle("myscript");
?>

以上例程的输出类似于：

$ ps c
  PID TTY      STAT   TIME COMMAND
 1178 pts/3    S      0:00 myscript

参见

  • pcntl_fork() - 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。
  • setproctitle() - Set the process title


xattr

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • xattr 函数
    • xattr_get — Get an extended attribute
    • xattr_list — Get a list of extended attributes
    • xattr_remove — Remove an extended attribute
    • xattr_set — Set an extended attribute
    • xattr_supported — Check if filesystem supports extended attributes


简介

The xattr extension allows for the manipulation of extended attributes on a filesystem.


需求

To use xattr, you will need libattr installed. It is available at » http://savannah.nongnu.org/projects/attr/.

Note:

These functions only work on filesystems that support extended attributes, and have them enabled at mount time. Some common filesystems that support extended attributes are ext2, ext3, reiserfs, jfs, and xfs.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/xattr.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

XATTR_ROOT (int)
Set attribute in root (trusted) namespace. Requires root privileges.
XATTR_DONTFOLLOW (int)
Do not follow the symbolic link but operate on symbolic link itself.
XATTR_CREATE (int)
Function will fail if extended attribute already exists.
XATTR_REPLACE (int)
Function will fail if extended attribute doesn't exist.


xattr 函数

Table of Contents

  • xattr_get — Get an extended attribute
  • xattr_list — Get a list of extended attributes
  • xattr_remove — Remove an extended attribute
  • xattr_set — Set an extended attribute
  • xattr_supported — Check if filesystem supports extended attributes


Get an extended attribute

  • ? xattr 函数
  • xattr_list ?
  • PHP Manual
  • xattr 函数
  • Get an extended attribute

xattr_get

(PECL xattr >= 0.9.0)

xattr_get — Get an extended attribute

说明

xattr_get ( string $filename , string $name , int $flags = 0 ) : string

This function gets the value of an extended attribute of a file.

扩展的属性有两种 不同的命名空间：user 和 root。user 命名空间对所有用户均有效，而 root 命名空间仅对拥有 root 权限的用户有效。 xattr 默认在 user 命名空间上操作，但可使用 flags 参数进行更改。

参数

filename

The file from which we get the attribute.

name

The name of the attribute.

flags

Supported xattr flags
XATTR_DONTFOLLOW | Do not follow the symbolic link but operate on symbolic link itself.
XATTR_ROOT | Set attribute in root (trusted) namespace. Requires root privileges.

返回值

Returns a string containing the value or false if the attribute doesn't exist.

范例

Example #1 Checks if system administrator has signed the file

<?php
$file = '/usr/local/sbin/some_binary';
$signature = xattr_get($file, 'Root signature', XATTR_ROOT);

/* ... check if $signature is valid ... */

?>

参见

  • xattr_list() - Get a list of extended attributes
  • xattr_set() - Set an extended attribute
  • xattr_remove() - Remove an extended attribute


Get a list of extended attributes

  • ? xattr_get
  • xattr_remove ?
  • PHP Manual
  • xattr 函数
  • Get a list of extended attributes

xattr_list

(PECL xattr >= 0.9.0)

xattr_list — Get a list of extended attributes

说明

xattr_list ( string $filename , int $flags = 0 ) : array

This functions gets a list of names of extended attributes of a file.

扩展的属性有两种 不同的命名空间：user 和 root。user 命名空间对所有用户均有效，而 root 命名空间仅对拥有 root 权限的用户有效。 xattr 默认在 user 命名空间上操作，但可使用 flags 参数进行更改。

参数

filename

The path of the file.

flags

Supported xattr flags
XATTR_DONTFOLLOW | Do not follow the symbolic link but operate on symbolic link itself.
XATTR_ROOT | Set attribute in root (trusted) namespace. Requires root privileges.

返回值

This function returns an array with names of extended attributes.

范例

Example #1 Prints names of all extended attributes of file

<?php
$file = 'some_file';
$root_attributes = xattr_list($file, XATTR_ROOT);
$user_attributes = xattr_list($file);

echo "Root attributes: \n";
foreach ($root_attributes as $attr_name) {
    printf("%s\n", $attr_name);
}

echo "\n User attributes: \n";
foreach ($attributes as $attr_name) {
    printf("%s\n", $attr_name);
}

?>

参见

  • xattr_get() - Get an extended attribute


Remove an extended attribute

  • ? xattr_list
  • xattr_set ?
  • PHP Manual
  • xattr 函数
  • Remove an extended attribute

xattr_remove

(PECL xattr >= 0.9.0)

xattr_remove — Remove an extended attribute

说明

xattr_remove ( string $filename , string $name , int $flags = 0 ) : bool

This function removes an extended attribute of a file.

扩展的属性有两种 不同的命名空间：user 和 root。user 命名空间对所有用户均有效，而 root 命名空间仅对拥有 root 权限的用户有效。 xattr 默认在 user 命名空间上操作，但可使用 flags 参数进行更改。

参数

filename

The file from which we remove the attribute.

name

The name of the attribute to remove.

flags

Supported xattr flags
XATTR_DONTFOLLOW | Do not follow the symbolic link but operate on symbolic link itself.
XATTR_ROOT | Set attribute in root (trusted) namespace. Requires root privileges.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Removes all extended attributes of a file

<?php
$file = 'some_file';
$attributes = xattr_list($file);

foreach ($attributes as $attr_name) {
    xattr_remove($file, $attr_name);
}
?>

参见

  • xattr_list() - Get a list of extended attributes
  • xattr_set() - Set an extended attribute
  • xattr_get() - Get an extended attribute


Set an extended attribute

  • ? xattr_remove
  • xattr_supported ?
  • PHP Manual
  • xattr 函数
  • Set an extended attribute

xattr_set

(PECL xattr >= 0.9.0)

xattr_set — Set an extended attribute

说明

xattr_set ( string $filename , string $name , string $value , int $flags = 0 ) : bool

This function sets the value of an extended attribute of a file.

扩展的属性有两种 不同的命名空间：user 和 root。user 命名空间对所有用户均有效，而 root 命名空间仅对拥有 root 权限的用户有效。 xattr 默认在 user 命名空间上操作，但可使用 flags 参数进行更改。

参数

filename

The file in which we set the attribute.

name

The name of the extended attribute. This attribute will be created if it doesn't exist or replaced otherwise. You can change this behaviour by using the flags parameter.

value

The value of the attribute.

flags

Supported xattr flags
XATTR_CREATE | Function will fail if extended attribute already exists.
XATTR_REPLACE | Function will fail if extended attribute doesn't exist.
XATTR_DONTFOLLOW | Do not follow the symbolic link but operate on symbolic link itself.
XATTR_ROOT | Set attribute in root (trusted) namespace. Requires root privileges.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Sets extended attributes on .wav file

<?php
$file = 'my_favourite_song.wav';
xattr_set($file, 'Artist', 'Someone');
xattr_set($file, 'My ranking', 'Good');
xattr_set($file, 'Listen count', '34');

/* ... other code ... */

printf("You've played this song %d times", xattr_get($file, 'Listen count'));
?>

参见

  • xattr_get() - Get an extended attribute
  • xattr_remove() - Remove an extended attribute


Check if filesystem supports extended attributes

  • ? xattr_set
  • xdiff ?
  • PHP Manual
  • xattr 函数
  • Check if filesystem supports extended attributes

xattr_supported

(PECL xattr >= 1.0.0)

xattr_supported — Check if filesystem supports extended attributes

说明

xattr_supported ( string $filename , int $flags = 0 ) : bool

This functions checks if the filesystem holding the given file supports extended attributes. Read access to the file is required.

参数

filename

The path of the tested file.

flags

Supported xattr flags
XATTR_DONTFOLLOW Do not follow the symbolic link but operate on symbolic link itself.

返回值

This function returns true if filesystem supports extended attributes, false if it doesn't and null if it can't be determined (for example wrong path or lack of permissions to file).

范例

Example #1 xattr_supported() example

The following code checks if we can use extended attributes.

<?php
$file = 'some_file';

if (xattr_supported($file)) {
    /* ... make use of some xattr_* functions ... */
}

?>

参见

  • xattr_get() - Get an extended attribute
  • xattr_list() - Get a list of extended attributes


xdiff

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • xdiff 函数
    • xdiff_file_bdiff_size — Read a size of file created by applying a binary diff
    • xdiff_file_bdiff — Make binary diff of two files
    • xdiff_file_bpatch — Patch a file with a binary diff
    • xdiff_file_diff_binary — Alias of xdiff_file_bdiff
    • xdiff_file_diff — Make unified diff of two files
    • xdiff_file_merge3 — Merge 3 files into one
    • xdiff_file_patch_binary — Alias of xdiff_file_bpatch
    • xdiff_file_patch — Patch a file with an unified diff
    • xdiff_file_rabdiff — Make binary diff of two files using the Rabin's polynomial fingerprinting algorithm
    • xdiff_string_bdiff_size — Read a size of file created by applying a binary diff
    • xdiff_string_bdiff — Make binary diff of two strings
    • xdiff_string_bpatch — Patch a string with a binary diff
    • xdiff_string_diff_binary — Alias of xdiff_string_bdiff
    • xdiff_string_diff — Make unified diff of two strings
    • xdiff_string_merge3 — Merge 3 strings into one
    • xdiff_string_patch_binary — Alias of xdiff_string_bpatch
    • xdiff_string_patch — Patch a string with an unified diff
    • xdiff_string_rabdiff — Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm


简介

xdiff extension enables you to create and apply patch files containing differences between different revisions of files.

This extension supports two modes of operation - on strings and on files, as well as two different patch formats - unified and binary. Unified patches are excellent for text files as they are human-readable and easy to review. For binary files like archives or images, binary patches will be adequate choice as they are binary safe and handle non-printable characters well.

Starting from version 1.5.0 there are two different sets of functions for generating binary patches. New functions - xdiff_string_rabdiff() and xdiff_file_rabdiff() generate output compatible with older functions but are typically faster and generate smaller results. For more details about methods of generating binary patches and differences between them, please check » libxdiff website.

This extension uses libxdiff to implement these functions. Please see » http://www.xmailserver.org/xdiff-lib.html for more information.


需求

To use xdiff, you will need libxdiff installed, available on the libxdiff homepage » http://www.xmailserver.org/xdiff-lib.html.

Note:

You'll need at least libxdiff 0.7 for these functions to be aware of memory_limit.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/xdiff.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

XDIFF_PATCH_NORMAL (int)
This flag indicates that xdiff_string_patch() and xdiff_file_patch() functions should create result by applying patch to original content thus creating newer version of file. This is the default mode of operation.
XDIFF_PATCH_REVERSE (int)
This flag indicated that xdiff_string_patch() and xdiff_file_patch() functions should create result by reversing patch changed from newer content thus creating original version.


xdiff 函数

Table of Contents

  • xdiff_file_bdiff_size — Read a size of file created by applying a binary diff
  • xdiff_file_bdiff — Make binary diff of two files
  • xdiff_file_bpatch — Patch a file with a binary diff
  • xdiff_file_diff_binary — Alias of xdiff_file_bdiff
  • xdiff_file_diff — Make unified diff of two files
  • xdiff_file_merge3 — Merge 3 files into one
  • xdiff_file_patch_binary — Alias of xdiff_file_bpatch
  • xdiff_file_patch — Patch a file with an unified diff
  • xdiff_file_rabdiff — Make binary diff of two files using the Rabin's polynomial fingerprinting algorithm
  • xdiff_string_bdiff_size — Read a size of file created by applying a binary diff
  • xdiff_string_bdiff — Make binary diff of two strings
  • xdiff_string_bpatch — Patch a string with a binary diff
  • xdiff_string_diff_binary — Alias of xdiff_string_bdiff
  • xdiff_string_diff — Make unified diff of two strings
  • xdiff_string_merge3 — Merge 3 strings into one
  • xdiff_string_patch_binary — Alias of xdiff_string_bpatch
  • xdiff_string_patch — Patch a string with an unified diff
  • xdiff_string_rabdiff — Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm


Read a size of file created by applying a binary diff

  • ? xdiff 函数
  • xdiff_file_bdiff ?
  • PHP Manual
  • xdiff 函数
  • Read a size of file created by applying a binary diff

xdiff_file_bdiff_size

(PECL xdiff >= 1.5.0)

xdiff_file_bdiff_size — Read a size of file created by applying a binary diff

说明

xdiff_file_bdiff_size ( string $file ) : int

Returns a size of a result file that would be created after applying binary patch from file file to the original file.

参数

file

The path to the binary patch created by xdiff_string_bdiff() or xdiff_string_rabdiff() function.

返回值

Returns the size of file that would be created.

范例

Example #1 xdiff_file_bdiff_size() example

The following code applies reads a size of file that would be created after applying a binary diff.

<?php
$length = xdiff_string_bdiff_size('file.bdiff');
echo "Resulting file will be $length bytes long";
?>

参见

  • xdiff_file_bdiff() - Make binary diff of two files
  • xdiff_file_rabdiff() - Make binary diff of two files using the Rabin's polynomial fingerprinting algorithm
  • xdiff_file_bpatch() - Patch a file with a binary diff


Make binary diff of two files

  • ? xdiff_file_bdiff_size
  • xdiff_file_bpatch ?
  • PHP Manual
  • xdiff 函数
  • Make binary diff of two files

xdiff_file_bdiff

(PECL xdiff >= 1.5.0)

xdiff_file_bdiff — Make binary diff of two files

说明

xdiff_file_bdiff ( string $old_file , string $new_file , string $dest ) : bool

Makes a binary diff of two files and stores the result in a patch file. This function works with both text and binary files. Resulting patch file can be later applied using xdiff_file_bpatch()/xdiff_string_bpatch().

参数

old_file

Path to the first file. This file acts as "old" file.

new_file

Path to the second file. This file acts as "new" file.

dest

Path of the resulting patch file. Resulting file contains differences between "old" and "new" files. It is in binary format and is human-unreadable.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 xdiff_file_bdiff() example

The following code makes binary diff of two archives.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_bdiff($old_version, $new_version, 'my_script.bdiff');
?>

注释

Note:

Both files will be loaded into memory so ensure that your memory_limit is set high enough.

参见

  • xdiff_file_bpatch() - Patch a file with a binary diff


Patch a file with a binary diff

  • ? xdiff_file_bdiff
  • xdiff_file_diff_binary ?
  • PHP Manual
  • xdiff 函数
  • Patch a file with a binary diff

xdiff_file_bpatch

(PECL xdiff >= 1.5.0)

xdiff_file_bpatch — Patch a file with a binary diff

说明

xdiff_file_bpatch ( string $file , string $patch , string $dest ) : bool

Patches a file with a binary patch and stores the result in a file dest. This function accepts patches created both via xdiff_file_bdiff() and xdiff_file_rabdiff() functions or their string counterparts.

参数

file

The original file.

patch

The binary patch file.

dest

Path of the resulting file.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 xdiff_file_bpatch() example

The following code applies binary diff to a file.

<?php
$old_version = 'archive-1.0.tgz';
$patch = 'archive.bpatch';

$result = xdiff_file_bpatch($old_version, $patch, 'archive-1.1.tgz');
if ($result) {
   echo "File patched";
} else {
   echo "File couldn't be patched";
}

?>

注释

Note:

Both files (file and patch) will be loaded into memory so ensure that your memory_limit is set high enough.

参见

  • xdiff_file_bdiff() - Make binary diff of two files
  • xdiff_file_rabdiff() - Make binary diff of two files using the Rabin's polynomial fingerprinting algorithm


Alias of xdiff_file_bdiff

  • ? xdiff_file_bpatch
  • xdiff_file_diff ?
  • PHP Manual
  • xdiff 函数
  • Alias of xdiff_file_bdiff

xdiff_file_diff_binary

(PECL xdiff >= 0.2.0)

xdiff_file_diff_binary — Alias of xdiff_file_bdiff

说明

xdiff_file_diff_binary ( string $old_file , string $new_file , string $dest ) : bool

Makes a binary diff of two files and stores the result in a patch file. This function works with both text and binary files. Resulting patch file can be later applied using xdiff_file_bpatch().

Starting with version 1.5.0 this function is an alias of xdiff_file_bdiff().

参数

old_file

Path to the first file. This file acts as "old" file.

new_file

Path to the second file. This file acts as "new" file.

dest

Path of the resulting patch file. Resulting file contains differences between "old" and "new" files. It is in binary format and is human-unreadable.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 xdiff_file_diff_binary() example

The following code makes binary diff of two archives.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_diff_binary($old_version, $new_version, 'my_script.bdiff');
?>

注释

Note:

Both files will be loaded into memory so ensure that your memory_limit is set high enough.

参见

  • xdiff_file_bdiff() - Make binary diff of two files
  • xdiff_file_bpatch() - Patch a file with a binary diff


Make unified diff of two files

  • ? xdiff_file_diff_binary
  • xdiff_file_merge3 ?
  • PHP Manual
  • xdiff 函数
  • Make unified diff of two files

xdiff_file_diff

(PECL xdiff >= 0.2.0)

xdiff_file_diff — Make unified diff of two files

说明

xdiff_file_diff ( string $old_file , string $new_file , string $dest , int $context = 3 , bool $minimal = false ) : bool

Makes an unified diff containing differences between old_file and new_file and stores it in dest file. The resulting file is human-readable. An optional context parameter specifies how many lines of context should be added around each change. Setting minimal parameter to true will result in outputting the shortest patch file possible (can take a long time).

参数

old_file

Path to the first file. This file acts as "old" file.

new_file

Path to the second file. This file acts as "new" file.

dest

Path of the resulting patch file.

context

Indicates how many lines of context you want to include in diff result.

minimal

Set this parameter to true if you want to minimalize size of the result (can take a long time).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 xdiff_file_diff() example

The following code makes unified diff of two php files with context length of 2.

<?php
$old_version = 'my_script.php';
$new_version = 'my_new_script.php';

xdiff_file_diff($old_version, $new_version, 'my_script.diff', 2);
?>

注释

Note:

This function doesn't work well with binary files. To make diff of binary files use xdiff_file_bdiff()/xdiff_file_rabdiff() function.

参见

  • xdiff_file_patch() - Patch a file with an unified diff


Merge 3 files into one

  • ? xdiff_file_diff
  • xdiff_file_patch_binary ?
  • PHP Manual
  • xdiff 函数
  • Merge 3 files into one

xdiff_file_merge3

(PECL xdiff >= 0.2.0)

xdiff_file_merge3 — Merge 3 files into one

说明

xdiff_file_merge3 ( string $old_file , string $new_file1 , string $new_file2 , string $dest ) : mixed

Merges three files into one and stores the result in a file dest. The old_file is an original version while new_file1 and new_file2 are modified versions of an original.

参数

old_file

Path to the first file. It acts as "old" file.

new_file1

Path to the second file. It acts as modified version of old_file.

new_file2

Path to the third file. It acts as modified version of old_file.

dest

Path of the resulting file, containing merged changed from both new_file1 and new_file2.

返回值

Returns true if merge was successful, string with rejected chunks if it was not or false if an internal error happened.

范例

Example #1 xdiff_file_merge3() example

The following code merges three files into one.

<?php
$old_version = 'original_script.php';
$fix1 = 'script_with_fix1.php';
$fix2 = 'script_with_fix2.php';

$errors = xdiff_file_merge3($old_version, $fix1, $fix2, 'fixed_script.php');
if (is_string($errors)) {
    echo "Rejects:\n";
    echo $errors;
}
?>

参见

  • xdiff_string_merge3() - Merge 3 strings into one


Alias of xdiff_file_bpatch

  • ? xdiff_file_merge3
  • xdiff_file_patch ?
  • PHP Manual
  • xdiff 函数
  • Alias of xdiff_file_bpatch

xdiff_file_patch_binary

(PECL xdiff >= 0.2.0)

xdiff_file_patch_binary — Alias of xdiff_file_bpatch

说明

xdiff_file_patch_binary ( string $file , string $patch , string $dest ) : bool

Patches a file with a binary patch and stores the result in a file dest. This function accepts patches created both via xdiff_file_bdiff() or xdiff_file_rabdiff() functions or their string counterparts.

Starting with version 1.5.0 this function is an alias of xdiff_file_bpatch().

参数

file

The original file.

patch

The binary patch file.

dest

Path of the resulting file.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 xdiff_file_patch_binary() example

The following code applies binary diff to a file.

<?php
$old_version = 'archive-1.0.tgz';
$patch = 'archive.bpatch';

$result = xdiff_file_patch_binary($old_version, $patch, 'archive-1.1.tgz');
if ($result) {
   echo "File patched";
} else {
   echo "File couldn't be patched";
}

?>

注释

Note:

Both files (file and patch) will be loaded into memory so ensure that your memory_limit is set high enough.

参见

  • xdiff_string_patch_binary() - Alias of xdiff_string_bpatch


Patch a file with an unified diff

  • ? xdiff_file_patch_binary
  • xdiff_file_rabdiff ?
  • PHP Manual
  • xdiff 函数
  • Patch a file with an unified diff

xdiff_file_patch

(PECL xdiff >= 0.2.0)

xdiff_file_patch — Patch a file with an unified diff

说明

xdiff_file_patch ( string $file , string $patch , string $dest , int $flags = DIFF_PATCH_NORMAL ) : mixed

Patches a file with a patch and stores the result in a file. patch has to be an unified diff created by xdiff_file_diff()/xdiff_string_diff() function. An optional flags parameter specifies mode of operation.

参数

file

The original file.

patch

The unified patch file. It has to be created using xdiff_string_diff(), xdiff_file_diff() functions or compatible tools.

dest

Path of the resulting file.

flags

Can be either XDIFF_PATCH_NORMAL (default mode, normal patch) or XDIFF_PATCH_REVERSE (reversed patch).

Starting from version 1.5.0, you can also use binary OR to enable XDIFF_PATCH_IGNORESPACE flag.

返回值

Returns false if an internal error happened, string with rejected chunks if patch couldn't be applied or true if patch has been successfully applied.

范例

Example #1 xdiff_file_patch() example

The following code applies unified diff to a file.

<?php
$old_version = 'my_script-1.0.php';
$patch = 'my_script.patch';

$errors = xdiff_file_patch($old_version, $patch, 'my_script-1.1.php');
if (is_string($errors)) {
   echo "Rejects:\n";
   echo $errors;
}

?>

Example #2 Patch reversing example

The following code reverses a patch.

<?php
$new_version = 'my_script-1.1.php';
$patch = 'my_script.patch';

$errors = xdiff_file_patch($new_version, $patch, 'my_script-1.0.php', XDIFF_PATCH_REVERSE);
if (is_string($errors)) {
   echo "Rejects:\n";
   echo $errors;
}

?>

参见

  • xdiff_file_diff() - Make unified diff of two files


Make binary diff of two files using the Rabin's polynomial fingerprinting algorithm

  • ? xdiff_file_patch
  • xdiff_string_bdiff_size ?
  • PHP Manual
  • xdiff 函数
  • Make binary diff of two files using the Rabin's polynomial fingerprinting algorithm

xdiff_file_rabdiff

(PECL xdiff >= 1.5.0)

xdiff_file_rabdiff — Make binary diff of two files using the Rabin's polynomial fingerprinting algorithm

说明

xdiff_file_rabdiff ( string $old_file , string $new_file , string $dest ) : bool

Makes a binary diff of two files and stores the result in a patch file. The difference between this function and xdiff_file_bdiff() is different algorithm used which should result in faster execution and smaller diff produced. This function works with both text and binary files. Resulting patch file can be later applied using xdiff_file_bpatch()/xdiff_string_bpatch().

For more details about differences between algorithm used please check » libxdiff website.

参数

old_file

Path to the first file. This file acts as "old" file.

new_file

Path to the second file. This file acts as "new" file.

dest

Path of the resulting patch file. Resulting file contains differences between "old" and "new" files. It is in binary format and is human-unreadable.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 xdiff_file_rabdiff() example

The following code makes binary diff of two archives.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_rabdiff($old_version, $new_version, 'my_script.bdiff');
?>

注释

Note:

Both files will be loaded into memory so ensure that your memory_limit is set high enough.

参见

  • xdiff_file_bpatch() - Patch a file with a binary diff


Read a size of file created by applying a binary diff

  • ? xdiff_file_rabdiff
  • xdiff_string_bdiff ?
  • PHP Manual
  • xdiff 函数
  • Read a size of file created by applying a binary diff

xdiff_string_bdiff_size

(PECL xdiff >= 1.5.0)

xdiff_string_bdiff_size — Read a size of file created by applying a binary diff

说明

xdiff_string_bdiff_size ( string $patch ) : int

Returns a size of a result file that would be created after applying binary patch to the original file.

参数

patch

The binary patch created by xdiff_string_bdiff() or xdiff_string_rabdiff() function.

返回值

Returns the size of file that would be created.

范例

Example #1 xdiff_string_bdiff_size() example

The following code applies reads a size of file that would be created after applying a binary diff.

<?php
$binary_patch = file_get_contents('file.bdiff');
$length = xdiff_string_bdiff_size($binary_patch);
echo "Resulting file will be $length bytes long";
?>

参见

  • xdiff_string_bdiff() - Make binary diff of two strings
  • xdiff_string_rabdiff() - Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm
  • xdiff_string_bpatch() - Patch a string with a binary diff


Make binary diff of two strings

  • ? xdiff_string_bdiff_size
  • xdiff_string_bpatch ?
  • PHP Manual
  • xdiff 函数
  • Make binary diff of two strings

xdiff_string_bdiff

(PECL xdiff >= 1.5.0)

xdiff_string_bdiff — Make binary diff of two strings

说明

xdiff_string_bdiff ( string $old_data , string $new_data ) : string

Makes a binary diff of two strings and returns the result. This function works with both text and binary data. Resulting patch can be later applied using xdiff_string_bpatch()/xdiff_file_bpatch().

参数

old_data

First string with binary data. It acts as "old" data.

new_data

Second string with binary data. It acts as "new" data.

返回值

Returns string with binary diff containing differences between "old" and "new" data or false if an internal error occurred.

参见

  • xdiff_string_bpatch() - Patch a string with a binary diff


Patch a string with a binary diff

  • ? xdiff_string_bdiff
  • xdiff_string_diff_binary ?
  • PHP Manual
  • xdiff 函数
  • Patch a string with a binary diff

xdiff_string_bpatch

(PECL xdiff >= 1.5.0)

xdiff_string_bpatch — Patch a string with a binary diff

说明

xdiff_string_bpatch ( string $str , string $patch ) : string

Patches a string str with a binary patch. This function accepts patches created both via xdiff_string_bdiff() and xdiff_string_rabdiff() functions or their file counterparts.

参数

str

The original binary string.

patch

The binary patch string.

返回值

Returns the patched string, or false on error.

参见

  • xdiff_string_bdiff() - Make binary diff of two strings
  • xdiff_string_rabdiff() - Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm


Alias of xdiff_string_bdiff

  • ? xdiff_string_bpatch
  • xdiff_string_diff ?
  • PHP Manual
  • xdiff 函数
  • Alias of xdiff_string_bdiff

xdiff_string_diff_binary

(PECL xdiff >= 0.2.0)

xdiff_string_diff_binary — Alias of xdiff_string_bdiff

说明

xdiff_string_bdiff ( string $old_data , string $new_data ) : string

Makes a binary diff of two strings and returns the result. This function works with both text and binary data. Resulting patch can be later applied using xdiff_string_bpatch()/xdiff_file_bpatch().

Starting with version 1.5.0 this function is an alias of xdiff_string_bdiff().

参数

old_data

First string with binary data. It acts as "old" data.

new_data

Second string with binary data. It acts as "new" data.

返回值

Returns string with result or false if an internal error happened.

参见

  • xdiff_string_bdiff() - Make binary diff of two strings
  • xdiff_string_bpatch() - Patch a string with a binary diff


Make unified diff of two strings

  • ? xdiff_string_diff_binary
  • xdiff_string_merge3 ?
  • PHP Manual
  • xdiff 函数
  • Make unified diff of two strings

xdiff_string_diff

(PECL xdiff >= 0.2.0)

xdiff_string_diff — Make unified diff of two strings

说明

xdiff_string_diff ( string $old_data , string $new_data , int $context = 3 , bool $minimal = false ) : string

Makes an unified diff containing differences between old_data string and new_data string and returns it. The resulting diff is human-readable. An optional context parameter specifies how many lines of context should be added around each change. Setting minimal parameter to true will result in outputting the shortest patch file possible (can take a long time).

参数

old_data

First string with data. It acts as "old" data.

new_data

Second string with data. It acts as "new" data.

context

Indicates how many lines of context you want to include in the diff result.

minimal

Set this parameter to true if you want to minimalize the size of the result (can take a long time).

返回值

Returns string with resulting diff or false if an internal error happened.

范例

Example #1 xdiff_string_diff() example

The following code makes unified diff of two articles.

<?php
$old_article = file_get_contents('./old_article.txt');
$new_article = $_REQUEST['article']; /* Let's say that someone pasted a new article to html form */

$diff = xdiff_string_diff($old_article, $new_article, 1);
if (is_string($diff)) {
    echo "Differences between two articles:\n";
    echo $diff;
}

?>

注释

Note:

This function doesn't work well with binary strings. To make diff of binary strings use xdiff_string_bdiff()/xdiff_string_rabdiff().

参见

  • xdiff_string_patch() - Patch a string with an unified diff


Merge 3 strings into one

  • ? xdiff_string_diff
  • xdiff_string_patch_binary ?
  • PHP Manual
  • xdiff 函数
  • Merge 3 strings into one

xdiff_string_merge3

(PECL xdiff >= 0.2.0)

xdiff_string_merge3 — Merge 3 strings into one

说明

xdiff_string_merge3 ( string $old_data , string $new_data1 , string $new_data2 , string &$error = ? ) : mixed

Merges three strings into one and returns the result. The old_data is an original version of data while new_data1 and new_data2 are modified versions of an original. An optional error is used to pass any rejected parts during merging process.

参数

old_data

First string with data. It acts as "old" data.

new_data1

Second string with data. It acts as modified version of old_data.

new_data2

Third string with data. It acts as modified version of old_data.

error

If provided then rejected parts are stored inside this variable.

返回值

Returns the merged string, false if an internal error happened, or true if merged string is empty.

参见

  • xdiff_file_merge3() - Merge 3 files into one


Alias of xdiff_string_bpatch

  • ? xdiff_string_merge3
  • xdiff_string_patch ?
  • PHP Manual
  • xdiff 函数
  • Alias of xdiff_string_bpatch

xdiff_string_patch_binary

(PECL xdiff >= 0.2.0)

xdiff_string_patch_binary — Alias of xdiff_string_bpatch

说明

xdiff_string_patch_binary ( string $str , string $patch ) : string

Patches a string str with a binary patch. This function accepts patches created both via xdiff_string_bdiff() and xdiff_string_rabdiff() functions or their file counterparts.

Starting with version 1.5.0 this function is an alias of xdiff_string_bpatch().

参数

str

The original binary string.

patch

The binary patch string.

返回值

Returns the patched string, or false on error.

参见

  • xdiff_string_bpatch() - Patch a string with a binary diff
  • xdiff_string_bdiff() - Make binary diff of two strings
  • xdiff_string_rabdiff() - Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm


Patch a string with an unified diff

  • ? xdiff_string_patch_binary
  • xdiff_string_rabdiff ?
  • PHP Manual
  • xdiff 函数
  • Patch a string with an unified diff

xdiff_string_patch

(PECL xdiff >= 0.2.0)

xdiff_string_patch — Patch a string with an unified diff

说明

xdiff_string_patch ( string $str , string $patch , int $flags = ? , string &$error = ? ) : string

Patches a str string with an unified patch in patch parameter and returns the result. patch has to be an unified diff created by xdiff_file_diff()/xdiff_string_diff() function. An optional flags parameter specifies mode of operation. Any rejected parts of the patch will be stored inside error variable if it is provided.

参数

str

The original string.

patch

The unified patch string. It has to be created using xdiff_string_diff(), xdiff_file_diff() functions or compatible tools.

flags

flags can be either XDIFF_PATCH_NORMAL (default mode, normal patch) or XDIFF_PATCH_REVERSE (reversed patch).

Starting from version 1.5.0, you can also use binary OR to enable XDIFF_PATCH_IGNORESPACE flag.

error

If provided then rejected parts are stored inside this variable.

返回值

Returns the patched string, or false on error.

范例

Example #1 xdiff_string_patch() example

The following code applies changes to some article.

<?php
$old_article = file_get_contents('./old_article.txt');
$diff = $_SERVER['patch']; /* Let's say that someone pasted a patch to html form */

$errors = '';

$new_article = xdiff_string_patch($old_article, $diff, XDIFF_PATCH_NORMAL, $errors);
if (is_string($new_article)) {
    echo "New article:\n";
    echo $new_article;
}

if (strlen($errors)) {
    echo "Rejects: \n";
    echo $errors;
}

?>

参见

  • xdiff_string_diff() - Make unified diff of two strings


Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm

  • ? xdiff_string_patch
  • 国际化与字符编码支持 ?
  • PHP Manual
  • xdiff 函数
  • Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm

xdiff_string_rabdiff

(PECL xdiff >= 1.5.0)

xdiff_string_rabdiff — Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm

说明

xdiff_string_bdiff ( string $old_data , string $new_data ) : string

Makes a binary diff of two strings and returns the result. The difference between this function and xdiff_string_bdiff() is different algorithm used which should result in faster execution and smaller diff produced. This function works with both text and binary data. Resulting patch can be later applied using xdiff_string_bpatch()/xdiff_file_bpatch().

For more details about differences between algorithm used please check » libxdiff website.

参数

old_data

First string with binary data. It acts as "old" data.

new_data

Second string with binary data. It acts as "new" data.

返回值

Returns string with binary diff containing differences between "old" and "new" data or false if an internal error occurred.

参见

  • xdiff_string_bpatch() - Patch a string with a binary diff


国际化与字符编码支持

  • Enchant — Enchant spelling library
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Enchant 函数
    • EnchantBroker — The EnchantBroker class
    • EnchantDictionary — The EnchantDictionary class
  • Gender — Determine gender of firstnames
    • 简介
    • 安装／配置
    • 范例
    • Gender\Gender — The Gender\Gender class
  • Gettext
    • 简介
    • 安装／配置
    • 预定义常量
    • Gettext 函数
  • iconv
    • 简介
    • 安装／配置
    • 预定义常量
    • iconv 函数
  • intl — Internationalization Functions
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Collator — The Collator class
    • NumberFormatter — The NumberFormatter class
    • Locale — The Locale class
    • Normalizer — The Normalizer class
    • MessageFormatter — The MessageFormatter class
    • IntlCalendar — The IntlCalendar class
    • IntlGregorianCalendar — The IntlGregorianCalendar class
    • IntlTimeZone — The IntlTimeZone class
    • IntlDateFormatter — The IntlDateFormatter class
    • ResourceBundle — The ResourceBundle class
    • Spoofchecker — The Spoofchecker class
    • Transliterator — The Transliterator class
    • IntlBreakIterator — The IntlBreakIterator class
    • IntlRuleBasedBreakIterator — The IntlRuleBasedBreakIterator class
    • IntlCodePointBreakIterator — The IntlCodePointBreakIterator class
    • IntlPartsIterator — The IntlPartsIterator class
    • UConverter — The UConverter class
    • Grapheme 函数
    • IDN 函数
    • IntlChar
    • IntlException — Exception class for intl errors
    • IntlIterator — The IntlIterator class
    • intl 函数
  • 多字节字符串
    • 简介
    • 安装／配置
    • 预定义常量
    • 支持编码的摘要
    • 日文字符多字节编码基础
    • HTTP 输入和输出
    • 支持的字符编码
    • 函数重载功能
    • PHP字符编码的要求
    • 多字节字符串 函数
  • Pspell
    • 简介
    • 安装／配置
    • 预定义常量
    • Pspell 函数
  • Recode — GNU Recode
    • 简介
    • 安装／配置
    • 预定义常量
    • Recode 函数


Enchant spelling library

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Enchant 函数
    • enchant_broker_describe — Enumerates the Enchant providers
    • enchant_broker_dict_exists — Whether a dictionary exists or not. Using non-empty tag
    • enchant_broker_free_dict — Free a dictionary resource
    • enchant_broker_free — Free the broker resource and its dictionaries
    • enchant_broker_get_dict_path — Get the directory path for a given backend
    • enchant_broker_get_error — Returns the last error of the broker
    • enchant_broker_init — Create a new broker object capable of requesting
    • enchant_broker_list_dicts — Returns a list of available dictionaries
    • enchant_broker_request_dict — Create a new dictionary using a tag
    • enchant_broker_request_pwl_dict — Creates a dictionary using a PWL file
    • enchant_broker_set_dict_path — Set the directory path for a given backend
    • enchant_broker_set_ordering — Declares a preference of dictionaries to use for the language
    • enchant_dict_add_to_personal — 别名 enchant_dict_add
    • enchant_dict_add_to_session — Add 'word' to this spell-checking session
    • enchant_dict_add — Add a word to personal word list
    • enchant_dict_check — Check whether a word is correctly spelled or not
    • enchant_dict_describe — Describes an individual dictionary
    • enchant_dict_get_error — Returns the last error of the current spelling-session
    • enchant_dict_is_added — Whether or not 'word' exists in this spelling-session
    • enchant_dict_is_in_session — 别名 enchant_dict_is_added
    • enchant_dict_quick_check — Check the word is correctly spelled and provide suggestions
    • enchant_dict_store_replacement — Add a correction for a word
    • enchant_dict_suggest — Will return a list of values if any of those pre-conditions are not met
  • EnchantBroker — The EnchantBroker class
  • EnchantDictionary — The EnchantDictionary class


简介

Enchant is the PHP binding for the » Enchant library. Enchant steps in to provide uniformity and conformity on top of all spelling libraries, and implement certain features that may be lacking in any individual provider library. Everything should "just work" for any and every definition of "just working."

Enchant supports the following backends:

  • Aspell/Pspell (intends to replace Ispell)

  • Ispell (old as sin, could be interpreted as a defacto standard)

  • MySpell/Hunspell (an OOo projects, also used by Mozilla)

  • Uspell (primarily Yiddish, Hebrew, and Eastern European languages - hosted in AbiWord's CVS under the module "uspell")

  • Hspell (Hebrew)

  • AppleSpell (Mac OSX)


需求

This version uses the functions of the » Enchant library by Dom Lachowicz. You need Enchant 1.2.4 or later. Enchant 2.0.0 or later is only supported as of PHP 8.0.0.

Enchant also requires » Glib 2.6 or greater. Pre-compiled Windows libraries are available from » http://ftp.gnome.org/pub/gnome/binaries/win32/glib/.


安装

This extension is bundled with PHP as of PHP 5.3.0. Before this time, enchant was a PECL extension. Users of versions prior to 5.3.0 may use the » PECL extension.

Provided the required libraries are installed, users of PHP 5.3.0 or later may enable enchant by adding the --with-enchant[=dir] option when compiling PHP.


资源类型

Prior to PHP 8.0.0, there are two types of resources in this extension. The first one is the broker (backends manager) and the second is for the dictionary.


预定义常量

LIBENCHANT_VERSION (string)
The version of libenchant. Available as of PHP 8.0.0.
ENCHANT_MYSPELL (int)
Dictionary type for MySpell. Used with enchant_broker_get_dict_path() and enchant_broker_set_dict_path(). Deprecated as of PHP 8.0.0.
ENCHANT_ISPELL (int)
Dictionary type for Ispell. Used with enchant_broker_get_dict_path() and enchant_broker_set_dict_path(). Deprecated as of PHP 8.0.0.


范例

Example #1 Enchant Usage Example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
$bprovides = enchant_broker_describe($r);
echo "Current broker provides the following backend(s):\n";
print_r($bprovides);

$dicts = enchant_broker_list_dicts($r);
print_r($dicts);
if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);
    $dprovides = enchant_dict_describe($d);
    echo "dictionary $tag provides:\n";
    $wordcorrect = enchant_dict_check($d, "soong");
    print_r($dprovides);
    if (!$wordcorrect) {
        $suggs = enchant_dict_suggest($d, "soong");
        echo "Suggestions for 'soong':";
        print_r($suggs);
    }
    enchant_broker_free_dict($d);
} else {
}
enchant_broker_free($r);
?>


Enchant 函数

Table of Contents

  • enchant_broker_describe — Enumerates the Enchant providers
  • enchant_broker_dict_exists — Whether a dictionary exists or not. Using non-empty tag
  • enchant_broker_free_dict — Free a dictionary resource
  • enchant_broker_free — Free the broker resource and its dictionaries
  • enchant_broker_get_dict_path — Get the directory path for a given backend
  • enchant_broker_get_error — Returns the last error of the broker
  • enchant_broker_init — Create a new broker object capable of requesting
  • enchant_broker_list_dicts — Returns a list of available dictionaries
  • enchant_broker_request_dict — Create a new dictionary using a tag
  • enchant_broker_request_pwl_dict — Creates a dictionary using a PWL file
  • enchant_broker_set_dict_path — Set the directory path for a given backend
  • enchant_broker_set_ordering — Declares a preference of dictionaries to use for the language
  • enchant_dict_add_to_personal — 别名 enchant_dict_add
  • enchant_dict_add_to_session — Add 'word' to this spell-checking session
  • enchant_dict_add — Add a word to personal word list
  • enchant_dict_check — Check whether a word is correctly spelled or not
  • enchant_dict_describe — Describes an individual dictionary
  • enchant_dict_get_error — Returns the last error of the current spelling-session
  • enchant_dict_is_added — Whether or not 'word' exists in this spelling-session
  • enchant_dict_is_in_session — 别名 enchant_dict_is_added
  • enchant_dict_quick_check — Check the word is correctly spelled and provide suggestions
  • enchant_dict_store_replacement — Add a correction for a word
  • enchant_dict_suggest — Will return a list of values if any of those pre-conditions are not met


Enumerates the Enchant providers

  • ? Enchant 函数
  • enchant_broker_dict_exists ?
  • PHP Manual
  • Enchant 函数
  • Enumerates the Enchant providers

enchant_broker_describe

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0)

enchant_broker_describe — Enumerates the Enchant providers

说明

enchant_broker_describe ( EnchantBroker $broker ) : array

Enumerates the Enchant providers and tells you some rudimentary information about them. The same info is provided through phpinfo().

参数

broker

An Enchant broker returned by enchant_broker_init().

返回值

Returns an array of available Enchant providers with their details.

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
8.0.0 | Prior to this version, the function returned false on failure.

范例

Example #1 List the backends provided by the given broker

<?php
$r = enchant_broker_init();
$bprovides = enchant_broker_describe($r);
echo "Current broker provides the following backend(s):\n";
print_r($bprovides);

?>

以上例程的输出类似于：

Current broker provides the following backend(s):
Array
(
    [0] => Array
        (
            [name] => aspell
            [desc] => Aspell Provider
            [file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [1] => Array
        (
            [name] => hspell
            [desc] => Hspell Provider
            [file] => /usr/lib/enchant/libenchant_hspell.so
        )

    [2] => Array
        (
            [name] => ispell
            [desc] => Ispell Provider
            [file] => /usr/lib/enchant/libenchant_ispell.so
        )

    [3] => Array
        (
            [name] => myspell
            [desc] => Myspell Provider
            [file] => /usr/lib/enchant/libenchant_myspell.so
        )

)


Whether a dictionary exists or not. Using non-empty tag

  • ? enchant_broker_describe
  • enchant_broker_free_dict ?
  • PHP Manual
  • Enchant 函数
  • Whether a dictionary exists or not. Using non-empty tag

enchant_broker_dict_exists

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_dict_exists — Whether a dictionary exists or not. Using non-empty tag

说明

enchant_broker_dict_exists ( EnchantBroker $broker , string $tag ) : bool

Tells if a dictionary exists or not, using a non-empty tags

参数

broker

An Enchant broker returned by enchant_broker_init().

tag

non-empty tag in the LOCALE format, ex: us_US, ch_DE, etc.

返回值

Returns true when the tag exist or false when not.

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.

范例

Example #1 A enchant_broker_dict_exists() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
if (enchant_broker_dict_exists($r,$tag)) {
    echo $tag . " dictionary found.\n";
}
?>

参见

  • enchant_broker_describe() - Enumerates the Enchant providers


Free a dictionary resource

  • ? enchant_broker_dict_exists
  • enchant_broker_free ?
  • PHP Manual
  • Enchant 函数
  • Free a dictionary resource

enchant_broker_free_dict

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_free_dict — Free a dictionary resource

Warning

本函数已自 PHP 8.0.0 起被废弃。强烈建议不要依赖本函数。

说明

enchant_broker_free_dict ( EnchantDictionary $dictionary ) : bool

Free a dictionary. As of PHP 8.0.0, it is recommended to unset the object instead of calling this function.

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | dictionary expects a EnchantDictionary now; previoulsy, a 资源(resource) was expected.

参见

  • enchant_broker_request_dict() - Create a new dictionary using a tag
  • enchant_broker_request_pwl_dict() - Creates a dictionary using a PWL file


Free the broker resource and its dictionaries

  • ? enchant_broker_free_dict
  • enchant_broker_get_dict_path ?
  • PHP Manual
  • Enchant 函数
  • Free the broker resource and its dictionaries

enchant_broker_free

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_free — Free the broker resource and its dictionaries

Warning

本函数已自 PHP 8.0.0 起被废弃。强烈建议不要依赖本函数。

说明

enchant_broker_free ( EnchantBroker $broker ) : bool

Free a broker with all its dictionaries. As of PHP 8.0.0, it is recommended to unset the object instead of calling this function.

参数

broker

An Enchant broker returned by enchant_broker_init().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.

参见

  • enchant_broker_init() - Create a new broker object capable of requesting


Get the directory path for a given backend

  • ? enchant_broker_free
  • enchant_broker_get_error ?
  • PHP Manual
  • Enchant 函数
  • Get the directory path for a given backend

enchant_broker_get_dict_path

(PHP 5 >= 5.3.1, PHP 7, PHP 8, PECL enchant >= 1.0.1)

enchant_broker_get_dict_path — Get the directory path for a given backend

Warning

本函数已自 PHP 8.0.0 起被废弃。强烈建议不要依赖本函数。

说明

enchant_broker_get_dict_path ( EnchantBroker $broker , int $type ) : string|false

Get the directory path for a given backend.

参数

broker

An Enchant broker returned by enchant_broker_init().

type

The type of the dictionaries, i.e. ENCHANT_MYSPELL or ENCHANT_ISPELL.

返回值

Returns the path of the dictionary directory on success 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.

注释

Note:

This function is only available if the extension has been compiled with Enchant v1.

参见

  • enchant_broker_set_dict_path() - Set the directory path for a given backend


Returns the last error of the broker

  • ? enchant_broker_get_dict_path
  • enchant_broker_init ?
  • PHP Manual
  • Enchant 函数
  • Returns the last error of the broker

enchant_broker_get_error

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_get_error — Returns the last error of the broker

说明

enchant_broker_get_error ( EnchantBroker $broker ) : string|false

Returns the last error which occurred in this broker.

参数

broker

An Enchant broker returned by enchant_broker_init().

返回值

Return the msg string if an error was found or false

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.


Create a new broker object capable of requesting

  • ? enchant_broker_get_error
  • enchant_broker_list_dicts ?
  • PHP Manual
  • Enchant 函数
  • Create a new broker object capable of requesting

enchant_broker_init

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_init — Create a new broker object capable of requesting

说明

enchant_broker_init ( ) : EnchantBroker|false

参数

返回值

Returns a broker resource on success or false.

更新日志

版本 | 说明
8.0.0 | On success, this function returns an EnchantBroker instance now; previoulsy, a 资源(resource) was retured.

参见

  • enchant_broker_free() - Free the broker resource and its dictionaries


Returns a list of available dictionaries

  • ? enchant_broker_init
  • enchant_broker_request_dict ?
  • PHP Manual
  • Enchant 函数
  • Returns a list of available dictionaries

enchant_broker_list_dicts

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 1.0.1)

enchant_broker_list_dicts — Returns a list of available dictionaries

说明

enchant_broker_list_dicts ( EnchantBroker $broker ) : array

Returns a list of available dictionaries with their details.

参数

broker

An Enchant broker returned by enchant_broker_init().

返回值

Returns an array of available dictionaries with their details.

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
8.0.0 | Prior to this version, the function returned false on failure.

范例

Example #1 List all available dictionaries for one broker

<?php
$r = enchant_broker_init();
$dicts = enchant_broker_list_dicts($r);
print_r($dicts);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [lang_tag] => de
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [1] => Array
        (
            [lang_tag] => de_DE
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [3] => Array
        (
            [lang_tag] => en
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [4] => Array
        (
            [lang_tag] => en_GB
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [5] => Array
        (
            [lang_tag] => en_US
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [6] => Array
        (
            [lang_tag] => hi_IN
            [provider_name] => myspell
            [provider_desc] => Myspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_myspell.so
        )

)

参见

  • enchant_broker_describe() - Enumerates the Enchant providers


Create a new dictionary using a tag

  • ? enchant_broker_list_dicts
  • enchant_broker_request_pwl_dict ?
  • PHP Manual
  • Enchant 函数
  • Create a new dictionary using a tag

enchant_broker_request_dict

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_request_dict — Create a new dictionary using a tag

说明

enchant_broker_request_dict ( EnchantBroker $broker , string $tag ) : EnchantDictionary|false

create a new dictionary using tag, the non-empty language tag you wish to request a dictionary for ("en_US", "de_DE", ...)

参数

broker

An Enchant broker returned by enchant_broker_init().

tag

A tag describing the locale, for example en_US, de_DE

返回值

Returns a dictionary resource on success 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
8.0.0 | On success, this function returns an EnchantDictionary instance now; previoulsy, a 资源(resource) was retured.

范例

Example #1 A enchant_broker_request_dict() example

Check if a dictionary exists using enchant_broker_dict_exists() and request it.

<?php
$tag = 'en_US';
$broker = enchant_broker_init();
if (enchant_broker_dict_exists($broker,$tag)) {
    $dict = enchant_broker_request_dict($r, $tag);
}
?>

参见

  • enchant_dict_describe() - Describes an individual dictionary
  • enchant_broker_dict_exists() - Whether a dictionary exists or not. Using non-empty tag
  • enchant_broker_free_dict() - Free a dictionary resource


Creates a dictionary using a PWL file

  • ? enchant_broker_request_dict
  • enchant_broker_set_dict_path ?
  • PHP Manual
  • Enchant 函数
  • Creates a dictionary using a PWL file

enchant_broker_request_pwl_dict

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_request_pwl_dict — Creates a dictionary using a PWL file

说明

enchant_broker_request_pwl_dict ( EnchantBroker $broker , string $filename ) : EnchantDictionary|false

Creates a dictionary using a PWL file. A PWL file is personal word file one word per line.

参数

broker

An Enchant broker returned by enchant_broker_init().

filename

Path to the PWL file. If there is no such file, a new one will be created if possible.

返回值

Returns a dictionary resource on success 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
8.0.0 | On success, this function returns an EnchantDictionary instance now; previoulsy, a 资源(resource) was retured.

参见

  • enchant_dict_describe() - Describes an individual dictionary
  • enchant_broker_dict_exists() - Whether a dictionary exists or not. Using non-empty tag
  • enchant_broker_free_dict() - Free a dictionary resource


Set the directory path for a given backend

  • ? enchant_broker_request_pwl_dict
  • enchant_broker_set_ordering ?
  • PHP Manual
  • Enchant 函数
  • Set the directory path for a given backend

enchant_broker_set_dict_path

(PHP 5 >= 5.3.1, PHP 7, PHP 8, PECL enchant >= 1.0.1)

enchant_broker_set_dict_path — Set the directory path for a given backend

Warning

本函数已自 PHP 8.0.0 起被废弃。强烈建议不要依赖本函数。

说明

enchant_broker_set_dict_path ( EnchantBroker $broker , int $type , string $path ) : bool

Set the directory path for a given backend.

参数

broker

An Enchant broker returned by enchant_broker_init().

type

The type of the dictionaries, i.e. ENCHANT_MYSPELL or ENCHANT_ISPELL.

path

The path of the dictionary directory.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.

注释

Note:

This function is only available if the extension has been compiled with Enchant v1.

参见

  • enchant_broker_get_dict_path() - Get the directory path for a given backend


Declares a preference of dictionaries to use for the language

  • ? enchant_broker_set_dict_path
  • enchant_dict_add_to_personal ?
  • PHP Manual
  • Enchant 函数
  • Declares a preference of dictionaries to use for the language

enchant_broker_set_ordering

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_broker_set_ordering — Declares a preference of dictionaries to use for the language

说明

enchant_broker_set_ordering ( EnchantBroker $broker , string $tag , string $ordering ) : bool

Declares a preference of dictionaries to use for the language described/referred to by 'tag'. The ordering is a comma delimited list of provider names. As a special exception, the "*" tag can be used as a language tag to declare a default ordering for any language that does not explicitly declare an ordering.

参数

broker

An Enchant broker returned by enchant_broker_init().

tag

Language tag. The special "*" tag can be used as a language tag to declare a default ordering for any language that does not explicitly declare an ordering.

ordering

Comma delimited list of provider names

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.


别名 enchant_dict_add

  • ? enchant_broker_set_ordering
  • enchant_dict_add_to_session ?
  • PHP Manual
  • Enchant 函数
  • 别名 enchant_dict_add

enchant_dict_add_to_personal

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_add_to_personal — 别名 enchant_dict_add()

Warning

该别名已在 PHP 8.0.0 中 废弃。

说明

此函数是该函数的别名： enchant_dict_add().


Add 'word' to this spell-checking session

  • ? enchant_dict_add_to_personal
  • enchant_dict_add ?
  • PHP Manual
  • Enchant 函数
  • Add 'word' to this spell-checking session

enchant_dict_add_to_session

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_add_to_session — Add 'word' to this spell-checking session

说明

enchant_dict_add_to_session ( EnchantDictionary $dictionary , string $word ) : void

Add a word to the given dictionary. It will be added only for the active spell-checking session.

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

word

The word to add

返回值

没有返回值。

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.

参见

  • enchant_broker_request_dict() - Create a new dictionary using a tag


Add a word to personal word list

  • ? enchant_dict_add_to_session
  • enchant_dict_check ?
  • PHP Manual
  • Enchant 函数
  • Add a word to personal word list

enchant_dict_add

(PHP 8)

enchant_dict_add — Add a word to personal word list

说明

enchant_dict_add ( EnchantDictionary $dictionary , string $word ) : void

Add a word to personal word list of the given dictionary.

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

word

The word to add

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.

Example #1 Adding a word to a PWL

<?php

$filename = './my_word_list.pwl';
$word = 'Supercalifragilisticexpialidocious';

$broker = enchant_broker_init();
$dict = enchant_broker_request_pwl_dict($broker, $filename);

enchant_dict_add($dict, $word);

enchant_broker_free($broker);

?>

参见

  • enchant_broker_request_pwl_dict() - Creates a dictionary using a PWL file
  • enchant_broker_request_dict() - Create a new dictionary using a tag


Check whether a word is correctly spelled or not

  • ? enchant_dict_add
  • enchant_dict_describe ?
  • PHP Manual
  • Enchant 函数
  • Check whether a word is correctly spelled or not

enchant_dict_check

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_check — Check whether a word is correctly spelled or not

说明

enchant_dict_check ( EnchantDictionary $dictionary , string $word ) : bool

If the word is correctly spelled return true, otherwise return false

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

word

The word to check

返回值

Returns true if the word is spelled correctly, false if not.

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.


Describes an individual dictionary

  • ? enchant_dict_check
  • enchant_dict_get_error ?
  • PHP Manual
  • Enchant 函数
  • Describes an individual dictionary

enchant_dict_describe

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_describe — Describes an individual dictionary

说明

enchant_dict_describe ( EnchantDictionary $dictionary ) : array

Returns the details of the dictionary.

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
8.0.0 | Prior to this version, the function returned false on failure.

范例

Example #1 A enchant_dict_describe() example

Check if a dictionary exists using enchant_broker_dict_exists() and show the detail of it.

<?php
$tag = 'en_US';
$broker = enchant_broker_init();
if (enchant_broker_dict_exists($broker,$tag)) {
    $dict = enchant_broker_request_dict($r, $tag);
    $dict_details = enchant_dict_describe($dict);
    print_r($dict_details);
}
?>

以上例程的输出类似于：

Array
(
    [lang] => en_US
    [name] => aspell
    [desc] => Aspell Provider
    [file] => /usr/lib/enchant/libenchant_aspell.so
)


Returns the last error of the current spelling-session

  • ? enchant_dict_describe
  • enchant_dict_is_added ?
  • PHP Manual
  • Enchant 函数
  • Returns the last error of the current spelling-session

enchant_dict_get_error

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_get_error — Returns the last error of the current spelling-session

说明

enchant_dict_get_error ( EnchantDictionary $dictionary ) : string|false

Returns the last error of the current spelling-session

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

返回值

Returns the error message as string or false if no error occurred.

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.


Whether or not 'word' exists in this spelling-session

  • ? enchant_dict_get_error
  • enchant_dict_is_in_session ?
  • PHP Manual
  • Enchant 函数
  • Whether or not 'word' exists in this spelling-session

enchant_dict_is_added

(PHP 8)

enchant_dict_is_added — Whether or not 'word' exists in this spelling-session

说明

enchant_dict_is_added ( EnchantDictionary $dictionary , string $word ) : bool

Tells whether or not a word already exists in the current session.

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

word

The word to lookup

返回值

Returns true if the word exists or false

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.

参见

  • enchant_dict_add_to_session() - Add 'word' to this spell-checking session


别名 enchant_dict_is_added

  • ? enchant_dict_is_added
  • enchant_dict_quick_check ?
  • PHP Manual
  • Enchant 函数
  • 别名 enchant_dict_is_added

enchant_dict_is_in_session

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_is_in_session — 别名 enchant_dict_is_added()

Warning

该别名已在 PHP 8.0.0 中 废弃。

说明

此函数是该函数的别名： enchant_dict_is_added().


Check the word is correctly spelled and provide suggestions

  • ? enchant_dict_is_in_session
  • enchant_dict_store_replacement ?
  • PHP Manual
  • Enchant 函数
  • Check the word is correctly spelled and provide suggestions

enchant_dict_quick_check

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant:0.2.0-1.0.1)

enchant_dict_quick_check — Check the word is correctly spelled and provide suggestions

说明

enchant_dict_quick_check ( EnchantDictionary $dictionary , string $word , array &$suggestions = null ) : bool

If the word is correctly spelled return true, otherwise return false, if suggestions variable is provided, fill it with spelling alternatives.

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

word

The word to check

suggestions

If the word is not correctly spelled, this variable will contain an array of suggestions.

返回值

Returns true if the word is correctly spelled or false

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.

范例

Example #1 A enchant_dict_quick_check() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();

if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);
    enchant_dict_quick_check($d, 'soong', $suggs);
    print_r($suggs);
}
?>

以上例程的输出类似于：

Array
(
    [0] => song
    [1] => snog
    [2] => soon
    [3] => Sang
    [4] => Sung
    [5] => sang
    [6] => sung
    [7] => sponge
    [8] => spongy
    [9] => snag
    [10] => snug
    [11] => sonic
    [12] => sing
    [13] => songs
    [14] => Son
    [15] => Sonja
    [16] => Synge
    [17] => son
    [18] => Sejong
    [19] => sarong
    [20] => sooner
    [21] => Sony
    [22] => sown
    [23] => scone
    [24] => song's
)

参见

  • enchant_dict_check() - Check whether a word is correctly spelled or not
  • enchant_dict_suggest() - Will return a list of values if any of those pre-conditions are not met


Add a correction for a word

  • ? enchant_dict_quick_check
  • enchant_dict_suggest ?
  • PHP Manual
  • Enchant 函数
  • Add a correction for a word

enchant_dict_store_replacement

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_store_replacement — Add a correction for a word

说明

enchant_dict_store_replacement ( EnchantDictionary $dictionary , string $misspelled , string $correct ) : void

Add a correction for 'mis' using 'cor'. Notes that you replaced @mis with @cor, so it's possibly more likely that future occurrences of @mis will be replaced with @cor. So it might bump @cor up in the suggestion list.

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

misspelled

The work to fix

correct

The correct word

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.


Will return a list of values if any of those pre-conditions are not met

  • ? enchant_dict_store_replacement
  • EnchantBroker ?
  • PHP Manual
  • Enchant 函数
  • Will return a list of values if any of those pre-conditions are not met

enchant_dict_suggest

(PHP 5 >= 5.3.0, PHP 7, PHP 8, PECL enchant >= 0.1.0 )

enchant_dict_suggest — Will return a list of values if any of those pre-conditions are not met

说明

enchant_dict_suggest ( EnchantDictionary $dictionary , string $word ) : array

参数

dictionary

An Enchant dictionary returned by enchant_broker_request_dict() or enchant_broker_request_pwl_dict().

word

Word to use for the suggestions.

返回值

Will returns an array of suggestions if the word is bad spelled.

更新日志

版本 | 说明
8.0.0 | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.

范例

Example #1 A enchant_dict_suggest() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);

    $wordcorrect = enchant_dict_check($d, "soong");
    if (!$wordcorrect) {
        $suggs = enchant_dict_suggest($d, "soong");
        echo "Suggestions for 'soong':";
        print_r($suggs);
    }
    enchant_broker_free_dict($d);
}
enchant_broker_free($r);
?>

参见

  • enchant_dict_check() - Check whether a word is correctly spelled or not
  • enchant_dict_quick_check() - Check the word is correctly spelled and provide suggestions


The EnchantBroker class

(PHP 8)

简介

A fully opaque class which replaces enchant_broker resources as of PHP 8.0.0.

类摘要

final EnchantBroker {
}


The EnchantDictionary class

(PHP 8)

简介

A fully opaque class which replaces enchant_dict resources as of PHP 8.0.0.

类摘要

final EnchantDictionary {
}


Determine gender of firstnames

  • 简介
  • 安装／配置
    • 安装
  • 范例
    • Usage example.
  • Gender\Gender — The Gender\Gender class
    • Gender\Gender::connect — Connect to an external name dictionary
    • Gender\Gender::__construct — Construct the Gender object
    • Gender\Gender::country — Get textual country representation
    • Gender\Gender::get — Get gender of a name
    • Gender\Gender::isNick — Check if the name0 is an alias of the name1
    • Gender\Gender::similarNames — Get similar names


简介

Gender PHP extension is a port of the gender.c program originally written by Joerg Michael. The main purpose is to find out the gender of firstnames. The current database contains >40000 firstnames from 54 countries.


  • ? 简介
  • 安装 ?
  • PHP Manual
  • Gender
  • 安装／配置

安装／配置

Table of Contents

  • 安装


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/gender.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/gender/.


  • ? 安装
  • Usage example. ?
  • PHP Manual
  • Gender
  • 范例

范例

Table of Contents

  • Usage example.


Usage example.

Gender class usage example.

Example #1 Usage example.

<?php

namespace Gender;

$gender = new Gender;

$name = "Milene";
$country = Gender::FRANCE;

$result = $gender->get($name, $country);

$data = $gender->country($country);

switch($result) {
    case Gender::IS_FEMALE:
        printf("The name %s is female in %s\n", $name, $data['country']);
    break;

    case Gender::IS_MOSTLY_FEMALE:
        printf("The name %s is mostly female in %s\n", $name, $data['country']);
    break;

    case Gender::IS_MALE:
        printf("The name %s is male in %s\n", $name, $data['country']);
    break;

    case Gender::IS_MOSTLY_MALE:
        printf("The name %s is mostly male in %s\n", $name, $data['country']);
    break;

    case Gender::IS_UNISEX_NAME:
        printf("The name %s is unisex in %s\n", $name, $data['country']);
    break;

    case Gender::IS_A_COUPLE:
        printf("The name %s is both male and female in %s\n", $name, $data['country']);
    break;

    case Gender::NAME_NOT_FOUND:
        printf("The name %s was not found for %s\n", $name, $data['country']);
    break;

    case Gender::ERROR_IN_NAME:
        echo "There is an error in the given name!\n";
    break;

    default:
        echo "An error occurred!\n";
    break;

}


The Gender\Gender class

(PECL gender >= 0.6.0)

简介

类摘要

Gender\Gender {
/* Constants */
const int IS_FEMALE = 70 ;
const int IS_MOSTLY_FEMALE = 102 ;
const int IS_MALE = 77 ;
const int IS_MOSTLY_MALE = 109 ;
const int IS_UNISEX_NAME = 63 ;
const int IS_A_COUPLE = 67 ;
const int NAME_NOT_FOUND = 32 ;
const int ERROR_IN_NAME = 69 ;
const int ANY_COUNTRY = 0 ;
const int BRITAIN = 1 ;
const int IRELAND = 2 ;
const int USA = 3 ;
const int SPAIN = 4 ;
const int PORTUGAL = 5 ;
const int ITALY = 6 ;
const int MALTA = 7 ;
const int FRANCE = 8 ;
const int BELGIUM = 9 ;
const int LUXEMBOURG = 10 ;
const int NETHERLANDS = 11 ;
const int GERMANY = 12 ;
const int EAST_FRISIA = 13 ;
const int AUSTRIA = 14 ;
const int SWISS = 15 ;
const int ICELAND = 16 ;
const int DENMARK = 17 ;
const int NORWAY = 18 ;
const int SWEDEN = 19 ;
const int FINLAND = 20 ;
const int ESTONIA = 21 ;
const int LATVIA = 22 ;
const int LITHUANIA = 23 ;
const int POLAND = 24 ;
const int CZECH_REP = 25 ;
const int SLOVAKIA = 26 ;
const int HUNGARY = 27 ;
const int ROMANIA = 28 ;
const int BULGARIA = 29 ;
const int BOSNIA = 30 ;
const int CROATIA = 31 ;
const int KOSOVO = 32 ;
const int MACEDONIA = 33 ;
const int MONTENEGRO = 34 ;
const int SERBIA = 35 ;
const int SLOVENIA = 36 ;
const int ALBANIA = 37 ;
const int GREECE = 38 ;
const int RUSSIA = 39 ;
const int BELARUS = 40 ;
const int MOLDOVA = 41 ;
const int UKRAINE = 42 ;
const int ARMENIA = 43 ;
const int AZERBAIJAN = 44 ;
const int GEORGIA = 45 ;
const int KAZAKH_UZBEK = 46 ;
const int TURKEY = 47 ;
const int ARABIA = 48 ;
const int ISRAEL = 49 ;
const int CHINA = 50 ;
const int INDIA = 51 ;
const int JAPAN = 52 ;
const int KOREA = 53 ;
/* 方法 */
public connect ( string $dsn ) : bool
public __construct ( string $dsn = ? )
public country ( int $country ) : array|false
public get ( string $name , int $country = ? ) : int
public isNick ( string $name0 , string $name1 , int $country = ? ) : array
public similarNames ( string $name , int $country = ? ) : array
}

预定义常量

Gender\Gender::IS_FEMALE

Gender\Gender::IS_MOSTLY_FEMALE

Gender\Gender::IS_MALE

Gender\Gender::IS_MOSTLY_MALE

Gender\Gender::IS_UNISEX_NAME

Gender\Gender::IS_A_COUPLE

Gender\Gender::NAME_NOT_FOUND

Gender\Gender::ERROR_IN_NAME

Gender\Gender::ANY_COUNTRY

Gender\Gender::BRITAIN

Gender\Gender::IRELAND

Gender\Gender::USA

Gender\Gender::SPAIN

Gender\Gender::PORTUGAL

Gender\Gender::ITALY

Gender\Gender::MALTA

Gender\Gender::FRANCE

Gender\Gender::BELGIUM

Gender\Gender::LUXEMBOURG

Gender\Gender::NETHERLANDS

Gender\Gender::GERMANY

Gender\Gender::EAST_FRISIA

Gender\Gender::AUSTRIA

Gender\Gender::SWISS

Gender\Gender::ICELAND

Gender\Gender::DENMARK

Gender\Gender::NORWAY

Gender\Gender::SWEDEN

Gender\Gender::FINLAND

Gender\Gender::ESTONIA

Gender\Gender::LATVIA

Gender\Gender::LITHUANIA

Gender\Gender::POLAND

Gender\Gender::CZECH_REP

Gender\Gender::SLOVAKIA

Gender\Gender::HUNGARY

Gender\Gender::ROMANIA

Gender\Gender::BULGARIA

Gender\Gender::BOSNIA

Gender\Gender::CROATIA

Gender\Gender::KOSOVO

Gender\Gender::MACEDONIA

Gender\Gender::MONTENEGRO

Gender\Gender::SERBIA

Gender\Gender::SLOVENIA

Gender\Gender::ALBANIA

Gender\Gender::GREECE

Gender\Gender::RUSSIA

Gender\Gender::BELARUS

Gender\Gender::MOLDOVA

Gender\Gender::UKRAINE

Gender\Gender::ARMENIA

Gender\Gender::AZERBAIJAN

Gender\Gender::GEORGIA

Gender\Gender::KAZAKH_UZBEK

Gender\Gender::TURKEY

Gender\Gender::ARABIA

Gender\Gender::ISRAEL

Gender\Gender::CHINA

Gender\Gender::INDIA

Gender\Gender::JAPAN

Gender\Gender::KOREA

Table of Contents

  • Gender\Gender::connect — Connect to an external name dictionary
  • Gender\Gender::__construct — Construct the Gender object
  • Gender\Gender::country — Get textual country representation
  • Gender\Gender::get — Get gender of a name
  • Gender\Gender::isNick — Check if the name0 is an alias of the name1
  • Gender\Gender::similarNames — Get similar names


Connect to an external name dictionary

  • ? Gender\Gender
  • Gender\Gender::__construct ?
  • PHP Manual
  • Gender\Gender
  • Connect to an external name dictionary

Gender\Gender::connect

(PECL gender >= 0.6.0)

Gender\Gender::connect — Connect to an external name dictionary

说明

public Gender\Gender::connect ( string $dsn ) : bool

Connect to an external name dictionary. Currently only streams are supported.

参数

dsn

DSN to open.

返回值

Boolean as success of failure.


Construct the Gender object

  • ? Gender\Gender::connect
  • Gender\Gender::country ?
  • PHP Manual
  • Gender\Gender
  • Construct the Gender object

Gender\Gender::__construct

(PECL gender >= 0.6.0)

Gender\Gender::__construct — Construct the Gender object

说明

public Gender\Gender::__construct ( string $dsn = ? )

Create a Gender object optionally connecting to an external name dictionary. When no external database was given, compiled in data will be used.

参数

dsn

DSN to open.

返回值


Get textual country representation

  • ? Gender\Gender::__construct
  • Gender\Gender::get ?
  • PHP Manual
  • Gender\Gender
  • Get textual country representation

Gender\Gender::country

(PECL gender >= 0.8.0)

Gender\Gender::country — Get textual country representation

说明

public Gender\Gender::country ( int $country ) : array|false

Returns the textual representation of a country from a Gender class constant.

参数

country

A country ID specified by a Gender\Gender class constant.

返回值

Returns an array with the short and full names of the country on success 或者在失败时返回 false.

范例

Example #1 Using Gender\Gender::country()

$gender = new Gender\Gender;
var_dump($gender->country(Gender\Gender::BRITAIN));

以上例程会输出：

array(2) {
  'country_short' =>
  string(2) "UK"
  'country' =>
  string(13) "Great Britain"
}


Get gender of a name

  • ? Gender\Gender::country
  • Gender\Gender::isNick ?
  • PHP Manual
  • Gender\Gender
  • Get gender of a name

Gender\Gender::get

(PECL gender >= 0.6.0)

Gender\Gender::get — Get gender of a name

说明

public Gender\Gender::get ( string $name , int $country = ? ) : int

Get the gender of the name in a particular country.

参数

name

Name to check.

country

Country id identified by Gender class constant.

返回值

Returns gender of the name.


Check if the name0 is an alias of the name1

  • ? Gender\Gender::get
  • Gender\Gender::similarNames ?
  • PHP Manual
  • Gender\Gender
  • Check if the name0 is an alias of the name1

Gender\Gender::isNick

(PECL gender >= 0.9.0)

Gender\Gender::isNick — Check if the name0 is an alias of the name1

说明

public Gender\Gender::isNick ( string $name0 , string $name1 , int $country = ? ) : array

Check whether the name0 is a nick of the name1.

参数

name0

Name to check.

name1

Name to check.

country

Country id identified by Gender class constant. If ommited ANY_COUNTRY is used.

返回值

成功时返回 true， 或者在失败时返回 false。


Get similar names

  • ? Gender\Gender::isNick
  • Gettext ?
  • PHP Manual
  • Gender\Gender
  • Get similar names

Gender\Gender::similarNames

(PECL gender >= 0.9.0)

Gender\Gender::similarNames — Get similar names

说明

public Gender\Gender::similarNames ( string $name , int $country = ? ) : array

Get similar names for the given name and country.

参数

name

Name to check.

country

Country id identified by Gender class constant. If ommited ANY_COUNTRY is used.

返回值

Returns an array with the similar names found.


Gettext

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Gettext 函数
    • bind_textdomain_codeset — Specify or get the character encoding in which the messages from the DOMAIN message catalog will be returned
    • bindtextdomain — Sets or gets the path for a domain
    • dcgettext — Overrides the domain for a single lookup
    • dcngettext — Plural version of dcgettext
    • dgettext — Override the current domain
    • dngettext — Plural version of dgettext
    • gettext — Lookup a message in the current domain
    • ngettext — Plural version of gettext
    • textdomain — Sets the default domain


简介

gettext函数实现了NLS (Native Language Support) API，他可以用来国际化您的PHP程序. 请参阅gettext的文档，为您的系统进行国际化功能的详尽的解释 或查看文档 » http://www.gnu.org/software/gettext/manual/gettext.html.


需求

要使用这些函数，你必须从 » http://www.gnu.org/software/gettext/gettext.html 下载和安装 GNU gettext 包


安装

在构建PHP的时候要添加 GNU gettext 支持，你必须添加如下选项 --with-gettext[=DIR] DIR 表示 gettext 的安装目录，默认是/usr/local.


  • ? 资源类型
  • Gettext 函数 ?
  • PHP Manual
  • Gettext
  • 预定义常量

预定义常量

此扩展没有定义常量。


Gettext 函数

Table of Contents

  • bind_textdomain_codeset — Specify or get the character encoding in which the messages from the DOMAIN message catalog will be returned
  • bindtextdomain — Sets or gets the path for a domain
  • dcgettext — Overrides the domain for a single lookup
  • dcngettext — Plural version of dcgettext
  • dgettext — Override the current domain
  • dngettext — Plural version of dgettext
  • gettext — Lookup a message in the current domain
  • ngettext — Plural version of gettext
  • textdomain — Sets the default domain


Specify or get the character encoding in which the messages from the DOMAIN message catalog will be returned

  • ? Gettext 函数
  • bindtextdomain ?
  • PHP Manual
  • Gettext 函数
  • Specify or get the character encoding in which the messages from the DOMAIN message catalog will be returned

bind_textdomain_codeset

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

bind_textdomain_codeset — Specify or get the character encoding in which the messages from the DOMAIN message catalog will be returned

说明

bind_textdomain_codeset ( string $domain , string|null $codeset ) : string|false

bind_textdomain_codeset() allows to set or get the encoding in which messages from domain will be returned by gettext() and similar functions.

参数

domain

The domain.

codeset

The code set. If null, the currently set encoding is returned.

返回值

A string on success.

更新日志

版本 | 说明
8.0.3 | codeset is nullable now. Previously, it was not possible to retrieve the currently set encoding.

注释

Note:

The bind_textdomain_codeset() information is maintained per process, not per thread.


Sets or gets the path for a domain

  • ? bind_textdomain_codeset
  • dcgettext ?
  • PHP Manual
  • Gettext 函数
  • Sets or gets the path for a domain

bindtextdomain

(PHP 4, PHP 5, PHP 7, PHP 8)

bindtextdomain — Sets or gets the path for a domain

说明

bindtextdomain ( string $domain , string|null $directory ) : string|false

The bindtextdomain() function sets or gets the path for a domain.

参数

domain

The domain.

directory

The directory path. If null, the currently set directory is returned.

返回值

The full pathname for the domain currently being set, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.3 | directory is nullable now. Previously, it was not possible to retrieve the currently set directory.

范例

Example #1 bindtextdomain() example

<?php

$domain = 'myapp';
echo bindtextdomain($domain, '/usr/share/myapp/locale');

?>

以上例程会输出：

/usr/share/myapp/locale

注释

Note:

The bindtextdomain() information is maintained per process, not per thread.


Overrides the domain for a single lookup

  • ? bindtextdomain
  • dcngettext ?
  • PHP Manual
  • Gettext 函数
  • Overrides the domain for a single lookup

dcgettext

(PHP 4, PHP 5, PHP 7, PHP 8)

dcgettext — Overrides the domain for a single lookup

说明

dcgettext ( string $domain , string $message , int $category ) : string

This function allows you to override the current domain for a single message lookup.

参数

domain

The domain

message

The message

category

The category

返回值

A string on success.

参见

  • gettext() - Lookup a message in the current domain


Plural version of dcgettext

  • ? dcgettext
  • dgettext ?
  • PHP Manual
  • Gettext 函数
  • Plural version of dcgettext

dcngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

dcngettext — Plural version of dcgettext

说明

dcngettext ( string $domain , string $singular , string $plural , int $count , int $category ) : string

This function allows you to override the current domain for a single plural message lookup.

参数

domain

The domain

singular

plural

count

category

返回值

A string on success.

参见

  • ngettext() - Plural version of gettext


Override the current domain

  • ? dcngettext
  • dngettext ?
  • PHP Manual
  • Gettext 函数
  • Override the current domain

dgettext

(PHP 4, PHP 5, PHP 7, PHP 8)

dgettext — Override the current domain

说明

dgettext ( string $domain , string $message ) : string

The dgettext() function allows you to override the current domain for a single message lookup.

参数

domain

The domain

message

The message

返回值

A string on success.

参见

  • gettext() - Lookup a message in the current domain


Plural version of dgettext

  • ? dgettext
  • gettext ?
  • PHP Manual
  • Gettext 函数
  • Plural version of dgettext

dngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

dngettext — Plural version of dgettext

说明

dngettext ( string $domain , string $singular , string $plural , int $count ) : string

The dngettext() function allows you to override the current domain for a single plural message lookup.

参数

domain

The domain

singular

plural

count

返回值

A string on success.

参见

  • ngettext() - Plural version of gettext


Lookup a message in the current domain

  • ? dngettext
  • ngettext ?
  • PHP Manual
  • Gettext 函数
  • Lookup a message in the current domain

gettext

(PHP 4, PHP 5, PHP 7, PHP 8)

gettext — Lookup a message in the current domain

说明

gettext ( string $message ) : string

Looks up a message in the current domain.

参数

message

The message being translated.

返回值

Returns a translated string if one is found in the translation table, or the submitted message if not found.

范例

Example #1 gettext()-check

<?php
// Set language to German
putenv('LC_ALL=de_DE');
setlocale(LC_ALL, 'de_DE');

// Specify location of translation tables
bindtextdomain("myPHPApp", "./locale");

// Choose domain
textdomain("myPHPApp");

// Translation is looking for in ./locale/de_DE/LC_MESSAGES/myPHPApp.mo now

// Print a test message
echo gettext("Welcome to My PHP Application");

// Or use the alias _() for gettext()
echo _("Have a nice day");
?>

注释

Note:

You may use the underscore character '_' as an alias to this function.

Note:

Setting a language isn't enough for some systems and the putenv() should be used to define the current locale.

参见

  • setlocale() - 设置地区信息


Plural version of gettext

  • ? gettext
  • textdomain ?
  • PHP Manual
  • Gettext 函数
  • Plural version of gettext

ngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ngettext — Plural version of gettext

说明

ngettext ( string $singular , string $plural , int $count ) : string

The plural version of gettext(). Some languages have more than one form for plural messages dependent on the count.

参数

singular

The singular message ID.

plural

The plural message ID.

count

The number (e.g. item count) to determine the translation for the respective grammatical number.

返回值

Returns correct plural form of message identified by singular and plural for count count.

范例

Example #1 ngettext() example

<?php

setlocale(LC_ALL, 'cs_CZ');
printf(ngettext("%d window", "%d windows", 1), 1); // 1 okno
printf(ngettext("%d window", "%d windows", 2), 2); // 2 okna
printf(ngettext("%d window", "%d windows", 5), 5); // 5 oken

?>


Sets the default domain

  • ? ngettext
  • iconv ?
  • PHP Manual
  • Gettext 函数
  • Sets the default domain

textdomain

(PHP 4, PHP 5, PHP 7, PHP 8)

textdomain — Sets the default domain

说明

textdomain ( string|null $domain ) : string

This function sets the domain to search within when calls are made to gettext(), usually the named after an application.

参数

domain

The new message domain, or null to get the current setting without changing it

返回值

If successful, this function returns the current message domain, after possibly changing it.

注释

Note:

The textdomain() information is maintained per process, not per thread.


iconv

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • iconv 函数
    • iconv_get_encoding — 获取 iconv 扩展的内部配置变量
    • iconv_mime_decode_headers — 一次性解码多个 MIME 头字段
    • iconv_mime_decode — 解码一个MIME头字段
    • iconv_mime_encode — Composes a MIME header field
    • iconv_set_encoding — 为字符编码转换设定当前设置
    • iconv_strlen — 返回字符串的字符数统计
    • iconv_strpos — Finds position of first occurrence of a needle within a haystack
    • iconv_strrpos — Finds the last occurrence of a needle within a haystack
    • iconv_substr — 截取字符串的部分
    • iconv — 字符串按要求的字符编码来转换
    • ob_iconv_handler — 以输出缓冲处理程序转换字符编码


简介

此模块包含了 iconv 字符集转换功能的接口。 使用此模块，你可以将一个本地字符集表达的字符串转换成另一种字符集，比如可以是 Unicode 字符集。 支持的字符集基于你系统上 iconv 的实现。 注意，在某些系统上 iconv 函数可能无法以你预期的那样工作。 在这种情况下，安装 » GNU libiconv 库将会是个不错的主意。 它最终将会产生更一致的结果。

自 PHP 5.0.0 起，配备了这个具有多种实用功能的扩展，来帮助您编写多语言脚本。 让我们看看以下章节，来探索新的功能。


需求

如果你使用了最新的 POSIX 兼容系统，则不需要安装其他程序，因为系统提供的 C 语言标准函数库肯定支持 iconv。否则，你必须在系统上安装 » libiconv 函数库。


安装

默认已激活此扩展，但是它能够在编译时通过 --without-iconv 选项被禁用。

选项指令 --with-iconv[=DIR] 用于 PHP 编译时指定 iconv 在系统里的路径，否则会扫描默认路径。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Iconv 配置选项
名字 | 默认 | 可修改范围 | 更新日志
iconv.input_encoding | "" | PHP_INI_ALL | 在 PHP 5.6.0 中废弃。
iconv.output_encoding | "" | PHP_INI_ALL | 在 PHP 5.6.0 中废弃。
iconv.internal_encoding | "" | PHP_INI_ALL | 在 PHP 5.6.0 中废弃。

这是配置指令的简短说明。

Warning

有些系统（比如 IBM AIX） 使用 "ISO8859-1" 来代替 "ISO-8859-1"，所以在配置选项和函数参数中必须使用这个值。

iconv.input_encoding string
Warning

本特性已自 PHP 5.6.0 起废弃。强烈建议不要使用本特性。

PHP 5.6 及以上的用户应该留空并以 input_encoding 取代。

iconv.output_encoding string
Warning

本特性已自 PHP 5.6.0 起废弃。强烈建议不要使用本特性。

PHP 5.6 及以上的用户应该留空并以 output_encoding 取代。

iconv.internal_encoding string
Warning

本特性已自 PHP 5.6.0 起废弃。强烈建议不要使用本特性。

PHP 5.6 及以上的用户应该留空并以 default_charset 取代。


预定义常量

自 PHP 4.3.0 起，它能够在运行时识别此扩展使用了哪种实现（implementation）。

iconv 常量
名称 | 类型 | 描述
ICONV_IMPL | string | 实现（implementation）的名称
ICONV_VERSION | string | 实现（implementation）的版本

Note:

通过这些常量编写依赖于实现的脚本是极其不建议的。

自 PHP 5.0.0 起，以下常量同样有效：

自 PHP 5.0.0 起的 iconv 常量
名称 | 类型 | 描述
ICONV_MIME_DECODE_STRICT | integer | 使用于 iconv_mime_decode() 的位掩码
ICONV_MIME_DECODE_CONTINUE_ON_ERROR | integer | 使用于 iconv_mime_decode() 的位掩码


iconv 函数

参见

参见 GNU Recode functions。

Table of Contents

  • iconv_get_encoding — 获取 iconv 扩展的内部配置变量
  • iconv_mime_decode_headers — 一次性解码多个 MIME 头字段
  • iconv_mime_decode — 解码一个MIME头字段
  • iconv_mime_encode — Composes a MIME header field
  • iconv_set_encoding — 为字符编码转换设定当前设置
  • iconv_strlen — 返回字符串的字符数统计
  • iconv_strpos — Finds position of first occurrence of a needle within a haystack
  • iconv_strrpos — Finds the last occurrence of a needle within a haystack
  • iconv_substr — 截取字符串的部分
  • iconv — 字符串按要求的字符编码来转换
  • ob_iconv_handler — 以输出缓冲处理程序转换字符编码


获取 iconv 扩展的内部配置变量

  • ? iconv 函数
  • iconv_mime_decode_headers ?
  • PHP Manual
  • iconv 函数
  • 获取 iconv 扩展的内部配置变量

iconv_get_encoding

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

iconv_get_encoding — 获取 iconv 扩展的内部配置变量

说明

iconv_get_encoding ( string $type = "all" ) : mixed

获取 iconv 扩展的内部配置变量。

参数

type

选项 type 的值可以是：

  • all
  • input_encoding
  • output_encoding
  • internal_encoding

返回值

成功时返回当前内部配置变量的值， 或者在失败时返回 false。

如果省略了 type，或者设置为 "all"，iconv_get_encoding() 返回包含所有这些变量的数组。

范例

Example #1 iconv_get_encoding() 例子

<pre>
<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
var_dump(iconv_get_encoding('all'));
?>
</pre>

以上例程会输出：

Array
(
    [input_encoding] => ISO-8859-1
    [output_encoding] => ISO-8859-1
    [internal_encoding] => UTF-8
)

参见

  • iconv_set_encoding() - 为字符编码转换设定当前设置
  • ob_iconv_handler() - 以输出缓冲处理程序转换字符编码


一次性解码多个 MIME 头字段

  • ? iconv_get_encoding
  • iconv_mime_decode ?
  • PHP Manual
  • iconv 函数
  • 一次性解码多个 MIME 头字段

iconv_mime_decode_headers

(PHP 5, PHP 7, PHP 8)

iconv_mime_decode_headers — 一次性解码多个 MIME 头字段

说明

iconv_mime_decode_headers ( string $encoded_headers , int $mode = 0 , string $charset = ini_get("iconv.internal_encoding") ) : array

一次性解码多个 MIME 头字段。

参数

encoded_headers

编码过的头，是一个字符串。

mode

mode 决定了 iconv_mime_decode_headers() 遇到畸形 MIME 头字段时的行为。 你可以指定为以下位掩码的任意组合。

iconv_mime_decode_headers() 接受的位掩码
值 | 常量 | 描述
1 | ICONV_MIME_DECODE_STRICT | 如果设置了，给定的头将会以 » RFC2047 定义的标准完全一致。 这个选项默认禁用，因为大量有问题的邮件用户代理不遵循标准并产生不正确的 MIME 头。
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | 如果设置了，iconv_mime_decode_headers() 尝试忽略任何语法错误并继续处理指定的头。

charset

可选参数 charset 指定了字符集结果的表现。 如果省略了，将使用 iconv.internal_encoding。

返回值

成功时返回 encoded_headers 指定的 MIME 头的整套关联数组，解码时出现错误则返回 false。

返回元素的每个键代表独立字段名，相应的元素代表一个字段值。 如果有多个同一名称的字段， iconv_mime_decode_headers() 自动将他们按出现顺序结合成数字索引的数组。

范例

Example #1 iconv_mime_decode_headers() 例子

<?php
$headers_string = <<<EOF
Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=
To: example@example.com
Date: Thu, 1 Jan 1970 00:00:00 +0000
Message-Id: <example@example.com>
Received: from localhost (localhost [127.0.0.1]) by localhost
    with SMTP id example for <example@example.com>;
    Thu, 1 Jan 1970 00:00:00 +0000 (UTC)
    (envelope-from example-return-0000-example=example.com@example.com)
Received: (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000

EOF;

$headers =  iconv_mime_decode_headers($headers_string, 0, "ISO-8859-1");
print_r($headers);
?>

以上例程会输出：

Array
(
    [Subject] => Prüfung Prüfung
    [To] => example@example.com
    [Date] => Thu, 1 Jan 1970 00:00:00 +0000
    [Message-Id] => <example@example.com>
    [Received] => Array
        (
            [0] => from localhost (localhost [127.0.0.1]) by localhost with SMTP id example for <example@example.com>; Thu, 1 Jan 1970 00:00:00 +0000 (UTC) (envelope-from example-return-0000-example=example.com@example.com)
            [1] => (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000
        )

)

参见

  • iconv_mime_decode() - 解码一个MIME头字段
  • mb_decode_mimeheader() - 解码 MIME 头字段中的字符串
  • imap_mime_header_decode() - Decode MIME header elements
  • imap_base64() - Decode BASE64 encoded text
  • imap_qprint() - Convert a quoted-printable string to an 8 bit string


解码一个MIME头字段

  • ? iconv_mime_decode_headers
  • iconv_mime_encode ?
  • PHP Manual
  • iconv 函数
  • 解码一个MIME头字段

iconv_mime_decode

(PHP 5, PHP 7, PHP 8)

iconv_mime_decode — 解码一个MIME头字段

说明

iconv_mime_decode ( string $encoded_header , int $mode = 0 , string $charset = ini_get("iconv.internal_encoding") ) : string

解码一个MIME头字段.

参数

encoded_header

编码头,是一个字符串.

mode

模式决定了当iconv_mime_decode()遇到一个不规则的 MIME头字段时,对这个事件作出的行为.你可以指定以下位掩码的任意组合.

可以在iconv_mime_decode()中使用的位掩码
值 | 常量 | 描述
1 | ICONV_MIME_DECODE_STRICT | 如果使用该位掩码,传入的头字段将会完全一致的按照» RFC2047的标准定义被解码. 这个选项默认是禁用的,因为有很多零散的邮件用户代理商不遵守标准规范并且不生成正确的MIME头.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | 如果使用该位掩码,iconv_mime_decode_headers() 将会试图忽略任何错误语法,并继续处理传入的头字段.

charset

可选的字符集参数,用指定的字符集表示结果.如果省略, iconv.internal_encoding 将会被默认使用.

返回值

如果解码成功,返回一个被解码的MIME字段, 如果在解码过程中出现一个错误,将返回false .

范例

Example #1 iconv_mime_decode()实例

<?php
//返回结果: "Subject: Prüfung Prüfung"
echo iconv_mime_decode("Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=",
                       0, "ISO-8859-1");
?>

参见

  • iconv_mime_decode_headers() - 一次性解码多个 MIME 头字段
  • mb_decode_mimeheader() - 解码 MIME 头字段中的字符串
  • imap_mime_header_decode() - Decode MIME header elements
  • imap_base64() - Decode BASE64 encoded text
  • imap_qprint() - Convert a quoted-printable string to an 8 bit string


Composes a MIME header field

  • ? iconv_mime_decode
  • iconv_set_encoding ?
  • PHP Manual
  • iconv 函数
  • Composes a MIME header field

iconv_mime_encode

(PHP 5, PHP 7, PHP 8)

iconv_mime_encode — Composes a MIME header field

说明

iconv_mime_encode ( string $field_name , string $field_value , array $options = [] ) : string|false

Composes and returns a string that represents a valid MIME header field, which looks like the following:

Subject: =?ISO-8859-1?Q?Pr=FCfung_f=FCr?= Entwerfen von einer MIME kopfzeile
In the above example, "Subject" is the field name and the portion that begins with "=?ISO-8859-1?..." is the field value.

参数

field_name

The field name.

field_value

The field value.

options

You can control the behaviour of iconv_mime_encode() by specifying an associative array that contains configuration items to the optional third parameter options. The items supported by iconv_mime_encode() are listed below. Note that item names are treated case-sensitive.

Configuration items supported by iconv_mime_encode()
Item | Type | Description | Default value | Example
scheme | string | Specifies the method to encode a field value by. The value of this item may be either "B" or "Q", where "B" stands for base64 encoding scheme and "Q" stands for quoted-printable encoding scheme. | B | B
input-charset | string | Specifies the character set in which the first parameter field_name and the second parameter field_value are presented. If not given, iconv_mime_encode() assumes those parameters are presented to it in the iconv.internal_encoding ini setting. | iconv.internal_encoding | ISO-8859-1
output-charset | string | Specifies the character set to use to compose the MIME header. | iconv.internal_encoding | UTF-8
line-length | int | Specifies the maximum length of the header lines. The resulting header is "folded" to a set of multiple lines in case the resulting header field would be longer than the value of this parameter, according to » RFC2822 - Internet Message Format. If not given, the length will be limited to 76 characters. | 76 | 996
line-break-chars | string | Specifies the sequence of characters to append to each line as an end-of-line sign when "folding" is performed on a long header field. If not given, this defaults to "\r\n" (CR LF). Note that this parameter is always treated as an ASCII string regardless of the value of input-charset. | \r\n | \n

返回值

Returns an encoded MIME field on success, or false if an error occurs during the encoding.

范例

Example #1 iconv_mime_encode() example

<?php
$preferences = array(
    "input-charset" => "ISO-8859-1",
    "output-charset" => "UTF-8",
    "line-length" => 76,
    "line-break-chars" => "\n"
);
$preferences["scheme"] = "Q";
// This yields "Subject: =?UTF-8?Q?Pr=C3=BCfung=20Pr=C3=BCfung?="
echo iconv_mime_encode("Subject", "Prüfung Prüfung", $preferences);

$preferences["scheme"] = "B";
// This yields "Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?="
echo iconv_mime_encode("Subject", "Prüfung Prüfung", $preferences);
?>

参见

  • imap_binary() - Convert an 8bit string to a base64 string
  • mb_encode_mimeheader() - 为 MIME 头编码字符串
  • imap_8bit() - Convert an 8bit string to a quoted-printable string
  • quoted_printable_encode() - 将 8-bit 字符串转换成 quoted-printable 字符串


为字符编码转换设定当前设置

  • ? iconv_mime_encode
  • iconv_strlen ?
  • PHP Manual
  • iconv 函数
  • 为字符编码转换设定当前设置

iconv_set_encoding

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

iconv_set_encoding — 为字符编码转换设定当前设置

说明

iconv_set_encoding ( string $type , string $charset ) : bool

将 type 设置的值从内部配置变量更改为 charset。

参数

type

type 的值可以是以下其中任意一个：

  • input_encoding
  • output_encoding
  • internal_encoding

charset

字符集。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 iconv_set_encoding() 例子

<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
?>

参见

  • iconv_get_encoding() - 获取 iconv 扩展的内部配置变量
  • ob_iconv_handler() - 以输出缓冲处理程序转换字符编码


返回字符串的字符数统计

  • ? iconv_set_encoding
  • iconv_strpos ?
  • PHP Manual
  • iconv 函数
  • 返回字符串的字符数统计

iconv_strlen

(PHP 5, PHP 7, PHP 8)

iconv_strlen — 返回字符串的字符数统计

说明

iconv_strlen ( string $str , string $charset = ini_get("iconv.internal_encoding") ) : int

和 strlen() 不同的是，iconv_strlen() 统计了给定的字节序列 str 中出现字符数的统计，基于指定的字符集，其产生的结果不一定和字符字节数相等。

参数

str

该字符串。

charset

如果省略了 charset 参数，假设 str 的编码为 iconv.internal_encoding。

返回值

返回 str 字符数的统计，是整型。

参见

  • grapheme_strlen() - Get string length in grapheme units
  • mb_strlen() - 获取字符串的长度
  • strlen() - 获取字符串长度


Finds position of first occurrence of a needle within a haystack

  • ? iconv_strlen
  • iconv_strrpos ?
  • PHP Manual
  • iconv 函数
  • Finds position of first occurrence of a needle within a haystack

iconv_strpos

(PHP 5, PHP 7, PHP 8)

iconv_strpos — Finds position of first occurrence of a needle within a haystack

说明

iconv_strpos ( string $haystack , string $needle , int $offset = 0 , string|null $encoding = null ) : int|false

Finds position of first occurrence of a needle within a haystack.

In contrast to strpos(), the return value of iconv_strpos() is the number of characters that appear before the needle, rather than the offset in bytes to the position where the needle has been found. The characters are counted on the basis of the specified character set encoding.

参数

haystack

The entire string.

needle

The searched substring.

offset

The optional offset parameter specifies the position from which the search should be performed. If the offset is negative, it is counted from the end of the string.

encoding

If encoding parameter is omitted or null, string are assumed to be encoded in iconv.internal_encoding.

If haystack or needle is not a string, it is converted to a string and applied as the ordinal value of a character.

返回值

Returns the numeric position of the first occurrence of needle in haystack.

If needle is not found, iconv_strpos() will return false.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
8.0.0 | encoding is nullable now.
7.1.0 | Support for negative offsets has been added.

参见

  • strpos() - 查找字符串首次出现的位置
  • iconv_strrpos() - Finds the last occurrence of a needle within a haystack
  • mb_strpos() - 查找字符串在另一个字符串中首次出现的位置


Finds the last occurrence of a needle within a haystack

  • ? iconv_strpos
  • iconv_substr ?
  • PHP Manual
  • iconv 函数
  • Finds the last occurrence of a needle within a haystack

iconv_strrpos

(PHP 5, PHP 7, PHP 8)

iconv_strrpos — Finds the last occurrence of a needle within a haystack

说明

iconv_strrpos ( string $haystack , string $needle , string|null $encoding = null ) : int|false

Finds the last occurrence of a needle within a haystack.

In contrast to strrpos(), the return value of iconv_strrpos() is the number of characters that appear before the needle, rather than the offset in bytes to the position where the needle has been found. The characters are counted on the basis of the specified character set encoding.

参数

haystack

The entire string.

needle

The searched substring.

encoding

If encoding parameter is omitted or null, string are assumed to be encoded in iconv.internal_encoding.

If haystack or needle is not a string, it is converted to a string and applied as the ordinal value of a character.

返回值

Returns the numeric position of the last occurrence of needle in haystack.

If needle is not found, iconv_strrpos() will return false.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
8.0.0 | encoding is nullable now.

参见

  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置
  • iconv_strpos() - Finds position of first occurrence of a needle within a haystack
  • mb_strrpos() - 查找字符串在一个字符串中最后出现的位置


截取字符串的部分

  • ? iconv_strrpos
  • iconv ?
  • PHP Manual
  • iconv 函数
  • 截取字符串的部分

iconv_substr

(PHP 5, PHP 7, PHP 8)

iconv_substr — 截取字符串的部分

说明

iconv_substr ( string $str , int $offset , int $length = iconv_strlen($str, $charset) , string $charset = ini_get("iconv.internal_encoding") ) : string

根据 offset 和 length 参数指定 str 截取的部分。

参数

str

原始字符串。

offset

如果 offset 是非负数，iconv_substr() 从 str 开头第 offset 个字符开始截出部分，从 0 开始计数。

如果 offset 是负数，iconv_substr() 从 str 末尾向前 offset 个字符开始截取。

length

如果指定了 length 并且是正数，返回的值从 offset 截取部分，最多包含 length 个字符（取决于 string 的长度）。

如果传入了负数的 length， iconv_substr() 将从第 offset 个字符到离末尾 length 个字符截出 str 的部分。 如果 offset 也是负数，则开始位置计算规则的解释见以上。

charset

如果省略了参数 charset，string 的编码被认定为 iconv.internal_encoding。

注意，offset 和 length 参数总是被认为字符表现的偏移，基于 charset 检测到的字符集进行统计计算，而相对应的 substr() 则是基于字节的位移来计算。

返回值

返回 offset 和 length 参数指定的 str 的部分。

如果 str 比 offset 字符数更短，将会返回 false。 如果 str 是 offset 个字符的长度，将返回空字符串。

更新日志

版本 | 说明
7.0.11 | 如果 str 等长于 offset 个字符， 将返回空字符串。之前的版本里，这种情况是会返回 false 的。

参见

  • substr() - 返回字符串的子串
  • mb_substr() - 获取部分字符串
  • mb_strcut() - 获取字符的一部分


字符串按要求的字符编码来转换

  • ? iconv_substr
  • ob_iconv_handler ?
  • PHP Manual
  • iconv 函数
  • 字符串按要求的字符编码来转换

iconv

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

iconv — 字符串按要求的字符编码来转换

说明

iconv ( string $in_charset , string $out_charset , string $str ) : string

将字符串 str 从 in_charset 转换编码到 out_charset。

参数

in_charset

输入的字符集。

out_charset

输出的字符集。

如果你在 out_charset 后添加了字符串 //TRANSLIT，将启用转写（transliteration）功能。这个意思是，当一个字符不能被目标字符集所表示时，它可以通过一个或多个形似的字符来近似表达。 如果你添加了字符串 //IGNORE，不能以目标字符集表达的字符将被默默丢弃。 否则，会导致一个 E_NOTICE并返回 false。

Caution

//TRANSLIT 运行细节高度依赖于系统的 iconv() 实现（参见 ICONV_IMPL）。 据悉，某些系统上的实现会直接忽略 //TRANSLIT，所以转换也有可能失败，out_charset 会是不合格的。

str

要转换的字符串。

返回值

返回转换后的字符串， 或者在失败时返回 false。

更新日志

版本 | 说明
5.4.0 | 这个版本起，字符非法时候会返回 false，除非在输出字符里指定了 //IGNORE 。 在之前版本，它会返回一部分字符串。

范例

Example #1 iconv() 例子

<?php
$text = "This is the Euro symbol '�'.";

echo 'Original : ', $text, PHP_EOL;
echo 'TRANSLIT : ', iconv("UTF-8", "ISO-8859-1//TRANSLIT", $text), PHP_EOL;
echo 'IGNORE   : ', iconv("UTF-8", "ISO-8859-1//IGNORE", $text), PHP_EOL;
echo 'Plain    : ', iconv("UTF-8", "ISO-8859-1", $text), PHP_EOL;

?>

以上例程的输出类似于：

Original : This is the Euro symbol '�'.
TRANSLIT : This is the Euro symbol 'EUR'.
IGNORE   : This is the Euro symbol ''.
Plain    :
Notice: iconv(): Detected an illegal character in input string in .\iconv-example.php on line 7


以输出缓冲处理程序转换字符编码

  • ? iconv
  • intl ?
  • PHP Manual
  • iconv 函数
  • 以输出缓冲处理程序转换字符编码

ob_iconv_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ob_iconv_handler — 以输出缓冲处理程序转换字符编码

说明

ob_iconv_handler ( string $contents , int $status ) : string

将字符编码从 internal_encoding 转换到 output_encoding。

internal_encoding 和 output_encoding 应当在 php.ini 文件或 iconv_set_encoding() 中定义。

参数

关于处理程序参数的信息，参见 ob_start()。

返回值

关于处理程序返回值的信息，参见 ob_start()。

范例

Example #1 ob_iconv_handler() 例子：

<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
ob_start("ob_iconv_handler"); // 开始输出缓冲
?>

参见

  • iconv_get_encoding() - 获取 iconv 扩展的内部配置变量
  • iconv_set_encoding() - 为字符编码转换设定当前设置
  • 输出控制函数


Internationalization Functions

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic usage of this extension
  • Collator — The Collator class
    • Collator::asort — Sort array maintaining index association
    • Collator::compare — Compare two Unicode strings
    • Collator::__construct — Create a collator
    • Collator::create — Create a collator
    • Collator::getAttribute — Get collation attribute value
    • Collator::getErrorCode — Get collator's last error code
    • Collator::getErrorMessage — Get text for collator's last error code
    • Collator::getLocale — Get the locale name of the collator
    • Collator::getSortKey — Get sorting key for a string
    • Collator::getStrength — Get current collation strength
    • Collator::setAttribute — Set collation attribute
    • Collator::setStrength — Set collation strength
    • Collator::sortWithSortKeys — Sort array using specified collator and sort keys
    • Collator::sort — Sort array using specified collator
  • NumberFormatter — The NumberFormatter class
    • NumberFormatter::create — Create a number formatter
    • NumberFormatter::formatCurrency — Format a currency value
    • NumberFormatter::format — Format a number
    • NumberFormatter::getAttribute — Get an attribute
    • NumberFormatter::getErrorCode — Get formatter's last error code
    • NumberFormatter::getErrorMessage — Get formatter's last error message
    • NumberFormatter::getLocale — Get formatter locale
    • NumberFormatter::getPattern — Get formatter pattern
    • NumberFormatter::getSymbol — Get a symbol value
    • NumberFormatter::getTextAttribute — Get a text attribute
    • NumberFormatter::parseCurrency — Parse a currency number
    • NumberFormatter::parse — Parse a number
    • NumberFormatter::setAttribute — Set an attribute
    • NumberFormatter::setPattern — Set formatter pattern
    • NumberFormatter::setSymbol — Set a symbol value
    • NumberFormatter::setTextAttribute — Set a text attribute
  • Locale — The Locale class
    • Locale::acceptFromHttp — Tries to find out best available locale based on HTTP "Accept-Language" header
    • Locale::canonicalize — Canonicalize the locale string
    • Locale::composeLocale — Returns a correctly ordered and delimited locale ID
    • Locale::filterMatches — Checks if a language tag filter matches with locale
    • Locale::getAllVariants — Gets the variants for the input locale
    • Locale::getDefault — Gets the default locale value from the INTL global 'default_locale'
    • Locale::getDisplayLanguage — Returns an appropriately localized display name for language of the inputlocale
    • Locale::getDisplayName — Returns an appropriately localized display name for the input locale
    • Locale::getDisplayRegion — Returns an appropriately localized display name for region of the input locale
    • Locale::getDisplayScript — Returns an appropriately localized display name for script of the input locale
    • Locale::getDisplayVariant — Returns an appropriately localized display name for variants of the input locale
    • Locale::getKeywords — Gets the keywords for the input locale
    • Locale::getPrimaryLanguage — Gets the primary language for the input locale
    • Locale::getRegion — Gets the region for the input locale
    • Locale::getScript — Gets the script for the input locale
    • Locale::lookup — Searches the language tag list for the best match to the language
    • Locale::parseLocale — Returns a key-value array of locale ID subtag elements
    • Locale::setDefault — Sets the default runtime locale
  • Normalizer — The Normalizer class
    • Normalizer::getRawDecomposition — Gets the Decomposition_Mapping property for the given UTF-8 encoded code point
    • Normalizer::isNormalized — Checks if the provided string is already in the specified normalization form
    • Normalizer::normalize — Normalizes the input provided and returns the normalized string
  • MessageFormatter — The MessageFormatter class
    • MessageFormatter::create — Constructs a new Message Formatter
    • MessageFormatter::formatMessage — Quick format message
    • MessageFormatter::format — Format the message
    • MessageFormatter::getErrorCode — Get the error code from last operation
    • MessageFormatter::getErrorMessage — Get the error text from the last operation
    • MessageFormatter::getLocale — Get the locale for which the formatter was created
    • MessageFormatter::getPattern — Get the pattern used by the formatter
    • MessageFormatter::parseMessage — Quick parse input string
    • MessageFormatter::parse — Parse input string according to pattern
    • MessageFormatter::setPattern — Set the pattern used by the formatter
  • IntlCalendar — The IntlCalendar class
    • IntlCalendar::add — Add a (signed) amount of time to a field
    • IntlCalendar::after — Whether this object?s time is after that of the passed object
    • IntlCalendar::before — Whether this object?s time is before that of the passed object
    • IntlCalendar::clear — Clear a field or all fields
    • IntlCalendar::__construct — Private constructor for disallowing instantiation
    • IntlCalendar::createInstance — Create a new IntlCalendar
    • IntlCalendar::equals — Compare time of two IntlCalendar objects for equality
    • IntlCalendar::fieldDifference — Calculate difference between given time and this object?s time
    • IntlCalendar::fromDateTime — Create an IntlCalendar from a DateTime object or string
    • IntlCalendar::get — Get the value for a field
    • IntlCalendar::getActualMaximum — The maximum value for a field, considering the object?s current time
    • IntlCalendar::getActualMinimum — The minimum value for a field, considering the object?s current time
    • IntlCalendar::getAvailableLocales — Get array of locales for which there is data
    • IntlCalendar::getDayOfWeekType — Tell whether a day is a weekday, weekend or a day that has a transition between the two
    • IntlCalendar::getErrorCode — Get last error code on the object
    • IntlCalendar::getErrorMessage — Get last error message on the object
    • IntlCalendar::getFirstDayOfWeek — Get the first day of the week for the calendar?s locale
    • IntlCalendar::getGreatestMinimum — Get the largest local minimum value for a field
    • IntlCalendar::getKeywordValuesForLocale — Get set of locale keyword values
    • IntlCalendar::getLeastMaximum — Get the smallest local maximum for a field
    • IntlCalendar::getLocale — Get the locale associated with the object
    • IntlCalendar::getMaximum — Get the global maximum value for a field
    • IntlCalendar::getMinimalDaysInFirstWeek — Get minimal number of days the first week in a year or month can have
    • IntlCalendar::getMinimum — Get the global minimum value for a field
    • IntlCalendar::getNow — Get number representing the current time
    • IntlCalendar::getRepeatedWallTimeOption — Get behavior for handling repeating wall time
    • IntlCalendar::getSkippedWallTimeOption — Get behavior for handling skipped wall time
    • IntlCalendar::getTime — Get time currently represented by the object
    • IntlCalendar::getTimeZone — Get the object?s timezone
    • IntlCalendar::getType — Get the calendar type
    • IntlCalendar::getWeekendTransition — Get time of the day at which weekend begins or ends
    • IntlCalendar::inDaylightTime — Whether the object?s time is in Daylight Savings Time
    • IntlCalendar::isEquivalentTo — Whether another calendar is equal but for a different time
    • IntlCalendar::isLenient — Whether date/time interpretation is in lenient mode
    • IntlCalendar::isSet — Whether a field is set
    • IntlCalendar::isWeekend — Whether a certain date/time is in the weekend
    • IntlCalendar::roll — Add value to field without carrying into more significant fields
    • IntlCalendar::set — Set a time field or several common fields at once
    • IntlCalendar::setFirstDayOfWeek — Set the day on which the week is deemed to start
    • IntlCalendar::setLenient — Set whether date/time interpretation is to be lenient
    • IntlCalendar::setMinimalDaysInFirstWeek — Set minimal number of days the first week in a year or month can have
    • IntlCalendar::setRepeatedWallTimeOption — Set behavior for handling repeating wall times at negative timezone offset transitions
    • IntlCalendar::setSkippedWallTimeOption — Set behavior for handling skipped wall times at positive timezone offset transitions
    • IntlCalendar::setTime — Set the calendar time in milliseconds since the epoch
    • IntlCalendar::setTimeZone — Set the timezone used by this calendar
    • IntlCalendar::toDateTime — Convert an IntlCalendar into a DateTime object
  • IntlGregorianCalendar — The IntlGregorianCalendar class
    • IntlGregorianCalendar::__construct — Create the Gregorian Calendar class
    • IntlGregorianCalendar::getGregorianChange — Get the Gregorian Calendar change date
    • IntlGregorianCalendar::isLeapYear — Determine if the given year is a leap year
    • IntlGregorianCalendar::setGregorianChange — Set the Gregorian Calendar the change date
  • IntlTimeZone — The IntlTimeZone class
    • IntlTimeZone::countEquivalentIDs — Get the number of IDs in the equivalency group that includes the given ID
    • IntlTimeZone::createDefault — Create a new copy of the default timezone for this host
    • IntlTimeZone::createEnumeration — Get an enumeration over time zone IDs associated with the given country or offset
    • IntlTimeZone::createTimeZone — Create a timezone object for the given ID
    • IntlTimeZone::createTimeZoneIDEnumeration — Get an enumeration over system time zone IDs with the given filter conditions
    • IntlTimeZone::fromDateTimeZone — Create a timezone object from DateTimeZone
    • IntlTimeZone::getCanonicalID — Get the canonical system timezone ID or the normalized custom time zone ID for the given time zone ID
    • IntlTimeZone::getDisplayName — Get a name of this time zone suitable for presentation to the user
    • IntlTimeZone::getDSTSavings — Get the amount of time to be added to local standard time to get local wall clock time
    • IntlTimeZone::getEquivalentID — Get an ID in the equivalency group that includes the given ID
    • IntlTimeZone::getErrorCode — Get last error code on the object
    • IntlTimeZone::getErrorMessage — Get last error message on the object
    • IntlTimeZone::getGMT — Create GMT (UTC) timezone
    • IntlTimeZone::getID — Get timezone ID
    • IntlTimeZone::getIDForWindowsID — Translate a Windows timezone into a system timezone
    • IntlTimeZone::getOffset — Get the time zone raw and GMT offset for the given moment in time
    • IntlTimeZone::getRawOffset — Get the raw GMT offset (before taking daylight savings time into account
    • IntlTimeZone::getRegion — Get the region code associated with the given system time zone ID
    • IntlTimeZone::getTZDataVersion — Get the timezone data version currently used by ICU
    • IntlTimeZone::getUnknown — Get the "unknown" time zone
    • IntlTimeZone::getWindowsID — Translate a system timezone into a Windows timezone
    • IntlTimeZone::hasSameRules — Check if this zone has the same rules and offset as another zone
    • IntlTimeZone::toDateTimeZone — Convert to DateTimeZone object
    • IntlTimeZone::useDaylightTime — Check if this time zone uses daylight savings time
  • IntlDateFormatter — The IntlDateFormatter class
    • IntlDateFormatter::create — Create a date formatter
    • IntlDateFormatter::format — Format the date/time value as a string
    • IntlDateFormatter::formatObject — Formats an object
    • IntlDateFormatter::getCalendar — Get the calendar type used for the IntlDateFormatter
    • IntlDateFormatter::getDateType — Get the datetype used for the IntlDateFormatter
    • IntlDateFormatter::getErrorCode — Get the error code from last operation
    • IntlDateFormatter::getErrorMessage — Get the error text from the last operation
    • IntlDateFormatter::getLocale — Get the locale used by formatter
    • IntlDateFormatter::getPattern — Get the pattern used for the IntlDateFormatter
    • IntlDateFormatter::getTimeType — Get the timetype used for the IntlDateFormatter
    • IntlDateFormatter::getTimeZoneId — Get the timezone-id used for the IntlDateFormatter
    • IntlDateFormatter::getCalendarObject — Get copy of formatter?s calendar object
    • IntlDateFormatter::getTimeZone — Get formatter?s timezone
    • IntlDateFormatter::isLenient — Get the lenient used for the IntlDateFormatter
    • IntlDateFormatter::localtime — Parse string to a field-based time value
    • IntlDateFormatter::parse — Parse string to a timestamp value
    • IntlDateFormatter::setCalendar — Sets the calendar type used by the formatter
    • IntlDateFormatter::setLenient — Set the leniency of the parser
    • IntlDateFormatter::setPattern — Set the pattern used for the IntlDateFormatter
    • IntlDateFormatter::setTimeZone — Sets formatter?s timezone
  • ResourceBundle — The ResourceBundle class
    • ResourceBundle::count — Get number of elements in the bundle
    • ResourceBundle::create — Create a resource bundle
    • ResourceBundle::getErrorCode — Get bundle's last error code
    • ResourceBundle::getErrorMessage — Get bundle's last error message
    • ResourceBundle::get — Get data from the bundle
    • ResourceBundle::getLocales — Get supported locales
  • Spoofchecker — The Spoofchecker class
    • Spoofchecker::areConfusable — Checks if given strings can be confused
    • Spoofchecker::__construct — Constructor
    • Spoofchecker::isSuspicious — Checks if a given text contains any suspicious characters
    • Spoofchecker::setAllowedLocales — Locales to use when running checks
    • Spoofchecker::setChecks — Set the checks to run
  • Transliterator — The Transliterator class
    • Transliterator::__construct — Private constructor to deny instantiation
    • Transliterator::create — Create a transliterator
    • Transliterator::createFromRules — Create transliterator from rules
    • Transliterator::createInverse — Create an inverse transliterator
    • Transliterator::getErrorCode — Get last error code
    • Transliterator::getErrorMessage — Get last error message
    • Transliterator::listIDs — Get transliterator IDs
    • Transliterator::transliterate — Transliterate a string
  • IntlBreakIterator — The IntlBreakIterator class
    • IntlBreakIterator::__construct — Private constructor for disallowing instantiation
    • IntlBreakIterator::createCharacterInstance — Create break iterator for boundaries of combining character sequences
    • IntlBreakIterator::createCodePointInstance — Create break iterator for boundaries of code points
    • IntlBreakIterator::createLineInstance — Create break iterator for logically possible line breaks
    • IntlBreakIterator::createSentenceInstance — Create break iterator for sentence breaks
    • IntlBreakIterator::createTitleInstance — Create break iterator for title-casing breaks
    • IntlBreakIterator::createWordInstance — Create break iterator for word breaks
    • IntlBreakIterator::current — Get index of current position
    • IntlBreakIterator::first — Set position to the first character in the text
    • IntlBreakIterator::following — Advance the iterator to the first boundary following specified offset
    • IntlBreakIterator::getErrorCode — Get last error code on the object
    • IntlBreakIterator::getErrorMessage — Get last error message on the object
    • IntlBreakIterator::getLocale — Get the locale associated with the object
    • IntlBreakIterator::getPartsIterator — Create iterator for navigating fragments between boundaries
    • IntlBreakIterator::getText — Get the text being scanned
    • IntlBreakIterator::isBoundary — Tell whether an offset is a boundary?s offset
    • IntlBreakIterator::last — Set the iterator position to index beyond the last character
    • IntlBreakIterator::next — Advance the iterator the next boundary
    • IntlBreakIterator::preceding — Set the iterator position to the first boundary before an offset
    • IntlBreakIterator::previous — Set the iterator position to the boundary immediately before the current
    • IntlBreakIterator::setText — Set the text being scanned
  • IntlRuleBasedBreakIterator — The IntlRuleBasedBreakIterator class
    • IntlRuleBasedBreakIterator::__construct — Create iterator from ruleset
    • IntlRuleBasedBreakIterator::getBinaryRules — Get the binary form of compiled rules
    • IntlRuleBasedBreakIterator::getRules — Get the rule set used to create this object
    • IntlRuleBasedBreakIterator::getRuleStatus — Get the largest status value from the break rules that determined the current break position
    • IntlRuleBasedBreakIterator::getRuleStatusVec — Get the status values from the break rules that determined the current break position
  • IntlCodePointBreakIterator — The IntlCodePointBreakIterator class
    • IntlCodePointBreakIterator::getLastCodePoint — Get last code point passed over after advancing or receding the iterator
  • IntlPartsIterator — The IntlPartsIterator class
    • IntlPartsIterator::getBreakIterator — Get IntlBreakIterator backing this parts iterator
  • UConverter — The UConverter class
    • UConverter::__construct — Create UConverter object
    • UConverter::convert — Convert string from one charset to another
    • UConverter::fromUCallback — Default "from" callback function
    • UConverter::getAliases — Get the aliases of the given name
    • UConverter::getAvailable — Get the available canonical converter names
    • UConverter::getDestinationEncoding — Get the destination encoding
    • UConverter::getDestinationType — Get the destination converter type
    • UConverter::getErrorCode — Get last error code on the object
    • UConverter::getErrorMessage — Get last error message on the object
    • UConverter::getSourceEncoding — Get the source encoding
    • UConverter::getSourceType — Get the source converter type
    • UConverter::getStandards — Get standards associated to converter names
    • UConverter::getSubstChars — Get substitution chars
    • UConverter::reasonText — Get string representation of the callback reason
    • UConverter::setDestinationEncoding — Set the destination encoding
    • UConverter::setSourceEncoding — Set the source encoding
    • UConverter::setSubstChars — Set the substitution chars
    • UConverter::toUCallback — Default "to" callback function
    • UConverter::transcode — Convert string from one charset to another
  • Grapheme 函数
    • grapheme_extract — Function to extract a sequence of default grapheme clusters from a text buffer, which must be encoded in UTF-8
    • grapheme_stripos — Find position (in grapheme units) of first occurrence of a case-insensitive string
    • grapheme_stristr — Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
    • grapheme_strlen — Get string length in grapheme units
    • grapheme_strpos — Find position (in grapheme units) of first occurrence of a string
    • grapheme_strripos — Find position (in grapheme units) of last occurrence of a case-insensitive string
    • grapheme_strrpos — Find position (in grapheme units) of last occurrence of a string
    • grapheme_strstr — Returns part of haystack string from the first occurrence of needle to the end of haystack
    • grapheme_substr — Return part of a string
  • IDN 函数
    • idn_to_ascii — 将域名转换为 IDNA ASCII 格式
    • idn_to_utf8 — 将域名从 IDNA ASCII 转换为 Unicode
  • IntlChar
    • IntlChar::charAge — Get the "age" of the code point
    • IntlChar::charDigitValue — Get the decimal digit value of a decimal digit character
    • IntlChar::charDirection — Get bidirectional category value for a code point
    • IntlChar::charFromName — Find Unicode character by name and return its code point value
    • IntlChar::charMirror — Get the "mirror-image" character for a code point
    • IntlChar::charName — Retrieve the name of a Unicode character
    • IntlChar::charType — Get the general category value for a code point
    • IntlChar::chr — Return Unicode character by code point value
    • IntlChar::digit — Get the decimal digit value of a code point for a given radix
    • IntlChar::enumCharNames — Enumerate all assigned Unicode characters within a range
    • IntlChar::enumCharTypes — Enumerate all code points with their Unicode general categories
    • IntlChar::foldCase — Perform case folding on a code point
    • IntlChar::forDigit — Get character representation for a given digit and radix
    • IntlChar::getBidiPairedBracket — Get the paired bracket character for a code point
    • IntlChar::getBlockCode — Get the Unicode allocation block containing a code point
    • IntlChar::getCombiningClass — Get the combining class of a code point
    • IntlChar::getFC_NFKC_Closure — Get the FC_NFKC_Closure property for a code point
    • IntlChar::getIntPropertyMaxValue — Get the max value for a Unicode property
    • IntlChar::getIntPropertyMinValue — Get the min value for a Unicode property
    • IntlChar::getIntPropertyValue — Get the value for a Unicode property for a code point
    • IntlChar::getNumericValue — Get the numeric value for a Unicode code point
    • IntlChar::getPropertyEnum — Get the property constant value for a given property name
    • IntlChar::getPropertyName — Get the Unicode name for a property
    • IntlChar::getPropertyValueEnum — Get the property value for a given value name
    • IntlChar::getPropertyValueName — Get the Unicode name for a property value
    • IntlChar::getUnicodeVersion — Get the Unicode version
    • IntlChar::hasBinaryProperty — Check a binary Unicode property for a code point
    • IntlChar::isalnum — Check if code point is an alphanumeric character
    • IntlChar::isalpha — Check if code point is a letter character
    • IntlChar::isbase — Check if code point is a base character
    • IntlChar::isblank — Check if code point is a "blank" or "horizontal space" character
    • IntlChar::iscntrl — Check if code point is a control character
    • IntlChar::isdefined — Check whether the code point is defined
    • IntlChar::isdigit — Check if code point is a digit character
    • IntlChar::isgraph — Check if code point is a graphic character
    • IntlChar::isIDIgnorable — Check if code point is an ignorable character
    • IntlChar::isIDPart — Check if code point is permissible in an identifier
    • IntlChar::isIDStart — Check if code point is permissible as the first character in an identifier
    • IntlChar::isISOControl — Check if code point is an ISO control code
    • IntlChar::isJavaIDPart — Check if code point is permissible in a Java identifier
    • IntlChar::isJavaIDStart — Check if code point is permissible as the first character in a Java identifier
    • IntlChar::isJavaSpaceChar — Check if code point is a space character according to Java
    • IntlChar::islower — Check if code point is a lowercase letter
    • IntlChar::isMirrored — Check if code point has the Bidi_Mirrored property
    • IntlChar::isprint — Check if code point is a printable character
    • IntlChar::ispunct — Check if code point is punctuation character
    • IntlChar::isspace — Check if code point is a space character
    • IntlChar::istitle — Check if code point is a titlecase letter
    • IntlChar::isUAlphabetic — Check if code point has the Alphabetic Unicode property
    • IntlChar::isULowercase — Check if code point has the Lowercase Unicode property
    • IntlChar::isupper — Check if code point has the general category "Lu" (uppercase letter)
    • IntlChar::isUUppercase — Check if code point has the Uppercase Unicode property
    • IntlChar::isUWhiteSpace — Check if code point has the White_Space Unicode property
    • IntlChar::isWhitespace — Check if code point is a whitespace character according to ICU
    • IntlChar::isxdigit — Check if code point is a hexadecimal digit
    • IntlChar::ord — Return Unicode code point value of character
    • IntlChar::tolower — Make Unicode character lowercase
    • IntlChar::totitle — Make Unicode character titlecase
    • IntlChar::toupper — Make Unicode character uppercase
  • IntlException — Exception class for intl errors
  • IntlIterator — The IntlIterator class
    • IntlIterator::current — Get the current element
    • IntlIterator::key — Get the current key
    • IntlIterator::next — Move forward to the next element
    • IntlIterator::rewind — Rewind the iterator to the first element
    • IntlIterator::valid — Check if current position is valid
  • intl 函数
    • intl_error_name — Get symbolic name for a given error code
    • intl_get_error_code — Get the last error code
    • intl_get_error_message — Get description of the last error
    • intl_is_failure — Check whether the given error code indicates failure


简介

Internationalization extension (further is referred as Intl) is a wrapper for » ICU library, enabling PHP programmers to perform various locale-aware operations including but not limited to formatting, transliteration, encoding conversion, calendar operations, » UCA-conformant collation, locating text boundaries and working with locale identifiers, timezones and graphemes,

It tends to closely follow ICU APIs, so that people having experience working with ICU in either C/C++ or Java could easily use the PHP API. Also, this way ICU documentation would be useful to understand various ICU functions.

Intl consists of several modules, each of them exposes the corresponding ICU API:

  • Collator: provides string comparison capability with support for appropriate locale-sensitive sort orderings.
  • Number Formatter: allows to display number according to the localized format or given pattern or set of rules, and to parse strings into numbers.
  • Message Formatter: allows to create messages incorporating data (such as numbers or dates) formatted according to given pattern and locale rules, and parse messages extracting data from them. It can handle plurals, locale-aware numbers, currencies, conditions and much more.
  • Normalizer: provides a function to transform text into one of the Unicode normalization forms, and provides a routine to test if a given string is already normalized.
  • Locale: provides interaction with locale identifiers in the form of functions to get subtags from locale identifier; parse, compose, match(lookup and filter) locale identifiers.
  • Calendar: provides a class which could be used for locale-aware calendar operations and getting various information such as timezone for locale chosen, first day of week or if it's daylight saving time now.
  • Timezone: provides a wrapper around the » "Olson" database which has information about all the timezones around the world.
  • Date formatter: allows to display date and time according to the localized format or given pattern or set of rules, and to parse strings into date and time.
  • Transliterator: allows getting latin representation of strings in various languages.

Links

  • » Miscellaneous ICU docs

  • » ICU User Guide

  • » Unicode Collation Algorithm


需求

To build the extension you need to install the » ICU library, version 4.0.0 or newer is required. As of PHP 7.4.0 ICU 50.1 or newer is required.

This extension is bundled with PHP as of PHP version 5.3.0. Alternatively, the PECL version of this extension may be used with all PHP versions greater than 5.2.0 (5.2.4+ recommended).


安装

This extension may be installed using the bundled version as of PHP 5.3.0, or as a PECL extension as of PHP 5.2.0. In other words, there are two methods to install the intl extension.

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/intl.

Alternatively, --enable-intl will enable the bundled version while compiling PHP.

If your ICU is installed to a non-standard directory then you might want to specify its location in LD_LIBRARY_PATH environment variable so that dynamic linker can find it:

$ export LD_LIBRARY_PATH=/opt/icu/lib

Otherwise, if PHP and ICU are installed to their default locations, then the additional options to `configure' are not needed.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Intl 配置选项
名字 | 默认 | 可修改范围 | 更新日志
intl.default_locale |  | PHP_INI_ALL |
intl.error_level | 0 | PHP_INI_ALL |
intl.use_exceptions | 0 | PHP_INI_ALL | Available since PHP 5.5 and PECL 3.0.0a1

这是配置指令的简短说明。

intl.default_locale string

The locale that will be used in intl functions when none is specified (either by omitting the corresponding argument or by passing NULL). These are ICU locales, not system locales. The built-in ICU locales and their data can be explored at » http://demo.icu-project.org/icu-bin/locexp.

The default value is empty, which forces the usage of ICU's default locale. Once set, the ini setting cannot be reset to this default value. It is not recommended that this default be relied on, as its effective value depends on the server's environment.

intl.error_level int

The level of the error messages generated when an error occurs in ICU functions. This is a PHP error level, such as E_WARNING. It can be set to 0 in order to inhibit the messages. This does not affect the return values indicating error or the values returned by intl_get_error_code() or by the class specific methods for retrieving error codes and messages. Choosing E_ERROR will terminate the script whenever an error condition is found on intl classes.

The default value is 0.

intl.use_exceptions int

If set to true, an exception will be raised whenever an error occurs in an intl function. The exception will be of type IntlException. This is possibly in addition to the error message generated due to intl.error_level.

The default value is false.


预定义常量

INTL_ICU_VERSION (string)
The current ICU library version as a dotted-decimal string.
INTL_MAX_LOCALE_LEN (int)
Limit on locale length, set to 80 in PHP code. Locale names longer than this limit will not be accepted.
IDNA_DEFAULT (int)
Prohibit processing of unassigned codepoints in the input for IDN functions and do not check if the input conforms to domain name ASCII rules.
IDNA_ALLOW_UNASSIGNED (int)
Allow processing of unassigned codepoints in the input for IDN functions.
IDNA_USE_STD3_RULES (int)
Check if the input for IDN functions conforms to domain name ASCII rules.
IDNA_CHECK_BIDI (int)
Check whether the input conforms to the BiDi rules. Ignored by the IDNA2003 implementation, which always performs this check.
IDNA_CHECK_CONTEXTJ (int)
Check whether the input conforms to the CONTEXTJ rules. Ignored by the IDNA2003 implementation, as this check is new in IDNA2008.
IDNA_NONTRANSITIONAL_TO_ASCII (int)
Option for nontransitional processing in idn_to_ascii(). Transitional processing is activated by default. This option is ignored by the IDNA2003 implementation.
IDNA_NONTRANSITIONAL_TO_UNICODE (int)
Option for nontransitional processing in idn_to_utf8(). Transitional processing is activated by default. This option is ignored by the IDNA2003 implementation.
INTL_IDNA_VARIANT_2003 (int)
Use IDNA 2003 algorithm in idn_to_utf8() and idn_to_ascii(). This is the default. This constant and using the default has been deprecated as of PHP 7.2.0.
INTL_IDNA_VARIANT_UTS46 (int)
Use UTS #46 algorithm in idn_to_utf8() and idn_to_ascii(). Available as of ICU 4.6.
IDNA_ERROR_EMPTY_LABEL (int)
IDNA_ERROR_LABEL_TOO_LONG (int)
IDNA_ERROR_DOMAIN_NAME_TOO_LONG (int)
IDNA_ERROR_LEADING_HYPHEN (int)
IDNA_ERROR_TRAILING_HYPHEN (int)
IDNA_ERROR_HYPHEN_3_4 (int)
IDNA_ERROR_LEADING_COMBINING_MARK (int)
IDNA_ERROR_DISALLOWED (int)
IDNA_ERROR_PUNYCODE (int)
IDNA_ERROR_LABEL_HAS_DOT (int)
IDNA_ERROR_INVALID_ACE_LABEL (int)
IDNA_ERROR_BIDI (int)
IDNA_ERROR_CONTEXTJ (int)
Errors reported in a bitset returned by the UTS #46 algorithm in idn_to_utf8() and idn_to_ascii().


  • ? 预定义常量
  • Basic usage of this extension ?
  • PHP Manual
  • intl
  • 范例

范例

Table of Contents

  • Basic usage of this extension


Basic usage of this extension

Each module provides two kind of APIs: a procedural one and an object oriented one. Both are actually identical and described in the corresponding document.

Note:

All input strings must be in UTF-8 encoding. All output strings are also in UTF-8.

Example #1 Example of using the procedural API

<?php
$coll  = collator_create('en_US');
$result = collator_compare($coll, "string#1", "string#2");
?>

Example #2 Example of using the object-oriented API

<?php
$coll = new Collator('en_US');
$al   = $coll->getLocale(Locale::ACTUAL_LOCALE);
echo "Actual locale: $al\n";

$formatter = new NumberFormatter('en_US', NumberFormatter::DECIMAL);
echo $formatter->format(1234567);
?>


The Collator class

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

简介

Provides string comparison capability with support for appropriate locale-sensitive sort orderings.

类摘要

Collator {
/* 方法 */
public __construct ( string $locale )
public asort ( array &$array , int $flags = Collator::SORT_REGULAR ) : bool
public compare ( string $string1 , string $string2 ) : int|false
public static create ( string $locale ) : Collator|null
public getAttribute ( int $attribute ) : int|false
public getErrorCode ( ) : int|false
public getErrorMessage ( ) : string|false
public getLocale ( int $type ) : string|false
public getSortKey ( string $string ) : string|false
public getStrength ( ) : int
public setAttribute ( int $attribute , int $value ) : bool
public setStrength ( int $strength ) : bool
public sortWithSortKeys ( array &$array ) : bool
public sort ( array &$array , int $flags = Collator::SORT_REGULAR ) : bool
}

预定义常量

Collator::FRENCH_COLLATION (int)

Sort strings with different accents from the back of the string. This attribute is automatically set to On for the French locales and a few others. Users normally would not need to explicitly set this attribute. There is a string comparison performance cost when it is set On, but sort key length is unaffected. Possible values are:

  • Collator::ON
  • Collator::OFF(default)
  • Collator::DEFAULT_VALUE

Example #1 FRENCH_COLLATION rules

  • F=OFF cote < coté < c?te < c?té
  • F=ON cote < c?te < coté < c?té

Collator::ALTERNATE_HANDLING (int)

The Alternate attribute is used to control the handling of the so called variable characters in the UCA: whitespace, punctuation and symbols. If Alternate is set to NonIgnorable (N), then differences among these characters are of the same importance as differences among letters. If Alternate is set to Shifted (S), then these characters are of only minor importance. The Shifted value is often used in combination with Strength set to Quaternary. In such a case, whitespace, punctuation, and symbols are considered when comparing strings, but only if all other aspects of the strings (base letters, accents, and case) are identical. If Alternate is not set to Shifted, then there is no difference between a Strength of 3 and a Strength of 4. For more information and examples, see Variable_Weighting in the » UCA. The reason the Alternate values are not simply On and Off is that additional Alternate values may be added in the future. The UCA option Blanked is expressed with Strength set to 3, and Alternate set to Shifted. The default for most locales is NonIgnorable. If Shifted is selected, it may be slower if there are many strings that are the same except for punctuation; sort key length will not be affected unless the strength level is also increased.

Possible values are:

  • Collator::NON_IGNORABLE(default)
  • Collator::SHIFTED
  • Collator::DEFAULT_VALUE

Example #2 ALTERNATE_HANDLING rules

  • S=3, A=N di Silva < Di Silva < diSilva < U.S.A. < USA
  • S=3, A=S di Silva = diSilva < Di Silva < U.S.A. = USA
  • S=4, A=S di Silva < diSilva < Di Silva < U.S.A. < USA

Collator::CASE_FIRST (int)

The Case_First attribute is used to control whether uppercase letters come before lowercase letters or vice versa, in the absence of other differences in the strings. The possible values are Uppercase_First (U) and Lowercase_First (L), plus the standard Default and Off. There is almost no difference between the Off and Lowercase_First options in terms of results, so typically users will not use Lowercase_First: only Off or Uppercase_First. (People interested in the detailed differences between X and L should consult the Collation Customization). Specifying either L or U won't affect string comparison performance, but will affect the sort key length.

Possible values are:

  • Collator::OFF(default)
  • Collator::LOWER_FIRST
  • Collator::UPPER_FIRST
  • Collator:DEFAULT

Example #3 CASE_FIRST rules

  • C=X or C=L "china" < "China" < "denmark" < "Denmark"
  • C=U "China" < "china" < "Denmark" < "denmark"

Collator::CASE_LEVEL (int)

The Case_Level attribute is used when ignoring accents but not case. In such a situation, set Strength to be Primary, and Case_Level to be On. In most locales, this setting is Off by default. There is a small string comparison performance and sort key impact if this attribute is set to be On.

Possible values are:

  • Collator::OFF(default)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Example #4 CASE_LEVEL rules

  • S=1, E=X role = Role = r?le
  • S=1, E=O role = r?le < Role

Collator::NORMALIZATION_MODE (int)

The Normalization setting determines whether text is thoroughly normalized or not in comparison. Even if the setting is off (which is the default for many locales), text as represented in common usage will compare correctly (for details, see UTN #5). Only if the accent marks are in noncanonical order will there be a problem. If the setting is On, then the best results are guaranteed for all possible text input. There is a medium string comparison performance cost if this attribute is On, depending on the frequency of sequences that require normalization. There is no significant effect on sort key length. If the input text is known to be in NFD or NFKD normalization forms, there is no need to enable this Normalization option.

Possible values are:

  • Collator::OFF(default)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::STRENGTH (int)

The ICU Collation Service supports many levels of comparison (named "Levels", but also known as "Strengths"). Having these categories enables ICU to sort strings precisely according to local conventions. However, by allowing the levels to be selectively employed, searching for a string in text can be performed with various matching conditions. For more detailed information, see collator_set_strength() chapter.

Possible values are:

  • Collator::PRIMARY
  • Collator::SECONDARY
  • Collator::TERTIARY(default)
  • Collator::QUATERNARY
  • Collator::IDENTICAL
  • Collator::DEFAULT_VALUE

Collator::HIRAGANA_QUATERNARY_MODE (int)

Compatibility with JIS x 4061 requires the introduction of an additional level to distinguish Hiragana and Katakana characters. If compatibility with that standard is required, then this attribute should be set On, and the strength set to Quaternary. This will affect sort key length and string comparison string comparison performance.

Possible values are:

  • Collator::OFF(default)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::NUMERIC_COLLATION (int)

When turned on, this attribute generates a collation key for the numeric value of substrings of digits. This is a way to get '100' to sort AFTER '2'.

Possible values are:

  • Collator::OFF(default)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::DEFAULT_VALUE (int)
Collator::PRIMARY (int)
Collator::SECONDARY (int)
Collator::TERTIARY (int)
Collator::DEFAULT_STRENGTH (int)
Collator::QUATERNARY (int)
Collator::IDENTICAL (int)
Collator::OFF (int)
Collator::ON (int)
Collator::SHIFTED (int)
Collator::NON_IGNORABLE (int)
Collator::LOWER_FIRST (int)
Collator::UPPER_FIRST (int)

Table of Contents

  • Collator::asort — Sort array maintaining index association
  • Collator::compare — Compare two Unicode strings
  • Collator::__construct — Create a collator
  • Collator::create — Create a collator
  • Collator::getAttribute — Get collation attribute value
  • Collator::getErrorCode — Get collator's last error code
  • Collator::getErrorMessage — Get text for collator's last error code
  • Collator::getLocale — Get the locale name of the collator
  • Collator::getSortKey — Get sorting key for a string
  • Collator::getStrength — Get current collation strength
  • Collator::setAttribute — Set collation attribute
  • Collator::setStrength — Set collation strength
  • Collator::sortWithSortKeys — Sort array using specified collator and sort keys
  • Collator::sort — Sort array using specified collator


Sort array maintaining index association

  • ? Collator
  • Collator::compare ?
  • PHP Manual
  • Collator
  • Sort array maintaining index association

Collator::asort

collator_asort

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::asort -- collator_asort — Sort array maintaining index association

说明

面向对象风格

public Collator::asort ( array &$array , int $flags = Collator::SORT_REGULAR ) : bool

过程化风格

collator_asort ( Collator $object , array &$array , int $flags = Collator::SORT_REGULAR ) : bool

This function sorts an array such that array indices maintain their correlation with the array elements they are associated with. This is used mainly when sorting associative arrays where the actual element order is significant. Array elements will have sort order according to current locale rules.

Equivalent to standard PHP asort().

参数

object

Collator object.

array

Array of strings to sort.

flags

Optional sorting type, one of the following:

  • Collator::SORT_REGULAR - compare items normally (don't change types)

  • Collator::SORT_NUMERIC - compare items numerically

  • Collator::SORT_STRING - compare items as strings

Default $sort_flag value is Collator::SORT_REGULAR. It is also used if an invalid $sort_flag value has been specified.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 collator_asort()example

<?php
$coll = collator_create( 'en_US' );
$arr = array(
     'a' => '100',
     'b' => '50',
     'c' => '7'
);
collator_asort( $coll, $arr, Collator::SORT_NUMERIC );
var_export( $arr );

collator_asort( $coll, $arr, Collator::SORT_STRING );
var_export( $arr );
?>

以上例程会输出：

array (
  'c' => '7',
  'b' => '50',
  'a' => '100',
)array (
  'a' => '100',
  'b' => '50',
  'c' => '7',
)

参见

  • Collator constants
  • collator_sort() - Sort array using specified collator
  • collator_sort_with_sort_keys() - Sort array using specified collator and sort keys


Compare two Unicode strings

  • ? Collator::asort
  • Collator::__construct ?
  • PHP Manual
  • Collator
  • Compare two Unicode strings

Collator::compare

collator_compare

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::compare -- collator_compare — Compare two Unicode strings

说明

面向对象风格

public Collator::compare ( string $string1 , string $string2 ) : int|false

过程化风格

collator_compare ( Collator $object , string $string1 , string $string2 ) : int|false

Compare two Unicode strings according to collation rules.

参数

object

Collator object.

string1

The first string to compare.

string2

The second string to compare.

返回值

Return comparison result:

  • 1 if string1 is greater than string2 ;

  • 0 if string1 is equal to string2;

  • -1 if string1 is less than string2 .

On error bool false is returned.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 collator_compare()example

<?php
$s1 = 'Hello';
$s2 = 'hello';

$coll = collator_create( 'en_US' );
$res  = collator_compare( $coll, $s1, $s2 );

if ($res === false) {
    echo collator_get_error_message( $coll );
} else if( $res > 0 ) {
    echo "s1 is greater than s2\n";
} else if( $res < 0 ) {
    echo "s1 is less than s2\n";
} else {
    echo "s1 is equal to s2\n";
}
?>

以上例程会输出：

s1 is greater than s2

参见

  • collator_sort() - Sort array using specified collator


Create a collator

  • ? Collator::compare
  • Collator::create ?
  • PHP Manual
  • Collator
  • Create a collator

Collator::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::__construct — Create a collator

说明

public Collator::__construct ( string $locale )

Creates a new instance of Collator.

参数

locale

The locale whose collation rules should be used. Special values for locales can be passed in - if null is passed for the locale, the default locale's collation rules will be used. If "root" is passed, UCA rules will be used.

The Locale attribute is typically the most important attribute for correct sorting and matching, according to the user expectations in different countries and regions. The default » UCA ordering will only sort a few languages such as Dutch and Portuguese correctly ("correctly" meaning according to the normal expectations for users of the languages). Otherwise, you need to supply the locale to UCA in order to properly collate text for a given language. Thus a locale needs to be supplied so as to choose a collator that is correctly tailored for that locale. The choice of a locale will automatically preset the values for all of the attributes to something that is reasonable for that locale. Thus most of the time the other attributes do not need to be explicitly set. In some cases, the choice of locale will make a difference in string comparison performance and/or sort key length.

返回值

Returns Collator instance.

错误／异常

Returns an "empty" object on error. You can use intl_get_error_code() and/or intl_get_error_message() to know what happened.

范例

Example #1 Collator::__construct() example

<?php
$coll = new Collator( 'en_CA' );
?>

参见

  • Collator::create() - Create a collator
  • collator_create() - Create a collator


Create a collator

  • ? Collator::__construct
  • Collator::getAttribute ?
  • PHP Manual
  • Collator
  • Create a collator

Collator::create

collator_create

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::create -- collator_create — Create a collator

说明

面向对象风格

public static Collator::create ( string $locale ) : Collator|null

过程化风格

collator_create ( string $locale ) : Collator|null

The strings will be compared using the options already specified.

参数

locale

The locale containing the required collation rules. Special values for locales can be passed in - if null is passed for the locale, the default locale collation rules will be used. If empty string ("") or "root" are passed, » UCA rules will be used.

返回值

Return new instance of Collator object, or null on error.

范例

Example #1 collator_create() example

<?php
$coll = collator_create( 'en_US' );

if( !isset( $coll ) ) {
    printf( "Collator creation failed: %s\n", intl_get_error_message() );
    exit( 1 );
}
?>

参见

  • Collator::__construct() - Create a collator


Get collation attribute value

  • ? Collator::create
  • Collator::getErrorCode ?
  • PHP Manual
  • Collator
  • Get collation attribute value

Collator::getAttribute

collator_get_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getAttribute -- collator_get_attribute — Get collation attribute value

说明

面向对象风格

public Collator::getAttribute ( int $attribute ) : int|false

过程化风格

collator_get_attribute ( Collator $object , int $attribute ) : int|false

Get a value of an integer collator attribute.

参数

object

Collator object.

attribute

Attribute to get value for.

返回值

Attribute value, or bool false on error.

范例

Example #1 collator_get_attribute() example

<?php
$coll = collator_create( 'en_CA' );
$val = collator_get_attribute( $coll, Collator::NUMERIC_COLLATION );
if( $val === false )
{
    // Handle error.
}
?>

参见

  • Collator constants
  • collator_set_attribute() - Set collation attribute
  • collator_get_strength() - Get current collation strength


Get collator's last error code

  • ? Collator::getAttribute
  • Collator::getErrorMessage ?
  • PHP Manual
  • Collator
  • Get collator's last error code

Collator::getErrorCode

collator_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getErrorCode -- collator_get_error_code — Get collator's last error code

说明

面向对象风格

public Collator::getErrorCode ( ) : int|false

过程化风格

collator_get_error_code ( Collator $object ) : int|false

参数

object

Collator object.

返回值

Error code returned by the last Collator API function call, 或者在失败时返回 false.

范例

Example #1 collator_get_error_code() example

<?php
$coll = collator_create( 'en_US' );
if( collator_get_attribute( $coll, Collator::FRENCH_COLLATION ) === false )
        handle_error( collator_get_error_code() );
?>

参见

  • collator_get_error_message() - Get text for collator's last error code


Get text for collator's last error code

  • ? Collator::getErrorCode
  • Collator::getLocale ?
  • PHP Manual
  • Collator
  • Get text for collator's last error code

Collator::getErrorMessage

collator_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getErrorMessage -- collator_get_error_message — Get text for collator's last error code

说明

面向对象风格

public Collator::getErrorMessage ( ) : string|false

过程化风格

collator_get_error_message ( Collator $object ) : string|false

Retrieves the message for the last error.

参数

object

Collator object.

返回值

Description of an error occurred in the last Collator API function call, 或者在失败时返回 false.

范例

Example #1 collator_get_error_message() example

<?php
$coll = collator_create( 'lt' );
if( collator_compare( $coll, 'y', 'k' ) === false ) {
    echo collator_get_error_message( $coll );
}
?>

参见

  • collator_get_error_code() - Get collator's last error code


Get the locale name of the collator

  • ? Collator::getErrorMessage
  • Collator::getSortKey ?
  • PHP Manual
  • Collator
  • Get the locale name of the collator

Collator::getLocale

collator_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getLocale -- collator_get_locale — Get the locale name of the collator

说明

面向对象风格

public Collator::getLocale ( int $type ) : string|false

过程化风格

collator_get_locale ( Collator $object , int $type ) : string|false

Get collector locale name.

参数

object

Collator object.

type

You can choose between valid and actual locale ( Locale::VALID_LOCALE and Locale::ACTUAL_LOCALE, respectively).

返回值

Real locale name from which the collation data comes. If the collator was instantiated from rules or an error occurred, returns bool false.

范例

Example #1 collator_get_locale() example

<?php
$coll    = collator_create( 'en_US_California' );
$res_val = collator_get_locale( $coll, Locale::VALID_LOCALE );
$res_act = collator_get_locale( $coll, Locale::ACTUAL_LOCALE );
printf( "Valid locale name: %s\nActual locale name: %s\n",
         $res_val, $res_act );
?>

以上例程会输出：

Requested locale name: en_US_California
Valid locale name: en_US
Actual locale name: en

参见

  • collator_create() - Create a collator


Get sorting key for a string

  • ? Collator::getLocale
  • Collator::getStrength ?
  • PHP Manual
  • Collator
  • Get sorting key for a string

Collator::getSortKey

collator_get_sort_key

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 1.0.3)

Collator::getSortKey -- collator_get_sort_key — Get sorting key for a string

说明

面向对象风格

public Collator::getSortKey ( string $string ) : string|false

过程化风格

collator_get_sort_key ( Collator $object , string $string ) : string|false

Return collation key for a string. Collation keys can be compared directly instead of strings, though are implementation specific and may change between ICU library versions. Sort keys are generally only useful in databases or other circumstances where function calls are extremely expensive.

参数

object

Collator object.

string

The string to produce the key from.

返回值

Returns the collation key for the string, 或者在失败时返回 false.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
5.3.15, 5.4.5 | Sort keys do no longer contain any NUL bytes.

范例

Example #1 collator_get_sort_key()example

<?php
$s1 = 'Hello';

$coll = collator_create('en_US');
$res  = collator_get_sort_key($coll, $s1);

echo bin2hex($res);
?>

以上例程的输出类似于：

3832404046010901dc08

参见

  • collator_sort() - Sort array using specified collator
  • collator_sort_with_sort_keys() - Sort array using specified collator and sort keys


Get current collation strength

  • ? Collator::getSortKey
  • Collator::setAttribute ?
  • PHP Manual
  • Collator
  • Get current collation strength

Collator::getStrength

collator_get_strength

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getStrength -- collator_get_strength — Get current collation strength

说明

面向对象风格

public Collator::getStrength ( ) : int

过程化风格

collator_get_strength ( Collator $object ) : int

参数

object

Collator object.

返回值

Returns current collation strength, or bool false on error.

范例

Example #1 collator_get_strength() example

<?php
$coll     = collator_create( 'en_US' );
$strength = collator_get_strength( $coll );
?>

参见

  • Collator constants
  • collator_set_strength() - Set collation strength
  • collator_get_attribute() - Get collation attribute value


Set collation attribute

  • ? Collator::getStrength
  • Collator::setStrength ?
  • PHP Manual
  • Collator
  • Set collation attribute

Collator::setAttribute

collator_set_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::setAttribute -- collator_set_attribute — Set collation attribute

说明

面向对象风格

public Collator::setAttribute ( int $attribute , int $value ) : bool

过程化风格

collator_set_attribute ( Collator $object , int $attribute , int $value ) : bool

参数

object

Collator object.

attribute

Attribute.

value

Attribute value.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 collator_set_attribute() example

<?php
$coll = collator_create( 'en_CA' );
$val  = collator_get_attribute( $coll, Collator::NUMERIC_COLLATION );
if ($val === false) {
    // Handle error.
} elseif ($val === Collator::ON) {
    // Do something useful.
}
?>

参见

  • Collator constants
  • collator_get_attribute() - Get collation attribute value
  • collator_set_strength() - Set collation strength


Set collation strength

  • ? Collator::setAttribute
  • Collator::sortWithSortKeys ?
  • PHP Manual
  • Collator
  • Set collation strength

Collator::setStrength

collator_set_strength

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::setStrength -- collator_set_strength — Set collation strength

说明

面向对象风格

public Collator::setStrength ( int $strength ) : bool

过程化风格

collator_set_strength ( Collator $object , int $strength ) : bool

The » ICU Collation Service supports many levels of comparison (named "Levels", but also known as "Strengths"). Having these categories enables ICU to sort strings precisely according to local conventions. However, by allowing the levels to be selectively employed, searching for a string in text can be performed with various matching conditions.

  1. Primary Level: Typically, this is used to denote differences between base characters (for example, "a" < "b"). It is the strongest difference. For example, dictionaries are divided into different sections by base character. This is also called the level1 strength.

  2. Secondary Level: Accents in the characters are considered secondary differences (for example, "as" < "às" < "at"). Other differences between letters can also be considered secondary differences, depending on the language. A secondary difference is ignored when there is a primary difference anywhere in the strings. This is also called the level2 strength.

    Note:

    Note: In some languages (such as Danish), certain accented letters are considered to be separate base characters. In most languages, however, an accented letter only has a secondary difference from the unaccented version of that letter.

  3. Tertiary Level: Upper and lower case differences in characters are distinguished at the tertiary level (for example, "ao" < "Ao" < "aò"). In addition, a variant of a letter differs from the base form on the tertiary level (such as "A" and " "). Another example is the difference between large and small Kana. A tertiary difference is ignored when there is a primary or secondary difference anywhere in the strings. This is also called the level3 strength.

  4. Quaternary Level: When punctuation is ignored (see Ignoring Punctuations ) at level 13, an additional level can be used to distinguish words with and without punctuation (for example, "ab" < "a-b" < "aB"). This difference is ignored when there is a primary, secondary or tertiary difference. This is also known as the level4 strength. The quaternary level should only be used if ignoring punctuation is required or when processing Japanese text (see Hiragana processing).

  5. Identical Level: When all other levels are equal, the identical level is used as a tiebreaker. The Unicode code point values of the NFD form of each string are compared at this level, just in case there is no difference at levels 14. For example, Hebrew cantillation marks are only distinguished at this level. This level should be used sparingly, as only code point values differences between two strings is an extremely rare occurrence. Using this level substantially decreases the performance for both incremental comparison and sort key generation (as well as increasing the sort key length). It is also known as level 5 strength.

For example, people may choose to ignore accents or ignore accents and case when searching for text. Almost all characters are distinguished by the first three levels, and in most locales the default value is thus Tertiary. However, if Alternate is set to be Shifted, then the Quaternary strength can be used to break ties among whitespace, punctuation, and symbols that would otherwise be ignored. If very fine distinctions among characters are required, then the Identical strength can be used (for example, Identical Strength distinguishes between the Mathematical Bold Small A and the Mathematical Italic Small A.). However, using levels higher than Tertiary the Identical strength result in significantly longer sort keys, and slower string comparison performance for equal strings.

参数

object

Collator object.

strength

Strength to set.

Possible values are:

  • Collator::PRIMARY

  • Collator::SECONDARY

  • Collator::TERTIARY

  • Collator::QUATERNARY

  • Collator::IDENTICAL

  • Collator::DEFAULT_STRENGTH

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 collator_set_strength() example

<?php
$arr  = array( 'aò', 'Ao', 'ao' );
$coll = collator_create( 'en_US' );

// Sort array using default strength.
collator_sort( $coll, $arr );
var_export( $arr );

// Sort array using primary strength.
collator_set_strength( $coll, Collator::PRIMARY );
collator_sort( $coll, $arr );
var_export( $arr );
?>

以上例程会输出：

array (
  0 => 'ao',
  1 => 'Ao',
  2 => 'aò',
)
array (
  0 => 'aò',
  1 => 'Ao',
  2 => 'ao',
)

参见

  • Collator constants
  • collator_get_strength() - Get current collation strength


Sort array using specified collator and sort keys

  • ? Collator::setStrength
  • Collator::sort ?
  • PHP Manual
  • Collator
  • Sort array using specified collator and sort keys

Collator::sortWithSortKeys

collator_sort_with_sort_keys

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::sortWithSortKeys -- collator_sort_with_sort_keys — Sort array using specified collator and sort keys

说明

面向对象风格

public Collator::sortWithSortKeys ( array &$array ) : bool

过程化风格

collator_sort_with_sort_keys ( Collator $object , array &$array ) : bool

Similar to collator_sort() but uses ICU sorting keys produced by ucol_getSortKey() to gain more speed on large arrays.

参数

object

Collator object.

array

Array of strings to sort

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 collator_sort_with_sort_keys() example

<?php
$arr  = array( 'K?pfe', 'Kypper', 'Kopfe' );
$coll = collator_create( 'sv' );

collator_sort_with_sort_keys( $coll, $arr );
var_export( $arr );
?>

以上例程会输出：

array (
  0 => 'Kopfe',
  1 => 'Kypper',
  2 => 'K?pfe',
)

参见

  • Collator constants
  • collator_sort() - Sort array using specified collator
  • collator_asort() - Sort array maintaining index association


Sort array using specified collator

  • ? Collator::sortWithSortKeys
  • NumberFormatter ?
  • PHP Manual
  • Collator
  • Sort array using specified collator

Collator::sort

collator_sort

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::sort -- collator_sort — Sort array using specified collator

说明

面向对象风格

public Collator::sort ( array &$array , int $flags = Collator::SORT_REGULAR ) : bool

过程化风格

collator_sort ( Collator $object , array &$array , int $flags = Collator::SORT_REGULAR ) : bool

This function sorts an array according to current locale rules.

Equivalent to standard PHP sort() .

参数

object

Collator object.

array

Array of strings to sort.

flags

Optional sorting type, one of the following:

  • Collator::SORT_REGULAR - compare items normally (don't change types)

  • Collator::SORT_NUMERIC - compare items numerically

  • Collator::SORT_STRING - compare items as strings

Default sorting type is Collator::SORT_REGULAR. It is also used if an invalid flags value has been specified.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 collator_sort() example

<?php
$coll = collator_create( 'en_US' );
$arr  = array( 'at', 'às', 'as' );

var_export( $arr );
collator_sort( $coll, $arr );
var_export( $arr );
?>

以上例程会输出：

array (
  0 => 'at',
  1 => 'às',
  2 => 'as',
)array (
  0 => 'as',
  1 => 'às',
  2 => 'at',
)

参见

  • Collator constants
  • collator_asort() - Sort array maintaining index association
  • collator_sort_with_sort_keys() - Sort array using specified collator and sort keys


The NumberFormatter class

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

简介

Programs store and operate on numbers using a locale-independent binary representation. When displaying or printing a number it is converted to a locale-specific string. For example, the number 12345.67 is "12,345.67" in the US, "12 345,67" in France and "12.345,67" in Germany.

By invoking the methods provided by the NumberFormatter class, you can format numbers, currencies, and percentages according to the specified or default locale. NumberFormatter is locale-sensitive so you need to create a new NumberFormatter for each locale. NumberFormatter methods format primitive-type numbers, such as double and output the number as a locale-specific string.

For currencies you can use currency format type to create a formatter that returns a string with the formatted number and the appropriate currency sign. Of course, the NumberFormatter class is unaware of exchange rates so, the number output is the same regardless of the specified currency. This means that the same number has different monetary values depending on the currency locale. If the number is 9988776.65 the results will be:

  • 9 988 776,65 � in France
  • 9.988.776,65 � in Germany
  • $9,988,776.65 in the United States

In order to format percentages, create a locale-specific formatter with percentage format type. With this formatter, a decimal fraction such as 0.75 is displayed as 75%.

For more complex formatting, like spelled-out numbers, the rule-based number formatters are used.

类摘要

NumberFormatter {
/* 方法 */
public __construct ( string $locale , int $style , string $pattern = ? )
public static create ( string $locale , int $style , string $pattern = ? ) : NumberFormatter
public formatCurrency ( float $value , string $currency ) : string|false
public format ( int|float $value , int $type = ? ) : string
public getAttribute ( int $attr ) : int
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getLocale ( int $type = ? ) : string
public getPattern ( ) : string
public getSymbol ( int $attr ) : string
public getTextAttribute ( int $attr ) : string
public parseCurrency ( string $value , string &$currency , int &$position = ? ) : float
public parse ( string $value , int $type = ? , int &$position = ? ) : mixed
public setAttribute ( int $attr , int $value ) : bool
public setPattern ( string $pattern ) : bool
public setSymbol ( int $attr , string $value ) : bool
public setTextAttribute ( int $attr , string $value ) : bool
}

预定义常量

These styles are used by the numfmt_create() to define the type of the formatter.

NumberFormatter::PATTERN_DECIMAL (int)
Decimal format defined by pattern
NumberFormatter::DECIMAL (int)
Decimal format
NumberFormatter::CURRENCY (int)
Currency format
NumberFormatter::PERCENT (int)
Percent format
NumberFormatter::SCIENTIFIC (int)
Scientific format
NumberFormatter::SPELLOUT (int)
Spellout rule-based format
NumberFormatter::ORDINAL (int)
Ordinal rule-based format
NumberFormatter::DURATION (int)
Duration rule-based format
NumberFormatter::PATTERN_RULEBASED (int)
Rule-based format defined by pattern
NumberFormatter::CURRENCY_ACCOUNTING (int)
Currency format for accounting, e.g., ($3.00) for negative currency amount instead of -$3.00. Available as of PHP 7.4.1 and ICU 53.
NumberFormatter::DEFAULT_STYLE (int)
Default format for the locale
NumberFormatter::IGNORE (int)
Alias for PATTERN_DECIMAL

These constants define how the numbers are parsed or formatted. They should be used as arguments to numfmt_format() and numfmt_parse().

NumberFormatter::TYPE_DEFAULT (int)
Derive the type from variable type
NumberFormatter::TYPE_INT32 (int)
Format/parse as 32-bit integer
NumberFormatter::TYPE_INT64 (int)
Format/parse as 64-bit integer
NumberFormatter::TYPE_DOUBLE (int)
Format/parse as floating point value
NumberFormatter::TYPE_CURRENCY (int)
Format/parse as currency value

Number format attribute used by numfmt_get_attribute() and numfmt_set_attribute().

NumberFormatter::PARSE_INT_ONLY (int)
Parse integers only.
NumberFormatter::GROUPING_USED (int)
Use grouping separator.
NumberFormatter::DECIMAL_ALWAYS_SHOWN (int)
Always show decimal point.
NumberFormatter::MAX_INTEGER_DIGITS (int)
Maximum integer digits.
NumberFormatter::MIN_INTEGER_DIGITS (int)
Minimum integer digits.
NumberFormatter::INTEGER_DIGITS (int)
Integer digits.
NumberFormatter::MAX_FRACTION_DIGITS (int)
Maximum fraction digits.
NumberFormatter::MIN_FRACTION_DIGITS (int)
Minimum fraction digits.
NumberFormatter::FRACTION_DIGITS (int)
Fraction digits.
NumberFormatter::MULTIPLIER (int)
Multiplier.
NumberFormatter::GROUPING_SIZE (int)
Grouping size.
NumberFormatter::ROUNDING_MODE (int)
Rounding Mode.
NumberFormatter::ROUNDING_INCREMENT (int)
Rounding increment.
NumberFormatter::FORMAT_WIDTH (int)
The width to which the output of format() is padded.
NumberFormatter::PADDING_POSITION (int)
The position at which padding will take place. See pad position constants for possible argument values.
NumberFormatter::SECONDARY_GROUPING_SIZE (int)
Secondary grouping size.
NumberFormatter::SIGNIFICANT_DIGITS_USED (int)
Use significant digits.
NumberFormatter::MIN_SIGNIFICANT_DIGITS (int)
Minimum significant digits.
NumberFormatter::MAX_SIGNIFICANT_DIGITS (int)
Maximum significant digits.
NumberFormatter::LENIENT_PARSE (int)
Lenient parse mode used by rule-based formats.

Number format text attribute used by numfmt_get_text_attribute() and numfmt_set_text_attribute().

NumberFormatter::POSITIVE_PREFIX (int)
Positive prefix.
NumberFormatter::POSITIVE_SUFFIX (int)
Positive suffix.
NumberFormatter::NEGATIVE_PREFIX (int)
Negative prefix.
NumberFormatter::NEGATIVE_SUFFIX (int)
Negative suffix.
NumberFormatter::PADDING_CHARACTER (int)
The character used to pad to the format width.
NumberFormatter::CURRENCY_CODE (int)
The ISO currency code.
NumberFormatter::DEFAULT_RULESET (int)
The default rule set. This is only available with rule-based formatters.
NumberFormatter::PUBLIC_RULESETS (int)
The public rule sets. This is only available with rule-based formatters. This is a read-only attribute. The public rulesets are returned as a single string, with each ruleset name delimited by ';' (semicolon).

Number format symbols used by numfmt_get_symbol() and numfmt_set_symbol().

NumberFormatter::DECIMAL_SEPARATOR_SYMBOL (int)
The decimal separator.
NumberFormatter::GROUPING_SEPARATOR_SYMBOL (int)
The grouping separator.
NumberFormatter::PATTERN_SEPARATOR_SYMBOL (int)
The pattern separator.
NumberFormatter::PERCENT_SYMBOL (int)
The percent sign.
NumberFormatter::ZERO_DIGIT_SYMBOL (int)
Zero.
NumberFormatter::DIGIT_SYMBOL (int)
Character representing a digit in the pattern.
NumberFormatter::MINUS_SIGN_SYMBOL (int)
The minus sign.
NumberFormatter::PLUS_SIGN_SYMBOL (int)
The plus sign.
NumberFormatter::CURRENCY_SYMBOL (int)
The currency symbol.
NumberFormatter::INTL_CURRENCY_SYMBOL (int)
The international currency symbol.
NumberFormatter::MONETARY_SEPARATOR_SYMBOL (int)
The monetary separator.
NumberFormatter::EXPONENTIAL_SYMBOL (int)
The exponential symbol.
NumberFormatter::PERMILL_SYMBOL (int)
Per mill symbol.
NumberFormatter::PAD_ESCAPE_SYMBOL (int)
Escape padding character.
NumberFormatter::INFINITY_SYMBOL (int)
Infinity symbol.
NumberFormatter::NAN_SYMBOL (int)
Not-a-number symbol.
NumberFormatter::SIGNIFICANT_DIGIT_SYMBOL (int)
Significant digit symbol.
NumberFormatter::MONETARY_GROUPING_SEPARATOR_SYMBOL (int)
The monetary grouping separator.

Rounding mode values used by numfmt_get_attribute()
and numfmt_set_attribute() with
NumberFormatter::ROUNDING_MODE attribute.

NumberFormatter::ROUND_CEILING (int)
Rounding mode to round towards positive infinity.
NumberFormatter::ROUND_DOWN (int)
Rounding mode to round towards zero.
NumberFormatter::ROUND_FLOOR (int)
Rounding mode to round towards negative infinity.
NumberFormatter::ROUND_HALFDOWN (int)
Rounding mode to round towards "nearest neighbor" unless both neighbors are equidistant, in which case round down.
NumberFormatter::ROUND_HALFEVEN (int)
Rounding mode to round towards the "nearest neighbor" unless both neighbors are equidistant, in which case, round towards the even neighbor.
NumberFormatter::ROUND_HALFUP (int)
Rounding mode to round towards "nearest neighbor" unless both neighbors are equidistant, in which case round up.
NumberFormatter::ROUND_UP (int)
Rounding mode to round away from zero.

Pad position values used by numfmt_get_attribute()
and numfmt_set_attribute() with
NumberFormatter::PADDING_POSITION attribute.

NumberFormatter::PAD_AFTER_PREFIX (int)
Pad characters inserted after the prefix.
NumberFormatter::PAD_AFTER_SUFFIX (int)
Pad characters inserted after the suffix.
NumberFormatter::PAD_BEFORE_PREFIX (int)
Pad characters inserted before the prefix.
NumberFormatter::PAD_BEFORE_SUFFIX (int)
Pad characters inserted before the suffix.

参见

  • » ICU formatting documentation
  • » ICU number formatters
  • » ICU decimal formatters
  • » ICU rule-based number formatters

Table of Contents

  • NumberFormatter::create — Create a number formatter
  • NumberFormatter::formatCurrency — Format a currency value
  • NumberFormatter::format — Format a number
  • NumberFormatter::getAttribute — Get an attribute
  • NumberFormatter::getErrorCode — Get formatter's last error code
  • NumberFormatter::getErrorMessage — Get formatter's last error message
  • NumberFormatter::getLocale — Get formatter locale
  • NumberFormatter::getPattern — Get formatter pattern
  • NumberFormatter::getSymbol — Get a symbol value
  • NumberFormatter::getTextAttribute — Get a text attribute
  • NumberFormatter::parseCurrency — Parse a currency number
  • NumberFormatter::parse — Parse a number
  • NumberFormatter::setAttribute — Set an attribute
  • NumberFormatter::setPattern — Set formatter pattern
  • NumberFormatter::setSymbol — Set a symbol value
  • NumberFormatter::setTextAttribute — Set a text attribute


Create a number formatter

  • ? NumberFormatter
  • NumberFormatter::formatCurrency ?
  • PHP Manual
  • NumberFormatter
  • Create a number formatter

NumberFormatter::create

numfmt_create

NumberFormatter::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::create -- numfmt_create -- NumberFormatter::__construct — Create a number formatter

说明

面向对象风格 (method)

public static NumberFormatter::create ( string $locale , int $style , string $pattern = ? ) : NumberFormatter

过程化风格

numfmt_create ( string $locale , int $style , string $pattern = ? ) : NumberFormatter

面向对象风格 (constructor):

public NumberFormatter::__construct ( string $locale , int $style , string $pattern = ? )

Creates a number formatter.

参数

locale

Locale in which the number would be formatted (locale name, e.g. en_CA).

style

Style of the formatting, one of the format style constants. If NumberFormatter::PATTERN_DECIMAL or NumberFormatter::PATTERN_RULEBASED is passed then the number format is opened using the given pattern, which must conform to the syntax described in » ICU DecimalFormat documentation or » ICU RuleBasedNumberFormat documentation, respectively.

pattern

Pattern string if the chosen style requires a pattern.

返回值

Returns NumberFormatter object or false on error.

范例

Example #1 numfmt_create() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
$fmt = numfmt_create( 'it', NumberFormatter::SPELLOUT );
echo numfmt_format($fmt, 1142)."\n";
?>

Example #2 NumberFormatter::create() example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo $fmt->format(1234567.891234567890000)."\n";
$fmt = new NumberFormatter( 'it', NumberFormatter::SPELLOUT );
echo $fmt->format(1142)."\n";
?>

以上例程会输出：

1.234.567,891
millicentoquarantadue

参见

  • numfmt_format() - Format a number
  • numfmt_parse() - Parse a number


Format a currency value

  • ? NumberFormatter::create
  • NumberFormatter::format ?
  • PHP Manual
  • NumberFormatter
  • Format a currency value

NumberFormatter::formatCurrency

numfmt_format_currency

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::formatCurrency -- numfmt_format_currency — Format a currency value

说明

面向对象风格

public NumberFormatter::formatCurrency ( float $value , string $currency ) : string|false

过程化风格

numfmt_format_currency ( NumberFormatter $fmt , float $value , string $currency ) : string|false

Format the currency value according to the formatter rules.

参数

fmt

NumberFormatter object.

value

The numeric currency value.

currency

The 3-letter ISO 4217 currency code indicating the currency to use.

返回值

String representing the formatted currency value, 或者在失败时返回 false.

范例

Example #1 numfmt_format_currency() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::CURRENCY );
echo numfmt_format_currency($fmt, 1234567.891234567890000, "EUR")."\n";
echo numfmt_format_currency($fmt, 1234567.891234567890000, "RUR")."\n";
$fmt = numfmt_create( 'ru_RU', NumberFormatter::CURRENCY );
echo numfmt_format_currency($fmt, 1234567.891234567890000, "EUR")."\n";
echo numfmt_format_currency($fmt, 1234567.891234567890000, "RUR")."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::CURRENCY );
echo $fmt->formatCurrency(1234567.891234567890000, "EUR")."\n";
echo $fmt->formatCurrency(1234567.891234567890000, "RUR")."\n";
$fmt = new NumberFormatter( 'ru_RU', NumberFormatter::CURRENCY );
echo $fmt->formatCurrency(1234567.891234567890000, "EUR")."\n";
echo $fmt->formatCurrency(1234567.891234567890000, "RUR")."\n";
?>

以上例程会输出：

1.234.567,89 �
1.234.567,89 RUR
1 234 567,89�
1 234 567,89р.

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_format() - Format a number
  • numfmt_parse_currency() - Parse a currency number


Format a number

  • ? NumberFormatter::formatCurrency
  • NumberFormatter::getAttribute ?
  • PHP Manual
  • NumberFormatter
  • Format a number

NumberFormatter::format

numfmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::format -- numfmt_format — Format a number

说明

面向对象风格

public NumberFormatter::format ( int|float $value , int $type = ? ) : string

过程化风格

numfmt_format ( NumberFormatter $fmt , int|float $value , int $type = ? ) : string

Format a numeric value according to the formatter rules.

参数

fmt

NumberFormatter object.

value

The value to format. Can be int or float, other values will be converted to a numeric value.

type

The formatting type to use.

返回值

Returns the string containing formatted value, or false on error.

范例

Example #1 numfmt_format() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
$data = numfmt_format($fmt, 1234567.891234567890000);
if(intl_is_failure(numfmt_format($fmt))) {
    report_error("Formatter error");
}
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
if(intl_is_failure($fmt->getErrorCode())) {
    report_error("Formatter error");
}
?>

以上例程会输出：

1.234.567,891

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_format_currency() - Format a currency value
  • numfmt_parse() - Parse a number


Get an attribute

  • ? NumberFormatter::format
  • NumberFormatter::getErrorCode ?
  • PHP Manual
  • NumberFormatter
  • Get an attribute

NumberFormatter::getAttribute

numfmt_get_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getAttribute -- numfmt_get_attribute — Get an attribute

说明

面向对象风格

public NumberFormatter::getAttribute ( int $attr ) : int

过程化风格

numfmt_get_attribute ( NumberFormatter $fmt , int $attr ) : int

Get a numeric attribute associated with the formatter. An example of a numeric attribute is the number of integer digits the formatter will produce.

参数

fmt

NumberFormatter object.

attr

Attribute specifier - one of the numeric attribute constants.

返回值

Return attribute value on success, or false on error.

范例

Example #1 numfmt_get_attribute() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Digits: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Digits: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Digits: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setAttribute(NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Digits: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

以上例程会输出：

Digits: 3
1.234.567,891
Digits: 2
1.234.567,89

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_get_text_attribute() - Get a text attribute
  • numfmt_set_attribute() - Set an attribute


Get formatter's last error code

  • ? NumberFormatter::getAttribute
  • NumberFormatter::getErrorMessage ?
  • PHP Manual
  • NumberFormatter
  • Get formatter's last error code

NumberFormatter::getErrorCode

numfmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getErrorCode -- numfmt_get_error_code — Get formatter's last error code

说明

面向对象风格

public NumberFormatter::getErrorCode ( ) : int

过程化风格

numfmt_get_error_code ( NumberFormatter $fmt ) : int

Get error code from the last function performed by the formatter.

参数

fmt

NumberFormatter object.

返回值

Returns error code from last formatter call.

范例

Example #1 numfmt_get_error_code() example

<?php
$fmt  = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
$data = numfmt_format($fmt, 1234567.891234567890000);
if(intl_is_failure(numfmt_get_error_code($fmt))) {
    report_error("Formatter error");
}
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
if(intl_is_failure($fmt->getErrorCode())) {
    report_error("Formatter error");
}
?>

参见

  • numfmt_get_error_message() - Get formatter's last error message
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure


Get formatter's last error message

  • ? NumberFormatter::getErrorCode
  • NumberFormatter::getLocale ?
  • PHP Manual
  • NumberFormatter
  • Get formatter's last error message

NumberFormatter::getErrorMessage

numfmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getErrorMessage -- numfmt_get_error_message — Get formatter's last error message

说明

面向对象风格

public NumberFormatter::getErrorMessage ( ) : string

过程化风格

numfmt_get_error_message ( NumberFormatter $fmt ) : string

Get error message from the last function performed by the formatter.

参数

fmt

NumberFormatter object.

返回值

Returns error message from last formatter call.

范例

Example #1 numfmt_get_error_message() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
$data = numfmt_format($fmt, 1234567.891234567890000);
var_dump(numfmt_get_error_message($fmt));
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
var_dump(numfmt_get_error_message($fmt));
?>

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure


Get formatter locale

  • ? NumberFormatter::getErrorMessage
  • NumberFormatter::getPattern ?
  • PHP Manual
  • NumberFormatter
  • Get formatter locale

NumberFormatter::getLocale

numfmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getLocale -- numfmt_get_locale — Get formatter locale

说明

面向对象风格

public NumberFormatter::getLocale ( int $type = ? ) : string

过程化风格

numfmt_get_locale ( NumberFormatter $fmt , int $type = ? ) : string

Get formatter locale name.

参数

fmt

NumberFormatter object.

type

You can choose between valid and actual locale ( Locale::VALID_LOCALE, Locale::ACTUAL_LOCALE, respectively). The default is the actual locale.

返回值

The locale name used to create the formatter.

范例

Example #1 numfmt_get_locale() example

<?php
$req     = 'fr_FR_PARIS';
$fmt     = numfmt_create( $req,  NumberFormatter::DECIMAL);
$res_val = numfmt_get_locale( $fmt, Locale::VALID_LOCALE );
$res_act = numfmt_get_locale( $fmt, Locale::ACTUAL_LOCALE );
printf( "Requested locale name: %s\nValid locale name: %s\nActual locale name: %s\n",
         $req, $res_val, $res_act );
?>

以上例程会输出：

Requested locale name: fr_FR_PARIS
Valid locale name: fr_FR
Actual locale name: fr

参见

  • numfmt_create() - Create a number formatter
  • numfmt_get_error_code() - Get formatter's last error code


Get formatter pattern

  • ? NumberFormatter::getLocale
  • NumberFormatter::getSymbol ?
  • PHP Manual
  • NumberFormatter
  • Get formatter pattern

NumberFormatter::getPattern

numfmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getPattern -- numfmt_get_pattern — Get formatter pattern

说明

面向对象风格

public NumberFormatter::getPattern ( ) : string

过程化风格

numfmt_get_pattern ( NumberFormatter $fmt ) : string

Extract pattern used by the formatter.

参数

fmt

NumberFormatter object.

返回值

Pattern string that is used by the formatter, or false if an error happens.

范例

Example #1 numfmt_get_pattern() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Pattern: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_pattern($fmt, "#0.# kg");
echo "Pattern: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Pattern: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setPattern("#0.# kg");
echo "Pattern: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

以上例程会输出：

Pattern: #,##0.###
1.234.567,891
Pattern: #0.# kg
1234567,9 kg

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_set_pattern() - Set formatter pattern
  • numfmt_create() - Create a number formatter


Get a symbol value

  • ? NumberFormatter::getPattern
  • NumberFormatter::getTextAttribute ?
  • PHP Manual
  • NumberFormatter
  • Get a symbol value

NumberFormatter::getSymbol

numfmt_get_symbol

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getSymbol -- numfmt_get_symbol — Get a symbol value

说明

面向对象风格

public NumberFormatter::getSymbol ( int $attr ) : string

过程化风格

numfmt_get_symbol ( NumberFormatter $fmt , int $attr ) : string

Get a symbol associated with the formatter. The formatter uses symbols to represent the special locale-dependent characters in a number, for example the percent sign. This API is not supported for rule-based formatters.

参数

fmt

NumberFormatter object.

attr

Symbol specifier, one of the format symbol constants.

返回值

The symbol string or false on error.

范例

Example #1 numfmt_get_symbol() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Sep: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Sep: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Sep: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Sep: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

以上例程会输出：

Sep: .
1.234.567,891
Sep: *
1*234*567,891

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_set_symbol() - Set a symbol value


Get a text attribute

  • ? NumberFormatter::getSymbol
  • NumberFormatter::parseCurrency ?
  • PHP Manual
  • NumberFormatter
  • Get a text attribute

NumberFormatter::getTextAttribute

numfmt_get_text_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getTextAttribute -- numfmt_get_text_attribute — Get a text attribute

说明

面向对象风格

public NumberFormatter::getTextAttribute ( int $attr ) : string

过程化风格

numfmt_get_text_attribute ( NumberFormatter $fmt , int $attr ) : string

Get a text attribute associated with the formatter. An example of a text attribute is the suffix for positive numbers. If the formatter does not understand the attribute, U_UNSUPPORTED_ERROR error is produced. Rule-based formatters only understand NumberFormatter::DEFAULT_RULESET and NumberFormatter::PUBLIC_RULESETS.

参数

fmt

NumberFormatter object.

attr

Attribute specifier - one of the text attribute constants.

返回值

Return attribute value on success, or false on error.

范例

Example #1 numfmt_get_text_attribute() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Prefix: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
numfmt_set_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX, "MINUS");
echo "Prefix: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Prefix: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
$fmt->setTextAttribute(NumberFormatter::NEGATIVE_PREFIX, "MINUS");
echo "Prefix: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
?>

以上例程会输出：

Prefix: -
-1.234.567,891
Prefix: MINUS
MINUS1.234.567,891

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_get_attribute() - Get an attribute
  • numfmt_set_text_attribute() - Set a text attribute


Parse a currency number

  • ? NumberFormatter::getTextAttribute
  • NumberFormatter::parse ?
  • PHP Manual
  • NumberFormatter
  • Parse a currency number

NumberFormatter::parseCurrency

numfmt_parse_currency

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::parseCurrency -- numfmt_parse_currency — Parse a currency number

说明

面向对象风格

public NumberFormatter::parseCurrency ( string $value , string &$currency , int &$position = ? ) : float

过程化风格

numfmt_parse_currency ( NumberFormatter $fmt , string $value , string &$currency , int &$position = ? ) : float

Parse a string into a double and a currency using the current formatter.

参数

fmt

NumberFormatter object.

currency

Parameter to receive the currency name (3-letter ISO 4217 currency code).

position

Offset in the string at which to begin parsing. On return, this value will hold the offset at which parsing ended.

返回值

The parsed numeric value or false on error.

范例

Example #1 numfmt_parse_currency() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::CURRENCY );
$num = "1.234.567,89\xc2\xa0$";
echo "We have ".numfmt_parse_currency($fmt, $num, $curr)." in $curr\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::CURRENCY );
$num = "1.234.567,89\xc2\xa0$";
echo "We have ".$fmt->parseCurrency($num, $curr)." in $curr\n";
?>

以上例程会输出：

We have 1234567.89 in USD

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_parse() - Parse a number
  • numfmt_format_currency() - Format a currency value


Parse a number

  • ? NumberFormatter::parseCurrency
  • NumberFormatter::setAttribute ?
  • PHP Manual
  • NumberFormatter
  • Parse a number

NumberFormatter::parse

numfmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::parse -- numfmt_parse — Parse a number

说明

面向对象风格

public NumberFormatter::parse ( string $value , int $type = ? , int &$position = ? ) : mixed

过程化风格

numfmt_parse ( NumberFormatter $fmt , string $value , int $type = ? , int &$position = ? ) : mixed

Parse a string into a number using the current formatter rules.

参数

fmt

NumberFormatter object.

type

The formatting type to use. By default, NumberFormatter::TYPE_DOUBLE is used.

position

Offset in the string at which to begin parsing. On return, this value will hold the offset at which parsing ended.

返回值

The value of the parsed number or false on error.

范例

Example #1 numfmt_parse() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
$num = "1.234.567,891";
echo numfmt_parse($fmt, $num)."\n";
echo numfmt_parse($fmt, $num, NumberFormatter::TYPE_INT32)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
$num = "1.234.567,891";
echo $fmt->parse($num)."\n";
echo $fmt->parse($num, NumberFormatter::TYPE_INT32)."\n";
?>

以上例程会输出：

1234567.891
1234567

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_format() - Format a number
  • numfmt_parse_currency() - Parse a currency number


Set an attribute

  • ? NumberFormatter::parse
  • NumberFormatter::setPattern ?
  • PHP Manual
  • NumberFormatter
  • Set an attribute

NumberFormatter::setAttribute

numfmt_set_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setAttribute -- numfmt_set_attribute — Set an attribute

说明

面向对象风格

public NumberFormatter::setAttribute ( int $attr , int $value ) : bool

过程化风格

numfmt_set_attribute ( NumberFormatter $fmt , int $attr , int $value ) : bool

Set a numeric attribute associated with the formatter. An example of a numeric attribute is the number of integer digits the formatter will produce.

参数

fmt

NumberFormatter object.

attr

Attribute specifier - one of the numeric attribute constants.

value

The attribute value.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 numfmt_set_attribute() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Digits: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Digits: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Digits: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setAttribute(NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Digits: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

以上例程会输出：

Digits: 3
1.234.567,891
Digits: 2
1.234.567,89

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_get_attribute() - Get an attribute
  • numfmt_set_text_attribute() - Set a text attribute


Set formatter pattern

  • ? NumberFormatter::setAttribute
  • NumberFormatter::setSymbol ?
  • PHP Manual
  • NumberFormatter
  • Set formatter pattern

NumberFormatter::setPattern

numfmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setPattern -- numfmt_set_pattern — Set formatter pattern

说明

面向对象风格

public NumberFormatter::setPattern ( string $pattern ) : bool

过程化风格

numfmt_set_pattern ( NumberFormatter $fmt , string $pattern ) : bool

Set the pattern used by the formatter. Can not be used on a rule-based formatter.

参数

fmt

NumberFormatter object.

pattern

Pattern in syntax described in » ICU DecimalFormat documentation.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 numfmt_set_pattern() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Pattern: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_pattern($fmt, "#0.# kg");
echo "Pattern: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Pattern: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setPattern("#0.# kg");
echo "Pattern: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

以上例程会输出：

Pattern: #,##0.###
1.234.567,891
Pattern: #0.# kg
1234567,9 kg

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_create() - Create a number formatter
  • numfmt_get_pattern() - Get formatter pattern


Set a symbol value

  • ? NumberFormatter::setPattern
  • NumberFormatter::setTextAttribute ?
  • PHP Manual
  • NumberFormatter
  • Set a symbol value

NumberFormatter::setSymbol

numfmt_set_symbol

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setSymbol -- numfmt_set_symbol — Set a symbol value

说明

面向对象风格

public NumberFormatter::setSymbol ( int $attr , string $value ) : bool

过程化风格

numfmt_set_symbol ( NumberFormatter $fmt , int $attr , string $value ) : bool

Set a symbol associated with the formatter. The formatter uses symbols to represent the special locale-dependent characters in a number, for example the percent sign. This API is not supported for rule-based formatters.

参数

fmt

NumberFormatter object.

attr

Symbol specifier, one of the format symbol constants.

value

Text for the symbol.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 numfmt_set_symbol() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Sep: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Sep: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Sep: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Sep: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

以上例程会输出：

Sep: .
1.234.567,891
Sep: *
1*234*567,891

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_get_symbol() - Get a symbol value


Set a text attribute

  • ? NumberFormatter::setSymbol
  • Locale ?
  • PHP Manual
  • NumberFormatter
  • Set a text attribute

NumberFormatter::setTextAttribute

numfmt_set_text_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setTextAttribute -- numfmt_set_text_attribute — Set a text attribute

说明

面向对象风格

public NumberFormatter::setTextAttribute ( int $attr , string $value ) : bool

过程化风格

numfmt_set_text_attribute ( NumberFormatter $fmt , int $attr , string $value ) : bool

Set a text attribute associated with the formatter. An example of a text attribute is the suffix for positive numbers. If the formatter does not understand the attribute, U_UNSUPPORTED_ERROR error is produced. Rule-based formatters only understand NumberFormatter::DEFAULT_RULESET and NumberFormatter::PUBLIC_RULESETS.

参数

fmt

NumberFormatter object.

attr

Attribute specifier - one of the text attribute constants.

value

Text for the attribute value.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 numfmt_set_text_attribute() example

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo "Prefix: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
numfmt_set_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX, "MINUS");
echo "Prefix: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
?>

Example #2 OO example

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo "Prefix: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
$fmt->setTextAttribute(NumberFormatter::NEGATIVE_PREFIX, "MINUS");
echo "Prefix: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
?>

以上例程会输出：

Prefix: -
-1.234.567,891
Prefix: MINUS
MINUS1.234.567,891

参见

  • numfmt_get_error_code() - Get formatter's last error code
  • numfmt_get_text_attribute() - Get a text attribute
  • numfmt_set_attribute() - Set an attribute


The Locale class

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

简介

A "Locale" is an identifier used to get language, culture, or regionally-specific behavior from an API. PHP locales are organized and identified the same way that the CLDR locales used by ICU (and many vendors of Unix-like operating systems, the Mac, Java, and so forth) use. Locales are identified using RFC 4646 language tags (which use hyphen, not underscore) in addition to the more traditional underscore-using identifiers. Unless otherwise noted the functions in this class are tolerant of both formats.

Examples of identifiers include:

  • en-US (English, United States)
  • zh-Hant-TW (Chinese, Traditional Script, Taiwan)
  • fr-CA, fr-FR (French for Canada and France respectively)

The Locale class (and related procedural functions) are used to interact with locale identifiers--to verify that an ID is well-formed, valid, etc. The extensions used by CLDR in UAX #35 (and inherited by ICU) are valid and used wherever they would be in ICU normally.

Locales cannot be instantiated as objects. All of the functions/methods provided are static.

The null or empty string obtains the "root" locale. The "root" locale is equivalent to "en_US_POSIX" in CLDR. Language tags (and thus locale identifiers) are case insensitive. There exists a canonicalization function to make case match the specification.

类摘要

Locale {
/* 方法 */
public static acceptFromHttp ( string $header ) : string
public static canonicalize ( string $locale ) : string
public static composeLocale ( array $subtags ) : string
public static filterMatches ( string $langtag , string $locale , bool $canonicalize = false ) : bool
public static getAllVariants ( string $locale ) : array
public static getDefault ( ) : string
public static getDisplayLanguage ( string $locale , string $in_locale = ? ) : string
public static getDisplayName ( string $locale , string $in_locale = ? ) : string
public static getDisplayRegion ( string $locale , string $in_locale = ? ) : string
public static getDisplayScript ( string $locale , string $in_locale = ? ) : string
public static getDisplayVariant ( string $locale , string $in_locale = ? ) : string
public static getKeywords ( string $locale ) : array
public static getPrimaryLanguage ( string $locale ) : string
public static getRegion ( string $locale ) : string
public static getScript ( string $locale ) : string
public static lookup ( array $langtag , string $locale , bool $canonicalize = false , string $default = ? ) : string
public static parseLocale ( string $locale ) : array
public static setDefault ( string $locale ) : bool
}

预定义常量

Locale::DEFAULT_LOCALE (null)
Used as locale parameter with the methods of the various locale affected classes, such as NumberFormatter. This constant would make the methods to use default locale.

These constants describe the choice of the locale for the getLocale method of different classes.

Locale::ACTUAL_LOCALE (string)
This is locale the data actually comes from.
Locale::VALID_LOCALE (string)
This is the most specific locale supported by ICU.

These constants define how the Locales are parsed or composed. They should be used as keys in the argument array to locale_compose() and are returned from locale_parse() as keys of the returned associative array.

Locale::LANG_TAG (string)
Language subtag
Locale::EXTLANG_TAG (string)
Extended language subtag
Locale::SCRIPT_TAG (string)
Script subtag
Locale::REGION_TAG (string)
Region subtag
Locale::VARIANT_TAG (string)
Variant subtag
Locale::GRANDFATHERED_LANG_TAG (string)
Grandfathered Language subtag
Locale::PRIVATE_TAG (string)
Private subtag

参见

  • » RFC 4646 - Tags for Identifying Languages
  • » RFC 4647 - Matching of Language Tags
  • » Unicode CLDR Project:Common Locale Data Repository
  • » IANA Language Subtags Registry
  • » ICU User Guide - Locale
  • » ICU Locale api

Table of Contents

  • Locale::acceptFromHttp — Tries to find out best available locale based on HTTP "Accept-Language" header
  • Locale::canonicalize — Canonicalize the locale string
  • Locale::composeLocale — Returns a correctly ordered and delimited locale ID
  • Locale::filterMatches — Checks if a language tag filter matches with locale
  • Locale::getAllVariants — Gets the variants for the input locale
  • Locale::getDefault — Gets the default locale value from the INTL global 'default_locale'
  • Locale::getDisplayLanguage — Returns an appropriately localized display name for language of the inputlocale
  • Locale::getDisplayName — Returns an appropriately localized display name for the input locale
  • Locale::getDisplayRegion — Returns an appropriately localized display name for region of the input locale
  • Locale::getDisplayScript — Returns an appropriately localized display name for script of the input locale
  • Locale::getDisplayVariant — Returns an appropriately localized display name for variants of the input locale
  • Locale::getKeywords — Gets the keywords for the input locale
  • Locale::getPrimaryLanguage — Gets the primary language for the input locale
  • Locale::getRegion — Gets the region for the input locale
  • Locale::getScript — Gets the script for the input locale
  • Locale::lookup — Searches the language tag list for the best match to the language
  • Locale::parseLocale — Returns a key-value array of locale ID subtag elements
  • Locale::setDefault — Sets the default runtime locale


Tries to find out best available locale based on HTTP "Accept-Language" header

  • ? Locale
  • Locale::canonicalize ?
  • PHP Manual
  • Locale
  • Tries to find out best available locale based on HTTP "Accept-Language" header

Locale::acceptFromHttp

locale_accept_from_http

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::acceptFromHttp -- locale_accept_from_http — Tries to find out best available locale based on HTTP "Accept-Language" header

说明

面向对象风格

public static Locale::acceptFromHttp ( string $header ) : string

过程化风格

locale_accept_from_http ( string $header ) : string

Tries to find locale that can satisfy the language list that is requested by the HTTP "Accept-Language" header.

参数

header

The string containing the "Accept-Language" header according to format in RFC 2616.

返回值

The corresponding locale identifier.

范例

Example #1 locale_accept_from_http() example

<?php
$locale = locale_accept_from_http($_SERVER['HTTP_ACCEPT_LANGUAGE']);
echo $locale;
?>

Example #2 OO example

<?php
$locale = Locale::acceptFromHttp($_SERVER['HTTP_ACCEPT_LANGUAGE']);
echo $locale;
?>

以上例程会输出：

en_US

参见

  • locale_lookup() - Searches the language tag list for the best match to the language


Canonicalize the locale string

  • ? Locale::acceptFromHttp
  • Locale::composeLocale ?
  • PHP Manual
  • Locale
  • Canonicalize the locale string

Locale::canonicalize

locale_canonicalize

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::canonicalize -- locale_canonicalize — Canonicalize the locale string

说明

public static Locale::canonicalize ( string $locale ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

locale

返回值


Returns a correctly ordered and delimited locale ID

  • ? Locale::canonicalize
  • Locale::filterMatches ?
  • PHP Manual
  • Locale
  • Returns a correctly ordered and delimited locale ID

Locale::composeLocale

locale_compose

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::composeLocale -- locale_compose — Returns a correctly ordered and delimited locale ID

说明

面向对象风格

public static Locale::composeLocale ( array $subtags ) : string

过程化风格

locale_compose ( array $subtags ) : string

Returns a correctly ordered and delimited locale ID the keys identify the particular locale ID subtags, and the values are the associated subtag values.

参数

subtags

an array containing a list of key-value pairs, where the keys identify the particular locale ID subtags, and the values are the associated subtag values.

Note:

The 'variant' and 'private' subtags can take maximum 15 values whereas 'extlang' can take maximum 3 values.e.g. Variants are allowed with the suffix ranging from 0-14. Hence the keys for the input array can be variant0, variant1, ...,variant14. In the returned locale id, the subtag is ordered by suffix resulting in variant0 followed by variant1 followed by variant2 and so on.

The 'variant', 'private' and 'extlang' multiple values can be specified both as array under specific key (e.g. 'variant') and as multiple numbered keys (e.g. 'variant0', 'variant1', etc.).

返回值

The corresponding locale identifier.

范例

Example #1 locale_compose() example

<?php
$arr = array(
    'language'=>'en' ,
    'script'  =>'Hans' ,
    'region'  =>'CN',
    'variant2'=>'rozaj' ,
    'variant1'=>'nedis' ,
    'private1'=>'prv1' ,
    'private2'=>'prv2'
);
echo locale_compose( $arr );
?>

Example #2 OO example

<?php
$arr = array(
    'language'=>'en' ,
    'script'  =>'Hans' ,
    'region'  =>'CN',
    'variant2'=>'rozaj' ,
    'variant1'=>'nedis' ,
    'private1'=>'prv1' ,
    'private2'=>'prv2'
);
echo Locale::composeLocale( $arr );
?>

以上例程会输出：

Locale: en_Hans_CN_nedis_rozaj_x_prv1_prv2

参见

  • locale_parse() - Returns a key-value array of locale ID subtag elements


Checks if a language tag filter matches with locale

  • ? Locale::composeLocale
  • Locale::getAllVariants ?
  • PHP Manual
  • Locale
  • Checks if a language tag filter matches with locale

Locale::filterMatches

locale_filter_matches

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::filterMatches -- locale_filter_matches — Checks if a language tag filter matches with locale

说明

面向对象风格

public static Locale::filterMatches ( string $langtag , string $locale , bool $canonicalize = false ) : bool

过程化风格

locale_filter_matches ( string $langtag , string $locale , bool $canonicalize = false ) : bool

Checks if a $langtag filter matches with $locale according to RFC 4647's basic filtering algorithm

参数

langtag

The language tag to check

locale

The language range to check against

canonicalize

If true, the arguments will be converted to canonical form before matching.

返回值

true if $locale matches $langtag false otherwise.

范例

Example #1 locale_filter_matches() example

<?php
echo (locale_filter_matches('de-DEVA','de-DE', false)) ? "Matches" : "Does not match";
echo '; ';
echo (locale_filter_matches('de-DE_1996','de-DE', false)) ? "Matches" : "Does not match";
?>

Example #2 OO example

<?php
echo (Locale::filterMatches('de-DEVA','de-DE', false)) ? "Matches" : "Does not match";
echo '; ';
echo (Locale::filterMatches('de-DE-1996','de-DE', false)) ? "Matches" : "Does not match";
?>

以上例程会输出：

Does not match; Matches

参见

  • locale_lookup() - Searches the language tag list for the best match to the language


Gets the variants for the input locale

  • ? Locale::filterMatches
  • Locale::getDefault ?
  • PHP Manual
  • Locale
  • Gets the variants for the input locale

Locale::getAllVariants

locale_get_all_variants

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getAllVariants -- locale_get_all_variants — Gets the variants for the input locale

说明

面向对象风格

public static Locale::getAllVariants ( string $locale ) : array

过程化风格

locale_get_all_variants ( string $locale ) : array

Gets the variants for the input locale

参数

locale

The locale to extract the variants from

返回值

The array containing the list of all variants subtag for the locale or null if not present

范例

Example #1 locale_get_all_variants() example

<?php
$arr = locale_get_all_variants('sl_IT_NEDIS_ROJAZ_1901');
var_export( $arr );
?>

Example #2 OO example

<?php
 $arr = Locale::getAllVariants('sl_IT_NEDIS_ROJAZ_1901');
 var_export( $arr );
?>

以上例程会输出：

array (
    0 => 'NEDIS',
    1 => 'ROJAZ',
    2 => '1901',
)

参见

  • locale_get_primary_language() - Gets the primary language for the input locale
  • locale_get_script() - Gets the script for the input locale
  • locale_get_region() - Gets the region for the input locale


Gets the default locale value from the INTL global 'default_locale'

  • ? Locale::getAllVariants
  • Locale::getDisplayLanguage ?
  • PHP Manual
  • Locale
  • Gets the default locale value from the INTL global 'default_locale'

Locale::getDefault

locale_get_default

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDefault -- locale_get_default — Gets the default locale value from the INTL global 'default_locale'

说明

面向对象风格

public static Locale::getDefault ( ) : string

过程化风格

locale_get_default ( ) : string

Gets the default locale value. At the PHP initialization this value is set to 'intl.default_locale' value from php.ini if that value exists or from ICU's function uloc_getDefault().

参数

返回值

The current runtime locale

范例

Example #1 locale_get_default() example

<?php
ini_set('intl.default_locale', 'de-DE');
echo locale_get_default();
echo '; ';
locale_set_default('fr');
echo locale_get_default();
?>

Example #2 OO example

<?php
ini_set('intl.default_locale', 'de-DE');
echo Locale::getDefault();
echo '; ';
Locale::setDefault('fr');
echo Locale::getDefault();
?>

以上例程会输出：

de-DE; fr

参见

  • locale_set_default() - Sets the default runtime locale


Returns an appropriately localized display name for language of the inputlocale

  • ? Locale::getDefault
  • Locale::getDisplayName ?
  • PHP Manual
  • Locale
  • Returns an appropriately localized display name for language of the inputlocale

Locale::getDisplayLanguage

locale_get_display_language

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayLanguage -- locale_get_display_language — Returns an appropriately localized display name for language of the inputlocale

说明

面向对象风格

public static Locale::getDisplayLanguage ( string $locale , string $in_locale = ? ) : string

过程化风格

locale_get_display_language ( string $locale , string $in_locale = ? ) : string

Returns an appropriately localized display name for language of the input locale. If is null then the default locale is used.

参数

locale

The locale to return a display language for

in_locale

Optional format locale to use to display the language name

返回值

display name of the language for the $locale in the format appropriate for $in_locale.

范例

Example #1 locale_get_display_language() example

<?php
echo locale_get_display_language('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_language('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_language('sl-Latn-IT-nedis', 'de');
?>

Example #2 OO example

<?php
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'de');
?>

以上例程会输出：

Slovenian;
slov\xc3\xa8ne;
Slowenisch

参见

  • locale_get_display_name() - Returns an appropriately localized display name for the input locale
  • locale_get_display_script() - Returns an appropriately localized display name for script of the input locale
  • locale_get_display_region() - Returns an appropriately localized display name for region of the input locale
  • locale_get_display_variant() - Returns an appropriately localized display name for variants of the input locale


Returns an appropriately localized display name for the input locale

  • ? Locale::getDisplayLanguage
  • Locale::getDisplayRegion ?
  • PHP Manual
  • Locale
  • Returns an appropriately localized display name for the input locale

Locale::getDisplayName

locale_get_display_name

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayName -- locale_get_display_name — Returns an appropriately localized display name for the input locale

说明

面向对象风格

public static Locale::getDisplayName ( string $locale , string $in_locale = ? ) : string

过程化风格

locale_get_display_name ( string $locale , string $in_locale = ? ) : string

Returns an appropriately localized display name for the input locale. If $locale is null then the default locale is used.

参数

locale

The locale to return a display name for.

in_locale

optional format locale

返回值

Display name of the locale in the format appropriate for $in_locale.

范例

Example #1 locale_get_display_name() example

<?php
echo locale_get_display_name('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_name('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_name('sl-Latn-IT-nedis', 'de');
?>

Example #2 OO example

<?php
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'de');
?>

以上例程会输出：

Slovenian (Latin, Italy, Natisone dialect);
slov\xc3\xa8ne (latin, Italie, dialecte de Natisone;
Slowenisch (Lateinisch, Italien, NEDIS)

参见

  • locale_get_display_language() - Returns an appropriately localized display name for language of the inputlocale
  • locale_get_display_script() - Returns an appropriately localized display name for script of the input locale
  • locale_get_display_region() - Returns an appropriately localized display name for region of the input locale
  • locale_get_display_variant() - Returns an appropriately localized display name for variants of the input locale


Returns an appropriately localized display name for region of the input locale

  • ? Locale::getDisplayName
  • Locale::getDisplayScript ?
  • PHP Manual
  • Locale
  • Returns an appropriately localized display name for region of the input locale

Locale::getDisplayRegion

locale_get_display_region

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayRegion -- locale_get_display_region — Returns an appropriately localized display name for region of the input locale

说明

面向对象风格

public static Locale::getDisplayRegion ( string $locale , string $in_locale = ? ) : string

过程化风格

locale_get_display_region ( string $locale , string $in_locale = ? ) : string

Returns an appropriately localized display name for region of the input locale. If is null then the default locale is used.

参数

locale

The locale to return a display region for.

in_locale

Optional format locale to use to display the region name

返回值

display name of the region for the $locale in the format appropriate for $in_locale.

范例

Example #1 locale_get_display_region() example

<?php
echo locale_get_display_region('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_region('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_region('sl-Latn-IT-nedis', 'de');
?>

Example #2 OO example

<?php
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'de');
?>

以上例程会输出：

Italy;
Italie;
Italien

参见

  • locale_get_display_name() - Returns an appropriately localized display name for the input locale
  • locale_get_display_language() - Returns an appropriately localized display name for language of the inputlocale
  • locale_get_display_script() - Returns an appropriately localized display name for script of the input locale
  • locale_get_display_variant() - Returns an appropriately localized display name for variants of the input locale


Returns an appropriately localized display name for script of the input locale

  • ? Locale::getDisplayRegion
  • Locale::getDisplayVariant ?
  • PHP Manual
  • Locale
  • Returns an appropriately localized display name for script of the input locale

Locale::getDisplayScript

locale_get_display_script

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayScript -- locale_get_display_script — Returns an appropriately localized display name for script of the input locale

说明

面向对象风格

public static Locale::getDisplayScript ( string $locale , string $in_locale = ? ) : string

过程化风格

locale_get_display_script ( string $locale , string $in_locale = ? ) : string

Returns an appropriately localized display name for script of the input locale. If is null then the default locale is used.

参数

locale

The locale to return a display script for

in_locale

Optional format locale to use to display the script name

返回值

Display name of the script for the $locale in the format appropriate for $in_locale.

范例

Example #1 locale_get_display_script() example

<?php
echo locale_get_display_script('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_script('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_script('sl-Latn-IT-nedis', 'de');
?>

Example #2 OO example

<?php
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'de');
?>

以上例程会输出：

Latin;
latin;
Lateinisch

参见

  • locale_get_display_name() - Returns an appropriately localized display name for the input locale
  • locale_get_display_language() - Returns an appropriately localized display name for language of the inputlocale
  • locale_get_display_region() - Returns an appropriately localized display name for region of the input locale
  • locale_get_display_variant() - Returns an appropriately localized display name for variants of the input locale


Returns an appropriately localized display name for variants of the input locale

  • ? Locale::getDisplayScript
  • Locale::getKeywords ?
  • PHP Manual
  • Locale
  • Returns an appropriately localized display name for variants of the input locale

Locale::getDisplayVariant

locale_get_display_variant

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayVariant -- locale_get_display_variant — Returns an appropriately localized display name for variants of the input locale

说明

面向对象风格

public static Locale::getDisplayVariant ( string $locale , string $in_locale = ? ) : string

过程化风格

locale_get_display_variant ( string $locale , string $in_locale = ? ) : string

Returns an appropriately localized display name for variants of the input locale. If is null then the default locale is used.

参数

locale

The locale to return a display variant for

in_locale

Optional format locale to use to display the variant name

返回值

Display name of the variant for the $locale in the format appropriate for $in_locale.

范例

Example #1 locale_get_display_variant() example

<?php
echo locale_get_display_variant('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_variant('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_variant('sl-Latn-IT-nedis', 'de');
?>

Example #2 OO example

<?php
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'de');
?>

以上例程会输出：

Natisone dialect;
dialecte de Natisone;
NEDIS

参见

  • locale_get_display_name() - Returns an appropriately localized display name for the input locale
  • locale_get_display_language() - Returns an appropriately localized display name for language of the inputlocale
  • locale_get_display_script() - Returns an appropriately localized display name for script of the input locale
  • locale_get_display_region() - Returns an appropriately localized display name for region of the input locale


Gets the keywords for the input locale

  • ? Locale::getDisplayVariant
  • Locale::getPrimaryLanguage ?
  • PHP Manual
  • Locale
  • Gets the keywords for the input locale

Locale::getKeywords

locale_get_keywords

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getKeywords -- locale_get_keywords — Gets the keywords for the input locale

说明

面向对象风格

public static Locale::getKeywords ( string $locale ) : array

过程化风格

locale_get_keywords ( string $locale ) : array

Gets the keywords for the input locale.

参数

locale

The locale to extract the keywords from

返回值

Associative array containing the keyword-value pairs for this locale

范例

Example #1 locale_get_keywords() example

<?php
$keywords_arr = locale_get_keywords('de_DE@currency=EUR;collation=PHONEBOOK');
if ($keywords_arr) {
    foreach ($keywords_arr as $key => $value) {
        echo "$key = $value\n";
    }
}
?>

Example #2 OO example

<?php
$keywords_arr = Locale::getKeywords('de_DE@currency=EUR;collation=PHONEBOOK');
if ($keywords_arr) {
    foreach ($keywords_arr as $key => $value) {
        echo "$key = $value\n";
    }
}
?>

以上例程会输出：

collation = PHONEBOOK
currency = EUR

参见

  • locale_get_all_variants() - Gets the variants for the input locale


Gets the primary language for the input locale

  • ? Locale::getKeywords
  • Locale::getRegion ?
  • PHP Manual
  • Locale
  • Gets the primary language for the input locale

Locale::getPrimaryLanguage

locale_get_primary_language

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getPrimaryLanguage -- locale_get_primary_language — Gets the primary language for the input locale

说明

面向对象风格

public static Locale::getPrimaryLanguage ( string $locale ) : string

过程化风格

locale_get_primary_language ( string $locale ) : string

Gets the primary language for the input locale

参数

locale

The locale to extract the primary language code from

返回值

The language code associated with the language or null in case of error.

范例

Example #1 locale_get_primary_language() example

<?php
echo locale_get_primary_language('zh-Hant');
?>

Example #2 OO example

<?php
echo Locale::getPrimaryLanguage('zh-Hant');
?>

以上例程会输出：

zh

参见

  • locale_get_script() - Gets the script for the input locale
  • locale_get_region() - Gets the region for the input locale
  • locale_get_all_variants() - Gets the variants for the input locale


Gets the region for the input locale

  • ? Locale::getPrimaryLanguage
  • Locale::getScript ?
  • PHP Manual
  • Locale
  • Gets the region for the input locale

Locale::getRegion

locale_get_region

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getRegion -- locale_get_region — Gets the region for the input locale

说明

面向对象风格

public static Locale::getRegion ( string $locale ) : string

过程化风格

locale_get_region ( string $locale ) : string

Gets the region for the input locale.

参数

locale

The locale to extract the region code from

返回值

The region subtag for the locale or null if not present

范例

Example #1 locale_get_region() example

<?php
echo locale_get_region('de-CH-1901');
?>

Example #2 OO example

<?php
echo Locale::getRegion('de-CH-1901');
?>

以上例程会输出：

CH

参见

  • locale_get_primary_language() - Gets the primary language for the input locale
  • locale_get_script() - Gets the script for the input locale
  • locale_get_all_variants() - Gets the variants for the input locale


Gets the script for the input locale

  • ? Locale::getRegion
  • Locale::lookup ?
  • PHP Manual
  • Locale
  • Gets the script for the input locale

Locale::getScript

locale_get_script

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getScript -- locale_get_script — Gets the script for the input locale

说明

面向对象风格

public static Locale::getScript ( string $locale ) : string

过程化风格

locale_get_script ( string $locale ) : string

Gets the script for the input locale.

参数

locale

The locale to extract the script code from

返回值

The script subtag for the locale or null if not present

范例

Example #1 locale_get_script() example

<?php
echo locale_get_script('sr-Cyrl');
?>

Example #2 OO example

<?php
echo Locale::getScript('sr-Cyrl');
?>

以上例程会输出：

Cyrl

参见

  • locale_get_primary_language() - Gets the primary language for the input locale
  • locale_get_region() - Gets the region for the input locale
  • locale_get_all_variants() - Gets the variants for the input locale


Searches the language tag list for the best match to the language

  • ? Locale::getScript
  • Locale::parseLocale ?
  • PHP Manual
  • Locale
  • Searches the language tag list for the best match to the language

Locale::lookup

locale_lookup

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::lookup -- locale_lookup — Searches the language tag list for the best match to the language

说明

面向对象风格

public static Locale::lookup ( array $langtag , string $locale , bool $canonicalize = false , string $default = ? ) : string

过程化风格

locale_lookup ( array $langtag , string $locale , bool $canonicalize = false , string $default = ? ) : string

Searches the items in langtag for the best match to the language range specified in locale according to RFC 4647's lookup algorithm.

参数

langtag

An array containing a list of language tags to compare to locale. Maximum 100 items allowed.

locale

The locale to use as the language range when matching.

canonicalize

If true, the arguments will be converted to canonical form before matching.

default

The locale to use if no match is found.

返回值

The closest matching language tag or default value.

范例

Example #1 locale_lookup() example

<?php
$arr = array(
    'de-DEVA',
    'de-DE-1996',
    'de',
    'de-De'
);
echo locale_lookup($arr, 'de-DE-1996-x-prv1-prv2', true, 'en_US');
?>

Example #2 OO example

<?php
$arr = array(
    'de-DEVA',
    'de-DE-1996',
    'de',
    'de-De'
);
echo Locale::lookup($arr, 'de-DE-1996-x-prv1-prv2', true, 'en_US');
?>

以上例程会输出：

de_de_1996

参见

  • locale_filter_matches() - Checks if a language tag filter matches with locale


Returns a key-value array of locale ID subtag elements

  • ? Locale::lookup
  • Locale::setDefault ?
  • PHP Manual
  • Locale
  • Returns a key-value array of locale ID subtag elements

Locale::parseLocale

locale_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::parseLocale -- locale_parse — Returns a key-value array of locale ID subtag elements

说明

面向对象风格

public static Locale::parseLocale ( string $locale ) : array

过程化风格

locale_parse ( string $locale ) : array

Returns a key-value array of locale ID subtag elements.

参数

locale

The locale to extract the subtag array from. Note: The 'variant' and 'private' subtags can take maximum 15 values whereas 'extlang' can take maximum 3 values.

返回值

Returns an array containing a list of key-value pairs, where the keys identify the particular locale ID subtags, and the values are the associated subtag values. The array will be ordered as the locale id subtags e.g. in the locale id if variants are '-varX-varY-varZ' then the returned array will have variant0=>varX , variant1=>varY , variant2=>varZ

Returns null when the length of locale exceeds INTL_MAX_LOCALE_LEN.

范例

Example #1 locale_parse() example

<?php
$arr = locale_parse('sl-Latn-IT-nedis');
if ($arr) {
    foreach ($arr as $key => $value) {
        echo "$key : $value , ";
    }
}
?>

Example #2 OO example

<?php
$arr = Locale::parseLocale('sl-Latn-IT-nedis');
if ($arr) {
    foreach ($arr as $key => $value) {
        echo "$key : $value , ";
    }
}
?>

以上例程会输出：

language : sl , script : Latn , region : IT , variant0 : NEDIS ,

参见

  • locale_compose() - Returns a correctly ordered and delimited locale ID


Sets the default runtime locale

  • ? Locale::parseLocale
  • Normalizer ?
  • PHP Manual
  • Locale
  • Sets the default runtime locale

Locale::setDefault

locale_set_default

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::setDefault -- locale_set_default — Sets the default runtime locale

说明

面向对象风格

public static Locale::setDefault ( string $locale ) : bool

过程化风格

locale_set_default ( string $locale ) : bool

Sets the default runtime locale to $locale. This changes the value of INTL global 'default_locale' locale identifier. UAX #35 extensions are accepted.

参数

locale

Is a BCP 47 compliant language tag.

返回值

Returns true.

范例

Example #1 locale_set_default() example

<?php
locale_set_default('de-DE');
echo locale_get_default();
?>

Example #2 OO example

<?php
Locale::setDefault('de-DE');
echo Locale::getDefault();
?>

以上例程会输出：

de-DE

参见

  • locale_get_default() - Gets the default locale value from the INTL global 'default_locale'


The Normalizer class

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

简介

Normalization is a process that involves transforming characters and sequences of characters into a formally-defined underlying representation. This process is most important when text needs to be compared for sorting and searching, but it is also used when storing text to ensure that the text is stored in a consistent representation.

The Unicode Consortium has defined a number of normalization forms reflecting the various needs of applications:

  • Normalization Form D (NFD) - Canonical Decomposition
  • Normalization Form C (NFC) - Canonical Decomposition followed by Canonical Composition
  • Normalization Form KD (NFKD) - Compatibility Decomposition
  • Normalization Form KC (NFKC) - Compatibility Decomposition followed by Canonical Composition
The different forms are defined in terms of a set of transformations on the text, transformations that are expressed by both an algorithm and a set of data files.

类摘要

Normalizer {
/* 方法 */
public static getRawDecomposition ( string $input ) : string
public static isNormalized ( string $input , int $form = Normalizer::FORM_C ) : bool
public static normalize ( string $input , int $form = Normalizer::FORM_C ) : string
}

预定义常量

The following constants define the normalization form used by the normalizer:

Normalizer::FORM_C (int)
Normalization Form C (NFC) - Canonical Decomposition followed by Canonical Composition
Normalizer::FORM_D (int)
Normalization Form D (NFD) - Canonical Decomposition
Normalizer::FORM_KC (int)
Normalization Form KC (NFKC) - Compatibility Decomposition, followed by Canonical Composition
Normalizer::FORM_KD (int)
Normalization Form KD (NFKD) - Compatibility Decomposition
Normalizer::NONE (int)
No decomposition/composition
Normalizer::OPTION_DEFAULT (int)
Default normalization options

参见

  • » Unicode Normalization
  • » Unicode Normalization FAQ
  • » ICU User Guide - Normalization
  • » ICU API Reference - Normalization

Table of Contents

  • Normalizer::getRawDecomposition — Gets the Decomposition_Mapping property for the given UTF-8 encoded code point
  • Normalizer::isNormalized — Checks if the provided string is already in the specified normalization form
  • Normalizer::normalize — Normalizes the input provided and returns the normalized string


Gets the Decomposition_Mapping property for the given UTF-8 encoded code point

  • ? Normalizer
  • Normalizer::isNormalized ?
  • PHP Manual
  • Normalizer
  • Gets the Decomposition_Mapping property for the given UTF-8 encoded code point

Normalizer::getRawDecomposition

normalizer_get_raw_decomposition

(PHP 7 >= 7.3)

Normalizer::getRawDecomposition -- normalizer_get_raw_decomposition — Gets the Decomposition_Mapping property for the given UTF-8 encoded code point

说明

面向对象风格

public static Normalizer::getRawDecomposition ( string $input ) : string

过程化风格

normalizer_get_raw_decomposition ( string $input ) : string

Gets the Decomposition_Mapping property, as specified in the Unicode Character Database (UCD), for the given UTF-8 encoded code point.

参数

input

The input string, which should be a single, UTF-8 encoded, code point.

返回值

Returns a string containing the Decomposition_Mapping property, if present in the UCD.

Returns null if there is no Decomposition_Mapping property for the character.

范例

Example #1 Normalizer::getRawDecomposition() example

<?php

$result = "";
$strings = [
    "a",
    "\u{FFDA}",
    "\u{FDFA}",
    "",
    "aa",
    "\xF5",
];

foreach ($strings as $string) {
    $decomposition = Normalizer::getRawDecomposition($string);
    // $decomposition = normalizer_get_raw_decomposition($string); Procedural way

    $error_code = intl_get_error_code();
    $error_message = intl_get_error_message();

    $string_hex = bin2hex($string);
    $result .= "---------------------\n";

    if ($decomposition === null) {
        $result .= "'$string_hex' has no decomposition mapping\n" ;
    } else {
        $result .= "'$string_hex' has the decomposition mapping '" . bin2hex($decomposition) . "'\n" ;
    }

    $result .= "error info: '$error_message' ($error_code)\n";
}

echo $result;
?>

以上例程会输出：

---------------------
'61' has no decomposition mapping
error info: 'U_ZERO_ERROR' (0)
---------------------
'efbf9a' has the decomposition mapping 'e385a1'
error info: 'U_ZERO_ERROR' (0)
---------------------
'efb7ba' has the decomposition mapping 'd8b5d984d98920d8a7d984d984d98720d8b9d984d98ad98720d988d8b3d984d985'
error info: 'U_ZERO_ERROR' (0)
---------------------
'' has no decomposition mapping
error info: 'Input string must be exactly one UTF-8 encoded code point long.: U_ILLEGAL_ARGUMENT_ERROR' (1)
---------------------
'6161' has no decomposition mapping
error info: 'Input string must be exactly one UTF-8 encoded code point long.: U_ILLEGAL_ARGUMENT_ERROR' (1)
---------------------
'f5' has no decomposition mapping
error info: 'Code point out of range: U_ILLEGAL_ARGUMENT_ERROR' (1)

参见

  • Normalizer::normalize() - Normalizes the input provided and returns the normalized string
  • Normalizer::isNormalized() - Checks if the provided string is already in the specified normalization form


Checks if the provided string is already in the specified normalization form

  • ? Normalizer::getRawDecomposition
  • Normalizer::normalize ?
  • PHP Manual
  • Normalizer
  • Checks if the provided string is already in the specified normalization form

Normalizer::isNormalized

normalizer_is_normalized

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Normalizer::isNormalized -- normalizer_is_normalized — Checks if the provided string is already in the specified normalization form

说明

面向对象风格

public static Normalizer::isNormalized ( string $input , int $form = Normalizer::FORM_C ) : bool

过程化风格

normalizer_is_normalized ( string $input , int $form = Normalizer::FORM_C ) : bool

Checks if the provided string is already in the specified normalization form.

参数

input

The input string to normalize

form

One of the normalization forms.

返回值

true if normalized, false otherwise or if there an error

范例

Example #1 normalizer_is_normalized() example

<?php
$char_A_ring = "\xC3\x85"; // 'LATIN CAPITAL LETTER A WITH RING ABOVE' (U+00C5)
$char_combining_ring_above = "\xCC\x8A";  // 'COMBINING RING ABOVE' (U+030A)

$char_orig = 'A' . $char_combining_ring_above;
$char_norm = normalizer_normalize( 'A' . $char_combining_ring_above, Normalizer::FORM_C );

echo ( normalizer_is_normalized($char_orig, Normalizer::FORM_C) ) ? "normalized" : "not normalized";
echo '; ';
echo ( normalizer_is_normalized($char_norm, Normalizer::FORM_C) ) ? "normalized" : "not normalized";
?>

Example #2 OO example

<?php
$char_A_ring = "\xC3\x85"; // 'LATIN CAPITAL LETTER A WITH RING ABOVE' (U+00C5)
$char_combining_ring_above = "\xCC\x8A";  // 'COMBINING RING ABOVE' (U+030A)

$char_orig = 'A' . $char_combining_ring_above;
$char_norm = Normalizer::normalize( 'A' . $char_combining_ring_above, Normalizer::FORM_C );

echo ( Normalizer::isNormalized($char_orig, Normalizer::FORM_C) ) ? "normalized" : "not normalized";
echo '; ';
echo ( Normalizer::isNormalized($char_norm, Normalizer::FORM_C) ) ? "normalized" : "not normalized";
?>

以上例程会输出：

not normalized; normalized

参见

  • normalizer_normalize() - Normalizes the input provided and returns the normalized string


Normalizes the input provided and returns the normalized string

  • ? Normalizer::isNormalized
  • MessageFormatter ?
  • PHP Manual
  • Normalizer
  • Normalizes the input provided and returns the normalized string

Normalizer::normalize

normalizer_normalize

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Normalizer::normalize -- normalizer_normalize — Normalizes the input provided and returns the normalized string

说明

面向对象风格

public static Normalizer::normalize ( string $input , int $form = Normalizer::FORM_C ) : string

过程化风格

normalizer_normalize ( string $input , int $form = Normalizer::FORM_C ) : string

Normalizes the input provided and returns the normalized string

参数

input

The input string to normalize

form

One of the normalization forms.

返回值

The normalized string or false if an error occurred.

范例

Example #1 normalizer_normalize() example

<?php
$char_A_ring = "\xC3\x85"; // 'LATIN CAPITAL LETTER A WITH RING ABOVE' (U+00C5)
$char_combining_ring_above = "\xCC\x8A";  // 'COMBINING RING ABOVE' (U+030A)

$char_1 = normalizer_normalize( $char_A_ring, Normalizer::FORM_C );
$char_2 = normalizer_normalize( 'A' . $char_combining_ring_above, Normalizer::FORM_C );

echo urlencode($char_1);
echo ' ';
echo urlencode($char_2);
?>

Example #2 OO example

<?php
$char_A_ring = "\xC3\x85"; // 'LATIN CAPITAL LETTER A WITH RING ABOVE' (U+00C5)
$char_combining_ring_above = "\xCC\x8A";  // 'COMBINING RING ABOVE' (U+030A)

$char_1 = Normalizer::normalize( $char_A_ring, Normalizer::FORM_C );
$char_2 = Normalizer::normalize( 'A' . $char_combining_ring_above, Normalizer::FORM_C );

echo urlencode($char_1);
echo ' ';
echo urlencode($char_2);
?>

以上例程会输出：

%C3%85 %C3%85

参见

  • normalizer_is_normalized() - Checks if the provided string is already in the specified normalization form


The MessageFormatter class

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

简介

MessageFormatter is a concrete class that enables users to produce concatenated, language-neutral messages. The methods supplied in this class are used to build all the messages that are seen by end users.

The MessageFormatter class assembles messages from various fragments (such as text fragments, numbers, and dates) supplied by the program. Because of the MessageFormatter class, the program does not need to know the order of the fragments. The class uses the formatting specifications for the fragments to assemble them into a message that is contained in a single string within a resource bundle. For example, MessageFormatter enables you to print the phrase "Finished printing x out of y files..." in a manner that still allows for flexibility in translation.

Previously, an end user message was created as a sentence and handled as a string. This procedure created problems for localizers because the sentence structure, word order, number format and so on are very different from language to language. The language-neutral way to create messages keeps each part of the message separate and provides keys to the data. Using these keys, the MessageFormatter class can concatenate the parts of the message, localize them, and display a well-formed string to the end user.

MessageFormatter takes a set of objects, formats them, and then inserts the formatted strings into the pattern at the appropriate places. Choice formats can be used in conjunction with MessageFormatter to handle plurals, match numbers, and select from an array of items. Typically, the message format will come from resources and the arguments will be dynamically set at runtime.

类摘要

MessageFormatter {
/* 方法 */
public __construct ( string $locale , string $pattern )
public static create ( string $locale , string $pattern ) : MessageFormatter
public static formatMessage ( string $locale , string $pattern , array $args ) : string
public format ( array $args ) : string
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getLocale ( ) : string
public getPattern ( ) : string
public static parseMessage ( string $locale , string $pattern , string $source ) : array
public parse ( string $value ) : array
public setPattern ( string $pattern ) : bool
}

参见

  • » ICU formatting documentation
  • » ICU message formatting description
  • » ICU message formatters
  • » ICU choice formatters

Table of Contents

  • MessageFormatter::create — Constructs a new Message Formatter
  • MessageFormatter::formatMessage — Quick format message
  • MessageFormatter::format — Format the message
  • MessageFormatter::getErrorCode — Get the error code from last operation
  • MessageFormatter::getErrorMessage — Get the error text from the last operation
  • MessageFormatter::getLocale — Get the locale for which the formatter was created
  • MessageFormatter::getPattern — Get the pattern used by the formatter
  • MessageFormatter::parseMessage — Quick parse input string
  • MessageFormatter::parse — Parse input string according to pattern
  • MessageFormatter::setPattern — Set the pattern used by the formatter


Constructs a new Message Formatter

  • ? MessageFormatter
  • MessageFormatter::formatMessage ?
  • PHP Manual
  • MessageFormatter
  • Constructs a new Message Formatter

MessageFormatter::create

MessageFormatter::__construct

msgfmt_create

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::create -- MessageFormatter::__construct -- msgfmt_create — Constructs a new Message Formatter

说明

面向对象风格 (method)

public static MessageFormatter::create ( string $locale , string $pattern ) : MessageFormatter

面向对象风格 (constructor):

public MessageFormatter::__construct ( string $locale , string $pattern )

过程化风格

msgfmt_create ( string $locale , string $pattern ) : MessageFormatter

Constructs a new Message Formatter

参数

locale

The locale to use when formatting arguments

pattern

The pattern string to stick arguments into. The pattern uses an 'apostrophe-friendly' syntax; it is run through » umsg_autoQuoteApostrophe before being interpreted.

返回值

The formatter object

错误／异常

When invoked as constructor, on failure an IntlException is thrown.

范例

Example #1 msgfmt_create() example

<?php
$fmt = msgfmt_create("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
$fmt = msgfmt_create("de", "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
?>

Example #2 OO example

<?php
$fmt = new MessageFormatter("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
echo $fmt->format(array(4560, 123, 4560/123));
$fmt = new MessageFormatter("de", "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum");
echo $fmt->format(array(4560, 123, 4560/123));
?>

以上例程会输出：

4,560 monkeys on 123 trees make 37.073 monkeys per tree
4.560 Affen auf 123 B?umen sind 37,073 Affen pro Baum

参见

  • msgfmt_format() - Format the message
  • msgfmt_parse() - Parse input string according to pattern
  • msgfmt_get_error_code() - Get the error code from last operation
  • msgfmt_get_error_message() - Get the error text from the last operation


Quick format message

  • ? MessageFormatter::create
  • MessageFormatter::format ?
  • PHP Manual
  • MessageFormatter
  • Quick format message

MessageFormatter::formatMessage

msgfmt_format_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::formatMessage -- msgfmt_format_message — Quick format message

说明

面向对象风格

public static MessageFormatter::formatMessage ( string $locale , string $pattern , array $args ) : string

过程化风格

msgfmt_format_message ( string $locale , string $pattern , array $args ) : string

Quick formatting function that formats the string without having to explicitly create the formatter object. Use this function when the format operation is done only once and does not need and parameters or state to be kept.

参数

locale

The locale to use for formatting locale-dependent parts

pattern

The pattern string to insert things into. The pattern uses an 'apostrophe-friendly' syntax; it is run through » umsg_autoQuoteApostrophe before being interpreted.

args

The array of values to insert into the format string

返回值

The formatted pattern string or false if an error occurred

范例

Example #1 msgfmt_format_message() example

<?php
echo msgfmt_format_message("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree\n", array(4560, 123, 4560/123));
echo msgfmt_format_message("de", "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum\n", array(4560, 123, 4560/123));
?>

Example #2 OO example

<?php
echo MessageFormatter::formatMessage("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree\n", array(4560, 123, 4560/123));
echo MessageFormatter::formatMessage("de", "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum\n", array(4560, 123, 4560/123));
?>

以上例程会输出：

4,560 monkeys on 123 trees make 37.073 monkeys per tree
4.560 Affen auf 123 B?umen sind 37,073 Affen pro Baum

参见

  • msgfmt_create() - Constructs a new Message Formatter
  • msgfmt_parse() - Parse input string according to pattern
  • msgfmt_get_error_code() - Get the error code from last operation
  • msgfmt_get_error_message() - Get the error text from the last operation


Format the message

  • ? MessageFormatter::formatMessage
  • MessageFormatter::getErrorCode ?
  • PHP Manual
  • MessageFormatter
  • Format the message

MessageFormatter::format

msgfmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::format -- msgfmt_format — Format the message

说明

面向对象风格

public MessageFormatter::format ( array $args ) : string

过程化风格

msgfmt_format ( MessageFormatter $fmt , array $args ) : string

Format the message by substituting the data into the format string according to the locale rules

参数

fmt

The message formatter

args

Arguments to insert into the format string

返回值

The formatted string, or false if an error occurred

范例

Example #1 msgfmt_format() example

<?php
$fmt = msgfmt_create("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
$fmt = msgfmt_create("de", "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
?>

Example #2 OO example

<?php
$fmt = new MessageFormatter("en_US", "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
echo $fmt->format(array(4560, 123, 4560/123));
$fmt = new MessageFormatter("de", "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum");
echo $fmt->format(array(4560, 123, 4560/123));
?>

以上例程会输出：

4,560 monkeys on 123 trees make 37.073 monkeys per tree
4.560 Affen auf 123 B?umen sind 37,073 Affen pro Baum

参见

  • msgfmt_create() - Constructs a new Message Formatter
  • msgfmt_parse() - Parse input string according to pattern
  • msgfmt_format_message() - Quick format message
  • msgfmt_get_error_code() - Get the error code from last operation
  • msgfmt_get_error_message() - Get the error text from the last operation


Get the error code from last operation

  • ? MessageFormatter::format
  • MessageFormatter::getErrorMessage ?
  • PHP Manual
  • MessageFormatter
  • Get the error code from last operation

MessageFormatter::getErrorCode

msgfmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getErrorCode -- msgfmt_get_error_code — Get the error code from last operation

说明

面向对象风格

public MessageFormatter::getErrorCode ( ) : int

过程化风格

msgfmt_get_error_code ( MessageFormatter $fmt ) : int

Get the error code from last operation.

参数

fmt

The message formatter

返回值

The error code, one of UErrorCode values. Initial value is U_ZERO_ERROR.

参见

  • msgfmt_get_error_message() - Get the error text from the last operation
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure


Get the error text from the last operation

  • ? MessageFormatter::getErrorCode
  • MessageFormatter::getLocale ?
  • PHP Manual
  • MessageFormatter
  • Get the error text from the last operation

MessageFormatter::getErrorMessage

msgfmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getErrorMessage -- msgfmt_get_error_message — Get the error text from the last operation

说明

面向对象风格

public MessageFormatter::getErrorMessage ( ) : string

过程化风格

msgfmt_get_error_message ( MessageFormatter $fmt ) : string

Get the error text from the last operation.

参数

fmt

The message formatter

返回值

Description of the last error.

范例

Example #1 msgfmt_get_error_message() example

<?php
$fmt = msgfmt_create("en_US", "{0, number} monkeys on {1, number} trees");
$str = msgfmt_format($fmt, array());
if(!$str) {
    echo "ERROR: ".msgfmt_get_error_message($fmt) . " (" . msgfmt_get_error_code($fmt) . ")\n";
}
?>

Example #2 OO example

<?php
$fmt = new MessageFormatter("en_US", "{0, number} monkeys on {1, number} trees");
$str = $fmt->format(array());
if(!$str) {
    echo "ERROR: ".$fmt->getErrorMessage() . " (" . $fmt->getErrorCode() . ")\n";
}
?>

以上例程会输出：

ERROR: msgfmt_format: not enough parameters: U_ILLEGAL_ARGUMENT_ERROR (1)

参见

  • msgfmt_get_error_code() - Get the error code from last operation
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure


Get the locale for which the formatter was created

  • ? MessageFormatter::getErrorMessage
  • MessageFormatter::getPattern ?
  • PHP Manual
  • MessageFormatter
  • Get the locale for which the formatter was created

MessageFormatter::getLocale

msgfmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getLocale -- msgfmt_get_locale — Get the locale for which the formatter was created

说明

面向对象风格

public MessageFormatter::getLocale ( ) : string

过程化风格

msgfmt_get_locale ( NumberFormatter $formatter ) : string

Get the locale for which the formatter was created.

参数

formatter

The formatter resource

返回值

The locale name

范例

Example #1 msgfmt_get_locale() example

<?php
$fmt = msgfmt_create('en_US', "Number {0,number}");
echo msgfmt_get_locale($fmt);
?>

Example #2 OO example

<?php
$fmt = new MessageFormatter('en_US', "Number {0,number}");
echo $fmt->getLocale();
?>

以上例程会输出：

en_US

参见

  • msgfmt_create() - Constructs a new Message Formatter


Get the pattern used by the formatter

  • ? MessageFormatter::getLocale
  • MessageFormatter::parseMessage ?
  • PHP Manual
  • MessageFormatter
  • Get the pattern used by the formatter

MessageFormatter::getPattern

msgfmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getPattern -- msgfmt_get_pattern — Get the pattern used by the formatter

说明

面向对象风格

public MessageFormatter::getPattern ( ) : string

过程化风格

msgfmt_get_pattern ( MessageFormatter $fmt ) : string

Get the pattern used by the formatter

参数

fmt

The message formatter

返回值

The pattern string for this message formatter

范例

Example #1 msgfmt_get_pattern() example

<?php
$fmt = msgfmt_create( "en_US", "{0, number} monkeys on {1, number} trees" );
echo "Default pattern: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Formatting result: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";

msgfmt_set_pattern( $fmt, "{0, number} trees hosting {1, number} monkeys" );
echo "New pattern: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Formatted number: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";
?>

Example #2 OO example

<?php
$fmt = new MessageFormatter( "en_US", "{0, number} monkeys on {1, number} trees" );
echo "Default pattern: '" . $fmt->getPattern() . "'\n";
echo "Formatting result: " . $fmt->format(array(123, 456)) . "\n";

$fmt->setPattern("{0, number} trees hosting {1, number} monkeys" );
echo "New pattern: '" . $fmt->getPattern() . "'\n";
echo "Formatted number: " . $fmt->format(array(123, 456)) . "\n";
?>

以上例程会输出：

Default pattern: '{0,number} monkeys on {1,number} trees'
Formatting result: 123 monkeys on 456 trees
New pattern: '{0,number} trees hosting {1,number} monkeys'
Formatted number: 123 trees hosting 456 monkeys

参见

  • msgfmt_create() - Constructs a new Message Formatter
  • msgfmt_set_pattern() - Set the pattern used by the formatter


Quick parse input string

  • ? MessageFormatter::getPattern
  • MessageFormatter::parse ?
  • PHP Manual
  • MessageFormatter
  • Quick parse input string

MessageFormatter::parseMessage

msgfmt_parse_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::parseMessage -- msgfmt_parse_message — Quick parse input string

说明

面向对象风格

public static MessageFormatter::parseMessage ( string $locale , string $pattern , string $source ) : array

过程化风格

msgfmt_parse_message ( string $locale , string $pattern , string $value ) : array

Parses input string without explicitly creating the formatter object. Use this function when the format operation is done only once and does not need and parameters or state to be kept.

参数

locale

The locale to use for parsing locale-dependent parts

pattern

The pattern with which to parse the value.

source

The string to parse, conforming to the pattern.

返回值

An array containing items extracted, or false on error

范例

Example #1 msgfmt_parse_message() example

<?php
$fmt = msgfmt_parse_message('en_US', "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree",
                            "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($fmt);

$fmt = msgfmt_parse_message('de', "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum",
                            "4.560 Affen auf 123 B?umen sind 37,073 Affen pro Baum");
var_export($fmt);
?>

Example #2 OO example

<?php
$fmt = MessageFormatter::parseMessage('en_US', "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree",
                            "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($fmt);

$fmt = MessageFormatter::parseMessage('de', "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum",
                            "4.560 Affen auf 123 B?umen sind 37,073 Affen pro Baum");
var_export($fmt);
?>

以上例程会输出：

array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)
array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)

参见

  • msgfmt_create() - Constructs a new Message Formatter
  • msgfmt_format_message() - Quick format message
  • msgfmt_parse() - Parse input string according to pattern


Parse input string according to pattern

  • ? MessageFormatter::parseMessage
  • MessageFormatter::setPattern ?
  • PHP Manual
  • MessageFormatter
  • Parse input string according to pattern

MessageFormatter::parse

msgfmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::parse -- msgfmt_parse — Parse input string according to pattern

说明

面向对象风格

public MessageFormatter::parse ( string $value ) : array

过程化风格

msgfmt_parse ( MessageFormatter $fmt , string $value ) : array

Parses input string and return any extracted items as an array.

参数

fmt

The message formatter

value

The string to parse

返回值

An array containing the items extracted, or false on error

范例

Example #1 msgfmt_parse() example

<?php
$fmt = msgfmt_create('en_US', "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
$res = msgfmt_parse($fmt, "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($res);

$fmt = msgfmt_create('de', "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum");
$res = msgfmt_parse($fmt, "4.560 Affen auf 123 B?umen sind 37,073 Affen pro Baum");
var_export($res);
?>

Example #2 OO example

<?php
$fmt = new MessageFormatter('en_US', "{0,number,integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree");
$res = $fmt->parse("4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($res);

$fmt = new MessageFormatter('de', "{0,number,integer} Affen auf {1,number,integer} B?umen sind {2,number} Affen pro Baum");
$res = $fmt->parse("4.560 Affen auf 123 B?umen sind 37,073 Affen pro Baum");
var_export($res);
?>

以上例程会输出：

array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)
array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)

参见

  • msgfmt_create() - Constructs a new Message Formatter
  • msgfmt_format() - Format the message
  • msgfmt_parse_message() - Quick parse input string


Set the pattern used by the formatter

  • ? MessageFormatter::parse
  • IntlCalendar ?
  • PHP Manual
  • MessageFormatter
  • Set the pattern used by the formatter

MessageFormatter::setPattern

msgfmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::setPattern -- msgfmt_set_pattern — Set the pattern used by the formatter

说明

面向对象风格

public MessageFormatter::setPattern ( string $pattern ) : bool

过程化风格

msgfmt_set_pattern ( MessageFormatter $fmt , string $pattern ) : bool

Set the pattern used by the formatter

参数

fmt

The message formatter

pattern

The pattern string to use in this message formatter. The pattern uses an 'apostrophe-friendly' syntax; it is run through » umsg_autoQuoteApostrophe before being interpreted.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 msgfmt_set_pattern() example

<?php
$fmt = msgfmt_create( "en_US", "{0, number} monkeys on {1, number} trees" );
echo "Default pattern: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Formatting result: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";

msgfmt_set_pattern( $fmt, "{0, number} trees hosting {1, number} monkeys" );
echo "New pattern: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Formatted number: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";
?>

Example #2 OO example

<?php
$fmt = new MessageFormatter( "en_US", "{0, number} monkeys on {1, number} trees" );
echo "Default pattern: '" . $fmt->getPattern() . "'\n";
echo "Formatting result: " . $fmt->format(array(123, 456)) . "\n";

$fmt->setPattern("{0, number} trees hosting {1, number} monkeys" );
echo "New pattern: '" . $fmt->getPattern() . "'\n";
echo "Formatted number: " . $fmt->format(array(123, 456)) . "\n";
?>

以上例程会输出：

Default pattern: '{0,number} monkeys on {1,number} trees'
Formatting result: 123 monkeys on 456 trees
New pattern: '{0,number} trees hosting {1,number} monkeys'
Formatted number: 123 trees hosting 456 monkeys

参见

  • msgfmt_create() - Constructs a new Message Formatter
  • msgfmt_get_pattern() - Get the pattern used by the formatter


The IntlCalendar class

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

简介

类摘要

IntlCalendar {
/* 常量 */
const int FIELD_ERA = 0 ;
const int FIELD_YEAR = 1 ;
const int FIELD_MONTH = 2 ;
const int FIELD_WEEK_OF_YEAR = 3 ;
const int FIELD_WEEK_OF_MONTH = 4 ;
const int FIELD_DATE = 5 ;
const int FIELD_DAY_OF_YEAR = 6 ;
const int FIELD_DAY_OF_WEEK = 7 ;
const int FIELD_DAY_OF_WEEK_IN_MONTH = 8 ;
const int FIELD_AM_PM = 9 ;
const int FIELD_HOUR = 10 ;
const int FIELD_HOUR_OF_DAY = 11 ;
const int FIELD_MINUTE = 12 ;
const int FIELD_SECOND = 13 ;
const int FIELD_MILLISECOND = 14 ;
const int FIELD_ZONE_OFFSET = 15 ;
const int FIELD_DST_OFFSET = 16 ;
const int FIELD_YEAR_WOY = 17 ;
const int FIELD_DOW_LOCAL = 18 ;
const int FIELD_EXTENDED_YEAR = 19 ;
const int FIELD_JULIAN_DAY = 20 ;
const int FIELD_MILLISECONDS_IN_DAY = 21 ;
const int FIELD_IS_LEAP_MONTH = 22 ;
const int FIELD_FIELD_COUNT = 23 ;
const int FIELD_DAY_OF_MONTH = 5 ;
const int DOW_SUNDAY = 1 ;
const int DOW_MONDAY = 2 ;
const int DOW_TUESDAY = 3 ;
const int DOW_WEDNESDAY = 4 ;
const int DOW_THURSDAY = 5 ;
const int DOW_FRIDAY = 6 ;
const int DOW_SATURDAY = 7 ;
const int DOW_TYPE_WEEKDAY = 0 ;
const int DOW_TYPE_WEEKEND = 1 ;
const int DOW_TYPE_WEEKEND_OFFSET = 2 ;
const int DOW_TYPE_WEEKEND_CEASE = 3 ;
const int WALLTIME_FIRST = 1 ;
const int WALLTIME_LAST = 0 ;
const int WALLTIME_NEXT_VALID = 2 ;
/* 方法 */
public add ( int $field , int $amount ) : bool
public after ( IntlCalendar $other ) : bool
public before ( IntlCalendar $other ) : bool
public clear ( int $field = NULL ) : bool
private __construct ( )
public static createInstance ( mixed $timeZone = NULL , string $locale = "" ) : IntlCalendar
public equals ( IntlCalendar $other ) : bool
public fieldDifference ( float $when , int $field ) : int|false
public static fromDateTime ( mixed $dateTime ) : IntlCalendar
public get ( int $field ) : int
public getActualMaximum ( int $field ) : int|false
public getActualMinimum ( int $field ) : int|false
public static getAvailableLocales ( ) : array
public getDayOfWeekType ( int $dayOfWeek ) : int|false
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getFirstDayOfWeek ( ) : int|false
public getGreatestMinimum ( int $field ) : int|false
public static getKeywordValuesForLocale ( string $key , string $locale , bool $commonlyUsed ) : Iterator|false
public getLeastMaximum ( int $field ) : int|false
public getLocale ( int $localeType ) : string|false
public getMaximum ( int $field ) : int|false
public getMinimalDaysInFirstWeek ( ) : int|false
public getMinimum ( int $field ) : int|false
public static getNow ( ) : float
public getRepeatedWallTimeOption ( ) : int
public getSkippedWallTimeOption ( ) : int
public getTime ( ) : float
public getTimeZone ( ) : IntlTimeZone
public getType ( ) : string
public getWeekendTransition ( string $dayOfWeek ) : int|false
public inDaylightTime ( ) : bool
public isEquivalentTo ( IntlCalendar $other ) : bool
public isLenient ( ) : bool
public isSet ( int $field ) : bool
public isWeekend ( float $date = NULL ) : bool
public roll ( int $field , mixed $amountOrUpOrDown ) : bool
public set ( int $field , int $value ) : bool
public set ( int $year , int $month , int $dayOfMonth = NULL , int $hour = NULL , int $minute = NULL , int $second = NULL ) : bool
public setFirstDayOfWeek ( int $dayOfWeek ) : bool
public setLenient ( bool $isLenient ) : bool
public setMinimalDaysInFirstWeek ( int $minimalDays ) : bool
public setRepeatedWallTimeOption ( int $wallTimeOption ) : bool
public setSkippedWallTimeOption ( int $wallTimeOption ) : bool
public setTime ( float $date ) : bool
public setTimeZone ( mixed $timeZone ) : bool
public toDateTime ( ) : DateTime
}

预定义常量

IntlCalendar::FIELD_ERA

Calendar field numerically representing an era, for instance 1 for AD and 0 for BC in the Gregorian/Julian calendars and 235 for the Heisei (平成) era in the Japanese calendar. Not all calendars have more than one era.

IntlCalendar::FIELD_YEAR

Calendar field for the year. This is not unique across eras. If the calendar type has more than one era, generally the minimum value for this field will be 1.

IntlCalendar::FIELD_MONTH

Calendar field for the month. The month sequence is zero-based, so January (here used to signify the first month of the calendar; this may be called another name, such as Muharram in the Islamic calendar) is represented by 0, February by 1, ..., December by 11 and, for calendars that have it, the 13th or leap month by 12.

IntlCalendar::FIELD_WEEK_OF_YEAR

Calendar field for the number of the week of the year. This depends on which day of the week is deemed to start the week and the minimal number of days in a week.

IntlCalendar::FIELD_WEEK_OF_MONTH

Calendar field for the number of the week of the month. This depends on which day of the week is deemed to start the week and the minimal number of days in a week.

IntlCalendar::FIELD_DATE

Calendar field for the day of the month. The same as IntlCalendar::FIELD_DAY_OF_MONTH, which has a clearer name.

IntlCalendar::FIELD_DAY_OF_YEAR

Calendar field for the day of the year. For the Gregorian calendar, starts with 1 and ends with 365 or 366.

IntlCalendar::FIELD_DAY_OF_WEEK

Calendar field for the day of the week. Its values start with 1 (Sunday, see IntlCalendar::DOW_SUNDAY and subsequent constants) and the last valid value is 7 (Saturday).

IntlCalendar::FIELD_DAY_OF_WEEK_IN_MONTH

Given a day of the week (Sunday, Monday, ...), this calendar field assigns an ordinal to such a day of the week in a specific month. Thus, if the value of this field is 1 and the value of the day of the week is 2 (Monday), then the set day of the month is the 1st Monday of the month; the maximum value is 5.

Additionally, the value 0 and negative values are also allowed. The value 0 encompasses the seven days that occur immediately before the first seven days of a month (which therefore have a 'day of week in month' with value 1). Negative values starts counting from the end of the month - -1 points to the last occurrence of a day of the week in a month, -2 to the second last, and so on.

Unlike IntlCalendar::FIELD_WEEK_OF_MONTH and IntlCalendar::FIELD_WEEK_OF_YEAR, this value does not depend on IntlCalendar::getFirstDayOfWeek() or on IntlCalendar::getMinimalDaysInFirstWeek(). The first Monday is the first Monday, even if it occurs in a week that belongs to the previous month.

IntlCalendar::FIELD_AM_PM

Calendar field indicating whether a time is before noon (value 0, AM) or after (1). Midnight is AM, noon is PM.

IntlCalendar::FIELD_HOUR

Calendar field for the hour, without specifying whether it?s in the morning or in the afternoon. Valid values are 0 to 11.

IntlCalendar::FIELD_HOUR_OF_DAY

Calendar field for the full (24h) hour of the day. Valid values are 0 to 23.

IntlCalendar::FIELD_MINUTE

Calendar field for the minutes component of the time.

IntlCalendar::FIELD_SECOND

Calendar field for the seconds component of the time.

IntlCalendar::FIELD_MILLISECOND

Calendar field the milliseconds component of the time.

IntlCalendar::FIELD_ZONE_OFFSET

Calendar field indicating the raw offset of the timezone, in milliseconds. The raw offset is the timezone offset, excluding any offset due to daylight saving time.

IntlCalendar::FIELD_DST_OFFSET

Calendar field for the daylight saving time offset of the calendar?s timezone, in milliseconds, if active for calendar?s time.

IntlCalendar::FIELD_YEAR_WOY

Calendar field representing the year for week of year purposes.

IntlCalendar::FIELD_DOW_LOCAL

Calendar field for the localized day of the week. This is a value between 1 and 7, 1 being used for the day of the week that matches the value returned by IntlCalendar::getFirstDayOfWeek().

IntlCalendar::FIELD_EXTENDED_YEAR

Calendar field for a year number representation that is continuous across eras. For the Gregorian calendar, the value of this field matches that of IntlCalendar::FIELD_YEAR for AD years; a BC year y is represented by -y + 1.

IntlCalendar::FIELD_JULIAN_DAY

Calendar field for a modified Julian day number. It is different from a conventional Julian day number in that its transitions occur at local zone midnight rather than at noon UTC. It uniquely identifies a date.

IntlCalendar::FIELD_MILLISECONDS_IN_DAY

Calendar field encompassing the information in IntlCalendar::FIELD_HOUR_OF_DAY, IntlCalendar::FIELD_MINUTE, IntlCalendar::FIELD_SECOND and IntlCalendar::FIELD_MILLISECOND. Range is from the 0 to 24 * 3600 * 1000 - 1. It is not the amount of milliseconds elapsed in the day since on DST transitions it will have discontinuities analog to those of the wall time.

IntlCalendar::FIELD_IS_LEAP_MONTH

Calendar field whose value is 1 for indicating a leap month and 0 otherwise.

IntlCalendar::FIELD_FIELD_COUNT

The total number of fields.

IntlCalendar::FIELD_DAY_OF_MONTH

Alias for IntlCalendar::FIELD_DATE.

IntlCalendar::DOW_SUNDAY

Sunday.

IntlCalendar::DOW_MONDAY

Monday.

IntlCalendar::DOW_TUESDAY

Tuesday.

IntlCalendar::DOW_WEDNESDAY

Wednesday.

IntlCalendar::DOW_THURSDAY

Thursday.

IntlCalendar::DOW_FRIDAY

Friday.

IntlCalendar::DOW_SATURDAY

Saturday.

IntlCalendar::DOW_TYPE_WEEKDAY

Output of IntlCalendar::getDayOfWeekType() indicating a day of week is a weekday.

IntlCalendar::DOW_TYPE_WEEKEND

Output of IntlCalendar::getDayOfWeekType() indicating a day of week belongs to the weekend.

IntlCalendar::DOW_TYPE_WEEKEND_OFFSET

Output of IntlCalendar::getDayOfWeekType() indicating the weekend begins during the given day of week.

IntlCalendar::DOW_TYPE_WEEKEND_CEASE

Output of IntlCalendar::getDayOfWeekType() indicating the weekend ends during the given day of week.

IntlCalendar::WALLTIME_FIRST

Output of IntlCalendar::getSkippedWallTimeOption() indicating that wall times in the skipped range should refer to the same instant as wall times with one hour less and of IntlCalendar::getRepeatedWallTimeOption() indicating the wall times in the repeated range should refer to the instant of the first occurrence of such wall time.

IntlCalendar::WALLTIME_LAST

Output of IntlCalendar::getSkippedWallTimeOption() indicating that wall times in the skipped range should refer to the same instant as wall times with one hour after and of IntlCalendar::getRepeatedWallTimeOption() indicating the wall times in the repeated range should refer to the instant of the second occurrence of such wall time.

IntlCalendar::WALLTIME_NEXT_VALID

Output of IntlCalendar::getSkippedWallTimeOption() indicating that wall times in the skipped range should refer to the instant when the daylight saving time transition occurs (begins).

Table of Contents

  • IntlCalendar::add — Add a (signed) amount of time to a field
  • IntlCalendar::after — Whether this object?s time is after that of the passed object
  • IntlCalendar::before — Whether this object?s time is before that of the passed object
  • IntlCalendar::clear — Clear a field or all fields
  • IntlCalendar::__construct — Private constructor for disallowing instantiation
  • IntlCalendar::createInstance — Create a new IntlCalendar
  • IntlCalendar::equals — Compare time of two IntlCalendar objects for equality
  • IntlCalendar::fieldDifference — Calculate difference between given time and this object?s time
  • IntlCalendar::fromDateTime — Create an IntlCalendar from a DateTime object or string
  • IntlCalendar::get — Get the value for a field
  • IntlCalendar::getActualMaximum — The maximum value for a field, considering the object?s current time
  • IntlCalendar::getActualMinimum — The minimum value for a field, considering the object?s current time
  • IntlCalendar::getAvailableLocales — Get array of locales for which there is data
  • IntlCalendar::getDayOfWeekType — Tell whether a day is a weekday, weekend or a day that has a transition between the two
  • IntlCalendar::getErrorCode — Get last error code on the object
  • IntlCalendar::getErrorMessage — Get last error message on the object
  • IntlCalendar::getFirstDayOfWeek — Get the first day of the week for the calendar?s locale
  • IntlCalendar::getGreatestMinimum — Get the largest local minimum value for a field
  • IntlCalendar::getKeywordValuesForLocale — Get set of locale keyword values
  • IntlCalendar::getLeastMaximum — Get the smallest local maximum for a field
  • IntlCalendar::getLocale — Get the locale associated with the object
  • IntlCalendar::getMaximum — Get the global maximum value for a field
  • IntlCalendar::getMinimalDaysInFirstWeek — Get minimal number of days the first week in a year or month can have
  • IntlCalendar::getMinimum — Get the global minimum value for a field
  • IntlCalendar::getNow — Get number representing the current time
  • IntlCalendar::getRepeatedWallTimeOption — Get behavior for handling repeating wall time
  • IntlCalendar::getSkippedWallTimeOption — Get behavior for handling skipped wall time
  • IntlCalendar::getTime — Get time currently represented by the object
  • IntlCalendar::getTimeZone — Get the object?s timezone
  • IntlCalendar::getType — Get the calendar type
  • IntlCalendar::getWeekendTransition — Get time of the day at which weekend begins or ends
  • IntlCalendar::inDaylightTime — Whether the object?s time is in Daylight Savings Time
  • IntlCalendar::isEquivalentTo — Whether another calendar is equal but for a different time
  • IntlCalendar::isLenient — Whether date/time interpretation is in lenient mode
  • IntlCalendar::isSet — Whether a field is set
  • IntlCalendar::isWeekend — Whether a certain date/time is in the weekend
  • IntlCalendar::roll — Add value to field without carrying into more significant fields
  • IntlCalendar::set — Set a time field or several common fields at once
  • IntlCalendar::setFirstDayOfWeek — Set the day on which the week is deemed to start
  • IntlCalendar::setLenient — Set whether date/time interpretation is to be lenient
  • IntlCalendar::setMinimalDaysInFirstWeek — Set minimal number of days the first week in a year or month can have
  • IntlCalendar::setRepeatedWallTimeOption — Set behavior for handling repeating wall times at negative timezone offset transitions
  • IntlCalendar::setSkippedWallTimeOption — Set behavior for handling skipped wall times at positive timezone offset transitions
  • IntlCalendar::setTime — Set the calendar time in milliseconds since the epoch
  • IntlCalendar::setTimeZone — Set the timezone used by this calendar
  • IntlCalendar::toDateTime — Convert an IntlCalendar into a DateTime object


Add a (signed) amount of time to a field

  • ? IntlCalendar
  • IntlCalendar::after ?
  • PHP Manual
  • IntlCalendar
  • Add a (signed) amount of time to a field

IntlCalendar::add

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::add — Add a (signed) amount of time to a field

说明

面向对象风格

public IntlCalendar::add ( int $field , int $amount ) : bool

过程化风格

intlcal_add ( IntlCalendar $cal , int $field , int $amount ) : bool

Add a signed amount to a field. Adding a positive amount allows advances in time, even if the numeric value of the field decreases (e.g. when working with years in BC dates).

Other fields may need to adjusted - for instance, adding a month to the 31st of January will result in the 28th (or 29th) of February. Contrary to IntlCalendar::roll(), when a value wraps around, more significant fields may change. For instance, adding a day to the 31st of January will result in the 1st of February, not the 1st of January.

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

amount

The signed amount to add to the current field. If the amount is positive, the instant will be moved forward; if it is negative, the instant will be moved into the past. The unit is implicit to the field type. For instance, hours for IntlCalendar::FIELD_HOUR_OF_DAY.

返回值

Returns true on success 或者在失败时返回 false.

范例

Example #1 IntlCalendar::add()

<?php
ini_set('intl.default_locale', 'fr_FR');
ini_set('date.timezone', 'UTC');

$cal = new IntlGregorianCalendar(2012, 0 /* January */, 31);
echo IntlDateFormatter::formatObject($cal), "\n";

$cal->add(IntlCalendar::FIELD_MONTH, 1);
echo IntlDateFormatter::formatObject($cal), "\n";

$cal->add(IntlCalendar::FIELD_DAY_OF_MONTH, 1);
echo IntlDateFormatter::formatObject($cal), "\n";

以上例程会输出：

31 janv. 2012 00:00:00
29 févr. 2012 00:00:00
1 mars 2012 00:00:00


Whether this object?s time is after that of the passed object

  • ? IntlCalendar::add
  • IntlCalendar::before ?
  • PHP Manual
  • IntlCalendar
  • Whether this object?s time is after that of the passed object

IntlCalendar::after

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::after — Whether this object?s time is after that of the passed object

说明

面向对象风格

public IntlCalendar::after ( IntlCalendar $other ) : bool

过程化风格

intlcal_after ( IntlCalendar $cal , IntlCalendar $other ) : bool

Returns whether this object?s time succeeds the argument?s time.

参数

cal

The IntlCalendar resource.

other

The calendar whose time will be checked against the primary object?s time.

返回值

Returns true if this object?s current time is after that of the calendar argument?s time. Returns false otherwise. Also returns false on failure. You can use exceptions or intl_get_error_code() to detect error conditions.

范例

Example #1 IntlCalendar::after()

<?php
$cal1 = IntlCalendar::createInstance();
$cal2 = clone $cal1;

var_dump($cal1->after($cal2), //false
        $cal2->after($cal1)); //false

$cal1->roll(IntlCalendar::FIELD_MILLISECOND, true);

var_dump($cal1->after($cal2), //true
        $cal2->after($cal1)); //false


Whether this object?s time is before that of the passed object

  • ? IntlCalendar::after
  • IntlCalendar::clear ?
  • PHP Manual
  • IntlCalendar
  • Whether this object?s time is before that of the passed object

IntlCalendar::before

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::before — Whether this object?s time is before that of the passed object

说明

面向对象风格

public IntlCalendar::before ( IntlCalendar $other ) : bool

过程化风格

intlcal_before ( IntlCalendar $cal , IntlCalendar $other ) : bool

Returns whether this object?s time precedes the argument?s time.

参数

cal

The IntlCalendar resource.

other

The calendar whose time will be checked against the primary object?s time.

返回值

Returns true if this object?s current time is before that of the calendar argument?s time. Returns false otherwise. Also returns false on failure. You can use exceptions or intl_get_error_code() to detect error conditions.


Clear a field or all fields

  • ? IntlCalendar::before
  • IntlCalendar::__construct ?
  • PHP Manual
  • IntlCalendar
  • Clear a field or all fields

IntlCalendar::clear

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::clear — Clear a field or all fields

说明

面向对象风格

public IntlCalendar::clear ( int $field = NULL ) : bool

过程化风格

intlcal_clear ( IntlCalendar $cal , int $field = NULL ) : bool

Clears either all of the fields or a specific field. A cleared field is marked as unset, giving it the lowest priority against overlapping fields or even default values when calculating the time. Additionally, its value is set to 0, though given the field?s low priority, its value may have been internally set to another value by the time the field has finished been queried.

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

Returns true on success 或者在失败时返回 false. Failure can only occur is invalid arguments are provided.

范例

Example #1 IntlCalendar::clear() examples

<?php
ini_set('intl.default_locale', 'es_ES');
ini_set('date.timezone', 'UTC');

$fields = array(
    'FIELD_ERA'                  => 0,
    'FIELD_YEAR'                 => 1,
    'FIELD_MONTH'                => 2,
    'FIELD_WEEK_OF_YEAR'         => 3,
    'FIELD_WEEK_OF_MONTH'        => 4,
    'FIELD_DATE'                 => 5,
    'FIELD_DAY_OF_YEAR'          => 6,
    'FIELD_DAY_OF_WEEK'          => 7,
    'FIELD_DAY_OF_WEEK_IN_MONTH' => 8,
    'FIELD_AM_PM'                => 9,
    'FIELD_HOUR'                 => 10,
    'FIELD_HOUR_OF_DAY'          => 11,
    'FIELD_MINUTE'               => 12,
    'FIELD_SECOND'               => 13,
    'FIELD_MILLISECOND'          => 14,
    'FIELD_ZONE_OFFSET'          => 15,
    'FIELD_DST_OFFSET'           => 16,
    'FIELD_YEAR_WOY'             => 17,
    'FIELD_DOW_LOCAL'            => 18,
    'FIELD_EXTENDED_YEAR'        => 19,
    'FIELD_JULIAN_DAY'           => 20,
    'FIELD_MILLISECONDS_IN_DAY'  => 21,
    'FIELD_IS_LEAP_MONTH'        => 22,
    'FIELD_FIELD_COUNT'          => 23,
);
function getSetFields(IntlCalendar $cal) {
    global $fields;
    $ret = array();
    foreach ($fields as $name => $value) {
        if ($cal->isSet($value)) {
            $ret[] = $name;
        }
    }
    return $ret;
}

$cal = new IntlGregorianCalendar(2013, 2 /* March */, 15);
echo "After GregorianCalendar creation\n";
print_r(getSetFields($cal));
echo "\n";

echo IntlDateFormatter::formatObject($cal), "\n";
echo "After the formatter requested the extended year\n";
print_r(getSetFields($cal));
echo "\n";

$cal->clear(IntlCalendar::FIELD_YEAR);
echo "After the year has been cleared, the date stays the same\n";
echo IntlDateFormatter::formatObject($cal), "\n";
echo "because FIELD_EXTENDED_YEAR is still set\n";
print_r(getSetFields($cal));
echo "\n";

var_dump($cal->clear(IntlCalendar::FIELD_EXTENDED_YEAR));
echo "After the extended year has been cleared\n";
print_r(getSetFields($cal));
echo IntlDateFormatter::formatObject($cal), "\n";
echo "\n";

echo "After the fields are recalculated,\n"
        . " extended year is set again (to 1970)\n";
print_r(getSetFields($cal));
echo "\n";

$cal->clear();
echo "After calling variant with no arguments\n";
print_r(getSetFields($cal));
echo IntlDateFormatter::formatObject($cal), "\n";

以上例程会输出：

After GregorianCalendar creation
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_YEAR
    [2] => FIELD_MONTH
    [3] => FIELD_DATE
)

15/03/2013 00:00:00
After the formatter requested the extended year
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_YEAR
    [2] => FIELD_MONTH
    [3] => FIELD_DATE
    [4] => FIELD_EXTENDED_YEAR
)

After the year has been cleared, the date stays the same
15/03/2013 00:00:00
because FIELD_EXTENDED_YEAR is still set
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_MONTH
    [2] => FIELD_DATE
    [3] => FIELD_EXTENDED_YEAR
)

bool(true)
After the extended year has been cleared
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_MONTH
    [2] => FIELD_DATE
)
15/03/1970 00:00:00

After the fields are recalculated,
 extended year is set again (to 1970)
Array
(
    [0] => FIELD_ERA
    [1] => FIELD_MONTH
    [2] => FIELD_DATE
    [3] => FIELD_EXTENDED_YEAR
)

After calling variant with no arguments
Array
(
)
01/01/1970 00:00:00


Private constructor for disallowing instantiation

  • ? IntlCalendar::clear
  • IntlCalendar::createInstance ?
  • PHP Manual
  • IntlCalendar
  • Private constructor for disallowing instantiation

IntlCalendar::__construct

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::__construct — Private constructor for disallowing instantiation

说明

private IntlCalendar::__construct ( )

A private constructor for disallowing instantiation with the new operator.

Call IntlCalendar::createInstance() instead.

参数

此函数没有参数。

返回值

没有返回值。


Create a new IntlCalendar

  • ? IntlCalendar::__construct
  • IntlCalendar::equals ?
  • PHP Manual
  • IntlCalendar
  • Create a new IntlCalendar

IntlCalendar::createInstance

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::createInstance — Create a new IntlCalendar

说明

面向对象风格

public static IntlCalendar::createInstance ( mixed $timeZone = NULL , string $locale = "" ) : IntlCalendar

过程化风格

intlcal_create_instance ( mixed $timeZone = NULL , string $locale = "" ) : IntlCalendar

Given a timezone and locale, this method creates an IntlCalendar object. This factory method may return a subclass of IntlCalendar.

The calendar created will represent the time instance at which it was created, based on the system time. The fields can all be cleared by calling IntCalendar::clear() with no arguments. See also IntlGregorianCalendar::__construct().

参数

timeZone

The timezone to use.

  • null, in which case the default timezone will be used, as specified in the ini setting date.timezone or through the function date_default_timezone_set() and as returned by date_default_timezone_get().

  • An IntlTimeZone, which will be used directly.

  • A DateTimeZone. Its identifier will be extracted and an ICU timezone object will be created; the timezone will be backed by ICU?s database, not PHP?s.

  • A string, which should be a valid ICU timezone identifier. See IntlTimeZone::createTimeZoneIDEnumeration(). Raw offsets such as "GMT+08:30" are also accepted.

locale

A locale to use or null to use the default locale.

返回值

The created IntlCalendar instance or null on failure.

范例

Example #1 IntlCalendar::createInstance()

<?php
ini_set('intl.default_locale', 'es_ES');
ini_set('date.timezone', 'Europe/Madrid');

$cal = IntlCalendar::createInstance();
echo "No arguments\n";
var_dump(get_class($cal),
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL));
echo "\n";

echo "Explicit timezone\n";
$cal = IntlCalendar::createInstance(IntlTimeZone::getGMT());
var_dump(get_class($cal),
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL));
echo "\n";

echo "Explicit locale (with calendar)\n";
$cal = IntlCalendar::createInstance(NULL, 'es_ES@calendar=persian');
var_dump(get_class($cal),
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL));

以上例程会输出：

No arguments
string(21) "IntlGregorianCalendar"
string(68) "martes 18 de junio de 2013 14:11:02 Hora de verano de Europa Central"

Explicit timezone
string(21) "IntlGregorianCalendar"
string(45) "martes 18 de junio de 2013 12:11:02 GMT+00:00"

Explicit locale (with calendar)
string(12) "IntlCalendar"
string(70) "martes 28 de Khordad de 1392 14:11:02 Hora de verano de Europa Central"

参见

  • IntlGregorianCalendar::__construct() - Create the Gregorian Calendar class


Compare time of two IntlCalendar objects for equality

  • ? IntlCalendar::createInstance
  • IntlCalendar::fieldDifference ?
  • PHP Manual
  • IntlCalendar
  • Compare time of two IntlCalendar objects for equality

IntlCalendar::equals

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::equals — Compare time of two IntlCalendar objects for equality

说明

面向对象风格

public IntlCalendar::equals ( IntlCalendar $other ) : bool

过程化风格

intlcal_equals ( IntlCalendar $cal , IntlCalendar $other ) : bool

Returns true if this calendar and the given calendar have the same time. The settings, calendar types and field states do not have to be the same.

参数

cal

The IntlCalendar resource.

other

The calendar to compare with the primary object.

返回值

Returns true if the current time of both this and the passed in IntlCalendar object are the same, or false otherwise. The value false can also be returned on failure. This can only happen if bad arguments are passed in. In any case, the two cases can be distinguished by calling intl_get_error_code().

范例

Example #1 IntlCalendar::equals()

<?php
ini_set('date.timezone', 'UTC');

$cal1 = IntlCalendar::createInstance(NULL, 'es_ES');
$cal2 = clone $cal1;

var_dump($cal1->equals($cal2)); //TRUE

//The locale is not included in the comparison
$cal2 = IntlCalendar::createInstance(NULL, 'pt_PT');
$cal2->setTime($cal1->getTime());
var_dump($cal1->equals($cal2)); //TRUE

//And set fields state is not included as well
$cal2->clear(IntlCalendar::FIELD_YEAR);
var_dump($cal1->isSet(IntlCalendar::FIELD_YEAR) ==
        $cal2->isSet(IntlCalendar::FIELD_YEAR)); //FALSE
var_dump($cal1->equals($cal2)); //TRUE

//Neither is the calendar type
$cal2 = IntlCalendar::createInstance(NULL, 'es_ES@calendar=islamic');
$cal2->setTime($cal1->getTime());
var_dump($cal1->equals($cal2)); //TRUE

//Only the time is
$cal2 = clone $cal1;
$cal2->setTime($cal1->getTime() + 1.);
var_dump($cal1->equals($cal2)); //FALSE


Calculate difference between given time and this object?s time

  • ? IntlCalendar::equals
  • IntlCalendar::fromDateTime ?
  • PHP Manual
  • IntlCalendar
  • Calculate difference between given time and this object?s time

IntlCalendar::fieldDifference

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::fieldDifference — Calculate difference between given time and this object?s time

说明

面向对象风格

public IntlCalendar::fieldDifference ( float $when , int $field ) : int|false

过程化风格

intlcal_field_difference ( IntlCalendar $cal , float $when , int $field ) : int|false

Return the difference between the given time and the time this object is set to, with respect to the quantity specified the field parameter.

This method is meant to be called successively, first with the most significant field of interest down to the least significant field. To this end, as a side effect, this calendar?s value for the field specified is advanced by the amount returned.

参数

cal

The IntlCalendar resource.

when

The time against which to compare the quantity represented by the field. For the result to be positive, the time given for this parameter must be ahead of the time of the object the method is being invoked on.

field

The field that represents the quantity being compared.

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

Returns a (signed) difference of time in the unit associated with the specified field 或者在失败时返回 false.

范例

Example #1 IntlCalendar::fieldDifference()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'fr_FR');

$cal1 = IntlCalendar::fromDateTime('2012-02-29 09:00:11');
$cal2 = IntlCalendar::fromDateTime('2013-03-01 09:19:29');
$time = $cal2->getTime();

echo "Time before: ", IntlDateFormatter::formatObject($cal1), "\n";

printf(
    "The difference in time is %d year(s), %d month(s), "
  . "%d day(s), %d hour(s) and %d minute(s)\n",
    $cal1->fieldDifference($time, IntlCalendar::FIELD_YEAR),
    $cal1->fieldDifference($time, IntlCalendar::FIELD_MONTH),
    $cal1->fieldDifference($time, IntlCalendar::FIELD_DAY_OF_MONTH),
    $cal1->fieldDifference($time, IntlCalendar::FIELD_HOUR_OF_DAY),
    $cal1->fieldDifference($time, IntlCalendar::FIELD_MINUTE)
);

//now it was advanced to the target time, exception for the seconds,
//for which we did not measure the difference
echo "Time after: ", IntlDateFormatter::formatObject($cal1), "\n";

以上例程会输出：

Time before: 29 févr. 2012 09:00:11
The difference in time is 1 year(s), 0 month(s), 1 day(s), 0 hour(s) and 19 minute(s)
Time after: 1 mars 2013 09:19:11


Create an IntlCalendar from a DateTime object or string

  • ? IntlCalendar::fieldDifference
  • IntlCalendar::get ?
  • PHP Manual
  • IntlCalendar
  • Create an IntlCalendar from a DateTime object or string

IntlCalendar::fromDateTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a2)

IntlCalendar::fromDateTime — Create an IntlCalendar from a DateTime object or string

说明

面向对象风格

public static IntlCalendar::fromDateTime ( mixed $dateTime ) : IntlCalendar

过程化风格

intlcal_from_date_time ( mixed $dateTime ) : IntlCalendar

Creates an IntlCalendar object either from a DateTime object or from a string from which a DateTime object can be built.

The new calendar will represent not only the same instant as the given DateTime (subject to precision loss for dates very far into the past or future), but also the same timezone (subject to the caveat that different timezone databases will be used, and therefore the results may differ).

参数

dateTime

A DateTime object or a string that can be passed to DateTime::__construct().

返回值

The created IntlCalendar object or null in case of failure. If a string is passed, any exception that occurs inside the DateTime constructor is propagated.

范例

Example #1 IntlCalendar::fromDateTime()

<?php
ini_set('date.timezone', 'Europe/Lisbon');

//same as IntlCalendar::fromDateTime(new DateTime(...))
$cal1 = IntlCalendar::fromDateTime('2013-02-28 00:01:02 Europe/Berlin');

//Note the timezone is Europe/Berlin, not the default Europe/Lisbon
echo IntlDateFormatter::formatObject($cal1, 'yyyy MMMM d HH:mm:ss VVVV', 'de_DE'), "\n";

以上例程会输出：

2013 Februar 28 00:01:02 Deutschland Zeit


Get the value for a field

  • ? IntlCalendar::fromDateTime
  • IntlCalendar::getActualMaximum ?
  • PHP Manual
  • IntlCalendar
  • Get the value for a field

IntlCalendar::get

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::get — Get the value for a field

说明

面向对象风格

public IntlCalendar::get ( int $field ) : int

过程化风格

intlcal_get ( IntlCalendar $cal , int $field ) : int

Gets the value for a specific field.

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

An integer with the value of the time field.

范例

Example #1 IntlCalendar::get()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');

$class = new ReflectionClass('IntlCalendar');
$fields = array();
foreach ($class->getConstants() as $name => $val) {
    if (strpos($name, 'FIELD_') !== 0 || $val > 22)
        continue;
    $fields[$val] = $name;
}

$cal = IntlCalendar::createInstance(); // current time
var_dump(IntlDateFormatter::formatObject($cal));
foreach ($fields as $val => $name) {
    echo "$val ($name)", "\n    ", $cal->get($val), "\n";
}

以上例程会输出：

string(23) "Jul 1, 2013, 4:44:44 AM"
0 (FIELD_ERA)
    1
1 (FIELD_YEAR)
    2013
2 (FIELD_MONTH)
    6
3 (FIELD_WEEK_OF_YEAR)
    27
4 (FIELD_WEEK_OF_MONTH)
    1
5 (FIELD_DAY_OF_MONTH)
    1
6 (FIELD_DAY_OF_YEAR)
    182
7 (FIELD_DAY_OF_WEEK)
    2
8 (FIELD_DAY_OF_WEEK_IN_MONTH)
    1
9 (FIELD_AM_PM)
    0
10 (FIELD_HOUR)
    4
11 (FIELD_HOUR_OF_DAY)
    4
12 (FIELD_MINUTE)
    44
13 (FIELD_SECOND)
    44
14 (FIELD_MILLISECOND)
    551
15 (FIELD_ZONE_OFFSET)
    0
16 (FIELD_DST_OFFSET)
    3600000
17 (FIELD_YEAR_WOY)
    2013
18 (FIELD_DOW_LOCAL)
    2
19 (FIELD_EXTENDED_YEAR)
    2013
20 (FIELD_JULIAN_DAY)
    2456475
21 (FIELD_MILLISECONDS_IN_DAY)
    17084551
22 (FIELD_IS_LEAP_MONTH)
    0


The maximum value for a field, considering the object?s current time

  • ? IntlCalendar::get
  • IntlCalendar::getActualMinimum ?
  • PHP Manual
  • IntlCalendar
  • The maximum value for a field, considering the object?s current time

IntlCalendar::getActualMaximum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getActualMaximum — The maximum value for a field, considering the object?s current time

说明

面向对象风格

public IntlCalendar::getActualMaximum ( int $field ) : int|false

过程化风格

intlcal_get_actual_maximum ( IntlCalendar $cal , int $field ) : int|false

Returns a field?s relative maximum value around the current time. The exact semantics vary by field, but in the general case this is the value that would be obtained if one would set the field value into the smallest relative maximum for the field and would increment it until reaching the global maximum or the field value wraps around, in which the value returned would be the global maximum or the value before the wrapping, respectively.

For instance, in the gregorian calendar, the actual maximum value for the day of month would vary between 28 and 31, depending on the month and year of the current time.

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

An int representing the maximum value in the units associated with the given field 或者在失败时返回 false.

范例

Example #1 IntlCalendar::getActualMaximum()

<?php
ini_set('date.timezone', 'Europe/Lisbon');

$cal = IntlCalendar::fromDateTime('2013-02-15');
var_dump($cal->getActualMaximum(IntlCalendar::FIELD_DAY_OF_MONTH)); //28

$cal->add(IntlCalendar::FIELD_EXTENDED_YEAR, -1);
var_dump($cal->getActualMaximum(IntlCalendar::FIELD_DAY_OF_MONTH)); //29

以上例程会输出：

int(28)
int(29)

参见

  • IntlCalendar::getMaximum() - Get the global maximum value for a field
  • IntlCalendar::getLeastMaximum() - Get the smallest local maximum for a field
  • IntlCalendar::getActualMinimum() - The minimum value for a field, considering the object?s current time


The minimum value for a field, considering the object?s current time

  • ? IntlCalendar::getActualMaximum
  • IntlCalendar::getAvailableLocales ?
  • PHP Manual
  • IntlCalendar
  • The minimum value for a field, considering the object?s current time

IntlCalendar::getActualMinimum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getActualMinimum — The minimum value for a field, considering the object?s current time

说明

面向对象风格

public IntlCalendar::getActualMinimum ( int $field ) : int|false

过程化风格

intlcal_get_actual_minimum ( IntlCalendar $cal , int $field ) : int|false

Returns a field?s relative minimum value around the current time. The exact semantics vary by field, but in the general case this is the value that would be obtained if one would set the field value into the greatest relative minimum for the field and would decrement it until reaching the global minimum or the field value wraps around, in which the value returned would be the global minimum or the value before the wrapping, respectively.

For the Gregorian calendar, this is always the same as IntlCalendar::getMinimum().

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

An int representing the minimum value in the field?s unit 或者在失败时返回 false.

参见

  • IntlCalendar::getMinimum() - Get the global minimum value for a field
  • IntlCalendar::getGreatestMinimum() - Get the largest local minimum value for a field
  • IntlCalendar::getActualMaximum() - The maximum value for a field, considering the object?s current time


Get array of locales for which there is data

  • ? IntlCalendar::getActualMinimum
  • IntlCalendar::getDayOfWeekType ?
  • PHP Manual
  • IntlCalendar
  • Get array of locales for which there is data

IntlCalendar::getAvailableLocales

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getAvailableLocales — Get array of locales for which there is data

说明

面向对象风格

public static IntlCalendar::getAvailableLocales ( ) : array

过程化风格

intlcal_get_available_locales ( ) : array

Gives the list of locales for which calendars are installed. As of ICU 51, this is the list of all installed ICU locales.

参数

此函数没有参数。

返回值

An array of strings, one for which locale.

范例

Example #1 IntlCalendar::getAvailableLocales()

<?php
print_r(IntlCalendar::getAvailableLocales());

以上例程会输出：

Array
(
    [0] => af
    [1] => af_NA
    [2] => af_ZA
    [3] => agq
    [4] => agq_CM
    [5] => ak
    [6] => ak_GH
    [7] => am
    [8] => am_ET
    [9] => ar
    [10] => ar_001
    [11] => ar_AE
    [12] => ar_BH
    [13] => ar_DJ
    ... output abbreviated ...
    [595] => zh_Hant_HK
    [596] => zh_Hant_MO
    [597] => zh_Hant_TW
    [598] => zu
    [599] => zu_ZA
)


Tell whether a day is a weekday, weekend or a day that has a transition between the two

  • ? IntlCalendar::getAvailableLocales
  • IntlCalendar::getErrorCode ?
  • PHP Manual
  • IntlCalendar
  • Tell whether a day is a weekday, weekend or a day that has a transition between the two

IntlCalendar::getDayOfWeekType

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getDayOfWeekType — Tell whether a day is a weekday, weekend or a day that has a transition between the two

说明

面向对象风格

public IntlCalendar::getDayOfWeekType ( int $dayOfWeek ) : int|false

过程化风格

intlcal_get_day_of_week_type ( IntlCalendar $cal , int $dayOfWeek ) : int|false

Returns whether the passed day is a weekday (IntlCalendar::DOW_TYPE_WEEKDAY), a weekend day (IntlCalendar::DOW_TYPE_WEEKEND), a day during which a transition occurs into the weekend (IntlCalendar::DOW_TYPE_WEEKEND_OFFSET) or a day during which the weekend ceases (IntlCalendar::DOW_TYPE_WEEKEND_CEASE).

If the return is either
IntlCalendar::DOW_TYPE_WEEKEND_OFFSET or
IntlCalendar::DOW_TYPE_WEEKEND_CEASE, then
IntlCalendar::getWeekendTransition() can be called to
obtain the time of the transition.

This function requires ICU 4.4 or later.

参数

cal

The IntlCalendar resource.

dayOfWeek

One of the constants IntlCalendar::DOW_SUNDAY,
IntlCalendar::DOW_MONDAY, ...,
IntlCalendar::DOW_SATURDAY.

返回值

Returns one of the constants
IntlCalendar::DOW_TYPE_WEEKDAY,
IntlCalendar::DOW_TYPE_WEEKEND,
IntlCalendar::DOW_TYPE_WEEKEND_OFFSET or
IntlCalendar::DOW_TYPE_WEEKEND_CEASE 或者在失败时返回 false.

范例

Example #1 IntlCalendar::getDayOfWeekType()

<?php
foreach (array('en_US', 'ar_SA') as $locale) {
    echo "Locale: ", Locale::getDisplayName($locale, "en_US"), "\n";

    $cal = IntlCalendar::createInstance('UTC', $locale);

    for ($i = IntlCalendar::DOW_SUNDAY; $i <= IntlCalendar::DOW_SATURDAY; $i++) {
        $type = $cal->getDayOfWeekType($i);
        $transition = ($type !== IntlCalendar::DOW_TYPE_WEEKDAY)
            ? $cal->getWeekendTransition($i)
            : '';
        echo $i, " ", $type, " ", $transition, "\n";
    }
    echo "\n";
}
?>

以上例程会输出：

Locale: English (United States)
1 1 86400000
2 0
3 0
4 0
5 0
6 0
7 1 0

Locale: Arabic (Saudi Arabia)
1 0
2 0
3 0
4 0
5 0
6 1 0
7 1 86400000


Get last error code on the object

  • ? IntlCalendar::getDayOfWeekType
  • IntlCalendar::getErrorMessage ?
  • PHP Manual
  • IntlCalendar
  • Get last error code on the object

IntlCalendar::getErrorCode

intlcal_get_error_code

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getErrorCode -- intlcal_get_error_code — Get last error code on the object

说明

面向对象风格 (method):

public IntlCalendar::getErrorCode ( ) : int

过程化风格:

intlcal_get_error_code ( IntlCalendar $calendar ) : int

Returns the numeric ICU error code for the last call on this object (including cloning) or the IntlCalendar given for the calendar parameter (in the procedural?style version). This may indicate only a warning (negative error code) or no error at all (U_ZERO_ERROR). The actual presence of an error can be tested with intl_is_failure().

Invalid arguments detected on the PHP side (before invoking functions of the ICU library) are not recorded for the purposes of this function.

The last error that occurred in any call to a function of the intl extension, including early argument errors, can be obtained with intl_get_error_code(). This function resets the global error code, but not the object?s error code.

参数

calendar

The calendar object, on the procedural style interface.

返回值

An ICU error code indicating either success, failure or a warning.

范例

Example #1 IntlCalendar::getErrorCode() and IntlCalendar::getErrorMessage()

<?php
ini_set("intl.error_level", E_WARNING);
ini_set("intl.default_locale", "nl");

$intlcal = new IntlGregorianCalendar(2012, 1, 29);
var_dump(
    $intlcal->getErrorCode(),
    $intlcal->getErrorMessage()
);
$intlcal->fieldDifference(-1e100, IntlCalendar::FIELD_SECOND);

var_dump(
    $intlcal->getErrorCode(),
    $intlcal->getErrorMessage()
);

以上例程会输出：

int(0)
string(12) "U_ZERO_ERROR"

Warning: IntlCalendar::fieldDifference(): intlcal_field_difference: Call to ICU method has failed in /home/glopes/php/ws/example.php on line 10
int(1)
string(81) "intlcal_field_difference: Call to ICU method has failed: U_ILLEGAL_ARGUMENT_ERROR"

参见

  • IntlCalendar::getErrorMessage() - Get last error message on the object
  • intl_is_failure() - Check whether the given error code indicates failure
  • intl_error_name() - Get symbolic name for a given error code
  • intl_get_error_code() - Get the last error code
  • intl_get_error_message() - Get description of the last error


Get last error message on the object

  • ? IntlCalendar::getErrorCode
  • IntlCalendar::getFirstDayOfWeek ?
  • PHP Manual
  • IntlCalendar
  • Get last error message on the object

IntlCalendar::getErrorMessage

intlcal_get_error_message

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getErrorMessage -- intlcal_get_error_message — Get last error message on the object

说明

面向对象风格 (method):

public IntlCalendar::getErrorMessage ( ) : string

过程化风格:

intlcal_get_error_message ( IntlCalendar $calendar ) : string

Returns the error message (if any) associated with the error reported by IntlCalendar::getErrorCode() or intlcal_get_error_code(). If there is no associated error message, only the string representation of the name of the error constant will be returned. Otherwise, the message also includes a message set on the side of the PHP binding.

参数

calendar

The calendar object, on the procedural style interface.

返回值

The error message associated with last error that occurred in a function call on this object, or a string indicating the non-existance of an error.

范例

Example #1 IntlCalendar::getErrorMessage()

<?php
$cal = IntlCalendar::createInstance('UTC', 'en_US');
var_dump($cal->getErrorMessage());

$cal->getWeekendTransition(IntlCalendar::DOW_WEDNESDAY);
var_dump($cal->getErrorMessage());

以上例程会输出：

string(12) "U_ZERO_ERROR"
string(82) "intlcal_get_weekend_transition: Error calling ICU method: U_ILLEGAL_ARGUMENT_ERROR"


Get the first day of the week for the calendar?s locale

  • ? IntlCalendar::getErrorMessage
  • IntlCalendar::getGreatestMinimum ?
  • PHP Manual
  • IntlCalendar
  • Get the first day of the week for the calendar?s locale

IntlCalendar::getFirstDayOfWeek

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getFirstDayOfWeek — Get the first day of the week for the calendar?s locale

说明

面向对象风格

public IntlCalendar::getFirstDayOfWeek ( ) : int|false

过程化风格

intlcal_get_first_day_of_week ( IntlCalendar $cal ) : int|false

The week day deemed to start a week, either the default value for this locale or the value set with IntlCalendar::setFirstDayOfWeek().

参数

cal

The IntlCalendar resource.

返回值

One of the constants IntlCalendar::DOW_SUNDAY,
IntlCalendar::DOW_MONDAY, ...,
IntlCalendar::DOW_SATURDAY 或者在失败时返回 false.

范例

Example #1 IntlCalendar::getFirstDayOfWeek()

<?php
ini_set('date.timezone', 'UTC');

$cal1 = IntlCalendar::createInstance(NULL, 'es_ES');
var_dump($cal1->getFirstDayOfWeek()); // Monday
$cal1->set(2013, 1 /* February */, 3); // a Sunday
var_dump($cal1->get(IntlCalendar::FIELD_WEEK_OF_YEAR)); // 5

$cal2 = IntlCalendar::createInstance(NULL, 'en_US');
var_dump($cal2->getFirstDayOfWeek()); // Sunday
$cal2->set(2013, 1 /* February */, 3); // a Sunday
var_dump($cal2->get(IntlCalendar::FIELD_WEEK_OF_YEAR)); // 6

以上例程会输出：

int(2)
int(5)
int(1)
int(6)

参见

  • IntlCalendar::setFirstDayOfWeek() - Set the day on which the week is deemed to start


Get the largest local minimum value for a field

  • ? IntlCalendar::getFirstDayOfWeek
  • IntlCalendar::getKeywordValuesForLocale ?
  • PHP Manual
  • IntlCalendar
  • Get the largest local minimum value for a field

IntlCalendar::getGreatestMinimum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getGreatestMinimum — Get the largest local minimum value for a field

说明

面向对象风格

public IntlCalendar::getGreatestMinimum ( int $field ) : int|false

过程化风格

intlcal_get_greatest_minimum ( IntlCalendar $cal , int $field ) : int|false

Returns the largest local minimum for a field. This should be a value larger or equal to that returned by IntlCalendar::getActualMinimum(), which is in its turn larger or equal to that returned by IntlCalendar::getMinimum(). All these three functions return the same value for the Gregorian calendar.

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

An int representing a field value, in the field?s unit, 或者在失败时返回 false.


Get set of locale keyword values

  • ? IntlCalendar::getGreatestMinimum
  • IntlCalendar::getLeastMaximum ?
  • PHP Manual
  • IntlCalendar
  • Get set of locale keyword values

IntlCalendar::getKeywordValuesForLocale

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getKeywordValuesForLocale — Get set of locale keyword values

说明

面向对象风格

public static IntlCalendar::getKeywordValuesForLocale ( string $key , string $locale , bool $commonlyUsed ) : Iterator|false

过程化风格

static intlcal_get_keyword_values_for_locale ( string $key , string $locale , bool $commonlyUsed ) : Iterator|false

For a given locale key, get the set of values for that key that would result in a different behavior. For now, only the 'calendar' keyword is supported.

This function requires ICU 4.2 or later.

参数

key

The locale keyword for which relevant values are to be queried. Only 'calendar' is supported.

locale

The locale onto which the keyword/value pair are to be appended.

commonlyUsed

Whether to show only the values commonly used for the specified locale.

返回值

An iterator that yields strings with the locale keyword values 或者在失败时返回 false.

范例

Example #1 IntlCalendar::getKeyworkValuesForLocale()

<?php
print_r(
        iterator_to_array(
                IntlCalendar::getKeywordValuesForLocale(
                        'calendar', 'fa_IR', true)));
print_r(
        iterator_to_array(
                IntlCalendar::getKeywordValuesForLocale(
                        'calendar', 'fa_IR', false)));

以上例程会输出：

Array
(
    [0] => persian
    [1] => gregorian
    [2] => islamic
    [3] => islamic-civil
)
Array
(
    [0] => persian
    [1] => gregorian
    [2] => islamic
    [3] => islamic-civil
    [4] => japanese
    [5] => buddhist
    [6] => roc
    [7] => hebrew
    [8] => chinese
    [9] => indian
    [10] => coptic
    [11] => ethiopic
    [12] => ethiopic-amete-alem
)


Get the smallest local maximum for a field

  • ? IntlCalendar::getKeywordValuesForLocale
  • IntlCalendar::getLocale ?
  • PHP Manual
  • IntlCalendar
  • Get the smallest local maximum for a field

IntlCalendar::getLeastMaximum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getLeastMaximum — Get the smallest local maximum for a field

说明

面向对象风格

public IntlCalendar::getLeastMaximum ( int $field ) : int|false

过程化风格

intlcal_get_least_maximum ( IntlCalendar $cal , int $field ) : int|false

Returns the smallest local maximumw for a field. This should be a value smaller or equal to that returned by IntlCalendar::getActualMaxmimum(), which is in its turn smaller or equal to that returned by IntlCalendar::getMaximum().

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

An int representing a field value in the field?s unit 或者在失败时返回 false.

范例

Example #1 Maxima examples

<?php
ini_set('date.timezone', 'UTC');
ini_set('intl.default_locale', 'it_IT');

$cal = new IntlGregorianCalendar(2013, 3 /* April */, 6);
var_dump(
    $cal->getLeastMaximum(IntlCalendar::FIELD_DAY_OF_MONTH),  // 28
    $cal->getActualMaximum(IntlCalendar::FIELD_DAY_OF_MONTH), // 30
    $cal->getMaximum(IntlCalendar::FIELD_DAY_OF_MONTH)        // 31
);

以上例程会输出：

int(28)
int(30)
int(31)

参见

  • IntlCalendar::getActualMaximum() - The maximum value for a field, considering the object?s current time
  • IntlCalendar::getMaximum() - Get the global maximum value for a field
  • IntlCalendar::getGreatestMinimum() - Get the largest local minimum value for a field


Get the locale associated with the object

  • ? IntlCalendar::getLeastMaximum
  • IntlCalendar::getMaximum ?
  • PHP Manual
  • IntlCalendar
  • Get the locale associated with the object

IntlCalendar::getLocale

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getLocale — Get the locale associated with the object

说明

面向对象风格

public IntlCalendar::getLocale ( int $localeType ) : string|false

过程化风格

intlcal_get_locale ( IntlCalendar $cal , int $localeType ) : string|false

Returns the locale used by this calendar object.

参数

cal

The IntlCalendar resource.

localeType

Whether to fetch the actual locale (the locale from which the calendar data originates, with Locale::ACTUAL_LOCALE) or the valid locale, i.e., the most specific locale supported by ICU relatively to the requested locale - see Locale::VALID_LOCALE. From the most general to the most specific, the locales are ordered in this fashion - actual locale, valid locale, requested locale.

返回值

A locale string 或者在失败时返回 false.

范例

Example #1 IntlCalendar::getLocale()

<?php
$cal = IntlCalendar::createInstance(IntlTimeZone::getGMT(), 'en_US_CALIFORNIA');
var_dump(
    $cal->getLocale(Locale::ACTUAL_LOCALE),
    $cal->getLocale(Locale::VALID_LOCALE)
);

以上例程会输出：

string(2) "en"
string(5) "en_US"


Get the global maximum value for a field

  • ? IntlCalendar::getLocale
  • IntlCalendar::getMinimalDaysInFirstWeek ?
  • PHP Manual
  • IntlCalendar
  • Get the global maximum value for a field

IntlCalendar::getMaximum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getMaximum — Get the global maximum value for a field

说明

面向对象风格

public IntlCalendar::getMaximum ( int $field ) : int|false

过程化风格

intlcal_get_maximum ( IntlCalendar $cal , int $field ) : int|false

Gets the global maximum for a field, in this specific calendar. This value is larger or equal to that returned by IntlCalendar::getActualMaximum(), which is in its turn larger or equal to that returned by IntlCalendar::getLeastMaximum().

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

An int representing a field value in the field?s unit 或者在失败时返回 false.

参见

  • IntlCalendar::getActualMaximum() - The maximum value for a field, considering the object?s current time
  • IntlCalendar::getLeastMaximum() - Get the smallest local maximum for a field
  • IntlCalendar::getMinimum() - Get the global minimum value for a field


Get minimal number of days the first week in a year or month can have

  • ? IntlCalendar::getMaximum
  • IntlCalendar::getMinimum ?
  • PHP Manual
  • IntlCalendar
  • Get minimal number of days the first week in a year or month can have

IntlCalendar::getMinimalDaysInFirstWeek

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getMinimalDaysInFirstWeek — Get minimal number of days the first week in a year or month can have

说明

面向对象风格

public IntlCalendar::getMinimalDaysInFirstWeek ( ) : int|false

过程化风格

intlcal_get_minimal_days_in_first_week ( IntlCalendar $cal ) : int|false

Returns the smallest number of days the first week of a year or month must have in the new year or month. For instance, in the Gregorian calendar, if this value is 1, then the first week of the year will necessarily include January 1st, while if this value is 7, then the week with January 1st will be the first week of the year only if the day of the week for January 1st matches the day of the week returned by IntlCalendar::getFirstDayOfWeek(); otherwise it will be the previous year?s last week.

参数

cal

The IntlCalendar resource.

返回值

An int representing a number of days 或者在失败时返回 false.

范例

Example #1 IntlCalendar::getMinimalDaysInFirstWeek()

<?php
ini_set('date.timezone', 'UTC');
ini_set('intl.default_locale', 'en_US');

$cal = new IntlGregorianCalendar(2013, 0 /* January */, 2);
var_dump(IntlDateFormatter::formatObject($cal, 'cccc')); // Wednesday

var_dump($cal->getMinimalDaysInFirstWeek(), // 1
$cal->getFirstDayofWeek()); // 1 (Sunday)

// Week 1 of 2013
var_dump(IntlDateFormatter::formatObject($cal, "'Week 'w' of 'Y"));

$cal->setMinimalDaysInFirstWeek(4);
// Still Week 1 of 2013 (1st week has 5 days in the new year)
var_dump(IntlDateFormatter::formatObject($cal, "'Week 'w' of 'Y"));

$cal->setMinimalDaysInFirstWeek(6);
// Week 53 of 2012
var_dump(IntlDateFormatter::formatObject($cal, "'Week 'w' of 'Y"));

以上例程会输出：

string(9) "Wednesday"
int(1)
int(1)
string(14) "Week 1 of 2013"
string(14) "Week 1 of 2013"
string(15) "Week 53 of 2012"


Get the global minimum value for a field

  • ? IntlCalendar::getMinimalDaysInFirstWeek
  • IntlCalendar::getNow ?
  • PHP Manual
  • IntlCalendar
  • Get the global minimum value for a field

IntlCalendar::getMinimum

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getMinimum — Get the global minimum value for a field

说明

面向对象风格

public IntlCalendar::getMinimum ( int $field ) : int|false

过程化风格

intlcal_get_minimum ( IntlCalendar $cal , int $field ) : int|false

Gets the global minimum for a field, in this specific calendar. This value is smaller or equal to that returned by IntlCalendar::getActualMinimum(), which is in its turn smaller or equal to that returned by IntlCalendar::getGreatestMinimum(). For the Gregorian calendar, these three functions always return the same value (for each field).

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

An int representing a value for the given field in the field?s unit 或者在失败时返回 false.


Get number representing the current time

  • ? IntlCalendar::getMinimum
  • IntlCalendar::getRepeatedWallTimeOption ?
  • PHP Manual
  • IntlCalendar
  • Get number representing the current time

IntlCalendar::getNow

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getNow — Get number representing the current time

说明

面向对象风格

public static IntlCalendar::getNow ( ) : float

过程化风格

intlcal_get_now ( ) : float

The number of milliseconds that have passed since the reference date. This number is derived from the system time.

参数

此函数没有参数。

返回值

A float representing a number of milliseconds since the epoch, not counting leap seconds.

范例

Example #1 IntlCalendar::getNow()

<?php
$formatter = IntlDateFormatter::create('es_ES',
        IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,
        'Europe/Madrid');

$val = IntlCalendar::getNow();

var_dump($val);
echo $formatter->format(IntlCalendar::getNow() / 1000.), "\n";

以上例程会输出：

float(1371425814666)
lunes, 17 de junio de 2013 01:36:54 Hora de verano de Europa central


Get behavior for handling repeating wall time

  • ? IntlCalendar::getNow
  • IntlCalendar::getSkippedWallTimeOption ?
  • PHP Manual
  • IntlCalendar
  • Get behavior for handling repeating wall time

IntlCalendar::getRepeatedWallTimeOption

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getRepeatedWallTimeOption — Get behavior for handling repeating wall time

说明

面向对象风格

public IntlCalendar::getRepeatedWallTimeOption ( ) : int

过程化风格

intlcal_get_repeated_wall_time_option ( IntlCalendar $cal ) : int

Gets the current strategy for dealing with wall times that are repeated whenever the clock is set back during dailight saving time end transitions. The default value is IntlCalendar::WALLTIME_LAST.

This function requires ICU 4.9 or later.

参数

cal

The IntlCalendar resource.

返回值

One of the constants IntlCalendar::WALLTIME_FIRST or IntlCalendar::WALLTIME_LAST.

范例

Example #1 IntlCalendar::getRepeatedWallTimeOption()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');
ini_set('intl.error_level', E_WARNING);

//On October 27th at 0200, the clock goes back 1 hour and from GMT+01 to GMT+00
$cal = new IntlGregorianCalendar(2013, 9 /* October */, 27, 1, 30);

var_dump($cal->getRepeatedWalltimeOption()); // 0 WALLTIME_LAST

$formatter = IntlDateFormatter::create(
    NULL,
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'UTC'
);
var_dump($formatter->format($cal->getTime() / 1000.));

$cal->setRepeatedWalltimeOption(IntlCalendar::WALLTIME_FIRST);
var_dump($cal->getRepeatedWalltimeOption()); // 1 WALLTIME_FIRST
$cal->set(IntlCalendar::FIELD_HOUR_OF_DAY, 1);

var_dump($formatter->format($cal->getTime() / 1000.));

以上例程会输出：

int(0)
string(42) "Sunday, October 27, 2013 at 1:30:00 AM GMT"
int(1)
string(43) "Sunday, October 27, 2013 at 12:30:00 AM GMT"

参见

  • IntlCalendar::getSkippedWallTimeOption() - Get behavior for handling skipped wall time
  • IntlCalendar::setSkippedWallTimeOption() - Set behavior for handling skipped wall times at positive timezone offset transitions
  • IntlCalendar::setRepeatedWallTimeOption() - Set behavior for handling repeating wall times at negative timezone offset transitions


Get behavior for handling skipped wall time

  • ? IntlCalendar::getRepeatedWallTimeOption
  • IntlCalendar::getTime ?
  • PHP Manual
  • IntlCalendar
  • Get behavior for handling skipped wall time

IntlCalendar::getSkippedWallTimeOption

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getSkippedWallTimeOption — Get behavior for handling skipped wall time

说明

面向对象风格

public IntlCalendar::getSkippedWallTimeOption ( ) : int

过程化风格

intlcal_get_skipped_wall_time_option ( IntlCalendar $cal ) : int

Gets the current strategy for dealing with wall times that are skipped whenever the clock is forwarded during dailight saving time start transitions. The default value is IntlCalendar::WALLTIME_LAST.

The calendar must be lenient for this option to have any effect, otherwise attempting to set a non-existing time will cause an error.

This function requires ICU 4.9 or later.

参数

cal

The IntlCalendar resource.

返回值

One of the constants IntlCalendar::WALLTIME_FIRST,
IntlCalendar::WALLTIME_LAST or
IntlCalendar::WALLTIME_NEXT_VALID.

范例

Example #1 IntlCalendar::getSkippedWallTimeOption()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');
ini_set('intl.error_level', E_WARNING);

//On March 31st at 0100, the clock goes forward 1 hour and from GMT+00 to GMT+01
$cal = new IntlGregorianCalendar(2013, 2 /* March */, 31, 1, 30);

var_dump(
    $cal->isLenient(),               // true
    $cal->getSkippedWalltimeOption() // 0 WALLTIME_LAST
);

$formatter = IntlDateFormatter::create(
    NULL,
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'UTC'
);
var_dump($formatter->format($cal->getTime() / 1000));

$cal->setSkippedWallTimeOption(IntlCalendar::WALLTIME_FIRST);
var_dump($cal->getSkippedWalltimeOption()); // 1 WALLTIME_FIRST
$cal->set(IntlCalendar::FIELD_HOUR_OF_DAY, 1);

var_dump($formatter->format($cal->getTime() / 1000));

$cal->setSkippedWallTimeOption(IntlCalendar::WALLTIME_NEXT_VALID);
var_dump($cal->getSkippedWalltimeOption()); // 2 WALLTIME_NEXT_VALID
$cal->set(IntlCalendar::FIELD_HOUR_OF_DAY, 1);

var_dump($formatter->format($cal->getTime() / 1000));

以上例程会输出：

bool(true)
int(0)
string(40) "Sunday, March 31, 2013 at 1:30:00 AM GMT"
int(1)
string(41) "Sunday, March 31, 2013 at 12:30:00 AM GMT"
int(2)
string(40) "Sunday, March 31, 2013 at 1:00:00 AM GMT"

参见

  • IntlCalendar::getRepeatedWallTimeOption() - Get behavior for handling repeating wall time
  • IntlCalendar::setSkippedWallTimeOption() - Set behavior for handling skipped wall times at positive timezone offset transitions
  • IntlCalendar::setRepeatedWallTimeOption() - Set behavior for handling repeating wall times at negative timezone offset transitions


Get time currently represented by the object

  • ? IntlCalendar::getSkippedWallTimeOption
  • IntlCalendar::getTimeZone ?
  • PHP Manual
  • IntlCalendar
  • Get time currently represented by the object

IntlCalendar::getTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getTime — Get time currently represented by the object

说明

面向对象风格

public IntlCalendar::getTime ( ) : float

过程化风格

intlcal_get_time ( IntlCalendar $cal ) : float

Returns the time associated with this object, expressed as the number of milliseconds since the epoch.

参数

cal

The IntlCalendar resource.

返回值

A float representing the number of milliseconds elapsed since the reference time (1 Jan 1970 00:00:00 UTC).

范例

Example #1 IntlCalendar::getTime()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');

$cal = new IntlGregorianCalendar(2013, 4 /* May */, 1, 0, 0, 0);
$time = $cal->getTime();
var_dump($time, $time / 1000 == strtotime('2013-05-01 00:00:00')); //true

以上例程会输出：

float(1367362800000)
bool(true)

参见

  • IntlCalendar::getNow() - Get number representing the current time


Get the object?s timezone

  • ? IntlCalendar::getTime
  • IntlCalendar::getType ?
  • PHP Manual
  • IntlCalendar
  • Get the object?s timezone

IntlCalendar::getTimeZone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getTimeZone — Get the object?s timezone

说明

面向对象风格

public IntlCalendar::getTimeZone ( ) : IntlTimeZone

过程化风格

intlcal_get_time_zone ( IntlCalendar $cal ) : IntlTimeZone

Returns the IntlTimeZone object associated with this calendar.

参数

cal

The IntlCalendar resource.

返回值

An IntlTimeZone object corresponding to the one used internally in this object.

范例

Example #1 IntlCalendar::getTimeZone()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');

$cal = IntlCalendar::createInstance();
print_r($cal->getTimeZone());

$cal->setTimeZone('UTC');
print_r($cal->getTimeZone());

$cal = IntlCalendar::fromDateTime('2012-01-01 00:00:00 GMT+03:33');
print_r($cal->getTimeZone());

以上例程会输出：

IntlTimeZone Object
(
    [valid] => 1
    [id] => Europe/Lisbon
    [rawOffset] => 0
    [currentOffset] => 3600000
)
IntlTimeZone Object
(
    [valid] => 1
    [id] => UTC
    [rawOffset] => 0
    [currentOffset] => 0
)
IntlTimeZone Object
(
    [valid] => 1
    [id] => GMT+03:33
    [rawOffset] => 12780000
    [currentOffset] => 12780000
)

参见

  • IntlCalendar::setTimeZone() - Set the timezone used by this calendar
  • IntlCalendar::createInstance() - Create a new IntlCalendar
  • IntlGregorianCalendar::__construct() - Create the Gregorian Calendar class


Get the calendar type

  • ? IntlCalendar::getTimeZone
  • IntlCalendar::getWeekendTransition ?
  • PHP Manual
  • IntlCalendar
  • Get the calendar type

IntlCalendar::getType

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getType — Get the calendar type

说明

面向对象风格

public IntlCalendar::getType ( ) : string

过程化风格

intlcal_get_type ( IntlCalendar $cal ) : string

A string describing the type of this calendar. This is one of the valid values for the calendar keyword value 'calendar'.

参数

cal

The IntlCalendar resource.

返回值

A string representing the calendar type, such as 'gregorian', 'islamic', etc.

范例

Example #1 IntlCalendar::getType()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'en_US');

$cal = IntlCalendar::createInstance(NULL, '@calendar=ethiopic-amete-alem');
var_dump($cal->getType());

$cal = new IntlGregorianCalendar();
var_dump($cal->getType());

以上例程会输出：

string(19) "ethiopic-amete-alem"
string(9) "gregorian"


Get time of the day at which weekend begins or ends

  • ? IntlCalendar::getType
  • IntlCalendar::inDaylightTime ?
  • PHP Manual
  • IntlCalendar
  • Get time of the day at which weekend begins or ends

IntlCalendar::getWeekendTransition

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::getWeekendTransition — Get time of the day at which weekend begins or ends

说明

面向对象风格

public IntlCalendar::getWeekendTransition ( string $dayOfWeek ) : int|false

过程化风格

intlcal_get_weekend_transition ( IntlCalendar $cal , string $dayOfWeek ) : int|false

Returns the number of milliseconds after midnight at which the weekend begins or ends.

This is only applicable for days of the week for which
IntlCalendar::getDayOfWeekType() returns either
IntlCalendar::DOW_TYPE_WEEKEND_OFFSET or
IntlCalendar::DOW_TYPE_WEEKEND_CEASE. Calling this
function for other days of the week is an error condition.

This function requires ICU 4.4 or later.

参数

cal

The IntlCalendar resource.

dayOfWeek

One of the constants IntlCalendar::DOW_SUNDAY,
IntlCalendar::DOW_MONDAY, ...,
IntlCalendar::DOW_SATURDAY.

返回值

The number of milliseconds into the day at which the weekend begins or ends 或者在失败时返回 false.

范例

See example on IntlCalendar::getDayOfWeekType().


Whether the object?s time is in Daylight Savings Time

  • ? IntlCalendar::getWeekendTransition
  • IntlCalendar::isEquivalentTo ?
  • PHP Manual
  • IntlCalendar
  • Whether the object?s time is in Daylight Savings Time

IntlCalendar::inDaylightTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::inDaylightTime — Whether the object?s time is in Daylight Savings Time

说明

面向对象风格

public IntlCalendar::inDaylightTime ( ) : bool

过程化风格

intlcal_in_daylight_time ( IntlCalendar $cal ) : bool

Whether, for the instant represented by this object and for this object?s timezone, daylight saving time is in place.

参数

cal

The IntlCalendar resource.

返回值

Returns true if the date is in Daylight Savings Time, false otherwise. The value false may also be returned on failure, for instance after specifying invalid field values on non-lenient mode; use exceptions or query intl_get_error_code() to disambiguate.

范例

Example #1 IntlCalendar::inDaylightTime()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'pt_PT');

$cal = new IntlGregorianCalendar(2013, 6 /* July */, 1, 4, 56, 31);
var_dump($cal->inDaylightTime()); // true
$cal->set(IntlCalendar::FIELD_MONTH, 11 /* December */);
var_dump($cal->inDaylightTime()); // false

//DST end transition on 2013-10-27 at 0200 (wall time back 1 hour)
$cal = new IntlGregorianCalendar(2013, 9 /* October */, 27, 1, 30, 0);

var_dump($cal->inDaylightTime()); // false (default WALLTIME_LAST)

$cal->setRepeatedWallTimeOption(IntlCalendar::WALLTIME_FIRST);
$cal->set(IntlCalendar::FIELD_HOUR_OF_DAY, 1); // force time recalculation
var_dump($cal->inDaylightTime()); // true


Whether another calendar is equal but for a different time

  • ? IntlCalendar::inDaylightTime
  • IntlCalendar::isLenient ?
  • PHP Manual
  • IntlCalendar
  • Whether another calendar is equal but for a different time

IntlCalendar::isEquivalentTo

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::isEquivalentTo — Whether another calendar is equal but for a different time

说明

面向对象风格

public IntlCalendar::isEquivalentTo ( IntlCalendar $other ) : bool

过程化风格

intlcal_is_equivalent_to ( IntlCalendar $cal , IntlCalendar $other ) : bool

Returns whether this and the given object are equivalent for all purposes except as to the time they have set. The locales do not have to match, as long as no change in behavior results from such mismatch. This includes the timezone, whether the lenient mode is set, the repeated and skipped wall time settings, the days of the week when the weekend starts and ceases and the times where such transitions occur. It may also include other calendar specific settings, such as the Gregorian/Julian transition instant.

参数

cal

The IntlCalendar resource.

other

The other calendar against which the comparison is to be made.

返回值

Assuming there are no argument errors, returns true if the calendars are equivalent except possibly for their set time.

范例

Example #1 IntlCalendar::isEquivalentTo()

<?php
$cal1 = IntlCalendar::createInstance('Europe/Lisbon', 'pt_PT');
$cal2 = IntlCalendar::createInstance('Europe/Lisbon', 'es_ES');
$cal2->clear();

var_dump($cal1->isEquivalentTo($cal2)); // true

$cal3 = IntlCalendar::createInstance('Europe/Lisbon', 'en_US');
var_dump($cal1->isEquivalentTo($cal3)); // false
var_dump($cal1->getFirstDayOfWeek(),    // 2 (Monday)
$cal3->getFirstDayOfWeek());            // 1 (Sunday)

以上例程会输出：

bool(true)
bool(false)
int(2)
int(1)

参见

  • IntlCalendar::equals() - Compare time of two IntlCalendar objects for equality


Whether date/time interpretation is in lenient mode

  • ? IntlCalendar::isEquivalentTo
  • IntlCalendar::isSet ?
  • PHP Manual
  • IntlCalendar
  • Whether date/time interpretation is in lenient mode

IntlCalendar::isLenient

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::isLenient — Whether date/time interpretation is in lenient mode

说明

面向对象风格

public IntlCalendar::isLenient ( ) : bool

过程化风格

intlcal_is_lenient ( IntlCalendar $cal ) : bool

Returns whether the current date/time interpretations is lenient (the default). If that is case, some out of range values for fields will be accepted instead of raising an error.

参数

cal

The IntlCalendar resource.

返回值

A bool representing whether the calendar is set to lenient mode.

范例

Example #1 IntlCalendar::isLenient()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'pt_PT');
ini_set('intl.use_exceptions', '1');

$cal = new IntlGregorianCalendar(2013, 6 /* July */, 1);
var_dump(IntlDateFormatter::formatObject($cal), // 01/07/2013, 00:00:00
$cal->isLenient()); // true

$cal->set(IntlCalendar::FIELD_DAY_OF_MONTH, 33);
var_dump(IntlDateFormatter::formatObject($cal)); // 02/08/2013, 00:00:00

$cal->setLenient(false);
var_dump($cal->isLenient()); // false
$cal->set(IntlCalendar::FIELD_DAY_OF_MONTH, 33);
var_dump(IntlDateFormatter::formatObject($cal)); // error

以上例程会输出：

string(20) "01/07/2013, 00:00:00"
bool(true)
string(20) "02/08/2013, 00:00:00"
bool(false)

Fatal error: Uncaught exception 'IntlException' with message 'datefmt_format_object: error obtaining instant from IntlCalendar' in /home/foobar/example.php:16
Stack trace:
#0 /home/foobar/example.php(16): IntlDateFormatter::formatObject(Object(IntlGregorianCalendar))
#1 {main}
  thrown in /home/foobar/example.php on line 16


Whether a field is set

  • ? IntlCalendar::isLenient
  • IntlCalendar::isWeekend ?
  • PHP Manual
  • IntlCalendar
  • Whether a field is set

IntlCalendar::isSet

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::isSet — Whether a field is set

说明

面向对象风格

public IntlCalendar::isSet ( int $field ) : bool

过程化风格

intlcal_is_set ( IntlCalendar $cal , int $field ) : bool

Returns whether a field is set (as opposed to clear). Set fields take priority over unset fields and their default values when the date/time is being calculated. Fields set later take priority over fields set earlier.

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

返回值

Assuming there are no argument errors, returns true if the field is set.

范例

See the example on IntlCalendar::clear().

参见

  • IntlCalendar::clear() - Clear a field or all fields
  • IntlCalendar::set() - Set a time field or several common fields at once


Whether a certain date/time is in the weekend

  • ? IntlCalendar::isSet
  • IntlCalendar::roll ?
  • PHP Manual
  • IntlCalendar
  • Whether a certain date/time is in the weekend

IntlCalendar::isWeekend

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::isWeekend — Whether a certain date/time is in the weekend

说明

面向对象风格

public IntlCalendar::isWeekend ( float $date = NULL ) : bool

过程化风格

intlcal_is_weekend ( IntlCalendar $cal , float $date = NULL ) : bool

Returns whether either the obejct?s current time or the provided timestamp occur during a weekend in this object?s calendar system.

This function requires ICU 4.4 or later.

参数

cal

The IntlCalendar resource.

date

An optional timestamp representing the number of milliseconds since the epoch, excluding leap seconds. If null, this object?s current time is used instead.

返回值

A bool indicating whether the given or this object?s time occurs in a weekend.

The value false may also be returned on failure, for instance after giving a date out of bounds on non-lenient mode; use exceptions or query intl_get_error_code() to disambiguate.

范例

Example #1 IntlCalendar::isWeekend()

<?php
ini_set('date.timezone', 'Europe/Lisbon');

$cal = new IntlGregorianCalendar(NULL, 'en_US');
$cal->set(2013, 6 /* July */, 7); // a Sunday

var_dump($cal->isWeekend()); // true
var_dump($cal->isWeekend(strtotime('2013-07-01 00:00:00'))); // false, Monday

$cal = new IntlGregorianCalendar(NULL, 'ar_SA');
$cal->set(2013, 6 /* July */, 7); // a Sunday
var_dump($cal->isWeekend()); // false, Sunday not in weekend in this calendar

参见

  • IntlCalendar::getDayOfWeekType() - Tell whether a day is a weekday, weekend or a day that has a transition between the two
  • IntlCalendar::getWeekendTransition() - Get time of the day at which weekend begins or ends


Add value to field without carrying into more significant fields

  • ? IntlCalendar::isWeekend
  • IntlCalendar::set ?
  • PHP Manual
  • IntlCalendar
  • Add value to field without carrying into more significant fields

IntlCalendar::roll

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::roll — Add value to field without carrying into more significant fields

说明

面向对象风格

public IntlCalendar::roll ( int $field , mixed $amountOrUpOrDown ) : bool

过程化风格

intlcal_roll ( IntlCalendar $cal , int $field , mixed $amountOrUpOrDown ) : bool

Adds a (signed) amount to a field. The difference with respect to IntlCalendar::add() is that when the field value overflows, it does not carry into more significant fields.

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

amountOrUpOrDown

The (signed) amount to add to the field, true for rolling up (adding 1), or false for rolling down (subtracting 1).

返回值

Returns true on success or false on failure.

范例

Example #1 IntlCalendar::roll()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'pt_PT');

$cal = new IntlGregorianCalendar(2013, 5 /* June */, 30);

$cal->add(IntlCalendar::FIELD_DAY_OF_MONTH, 1);
var_dump(IntlDateFormatter::formatObject($cal)); // "01/07/2013, 00:00:00"

$cal->set(2013, 5 /* June */, 30);
$cal->roll(IntlCalendar::FIELD_DAY_OF_MONTH, true); // roll up, same as rolling +1
var_dump(IntlDateFormatter::formatObject($cal)); // "01/06/2013, 00:00:00"

以上例程会输出：

string(20) "01/07/2013, 00:00:00"
string(20) "01/06/2013, 00:00:00"

参见

  • IntlCalendar::add() - Add a (signed) amount of time to a field
  • IntlCalendar::set() - Set a time field or several common fields at once


Set a time field or several common fields at once

  • ? IntlCalendar::roll
  • IntlCalendar::setFirstDayOfWeek ?
  • PHP Manual
  • IntlCalendar
  • Set a time field or several common fields at once

IntlCalendar::set

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::set — Set a time field or several common fields at once

说明

面向对象风格

public IntlCalendar::set ( int $field , int $value ) : bool
public IntlCalendar::set ( int $year , int $month , int $dayOfMonth = NULL , int $hour = NULL , int $minute = NULL , int $second = NULL ) : bool

过程化风格

intlcal_set ( IntlCalendar $cal , int $field , int $value ) : bool
intlcal_set ( IntlCalendar $cal , int $year , int $month , int $dayOfMonth = NULL , int $hour = NULL , int $minute = NULL , int $second = NULL ) : bool

Sets either a specific field to the given value, or sets at once several common fields. The range of values that are accepted depend on whether the calendar is using the lenient mode.

For fields that conflict, the fields that are set later have priority.

This method cannot be called with exactly four arguments.

参数

cal

The IntlCalendar resource.

field

One of the IntlCalendar date/time field constants. These are integer values between 0 and IntlCalendar::FIELD_COUNT.

value

The new value of the given field.

year

The new value for IntlCalendar::FIELD_YEAR.

month

The new value for IntlCalendar::FIELD_MONTH. The month sequence is zero-based, i.e., January is represented by 0, February by 1, ..., December is 11 and Undecember (if the calendar has it) is 12.

dayOfMonth

The new value for IntlCalendar::FIELD_DAY_OF_MONTH.

hour

The new value for IntlCalendar::FIELD_HOUR_OF_DAY.

minute

The new value for IntlCalendar::FIELD_MINUTE.

second

The new value for IntlCalendar::FIELD_SECOND.

返回值

Returns true on success and false on failure.

范例

Example #1 IntlCalendar::set()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'pt_PT');

//Calls made later have priority
$cal = new IntlGregorianCalendar(2013, 6 /* July */, 1);
$cal->set(IntlCalendar::FIELD_YEAR, 2012);
$cal->set(IntlCalendar::FIELD_EXTENDED_YEAR, 2011);
var_dump(IntlDateFormatter::formatObject($cal));

$cal = new IntlGregorianCalendar(2013, 6 /* July */, 1);
$cal->set(IntlCalendar::FIELD_YEAR, 2012);
$cal->set(IntlCalendar::FIELD_EXTENDED_YEAR, 2011);
//the time has not been recalculated yet. If we clear the extended year,
//the year set before will be used
$cal->clear(IntlCalendar::FIELD_EXTENDED_YEAR);
var_dump(IntlDateFormatter::formatObject($cal));

以上例程会输出：

string(20) "01/07/2011, 00:00:00"
string(20) "01/07/2012, 00:00:00"

参见

  • IntlCalendar::get() - Get the value for a field
  • IntlCalendar::add() - Add a (signed) amount of time to a field
  • IntlCalendar::roll() - Add value to field without carrying into more significant fields


Set the day on which the week is deemed to start

  • ? IntlCalendar::set
  • IntlCalendar::setLenient ?
  • PHP Manual
  • IntlCalendar
  • Set the day on which the week is deemed to start

IntlCalendar::setFirstDayOfWeek

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setFirstDayOfWeek — Set the day on which the week is deemed to start

说明

面向对象风格

public IntlCalendar::setFirstDayOfWeek ( int $dayOfWeek ) : bool

过程化风格

intlcal_set_first_day_of_week ( IntlCalendar $cal , int $dayOfWeek ) : bool

Defines the day of week deemed to start the week. This affects the behavior of fields that depend on the concept of week start and end such as IntlCalendar::FIELD_WEEK_OF_YEAR and IntlCalendar::FIELD_YEAR_WOY.

参数

cal

The IntlCalendar resource.

dayOfWeek

One of the constants IntlCalendar::DOW_SUNDAY,
IntlCalendar::DOW_MONDAY, ...,
IntlCalendar::DOW_SATURDAY.

返回值

Returns true on success. Failure can only happen due to invalid parameters.

范例

Example #1 IntlCalendar::setFirstDayOfWeek()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'es_ES');

$cal = IntlCalendar::createInstance();
$cal->set(2013, 5 /* June */, 30); // A Sunday

var_dump($cal->getFirstDayOfWeek()); // 2 (Monday)

echo IntlDateFormatter::formatObject($cal, <<<EOD
'local day of week: 'cc'
week of month    : 'W'
week of year     : 'ww
EOD
), "\n";

$cal->setFirstDayOfWeek(IntlCalendar::DOW_SUNDAY);

echo IntlDateFormatter::formatObject($cal, <<<EOD
'local day of week: 'cc'
week of month    : 'W'
week of year     : 'ww
EOD
), "\n";

以上例程会输出：

int(2)
local day of week: 7
week of month    : 4
week of year     : 26
local day of week: 1
week of month    : 5
week of year     : 27


Set whether date/time interpretation is to be lenient

  • ? IntlCalendar::setFirstDayOfWeek
  • IntlCalendar::setMinimalDaysInFirstWeek ?
  • PHP Manual
  • IntlCalendar
  • Set whether date/time interpretation is to be lenient

IntlCalendar::setLenient

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setLenient — Set whether date/time interpretation is to be lenient

说明

面向对象风格

public IntlCalendar::setLenient ( bool $isLenient ) : bool

过程化风格

intlcal_set_lenient ( IntlCalendar $cal , bool $isLenient ) : bool

Defines whether the calendar is 'lenient mode'. In such a mode, some of out-of-bounds values for some fields are accepted, the behavior being similar to that of IntlCalendar::add() (i.e., the value wraps around, carrying into more significant fields each time). If the lenient mode is off, then such values will generate an error.

参数

cal

The IntlCalendar resource.

isLenient

Use true to activate the lenient mode; false otherwise.

返回值

Returns true on success. Failure can only happen due to invalid parameters.

范例

See the example in IntlCalendar::isLenient().


Set minimal number of days the first week in a year or month can have

  • ? IntlCalendar::setLenient
  • IntlCalendar::setRepeatedWallTimeOption ?
  • PHP Manual
  • IntlCalendar
  • Set minimal number of days the first week in a year or month can have

IntlCalendar::setMinimalDaysInFirstWeek

(PHP 5 >= 5.5.1, PHP 7)

IntlCalendar::setMinimalDaysInFirstWeek — Set minimal number of days the first week in a year or month can have

说明

面向对象风格

public IntlCalendar::setMinimalDaysInFirstWeek ( int $minimalDays ) : bool

过程化风格

intlcal_set_minimal_days_in_first_week ( IntlCalendar $cal , int $minimalDays ) : bool

Sets the smallest number of days the first week of a year or month must have in the new year or month. For instance, in the Gregorian calendar, if this value is 1, then the first week of the year will necessarily include January 1st, while if this value is 7, then the week with January 1st will be the first week of the year only if the day of the week for January 1st matches the day of the week returned by IntlCalendar::getFirstDayOfWeek(); otherwise it will be the previous year?s last week.

参数

cal

The IntlCalendar resource.

minimalDays

The number of minimal days to set.

返回值

true on success, false on failure.


Set behavior for handling repeating wall times at negative timezone offset transitions

  • ? IntlCalendar::setMinimalDaysInFirstWeek
  • IntlCalendar::setSkippedWallTimeOption ?
  • PHP Manual
  • IntlCalendar
  • Set behavior for handling repeating wall times at negative timezone offset transitions

IntlCalendar::setRepeatedWallTimeOption

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setRepeatedWallTimeOption — Set behavior for handling repeating wall times at negative timezone offset transitions

说明

面向对象风格

public IntlCalendar::setRepeatedWallTimeOption ( int $wallTimeOption ) : bool

过程化风格

intlcal_set_repeated_wall_time_option ( IntlCalendar $cal , int $wallTimeOption ) : bool

Sets the current strategy for dealing with wall times that are repeated whenever the clock is set back during dailight saving time end transitions. The default value is IntlCalendar::WALLTIME_LAST (take the post-DST instant). The other possible value is IntlCalendar::WALLTIME_FIRST (take the instant that occurs during DST).

This function requires ICU 4.9 or later.

参数

cal

The IntlCalendar resource.

wallTimeOption

One of the constants IntlCalendar::WALLTIME_FIRST or IntlCalendar::WALLTIME_LAST.

返回值

Returns true on success. Failure can only happen due to invalid parameters.

范例

See the example on IntlCalendar::getRepeatedWallTimeOption().

参见

  • intlCalendar::getRepeatedWallTimeOption() - Get behavior for handling repeating wall time
  • intlCalendar::setSkippedWallTimeOption() - Set behavior for handling skipped wall times at positive timezone offset transitions
  • intlCalendar::getSkippedWallTimeOption() - Get behavior for handling skipped wall time


Set behavior for handling skipped wall times at positive timezone offset transitions

  • ? IntlCalendar::setRepeatedWallTimeOption
  • IntlCalendar::setTime ?
  • PHP Manual
  • IntlCalendar
  • Set behavior for handling skipped wall times at positive timezone offset transitions

IntlCalendar::setSkippedWallTimeOption

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setSkippedWallTimeOption — Set behavior for handling skipped wall times at positive timezone offset transitions

说明

面向对象风格

public IntlCalendar::setSkippedWallTimeOption ( int $wallTimeOption ) : bool

过程化风格

intlcal_set_skipped_wall_time_option ( IntlCalendar $cal , int $wallTimeOption ) : bool

Sets the current strategy for dealing with wall times that are skipped whenever the clock is forwarded during dailight saving time start transitions. The default value is IntlCalendar::WALLTIME_LAST (take it as being the same instant as the one when the wall time is one hour more). Alternative values are IntlCalendar::WALLTIME_FIRST (same instant as the one with a wall time of one hour less) and IntlCalendar::WALLTIME_NEXT_VALID (same instant as when DST begins).

This affects only the instant represented by the calendar (as reported by IntlCalendar::getTime()), the field values will not be rewritten accordingly.

The calendar must be lenient for this option to have any effect, otherwise attempting to set a non-existing time will cause an error.

This function requires ICU 4.9 or later.

参数

cal

The IntlCalendar resource.

wallTimeOption

One of the constants IntlCalendar::WALLTIME_FIRST,
IntlCalendar::WALLTIME_LAST or
IntlCalendar::WALLTIME_NEXT_VALID.

返回值

Returns true on success. Failure can only happen due to invalid parameters.

范例

See the example on IntlCalendar::getSkippedWallTimeOption().

参见

  • intlCalendar::getSkippedWallTimeOption() - Get behavior for handling skipped wall time
  • intlCalendar::setRepeatedWallTimeOption() - Set behavior for handling repeating wall times at negative timezone offset transitions
  • intlCalendar::getRepeatedWallTimeOption() - Get behavior for handling repeating wall time


Set the calendar time in milliseconds since the epoch

  • ? IntlCalendar::setSkippedWallTimeOption
  • IntlCalendar::setTimeZone ?
  • PHP Manual
  • IntlCalendar
  • Set the calendar time in milliseconds since the epoch

IntlCalendar::setTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setTime — Set the calendar time in milliseconds since the epoch

说明

面向对象风格

public IntlCalendar::setTime ( float $date ) : bool

过程化风格

intlcal_set_time ( IntlCalendar $cal , float $date ) : bool

Sets the instant represented by this object. The instant is represented by a float whose value should be an integer number of milliseconds since the epoch (1 Jan 1970 00:00:00.000 UTC), ignoring leap seconds. All the field values will be recalculated accordingly.

参数

cal

The IntlCalendar resource.

date

An instant represented by the number of number of milliseconds between such instant and the epoch, ignoring leap seconds.

返回值

Returns true on success and false on failure.

范例

Example #1 IntlCalendar::setTime()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'fr_FR');

$cal = new IntlGregorianCalendar(2013, 5 /* May */, 1, 12, 0, 0);

echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";

/* In Europe/Lisbon, on 2013-10-27 at 0200, the clock goes back one hour and
   the timezone from UTC+01 to UTC+00 */

$cal->setTime(strtotime('2013-10-27 00:30:00 UTC') * 1000.);

echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";

$cal->setTime(strtotime('2013-10-27 01:30:00 UTC') * 1000.);

echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";

以上例程会输出：

samedi 1 juin 2013 12:00:00 heure avancée d'Europe de l'Ouest
dimanche 27 octobre 2013 01:30:00 heure avancée d'Europe de l'Ouest
dimanche 27 octobre 2013 01:30:00 heure normale d'Europe de l'Ouest


Set the timezone used by this calendar

  • ? IntlCalendar::setTime
  • IntlCalendar::toDateTime ?
  • PHP Manual
  • IntlCalendar
  • Set the timezone used by this calendar

IntlCalendar::setTimeZone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlCalendar::setTimeZone — Set the timezone used by this calendar

说明

面向对象风格

public IntlCalendar::setTimeZone ( mixed $timeZone ) : bool

过程化风格

intlcal_set_time_zone ( IntlCalendar $cal , mixed $timeZone ) : bool

Defines a new timezone for this calendar. The time represented by the object is preserved to the detriment of the field values.

参数

cal

The IntlCalendar resource.

timeZone

The new timezone to be used by this calendar. It can be specified in the following ways:

  • null, in which case the default timezone will be used, as specified in the ini setting date.timezone or through the function date_default_timezone_set() and as returned by date_default_timezone_get().

  • An IntlTimeZone, which will be used directly.

  • A DateTimeZone. Its identifier will be extracted and an ICU timezone object will be created; the timezone will be backed by ICU?s database, not PHP?s.

  • A string, which should be a valid ICU timezone identifier. See IntlTimeZone::createTimeZoneIDEnumeration(). Raw offsets such as "GMT+08:30" are also accepted.

返回值

Returns true on success and false on failure.

范例

Example #1 IntlCalendar::setTimeZone()

<?php
ini_set('date.timezone', 'Europe/Lisbon');
ini_set('intl.default_locale', 'es_ES');

$cal = new IntlGregorianCalendar(2013, 5 /* May */, 1, 12, 0, 0);

echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";
echo "(instant {$cal->getTime()})\n";

$cal->setTimeZone(IntlTimeZone::getGMT());
echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";
echo "(instant {$cal->getTime()})\n";

$cal->setTimeZone('GMT+03:33');
echo IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL), "\n";
echo "(instant {$cal->getTime()})\n";

以上例程会输出：

sábado, 1 de junio de 2013 12:00:00 Hora de verano de Europa occidental
(instant 1370084400000)
sábado, 1 de junio de 2013 11:00:00 GMT
(instant 1370084400000)
sábado, 1 de junio de 2013 14:33:00 GMT+03:33
(instant 1370084400000)


Convert an IntlCalendar into a DateTime object

  • ? IntlCalendar::setTimeZone
  • IntlGregorianCalendar ?
  • PHP Manual
  • IntlCalendar
  • Convert an IntlCalendar into a DateTime object

IntlCalendar::toDateTime

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a2)

IntlCalendar::toDateTime — Convert an IntlCalendar into a DateTime object

说明

面向对象风格

public IntlCalendar::toDateTime ( ) : DateTime

过程化风格

intlcal_to_date_time ( IntlCalendar $cal ) : DateTime

Create a DateTime object that represents the same instant (up to second precision, with a rounding error of less than 1 second) and has an analog timezone to this object (the difference being DateTime?s timezone will be backed by PHP?s timezone while IntlCalendar?s timezone is backed by ICU?s).

参数

cal

The IntlCalendar resource.

返回值

A DateTime object with the same timezone as this object (though using PHP?s database instead of ICU?s) and the same time, except for the smaller precision (second precision instead of millisecond). Returns false on failure.

范例

Example #1 IntlCalendar::toDateTime()

<?php
ini_set('date.timezone', 'UTC');
ini_set('intl.default_locale', 'pt_PT');

$cal = IntlCalendar::createInstance('Europe/Lisbon'); //current time

$dt = $cal->toDateTime();
print_r($dt);

以上例程会输出：

DateTime Object
(
    [date] => 2013-07-02 00:29:13
    [timezone_type] => 3
    [timezone] => Europe/Lisbon
)

参见

  • IntlCalendar::fromDateTime() - Create an IntlCalendar from a DateTime object or string
  • IntlCalendar::getTime() - Get time currently represented by the object
  • IntlCalendar::createInstance() - Create a new IntlCalendar
  • DateTime:__construct()


The IntlGregorianCalendar class

(PHP 5 >= 5.5.0, PHP 7)

简介

类摘要

IntlGregorianCalendar extends IntlCalendar {
/* 继承的常量 */
const int IntlCalendar::FIELD_ERA = 0 ;
const int IntlCalendar::FIELD_YEAR = 1 ;
const int IntlCalendar::FIELD_MONTH = 2 ;
const int IntlCalendar::FIELD_WEEK_OF_YEAR = 3 ;
const int IntlCalendar::FIELD_WEEK_OF_MONTH = 4 ;
const int IntlCalendar::FIELD_DATE = 5 ;
const int IntlCalendar::FIELD_DAY_OF_YEAR = 6 ;
const int IntlCalendar::FIELD_DAY_OF_WEEK = 7 ;
const int IntlCalendar::FIELD_DAY_OF_WEEK_IN_MONTH = 8 ;
const int IntlCalendar::FIELD_AM_PM = 9 ;
const int IntlCalendar::FIELD_HOUR = 10 ;
const int IntlCalendar::FIELD_HOUR_OF_DAY = 11 ;
const int IntlCalendar::FIELD_MINUTE = 12 ;
const int IntlCalendar::FIELD_SECOND = 13 ;
const int IntlCalendar::FIELD_MILLISECOND = 14 ;
const int IntlCalendar::FIELD_ZONE_OFFSET = 15 ;
const int IntlCalendar::FIELD_DST_OFFSET = 16 ;
const int IntlCalendar::FIELD_YEAR_WOY = 17 ;
const int IntlCalendar::FIELD_DOW_LOCAL = 18 ;
const int IntlCalendar::FIELD_EXTENDED_YEAR = 19 ;
const int IntlCalendar::FIELD_JULIAN_DAY = 20 ;
const int IntlCalendar::FIELD_MILLISECONDS_IN_DAY = 21 ;
const int IntlCalendar::FIELD_IS_LEAP_MONTH = 22 ;
const int IntlCalendar::FIELD_FIELD_COUNT = 23 ;
const int IntlCalendar::FIELD_DAY_OF_MONTH = 5 ;
const int IntlCalendar::DOW_SUNDAY = 1 ;
const int IntlCalendar::DOW_MONDAY = 2 ;
const int IntlCalendar::DOW_TUESDAY = 3 ;
const int IntlCalendar::DOW_WEDNESDAY = 4 ;
const int IntlCalendar::DOW_THURSDAY = 5 ;
const int IntlCalendar::DOW_FRIDAY = 6 ;
const int IntlCalendar::DOW_SATURDAY = 7 ;
const int IntlCalendar::DOW_TYPE_WEEKDAY = 0 ;
const int IntlCalendar::DOW_TYPE_WEEKEND = 1 ;
const int IntlCalendar::DOW_TYPE_WEEKEND_OFFSET = 2 ;
const int IntlCalendar::DOW_TYPE_WEEKEND_CEASE = 3 ;
const int IntlCalendar::WALLTIME_FIRST = 1 ;
const int IntlCalendar::WALLTIME_LAST = 0 ;
const int IntlCalendar::WALLTIME_NEXT_VALID = 2 ;
/* 方法 */
public __construct ( IntlTimeZone $tz = ? , string $locale = ? )
public getGregorianChange ( ) : float|false
public isLeapYear ( int $year ) : bool
public setGregorianChange ( float $date ) : bool
/* 继承的方法 */
public IntlCalendar::add ( int $field , int $amount ) : bool
public IntlCalendar::after ( IntlCalendar $other ) : bool
public IntlCalendar::before ( IntlCalendar $other ) : bool
public IntlCalendar::clear ( int $field = NULL ) : bool
private IntlCalendar::__construct ( )
public static IntlCalendar::createInstance ( mixed $timeZone = NULL , string $locale = "" ) : IntlCalendar
public IntlCalendar::equals ( IntlCalendar $other ) : bool
public IntlCalendar::fieldDifference ( float $when , int $field ) : int|false
public static IntlCalendar::fromDateTime ( mixed $dateTime ) : IntlCalendar
public IntlCalendar::get ( int $field ) : int
public IntlCalendar::getActualMaximum ( int $field ) : int|false
public IntlCalendar::getActualMinimum ( int $field ) : int|false
public static IntlCalendar::getAvailableLocales ( ) : array
public IntlCalendar::getDayOfWeekType ( int $dayOfWeek ) : int|false
public IntlCalendar::getErrorCode ( ) : int
public IntlCalendar::getErrorMessage ( ) : string
public IntlCalendar::getFirstDayOfWeek ( ) : int|false
public IntlCalendar::getGreatestMinimum ( int $field ) : int|false
public static IntlCalendar::getKeywordValuesForLocale ( string $key , string $locale , bool $commonlyUsed ) : Iterator|false
public IntlCalendar::getLeastMaximum ( int $field ) : int|false
public IntlCalendar::getLocale ( int $localeType ) : string|false
public IntlCalendar::getMaximum ( int $field ) : int|false
public IntlCalendar::getMinimalDaysInFirstWeek ( ) : int|false
public IntlCalendar::getMinimum ( int $field ) : int|false
public static IntlCalendar::getNow ( ) : float
public IntlCalendar::getRepeatedWallTimeOption ( ) : int
public IntlCalendar::getSkippedWallTimeOption ( ) : int
public IntlCalendar::getTime ( ) : float
public IntlCalendar::getTimeZone ( ) : IntlTimeZone
public IntlCalendar::getType ( ) : string
public IntlCalendar::getWeekendTransition ( string $dayOfWeek ) : int|false
public IntlCalendar::inDaylightTime ( ) : bool
public IntlCalendar::isEquivalentTo ( IntlCalendar $other ) : bool
public IntlCalendar::isLenient ( ) : bool
public IntlCalendar::isSet ( int $field ) : bool
public IntlCalendar::isWeekend ( float $date = NULL ) : bool
public IntlCalendar::roll ( int $field , mixed $amountOrUpOrDown ) : bool
public IntlCalendar::set ( int $field , int $value ) : bool
public IntlCalendar::set ( int $year , int $month , int $dayOfMonth = NULL , int $hour = NULL , int $minute = NULL , int $second = NULL ) : bool
public IntlCalendar::setFirstDayOfWeek ( int $dayOfWeek ) : bool
public IntlCalendar::setLenient ( bool $isLenient ) : bool
public IntlCalendar::setMinimalDaysInFirstWeek ( int $minimalDays ) : bool
public IntlCalendar::setRepeatedWallTimeOption ( int $wallTimeOption ) : bool
public IntlCalendar::setSkippedWallTimeOption ( int $wallTimeOption ) : bool
public IntlCalendar::setTime ( float $date ) : bool
public IntlCalendar::setTimeZone ( mixed $timeZone ) : bool
public IntlCalendar::toDateTime ( ) : DateTime
}

Table of Contents

  • IntlGregorianCalendar::__construct — Create the Gregorian Calendar class
  • IntlGregorianCalendar::getGregorianChange — Get the Gregorian Calendar change date
  • IntlGregorianCalendar::isLeapYear — Determine if the given year is a leap year
  • IntlGregorianCalendar::setGregorianChange — Set the Gregorian Calendar the change date


Create the Gregorian Calendar class

  • ? IntlGregorianCalendar
  • IntlGregorianCalendar::getGregorianChange ?
  • PHP Manual
  • IntlGregorianCalendar
  • Create the Gregorian Calendar class

IntlGregorianCalendar::__construct

(PHP 5 >= 5.5.0, PHP 7)

IntlGregorianCalendar::__construct — Create the Gregorian Calendar class

说明

public IntlGregorianCalendar::__construct ( IntlTimeZone $tz = ? , string $locale = ? )
public IntlGregorianCalendar::__construct ( int $timeZoneOrYear , int $localeOrMonth , int $dayOfMonth )
public IntlGregorianCalendar::__construct ( int $timeZoneOrYear , int $localeOrMonth , int $dayOfMonth , int $hour , int $minute , int $second = ? )

Warning

本函数还未编写文档，仅有参数列表。

参数

tz

locale

timeZoneOrYear

localeOrMonth

dayOfMonth

hour

minute

second


Get the Gregorian Calendar change date

  • ? IntlGregorianCalendar::__construct
  • IntlGregorianCalendar::isLeapYear ?
  • PHP Manual
  • IntlGregorianCalendar
  • Get the Gregorian Calendar change date

IntlGregorianCalendar::getGregorianChange

(PHP 5 >= 5.5.0, PHP 7)

IntlGregorianCalendar::getGregorianChange — Get the Gregorian Calendar change date

说明

public IntlGregorianCalendar::getGregorianChange ( ) : float|false

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns the change date 或者在失败时返回 false.


Determine if the given year is a leap year

  • ? IntlGregorianCalendar::getGregorianChange
  • IntlGregorianCalendar::setGregorianChange ?
  • PHP Manual
  • IntlGregorianCalendar
  • Determine if the given year is a leap year

IntlGregorianCalendar::isLeapYear

(PHP 5 >= 5.5.0, PHP 7)

IntlGregorianCalendar::isLeapYear — Determine if the given year is a leap year

说明

public IntlGregorianCalendar::isLeapYear ( int $year ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

year

返回值

Returns true for leap years, false otherwise and on failure.


Set the Gregorian Calendar the change date

  • ? IntlGregorianCalendar::isLeapYear
  • IntlTimeZone ?
  • PHP Manual
  • IntlGregorianCalendar
  • Set the Gregorian Calendar the change date

IntlGregorianCalendar::setGregorianChange

(PHP 5 >= 5.5.0, PHP 7)

IntlGregorianCalendar::setGregorianChange — Set the Gregorian Calendar the change date

说明

public IntlGregorianCalendar::setGregorianChange ( float $date ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

date

返回值

成功时返回 true， 或者在失败时返回 false。


The IntlTimeZone class

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

简介

类摘要

IntlTimeZone {
/* Constants */
const int DISPLAY_SHORT = 1 ;
const int DISPLAY_LONG = 2 ;
/* 方法 */
public static countEquivalentIDs ( string $zoneId ) : int
public static createDefault ( ) : IntlTimeZone
public static createEnumeration ( mixed $countryOrRawOffset = ? ) : IntlIterator
public static createTimeZone ( string $zoneId ) : IntlTimeZone
public static createTimeZoneIDEnumeration ( int $zoneType , string $region = ? , int $rawOffset = ? ) : IntlIterator|false
public static fromDateTimeZone ( DateTimeZone $zoneId ) : IntlTimeZone
public static getCanonicalID ( string $zoneId , bool &$isSystemID = ? ) : string
public getDisplayName ( bool $isDaylight = ? , int $style = ? , string $locale = ? ) : string
public getDSTSavings ( ) : int
public static getEquivalentID ( string $zoneId , int $index ) : string
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public static getGMT ( ) : IntlTimeZone
public getID ( ) : string
public static getIDForWindowsID ( string $timezone , string $region = ? ) : string|false
public getOffset ( float $date , bool $local , int &$rawOffset , int &$dstOffset ) : bool
public getRawOffset ( ) : int
public static getRegion ( string $zoneId ) : string|false
public static getTZDataVersion ( ) : string
public static getUnknown ( ) : IntlTimeZone
public static getWindowsID ( string $timezone ) : string|false
public hasSameRules ( IntlTimeZone $otherTimeZone ) : bool
public toDateTimeZone ( ) : DateTimeZone
public useDaylightTime ( ) : bool
}

预定义常量

IntlTimeZone::DISPLAY_SHORT

IntlTimeZone::DISPLAY_LONG

Table of Contents

  • IntlTimeZone::countEquivalentIDs — Get the number of IDs in the equivalency group that includes the given ID
  • IntlTimeZone::createDefault — Create a new copy of the default timezone for this host
  • IntlTimeZone::createEnumeration — Get an enumeration over time zone IDs associated with the given country or offset
  • IntlTimeZone::createTimeZone — Create a timezone object for the given ID
  • IntlTimeZone::createTimeZoneIDEnumeration — Get an enumeration over system time zone IDs with the given filter conditions
  • IntlTimeZone::fromDateTimeZone — Create a timezone object from DateTimeZone
  • IntlTimeZone::getCanonicalID — Get the canonical system timezone ID or the normalized custom time zone ID for the given time zone ID
  • IntlTimeZone::getDisplayName — Get a name of this time zone suitable for presentation to the user
  • IntlTimeZone::getDSTSavings — Get the amount of time to be added to local standard time to get local wall clock time
  • IntlTimeZone::getEquivalentID — Get an ID in the equivalency group that includes the given ID
  • IntlTimeZone::getErrorCode — Get last error code on the object
  • IntlTimeZone::getErrorMessage — Get last error message on the object
  • IntlTimeZone::getGMT — Create GMT (UTC) timezone
  • IntlTimeZone::getID — Get timezone ID
  • IntlTimeZone::getIDForWindowsID — Translate a Windows timezone into a system timezone
  • IntlTimeZone::getOffset — Get the time zone raw and GMT offset for the given moment in time
  • IntlTimeZone::getRawOffset — Get the raw GMT offset (before taking daylight savings time into account
  • IntlTimeZone::getRegion — Get the region code associated with the given system time zone ID
  • IntlTimeZone::getTZDataVersion — Get the timezone data version currently used by ICU
  • IntlTimeZone::getUnknown — Get the "unknown" time zone
  • IntlTimeZone::getWindowsID — Translate a system timezone into a Windows timezone
  • IntlTimeZone::hasSameRules — Check if this zone has the same rules and offset as another zone
  • IntlTimeZone::toDateTimeZone — Convert to DateTimeZone object
  • IntlTimeZone::useDaylightTime — Check if this time zone uses daylight savings time


Get the number of IDs in the equivalency group that includes the given ID

  • ? IntlTimeZone
  • IntlTimeZone::createDefault ?
  • PHP Manual
  • IntlTimeZone
  • Get the number of IDs in the equivalency group that includes the given ID

IntlTimeZone::countEquivalentIDs

intltz_count_equivalent_ids

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::countEquivalentIDs -- intltz_count_equivalent_ids — Get the number of IDs in the equivalency group that includes the given ID

说明

面向对象风格 (method):

public static IntlTimeZone::countEquivalentIDs ( string $zoneId ) : int

过程化风格:

intltz_count_equivalent_ids ( string $zoneId ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

zoneId

返回值


Create a new copy of the default timezone for this host

  • ? IntlTimeZone::countEquivalentIDs
  • IntlTimeZone::createEnumeration ?
  • PHP Manual
  • IntlTimeZone
  • Create a new copy of the default timezone for this host

IntlTimeZone::createDefault

intltz_create_default

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::createDefault -- intltz_create_default — Create a new copy of the default timezone for this host

说明

面向对象风格 (method):

public static IntlTimeZone::createDefault ( ) : IntlTimeZone

过程化风格:

intltz_create_default ( ) : IntlTimeZone

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get an enumeration over time zone IDs associated with the given country or offset

  • ? IntlTimeZone::createDefault
  • IntlTimeZone::createTimeZone ?
  • PHP Manual
  • IntlTimeZone
  • Get an enumeration over time zone IDs associated with the given country or offset

IntlTimeZone::createEnumeration

intltz_create_enumeration

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::createEnumeration -- intltz_create_enumeration — Get an enumeration over time zone IDs associated with the given country or offset

说明

面向对象风格 (method):

public static IntlTimeZone::createEnumeration ( mixed $countryOrRawOffset = ? ) : IntlIterator

过程化风格:

intltz_create_enumeration ( mixed $countryOrRawOffset = ? ) : IntlIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

countryOrRawOffset

返回值


Create a timezone object for the given ID

  • ? IntlTimeZone::createEnumeration
  • IntlTimeZone::createTimeZoneIDEnumeration ?
  • PHP Manual
  • IntlTimeZone
  • Create a timezone object for the given ID

IntlTimeZone::createTimeZone

intltz_create_time_zone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::createTimeZone -- intltz_create_time_zone — Create a timezone object for the given ID

说明

面向对象风格 (method):

public static IntlTimeZone::createTimeZone ( string $zoneId ) : IntlTimeZone

过程化风格:

intltz_create_time_zone ( string $zoneId ) : IntlTimeZone

Warning

本函数还未编写文档，仅有参数列表。

参数

zoneId

返回值


Get an enumeration over system time zone IDs with the given filter conditions

  • ? IntlTimeZone::createTimeZone
  • IntlTimeZone::fromDateTimeZone ?
  • PHP Manual
  • IntlTimeZone
  • Get an enumeration over system time zone IDs with the given filter conditions

IntlTimeZone::createTimeZoneIDEnumeration

intltz_create_time_zone_id_enumeration

(PHP 5 >= 5.5.0, PHP 7)

IntlTimeZone::createTimeZoneIDEnumeration -- intltz_create_time_zone_id_enumeration — Get an enumeration over system time zone IDs with the given filter conditions

说明

面向对象风格 (method):

public static IntlTimeZone::createTimeZoneIDEnumeration ( int $zoneType , string $region = ? , int $rawOffset = ? ) : IntlIterator|false

过程化风格:

intltz_create_time_zone_id_enumeration ( int $zoneType , string $region = ? , int $rawOffset = ? ) : IntlIterator|false

Warning

本函数还未编写文档，仅有参数列表。

参数

zoneType

region

rawOffset

返回值

Returns IntlIterator 或者在失败时返回 false.


Create a timezone object from DateTimeZone

  • ? IntlTimeZone::createTimeZoneIDEnumeration
  • IntlTimeZone::getCanonicalID ?
  • PHP Manual
  • IntlTimeZone
  • Create a timezone object from DateTimeZone

IntlTimeZone::fromDateTimeZone

intltz_from_date_time_zone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::fromDateTimeZone -- intltz_from_date_time_zone — Create a timezone object from DateTimeZone

说明

面向对象风格 (method):

public static IntlTimeZone::fromDateTimeZone ( DateTimeZone $zoneId ) : IntlTimeZone

过程化风格:

intltz_from_date_time_zone ( DateTimeZone $zoneId ) : IntlTimeZone

Warning

本函数还未编写文档，仅有参数列表。

参数

zoneId

返回值


Get the canonical system timezone ID or the normalized custom time zone ID for the given time zone ID

  • ? IntlTimeZone::fromDateTimeZone
  • IntlTimeZone::getDisplayName ?
  • PHP Manual
  • IntlTimeZone
  • Get the canonical system timezone ID or the normalized custom time zone ID for the given time zone ID

IntlTimeZone::getCanonicalID

intltz_get_canonical_id

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getCanonicalID -- intltz_get_canonical_id — Get the canonical system timezone ID or the normalized custom time zone ID for the given time zone ID

说明

面向对象风格 (method):

public static IntlTimeZone::getCanonicalID ( string $zoneId , bool &$isSystemID = ? ) : string

过程化风格:

intltz_get_canonical_id ( string $zoneId , bool &$isSystemID = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

zoneId

isSystemID

返回值


Get a name of this time zone suitable for presentation to the user

  • ? IntlTimeZone::getCanonicalID
  • IntlTimeZone::getDSTSavings ?
  • PHP Manual
  • IntlTimeZone
  • Get a name of this time zone suitable for presentation to the user

IntlTimeZone::getDisplayName

intltz_get_display_name

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getDisplayName -- intltz_get_display_name — Get a name of this time zone suitable for presentation to the user

说明

面向对象风格 (method):

public IntlTimeZone::getDisplayName ( bool $isDaylight = ? , int $style = ? , string $locale = ? ) : string

过程化风格:

intltz_get_display_name ( IntlTimeZone $timezone , bool $isDaylight = ? , int $style = ? , string $locale = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

isDaylight

style

locale

返回值


Get the amount of time to be added to local standard time to get local wall clock time

  • ? IntlTimeZone::getDisplayName
  • IntlTimeZone::getEquivalentID ?
  • PHP Manual
  • IntlTimeZone
  • Get the amount of time to be added to local standard time to get local wall clock time

IntlTimeZone::getDSTSavings

intltz_get_dst_savings

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getDSTSavings -- intltz_get_dst_savings — Get the amount of time to be added to local standard time to get local wall clock time

说明

面向对象风格 (method):

public IntlTimeZone::getDSTSavings ( ) : int

过程化风格:

intltz_get_dst_savings ( IntlTimeZone $timezone ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get an ID in the equivalency group that includes the given ID

  • ? IntlTimeZone::getDSTSavings
  • IntlTimeZone::getErrorCode ?
  • PHP Manual
  • IntlTimeZone
  • Get an ID in the equivalency group that includes the given ID

IntlTimeZone::getEquivalentID

intltz_get_equivalent_id

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getEquivalentID -- intltz_get_equivalent_id — Get an ID in the equivalency group that includes the given ID

说明

面向对象风格 (method):

public static IntlTimeZone::getEquivalentID ( string $zoneId , int $index ) : string

过程化风格:

intltz_get_equivalent_id ( string $zoneId , int $index ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

zoneId

index

返回值


Get last error code on the object

  • ? IntlTimeZone::getEquivalentID
  • IntlTimeZone::getErrorMessage ?
  • PHP Manual
  • IntlTimeZone
  • Get last error code on the object

IntlTimeZone::getErrorCode

intltz_get_error_code

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getErrorCode -- intltz_get_error_code — Get last error code on the object

说明

面向对象风格 (method):

public IntlTimeZone::getErrorCode ( ) : int

过程化风格:

intltz_get_error_code ( IntlTimeZone $timezone ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get last error message on the object

  • ? IntlTimeZone::getErrorCode
  • IntlTimeZone::getGMT ?
  • PHP Manual
  • IntlTimeZone
  • Get last error message on the object

IntlTimeZone::getErrorMessage

intltz_get_error_message

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getErrorMessage -- intltz_get_error_message — Get last error message on the object

说明

面向对象风格 (method):

public IntlTimeZone::getErrorMessage ( ) : string

过程化风格:

intltz_get_error_message ( IntlTimeZone $timezone ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Create GMT (UTC) timezone

  • ? IntlTimeZone::getErrorMessage
  • IntlTimeZone::getID ?
  • PHP Manual
  • IntlTimeZone
  • Create GMT (UTC) timezone

IntlTimeZone::getGMT

intltz_get_gmt

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getGMT -- intltz_get_gmt — Create GMT (UTC) timezone

说明

面向对象风格 (method):

public static IntlTimeZone::getGMT ( ) : IntlTimeZone

过程化风格:

intltz_get_gmt ( ) : IntlTimeZone

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get timezone ID

  • ? IntlTimeZone::getGMT
  • IntlTimeZone::getIDForWindowsID ?
  • PHP Manual
  • IntlTimeZone
  • Get timezone ID

IntlTimeZone::getID

intltz_get_id

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getID -- intltz_get_id — Get timezone ID

说明

面向对象风格 (method):

public IntlTimeZone::getID ( ) : string

过程化风格:

intltz_get_id ( IntlTimeZone $timezone ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Translate a Windows timezone into a system timezone

  • ? IntlTimeZone::getID
  • IntlTimeZone::getOffset ?
  • PHP Manual
  • IntlTimeZone
  • Translate a Windows timezone into a system timezone

IntlTimeZone::getIDForWindowsID

intltz_get_id_for_windows_id

(PHP 7 >= 7.1.0)

IntlTimeZone::getIDForWindowsID -- intltz_get_id_for_windows_id — Translate a Windows timezone into a system timezone

说明

面向对象风格 (method):

public static IntlTimeZone::getIDForWindowsID ( string $timezone , string $region = ? ) : string|false

过程化风格:

intltz_get_id_for_windows_id ( string $timezone , string $region = ? ) : string|false

Translates a Windows timezone (e.g. "Pacific Standard Time") into a system timezone (e.g. "America/Los_Angeles").

Note: This function requires ICU version ≥ 52.

Warning

本函数还未编写文档，仅有参数列表。

参数

timezone

region

返回值

Returns the system timezone 或者在失败时返回 false.

参见

  • IntlTimeZone::getWindowsID() - Translate a system timezone into a Windows timezone


Get the time zone raw and GMT offset for the given moment in time

  • ? IntlTimeZone::getIDForWindowsID
  • IntlTimeZone::getRawOffset ?
  • PHP Manual
  • IntlTimeZone
  • Get the time zone raw and GMT offset for the given moment in time

IntlTimeZone::getOffset

intltz_get_offset

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getOffset -- intltz_get_offset — Get the time zone raw and GMT offset for the given moment in time

说明

面向对象风格 (method):

public IntlTimeZone::getOffset ( float $date , bool $local , int &$rawOffset , int &$dstOffset ) : bool

过程化风格:

intltz_get_offset ( IntlTimeZone $timezone , float $date , bool $local , int &$rawOffset , int &$dstOffset ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

date

local

rawOffset

dstOffset

返回值


Get the raw GMT offset (before taking daylight savings time into account

  • ? IntlTimeZone::getOffset
  • IntlTimeZone::getRegion ?
  • PHP Manual
  • IntlTimeZone
  • Get the raw GMT offset (before taking daylight savings time into account

IntlTimeZone::getRawOffset

intltz_get_raw_offset

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getRawOffset -- intltz_get_raw_offset — Get the raw GMT offset (before taking daylight savings time into account

说明

面向对象风格 (method):

public IntlTimeZone::getRawOffset ( ) : int

过程化风格:

intltz_get_raw_offset ( IntlTimeZone $timezone ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the region code associated with the given system time zone ID

  • ? IntlTimeZone::getRawOffset
  • IntlTimeZone::getTZDataVersion ?
  • PHP Manual
  • IntlTimeZone
  • Get the region code associated with the given system time zone ID

IntlTimeZone::getRegion

intltz_get_region

(PHP 5 >= 5.5.0, PHP 7)

IntlTimeZone::getRegion -- intltz_get_region — Get the region code associated with the given system time zone ID

说明

面向对象风格 (method):

public static IntlTimeZone::getRegion ( string $zoneId ) : string|false

过程化风格:

intltz_get_region ( string $zoneId ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

zoneId

返回值

Return region 或者在失败时返回 false.


Get the timezone data version currently used by ICU

  • ? IntlTimeZone::getRegion
  • IntlTimeZone::getUnknown ?
  • PHP Manual
  • IntlTimeZone
  • Get the timezone data version currently used by ICU

IntlTimeZone::getTZDataVersion

intltz_get_tz_data_version

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::getTZDataVersion -- intltz_get_tz_data_version — Get the timezone data version currently used by ICU

说明

面向对象风格 (method):

public static IntlTimeZone::getTZDataVersion ( ) : string

过程化风格:

intltz_get_tz_data_version ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the "unknown" time zone

  • ? IntlTimeZone::getTZDataVersion
  • IntlTimeZone::getWindowsID ?
  • PHP Manual
  • IntlTimeZone
  • Get the "unknown" time zone

IntlTimeZone::getUnknown

intltz_get_unknown

(PHP 5 >= 5.5.0, PHP 7)

IntlTimeZone::getUnknown -- intltz_get_unknown — Get the "unknown" time zone

说明

面向对象风格 (method):

public static IntlTimeZone::getUnknown ( ) : IntlTimeZone

过程化风格:

intltz_get_unknown ( ) : IntlTimeZone

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns IntlTimeZone or null on failure.


Translate a system timezone into a Windows timezone

  • ? IntlTimeZone::getUnknown
  • IntlTimeZone::hasSameRules ?
  • PHP Manual
  • IntlTimeZone
  • Translate a system timezone into a Windows timezone

IntlTimeZone::getWindowsID

intltz_get_windows_id

(PHP 7 >= 7.1.0)

IntlTimeZone::getWindowsID -- intltz_get_windows_id — Translate a system timezone into a Windows timezone

说明

面向对象风格 (method):

public static IntlTimeZone::getWindowsID ( string $timezone ) : string|false

过程化风格:

intltz_get_windows_id ( string $timezone ) : string|false

Translates a system timezone (e.g. "America/Los_Angeles") into a Windows timezone (e.g. "Pacific Standard Time").

Note: This function requires ICU version ≥ 52.

Warning

本函数还未编写文档，仅有参数列表。

参数

timezone

返回值

Returns the Windows timezone 或者在失败时返回 false.

参见

  • IntlTimeZone::getIDForWindowsID() - Translate a Windows timezone into a system timezone


Check if this zone has the same rules and offset as another zone

  • ? IntlTimeZone::getWindowsID
  • IntlTimeZone::toDateTimeZone ?
  • PHP Manual
  • IntlTimeZone
  • Check if this zone has the same rules and offset as another zone

IntlTimeZone::hasSameRules

intltz_has_same_rules

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::hasSameRules -- intltz_has_same_rules — Check if this zone has the same rules and offset as another zone

说明

面向对象风格 (method):

public IntlTimeZone::hasSameRules ( IntlTimeZone $otherTimeZone ) : bool

过程化风格:

intltz_has_same_rules ( IntlTimeZone $timezone , IntlTimeZone $otherTimeZone ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

otherTimeZone

返回值


Convert to DateTimeZone object

  • ? IntlTimeZone::hasSameRules
  • IntlTimeZone::useDaylightTime ?
  • PHP Manual
  • IntlTimeZone
  • Convert to DateTimeZone object

IntlTimeZone::toDateTimeZone

intltz_to_date_time_zone

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::toDateTimeZone -- intltz_to_date_time_zone — Convert to DateTimeZone object

说明

面向对象风格 (method):

public IntlTimeZone::toDateTimeZone ( ) : DateTimeZone

过程化风格:

intltz_to_date_time_zone ( IntlTimeZone $timezone ) : DateTimeZone

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Check if this time zone uses daylight savings time

  • ? IntlTimeZone::toDateTimeZone
  • IntlDateFormatter ?
  • PHP Manual
  • IntlTimeZone
  • Check if this time zone uses daylight savings time

IntlTimeZone::useDaylightTime

intltz_use_daylight_time

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

IntlTimeZone::useDaylightTime -- intltz_use_daylight_time — Check if this time zone uses daylight savings time

说明

面向对象风格 (method):

public IntlTimeZone::useDaylightTime ( ) : bool

过程化风格:

intltz_use_daylight_time ( IntlTimeZone $timezone ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The IntlDateFormatter class

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

简介

Date Formatter is a concrete class that enables locale-dependent formatting/parsing of dates using pattern strings and/or canned patterns.

This class represents the ICU date formatting functionality. It allows users to display dates in a localized format or to parse strings into PHP date values using pattern strings and/or canned patterns.

Class synopsis

IntlDateFormatter {
/* 方法 */
public __construct ( string|null $locale , int $dateType , int $timeType , IntlTimeZone|DateTimeZone|string|null $timezone = null , IntlCalendar|int|null $calendar = null , string $pattern = "" )
public static create ( string|null $locale , int $dateType , int $timeType , IntlTimeZone|DateTimeZone|string|null $timezone = null , IntlCalendar|int|null $calendar = null , string $pattern = "" ) : IntlDateFormatter|null
public format ( IntlCalendar|DateTimeInterface|array|string|int|float $datetime ) : string|false
public static formatObject ( IntlCalendar|DateTime $datetime , array|int|string|null $format = null , string|null $locale = null ) : string|false
public getCalendar ( ) : int|false
public getDateType ( ) : int|false
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getLocale ( int $type = ULOC_ACTUAL_LOCALE ) : string|false
public getPattern ( ) : string|false
public getTimeType ( ) : int|false
public getTimeZoneId ( ) : string|false
public getCalendarObject ( ) : IntlCalendar|false|null
public getTimeZone ( ) : IntlTimeZone|false
public isLenient ( ) : bool
public localtime ( string $string , int &$offset = null ) : array|false
public parse ( string $string , int &$offset = null ) : int|float|false
public setCalendar ( IntlCalendar|int|null $calendar ) : bool
public setLenient ( bool $lenient ) : void
public setPattern ( string $pattern ) : bool
public setTimeZone ( IntlTimeZone|DateTimeZone|string|null $timezone ) : bool|null
}

参见

  • » ICU Date formatter
  • » ICU Date formats

预定义常量

These constants are used to specify different formats in the constructor for DateType and TimeType.

IntlDateFormatter::NONE (int)
Do not include this element
IntlDateFormatter::FULL (int)
Completely specified style (Tuesday, April 12, 1952 AD or 3:30:42pm PST)
IntlDateFormatter::LONG (int)
Long style (January 12, 1952 or 3:30:32pm)
IntlDateFormatter::MEDIUM (int)
Medium style (Jan 12, 1952)
IntlDateFormatter::SHORT (int)
Most abbreviated style, only essential data (12/13/52 or 3:30pm)
IntlDateFormatter::RELATIVE_FULL (int)
The same as IntlDateFormatter::FULL, but yesterday, today, and tomorrow show as yesterday, today, and tomorrow, respectively. Available as of PHP 8.0.0, for dateType only.
IntlDateFormatter::RELATIVE_LONG (int)
The same as IntlDateFormatter::LONG, but yesterday, today, and tomorrow show as yesterday, today, and tomorrow, respectively. Available as of PHP 8.0.0, for dateType only.
IntlDateFormatter::RELATIVE_MEDIUM (int)
The same as IntlDateFormatter::MEDIUM, but yesterday, today, and tomorrow show as yesterday, today, and tomorrow, respectively. Available as of PHP 8.0.0, for dateType only.
IntlDateFormatter::RELATIVE_SHORT (int)
The same as IntlDateFormatter::SHORT, but yesterday, today, and tomorrow show as yesterday, today, and tomorrow, respectively. Available as of PHP 8.0.0, for dateType only.

The following int constants are used to specify the calendar. These calendars are all based directly on the Gregorian calendar. Non-Gregorian calendars need to be specified in locale. Examples might include locale="hi@calendar=BUDDHIST".

IntlDateFormatter::TRADITIONAL (int)
Non-Gregorian Calendar
IntlDateFormatter::GREGORIAN (int)
Gregorian Calendar

Table of Contents

  • IntlDateFormatter::create — Create a date formatter
  • IntlDateFormatter::format — Format the date/time value as a string
  • IntlDateFormatter::formatObject — Formats an object
  • IntlDateFormatter::getCalendar — Get the calendar type used for the IntlDateFormatter
  • IntlDateFormatter::getDateType — Get the datetype used for the IntlDateFormatter
  • IntlDateFormatter::getErrorCode — Get the error code from last operation
  • IntlDateFormatter::getErrorMessage — Get the error text from the last operation
  • IntlDateFormatter::getLocale — Get the locale used by formatter
  • IntlDateFormatter::getPattern — Get the pattern used for the IntlDateFormatter
  • IntlDateFormatter::getTimeType — Get the timetype used for the IntlDateFormatter
  • IntlDateFormatter::getTimeZoneId — Get the timezone-id used for the IntlDateFormatter
  • IntlDateFormatter::getCalendarObject — Get copy of formatter?s calendar object
  • IntlDateFormatter::getTimeZone — Get formatter?s timezone
  • IntlDateFormatter::isLenient — Get the lenient used for the IntlDateFormatter
  • IntlDateFormatter::localtime — Parse string to a field-based time value
  • IntlDateFormatter::parse — Parse string to a timestamp value
  • IntlDateFormatter::setCalendar — Sets the calendar type used by the formatter
  • IntlDateFormatter::setLenient — Set the leniency of the parser
  • IntlDateFormatter::setPattern — Set the pattern used for the IntlDateFormatter
  • IntlDateFormatter::setTimeZone — Sets formatter?s timezone


Create a date formatter

  • ? IntlDateFormatter
  • IntlDateFormatter::format ?
  • PHP Manual
  • IntlDateFormatter
  • Create a date formatter

IntlDateFormatter::create

datefmt_create

IntlDateFormatter::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::create -- datefmt_create -- IntlDateFormatter::__construct — Create a date formatter

说明

面向对象风格

public static IntlDateFormatter::create ( string|null $locale , int $dateType , int $timeType , IntlTimeZone|DateTimeZone|string|null $timezone = null , IntlCalendar|int|null $calendar = null , string $pattern = "" ) : IntlDateFormatter|null

面向对象风格 (constructor)

public IntlDateFormatter::__construct ( string|null $locale , int $dateType , int $timeType , IntlTimeZone|DateTimeZone|string|null $timezone = null , IntlCalendar|int|null $calendar = null , string $pattern = "" )

过程化风格

datefmt_create ( string|null $locale , int $dateType , int $timeType , IntlTimeZone|DateTimeZone|string|null $timezone = null , IntlCalendar|int|null $calendar = null , string $pattern = "" ) : IntlDateFormatter|null

Create a date formatter.

参数

locale

Locale to use when formatting or parsing or null to use the value specified in the ini setting intl.default_locale.

dateType

Date type to use (none, short, medium, long, full). This is one of the IntlDateFormatter constants. It can also be null, in which case ICU?s default date type will be used.

timeType

Time type to use (none, short, medium, long, full). This is one of the IntlDateFormatter constants. It can also be null, in which case ICU?s default time type will be used.

timezone

Time zone ID. The default (and the one used if null is given) is the one returned by date_default_timezone_get() or, if applicable, that of the IntlCalendar object passed for the calendar parameter. This ID must be a valid identifier on ICU?s database or an ID representing an explicit offset, such as GMT-05:30.

This can also be an IntlTimeZone or a DateTimeZone object.

calendar

Calendar to use for formatting or parsing. The default value is null, which corresponds to IntlDateFormatter::GREGORIAN. This can either be one of the IntlDateFormatter calendar constants or an IntlCalendar. Any IntlCalendar object passed will be clone; it will not be changed by the IntlDateFormatter. This will determine the calendar type used (gregorian, islamic, persian, etc.) and, if null is given for the timezone parameter, also the timezone used.

pattern

Optional pattern to use when formatting or parsing. Possible patterns are documented at » https://unicode-org.github.io/icu/userguide/format_parse/datetime/.

返回值

The created IntlDateFormatter or null in case of failure.

更新日志

版本 | 说明
5.5.0/PECL 3.0.0 | An IntlCalendar object is allowed for calendar. Objects of type IntlTimeZone and DateTimeZone are allowed for timezone. Invalid timezone identifiers (including empty strings) are no longer allowed for timezone. If null is given for timezone, the timezone identifier given by date_default_timezone_get() will be used instead of ICU?s default.

范例

Example #1 datefmt_create() example

<?php
$fmt = datefmt_create( "en_US" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
    'America/Los_Angeles', IntlDateFormatter::GREGORIAN  );
echo "First Formatted output is ".datefmt_format( $fmt , 0);
$fmt = datefmt_create( "de-DE" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
    'America/Los_Angeles',IntlDateFormatter::GREGORIAN  );
echo "Second Formatted output is ".datefmt_format( $fmt , 0);

$fmt = datefmt_create( "en_US" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
     'America/Los_Angeles',IntlDateFormatter::GREGORIAN  ,"MM/dd/yyyy");
echo "First Formatted output with pattern is ".datefmt_format( $fmt , 0);
$fmt = datefmt_create( "de-DE" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
     'America/Los_Angeles',IntlDateFormatter::GREGORIAN  ,"MM/dd/yyyy");
echo "Second Formatted output with pattern is ".datefmt_format( $fmt , 0);
?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter( "en_US" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
    'America/Los_Angeles',IntlDateFormatter::GREGORIAN  );
echo "First Formatted output is ".$fmt->format(0);
$fmt = new IntlDateFormatter( "de-DE" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
    'America/Los_Angeles',IntlDateFormatter::GREGORIAN  );
echo "Second Formatted output is ".$fmt->format(0);

$fmt = new IntlDateFormatter( "en_US" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
     'America/Los_Angeles',IntlDateFormatter::GREGORIAN  ,"MM/dd/yyyy");
echo "First Formatted output with pattern is ".$fmt->format(0);
$fmt = new IntlDateFormatter( "de-DE" ,IntlDateFormatter::FULL, IntlDateFormatter::FULL,
      'America/Los_Angeles',IntlDateFormatter::GREGORIAN , "MM/dd/yyyy");
echo "Second Formatted output with pattern is ".$fmt->format(0);
?>

以上例程会输出：

First Formatted output is Wednesday, December 31, 1969 4:00:00 PM PT
Second Formatted output is Mittwoch, 31. Dezember 1969 16:00 Uhr GMT-08:00
First Formatted output with pattern is 12/31/1969
Second Formatted output with pattern is 12/31/1969

参见

  • datefmt_format() - Format the date/time value as a string
  • datefmt_parse() - Parse string to a timestamp value
  • datefmt_get_error_code() - Get the error code from last operation
  • datefmt_get_error_message() - Get the error text from the last operation


Format the date/time value as a string

  • ? IntlDateFormatter::create
  • IntlDateFormatter::formatObject ?
  • PHP Manual
  • IntlDateFormatter
  • Format the date/time value as a string

IntlDateFormatter::format

datefmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::format -- datefmt_format — Format the date/time value as a string

说明

面向对象风格

public IntlDateFormatter::format ( IntlCalendar|DateTimeInterface|array|string|int|float $datetime ) : string|false

过程化风格

datefmt_format ( IntlDateFormatter $formatter , IntlCalendar|DateTimeInterface|array|string|int|float $datetime ) : string|false

Formats the time value as a string.

参数

formatter

The date formatter resource.

datetime

Value to format. This may be a DateTimeInterface object, an IntlCalendar object, a numeric type representing a (possibly fractional) number of seconds since epoch or an array in the format output by localtime().

If a DateTime or an IntlCalendar object is passed, its timezone is not considered. The object will be formatted using the formater?s configured timezone. If one wants to use the timezone of the object to be formatted, IntlDateFormatter::setTimeZone() must be called before with the object?s timezone. Alternatively, the static function IntlDateFormatter::formatObject() may be used instead.

返回值

The formatted string or, if an error occurred, false.

更新日志

版本 | 说明
7.1.5 | Support for providing general DateTimeInterface objects to the datetime parameter was added. Formerly, only proper DateTime objects were supported.
PECL 3.0.0 | Support for providing IntlCalendar objects to the datetime parameter was added.

范例

Example #1 datefmt_format() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'First Formatted output is ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Second Formatted output is ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'First Formatted output with pattern is ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo "Second Formatted output with pattern is " . datefmt_format($fmt, 0);
?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'First Formatted output is ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Second Formatted output is ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'First Formatted output with pattern is ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'Second Formatted output with pattern is ' . $fmt->format(0);
?>

以上例程会输出：

First Formatted output is Wednesday, December 31, 1969 4:00:00 PM PT
Second Formatted output is Mittwoch, 31. Dezember 1969 16:00 Uhr GMT-08:00
First Formatted output with pattern is 12/31/1969
Second Formatted output with pattern is 12/31/1969

Example #3 With IntlCalendar object

<?php
$tz = reset(iterator_to_array(IntlTimeZone::createEnumeration('FR')));
$formatter = IntlDateFormatter::create(
    'fr_FR',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    $tz,
    IntlDateFormatter::GREGORIAN
);

$cal = IntlCalendar::createInstance($tz, '@calendar=islamic-civil');
$cal->set(IntlCalendar::FIELD_MONTH, 8); //9th month, Ramadan
$cal->set(IntlCalendar::FIELD_DAY_OF_MONTH, 1); //1st day
$cal->clear(IntlCalendar::FIELD_HOUR_OF_DAY);
$cal->clear(IntlCalendar::FIELD_MINUTE);
$cal->clear(IntlCalendar::FIELD_SECOND);
$cal->clear(IntlCalendar::FIELD_MILLISECOND);

echo "In this islamic year, Ramadan started/will start on:\n\t",
        $formatter->format($cal), "\n";

//It?s the formatter?s timezone that is used:
$formatter->setTimeZone('Asia/Tokyo');
echo "After changing timezone:\n\t",
        $formatter->format($cal), "\n";

以上例程会输出：

In this islamic year, Ramadan started/will start on:
    mardi 9 juillet 2013 19:00:00 heure avancée d'Europe centrale
After changing timezone:
    mercredi 10 juillet 2013 02:00:00 heure normale du Japon

参见

  • datefmt_create() - Create a date formatter
  • datefmt_parse() - Parse string to a timestamp value
  • datefmt_get_error_code() - Get the error code from last operation
  • datefmt_get_error_message() - Get the error text from the last operation
  • datefmt_format_object() - Formats an object


Formats an object

  • ? IntlDateFormatter::format
  • IntlDateFormatter::getCalendar ?
  • PHP Manual
  • IntlDateFormatter
  • Formats an object

IntlDateFormatter::formatObject

datefmt_format_object

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::formatObject -- datefmt_format_object — Formats an object

说明

面向对象风格

public static IntlDateFormatter::formatObject ( IntlCalendar|DateTime $datetime , array|int|string|null $format = null , string|null $locale = null ) : string|false

过程化风格

datefmt_format_object ( IntlCalendar|DateTimeInterface $datetime , array|int|string|null $format = null , string|null $locale = null ) : string|false

This function allows formatting an IntlCalendar or DateTime object without first explicitly creating a IntlDateFormatter object.

The temporary IntlDateFormatter that will be created will take the timezone from the passed in object. The timezone database bundled with PHP will not be used - ICU's will be used instead. The timezone identifier used in DateTime objects must therefore also exist in ICU's database.

参数

datetime

An object of type IntlCalendar or DateTime. The timezone information in the object will be used.

format

How to format the date/time. This can either be an array with two elements (first the date style, then the time style, these being one of the constants IntlDateFormatter::NONE, IntlDateFormatter::SHORT, IntlDateFormatter::MEDIUM, IntlDateFormatter::LONG, IntlDateFormatter::FULL), an int with the value of one of these constants (in which case it will be used both for the time and the date) or a string with the format described in » the ICU documentation. If null, the default style will be used.

locale

The locale to use, or null to use the default one.

返回值

A string with result 或者在失败时返回 false.

范例

Example #1 IntlDateFormatter::formatObject() examples

<?php
/* default timezone is irrelevant; timezone taken from the object */
ini_set('date.timezone', 'UTC');
/* default locale is taken from this ini setting */
ini_set('intl.default_locale', 'fr_FR');

$cal = IntlCalendar::fromDateTime("2013-06-06 17:05:06 Europe/Dublin");
echo "default:\n\t",
        IntlDateFormatter::formatObject($cal),
        "\n";

echo "long \$format (full):\n\t",
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL),
        "\n";

echo "array \$format (none, full):\n\t",
        IntlDateFormatter::formatObject($cal, array(
                IntlDateFormatter::NONE,
                IntlDateFormatter::FULL)),
        "\n";

echo "string \$format (d 'of' MMMM y):\n\t",
        IntlDateFormatter::formatObject($cal, "d 'of' MMMM y", 'en_US'),
        "\n";

echo "with DateTime:\n\t",
        IntlDateFormatter::formatObject(
                new DateTime("2013-09-09 09:09:09 Europe/Madrid"),
                IntlDateFormatter::FULL,
                'es_ES'),
        "\n";

以上例程会输出：

default:
    6 juin 2013 17:05:06
long $format (full):
    jeudi 6 juin 2013 17:05:06 heure d'été irlandaise
array $format (none, full):
    17:05:06 heure d'été irlandaise
string $format (d 'of' MMMM y):
    6 of June 2013
with DateTime:
    lunes, 9 de septiembre de 2013 09:09:09 Hora de verano de Europa central


Get the calendar type used for the IntlDateFormatter

  • ? IntlDateFormatter::formatObject
  • IntlDateFormatter::getDateType ?
  • PHP Manual
  • IntlDateFormatter
  • Get the calendar type used for the IntlDateFormatter

IntlDateFormatter::getCalendar

datefmt_get_calendar

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getCalendar -- datefmt_get_calendar — Get the calendar type used for the IntlDateFormatter

说明

面向对象风格

public IntlDateFormatter::getCalendar ( ) : int|false

过程化风格

datefmt_get_calendar ( IntlDateFormatter $formatter ) : int|false

参数

formatter

The formatter resource

返回值

The calendar type being used by the formatter. Either IntlDateFormatter::TRADITIONAL or IntlDateFormatter::GREGORIAN. Returns false on failure.

范例

Example #1 datefmt_get_calendar() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'calendar of the formatter is : ' . datefmt_get_calendar($fmt);
datefmt_set_calendar($fmt, IntlDateFormatter::TRADITIONAL);
echo 'Now calendar of the formatter is : ' . datefmt_get_calendar($fmt);
?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'calendar of the formatter is : ' . $fmt->getCalendar();
$fmt->setCalendar(IntlDateFormatter::TRADITIONAL);
echo 'Now calendar of the formatter is : ' . $fmt->getCalendar();

?>

以上例程会输出：

calendar of the formatter is : 1
Now calendar of the formatter is : 0

参见

  • datefmt_get_calendar_object() - Get copy of formatter?s calendar object
  • datefmt_set_calendar() - Sets the calendar type used by the formatter
  • datefmt_create() - Create a date formatter


Get the datetype used for the IntlDateFormatter

  • ? IntlDateFormatter::getCalendar
  • IntlDateFormatter::getErrorCode ?
  • PHP Manual
  • IntlDateFormatter
  • Get the datetype used for the IntlDateFormatter

IntlDateFormatter::getDateType

datefmt_get_datetype

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getDateType -- datefmt_get_datetype — Get the datetype used for the IntlDateFormatter

说明

面向对象风格

public IntlDateFormatter::getDateType ( ) : int|false

过程化风格

datefmt_get_datetype ( IntlDateFormatter $formatter ) : int|false

Returns date type used by the formatter.

参数

formatter

The formatter resource.

返回值

The current date type value of the formatter, 或者在失败时返回 false.

范例

Example #1 datefmt_get_datetype() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'datetype of the formatter is : ' . datefmt_get_datetype($fmt);
echo 'First Formatted output with datetype is ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::SHORT,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Now datetype of the formatter is : ' . datefmt_get_datetype($fmt);
echo 'Second Formatted output with datetype is ' . datefmt_format($fmt, 0);

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'datetype of the formatter is : ' . $fmt->getDateType();
echo 'First Formatted output is ' . $fmt->format(0);
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::SHORT,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Now datetype of the formatter is : ' . $fmt->getDateType();
echo 'Second Formatted output is ' . $fmt->format(0);

?>

以上例程会输出：

datetype of the formatter is : 0
First Formatted output is Wednesday, December 31, 1969 4:00:00 PM PT
Now datetype of the formatter is : 2
Second Formatted output is 12/31/69 4:00:00 PM PT

参见

  • datefmt_get_timetype() - Get the timetype used for the IntlDateFormatter
  • datefmt_create() - Create a date formatter


Get the error code from last operation

  • ? IntlDateFormatter::getDateType
  • IntlDateFormatter::getErrorMessage ?
  • PHP Manual
  • IntlDateFormatter
  • Get the error code from last operation

IntlDateFormatter::getErrorCode

datefmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getErrorCode -- datefmt_get_error_code — Get the error code from last operation

说明

面向对象风格

public IntlDateFormatter::getErrorCode ( ) : int

过程化风格

datefmt_get_error_code ( IntlDateFormatter $formatter ) : int

Get the error code from last operation. Returns error code from the last number formatting operation.

参数

formatter

The formatter resource.

返回值

The error code, one of UErrorCode values. Initial value is U_ZERO_ERROR.

范例

Example #1 datefmt_get_error_code() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$str = datefmt_format($fmt);
if (!$str) {
    printf(
        "ERROR: %s (%d)\n",
        datefmt_get_error_message($fmt),
        datefmt_get_error_code($fmt)
    );
}
?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$str = $fmt->format();
if (!$str) {
    printf(
        "ERROR: %s (%d)\n",
        $fmt->getErrorMessage(),
        $fmt->getErrorCode()
    );
}
?>

以上例程会输出：

ERROR: U_ZERO_ERROR (0)

参见

  • datefmt_get_error_message() - Get the error text from the last operation
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure


Get the error text from the last operation

  • ? IntlDateFormatter::getErrorCode
  • IntlDateFormatter::getLocale ?
  • PHP Manual
  • IntlDateFormatter
  • Get the error text from the last operation

IntlDateFormatter::getErrorMessage

datefmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getErrorMessage -- datefmt_get_error_message — Get the error text from the last operation

说明

面向对象风格

public IntlDateFormatter::getErrorMessage ( ) : string

过程化风格

datefmt_get_error_message ( IntlDateFormatter $formatter ) : string

Get the error text from the last operation.

参数

formatter

The formatter resource.

返回值

Description of the last error.

范例

Example #1 datefmt_get_error_message() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$str = datefmt_format($fmt);
if (!$str) {
    printf(
        "ERROR: %s (%d)\n",
        datefmt_get_error_message($fmt),
        datefmt_get_error_code($fmt)
    );
}
?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$str = $fmt->format();
if(!$str) {
    printf(
        "ERROR: %s (%d)\n",
        $fmt->getErrorMessage(),
        $fmt->getErrorCode()
    );
}

?>

以上例程会输出：

ERROR: U_ZERO_ERROR (0)

参见

  • datefmt_get_error_code() - Get the error code from last operation
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure


Get the locale used by formatter

  • ? IntlDateFormatter::getErrorMessage
  • IntlDateFormatter::getPattern ?
  • PHP Manual
  • IntlDateFormatter
  • Get the locale used by formatter

IntlDateFormatter::getLocale

datefmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getLocale -- datefmt_get_locale — Get the locale used by formatter

说明

面向对象风格

public IntlDateFormatter::getLocale ( int $type = ULOC_ACTUAL_LOCALE ) : string|false

过程化风格

datefmt_get_locale ( IntlDateFormatter $formatter , int $type = ULOC_ACTUAL_LOCALE ) : string|false

Get locale used by the formatter.

参数

formatter

The formatter resource

type

You can choose between valid and actual locale ( Locale::VALID_LOCALE, Locale::ACTUAL_LOCALE, respectively). The default is the actual locale.

返回值

The locale of this formatter, 或者在失败时返回 false.

范例

Example #1 datefmt_get_locale() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'locale of the formatter is : ' . datefmt_get_locale($fmt);
echo 'First Formatted output is ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'locale of the formatter is : ' . datefmt_get_locale($fmt);
echo 'Second Formatted output is ' . datefmt_format($fmt, 0);

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'locale of the formatter is : ' . $fmt->getLocale();
echo 'First Formatted output is ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'locale of the formatter is : ' . $fmt->getLocale();
echo 'Second Formatted output is ' . $fmt->format(0);

?>

以上例程会输出：

locale of the formatter is : en
First Formatted output is Wednesday, December 31, 1969 4:00:00 PM PT
locale of the formatter is : de
Second Formatted output is Mittwoch, 31. Dezember 1969 16:00 Uhr GMT-08:00

参见

  • datefmt_create() - Create a date formatter


Get the pattern used for the IntlDateFormatter

  • ? IntlDateFormatter::getLocale
  • IntlDateFormatter::getTimeType ?
  • PHP Manual
  • IntlDateFormatter
  • Get the pattern used for the IntlDateFormatter

IntlDateFormatter::getPattern

datefmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getPattern -- datefmt_get_pattern — Get the pattern used for the IntlDateFormatter

说明

面向对象风格

public IntlDateFormatter::getPattern ( ) : string|false

过程化风格

datefmt_get_pattern ( IntlDateFormatter $formatter ) : string|false

Get pattern used by the formatter.

参数

formatter

The formatter resource.

返回值

The pattern string being used to format/parse, 或者在失败时返回 false.

范例

Example #1 datefmt_get_pattern() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'pattern of the formatter is : ' . datefmt_get_pattern($fmt);
echo 'First Formatted output with pattern is ' . datefmt_format($fmt, 0);
datefmt_set_pattern($fmt,'yyyymmdd hh:mm:ss z');
echo 'Now pattern of the formatter is : ' . datefmt_get_pattern($fmt);
echo 'Second Formatted output with pattern is ' . datefmt_format($fmt, 0);

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'pattern of the formatter is : ' . $fmt->getPattern();
echo 'First Formatted output is ' . $fmt->format(0);
$fmt->setPattern('yyyymmdd hh:mm:ss z');
echo 'Now pattern of the formatter is : ' . $fmt->getPattern();
echo 'Second Formatted output is ' . $fmt->format(0);
?>

以上例程会输出：

pattern of the formatter is : MM/dd/yyyy
First Formatted output is 12/31/1969
Now pattern of the formatter is : yyyymmdd hh:mm:ss z
Second Formatted output is 19690031 04:00:00 PST

参见

  • datefmt_set_pattern() - Set the pattern used for the IntlDateFormatter
  • datefmt_create() - Create a date formatter


Get the timetype used for the IntlDateFormatter

  • ? IntlDateFormatter::getPattern
  • IntlDateFormatter::getTimeZoneId ?
  • PHP Manual
  • IntlDateFormatter
  • Get the timetype used for the IntlDateFormatter

IntlDateFormatter::getTimeType

datefmt_get_timetype

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getTimeType -- datefmt_get_timetype — Get the timetype used for the IntlDateFormatter

说明

面向对象风格

public IntlDateFormatter::getTimeType ( ) : int|false

过程化风格

datefmt_get_timetype ( IntlDateFormatter $formatter ) : int|false

Return time type used by the formatter.

参数

formatter

The formatter resource.

返回值

The current date type value of the formatter, 或者在失败时返回 false.

范例

Example #1 datefmt_get_timetype() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'timetype of the formatter is : ' . datefmt_get_timetype($fmt);
echo 'First Formatted output with timetype is ' . datefmt_format($fmt, 0);

$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::SHORT,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Now timetype of the formatter is : ' . datefmt_get_timetype($fmt);
echo 'Second Formatted output with timetype is ' . datefmt_format($fmt, 0);

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'timetype of the formatter is : ' . $fmt->getTimeType();
echo 'First Formatted output is ' . $fmt->format(0);

$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::SHORT,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Now timetype of the formatter is : ' . $fmt->getTimeType();
echo 'Second Formatted output is ' . $fmt->format(0);

?>

以上例程会输出：

timetype of the formatter is : 0
First Formatted output is Wednesday, December 31, 1969 4:00:00 PM PT
Now timetype of the formatter is : 3
Second Formatted output is Wednesday, December 31, 1969 4:00 PM

参见

  • datefmt_get_datetype() - Get the datetype used for the IntlDateFormatter
  • datefmt_create() - Create a date formatter


Get the timezone-id used for the IntlDateFormatter

  • ? IntlDateFormatter::getTimeType
  • IntlDateFormatter::getCalendarObject ?
  • PHP Manual
  • IntlDateFormatter
  • Get the timezone-id used for the IntlDateFormatter

IntlDateFormatter::getTimeZoneId

datefmt_get_timezone_id

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getTimeZoneId -- datefmt_get_timezone_id — Get the timezone-id used for the IntlDateFormatter

说明

面向对象风格

public IntlDateFormatter::getTimeZoneId ( ) : string|false

过程化风格

datefmt_get_timezone_id ( IntlDateFormatter $formatter ) : string|false

Get the timezone-id used for the IntlDateFormatter.

参数

formatter

The formatter resource.

返回值

ID string for the time zone used by this formatter, 或者在失败时返回 false.

范例

Example #1 datefmt_get_timezone_id() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'timezone_id of the formatter is : ' . datefmt_get_timezone_id($fmt);
datefmt_set_timezone_id($fmt, 'CN');
echo 'Now timezone_id of the formatter is : ' . datefmt_get_timezone_id($fmt);

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'timezone_id of the formatter is : ' . $fmt->getTimezoneId();
$fmt->setTimezoneId('CN');
echo 'Now timezone_id of the formatter is : ' . $fmt->getTimezoneId();

?>

以上例程会输出：

timezone_id of the formatter is : America/Los_Angeles
Now timezone_id of the formatter is : CN

参见

  • datefmt_set_timezone_id()
  • datefmt_create() - Create a date formatter


Get copy of formatter?s calendar object

  • ? IntlDateFormatter::getTimeZoneId
  • IntlDateFormatter::getTimeZone ?
  • PHP Manual
  • IntlDateFormatter
  • Get copy of formatter?s calendar object

IntlDateFormatter::getCalendarObject

datefmt_get_calendar_object

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::getCalendarObject -- datefmt_get_calendar_object — Get copy of formatter?s calendar object

说明

面向对象风格

public IntlDateFormatter::getCalendarObject ( ) : IntlCalendar|false|null

过程化风格

datefmt_get_calendar_object ( IntlDateFormatter $formatter ) : IntlCalendar|false|null

Obtain a copy of the calendar object used internally by this formatter. This calendar will have a type (as in gregorian, japanese, buddhist, roc, persian, islamic, etc.) and a timezone that match the type and timezone used by the formatter. The date/time of the object is unspecified.

参数

此函数没有参数。

返回值

A copy of the internal calendar object used by this formatter, or null if none has been set, 或者在失败时返回 false.

范例

Example #1 IntlDateFormatter::getCalendarObject() example

<?php
$formatter = IntlDateFormatter::create(
    "fr_FR@calendar=islamic",
    NULL,
    NULL,
    "GMT-01:00",
    IntlDateFormatter::TRADITIONAL
);

$cal = $formatter->getCalendarObject();

var_dump(
    $cal->getType(),
    $cal->getTimeZone(),
    $cal->getLocale(Locale::VALID_LOCALE)
);

以上例程会输出：

string(7) "islamic"
object(IntlTimeZone)#3 (4) {
  ["valid"]=>
  bool(true)
  ["id"]=>
  string(9) "GMT-01:00"
  ["rawOffset"]=>
  int(-3600000)
  ["currentOffset"]=>
  int(-3600000)
}
string(5) "fr_FR"

参见

  • IntlDateFormatter::getCalendar() - Get the calendar type used for the IntlDateFormatter
  • IntlDateFormatter::setCalendar() - Sets the calendar type used by the formatter
  • IntlCalendar


Get formatter?s timezone

  • ? IntlDateFormatter::getCalendarObject
  • IntlDateFormatter::isLenient ?
  • PHP Manual
  • IntlDateFormatter
  • Get formatter?s timezone

IntlDateFormatter::getTimeZone

datefmt_get_timezone

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::getTimeZone -- datefmt_get_timezone — Get formatter?s timezone

说明

面向对象风格

public IntlDateFormatter::getTimeZone ( ) : IntlTimeZone|false

过程化风格

datefmt_get_timezone ( IntlDateFormatter $formatter ) : IntlTimeZone|false

Returns an IntlTimeZone object representing the timezone that will be used by this object to format dates and times. When formatting IntlCalendar and DateTime objects with this IntlDateFormatter, the timezone used will be the one returned by this method, not the one associated with the objects being formatted.

参数

此函数没有参数。

返回值

The associated IntlTimeZone object 或者在失败时返回 false.

范例

Example #1 IntlDateFormatter::getTimeZone() examples

<?php

$madrid = IntlDateFormatter::create(NULL, NULL, NULL, 'Europe/Madrid');
$lisbon = IntlDateFormatter::create(NULL, NULL, NULL, 'Europe/Lisbon');

var_dump($madrid->getTimezone());
echo $madrid->getTimezone()->getDisplayName(
        false, IntlTimeZone::DISPLAY_GENERIC_LOCATION, "en_US"), "\n";
echo $lisbon->getTimeZone()->getId(), "\n";
//The id can also be retrieved with ->getTimezoneId()
echo $lisbon->getTimeZoneId(), "\n";

以上例程会输出：

object(IntlTimeZone)#4 (4) {
  ["valid"]=>
  bool(true)
  ["id"]=>
  string(13) "Europe/Madrid"
  ["rawOffset"]=>
  int(3600000)
  ["currentOffset"]=>
  int(7200000)
}
Spain Time
Europe/Lisbon
Europe/Lisbon

参见

  • IntlDateFormatter::getTimeZoneId() - Get the timezone-id used for the IntlDateFormatter
  • IntlDateFormatter::setTimeZone() - Sets formatter?s timezone
  • IntlTimeZone


Get the lenient used for the IntlDateFormatter

  • ? IntlDateFormatter::getTimeZone
  • IntlDateFormatter::localtime ?
  • PHP Manual
  • IntlDateFormatter
  • Get the lenient used for the IntlDateFormatter

IntlDateFormatter::isLenient

datefmt_is_lenient

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::isLenient -- datefmt_is_lenient — Get the lenient used for the IntlDateFormatter

说明

面向对象风格

public IntlDateFormatter::isLenient ( ) : bool

过程化风格

datefmt_is_lenient ( IntlDateFormatter $formatter ) : bool

Check if the parser is strict or lenient in interpreting inputs that do not match the pattern exactly.

参数

formatter

The formatter resource.

返回值

true if parser is lenient, false if parser is strict. By default the parser is lenient.

范例

Example #1 datefmt_is_lenient() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'dd/mm/yyyy'
);
echo 'lenient of the formatter is : ';
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
datefmt_parse($fmt, '35/13/1971');
echo "\n Trying to do parse('35/13/1971').\nResult is : " . datefmt_parse($fmt, '35/13/1971');
if (intl_get_error_code() != 0) {
    echo "\nError_msg is : " . intl_get_error_message();
    echo "\nError_code is : " . intl_get_error_code();
}
datefmt_set_lenient($fmt,false);
echo 'Now lenient of the formatter is : ';
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
datefmt_parse($fmt, '35/13/1971');
echo "\n Trying to do parse('35/13/1971').Result is : " . datefmt_parse($fmt, '35/13/1971');
if (intl_get_error_code() != 0) {
    echo "\nError_msg is : " . intl_get_error_message();
    echo "\nError_code is : " . intl_get_error_code();
}

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    "dd/mm/yyyy"
);
echo "lenient of the formatter is : ";
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
$fmt->parse('35/13/1971');
echo "\n Trying to do parse('35/13/1971').\nResult is : " . $fmt->parse('35/13/1971');
if (intl_get_error_code() != 0){
    echo "\nError_msg is : " . intl_get_error_message();
    echo "\nError_code is : " . intl_get_error_code();
}

$fmt->setLenient(FALSE);
echo 'Now lenient of the formatter is : ';
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
$fmt->parse('35/13/1971');
echo "\n Trying to do parse('35/13/1971').\nResult is : " . $fmt->parse('35/13/1971');
if (intl_get_error_code() != 0) {
    echo "\nError_msg is : " . intl_get_error_message();
    echo "\nError_code is : " . intl_get_error_code();
}

?>

以上例程会输出：

lenient of the formatter is : TRUE
Trying to do parse('35/13/1971').
Result is : -2147483
Now lenient of the formatter is : FALSE
Trying to do parse('35/13/1971').
Result is :
Error_msg is : Date parsing failed: U_PARSE_ERROR
Error_code is : 9

参见

  • datefmt_set_lenient() - Set the leniency of the parser
  • datefmt_create() - Create a date formatter


Parse string to a field-based time value

  • ? IntlDateFormatter::isLenient
  • IntlDateFormatter::parse ?
  • PHP Manual
  • IntlDateFormatter
  • Parse string to a field-based time value

IntlDateFormatter::localtime

datefmt_localtime

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::localtime -- datefmt_localtime — Parse string to a field-based time value

说明

面向对象风格

public IntlDateFormatter::localtime ( string $string , int &$offset = null ) : array|false

过程化风格

datefmt_localtime ( IntlDateFormatter $formatter , string $string , int &$offset = null ) : array|false

Converts string $value to a field-based time value ( an array of various fields), starting at $parse_pos and consuming as much of the input value as possible.

参数

formatter

The formatter resource

string

string to convert to a time

offset

Position at which to start the parsing in $value (zero-based). If no error occurs before $value is consumed, $parse_pos will contain -1 otherwise it will contain the position at which parsing ended . If $parse_pos > strlen($value), the parse fails immediately.

返回值

Localtime compatible array of integers : contains 24 hour clock value in tm_hour field, 或者在失败时返回 false.

范例

Example #1 datefmt_localtime() example

<?php

$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$arr = datefmt_localtime($fmt, 'Wednesday, December 31, 1969 4:00:00 PM PT', 0);
echo 'First parsed output is ';
if ($arr) {
    foreach ($arr as $key => $value) {
        echo "$key : $value , ";
    }
}

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
$arr = $fmt->localtime('Wednesday, December 31, 1969 4:00:00 PM PT', 0);
echo 'First parsed output is ';
if ($arr) {
    foreach ($arr as $key => $value) {
        echo "$key : $value , ";
    }
}

?>

以上例程会输出：

First parsed output is tm_sec : 0 , tm_min : 0 , tm_hour : 16 , tm_year : 1969 ,
tm_mday : 31 , tm_wday : 4 , tm_yday : 365 , tm_mon : 11 , tm_isdst : 0 ,

参见

  • datefmt_create() - Create a date formatter
  • datefmt_format() - Format the date/time value as a string
  • datefmt_parse() - Parse string to a timestamp value
  • datefmt_get_error_code() - Get the error code from last operation
  • datefmt_get_error_message() - Get the error text from the last operation


Parse string to a timestamp value

  • ? IntlDateFormatter::localtime
  • IntlDateFormatter::setCalendar ?
  • PHP Manual
  • IntlDateFormatter
  • Parse string to a timestamp value

IntlDateFormatter::parse

datefmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::parse -- datefmt_parse — Parse string to a timestamp value

说明

面向对象风格

public IntlDateFormatter::parse ( string $string , int &$offset = null ) : int|float|false

过程化风格

datefmt_parse ( IntlDateFormatter $formatter , string $string , int &$offset = null ) : int|float|false

Converts string to an incremental time value, starting at offset and consuming as much of the input value as possible.

参数

formatter

The formatter resource

string

string to convert to a time

offset

Position at which to start the parsing in string (zero-based). If no error occurs before string is consumed, offset will contain -1 otherwise it will contain the position at which parsing ended (and the error occurred). This variable will contain the end position if the parse fails. If offset > strlen($string), the parse fails immediately.

返回值

Timestamp of parsed value, or false if value cannot be parsed.

范例

Example #1 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'First parsed output is ' . $fmt->parse('Wednesday, December 20, 1989 4:00:00 PM PT');
$fmt = new IntlDateFormatter(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
?>

Example #2 datefmt_parse() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'First parsed output is ' . datefmt_parse($fmt, 'Wednesday, December 20, 1989 4:00:00 PM PT');
$fmt = datefmt_create(
    'de-DE',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'Second parsed output is ' . datefmt_parse($fmt, 'Mittwoch, 20. Dezember 1989 16:00 Uhr GMT-08:00');
?

以上例程会输出：

First parsed output is 630201600
Second parsed output is 630201600

参见

  • datefmt_create() - Create a date formatter
  • datefmt_format() - Format the date/time value as a string
  • datefmt_localtime() - Parse string to a field-based time value
  • datefmt_get_error_code() - Get the error code from last operation
  • datefmt_get_error_message() - Get the error text from the last operation


Sets the calendar type used by the formatter

  • ? IntlDateFormatter::parse
  • IntlDateFormatter::setLenient ?
  • PHP Manual
  • IntlDateFormatter
  • Sets the calendar type used by the formatter

IntlDateFormatter::setCalendar

datefmt_set_calendar

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setCalendar -- datefmt_set_calendar — Sets the calendar type used by the formatter

说明

面向对象风格

public IntlDateFormatter::setCalendar ( IntlCalendar|int|null $calendar ) : bool

过程化风格

datefmt_set_calendar ( IntlDateFormatter $formatter , IntlCalendar|int|null $calendar ) : bool

Sets the calendar or calendar type used by the formatter.

参数

formatter

The formatter resource.

calendar

This can either be: the calendar type to use (default is IntlDateFormatter::GREGORIAN, which is also used if null is specified) or an IntlCalendar object.

Any IntlCalendar object passed in will be cloned; no modifications will be made to the argument object.

The timezone of the formatter will only be kept if an IntlCalendar object is not passed, otherwise the new timezone will be that of the passed object.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.5.0/PECL 3.0.0 | It became possible to pass an IntlCalendar object.

范例

Example #1 datefmt_set_calendar() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'calendar of the formatter is : ' . datefmt_get_calendar($fmt);
datefmt_set_calendar($fmt, IntlDateFormatter::TRADITIONAL);
echo 'Now calendar of the formatter is : ' . datefmt_get_calendar($fmt);
?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN
);
echo 'calendar of the formatter is : ' . $fmt->getCalendar();
$fmt->setCalendar(IntlDateFormatter::TRADITIONAL);
echo 'Now calendar of the formatter is : ' . $fmt->getCalendar();
?>

以上例程会输出：

calendar of the formatter is : 1
Now calendar of the formatter is : 0

Example #3 Example with IntlCalendar argument

<?php
$time = strtotime("2013-03-03 00:00:00 UTC");
$formatter = IntlDateFormatter::create("en_US", NULL, NULL, "Europe/Amsterdam");

echo "before: ", $formatter->format($time), "\n";

/* note that the calendar's locale is not used! */
$formatter->setCalendar(IntlCalendar::createInstance(
               "America/New_York", "pt_PT@calendar=islamic"));

echo "after:  ", $formatter->format($time), "\n";

以上例程会输出：

before: Sunday, March 3, 2013 at 1:00:00 AM Central European Standard Time
after:  Saturday, Rabi? II 20, 1434 at 7:00:00 PM Eastern Standard Time

参见

  • datefmt_get_calendar() - Get the calendar type used for the IntlDateFormatter
  • datefmt_get_calendar_object() - Get copy of formatter?s calendar object
  • datefmt_create() - Create a date formatter


Set the leniency of the parser

  • ? IntlDateFormatter::setCalendar
  • IntlDateFormatter::setPattern ?
  • PHP Manual
  • IntlDateFormatter
  • Set the leniency of the parser

IntlDateFormatter::setLenient

datefmt_set_lenient

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setLenient -- datefmt_set_lenient — Set the leniency of the parser

说明

面向对象风格

public IntlDateFormatter::setLenient ( bool $lenient ) : void

过程化风格

datefmt_set_lenient ( IntlDateFormatter $formatter , bool $lenient ) : void

Define if the parser is strict or lenient in interpreting inputs that do not match the pattern exactly. Enabling lenient parsing allows the parser to accept otherwise flawed date or time patterns, parsing as much as possible to obtain a value. Extra space, unrecognized tokens, or invalid values ("February 30th") are not accepted.

参数

formatter

The formatter resource

lenient

Sets whether the parser is lenient or not, default is true (lenient).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 datefmt_set_lenient() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'dd/MM/yyyy'
);
echo 'lenient of the formatter is : ';
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
datefmt_parse($fmt, '35/13/1971');
echo "\n Trying to do parse('35/13/1971').\nResult is : " . datefmt_parse($fmt, '35/13/1971');
if (intl_get_error_code() != 0) {
    echo "\nError_msg is : " . intl_get_error_message();
    echo "\nError_code is : " . intl_get_error_code();
}
datefmt_set_lenient($fmt, false);
echo "\nNow lenient of the formatter is : ";
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
datefmt_parse($fmt, '35/13/1971');
echo "\nTrying to do parse('35/13/1971').\nResult is : " . datefmt_parse($fmt, '35/13/1971');
if (intl_get_error_code() != 0) {
    echo "\nError_msg is : ".intl_get_error_message();
    echo "\nError_code is : ".intl_get_error_code();
}

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,
    IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'dd/MM/yyyy'
);
echo 'lenient of the formatter is : ';
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
$fmt->parse('35/13/1971');
echo "\n Trying to do parse('35/13/1971').\nResult is : " . $fmt->parse('35/13/1971');
if (intl_get_error_code() != 0) {
    echo "\nError_msg is : " . intl_get_error_message();
    echo "\nError_code is : " . intl_get_error_code();
}

$fmt->setLenient(FALSE);
echo "\nNow lenient of the formatter is : ";
if ($fmt->isLenient()) {
    echo 'TRUE';
} else {
    echo 'FALSE';
}
$fmt->parse('35/13/1971');
echo "\n Trying to do parse('35/13/1971').\nResult is : " . $fmt->parse('35/13/1971');
if (intl_get_error_code() != 0) {
    echo "\nError_msg is : " . intl_get_error_message();
    echo "\nError_code is : " . intl_get_error_code();
}

?>

以上例程会输出：

lenient of the formatter is : TRUE
Trying to do parse('35/13/1971').
Result is : 66038400
Now lenient of the formatter is : FALSE
Trying to do parse('35/13/1971').
Result is :
Error_msg is : Date parsing failed: U_PARSE_ERROR
Error_code is : 9

参见

  • datefmt_is_lenient() - Get the lenient used for the IntlDateFormatter
  • datefmt_create() - Create a date formatter


Set the pattern used for the IntlDateFormatter

  • ? IntlDateFormatter::setLenient
  • IntlDateFormatter::setTimeZone ?
  • PHP Manual
  • IntlDateFormatter
  • Set the pattern used for the IntlDateFormatter

IntlDateFormatter::setPattern

datefmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setPattern -- datefmt_set_pattern — Set the pattern used for the IntlDateFormatter

说明

面向对象风格

public IntlDateFormatter::setPattern ( string $pattern ) : bool

过程化风格

datefmt_set_pattern ( IntlDateFormatter $formatter , string $pattern ) : bool

Set the pattern used for the IntlDateFormatter.

参数

formatter

The formatter resource.

pattern

New pattern string to use. Possible patterns are documented at » https://unicode-org.github.io/icu/userguide/format_parse/datetime/.

返回值

成功时返回 true， 或者在失败时返回 false。 Bad formatstrings are usually the cause of the failure.

范例

Example #1 datefmt_set_pattern() example

<?php
$fmt = datefmt_create(
    'en_US',
    IntlDateFormatter::FULL,IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'pattern of the formatter is : ' . datefmt_get_pattern($fmt);
echo 'First Formatted output with pattern is ' . datefmt_format($fmt, 0);
datefmt_set_pattern($fmt, 'yyyymmdd hh:mm:ss z');
echo 'Now pattern of the formatter is : ' . datefmt_get_pattern($fmt);
echo 'Second Formatted output with pattern is ' . datefmt_format($fmt, 0);

?>

Example #2 OO example

<?php
$fmt = new IntlDateFormatter(
    'en_US',
    IntlDateFormatter::FULL,IntlDateFormatter::FULL,
    'America/Los_Angeles',
    IntlDateFormatter::GREGORIAN,
    'MM/dd/yyyy'
);
echo 'pattern of the formatter is : ' . $fmt->getPattern();
echo 'First Formatted output is ' . $fmt->format(0);
$fmt->setPattern('yyyymmdd hh:mm:ss z');
echo 'Now pattern of the formatter is : ' . $fmt->getPattern();
echo 'Second Formatted output is ' . $fmt->format(0);

?>

以上例程会输出：

pattern of the formatter is : MM/dd/yyyy
First Formatted output with pattern is 12/31/1969
Now pattern of the formatter is : yyyymmdd hh:mm:ss z
Second Formatted output with pattern is 19690031 04:00:00 PST

参见

  • datefmt_get_pattern() - Get the pattern used for the IntlDateFormatter
  • datefmt_create() - Create a date formatter


Sets formatter?s timezone

  • ? IntlDateFormatter::setPattern
  • ResourceBundle ?
  • PHP Manual
  • IntlDateFormatter
  • Sets formatter?s timezone

IntlDateFormatter::setTimeZone

datefmt_set_timezone

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::setTimeZone -- datefmt_set_timezone — Sets formatter?s timezone

说明

面向对象风格

public IntlDateFormatter::setTimeZone ( IntlTimeZone|DateTimeZone|string|null $timezone ) : bool|null

过程化风格

datefmt_set_timezone ( IntlDateFormatter $formatter , IntlTimeZone|DateTimeZone|string|null $timezone ) : bool|null

Sets the timezone used for the IntlDateFormatter. object.

参数

formatter

The formatter resource.

timezone

The timezone to use for this formatter. This can be specified in the following forms:

  • null, in which case the default timezone will be used, as specified in the ini setting date.timezone or through the function date_default_timezone_set() and as returned by date_default_timezone_get().

  • An IntlTimeZone, which will be used directly.

  • A DateTimeZone. Its identifier will be extracted and an ICU timezone object will be created; the timezone will be backed by ICU?s database, not PHP?s.

  • A string, which should be a valid ICU timezone identifier. See IntlTimeZone::createTimeZoneIDEnumeration(). Raw offsets such as "GMT+08:30" are also accepted.

返回值

Returns null on success and false on failure.

范例

Example #1 IntlDateFormatter::setTimeZone() examples

<?php
ini_set('date.timezone', 'Europe/Amsterdam');

$formatter = IntlDateFormatter::create(NULL, NULL, NULL, "UTC");

$formatter->setTimeZone(NULL);
echo "NULL\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone(IntlTimeZone::createTimeZone('Europe/Lisbon'));
echo "IntlTimeZone\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone(new DateTimeZone('Europe/Paris'));
echo "DateTimeZone\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone('Europe/Rome');
echo "String\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone('GMT+00:30');
print_r($formatter->getTimeZone());

以上例程会输出：

NULL
    Europe/Amsterdam
IntlTimeZone
    Europe/Lisbon
DateTimeZone
    Europe/Paris
String
    Europe/Rome
IntlTimeZone Object
(
    [valid] => 1
    [id] => GMT+00:30
    [rawOffset] => 1800000
    [currentOffset] => 1800000
)

参见

  • IntlDateFormatter::getTimeZone() - Get formatter?s timezone


The ResourceBundle class

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

简介

Localized software products often require sets of data that are to be customized depending on current locale, e.g.: messages, labels, formatting patterns. ICU resource mechanism allows to define sets of resources that the application can load on locale basis, while accessing them in unified locale-independent fashion.

This class implements access to ICU resource data files. These files are binary data arrays which ICU uses to store the localized data.

ICU resource bundle can hold simple resources and complex resources. Complex resources are containers which can be either integer-indexed or string-indexed (just like PHP arrays). Simple resources can be of the following types: string, integer, binary data field or integer array.

ResourceBundle supports direct access to the data through array access pattern and iteration via foreach, as well as access via class methods. The result will be PHP value for simple resources and ResourceBundle object for complex ones. All resources are read-only.

类摘要

ResourceBundle {
/* Methods */
public __construct ( string $locale , string $bundlename , bool $fallback = ? )
public count ( ) : int
public static create ( string $locale , string $bundlename , bool $fallback = ? ) : ResourceBundle
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public get ( string|int $index , bool $fallback = true ) : mixed
public getLocales ( string $bundlename ) : array
}

参见

  • » ICU Resource Management
  • » ICU Data

Table of Contents

  • ResourceBundle::count — Get number of elements in the bundle
  • ResourceBundle::create — Create a resource bundle
  • ResourceBundle::getErrorCode — Get bundle's last error code
  • ResourceBundle::getErrorMessage — Get bundle's last error message
  • ResourceBundle::get — Get data from the bundle
  • ResourceBundle::getLocales — Get supported locales


Get number of elements in the bundle

  • ? ResourceBundle
  • ResourceBundle::create ?
  • PHP Manual
  • ResourceBundle
  • Get number of elements in the bundle

ResourceBundle::count

resourcebundle_count

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::count -- resourcebundle_count — Get number of elements in the bundle

说明

面向对象风格

public ResourceBundle::count ( ) : int

过程化风格

resourcebundle_count ( ResourceBundle $r ) : int

Get the number of elements in the bundle.

参数

r

ResourceBundle object.

返回值

Returns number of elements in the bundle.

范例

Example #1 resourcebundle_count() example

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo resourcebundle_count($r);
?>

Example #2 OO example

<?php
$r = new ResourceBundle( 'es', "/usr/share/data/myapp");
echo $r->count();
?>

以上例程会输出：

42

参见

  • resourcebundle_get() - Get data from the bundle


Create a resource bundle

  • ? ResourceBundle::count
  • ResourceBundle::getErrorCode ?
  • PHP Manual
  • ResourceBundle
  • Create a resource bundle

ResourceBundle::create

resourcebundle_create

ResourceBundle::__construct

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::create -- resourcebundle_create -- ResourceBundle::__construct — Create a resource bundle

说明

面向对象风格 (method)

public static ResourceBundle::create ( string $locale , string $bundlename , bool $fallback = ? ) : ResourceBundle

过程化风格

resourcebundle_create ( string $locale , string $bundlename , bool $fallback = ? ) : ResourceBundle

面向对象风格 (constructor):

public ResourceBundle::__construct ( string $locale , string $bundlename , bool $fallback = ? )

Creates a resource bundle.

参数

locale

Locale for which the resources should be loaded (locale name, e.g. en_CA).

bundlename

The directory where the data is stored or the name of the .dat file.

fallback

Whether locale should match exactly or fallback to parent locale is allowed.

返回值

Returns ResourceBundle object or null on error.

范例

Example #1 resourcebundle_create() example

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo $r['teststring'];
?>

Example #2 ResourceBundle::create() example

<?php
$r = ResourceBundle::create( 'es', "/usr/share/data/myapp");
echo $r['teststring'];
?>

以上例程会输出：

?Hola, mundo!

参见

  • resourcebundle_get() - Get data from the bundle


Get bundle's last error code

  • ? ResourceBundle::create
  • ResourceBundle::getErrorMessage ?
  • PHP Manual
  • ResourceBundle
  • Get bundle's last error code

ResourceBundle::getErrorCode

resourcebundle_get_error_code

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::getErrorCode -- resourcebundle_get_error_code — Get bundle's last error code

说明

面向对象风格

public ResourceBundle::getErrorCode ( ) : int

过程化风格

resourcebundle_get_error_code ( ResourceBundle $r ) : int

Get error code from the last function performed by the bundle object.

参数

r

ResourceBundle object.

返回值

Returns error code from last bundle object call.

范例

Example #1 resourcebundle_get_error_code() example

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo $r['somestring'];
if(intl_is_failure(resourcebundle_get_error_code($r))) {
    report_error("Bundle error");
}
?>

Example #2 OO example

<?php
$r = new ResourceBundle( 'es', "/usr/share/data/myapp");
echo $r['somestring'];
if(intl_is_failure(ResourceBundle::getErrorCode($r))) {
    report_error("Bundle error");
}
?>

参见

  • resourcebundle_get_error_message() - Get bundle's last error message
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure


Get bundle's last error message

  • ? ResourceBundle::getErrorCode
  • ResourceBundle::get ?
  • PHP Manual
  • ResourceBundle
  • Get bundle's last error message

ResourceBundle::getErrorMessage

resourcebundle_get_error_message

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::getErrorMessage -- resourcebundle_get_error_message — Get bundle's last error message

说明

面向对象风格

public ResourceBundle::getErrorMessage ( ) : string

过程化风格

resourcebundle_get_error_message ( ResourceBundle $r ) : string

Get error message from the last function performed by the bundle object.

参数

r

ResourceBundle object.

返回值

Returns error message from last bundle object's call.

范例

Example #1 resourcebundle_get_error_message() example

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo $r['somestring'];
if(intl_is_failure(resourcebundle_get_error_code($r))) {
    report_error("Bundle error: ".resourcebundle_get_error_message($r));
}
?>

Example #2 OO example

<?php
$r = new ResourceBundle( 'es', "/usr/share/data/myapp");
echo $r['somestring'];
if(intl_is_failure(ResourceBundle::getErrorCode($r))) {
    report_error("Bundle error: ".ResourceBundle::getErrorMessage($r));
}
?>

参见

  • resourcebundle_get_error_code() - Get bundle's last error code
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure


Get data from the bundle

  • ? ResourceBundle::getErrorMessage
  • ResourceBundle::getLocales ?
  • PHP Manual
  • ResourceBundle
  • Get data from the bundle

ResourceBundle::get

resourcebundle_get

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::get -- resourcebundle_get — Get data from the bundle

说明

面向对象风格

public ResourceBundle::get ( string|int $index , bool $fallback = true ) : mixed

过程化风格

resourcebundle_get ( ResourceBundle $r , string|int $index , bool $fallback = true ) : mixed

Get the data from the bundle by index or string key.

参数

r

ResourceBundle object.

index

Data index, must be string or integer.

fallback

Whether locale should match exactly or fallback to parent locale is allowed.

返回值

Returns the data located at the index or null on error. Strings, integers and binary data strings are returned as corresponding PHP types, integer array is returned as PHP array. Complex types are returned as ResourceBundle object.

范例

Example #1 resourcebundle_get() example

<?php
$r = resourcebundle_create( 'es', "/usr/share/data/myapp");
echo resourcebundle_get($r, 'somestring');
?>

Example #2 OO example

<?php
$r = new ResourceBundle( 'es', "/usr/share/data/myapp");
echo $r->get('somestring');
?>

以上例程会输出：

?Hola, mundo!

参见

  • resourcebundle_count() - Get number of elements in the bundle


Get supported locales

  • ? ResourceBundle::get
  • Spoofchecker ?
  • PHP Manual
  • ResourceBundle
  • Get supported locales

ResourceBundle::getLocales

resourcebundle_locales

(PHP 5 >= 5.3.2, PHP 7, PECL intl >= 2.0.0)

ResourceBundle::getLocales -- resourcebundle_locales — Get supported locales

说明

面向对象风格

public ResourceBundle::getLocales ( string $bundlename ) : array

过程化风格

resourcebundle_locales ( string $bundlename ) : array

Get available locales from ResourceBundle name.

参数

bundlename

Path of ResourceBundle for which to get available locales, or empty string for default locales list.

返回值

Returns the list of locales supported by the bundle.

范例

Example #1 resourcebundle_locales() example

<?php
$bundle = "/user/share/data/myapp";
echo join(PHP_EOL, resourcebundle_locales($bundle));
?>

以上例程的输出类似于：

es
root

Example #2 OO example

<?php
$bundle = "/usr/share/data/myapp";
$r = new ResourceBundle( 'es', $bundle);
echo join("\n", $r->getLocales($bundle));
?>

以上例程的输出类似于：

es
root

参见

  • resourcebundle_get() - Get data from the bundle


The Spoofchecker class

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

简介

This class is provided because Unicode contains large number of characters and incorporates the varied writing systems of the world and their incorrect usage can expose programs or systems to possible security attacks using characters similarity.

Provided methods allow to check whether an individual string is likely an attempt at confusing the reader (spoof detection), such as "pаypаl" spelled with Cyrillic 'а' characters.

类摘要

Spoofchecker {
/* Constants */
const int|float ASCII = 0x10000000 ;
const int|float HIGHLY_RESTRICTIVE = 0x30000000 ;
const int|float MODERATELY_RESTRICTIVE = 0x40000000 ;
const int|float MINIMALLY_RESTRICTIVE = 0x50000000 ;
const int|float UNRESTRICTIVE = 0x60000000 ;
const int|float SINGLE_SCRIPT_RESTRICTIVE = 0x20000000 ;
const int SINGLE_SCRIPT_CONFUSABLE = 1 ;
const int MIXED_SCRIPT_CONFUSABLE = 2 ;
const int WHOLE_SCRIPT_CONFUSABLE = 4 ;
const int ANY_CASE = 8 ;
const int SINGLE_SCRIPT = 16 ;
const int INVISIBLE = 32 ;
const int CHAR_LIMIT = 64 ;
/* 方法 */
public areConfusable ( string $str1 , string $str2 , string &$error = ? ) : bool
public __construct ( )
public isSuspicious ( string $text , string &$error = ? ) : bool
public setAllowedLocales ( string $locale_list ) : void
public setChecks ( int $checks ) : void
}

预定义常量

Spoofchecker::ASCII

Spoofchecker::HIGHLY_RESTRICTIVE

Spoofchecker::MODERATELY_RESTRICTIVE

Spoofchecker::MINIMALLY_RESTRICTIVE

Spoofchecker::UNRESTRICTIVE

Spoofchecker::SINGLE_SCRIPT_RESTRICTIVE

Spoofchecker::SINGLE_SCRIPT_CONFUSABLE

Spoofchecker::MIXED_SCRIPT_CONFUSABLE

Spoofchecker::WHOLE_SCRIPT_CONFUSABLE

Spoofchecker::ANY_CASE

Spoofchecker::SINGLE_SCRIPT

Spoofchecker::INVISIBLE

Spoofchecker::CHAR_LIMIT

更新日志

版本 | 说明
7.3.0 | Class constants used by Spoofchecker::setRestrictionLevel() such as Spoofchecker::ASCII, Spoofchecker::HIGHLY_RESTRICTIVE, Spoofchecker::MODERATELY_RESTRICTIVE, Spoofchecker::MINIMALLY_RESTRICTIVE, Spoofchecker::UNRESTRICTIVE, Spoofchecker::SINGLE_SCRIPT_RESTRICTIVE has been added.

Table of Contents

  • Spoofchecker::areConfusable — Checks if given strings can be confused
  • Spoofchecker::__construct — Constructor
  • Spoofchecker::isSuspicious — Checks if a given text contains any suspicious characters
  • Spoofchecker::setAllowedLocales — Locales to use when running checks
  • Spoofchecker::setChecks — Set the checks to run


Checks if given strings can be confused

  • ? Spoofchecker
  • Spoofchecker::__construct ?
  • PHP Manual
  • Spoofchecker
  • Checks if given strings can be confused

Spoofchecker::areConfusable

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::areConfusable — Checks if given strings can be confused

说明

public Spoofchecker::areConfusable ( string $str1 , string $str2 , string &$error = ? ) : bool

Checks whether two given strings can easily be mistaken.

参数

str1

First string to check.

str2

Second string to check.

error

This variable is set by-reference to string containing an error, if there were any.

返回值

Returns true if two given strings can be confused, false otherwise.

范例

Example #1 Spoofchecker::areConfusable() example

<?php
$checker = new Spoofchecker();

$checker->areConfusable('google.com', 'goog1e.com'); // true
// Lower l can be confused with digit one

$checker->areConfusable('google.com', 'g00g1e.com'); // false
// Zero (0) cannot be easily confused with "o" letter


Constructor

  • ? Spoofchecker::areConfusable
  • Spoofchecker::isSuspicious ?
  • PHP Manual
  • Spoofchecker
  • Constructor

Spoofchecker::__construct

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::__construct — Constructor

说明

public Spoofchecker::__construct ( )

Creates new instance of Spoofchecker.

参数

此函数没有参数。

返回值

Returns Spoofchecker instance.


Checks if a given text contains any suspicious characters

  • ? Spoofchecker::__construct
  • Spoofchecker::setAllowedLocales ?
  • PHP Manual
  • Spoofchecker
  • Checks if a given text contains any suspicious characters

Spoofchecker::isSuspicious

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::isSuspicious — Checks if a given text contains any suspicious characters

说明

public Spoofchecker::isSuspicious ( string $text , string &$error = ? ) : bool

Checks if given string contains any suspicious characters like letters which are almost identical visually, but are Unicode characters from different sets.

参数

text

String to test.

error

This variable is set by-reference to string containing an error, if there were any.

返回值

Returns true if there are suspicious characters, false otherwise.

范例

Example #1 Spoofchecker::isSuspicious() example

<?php
$checker = new Spoofchecker();

$checker->isSuspicious('google.com'); // FALSE: only ASCII characters

$checker->isSuspicious('Рaypal.com'); // TRUE
// The first letter is from Cyrylic, not a regular latin "P"


Locales to use when running checks

  • ? Spoofchecker::isSuspicious
  • Spoofchecker::setChecks ?
  • PHP Manual
  • Spoofchecker
  • Locales to use when running checks

Spoofchecker::setAllowedLocales

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::setAllowedLocales — Locales to use when running checks

说明

public Spoofchecker::setAllowedLocales ( string $locale_list ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

locale_list

返回值


Set the checks to run

  • ? Spoofchecker::setAllowedLocales
  • Transliterator ?
  • PHP Manual
  • Spoofchecker
  • Set the checks to run

Spoofchecker::setChecks

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Spoofchecker::setChecks — Set the checks to run

说明

public Spoofchecker::setChecks ( int $checks ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

checks

返回值


The Transliterator class

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

简介

Transliterator provides transliteration of strings.

类摘要

Transliterator {
/* 常量 */
const int FORWARD = 0 ;
const int REVERSE = 1 ;
/* 属性 */
public $id ;
/* 方法 */
private __construct ( )
public static create ( string $id , int $direction = ? ) : Transliterator
public static createFromRules ( string $rules , string $direction = ? ) : Transliterator
public createInverse ( ) : Transliterator
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public static listIDs ( ) : array|false
public transliterate ( string $subject , int $start = ? , int $end = ? ) : string|false
}

属性

id

预定义常量

Transliterator::FORWARD

Transliterator::REVERSE

Table of Contents

  • Transliterator::__construct — Private constructor to deny instantiation
  • Transliterator::create — Create a transliterator
  • Transliterator::createFromRules — Create transliterator from rules
  • Transliterator::createInverse — Create an inverse transliterator
  • Transliterator::getErrorCode — Get last error code
  • Transliterator::getErrorMessage — Get last error message
  • Transliterator::listIDs — Get transliterator IDs
  • Transliterator::transliterate — Transliterate a string


Private constructor to deny instantiation

  • ? Transliterator
  • Transliterator::create ?
  • PHP Manual
  • Transliterator
  • Private constructor to deny instantiation

Transliterator::__construct

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::__construct — Private constructor to deny instantiation

说明

private Transliterator::__construct ( )

This method should not be called. Its only purpose is to deny instantiation with the new operator.

Use the factory methods Transliterator::create() or Transliterator::createFromRules() instead.

参数

此函数没有参数。

返回值

This method should not be executed. If it is (e.g. through reflection), then its return value is unspecified.

参见

  • Transliterator::create() - Create a transliterator
  • Transliterator::createFromRules() - Create transliterator from rules


Create a transliterator

  • ? Transliterator::__construct
  • Transliterator::createFromRules ?
  • PHP Manual
  • Transliterator
  • Create a transliterator

Transliterator::create

transliterator_create

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::create -- transliterator_create — Create a transliterator

说明

面向对象风格

public static Transliterator::create ( string $id , int $direction = ? ) : Transliterator

过程化风格

transliterator_create ( string $id , int $direction = ? ) : Transliterator

Opens a Transliterator by ID.

Warning

本函数还未编写文档，仅有参数列表。

参数

id

The ID. A list of all registered transliterator IDs can be retrieved by using Transliterator::listIDs().

direction

The direction, defaults to Transliterator::FORWARD. May also be set to Transliterator::REVERSE.

返回值

Returns a Transliterator object on success, or null on failure.

参见

  • Transliterator::getErrorMessage() - Get last error message
  • Transliterator::__construct() - Private constructor to deny instantiation


Create transliterator from rules

  • ? Transliterator::create
  • Transliterator::createInverse ?
  • PHP Manual
  • Transliterator
  • Create transliterator from rules

Transliterator::createFromRules

transliterator_create_from_rules

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::createFromRules -- transliterator_create_from_rules — Create transliterator from rules

说明

面向对象风格

public static Transliterator::createFromRules ( string $rules , string $direction = ? ) : Transliterator

过程化风格

transliterator_create_from_rules ( string $id , int $direction = ? ) : Transliterator

Creates a Transliterator from rules.

Warning

本函数还未编写文档，仅有参数列表。

参数

rules

The rules as defined in Transform Rules Syntax of UTS #35: Unicode LDML.

direction

The direction, defaults to >Transliterator::FORWARD. May also be set to Transliterator::REVERSE.

返回值

Returns a Transliterator object on success, or null on failure.

参见

  • Transliterator::getErrorMessage() - Get last error message
  • Transliterator::create() - Create a transliterator


Create an inverse transliterator

  • ? Transliterator::createFromRules
  • Transliterator::getErrorCode ?
  • PHP Manual
  • Transliterator
  • Create an inverse transliterator

Transliterator::createInverse

transliterator_create_inverse

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::createInverse -- transliterator_create_inverse — Create an inverse transliterator

说明

面向对象风格

public Transliterator::createInverse ( ) : Transliterator

过程化风格

transliterator_create_inverse ( ) : Transliterator

Opens the inverse transliterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns a Transliterator object on success, or null on failure

参见

  • Transliterator::getErrorMessage() - Get last error message
  • Transliterator::create() - Create a transliterator


Get last error code

  • ? Transliterator::createInverse
  • Transliterator::getErrorMessage ?
  • PHP Manual
  • Transliterator
  • Get last error code

Transliterator::getErrorCode

transliterator_get_error_code

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::getErrorCode -- transliterator_get_error_code — Get last error code

说明

面向对象风格

public Transliterator::getErrorCode ( ) : int

过程化风格

transliterator_get_error_code ( Transliterator $trans ) : int

Gets the last error code for this transliterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

trans

返回值

The error code on success, or false if none exists, or on failure.

参见

  • Transliterator::getErrorMessage() - Get last error message
  • Transliterator::listIDs() - Get transliterator IDs


Get last error message

  • ? Transliterator::getErrorCode
  • Transliterator::listIDs ?
  • PHP Manual
  • Transliterator
  • Get last error message

Transliterator::getErrorMessage

transliterator_get_error_message

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::getErrorMessage -- transliterator_get_error_message — Get last error message

说明

面向对象风格

public Transliterator::getErrorMessage ( ) : string

过程化风格

transliterator_get_error_message ( Transliterator $trans ) : string

Gets the last error message for this transliterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

trans

返回值

The error message on success, or false if none exists, or on failure.

参见

  • Transliterator::getErrorCode() - Get last error code
  • Transliterator::listIDs() - Get transliterator IDs


Get transliterator IDs

  • ? Transliterator::getErrorMessage
  • Transliterator::transliterate ?
  • PHP Manual
  • Transliterator
  • Get transliterator IDs

Transliterator::listIDs

transliterator_list_ids

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::listIDs -- transliterator_list_ids — Get transliterator IDs

说明

面向对象风格

public static Transliterator::listIDs ( ) : array|false

过程化风格

transliterator_list_ids ( ) : array|false

Returns an array with the registered transliterator IDs.

参数

此函数没有参数。

返回值

An array of registered transliterator IDs on success, 或者在失败时返回 false.

范例

Example #1 Retrieving the registered transliterator IDs

<?php
print_r(Transliterator::listIDs());
?>

以上例程的输出类似于：

Array
(
    [0] => ASCII-Latin
    [1] => Accents-Any
    [2] => Amharic-Latin/BGN
    [3] => Any-Accents
    [4] => Any-Publishing
...
    [650] => Any-ps_Latn/BGN
    [651] => Any-tk/BGN
    [652] => Any-ch_FONIPA
    [653] => Any-cs_FONIPA
    [654] => Any-cy_FONIPA
)

参见

  • Transliterator::getErrorMessage() - Get last error message
  • Transliterator::transliterate() - Transliterate a string


Transliterate a string

  • ? Transliterator::listIDs
  • IntlBreakIterator ?
  • PHP Manual
  • Transliterator
  • Transliterate a string

Transliterator::transliterate

transliterator_transliterate

(PHP 5 >= 5.4.0, PHP 7, PECL intl >= 2.0.0)

Transliterator::transliterate -- transliterator_transliterate — Transliterate a string

说明

面向对象风格

public Transliterator::transliterate ( string $subject , int $start = ? , int $end = ? ) : string|false

过程化风格

transliterator_transliterate ( mixed $transliterator , string $subject , int $start = ? , int $end = ? )

Transforms a string or part thereof using an ICU transliterator.

参数

transliterator

In the procedural version, either a Transliterator or a string from which a Transliterator can be built.

subject

The string to be transformed.

start

The start index (in UTF-16 code units) from which the string will start to be transformed, inclusive. Indexing starts at 0. The text before will be left as is.

end

The end index (in UTF-16 code units) until which the string will be transformed, exclusive. Indexing starts at 0. The text after will be left as is.

返回值

The transformed string on success, 或者在失败时返回 false.

范例

Example #1 Converting escaped UTF-16 code units

<?php
$s = "\u304A\u65E9\u3046\u3054\u3056\u3044\u307E\u3059";
echo transliterator_transliterate("Hex-Any/Java", $s), "\n";

//now the reverse operation with a supplementary character
$supplChar = html_entity_decode('&#x1D11E;');
echo mb_strlen($supplChar, "UTF-8"), "\n";
$encSupplChar = transliterator_transliterate("Any-Hex/Java", $supplChar);
//echoes two encoded UTF-16 code units
echo $encSupplChar, "\n";
//and back
echo transliterator_transliterate("Hex-Any/Java", $encSupplChar), "\n";
?>

以上例程的输出类似于：

お早うございます
1
\uD834\uDD1E
??

参见

  • Transliterator::getErrorMessage() - Get last error message
  • Transliterator::__construct() - Private constructor to deny instantiation


The IntlBreakIterator class

(PHP 5 >= 5.5.0, PHP 7)

简介

A "break iterator" is an ICU object that exposes methods for locating boundaries in text (e.g. word or sentence boundaries). The PHP IntlBreakIterator serves as the base class for all types of ICU break iterators. Where extra functionality is available, the intl extension may expose the ICU break iterator with suitable subclasses, such as IntlRuleBasedBreakIterator or IntlCodePointBreakIterator.

This class implements Traversable. Traversing an IntlBreakIterator yields non-negative integer values representing the successive locations of the text boundaries, expressed as UTF-8 code units (byte) counts, taken from the beginning of the text (which has the location 0). The keys yielded by the iterator simply form the sequence of natural numbers {0, 1, 2, ...}.

类摘要

IntlBreakIterator implements Traversable {
/* 常量 */
const int DONE = -1 ;
const int WORD_NONE = 0 ;
const int WORD_NONE_LIMIT = 100 ;
const int WORD_NUMBER = 100 ;
const int WORD_NUMBER_LIMIT = 200 ;
const int WORD_LETTER = 200 ;
const int WORD_LETTER_LIMIT = 300 ;
const int WORD_KANA = 300 ;
const int WORD_KANA_LIMIT = 400 ;
const int WORD_IDEO = 400 ;
const int WORD_IDEO_LIMIT = 500 ;
const int LINE_SOFT = 0 ;
const int LINE_SOFT_LIMIT = 100 ;
const int LINE_HARD = 100 ;
const int LINE_HARD_LIMIT = 200 ;
const int SENTENCE_TERM = 0 ;
const int SENTENCE_TERM_LIMIT = 100 ;
const int SENTENCE_SEP = 100 ;
const int SENTENCE_SEP_LIMIT = 200 ;
/* 方法 */
private __construct ( )
public static createCharacterInstance ( string $locale = ? ) : IntlBreakIterator
public static createCodePointInstance ( ) : IntlBreakIterator
public static createLineInstance ( string $locale = ? ) : IntlBreakIterator
public static createSentenceInstance ( string $locale = ? ) : IntlBreakIterator
public static createTitleInstance ( string $locale = ? ) : IntlBreakIterator
public static createWordInstance ( string $locale = ? ) : IntlBreakIterator
public current ( ) : int
public first ( ) : int
public following ( int $offset ) : int
public getErrorCode ( ) : int
intl_get_error_code ( ) : int
public getErrorMessage ( ) : string
intl_get_error_message ( ) : string
public getLocale ( string $locale_type ) : string
public getPartsIterator ( int $key_type = IntlPartsIterator::KEY_SEQUENTIAL ) : IntlPartsIterator
public getText ( ) : string
public isBoundary ( int $offset ) : bool
public last ( ) : int
public next ( int $offset = ? ) : int
public preceding ( int $offset ) : int
public previous ( ) : int
public setText ( string $text ) : bool
}

预定义常量

IntlBreakIterator::DONE

IntlBreakIterator::WORD_NONE

IntlBreakIterator::WORD_NONE_LIMIT

IntlBreakIterator::WORD_NUMBER

IntlBreakIterator::WORD_NUMBER_LIMIT

IntlBreakIterator::WORD_LETTER

IntlBreakIterator::WORD_LETTER_LIMIT

IntlBreakIterator::WORD_KANA

IntlBreakIterator::WORD_KANA_LIMIT

IntlBreakIterator::WORD_IDEO

IntlBreakIterator::WORD_IDEO_LIMIT

IntlBreakIterator::LINE_SOFT

IntlBreakIterator::LINE_SOFT_LIMIT

IntlBreakIterator::LINE_HARD

IntlBreakIterator::LINE_HARD_LIMIT

IntlBreakIterator::SENTENCE_TERM

IntlBreakIterator::SENTENCE_TERM_LIMIT

IntlBreakIterator::SENTENCE_SEP

IntlBreakIterator::SENTENCE_SEP_LIMIT

Table of Contents

  • IntlBreakIterator::__construct — Private constructor for disallowing instantiation
  • IntlBreakIterator::createCharacterInstance — Create break iterator for boundaries of combining character sequences
  • IntlBreakIterator::createCodePointInstance — Create break iterator for boundaries of code points
  • IntlBreakIterator::createLineInstance — Create break iterator for logically possible line breaks
  • IntlBreakIterator::createSentenceInstance — Create break iterator for sentence breaks
  • IntlBreakIterator::createTitleInstance — Create break iterator for title-casing breaks
  • IntlBreakIterator::createWordInstance — Create break iterator for word breaks
  • IntlBreakIterator::current — Get index of current position
  • IntlBreakIterator::first — Set position to the first character in the text
  • IntlBreakIterator::following — Advance the iterator to the first boundary following specified offset
  • IntlBreakIterator::getErrorCode — Get last error code on the object
  • IntlBreakIterator::getErrorMessage — Get last error message on the object
  • IntlBreakIterator::getLocale — Get the locale associated with the object
  • IntlBreakIterator::getPartsIterator — Create iterator for navigating fragments between boundaries
  • IntlBreakIterator::getText — Get the text being scanned
  • IntlBreakIterator::isBoundary — Tell whether an offset is a boundary?s offset
  • IntlBreakIterator::last — Set the iterator position to index beyond the last character
  • IntlBreakIterator::next — Advance the iterator the next boundary
  • IntlBreakIterator::preceding — Set the iterator position to the first boundary before an offset
  • IntlBreakIterator::previous — Set the iterator position to the boundary immediately before the current
  • IntlBreakIterator::setText — Set the text being scanned


Private constructor for disallowing instantiation

  • ? IntlBreakIterator
  • IntlBreakIterator::createCharacterInstance ?
  • PHP Manual
  • IntlBreakIterator
  • Private constructor for disallowing instantiation

IntlBreakIterator::__construct

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::__construct — Private constructor for disallowing instantiation

说明

private IntlBreakIterator::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Create break iterator for boundaries of combining character sequences

  • ? IntlBreakIterator::__construct
  • IntlBreakIterator::createCodePointInstance ?
  • PHP Manual
  • IntlBreakIterator
  • Create break iterator for boundaries of combining character sequences

IntlBreakIterator::createCharacterInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createCharacterInstance — Create break iterator for boundaries of combining character sequences

说明

public static IntlBreakIterator::createCharacterInstance ( string $locale = ? ) : IntlBreakIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

locale

返回值


Create break iterator for boundaries of code points

  • ? IntlBreakIterator::createCharacterInstance
  • IntlBreakIterator::createLineInstance ?
  • PHP Manual
  • IntlBreakIterator
  • Create break iterator for boundaries of code points

IntlBreakIterator::createCodePointInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createCodePointInstance — Create break iterator for boundaries of code points

说明

public static IntlBreakIterator::createCodePointInstance ( ) : IntlBreakIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Create break iterator for logically possible line breaks

  • ? IntlBreakIterator::createCodePointInstance
  • IntlBreakIterator::createSentenceInstance ?
  • PHP Manual
  • IntlBreakIterator
  • Create break iterator for logically possible line breaks

IntlBreakIterator::createLineInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createLineInstance — Create break iterator for logically possible line breaks

说明

public static IntlBreakIterator::createLineInstance ( string $locale = ? ) : IntlBreakIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

locale

返回值


Create break iterator for sentence breaks

  • ? IntlBreakIterator::createLineInstance
  • IntlBreakIterator::createTitleInstance ?
  • PHP Manual
  • IntlBreakIterator
  • Create break iterator for sentence breaks

IntlBreakIterator::createSentenceInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createSentenceInstance — Create break iterator for sentence breaks

说明

public static IntlBreakIterator::createSentenceInstance ( string $locale = ? ) : IntlBreakIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

locale

返回值


Create break iterator for title-casing breaks

  • ? IntlBreakIterator::createSentenceInstance
  • IntlBreakIterator::createWordInstance ?
  • PHP Manual
  • IntlBreakIterator
  • Create break iterator for title-casing breaks

IntlBreakIterator::createTitleInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createTitleInstance — Create break iterator for title-casing breaks

说明

public static IntlBreakIterator::createTitleInstance ( string $locale = ? ) : IntlBreakIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

locale

返回值


Create break iterator for word breaks

  • ? IntlBreakIterator::createTitleInstance
  • IntlBreakIterator::current ?
  • PHP Manual
  • IntlBreakIterator
  • Create break iterator for word breaks

IntlBreakIterator::createWordInstance

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::createWordInstance — Create break iterator for word breaks

说明

public static IntlBreakIterator::createWordInstance ( string $locale = ? ) : IntlBreakIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

locale

返回值


Get index of current position

  • ? IntlBreakIterator::createWordInstance
  • IntlBreakIterator::first ?
  • PHP Manual
  • IntlBreakIterator
  • Get index of current position

IntlBreakIterator::current

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::current — Get index of current position

说明

public IntlBreakIterator::current ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Set position to the first character in the text

  • ? IntlBreakIterator::current
  • IntlBreakIterator::following ?
  • PHP Manual
  • IntlBreakIterator
  • Set position to the first character in the text

IntlBreakIterator::first

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::first — Set position to the first character in the text

说明

public IntlBreakIterator::first ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Advance the iterator to the first boundary following specified offset

  • ? IntlBreakIterator::first
  • IntlBreakIterator::getErrorCode ?
  • PHP Manual
  • IntlBreakIterator
  • Advance the iterator to the first boundary following specified offset

IntlBreakIterator::following

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::following — Advance the iterator to the first boundary following specified offset

说明

public IntlBreakIterator::following ( int $offset ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

offset

返回值


Get last error code on the object

  • ? IntlBreakIterator::following
  • IntlBreakIterator::getErrorMessage ?
  • PHP Manual
  • IntlBreakIterator
  • Get last error code on the object

IntlBreakIterator::getErrorCode

intl_get_error_code

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getErrorCode -- intl_get_error_code — Get last error code on the object

说明

面向对象风格 (method):

public IntlBreakIterator::getErrorCode ( ) : int

过程化风格:

intl_get_error_code ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get last error message on the object

  • ? IntlBreakIterator::getErrorCode
  • IntlBreakIterator::getLocale ?
  • PHP Manual
  • IntlBreakIterator
  • Get last error message on the object

IntlBreakIterator::getErrorMessage

intl_get_error_message

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getErrorMessage -- intl_get_error_message — Get last error message on the object

说明

面向对象风格 (method):

public IntlBreakIterator::getErrorMessage ( ) : string

过程化风格:

intl_get_error_message ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the locale associated with the object

  • ? IntlBreakIterator::getErrorMessage
  • IntlBreakIterator::getPartsIterator ?
  • PHP Manual
  • IntlBreakIterator
  • Get the locale associated with the object

IntlBreakIterator::getLocale

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getLocale — Get the locale associated with the object

说明

public IntlBreakIterator::getLocale ( string $locale_type ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

locale_type

返回值


Create iterator for navigating fragments between boundaries

  • ? IntlBreakIterator::getLocale
  • IntlBreakIterator::getText ?
  • PHP Manual
  • IntlBreakIterator
  • Create iterator for navigating fragments between boundaries

IntlBreakIterator::getPartsIterator

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getPartsIterator — Create iterator for navigating fragments between boundaries

说明

public IntlBreakIterator::getPartsIterator ( int $key_type = IntlPartsIterator::KEY_SEQUENTIAL ) : IntlPartsIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

key_type

Optional key type. Possible values are:

  • IntlPartsIterator::KEY_SEQUENTIAL - The default. Sequentially increasing integers used as key.
  • IntlPartsIterator::KEY_LEFT - Byte offset left of current part used as key.
  • IntlPartsIterator::KEY_RIGHT - Byte offset right of current part used as key.

返回值


Get the text being scanned

  • ? IntlBreakIterator::getPartsIterator
  • IntlBreakIterator::isBoundary ?
  • PHP Manual
  • IntlBreakIterator
  • Get the text being scanned

IntlBreakIterator::getText

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::getText — Get the text being scanned

说明

public IntlBreakIterator::getText ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Tell whether an offset is a boundary?s offset

  • ? IntlBreakIterator::getText
  • IntlBreakIterator::last ?
  • PHP Manual
  • IntlBreakIterator
  • Tell whether an offset is a boundary?s offset

IntlBreakIterator::isBoundary

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::isBoundary — Tell whether an offset is a boundary?s offset

说明

public IntlBreakIterator::isBoundary ( int $offset ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

offset

返回值


Set the iterator position to index beyond the last character

  • ? IntlBreakIterator::isBoundary
  • IntlBreakIterator::next ?
  • PHP Manual
  • IntlBreakIterator
  • Set the iterator position to index beyond the last character

IntlBreakIterator::last

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::last — Set the iterator position to index beyond the last character

说明

public IntlBreakIterator::last ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Advance the iterator the next boundary

  • ? IntlBreakIterator::last
  • IntlBreakIterator::preceding ?
  • PHP Manual
  • IntlBreakIterator
  • Advance the iterator the next boundary

IntlBreakIterator::next

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::next — Advance the iterator the next boundary

说明

public IntlBreakIterator::next ( int $offset = ? ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

offset

返回值


Set the iterator position to the first boundary before an offset

  • ? IntlBreakIterator::next
  • IntlBreakIterator::previous ?
  • PHP Manual
  • IntlBreakIterator
  • Set the iterator position to the first boundary before an offset

IntlBreakIterator::preceding

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::preceding — Set the iterator position to the first boundary before an offset

说明

public IntlBreakIterator::preceding ( int $offset ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

offset

返回值


Set the iterator position to the boundary immediately before the current

  • ? IntlBreakIterator::preceding
  • IntlBreakIterator::setText ?
  • PHP Manual
  • IntlBreakIterator
  • Set the iterator position to the boundary immediately before the current

IntlBreakIterator::previous

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::previous — Set the iterator position to the boundary immediately before the current

说明

public IntlBreakIterator::previous ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Set the text being scanned

  • ? IntlBreakIterator::previous
  • IntlRuleBasedBreakIterator ?
  • PHP Manual
  • IntlBreakIterator
  • Set the text being scanned

IntlBreakIterator::setText

(PHP 5 >= 5.5.0, PHP 7)

IntlBreakIterator::setText — Set the text being scanned

说明

public IntlBreakIterator::setText ( string $text ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

text

返回值


The IntlRuleBasedBreakIterator class

(PHP 5 >= 5.5.0, PHP 7)

简介

A subclass of IntlBreakIterator that encapsulates ICU break iterators whose behavior is specified using a set of rules. This is the most common kind of break iterators.

These rules are described in the » ICU Boundary Analysis User Guide.

类摘要

IntlRuleBasedBreakIterator extends IntlBreakIterator implements Traversable {
/* 继承的常量 */
const int IntlBreakIterator::DONE = -1 ;
const int IntlBreakIterator::WORD_NONE = 0 ;
const int IntlBreakIterator::WORD_NONE_LIMIT = 100 ;
const int IntlBreakIterator::WORD_NUMBER = 100 ;
const int IntlBreakIterator::WORD_NUMBER_LIMIT = 200 ;
const int IntlBreakIterator::WORD_LETTER = 200 ;
const int IntlBreakIterator::WORD_LETTER_LIMIT = 300 ;
const int IntlBreakIterator::WORD_KANA = 300 ;
const int IntlBreakIterator::WORD_KANA_LIMIT = 400 ;
const int IntlBreakIterator::WORD_IDEO = 400 ;
const int IntlBreakIterator::WORD_IDEO_LIMIT = 500 ;
const int IntlBreakIterator::LINE_SOFT = 0 ;
const int IntlBreakIterator::LINE_SOFT_LIMIT = 100 ;
const int IntlBreakIterator::LINE_HARD = 100 ;
const int IntlBreakIterator::LINE_HARD_LIMIT = 200 ;
const int IntlBreakIterator::SENTENCE_TERM = 0 ;
const int IntlBreakIterator::SENTENCE_TERM_LIMIT = 100 ;
const int IntlBreakIterator::SENTENCE_SEP = 100 ;
const int IntlBreakIterator::SENTENCE_SEP_LIMIT = 200 ;
/* 方法 */
public __construct ( string $rules , string $areCompiled = ? )
public getBinaryRules ( ) : string
public getRules ( ) : string
public getRuleStatus ( ) : int
public getRuleStatusVec ( ) : array
/* 继承的方法 */
private IntlBreakIterator::__construct ( )
public static IntlBreakIterator::createCharacterInstance ( string $locale = ? ) : IntlBreakIterator
public static IntlBreakIterator::createCodePointInstance ( ) : IntlBreakIterator
public static IntlBreakIterator::createLineInstance ( string $locale = ? ) : IntlBreakIterator
public static IntlBreakIterator::createSentenceInstance ( string $locale = ? ) : IntlBreakIterator
public static IntlBreakIterator::createTitleInstance ( string $locale = ? ) : IntlBreakIterator
public static IntlBreakIterator::createWordInstance ( string $locale = ? ) : IntlBreakIterator
public IntlBreakIterator::current ( ) : int
public IntlBreakIterator::first ( ) : int
public IntlBreakIterator::following ( int $offset ) : int
public IntlBreakIterator::getErrorCode ( ) : int
intl_get_error_code ( ) : int
public IntlBreakIterator::getErrorMessage ( ) : string
intl_get_error_message ( ) : string
public IntlBreakIterator::getLocale ( string $locale_type ) : string
public IntlBreakIterator::getPartsIterator ( int $key_type = IntlPartsIterator::KEY_SEQUENTIAL ) : IntlPartsIterator
public IntlBreakIterator::getText ( ) : string
public IntlBreakIterator::isBoundary ( int $offset ) : bool
public IntlBreakIterator::last ( ) : int
public IntlBreakIterator::next ( int $offset = ? ) : int
public IntlBreakIterator::preceding ( int $offset ) : int
public IntlBreakIterator::previous ( ) : int
public IntlBreakIterator::setText ( string $text ) : bool
}

Table of Contents

  • IntlRuleBasedBreakIterator::__construct — Create iterator from ruleset
  • IntlRuleBasedBreakIterator::getBinaryRules — Get the binary form of compiled rules
  • IntlRuleBasedBreakIterator::getRules — Get the rule set used to create this object
  • IntlRuleBasedBreakIterator::getRuleStatus — Get the largest status value from the break rules that determined the current break position
  • IntlRuleBasedBreakIterator::getRuleStatusVec — Get the status values from the break rules that determined the current break position


Create iterator from ruleset

  • ? IntlRuleBasedBreakIterator
  • IntlRuleBasedBreakIterator::getBinaryRules ?
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Create iterator from ruleset

IntlRuleBasedBreakIterator::__construct

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::__construct — Create iterator from ruleset

说明

public IntlRuleBasedBreakIterator::__construct ( string $rules , string $areCompiled = ? )

Warning

本函数还未编写文档，仅有参数列表。

参数

rules

areCompiled

返回值


Get the binary form of compiled rules

  • ? IntlRuleBasedBreakIterator::__construct
  • IntlRuleBasedBreakIterator::getRules ?
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Get the binary form of compiled rules

IntlRuleBasedBreakIterator::getBinaryRules

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::getBinaryRules — Get the binary form of compiled rules

说明

public IntlRuleBasedBreakIterator::getBinaryRules ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the rule set used to create this object

  • ? IntlRuleBasedBreakIterator::getBinaryRules
  • IntlRuleBasedBreakIterator::getRuleStatus ?
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Get the rule set used to create this object

IntlRuleBasedBreakIterator::getRules

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::getRules — Get the rule set used to create this object

说明

public IntlRuleBasedBreakIterator::getRules ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the largest status value from the break rules that determined the current break position

  • ? IntlRuleBasedBreakIterator::getRules
  • IntlRuleBasedBreakIterator::getRuleStatusVec ?
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Get the largest status value from the break rules that determined the current break position

IntlRuleBasedBreakIterator::getRuleStatus

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::getRuleStatus — Get the largest status value from the break rules that determined the current break position

说明

public IntlRuleBasedBreakIterator::getRuleStatus ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the status values from the break rules that determined the current break position

  • ? IntlRuleBasedBreakIterator::getRuleStatus
  • IntlCodePointBreakIterator ?
  • PHP Manual
  • IntlRuleBasedBreakIterator
  • Get the status values from the break rules that determined the current break position

IntlRuleBasedBreakIterator::getRuleStatusVec

(PHP 5 >= 5.5.0, PHP 7)

IntlRuleBasedBreakIterator::getRuleStatusVec — Get the status values from the break rules that determined the current break position

说明

public IntlRuleBasedBreakIterator::getRuleStatusVec ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The IntlCodePointBreakIterator class

(PHP 5 >= 5.5.0, PHP 7)

简介

This break iterator identifies the boundaries between UTF-8 code points.

类摘要

IntlCodePointBreakIterator extends IntlBreakIterator implements Traversable {
/* 继承的常量 */
const int IntlBreakIterator::DONE = -1 ;
const int IntlBreakIterator::WORD_NONE = 0 ;
const int IntlBreakIterator::WORD_NONE_LIMIT = 100 ;
const int IntlBreakIterator::WORD_NUMBER = 100 ;
const int IntlBreakIterator::WORD_NUMBER_LIMIT = 200 ;
const int IntlBreakIterator::WORD_LETTER = 200 ;
const int IntlBreakIterator::WORD_LETTER_LIMIT = 300 ;
const int IntlBreakIterator::WORD_KANA = 300 ;
const int IntlBreakIterator::WORD_KANA_LIMIT = 400 ;
const int IntlBreakIterator::WORD_IDEO = 400 ;
const int IntlBreakIterator::WORD_IDEO_LIMIT = 500 ;
const int IntlBreakIterator::LINE_SOFT = 0 ;
const int IntlBreakIterator::LINE_SOFT_LIMIT = 100 ;
const int IntlBreakIterator::LINE_HARD = 100 ;
const int IntlBreakIterator::LINE_HARD_LIMIT = 200 ;
const int IntlBreakIterator::SENTENCE_TERM = 0 ;
const int IntlBreakIterator::SENTENCE_TERM_LIMIT = 100 ;
const int IntlBreakIterator::SENTENCE_SEP = 100 ;
const int IntlBreakIterator::SENTENCE_SEP_LIMIT = 200 ;
/* 方法 */
public getLastCodePoint ( ) : int
/* 继承的方法 */
private IntlBreakIterator::__construct ( )
public static IntlBreakIterator::createCharacterInstance ( string $locale = ? ) : IntlBreakIterator
public static IntlBreakIterator::createCodePointInstance ( ) : IntlBreakIterator
public static IntlBreakIterator::createLineInstance ( string $locale = ? ) : IntlBreakIterator
public static IntlBreakIterator::createSentenceInstance ( string $locale = ? ) : IntlBreakIterator
public static IntlBreakIterator::createTitleInstance ( string $locale = ? ) : IntlBreakIterator
public static IntlBreakIterator::createWordInstance ( string $locale = ? ) : IntlBreakIterator
public IntlBreakIterator::current ( ) : int
public IntlBreakIterator::first ( ) : int
public IntlBreakIterator::following ( int $offset ) : int
public IntlBreakIterator::getErrorCode ( ) : int
intl_get_error_code ( ) : int
public IntlBreakIterator::getErrorMessage ( ) : string
intl_get_error_message ( ) : string
public IntlBreakIterator::getLocale ( string $locale_type ) : string
public IntlBreakIterator::getPartsIterator ( int $key_type = IntlPartsIterator::KEY_SEQUENTIAL ) : IntlPartsIterator
public IntlBreakIterator::getText ( ) : string
public IntlBreakIterator::isBoundary ( int $offset ) : bool
public IntlBreakIterator::last ( ) : int
public IntlBreakIterator::next ( int $offset = ? ) : int
public IntlBreakIterator::preceding ( int $offset ) : int
public IntlBreakIterator::previous ( ) : int
public IntlBreakIterator::setText ( string $text ) : bool
}

Table of Contents

  • IntlCodePointBreakIterator::getLastCodePoint — Get last code point passed over after advancing or receding the iterator


Get last code point passed over after advancing or receding the iterator

  • ? IntlCodePointBreakIterator
  • IntlPartsIterator ?
  • PHP Manual
  • IntlCodePointBreakIterator
  • Get last code point passed over after advancing or receding the iterator

IntlCodePointBreakIterator::getLastCodePoint

(PHP 5 >= 5.5.0, PHP 7)

IntlCodePointBreakIterator::getLastCodePoint — Get last code point passed over after advancing or receding the iterator

说明

public IntlCodePointBreakIterator::getLastCodePoint ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The IntlPartsIterator class

(PHP 5 >= 5.5.0, PHP 7)

简介

Objects of this class can be obtained from IntlBreakIterator objects. While the break iterators provide a sequence of boundary positions when iterated, IntlPartsIterator objects provide, as a convenience, the text fragments comprehended between two successive boundaries.

The keys may represent the offset of the left boundary, right boundary, or they may just the sequence of non-negative integers. See IntlBreakIterator::getPartsIterator().

类摘要

IntlPartsIterator extends IntlIterator implements Iterator {
/* Constants */
const int KEY_SEQUENTIAL = 0 ;
const int KEY_LEFT = 1 ;
const int KEY_RIGHT = 2 ;
/* 方法 */
public getBreakIterator ( ) : IntlBreakIterator
/* 继承的方法 */
public IntlIterator::current ( ) : mixed
public IntlIterator::key ( ) : string
public IntlIterator::next ( ) : void
public IntlIterator::rewind ( ) : void
public IntlIterator::valid ( ) : bool
}

预定义常量

IntlPartsIterator::KEY_SEQUENTIAL

IntlPartsIterator::KEY_LEFT

IntlPartsIterator::KEY_RIGHT

Table of Contents

  • IntlPartsIterator::getBreakIterator — Get IntlBreakIterator backing this parts iterator


Get IntlBreakIterator backing this parts iterator

  • ? IntlPartsIterator
  • UConverter ?
  • PHP Manual
  • IntlPartsIterator
  • Get IntlBreakIterator backing this parts iterator

IntlPartsIterator::getBreakIterator

(PHP 5 >= 5.5.0, PHP 7)

IntlPartsIterator::getBreakIterator — Get IntlBreakIterator backing this parts iterator

说明

public IntlPartsIterator::getBreakIterator ( ) : IntlBreakIterator

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The UConverter class

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

简介

类摘要

UConverter {
/* Constants */
const int REASON_UNASSIGNED = 0 ;
const int REASON_ILLEGAL = 1 ;
const int REASON_IRREGULAR = 2 ;
const int REASON_RESET = 3 ;
const int REASON_CLOSE = 4 ;
const int REASON_CLONE = 5 ;
const int UNSUPPORTED_CONVERTER = -1 ;
const int SBCS = 0 ;
const int DBCS = 1 ;
const int MBCS = 2 ;
const int LATIN_1 = 3 ;
const int UTF8 = 4 ;
const int UTF16_BigEndian = 5 ;
const int UTF16_LittleEndian = 6 ;
const int UTF32_BigEndian = 7 ;
const int UTF32_LittleEndian = 8 ;
const int EBCDIC_STATEFUL = 9 ;
const int ISO_2022 = 10 ;
const int LMBCS_1 = 11 ;
const int LMBCS_2 = 12 ;
const int LMBCS_3 = 13 ;
const int LMBCS_4 = 14 ;
const int LMBCS_5 = 15 ;
const int LMBCS_6 = 16 ;
const int LMBCS_8 = 17 ;
const int LMBCS_11 = 18 ;
const int LMBCS_16 = 19 ;
const int LMBCS_17 = 20 ;
const int LMBCS_18 = 21 ;
const int LMBCS_19 = 22 ;
const int LMBCS_LAST = 22 ;
const int HZ = 23 ;
const int SCSU = 24 ;
const int ISCII = 25 ;
const int US_ASCII = 26 ;
const int UTF7 = 27 ;
const int BOCU1 = 28 ;
const int UTF16 = 29 ;
const int UTF32 = 30 ;
const int CESU8 = 31 ;
const int IMAP_MAILBOX = 32 ;
/* 方法 */
public __construct ( string $destination_encoding = ? , string $source_encoding = ? )
public convert ( string $str , bool $reverse = ? ) : string
public fromUCallback ( int $reason , string $source , string $codePoint , int &$error ) : mixed
public static getAliases ( string $name ) : array
public static getAvailable ( ) : array
public getDestinationEncoding ( ) : string
public getDestinationType ( ) : int
public getErrorCode ( ) : int
public getErrorMessage ( ) : string
public getSourceEncoding ( ) : string
public getSourceType ( ) : int
public static getStandards ( ) : array
public getSubstChars ( ) : string
public static reasonText ( int $reason = ? ) : string
public setDestinationEncoding ( string $encoding ) : void
public setSourceEncoding ( string $encoding ) : void
public setSubstChars ( string $chars ) : void
public toUCallback ( int $reason , string $source , string $codeUnits , int &$error ) : mixed
public static transcode ( string $str , string $toEncoding , string $fromEncoding , array $options = ? ) : string
}

预定义常量

UConverter::REASON_UNASSIGNED

UConverter::REASON_ILLEGAL

UConverter::REASON_IRREGULAR

UConverter::REASON_RESET

UConverter::REASON_CLOSE

UConverter::REASON_CLONE

UConverter::UNSUPPORTED_CONVERTER

UConverter::SBCS

UConverter::DBCS

UConverter::MBCS

UConverter::LATIN_1

UConverter::UTF8

UConverter::UTF16_BigEndian

UConverter::UTF16_LittleEndian

UConverter::UTF32_BigEndian

UConverter::UTF32_LittleEndian

UConverter::EBCDIC_STATEFUL

UConverter::ISO_2022

UConverter::LMBCS_1

UConverter::LMBCS_2

UConverter::LMBCS_3

UConverter::LMBCS_4

UConverter::LMBCS_5

UConverter::LMBCS_6

UConverter::LMBCS_8

UConverter::LMBCS_11

UConverter::LMBCS_16

UConverter::LMBCS_17

UConverter::LMBCS_18

UConverter::LMBCS_19

UConverter::LMBCS_LAST

UConverter::HZ

UConverter::SCSU

UConverter::ISCII

UConverter::US_ASCII

UConverter::UTF7

UConverter::BOCU1

UConverter::UTF16

UConverter::UTF32

UConverter::CESU8

UConverter::IMAP_MAILBOX

Table of Contents

  • UConverter::__construct — Create UConverter object
  • UConverter::convert — Convert string from one charset to another
  • UConverter::fromUCallback — Default "from" callback function
  • UConverter::getAliases — Get the aliases of the given name
  • UConverter::getAvailable — Get the available canonical converter names
  • UConverter::getDestinationEncoding — Get the destination encoding
  • UConverter::getDestinationType — Get the destination converter type
  • UConverter::getErrorCode — Get last error code on the object
  • UConverter::getErrorMessage — Get last error message on the object
  • UConverter::getSourceEncoding — Get the source encoding
  • UConverter::getSourceType — Get the source converter type
  • UConverter::getStandards — Get standards associated to converter names
  • UConverter::getSubstChars — Get substitution chars
  • UConverter::reasonText — Get string representation of the callback reason
  • UConverter::setDestinationEncoding — Set the destination encoding
  • UConverter::setSourceEncoding — Set the source encoding
  • UConverter::setSubstChars — Set the substitution chars
  • UConverter::toUCallback — Default "to" callback function
  • UConverter::transcode — Convert string from one charset to another


Create UConverter object

  • ? UConverter
  • UConverter::convert ?
  • PHP Manual
  • UConverter
  • Create UConverter object

UConverter::__construct

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::__construct — Create UConverter object

说明

public UConverter::__construct ( string $destination_encoding = ? , string $source_encoding = ? )

Warning

本函数还未编写文档，仅有参数列表。

参数

destination_encoding

source_encoding

返回值


Convert string from one charset to another

  • ? UConverter::__construct
  • UConverter::fromUCallback ?
  • PHP Manual
  • UConverter
  • Convert string from one charset to another

UConverter::convert

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::convert — Convert string from one charset to another

说明

public UConverter::convert ( string $str , bool $reverse = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

str

reverse

返回值


Default "from" callback function

  • ? UConverter::convert
  • UConverter::getAliases ?
  • PHP Manual
  • UConverter
  • Default "from" callback function

UConverter::fromUCallback

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::fromUCallback — Default "from" callback function

说明

public UConverter::fromUCallback ( int $reason , string $source , string $codePoint , int &$error ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

reason

source

codePoint

error

返回值


Get the aliases of the given name

  • ? UConverter::fromUCallback
  • UConverter::getAvailable ?
  • PHP Manual
  • UConverter
  • Get the aliases of the given name

UConverter::getAliases

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getAliases — Get the aliases of the given name

说明

public static UConverter::getAliases ( string $name ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


Get the available canonical converter names

  • ? UConverter::getAliases
  • UConverter::getDestinationEncoding ?
  • PHP Manual
  • UConverter
  • Get the available canonical converter names

UConverter::getAvailable

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getAvailable — Get the available canonical converter names

说明

public static UConverter::getAvailable ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the destination encoding

  • ? UConverter::getAvailable
  • UConverter::getDestinationType ?
  • PHP Manual
  • UConverter
  • Get the destination encoding

UConverter::getDestinationEncoding

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getDestinationEncoding — Get the destination encoding

说明

public UConverter::getDestinationEncoding ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the destination converter type

  • ? UConverter::getDestinationEncoding
  • UConverter::getErrorCode ?
  • PHP Manual
  • UConverter
  • Get the destination converter type

UConverter::getDestinationType

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getDestinationType — Get the destination converter type

说明

public UConverter::getDestinationType ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get last error code on the object

  • ? UConverter::getDestinationType
  • UConverter::getErrorMessage ?
  • PHP Manual
  • UConverter
  • Get last error code on the object

UConverter::getErrorCode

intl_get_error_code

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getErrorCode -- intl_get_error_code — Get last error code on the object

说明

public UConverter::getErrorCode ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get last error message on the object

  • ? UConverter::getErrorCode
  • UConverter::getSourceEncoding ?
  • PHP Manual
  • UConverter
  • Get last error message on the object

UConverter::getErrorMessage

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getErrorMessage — Get last error message on the object

说明

public UConverter::getErrorMessage ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the source encoding

  • ? UConverter::getErrorMessage
  • UConverter::getSourceType ?
  • PHP Manual
  • UConverter
  • Get the source encoding

UConverter::getSourceEncoding

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getSourceEncoding — Get the source encoding

说明

public UConverter::getSourceEncoding ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the source converter type

  • ? UConverter::getSourceEncoding
  • UConverter::getStandards ?
  • PHP Manual
  • UConverter
  • Get the source converter type

UConverter::getSourceType

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getSourceType — Get the source converter type

说明

public UConverter::getSourceType ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get standards associated to converter names

  • ? UConverter::getSourceType
  • UConverter::getSubstChars ?
  • PHP Manual
  • UConverter
  • Get standards associated to converter names

UConverter::getStandards

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getStandards — Get standards associated to converter names

说明

public static UConverter::getStandards ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get substitution chars

  • ? UConverter::getStandards
  • UConverter::reasonText ?
  • PHP Manual
  • UConverter
  • Get substitution chars

UConverter::getSubstChars

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::getSubstChars — Get substitution chars

说明

public UConverter::getSubstChars ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get string representation of the callback reason

  • ? UConverter::getSubstChars
  • UConverter::setDestinationEncoding ?
  • PHP Manual
  • UConverter
  • Get string representation of the callback reason

UConverter::reasonText

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::reasonText — Get string representation of the callback reason

说明

public static UConverter::reasonText ( int $reason = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

reason

返回值


Set the destination encoding

  • ? UConverter::reasonText
  • UConverter::setSourceEncoding ?
  • PHP Manual
  • UConverter
  • Set the destination encoding

UConverter::setDestinationEncoding

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::setDestinationEncoding — Set the destination encoding

说明

public UConverter::setDestinationEncoding ( string $encoding ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

encoding

返回值


Set the source encoding

  • ? UConverter::setDestinationEncoding
  • UConverter::setSubstChars ?
  • PHP Manual
  • UConverter
  • Set the source encoding

UConverter::setSourceEncoding

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::setSourceEncoding — Set the source encoding

说明

public UConverter::setSourceEncoding ( string $encoding ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

encoding

返回值


Set the substitution chars

  • ? UConverter::setSourceEncoding
  • UConverter::toUCallback ?
  • PHP Manual
  • UConverter
  • Set the substitution chars

UConverter::setSubstChars

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::setSubstChars — Set the substitution chars

说明

public UConverter::setSubstChars ( string $chars ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

chars

返回值


Default "to" callback function

  • ? UConverter::setSubstChars
  • UConverter::transcode ?
  • PHP Manual
  • UConverter
  • Default "to" callback function

UConverter::toUCallback

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::toUCallback — Default "to" callback function

说明

public UConverter::toUCallback ( int $reason , string $source , string $codeUnits , int &$error ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

reason

source

codeUnits

error

返回值


Convert string from one charset to another

  • ? UConverter::toUCallback
  • Grapheme 函数 ?
  • PHP Manual
  • UConverter
  • Convert string from one charset to another

UConverter::transcode

(PHP 5 >= 5.5.0, PHP 7, PECL >= 3.0.0a1)

UConverter::transcode — Convert string from one charset to another

说明

public static UConverter::transcode ( string $str , string $toEncoding , string $fromEncoding , array $options = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

str

toEncoding

fromEncoding

options

返回值


Grapheme 函数

Table of Contents

  • grapheme_extract — Function to extract a sequence of default grapheme clusters from a text buffer, which must be encoded in UTF-8
  • grapheme_stripos — Find position (in grapheme units) of first occurrence of a case-insensitive string
  • grapheme_stristr — Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
  • grapheme_strlen — Get string length in grapheme units
  • grapheme_strpos — Find position (in grapheme units) of first occurrence of a string
  • grapheme_strripos — Find position (in grapheme units) of last occurrence of a case-insensitive string
  • grapheme_strrpos — Find position (in grapheme units) of last occurrence of a string
  • grapheme_strstr — Returns part of haystack string from the first occurrence of needle to the end of haystack
  • grapheme_substr — Return part of a string


Function to extract a sequence of default grapheme clusters from a text buffer, which must be encoded in UTF-8

  • ? Grapheme 函数
  • grapheme_stripos ?
  • PHP Manual
  • Grapheme 函数
  • Function to extract a sequence of default grapheme clusters from a text buffer, which must be encoded in UTF-8

grapheme_extract

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_extract — Function to extract a sequence of default grapheme clusters from a text buffer, which must be encoded in UTF-8

说明

过程化风格

grapheme_extract ( string $haystack , int $size , int $type = GRAPHEME_EXTR_COUNT , int $offset = 0 , int &$next = null ) : string|false

Function to extract a sequence of default grapheme clusters from a text buffer, which must be encoded in UTF-8.

参数

haystack

String to search.

size

Maximum number items - based on the $extract_type - to return.

type

Defines the type of units referred to by the $size parameter:

  • GRAPHEME_EXTR_COUNT (default) - $size is the number of default grapheme clusters to extract.
  • GRAPHEME_EXTR_MAXBYTES - $size is the maximum number of bytes returned.
  • GRAPHEME_EXTR_MAXCHARS - $size is the maximum number of UTF-8 characters returned.

offset

Starting position in $haystack in bytes - if given, it must be zero or a positive value that is less than or equal to the length of $haystack in bytes, or a negative value that counts from the end of $haystack. If $start does not point to the first byte of a UTF-8 character, the start position is moved to the next character boundary.

next

Reference to a value that will be set to the next starting position. When the call returns, this may point to the first byte position past the end of the string.

返回值

A string starting at offset $start and ending on a default grapheme cluster boundary that conforms to the $size and $extract_type specified, 或者在失败时返回 false.

更新日志

版本 | 说明
7.1.0 | Support for negative offsets has been added.

范例

Example #1 grapheme_extract() example

<?php

$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"

print urlencode(grapheme_extract( $char_a_ring_nfd . $char_o_diaeresis_nfd, 1, GRAPHEME_EXTR_COUNT, 2));

?>

以上例程会输出：

o%CC%88

参见

  • grapheme_substr() - Return part of a string
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries


Find position (in grapheme units) of first occurrence of a case-insensitive string

  • ? grapheme_extract
  • grapheme_stristr ?
  • PHP Manual
  • Grapheme 函数
  • Find position (in grapheme units) of first occurrence of a case-insensitive string

grapheme_stripos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_stripos — Find position (in grapheme units) of first occurrence of a case-insensitive string

说明

过程化风格

grapheme_stripos ( string $haystack , string $needle , int $offset = 0 ) : int|false

Find position (in grapheme units) of first occurrence of a case-insensitive string

参数

haystack

The string to look in. Must be valid UTF-8.

needle

The string to look for. Must be valid UTF-8.

offset

The optional $offset parameter allows you to specify where in haystack to start searching as an offset in grapheme units (not bytes or characters). If the offset is negative, it is treated relative to the end of the string. The position returned is still relative to the beginning of haystack regardless of the value of $offset.

返回值

Returns the position as an integer. If needle is not found, grapheme_stripos() will return false.

更新日志

版本 | 说明
7.1.0 | Support for negative offsets has been added.

范例

Example #1 grapheme_stripos() example

<?php

$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"
$char_O_diaeresis_nfd = "O\xCC\x88"; // 'LATIN CAPITAL LETTER O WITH DIAERESIS' (U+00D6) normalization form "D"

print grapheme_stripos( $char_a_ring_nfd . $char_a_ring_nfd . $char_o_diaeresis_nfd, $char_O_diaeresis_nfd);

?>

以上例程会输出：

2

参见

  • grapheme_stristr() - Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
  • grapheme_strpos() - Find position (in grapheme units) of first occurrence of a string
  • grapheme_strripos() - Find position (in grapheme units) of last occurrence of a case-insensitive string
  • grapheme_strrpos() - Find position (in grapheme units) of last occurrence of a string
  • grapheme_strstr() - Returns part of haystack string from the first occurrence of needle to the end of haystack
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries


Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack

  • ? grapheme_stripos
  • grapheme_strlen ?
  • PHP Manual
  • Grapheme 函数
  • Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack

grapheme_stristr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_stristr — Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack

说明

过程化风格

grapheme_stristr ( string $haystack , string $needle , bool $beforeNeedle = false ) : string|false

Returns part of haystack string starting from and including the first occurrence of case-insensitive needle to the end of haystack.

参数

haystack

The input string. Must be valid UTF-8.

needle

The string to look for. Must be valid UTF-8.

beforeNeedle

If true, grapheme_strstr() returns the part of the haystack before the first occurrence of the needle (excluding needle).

返回值

Returns the portion of $haystack, or false if $needle is not found.

范例

Example #1 grapheme_stristr() example

<?php

$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"
$char_O_diaeresis_nfd = "O\xCC\x88"; // 'LATIN CAPITAL LETTER O WITH DIAERESIS' (U+00D6) normalization form "D"

print urlencode(grapheme_stristr( $char_a_ring_nfd . $char_o_diaeresis_nfd . $char_a_ring_nfd, $char_O_diaeresis_nfd));

?>

以上例程会输出：

o%CC%88a%CC%8A

参见

  • grapheme_stripos() - Find position (in grapheme units) of first occurrence of a case-insensitive string
  • grapheme_strpos() - Find position (in grapheme units) of first occurrence of a string
  • grapheme_strripos() - Find position (in grapheme units) of last occurrence of a case-insensitive string
  • grapheme_strrpos() - Find position (in grapheme units) of last occurrence of a string
  • grapheme_strstr() - Returns part of haystack string from the first occurrence of needle to the end of haystack
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries


Get string length in grapheme units

  • ? grapheme_stristr
  • grapheme_strpos ?
  • PHP Manual
  • Grapheme 函数
  • Get string length in grapheme units

grapheme_strlen

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strlen — Get string length in grapheme units

说明

过程化风格

grapheme_strlen ( string $string ) : int|false|null

Get string length in grapheme units (not bytes or characters)

参数

string

The string being measured for length. It must be a valid UTF-8 string.

返回值

The length of the string on success, 或者在失败时返回 false.

范例

Example #1 grapheme_strlen() example

<?php

$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"

print grapheme_strlen( 'abc' . $char_a_ring_nfd . $char_o_diaeresis_nfd . $char_a_ring_nfd);

?>

以上例程会输出：

6

参见

  • » Unicode Text Segmentation: Grapheme Cluster Boundaries
  • iconv_strlen() - 返回字符串的字符数统计
  • mb_strlen() - 获取字符串的长度
  • strlen() - 获取字符串长度


Find position (in grapheme units) of first occurrence of a string

  • ? grapheme_strlen
  • grapheme_strripos ?
  • PHP Manual
  • Grapheme 函数
  • Find position (in grapheme units) of first occurrence of a string

grapheme_strpos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strpos — Find position (in grapheme units) of first occurrence of a string

说明

过程化风格

grapheme_strpos ( string $haystack , string $needle , int $offset = 0 ) : int|false

Find position (in grapheme units) of first occurrence of a string

参数

haystack

The string to look in. Must be valid UTF-8.

needle

The string to look for. Must be valid UTF-8.

offset

The optional $offset parameter allows you to specify where in $haystack to start searching as an offset in grapheme units (not bytes or characters). If the offset is negative, it is treated relative to the end of the string. The position returned is still relative to the beginning of haystack regardless of the value of $offset.

返回值

Returns the position as an integer. If needle is not found, grapheme_strpos() will return false.

更新日志

版本 | 说明
7.1.0 | Support for negative offsets has been added.

范例

Example #1 grapheme_strpos() example

<?php

$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"

print grapheme_strpos( $char_a_ring_nfd . $char_a_ring_nfd . $char_o_diaeresis_nfd, $char_o_diaeresis_nfd);

?>

以上例程会输出：

2

参见

  • grapheme_stripos() - Find position (in grapheme units) of first occurrence of a case-insensitive string
  • grapheme_stristr() - Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
  • grapheme_strripos() - Find position (in grapheme units) of last occurrence of a case-insensitive string
  • grapheme_strrpos() - Find position (in grapheme units) of last occurrence of a string
  • grapheme_strstr() - Returns part of haystack string from the first occurrence of needle to the end of haystack
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries


Find position (in grapheme units) of last occurrence of a case-insensitive string

  • ? grapheme_strpos
  • grapheme_strrpos ?
  • PHP Manual
  • Grapheme 函数
  • Find position (in grapheme units) of last occurrence of a case-insensitive string

grapheme_strripos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strripos — Find position (in grapheme units) of last occurrence of a case-insensitive string

说明

过程化风格

grapheme_strripos ( string $haystack , string $needle , int $offset = 0 ) : int|false

Find position (in grapheme units) of last occurrence of a case-insensitive string

参数

haystack

The string to look in. Must be valid UTF-8.

needle

The string to look for. Must be valid UTF-8.

offset

The optional $offset parameter allows you to specify where in $haystack to start searching as an offset in grapheme units (not bytes or characters). The position returned is still relative to the beginning of haystack regardless of the value of $offset.

返回值

Returns the position as an integer. If needle is not found, grapheme_strripos() will return false.

范例

Example #1 grapheme_strripos() example

<?php

$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"
$char_O_diaeresis_nfd = "O\xCC\x88"; // 'LATIN CAPITAL LETTER O WITH DIAERESIS' (U+00D6) normalization form "D"

print grapheme_strripos( $char_a_ring_nfd . $char_o_diaeresis_nfd . $char_o_diaeresis_nfd, $char_O_diaeresis_nfd);

?>

以上例程会输出：

2

参见

  • grapheme_stripos() - Find position (in grapheme units) of first occurrence of a case-insensitive string
  • grapheme_stristr() - Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
  • grapheme_strpos() - Find position (in grapheme units) of first occurrence of a string
  • grapheme_strrpos() - Find position (in grapheme units) of last occurrence of a string
  • grapheme_strstr() - Returns part of haystack string from the first occurrence of needle to the end of haystack
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries


Find position (in grapheme units) of last occurrence of a string

  • ? grapheme_strripos
  • grapheme_strstr ?
  • PHP Manual
  • Grapheme 函数
  • Find position (in grapheme units) of last occurrence of a string

grapheme_strrpos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strrpos — Find position (in grapheme units) of last occurrence of a string

说明

过程化风格

grapheme_strrpos ( string $haystack , string $needle , int $offset = 0 ) : int|false

Find position (in grapheme units) of last occurrence of a string

参数

haystack

The string to look in. Must be valid UTF-8.

needle

The string to look for. Must be valid UTF-8.

offset

The optional $offset parameter allows you to specify where in $haystack to start searching as an offset in grapheme units (not bytes or characters). The position returned is still relative to the beginning of haystack regardless of the value of $offset.

返回值

Returns the position as an integer. If needle is not found, grapheme_strrpos() will return false.

范例

Example #1 grapheme_strrpos() example

<?php
$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"

print grapheme_strrpos( $char_a_ring_nfd . $char_o_diaeresis_nfd . $char_o_diaeresis_nfd, $char_o_diaeresis_nfd);
?>

以上例程会输出：

2

参见

  • grapheme_stripos() - Find position (in grapheme units) of first occurrence of a case-insensitive string
  • grapheme_stristr() - Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
  • grapheme_strpos() - Find position (in grapheme units) of first occurrence of a string
  • grapheme_strripos() - Find position (in grapheme units) of last occurrence of a case-insensitive string
  • grapheme_strstr() - Returns part of haystack string from the first occurrence of needle to the end of haystack
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries


Returns part of haystack string from the first occurrence of needle to the end of haystack

  • ? grapheme_strrpos
  • grapheme_substr ?
  • PHP Manual
  • Grapheme 函数
  • Returns part of haystack string from the first occurrence of needle to the end of haystack

grapheme_strstr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strstr — Returns part of haystack string from the first occurrence of needle to the end of haystack

说明

过程化风格

grapheme_strstr ( string $haystack , string $needle , bool $beforeNeedle = false ) : string|false

Returns part of haystack string from the first occurrence of needle to the end of haystack (including the needle).

参数

haystack

The input string. Must be valid UTF-8.

needle

The string to look for. Must be valid UTF-8.

beforeNeedle

If true, grapheme_strstr() returns the part of the haystack before the first occurrence of the needle (excluding the needle).

返回值

Returns the portion of string, or false if needle is not found.

范例

Example #1 grapheme_strstr() example

<?php

$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"

print urlencode(grapheme_stristr( $char_a_ring_nfd . $char_o_diaeresis_nfd . $char_a_ring_nfd, $char_o_diaeresis_nfd));

?>

以上例程会输出：

o%CC%88a%CC%8A

参见

  • grapheme_stristr() - Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
  • grapheme_stripos() - Find position (in grapheme units) of first occurrence of a case-insensitive string
  • grapheme_strpos() - Find position (in grapheme units) of first occurrence of a string
  • grapheme_strripos() - Find position (in grapheme units) of last occurrence of a case-insensitive string
  • grapheme_strrpos() - Find position (in grapheme units) of last occurrence of a string
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries


Return part of a string

  • ? grapheme_strstr
  • IDN 函数 ?
  • PHP Manual
  • Grapheme 函数
  • Return part of a string

grapheme_substr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_substr — Return part of a string

说明

过程化风格

grapheme_substr ( string $string , int $offset , int|null $length = null ) : string|false

Return part of a string

参数

string

The input string. Must be valid UTF-8.

offset

Start position in default grapheme units. If $start is non-negative, the returned string will start at the $start'th position in $string, counting from zero. If $start is negative, the returned string will start at the $start'th grapheme unit from the end of string.

length

Length in grapheme units. If $length is given and is positive, the string returned will contain at most $length grapheme units beginning from $start (depending on the length of string). If $length is given and is negative, then that many grapheme units will be omitted from the end of string (after the start position has been calculated when a start is negative). If $start denotes a position beyond this truncation, false will be returned.

返回值

Returns the extracted part of string, 或者在失败时返回 false.

范例

Example #1 grapheme_substr() example

<?php

$char_a_ring_nfd = "a\xCC\x8A";  // 'LATIN SMALL LETTER A WITH RING ABOVE' (U+00E5) normalization form "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'LATIN SMALL LETTER O WITH DIAERESIS' (U+00F6) normalization form "D"

print urlencode(grapheme_substr( "ao" . $char_a_ring_nfd . "bc" . $char_o_diaeresis_nfd . "O", 2, -1 ));
?>

以上例程会输出：

a%CC%8Abco%CC%88

参见

  • grapheme_extract() - Function to extract a sequence of default grapheme clusters from a text buffer, which must be encoded in UTF-8
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries


IDN 函数

Table of Contents

  • idn_to_ascii — 将域名转换为 IDNA ASCII 格式
  • idn_to_utf8 — 将域名从 IDNA ASCII 转换为 Unicode


将域名转换为 IDNA ASCII 格式

  • ? IDN 函数
  • idn_to_utf8 ?
  • PHP Manual
  • IDN 函数
  • 将域名转换为 IDNA ASCII 格式

idn_to_ascii

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.2, PECL idn >= 0.1)

idn_to_ascii — 将域名转换为 IDNA ASCII 格式

说明

过程化风格

idn_to_ascii ( string $domain , int $options = IDNA_DEFAULT , int $variant = INTL_IDNA_VARIANT_UTS46 , array &$idna_info = ? ) : string|false

该函数可以将 Unicode 域名转换为 IDNA ASCII 兼容格式。

参数

domain

要转换的域，必须使用 UTF-8 编码。

options

转换选项 — IDNA_* 开头的常量（除 IDNA_ERROR_* 开头的常量）。

variant

对于 IDNA 2003 是 INTL_IDNA_VARIANT_2003 (自 PHP 7.2.0 起已弃用)， 对于 UTS #46 是 INTL_IDNA_VARIANT_UTS46 (仅 ICU 4.6 起可用)。

idna_info

仅当 INTL_IDNA_VARIANT_UTS46 用于 variant 时，才可以使用该参数。 在这种情况下，它将用这些键组成的数组来填充： 'result' 键，转换结果（有可能是一个非法结果）； 'isTransitionalDifferent' 键，布尔值，指示使用 UTS #46 的过滤机制是否会改变结果； 'errors' 键，是 IDNA_ERROR_* 常量集里一个常量对应的 int 。

返回值

IDNA ASCII 兼容格式编码的域名， 或者在失败时返回 false

更新日志

版本 | 说明
7.4.0 | 现在 variant 的默认值为 INTL_IDNA_VARIANT_UTS46 ， 而不是已弃用的 INTL_IDNA_VARIANT_2003 。
7.2.0 | INTL_IDNA_VARIANT_2003 已被弃用； 可以使用 INTL_IDNA_VARIANT_UTS46 代替。

范例

Example #1 idn_to_ascii() 示例

<?php

echo idn_to_ascii('t?st.de');

?>

以上例程会输出：

xn--tst-qla.de

参见

  • idn_to_utf8() - 将域名从 IDNA ASCII 转换为 Unicode


将域名从 IDNA ASCII 转换为 Unicode

  • ? idn_to_ascii
  • IntlChar ?
  • PHP Manual
  • IDN 函数
  • 将域名从 IDNA ASCII 转换为 Unicode

idn_to_utf8

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.2, PECL idn >= 0.1)

idn_to_utf8 — 将域名从 IDNA ASCII 转换为 Unicode

说明

过程化风格

idn_to_utf8 ( string $domain , int $options = IDNA_DEFAULT , int $variant = INTL_IDNA_VARIANT_UTS46 , array &$idna_info = ? ) : string|false

该函数将 Unicode 域名从 IDNA ASCII 兼容格式转换为 纯 Unicode（UTF-8 编码）。

参数

domain

要转换的 IDNA ASCII 兼容格式的域名。

options

转换选项 — IDNA_* 开头的常量（除 IDNA_ERROR_* 开头的常量）。

variant

对于 IDNA 2003 是 INTL_IDNA_VARIANT_2003 (自 PHP 7.2.0 起已弃用)， 对于 UTS #46 是 INTL_IDNA_VARIANT_UTS46 (仅 ICU 4.6 起可用)。

idna_info

仅当 INTL_IDNA_VARIANT_UTS46 用于 variant 时，才可以使用该参数。 在这种情况下，它将用这些键组成的数组来填充： 'result' 键，转换结果（有可能是一个非法结果）； 'isTransitionalDifferent' 键，布尔值，指示使用 UTS #46 的过滤机制是否会改变结果； 'errors' 键，是 IDNA_ERROR_* 常量集里一个常量对应的 int 。

返回值

UTF-8 编码的 Unicode 域名， 或者在失败时返回 false

更新日志

版本 | 说明
7.4.0 | 现在 variant 的默认值为 INTL_IDNA_VARIANT_UTS46 ， 而不是已弃用的 INTL_IDNA_VARIANT_2003 。
7.2.0 | INTL_IDNA_VARIANT_2003 已被弃用； 可以使用 INTL_IDNA_VARIANT_UTS46 代替。

范例

Example #1 idn_to_utf8() 示例

<?php

echo idn_to_utf8('xn--tst-qla.de');

?>

以上例程会输出：

t?st.de

参见

  • idn_to_ascii() - 将域名转换为 IDNA ASCII 格式


IntlChar

(PHP 7)

简介

IntlChar provides access to a number of utility methods that can be used to access information about Unicode characters.

The methods and constants adhere closely to the names and behavior used by the underlying ICU library.

类摘要

IntlChar {
/* Constants */
const string UNICODE_VERSION = 6.3 ;
const int CODEPOINT_MIN = 0 ;
const int CODEPOINT_MAX = 1114111 ;
const float NO_NUMERIC_VALUE = -123456789 ;
const int PROPERTY_ALPHABETIC = 0 ;
const int PROPERTY_BINARY_START = 0 ;
const int PROPERTY_ASCII_HEX_DIGIT = 1 ;
const int PROPERTY_BIDI_CONTROL = 2 ;
const int PROPERTY_BIDI_MIRRORED = 3 ;
const int PROPERTY_DASH = 4 ;
const int PROPERTY_DEFAULT_IGNORABLE_CODE_POINT = 5 ;
const int PROPERTY_DEPRECATED = 6 ;
const int PROPERTY_DIACRITIC = 7 ;
const int PROPERTY_EXTENDER = 8 ;
const int PROPERTY_FULL_COMPOSITION_EXCLUSION = 9 ;
const int PROPERTY_GRAPHEME_BASE = 10 ;
const int PROPERTY_GRAPHEME_EXTEND = 11 ;
const int PROPERTY_GRAPHEME_LINK = 12 ;
const int PROPERTY_HEX_DIGIT = 13 ;
const int PROPERTY_HYPHEN = 14 ;
const int PROPERTY_ID_CONTINUE = 15 ;
const int PROPERTY_ID_START = 16 ;
const int PROPERTY_IDEOGRAPHIC = 17 ;
const int PROPERTY_IDS_BINARY_OPERATOR = 18 ;
const int PROPERTY_IDS_TRINARY_OPERATOR = 19 ;
const int PROPERTY_JOIN_CONTROL = 20 ;
const int PROPERTY_LOGICAL_ORDER_EXCEPTION = 21 ;
const int PROPERTY_LOWERCASE = 22 ;
const int PROPERTY_MATH = 23 ;
const int PROPERTY_NONCHARACTER_CODE_POINT = 24 ;
const int PROPERTY_QUOTATION_MARK = 25 ;
const int PROPERTY_RADICAL = 26 ;
const int PROPERTY_SOFT_DOTTED = 27 ;
const int PROPERTY_TERMINAL_PUNCTUATION = 28 ;
const int PROPERTY_UNIFIED_IDEOGRAPH = 29 ;
const int PROPERTY_UPPERCASE = 30 ;
const int PROPERTY_WHITE_SPACE = 31 ;
const int PROPERTY_XID_CONTINUE = 32 ;
const int PROPERTY_XID_START = 33 ;
const int PROPERTY_CASE_SENSITIVE = 34 ;
const int PROPERTY_S_TERM = 35 ;
const int PROPERTY_VARIATION_SELECTOR = 36 ;
const int PROPERTY_NFD_INERT = 37 ;
const int PROPERTY_NFKD_INERT = 38 ;
const int PROPERTY_NFC_INERT = 39 ;
const int PROPERTY_NFKC_INERT = 40 ;
const int PROPERTY_SEGMENT_STARTER = 41 ;
const int PROPERTY_PATTERN_SYNTAX = 42 ;
const int PROPERTY_PATTERN_WHITE_SPACE = 43 ;
const int PROPERTY_POSIX_ALNUM = 44 ;
const int PROPERTY_POSIX_BLANK = 45 ;
const int PROPERTY_POSIX_GRAPH = 46 ;
const int PROPERTY_POSIX_PRINT = 47 ;
const int PROPERTY_POSIX_XDIGIT = 48 ;
const int PROPERTY_CASED = 49 ;
const int PROPERTY_CASE_IGNORABLE = 50 ;
const int PROPERTY_CHANGES_WHEN_LOWERCASED = 51 ;
const int PROPERTY_CHANGES_WHEN_UPPERCASED = 52 ;
const int PROPERTY_CHANGES_WHEN_TITLECASED = 53 ;
const int PROPERTY_CHANGES_WHEN_CASEFOLDED = 54 ;
const int PROPERTY_CHANGES_WHEN_CASEMAPPED = 55 ;
const int PROPERTY_CHANGES_WHEN_NFKC_CASEFOLDED = 56 ;
const int PROPERTY_BINARY_LIMIT = 57 ;
const int PROPERTY_BIDI_CLASS = 4096 ;
const int PROPERTY_INT_START = 4096 ;
const int PROPERTY_BLOCK = 4097 ;
const int PROPERTY_CANONICAL_COMBINING_CLASS = 4098 ;
const int PROPERTY_DECOMPOSITION_TYPE = 4099 ;
const int PROPERTY_EAST_ASIAN_WIDTH = 4100 ;
const int PROPERTY_GENERAL_CATEGORY = 4101 ;
const int PROPERTY_JOINING_GROUP = 4102 ;
const int PROPERTY_JOINING_TYPE = 4103 ;
const int PROPERTY_LINE_BREAK = 4104 ;
const int PROPERTY_NUMERIC_TYPE = 4105 ;
const int PROPERTY_SCRIPT = 4106 ;
const int PROPERTY_HANGUL_SYLLABLE_TYPE = 4107 ;
const int PROPERTY_NFD_QUICK_CHECK = 4108 ;
const int PROPERTY_NFKD_QUICK_CHECK = 4109 ;
const int PROPERTY_NFC_QUICK_CHECK = 4110 ;
const int PROPERTY_NFKC_QUICK_CHECK = 4111 ;
const int PROPERTY_LEAD_CANONICAL_COMBINING_CLASS = 4112 ;
const int PROPERTY_TRAIL_CANONICAL_COMBINING_CLASS = 4113 ;
const int PROPERTY_GRAPHEME_CLUSTER_BREAK = 4114 ;
const int PROPERTY_SENTENCE_BREAK = 4115 ;
const int PROPERTY_WORD_BREAK = 4116 ;
const int PROPERTY_BIDI_PAIRED_BRACKET_TYPE = 4117 ;
const int PROPERTY_INT_LIMIT = 4118 ;
const int PROPERTY_GENERAL_CATEGORY_MASK = 8192 ;
const int PROPERTY_MASK_START = 8192 ;
const int PROPERTY_MASK_LIMIT = 8193 ;
const int PROPERTY_NUMERIC_VALUE = 12288 ;
const int PROPERTY_DOUBLE_START = 12288 ;
const int PROPERTY_DOUBLE_LIMIT = 12289 ;
const int PROPERTY_AGE = 16384 ;
const int PROPERTY_STRING_START = 16384 ;
const int PROPERTY_BIDI_MIRRORING_GLYPH = 16385 ;
const int PROPERTY_CASE_FOLDING = 16386 ;
const int PROPERTY_ISO_COMMENT = 16387 ;
const int PROPERTY_LOWERCASE_MAPPING = 16388 ;
const int PROPERTY_NAME = 16389 ;
const int PROPERTY_SIMPLE_CASE_FOLDING = 16390 ;
const int PROPERTY_SIMPLE_LOWERCASE_MAPPING = 16391 ;
const int PROPERTY_SIMPLE_TITLECASE_MAPPING = 16392 ;
const int PROPERTY_SIMPLE_UPPERCASE_MAPPING = 16393 ;
const int PROPERTY_TITLECASE_MAPPING = 16394 ;
const int PROPERTY_UNICODE_1_NAME = 16395 ;
const int PROPERTY_UPPERCASE_MAPPING = 16396 ;
const int PROPERTY_BIDI_PAIRED_BRACKET = 16397 ;
const int PROPERTY_STRING_LIMIT = 16398 ;
const int PROPERTY_SCRIPT_EXTENSIONS = 28672 ;
const int PROPERTY_OTHER_PROPERTY_START = 28672 ;
const int PROPERTY_OTHER_PROPERTY_LIMIT = 28673 ;
const int PROPERTY_INVALID_CODE = -1 ;
const int CHAR_CATEGORY_UNASSIGNED = 0 ;
const int CHAR_CATEGORY_GENERAL_OTHER_TYPES = 0 ;
const int CHAR_CATEGORY_UPPERCASE_LETTER = 1 ;
const int CHAR_CATEGORY_LOWERCASE_LETTER = 2 ;
const int CHAR_CATEGORY_TITLECASE_LETTER = 3 ;
const int CHAR_CATEGORY_MODIFIER_LETTER = 4 ;
const int CHAR_CATEGORY_OTHER_LETTER = 5 ;
const int CHAR_CATEGORY_NON_SPACING_MARK = 6 ;
const int CHAR_CATEGORY_ENCLOSING_MARK = 7 ;
const int CHAR_CATEGORY_COMBINING_SPACING_MARK = 8 ;
const int CHAR_CATEGORY_DECIMAL_DIGIT_NUMBER = 9 ;
const int CHAR_CATEGORY_LETTER_NUMBER = 10 ;
const int CHAR_CATEGORY_OTHER_NUMBER = 11 ;
const int CHAR_CATEGORY_SPACE_SEPARATOR = 12 ;
const int CHAR_CATEGORY_LINE_SEPARATOR = 13 ;
const int CHAR_CATEGORY_PARAGRAPH_SEPARATOR = 14 ;
const int CHAR_CATEGORY_CONTROL_CHAR = 15 ;
const int CHAR_CATEGORY_FORMAT_CHAR = 16 ;
const int CHAR_CATEGORY_PRIVATE_USE_CHAR = 17 ;
const int CHAR_CATEGORY_SURROGATE = 18 ;
const int CHAR_CATEGORY_DASH_PUNCTUATION = 19 ;
const int CHAR_CATEGORY_START_PUNCTUATION = 20 ;
const int CHAR_CATEGORY_END_PUNCTUATION = 21 ;
const int CHAR_CATEGORY_CONNECTOR_PUNCTUATION = 22 ;
const int CHAR_CATEGORY_OTHER_PUNCTUATION = 23 ;
const int CHAR_CATEGORY_MATH_SYMBOL = 24 ;
const int CHAR_CATEGORY_CURRENCY_SYMBOL = 25 ;
const int CHAR_CATEGORY_MODIFIER_SYMBOL = 26 ;
const int CHAR_CATEGORY_OTHER_SYMBOL = 27 ;
const int CHAR_CATEGORY_INITIAL_PUNCTUATION = 28 ;
const int CHAR_CATEGORY_FINAL_PUNCTUATION = 29 ;
const int CHAR_CATEGORY_CHAR_CATEGORY_COUNT = 30 ;
const int CHAR_DIRECTION_LEFT_TO_RIGHT = 0 ;
const int CHAR_DIRECTION_RIGHT_TO_LEFT = 1 ;
const int CHAR_DIRECTION_EUROPEAN_NUMBER = 2 ;
const int CHAR_DIRECTION_EUROPEAN_NUMBER_SEPARATOR = 3 ;
const int CHAR_DIRECTION_EUROPEAN_NUMBER_TERMINATOR = 4 ;
const int CHAR_DIRECTION_ARABIC_NUMBER = 5 ;
const int CHAR_DIRECTION_COMMON_NUMBER_SEPARATOR = 6 ;
const int CHAR_DIRECTION_BLOCK_SEPARATOR = 7 ;
const int CHAR_DIRECTION_SEGMENT_SEPARATOR = 8 ;
const int CHAR_DIRECTION_WHITE_SPACE_NEUTRAL = 9 ;
const int CHAR_DIRECTION_OTHER_NEUTRAL = 10 ;
const int CHAR_DIRECTION_LEFT_TO_RIGHT_EMBEDDING = 11 ;
const int CHAR_DIRECTION_LEFT_TO_RIGHT_OVERRIDE = 12 ;
const int CHAR_DIRECTION_RIGHT_TO_LEFT_ARABIC = 13 ;
const int CHAR_DIRECTION_RIGHT_TO_LEFT_EMBEDDING = 14 ;
const int CHAR_DIRECTION_RIGHT_TO_LEFT_OVERRIDE = 15 ;
const int CHAR_DIRECTION_POP_DIRECTIONAL_FORMAT = 16 ;
const int CHAR_DIRECTION_DIR_NON_SPACING_MARK = 17 ;
const int CHAR_DIRECTION_BOUNDARY_NEUTRAL = 18 ;
const int CHAR_DIRECTION_FIRST_STRONG_ISOLATE = 19 ;
const int CHAR_DIRECTION_LEFT_TO_RIGHT_ISOLATE = 20 ;
const int CHAR_DIRECTION_RIGHT_TO_LEFT_ISOLATE = 21 ;
const int CHAR_DIRECTION_POP_DIRECTIONAL_ISOLATE = 22 ;
const int CHAR_DIRECTION_CHAR_DIRECTION_COUNT = 23 ;
const int BLOCK_CODE_NO_BLOCK = 0 ;
const int BLOCK_CODE_BASIC_LATIN = 1 ;
const int BLOCK_CODE_LATIN_1_SUPPLEMENT = 2 ;
const int BLOCK_CODE_LATIN_EXTENDED_A = 3 ;
const int BLOCK_CODE_LATIN_EXTENDED_B = 4 ;
const int BLOCK_CODE_IPA_EXTENSIONS = 5 ;
const int BLOCK_CODE_SPACING_MODIFIER_LETTERS = 6 ;
const int BLOCK_CODE_COMBINING_DIACRITICAL_MARKS = 7 ;
const int BLOCK_CODE_GREEK = 8 ;
const int BLOCK_CODE_CYRILLIC = 9 ;
const int BLOCK_CODE_ARMENIAN = 10 ;
const int BLOCK_CODE_HEBREW = 11 ;
const int BLOCK_CODE_ARABIC = 12 ;
const int BLOCK_CODE_SYRIAC = 13 ;
const int BLOCK_CODE_THAANA = 14 ;
const int BLOCK_CODE_DEVANAGARI = 15 ;
const int BLOCK_CODE_BENGALI = 16 ;
const int BLOCK_CODE_GURMUKHI = 17 ;
const int BLOCK_CODE_GUJARATI = 18 ;
const int BLOCK_CODE_ORIYA = 19 ;
const int BLOCK_CODE_TAMIL = 20 ;
const int BLOCK_CODE_TELUGU = 21 ;
const int BLOCK_CODE_KANNADA = 22 ;
const int BLOCK_CODE_MALAYALAM = 23 ;
const int BLOCK_CODE_SINHALA = 24 ;
const int BLOCK_CODE_THAI = 25 ;
const int BLOCK_CODE_LAO = 26 ;
const int BLOCK_CODE_TIBETAN = 27 ;
const int BLOCK_CODE_MYANMAR = 28 ;
const int BLOCK_CODE_GEORGIAN = 29 ;
const int BLOCK_CODE_HANGUL_JAMO = 30 ;
const int BLOCK_CODE_ETHIOPIC = 31 ;
const int BLOCK_CODE_CHEROKEE = 32 ;
const int BLOCK_CODE_UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS = 33 ;
const int BLOCK_CODE_OGHAM = 34 ;
const int BLOCK_CODE_RUNIC = 35 ;
const int BLOCK_CODE_KHMER = 36 ;
const int BLOCK_CODE_MONGOLIAN = 37 ;
const int BLOCK_CODE_LATIN_EXTENDED_ADDITIONAL = 38 ;
const int BLOCK_CODE_GREEK_EXTENDED = 39 ;
const int BLOCK_CODE_GENERAL_PUNCTUATION = 40 ;
const int BLOCK_CODE_SUPERSCRIPTS_AND_SUBSCRIPTS = 41 ;
const int BLOCK_CODE_CURRENCY_SYMBOLS = 42 ;
const int BLOCK_CODE_COMBINING_MARKS_FOR_SYMBOLS = 43 ;
const int BLOCK_CODE_LETTERLIKE_SYMBOLS = 44 ;
const int BLOCK_CODE_NUMBER_FORMS = 45 ;
const int BLOCK_CODE_ARROWS = 46 ;
const int BLOCK_CODE_MATHEMATICAL_OPERATORS = 47 ;
const int BLOCK_CODE_MISCELLANEOUS_TECHNICAL = 48 ;
const int BLOCK_CODE_CONTROL_PICTURES = 49 ;
const int BLOCK_CODE_OPTICAL_CHARACTER_RECOGNITION = 50 ;
const int BLOCK_CODE_ENCLOSED_ALPHANUMERICS = 51 ;
const int BLOCK_CODE_BOX_DRAWING = 52 ;
const int BLOCK_CODE_BLOCK_ELEMENTS = 53 ;
const int BLOCK_CODE_GEOMETRIC_SHAPES = 54 ;
const int BLOCK_CODE_MISCELLANEOUS_SYMBOLS = 55 ;
const int BLOCK_CODE_DINGBATS = 56 ;
const int BLOCK_CODE_BRAILLE_PATTERNS = 57 ;
const int BLOCK_CODE_CJK_RADICALS_SUPPLEMENT = 58 ;
const int BLOCK_CODE_KANGXI_RADICALS = 59 ;
const int BLOCK_CODE_IDEOGRAPHIC_DESCRIPTION_CHARACTERS = 60 ;
const int BLOCK_CODE_CJK_SYMBOLS_AND_PUNCTUATION = 61 ;
const int BLOCK_CODE_HIRAGANA = 62 ;
const int BLOCK_CODE_KATAKANA = 63 ;
const int BLOCK_CODE_BOPOMOFO = 64 ;
const int BLOCK_CODE_HANGUL_COMPATIBILITY_JAMO = 65 ;
const int BLOCK_CODE_KANBUN = 66 ;
const int BLOCK_CODE_BOPOMOFO_EXTENDED = 67 ;
const int BLOCK_CODE_ENCLOSED_CJK_LETTERS_AND_MONTHS = 68 ;
const int BLOCK_CODE_CJK_COMPATIBILITY = 69 ;
const int BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A = 70 ;
const int BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS = 71 ;
const int BLOCK_CODE_YI_SYLLABLES = 72 ;
const int BLOCK_CODE_YI_RADICALS = 73 ;
const int BLOCK_CODE_HANGUL_SYLLABLES = 74 ;
const int BLOCK_CODE_HIGH_SURROGATES = 75 ;
const int BLOCK_CODE_HIGH_PRIVATE_USE_SURROGATES = 76 ;
const int BLOCK_CODE_LOW_SURROGATES = 77 ;
const int BLOCK_CODE_PRIVATE_USE_AREA = 78 ;
const int BLOCK_CODE_PRIVATE_USE = 78 ;
const int BLOCK_CODE_CJK_COMPATIBILITY_IDEOGRAPHS = 79 ;
const int BLOCK_CODE_ALPHABETIC_PRESENTATION_FORMS = 80 ;
const int BLOCK_CODE_ARABIC_PRESENTATION_FORMS_A = 81 ;
const int BLOCK_CODE_COMBINING_HALF_MARKS = 82 ;
const int BLOCK_CODE_CJK_COMPATIBILITY_FORMS = 83 ;
const int BLOCK_CODE_SMALL_FORM_VARIANTS = 84 ;
const int BLOCK_CODE_ARABIC_PRESENTATION_FORMS_B = 85 ;
const int BLOCK_CODE_SPECIALS = 86 ;
const int BLOCK_CODE_HALFWIDTH_AND_FULLWIDTH_FORMS = 87 ;
const int BLOCK_CODE_OLD_ITALIC = 88 ;
const int BLOCK_CODE_GOTHIC = 89 ;
const int BLOCK_CODE_DESERET = 90 ;
const int BLOCK_CODE_BYZANTINE_MUSICAL_SYMBOLS = 91 ;
const int BLOCK_CODE_MUSICAL_SYMBOLS = 92 ;
const int BLOCK_CODE_MATHEMATICAL_ALPHANUMERIC_SYMBOLS = 93 ;
const int BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B = 94 ;
const int BLOCK_CODE_CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT = 95 ;
const int BLOCK_CODE_TAGS = 96 ;
const int BLOCK_CODE_CYRILLIC_SUPPLEMENT = 97 ;
const int BLOCK_CODE_CYRILLIC_SUPPLEMENTARY = 97 ;
const int BLOCK_CODE_TAGALOG = 98 ;
const int BLOCK_CODE_HANUNOO = 99 ;
const int BLOCK_CODE_BUHID = 100 ;
const int BLOCK_CODE_TAGBANWA = 101 ;
const int BLOCK_CODE_MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A = 102 ;
const int BLOCK_CODE_SUPPLEMENTAL_ARROWS_A = 103 ;
const int BLOCK_CODE_SUPPLEMENTAL_ARROWS_B = 104 ;
const int BLOCK_CODE_MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B = 105 ;
const int BLOCK_CODE_SUPPLEMENTAL_MATHEMATICAL_OPERATORS = 106 ;
const int BLOCK_CODE_KATAKANA_PHONETIC_EXTENSIONS = 107 ;
const int BLOCK_CODE_VARIATION_SELECTORS = 108 ;
const int BLOCK_CODE_SUPPLEMENTARY_PRIVATE_USE_AREA_A = 109 ;
const int BLOCK_CODE_SUPPLEMENTARY_PRIVATE_USE_AREA_B = 110 ;
const int BLOCK_CODE_LIMBU = 111 ;
const int BLOCK_CODE_TAI_LE = 112 ;
const int BLOCK_CODE_KHMER_SYMBOLS = 113 ;
const int BLOCK_CODE_PHONETIC_EXTENSIONS = 114 ;
const int BLOCK_CODE_MISCELLANEOUS_SYMBOLS_AND_ARROWS = 115 ;
const int BLOCK_CODE_YIJING_HEXAGRAM_SYMBOLS = 116 ;
const int BLOCK_CODE_LINEAR_B_SYLLABARY = 117 ;
const int BLOCK_CODE_LINEAR_B_IDEOGRAMS = 118 ;
const int BLOCK_CODE_AEGEAN_NUMBERS = 119 ;
const int BLOCK_CODE_UGARITIC = 120 ;
const int BLOCK_CODE_SHAVIAN = 121 ;
const int BLOCK_CODE_OSMANYA = 122 ;
const int BLOCK_CODE_CYPRIOT_SYLLABARY = 123 ;
const int BLOCK_CODE_TAI_XUAN_JING_SYMBOLS = 124 ;
const int BLOCK_CODE_VARIATION_SELECTORS_SUPPLEMENT = 125 ;
const int BLOCK_CODE_ANCIENT_GREEK_MUSICAL_NOTATION = 126 ;
const int BLOCK_CODE_ANCIENT_GREEK_NUMBERS = 127 ;
const int BLOCK_CODE_ARABIC_SUPPLEMENT = 128 ;
const int BLOCK_CODE_BUGINESE = 129 ;
const int BLOCK_CODE_CJK_STROKES = 130 ;
const int BLOCK_CODE_COMBINING_DIACRITICAL_MARKS_SUPPLEMENT = 131 ;
const int BLOCK_CODE_COPTIC = 132 ;
const int BLOCK_CODE_ETHIOPIC_EXTENDED = 133 ;
const int BLOCK_CODE_ETHIOPIC_SUPPLEMENT = 134 ;
const int BLOCK_CODE_GEORGIAN_SUPPLEMENT = 135 ;
const int BLOCK_CODE_GLAGOLITIC = 136 ;
const int BLOCK_CODE_KHAROSHTHI = 137 ;
const int BLOCK_CODE_MODIFIER_TONE_LETTERS = 138 ;
const int BLOCK_CODE_NEW_TAI_LUE = 139 ;
const int BLOCK_CODE_OLD_PERSIAN = 140 ;
const int BLOCK_CODE_PHONETIC_EXTENSIONS_SUPPLEMENT = 141 ;
const int BLOCK_CODE_SUPPLEMENTAL_PUNCTUATION = 142 ;
const int BLOCK_CODE_SYLOTI_NAGRI = 143 ;
const int BLOCK_CODE_TIFINAGH = 144 ;
const int BLOCK_CODE_VERTICAL_FORMS = 145 ;
const int BLOCK_CODE_NKO = 146 ;
const int BLOCK_CODE_BALINESE = 147 ;
const int BLOCK_CODE_LATIN_EXTENDED_C = 148 ;
const int BLOCK_CODE_LATIN_EXTENDED_D = 149 ;
const int BLOCK_CODE_PHAGS_PA = 150 ;
const int BLOCK_CODE_PHOENICIAN = 151 ;
const int BLOCK_CODE_CUNEIFORM = 152 ;
const int BLOCK_CODE_CUNEIFORM_NUMBERS_AND_PUNCTUATION = 153 ;
const int BLOCK_CODE_COUNTING_ROD_NUMERALS = 154 ;
const int BLOCK_CODE_SUNDANESE = 155 ;
const int BLOCK_CODE_LEPCHA = 156 ;
const int BLOCK_CODE_OL_CHIKI = 157 ;
const int BLOCK_CODE_CYRILLIC_EXTENDED_A = 158 ;
const int BLOCK_CODE_VAI = 159 ;
const int BLOCK_CODE_CYRILLIC_EXTENDED_B = 160 ;
const int BLOCK_CODE_SAURASHTRA = 161 ;
const int BLOCK_CODE_KAYAH_LI = 162 ;
const int BLOCK_CODE_REJANG = 163 ;
const int BLOCK_CODE_CHAM = 164 ;
const int BLOCK_CODE_ANCIENT_SYMBOLS = 165 ;
const int BLOCK_CODE_PHAISTOS_DISC = 166 ;
const int BLOCK_CODE_LYCIAN = 167 ;
const int BLOCK_CODE_CARIAN = 168 ;
const int BLOCK_CODE_LYDIAN = 169 ;
const int BLOCK_CODE_MAHJONG_TILES = 170 ;
const int BLOCK_CODE_DOMINO_TILES = 171 ;
const int BLOCK_CODE_SAMARITAN = 172 ;
const int BLOCK_CODE_UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED = 173 ;
const int BLOCK_CODE_TAI_THAM = 174 ;
const int BLOCK_CODE_VEDIC_EXTENSIONS = 175 ;
const int BLOCK_CODE_LISU = 176 ;
const int BLOCK_CODE_BAMUM = 177 ;
const int BLOCK_CODE_COMMON_INDIC_NUMBER_FORMS = 178 ;
const int BLOCK_CODE_DEVANAGARI_EXTENDED = 179 ;
const int BLOCK_CODE_HANGUL_JAMO_EXTENDED_A = 180 ;
const int BLOCK_CODE_JAVANESE = 181 ;
const int BLOCK_CODE_MYANMAR_EXTENDED_A = 182 ;
const int BLOCK_CODE_TAI_VIET = 183 ;
const int BLOCK_CODE_MEETEI_MAYEK = 184 ;
const int BLOCK_CODE_HANGUL_JAMO_EXTENDED_B = 185 ;
const int BLOCK_CODE_IMPERIAL_ARAMAIC = 186 ;
const int BLOCK_CODE_OLD_SOUTH_ARABIAN = 187 ;
const int BLOCK_CODE_AVESTAN = 188 ;
const int BLOCK_CODE_INSCRIPTIONAL_PARTHIAN = 189 ;
const int BLOCK_CODE_INSCRIPTIONAL_PAHLAVI = 190 ;
const int BLOCK_CODE_OLD_TURKIC = 191 ;
const int BLOCK_CODE_RUMI_NUMERAL_SYMBOLS = 192 ;
const int BLOCK_CODE_KAITHI = 193 ;
const int BLOCK_CODE_EGYPTIAN_HIEROGLYPHS = 194 ;
const int BLOCK_CODE_ENCLOSED_ALPHANUMERIC_SUPPLEMENT = 195 ;
const int BLOCK_CODE_ENCLOSED_IDEOGRAPHIC_SUPPLEMENT = 196 ;
const int BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C = 197 ;
const int BLOCK_CODE_MANDAIC = 198 ;
const int BLOCK_CODE_BATAK = 199 ;
const int BLOCK_CODE_ETHIOPIC_EXTENDED_A = 200 ;
const int BLOCK_CODE_BRAHMI = 201 ;
const int BLOCK_CODE_BAMUM_SUPPLEMENT = 202 ;
const int BLOCK_CODE_KANA_SUPPLEMENT = 203 ;
const int BLOCK_CODE_PLAYING_CARDS = 204 ;
const int BLOCK_CODE_MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS = 205 ;
const int BLOCK_CODE_EMOTICONS = 206 ;
const int BLOCK_CODE_TRANSPORT_AND_MAP_SYMBOLS = 207 ;
const int BLOCK_CODE_ALCHEMICAL_SYMBOLS = 208 ;
const int BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D = 209 ;
const int BLOCK_CODE_ARABIC_EXTENDED_A = 210 ;
const int BLOCK_CODE_ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS = 211 ;
const int BLOCK_CODE_CHAKMA = 212 ;
const int BLOCK_CODE_MEETEI_MAYEK_EXTENSIONS = 213 ;
const int BLOCK_CODE_MEROITIC_CURSIVE = 214 ;
const int BLOCK_CODE_MEROITIC_HIEROGLYPHS = 215 ;
const int BLOCK_CODE_MIAO = 216 ;
const int BLOCK_CODE_SHARADA = 217 ;
const int BLOCK_CODE_SORA_SOMPENG = 218 ;
const int BLOCK_CODE_SUNDANESE_SUPPLEMENT = 219 ;
const int BLOCK_CODE_TAKRI = 220 ;
const int BLOCK_CODE_COUNT = 221 ;
const int BLOCK_CODE_INVALID_CODE = -1 ;
const int BPT_NONE = 0 ;
const int BPT_OPEN = 1 ;
const int BPT_CLOSE = 2 ;
const int BPT_COUNT = 3 ;
const int EA_NEUTRAL = 0 ;
const int EA_AMBIGUOUS = 1 ;
const int EA_HALFWIDTH = 2 ;
const int EA_FULLWIDTH = 3 ;
const int EA_NARROW = 4 ;
const int EA_WIDE = 5 ;
const int EA_COUNT = 6 ;
const int UNICODE_CHAR_NAME = 0 ;
const int UNICODE_10_CHAR_NAME = 1 ;
const int EXTENDED_CHAR_NAME = 2 ;
const int CHAR_NAME_ALIAS = 3 ;
const int CHAR_NAME_CHOICE_COUNT = 4 ;
const int SHORT_PROPERTY_NAME = 0 ;
const int LONG_PROPERTY_NAME = 1 ;
const int PROPERTY_NAME_CHOICE_COUNT = 2 ;
const int DT_NONE = 0 ;
const int DT_CANONICAL = 1 ;
const int DT_COMPAT = 2 ;
const int DT_CIRCLE = 3 ;
const int DT_FINAL = 4 ;
const int DT_FONT = 5 ;
const int DT_FRACTION = 6 ;
const int DT_INITIAL = 7 ;
const int DT_ISOLATED = 8 ;
const int DT_MEDIAL = 9 ;
const int DT_NARROW = 10 ;
const int DT_NOBREAK = 11 ;
const int DT_SMALL = 12 ;
const int DT_SQUARE = 13 ;
const int DT_SUB = 14 ;
const int DT_SUPER = 15 ;
const int DT_VERTICAL = 16 ;
const int DT_WIDE = 17 ;
const int DT_COUNT = 18 ;
const int JT_NON_JOINING = 0 ;
const int JT_JOIN_CAUSING = 1 ;
const int JT_DUAL_JOINING = 2 ;
const int JT_LEFT_JOINING = 3 ;
const int JT_RIGHT_JOINING = 4 ;
const int JT_TRANSPARENT = 5 ;
const int JT_COUNT = 6 ;
const int JG_NO_JOINING_GROUP = 0 ;
const int JG_AIN = 1 ;
const int JG_ALAPH = 2 ;
const int JG_ALEF = 3 ;
const int JG_BEH = 4 ;
const int JG_BETH = 5 ;
const int JG_DAL = 6 ;
const int JG_DALATH_RISH = 7 ;
const int JG_E = 8 ;
const int JG_FEH = 9 ;
const int JG_FINAL_SEMKATH = 10 ;
const int JG_GAF = 11 ;
const int JG_GAMAL = 12 ;
const int JG_HAH = 13 ;
const int JG_TEH_MARBUTA_GOAL = 14 ;
const int JG_HAMZA_ON_HEH_GOAL = 14 ;
const int JG_HE = 15 ;
const int JG_HEH = 16 ;
const int JG_HEH_GOAL = 17 ;
const int JG_HETH = 18 ;
const int JG_KAF = 19 ;
const int JG_KAPH = 20 ;
const int JG_KNOTTED_HEH = 21 ;
const int JG_LAM = 22 ;
const int JG_LAMADH = 23 ;
const int JG_MEEM = 24 ;
const int JG_MIM = 25 ;
const int JG_NOON = 26 ;
const int JG_NUN = 27 ;
const int JG_PE = 28 ;
const int JG_QAF = 29 ;
const int JG_QAPH = 30 ;
const int JG_REH = 31 ;
const int JG_REVERSED_PE = 32 ;
const int JG_SAD = 33 ;
const int JG_SADHE = 34 ;
const int JG_SEEN = 35 ;
const int JG_SEMKATH = 36 ;
const int JG_SHIN = 37 ;
const int JG_SWASH_KAF = 38 ;
const int JG_SYRIAC_WAW = 39 ;
const int JG_TAH = 40 ;
const int JG_TAW = 41 ;
const int JG_TEH_MARBUTA = 42 ;
const int JG_TETH = 43 ;
const int JG_WAW = 44 ;
const int JG_YEH = 45 ;
const int JG_YEH_BARREE = 46 ;
const int JG_YEH_WITH_TAIL = 47 ;
const int JG_YUDH = 48 ;
const int JG_YUDH_HE = 49 ;
const int JG_ZAIN = 50 ;
const int JG_FE = 51 ;
const int JG_KHAPH = 52 ;
const int JG_ZHAIN = 53 ;
const int JG_BURUSHASKI_YEH_BARREE = 54 ;
const int JG_FARSI_YEH = 55 ;
const int JG_NYA = 56 ;
const int JG_ROHINGYA_YEH = 57 ;
const int JG_COUNT = 58 ;
const int GCB_OTHER = 0 ;
const int GCB_CONTROL = 1 ;
const int GCB_CR = 2 ;
const int GCB_EXTEND = 3 ;
const int GCB_L = 4 ;
const int GCB_LF = 5 ;
const int GCB_LV = 6 ;
const int GCB_LVT = 7 ;
const int GCB_T = 8 ;
const int GCB_V = 9 ;
const int GCB_SPACING_MARK = 10 ;
const int GCB_PREPEND = 11 ;
const int GCB_REGIONAL_INDICATOR = 12 ;
const int GCB_COUNT = 13 ;
const int WB_OTHER = 0 ;
const int WB_ALETTER = 1 ;
const int WB_FORMAT = 2 ;
const int WB_KATAKANA = 3 ;
const int WB_MIDLETTER = 4 ;
const int WB_MIDNUM = 5 ;
const int WB_NUMERIC = 6 ;
const int WB_EXTENDNUMLET = 7 ;
const int WB_CR = 8 ;
const int WB_EXTEND = 9 ;
const int WB_LF = 10 ;
const int WB_MIDNUMLET = 11 ;
const int WB_NEWLINE = 12 ;
const int WB_REGIONAL_INDICATOR = 13 ;
const int WB_HEBREW_LETTER = 14 ;
const int WB_SINGLE_QUOTE = 15 ;
const int WB_DOUBLE_QUOTE = 16 ;
const int WB_COUNT = 17 ;
const int SB_OTHER = 0 ;
const int SB_ATERM = 1 ;
const int SB_CLOSE = 2 ;
const int SB_FORMAT = 3 ;
const int SB_LOWER = 4 ;
const int SB_NUMERIC = 5 ;
const int SB_OLETTER = 6 ;
const int SB_SEP = 7 ;
const int SB_SP = 8 ;
const int SB_STERM = 9 ;
const int SB_UPPER = 10 ;
const int SB_CR = 11 ;
const int SB_EXTEND = 12 ;
const int SB_LF = 13 ;
const int SB_SCONTINUE = 14 ;
const int SB_COUNT = 15 ;
const int LB_UNKNOWN = 0 ;
const int LB_AMBIGUOUS = 1 ;
const int LB_ALPHABETIC = 2 ;
const int LB_BREAK_BOTH = 3 ;
const int LB_BREAK_AFTER = 4 ;
const int LB_BREAK_BEFORE = 5 ;
const int LB_MANDATORY_BREAK = 6 ;
const int LB_CONTINGENT_BREAK = 7 ;
const int LB_CLOSE_PUNCTUATION = 8 ;
const int LB_COMBINING_MARK = 9 ;
const int LB_CARRIAGE_RETURN = 10 ;
const int LB_EXCLAMATION = 11 ;
const int LB_GLUE = 12 ;
const int LB_HYPHEN = 13 ;
const int LB_IDEOGRAPHIC = 14 ;
const int LB_INSEPARABLE = 15 ;
const int LB_INSEPERABLE = 15 ;
const int LB_INFIX_NUMERIC = 16 ;
const int LB_LINE_FEED = 17 ;
const int LB_NONSTARTER = 18 ;
const int LB_NUMERIC = 19 ;
const int LB_OPEN_PUNCTUATION = 20 ;
const int LB_POSTFIX_NUMERIC = 21 ;
const int LB_PREFIX_NUMERIC = 22 ;
const int LB_QUOTATION = 23 ;
const int LB_COMPLEX_CONTEXT = 24 ;
const int LB_SURROGATE = 25 ;
const int LB_SPACE = 26 ;
const int LB_BREAK_SYMBOLS = 27 ;
const int LB_ZWSPACE = 28 ;
const int LB_NEXT_LINE = 29 ;
const int LB_WORD_JOINER = 30 ;
const int LB_H2 = 31 ;
const int LB_H3 = 32 ;
const int LB_JL = 33 ;
const int LB_JT = 34 ;
const int LB_JV = 35 ;
const int LB_CLOSE_PARENTHESIS = 36 ;
const int LB_CONDITIONAL_JAPANESE_STARTER = 37 ;
const int LB_HEBREW_LETTER = 38 ;
const int LB_REGIONAL_INDICATOR = 39 ;
const int LB_COUNT = 40 ;
const int NT_NONE = 0 ;
const int NT_DECIMAL = 1 ;
const int NT_DIGIT = 2 ;
const int NT_NUMERIC = 3 ;
const int NT_COUNT = 4 ;
const int HST_NOT_APPLICABLE = 0 ;
const int HST_LEADING_JAMO = 1 ;
const int HST_VOWEL_JAMO = 2 ;
const int HST_TRAILING_JAMO = 3 ;
const int HST_LV_SYLLABLE = 4 ;
const int HST_LVT_SYLLABLE = 5 ;
const int HST_COUNT = 6 ;
/* 方法 */
public static charAge ( mixed $codepoint ) : array
public static charDigitValue ( mixed $codepoint ) : int
public static charDirection ( mixed $codepoint ) : int
public static charFromName ( string $characterName , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : int
public static charMirror ( mixed $codepoint ) : mixed
public static charName ( mixed $codepoint , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : string
public static charType ( mixed $codepoint ) : int
public static chr ( mixed $codepoint ) : string
public static digit ( string $codepoint , int $radix = 10 ) : int
public static enumCharNames ( mixed $start , mixed $limit , callable $callback , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : void
public static enumCharTypes ( callable $callback ) : void
public static foldCase ( mixed $codepoint , int $options = IntlChar::FOLD_CASE_DEFAULT ) : mixed
public static forDigit ( int $digit , int $radix = 10 ) : int
public static getBidiPairedBracket ( mixed $codepoint ) : mixed
public static getBlockCode ( mixed $codepoint ) : int
public static getCombiningClass ( mixed $codepoint ) : int
public static getFC_NFKC_Closure ( mixed $codepoint ) : string
public static getIntPropertyMaxValue ( int $property ) : int
public static getIntPropertyMinValue ( int $property ) : int
public static getIntPropertyValue ( mixed $codepoint , int $property ) : int
public static getNumericValue ( mixed $codepoint ) : float
public static getPropertyEnum ( string $alias ) : int
public static getPropertyName ( int $property , int $nameChoice = IntlChar::LONG_PROPERTY_NAME ) : string
public static getPropertyValueEnum ( int $property , string $name ) : int
public static getPropertyValueName ( int $property , int $value , int $nameChoice = IntlChar::LONG_PROPERTY_NAME ) : string
public static getUnicodeVersion ( ) : array
public static hasBinaryProperty ( mixed $codepoint , int $property ) : bool
public static isalnum ( mixed $codepoint ) : bool
public static isalpha ( mixed $codepoint ) : bool
public static isbase ( mixed $codepoint ) : bool
public static isblank ( mixed $codepoint ) : bool
public static iscntrl ( mixed $codepoint ) : bool
public static isdefined ( mixed $codepoint ) : bool
public static isdigit ( mixed $codepoint ) : bool
public static isgraph ( mixed $codepoint ) : bool
public static isIDIgnorable ( mixed $codepoint ) : bool
public static isIDPart ( mixed $codepoint ) : bool
public static isIDStart ( mixed $codepoint ) : bool
public static isISOControl ( mixed $codepoint ) : bool
public static isJavaIDPart ( mixed $codepoint ) : bool
public static isJavaIDStart ( mixed $codepoint ) : bool
public static isJavaSpaceChar ( mixed $codepoint ) : bool
public static islower ( mixed $codepoint ) : bool
public static isMirrored ( mixed $codepoint ) : bool
public static isprint ( mixed $codepoint ) : bool
public static ispunct ( mixed $codepoint ) : bool
public static isspace ( mixed $codepoint ) : bool
public static istitle ( mixed $codepoint ) : bool
public static isUAlphabetic ( mixed $codepoint ) : bool
public static isULowercase ( mixed $codepoint ) : bool
public static isupper ( mixed $codepoint ) : bool
public static isUUppercase ( mixed $codepoint ) : bool
public static isUWhiteSpace ( mixed $codepoint ) : bool
public static isWhitespace ( mixed $codepoint ) : bool
public static isxdigit ( mixed $codepoint ) : bool
public static ord ( mixed $character ) : int
public static tolower ( mixed $codepoint ) : mixed
public static totitle ( mixed $codepoint ) : mixed
public static toupper ( mixed $codepoint ) : mixed
}

预定义常量

IntlChar::UNICODE_VERSION

IntlChar::CODEPOINT_MIN

IntlChar::CODEPOINT_MAX

IntlChar::NO_NUMERIC_VALUE

Special value that is returned by IntlChar::getNumericValue() when no numeric value is defined for a code point.

IntlChar::PROPERTY_ALPHABETIC

IntlChar::PROPERTY_BINARY_START

IntlChar::PROPERTY_ASCII_HEX_DIGIT

IntlChar::PROPERTY_BIDI_CONTROL

IntlChar::PROPERTY_BIDI_MIRRORED

IntlChar::PROPERTY_DASH

IntlChar::PROPERTY_DEFAULT_IGNORABLE_CODE_POINT

IntlChar::PROPERTY_DEPRECATED

IntlChar::PROPERTY_DIACRITIC

IntlChar::PROPERTY_EXTENDER

IntlChar::PROPERTY_FULL_COMPOSITION_EXCLUSION

IntlChar::PROPERTY_GRAPHEME_BASE

IntlChar::PROPERTY_GRAPHEME_EXTEND

IntlChar::PROPERTY_GRAPHEME_LINK

IntlChar::PROPERTY_HEX_DIGIT

IntlChar::PROPERTY_HYPHEN

IntlChar::PROPERTY_ID_CONTINUE

IntlChar::PROPERTY_ID_START

IntlChar::PROPERTY_IDEOGRAPHIC

IntlChar::PROPERTY_IDS_BINARY_OPERATOR

IntlChar::PROPERTY_IDS_TRINARY_OPERATOR

IntlChar::PROPERTY_JOIN_CONTROL

IntlChar::PROPERTY_LOGICAL_ORDER_EXCEPTION

IntlChar::PROPERTY_LOWERCASE

IntlChar::PROPERTY_MATH

IntlChar::PROPERTY_NONCHARACTER_CODE_POINT

IntlChar::PROPERTY_QUOTATION_MARK

IntlChar::PROPERTY_RADICAL

IntlChar::PROPERTY_SOFT_DOTTED

IntlChar::PROPERTY_TERMINAL_PUNCTUATION

IntlChar::PROPERTY_UNIFIED_IDEOGRAPH

IntlChar::PROPERTY_UPPERCASE

IntlChar::PROPERTY_WHITE_SPACE

IntlChar::PROPERTY_XID_CONTINUE

IntlChar::PROPERTY_XID_START

IntlChar::PROPERTY_CASE_SENSITIVE

IntlChar::PROPERTY_S_TERM

IntlChar::PROPERTY_VARIATION_SELECTOR

IntlChar::PROPERTY_NFD_INERT

IntlChar::PROPERTY_NFKD_INERT

IntlChar::PROPERTY_NFC_INERT

IntlChar::PROPERTY_NFKC_INERT

IntlChar::PROPERTY_SEGMENT_STARTER

IntlChar::PROPERTY_PATTERN_SYNTAX

IntlChar::PROPERTY_PATTERN_WHITE_SPACE

IntlChar::PROPERTY_POSIX_ALNUM

IntlChar::PROPERTY_POSIX_BLANK

IntlChar::PROPERTY_POSIX_GRAPH

IntlChar::PROPERTY_POSIX_PRINT

IntlChar::PROPERTY_POSIX_XDIGIT

IntlChar::PROPERTY_CASED

IntlChar::PROPERTY_CASE_IGNORABLE

IntlChar::PROPERTY_CHANGES_WHEN_LOWERCASED

IntlChar::PROPERTY_CHANGES_WHEN_UPPERCASED

IntlChar::PROPERTY_CHANGES_WHEN_TITLECASED

IntlChar::PROPERTY_CHANGES_WHEN_CASEFOLDED

IntlChar::PROPERTY_CHANGES_WHEN_CASEMAPPED

IntlChar::PROPERTY_CHANGES_WHEN_NFKC_CASEFOLDED

IntlChar::PROPERTY_BINARY_LIMIT

IntlChar::PROPERTY_BIDI_CLASS

IntlChar::PROPERTY_INT_START

IntlChar::PROPERTY_BLOCK

IntlChar::PROPERTY_CANONICAL_COMBINING_CLASS

IntlChar::PROPERTY_DECOMPOSITION_TYPE

IntlChar::PROPERTY_EAST_ASIAN_WIDTH

IntlChar::PROPERTY_GENERAL_CATEGORY

IntlChar::PROPERTY_JOINING_GROUP

IntlChar::PROPERTY_JOINING_TYPE

IntlChar::PROPERTY_LINE_BREAK

IntlChar::PROPERTY_NUMERIC_TYPE

IntlChar::PROPERTY_SCRIPT

IntlChar::PROPERTY_HANGUL_SYLLABLE_TYPE

IntlChar::PROPERTY_NFD_QUICK_CHECK

IntlChar::PROPERTY_NFKD_QUICK_CHECK

IntlChar::PROPERTY_NFC_QUICK_CHECK

IntlChar::PROPERTY_NFKC_QUICK_CHECK

IntlChar::PROPERTY_LEAD_CANONICAL_COMBINING_CLASS

IntlChar::PROPERTY_TRAIL_CANONICAL_COMBINING_CLASS

IntlChar::PROPERTY_GRAPHEME_CLUSTER_BREAK

IntlChar::PROPERTY_SENTENCE_BREAK

IntlChar::PROPERTY_WORD_BREAK

IntlChar::PROPERTY_BIDI_PAIRED_BRACKET_TYPE

IntlChar::PROPERTY_INT_LIMIT

IntlChar::PROPERTY_GENERAL_CATEGORY_MASK

IntlChar::PROPERTY_MASK_START

IntlChar::PROPERTY_MASK_LIMIT

IntlChar::PROPERTY_NUMERIC_VALUE

IntlChar::PROPERTY_DOUBLE_START

IntlChar::PROPERTY_DOUBLE_LIMIT

IntlChar::PROPERTY_AGE

IntlChar::PROPERTY_STRING_START

IntlChar::PROPERTY_BIDI_MIRRORING_GLYPH

IntlChar::PROPERTY_CASE_FOLDING

IntlChar::PROPERTY_ISO_COMMENT

IntlChar::PROPERTY_LOWERCASE_MAPPING

IntlChar::PROPERTY_NAME

IntlChar::PROPERTY_SIMPLE_CASE_FOLDING

IntlChar::PROPERTY_SIMPLE_LOWERCASE_MAPPING

IntlChar::PROPERTY_SIMPLE_TITLECASE_MAPPING

IntlChar::PROPERTY_SIMPLE_UPPERCASE_MAPPING

IntlChar::PROPERTY_TITLECASE_MAPPING

IntlChar::PROPERTY_UNICODE_1_NAME

IntlChar::PROPERTY_UPPERCASE_MAPPING

IntlChar::PROPERTY_BIDI_PAIRED_BRACKET

IntlChar::PROPERTY_STRING_LIMIT

IntlChar::PROPERTY_SCRIPT_EXTENSIONS

IntlChar::PROPERTY_OTHER_PROPERTY_START

IntlChar::PROPERTY_OTHER_PROPERTY_LIMIT

IntlChar::PROPERTY_INVALID_CODE

IntlChar::CHAR_CATEGORY_UNASSIGNED

IntlChar::CHAR_CATEGORY_GENERAL_OTHER_TYPES

IntlChar::CHAR_CATEGORY_UPPERCASE_LETTER

IntlChar::CHAR_CATEGORY_LOWERCASE_LETTER

IntlChar::CHAR_CATEGORY_TITLECASE_LETTER

IntlChar::CHAR_CATEGORY_MODIFIER_LETTER

IntlChar::CHAR_CATEGORY_OTHER_LETTER

IntlChar::CHAR_CATEGORY_NON_SPACING_MARK

IntlChar::CHAR_CATEGORY_ENCLOSING_MARK

IntlChar::CHAR_CATEGORY_COMBINING_SPACING_MARK

IntlChar::CHAR_CATEGORY_DECIMAL_DIGIT_NUMBER

IntlChar::CHAR_CATEGORY_LETTER_NUMBER

IntlChar::CHAR_CATEGORY_OTHER_NUMBER

IntlChar::CHAR_CATEGORY_SPACE_SEPARATOR

IntlChar::CHAR_CATEGORY_LINE_SEPARATOR

IntlChar::CHAR_CATEGORY_PARAGRAPH_SEPARATOR

IntlChar::CHAR_CATEGORY_CONTROL_CHAR

IntlChar::CHAR_CATEGORY_FORMAT_CHAR

IntlChar::CHAR_CATEGORY_PRIVATE_USE_CHAR

IntlChar::CHAR_CATEGORY_SURROGATE

IntlChar::CHAR_CATEGORY_DASH_PUNCTUATION

IntlChar::CHAR_CATEGORY_START_PUNCTUATION

IntlChar::CHAR_CATEGORY_END_PUNCTUATION

IntlChar::CHAR_CATEGORY_CONNECTOR_PUNCTUATION

IntlChar::CHAR_CATEGORY_OTHER_PUNCTUATION

IntlChar::CHAR_CATEGORY_MATH_SYMBOL

IntlChar::CHAR_CATEGORY_CURRENCY_SYMBOL

IntlChar::CHAR_CATEGORY_MODIFIER_SYMBOL

IntlChar::CHAR_CATEGORY_OTHER_SYMBOL

IntlChar::CHAR_CATEGORY_INITIAL_PUNCTUATION

IntlChar::CHAR_CATEGORY_FINAL_PUNCTUATION

IntlChar::CHAR_CATEGORY_CHAR_CATEGORY_COUNT

IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT

IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER

IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_SEPARATOR

IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_TERMINATOR

IntlChar::CHAR_DIRECTION_ARABIC_NUMBER

IntlChar::CHAR_DIRECTION_COMMON_NUMBER_SEPARATOR

IntlChar::CHAR_DIRECTION_BLOCK_SEPARATOR

IntlChar::CHAR_DIRECTION_SEGMENT_SEPARATOR

IntlChar::CHAR_DIRECTION_WHITE_SPACE_NEUTRAL

IntlChar::CHAR_DIRECTION_OTHER_NEUTRAL

IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_EMBEDDING

IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_OVERRIDE

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_ARABIC

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_EMBEDDING

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_OVERRIDE

IntlChar::CHAR_DIRECTION_POP_DIRECTIONAL_FORMAT

IntlChar::CHAR_DIRECTION_DIR_NON_SPACING_MARK

IntlChar::CHAR_DIRECTION_BOUNDARY_NEUTRAL

IntlChar::CHAR_DIRECTION_FIRST_STRONG_ISOLATE

IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_ISOLATE

IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_ISOLATE

IntlChar::CHAR_DIRECTION_POP_DIRECTIONAL_ISOLATE

IntlChar::CHAR_DIRECTION_CHAR_DIRECTION_COUNT

IntlChar::BLOCK_CODE_NO_BLOCK

IntlChar::BLOCK_CODE_BASIC_LATIN

IntlChar::BLOCK_CODE_LATIN_1_SUPPLEMENT

IntlChar::BLOCK_CODE_LATIN_EXTENDED_A

IntlChar::BLOCK_CODE_LATIN_EXTENDED_B

IntlChar::BLOCK_CODE_IPA_EXTENSIONS

IntlChar::BLOCK_CODE_SPACING_MODIFIER_LETTERS

IntlChar::BLOCK_CODE_COMBINING_DIACRITICAL_MARKS

IntlChar::BLOCK_CODE_GREEK

IntlChar::BLOCK_CODE_CYRILLIC

IntlChar::BLOCK_CODE_ARMENIAN

IntlChar::BLOCK_CODE_HEBREW

IntlChar::BLOCK_CODE_ARABIC

IntlChar::BLOCK_CODE_SYRIAC

IntlChar::BLOCK_CODE_THAANA

IntlChar::BLOCK_CODE_DEVANAGARI

IntlChar::BLOCK_CODE_BENGALI

IntlChar::BLOCK_CODE_GURMUKHI

IntlChar::BLOCK_CODE_GUJARATI

IntlChar::BLOCK_CODE_ORIYA

IntlChar::BLOCK_CODE_TAMIL

IntlChar::BLOCK_CODE_TELUGU

IntlChar::BLOCK_CODE_KANNADA

IntlChar::BLOCK_CODE_MALAYALAM

IntlChar::BLOCK_CODE_SINHALA

IntlChar::BLOCK_CODE_THAI

IntlChar::BLOCK_CODE_LAO

IntlChar::BLOCK_CODE_TIBETAN

IntlChar::BLOCK_CODE_MYANMAR

IntlChar::BLOCK_CODE_GEORGIAN

IntlChar::BLOCK_CODE_HANGUL_JAMO

IntlChar::BLOCK_CODE_ETHIOPIC

IntlChar::BLOCK_CODE_CHEROKEE

IntlChar::BLOCK_CODE_UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS

IntlChar::BLOCK_CODE_OGHAM

IntlChar::BLOCK_CODE_RUNIC

IntlChar::BLOCK_CODE_KHMER

IntlChar::BLOCK_CODE_MONGOLIAN

IntlChar::BLOCK_CODE_LATIN_EXTENDED_ADDITIONAL

IntlChar::BLOCK_CODE_GREEK_EXTENDED

IntlChar::BLOCK_CODE_GENERAL_PUNCTUATION

IntlChar::BLOCK_CODE_SUPERSCRIPTS_AND_SUBSCRIPTS

IntlChar::BLOCK_CODE_CURRENCY_SYMBOLS

IntlChar::BLOCK_CODE_COMBINING_MARKS_FOR_SYMBOLS

IntlChar::BLOCK_CODE_LETTERLIKE_SYMBOLS

IntlChar::BLOCK_CODE_NUMBER_FORMS

IntlChar::BLOCK_CODE_ARROWS

IntlChar::BLOCK_CODE_MATHEMATICAL_OPERATORS

IntlChar::BLOCK_CODE_MISCELLANEOUS_TECHNICAL

IntlChar::BLOCK_CODE_CONTROL_PICTURES

IntlChar::BLOCK_CODE_OPTICAL_CHARACTER_RECOGNITION

IntlChar::BLOCK_CODE_ENCLOSED_ALPHANUMERICS

IntlChar::BLOCK_CODE_BOX_DRAWING

IntlChar::BLOCK_CODE_BLOCK_ELEMENTS

IntlChar::BLOCK_CODE_GEOMETRIC_SHAPES

IntlChar::BLOCK_CODE_MISCELLANEOUS_SYMBOLS

IntlChar::BLOCK_CODE_DINGBATS

IntlChar::BLOCK_CODE_BRAILLE_PATTERNS

IntlChar::BLOCK_CODE_CJK_RADICALS_SUPPLEMENT

IntlChar::BLOCK_CODE_KANGXI_RADICALS

IntlChar::BLOCK_CODE_IDEOGRAPHIC_DESCRIPTION_CHARACTERS

IntlChar::BLOCK_CODE_CJK_SYMBOLS_AND_PUNCTUATION

IntlChar::BLOCK_CODE_HIRAGANA

IntlChar::BLOCK_CODE_KATAKANA

IntlChar::BLOCK_CODE_BOPOMOFO

IntlChar::BLOCK_CODE_HANGUL_COMPATIBILITY_JAMO

IntlChar::BLOCK_CODE_KANBUN

IntlChar::BLOCK_CODE_BOPOMOFO_EXTENDED

IntlChar::BLOCK_CODE_ENCLOSED_CJK_LETTERS_AND_MONTHS

IntlChar::BLOCK_CODE_CJK_COMPATIBILITY

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS

IntlChar::BLOCK_CODE_YI_SYLLABLES

IntlChar::BLOCK_CODE_YI_RADICALS

IntlChar::BLOCK_CODE_HANGUL_SYLLABLES

IntlChar::BLOCK_CODE_HIGH_SURROGATES

IntlChar::BLOCK_CODE_HIGH_PRIVATE_USE_SURROGATES

IntlChar::BLOCK_CODE_LOW_SURROGATES

IntlChar::BLOCK_CODE_PRIVATE_USE_AREA

IntlChar::BLOCK_CODE_PRIVATE_USE

IntlChar::BLOCK_CODE_CJK_COMPATIBILITY_IDEOGRAPHS

IntlChar::BLOCK_CODE_ALPHABETIC_PRESENTATION_FORMS

IntlChar::BLOCK_CODE_ARABIC_PRESENTATION_FORMS_A

IntlChar::BLOCK_CODE_COMBINING_HALF_MARKS

IntlChar::BLOCK_CODE_CJK_COMPATIBILITY_FORMS

IntlChar::BLOCK_CODE_SMALL_FORM_VARIANTS

IntlChar::BLOCK_CODE_ARABIC_PRESENTATION_FORMS_B

IntlChar::BLOCK_CODE_SPECIALS

IntlChar::BLOCK_CODE_HALFWIDTH_AND_FULLWIDTH_FORMS

IntlChar::BLOCK_CODE_OLD_ITALIC

IntlChar::BLOCK_CODE_GOTHIC

IntlChar::BLOCK_CODE_DESERET

IntlChar::BLOCK_CODE_BYZANTINE_MUSICAL_SYMBOLS

IntlChar::BLOCK_CODE_MUSICAL_SYMBOLS

IntlChar::BLOCK_CODE_MATHEMATICAL_ALPHANUMERIC_SYMBOLS

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B

IntlChar::BLOCK_CODE_CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT

IntlChar::BLOCK_CODE_TAGS

IntlChar::BLOCK_CODE_CYRILLIC_SUPPLEMENT

IntlChar::BLOCK_CODE_CYRILLIC_SUPPLEMENTARY

IntlChar::BLOCK_CODE_TAGALOG

IntlChar::BLOCK_CODE_HANUNOO

IntlChar::BLOCK_CODE_BUHID

IntlChar::BLOCK_CODE_TAGBANWA

IntlChar::BLOCK_CODE_MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A

IntlChar::BLOCK_CODE_SUPPLEMENTAL_ARROWS_A

IntlChar::BLOCK_CODE_SUPPLEMENTAL_ARROWS_B

IntlChar::BLOCK_CODE_MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B

IntlChar::BLOCK_CODE_SUPPLEMENTAL_MATHEMATICAL_OPERATORS

IntlChar::BLOCK_CODE_KATAKANA_PHONETIC_EXTENSIONS

IntlChar::BLOCK_CODE_VARIATION_SELECTORS

IntlChar::BLOCK_CODE_SUPPLEMENTARY_PRIVATE_USE_AREA_A

IntlChar::BLOCK_CODE_SUPPLEMENTARY_PRIVATE_USE_AREA_B

IntlChar::BLOCK_CODE_LIMBU

IntlChar::BLOCK_CODE_TAI_LE

IntlChar::BLOCK_CODE_KHMER_SYMBOLS

IntlChar::BLOCK_CODE_PHONETIC_EXTENSIONS

IntlChar::BLOCK_CODE_MISCELLANEOUS_SYMBOLS_AND_ARROWS

IntlChar::BLOCK_CODE_YIJING_HEXAGRAM_SYMBOLS

IntlChar::BLOCK_CODE_LINEAR_B_SYLLABARY

IntlChar::BLOCK_CODE_LINEAR_B_IDEOGRAMS

IntlChar::BLOCK_CODE_AEGEAN_NUMBERS

IntlChar::BLOCK_CODE_UGARITIC

IntlChar::BLOCK_CODE_SHAVIAN

IntlChar::BLOCK_CODE_OSMANYA

IntlChar::BLOCK_CODE_CYPRIOT_SYLLABARY

IntlChar::BLOCK_CODE_TAI_XUAN_JING_SYMBOLS

IntlChar::BLOCK_CODE_VARIATION_SELECTORS_SUPPLEMENT

IntlChar::BLOCK_CODE_ANCIENT_GREEK_MUSICAL_NOTATION

IntlChar::BLOCK_CODE_ANCIENT_GREEK_NUMBERS

IntlChar::BLOCK_CODE_ARABIC_SUPPLEMENT

IntlChar::BLOCK_CODE_BUGINESE

IntlChar::BLOCK_CODE_CJK_STROKES

IntlChar::BLOCK_CODE_COMBINING_DIACRITICAL_MARKS_SUPPLEMENT

IntlChar::BLOCK_CODE_COPTIC

IntlChar::BLOCK_CODE_ETHIOPIC_EXTENDED

IntlChar::BLOCK_CODE_ETHIOPIC_SUPPLEMENT

IntlChar::BLOCK_CODE_GEORGIAN_SUPPLEMENT

IntlChar::BLOCK_CODE_GLAGOLITIC

IntlChar::BLOCK_CODE_KHAROSHTHI

IntlChar::BLOCK_CODE_MODIFIER_TONE_LETTERS

IntlChar::BLOCK_CODE_NEW_TAI_LUE

IntlChar::BLOCK_CODE_OLD_PERSIAN

IntlChar::BLOCK_CODE_PHONETIC_EXTENSIONS_SUPPLEMENT

IntlChar::BLOCK_CODE_SUPPLEMENTAL_PUNCTUATION

IntlChar::BLOCK_CODE_SYLOTI_NAGRI

IntlChar::BLOCK_CODE_TIFINAGH

IntlChar::BLOCK_CODE_VERTICAL_FORMS

IntlChar::BLOCK_CODE_NKO

IntlChar::BLOCK_CODE_BALINESE

IntlChar::BLOCK_CODE_LATIN_EXTENDED_C

IntlChar::BLOCK_CODE_LATIN_EXTENDED_D

IntlChar::BLOCK_CODE_PHAGS_PA

IntlChar::BLOCK_CODE_PHOENICIAN

IntlChar::BLOCK_CODE_CUNEIFORM

IntlChar::BLOCK_CODE_CUNEIFORM_NUMBERS_AND_PUNCTUATION

IntlChar::BLOCK_CODE_COUNTING_ROD_NUMERALS

IntlChar::BLOCK_CODE_SUNDANESE

IntlChar::BLOCK_CODE_LEPCHA

IntlChar::BLOCK_CODE_OL_CHIKI

IntlChar::BLOCK_CODE_CYRILLIC_EXTENDED_A

IntlChar::BLOCK_CODE_VAI

IntlChar::BLOCK_CODE_CYRILLIC_EXTENDED_B

IntlChar::BLOCK_CODE_SAURASHTRA

IntlChar::BLOCK_CODE_KAYAH_LI

IntlChar::BLOCK_CODE_REJANG

IntlChar::BLOCK_CODE_CHAM

IntlChar::BLOCK_CODE_ANCIENT_SYMBOLS

IntlChar::BLOCK_CODE_PHAISTOS_DISC

IntlChar::BLOCK_CODE_LYCIAN

IntlChar::BLOCK_CODE_CARIAN

IntlChar::BLOCK_CODE_LYDIAN

IntlChar::BLOCK_CODE_MAHJONG_TILES

IntlChar::BLOCK_CODE_DOMINO_TILES

IntlChar::BLOCK_CODE_SAMARITAN

IntlChar::BLOCK_CODE_UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED

IntlChar::BLOCK_CODE_TAI_THAM

IntlChar::BLOCK_CODE_VEDIC_EXTENSIONS

IntlChar::BLOCK_CODE_LISU

IntlChar::BLOCK_CODE_BAMUM

IntlChar::BLOCK_CODE_COMMON_INDIC_NUMBER_FORMS

IntlChar::BLOCK_CODE_DEVANAGARI_EXTENDED

IntlChar::BLOCK_CODE_HANGUL_JAMO_EXTENDED_A

IntlChar::BLOCK_CODE_JAVANESE

IntlChar::BLOCK_CODE_MYANMAR_EXTENDED_A

IntlChar::BLOCK_CODE_TAI_VIET

IntlChar::BLOCK_CODE_MEETEI_MAYEK

IntlChar::BLOCK_CODE_HANGUL_JAMO_EXTENDED_B

IntlChar::BLOCK_CODE_IMPERIAL_ARAMAIC

IntlChar::BLOCK_CODE_OLD_SOUTH_ARABIAN

IntlChar::BLOCK_CODE_AVESTAN

IntlChar::BLOCK_CODE_INSCRIPTIONAL_PARTHIAN

IntlChar::BLOCK_CODE_INSCRIPTIONAL_PAHLAVI

IntlChar::BLOCK_CODE_OLD_TURKIC

IntlChar::BLOCK_CODE_RUMI_NUMERAL_SYMBOLS

IntlChar::BLOCK_CODE_KAITHI

IntlChar::BLOCK_CODE_EGYPTIAN_HIEROGLYPHS

IntlChar::BLOCK_CODE_ENCLOSED_ALPHANUMERIC_SUPPLEMENT

IntlChar::BLOCK_CODE_ENCLOSED_IDEOGRAPHIC_SUPPLEMENT

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C

IntlChar::BLOCK_CODE_MANDAIC

IntlChar::BLOCK_CODE_BATAK

IntlChar::BLOCK_CODE_ETHIOPIC_EXTENDED_A

IntlChar::BLOCK_CODE_BRAHMI

IntlChar::BLOCK_CODE_BAMUM_SUPPLEMENT

IntlChar::BLOCK_CODE_KANA_SUPPLEMENT

IntlChar::BLOCK_CODE_PLAYING_CARDS

IntlChar::BLOCK_CODE_MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS

IntlChar::BLOCK_CODE_EMOTICONS

IntlChar::BLOCK_CODE_TRANSPORT_AND_MAP_SYMBOLS

IntlChar::BLOCK_CODE_ALCHEMICAL_SYMBOLS

IntlChar::BLOCK_CODE_CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D

IntlChar::BLOCK_CODE_ARABIC_EXTENDED_A

IntlChar::BLOCK_CODE_ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS

IntlChar::BLOCK_CODE_CHAKMA

IntlChar::BLOCK_CODE_MEETEI_MAYEK_EXTENSIONS

IntlChar::BLOCK_CODE_MEROITIC_CURSIVE

IntlChar::BLOCK_CODE_MEROITIC_HIEROGLYPHS

IntlChar::BLOCK_CODE_MIAO

IntlChar::BLOCK_CODE_SHARADA

IntlChar::BLOCK_CODE_SORA_SOMPENG

IntlChar::BLOCK_CODE_SUNDANESE_SUPPLEMENT

IntlChar::BLOCK_CODE_TAKRI

IntlChar::BLOCK_CODE_COUNT

IntlChar::BLOCK_CODE_INVALID_CODE

IntlChar::BPT_NONE

IntlChar::BPT_OPEN

IntlChar::BPT_CLOSE

IntlChar::BPT_COUNT

IntlChar::EA_NEUTRAL

IntlChar::EA_AMBIGUOUS

IntlChar::EA_HALFWIDTH

IntlChar::EA_FULLWIDTH

IntlChar::EA_NARROW

IntlChar::EA_WIDE

IntlChar::EA_COUNT

IntlChar::UNICODE_CHAR_NAME

IntlChar::UNICODE_10_CHAR_NAME

IntlChar::EXTENDED_CHAR_NAME

IntlChar::CHAR_NAME_ALIAS

IntlChar::CHAR_NAME_CHOICE_COUNT

IntlChar::SHORT_PROPERTY_NAME

IntlChar::LONG_PROPERTY_NAME

IntlChar::PROPERTY_NAME_CHOICE_COUNT

IntlChar::DT_NONE

IntlChar::DT_CANONICAL

IntlChar::DT_COMPAT

IntlChar::DT_CIRCLE

IntlChar::DT_FINAL

IntlChar::DT_FONT

IntlChar::DT_FRACTION

IntlChar::DT_INITIAL

IntlChar::DT_ISOLATED

IntlChar::DT_MEDIAL

IntlChar::DT_NARROW

IntlChar::DT_NOBREAK

IntlChar::DT_SMALL

IntlChar::DT_SQUARE

IntlChar::DT_SUB

IntlChar::DT_SUPER

IntlChar::DT_VERTICAL

IntlChar::DT_WIDE

IntlChar::DT_COUNT

IntlChar::JT_NON_JOINING

IntlChar::JT_JOIN_CAUSING

IntlChar::JT_DUAL_JOINING

IntlChar::JT_LEFT_JOINING

IntlChar::JT_RIGHT_JOINING

IntlChar::JT_TRANSPARENT

IntlChar::JT_COUNT

IntlChar::JG_NO_JOINING_GROUP

IntlChar::JG_AIN

IntlChar::JG_ALAPH

IntlChar::JG_ALEF

IntlChar::JG_BEH

IntlChar::JG_BETH

IntlChar::JG_DAL

IntlChar::JG_DALATH_RISH

IntlChar::JG_E

IntlChar::JG_FEH

IntlChar::JG_FINAL_SEMKATH

IntlChar::JG_GAF

IntlChar::JG_GAMAL

IntlChar::JG_HAH

IntlChar::JG_TEH_MARBUTA_GOAL

IntlChar::JG_HAMZA_ON_HEH_GOAL

IntlChar::JG_HE

IntlChar::JG_HEH

IntlChar::JG_HEH_GOAL

IntlChar::JG_HETH

IntlChar::JG_KAF

IntlChar::JG_KAPH

IntlChar::JG_KNOTTED_HEH

IntlChar::JG_LAM

IntlChar::JG_LAMADH

IntlChar::JG_MEEM

IntlChar::JG_MIM

IntlChar::JG_NOON

IntlChar::JG_NUN

IntlChar::JG_PE

IntlChar::JG_QAF

IntlChar::JG_QAPH

IntlChar::JG_REH

IntlChar::JG_REVERSED_PE

IntlChar::JG_SAD

IntlChar::JG_SADHE

IntlChar::JG_SEEN

IntlChar::JG_SEMKATH

IntlChar::JG_SHIN

IntlChar::JG_SWASH_KAF

IntlChar::JG_SYRIAC_WAW

IntlChar::JG_TAH

IntlChar::JG_TAW

IntlChar::JG_TEH_MARBUTA

IntlChar::JG_TETH

IntlChar::JG_WAW

IntlChar::JG_YEH

IntlChar::JG_YEH_BARREE

IntlChar::JG_YEH_WITH_TAIL

IntlChar::JG_YUDH

IntlChar::JG_YUDH_HE

IntlChar::JG_ZAIN

IntlChar::JG_FE

IntlChar::JG_KHAPH

IntlChar::JG_ZHAIN

IntlChar::JG_BURUSHASKI_YEH_BARREE

IntlChar::JG_FARSI_YEH

IntlChar::JG_NYA

IntlChar::JG_ROHINGYA_YEH

IntlChar::JG_COUNT

IntlChar::GCB_OTHER

IntlChar::GCB_CONTROL

IntlChar::GCB_CR

IntlChar::GCB_EXTEND

IntlChar::GCB_L

IntlChar::GCB_LF

IntlChar::GCB_LV

IntlChar::GCB_LVT

IntlChar::GCB_T

IntlChar::GCB_V

IntlChar::GCB_SPACING_MARK

IntlChar::GCB_PREPEND

IntlChar::GCB_REGIONAL_INDICATOR

IntlChar::GCB_COUNT

IntlChar::WB_OTHER

IntlChar::WB_ALETTER

IntlChar::WB_FORMAT

IntlChar::WB_KATAKANA

IntlChar::WB_MIDLETTER

IntlChar::WB_MIDNUM

IntlChar::WB_NUMERIC

IntlChar::WB_EXTENDNUMLET

IntlChar::WB_CR

IntlChar::WB_EXTEND

IntlChar::WB_LF

IntlChar::WB_MIDNUMLET

IntlChar::WB_NEWLINE

IntlChar::WB_REGIONAL_INDICATOR

IntlChar::WB_HEBREW_LETTER

IntlChar::WB_SINGLE_QUOTE

IntlChar::WB_DOUBLE_QUOTE

IntlChar::WB_COUNT

IntlChar::SB_OTHER

IntlChar::SB_ATERM

IntlChar::SB_CLOSE

IntlChar::SB_FORMAT

IntlChar::SB_LOWER

IntlChar::SB_NUMERIC

IntlChar::SB_OLETTER

IntlChar::SB_SEP

IntlChar::SB_SP

IntlChar::SB_STERM

IntlChar::SB_UPPER

IntlChar::SB_CR

IntlChar::SB_EXTEND

IntlChar::SB_LF

IntlChar::SB_SCONTINUE

IntlChar::SB_COUNT

IntlChar::LB_UNKNOWN

IntlChar::LB_AMBIGUOUS

IntlChar::LB_ALPHABETIC

IntlChar::LB_BREAK_BOTH

IntlChar::LB_BREAK_AFTER

IntlChar::LB_BREAK_BEFORE

IntlChar::LB_MANDATORY_BREAK

IntlChar::LB_CONTINGENT_BREAK

IntlChar::LB_CLOSE_PUNCTUATION

IntlChar::LB_COMBINING_MARK

IntlChar::LB_CARRIAGE_RETURN

IntlChar::LB_EXCLAMATION

IntlChar::LB_GLUE

IntlChar::LB_HYPHEN

IntlChar::LB_IDEOGRAPHIC

IntlChar::LB_INSEPARABLE

IntlChar::LB_INSEPERABLE

IntlChar::LB_INFIX_NUMERIC

IntlChar::LB_LINE_FEED

IntlChar::LB_NONSTARTER

IntlChar::LB_NUMERIC

IntlChar::LB_OPEN_PUNCTUATION

IntlChar::LB_POSTFIX_NUMERIC

IntlChar::LB_PREFIX_NUMERIC

IntlChar::LB_QUOTATION

IntlChar::LB_COMPLEX_CONTEXT

IntlChar::LB_SURROGATE

IntlChar::LB_SPACE

IntlChar::LB_BREAK_SYMBOLS

IntlChar::LB_ZWSPACE

IntlChar::LB_NEXT_LINE

IntlChar::LB_WORD_JOINER

IntlChar::LB_H2

IntlChar::LB_H3

IntlChar::LB_JL

IntlChar::LB_JT

IntlChar::LB_JV

IntlChar::LB_CLOSE_PARENTHESIS

IntlChar::LB_CONDITIONAL_JAPANESE_STARTER

IntlChar::LB_HEBREW_LETTER

IntlChar::LB_REGIONAL_INDICATOR

IntlChar::LB_COUNT

IntlChar::NT_NONE

IntlChar::NT_DECIMAL

IntlChar::NT_DIGIT

IntlChar::NT_NUMERIC

IntlChar::NT_COUNT

IntlChar::HST_NOT_APPLICABLE

IntlChar::HST_LEADING_JAMO

IntlChar::HST_VOWEL_JAMO

IntlChar::HST_TRAILING_JAMO

IntlChar::HST_LV_SYLLABLE

IntlChar::HST_LVT_SYLLABLE

IntlChar::HST_COUNT

IntlChar::FOLD_CASE_DEFAULT

IntlChar::FOLD_CASE_EXCLUDE_SPECIAL_I

更新日志

版本 | 说明
7.0.6 | The IntlChar::NO_NUMERIC_VALUE constant was added.

Table of Contents

  • IntlChar::charAge — Get the "age" of the code point
  • IntlChar::charDigitValue — Get the decimal digit value of a decimal digit character
  • IntlChar::charDirection — Get bidirectional category value for a code point
  • IntlChar::charFromName — Find Unicode character by name and return its code point value
  • IntlChar::charMirror — Get the "mirror-image" character for a code point
  • IntlChar::charName — Retrieve the name of a Unicode character
  • IntlChar::charType — Get the general category value for a code point
  • IntlChar::chr — Return Unicode character by code point value
  • IntlChar::digit — Get the decimal digit value of a code point for a given radix
  • IntlChar::enumCharNames — Enumerate all assigned Unicode characters within a range
  • IntlChar::enumCharTypes — Enumerate all code points with their Unicode general categories
  • IntlChar::foldCase — Perform case folding on a code point
  • IntlChar::forDigit — Get character representation for a given digit and radix
  • IntlChar::getBidiPairedBracket — Get the paired bracket character for a code point
  • IntlChar::getBlockCode — Get the Unicode allocation block containing a code point
  • IntlChar::getCombiningClass — Get the combining class of a code point
  • IntlChar::getFC_NFKC_Closure — Get the FC_NFKC_Closure property for a code point
  • IntlChar::getIntPropertyMaxValue — Get the max value for a Unicode property
  • IntlChar::getIntPropertyMinValue — Get the min value for a Unicode property
  • IntlChar::getIntPropertyValue — Get the value for a Unicode property for a code point
  • IntlChar::getNumericValue — Get the numeric value for a Unicode code point
  • IntlChar::getPropertyEnum — Get the property constant value for a given property name
  • IntlChar::getPropertyName — Get the Unicode name for a property
  • IntlChar::getPropertyValueEnum — Get the property value for a given value name
  • IntlChar::getPropertyValueName — Get the Unicode name for a property value
  • IntlChar::getUnicodeVersion — Get the Unicode version
  • IntlChar::hasBinaryProperty — Check a binary Unicode property for a code point
  • IntlChar::isalnum — Check if code point is an alphanumeric character
  • IntlChar::isalpha — Check if code point is a letter character
  • IntlChar::isbase — Check if code point is a base character
  • IntlChar::isblank — Check if code point is a "blank" or "horizontal space" character
  • IntlChar::iscntrl — Check if code point is a control character
  • IntlChar::isdefined — Check whether the code point is defined
  • IntlChar::isdigit — Check if code point is a digit character
  • IntlChar::isgraph — Check if code point is a graphic character
  • IntlChar::isIDIgnorable — Check if code point is an ignorable character
  • IntlChar::isIDPart — Check if code point is permissible in an identifier
  • IntlChar::isIDStart — Check if code point is permissible as the first character in an identifier
  • IntlChar::isISOControl — Check if code point is an ISO control code
  • IntlChar::isJavaIDPart — Check if code point is permissible in a Java identifier
  • IntlChar::isJavaIDStart — Check if code point is permissible as the first character in a Java identifier
  • IntlChar::isJavaSpaceChar — Check if code point is a space character according to Java
  • IntlChar::islower — Check if code point is a lowercase letter
  • IntlChar::isMirrored — Check if code point has the Bidi_Mirrored property
  • IntlChar::isprint — Check if code point is a printable character
  • IntlChar::ispunct — Check if code point is punctuation character
  • IntlChar::isspace — Check if code point is a space character
  • IntlChar::istitle — Check if code point is a titlecase letter
  • IntlChar::isUAlphabetic — Check if code point has the Alphabetic Unicode property
  • IntlChar::isULowercase — Check if code point has the Lowercase Unicode property
  • IntlChar::isupper — Check if code point has the general category "Lu" (uppercase letter)
  • IntlChar::isUUppercase — Check if code point has the Uppercase Unicode property
  • IntlChar::isUWhiteSpace — Check if code point has the White_Space Unicode property
  • IntlChar::isWhitespace — Check if code point is a whitespace character according to ICU
  • IntlChar::isxdigit — Check if code point is a hexadecimal digit
  • IntlChar::ord — Return Unicode code point value of character
  • IntlChar::tolower — Make Unicode character lowercase
  • IntlChar::totitle — Make Unicode character titlecase
  • IntlChar::toupper — Make Unicode character uppercase


Get the "age" of the code point

  • ? IntlChar
  • IntlChar::charDigitValue ?
  • PHP Manual
  • IntlChar
  • Get the "age" of the code point

IntlChar::charAge

(PHP 7)

IntlChar::charAge — Get the "age" of the code point

说明

public static IntlChar::charAge ( mixed $codepoint ) : array

Gets the "age" of the code point.

The "age" is the Unicode version when the code point was first designated (as a non-character or for Private Use) or assigned a character. This can be useful to avoid emitting code points to receiving processes that do not accept newer characters.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

The Unicode version number, as an array. For example, version 1.3.31.2 would be represented as [1, 3, 31, 2].

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::charage("\u{2603}"));
var_dump(IntlChar::charage("\u{1F576}"));
?>

以上例程会输出：

array(4) {
  [0]=>
  int(1)
  [1]=>
  int(1)
  [2]=>
  int(0)
  [3]=>
  int(0)
}
array(4) {
  [0]=>
  int(7)
  [1]=>
  int(0)
  [2]=>
  int(0)
  [3]=>
  int(0)
}

参见

  • IntlChar::getUnicodeVersion() - Get the Unicode version
  • IntlChar::getIntPropertyMinValue() - Get the min value for a Unicode property
  • IntlChar::getIntPropertyValue() - Get the value for a Unicode property for a code point


Get the decimal digit value of a decimal digit character

  • ? IntlChar::charAge
  • IntlChar::charDirection ?
  • PHP Manual
  • IntlChar
  • Get the decimal digit value of a decimal digit character

IntlChar::charDigitValue

(PHP 7)

IntlChar::charDigitValue — Get the decimal digit value of a decimal digit character

说明

public static IntlChar::charDigitValue ( mixed $codepoint ) : int

Returns the decimal digit value of a decimal digit character.

Such characters have the general category "Nd" (decimal digit numbers) and a Numeric_Type of Decimal.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

The decimal digit value of codepoint, or -1 if it is not a decimal digit character.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::charDigitValue("1"));
var_dump(IntlChar::charDigitValue("\u{0662}"));
var_dump(IntlChar::charDigitValue("\u{0E53}"));
?>

以上例程会输出：

int(1)
int(2)
int(3)

参见

  • IntlChar::getNumericValue() - Get the numeric value for a Unicode code point


Get bidirectional category value for a code point

  • ? IntlChar::charDigitValue
  • IntlChar::charFromName ?
  • PHP Manual
  • IntlChar
  • Get bidirectional category value for a code point

IntlChar::charDirection

(PHP 7)

IntlChar::charDirection — Get bidirectional category value for a code point

说明

public static IntlChar::charDirection ( mixed $codepoint ) : int

Returns the bidirectional category value for the code point, which is used in the » Unicode bidirectional algorithm (UAX #9).

Note:

Some unassigned code points have bidi values of R or AL because they are in blocks that are reserved for Right-To-Left scripts.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

The bidirectional category value; one of the following constants:

  • IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT
  • IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER
  • IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_SEPARATOR
  • IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_TERMINATOR
  • IntlChar::CHAR_DIRECTION_ARABIC_NUMBER
  • IntlChar::CHAR_DIRECTION_COMMON_NUMBER_SEPARATOR
  • IntlChar::CHAR_DIRECTION_BLOCK_SEPARATOR
  • IntlChar::CHAR_DIRECTION_SEGMENT_SEPARATOR
  • IntlChar::CHAR_DIRECTION_WHITE_SPACE_NEUTRAL
  • IntlChar::CHAR_DIRECTION_OTHER_NEUTRAL
  • IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_EMBEDDING
  • IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_OVERRIDE
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_ARABIC
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_EMBEDDING
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_OVERRIDE
  • IntlChar::CHAR_DIRECTION_POP_DIRECTIONAL_FORMAT
  • IntlChar::CHAR_DIRECTION_DIR_NON_SPACING_MARK
  • IntlChar::CHAR_DIRECTION_BOUNDARY_NEUTRAL
  • IntlChar::CHAR_DIRECTION_FIRST_STRONG_ISOLATE
  • IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT_ISOLATE
  • IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT_ISOLATE
  • IntlChar::CHAR_DIRECTION_POP_DIRECTIONAL_ISOLATE
  • IntlChar::CHAR_DIRECTION_CHAR_DIRECTION_COUNT

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::charDirection("A") === IntlChar::CHAR_DIRECTION_LEFT_TO_RIGHT);
var_dump(IntlChar::charDirection("\u{05E9}") === IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT);
var_dump(IntlChar::charDirection("+") === IntlChar::CHAR_DIRECTION_EUROPEAN_NUMBER_SEPARATOR);
var_dump(IntlChar::charDirection(".") === IntlChar::CHAR_DIRECTION_COMMON_NUMBER_SEPARATOR);
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)
bool(true)


Find Unicode character by name and return its code point value

  • ? IntlChar::charDirection
  • IntlChar::charMirror ?
  • PHP Manual
  • IntlChar
  • Find Unicode character by name and return its code point value

IntlChar::charFromName

(PHP 7)

IntlChar::charFromName — Find Unicode character by name and return its code point value

说明

public static IntlChar::charFromName ( string $characterName , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : int

Finds a Unicode character by its name and returns its code point value.

The name is matched exactly and completely. If the name does not correspond to a code point, null is returned.

A Unicode 1.0 name is matched only if it differs from the modern name. Unicode names are all uppercase. Extended names are lowercase followed by an uppercase hexadecimal number, and within angle brackets.

参数

characterName

Full name of the Unicode character.

nameChoice

Which set of names to use for the lookup. Can be any of these constants:

  • IntlChar::UNICODE_CHAR_NAME (default)
  • IntlChar::UNICODE_10_CHAR_NAME
  • IntlChar::EXTENDED_CHAR_NAME
  • IntlChar::CHAR_NAME_ALIAS
  • IntlChar::CHAR_NAME_CHOICE_COUNT

返回值

The Unicode value of the code point with the given name (as an int), or null if there is no such code point.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::charFromName("LATIN CAPITAL LETTER A"));
var_dump(IntlChar::charFromName("SNOWMAN"));
var_dump(IntlChar::charFromName("RECYCLING SYMBOL FOR TYPE-1 PLASTICS"));
var_dump(IntlChar::charFromName("A RANDOM STRING WHICH DOESN'T CORRESPOND TO ANY UNICODE CHARACTER"));
?>

以上例程会输出：

int(65)
int(9731)
int(9843)
bool(false)

参见

  • IntlChar::charName() - Retrieve the name of a Unicode character
  • IntlChar::enumCharNames() - Enumerate all assigned Unicode characters within a range


Get the "mirror-image" character for a code point

  • ? IntlChar::charFromName
  • IntlChar::charName ?
  • PHP Manual
  • IntlChar
  • Get the "mirror-image" character for a code point

IntlChar::charMirror

(PHP 7)

IntlChar::charMirror — Get the "mirror-image" character for a code point

说明

public static IntlChar::charMirror ( mixed $codepoint ) : mixed

Maps the specified character to a "mirror-image" character.

For characters with the Bidi_Mirrored property, implementations sometimes need a "poor man's" mapping to another Unicode character (code point) such that the default glyph may serve as the mirror-image of the default glyph of the specified character. This is useful for text conversion to and from codepages with visual order, and for displays without glyph selection capabilities.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns another Unicode code point that may serve as a mirror-image substitute, or codepoint itself if there is no such mapping or codepoint does not have the Bidi_Mirrored property.

The return type will be int unless the code point was passed as a UTF-8 string, in which case a string will be returned.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::charMirror("A"));
var_dump(IntlChar::charMirror("<"));
var_dump(IntlChar::charMirror("("));
?>

以上例程会输出：

string(1) "A"
string(1) ">"
string(2) ")"

参见

  • IntlChar::isMirrored() - Check if code point has the Bidi_Mirrored property
  • IntlChar::PROPERTY_BIDI_MIRRORED


Retrieve the name of a Unicode character

  • ? IntlChar::charMirror
  • IntlChar::charType ?
  • PHP Manual
  • IntlChar
  • Retrieve the name of a Unicode character

IntlChar::charName

(PHP 7)

IntlChar::charName — Retrieve the name of a Unicode character

说明

public static IntlChar::charName ( mixed $codepoint , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : string

Retrieves the name of a Unicode character.

Depending on nameChoice, the resulting character name is the "modern" name or the name that was defined in Unicode version 1.0. The name contains only "invariant" characters like A-Z, 0-9, space, and '-'. Unicode 1.0 names are only retrieved if they are different from the modern names and if ICU contains the data for them.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

nameChoice

Which set of names to use for the lookup. Can be any of these constants:

  • IntlChar::UNICODE_CHAR_NAME (default)
  • IntlChar::UNICODE_10_CHAR_NAME
  • IntlChar::EXTENDED_CHAR_NAME
  • IntlChar::CHAR_NAME_ALIAS
  • IntlChar::CHAR_NAME_CHOICE_COUNT

返回值

The corresponding name, or an empty string if there is no name for this character, or null if there is no such code point.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::charName("."));
var_dump(IntlChar::charName(".", IntlChar::UNICODE_CHAR_NAME));
var_dump(IntlChar::charName("\u{2603}"));
var_dump(IntlChar::charName("\u{0000}"));
?>

以上例程会输出：

string(9) "FULL STOP"
string(9) "FULL STOP"
string(7) "SNOWMAN"
string(0) ""

参见

  • IntlChar::charFromName() - Find Unicode character by name and return its code point value
  • IntlChar::enumCharNames() - Enumerate all assigned Unicode characters within a range


Get the general category value for a code point

  • ? IntlChar::charName
  • IntlChar::chr ?
  • PHP Manual
  • IntlChar
  • Get the general category value for a code point

IntlChar::charType

(PHP 7)

IntlChar::charType — Get the general category value for a code point

说明

public static IntlChar::charType ( mixed $codepoint ) : int

Returns the general category value for the code point.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns the general category type, which may be one of the following constants:

  • IntlChar::CHAR_CATEGORY_UNASSIGNED
  • IntlChar::CHAR_CATEGORY_GENERAL_OTHER_TYPES
  • IntlChar::CHAR_CATEGORY_UPPERCASE_LETTER
  • IntlChar::CHAR_CATEGORY_LOWERCASE_LETTER
  • IntlChar::CHAR_CATEGORY_TITLECASE_LETTER
  • IntlChar::CHAR_CATEGORY_MODIFIER_LETTER
  • IntlChar::CHAR_CATEGORY_OTHER_LETTER
  • IntlChar::CHAR_CATEGORY_NON_SPACING_MARK
  • IntlChar::CHAR_CATEGORY_ENCLOSING_MARK
  • IntlChar::CHAR_CATEGORY_COMBINING_SPACING_MARK
  • IntlChar::CHAR_CATEGORY_DECIMAL_DIGIT_NUMBER
  • IntlChar::CHAR_CATEGORY_LETTER_NUMBER
  • IntlChar::CHAR_CATEGORY_OTHER_NUMBER
  • IntlChar::CHAR_CATEGORY_SPACE_SEPARATOR
  • IntlChar::CHAR_CATEGORY_LINE_SEPARATOR
  • IntlChar::CHAR_CATEGORY_PARAGRAPH_SEPARATOR
  • IntlChar::CHAR_CATEGORY_CONTROL_CHAR
  • IntlChar::CHAR_CATEGORY_FORMAT_CHAR
  • IntlChar::CHAR_CATEGORY_PRIVATE_USE_CHAR
  • IntlChar::CHAR_CATEGORY_SURROGATE
  • IntlChar::CHAR_CATEGORY_DASH_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_START_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_END_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_CONNECTOR_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_OTHER_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_MATH_SYMBOL
  • IntlChar::CHAR_CATEGORY_CURRENCY_SYMBOL
  • IntlChar::CHAR_CATEGORY_MODIFIER_SYMBOL
  • IntlChar::CHAR_CATEGORY_OTHER_SYMBOL
  • IntlChar::CHAR_CATEGORY_INITIAL_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_FINAL_PUNCTUATION
  • IntlChar::CHAR_CATEGORY_CHAR_CATEGORY_COUNT

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::charType("A") === IntlChar::CHAR_CATEGORY_UPPERCASE_LETTER);
var_dump(IntlChar::charType(".") === IntlChar::CHAR_CATEGORY_OTHER_PUNCTUATION);
var_dump(IntlChar::charType("\t") === IntlChar::CHAR_CATEGORY_CONTROL_CHAR);
var_dump(IntlChar::charType("\u{2603}") === IntlChar::CHAR_CATEGORY_OTHER_SYMBOL);
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)
bool(true)


Return Unicode character by code point value

  • ? IntlChar::charType
  • IntlChar::digit ?
  • PHP Manual
  • IntlChar
  • Return Unicode character by code point value

IntlChar::chr

(PHP 7)

IntlChar::chr — Return Unicode character by code point value

说明

public static IntlChar::chr ( mixed $codepoint ) : string

Returns a string containing the character specified by the Unicode code point value.

This function compliments IntlChar::ord().

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

A string containing the single character specified by the Unicode code point value.

范例

Example #1 Testing different code points

<?php
$values = ["A", 63, 123, 9731];
foreach ($values as $value) {
    var_dump(IntlChar::chr($value));
}
?>

以上例程会输出：

string(1) "A"
string(1) "?"
string(1) "{"
string(3) "?"

参见

  • IntlChar::ord() - Return Unicode code point value of character
  • chr() - 返回指定的字符


Get the decimal digit value of a code point for a given radix

  • ? IntlChar::chr
  • IntlChar::enumCharNames ?
  • PHP Manual
  • IntlChar
  • Get the decimal digit value of a code point for a given radix

IntlChar::digit

(PHP 7)

IntlChar::digit — Get the decimal digit value of a code point for a given radix

说明

public static IntlChar::digit ( string $codepoint , int $radix = 10 ) : int

Returns the decimal digit value of the code point in the specified radix.

If the radix is not in the range 2<=radix<=36 or if the value of codepoint is not a valid digit in the specified radix, false is returned. A character is a valid digit if at least one of the following is true:

  • The character has a decimal digit value. Such characters have the general category "Nd" (decimal digit numbers) and a Numeric_Type of Decimal. In this case the value is the character's decimal digit value.
  • The character is one of the uppercase Latin letters 'A' through 'Z'. In this case the value is c-'A'+10.
  • The character is one of the lowercase Latin letters 'a' through 'z'. In this case the value is ch-'a'+10.
  • Latin letters from both the ASCII range (0061..007A, 0041..005A) as well as from the Fullwidth ASCII range (FF41..FF5A, FF21..FF3A) are recognized.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

radix

The radix (defaults to 10).

返回值

Returns the numeric value represented by the character in the specified radix, or false if there is no value or if the value exceeds the radix.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::digit("0"));
var_dump(IntlChar::digit("3"));
var_dump(IntlChar::digit("A"));
var_dump(IntlChar::digit("A", 16));
?>

以上例程会输出：

int(0)
int(3)
bool(false)
int(10)

参见

  • IntlChar::forDigit() - Get character representation for a given digit and radix
  • IntlChar::charDigitValue() - Get the decimal digit value of a decimal digit character
  • IntlChar::isdigit() - Check if code point is a digit character
  • IntlChar::PROPERTY_NUMERIC_TYPE


Enumerate all assigned Unicode characters within a range

  • ? IntlChar::digit
  • IntlChar::enumCharTypes ?
  • PHP Manual
  • IntlChar
  • Enumerate all assigned Unicode characters within a range

IntlChar::enumCharNames

(PHP 7)

IntlChar::enumCharNames — Enumerate all assigned Unicode characters within a range

说明

public static IntlChar::enumCharNames ( mixed $start , mixed $limit , callable $callback , int $nameChoice = IntlChar::UNICODE_CHAR_NAME ) : void

Enumerate all assigned Unicode characters between the start and limit code points (start inclusive, limit exclusive) and call a function for each, passing the code point value and the character name.

For Unicode 1.0 names, only those are enumerated that differ from the modern names.

参数

start

The first code point in the enumeration range.

limit

One more than the last code point in the enumeration range (the first one after the range).

callback

The function that is to be called for each character name. The following three arguments will be passed into it:

  • int $codepoint - The numeric code point value
  • int $nameChoice - The same value as the nameChoice parameter below
  • string $name - The name of the character

nameChoice

Selector for which kind of names to enumerate. Can be any of these constants:

  • IntlChar::UNICODE_CHAR_NAME (default)
  • IntlChar::UNICODE_10_CHAR_NAME
  • IntlChar::EXTENDED_CHAR_NAME
  • IntlChar::CHAR_NAME_ALIAS
  • IntlChar::CHAR_NAME_CHOICE_COUNT

返回值

没有返回值。

范例

Example #1 Enumerating over a sample range of code points

<?php
IntlChar::enumCharNames(0x2600, 0x2610, function($codepoint, $nameChoice, $name) {
    printf("U+%04x %s\n", $codepoint, $name);
});
?>

以上例程会输出：

U+2600 BLACK SUN WITH RAYS
U+2601 CLOUD
U+2602 UMBRELLA
U+2603 SNOWMAN
U+2604 COMET
U+2605 BLACK STAR
U+2606 WHITE STAR
U+2607 LIGHTNING
U+2608 THUNDERSTORM
U+2609 SUN
U+260a ASCENDING NODE
U+260b DESCENDING NODE
U+260c CONJUNCTION
U+260d OPPOSITION
U+260e BLACK TELEPHONE
U+260f WHITE TELEPHONE

参见

  • IntlChar::charName() - Retrieve the name of a Unicode character
  • IntlChar::charFromName() - Find Unicode character by name and return its code point value


Enumerate all code points with their Unicode general categories

  • ? IntlChar::enumCharNames
  • IntlChar::foldCase ?
  • PHP Manual
  • IntlChar
  • Enumerate all code points with their Unicode general categories

IntlChar::enumCharTypes

(PHP 7)

IntlChar::enumCharTypes — Enumerate all code points with their Unicode general categories

说明

public static IntlChar::enumCharTypes ( callable $callback ) : void

Enumerates efficiently all code points with their Unicode general categories. This is useful for building data structures, for enumerating all assigned code points, etc.

For each contiguous range of code points with a given general category ("character type"), the callback function is called. Adjacent ranges have different types. The Unicode Standard guarantees that the numeric value of the type is 0..31.

参数

callback

The function that is to be called for each contiguous range of code points with the same general category. The following three arguments will be passed into it:

  • int $start - The starting code point of the range
  • int $end - The ending code point of the range
  • int $name - The category type (one of the IntlChar::CHAR_CATEGORY_* constants)

返回值

没有返回值。

范例

Example #1 Enumerating over a sample range of code points

<?php
IntlChar::enumCharTypes(function($start, $end, $type) {
    printf("U+%04x through U+%04x are in category %d\n", $start, $end, $type);
});
?>

以上例程会输出：

U+0000 through U+0020 are in category 15
U+0020 through U+0021 are in category 12
U+0021 through U+0024 are in category 23
U+0024 through U+0025 are in category 25
U+0025 through U+0028 are in category 23
U+0028 through U+0029 are in category 20
U+0029 through U+002a are in category 21
U+002a through U+002b are in category 23
U+002b through U+002c are in category 24
U+002c through U+002d are in category 23
U+002d through U+002e are in category 19
U+002e through U+0030 are in category 23
U+0030 through U+003a are in category 9
...


Perform case folding on a code point

  • ? IntlChar::enumCharTypes
  • IntlChar::forDigit ?
  • PHP Manual
  • IntlChar
  • Perform case folding on a code point

IntlChar::foldCase

(PHP 7)

IntlChar::foldCase — Perform case folding on a code point

说明

public static IntlChar::foldCase ( mixed $codepoint , int $options = IntlChar::FOLD_CASE_DEFAULT ) : mixed

The given character is mapped to its case folding equivalent; if the character has no case folding equivalent, the character itself is returned.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

options

Either IntlChar::FOLD_CASE_DEFAULT (default) or IntlChar::FOLD_CASE_EXCLUDE_SPECIAL_I.

返回值

Returns the Simple_Case_Folding of the code point, if any; otherwise the code point itself.


Get character representation for a given digit and radix

  • ? IntlChar::foldCase
  • IntlChar::getBidiPairedBracket ?
  • PHP Manual
  • IntlChar
  • Get character representation for a given digit and radix

IntlChar::forDigit

(PHP 7)

IntlChar::forDigit — Get character representation for a given digit and radix

说明

public static IntlChar::forDigit ( int $digit , int $radix = 10 ) : int

Determines the character representation for a specific digit in the specified radix.

If the value of radix is not a valid radix, or the value of digit is not a valid digit in the specified radix, the null character (U+0000) is returned.

The radix argument is valid if it is greater than or equal to 2 and less than or equal to 36. The digit argument is valid if 0 <= digit < radix.

If the digit is less than 10, then '0' + digit is returned. Otherwise, the value 'a' + digit - 10 is returned.

参数

digit

The number to convert to a character.

radix

The radix (defaults to 10).

返回值

The character representation (as a string) of the specified digit in the specified radix.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::forDigit(0));
var_dump(IntlChar::forDigit(3));
var_dump(IntlChar::forDigit(3, 10));
var_dump(IntlChar::forDigit(10));
var_dump(IntlChar::forDigit(10, 16));
?>

以上例程会输出：

int(48)
int(51)
int(51)
int(0)
int(97)

参见

  • IntlChar::digit() - Get the decimal digit value of a code point for a given radix
  • IntlChar::charDigitValue() - Get the decimal digit value of a decimal digit character
  • IntlChar::isdigit() - Check if code point is a digit character
  • IntlChar::PROPERTY_NUMERIC_TYPE


Get the paired bracket character for a code point

  • ? IntlChar::forDigit
  • IntlChar::getBlockCode ?
  • PHP Manual
  • IntlChar
  • Get the paired bracket character for a code point

IntlChar::getBidiPairedBracket

(PHP 7)

IntlChar::getBidiPairedBracket — Get the paired bracket character for a code point

说明

public static IntlChar::getBidiPairedBracket ( mixed $codepoint ) : mixed

Maps the specified character to its paired bracket character.

For Bidi_Paired_Bracket_Type!=None, this is the same as IntlChar::charMirror(). Otherwise codepoint itself is returned.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns the paired bracket code point, or codepoint itself if there is no such mapping.

The return type will be int unless the code point was passed as a UTF-8 string, in which case a string will be returned.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::getBidiPairedBracket(91));
var_dump(IntlChar::getBidiPairedBracket('['));
?>

以上例程会输出：

int(93)
string(1) "]"

参见

  • IntlChar::charMirror() - Get the "mirror-image" character for a code point
  • IntlChar::PROPERTY_BIDI_PAIRED_BRACKET
  • IntlChar::PROPERTY_BIDI_PAIRED_BRACKET_TYPE


Get the Unicode allocation block containing a code point

  • ? IntlChar::getBidiPairedBracket
  • IntlChar::getCombiningClass ?
  • PHP Manual
  • IntlChar
  • Get the Unicode allocation block containing a code point

IntlChar::getBlockCode

(PHP 7)

IntlChar::getBlockCode — Get the Unicode allocation block containing a code point

说明

public static IntlChar::getBlockCode ( mixed $codepoint ) : int

Returns the Unicode allocation block that contains the character.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns the block value for codepoint. See the IntlChar::BLOCK_CODE_* constants for possible return values.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::getBlockCode("A") === IntlChar::BLOCK_CODE_BASIC_LATIN);
var_dump(IntlChar::getBlockCode("Φ") === IntlChar::BLOCK_CODE_GREEK);
var_dump(IntlChar::getBlockCode("\u{2603}") === IntlChar::BLOCK_CODE_MISCELLANEOUS_SYMBOLS);
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)


Get the combining class of a code point

  • ? IntlChar::getBlockCode
  • IntlChar::getFC_NFKC_Closure ?
  • PHP Manual
  • IntlChar
  • Get the combining class of a code point

IntlChar::getCombiningClass

(PHP 7)

IntlChar::getCombiningClass — Get the combining class of a code point

说明

public static IntlChar::getCombiningClass ( mixed $codepoint ) : int

Returns the combining class of the code point.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns the combining class of the character.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::getCombiningClass("A"));
var_dump(IntlChar::getCombiningClass("\u{0334}"));
var_dump(IntlChar::getCombiningClass("\u{0358}"));
?>

以上例程会输出：

int(0)
int(1)
int(232)


Get the FC_NFKC_Closure property for a code point

  • ? IntlChar::getCombiningClass
  • IntlChar::getIntPropertyMaxValue ?
  • PHP Manual
  • IntlChar
  • Get the FC_NFKC_Closure property for a code point

IntlChar::getFC_NFKC_Closure

(PHP 7)

IntlChar::getFC_NFKC_Closure — Get the FC_NFKC_Closure property for a code point

说明

public static IntlChar::getFC_NFKC_Closure ( mixed $codepoint ) : string

Gets the FC_NFKC_Closure property string for a character.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns the FC_NFKC_Closure property string for the codepoint, or an empty string if there is none.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::getFC_NFKC_Closure("\u{2121}"));
var_dump(IntlChar::getFC_NFKC_Closure("\u{1D2D}"));
?>

以上例程会输出：

string(3) "tel"
string(2) "?"


Get the max value for a Unicode property

  • ? IntlChar::getFC_NFKC_Closure
  • IntlChar::getIntPropertyMinValue ?
  • PHP Manual
  • IntlChar
  • Get the max value for a Unicode property

IntlChar::getIntPropertyMaxValue

(PHP 7)

IntlChar::getIntPropertyMaxValue — Get the max value for a Unicode property

说明

public static IntlChar::getIntPropertyMaxValue ( int $property ) : int

Gets the maximum value for an enumerated/integer/binary Unicode property.

参数

property

The Unicode property to lookup (see the IntlChar::PROPERTY_* constants).

返回值

The maximum value returned by IntlChar::getIntPropertyValue() for a Unicode property. <=0 if the property selector is out of range.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::getIntPropertyMaxValue(IntlChar::PROPERTY_BIDI_CLASS));
var_dump(IntlChar::getIntPropertyMaxValue(IntlChar::PROPERTY_SCRIPT));
var_dump(IntlChar::getIntPropertyMaxValue(IntlChar::PROPERTY_IDEOGRAPHIC));
var_dump(IntlChar::getIntPropertyMaxValue(999999999)); // Some made-up value
?>

以上例程会输出：

int(22)
int(166)
int(1)
int(-1)

参见

  • IntlChar::hasBinaryProperty() - Check a binary Unicode property for a code point
  • IntlChar::getIntPropertyMinValue() - Get the min value for a Unicode property
  • IntlChar::getIntPropertyValue() - Get the value for a Unicode property for a code point
  • IntlChar::getUnicodeVersion() - Get the Unicode version


Get the min value for a Unicode property

  • ? IntlChar::getIntPropertyMaxValue
  • IntlChar::getIntPropertyValue ?
  • PHP Manual
  • IntlChar
  • Get the min value for a Unicode property

IntlChar::getIntPropertyMinValue

(PHP 7)

IntlChar::getIntPropertyMinValue — Get the min value for a Unicode property

说明

public static IntlChar::getIntPropertyMinValue ( int $property ) : int

Gets the minimum value for an enumerated/integer/binary Unicode property.

参数

property

The Unicode property to lookup (see the IntlChar::PROPERTY_* constants).

返回值

The minimum value returned by IntlChar::getIntPropertyValue() for a Unicode property. 0 if the property selector is out of range.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::getIntPropertyMinValue(IntlChar::PROPERTY_BIDI_CLASS));
var_dump(IntlChar::getIntPropertyMinValue(IntlChar::PROPERTY_SCRIPT));
var_dump(IntlChar::getIntPropertyMinValue(IntlChar::PROPERTY_IDEOGRAPHIC));
var_dump(IntlChar::getIntPropertyMinValue(999999999)); // Some made-up value
?>

以上例程会输出：

int(0)
int(0)
int(0)
int(0)

参见

  • IntlChar::hasBinaryProperty() - Check a binary Unicode property for a code point
  • IntlChar::getIntPropertyMaxValue() - Get the max value for a Unicode property
  • IntlChar::getIntPropertyValue() - Get the value for a Unicode property for a code point
  • IntlChar::getUnicodeVersion() - Get the Unicode version


Get the value for a Unicode property for a code point

  • ? IntlChar::getIntPropertyMinValue
  • IntlChar::getNumericValue ?
  • PHP Manual
  • IntlChar
  • Get the value for a Unicode property for a code point

IntlChar::getIntPropertyValue

(PHP 7)

IntlChar::getIntPropertyValue — Get the value for a Unicode property for a code point

说明

public static IntlChar::getIntPropertyValue ( mixed $codepoint , int $property ) : int

Gets the property value for an enumerated or integer Unicode property for a code point. Also returns binary and mask property values.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

property

The Unicode property to lookup (see the IntlChar::PROPERTY_* constants).

返回值

Returns the numeric value that is directly the property value or, for enumerated properties, corresponds to the numeric value of the enumerated constant of the respective property value enumeration type.

Returns 0 or 1 (for false/true) for binary Unicode properties.

Returns a bit-mask for mask properties.

Returns 0 if property is out of bounds or if the Unicode version does not have data for the property at all, or not for this code point.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::getIntPropertyValue("A", IntlChar::PROPERTY_ALPHABETIC) === 1);
var_dump(IntlChar::getIntPropertyValue("[", IntlChar::PROPERTY_BIDI_MIRRORED) === 1);
var_dump(IntlChar::getIntPropertyValue("Φ", IntlChar::PROPERTY_BLOCK) === IntlChar::BLOCK_CODE_GREEK);
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)

参见

  • IntlChar::hasBinaryProperty() - Check a binary Unicode property for a code point
  • IntlChar::getIntPropertyMinValue() - Get the min value for a Unicode property
  • IntlChar::getIntPropertyMaxValue() - Get the max value for a Unicode property
  • IntlChar::getUnicodeVersion() - Get the Unicode version


Get the numeric value for a Unicode code point

  • ? IntlChar::getIntPropertyValue
  • IntlChar::getPropertyEnum ?
  • PHP Manual
  • IntlChar
  • Get the numeric value for a Unicode code point

IntlChar::getNumericValue

(PHP 7)

IntlChar::getNumericValue — Get the numeric value for a Unicode code point

说明

public static IntlChar::getNumericValue ( mixed $codepoint ) : float

Gets the numeric value for a Unicode code point as defined in the Unicode Character Database.

For characters without any numeric values in the Unicode Character Database, this function will return IntlChar::NO_NUMERIC_VALUE.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Numeric value of codepoint, or IntlChar::NO_NUMERIC_VALUE if none is defined. This constant was added in PHP 7.0.6, prior to this version the literal value (float)-123456789 may be used instead.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::getNumericValue("4"));
var_dump(IntlChar::getNumericValue("x"));
var_dump(IntlChar::getNumericValue("\u{216C}"));
?>

以上例程会输出：

float(4)
float(-123456789)
float(50)


Get the property constant value for a given property name

  • ? IntlChar::getNumericValue
  • IntlChar::getPropertyName ?
  • PHP Manual
  • IntlChar
  • Get the property constant value for a given property name

IntlChar::getPropertyEnum

(PHP 7)

IntlChar::getPropertyEnum — Get the property constant value for a given property name

说明

public static IntlChar::getPropertyEnum ( string $alias ) : int

Returns the property constant value for a given property name, as specified in the Unicode database file PropertyAliases.txt. Short, long, and any other variants are recognized.

In addition, this function maps the synthetic names "gcm" / "General_Category_Mask" to the property IntlChar::PROPERTY_GENERAL_CATEGORY_MASK. These names are not in PropertyAliases.txt.

This function compliments IntlChar::getPropertyName().

参数

alias

The property name to be matched. The name is compared using "loose matching" as described in PropertyAliases.txt.

返回值

Returns an IntlChar::PROPERTY_ constant value, or IntlChar::PROPERTY_INVALID_CODE if the given name does not match any property.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::getPropertyEnum('Bidi_Class') === IntlChar::PROPERTY_BIDI_CLASS);
var_dump(IntlChar::getPropertyEnum('script') === IntlChar::PROPERTY_SCRIPT);
var_dump(IntlChar::getPropertyEnum('IDEOGRAPHIC') === IntlChar::PROPERTY_IDEOGRAPHIC);
var_dump(IntlChar::getPropertyEnum('Some made-up string') === IntlChar::PROPERTY_INVALID_CODE);
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)
bool(true)

参见

  • IntlChar::getPropertyName() - Get the Unicode name for a property


Get the Unicode name for a property

  • ? IntlChar::getPropertyEnum
  • IntlChar::getPropertyValueEnum ?
  • PHP Manual
  • IntlChar
  • Get the Unicode name for a property

IntlChar::getPropertyName

(PHP 7)

IntlChar::getPropertyName — Get the Unicode name for a property

说明

public static IntlChar::getPropertyName ( int $property , int $nameChoice = IntlChar::LONG_PROPERTY_NAME ) : string

Returns the Unicode name for a given property, as given in the Unicode database file PropertyAliases.txt.

In addition, this function maps the property IntlChar::PROPERTY_GENERAL_CATEGORY_MASK to the synthetic names "gcm" / "General_Category_Mask". These names are not in PropertyAliases.txt.

This function compliments IntlChar::getPropertyEnum().

参数

property

The Unicode property to lookup (see the IntlChar::PROPERTY_* constants).

IntlChar::PROPERTY_INVALID_CODE should not be used. Also, if property is out of range, false is returned.

nameChoice

Selector for which name to get. If out of range, false is returned.

All properties have a long name. Most have a short name, but some do not. Unicode allows for additional names; if present these will be returned by adding 1, 2, etc. to IntlChar::LONG_PROPERTY_NAME.

返回值

Returns the name, or false if either the property or the nameChoice is out of range.

If a given nameChoice returns false, then all larger values of nameChoice will return false, with one exception: if false is returned for IntlChar::SHORT_PROPERTY_NAME, then IntlChar::LONG_PROPERTY_NAME (and higher) may still return a non-false value.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::getPropertyName(IntlChar::PROPERTY_BIDI_CLASS));
var_dump(IntlChar::getPropertyName(IntlChar::PROPERTY_BIDI_CLASS, IntlChar::SHORT_PROPERTY_NAME));
var_dump(IntlChar::getPropertyName(IntlChar::PROPERTY_BIDI_CLASS, IntlChar::LONG_PROPERTY_NAME));
var_dump(IntlChar::getPropertyName(IntlChar::PROPERTY_BIDI_CLASS, IntlChar::LONG_PROPERTY_NAME + 1));
?>

以上例程会输出：

string(10) "Bidi_Class"
string(2) "bc"
string(10) "Bidi_Class"
bool(false)

参见

  • IntlChar::getPropertyEnum() - Get the property constant value for a given property name


Get the property value for a given value name

  • ? IntlChar::getPropertyName
  • IntlChar::getPropertyValueName ?
  • PHP Manual
  • IntlChar
  • Get the property value for a given value name

IntlChar::getPropertyValueEnum

(PHP 7)

IntlChar::getPropertyValueEnum — Get the property value for a given value name

说明

public static IntlChar::getPropertyValueEnum ( int $property , string $name ) : int

Returns the property value integer for a given value name, as specified in the Unicode database file PropertyValueAliases.txt. Short, long, and any other variants are recognized.

Note:

Some of the names in PropertyValueAliases.txt will only be recognized with IntlChar::PROPERTY_GENERAL_CATEGORY_MASK, not IntlChar::PROPERTY_GENERAL_CATEGORY. These include:

  • "C" / "Other"
  • "L" / "Letter"
  • "LC" / "Cased_Letter"
  • "M" / "Mark"
  • "N" / "Number"
  • "P" / "Punctuation"
  • "S" / "Symbol"
  • "Z" / "Separator"

参数

property

The Unicode property to lookup (see the IntlChar::PROPERTY_* constants).

If out of range, or this method doesn't work with the given value, IntlChar::PROPERTY_INVALID_CODE is returned.

name

The value name to be matched. The name is compared using "loose matching" as described in PropertyValueAliases.txt.

返回值

Returns the corresponding value integer, or IntlChar::PROPERTY_INVALID_CODE if the given name does not match any value of the given property, or if the property is invalid.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::getPropertyValueEnum(IntlChar::PROPERTY_BLOCK, 'greek') === IntlChar::BLOCK_CODE_GREEK);
var_dump(IntlChar::getPropertyValueEnum(IntlChar::PROPERTY_BIDI_CLASS, 'RIGHT_TO_LEFT') === IntlChar::CHAR_DIRECTION_RIGHT_TO_LEFT);
var_dump(IntlChar::getPropertyValueEnum(IntlChar::PROPERTY_BIDI_CLASS, 'some made-up string') === IntlChar::PROPERTY_INVALID_CODE);
var_dump(IntlChar::getPropertyValueEnum(123456789, 'RIGHT_TO_LEFT') === IntlChar::PROPERTY_INVALID_CODE);
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)
bool(true)


Get the Unicode name for a property value

  • ? IntlChar::getPropertyValueEnum
  • IntlChar::getUnicodeVersion ?
  • PHP Manual
  • IntlChar
  • Get the Unicode name for a property value

IntlChar::getPropertyValueName

(PHP 7)

IntlChar::getPropertyValueName — Get the Unicode name for a property value

说明

public static IntlChar::getPropertyValueName ( int $property , int $value , int $nameChoice = IntlChar::LONG_PROPERTY_NAME ) : string

Returns the Unicode name for a given property value, as given in the Unicode database file PropertyValueAliases.txt.

Note:

Some of the names in PropertyValueAliases.txt can only be retrieved using IntlChar::PROPERTY_GENERAL_CATEGORY_MASK, not IntlChar::PROPERTY_GENERAL_CATEGORY. These include:

  • "C" / "Other"
  • "L" / "Letter"
  • "LC" / "Cased_Letter"
  • "M" / "Mark"
  • "N" / "Number"
  • "P" / "Punctuation"
  • "S" / "Symbol"
  • "Z" / "Separator"

参数

property

The Unicode property to lookup (see the IntlChar::PROPERTY_* constants).

If out of range, or this method doesn't work with the given value, false is returned.

value

Selector for a value for the given property. If out of range, false is returned.

In general, valid values range from 0 up to some maximum. There are a couple exceptions:

  • IntlChar::PROPERTY_BLOCK values begin at the non-zero value IntlChar::BLOCK_CODE_BASIC_LATIN
  • IntlChar::PROPERTY_CANONICAL_COMBINING_CLASS values are not contiguous and range from 0..240.

nameChoice

Selector for which name to get. If out of range, false is returned.

All values have a long name. Most have a short name, but some do not. Unicode allows for additional names; if present these will be returned by adding 1, 2, etc. to IntlChar::LONG_PROPERTY_NAME.

返回值

Returns the name, or false if either the property or the nameChoice is out of range.

If a given nameChoice returns false, then all larger values of nameChoice will return false, with one exception: if false is returned for IntlChar::SHORT_PROPERTY_NAME, then IntlChar::LONG_PROPERTY_NAME (and higher) may still return a non-false value.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::getPropertyValueName(IntlChar::PROPERTY_BLOCK, IntlChar::BLOCK_CODE_GREEK));
var_dump(IntlChar::getPropertyValueName(IntlChar::PROPERTY_BLOCK, IntlChar::BLOCK_CODE_GREEK, IntlChar::SHORT_PROPERTY_NAME));
var_dump(IntlChar::getPropertyValueName(IntlChar::PROPERTY_BLOCK, IntlChar::BLOCK_CODE_GREEK, IntlChar::LONG_PROPERTY_NAME));
var_dump(IntlChar::getPropertyValueName(IntlChar::PROPERTY_BLOCK, IntlChar::BLOCK_CODE_GREEK, IntlChar::LONG_PROPERTY_NAME + 1));
?>

以上例程会输出：

string(16) "Greek_And_Coptic"
string(5) "Greek"
string(16) "Greek_And_Coptic"
bool(false)


Get the Unicode version

  • ? IntlChar::getPropertyValueName
  • IntlChar::hasBinaryProperty ?
  • PHP Manual
  • IntlChar
  • Get the Unicode version

IntlChar::getUnicodeVersion

(PHP 7)

IntlChar::getUnicodeVersion — Get the Unicode version

说明

public static IntlChar::getUnicodeVersion ( ) : array

Gets the Unicode version information.

The version array is filled in with the version information for the Unicode standard that is currently used by ICU. For example, Unicode version 3.1.1 is represented as an array with the values [3, 1, 1, 0].

参数

此函数没有参数。

返回值

An array containing the Unicode version number.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::getUnicodeVersion());
?>

以上例程会输出：

array(4) {
  [0]=>
  int(7)
  [1]=>
  int(0)
  [2]=>
  int(0)
  [3]=>
  int(0)
}

参见

  • IntlChar::charAge() - Get the "age" of the code point


Check a binary Unicode property for a code point

  • ? IntlChar::getUnicodeVersion
  • IntlChar::isalnum ?
  • PHP Manual
  • IntlChar
  • Check a binary Unicode property for a code point

IntlChar::hasBinaryProperty

(PHP 7)

IntlChar::hasBinaryProperty — Check a binary Unicode property for a code point

说明

public static IntlChar::hasBinaryProperty ( mixed $codepoint , int $property ) : bool

Checks a binary Unicode property for a code point.

Unicode, especially in version 3.2, defines many more properties than the original set in UnicodeData.txt.

The properties APIs are intended to reflect Unicode properties as defined in the Unicode Character Database (UCD) and Unicode Technical Reports (UTR). For details about the properties see » http://www.unicode.org/ucd/. For names of Unicode properties see the UCD file PropertyAliases.txt.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

property

The Unicode property to lookup (see the IntlChar::PROPERTY_* constants).

返回值

Returns true or false according to the binary Unicode property value for codepoint. Also false if property is out of bounds or if the Unicode version does not have data for the property at all, or not for this code point.

范例

Example #1 Testing different properties

<?php
var_dump(IntlChar::hasBinaryProperty("A", IntlChar::PROPERTY_ALPHABETIC));
var_dump(IntlChar::hasBinaryProperty("A", IntlChar::PROPERTY_CASE_SENSITIVE));
var_dump(IntlChar::hasBinaryProperty("A", IntlChar::PROPERTY_BIDI_MIRRORED));
var_dump(IntlChar::hasBinaryProperty("[", IntlChar::PROPERTY_ALPHABETIC));
var_dump(IntlChar::hasBinaryProperty("[", IntlChar::PROPERTY_CASE_SENSITIVE));
var_dump(IntlChar::hasBinaryProperty("[", IntlChar::PROPERTY_BIDI_MIRRORED));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)
bool(false)
bool(false)
bool(true)

参见

  • IntlChar::getIntPropertyValue() - Get the value for a Unicode property for a code point
  • IntlChar::getUnicodeVersion() - Get the Unicode version


Check if code point is an alphanumeric character

  • ? IntlChar::hasBinaryProperty
  • IntlChar::isalpha ?
  • PHP Manual
  • IntlChar
  • Check if code point is an alphanumeric character

IntlChar::isalnum

(PHP 7)

IntlChar::isalnum — Check if code point is an alphanumeric character

说明

public static IntlChar::isalnum ( mixed $codepoint ) : bool

Determines whether the specified code point is an alphanumeric character (letter or digit). true for characters with general categories "L" (letters) and "Nd" (decimal digit numbers).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is an alphanumeric character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isalnum("A"));
var_dump(IntlChar::isalnum("1"));
var_dump(IntlChar::isalnum("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)

参见

  • IntlChar::isalpha() - Check if code point is a letter character
  • IntlChar::isdigit() - Check if code point is a digit character


Check if code point is a letter character

  • ? IntlChar::isalnum
  • IntlChar::isbase ?
  • PHP Manual
  • IntlChar
  • Check if code point is a letter character

IntlChar::isalpha

(PHP 7)

IntlChar::isalpha — Check if code point is a letter character

说明

public static IntlChar::isalpha ( mixed $codepoint ) : bool

Determines whether the specified code point is a letter character. true for general categories "L" (letters).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a letter character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isalpha("A"));
var_dump(IntlChar::isalpha("1"));
var_dump(IntlChar::isalpha("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(false)
bool(false)

参见

  • IntlChar::isalnum() - Check if code point is an alphanumeric character
  • IntlChar::isdigit() - Check if code point is a digit character


Check if code point is a base character

  • ? IntlChar::isalpha
  • IntlChar::isblank ?
  • PHP Manual
  • IntlChar
  • Check if code point is a base character

IntlChar::isbase

(PHP 7)

IntlChar::isbase — Check if code point is a base character

说明

public static IntlChar::isbase ( mixed $codepoint ) : bool

Determines whether the specified code point is a base character. true for general categories "L" (letters), "N" (numbers), "Mc" (spacing combining marks), and "Me" (enclosing marks).

Note:

This is different from the Unicode definition in chapter 3.5, conformance clause D13, which defines base characters to be all characters (not Cn) that do not graphically combine with preceding characters (M) and that are neither control (Cc) or format (Cf) characters.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a base character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isbase("A"));
var_dump(IntlChar::isbase("1"));
var_dump(IntlChar::isbase("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)

参见

  • IntlChar::isalpha() - Check if code point is a letter character
  • IntlChar::isdigit() - Check if code point is a digit character


Check if code point is a "blank" or "horizontal space" character

  • ? IntlChar::isbase
  • IntlChar::iscntrl ?
  • PHP Manual
  • IntlChar
  • Check if code point is a "blank" or "horizontal space" character

IntlChar::isblank

(PHP 7)

IntlChar::isblank — Check if code point is a "blank" or "horizontal space" character

说明

public static IntlChar::isblank ( mixed $codepoint ) : bool

Determines whether the specified code point is a "blank" or "horizontal space", a character that visibly separates words on a line.

The following are equivalent definitions:

  • true for Unicode White_Space characters except for "vertical space controls" where "vertical space controls" are the following characters: U+000A (LF) U+000B (VT) U+000C (FF) U+000D (CR) U+0085 (NEL) U+2028 (LS) U+2029 (PS)
  • true for U+0009 (TAB) and characters with general category "Zs" (space separators) except Zero Width Space (ZWSP, U+200B).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is either a "blank" or "horizontal space" character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isblank("A"));
var_dump(IntlChar::isblank(" "));
var_dump(IntlChar::isblank("\t"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(true)

参见

  • IntlChar::isspace() - Check if code point is a space character
  • IntlChar::isJavaSpaceChar() - Check if code point is a space character according to Java
  • IntlChar::isUWhiteSpace() - Check if code point has the White_Space Unicode property
  • IntlChar::isWhitespace() - Check if code point is a whitespace character according to ICU


Check if code point is a control character

  • ? IntlChar::isblank
  • IntlChar::isdefined ?
  • PHP Manual
  • IntlChar
  • Check if code point is a control character

IntlChar::iscntrl

(PHP 7)

IntlChar::iscntrl — Check if code point is a control character

说明

public static IntlChar::iscntrl ( mixed $codepoint ) : bool

Determines whether the specified code point is a control character.

A control character is one of the following:

  • ISO 8-bit control character (U+0000..U+001f and U+007f..U+009f)
  • IntlChar::CHAR_CATEGORY_CONTROL_CHAR (Cc)
  • IntlChar::CHAR_CATEGORY_FORMAT_CHAR (Cf)
  • IntlChar::CHAR_CATEGORY_LINE_SEPARATOR (Zl)
  • IntlChar::CHAR_CATEGORY_PARAGRAPH_SEPARATOR (Zp)

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a control character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::iscntrl("A"));
var_dump(IntlChar::iscntrl(" "));
var_dump(IntlChar::iscntrl("\n"));
var_dump(IntlChar::iscntrl("\u{200e}"));
?>

以上例程会输出：

bool(false)
bool(false)
bool(true)
bool(true)

参见

  • IntlChar::isprint() - Check if code point is a printable character
  • IntlChar::PROPERTY_DEFAULT_IGNORABLE_CODE_POINT


Check whether the code point is defined

  • ? IntlChar::iscntrl
  • IntlChar::isdigit ?
  • PHP Manual
  • IntlChar
  • Check whether the code point is defined

IntlChar::isdefined

(PHP 7)

IntlChar::isdefined — Check whether the code point is defined

说明

public static IntlChar::isdefined ( mixed $codepoint ) : bool

Determines whether the specified code point is "defined", which usually means that it is assigned a character.

true for general categories other than "Cn" (other, not assigned).

Note:

Note that non-character code points (e.g., U+FDD0) are not "defined" (they are Cn), but surrogate code points are "defined" (Cs).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a defined character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isdefined("A"));
var_dump(IntlChar::isdefined(" "));
var_dump(IntlChar::isdefined("\u{FDD0}"));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)

参见

  • IntlChar::isdigit() - Check if code point is a digit character
  • IntlChar::isalpha() - Check if code point is a letter character
  • IntlChar::isalnum() - Check if code point is an alphanumeric character
  • IntlChar::isupper() - Check if code point has the general category "Lu" (uppercase letter)
  • IntlChar::islower() - Check if code point is a lowercase letter
  • IntlChar::istitle() - Check if code point is a titlecase letter


Check if code point is a digit character

  • ? IntlChar::isdefined
  • IntlChar::isgraph ?
  • PHP Manual
  • IntlChar
  • Check if code point is a digit character

IntlChar::isdigit

(PHP 7)

IntlChar::isdigit — Check if code point is a digit character

说明

public static IntlChar::isdigit ( mixed $codepoint ) : bool

Determines whether the specified code point is a digit character.

true for characters with general category "Nd" (decimal digit numbers). Beginning with Unicode 4, this is the same as testing for the Numeric_Type of Decimal.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a digit character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isdigit("A"));
var_dump(IntlChar::isdigit("1"));
var_dump(IntlChar::isdigit("\t"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)

参见

  • IntlChar::isalpha() - Check if code point is a letter character
  • IntlChar::isalnum() - Check if code point is an alphanumeric character
  • IntlChar::isxdigit() - Check if code point is a hexadecimal digit


Check if code point is a graphic character

  • ? IntlChar::isdigit
  • IntlChar::isIDIgnorable ?
  • PHP Manual
  • IntlChar
  • Check if code point is a graphic character

IntlChar::isgraph

(PHP 7)

IntlChar::isgraph — Check if code point is a graphic character

说明

public static IntlChar::isgraph ( mixed $codepoint ) : bool

Determines whether the specified code point is a "graphic" character (printable, excluding spaces).

true for all characters except those with general categories "Cc" (control codes), "Cf" (format controls), "Cs" (surrogates), "Cn" (unassigned), and "Z" (separators).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a "graphic" character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isgraph("A"));
var_dump(IntlChar::isgraph("1"));
var_dump(IntlChar::isgraph("\u{2603}"));
var_dump(IntlChar::isgraph("\n"));
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)
bool(false)


Check if code point is an ignorable character

  • ? IntlChar::isgraph
  • IntlChar::isIDPart ?
  • PHP Manual
  • IntlChar
  • Check if code point is an ignorable character

IntlChar::isIDIgnorable

(PHP 7)

IntlChar::isIDIgnorable — Check if code point is an ignorable character

说明

public static IntlChar::isIDIgnorable ( mixed $codepoint ) : bool

Determines if the specified character should be regarded as an ignorable character in an identifier.

true for characters with general category "Cf" (format controls) as well as non-whitespace ISO controls (U+0000..U+0008, U+000E..U+001B, U+007F..U+009F).

Note:

Note that Unicode just recommends to ignore Cf (format controls).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is ignorable in identifiers, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isIDIgnorable("A"));
var_dump(IntlChar::isIDIgnorable(" "));
var_dump(IntlChar::isIDIgnorable("\u{007F}"));
?>

以上例程会输出：

bool(false)
bool(false)
bool(true)

参见

  • IntlChar::isIDStart() - Check if code point is permissible as the first character in an identifier
  • IntlChar::isIDPart() - Check if code point is permissible in an identifier
  • IntlChar::PROPERTY_DEFAULT_IGNORABLE_CODE_POINT


Check if code point is permissible in an identifier

  • ? IntlChar::isIDIgnorable
  • IntlChar::isIDStart ?
  • PHP Manual
  • IntlChar
  • Check if code point is permissible in an identifier

IntlChar::isIDPart

(PHP 7)

IntlChar::isIDPart — Check if code point is permissible in an identifier

说明

public static IntlChar::isIDPart ( mixed $codepoint ) : bool

Determines if the specified character is permissible in an identifier.

true for characters with general categories "L" (letters), "Nl" (letter numbers), "Nd" (decimal digits), "Mc" and "Mn" (combining marks), "Pc" (connecting punctuation), and u_isIDIgnorable(c).

Note:

This is almost the same as Unicode's ID_Continue (IntlChar::PROPERTY_ID_CONTINUE) except that Unicode recommends to ignore Cf which is less than IntlChar::isIDIgnorable().

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is the code point may occur in an identifier, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isIDPart("A"));
var_dump(IntlChar::isIDPart("$"));
var_dump(IntlChar::isIDPart("\n"));
var_dump(IntlChar::isIDPart("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(false)
bool(false)
bool(false)

参见

  • IntlChar::isIDIgnorable() - Check if code point is an ignorable character
  • IntlChar::isIDStart() - Check if code point is permissible as the first character in an identifier
  • IntlChar::PROPERTY_ID_CONTINUE


Check if code point is permissible as the first character in an identifier

  • ? IntlChar::isIDPart
  • IntlChar::isISOControl ?
  • PHP Manual
  • IntlChar
  • Check if code point is permissible as the first character in an identifier

IntlChar::isIDStart

(PHP 7)

IntlChar::isIDStart — Check if code point is permissible as the first character in an identifier

说明

public static IntlChar::isIDStart ( mixed $codepoint ) : bool

Determines if the specified character is permissible as the first character in an identifier according to Unicode (The Unicode Standard, Version 3.0, chapter 5.16 Identifiers).

true for characters with general categories "L" (letters) and "Nl" (letter numbers).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint may start an identifier, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isIDStart("A"));
var_dump(IntlChar::isIDStart("$"));
var_dump(IntlChar::isIDStart("\n"));
var_dump(IntlChar::isIDStart("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(false)
bool(false)
bool(false)

参见

  • IntlChar::isalpha() - Check if code point is a letter character
  • IntlChar::isIDPart() - Check if code point is permissible in an identifier
  • IntlChar::PROPERTY_ID_START


Check if code point is an ISO control code

  • ? IntlChar::isIDStart
  • IntlChar::isJavaIDPart ?
  • PHP Manual
  • IntlChar
  • Check if code point is an ISO control code

IntlChar::isISOControl

(PHP 7)

IntlChar::isISOControl — Check if code point is an ISO control code

说明

public static IntlChar::isISOControl ( mixed $codepoint ) : bool

Determines whether the specified code point is an ISO control code.

true for U+0000..U+001f and U+007f..U+009f (general category "Cc").

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is an ISO control code, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isISOControl(" "));
var_dump(IntlChar::isISOControl("\n"));
var_dump(IntlChar::isISOControl("\u{200e}"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)

参见

  • IntlChar::iscntrl() - Check if code point is a control character


Check if code point is permissible in a Java identifier

  • ? IntlChar::isISOControl
  • IntlChar::isJavaIDStart ?
  • PHP Manual
  • IntlChar
  • Check if code point is permissible in a Java identifier

IntlChar::isJavaIDPart

(PHP 7)

IntlChar::isJavaIDPart — Check if code point is permissible in a Java identifier

说明

public static IntlChar::isJavaIDPart ( mixed $codepoint ) : bool

Determines if the specified character is permissible in a Java identifier.

In addition to IntlChar::isIDPart(), true for characters with general category "Sc" (currency symbols).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint may occur in a Java identifier, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isJavaIDPart("A"));
var_dump(IntlChar::isJavaIDPart("$"));
var_dump(IntlChar::isJavaIDPart("\n"));
var_dump(IntlChar::isJavaIDPart("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)
bool(false)

参见

  • IntlChar::isIDIgnorable() - Check if code point is an ignorable character
  • IntlChar::isIDPart() - Check if code point is permissible in an identifier
  • IntlChar::isJavaIDStart() - Check if code point is permissible as the first character in a Java identifier
  • IntlChar::isalpha() - Check if code point is a letter character
  • IntlChar::isdigit() - Check if code point is a digit character


Check if code point is permissible as the first character in a Java identifier

  • ? IntlChar::isJavaIDPart
  • IntlChar::isJavaSpaceChar ?
  • PHP Manual
  • IntlChar
  • Check if code point is permissible as the first character in a Java identifier

IntlChar::isJavaIDStart

(PHP 7)

IntlChar::isJavaIDStart — Check if code point is permissible as the first character in a Java identifier

说明

public static IntlChar::isJavaIDStart ( mixed $codepoint ) : bool

Determines if the specified character is permissible as the start of a Java identifier.

In addition to IntlChar::isIDStart(), true for characters with general categories "Sc" (currency symbols) and "Pc" (connecting punctuation).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint may start a Java identifier, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isJavaIDStart("A"));
var_dump(IntlChar::isJavaIDStart("$"));
var_dump(IntlChar::isJavaIDStart("\n"));
var_dump(IntlChar::isJavaIDStart("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)
bool(false)

参见

  • IntlChar::isIDStart() - Check if code point is permissible as the first character in an identifier
  • IntlChar::isJavaIDPart() - Check if code point is permissible in a Java identifier
  • IntlChar::isalpha() - Check if code point is a letter character


Check if code point is a space character according to Java

  • ? IntlChar::isJavaIDStart
  • IntlChar::islower ?
  • PHP Manual
  • IntlChar
  • Check if code point is a space character according to Java

IntlChar::isJavaSpaceChar

(PHP 7)

IntlChar::isJavaSpaceChar — Check if code point is a space character according to Java

说明

public static IntlChar::isJavaSpaceChar ( mixed $codepoint ) : bool

Determine if the specified code point is a space character according to Java.

true for characters with general categories "Z" (separators), which does not include control codes (e.g., TAB or Line Feed).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a space character according to Java, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isJavaSpaceChar("A"));
var_dump(IntlChar::isJavaSpaceChar(" "));
var_dump(IntlChar::isJavaSpaceChar("\n"));
var_dump(IntlChar::isJavaSpaceChar("\t"));
var_dump(IntlChar::isJavaSpaceChar("\u{00A0}"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)
bool(false)
bool(true)

参见

  • IntlChar::isspace() - Check if code point is a space character
  • IntlChar::isWhitespace() - Check if code point is a whitespace character according to ICU
  • IntlChar::isUWhiteSpace() - Check if code point has the White_Space Unicode property


Check if code point is a lowercase letter

  • ? IntlChar::isJavaSpaceChar
  • IntlChar::isMirrored ?
  • PHP Manual
  • IntlChar
  • Check if code point is a lowercase letter

IntlChar::islower

(PHP 7)

IntlChar::islower — Check if code point is a lowercase letter

说明

public static IntlChar::islower ( mixed $codepoint ) : bool

Determines whether the specified code point has the general category "Ll" (lowercase letter).

Note:

This misses some characters that are also lowercase but have a different general category value. In order to include those, use IntlChar::isULowercase().

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is an Ll lowercase letter, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::islower("A"));
var_dump(IntlChar::islower("a"));
var_dump(IntlChar::islower("Φ"));
var_dump(IntlChar::islower("φ"));
var_dump(IntlChar::islower("1"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)
bool(true)
bool(false)

参见

  • IntlChar::isupper() - Check if code point has the general category "Lu" (uppercase letter)
  • IntlChar::istitle() - Check if code point is a titlecase letter
  • IntlChar::tolower() - Make Unicode character lowercase
  • IntlChar::toupper() - Make Unicode character uppercase
  • IntlChar::PROPERTY_LOWERCASE


Check if code point has the Bidi_Mirrored property

  • ? IntlChar::islower
  • IntlChar::isprint ?
  • PHP Manual
  • IntlChar
  • Check if code point has the Bidi_Mirrored property

IntlChar::isMirrored

(PHP 7)

IntlChar::isMirrored — Check if code point has the Bidi_Mirrored property

说明

public static IntlChar::isMirrored ( mixed $codepoint ) : bool

Determines whether the code point has the Bidi_Mirrored property.

This property is set for characters that are commonly used in Right-To-Left contexts and need to be displayed with a "mirrored" glyph.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint has the Bidi_Mirrored property, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isMirrored("A"));
var_dump(IntlChar::isMirrored("<"));
var_dump(IntlChar::isMirrored("("));
?>

以上例程会输出：

bool(false)
bool(true)
bool(true)

参见

  • IntlChar::charMirror() - Get the "mirror-image" character for a code point
  • IntlChar::PROPERTY_BIDI_MIRRORED


Check if code point is a printable character

  • ? IntlChar::isMirrored
  • IntlChar::ispunct ?
  • PHP Manual
  • IntlChar
  • Check if code point is a printable character

IntlChar::isprint

(PHP 7)

IntlChar::isprint — Check if code point is a printable character

说明

public static IntlChar::isprint ( mixed $codepoint ) : bool

Determines whether the specified code point is a printable character.

true for general categories other than "C" (controls).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a printable character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isprint("A"));
var_dump(IntlChar::isprint(" "));
var_dump(IntlChar::isprint("\n"));
var_dump(IntlChar::isprint("\u{200e}"));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)
bool(false)

参见

  • IntlChar::iscntrl() - Check if code point is a control character
  • IntlChar::PROPERTY_DEFAULT_IGNORABLE_CODE_POINT


Check if code point is punctuation character

  • ? IntlChar::isprint
  • IntlChar::isspace ?
  • PHP Manual
  • IntlChar
  • Check if code point is punctuation character

IntlChar::ispunct

(PHP 7)

IntlChar::ispunct — Check if code point is punctuation character

说明

public static IntlChar::ispunct ( mixed $codepoint ) : bool

Determines whether the specified code point is a punctuation character.

true for characters with general categories "P" (punctuation).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a punctuation character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::ispunct("."));
var_dump(IntlChar::ispunct(","));
var_dump(IntlChar::ispunct("\n"));
var_dump(IntlChar::ispunct("$"));

以上例程会输出：

bool(true)
bool(true)
bool(false)
bool(false)


Check if code point is a space character

  • ? IntlChar::ispunct
  • IntlChar::istitle ?
  • PHP Manual
  • IntlChar
  • Check if code point is a space character

IntlChar::isspace

(PHP 7)

IntlChar::isspace — Check if code point is a space character

说明

public static IntlChar::isspace ( mixed $codepoint ) : bool

Determines if the specified character is a space character or not.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a space character, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isspace("A"));
var_dump(IntlChar::isspace(" "));
var_dump(IntlChar::isspace("\n"));
var_dump(IntlChar::isspace("\t"));
var_dump(IntlChar::isspace("\u{00A0}"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(true)
bool(true)
bool(true)

参见

  • IntlChar::isJavaSpaceChar() - Check if code point is a space character according to Java
  • IntlChar::isWhitespace() - Check if code point is a whitespace character according to ICU
  • IntlChar::isUWhiteSpace() - Check if code point has the White_Space Unicode property


Check if code point is a titlecase letter

  • ? IntlChar::isspace
  • IntlChar::isUAlphabetic ?
  • PHP Manual
  • IntlChar
  • Check if code point is a titlecase letter

IntlChar::istitle

(PHP 7)

IntlChar::istitle — Check if code point is a titlecase letter

说明

public static IntlChar::istitle ( mixed $codepoint ) : bool

Determines whether the specified code point is a titlecase letter.

true for general category "Lt" (titlecase letter).

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a titlecase letter, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::istitle("A"));
var_dump(IntlChar::istitle("a"));
var_dump(IntlChar::istitle("Φ"));
var_dump(IntlChar::istitle("φ"));
var_dump(IntlChar::istitle("1"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)
bool(true)
bool(false)

参见

  • IntlChar::isupper() - Check if code point has the general category "Lu" (uppercase letter)
  • IntlChar::islower() - Check if code point is a lowercase letter
  • IntlChar::totitle() - Make Unicode character titlecase


Check if code point has the Alphabetic Unicode property

  • ? IntlChar::istitle
  • IntlChar::isULowercase ?
  • PHP Manual
  • IntlChar
  • Check if code point has the Alphabetic Unicode property

IntlChar::isUAlphabetic

(PHP 7)

IntlChar::isUAlphabetic — Check if code point has the Alphabetic Unicode property

说明

public static IntlChar::isUAlphabetic ( mixed $codepoint ) : bool

Check if a code point has the Alphabetic Unicode property.

This is the same as IntlChar::hasBinaryProperty($codepoint, IntlChar::PROPERTY_ALPHABETIC)

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint has the Alphabetic Unicode property, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isUAlphabetic("A"));
var_dump(IntlChar::isUAlphabetic("1"));
var_dump(IntlChar::isUAlphabetic("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(false)
bool(false)

参见

  • IntlChar::isalpha() - Check if code point is a letter character
  • IntlChar::hasBinaryProperty() - Check a binary Unicode property for a code point
  • IntlChar::PROPERTY_ALPHABETIC


Check if code point has the Lowercase Unicode property

  • ? IntlChar::isUAlphabetic
  • IntlChar::isupper ?
  • PHP Manual
  • IntlChar
  • Check if code point has the Lowercase Unicode property

IntlChar::isULowercase

(PHP 7)

IntlChar::isULowercase — Check if code point has the Lowercase Unicode property

说明

public static IntlChar::isULowercase ( mixed $codepoint ) : bool

Check if a code point has the Lowercase Unicode property.

This is the same as IntlChar::hasBinaryProperty($codepoint, IntlChar::PROPERTY_LOWERCASE)

Note:

This is different than IntlChar::islower() and will return true for more characters.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint has the Lowercase Unicode property, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isULowercase("A"));
var_dump(IntlChar::isULowercase("a"));
var_dump(IntlChar::isULowercase("Φ"));
var_dump(IntlChar::isULowercase("φ"));
var_dump(IntlChar::isULowercase("1"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(false)
bool(true)
bool(false)

参见

  • IntlChar::islower() - Check if code point is a lowercase letter
  • IntlChar::hasBinaryProperty() - Check a binary Unicode property for a code point
  • IntlChar::PROPERTY_LOWERCASE


Check if code point has the general category "Lu" (uppercase letter)

  • ? IntlChar::isULowercase
  • IntlChar::isUUppercase ?
  • PHP Manual
  • IntlChar
  • Check if code point has the general category "Lu" (uppercase letter)

IntlChar::isupper

(PHP 7)

IntlChar::isupper — Check if code point has the general category "Lu" (uppercase letter)

说明

public static IntlChar::isupper ( mixed $codepoint ) : bool

Determines whether the specified code point has the general category "Lu" (uppercase letter).

Note:

This misses some characters that are also uppercase but have a different general category value. In order to include those, use IntlChar::isUUppercase().

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is an Lu uppercase letter, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isupper("A"));
var_dump(IntlChar::isupper("a"));
var_dump(IntlChar::isupper("Φ"));
var_dump(IntlChar::isupper("φ"));
var_dump(IntlChar::isupper("1"));
?>

以上例程会输出：

bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

参见

  • IntlChar::islower() - Check if code point is a lowercase letter
  • IntlChar::istitle() - Check if code point is a titlecase letter
  • IntlChar::tolower() - Make Unicode character lowercase
  • IntlChar::toupper() - Make Unicode character uppercase
  • IntlChar::PROPERTY_UPPERCASE


Check if code point has the Uppercase Unicode property

  • ? IntlChar::isupper
  • IntlChar::isUWhiteSpace ?
  • PHP Manual
  • IntlChar
  • Check if code point has the Uppercase Unicode property

IntlChar::isUUppercase

(PHP 7)

IntlChar::isUUppercase — Check if code point has the Uppercase Unicode property

说明

public static IntlChar::isUUppercase ( mixed $codepoint ) : bool

Check if a code point has the Uppercase Unicode property.

This is the same as IntlChar::hasBinaryProperty($codepoint, IntlChar::PROPERTY_UPPERCASE)

Note:

This is different than IntlChar::isupper() and will return true for more characters.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint has the Uppercase Unicode property, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isUUppercase("A"));
var_dump(IntlChar::isUUppercase("a"));
var_dump(IntlChar::isUUppercase("Φ"));
var_dump(IntlChar::isUUppercase("φ"));
var_dump(IntlChar::isUUppercase("1"));
?>

以上例程会输出：

bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

参见

  • IntlChar::isupper() - Check if code point has the general category "Lu" (uppercase letter)
  • IntlChar::hasBinaryProperty() - Check a binary Unicode property for a code point
  • IntlChar::PROPERTY_UPPERCASE


Check if code point has the White_Space Unicode property

  • ? IntlChar::isUUppercase
  • IntlChar::isWhitespace ?
  • PHP Manual
  • IntlChar
  • Check if code point has the White_Space Unicode property

IntlChar::isUWhiteSpace

(PHP 7)

IntlChar::isUWhiteSpace — Check if code point has the White_Space Unicode property

说明

public static IntlChar::isUWhiteSpace ( mixed $codepoint ) : bool

Check if a code point has the White_Space Unicode property.

This is the same as IntlChar::hasBinaryProperty($codepoint, IntlChar::PROPERTY_WHITE_SPACE)

Note:

This is different from both IntlChar::isspace() and IntlChar::isWhitespace().

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint has the White_Space Unicode property, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isUWhiteSpace("A"));
var_dump(IntlChar::isUWhiteSpace(" "));
var_dump(IntlChar::isUWhiteSpace("\n"));
var_dump(IntlChar::isUWhiteSpace("\t"));
var_dump(IntlChar::isUWhiteSpace("\u{00A0}"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(true)
bool(true)
bool(true)

参见

  • IntlChar::isspace() - Check if code point is a space character
  • IntlChar::isWhitespace() - Check if code point is a whitespace character according to ICU
  • IntlChar::isJavaSpaceChar() - Check if code point is a space character according to Java
  • IntlChar::hasBinaryProperty() - Check a binary Unicode property for a code point
  • IntlChar::PROPERTY_WHITE_SPACE


Check if code point is a whitespace character according to ICU

  • ? IntlChar::isUWhiteSpace
  • IntlChar::isxdigit ?
  • PHP Manual
  • IntlChar
  • Check if code point is a whitespace character according to ICU

IntlChar::isWhitespace

(PHP 7)

IntlChar::isWhitespace — Check if code point is a whitespace character according to ICU

说明

public static IntlChar::isWhitespace ( mixed $codepoint ) : bool

Determines if the specified code point is a whitespace character according to ICU.

A character is considered to be a ICU whitespace character if and only if it satisfies one of the following criteria:

  • It is a Unicode Separator character (categories "Z" = "Zs" or "Zl" or "Zp"), but is not also a non-breaking space (U+00A0 NBSP or U+2007 Figure Space or U+202F Narrow NBSP).
  • It is U+0009 HORIZONTAL TABULATION.
  • It is U+000A LINE FEED.
  • It is U+000B VERTICAL TABULATION.
  • It is U+000C FORM FEED.
  • It is U+000D CARRIAGE RETURN.
  • It is U+001C FILE SEPARATOR.
  • It is U+001D GROUP SEPARATOR.
  • It is U+001E RECORD SEPARATOR.
  • It is U+001F UNIT SEPARATOR.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a whitespace character according to ICU, false if not.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::iswhitespace("A"));
var_dump(IntlChar::iswhitespace(" "));
var_dump(IntlChar::iswhitespace("\n"));
var_dump(IntlChar::iswhitespace("\t"));
var_dump(IntlChar::iswhitespace("\u{00A0}"));
?>

以上例程会输出：

bool(false)
bool(true)
bool(true)
bool(true)
bool(false)

参见

  • IntlChar::isspace() - Check if code point is a space character
  • IntlChar::isJavaSpaceChar() - Check if code point is a space character according to Java
  • IntlChar::isUWhiteSpace() - Check if code point has the White_Space Unicode property


Check if code point is a hexadecimal digit

  • ? IntlChar::isWhitespace
  • IntlChar::ord ?
  • PHP Manual
  • IntlChar
  • Check if code point is a hexadecimal digit

IntlChar::isxdigit

(PHP 7)

IntlChar::isxdigit — Check if code point is a hexadecimal digit

说明

public static IntlChar::isxdigit ( mixed $codepoint ) : bool

Determines whether the specified code point is a hexadecimal digit.

true for characters with general category "Nd" (decimal digit numbers) as well as Latin letters a-f and A-F in both ASCII and Fullwidth ASCII. (That is, for letters with code points 0041..0046, 0061..0066, FF21..FF26, FF41..FF46.)

This is equivalent to IntlChar::digit($codepoint, 16) >= 0.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns true if codepoint is a hexadecimal character, false if not.

注释

Note:

In order to narrow the definition of hexadecimal digits to only ASCII characters use:

<?php
$isASCIIHexadecimal = IntlChar::ord($codepoint) <= 0x7F && IntlChar::isxdigit($codepoint);
?>

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::isxdigit("A"));
var_dump(IntlChar::isxdigit("1"));
var_dump(IntlChar::isxdigit("\u{2603}"));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)

参见

  • IntlChar::isdigit() - Check if code point is a digit character


Return Unicode code point value of character

  • ? IntlChar::isxdigit
  • IntlChar::tolower ?
  • PHP Manual
  • IntlChar
  • Return Unicode code point value of character

IntlChar::ord

(PHP 7)

IntlChar::ord — Return Unicode code point value of character

说明

public static IntlChar::ord ( mixed $character ) : int

Returns the Unicode code point value of the given character.

This function compliments IntlChar::chr().

参数

character

A Unicode character.

返回值

Returns the Unicode code point value as an integer.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::ord("A"));
var_dump(IntlChar::ord(" "));
var_dump(IntlChar::ord("\u{2603}"));
?>

以上例程会输出：

int(65)
int(32)
int(9731)

参见

  • IntlChar::isalnum() - Check if code point is an alphanumeric character
  • IntlChar::isdigit() - Check if code point is a digit character
  • IntlChar::chr() - Return Unicode character by code point value
  • ord() - 转换字符串第一个字节为 0-255 之间的值


Make Unicode character lowercase

  • ? IntlChar::ord
  • IntlChar::totitle ?
  • PHP Manual
  • IntlChar
  • Make Unicode character lowercase

IntlChar::tolower

(PHP 7)

IntlChar::tolower — Make Unicode character lowercase

说明

public static IntlChar::tolower ( mixed $codepoint ) : mixed

The given character is mapped to its lowercase equivalent. If the character has no lowercase equivalent, the original character itself is returned.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns the Simple_Lowercase_Mapping of the code point, if any; otherwise the code point itself.

The return type will be int unless the code point was passed as a UTF-8 string, in which case a string will be returned.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::tolower("A"));
var_dump(IntlChar::tolower("a"));
var_dump(IntlChar::tolower("Φ"));
var_dump(IntlChar::tolower("φ"));
var_dump(IntlChar::tolower("1"));
var_dump(IntlChar::tolower(ord("A")));
var_dump(IntlChar::tolower(ord("a")));
?>

以上例程会输出：

string(1) "a"
string(1) "a"
string(2) "φ"
string(2) "φ"
string(1) "1"
int(97)
int(97)

参见

  • IntlChar::totitle() - Make Unicode character titlecase
  • IntlChar::toupper() - Make Unicode character uppercase
  • mb_strtolower() - 使字符串小写


Make Unicode character titlecase

  • ? IntlChar::tolower
  • IntlChar::toupper ?
  • PHP Manual
  • IntlChar
  • Make Unicode character titlecase

IntlChar::totitle

(PHP 7)

IntlChar::totitle — Make Unicode character titlecase

说明

public static IntlChar::totitle ( mixed $codepoint ) : mixed

The given character is mapped to its titlecase equivalent. If the character has no titlecase equivalent, the original character itself is returned.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns the Simple_Titlecase_Mapping of the code point, if any; otherwise the code point itself.

The return type will be int unless the code point was passed as a UTF-8 string, in which case a string will be returned.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::totitle("A"));
var_dump(IntlChar::totitle("a"));
var_dump(IntlChar::totitle("Φ"));
var_dump(IntlChar::totitle("φ"));
var_dump(IntlChar::totitle("1"));
var_dump(IntlChar::totitle(ord("A")));
var_dump(IntlChar::totitle(ord("a")));
?>

以上例程会输出：

string(1) "A"
string(1) "A"
string(2) "Φ"
string(2) "Φ"
string(1) "1"
int(65)
int(65)

参见

  • IntlChar::tolower() - Make Unicode character lowercase
  • IntlChar::toupper() - Make Unicode character uppercase
  • mb_convert_case() - 对字符串进行大小写转换


Make Unicode character uppercase

  • ? IntlChar::totitle
  • IntlException ?
  • PHP Manual
  • IntlChar
  • Make Unicode character uppercase

IntlChar::toupper

(PHP 7)

IntlChar::toupper — Make Unicode character uppercase

说明

public static IntlChar::toupper ( mixed $codepoint ) : mixed

The given character is mapped to its uppercase equivalent. If the character has no uppercase equivalent, the character itself is returned.

参数

codepoint

The int codepoint value (e.g. 0x2603 for U+2603 SNOWMAN), or the character encoded as a UTF-8 string (e.g. "\u{2603}")

返回值

Returns the Simple_Uppercase_Mapping of the code point, if any; otherwise the code point itself.

The return type will be int unless the code point was passed as a UTF-8 string, in which case a string will be returned.

范例

Example #1 Testing different code points

<?php
var_dump(IntlChar::toupper("A"));
var_dump(IntlChar::toupper("a"));
var_dump(IntlChar::toupper("Φ"));
var_dump(IntlChar::toupper("φ"));
var_dump(IntlChar::toupper("1"));
var_dump(IntlChar::toupper(ord("A")));
var_dump(IntlChar::toupper(ord("a")));
?>

以上例程会输出：

string(1) "A"
string(1) "A"
string(2) "Φ"
string(2) "Φ"
string(1) "1"
int(65)
int(65)

参见

  • IntlChar::tolower() - Make Unicode character lowercase
  • IntlChar::totitle() - Make Unicode character titlecase
  • mb_strtoupper() - 使字符串大写


Exception class for intl errors

(PHP 5 > 5.5.0, PHP 7, PECL intl > 3.0.0a1)

简介

This class is used for generating exceptions when errors occur inside intl functions. Such exceptions are only generated when intl.use_exceptions is enabled.

类摘要

IntlException extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The IntlIterator class

(PHP 5 >= 5.5.0, PHP 7)

简介

This class represents iterator objects throughout the intl extension whenever the iterator cannot be identified with any other object provided by the extension. The distinct iterator object used internally by the foreach construct can only be obtained (in the relevant part here) from objects, so objects of this class serve the purpose of providing the hook through which this internal object can be obtained. As a convenience, this class also implements the Iterator interface, allowing the collection of values to be navigated using the methods defined in that interface. Both these methods and the internal iterator objects provided to foreach are backed by the same state (e.g. the position of the iterator and its current value).

Subclasses may provide richer functionality.

类摘要

IntlIterator implements Iterator {
/* 方法 */
public current ( ) : mixed
public key ( ) : string
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Table of Contents

  • IntlIterator::current — Get the current element
  • IntlIterator::key — Get the current key
  • IntlIterator::next — Move forward to the next element
  • IntlIterator::rewind — Rewind the iterator to the first element
  • IntlIterator::valid — Check if current position is valid


Get the current element

  • ? IntlIterator
  • IntlIterator::key ?
  • PHP Manual
  • IntlIterator
  • Get the current element

IntlIterator::current

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::current — Get the current element

说明

public IntlIterator::current ( ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get the current key

  • ? IntlIterator::current
  • IntlIterator::next ?
  • PHP Manual
  • IntlIterator
  • Get the current key

IntlIterator::key

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::key — Get the current key

说明

public IntlIterator::key ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Move forward to the next element

  • ? IntlIterator::key
  • IntlIterator::rewind ?
  • PHP Manual
  • IntlIterator
  • Move forward to the next element

IntlIterator::next

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::next — Move forward to the next element

说明

public IntlIterator::next ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Rewind the iterator to the first element

  • ? IntlIterator::next
  • IntlIterator::valid ?
  • PHP Manual
  • IntlIterator
  • Rewind the iterator to the first element

IntlIterator::rewind

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::rewind — Rewind the iterator to the first element

说明

public IntlIterator::rewind ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Check if current position is valid

  • ? IntlIterator::rewind
  • intl 函数 ?
  • PHP Manual
  • IntlIterator
  • Check if current position is valid

IntlIterator::valid

(PHP 5 >= 5.5.0, PHP 7)

IntlIterator::valid — Check if current position is valid

说明

public IntlIterator::valid ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


intl 函数

Table of Contents

  • intl_error_name — Get symbolic name for a given error code
  • intl_get_error_code — Get the last error code
  • intl_get_error_message — Get description of the last error
  • intl_is_failure — Check whether the given error code indicates failure


Get symbolic name for a given error code

  • ? intl 函数
  • intl_get_error_code ?
  • PHP Manual
  • intl 函数
  • Get symbolic name for a given error code

intl_error_name

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_error_name — Get symbolic name for a given error code

说明

intl_error_name ( int $errorCode ) : string

Return ICU error code name.

参数

errorCode

ICU error code.

返回值

The returned string will be the same as the name of the error code constant.

范例

Example #1 intl_error_name() example

<?php
$coll     = collator_create( 'en_RU' );
$err_code = collator_get_error_code( $coll );

printf( "Symbolic name for %d is %s\n.", $err_code, intl_error_name( $err_code ) );
?>

以上例程的输出类似于：

Symbolic name for -128 is U_USING_FALLBACK_WARNING.

参见

  • intl_is_failure() - Check whether the given error code indicates failure
  • intl_get_error_code() - Get the last error code
  • intl_get_error_message() - Get description of the last error


Get the last error code

  • ? intl_error_name
  • intl_get_error_message ?
  • PHP Manual
  • intl 函数
  • Get the last error code

intl_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_get_error_code — Get the last error code

说明

intl_get_error_code ( ) : int

Useful to handle errors occurred in static methods when there's no object to get error code from.

返回值

Error code returned by the last API function call.

范例

Example #1 intl_get_error_code() example

<?php
$coll = collator_create( '<bad_param>' );
if( !$coll ) {
    handle_error( intl_get_error_code() );
}
?>

参见

  • intl_is_failure() - Check whether the given error code indicates failure
  • intl_error_name() - Get symbolic name for a given error code
  • intl_get_error_message() - Get description of the last error
  • collator_get_error_code() - Get collator's last error code
  • numfmt_get_error_code() - Get formatter's last error code


Get description of the last error

  • ? intl_get_error_code
  • intl_is_failure ?
  • PHP Manual
  • intl 函数
  • Get description of the last error

intl_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_get_error_message — Get description of the last error

说明

intl_get_error_message ( ) : string

Get error message from last internationalization function called.

返回值

Description of an error occurred in the last API function call.

范例

Example #1 intl_get_error_message() example

<?php
if( Collator::getAvailableLocales() === false ) {
    show_error( intl_get_error_message() );
}
?>

参见

  • intl_error_name() - Get symbolic name for a given error code
  • intl_get_error_code() - Get the last error code
  • intl_is_failure() - Check whether the given error code indicates failure
  • collator_get_error_message() - Get text for collator's last error code
  • numfmt_get_error_message() - Get formatter's last error message


Check whether the given error code indicates failure

  • ? intl_get_error_message
  • 多字节字符串 ?
  • PHP Manual
  • intl 函数
  • Check whether the given error code indicates failure

intl_is_failure

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_is_failure — Check whether the given error code indicates failure

说明

intl_is_failure ( int $errorCode ) : bool

参数

errorCode

is a value that returned by functions: intl_get_error_code(), collator_get_error_code() .

返回值

true if it the code indicates some failure, and false in case of success or a warning.

范例

Example #1 intl_is_failure() example

<?php
function check( $err_code )
{
    var_export( intl_is_failure( $err_code ) );
    echo "\n";
}

check( U_ZERO_ERROR );
check( U_USING_FALLBACK_WARNING );
check( U_ILLEGAL_ARGUMENT_ERROR );
?>

以上例程的输出类似于：

false
false
true

参见

  • intl_get_error_code() - Get the last error code
  • collator_get_error_code() - Get collator's last error code
  • Collator-getErrorCode() - Get collator's last error code


多字节字符串

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 支持编码的摘要
  • 日文字符多字节编码基础
  • HTTP 输入和输出
  • 支持的字符编码
  • 函数重载功能
  • PHP字符编码的要求
  • 多字节字符串 函数
    • mb_check_encoding — 检查字符串在指定的编码里是否有效
    • mb_chr — Get a specific character
    • mb_convert_case — 对字符串进行大小写转换
    • mb_convert_encoding — 转换字符的编码
    • mb_convert_kana — Convert "kana" one from another ("zen-kaku", "han-kaku" and more)
    • mb_convert_variables — 转换一个或多个变量的字符编码
    • mb_decode_mimeheader — 解码 MIME 头字段中的字符串
    • mb_decode_numericentity — 根据 HTML 数字字符串解码成字符
    • mb_detect_encoding — 检测字符的编码
    • mb_detect_order — 设置/获取 字符编码的检测顺序
    • mb_encode_mimeheader — 为 MIME 头编码字符串
    • mb_encode_numericentity — Encode character to HTML numeric string reference
    • mb_encoding_aliases — Get aliases of a known encoding type
    • mb_ereg_match — Regular expression match for multibyte string
    • mb_ereg_replace_callback — Perform a regular expression search and replace with multibyte support using a callback
    • mb_ereg_replace — Replace regular expression with multibyte support
    • mb_ereg_search_getpos — Returns start point for next regular expression match
    • mb_ereg_search_getregs — Retrieve the result from the last multibyte regular expression match
    • mb_ereg_search_init — Setup string and regular expression for a multibyte regular expression match
    • mb_ereg_search_pos — Returns position and length of a matched part of the multibyte regular expression for a predefined multibyte string
    • mb_ereg_search_regs — Returns the matched part of a multibyte regular expression
    • mb_ereg_search_setpos — Set start point of next regular expression match
    • mb_ereg_search — Multibyte regular expression match for predefined multibyte string
    • mb_ereg — Regular expression match with multibyte support
    • mb_eregi_replace — Replace regular expression with multibyte support ignoring case
    • mb_eregi — Regular expression match ignoring case with multibyte support
    • mb_get_info — 获取 mbstring 的内部设置
    • mb_http_input — 检测 HTTP 输入字符编码
    • mb_http_output — 设置/获取 HTTP 输出字符编码
    • mb_internal_encoding — 设置/获取内部字符编码
    • mb_language — 设置/获取当前的语言
    • mb_list_encodings — 返回所有支持编码的数组
    • mb_ord — Get code point of character
    • mb_output_handler — 在输出缓冲中转换字符编码的回调函数
    • mb_parse_str — 解析 GET/POST/COOKIE 数据并设置全局变量
    • mb_preferred_mime_name — 获取 MIME 字符串
    • mb_regex_encoding — Set/Get character encoding for multibyte regex
    • mb_regex_set_options — Set/Get the default options for mbregex functions
    • mb_scrub — Description
    • mb_send_mail — 发送编码过的邮件
    • mb_split — 使用正则表达式分割多字节字符串
    • mb_str_split — Given a multibyte string, return an array of its characters
    • mb_strcut — 获取字符的一部分
    • mb_strimwidth — 获取按指定宽度截断的字符串
    • mb_stripos — 大小写不敏感地查找字符串在另一个字符串中首次出现的位置
    • mb_stristr — 大小写不敏感地查找字符串在另一个字符串里的首次出现
    • mb_strlen — 获取字符串的长度
    • mb_strpos — 查找字符串在另一个字符串中首次出现的位置
    • mb_strrchr — 查找指定字符在另一个字符串中最后一次的出现
    • mb_strrichr — 大小写不敏感地查找指定字符在另一个字符串中最后一次的出现
    • mb_strripos — 大小写不敏感地在字符串中查找一个字符串最后出现的位置
    • mb_strrpos — 查找字符串在一个字符串中最后出现的位置
    • mb_strstr — 查找字符串在另一个字符串里的首次出现
    • mb_strtolower — 使字符串小写
    • mb_strtoupper — 使字符串大写
    • mb_strwidth — 返回字符串的宽度
    • mb_substitute_character — 设置/获取替代字符
    • mb_substr_count — 统计字符串出现的次数
    • mb_substr — 获取部分字符串


简介

虽然许多语言每个必要字符都能一对一映射到 8 比特（bit）的值，但也有好几种语言需要非常多的字符来书面通讯，以至于它们的编码范围不能仅仅包含在一个字节里（一个字节 Byte 由 8 比特 bit 构成。每一比特仅能包含两种不同的值： 1 或 0。所以，一字节仅能够表示 256 种不同的值，即 2 的八次方）。 开发多字节字符编码方案是为了在基于字节的常规编码系统中表达超过 256 个字符。

在你操作（trim、split、splice 等等）多字节编码的字符串的时候，由于在这种编码方案下，两个或多个连续字节可能只表达了一个字符，所以你需要使用专门的函数。 否则，当你将不能检测多字节字符串的函数应用到这个字符串的时候，它可能无法检测多字节字符的起始位置，并以乱码字符串结尾，基本丢失了它原来的意思。

mbstring 提供了针对多字节字符串的函数，能够帮你处理 PHP 中的多字节编码。 除此以外，mbstring 还能在可能的字符编码之间相互进行编码转换。 为了方便起见，mbstring 设计成了处理基于 Unicode 的编码，类似 UTF-8、UCS-2 及诸多单字节的编码（在以下列出了）。


安装

mbstring 不是一个默认扩展。这意味着它默认没有被激活。 你必须在 configure 选项中显式激活该模块。 详情参见安装这一节。

以下是涉及到 mbstring 的相关配置选项。

  • --enable-mbstring：激活 mbstring 函数。 要使用 mbstring 函数必须启用这个选项。

    libmbfl 对 mbstring 是必要的。 libmbfl 被捆绑到了 mbstring。 如果系统已安装 libmbfl，--with-libmbfl[=DIR] 可以指定使用已安装的库。

  • --disable-mbregex：禁用正则表达式函数中多字节字符的支持。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

mbstring 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mbstring.language | "neutral" | PHP_INI_ALL | PHP_INI_PERDIR 位于 PHP <= 5.2.6
mbstring.detect_order | NULL | PHP_INI_ALL |
mbstring.http_input | "pass" | PHP_INI_ALL |
mbstring.http_output | "pass" | PHP_INI_ALL |
mbstring.internal_encoding | NULL | PHP_INI_ALL |
mbstring.script_encoding | NULL | PHP_INI_ALL | 在 PHP 5.4.0. 中移除， 使用 zend.script_encoding 代替。
mbstring.substitute_character | NULL | PHP_INI_ALL |
mbstring.func_overload | "0" | PHP_INI_SYSTEM | PHP <= 5.2.6 是 PHP_INI_PERDIR。 Deprecated as of PHP 7.2.0; removed as of PHP 8.0.0.
mbstring.encoding_translation | "0" | PHP_INI_PERDIR |
mbstring.http_output_conv_mimetypes | "^(text/|application/xhtml\+xml)" | PHP_INI_ALL | Available as of PHP 5.3.0.
mbstring.strict_detection | "0" | PHP_INI_ALL | 自 PHP 5.1.2 起有效。
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

mbstring.language string

mbstring 使用了国家默认语言设置（NLS）。 注意，该选项自动地定义了 mbstring.internal_encoding 和 mbstring.internal_encoding，在 php.ini 里应当放置在 mbstring.language 之后。

mbstring.encoding_translation bool

为传入的 HTTP 查询启用透明字符编码过滤器，将检测和转换输入的编码为内部字符编码（internal character encoding）。

mbstring.internal_encoding string
Warning

本特性已自 PHP 5.6.0 起废弃。强烈建议不要使用本特性。

定义内部字符的默认编码。

PHP 5.6 及更新版的用户应该将此选项留空，并设置 default_charset 作为代替。

mbstring.http_input string
Warning

本特性已自 PHP 5.6.0 起废弃。强烈建议不要使用本特性。

定义 HTTP 输入字符的默认编码。

PHP 5.6 及更新版的用户应该将此选项留空，并设置 default_charset 作为代替。

mbstring.http_output string
Warning

本特性已自 PHP 5.6.0 起废弃。强烈建议不要使用本特性。

定义 HTTP 输出字符的默认编码。

PHP 5.6 及更新版的用户应该将此选项留空，并设置 default_charset 作为代替。

mbstring.detect_order string

定义字符编码的默认检测顺序。参见 mb_detect_order()。

mbstring.substitute_character string

为无效编码的字符定义替代字符。 参见 mb_substitute_character() ，查看支持的值。

mbstring.func_overload string
Warning

This feature has been DEPRECATED as of PHP 7.2.0, and REMOVED as of PHP 8.0.0. Relying on this feature is highly discouraged.

用 mbstring 对应的函数覆盖单字节版本的函数集。更多信息参见函数的覆盖。

该设置仅能通过 php.ini 文件来修改。

mbstring.http_output_conv_mimetypes string

mbstring.strict_detection bool

使用严格的编码检测。

根据 » HTML4.01 规范，允许 Web 浏览器以页面不同的字符编码来提交表单。 参见用 mb_http_input() 来检测浏览器使用的字符编码。

尽管流行的浏览器能够根据给出的 HTML 文档合理猜测正确的编码，但如果能通过 header() 函数在 HTTP 的 Content-Type 头内或 ini 的 default_charset 里设置适当的 charset 参数则会更佳。

Example #1 php.ini 设置例子

; 设置默认语言
mbstring.language        = Neutral; 设置默认语言 Neutral(UTF-8) (默认的值)
mbstring.language        = English; 设置默认语言为 English
mbstring.language        = Japanese; 设置默认语言为 Japanese

;; 设置内部的默认编码
;; 注意：请确保这个编码能被 PHP 所处理
mbstring.internal_encoding    = UTF-8  ; 设置内部的默认编码为 UTF-8

;; 启用 HTTP 输入编码的转换
mbstring.encoding_translation = On

;; 设置 HTTP 输入的默认编码
;; 注意：脚本不能修改 http_input 的设置
mbstring.http_input           = pass    ; 不转换
mbstring.http_input           = auto    ; 设置 HTTP 输入为 auto
                                ; "auto" 会根据 mbstring.language 自动扩展
mbstring.http_input           = SJIS    ; 设置 HTTP 输入编码为 SJIS
mbstring.http_input           = UTF-8,SJIS,EUC-JP ; 指定顺序

;; 设置 HTTP 输出的默认编码
mbstring.http_output          = pass    ; 不转换
mbstring.http_output          = UTF-8   ; 设置 HTTP 输出编码为 UTF-8

;; 设置字符编码的默认检测顺序
mbstring.detect_order         = auto    ; Set detect order to auto
mbstring.detect_order         = ASCII,JIS,UTF-8,SJIS,EUC-JP ; Specify order

;; 设置默认的替代字符
mbstring.substitute_character = 12307   ; 指定 Unicode 值
mbstring.substitute_character = none    ; 不打印字符
mbstring.substitute_character = long    ; Long 的例子： U+3000,JIS+7E7E

Example #2 php.ini 里 EUC-JP 用户的设置

;; 禁用输出缓冲
output_buffering      = Off

;; 设置 HTTP header 字符编码
default_charset       = EUC-JP

;; 设置默认语言为 Japanese
mbstring.language = Japanese

;; 启用 HTTP 输入编码的转换
mbstring.encoding_translation = On

;; 启用 HTTP 输入转换的编码为 auto
mbstring.http_input   = auto

;; 转换 HTTP 输出的编码为 EUC-JP
mbstring.http_output  = EUC-JP

;; 设置内部编码为 EUC-JP
mbstring.internal_encoding = EUC-JP

;; 不要打印无效的字符
mbstring.substitute_character = none

Example #3 php.ini 里 SJIS 用户的设置

;; 启用输出缓冲
output_buffering     = On

;; 设置 mb_output_handler 来启用输出编码的转换
output_handler       = mb_output_handler

;; 设置 HTTP header 的字符编码
default_charset      = Shift_JIS

;; 设置默认语言为 Japanese
mbstring.language = Japanese

;; 设置 http 输入转换的编码为 auto
mbstring.http_input  = auto

;; 转换成 SJIS
mbstring.http_output = SJIS

;; 设置内部变量为 EUC-JP
mbstring.internal_encoding = EUC-JP

;; 不要打印无效的字符
mbstring.substitute_character = none


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

MB_OVERLOAD_MAIL (integer)
MB_OVERLOAD_STRING (integer)
MB_OVERLOAD_REGEX (integer)
MB_CASE_UPPER (integer)
MB_CASE_LOWER (integer)
MB_CASE_TITLE (integer)


支持编码的摘要

支持编码的摘要
IANA 字符集注册表内的名称 | 相关字符集 | 描述 | 额外的说明
ISO-10646-UCS-4 | ISO 10646 | 31位编码空间的通用字符集，以 ISO/IEC 10646 标准化为 UCS-4。 它和最新的 Unicode 代码映射表保持同步。 | 如果在编码转化程序中使用了这个名字，转换器将尝试识别前缀的 BOM头（字节顺序标记），即表示后续字节的字节序。
ISO-10646-UCS-4 | UCS-4 | 参见以上。 | 和 UCS-4 相比较，字符串总是设为大端序（big endian）的形式。
ISO-10646-UCS-4 | UCS-4 | 参见以上。 | 和 UCS-4 相比较，字符串总是设为小端序（little endian）的形式。
ISO-10646-UCS-2 | UCS-2 | 16位编码空间的通用字符集，以 ISO/IEC 10646 标准化为 UCS-2。它和最新的 Unicode 代码映射表保持同步。 | 如果在编码转化程序中使用了这个名字，转换器将尝试识别前缀的 BOM头（字节顺序标记），即表示后续字节的字节序。
ISO-10646-UCS-2 | UCS-2 | 参见以上。 | 和 UCS-2 相比较，字符串总是设为大端序（big endian）的形式。
ISO-10646-UCS-2 | UCS-2 | 参见以上。 | 和 UCS-2 相比较，字符串总是设为小端序（little endian）的形式。
UTF-32 | Unicode | 32 位单位宽度的 Unicode 转换格式，涉及到了 Unicode 字符集标准。该编码方案和 UCS-4 没有完全相同，因为 Unicode 编码空间限制为 21 位的值。 | 如果在编码转化程序中使用了这个名字，转换器将尝试识别前缀的 BOM头（字节顺序标记），即表示后续字节的字节序。
UTF-32BE | Unicode | 参见以上 | 和 UTF-32 相比较，字符串总是设为大端序（big endian）的形式。
UTF-32LE | Unicode | 参见以上 | 和 UTF-32 相比较，字符串总是设为小端序（little endian）的形式。
UTF-16 | Unicode | 16 位单位宽度的 Unicode 转换格式。值得一记的是，UTF-16 的规格不再和 UCS-2 一样， 因为 Unicode 2.0 引入了代理机制（surrogate mechanism），UTF-16 现在指向了 21 位的编码空间。 | 如果在编码转化程序中使用了这个名字，转换器将尝试识别前缀的 BOM头（字节顺序标记），即表示后续字节的字节序。
UTF-16BE | Unicode | 参见以上。 | 和 UTF-16 相比较，字符串总是设为大端序（big endian）的形式。
UTF-16LE | Unicode | 参见以上。 | 和 UTF-16 相比较，字符串总是设为小端序（little endian）的形式。
UTF-8 | Unicode / UCS | 8 位单位宽度的 Unicode 转换格式。 | none
UTF-7 | Unicode | 一种邮件安全的 Unicode 转换格式，规格是 » RFC2152。 | none
(none) | Unicode | UTF-7 的一种变体，其规格在 » IMAP 协议 中用到了。 | none
US-ASCII (首选 MIME 名称) / iso-ir-6 / ANSI_X3.4-1986 / ISO_646.irv:1991 / ASCII / ISO646-US / us / IBM367 / CP367 / csASCII | ASCII / ISO 646 | 美国标准代码（American Standard Code）是一种常用的 7-bit 信息交换编码。同样，标准化为 ISO 646 国际标准。 | (none)
EUC-JP (首选 MIME 名称) / Extended_UNIX_Code_Packed_Format_for_Japanese / csEUCPkdFmtJapanese | US-ASCII / JIS X0201:1997 (半角假名部分) / JIS X0208:1990 / JIS X0212:1990 的复合 | 就像你所看到的，名字来源于扩展 Extended UNIX Code Packed Format for Japanese 的缩写，该编码常用于 UNIX 或类似平台。原始编码方案 Extended UNIX Code 基于 ISO 2022 而设计。 | EUC-JP 涉及的字符集和 IBM932 / CP932 是不一样的，后者使用于 OS/2® 和 Microsoft® Windows®。 这些平台上的信息交换，使用 EUCJP-WIN 来代替。
Shift_JIS (首选 MIME 名称) / MS_Kanji / csShift_JIS | JIS X0201:1997 / JIS X0208:1997 的复合 | 80 年代初，个人日文文字处理软件进入了市场之时，为了兼容传统编码方案 JIS X 0201:1976，开发了 Shift_JIS。 根据 IANA 对 Shift_JIS 编码集的定义，和 IBM932 / CP932 稍有不同。但 "SJIS"、"Shift_JIS" 的名称常被错误得指向这些编码集。 | 要使用 CP932，使用 SJIS-WIN 作为替代。
(none) | JIS X0201:1997 / JIS X0208:1997 / IBM extensions / NEC extensions 的复合 | 虽然此 "encoding" 使用了 EUC-JP 同样的方案，一些字符集有所不同。 也就是说，一些编码映射到了和 EUC-JP 不同的字符。 | none
Windows-31J / csWindows31J | JIS X0201:1997 / JIS X0208:1997 / IBM extensions / NEC extensions 的符合 | 虽然此 "encoding" 使用了 Shift_JIS 同样的方案，一些字符集有所不同。 也就是说，一些编码映射到了和 Shift_JIS 不同的字符。 | (none)
ISO-2022-JP (首选 MIME 名称) / csISO2022JP | US-ASCII / JIS X0201:1976 / JIS X0208:1978 / JIS X0208:1983 | » RFC1468 | (none)
JIS |  |  |
ISO-8859-1 |  |  |
ISO-8859-2 |  |  |
ISO-8859-3 |  |  |
ISO-8859-4 |  |  |
ISO-8859-5 |  |  |
ISO-8859-6 |  |  |
ISO-8859-7 |  |  |
ISO-8859-8 |  |  |
ISO-8859-9 |  |  |
ISO-8859-10 |  |  |
ISO-8859-13 |  |  |
ISO-8859-14 |  |  |
ISO-8859-15 |  |  |
ISO-8859-16 |  |  |
byte2be |  |  |
byte2le |  |  |
byte4be |  |  |
byte4le |  |  |
BASE64 |  |  |
HTML-ENTITIES |  |  |
7bit |  |  |
8bit |  |  |
EUC-CN |  |  |
CP936 |  |  |
HZ |  |  |
EUC-TW |  |  |
CP950 |  |  |
BIG-5 |  |  |
EUC-KR |  |  |
UHC (CP949) |  |  |
ISO-2022-KR |  |  |
Windows-1251 (CP1251) |  |  |
Windows-1252 (CP1252) |  |  |
CP866 (IBM866) |  |  |
KOI8-R |  |  |
KOI8-U |  |  |


日文字符多字节编码基础

日文字符只能使用多字节编码，而且，编码规范取决于平台和字符的使用 目的（text purpose)。跟糟糕的是，编码规范之间还稍有差异。为了开发 出适应日文环境的Web应用，开发人员必须对编码规范有个清晰的认识，确保 使用了合适的编码规范。

  • 存储一个日文字符最大需要6个字节空间
  • 多数日文多字节字符是单字节字符出现频率的两倍。这些字符被称为 "zen-kaku"，在日文中代表的意思是"full width"。 其它窄一些的字符被称作"han-kaku"，意思是"half width"。 字符实际显示的宽度，取决于显示时使用的字体。
  • 有些字符编码采用ISO-2022定义的转码序列（shift sequences) 来转换特殊的编码 空间(00h to 7fh)。
  • 在SMTP/NNTP协议应用中 建议 采用ISO-2022-JP编码，并且头部和实体部分，应该按照 RFC要求重新编码。虽然这些并不是强制性要求，但最好还是按这个建议做，因为几款 流行的客户端不支持其他的编码方式。
  • 手机服务页面，例如» i-mode或者» EZweb 应该 使用Shift_JIS编码。
  • 从PHP 5.4.0开始，象形字符（pictogram characters ）已经可以支持像 » i-mode 或者 » EZweb 这样的手机服务。


HTTP 输入和输出

HTTP 输入/输出字符编码转换同样也适用于二进制数据。 如果 HTTP 输入/输出用到了二进制数据，用户应当控制字符的编码转换。

Note:

如果 HTML 表单的 enctype 属性设置为 multipart/form-data，并且 php.ini 里的 mbstring.encoding_translation 设置为 On， POST 的变量以及上传文件的名称也将会被转换到内部字符编码。 不过，转换不会应用于查询（query）的键。

  • HTTP 输入

    在 PHP 脚本里无法控制 HTTP 输入字符的转换。 要禁用 HTTP 输入字符的转换，必须要在 php.ini 里设置。

    Example #1 在 php.ini 中禁用 HTTP 输入转换

    ;; 禁用 HTTP 输入转换
mbstring.http_input = pass
;;禁用 HTTP 输入转换
mbstring.encoding_translation = Off

    当 PHP 以 Apache 模块运行。这些设置还可以通过 httpd.conf 内每个虚拟主机（Virtual Host）指令或每个目录下的 .htaccess 来覆盖（override）。 详情参见配置这一节，以及 Apache 手册。

  • HTTP 输出

    输出字符编码转换的使用有几种方式。 一种是使用 php.ini，另一种是使用 ob_start()，以 mb_output_handler() 作为 ob_start 的回调函数。

Example #2 php.ini 设置例子

;; 为所有 PHP 页面启用输出字符编码的转换

;; 启用输出缓冲
output_buffering    = On

;; 设置 mb_output_handler 来进行输出的转换
output_handler      = mb_output_handler

Example #3 脚本例子

<?php

// 仅为此页面启用输出字符编码的转换

// 设置 HTTP 输出字符编码为 SJIS
mb_http_output('SJIS');

// 开始缓冲并指定 "mb_output_handler" 为回调函数
ob_start('mb_output_handler');

?>


支持的字符编码

当前 mbstring 模块支持以下的字符编码。这些字符编码中的任意一个都能指定到 mbstring 函数中的 encoding 参数。

该 PHP 扩展支持的字符编码有以下几种：

  • UCS-4*
  • UCS-4BE
  • UCS-4LE*
  • UCS-2
  • UCS-2BE
  • UCS-2LE
  • UTF-32*
  • UTF-32BE*
  • UTF-32LE*
  • UTF-16*
  • UTF-16BE*
  • UTF-16LE*
  • UTF-7
  • UTF7-IMAP
  • UTF-8*
  • ASCII*
  • EUC-JP*
  • SJIS*
  • eucJP-win*
  • SJIS-win*
  • ISO-2022-JP
  • ISO-2022-JP-MS
  • CP932
  • CP51932
  • SJIS-mac** (别名： MacJapanese)
  • SJIS-Mobile#DOCOMO** (别名： SJIS-DOCOMO)
  • SJIS-Mobile#KDDI** (别名： SJIS-KDDI)
  • SJIS-Mobile#SOFTBANK** (别名： SJIS-SOFTBANK)
  • UTF-8-Mobile#DOCOMO** (别名： UTF-8-DOCOMO)
  • UTF-8-Mobile#KDDI-A**
  • UTF-8-Mobile#KDDI-B** (别名： UTF-8-KDDI)
  • UTF-8-Mobile#SOFTBANK** (别名： UTF-8-SOFTBANK)
  • ISO-2022-JP-MOBILE#KDDI** (别名： ISO-2022-JP-KDDI)
  • JIS
  • JIS-ms
  • CP50220
  • CP50220raw
  • CP50221
  • CP50222
  • ISO-8859-1*
  • ISO-8859-2*
  • ISO-8859-3*
  • ISO-8859-4*
  • ISO-8859-5*
  • ISO-8859-6*
  • ISO-8859-7*
  • ISO-8859-8*
  • ISO-8859-9*
  • ISO-8859-10*
  • ISO-8859-13*
  • ISO-8859-14*
  • ISO-8859-15*
  • ISO-8859-16*
  • byte2be
  • byte2le
  • byte4be
  • byte4le
  • BASE64
  • HTML-ENTITIES
  • 7bit
  • 8bit
  • EUC-CN*
  • CP936
  • GB18030**
  • HZ
  • EUC-TW*
  • CP950
  • BIG-5*
  • EUC-KR*
  • UHC (CP949)
  • ISO-2022-KR
  • Windows-1251 (CP1251)
  • Windows-1252 (CP1252)
  • CP866 (IBM866)
  • KOI8-R*
  • KOI8-U*
  • ArmSCII-8 (ArmSCII8)

* 表示该编码也可以在正则表达式中使用。

** 表示该编码自 PHP 5.4.0 始可用。

任何接受编码名称的 php.ini 条目同样也可以使用 "auto" 和 "pass" 的值。 接受编码名的 mbstring 函数同样也可以使用值 "auto"。

如果设置了 "pass"，将不会对字符的编码进行转化。

如果设置了 "auto"，它将扩展成 NLS 中定义的每个字符编码列表。 比如，假设 NLS 设置为 Japanese，值将会认为是 "ASCII,JIS,UTF-8,EUC-JP,SJIS"。

参见 mb_detect_order()


函数重载功能

Warning

本特性已自 PHP 7.2.0 起废弃。强烈建议不要使用本特性。

你也许常常会发现现存的 PHP 应用很难运行在多字节环境下。 发生这种情况的原因是大多数那种 PHP 应用使用了标准的字符串函数，类似 substr()，已知无法处理多字节编码的字符串。

mbstring 支持一个"函数重载"功能，将对应的多字节版本重载到标准字符处理函数上，例如你能够让这类应用在不修改代码的前提下添加多字节的处理能力。 比如，启用函数重载后，mb_substr() 将会代替 substr() 被调用。 在很多情况下这个功能允许让仅支持单字节编码的应用简单地和多字节环境对接。

要使用函数重载功能，设置 php.ini 里的 mbstring.func_overload 为正值，就是表示为重载函数分类的位掩码组合。 要重载 mail() 函数需要设置它为 1。字符串函数设置为 2，正则表达式函数为 4。 例如，当它设置为 7， mail、strings 和 正则表达式函数将都会被重载。 以下列表显示了重载的函数。

被重载的函数
mbstring.func_overload 的值 | 原始函数 | 重载后的函数
1 | mail() | mb_send_mail()
2 | strlen() | mb_strlen()
2 | strpos() | mb_strpos()
2 | strrpos() | mb_strrpos()
2 | substr() | mb_substr()
2 | strtolower() | mb_strtolower()
2 | strtoupper() | mb_strtoupper()
2 | stripos() | mb_stripos()
2 | strripos() | mb_strripos()
2 | strstr() | mb_strstr()
2 | stristr() | mb_stristr()
2 | strrchr() | mb_strrchr()
2 | substr_count() | mb_substr_count()
4 | ereg() | mb_ereg()
4 | eregi() | mb_eregi()
4 | ereg_replace() | mb_ereg_replace()
4 | eregi_replace() | mb_eregi_replace()
4 | split() | mb_split()

Note:

不推荐每个目录的范围（context）内使用函数重载选项，因为还无法确定在生产环境中是否稳定，也许会导致不确定的行为。


PHP字符编码的要求

以下类型的编码能够被 PHP 安全地使用。

  • 单字节编码

    • ASCII兼容（ISO646 兼容），在 00h 到 7fh 的范围内映射字符集。

  • 多字节编码，

    • ASCII兼容，在 00h 到 7fh 的范围内映射字符集。
    • 不使用 ISO2022 转义序列（escape sequences）。
    • 单个字符以任意复合字节表达、不使用 00h 到 7fh 的值。

有几个不太可能用 PHP 运行的字符编码例子。

JIS, SJIS, ISO-2022-JP, BIG-5

虽然用任何其中一个编码来编写 PHP 脚本可能无法工作，尤其是这些编码的字符串以标识符（identifier）和字符（literal）出现， 但通过设置 mbstring 透明地过滤编码的函数，你几乎可以避免传入的 HTTP 查询使用这些编码。

Note:

我们极度不赞成在内部编码中使用 SJIS、BIG5、CP936、CP949 和 GB18030，除非你熟悉解析器（parser）、扫描器（scanner）和该字符编码。

Note:

当你用 PHP 连接到一个数据库，为了易用性和性能，推荐在数据库和内部编码使用一致的字符编码。

如果你使用的是 PostgreSQL，数据库里使用的编码和 PHP 里使用的编码可以是不同的，因为它支持字符集在前端和后端之间进行自动转换。


多字节字符串 函数

参考资料

多字节字符编码方案和他们相关的问题相当复杂，超越了本文档的范围。 关于这些话题的更多信息请参考以下 URL 和其他资源。

  • Unicode materials

    » http://www.unicode.org/

  • Japanese/Korean/Chinese 字符信息

    » https://resources.oreilly.com/examples/9781565922242/blob/master/doc/cjk.inf

Table of Contents

  • mb_check_encoding — 检查字符串在指定的编码里是否有效
  • mb_chr — Get a specific character
  • mb_convert_case — 对字符串进行大小写转换
  • mb_convert_encoding — 转换字符的编码
  • mb_convert_kana — Convert "kana" one from another ("zen-kaku", "han-kaku" and more)
  • mb_convert_variables — 转换一个或多个变量的字符编码
  • mb_decode_mimeheader — 解码 MIME 头字段中的字符串
  • mb_decode_numericentity — 根据 HTML 数字字符串解码成字符
  • mb_detect_encoding — 检测字符的编码
  • mb_detect_order — 设置/获取 字符编码的检测顺序
  • mb_encode_mimeheader — 为 MIME 头编码字符串
  • mb_encode_numericentity — Encode character to HTML numeric string reference
  • mb_encoding_aliases — Get aliases of a known encoding type
  • mb_ereg_match — Regular expression match for multibyte string
  • mb_ereg_replace_callback — Perform a regular expression search and replace with multibyte support using a callback
  • mb_ereg_replace — Replace regular expression with multibyte support
  • mb_ereg_search_getpos — Returns start point for next regular expression match
  • mb_ereg_search_getregs — Retrieve the result from the last multibyte regular expression match
  • mb_ereg_search_init — Setup string and regular expression for a multibyte regular expression match
  • mb_ereg_search_pos — Returns position and length of a matched part of the multibyte regular expression for a predefined multibyte string
  • mb_ereg_search_regs — Returns the matched part of a multibyte regular expression
  • mb_ereg_search_setpos — Set start point of next regular expression match
  • mb_ereg_search — Multibyte regular expression match for predefined multibyte string
  • mb_ereg — Regular expression match with multibyte support
  • mb_eregi_replace — Replace regular expression with multibyte support ignoring case
  • mb_eregi — Regular expression match ignoring case with multibyte support
  • mb_get_info — 获取 mbstring 的内部设置
  • mb_http_input — 检测 HTTP 输入字符编码
  • mb_http_output — 设置/获取 HTTP 输出字符编码
  • mb_internal_encoding — 设置/获取内部字符编码
  • mb_language — 设置/获取当前的语言
  • mb_list_encodings — 返回所有支持编码的数组
  • mb_ord — Get code point of character
  • mb_output_handler — 在输出缓冲中转换字符编码的回调函数
  • mb_parse_str — 解析 GET/POST/COOKIE 数据并设置全局变量
  • mb_preferred_mime_name — 获取 MIME 字符串
  • mb_regex_encoding — Set/Get character encoding for multibyte regex
  • mb_regex_set_options — Set/Get the default options for mbregex functions
  • mb_scrub — Description
  • mb_send_mail — 发送编码过的邮件
  • mb_split — 使用正则表达式分割多字节字符串
  • mb_str_split — Given a multibyte string, return an array of its characters
  • mb_strcut — 获取字符的一部分
  • mb_strimwidth — 获取按指定宽度截断的字符串
  • mb_stripos — 大小写不敏感地查找字符串在另一个字符串中首次出现的位置
  • mb_stristr — 大小写不敏感地查找字符串在另一个字符串里的首次出现
  • mb_strlen — 获取字符串的长度
  • mb_strpos — 查找字符串在另一个字符串中首次出现的位置
  • mb_strrchr — 查找指定字符在另一个字符串中最后一次的出现
  • mb_strrichr — 大小写不敏感地查找指定字符在另一个字符串中最后一次的出现
  • mb_strripos — 大小写不敏感地在字符串中查找一个字符串最后出现的位置
  • mb_strrpos — 查找字符串在一个字符串中最后出现的位置
  • mb_strstr — 查找字符串在另一个字符串里的首次出现
  • mb_strtolower — 使字符串小写
  • mb_strtoupper — 使字符串大写
  • mb_strwidth — 返回字符串的宽度
  • mb_substitute_character — 设置/获取替代字符
  • mb_substr_count — 统计字符串出现的次数
  • mb_substr — 获取部分字符串


检查字符串在指定的编码里是否有效

  • ? 多字节字符串 函数
  • mb_chr ?
  • PHP Manual
  • 多字节字符串 函数
  • 检查字符串在指定的编码里是否有效

mb_check_encoding

(PHP 4 >= 4.4.3, PHP 5 >= 5.1.3, PHP 7, PHP 8)

mb_check_encoding — 检查字符串在指定的编码里是否有效

说明

mb_check_encoding ( string $var = null , string $encoding = mb_internal_encoding() ) : bool

检查指定的字节流在指定的编码里是否有效。它能有效避免所谓的"无效编码攻击（Invalid Encoding Attack）"。

参数

var

要检查的字节流。如果省略了这个参数，此函数会检查所有来自最初请求所有的输入。

encoding

期望的编码。

返回值

成功时返回 true， 或者在失败时返回 false。


Get a specific character

  • ? mb_check_encoding
  • mb_convert_case ?
  • PHP Manual
  • 多字节字符串 函数
  • Get a specific character

mb_chr

(PHP 7 >= 7.2.0, PHP 8)

mb_chr — Get a specific character

说明

mb_chr ( int $codepoint , string|null $encoding = null ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

codepoint

encoding

返回值

Returns a specific character 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | 现在 encoding 可以为 null。

参见

  • mb_ord() - Get code point of character
  • chr() - 返回指定的字符


对字符串进行大小写转换

  • ? mb_chr
  • mb_convert_encoding ?
  • PHP Manual
  • 多字节字符串 函数
  • 对字符串进行大小写转换

mb_convert_case

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_convert_case — 对字符串进行大小写转换

说明

mb_convert_case ( string $str , int $mode , string $encoding = mb_internal_encoding() ) : string

对一个 string 进行大小写转换，转换模式由 mode 指定。

参数

str

要被转换的 string。

mode

转换的模式。它可以是 MB_CASE_UPPER、 MB_CASE_LOWER 和 MB_CASE_TITLE 的其中一个。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

按 mode 指定的模式转换 string 大小写后的版本。

Unicode

和类似 strtolower()、strtoupper() 的标准大小写转换函数相比， 大小写转换的执行根据 Unicode 字符属性的基础。 因此此函数的行为不受语言环境（locale）设置的影响，能够转换任意具有"字母"属性的字符，例如元音变音A（?）。

更多关于 Unicode 属性的信息，请查看 » http://www.unicode.org/reports/tr21/。

范例

Example #1 mb_convert_case() 例子

<?php
$str = "mary had a Little lamb and she loved it so";
$str = mb_convert_case($str, MB_CASE_UPPER, "UTF-8");
echo $str; // 输出 MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
$str = mb_convert_case($str, MB_CASE_TITLE, "UTF-8");
echo $str; // 输出 Mary Had A Little Lamb And She Loved It So
?>

Example #2 非拉丁 UTF-8 文本的mb_convert_case() 例子

<?php
$str = "Τ?χιστη αλ?πηξ βαφ?? ψημ?νη γη, δρασκελ?ζει υπ?ρ νωθρο? κυν??";
$str = mb_convert_case($str, MB_CASE_UPPER, "UTF-8");
echo $str; // 输出 Τ?ΧΙΣΤΗ ΑΛ?ΠΗΞ ΒΑΦ?Σ ΨΗΜ?ΝΗ ΓΗ, ΔΡΑΣΚΕΛ?ΖΕΙ ΥΠ?Ρ ΝΩΘΡΟ? ΚΥΝ?Σ
$str = mb_convert_case($str, MB_CASE_TITLE, "UTF-8");
echo $str; // 输出 Τ?χιστη Αλ?πηξ Βαφ?σ Ψημ?νη Γη, Δρασκελ?ζει Υπ?ρ Νωθρο? Κυν?σ
?>

参见

  • mb_strtolower() - 使字符串小写
  • mb_strtoupper() - 使字符串大写
  • strtolower() - 将字符串转化为小写
  • strtoupper() - 将字符串转化为大写
  • ucfirst() - 将字符串的首字母转换为大写
  • ucwords() - 将字符串中每个单词的首字母转换为大写


转换字符的编码

  • ? mb_convert_case
  • mb_convert_kana ?
  • PHP Manual
  • 多字节字符串 函数
  • 转换字符的编码

mb_convert_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_convert_encoding — 转换字符的编码

说明

mb_convert_encoding ( string $str , string $to_encoding , mixed $from_encoding = mb_internal_encoding() ) : string

将 string 类型 str 的字符编码从可选的 from_encoding 转换到 to_encoding。

参数

str

要编码的 string。

to_encoding

str 要转换成的编码类型。

from_encoding

在转换前通过字符代码名称来指定。它可以是一个 array 也可以是逗号分隔的枚举列表。 如果没有提供 from_encoding，则会使用内部（internal）编码。

参见支持的编码。

返回值

编码后的 string。

范例

Example #1 mb_convert_encoding() 例子

<?php
/* 转换内部编码为 SJIS */
$str = mb_convert_encoding($str, "SJIS");

/* 将 EUC-JP 转换成 UTF-7 */
$str = mb_convert_encoding($str, "UTF-7", "EUC-JP");

/* 从 JIS, eucjp-win, sjis-win 中自动检测编码，并转换 str 到 UCS-2LE */
$str = mb_convert_encoding($str, "UCS-2LE", "JIS, eucjp-win, sjis-win");

/* "auto" 扩展成 "ASCII,JIS,UTF-8,EUC-JP,SJIS" */
$str = mb_convert_encoding($str, "EUC-JP", "auto");
?>

参见

  • mb_detect_order() - 设置/获取 字符编码的检测顺序


Convert "kana" one from another ("zen-kaku", "han-kaku" and more)

  • ? mb_convert_encoding
  • mb_convert_variables ?
  • PHP Manual
  • 多字节字符串 函数
  • Convert "kana" one from another ("zen-kaku", "han-kaku" and more)

mb_convert_kana

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_convert_kana — Convert "kana" one from another ("zen-kaku", "han-kaku" and more)

说明

mb_convert_kana ( string $string , string $mode = "KV" , string|null $encoding = null ) : string

Performs a "han-kaku" - "zen-kaku" conversion for string string. This function is only useful for Japanese.

参数

string

The string being converted.

mode

The conversion option.

Specify with a combination of following options.

Applicable Conversion Options
Option | Meaning
r | Convert "zen-kaku" alphabets to "han-kaku"
R | Convert "han-kaku" alphabets to "zen-kaku"
n | Convert "zen-kaku" numbers to "han-kaku"
N | Convert "han-kaku" numbers to "zen-kaku"
a | Convert "zen-kaku" alphabets and numbers to "han-kaku"
A | Convert "han-kaku" alphabets and numbers to "zen-kaku" (Characters included in "a", "A" options are U+0021 - U+007E excluding U+0022, U+0027, U+005C, U+007E)
s | Convert "zen-kaku" space to "han-kaku" (U+3000 -> U+0020)
S | Convert "han-kaku" space to "zen-kaku" (U+0020 -> U+3000)
k | Convert "zen-kaku kata-kana" to "han-kaku kata-kana"
K | Convert "han-kaku kata-kana" to "zen-kaku kata-kana"
h | Convert "zen-kaku hira-gana" to "han-kaku kata-kana"
H | Convert "han-kaku kata-kana" to "zen-kaku hira-gana"
c | Convert "zen-kaku kata-kana" to "zen-kaku hira-gana"
C | Convert "zen-kaku hira-gana" to "zen-kaku kata-kana"
V | Collapse voiced sound notation and convert them into a character. Use with "K","H"

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

The converted string.

更新日志

版本 | 说明
8.0.0 | 现在 encoding 可以为 null。

范例

Example #1 mb_convert_kana() example

<?php
/* Convert all "kana" to "zen-kaku" "kata-kana" */
$str = mb_convert_kana($str, "KVC");

/* Convert "han-kaku" "kata-kana" to "zen-kaku" "kata-kana"
   and "zen-kaku" alphanumeric to "han-kaku" */
$str = mb_convert_kana($str, "KVa");
?>


转换一个或多个变量的字符编码

  • ? mb_convert_kana
  • mb_decode_mimeheader ?
  • PHP Manual
  • 多字节字符串 函数
  • 转换一个或多个变量的字符编码

mb_convert_variables

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_convert_variables — 转换一个或多个变量的字符编码

说明

mb_convert_variables ( string $to_encoding , mixed $from_encoding , mixed &$vars , mixed &$... = ? ) : string

将变量 vars 的编码从 from_encoding 转换成编码 to_encoding。

mb_convert_variables() 会拼接变量数组或对象中的字符串来检测编码，因为短字符串的检测往往会失败。因此，不能在一个数组或对象中混合使用编码。

参数

to_encoding

将 string 转换成这个编码。

from_encoding

from_encoding 可以指定为一个 array 或者逗号分隔的 string，它将尝试根据 from-coding 来检测编码。 当省略了 from_encoding，将使用 detect_order。

vars

vars 是要转换的变量的引用。 参数可以接受 String、Array 和 Object 的类型。 mb_convert_variables() 假设所有的参数都具有同样的编码。

...

额外的 vars。

返回值

成功时返回转换前的字符编码，失败时返回 false。

范例

Example #1 mb_convert_variables() 例子

<?php
/* 转换变量 $post1、$post2 编码为内部（internal）编码 */
$interenc = mb_internal_encoding();
$inputenc = mb_convert_variables($interenc, "ASCII,UTF-8,SJIS-win", $post1, $post2);
?>


解码 MIME 头字段中的字符串

  • ? mb_convert_variables
  • mb_decode_numericentity ?
  • PHP Manual
  • 多字节字符串 函数
  • 解码 MIME 头字段中的字符串

mb_decode_mimeheader

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_decode_mimeheader — 解码 MIME 头字段中的字符串

说明

mb_decode_mimeheader ( string $str ) : string

解码 MIME 头中编码过的字符串 str。

参数

str

要解码的 string。

返回值

以内部（internal）字符编码解码的 string。

参见

  • mb_encode_mimeheader() - 为 MIME 头编码字符串


根据 HTML 数字字符串解码成字符

  • ? mb_decode_mimeheader
  • mb_detect_encoding ?
  • PHP Manual
  • 多字节字符串 函数
  • 根据 HTML 数字字符串解码成字符

mb_decode_numericentity

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_decode_numericentity — 根据 HTML 数字字符串解码成字符

说明

mb_decode_numericentity ( string $str , array $convmap , string $encoding = mb_internal_encoding() ) : string

将数字字符串的引用str 按指定的字符块转换成字符串。

参数

str

要解码的 string。

convmap

convmap 是一个 array，指定了要转换的代码区域。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

转换后的字符串。

范例

Example #1 convmap 例子

<?php
$convmap = array (
   int start_code1, int end_code1, int offset1, int mask1,
   int start_code2, int end_code2, int offset2, int mask2,
   ........
   int start_codeN, int end_codeN, int offsetN, int maskN );
// Specify Unicode value for start_codeN and end_codeN
// Add offsetN to value and take bit-wise 'AND' with maskN,
// then convert value to numeric string reference.
?>

参见

  • mb_encode_numericentity() - Encode character to HTML numeric string reference

Example #2 convmap 的例子： 编码(escape) JavaScript 字符串

<?php
function escape_javascript_string($str) {
  $map = [
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,0,0, // 49
          0,0,0,0,0,0,0,0,1,1,
          1,1,1,1,1,0,0,0,0,0,
          0,0,0,0,0,0,0,0,0,0,
          0,0,0,0,0,0,0,0,0,0,
          0,1,1,1,1,1,1,0,0,0, // 99
          0,0,0,0,0,0,0,0,0,0,
          0,0,0,0,0,0,0,0,0,0,
          0,0,0,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1, // 149
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1, // 199
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1,
          1,1,1,1,1,1,1,1,1,1, // 249
          1,1,1,1,1,1,1, // 255
          ];
  // Char encoding is UTF-8
  $mblen = mb_strlen($str, 'UTF-8');
  $utf32 = bin2hex(mb_convert_encoding($str, 'UTF-32', 'UTF-8'));
  for ($i=0, $encoded=''; $i < $mblen; $i++) {
      $u = substr($utf32, $i*8, 8);
      $v = base_convert($u, 16, 10);
      if ($v < 256 && $map[$v]) {
        $encoded .= '\\x'.substr($u, 6,2);
      } else if ($v == 2028) {
        $encoded .= '\\u2028';
      } else if ($v == 2029) {
        $encoded .= '\\u2029';
      } else {
        $encoded .= mb_convert_encoding(hex2bin($u), 'UTF-8', 'UTF-32');
      }
   }
   return $encoded;
}

// Test data
$convmap = [ 0x0, 0xffff, 0, 0xffff ];
$msg = '';
for ($i=0; $i < 1000; $i++) {
  // chr() cannot generate correct UTF-8 data larger value than 128, use mb_decode_numericentity().
  $msg .= mb_decode_numericentity('&#'.$i.';', $convmap, 'UTF-8');
}

// var_dump($msg);
var_dump(escape_javascript_string($msg));


检测字符的编码

  • ? mb_decode_numericentity
  • mb_detect_order ?
  • PHP Manual
  • 多字节字符串 函数
  • 检测字符的编码

mb_detect_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_detect_encoding — 检测字符的编码

说明

mb_detect_encoding ( string $str , mixed $encoding_list = mb_detect_order() , bool $strict = false ) : string

检测字符串 str 的编码。

参数

str

待检查的字符串。

encoding_list

encoding_list 是一个字符编码列表。 编码顺序可以由数组或者逗号分隔的列表字符串指定。

如果省略了 encoding_list 将会使用 detect_order。

strict

strict 指定了是否严格地检测编码。 默认是 false。

返回值

检测到的字符编码，或者无法检测指定字符串的编码时返回 false。

范例

Example #1 mb_detect_encoding() 例子

<?php
/* 使用当前的 detect_order 来检测字符编码 */
echo mb_detect_encoding($str);

/* "auto" 将根据 mbstring.language 来扩展 */
echo mb_detect_encoding($str, "auto");

/* 通过逗号分隔的列表来指定编码列表 encoding_list */
echo mb_detect_encoding($str, "JIS, eucjp-win, sjis-win");

/* 使用数组来指定编码列表 encoding_list  */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
echo mb_detect_encoding($str, $ary);
?>

参见

  • mb_detect_order() - 设置/获取 字符编码的检测顺序


设置/获取 字符编码的检测顺序

  • ? mb_detect_encoding
  • mb_encode_mimeheader ?
  • PHP Manual
  • 多字节字符串 函数
  • 设置/获取 字符编码的检测顺序

mb_detect_order

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_detect_order — 设置/获取 字符编码的检测顺序

说明

mb_detect_order ( mixed $encoding_list = mb_detect_order() ) : mixed

为编码列表 encoding_list 设置自动检测字符编码的顺序。

参数

encoding_list

encoding_list 是一个 array 或者逗号分隔的字符编码列表。 参见支持的编码。

如果省略了 encoding_list 参数，它将返回当前字符编码检测顺序的数组。

该设置会影响 mb_detect_encoding() 和 mb_send_mail()。

mbstring 当前实现了以下编码检测筛选器。 如有以下编码列表的无效字节序列，编码的检测将会失败。

UTF-8, UTF-7, ASCII, EUC-JP,SJIS, eucJP-win, SJIS-win, JIS, ISO-2022-JP

对于 ISO-8859-*，mbstring 总是检测为 ISO-8859-*。

对于 UTF-16、UTF-32、 UCS2 和 UCS4，编码检测总是会失败。

返回值

设置编码检测顺序时候，成功时返回 true，识别时候返回 false。

在获取编码检测顺序的时候，会返回排序过的编码数组。

范例

Example #1 mb_detect_order() 例子

<?php
/* 为检测顺序设置枚举列表 */
mb_detect_order("eucjp-win,sjis-win,UTF-8");

/* 通过数组设置检测顺序 */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
mb_detect_order($ary);

/* 显示当前的检测顺序 */
echo implode(", ", mb_detect_order());
?>

Example #2 案例展示了无效的检测顺序

; 总是检测为 ISO-8859-1
detect_order = ISO-8859-1, UTF-8

; 总是检测为 UTF-8，由于 ASCII/UTF-7 的值对  UTF-8 是有效的
detect_order = UTF-8, ASCII, UTF-7

参见

  • mb_internal_encoding() - 设置/获取内部字符编码
  • mb_http_input() - 检测 HTTP 输入字符编码
  • mb_http_output() - 设置/获取 HTTP 输出字符编码
  • mb_send_mail() - 发送编码过的邮件


为 MIME 头编码字符串

  • ? mb_detect_order
  • mb_encode_numericentity ?
  • PHP Manual
  • 多字节字符串 函数
  • 为 MIME 头编码字符串

mb_encode_mimeheader

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_encode_mimeheader — 为 MIME 头编码字符串

说明

mb_encode_mimeheader ( string $str , string $charset = determined by mb_language() , string $transfer_encoding = "B" , string $linefeed = "\r\n" , int $indent = 0 ) : string

按 MIME 头编码方案将指定的字符串 str 进行编码。

参数

str

要编码的 string。 它的编码应该和 mb_internal_encoding() 一样。

charset

charset 指定了 str 的字符集名。 其默认值由当前的 NLS 设置（mbstring.language）来确定。

transfer_encoding

transfer_encoding 指定了 MIME 的编码方案。 它可以是 "B"（Base64）也可以是 "Q"（Quoted-Printable）。 如果未设置，将回退为 "B"。

linefeed

linefeed 指定了 EOL（行尾）标记，使 mb_encode_mimeheader() 执行了一个换行（» RFC 文档中规定，超过长度的一行将换成多行，当前该长度硬式编码为 74 个字符）。 如果没有设定，则回退为 "\r\n" (CRLF)。

indent

首行缩进（header 里 str 前的字符数目）。

返回值

转换后的字符串版本以 ASCII 形式表达。

范例

Example #1 mb_encode_mimeheader() 例子

<?php
$name = ""; // kanji
$mbox = "kru";
$doma = "gtinn.mon";
$addr = mb_encode_mimeheader($name, "UTF-7", "Q") . " <" . $mbox . "@" . $doma . ">";
echo $addr;
?>

注释

Note:

这个函数没有设计成据更高级上下文的中断点来换行（单词边界等）。 这个特性将导致意外的空格可能会让原始字符串看上去很乱。

参见

  • mb_decode_mimeheader() - 解码 MIME 头字段中的字符串


Encode character to HTML numeric string reference

  • ? mb_encode_mimeheader
  • mb_encoding_aliases ?
  • PHP Manual
  • 多字节字符串 函数
  • Encode character to HTML numeric string reference

mb_encode_numericentity

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_encode_numericentity — Encode character to HTML numeric string reference

说明

mb_encode_numericentity ( string $string , array $map , string|null $encoding = null , bool $hex = false ) : string

Converts specified character codes in string string from character code to HTML numeric character reference.

参数

string

The string being encoded.

map

map is array specifies code area to convert.

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

hex

Whether the returned entity reference should be in hexadecimal notation (otherwise it is in decimal notation).

返回值

The converted string.

更新日志

版本 | 说明
8.0.0 | 现在 encoding 可以为 null。

范例

Example #1 map example

<?php
$convmap = array (
 int start_code1, int end_code1, int offset1, int mask1,
 int start_code2, int end_code2, int offset2, int mask2,
 ........
 int start_codeN, int end_codeN, int offsetN, int maskN );
// Specify Unicode value for start_codeN and end_codeN
// Add offsetN to value and take bit-wise 'AND' with maskN, then
// it converts value to numeric string reference.
?>

Example #2 mb_encode_numericentity() example

<?php
/* Convert Left side of ISO-8859-1 to HTML numeric character reference */
$convmap = array(0x80, 0xff, 0, 0xff);
$str = mb_encode_numericentity($str, $convmap, "ISO-8859-1");

/* Convert user defined SJIS-win code in block 95-104 to numeric
   string reference */
$convmap = array(
       0xe000, 0xe03e, 0x1040, 0xffff,
       0xe03f, 0xe0bb, 0x1041, 0xffff,
       0xe0bc, 0xe0fa, 0x1084, 0xffff,
       0xe0fb, 0xe177, 0x1085, 0xffff,
       0xe178, 0xe1b6, 0x10c8, 0xffff,
       0xe1b7, 0xe233, 0x10c9, 0xffff,
       0xe234, 0xe272, 0x110c, 0xffff,
       0xe273, 0xe2ef, 0x110d, 0xffff,
       0xe2f0, 0xe32e, 0x1150, 0xffff,
       0xe32f, 0xe3ab, 0x1151, 0xffff );
$str = mb_encode_numericentity($str, $convmap, "sjis-win");
?>

参见

  • mb_decode_numericentity() - 根据 HTML 数字字符串解码成字符


Get aliases of a known encoding type

  • ? mb_encode_numericentity
  • mb_ereg_match ?
  • PHP Manual
  • 多字节字符串 函数
  • Get aliases of a known encoding type

mb_encoding_aliases

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

mb_encoding_aliases — Get aliases of a known encoding type

说明

mb_encoding_aliases ( string $encoding ) : array

Returns an array of aliases for a known encoding type.

参数

encoding

The encoding type being checked, for aliases.

返回值

Returns a numerically indexed array of encoding aliases on success, 或者在失败时返回 false

错误／异常

Emits an E_WARNING level error if encoding is unknown.

范例

Example #1 mb_encoding_aliases() example

<?php
$encoding        = 'ASCII';
$known_encodings = mb_list_encodings();

if (in_array($encoding, $known_encodings)) {

    $aliases = mb_encoding_aliases($encoding);
    print_r($aliases);

} else {

    echo "Unknown ($encoding) encoding.\n";

}
?>

以上例程的输出类似于：

Array
(
    [0] => ANSI_X3.4-1968
    [1] => iso-ir-6
    [2] => ANSI_X3.4-1986
    [3] => ISO_646.irv:1991
    [4] => US-ASCII
    [5] => ISO646-US
    [6] => us
    [7] => IBM367
    [8] => cp367
    [9] => csASCII
)

参见

  • mb_list_encodings() - 返回所有支持编码的数组


Regular expression match for multibyte string

  • ? mb_encoding_aliases
  • mb_ereg_replace_callback ?
  • PHP Manual
  • 多字节字符串 函数
  • Regular expression match for multibyte string

mb_ereg_match

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_match — Regular expression match for multibyte string

说明

mb_ereg_match ( string $pattern , string $string , string|null $options = null ) : bool

A regular expression match for a multibyte string

参数

pattern

The regular expression pattern.

string

The string being evaluated.

options

The search option. See mb_regex_set_options() for explanation.

返回值

Returns true if string matches the regular expression pattern, false if not.

更新日志

版本 | 说明
8.0.0 | options is nullable now.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg() - Regular expression match with multibyte support


Perform a regular expression search and replace with multibyte support using a callback

  • ? mb_ereg_match
  • mb_ereg_replace ?
  • PHP Manual
  • 多字节字符串 函数
  • Perform a regular expression search and replace with multibyte support using a callback

mb_ereg_replace_callback

(PHP 5 >= 5.4.1, PHP 7, PHP 8)

mb_ereg_replace_callback — Perform a regular expression search and replace with multibyte support using a callback

说明

mb_ereg_replace_callback ( string $pattern , callable $callback , string $string , string|null $options = null ) : string|false|null

Scans string for matches to pattern, then replaces the matched text with the output of callback function.

The behavior of this function is almost identical to mb_ereg_replace(), except for the fact that instead of replacement parameter, one should specify a callback.

参数

pattern

The regular expression pattern.

Multibyte characters may be used in pattern.

callback

A callback that will be called and passed an array of matched elements in the subject string. The callback should return the replacement string.

You'll often need the callback function for a mb_ereg_replace_callback() in just one place. In this case you can use an anonymous function to declare the callback within the call to mb_ereg_replace_callback(). By doing it this way you have all information for the call in one place and do not clutter the function namespace with a callback function's name not used anywhere else.

string

The string being checked.

options

The search option. See mb_regex_set_options() for explanation.

返回值

The resultant string on success, or false on error. If string is not valid for the current encoding, null is returned.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

更新日志

版本 | 说明
8.0.0 | options is nullable now.
7.1.0 | The function checks whether string is valid for the current encoding.

范例

Example #1 mb_ereg_replace_callback() example

<?php
// this text was used in 2002
// we want to get this up to date for 2003
$text = "April fools day is 04/01/2002\n";
$text.= "Last christmas was 12/24/2001\n";
// the callback function
function next_year($matches)
{
  // as usual: $matches[0] is the complete match
  // $matches[1] the match for the first subpattern
  // enclosed in '(...)' and so on
  return $matches[1].($matches[2]+1);
}
echo mb_ereg_replace_callback(
            "(\d{2}/\d{2}/)(\d{4})",
            "next_year",
            $text);

?>

以上例程会输出：

April fools day is 04/01/2003
Last christmas was 12/24/2002

Example #2 mb_ereg_replace_callback() using anonymous function supported in PHP 5.3.0 or later

<?php
// this text was used in 2002
// we want to get this up to date for 2003
$text = "April fools day is 04/01/2002\n";
$text.= "Last christmas was 12/24/2001\n";

echo mb_ereg_replace_callback(
            "(\d{2}/\d{2}/)(\d{4})",
            function ($matches) {
               return $matches[1].($matches[2]+1);
            },
            $text);
?>

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_replace() - Replace regular expression with multibyte support
  • Anonymous functions


Replace regular expression with multibyte support

  • ? mb_ereg_replace_callback
  • mb_ereg_search_getpos ?
  • PHP Manual
  • 多字节字符串 函数
  • Replace regular expression with multibyte support

mb_ereg_replace

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_replace — Replace regular expression with multibyte support

说明

mb_ereg_replace ( string $pattern , string $replacement , string $string , string|null $options = null ) : string|false|null

Scans string for matches to pattern, then replaces the matched text with replacement

参数

pattern

The regular expression pattern.

Multibyte characters may be used in pattern.

replacement

The replacement text.

string

The string being checked.

options
The search option. See mb_regex_set_options() for explanation.

返回值

The resultant string on success, or false on error. If string is not valid for the current encoding, null is returned.

更新日志

版本 | 说明
8.0.0 | options is nullable now.
7.1.0 | The function checks whether string is valid for the current encoding.
7.1.0 | The e modifier has been deprecated.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

Warning

处理非信任的输入时从不使用 e 修饰符，就不会转码（即调用 preg_replace()）。不注意这些会很可能会导致应用程序引发远程代码执行的漏洞。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_eregi_replace() - Replace regular expression with multibyte support ignoring case


Returns start point for next regular expression match

  • ? mb_ereg_replace
  • mb_ereg_search_getregs ?
  • PHP Manual
  • 多字节字符串 函数
  • Returns start point for next regular expression match

mb_ereg_search_getpos

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_getpos — Returns start point for next regular expression match

说明

mb_ereg_search_getpos ( ) : int

Returns the start point for the next regular expression match.

参数

此函数没有参数。

返回值

mb_ereg_search_getpos() returns
the point to start regular expression match for
mb_ereg_search(),
mb_ereg_search_pos(),
mb_ereg_search_regs(). The position is
represented by bytes from the head of string.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_search_setpos() - Set start point of next regular expression match


Retrieve the result from the last multibyte regular expression match

  • ? mb_ereg_search_getpos
  • mb_ereg_search_init ?
  • PHP Manual
  • 多字节字符串 函数
  • Retrieve the result from the last multibyte regular expression match

mb_ereg_search_getregs

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_getregs — Retrieve the result from the last multibyte regular expression match

说明

mb_ereg_search_getregs ( ) : array|false

Retrieve the result from the last multibyte regular expression match

参数

此函数没有参数。

返回值

An array including the sub-string of matched part by last mb_ereg_search(), mb_ereg_search_pos(), mb_ereg_search_regs(). If there are some matches, the first element will have the matched sub-string, the second element will have the first part grouped with brackets, the third element will have the second part grouped with brackets, and so on. It returns false on error.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_search_init() - Setup string and regular expression for a multibyte regular expression match


Setup string and regular expression for a multibyte regular expression match

  • ? mb_ereg_search_getregs
  • mb_ereg_search_pos ?
  • PHP Manual
  • 多字节字符串 函数
  • Setup string and regular expression for a multibyte regular expression match

mb_ereg_search_init

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_init — Setup string and regular expression for a multibyte regular expression match

说明

mb_ereg_search_init ( string $string , string|null $pattern = null , string|null $options = null ) : bool

mb_ereg_search_init() sets
string and pattern
for a multibyte regular expression. These values are used for
mb_ereg_search(),
mb_ereg_search_pos(), and
mb_ereg_search_regs().

参数

string

The search string.

pattern

The search pattern.

options

The search option. See mb_regex_set_options() for explanation.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | pattern and options are nullable now.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_search_regs() - Returns the matched part of a multibyte regular expression


Returns position and length of a matched part of the multibyte regular expression for a predefined multibyte string

  • ? mb_ereg_search_init
  • mb_ereg_search_regs ?
  • PHP Manual
  • 多字节字符串 函数
  • Returns position and length of a matched part of the multibyte regular expression for a predefined multibyte string

mb_ereg_search_pos

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_pos — Returns position and length of a matched part of the multibyte regular expression for a predefined multibyte string

说明

mb_ereg_search_pos ( string|null $pattern = null , string|null $options = null ) : array|false

Returns position and length of a matched part of the multibyte regular expression for a predefined multibyte string

The string for match is specified by mb_ereg_search_init(). If it is not specified, the previous one will be used.

参数

pattern

The search pattern.

options

The search option. See mb_regex_set_options() for explanation.

返回值

An array containing two elements. The first element is the offset, in bytes, where the match begins relative to the start of the search string, and the second element is the length in bytes of the match.

If an error occurs, false is returned.

更新日志

版本 | 说明
8.0.0 | pattern and options are nullable now.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_search_init() - Setup string and regular expression for a multibyte regular expression match


Returns the matched part of a multibyte regular expression

  • ? mb_ereg_search_pos
  • mb_ereg_search_setpos ?
  • PHP Manual
  • 多字节字符串 函数
  • Returns the matched part of a multibyte regular expression

mb_ereg_search_regs

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_regs — Returns the matched part of a multibyte regular expression

说明

mb_ereg_search_regs ( string|null $pattern = null , string|null $options = null ) : array|false

Returns the matched part of a multibyte regular expression.

参数

pattern

The search pattern.

options

The search option. See mb_regex_set_options() for explanation.

返回值

mb_ereg_search_regs() executes the multibyte regular expression match, and if there are some matched part, it returns an array including substring of matched part as first element, the first grouped part with brackets as second element, the second grouped part as third element, and so on. It returns false on error.

更新日志

版本 | 说明
8.0.0 | pattern and options are nullable now.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_search_init() - Setup string and regular expression for a multibyte regular expression match


Set start point of next regular expression match

  • ? mb_ereg_search_regs
  • mb_ereg_search ?
  • PHP Manual
  • 多字节字符串 函数
  • Set start point of next regular expression match

mb_ereg_search_setpos

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search_setpos — Set start point of next regular expression match

说明

mb_ereg_search_setpos ( int $offset ) : bool

mb_ereg_search_setpos() sets the starting point of a match for mb_ereg_search().

参数

offset

The position to set. If it is negative, it counts from the end of the string.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.1.0 | Support for negative offsets has been added.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_search_init() - Setup string and regular expression for a multibyte regular expression match


Multibyte regular expression match for predefined multibyte string

  • ? mb_ereg_search_setpos
  • mb_ereg ?
  • PHP Manual
  • 多字节字符串 函数
  • Multibyte regular expression match for predefined multibyte string

mb_ereg_search

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg_search — Multibyte regular expression match for predefined multibyte string

说明

mb_ereg_search ( string|null $pattern = null , string|null $options = null ) : bool

Performs a multibyte regular expression match for a predefined multibyte string.

参数

pattern

The search pattern.

options

The search option. See mb_regex_set_options() for explanation.

返回值

mb_ereg_search() returns true if the multibyte string matches with the regular expression, or false otherwise. The string for matching is set by mb_ereg_search_init(). If pattern is not specified, the previous one is used.

更新日志

版本 | 说明
8.0.0 | pattern and options are nullable now.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_search_init() - Setup string and regular expression for a multibyte regular expression match


Regular expression match with multibyte support

  • ? mb_ereg_search
  • mb_eregi_replace ?
  • PHP Manual
  • 多字节字符串 函数
  • Regular expression match with multibyte support

mb_ereg

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_ereg — Regular expression match with multibyte support

说明

mb_ereg ( string $pattern , string $string , array &$matches = null ) : bool

Executes the regular expression match with multibyte support.

参数

pattern

The search pattern.

string

The search string.

matches

If matches are found for parenthesized substrings of pattern and the function is called with the third argument matches, the matches will be stored in the elements of the array matches. If no matches are found, matches is set to an empty array.

$matches[1] will contain the substring which starts at the first left parenthesis; $matches[2] will contain the substring starting at the second, and so on. $matches[0] will contain a copy of the complete string matched.

返回值

Returns whether pattern matches string.

更新日志

版本 | 说明
8.0.0 | This function returns true on success now. Previously, it returned the byte length of the matched string if a match for pattern was found in string and matches was passed. If the optional parameter matches was not passed or the length of the matched string was 0, this function returned 1.
7.1.0 | mb_ereg() will now set matches to an empty array, if nothing matched. Formerly, matches was not modified in that case.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_eregi() - Regular expression match ignoring case with multibyte support


Replace regular expression with multibyte support ignoring case

  • ? mb_ereg
  • mb_eregi ?
  • PHP Manual
  • 多字节字符串 函数
  • Replace regular expression with multibyte support ignoring case

mb_eregi_replace

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_eregi_replace — Replace regular expression with multibyte support ignoring case

说明

mb_eregi_replace ( string $pattern , string $replacement , string $string , string|null $options = null ) : string|false|null

Scans string for matches to pattern, then replaces the matched text with replacement.

参数

pattern

The regular expression pattern. Multibyte characters may be used. The case will be ignored.

replacement

The replacement text.

string

The searched string.

options
The search option. See mb_regex_set_options() for explanation.

返回值

The resultant string or false on error. If string is not valid for the current encoding, null is returned.

更新日志

版本 | 说明
8.0.0 | options is nullable now.
7.1.0 | The function checks whether string is valid for the current encoding.
7.1.0 | The e modifier has been deprecated.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

Warning

处理非信任的输入时从不使用 e 修饰符，就不会转码（即调用 preg_replace()）。不注意这些会很可能会导致应用程序引发远程代码执行的漏洞。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg_replace() - Replace regular expression with multibyte support


Regular expression match ignoring case with multibyte support

  • ? mb_eregi_replace
  • mb_get_info ?
  • PHP Manual
  • 多字节字符串 函数
  • Regular expression match ignoring case with multibyte support

mb_eregi

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_eregi — Regular expression match ignoring case with multibyte support

说明

mb_eregi ( string $pattern , string $string , array &$matches = null ) : bool

Executes the case insensitive regular expression match with multibyte support.

参数

pattern

The regular expression pattern.

string

The string being searched.

matches

If matches are found for parenthesized substrings of pattern and the function is called with the third argument matches, the matches will be stored in the elements of the array matches. If no matches are found, matches is set to an empty array.

$matches[1] will contain the substring which starts at the first left parenthesis; $matches[2] will contain the substring starting at the second, and so on. $matches[0] will contain a copy of the complete string matched.

返回值

Returns whether pattern matches string.

更新日志

版本 | 说明
8.0.0 | This function returns true on success now. Previously, it returned the byte length of the matched string if a match for pattern was found in string and matches was passed. If the optional parameter matches was not passed or the length of the matched string was 0, this function returned 1.
7.1.0 | mb_eregi() will now set matches to an empty array, if nothing matched. Formerly, matches was not modified in that case.

注释

Note:

mb_regex_encoding() 指定的内部编码或字符编码将会当作此函数用的字符编码。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg() - Regular expression match with multibyte support


获取 mbstring 的内部设置

  • ? mb_eregi
  • mb_http_input ?
  • PHP Manual
  • 多字节字符串 函数
  • 获取 mbstring 的内部设置

mb_get_info

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_get_info — 获取 mbstring 的内部设置

说明

mb_get_info ( string $type = "all" ) : mixed

mb_get_info() 返回 mbstring 参数的内部设定。

参数

type

如果没有设定 type 或者将其设定为 "all" 将会返回以下内容 "internal_encoding", "http_input", "http_output", "http_output_conv_mimetypes", "mail_charset", "mail_header_encoding", "mail_body_encoding", "illegal_chars", "encoding_translation", "language", "detect_order", "substitute_character" 和 "strict_detection"。

如果 type 设定为类似 "internal_encoding", "http_input", "http_output", "http_output_conv_mimetypes", "mail_charset", "mail_header_encoding", "mail_body_encoding", "illegal_chars", "encoding_translation", "language", "detect_order", "substitute_character" 或 "strict_detection"，将返回该参数的设置。

返回值

如果没有指定 type 将返回类型信息的数组，否则将返回指定 type 的信息。 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 参数 type 中的 "func_overload" 和 "func_overload_list" 不再被支持。

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_http_output() - 设置/获取 HTTP 输出字符编码


检测 HTTP 输入字符编码

  • ? mb_get_info
  • mb_http_output ?
  • PHP Manual
  • 多字节字符串 函数
  • 检测 HTTP 输入字符编码

mb_http_input

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_http_input — 检测 HTTP 输入字符编码

说明

mb_http_input ( string $type = "" ) : mixed

检测 HTTP 输入字符的编码。

参数

type

设置的字符串指定了输入类型。 "G" 是 GET，"P" 是 POST，"C" 是 COOKIE，"S" 是 string，"L" 是 list，以及 "I" 是整个列表（将会返回 array）。 如果省略了 type，它将返回最后处理的一种输入类型。

返回值

每个 type 的字符编码名称。 如果 mb_http_input() 没有处理过任何指定的 HTTP 输入，它将返回 false。

参见

  • mb_internal_encoding() - 设置/获取内部字符编码
  • mb_http_output() - 设置/获取 HTTP 输出字符编码
  • mb_detect_order() - 设置/获取 字符编码的检测顺序


设置/获取 HTTP 输出字符编码

  • ? mb_http_input
  • mb_internal_encoding ?
  • PHP Manual
  • 多字节字符串 函数
  • 设置/获取 HTTP 输出字符编码

mb_http_output

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_http_output — 设置/获取 HTTP 输出字符编码

说明

mb_http_output ( string $encoding = mb_http_output() ) : mixed

设置/获取 HTTP 输出字符编码。此函数被调用之后输出的内容会被转换成 encoding。

参数

encoding

如果设置了 encoding，mb_http_output() 设置 HTTP 输出字符编码为 encoding。

如果省略了 encoding，mb_http_output() 返回当前的 HTTP 输出字符编码。

返回值

如果省略了 encoding，mb_http_output() 返回当前的 HTTP 输出字符编码。 否则成功时返回 true， 或者在失败时返回 false。

参见

  • mb_internal_encoding() - 设置/获取内部字符编码
  • mb_http_input() - 检测 HTTP 输入字符编码
  • mb_detect_order() - 设置/获取 字符编码的检测顺序


设置/获取内部字符编码

  • ? mb_http_output
  • mb_language ?
  • PHP Manual
  • 多字节字符串 函数
  • 设置/获取内部字符编码

mb_internal_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_internal_encoding — 设置/获取内部字符编码

说明

mb_internal_encoding ( string $encoding = mb_internal_encoding() ) : mixed

设置/获取内部字符编码

参数

encoding

encoding 字符编码名称使用于 HTTP 输入字符编码转换、HTTP 输出字符编码转换、mbstring 模块系列函数字符编码转换的默认编码。 You should notice that the internal encoding is totally different from the one for multibyte regex.

返回值

如果设置了 encoding，则成功时返回 true， 或者在失败时返回 false。 In this case, the character encoding for multibyte regex is NOT changed. 如果省略了 encoding，则返回当前的字符编码名称。

范例

Example #1 mb_internal_encoding() 例子

<?php
/* 设置内部字符编码为 UTF-8 */
mb_internal_encoding("UTF-8");

/* 显示当前的内部字符编码*/
echo mb_internal_encoding();
?>

参见

  • mb_http_input() - 检测 HTTP 输入字符编码
  • mb_http_output() - 设置/获取 HTTP 输出字符编码
  • mb_detect_order() - 设置/获取 字符编码的检测顺序
  • mb_regex_encoding() - Set/Get character encoding for multibyte regex


设置/获取当前的语言

  • ? mb_internal_encoding
  • mb_list_encodings ?
  • PHP Manual
  • 多字节字符串 函数
  • 设置/获取当前的语言

mb_language

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_language — 设置/获取当前的语言

说明

mb_language ( string $language = mb_language() ) : mixed

设置/获取当前的语言。

参数

language

用于编码邮件信息。有效的语言有："Japanese","ja","English","en" 和 "uni"（UTF-8）。 mb_send_mail() 使用了该设置来对邮件进行编码。

语言和它的设置，日文是 ISO-2022-JP/Base64，uni 是 UTF-8/Base64，英文是 ISO-8859-1/quoted。

返回值

如果设置了 language，并且 language 是有效的，它将返回 true。否则将返回 false。 当省略了 language 参数，它将返回语言名称的 string。如果之前没有设置过语言，则将返回 false。

参见

  • mb_send_mail() - 发送编码过的邮件


返回所有支持编码的数组

  • ? mb_language
  • mb_ord ?
  • PHP Manual
  • 多字节字符串 函数
  • 返回所有支持编码的数组

mb_list_encodings

(PHP 5, PHP 7, PHP 8)

mb_list_encodings — 返回所有支持编码的数组

说明

mb_list_encodings ( ) : array

返回所有支持编码的数组。

参数

此函数没有参数。

返回值

返回一个数字索引数组。

错误／异常

该函数不会触发任何错误。

范例

Example #1 mb_list_encodings() 例子

<?php

print_r(mb_list_encodings());

?>

以上例程的输出类似于：

Array
(
    [0] => pass
    [1] => auto
    [2] => wchar
    [3] => byte2be
    [4] => byte2le
    [5] => byte4be
    [6] => byte4le
    [7] => BASE64
    [8] => UUENCODE
    [9] => HTML-ENTITIES
    [10] => Quoted-Printable
    [11] => 7bit
    [12] => 8bit
    [13] => UCS-4
    [14] => UCS-4BE
    [15] => UCS-4LE
    [16] => UCS-2
    [17] => UCS-2BE
    [18] => UCS-2LE
    [19] => UTF-32
    [20] => UTF-32BE
    [21] => UTF-32LE
    [22] => UTF-16
    [23] => UTF-16BE
    [24] => UTF-16LE
    [25] => UTF-8
    [26] => UTF-7
    [27] => UTF7-IMAP
    [28] => ASCII
    [29] => EUC-JP
    [30] => SJIS
    [31] => eucJP-win
    [32] => SJIS-win
    [33] => JIS
    [34] => ISO-2022-JP
    [35] => Windows-1252
    [36] => ISO-8859-1
    [37] => ISO-8859-2
    [38] => ISO-8859-3
    [39] => ISO-8859-4
    [40] => ISO-8859-5
    [41] => ISO-8859-6
    [42] => ISO-8859-7
    [43] => ISO-8859-8
    [44] => ISO-8859-9
    [45] => ISO-8859-10
    [46] => ISO-8859-13
    [47] => ISO-8859-14
    [48] => ISO-8859-15
    [49] => EUC-CN
    [50] => CP936
    [51] => HZ
    [52] => EUC-TW
    [53] => BIG-5
    [54] => EUC-KR
    [55] => UHC
    [56] => ISO-2022-KR
    [57] => Windows-1251
    [58] => CP866
    [59] => KOI8-R
)


Get code point of character

  • ? mb_list_encodings
  • mb_output_handler ?
  • PHP Manual
  • 多字节字符串 函数
  • Get code point of character

mb_ord

(PHP 7 >= 7.2.0, PHP 8)

mb_ord — Get code point of character

说明

mb_ord ( string $string , string|null $encoding = null ) : int|false

Warning

本函数还未编写文档，仅有参数列表。

参数

string

encoding

返回值

Returns a code point of character 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | 现在 encoding 可以为 null。

参见

  • mb_chr() - Get a specific character
  • ord() - 转换字符串第一个字节为 0-255 之间的值


在输出缓冲中转换字符编码的回调函数

  • ? mb_ord
  • mb_parse_str ?
  • PHP Manual
  • 多字节字符串 函数
  • 在输出缓冲中转换字符编码的回调函数

mb_output_handler

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_output_handler — 在输出缓冲中转换字符编码的回调函数

说明

mb_output_handler ( string $contents , int $status ) : string

mb_output_handler() 是一个
ob_start() 回调函数。
mb_output_handler() 将输出缓冲中的字符从内部字符编码转换为 HTTP 输出的字符编码。

参数

contents

输出缓冲的内容。

status

输出缓冲的状态。

返回值

转换后的 string。

更新日志

版本 说明
4.1.0

当遇到以下条件的时候，该函数将添加 HTTP 字符编码头：

  • 未使用 header() 设置 Content-Type。
  • 默认 MIME 类型以 text/ 开始。
  • mbstring.http_input 是除 pass 外的任意设置。

范例

Example #1 mb_output_handler() 例子

<?php
mb_http_output("UTF-8");
ob_start("mb_output_handler");
?>

注释

Note:

如果你想要输出二进制数据，比如图片，必须在任何二进制数据发送到客户端之前使用 header() 来设置 Content-Type: 头。（例如 header("Content-Type: image/png")）。 如果 Content-Type: 头已发送，输出字符编码的转换将不会执行。

注意，如果发送了 'Content-Type: text/*'，则内容被认为是文本，将发生转换。

参见

  • ob_start() - 打开输出控制缓冲


解析 GET/POST/COOKIE 数据并设置全局变量

  • ? mb_output_handler
  • mb_preferred_mime_name ?
  • PHP Manual
  • 多字节字符串 函数
  • 解析 GET/POST/COOKIE 数据并设置全局变量

mb_parse_str

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_parse_str — 解析 GET/POST/COOKIE 数据并设置全局变量

说明

mb_parse_str ( string $encoded_string , array &$result = ? ) : bool

解析 GET/POST/COOKIE 数据并设置全局变量。 由于 PHP 不提供原始 POST/COOKIE 数据，目前它仅能够用于 GET 数据。 它解析了 URL 编码过的数据，检测其编码，并转换编码为内部编码，然后设置其值为 array 的 result 或者全局变量。

参数

encoded_string

URL 编码过的数据。

result

一个 array，包含解码过的、编码转换后的值。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mb_detect_order() - 设置/获取 字符编码的检测顺序
  • mb_internal_encoding() - 设置/获取内部字符编码


获取 MIME 字符串

  • ? mb_parse_str
  • mb_regex_encoding ?
  • PHP Manual
  • 多字节字符串 函数
  • 获取 MIME 字符串

mb_preferred_mime_name

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_preferred_mime_name — 获取 MIME 字符串

说明

mb_preferred_mime_name ( string $encoding ) : string

获取指定编码的 MIME 字符 string。

参数

encoding

要检查的字符串。

返回值

字符编码 encoding 的 MIME charset string。

范例

Example #1 mb_preferred_mime_name() 例子

<?php
$outputenc = "sjis-win";
mb_http_output($outputenc);
ob_start("mb_output_handler");
header("Content-Type: text/html; charset=" . mb_preferred_mime_name($outputenc));
?>


Set/Get character encoding for multibyte regex

  • ? mb_preferred_mime_name
  • mb_regex_set_options ?
  • PHP Manual
  • 多字节字符串 函数
  • Set/Get character encoding for multibyte regex

mb_regex_encoding

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_regex_encoding — Set/Get character encoding for multibyte regex

说明

mb_regex_encoding ( string|null $encoding = null ) : string|bool

Set/Get character encoding for a multibyte regex.

参数

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

If encoding is set, then 成功时返回 true， 或者在失败时返回 false。 In this case, the internal character encoding is NOT changed. If encoding is omitted, then the current character encoding name for a multibyte regex is returned.

更新日志

版本 | 说明
8.0.0 | 现在 encoding 可以为 null。
5.6.0 | Default encoding is changed to UTF-8. It was EUC-JP Previously.

参见

  • mb_internal_encoding() - 设置/获取内部字符编码
  • mb_ereg() - Regular expression match with multibyte support


Set/Get the default options for mbregex functions

  • ? mb_regex_encoding
  • mb_scrub ?
  • PHP Manual
  • 多字节字符串 函数
  • Set/Get the default options for mbregex functions

mb_regex_set_options

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_regex_set_options — Set/Get the default options for mbregex functions

说明

mb_regex_set_options ( string|null $options = null ) : string

Sets the default options described by options for multibyte regex functions.

参数

options

The options to set. This is a string where each character is an option. To set a mode, the mode character must be the last one set, however there can only be set one mode but multiple options.

Regex options
Option | Meaning
i | Ambiguity match on
x | Enables extended pattern form
m | '.' matches with newlines
s | '^' -> '\A', '$' -> '\Z'
p | Same as both the m and s options
l | Finds longest matches
n | Ignores empty matches
e | eval() resulting code
Regex syntax modes
Mode | Meaning
j | Java (Sun java.util.regex)
u | GNU regex
g | grep
c | Emacs
r | Ruby
z | Perl
b | POSIX Basic regex
d | POSIX Extended regex

返回值

The previous options. If options is omitted or null, it returns the string that describes the current options.

更新日志

版本 | 说明
8.0.0 | If the parameter options is given and not null, the previous options are returned. Formerly, the current options have been returned.
8.0.0 | options is nullable now.

参见

  • mb_split() - 使用正则表达式分割多字节字符串
  • mb_ereg() - Regular expression match with multibyte support
  • mb_eregi() - Regular expression match ignoring case with multibyte support


Description

  • ? mb_regex_set_options
  • mb_send_mail ?
  • PHP Manual
  • 多字节字符串 函数
  • Description

mb_scrub

(PHP 7 >= 7.2.0, PHP 8)

mb_scrub — Description

说明

mb_scrub ( string $string , string|null $encoding = null ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

string

encoding

返回值

更新日志

版本 | 说明
8.0.0 | 现在 encoding 可以为 null。


发送编码过的邮件

  • ? mb_scrub
  • mb_split ?
  • PHP Manual
  • 多字节字符串 函数
  • 发送编码过的邮件

mb_send_mail

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_send_mail — 发送编码过的邮件

说明

mb_send_mail ( string $to , string $subject , string $message , string $additional_headers = null , string $additional_parameter = null ) : bool

发送邮件。邮件头和内容根据 mb_language() 设置来转换编码。 这是 mail() 的一个包装器函数，所以详情参见 mail()。

参数

to

被发送到该邮件地址。可通过逗号分隔地址的 to 来指定多个收件人。 该参数不会被自动编码。

subject

邮件标题。

message

邮件消息。

additional_headers(可选)

String to be inserted at the end of the email header.

This is typically used to add extra headers (From, Cc, and Bcc). Multiple extra headers should be separated with a CRLF (\r\n). Validate parameter not to be injected unwanted headers by attackers.

Note:

When sending mail, the mail must contain a From header. This can be set with the additional_headers parameter, or a default can be set in php.ini.

Failing to do this will result in an error message similar to Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing. The From header sets also Return-Path under Windows.

Note:

If messages are not received, try using a LF (\n) only. Some Unix mail transfer agents (most notably » qmail) replace LF by CRLF automatically (which leads to doubling CR if CRLF is used). This should be a last resort, as it does not comply with » RFC 2822.

additional_parameter

additional_parameter 是一个 MTA 命令行参数。 在使用 sendmail 时对设置正确的返回路径头很有帮助。

This parameter is escaped by escapeshellcmd() internally to prevent command execution. escapeshellcmd() prevents command execution, but allows to add addtional parameters. For security reason, this parameter should be validated.

Since escapeshellcmd() is applied automatically, some characters that are allowed as email addresses by internet RFCs cannot be used. Programs that are required to use these characters mail() cannot be used.

The user that the webserver runs as should be added as a trusted user to the sendmail configuration to prevent a 'X-Warning' header from being added to the message when the envelope sender (-f) is set using this method. For sendmail users, this file is /etc/mail/trusted-users.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mail() - 发送邮件
  • mb_encode_mimeheader() - 为 MIME 头编码字符串
  • mb_language() - 设置/获取当前的语言


使用正则表达式分割多字节字符串

  • ? mb_send_mail
  • mb_str_split ?
  • PHP Manual
  • 多字节字符串 函数
  • 使用正则表达式分割多字节字符串

mb_split

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

mb_split — 使用正则表达式分割多字节字符串

说明

mb_split ( string $pattern , string $string , int $limit = -1 ) : array

使用正则表达式 pattern 分割多字节 string 并返回结果 array。

参数

pattern

正则表达式。

string

待分割的 string。

limit
如果指定了可选参数 limit，将最多分割为 limit 个元素。

返回值

array 的结果。

注释

Note:

The character encoding specified by mb_regex_encoding() will be used as the character encoding for this function by default.

参见

  • mb_regex_encoding() - Set/Get character encoding for multibyte regex
  • mb_ereg() - Regular expression match with multibyte support


Given a multibyte string, return an array of its characters

  • ? mb_split
  • mb_strcut ?
  • PHP Manual
  • 多字节字符串 函数
  • Given a multibyte string, return an array of its characters

mb_str_split

(PHP 7 >= 7.4.0, PHP 8)

mb_str_split — Given a multibyte string, return an array of its characters

说明

mb_str_split ( string $string , int $length = 1 , string|null $encoding = null ) : array

This function will return an array of strings, it is a version of str_split() with support for encodings of variable character size as well as fixed-size encodings of 1,2 or 4 byte characters. If the length parameter is specified, the string is broken down into chunks of the specified length in characters (not bytes). The encoding parameter can be optionally specified and it is good practice to do so.

参数

string

The string to split into characters or chunks.

length

If specified, each element of the returned array will be composed of multiple characters instead of a single character.

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

A string specifying one of the supported encodings.

返回值

mb_str_split() returns an array of strings.

更新日志

版本 | 说明
8.0.0 | 现在 encoding 可以为 null。
8.0.0 | This function no longer returns false on failure.

参见

  • str_split() - 将字符串转换为数组


获取字符的一部分

  • ? mb_str_split
  • mb_strimwidth ?
  • PHP Manual
  • 多字节字符串 函数
  • 获取字符的一部分

mb_strcut

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strcut — 获取字符的一部分

说明

mb_strcut ( string $str , int $start , int $length = NULL , string $encoding = mb_internal_encoding() ) : string

mb_strcut() 和 mb_substr() 类似，都是从字符串中提取子字符串，但是按字节数来执行，而不是字符个数。 如果截断位置位于多字节字符两个字节的中间，将于该字符的第一个字节开始执行。 这也是和 substr() 函数的不同之处，后者简单地将字符串在字节之间截断，这将导致一个畸形的字节序列。

参数

str

要截断的 string。

start

如果 start 不是负数，返回的字符串会从 str 的第 start 字节位置开始，从 0 开始计数。举个例子，字符串 'abcdef'，字节位置 0 的字符是 'a'，字节位置 2 的字符是 'c'，以此类推。

如果 start 是负数，返回的字符串是从 str 末尾处第 start 个字节开始的。

length

字节长度。If omitted or NULL is passed, extract all bytes to the end of the string.

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

mb_strcut() 根据 start 和 length 参数返回 str 的一部分。

更新日志

版本 | 说明
5.4.8 | Passing NULL as length extracts all bytes to the end of the string. Prior to this version NULL was treated the same as 0.

参见

  • mb_substr() - 获取部分字符串
  • mb_internal_encoding() - 设置/获取内部字符编码


获取按指定宽度截断的字符串

  • ? mb_strcut
  • mb_stripos ?
  • PHP Manual
  • 多字节字符串 函数
  • 获取按指定宽度截断的字符串

mb_strimwidth

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strimwidth — 获取按指定宽度截断的字符串

说明

mb_strimwidth ( string $str , int $start , int $width , string $trimmarker = "" , string $encoding = mb_internal_encoding() ) : string

按 width 将字符串 str 截短。

参数

str

要截短的 string。

start

开始位置的偏移。从这些字符数开始的截取字符串。（默认是 0 个字符） 如果 start 是负数，就是字符串结尾处的字符数。

width

所需修剪的宽度。负数的宽度是从字符串结尾处统计的。

trimmarker

当字符串被截短的时候，将此字符串添加到截短后的末尾。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

截短后的 string。 如果设置了 trimmarker，还将结尾处的字符替换为 trimmarker ，并符合 width 的宽度。

更新日志

版本 | 说明
7.1.0 | 支持负数的 start 和 width。

范例

Example #1 mb_strimwidth() 例子

<?php
echo mb_strimwidth("Hello World", 0, 10, "...");
// 输出 Hello W...
?>

参见

  • mb_strwidth() - 返回字符串的宽度
  • mb_internal_encoding() - 设置/获取内部字符编码


大小写不敏感地查找字符串在另一个字符串中首次出现的位置

  • ? mb_strimwidth
  • mb_stristr ?
  • PHP Manual
  • 多字节字符串 函数
  • 大小写不敏感地查找字符串在另一个字符串中首次出现的位置

mb_stripos

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_stripos — 大小写不敏感地查找字符串在另一个字符串中首次出现的位置

说明

mb_stripos ( string $haystack , string $needle , int $offset = 0 , string $encoding = mb_internal_encoding() ) : int

mb_stripos() 返回 needle 在字符串 haystack 中首次出现位置的数值。 和 mb_strpos() 不同的是，mb_stripos() 是大小写不敏感的。 如果 needle 没找到，它将返回 false。

参数

haystack

在这个字符串中查找获取 needle 首次出现的位置

needle

在 haystack 中查找这个字符串

offset

haystack 里开始搜索的位置。如果是负数，就从字符串的尾部开始统计。

encoding

使用的字符编码名称。 如果省略了它，将使用内部字符编码。

返回值

返回字符串 haystack 中 needle 首次出现位置的数值。 如果没有找到 needle，它将返回 false。

更新日志

版本 | 说明
7.1.0 | 支持 offset 使用负数。

参见

  • stripos() - 查找字符串首次出现的位置（不区分大小写）
  • strpos() - 查找字符串首次出现的位置
  • mb_strpos() - 查找字符串在另一个字符串中首次出现的位置


大小写不敏感地查找字符串在另一个字符串里的首次出现

  • ? mb_stripos
  • mb_strlen ?
  • PHP Manual
  • 多字节字符串 函数
  • 大小写不敏感地查找字符串在另一个字符串里的首次出现

mb_stristr

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_stristr — 大小写不敏感地查找字符串在另一个字符串里的首次出现

说明

mb_stristr ( string $haystack , string $needle , bool $before_needle = false , string $encoding = mb_internal_encoding() ) : string

mb_strstr() 查找了 needle 在 haystack 中首次的出现并返回 haystack 的一部分。 和 mb_strstr() 不同的是，mb_stristr() 是大小写不敏感的。 如果 needle 没有找到，它将返回 false。

参数

haystack

要获取 needle 首次出现的字符串。

needle

在 haystack 中查找这个字符串。

before_needle

决定这个函数返回 haystack 的哪一部分。 如果设置为 true，它返回 haystack 中从开始到 needle 出现位置的所有字符（不包括 needle）。 如果设置为 false，它返回 haystack 中 needle 出现位置到最后的所有字符（包括了 needle）。

encoding

要使用的字符编码名称。 如果省略该参数，将使用内部字符编码。

返回值

返回 haystack 的一部分，或者 needle 没找到则返回 false。

参见

  • stristr() - strstr 函数的忽略大小写版本
  • strstr() - 查找字符串的首次出现
  • mb_strstr() - 查找字符串在另一个字符串里的首次出现


获取字符串的长度

  • ? mb_stristr
  • mb_strpos ?
  • PHP Manual
  • 多字节字符串 函数
  • 获取字符串的长度

mb_strlen

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strlen — 获取字符串的长度

说明

mb_strlen ( string $str , string $encoding = mb_internal_encoding() ) : mixed

获取一个 string 的长度。

参数

str

要检查长度的字符串。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

返回具有 encoding 编码的字符串 str 包含的字符数。 多字节的字符被计为 1。

如果给定的 encoding 无效则返回 false。

参见

  • mb_internal_encoding() - 设置/获取内部字符编码
  • grapheme_strlen() - Get string length in grapheme units
  • iconv_strlen() - 返回字符串的字符数统计
  • strlen() - 获取字符串长度


查找字符串在另一个字符串中首次出现的位置

  • ? mb_strlen
  • mb_strrchr ?
  • PHP Manual
  • 多字节字符串 函数
  • 查找字符串在另一个字符串中首次出现的位置

mb_strpos

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strpos — 查找字符串在另一个字符串中首次出现的位置

说明

mb_strpos ( string $haystack , string $needle , int $offset = 0 , string $encoding = mb_internal_encoding() ) : int

查找 string 在一个 string 中首次出现的位置。

基于字符数执行一个多字节安全的 strpos() 操作。 第一个字符的位置是 0，第二个字符的位置是 1，以此类推。

参数

haystack

要被检查的 string。

needle

在 haystack 中查找这个字符串。 和 strpos() 不同的是，数字的值不会被当做字符的顺序值。

offset

搜索位置的偏移。如果没有提供该参数，将会使用 0。负数的 offset 会从字符串尾部开始统计。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

返回 string 的 haystack 中 needle 首次出现位置的数值。 如果没有找到 needle，它将返回 false。

更新日志

版本 | 说明
7.1.0 | 支持负数的 offset。

参见

  • mb_internal_encoding() - 设置/获取内部字符编码
  • strpos() - 查找字符串首次出现的位置


查找指定字符在另一个字符串中最后一次的出现

  • ? mb_strpos
  • mb_strrichr ?
  • PHP Manual
  • 多字节字符串 函数
  • 查找指定字符在另一个字符串中最后一次的出现

mb_strrchr

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_strrchr — 查找指定字符在另一个字符串中最后一次的出现

说明

mb_strrchr ( string $haystack , string $needle , bool $part = false , string $encoding = mb_internal_encoding() ) : string

mb_strrchr() 查找了 needle 在 haystack 中最后一次出现的位置，并返回 haystack 的部分。 如果没有找到 needle，它将返回 false。

参数

haystack

在该字符串中查找 needle 最后出现的位置

needle

在 haystack 中查找这个字符串

part

决定这个函数返回 haystack 的哪一部分。 如果设置为 true，它将返回的字符是从 haystack 的开始到 needle 最后出现的位置。 如果设置为 false，它将返回的字符是从 needle 最后出现的位置到 haystack 的末尾。

encoding

使用的字符编码名称。如果省略了，则将使用内部编码。

返回值

返回 haystack 的一部分。 或者在没有找到 needle 时返回 false。

参见

  • strrchr() - 查找指定字符在字符串中的最后一次出现
  • mb_strstr() - 查找字符串在另一个字符串里的首次出现
  • mb_strrichr() - 大小写不敏感地查找指定字符在另一个字符串中最后一次的出现


大小写不敏感地查找指定字符在另一个字符串中最后一次的出现

  • ? mb_strrchr
  • mb_strripos ?
  • PHP Manual
  • 多字节字符串 函数
  • 大小写不敏感地查找指定字符在另一个字符串中最后一次的出现

mb_strrichr

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_strrichr — 大小写不敏感地查找指定字符在另一个字符串中最后一次的出现

说明

mb_strrichr ( string $haystack , string $needle , bool $part = false , string $encoding = mb_internal_encoding() ) : string

mb_strrichr() 大小写不敏感地查找指定 needle 在 haystack 中最后一次的出现，并返回 haystack 的一部分。 和 mb_strrchr() 不同的是，mb_strrichr() 是大小写不敏感的。 如果 needle 没有找到，它将返回 false。

参数

haystack

在该字符串中查找 needle 的最后出现位置

needle

在 needle 中查找该字符串

part

决定这个函数返回 haystack 的哪一部分。 如果设置为 true，它将返回的字符是从 haystack 的开始到 needle 最后出现的位置。 如果设置为 false，它将返回的字符是从 needle 最后出现的位置到 haystack 的末尾。

encoding

使用的字符编码名称。如果省略了，则将使用内部编码。

返回值

返回 haystack 的一部分。 或者在没有找到 needle 时返回 false。

参见

  • mb_stristr() - 大小写不敏感地查找字符串在另一个字符串里的首次出现
  • mb_strrchr() - 查找指定字符在另一个字符串中最后一次的出现


大小写不敏感地在字符串中查找一个字符串最后出现的位置

  • ? mb_strrichr
  • mb_strrpos ?
  • PHP Manual
  • 多字节字符串 函数
  • 大小写不敏感地在字符串中查找一个字符串最后出现的位置

mb_strripos

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_strripos — 大小写不敏感地在字符串中查找一个字符串最后出现的位置

说明

mb_strripos ( string $haystack , string $needle , int $offset = 0 , string $encoding = mb_internal_encoding() ) : int

mb_strripos() 基于字符数执行一个多字节安全的 strripos() 操作。 needle 的位置是从 haystack 的开始进行统计的。 第一个字符的位置是 0，第二个字符的位置是 1。 和 mb_strrpos() 不同的是，mb_strripos() 是大小写不敏感的。

参数

haystack

查找 needle 在这个字符串中最后出现的位置。

needle

在 haystack 中查找这个字符串。

offset

在 haystack 中开始搜索的位置。

encoding

使用的字符编码名称。如果省略了，则将使用内部编码。

返回值

返回字符串 haystack 中 needle 最后出现位置的数值。 如果没有找到 needle，它将返回 false。

参见

  • strripos() - 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置
  • mb_strrpos() - 查找字符串在一个字符串中最后出现的位置


查找字符串在一个字符串中最后出现的位置

  • ? mb_strripos
  • mb_strstr ?
  • PHP Manual
  • 多字节字符串 函数
  • 查找字符串在一个字符串中最后出现的位置

mb_strrpos

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strrpos — 查找字符串在一个字符串中最后出现的位置

说明

mb_strrpos ( string $haystack , string $needle , int $offset = 0 , string $encoding = mb_internal_encoding() ) : int

基于字符数执行一个多字节安全的 strrpos() 操作。 needle 的位置是从 haystack 的开始进行统计的。 第一个字符的位置是 0，第二个字符的位置是 1。

参数

haystack

查找 needle 在这个 string 中最后出现的位置。

needle

在 haystack 中查找这个 string。

offset
可以用于指定 string 里从任意字符数开始进行搜索。 负数的值将导致搜索会终止于指向 string 末尾的任意点。
encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

返回 string 的 haystack 中，needle 最后出现位置的数值。 如果没有找到 needle，它将返回 false。

更新日志

版本 | 说明
5.2.0 | 增加了可选参数 offset。

注释

Note: 从 PHP 5.2.0 开始，encoding 参数从第三个位置移到了第四个位置。 为实现向后兼容，可以将第三个参数指定为 encoding，但不建议这么做，在将来会移除这个特性。

参见

  • mb_strpos() - 查找字符串在另一个字符串中首次出现的位置
  • mb_internal_encoding() - 设置/获取内部字符编码
  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置


查找字符串在另一个字符串里的首次出现

  • ? mb_strrpos
  • mb_strtolower ?
  • PHP Manual
  • 多字节字符串 函数
  • 查找字符串在另一个字符串里的首次出现

mb_strstr

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

mb_strstr — 查找字符串在另一个字符串里的首次出现

说明

mb_strstr ( string $haystack , string $needle , bool $before_needle = false , string $encoding = mb_internal_encoding() ) : string

mb_strstr() 查找了 needle 在 haystack 中首次的出现并返回 haystack 的一部分。 如果 needle 没有找到，它将返回 false。

参数

haystack

要获取 needle 首次出现的字符串。

needle

在 haystack 中查找这个字符串。

before_needle

决定这个函数返回 haystack 的哪一部分。 如果设置为 true，它返回 haystack 中从开始到 needle 出现位置的所有字符（不包括 needle）。 如果设置为 false，它返回 haystack 中 needle 出现位置到最后的所有字符（包括了 needle）。

encoding

要使用的字符编码名称。 如果省略该参数，将使用内部字符编码。

返回值

返回 haystack 的一部分，或者 needle 没找到则返回 false。

参见

  • stristr() - strstr 函数的忽略大小写版本
  • strstr() - 查找字符串的首次出现
  • mb_stristr() - 大小写不敏感地查找字符串在另一个字符串里的首次出现


使字符串小写

  • ? mb_strstr
  • mb_strtoupper ?
  • PHP Manual
  • 多字节字符串 函数
  • 使字符串小写

mb_strtolower

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_strtolower — 使字符串小写

说明

mb_strtolower ( string $str , string $encoding = mb_internal_encoding() ) : string

返回所有字母字符转换成小写的 str。

参数

str

要被小写的字符串。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

所有字母字符已被转换成小写的 str。

Unicode

更多关于 Unicode 属性的信息，请参见 » http://www.unicode.org/reports/tr21/。

和 strtolower() 不同的是，"字母"字符的检测是根据字符的 Unicode 属性。 因此函数的行为不会受语言设置的影响，能偶转换任意具有"字母"属性的字符，例如元音变音 A（?）。

范例

Example #1 mb_strtolower() 例子

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = mb_strtolower($str);
echo $str; // 输出： mary had a little lamb and she loved it so
?>

Example #2 非拉丁 UTF-8 文本的 mb_strtolower() 例子

<?php
$str = "Τ?χιστη αλ?πηξ βαφ?? ψημ?νη γη, δρασκελ?ζει υπ?ρ νωθρο? κυν??";
$str = mb_strtolower($str, 'UTF-8');
echo $str; // 输出 τ?χιστη αλ?πηξ βαφ?? ψημ?νη γη, δρασκελ?ζει υπ?ρ νωθρο? κυν??
?>

参见

  • mb_strtoupper() - 使字符串大写
  • mb_convert_case() - 对字符串进行大小写转换
  • strtolower() - 将字符串转化为小写


使字符串大写

  • ? mb_strtolower
  • mb_strwidth ?
  • PHP Manual
  • 多字节字符串 函数
  • 使字符串大写

mb_strtoupper

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_strtoupper — 使字符串大写

说明

mb_strtoupper ( string $str , string $encoding = mb_internal_encoding() ) : string

将所有的字母字符转化成大写并返回 str。

参数

str

要大写的 string。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

str 里所有的字母都转换成大写的。

Unicode

更多 Unicode 属性的信息，请参见 » http://www.unicode.org/reports/tr21/。

和 strtoupper() 不同的是，"字母"是通过 Unicode 字符属性来确定的。 因此这个函数不会受语言环境（locale）设置影响，能够转化任何具有"字母"属性的字符，例如 a 变音符号（?）。

范例

Example #1 mb_strtoupper() 例子

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = mb_strtoupper($str);
echo $str; // Prints MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
?>

Example #2 非拉丁 UTF-8 文本的 mb_strtoupper() 例子

<?php
$str = "Τ?χιστη αλ?πηξ βαφ?? ψημ?νη γη, δρασκελ?ζει υπ?ρ νωθρο? κυν??";
$str = mb_strtoupper($str, 'UTF-8');
echo $str; // 打印了 Τ?ΧΙΣΤΗ ΑΛ?ΠΗΞ ΒΑΦ?Σ ΨΗΜ?ΝΗ ΓΗ, ΔΡΑΣΚΕΛ?ΖΕΙ ΥΠ?Ρ ΝΩΘΡΟ? ΚΥΝ?Σ
?>

参见

  • mb_strtolower() - 使字符串小写
  • mb_convert_case() - 对字符串进行大小写转换
  • strtoupper() - 将字符串转化为大写


返回字符串的宽度

  • ? mb_strtoupper
  • mb_substitute_character ?
  • PHP Manual
  • 多字节字符串 函数
  • 返回字符串的宽度

mb_strwidth

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_strwidth — 返回字符串的宽度

说明

mb_strwidth ( string $str , string $encoding = mb_internal_encoding() ) : int

返回 string 类型 str 的宽度。

多字节字符通常是单字节字符的两倍宽度。

字符宽度
字符 | 宽度
U+0000 - U+0019 | 0
U+0020 - U+1FFF | 1
U+2000 - U+FF60 | 2
U+FF61 - U+FF9F | 1
U+FFA0 - | 2

参数

str

待解码的 string。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

string str 的宽度。

参见

  • mb_strimwidth() - 获取按指定宽度截断的字符串
  • mb_internal_encoding() - 设置/获取内部字符编码


设置/获取替代字符

  • ? mb_strwidth
  • mb_substr_count ?
  • PHP Manual
  • 多字节字符串 函数
  • 设置/获取替代字符

mb_substitute_character

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_substitute_character — 设置/获取替代字符

说明

mb_substitute_character ( mixed $substchar = mb_substitute_character() ) : mixed

当输入字符的编码是无效的，或者字符代码不存在于输出的字符编码中时，可以为其指定一个替代字符。 无效字符可以被替换为 null（不输出）、string 或者 integer 值（Unicode 字符代码的值）。

该设置会影响 mb_convert_encoding()、
mb_convert_variables()、
mb_output_handler()
和 mb_send_mail()。

参数

substchar

指定 Unicode 值为一个 integer，或者是以下字符串中的一个：

  • "none":：不输出
  • "long"：输出字符代码的值（比如：U+3000、JIS+7E7E）
  • "entity"：输出字符的实体（比如：&#x200;）

返回值

如果设置了 substchar，在成功时返回 true，失败时返回 false。 如果没有设置 substchar，它将返回当前设置。

范例

Example #1 mb_substitute_character() 例子

<?php
/* 设置为 Unicode U+3013 (GETA MARK) */
mb_substitute_character(0x3013);

/* 设置十六进制格式 */
mb_substitute_character("long");

/* 显示当前设置 */
echo mb_substitute_character();
?>


统计字符串出现的次数

  • ? mb_substitute_character
  • mb_substr ?
  • PHP Manual
  • 多字节字符串 函数
  • 统计字符串出现的次数

mb_substr_count

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

mb_substr_count — 统计字符串出现的次数

说明

mb_substr_count ( string $haystack , string $needle , string $encoding = mb_internal_encoding() ) : int

统计子字符串 needle 出现在字符串 haystack 中的次数。

参数

haystack

要检查的字符串。

needle

待查找的字符串。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

子字符串 needle 出现在字符串 haystack 中的次数。

范例

Example #1 mb_substr_count() 例子

<?php
echo mb_substr_count("This is a test", "is"); // 输出 2
?>

参见

  • mb_strpos() - 查找字符串在另一个字符串中首次出现的位置
  • mb_substr() - 获取部分字符串
  • substr_count() - 计算字串出现的次数


获取部分字符串

  • ? mb_substr_count
  • Pspell ?
  • PHP Manual
  • 多字节字符串 函数
  • 获取部分字符串

mb_substr

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

mb_substr — 获取部分字符串

说明

mb_substr ( string $str , int $start , int $length = NULL , string $encoding = mb_internal_encoding() ) : string

根据字符数执行一个多字节安全的 substr() 操作。 位置是从 str 的开始位置进行计数。 第一个字符的位置是 0。第二个字符的位置是 1，以此类推。

参数

str

从该 string 中提取子字符串。

start

如果 start 不是负数，返回的字符串会从 str 第 start 的位置开始，从 0 开始计数。举个例子，字符串 'abcdef'，位置 0 的字符是 'a'，位置 2 的字符是 'c'，以此类推。

如果 start 是负数，返回的字符串是从 str 末尾处第 start 个字符开始的。

length

str 中要使用的最大字符数。如果省略了此参数或者传入了 NULL，则会提取到字符串的尾部。

encoding

encoding 参数为字符编码。如果省略或是 null，则使用内部字符编码。

返回值

mb_substr() 函数根据 start 和 length 参数返回 str 中指定的部分。

更新日志

版本 | 说明
5.4.8 | length 传入 NULL，则从 start 提取到字符串的结尾处。 在之前的版本里， NULL 会被当作 0 来处理。

参见

  • mb_strcut() - 获取字符的一部分
  • mb_internal_encoding() - 设置/获取内部字符编码


Pspell

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Pspell 函数
    • pspell_add_to_personal — Add the word to a personal wordlist
    • pspell_add_to_session — Add the word to the wordlist in the current session
    • pspell_check — Check a word
    • pspell_clear_session — Clear the current session
    • pspell_config_create — Create a config used to open a dictionary
    • pspell_config_data_dir — Location of language data files
    • pspell_config_dict_dir — Location of the main word list
    • pspell_config_ignore — Ignore words less than N characters long
    • pspell_config_mode — Change the mode number of suggestions returned
    • pspell_config_personal — Set a file that contains personal wordlist
    • pspell_config_repl — Set a file that contains replacement pairs
    • pspell_config_runtogether — Consider run-together words as valid compounds
    • pspell_config_save_repl — Determine whether to save a replacement pairs list along with the wordlist
    • pspell_new_config — Load a new dictionary with settings based on a given config
    • pspell_new_personal — Load a new dictionary with personal wordlist
    • pspell_new — Load a new dictionary
    • pspell_save_wordlist — Save the personal wordlist to a file
    • pspell_store_replacement — Store a replacement pair for a word
    • pspell_suggest — Suggest spellings of a word


简介

These functions allow you to check the spelling of a word and offer suggestions.


需求

To compile PHP with pspell support, you need the aspell library, available from » http://aspell.net/.


安装

If you have the libraries needed add the --with-pspell[=dir] option when compiling PHP.

Note: Note to Win32 Users

为了使此扩展生效， DLL 文件必须能在 Windows 系统的 PATH 指示的路径下找到。如何操作的信息，请参见题为"如何在 Windows 中将 PHP 目录加到 PATH 中"的FAQ。虽然将 DLL 文件从 PHP 文件夹复制到 Windows 系统目录也行，但不建议这样做。 此扩展需要下列文件在 PATH 路径中： aspell-15.dll from the bin folder of the aspell installation.

Win32 support requires at least aspell version 0.50.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

PSPELL_FAST (int)
PSPELL_NORMAL (int)
PSPELL_BAD_SPELLERS (int)
PSPELL_RUN_TOGETHER (int)


Pspell 函数

Table of Contents

  • pspell_add_to_personal — Add the word to a personal wordlist
  • pspell_add_to_session — Add the word to the wordlist in the current session
  • pspell_check — Check a word
  • pspell_clear_session — Clear the current session
  • pspell_config_create — Create a config used to open a dictionary
  • pspell_config_data_dir — Location of language data files
  • pspell_config_dict_dir — Location of the main word list
  • pspell_config_ignore — Ignore words less than N characters long
  • pspell_config_mode — Change the mode number of suggestions returned
  • pspell_config_personal — Set a file that contains personal wordlist
  • pspell_config_repl — Set a file that contains replacement pairs
  • pspell_config_runtogether — Consider run-together words as valid compounds
  • pspell_config_save_repl — Determine whether to save a replacement pairs list along with the wordlist
  • pspell_new_config — Load a new dictionary with settings based on a given config
  • pspell_new_personal — Load a new dictionary with personal wordlist
  • pspell_new — Load a new dictionary
  • pspell_save_wordlist — Save the personal wordlist to a file
  • pspell_store_replacement — Store a replacement pair for a word
  • pspell_suggest — Suggest spellings of a word


Add the word to a personal wordlist

  • ? Pspell 函数
  • pspell_add_to_session ?
  • PHP Manual
  • Pspell 函数
  • Add the word to a personal wordlist

pspell_add_to_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_add_to_personal — Add the word to a personal wordlist

说明

pspell_add_to_personal ( int $dictionary , string $word ) : bool

pspell_add_to_personal() adds a word to the personal wordlist. If you used pspell_new_config() with pspell_config_personal() to open the dictionary, you can save the wordlist later with pspell_save_wordlist().

参数

dictionary

word

The added word.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_save_wordlist($pspell_link);
?>

注释

Note:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.


Add the word to the wordlist in the current session

  • ? pspell_add_to_personal
  • pspell_check ?
  • PHP Manual
  • Pspell 函数
  • Add the word to the wordlist in the current session

pspell_add_to_session

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_add_to_session — Add the word to the wordlist in the current session

说明

pspell_add_to_session ( int $dictionary , string $word ) : bool

pspell_add_to_session() adds a word to the wordlist associated with the current session. It is very similar to pspell_add_to_personal()

参数

dictionary

word

The added word.

返回值

成功时返回 true， 或者在失败时返回 false。


Check a word

  • ? pspell_add_to_session
  • pspell_clear_session ?
  • PHP Manual
  • Pspell 函数
  • Check a word

pspell_check

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_check — Check a word

说明

pspell_check ( int $dictionary , string $word ) : bool

pspell_check() checks the spelling of a word.

参数

dictionary

word

The tested word.

返回值

Returns true if the spelling is correct, false if not.

范例

Example #1 pspell_check() Example

<?php
$pspell_link = pspell_new("en");

if (pspell_check($pspell_link, "testt")) {
    echo "This is a valid spelling";
} else {
    echo "Sorry, wrong spelling";
}
?>


Clear the current session

  • ? pspell_check
  • pspell_config_create ?
  • PHP Manual
  • Pspell 函数
  • Clear the current session

pspell_clear_session

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_clear_session — Clear the current session

说明

pspell_clear_session ( int $dictionary ) : bool

pspell_clear_session() clears the current session. The current wordlist becomes blank, and, for example, if you try to save it with pspell_save_wordlist(), nothing happens.

参数

dictionary

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_add_to_personal() Example

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_clear_session($pspell_link);
pspell_save_wordlist($pspell_link);    //"Vlad" will not be saved
?>


Create a config used to open a dictionary

  • ? pspell_clear_session
  • pspell_config_data_dir ?
  • PHP Manual
  • Pspell 函数
  • Create a config used to open a dictionary

pspell_config_create

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_create — Create a config used to open a dictionary

说明

pspell_config_create ( string $language , string $spelling = "" , string $jargon = "" , string $encoding = "" ) : int

Create a config used to open a dictionary.

pspell_config_create() has a very similar syntax to pspell_new(). In fact, using pspell_config_create() immediately followed by pspell_new_config() will produce the exact same result. However, after creating a new config, you can also use pspell_config_*() functions before calling pspell_new_config() to take advantage of some advanced functionality.

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

参数

language

The language parameter is the language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The spelling parameter is the requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

The jargon parameter contains extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding parameter is the encoding that words are expected to be in. Valid values are 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. This parameter is largely untested, so be careful when using.

返回值

Returns a pspell config identifier, or false on error.

范例

Example #1 pspell_config_create()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_personal($pspell_config, "en");
?>


Location of language data files

  • ? pspell_config_create
  • pspell_config_dict_dir ?
  • PHP Manual
  • Pspell 函数
  • Location of language data files

pspell_config_data_dir

(PHP 5, PHP 7, PHP 8)

pspell_config_data_dir — Location of language data files

说明

pspell_config_data_dir ( int $config , string $directory ) : bool

Warning

本函数还未编写文档，仅有参数列表。

返回值

成功时返回 true， 或者在失败时返回 false。


Location of the main word list

  • ? pspell_config_data_dir
  • pspell_config_ignore ?
  • PHP Manual
  • Pspell 函数
  • Location of the main word list

pspell_config_dict_dir

(PHP 5, PHP 7, PHP 8)

pspell_config_dict_dir — Location of the main word list

说明

pspell_config_dict_dir ( int $config , string $directory ) : bool

Warning

本函数还未编写文档，仅有参数列表。

返回值

成功时返回 true， 或者在失败时返回 false。


Ignore words less than N characters long

  • ? pspell_config_dict_dir
  • pspell_config_mode ?
  • PHP Manual
  • Pspell 函数
  • Ignore words less than N characters long

pspell_config_ignore

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_ignore — Ignore words less than N characters long

说明

pspell_config_ignore ( int $config , int $min_length ) : bool

pspell_config_ignore() should be used on a config before calling pspell_new_config(). This function allows short words to be skipped by the spell checker.

参数

config

min_length

Words less than min_length characters will be skipped.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_config_ignore()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_ignore($pspell_config, 5);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "abcd");    //will not result in an error
?>


Change the mode number of suggestions returned

  • ? pspell_config_ignore
  • pspell_config_personal ?
  • PHP Manual
  • Pspell 函数
  • Change the mode number of suggestions returned

pspell_config_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_mode — Change the mode number of suggestions returned

说明

pspell_config_mode ( int $config , int $mode ) : bool

pspell_config_mode() should be used on a config before calling pspell_new_config(). This function determines how many suggestions will be returned by pspell_suggest().

参数

config

mode

The mode parameter is the mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_config_mode() Example

<?php
$pspell_config = pspell_config_create("en");
pspell_config_mode($pspell_config, PSPELL_FAST);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>


Set a file that contains personal wordlist

  • ? pspell_config_mode
  • pspell_config_repl ?
  • PHP Manual
  • Pspell 函数
  • Set a file that contains personal wordlist

pspell_config_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_personal — Set a file that contains personal wordlist

说明

pspell_config_personal ( int $config , string $filename ) : bool

Set a file that contains personal wordlist. The personal wordlist will be loaded and used in addition to the standard one after you call pspell_new_config(). The file is also the file where pspell_save_wordlist() will save personal wordlist to.

pspell_config_personal() should be used on a config before calling pspell_new_config().

参数

config

filename

The personal wordlist. If the file does not exist, it will be created. The file should be writable by whoever PHP runs as (e.g. nobody).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_config_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

注释

Note:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.


Set a file that contains replacement pairs

  • ? pspell_config_personal
  • pspell_config_runtogether ?
  • PHP Manual
  • Pspell 函数
  • Set a file that contains replacement pairs

pspell_config_repl

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_repl — Set a file that contains replacement pairs

说明

pspell_config_repl ( int $config , string $filename ) : bool

Set a file that contains replacement pairs.

The replacement pairs improve the quality of the spellchecker. When a word is misspelled, and a proper suggestion was not found in the list, pspell_store_replacement() can be used to store a replacement pair and then pspell_save_wordlist() to save the wordlist along with the replacement pairs.

pspell_config_repl() should be used on a config before calling pspell_new_config().

参数

config

filename

The file should be writable by whoever PHP runs as (e.g. nobody).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_config_repl()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

注释

Note:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.


Consider run-together words as valid compounds

  • ? pspell_config_repl
  • pspell_config_save_repl ?
  • PHP Manual
  • Pspell 函数
  • Consider run-together words as valid compounds

pspell_config_runtogether

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_runtogether — Consider run-together words as valid compounds

说明

pspell_config_runtogether ( int $config , bool $allow ) : bool

This function determines whether run-together words will be treated as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.

pspell_config_runtogether() should be used on a config before calling pspell_new_config().

参数

config

allow

true if run-together words should be treated as legal compounds, false otherwise.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_config_runtogether()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_runtogether($pspell_config, true);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>


Determine whether to save a replacement pairs list along with the wordlist

  • ? pspell_config_runtogether
  • pspell_new_config ?
  • PHP Manual
  • Pspell 函数
  • Determine whether to save a replacement pairs list along with the wordlist

pspell_config_save_repl

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_save_repl — Determine whether to save a replacement pairs list along with the wordlist

说明

pspell_config_save_repl ( int $config , bool $save ) : bool

pspell_config_save_repl() determines whether pspell_save_wordlist() will save the replacement pairs along with the wordlist. Usually there is no need to use this function because if pspell_config_repl() is used, the replacement pairs will be saved by pspell_save_wordlist() anyway, and if it is not, the replacement pairs will not be saved.

pspell_config_save_repl() should be used on a config before calling pspell_new_config().

参数

config

save

true if replacement pairs should be saved, false otherwise.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.


Load a new dictionary with settings based on a given config

  • ? pspell_config_save_repl
  • pspell_new_personal ?
  • PHP Manual
  • Pspell 函数
  • Load a new dictionary with settings based on a given config

pspell_new_config

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_new_config — Load a new dictionary with settings based on a given config

说明

pspell_new_config ( int $config ) : int|false

pspell_new_config() opens up a new dictionary with settings specified in a config, created with pspell_config_create() and modified with pspell_config_*() functions. This method provides you with the most flexibility and has all the functionality provided by pspell_new() and pspell_new_personal().

参数

config

The config parameter is the one returned by pspell_config_create() when the config was created.

返回值

Returns a dictionary link identifier on success, 或者在失败时返回 false.

范例

Example #1 pspell_new_config()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);
?>


Load a new dictionary with personal wordlist

  • ? pspell_new_config
  • pspell_new ?
  • PHP Manual
  • Pspell 函数
  • Load a new dictionary with personal wordlist

pspell_new_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_new_personal — Load a new dictionary with personal wordlist

说明

pspell_new_personal ( string $filename , string $language , string $spelling = "" , string $jargon = "" , string $encoding = "" , int $mode = 0 ) : int|false

pspell_new_personal() opens up a new dictionary with a personal wordlist. The wordlist can be modified and saved with pspell_save_wordlist(), if desired. However, the replacement pairs are not saved. In order to save replacement pairs, you should create a config using pspell_config_create(), set the personal wordlist file with pspell_config_personal(), set the file for replacement pairs with pspell_config_repl(), and open a new dictionary with pspell_new_config().

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

参数

filename

The file where words added to the personal list will be stored. It should be an absolute filename beginning with '/' because otherwise it will be relative to $HOME, which is "/root" for most systems, and is probably not what you want.

language

The language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

Extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding that words are expected to be in. Valid values are utf-8, iso8859-*, koi8-r, viscii, cp1252, machine unsigned 16, machine unsigned 32.

mode

The mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)
  • PSPELL_RUN_TOGETHER - Consider run-together words as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.
Mode is a bitmask constructed from different constants listed above. However, PSPELL_FAST, PSPELL_NORMAL and PSPELL_BAD_SPELLERS are mutually exclusive, so you should select only one of them.

返回值

Returns the dictionary link identifier for use in other pspell functions.

范例

Example #1 pspell_new_personal()

<?php
$pspell_link = pspell_new_personal ("/var/dictionaries/custom.pws",
        "en", "", "", "", PSPELL_FAST|PSPELL_RUN_TOGETHER);
?>


Load a new dictionary

  • ? pspell_new_personal
  • pspell_save_wordlist ?
  • PHP Manual
  • Pspell 函数
  • Load a new dictionary

pspell_new

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_new — Load a new dictionary

说明

pspell_new ( string $language , string $spelling = "" , string $jargon = "" , string $encoding = "" , int $mode = 0 ) : int|false

pspell_new() opens up a new dictionary and returns the dictionary link identifier for use in other pspell functions.

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

参数

language

The language parameter is the language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The spelling parameter is the requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

The jargon parameter contains extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding parameter is the encoding that words are expected to be in. Valid values are 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. This parameter is largely untested, so be careful when using.

mode

The mode parameter is the mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)
  • PSPELL_RUN_TOGETHER - Consider run-together words as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.
Mode is a bitmask constructed from different constants listed above. However, PSPELL_FAST, PSPELL_NORMAL and PSPELL_BAD_SPELLERS are mutually exclusive, so you should select only one of them.

返回值

Returns the dictionary link identifier on success 或者在失败时返回 false.

范例

Example #1 pspell_new()

<?php
$pspell_link = pspell_new("en", "", "", "",
                           (PSPELL_FAST|PSPELL_RUN_TOGETHER));
?>


Save the personal wordlist to a file

  • ? pspell_new
  • pspell_store_replacement ?
  • PHP Manual
  • Pspell 函数
  • Save the personal wordlist to a file

pspell_save_wordlist

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_save_wordlist — Save the personal wordlist to a file

说明

pspell_save_wordlist ( int $dictionary ) : bool

pspell_save_wordlist() saves the personal wordlist from the current session. The location of files to be saved specified with pspell_config_personal() and (optionally) pspell_config_repl().

参数

dictionary

A dictionary link identifier opened with pspell_new_personal().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/tmp/dicts/newdict");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_save_wordlist($pspell_link);
?>

注释

Note:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.


Store a replacement pair for a word

  • ? pspell_save_wordlist
  • pspell_suggest ?
  • PHP Manual
  • Pspell 函数
  • Store a replacement pair for a word

pspell_store_replacement

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_store_replacement — Store a replacement pair for a word

说明

pspell_store_replacement ( int $dictionary , string $misspelled , string $correct ) : bool

pspell_store_replacement() stores a replacement pair for a word, so that replacement can be returned by pspell_suggest() later. In order to be able to take advantage of this function, you have to use pspell_new_personal() to open the dictionary. In order to permanently save the replacement pair, you have to use pspell_config_personal() and pspell_config_repl() to set the path where to save your custom wordlists, and then use pspell_save_wordlist() for the changes to be written to disk.

参数

dictionary

A dictionary link identifier, opened with pspell_new_personal()

misspelled

The misspelled word.

correct

The fixed spelling for the misspelled word.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pspell_store_replacement()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);

pspell_store_replacement($pspell_link, $misspelled, $correct);
pspell_save_wordlist($pspell_link);
?>

注释

Note:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.


Suggest spellings of a word

  • ? pspell_store_replacement
  • Recode ?
  • PHP Manual
  • Pspell 函数
  • Suggest spellings of a word

pspell_suggest

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_suggest — Suggest spellings of a word

说明

pspell_suggest ( int $dictionary , string $word ) : array|false

pspell_suggest() returns an array of possible spellings for the given word.

参数

dictionary

word

The tested word.

返回值

Returns an array of possible spellings.

范例

Example #1 pspell_suggest() example

<?php
$pspell_link = pspell_new("en");

if (!pspell_check($pspell_link, "testt")) {
    $suggestions = pspell_suggest($pspell_link, "testt");

    foreach ($suggestions as $suggestion) {
        echo "Possible spelling: $suggestion<br />";
    }
}
?>


GNU Recode

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Recode 函数
    • recode_file — Recode from file to file according to recode request
    • recode_string — Recode a string according to a recode request
    • recode — 别名 recode_string


简介

This module contains an interface to the GNU Recode library. The GNU Recode library converts files between various coded character sets and surface encodings. When this cannot be achieved exactly, it may get rid of the offending characters or fall back on approximations. The library recognises or produces nearly 150 different character sets and is able to convert files between almost any pair. Most » RFC 1345 character sets are supported.

Note: This extension is unbundled and moved to » PECL as of PHP 7.4.0. Consider to use the Multibyte String or iconv extensions instead.

Note: 此扩展在 Windows 平台上不可用。


需求

You must have GNU Recode 3.5 or higher installed on your system. You can download the package from » http://directory.fsf.org/All_GNU_Packages/recode.html.

Warning

The Recode library version 3.6 adds weird characters behind converted strings under certain circumstances. Thus it's safer to use Recode v3.5 or one of the available alternatives like the iconv or mbstring extension.


安装

PHP 7.4

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。7.4.0

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/recode.

PHP < 7.4

To be able to use the functions defined in this module you must compile your PHP interpreter using the --with-recode[=DIR] option.

Warning

Crashes and startup problems of PHP may be encountered when loading the recode as extension after loading any extension of mysql or imap. Loading the recode before those extension has proved to fix the problem. This is due a technical problem that both the c-client library used by imap and recode have their own hash_lookup() function and both mysql and recode have their own hash_insert function.

Warning

IMAP，recode，和 YAZ 扩展不能同时使用，因为它们共享了相同 的内部符号。注意：Yaz 2.0 及以上版本不存在此问题。


  • ? 资源类型
  • Recode 函数 ?
  • PHP Manual
  • Recode
  • 预定义常量

预定义常量

此扩展没有定义常量。


Recode 函数

Table of Contents

  • recode_file — Recode from file to file according to recode request
  • recode_string — Recode a string according to a recode request
  • recode — 别名 recode_string


Recode from file to file according to recode request

  • ? Recode 函数
  • recode_string ?
  • PHP Manual
  • Recode 函数
  • Recode from file to file according to recode request

recode_file

(PHP 4, PHP 5, PHP 7 < 7.4.0)

recode_file — Recode from file to file according to recode request

说明

recode_file ( string $request , resource $input , resource $output ) : bool

Recode the file referenced by file handle input into the file referenced by file handle output according to the recode request.

参数

request

The desired recode request type

input

A local file handle resource for the input

output

A local file handle resource for the output

返回值

Returns false, if unable to comply, true otherwise.

范例

Example #1 Basic recode_file() example

<?php
$input = fopen('input.txt', 'r');
$output = fopen('output.txt', 'w');
recode_file("us..flat", $input, $output);
?>

注释

This function does not currently process file handles referencing remote files (URLs). Both file handles must refer to local files.

参见

  • fopen() - 打开文件或者 URL


Recode a string according to a recode request

  • ? recode_file
  • recode ?
  • PHP Manual
  • Recode 函数
  • Recode a string according to a recode request

recode_string

(PHP 4, PHP 5, PHP 7 < 7.4.0)

recode_string — Recode a string according to a recode request

说明

recode_string ( string $request , string $string ) : string

Recode the string string according to the recode request request.

参数

request

The desired recode request type

string

The string to be recoded

返回值

Returns the recoded string or false, if unable to perform the recode request.

范例

Example #1 Basic recode_string() example

<?php
echo recode_string("us..flat", "The following character has a diacritical mark: á");
?>

注释

A simple recode request may be "lat1..iso646-de".

参见

  • The GNU Recode documentation of your installation for detailed instructions about recode requests.


别名 recode_string

  • ? recode_string
  • 图像生成和处理 ?
  • PHP Manual
  • Recode 函数
  • 别名 recode_string

recode

(PHP 4, PHP 5, PHP 7 < 7.4.0)

recode — 别名 recode_string()

说明

此函数是该函数的别名： recode_string().


图像生成和处理

  • Exif — 可交换图像信息
    • 简介
    • 安装／配置
    • 预定义常量
    • Exif 函数
  • GD — 图像处理和 GD
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • GD 和图像处理 函数
  • Gmagick
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Gmagick — The Gmagick class
    • GmagickDraw — The GmagickDraw class
    • GmagickPixel — The GmagickPixel class
  • ImageMagick — 图像处理(ImageMagick)
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Imagick — The Imagick class
    • ImagickDraw — The ImagickDraw class
    • ImagickPixel — The ImagickPixel class
    • ImagickPixelIterator — The ImagickPixelIterator class


可交换图像信息

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Exif 函数
    • exif_imagetype — 判断一个图像的类型
    • exif_read_data — 从 JPEG 或 TIFF 文件中读取 EXIF 头信息
    • exif_tagname — 获取指定索引的头名称
    • exif_thumbnail — 取得嵌入在 TIFF 或 JPEG 图像中的缩略图
    • read_exif_data — 别名 exif_read_data


简介

通过使用 exif 扩展，你可以操作图像元数据。 例如：你可以使用 exif 相关的函数从数码相机拍摄的图片文件中读取元数据。 通常 JPEG 和 TIFF 格式的图像文件都包含元数据。


需求

必须使用 --enable-exif 选项编译 PHP。 如果要提供对 EXIF 标签中元数据的多字节文字支持，需要通过使用 --enable-mbstring 选项编译 PHP 来启用 mbstring 扩展。 exif 不需要其他额外的 PHP 库就可以直接使用。

Windows 平台：必须启用 mbstring 扩展。 并且，在 php.ini 文件中， mbstring 必须先于 EXIF 加载。


安装

使用 --enable-exif 选项 配置 PHP 来启用 exif 支持。

Windows 用户必须在 php.ini 中启用 php_mbstring.dll 和 php_exif.dll 扩展。 请确保在 php.ini 中保持正确的顺序： php_mbstring.dll 必须在 php_exif.dll 之前 加载。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

当 mbstring 模块可用时，exif 支持用户注释中的 Unicode 和 JIS 字符编码的自动转换。这是通过先用指定字符集将注释解码，把结果再用另一个符合你的 HTTP 输出的字符集编码来实现的。

Exif configuration options
名字 | 默认 | 可修改范围 | 更新日志
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL |
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL |
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL |
exif.encode_jis | "" | PHP_INI_ALL |
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL |
exif.decode_jis_intel | "JIS" | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

exif.encode_unicode string

exif.encode_unicode 定义了 UNICODE 用户注释被处理的字符集。默认为 ISO-8859-15，可用于大多数非亚洲国家。本设置可以为空或者必须为一个 mbstring 所支持的编码。如果为空，则使用当前 mbstring 内部使用的编码。

exif.decode_unicode_motorola string

exif.decode_unicode_motorola 定义了 Unicode 编码的用户注释的图像内部字符集，如果图像是摩托罗拉字节顺序（big-endian）的话。本设置不能为空但可以指定一个 mbstring 支持的编码列表。默认为 UCS-2BE。

exif.decode_unicode_intel string

exif.decode_unicode_intel 定义了 Unicode 编码的用户注释的图像内部字符集，如果图像是英特尔字节顺序（little-endian）的话。本设置不能为空但可以指定一个 mbstring 支持的编码列表。默认为 UCS-2LE。

exif.encode_jis string

exif.encode_jis 定义了 JIS 用户注释被处理的字符集。默认为空值，迫使函数使用当前 mbstring 使用的内部编码。

exif.decode_jis_motorola string

exif.decode_jis_motorola 定义了 JIS 编码的用户注释的图像内部字符集，如果图像是摩托罗拉字节顺序（big-endian）的话。本设置不能为空但可以指定一个 mbstring 支持的编码列表。默认为 JIS。

exif.decode_jis_intel string

exif.decode_jis_intel 定义了 JIS 编码的用户注释的图像内部字符集，如果图像是英特尔字节顺序（litle-endian）的话。本设置不能为空但可以指定一个 mbstring 支持的编码列表。默认为 JIS。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

EXIF_USE_MBSTRING (integer)
如果启用了 mbstring， 这个常量的值为 1， 否则为 0。

exif_imagetype() 列出几个相关的内建变量。


Exif 函数

Table of Contents

  • exif_imagetype — 判断一个图像的类型
  • exif_read_data — 从 JPEG 或 TIFF 文件中读取 EXIF 头信息
  • exif_tagname — 获取指定索引的头名称
  • exif_thumbnail — 取得嵌入在 TIFF 或 JPEG 图像中的缩略图
  • read_exif_data — 别名 exif_read_data


判断一个图像的类型

  • ? Exif 函数
  • exif_read_data ?
  • PHP Manual
  • Exif 函数
  • 判断一个图像的类型

exif_imagetype

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

exif_imagetype — 判断一个图像的类型

说明

exif_imagetype ( string $filename ) : int

exif_imagetype() 读取一个图像的第一个字节并检查其签名。

本函数可用来避免调用其它 exif 函数用到了不支持的文件类型上或和 $_SERVER['HTTP_ACCEPT'] 结合使用来检查浏览器是否可以显示某个指定的图像。

参数

filename
被检查的图像文件名。

返回值

如果发现了恰当的签名则返回一个对应的常量，否则返回 false。返回值和 getimagesize() 返回的数组中的索引 2 的值是一样的，但本函数快得多。

更新日志

版本 | 说明
4.3.2 | 支持 JPC，JP2，JPX，JB2，XBM 以及 WBMP
4.3.0 | 支持 SWC

预定义常量

定义有以下常量，并代表了 exif_imagetype() 可能的返回值：

图像类型常量
值 | 常量
1 | IMAGETYPE_GIF
2 | IMAGETYPE_JPEG
3 | IMAGETYPE_PNG
4 | IMAGETYPE_SWF
5 | IMAGETYPE_PSD
6 | IMAGETYPE_BMP
7 | IMAGETYPE_TIFF_II（Intel 字节顺序）
8 | IMAGETYPE_TIFF_MM（Motorola 字节顺序）
9 | IMAGETYPE_JPC
10 | IMAGETYPE_JP2
11 | IMAGETYPE_JPX
12 | IMAGETYPE_JB2
13 | IMAGETYPE_SWC
14 | IMAGETYPE_IFF
15 | IMAGETYPE_WBMP
16 | IMAGETYPE_XBM

范例

Example #1 exif_imagetype() 例子

<?php

if (exif_imagetype("image.gif") != IMAGETYPE_GIF) {
    echo "The picture is not a gif";
}

?>

参见

  • getimagesize() - 取得图像大小


从 JPEG 或 TIFF 文件中读取 EXIF 头信息

  • ? exif_imagetype
  • exif_tagname ?
  • PHP Manual
  • Exif 函数
  • 从 JPEG 或 TIFF 文件中读取 EXIF 头信息

exif_read_data

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

exif_read_data — 从 JPEG 或 TIFF 文件中读取 EXIF 头信息

说明

exif_read_data ( string $filename , string $sections = null , bool $arrays = false , bool $thumbnail = false ) : array

exif_read_data() 函数从 JPEG 或 TIFF 图像文件中读取 EXIF 头信息。这样就可以读取数码相机产生的元数据。

EXIF 头信息往往存在于数码相机生成的 JPEG/TIFF 图像中，但不幸的是每个数码相机制造商的标记都不同，因此（编写代码时）不能依赖于某个特定的 Exif 头信息。

Height 和 Width 是用和 getimagesize() 一样的方法计算的，因此它们的值不能是任何返回的头信息的部分。此外 html 是一个 height/width 的文本字符串可以用于普通的 HTML 中。

当一个 Exif 头信息包含有一个 Copyright 时注意它本身可以包含两个值。解决方案和 Exif 2.10 标准不一致，COMPUTED 区段会同时返回 Copyright.Photographer 和 Copyright.Editor，但是 IFD0 区段则包含有一个字节数组用 NULL 字符分隔开两个项目。或者只有第一项如果数据类型错误的话（Exif 的正常行为）。COMPUTED 也会包含 Copyright，要么是原始的版权字符串，要么是逗号分隔的摄像与编辑的版权信息。

UserComment 标记和 Copyright 有同样的问题。它也可以存储两个值，第一个是使用的编码方式，第二个是其值本身。如果这样则 IFD0 区段仅包含编码方式或者一个字节数组。COMPUTED 区段将存储两个值到 UserCommentEncoding 和 UserComment。UserComment 在两种情况下都可用因此应该优先使用它而不是 IFD0 区段中的该值。

exif_read_data() 还会根据 EXIF 规范（» http://exif.org/Exif2-2.PDF，第 20 页）来验证 EXIF 数据。

Note:

Windows ME/XP 在连接到数码相机时能清除掉 Exif 头信息。

参数

filename

被读取的图像文件名。不能是 URL。

sections

是需要存在于文件中的逗号分隔的区段列表用来产生结果数组。如果未找到所请求的区段则返回值为 false。

FILE | FileName, FileSize, FileDateTime, SectionsFound
COMPUTED | html，Width，Height，IsColor，可能有更多其它的。Height 和 Width 是用和 getimagesize() 一样的方法计算的，因此它们的值不能是任何返回的头信息的部分。此外 html 是一个 height/width 的文本字符串可以用于普通的 HTML 中。
ANY_TAG | 任何包含有标记的信息，例如 IFD0，EXIF，...
IFD0 | 所有 IFD0 的标记数据。在标准的图像文件中这包含了图像大小及其它。
THUMBNAIL | 如果有第二个 IFD，文件应该包含有缩略图。所有有关嵌入缩略图的标记信息都存储在本区。
COMMENT | JPEG 图像的注释头信息。
EXIF | EXIF 区段是 IFDO 的子区，包含有图像的更多详细信息。大多数内容都是数码相机相关的。

arrays

指定了是否每个区段都成为一个数组。sections COMPUTED，THUMBNAIL 和COMMENT 区段总是成为数组，因为它们里面包含的名字和其它区段冲突。

thumbnail

当设定为 true 时，读取缩略图本身。否则只读取标记数据。

返回值

返回一个关联数组，键名是头信息名，值为与其相应的值。如果没有可供返回的数据，exif_read_data() 将返回 false。

更新日志

版本 | 说明
4.3.0 | 可以读取所有嵌入的 IFD 数据，包括数组（也返回数组）。此外嵌入的缩略图的大小包括在 THUMBNAIL 子数组中并且 exif_read_data() 可以将缩略图按照 TIFF 格式返回。最后，不再有返回值最大长度的限制了（直到达到内存限定）。
4.3.0 | 如果 PHP 有 mbstring 支持，则用户注释可以自动改变编码。此外，如果用户注释使用 Unicode 或 JIS 编码，将会根据 EXIF 在 php.ini 中的 设置被自动改变。
4.3.0 | 如果图像包含任何 IFD0 数据，则 COMPUTED 会包含有一项 ByteOrderMotorola，对于 little-endian (intel) 字节顺序，其值为 0，对于 big-endian (motorola) 字节顺序，其值为 1。此外，COMPUTED 和 UserComment 在数据类型出错时也不再仅包含第一个版权条目。

范例

Example #1 exif_read_data() 例子

<?php
echo "test1.jpg:<br />\n";
$exif = exif_read_data('tests/test1.jpg', 'IFD0');
echo $exif===false ? "No header data found.<br />\n" : "Image contains headers<br />\n";

$exif = exif_read_data('tests/test2.jpg', 0, true);
echo "test2.jpg:<br />\n";
foreach ($exif as $key => $section) {
    foreach ($section as $name => $val) {
        echo "$key.$name: $val<br />\n";
    }
}
?>

第一个调用失败了，因为图像没有头信息。

以上例程的输出类似于：

test1.jpg:
No header data found.
test2.jpg:
FILE.FileName: test2.jpg
FILE.FileDateTime: 1017666176
FILE.FileSize: 1240
FILE.FileType: 2
FILE.SectionsFound: ANY_TAG, IFD0, THUMBNAIL, COMMENT
COMPUTED.html: width="1" height="1"
COMPUTED.Height: 1
COMPUTED.Width: 1
COMPUTED.IsColor: 1
COMPUTED.ByteOrderMotorola: 1
COMPUTED.UserComment: Exif test image.
COMPUTED.UserCommentEncoding: ASCII
COMPUTED.Copyright: Photo (c) M.Boerger, Edited by M.Boerger.
COMPUTED.Copyright.Photographer: Photo (c) M.Boerger
COMPUTED.Copyright.Editor: Edited by M.Boerger.
IFD0.Copyright: Photo (c) M.Boerger
IFD0.UserComment: ASCII
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.JPEGInterchangeFormatLength: 523
COMMENT.0: Comment #1.
COMMENT.1: Comment #2.
COMMENT.2: Comment #3end
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.Thumbnail.Height: 1
THUMBNAIL.Thumbnail.Height: 1

参见

  • exif_thumbnail() - 取得嵌入在 TIFF 或 JPEG 图像中的缩略图
  • getimagesize() - 取得图像大小


获取指定索引的头名称

  • ? exif_read_data
  • exif_thumbnail ?
  • PHP Manual
  • Exif 函数
  • 获取指定索引的头名称

exif_tagname

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

exif_tagname — 获取指定索引的头名称

说明

exif_tagname ( int $index ) : string

参数

index

要查找的标签名称的 ID。

返回值

返回头名称。 如果 index 参数不是预定义的 EXIF 标签 id，则返回 false

范例

Example #1 exif_tagname() 函数例程

<?php
echo "256: ".exif_tagname(256).PHP_EOL;
echo "257: ".exif_tagname(257).PHP_EOL;
?>

以上例程会输出：

256: ImageWidth
257: ImageLength

参见

  • exif_imagetype() - 判断一个图像的类型
  • » EXIF 规范
  • » EXIF 标签


取得嵌入在 TIFF 或 JPEG 图像中的缩略图

  • ? exif_tagname
  • read_exif_data ?
  • PHP Manual
  • Exif 函数
  • 取得嵌入在 TIFF 或 JPEG 图像中的缩略图

exif_thumbnail

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

exif_thumbnail — 取得嵌入在 TIFF 或 JPEG 图像中的缩略图

说明

exif_thumbnail ( string $filename , int &$width = ? , int &$height = ? , int &$imagetype = ? ) : string

exif_thumbnail() 读取 TIFF 或 JPEG 图像中的嵌入缩略图。如果图像不包含缩略图则返回 false。

If you want to deliver thumbnails through this function, you should send the mimetype information using the header() function.

It is possible that exif_thumbnail() cannot create an image but can determine its size. In this case, the return value is false but width and height are set.

参数

filename

The name of the image file being read. This image contains an embedded thumbnail.

width

The return width of the returned thumbnail.

height

The returned height of the returned thumbnail.

imagetype

The returned image type of the returned thumbnail. This is either TIFF or JPEG.

返回值

Returns the embedded thumbnail, or false if the image contains no thumbnail.

更新日志

版本 | 说明
4.3.0 | The optional parameters width, height, and imagetype all became available.
4.3.0 | May return thumbnails in the TIFF format.

范例

Example #1 exif_thumbnail() 例子

<?php
if (array_key_exists('file',$_REQUEST)) {
    $image = exif_thumbnail($_REQUEST['file'], $width, $height, $type);
} else {
    $image = false;
}
if ($image!==false) {
    header("Content-type: ".image_type_to_mime_type($type));
    echo $image;
    exit;
} else {
    // no thumbnail available, handle the error here
    echo "No thumbnail available";
}
?>

参见

  • exif_read_data() - 从 JPEG 或 TIFF 文件中读取 EXIF 头信息
  • image_type_to_mime_type() - 取得 getimagesize，exif_read_data，exif_thumbnail，exif_imagetype 所返回的图像类型的 MIME 类型


别名 exif_read_data

  • ? exif_thumbnail
  • GD ?
  • PHP Manual
  • Exif 函数
  • 别名 exif_read_data

read_exif_data

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

read_exif_data — 别名 exif_read_data()

说明

此函数是该函数的别名： exif_read_data().


图像处理和 GD

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • 使用 PHP 创建 PNG 图像
    • 使用 Alpha 通道为图像加水印
    • 使用 imagecopymerge 函数创建半透明水印
  • GD 和图像处理 函数
    • gd_info — 取得当前安装的 GD 库的信息
    • getimagesize — 取得图像大小
    • getimagesizefromstring — 从字符串中获取图像尺寸信息
    • image_type_to_extension — 取得图像类型的文件后缀
    • image_type_to_mime_type — 取得 getimagesize，exif_read_data，exif_thumbnail，exif_imagetype 所返回的图像类型的 MIME 类型
    • image2wbmp — 以 WBMP 格式将图像输出到浏览器或文件
    • imageaffine — 返回经过仿射变换后的图像，剪切区域可选
    • imageaffinematrixconcat — Concatenate two affine transformation matrices
    • imageaffinematrixget — Get an affine transformation matrix
    • imagealphablending — 设定图像的混色模式
    • imageantialias — 是否使用抗锯齿（antialias）功能
    • imagearc — 画椭圆弧
    • imagebmp — Output a BMP image to browser or file
    • imagechar — 水平地画一个字符
    • imagecharup — 垂直地画一个字符
    • imagecolorallocate — 为一幅图像分配颜色
    • imagecolorallocatealpha — 为一幅图像分配颜色 + alpha
    • imagecolorat — 取得某像素的颜色索引值
    • imagecolorclosest — 取得与指定的颜色最接近的颜色的索引值
    • imagecolorclosestalpha — 取得与指定的颜色加透明度最接近的颜色
    • imagecolorclosesthwb — 取得与给定颜色最接近的色度的黑白色的索引
    • imagecolordeallocate — 取消图像颜色的分配
    • imagecolorexact — 取得指定颜色的索引值
    • imagecolorexactalpha — 取得指定的颜色加透明度的索引值
    • imagecolormatch — 使一个图像中调色板版本的颜色与真彩色版本更能匹配
    • imagecolorresolve — 取得指定颜色的索引值或有可能得到的最接近的替代值
    • imagecolorresolvealpha — 取得指定颜色 + alpha 的索引值或有可能得到的最接近的替代值
    • imagecolorset — 给指定调色板索引设定颜色
    • imagecolorsforindex — 取得某索引的颜色
    • imagecolorstotal — 取得一幅图像的调色板中颜色的数目
    • imagecolortransparent — 将某个颜色定义为透明色
    • imageconvolution — 用系数 div 和 offset 申请一个 3x3 的卷积矩阵
    • imagecopy — 拷贝图像的一部分
    • imagecopymerge — 拷贝并合并图像的一部分
    • imagecopymergegray — 用灰度拷贝并合并图像的一部分
    • imagecopyresampled — 重采样拷贝部分图像并调整大小
    • imagecopyresized — 拷贝部分图像并调整大小
    • imagecreate — 新建一个基于调色板的图像
    • imagecreatefrombmp — 由文件或 URL 创建一个新图象。
    • imagecreatefromgd2 — 从 GD2 文件或 URL 新建一图像
    • imagecreatefromgd2part — 从给定的 GD2 文件或 URL 中的部分新建一图像
    • imagecreatefromgd — 从 GD 文件或 URL 新建一图像
    • imagecreatefromgif — 由文件或 URL 创建一个新图象。
    • imagecreatefromjpeg — 由文件或 URL 创建一个新图象。
    • imagecreatefrompng — 由文件或 URL 创建一个新图象。
    • imagecreatefromstring — 从字符串中的图像流新建一图像
    • imagecreatefromwbmp — 由文件或 URL 创建一个新图象。
    • imagecreatefromwebp — 由文件或 URL 创建一个新图象。
    • imagecreatefromxbm — 由文件或 URL 创建一个新图象。
    • imagecreatefromxpm — 由文件或 URL 创建一个新图象。
    • imagecreatetruecolor — 新建一个真彩色图像
    • imagecrop — Crop an image to the given rectangle
    • imagecropauto — Crop an image automatically using one of the available modes
    • imagedashedline — 画一虚线
    • imagedestroy — 销毁一图像
    • imageellipse — 画一个椭圆
    • imagefill — 区域填充
    • imagefilledarc — 画一椭圆弧且填充
    • imagefilledellipse — 画一椭圆并填充
    • imagefilledpolygon — 画一多边形并填充
    • imagefilledrectangle — 画一矩形并填充
    • imagefilltoborder — 区域填充到指定颜色的边界为止
    • imagefilter — 对图像使用过滤器
    • imageflip — Flips an image using a given mode
    • imagefontheight — 取得字体高度
    • imagefontwidth — 取得字体宽度
    • imageftbbox — 给出一个使用 FreeType 2 字体的文本框
    • imagefttext — 使用 FreeType 2 字体将文本写入图像
    • imagegammacorrect — 对 GD 图像应用 gamma 修正
    • imagegd2 — 将 GD2 图像输出到浏览器或文件
    • imagegd — 将 GD 图像输出到浏览器或文件
    • imagegetclip — Get the clipping rectangle
    • imagegetinterpolation — Get the interpolation method
    • imagegif — 输出图象到浏览器或文件。
    • imagegrabscreen — Captures the whole screen
    • imagegrabwindow — Captures a window
    • imageinterlace — 启用或禁用隔行扫描
    • imageistruecolor — 检查图像是否为真彩色图像
    • imagejpeg — 输出图象到浏览器或文件。
    • imagelayereffect — 设定 alpha 混色标志以使用绑定的 libgd 分层效果
    • imageline — 画一条线段
    • imageloadfont — 载入一新字体
    • imageopenpolygon — Draws an open polygon
    • imagepalettecopy — 将调色板从一幅图像拷贝到另一幅
    • imagepalettetotruecolor — Converts a palette based image to true color
    • imagepng — 以 PNG 格式将图像输出到浏览器或文件
    • imagepolygon — 画一个多边形
    • imagerectangle — 画一个矩形
    • imageresolution — Get or set the resolution of the image
    • imagerotate — 用给定角度旋转图像
    • imagesavealpha — 设置标记以在保存 PNG 图像时保存完整的 alpha 通道信息（与单一透明色相反）
    • imagescale — Scale an image using the given new width and height
    • imagesetbrush — 设定画线用的画笔图像
    • imagesetclip — Set the clipping rectangle
    • imagesetinterpolation — Set the interpolation method
    • imagesetpixel — 画一个单一像素
    • imagesetstyle — 设定画线的风格
    • imagesetthickness — 设定画线的宽度
    • imagesettile — 设定用于填充的贴图
    • imagestring — 水平地画一行字符串
    • imagestringup — 垂直地画一行字符串
    • imagesx — 取得图像宽度
    • imagesy — 取得图像高度
    • imagetruecolortopalette — 将真彩色图像转换为调色板图像
    • imagettfbbox — 取得使用 TrueType 字体的文本的范围
    • imagettftext — 用 TrueType 字体向图像写入文本
    • imagetypes — 返回当前 PHP 版本所支持的图像类型
    • imagewbmp — 以 WBMP 格式将图像输出到浏览器或文件
    • imagewebp — 将 WebP 格式的图像输出到浏览器或文件
    • imagexbm — 将 XBM 图像输出到浏览器或文件
    • iptcembed — 将二进制 IPTC 数据嵌入到一幅 JPEG 图像中
    • iptcparse — 将二进制 IPTC 块解析为单个标记
    • jpeg2wbmp — 将 JPEG 图像文件转换为 WBMP 图像文件
    • png2wbmp — 将 PNG 图像文件转换为 WBMP 图像文件


简介

PHP 并不仅限于创建 HTML 输出， 它也可以创建和处理包括 GIF， PNG， JPEG， WBMP 以及 XPM 在内的多种格式的图像。 更加方便的是，PHP 可以直接将图像数据流输出到浏览器。 要想在 PHP 中使用图像处理功能，你需要连带 GD 库一起来编译 PHP。 GD 库和 PHP 可能需要其他的库， 这取决于你要处理的图像格式。

你可以使用 PHP 中的图像函数来获取下列格式图像的大小： JPEG， GIF， PNG， SWF， TIFF 和 JPEG2000。

如果联合 exif 扩展 一起使用， 你可以操作存储在 JPEG 和 TIFF 图像文件头部的信息， 这样就就可以获取数码相机所产生的元数据。 exif 相关的函数不需要 GD 库亦可使用。

Note: 关于如何扩展图像处理能力，例如读取、写入以及修改， 请参考"需求"一节。 要想读取数码相机拍摄的图片的元数据， 你需要上面提到的 exif 扩展。

Note: getimagesize() 函数不需要 GD 扩展库。

Caution

由于绑定的 GD 库使用 Zend 内存管理机制来分配内存， 所以所使用的内存大小不受 memory_limit 配置参数限制。

GD 库支持多种图像格式， 下标所列的是 GD 所支持的格式，请注意备图像格式对应的读取/写入支持的可用性。

GD 所支持的格式
格式 | 支持读取 | 支持写入 | 备注
JPEG | true | true |
PNG | true | true |
GIF | true | true | 从 GD 2.0.28 及 PHP 5.0.1 开始支持
XBM | true | true |
XPM | true | false | 在 Windows 平台上，从 PHP 5.3.19 开始支持读取。
WBMP | true | true |
WebP | true | true | PHP 5.5+
BMP | true | true | 从 GD 2.1.0 及 PHP 7.2.0 开始支持

很遗憾的是，虽然上表中显示大部分图像格式都是支持读取和写入的， 但是不代表你的 PHP 环境在编译的时候是支持这些操作的。 要想检测 GD 库所支持的格式，请使用 gd_info() 函数， 更多信息请参考 "安装" 一章。


需求

如果你有 GD 库（可从 » http://www.libgd.org/ 获得）， 你就可以创建 和处理图像。

可以处理的图像格式由你所使用的 GD 库版本 以及 GD 库可能需要的其他库决定。 在 gd-2.0.28 中，提供了对 GIF 格式的支持。

Note: 要求 libgd-2.0.4 或更高版本， PHP 5.5 要求 libgd-2.1.0 或更高版本。 你也可以使用 PHP 中绑定的 GD 库。

你可能希望增强 GD 库以处理更多的图像格式。

支持的图像格式
图像格式 | 需要下载的库 | 备注
gif |  | 仅在 gd-2.0.28 及更高版本的 GD 库提供支持， 从 PHP 5.0.1 开始支持 写入 操作。
jpeg | » http://www.ijg.org/ | 在构建 PHP 之前， 需要在配置步骤使用 --enable-shared 选项来构建 jpeg 库。 如果不使用此选项，那么在构建 PHP 时的配置环节， 会产生 libjpeg.(a|so) not found 的错误。
png | » http://www.libpng.org/pub/png/libpng.html |
xpm | » ftp://metalab.unc.edu/pub/Linux/libs/X/!INDEX.html | 如果你的系统中已经安装了 X 环境， 就已经包含这个库了。

你可能希望增强 GD 库来使用不同的字体。 下列字体库是受支持的：

支持的字体库
字体库 | 下载 | 备注
FreeType 1.x | » http://www.freetype.org/ | 从 PHP 5.3.0 开始，不再提供对 FreeType 1.x 的支持。
FreeType 2 | » http://www.freetype.org/ |
T1lib | » ftp://sunsite.unc.edu/pub/Linux/libs/graphics/) | 支持 Postscript Type 1 字体（在 PHP 7.0.0 中移除）。


安装

要激活 GD 支持，配置 PHP 时加上 --with-gd[=DIR]，DIR 是 GD 的基本安装目录。要使用推荐的绑定的 GD 库版本（首次绑定于 PHP 4.3.0），使用 --with-gd。要编译 GD 库，需要libpng 和 libjpeg。

在 Windows 中，需要将 GD2 的 DLL 文件 php_gd2.dll 作为一个扩展包含在 php.ini 中。GD1 的 DLL 文件 php_gd.dll 在 PHP 4.3.2 中被删除了。此外要注意首选的真彩色图像函数，例如 imagecreatetruecolor()，需要 GD2。

Note:

要在 Windows 下启用 exif，在 php.ini 中 php_mbstring.dll 必须在 php_exif.dll 之前加载。

要在 PHP 3 中禁止 GD 支持，在配置时加上 --without-gd。

要增强 GD 的能力以处理更多的图像格式，在配置 PHP 时指定 --with-XXXX 的配置开关。

所支持的图像格式
图像格式 | 配置开关
jpeg-6b | 要激活 jpeg-6b 的支持，加上 --with-jpeg-dir=DIR.
png | 要激活 png 的支持，加上 --with-png-dir=DIR。注意，libpng 需要 zlib library，因此配置中还要加上 --with-zlib-dir[=DIR]。
xpm | 要激活 xpm 的支持，加上 --with-xpm-dir=DIR。如果配置时提示找不到所需要的库，可以加上到 X11 库的路径。

Note: 当把 PHP 和 libpng 一起编译时，必须使用和 GD 库连接的同一个版本。

要增强 GD 的能力以处理更多的字体，在配置 PHP 时指定 --with-XXXX 的配置开关。

所支持的字库
字库 | 配置开关
FreeType 1.x | 要激活 FreeType 1.x 的支持，加上 --with-ttf[=DIR]。
FreeType 2 | 要激活 FreeType 2 的支持，加上 --with-freetype-dir=DIR。
T1lib | 要激活 T1lib（Type 1 字体），加上 --with-t1lib[=DIR]。
本地 TrueType 字符串函数 | 要激活本地 TrueType 字符串函数的支持，加上 --enable-gd-native-ttf。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Image 配置选项
名字 | 默认 | 可修改范围 | 更新日志
gd.jpeg_ignore_warning | "1" | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

gd.jpeg_ignore_warning bool

Ignore warnings (but not errors) created by libjpeg(-turbo).

gd.jpeg_ignore_warning 变更日志
版本 | 说明
7.1.0 | gd.jpeg_ignore_warning 默认值从 0 变更为 1。

参见 exif 配置。

Warning

图片处理函数相当占用内存，请确保你的 memory_limit 设置。


资源类型

本扩展定义了 2 个资源类型：

GD 库中定义的资源类型
名称 | 描述 | 说明
gd | 图像资源，由 imagecreatefrompng() 等函数使用 |
gd font | 由 imageloadfont() 函数内部创建的字体资源 |
gd PS font | PostScript Type 1 字体资源，由 imagepsloadfont() 函数返回 | 在 PHP 7.0.0 中被移除。
gd PS encoding | PostScript Type 1 编码资源，由 imagepsencodefont() 函数返回 | 在 PHP 7.0.0 中被移除。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

GD_VERSION (string)
PHP 编译所依据的 GD 版本。 （PHP 5.2.4 可用）
GD_MAJOR_VERSION (integer)
PHP 编译所依据的 GD 大版本。 （PHP 5.2.4 可用）
GD_MINOR_VERSION (integer)
PHP 编译所依据的 GD 小版本。 （PHP 5.2.4 可用）
GD_RELEASE_VERSION (integer)
PHP 编译所依据的 GD 发布版本。 （PHP 5.2.4 可用）
GD_EXTRA_VERSION (string)
PHP 编译所依据的 GD 扩展版本（beta/rc..）。 （PHP 5.2.4 可用）
GD_BUNDLED (integer)
当使用绑定版本的 GD 时，此值为 1， 反之为 0。
IMG_BMP (integer)
Used as a return value by imagetypes()
IMG_GIF (integer)
Used as a return value by imagetypes()
IMG_JPG (integer)
Used as a return value by imagetypes()
IMG_JPEG (integer)
Used as a return value by imagetypes()

Note:

本常量值同 IMG_JPG

IMG_PNG (integer)
Used as a return value by imagetypes()
IMG_WBMP (integer)
Used as a return value by imagetypes()
IMG_XPM (integer)
Used as a return value by imagetypes()
IMG_WEBP (integer)
Used as a return value by imagetypes() PHP 5.6.25 和 PHP 7.0.10 版本中都可用。
IMG_COLOR_TILED (integer)
Special color option which can be used instead of a color allocated with imagecolorallocate() or imagecolorallocatealpha().
IMG_COLOR_STYLED (integer)
Special color option which can be used instead of a color allocated with imagecolorallocate() or imagecolorallocatealpha().
IMG_COLOR_BRUSHED (integer)
Special color option which can be used instead of a color allocated with imagecolorallocate() or imagecolorallocatealpha().
IMG_COLOR_STYLEDBRUSHED (integer)
Special color option which can be used instead of a color allocated with imagecolorallocate() or imagecolorallocatealpha().
IMG_COLOR_TRANSPARENT (integer)
Special color option which can be used instead of a color allocated with imagecolorallocate() or imagecolorallocatealpha().
IMG_AFFINE_TRANSLATE (integer)
An affine transformation type constant used by the imageaffinematrixget() function.
IMG_AFFINE_SCALE (integer)
An affine transformation type constant used by the imageaffinematrixget() function.
IMG_AFFINE_ROTATE (integer)
An affine transformation type constant used by the imageaffinematrixget() function.
IMG_AFFINE_SHEAR_HORIZONTAL (integer)
An affine transformation type constant used by the imageaffinematrixget() function.
IMG_AFFINE_SHEAR_VERTICAL (integer)
An affine transformation type constant used by the imageaffinematrixget() function.
IMG_ARC_ROUNDED (integer)
A style constant used by the imagefilledarc() function.

Note:

此常量值同 IMG_ARC_PIE

IMG_ARC_PIE (integer)
A style constant used by the imagefilledarc() function.
IMG_ARC_CHORD (integer)
A style constant used by the imagefilledarc() function.
IMG_ARC_NOFILL (integer)
A style constant used by the imagefilledarc() function.
IMG_ARC_EDGED (integer)
A style constant used by the imagefilledarc() function.
IMG_GD2_RAW (integer)
A type constant used by the imagegd2() function.
IMG_GD2_COMPRESSED (integer)
A type constant used by the imagegd2() function.
IMG_EFFECT_REPLACE (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_EFFECT_ALPHABLEND (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_EFFECT_NORMAL (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_EFFECT_OVERLAY (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_EFFECT_MULTIPLY (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_FILTER_NEGATE (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_GRAYSCALE (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_BRIGHTNESS (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_CONTRAST (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_COLORIZE (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_EDGEDETECT (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_GAUSSIAN_BLUR (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_SELECTIVE_BLUR (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_EMBOSS (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_MEAN_REMOVAL (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_SMOOTH (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_PIXELATE (integer)
Special GD filter used by the imagefilter() function. （PHP 5.3.0 可用）
IMG_FILTER_SCATTER (integer)
Special GD filter used by the imagefilter() function. （自 PHP 7.4.0 版本可用）
IMAGETYPE_GIF (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JPEG (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JPEG2000 (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_PNG (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_SWF (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_PSD (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_BMP (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_WBMP (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_XBM (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_TIFF_II (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_TIFF_MM (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_IFF (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JB2 (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JPC (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JP2 (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JPX (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_SWC (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_ICO (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions. (自 PHP 5.3.0 开始支持)
IMAGETYPE_WEBP (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions. (从 PHP 7.1.0 开始支持)
PNG_NO_FILTER (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_NONE (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_SUB (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_UP (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_AVG (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_PAETH (integer)
A special PNG filter, used by the imagepng() function.
PNG_ALL_FILTERS (integer)
A special PNG filter, used by the imagepng() function.
IMG_FLIP_VERTICAL (int)
Used together with imageflip(), available as of PHP 5.5.0.
IMG_FLIP_HORIZONTAL (int)
Used together with imageflip(), available as of PHP 5.5.0.
IMG_FLIP_BOTH (int)
Used together with imageflip(), available as of PHP 5.5.0.
IMG_BELL (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_BESSEL (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_BILINEAR_FIXED (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_BICUBIC (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_BICUBIC (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_BLACKMAN (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_BOX (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_BSPLINE (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_CATMULLROM (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_GAUSSIAN (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_GENERALIZED_CUBIC (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_HERMITE (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_HAMMING (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_HANNING (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_MITCHELL (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_POWER (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_QUADRATIC (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_SINC (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_NEAREST_NEIGHBOUR (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_WEIGHTED4 (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.
IMG_TRIANGLE (int)
Used together with imagesetinterpolation(), available as of PHP 5.5.0.


范例

Table of Contents

  • 使用 PHP 创建 PNG 图像
  • 使用 Alpha 通道为图像加水印
  • 使用 imagecopymerge 函数创建半透明水印


使用 PHP 创建 PNG 图像

Example #1 使用 PHP 创建 PNG 图像

<?php

header("Content-type: image/png");
$string = $_GET['text'];
$im     = imagecreatefrompng("images/button1.png");
$orange = imagecolorallocate($im, 220, 210, 60);
$px     = (imagesx($im) - 7.5 * strlen($string)) / 2;
imagestring($im, 3, $px, 9, $string, $orange);
imagepng($im);
imagedestroy($im);

?>
本例程需要从带有 <img src="button.php?text=text"> 标签的页面调用。 上述 button.php 脚本将 "text" 字符串绘制到一个图像上， 在本例中图像文件为 "images/button1.png"， 然后输出绘制后的图像。 当你需要经常修改图像上的文字时， 动态生成图像就可以省去了每次都重新制作图像的麻烦。


使用 Alpha 通道为图像加水印

Example #1 使用 Alpha 通道为图像加水印

<?php
// 加载水印以及要加水印的图像
$stamp = imagecreatefrompng('stamp.png');
$im = imagecreatefromjpeg('photo.jpeg');

// 设置水印图像的外边距，并且获取水印图像的尺寸
$marge_right = 10;
$marge_bottom = 10;
$sx = imagesx($stamp);
$sy = imagesy($stamp);

// 利用图像的宽度和水印的外边距计算位置，并且将水印复制到图像上

imagecopy($im, $stamp, imagesx($im) - $sx - $marge_right, imagesy($im) - $sy - $marge_bottom, 0, 0, imagesx($stamp), imagesy($stamp));

// 输出图像并释放内存
header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>
使用 Alpha 通道为图像加水印
本示例是为图像加水印以及版权信息的常见方式。 请注意，水印图像中所包含的 alpha 通道信息以及文本的抗锯齿效果， 都会在复制过程中保留。


使用 imagecopymerge 函数创建半透明水印

  • ? 使用 Alpha 通道为图像加水印
  • GD 和图像处理 函数 ?
  • PHP Manual
  • 范例
  • 使用 imagecopymerge 函数创建半透明水印

使用 imagecopymerge() 函数创建半透明水印

Example #1 使用 imagecopymerge() 函数创建半透明水印

<?php
// 加载要加水印的图像
$im = imagecreatefromjpeg('photo.jpeg');

// 首先我们从 GD 手动创建水印图像
$stamp = imagecreatetruecolor(100, 70);
imagefilledrectangle($stamp, 0, 0, 99, 69, 0x0000FF);
imagefilledrectangle($stamp, 9, 9, 90, 60, 0xFFFFFF);
imagestring($stamp, 5, 20, 20, 'libGD', 0x0000FF);
imagestring($stamp, 3, 20, 40, '(c) 2007-9', 0x0000FF);

// 设置水印图像的位置和大小
$marge_right = 10;
$marge_bottom = 10;
$sx = imagesx($stamp);
$sy = imagesy($stamp);

// 以 50% 的透明度合并水印和图像
imagecopymerge($im, $stamp, imagesx($im) - $sx - $marge_right, imagesy($im) - $sy - $marge_bottom, 0, 0, imagesx($stamp), imagesy($stamp), 50);

// 将图像保存到文件，并释放内存
imagepng($im, 'photo_stamp.png');
imagedestroy($im);

?>
使用 imagecopymerge() 函数创建半透明水印
本示例使用 imagecopymerge() 函数 来合并水印图像和原始图像。 我们可以控制水印的透明度，在本例中是 50% 的透明度。 在实际使用中， 使用半透明水印可以在不影响用户观看图像的前提下进行版权保护。


GD 和图像处理 函数

Table of Contents

  • gd_info — 取得当前安装的 GD 库的信息
  • getimagesize — 取得图像大小
  • getimagesizefromstring — 从字符串中获取图像尺寸信息
  • image_type_to_extension — 取得图像类型的文件后缀
  • image_type_to_mime_type — 取得 getimagesize，exif_read_data，exif_thumbnail，exif_imagetype 所返回的图像类型的 MIME 类型
  • image2wbmp — 以 WBMP 格式将图像输出到浏览器或文件
  • imageaffine — 返回经过仿射变换后的图像，剪切区域可选
  • imageaffinematrixconcat — Concatenate two affine transformation matrices
  • imageaffinematrixget — Get an affine transformation matrix
  • imagealphablending — 设定图像的混色模式
  • imageantialias — 是否使用抗锯齿（antialias）功能
  • imagearc — 画椭圆弧
  • imagebmp — Output a BMP image to browser or file
  • imagechar — 水平地画一个字符
  • imagecharup — 垂直地画一个字符
  • imagecolorallocate — 为一幅图像分配颜色
  • imagecolorallocatealpha — 为一幅图像分配颜色 + alpha
  • imagecolorat — 取得某像素的颜色索引值
  • imagecolorclosest — 取得与指定的颜色最接近的颜色的索引值
  • imagecolorclosestalpha — 取得与指定的颜色加透明度最接近的颜色
  • imagecolorclosesthwb — 取得与给定颜色最接近的色度的黑白色的索引
  • imagecolordeallocate — 取消图像颜色的分配
  • imagecolorexact — 取得指定颜色的索引值
  • imagecolorexactalpha — 取得指定的颜色加透明度的索引值
  • imagecolormatch — 使一个图像中调色板版本的颜色与真彩色版本更能匹配
  • imagecolorresolve — 取得指定颜色的索引值或有可能得到的最接近的替代值
  • imagecolorresolvealpha — 取得指定颜色 + alpha 的索引值或有可能得到的最接近的替代值
  • imagecolorset — 给指定调色板索引设定颜色
  • imagecolorsforindex — 取得某索引的颜色
  • imagecolorstotal — 取得一幅图像的调色板中颜色的数目
  • imagecolortransparent — 将某个颜色定义为透明色
  • imageconvolution — 用系数 div 和 offset 申请一个 3x3 的卷积矩阵
  • imagecopy — 拷贝图像的一部分
  • imagecopymerge — 拷贝并合并图像的一部分
  • imagecopymergegray — 用灰度拷贝并合并图像的一部分
  • imagecopyresampled — 重采样拷贝部分图像并调整大小
  • imagecopyresized — 拷贝部分图像并调整大小
  • imagecreate — 新建一个基于调色板的图像
  • imagecreatefrombmp — 由文件或 URL 创建一个新图象。
  • imagecreatefromgd2 — 从 GD2 文件或 URL 新建一图像
  • imagecreatefromgd2part — 从给定的 GD2 文件或 URL 中的部分新建一图像
  • imagecreatefromgd — 从 GD 文件或 URL 新建一图像
  • imagecreatefromgif — 由文件或 URL 创建一个新图象。
  • imagecreatefromjpeg — 由文件或 URL 创建一个新图象。
  • imagecreatefrompng — 由文件或 URL 创建一个新图象。
  • imagecreatefromstring — 从字符串中的图像流新建一图像
  • imagecreatefromwbmp — 由文件或 URL 创建一个新图象。
  • imagecreatefromwebp — 由文件或 URL 创建一个新图象。
  • imagecreatefromxbm — 由文件或 URL 创建一个新图象。
  • imagecreatefromxpm — 由文件或 URL 创建一个新图象。
  • imagecreatetruecolor — 新建一个真彩色图像
  • imagecrop — Crop an image to the given rectangle
  • imagecropauto — Crop an image automatically using one of the available modes
  • imagedashedline — 画一虚线
  • imagedestroy — 销毁一图像
  • imageellipse — 画一个椭圆
  • imagefill — 区域填充
  • imagefilledarc — 画一椭圆弧且填充
  • imagefilledellipse — 画一椭圆并填充
  • imagefilledpolygon — 画一多边形并填充
  • imagefilledrectangle — 画一矩形并填充
  • imagefilltoborder — 区域填充到指定颜色的边界为止
  • imagefilter — 对图像使用过滤器
  • imageflip — Flips an image using a given mode
  • imagefontheight — 取得字体高度
  • imagefontwidth — 取得字体宽度
  • imageftbbox — 给出一个使用 FreeType 2 字体的文本框
  • imagefttext — 使用 FreeType 2 字体将文本写入图像
  • imagegammacorrect — 对 GD 图像应用 gamma 修正
  • imagegd2 — 将 GD2 图像输出到浏览器或文件
  • imagegd — 将 GD 图像输出到浏览器或文件
  • imagegetclip — Get the clipping rectangle
  • imagegetinterpolation — Get the interpolation method
  • imagegif — 输出图象到浏览器或文件。
  • imagegrabscreen — Captures the whole screen
  • imagegrabwindow — Captures a window
  • imageinterlace — 启用或禁用隔行扫描
  • imageistruecolor — 检查图像是否为真彩色图像
  • imagejpeg — 输出图象到浏览器或文件。
  • imagelayereffect — 设定 alpha 混色标志以使用绑定的 libgd 分层效果
  • imageline — 画一条线段
  • imageloadfont — 载入一新字体
  • imageopenpolygon — Draws an open polygon
  • imagepalettecopy — 将调色板从一幅图像拷贝到另一幅
  • imagepalettetotruecolor — Converts a palette based image to true color
  • imagepng — 以 PNG 格式将图像输出到浏览器或文件
  • imagepolygon — 画一个多边形
  • imagerectangle — 画一个矩形
  • imageresolution — Get or set the resolution of the image
  • imagerotate — 用给定角度旋转图像
  • imagesavealpha — 设置标记以在保存 PNG 图像时保存完整的 alpha 通道信息（与单一透明色相反）
  • imagescale — Scale an image using the given new width and height
  • imagesetbrush — 设定画线用的画笔图像
  • imagesetclip — Set the clipping rectangle
  • imagesetinterpolation — Set the interpolation method
  • imagesetpixel — 画一个单一像素
  • imagesetstyle — 设定画线的风格
  • imagesetthickness — 设定画线的宽度
  • imagesettile — 设定用于填充的贴图
  • imagestring — 水平地画一行字符串
  • imagestringup — 垂直地画一行字符串
  • imagesx — 取得图像宽度
  • imagesy — 取得图像高度
  • imagetruecolortopalette — 将真彩色图像转换为调色板图像
  • imagettfbbox — 取得使用 TrueType 字体的文本的范围
  • imagettftext — 用 TrueType 字体向图像写入文本
  • imagetypes — 返回当前 PHP 版本所支持的图像类型
  • imagewbmp — 以 WBMP 格式将图像输出到浏览器或文件
  • imagewebp — 将 WebP 格式的图像输出到浏览器或文件
  • imagexbm — 将 XBM 图像输出到浏览器或文件
  • iptcembed — 将二进制 IPTC 数据嵌入到一幅 JPEG 图像中
  • iptcparse — 将二进制 IPTC 块解析为单个标记
  • jpeg2wbmp — 将 JPEG 图像文件转换为 WBMP 图像文件
  • png2wbmp — 将 PNG 图像文件转换为 WBMP 图像文件


取得当前安装的 GD 库的信息

  • ? GD 和图像处理 函数
  • getimagesize ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得当前安装的 GD 库的信息

gd_info

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

gd_info — 取得当前安装的 GD 库的信息

说明

gd_info ( ) : array

获取当前安装的 GD 库的版本和功能的信息。

返回值

返回一个关联数组。

gd_info() 返回的数组元素
属性 | 含义
GD Version | 描述安装的 libgd 的版本的 string 值。
FreeType Support | bool 值。如果安装了 FreeType 支持则为 true。
FreeType Linkage | 描述 FreeType 链接方式的 string 值。 可能值为：'with freetype'、'with TTF library' 和 'with unknown library'。 仅当 FreeType Support 为 true 时才会有该属性。
GIF Read Support | bool 值。 如果支持 读取 GIF 图像， 则为 true。
GIF Create Support | bool 值。 如果支持 创建 GIF 图像， 则为 true。
JPEG Support | bool 值。 如果支持 JPEG 则为 true 。
PNG Support | bool 值。 如果支持 PNG 则为 true 。
WBMP Support | bool 值。 如果支持 WBMP 则为 true 。
XBM Support | bool 值。 如果支持 XBM 则为 true 。
WebP Support | bool 值。 如果支持 WebP 则为 true 。

范例

Example #1 使用 gd_info()

<?php
var_dump(gd_info());
?>

以上例程的输出类似于：

array(10) {
  ["GD Version"]=>
  string(24) "bundled (2.1.0 compatible)"
  ["FreeType Support"]=>
  bool(false)
  ["GIF Read Support"]=>
  bool(true)
  ["GIF Create Support"]=>
  bool(false)
  ["JPEG Support"]=>
  bool(false)
  ["PNG Support"]=>
  bool(true)
  ["WBMP Support"]=>
  bool(true)
  ["XBM Support"]=>
  bool(false)
  ["WebP Support"]=>
  bool(false)
}

参见

  • imagepng() - 以 PNG 格式将图像输出到浏览器或文件
  • imagejpeg() - 输出图象到浏览器或文件。
  • imagegif() - 输出图象到浏览器或文件。
  • imagewbmp() - 以 WBMP 格式将图像输出到浏览器或文件
  • imagewebp() - 将 WebP 格式的图像输出到浏览器或文件
  • imagetypes() - 返回当前 PHP 版本所支持的图像类型


取得图像大小

  • ? gd_info
  • getimagesizefromstring ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得图像大小

getimagesize

(PHP 4, PHP 5, PHP 7, PHP 8)

getimagesize — 取得图像大小

说明

getimagesize ( string $filename , array &$imageinfo = ? ) : array

getimagesize() 函数将测定任何 GIF，JPG，PNG，SWF，SWC，PSD，TIFF，BMP，IFF，JP2，JPX，JB2，JPC，XBM 或 WBMP 图像文件的大小并返回图像的尺寸以及文件类型和一个可以用于普通 HTML 文件中 IMG 标记中的 height/width 文本字符串。

如果不能访问 filename 指定的图像或者其不是有效的图像，getimagesize() 将返回 false 并产生一条 E_WARNING 级的错误。

Note:

对 JPC，JP2，JPX，JB2，XBM 和 WBMP 的支持自 PHP 4.3.2 起可用。对 SWC 的支持自 PHP 4.3.0 起可用。对 TIFF 的支持是 PHP 4.2.0 添加的。

Note: JPEG 2000 支持是 PHP 4.3.2 添加的。注意 JPC 和 JP2 可以有不同的色彩深度的成分。此情况下，"bits"的值是碰到的最高的位深度。此外，JP2 文件可能包含有多个 JPEG 2000 代码流，此情况下，getimagesize() 返回此文件顶层中碰到的第一个代码流的值。

Note: 本函数不需要 GD 图像库。

返回一个具有四个单元的数组。索引 0 包含图像宽度的像素值，索引 1 包含图像高度的像素值。索引 2 是图像类型的标记：1 = GIF，2 = JPG，3 = PNG，4 = SWF，5 = PSD，6 = BMP，7 = TIFF(intel byte order)，8 = TIFF(motorola byte order)，9 = JPC，10 = JP2，11 = JPX，12 = JB2，13 = SWC，14 = IFF，15 = WBMP，16 = XBM。这些标记与 PHP 4.3.0 新加的 IMAGETYPE 常量对应。索引 3 是文本字符串，内容为"height="yyy" width="xxx""，可直接用于 IMG 标记。

Example #1 getimagesize（文件）

<?php
list($width, $height, $type, $attr) = getimagesize("img/flag.jpg");
echo "<img src=\"img/flag.jpg\" $attr>";
?>

URL 支持是 PHP 4.0.5 添加的。

Example #2 getimagesize（URL）

<?php
$size = getimagesize("http://www.example.com/gifs/logo.gif");

// if the file name has space in it, encode it properly
$size = getimagesize("http://www.example.com/gifs/lo%20go.gif");

?>

对于 JPG 图像，还会多返回两个索引：channels 和 bits。channels 对于 RGB 图像其值为 3，对于 CMYK 图像其值为 4。bits 是每种颜色的位数。

自 PHP 4.3.0 起，bits 和 channels 对于其它图像类型也存在。但是这些值可能会把人搞糊涂。例如，GIF 总是对每个像素使用 3 个 channel，但是对于动画 GIF 来说每个像素的位数无法通过全局颜色表计算出来。

某些格式可能不包含图像或者包含多个图像。此种情况下，getimagesize() 可能不能用来准确测定图像的大小。此时 getimagesize() 将返回零作为宽度和高度。

自 PHP 4.3.0 起，getimagesize() 还会返回额外的参数 mime，符合该图像的 MIME 类型。此信息可以用来在 HTTP Content-type 头信息中发送正确的信息：

Example #3 getimagesize() 和 MIME 类型

<?php
$size = getimagesize($filename);
$fp=fopen($filename, "rb");
if ($size && $fp) {
  header("Content-type: {$size['mime']}");
  fpassthru($fp);
  exit;
} else {
  // error
}
?>

可选的 imageinfo 参数允许从图像文件中提取一些扩展信息。目前，这将以一个关联数组返回不同的 JPG APP 标识。某些程序用这些 APP 标识来在图像中嵌入文本信息。一个非常常见的是 APP13 标识中嵌入的 IPTC » http://www.iptc.org/ 信息。可以用 iptcparse() 函数来将二进制的 APP13 标识解析为可读的信息。

Example #4 getimagesize() 返回 IPTC

<?php
$size = getimagesize("testimg.jpg", &$info);
if (isset($info["APP13"])) {
    $iptc = iptcparse($info["APP13"]);
    var_dump($iptc);
}
?>

参见 image_type_to_mime_type()，exif_imagetype()，exif_read_data() 和 exif_thumbnail()。

参数

filename

This parameter specifies the file you wish to retrieve information about. It can reference a local file or (configuration permitting) a remote file using one of the supported streams.

imageinfo

This optional parameter allows you to extract some extended information from the image file. Currently, this will return the different JPG APP markers as an associative array. Some programs use these APP markers to embed text information in images. A very common one is to embed » IPTC information in the APP13 marker. You can use the iptcparse() function to parse the binary APP13 marker into something readable.

返回值

Returns an array with 7 elements.

Index 0 and 1 contains respectively the width and the height of the image.

Note:

Some formats may contain no image or may contain multiple images. In these cases, getimagesize() might not be able to properly determine the image size. getimagesize() will return zero for width and height in these cases.

Index 2 is one of the IMAGETYPE_XXX constants indicating the type of the image.

Index 3 is a text string with the correct height="yyy" width="xxx" string that can be used directly in an IMG tag.

mime is the correspondant MIME type of the image. This information can be used to deliver images with the correct HTTP Content-type header:

Example #5 getimagesize() and MIME types

<?php
$size = getimagesize($filename);
$fp = fopen($filename, "rb");
if ($size && $fp) {
    header("Content-type: {$size['mime']}");
    fpassthru($fp);
    exit;
} else {
    // error
}
?>

channels will be 3 for RGB pictures and 4 for CMYK pictures.

bits is the number of bits for each color.

For some image types, the presence of channels and bits values can be a bit confusing. As an example, GIF always uses 3 channels per pixel, but the number of bits per pixel cannot be calculated for an animated GIF with a global color table.

On failure, false is returned.

错误／异常

If accessing the filename image is impossible, or if it isn't a valid picture, getimagesize() will generate an error of level E_WARNING. On read error, getimagesize() will generate an error of level E_NOTICE.

更新日志

版本 | 说明
5.3.0 | Added icon support.
5.2.3 | Read errors generated by this function downgraded to E_NOTICE from E_WARNING.
4.3.2 | Support for JPC, JP2, JPX, JB2, XBM, and WBMP became available.
4.3.2 | JPEG 2000 support was added for the imageinfo parameter.
4.3.0 | bits and channels are present for other image types, too.
4.3.0 | mime was added.
4.3.0 | Support for SWC and IFF was added.
4.2.0 | Support for TIFF was added.
4.0.6 | Support for BMP and PSD was added.
4.0.5 | URL support was added.

范例

Example #6 getimagesize() example

<?php
list($width, $height, $type, $attr) = getimagesize("img/flag.jpg");
echo "<img src=\"img/flag.jpg\" $attr alt=\"getimagesize() example\" />";
?>

Example #7 getimagesize (URL)

<?php
$size = getimagesize("http://www.example.com/gifs/logo.gif");

// if the file name has space in it, encode it properly
$size = getimagesize("http://www.example.com/gifs/lo%20go.gif");

?>

Example #8 getimagesize() returning IPTC

<?php
$size = getimagesize("testimg.jpg", $info);
if (isset($info["APP13"])) {
    $iptc = iptcparse($info["APP13"]);
    var_dump($iptc);
}
?>

注释

Note:

此函数不需要 GD 图象库。

参见

  • image_type_to_mime_type() - 取得 getimagesize，exif_read_data，exif_thumbnail，exif_imagetype 所返回的图像类型的 MIME 类型
  • exif_imagetype() - 判断一个图像的类型
  • exif_read_data() - 从 JPEG 或 TIFF 文件中读取 EXIF 头信息
  • exif_thumbnail() - 取得嵌入在 TIFF 或 JPEG 图像中的缩略图


从字符串中获取图像尺寸信息

  • ? getimagesize
  • image_type_to_extension ?
  • PHP Manual
  • GD 和图像处理 函数
  • 从字符串中获取图像尺寸信息

getimagesizefromstring

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

getimagesizefromstring — 从字符串中获取图像尺寸信息

说明

getimagesizefromstring ( string $imagedata , array &$imageinfo = ? ) : array

同 getimagesize() 函数。 区别是 getimagesizefromstring() 第一个参数是图像数据的字符串表达，而不是文件名。

关于本函数如何工作的更多信息请参见 getimagesize() 函数。

参数

imagedata

图像数据的字符串表示。

imageinfo

参见 getimagesize() 函数。

返回值

参见 getimagesize() 函数。

范例

Example #1 getimagesizefromstring() 函数例程

<?php
$img = '/path/to/test.png';

// 以文件方式打开
$size_info1 = getimagesize($img);

// 以字符串格式打开
$data       = file_get_contents($img);
$size_info2 = getimagesizefromstring($data);
?>

参见

  • getimagesize() - 取得图像大小


取得图像类型的文件后缀

  • ? getimagesizefromstring
  • image_type_to_mime_type ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得图像类型的文件后缀

image_type_to_extension

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

image_type_to_extension — 取得图像类型的文件后缀

说明

image_type_to_extension ( int $imagetype , bool $include_dot = true ) : string

根据给定的常量 IMAGETYPE_XXX 返回后缀名。

参数

imagetype

IMAGETYPE_XXX 系列常量之一。

include_dot

是否在后缀名前加一个点。默认是 true。

返回值

根据指定的图像类型返回对应的后缀名。

范例

Example #1 image_type_to_extension() 例子

<?php
// 创建图像实例
$im = imagecreatetruecolor(100, 100);

// 保存图像
imagepng($im, './test' . image_type_to_extension(IMAGETYPE_PNG));
imagedestroy($im);
?>

注释

Note:

此函数不需要 GD 图象库。


取得 getimagesize，exif_read_data，exif_thumbnail，exif_imagetype 所返回的图像类型的 MIME 类型

  • ? image_type_to_extension
  • image2wbmp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得 getimagesize，exif_read_data，exif_thumbnail，exif_imagetype 所返回的图像类型的 MIME 类型

image_type_to_mime_type

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

image_type_to_mime_type — 取得 getimagesize，exif_read_data，exif_thumbnail，exif_imagetype 所返回的图像类型的 MIME 类型

说明

image_type_to_mime_type ( int $imagetype ) : string

image_type_to_mime_type() 函数可以判断一个 IMAGETYPE 常量的 MIME 类型。

Example #1 image_type_to_mime_type (file)

<?php
header("Content-type: " . image_type_to_mime_type(IMAGETYPE_PNG));
?>

返回值如下：

返回值常量
图像类型（imagetype） | 返回值
IMAGETYPE_GIF | image/gif
IMAGETYPE_JPEG | image/jpeg
IMAGETYPE_PNG | image/png
IMAGETYPE_SWF | application/x-shockwave-flash
IMAGETYPE_PSD | image/psd
IMAGETYPE_BMP | image/bmp
IMAGETYPE_TIFF_II (intel byte order) | image/tiff
IMAGETYPE_TIFF_MM (motorola byte order) | image/tiff
IMAGETYPE_JPC | application/octet-stream
IMAGETYPE_JP2 | image/jp2
IMAGETYPE_JPX | application/octet-stream
IMAGETYPE_JB2 | application/octet-stream
IMAGETYPE_SWC | application/x-shockwave-flash
IMAGETYPE_IFF | image/iff
IMAGETYPE_WBMP | image/vnd.wap.wbmp
IMAGETYPE_XBM | image/xbm

Note: 本函数不需要 GD 库。

参见 getimagesize()，exif_imagetype()，exif_read_data() 和 exif_thumbnail()。


以 WBMP 格式将图像输出到浏览器或文件

  • ? image_type_to_mime_type
  • imageaffine ?
  • PHP Manual
  • GD 和图像处理 函数
  • 以 WBMP 格式将图像输出到浏览器或文件

image2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

image2wbmp — 以 WBMP 格式将图像输出到浏览器或文件

说明

image2wbmp ( resource $image , string $filename = ? , int $threshold = ? ) : int

image2wbmp() 从 image 图像创建一个名为 filename 的 WBMP 文件。image 参数是某个图像创建函数的返回值，例如 imagecreatetruecolor()。

filename 参数是可选项，如果省略，则直接将原图像流输出。通过用 header() 发送 image/vnd.wap.wbmp 的 Content-type，可以创建直接输出 WBMP 图像的 PHP 脚本。

Example #1 image2wbmp() 例子

<?php
$file = 'php.jpg';
$image = imagecreatefrompng($file);
header('Content-type: ' . image_type_to_mime(IMAGETYPE_WBMP));
image2wbmp($file); // output the stream directly
?>

Note:

WBMP 支持仅在 PHP 编译时加入了 GD-1.8 或更高版本时可用。

参见 imagewbmp()。


返回经过仿射变换后的图像，剪切区域可选

  • ? image2wbmp
  • imageaffinematrixconcat ?
  • PHP Manual
  • GD 和图像处理 函数
  • 返回经过仿射变换后的图像，剪切区域可选

imageaffine

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imageaffine — 返回经过仿射变换后的图像，剪切区域可选

说明

imageaffine ( resource $image , array $affine , array $clip = ? ) : resource

Warning

本函数还未编写文档，仅有参数列表。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

affine

数组，其中键为 0 至 5 的数字。

clip

数组，其中键为 "x"，"y"，"width" 和 "height"。

返回值

成功则返回仿射变换后的图像， 或者在失败时返回 false.


Concatenate two affine transformation matrices

  • ? imageaffine
  • imageaffinematrixget ?
  • PHP Manual
  • GD 和图像处理 函数
  • Concatenate two affine transformation matrices

imageaffinematrixconcat

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imageaffinematrixconcat — Concatenate two affine transformation matrices

说明

imageaffinematrixconcat ( array $m1 , array $m2 ) : array|false

Returns the concatenation of two affine transformation matrices, what is useful if multiple transformations should be applied to the same image in one go.

参数

m1

An affine transformation matrix (an array with keys 0 to 5 and float values).

m2

An affine transformation matrix (an array with keys 0 to 5 and float values).

返回值

An affine transformation matrix (an array with keys 0 to 5 and float values) 或者在失败时返回 false.

范例

Example #1 imageaffinematrixconcat() example

<?php
$m1 = imageaffinematrixget(IMG_AFFINE_TRANSLATE, array('x' = 2, 'y' => 3));
$m2 = imageaffinematrixget(IMG_AFFINE_SCALE, array('x' = 4, 'y' => 5));
$matrix = imageaffinematrixconcat($m1, $m2);
print_r($matrix);
?>

以上例程会输出：

Array
(
    [0] => 4
    [1] => 0
    [2] => 0
    [3] => 5
    [4] => 8
    [5] => 15
)

参见

  • imageaffine() - 返回经过仿射变换后的图像，剪切区域可选
  • imageaffinematrixget() - Get an affine transformation matrix


Get an affine transformation matrix

  • ? imageaffinematrixconcat
  • imagealphablending ?
  • PHP Manual
  • GD 和图像处理 函数
  • Get an affine transformation matrix

imageaffinematrixget

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imageaffinematrixget — Get an affine transformation matrix

说明

imageaffinematrixget ( int $type , mixed $options = ? ) : array|false

Returns an affine transformation matrix.

参数

type

One of the IMG_AFFINE_* constants.

options

If type is IMG_AFFINE_TRANSLATE or IMG_AFFINE_SCALE, options has to be an array with keys x and y, both having float values.

If type is IMG_AFFINE_ROTATE, IMG_AFFINE_SHEAR_HORIZONTAL or IMG_AFFINE_SHEAR_VERTICAL, options has to be a float specifying the angle.

返回值

An affine transformation matrix (an array with keys 0 to 5 and float values) 或者在失败时返回 false.

范例

Example #1 imageaffinematrixget() example

<?php
$matrix = imageaffinematrixget(IMG_AFFINE_TRANSLATE, array('x' => 2, 'y' => 3));
print_r($matrix);
?>

以上例程会输出：

Array
(
    [0] => 1
    [1] => 0
    [2] => 0
    [3] => 1
    [4] => 2
    [5] => 3
)

参见

  • imageaffine() - 返回经过仿射变换后的图像，剪切区域可选
  • imageaffinematrixconcat() - Concatenate two affine transformation matrices


设定图像的混色模式

  • ? imageaffinematrixget
  • imageantialias ?
  • PHP Manual
  • GD 和图像处理 函数
  • 设定图像的混色模式

imagealphablending

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagealphablending — 设定图像的混色模式

说明

imagealphablending ( resource $image , bool $blendmode ) : bool

imagealphablending() 允许在真彩色图像上使用两种不同的绘画模式。在混色（blending）模式下，alpha 通道色彩成分提供给所有的绘画函数，例如 imagesetpixel() 决定底层的颜色应在何种程度上被允许照射透过。作为结果，GD 自动将该点现有的颜色和画笔颜色混合，并将结果储存在图像中。结果的像素是不透明的。在非混色模式下，画笔颜色连同其 alpha 通道信息一起被拷贝，替换掉目标像素。混色模式在画调色板图像时不可用。如果 blendmode 为 true，则启用混色模式，否则关闭。成功时返回 true， 或者在失败时返回 false。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

blendmode

Whether to enable the blending mode or not. On true color images the default value is true otherwise the default value is false

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imagealphablending() usage example

<?php
// Create image
$im = imagecreatetruecolor(100, 100);

// Set alphablending to on
imagealphablending($im, true);

// Draw a square
imagefilledrectangle($im, 30, 30, 70, 70, imagecolorallocate($im, 255, 0, 0));

// Output
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

注释


是否使用抗锯齿（antialias）功能

  • ? imagealphablending
  • imagearc ?
  • PHP Manual
  • GD 和图像处理 函数
  • 是否使用抗锯齿（antialias）功能

imageantialias

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

imageantialias — 是否使用抗锯齿（antialias）功能

说明

imageantialias ( resource $image , bool $enabled ) : bool

对线段和多边形启用快速画图抗锯齿方法。不支持 alpha 部分。使用直接混色操作。仅用于真彩色图像。

不支持线宽和风格。

使用抗锯齿和透明背景色可能出现未预期的结果。混色方法把背景色当成任何其它颜色使用。缺乏 alpha 部分的支持导致不允许基于 alpha 抗锯齿方法。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

enabled

是否启用抗锯齿。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 A comparison of two lines, one with anti-aliasing switched on

<?php
// Setup an anti-aliased image and a normal image
$aa = imagecreatetruecolor(400, 100);
$normal = imagecreatetruecolor(200, 100);

// Switch antialiasing on for one image
imageantialias($aa, true);

// Allocate colors
$red = imagecolorallocate($normal, 255, 0, 0);
$red_aa = imagecolorallocate($aa, 255, 0, 0);

// Draw two lines, one with AA enabled
imageline($normal, 0, 0, 200, 100, $red);
imageline($aa, 0, 0, 200, 100, $red_aa);

// Merge the two images side by side for output (AA: left, Normal: Right)
imagecopymerge($aa, $normal, 200, 0, 0, 0, 200, 100, 100);

// Output image
header('Content-type: image/png');

imagepng($aa);
imagedestroy($aa);
imagedestroy($normal);
?>

以上例程的输出类似于：

Output of example : A comparison of two lines, one with anti-aliasing switched on

注释

参见

  • imagecreatetruecolor() - 新建一个真彩色图像


画椭圆弧

  • ? imageantialias
  • imagebmp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画椭圆弧

imagearc

(PHP 4, PHP 5, PHP 7, PHP 8)

imagearc — 画椭圆弧

说明

imagearc ( resource $image , int $cx , int $cy , int $w , int $h , int $s , int $e , int $color ) : bool

imagearc() 以 cx，cy（图像左上角为 0, 0）为中心在 image 所代表的图像中画一个椭圆弧。w 和 h 分别指定了椭圆的宽度和高度，起始和结束点以 s 和 e 参数以角度指定。0°位于三点钟位置，以顺时针方向绘画。

Example #1 用 imagearc() 画一个圆

<?php
// 创建一个 200X200 的图像
$img = imagecreatetruecolor(200, 200);
// 分配颜色
$white = imagecolorallocate($img, 255, 255, 255);
$black = imagecolorallocate($img, 0, 0, 0);
// 画一个黑色的圆
imagearc($img, 100, 100, 150, 150, 0, 360, $black);
// 将图像输出到浏览器
header("Content-type: image/png");
imagepng($img);
// 释放内存
imagedestroy($img);
?>

参见 imageellipse()，imagefilledellipse() 和 imagefilledarc()。


Output a BMP image to browser or file

  • ? imagearc
  • imagechar ?
  • PHP Manual
  • GD 和图像处理 函数
  • Output a BMP image to browser or file

imagebmp

(PHP 7 >= 7.2.0, PHP 8)

imagebmp — Output a BMP image to browser or file

说明

imagebmp ( resource $image , mixed $to = null , bool $compressed = true ) : bool

Outputs or saves a BMP version of the given image.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

to

文件保存的路径，如果未设置或为 null，将会直接输出原始图象流。

Note:

null is invalid if the compressed arguments is not used.

compressed

Whether the BMP should be compressed with run-length encoding (RLE), or not.

返回值

成功时返回 true， 或者在失败时返回 false。

Caution

如果 libgd 输出图像失败，函数会返回 true。

范例

Example #1 Saving a BMP file

<?php
// Create a blank image and add some text
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);

imagestring($im, 1, 5, 5,  'BMP with PHP', $text_color);

// Save the image
imagebmp($im, 'php.bmp');

// Free up memory
imagedestroy($im);
?>


水平地画一个字符

  • ? imagebmp
  • imagecharup ?
  • PHP Manual
  • GD 和图像处理 函数
  • 水平地画一个字符

imagechar

(PHP 4, PHP 5, PHP 7, PHP 8)

imagechar — 水平地画一个字符

说明

imagechar ( resource $image , int $font , int $x , int $y , string $c , int $color ) : bool

imagechar() 将字符串 c 的第一个字符画在 image 指定的图像中，其左上角位于 x，y（图像左上角为 0, 0），颜色为 color。如果 font 是 1，2，3，4 或 5，则使用内置的字体（更大的数字对应于更大的字体）。

Example #1 imagechar() 例子

<?php

$im = imagecreate(100,100);

$string = 'PHP';

$bg = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// prints a black "P" in the top left corner
imagechar($im, 1, 0, 0, $string, $black);

header('Content-type: image/png');
imagepng($im);

?>

参见 imagecharup() 和 imageloadfont()。


垂直地画一个字符

  • ? imagechar
  • imagecolorallocate ?
  • PHP Manual
  • GD 和图像处理 函数
  • 垂直地画一个字符

imagecharup

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecharup — 垂直地画一个字符

说明

imagecharup ( resource $image , int $font , int $x , int $y , string $c , int $color ) : bool

imagecharup() 将字符 c 垂直地画在 image 指定的图像上，位于 x，y（图像左上角为 0, 0），颜色为 color。如果 font 为 1，2，3，4 或 5，则使用内置的字体。

Example #1 imagecharup() 例子

<?php

$im = imagecreate(100,100);

$string = 'Note that the first letter is a N';

$bg = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// prints a black "Z" on a white background
imagecharup($im, 3, 10, 10, $string, $black);

header('Content-type: image/png');
imagepng($im);

?>

参见 imagechar() 和 imageloadfont()。


为一幅图像分配颜色

  • ? imagecharup
  • imagecolorallocatealpha ?
  • PHP Manual
  • GD 和图像处理 函数
  • 为一幅图像分配颜色

imagecolorallocate

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorallocate — 为一幅图像分配颜色

说明

imagecolorallocate ( resource $image , int $red , int $green , int $blue ) : int

imagecolorallocate() 返回一个标识符，代表了由给定的 RGB 成分组成的颜色。red，green 和 blue 分别是所需要的颜色的红，绿，蓝成分。这些参数是 0 到 255 的整数或者十六进制的 0x00 到 0xFF。imagecolorallocate() 必须被调用以创建每一种用在 image 所代表的图像中的颜色。

Note:

第一次对 imagecolorallocate() 的调用会给基于调色板的图像填充背景色，即用 imagecreate() 建立的图像。

Example #1 imagecolorallocate() 例子

<?php
$im = imagecreate('example.jpg', 100, 100);
// 背景设为红色
$background = imagecolorallocate($im, 255, 0, 0);
// 设定一些颜色
$white = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);
// 十六进制方式
$white = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
$black = imagecolorallocate($im, 0x00, 0x00, 0x00);
?>

如果分配失败则返回 -1。

参见 imagecolorallocatealpha() 和 imagecolordeallocate()。


为一幅图像分配颜色 + alpha

  • ? imagecolorallocate
  • imagecolorat ?
  • PHP Manual
  • GD 和图像处理 函数
  • 为一幅图像分配颜色 + alpha

imagecolorallocatealpha

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

imagecolorallocatealpha — 为一幅图像分配颜色 + alpha

说明

imagecolorallocatealpha ( resource $image , int $red , int $green , int $blue , int $alpha ) : int

imagecolorallocatealpha() 的行为和 imagecolorallocate() 相同，但多了一个额外的透明度参数 alpha，其值从 0 到 127。0 表示完全不透明，127 表示完全透明。

如果分配失败则返回 false。

Example #1 使用 imagecolorallocatealpha() 的例子

<?php
$size = 300;
$image=imagecreatetruecolor($size, $size);

// 用白色背景加黑色边框画个方框
$back = imagecolorallocate($image, 255, 255, 255);
$border = imagecolorallocate($image, 0, 0, 0);
imagefilledrectangle($image, 0, 0, $size - 1, $size - 1, $back);
imagerectangle($image, 0, 0, $size - 1, $size - 1, $border);

$yellow_x = 100;
$yellow_y = 75;
$red_x    = 120;
$red_y    = 165;
$blue_x   = 187;
$blue_y   = 125;
$radius   = 150;

// 用 alpha 值分配一些颜色
$yellow = imagecolorallocatealpha($image, 255, 255, 0, 75);
$red    = imagecolorallocatealpha($image, 255, 0, 0, 75);
$blue   = imagecolorallocatealpha($image, 0, 0, 255, 75);

// 画三个交迭的圆
imagefilledellipse($image, $yellow_x, $yellow_y, $radius, $radius, $yellow);
imagefilledellipse($image, $red_x, $red_y, $radius, $radius, $red);
imagefilledellipse($image, $blue_x, $blue_y, $radius, $radius, $blue);

// 不要忘记输出正确的 header！
header('Content-type: image/png');

// 最后输出结果
imagepng($image);
imagedestroy($image);
?>

参见 imagecolorallocate() 和 imagecolordeallocate()。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

red

红色成分的值。

green

绿色成分的值。

blue

蓝色成分的值。

alpha

A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

返回值

A color identifier or false if the allocation failed.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
Prior to 5.1.3 | Returns -1 if the allocation failed.

范例

Example #2 Example of using imagecolorallocatealpha()

<?php
$size = 300;
$image=imagecreatetruecolor($size, $size);

// something to get a white background with black border
$back = imagecolorallocate($image, 255, 255, 255);
$border = imagecolorallocate($image, 0, 0, 0);
imagefilledrectangle($image, 0, 0, $size - 1, $size - 1, $back);
imagerectangle($image, 0, 0, $size - 1, $size - 1, $border);

$yellow_x = 100;
$yellow_y = 75;
$red_x    = 120;
$red_y    = 165;
$blue_x   = 187;
$blue_y   = 125;
$radius   = 150;

// allocate colors with alpha values
$yellow = imagecolorallocatealpha($image, 255, 255, 0, 75);
$red    = imagecolorallocatealpha($image, 255, 0, 0, 75);
$blue   = imagecolorallocatealpha($image, 0, 0, 255, 75);

// drawing 3 overlapped circle
imagefilledellipse($image, $yellow_x, $yellow_y, $radius, $radius, $yellow);
imagefilledellipse($image, $red_x, $red_y, $radius, $radius, $red);
imagefilledellipse($image, $blue_x, $blue_y, $radius, $radius, $blue);

// don't forget to output a correct header!
header('Content-Type: image/png');

// and finally, output the result
imagepng($image);
imagedestroy($image);
?>

以上例程的输出类似于：

Output of example : Example of using imagecolorallocatealpha()

注释

参见

  • imagecolorallocate() - 为一幅图像分配颜色
  • imagecolordeallocate() - 取消图像颜色的分配


取得某像素的颜色索引值

  • ? imagecolorallocatealpha
  • imagecolorclosest ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得某像素的颜色索引值

imagecolorat

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorat — 取得某像素的颜色索引值

说明

imagecolorat ( resource $image , int $x , int $y ) : int

返回 image 所指定的图形中指定位置像素的颜色索引值。

如果 PHP 编译时加上了 GD 库 2.0 或更高的版本并且图像是真彩色图像，则本函数以整数返回该点的 RGB 值。用移位加掩码来取得红，绿，蓝各自成分的值：

Example #1 取得各自的 RGB 值

<?php
$im = ImageCreateFromPng("rockym.png");
$rgb = ImageColorAt($im, 100, 100);
$r = ($rgb >> 16) & 0xFF;
$g = ($rgb >> 8) & 0xFF;
$b = $rgb & 0xFF;
?>

参见 imagecolorset() 和 imagecolorsforindex()。


取得与指定的颜色最接近的颜色的索引值

  • ? imagecolorat
  • imagecolorclosestalpha ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得与指定的颜色最接近的颜色的索引值

imagecolorclosest

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorclosest — 取得与指定的颜色最接近的颜色的索引值

说明

imagecolorclosest ( resource $image , int $red , int $green , int $blue ) : int

返回图像调色板中与指定的 RGB 值最"接近"的颜色。

指定的颜色与调色板中的每个颜色的"距离"的计算方法是把 RGB 值当成三维空间中点的坐标。

如果从文件创建了图像，只有图像中使用了的颜色会被辨析。仅出现在调色板中的颜色不会被辨析。

参见 imagecolorexact()。


取得与指定的颜色加透明度最接近的颜色

  • ? imagecolorclosest
  • imagecolorclosesthwb ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得与指定的颜色加透明度最接近的颜色

imagecolorclosestalpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecolorclosestalpha — 取得与指定的颜色加透明度最接近的颜色

说明

imagecolorclosestalpha ( resource $image , int $red , int $green , int $blue , int $alpha ) : int

返回图像调色板中与指定的 RGB 值以及 alpha 深度最"接近"的颜色。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

red

红色成分的值。

green

绿色成分的值。

blue

蓝色成分的值。

alpha

A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

返回值

Returns the index of the closest color in the palette.

范例

Example #1 Search for a set of colors in an image

<?php
// Start with an image and convert it to a palette-based image
$im = imagecreatefrompng('figures/imagecolorclosest.png');
imagetruecolortopalette($im, false, 255);

// Search colors (RGB)
$colors = array(
    array(254, 145, 154, 50),
    array(153, 145, 188, 127),
    array(153, 90, 145, 0),
    array(255, 137, 92, 84)
);

// Loop through each search and find the closest color in the palette.
// Return the search number, the search RGB and the converted RGB match
foreach($colors as $id => $rgb)
{
    $result = imagecolorclosestalpha($im, $rgb[0], $rgb[1], $rgb[2], $rgb[3]);
    $result = imagecolorsforindex($im, $result);
    $result = "({$result['red']}, {$result['green']}, {$result['blue']}, {$result['alpha']})";

    echo "#$id: Search ($rgb[0], $rgb[1], $rgb[2], $rgb[3]); Closest match: $result.\n";
}

imagedestroy($im);
?>

以上例程的输出类似于：

#0: Search (254, 145, 154, 50); Closest match: (252, 150, 148, 0).
#1: Search (153, 145, 188, 127); Closest match: (148, 150, 196, 0).
#2: Search (153, 90, 145, 0); Closest match: (148, 90, 156, 0).
#3: Search (255, 137, 92, 84); Closest match: (252, 150, 92, 0).

注释

参见

  • imagecolorexactalpha() - 取得指定的颜色加透明度的索引值
  • imagecolorclosest() - 取得与指定的颜色最接近的颜色的索引值
  • imagecolorclosesthwb() - 取得与给定颜色最接近的色度的黑白色的索引


取得与给定颜色最接近的色度的黑白色的索引

  • ? imagecolorclosestalpha
  • imagecolordeallocate ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得与给定颜色最接近的色度的黑白色的索引

imagecolorclosesthwb

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecolorclosesthwb — 取得与给定颜色最接近的色度的黑白色的索引

说明

imagecolorclosesthwb ( resource $image , int $red , int $green , int $blue ) : int

取得与给定颜色最接近的色度的黑白色的索引。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

red

红色成分的值。

green

绿色成分的值。

blue

蓝色成分的值。

返回值

返回一个整数，是给定颜色最接近的色度的黑白色的索引。

范例

Example #1 使用 imagecolorclosesthwb() 的例子

<?php
$im = imagecreatefromgif('php.gif');

echo 'HWB: ' . imagecolorclosesthwb($im, 116, 115, 152);

imagedestroy($im);
?>

以上例程的输出类似于：

HWB: 33

更新日志

版本 | 说明
5.3.0 | 在 Windows 平台上可用

参见

  • imagecolorclosest() - 取得与指定的颜色最接近的颜色的索引值


取消图像颜色的分配

  • ? imagecolorclosesthwb
  • imagecolorexact ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取消图像颜色的分配

imagecolordeallocate

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolordeallocate — 取消图像颜色的分配

说明

imagecolordeallocate ( resource $image , int $color ) : bool

imagecolordeallocate() 函数取消先前由
imagecolorallocate() 或
imagecolorallocatealpha() 分配的颜色。

<?php
$white = imagecolorallocate($im, 255, 255, 255);
imagecolordeallocate($im, $white);
?>

参见 imagecolorallocate() 和 imagecolorallocatealpha()。


取得指定颜色的索引值

  • ? imagecolordeallocate
  • imagecolorexactalpha ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得指定颜色的索引值

imagecolorexact

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorexact — 取得指定颜色的索引值

说明

imagecolorexact ( resource $image , int $red , int $green , int $blue ) : int

返回图像调色板中指定颜色的索引值。

如果颜色不在图像的调色板中，返回 -1。

如果从文件创建了图像，只有图像中使用了的颜色会被辨析。仅出现在调色板中的颜色不会被辨析。

参见 imagecolorclosest()。


取得指定的颜色加透明度的索引值

  • ? imagecolorexact
  • imagecolormatch ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得指定的颜色加透明度的索引值

imagecolorexactalpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecolorexactalpha — 取得指定的颜色加透明度的索引值

说明

imagecolorexactalpha ( resource $image , int $red , int $green , int $blue , int $alpha ) : int

返回图像调色板中指定颜色加透明度的索引值。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

red

红色成分的值。

green

绿色成分的值。

blue

蓝色成分的值。

alpha

A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

返回值

返回图像调色板中指定颜色加透明度的索引值。 如果颜色不在图像的调色板中，返回 -1。

范例

Example #1 Get colors from the GD logo

<?php

// Setup an image
$im = imagecreatefrompng('./gdlogo.png');

$colors   = Array();
$colors[] = imagecolorexactalpha($im, 255, 0, 0, 0);
$colors[] = imagecolorexactalpha($im, 0, 0, 0, 127);
$colors[] = imagecolorexactalpha($im, 255, 255, 255, 55);
$colors[] = imagecolorexactalpha($im, 100, 255, 52, 20);

print_r($colors);

// Free from memory
imagedestroy($im);
?>

以上例程的输出类似于：

Array
(
    [0] => 16711680
    [1] => 2130706432
    [2] => 939524095
    [3] => 342163252
)

注释

参见

  • imagecolorclosestalpha() - 取得与指定的颜色加透明度最接近的颜色


使一个图像中调色板版本的颜色与真彩色版本更能匹配

  • ? imagecolorexactalpha
  • imagecolorresolve ?
  • PHP Manual
  • GD 和图像处理 函数
  • 使一个图像中调色板版本的颜色与真彩色版本更能匹配

imagecolormatch

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

imagecolormatch — 使一个图像中调色板版本的颜色与真彩色版本更能匹配

说明

imagecolormatch ( resource $image1 , resource $image2 ) : bool

使一个图像中调色板版本的颜色与真彩色版本更能匹配。

参数

image1

真彩色图像连接资源。

image2

必须是调色板图像，而且和 image1 的大小必须相同。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imagecolormatch() 例子

<?php
// Setup the true color and palette images
$im1 = imagecreatefrompng('./gdlogo.png');
$im2 = imagecreate(imagesx($im1), imagesy($im1));

// Add some colors to $im2
$colors   = Array();
$colors[] = imagecolorallocate($im2, 255, 36, 74);
$colors[] = imagecolorallocate($im2, 40, 0, 240);
$colors[] = imagecolorallocate($im2, 82, 100, 255);
$colors[] = imagecolorallocate($im2, 84, 63, 44);

// Match these colors with the true color image
imagecolormatch($im1, $im2);

// Free from memory
imagedestroy($im1);
imagedestroy($im2);
?>

注释

参见

  • imagecreatetruecolor() - 新建一个真彩色图像


取得指定颜色的索引值或有可能得到的最接近的替代值

  • ? imagecolormatch
  • imagecolorresolvealpha ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得指定颜色的索引值或有可能得到的最接近的替代值

imagecolorresolve

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorresolve — 取得指定颜色的索引值或有可能得到的最接近的替代值

说明

imagecolorresolve ( resource $image , int $red , int $green , int $blue ) : int

本函数可以保证对所请求的颜色返回一个颜色索引，要么是确切值要么是所能得到最接近的替代值。

如果从文件创建了图像，只有图像中使用了的颜色会被辨析。仅出现在调色板中的颜色不会被辨析。

参见 imagecolorclosest()。


取得指定颜色 + alpha 的索引值或有可能得到的最接近的替代值

  • ? imagecolorresolve
  • imagecolorset ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得指定颜色 + alpha 的索引值或有可能得到的最接近的替代值

imagecolorresolvealpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecolorresolvealpha — 取得指定颜色 + alpha 的索引值或有可能得到的最接近的替代值

说明

imagecolorresolvealpha ( resource $image , int $red , int $green , int $blue , int $alpha ) : int

本函数可以保证对所请求的颜色返回一个颜色索引，要么是确切值要么是所能得到最接近的替代值。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

red

红色成分的值。

green

绿色成分的值。

blue

蓝色成分的值。

alpha

A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

返回值

Returns a color index.

范例

Example #1 Using imagecoloresolvealpha() to get colors from an image

<?php
// Load an image
$im = imagecreatefromgif('phplogo.gif');

// Get closest colors from the image
$colors = array();
$colors[] = imagecolorresolvealpha($im, 255, 255, 255, 0);
$colors[] = imagecolorresolvealpha($im, 0, 0, 200, 127);

// Output
print_r($colors);

imagedestroy($im);
?>

以上例程的输出类似于：

Array
(
    [0] => 89
    [1] => 85
)

注释

参见

  • imagecolorclosestalpha() - 取得与指定的颜色加透明度最接近的颜色


给指定调色板索引设定颜色

  • ? imagecolorresolvealpha
  • imagecolorsforindex ?
  • PHP Manual
  • GD 和图像处理 函数
  • 给指定调色板索引设定颜色

imagecolorset

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorset — 给指定调色板索引设定颜色

说明

imagecolorset ( resource $image , int $index , int $red , int $green , int $blue ) : void

本函数将调色板中指定的索引设定为指定的颜色。对于在调色板图像中创建类似区域填充（flood-fill）的效果很有用，免去了真的去填充的开销。

参见 imagecolorat()。


取得某索引的颜色

  • ? imagecolorset
  • imagecolorstotal ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得某索引的颜色

imagecolorsforindex

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorsforindex — 取得某索引的颜色

说明

imagecolorsforindex ( resource $image , int $index ) : array

本函数返回一个具有 red，green，blue 和 alpha 的键名的关联数组，包含了指定颜色索引的相应的值。

Example #1 imagecolorsforindex() 例子

<?php

// 打开一幅图像
$im = imagecreatefrompng('nexen.png');

// 取得一点的颜色
$start_x = 40;
$start_y = 50;
$color_index = imagecolorat($im, $start_x, $start_y);

// 使其可读
$color_tran = imagecolorsforindex($im, $color_index);

// 显示该颜色的值
echo '<pre>';
print_r($color_tran);
echo '</pre>';

?>

本例将输出：

Array
(
    [red] => 226
    [green] => 222
    [blue] => 252
    [alpha] => 0
)

参见 imagecolorat() 和 imagecolorexact()。


取得一幅图像的调色板中颜色的数目

  • ? imagecolorsforindex
  • imagecolortransparent ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得一幅图像的调色板中颜色的数目

imagecolorstotal

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolorstotal — 取得一幅图像的调色板中颜色的数目

说明

imagecolorstotal ( resource $image ) : int

本函数返回指定图像的调色板中的颜色数目。

参见 imagecolorat() 和 imagecolorsforindex()。


将某个颜色定义为透明色

  • ? imagecolorstotal
  • imageconvolution ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将某个颜色定义为透明色

imagecolortransparent

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecolortransparent — 将某个颜色定义为透明色

说明

imagecolortransparent ( resource $image , int $color = ? ) : int

imagecolortransparent() 将 image 图像中的透明色设定为 color。image 是 imagecreatetruecolor() 返回的图像标识符，color 是 imagecolorallocate() 返回的颜色标识符。

Note:

透明色是图像的一种属性，透明度不是颜色的属性。一旦设定了某个颜色为透明色，图像中之前画为该色的任何区域都成为透明的。

返回新透明色的标识符，如果省略 color 则返回当前透明色的标识符。

Note:

透明度仅能通过 imagecopymerge() 和真彩色图像拷贝，不能用 imagecopy() 或调色板图像。


用系数 div 和 offset 申请一个 3x3 的卷积矩阵

  • ? imagecolortransparent
  • imagecopy ?
  • PHP Manual
  • GD 和图像处理 函数
  • 用系数 div 和 offset 申请一个 3x3 的卷积矩阵

imageconvolution

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

imageconvolution — 用系数 div 和 offset 申请一个 3x3 的卷积矩阵

说明

imageconvolution ( resource $image , array $matrix , float $div , float $offset ) : bool

Applies a convolution matrix on the image, using the given coefficient and offset.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

matrix

A 3x3 matrix: an array of three arrays of three floats.

div

The divisor of the result of the convolution, used for normalization.

offset

Color offset.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Embossing the PHP.net logo

<?php
$image = imagecreatefromgif('http://www.php.net/images/php.gif');

$emboss = array(array(2, 0, 0), array(0, -1, 0), array(0, 0, -1));
imageconvolution($image, $emboss, 1, 127);

header('Content-Type: image/png');
imagepng($image, null, 9);
?>

以上例程会输出：

Output of example : Embossing the PHP.net logo

Example #2 Gaussian blur

<?php
$image = imagecreatetruecolor(180,40);

// Writes the text and apply a gaussian blur on the image
imagestring($image, 5, 10, 8, 'Gaussian Blur Text', 0x00ff00);
$gaussian = array(array(1.0, 2.0, 1.0), array(2.0, 4.0, 2.0), array(1.0, 2.0, 1.0));
imageconvolution($image, $gaussian, 16, 0);

// Rewrites the text for comparison
imagestring($image, 5, 10, 18, 'Gaussian Blur Text', 0x00ff00);

header('Content-Type: image/png');
imagepng($image, null, 9);
?>

以上例程会输出：

Output of example : Gaussian blur

注释

参见

  • imagefilter() - 对图像使用过滤器


拷贝图像的一部分

  • ? imageconvolution
  • imagecopymerge ?
  • PHP Manual
  • GD 和图像处理 函数
  • 拷贝图像的一部分

imagecopy

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecopy — 拷贝图像的一部分

说明

imagecopy ( resource $dst_im , resource $src_im , int $dst_x , int $dst_y , int $src_x , int $src_y , int $src_w , int $src_h ) : bool

将 src_im 图像中坐标从 src_x，src_y 开始，宽度为 src_w，高度为 src_h 的一部分拷贝到 dst_im 图像中坐标为 dst_x 和 dst_y 的位置上。


拷贝并合并图像的一部分

  • ? imagecopy
  • imagecopymergegray ?
  • PHP Manual
  • GD 和图像处理 函数
  • 拷贝并合并图像的一部分

imagecopymerge

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecopymerge — 拷贝并合并图像的一部分

说明

imagecopymerge ( resource $dst_im , resource $src_im , int $dst_x , int $dst_y , int $src_x , int $src_y , int $src_w , int $src_h , int $pct ) : bool

将 src_im 图像中坐标从 src_x，src_y 开始，宽度为 src_w，高度为 src_h 的一部分拷贝到 dst_im 图像中坐标为 dst_x 和 dst_y 的位置上。两图像将根据 pct 来决定合并程度，其值范围从 0 到 100。当 pct = 0 时，实际上什么也没做，当为 100 时对于调色板图像本函数和 imagecopy() 完全一样，它对真彩色图像实现了 alpha 透明。

Note:

本函数是 PHP 4.0.6 新加的。


用灰度拷贝并合并图像的一部分

  • ? imagecopymerge
  • imagecopyresampled ?
  • PHP Manual
  • GD 和图像处理 函数
  • 用灰度拷贝并合并图像的一部分

imagecopymergegray

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecopymergegray — 用灰度拷贝并合并图像的一部分

说明

imagecopymergegray ( resource $dst_im , resource $src_im , int $dst_x , int $dst_y , int $src_x , int $src_y , int $src_w , int $src_h , int $pct ) : bool

将 src_im 图像中坐标从 src_x，src_y 开始，宽度为 src_w，高度为 src_h 的一部分拷贝到 dst_im 图像中坐标为 dst_x 和 dst_y 的位置上。两图像将根据 pct 来决定合并程度，其值范围从 0 到 100。当 pct = 0 时，实际上什么也没做，当为 100 时本函数和 imagecopy() 完全一样。

本函数和 imagecopymerge() 完全一样只除了合并时通过在拷贝操作前将目标像素转换为灰度级来保留了原色度。

Note:

本函数添加于 PHP 4.0.6。


重采样拷贝部分图像并调整大小

  • ? imagecopymergegray
  • imagecopyresized ?
  • PHP Manual
  • GD 和图像处理 函数
  • 重采样拷贝部分图像并调整大小

imagecopyresampled

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecopyresampled — 重采样拷贝部分图像并调整大小

说明

imagecopyresampled ( resource $dst_image , resource $src_image , int $dst_x , int $dst_y , int $src_x , int $src_y , int $dst_w , int $dst_h , int $src_w , int $src_h ) : bool

imagecopyresampled() 将一幅图像中的一块正方形区域拷贝到另一个图像中，平滑地插入像素值，因此，尤其是，减小了图像的大小而仍然保持了极大的清晰度。

In other words, imagecopyresampled() will take a rectangular area from src_image of width src_w and height src_h at position (src_x,src_y) and place it in a rectangular area of dst_image of width dst_w and height dst_h at position (dst_x,dst_y).

如果源和目标的宽度和高度不同，则会进行相应的图像收缩和拉伸。坐标指的是左上角。本函数可用来在同一幅图内部拷贝（如果 dst_image 和 src_image 相同的话）区域，但如果区域交迭的话则结果不可预知。

参数

dst_image

目标图象资源。

src_image

源图象资源。

dst_x

目标 X 坐标点。

dst_y

目标 Y 坐标点。

src_x

源的 X 坐标点。

src_y

源的 Y 坐标点。

dst_w

目标宽度。

dst_h

目标高度。

src_w

源图象的宽度。

src_h

源图象的高度。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 简单的例子

这个例子会将图像调整为原有尺寸的一半。

<?php
// 这个文件
$filename = 'test.jpg';
$percent = 0.5;

// 内容类型
header('Content-Type: image/jpeg');

// 获取新的尺寸
list($width, $height) = getimagesize($filename);
$new_width = $width * $percent;
$new_height = $height * $percent;

// 重新取样
$image_p = imagecreatetruecolor($new_width, $new_height);
$image = imagecreatefromjpeg($filename);
imagecopyresampled($image_p, $image, 0, 0, 0, 0, $new_width, $new_height, $width, $height);

// 输出
imagejpeg($image_p, null, 100);
?>

以上例程的输出类似于：

Example #2 按比例对图像重新采样

这个例子会以最大宽度高度为 200 像素显示一个图像。

<?php
// 源文件
$filename = 'test.jpg';

// 设置最大宽高
$width = 200;
$height = 200;

// Content type
header('Content-Type: image/jpeg');

// 获取新尺寸
list($width_orig, $height_orig) = getimagesize($filename);

$ratio_orig = $width_orig/$height_orig;

if ($width/$height > $ratio_orig) {
   $width = $height*$ratio_orig;
} else {
   $height = $width/$ratio_orig;
}

// 重新取样
$image_p = imagecreatetruecolor($width, $height);
$image = imagecreatefromjpeg($filename);
imagecopyresampled($image_p, $image, 0, 0, 0, 0, $width, $height, $width_orig, $height_orig);

// 输出
imagejpeg($image_p, null, 100);
?>

以上例程的输出类似于：

注释

Note:

因为调色板图像限制（255+1 种颜色）有个问题。重采样或过滤图像通常需要多于 255 种颜色，计算新的被重采样的像素及其颜色时采用了一种近似值。对调色板图像尝试分配一个新颜色时，如果失败我们选择了计算结果最接近（理论上）的颜色。这并不总是视觉上最接近的颜色。这可能会产生怪异的结果，例如空白（或者视觉上是空白）的图像。要跳过这个问题，请使用真彩色图像作为目标图像，例如用 imagecreatetruecolor() 创建的。

参见

imagecopyresized() - 拷贝部分图像并调整大小


拷贝部分图像并调整大小

  • ? imagecopyresampled
  • imagecreate ?
  • PHP Manual
  • GD 和图像处理 函数
  • 拷贝部分图像并调整大小

imagecopyresized

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecopyresized — 拷贝部分图像并调整大小

说明

imagecopyresized ( resource $dst_image , resource $src_image , int $dst_x , int $dst_y , int $src_x , int $src_y , int $dst_w , int $dst_h , int $src_w , int $src_h ) : bool

imagecopyresized() 将一幅图像中的一块矩形区域拷贝到另一个图像中。dst_image 和 src_image 分别是目标图像和源图像的标识符。

In other words, imagecopyresized() will take an rectangular area from src_image of width src_w and height src_h at position (src_x,src_y) and place it in a rectangular area of dst_image of width dst_w and height dst_h at position (dst_x,dst_y).

如果源和目标的宽度和高度不同，则会进行相应的图像收缩和拉伸。坐标指的是左上角。本函数可用来在同一幅图内部拷贝（如果 dst_image 和 src_image 相同的话）区域，但如果区域交迭的话则结果不可预知。

参数

dst_image

目标图象资源。

src_image

源图象资源。

dst_x

x-coordinate of destination point.

dst_y

y-coordinate of destination point.

src_x

x-coordinate of source point.

src_y

y-coordinate of source point.

dst_w

Destination width.

dst_h

Destination height.

src_w

源图象的宽度。

src_h

源图象的高度。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Resizing an image

这个例子会以一半的尺寸显示图片

<?php
// File and new size
$filename = 'test.jpg';
$percent = 0.5;

// Content type
header('Content-Type: image/jpeg');

// Get new sizes
list($width, $height) = getimagesize($filename);
$newwidth = $width * $percent;
$newheight = $height * $percent;

// Load
$thumb = imagecreatetruecolor($newwidth, $newheight);
$source = imagecreatefromjpeg($filename);

// Resize
imagecopyresized($thumb, $source, 0, 0, 0, 0, $newwidth, $newheight, $width, $height);

// Output
imagejpeg($thumb);
?>

以上例程的输出类似于：

Output of example : Resizing an image

The image will be output at half size, though better quality could be obtained using imagecopyresampled().

注释

Note:

因为调色板图像限制（255+1 种颜色）有个问题。重采样或过滤图像通常需要多于 255 种颜色，计算新的被重采样的像素及其颜色时采用了一种近似值。对调色板图像尝试分配一个新颜色时，如果失败我们选择了计算结果最接近（理论上）的颜色。这并不总是视觉上最接近的颜色。这可能会产生怪异的结果，例如空白（或者视觉上是空白）的图像。要跳过这个问题，请使用真彩色图像作为目标图像，例如用 imagecreatetruecolor() 创建的。

参见

imagecopyresampled() - 重采样拷贝部分图像并调整大小


新建一个基于调色板的图像

  • ? imagecopyresized
  • imagecreatefrombmp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 新建一个基于调色板的图像

imagecreate

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecreate — 新建一个基于调色板的图像

说明

imagecreate ( int $x_size , int $y_size ) : resource

imagecreate() 返回一个图像标识符，代表了一幅大小为 x_size 和 y_size 的空白图像。

推荐使用 imagecreatetruecolor()。

Example #1 新建一个新的 GD 图像流并输出图像

<?php
header("Content-type: image/png");
$im = @imagecreate(100, 50)
    or die("Cannot Initialize new GD image stream");
$background_color = imagecolorallocate($im, 255, 255, 255);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);
imagepng($im);
imagedestroy($im);
?>

参见 imagedestroy() 和 imagecreatetruecolor()。


由文件或 URL 创建一个新图象。

  • ? imagecreate
  • imagecreatefromgd2 ?
  • PHP Manual
  • GD 和图像处理 函数
  • 由文件或 URL 创建一个新图象。

imagecreatefrombmp

(PHP 7 >= 7.2.0, PHP 8)

imagecreatefrombmp — 由文件或 URL 创建一个新图象。

说明

imagecreatefrombmp ( string $filename ) : resource

imagecreatefrombmp() returns an image identifier representing the image obtained from the given filename.

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

Path to the BMP image.

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 Convert an BMP image to a PNG image using imagecreatefrombmp()

<?php
// Load the BMP file
$im = imagecreatefrombmp('./example.bmp');

// Convert it to a PNG file with default settings
imagepng($im, './example.png');
imagedestroy($im);
?>


从 GD2 文件或 URL 新建一图像

  • ? imagecreatefrombmp
  • imagecreatefromgd2part ?
  • PHP Manual
  • GD 和图像处理 函数
  • 从 GD2 文件或 URL 新建一图像

imagecreatefromgd2

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagecreatefromgd2 — 从 GD2 文件或 URL 新建一图像

说明

imagecreatefromgd2 ( string $filename ) : resource

从 GD2 文件或 URL 新建一图像。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

GD2 图像的路径。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 imagecreatefromgd2() 例子

<?php
// 加载 gd2 图像
$im = imagecreatefromgd2('./test.gd2');

// 在图像上应用效果。
// 在这个例子中，如果版本为 PHP5+ 则反转图像颜色
if(function_exists('imagefilter'))
{
    imagefilter($im, IMG_FILTER_NEGATE);
}

// 保存图像
imagegd2($im, './test_updated.gd2');
imagedestroy($im);
?>

注释


从给定的 GD2 文件或 URL 中的部分新建一图像

  • ? imagecreatefromgd2
  • imagecreatefromgd ?
  • PHP Manual
  • GD 和图像处理 函数
  • 从给定的 GD2 文件或 URL 中的部分新建一图像

imagecreatefromgd2part

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagecreatefromgd2part — 从给定的 GD2 文件或 URL 中的部分新建一图像

说明

imagecreatefromgd2part ( string $filename , int $srcX , int $srcY , int $width , int $height ) : resource

Create a new image from a given part of GD2 file or URL.

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

Path to the GD2 image.

srcX

x-coordinate of source point.

srcY

y-coordinate of source point.

width

源图象的宽度。

height

源图象的高度。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 imagecreatefromgd2part() example

<?php
// For this example we need the image size before
$image = getimagesize('./test.gd2');

// Create the image instance now we got the image
// sizes
$im = imagecreatefromgd2part('./test.gd2', 4, 4, ($image[0] / 2) - 6, ($image[1] / 2) - 6);

// Do an image operation, in this case we emboss the
// image if PHP 5+
if(function_exists('imagefilter'))
{
    imagefilter($im, IMG_FILTER_EMBOSS);
}

// Save optimized image
imagegd2($im, './test_emboss.gd2');
imagedestroy($im);
?>

注释


从 GD 文件或 URL 新建一图像

  • ? imagecreatefromgd2part
  • imagecreatefromgif ?
  • PHP Manual
  • GD 和图像处理 函数
  • 从 GD 文件或 URL 新建一图像

imagecreatefromgd

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagecreatefromgd — 从 GD 文件或 URL 新建一图像

说明

imagecreatefromgd ( string $filename ) : resource

从 GD 文件或 URL 新建一图像。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

GD 文件的路径。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 imagecreatefromgd() 例子

<?php
// Load the gd image
$im = @imagecreatefromgd('./test.gd');

// Test if the image was loaded
if(!is_resource($im))
{
     die('Unable to load gd image!');
}

// Do image operations here

// Save the image
imagegd($im, './test_updated.gd');
imagedestroy($im);
?>

注释


由文件或 URL 创建一个新图象。

  • ? imagecreatefromgd
  • imagecreatefromjpeg ?
  • PHP Manual
  • GD 和图像处理 函数
  • 由文件或 URL 创建一个新图象。

imagecreatefromgif

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecreatefromgif — 由文件或 URL 创建一个新图象。

说明

imagecreatefromgif ( string $filename ) : resource

imagecreatefromgif() 返回一图像标识符，代表了从给定的文件名取得的图像。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

GIF 图像的路径。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 处理创建过程中的错误

<?php
function LoadGif($imgname)
{
    /* Attempt to open */
    $im = @imagecreatefromgif($imgname);

    /* See if it failed */
    if(!$im)
    {
        /* Create a blank image */
        $im = imagecreatetruecolor (150, 30);
        $bgc = imagecolorallocate ($im, 255, 255, 255);
        $tc = imagecolorallocate ($im, 0, 0, 0);

        imagefilledrectangle ($im, 0, 0, 150, 30, $bgc);

        /* Output an error message */
        imagestring ($im, 1, 5, 5, 'Error loading ' . $imgname, $tc);
    }

    return $im;
}

header('Content-Type: image/gif');

$img = LoadGif('bogus.image');

imagegif($img);
imagedestroy($img);
?>

以上例程的输出类似于：

例子的输出： 处理创建 GIF 过程中的错误

注释

Note:

自 GD 库 1.6 版起所有的 GIF 支持都移除了，又在 GD 库 2.0.28 版起又加了回来。如果使用二者之间版本的 GD 库时本函数不可用。


由文件或 URL 创建一个新图象。

  • ? imagecreatefromgif
  • imagecreatefrompng ?
  • PHP Manual
  • GD 和图像处理 函数
  • 由文件或 URL 创建一个新图象。

imagecreatefromjpeg

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecreatefromjpeg — 由文件或 URL 创建一个新图象。

说明

imagecreatefromjpeg ( string $filename ) : resource

imagecreatefromjpeg() 返回一图像标识符，代表了从给定的文件名取得的图像。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

JPEG 图像的路径。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 处理创建过程中的错误

<?php
function LoadJpeg($imgname)
{
    /* 尝试打开 */
    $im = @imagecreatefromjpeg($imgname);

    /* See if it failed */
    if(!$im)
    {
        /* Create a black image */
        $im  = imagecreatetruecolor(150, 30);
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 150, 30, $bgc);

        /* Output an error message */
        imagestring($im, 1, 5, 5, 'Error loading ' . $imgname, $tc);
    }

    return $im;
}

header('Content-Type: image/jpeg');

$img = LoadJpeg('bogus.image');

imagejpeg($img);
imagedestroy($img);
?>

以上例程的输出类似于：

注释


由文件或 URL 创建一个新图象。

  • ? imagecreatefromjpeg
  • imagecreatefromstring ?
  • PHP Manual
  • GD 和图像处理 函数
  • 由文件或 URL 创建一个新图象。

imagecreatefrompng

(PHP 4, PHP 5, PHP 7, PHP 8)

imagecreatefrompng — 由文件或 URL 创建一个新图象。

说明

imagecreatefrompng ( string $filename ) : resource

imagecreatefrompng() 返回一图像标识符，代表了从给定的文件名取得的图像。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

PNG 图像的路径。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 处理创建 PNG 过程中的错误

<?php
function LoadPNG($imgname)
{
    /* Attempt to open */
    $im = @imagecreatefrompng($imgname);

    /* See if it failed */
    if(!$im)
    {
        /* Create a blank image */
        $im  = imagecreatetruecolor(150, 30);
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 150, 30, $bgc);

        /* Output an error message */
        imagestring($im, 1, 5, 5, 'Error loading ' . $imgname, $tc);
    }

    return $im;
}

header('Content-Type: image/png');

$img = LoadPNG('bogus.image');

imagepng($img);
imagedestroy($img);
?>

以上例程的输出类似于：

注释


从字符串中的图像流新建一图像

  • ? imagecreatefrompng
  • imagecreatefromwbmp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 从字符串中的图像流新建一图像

imagecreatefromstring

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

imagecreatefromstring — 从字符串中的图像流新建一图像

说明

imagecreatefromstring ( string $image ) : resource

imagecreatefromstring() 返回一个图像标识符，其表达了从给定字符串得来的图像。图像格式将自动检测，只要 PHP 支持：JPEG，PNG，GIF，WBMP 和 GD2。

参数

image

A string containing the image data.

返回值

An image resource will be returned on success. false is returned if the image type is unsupported, the data is not in a recognised format, or the image is corrupt and cannot be loaded.

范例

Example #1 imagecreatefromstring() example

<?php
$data = 'iVBORw0KGgoAAAANSUhEUgAAABwAAAASCAMAAAB/2U7WAAAABl'
       . 'BMVEUAAAD///+l2Z/dAAAASUlEQVR4XqWQUQoAIAxC2/0vXZDr'
       . 'EX4IJTRkb7lobNUStXsB0jIXIAMSsQnWlsV+wULF4Avk9fLq2r'
       . '8a5HSE35Q3eO2XP1A1wQkZSgETvDtKdQAAAABJRU5ErkJggg==';
$data = base64_decode($data);

$im = imagecreatefromstring($data);
if ($im !== false) {
    header('Content-Type: image/png');
    imagepng($im);
    imagedestroy($im);
}
else {
    echo 'An error occurred.';
}
?>

以上例程的输出类似于：

Output of example : imagecreatefromstring()

参见

  • imagecreatefromjpeg() - 由文件或 URL 创建一个新图象。
  • imagecreatefrompng() - 由文件或 URL 创建一个新图象。
  • imagecreatefromgif() - 由文件或 URL 创建一个新图象。
  • imagecreatetruecolor() - 新建一个真彩色图像


由文件或 URL 创建一个新图象。

  • ? imagecreatefromstring
  • imagecreatefromwebp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 由文件或 URL 创建一个新图象。

imagecreatefromwbmp

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecreatefromwbmp — 由文件或 URL 创建一个新图象。

说明

imagecreatefromwbmp ( string $filename ) : resource

imagecreatefromwbmp() 返回一图像标识符，代表了从给定的文件名取得的图像。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

WBMP 图像的路径。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 处理创建 WBMP 过程中的错误

<?php
function LoadWBMP($imgname)
{
    /* Attempt to open */
    $im = @imagecreatefromwbmp($imgname);

    /* See if it failed */
    if(!$im)
    {
        /* Create a blank image */
        $im  = imagecreatetruecolor(150, 30);
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 150, 30, $bgc);

        /* Output an error message */
        imagestring($im, 1, 5, 5, 'Error loading ' . $imgname, $tc);
    }

    return $im;
}

header('Content-Type: image/vnd.wap.wbmp');

$img = LoadWBMP('bogus.image');

imagewbmp($img);
imagedestroy($img);
?>

注释


由文件或 URL 创建一个新图象。

  • ? imagecreatefromwbmp
  • imagecreatefromxbm ?
  • PHP Manual
  • GD 和图像处理 函数
  • 由文件或 URL 创建一个新图象。

imagecreatefromwebp

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

imagecreatefromwebp — 由文件或 URL 创建一个新图象。

说明

imagecreatefromwebp ( string $filename ) : resource

imagecreatefromwebp() 返回从给定文件名创建的图像标示符。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

WebP 图像文件路径。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 Convert an WebP image to a jpeg image using imagecreatefromwebp()

<?php
// 加载 WebP 文件
$im = imagecreatefromwebp('./example.webp');

// 以 100% 的质量转换成 jpeg 格式
imagejpeg($im, './example.jpeg', 100);
imagedestroy($im);
?>


由文件或 URL 创建一个新图象。

  • ? imagecreatefromwebp
  • imagecreatefromxpm ?
  • PHP Manual
  • GD 和图像处理 函数
  • 由文件或 URL 创建一个新图象。

imagecreatefromxbm

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecreatefromxbm — 由文件或 URL 创建一个新图象。

说明

imagecreatefromxbm ( string $filename ) : resource

imagecreatefromxbm() 返回一图像标识符，代表了从给定的文件名取得的图像。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

参数

filename

Path to the XBM image.

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 Convert an XBM image to a png image using imagecreatefromxbm()

<?php
// Load the xbm file
$xbm = imagecreatefromxbm('./example.xbm');

// Convert it to a png file
imagepng($xbm, './example.png');
imagedestroy($xbm);
?>

注释


由文件或 URL 创建一个新图象。

  • ? imagecreatefromxbm
  • imagecreatetruecolor ?
  • PHP Manual
  • GD 和图像处理 函数
  • 由文件或 URL 创建一个新图象。

imagecreatefromxpm

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagecreatefromxpm — 由文件或 URL 创建一个新图象。

说明

imagecreatefromxpm ( string $filename ) : resource

imagecreatefromxpm() 返回一图像标识符，代表了从给定的文件名取得的图像。

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

Note: 此函数未在 Windows 平台下实现。

参数

filename

Path to the XPM image.

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 Creating an image instance using imagecreatefromxpm()

<?php
// Check for XPM support
if(!(imagetypes() & IMG_XPM))
{
    die('Support for xpm was not found!');
}

// Create the image instance
$xpm = imagecreatefromxpm('./example.xpm');

// Do image operations here

// PHP has no support for writing xpm images
// so in this case we save the image as a
// jpeg file with 100% quality
imagejpeg($xpm, './example.jpg', 100);
imagedestroy($xpm);
?>

返回值

Note: 此函数未在 Windows 平台下实现。


新建一个真彩色图像

  • ? imagecreatefromxpm
  • imagecrop ?
  • PHP Manual
  • GD 和图像处理 函数
  • 新建一个真彩色图像

imagecreatetruecolor

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagecreatetruecolor — 新建一个真彩色图像

说明

imagecreatetruecolor ( int $width , int $height ) : resource

imagecreatetruecolor() 返回一个图像标识符，代表了一幅大小为 x_size 和 y_size 的黑色图像。

是否定义了本函数取决于 PHP 和 GD 的版本。从 PHP 4.0.6 到 4.1.x 只要加载了 GD 模块本函数一直存在，但是在没有安装 GD2 的时候调用，PHP 将发出致命错误并退出。在 PHP 4.2.x 中此行为改为发出警告而不是错误。其它版本只在安装了正确的 GD 版本时定义了本函数。

参数

width

图像宽度。

height

图像高度。

返回值

成功后返回图象资源,失败后返回 false。

范例

Example #1 新建一个新的 GD 图像流并输出图像

<?php
header ('Content-Type: image/png');
$im = @imagecreatetruecolor(120, 20)
      or die('Cannot Initialize new GD image stream');
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);
imagepng($im);
imagedestroy($im);
?>

以上例程的输出类似于：

例子的输出： 新建一个新的 GD 图像流并输出图像

注释

参见

  • imagedestroy() - 销毁一图像
  • imagecreate() - 新建一个基于调色板的图像


Crop an image to the given rectangle

  • ? imagecreatetruecolor
  • imagecropauto ?
  • PHP Manual
  • GD 和图像处理 函数
  • Crop an image to the given rectangle

imagecrop

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagecrop — Crop an image to the given rectangle

说明

imagecrop ( resource $image , array $rect ) : resource|false

Crops an image to the given rectangular area and returns the resulting image. The given image is not modified.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

rect

The cropping rectangle as array with keys x, y, width and height.

返回值

Return cropped image resource on success 或者在失败时返回 false.

范例

Example #1 imagecrop() example

This example shows how to crop an image to a square area.

<?php
$im = imagecreatefrompng('example.png');
$size = min(imagesx($im), imagesy($im));
$im2 = imagecrop($im, ['x' => 0, 'y' => 0, 'width' => $size, 'height' => $size]);
if ($im2 !== FALSE) {
    imagepng($im2, 'example-cropped.png');
    imagedestroy($im2);
}
imagedestroy($im);
?>

参见

  • imagecropauto() - Crop an image automatically using one of the available modes


Crop an image automatically using one of the available modes

  • ? imagecrop
  • imagedashedline ?
  • PHP Manual
  • GD 和图像处理 函数
  • Crop an image automatically using one of the available modes

imagecropauto

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagecropauto — Crop an image automatically using one of the available modes

说明

imagecropauto ( resource $image , int $mode = IMG_CROP_DEFAULT , float $threshold = .5 , int $color = -1 ) : resource|false

Automatically crops an image according to the given mode.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

mode

One of the following constants:

IMG_CROP_DEFAULT
Same as IMG_CROP_TRANSPARENT. Before PHP 7.4.0, the bundled libgd fell back to IMG_CROP_SIDES, if the image had no transparent color.
IMG_CROP_TRANSPARENT
Crops out a transparent background.
IMG_CROP_BLACK
Crops out a black background.
IMG_CROP_WHITE
Crops out a white background.
IMG_CROP_SIDES
Uses the 4 corners of the image to attempt to detect the background to crop.
IMG_CROP_THRESHOLD
Crops an image using the given threshold and color.
threshold

Specifies the tolerance in percent to be used while comparing the image color and the color to crop. The method used to calculate the color difference is based on the color distance in the RGB(a) cube.

Used only in IMG_CROP_THRESHOLD mode.

Note: Before PHP 7.4.0, the bundled libgd used a somewhat different algorithm, so the same threshold yielded different results for system and bundled libgd.

color

Either an RGB color value or a palette index.

Used only in IMG_CROP_THRESHOLD mode.

返回值

Returns a cropped image resource on success 或者在失败时返回 false. If the complete image was cropped, imagecrop() returns false.

更新日志

版本 | 说明
7.4.0 | The behavior of imagecropauto() in the bundled libgd has been synced with that of system libgd: IMG_CROP_DEFAULT no longer falls back to IMG_CROP_SIDES and threshold-cropping now uses the same algorithm as system libgd.
7.4.0 | The default value of mode has been changed to IMG_CROP_AUTO. Formerly, the default value has been -1 which corresponds to IMG_CROP_DEFAULT, but passing -1 is now deprecated.

范例

Example #1 Proper handling of auto-cropping

As noted in the return value section, imagecropauto() returns false if the whole image was cropped. In this example we have an image resource $im which should be automatically cropped only if there is something to crop; otherwise we want to proceed with the original image.

<?php
$cropped = imagecropauto($im, IMG_CROP_DEFAULT);
if ($cropped !== false) { // in case a new image resource was returned
    imagedestroy($im);    // we destroy the original image
    $im = $cropped;       // and assign the cropped image to $im
}
?>

参见

  • imagecrop() - Crop an image to the given rectangle


画一虚线

  • ? imagecropauto
  • imagedestroy ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一虚线

imagedashedline

(PHP 4, PHP 5, PHP 7, PHP 8)

imagedashedline — 画一虚线

说明

imagedashedline ( resource $image , int $x1 , int $y1 , int $x2 , int $y2 , int $color ) : bool

反对使用本函数。应该用 imagesetstyle() 和 imageline() 的组合替代之。


销毁一图像

  • ? imagedashedline
  • imageellipse ?
  • PHP Manual
  • GD 和图像处理 函数
  • 销毁一图像

imagedestroy

(PHP 4, PHP 5, PHP 7, PHP 8)

imagedestroy — 销毁一图像

说明

imagedestroy ( resource $image ) : bool

imagedestroy() 释放与 image 关联的内存。image 是由图像创建函数返回的图像标识符，例如 imagecreatetruecolor()。


画一个椭圆

  • ? imagedestroy
  • imagefill ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一个椭圆

imageellipse

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imageellipse — 画一个椭圆

说明

imageellipse ( resource $image , int $cx , int $cy , int $width , int $height , int $color ) : bool

在指定的坐标上画一个椭圆。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

cx

中间的 X 坐标。

cy

中间的 Y 坐标。

width

椭圆的宽度。

height

椭圆的高度。

color

椭圆的颜色。颜色标识符由 imagecolorallocate() 创建。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imageellipse() 例子

<?php

// 新建一个空白图像
$image = imagecreatetruecolor(400, 300);

// 填充背景色
$bg = imagecolorallocate($image, 0, 0, 0);

// 选择椭圆的颜色
$col_ellipse = imagecolorallocate($image, 255, 255, 255);

// 画一个椭圆
imageellipse($image, 200, 150, 300, 200, $col_ellipse);

// 输出图像
header("Content-type: image/png");
imagepng($image);

?>

以上例程的输出类似于：

注释

Note:

本函数需要 GD 2.0.2 或更高版本。

参见

  • imagefilledellipse() - 画一椭圆并填充
  • imagearc() - 画椭圆弧


区域填充

  • ? imageellipse
  • imagefilledarc ?
  • PHP Manual
  • GD 和图像处理 函数
  • 区域填充

imagefill

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefill — 区域填充

说明

imagefill ( resource $image , int $x , int $y , int $color ) : bool

imagefill() 在 image 图像的坐标 x，y（图像左上角为 0, 0）处用 color 颜色执行区域填充（即与 x, y 点颜色相同且相邻的点都会被填充）。

Example #1 imagefill() 例子

<?php

$im = imagecreatetruecolor(100, 100);

// 将背景设为红色
$red = imagecolorallocate($im, 255, 0, 0);
imagefill($im, 0, 0, $red);

header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>

参见 imagecolorallocate()。


画一椭圆弧且填充

  • ? imagefill
  • imagefilledellipse ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一椭圆弧且填充

imagefilledarc

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagefilledarc — 画一椭圆弧且填充

说明

imagefilledarc ( resource $image , int $cx , int $cy , int $width , int $height , int $start , int $end , int $color , int $style ) : bool

在指定的 image 上画一椭圆弧且填充。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

cx

中间的 x 坐标。

cy

中间的 y 坐标。

width

椭圆弧的宽度。

height

椭圆弧的高度。

start

起点角度。

end

终点角度。 0° is located at the three-o'clock position, and the arc is drawn clockwise.

color

imagecolorallocate() 创建的颜色标识符。

style

值可以是下列值的按位或（OR）：

  1. IMG_ARC_PIE
  2. IMG_ARC_CHORD
  3. IMG_ARC_NOFILL
  4. IMG_ARC_EDGED
IMG_ARC_PIE 和 IMG_ARC_CHORD 是互斥的；IMG_ARC_CHORD 只是用直线连接了起始和结束点，IMG_ARC_PIE 则产生圆形边界。IMG_ARC_NOFILL 指明弧或弦只有轮廓，不填充。IMG_ARC_EDGED 指明用直线将起始和结束点与中心点相连，和 IMG_ARC_NOFILL 一起使用是画饼状图轮廓的好方法（而不用填充）。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 创建一 3D 效果的饼状图

<?php

// 创建图像
$image = imagecreatetruecolor(100, 100);

// 分配一些颜色
$white    = imagecolorallocate($image, 0xFF, 0xFF, 0xFF);
$gray     = imagecolorallocate($image, 0xC0, 0xC0, 0xC0);
$darkgray = imagecolorallocate($image, 0x90, 0x90, 0x90);
$navy     = imagecolorallocate($image, 0x00, 0x00, 0x80);
$darknavy = imagecolorallocate($image, 0x00, 0x00, 0x50);
$red      = imagecolorallocate($image, 0xFF, 0x00, 0x00);
$darkred  = imagecolorallocate($image, 0x90, 0x00, 0x00);

// 创建 3D 效果
for ($i = 60; $i > 50; $i--) {
   imagefilledarc($image, 50, $i, 100, 50, 0, 45, $darknavy, IMG_ARC_PIE);
   imagefilledarc($image, 50, $i, 100, 50, 45, 75 , $darkgray, IMG_ARC_PIE);
   imagefilledarc($image, 50, $i, 100, 50, 75, 360 , $darkred, IMG_ARC_PIE);
}

imagefilledarc($image, 50, 50, 100, 50, 0, 45, $navy, IMG_ARC_PIE);
imagefilledarc($image, 50, 50, 100, 50, 45, 75 , $gray, IMG_ARC_PIE);
imagefilledarc($image, 50, 50, 100, 50, 75, 360 , $red, IMG_ARC_PIE);

// 输出图像
header('Content-type: image/png');
imagepng($image);
imagedestroy($image);
?>

以上例程的输出类似于：

例子输出：创建一 3D 效果的饼状图

注释


画一椭圆并填充

  • ? imagefilledarc
  • imagefilledpolygon ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一椭圆并填充

imagefilledellipse

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagefilledellipse — 画一椭圆并填充

说明

imagefilledellipse ( resource $image , int $cx , int $cy , int $width , int $height , int $color ) : bool

画一椭圆并填充到指定的 image。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

cx

中央的 x 坐标。

cy

中央的 y 坐标。

width

椭圆的宽度。

height

椭圆的高度。

color

要填充的颜色。颜色标识由函数 imagecolorallocate() 创建。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imagefilledellipse() 例子

<?php

// create a blank image
$image = imagecreatetruecolor(400, 300);

// fill the background color
$bg = imagecolorallocate($image, 0, 0, 0);

// choose a color for the ellipse
$col_ellipse = imagecolorallocate($image, 255, 255, 255);

// draw the white ellipse
imagefilledellipse($image, 200, 150, 300, 200, $col_ellipse);

// output the picture
header("Content-type: image/png");
imagepng($image);

?>

以上例程的输出类似于：

注释

参见

  • imageellipse() - 画一个椭圆
  • imagefilledarc() - 画一椭圆弧且填充


画一多边形并填充

  • ? imagefilledellipse
  • imagefilledrectangle ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一多边形并填充

imagefilledpolygon

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefilledpolygon — 画一多边形并填充

说明

imagefilledpolygon ( resource $image , array $points , int $num_points , int $color ) : bool

imagefilledpolygon() 在 image 图像中画一个填充了的多边形。

points 参数是一个按顺序包含有多边形各顶点的 x 和 y 坐标的数组。

num_points 参数是顶点的总数，必须大于 3。

Example #1 imagefilledpolygon() 例子

<?php
// 建立多边形各顶点坐标的数组
$values = array(
            40,  50,  // Point 1 (x, y)
            20,  240, // Point 2 (x, y)
            60,  60,  // Point 3 (x, y)
            240, 20,  // Point 4 (x, y)
            50,  40,  // Point 5 (x, y)
            10,  10   // Point 6 (x, y)
            );

// 创建图像
$image = imagecreatetruecolor(250, 250);

// 设定颜色
$bg   = imagecolorallocate($image, 200, 200, 200);
$blue = imagecolorallocate($image, 0, 0, 255);

// 画一个多边形
imagefilledpolygon($image, $values, 6, $blue);

// 输出图像
header('Content-type: image/png');
imagepng($image);
imagedestroy($image);
?>


画一矩形并填充

  • ? imagefilledpolygon
  • imagefilltoborder ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一矩形并填充

imagefilledrectangle

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefilledrectangle — 画一矩形并填充

说明

imagefilledrectangle ( resource $image , int $x1 , int $y1 , int $x2 , int $y2 , int $color ) : bool

imagefilledrectangle() 在 image 图像中画一个用 color 颜色填充了的矩形，其左上角坐标为 x1，y1，右下角坐标为 x2，y2。0, 0 是图像的最左上角。


区域填充到指定颜色的边界为止

  • ? imagefilledrectangle
  • imagefilter ?
  • PHP Manual
  • GD 和图像处理 函数
  • 区域填充到指定颜色的边界为止

imagefilltoborder

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefilltoborder — 区域填充到指定颜色的边界为止

说明

imagefilltoborder ( resource $image , int $x , int $y , int $border , int $color ) : bool

imagefilltoborder() 从 x，y（图像左上角为 0, 0）点开始用 color 颜色执行区域填充，直到碰到颜色为 border 的边界为止。【注：边界内的所有颜色都会被填充。如果指定的边界色和该点颜色相同，则没有填充。如果图像中没有该边界色，则整幅图像都会被填充。】


对图像使用过滤器

  • ? imagefilltoborder
  • imageflip ?
  • PHP Manual
  • GD 和图像处理 函数
  • 对图像使用过滤器

imagefilter

(PHP 5, PHP 7, PHP 8)

imagefilter — 对图像使用过滤器

说明

imagefilter ( resource $src_im , int $filtertype , int $arg1 = ? , int $arg2 = ? , int $arg3 = ? ) : bool

imagefilter() 把过滤器 filtertype 应用到图像上，在需要时使用 arg1，arg2 和 arg3。

filtertype 可以是下列中的一个：

  • IMG_FILTER_NEGATE：将图像中所有颜色反转。
  • IMG_FILTER_GRAYSCALE：将图像转换为灰度的。
  • IMG_FILTER_BRIGHTNESS：改变图像的亮度。用 arg1 设定亮度级别。
  • IMG_FILTER_CONTRAST：改变图像的对比度。用 arg1 设定对比度级别。
  • IMG_FILTER_COLORIZE：与 IMG_FILTER_GRAYSCALE 类似，不过可以指定颜色。用 arg1，arg2 和 arg3 分别指定 red，blue 和 green。每种颜色范围是 0 到 255。
  • IMG_FILTER_EDGEDETECT：用边缘检测来突出图像的边缘。
  • IMG_FILTER_EMBOSS：使图像浮雕化。
  • IMG_FILTER_GAUSSIAN_BLUR：用高斯算法模糊图像。
  • IMG_FILTER_SELECTIVE_BLUR：模糊图像。
  • IMG_FILTER_MEAN_REMOVAL：用平均移除法来达到轮廓效果。
  • IMG_FILTER_SMOOTH：使图像更柔滑。用 arg1 设定柔滑级别。

成功时返回 true， 或者在失败时返回 false。

Example #1 imagefilter() 灰度例子

<?php
$im = imagecreatefrompng('dave.png');
if ($im && imagefilter($im, IMG_FILTER_GRAYSCALE)) {
    echo 'Image converted to grayscale.';
    imagepng($im, 'dave.png');
} else {
    echo 'Conversion to grayscale failed.';
}

imagedestroy($im);
?>

Example #2 imagefilter() 亮度例子

<?php
$im = imagecreatefrompng('sean.png');
if ($im && imagefilter($im, IMG_FILTER_BRIGHTNESS, 20)) {
    echo 'Image brightness changed.';
    imagepng($im, 'sean.png');
} else {
    echo 'Image brightness change failed.';
}

imagedestroy($im);
?>

Example #3 imagefilter() 上彩例子

<?php
$im = imagecreatefrompng('philip.png');

/* R, G, B, so 0, 255, 0 is green */
if ($im && imagefilter($im, IMG_FILTER_COLORIZE, 0, 255, 0)) {
    echo 'Image successfully shaded green.';
    imagepng($im, 'philip.png');
} else {
    echo 'Green shading failed.';
}

imagedestroy($im);
?>

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

filtertype

filtertype can be one of the following:

  • IMG_FILTER_NEGATE: Reverses all colors of the image.
  • IMG_FILTER_GRAYSCALE: Converts the image into grayscale.
  • IMG_FILTER_BRIGHTNESS: Changes the brightness of the image. Use arg1 to set the level of brightness.
  • IMG_FILTER_CONTRAST: Changes the contrast of the image. Use arg1 to set the level of contrast.
  • IMG_FILTER_COLORIZE: Like IMG_FILTER_GRAYSCALE, except you can specify the color. Use arg1, arg2 and arg3 in the form of red, blue, green and arg4 for the alpha channel. The range for each color is 0 to 255.
  • IMG_FILTER_EDGEDETECT: Uses edge detection to highlight the edges in the image.
  • IMG_FILTER_EMBOSS: Embosses the image.
  • IMG_FILTER_GAUSSIAN_BLUR: Blurs the image using the Gaussian method.
  • IMG_FILTER_SELECTIVE_BLUR: Blurs the image.
  • IMG_FILTER_MEAN_REMOVAL: Uses mean removal to achieve a "sketchy" effect.
  • IMG_FILTER_SMOOTH: Makes the image smoother. Use arg1 to set the level of smoothness.
  • IMG_FILTER_PIXELATE: Applies pixelation effect to the image, use arg1 to set the block size and arg2 to set the pixelation effect mode.

arg1

  • IMG_FILTER_BRIGHTNESS: Brightness level.
  • IMG_FILTER_CONTRAST: Contrast level.
  • IMG_FILTER_COLORIZE: 红色成分的值。
  • IMG_FILTER_SMOOTH: Smoothness level.
  • IMG_FILTER_PIXELATE: Block size in pixels.

arg2

  • IMG_FILTER_COLORIZE: 绿色成分的值。
  • IMG_FILTER_PIXELATE: Whether to use advanced pixelation effect or not (defaults to false).

arg3

  • IMG_FILTER_COLORIZE: 蓝色成分的值。

arg4

  • IMG_FILTER_COLORIZE: Alpha channel, A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.3.0 | Pixelation support (IMG_FILTER_PIXELATE) was added.
5.2.5 | Alpha support for IMG_FILTER_COLORIZE was added.

范例

Example #4 imagefilter() grayscale example

<?php
$im = imagecreatefrompng('dave.png');

if($im && imagefilter($im, IMG_FILTER_GRAYSCALE))
{
    echo 'Image converted to grayscale.';

    imagepng($im, 'dave.png');
}
else
{
    echo 'Conversion to grayscale failed.';
}

imagedestroy($im);
?>

Example #5 imagefilter() brightness example

<?php
$im = imagecreatefrompng('sean.png');

if($im && imagefilter($im, IMG_FILTER_BRIGHTNESS, 20))
{
    echo 'Image brightness changed.';

    imagepng($im, 'sean.png');
    imagedestroy($im);
}
else
{
    echo 'Image brightness change failed.';
}
?>

Example #6 imagefilter() colorize example

<?php
$im = imagecreatefrompng('philip.png');

/* R, G, B, so 0, 255, 0 is green */
if($im && imagefilter($im, IMG_FILTER_COLORIZE, 0, 255, 0))
{
    echo 'Image successfully shaded green.';

    imagepng($im, 'philip.png');
    imagedestroy($im);
}
else
{
    echo 'Green shading failed.';
}
?>

Example #7 imagefilter() negate example

<?php
// Define our negate function so its portable for
// php versions without imagefilter()
function negate($im)
{
    if(function_exists('imagefilter'))
    {
        return imagefilter($im, IMG_FILTER_NEGATE);
    }

    for($x = 0; $x < imagesx($im); ++$x)
    {
        for($y = 0; $y < imagesy($im); ++$y)
        {
            $index = imagecolorat($im, $x, $y);
            $rgb = imagecolorsforindex($index);
            $color = imagecolorallocate($im, 255 - $rgb['red'], 255 - $rgb['green'], 255 - $rgb['blue']);

            imagesetpixel($im, $x, $y, $color);
        }
    }

    return(true);
}

$im = imagecreatefromjpeg('kalle.jpg');

if($im && negate($im))
{
    echo 'Image successfully converted to negative colors.';

    imagejpeg($im, 'kalle.jpg', 100);
    imagedestroy($im);
}
else
{
    echo 'Converting to negative colors failed.';
}
?>

Example #8 imagefilter() pixelate example

<?php
// Load the PHP logo, we need to create two instances
// to show the differences
$logo1 = imagecreatefrompng('./php.png');
$logo2 = imagecreatefrompng('./php.png');

// Create the image instance we want to show the
// differences on
$output = imagecreatetruecolor(imagesx($logo1) * 2, imagesy($logo1));

// Apply pixelation to each instance, with a block
// size of 3
imagefilter($logo1, IMG_FILTER_PIXELATE, 3);
imagefilter($logo2, IMG_FILTER_PIXELATE, 3, true);

// Merge the differences onto the output image
imagecopy($output, $logo1, 0, 0, 0, 0, imagesx($logo1) - 1, imagesy($logo1) - 1);
imagecopy($output, $logo2, imagesx($logo2), 0, 0, 0, imagesx($logo2) - 1, imagesy($logo2) - 1);
imagedestroy($logo1);
imagedestroy($logo2);

// Output the differences
header('Content-Type: image/png');
imagepng($output);
imagedestroy($output);
?>

以上例程的输出类似于：

Output of example : imagefilter() pixelate

注释

参见

  • imageconvolution() - 用系数 div 和 offset 申请一个 3x3 的卷积矩阵


Flips an image using a given mode

  • ? imagefilter
  • imagefontheight ?
  • PHP Manual
  • GD 和图像处理 函数
  • Flips an image using a given mode

imageflip

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imageflip — Flips an image using a given mode

说明

imageflip ( resource $image , int $mode ) : bool

Flips the image image using the given mode.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

mode

Flip mode, this can be one of the IMG_FLIP_* constants:

Constant | Meaning
IMG_FLIP_HORIZONTAL | Flips the image horizontally.
IMG_FLIP_VERTICAL | Flips the image vertically.
IMG_FLIP_BOTH | Flips the image both horizontally and vertically.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Flips an image vertically

This example uses the IMG_FLIP_VERTICAL constant.

<?php
// File
$filename = 'phplogo.png';

// Content type
header('Content-type: image/png');

// Load
$im = imagecreatefrompng($filename);

// Flip it vertically
imageflip($im, IMG_FLIP_VERTICAL);

// Output
imagejpeg($im);
imagedestroy($im);
?>

以上例程的输出类似于：

Output of example: Vertically flipped image

Example #2 Flips the image horizontally

This example uses the IMG_FLIP_HORIZONTAL constant.

<?php
// File
$filename = 'phplogo.png';

// Content type
header('Content-type: image/png');

// Load
$im = imagecreatefrompng($filename);

// Flip it horizontally
imageflip($im, IMG_FLIP_HORIZONTAL);

// Output
imagejpeg($im);
imagedestroy($im);
?>

以上例程的输出类似于：

Output of example: Horizontally flipped image


取得字体高度

  • ? imageflip
  • imagefontwidth ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得字体高度

imagefontheight

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefontheight — 取得字体高度

说明

imagefontheight ( int $font ) : int

返回指定字体一个字符高度的像素值。

参见 imagefontwidth() 和 imageloadfont()。


取得字体宽度

  • ? imagefontheight
  • imageftbbox ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得字体宽度

imagefontwidth

(PHP 4, PHP 5, PHP 7, PHP 8)

imagefontwidth — 取得字体宽度

说明

imagefontwidth ( int $font ) : int

返回指定字体一个字符宽度的像素值。

参见 imagefontheight() 和 imageloadfont()。


给出一个使用 FreeType 2 字体的文本框

  • ? imagefontwidth
  • imagefttext ?
  • PHP Manual
  • GD 和图像处理 函数
  • 给出一个使用 FreeType 2 字体的文本框

imageftbbox

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imageftbbox — 给出一个使用 FreeType 2 字体的文本框

说明

imageftbbox ( float $size , float $angle , string $fontfile , string $text , array $extrainfo = ? ) : array

This function calculates and returns the bounding box in pixels for a FreeType text.

参数

size

字体的尺寸，单位：点（磅）。

angle

Angle in degrees in which text will be measured.

fontfile

The name of the TrueType font file (can be a URL). Depending on which version of the GD library that PHP is using, it may attempt to search for files that do not begin with a leading '/' by appending '.ttf' to the filename and searching along a library-defined font path.

text

The string to be measured.

extrainfo

Possible array indexes for extrainfo
Key | Type | Meaning
linespacing | float | Defines drawing linespacing

返回值

imageftbbox() returns an array with 8 elements representing four points making the bounding box of the text:

0 | lower left corner, X position
1 | lower left corner, Y position
2 | lower right corner, X position
3 | lower right corner, Y position
4 | upper right corner, X position
5 | upper right corner, Y position
6 | upper left corner, X position
7 | upper left corner, Y position

The points are relative to the text regardless of the angle, so "upper left" means in the top left-hand corner seeing the text horizontally.

范例

Example #1 imageftbbox() example

<?php
// Create a 300x150 image
$im = imagecreatetruecolor(300, 150);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);

// Set the background to be white
imagefilledrectangle($im, 0, 0, 299, 299, $white);

// Path to our font file
$font = './arial.ttf';

// First we create our bounding box
$bbox = imageftbbox(10, 0, $font, 'The PHP Documentation Group');

// This is our cordinates for X and Y
$x = $bbox[0] + (imagesx($im) / 2) - ($bbox[4] / 2) - 5;
$y = $bbox[1] + (imagesy($im) / 2) - ($bbox[5] / 2) - 5;

imagefttext($im, 10, 0, $x, $y, $black, $font, 'The PHP Documentation Group');

// Output to browser
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

注释

Note: 此函数仅在 PHP 编译时加入 freetype 支持时有效（--with-freetype-dir=DIR）。

更新日志

版本 | 说明
4.3.5 | extrainfo was made optional.


使用 FreeType 2 字体将文本写入图像

  • ? imageftbbox
  • imagegammacorrect ?
  • PHP Manual
  • GD 和图像处理 函数
  • 使用 FreeType 2 字体将文本写入图像

imagefttext

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagefttext — 使用 FreeType 2 字体将文本写入图像

说明

imagefttext ( resource $image , float $size , float $angle , int $x , int $y , int $color , string $fontfile , string $text , array $extrainfo = ? ) : array

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

size

The font size to use in points.

angle

The angle in degrees, with 0 degrees being left-to-right reading text. Higher values represent a counter-clockwise rotation. For example, a value of 90 would result in bottom-to-top reading text.

x

The coordinates given by x and y will define the basepoint of the first character (roughly the lower-left corner of the character). This is different from the imagestring(), where x and y define the upper-left corner of the first character. For example, "top left" is 0, 0.

y

The y-ordinate. This sets the position of the fonts baseline, not the very bottom of the character.

color

The index of the desired color for the text, see imagecolorexact().

fontfile

The path to the TrueType font you wish to use.

Depending on which version of the GD library PHP is using, when fontfile does not begin with a leading / then .ttf will be appended to the filename and the library will attempt to search for that filename along a library-defined font path.

When using versions of the GD library lower than 2.0.18, a space character, rather than a semicolon, was used as the 'path separator' for different font files. Unintentional use of this feature will result in the warning message: Warning: Could not find/open font. For these affected versions, the only solution is moving the font to a path which does not contain spaces.

In many cases where a font resides in the same directory as the script using it the following trick will alleviate any include problems.

<?php
// Set the enviroment variable for GD
putenv('GDFONTPATH=' . realpath('.'));

// Name the font to be used (note the lack of the .ttf extension)
$font = 'SomeFont';
?>

text

Text to be inserted into image.

extrainfo

Possible array indexes for extrainfo
Key | Type | Meaning
linespacing | float | Defines drawing linespacing

返回值

This function returns an array defining the four points of the box, starting in the lower left and moving counter-clockwise:

0 | lower left x-coordinate
1 | lower left y-coordinate
2 | lower right x-coordinate
3 | lower right y-coordinate
4 | upper right x-coordinate
5 | upper right y-coordinate
6 | upper left x-coordinate
7 | upper left y-coordinate

范例

Example #1 imagefttext() example

<?php
// Create a 300x100 image
$im = imagecreatetruecolor(300, 100);
$red = imagecolorallocate($im, 0xFF, 0x00, 0x00);
$black = imagecolorallocate($im, 0x00, 0x00, 0x00);

// Make the background red
imagefilledrectangle($im, 0, 0, 299, 99, $red);

// Path to our ttf font file
$font_file = './arial.ttf';

// Draw the text 'PHP Manual' using font size 13
imagefttext($im, 13, 0, 105, 55, $black, $font_file, 'PHP Manual');

// Output image to the browser
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

注释

Note: 此函数仅在 PHP 编译时加入 freetype 支持时有效（--with-freetype-dir=DIR）。

更新日志

版本 | 说明
4.3.5 | extrainfo was made optional.


对 GD 图像应用 gamma 修正

  • ? imagefttext
  • imagegd2 ?
  • PHP Manual
  • GD 和图像处理 函数
  • 对 GD 图像应用 gamma 修正

imagegammacorrect

(PHP 4, PHP 5, PHP 7, PHP 8)

imagegammacorrect — 对 GD 图像应用 gamma 修正

说明

imagegammacorrect ( resource $image , float $inputgamma , float $outputgamma ) : bool

imagegammacorrect() 函数用给定的输入 gamma 值 inputgamma 和输出 gamma 值 outputgamma 对一幅 GD 图像流（image）应用 gamma 修正。


将 GD2 图像输出到浏览器或文件

  • ? imagegammacorrect
  • imagegd ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将 GD2 图像输出到浏览器或文件

imagegd2

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagegd2 — 将 GD2 图像输出到浏览器或文件

说明

imagegd2 ( resource $image , string $filename = ? , int $chunk_size = ? , int $type = IMG_GD2_RAW ) : bool

imagegd2() 将一个 GD 图像输出到 filename。image

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

filename

文件保存的路径，如果未设置或为 null，将会直接输出原始图象流。

chunk_size

Chunk size.

type

可以是 IMG_GD2_RAW 或 IMG_GD2_COMPRESSED。默认为 IMG_GD2_RAW。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 输出一个 GD2 图像

<?php
// Create a blank image and add some text
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);

// Output the image
imagegd2($im);

// Free up memory
imagedestroy($im);
?>

Example #2 保存 GD2 图像

<?php
// Create a blank image and add some text
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);

// Save the gd2 image
// The file format for GD2 images is .gd2, see http://www.libgd.org/GdFileFormats
imagegd2($im, 'simple.gd2');

// Free up memory
imagedestroy($im);
?>

注释

Note:

GD2 格式一般是用来加载图像中的一部分时更快。注意 GD2 格式只能用于兼容于 GD2 的应用程序。

更新日志

版本 | 说明
4.3.2 | 添加了参数 chunk_size 和 type。

参见

  • imagegd() - 将 GD 图像输出到浏览器或文件


将 GD 图像输出到浏览器或文件

  • ? imagegd2
  • imagegetclip ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将 GD 图像输出到浏览器或文件

imagegd

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imagegd — 将 GD 图像输出到浏览器或文件

说明

imagegd ( resource $image , string $filename = ? ) : bool

imagegd() 将一个 GD 图像输出到 filename。image 参数是由 imagecreatetruecolor() 函数返回的。

filename 参数为可选项，如果为空，则原始图像流会被直接输出。

Note:

GD 格式一般是用来加载图像中的一部分时更快。注意 GD 格式只能用于兼容于 GD 的应用程序。

参见 imagegd2()。


Get the clipping rectangle

  • ? imagegd
  • imagegetinterpolation ?
  • PHP Manual
  • GD 和图像处理 函数
  • Get the clipping rectangle

imagegetclip

(PHP 7 >= 7.2.0, PHP 8)

imagegetclip — Get the clipping rectangle

说明

imagegetclip ( resource $im ) : array

imagegetclip() retrieves the current clipping rectangle, i.e. the area beyond which no pixels will be drawn.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

返回值

The function returns an indexed array with the coordinates of the clipping rectangle which has the following entries:

  • x-coordinate of the upper left corner
  • y-coordinate of the upper left corner
  • x-coordinate of the lower right corner
  • y-coordinate of the lower right corner

范例

Example #1 imagegetclip() example

Setting and retrieving the clipping rectangle.

<?php
$im = imagecreate(100, 100);
imagesetclip($im, 10,10, 89,89);
print_r(imagegetclip($im));

以上例程会输出：

Array
(
    [0] => 10
    [1] => 10
    [2] => 89
    [3] => 89
)

参见

  • imagesetclip() - Set the clipping rectangle


Get the interpolation method

  • ? imagegetclip
  • imagegif ?
  • PHP Manual
  • GD 和图像处理 函数
  • Get the interpolation method

imagegetinterpolation

(PHP 8)

imagegetinterpolation — Get the interpolation method

说明

imagegetinterpolation ( GdImage $image ) : int

Gets the currently set interpolation method of the image.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

返回值

Returns the interpolation method.

参见

  • imagesetinterpolation() - Set the interpolation method


输出图象到浏览器或文件。

  • ? imagegetinterpolation
  • imagegrabscreen ?
  • PHP Manual
  • GD 和图像处理 函数
  • 输出图象到浏览器或文件。

imagegif

(PHP 4, PHP 5, PHP 7, PHP 8)

imagegif — 输出图象到浏览器或文件。

说明

imagegif ( resource $image , string $filename = ? ) : bool

imagegif() 从 image 图像以 filename 为文件名创建一个 GIF 图像。image 参数是 imagecreate() 或 imagecreatefrom* 函数的返回值。

图像格式为 GIF87a。如果用了 imagecolortransparent() 使图像为透明，则其格式为 GIF89a。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

filename

文件保存的路径，如果未设置或为 null，将会直接输出原始图象流。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 使用 imagegif() 输出一个图像

<?php
// 创建新的图像实例
$im = imagecreatetruecolor(100, 100);

// 设置背景为白色
imagefilledrectangle($im, 0, 0, 99, 99, 0xFFFFFF);

//在图像上写字
imagestring($im, 3, 40, 20, 'GD Library', 0xFFBA00);

// 输出图像到浏览器
header('Content-Type: image/gif');

imagegif($im);
imagedestroy($im);
?>

Example #2 使用 imagegif() 将一个 PNG 转换成 GIF

<?php

// 载入 PNG
$png = imagecreatefrompng('./php.png');

// 以 GIF 保存图像
imagegif($png, './php.gif');

// 释放内存
imagedestroy($png);

// 完工
echo 'Converted PNG image to GIF with success!';
?>

注释

Note:

不过从 GD 库 1.6 起所有的 GIF 支持都移除了，并在版本 2.0.28 中加了回来。如果使用这些 版本之间的 GD 库时本函数不可用。 更多信息见 » GD Project 站点。

以下代码段通过自动检测 GD 支持的图像类型来写出移植性更好的 PHP 程序。用更灵活的代码替代了原来的 header("Content-type: image/gif"); imagegif($im);：

<?php
// 创建新的图像实例
$im = imagecreatetruecolor(100, 100);

// 在这里对图像进行一些操作

// 处理输出
if(function_exists('imagegif'))
{
    // 针对 GIF
    header('Content-Type: image/gif');

    imagegif($im);
}
elseif(function_exists('imagejpeg'))
{
    // 针对 JPEG
    header('Content-Type: image/jpeg');

    imagejpeg($im, NULL, 100);
}
elseif(function_exists('imagepng'))
{
    // 针对 PNG
    header('Content-Type: image/png');

    imagepng($im);
}
elseif(function_exists('imagewbmp'))
{
    // 针对 WBMP
    header('Content-Type: image/vnd.wap.wbmp');

    imagewbmp($im);
}
else
{
    imagedestroy($im);

    die('No image support in this PHP server');
}

// 如果发现图像是以上的格式之一，就从内存中释放
if($im)
{
    imagedestroy($im);
}
?>

Note:

自 PHP 3.0.18 和 4.0.2 起可以用 imagetypes() 函数代替 function_exists() 来检查是否支持某种图像格式：

<?php
if(imagetypes() & IMG_GIF)
{
    header('Content-Type: image/gif');
    imagegif($im);
}
elseif(imagetypes() & IMG_JPG)
{
    /* ... etc. */
}
?>

参见

  • imagepng() - 以 PNG 格式将图像输出到浏览器或文件
  • imagewbmp() - 以 WBMP 格式将图像输出到浏览器或文件
  • imagejpeg() - 输出图象到浏览器或文件。
  • imagetypes() - 返回当前 PHP 版本所支持的图像类型


Captures the whole screen

  • ? imagegif
  • imagegrabwindow ?
  • PHP Manual
  • GD 和图像处理 函数
  • Captures the whole screen

imagegrabscreen

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

imagegrabscreen — Captures the whole screen

说明

imagegrabscreen ( ) : resource

Grabs a screenshot of the whole screen.

Note:

This function is only available on Windows.

返回值

Returns an image resource identifier on success, false on failure.

范例

Example #1 imagegrabscreen() example

This example demonstrates how to take a screenshot of the current screen and save it as a png image.

<?php
$im = imagegrabscreen();
imagepng($im, "myscreenshot.png");
imagedestroy($im);
?>

参见

  • imagegrabwindow() - Captures a window


Captures a window

  • ? imagegrabscreen
  • imageinterlace ?
  • PHP Manual
  • GD 和图像处理 函数
  • Captures a window

imagegrabwindow

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

imagegrabwindow — Captures a window

说明

imagegrabwindow ( int $window_handle , int $client_area = 0 ) : resource

Grabs a window or its client area using a windows handle (HWND property in COM instance)

Note:

This function is only available on Windows.

参数

window_handle

The HWND window ID.

client_area

Include the client area of the application window.

返回值

Returns an image resource identifier on success, false on failure.

错误／异常

E_NOTICE is issued if window_handle is invalid window handle. E_WARNING is issued if the Windows API is too old.

范例

Example #1 imagegrabwindow() example

Capture a window (IE for example)

<?php
$browser = new COM("InternetExplorer.Application");
$handle = $browser->HWND;
$browser->Visible = true;
$im = imagegrabwindow($handle);
$browser->Quit();
imagepng($im, "iesnap.png");
imagedestroy($im);
?>

Capture a window (IE for example) but with its content

<?php
$browser = new COM("InternetExplorer.Application");
$handle = $browser->HWND;
$browser->Visible = true;
$browser->Navigate("http://www.libgd.org");

/* Still working? */
while ($browser->Busy) {
    com_message_pump(4000);
}
$im = imagegrabwindow($handle, 0);
$browser->Quit();
imagepng($im, "iesnap.png");
imagedestroy($im);
?>

参见

  • imagegrabscreen() - Captures the whole screen


启用或禁用隔行扫描

  • ? imagegrabwindow
  • imageistruecolor ?
  • PHP Manual
  • GD 和图像处理 函数
  • 启用或禁用隔行扫描

imageinterlace

(PHP 4, PHP 5, PHP 7, PHP 8)

imageinterlace — 启用或禁用隔行扫描

说明

imageinterlace ( resource $image , int $interlace = 0 ) : int

imageinterlace() 打开或关闭隔行扫描位（bit）。

如果设置了隔行扫描位（interlace bit），对于 JPEG 图像，会被创建为渐进式 JPEG 图像。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

interlace

如果为 0 ，则关闭隔行扫描，否则将打开隔行扫描。

返回值

如果为图像设置了隔行扫描，则返回 1 ，否则返回 0 。

范例

Example #1 使用 imageinterlace() 打开隔行扫描

<?php
// 创建一个图像实例
$im = imagecreatefromgif('php.gif');

// 打开隔行扫描
imageinterlace($im, true);

// 保存图像
imagegif($im, './php_interlaced.gif');
imagedestroy($im);
?>


检查图像是否为真彩色图像

  • ? imageinterlace
  • imagejpeg ?
  • PHP Manual
  • GD 和图像处理 函数
  • 检查图像是否为真彩色图像

imageistruecolor

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

imageistruecolor — 检查图像是否为真彩色图像

说明

imageistruecolor ( resource $image ) : bool

imageistruecolor() 检查 image 图像是否为真彩色图像。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

返回值

如果 image 是真彩色图像返回 true，否则返回 false。

范例

Example #1 Simple detection of true color image instances using imageistruecolor()

<?php
// $im is an image instance

// Check if image is a true color image or not
if(!imageistruecolor($im))
{
    // Create a new true color image instance
    $tc = imagecreatetruecolor(imagesx($im), imagesy($im));

    imagecopy($tc, $im, 0, 0, 0, 0, imagesx($im), imagesy($im));
    imagedestroy($im);

    $im = $tc;
    $tc = NULL;
}

// Continue working with image instance
?>

注释

参见

  • imagecreatetruecolor() - 新建一个真彩色图像


输出图象到浏览器或文件。

  • ? imageistruecolor
  • imagelayereffect ?
  • PHP Manual
  • GD 和图像处理 函数
  • 输出图象到浏览器或文件。

imagejpeg

(PHP 4, PHP 5, PHP 7, PHP 8)

imagejpeg — 输出图象到浏览器或文件。

说明

imagejpeg ( resource $image , string $filename = ? , int $quality = ? ) : bool

imagejpeg() 从 image 图像以 filename 为文件名创建一个 JPEG 图像。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

filename

文件保存的路径，如果未设置或为 null，将会直接输出原始图象流。

如果要省略这个参数而提供 quality 参数，使用NULL。

quality

quality 为可选项，范围从 0（最差质量，文件更小）到 100（最佳质量，文件最大）。默认为 IJG 默认的质量值（大约 75）。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 输出 JPEG 图像

<?php
// 创键空白图像并添加一些文本
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);

// 设置内容类型标头 —— 这个例子里是 image/jpeg
header('Content-Type: image/jpeg');

// 输出图像
imagejpeg($im);

// 释放内存
imagedestroy($im);
?>

以上例程的输出类似于：

例子的输出：输出 JPEG 图像

Example #2 保存一副 JPEG 图像

<?php
// 创键空白图像并添加一些文本
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);

// 保存图像为 'simpletext.jpg'
imagejpeg($im, 'simpletext.jpg');

// 释放内存
imagedestroy($im);
?>

Example #3 以 75% 的图像质量输出图像

<?php
// 创键空白图像并添加一些文本
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);

// 设置内容类型标头 —— 这个例子里是 image/jpeg
header('Content-Type: image/jpeg');

// 使用 NULL 跳过 filename 参数，并设置图像质量为 75%
imagejpeg($im, NULL, 75);

// 释放内存
imagedestroy($im);
?>

注释

Note:

如果想输出渐进式 JPEG，需要用 imageinterlace() 函数将隔行扫描比特置位。

参见

  • imagepng() - 以 PNG 格式将图像输出到浏览器或文件
  • imagegif() - 输出图象到浏览器或文件。
  • imagewbmp() - 以 WBMP 格式将图像输出到浏览器或文件
  • imageinterlace() - 启用或禁用隔行扫描
  • imagetypes() - 返回当前 PHP 版本所支持的图像类型


设定 alpha 混色标志以使用绑定的 libgd 分层效果

  • ? imagejpeg
  • imageline ?
  • PHP Manual
  • GD 和图像处理 函数
  • 设定 alpha 混色标志以使用绑定的 libgd 分层效果

imagelayereffect

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

imagelayereffect — 设定 alpha 混色标志以使用绑定的 libgd 分层效果

说明

imagelayereffect ( resource $image , int $effect ) : bool

设定 alpha 混色标志以使用绑定的 libgd 分层效果。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

effect

One of the following constants:

IMG_EFFECT_REPLACE
Use pixel replacement (equivalent of passing true to imagealphablending())
IMG_EFFECT_ALPHABLEND
Use normal pixel blending (equivalent of passing false to imagealphablending())
IMG_EFFECT_NORMAL
Same as IMG_EFFECT_ALPHABLEND.
IMG_EFFECT_OVERLAY
Overlay has the effect that black background pixels will remain black, white background pixels will remain white, but grey background pixels will take the colour of the foreground pixel.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imagelayereffect() example

<?php
// Setup an image
$im = imagecreatetruecolor(100, 100);

// Set a background
imagefilledrectangle($im, 0, 0, 100, 100, imagecolorallocate($im, 220, 220, 220));

// Apply the overlay alpha blending flag
imagelayereffect($im, IMG_EFFECT_OVERLAY);

// Draw two grey ellipses
imagefilledellipse($im, 50, 50, 40, 40, imagecolorallocate($im, 100, 255, 100));
imagefilledellipse($im, 50, 50, 50, 80, imagecolorallocate($im, 100, 100, 255));
imagefilledellipse($im, 50, 50, 80, 50, imagecolorallocate($im, 255, 100, 100));

// Output
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

以上例程的输出类似于：

Output of example : imagelayereffect()

注释


画一条线段

  • ? imagelayereffect
  • imageloadfont ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一条线段

imageline

(PHP 4, PHP 5, PHP 7, PHP 8)

imageline — 画一条线段

说明

imageline ( resource $image , int $x1 , int $y1 , int $x2 , int $y2 , int $color ) : bool

imageline() 用 color 颜色在图像 image 中从坐标 x1，y1 到 x2，y2（图像左上角为 0, 0）画一条线段。

Example #1 画一条粗线

<?php

function imagelinethick($image, $x1, $y1, $x2, $y2, $color, $thick = 1)
{
    /* 下面两行只在线段直角相交时好使
    imagesetthickness($image, $thick);
    return imageline($image, $x1, $y1, $x2, $y2, $color);
    */
    if ($thick == 1) {
        return imageline($image, $x1, $y1, $x2, $y2, $color);
    }
    $t = $thick / 2 - 0.5;
    if ($x1 == $x2 || $y1 == $y2) {
        return imagefilledrectangle($image, round(min($x1, $x2) - $t), round(min($y1, $y2) - $t), round(max($x1, $x2) + $t), round(max($y1, $y2) + $t), $color);
    }
    $k = ($y2 - $y1) / ($x2 - $x1); //y = kx + q
    $a = $t / sqrt(1 + pow($k, 2));
    $points = array(
        round($x1 - (1+$k)*$a), round($y1 + (1-$k)*$a),
        round($x1 - (1-$k)*$a), round($y1 - (1+$k)*$a),
        round($x2 + (1+$k)*$a), round($y2 - (1-$k)*$a),
        round($x2 + (1-$k)*$a), round($y2 + (1+$k)*$a),
    );
    imagefilledpolygon($image, $points, 4, $color);
    return imagepolygon($image, $points, 4, $color);
}

?>

参见 imagecreatetruecolor() 和 imagecolorallocate()。


载入一新字体

  • ? imageline
  • imageopenpolygon ?
  • PHP Manual
  • GD 和图像处理 函数
  • 载入一新字体

imageloadfont

(PHP 4, PHP 5, PHP 7, PHP 8)

imageloadfont — 载入一新字体

说明

imageloadfont ( string $file ) : int

imageloadfont() 加载一个用户定义的位图字体并返回该字体的标识符（其值总是大于 5，因此不会和内置字体冲突）。 在产生错误的情况下，该函数返回 false 。

字体文件格式目前是二进制的且和平台有关。这意味着应该用和你运行 PHP 的机器相同类型 CPU 的机器生成字体。

字体文件格式
字节位置 | C 数据类型 | 说明
byte 0-3 | int | 字体中的字符数目
byte 4-7 | int | 字体中第一个字符的值（通常是 32 代表空格）
byte 8-11 | int | 每个字符宽度的像素值
byte 12-15 | int | 每个字符高度的像素值
byte 16- | char | 字符数据的数组，每字符中每像素一字节，一共 (nchars*width*height) 字节。

Example #1 使用 imageloadfont

<?php
header("Content-type: image/png");
$im = imagecreatetruecolor(50, 20);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);
imagefilledrectangle($im, 0, 0, 49, 19, $white);
$font = imageloadfont("04b.gdf");
imagestring($im, $font, 0, 0, "Hello", $black);
imagepng($im);
?>

参见 imagefontwidth() 和 imagefontheight()。


Draws an open polygon

  • ? imageloadfont
  • imagepalettecopy ?
  • PHP Manual
  • GD 和图像处理 函数
  • Draws an open polygon

imageopenpolygon

(PHP 7 >= 7.2.0, PHP 8)

imageopenpolygon — Draws an open polygon

说明

imageopenpolygon ( resource $image , array $points , int $num_points , int $color ) : bool

Alternative signature (as of PHP 8.0.0)

imageopenpolygon ( resource $image , array $points , int $color ) : bool

imageopenpolygon() draws an open polygon on the given image. Contrary to imagepolygon(), no line is drawn between the last and the first point.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

points

An array containing the polygon's vertices, e.g.:

points[0] | = x0
points[1] | = y0
points[2] | = x1
points[3] | = y1

num_points

Total number of points (vertices), which must be at least 3.

If this parameter is omitted as per the second signature, points must have an even number of elements, and num_points is assumed to be count($points)/2.
color

颜色标识符使用 imagecolorallocate() 创建。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imageopenpolygon() example

<?php
// Create a blank image
$image = imagecreatetruecolor(400, 300);

// Allocate a color for the polygon
$col_poly = imagecolorallocate($image, 255, 255, 255);

// Draw the polygon
imageopenpolygon($image, array(
        0,   0,
        100, 200,
        300, 200
    ),
    3,
    $col_poly);

// Output the picture to the browser
header('Content-type: image/png');

imagepng($image);
imagedestroy($image);
?>

以上例程的输出类似于：

Output of example : imageopenpolygon()

参见

  • imagepolygon() - 画一个多边形


将调色板从一幅图像拷贝到另一幅

  • ? imageopenpolygon
  • imagepalettetotruecolor ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将调色板从一幅图像拷贝到另一幅

imagepalettecopy

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagepalettecopy — 将调色板从一幅图像拷贝到另一幅

说明

imagepalettecopy ( resource $destination , resource $source ) : void

imagepalettecopy() 从 source 图像把调色板拷贝到 destination 图像。


Converts a palette based image to true color

  • ? imagepalettecopy
  • imagepng ?
  • PHP Manual
  • GD 和图像处理 函数
  • Converts a palette based image to true color

imagepalettetotruecolor

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagepalettetotruecolor — Converts a palette based image to true color

说明

imagepalettetotruecolor ( resource $src ) : bool

Converts a palette based image, created by functions like imagecreate() to a true color image, like imagecreatetruecolor().

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

返回值

Returns true if the convertion was complete, or if the source image already is a true color image, otherwise false is returned.

范例

Example #1 Converts any image resource to true color

<?php
// Backwards compatiblity
if(!function_exists('imagepalettetotruecolor'))
{
    function imagepalettetotruecolor(&$src)
    {
        if(imageistruecolor($src))
        {
            return(true);
        }

        $dst = imagecreatetruecolor(imagesx($src), imagesy($src));

        imagecopy($dst, $src, 0, 0, 0, 0, imagesx($src), imagesy($src));
        imagedestroy($src);

        $src = $dst;

        return(true);
    }
}

// Helper closure
$typeof = function() use($im)
{
    echo 'typeof($im) = ' . (imageistruecolor($im) ? 'true color' : 'palette'), PHP_EOL;
};

// Create a palette based image
$im = imagecreate(100, 100);
$typeof();

// Convert it to true color
imagepalettetotruecolor($im);
$typeof();

// Free the memory
imagedestroy($im);
?>

以上例程会输出：

typeof($im) = palette
typeof($im) = true color

参见

  • imagecreatetruecolor() - 新建一个真彩色图像
  • imageistruecolor() - 检查图像是否为真彩色图像


以 PNG 格式将图像输出到浏览器或文件

  • ? imagepalettetotruecolor
  • imagepolygon ?
  • PHP Manual
  • GD 和图像处理 函数
  • 以 PNG 格式将图像输出到浏览器或文件

imagepng

(PHP 4, PHP 5, PHP 7, PHP 8)

imagepng — 以 PNG 格式将图像输出到浏览器或文件

说明

imagepng ( resource $image , string $filename = ? ) : bool

imagepng() 将 GD 图像流（image）以 PNG 格式输出到标准输出（通常为浏览器），或者如果用 filename 给出了文件名则将其输出到该文件。

<?php
$im = imagecreatefrompng("test.png");
imagepng($im);
?>

参见 imagegif()，imagewbmp()，imagejpeg() 和 imagetypes()。


画一个多边形

  • ? imagepng
  • imagerectangle ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一个多边形

imagepolygon

(PHP 4, PHP 5, PHP 7, PHP 8)

imagepolygon — 画一个多边形

说明

imagepolygon ( resource $image , array $points , int $num_points , int $color ) : bool

imagepolygon() 在图像中创建一个多边形。points 是一个 PHP 数组，包含了多边形的各个顶点坐标，即 points[0] = x0，points[1] = y0，points[2] = x1，points[3] = y1，以此类推。num_points 是顶点的总数。

Example #1 imagepolygon() 例子

<?php
// create a blank image
$image = imagecreatetruecolor(400, 300);

// fill the background color
$bg = imagecolorallocate($image, 0, 0, 0);

// choose a color for the polygon
$col_poly = imagecolorallocate($image, 255, 255, 255);

// draw the polygon
imagepolygon($image,
             array (
                    0, 0,
                    100, 200,
                    300, 200
             ),
             3,
             $col_poly);

// output the picture
header("Content-type: image/png");
imagepng($image);

?>

参见 imagecreate() 和 imagecreatetruecolor()。


画一个矩形

  • ? imagepolygon
  • imageresolution ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一个矩形

imagerectangle

(PHP 4, PHP 5, PHP 7, PHP 8)

imagerectangle — 画一个矩形

说明

imagerectangle ( resource $image , int $x1 , int $y1 , int $x2 , int $y2 , int $col ) : bool

imagerectangle() 用 col 颜色在 image 图像中画一个矩形，其左上角坐标为 x1, y1，右下角坐标为 x2, y2。图像的左上角坐标为 0, 0。


Get or set the resolution of the image

  • ? imagerectangle
  • imagerotate ?
  • PHP Manual
  • GD 和图像处理 函数
  • Get or set the resolution of the image

imageresolution

(PHP 7 >= 7.2.0, PHP 8)

imageresolution — Get or set the resolution of the image

说明

imageresolution ( resource $image ) : mixed
imageresolution ( resource $image , int $res_x , int $res_y = $res_x ) : mixed

imageresolution() allows to set and get the resolution of an image in DPI (dots per inch). If none of the optional parameters is given, the current resolution is returned as indexed array. If only res_x is given, the horizontal and vertical resolution are set to this value. If both optional parameters are given, the horizontal and vertical resolution are set to these values, respectively.

The resolution is only used as meta information when images are read from and written to formats supporting this kind of information (curently PNG and JPEG). It does not affect any drawing operations. The default resolution for new images is 96 DPI.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

res_x

The horizontal resolution in DPI.

res_y

The vertical resolution in DPI.

返回值

When used as getter (first signature), it returns an indexed array of the horizontal and vertical resolution on success, 或者在失败时返回 false. When used as setter (second signature), it returns true on success, 或者在失败时返回 false.

范例

Example #1 Setting and getting the resolution of an image

<?php
$im = imagecreatetruecolor(100, 100);
imageresolution($im, 200);
print_r(imageresolution($im));
imageresolution($im, 300, 72);
print_r(imageresolution($im));
?>

以上例程会输出：

Array
(
    [0] => 200
    [1] => 200
)
Array
(
    [0] => 300
    [1] => 72
)


用给定角度旋转图像

  • ? imageresolution
  • imagesavealpha ?
  • PHP Manual
  • GD 和图像处理 函数
  • 用给定角度旋转图像

imagerotate

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

imagerotate — 用给定角度旋转图像

说明

imagerotate ( resource $image , float $angle , int $bgd_color , int $ignore_transparent = 0 ) : resource

将 src_im 图像用给定的 angle 角度旋转。bgd_color 指定了旋转后没有覆盖到的部分的颜色。

旋转的中心是图像的中心，旋转后的图像会按比例缩小以适合目标图像的大小——边缘不会被剪去。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

angle

Rotation angle, in degrees. The rotation angle is interpreted as the number of degrees to rotate the image anticlockwise.

bgd_color

Specifies the color of the uncovered zone after the rotation

ignore_transparent

如果被设为非零值，则透明色会被忽略（否则会被保留）。

返回值

返回旋转后的图像资源， 或者在失败时返回 false。

更新日志

版本 | 说明
5.1.0 | 新增： ignore_transparent 。

范例

Example #1 将图像旋转 180 度

本例将把一幅图像旋转 180 度——上下颠倒。

<?php
// File and rotation
$filename = 'test.jpg';
$degrees = 180;

// Content type
header('Content-type: image/jpeg');

// Load
$source = imagecreatefromjpeg($filename);

// Rotate
$rotate = imagerotate($source, $degrees, 0);

// Output
imagejpeg($rotate);
?>

以上例程的输出类似于：

例子的输出：将图像旋转 180 度

注释


设置标记以在保存 PNG 图像时保存完整的 alpha 通道信息（与单一透明色相反）

  • ? imagerotate
  • imagescale ?
  • PHP Manual
  • GD 和图像处理 函数
  • 设置标记以在保存 PNG 图像时保存完整的 alpha 通道信息（与单一透明色相反）

imagesavealpha

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

imagesavealpha — 设置标记以在保存 PNG 图像时保存完整的 alpha 通道信息（与单一透明色相反）

说明

imagesavealpha ( resource $image , bool $saveflag ) : bool

imagesavealpha() 设置标记以在保存 PNG 图像时保存完整的 alpha 通道信息（与单一透明色相反）。

要使用本函数，必须将 alphablending 清位（imagealphablending($im, false)）。

不是所有的浏览器都支持 alpha 通道，如果在你的浏览器上碰到问题，试着用兼容 alpha 通道的浏览器（例如最新版的 Mozilla）重新加载脚本。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

saveflag

是否保存透明（alpha）通道。 默认 false。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imagesavealpha() 例子

<?php
// 载入带 alpha 通道的 png 图像
$png = imagecreatefrompng('./alphachannel_example.png');

// 做些必须的操作

// 关闭 alpha 渲染并设置 alpha 标志
imagealphablending($png, false);
imagesavealpha($png, true);

// 输出图像到浏览器
header('Content-Type: image/png');

imagepng($png);
imagedestroy($png);
?>

注释

参见

  • imagealphablending() - 设定图像的混色模式


Scale an image using the given new width and height

  • ? imagesavealpha
  • imagesetbrush ?
  • PHP Manual
  • GD 和图像处理 函数
  • Scale an image using the given new width and height

imagescale

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagescale — Scale an image using the given new width and height

说明

imagescale ( resource $image , int $new_width , int $new_height = -1 , int $mode = IMG_BILINEAR_FIXED ) : resource|false

imagescale() scales an image using the given interpolation algorithm.

Note:

Unlike many of other image functions, imagescale() does not modify the passed image; instead, a new image is returned.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

new_width

The width to scale the image to.

new_height

The height to scale the image to. If omitted or negative, the aspect ratio will be preserved.

mode

One of IMG_NEAREST_NEIGHBOUR, IMG_BILINEAR_FIXED, IMG_BICUBIC, IMG_BICUBIC_FIXED or anything else (will use two pass).

Note: IMG_WEIGHTED4 is not yet supported.

返回值

Return the scaled image resource on success 或者在失败时返回 false.

参见

  • imagecopyresized() - 拷贝部分图像并调整大小
  • imagecopyresampled() - 重采样拷贝部分图像并调整大小


设定画线用的画笔图像

  • ? imagescale
  • imagesetclip ?
  • PHP Manual
  • GD 和图像处理 函数
  • 设定画线用的画笔图像

imagesetbrush

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagesetbrush — 设定画线用的画笔图像

说明

imagesetbrush ( resource $image , resource $brush ) : bool

当用特殊的颜色 IMG_COLOR_BRUSHED 或 IMG_COLOR_STYLEDBRUSHED 绘画时，imagesetbrush() 设定了所有画线的函数（例如 imageline() 和 imagepolygon()）所使用的画笔图像。【注：使用画笔图像，所画的线是由 brush 所代表的图像构成的。请参考并尝试运行 imagesetstyle() 中的例子以帮助理解。】

Note:

使用完画笔图像后不需要采取什么特殊动作。但如果销毁了画笔图像，在设定一个新的画笔图像之前不能使用 IMG_COLOR_BRUSHED 或 IMG_COLOR_STYLEDBRUSHED！

Note:

本函数是 PHP 4.0.6 添加的。


Set the clipping rectangle

  • ? imagesetbrush
  • imagesetinterpolation ?
  • PHP Manual
  • GD 和图像处理 函数
  • Set the clipping rectangle

imagesetclip

(PHP 7 >= 7.2.0, PHP 8)

imagesetclip — Set the clipping rectangle

说明

imagesetclip ( resource $im , int $x1 , int $y1 , int $x2 , int $y2 ) : bool

imagesetclip() sets the current clipping rectangle, i.e. the area beyond which no pixels will be drawn.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

x1

The x-coordinate of the upper left corner.

y1

The y-coordinate of the upper left corner.

x2

The x-coordinate of the lower right corner.

y2

The y-coordinate of the lower right corner.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imagegetclip() - Get the clipping rectangle


Set the interpolation method

  • ? imagesetclip
  • imagesetpixel ?
  • PHP Manual
  • GD 和图像处理 函数
  • Set the interpolation method

imagesetinterpolation

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

imagesetinterpolation — Set the interpolation method

说明

imagesetinterpolation ( resource $image , int $method = IMG_BILINEAR_FIXED ) : bool

Sets the interpolation method, setting an interpolation method affects the rendering of various functions in GD, such as the imagerotate() function.

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

method

The interpolation method, which can be one of the following:

  • IMG_BELL: Bell filter.
  • IMG_BESSEL: Bessel filter.
  • IMG_BICUBIC: Bicubic interpolation.
  • IMG_BICUBIC_FIXED: Fixed point implementation of the bicubic interpolation.
  • IMG_BILINEAR_FIXED: Fixed point implementation of the bilinear interpolation (default (also on image creation)).
  • IMG_BLACKMAN: Blackman window function.
  • IMG_BOX: Box blur filter.
  • IMG_BSPLINE: Spline interpolation.
  • IMG_CATMULLROM: Cubic Hermite spline interpolation.
  • IMG_GAUSSIAN: Gaussian function.
  • IMG_GENERALIZED_CUBIC: Generalized cubic spline fractal interpolation.
  • IMG_HERMITE: Hermite interpolation.
  • IMG_HAMMING: Hamming filter.
  • IMG_HANNING: Hanning filter.
  • IMG_MITCHELL: Mitchell filter.
  • IMG_POWER: Power interpolation.
  • IMG_QUADRATIC: Inverse quadratic interpolation.
  • IMG_SINC: Sinc function.
  • IMG_NEAREST_NEIGHBOUR: Nearest neighbour interpolation.
  • IMG_WEIGHTED4: Weighting filter.
  • IMG_TRIANGLE: Triangle interpolation.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imagesetinterpolation() example

<?php
// Load an image
$im = imagecreate(500, 500);

// By default interpolation is IMG_BILINEAR_FIXED, switch
// to use the 'Mitchell' filter:
imagesetinterpolation($im, IMG_MITCHELL);

// Continue to work with $im ...
?>

注释

Changing the interpolation method affects the following functions when rendering:

  • imageaffine()
  • imagerotate()

参见

  • imagegetinterpolation() - Get the interpolation method


画一个单一像素

  • ? imagesetinterpolation
  • imagesetstyle ?
  • PHP Manual
  • GD 和图像处理 函数
  • 画一个单一像素

imagesetpixel

(PHP 4, PHP 5, PHP 7, PHP 8)

imagesetpixel — 画一个单一像素

说明

imagesetpixel ( resource $image , int $x , int $y , int $color ) : bool

imagesetpixel() 在 image 图像中用 color 颜色在 x，y 坐标（图像左上角为 0，0）上画一个点。

参见 imagecreatetruecolor() 和 imagecolorallocate()。


设定画线的风格

  • ? imagesetpixel
  • imagesetthickness ?
  • PHP Manual
  • GD 和图像处理 函数
  • 设定画线的风格

imagesetstyle

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagesetstyle — 设定画线的风格

说明

imagesetstyle ( resource $image , array $style ) : bool

imagesetstyle() 设定所有画线的函数（例如
imageline()
和 imagepolygon()）在使用特殊颜色
IMG_COLOR_STYLED 或者用
IMG_COLOR_STYLEDBRUSHED 画一行图像时所使用的风格。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

style

像素组成的数组。你可以通过常量 IMG_COLOR_TRANSPARENT 来添加一个透明像素。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

下面的示例脚本在画布上从左上角到右下角画一行虚线：

Example #1 imagesetstyle() 例子

<?php
header("Content-type: image/jpeg");
$im  = imagecreatetruecolor(100, 100);
$w   = imagecolorallocate($im, 255, 255, 255);
$red = imagecolorallocate($im, 255, 0, 0);

/* 画一条虚线，5 个红色像素，5 个白色像素 */
$style = array($red, $red, $red, $red, $red, $w, $w, $w, $w, $w);
imagesetstyle($im, $style);
imageline($im, 0, 0, 100, 100, IMG_COLOR_STYLED);

/* 用 imagesetbrush() 和 imagesetstyle 画一行笑脸 */
$style = array($w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $red);
imagesetstyle($im, $style);

$brush = imagecreatefrompng("http://www.libpng.org/pub/png/images/smile.happy.png");
$w2 = imagecolorallocate($brush, 255, 255, 255);
imagecolortransparent($brush, $w2);
imagesetbrush($im, $brush);
imageline($im, 100, 0, 0, 100, IMG_COLOR_STYLEDBRUSHED);

imagejpeg($im);
imagedestroy($im);
?>

以上例程的输出类似于：

Output of example : imagesetstyle()

参见

  • imagesetbrush() - 设定画线用的画笔图像
  • imageline() - 画一条线段


设定画线的宽度

  • ? imagesetstyle
  • imagesettile ?
  • PHP Manual
  • GD 和图像处理 函数
  • 设定画线的宽度

imagesetthickness

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagesetthickness — 设定画线的宽度

说明

imagesetthickness ( resource $image , int $thickness ) : bool

imagesetthickness() 把画矩形，多边形，椭圆等等时所用的线宽设为 thickness 个像素。成功时返回 true， 或者在失败时返回 false。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

thickness

Thickness, in pixels.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imagesetthickness() example

<?php
// Create a 200x100 image
$im = imagecreatetruecolor(200, 100);
$white = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
$black = imagecolorallocate($im, 0x00, 0x00, 0x00);

// Set the background to be white
imagefilledrectangle($im, 0, 0, 299, 99, $white);

// Set the line thickness to 5
imagesetthickness($im, 5);

// Draw the rectangle
imagerectangle($im, 14, 14, 185, 85, $black);

// Output image to the browser
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

以上例程的输出类似于：

Output of example : imagesetthickness()

注释


设定用于填充的贴图

  • ? imagesetthickness
  • imagestring ?
  • PHP Manual
  • GD 和图像处理 函数
  • 设定用于填充的贴图

imagesettile

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagesettile — 设定用于填充的贴图

说明

imagesettile ( resource $image , resource $tile ) : bool

imagesettile() 设定所有区域填充函数（例如
imagefill()
和 imagefilledpolygon()）在使用特殊颜色
IMG_COLOR_TILED 填充时所使用的贴图。

贴图是指用重复的样式来填充一块区域所使用的图像。任何 GD 图像都能用作贴图，并且通过使用 imagecolortransparent() 来设定贴图的透明色，贴图可以使底层的特定区域透上来。

Note:

使用完贴图后不需要采取什么特殊动作。但如果销毁了贴图，在设定一个新的贴图之前不能使用 IMG_COLOR_TILED！


水平地画一行字符串

  • ? imagesettile
  • imagestringup ?
  • PHP Manual
  • GD 和图像处理 函数
  • 水平地画一行字符串

imagestring

(PHP 4, PHP 5, PHP 7, PHP 8)

imagestring — 水平地画一行字符串

说明

imagestring ( resource $image , int $font , int $x , int $y , string $s , int $col ) : bool

imagestring() 用 col 颜色将字符串 s 画到 image 所代表的图像的 x，y 坐标处（这是字符串左上角坐标，整幅图像的左上角为 0，0）。如果 font 是 1，2，3，4 或 5，则使用内置字体。

Example #1 imagestring() 例子

<?php
// 建立一幅 100X30 的图像
$im = imagecreate(100, 30);

// 白色背景和蓝色文本
$bg = imagecolorallocate($im, 255, 255, 255);
$textcolor = imagecolorallocate($im, 0, 0, 255);

// 把字符串写在图像左上角
imagestring($im, 5, 0, 0, "Hello world!", $textcolor);

// 输出图像
header("Content-type: image/png");
imagepng($im);
?>

参见 imageloadfont() 和 imagettftext()。


垂直地画一行字符串

  • ? imagestring
  • imagesx ?
  • PHP Manual
  • GD 和图像处理 函数
  • 垂直地画一行字符串

imagestringup

(PHP 4, PHP 5, PHP 7, PHP 8)

imagestringup — 垂直地画一行字符串

说明

imagestringup ( resource $image , int $font , int $x , int $y , string $s , int $col ) : bool

imagestring() 用 col 颜色将字符串 s 垂直地画到 image 所代表的图像的 x, y 座标处（图像的左上角为 0, 0）。如果 font 是 1，2，3，4 或 5，则使用内置字体。

参见 imageloadfont()。


取得图像宽度

  • ? imagestringup
  • imagesy ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得图像宽度

imagesx

(PHP 4, PHP 5, PHP 7, PHP 8)

imagesx — 取得图像宽度

说明

imagesx ( resource $image ) : int

imagesx() 返回 image 所代表的图像的宽度。

Example #1 使用 imagesx()

<?php

// create a 300*200 image
$img = imagecreatetruecolor(300, 200);

echo imagesx($img); // 300

?>

参见 imagecreatetruecolor()，getimagesize() 和 imagesy()。


取得图像高度

  • ? imagesx
  • imagetruecolortopalette ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得图像高度

imagesy

(PHP 4, PHP 5, PHP 7, PHP 8)

imagesy — 取得图像高度

说明

imagesy ( resource $image ) : int

imagesy() 返回 image 所代表的图像的高度。

Example #1 使用 imagesy()

<?php

// create a 300*200 image
$img = imagecreatetruecolor(300, 200);

echo imagesy($img); // 200

?>

参见 imagecreatetruecolor()，getimagesize() 和 imagesx()。


将真彩色图像转换为调色板图像

  • ? imagesy
  • imagettfbbox ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将真彩色图像转换为调色板图像

imagetruecolortopalette

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

imagetruecolortopalette — 将真彩色图像转换为调色板图像

说明

imagetruecolortopalette ( resource $image , bool $dither , int $ncolors ) : bool

imagetruecolortopalette() 将一幅真彩色图像转换为调色板图像。本函数的代码原本是从独立的 JPEG 小组库代码中提取出来的，非常出色。此代码被修改以在结果调色板中保留尽可能多的 alpha 通道信息以及尽可能多的颜色。但并没有达到期望的效果。通常最好生成真彩色图像输出，这样可以保证得到最高的输出质量。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

dither

指明图像是否被抖动（dithered），如果为 true 则图像将被抖动使图像中的斑点更多但是颜色更接近。

ncolors

设定调色板中被保留的颜色的最大数目。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Converting a true color image to a palette-based image

<?php
// Create a new true color image
$im = imagecreatetruecolor(100, 100);

// Convert to palette-based with no dithering and 255 colors
imagetruecolortopalette($im, false, 255);

// Save the image
imagepng($im, './paletteimage.png');
imagedestroy($im);
?>

注释


取得使用 TrueType 字体的文本的范围

  • ? imagetruecolortopalette
  • imagettftext ?
  • PHP Manual
  • GD 和图像处理 函数
  • 取得使用 TrueType 字体的文本的范围

imagettfbbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imagettfbbox — 取得使用 TrueType 字体的文本的范围

说明

imagettfbbox ( float $size , float $angle , string $fontfile , string $text ) : array

本函数计算并返回一个包围着 TrueType 文本范围的虚拟方框的像素大小。

size
像素单位的字体大小。
angle
text 将被度量的角度大小。
fontfile
TrueType 字体文件的文件名（可以是 URL）。根据 PHP 所使用的 GD 库版本，可能尝试搜索那些不是以 '/' 开头的文件名并加上 '.ttf' 的后缀并搜索库定义的字体路径。
text
要度量的字符串。
imagettfbbox() 返回一个含有 8 个单元的数组表示了文本外框的四个角：
0 | 左下角 X 位置
1 | 左下角 Y 位置
2 | 右下角 X 位置
3 | 右下角 Y 位置
4 | 右上角 X 位置
5 | 右上角 Y 位置
6 | 左上角 X 位置
7 | 左上角 Y 位置
这些点是相对于文本的而和角度无关，因此"左上角"指的是以水平方向看文字时其左上角。

本函数同时需要 GD 库和 FreeType 库。

参见 imagettftext()。


用 TrueType 字体向图像写入文本

  • ? imagettfbbox
  • imagetypes ?
  • PHP Manual
  • GD 和图像处理 函数
  • 用 TrueType 字体向图像写入文本

imagettftext

(PHP 4, PHP 5, PHP 7, PHP 8)

imagettftext — 用 TrueType 字体向图像写入文本

说明

imagettftext ( resource $image , float $size , float $angle , int $x , int $y , int $color , string $fontfile , string $text ) : array

使用 TrueType 字体将 指定的 text 写入图像。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

size

字体的尺寸，单位：点（磅）。

angle

角度制表示的角度，0 度为从左向右读的文本。更高数值表示逆时针旋转。例如 90 度表示从下向上读的文本。

x

由 x，y 所表示的坐标定义了第一个字符的基本点（大概是字符的左下角）。这和 imagestring() 不同，其 x，y 定义了第一个字符的左上角。例如 "top left" 为 0, 0。

y

Y 坐标。它设定了字体基线的位置，不是字符的最底端。

color

颜色索引。使用负的颜色索引值具有关闭防锯齿的效果。见 imagecolorallocate()。

fontfile

是想要使用的 TrueType 字体的路径。

根据 PHP 所使用的 GD 库的不同，当 fontfile 没有以 / 开头时则 .ttf 将被加到文件名之后并且会在库定义字体路径中尝试搜索该文件名。

当使用的 GD 库版本低于 2.0.18 时，一个空格字符 而不是分号将被用来作为不同字体文件的"路径分隔符"。不小心使用了此特性将会导致一条警告信息：Warning: Could not find/open font。对受影响的版本来说唯一解决方案就是将字体移动到不包含空格的路径中去。

很多情况下字体都放在脚本的同一个目录下。下面的小技巧可以减轻包含的问题。

<?php
// Set the enviroment variable for GD
putenv('GDFONTPATH=' . realpath('.'));

// Name the font to be used (note the lack of the .ttf extension)
$font = 'SomeFont';
?>

text

UTF-8 编码的文本字符串。

可以包含十进制数字化字符表示（形式为：&#8364;）来访问字体中超过位置 127 的字符。UTF-8 编码的字符串可以直接传递。

命名实体，比如 &copy; 是不支持的。可以考虑使用 html_entity_decode() 来解码命名实体为 UTF-8 字符。 （自 PHP 5.0.0 开始 html_entity_decode() 开始支持）

如果字符串中使用的某个字符不被字体支持，一个空心矩形将替换该字符。

返回值

返回一个含有 8 个单元的数组表示了文本外框的四个角，顺序为坐下角，右下角，右上角，左上角。这些点是相对于文本的而和角度无关，因此"左上角"指的是以水平方向看文字时其左上角。

更新日志

版本 | 说明
5.2.0 | It is now possible to specify an hexadecimal entity in text.

范例

Example #1 imagettftext() 例子

本例中的脚本将生成一个白色的 400x30 像素 PNG 图像，其中有黑色（带灰色阴影）Arial 字体写的"Testing..."。

<?php
// Set the content-type
header('Content-Type: image/png');

// Create the image
$im = imagecreatetruecolor(400, 30);

// Create some colors
$white = imagecolorallocate($im, 255, 255, 255);
$grey = imagecolorallocate($im, 128, 128, 128);
$black = imagecolorallocate($im, 0, 0, 0);
imagefilledrectangle($im, 0, 0, 399, 29, $white);

// The text to draw
$text = 'Testing...';
// Replace path by your own font path
$font = 'arial.ttf';

// Add some shadow to the text
imagettftext($im, 20, 0, 11, 21, $grey, $font, $text);

// Add the text
imagettftext($im, 20, 0, 10, 20, $black, $font, $text);

// Using imagepng() results in clearer text compared with imagejpeg()
imagepng($im);
imagedestroy($im);
?>

以上例程的输出类似于：

注释

Note:

本函数同时需要 GD 库和 » FreeType 库。.

参见

  • imagettfbbox() - 取得使用 TrueType 字体的文本的范围


返回当前 PHP 版本所支持的图像类型

  • ? imagettftext
  • imagewbmp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 返回当前 PHP 版本所支持的图像类型

imagetypes

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

imagetypes — 返回当前 PHP 版本所支持的图像类型

说明

imagetypes ( ) : int

本函数以比特字段方式返回与当前 PHP 版本关联的 GD 库所支持的图像格式。将返回以下结果，IMG_GIF | IMG_JPG | IMG_PNG | IMG_WBMP| IMG_XPM。 例如要检查是否支持 PNG，这样做：

Example #1 imagetypes() 例子

<?php
if (imagetypes() & IMG_PNG) {
    echo "PNG Support is enabled";
}
?>


以 WBMP 格式将图像输出到浏览器或文件

  • ? imagetypes
  • imagewebp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 以 WBMP 格式将图像输出到浏览器或文件

imagewbmp

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

imagewbmp — 以 WBMP 格式将图像输出到浏览器或文件

说明

imagewbmp ( resource $image , string $filename = ? , int $foreground = ? ) : bool

imagewbmp() 从 image 图像创建一个名为 filename 的 WBMP 文件。image 参数是 imagecreatetruecolor() 的返回值。

filename 参数是可选项，如果省略，则直接将原图像流输出。通过用 header() 发送 image/vnd.wap.wbmp 的 Content-type，可以创建直接输出 WBMP 图像的 PHP 脚本。

Note:

WBMP 支持仅能用于 PHP 编译时加入了 GD-1.8 或更高版本时。

用可选的 foreground 参数可以设定前景色，用 imagecolorallocate() 函数返回的颜色标识符。默认前景色是黑色。

参见 image2wbmp()，imagepng()，imagegif()，imagejpeg() 和 imagetypes()。


将 WebP 格式的图像输出到浏览器或文件

  • ? imagewbmp
  • imagexbm ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将 WebP 格式的图像输出到浏览器或文件

imagewebp

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

imagewebp — 将 WebP 格式的图像输出到浏览器或文件

说明

imagewebp ( resource $image , mixed $to = null , int $quality = 80 ) : bool

将 image 参数指定的图像以 WebP 格式输出到浏览器或者保存到文件。

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

to

文件保存的路径，如果未设置或为 null，将会直接输出原始图象流。

quality

quality 范围从0（最低质量，最小文件体积）到100 （最好质量, 最大文件体积）。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.4.0 | 支持把 resource 流作为 to 参数传入。

范例

Example #1 保存为 WebP 图像文件

<?php
// 创建一个空图像并在其上加入一些文字
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);

imagestring($im, 1, 5, 5,  'WebP with PHP', $text_color);

// 保存图像
imagewebp($im, 'php.webp');

// 释放内存
imagedestroy($im);
?>


将 XBM 图像输出到浏览器或文件

  • ? imagewebp
  • iptcembed ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将 XBM 图像输出到浏览器或文件

imagexbm

(PHP 5, PHP 7, PHP 8)

imagexbm — 将 XBM 图像输出到浏览器或文件

说明

imagexbm ( resource $image , string $filename , int $foreground = ? ) : bool

将 XBM 图像 image 输出到浏览器或文件

参数

image

由图象创建函数(例如imagecreatetruecolor())返回的图象资源。

filename

文件保存的路径，如果未设置或为 null，将会直接输出原始图象流。

foreground

你可以从 imagecolorallocate() 分配一个颜色，并设置为该前景色参数。 默认颜色是黑色。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 保存一个 XBM 文件

<?php
// 创建空白图像并添加文字
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);

// 保存图像
imagexbm($im, 'simpletext.xbm');

// 释放内存
imagedestroy($im);
?>

Example #2 以不同前景色保存一个 XBM 文件

<?php
// 创建空白图像并添加文字
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);

// 设置替换的前景色
$foreground_color = imagecolorallocate($im, 255, 0, 0);

// 保存图像
imagexbm($im, NULL, $foreground_color);

// 释放内存
imagedestroy($im);
?>

注释


将二进制 IPTC 数据嵌入到一幅 JPEG 图像中

  • ? imagexbm
  • iptcparse ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将二进制 IPTC 数据嵌入到一幅 JPEG 图像中

iptcembed

(PHP 4, PHP 5, PHP 7, PHP 8)

iptcembed — 将二进制 IPTC 数据嵌入到一幅 JPEG 图像中

说明

iptcembed ( string $iptcdata , string $jpeg_file_name , int $spool = ? ) : mixed

Embeds binary IPTC data into a JPEG image.

参数

iptcdata

The data to be written.

jpeg_file_name

Path to the JPEG image.

spool

Spool flag. If the spool flag is over 2 then the JPEG will be returned as a string.

返回值

If success and spool flag is lower than 2 then the JPEG will not be returned as a string, false on errors.

范例

Example #1 Embedding IPTC data into a JPEG

<?php

// iptc_make_tag() function by Thies C. Arntzen
function iptc_make_tag($rec, $data, $value)
{
    $length = strlen($value);
    $retval = chr(0x1C) . chr($rec) . chr($data);

    if($length < 0x8000)
    {
        $retval .= chr($length >> 8) .  chr($length & 0xFF);
    }
    else
    {
        $retval .= chr(0x80) .
                   chr(0x04) .
                   chr(($length >> 24) & 0xFF) .
                   chr(($length >> 16) & 0xFF) .
                   chr(($length >> 8) & 0xFF) .
                   chr($length & 0xFF);
    }

    return $retval . $value;
}

// Path to jpeg file
$path = './phplogo.jpg';

// We need to check if theres any IPTC data in the jpeg image. If there is then
// bail out because we cannot embed any image that already has some IPTC data!
$image = getimagesize($path, $info);

if(isset($info['APP13']))
{
    die('Error: IPTC data found in source image, cannot continue');
}

// Set the IPTC tags
$iptc = array(
    '2#120' => 'Test image',
    '2#116' => 'Copyright 2008-2009, The PHP Group'
);

// Convert the IPTC tags into binary code
$data = '';

foreach($iptc as $tag => $string)
{
    $tag = substr($tag, 2);
    $data .= iptc_make_tag(2, $tag, $string);
}

// Embed the IPTC data
$content = iptcembed($data, $path);

// Write the new image data out to the file.
$fp = fopen($path, "wb");
fwrite($fp, $content);
fclose($fp);
?>

注释

Note:

此函数不需要 GD 图象库。


将二进制 IPTC 块解析为单个标记

  • ? iptcembed
  • jpeg2wbmp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将二进制 IPTC 块解析为单个标记

iptcparse

(PHP 4, PHP 5, PHP 7, PHP 8)

iptcparse — 将二进制 IPTC 块解析为单个标记

说明

iptcparse ( string $iptcblock ) : array

本函数将一个二进制的 » IPTC 块解析为单个的标记。

参数

iptcblock

二进制的 IPTC 块。

返回值

返回一个数组，用 tagmarker 作为索引，以其值为值。如果出错或未发现 IPTC 数据则返回 false。

范例

Example #1 iptcparse() used together with getimagesize()

<?php
$size = getimagesize('./test.jpg', $info);
if(isset($info['APP13']))
{
    $iptc = iptcparse($info['APP13']);
    var_dump($iptc);
}
?>

注释

Note:

此函数不需要 GD 图象库。


将 JPEG 图像文件转换为 WBMP 图像文件

  • ? iptcparse
  • png2wbmp ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将 JPEG 图像文件转换为 WBMP 图像文件

jpeg2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

jpeg2wbmp — 将 JPEG 图像文件转换为 WBMP 图像文件

说明

jpeg2wbmp ( string $jpegname , string $wbmpname , int $dest_height , int $dest_width , int $threshold ) : bool

将 JPEG 图像文件转换为 WBMP 图像文件。

参数

jpegname

JPEG 文件的路径。

wbmpname

目标 WBMP 文件的路径。

dest_height

目标图像高度。

dest_width

目标图像宽度。

threshold

阈值，在 0 和 8 之间（含）。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 jpeg2wbmp() 例子

<?php
// 目标 jpeg 的路径
$path = './test.jpg';

// 获取图像尺寸
$image = getimagesize($path);

// 转换图像
jpeg2wbmp($path, './test.wbmp', $image[1], $image[0], 5);
?>

注释

参见

  • png2wbmp() - 将 PNG 图像文件转换为 WBMP 图像文件


将 PNG 图像文件转换为 WBMP 图像文件

  • ? jpeg2wbmp
  • Gmagick ?
  • PHP Manual
  • GD 和图像处理 函数
  • 将 PNG 图像文件转换为 WBMP 图像文件

png2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

png2wbmp — 将 PNG 图像文件转换为 WBMP 图像文件

说明

png2wbmp ( string $pngname , string $wbmpname , int $dest_height , int $dest_width , int $threshold ) : bool

将名为 pngname 的 PNG 文件转换为 WBMP 格式，并存为 wbmpname。用 d_height 和 d_width 指定目标图像的高度和宽度。

参数

pngname

PNG 文件的路径。

wbmpname

目标 WBMP 文件的路径。

dest_height

目标图像的高度。

dest_width

目标图像的宽度。

threshold

阈值，在 0 到 8 之间（含）。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 png2wbmp() 例子

<?php
// Path to the target png
$path = './test.png';

// Get the image sizes
$image = getimagesize($path);

// Convert image
png2wbmp($path, './test.wbmp', $image[1], $image[0], 7);
?>

注释

参见

  • jpeg2wbmp() - 将 JPEG 图像文件转换为 WBMP 图像文件


Gmagick

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • 范例
  • Gmagick — The Gmagick class
    • Gmagick::addimage — Adds new image to Gmagick object image list
    • Gmagick::addnoiseimage — Adds random noise to the image
    • Gmagick::annotateimage — Annotates an image with text
    • Gmagick::blurimage — Adds blur filter to image
    • Gmagick::borderimage — Surrounds the image with a border
    • Gmagick::charcoalimage — Simulates a charcoal drawing
    • Gmagick::chopimage — Removes a region of an image and trims
    • Gmagick::clear — Clears all resources associated to Gmagick object
    • Gmagick::commentimage — Adds a comment to your image
    • Gmagick::compositeimage — Composite one image onto another
    • Gmagick::__construct — The Gmagick constructor
    • Gmagick::cropimage — Extracts a region of the image
    • Gmagick::cropthumbnailimage — Creates a crop thumbnail
    • Gmagick::current — The current purpose
    • Gmagick::cyclecolormapimage — Displaces an image's colormap
    • Gmagick::deconstructimages — Returns certain pixel differences between images
    • Gmagick::despeckleimage — The despeckleimage purpose
    • Gmagick::destroy — The destroy purpose
    • Gmagick::drawimage — Renders the GmagickDraw object on the current image
    • Gmagick::edgeimage — Enhance edges within the image
    • Gmagick::embossimage — Returns a grayscale image with a three-dimensional effect
    • Gmagick::enhanceimage — Improves the quality of a noisy image
    • Gmagick::equalizeimage — Equalizes the image histogram
    • Gmagick::flipimage — Creates a vertical mirror image
    • Gmagick::flopimage — The flopimage purpose
    • Gmagick::frameimage — Adds a simulated three-dimensional border
    • Gmagick::gammaimage — Gamma-corrects an image
    • Gmagick::getcopyright — Returns the GraphicsMagick API copyright as a string
    • Gmagick::getfilename — The filename associated with an image sequence
    • Gmagick::getimagebackgroundcolor — Returns the image background color
    • Gmagick::getimageblueprimary — Returns the chromaticy blue primary point
    • Gmagick::getimagebordercolor — Returns the image border color
    • Gmagick::getimagechanneldepth — Gets the depth for a particular image channel
    • Gmagick::getimagecolors — Returns the color of the specified colormap index
    • Gmagick::getimagecolorspace — Gets the image colorspace
    • Gmagick::getimagecompose — Returns the composite operator associated with the image
    • Gmagick::getimagedelay — Gets the image delay
    • Gmagick::getimagedepth — Gets the depth of the image
    • Gmagick::getimagedispose — Gets the image disposal method
    • Gmagick::getimageextrema — Gets the extrema for the image
    • Gmagick::getimagefilename — Returns the filename of a particular image in a sequence
    • Gmagick::getimageformat — Returns the format of a particular image in a sequence
    • Gmagick::getimagegamma — Gets the image gamma
    • Gmagick::getimagegreenprimary — Returns the chromaticy green primary point
    • Gmagick::getimageheight — Returns the image height
    • Gmagick::getimagehistogram — Gets the image histogram
    • Gmagick::getimageindex — Gets the index of the current active image
    • Gmagick::getimageinterlacescheme — Gets the image interlace scheme
    • Gmagick::getimageiterations — Gets the image iterations
    • Gmagick::getimagematte — Check if the image has a matte channel
    • Gmagick::getimagemattecolor — Returns the image matte color
    • Gmagick::getimageprofile — Returns the named image profile
    • Gmagick::getimageredprimary — Returns the chromaticity red primary point
    • Gmagick::getimagerenderingintent — Gets the image rendering intent
    • Gmagick::getimageresolution — Gets the image X and Y resolution
    • Gmagick::getimagescene — Gets the image scene
    • Gmagick::getimagesignature — Generates an SHA-256 message digest
    • Gmagick::getimagetype — Gets the potential image type
    • Gmagick::getimageunits — Gets the image units of resolution
    • Gmagick::getimagewhitepoint — Returns the chromaticity white point
    • Gmagick::getimagewidth — Returns the width of the image
    • Gmagick::getpackagename — Returns the GraphicsMagick package name
    • Gmagick::getquantumdepth — Returns the Gmagick quantum depth as a string
    • Gmagick::getreleasedate — Returns the GraphicsMagick release date as a string
    • Gmagick::getsamplingfactors — Gets the horizontal and vertical sampling factor
    • Gmagick::getsize — Returns the size associated with the Gmagick object
    • Gmagick::getversion — Returns the GraphicsMagick API version
    • Gmagick::hasnextimage — Checks if the object has more images
    • Gmagick::haspreviousimage — Checks if the object has a previous image
    • Gmagick::implodeimage — Creates a new image as a copy
    • Gmagick::labelimage — Adds a label to an image
    • Gmagick::levelimage — Adjusts the levels of an image
    • Gmagick::magnifyimage — Scales an image proportionally 2x
    • Gmagick::mapimage — Replaces the colors of an image with the closest color from a reference image
    • Gmagick::medianfilterimage — Applies a digital filter
    • Gmagick::minifyimage — Scales an image proportionally to half its size
    • Gmagick::modulateimage — Control the brightness, saturation, and hue
    • Gmagick::motionblurimage — Simulates motion blur
    • Gmagick::newimage — Creates a new image
    • Gmagick::nextimage — Moves to the next image
    • Gmagick::normalizeimage — Enhances the contrast of a color image
    • Gmagick::oilpaintimage — Simulates an oil painting
    • Gmagick::previousimage — Move to the previous image in the object
    • Gmagick::profileimage — Adds or removes a profile from an image
    • Gmagick::quantizeimage — Analyzes the colors within a reference image
    • Gmagick::quantizeimages — The quantizeimages purpose
    • Gmagick::queryfontmetrics — Returns an array representing the font metrics
    • Gmagick::queryfonts — Returns the configured fonts
    • Gmagick::queryformats — Returns formats supported by Gmagick
    • Gmagick::radialblurimage — Radial blurs an image
    • Gmagick::raiseimage — Creates a simulated 3d button-like effect
    • Gmagick::read — Reads image from filename
    • Gmagick::readimage — Reads image from filename
    • Gmagick::readimageblob — Reads image from a binary string
    • Gmagick::readimagefile — The readimagefile purpose
    • Gmagick::reducenoiseimage — Smooths the contours of an image
    • Gmagick::removeimage — Removes an image from the image list
    • Gmagick::removeimageprofile — Removes the named image profile and returns it
    • Gmagick::resampleimage — Resample image to desired resolution
    • Gmagick::resizeimage — Scales an image
    • Gmagick::rollimage — Offsets an image
    • Gmagick::rotateimage — Rotates an image
    • Gmagick::scaleimage — Scales the size of an image
    • Gmagick::separateimagechannel — Separates a channel from the image
    • Gmagick::setCompressionQuality — Sets the object's default compression quality
    • Gmagick::setfilename — Sets the filename before you read or write the image
    • Gmagick::setimagebackgroundcolor — Sets the image background color
    • Gmagick::setimageblueprimary — Sets the image chromaticity blue primary point
    • Gmagick::setimagebordercolor — Sets the image border color
    • Gmagick::setimagechanneldepth — Sets the depth of a particular image channel
    • Gmagick::setimagecolorspace — Sets the image colorspace
    • Gmagick::setimagecompose — Sets the image composite operator
    • Gmagick::setimagedelay — Sets the image delay
    • Gmagick::setimagedepth — Sets the image depth
    • Gmagick::setimagedispose — Sets the image disposal method
    • Gmagick::setimagefilename — Sets the filename of a particular image in a sequence
    • Gmagick::setimageformat — Sets the format of a particular image
    • Gmagick::setimagegamma — Sets the image gamma
    • Gmagick::setimagegreenprimary — Sets the image chromaticity green primary point
    • Gmagick::setimageindex — Set the iterator to the position in the image list specified with the index parameter
    • Gmagick::setimageinterlacescheme — Sets the interlace scheme of the image
    • Gmagick::setimageiterations — Sets the image iterations
    • Gmagick::setimageprofile — Adds a named profile to the Gmagick object
    • Gmagick::setimageredprimary — Sets the image chromaticity red primary point
    • Gmagick::setimagerenderingintent — Sets the image rendering intent
    • Gmagick::setimageresolution — Sets the image resolution
    • Gmagick::setimagescene — Sets the image scene
    • Gmagick::setimagetype — Sets the image type
    • Gmagick::setimageunits — Sets the image units of resolution
    • Gmagick::setimagewhitepoint — Sets the image chromaticity white point
    • Gmagick::setsamplingfactors — Sets the image sampling factors
    • Gmagick::setsize — Sets the size of the Gmagick object
    • Gmagick::shearimage — Creating a parallelogram
    • Gmagick::solarizeimage — Applies a solarizing effect to the image
    • Gmagick::spreadimage — Randomly displaces each pixel in a block
    • Gmagick::stripimage — Strips an image of all profiles and comments
    • Gmagick::swirlimage — Swirls the pixels about the center of the image
    • Gmagick::thumbnailimage — Changes the size of an image
    • Gmagick::trimimage — Remove edges from the image
    • Gmagick::write — 别名 Gmagick::writeimage
    • Gmagick::writeimage — Writes an image to the specified filename
  • GmagickDraw — The GmagickDraw class
    • GmagickDraw::annotate — Draws text on the image
    • GmagickDraw::arc — Draws an arc
    • GmagickDraw::bezier — Draws a bezier curve
    • GmagickDraw::ellipse — Draws an ellipse on the image
    • GmagickDraw::getfillcolor — Returns the fill color
    • GmagickDraw::getfillopacity — Returns the opacity used when drawing
    • GmagickDraw::getfont — Returns the font
    • GmagickDraw::getfontsize — Returns the font pointsize
    • GmagickDraw::getfontstyle — Returns the font style
    • GmagickDraw::getfontweight — Returns the font weight
    • GmagickDraw::getstrokecolor — Returns the color used for stroking object outlines
    • GmagickDraw::getstrokeopacity — Returns the opacity of stroked object outlines
    • GmagickDraw::getstrokewidth — Returns the width of the stroke used to draw object outlines
    • GmagickDraw::gettextdecoration — Returns the text decoration
    • GmagickDraw::gettextencoding — Returns the code set used for text annotations
    • GmagickDraw::line — The line purpose
    • GmagickDraw::point — Draws a point
    • GmagickDraw::polygon — Draws a polygon
    • GmagickDraw::polyline — Draws a polyline
    • GmagickDraw::rectangle — Draws a rectangle
    • GmagickDraw::rotate — Applies the specified rotation to the current coordinate space
    • GmagickDraw::roundrectangle — Draws a rounded rectangle
    • GmagickDraw::scale — Adjusts the scaling factor
    • GmagickDraw::setfillcolor — Sets the fill color to be used for drawing filled objects
    • GmagickDraw::setfillopacity — The setfillopacity purpose
    • GmagickDraw::setfont — Sets the fully-specified font to use when annotating with text
    • GmagickDraw::setfontsize — Sets the font pointsize to use when annotating with text
    • GmagickDraw::setfontstyle — Sets the font style to use when annotating with text
    • GmagickDraw::setfontweight — Sets the font weight
    • GmagickDraw::setstrokecolor — Sets the color used for stroking object outlines
    • GmagickDraw::setstrokeopacity — Specifies the opacity of stroked object outlines
    • GmagickDraw::setstrokewidth — Sets the width of the stroke used to draw object outlines
    • GmagickDraw::settextdecoration — Specifies a decoration
    • GmagickDraw::settextencoding — Specifies the text code set
  • GmagickPixel — The GmagickPixel class
    • GmagickPixel::__construct — The GmagickPixel constructor
    • GmagickPixel::getcolor — Returns the color
    • GmagickPixel::getcolorcount — Returns the color count associated with this color
    • GmagickPixel::getcolorvalue — Gets the normalized value of the provided color channel
    • GmagickPixel::setcolor — Sets the color
    • GmagickPixel::setcolorvalue — Sets the normalized value of one of the channels


简介

Gmagick is a php extension to create, modify and obtain meta information of images using the GraphicsMagick API.

GraphicsMagick prides itself as the swiss army knife of image processing. It works with over 88 major formats including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF, PNM, and TIFF.

Gmagick consists of a main Gmagick class, a GmagickDraw class which is in effect a drawing wand and a GmagickPixel class of which instances represent a single pixel of an image (color, opacity).


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Gmagick
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

This extension works best with GraphicsMagick version 1.4+ and PHP 5.1.3+. Gmagick should work with earlier versions up to GraphicsMagick 1.2.6 but some features and formats are not supported for these versions. Windows version of GraphicsMagick is available from the GraphicsMagick website. To read about the difference between ImageMagick and GraphicsMagick, check this out: » FAQ .


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/gmagick.

Note: The official name of this extension is gmagick.

For Windows, the build of the Gmagick extension is available » here


  • ? 安装
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 运行时配置

运行时配置

此扩展没有在 php.ini 中定义配置指令。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Colortype constants
Gmagick::COLOR_BLACK (int)
Black
Gmagick::COLOR_BLUE (int)
Blue
Gmagick::COLOR_CYAN (int)
Cyan
Gmagick::COLOR_GREEN (int)
Green
Gmagick::COLOR_RED (int)
Red
Gmagick::COLOR_YELLOW (int)
Yellow
Gmagick::COLOR_MAGENTA (int)
Magenta
Gmagick::COLOR_OPACITY (int)
Opacity
Gmagick::COLOR_ALPHA (int)
Alpha
Gmagick::COLOR_FUZZ (int)
Fuzz
Composite Operator Constants
Gmagick::COMPOSITE_DEFAULT (int)
The default composite operator
Gmagick::COMPOSITE_UNDEFINED (int)
Undefined composite operator
Gmagick::COMPOSITE_NO (int)
No composite operator defined
Gmagick::COMPOSITE_ADD (int)
The result of image + image
Gmagick::COMPOSITE_ATOP (int)
The result is the same shape as image, with composite image obscuring image where the image shapes overlap
Gmagick::COMPOSITE_BLEND (int)
Blends the image
Gmagick::COMPOSITE_BUMPMAP (int)
The same as COMPOSITE_MULTIPLY, except the source is converted to grayscale first.
Gmagick::COMPOSITE_CLEAR (int)
Makes the target image transparent
Gmagick::COMPOSITE_COLORBURN (int)
Darkens the destination image to reflect the source image
Gmagick::COMPOSITE_COLORDODGE (int)
Brightens the destination image to reflect the source image
Gmagick::COMPOSITE_COLORIZE (int)
Colorizes the target image using the composite image
Gmagick::COMPOSITE_COPYBLACK (int)
Copies black from the source to target
Gmagick::COMPOSITE_COPYBLUE (int)
Copies blue from the source to target
Gmagick::COMPOSITE_COPY (int)
Copies the source image on the target image
Gmagick::COMPOSITE_COPYCYAN (int)
Copies cyan from the source to target
Gmagick::COMPOSITE_COPYGREEN (int)
Copies green from the source to target
Gmagick::COMPOSITE_COPYMAGENTA (int)
Copies magenta from the source to target
Gmagick::COMPOSITE_COPYOPACITY (int)
Copies opacity from the source to target
Gmagick::COMPOSITE_COPYRED (int)
Copies red from the source to target
Gmagick::COMPOSITE_COPYYELLOW (int)
Copies yellow from the source to target
Gmagick::COMPOSITE_DARKEN (int)
Darkens the target image
Gmagick::COMPOSITE_DSTATOP (int)
The part of the destination lying inside of the source is composited over the source and replaces the destination
Gmagick::COMPOSITE_DST (int)
The target is left untouched
Gmagick::COMPOSITE_DSTIN (int)
The parts inside the source replace the target
Gmagick::COMPOSITE_DSTOUT (int)
The parts outside the source replace the target
Gmagick::COMPOSITE_DSTOVER (int)
Target replaces the source
Gmagick::COMPOSITE_DIFFERENCE (int)
Subtracts the darker of the two constituent colors from the lighter
Gmagick::COMPOSITE_DISPLACE (int)
Shifts target image pixels as defined by the source
Gmagick::COMPOSITE_DISSOLVE (int)
Dissolves the source in to the target
Gmagick::COMPOSITE_EXCLUSION (int)
Produces an effect similar to that of Gmagick::COMPOSITE_DIFFERENCE, but appears as lower contrast
Gmagick::COMPOSITE_HARDLIGHT (int)
Multiplies or screens the colors, dependent on the source color value
Gmagick::COMPOSITE_HUE (int)
Modifies the hue of the target as defined by source
Gmagick::COMPOSITE_IN (int)
Composites source into the target
Gmagick::COMPOSITE_LIGHTEN (int)
Lightens the target as defined by source
Gmagick::COMPOSITE_LUMINIZE (int)
Luminizes the target as defined by source
Gmagick::COMPOSITE_MINUS (int)
Subtracts the source from the target
Gmagick::COMPOSITE_MODULATE (int)
Modulates the target brightness, saturation and hue as defined by source
Gmagick::COMPOSITE_MULTIPLY (int)
Multiplies the target to the source
Gmagick::COMPOSITE_OUT (int)
Composites outer parts of the source on the target
Gmagick::COMPOSITE_OVER (int)
Composites source over the target
Gmagick::COMPOSITE_OVERLAY (int)
Overlays the source on the target
Gmagick::COMPOSITE_PLUS (int)
Adds the source to the target
Gmagick::COMPOSITE_REPLACE (int)
Replaces the target with the source
Gmagick::COMPOSITE_SATURATE (int)
Saturates the target as defined by the source
Gmagick::COMPOSITE_SCREEN (int)
The source and destination are complemented and then multiplied and then replace the destination
Gmagick::COMPOSITE_SOFTLIGHT (int)
Darkens or lightens the colors, dependent on the source
Gmagick::COMPOSITE_SRCATOP (int)
The part of the source lying inside of the destination is composited onto the destination
Gmagick::COMPOSITE_SRC (int)
The source is copied to the destination
Gmagick::COMPOSITE_SRCIN (int)
The part of the source lying inside of the destination replaces the destination
Gmagick::COMPOSITE_SRCOUT (int)
The part of the source lying outside of the destination replaces the destination
Gmagick::COMPOSITE_SRCOVER (int)
The source replaces the destination
Gmagick::COMPOSITE_SUBTRACT (int)
Subtract the colors in the source image from the destination image
Gmagick::COMPOSITE_THRESHOLD (int)
The source is composited on the target as defined by source threshold
Gmagick::COMPOSITE_XOR (int)
The part of the source that lies outside of the destination is combined with the part of the destination that lies outside of the source
Montage Mode constants
Gmagick::MONTAGEMODE_FRAME (int)
Gmagick::MONTAGEMODE_UNFRAME (int)
Gmagick::MONTAGEMODE_CONCATENATE (int)
Style constants
Gmagick::STYLE_NORMAL (int)
Gmagick::STYLE_ITALIC (int)
Gmagick::STYLE_OBLIQUE (int)
Gmagick::STYLE_ANY (int)
Filter constants
Gmagick::FILTER_UNDEFINED (int)
Gmagick::FILTER_POINT (int)
Gmagick::FILTER_BOX (int)
Gmagick::FILTER_TRIANGLE (int)
Gmagick::FILTER_HERMITE (int)
Gmagick::FILTER_HANNING (int)
Gmagick::FILTER_HAMMING (int)
Gmagick::FILTER_BLACKMAN (int)
Gmagick::FILTER_GAUSSIAN (int)
Gmagick::FILTER_QUADRATIC (int)
Gmagick::FILTER_CUBIC (int)
Gmagick::FILTER_CATROM (int)
Gmagick::FILTER_MITCHELL (int)
Gmagick::FILTER_LANCZOS (int)
Gmagick::FILTER_BESSEL (int)
Gmagick::FILTER_SINC (int)
Image type constants
Gmagick::IMGTYPE_UNDEFINED (int)
Gmagick::IMGTYPE_BILEVEL (int)
Gmagick::IMGTYPE_GRAYSCALE (int)
Gmagick::IMGTYPE_GRAYSCALEMATTE (int)
Gmagick::IMGTYPE_PALETTE (int)
Gmagick::IMGTYPE_PALETTEMATTE (int)
Gmagick::IMGTYPE_TRUECOLOR (int)
Gmagick::IMGTYPE_TRUECOLORMATTE (int)
Gmagick::IMGTYPE_COLORSEPARATION (int)
Gmagick::IMGTYPE_COLORSEPARATIONMATTE (int)
Gmagick::IMGTYPE_OPTIMIZE (int)
Resolution constants
Gmagick::RESOLUTION_UNDEFINED (int)
Gmagick::RESOLUTION_PIXELSPERINCH (int)
Gmagick::RESOLUTION_PIXELSPERCENTIMETER (int)
Compression constants
Gmagick::COMPRESSION_UNDEFINED (int)
Gmagick::COMPRESSION_NO (int)
Gmagick::COMPRESSION_BZIP (int)
Gmagick::COMPRESSION_FAX (int)
Gmagick::COMPRESSION_GROUP4 (int)
Gmagick::COMPRESSION_JPEG (int)
Gmagick::COMPRESSION_JPEG2000 (int)
Gmagick::COMPRESSION_LOSSLESSJPEG (int)
Gmagick::COMPRESSION_LZW (int)
Gmagick::COMPRESSION_RLE (int)
Gmagick::COMPRESSION_ZIP (int)
Paint constants
Gmagick::PAINT_POINT (int)
Gmagick::PAINT_REPLACE (int)
Gmagick::PAINT_FLOODFILL (int)
Gmagick::PAINT_FILLTOBORDER (int)
Gmagick::PAINT_RESET (int)
Gravity constants
Gmagick::GRAVITY_NORTHWEST (int)
Gmagick::GRAVITY_NORTH (int)
Gmagick::GRAVITY_NORTHEAST (int)
Gmagick::GRAVITY_WEST (int)
Gmagick::GRAVITY_CENTER (int)
Gmagick::GRAVITY_EAST (int)
Gmagick::GRAVITY_SOUTHWEST (int)
Gmagick::GRAVITY_SOUTH (int)
Gmagick::GRAVITY_SOUTHEAST (int)
Stretch constants
Gmagick::STRETCH_NORMAL (int)
Gmagick::STRETCH_ULTRACONDENSED (int)
Gmagick::STRETCH_CONDENSED (int)
Gmagick::STRETCH_SEMICONDENSED (int)
Gmagick::STRETCH_SEMIEXPANDED (int)
Gmagick::STRETCH_EXPANDED (int)
Gmagick::STRETCH_EXTRAEXPANDED (int)
Gmagick::STRETCH_ULTRAEXPANDED (int)
Gmagick::STRETCH_ANY (int)
Align constants
Gmagick::ALIGN_UNDEFINED (int)
Gmagick::ALIGN_LEFT (int)
Gmagick::ALIGN_CENTER (int)
Gmagick::ALIGN_RIGHT (int)
Decoration constants
Gmagick::DECORATION_NO (int)
Gmagick::DECORATION_UNDERLINE (int)
Gmagick::DECORATION_OVERLINE (int)
Gmagick::DECORATION_LINETROUGH (int)
Noise constants
Gmagick::NOISE_UNIFORM (int)
Gmagick::NOISE_GAUSSIAN (int)
Gmagick::NOISE_MULTIPLICATIVEGAUSSIAN (int)
Gmagick::NOISE_IMPULSE (int)
Gmagick::NOISE_LAPLACIAN (int)
Gmagick::NOISE_POISSON (int)
Channel constants
Gmagick::CHANNEL_UNDEFINED (int)
Gmagick::CHANNEL_RED (int)
Gmagick::CHANNEL_GRAY (int)
Gmagick::CHANNEL_CYAN (int)
Gmagick::CHANNEL_GREEN (int)
Gmagick::CHANNEL_MAGENTA (int)
Gmagick::CHANNEL_BLUE (int)
Gmagick::CHANNEL_YELLOW (int)
Gmagick::CHANNEL_ALPHA (int)
Gmagick::CHANNEL_OPACITY (int)
Gmagick::CHANNEL_MATTE (int)
Gmagick::CHANNEL_BLACK (int)
Gmagick::CHANNEL_INDEX (int)
Gmagick::CHANNEL_ALL (int)
Metric constants
Gmagick::METRIC_UNDEFINED (int)
Gmagick::METRIC_MEANABSOLUTEERROR (int)
Gmagick::METRIC_MEANSQUAREERROR (int)
Gmagick::METRIC_PEAKABSOLUTEERROR (int)
Gmagick::METRIC_PEAKSIGNALTONOISERATIO (int)
Gmagick::METRIC_ROOTMEANSQUAREDERROR (int)
Pixel constants
Gmagick::PIXEL_CHAR (int)
Gmagick::PIXEL_DOUBLE (int)
Gmagick::PIXEL_FLOAT (int)
Gmagick::PIXEL_INTEGER (int)
Gmagick::PIXEL_LONG (int)
Gmagick::PIXEL_QUANTUM (int)
Gmagick::PIXEL_SHORT (int)
Colorspace constants
Gmagick::COLORSPACE_UNDEFINED (int)
Gmagick::COLORSPACE_RGB (int)
Gmagick::COLORSPACE_GRAY (int)
Gmagick::COLORSPACE_TRANSPARENT (int)
Gmagick::COLORSPACE_OHTA (int)
Gmagick::COLORSPACE_LAB (int)
Gmagick::COLORSPACE_XYZ (int)
Gmagick::COLORSPACE_YCBCR (int)
Gmagick::COLORSPACE_YCC (int)
Gmagick::COLORSPACE_YIQ (int)
Gmagick::COLORSPACE_YPBPR (int)
Gmagick::COLORSPACE_YUV (int)
Gmagick::COLORSPACE_CMYK (int)
Gmagick::COLORSPACE_SRGB (int)
Gmagick::COLORSPACE_HSB (int)
Gmagick::COLORSPACE_HSL (int)
Gmagick::COLORSPACE_HWB (int)
Gmagick::COLORSPACE_REC601LUMA (int)
Gmagick::COLORSPACE_REC709LUMA (int)
Gmagick::COLORSPACE_LOG (int)
Virtual Pixel Method constants
Gmagick::VIRTUALPIXELMETHOD_UNDEFINED (int)
Gmagick::VIRTUALPIXELMETHOD_BACKGROUND (int)
Gmagick::VIRTUALPIXELMETHOD_CONSTANT (int)
Gmagick::VIRTUALPIXELMETHOD_EDGE (int)
Gmagick::VIRTUALPIXELMETHOD_MIRROR (int)
Gmagick::VIRTUALPIXELMETHOD_TILE (int)
Gmagick::VIRTUALPIXELMETHOD_TRANSPARENT (int)
Preview constants
Gmagick::PREVIEW_UNDEFINED (int)
Gmagick::PREVIEW_ROTATE (int)
Gmagick::PREVIEW_SHEAR (int)
Gmagick::PREVIEW_ROLL (int)
Gmagick::PREVIEW_HUE (int)
Gmagick::PREVIEW_SATURATION (int)
Gmagick::PREVIEW_BRIGHTNESS (int)
Gmagick::PREVIEW_GAMMA (int)
Gmagick::PREVIEW_SPIFF (int)
Gmagick::PREVIEW_DULL (int)
Gmagick::PREVIEW_GRAYSCALE (int)
Gmagick::PREVIEW_QUANTIZE (int)
Gmagick::PREVIEW_DESPECKLE (int)
Gmagick::PREVIEW_REDUCENOISE (int)
Gmagick::PREVIEW_ADDNOISE (int)
Gmagick::PREVIEW_SHARPEN (int)
Gmagick::PREVIEW_BLUR (int)
Gmagick::PREVIEW_THRESHOLD (int)
Gmagick::PREVIEW_EDGEDETECT (int)
Gmagick::PREVIEW_SPREAD (int)
Gmagick::PREVIEW_SOLARIZE (int)
Gmagick::PREVIEW_SHADE (int)
Gmagick::PREVIEW_RAISE (int)
Gmagick::PREVIEW_SEGMENT (int)
Gmagick::PREVIEW_SWIRL (int)
Gmagick::PREVIEW_IMPLODE (int)
Gmagick::PREVIEW_WAVE (int)
Gmagick::PREVIEW_OILPAINT (int)
Gmagick::PREVIEW_CHARCOALDRAWING (int)
Gmagick::PREVIEW_JPEG (int)
Rendering Intent constants
Gmagick::RENDERINGINTENT_UNDEFINED (int)
Gmagick::RENDERINGINTENT_SATURATION (int)
Gmagick::RENDERINGINTENT_PERCEPTUAL (int)
Gmagick::RENDERINGINTENT_ABSOLUTE (int)
Gmagick::RENDERINGINTENT_RELATIVE (int)
Fillrule constants
Gmagick::FILLRULE_UNDEFINED (int)
Gmagick::FILLRULE_EVENODD (int)
Gmagick::FILLRULE_NONZERO (int)
Pathunit constants
Gmagick::PATHUNITS_UNDEFINED (int)
Gmagick::PATHUNITS_USERSPACE (int)
Gmagick::PATHUNITS_USERSPACEONUSE (int)
Gmagick::PATHUNITS_OBJECTBOUNDINGBOX (int)
Linecap constants
Gmagick::LINECAP_UNDEFINED (int)
Gmagick::LINECAP_BUTT (int)
Gmagick::LINECAP_ROUND (int)
Gmagick::LINECAP_SQUARE (int)
Line Join constants
Gmagick::LINEJOIN_UNDEFINED (int)
Gmagick::LINEJOIN_MITER (int)
Gmagick::LINEJOIN_ROUND (int)
Gmagick::LINEJOIN_BEVEL (int)
Resourcetype constants
Gmagick::RESOURCETYPE_UNDEFINED (int)
Gmagick::RESOURCETYPE_AREA (int)
Gmagick::RESOURCETYPE_DISK (int)
Gmagick::RESOURCETYPE_FILE (int)
Gmagick::RESOURCETYPE_MAP (int)
Gmagick::RESOURCETYPE_MEMORY (int)
Orientation constants
Gmagick::ORIENTATION_UNDEFINED (int)
Gmagick::ORIENTATION_TOPLEFT (int)
Gmagick::ORIENTATION_TOPRIGHT (int)
Gmagick::ORIENTATION_BOTTOMRIGHT (int)
Gmagick::ORIENTATION_BOTTOMLEFT (int)
Gmagick::ORIENTATION_LEFTTOP (int)
Gmagick::ORIENTATION_RIGHTTOP (int)
Gmagick::ORIENTATION_RIGHTBOTTOM (int)
Gmagick::ORIENTATION_LEFTBOTTOM (int)


范例

The following shows some common Gmagick image operations.

Example #1 Gmagick Example

<?php
//Instantiate a new Gmagick object
$image = new Gmagick('example.jpg');

//Make thumbnail from image loaded. 0 for either axes preserves aspect ratio
$image->thumbnailimage(100, 0);

//Create a border around the image, then simulate how the image will look like as an oil painting
//Notice the chaining of mutator methods which is supported in gmagick
$image->borderimage("yellow", 8, 8)->oilpaintimage(0.3);

//Write the current image at the current state to a file
$image->write('example_thumbnail.jpg');
?>


The Gmagick class

(PECL gmagick >= Unknown)

简介

类摘要

Gmagick {
/* 方法 */
public addimage ( Gmagick $source ) : Gmagick
public addnoiseimage ( int $noise_type ) : Gmagick
public annotateimage ( GmagickDraw $GmagickDraw , float $x , float $y , float $angle , string $text ) : Gmagick
public blurimage ( float $radius , float $sigma , int $channel = ? ) : Gmagick
public borderimage ( GmagickPixel $color , int $width , int $height ) : Gmagick
public charcoalimage ( float $radius , float $sigma ) : Gmagick
public chopimage ( int $width , int $height , int $x , int $y ) : Gmagick
public clear ( ) : Gmagick
public commentimage ( string $comment ) : Gmagick
public compositeimage ( Gmagick $source , int $COMPOSE , int $x , int $y ) : Gmagick
public __construct ( string $filename = ? )
public cropimage ( int $width , int $height , int $x , int $y ) : Gmagick
public cropthumbnailimage ( int $width , int $height ) : Gmagick
public current ( ) : Gmagick
public cyclecolormapimage ( int $displace ) : Gmagick
public deconstructimages ( ) : Gmagick
public despeckleimage ( ) : Gmagick
public destroy ( ) : bool
public drawimage ( GmagickDraw $GmagickDraw ) : Gmagick
public edgeimage ( float $radius ) : Gmagick
public embossimage ( float $radius , float $sigma ) : Gmagick
public enhanceimage ( ) : Gmagick
public equalizeimage ( ) : Gmagick
public flipimage ( ) : Gmagick
public flopimage ( ) : Gmagick
public frameimage ( GmagickPixel $color , int $width , int $height , int $inner_bevel , int $outer_bevel ) : Gmagick
public gammaimage ( float $gamma ) : Gmagick
public getcopyright ( ) : string
public getfilename ( ) : string
public getimagebackgroundcolor ( ) : GmagickPixel
public getimageblueprimary ( ) : array
public getimagebordercolor ( ) : GmagickPixel
public getimagechanneldepth ( int $channel_type ) : int
public getimagecolors ( ) : int
public getimagecolorspace ( ) : int
public getimagecompose ( ) : int
public getimagedelay ( ) : int
public getimagedepth ( ) : int
public getimagedispose ( ) : int
public getimageextrema ( ) : array
public getimagefilename ( ) : string
public getimageformat ( ) : string
public getimagegamma ( ) : float
public getimagegreenprimary ( ) : array
public getimageheight ( ) : int
public getimagehistogram ( ) : array
public getimageindex ( ) : int
public getimageinterlacescheme ( ) : int
public getimageiterations ( ) : int
public getimagematte ( ) : int
public getimagemattecolor ( ) : GmagickPixel
public getimageprofile ( string $name ) : string
public getimageredprimary ( ) : array
public getimagerenderingintent ( ) : int
public getimageresolution ( ) : array
public getimagescene ( ) : int
public getimagesignature ( ) : string
public getimagetype ( ) : int
public getimageunits ( ) : int
public getimagewhitepoint ( ) : array
public getimagewidth ( ) : int
public getpackagename ( ) : string
public getquantumdepth ( ) : array
public getreleasedate ( ) : string
public getsamplingfactors ( ) : array
public getsize ( ) : array
public getversion ( ) : array
public hasnextimage ( ) : mixed
public haspreviousimage ( ) : mixed
public implodeimage ( float $radius ) : mixed
public labelimage ( string $label ) : mixed
public levelimage ( float $blackPoint , float $gamma , float $whitePoint , int $channel = Gmagick::CHANNEL_DEFAULT ) : mixed
public magnifyimage ( ) : mixed
public mapimage ( gmagick $gmagick , bool $dither ) : Gmagick
public medianfilterimage ( float $radius ) : void
public minifyimage ( ) : Gmagick
public modulateimage ( float $brightness , float $saturation , float $hue ) : Gmagick
public motionblurimage ( float $radius , float $sigma , float $angle ) : Gmagick
public newimage ( int $width , int $height , string $background , string $format = ? ) : Gmagick
public nextimage ( ) : bool
public normalizeimage ( int $channel = ? ) : Gmagick
public oilpaintimage ( float $radius ) : Gmagick
public previousimage ( ) : bool
public profileimage ( string $name , string $profile ) : Gmagick
public quantizeimage ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError ) : Gmagick
public quantizeimages ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError ) : Gmagick
public queryfontmetrics ( GmagickDraw $draw , string $text ) : array
public queryfonts ( string $pattern = "*" ) : array
public queryformats ( string $pattern = "*" ) : array
public radialblurimage ( float $angle , int $channel = Gmagick::CHANNEL_DEFAULT ) : Gmagick
public raiseimage ( int $width , int $height , int $x , int $y , bool $raise ) : Gmagick
public read ( string $filename ) : Gmagick
public readimage ( string $filename ) : Gmagick
public readimageblob ( string $imageContents , string $filename = ? ) : Gmagick
public readimagefile ( resource $fp , string $filename = ? ) : Gmagick
public reducenoiseimage ( float $radius ) : Gmagick
public removeimage ( ) : Gmagick
public removeimageprofile ( string $name ) : string
public resampleimage ( float $xResolution , float $yResolution , int $filter , float $blur ) : Gmagick
public resizeimage ( int $width , int $height , int $filter , float $blur , bool $fit = false ) : Gmagick
public rollimage ( int $x , int $y ) : Gmagick
public rotateimage ( mixed $color , float $degrees ) : Gmagick
public scaleimage ( int $width , int $height , bool $fit = false ) : Gmagick
public separateimagechannel ( int $channel ) : Gmagick
setCompressionQuality ( int $quality = 75 ) : Gmagick
public setfilename ( string $filename ) : Gmagick
public setimagebackgroundcolor ( GmagickPixel $color ) : Gmagick
public setimageblueprimary ( float $x , float $y ) : Gmagick
public setimagebordercolor ( GmagickPixel $color ) : Gmagick
public setimagechanneldepth ( int $channel , int $depth ) : Gmagick
public setimagecolorspace ( int $colorspace ) : Gmagick
public setimagecompose ( int $composite ) : Gmagick
public setimagedelay ( int $delay ) : Gmagick
public setimagedepth ( int $depth ) : Gmagick
public setimagedispose ( int $disposeType ) : Gmagick
public setimagefilename ( string $filename ) : Gmagick
public setimageformat ( string $imageFormat ) : Gmagick
public setimagegamma ( float $gamma ) : Gmagick
public setimagegreenprimary ( float $x , float $y ) : Gmagick
public setimageindex ( int $index ) : Gmagick
public setimageinterlacescheme ( int $interlace ) : Gmagick
public setimageiterations ( int $iterations ) : Gmagick
public setimageprofile ( string $name , string $profile ) : Gmagick
public setimageredprimary ( float $x , float $y ) : Gmagick
public setimagerenderingintent ( int $rendering_intent ) : Gmagick
public setimageresolution ( float $xResolution , float $yResolution ) : Gmagick
public setimagescene ( int $scene ) : Gmagick
public setimagetype ( int $imgType ) : Gmagick
public setimageunits ( int $resolution ) : Gmagick
public setimagewhitepoint ( float $x , float $y ) : Gmagick
public setsamplingfactors ( array $factors ) : Gmagick
public setsize ( int $columns , int $rows ) : Gmagick
public shearimage ( mixed $color , float $xShear , float $yShear ) : Gmagick
public solarizeimage ( int $threshold ) : Gmagick
public spreadimage ( float $radius ) : Gmagick
public stripimage ( ) : Gmagick
public swirlimage ( float $degrees ) : Gmagick
public thumbnailimage ( int $width , int $height , bool $fit = false ) : Gmagick
public trimimage ( float $fuzz ) : Gmagick
public writeimage ( string $filename , bool $all_frames = false ) : Gmagick
}

Table of Contents

  • Gmagick::addimage — Adds new image to Gmagick object image list
  • Gmagick::addnoiseimage — Adds random noise to the image
  • Gmagick::annotateimage — Annotates an image with text
  • Gmagick::blurimage — Adds blur filter to image
  • Gmagick::borderimage — Surrounds the image with a border
  • Gmagick::charcoalimage — Simulates a charcoal drawing
  • Gmagick::chopimage — Removes a region of an image and trims
  • Gmagick::clear — Clears all resources associated to Gmagick object
  • Gmagick::commentimage — Adds a comment to your image
  • Gmagick::compositeimage — Composite one image onto another
  • Gmagick::__construct — The Gmagick constructor
  • Gmagick::cropimage — Extracts a region of the image
  • Gmagick::cropthumbnailimage — Creates a crop thumbnail
  • Gmagick::current — The current purpose
  • Gmagick::cyclecolormapimage — Displaces an image's colormap
  • Gmagick::deconstructimages — Returns certain pixel differences between images
  • Gmagick::despeckleimage — The despeckleimage purpose
  • Gmagick::destroy — The destroy purpose
  • Gmagick::drawimage — Renders the GmagickDraw object on the current image
  • Gmagick::edgeimage — Enhance edges within the image
  • Gmagick::embossimage — Returns a grayscale image with a three-dimensional effect
  • Gmagick::enhanceimage — Improves the quality of a noisy image
  • Gmagick::equalizeimage — Equalizes the image histogram
  • Gmagick::flipimage — Creates a vertical mirror image
  • Gmagick::flopimage — The flopimage purpose
  • Gmagick::frameimage — Adds a simulated three-dimensional border
  • Gmagick::gammaimage — Gamma-corrects an image
  • Gmagick::getcopyright — Returns the GraphicsMagick API copyright as a string
  • Gmagick::getfilename — The filename associated with an image sequence
  • Gmagick::getimagebackgroundcolor — Returns the image background color
  • Gmagick::getimageblueprimary — Returns the chromaticy blue primary point
  • Gmagick::getimagebordercolor — Returns the image border color
  • Gmagick::getimagechanneldepth — Gets the depth for a particular image channel
  • Gmagick::getimagecolors — Returns the color of the specified colormap index
  • Gmagick::getimagecolorspace — Gets the image colorspace
  • Gmagick::getimagecompose — Returns the composite operator associated with the image
  • Gmagick::getimagedelay — Gets the image delay
  • Gmagick::getimagedepth — Gets the depth of the image
  • Gmagick::getimagedispose — Gets the image disposal method
  • Gmagick::getimageextrema — Gets the extrema for the image
  • Gmagick::getimagefilename — Returns the filename of a particular image in a sequence
  • Gmagick::getimageformat — Returns the format of a particular image in a sequence
  • Gmagick::getimagegamma — Gets the image gamma
  • Gmagick::getimagegreenprimary — Returns the chromaticy green primary point
  • Gmagick::getimageheight — Returns the image height
  • Gmagick::getimagehistogram — Gets the image histogram
  • Gmagick::getimageindex — Gets the index of the current active image
  • Gmagick::getimageinterlacescheme — Gets the image interlace scheme
  • Gmagick::getimageiterations — Gets the image iterations
  • Gmagick::getimagematte — Check if the image has a matte channel
  • Gmagick::getimagemattecolor — Returns the image matte color
  • Gmagick::getimageprofile — Returns the named image profile
  • Gmagick::getimageredprimary — Returns the chromaticity red primary point
  • Gmagick::getimagerenderingintent — Gets the image rendering intent
  • Gmagick::getimageresolution — Gets the image X and Y resolution
  • Gmagick::getimagescene — Gets the image scene
  • Gmagick::getimagesignature — Generates an SHA-256 message digest
  • Gmagick::getimagetype — Gets the potential image type
  • Gmagick::getimageunits — Gets the image units of resolution
  • Gmagick::getimagewhitepoint — Returns the chromaticity white point
  • Gmagick::getimagewidth — Returns the width of the image
  • Gmagick::getpackagename — Returns the GraphicsMagick package name
  • Gmagick::getquantumdepth — Returns the Gmagick quantum depth as a string
  • Gmagick::getreleasedate — Returns the GraphicsMagick release date as a string
  • Gmagick::getsamplingfactors — Gets the horizontal and vertical sampling factor
  • Gmagick::getsize — Returns the size associated with the Gmagick object
  • Gmagick::getversion — Returns the GraphicsMagick API version
  • Gmagick::hasnextimage — Checks if the object has more images
  • Gmagick::haspreviousimage — Checks if the object has a previous image
  • Gmagick::implodeimage — Creates a new image as a copy
  • Gmagick::labelimage — Adds a label to an image
  • Gmagick::levelimage — Adjusts the levels of an image
  • Gmagick::magnifyimage — Scales an image proportionally 2x
  • Gmagick::mapimage — Replaces the colors of an image with the closest color from a reference image
  • Gmagick::medianfilterimage — Applies a digital filter
  • Gmagick::minifyimage — Scales an image proportionally to half its size
  • Gmagick::modulateimage — Control the brightness, saturation, and hue
  • Gmagick::motionblurimage — Simulates motion blur
  • Gmagick::newimage — Creates a new image
  • Gmagick::nextimage — Moves to the next image
  • Gmagick::normalizeimage — Enhances the contrast of a color image
  • Gmagick::oilpaintimage — Simulates an oil painting
  • Gmagick::previousimage — Move to the previous image in the object
  • Gmagick::profileimage — Adds or removes a profile from an image
  • Gmagick::quantizeimage — Analyzes the colors within a reference image
  • Gmagick::quantizeimages — The quantizeimages purpose
  • Gmagick::queryfontmetrics — Returns an array representing the font metrics
  • Gmagick::queryfonts — Returns the configured fonts
  • Gmagick::queryformats — Returns formats supported by Gmagick
  • Gmagick::radialblurimage — Radial blurs an image
  • Gmagick::raiseimage — Creates a simulated 3d button-like effect
  • Gmagick::read — Reads image from filename
  • Gmagick::readimage — Reads image from filename
  • Gmagick::readimageblob — Reads image from a binary string
  • Gmagick::readimagefile — The readimagefile purpose
  • Gmagick::reducenoiseimage — Smooths the contours of an image
  • Gmagick::removeimage — Removes an image from the image list
  • Gmagick::removeimageprofile — Removes the named image profile and returns it
  • Gmagick::resampleimage — Resample image to desired resolution
  • Gmagick::resizeimage — Scales an image
  • Gmagick::rollimage — Offsets an image
  • Gmagick::rotateimage — Rotates an image
  • Gmagick::scaleimage — Scales the size of an image
  • Gmagick::separateimagechannel — Separates a channel from the image
  • Gmagick::setCompressionQuality — Sets the object's default compression quality
  • Gmagick::setfilename — Sets the filename before you read or write the image
  • Gmagick::setimagebackgroundcolor — Sets the image background color
  • Gmagick::setimageblueprimary — Sets the image chromaticity blue primary point
  • Gmagick::setimagebordercolor — Sets the image border color
  • Gmagick::setimagechanneldepth — Sets the depth of a particular image channel
  • Gmagick::setimagecolorspace — Sets the image colorspace
  • Gmagick::setimagecompose — Sets the image composite operator
  • Gmagick::setimagedelay — Sets the image delay
  • Gmagick::setimagedepth — Sets the image depth
  • Gmagick::setimagedispose — Sets the image disposal method
  • Gmagick::setimagefilename — Sets the filename of a particular image in a sequence
  • Gmagick::setimageformat — Sets the format of a particular image
  • Gmagick::setimagegamma — Sets the image gamma
  • Gmagick::setimagegreenprimary — Sets the image chromaticity green primary point
  • Gmagick::setimageindex — Set the iterator to the position in the image list specified with the index parameter
  • Gmagick::setimageinterlacescheme — Sets the interlace scheme of the image
  • Gmagick::setimageiterations — Sets the image iterations
  • Gmagick::setimageprofile — Adds a named profile to the Gmagick object
  • Gmagick::setimageredprimary — Sets the image chromaticity red primary point
  • Gmagick::setimagerenderingintent — Sets the image rendering intent
  • Gmagick::setimageresolution — Sets the image resolution
  • Gmagick::setimagescene — Sets the image scene
  • Gmagick::setimagetype — Sets the image type
  • Gmagick::setimageunits — Sets the image units of resolution
  • Gmagick::setimagewhitepoint — Sets the image chromaticity white point
  • Gmagick::setsamplingfactors — Sets the image sampling factors
  • Gmagick::setsize — Sets the size of the Gmagick object
  • Gmagick::shearimage — Creating a parallelogram
  • Gmagick::solarizeimage — Applies a solarizing effect to the image
  • Gmagick::spreadimage — Randomly displaces each pixel in a block
  • Gmagick::stripimage — Strips an image of all profiles and comments
  • Gmagick::swirlimage — Swirls the pixels about the center of the image
  • Gmagick::thumbnailimage — Changes the size of an image
  • Gmagick::trimimage — Remove edges from the image
  • Gmagick::write — 别名 Gmagick::writeimage
  • Gmagick::writeimage — Writes an image to the specified filename


Adds new image to Gmagick object image list

  • ? Gmagick
  • Gmagick::addnoiseimage ?
  • PHP Manual
  • Gmagick
  • Adds new image to Gmagick object image list

Gmagick::addimage

(PECL gmagick >= Unknown)

Gmagick::addimage — Adds new image to Gmagick object image list

说明

public Gmagick::addimage ( Gmagick $source ) : Gmagick

Adds new image to Gmagick object from the current position of the source object. After the operation iterator position is moved at the end of the list.

参数

source

The source Gmagick object

返回值

The Gmagick object with image added

错误／异常

错误时抛出 GmagickException。


Adds random noise to the image

  • ? Gmagick::addimage
  • Gmagick::annotateimage ?
  • PHP Manual
  • Gmagick
  • Adds random noise to the image

Gmagick::addnoiseimage

(PECL gmagick >= Unknown)

Gmagick::addnoiseimage — Adds random noise to the image

说明

public Gmagick::addnoiseimage ( int $noise_type ) : Gmagick

Adds random noise to the image.

参数

noise_type

The type of the noise. Refer to this list of noise constants.

返回值

The Gmagick object with noise added.

错误／异常

错误时抛出 GmagickException。


Annotates an image with text

  • ? Gmagick::addnoiseimage
  • Gmagick::blurimage ?
  • PHP Manual
  • Gmagick
  • Annotates an image with text

Gmagick::annotateimage

(PECL gmagick >= Unknown)

Gmagick::annotateimage — Annotates an image with text

说明

public Gmagick::annotateimage ( GmagickDraw $GmagickDraw , float $x , float $y , float $angle , string $text ) : Gmagick

Annotates an image with text.

参数

GmagickDraw

The GmagickDraw object that contains settings for drawing the text

x

Horizontal offset in pixels to the left of text

y

Vertical offset in pixels to the baseline of text

angle

The angle at which to write the text

text

The string to draw

返回值

The Gmagick object with annotation made.

错误／异常

错误时抛出 GmagickException。


Adds blur filter to image

  • ? Gmagick::annotateimage
  • Gmagick::borderimage ?
  • PHP Manual
  • Gmagick
  • Adds blur filter to image

Gmagick::blurimage

(PECL gmagick >= Unknown)

Gmagick::blurimage — Adds blur filter to image

说明

public Gmagick::blurimage ( float $radius , float $sigma , int $channel = ? ) : Gmagick

Adds blur filter to image.

参数

radius

Blur radius

sigma

Standard deviation

返回值

The blurred Gmagick object

错误／异常

错误时抛出 GmagickException。


Surrounds the image with a border

  • ? Gmagick::blurimage
  • Gmagick::charcoalimage ?
  • PHP Manual
  • Gmagick
  • Surrounds the image with a border

Gmagick::borderimage

(PECL gmagick >= Unknown)

Gmagick::borderimage — Surrounds the image with a border

说明

public Gmagick::borderimage ( GmagickPixel $color , int $width , int $height ) : Gmagick

Surrounds the image with a border of the color defined by the bordercolor GmagickPixel object or a color string.

参数

color

GmagickPixel object or a string containing the border color

width

Border width

height

Border height

返回值

The Gmagick object with border defined

错误／异常

错误时抛出 GmagickException。


Simulates a charcoal drawing

  • ? Gmagick::borderimage
  • Gmagick::chopimage ?
  • PHP Manual
  • Gmagick
  • Simulates a charcoal drawing

Gmagick::charcoalimage

(PECL gmagick >= Unknown)

Gmagick::charcoalimage — Simulates a charcoal drawing

说明

public Gmagick::charcoalimage ( float $radius , float $sigma ) : Gmagick

Simulates a charcoal drawing.

参数

radius

The radius of the Gaussian, in pixels, not counting the center pixel

sigma

The standard deviation of the Gaussian, in pixels

返回值

The Gmagick object with charcoal simulation

错误／异常

错误时抛出 GmagickException。


Removes a region of an image and trims

  • ? Gmagick::charcoalimage
  • Gmagick::clear ?
  • PHP Manual
  • Gmagick
  • Removes a region of an image and trims

Gmagick::chopimage

(PECL gmagick >= Unknown)

Gmagick::chopimage — Removes a region of an image and trims

说明

public Gmagick::chopimage ( int $width , int $height , int $x , int $y ) : Gmagick

Removes a region of an image and collapses the image to occupy the removed portion.

参数

width

Width of the chopped area

height

Height of the chopped area

x

X origo of the chopped area

y

Y origo of the chopped area

返回值

The chopped Gmagick object

错误／异常

错误时抛出 GmagickException。


Clears all resources associated to Gmagick object

  • ? Gmagick::chopimage
  • Gmagick::commentimage ?
  • PHP Manual
  • Gmagick
  • Clears all resources associated to Gmagick object

Gmagick::clear

(PECL gmagick >= Unknown)

Gmagick::clear — Clears all resources associated to Gmagick object

说明

public Gmagick::clear ( ) : Gmagick

Clears all resources associated to Gmagick object

参数

此函数没有参数。

返回值

The cleared Gmagick object

错误／异常

错误时抛出 GmagickException。


Adds a comment to your image

  • ? Gmagick::clear
  • Gmagick::compositeimage ?
  • PHP Manual
  • Gmagick
  • Adds a comment to your image

Gmagick::commentimage

(PECL gmagick >= Unknown)

Gmagick::commentimage — Adds a comment to your image

说明

public Gmagick::commentimage ( string $comment ) : Gmagick

Adds a comment to your image.

参数

comment

The comment to add

返回值

The Gmagick object with comment added.

错误／异常

错误时抛出 GmagickException。


Composite one image onto another

  • ? Gmagick::commentimage
  • Gmagick::__construct ?
  • PHP Manual
  • Gmagick
  • Composite one image onto another

Gmagick::compositeimage

(PECL gmagick >= Unknown)

Gmagick::compositeimage — Composite one image onto another

说明

public Gmagick::compositeimage ( Gmagick $source , int $COMPOSE , int $x , int $y ) : Gmagick

Composite one image onto another at the specified offset.

参数

source

Gmagick object which holds the composite image

compose

Composite operator.

x

The column offset of the composited image

y

The row offset of the composited image

返回值

The Gmagick object with compositions.

错误／异常

错误时抛出 GmagickException。


The Gmagick constructor

  • ? Gmagick::compositeimage
  • Gmagick::cropimage ?
  • PHP Manual
  • Gmagick
  • The Gmagick constructor

Gmagick::__construct

(PECL gmagick >= Unknown)

Gmagick::__construct — The Gmagick constructor

说明

public Gmagick::__construct ( string $filename = ? )

The Gmagick constructor.

参数

filename

The path to an image to load or array of paths

返回值

Returns a new Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Extracts a region of the image

  • ? Gmagick::__construct
  • Gmagick::cropthumbnailimage ?
  • PHP Manual
  • Gmagick
  • Extracts a region of the image

Gmagick::cropimage

(PECL gmagick >= Unknown)

Gmagick::cropimage — Extracts a region of the image

说明

public Gmagick::cropimage ( int $width , int $height , int $x , int $y ) : Gmagick

Extracts a region of the image.

参数

width

The width of the crop

height

The height of the crop

x

The X coordinate of the cropped region's top left corner

y

The Y coordinate of the cropped region's top left corner

返回值

The cropped Gmagick object

错误／异常

错误时抛出 GmagickException。


Creates a crop thumbnail

  • ? Gmagick::cropimage
  • Gmagick::current ?
  • PHP Manual
  • Gmagick
  • Creates a crop thumbnail

Gmagick::cropthumbnailimage

(PECL gmagick >= Unknown)

Gmagick::cropthumbnailimage — Creates a crop thumbnail

说明

public Gmagick::cropthumbnailimage ( int $width , int $height ) : Gmagick

Creates a fixed size thumbnail by first scaling the image down and cropping a specified area from the center.

参数

width

The width of the thumbnail

height

The Height of the thumbnail

返回值

The cropped Gmagick object

错误／异常

错误时抛出 GmagickException。


The current purpose

  • ? Gmagick::cropthumbnailimage
  • Gmagick::cyclecolormapimage ?
  • PHP Manual
  • Gmagick
  • The current purpose

Gmagick::current

(PECL gmagick >= Unknown)

Gmagick::current — The current purpose

说明

public Gmagick::current ( ) : Gmagick

Returns reference to the current gmagick object with image pointer at the correct sequence.

参数

此函数没有参数。

返回值

Returns self on success.

错误／异常

错误时抛出 GmagickException。


Displaces an image's colormap

  • ? Gmagick::current
  • Gmagick::deconstructimages ?
  • PHP Manual
  • Gmagick
  • Displaces an image's colormap

Gmagick::cyclecolormapimage

(PECL gmagick >= Unknown)

Gmagick::cyclecolormapimage — Displaces an image's colormap

说明

public Gmagick::cyclecolormapimage ( int $displace ) : Gmagick

Displaces an image's colormap by a given number of positions. If you cycle the colormap a number of times you can produce a psychedelic effect.

参数

displace

The amount to displace the colormap.

返回值

Returns self on success.

错误／异常

错误时抛出 GmagickException。


Returns certain pixel differences between images

  • ? Gmagick::cyclecolormapimage
  • Gmagick::despeckleimage ?
  • PHP Manual
  • Gmagick
  • Returns certain pixel differences between images

Gmagick::deconstructimages

(PECL gmagick >= Unknown)

Gmagick::deconstructimages — Returns certain pixel differences between images

说明

public Gmagick::deconstructimages ( ) : Gmagick

Compares each image with the next in a sequence and returns the maximum bounding region of any pixel differences it discovers.

参数

此函数没有参数。

返回值

Returns a new Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


The despeckleimage purpose

  • ? Gmagick::deconstructimages
  • Gmagick::destroy ?
  • PHP Manual
  • Gmagick
  • The despeckleimage purpose

Gmagick::despeckleimage

(PECL gmagick >= Unknown)

Gmagick::despeckleimage — The despeckleimage purpose

说明

public Gmagick::despeckleimage ( ) : Gmagick

Reduces the speckle noise in an image while preserving the edges of the original image.

参数

此函数没有参数。

返回值

The despeckled Gmagick object on success.

错误／异常

错误时抛出 GmagickException。

范例

Example #1 Gmagick::despeckleimage() example

<?php
/* ... */
?>

以上例程的输出类似于：

...

参见

  • Classname::Method()


The destroy purpose

  • ? Gmagick::despeckleimage
  • Gmagick::drawimage ?
  • PHP Manual
  • Gmagick
  • The destroy purpose

Gmagick::destroy

(PECL gmagick >= Unknown)

Gmagick::destroy — The destroy purpose

说明

public Gmagick::destroy ( ) : bool

Destroys the Gmagick object and frees all resources associated with it

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

错误时抛出 GmagickException。


Renders the GmagickDraw object on the current image

  • ? Gmagick::destroy
  • Gmagick::edgeimage ?
  • PHP Manual
  • Gmagick
  • Renders the GmagickDraw object on the current image

Gmagick::drawimage

(PECL gmagick >= Unknown)

Gmagick::drawimage — Renders the GmagickDraw object on the current image

说明

public Gmagick::drawimage ( GmagickDraw $GmagickDraw ) : Gmagick

Renders the GmagickDraw object on the current image

参数

GmagickDraw

The drawing operations to render on the image.

返回值

The drawn Gmagick object

错误／异常

错误时抛出 GmagickException。


Enhance edges within the image

  • ? Gmagick::drawimage
  • Gmagick::embossimage ?
  • PHP Manual
  • Gmagick
  • Enhance edges within the image

Gmagick::edgeimage

(PECL gmagick >= Unknown)

Gmagick::edgeimage — Enhance edges within the image

说明

public Gmagick::edgeimage ( float $radius ) : Gmagick

Enhance edges within the image with a convolution filter of the given radius. Use radius 0 and it will be auto-selected.

参数

radius

The radius of the operation.

返回值

The Gmagick object with edges enhanced.

错误／异常

错误时抛出 GmagickException。


Returns a grayscale image with a three-dimensional effect

  • ? Gmagick::edgeimage
  • Gmagick::enhanceimage ?
  • PHP Manual
  • Gmagick
  • Returns a grayscale image with a three-dimensional effect

Gmagick::embossimage

(PECL gmagick >= Unknown)

Gmagick::embossimage — Returns a grayscale image with a three-dimensional effect

说明

public Gmagick::embossimage ( float $radius , float $sigma ) : Gmagick

Returns a grayscale image with a three-dimensional effect. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and it will choose a suitable radius for you.

参数

radius

The radius of the effect

sigma

The sigma of the effect

返回值

The embossed Gmagick object.

错误／异常

错误时抛出 GmagickException。


Improves the quality of a noisy image

  • ? Gmagick::embossimage
  • Gmagick::equalizeimage ?
  • PHP Manual
  • Gmagick
  • Improves the quality of a noisy image

Gmagick::enhanceimage

(PECL gmagick >= Unknown)

Gmagick::enhanceimage — Improves the quality of a noisy image

说明

public Gmagick::enhanceimage ( ) : Gmagick

Applies a digital filter that improves the quality of a noisy image.

返回值

The enhanced Gmagick object.

错误／异常

错误时抛出 GmagickException。


Equalizes the image histogram

  • ? Gmagick::enhanceimage
  • Gmagick::flipimage ?
  • PHP Manual
  • Gmagick
  • Equalizes the image histogram

Gmagick::equalizeimage

(PECL gmagick >= Unknown)

Gmagick::equalizeimage — Equalizes the image histogram

说明

public Gmagick::equalizeimage ( ) : Gmagick

Equalizes the image histogram.

返回值

The equalized Gmagick object.

错误／异常

错误时抛出 GmagickException。


Creates a vertical mirror image

  • ? Gmagick::equalizeimage
  • Gmagick::flopimage ?
  • PHP Manual
  • Gmagick
  • Creates a vertical mirror image

Gmagick::flipimage

(PECL gmagick >= Unknown)

Gmagick::flipimage — Creates a vertical mirror image

说明

public Gmagick::flipimage ( ) : Gmagick

Creates a vertical mirror image by reflecting the pixels around the central x-axis.

返回值

The flipped Gmagick object.

错误／异常

错误时抛出 GmagickException。

参见

  • Imagick::flopimage() - Creates a vertical mirror image


The flopimage purpose

  • ? Gmagick::flipimage
  • Gmagick::frameimage ?
  • PHP Manual
  • Gmagick
  • The flopimage purpose

Gmagick::flopimage

(PECL gmagick >= Unknown)

Gmagick::flopimage — The flopimage purpose

说明

public Gmagick::flopimage ( ) : Gmagick

Creates a vertical mirror image by reflecting the pixels around the central y-axis.

返回值

The flopped Gmagick object.

错误／异常

错误时抛出 GmagickException。

参见

  • Imagick::flipimage() - Creates a vertical mirror image


Adds a simulated three-dimensional border

  • ? Gmagick::flopimage
  • Gmagick::gammaimage ?
  • PHP Manual
  • Gmagick
  • Adds a simulated three-dimensional border

Gmagick::frameimage

(PECL gmagick >= Unknown)

Gmagick::frameimage — Adds a simulated three-dimensional border

说明

public Gmagick::frameimage ( GmagickPixel $color , int $width , int $height , int $inner_bevel , int $outer_bevel ) : Gmagick

Adds a simulated three-dimensional border around the image. The width and height specify the border width of the vertical and horizontal sides of the frame. The inner and outer bevels indicate the width of the inner and outer shadows of the frame.

参数

color

GmagickPixel object or a float representing the matte color

width

The width of the border

height

The height of the border

inner_bevel

The inner bevel width

outer_bevel

The outer bevel width

返回值

The framed Gmagick object.

错误／异常

错误时抛出 GmagickException。


Gamma-corrects an image

  • ? Gmagick::frameimage
  • Gmagick::getcopyright ?
  • PHP Manual
  • Gmagick
  • Gamma-corrects an image

Gmagick::gammaimage

(PECL gmagick >= Unknown)

Gmagick::gammaimage — Gamma-corrects an image

说明

public Gmagick::gammaimage ( float $gamma ) : Gmagick

Gamma-corrects an image. The same image viewed on different devices will have perceptual differences in the way the image's intensities are represented on the screen. Specify individual gamma levels for the red, green, and blue channels, or adjust all three with the gamma parameter. Values typically range from 0.8 to 2.3.

参数

gamma

The amount of gamma-correction.

返回值

The gamma corrected Gmagick object.

错误／异常

错误时抛出 GmagickException。


Returns the GraphicsMagick API copyright as a string

  • ? Gmagick::gammaimage
  • Gmagick::getfilename ?
  • PHP Manual
  • Gmagick
  • Returns the GraphicsMagick API copyright as a string

Gmagick::getcopyright

(PECL gmagick >= Unknown)

Gmagick::getcopyright — Returns the GraphicsMagick API copyright as a string

说明

public Gmagick::getcopyright ( ) : string

Returns the GraphicsMagick API copyright as a string.

返回值

Returns a string containing the copyright notice of GraphicsMagick and Magickwand C API.

错误／异常

错误时抛出 GmagickException。


The filename associated with an image sequence

  • ? Gmagick::getcopyright
  • Gmagick::getimagebackgroundcolor ?
  • PHP Manual
  • Gmagick
  • The filename associated with an image sequence

Gmagick::getfilename

(PECL gmagick >= Unknown)

Gmagick::getfilename — The filename associated with an image sequence

说明

public Gmagick::getfilename ( ) : string

Returns the filename associated with an image sequence.

返回值

Returns a string on success.

错误／异常

错误时抛出 GmagickException。


Returns the image background color

  • ? Gmagick::getfilename
  • Gmagick::getimageblueprimary ?
  • PHP Manual
  • Gmagick
  • Returns the image background color

Gmagick::getimagebackgroundcolor

(PECL gmagick >= Unknown)

Gmagick::getimagebackgroundcolor — Returns the image background color

说明

public Gmagick::getimagebackgroundcolor ( ) : GmagickPixel

Returns the image background color.

参数

此函数没有参数。

返回值

Returns an GmagickPixel set to the background color of the image.

错误／异常

错误时抛出 GmagickException。


Returns the chromaticy blue primary point

  • ? Gmagick::getimagebackgroundcolor
  • Gmagick::getimagebordercolor ?
  • PHP Manual
  • Gmagick
  • Returns the chromaticy blue primary point

Gmagick::getimageblueprimary

(PECL gmagick >= Unknown)

Gmagick::getimageblueprimary — Returns the chromaticy blue primary point

说明

public Gmagick::getimageblueprimary ( ) : array

Returns the chromaticity blue primary point for the image.

参数

x

The chromaticity blue primary x-point.

y

The chromaticity blue primary y-point.

返回值

Array consisting of "x" and "y" coordinates of point.

错误／异常

错误时抛出 GmagickException。


Returns the image border color

  • ? Gmagick::getimageblueprimary
  • Gmagick::getimagechanneldepth ?
  • PHP Manual
  • Gmagick
  • Returns the image border color

Gmagick::getimagebordercolor

(PECL gmagick >= Unknown)

Gmagick::getimagebordercolor — Returns the image border color

说明

public Gmagick::getimagebordercolor ( ) : GmagickPixel

Returns the image border color.

参数

此函数没有参数。

返回值

GmagickPixel object representing the color of the border

错误／异常

错误时抛出 GmagickException。


Gets the depth for a particular image channel

  • ? Gmagick::getimagebordercolor
  • Gmagick::getimagecolors ?
  • PHP Manual
  • Gmagick
  • Gets the depth for a particular image channel

Gmagick::getimagechanneldepth

(PECL gmagick >= Unknown)

Gmagick::getimagechanneldepth — Gets the depth for a particular image channel

说明

public Gmagick::getimagechanneldepth ( int $channel_type ) : int

Gets the depth for a particular image channel.

参数

此函数没有参数。

返回值

Depth of image channel

错误／异常

错误时抛出 GmagickException。


Returns the color of the specified colormap index

  • ? Gmagick::getimagechanneldepth
  • Gmagick::getimagecolorspace ?
  • PHP Manual
  • Gmagick
  • Returns the color of the specified colormap index

Gmagick::getimagecolors

(PECL gmagick >= Unknown)

Gmagick::getimagecolors — Returns the color of the specified colormap index

说明

public Gmagick::getimagecolors ( ) : int

Returns the color of the specified colormap index.

参数

此函数没有参数。

返回值

The number of colors in image.

错误／异常

错误时抛出 GmagickException。


Gets the image colorspace

  • ? Gmagick::getimagecolors
  • Gmagick::getimagecompose ?
  • PHP Manual
  • Gmagick
  • Gets the image colorspace

Gmagick::getimagecolorspace

(PECL gmagick >= Unknown)

Gmagick::getimagecolorspace — Gets the image colorspace

说明

public Gmagick::getimagecolorspace ( ) : int

Gets the image colorspace.

参数

此函数没有参数。

返回值

Colorspace

错误／异常

错误时抛出 GmagickException。


Returns the composite operator associated with the image

  • ? Gmagick::getimagecolorspace
  • Gmagick::getimagedelay ?
  • PHP Manual
  • Gmagick
  • Returns the composite operator associated with the image

Gmagick::getimagecompose

(PECL gmagick >= Unknown)

Gmagick::getimagecompose — Returns the composite operator associated with the image

说明

public Gmagick::getimagecompose ( ) : int

Returns the composite operator associated with the image.

参数

此函数没有参数。

返回值

Returns the composite operator associated with the image.

错误／异常

错误时抛出 GmagickException。


Gets the image delay

  • ? Gmagick::getimagecompose
  • Gmagick::getimagedepth ?
  • PHP Manual
  • Gmagick
  • Gets the image delay

Gmagick::getimagedelay

(PECL gmagick >= Unknown)

Gmagick::getimagedelay — Gets the image delay

说明

public Gmagick::getimagedelay ( ) : int

Gets the image delay

参数

此函数没有参数。

返回值

Returns the composite operator associated with the image.

错误／异常

错误时抛出 GmagickException。


Gets the depth of the image

  • ? Gmagick::getimagedelay
  • Gmagick::getimagedispose ?
  • PHP Manual
  • Gmagick
  • Gets the depth of the image

Gmagick::getimagedepth

(PECL gmagick >= Unknown)

Gmagick::getimagedepth — Gets the depth of the image

说明

public Gmagick::getimagedepth ( ) : int

Gets the depth of the image.

参数

此函数没有参数。

返回值

Image depth

错误／异常

错误时抛出 GmagickException。


Gets the image disposal method

  • ? Gmagick::getimagedepth
  • Gmagick::getimageextrema ?
  • PHP Manual
  • Gmagick
  • Gets the image disposal method

Gmagick::getimagedispose

(PECL gmagick >= Unknown)

Gmagick::getimagedispose — Gets the image disposal method

说明

public Gmagick::getimagedispose ( ) : int

Gets the image disposal method

参数

此函数没有参数。

返回值

Returns the dispose method on success.

错误／异常

错误时抛出 GmagickException。


Gets the extrema for the image

  • ? Gmagick::getimagedispose
  • Gmagick::getimagefilename ?
  • PHP Manual
  • Gmagick
  • Gets the extrema for the image

Gmagick::getimageextrema

(PECL gmagick >= Unknown)

Gmagick::getimageextrema — Gets the extrema for the image

说明

public Gmagick::getimageextrema ( ) : array

Returns an associative array with the keys "min" and "max". 错误时抛出 GmagickException。

参数

此函数没有参数。

返回值

Returns an associative array with the keys "min" and "max".

错误／异常

错误时抛出 GmagickException。


Returns the filename of a particular image in a sequence

  • ? Gmagick::getimageextrema
  • Gmagick::getimageformat ?
  • PHP Manual
  • Gmagick
  • Returns the filename of a particular image in a sequence

Gmagick::getimagefilename

(PECL gmagick >= Unknown)

Gmagick::getimagefilename — Returns the filename of a particular image in a sequence

说明

public Gmagick::getimagefilename ( ) : string

Returns the filename of a particular image in a sequence

参数

此函数没有参数。

返回值

Returns a string with the filename of the image

错误／异常

错误时抛出 GmagickException。


Returns the format of a particular image in a sequence

  • ? Gmagick::getimagefilename
  • Gmagick::getimagegamma ?
  • PHP Manual
  • Gmagick
  • Returns the format of a particular image in a sequence

Gmagick::getimageformat

(PECL gmagick >= Unknown)

Gmagick::getimageformat — Returns the format of a particular image in a sequence

说明

public Gmagick::getimageformat ( ) : string

Returns the format of a particular image in a sequence.

参数

此函数没有参数。

返回值

Returns a string containing the image format on success.

错误／异常

错误时抛出 GmagickException。


Gets the image gamma

  • ? Gmagick::getimageformat
  • Gmagick::getimagegreenprimary ?
  • PHP Manual
  • Gmagick
  • Gets the image gamma

Gmagick::getimagegamma

(PECL gmagick >= Unknown)

Gmagick::getimagegamma — Gets the image gamma

说明

public Gmagick::getimagegamma ( ) : float

Gets the image gamma

参数

此函数没有参数。

返回值

Returns the image gamma on success

错误／异常

错误时抛出 GmagickException。


Returns the chromaticy green primary point

  • ? Gmagick::getimagegamma
  • Gmagick::getimageheight ?
  • PHP Manual
  • Gmagick
  • Returns the chromaticy green primary point

Gmagick::getimagegreenprimary

(PECL gmagick >= Unknown)

Gmagick::getimagegreenprimary — Returns the chromaticy green primary point

说明

public Gmagick::getimagegreenprimary ( ) : array

Returns the chromaticity green primary point. Returns an array with the keys "x" and "y".

参数

此函数没有参数。

返回值

Returns an array with the keys "x" and "y" on success.

错误／异常

错误时抛出 GmagickException。


Returns the image height

  • ? Gmagick::getimagegreenprimary
  • Gmagick::getimagehistogram ?
  • PHP Manual
  • Gmagick
  • Returns the image height

Gmagick::getimageheight

(PECL gmagick >= Unknown)

Gmagick::getimageheight — Returns the image height

说明

public Gmagick::getimageheight ( ) : int

Returns the image height

参数

此函数没有参数。

返回值

Returns the image height in pixels.

错误／异常

错误时抛出 GmagickException。


Gets the image histogram

  • ? Gmagick::getimageheight
  • Gmagick::getimageindex ?
  • PHP Manual
  • Gmagick
  • Gets the image histogram

Gmagick::getimagehistogram

(PECL gmagick >= Unknown)

Gmagick::getimagehistogram — Gets the image histogram

说明

public Gmagick::getimagehistogram ( ) : array

Returns the image histogram as an array of GmagickPixel objects. Throw an GmagickException on error.

参数

此函数没有参数。

返回值

Returns the image histogram as an array of GmagickPixel objects.

错误／异常

错误时抛出 GmagickException。


Gets the index of the current active image

  • ? Gmagick::getimagehistogram
  • Gmagick::getimageinterlacescheme ?
  • PHP Manual
  • Gmagick
  • Gets the index of the current active image

Gmagick::getimageindex

(PECL gmagick >= Unknown)

Gmagick::getimageindex — Gets the index of the current active image

说明

public Gmagick::getimageindex ( ) : int

Returns the index of the current active image within the Gmagick object.

参数

此函数没有参数。

返回值

Index of current active image

错误／异常

错误时抛出 GmagickException。


Gets the image interlace scheme

  • ? Gmagick::getimageindex
  • Gmagick::getimageiterations ?
  • PHP Manual
  • Gmagick
  • Gets the image interlace scheme

Gmagick::getimageinterlacescheme

(PECL gmagick >= Unknown)

Gmagick::getimageinterlacescheme — Gets the image interlace scheme

说明

public Gmagick::getimageinterlacescheme ( ) : int

Gets the image interlace scheme.

参数

此函数没有参数。

返回值

Returns the interlace scheme as an integer on success

错误／异常

错误时抛出 GmagickException。


Gets the image iterations

  • ? Gmagick::getimageinterlacescheme
  • Gmagick::getimagematte ?
  • PHP Manual
  • Gmagick
  • Gets the image iterations

Gmagick::getimageiterations

(PECL gmagick >= Unknown)

Gmagick::getimageiterations — Gets the image iterations

说明

public Gmagick::getimageiterations ( ) : int

Gets the image iterations.

参数

此函数没有参数。

返回值

Returns the image iterations as an integer.

错误／异常

错误时抛出 GmagickException。


Check if the image has a matte channel

  • ? Gmagick::getimageiterations
  • Gmagick::getimagemattecolor ?
  • PHP Manual
  • Gmagick
  • Check if the image has a matte channel

Gmagick::getimagematte

(PECL gmagick >= Unknown)

Gmagick::getimagematte — Check if the image has a matte channel

说明

public Gmagick::getimagematte ( ) : int

Returns true if the image has a matte channel, otherwise false.

参数

此函数没有参数。

返回值

Returns true if the image has a matte channel, otherwise false.

错误／异常

错误时抛出 GmagickException。


Returns the image matte color

  • ? Gmagick::getimagematte
  • Gmagick::getimageprofile ?
  • PHP Manual
  • Gmagick
  • Returns the image matte color

Gmagick::getimagemattecolor

(PECL gmagick >= Unknown)

Gmagick::getimagemattecolor — Returns the image matte color

说明

public Gmagick::getimagemattecolor ( ) : GmagickPixel

Returns GmagickPixel object on success. Throw an GmagickException on error.

参数

此函数没有参数。

返回值

Returns GmagickPixel object on success.

错误／异常

错误时抛出 GmagickException。


Returns the named image profile

  • ? Gmagick::getimagemattecolor
  • Gmagick::getimageredprimary ?
  • PHP Manual
  • Gmagick
  • Returns the named image profile

Gmagick::getimageprofile

(PECL gmagick >= Unknown)

Gmagick::getimageprofile — Returns the named image profile

说明

public Gmagick::getimageprofile ( string $name ) : string

Returns the named image profile.

参数

此函数没有参数。

返回值

Returns a string containing the image profile.

错误／异常

错误时抛出 GmagickException。


Returns the chromaticity red primary point

  • ? Gmagick::getimageprofile
  • Gmagick::getimagerenderingintent ?
  • PHP Manual
  • Gmagick
  • Returns the chromaticity red primary point

Gmagick::getimageredprimary

(PECL gmagick >= Unknown)

Gmagick::getimageredprimary — Returns the chromaticity red primary point

说明

public Gmagick::getimageredprimary ( ) : array

Returns the chromaticity red primary point as an array with the keys "x" and "y".

参数

此函数没有参数。

返回值

Returns the chromaticity red primary point as an array with the keys "x" and "y".

错误／异常

错误时抛出 GmagickException。


Gets the image rendering intent

  • ? Gmagick::getimageredprimary
  • Gmagick::getimageresolution ?
  • PHP Manual
  • Gmagick
  • Gets the image rendering intent

Gmagick::getimagerenderingintent

(PECL gmagick >= Unknown)

Gmagick::getimagerenderingintent — Gets the image rendering intent

说明

public Gmagick::getimagerenderingintent ( ) : int

Gets the image rendering intent

参数

此函数没有参数。

返回值

Extracts a region of the image and returns it as a new wand

错误／异常

错误时抛出 GmagickException。


Gets the image X and Y resolution

  • ? Gmagick::getimagerenderingintent
  • Gmagick::getimagescene ?
  • PHP Manual
  • Gmagick
  • Gets the image X and Y resolution

Gmagick::getimageresolution

(PECL gmagick >= Unknown)

Gmagick::getimageresolution — Gets the image X and Y resolution

说明

public Gmagick::getimageresolution ( ) : array

Returns the resolution as an array.

参数

此函数没有参数。

返回值

Returns the resolution as an array.

错误／异常

错误时抛出 GmagickException。


Gets the image scene

  • ? Gmagick::getimageresolution
  • Gmagick::getimagesignature ?
  • PHP Manual
  • Gmagick
  • Gets the image scene

Gmagick::getimagescene

(PECL gmagick >= Unknown)

Gmagick::getimagescene — Gets the image scene

说明

public Gmagick::getimagescene ( ) : int

Gets the image scene.

参数

此函数没有参数。

返回值

Returns the image scene.

错误／异常

错误时抛出 GmagickException。


Generates an SHA-256 message digest

  • ? Gmagick::getimagescene
  • Gmagick::getimagetype ?
  • PHP Manual
  • Gmagick
  • Generates an SHA-256 message digest

Gmagick::getimagesignature

(PECL gmagick >= Unknown)

Gmagick::getimagesignature — Generates an SHA-256 message digest

说明

public Gmagick::getimagesignature ( ) : string

Generates an SHA-256 message digest for the image pixel stream.

参数

此函数没有参数。

返回值

Returns a string containing the SHA-256 hash of the file.

错误／异常

错误时抛出 GmagickException。


Gets the potential image type

  • ? Gmagick::getimagesignature
  • Gmagick::getimageunits ?
  • PHP Manual
  • Gmagick
  • Gets the potential image type

Gmagick::getimagetype

(PECL gmagick >= Unknown)

Gmagick::getimagetype — Gets the potential image type

说明

public Gmagick::getimagetype ( ) : int

Gets the potential image type.

参数

此函数没有参数。

返回值

Returns the potential image type.

错误／异常

错误时抛出 GmagickException。


Gets the image units of resolution

  • ? Gmagick::getimagetype
  • Gmagick::getimagewhitepoint ?
  • PHP Manual
  • Gmagick
  • Gets the image units of resolution

Gmagick::getimageunits

(PECL gmagick >= Unknown)

Gmagick::getimageunits — Gets the image units of resolution

说明

public Gmagick::getimageunits ( ) : int

Gets the image units of resolution.

参数

此函数没有参数。

返回值

Returns the image units of resolution.


Returns the chromaticity white point

  • ? Gmagick::getimageunits
  • Gmagick::getimagewidth ?
  • PHP Manual
  • Gmagick
  • Returns the chromaticity white point

Gmagick::getimagewhitepoint

(PECL gmagick >= Unknown)

Gmagick::getimagewhitepoint — Returns the chromaticity white point

说明

public Gmagick::getimagewhitepoint ( ) : array

Returns the chromaticity white point as an associative array with the keys "x" and "y".

参数

此函数没有参数。

返回值

Returns the chromaticity white point as an associative array with the keys "x" and "y".

错误／异常

错误时抛出 GmagickException。


Returns the width of the image

  • ? Gmagick::getimagewhitepoint
  • Gmagick::getpackagename ?
  • PHP Manual
  • Gmagick
  • Returns the width of the image

Gmagick::getimagewidth

(PECL gmagick >= Unknown)

Gmagick::getimagewidth — Returns the width of the image

说明

public Gmagick::getimagewidth ( ) : int

Returns the width of the image.

参数

此函数没有参数。

返回值

Returns the image width.

错误／异常

错误时抛出 GmagickException。


Returns the GraphicsMagick package name

  • ? Gmagick::getimagewidth
  • Gmagick::getquantumdepth ?
  • PHP Manual
  • Gmagick
  • Returns the GraphicsMagick package name

Gmagick::getpackagename

(PECL gmagick >= Unknown)

Gmagick::getpackagename — Returns the GraphicsMagick package name

说明

public Gmagick::getpackagename ( ) : string

Returns the GraphicsMagick package name.

参数

此函数没有参数。

返回值

Returns the GraphicsMagick package name as a string.

错误／异常

错误时抛出 GmagickException。


Returns the Gmagick quantum depth as a string

  • ? Gmagick::getpackagename
  • Gmagick::getreleasedate ?
  • PHP Manual
  • Gmagick
  • Returns the Gmagick quantum depth as a string

Gmagick::getquantumdepth

(PECL gmagick >= Unknown)

Gmagick::getquantumdepth — Returns the Gmagick quantum depth as a string

说明

public Gmagick::getquantumdepth ( ) : array

Returns the Gmagick quantum depth as a string.

参数

此函数没有参数。

返回值

Returns the Gmagick quantum depth as a string.

错误／异常

错误时抛出 GmagickException。


Returns the GraphicsMagick release date as a string

  • ? Gmagick::getquantumdepth
  • Gmagick::getsamplingfactors ?
  • PHP Manual
  • Gmagick
  • Returns the GraphicsMagick release date as a string

Gmagick::getreleasedate

(PECL gmagick >= Unknown)

Gmagick::getreleasedate — Returns the GraphicsMagick release date as a string

说明

public Gmagick::getreleasedate ( ) : string

Returns the GraphicsMagick release date as a string.

参数

此函数没有参数。

返回值

Returns the GraphicsMagick release date as a string.

错误／异常

错误时抛出 GmagickException。


Gets the horizontal and vertical sampling factor

  • ? Gmagick::getreleasedate
  • Gmagick::getsize ?
  • PHP Manual
  • Gmagick
  • Gets the horizontal and vertical sampling factor

Gmagick::getsamplingfactors

(PECL gmagick >= Unknown)

Gmagick::getsamplingfactors — Gets the horizontal and vertical sampling factor

说明

public Gmagick::getsamplingfactors ( ) : array

Gets the horizontal and vertical sampling factor.

参数

此函数没有参数。

返回值

Returns an associative array with the horizontal and vertical sampling factors of the image.

错误／异常

错误时抛出 GmagickException。


Returns the size associated with the Gmagick object

  • ? Gmagick::getsamplingfactors
  • Gmagick::getversion ?
  • PHP Manual
  • Gmagick
  • Returns the size associated with the Gmagick object

Gmagick::getsize

(PECL gmagick >= Unknown)

Gmagick::getsize — Returns the size associated with the Gmagick object

说明

public Gmagick::getsize ( ) : array

Returns the size associated with the Gmagick object as an array with the keys "columns" and "rows".

参数

此函数没有参数。

返回值

Returns the size associated with the Gmagick object as an array with the keys "columns" and "rows".

错误／异常

错误时抛出 GmagickException。


Returns the GraphicsMagick API version

  • ? Gmagick::getsize
  • Gmagick::hasnextimage ?
  • PHP Manual
  • Gmagick
  • Returns the GraphicsMagick API version

Gmagick::getversion

(PECL gmagick >= Unknown)

Gmagick::getversion — Returns the GraphicsMagick API version

说明

public Gmagick::getversion ( ) : array

Returns the GraphicsMagick API version as a string and as a number.

参数

此函数没有参数。

返回值

Returns the GraphicsMagick API version as a string and as a number.

错误／异常

错误时抛出 GmagickException。


Checks if the object has more images

  • ? Gmagick::getversion
  • Gmagick::haspreviousimage ?
  • PHP Manual
  • Gmagick
  • Checks if the object has more images

Gmagick::hasnextimage

(PECL gmagick >= Unknown)

Gmagick::hasnextimage — Checks if the object has more images

说明

public Gmagick::hasnextimage ( ) : mixed

Returns TRUE if the object has more images when traversing the list in the forward direction.

参数

此函数没有参数。

返回值

Returns TRUE if the object has more images when traversing the list in the forward direction, returns FALSE if there are none.

错误／异常

错误时抛出 GmagickException。


Checks if the object has a previous image

  • ? Gmagick::hasnextimage
  • Gmagick::implodeimage ?
  • PHP Manual
  • Gmagick
  • Checks if the object has a previous image

Gmagick::haspreviousimage

(PECL gmagick >= Unknown)

Gmagick::haspreviousimage — Checks if the object has a previous image

说明

public Gmagick::haspreviousimage ( ) : mixed

Returns TRUE if the object has more images when traversing the list in the reverse direction

参数

此函数没有参数。

返回值

Returns TRUE if the object has more images when traversing the list in the reverse direction, returns FALSE if there are none.

错误／异常

错误时抛出 GmagickException。


Creates a new image as a copy

  • ? Gmagick::haspreviousimage
  • Gmagick::labelimage ?
  • PHP Manual
  • Gmagick
  • Creates a new image as a copy

Gmagick::implodeimage

(PECL gmagick >= Unknown)

Gmagick::implodeimage — Creates a new image as a copy

说明

public Gmagick::implodeimage ( float $radius ) : mixed

Creates a new image that is a copy of an existing one with the image pixels "imploded" by the specified percentage.

参数

radius

The radius of the implode

返回值

Returns imploded Gmagick object.

错误／异常

错误时抛出 GmagickException。


Adds a label to an image

  • ? Gmagick::implodeimage
  • Gmagick::levelimage ?
  • PHP Manual
  • Gmagick
  • Adds a label to an image

Gmagick::labelimage

(PECL gmagick >= Unknown)

Gmagick::labelimage — Adds a label to an image

说明

public Gmagick::labelimage ( string $label ) : mixed

Adds a label to an image.

参数

label

The label to add

返回值

Gmagick with label.

错误／异常

错误时抛出 GmagickException。


Adjusts the levels of an image

  • ? Gmagick::labelimage
  • Gmagick::magnifyimage ?
  • PHP Manual
  • Gmagick
  • Adjusts the levels of an image

Gmagick::levelimage

(PECL gmagick >= Unknown)

Gmagick::levelimage — Adjusts the levels of an image

说明

public Gmagick::levelimage ( float $blackPoint , float $gamma , float $whitePoint , int $channel = Gmagick::CHANNEL_DEFAULT ) : mixed

Adjusts the levels of an image by scaling the colors falling between specified white and black points to the full available quantum range. The parameters provided represent the black, mid, and white points. The black point specifies the darkest color in the image. Colors darker than the black point are set to zero. Mid point specifies a gamma correction to apply to the image. White point specifies the lightest color in the image. Colors brighter than the white point are set to the maximum quantum value.

参数

blackPoint

The image black point

gamma

The gamma value

whitePoint

The image white point

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

Gmagick object with image levelled.

错误／异常

错误时抛出 GmagickException。


Scales an image proportionally 2x

  • ? Gmagick::levelimage
  • Gmagick::mapimage ?
  • PHP Manual
  • Gmagick
  • Scales an image proportionally 2x

Gmagick::magnifyimage

(PECL gmagick >= Unknown)

Gmagick::magnifyimage — Scales an image proportionally 2x

说明

public Gmagick::magnifyimage ( ) : mixed

Conveniently scales an image proportionally to twice its original size.

参数

此函数没有参数。

返回值

Magnified Gmagick object.

错误／异常

错误时抛出 GmagickException。


Replaces the colors of an image with the closest color from a reference image

  • ? Gmagick::magnifyimage
  • Gmagick::medianfilterimage ?
  • PHP Manual
  • Gmagick
  • Replaces the colors of an image with the closest color from a reference image

Gmagick::mapimage

(PECL gmagick >= Unknown)

Gmagick::mapimage — Replaces the colors of an image with the closest color from a reference image

说明

public Gmagick::mapimage ( gmagick $gmagick , bool $dither ) : Gmagick

Replaces the colors of an image with the closest color from a reference image.

参数

gmagick

The reference image

dither

Set this integer value to something other than zero to dither the mapped image

返回值

Gmagick object

错误／异常

错误时抛出 GmagickException。


Applies a digital filter

  • ? Gmagick::mapimage
  • Gmagick::minifyimage ?
  • PHP Manual
  • Gmagick
  • Applies a digital filter

Gmagick::medianfilterimage

(PECL gmagick >= Unknown)

Gmagick::medianfilterimage — Applies a digital filter

说明

public Gmagick::medianfilterimage ( float $radius ) : void

Applies a digital filter that improves the quality of a noisy image. Each pixel is replaced by the median in a set of neighboring pixels as defined by radius.

参数

radius

The radius of the pixel neighborhood.

返回值

Gmagick object with median filter applied.

错误／异常

错误时抛出 GmagickException。


Scales an image proportionally to half its size

  • ? Gmagick::medianfilterimage
  • Gmagick::modulateimage ?
  • PHP Manual
  • Gmagick
  • Scales an image proportionally to half its size

Gmagick::minifyimage

(PECL gmagick >= Unknown)

Gmagick::minifyimage — Scales an image proportionally to half its size

说明

public Gmagick::minifyimage ( ) : Gmagick

A convenient method that scales an image proportionally to one-half its original size

参数

此函数没有参数。

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Control the brightness, saturation, and hue

  • ? Gmagick::minifyimage
  • Gmagick::motionblurimage ?
  • PHP Manual
  • Gmagick
  • Control the brightness, saturation, and hue

Gmagick::modulateimage

(PECL gmagick >= Unknown)

Gmagick::modulateimage — Control the brightness, saturation, and hue

说明

public Gmagick::modulateimage ( float $brightness , float $saturation , float $hue ) : Gmagick

Lets you control the brightness, saturation, and hue of an image. Hue is the percentage of absolute rotation from the current position. For example 50 results in a counter-clockwise rotation of 90 degrees, 150 results in a clockwise rotation of 90 degrees, with 0 and 200 both resulting in a rotation of 180 degrees.

参数

brightness

The percent change in brighness (-100 thru +100).

saturation

The percent change in saturation (-100 thru +100)

hue

The percent change in hue (-100 thru +100)

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Simulates motion blur

  • ? Gmagick::modulateimage
  • Gmagick::newimage ?
  • PHP Manual
  • Gmagick
  • Simulates motion blur

Gmagick::motionblurimage

(PECL gmagick >= Unknown)

Gmagick::motionblurimage — Simulates motion blur

说明

public Gmagick::motionblurimage ( float $radius , float $sigma , float $angle ) : Gmagick

Simulates motion blur. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and MotionBlurImage() selects a suitable radius for you. Angle gives the angle of the blurring motion.

参数

radius

The radius of the Gaussian, in pixels, not counting the center pixel.

sigma

The standard deviation of the Gaussian, in pixels.

angle

Apply the effect along this angle.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Creates a new image

  • ? Gmagick::motionblurimage
  • Gmagick::nextimage ?
  • PHP Manual
  • Gmagick
  • Creates a new image

Gmagick::newimage

(PECL gmagick >= Unknown)

Gmagick::newimage — Creates a new image

说明

public Gmagick::newimage ( int $width , int $height , string $background , string $format = ? ) : Gmagick

Creates a new image with the specified background color

参数

width

Width of the new image

height

Height of the new image

background

The background color used for this image (as float)

format

Image format.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Moves to the next image

  • ? Gmagick::newimage
  • Gmagick::normalizeimage ?
  • PHP Manual
  • Gmagick
  • Moves to the next image

Gmagick::nextimage

(PECL gmagick >= Unknown)

Gmagick::nextimage — Moves to the next image

说明

public Gmagick::nextimage ( ) : bool

Associates the next image in the image list with an Gmagick object.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

错误时抛出 GmagickException。


Enhances the contrast of a color image

  • ? Gmagick::nextimage
  • Gmagick::oilpaintimage ?
  • PHP Manual
  • Gmagick
  • Enhances the contrast of a color image

Gmagick::normalizeimage

(PECL gmagick >= Unknown)

Gmagick::normalizeimage — Enhances the contrast of a color image

说明

public Gmagick::normalizeimage ( int $channel = ? ) : Gmagick

Enhances the contrast of a color image by adjusting the pixels color to span the entire range of colors available.

参数

channel

Identify which channel to normalize

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Simulates an oil painting

  • ? Gmagick::normalizeimage
  • Gmagick::previousimage ?
  • PHP Manual
  • Gmagick
  • Simulates an oil painting

Gmagick::oilpaintimage

(PECL gmagick >= Unknown)

Gmagick::oilpaintimage — Simulates an oil painting

说明

public Gmagick::oilpaintimage ( float $radius ) : Gmagick

Applies a special effect filter that simulates an oil painting. Each pixel is replaced by the most frequent color occurring in a circular region defined by radius.

参数

radius

The radius of the circular neighborhood.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Move to the previous image in the object

  • ? Gmagick::oilpaintimage
  • Gmagick::profileimage ?
  • PHP Manual
  • Gmagick
  • Move to the previous image in the object

Gmagick::previousimage

(PECL gmagick >= Unknown)

Gmagick::previousimage — Move to the previous image in the object

说明

public Gmagick::previousimage ( ) : bool

Associates the previous image in an image list with the Gmagick object.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

错误时抛出 GmagickException。


Adds or removes a profile from an image

  • ? Gmagick::previousimage
  • Gmagick::quantizeimage ?
  • PHP Manual
  • Gmagick
  • Adds or removes a profile from an image

Gmagick::profileimage

(PECL gmagick >= Unknown)

Gmagick::profileimage — Adds or removes a profile from an image

说明

public Gmagick::profileimage ( string $name , string $profile ) : Gmagick

Adds or removes a ICC, IPTC, or generic profile from an image. If the profile is NULL, it is removed from the image otherwise added. Use a name of '*' and a profile of NULL to remove all profiles from the image.

参数

name

Name of profile to add or remove: ICC, IPTC, or generic profile.

profile

The profile.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Analyzes the colors within a reference image

  • ? Gmagick::profileimage
  • Gmagick::quantizeimages ?
  • PHP Manual
  • Gmagick
  • Analyzes the colors within a reference image

Gmagick::quantizeimage

(PECL gmagick >= Unknown)

Gmagick::quantizeimage — Analyzes the colors within a reference image

说明

public Gmagick::quantizeimage ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError ) : Gmagick

Analyzes the colors within a reference image and chooses a fixed number of colors to represent the image. The goal of the algorithm is to minimize the color difference between the input and output image while minimizing the processing time.

参数

numColors

The number of colors.

colorspace

Perform color reduction in this colorspace, typically RGBColorspace.

treeDepth

Normally, this integer value is zero or one. A zero or one tells Quantize to choose a optimal tree depth of Log4(number_colors).% A tree of this depth generally allows the best representation of the reference image with the least amount of memory and the fastest computational speed. In some cases, such as an image with low color dispersion (a few number of colors), a value other than Log4(number_colors) is required. To expand the color tree completely, use a value of 8.

dither

A value other than zero distributes the difference between an original image and the corresponding color reduced algorithm to neighboring pixels along a Hilbert curve.

measureError

A value other than zero measures the difference between the original and quantized images. This difference is the total quantization error. The error is computed by summing over all pixels in an image the distance squared in RGB space between each reference pixel value and its quantized value.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


The quantizeimages purpose

  • ? Gmagick::quantizeimage
  • Gmagick::queryfontmetrics ?
  • PHP Manual
  • Gmagick
  • The quantizeimages purpose

Gmagick::quantizeimages

(PECL gmagick >= Unknown)

Gmagick::quantizeimages — The quantizeimages purpose

说明

public Gmagick::quantizeimages ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError ) : Gmagick

Analyzes the colors within a sequence of images and chooses a fixed number of colors to represent the image. The goal of the algorithm is to minimize the color difference between the input and output image while minimizing the processing time.

参数

numColors

The number of colors.

colorspace

Perform color reduction in this colorspace, typically RGBColorspace.

treeDepth

Normally, this integer value is zero or one. A zero or one tells Quantize to choose a optimal tree depth of Log4(number_colors).% A tree of this depth generally allows the best representation of the reference image with the least amount of memory and the fastest computational speed. In some cases, such as an image with low color dispersion (a few number of colors), a value other than Log4(number_colors) is required. To expand the color tree completely, use a value of 8.

dither

A value other than zero distributes the difference between an original image and the corresponding color reduced algorithm to neighboring pixels along a Hilbert curve.

measureError

A value other than zero measures the difference between the original and quantized images. This difference is the total quantization error. The error is computed by summing over all pixels in an image the distance squared in RGB space between each reference pixel value and its quantized value.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Returns an array representing the font metrics

  • ? Gmagick::quantizeimages
  • Gmagick::queryfonts ?
  • PHP Manual
  • Gmagick
  • Returns an array representing the font metrics

Gmagick::queryfontmetrics

(PECL gmagick >= Unknown)

Gmagick::queryfontmetrics — Returns an array representing the font metrics

说明

public Gmagick::queryfontmetrics ( GmagickDraw $draw , string $text ) : array

MagickQueryFontMetrics() returns an array representing the font metrics.

参数

此函数没有参数。

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Returns the configured fonts

  • ? Gmagick::queryfontmetrics
  • Gmagick::queryformats ?
  • PHP Manual
  • Gmagick
  • Returns the configured fonts

Gmagick::queryfonts

(PECL gmagick >= Unknown)

Gmagick::queryfonts — Returns the configured fonts

说明

public Gmagick::queryfonts ( string $pattern = "*" ) : array

Returns fonts supported by Gmagick.

参数

此函数没有参数。

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Returns formats supported by Gmagick

  • ? Gmagick::queryfonts
  • Gmagick::radialblurimage ?
  • PHP Manual
  • Gmagick
  • Returns formats supported by Gmagick

Gmagick::queryformats

(PECL gmagick >= Unknown)

Gmagick::queryformats — Returns formats supported by Gmagick

说明

public Gmagick::queryformats ( string $pattern = "*" ) : array

Returns formats supported by Gmagick.

参数

pattern

Specifies a string containing a pattern.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Radial blurs an image

  • ? Gmagick::queryformats
  • Gmagick::raiseimage ?
  • PHP Manual
  • Gmagick
  • Radial blurs an image

Gmagick::radialblurimage

(PECL gmagick >= Unknown)

Gmagick::radialblurimage — Radial blurs an image

说明

public Gmagick::radialblurimage ( float $angle , int $channel = Gmagick::CHANNEL_DEFAULT ) : Gmagick

Radial blurs an image.

参数

angle

The angle of the blur in degrees.

channel

Related channel

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Creates a simulated 3d button-like effect

  • ? Gmagick::radialblurimage
  • Gmagick::read ?
  • PHP Manual
  • Gmagick
  • Creates a simulated 3d button-like effect

Gmagick::raiseimage

(PECL gmagick >= Unknown)

Gmagick::raiseimage — Creates a simulated 3d button-like effect

说明

public Gmagick::raiseimage ( int $width , int $height , int $x , int $y , bool $raise ) : Gmagick

Creates a simulated three-dimensional button-like effect by lightening and darkening the edges of the image. Members width and height of raise_info define the width of the vertical and horizontal edge of the effect.

参数

width

Width of the area to raise.

height

Height of the area to raise.

x

X coordinate

y

Y coordinate

raise

A value other than zero creates a 3-D raise effect, otherwise it has a lowered effect.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Reads image from filename

  • ? Gmagick::raiseimage
  • Gmagick::readimage ?
  • PHP Manual
  • Gmagick
  • Reads image from filename

Gmagick::read

(PECL gmagick >= Unknown)

Gmagick::read — Reads image from filename

说明

public Gmagick::read ( string $filename ) : Gmagick

Reads image from filename.

参数

filename

The image filename.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Reads image from filename

  • ? Gmagick::read
  • Gmagick::readimageblob ?
  • PHP Manual
  • Gmagick
  • Reads image from filename

Gmagick::readimage

(PECL gmagick >= Unknown)

Gmagick::readimage — Reads image from filename

说明

public Gmagick::readimage ( string $filename ) : Gmagick

Reads image from filename.

参数

filename

The image filename.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Reads image from a binary string

  • ? Gmagick::readimage
  • Gmagick::readimagefile ?
  • PHP Manual
  • Gmagick
  • Reads image from a binary string

Gmagick::readimageblob

(PECL gmagick >= Unknown)

Gmagick::readimageblob — Reads image from a binary string

说明

public Gmagick::readimageblob ( string $imageContents , string $filename = ? ) : Gmagick

Reads image from a binary string.

参数

imageContents

Content of image

filename

The image filename.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


The readimagefile purpose

  • ? Gmagick::readimageblob
  • Gmagick::reducenoiseimage ?
  • PHP Manual
  • Gmagick
  • The readimagefile purpose

Gmagick::readimagefile

(PECL gmagick >= Unknown)

Gmagick::readimagefile — The readimagefile purpose

说明

public Gmagick::readimagefile ( resource $fp , string $filename = ? ) : Gmagick

Reads an image or image sequence from an open file descriptor.

参数

fp

The file descriptor.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Smooths the contours of an image

  • ? Gmagick::readimagefile
  • Gmagick::removeimage ?
  • PHP Manual
  • Gmagick
  • Smooths the contours of an image

Gmagick::reducenoiseimage

(PECL gmagick >= Unknown)

Gmagick::reducenoiseimage — Smooths the contours of an image

说明

public Gmagick::reducenoiseimage ( float $radius ) : Gmagick

Smooths the contours of an image while still preserving edge information. The algorithm works by replacing each pixel with its neighbor closest in value. A neighbor is defined by radius. Use a radius of 0 and Gmagick::reduceNoiseImage() selects a suitable radius for you.

参数

radius

The radius of the pixel neighborhood.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Removes an image from the image list

  • ? Gmagick::reducenoiseimage
  • Gmagick::removeimageprofile ?
  • PHP Manual
  • Gmagick
  • Removes an image from the image list

Gmagick::removeimage

(PECL gmagick >= Unknown)

Gmagick::removeimage — Removes an image from the image list

说明

public Gmagick::removeimage ( ) : Gmagick

Removes an image from the image list.

参数

此函数没有参数。

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Removes the named image profile and returns it

  • ? Gmagick::removeimage
  • Gmagick::resampleimage ?
  • PHP Manual
  • Gmagick
  • Removes the named image profile and returns it

Gmagick::removeimageprofile

(PECL gmagick >= Unknown)

Gmagick::removeimageprofile — Removes the named image profile and returns it

说明

public Gmagick::removeimageprofile ( string $name ) : string

Removes the named image profile and returns it.

参数

name

Name of profile to return: ICC, IPTC, or generic profile.

返回值

The named profile.

错误／异常

错误时抛出 GmagickException。


Resample image to desired resolution

  • ? Gmagick::removeimageprofile
  • Gmagick::resizeimage ?
  • PHP Manual
  • Gmagick
  • Resample image to desired resolution

Gmagick::resampleimage

(PECL gmagick >= Unknown)

Gmagick::resampleimage — Resample image to desired resolution

说明

public Gmagick::resampleimage ( float $xResolution , float $yResolution , int $filter , float $blur ) : Gmagick

Resample image to desired resolution.

参数

xResolution

The new image x resolution.

yResolution

The new image y resolution.

filter

Image filter to use.

blur

The blur factor where larger than 1 is blurry, smaller than 1 is sharp.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Scales an image

  • ? Gmagick::resampleimage
  • Gmagick::rollimage ?
  • PHP Manual
  • Gmagick
  • Scales an image

Gmagick::resizeimage

(PECL gmagick >= Unknown)

Gmagick::resizeimage — Scales an image

说明

public Gmagick::resizeimage ( int $width , int $height , int $filter , float $blur , bool $fit = false ) : Gmagick

Scales an image to the desired dimensions with a filter.

参数

width

The number of columns in the scaled image.

height

The number of rows in the scaled image.

filter

Image filter to use.

blur

The blur factor where larger than 1 is blurry, lesser than 1 is sharp.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Offsets an image

  • ? Gmagick::resizeimage
  • Gmagick::rotateimage ?
  • PHP Manual
  • Gmagick
  • Offsets an image

Gmagick::rollimage

(PECL gmagick >= Unknown)

Gmagick::rollimage — Offsets an image

说明

public Gmagick::rollimage ( int $x , int $y ) : Gmagick

Offsets an image as defined by x and y.

参数

x

The x offset.

y

The y offset.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Rotates an image

  • ? Gmagick::rollimage
  • Gmagick::scaleimage ?
  • PHP Manual
  • Gmagick
  • Rotates an image

Gmagick::rotateimage

(PECL gmagick >= Unknown)

Gmagick::rotateimage — Rotates an image

说明

public Gmagick::rotateimage ( mixed $color , float $degrees ) : Gmagick

Rotates an image the specified number of degrees. Empty triangles left over from rotating the image are filled with the background color.

参数

color

The background pixel.

degrees

The number of degrees to rotate the image.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Scales the size of an image

  • ? Gmagick::rotateimage
  • Gmagick::separateimagechannel ?
  • PHP Manual
  • Gmagick
  • Scales the size of an image

Gmagick::scaleimage

(PECL gmagick >= Unknown)

Gmagick::scaleimage — Scales the size of an image

说明

public Gmagick::scaleimage ( int $width , int $height , bool $fit = false ) : Gmagick

Scales the size of an image to the given dimensions. The other parameter will be calculated if 0 is passed as either param.

参数

width

The number of columns in the scaled image.

height

The number of rows in the scaled image.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Separates a channel from the image

  • ? Gmagick::scaleimage
  • Gmagick::setCompressionQuality ?
  • PHP Manual
  • Gmagick
  • Separates a channel from the image

Gmagick::separateimagechannel

(PECL gmagick >= Unknown)

Gmagick::separateimagechannel — Separates a channel from the image

说明

public Gmagick::separateimagechannel ( int $channel ) : Gmagick

Separates a channel from the image and returns a grayscale image. A channel is a particular color component of each pixel in the image.

参数

channel

Identify which channel to extract: RedChannel, GreenChannel, BlueChannel, OpacityChannel, CyanChannel, MagentaChannel, YellowChannel, BlackChannel.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the object's default compression quality

  • ? Gmagick::separateimagechannel
  • Gmagick::setfilename ?
  • PHP Manual
  • Gmagick
  • Sets the object's default compression quality

Gmagick::setCompressionQuality

(No version information available, might only be in Git)

Gmagick::setCompressionQuality — Sets the object's default compression quality

说明

Gmagick::setCompressionQuality ( int $quality = 75 ) : Gmagick

Sets the object's default compression quality.

参数

quality

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。

范例

Example #1 Gmagick::setCompressionQuality()

<?php
$gm = new Gmagick();
$gm->read("magick:rose");
$gm->setCompressionQuality(2);
?>


Sets the filename before you read or write the image

  • ? Gmagick::setCompressionQuality
  • Gmagick::setimagebackgroundcolor ?
  • PHP Manual
  • Gmagick
  • Sets the filename before you read or write the image

Gmagick::setfilename

(PECL gmagick >= Unknown)

Gmagick::setfilename — Sets the filename before you read or write the image

说明

public Gmagick::setfilename ( string $filename ) : Gmagick

Sets the filename before you read or write an image file.

参数

filename

The image filename.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the image background color

  • ? Gmagick::setfilename
  • Gmagick::setimageblueprimary ?
  • PHP Manual
  • Gmagick
  • Sets the image background color

Gmagick::setimagebackgroundcolor

(PECL gmagick >= Unknown)

Gmagick::setimagebackgroundcolor — Sets the image background color

说明

public Gmagick::setimagebackgroundcolor ( GmagickPixel $color ) : Gmagick

Sets the image background color.

参数

color

The background pixel wand.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the image chromaticity blue primary point

  • ? Gmagick::setimagebackgroundcolor
  • Gmagick::setimagebordercolor ?
  • PHP Manual
  • Gmagick
  • Sets the image chromaticity blue primary point

Gmagick::setimageblueprimary

(PECL gmagick >= Unknown)

Gmagick::setimageblueprimary — Sets the image chromaticity blue primary point

说明

public Gmagick::setimageblueprimary ( float $x , float $y ) : Gmagick

Sets the image chromaticity blue primary point.

参数

x

The blue primary x-point.

y

The blue primary y-point.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the image border color

  • ? Gmagick::setimageblueprimary
  • Gmagick::setimagechanneldepth ?
  • PHP Manual
  • Gmagick
  • Sets the image border color

Gmagick::setimagebordercolor

(PECL gmagick >= Unknown)

Gmagick::setimagebordercolor — Sets the image border color

说明

public Gmagick::setimagebordercolor ( GmagickPixel $color ) : Gmagick

Sets the image border color.

参数

color

The border pixel wand.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the depth of a particular image channel

  • ? Gmagick::setimagebordercolor
  • Gmagick::setimagecolorspace ?
  • PHP Manual
  • Gmagick
  • Sets the depth of a particular image channel

Gmagick::setimagechanneldepth

(PECL gmagick >= Unknown)

Gmagick::setimagechanneldepth — Sets the depth of a particular image channel

说明

public Gmagick::setimagechanneldepth ( int $channel , int $depth ) : Gmagick

Sets the depth of a particular image channel.

参数

channel

Identify which channel to extract: RedChannel, GreenChannel, BlueChannel, OpacityChannel, CyanChannel, MagentaChannel, YellowChannel, BlackChannel.

depth

The image depth in bits.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the image colorspace

  • ? Gmagick::setimagechanneldepth
  • Gmagick::setimagecompose ?
  • PHP Manual
  • Gmagick
  • Sets the image colorspace

Gmagick::setimagecolorspace

(PECL gmagick >= Unknown)

Gmagick::setimagecolorspace — Sets the image colorspace

说明

public Gmagick::setimagecolorspace ( int $colorspace ) : Gmagick

Sets the image colorspace.

参数

colorspace

The image colorspace: UndefinedColorspace, RGBColorspace, GRAYColorspace, TransparentColorspace, OHTAColorspace, XYZColorspace, YCbCrColorspace, YCCColorspace, YIQColorspace, YPbPrColorspace, YPbPrColorspace, YUVColorspace, CMYKColorspace, sRGBColorspace, HSLColorspace, or HWBColorspace.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the image composite operator

  • ? Gmagick::setimagecolorspace
  • Gmagick::setimagedelay ?
  • PHP Manual
  • Gmagick
  • Sets the image composite operator

Gmagick::setimagecompose

(PECL gmagick >= Unknown)

Gmagick::setimagecompose — Sets the image composite operator

说明

public Gmagick::setimagecompose ( int $composite ) : Gmagick

Sets the image composite operator.

参数

composite

The image composite operator.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the image delay

  • ? Gmagick::setimagecompose
  • Gmagick::setimagedepth ?
  • PHP Manual
  • Gmagick
  • Sets the image delay

Gmagick::setimagedelay

(PECL gmagick >= Unknown)

Gmagick::setimagedelay — Sets the image delay

说明

public Gmagick::setimagedelay ( int $delay ) : Gmagick

Sets the image delay

参数

delay

The image delay in 1/100th of a second.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image depth

  • ? Gmagick::setimagedelay
  • Gmagick::setimagedispose ?
  • PHP Manual
  • Gmagick
  • Sets the image depth

Gmagick::setimagedepth

(PECL gmagick >= Unknown)

Gmagick::setimagedepth — Sets the image depth

说明

public Gmagick::setimagedepth ( int $depth ) : Gmagick

Sets the image depth

参数

depth

The image depth in bits: 8, 16, or 32.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image disposal method

  • ? Gmagick::setimagedepth
  • Gmagick::setimagefilename ?
  • PHP Manual
  • Gmagick
  • Sets the image disposal method

Gmagick::setimagedispose

(PECL gmagick >= Unknown)

Gmagick::setimagedispose — Sets the image disposal method

说明

public Gmagick::setimagedispose ( int $disposeType ) : Gmagick

Sets the image disposal method.

参数

disposeType

The image disposal type.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the filename of a particular image in a sequence

  • ? Gmagick::setimagedispose
  • Gmagick::setimageformat ?
  • PHP Manual
  • Gmagick
  • Sets the filename of a particular image in a sequence

Gmagick::setimagefilename

(PECL gmagick >= Unknown)

Gmagick::setimagefilename — Sets the filename of a particular image in a sequence

说明

public Gmagick::setimagefilename ( string $filename ) : Gmagick

Sets the filename of a particular image in a sequence.

参数

filename

The image filename.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the format of a particular image

  • ? Gmagick::setimagefilename
  • Gmagick::setimagegamma ?
  • PHP Manual
  • Gmagick
  • Sets the format of a particular image

Gmagick::setimageformat

(PECL gmagick >= Unknown)

Gmagick::setimageformat — Sets the format of a particular image

说明

public Gmagick::setimageformat ( string $imageFormat ) : Gmagick

Sets the format of a particular image in a sequence.

参数

imageFormat

The image format.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image gamma

  • ? Gmagick::setimageformat
  • Gmagick::setimagegreenprimary ?
  • PHP Manual
  • Gmagick
  • Sets the image gamma

Gmagick::setimagegamma

(PECL gmagick >= Unknown)

Gmagick::setimagegamma — Sets the image gamma

说明

public Gmagick::setimagegamma ( float $gamma ) : Gmagick

Sets the image gamma.

参数

gamma

The image gamma.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the image chromaticity green primary point

  • ? Gmagick::setimagegamma
  • Gmagick::setimageindex ?
  • PHP Manual
  • Gmagick
  • Sets the image chromaticity green primary point

Gmagick::setimagegreenprimary

(PECL gmagick >= Unknown)

Gmagick::setimagegreenprimary — Sets the image chromaticity green primary point

说明

public Gmagick::setimagegreenprimary ( float $x , float $y ) : Gmagick

Sets the image chromaticity green primary point.

参数

x

The chromaticity green primary x-point.

y

The chromaticity green primary y-point.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Set the iterator to the position in the image list specified with the index parameter

  • ? Gmagick::setimagegreenprimary
  • Gmagick::setimageinterlacescheme ?
  • PHP Manual
  • Gmagick
  • Set the iterator to the position in the image list specified with the index parameter

Gmagick::setimageindex

(PECL gmagick >= Unknown)

Gmagick::setimageindex — Set the iterator to the position in the image list specified with the index parameter

说明

public Gmagick::setimageindex ( int $index ) : Gmagick

Set the iterator to the position in the image list specified with the index parameter.

参数

index

The scene number.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the interlace scheme of the image

  • ? Gmagick::setimageindex
  • Gmagick::setimageiterations ?
  • PHP Manual
  • Gmagick
  • Sets the interlace scheme of the image

Gmagick::setimageinterlacescheme

(PECL gmagick >= Unknown)

Gmagick::setimageinterlacescheme — Sets the interlace scheme of the image

说明

public Gmagick::setimageinterlacescheme ( int $interlace ) : Gmagick

Sets the interlace scheme of the image.

参数

interlace

The image interlace scheme: NoInterlace, LineInterlace, PlaneInterlace, PartitionInterlace.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Sets the image iterations

  • ? Gmagick::setimageinterlacescheme
  • Gmagick::setimageprofile ?
  • PHP Manual
  • Gmagick
  • Sets the image iterations

Gmagick::setimageiterations

(PECL gmagick >= Unknown)

Gmagick::setimageiterations — Sets the image iterations

说明

public Gmagick::setimageiterations ( int $iterations ) : Gmagick

Sets the image iterations.

参数

iterations

The image delay in 1/100th of a second.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Adds a named profile to the Gmagick object

  • ? Gmagick::setimageiterations
  • Gmagick::setimageredprimary ?
  • PHP Manual
  • Gmagick
  • Adds a named profile to the Gmagick object

Gmagick::setimageprofile

(PECL gmagick >= Unknown)

Gmagick::setimageprofile — Adds a named profile to the Gmagick object

说明

public Gmagick::setimageprofile ( string $name , string $profile ) : Gmagick

Adds a named profile to the Gmagick object. If a profile with the same name already exists, it is replaced. This method differs from the Gmagick::profileimage() method in that it does not apply any CMS color profiles.

参数

name

Name of profile to add or remove: ICC, IPTC, or generic profile.

profile

The profile.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image chromaticity red primary point

  • ? Gmagick::setimageprofile
  • Gmagick::setimagerenderingintent ?
  • PHP Manual
  • Gmagick
  • Sets the image chromaticity red primary point

Gmagick::setimageredprimary

(PECL gmagick >= Unknown)

Gmagick::setimageredprimary — Sets the image chromaticity red primary point

说明

public Gmagick::setimageredprimary ( float $x , float $y ) : Gmagick

Sets the image chromaticity red primary point.

参数

x

The red primary x-point.

y

The red primary y-point.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image rendering intent

  • ? Gmagick::setimageredprimary
  • Gmagick::setimageresolution ?
  • PHP Manual
  • Gmagick
  • Sets the image rendering intent

Gmagick::setimagerenderingintent

(PECL gmagick >= Unknown)

Gmagick::setimagerenderingintent — Sets the image rendering intent

说明

public Gmagick::setimagerenderingintent ( int $rendering_intent ) : Gmagick

Sets the image rendering intent.

参数

rendering_intent

The image rendering intent: UndefinedIntent, SaturationIntent, PerceptualIntent, AbsoluteIntent, or RelativeIntent.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image resolution

  • ? Gmagick::setimagerenderingintent
  • Gmagick::setimagescene ?
  • PHP Manual
  • Gmagick
  • Sets the image resolution

Gmagick::setimageresolution

(PECL gmagick >= Unknown)

Gmagick::setimageresolution — Sets the image resolution

说明

public Gmagick::setimageresolution ( float $xResolution , float $yResolution ) : Gmagick

Sets the image resolution.

参数

xResolution

The image x resolution.

yResolution

The image y resolution.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image scene

  • ? Gmagick::setimageresolution
  • Gmagick::setimagetype ?
  • PHP Manual
  • Gmagick
  • Sets the image scene

Gmagick::setimagescene

(PECL gmagick >= Unknown)

Gmagick::setimagescene — Sets the image scene

说明

public Gmagick::setimagescene ( int $scene ) : Gmagick

Sets the image scene.

参数

scene

The image scene number.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image type

  • ? Gmagick::setimagescene
  • Gmagick::setimageunits ?
  • PHP Manual
  • Gmagick
  • Sets the image type

Gmagick::setimagetype

(PECL gmagick >= Unknown)

Gmagick::setimagetype — Sets the image type

说明

public Gmagick::setimagetype ( int $imgType ) : Gmagick

Sets the image type.

参数

imgType

The image type: UndefinedType, BilevelType, GrayscaleType, GrayscaleMatteType, PaletteType, PaletteMatteType, TrueColorType, TrueColorMatteType, ColorSeparationType, ColorSeparationMatteType, or OptimizeType.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image units of resolution

  • ? Gmagick::setimagetype
  • Gmagick::setimagewhitepoint ?
  • PHP Manual
  • Gmagick
  • Sets the image units of resolution

Gmagick::setimageunits

(PECL gmagick >= Unknown)

Gmagick::setimageunits — Sets the image units of resolution

说明

public Gmagick::setimageunits ( int $resolution ) : Gmagick

Sets the image units of resolution.

参数

resolution

The image units of resolution : Undefinedresolution, PixelsPerInchResolution, or PixelsPerCentimeterResolution.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image chromaticity white point

  • ? Gmagick::setimageunits
  • Gmagick::setsamplingfactors ?
  • PHP Manual
  • Gmagick
  • Sets the image chromaticity white point

Gmagick::setimagewhitepoint

(PECL gmagick >= Unknown)

Gmagick::setimagewhitepoint — Sets the image chromaticity white point

说明

public Gmagick::setimagewhitepoint ( float $x , float $y ) : Gmagick

Sets the image chromaticity white point.

参数

x

The white x-point.

y

The white y-point.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the image sampling factors

  • ? Gmagick::setimagewhitepoint
  • Gmagick::setsize ?
  • PHP Manual
  • Gmagick
  • Sets the image sampling factors

Gmagick::setsamplingfactors

(PECL gmagick >= Unknown)

Gmagick::setsamplingfactors — Sets the image sampling factors

说明

public Gmagick::setsamplingfactors ( array $factors ) : Gmagick

Sets the image sampling factors.

参数

factors

An array of doubles representing the sampling factor for each color component (in RGB order).

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Sets the size of the Gmagick object

  • ? Gmagick::setsamplingfactors
  • Gmagick::shearimage ?
  • PHP Manual
  • Gmagick
  • Sets the size of the Gmagick object

Gmagick::setsize

(PECL gmagick >= Unknown)

Gmagick::setsize — Sets the size of the Gmagick object

说明

public Gmagick::setsize ( int $columns , int $rows ) : Gmagick

Sets the size of the Gmagick object. Set it before you read a raw image format such as RGB, GRAY, or CMYK.

参数

columns

The width in pixels.

rows

The height in pixels.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Creating a parallelogram

  • ? Gmagick::setsize
  • Gmagick::solarizeimage ?
  • PHP Manual
  • Gmagick
  • Creating a parallelogram

Gmagick::shearimage

(PECL gmagick >= Unknown)

Gmagick::shearimage — Creating a parallelogram

说明

public Gmagick::shearimage ( mixed $color , float $xShear , float $yShear ) : Gmagick

Slides one edge of an image along the X or Y axis, creating a parallelogram. An X direction shear slides an edge along the X axis, while a Y direction shear slides an edge along the Y axis. The amount of the shear is controlled by a shear angle. For X direction shears, x_shear is measured relative to the Y axis, and similarly, for Y direction shears y_shear is measured relative to the X axis. Empty triangles left over from shearing the image are filled with the background color.

参数

color

The background pixel wand.

xShear

The number of degrees to shear the image.

yShear

The number of degrees to shear the image.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Applies a solarizing effect to the image

  • ? Gmagick::shearimage
  • Gmagick::spreadimage ?
  • PHP Manual
  • Gmagick
  • Applies a solarizing effect to the image

Gmagick::solarizeimage

(PECL gmagick >= Unknown)

Gmagick::solarizeimage — Applies a solarizing effect to the image

说明

public Gmagick::solarizeimage ( int $threshold ) : Gmagick

Applies a special effect to the image, similar to the effect achieved in a photo darkroom by selectively exposing areas of photo sensitive paper to light. Threshold ranges from 0 to QuantumRange and is a measure of the extent of the solarization.

参数

threshold

Define the extent of the solarization.

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Randomly displaces each pixel in a block

  • ? Gmagick::solarizeimage
  • Gmagick::stripimage ?
  • PHP Manual
  • Gmagick
  • Randomly displaces each pixel in a block

Gmagick::spreadimage

(PECL gmagick >= Unknown)

Gmagick::spreadimage — Randomly displaces each pixel in a block

说明

public Gmagick::spreadimage ( float $radius ) : Gmagick

Special effects method that randomly displaces each pixel in a block defined by the radius parameter.

参数

radius

Choose a random pixel in a neighborhood of this extent.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Strips an image of all profiles and comments

  • ? Gmagick::spreadimage
  • Gmagick::swirlimage ?
  • PHP Manual
  • Gmagick
  • Strips an image of all profiles and comments

Gmagick::stripimage

(PECL gmagick >= Unknown)

Gmagick::stripimage — Strips an image of all profiles and comments

说明

public Gmagick::stripimage ( ) : Gmagick

Strips an image of all profiles and comments.

参数

此函数没有参数。

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Swirls the pixels about the center of the image

  • ? Gmagick::stripimage
  • Gmagick::thumbnailimage ?
  • PHP Manual
  • Gmagick
  • Swirls the pixels about the center of the image

Gmagick::swirlimage

(PECL gmagick >= Unknown)

Gmagick::swirlimage — Swirls the pixels about the center of the image

说明

public Gmagick::swirlimage ( float $degrees ) : Gmagick

Swirls the pixels about the center of the image, where degrees indicates the sweep of the arc through which each pixel is moved. You get a more dramatic effect as the degrees move from 1 to 360.

参数

degrees

Define the tightness of the swirling effect.

返回值

The Gmagick object on success

错误／异常

错误时抛出 GmagickException。


Changes the size of an image

  • ? Gmagick::swirlimage
  • Gmagick::trimimage ?
  • PHP Manual
  • Gmagick
  • Changes the size of an image

Gmagick::thumbnailimage

(PECL gmagick >= Unknown)

Gmagick::thumbnailimage — Changes the size of an image

说明

public Gmagick::thumbnailimage ( int $width , int $height , bool $fit = false ) : Gmagick

Changes the size of an image to the given dimensions and removes any associated profiles. The goal is to produce small low cost thumbnail images suited for display on the Web. If TRUE is given as a third parameter then columns and rows parameters are used as maximums for each side. Both sides will be scaled down until the match or are smaller than the parameter given for the side.

参数

width

Image width

height

Image height

返回值

The Gmagick object on success.

错误／异常

错误时抛出 GmagickException。


Remove edges from the image

  • ? Gmagick::thumbnailimage
  • Gmagick::write ?
  • PHP Manual
  • Gmagick
  • Remove edges from the image

Gmagick::trimimage

(PECL gmagick >= Unknown)

Gmagick::trimimage — Remove edges from the image

说明

public Gmagick::trimimage ( float $fuzz ) : Gmagick

Remove edges that are the background color from the image.

参数

fuzz

By default target must match a particular pixel color exactly. However, in many cases two colors may differ by a small amount. The fuzz member of image defines how much tolerance is acceptable to consider two colors as the same. This parameter represents the variation on the quantum range.

返回值

The Gmagick object

错误／异常

错误时抛出 GmagickException。


别名 Gmagick::writeimage

  • ? Gmagick::trimimage
  • Gmagick::writeimage ?
  • PHP Manual
  • Gmagick
  • 别名 Gmagick::writeimage

Gmagick::write

(PECL gmagick >= Unknown)

Gmagick::write — 别名 Gmagick::writeimage()

说明

此方法是该方法的别名： Gmagick::writeimage().


Writes an image to the specified filename

  • ? Gmagick::write
  • GmagickDraw ?
  • PHP Manual
  • Gmagick
  • Writes an image to the specified filename

Gmagick::writeimage

(PECL gmagick >= Unknown)

Gmagick::writeimage — Writes an image to the specified filename

说明

public Gmagick::writeimage ( string $filename , bool $all_frames = false ) : Gmagick

Writes an image to the specified filename. If the filename parameter is NULL, the image is written to the filename set by Gmagick::ReadImage() or Gmagick::SetImageFilename().

参数

filename

The image filename.

返回值

The Gmagick object

错误／异常

错误时抛出 GmagickException。


The GmagickDraw class

(PECL gmagick >= Unknown)

简介

类摘要

GmagickDraw {
/* 方法 */
public annotate ( float $x , float $y , string $text ) : GmagickDraw
public arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed ) : GmagickDraw
public bezier ( array $coordinate_array ) : GmagickDraw
public ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end ) : GmagickDraw
public getfillcolor ( ) : GmagickPixel
public getfillopacity ( ) : float
public getfont ( ) : mixed
public getfontsize ( ) : float
public getfontstyle ( ) : int
public getfontweight ( ) : int
public getstrokecolor ( ) : GmagickPixel
public getstrokeopacity ( ) : float
public getstrokewidth ( ) : float
public gettextdecoration ( ) : int
public gettextencoding ( ) : mixed
public line ( float $sx , float $sy , float $ex , float $ey ) : GmagickDraw
public point ( float $x , float $y ) : GmagickDraw
public polygon ( array $coordinates ) : GmagickDraw
public polyline ( array $coordinate_array ) : GmagickDraw
public rectangle ( float $x1 , float $y1 , float $x2 , float $y2 ) : GmagickDraw
public rotate ( float $degrees ) : GmagickDraw
public roundrectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry ) : GmagickDraw
public scale ( float $x , float $y ) : GmagickDraw
public setfillcolor ( mixed $color ) : GmagickDraw
public setfillopacity ( float $fill_opacity ) : GmagickDraw
public setfont ( string $font ) : GmagickDraw
public setfontsize ( float $pointsize ) : GmagickDraw
public setfontstyle ( int $style ) : GmagickDraw
public setfontweight ( int $weight ) : GmagickDraw
public setstrokecolor ( mixed $color ) : GmagickDraw
public setstrokeopacity ( float $stroke_opacity ) : GmagickDraw
public setstrokewidth ( float $width ) : GmagickDraw
public settextdecoration ( int $decoration ) : GmagickDraw
public settextencoding ( string $encoding ) : GmagickDraw
}

Table of Contents

  • GmagickDraw::annotate — Draws text on the image
  • GmagickDraw::arc — Draws an arc
  • GmagickDraw::bezier — Draws a bezier curve
  • GmagickDraw::ellipse — Draws an ellipse on the image
  • GmagickDraw::getfillcolor — Returns the fill color
  • GmagickDraw::getfillopacity — Returns the opacity used when drawing
  • GmagickDraw::getfont — Returns the font
  • GmagickDraw::getfontsize — Returns the font pointsize
  • GmagickDraw::getfontstyle — Returns the font style
  • GmagickDraw::getfontweight — Returns the font weight
  • GmagickDraw::getstrokecolor — Returns the color used for stroking object outlines
  • GmagickDraw::getstrokeopacity — Returns the opacity of stroked object outlines
  • GmagickDraw::getstrokewidth — Returns the width of the stroke used to draw object outlines
  • GmagickDraw::gettextdecoration — Returns the text decoration
  • GmagickDraw::gettextencoding — Returns the code set used for text annotations
  • GmagickDraw::line — The line purpose
  • GmagickDraw::point — Draws a point
  • GmagickDraw::polygon — Draws a polygon
  • GmagickDraw::polyline — Draws a polyline
  • GmagickDraw::rectangle — Draws a rectangle
  • GmagickDraw::rotate — Applies the specified rotation to the current coordinate space
  • GmagickDraw::roundrectangle — Draws a rounded rectangle
  • GmagickDraw::scale — Adjusts the scaling factor
  • GmagickDraw::setfillcolor — Sets the fill color to be used for drawing filled objects
  • GmagickDraw::setfillopacity — The setfillopacity purpose
  • GmagickDraw::setfont — Sets the fully-specified font to use when annotating with text
  • GmagickDraw::setfontsize — Sets the font pointsize to use when annotating with text
  • GmagickDraw::setfontstyle — Sets the font style to use when annotating with text
  • GmagickDraw::setfontweight — Sets the font weight
  • GmagickDraw::setstrokecolor — Sets the color used for stroking object outlines
  • GmagickDraw::setstrokeopacity — Specifies the opacity of stroked object outlines
  • GmagickDraw::setstrokewidth — Sets the width of the stroke used to draw object outlines
  • GmagickDraw::settextdecoration — Specifies a decoration
  • GmagickDraw::settextencoding — Specifies the text code set


Draws text on the image

  • ? GmagickDraw
  • GmagickDraw::arc ?
  • PHP Manual
  • GmagickDraw
  • Draws text on the image

GmagickDraw::annotate

(PECL gmagick >= Unknown)

GmagickDraw::annotate — Draws text on the image

说明

public GmagickDraw::annotate ( float $x , float $y , string $text ) : GmagickDraw

Draws text on the image.

参数

x

x ordinate to left of text

y

y ordinate to text baseline

text

text to draw

返回值

The GmagickDraw object on success.


Draws an arc

  • ? GmagickDraw::annotate
  • GmagickDraw::bezier ?
  • PHP Manual
  • GmagickDraw
  • Draws an arc

GmagickDraw::arc

(PECL gmagick >= Unknown)

GmagickDraw::arc — Draws an arc

说明

public GmagickDraw::arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed ) : GmagickDraw

Draws an arc falling within a specified bounding rectangle on the image.

参数

sx

starting x ordinate of bounding rectangle

sy

starting y ordinate of bounding rectangle

ex

ending x ordinate of bounding rectangle

ey

ending y ordinate of bounding rectangle

sd

starting degrees of rotation

ed

ending degrees of rotation

返回值

The GmagickDraw object on success.


Draws a bezier curve

  • ? GmagickDraw::arc
  • GmagickDraw::ellipse ?
  • PHP Manual
  • GmagickDraw
  • Draws a bezier curve

GmagickDraw::bezier

(PECL gmagick >= Unknown)

GmagickDraw::bezier — Draws a bezier curve

说明

public GmagickDraw::bezier ( array $coordinate_array ) : GmagickDraw

Draws a bezier curve through a set of points on the image.

参数

coordinate_array

Coordinates array

返回值

The GmagickDraw object on success


Draws an ellipse on the image

  • ? GmagickDraw::bezier
  • GmagickDraw::getfillcolor ?
  • PHP Manual
  • GmagickDraw
  • Draws an ellipse on the image

GmagickDraw::ellipse

(PECL gmagick >= Unknown)

GmagickDraw::ellipse — Draws an ellipse on the image

说明

public GmagickDraw::ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end ) : GmagickDraw

Draws an ellipse on the image.

参数

ox

origin x ordinate

oy

origin y ordinate

rx

radius in x

ry

radius in y

start

starting rotation in degrees

end

ending rotation in degrees

返回值

The GmagickDraw object on success


Returns the fill color

  • ? GmagickDraw::ellipse
  • GmagickDraw::getfillopacity ?
  • PHP Manual
  • GmagickDraw
  • Returns the fill color

GmagickDraw::getfillcolor

(PECL gmagick >= Unknown)

GmagickDraw::getfillcolor — Returns the fill color

说明

public GmagickDraw::getfillcolor ( ) : GmagickPixel

Returns the fill color used for drawing filled objects.

参数

此函数没有参数。

返回值

The GmagickPixel fill color used for drawing filled objects.


Returns the opacity used when drawing

  • ? GmagickDraw::getfillcolor
  • GmagickDraw::getfont ?
  • PHP Manual
  • GmagickDraw
  • Returns the opacity used when drawing

GmagickDraw::getfillopacity

(PECL gmagick >= Unknown)

GmagickDraw::getfillopacity — Returns the opacity used when drawing

说明

public GmagickDraw::getfillopacity ( ) : float

Returns the opacity used when drawing

参数

此函数没有参数。

返回值

Returns the opacity used when drawing using the fill color or fill texture. Fully opaque is 1.0.


Returns the font

  • ? GmagickDraw::getfillopacity
  • GmagickDraw::getfontsize ?
  • PHP Manual
  • GmagickDraw
  • Returns the font

GmagickDraw::getfont

(PECL gmagick >= Unknown)

GmagickDraw::getfont — Returns the font

说明

public GmagickDraw::getfont ( ) : mixed

Returns a string specifying the font used when annotating with text.

参数

此函数没有参数。

返回值

Returns a string on success and false if no font is set.


Returns the font pointsize

  • ? GmagickDraw::getfont
  • GmagickDraw::getfontstyle ?
  • PHP Manual
  • GmagickDraw
  • Returns the font pointsize

GmagickDraw::getfontsize

(PECL gmagick >= Unknown)

GmagickDraw::getfontsize — Returns the font pointsize

说明

public GmagickDraw::getfontsize ( ) : float

Returns the font pointsize used when annotating with text.

参数

此函数没有参数。

返回值

Returns the font size associated with the current GmagickDraw object.


Returns the font style

  • ? GmagickDraw::getfontsize
  • GmagickDraw::getfontweight ?
  • PHP Manual
  • GmagickDraw
  • Returns the font style

GmagickDraw::getfontstyle

(PECL gmagick >= Unknown)

GmagickDraw::getfontstyle — Returns the font style

说明

public GmagickDraw::getfontstyle ( ) : int

Returns the font style used when annotating with text.

参数

此函数没有参数。

返回值

Returns the font style constant (STYLE_) associated with the GmagickDraw object or 0 if no style is set.


Returns the font weight

  • ? GmagickDraw::getfontstyle
  • GmagickDraw::getstrokecolor ?
  • PHP Manual
  • GmagickDraw
  • Returns the font weight

GmagickDraw::getfontweight

(PECL gmagick >= Unknown)

GmagickDraw::getfontweight — Returns the font weight

说明

public GmagickDraw::getfontweight ( ) : int

Returns the font weight used when annotating with text.

参数

此函数没有参数。

返回值

Returns an int on success and 0 if no weight is set.


Returns the color used for stroking object outlines

  • ? GmagickDraw::getfontweight
  • GmagickDraw::getstrokeopacity ?
  • PHP Manual
  • GmagickDraw
  • Returns the color used for stroking object outlines

GmagickDraw::getstrokecolor

(PECL gmagick >= Unknown)

GmagickDraw::getstrokecolor — Returns the color used for stroking object outlines

说明

public GmagickDraw::getstrokecolor ( ) : GmagickPixel

Returns the color used for stroking object outlines.

参数

此函数没有参数。

返回值

Returns an GmagickPixel object which describes the color.


Returns the opacity of stroked object outlines

  • ? GmagickDraw::getstrokecolor
  • GmagickDraw::getstrokewidth ?
  • PHP Manual
  • GmagickDraw
  • Returns the opacity of stroked object outlines

GmagickDraw::getstrokeopacity

(PECL gmagick >= Unknown)

GmagickDraw::getstrokeopacity — Returns the opacity of stroked object outlines

说明

public GmagickDraw::getstrokeopacity ( ) : float

Returns the opacity of stroked object outlines.

参数

此函数没有参数。

返回值

Returns a double describing the opacity.


Returns the width of the stroke used to draw object outlines

  • ? GmagickDraw::getstrokeopacity
  • GmagickDraw::gettextdecoration ?
  • PHP Manual
  • GmagickDraw
  • Returns the width of the stroke used to draw object outlines

GmagickDraw::getstrokewidth

(PECL gmagick >= Unknown)

GmagickDraw::getstrokewidth — Returns the width of the stroke used to draw object outlines

说明

public GmagickDraw::getstrokewidth ( ) : float

Returns the width of the stroke used to draw object outlines.

参数

此函数没有参数。

返回值

Returns a double describing the stroke width.


Returns the text decoration

  • ? GmagickDraw::getstrokewidth
  • GmagickDraw::gettextencoding ?
  • PHP Manual
  • GmagickDraw
  • Returns the text decoration

GmagickDraw::gettextdecoration

(PECL gmagick >= Unknown)

GmagickDraw::gettextdecoration — Returns the text decoration

说明

public GmagickDraw::gettextdecoration ( ) : int

Returns the decoration applied when annotating with text.

参数

此函数没有参数。

返回值

Returns one of the DECORATION_ constants and 0 if no decoration is set.


Returns the code set used for text annotations

  • ? GmagickDraw::gettextdecoration
  • GmagickDraw::line ?
  • PHP Manual
  • GmagickDraw
  • Returns the code set used for text annotations

GmagickDraw::gettextencoding

(PECL gmagick >= Unknown)

GmagickDraw::gettextencoding — Returns the code set used for text annotations

说明

public GmagickDraw::gettextencoding ( ) : mixed

Returns a string which specifies the code set used for text annotations.

参数

此函数没有参数。

返回值

Returns a string specifying the code set or false if text encoding is not set.


The line purpose

  • ? GmagickDraw::gettextencoding
  • GmagickDraw::point ?
  • PHP Manual
  • GmagickDraw
  • The line purpose

GmagickDraw::line

(PECL gmagick >= Unknown)

GmagickDraw::line — The line purpose

说明

public GmagickDraw::line ( float $sx , float $sy , float $ex , float $ey ) : GmagickDraw

Draws a line on the image using the current stroke color, stroke opacity, and stroke width.

参数

sx

starting x ordinate

sy

starting y ordinate

ex

ending x ordinate

ey

ending y ordinate

返回值

The GmagickDraw object on success


Draws a point

  • ? GmagickDraw::line
  • GmagickDraw::polygon ?
  • PHP Manual
  • GmagickDraw
  • Draws a point

GmagickDraw::point

(PECL gmagick >= Unknown)

GmagickDraw::point — Draws a point

说明

public GmagickDraw::point ( float $x , float $y ) : GmagickDraw

Draws a point using the current stroke color and stroke thickness at the specified coordinates.

参数

x

target x coordinate

y

target y coordinate

返回值

The GmagickDraw object on success


Draws a polygon

  • ? GmagickDraw::point
  • GmagickDraw::polyline ?
  • PHP Manual
  • GmagickDraw
  • Draws a polygon

GmagickDraw::polygon

(PECL gmagick >= Unknown)

GmagickDraw::polygon — Draws a polygon

说明

public GmagickDraw::polygon ( array $coordinates ) : GmagickDraw

Draws a polygon using the current stroke, stroke width, and fill color or texture, using the specified array of coordinates.

参数

coordinates

coordinate array

返回值

The GmagickDraw object on success


Draws a polyline

  • ? GmagickDraw::polygon
  • GmagickDraw::rectangle ?
  • PHP Manual
  • GmagickDraw
  • Draws a polyline

GmagickDraw::polyline

(PECL gmagick >= Unknown)

GmagickDraw::polyline — Draws a polyline

说明

public GmagickDraw::polyline ( array $coordinate_array ) : GmagickDraw

Draws a polyline using the current stroke, stroke width, and fill color or texture, using the specified array of coordinates.

参数

coordinate_array

The array of coordinates

返回值

The GmagickDraw object on success


Draws a rectangle

  • ? GmagickDraw::polyline
  • GmagickDraw::rotate ?
  • PHP Manual
  • GmagickDraw
  • Draws a rectangle

GmagickDraw::rectangle

(PECL gmagick >= Unknown)

GmagickDraw::rectangle — Draws a rectangle

说明

public GmagickDraw::rectangle ( float $x1 , float $y1 , float $x2 , float $y2 ) : GmagickDraw

Draws a rectangle given two coordinates and using the current stroke, stroke width, and fill settings.

参数

x1

x ordinate of first coordinate

y1

y ordinate of first coordinate

x2

x ordinate of second coordinate

y2

y ordinate of second coordinate

返回值

The GmagickDraw object on success


Applies the specified rotation to the current coordinate space

  • ? GmagickDraw::rectangle
  • GmagickDraw::roundrectangle ?
  • PHP Manual
  • GmagickDraw
  • Applies the specified rotation to the current coordinate space

GmagickDraw::rotate

(PECL gmagick >= Unknown)

GmagickDraw::rotate — Applies the specified rotation to the current coordinate space

说明

public GmagickDraw::rotate ( float $degrees ) : GmagickDraw

Applies the specified rotation to the current coordinate space.

参数

degrees

degrees of rotation

返回值

The GmagickDraw object on success


Draws a rounded rectangle

  • ? GmagickDraw::rotate
  • GmagickDraw::scale ?
  • PHP Manual
  • GmagickDraw
  • Draws a rounded rectangle

GmagickDraw::roundrectangle

(PECL gmagick >= Unknown)

GmagickDraw::roundrectangle — Draws a rounded rectangle

说明

public GmagickDraw::roundrectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry ) : GmagickDraw

Draws a rounded rectangle given two coordinates, x and y corner radiuses and using the current stroke, stroke width, and fill settings.

参数

x1

x ordinate of first coordinate

y1

y ordinate of first coordinate

x2

x ordinate of second coordinate

y2

y ordinate of second coordinate

rx

radius of corner in horizontal direction

ry

radius of corner in vertical direction

返回值

The GmagickDraw object on success


Adjusts the scaling factor

  • ? GmagickDraw::roundrectangle
  • GmagickDraw::setfillcolor ?
  • PHP Manual
  • GmagickDraw
  • Adjusts the scaling factor

GmagickDraw::scale

(PECL gmagick >= Unknown)

GmagickDraw::scale — Adjusts the scaling factor

说明

public GmagickDraw::scale ( float $x , float $y ) : GmagickDraw

Adjusts the scaling factor to apply in the horizontal and vertical directions to the current coordinate space.

参数

x

horizontal scale factor

y

vertical scale factor

返回值

The GmagickDraw object on success


Sets the fill color to be used for drawing filled objects

  • ? GmagickDraw::scale
  • GmagickDraw::setfillopacity ?
  • PHP Manual
  • GmagickDraw
  • Sets the fill color to be used for drawing filled objects

GmagickDraw::setfillcolor

(PECL gmagick >= Unknown)

GmagickDraw::setfillcolor — Sets the fill color to be used for drawing filled objects

说明

public GmagickDraw::setfillcolor ( mixed $color ) : GmagickDraw

Sets the fill color to be used for drawing filled objects.

参数

color

GmagickPixel or string indicating color to use for filling.

返回值

The GmagickDraw object on success.


The setfillopacity purpose

  • ? GmagickDraw::setfillcolor
  • GmagickDraw::setfont ?
  • PHP Manual
  • GmagickDraw
  • The setfillopacity purpose

GmagickDraw::setfillopacity

(PECL gmagick >= Unknown)

GmagickDraw::setfillopacity — The setfillopacity purpose

说明

public GmagickDraw::setfillopacity ( float $fill_opacity ) : GmagickDraw

Sets the opacity to use when drawing using the fill color or fill texture. Setting it to 1.0 will make fill full opaque.

参数

fill_opacity

Fill opacity

返回值

The GmagickDraw object on success


Sets the fully-specified font to use when annotating with text

  • ? GmagickDraw::setfillopacity
  • GmagickDraw::setfontsize ?
  • PHP Manual
  • GmagickDraw
  • Sets the fully-specified font to use when annotating with text

GmagickDraw::setfont

(PECL gmagick >= Unknown)

GmagickDraw::setfont — Sets the fully-specified font to use when annotating with text

说明

public GmagickDraw::setfont ( string $font ) : GmagickDraw

Sets the fully-specified font to use when annotating with text

参数

font

font name

返回值

The GmagickDraw object on success


Sets the font pointsize to use when annotating with text

  • ? GmagickDraw::setfont
  • GmagickDraw::setfontstyle ?
  • PHP Manual
  • GmagickDraw
  • Sets the font pointsize to use when annotating with text

GmagickDraw::setfontsize

(PECL gmagick >= Unknown)

GmagickDraw::setfontsize — Sets the font pointsize to use when annotating with text

说明

public GmagickDraw::setfontsize ( float $pointsize ) : GmagickDraw

Sets the font pointsize to use when annotating with text.

参数

pointsize

Text pointsize

返回值

The GmagickDraw object on success


Sets the font style to use when annotating with text

  • ? GmagickDraw::setfontsize
  • GmagickDraw::setfontweight ?
  • PHP Manual
  • GmagickDraw
  • Sets the font style to use when annotating with text

GmagickDraw::setfontstyle

(PECL gmagick >= Unknown)

GmagickDraw::setfontstyle — Sets the font style to use when annotating with text

说明

public GmagickDraw::setfontstyle ( int $style ) : GmagickDraw

Sets the font style to use when annotating with text. The AnyStyle enumeration acts as a wild-card "don't care" option.

参数

style

Font style (NormalStyle, ItalicStyle, ObliqueStyle, AnyStyle)

返回值

The GmagickDraw object on success


Sets the font weight

  • ? GmagickDraw::setfontstyle
  • GmagickDraw::setstrokecolor ?
  • PHP Manual
  • GmagickDraw
  • Sets the font weight

GmagickDraw::setfontweight

(PECL gmagick >= Unknown)

GmagickDraw::setfontweight — Sets the font weight

说明

public GmagickDraw::setfontweight ( int $weight ) : GmagickDraw

Sets the font weight to use when annotating with text.

参数

weight

Font weight (valid range 100-900)

返回值

The GmagickDraw object on success


Sets the color used for stroking object outlines

  • ? GmagickDraw::setfontweight
  • GmagickDraw::setstrokeopacity ?
  • PHP Manual
  • GmagickDraw
  • Sets the color used for stroking object outlines

GmagickDraw::setstrokecolor

(PECL gmagick >= Unknown)

GmagickDraw::setstrokecolor — Sets the color used for stroking object outlines

说明

public GmagickDraw::setstrokecolor ( mixed $color ) : GmagickDraw

Sets the color used for stroking object outlines.

参数

color

GmagickPixel or string representing the color for the stroke.

返回值

The GmagickDraw object on success.


Specifies the opacity of stroked object outlines

  • ? GmagickDraw::setstrokecolor
  • GmagickDraw::setstrokewidth ?
  • PHP Manual
  • GmagickDraw
  • Specifies the opacity of stroked object outlines

GmagickDraw::setstrokeopacity

(PECL gmagick >= Unknown)

GmagickDraw::setstrokeopacity — Specifies the opacity of stroked object outlines

说明

public GmagickDraw::setstrokeopacity ( float $stroke_opacity ) : GmagickDraw

Specifies the opacity of stroked object outlines.

参数

stroke_opacity

Stroke opacity. The value 1.0 is opaque.

返回值

The GmagickDraw object on success


Sets the width of the stroke used to draw object outlines

  • ? GmagickDraw::setstrokeopacity
  • GmagickDraw::settextdecoration ?
  • PHP Manual
  • GmagickDraw
  • Sets the width of the stroke used to draw object outlines

GmagickDraw::setstrokewidth

(PECL gmagick >= Unknown)

GmagickDraw::setstrokewidth — Sets the width of the stroke used to draw object outlines

说明

public GmagickDraw::setstrokewidth ( float $width ) : GmagickDraw

Sets the width of the stroke used to draw object outlines

参数

width

Stroke width

返回值

The GmagickDraw object on success


Specifies a decoration

  • ? GmagickDraw::setstrokewidth
  • GmagickDraw::settextencoding ?
  • PHP Manual
  • GmagickDraw
  • Specifies a decoration

GmagickDraw::settextdecoration

(PECL gmagick >= Unknown)

GmagickDraw::settextdecoration — Specifies a decoration

说明

public GmagickDraw::settextdecoration ( int $decoration ) : GmagickDraw

Specifies a decoration to be applied when annotating with text.

参数

int

Text decoration. One of NoDecoration, UnderlineDecoration, OverlineDecoration, or LineThroughDecoration

返回值

The GmagickDraw object on success


Specifies the text code set

  • ? GmagickDraw::settextdecoration
  • GmagickPixel ?
  • PHP Manual
  • GmagickDraw
  • Specifies the text code set

GmagickDraw::settextencoding

(PECL gmagick >= Unknown)

GmagickDraw::settextencoding — Specifies the text code set

说明

public GmagickDraw::settextencoding ( string $encoding ) : GmagickDraw

Specifies the code set to use for text annotations. The only character encoding which may be specified at this time is "UTF-8" for representing Unicode as a sequence of bytes. Specify an empty string to set text encoding to the system's default. Successful text annotation using Unicode may require fonts designed to support Unicode.

参数

encoding

Character string specifying text encoding

返回值

The GmagickDraw object on success


The GmagickPixel class

(PECL gmagick >= Unknown)

简介

类摘要

GmagickPixel {
/* 方法 */
public __construct ( string $color = ? )
public getcolor ( bool $as_array = false , bool $normalize_array = false ) : mixed
public getcolorcount ( ) : int
public getcolorvalue ( int $color ) : float
public setcolor ( string $color ) : GmagickPixel
public setcolorvalue ( int $color , float $value ) : GmagickPixel
}

Table of Contents

  • GmagickPixel::__construct — The GmagickPixel constructor
  • GmagickPixel::getcolor — Returns the color
  • GmagickPixel::getcolorcount — Returns the color count associated with this color
  • GmagickPixel::getcolorvalue — Gets the normalized value of the provided color channel
  • GmagickPixel::setcolor — Sets the color
  • GmagickPixel::setcolorvalue — Sets the normalized value of one of the channels


The GmagickPixel constructor

  • ? GmagickPixel
  • GmagickPixel::getcolor ?
  • PHP Manual
  • GmagickPixel
  • The GmagickPixel constructor

GmagickPixel::__construct

(PECL gmagick >= Unknown)

GmagickPixel::__construct — The GmagickPixel constructor

说明

public GmagickPixel::__construct ( string $color = ? )

Constructs an GmagickPixel object. If a color is specified, the object is constructed and then initialised with that color before being returned.

参数

color

The optional color string to use as the initial value of this object.

返回值

The GmagickPixel object on success.


Returns the color

  • ? GmagickPixel::__construct
  • GmagickPixel::getcolorcount ?
  • PHP Manual
  • GmagickPixel
  • Returns the color

GmagickPixel::getcolor

(PECL gmagick >= Unknown)

GmagickPixel::getcolor — Returns the color

说明

public GmagickPixel::getcolor ( bool $as_array = false , bool $normalize_array = false ) : mixed

Returns the color described by the GmagickPixel object, as a string or an array. If the color has an opacity channel set, this is provided as a fourth value in the list.

参数

as_array

true to indicate return of array instead of string.

normalize_array

true to normalize the color values.

返回值

A string or an array of channel values, each normalized if true is given as normalize_array. Throws GmagickPixelException on error.


Returns the color count associated with this color

  • ? GmagickPixel::getcolor
  • GmagickPixel::getcolorvalue ?
  • PHP Manual
  • GmagickPixel
  • Returns the color count associated with this color

GmagickPixel::getcolorcount

(PECL gmagick >= Unknown)

GmagickPixel::getcolorcount — Returns the color count associated with this color

说明

public GmagickPixel::getcolorcount ( ) : int

Returns the color count associated with this color

参数

此函数没有参数。

返回值

Returns the color count as an integer on success, throws GmagickPixelException on failure.


Gets the normalized value of the provided color channel

  • ? GmagickPixel::getcolorcount
  • GmagickPixel::setcolor ?
  • PHP Manual
  • GmagickPixel
  • Gets the normalized value of the provided color channel

GmagickPixel::getcolorvalue

(PECL gmagick >= Unknown)

GmagickPixel::getcolorvalue — Gets the normalized value of the provided color channel

说明

public GmagickPixel::getcolorvalue ( int $color ) : float

Retrieves the value of the color channel specified, as a floating-point number between 0 and 1.

参数

color

The channel to check, specified as one of the Gmagick channel constants.

返回值

The value of the channel, as a normalized floating-point number, throwing GmagickPixelException on error.


Sets the color

  • ? GmagickPixel::getcolorvalue
  • GmagickPixel::setcolorvalue ?
  • PHP Manual
  • GmagickPixel
  • Sets the color

GmagickPixel::setcolor

(PECL gmagick >= Unknown)

GmagickPixel::setcolor — Sets the color

说明

public GmagickPixel::setcolor ( string $color ) : GmagickPixel

Sets the color described by the GmagickPixel object, with a string (e.g. "blue", "#0000ff", "rgb(0,0,255)", "cmyk(100,100,100,10)", etc.).

参数

color

The color definition to use in order to initialise the GmagickPixel object.

返回值

The GmagickPixel object on success.


Sets the normalized value of one of the channels

  • ? GmagickPixel::setcolor
  • ImageMagick ?
  • PHP Manual
  • GmagickPixel
  • Sets the normalized value of one of the channels

GmagickPixel::setcolorvalue

(PECL gmagick >= Unknown)

GmagickPixel::setcolorvalue — Sets the normalized value of one of the channels

说明

public GmagickPixel::setcolorvalue ( int $color , float $value ) : GmagickPixel

Sets the value of the specified channel of this object to the provided value, which should be between 0 and 1. This function can be used to provide an opacity channel to a GmagickPixel object.

参数

color

One of the Gmagick channel color constants.

value

The value to set this channel to, ranging from 0 to 1.

返回值

The GmagickPixel object on success.


图像处理(ImageMagick)

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic usage
  • Imagick — The Imagick class
    • Imagick::adaptiveBlurImage — Adds adaptive blur filter to image
    • Imagick::adaptiveResizeImage — Adaptively resize image with data dependent triangulation
    • Imagick::adaptiveSharpenImage — Adaptively sharpen the image
    • Imagick::adaptiveThresholdImage — Selects a threshold for each pixel based on a range of intensity
    • Imagick::addImage — Adds new image to Imagick object image list
    • Imagick::addNoiseImage — Adds random noise to the image
    • Imagick::affineTransformImage — Transforms an image
    • Imagick::animateImages — Animates an image or images
    • Imagick::annotateImage — Annotates an image with text
    • Imagick::appendImages — Append a set of images
    • Imagick::autoLevelImage — Description
    • Imagick::averageImages — Average a set of images
    • Imagick::blackThresholdImage — Forces all pixels below the threshold into black
    • Imagick::blueShiftImage — Description
    • Imagick::blurImage — Adds blur filter to image
    • Imagick::borderImage — Surrounds the image with a border
    • Imagick::brightnessContrastImage — Description
    • Imagick::charcoalImage — Simulates a charcoal drawing
    • Imagick::chopImage — Removes a region of an image and trims
    • Imagick::clampImage — Description
    • Imagick::clear — Clears all resources associated to Imagick object
    • Imagick::clipImage — Clips along the first path from the 8BIM profile
    • Imagick::clipImagePath — Description
    • Imagick::clipPathImage — Clips along the named paths from the 8BIM profile
    • Imagick::clone — Makes an exact copy of the Imagick object
    • Imagick::clutImage — Replaces colors in the image
    • Imagick::coalesceImages — Composites a set of images
    • Imagick::colorFloodfillImage — Changes the color value of any pixel that matches target
    • Imagick::colorizeImage — Blends the fill color with the image
    • Imagick::colorMatrixImage — Description
    • Imagick::combineImages — Combines one or more images into a single image
    • Imagick::commentImage — Adds a comment to your image
    • Imagick::compareImageChannels — Returns the difference in one or more images
    • Imagick::compareImageLayers — Returns the maximum bounding region between images
    • Imagick::compareImages — Compares an image to a reconstructed image
    • Imagick::compositeImage — 把一张图合并到一张图
    • Imagick::__construct — The Imagick constructor
    • Imagick::contrastImage — Change the contrast of the image
    • Imagick::contrastStretchImage — Enhances the contrast of a color image
    • Imagick::convolveImage — Applies a custom convolution kernel to the image
    • Imagick::count — Get the number of images
    • Imagick::cropImage — 截图图片的一块区域
    • Imagick::cropThumbnailImage — 创建缩略图
    • Imagick::current — Returns a reference to the current Imagick object
    • Imagick::cycleColormapImage — Displaces an image's colormap
    • Imagick::decipherImage — Deciphers an image
    • Imagick::deconstructImages — Returns certain pixel differences between images
    • Imagick::deleteImageArtifact — Delete image artifact
    • Imagick::deleteImageProperty — Description
    • Imagick::deskewImage — Removes skew from the image
    • Imagick::despeckleImage — Reduces the speckle noise in an image
    • Imagick::destroy — Destroys the Imagick object
    • Imagick::displayImage — Displays an image
    • Imagick::displayImages — Displays an image or image sequence
    • Imagick::distortImage — Distorts an image using various distortion methods
    • Imagick::drawImage — 把 ImagickDraw 对象渲染到当前图片上
    • Imagick::edgeImage — Enhance edges within the image
    • Imagick::embossImage — Returns a grayscale image with a three-dimensional effect
    • Imagick::encipherImage — Enciphers an image
    • Imagick::enhanceImage — Improves the quality of a noisy image
    • Imagick::equalizeImage — Equalizes the image histogram
    • Imagick::evaluateImage — Applies an expression to an image
    • Imagick::exportImagePixels — Exports raw image pixels
    • Imagick::extentImage — Set image size
    • Imagick::filter — Description
    • Imagick::flattenImages — Merges a sequence of images
    • Imagick::flipImage — Creates a vertical mirror image
    • Imagick::floodFillPaintImage — Changes the color value of any pixel that matches target
    • Imagick::flopImage — Creates a vertical mirror image
    • Imagick::forwardFourierTransformImage — Description
    • Imagick::frameImage — Adds a simulated three-dimensional border
    • Imagick::functionImage — Applies a function on the image
    • Imagick::fxImage — Evaluate expression for each pixel in the image
    • Imagick::gammaImage — Gamma-corrects an image
    • Imagick::gaussianBlurImage — Blurs an image
    • Imagick::getColorspace — Gets the colorspace
    • Imagick::getCompression — Gets the object compression type
    • Imagick::getCompressionQuality — Gets the object compression quality
    • Imagick::getCopyright — Returns the ImageMagick API copyright as a string
    • Imagick::getFilename — The filename associated with an image sequence
    • Imagick::getFont — Gets font
    • Imagick::getFormat — Returns the format of the Imagick object
    • Imagick::getGravity — Gets the gravity
    • Imagick::getHomeURL — Returns the ImageMagick home URL
    • Imagick::getImage — Returns a new Imagick object
    • Imagick::getImageAlphaChannel — 获取图像的 alpha 通道
    • Imagick::getImageArtifact — Get image artifact
    • Imagick::getImageAttribute — Description
    • Imagick::getImageBackgroundColor — Returns the image background color
    • Imagick::getImageBlob — Returns the image sequence as a blob
    • Imagick::getImageBluePrimary — Returns the chromaticy blue primary point
    • Imagick::getImageBorderColor — Returns the image border color
    • Imagick::getImageChannelDepth — Gets the depth for a particular image channel
    • Imagick::getImageChannelDistortion — Compares image channels of an image to a reconstructed image
    • Imagick::getImageChannelDistortions — Gets channel distortions
    • Imagick::getImageChannelExtrema — Gets the extrema for one or more image channels
    • Imagick::getImageChannelKurtosis — The getImageChannelKurtosis purpose
    • Imagick::getImageChannelMean — Gets the mean and standard deviation
    • Imagick::getImageChannelRange — Gets channel range
    • Imagick::getImageChannelStatistics — Returns statistics for each channel in the image
    • Imagick::getImageClipMask — Gets image clip mask
    • Imagick::getImageColormapColor — Returns the color of the specified colormap index
    • Imagick::getImageColors — Gets the number of unique colors in the image
    • Imagick::getImageColorspace — Gets the image colorspace
    • Imagick::getImageCompose — Returns the composite operator associated with the image
    • Imagick::getImageCompression — Gets the current image's compression type
    • Imagick::getImageCompressionQuality — Gets the current image's compression quality
    • Imagick::getImageDelay — Gets the image delay
    • Imagick::getImageDepth — Gets the image depth
    • Imagick::getImageDispose — Gets the image disposal method
    • Imagick::getImageDistortion — Compares an image to a reconstructed image
    • Imagick::getImageExtrema — Gets the extrema for the image
    • Imagick::getImageFilename — Returns the filename of a particular image in a sequence
    • Imagick::getImageFormat — Returns the format of a particular image in a sequence
    • Imagick::getImageGamma — Gets the image gamma
    • Imagick::getImageGeometry — Gets the width and height as an associative array
    • Imagick::getImageGravity — Gets the image gravity
    • Imagick::getImageGreenPrimary — Returns the chromaticy green primary point
    • Imagick::getImageHeight — Returns the image height
    • Imagick::getImageHistogram — Gets the image histogram
    • Imagick::getImageIndex — Gets the index of the current active image
    • Imagick::getImageInterlaceScheme — Gets the image interlace scheme
    • Imagick::getImageInterpolateMethod — Returns the interpolation method
    • Imagick::getImageIterations — Gets the image iterations
    • Imagick::getImageLength — Returns the image length in bytes
    • Imagick::getImageMatte — Return if the image has a matte channel
    • Imagick::getImageMatteColor — Returns the image matte color
    • Imagick::getImageMimeType — Description
    • Imagick::getImageOrientation — Gets the image orientation
    • Imagick::getImagePage — Returns the page geometry
    • Imagick::getImagePixelColor — Returns the color of the specified pixel
    • Imagick::getImageProfile — Returns the named image profile
    • Imagick::getImageProfiles — Returns the image profiles
    • Imagick::getImageProperties — Returns the image properties
    • Imagick::getImageProperty — Returns the named image property
    • Imagick::getImageRedPrimary — Returns the chromaticity red primary point
    • Imagick::getImageRegion — Extracts a region of the image
    • Imagick::getImageRenderingIntent — Gets the image rendering intent
    • Imagick::getImageResolution — 获取图像的x,y轴分辨率
    • Imagick::getImagesBlob — Returns all image sequences as a blob
    • Imagick::getImageScene — Gets the image scene
    • Imagick::getImageSignature — Generates an SHA-256 message digest
    • Imagick::getImageSize — Returns the image length in bytes
    • Imagick::getImageTicksPerSecond — Gets the image ticks-per-second
    • Imagick::getImageTotalInkDensity — Gets the image total ink density
    • Imagick::getImageType — Gets the potential image type
    • Imagick::getImageUnits — 获取图像的分辨率单位
    • Imagick::getImageVirtualPixelMethod — Returns the virtual pixel method
    • Imagick::getImageWhitePoint — Returns the chromaticity white point
    • Imagick::getImageWidth — Returns the image width
    • Imagick::getInterlaceScheme — Gets the object interlace scheme
    • Imagick::getIteratorIndex — Gets the index of the current active image
    • Imagick::getNumberImages — Returns the number of images in the object
    • Imagick::getOption — Returns a value associated with the specified key
    • Imagick::getPackageName — Returns the ImageMagick package name
    • Imagick::getPage — Returns the page geometry
    • Imagick::getPixelIterator — Returns a MagickPixelIterator
    • Imagick::getPixelRegionIterator — Get an ImagickPixelIterator for an image section
    • Imagick::getPointSize — Gets point size
    • Imagick::getQuantum — Description
    • Imagick::getQuantumDepth — Gets the quantum depth
    • Imagick::getQuantumRange — Returns the Imagick quantum range
    • Imagick::getRegistry — Description
    • Imagick::getReleaseDate — Returns the ImageMagick release date
    • Imagick::getResource — Returns the specified resource's memory usage
    • Imagick::getResourceLimit — Returns the specified resource limit
    • Imagick::getSamplingFactors — Gets the horizontal and vertical sampling factor
    • Imagick::getSize — Returns the size associated with the Imagick object
    • Imagick::getSizeOffset — Returns the size offset
    • Imagick::getVersion — Returns the ImageMagick API version
    • Imagick::haldClutImage — Replaces colors in the image
    • Imagick::hasNextImage — Checks if the object has more images
    • Imagick::hasPreviousImage — Checks if the object has a previous image
    • Imagick::identifyFormat — Description
    • Imagick::identifyImage — Identifies an image and fetches attributes
    • Imagick::implodeImage — Creates a new image as a copy
    • Imagick::importImagePixels — Imports image pixels
    • Imagick::inverseFourierTransformImage — Description
    • Imagick::labelImage — Adds a label to an image
    • Imagick::levelImage — Adjusts the levels of an image
    • Imagick::linearStretchImage — Stretches with saturation the image intensity
    • Imagick::liquidRescaleImage — Animates an image or images
    • Imagick::listRegistry — Description
    • Imagick::magnifyImage — Scales an image proportionally 2x
    • Imagick::mapImage — Replaces the colors of an image with the closest color from a reference image
    • Imagick::matteFloodfillImage — Changes the transparency value of a color
    • Imagick::medianFilterImage — Applies a digital filter
    • Imagick::mergeImageLayers — Merges image layers
    • Imagick::minifyImage — Scales an image proportionally to half its size
    • Imagick::modulateImage — Control the brightness, saturation, and hue
    • Imagick::montageImage — Creates a composite image
    • Imagick::morphImages — Method morphs a set of images
    • Imagick::morphology — Description
    • Imagick::mosaicImages — Forms a mosaic from images
    • Imagick::motionBlurImage — Simulates motion blur
    • Imagick::negateImage — Negates the colors in the reference image
    • Imagick::newImage — 创建一张图片
    • Imagick::newPseudoImage — Creates a new image
    • Imagick::nextImage — Moves to the next image
    • Imagick::normalizeImage — Enhances the contrast of a color image
    • Imagick::oilPaintImage — Simulates an oil painting
    • Imagick::opaquePaintImage — Changes the color value of any pixel that matches target
    • Imagick::optimizeImageLayers — Removes repeated portions of images to optimize
    • Imagick::orderedPosterizeImage — Performs an ordered dither
    • Imagick::paintFloodfillImage — Changes the color value of any pixel that matches target
    • Imagick::paintOpaqueImage — Change any pixel that matches color
    • Imagick::paintTransparentImage — Changes any pixel that matches color with the color defined by fill
    • Imagick::pingImage — Fetch basic attributes about the image
    • Imagick::pingImageBlob — Quickly fetch attributes
    • Imagick::pingImageFile — Get basic image attributes in a lightweight manner
    • Imagick::polaroidImage — Simulates a Polaroid picture
    • Imagick::posterizeImage — Reduces the image to a limited number of color level
    • Imagick::previewImages — Quickly pin-point appropriate parameters for image processing
    • Imagick::previousImage — Move to the previous image in the object
    • Imagick::profileImage — Adds or removes a profile from an image
    • Imagick::quantizeImage — Analyzes the colors within a reference image
    • Imagick::quantizeImages — Analyzes the colors within a sequence of images
    • Imagick::queryFontMetrics — Returns an array representing the font metrics
    • Imagick::queryFonts — Returns the configured fonts
    • Imagick::queryFormats — Returns formats supported by Imagick
    • Imagick::radialBlurImage — Radial blurs an image
    • Imagick::raiseImage — Creates a simulated 3d button-like effect
    • Imagick::randomThresholdImage — Creates a high-contrast, two-color image
    • Imagick::readImage — Reads image from filename
    • Imagick::readImageBlob — 从二进制字符串里读取图片
    • Imagick::readImageFile — Reads image from open filehandle
    • Imagick::readimages — Description
    • Imagick::recolorImage — Recolors image
    • Imagick::reduceNoiseImage — Smooths the contours of an image
    • Imagick::remapImage — Remaps image colors
    • Imagick::removeImage — Removes an image from the image list
    • Imagick::removeImageProfile — Removes the named image profile and returns it
    • Imagick::render — Renders all preceding drawing commands
    • Imagick::resampleImage — Resample image to desired resolution
    • Imagick::resetImagePage — Reset image page
    • Imagick::resizeImage — Scales an image
    • Imagick::rollImage — Offsets an image
    • Imagick::rotateImage — Rotates an image
    • Imagick::rotationalBlurImage — Description
    • Imagick::roundCorners — Rounds image corners
    • Imagick::sampleImage — Scales an image with pixel sampling
    • Imagick::scaleImage — Scales the size of an image
    • Imagick::segmentImage — Segments an image
    • Imagick::selectiveBlurImage — Description
    • Imagick::separateImageChannel — Separates a channel from the image
    • Imagick::sepiaToneImage — Sepia tones an image
    • Imagick::setBackgroundColor — Sets the object's default background color
    • Imagick::setColorspace — Set colorspace
    • Imagick::setCompression — Sets the object's default compression type
    • Imagick::setCompressionQuality — Sets the object's default compression quality
    • Imagick::setFilename — Sets the filename before you read or write the image
    • Imagick::setFirstIterator — Sets the Imagick iterator to the first image
    • Imagick::setFont — Sets font
    • Imagick::setFormat — Sets the format of the Imagick object
    • Imagick::setGravity — Sets the gravity
    • Imagick::setImage — Replaces image in the object
    • Imagick::setImageAlphaChannel — Sets image alpha channel
    • Imagick::setImageArtifact — Set image artifact
    • Imagick::setImageAttribute — Description
    • Imagick::setImageBackgroundColor — Sets the image background color
    • Imagick::setImageBias — Sets the image bias for any method that convolves an image
    • Imagick::setImageBiasQuantum — Description
    • Imagick::setImageBluePrimary — Sets the image chromaticity blue primary point
    • Imagick::setImageBorderColor — Sets the image border color
    • Imagick::setImageChannelDepth — Sets the depth of a particular image channel
    • Imagick::setImageClipMask — Sets image clip mask
    • Imagick::setImageColormapColor — Sets the color of the specified colormap index
    • Imagick::setImageColorspace — Sets the image colorspace
    • Imagick::setImageCompose — Sets the image composite operator
    • Imagick::setImageCompression — 设置图片压缩的类型
    • Imagick::setImageCompressionQuality — 设置图片压缩的质量
    • Imagick::setImageDelay — Sets the image delay
    • Imagick::setImageDepth — Sets the image depth
    • Imagick::setImageDispose — Sets the image disposal method
    • Imagick::setImageExtent — Sets the image size
    • Imagick::setImageFilename — Sets the filename of a particular image
    • Imagick::setImageFormat — 为图片设置指定的格式
    • Imagick::setImageGamma — Sets the image gamma
    • Imagick::setImageGravity — Sets the image gravity
    • Imagick::setImageGreenPrimary — Sets the image chromaticity green primary point
    • Imagick::setImageIndex — Set the iterator position
    • Imagick::setImageInterlaceScheme — Sets the image compression
    • Imagick::setImageInterpolateMethod — Sets the image interpolate pixel method
    • Imagick::setImageIterations — Sets the image iterations
    • Imagick::setImageMatte — Sets the image matte channel
    • Imagick::setImageMatteColor — Sets the image matte color
    • Imagick::setImageOpacity — Sets the image opacity level
    • Imagick::setImageOrientation — Sets the image orientation
    • Imagick::setImagePage — Sets the page geometry of the image
    • Imagick::setImageProfile — Adds a named profile to the Imagick object
    • Imagick::setImageProperty — Sets an image property
    • Imagick::setImageRedPrimary — Sets the image chromaticity red primary point
    • Imagick::setImageRenderingIntent — Sets the image rendering intent
    • Imagick::setImageResolution — Sets the image resolution
    • Imagick::setImageScene — Sets the image scene
    • Imagick::setImageTicksPerSecond — Sets the image ticks-per-second
    • Imagick::setImageType — Sets the image type
    • Imagick::setImageUnits — Sets the image units of resolution
    • Imagick::setImageVirtualPixelMethod — Sets the image virtual pixel method
    • Imagick::setImageWhitePoint — Sets the image chromaticity white point
    • Imagick::setInterlaceScheme — Sets the image compression
    • Imagick::setIteratorIndex — Set the iterator position
    • Imagick::setLastIterator — Sets the Imagick iterator to the last image
    • Imagick::setOption — Set an option
    • Imagick::setPage — Sets the page geometry of the Imagick object
    • Imagick::setPointSize — Sets point size
    • Imagick::setProgressMonitor — Description
    • Imagick::setRegistry — Description
    • Imagick::setResolution — Sets the image resolution
    • Imagick::setResourceLimit — Sets the limit for a particular resource
    • Imagick::setSamplingFactors — Sets the image sampling factors
    • Imagick::setSize — Sets the size of the Imagick object
    • Imagick::setSizeOffset — Sets the size and offset of the Imagick object
    • Imagick::setType — Sets the image type attribute
    • Imagick::shadeImage — Creates a 3D effect
    • Imagick::shadowImage — Simulates an image shadow
    • Imagick::sharpenImage — Sharpens an image
    • Imagick::shaveImage — Shaves pixels from the image edges
    • Imagick::shearImage — Creating a parallelogram
    • Imagick::sigmoidalContrastImage — Adjusts the contrast of an image
    • Imagick::sketchImage — Simulates a pencil sketch
    • Imagick::smushImages — Description
    • Imagick::solarizeImage — Applies a solarizing effect to the image
    • Imagick::sparseColorImage — Interpolates colors
    • Imagick::spliceImage — Splices a solid color into the image
    • Imagick::spreadImage — Randomly displaces each pixel in a block
    • Imagick::statisticImage — Description
    • Imagick::steganoImage — Hides a digital watermark within the image
    • Imagick::stereoImage — Composites two images
    • Imagick::stripImage — 去掉图片的所有配置和设置
    • Imagick::subImageMatch — Description
    • Imagick::swirlImage — Swirls the pixels about the center of the image
    • Imagick::textureImage — Repeatedly tiles the texture image
    • Imagick::thresholdImage — Changes the value of individual pixels based on a threshold
    • Imagick::thumbnailImage — Changes the size of an image
    • Imagick::tintImage — Applies a color vector to each pixel in the image
    • Imagick::__toString — Returns the image as a string
    • Imagick::transformImage — Convenience method for setting crop size and the image geometry
    • Imagick::transformImageColorspace — Transforms an image to a new colorspace
    • Imagick::transparentPaintImage — Paints pixels transparent
    • Imagick::transposeImage — Creates a vertical mirror image
    • Imagick::transverseImage — Creates a horizontal mirror image
    • Imagick::trimImage — Remove edges from the image
    • Imagick::uniqueImageColors — Discards all but one of any pixel color
    • Imagick::unsharpMaskImage — Sharpens an image
    • Imagick::valid — Checks if the current item is valid
    • Imagick::vignetteImage — Adds vignette filter to the image
    • Imagick::waveImage — Applies wave filter to the image
    • Imagick::whiteThresholdImage — Force all pixels above the threshold into white
    • Imagick::writeImage — 把图片写入指定的文件
    • Imagick::writeImageFile — Writes an image to a filehandle
    • Imagick::writeImages — Writes an image or image sequence
    • Imagick::writeImagesFile — Writes frames to a filehandle
  • ImagickDraw — The ImagickDraw class
    • ImagickDraw::affine — Adjusts the current affine transformation matrix
    • ImagickDraw::annotation — Draws text on the image
    • ImagickDraw::arc — Draws an arc
    • ImagickDraw::bezier — Draws a bezier curve
    • ImagickDraw::circle — Draws a circle
    • ImagickDraw::clear — Clears the ImagickDraw
    • ImagickDraw::clone — Makes an exact copy of the specified ImagickDraw object
    • ImagickDraw::color — Draws color on image
    • ImagickDraw::comment — Adds a comment
    • ImagickDraw::composite — Composites an image onto the current image
    • ImagickDraw::__construct — The ImagickDraw constructor
    • ImagickDraw::destroy — Frees all associated resources
    • ImagickDraw::ellipse — Draws an ellipse on the image
    • ImagickDraw::getClipPath — Obtains the current clipping path ID
    • ImagickDraw::getClipRule — Returns the current polygon fill rule
    • ImagickDraw::getClipUnits — Returns the interpretation of clip path units
    • ImagickDraw::getFillColor — Returns the fill color
    • ImagickDraw::getFillOpacity — Returns the opacity used when drawing
    • ImagickDraw::getFillRule — Returns the fill rule
    • ImagickDraw::getFont — Returns the font
    • ImagickDraw::getFontFamily — Returns the font family
    • ImagickDraw::getFontSize — Returns the font pointsize
    • ImagickDraw::getFontStretch — Description
    • ImagickDraw::getFontStyle — Returns the font style
    • ImagickDraw::getFontWeight — Returns the font weight
    • ImagickDraw::getGravity — Returns the text placement gravity
    • ImagickDraw::getStrokeAntialias — Returns the current stroke antialias setting
    • ImagickDraw::getStrokeColor — Returns the color used for stroking object outlines
    • ImagickDraw::getStrokeDashArray — Returns an array representing the pattern of dashes and gaps used to stroke paths
    • ImagickDraw::getStrokeDashOffset — Returns the offset into the dash pattern to start the dash
    • ImagickDraw::getStrokeLineCap — Returns the shape to be used at the end of open subpaths when they are stroked
    • ImagickDraw::getStrokeLineJoin — Returns the shape to be used at the corners of paths when they are stroked
    • ImagickDraw::getStrokeMiterLimit — Returns the stroke miter limit
    • ImagickDraw::getStrokeOpacity — Returns the opacity of stroked object outlines
    • ImagickDraw::getStrokeWidth — Returns the width of the stroke used to draw object outlines
    • ImagickDraw::getTextAlignment — Returns the text alignment
    • ImagickDraw::getTextAntialias — Returns the current text antialias setting
    • ImagickDraw::getTextDecoration — Returns the text decoration
    • ImagickDraw::getTextEncoding — Returns the code set used for text annotations
    • ImagickDraw::getTextInterlineSpacing — Description
    • ImagickDraw::getTextInterwordSpacing — Description
    • ImagickDraw::getTextKerning — Description
    • ImagickDraw::getTextUnderColor — Returns the text under color
    • ImagickDraw::getVectorGraphics — Returns a string containing vector graphics
    • ImagickDraw::line — Draws a line
    • ImagickDraw::matte — Paints on the image's opacity channel
    • ImagickDraw::pathClose — Adds a path element to the current path
    • ImagickDraw::pathCurveToAbsolute — Draws a cubic Bezier curve
    • ImagickDraw::pathCurveToQuadraticBezierAbsolute — Draws a quadratic Bezier curve
    • ImagickDraw::pathCurveToQuadraticBezierRelative — Draws a quadratic Bezier curve
    • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — Draws a quadratic Bezier curve
    • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — Draws a quadratic Bezier curve
    • ImagickDraw::pathCurveToRelative — Draws a cubic Bezier curve
    • ImagickDraw::pathCurveToSmoothAbsolute — Draws a cubic Bezier curve
    • ImagickDraw::pathCurveToSmoothRelative — Draws a cubic Bezier curve
    • ImagickDraw::pathEllipticArcAbsolute — Draws an elliptical arc
    • ImagickDraw::pathEllipticArcRelative — Draws an elliptical arc
    • ImagickDraw::pathFinish — Terminates the current path
    • ImagickDraw::pathLineToAbsolute — Draws a line path
    • ImagickDraw::pathLineToHorizontalAbsolute — Draws a horizontal line path
    • ImagickDraw::pathLineToHorizontalRelative — Draws a horizontal line
    • ImagickDraw::pathLineToRelative — Draws a line path
    • ImagickDraw::pathLineToVerticalAbsolute — Draws a vertical line
    • ImagickDraw::pathLineToVerticalRelative — Draws a vertical line path
    • ImagickDraw::pathMoveToAbsolute — Starts a new sub-path
    • ImagickDraw::pathMoveToRelative — Starts a new sub-path
    • ImagickDraw::pathStart — Declares the start of a path drawing list
    • ImagickDraw::point — Draws a point
    • ImagickDraw::polygon — Draws a polygon
    • ImagickDraw::polyline — Draws a polyline
    • ImagickDraw::pop — Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw
    • ImagickDraw::popClipPath — Terminates a clip path definition
    • ImagickDraw::popDefs — Terminates a definition list
    • ImagickDraw::popPattern — Terminates a pattern definition
    • ImagickDraw::push — Clones the current ImagickDraw and pushes it to the stack
    • ImagickDraw::pushClipPath — Starts a clip path definition
    • ImagickDraw::pushDefs — Indicates that following commands create named elements for early processing
    • ImagickDraw::pushPattern — Indicates that subsequent commands up to a ImagickDraw::opPattern() command comprise the definition of a named pattern
    • ImagickDraw::rectangle — Draws a rectangle
    • ImagickDraw::render — Renders all preceding drawing commands onto the image
    • ImagickDraw::resetVectorGraphics — Description
    • ImagickDraw::rotate — Applies the specified rotation to the current coordinate space
    • ImagickDraw::roundRectangle — Draws a rounded rectangle
    • ImagickDraw::scale — Adjusts the scaling factor
    • ImagickDraw::setClipPath — Associates a named clipping path with the image
    • ImagickDraw::setClipRule — Set the polygon fill rule to be used by the clipping path
    • ImagickDraw::setClipUnits — Sets the interpretation of clip path units
    • ImagickDraw::setFillAlpha — Sets the opacity to use when drawing using the fill color or fill texture
    • ImagickDraw::setFillColor — Sets the fill color to be used for drawing filled objects
    • ImagickDraw::setFillOpacity — Sets the opacity to use when drawing using the fill color or fill texture
    • ImagickDraw::setFillPatternURL — Sets the URL to use as a fill pattern for filling objects
    • ImagickDraw::setFillRule — Sets the fill rule to use while drawing polygons
    • ImagickDraw::setFont — Sets the fully-specified font to use when annotating with text
    • ImagickDraw::setFontFamily — Sets the font family to use when annotating with text
    • ImagickDraw::setFontSize — Sets the font pointsize to use when annotating with text
    • ImagickDraw::setFontStretch — Sets the font stretch to use when annotating with text
    • ImagickDraw::setFontStyle — Sets the font style to use when annotating with text
    • ImagickDraw::setFontWeight — Sets the font weight
    • ImagickDraw::setGravity — Sets the text placement gravity
    • ImagickDraw::setResolution — Description
    • ImagickDraw::setStrokeAlpha — Specifies the opacity of stroked object outlines
    • ImagickDraw::setStrokeAntialias — Controls whether stroked outlines are antialiased
    • ImagickDraw::setStrokeColor — Sets the color used for stroking object outlines
    • ImagickDraw::setStrokeDashArray — Specifies the pattern of dashes and gaps used to stroke paths
    • ImagickDraw::setStrokeDashOffset — Specifies the offset into the dash pattern to start the dash
    • ImagickDraw::setStrokeLineCap — Specifies the shape to be used at the end of open subpaths when they are stroked
    • ImagickDraw::setStrokeLineJoin — Specifies the shape to be used at the corners of paths when they are stroked
    • ImagickDraw::setStrokeMiterLimit — Specifies the miter limit
    • ImagickDraw::setStrokeOpacity — Specifies the opacity of stroked object outlines
    • ImagickDraw::setStrokePatternURL — Sets the pattern used for stroking object outlines
    • ImagickDraw::setStrokeWidth — Sets the width of the stroke used to draw object outlines
    • ImagickDraw::setTextAlignment — Specifies a text alignment
    • ImagickDraw::setTextAntialias — Controls whether text is antialiased
    • ImagickDraw::setTextDecoration — Specifies a decoration
    • ImagickDraw::setTextEncoding — Specifies the text code set
    • ImagickDraw::setTextInterlineSpacing — Description
    • ImagickDraw::setTextInterwordSpacing — Description
    • ImagickDraw::setTextKerning — Description
    • ImagickDraw::setTextUnderColor — Specifies the color of a background rectangle
    • ImagickDraw::setVectorGraphics — Sets the vector graphics
    • ImagickDraw::setViewbox — Sets the overall canvas size
    • ImagickDraw::skewX — Skews the current coordinate system in the horizontal direction
    • ImagickDraw::skewY — Skews the current coordinate system in the vertical direction
    • ImagickDraw::translate — Applies a translation to the current coordinate system
  • ImagickPixel — The ImagickPixel class
    • ImagickPixel::clear — Clears resources associated with this object
    • ImagickPixel::__construct — The ImagickPixel constructor
    • ImagickPixel::destroy — Deallocates resources associated with this object
    • ImagickPixel::getColor — Returns the color
    • ImagickPixel::getColorAsString — Returns the color as a string
    • ImagickPixel::getColorCount — Returns the color count associated with this color
    • ImagickPixel::getColorQuantum — Description
    • ImagickPixel::getColorValue — Gets the normalized value of the provided color channel
    • ImagickPixel::getColorValueQuantum — Description
    • ImagickPixel::getHSL — Returns the normalized HSL color of the ImagickPixel object
    • ImagickPixel::getIndex — Description
    • ImagickPixel::isPixelSimilar — Check the distance between this color and another
    • ImagickPixel::isPixelSimilarQuantum — Description
    • ImagickPixel::isSimilar — Check the distance between this color and another
    • ImagickPixel::setColor — Sets the color
    • ImagickPixel::setColorCount — Description
    • ImagickPixel::setColorValue — Sets the normalized value of one of the channels
    • ImagickPixel::setColorValueQuantum — Description
    • ImagickPixel::setHSL — Sets the normalized HSL color
    • ImagickPixel::setIndex — Description
  • ImagickPixelIterator — The ImagickPixelIterator class
    • ImagickPixelIterator::clear — Clear resources associated with a PixelIterator
    • ImagickPixelIterator::__construct — The ImagickPixelIterator constructor
    • ImagickPixelIterator::destroy — Deallocates resources associated with a PixelIterator
    • ImagickPixelIterator::getCurrentIteratorRow — Returns the current row of ImagickPixel objects
    • ImagickPixelIterator::getIteratorRow — Returns the current pixel iterator row
    • ImagickPixelIterator::getNextIteratorRow — Returns the next row of the pixel iterator
    • ImagickPixelIterator::getPreviousIteratorRow — Returns the previous row
    • ImagickPixelIterator::newPixelIterator — Returns a new pixel iterator
    • ImagickPixelIterator::newPixelRegionIterator — Returns a new pixel iterator
    • ImagickPixelIterator::resetIterator — Resets the pixel iterator
    • ImagickPixelIterator::setIteratorFirstRow — Sets the pixel iterator to the first pixel row
    • ImagickPixelIterator::setIteratorLastRow — Sets the pixel iterator to the last pixel row
    • ImagickPixelIterator::setIteratorRow — Set the pixel iterator row
    • ImagickPixelIterator::syncIterator — Syncs the pixel iterator


简介

Imagick 是用 ImageMagic API 来创建和修改图像的PHP官方扩展。

ImageMagick® 是用来创建，编辑，合并位图图像的一套组件。 它能够用于读取，转换，写入多种不同格式的图像。 包含 DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript, SVG, 和 TIFF。

Copyright 1999-2007 ImageMagick Studio LLC, a non-profit organization dedicated to making software imaging solutions freely available.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • ImageMagick
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

Installation requirements on Windows

Version information does not differ from that above. There are binaries available from http://www.imagemagick.org/ so that you can load this extension on Windows without need for a compiler.

Installation requirements on other platforms

PHP >= 5.1.3 and ImageMagick >= 6.2.4 is required. The amount of file formats supported by Imagick depends entirely upon the amount of formats supported by your ImageMagick installation. For example, Imagemagick requires ghostscript to conduct PDF operations.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/imagick.

Note: The official name of this extension is imagick.

Windows users can download prebuilt DLL from the » PECL website.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Imagick configuration options
名字 | 默认 | 可修改范围 | 更新日志
imagick.locale_fix | false | PHP_INI_ALL | Available since Imagick 2.1.0
imagick.progress_monitor | false | PHP_INI_SYSTEM | Available since Imagick 2.2.2
imagick.skip_version_check | false | PHP_INI_SYSTEM | Available since Imagick 3.3.0
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

imagick.locale_fix bool

Fixes a drawing bug with locales that use ',' as float separators.

imagick.progress_monitor bool

Used to enable the image progress monitor.

imagick.skip_version_check bool

When Imagick is loaded, it checks the version number of ImageMagick that it was compiled against, with the version number that is currently being used and will give a warning if they don't match. This warning can be suppressed by enabling this ini setting.

Using a version of Imagick that was compiled against a different version of ImageMagick than the one being used is not recommended. Although it may appear to work, it can lead to random crashes or other undefined behaviour.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

COLOR_* constants

Colortype constants. These constants are mainly used with ImagickPixel.

imagick::COLOR_BLACK (int)
Black color
imagick::COLOR_BLUE (int)
Blue color
imagick::COLOR_CYAN (int)
Cyan color
imagick::COLOR_GREEN (int)
Green color
imagick::COLOR_RED (int)
Red color
imagick::COLOR_YELLOW (int)
Yellow color
imagick::COLOR_MAGENTA (int)
Magenta color
imagick::COLOR_OPACITY (int)
Color's opacity
imagick::COLOR_ALPHA (int)
Color's alpha
imagick::COLOR_FUZZ (int)
Color's fuzz
DISPOSE constants

Dispose type constants

imagick::DISPOSE_UNRECOGNIZED (int)
Unrecognized dispose type
imagick::DISPOSE_UNDEFINED (int)
Undefined dispose type
imagick::DISPOSE_NONE (int)
No dispose type defined
imagick::DISPOSE_BACKGROUND (int)
Dispose background
imagick::DISPOSE_PREVIOUS (int)
Dispose previous
Composite Operator Constants
imagick::COMPOSITE_DEFAULT (int)
The default composite operator
imagick::COMPOSITE_UNDEFINED (int)
Undefined composite operator
imagick::COMPOSITE_NO (int)
No composite operator defined
imagick::COMPOSITE_ADD (int)
The result of image + image
imagick::COMPOSITE_ATOP (int)
The result is the same shape as image, with composite image obscuring image where the image shapes overlap
imagick::COMPOSITE_BLEND (int)
Blends the image
imagick::COMPOSITE_BUMPMAP (int)
The same as COMPOSITE_MULTIPLY, except the source is converted to grayscale first.
imagick::COMPOSITE_CLEAR (int)
Makes the target image transparent
imagick::COMPOSITE_COLORBURN (int)
Darkens the destination image to reflect the source image
imagick::COMPOSITE_COLORDODGE (int)
Brightens the destination image to reflect the source image
imagick::COMPOSITE_COLORIZE (int)
Colorizes the target image using the composite image
imagick::COMPOSITE_COPYBLACK (int)
Copies black from the source to target
imagick::COMPOSITE_COPYBLUE (int)
Copies blue from the source to target
imagick::COMPOSITE_COPY (int)
Copies the source image on the target image
imagick::COMPOSITE_COPYCYAN (int)
Copies cyan from the source to target
imagick::COMPOSITE_COPYGREEN (int)
Copies green from the source to target
imagick::COMPOSITE_COPYMAGENTA (int)
Copies magenta from the source to target
imagick::COMPOSITE_COPYOPACITY (int)
Copies opacity from the source to target
imagick::COMPOSITE_COPYRED (int)
Copies red from the source to target
imagick::COMPOSITE_COPYYELLOW (int)
Copies yellow from the source to target
imagick::COMPOSITE_DARKEN (int)
Darkens the target image
imagick::COMPOSITE_DSTATOP (int)
The part of the destination lying inside of the source is composited over the source and replaces the destination
imagick::COMPOSITE_DST (int)
The target is left untouched
imagick::COMPOSITE_DSTIN (int)
The parts inside the source replace the target
imagick::COMPOSITE_DSTOUT (int)
The parts outside the source replace the target
imagick::COMPOSITE_DSTOVER (int)
Target replaces the source
imagick::COMPOSITE_DIFFERENCE (int)
Subtracts the darker of the two constituent colors from the lighter
imagick::COMPOSITE_DISPLACE (int)
Shifts target image pixels as defined by the source
imagick::COMPOSITE_DISSOLVE (int)
Dissolves the source in to the target
imagick::COMPOSITE_EXCLUSION (int)
Produces an effect similar to that of imagick::COMPOSITE_DIFFERENCE, but appears as lower contrast
imagick::COMPOSITE_HARDLIGHT (int)
Multiplies or screens the colors, dependent on the source color value
imagick::COMPOSITE_HUE (int)
Modifies the hue of the target as defined by source
imagick::COMPOSITE_IN (int)
Composites source into the target
imagick::COMPOSITE_LIGHTEN (int)
Lightens the target as defined by source
imagick::COMPOSITE_LUMINIZE (int)
Luminizes the target as defined by source
imagick::COMPOSITE_MINUS (int)
Subtracts the source from the target
imagick::COMPOSITE_MODULATE (int)
Modulates the target brightness, saturation and hue as defined by source
imagick::COMPOSITE_MULTIPLY (int)
Multiplies the target to the source
imagick::COMPOSITE_OUT (int)
Composites outer parts of the source on the target
imagick::COMPOSITE_OVER (int)
Composites source over the target
imagick::COMPOSITE_OVERLAY (int)
Overlays the source on the target
imagick::COMPOSITE_PLUS (int)
Adds the source to the target
imagick::COMPOSITE_REPLACE (int)
Replaces the target with the source
imagick::COMPOSITE_SATURATE (int)
Saturates the target as defined by the source
imagick::COMPOSITE_SCREEN (int)
The source and destination are complemented and then multiplied and then replace the destination
imagick::COMPOSITE_SOFTLIGHT (int)
Darkens or lightens the colors, dependent on the source
imagick::COMPOSITE_SRCATOP (int)
The part of the source lying inside of the destination is composited onto the destination
imagick::COMPOSITE_SRC (int)
The source is copied to the destination
imagick::COMPOSITE_SRCIN (int)
The part of the source lying inside of the destination replaces the destination
imagick::COMPOSITE_SRCOUT (int)
The part of the source lying outside of the destination replaces the destination
imagick::COMPOSITE_SRCOVER (int)
The source replaces the destination
imagick::COMPOSITE_SUBTRACT (int)
Subtract the colors in the source image from the destination image
imagick::COMPOSITE_THRESHOLD (int)
The source is composited on the target as defined by source threshold
imagick::COMPOSITE_XOR (int)
The part of the source that lies outside of the destination is combined with the part of the destination that lies outside of the source
MONTAGEMODE constants

imagick::MONTAGEMODE_FRAME (int)
imagick::MONTAGEMODE_UNFRAME (int)
imagick::MONTAGEMODE_CONCATENATE (int)
STYLE constants

imagick::STYLE_NORMAL (int)
imagick::STYLE_ITALIC (int)
imagick::STYLE_OBLIQUE (int)
imagick::STYLE_ANY (int)
FILTER constants

imagick::FILTER_UNDEFINED (int)
imagick::FILTER_POINT (int)
imagick::FILTER_BOX (int)
imagick::FILTER_TRIANGLE (int)
imagick::FILTER_HERMITE (int)
imagick::FILTER_HANNING (int)
imagick::FILTER_HAMMING (int)
imagick::FILTER_BLACKMAN (int)
imagick::FILTER_GAUSSIAN (int)
imagick::FILTER_QUADRATIC (int)
imagick::FILTER_CUBIC (int)
imagick::FILTER_CATROM (int)
imagick::FILTER_MITCHELL (int)
imagick::FILTER_LANCZOS (int)
imagick::FILTER_BESSEL (int)
imagick::FILTER_SINC (int)
IMGTYPE constants

imagick::IMGTYPE_UNDEFINED (int)
imagick::IMGTYPE_BILEVEL (int)
imagick::IMGTYPE_GRAYSCALE (int)
imagick::IMGTYPE_GRAYSCALEMATTE (int)
imagick::IMGTYPE_PALETTE (int)
imagick::IMGTYPE_PALETTEMATTE (int)
imagick::IMGTYPE_TRUECOLOR (int)
imagick::IMGTYPE_TRUECOLORMATTE (int)
imagick::IMGTYPE_COLORSEPARATION (int)
imagick::IMGTYPE_COLORSEPARATIONMATTE (int)
imagick::IMGTYPE_OPTIMIZE (int)
RESOLUTION constants

imagick::RESOLUTION_UNDEFINED (int)
imagick::RESOLUTION_PIXELSPERINCH (int)
imagick::RESOLUTION_PIXELSPERCENTIMETER (int)
COMPRESSION constants

imagick::COMPRESSION_UNDEFINED (int)
imagick::COMPRESSION_NO (int)
imagick::COMPRESSION_BZIP (int)
imagick::COMPRESSION_FAX (int)
imagick::COMPRESSION_GROUP4 (int)
imagick::COMPRESSION_JPEG (int)
imagick::COMPRESSION_JPEG2000 (int)
imagick::COMPRESSION_LOSSLESSJPEG (int)
imagick::COMPRESSION_LZW (int)
imagick::COMPRESSION_RLE (int)
imagick::COMPRESSION_ZIP (int)
imagick::COMPRESSION_DXT1 (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.0 or higher.
imagick::COMPRESSION_DXT3 (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.0 or higher.
imagick::COMPRESSION_DXT5 (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.0 or higher.
PAINT constants

imagick::PAINT_POINT (int)
imagick::PAINT_REPLACE (int)
imagick::PAINT_FLOODFILL (int)
imagick::PAINT_FILLTOBORDER (int)
imagick::PAINT_RESET (int)
GRAVITY constants

imagick::GRAVITY_NORTHWEST (int)
imagick::GRAVITY_NORTH (int)
imagick::GRAVITY_NORTHEAST (int)
imagick::GRAVITY_WEST (int)
imagick::GRAVITY_CENTER (int)
imagick::GRAVITY_EAST (int)
imagick::GRAVITY_SOUTHWEST (int)
imagick::GRAVITY_SOUTH (int)
imagick::GRAVITY_SOUTHEAST (int)
STRETCH constants

imagick::STRETCH_NORMAL (int)
imagick::STRETCH_ULTRACONDENSED (int)
imagick::STRETCH_CONDENSED (int)
imagick::STRETCH_SEMICONDENSED (int)
imagick::STRETCH_SEMIEXPANDED (int)
imagick::STRETCH_EXPANDED (int)
imagick::STRETCH_EXTRAEXPANDED (int)
imagick::STRETCH_ULTRAEXPANDED (int)
imagick::STRETCH_ANY (int)
ALIGN constants

imagick::ALIGN_UNDEFINED (int)
imagick::ALIGN_LEFT (int)
imagick::ALIGN_CENTER (int)
imagick::ALIGN_RIGHT (int)
DECORATION constants

imagick::DECORATION_NO (int)
imagick::DECORATION_UNDERLINE (int)
imagick::DECORATION_OVERLINE (int)
imagick::DECORATION_LINETROUGH (int)
NOISE constants

imagick::NOISE_UNIFORM (int)
imagick::NOISE_GAUSSIAN (int)
imagick::NOISE_MULTIPLICATIVEGAUSSIAN (int)
imagick::NOISE_IMPULSE (int)
imagick::NOISE_LAPLACIAN (int)
imagick::NOISE_POISSON (int)
imagick::NOISE_RANDOM (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
CHANNEL constants

imagick::CHANNEL_UNDEFINED (int)
imagick::CHANNEL_RED (int)
imagick::CHANNEL_GRAY (int)
imagick::CHANNEL_CYAN (int)
imagick::CHANNEL_GREEN (int)
imagick::CHANNEL_MAGENTA (int)
imagick::CHANNEL_BLUE (int)
imagick::CHANNEL_YELLOW (int)
imagick::CHANNEL_ALPHA (int)
imagick::CHANNEL_OPACITY (int)
imagick::CHANNEL_MATTE (int)
imagick::CHANNEL_BLACK (int)
imagick::CHANNEL_INDEX (int)
imagick::CHANNEL_ALL (int)
imagick::CHANNEL_DEFAULT (int)
METRIC constants

imagick::METRIC_UNDEFINED (int)
imagick::METRIC_MEANABSOLUTEERROR (int)
imagick::METRIC_MEANSQUAREERROR (int)
imagick::METRIC_PEAKABSOLUTEERROR (int)
imagick::METRIC_PEAKSIGNALTONOISERATIO (int)
imagick::METRIC_ROOTMEANSQUAREDERROR (int)
PIXEL constants

imagick::PIXEL_CHAR (int)
imagick::PIXEL_DOUBLE (int)
imagick::PIXEL_FLOAT (int)
imagick::PIXEL_INTEGER (int)
Only available for ImageMagick < 7.
imagick::PIXEL_LONG (int)
imagick::PIXEL_QUANTUM (int)
imagick::PIXEL_SHORT (int)
EVALUATE constants

imagick::EVALUATE_UNDEFINED (int)
imagick::EVALUATE_ADD (int)
imagick::EVALUATE_AND (int)
imagick::EVALUATE_DIVIDE (int)
imagick::EVALUATE_LEFTSHIFT (int)
imagick::EVALUATE_MAX (int)
imagick::EVALUATE_MIN (int)
imagick::EVALUATE_MULTIPLY (int)
imagick::EVALUATE_OR (int)
imagick::EVALUATE_RIGHTSHIFT (int)
imagick::EVALUATE_SET (int)
imagick::EVALUATE_SUBTRACT (int)
imagick::EVALUATE_XOR (int)
imagick::EVALUATE_POW (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_LOG (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_THRESHOLD (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_THRESHOLDBLACK (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_THRESHOLDWHITE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_GAUSSIANNOISE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_IMPULSENOISE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_LAPLACIANNOISE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_MULTIPLICATIVENOISE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_POISSONNOISE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_UNIFORMNOISE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_COSINE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_SINE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
imagick::EVALUATE_ADDMODULUS (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.4 or higher.
COLORSPACE constants

imagick::COLORSPACE_UNDEFINED (int)
imagick::COLORSPACE_RGB (int)
imagick::COLORSPACE_GRAY (int)
imagick::COLORSPACE_TRANSPARENT (int)
imagick::COLORSPACE_OHTA (int)
imagick::COLORSPACE_LAB (int)
imagick::COLORSPACE_XYZ (int)
imagick::COLORSPACE_YCBCR (int)
imagick::COLORSPACE_YCC (int)
imagick::COLORSPACE_YIQ (int)
imagick::COLORSPACE_YPBPR (int)
imagick::COLORSPACE_YUV (int)
imagick::COLORSPACE_CMYK (int)
imagick::COLORSPACE_SRGB (int)
imagick::COLORSPACE_HSB (int)
imagick::COLORSPACE_HSL (int)
imagick::COLORSPACE_HWB (int)
imagick::COLORSPACE_REC601LUMA (int)
imagick::COLORSPACE_REC709LUMA (int)
imagick::COLORSPACE_LOG (int)
imagick::COLORSPACE_CMY (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.2 or higher.
VIRTUALPIXELMETHOD constants

imagick::VIRTUALPIXELMETHOD_UNDEFINED (int)
imagick::VIRTUALPIXELMETHOD_BACKGROUND (int)
imagick::VIRTUALPIXELMETHOD_CONSTANT (int)
imagick::VIRTUALPIXELMETHOD_EDGE (int)
imagick::VIRTUALPIXELMETHOD_MIRROR (int)
imagick::VIRTUALPIXELMETHOD_TILE (int)
imagick::VIRTUALPIXELMETHOD_TRANSPARENT (int)
imagick::VIRTUALPIXELMETHOD_MASK (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.2 or higher.
imagick::VIRTUALPIXELMETHOD_BLACK (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.2 or higher.
imagick::VIRTUALPIXELMETHOD_GRAY (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.2 or higher.
imagick::VIRTUALPIXELMETHOD_WHITE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.2 or higher.
imagick::VIRTUALPIXELMETHOD_HORIZONTALTILE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.3 or higher.
imagick::VIRTUALPIXELMETHOD_VERTICALTILE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.3 or higher.
PREVIEW constants

imagick::PREVIEW_UNDEFINED (int)
imagick::PREVIEW_ROTATE (int)
imagick::PREVIEW_SHEAR (int)
imagick::PREVIEW_ROLL (int)
imagick::PREVIEW_HUE (int)
imagick::PREVIEW_SATURATION (int)
imagick::PREVIEW_BRIGHTNESS (int)
imagick::PREVIEW_GAMMA (int)
imagick::PREVIEW_SPIFF (int)
imagick::PREVIEW_DULL (int)
imagick::PREVIEW_GRAYSCALE (int)
imagick::PREVIEW_QUANTIZE (int)
imagick::PREVIEW_DESPECKLE (int)
imagick::PREVIEW_REDUCENOISE (int)
imagick::PREVIEW_ADDNOISE (int)
imagick::PREVIEW_SHARPEN (int)
imagick::PREVIEW_BLUR (int)
imagick::PREVIEW_THRESHOLD (int)
imagick::PREVIEW_EDGEDETECT (int)
imagick::PREVIEW_SPREAD (int)
imagick::PREVIEW_SOLARIZE (int)
imagick::PREVIEW_SHADE (int)
imagick::PREVIEW_RAISE (int)
imagick::PREVIEW_SEGMENT (int)
imagick::PREVIEW_SWIRL (int)
imagick::PREVIEW_IMPLODE (int)
imagick::PREVIEW_WAVE (int)
imagick::PREVIEW_OILPAINT (int)
imagick::PREVIEW_CHARCOALDRAWING (int)
imagick::PREVIEW_JPEG (int)
RENDERINGINTENT constants

imagick::RENDERINGINTENT_UNDEFINED (int)
imagick::RENDERINGINTENT_SATURATION (int)
imagick::RENDERINGINTENT_PERCEPTUAL (int)
imagick::RENDERINGINTENT_ABSOLUTE (int)
imagick::RENDERINGINTENT_RELATIVE (int)
INTERLACE constants

imagick::INTERLACE_UNDEFINED (int)
imagick::INTERLACE_NO (int)
imagick::INTERLACE_LINE (int)
imagick::INTERLACE_PLANE (int)
imagick::INTERLACE_PARTITION (int)
imagick::INTERLACE_GIF (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.4 or higher.
imagick::INTERLACE_JPEG (int)
imagick::INTERLACE_PNG (int)
FILLRULE constants

imagick::FILLRULE_UNDEFINED (int)
imagick::FILLRULE_EVENODD (int)
imagick::FILLRULE_NONZERO (int)
PATHUNITS constants

imagick::PATHUNITS_UNDEFINED (int)
imagick::PATHUNITS_USERSPACE (int)
imagick::PATHUNITS_USERSPACEONUSE (int)
imagick::PATHUNITS_OBJECTBOUNDINGBOX (int)
LINECAP constants

imagick::LINECAP_UNDEFINED (int)
imagick::LINECAP_BUTT (int)
imagick::LINECAP_ROUND (int)
imagick::LINECAP_SQUARE (int)
LINEJOIN constants

imagick::LINEJOIN_UNDEFINED (int)
imagick::LINEJOIN_MITER (int)
imagick::LINEJOIN_ROUND (int)
imagick::LINEJOIN_BEVEL (int)
RESOURCETYPE constants

imagick::RESOURCETYPE_UNDEFINED (int)
imagick::RESOURCETYPE_AREA (int)
Set the maximum width * height of an image that can reside in the pixel cache memory.
imagick::RESOURCETYPE_DISK (int)
Set maximum amount of disk space in bytes permitted for use by the pixel cache.
imagick::RESOURCETYPE_FILE (int)
Set maximum number of open pixel cache files.
imagick::RESOURCETYPE_MAP (int)
Set maximum amount of memory map in bytes to allocate for the pixel cache.
imagick::RESOURCETYPE_MEMORY (int)
Set maximum amount of memory in bytes to allocate for the pixel cache from the heap.
imagick::RESOURCETYPE_THREAD (int)
Set maximum parallel threads. 此常量可用仅当Imagick编译于ImageMagick版本 6.7.8 or higher.
LAYERMETHOD constants

imagick::LAYERMETHOD_UNDEFINED (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.2.9 or higher.
imagick::LAYERMETHOD_COALESCE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.2.9 or higher.
imagick::LAYERMETHOD_COMPAREANY (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.2.9 or higher.
imagick::LAYERMETHOD_COMPARECLEAR (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.2.9 or higher.
imagick::LAYERMETHOD_COMPAREOVERLAY (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.2.9 or higher.
imagick::LAYERMETHOD_DISPOSE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.2.9 or higher.
imagick::LAYERMETHOD_OPTIMIZE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.2.9 or higher.
imagick::LAYERMETHOD_OPTIMIZEPLUS (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.2.9 or higher.
imagick::LAYERMETHOD_OPTIMIZEIMAGE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::LAYERMETHOD_OPTIMIZETRANS (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::LAYERMETHOD_REMOVEDUPS (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::LAYERMETHOD_REMOVEZERO (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::LAYERMETHOD_COMPOSITE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::LAYERMETHOD_MERGE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.7 or higher.
imagick::LAYERMETHOD_FLATTEN (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.7 or higher.
imagick::LAYERMETHOD_MOSAIC (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.7 or higher.
ORIENTATION constants

imagick::ORIENTATION_UNDEFINED (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::ORIENTATION_TOPLEFT (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::ORIENTATION_TOPRIGHT (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::ORIENTATION_BOTTOMRIGHT (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::ORIENTATION_BOTTOMLEFT (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::ORIENTATION_LEFTTOP (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::ORIENTATION_RIGHTTOP (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::ORIENTATION_RIGHTBOTTOM (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
imagick::ORIENTATION_LEFTBOTTOM (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.0 or higher.
DISTORTION constants

imagick::DISTORTION_UNDEFINED (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
imagick::DISTORTION_AFFINE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
imagick::DISTORTION_AFFINEPROJECTION (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
imagick::DISTORTION_ARC (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
imagick::DISTORTION_BILINEAR (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
imagick::DISTORTION_PERSPECTIVE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
imagick::DISTORTION_PERSPECTIVEPROJECTION (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
imagick::DISTORTION_SCALEROTATETRANSLATE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.6 or higher.
imagick::DISTORTION_POLYNOMIAL (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DISTORTION_POLAR (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DISTORTION_DEPOLAR (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DISTORTION_BARREL (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DISTORTION_BARRELINVERSE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DISTORTION_SHEPARDS (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DISTORTION_SENTINEL (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
ALPHACHANNEL constants

imagick::ALPHACHANNEL_ACTIVATE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.8 or higher.
imagick::ALPHACHANNEL_DEACTIVATE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.8 or higher.
imagick::ALPHACHANNEL_RESET (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.8 or higher.
imagick::ALPHACHANNEL_SET (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.8 or higher.
imagick::ALPHACHANNEL_UNDEFINED (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::ALPHACHANNEL_COPY (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::ALPHACHANNEL_EXTRACT (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::ALPHACHANNEL_OPAQUE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::ALPHACHANNEL_SHAPE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::ALPHACHANNEL_TRANSPARENT (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
SPARSECOLORMETHOD constants

imagick::SPARSECOLORMETHOD_UNDEFINED (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::SPARSECOLORMETHOD_BARYCENTRIC (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::SPARSECOLORMETHOD_BILINEAR (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::SPARSECOLORMETHOD_POLYNOMIAL (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::SPARSECOLORMETHOD_SPEPARDS (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::SPARSECOLORMETHOD_VORONOI (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
FUNCTION constants

imagick::FUNCTION_UNDEFINED (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.9 or higher.
imagick::FUNCTION_POLYNOMIAL (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.9 or higher.
imagick::FUNCTION_SINUSOID (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.9 or higher.
INTERPOLATE constants

imagick::INTERPOLATE_UNDEFINED (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.2 or higher.
imagick::INTERPOLATE_AVERAGE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.2 or higher.
imagick::INTERPOLATE_BICUBIC (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.2 or higher.
imagick::INTERPOLATE_BILINEAR (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.2 or higher.
imagick::INTERPOLATE_FILTER (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.2 or higher.
imagick::INTERPOLATE_INTEGER (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.2 or higher.
imagick::INTERPOLATE_MESH (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.2 or higher.
imagick::INTERPOLATE_NEARESTNEIGHBOR (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.2 or higher.
imagick::INTERPOLATE_SPLINE (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.3.4 or higher.
DITHERMETHOD constants

imagick::DITHERMETHOD_UNDEFINED (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DITHERMETHOD_NO (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DITHERMETHOD_RIEMERSMA (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.
imagick::DITHERMETHOD_FLOYDSTEINBERG (int)
此常量可用仅当Imagick编译于ImageMagick版本 6.4.6 or higher.


  • ? 预定义常量
  • Basic usage ?
  • PHP Manual
  • ImageMagick
  • 范例

范例

Table of Contents

  • Basic usage


Basic usage

Imagick makes image manipulation in PHP extremely easy through an OO interface. Here is a quick example on how to make a thumbnail:

Example #1 Creating a thumbnail in Imagick

<?php

header('Content-type: image/jpeg');

$image = new Imagick('image.jpg');

// If 0 is provided as a width or height parameter,
// aspect ratio is maintained
$image->thumbnailImage(100, 0);

echo $image;

?>

Using SPL and other OO features supported in Imagick, it can be simple to resize all files in a directory (useful for batch resizing large digital camera images to be web viewable). Here we use resize, as we might want to retain certain meta-data:

Example #2 Make a thumbnail of all JPG files in a directory

<?php

$images = new Imagick(glob('images/*.JPG'));

foreach($images as $image) {

    // Providing 0 forces thumbnailImage to maintain aspect ratio
    $image->thumbnailImage(1024,0);

}

$images->writeImages();

?>

This is an example of creating a reflection of an image. The reflection is created by flipping the image and overlaying a gradient on it. Then both, the original image and the reflection is overlayed on a canvas.

Example #3 Creating a reflection of an image

<?php
/* Read the image */
$im = new Imagick("test.png");

/* Thumbnail the image */
$im->thumbnailImage(200, null);

/* Create a border for the image */
$im->borderImage(new ImagickPixel("white"), 5, 5);

/* Clone the image and flip it */
$reflection = $im->clone();
$reflection->flipImage();

/* Create gradient. It will be overlayed on the reflection */
$gradient = new Imagick();

/* Gradient needs to be large enough for the image and the borders */
$gradient->newPseudoImage($reflection->getImageWidth() + 10, $reflection->getImageHeight() + 10, "gradient:transparent-black");

/* Composite the gradient on the reflection */
$reflection->compositeImage($gradient, imagick::COMPOSITE_OVER, 0, 0);

/* Add some opacity. Requires ImageMagick 6.2.9 or later */
$reflection->setImageOpacity( 0.3 );

/* Create an empty canvas */
$canvas = new Imagick();

/* Canvas needs to be large enough to hold the both images */
$width = $im->getImageWidth() + 40;
$height = ($im->getImageHeight() * 2) + 30;
$canvas->newImage($width, $height, new ImagickPixel("black"));
$canvas->setImageFormat("png");

/* Composite the original image and the reflection on the canvas */
$canvas->compositeImage($im, imagick::COMPOSITE_OVER, 20, 10);
$canvas->compositeImage($reflection, imagick::COMPOSITE_OVER, 20, $im->getImageHeight() + 10);

/* Output the image*/
header("Content-Type: image/png");
echo $canvas;
?>

以上例程的输出类似于：

Output of example : Creating a reflection of an image

This example illustrates how to use fill patterns during drawing.

Example #4 Filling text with gradient

<?php

/* Create a new imagick object */
$im = new Imagick();

/* Create new image. This will be used as fill pattern */
$im->newPseudoImage(50, 50, "gradient:red-black");

/* Create imagickdraw object */
$draw = new ImagickDraw();

/* Start a new pattern called "gradient" */
$draw->pushPattern('gradient', 0, 0, 50, 50);

/* Composite the gradient on the pattern */
$draw->composite(Imagick::COMPOSITE_OVER, 0, 0, 50, 50, $im);

/* Close the pattern */
$draw->popPattern();

/* Use the pattern called "gradient" as the fill */
$draw->setFillPatternURL('#gradient');

/* Set font size to 52 */
$draw->setFontSize(52);

/* Annotate some text */
$draw->annotation(20, 50, "Hello World!");

/* Create a new canvas object and a white image */
$canvas = new Imagick();
$canvas->newImage(350, 70, "white");

/* Draw the ImagickDraw on to the canvas */
$canvas->drawImage($draw);

/* 1px black border around the image */
$canvas->borderImage('black', 1, 1);

/* Set the format to PNG */
$canvas->setImageFormat('png');

/* Output the image */
header("Content-Type: image/png");
echo $canvas;
?>

以上例程的输出类似于：

Output of example : Filling text with gradient

Working with animated GIF images

Example #5 Read in GIF image and resize all frames

<?php

/* Create a new imagick object and read in GIF */
$im = new Imagick("example.gif");

/* Resize all frames */
foreach ($im as $frame) {
    /* 50x50 frames */
    $frame->thumbnailImage(50, 50);

    /* Set the virtual canvas to correct size */
    $frame->setImagePage(50, 50, 0, 0);
}

/* Notice writeImages instead of writeImage */
$im->writeImages("example_small.gif", true);
?>

Working with ellipse primitive and custom fonts

Example #6 Create a PHP logo

<?php
/* Set width and height in proportion of genuine PHP logo */
$width = 400;
$height = 210;

/* Create an Imagick object with transparent canvas */
$img = new Imagick();
$img->newImage($width, $height, new ImagickPixel('transparent'));

/* New ImagickDraw instance for ellipse draw */
$draw = new ImagickDraw();
/* Set purple fill color for ellipse */
$draw->setFillColor('#777bb4');
/* Set ellipse dimensions */
$draw->ellipse($width / 2, $height / 2, $width / 2, $height / 2, 0, 360);
/* Draw ellipse onto the canvas */
$img->drawImage($draw);

/* Reset fill color from purple to black for text (note: we are reusing ImagickDraw object) */
$draw->setFillColor('black');
/* Set stroke border to white color */
$draw->setStrokeColor('white');
/* Set stroke border thickness */
$draw->setStrokeWidth(2);
/* Set font kerning (negative value means that letters are closer to each other) */
$draw->setTextKerning(-8);
/* Set font and font size used in PHP logo */
$draw->setFont('Handel Gothic.ttf');
$draw->setFontSize(150);
/* Center text horizontally and vertically */
$draw->setGravity(Imagick::GRAVITY_CENTER);

/* Add center "php" with Y offset of -10 to canvas (inside ellipse) */
$img->annotateImage($draw, 0, -10, 0, 'php');
$img->setImageFormat('png');

/* Set appropriate header for PNG and output the image */
header('Content-Type: image/png');
echo $img;
?>

以上例程的输出类似于：

Output of example : Creating PHP logo with Imagick


The Imagick class

(PECL imagick 2, PECL imagick 3)

类摘要

Imagick implements Iterator {
public adaptiveBlurImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public adaptiveResizeImage ( int $columns , int $rows , bool $bestfit = false , bool $legacy = false ) : bool
public adaptiveSharpenImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public adaptiveThresholdImage ( int $width , int $height , int $offset ) : bool
public addImage ( Imagick $source ) : bool
public addNoiseImage ( int $noise_type , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public affineTransformImage ( ImagickDraw $matrix ) : bool
public animateImages ( string $x_server ) : bool
public annotateImage ( ImagickDraw $draw_settings , float $x , float $y , float $angle , string $text ) : bool
public appendImages ( bool $stack ) : Imagick
public autoLevelImage ( int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public averageImages ( ) : Imagick
public blackThresholdImage ( mixed $threshold ) : bool
public blueShiftImage ( float $factor = 1.5 ) : bool
public blurImage ( float $radius , float $sigma , int $channel = ? ) : bool
public borderImage ( mixed $bordercolor , int $width , int $height ) : bool
public brightnessContrastImage ( float $brightness , float $contrast , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public charcoalImage ( float $radius , float $sigma ) : bool
public chopImage ( int $width , int $height , int $x , int $y ) : bool
public clampImage ( int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public clear ( ) : bool
public clipImage ( ) : bool
public clipImagePath ( string $pathname , string $inside ) : void
public clipPathImage ( string $pathname , bool $inside ) : bool
public clone ( ) : Imagick
public clutImage ( Imagick $lookup_table , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public coalesceImages ( ) : Imagick
public colorFloodfillImage ( mixed $fill , float $fuzz , mixed $bordercolor , int $x , int $y ) : bool
public colorizeImage ( mixed $colorize , mixed $opacity , bool $legacy = false ) : bool
public colorMatrixImage ( array $color_matrix = Imagick::CHANNEL_DEFAULT ) : bool
public combineImages ( int $channelType ) : Imagick
public commentImage ( string $comment ) : bool
public compareImageChannels ( Imagick $image , int $channelType , int $metricType ) : array
public compareImageLayers ( int $method ) : Imagick
public compareImages ( Imagick $compare , int $metric ) : array
compositeImage ( Imagick $composite_object , int $composite , int $x , int $y , int $channel = Imagick::CHANNEL_ALL ) : bool
public __construct ( mixed $files = ? )
public contrastImage ( bool $sharpen ) : bool
public contrastStretchImage ( float $black_point , float $white_point , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public convolveImage ( array $kernel , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public count ( int $mode = 0 ) : int
cropImage ( int $width , int $height , int $x , int $y ) : bool
cropThumbnailImage ( int $width , int $height ) : bool
public current ( ) : Imagick
public cycleColormapImage ( int $displace ) : bool
public decipherImage ( string $passphrase ) : bool
public deconstructImages ( ) : Imagick
public deleteImageArtifact ( string $artifact ) : bool
public deleteImageProperty ( string $name ) : bool
public deskewImage ( float $threshold ) : bool
public despeckleImage ( ) : bool
public destroy ( ) : bool
public displayImage ( string $servername ) : bool
public displayImages ( string $servername ) : bool
public distortImage ( int $method , array $arguments , bool $bestfit ) : bool
drawImage ( ImagickDraw $draw ) : bool
public edgeImage ( float $radius ) : bool
public embossImage ( float $radius , float $sigma ) : bool
public encipherImage ( string $passphrase ) : bool
public enhanceImage ( ) : bool
public equalizeImage ( ) : bool
public evaluateImage ( int $op , float $constant , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public exportImagePixels ( int $x , int $y , int $width , int $height , string $map , int $STORAGE ) : array
public extentImage ( int $width , int $height , int $x , int $y ) : bool
public filter ( ImagickKernel $ImagickKernel , int $channel = Imagick::CHANNEL_UNDEFINED ) : bool
public flattenImages ( ) : Imagick
public flipImage ( ) : bool
public floodFillPaintImage ( mixed $fill , float $fuzz , mixed $target , int $x , int $y , bool $invert , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public flopImage ( ) : bool
public forwardFourierTransformimage ( bool $magnitude ) : bool
public frameImage ( mixed $matte_color , int $width , int $height , int $inner_bevel , int $outer_bevel ) : bool
public functionImage ( int $function , array $arguments , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public fxImage ( string $expression , int $channel = Imagick::CHANNEL_DEFAULT ) : Imagick
public gammaImage ( float $gamma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public gaussianBlurImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public getColorspace ( ) : int
public getCompression ( ) : int
public getCompressionQuality ( ) : int
public static getCopyright ( ) : string
public getFilename ( ) : string
public getFont ( ) : string
public getFormat ( ) : string
public getGravity ( ) : int
public static getHomeURL ( ) : string
public getImage ( ) : Imagick
getImageAlphaChannel ( ) : int
public getImageArtifact ( string $artifact ) : string
public getImageAttribute ( string $key ) : string
public getImageBackgroundColor ( ) : ImagickPixel
public getImageBlob ( ) : string
public getImageBluePrimary ( ) : array
public getImageBorderColor ( ) : ImagickPixel
public getImageChannelDepth ( int $channel ) : int
public getImageChannelDistortion ( Imagick $reference , int $channel , int $metric ) : float
public getImageChannelDistortions ( Imagick $reference , int $metric , int $channel = Imagick::CHANNEL_DEFAULT ) : float
public getImageChannelExtrema ( int $channel ) : array
public getImageChannelKurtosis ( int $channel = Imagick::CHANNEL_DEFAULT ) : array
public getImageChannelMean ( int $channel ) : array
public getImageChannelRange ( int $channel ) : array
public getImageChannelStatistics ( ) : array
public getImageClipMask ( ) : Imagick
public getImageColormapColor ( int $index ) : ImagickPixel
public getImageColors ( ) : int
public getImageColorspace ( ) : int
public getImageCompose ( ) : int
public getImageCompression ( ) : int
public getImageCompressionQuality ( ) : int
public getImageDelay ( ) : int
public getImageDepth ( ) : int
public getImageDispose ( ) : int
public getImageDistortion ( MagickWand $reference , int $metric ) : float
public getImageExtrema ( ) : array
public getImageFilename ( ) : string
public getImageFormat ( ) : string
public getImageGamma ( ) : float
public getImageGeometry ( ) : array
public getImageGravity ( ) : int
public getImageGreenPrimary ( ) : array
public getImageHeight ( ) : int
public getImageHistogram ( ) : array
public getImageIndex ( ) : int
public getImageInterlaceScheme ( ) : int
public getImageInterpolateMethod ( ) : int
public getImageIterations ( ) : int
public getImageLength ( ) : int
public getImageMatte ( ) : bool
public getImageMatteColor ( ) : ImagickPixel
public getImageMimeType ( ) : string
public getImageOrientation ( ) : int
public getImagePage ( ) : array
public getImagePixelColor ( int $x , int $y ) : ImagickPixel
public getImageProfile ( string $name ) : string
public getImageProfiles ( string $pattern = "*" , bool $include_values = true ) : array
public getImageProperties ( string $pattern = "*" , bool $include_values = true ) : array
public getImageProperty ( string $name ) : string
public getImageRedPrimary ( ) : array
public getImageRegion ( int $width , int $height , int $x , int $y ) : Imagick
public getImageRenderingIntent ( ) : int
getImageResolution ( ) : array
public getImagesBlob ( ) : string
public getImageScene ( ) : int
public getImageSignature ( ) : string
public getImageSize ( ) : int
public getImageTicksPerSecond ( ) : int
public getImageTotalInkDensity ( ) : float
public getImageType ( ) : int
getImageUnits ( ) : int
public getImageVirtualPixelMethod ( ) : int
public getImageWhitePoint ( ) : array
public getImageWidth ( ) : int
public getInterlaceScheme ( ) : int
public getIteratorIndex ( ) : int
public getNumberImages ( ) : int
public getOption ( string $key ) : string
public static getPackageName ( ) : string
public getPage ( ) : array
public getPixelIterator ( ) : ImagickPixelIterator
public getPixelRegionIterator ( int $x , int $y , int $columns , int $rows ) : ImagickPixelIterator
public getPointSize ( ) : float
public static getQuantum ( ) : int
public static getQuantumDepth ( ) : array
public static getQuantumRange ( ) : array
public static getRegistry ( string $key ) : string
public static getReleaseDate ( ) : string
public static getResource ( int $type ) : int
public static getResourceLimit ( int $type ) : int
public getSamplingFactors ( ) : array
public getSize ( ) : array
public getSizeOffset ( ) : int
public static getVersion ( ) : array
public haldClutImage ( Imagick $clut , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public hasNextImage ( ) : bool
public hasPreviousImage ( ) : bool
public identifyFormat ( string $embedText ) : string|false
public identifyImage ( bool $appendRawOutput = false ) : array
public implodeImage ( float $radius ) : bool
public importImagePixels ( int $x , int $y , int $width , int $height , string $map , int $storage , array $pixels ) : bool
public inverseFourierTransformImage ( Imagick $complement , bool $magnitude ) : bool
public labelImage ( string $label ) : bool
public levelImage ( float $blackPoint , float $gamma , float $whitePoint , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public linearStretchImage ( float $blackPoint , float $whitePoint ) : bool
public liquidRescaleImage ( int $width , int $height , float $delta_x , float $rigidity ) : bool
public static listRegistry ( ) : array
public magnifyImage ( ) : bool
public mapImage ( Imagick $map , bool $dither ) : bool
public matteFloodfillImage ( float $alpha , float $fuzz , mixed $bordercolor , int $x , int $y ) : bool
public medianFilterImage ( float $radius ) : bool
public mergeImageLayers ( int $layer_method ) : Imagick
public minifyImage ( ) : bool
public modulateImage ( float $brightness , float $saturation , float $hue ) : bool
public montageImage ( ImagickDraw $draw , string $tile_geometry , string $thumbnail_geometry , int $mode , string $frame ) : Imagick
public morphImages ( int $number_frames ) : Imagick
public morphology ( int $morphologyMethod , int $iterations , ImagickKernel $ImagickKernel , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public mosaicImages ( ) : Imagick
public motionBlurImage ( float $radius , float $sigma , float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public negateImage ( bool $gray , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
newImage ( int $cols , int $rows , mixed $background , string $format = ? ) : bool
public newPseudoImage ( int $columns , int $rows , string $pseudoString ) : bool
public nextImage ( ) : bool
public normalizeImage ( int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public oilPaintImage ( float $radius ) : bool
public opaquePaintImage ( mixed $target , mixed $fill , float $fuzz , bool $invert , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public optimizeImageLayers ( ) : bool
public orderedPosterizeImage ( string $threshold_map , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public paintFloodfillImage ( mixed $fill , float $fuzz , mixed $bordercolor , int $x , int $y , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public paintOpaqueImage ( mixed $target , mixed $fill , float $fuzz , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public paintTransparentImage ( mixed $target , float $alpha , float $fuzz ) : bool
public pingImage ( string $filename ) : bool
public pingImageBlob ( string $image ) : bool
public pingImageFile ( resource $filehandle , string $fileName = ? ) : bool
public polaroidImage ( ImagickDraw $properties , float $angle ) : bool
public posterizeImage ( int $levels , bool $dither ) : bool
public previewImages ( int $preview ) : bool
public previousImage ( ) : bool
public profileImage ( string $name , string $profile ) : bool
public quantizeImage ( int $numberColors , int $colorspace , int $treedepth , bool $dither , bool $measureError ) : bool
public quantizeImages ( int $numberColors , int $colorspace , int $treedepth , bool $dither , bool $measureError ) : bool
public queryFontMetrics ( ImagickDraw $properties , string $text , bool $multiline = ? ) : array
public static queryFonts ( string $pattern = "*" ) : array
public static queryFormats ( string $pattern = "*" ) : array
public radialBlurImage ( float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public raiseImage ( int $width , int $height , int $x , int $y , bool $raise ) : bool
public randomThresholdImage ( float $low , float $high , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public readImage ( string $filename ) : bool
readImageBlob ( string $image , string $filename = ? ) : bool
public readImageFile ( resource $filehandle , string $fileName = null ) : bool
public readImages ( array $filenames ) : bool
public recolorImage ( array $matrix ) : bool
public reduceNoiseImage ( float $radius ) : bool
public remapImage ( Imagick $replacement , int $DITHER ) : bool
public removeImage ( ) : bool
public removeImageProfile ( string $name ) : string
public render ( ) : bool
public resampleImage ( float $x_resolution , float $y_resolution , int $filter , float $blur ) : bool
public resetImagePage ( string $page ) : bool
public resizeImage ( int $columns , int $rows , int $filter , float $blur , bool $bestfit = false , bool $legacy = false ) : bool
public rollImage ( int $x , int $y ) : bool
public rotateImage ( mixed $background , float $degrees ) : bool
public rotationalBlurImage ( float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public roundCorners ( float $x_rounding , float $y_rounding , float $stroke_width = 10 , float $displace = 5 , float $size_correction = -6 ) : bool
public sampleImage ( int $columns , int $rows ) : bool
public scaleImage ( int $cols , int $rows , bool $bestfit = false , bool $legacy = false ) : bool
public segmentImage ( int $COLORSPACE , float $cluster_threshold , float $smooth_threshold , bool $verbose = false ) : bool
public selectiveBlurImage ( float $radius , float $sigma , float $threshold , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public separateImageChannel ( int $channel ) : bool
public sepiaToneImage ( float $threshold ) : bool
public setBackgroundColor ( mixed $background ) : bool
public setColorspace ( int $COLORSPACE ) : bool
public setCompression ( int $compression ) : bool
public setCompressionQuality ( int $quality ) : bool
public setFilename ( string $filename ) : bool
public setFirstIterator ( ) : bool
public setFont ( string $font ) : bool
public setFormat ( string $format ) : bool
public setGravity ( int $gravity ) : bool
public setImage ( Imagick $replace ) : bool
public setImageAlphaChannel ( int $mode ) : bool
public setImageArtifact ( string $artifact , string $value ) : bool
public setImageAttribute ( string $key , string $value ) : bool
public setImageBackgroundColor ( mixed $background ) : bool
public setImageBias ( float $bias ) : bool
public setImageBiasQuantum ( string $bias ) : void
public setImageBluePrimary ( float $x , float $y ) : bool
public setImageBorderColor ( mixed $border ) : bool
public setImageChannelDepth ( int $channel , int $depth ) : bool
public setImageClipMask ( Imagick $clip_mask ) : bool
public setImageColormapColor ( int $index , ImagickPixel $color ) : bool
public setImageColorspace ( int $colorspace ) : bool
public setImageCompose ( int $compose ) : bool
setImageCompression ( int $compression ) : bool
setImageCompressionQuality ( int $quality ) : bool
public setImageDelay ( int $delay ) : bool
public setImageDepth ( int $depth ) : bool
public setImageDispose ( int $dispose ) : bool
public setImageExtent ( int $columns , int $rows ) : bool
public setImageFilename ( string $filename ) : bool
setImageFormat ( string $format ) : bool
public setImageGamma ( float $gamma ) : bool
public setImageGravity ( int $gravity ) : bool
public setImageGreenPrimary ( float $x , float $y ) : bool
public setImageIndex ( int $index ) : bool
public setImageInterlaceScheme ( int $interlace_scheme ) : bool
public setImageInterpolateMethod ( int $method ) : bool
public setImageIterations ( int $iterations ) : bool
public setImageMatte ( bool $matte ) : bool
public setImageMatteColor ( mixed $matte ) : bool
public setImageOpacity ( float $opacity ) : bool
public setImageOrientation ( int $orientation ) : bool
public setImagePage ( int $width , int $height , int $x , int $y ) : bool
public setImageProfile ( string $name , string $profile ) : bool
public setImageProperty ( string $name , string $value ) : bool
public setImageRedPrimary ( float $x , float $y ) : bool
public setImageRenderingIntent ( int $rendering_intent ) : bool
public setImageResolution ( float $x_resolution , float $y_resolution ) : bool
public setImageScene ( int $scene ) : bool
public setImageTicksPerSecond ( int $ticks_per_second ) : bool
public setImageType ( int $image_type ) : bool
public setImageUnits ( int $units ) : bool
public setImageVirtualPixelMethod ( int $method ) : bool
public setImageWhitePoint ( float $x , float $y ) : bool
public setInterlaceScheme ( int $interlace_scheme ) : bool
public setIteratorIndex ( int $index ) : bool
public setLastIterator ( ) : bool
public setOption ( string $key , string $value ) : bool
public setPage ( int $width , int $height , int $x , int $y ) : bool
public setPointSize ( float $point_size ) : bool
public setProgressMonitor ( callable $callback ) : bool
public static setRegistry ( string $key , string $value ) : bool
public setResolution ( float $x_resolution , float $y_resolution ) : bool
public static setResourceLimit ( int $type , int $limit ) : bool
public setSamplingFactors ( array $factors ) : bool
public setSize ( int $columns , int $rows ) : bool
public setSizeOffset ( int $columns , int $rows , int $offset ) : bool
public setType ( int $image_type ) : bool
public shadeImage ( bool $gray , float $azimuth , float $elevation ) : bool
public shadowImage ( float $opacity , float $sigma , int $x , int $y ) : bool
public sharpenImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public shaveImage ( int $columns , int $rows ) : bool
public shearImage ( mixed $background , float $x_shear , float $y_shear ) : bool
public sigmoidalContrastImage ( bool $sharpen , float $alpha , float $beta , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public sketchImage ( float $radius , float $sigma , float $angle ) : bool
public smushImages ( bool $stack , int $offset ) : Imagick
public solarizeImage ( int $threshold ) : bool
public sparseColorImage ( int $SPARSE_METHOD , array $arguments , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public spliceImage ( int $width , int $height , int $x , int $y ) : bool
public spreadImage ( float $radius ) : bool
public statisticImage ( int $type , int $width , int $height , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public steganoImage ( Imagick $watermark_wand , int $offset ) : Imagick
public stereoImage ( Imagick $offset_wand ) : bool
stripImage ( ) : bool
public subImageMatch ( Imagick $Imagick , array &$offset = ? , float &$similarity = ? ) : Imagick
swirlImage ( float $degrees ) : bool
textureImage ( Imagick $texture_wand ) : Imagick
public thresholdImage ( float $threshold , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public thumbnailImage ( int $columns , int $rows , bool $bestfit = false , bool $fill = false , bool $legacy = false ) : bool
public tintImage ( mixed $tint , mixed $opacity , bool $legacy = false ) : bool
public __toString ( ) : string
public transformImage ( string $crop , string $geometry ) : Imagick
public transformImageColorspace ( int $colorspace ) : bool
public transparentPaintImage ( mixed $target , float $alpha , float $fuzz , bool $invert ) : bool
public transposeImage ( ) : bool
public transverseImage ( ) : bool
public trimImage ( float $fuzz ) : bool
public uniqueImageColors ( ) : bool
public unsharpMaskImage ( float $radius , float $sigma , float $amount , float $threshold , int $channel = Imagick::CHANNEL_DEFAULT ) : bool
public valid ( ) : bool
public vignetteImage ( float $blackPoint , float $whitePoint , int $x , int $y ) : bool
public waveImage ( float $amplitude , float $length ) : bool
public whiteThresholdImage ( mixed $threshold ) : bool
writeImage ( string $filename = NULL ) : bool
public writeImageFile ( resource $filehandle , string $format = ? ) : bool
public writeImages ( string $filename , bool $adjoin ) : bool
public writeImagesFile ( resource $filehandle , string $format = ? ) : bool
}

Image methods and global methods

The Imagick class has the ability to hold and operate on multiple images simultaneously. This is achieved through an internal stack. There is always an internal pointer that points at the current image. Some functions operate on all images in the Imagick class, but most operate only on the current image in the internal stack. As a convention, method names can contain the word Image to denote they affect only the current image in the stack.

Class Methods

Because there are so many methods, here is a handy list of methods, somewhat reduced to their general purpose:

Class methods by purpose
Image effects | Get methods | Set methods | Read/write images | Other
Imagick::adaptiveBlurImage() | Imagick::getCompression() | Imagick::setBackgroundColor() | Imagick::__construct() | Imagick::clear()
Imagick::adaptiveResizeImage() | Imagick::getFilename() | Imagick::setCompressionQuality() | Imagick::addImage() | Imagick::clone()
Imagick::adaptiveSharpenImage() | Imagick::getFormat() | Imagick::setCompression() | Imagick::appendImages() | Imagick::current()
Imagick::adaptiveThresholdImage() | Imagick::getImageBackgroundColor() | Imagick::setFilename() | Imagick::getFilename() | Imagick::destroy()
Imagick::addNoiseImage() | Imagick::getImageBlob() | Imagick::getImagesBlob() | Imagick::setFormat() | Imagick::getFormat()
Imagick::affinetransformimage() | Imagick::getImageBluePrimary() | Imagick::setImageBackgroundColor() | Imagick::getImageFilename() | Imagick::getHomeURL()
Imagick::annotateImage() | Imagick::getImageBorderColor() | Imagick::setFirstIterator() | Imagick::getImageFormat() | Imagick::commentImage()
Imagick::averageImages() | Imagick::getImageChannelDepth() | Imagick::setImageBias() | Imagick::getImage() | Imagick::getNumberImages()
Imagick::blackThresholdImage() | Imagick::getImageChannelDistortion() | Imagick::setImageBluePrimary() | Imagick::setImageFilename() | Imagick::getReleaseDate()
Imagick::blurImage() | Imagick::getImageChannelExtrema() | Imagick::setImageBorderColor() | Imagick::setImageFormat() | Imagick::getVersion()
Imagick::borderImage() | Imagick::getImageChannelMean() | Imagick::setImageChannelDepth() | Imagick::readImageFile() | Imagick::hasNextImage()
Imagick::charcoalImage() | Imagick::getImageChannelStatistics() | Imagick::setImageColormapColor() | Imagick::readImage() | Imagick::hasPreviousImage()
Imagick::chopImage() | Imagick::getImageColormapColor() | Imagick::setImageColorSpace() | Imagick::writeImages() | Imagick::labelImage()
Imagick::clipImage() | Imagick::getImageColorspace() | Imagick::setImageCompose() | Imagick::writeImage() | Imagick::newImage()
Imagick::clipPathImage() | Imagick::getImageColors() | Imagick::setImageCompression() |  | Imagick::newPseudoImage()
Imagick::coalesceImages() | Imagick::getImageCompose() | Imagick::setImageDelay() |  | Imagick::nextImage()
Imagick::colorFloodFillImage() | Imagick::getImageDelay() | Imagick::setImageDepth() |  | Imagick::pingImageBlob()
Imagick::colorizeImage() | Imagick::getImageDepth() | Imagick::setImageDispose() |  | Imagick::pingImageFile()
Imagick::combineImages() | Imagick::getImageDispose() | Imagick::setImageDispose() |  | Imagick::pingImage()
Imagick::compareImageChannels() | Imagick::getImageDistortion() | Imagick::setImageExtent() |  | Imagick::previousImage()
Imagick::compareImageLayers() | Imagick::getImageExtrema() | Imagick::setImageFilename() |  | Imagick::profileImage()
Imagick::compositeImage() | Imagick::getImageFilename() | Imagick::setImageFormat() |  | Imagick::queryFormats()
Imagick::contrastImage() | Imagick::getImageFormat() | Imagick::setImageGamma() |  | Imagick::removeImageProfile()
Imagick::contrastStretchImage() | Imagick::getImageGamma() | Imagick::setImageGreenPrimary() |  | Imagick::removeImage()
Imagick::convolveImage() | Imagick::getImageGeometry() | Imagick::setImageIndex() |  | Imagick::setFirstIterator()
Imagick::cropImage() | Imagick::getImageGreenPrimary() | Imagick::setImageInterpolateMethod() |  | Imagick::setImageIndex()
Imagick::cycleColormapImage() | Imagick::getImageHeight() | Imagick::setImageIterations() |  | Imagick::valid()
Imagick::deconstructImages() | Imagick::getImageHistogram() | Imagick::setImageMatteColor() |  | Imagick::getCopyright()
Imagick::drawImage() | Imagick::getImageIndex() | Imagick::setImageMatte() |  |
Imagick::edgeImage() | Imagick::getImageInterlaceScheme() | Imagick::setImagePage() |  |
Imagick::embossImage() | Imagick::getImageInterpolateMethod() | Imagick::setImageProfile() |  |
Imagick::enhanceImage() | Imagick::getImageIterations() | Imagick::setImageProperty() |  |
Imagick::equalizeImage() | Imagick::getImageMatteColor() | Imagick::setImageRedPrimary() |  |
Imagick::evaluateImage() | Imagick::getImageMatte() | Imagick::setImageRenderingIntent() |  |
Imagick::flattenImages() | Imagick::getImagePage() | Imagick::setImageResolution() |  |
Imagick::flipImage() | Imagick::getImagePixelColor() | Imagick::setImageScene() |  |
Imagick::flopImage() | Imagick::getImageProfile() | Imagick::setImageTicksPerSecond() |  |
 | Imagick::getImageProperty() | Imagick::setImageType() |  |
Imagick::fxImage() | Imagick::getImageRedPrimary() | Imagick::setImageUnits() |  |
Imagick::gammaImage() | Imagick::getImageRegion() | Imagick::setImageVirtualPixelMethod() |  |
Imagick::gaussianBlurImage() | Imagick::getImageRenderingIntent() | Imagick::setImageWhitepoint() |  |
Imagick::implodeImage() | Imagick::getImageResolution() | Imagick::setInterlaceScheme() |  |
Imagick::levelImage() | Imagick::getImageScene() | Imagick::setOption() |  |
Imagick::linearStretchImage() | Imagick::getImageSignature() | Imagick::setPage() |  |
Imagick::magnifyImage() | Imagick::getImageTicksPerSecond() | Imagick::setResolution() |  |
Imagick::matteFloodFillImage() | Imagick::getImageTotalInkDensity() | Imagick::setResourceLimit() |  |
Imagick::medianFilterImage() | Imagick::getImageType() | Imagick::setSamplingFactors() |  |
Imagick::minifyImage() | Imagick::getImageUnits() | Imagick::setSizeOffset() |  |
Imagick::modulateImage() | Imagick::getImageVirtualPixelMethod() | Imagick::setSize() |  |
Imagick::montageImage() | Imagick::getImageWhitepoint() | Imagick::setType() |  |
Imagick::morphImages() | Imagick::getImageWidth() |  |  |
Imagick::mosaicImages() | Imagick::getImage() |  |  |
Imagick::motionBlurImage() | Imagick::getInterlaceScheme() |  |  |
Imagick::negateImage() | Imagick::getNumberImages() |  |  |
Imagick::normalizeImage() | Imagick::getOption() |  |  |
Imagick::oilPaintImage() | Imagick::getPackageName() |  |  |
Imagick::optimizeImageLayers() | Imagick::getPage() |  |  |
Imagick::paintOpaqueImage() | Imagick::getPixelIterator() |  |  |
Imagick::paintTransparentImage() | Imagick::getPixelRegionIterator() |  |  |
Imagick::posterizeImage() | Imagick::getQuantumDepth() |  |  |
Imagick::radialBlurImage() | Imagick::getQuantumRange() |  |  |
Imagick::raiseImage() | Imagick::getResourceLimit() |  |  |
Imagick::randomThresholdImage() | Imagick::getResource() |  |  |
Imagick::reduceNoiseImage() | Imagick::getSamplingFactors() |  |  |
Imagick::render() | Imagick::getSizeOffset() |  |  |
Imagick::resampleImage() | Imagick::getSize() |  |  |
Imagick::resizeImage() | Imagick::identifyImage() |  |  |
Imagick::rollImage() | Imagick::getImageSize() |  |  |
Imagick::rotateImage() |  |  |  |
Imagick::sampleImage() |  |  |  |
Imagick::scaleImage() |  |  |  |
Imagick::separateImageChannel() |  |  |  |
Imagick::sepiaToneImage() |  |  |  |
Imagick::shadeImage() |  |  |  |
Imagick::shadowImage() |  |  |  |
Imagick::sharpenImage() |  |  |  |
Imagick::shaveImage() |  |  |  |
Imagick::shearImage() |  |  |  |
Imagick::sigmoidalContrastImage() |  |  |  |
Imagick::sketchImage() |  |  |  |
Imagick::solarizeImage() |  |  |  |
Imagick::spliceImage() |  |  |  |
Imagick::spreadImage() |  |  |  |
Imagick::steganoImage() |  |  |  |
Imagick::stereoImage() |  |  |  |
Imagick::stripImage() |  |  |  |
Imagick::swirlImage() |  |  |  |
Imagick::textureImage() |  |  |  |
Imagick::thresholdImage() |  |  |  |
Imagick::thumbnailImage() |  |  |  |
Imagick::tintImage() |  |  |  |
Imagick::transverseImage() |  |  |  |
Imagick::trimImage() |  |  |  |
Imagick::uniqueImageColors() |  |  |  |
Imagick::unsharpMaskImage() |  |  |  |
Imagick::vignetteImage() |  |  |  |
Imagick::waveImage() |  |  |  |
Imagick::whiteThresholdImage() |  |  |  |

Table of Contents

  • Imagick::adaptiveBlurImage — Adds adaptive blur filter to image
  • Imagick::adaptiveResizeImage — Adaptively resize image with data dependent triangulation
  • Imagick::adaptiveSharpenImage — Adaptively sharpen the image
  • Imagick::adaptiveThresholdImage — Selects a threshold for each pixel based on a range of intensity
  • Imagick::addImage — Adds new image to Imagick object image list
  • Imagick::addNoiseImage — Adds random noise to the image
  • Imagick::affineTransformImage — Transforms an image
  • Imagick::animateImages — Animates an image or images
  • Imagick::annotateImage — Annotates an image with text
  • Imagick::appendImages — Append a set of images
  • Imagick::autoLevelImage — Description
  • Imagick::averageImages — Average a set of images
  • Imagick::blackThresholdImage — Forces all pixels below the threshold into black
  • Imagick::blueShiftImage — Description
  • Imagick::blurImage — Adds blur filter to image
  • Imagick::borderImage — Surrounds the image with a border
  • Imagick::brightnessContrastImage — Description
  • Imagick::charcoalImage — Simulates a charcoal drawing
  • Imagick::chopImage — Removes a region of an image and trims
  • Imagick::clampImage — Description
  • Imagick::clear — Clears all resources associated to Imagick object
  • Imagick::clipImage — Clips along the first path from the 8BIM profile
  • Imagick::clipImagePath — Description
  • Imagick::clipPathImage — Clips along the named paths from the 8BIM profile
  • Imagick::clone — Makes an exact copy of the Imagick object
  • Imagick::clutImage — Replaces colors in the image
  • Imagick::coalesceImages — Composites a set of images
  • Imagick::colorFloodfillImage — Changes the color value of any pixel that matches target
  • Imagick::colorizeImage — Blends the fill color with the image
  • Imagick::colorMatrixImage — Description
  • Imagick::combineImages — Combines one or more images into a single image
  • Imagick::commentImage — Adds a comment to your image
  • Imagick::compareImageChannels — Returns the difference in one or more images
  • Imagick::compareImageLayers — Returns the maximum bounding region between images
  • Imagick::compareImages — Compares an image to a reconstructed image
  • Imagick::compositeImage — 把一张图合并到一张图
  • Imagick::__construct — The Imagick constructor
  • Imagick::contrastImage — Change the contrast of the image
  • Imagick::contrastStretchImage — Enhances the contrast of a color image
  • Imagick::convolveImage — Applies a custom convolution kernel to the image
  • Imagick::count — Get the number of images
  • Imagick::cropImage — 截图图片的一块区域
  • Imagick::cropThumbnailImage — 创建缩略图
  • Imagick::current — Returns a reference to the current Imagick object
  • Imagick::cycleColormapImage — Displaces an image's colormap
  • Imagick::decipherImage — Deciphers an image
  • Imagick::deconstructImages — Returns certain pixel differences between images
  • Imagick::deleteImageArtifact — Delete image artifact
  • Imagick::deleteImageProperty — Description
  • Imagick::deskewImage — Removes skew from the image
  • Imagick::despeckleImage — Reduces the speckle noise in an image
  • Imagick::destroy — Destroys the Imagick object
  • Imagick::displayImage — Displays an image
  • Imagick::displayImages — Displays an image or image sequence
  • Imagick::distortImage — Distorts an image using various distortion methods
  • Imagick::drawImage — 把 ImagickDraw 对象渲染到当前图片上
  • Imagick::edgeImage — Enhance edges within the image
  • Imagick::embossImage — Returns a grayscale image with a three-dimensional effect
  • Imagick::encipherImage — Enciphers an image
  • Imagick::enhanceImage — Improves the quality of a noisy image
  • Imagick::equalizeImage — Equalizes the image histogram
  • Imagick::evaluateImage — Applies an expression to an image
  • Imagick::exportImagePixels — Exports raw image pixels
  • Imagick::extentImage — Set image size
  • Imagick::filter — Description
  • Imagick::flattenImages — Merges a sequence of images
  • Imagick::flipImage — Creates a vertical mirror image
  • Imagick::floodFillPaintImage — Changes the color value of any pixel that matches target
  • Imagick::flopImage — Creates a vertical mirror image
  • Imagick::forwardFourierTransformImage — Description
  • Imagick::frameImage — Adds a simulated three-dimensional border
  • Imagick::functionImage — Applies a function on the image
  • Imagick::fxImage — Evaluate expression for each pixel in the image
  • Imagick::gammaImage — Gamma-corrects an image
  • Imagick::gaussianBlurImage — Blurs an image
  • Imagick::getColorspace — Gets the colorspace
  • Imagick::getCompression — Gets the object compression type
  • Imagick::getCompressionQuality — Gets the object compression quality
  • Imagick::getCopyright — Returns the ImageMagick API copyright as a string
  • Imagick::getFilename — The filename associated with an image sequence
  • Imagick::getFont — Gets font
  • Imagick::getFormat — Returns the format of the Imagick object
  • Imagick::getGravity — Gets the gravity
  • Imagick::getHomeURL — Returns the ImageMagick home URL
  • Imagick::getImage — Returns a new Imagick object
  • Imagick::getImageAlphaChannel — 获取图像的 alpha 通道
  • Imagick::getImageArtifact — Get image artifact
  • Imagick::getImageAttribute — Description
  • Imagick::getImageBackgroundColor — Returns the image background color
  • Imagick::getImageBlob — Returns the image sequence as a blob
  • Imagick::getImageBluePrimary — Returns the chromaticy blue primary point
  • Imagick::getImageBorderColor — Returns the image border color
  • Imagick::getImageChannelDepth — Gets the depth for a particular image channel
  • Imagick::getImageChannelDistortion — Compares image channels of an image to a reconstructed image
  • Imagick::getImageChannelDistortions — Gets channel distortions
  • Imagick::getImageChannelExtrema — Gets the extrema for one or more image channels
  • Imagick::getImageChannelKurtosis — The getImageChannelKurtosis purpose
  • Imagick::getImageChannelMean — Gets the mean and standard deviation
  • Imagick::getImageChannelRange — Gets channel range
  • Imagick::getImageChannelStatistics — Returns statistics for each channel in the image
  • Imagick::getImageClipMask — Gets image clip mask
  • Imagick::getImageColormapColor — Returns the color of the specified colormap index
  • Imagick::getImageColors — Gets the number of unique colors in the image
  • Imagick::getImageColorspace — Gets the image colorspace
  • Imagick::getImageCompose — Returns the composite operator associated with the image
  • Imagick::getImageCompression — Gets the current image's compression type
  • Imagick::getImageCompressionQuality — Gets the current image's compression quality
  • Imagick::getImageDelay — Gets the image delay
  • Imagick::getImageDepth — Gets the image depth
  • Imagick::getImageDispose — Gets the image disposal method
  • Imagick::getImageDistortion — Compares an image to a reconstructed image
  • Imagick::getImageExtrema — Gets the extrema for the image
  • Imagick::getImageFilename — Returns the filename of a particular image in a sequence
  • Imagick::getImageFormat — Returns the format of a particular image in a sequence
  • Imagick::getImageGamma — Gets the image gamma
  • Imagick::getImageGeometry — Gets the width and height as an associative array
  • Imagick::getImageGravity — Gets the image gravity
  • Imagick::getImageGreenPrimary — Returns the chromaticy green primary point
  • Imagick::getImageHeight — Returns the image height
  • Imagick::getImageHistogram — Gets the image histogram
  • Imagick::getImageIndex — Gets the index of the current active image
  • Imagick::getImageInterlaceScheme — Gets the image interlace scheme
  • Imagick::getImageInterpolateMethod — Returns the interpolation method
  • Imagick::getImageIterations — Gets the image iterations
  • Imagick::getImageLength — Returns the image length in bytes
  • Imagick::getImageMatte — Return if the image has a matte channel
  • Imagick::getImageMatteColor — Returns the image matte color
  • Imagick::getImageMimeType — Description
  • Imagick::getImageOrientation — Gets the image orientation
  • Imagick::getImagePage — Returns the page geometry
  • Imagick::getImagePixelColor — Returns the color of the specified pixel
  • Imagick::getImageProfile — Returns the named image profile
  • Imagick::getImageProfiles — Returns the image profiles
  • Imagick::getImageProperties — Returns the image properties
  • Imagick::getImageProperty — Returns the named image property
  • Imagick::getImageRedPrimary — Returns the chromaticity red primary point
  • Imagick::getImageRegion — Extracts a region of the image
  • Imagick::getImageRenderingIntent — Gets the image rendering intent
  • Imagick::getImageResolution — 获取图像的x,y轴分辨率
  • Imagick::getImagesBlob — Returns all image sequences as a blob
  • Imagick::getImageScene — Gets the image scene
  • Imagick::getImageSignature — Generates an SHA-256 message digest
  • Imagick::getImageSize — Returns the image length in bytes
  • Imagick::getImageTicksPerSecond — Gets the image ticks-per-second
  • Imagick::getImageTotalInkDensity — Gets the image total ink density
  • Imagick::getImageType — Gets the potential image type
  • Imagick::getImageUnits — 获取图像的分辨率单位
  • Imagick::getImageVirtualPixelMethod — Returns the virtual pixel method
  • Imagick::getImageWhitePoint — Returns the chromaticity white point
  • Imagick::getImageWidth — Returns the image width
  • Imagick::getInterlaceScheme — Gets the object interlace scheme
  • Imagick::getIteratorIndex — Gets the index of the current active image
  • Imagick::getNumberImages — Returns the number of images in the object
  • Imagick::getOption — Returns a value associated with the specified key
  • Imagick::getPackageName — Returns the ImageMagick package name
  • Imagick::getPage — Returns the page geometry
  • Imagick::getPixelIterator — Returns a MagickPixelIterator
  • Imagick::getPixelRegionIterator — Get an ImagickPixelIterator for an image section
  • Imagick::getPointSize — Gets point size
  • Imagick::getQuantum — Description
  • Imagick::getQuantumDepth — Gets the quantum depth
  • Imagick::getQuantumRange — Returns the Imagick quantum range
  • Imagick::getRegistry — Description
  • Imagick::getReleaseDate — Returns the ImageMagick release date
  • Imagick::getResource — Returns the specified resource's memory usage
  • Imagick::getResourceLimit — Returns the specified resource limit
  • Imagick::getSamplingFactors — Gets the horizontal and vertical sampling factor
  • Imagick::getSize — Returns the size associated with the Imagick object
  • Imagick::getSizeOffset — Returns the size offset
  • Imagick::getVersion — Returns the ImageMagick API version
  • Imagick::haldClutImage — Replaces colors in the image
  • Imagick::hasNextImage — Checks if the object has more images
  • Imagick::hasPreviousImage — Checks if the object has a previous image
  • Imagick::identifyFormat — Description
  • Imagick::identifyImage — Identifies an image and fetches attributes
  • Imagick::implodeImage — Creates a new image as a copy
  • Imagick::importImagePixels — Imports image pixels
  • Imagick::inverseFourierTransformImage — Description
  • Imagick::labelImage — Adds a label to an image
  • Imagick::levelImage — Adjusts the levels of an image
  • Imagick::linearStretchImage — Stretches with saturation the image intensity
  • Imagick::liquidRescaleImage — Animates an image or images
  • Imagick::listRegistry — Description
  • Imagick::magnifyImage — Scales an image proportionally 2x
  • Imagick::mapImage — Replaces the colors of an image with the closest color from a reference image
  • Imagick::matteFloodfillImage — Changes the transparency value of a color
  • Imagick::medianFilterImage — Applies a digital filter
  • Imagick::mergeImageLayers — Merges image layers
  • Imagick::minifyImage — Scales an image proportionally to half its size
  • Imagick::modulateImage — Control the brightness, saturation, and hue
  • Imagick::montageImage — Creates a composite image
  • Imagick::morphImages — Method morphs a set of images
  • Imagick::morphology — Description
  • Imagick::mosaicImages — Forms a mosaic from images
  • Imagick::motionBlurImage — Simulates motion blur
  • Imagick::negateImage — Negates the colors in the reference image
  • Imagick::newImage — 创建一张图片
  • Imagick::newPseudoImage — Creates a new image
  • Imagick::nextImage — Moves to the next image
  • Imagick::normalizeImage — Enhances the contrast of a color image
  • Imagick::oilPaintImage — Simulates an oil painting
  • Imagick::opaquePaintImage — Changes the color value of any pixel that matches target
  • Imagick::optimizeImageLayers — Removes repeated portions of images to optimize
  • Imagick::orderedPosterizeImage — Performs an ordered dither
  • Imagick::paintFloodfillImage — Changes the color value of any pixel that matches target
  • Imagick::paintOpaqueImage — Change any pixel that matches color
  • Imagick::paintTransparentImage — Changes any pixel that matches color with the color defined by fill
  • Imagick::pingImage — Fetch basic attributes about the image
  • Imagick::pingImageBlob — Quickly fetch attributes
  • Imagick::pingImageFile — Get basic image attributes in a lightweight manner
  • Imagick::polaroidImage — Simulates a Polaroid picture
  • Imagick::posterizeImage — Reduces the image to a limited number of color level
  • Imagick::previewImages — Quickly pin-point appropriate parameters for image processing
  • Imagick::previousImage — Move to the previous image in the object
  • Imagick::profileImage — Adds or removes a profile from an image
  • Imagick::quantizeImage — Analyzes the colors within a reference image
  • Imagick::quantizeImages — Analyzes the colors within a sequence of images
  • Imagick::queryFontMetrics — Returns an array representing the font metrics
  • Imagick::queryFonts — Returns the configured fonts
  • Imagick::queryFormats — Returns formats supported by Imagick
  • Imagick::radialBlurImage — Radial blurs an image
  • Imagick::raiseImage — Creates a simulated 3d button-like effect
  • Imagick::randomThresholdImage — Creates a high-contrast, two-color image
  • Imagick::readImage — Reads image from filename
  • Imagick::readImageBlob — 从二进制字符串里读取图片
  • Imagick::readImageFile — Reads image from open filehandle
  • Imagick::readimages — Description
  • Imagick::recolorImage — Recolors image
  • Imagick::reduceNoiseImage — Smooths the contours of an image
  • Imagick::remapImage — Remaps image colors
  • Imagick::removeImage — Removes an image from the image list
  • Imagick::removeImageProfile — Removes the named image profile and returns it
  • Imagick::render — Renders all preceding drawing commands
  • Imagick::resampleImage — Resample image to desired resolution
  • Imagick::resetImagePage — Reset image page
  • Imagick::resizeImage — Scales an image
  • Imagick::rollImage — Offsets an image
  • Imagick::rotateImage — Rotates an image
  • Imagick::rotationalBlurImage — Description
  • Imagick::roundCorners — Rounds image corners
  • Imagick::sampleImage — Scales an image with pixel sampling
  • Imagick::scaleImage — Scales the size of an image
  • Imagick::segmentImage — Segments an image
  • Imagick::selectiveBlurImage — Description
  • Imagick::separateImageChannel — Separates a channel from the image
  • Imagick::sepiaToneImage — Sepia tones an image
  • Imagick::setBackgroundColor — Sets the object's default background color
  • Imagick::setColorspace — Set colorspace
  • Imagick::setCompression — Sets the object's default compression type
  • Imagick::setCompressionQuality — Sets the object's default compression quality
  • Imagick::setFilename — Sets the filename before you read or write the image
  • Imagick::setFirstIterator — Sets the Imagick iterator to the first image
  • Imagick::setFont — Sets font
  • Imagick::setFormat — Sets the format of the Imagick object
  • Imagick::setGravity — Sets the gravity
  • Imagick::setImage — Replaces image in the object
  • Imagick::setImageAlphaChannel — Sets image alpha channel
  • Imagick::setImageArtifact — Set image artifact
  • Imagick::setImageAttribute — Description
  • Imagick::setImageBackgroundColor — Sets the image background color
  • Imagick::setImageBias — Sets the image bias for any method that convolves an image
  • Imagick::setImageBiasQuantum — Description
  • Imagick::setImageBluePrimary — Sets the image chromaticity blue primary point
  • Imagick::setImageBorderColor — Sets the image border color
  • Imagick::setImageChannelDepth — Sets the depth of a particular image channel
  • Imagick::setImageClipMask — Sets image clip mask
  • Imagick::setImageColormapColor — Sets the color of the specified colormap index
  • Imagick::setImageColorspace — Sets the image colorspace
  • Imagick::setImageCompose — Sets the image composite operator
  • Imagick::setImageCompression — 设置图片压缩的类型
  • Imagick::setImageCompressionQuality — 设置图片压缩的质量
  • Imagick::setImageDelay — Sets the image delay
  • Imagick::setImageDepth — Sets the image depth
  • Imagick::setImageDispose — Sets the image disposal method
  • Imagick::setImageExtent — Sets the image size
  • Imagick::setImageFilename — Sets the filename of a particular image
  • Imagick::setImageFormat — 为图片设置指定的格式
  • Imagick::setImageGamma — Sets the image gamma
  • Imagick::setImageGravity — Sets the image gravity
  • Imagick::setImageGreenPrimary — Sets the image chromaticity green primary point
  • Imagick::setImageIndex — Set the iterator position
  • Imagick::setImageInterlaceScheme — Sets the image compression
  • Imagick::setImageInterpolateMethod — Sets the image interpolate pixel method
  • Imagick::setImageIterations — Sets the image iterations
  • Imagick::setImageMatte — Sets the image matte channel
  • Imagick::setImageMatteColor — Sets the image matte color
  • Imagick::setImageOpacity — Sets the image opacity level
  • Imagick::setImageOrientation — Sets the image orientation
  • Imagick::setImagePage — Sets the page geometry of the image
  • Imagick::setImageProfile — Adds a named profile to the Imagick object
  • Imagick::setImageProperty — Sets an image property
  • Imagick::setImageRedPrimary — Sets the image chromaticity red primary point
  • Imagick::setImageRenderingIntent — Sets the image rendering intent
  • Imagick::setImageResolution — Sets the image resolution
  • Imagick::setImageScene — Sets the image scene
  • Imagick::setImageTicksPerSecond — Sets the image ticks-per-second
  • Imagick::setImageType — Sets the image type
  • Imagick::setImageUnits — Sets the image units of resolution
  • Imagick::setImageVirtualPixelMethod — Sets the image virtual pixel method
  • Imagick::setImageWhitePoint — Sets the image chromaticity white point
  • Imagick::setInterlaceScheme — Sets the image compression
  • Imagick::setIteratorIndex — Set the iterator position
  • Imagick::setLastIterator — Sets the Imagick iterator to the last image
  • Imagick::setOption — Set an option
  • Imagick::setPage — Sets the page geometry of the Imagick object
  • Imagick::setPointSize — Sets point size
  • Imagick::setProgressMonitor — Description
  • Imagick::setRegistry — Description
  • Imagick::setResolution — Sets the image resolution
  • Imagick::setResourceLimit — Sets the limit for a particular resource
  • Imagick::setSamplingFactors — Sets the image sampling factors
  • Imagick::setSize — Sets the size of the Imagick object
  • Imagick::setSizeOffset — Sets the size and offset of the Imagick object
  • Imagick::setType — Sets the image type attribute
  • Imagick::shadeImage — Creates a 3D effect
  • Imagick::shadowImage — Simulates an image shadow
  • Imagick::sharpenImage — Sharpens an image
  • Imagick::shaveImage — Shaves pixels from the image edges
  • Imagick::shearImage — Creating a parallelogram
  • Imagick::sigmoidalContrastImage — Adjusts the contrast of an image
  • Imagick::sketchImage — Simulates a pencil sketch
  • Imagick::smushImages — Description
  • Imagick::solarizeImage — Applies a solarizing effect to the image
  • Imagick::sparseColorImage — Interpolates colors
  • Imagick::spliceImage — Splices a solid color into the image
  • Imagick::spreadImage — Randomly displaces each pixel in a block
  • Imagick::statisticImage — Description
  • Imagick::steganoImage — Hides a digital watermark within the image
  • Imagick::stereoImage — Composites two images
  • Imagick::stripImage — 去掉图片的所有配置和设置
  • Imagick::subImageMatch — Description
  • Imagick::swirlImage — Swirls the pixels about the center of the image
  • Imagick::textureImage — Repeatedly tiles the texture image
  • Imagick::thresholdImage — Changes the value of individual pixels based on a threshold
  • Imagick::thumbnailImage — Changes the size of an image
  • Imagick::tintImage — Applies a color vector to each pixel in the image
  • Imagick::__toString — Returns the image as a string
  • Imagick::transformImage — Convenience method for setting crop size and the image geometry
  • Imagick::transformImageColorspace — Transforms an image to a new colorspace
  • Imagick::transparentPaintImage — Paints pixels transparent
  • Imagick::transposeImage — Creates a vertical mirror image
  • Imagick::transverseImage — Creates a horizontal mirror image
  • Imagick::trimImage — Remove edges from the image
  • Imagick::uniqueImageColors — Discards all but one of any pixel color
  • Imagick::unsharpMaskImage — Sharpens an image
  • Imagick::valid — Checks if the current item is valid
  • Imagick::vignetteImage — Adds vignette filter to the image
  • Imagick::waveImage — Applies wave filter to the image
  • Imagick::whiteThresholdImage — Force all pixels above the threshold into white
  • Imagick::writeImage — 把图片写入指定的文件
  • Imagick::writeImageFile — Writes an image to a filehandle
  • Imagick::writeImages — Writes an image or image sequence
  • Imagick::writeImagesFile — Writes frames to a filehandle


Adds adaptive blur filter to image

  • ? Imagick
  • Imagick::adaptiveResizeImage ?
  • PHP Manual
  • Imagick
  • Adds adaptive blur filter to image

Imagick::adaptiveBlurImage

(PECL imagick 2, PECL imagick 3)

Imagick::adaptiveBlurImage — Adds adaptive blur filter to image

说明

public Imagick::adaptiveBlurImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Adds an adaptive blur filter to image. The intensity of an adaptive blur depends is dramatically decreased at edge of the image, whereas a standard blur is uniform across the image. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

radius

The radius of the Gaussian, in pixels, not counting the center pixel. Provide a value of 0 and the radius will be chosen automagically.

sigma

The standard deviation of the Gaussian, in pixels.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::adaptiveBlurImage():

Adaptively blur an image, then display to the browser.

<?php

header('Content-type: image/jpeg');

$image = new Imagick('test.jpg');

$image->adaptiveBlurImage(5,3);
echo $image;

?>

以上例程的输出类似于：

Output of example : Using Imagick::adaptiveBlurImage()

参见

  • Imagick::blurImage() - Adds blur filter to image
  • Imagick::motionBlurImage() - Simulates motion blur
  • Imagick::radialBlurImage() - Radial blurs an image


Adaptively resize image with data dependent triangulation

  • ? Imagick::adaptiveBlurImage
  • Imagick::adaptiveSharpenImage ?
  • PHP Manual
  • Imagick
  • Adaptively resize image with data dependent triangulation

Imagick::adaptiveResizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::adaptiveResizeImage — Adaptively resize image with data dependent triangulation

说明

public Imagick::adaptiveResizeImage ( int $columns , int $rows , bool $bestfit = false , bool $legacy = false ) : bool

Adaptively resize image with data-dependent triangulation. Avoids blurring across sharp color changes. Most useful when used to shrink images slightly to a slightly smaller "web size"; may not look good when a full-sized image is adaptively resized to a thumbnail. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

Note: 参数 bestfit 的特性在 Imagick 3.0.0 中已改变。在此版本以前，当目标尺寸设为 400x400 时，原尺寸为 200x150 的图像将不会被改变。自 Imagick 3.0.0 起，源图像将会被放大到 400x300 因为这将更好的适合目标尺寸。当使用参数 bestfit 时，必须同时给出宽度和高度。

参数

columns

The number of columns in the scaled image.

rows

The number of rows in the scaled image.

bestfit

Whether to fit the image inside a bounding box.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Added optional fit parameter.
PECL imagick 2.1.0 | This method now supports proportional scaling. Pass zero as either parameter for proportional scaling.

范例

Example #1 Using Imagick::adaptiveResizeImage()

Resize an image to a standard size for the web. This method works best when resizing to a size only slightly smaller than the previous image size.

<?php
header('Content-type: image/jpeg');

$image = new Imagick('image.jpg');
$image->adaptiveResizeImage(1024,768);

echo $image;
?>

参见

  • Imagick::chopImage() - Removes a region of an image and trims
  • Imagick::cropImage() - 截图图片的一块区域
  • Imagick::magnifyImage() - Scales an image proportionally 2x
  • Imagick::minifyImage() - Scales an image proportionally to half its size
  • Imagick::resizeImage() - Scales an image
  • Imagick::scaleImage() - Scales the size of an image
  • Imagick::shaveImage() - Shaves pixels from the image edges
  • Imagick::thumbnailImage() - Changes the size of an image
  • Imagick::trimImage() - Remove edges from the image


Adaptively sharpen the image

  • ? Imagick::adaptiveResizeImage
  • Imagick::adaptiveThresholdImage ?
  • PHP Manual
  • Imagick
  • Adaptively sharpen the image

Imagick::adaptiveSharpenImage

(PECL imagick 2, PECL imagick 3)

Imagick::adaptiveSharpenImage — Adaptively sharpen the image

说明

public Imagick::adaptiveSharpenImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Adaptively sharpen the image by sharpening more intensely near image edges and less intensely far from edges. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

radius

The radius of the Gaussian, in pixels, not counting the center pixel. Use 0 for auto-select.

sigma

The standard deviation of the Gaussian, in pixels.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

范例

Example #1 A Imagick::adaptiveSharpenImage() example

Adaptively sharpen the image with radius 2 and sigma 1.

<?php
try {
    $image = new Imagick('image.png');
    $image->adaptiveSharpenImage(2,1);
} catch(ImagickException $e) {
    echo 'Error: ' , $e->getMessage();
    die();
}
header('Content-type: image/png');
echo $image;
?>

参见

  • Imagick::sharpenImage() - Sharpens an image


Selects a threshold for each pixel based on a range of intensity

  • ? Imagick::adaptiveSharpenImage
  • Imagick::addImage ?
  • PHP Manual
  • Imagick
  • Selects a threshold for each pixel based on a range of intensity

Imagick::adaptiveThresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::adaptiveThresholdImage — Selects a threshold for each pixel based on a range of intensity

说明

public Imagick::adaptiveThresholdImage ( int $width , int $height , int $offset ) : bool

Selects an individual threshold for each pixel based on the range of intensity values in its local neighborhood. This allows for thresholding of an image whose global intensity histogram doesn't contain distinctive peaks.

参数

width

Width of the local neighborhood.

height

Height of the local neighborhood.

offset

The mean offset

返回值

成功时返回 true。

范例

Example #1 Imagick::adaptiveThresholdImage()

<?php
function adaptiveThresholdImage($imagePath, $width, $height, $adaptiveOffset) {
    $imagick = new \Imagick(realpath($imagePath));
    $adaptiveOffsetQuantum = intval($adaptiveOffset * \Imagick::getQuantum());
    $imagick->adaptiveThresholdImage($width, $height, $adaptiveOffsetQuantum);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Adds new image to Imagick object image list

  • ? Imagick::adaptiveThresholdImage
  • Imagick::addNoiseImage ?
  • PHP Manual
  • Imagick
  • Adds new image to Imagick object image list

Imagick::addImage

(PECL imagick 2, PECL imagick 3)

Imagick::addImage — Adds new image to Imagick object image list

说明

public Imagick::addImage ( Imagick $source ) : bool

Adds new image to Imagick object from the current position of the source object. After the operation iterator position is moved at the end of the list.

参数

source

The source Imagick object

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Adds random noise to the image

  • ? Imagick::addImage
  • Imagick::affineTransformImage ?
  • PHP Manual
  • Imagick
  • Adds random noise to the image

Imagick::addNoiseImage

(PECL imagick 2, PECL imagick 3)

Imagick::addNoiseImage — Adds random noise to the image

说明

public Imagick::addNoiseImage ( int $noise_type , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Adds random noise to the image.

参数

noise_type

The type of the noise. Refer to this list of noise constants.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

范例

Example #1 Imagick::addNoiseImage()

<?php
function addNoiseImage($noiseType, $imagePath, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->addNoiseImage($noiseType, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Transforms an image

  • ? Imagick::addNoiseImage
  • Imagick::animateImages ?
  • PHP Manual
  • Imagick
  • Transforms an image

Imagick::affineTransformImage

(PECL imagick 2, PECL imagick 3)

Imagick::affineTransformImage — Transforms an image

说明

public Imagick::affineTransformImage ( ImagickDraw $matrix ) : bool

Transforms an image as dictated by the affine matrix.

参数

matrix

The affine matrix

返回值

成功时返回 true。

范例

Example #1 Imagick::affineTransformImage()

<?php
function affineTransformImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $draw = new \ImagickDraw();

    $angle = deg2rad(40);

    $affineRotate = array(
        "sx" => cos($angle), "sy" => cos($angle),
        "rx" => sin($angle), "ry" => -sin($angle),
        "tx" => 0, "ty" => 0,
    );

    $draw->affine($affineRotate);

    $imagick->affineTransformImage($draw);

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Animates an image or images

  • ? Imagick::affineTransformImage
  • Imagick::annotateImage ?
  • PHP Manual
  • Imagick
  • Animates an image or images

Imagick::animateImages

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::animateImages — Animates an image or images

说明

public Imagick::animateImages ( string $x_server ) : bool

This method animates the image onto a local or remote X server. This method is not available on Windows. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

x_server

X server address

返回值

成功时返回 true。

参见

  • Imagick::displayImage() - Displays an image


Annotates an image with text

  • ? Imagick::animateImages
  • Imagick::appendImages ?
  • PHP Manual
  • Imagick
  • Annotates an image with text

Imagick::annotateImage

(PECL imagick 2, PECL imagick 3)

Imagick::annotateImage — Annotates an image with text

说明

public Imagick::annotateImage ( ImagickDraw $draw_settings , float $x , float $y , float $angle , string $text ) : bool

Annotates an image with text.

参数

draw_settings

The ImagickDraw object that contains settings for drawing the text

x

Horizontal offset in pixels to the left of text

y

Vertical offset in pixels to the baseline of text

angle

The angle at which to write the text

text

The string to draw

返回值

成功时返回 true。

范例

Example #1 Using Imagick::annotateImage():

Annotate text on an empty image

<?php
/* Create some objects */
$image = new Imagick();
$draw = new ImagickDraw();
$pixel = new ImagickPixel( 'gray' );

/* New image */
$image->newImage(800, 75, $pixel);

/* Black text */
$draw->setFillColor('black');

/* Font properties */
$draw->setFont('Bookman-DemiItalic');
$draw->setFontSize( 30 );

/* Create text */
$image->annotateImage($draw, 10, 45, 0, 'The quick brown fox jumps over the lazy dog');

/* Give image a format */
$image->setImageFormat('png');

/* Output the image with headers */
header('Content-type: image/png');
echo $image;

?>

参见

  • ImagickDraw::annotation() - Draws text on the image
  • ImagickDraw::setFont() - Sets the fully-specified font to use when annotating with text


Append a set of images

  • ? Imagick::annotateImage
  • Imagick::autoLevelImage ?
  • PHP Manual
  • Imagick
  • Append a set of images

Imagick::appendImages

(PECL imagick 2, PECL imagick 3)

Imagick::appendImages — Append a set of images

说明

public Imagick::appendImages ( bool $stack ) : Imagick

Append a set of images into one larger image.

参数

stack

Whether to stack the images vertically. By default (or if false is specified) images are stacked left-to-right. If stack is true, images are stacked top-to-bottom.

返回值

Returns Imagick instance on success.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::appendImages() example

<?php

/* Create new imagick object */
$im = new Imagick();

/* create red, green and blue images */
$im->newImage(100, 50, "red");
$im->newImage(100, 50, "green");
$im->newImage(100, 50, "blue");

/* Append the images into one */
$im->resetIterator();
$combined = $im->appendImages(true);

/* Output the image */
$combined->setImageFormat("png");
header("Content-Type: image/png");
echo $combined;
?>

以上例程的输出类似于：

Output of example : Imagick::appendImages()


Description

  • ? Imagick::appendImages
  • Imagick::averageImages ?
  • PHP Manual
  • Imagick
  • Description

Imagick::autoLevelImage

(PECL imagick 3 >= 3.3.0)

Imagick::autoLevelImage — Description

说明

public Imagick::autoLevelImage ( int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Adjusts the levels of a particular image channel by scaling the minimum and maximum values to the full quantum range.

参数

channel

Which channel should the auto-levelling should be done on.

返回值

成功时返回 true。

范例

Example #1 Imagick::autoLevelImage()

<?php
function autoLevelImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->autoLevelImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Average a set of images

  • ? Imagick::autoLevelImage
  • Imagick::blackThresholdImage ?
  • PHP Manual
  • Imagick
  • Average a set of images

Imagick::averageImages

(PECL imagick 2, PECL imagick 3)

Imagick::averageImages — Average a set of images

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::averageImages ( ) : Imagick

Average a set of images.

返回值

Returns a new Imagick object on success.

错误／异常

错误时抛出 ImagickException。


Forces all pixels below the threshold into black

  • ? Imagick::averageImages
  • Imagick::blueShiftImage ?
  • PHP Manual
  • Imagick
  • Forces all pixels below the threshold into black

Imagick::blackThresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::blackThresholdImage — Forces all pixels below the threshold into black

说明

public Imagick::blackThresholdImage ( mixed $threshold ) : bool

Is like Imagick::thresholdImage() but forces all pixels below the threshold into black while leaving all pixels above the threshold unchanged.

参数

threshold

The threshold below which everything turns black

返回值

成功时返回 true。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as a parameter. Previous versions allow only an ImagickPixel object.

范例

Example #1 Imagick::blackThresholdImage()

<?php
function blackThresholdImage($imagePath, $thresholdColor) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->blackthresholdimage($thresholdColor);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • ? Imagick::blackThresholdImage
  • Imagick::blurImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::blueShiftImage

(PECL imagick 3 >= 3.3.0)

Imagick::blueShiftImage — Description

说明

public Imagick::blueShiftImage ( float $factor = 1.5 ) : bool

Mutes the colors of the image to simulate a scene at nighttime in the moonlight.

参数

factor

返回值

成功时返回 true。

范例

Example #1 Imagick::blueShiftImage()

<?php
function blueShiftImage($imagePath, $blueShift) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->blueShiftImage($blueShift);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Adds blur filter to image

  • ? Imagick::blueShiftImage
  • Imagick::borderImage ?
  • PHP Manual
  • Imagick
  • Adds blur filter to image

Imagick::blurImage

(PECL imagick 2, PECL imagick 3)

Imagick::blurImage — Adds blur filter to image

说明

public Imagick::blurImage ( float $radius , float $sigma , int $channel = ? ) : bool

Adds blur filter to image. Optional third parameter to blur a specific channel.

参数

radius

Blur radius

sigma

Standard deviation

channel

The Channeltype constant. When not supplied, all channels are blurred.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::blurImage():

Blur an image, then display to the browser.

<?php

header('Content-type: image/jpeg');

$image = new Imagick('test.jpg');

$image->blurImage(5,3);
echo $image;

?>

参见

  • Imagick::adaptiveBlurImage() - Adds adaptive blur filter to image
  • Imagick::motionBlurImage() - Simulates motion blur
  • Imagick::radialBlurImage() - Radial blurs an image


Surrounds the image with a border

  • ? Imagick::blurImage
  • Imagick::brightnessContrastImage ?
  • PHP Manual
  • Imagick
  • Surrounds the image with a border

Imagick::borderImage

(PECL imagick 2, PECL imagick 3)

Imagick::borderImage — Surrounds the image with a border

说明

public Imagick::borderImage ( mixed $bordercolor , int $width , int $height ) : bool

Surrounds the image with a border of the color defined by the bordercolor ImagickPixel object.

参数

bordercolor

ImagickPixel object or a string containing the border color

width

Border width

height

Border height

返回值

成功时返回 true。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the first parameter. Previous versions allow only an ImagickPixel object.

范例

Example #1 Imagick::borderImage()

<?php
function borderImage($imagePath, $color, $width, $height) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->borderImage($color, $width, $height);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • ? Imagick::borderImage
  • Imagick::charcoalImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::brightnessContrastImage

(PECL imagick 3 >= 3.3.0)

Imagick::brightnessContrastImage — Description

说明

public Imagick::brightnessContrastImage ( float $brightness , float $contrast , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Change the brightness and/or contrast of an image. It converts the brightness and contrast parameters into slope and intercept and calls a polynomical function to apply to the image.

参数

brightness

contrast

channel

返回值

成功时返回 true。

范例

Example #1 Imagick::brightnessContrastImage()

<?php
function brightnessContrastImage($imagePath, $brightness, $contrast, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->brightnessContrastImage($brightness, $contrast, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Simulates a charcoal drawing

  • ? Imagick::brightnessContrastImage
  • Imagick::chopImage ?
  • PHP Manual
  • Imagick
  • Simulates a charcoal drawing

Imagick::charcoalImage

(PECL imagick 2, PECL imagick 3)

Imagick::charcoalImage — Simulates a charcoal drawing

说明

public Imagick::charcoalImage ( float $radius , float $sigma ) : bool

Simulates a charcoal drawing.

参数

radius

The radius of the Gaussian, in pixels, not counting the center pixel

sigma

The standard deviation of the Gaussian, in pixels

返回值

成功时返回 true。

范例

Example #1 Imagick::charcoalImage()

<?php
function charcoalImage($imagePath, $radius, $sigma) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->charcoalImage($radius, $sigma);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Removes a region of an image and trims

  • ? Imagick::charcoalImage
  • Imagick::clampImage ?
  • PHP Manual
  • Imagick
  • Removes a region of an image and trims

Imagick::chopImage

(PECL imagick 2, PECL imagick 3)

Imagick::chopImage — Removes a region of an image and trims

说明

public Imagick::chopImage ( int $width , int $height , int $x , int $y ) : bool

Removes a region of an image and collapses the image to occupy the removed portion.

参数

width

Width of the chopped area

height

Height of the chopped area

x

X origo of the chopped area

y

Y origo of the chopped area

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::chopImage():

Example of using Imagick::chopImage

<?php
/* Create some objects */
$image = new Imagick();
$pixel = new ImagickPixel( 'gray' );

/* New image */
$image->newImage(400, 200, $pixel);

/* Chop image */
$image->chopImage(200, 200, 0, 0);

/* Give image a format */
$image->setImageFormat('png');

/* Output the image with headers */
header('Content-type: image/png');
echo $image;

?>

参见

  • Imagick::cropImage() - 截图图片的一块区域


Description

  • ? Imagick::chopImage
  • Imagick::clear ?
  • PHP Manual
  • Imagick
  • Description

Imagick::clampImage

(PECL imagick 3 >= 3.3.0)

Imagick::clampImage — Description

说明

public Imagick::clampImage ( int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Restricts the color range from 0 to the quantum depth.

参数

channel

返回值

成功时返回 true， 或者在失败时返回 false。


Clears all resources associated to Imagick object

  • ? Imagick::clampImage
  • Imagick::clipImage ?
  • PHP Manual
  • Imagick
  • Clears all resources associated to Imagick object

Imagick::clear

(PECL imagick 2, PECL imagick 3)

Imagick::clear — Clears all resources associated to Imagick object

说明

public Imagick::clear ( ) : bool

Clears all resources associated to Imagick object

返回值

成功时返回 true。


Clips along the first path from the 8BIM profile

  • ? Imagick::clear
  • Imagick::clipImagePath ?
  • PHP Manual
  • Imagick
  • Clips along the first path from the 8BIM profile

Imagick::clipImage

(PECL imagick 2, PECL imagick 3)

Imagick::clipImage — Clips along the first path from the 8BIM profile

说明

public Imagick::clipImage ( ) : bool

Clips along the first path from the 8BIM profile, if present.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Description

  • ? Imagick::clipImage
  • Imagick::clipPathImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::clipImagePath

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::clipImagePath — Description

说明

public Imagick::clipImagePath ( string $pathname , string $inside ) : void

Clips along the named paths from the 8BIM profile, if present. Later operations take effect inside the path. Id may be a number if preceded with #, to work on a numbered path, e.g., "#1" to use the first path.

Warning

本函数还未编写文档，仅有参数列表。

参数

pathname

inside

返回值


Clips along the named paths from the 8BIM profile

  • ? Imagick::clipImagePath
  • Imagick::clone ?
  • PHP Manual
  • Imagick
  • Clips along the named paths from the 8BIM profile

Imagick::clipPathImage

(PECL imagick 2, PECL imagick 3)

Imagick::clipPathImage — Clips along the named paths from the 8BIM profile

说明

public Imagick::clipPathImage ( string $pathname , bool $inside ) : bool

Clips along the named paths from the 8BIM profile, if present. Later operations take effect inside the path. It may be a number if preceded with #, to work on a numbered path, e.g., "#1" to use the first path.

参数

pathname

The name of the path

inside

If true later operations take effect inside clipping path. Otherwise later operations take effect outside clipping path.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Makes an exact copy of the Imagick object

  • ? Imagick::clipPathImage
  • Imagick::clutImage ?
  • PHP Manual
  • Imagick
  • Makes an exact copy of the Imagick object

Imagick::clone

(PECL imagick 2, PECL imagick 3)

Imagick::clone — Makes an exact copy of the Imagick object

说明

public Imagick::clone ( ) : Imagick

Makes an exact copy of the Imagick object.

Warning

This function has been DEPRECATED as of imagick 3.1.0 in favour of using the clone keyword.

范例

Example #1 Imagick object cloning in different versions of imagick

<?php
// Cloning an Imagick object in imagick 2.x and 3.0:
$newImage = $image->clone();

// Cloning an Imagick object from 3.1.0 on:
$newImage = clone $image;
?>

返回值

A copy of the Imagick object is returned.

更新日志

版本 | 说明
PECL imagick 3.1.0 | The method was deprecated in favour of the clone keyword.


Replaces colors in the image

  • ? Imagick::clone
  • Imagick::coalesceImages ?
  • PHP Manual
  • Imagick
  • Replaces colors in the image

Imagick::clutImage

(PECL imagick 2, PECL imagick 3)

Imagick::clutImage — Replaces colors in the image

说明

public Imagick::clutImage ( Imagick $lookup_table , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Replaces colors in the image from a color lookup table. Optional second parameter to replace colors in a specific channel. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

lookup_table

Imagick object containing the color lookup table

channel

The Channeltype constant. When not supplied, default channels are replaced.

返回值

成功时返回 true。

范例

Example #1 Using Imagick::clutImage():

Replace colors in the image from a color lookup table.

<?php
$image = new Imagick('test.jpg');
$clut = new Imagick();
$clut->newImage(1, 1, new ImagickPixel('black'));
$image->clutImage($clut);
$image->writeImage('test_out.jpg');
?>

参见

  • Imagick::adaptiveBlurImage() - Adds adaptive blur filter to image
  • Imagick::motionBlurImage() - Simulates motion blur
  • Imagick::radialBlurImage() - Radial blurs an image


Composites a set of images

  • ? Imagick::clutImage
  • Imagick::colorFloodfillImage ?
  • PHP Manual
  • Imagick
  • Composites a set of images

Imagick::coalesceImages

(PECL imagick 2, PECL imagick 3)

Imagick::coalesceImages — Composites a set of images

说明

public Imagick::coalesceImages ( ) : Imagick

Composites a set of images while respecting any page offsets and disposal methods. GIF, MIFF, and MNG animation sequences typically start with an image background and each subsequent image varies in size and offset. Returns a new Imagick object where each image in the sequence is the same size as the first and composited with the next image in the sequence.

返回值

Returns a new Imagick object on success.

错误／异常

错误时抛出 ImagickException。


Changes the color value of any pixel that matches target

  • ? Imagick::coalesceImages
  • Imagick::colorizeImage ?
  • PHP Manual
  • Imagick
  • Changes the color value of any pixel that matches target

Imagick::colorFloodfillImage

(PECL imagick 2, PECL imagick 3)

Imagick::colorFloodfillImage — Changes the color value of any pixel that matches target

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::colorFloodfillImage ( mixed $fill , float $fuzz , mixed $bordercolor , int $x , int $y ) : bool

Changes the color value of any pixel that matches target and is an immediate neighbor.

参数

fill

ImagickPixel object containing the fill color

fuzz

The amount of fuzz. For example, set fuzz to 10 and the color red at intensities of 100 and 102 respectively are now interpreted as the same color for the purposes of the floodfill.

bordercolor

ImagickPixel object containing the border color

x

X start position of the floodfill

y

Y start position of the floodfill

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as first and third parameter. Previous versions allow only an ImagickPixel object.


Blends the fill color with the image

  • ? Imagick::colorFloodfillImage
  • Imagick::colorMatrixImage ?
  • PHP Manual
  • Imagick
  • Blends the fill color with the image

Imagick::colorizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::colorizeImage — Blends the fill color with the image

说明

public Imagick::colorizeImage ( mixed $colorize , mixed $opacity , bool $legacy = false ) : bool

Blends the fill color with each pixel in the image.

参数

colorize

ImagickPixel object or a string containing the colorize color

opacity

ImagickPixel object or an float containing the opacity value. 1.0 is fully opaque and 0.0 is fully transparent.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the first parameter and a float representing the opacity value as the second parameter. Previous versions allow only an ImagickPixel objects.

范例

Example #1 Imagick::colorizeImage()

<?php
function colorizeImage($imagePath, $color, $opacity) {
    $imagick = new \Imagick(realpath($imagePath));
    $opacity = $opacity / 255.0;
    $opacityColor = new \ImagickPixel("rgba(0, 0, 0, $opacity)");
    $imagick->colorizeImage($color, $opacityColor);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • ? Imagick::colorizeImage
  • Imagick::combineImages ?
  • PHP Manual
  • Imagick
  • Description

Imagick::colorMatrixImage

(PECL imagick 3 >= 3.3.0)

Imagick::colorMatrixImage — Description

说明

public Imagick::colorMatrixImage ( array $color_matrix = Imagick::CHANNEL_DEFAULT ) : bool

Apply color transformation to an image. The method permits saturation changes, hue rotation, luminance to alpha, and various other effects. Although variable-sized transformation matrices can be used, typically one uses a 5x5 matrix for an RGBA image and a 6x6 for CMYKA (or RGBA with offsets). The matrix is similar to those used by Adobe Flash except offsets are in column 6 rather than 5 (in support of CMYKA images) and offsets are normalized (divide Flash offset by 255)

参数

color_matrix

返回值

成功时返回 true。

范例

Example #1 Imagick::colorMatrixImage()

<?php
function colorMatrixImage($imagePath, $colorMatrix) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageOpacity(1);

    //A color matrix should look like:
    //    $colorMatrix = [
    //        1.5, 0.0, 0.0, 0.0, 0.0, -0.157,
    //        0.0, 1.0, 0.5, 0.0, 0.0, -0.157,
    //        0.0, 0.0, 1.5, 0.0, 0.0, -0.157,
    //        0.0, 0.0, 0.0, 1.0, 0.0,  0.0,
    //        0.0, 0.0, 0.0, 0.0, 1.0,  0.0,
    //        0.0, 0.0, 0.0, 0.0, 0.0,  1.0
    //    ];

    $background = new \Imagick();
    $background->newPseudoImage($imagick->getImageWidth(), $imagick->getImageHeight(),  "pattern:checkerboard");

    $background->setImageFormat('png');

    $imagick->setImageFormat('png');
    $imagick->colorMatrixImage($colorMatrix);

    $background->compositeImage($imagick, \Imagick::COMPOSITE_ATOP, 0, 0);

    header("Content-Type: image/png");
    echo $background->getImageBlob();
}

?>


Combines one or more images into a single image

  • ? Imagick::colorMatrixImage
  • Imagick::commentImage ?
  • PHP Manual
  • Imagick
  • Combines one or more images into a single image

Imagick::combineImages

(PECL imagick 2, PECL imagick 3)

Imagick::combineImages — Combines one or more images into a single image

说明

public Imagick::combineImages ( int $channelType ) : Imagick

Combines one or more images into a single image. The grayscale value of the pixels of each image in the sequence is assigned in order to the specified channels of the combined image. The typical ordering would be image 1 => Red, 2 => Green, 3 => Blue, etc.

参数

channelType

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Adds a comment to your image

  • ? Imagick::combineImages
  • Imagick::compareImageChannels ?
  • PHP Manual
  • Imagick
  • Adds a comment to your image

Imagick::commentImage

(PECL imagick 2, PECL imagick 3)

Imagick::commentImage — Adds a comment to your image

说明

public Imagick::commentImage ( string $comment ) : bool

Adds a comment to your image.

参数

comment

The comment to add

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::commentImage():

Commenting an image and retrieving the comment:

<?php

/* Create new Imagick object */
$im = new imagick();

/* Create an empty image */
$im->newImage(100, 100, new ImagickPixel("red"));

/* Add comment to the image */
$im->commentImage("Hello World!");

/* Display the comment */
echo $im->getImageProperty("comment");

?>


Returns the difference in one or more images

  • ? Imagick::commentImage
  • Imagick::compareImageLayers ?
  • PHP Manual
  • Imagick
  • Returns the difference in one or more images

Imagick::compareImageChannels

(PECL imagick 2, PECL imagick 3)

Imagick::compareImageChannels — Returns the difference in one or more images

说明

public Imagick::compareImageChannels ( Imagick $image , int $channelType , int $metricType ) : array

Compares one or more images and returns the difference image.

参数

image

Imagick object containing the image to compare.

channelType

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

metricType

One of the metric type constants.

返回值

Array consisting of new_wand and distortion.

错误／异常

错误时抛出 ImagickException。


Returns the maximum bounding region between images

  • ? Imagick::compareImageChannels
  • Imagick::compareImages ?
  • PHP Manual
  • Imagick
  • Returns the maximum bounding region between images

Imagick::compareImageLayers

(PECL imagick 2, PECL imagick 3)

Imagick::compareImageLayers — Returns the maximum bounding region between images

说明

public Imagick::compareImageLayers ( int $method ) : Imagick

Compares each image with the next in a sequence and returns the maximum bounding region of any pixel differences it discovers. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

method

One of the layer method constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::compareImageLayers()

Comparing image layers

<?php
/* create new imagick object */
$im = new Imagick("test.gif");

/* optimize the image layers */
$result = $im->compareImageLayers(imagick::LAYERMETHOD_COALESCE);

/* work on the $result */
?>

参见

  • Imagick::optimizeImageLayers() - Removes repeated portions of images to optimize
  • Imagick::writeImages() - Writes an image or image sequence
  • Imagick::writeImage() - 把图片写入指定的文件


Compares an image to a reconstructed image

  • ? Imagick::compareImageLayers
  • Imagick::compositeImage ?
  • PHP Manual
  • Imagick
  • Compares an image to a reconstructed image

Imagick::compareImages

(PECL imagick 2, PECL imagick 3)

Imagick::compareImages — Compares an image to a reconstructed image

说明

public Imagick::compareImages ( Imagick $compare , int $metric ) : array

Returns an array containing a reconstructed image and the difference between images.

参数

compare

An image to compare to.

metric

Provide a valid metric type constant. Refer to this list of metric constants.

返回值

Returns an array containing a reconstructed image and the difference between images.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::compareImages():

Compare images and display the reconstructed image

<?php

$image1 = new imagick("image1.png");
$image2 = new imagick("image2.png");

$result = $image1->compareImages($image2, Imagick::METRIC_MEANSQUAREERROR);
$result[0]->setImageFormat("png");

header("Content-Type: image/png");
echo $result[0];

?>


把一张图合并到一张图

  • ? Imagick::compareImages
  • Imagick::__construct ?
  • PHP Manual
  • Imagick
  • 把一张图合并到一张图

Imagick::compositeImage

(PECL imagick 2, PECL imagick 3)

Imagick::compositeImage — 把一张图合并到一张图

说明

Imagick::compositeImage ( Imagick $composite_object , int $composite , int $x , int $y , int $channel = Imagick::CHANNEL_ALL ) : bool

把一张图合并到另一张图的指定位置

参数

composite_object

用于合并的图片的Imagick对象

composite

合并操作，定义操作常量。 具体请查看 合并操作常量列表

x

相对图像顶点左上位置（0,0）的横坐标

y

相对图像顶点左上位置（0,0）的纵坐标

channel

通过传入一个通道常量，来开启通道模式。为了支持多个通道，可以通过二进制运算的操作来合并多个通道常量。（Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators）可以参考这个列表 通道常量列表.

返回值

成功时返回 true。


The Imagick constructor

  • ? Imagick::compositeImage
  • Imagick::contrastImage ?
  • PHP Manual
  • Imagick
  • The Imagick constructor

Imagick::__construct

(PECL imagick 2, PECL imagick 3)

Imagick::__construct — The Imagick constructor

说明

public Imagick::__construct ( mixed $files = ? )

Creates an Imagick instance for a specified image or set of images.

参数

files

The path to an image to load or an array of paths. Paths can include wildcards for file names, or can be URLs.

返回值

Returns a new Imagick object on success.

错误／异常

错误时抛出 ImagickException。


Change the contrast of the image

  • ? Imagick::__construct
  • Imagick::contrastStretchImage ?
  • PHP Manual
  • Imagick
  • Change the contrast of the image

Imagick::contrastImage

(PECL imagick 2, PECL imagick 3)

Imagick::contrastImage — Change the contrast of the image

说明

public Imagick::contrastImage ( bool $sharpen ) : bool

Enhances the intensity differences between the lighter and darker elements of the image. Set sharpen to a value other than 0 to increase the image contrast otherwise the contrast is reduced.

参数

sharpen

The sharpen value

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::contrastImage()

<?php
function contrastImage($imagePath, $contrastType) {
    $imagick = new \Imagick(realpath($imagePath));
    if ($contrastType != 2) {
        $imagick->contrastImage($contrastType);
    }

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Enhances the contrast of a color image

  • ? Imagick::contrastImage
  • Imagick::convolveImage ?
  • PHP Manual
  • Imagick
  • Enhances the contrast of a color image

Imagick::contrastStretchImage

(PECL imagick 2, PECL imagick 3)

Imagick::contrastStretchImage — Enhances the contrast of a color image

说明

public Imagick::contrastStretchImage ( float $black_point , float $white_point , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Enhances the contrast of a color image by adjusting the pixels color to span the entire range of colors available. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

black_point

The black point.

white_point

The white point.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Imagick::CHANNEL_ALL. Refer to this list of channel constants.

返回值

成功时返回 true。


Applies a custom convolution kernel to the image

  • ? Imagick::contrastStretchImage
  • Imagick::count ?
  • PHP Manual
  • Imagick
  • Applies a custom convolution kernel to the image

Imagick::convolveImage

(PECL imagick 2, PECL imagick 3)

Imagick::convolveImage — Applies a custom convolution kernel to the image

说明

public Imagick::convolveImage ( array $kernel , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Applies a custom convolution kernel to the image.

参数

kernel

The convolution kernel

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::convolveImage()

<?php
function convolveImage($imagePath, $bias, $kernelMatrix) {
    $imagick = new \Imagick(realpath($imagePath));
    //$edgeFindingKernel = [-1, -1, -1, -1, 8, -1, -1, -1, -1,];
    $imagick->setImageBias($bias * \Imagick::getQuantum());
    $imagick->convolveImage($kernelMatrix);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Get the number of images

  • ? Imagick::convolveImage
  • Imagick::cropImage ?
  • PHP Manual
  • Imagick
  • Get the number of images

Imagick::count

(PECL imagick 3 >= 3.3.0)

Imagick::count — Get the number of images

说明

public Imagick::count ( int $mode = 0 ) : int

Returns the number of images.

参数

mode

An unused argument. Currently there is a non-particularly well defined feature in PHP where calling count() on a countable object might (or might not) require this method to accept a parameter. This parameter is here to be conformant with the interface of countable, even though the param is not used.

返回值

Returns the number of images.


截图图片的一块区域

  • ? Imagick::count
  • Imagick::cropThumbnailImage ?
  • PHP Manual
  • Imagick
  • 截图图片的一块区域

Imagick::cropImage

(PECL imagick 2, PECL imagick 3)

Imagick::cropImage — 截图图片的一块区域

说明

Imagick::cropImage ( int $width , int $height , int $x , int $y ) : bool

截图图片的一块区域

参数

width

截图的宽度

height

截图的高度

x

裁剪区域左上角的 X 轴坐标（以原图的左上角为原点）

y

裁剪区域左上角的 X 轴坐标（以原图的左上角为原点）

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::cropImage()

<?php
function cropImage($imagePath, $startX, $startY, $width, $height) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->cropImage($width, $height, $startX, $startY);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


创建缩略图

  • ? Imagick::cropImage
  • Imagick::current ?
  • PHP Manual
  • Imagick
  • 创建缩略图

Imagick::cropThumbnailImage

(PECL imagick 2, PECL imagick 3)

Imagick::cropThumbnailImage — 创建缩略图

说明

Imagick::cropThumbnailImage ( int $width , int $height ) : bool

首先将图片放大或者缩小，然后从图片的中间裁剪到指定的的大小。

参数

width

缩略图的宽

height

缩略图的高

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Returns a reference to the current Imagick object

  • ? Imagick::cropThumbnailImage
  • Imagick::cycleColormapImage ?
  • PHP Manual
  • Imagick
  • Returns a reference to the current Imagick object

Imagick::current

(PECL imagick 2, PECL imagick 3)

Imagick::current — Returns a reference to the current Imagick object

说明

public Imagick::current ( ) : Imagick

Returns reference to the current imagick object with image pointer at the correct sequence.

返回值

Returns self on success.

错误／异常

错误时抛出 ImagickException。


Displaces an image's colormap

  • ? Imagick::current
  • Imagick::decipherImage ?
  • PHP Manual
  • Imagick
  • Displaces an image's colormap

Imagick::cycleColormapImage

(PECL imagick 2, PECL imagick 3)

Imagick::cycleColormapImage — Displaces an image's colormap

说明

public Imagick::cycleColormapImage ( int $displace ) : bool

Displaces an image's colormap by a given number of positions. If you cycle the colormap a number of times you can produce a psychedelic effect.

参数

displace

The amount to displace the colormap.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Deciphers an image

  • ? Imagick::cycleColormapImage
  • Imagick::deconstructImages ?
  • PHP Manual
  • Imagick
  • Deciphers an image

Imagick::decipherImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::decipherImage — Deciphers an image

说明

public Imagick::decipherImage ( string $passphrase ) : bool

Deciphers image that has been enciphered before. The image must be enciphered using Imagick::encipherImage(). 此方法在Imagick基于ImageMagick 6.3.9以上版本编译时可用。

参数

passphrase

The passphrase

返回值

成功时返回 true。

参见

  • Imagick::encipherImage() - Enciphers an image


Returns certain pixel differences between images

  • ? Imagick::decipherImage
  • Imagick::deleteImageArtifact ?
  • PHP Manual
  • Imagick
  • Returns certain pixel differences between images

Imagick::deconstructImages

(PECL imagick 2, PECL imagick 3)

Imagick::deconstructImages — Returns certain pixel differences between images

说明

public Imagick::deconstructImages ( ) : Imagick

Compares each image with the next in a sequence and returns the maximum bounding region of any pixel differences it discovers.

返回值

Returns a new Imagick object on success.

错误／异常

错误时抛出 ImagickException。


Delete image artifact

  • ? Imagick::deconstructImages
  • Imagick::deleteImageProperty ?
  • PHP Manual
  • Imagick
  • Delete image artifact

Imagick::deleteImageArtifact

(PECL imagick 3)

Imagick::deleteImageArtifact — Delete image artifact

说明

public Imagick::deleteImageArtifact ( string $artifact ) : bool

Deletes an artifact associated with the image. The difference between image properties and image artifacts is that properties are public and artifacts are private. 此方法在Imagick基于ImageMagick 6.5.7以上版本编译时可用。

参数

artifact

The name of the artifact to delete

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

参见

  • Imagick::setImageArtifact() - Set image artifact
  • Imagick::getImageArtifact() - Get image artifact


Description

  • ? Imagick::deleteImageArtifact
  • Imagick::deskewImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::deleteImageProperty

(PECL imagick 3 >= 3.3.0)

Imagick::deleteImageProperty — Description

说明

public Imagick::deleteImageProperty ( string $name ) : bool

Deletes an image property.

参数

name

The name of the property to delete.

返回值

成功时返回 true。


Removes skew from the image

  • ? Imagick::deleteImageProperty
  • Imagick::despeckleImage ?
  • PHP Manual
  • Imagick
  • Removes skew from the image

Imagick::deskewImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3 >= 3.3.0)

Imagick::deskewImage — Removes skew from the image

说明

public Imagick::deskewImage ( float $threshold ) : bool

This method can be used to remove skew from for example scanned images where the paper was not properly placed on the scanning surface. 此方法在Imagick基于ImageMagick 6.4.5以上版本编译时可用。

参数

threshold

Deskew threshold

返回值

范例

Example #1 Imagick::deskewImage()

<?php
function deskewImage($threshold) {
    $imagick = new \Imagick(realpath("images/NYTimes-Page1-11-11-1918.jpg"));
    $deskewImagick = clone $imagick;

    //This is the only thing required for deskewing.
    $deskewImagick->deskewImage($threshold);

    //The rest of this example is to make the result obvious - because
    //otherwise the result is not obvious.
    $trim = 9;

    $deskewImagick->cropImage($deskewImagick->getImageWidth() - $trim, $deskewImagick->getImageHeight(), $trim, 0);
    $imagick->cropImage($imagick->getImageWidth() - $trim, $imagick->getImageHeight(), $trim, 0);
    $deskewImagick->resizeimage($deskewImagick->getImageWidth() / 2, $deskewImagick->getImageHeight() / 2, \Imagick::FILTER_LANCZOS, 1);
    $imagick->resizeimage($imagick->getImageWidth() / 2, $imagick->getImageHeight() / 2, \Imagick::FILTER_LANCZOS, 1);
    $newCanvas = new \Imagick();
    $newCanvas->newimage($imagick->getImageWidth() + $deskewImagick->getImageWidth() + 20, $imagick->getImageHeight(), 'red', 'jpg');
    $newCanvas->compositeimage($imagick, \Imagick::COMPOSITE_COPY, 5, 0);
    $newCanvas->compositeimage($deskewImagick, \Imagick::COMPOSITE_COPY, $imagick->getImageWidth() + 10, 0);

    header("Content-Type: image/jpg");
    echo $newCanvas->getImageBlob();
}

?>


Reduces the speckle noise in an image

  • ? Imagick::deskewImage
  • Imagick::destroy ?
  • PHP Manual
  • Imagick
  • Reduces the speckle noise in an image

Imagick::despeckleImage

(PECL imagick 2, PECL imagick 3)

Imagick::despeckleImage — Reduces the speckle noise in an image

说明

public Imagick::despeckleImage ( ) : bool

Reduces the speckle noise in an image while preserving the edges of the original image.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::despeckleImage()

<?php
function despeckleImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->despeckleImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Destroys the Imagick object

  • ? Imagick::despeckleImage
  • Imagick::displayImage ?
  • PHP Manual
  • Imagick
  • Destroys the Imagick object

Imagick::destroy

(PECL imagick 2, PECL imagick 3)

Imagick::destroy — Destroys the Imagick object

说明

public Imagick::destroy ( ) : bool

Destroys the Imagick object and frees all resources associated with it. This method is deprecated in favour of Imagick::clear.

返回值

成功时返回 true。


Displays an image

  • ? Imagick::destroy
  • Imagick::displayImages ?
  • PHP Manual
  • Imagick
  • Displays an image

Imagick::displayImage

(PECL imagick 2, PECL imagick 3)

Imagick::displayImage — Displays an image

说明

public Imagick::displayImage ( string $servername ) : bool

This method displays an image on a X server.

参数

servername

The X server name

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Displays an image or image sequence

  • ? Imagick::displayImage
  • Imagick::distortImage ?
  • PHP Manual
  • Imagick
  • Displays an image or image sequence

Imagick::displayImages

(PECL imagick 2, PECL imagick 3)

Imagick::displayImages — Displays an image or image sequence

说明

public Imagick::displayImages ( string $servername ) : bool

Displays an image or image sequence on a X server.

参数

servername

The X server name

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Distorts an image using various distortion methods

  • ? Imagick::displayImages
  • Imagick::drawImage ?
  • PHP Manual
  • Imagick
  • Distorts an image using various distortion methods

Imagick::distortImage

(PECL imagick 2 >= 2.0.1, PECL imagick 3)

Imagick::distortImage — Distorts an image using various distortion methods

说明

public Imagick::distortImage ( int $method , array $arguments , bool $bestfit ) : bool

Distorts an image using various distortion methods, by mapping color lookups of the source image to a new destination image usually of the same size as the source image, unless 'bestfit' is set to true.

If 'bestfit' is enabled, and distortion allows it, the destination image is adjusted to ensure the whole source 'image' will just fit within the final destination image, which will be sized and offset accordingly. Also in many cases the virtual offset of the source image will be taken into account in the mapping.

此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

method

The method of image distortion. See distortion constants

arguments

The arguments for this distortion method

bestfit

Attempt to resize destination to fit distorted source

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::distortImage():

Distort an image and display to the browser.

<?php
/* Create new object */
$im = new Imagick();

/* Create new checkerboard pattern */
$im->newPseudoImage(100, 100, "pattern:checkerboard");

/* Set the image format to png */
$im->setImageFormat('png');

/* Fill new visible areas with transparent */
$im->setImageVirtualPixelMethod(Imagick::VIRTUALPIXELMETHOD_TRANSPARENT);

/* Activate matte */
$im->setImageMatte(true);

/* Control points for the distortion */
$controlPoints = array( 10, 10,
                        10, 5,

                        10, $im->getImageHeight() - 20,
                        10, $im->getImageHeight() - 5,

                        $im->getImageWidth() - 10, 10,
                        $im->getImageWidth() - 10, 20,

                        $im->getImageWidth() - 10, $im->getImageHeight() - 10,
                        $im->getImageWidth() - 10, $im->getImageHeight() - 30);

/* Perform the distortion */
$im->distortImage(Imagick::DISTORTION_PERSPECTIVE, $controlPoints, true);

/* Ouput the image */
header("Content-Type: image/png");
echo $im;
?>

以上例程的输出类似于：

Output of example : Using Imagick::distortImage()

参见

  • Imagick::blurImage() - Adds blur filter to image
  • Imagick::motionBlurImage() - Simulates motion blur
  • Imagick::radialBlurImage() - Radial blurs an image


把 ImagickDraw 对象渲染到当前图片上

  • ? Imagick::distortImage
  • Imagick::edgeImage ?
  • PHP Manual
  • Imagick
  • 把 ImagickDraw 对象渲染到当前图片上

Imagick::drawImage

(PECL imagick 2, PECL imagick 3)

Imagick::drawImage — 把 ImagickDraw 对象渲染到当前图片上

说明

Imagick::drawImage ( ImagickDraw $draw ) : bool

把 ImagickDraw 对象渲染到当前图片上。

参数

draw

被渲染到图片上的 ImagickDraw 对象（在经过各种绘画操作之后的 ImagickDraw 对象）

返回值

成功时返回 true。


Enhance edges within the image

  • ? Imagick::drawImage
  • Imagick::embossImage ?
  • PHP Manual
  • Imagick
  • Enhance edges within the image

Imagick::edgeImage

(PECL imagick 2, PECL imagick 3)

Imagick::edgeImage — Enhance edges within the image

说明

public Imagick::edgeImage ( float $radius ) : bool

Enhance edges within the image with a convolution filter of the given radius. Use radius 0 and it will be auto-selected.

参数

radius

The radius of the operation.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::edgeImage()

<?php
function edgeImage($imagePath, $radius) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->edgeImage($radius);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Returns a grayscale image with a three-dimensional effect

  • ? Imagick::edgeImage
  • Imagick::encipherImage ?
  • PHP Manual
  • Imagick
  • Returns a grayscale image with a three-dimensional effect

Imagick::embossImage

(PECL imagick 2, PECL imagick 3)

Imagick::embossImage — Returns a grayscale image with a three-dimensional effect

说明

public Imagick::embossImage ( float $radius , float $sigma ) : bool

Returns a grayscale image with a three-dimensional effect. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and it will choose a suitable radius for you.

参数

radius

The radius of the effect

sigma

The sigma of the effect

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::embossImage()

<?php
function embossImage($imagePath, $radius, $sigma) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->embossImage($radius, $sigma);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Enciphers an image

  • ? Imagick::embossImage
  • Imagick::enhanceImage ?
  • PHP Manual
  • Imagick
  • Enciphers an image

Imagick::encipherImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::encipherImage — Enciphers an image

说明

public Imagick::encipherImage ( string $passphrase ) : bool

Converts plain pixels to enciphered pixels. The image is not readable until it has been deciphered using Imagick::decipherImage() 此方法在Imagick基于ImageMagick 6.3.9以上版本编译时可用。

参数

passphrase

The passphrase

返回值

成功时返回 true。

参见

  • Imagick::decipherImage() - Deciphers an image


Improves the quality of a noisy image

  • ? Imagick::encipherImage
  • Imagick::equalizeImage ?
  • PHP Manual
  • Imagick
  • Improves the quality of a noisy image

Imagick::enhanceImage

(PECL imagick 2, PECL imagick 3)

Imagick::enhanceImage — Improves the quality of a noisy image

说明

public Imagick::enhanceImage ( ) : bool

Applies a digital filter that improves the quality of a noisy image.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::enhanceImage()

<?php
function enhanceImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->enhanceImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Equalizes the image histogram

  • ? Imagick::enhanceImage
  • Imagick::evaluateImage ?
  • PHP Manual
  • Imagick
  • Equalizes the image histogram

Imagick::equalizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::equalizeImage — Equalizes the image histogram

说明

public Imagick::equalizeImage ( ) : bool

Equalizes the image histogram.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::equalizeImage()

<?php
function equalizeImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->equalizeImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Applies an expression to an image

  • ? Imagick::equalizeImage
  • Imagick::exportImagePixels ?
  • PHP Manual
  • Imagick
  • Applies an expression to an image

Imagick::evaluateImage

(PECL imagick 2, PECL imagick 3)

Imagick::evaluateImage — Applies an expression to an image

说明

public Imagick::evaluateImage ( int $op , float $constant , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Applys an arithmetic, relational, or logical expression to an image. Use these operators to lighten or darken an image, to increase or decrease contrast in an image, or to produce the "negative" of an image.

参数

op

The evaluation operator

constant

The value of the operator

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

范例

Example #1 Using Imagick::evaluateImage()

Using evaluateImage to reduce opacity in an image.

<?php
// Create new object with the image
$im = new Imagick('example-alpha.png');

// Reduce the alpha by 50%
$im->evaluateImage(Imagick::EVALUATE_DIVIDE, 2, Imagick::CHANNEL_ALPHA);

// Output the image
header("Content-Type: image/png");
echo $im;
?>

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Exports raw image pixels

  • ? Imagick::evaluateImage
  • Imagick::extentImage ?
  • PHP Manual
  • Imagick
  • Exports raw image pixels

Imagick::exportImagePixels

(PECL imagick 2 >=2.3.0, PECL imagick 3)

Imagick::exportImagePixels — Exports raw image pixels

说明

public Imagick::exportImagePixels ( int $x , int $y , int $width , int $height , string $map , int $STORAGE ) : array

Exports image pixels into an array. The map defines the ordering of the exported pixels. The size of the returned array is width * height * strlen(map). 此方法在Imagick基于ImageMagick 6.4.7以上版本编译时可用。

参数

x

X-coordinate of the exported area

y

Y-coordinate of the exported area

width

Width of the exported aread

height

Height of the exported area

map

Ordering of the exported pixels. For example "RGB". Valid characters for the map are R, G, B, A, O, C, Y, M, K, I and P.

STORAGE

Refer to this list of pixel type constants

范例

Example #1 Using Imagick::exportImagePixels()

Export image pixels into an array

<?php

/* Create new object */
$im = new Imagick();

/* Create new image */
$im->newPseudoImage(0, 0, "magick:rose");

/* Export the image pixels */
$pixels = $im->exportImagePixels(10, 10, 2, 2, "RGB", Imagick::PIXEL_CHAR);

/* Output */
var_dump($pixels);
?>

以上例程会输出：

array(12) {
  [0]=>
  int(72)
  [1]=>
  int(64)
  [2]=>
  int(57)
  [3]=>
  int(69)
  [4]=>
  int(59)
  [5]=>
  int(43)
  [6]=>
  int(124)
  [7]=>
  int(120)
  [8]=>
  int(-96)
  [9]=>
  int(91)
  [10]=>
  int(84)
  [11]=>
  int(111)
}

返回值

Returns an array containing the pixels values.

错误／异常

错误时抛出 ImagickException。


Set image size

  • ? Imagick::exportImagePixels
  • Imagick::filter ?
  • PHP Manual
  • Imagick
  • Set image size

Imagick::extentImage

(PECL imagick 2, PECL imagick 3)

Imagick::extentImage — Set image size

说明

public Imagick::extentImage ( int $width , int $height , int $x , int $y ) : bool

Comfortability method for setting image size. The method sets the image size and allows setting x,y coordinates where the new area begins. 此方法在Imagick基于ImageMagick 6.3.1以上版本编译时可用。

Caution

Prior to ImageMagick 6.5.7-8 (1623), $x was positive when shifting to the left and negative when shifting to the right, and $y was positive when shifting an image up and negative when shifting an image down. Somewhere betwen ImageMagick 6.3.7 (1591) and ImageMagick 6.5.7-8 (1623), the axes of $x and $y were flipped, so that $x was negative when shifting to the left and positive when shifting to the right, and $y was negative when shifting an image up and positive when shifting an image down. Somewhere between ImageMagick 6.5.7-8 (1623) and ImageMagick 6.6.9-7 (1641), the axes of $x and $y were flipped back to pre-ImageMagick 6.5.7-8 (1623) functionality.

参数

width

The new width

height

The new height

x

X position for the new size

y

Y position for the new size

返回值

成功时返回 true。

参见

  • Imagick::resizeImage() - Scales an image
  • Imagick::thumbnailImage() - Changes the size of an image
  • Imagick::cropImage() - 截图图片的一块区域


Description

  • ? Imagick::extentImage
  • Imagick::flattenImages ?
  • PHP Manual
  • Imagick
  • Description

Imagick::filter

(PECL imagick 3 >= 3.3.0)

Imagick::filter — Description

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::filter ( ImagickKernel $ImagickKernel , int $channel = Imagick::CHANNEL_UNDEFINED ) : bool

Applies a custom convolution kernel to the image.

参数

ImagickKernel

An instance of ImagickKernel that represents either a single kernel or a linked series of kernels.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

范例

Example #1 Imagick::filter()

<?php
function filter($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $matrix = [
        [-1, 0, -1],
        [0,  5,  0],
        [-1, 0, -1],
    ];

    $kernel = \ImagickKernel::fromMatrix($matrix);
    $strength = 0.5;
    $kernel->scale($strength, \Imagick::NORMALIZE_KERNEL_VALUE);
    $kernel->addUnityKernel(1 - $strength);

    $imagick->filter($kernel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Merges a sequence of images

  • ? Imagick::filter
  • Imagick::flipImage ?
  • PHP Manual
  • Imagick
  • Merges a sequence of images

Imagick::flattenImages

(PECL imagick 2, PECL imagick 3)

Imagick::flattenImages — Merges a sequence of images

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::flattenImages ( ) : Imagick

Merges a sequence of images. This is useful for combining Photoshop layers into a single image.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Creates a vertical mirror image

  • ? Imagick::flattenImages
  • Imagick::floodFillPaintImage ?
  • PHP Manual
  • Imagick
  • Creates a vertical mirror image

Imagick::flipImage

(PECL imagick 2, PECL imagick 3)

Imagick::flipImage — Creates a vertical mirror image

说明

public Imagick::flipImage ( ) : bool

Creates a vertical mirror image by reflecting the pixels around the central x-axis.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::flipImage()

<?php
function flipImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->flipImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Changes the color value of any pixel that matches target

  • ? Imagick::flipImage
  • Imagick::flopImage ?
  • PHP Manual
  • Imagick
  • Changes the color value of any pixel that matches target

Imagick::floodFillPaintImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::floodFillPaintImage — Changes the color value of any pixel that matches target

说明

public Imagick::floodFillPaintImage ( mixed $fill , float $fuzz , mixed $target , int $x , int $y , bool $invert , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Changes the color value of any pixel that matches target and is an immediate neighbor. This method is a replacement for deprecated Imagick::paintFloodFillImage(). 此方法在Imagick基于ImageMagick 6.3.8以上版本编译时可用。

参数

fill

ImagickPixel object or a string containing the fill color

fuzz

The amount of fuzz. For example, set fuzz to 10 and the color red at intensities of 100 and 102 respectively are now interpreted as the same color.

target

ImagickPixel object or a string containing the target color to paint

x

X start position of the floodfill

y

Y start position of the floodfill

invert

If true paints any pixel that does not match the target color.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

范例

Example #1 Imagick::floodfillPaintImage() example

<?php

/* Create new imagick object */
$im = new Imagick();

/* create red, green and blue images */
$im->newImage(100, 50, "red");
$im->newImage(100, 50, "green");
$im->newImage(100, 50, "blue");

/* Append the images into one */
$im->resetIterator();
$combined = $im->appendImages(true);

/* Save the intermediate image for comparison */
$combined->writeImage("floodfillpaint_intermediate.png");

/* The target pixel to paint */
$x = 1;
$y = 1;

/* Get the color we are painting */
$target = $combined->getImagePixelColor($x, $y);

/* Paints pixel in position 1,1 black and all neighboring
   pixels that match the target color */
$combined->floodfillPaintImage("black", 1, $target, $x, $y, false);

/* Save the result */
$combined->writeImage("floodfillpaint_result.png");
?>

以上例程的输出类似于：

Output of example : Imagick::floodfillPaintImage()
Output of example : Imagick::floodfillPaintImage()


Creates a vertical mirror image

  • ? Imagick::floodFillPaintImage
  • Imagick::forwardFourierTransformImage ?
  • PHP Manual
  • Imagick
  • Creates a vertical mirror image

Imagick::flopImage

(PECL imagick 2, PECL imagick 3)

Imagick::flopImage — Creates a vertical mirror image

说明

public Imagick::flopImage ( ) : bool

Creates a vertical mirror image by reflecting the pixels around the central y-axis.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::flopImage()

<?php
function flopImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->flopImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • ? Imagick::flopImage
  • Imagick::frameImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::forwardFourierTransformImage

(PECL imagick 3 >= 3.3.0)

Imagick::forwardFourierTransformImage — Description

说明

public Imagick::forwardFourierTransformimage ( bool $magnitude ) : bool

Implements the discrete Fourier transform (DFT) of the image either as a magnitude / phase or real / imaginary image pair.

参数

magnitude

If true, return as magnitude / phase pair otherwise a real / imaginary image pair.

返回值

成功时返回 true。

范例

Example #1 Imagick::forwardFourierTransformImage()

<?php
//Utility function for forwardTransformImage
function createMask() {
    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(0);
    $draw->setStrokeColor('rgb(255, 255, 255)');
    $draw->setFillColor('rgb(255, 255, 255)');

    //Draw a circle on the y-axis, with it's centre
    //at x, y that touches the origin
    $draw->circle(250, 250, 220, 250);

    $imagick = new \Imagick();
    $imagick->newImage(512, 512, "black");
    $imagick->drawImage($draw);
    $imagick->gaussianBlurImage(20, 20);
    $imagick->autoLevelImage();

    return $imagick;
}

function forwardFourierTransformImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->resizeimage(512, 512, \Imagick::FILTER_LANCZOS, 1);

    $mask = createMask();
    $imagick->forwardFourierTransformImage(true);

    @$imagick->setimageindex(0);
    $magnitude = $imagick->getimage();

    @$imagick->setimageindex(1);
    $imagickPhase = $imagick->getimage();

    if (true) {
        $imagickPhase->compositeImage($mask, \Imagick::COMPOSITE_MULTIPLY, 0, 0);
    }

    if (false) {
        $output = clone $imagickPhase;
        $output->setimageformat('png');
        header("Content-Type: image/png");
        echo $output->getImageBlob();
    }

    $magnitude->inverseFourierTransformImage($imagickPhase, true);

    $magnitude->setimageformat('png');
    header("Content-Type: image/png");
    echo $magnitude->getImageBlob();
}

?>


Adds a simulated three-dimensional border

  • ? Imagick::forwardFourierTransformImage
  • Imagick::functionImage ?
  • PHP Manual
  • Imagick
  • Adds a simulated three-dimensional border

Imagick::frameImage

(PECL imagick 2, PECL imagick 3)

Imagick::frameImage — Adds a simulated three-dimensional border

说明

public Imagick::frameImage ( mixed $matte_color , int $width , int $height , int $inner_bevel , int $outer_bevel ) : bool

Adds a simulated three-dimensional border around the image. The width and height specify the border width of the vertical and horizontal sides of the frame. The inner and outer bevels indicate the width of the inner and outer shadows of the frame.

参数

matte_color

ImagickPixel object or a string representing the matte color

width

The width of the border

height

The height of the border

inner_bevel

The inner bevel width

outer_bevel

The outer bevel width

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the first parameter. Previous versions allow only an ImagickPixel object.

范例

Example #1 Imagick::frameImage()

<?php
function frameImage($imagePath, $color, $width, $height, $innerBevel, $outerBevel) {
    $imagick = new \Imagick(realpath($imagePath));

    $width = $width + $innerBevel + $outerBevel;
    $height = $height + $innerBevel + $outerBevel;

    $imagick->frameimage(
        $color,
        $width,
        $height,
        $innerBevel,
        $outerBevel
    );
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Applies a function on the image

  • ? Imagick::frameImage
  • Imagick::fxImage ?
  • PHP Manual
  • Imagick
  • Applies a function on the image

Imagick::functionImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::functionImage — Applies a function on the image

说明

public Imagick::functionImage ( int $function , array $arguments , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Applies an arithmetic, relational, or logical expression to a pseudo image.

See also » ImageMagick v6 Examples - Image Transformations — Function, Multi-Argument Evaluate

此方法在Imagick基于ImageMagick 6.4.9以上版本编译时可用。

参数

function

Refer to this list of function constants

arguments

Array of arguments to pass to this function.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Create a sinusoidal gradient

<?php
$imagick = new Imagick();
$imagick->newPseudoImage(200, 200, 'gradient:black-white');
$arguments = array(3, -90);
$imagick->functionImage(Imagick::FUNCTION_SINUSOID, $arguments);

header("Content-Type: image/png");
$imagick->setImageFormat("png");
echo $imagick->getImageBlob();
?>

以上例程的输出类似于：

Output of create a sinusoidal gradient

Example #2 Create a gradient from the polynomial (4x^2 - 4x + 1)

<?php
$imagick = new Imagick();
$imagick->newPseudoImage(200, 200, 'gradient:black-white');
$arguments = array(4, -4, 1);
$imagick->functionImage(Imagick::FUNCTION_POLYNOMIAL, $arguments);

header("Content-Type: image/png");
$imagick->setimageformat("png");
echo $imagick->getImageBlob();
?>

以上例程的输出类似于：

Output of create a polynomial gradient

Example #3 Create a complex gradient from the polynomial (4x^2 - 4x^2 + 1) modulated by a sinusoidal gradient

<?php
$imagick1 = new Imagick();
$imagick1->newPseudoImage(200, 200, 'gradient:black-white');
$arguments = array(9, -90);
$imagick1->functionImage(Imagick::FUNCTION_SINUSOID, $arguments);

$imagick2 = new Imagick();
$imagick2->newPseudoImage(200, 200, 'gradient:black-white');
$arguments = array(0.5, 0);
$imagick2->functionImage(Imagick::FUNCTION_SINUSOID, $arguments);
$imagick1->compositeimage($imagick2, Imagick::COMPOSITE_MULTIPLY, 0, 0);

header("Content-Type: image/png");
$imagick1->setImageFormat("png");
echo $imagick1->getImageBlob();
?>

以上例程的输出类似于：

Output of create complex gradient


Evaluate expression for each pixel in the image

  • ? Imagick::functionImage
  • Imagick::gammaImage ?
  • PHP Manual
  • Imagick
  • Evaluate expression for each pixel in the image

Imagick::fxImage

(PECL imagick 2, PECL imagick 3)

Imagick::fxImage — Evaluate expression for each pixel in the image

说明

public Imagick::fxImage ( string $expression , int $channel = Imagick::CHANNEL_DEFAULT ) : Imagick

Evaluate expression for each pixel in the image. Consult » The Fx Special Effects Image Operator for more information.

参数

expression

The expression.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::fxImage()

<?php
function fxImage() {
    $imagick = new \Imagick();
    $imagick->newPseudoImage(200, 200, "xc:white");

    $fx = 'xx=i-w/2; yy=j-h/2; rr=hypot(xx,yy); (.5-rr/140)*1.2+.5';
    $fxImage = $imagick->fxImage($fx);

    header("Content-Type: image/png");
    $fxImage->setimageformat('png');
    echo $fxImage->getImageBlob();
}

?>


Gamma-corrects an image

  • ? Imagick::fxImage
  • Imagick::gaussianBlurImage ?
  • PHP Manual
  • Imagick
  • Gamma-corrects an image

Imagick::gammaImage

(PECL imagick 2, PECL imagick 3)

Imagick::gammaImage — Gamma-corrects an image

说明

public Imagick::gammaImage ( float $gamma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Gamma-corrects an image. The same image viewed on different devices will have perceptual differences in the way the image's intensities are represented on the screen. Specify individual gamma levels for the red, green, and blue channels, or adjust all three with the gamma parameter. Values typically range from 0.8 to 2.3.

参数

gamma

The amount of gamma-correction.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::gammaImage()

<?php
function gammaImage($imagePath, $gamma, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->gammaImage($gamma, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Blurs an image

  • ? Imagick::gammaImage
  • Imagick::getColorspace ?
  • PHP Manual
  • Imagick
  • Blurs an image

Imagick::gaussianBlurImage

(PECL imagick 2, PECL imagick 3)

Imagick::gaussianBlurImage — Blurs an image

说明

public Imagick::gaussianBlurImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Blurs an image. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, the radius should be larger than sigma. Use a radius of 0 and selects a suitable radius for you.

参数

radius

The radius of the Gaussian, in pixels, not counting the center pixel.

sigma

The standard deviation of the Gaussian, in pixels.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::gaussianBlurImage()

<?php
function gaussianBlurImage($imagePath, $radius, $sigma, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->gaussianBlurImage($radius, $sigma, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Gets the colorspace

  • ? Imagick::gaussianBlurImage
  • Imagick::getCompression ?
  • PHP Manual
  • Imagick
  • Gets the colorspace

Imagick::getColorspace

(PECL imagick 3)

Imagick::getColorspace — Gets the colorspace

说明

public Imagick::getColorspace ( ) : int

Gets the global colorspace value. 此方法在Imagick基于ImageMagick 6.5.7以上版本编译时可用。

返回值

Returns an integer which can be compared against COLORSPACE constants.


Gets the object compression type

  • ? Imagick::getColorspace
  • Imagick::getCompressionQuality ?
  • PHP Manual
  • Imagick
  • Gets the object compression type

Imagick::getCompression

(PECL imagick 2, PECL imagick 3)

Imagick::getCompression — Gets the object compression type

说明

public Imagick::getCompression ( ) : int

Gets the object compression type.

返回值

Returns the compression constant


Gets the object compression quality

  • ? Imagick::getCompression
  • Imagick::getCopyright ?
  • PHP Manual
  • Imagick
  • Gets the object compression quality

Imagick::getCompressionQuality

(PECL imagick 2, PECL imagick 3)

Imagick::getCompressionQuality — Gets the object compression quality

说明

public Imagick::getCompressionQuality ( ) : int

Gets the object compression quality.

返回值

Returns integer describing the compression quality


Returns the ImageMagick API copyright as a string

  • ? Imagick::getCompressionQuality
  • Imagick::getFilename ?
  • PHP Manual
  • Imagick
  • Returns the ImageMagick API copyright as a string

Imagick::getCopyright

(PECL imagick 2, PECL imagick 3)

Imagick::getCopyright — Returns the ImageMagick API copyright as a string

说明

public static Imagick::getCopyright ( ) : string

Returns the ImageMagick API copyright as a string.

返回值

Returns a string containing the copyright notice of Imagemagick and Magickwand C API.


The filename associated with an image sequence

  • ? Imagick::getCopyright
  • Imagick::getFont ?
  • PHP Manual
  • Imagick
  • The filename associated with an image sequence

Imagick::getFilename

(PECL imagick 2, PECL imagick 3)

Imagick::getFilename — The filename associated with an image sequence

说明

public Imagick::getFilename ( ) : string

Returns the filename associated with an image sequence.

返回值

Returns a string on success.

错误／异常

错误时抛出 ImagickException。


Gets font

  • ? Imagick::getFilename
  • Imagick::getFormat ?
  • PHP Manual
  • Imagick
  • Gets font

Imagick::getFont

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::getFont — Gets font

说明

public Imagick::getFont ( ) : string

Returns the objects font property. 此方法在Imagick基于ImageMagick 6.3.7以上版本编译时可用。

返回值

Returns the string containing the font name or false if not font is set.

参见

  • Imagick::setFont() - Sets font
  • ImagickDraw::setFont() - Sets the fully-specified font to use when annotating with text
  • ImagickDraw::getFont() - Returns the font


Returns the format of the Imagick object

  • ? Imagick::getFont
  • Imagick::getGravity ?
  • PHP Manual
  • Imagick
  • Returns the format of the Imagick object

Imagick::getFormat

(PECL imagick 2, PECL imagick 3)

Imagick::getFormat — Returns the format of the Imagick object

说明

public Imagick::getFormat ( ) : string

Returns the format of the Imagick object.

返回值

Returns the format of the image.

错误／异常

错误时抛出 ImagickException。


Gets the gravity

  • ? Imagick::getFormat
  • Imagick::getHomeURL ?
  • PHP Manual
  • Imagick
  • Gets the gravity

Imagick::getGravity

(PECL imagick 2, PECL imagick 3)

Imagick::getGravity — Gets the gravity

说明

public Imagick::getGravity ( ) : int

Gets the global gravity property for the Imagick object. 此方法在Imagick基于ImageMagick 6.4.0以上版本编译时可用。

返回值

Returns the gravity property. Refer to the list of gravity constants.


Returns the ImageMagick home URL

  • ? Imagick::getGravity
  • Imagick::getImage ?
  • PHP Manual
  • Imagick
  • Returns the ImageMagick home URL

Imagick::getHomeURL

(PECL imagick 2, PECL imagick 3)

Imagick::getHomeURL — Returns the ImageMagick home URL

说明

public static Imagick::getHomeURL ( ) : string

Returns the ImageMagick home URL.

返回值

Returns a link to the imagemagick homepage.


Returns a new Imagick object

  • ? Imagick::getHomeURL
  • Imagick::getImageAlphaChannel ?
  • PHP Manual
  • Imagick
  • Returns a new Imagick object

Imagick::getImage

(PECL imagick 2, PECL imagick 3)

Imagick::getImage — Returns a new Imagick object

说明

public Imagick::getImage ( ) : Imagick

Returns a new Imagick object with the current image sequence.

返回值

Returns a new Imagick object with the current image sequence.

错误／异常

错误时抛出 ImagickException。


获取图像的 alpha 通道

  • ? Imagick::getImage
  • Imagick::getImageArtifact ?
  • PHP Manual
  • Imagick
  • 获取图像的 alpha 通道

Imagick::getImageAlphaChannel

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageAlphaChannel — 获取图像的 alpha 通道

说明

Imagick::getImageAlphaChannel ( ) : int

获取图像的alpha通道值，为以下常量之一 alpha channel constants. 此方法在Imagick基于ImageMagick 6.4.0以上版本编译时可用。

返回值

返回当前图像的alpha通道值，该值是一个常量。该参考常量列表 alpha channel constants.

错误／异常

错误时抛出 ImagickException。


Get image artifact

  • ? Imagick::getImageAlphaChannel
  • Imagick::getImageAttribute ?
  • PHP Manual
  • Imagick
  • Get image artifact

Imagick::getImageArtifact

(PECL imagick 3)

Imagick::getImageArtifact — Get image artifact

说明

public Imagick::getImageArtifact ( string $artifact ) : string

Gets an artifact associated with the image. The difference between image properties and image artifacts is that properties are public and artifacts are private. 此方法在Imagick基于ImageMagick 6.5.7以上版本编译时可用。

参数

artifact

The name of the artifact

返回值

Returns the artifact value on success.

错误／异常

错误时抛出 ImagickException。

参见

  • Imagick::setImageArtifact() - Set image artifact
  • Imagick::deleteImageArtifact() - Delete image artifact


Description

  • ? Imagick::getImageArtifact
  • Imagick::getImageBackgroundColor ?
  • PHP Manual
  • Imagick
  • Description

Imagick::getImageAttribute

(PECL imagick 2, PECL imagick 3)

Imagick::getImageAttribute — Description

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::getImageAttribute ( string $key ) : string

Returns a named attribute.

参数

key

The key of the attribute to get.

返回值


Returns the image background color

  • ? Imagick::getImageAttribute
  • Imagick::getImageBlob ?
  • PHP Manual
  • Imagick
  • Returns the image background color

Imagick::getImageBackgroundColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImageBackgroundColor — Returns the image background color

说明

public Imagick::getImageBackgroundColor ( ) : ImagickPixel

Returns the image background color.

返回值

Returns an ImagickPixel set to the background color of the image.

错误／异常

错误时抛出 ImagickException。


Returns the image sequence as a blob

  • ? Imagick::getImageBackgroundColor
  • Imagick::getImageBluePrimary ?
  • PHP Manual
  • Imagick
  • Returns the image sequence as a blob

Imagick::getImageBlob

(PECL imagick 2, PECL imagick 3)

Imagick::getImageBlob — Returns the image sequence as a blob

说明

public Imagick::getImageBlob ( ) : string

Implements direct to memory image formats. It returns the image sequence as a string. The format of the image determines the format of the returned blob (GIF, JPEG, PNG, etc.). To return a different image format, use Imagick::setImageFormat().

返回值

Returns a string containing the image.

错误／异常

错误时抛出 ImagickException。


Returns the chromaticy blue primary point

  • ? Imagick::getImageBlob
  • Imagick::getImageBorderColor ?
  • PHP Manual
  • Imagick
  • Returns the chromaticy blue primary point

Imagick::getImageBluePrimary

(PECL imagick 2, PECL imagick 3)

Imagick::getImageBluePrimary — Returns the chromaticy blue primary point

说明

public Imagick::getImageBluePrimary ( ) : array

Returns the chromaticity blue primary point for the image.

参数

x

The chromaticity blue primary x-point.

y

The chromaticity blue primary y-point.

返回值

Array consisting of "x" and "y" coordinates of point.

错误／异常

错误时抛出 ImagickException。


Returns the image border color

  • ? Imagick::getImageBluePrimary
  • Imagick::getImageChannelDepth ?
  • PHP Manual
  • Imagick
  • Returns the image border color

Imagick::getImageBorderColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImageBorderColor — Returns the image border color

说明

public Imagick::getImageBorderColor ( ) : ImagickPixel

Returns the image border color.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Gets the depth for a particular image channel

  • ? Imagick::getImageBorderColor
  • Imagick::getImageChannelDistortion ?
  • PHP Manual
  • Imagick
  • Gets the depth for a particular image channel

Imagick::getImageChannelDepth

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelDepth — Gets the depth for a particular image channel

说明

public Imagick::getImageChannelDepth ( int $channel ) : int

Gets the depth for a particular image channel.

参数

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。


Compares image channels of an image to a reconstructed image

  • ? Imagick::getImageChannelDepth
  • Imagick::getImageChannelDistortions ?
  • PHP Manual
  • Imagick
  • Compares image channels of an image to a reconstructed image

Imagick::getImageChannelDistortion

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelDistortion — Compares image channels of an image to a reconstructed image

说明

public Imagick::getImageChannelDistortion ( Imagick $reference , int $channel , int $metric ) : float

Compares one or more image channels of an image to a reconstructed image and returns the specified distortion metric.

参数

reference

Imagick object to compare to.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

metric

One of the metric type constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Gets channel distortions

  • ? Imagick::getImageChannelDistortion
  • Imagick::getImageChannelExtrema ?
  • PHP Manual
  • Imagick
  • Gets channel distortions

Imagick::getImageChannelDistortions

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageChannelDistortions — Gets channel distortions

说明

public Imagick::getImageChannelDistortions ( Imagick $reference , int $metric , int $channel = Imagick::CHANNEL_DEFAULT ) : float

Compares one or more image channels of an image to a reconstructed image and returns the specified distortion metrics 此方法在Imagick基于ImageMagick 6.4.4以上版本编译时可用。

参数

reference

Imagick object containing the reference image

metric

Refer to this list of metric type constants.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

Returns a double describing the channel distortion.

错误／异常

错误时抛出 ImagickException。


Gets the extrema for one or more image channels

  • ? Imagick::getImageChannelDistortions
  • Imagick::getImageChannelKurtosis ?
  • PHP Manual
  • Imagick
  • Gets the extrema for one or more image channels

Imagick::getImageChannelExtrema

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelExtrema — Gets the extrema for one or more image channels

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::getImageChannelExtrema ( int $channel ) : array

Gets the extrema for one or more image channels. Return value is an associative array with the keys "minima" and "maxima".

参数

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


The getImageChannelKurtosis purpose

  • ? Imagick::getImageChannelExtrema
  • Imagick::getImageChannelMean ?
  • PHP Manual
  • Imagick
  • The getImageChannelKurtosis purpose

Imagick::getImageChannelKurtosis

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageChannelKurtosis — The getImageChannelKurtosis purpose

说明

public Imagick::getImageChannelKurtosis ( int $channel = Imagick::CHANNEL_DEFAULT ) : array

Get the kurtosis and skewness of a specific channel. 此方法在Imagick基于ImageMagick 6.4.9以上版本编译时可用。

参数

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

Returns an array with kurtosis and skewness members.

错误／异常

错误时抛出 ImagickException。


Gets the mean and standard deviation

  • ? Imagick::getImageChannelKurtosis
  • Imagick::getImageChannelRange ?
  • PHP Manual
  • Imagick
  • Gets the mean and standard deviation

Imagick::getImageChannelMean

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelMean — Gets the mean and standard deviation

说明

public Imagick::getImageChannelMean ( int $channel ) : array

Gets the mean and standard deviation of one or more image channels.

参数

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

Returns an array with "mean" and "standardDeviation" members.

错误／异常

错误时抛出 ImagickException。


Gets channel range

  • ? Imagick::getImageChannelMean
  • Imagick::getImageChannelStatistics ?
  • PHP Manual
  • Imagick
  • Gets channel range

Imagick::getImageChannelRange

(PECL imagick 2 >= 2.2.1, PECL imagick 3)

Imagick::getImageChannelRange — Gets channel range

说明

public Imagick::getImageChannelRange ( int $channel ) : array

Gets the range for one or more image channels. 此方法在Imagick基于ImageMagick 6.4.0以上版本编译时可用。

参数

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

Returns an array containing minima and maxima values of the channel(s).

错误／异常

错误时抛出 ImagickException。


Returns statistics for each channel in the image

  • ? Imagick::getImageChannelRange
  • Imagick::getImageClipMask ?
  • PHP Manual
  • Imagick
  • Returns statistics for each channel in the image

Imagick::getImageChannelStatistics

(PECL imagick 2, PECL imagick 3)

Imagick::getImageChannelStatistics — Returns statistics for each channel in the image

说明

public Imagick::getImageChannelStatistics ( ) : array

Returns statistics for each channel in the image. The statistics include the channel depth, its minima and maxima, the mean, and the standard deviation.

返回值

成功时返回 true。


Gets image clip mask

  • ? Imagick::getImageChannelStatistics
  • Imagick::getImageColormapColor ?
  • PHP Manual
  • Imagick
  • Gets image clip mask

Imagick::getImageClipMask

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageClipMask — Gets image clip mask

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::getImageClipMask ( ) : Imagick

Returns the image clip mask. The clip mask is an Imagick object containing the clip mask. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

返回值

Returns an Imagick object containing the clip mask.

错误／异常

错误时抛出 ImagickException。


Returns the color of the specified colormap index

  • ? Imagick::getImageClipMask
  • Imagick::getImageColors ?
  • PHP Manual
  • Imagick
  • Returns the color of the specified colormap index

Imagick::getImageColormapColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImageColormapColor — Returns the color of the specified colormap index

说明

public Imagick::getImageColormapColor ( int $index ) : ImagickPixel

Returns the color of the specified colormap index.

参数

index

The offset into the image colormap.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Gets the number of unique colors in the image

  • ? Imagick::getImageColormapColor
  • Imagick::getImageColorspace ?
  • PHP Manual
  • Imagick
  • Gets the number of unique colors in the image

Imagick::getImageColors

(PECL imagick 2, PECL imagick 3)

Imagick::getImageColors — Gets the number of unique colors in the image

说明

public Imagick::getImageColors ( ) : int

Gets the number of unique colors in the image.

返回值

Returns an int, the number of unique colors in the image.


Gets the image colorspace

  • ? Imagick::getImageColors
  • Imagick::getImageCompose ?
  • PHP Manual
  • Imagick
  • Gets the image colorspace

Imagick::getImageColorspace

(PECL imagick 2, PECL imagick 3)

Imagick::getImageColorspace — Gets the image colorspace

说明

public Imagick::getImageColorspace ( ) : int

Gets the image colorspace.

返回值

Returns an integer which can be compared against COLORSPACE constants.


Returns the composite operator associated with the image

  • ? Imagick::getImageColorspace
  • Imagick::getImageCompression ?
  • PHP Manual
  • Imagick
  • Returns the composite operator associated with the image

Imagick::getImageCompose

(PECL imagick 2, PECL imagick 3)

Imagick::getImageCompose — Returns the composite operator associated with the image

说明

public Imagick::getImageCompose ( ) : int

Returns the composite operator associated with the image.

返回值

成功时返回 true。


Gets the current image's compression type

  • ? Imagick::getImageCompose
  • Imagick::getImageCompressionQuality ?
  • PHP Manual
  • Imagick
  • Gets the current image's compression type

Imagick::getImageCompression

(PECL imagick 3 >= 3.3.0)

Imagick::getImageCompression — Gets the current image's compression type

说明

public Imagick::getImageCompression ( ) : int

Gets the current image's compression type.

返回值

Returns the compression constant


Gets the current image's compression quality

  • ? Imagick::getImageCompression
  • Imagick::getImageDelay ?
  • PHP Manual
  • Imagick
  • Gets the current image's compression quality

Imagick::getImageCompressionQuality

(PECL imagick 2 >= 2.2.2, PECL imagick 3)

Imagick::getImageCompressionQuality — Gets the current image's compression quality

说明

public Imagick::getImageCompressionQuality ( ) : int

Gets the current image's compression quality

返回值

Returns integer describing the images compression quality


Gets the image delay

  • ? Imagick::getImageCompressionQuality
  • Imagick::getImageDepth ?
  • PHP Manual
  • Imagick
  • Gets the image delay

Imagick::getImageDelay

(PECL imagick 2, PECL imagick 3)

Imagick::getImageDelay — Gets the image delay

说明

public Imagick::getImageDelay ( ) : int

Gets the image delay.

返回值

Returns the image delay.

错误／异常

错误时抛出 ImagickException。


Gets the image depth

  • ? Imagick::getImageDelay
  • Imagick::getImageDispose ?
  • PHP Manual
  • Imagick
  • Gets the image depth

Imagick::getImageDepth

(PECL imagick 2, PECL imagick 3)

Imagick::getImageDepth — Gets the image depth

说明

public Imagick::getImageDepth ( ) : int

Gets the image depth.

返回值

The image depth.


Gets the image disposal method

  • ? Imagick::getImageDepth
  • Imagick::getImageDistortion ?
  • PHP Manual
  • Imagick
  • Gets the image disposal method

Imagick::getImageDispose

(PECL imagick 2, PECL imagick 3)

Imagick::getImageDispose — Gets the image disposal method

说明

public Imagick::getImageDispose ( ) : int

Gets the image disposal method.

返回值

Returns the dispose method on success.

错误／异常

错误时抛出 ImagickException。


Compares an image to a reconstructed image

  • ? Imagick::getImageDispose
  • Imagick::getImageExtrema ?
  • PHP Manual
  • Imagick
  • Compares an image to a reconstructed image

Imagick::getImageDistortion

(PECL imagick 2, PECL imagick 3)

Imagick::getImageDistortion — Compares an image to a reconstructed image

说明

public Imagick::getImageDistortion ( MagickWand $reference , int $metric ) : float

Compares an image to a reconstructed image and returns the specified distortion metric.

参数

reference

Imagick object to compare to.

metric

One of the metric type constants.

返回值

Returns the distortion metric used on the image (or the best guess thereof).

错误／异常

错误时抛出 ImagickException。


Gets the extrema for the image

  • ? Imagick::getImageDistortion
  • Imagick::getImageFilename ?
  • PHP Manual
  • Imagick
  • Gets the extrema for the image

Imagick::getImageExtrema

(PECL imagick 2, PECL imagick 3)

Imagick::getImageExtrema — Gets the extrema for the image

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::getImageExtrema ( ) : array

Gets the extrema for the image. Returns an associative array with the keys "min" and "max".

返回值

Returns an associative array with the keys "min" and "max".

错误／异常

错误时抛出 ImagickException。


Returns the filename of a particular image in a sequence

  • ? Imagick::getImageExtrema
  • Imagick::getImageFormat ?
  • PHP Manual
  • Imagick
  • Returns the filename of a particular image in a sequence

Imagick::getImageFilename

(PECL imagick 2, PECL imagick 3)

Imagick::getImageFilename — Returns the filename of a particular image in a sequence

说明

public Imagick::getImageFilename ( ) : string

Returns the filename of a particular image in a sequence.

返回值

Returns a string with the filename of the image.

错误／异常

错误时抛出 ImagickException。


Returns the format of a particular image in a sequence

  • ? Imagick::getImageFilename
  • Imagick::getImageGamma ?
  • PHP Manual
  • Imagick
  • Returns the format of a particular image in a sequence

Imagick::getImageFormat

(PECL imagick 2, PECL imagick 3)

Imagick::getImageFormat — Returns the format of a particular image in a sequence

说明

public Imagick::getImageFormat ( ) : string

Returns the format of a particular image in a sequence.

返回值

Returns a string containing the image format on success.

错误／异常

错误时抛出 ImagickException。


Gets the image gamma

  • ? Imagick::getImageFormat
  • Imagick::getImageGeometry ?
  • PHP Manual
  • Imagick
  • Gets the image gamma

Imagick::getImageGamma

(PECL imagick 2, PECL imagick 3)

Imagick::getImageGamma — Gets the image gamma

说明

public Imagick::getImageGamma ( ) : float

Gets the image gamma.

返回值

Returns the image gamma on success.

错误／异常

错误时抛出 ImagickException。


Gets the width and height as an associative array

  • ? Imagick::getImageGamma
  • Imagick::getImageGravity ?
  • PHP Manual
  • Imagick
  • Gets the width and height as an associative array

Imagick::getImageGeometry

(PECL imagick 2, PECL imagick 3)

Imagick::getImageGeometry — Gets the width and height as an associative array

说明

public Imagick::getImageGeometry ( ) : array

Returns the width and height as an associative array.

返回值

Returns an array with the width/height of the image.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::getImageGeometry()

<?php
function getImageGeometry($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Gets the image gravity

  • ? Imagick::getImageGeometry
  • Imagick::getImageGreenPrimary ?
  • PHP Manual
  • Imagick
  • Gets the image gravity

Imagick::getImageGravity

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageGravity — Gets the image gravity

说明

public Imagick::getImageGravity ( ) : int

Gets the current gravity value of the image. Unlike Imagick::getGravity(), this method returns the gravity defined for the current image sequence. 此方法在Imagick基于ImageMagick 6.4.4以上版本编译时可用。

返回值

Returns the images gravity property. Refer to the list of gravity constants.


Returns the chromaticy green primary point

  • ? Imagick::getImageGravity
  • Imagick::getImageHeight ?
  • PHP Manual
  • Imagick
  • Returns the chromaticy green primary point

Imagick::getImageGreenPrimary

(PECL imagick 2, PECL imagick 3)

Imagick::getImageGreenPrimary — Returns the chromaticy green primary point

说明

public Imagick::getImageGreenPrimary ( ) : array

Returns the chromaticity green primary point. Returns an array with the keys "x" and "y".

返回值

Returns an array with the keys "x" and "y" on success, throws an ImagickException on failure.

错误／异常

错误时抛出 ImagickException。


Returns the image height

  • ? Imagick::getImageGreenPrimary
  • Imagick::getImageHistogram ?
  • PHP Manual
  • Imagick
  • Returns the image height

Imagick::getImageHeight

(PECL imagick 2, PECL imagick 3)

Imagick::getImageHeight — Returns the image height

说明

public Imagick::getImageHeight ( ) : int

Returns the image height.

返回值

Returns the image height in pixels.

错误／异常

错误时抛出 ImagickException。


Gets the image histogram

  • ? Imagick::getImageHeight
  • Imagick::getImageIndex ?
  • PHP Manual
  • Imagick
  • Gets the image histogram

Imagick::getImageHistogram

(PECL imagick 2, PECL imagick 3)

Imagick::getImageHistogram — Gets the image histogram

说明

public Imagick::getImageHistogram ( ) : array

Returns the image histogram as an array of ImagickPixel objects.

返回值

Returns the image histogram as an array of ImagickPixel objects.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Generates Imagick::getImageHistogram()

<?php
function getColorStatistics($histogramElements, $colorChannel) {
    $colorStatistics = [];

    foreach ($histogramElements as $histogramElement) {
        $color = $histogramElement->getColorValue($colorChannel);
        $color = intval($color * 255);
        $count = $histogramElement->getColorCount();

        if (array_key_exists($color, $colorStatistics)) {
            $colorStatistics[$color] += $count;
        }
        else {
            $colorStatistics[$color] = $count;
        }
    }

    ksort($colorStatistics);

    return $colorStatistics;
}

function getImageHistogram($imagePath) {

    $backgroundColor = 'black';

    $draw = new \ImagickDraw();
    $draw->setStrokeWidth(0); //make the lines be as thin as possible

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    $histogramWidth = 256;
    $histogramHeight = 100; // the height for each RGB segment

    $imagick = new \Imagick(realpath($imagePath));
    //Resize the image to be small, otherwise PHP tends to run out of memory
    //This might lead to bad results for images that are pathologically 'pixelly'
    $imagick->adaptiveResizeImage(200, 200, true);
    $histogramElements = $imagick->getImageHistogram();

    $histogram = new \Imagick();
    $histogram->newpseudoimage($histogramWidth, $histogramHeight * 3, 'xc:black');
    $histogram->setImageFormat('png');

    $getMax = function ($carry, $item)  {
        if ($item > $carry) {
            return $item;
        }
        return $carry;
    };

    $colorValues = [
        'red' => getColorStatistics($histogramElements, \Imagick::COLOR_RED),
        'lime' => getColorStatistics($histogramElements, \Imagick::COLOR_GREEN),
        'blue' => getColorStatistics($histogramElements, \Imagick::COLOR_BLUE),
    ];

    $max = array_reduce($colorValues['red'] , $getMax, 0);
    $max = array_reduce($colorValues['lime'] , $getMax, $max);
    $max = array_reduce($colorValues['blue'] , $getMax, $max);

    $scale =  $histogramHeight / $max;

    $count = 0;
    foreach ($colorValues as $color => $values) {
        $draw->setstrokecolor($color);

        $offset = ($count + 1) * $histogramHeight;

        foreach ($values as $index => $value) {
            $draw->line($index, $offset, $index, $offset - ($value * $scale));
        }
        $count++;
    }

    $histogram->drawImage($draw);

    header( "Content-Type: image/png" );
    echo $histogram;
}

?>


Gets the index of the current active image

  • ? Imagick::getImageHistogram
  • Imagick::getImageInterlaceScheme ?
  • PHP Manual
  • Imagick
  • Gets the index of the current active image

Imagick::getImageIndex

(PECL imagick 2, PECL imagick 3)

Imagick::getImageIndex — Gets the index of the current active image

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::getImageIndex ( ) : int

Returns the index of the current active image within the Imagick object. This method has been deprecated. See Imagick::getIteratorIndex().

返回值

Returns an integer containing the index of the image in the stack.

错误／异常

错误时抛出 ImagickException。


Gets the image interlace scheme

  • ? Imagick::getImageIndex
  • Imagick::getImageInterpolateMethod ?
  • PHP Manual
  • Imagick
  • Gets the image interlace scheme

Imagick::getImageInterlaceScheme

(PECL imagick 2, PECL imagick 3)

Imagick::getImageInterlaceScheme — Gets the image interlace scheme

说明

public Imagick::getImageInterlaceScheme ( ) : int

Gets the image interlace scheme.

返回值

Returns the interlace scheme as an integer on success. 错误时抛出 ImagickException。


Returns the interpolation method

  • ? Imagick::getImageInterlaceScheme
  • Imagick::getImageIterations ?
  • PHP Manual
  • Imagick
  • Returns the interpolation method

Imagick::getImageInterpolateMethod

(PECL imagick 2, PECL imagick 3)

Imagick::getImageInterpolateMethod — Returns the interpolation method

说明

public Imagick::getImageInterpolateMethod ( ) : int

Returns the interpolation method for the specified image. The method is one of the Imagick::INTERPOLATE_* constants.

返回值

Returns the interpolate method on success.

错误／异常

错误时抛出 ImagickException。


Gets the image iterations

  • ? Imagick::getImageInterpolateMethod
  • Imagick::getImageLength ?
  • PHP Manual
  • Imagick
  • Gets the image iterations

Imagick::getImageIterations

(PECL imagick 2, PECL imagick 3)

Imagick::getImageIterations — Gets the image iterations

说明

public Imagick::getImageIterations ( ) : int

Gets the image iterations.

返回值

Returns the image iterations as an integer.

错误／异常

错误时抛出 ImagickException。


Returns the image length in bytes

  • ? Imagick::getImageIterations
  • Imagick::getImageMatte ?
  • PHP Manual
  • Imagick
  • Returns the image length in bytes

Imagick::getImageLength

(PECL imagick 2, PECL imagick 3)

Imagick::getImageLength — Returns the image length in bytes

说明

public Imagick::getImageLength ( ) : int

Returns the image length in bytes

返回值

Returns an int containing the current image size.

范例

Example #1 Using Imagick::getImageLength():

Getting image length in bytes

<?php
$image = new Imagick('test.jpg');
echo $image->getImageLength() . ' bytes';
?>


Return if the image has a matte channel

  • ? Imagick::getImageLength
  • Imagick::getImageMatteColor ?
  • PHP Manual
  • Imagick
  • Return if the image has a matte channel

Imagick::getImageMatte

(PECL imagick 2, PECL imagick 3)

Imagick::getImageMatte — Return if the image has a matte channel

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::getImageMatte ( ) : bool

Returns true if the image has a matte channel otherwise false. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

返回值

成功时返回 true。


Returns the image matte color

  • ? Imagick::getImageMatte
  • Imagick::getImageMimeType ?
  • PHP Manual
  • Imagick
  • Returns the image matte color

Imagick::getImageMatteColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImageMatteColor — Returns the image matte color

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::getImageMatteColor ( ) : ImagickPixel

Returns the image matte color.

返回值

Returns ImagickPixel object on success.

错误／异常

错误时抛出 ImagickException。


Description

  • ? Imagick::getImageMatteColor
  • Imagick::getImageOrientation ?
  • PHP Manual
  • Imagick
  • Description

Imagick::getImageMimeType

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::getImageMimeType — Description

说明

public Imagick::getImageMimeType ( ) : string

Returns the image mime-type.

参数

此函数没有参数。

返回值


Gets the image orientation

  • ? Imagick::getImageMimeType
  • Imagick::getImagePage ?
  • PHP Manual
  • Imagick
  • Gets the image orientation

Imagick::getImageOrientation

(PECL imagick 2, PECL imagick 3)

Imagick::getImageOrientation — Gets the image orientation

说明

public Imagick::getImageOrientation ( ) : int

Gets the image orientation. The return value is one of the orientation constants.

返回值

Returns an int on success.

错误／异常

错误时抛出 ImagickException。


Returns the page geometry

  • ? Imagick::getImageOrientation
  • Imagick::getImagePixelColor ?
  • PHP Manual
  • Imagick
  • Returns the page geometry

Imagick::getImagePage

(PECL imagick 2, PECL imagick 3)

Imagick::getImagePage — Returns the page geometry

说明

public Imagick::getImagePage ( ) : array

Returns the page geometry associated with the image in an array with the keys "width", "height", "x", and "y".

返回值

Returns the page geometry associated with the image in an array with the keys "width", "height", "x", and "y".

错误／异常

错误时抛出 ImagickException。


Returns the color of the specified pixel

  • ? Imagick::getImagePage
  • Imagick::getImageProfile ?
  • PHP Manual
  • Imagick
  • Returns the color of the specified pixel

Imagick::getImagePixelColor

(PECL imagick 2, PECL imagick 3)

Imagick::getImagePixelColor — Returns the color of the specified pixel

说明

public Imagick::getImagePixelColor ( int $x , int $y ) : ImagickPixel

Returns the color of the specified pixel.

参数

x

The x-coordinate of the pixel

y

The y-coordinate of the pixel

返回值

Returns an ImagickPixel instance for the color at the coordinates given.

错误／异常

错误时抛出 ImagickException。


Returns the named image profile

  • ? Imagick::getImagePixelColor
  • Imagick::getImageProfiles ?
  • PHP Manual
  • Imagick
  • Returns the named image profile

Imagick::getImageProfile

(PECL imagick 2, PECL imagick 3)

Imagick::getImageProfile — Returns the named image profile

说明

public Imagick::getImageProfile ( string $name ) : string

Returns the named image profile.

参数

name

The name of the profile to return.

返回值

Returns a string containing the image profile.

错误／异常

错误时抛出 ImagickException。


Returns the image profiles

  • ? Imagick::getImageProfile
  • Imagick::getImageProperties ?
  • PHP Manual
  • Imagick
  • Returns the image profiles

Imagick::getImageProfiles

(PECL imagick 2, PECL imagick 3)

Imagick::getImageProfiles — Returns the image profiles

说明

public Imagick::getImageProfiles ( string $pattern = "*" , bool $include_values = true ) : array

Returns all associated profiles that match the pattern. If false is passed as second parameter only the profile names are returned. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

pattern

The pattern for profile names.

include_values

Whether to return only profile names. If false then only profile names will be returned.

返回值

Returns an array containing the image profiles or profile names.


Returns the image properties

  • ? Imagick::getImageProfiles
  • Imagick::getImageProperty ?
  • PHP Manual
  • Imagick
  • Returns the image properties

Imagick::getImageProperties

(PECL imagick 2, PECL imagick 3)

Imagick::getImageProperties — Returns the image properties

说明

public Imagick::getImageProperties ( string $pattern = "*" , bool $include_values = true ) : array

Returns all associated properties that match the pattern. If false is passed as second parameter only the property names are returned. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

pattern

The pattern for property names.

include_values

Whether to return only property names. If false then only property names will be returned.

返回值

Returns an array containing the image properties or property names.

范例

Example #1 Using Imagick::getImageProperties():

An example of extracting EXIF information.

<?php

/* Create the object */
$im = new imagick("/path/to/example.jpg");

/* Get the EXIF information */
$exifArray = $im->getImageProperties("exif:*");

/* Loop trough the EXIF properties */
foreach ($exifArray as $name => $property)
{
    echo "{$name} => {$property}<br />\n";
}

?>


Returns the named image property

  • ? Imagick::getImageProperties
  • Imagick::getImageRedPrimary ?
  • PHP Manual
  • Imagick
  • Returns the named image property

Imagick::getImageProperty

(PECL imagick 2, PECL imagick 3)

Imagick::getImageProperty — Returns the named image property

说明

public Imagick::getImageProperty ( string $name ) : string

Returns the named image property. 此方法在Imagick基于ImageMagick 6.3.2以上版本编译时可用。

参数

name

name of the property (for example Exif:DateTime)

范例

Example #1 Using Imagick::getImageProperty():

Setting and getting image property

<?php
$image = new Imagick();
$image->newImage(300, 200, "black");

$image->setImageProperty('Exif:Make', 'Imagick');
echo $image->getImageProperty('Exif:Make');
?>

参见

  • Imagick::setImageProperty() - Sets an image property

返回值

Returns a string containing the image property, false if a property with the given name does not exist.


Returns the chromaticity red primary point

  • ? Imagick::getImageProperty
  • Imagick::getImageRegion ?
  • PHP Manual
  • Imagick
  • Returns the chromaticity red primary point

Imagick::getImageRedPrimary

(PECL imagick 2, PECL imagick 3)

Imagick::getImageRedPrimary — Returns the chromaticity red primary point

说明

public Imagick::getImageRedPrimary ( ) : array

Returns the chromaticity red primary point as an array with the keys "x" and "y".

返回值

Returns the chromaticity red primary point as an array with the keys "x" and "y". 错误时抛出 ImagickException。

错误／异常

错误时抛出 ImagickException。


Extracts a region of the image

  • ? Imagick::getImageRedPrimary
  • Imagick::getImageRenderingIntent ?
  • PHP Manual
  • Imagick
  • Extracts a region of the image

Imagick::getImageRegion

(PECL imagick 2, PECL imagick 3)

Imagick::getImageRegion — Extracts a region of the image

说明

public Imagick::getImageRegion ( int $width , int $height , int $x , int $y ) : Imagick

Extracts a region of the image and returns it as a new Imagick object.

参数

width

The width of the extracted region.

height

The height of the extracted region.

x

X-coordinate of the top-left corner of the extracted region.

y

Y-coordinate of the top-left corner of the extracted region.

返回值

Extracts a region of the image and returns it as a new wand.

错误／异常

错误时抛出 ImagickException。


Gets the image rendering intent

  • ? Imagick::getImageRegion
  • Imagick::getImageResolution ?
  • PHP Manual
  • Imagick
  • Gets the image rendering intent

Imagick::getImageRenderingIntent

(PECL imagick 2, PECL imagick 3)

Imagick::getImageRenderingIntent — Gets the image rendering intent

说明

public Imagick::getImageRenderingIntent ( ) : int

Gets the image rendering intent.

返回值

Returns the image rendering intent.

错误／异常

错误时抛出 ImagickException。


获取图像的x,y轴分辨率

  • ? Imagick::getImageRenderingIntent
  • Imagick::getImagesBlob ?
  • PHP Manual
  • Imagick
  • 获取图像的x,y轴分辨率

Imagick::getImageResolution

(PECL imagick 2, PECL imagick 3)

Imagick::getImageResolution — 获取图像的x,y轴分辨率

说明

Imagick::getImageResolution ( ) : array

获取图像的x,y轴分辨率

返回值

返回分辨率值的数组

错误／异常

错误时抛出 ImagickException。


Returns all image sequences as a blob

  • ? Imagick::getImageResolution
  • Imagick::getImageScene ?
  • PHP Manual
  • Imagick
  • Returns all image sequences as a blob

Imagick::getImagesBlob

(PECL imagick 2, PECL imagick 3)

Imagick::getImagesBlob — Returns all image sequences as a blob

说明

public Imagick::getImagesBlob ( ) : string

Implements direct to memory image formats. It returns all image sequences as a string. The format of the image determines the format of the returned blob (GIF, JPEG, PNG, etc.). To return a different image format, use Imagick::setImageFormat().

返回值

Returns a string containing the images. On failure, throws ImagickException.


Gets the image scene

  • ? Imagick::getImagesBlob
  • Imagick::getImageSignature ?
  • PHP Manual
  • Imagick
  • Gets the image scene

Imagick::getImageScene

(PECL imagick 2, PECL imagick 3)

Imagick::getImageScene — Gets the image scene

说明

public Imagick::getImageScene ( ) : int

Gets the image scene.

返回值

Returns the image scene.

错误／异常

错误时抛出 ImagickException。


Generates an SHA-256 message digest

  • ? Imagick::getImageScene
  • Imagick::getImageSize ?
  • PHP Manual
  • Imagick
  • Generates an SHA-256 message digest

Imagick::getImageSignature

(PECL imagick 2, PECL imagick 3)

Imagick::getImageSignature — Generates an SHA-256 message digest

说明

public Imagick::getImageSignature ( ) : string

Generates an SHA-256 message digest for the image pixel stream.

返回值

Returns a string containing the SHA-256 hash of the file.

错误／异常

错误时抛出 ImagickException。


Returns the image length in bytes

  • ? Imagick::getImageSignature
  • Imagick::getImageTicksPerSecond ?
  • PHP Manual
  • Imagick
  • Returns the image length in bytes

Imagick::getImageSize

(PECL imagick 2, PECL imagick 3)

Imagick::getImageSize — Returns the image length in bytes

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::getImageSize ( ) : int

Returns the image length in bytes. Deprecated in favour of Imagick::getImageLength()

返回值

Returns an int containing the current image size.


Gets the image ticks-per-second

  • ? Imagick::getImageSize
  • Imagick::getImageTotalInkDensity ?
  • PHP Manual
  • Imagick
  • Gets the image ticks-per-second

Imagick::getImageTicksPerSecond

(PECL imagick 2, PECL imagick 3)

Imagick::getImageTicksPerSecond — Gets the image ticks-per-second

说明

public Imagick::getImageTicksPerSecond ( ) : int

Gets the image ticks-per-second.

返回值

Returns the image ticks-per-second.

错误／异常

错误时抛出 ImagickException。


Gets the image total ink density

  • ? Imagick::getImageTicksPerSecond
  • Imagick::getImageType ?
  • PHP Manual
  • Imagick
  • Gets the image total ink density

Imagick::getImageTotalInkDensity

(PECL imagick 2, PECL imagick 3)

Imagick::getImageTotalInkDensity — Gets the image total ink density

说明

public Imagick::getImageTotalInkDensity ( ) : float

Gets the image total ink density.

返回值

Returns the image total ink density of the image. 错误时抛出 ImagickException。


Gets the potential image type

  • ? Imagick::getImageTotalInkDensity
  • Imagick::getImageUnits ?
  • PHP Manual
  • Imagick
  • Gets the potential image type

Imagick::getImageType

(PECL imagick 2, PECL imagick 3)

Imagick::getImageType — Gets the potential image type

说明

public Imagick::getImageType ( ) : int

Gets the potential image type.

返回值

Returns the potential image type.

  • imagick::IMGTYPE_UNDEFINED
  • imagick::IMGTYPE_BILEVEL
  • imagick::IMGTYPE_GRAYSCALE
  • imagick::IMGTYPE_GRAYSCALEMATTE
  • imagick::IMGTYPE_PALETTE
  • imagick::IMGTYPE_PALETTEMATTE
  • imagick::IMGTYPE_TRUECOLOR
  • imagick::IMGTYPE_TRUECOLORMATTE
  • imagick::IMGTYPE_COLORSEPARATION
  • imagick::IMGTYPE_COLORSEPARATIONMATTE
  • imagick::IMGTYPE_OPTIMIZE

错误／异常

错误时抛出 ImagickException。


获取图像的分辨率单位

  • ? Imagick::getImageType
  • Imagick::getImageVirtualPixelMethod ?
  • PHP Manual
  • Imagick
  • 获取图像的分辨率单位

Imagick::getImageUnits

(PECL imagick 2, PECL imagick 3)

Imagick::getImageUnits — 获取图像的分辨率单位

说明

Imagick::getImageUnits ( ) : int

获取图像的分辨率单位。

返回值

返回分辨率的单位

错误／异常

错误时抛出 ImagickException。


Returns the virtual pixel method

  • ? Imagick::getImageUnits
  • Imagick::getImageWhitePoint ?
  • PHP Manual
  • Imagick
  • Returns the virtual pixel method

Imagick::getImageVirtualPixelMethod

(PECL imagick 2, PECL imagick 3)

Imagick::getImageVirtualPixelMethod — Returns the virtual pixel method

说明

public Imagick::getImageVirtualPixelMethod ( ) : int

Returns the virtual pixel method for the specified image.

返回值

Returns the virtual pixel method on success.

错误／异常

错误时抛出 ImagickException。


Returns the chromaticity white point

  • ? Imagick::getImageVirtualPixelMethod
  • Imagick::getImageWidth ?
  • PHP Manual
  • Imagick
  • Returns the chromaticity white point

Imagick::getImageWhitePoint

(PECL imagick 2, PECL imagick 3)

Imagick::getImageWhitePoint — Returns the chromaticity white point

说明

public Imagick::getImageWhitePoint ( ) : array

Returns the chromaticity white point as an associative array with the keys "x" and "y".

返回值

Returns the chromaticity white point as an associative array with the keys "x" and "y".

错误／异常

错误时抛出 ImagickException。


Returns the image width

  • ? Imagick::getImageWhitePoint
  • Imagick::getInterlaceScheme ?
  • PHP Manual
  • Imagick
  • Returns the image width

Imagick::getImageWidth

(PECL imagick 2, PECL imagick 3)

Imagick::getImageWidth — Returns the image width

说明

public Imagick::getImageWidth ( ) : int

Returns the image width.

返回值

Returns the image width.

错误／异常

错误时抛出 ImagickException。


Gets the object interlace scheme

  • ? Imagick::getImageWidth
  • Imagick::getIteratorIndex ?
  • PHP Manual
  • Imagick
  • Gets the object interlace scheme

Imagick::getInterlaceScheme

(PECL imagick 2, PECL imagick 3)

Imagick::getInterlaceScheme — Gets the object interlace scheme

说明

public Imagick::getInterlaceScheme ( ) : int

Gets the object interlace scheme.

返回值

Gets the wand interlace scheme.

错误／异常

错误时抛出 ImagickException。


Gets the index of the current active image

  • ? Imagick::getInterlaceScheme
  • Imagick::getNumberImages ?
  • PHP Manual
  • Imagick
  • Gets the index of the current active image

Imagick::getIteratorIndex

(PECL imagick 2, PECL imagick 3)

Imagick::getIteratorIndex — Gets the index of the current active image

说明

public Imagick::getIteratorIndex ( ) : int

Returns the index of the current active image within the Imagick object. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

返回值

Returns an integer containing the index of the image in the stack.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::getIteratorIndex():

Create images, set and get the iterator index

<?php
$im = new Imagick();
$im->newImage(100, 100, new ImagickPixel("red"));
$im->newImage(100, 100, new ImagickPixel("green"));
$im->newImage(100, 100, new ImagickPixel("blue"));

$im->setIteratorIndex(1);
echo $im->getIteratorIndex();
?>

参见

  • Imagick::setIteratorIndex() - Set the iterator position
  • Imagick::getImageIndex() - Gets the index of the current active image
  • Imagick::setImageIndex() - Set the iterator position


Returns the number of images in the object

  • ? Imagick::getIteratorIndex
  • Imagick::getOption ?
  • PHP Manual
  • Imagick
  • Returns the number of images in the object

Imagick::getNumberImages

(PECL imagick 2, PECL imagick 3)

Imagick::getNumberImages — Returns the number of images in the object

说明

public Imagick::getNumberImages ( ) : int

Returns the number of images associated with Imagick object.

返回值

Returns the number of images associated with Imagick object.

错误／异常

错误时抛出 ImagickException。


Returns a value associated with the specified key

  • ? Imagick::getNumberImages
  • Imagick::getPackageName ?
  • PHP Manual
  • Imagick
  • Returns a value associated with the specified key

Imagick::getOption

(PECL imagick 2, PECL imagick 3)

Imagick::getOption — Returns a value associated with the specified key

说明

public Imagick::getOption ( string $key ) : string

Returns a value associated within the object for the specified key.

参数

key

The name of the option

返回值

Returns a value associated with a wand and the specified key.

错误／异常

错误时抛出 ImagickException。


Returns the ImageMagick package name

  • ? Imagick::getOption
  • Imagick::getPage ?
  • PHP Manual
  • Imagick
  • Returns the ImageMagick package name

Imagick::getPackageName

(PECL imagick 2, PECL imagick 3)

Imagick::getPackageName — Returns the ImageMagick package name

说明

public static Imagick::getPackageName ( ) : string

Returns the ImageMagick package name.

返回值

Returns the ImageMagick package name as a string.

错误／异常

错误时抛出 ImagickException。


Returns the page geometry

  • ? Imagick::getPackageName
  • Imagick::getPixelIterator ?
  • PHP Manual
  • Imagick
  • Returns the page geometry

Imagick::getPage

(PECL imagick 2, PECL imagick 3)

Imagick::getPage — Returns the page geometry

说明

public Imagick::getPage ( ) : array

Returns the page geometry associated with the Imagick object in an associative array with the keys "width", "height", "x", and "y".

返回值

Returns the page geometry associated with the Imagick object in an associative array with the keys "width", "height", "x", and "y", throwing ImagickException on error.


Returns a MagickPixelIterator

  • ? Imagick::getPage
  • Imagick::getPixelRegionIterator ?
  • PHP Manual
  • Imagick
  • Returns a MagickPixelIterator

Imagick::getPixelIterator

(PECL imagick 2, PECL imagick 3)

Imagick::getPixelIterator — Returns a MagickPixelIterator

说明

public Imagick::getPixelIterator ( ) : ImagickPixelIterator

Returns a MagickPixelIterator.

返回值

Returns an ImagickPixelIterator on success.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::getPixelIterator()

<?php
function getPixelIterator($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imageIterator = $imagick->getPixelIterator();

    foreach ($imageIterator as $row => $pixels) { /* Loop through pixel rows */
        foreach ($pixels as $column => $pixel) { /* Loop through the pixels in the row (columns) */
            /** @var $pixel \ImagickPixel */
            if ($column % 2) {
                $pixel->setColor("rgba(0, 0, 0, 0)"); /* Paint every second pixel black*/
            }
        }
        $imageIterator->syncIterator(); /* Sync the iterator, this is important to do on each iteration */
    }

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Get an ImagickPixelIterator for an image section

  • ? Imagick::getPixelIterator
  • Imagick::getPointSize ?
  • PHP Manual
  • Imagick
  • Get an ImagickPixelIterator for an image section

Imagick::getPixelRegionIterator

(PECL imagick 2, PECL imagick 3)

Imagick::getPixelRegionIterator — Get an ImagickPixelIterator for an image section

说明

public Imagick::getPixelRegionIterator ( int $x , int $y , int $columns , int $rows ) : ImagickPixelIterator

Get an ImagickPixelIterator for an image section.

参数

x

The x-coordinate of the region.

y

The y-coordinate of the region.

columns

The width of the region.

rows

The height of the region.

返回值

Returns an ImagickPixelIterator for an image section.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::getPixelRegionIterator() example

Iterate over the pixels in the top left of the image, changing them to be black.

<?php
$im = new Imagick(realpath("./testImage.png"));
$areaIterator = $im->getPixelRegionIterator(0, 0, 10, 10);

foreach ($areaIterator as $rowIterator) {
    foreach ($rowIterator as $pixel) {
        // Paint every pixel black
        $pixel->setColor("rgba(0, 0, 0, 0)");
    }
    $areaIterator->syncIterator();
}
$im->writeImage("./output.png");
?>


Gets point size

  • ? Imagick::getPixelRegionIterator
  • Imagick::getQuantum ?
  • PHP Manual
  • Imagick
  • Gets point size

Imagick::getPointSize

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::getPointSize — Gets point size

说明

public Imagick::getPointSize ( ) : float

Returns the objects point size property. 此方法在Imagick基于ImageMagick 6.3.7以上版本编译时可用。

返回值

Returns a float containing the point size.

参见

  • Imagick::setPointSize() - Sets point size


Description

  • ? Imagick::getPointSize
  • Imagick::getQuantumDepth ?
  • PHP Manual
  • Imagick
  • Description

Imagick::getQuantum

(PECL imagick 3 >= 3.3.0)

Imagick::getQuantum — Description

说明

public static Imagick::getQuantum ( ) : int

Returns the ImageMagick quantum range as an integer.

参数

此函数没有参数。

返回值


Gets the quantum depth

  • ? Imagick::getQuantum
  • Imagick::getQuantumRange ?
  • PHP Manual
  • Imagick
  • Gets the quantum depth

Imagick::getQuantumDepth

(PECL imagick 2, PECL imagick 3)

Imagick::getQuantumDepth — Gets the quantum depth

说明

public static Imagick::getQuantumDepth ( ) : array

Returns the Imagick quantum depth.

返回值

Returns an array with "quantumDepthLong" and "quantumDepthString" members.

错误／异常

错误时抛出 ImagickException。


Returns the Imagick quantum range

  • ? Imagick::getQuantumDepth
  • Imagick::getRegistry ?
  • PHP Manual
  • Imagick
  • Returns the Imagick quantum range

Imagick::getQuantumRange

(PECL imagick 2, PECL imagick 3)

Imagick::getQuantumRange — Returns the Imagick quantum range

说明

public static Imagick::getQuantumRange ( ) : array

Returns the quantum range for the Imagick instance.

返回值

Returns an associative array containing the quantum range as an int ("quantumRangeLong") and as a string ("quantumRangeString").

错误／异常

错误时抛出 ImagickException。


Description

  • ? Imagick::getQuantumRange
  • Imagick::getReleaseDate ?
  • PHP Manual
  • Imagick
  • Description

Imagick::getRegistry

(PECL imagick 3 >= 3.3.0)

Imagick::getRegistry — Description

说明

public static Imagick::getRegistry ( string $key ) : string

Get the StringRegistry entry for the named key or false if not set.

参数

key

The entry to get.

返回值


Returns the ImageMagick release date

  • ? Imagick::getRegistry
  • Imagick::getResource ?
  • PHP Manual
  • Imagick
  • Returns the ImageMagick release date

Imagick::getReleaseDate

(PECL imagick 2, PECL imagick 3)

Imagick::getReleaseDate — Returns the ImageMagick release date

说明

public static Imagick::getReleaseDate ( ) : string

Returns the ImageMagick release date as a string.

返回值

Returns the ImageMagick release date as a string.

错误／异常

错误时抛出 ImagickException。


Returns the specified resource's memory usage

  • ? Imagick::getReleaseDate
  • Imagick::getResourceLimit ?
  • PHP Manual
  • Imagick
  • Returns the specified resource's memory usage

Imagick::getResource

(PECL imagick 2, PECL imagick 3)

Imagick::getResource — Returns the specified resource's memory usage

说明

public static Imagick::getResource ( int $type ) : int

Returns the specified resource's memory usage in megabytes.

参数

type

Refer to the list of resourcetype constants.

返回值

Returns the specified resource's memory usage in megabytes.

错误／异常

错误时抛出 ImagickException。


Returns the specified resource limit

  • ? Imagick::getResource
  • Imagick::getSamplingFactors ?
  • PHP Manual
  • Imagick
  • Returns the specified resource limit

Imagick::getResourceLimit

(PECL imagick 2, PECL imagick 3)

Imagick::getResourceLimit — Returns the specified resource limit

说明

public static Imagick::getResourceLimit ( int $type ) : int

Returns the specified resource limit.

参数

type

One of the resourcetype constants. The unit depends on the type of the resource being limited.

返回值

Returns the specified resource limit in megabytes.

错误／异常

错误时抛出 ImagickException。

参见

  • Imagick::setResourceLimit() - Sets the limit for a particular resource


Gets the horizontal and vertical sampling factor

  • ? Imagick::getResourceLimit
  • Imagick::getSize ?
  • PHP Manual
  • Imagick
  • Gets the horizontal and vertical sampling factor

Imagick::getSamplingFactors

(PECL imagick 2, PECL imagick 3)

Imagick::getSamplingFactors — Gets the horizontal and vertical sampling factor

说明

public Imagick::getSamplingFactors ( ) : array

Gets the horizontal and vertical sampling factor.

返回值

Returns an associative array with the horizontal and vertical sampling factors of the image.

错误／异常

错误时抛出 ImagickException。


Returns the size associated with the Imagick object

  • ? Imagick::getSamplingFactors
  • Imagick::getSizeOffset ?
  • PHP Manual
  • Imagick
  • Returns the size associated with the Imagick object

Imagick::getSize

(PECL imagick 2, PECL imagick 3)

Imagick::getSize — Returns the size associated with the Imagick object

说明

public Imagick::getSize ( ) : array

Get the size in pixels associated with the Imagick object, previously set by Imagick::setSize().

Note:

This method just returns the size that was set using Imagick::setSize(). If you want to get the actual width / height of the image, use Imagick::getImageWidth() and Imagick::getImageHeight().

返回值

Returns the size associated with the Imagick object as an array with the keys "columns" and "rows".

范例

Example #1 Getting the size of a raw RGB image set at 200x400, after scaling to 400x800 (compared to width / height)

<?php
//Set size first and then load the raw image
$img = new Imagick();
$img->setSize(200, 400);
$img->readImage("image.rgb");

$img->scaleImage(400, 800);

$size = $img->getSize();
print_r($size);

echo "$img->getImageWidth()."x".$img->getImageHeight();
?>

以上例程会输出：

Array
(
    [columns] => 200
    [rows] => 400
)
400x800


Returns the size offset

  • ? Imagick::getSize
  • Imagick::getVersion ?
  • PHP Manual
  • Imagick
  • Returns the size offset

Imagick::getSizeOffset

(PECL imagick 2, PECL imagick 3)

Imagick::getSizeOffset — Returns the size offset

说明

public Imagick::getSizeOffset ( ) : int

Returns the size offset associated with the Imagick object. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

返回值

Returns the size offset associated with the Imagick object.

错误／异常

错误时抛出 ImagickException。


Returns the ImageMagick API version

  • ? Imagick::getSizeOffset
  • Imagick::haldClutImage ?
  • PHP Manual
  • Imagick
  • Returns the ImageMagick API version

Imagick::getVersion

(PECL imagick 2, PECL imagick 3)

Imagick::getVersion — Returns the ImageMagick API version

说明

public static Imagick::getVersion ( ) : array

Returns the ImageMagick API version as a string and as a number.

返回值

Returns the ImageMagick API version as a string and as a number.

错误／异常

错误时抛出 ImagickException。


Replaces colors in the image

  • ? Imagick::getVersion
  • Imagick::hasNextImage ?
  • PHP Manual
  • Imagick
  • Replaces colors in the image

Imagick::haldClutImage

(PECL imagick 3)

Imagick::haldClutImage — Replaces colors in the image

说明

public Imagick::haldClutImage ( Imagick $clut , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Replaces colors in the image using a Hald lookup table. Hald images can be created using HALD color coder.

参数

clut

Imagick object containing the Hald lookup image.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::haldClutImage()

<?php
function haldClutImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagickPalette = new \Imagick(realpath("images/hald/hald_8.png"));
    $imagickPalette->sepiatoneImage(55);
    $imagick->haldClutImage($imagickPalette);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Checks if the object has more images

  • ? Imagick::haldClutImage
  • Imagick::hasPreviousImage ?
  • PHP Manual
  • Imagick
  • Checks if the object has more images

Imagick::hasNextImage

(PECL imagick 2, PECL imagick 3)

Imagick::hasNextImage — Checks if the object has more images

说明

public Imagick::hasNextImage ( ) : bool

Returns true if the object has more images when traversing the list in the forward direction.

返回值

Returns true if the object has more images when traversing the list in the forward direction, returns false if there are none.


Checks if the object has a previous image

  • ? Imagick::hasNextImage
  • Imagick::identifyFormat ?
  • PHP Manual
  • Imagick
  • Checks if the object has a previous image

Imagick::hasPreviousImage

(PECL imagick 2, PECL imagick 3)

Imagick::hasPreviousImage — Checks if the object has a previous image

说明

public Imagick::hasPreviousImage ( ) : bool

Returns true if the object has more images when traversing the list in the reverse direction

返回值

Returns true if the object has more images when traversing the list in the reverse direction, returns false if there are none.


Description

  • ? Imagick::hasPreviousImage
  • Imagick::identifyImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::identifyFormat

(PECL imagick 3 >= 3.3.0)

Imagick::identifyFormat — Description

说明

public Imagick::identifyFormat ( string $embedText ) : string|false

Replaces any embedded formatting characters with the appropriate image property and returns the interpreted text. See http://www.imagemagick.org/script/escape.php for escape sequences.

参数

embedText

A string containing formatting sequences e.g. "Trim box: %@ number of unique colors: %k".

返回值

Returns format 或者在失败时返回 false.

范例

Example #1 Imagick::identifyFormat()

<?php
        $output = "Output of 'Trim box: %@ number of unique colors: %k' is: <br/>";
        $imagick = new \Imagick(realpath("./images/artifact/mask.png"));
        $output .= $imagick->identifyFormat("Trim box: %@ number of unique colors: %k");

?>


Identifies an image and fetches attributes

  • ? Imagick::identifyFormat
  • Imagick::implodeImage ?
  • PHP Manual
  • Imagick
  • Identifies an image and fetches attributes

Imagick::identifyImage

(PECL imagick 2, PECL imagick 3)

Imagick::identifyImage — Identifies an image and fetches attributes

说明

public Imagick::identifyImage ( bool $appendRawOutput = false ) : array

Identifies an image and returns the attributes. Attributes include the image width, height, size, and others.

参数

appendRawOutput

If true then the raw output is appended to the array.

返回值

Identifies an image and returns the attributes. Attributes include the image width, height, size, and others.

Example #1 Example Result Format

Array
(
    [imageName] => /some/path/image.jpg
    [format] => JPEG (Joint Photographic Experts Group JFIF format)
    [geometry] => Array
        (
            [width] => 90
            [height] => 90
        )

    [type] => TrueColor
    [colorSpace] => RGB
    [resolution] => Array
        (
            [x] => 300
            [y] => 300
        )

    [units] => PixelsPerInch
    [fileSize] => 1.88672kb
    [compression] => JPEG
    [signature] => 9a6dc8f604f97d0d691c0286176ddf992e188f0bebba98494b2146ee2d7118da
)

错误／异常

错误时抛出 ImagickException。


Creates a new image as a copy

  • ? Imagick::identifyImage
  • Imagick::importImagePixels ?
  • PHP Manual
  • Imagick
  • Creates a new image as a copy

Imagick::implodeImage

(PECL imagick 2, PECL imagick 3)

Imagick::implodeImage — Creates a new image as a copy

说明

public Imagick::implodeImage ( float $radius ) : bool

Creates a new image that is a copy of an existing one with the image pixels "imploded" by the specified percentage.

参数

radius

The radius of the implode

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::implodeImage()

<?php
function implodeImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->implodeImage(0.0001);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();

}

?>


Imports image pixels

  • ? Imagick::implodeImage
  • Imagick::inverseFourierTransformImage ?
  • PHP Manual
  • Imagick
  • Imports image pixels

Imagick::importImagePixels

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::importImagePixels — Imports image pixels

说明

public Imagick::importImagePixels ( int $x , int $y , int $width , int $height , string $map , int $storage , array $pixels ) : bool

Imports pixels from an array into an image. The map is usually 'RGB'. This method imposes the following constraints for the parameters: amount of pixels in the array must match width x height x length of the map. 此方法在Imagick基于ImageMagick 6.4.5以上版本编译时可用。

参数

x

The image x position

y

The image y position

width

The image width

height

The image height

map

Map of pixel ordering as a string. This can be for example RGB. The value can be any combination or order of R = red, G = green, B = blue, A = alpha (0 is transparent), O = opacity (0 is opaque), C = cyan, Y = yellow, M = magenta, K = black, I = intensity (for grayscale), P = pad.

storage

The pixel storage method. Refer to this list of pixel constants.

pixels

The array of pixels

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::importImagePixels() example

<?php

/* Generate array of pixels. 2000 pixels per color stripe */
$count = 2000 * 3;

$pixels =
   array_merge(array_pad(array(), $count, 0),
               array_pad(array(), $count, 255),
               array_pad(array(), $count, 0),
               array_pad(array(), $count, 255),
               array_pad(array(), $count, 0));

/* Width and height. The area is amount of pixels divided
   by three. Three comes from 'RGB', three values per pixel */
$width = $height = pow((count($pixels) / 3), 0.5);

/* Create empty image */
$im = new Imagick();
$im->newImage($width, $height, 'gray');

/* Import the pixels into image.
   width * height * strlen("RGB") must match count($pixels) */
$im->importImagePixels(0, 0, $width, $height, "RGB", Imagick::PIXEL_CHAR, $pixels);

/* output as jpeg image */
$im->setImageFormat('jpg');
header("Content-Type: image/jpg");
echo $im;

?>

以上例程的输出类似于：

Output of example : Imagick::importImagePixels()


Description

  • ? Imagick::importImagePixels
  • Imagick::labelImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::inverseFourierTransformImage

(PECL imagick 3 >= 3.3.0)

Imagick::inverseFourierTransformImage — Description

说明

public Imagick::inverseFourierTransformImage ( Imagick $complement , bool $magnitude ) : bool

Implements the inverse discrete Fourier transform (DFT) of the image either as a magnitude / phase or real / imaginary image pair.

Warning

本函数还未编写文档，仅有参数列表。

参数

complement

The second image to combine with this one to form either the magnitude / phase or real / imaginary image pair.

magnitude

If true, combine as magnitude / phase pair otherwise a real / imaginary image pair.

返回值

成功时返回 true。


Adds a label to an image

  • ? Imagick::inverseFourierTransformImage
  • Imagick::levelImage ?
  • PHP Manual
  • Imagick
  • Adds a label to an image

Imagick::labelImage

(PECL imagick 2, PECL imagick 3)

Imagick::labelImage — Adds a label to an image

说明

public Imagick::labelImage ( string $label ) : bool

Adds a label to an image.

参数

label

The label to add

返回值

成功时返回 true。


Adjusts the levels of an image

  • ? Imagick::labelImage
  • Imagick::linearStretchImage ?
  • PHP Manual
  • Imagick
  • Adjusts the levels of an image

Imagick::levelImage

(PECL imagick 2, PECL imagick 3)

Imagick::levelImage — Adjusts the levels of an image

说明

public Imagick::levelImage ( float $blackPoint , float $gamma , float $whitePoint , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Adjusts the levels of an image by scaling the colors falling between specified white and black points to the full available quantum range. The parameters provided represent the black, mid, and white points. The black point specifies the darkest color in the image. Colors darker than the black point are set to zero. Mid point specifies a gamma correction to apply to the image. White point specifies the lightest color in the image. Colors brighter than the white point are set to the maximum quantum value.

参数

blackPoint

The image black point

gamma

The gamma value

whitePoint

The image white point

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::levelImage()

<?php
function levelImage($blackPoint, $gamma, $whitePoint) {
    $imagick = new \Imagick();
    $imagick->newPseudoimage(500, 500, 'gradient:black-white');

    $imagick->setFormat('png');
    $quantum = $imagick->getQuantum();
    $imagick->levelImage($blackPoint / 100 , $gamma, $quantum * $whitePoint / 100);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Stretches with saturation the image intensity

  • ? Imagick::levelImage
  • Imagick::liquidRescaleImage ?
  • PHP Manual
  • Imagick
  • Stretches with saturation the image intensity

Imagick::linearStretchImage

(PECL imagick 2, PECL imagick 3)

Imagick::linearStretchImage — Stretches with saturation the image intensity

说明

public Imagick::linearStretchImage ( float $blackPoint , float $whitePoint ) : bool

Stretches with saturation the image intensity.

参数

blackPoint

The image black point

whitePoint

The image white point

返回值

成功时返回 true。

范例

Example #1 Imagick::linearStretchImage()

<?php
function linearStretchImage($imagePath, $blackThreshold, $whiteThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $pixels = $imagick->getImageWidth() * $imagick->getImageHeight();
    $imagick->linearStretchImage($blackThreshold * $pixels, $whiteThreshold * $pixels);

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Animates an image or images

  • ? Imagick::linearStretchImage
  • Imagick::listRegistry ?
  • PHP Manual
  • Imagick
  • Animates an image or images

Imagick::liquidRescaleImage

(PECL imagick 2 >= 2.2.0, PECL imagick 3)

Imagick::liquidRescaleImage — Animates an image or images

说明

public Imagick::liquidRescaleImage ( int $width , int $height , float $delta_x , float $rigidity ) : bool

This method scales the images using liquid rescaling method. This method is an implementation of a technique called seam carving. In order for this method to work as expected ImageMagick must be compiled with liblqr support. 此方法在Imagick基于ImageMagick 6.3.9以上版本编译时可用。

参数

width

The width of the target size

height

The height of the target size

delta_x

How much the seam can traverse on x-axis. Passing 0 causes the seams to be straight.

rigidity

Introduces a bias for non-straight seams. This parameter is typically 0.

返回值

成功时返回 true。

参见

  • Imagick::resizeImage() - Scales an image


Description

  • ? Imagick::liquidRescaleImage
  • Imagick::magnifyImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::listRegistry

(PECL imagick 3 >= 3.3.0)

Imagick::listRegistry — Description

说明

public static Imagick::listRegistry ( ) : array

List all the registry settings. Returns an array of all the key/value pairs in the registry

参数

此函数没有参数。

返回值

An array containing the key/values from the registry.


Scales an image proportionally 2x

  • ? Imagick::listRegistry
  • Imagick::mapImage ?
  • PHP Manual
  • Imagick
  • Scales an image proportionally 2x

Imagick::magnifyImage

(PECL imagick 2, PECL imagick 3)

Imagick::magnifyImage — Scales an image proportionally 2x

说明

public Imagick::magnifyImage ( ) : bool

Is a convenience method that scales an image proportionally to twice its original size.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::magnifyImage()

<?php
function magnifyImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->magnifyImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Replaces the colors of an image with the closest color from a reference image

  • ? Imagick::magnifyImage
  • Imagick::matteFloodfillImage ?
  • PHP Manual
  • Imagick
  • Replaces the colors of an image with the closest color from a reference image

Imagick::mapImage

(PECL imagick 2, PECL imagick 3)

Imagick::mapImage — Replaces the colors of an image with the closest color from a reference image

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::mapImage ( Imagick $map , bool $dither ) : bool

参数

map

dither

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Changes the transparency value of a color

  • ? Imagick::mapImage
  • Imagick::medianFilterImage ?
  • PHP Manual
  • Imagick
  • Changes the transparency value of a color

Imagick::matteFloodfillImage

(PECL imagick 2, PECL imagick 3)

Imagick::matteFloodfillImage — Changes the transparency value of a color

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::matteFloodfillImage ( float $alpha , float $fuzz , mixed $bordercolor , int $x , int $y ) : bool

Changes the transparency value of any pixel that matches target and is an immediate neighbor. If the method FillToBorderMethod is specified, the transparency value is changed for any neighbor pixel that does not match the bordercolor member of image.

参数

alpha

The level of transparency: 1.0 is fully opaque and 0.0 is fully transparent.

fuzz

The fuzz member of image defines how much tolerance is acceptable to consider two colors as the same.

bordercolor

An ImagickPixel object or string representing the border color.

x

The starting x coordinate of the operation.

y

The starting y coordinate of the operation.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the third parameter. Previous versions allow only an ImagickPixel object.


Applies a digital filter

  • ? Imagick::matteFloodfillImage
  • Imagick::mergeImageLayers ?
  • PHP Manual
  • Imagick
  • Applies a digital filter

Imagick::medianFilterImage

(PECL imagick 2, PECL imagick 3)

Imagick::medianFilterImage — Applies a digital filter

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::medianFilterImage ( float $radius ) : bool

Applies a digital filter that improves the quality of a noisy image. Each pixel is replaced by the median in a set of neighboring pixels as defined by radius.

参数

radius

The radius of the pixel neighborhood.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::medianFilterImage()

<?php
function medianFilterImage($radius, $imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    @$imagick->medianFilterImage($radius);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Merges image layers

  • ? Imagick::medianFilterImage
  • Imagick::minifyImage ?
  • PHP Manual
  • Imagick
  • Merges image layers

Imagick::mergeImageLayers

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::mergeImageLayers — Merges image layers

说明

public Imagick::mergeImageLayers ( int $layer_method ) : Imagick

Merges image layers into one. This method is useful when working with image formats that use multiple layers such as PSD. The merging is controlled using the layer_method which defines how the layers are merged. 此方法在Imagick基于ImageMagick 6.3.7以上版本编译时可用。

参数

layer_method

One of the Imagick::LAYERMETHOD_* constants

返回值

Returns an Imagick object containing the merged image.

错误／异常

错误时抛出 ImagickException。

参见

  • Imagick::flattenImages() - Merges a sequence of images

范例

Example #1 Imagick::mergeImageLayers()

<?php
function mergeImageLayers($layerMethodType, $imagePath1, $imagePath2) {

    $imagick = new \Imagick(realpath($imagePath));

    $imagick2 = new \Imagick(realpath($imagePath2));
    $imagick->addImage($imagick2);
    $imagick->setImageFormat('png');

    $result = $imagick->mergeImageLayers($layerMethodType);
    header("Content-Type: image/png");
    echo $result->getImageBlob();
}

?>


Scales an image proportionally to half its size

  • ? Imagick::mergeImageLayers
  • Imagick::modulateImage ?
  • PHP Manual
  • Imagick
  • Scales an image proportionally to half its size

Imagick::minifyImage

(PECL imagick 2, PECL imagick 3)

Imagick::minifyImage — Scales an image proportionally to half its size

说明

public Imagick::minifyImage ( ) : bool

Is a convenience method that scales an image proportionally to one-half its original size

返回值

成功时返回 true。


Control the brightness, saturation, and hue

  • ? Imagick::minifyImage
  • Imagick::montageImage ?
  • PHP Manual
  • Imagick
  • Control the brightness, saturation, and hue

Imagick::modulateImage

(PECL imagick 2, PECL imagick 3)

Imagick::modulateImage — Control the brightness, saturation, and hue

说明

public Imagick::modulateImage ( float $brightness , float $saturation , float $hue ) : bool

Lets you control the brightness, saturation, and hue of an image. Hue is the percentage of absolute rotation from the current position. For example 50 results in a counter-clockwise rotation of 90 degrees, 150 results in a clockwise rotation of 90 degrees, with 0 and 200 both resulting in a rotation of 180 degrees.

参数

brightness

saturation

hue

返回值

成功时返回 true。

范例

Example #1 Imagick::modulateImage()

<?php
function modulateImage($imagePath, $hue, $brightness, $saturation) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->modulateImage($brightness, $saturation, $hue);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Creates a composite image

  • ? Imagick::modulateImage
  • Imagick::morphImages ?
  • PHP Manual
  • Imagick
  • Creates a composite image

Imagick::montageImage

(PECL imagick 2, PECL imagick 3)

Imagick::montageImage — Creates a composite image

说明

public Imagick::montageImage ( ImagickDraw $draw , string $tile_geometry , string $thumbnail_geometry , int $mode , string $frame ) : Imagick

Creates a composite image by combining several separate images. The images are tiled on the composite image with the name of the image optionally appearing just below the individual tile.

参数

draw

The font name, size, and color are obtained from this object.

tile_geometry

The number of tiles per row and page (e.g. 6x4+0+0).

thumbnail_geometry

Preferred image size and border size of each thumbnail (e.g. 120x120+4+3>).

mode

Thumbnail framing mode, see Montage Mode constants.

frame

Surround the image with an ornamental border (e.g. 15x15+3+3). The frame color is that of the thumbnail's matte color.

返回值

成功时返回 true。


Method morphs a set of images

  • ? Imagick::montageImage
  • Imagick::morphology ?
  • PHP Manual
  • Imagick
  • Method morphs a set of images

Imagick::morphImages

(PECL imagick 2, PECL imagick 3)

Imagick::morphImages — Method morphs a set of images

说明

public Imagick::morphImages ( int $number_frames ) : Imagick

Method morphs a set of images. Both the image pixels and size are linearly interpolated to give the appearance of a meta-morphosis from one image to the next.

参数

number_frames

The number of in-between images to generate.

返回值

This method returns a new Imagick object on success. 错误时抛出 ImagickException。


Description

  • ? Imagick::morphImages
  • Imagick::mosaicImages ?
  • PHP Manual
  • Imagick
  • Description

Imagick::morphology

(PECL imagick 3 >= 3.3.0)

Imagick::morphology — Description

说明

public Imagick::morphology ( int $morphologyMethod , int $iterations , ImagickKernel $ImagickKernel , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Applies a user supplied kernel to the image according to the given morphology method.

参数

morphologyMethod

Which morphology method to use one of the \Imagick::MORPHOLOGY_* constants.

iterations

The number of iteration to apply the morphology function. A value of -1 means loop until no change found. How this is applied may depend on the morphology method. Typically this is a value of 1.

ImagickKernel

channel

返回值

成功时返回 true。

范例

Example #1 Convolve Imagick::morphology()

<?php
        $imagick = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_GAUSSIAN, "5,1");
        $imagick->morphology(\Imagick::MORPHOLOGY_CONVOLVE, 2, $kernel);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();

?>

Example #2 Correlate Imagick::morphology()

<?php

        // Top-left pixel must be black
        // Bottom right pixel must be white
        // We don't care about the rest.

        $imagick = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromMatrix(self::$correlateMatrix, [2, 2]);
        $imagick->morphology(\Imagick::MORPHOLOGY_CORRELATE, 1, $kernel);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();

?>

Example #3 Erode Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_ERODE, 2, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #4 Erode Intensity Imagick::morphology()

<?php
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "1");
        $canvas->morphology(\Imagick::MORPHOLOGY_ERODE_INTENSITY, 2, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #5 Dilate Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_DILATE, 4, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #6 Dilate intensity Imagick::morphology()

<?php
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "1");
        $canvas->morphology(\Imagick::MORPHOLOGY_DILATE_INTENSITY, 4, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #7 Distance with Chebyshev kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_CHEBYSHEV, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #8 Distance with Manhattan kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_MANHATTAN, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #9 Distance with ocatagonal kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGONAL, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #10 Distance with Euclidean kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_EUCLIDEAN, "4");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #11 Edge Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #12 Open Imagick::morphology()

<?php
        // As a result you will see that 'Open' smoothed the outline, by rounding off any sharp points, and remove any parts that is smaller than the shape used. It will also disconnect or 'open' any thin bridges.
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_OPEN, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #13 Open intensity Imagick::morphology()

<?php
        // As a result you will see that 'Open' smoothed the outline, by rounding off any sharp points, and remove any parts that is smaller than the shape used. It will also disconnect or 'open' any thin bridges.

        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_OPEN_INTENSITY, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #14 Close Imagick::morphology()

<?php
        //The basic use of the 'Close' method is to reduce or remove any 'holes' or 'gaps' about the size of the kernel 'Structure Element'. That is 'close' parts of the background that are about that size.
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #15 Close Intensity Imagick::morphology()

<?php
        //The basic use of the 'Close' method is to reduce or remove any 'holes' or 'gaps' about the size of the kernel 'Structure Element'. That is 'close' parts of the background that are about that size.
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE_INTENSITY, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #16 Smooth Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_SMOOTH, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #17 Edge in Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE_IN, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #18 Edge out Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE_OUT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #19 The 'TopHat' method, or more specifically 'White Top Hat', returns the pixels that were removed by a Opening of the shape, that is the pixels that were removed to round off the points, and the connecting bridged between shapes. Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_TOP_HAT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #20 The 'BottomHat' method, also known as 'Black TopHat' is the pixels that a Closing of the shape adds to the image. That is the pixels that were used to fill in the 'holes', 'gaps', and 'bridges'. Imagick::morphology()

<?php

        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_BOTTOM_HAT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #21 Hit and Miss Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        //This finds all the pixels with 3 pixels of the right edge
        $matrix = [[1, false, false, 0]];
        $kernel = \ImagickKernel::fromMatrix(
            $matrix,
            [0, 0]
        );
        $canvas->morphology(\Imagick::MORPHOLOGY_HIT_AND_MISS, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #22 Thinning Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $leftEdgeKernel = \ImagickKernel::fromMatrix([[0, 1]], [1, 0]);
        $rightEdgeKernel = \ImagickKernel::fromMatrix([[1, 0]], [0, 0]);
        $leftEdgeKernel->addKernel($rightEdgeKernel);

        $canvas->morphology(\Imagick::MORPHOLOGY_THINNING, 3, $leftEdgeKernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #23 Thicken Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $leftEdgeKernel = \ImagickKernel::fromMatrix([[0, 1]], [1, 0]);
        $rightEdgeKernel = \ImagickKernel::fromMatrix([[1, 0]], [0, 0]);
        $leftEdgeKernel->addKernel($rightEdgeKernel);

        $canvas->morphology(\Imagick::MORPHOLOGY_THICKEN, 3, $leftEdgeKernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #24 Thick to generate a convex hull Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $diamondKernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DIAMOND, "1");
        $convexKernel =  \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_CONVEX_HULL, "");

        // The thicken morphology doesn't handle small gaps. We close them
        // with the close morphology.
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $diamondKernel);
        $canvas->morphology(\Imagick::MORPHOLOGY_THICKEN, -1, $convexKernel);
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $diamondKernel);

        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #25 Iterative morphology Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "2");
        $canvas->morphology(\Imagick::MORPHOLOGY_ITERATIVE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Example #26 Helper functon to get an image silhouette Imagick::morphology()

<?php
    private function getCharacterOutline() {

        $imagick = new \Imagick(realpath("./images/character.png"));
        $character = new \Imagick();
        $character->newPseudoImage(
            $imagick->getImageWidth(),
            $imagick->getImageHeight(),
            "canvas:white"
        );
        $canvas = new \Imagick();
        $canvas->newPseudoImage(
            $imagick->getImageWidth(),
            $imagick->getImageHeight(),
            "canvas:black"
        );

        $character->compositeimage(
            $imagick,
            \Imagick::COMPOSITE_COPYOPACITY,
            0, 0
        );
        $canvas->compositeimage(
            $character,
            \Imagick::COMPOSITE_ATOP,
            0, 0
        );
        $canvas->setFormat('png');

        return $canvas;
    }

?>


Forms a mosaic from images

  • ? Imagick::morphology
  • Imagick::motionBlurImage ?
  • PHP Manual
  • Imagick
  • Forms a mosaic from images

Imagick::mosaicImages

(PECL imagick 2, PECL imagick 3)

Imagick::mosaicImages — Forms a mosaic from images

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::mosaicImages ( ) : Imagick

Inlays an image sequence to form a single coherent picture. It returns a wand with each image in the sequence composited at the location defined by the page offset of the image.

返回值

成功时返回 true。


Simulates motion blur

  • ? Imagick::mosaicImages
  • Imagick::negateImage ?
  • PHP Manual
  • Imagick
  • Simulates motion blur

Imagick::motionBlurImage

(PECL imagick 2, PECL imagick 3)

Imagick::motionBlurImage — Simulates motion blur

说明

public Imagick::motionBlurImage ( float $radius , float $sigma , float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Simulates motion blur. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and MotionBlurImage() selects a suitable radius for you. Angle gives the angle of the blurring motion.

参数

radius

The radius of the Gaussian, in pixels, not counting the center pixel.

sigma

The standard deviation of the Gaussian, in pixels.

angle

Apply the effect along this angle.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants. The channel argument affects only if Imagick is compiled against ImageMagick version 6.4.4 or greater.

返回值

成功时返回 true。

范例

Example #1 Imagick::motionBlurImage()

<?php
function motionBlurImage($imagePath, $radius, $sigma, $angle, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->motionBlurImage($radius, $sigma, $angle, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Negates the colors in the reference image

  • ? Imagick::motionBlurImage
  • Imagick::newImage ?
  • PHP Manual
  • Imagick
  • Negates the colors in the reference image

Imagick::negateImage

(PECL imagick 2, PECL imagick 3)

Imagick::negateImage — Negates the colors in the reference image

说明

public Imagick::negateImage ( bool $gray , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Negates the colors in the reference image. The Grayscale option means that only grayscale values within the image are negated.

参数

gray

Whether to only negate grayscale pixels within the image.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::negateImage()

<?php
function negateImage($imagePath, $grayOnly, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->negateImage($grayOnly, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


创建一张图片

  • ? Imagick::negateImage
  • Imagick::newPseudoImage ?
  • PHP Manual
  • Imagick
  • 创建一张图片

Imagick::newImage

(PECL imagick 2, PECL imagick 3)

Imagick::newImage — 创建一张图片

说明

Imagick::newImage ( int $cols , int $rows , mixed $background , string $format = ? ) : bool

创建一个 Imagick 图片对象，同时可以附带设置一个 ImagickPixel 值作为其背景色。

参数

cols

新建图片对象列的值（宽多少像素）

rows

新建图片对象行的值（高多少像素）

background

新建图片独享的背景色

format

图片格式。这个参数是在 Imagick 2.0.1 版本添加的。

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
2.1.0 | 现在可以似乎用了一个字符串作为颜色传入第三个参数。在此之前的版本只允许以一个 ImagickPixel 对象的形式传入。

范例

Example #1 Using Imagick::newImage():

Create a new image and display it.

<?php

$image = new Imagick();
$image->newImage(100, 100, new ImagickPixel('red'));
$image->setImageFormat('png');

header('Content-type: image/png');
echo $image;

?>


Creates a new image

  • ? Imagick::newImage
  • Imagick::nextImage ?
  • PHP Manual
  • Imagick
  • Creates a new image

Imagick::newPseudoImage

(PECL imagick 2, PECL imagick 3)

Imagick::newPseudoImage — Creates a new image

说明

public Imagick::newPseudoImage ( int $columns , int $rows , string $pseudoString ) : bool

Creates a new image using ImageMagick pseudo-formats.

参数

columns

columns in the new image

rows

rows in the new image

pseudoString

string containing pseudo image definition.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::newPseudoImage()

<?php
function newPseudoImage($canvasType) {
    $imagick = new \Imagick();
    $imagick->newPseudoImage(300, 300, $canvasType);
    $imagick->setImageFormat("png");
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

//newPseudoImage('gradient:red-rgba(64, 255, 255, 0.5)');
//newPseudoImage("radial-gradient:red-blue");
newPseudoImage("plasma:fractal");

?>


Moves to the next image

  • ? Imagick::newPseudoImage
  • Imagick::normalizeImage ?
  • PHP Manual
  • Imagick
  • Moves to the next image

Imagick::nextImage

(PECL imagick 2, PECL imagick 3)

Imagick::nextImage — Moves to the next image

说明

public Imagick::nextImage ( ) : bool

Associates the next image in the image list with an Imagick object.

返回值

成功时返回 true。


Enhances the contrast of a color image

  • ? Imagick::nextImage
  • Imagick::oilPaintImage ?
  • PHP Manual
  • Imagick
  • Enhances the contrast of a color image

Imagick::normalizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::normalizeImage — Enhances the contrast of a color image

说明

public Imagick::normalizeImage ( int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Enhances the contrast of a color image by adjusting the pixels color to span the entire range of colors available.

参数

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

范例

Example #1 Imagick::normalizeImage()

<?php
function normalizeImage($imagePath, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $original = clone $imagick;
    $original->cropimage($original->getImageWidth() / 2, $original->getImageHeight(), 0, 0);
    $imagick->normalizeImage($channel);
    $imagick->compositeimage($original, \Imagick::COMPOSITE_ATOP, 0, 0);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Simulates an oil painting

  • ? Imagick::normalizeImage
  • Imagick::opaquePaintImage ?
  • PHP Manual
  • Imagick
  • Simulates an oil painting

Imagick::oilPaintImage

(PECL imagick 2, PECL imagick 3)

Imagick::oilPaintImage — Simulates an oil painting

说明

public Imagick::oilPaintImage ( float $radius ) : bool

Applies a special effect filter that simulates an oil painting. Each pixel is replaced by the most frequent color occurring in a circular region defined by radius.

参数

radius

The radius of the circular neighborhood.

返回值

成功时返回 true。

范例

Example #1 Imagick::oilPaintImage()

<?php
function oilPaintImage($imagePath, $radius) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->oilPaintImage($radius);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Changes the color value of any pixel that matches target

  • ? Imagick::oilPaintImage
  • Imagick::optimizeImageLayers ?
  • PHP Manual
  • Imagick
  • Changes the color value of any pixel that matches target

Imagick::opaquePaintImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::opaquePaintImage — Changes the color value of any pixel that matches target

说明

public Imagick::opaquePaintImage ( mixed $target , mixed $fill , float $fuzz , bool $invert , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Changes any pixel that matches color with the color defined by fill. 此方法在Imagick基于ImageMagick 6.3.8以上版本编译时可用。

参数

target

ImagickPixel object or a string containing the color to change

fill

The replacement color

fuzz

The amount of fuzz. For example, set fuzz to 10 and the color red at intensities of 100 and 102 respectively are now interpreted as the same color.

invert

If true paints any pixel that does not match the target color.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。


Removes repeated portions of images to optimize

  • ? Imagick::opaquePaintImage
  • Imagick::orderedPosterizeImage ?
  • PHP Manual
  • Imagick
  • Removes repeated portions of images to optimize

Imagick::optimizeImageLayers

(PECL imagick 2, PECL imagick 3)

Imagick::optimizeImageLayers — Removes repeated portions of images to optimize

说明

public Imagick::optimizeImageLayers ( ) : bool

Compares each image the GIF disposed forms of the previous image in the sequence. From this it attempts to select the smallest cropped image to replace each frame, while preserving the results of the animation. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::optimizeImageLayers()

Reading, optimizing and writing a GIF image

<?php
/* create new imagick object */
$im = new Imagick("test.gif");

/* optimize the image layers */
$im->optimizeImageLayers();

/* write the image back */
$im->writeImages("test_optimized.gif", true);
?>

参见

  • Imagick::compareImageLayers() - Returns the maximum bounding region between images
  • Imagick::writeImages() - Writes an image or image sequence
  • Imagick::writeImage() - 把图片写入指定的文件


Performs an ordered dither

  • ? Imagick::optimizeImageLayers
  • Imagick::paintFloodfillImage ?
  • PHP Manual
  • Imagick
  • Performs an ordered dither

Imagick::orderedPosterizeImage

(PECL imagick 2 >= 2.2.2, PECL imagick 3)

Imagick::orderedPosterizeImage — Performs an ordered dither

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::orderedPosterizeImage ( string $threshold_map , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Performs an ordered dither based on a number of pre-defined dithering threshold maps, but over multiple intensity levels, which can be different for different channels, according to the input arguments. 此方法在Imagick基于ImageMagick 6.3.1以上版本编译时可用。

参数

threshold_map

A string containing the name of the threshold dither map to use

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::orderedPosterizeImage()

<?php
function orderedPosterizeImage($imagePath, $orderedPosterizeType) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->orderedPosterizeImage($orderedPosterizeType);
    $imagick->setImageFormat('png');

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

//orderedPosterizeImage($imagePath, 'o4x4,3,3');
//orderedPosterizeImage($imagePath, 'o8x8,6,6');
orderedPosterizeImage($imagePath, 'h8x8a');

?>


Changes the color value of any pixel that matches target

  • ? Imagick::orderedPosterizeImage
  • Imagick::paintOpaqueImage ?
  • PHP Manual
  • Imagick
  • Changes the color value of any pixel that matches target

Imagick::paintFloodfillImage

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::paintFloodfillImage — Changes the color value of any pixel that matches target

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::paintFloodfillImage ( mixed $fill , float $fuzz , mixed $bordercolor , int $x , int $y , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Changes the color value of any pixel that matches target and is an immediate neighbor. As of ImageMagick 6.3.8 this method has been deprecated and Imagick::floodfillPaintImage() should be used instead.

参数

fill

ImagickPixel object or a string containing the fill color

fuzz

The amount of fuzz. For example, set fuzz to 10 and the color red at intensities of 100 and 102 respectively are now interpreted as the same color for the purposes of the floodfill.

bordercolor

ImagickPixel object or a string containing the border color

x

X start position of the floodfill

y

Y start position of the floodfill

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。


Change any pixel that matches color

  • ? Imagick::paintFloodfillImage
  • Imagick::paintTransparentImage ?
  • PHP Manual
  • Imagick
  • Change any pixel that matches color

Imagick::paintOpaqueImage

(PECL imagick 2, PECL imagick 3)

Imagick::paintOpaqueImage — Change any pixel that matches color

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::paintOpaqueImage ( mixed $target , mixed $fill , float $fuzz , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Changes any pixel that matches color with the color defined by fill.

参数

target

Change this target color to the fill color within the image. An ImagickPixel object or a string representing the target color.

fill

An ImagickPixel object or a string representing the fill color.

fuzz

The fuzz member of image defines how much tolerance is acceptable to consider two colors as the same.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as first and second parameter. Previous versions allow only an ImagickPixel object.


Changes any pixel that matches color with the color defined by fill

  • ? Imagick::paintOpaqueImage
  • Imagick::pingImage ?
  • PHP Manual
  • Imagick
  • Changes any pixel that matches color with the color defined by fill

Imagick::paintTransparentImage

(PECL imagick 2, PECL imagick 3)

Imagick::paintTransparentImage — Changes any pixel that matches color with the color defined by fill

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::paintTransparentImage ( mixed $target , float $alpha , float $fuzz ) : bool

Changes any pixel that matches color with the color defined by fill.

参数

target

Change this target color to specified opacity value within the image.

alpha

The level of transparency: 1.0 is fully opaque and 0.0 is fully transparent.

fuzz

The fuzz member of image defines how much tolerance is acceptable to consider two colors as the same.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the first parameter. Previous versions allow only an ImagickPixel object.


Fetch basic attributes about the image

  • ? Imagick::paintTransparentImage
  • Imagick::pingImageBlob ?
  • PHP Manual
  • Imagick
  • Fetch basic attributes about the image

Imagick::pingImage

(PECL imagick 2, PECL imagick 3)

Imagick::pingImage — Fetch basic attributes about the image

说明

public Imagick::pingImage ( string $filename ) : bool

This method can be used to query image width, height, size, and format without reading the whole image in to memory.

参数

filename

The filename to read the information from.

返回值

成功时返回 true。


Quickly fetch attributes

  • ? Imagick::pingImage
  • Imagick::pingImageFile ?
  • PHP Manual
  • Imagick
  • Quickly fetch attributes

Imagick::pingImageBlob

(PECL imagick 2, PECL imagick 3)

Imagick::pingImageBlob — Quickly fetch attributes

说明

public Imagick::pingImageBlob ( string $image ) : bool

This method can be used to query image width, height, size, and format without reading the whole image to memory. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

image

A string containing the image.

返回值

成功时返回 true。

范例

Example #1 Using Imagick::pingImageBlob()

Pinging an image from a string

<?php
/* read image contents */
$image = file_get_contents("test.jpg");

/* create new imagick object */
$im = new Imagick();

/* pass the string to the imagick object */
$im->pingImageBlob($image);

/* output image width and height */
echo $im->getImageWidth() . 'x' . $im->getImageHeight();
?>

参见

  • Imagick::pingImage() - Fetch basic attributes about the image
  • Imagick::pingImageFile() - Get basic image attributes in a lightweight manner
  • Imagick::readImage() - Reads image from filename
  • Imagick::readImageBlob() - 从二进制字符串里读取图片
  • Imagick::readImageFile() - Reads image from open filehandle


Get basic image attributes in a lightweight manner

  • ? Imagick::pingImageBlob
  • Imagick::polaroidImage ?
  • PHP Manual
  • Imagick
  • Get basic image attributes in a lightweight manner

Imagick::pingImageFile

(PECL imagick 2, PECL imagick 3)

Imagick::pingImageFile — Get basic image attributes in a lightweight manner

说明

public Imagick::pingImageFile ( resource $filehandle , string $fileName = ? ) : bool

This method can be used to query image width, height, size, and format without reading the whole image to memory. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

filehandle

An open filehandle to the image.

fileName

Optional filename for this image.

返回值

成功时返回 true。

范例

Example #1 Using Imagick::pingImageFile()

Opening a remote location

<?php
/* fopen a remote location */
$fp = fopen("http://example.com/test.jpg");

/* create new imagick object */
$im = new Imagick();

/* pass the handle to imagick */
$im->pingImageFile($fp);
?>

参见

  • Imagick::pingImage() - Fetch basic attributes about the image
  • Imagick::pingImageBlob() - Quickly fetch attributes
  • Imagick::readImage() - Reads image from filename
  • Imagick::readImageBlob() - 从二进制字符串里读取图片
  • Imagick::readImageFile() - Reads image from open filehandle


Simulates a Polaroid picture

  • ? Imagick::pingImageFile
  • Imagick::posterizeImage ?
  • PHP Manual
  • Imagick
  • Simulates a Polaroid picture

Imagick::polaroidImage

(PECL imagick 2, PECL imagick 3)

Imagick::polaroidImage — Simulates a Polaroid picture

说明

public Imagick::polaroidImage ( ImagickDraw $properties , float $angle ) : bool

Simulates a Polaroid picture. 此方法在Imagick基于ImageMagick 6.3.2以上版本编译时可用。

参数

properties

The polaroid properties

angle

The polaroid angle

返回值

成功时返回 true。

范例

Example #1 A Imagick::polaroidImage() example

An example of using Imagick::polaroidImage()

<?php
/* Create the object */
$image = new Imagick('source.png');

/* Set the opacity */
$image->polaroidImage(new ImagickDraw(), 25);

/* output the image */
header('Content-type: image/png');
echo $image;

?>


Reduces the image to a limited number of color level

  • ? Imagick::polaroidImage
  • Imagick::previewImages ?
  • PHP Manual
  • Imagick
  • Reduces the image to a limited number of color level

Imagick::posterizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::posterizeImage — Reduces the image to a limited number of color level

说明

public Imagick::posterizeImage ( int $levels , bool $dither ) : bool

Reduces the image to a limited number of color level.

参数

levels

dither

返回值

成功时返回 true。

范例

Example #1 Imagick::posterizeImage()

<?php
function posterizeImage($imagePath, $posterizeType, $numberLevels) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->posterizeImage($numberLevels, $posterizeType);
    $imagick->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

posterizeImage($imagePath, \Imagick::DITHERMETHOD_RIEMERSMA, 8);

?>


Quickly pin-point appropriate parameters for image processing

  • ? Imagick::posterizeImage
  • Imagick::previousImage ?
  • PHP Manual
  • Imagick
  • Quickly pin-point appropriate parameters for image processing

Imagick::previewImages

(PECL imagick 2, PECL imagick 3)

Imagick::previewImages — Quickly pin-point appropriate parameters for image processing

说明

public Imagick::previewImages ( int $preview ) : bool

Tiles 9 thumbnails of the specified image with an image processing operation applied at varying strengths. This is helpful to quickly pin-point an appropriate parameter for an image processing operation.

参数

preview

Preview type. See Preview type constants

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Move to the previous image in the object

  • ? Imagick::previewImages
  • Imagick::profileImage ?
  • PHP Manual
  • Imagick
  • Move to the previous image in the object

Imagick::previousImage

(PECL imagick 2, PECL imagick 3)

Imagick::previousImage — Move to the previous image in the object

说明

public Imagick::previousImage ( ) : bool

Assocates the previous image in an image list with the Imagick object.

返回值

成功时返回 true。


Adds or removes a profile from an image

  • ? Imagick::previousImage
  • Imagick::quantizeImage ?
  • PHP Manual
  • Imagick
  • Adds or removes a profile from an image

Imagick::profileImage

(PECL imagick 2, PECL imagick 3)

Imagick::profileImage — Adds or removes a profile from an image

说明

public Imagick::profileImage ( string $name , string $profile ) : bool

Adds or removes a ICC, IPTC, or generic profile from an image. If the profile is NULL, it is removed from the image otherwise added. Use a name of '*' and a profile of NULL to remove all profiles from the image.

参数

name

profile

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Analyzes the colors within a reference image

  • ? Imagick::profileImage
  • Imagick::quantizeImages ?
  • PHP Manual
  • Imagick
  • Analyzes the colors within a reference image

Imagick::quantizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::quantizeImage — Analyzes the colors within a reference image

说明

public Imagick::quantizeImage ( int $numberColors , int $colorspace , int $treedepth , bool $dither , bool $measureError ) : bool

参数

numberColors

colorspace

treedepth

dither

measureError

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::quantizeImage()

<?php
function quantizeImage($imagePath, $numberColors, $colorSpace, $treeDepth, $dither) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->quantizeImage($numberColors, $colorSpace, $treeDepth, $dither, false);
    $imagick->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Analyzes the colors within a sequence of images

  • ? Imagick::quantizeImage
  • Imagick::queryFontMetrics ?
  • PHP Manual
  • Imagick
  • Analyzes the colors within a sequence of images

Imagick::quantizeImages

(PECL imagick 2, PECL imagick 3)

Imagick::quantizeImages — Analyzes the colors within a sequence of images

说明

public Imagick::quantizeImages ( int $numberColors , int $colorspace , int $treedepth , bool $dither , bool $measureError ) : bool

参数

numberColors

colorspace

treedepth

dither

measureError

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Returns an array representing the font metrics

  • ? Imagick::quantizeImages
  • Imagick::queryFonts ?
  • PHP Manual
  • Imagick
  • Returns an array representing the font metrics

Imagick::queryFontMetrics

(PECL imagick 2, PECL imagick 3)

Imagick::queryFontMetrics — Returns an array representing the font metrics

说明

public Imagick::queryFontMetrics ( ImagickDraw $properties , string $text , bool $multiline = ? ) : array

Returns a multi-dimensional array representing the font metrics.

参数

properties

ImagickDraw object containing font properties

text

The text

multiline

Multiline parameter. If left empty it is autodetected

返回值

Returns a multi-dimensional array representing the font metrics.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::queryFontMetrics():

Query the metrics for the text and dump the results on the screen.

<?php
/* Create a new Imagick object */
$im = new Imagick();

/* Create an ImagickDraw object */
$draw = new ImagickDraw();

/* Set the font */
$draw->setFont('/path/to/font.ttf');

/* Dump the font metrics, autodetect multiline */
var_dump($im->queryFontMetrics($draw, "Hello World!"));
?>


Returns the configured fonts

  • ? Imagick::queryFontMetrics
  • Imagick::queryFormats ?
  • PHP Manual
  • Imagick
  • Returns the configured fonts

Imagick::queryFonts

(PECL imagick 2, PECL imagick 3)

Imagick::queryFonts — Returns the configured fonts

说明

public static Imagick::queryFonts ( string $pattern = "*" ) : array

Returns the configured fonts.

参数

pattern

The query pattern

返回值

Returns an array containing the configured fonts.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::queryFonts()

<?php
        $output = '';
        $output .= "Fonts that match 'Helvetica*' are:<br/>";

        $fontList = \Imagick::queryFonts("Helvetica*");

        foreach ($fontList as $fontName) {
            $output .= '<li>'. $fontName."</li>";
        }

        return $output;

?>


Returns formats supported by Imagick

  • ? Imagick::queryFonts
  • Imagick::radialBlurImage ?
  • PHP Manual
  • Imagick
  • Returns formats supported by Imagick

Imagick::queryFormats

(PECL imagick 2, PECL imagick 3)

Imagick::queryFormats — Returns formats supported by Imagick

说明

public static Imagick::queryFormats ( string $pattern = "*" ) : array

Returns formats supported by Imagick.

参数

pattern

返回值

Returns an array containing the formats supported by Imagick.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::queryFormats()

<?php
    function render() {
        $output = "";
        $input = \Imagick::queryformats();
        $columns = 6;

        $output .= "<table border='2'>";

        for ($i=0; $i < count($input); $i += $columns) {
            $output .= "<tr>";
            for ($c=0; $c<$columns; $c++) {
                $output .= "<td>";
                if (($i + $c) <  count($input)) {
                    $output .= $input[$i + $c];
                }
                $output .= "</td>";
            }
            $output .= "</tr>";
        }

        $output .= "</table>";

        return $output;
    }

?>


Radial blurs an image

  • ? Imagick::queryFormats
  • Imagick::raiseImage ?
  • PHP Manual
  • Imagick
  • Radial blurs an image

Imagick::radialBlurImage

(PECL imagick 2, PECL imagick 3)

Imagick::radialBlurImage — Radial blurs an image

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::radialBlurImage ( float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Radial blurs an image.

参数

angle

channel

返回值

成功时返回 true。

范例

Example #1 Imagick::radialBlurImage()

<?php
function radialBlurImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    //Blur 3 times with different radii
    $imagick->radialBlurImage(3);
    $imagick->radialBlurImage(5);
    $imagick->radialBlurImage(7);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Creates a simulated 3d button-like effect

  • ? Imagick::radialBlurImage
  • Imagick::randomThresholdImage ?
  • PHP Manual
  • Imagick
  • Creates a simulated 3d button-like effect

Imagick::raiseImage

(PECL imagick 2, PECL imagick 3)

Imagick::raiseImage — Creates a simulated 3d button-like effect

说明

public Imagick::raiseImage ( int $width , int $height , int $x , int $y , bool $raise ) : bool

Creates a simulated three-dimensional button-like effect by lightening and darkening the edges of the image. Members width and height of raise_info define the width of the vertical and horizontal edge of the effect.

参数

width

height

x

y

raise

返回值

成功时返回 true。

范例

Example #1 Imagick::raiseImage()

<?php
function raiseImage($imagePath, $width, $height, $x, $y, $raise) {
    $imagick = new \Imagick(realpath($imagePath));

    //x and y do nothing?
    $imagick->raiseImage($width, $height, $x, $y, $raise);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Creates a high-contrast, two-color image

  • ? Imagick::raiseImage
  • Imagick::readImage ?
  • PHP Manual
  • Imagick
  • Creates a high-contrast, two-color image

Imagick::randomThresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::randomThresholdImage — Creates a high-contrast, two-color image

说明

public Imagick::randomThresholdImage ( float $low , float $high , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Changes the value of individual pixels based on the intensity of each pixel compared to threshold. The result is a high-contrast, two color image. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

low

The low point

high

The high point

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

返回值

成功时返回 true。

范例

Example #1 Imagick::randomThresholdImage()

<?php
function randomThresholdimage($imagePath, $lowThreshold, $highThreshold, $channel) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->randomThresholdimage(
        $lowThreshold * \Imagick::getQuantum(),
        $highThreshold * \Imagick::getQuantum(),
        $channel
    );
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Reads image from filename

  • ? Imagick::randomThresholdImage
  • Imagick::readImageBlob ?
  • PHP Manual
  • Imagick
  • Reads image from filename

Imagick::readImage

(PECL imagick 2, PECL imagick 3)

Imagick::readImage — Reads image from filename

说明

public Imagick::readImage ( string $filename ) : bool

Reads image from filename

参数

filename

返回值

成功时返回 true。


从二进制字符串里读取图片

  • ? Imagick::readImage
  • Imagick::readImageFile ?
  • PHP Manual
  • Imagick
  • 从二进制字符串里读取图片

Imagick::readImageBlob

(PECL imagick 2, PECL imagick 3)

Imagick::readImageBlob — 从二进制字符串里读取图片

说明

Imagick::readImageBlob ( string $image , string $filename = ? ) : bool

从二进制字符串里读取图片

参数

image

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::readImageBlob()

<?php
function readImageBlob() {
    $base64 = "iVBORw0KGgoAAAANSUhEUgAAAM0AAAD
 NCAMAAAAsYgRbAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5c
 cllPAAAABJQTFRF3NSmzMewPxIG//ncJEJsldTou1jHgAAAARBJREFUeNrs2EEK
 gCAQBVDLuv+V20dENbMY831wKz4Y/VHb/5RGQ0NDQ0NDQ0NDQ0NDQ0NDQ
 0NDQ0NDQ0NDQ0NDQ0NDQ0NDQ0PzMWtyaGhoaGhoaGhoaGhoaGhoxtb0QGho
 aGhoaGhoaGhoaGhoaMbRLEvv50VTQ9OTQ5OpyZ01GpM2g0bfmDQaL7S+ofFC6x
 v3ZpxJiywakzbvd9r3RWPS9I2+MWk0+kbf0Hih9Y17U0nTHibrDDQ0NDQ0NDQ0
 NDQ0NDQ0NTXbRSL/AK72o6GhoaGhoRlL8951vwsNDQ0NDQ1NDc0WyHtDTEhD
 Q0NDQ0NTS5MdGhoaGhoaGhoaGhoaGhoaGhoaGhoaGposzSHAAErMwwQ2HwRQ
 AAAAAElFTkSuQmCC";

    $imageBlob = base64_decode($base64);

    $imagick = new Imagick();
    $imagick->readImageBlob($imageBlob);

    header("Content-Type: image/png");
    echo $imageBlob;
}

?>


Reads image from open filehandle

  • ? Imagick::readImageBlob
  • Imagick::readimages ?
  • PHP Manual
  • Imagick
  • Reads image from open filehandle

Imagick::readImageFile

(PECL imagick 2, PECL imagick 3)

Imagick::readImageFile — Reads image from open filehandle

说明

public Imagick::readImageFile ( resource $filehandle , string $fileName = null ) : bool

Reads image from open filehandle

参数

filehandle

fileName

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Description

  • ? Imagick::readImageFile
  • Imagick::recolorImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::readimages

(PECL imagick 2, PECL imagick 3)

Imagick::readimages — Description

说明

public Imagick::readImages ( array $filenames ) : bool

Reads image from an array of filenames. All the images are held in a single Imagick object.

参数

filenames

返回值

成功时返回 true。


Recolors image

  • ? Imagick::readimages
  • Imagick::reduceNoiseImage ?
  • PHP Manual
  • Imagick
  • Recolors image

Imagick::recolorImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::recolorImage — Recolors image

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::recolorImage ( array $matrix ) : bool

Translate, scale, shear, or rotate image colors. This method supports variable sized matrices but normally 5x5 matrix is used for RGBA and 6x6 is used for CMYK. The last row should contain the normalized values. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

matrix

The matrix containing the color values

返回值

成功时返回 true。

参见

  • Imagick::displayImage() - Displays an image

范例

Example #1 Imagick::recolorImage()

<?php
function recolorImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $remapColor = [ 1, 0, 0,
        0, 0, 1,
        0, 1, 0,];

//$remapColor = [
//    1.438, -0.122, -0.016,  0, 0, -0.03,
//    -0.062,  1.378, -0.016,  0, 0,  0.05,
//    -0.062, -0.122, 1.483,   0, 0, -0.02,
//];

    @$imagick->recolorImage($remapColor);

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Smooths the contours of an image

  • ? Imagick::recolorImage
  • Imagick::remapImage ?
  • PHP Manual
  • Imagick
  • Smooths the contours of an image

Imagick::reduceNoiseImage

(PECL imagick 2, PECL imagick 3)

Imagick::reduceNoiseImage — Smooths the contours of an image

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::reduceNoiseImage ( float $radius ) : bool

Smooths the contours of an image while still preserving edge information. The algorithm works by replacing each pixel with its neighbor closest in value. A neighbor is defined by radius. Use a radius of 0 and Imagick::reduceNoiseImage() selects a suitable radius for you.

参数

radius

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::reduceNoiseImage()

<?php
function reduceNoiseImage($imagePath, $reduceNoise) {
    $imagick = new \Imagick(realpath($imagePath));
    @$imagick->reduceNoiseImage($reduceNoise);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Remaps image colors

  • ? Imagick::reduceNoiseImage
  • Imagick::removeImage ?
  • PHP Manual
  • Imagick
  • Remaps image colors

Imagick::remapImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::remapImage — Remaps image colors

说明

public Imagick::remapImage ( Imagick $replacement , int $DITHER ) : bool

Replaces colors an image with those defined by replacement. The colors are replaced with the closest possible color. 此方法在Imagick基于ImageMagick 6.4.5以上版本编译时可用。

参数

replacement

An Imagick object containing the replacement colors

DITHER

Refer to this list of dither method constants

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Removes an image from the image list

  • ? Imagick::remapImage
  • Imagick::removeImageProfile ?
  • PHP Manual
  • Imagick
  • Removes an image from the image list

Imagick::removeImage

(PECL imagick 2, PECL imagick 3)

Imagick::removeImage — Removes an image from the image list

说明

public Imagick::removeImage ( ) : bool

Removes an image from the image list.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Removes the named image profile and returns it

  • ? Imagick::removeImage
  • Imagick::render ?
  • PHP Manual
  • Imagick
  • Removes the named image profile and returns it

Imagick::removeImageProfile

(PECL imagick 2, PECL imagick 3)

Imagick::removeImageProfile — Removes the named image profile and returns it

说明

public Imagick::removeImageProfile ( string $name ) : string

Removes the named image profile and returns it.

参数

name

返回值

Returns a string containing the profile of the image.

错误／异常

错误时抛出 ImagickException。


Renders all preceding drawing commands

  • ? Imagick::removeImageProfile
  • Imagick::resampleImage ?
  • PHP Manual
  • Imagick
  • Renders all preceding drawing commands

Imagick::render

(PECL imagick 2, PECL imagick 3)

Imagick::render — Renders all preceding drawing commands

说明

public Imagick::render ( ) : bool

Renders all preceding drawing commands.

返回值

成功时返回 true。


Resample image to desired resolution

  • ? Imagick::render
  • Imagick::resetImagePage ?
  • PHP Manual
  • Imagick
  • Resample image to desired resolution

Imagick::resampleImage

(PECL imagick 2, PECL imagick 3)

Imagick::resampleImage — Resample image to desired resolution

说明

public Imagick::resampleImage ( float $x_resolution , float $y_resolution , int $filter , float $blur ) : bool

Resample image to desired resolution.

参数

x_resolution

y_resolution

filter

blur

返回值

成功时返回 true。

范例

Example #1 Imagick::resampleImage()

<?php
function resampleImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->resampleImage(200, 200, \Imagick::FILTER_LANCZOS, 1);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Reset image page

  • ? Imagick::resampleImage
  • Imagick::resizeImage ?
  • PHP Manual
  • Imagick
  • Reset image page

Imagick::resetImagePage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::resetImagePage — Reset image page

说明

public Imagick::resetImagePage ( string $page ) : bool

The page definition as a string. The string is in format WxH+x+y. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

page

The page definition. For example 7168x5147+0+0

返回值

成功时返回 true。


Scales an image

  • ? Imagick::resetImagePage
  • Imagick::rollImage ?
  • PHP Manual
  • Imagick
  • Scales an image

Imagick::resizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::resizeImage — Scales an image

说明

public Imagick::resizeImage ( int $columns , int $rows , int $filter , float $blur , bool $bestfit = false , bool $legacy = false ) : bool

Scales an image to the desired dimensions with a filter.

Note: 参数 bestfit 的特性在 Imagick 3.0.0 中已改变。在此版本以前，当目标尺寸设为 400x400 时，原尺寸为 200x150 的图像将不会被改变。自 Imagick 3.0.0 起，源图像将会被放大到 400x300 因为这将更好的适合目标尺寸。当使用参数 bestfit 时，必须同时给出宽度和高度。

参数

columns

Width of the image

rows

Height of the image

filter

Refer to the list of filter constants.

blur

The blur factor where > 1 is blurry, < 1 is sharp.

bestfit

Optional fit parameter.

返回值

成功时返回 true。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Added optional fit parameter. This method now supports proportional scaling. Pass zero as either parameter for proportional scaling.

范例

Example #1 Imagick::resizeImage()

<?php
function resizeImage($imagePath, $width, $height, $filterType, $blur, $bestFit, $cropZoom) {
    //The blur factor where > 1 is blurry, < 1 is sharp.
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->resizeImage($width, $height, $filterType, $blur, $bestFit);

    $cropWidth = $imagick->getImageWidth();
    $cropHeight = $imagick->getImageHeight();

    if ($cropZoom) {
        $newWidth = $cropWidth / 2;
        $newHeight = $cropHeight / 2;

        $imagick->cropimage(
            $newWidth,
            $newHeight,
            ($cropWidth - $newWidth) / 2,
            ($cropHeight - $newHeight) / 2
        );

        $imagick->scaleimage(
            $imagick->getImageWidth() * 4,
            $imagick->getImageHeight() * 4
        );
    }

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Offsets an image

  • ? Imagick::resizeImage
  • Imagick::rotateImage ?
  • PHP Manual
  • Imagick
  • Offsets an image

Imagick::rollImage

(PECL imagick 2, PECL imagick 3)

Imagick::rollImage — Offsets an image

说明

public Imagick::rollImage ( int $x , int $y ) : bool

Offsets an image as defined by x and y.

参数

x

The X offset.

y

The Y offset.

返回值

成功时返回 true。

范例

Example #1 Imagick::rollImage()

<?php
function rollImage($imagePath, $rollX, $rollY) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->rollimage($rollX, $rollY);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Rotates an image

  • ? Imagick::rollImage
  • Imagick::rotationalBlurImage ?
  • PHP Manual
  • Imagick
  • Rotates an image

Imagick::rotateImage

(PECL imagick 2, PECL imagick 3)

Imagick::rotateImage — Rotates an image

说明

public Imagick::rotateImage ( mixed $background , float $degrees ) : bool

Rotates an image the specified number of degrees. Empty triangles left over from rotating the image are filled with the background color.

参数

background

The background color

degrees

Rotation angle, in degrees. The rotation angle is interpreted as the number of degrees to rotate the image clockwise.

返回值

成功时返回 true。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the first parameter. Previous versions allow only an ImagickPixel object.

范例

Example #1 Imagick::rotateImage()

<?php
function rotateImage($imagePath, $angle, $color) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->rotateimage($color, $angle);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • ? Imagick::rotateImage
  • Imagick::roundCorners ?
  • PHP Manual
  • Imagick
  • Description

Imagick::rotationalBlurImage

(PECL imagick 3 >= 3.3.0)

Imagick::rotationalBlurImage — Description

说明

public Imagick::rotationalBlurImage ( float $angle , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Rotational blurs an image.

参数

angle

The angle to apply the blur over.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

范例

Example #1 Imagick::rotationalBlurImage()

<?php
function rotationalBlurImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->rotationalBlurImage(3);
    $imagick->rotationalBlurImage(5);
    $imagick->rotationalBlurImage(7);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Rounds image corners

  • ? Imagick::rotationalBlurImage
  • Imagick::sampleImage ?
  • PHP Manual
  • Imagick
  • Rounds image corners

Imagick::roundCorners

(PECL imagick 2, PECL imagick 3)

Imagick::roundCorners — Rounds image corners

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::roundCorners ( float $x_rounding , float $y_rounding , float $stroke_width = 10 , float $displace = 5 , float $size_correction = -6 ) : bool

Rounds image corners. The first two parameters control the amount of rounding and the three last parameters can be used to fine-tune the rounding process. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

x_rounding

x rounding

y_rounding

y rounding

stroke_width

stroke width

displace

image displace

size_correction

size correction

范例

Example #1 Using Imagick::roundCorners():

Rounds the image corners

<?php

$image = new Imagick();
$image->newPseudoImage(100, 100, "magick:rose");
$image->setImageFormat("png");

$image->roundCorners(5,3);
$image->writeImage("rounded.png");
?>

返回值

成功时返回 true。


Scales an image with pixel sampling

  • ? Imagick::roundCorners
  • Imagick::scaleImage ?
  • PHP Manual
  • Imagick
  • Scales an image with pixel sampling

Imagick::sampleImage

(PECL imagick 2, PECL imagick 3)

Imagick::sampleImage — Scales an image with pixel sampling

说明

public Imagick::sampleImage ( int $columns , int $rows ) : bool

Scales an image to the desired dimensions with pixel sampling. Unlike other scaling methods, this method does not introduce any additional color into the scaled image.

参数

columns

rows

返回值

成功时返回 true。


Scales the size of an image

  • ? Imagick::sampleImage
  • Imagick::segmentImage ?
  • PHP Manual
  • Imagick
  • Scales the size of an image

Imagick::scaleImage

(PECL imagick 2, PECL imagick 3)

Imagick::scaleImage — Scales the size of an image

说明

public Imagick::scaleImage ( int $cols , int $rows , bool $bestfit = false , bool $legacy = false ) : bool

Scales the size of an image to the given dimensions. The other parameter will be calculated if 0 is passed as either param.

Note: 参数 bestfit 的特性在 Imagick 3.0.0 中已改变。在此版本以前，当目标尺寸设为 400x400 时，原尺寸为 200x150 的图像将不会被改变。自 Imagick 3.0.0 起，源图像将会被放大到 400x300 因为这将更好的适合目标尺寸。当使用参数 bestfit 时，必须同时给出宽度和高度。

参数

cols

rows

bestfit

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Added optional fit parameter. This method now supports proportional scaling. Pass zero as either parameter for proportional scaling.

范例

Example #1 Imagick::scaleImage()

<?php
function scaleImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->scaleImage(150, 150, true);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Segments an image

  • ? Imagick::scaleImage
  • Imagick::selectiveBlurImage ?
  • PHP Manual
  • Imagick
  • Segments an image

Imagick::segmentImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::segmentImage — Segments an image

说明

public Imagick::segmentImage ( int $COLORSPACE , float $cluster_threshold , float $smooth_threshold , bool $verbose = false ) : bool

Analyses the image and identifies units that are similar. 此方法在Imagick基于ImageMagick 6.4.5以上版本编译时可用。

参数

COLORSPACE

One of the COLORSPACE constants.

cluster_threshold

A percentage describing minimum number of pixels contained in hexedra before it is considered valid.

smooth_threshold

Eliminates noise from the histogram.

verbose

Whether to output detailed information about recognised classes.

返回值

范例

Example #1 Imagick::segmentImage()

<?php
function segmentImage($imagePath, $colorSpace, $clusterThreshold, $smoothThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->segmentImage($colorSpace, $clusterThreshold, $smoothThreshold);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

segmentImage($imagePath, \Imagick::COLORSPACE_RGB, 5, 5);

?>


Description

  • ? Imagick::segmentImage
  • Imagick::separateImageChannel ?
  • PHP Manual
  • Imagick
  • Description

Imagick::selectiveBlurImage

(PECL imagick 3 >= 3.3.0)

Imagick::selectiveBlurImage — Description

说明

public Imagick::selectiveBlurImage ( float $radius , float $sigma , float $threshold , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Selectively blur an image within a contrast threshold. It is similar to the unsharpen mask that sharpens everything with contrast above a certain threshold.

参数

radius

sigma

threshold

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

范例

Example #1 Imagick::selectiveBlurImage()

<?php
function selectiveBlurImage($imagePath, $radius, $sigma, $threshold, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->selectiveBlurImage($radius, $sigma, $threshold, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Separates a channel from the image

  • ? Imagick::selectiveBlurImage
  • Imagick::sepiaToneImage ?
  • PHP Manual
  • Imagick
  • Separates a channel from the image

Imagick::separateImageChannel

(PECL imagick 2, PECL imagick 3)

Imagick::separateImageChannel — Separates a channel from the image

说明

public Imagick::separateImageChannel ( int $channel ) : bool

Separates a channel from the image and returns a grayscale image. A channel is a particular color component of each pixel in the image.

参数

channel

Which 'channel' to return. For colorspaces other than RGB, you can still use the CHANNEL_RED, CHANNEL_GREEN, CHANNEL_BLUE constants to indicate the 1st, 2nd and 3rd channels.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::separateImageChannel()

<?php
function separateImageChannel($imagePath, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->separateimagechannel($channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

separateImageChannel($imagePath, \Imagick::CHANNEL_GREEN);

?>


Sepia tones an image

  • ? Imagick::separateImageChannel
  • Imagick::setBackgroundColor ?
  • PHP Manual
  • Imagick
  • Sepia tones an image

Imagick::sepiaToneImage

(PECL imagick 2, PECL imagick 3)

Imagick::sepiaToneImage — Sepia tones an image

说明

public Imagick::sepiaToneImage ( float $threshold ) : bool

Applies a special effect to the image, similar to the effect achieved in a photo darkroom by sepia toning. Threshold ranges from 0 to QuantumRange and is a measure of the extent of the sepia toning. A threshold of 80 is a good starting point for a reasonable tone.

参数

threshold

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::sepiaToneImage()

<?php
function sepiaToneImage($imagePath, $sepia) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->sepiaToneImage($sepia);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Sets the object's default background color

  • ? Imagick::sepiaToneImage
  • Imagick::setColorspace ?
  • PHP Manual
  • Imagick
  • Sets the object's default background color

Imagick::setBackgroundColor

(PECL imagick 2, PECL imagick 3)

Imagick::setBackgroundColor — Sets the object's default background color

说明

public Imagick::setBackgroundColor ( mixed $background ) : bool

Sets the object's default background color.

参数

background

返回值

成功时返回 true。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as a parameter. Previous versions allow only an ImagickPixel object.


Set colorspace

  • ? Imagick::setBackgroundColor
  • Imagick::setCompression ?
  • PHP Manual
  • Imagick
  • Set colorspace

Imagick::setColorspace

(PECL imagick 3)

Imagick::setColorspace — Set colorspace

说明

public Imagick::setColorspace ( int $COLORSPACE ) : bool

Sets the global colorspace value for the object. 此方法在Imagick基于ImageMagick 6.5.7以上版本编译时可用。

参数

COLORSPACE

One of the COLORSPACE constants

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the object's default compression type

  • ? Imagick::setColorspace
  • Imagick::setCompressionQuality ?
  • PHP Manual
  • Imagick
  • Sets the object's default compression type

Imagick::setCompression

(PECL imagick 2, PECL imagick 3)

Imagick::setCompression — Sets the object's default compression type

说明

public Imagick::setCompression ( int $compression ) : bool

Sets the object's default compression type

参数

compression

The compression type. See the Imagick::COMPRESSION_* constants.

返回值

成功时返回 true。


Sets the object's default compression quality

  • ? Imagick::setCompression
  • Imagick::setFilename ?
  • PHP Manual
  • Imagick
  • Sets the object's default compression quality

Imagick::setCompressionQuality

(PECL imagick 2, PECL imagick 3)

Imagick::setCompressionQuality — Sets the object's default compression quality

说明

public Imagick::setCompressionQuality ( int $quality ) : bool

Sets the object's default compression quality.

Caution

This method only works for new images e.g. those created through Imagick::newPseudoImage. For existing images you should use Imagick::setImageCompressionQuality().

参数

quality

An int between 1 and 100, 1 = high compression, 100 low compression.

返回值

成功时返回 true。

范例

Example #1 Imagick::setCompressionQuality()

<?php
function setCompressionQuality($imagePath, $quality) {

    $backgroundImagick = new \Imagick(realpath($imagePath));
    $imagick = new \Imagick();
    $imagick->setCompressionQuality($quality);
    $imagick->newPseudoImage(
        $backgroundImagick->getImageWidth(),
        $backgroundImagick->getImageHeight(),
        'canvas:white'
    );

    $imagick->compositeImage(
        $backgroundImagick,
        \Imagick::COMPOSITE_ATOP,
        0,
        0
    );

    $imagick->setFormat("jpg");
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Sets the filename before you read or write the image

  • ? Imagick::setCompressionQuality
  • Imagick::setFirstIterator ?
  • PHP Manual
  • Imagick
  • Sets the filename before you read or write the image

Imagick::setFilename

(PECL imagick 2, PECL imagick 3)

Imagick::setFilename — Sets the filename before you read or write the image

说明

public Imagick::setFilename ( string $filename ) : bool

Sets the filename before you read or write an image file.

参数

filename

返回值

成功时返回 true。


Sets the Imagick iterator to the first image

  • ? Imagick::setFilename
  • Imagick::setFont ?
  • PHP Manual
  • Imagick
  • Sets the Imagick iterator to the first image

Imagick::setFirstIterator

(PECL imagick 2, PECL imagick 3)

Imagick::setFirstIterator — Sets the Imagick iterator to the first image

说明

public Imagick::setFirstIterator ( ) : bool

Sets the Imagick iterator to the first image.

返回值

成功时返回 true。


Sets font

  • ? Imagick::setFirstIterator
  • Imagick::setFormat ?
  • PHP Manual
  • Imagick
  • Sets font

Imagick::setFont

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::setFont — Sets font

说明

public Imagick::setFont ( string $font ) : bool

Sets object's font property. This method can be used for example to set font for caption: pseudo-format. The font needs to be configured in ImageMagick configuration or a file by the name of font must exist. This method should not be confused with ImagickDraw::setFont() which sets the font for a specific ImagickDraw object. 此方法在Imagick基于ImageMagick 6.3.7以上版本编译时可用。

参数

font

Font name or a filename

返回值

成功时返回 true。

参见

  • Imagick::getFont() - Gets font
  • ImagickDraw::setFont() - Sets the fully-specified font to use when annotating with text
  • ImagickDraw::getFont() - Returns the font

范例

Example #1 A Imagick::setFont() example

Example of using Imagick::setFont

<?php
/* Create new imagick object */
$im = new Imagick();

/* Set the font for the object */
$im->setFont("example.ttf");

/* Create new caption */
$im->newPseudoImage(100, 100, "caption:Hello");

/* Do something with the image */
?>


Sets the format of the Imagick object

  • ? Imagick::setFont
  • Imagick::setGravity ?
  • PHP Manual
  • Imagick
  • Sets the format of the Imagick object

Imagick::setFormat

(PECL imagick 2, PECL imagick 3)

Imagick::setFormat — Sets the format of the Imagick object

说明

public Imagick::setFormat ( string $format ) : bool

Sets the format of the Imagick object.

参数

format

返回值

成功时返回 true。


Sets the gravity

  • ? Imagick::setFormat
  • Imagick::setImage ?
  • PHP Manual
  • Imagick
  • Sets the gravity

Imagick::setGravity

(PECL imagick 2 >= 2.2.0, PECL imagick 3)

Imagick::setGravity — Sets the gravity

说明

public Imagick::setGravity ( int $gravity ) : bool

Sets the global gravity property for the Imagick object. 此方法在Imagick基于ImageMagick 6.4.0以上版本编译时可用。

参数

gravity

The gravity property. Refer to the list of gravity constants.

返回值

没有返回值。


Replaces image in the object

  • ? Imagick::setGravity
  • Imagick::setImageAlphaChannel ?
  • PHP Manual
  • Imagick
  • Replaces image in the object

Imagick::setImage

(PECL imagick 2, PECL imagick 3)

Imagick::setImage — Replaces image in the object

说明

public Imagick::setImage ( Imagick $replace ) : bool

Replaces the current image sequence with the image from replace object.

参数

replace

The replace Imagick object

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 A Imagick::setImage() example

An example of using Imagick::setImage()

<?php
/* Create the objects */
$image = new Imagick('source.jpg');
$replace = new Imagick('replace.jpg');

/* source.jpg is replaced with replace.jpg */
$image->setImage($replace);

/* output the image */
header('Content-type: image/jpeg');
echo $image;

?>


Sets image alpha channel

  • ? Imagick::setImage
  • Imagick::setImageArtifact ?
  • PHP Manual
  • Imagick
  • Sets image alpha channel

Imagick::setImageAlphaChannel

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::setImageAlphaChannel — Sets image alpha channel

说明

public Imagick::setImageAlphaChannel ( int $mode ) : bool

Activate or deactivate image alpha channel. The mode is one of the Imagick::ALPHACHANNEL_* constants. 此方法在Imagick基于ImageMagick 6.3.8以上版本编译时可用。

参数

mode

One of the Imagick::ALPHACHANNEL_* constants

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

参见

  • Imagick::setImageMatte() - Sets the image matte channel
  • Imagick Alpha Channel Constants


Set image artifact

  • ? Imagick::setImageAlphaChannel
  • Imagick::setImageAttribute ?
  • PHP Manual
  • Imagick
  • Set image artifact

Imagick::setImageArtifact

(PECL imagick 3)

Imagick::setImageArtifact — Set image artifact

说明

public Imagick::setImageArtifact ( string $artifact , string $value ) : bool

Associates an artifact with the image. The difference between image properties and image artifacts is that properties are public and artifacts are private. 此方法在Imagick基于ImageMagick 6.5.7以上版本编译时可用。

参数

artifact

The name of the artifact

value

The value of the artifact

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

参见

  • Imagick::getImageArtifact() - Get image artifact
  • Imagick::deleteImageArtifact() - Delete image artifact

范例

Example #1 Imagick::setImageArtifact()

<?php
function setImageArtifact() {

    $src1 = new \Imagick(realpath("./images/artifact/source1.png"));
    $src2 = new \Imagick(realpath("./images/artifact/source2.png"));

    $src2->setImageVirtualPixelMethod(\Imagick::VIRTUALPIXELMETHOD_TRANSPARENT);
    $src2->setImageArtifact('compose:args', "1,0,-0.5,0.5");
    $src1->compositeImage($src2, Imagick::COMPOSITE_MATHEMATICS, 0, 0);

    $src1->setImageFormat('png');
    header("Content-Type: image/png");
    echo $src1->getImagesBlob();
}

?>


Description

  • ? Imagick::setImageArtifact
  • Imagick::setImageBackgroundColor ?
  • PHP Manual
  • Imagick
  • Description

Imagick::setImageAttribute

(PECL imagick 2, PECL imagick 3)

Imagick::setImageAttribute — Description

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::setImageAttribute ( string $key , string $value ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

key

value

返回值

成功时返回 true。


Sets the image background color

  • ? Imagick::setImageAttribute
  • Imagick::setImageBias ?
  • PHP Manual
  • Imagick
  • Sets the image background color

Imagick::setImageBackgroundColor

(PECL imagick 2, PECL imagick 3)

Imagick::setImageBackgroundColor — Sets the image background color

说明

public Imagick::setImageBackgroundColor ( mixed $background ) : bool

Sets the image background color.

参数

background

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the parameter. Previous versions allow only an ImagickPixel object.


Sets the image bias for any method that convolves an image

  • ? Imagick::setImageBackgroundColor
  • Imagick::setImageBiasQuantum ?
  • PHP Manual
  • Imagick
  • Sets the image bias for any method that convolves an image

Imagick::setImageBias

(PECL imagick 2, PECL imagick 3)

Imagick::setImageBias — Sets the image bias for any method that convolves an image

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::setImageBias ( float $bias ) : bool

Sets the image bias for any method that convolves an image (e.g. Imagick::ConvolveImage()).

参数

bias

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::setImageBias()

<?php
//requires ImageMagick version 6.9.0-1 to have an effect on convolveImage
function setImageBias($bias) {
    $imagick = new \Imagick(realpath("images/stack.jpg"));

    $xKernel = array(
        -0.70, 0, 0.70,
        -0.70, 0, 0.70,
        -0.70, 0, 0.70
    );

    $imagick->setImageBias($bias * \Imagick::getQuantum());
    $imagick->convolveImage($xKernel, \Imagick::CHANNEL_ALL);

    $imagick->setImageFormat('png');

    header('Content-type: image/png');
    echo $imagick->getImageBlob();
}

?>


Description

  • ? Imagick::setImageBias
  • Imagick::setImageBluePrimary ?
  • PHP Manual
  • Imagick
  • Description

Imagick::setImageBiasQuantum

(PECL imagick 3 >= 3.3.0)

Imagick::setImageBiasQuantum — Description

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::setImageBiasQuantum ( string $bias ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

bias

返回值


Sets the image chromaticity blue primary point

  • ? Imagick::setImageBiasQuantum
  • Imagick::setImageBorderColor ?
  • PHP Manual
  • Imagick
  • Sets the image chromaticity blue primary point

Imagick::setImageBluePrimary

(PECL imagick 2, PECL imagick 3)

Imagick::setImageBluePrimary — Sets the image chromaticity blue primary point

说明

public Imagick::setImageBluePrimary ( float $x , float $y ) : bool

Sets the image chromaticity blue primary point.

参数

x

y

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image border color

  • ? Imagick::setImageBluePrimary
  • Imagick::setImageChannelDepth ?
  • PHP Manual
  • Imagick
  • Sets the image border color

Imagick::setImageBorderColor

(PECL imagick 2, PECL imagick 3)

Imagick::setImageBorderColor — Sets the image border color

说明

public Imagick::setImageBorderColor ( mixed $border ) : bool

Sets the image border color.

参数

border

The border color

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as a parameter. Previous versions allow only an ImagickPixel object.


Sets the depth of a particular image channel

  • ? Imagick::setImageBorderColor
  • Imagick::setImageClipMask ?
  • PHP Manual
  • Imagick
  • Sets the depth of a particular image channel

Imagick::setImageChannelDepth

(PECL imagick 2, PECL imagick 3)

Imagick::setImageChannelDepth — Sets the depth of a particular image channel

说明

public Imagick::setImageChannelDepth ( int $channel , int $depth ) : bool

Sets the depth of a particular image channel.

参数

channel

depth

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets image clip mask

  • ? Imagick::setImageChannelDepth
  • Imagick::setImageColormapColor ?
  • PHP Manual
  • Imagick
  • Sets image clip mask

Imagick::setImageClipMask

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::setImageClipMask — Sets image clip mask

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::setImageClipMask ( Imagick $clip_mask ) : bool

Sets image clip mask from another Imagick object. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

clip_mask

The Imagick object containing the clip mask

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::setImageClipMask()

<?php
function setImageClipMask($imagePath) {
    $imagick = new \Imagick();
    $imagick->readImage(realpath($imagePath));

    $width = $imagick->getImageWidth();
    $height = $imagick->getImageHeight();

    $clipMask = new \Imagick();
    $clipMask->newPseudoImage(
        $width,
        $height,
        "canvas:transparent"
    );

    $draw = new \ImagickDraw();
    $draw->setFillColor('white');
    $draw->circle(
        $width / 2,
        $height / 2,
        ($width / 2) + ($width / 4),
        $height / 2
    );
    $clipMask->drawImage($draw);
    $imagick->setImageClipMask($clipMask);

    $imagick->negateImage(false);
    $imagick->setFormat("png");

    header("Content-Type: image/png");
    echo $imagick->getImagesBlob();

}

?>


Sets the color of the specified colormap index

  • ? Imagick::setImageClipMask
  • Imagick::setImageColorspace ?
  • PHP Manual
  • Imagick
  • Sets the color of the specified colormap index

Imagick::setImageColormapColor

(PECL imagick 2, PECL imagick 3)

Imagick::setImageColormapColor — Sets the color of the specified colormap index

说明

public Imagick::setImageColormapColor ( int $index , ImagickPixel $color ) : bool

Sets the color of the specified colormap index.

参数

index

color

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image colorspace

  • ? Imagick::setImageColormapColor
  • Imagick::setImageCompose ?
  • PHP Manual
  • Imagick
  • Sets the image colorspace

Imagick::setImageColorspace

(PECL imagick 2, PECL imagick 3)

Imagick::setImageColorspace — Sets the image colorspace

说明

public Imagick::setImageColorspace ( int $colorspace ) : bool

Sets the image colorspace. This method should be used when creating new images. To change the colorspace of an existing image, you should use Imagick::transformImageColorspace().

参数

colorspace

One of the COLORSPACE constants

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image composite operator

  • ? Imagick::setImageColorspace
  • Imagick::setImageCompression ?
  • PHP Manual
  • Imagick
  • Sets the image composite operator

Imagick::setImageCompose

(PECL imagick 2, PECL imagick 3)

Imagick::setImageCompose — Sets the image composite operator

说明

public Imagick::setImageCompose ( int $compose ) : bool

Sets the image composite operator, useful for specifying how to composite the image thumbnail when using the Imagick::montageImage() method.

参数

compose

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


设置图片压缩的类型

  • ? Imagick::setImageCompose
  • Imagick::setImageCompressionQuality ?
  • PHP Manual
  • Imagick
  • 设置图片压缩的类型

Imagick::setImageCompression

(PECL imagick 2, PECL imagick 3)

Imagick::setImageCompression — 设置图片压缩的类型

说明

Imagick::setImageCompression ( int $compression ) : bool

参数

compression

COMPRESSION 常量里的一种

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


设置图片压缩的质量

  • ? Imagick::setImageCompression
  • Imagick::setImageDelay ?
  • PHP Manual
  • Imagick
  • 设置图片压缩的质量

Imagick::setImageCompressionQuality

(PECL imagick 2, PECL imagick 3)

Imagick::setImageCompressionQuality — 设置图片压缩的质量

说明

Imagick::setImageCompressionQuality ( int $quality ) : bool

设置图片压缩的质量

参数

quality

配置压缩质量的整数

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image delay

  • ? Imagick::setImageCompressionQuality
  • Imagick::setImageDepth ?
  • PHP Manual
  • Imagick
  • Sets the image delay

Imagick::setImageDelay

(PECL imagick 2, PECL imagick 3)

Imagick::setImageDelay — Sets the image delay

说明

public Imagick::setImageDelay ( int $delay ) : bool

Sets the image delay. For an animated image this is the amount of time that this frame of the image should be displayed for, before displaying the next frame.

The delay can be set individually for each frame in an image.

参数

delay

The amount of time expressed in 'ticks' that the image should be displayed for. For animated GIFs there are 100 ticks per second, so a value of 20 would be 20/100 of a second aka 1/5th of a second.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Modify animated Gif with Imagick::setImageDelay()

<?php

// Modify an animated Gif so that it's frames are played at a variable speed,
// varying between being shown for 50ms down to 0ms, which will cause the frame
// to be skipped in most browsers.
$imagick = new Imagick(realpath("Test.gif"));
$imagick = $imagick->coalesceImages();

$frameCount = 0;

foreach ($imagick as $frame) {
    $imagick->setImageDelay((($frameCount % 11) * 5));
    $frameCount++;
}

$imagick = $imagick->deconstructImages();

$imagick->writeImages("/path/to/save/output.gif", true);

?>


Sets the image depth

  • ? Imagick::setImageDelay
  • Imagick::setImageDispose ?
  • PHP Manual
  • Imagick
  • Sets the image depth

Imagick::setImageDepth

(PECL imagick 2, PECL imagick 3)

Imagick::setImageDepth — Sets the image depth

说明

public Imagick::setImageDepth ( int $depth ) : bool

Sets the image depth.

参数

depth

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image disposal method

  • ? Imagick::setImageDepth
  • Imagick::setImageExtent ?
  • PHP Manual
  • Imagick
  • Sets the image disposal method

Imagick::setImageDispose

(PECL imagick 2, PECL imagick 3)

Imagick::setImageDispose — Sets the image disposal method

说明

public Imagick::setImageDispose ( int $dispose ) : bool

Sets the image disposal method.

参数

dispose

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image size

  • ? Imagick::setImageDispose
  • Imagick::setImageFilename ?
  • PHP Manual
  • Imagick
  • Sets the image size

Imagick::setImageExtent

(PECL imagick 2, PECL imagick 3)

Imagick::setImageExtent — Sets the image size

说明

public Imagick::setImageExtent ( int $columns , int $rows ) : bool

Sets the image size (i.e. columns & rows).

参数

columns

rows

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the filename of a particular image

  • ? Imagick::setImageExtent
  • Imagick::setImageFormat ?
  • PHP Manual
  • Imagick
  • Sets the filename of a particular image

Imagick::setImageFilename

(PECL imagick 2, PECL imagick 3)

Imagick::setImageFilename — Sets the filename of a particular image

说明

public Imagick::setImageFilename ( string $filename ) : bool

Sets the filename of a particular image in a sequence.

参数

filename

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


为图片设置指定的格式

  • ? Imagick::setImageFilename
  • Imagick::setImageGamma ?
  • PHP Manual
  • Imagick
  • 为图片设置指定的格式

Imagick::setImageFormat

(PECL imagick 2, PECL imagick 3)

Imagick::setImageFormat — 为图片设置指定的格式

说明

Imagick::setImageFormat ( string $format ) : bool

为图片设置指定的格式

参数

format

表示图片格式的一个字符串。支持的格式依赖于 ImageMagick 的安装。

返回值

成功时返回 true。


Sets the image gamma

  • ? Imagick::setImageFormat
  • Imagick::setImageGravity ?
  • PHP Manual
  • Imagick
  • Sets the image gamma

Imagick::setImageGamma

(PECL imagick 2, PECL imagick 3)

Imagick::setImageGamma — Sets the image gamma

说明

public Imagick::setImageGamma ( float $gamma ) : bool

Sets the image gamma.

参数

gamma

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image gravity

  • ? Imagick::setImageGamma
  • Imagick::setImageGreenPrimary ?
  • PHP Manual
  • Imagick
  • Sets the image gravity

Imagick::setImageGravity

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::setImageGravity — Sets the image gravity

说明

public Imagick::setImageGravity ( int $gravity ) : bool

Sets the gravity property for the current image. This method can be used to set the gravity property for a single image sequence. 此方法在Imagick基于ImageMagick 6.4.4以上版本编译时可用。

参数

gravity

The gravity property. Refer to the list of gravity constants.

返回值

没有返回值。


Sets the image chromaticity green primary point

  • ? Imagick::setImageGravity
  • Imagick::setImageIndex ?
  • PHP Manual
  • Imagick
  • Sets the image chromaticity green primary point

Imagick::setImageGreenPrimary

(PECL imagick 2, PECL imagick 3)

Imagick::setImageGreenPrimary — Sets the image chromaticity green primary point

说明

public Imagick::setImageGreenPrimary ( float $x , float $y ) : bool

Sets the image chromaticity green primary point.

参数

x

y

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Set the iterator position

  • ? Imagick::setImageGreenPrimary
  • Imagick::setImageInterlaceScheme ?
  • PHP Manual
  • Imagick
  • Set the iterator position

Imagick::setImageIndex

(PECL imagick 2, PECL imagick 3)

Imagick::setImageIndex — Set the iterator position

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::setImageIndex ( int $index ) : bool

Set the iterator to the position in the image list specified with the index parameter.

This method has been deprecated. See Imagick::setIteratorIndex().

参数

index

The position to set the iterator to

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image compression

  • ? Imagick::setImageIndex
  • Imagick::setImageInterpolateMethod ?
  • PHP Manual
  • Imagick
  • Sets the image compression

Imagick::setImageInterlaceScheme

(PECL imagick 2, PECL imagick 3)

Imagick::setImageInterlaceScheme — Sets the image compression

说明

public Imagick::setImageInterlaceScheme ( int $interlace_scheme ) : bool

Sets the image compression.

参数

interlace_scheme

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image interpolate pixel method

  • ? Imagick::setImageInterlaceScheme
  • Imagick::setImageIterations ?
  • PHP Manual
  • Imagick
  • Sets the image interpolate pixel method

Imagick::setImageInterpolateMethod

(PECL imagick 2, PECL imagick 3)

Imagick::setImageInterpolateMethod — Sets the image interpolate pixel method

说明

public Imagick::setImageInterpolateMethod ( int $method ) : bool

Sets the image interpolate pixel method.

参数

method

The method is one of the Imagick::INTERPOLATE_* constants

返回值

成功时返回 true。


Sets the image iterations

  • ? Imagick::setImageInterpolateMethod
  • Imagick::setImageMatte ?
  • PHP Manual
  • Imagick
  • Sets the image iterations

Imagick::setImageIterations

(PECL imagick 2, PECL imagick 3)

Imagick::setImageIterations — Sets the image iterations

说明

public Imagick::setImageIterations ( int $iterations ) : bool

Sets the number of iterations an animated image is repeated.

参数

iterations

The number of iterations the image should loop over. Set to '0' to loop continuously.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Basic Imagick::setImageIterations() usage

<?php

$imagick = new Imagick(realpath("Test.gif"));

$imagick = $imagick->coalesceImages();
$imagick->setImageIterations(1);
$imagick = $imagick->deconstructImages();

$imagick->writeImages('/path/to/save/OnceOnly.gif', true);

?>


Sets the image matte channel

  • ? Imagick::setImageIterations
  • Imagick::setImageMatteColor ?
  • PHP Manual
  • Imagick
  • Sets the image matte channel

Imagick::setImageMatte

(PECL imagick 2, PECL imagick 3)

Imagick::setImageMatte — Sets the image matte channel

说明

public Imagick::setImageMatte ( bool $matte ) : bool

Sets the image matte channel. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

matte

True activates the matte channel and false disables it.

返回值

成功时返回 true。


Sets the image matte color

  • ? Imagick::setImageMatte
  • Imagick::setImageOpacity ?
  • PHP Manual
  • Imagick
  • Sets the image matte color

Imagick::setImageMatteColor

(PECL imagick 2, PECL imagick 3)

Imagick::setImageMatteColor — Sets the image matte color

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::setImageMatteColor ( mixed $matte ) : bool

Sets the image matte color.

参数

matte

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the parameter. Previous versions allow only an ImagickPixel object.


Sets the image opacity level

  • ? Imagick::setImageMatteColor
  • Imagick::setImageOrientation ?
  • PHP Manual
  • Imagick
  • Sets the image opacity level

Imagick::setImageOpacity

(PECL imagick 2, PECL imagick 3)

Imagick::setImageOpacity — Sets the image opacity level

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::setImageOpacity ( float $opacity ) : bool

Sets the image to the specified opacity level. 此方法在Imagick基于ImageMagick 6.3.1以上版本编译时可用。 This method operates on all channels, which means that for example opacity value of 0.5 will set all transparent areas to partially opaque. To add transparency to areas that are not already transparent use Imagick::evaluateImage()

参数

opacity

The level of transparency: 1.0 is fully opaque and 0.0 is fully transparent.

返回值

成功时返回 true。

范例

Example #1 A Imagick::setImageOpacity() example

An example of using Imagick::setImageOpacity()

<?php
/* Create the object */
$image = new Imagick('source.png');

/* Set the opacity */
$image->setImageOpacity(0.7);

/* output the image */
header('Content-type: image/png');
echo $image;

?>


Sets the image orientation

  • ? Imagick::setImageOpacity
  • Imagick::setImagePage ?
  • PHP Manual
  • Imagick
  • Sets the image orientation

Imagick::setImageOrientation

(PECL imagick 2, PECL imagick 3)

Imagick::setImageOrientation — Sets the image orientation

说明

public Imagick::setImageOrientation ( int $orientation ) : bool

Sets the image orientation.

参数

orientation

One of the orientation constants

返回值

成功时返回 true。

范例

Example #1 Imagick::setImageOrientation()

<?php
//Doesn't appear to do anything
function setImageOrientation($imagePath, $orientationType) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageOrientation($orientationType);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Sets the page geometry of the image

  • ? Imagick::setImageOrientation
  • Imagick::setImageProfile ?
  • PHP Manual
  • Imagick
  • Sets the page geometry of the image

Imagick::setImagePage

(PECL imagick 2, PECL imagick 3)

Imagick::setImagePage — Sets the page geometry of the image

说明

public Imagick::setImagePage ( int $width , int $height , int $x , int $y ) : bool

Sets the page geometry of the image.

参数

width

height

x

y

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Adds a named profile to the Imagick object

  • ? Imagick::setImagePage
  • Imagick::setImageProperty ?
  • PHP Manual
  • Imagick
  • Adds a named profile to the Imagick object

Imagick::setImageProfile

(PECL imagick 2, PECL imagick 3)

Imagick::setImageProfile — Adds a named profile to the Imagick object

说明

public Imagick::setImageProfile ( string $name , string $profile ) : bool

Adds a named profile to the Imagick object. If a profile with the same name already exists, it is replaced. This method differs from the Imagick::ProfileImage() method in that it does not apply any CMS color profiles.

参数

name

profile

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets an image property

  • ? Imagick::setImageProfile
  • Imagick::setImageRedPrimary ?
  • PHP Manual
  • Imagick
  • Sets an image property

Imagick::setImageProperty

(PECL imagick 2, PECL imagick 3)

Imagick::setImageProperty — Sets an image property

说明

public Imagick::setImageProperty ( string $name , string $value ) : bool

Sets a named property to the image. 此方法在Imagick基于ImageMagick 6.3.2以上版本编译时可用。

参数

name

value

范例

Example #1 Using Imagick::setImageProperty():

Setting and getting image properties

<?php
$image = new Imagick();
$image->newImage(300, 200, "black");

$image->setImageProperty('Exif:Make', 'Imagick');
echo $image->getImageProperty('Exif:Make');
?>

参见

  • Imagick::getImageProperty() - Returns the named image property

返回值

成功时返回 true。


Sets the image chromaticity red primary point

  • ? Imagick::setImageProperty
  • Imagick::setImageRenderingIntent ?
  • PHP Manual
  • Imagick
  • Sets the image chromaticity red primary point

Imagick::setImageRedPrimary

(PECL imagick 2, PECL imagick 3)

Imagick::setImageRedPrimary — Sets the image chromaticity red primary point

说明

public Imagick::setImageRedPrimary ( float $x , float $y ) : bool

Sets the image chromaticity red primary point.

参数

x

y

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image rendering intent

  • ? Imagick::setImageRedPrimary
  • Imagick::setImageResolution ?
  • PHP Manual
  • Imagick
  • Sets the image rendering intent

Imagick::setImageRenderingIntent

(PECL imagick 2, PECL imagick 3)

Imagick::setImageRenderingIntent — Sets the image rendering intent

说明

public Imagick::setImageRenderingIntent ( int $rendering_intent ) : bool

Sets the image rendering intent.

参数

rendering_intent

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image resolution

  • ? Imagick::setImageRenderingIntent
  • Imagick::setImageScene ?
  • PHP Manual
  • Imagick
  • Sets the image resolution

Imagick::setImageResolution

(PECL imagick 2, PECL imagick 3)

Imagick::setImageResolution — Sets the image resolution

说明

public Imagick::setImageResolution ( float $x_resolution , float $y_resolution ) : bool

Sets the image resolution.

参数

x_resolution

y_resolution

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::setImageResolution()

<?php
function setImageResolution($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageResolution(50, 50);

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Sets the image scene

  • ? Imagick::setImageResolution
  • Imagick::setImageTicksPerSecond ?
  • PHP Manual
  • Imagick
  • Sets the image scene

Imagick::setImageScene

(PECL imagick 2, PECL imagick 3)

Imagick::setImageScene — Sets the image scene

说明

public Imagick::setImageScene ( int $scene ) : bool

Sets the image scene.

参数

scene

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image ticks-per-second

  • ? Imagick::setImageScene
  • Imagick::setImageType ?
  • PHP Manual
  • Imagick
  • Sets the image ticks-per-second

Imagick::setImageTicksPerSecond

(PECL imagick 2, PECL imagick 3)

Imagick::setImageTicksPerSecond — Sets the image ticks-per-second

说明

public Imagick::setImageTicksPerSecond ( int $ticks_per_second ) : bool

Adjust the amount of time that a frame of an animated image is displayed for.

Note:

For animated GIFs, this function does not change the number of 'image ticks' per second, which is always defined as 100. Instead it adjusts the amount of time that the frame is displayed for to simulate the change in 'ticks per second'.

For example, for an animated GIF where each frame is displayed for 20 ticks (1/5 of a second) when this method is called on each frame of that image with an argument of 50 the frames are adjusted to be displayed for 40 ticks (2/5 of a second) and the animation will play at half the original speed.

参数

ticks_per_second

The duration for which an image should be displayed expressed in ticks per second.

返回值

成功时返回 true。

范例

Example #1 Modify animated Gif with Imagick::setImageTicksPerSecond()

<?php

// Modify an animated gif so the first half of the gif is played at half the
// speed it currently is, and the second half to be played at double the speed
// it currently is

$imagick = new Imagick(realpath("Test.gif"));
$imagick = $imagick->coalesceImages();

$totalFrames = $imagick->getNumberImages();

$frameCount = 0;

foreach ($imagick as $frame) {
    $imagick->setImageTicksPerSecond(50);

    if ($frameCount < ($totalFrames / 2)) {
        // Modify the frame to be displayed for twice as long as it currently is
        $imagick->setImageTicksPerSecond(50);
    } else {
        // Modify the frame to be displayed for half as long as it currently is
        $imagick->setImageTicksPerSecond(200);
    }

    $frameCount++;
}

$imagick = $imagick->deconstructImages();

$imagick->writeImages("/path/to/save/output.gif", true);

?>


Sets the image type

  • ? Imagick::setImageTicksPerSecond
  • Imagick::setImageUnits ?
  • PHP Manual
  • Imagick
  • Sets the image type

Imagick::setImageType

(PECL imagick 2, PECL imagick 3)

Imagick::setImageType — Sets the image type

说明

public Imagick::setImageType ( int $image_type ) : bool

Sets the image type.

参数

image_type

返回值

成功时返回 true。


Sets the image units of resolution

  • ? Imagick::setImageType
  • Imagick::setImageVirtualPixelMethod ?
  • PHP Manual
  • Imagick
  • Sets the image units of resolution

Imagick::setImageUnits

(PECL imagick 2, PECL imagick 3)

Imagick::setImageUnits — Sets the image units of resolution

说明

public Imagick::setImageUnits ( int $units ) : bool

Sets the image units of resolution.

参数

units

返回值

成功时返回 true。


Sets the image virtual pixel method

  • ? Imagick::setImageUnits
  • Imagick::setImageWhitePoint ?
  • PHP Manual
  • Imagick
  • Sets the image virtual pixel method

Imagick::setImageVirtualPixelMethod

(PECL imagick 2, PECL imagick 3)

Imagick::setImageVirtualPixelMethod — Sets the image virtual pixel method

说明

public Imagick::setImageVirtualPixelMethod ( int $method ) : bool

Sets the image virtual pixel method.

参数

method

返回值

成功时返回 true。


Sets the image chromaticity white point

  • ? Imagick::setImageVirtualPixelMethod
  • Imagick::setInterlaceScheme ?
  • PHP Manual
  • Imagick
  • Sets the image chromaticity white point

Imagick::setImageWhitePoint

(PECL imagick 2, PECL imagick 3)

Imagick::setImageWhitePoint — Sets the image chromaticity white point

说明

public Imagick::setImageWhitePoint ( float $x , float $y ) : bool

Sets the image chromaticity white point.

参数

x

y

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Sets the image compression

  • ? Imagick::setImageWhitePoint
  • Imagick::setIteratorIndex ?
  • PHP Manual
  • Imagick
  • Sets the image compression

Imagick::setInterlaceScheme

(PECL imagick 2, PECL imagick 3)

Imagick::setInterlaceScheme — Sets the image compression

说明

public Imagick::setInterlaceScheme ( int $interlace_scheme ) : bool

Sets the image compression.

参数

interlace_scheme

返回值

成功时返回 true。


Set the iterator position

  • ? Imagick::setInterlaceScheme
  • Imagick::setLastIterator ?
  • PHP Manual
  • Imagick
  • Set the iterator position

Imagick::setIteratorIndex

(PECL imagick 2, PECL imagick 3)

Imagick::setIteratorIndex — Set the iterator position

说明

public Imagick::setIteratorIndex ( int $index ) : bool

Set the iterator to the position in the image list specified with the index parameter. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

index

The position to set the iterator to

返回值

成功时返回 true。

范例

Example #1 Using Imagick::setIteratorIndex():

Create images, set and get the iterator index

<?php
$im = new Imagick();
$im->newImage(100, 100, new ImagickPixel("red"));
$im->newImage(100, 100, new ImagickPixel("green"));
$im->newImage(100, 100, new ImagickPixel("blue"));

$im->setIteratorIndex(1);
echo $im->getIteratorIndex();
?>

参见

  • Imagick::getIteratorIndex() - Gets the index of the current active image
  • Imagick::getImageIndex() - Gets the index of the current active image
  • Imagick::setImageIndex() - Set the iterator position


Sets the Imagick iterator to the last image

  • ? Imagick::setIteratorIndex
  • Imagick::setOption ?
  • PHP Manual
  • Imagick
  • Sets the Imagick iterator to the last image

Imagick::setLastIterator

(PECL imagick 2 >= 2.0.1, PECL imagick 3)

Imagick::setLastIterator — Sets the Imagick iterator to the last image

说明

public Imagick::setLastIterator ( ) : bool

Sets the Imagick iterator to the last image.

返回值

成功时返回 true。


Set an option

  • ? Imagick::setLastIterator
  • Imagick::setPage ?
  • PHP Manual
  • Imagick
  • Set an option

Imagick::setOption

(PECL imagick 2, PECL imagick 3)

Imagick::setOption — Set an option

说明

public Imagick::setOption ( string $key , string $value ) : bool

Associates one or more options with the wand.

参数

key

value

返回值

成功时返回 true。

范例

Example #1 Attempt to reach '$extent' sizeImagick::setOption()

<?php
    function renderJPG($extent) {
        $imagePath = $this->control->getImagePath();
        $imagick = new \Imagick(realpath($imagePath));
        $imagick->setImageFormat('jpg');
        $imagick->setOption('jpeg:extent', $extent);
        header("Content-Type: image/jpg");
        echo $imagick->getImageBlob();
    }

?>

Example #2 Imagick::setOption()

<?php
    function renderPNG($imagePath, $format) {

        $imagick = new \Imagick(realpath($imagePath));
        $imagick->setImageFormat('png');
        $imagick->setOption('png:format', $format);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

    //Save as 64bit PNG.
    renderPNG($imagePath, 'png64');

?>

Example #3 Imagick::setOption()

<?php
    function renderCustomBitDepthPNG() {
        $imagePath = $this->control->getImagePath();
        $imagick = new \Imagick(realpath($imagePath));
        $imagick->setImageFormat('png');

        $imagick->setOption('png:bit-depth', '16');
        $imagick->setOption('png:color-type', 6);
        header("Content-Type: image/png");
        $crash = true;
        if ($crash) {
            echo $imagick->getImageBlob();
        }
        else {
            $tempFilename = tempnam('./', 'imagick');
            $imagick->writeimage(realpath($tempFilename));
            echo file_get_contents($tempFilename);
        }
    }

?>


Sets the page geometry of the Imagick object

  • ? Imagick::setOption
  • Imagick::setPointSize ?
  • PHP Manual
  • Imagick
  • Sets the page geometry of the Imagick object

Imagick::setPage

(PECL imagick 2, PECL imagick 3)

Imagick::setPage — Sets the page geometry of the Imagick object

说明

public Imagick::setPage ( int $width , int $height , int $x , int $y ) : bool

Sets the page geometry of the Imagick object.

参数

width

height

x

y

返回值

成功时返回 true。


Sets point size

  • ? Imagick::setPage
  • Imagick::setProgressMonitor ?
  • PHP Manual
  • Imagick
  • Sets point size

Imagick::setPointSize

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

Imagick::setPointSize — Sets point size

说明

public Imagick::setPointSize ( float $point_size ) : bool

Sets object's point size property. This method can be used for example to set font size for caption: pseudo-format. 此方法在Imagick基于ImageMagick 6.3.7以上版本编译时可用。

参数

point_size

Point size

返回值

成功时返回 true。

参见

  • Imagick::getPointSize() - Gets point size

范例

Example #1 A Imagick::setPointSize() example

Example of using Imagick::setPointSize

<?php
/* Create new imagick object */
$im = new Imagick();

/* Set the font for the object */
$im->setFont("example.ttf");

/* Set the point size */
$im->setPointSize(12);

/* Create new caption */
$im->newPseudoImage(100, 100, "caption:Hello");

/* Do something with the image */
?>


Description

  • ? Imagick::setPointSize
  • Imagick::setRegistry ?
  • PHP Manual
  • Imagick
  • Description

Imagick::setProgressMonitor

(PECL imagick 3 >= 3.3.0)

Imagick::setProgressMonitor — Description

说明

public Imagick::setProgressMonitor ( callable $callback ) : bool

Set a callback that will be called during the processing of the Imagick image.

参数

callback

The progress function to call. It should return true if image processing should continue, or false if it should be cancelled. The offset parameter indicates the progress and the span parameter indicates the total amount of work needed to be done.

callback ( mixed $offset , mixed $span ) : bool
Caution

The values passed to the callback function are not consistent. In particular the span parameter can increase during image processing. Because of this calculating the percentage complete of an image operation is not trivial.

返回值

成功时返回 true。

范例

Example #1 Imagick::setProgressMonitor()

<?php
        $abortReason = null;

        try {
            $imagick = new \Imagick(realpath($this->control->getImagePath()));
            $startTime = time();

            $callback = function ($offset, $span)  use ($startTime, &$abortReason) {
                if (((100 * $offset) / $span)  > 20) {
                    $abortReason = "Processing reached 20%";
                    return false;
                }

                $nowTime = time();

                if ($nowTime - $startTime > 5) {
                    $abortReason = "Image processing took more than 5 seconds";
                    return false;
                }
                if (($offset % 5) == 0) {
                    echo "Progress: $offset / $span <br/>";
                }
                return true;
            };

            $imagick->setProgressMonitor($callback);

            $imagick->waveImage(2, 15);

            echo "Data len is: ".strlen($imagick->getImageBlob());
        }
        catch(\ImagickException $e) {
            if ($abortReason != null) {
                echo "Image processing was aborted: ".$abortReason."<br/>";
            }
            else {
                echo "ImagickException caught: ".$e->getMessage()." Exception type is ".get_class($e);
            }
        }

?>


Description

  • ? Imagick::setProgressMonitor
  • Imagick::setResolution ?
  • PHP Manual
  • Imagick
  • Description

Imagick::setRegistry

(PECL imagick 3 >= 3.3.0)

Imagick::setRegistry — Description

说明

public static Imagick::setRegistry ( string $key , string $value ) : bool

Sets the ImageMagick registry entry named key to value. This is most useful for setting "temporary-path" which controls where ImageMagick creates temporary images e.g. while processing PDFs.

参数

key

value

返回值

成功时返回 true。


Sets the image resolution

  • ? Imagick::setRegistry
  • Imagick::setResourceLimit ?
  • PHP Manual
  • Imagick
  • Sets the image resolution

Imagick::setResolution

(PECL imagick 2, PECL imagick 3)

Imagick::setResolution — Sets the image resolution

说明

public Imagick::setResolution ( float $x_resolution , float $y_resolution ) : bool

Sets the image resolution.

参数

x_resolution

The horizontal resolution.

y_resolution

The vertical resolution.

返回值

成功时返回 true。

注释

Imagick::setResolution() must be called before loading or creating an image.

参见

  • Imagick::setImageResolution() - Sets the image resolution
  • Imagick::getImageResolution() - 获取图像的x,y轴分辨率


Sets the limit for a particular resource

  • ? Imagick::setResolution
  • Imagick::setSamplingFactors ?
  • PHP Manual
  • Imagick
  • Sets the limit for a particular resource

Imagick::setResourceLimit

(PECL imagick 2, PECL imagick 3)

Imagick::setResourceLimit — Sets the limit for a particular resource

说明

public static Imagick::setResourceLimit ( int $type , int $limit ) : bool

This method is used to modify the resource limits of the underlying ImageMagick library.

参数

type

Refer to the list of resourcetype constants.

limit

One of the resourcetype constants. The unit depends on the type of the resource being limited.

返回值

成功时返回 true。

参见

  • Imagick::getResourceLimit() - Returns the specified resource limit


Sets the image sampling factors

  • ? Imagick::setResourceLimit
  • Imagick::setSize ?
  • PHP Manual
  • Imagick
  • Sets the image sampling factors

Imagick::setSamplingFactors

(PECL imagick 2, PECL imagick 3)

Imagick::setSamplingFactors — Sets the image sampling factors

说明

public Imagick::setSamplingFactors ( array $factors ) : bool

Sets the image sampling factors.

参数

factors

返回值

成功时返回 true。

范例

Example #1 Imagick::setSamplingFactors()

<?php
function setSamplingFactors($imagePath) {

    $imagePath = "../imagick/images/FineDetail.png";
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageFormat('jpg');
    $imagick->setSamplingFactors(array('2x2', '1x1', '1x1'));

    $compressed = $imagick->getImageBlob();

    $reopen = new \Imagick();
    $reopen->readImageBlob($compressed);

    $reopen->resizeImage(
        $reopen->getImageWidth() * 4,
        $reopen->getImageHeight() * 4,
        \Imagick::FILTER_POINT,
        1
    );

    header("Content-Type: image/jpg");
    echo $reopen->getImageBlob();
}

?>


Sets the size of the Imagick object

  • ? Imagick::setSamplingFactors
  • Imagick::setSizeOffset ?
  • PHP Manual
  • Imagick
  • Sets the size of the Imagick object

Imagick::setSize

(PECL imagick 2, PECL imagick 3)

Imagick::setSize — Sets the size of the Imagick object

说明

public Imagick::setSize ( int $columns , int $rows ) : bool

Sets the size of the Imagick object. Set it before you read a raw image format such as RGB, GRAY, or CMYK.

参数

columns

rows

返回值

成功时返回 true。


Sets the size and offset of the Imagick object

  • ? Imagick::setSize
  • Imagick::setType ?
  • PHP Manual
  • Imagick
  • Sets the size and offset of the Imagick object

Imagick::setSizeOffset

(PECL imagick 2, PECL imagick 3)

Imagick::setSizeOffset — Sets the size and offset of the Imagick object

说明

public Imagick::setSizeOffset ( int $columns , int $rows , int $offset ) : bool

Sets the size and offset of the Imagick object. Set it before you read a raw image format such as RGB, GRAY, or CMYK. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

columns

The width in pixels.

rows

The height in pixels.

offset

The image offset.

返回值

成功时返回 true。


Sets the image type attribute

  • ? Imagick::setSizeOffset
  • Imagick::shadeImage ?
  • PHP Manual
  • Imagick
  • Sets the image type attribute

Imagick::setType

(PECL imagick 2, PECL imagick 3)

Imagick::setType — Sets the image type attribute

说明

public Imagick::setType ( int $image_type ) : bool

Sets the image type attribute.

参数

image_type

返回值

成功时返回 true。


Creates a 3D effect

  • ? Imagick::setType
  • Imagick::shadowImage ?
  • PHP Manual
  • Imagick
  • Creates a 3D effect

Imagick::shadeImage

(PECL imagick 2, PECL imagick 3)

Imagick::shadeImage — Creates a 3D effect

说明

public Imagick::shadeImage ( bool $gray , float $azimuth , float $elevation ) : bool

Shines a distant light on an image to create a three-dimensional effect. You control the positioning of the light with azimuth and elevation; azimuth is measured in degrees off the x axis and elevation is measured in pixels above the Z axis. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

gray

A value other than zero shades the intensity of each pixel.

azimuth

Defines the light source direction.

elevation

Defines the light source direction.

返回值

成功时返回 true。

错误／异常

Throws ImagickException on failure.

范例

Example #1 Imagick::shadeImage()

<?php
function shadeImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->shadeImage(true, 45, 20);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Simulates an image shadow

  • ? Imagick::shadeImage
  • Imagick::sharpenImage ?
  • PHP Manual
  • Imagick
  • Simulates an image shadow

Imagick::shadowImage

(PECL imagick 2, PECL imagick 3)

Imagick::shadowImage — Simulates an image shadow

说明

public Imagick::shadowImage ( float $opacity , float $sigma , int $x , int $y ) : bool

Simulates an image shadow.

参数

opacity

sigma

x

y

返回值

成功时返回 true。

范例

Example #1 Imagick::shadowImage()

<?php
function shadowImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->shadowImage(0.4, 10, 50, 5);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Sharpens an image

  • ? Imagick::shadowImage
  • Imagick::shaveImage ?
  • PHP Manual
  • Imagick
  • Sharpens an image

Imagick::sharpenImage

(PECL imagick 2, PECL imagick 3)

Imagick::sharpenImage — Sharpens an image

说明

public Imagick::sharpenImage ( float $radius , float $sigma , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Sharpens an image. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, the radius should be larger than sigma. Use a radius of 0 and Imagick::sharpenImage() selects a suitable radius for you.

参数

radius

sigma

channel

返回值

成功时返回 true。

范例

Example #1 Imagick::sharpenImage()

<?php
function sharpenImage($imagePath, $radius, $sigma, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->sharpenimage($radius, $sigma, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Shaves pixels from the image edges

  • ? Imagick::sharpenImage
  • Imagick::shearImage ?
  • PHP Manual
  • Imagick
  • Shaves pixels from the image edges

Imagick::shaveImage

(PECL imagick 2, PECL imagick 3)

Imagick::shaveImage — Shaves pixels from the image edges

说明

public Imagick::shaveImage ( int $columns , int $rows ) : bool

Shaves pixels from the image edges. It allocates the memory necessary for the new Image structure and returns a pointer to the new image.

参数

columns

rows

返回值

成功时返回 true。

范例

Example #1 Imagick::shaveImage()

<?php
function shaveImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->shaveImage(100, 50);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Creating a parallelogram

  • ? Imagick::shaveImage
  • Imagick::sigmoidalContrastImage ?
  • PHP Manual
  • Imagick
  • Creating a parallelogram

Imagick::shearImage

(PECL imagick 2, PECL imagick 3)

Imagick::shearImage — Creating a parallelogram

说明

public Imagick::shearImage ( mixed $background , float $x_shear , float $y_shear ) : bool

Slides one edge of an image along the X or Y axis, creating a parallelogram. An X direction shear slides an edge along the X axis, while a Y direction shear slides an edge along the Y axis. The amount of the shear is controlled by a shear angle. For X direction shears, x_shear is measured relative to the Y axis, and similarly, for Y direction shears y_shear is measured relative to the X axis. Empty triangles left over from shearing the image are filled with the background color.

参数

background

The background color

x_shear

The number of degrees to shear on the x axis

y_shear

The number of degrees to shear on the y axis

返回值

成功时返回 true。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the first parameter. Previous versions allow only an ImagickPixel object.

范例

Example #1 Imagick::shearImage()

<?php
function shearImage($imagePath, $color, $shearX, $shearY) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->shearimage($color, $shearX, $shearY);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Adjusts the contrast of an image

  • ? Imagick::shearImage
  • Imagick::sketchImage ?
  • PHP Manual
  • Imagick
  • Adjusts the contrast of an image

Imagick::sigmoidalContrastImage

(PECL imagick 2, PECL imagick 3)

Imagick::sigmoidalContrastImage — Adjusts the contrast of an image

说明

public Imagick::sigmoidalContrastImage ( bool $sharpen , float $alpha , float $beta , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Adjusts the contrast of an image with a non-linear sigmoidal contrast algorithm. Increase the contrast of the image using a sigmoidal transfer function without saturating highlights or shadows. Contrast indicates how much to increase the contrast (0 is none; 3 is typical; 20 is pushing it); mid-point indicates where midtones fall in the resultant image (0 is white; 50 is middle-gray; 100 is black). Set sharpen to true to increase the image contrast otherwise the contrast is reduced.

See also » ImageMagick v6 Examples - Image Transformations — Sigmoidal Non-linearity Contrast

参数

sharpen

If true increase the contrast, if false decrease the contrast.

alpha

The amount of contrast to apply. 1 is very little, 5 is a significant amount, 20 is extreme.

beta

Where the midpoint of the gradient will be. This value should be in the range 0 to 1 - mutliplied by the quantum value for ImageMagick.

channel

Which color channels the contrast will be applied to.

返回值

成功时返回 true。

范例

Example #1 Create a gradient image using Imagick::sigmoidalContrastImage() suitable for blending two images together smoothly, with the blending defined by $contrast and $the midpoint

<?php

function generateBlendImage($width, $height, $contrast = 10, $midpoint = 0.5) {
    $imagick = new Imagick();
    $imagick->newPseudoImage($width, $height, 'gradient:black-white');
    $quanta = $imagick->getQuantumRange();
    $imagick->sigmoidalContrastImage(true, $contrast, $midpoint * $quanta["quantumRangeLong"]);

    return $imagick;
}

?>

错误／异常

错误时抛出 ImagickException。


Simulates a pencil sketch

  • ? Imagick::sigmoidalContrastImage
  • Imagick::smushImages ?
  • PHP Manual
  • Imagick
  • Simulates a pencil sketch

Imagick::sketchImage

(PECL imagick 2, PECL imagick 3)

Imagick::sketchImage — Simulates a pencil sketch

说明

public Imagick::sketchImage ( float $radius , float $sigma , float $angle ) : bool

Simulates a pencil sketch. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and Imagick::sketchImage() selects a suitable radius for you. Angle gives the angle of the blurring motion. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

radius

The radius of the Gaussian, in pixels, not counting the center pixel

sigma

The standard deviation of the Gaussian, in pixels.

angle

Apply the effect along this angle.

返回值

成功时返回 true。

范例

Example #1 Imagick::sketchImage()

<?php
function sketchImage($imagePath, $radius, $sigma, $angle) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->sketchimage($radius, $sigma, $angle);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • ? Imagick::sketchImage
  • Imagick::solarizeImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::smushImages

(PECL imagick 3 >= 3.3.0)

Imagick::smushImages — Description

说明

public Imagick::smushImages ( bool $stack , int $offset ) : Imagick

Takes all images from the current image pointer to the end of the image list and smushs them to each other top-to-bottom if the stack parameter is true, otherwise left-to-right.

参数

stack

offset

返回值

The new smushed image.

范例

Example #1 Imagick::smushImages()

<?php
function smushImages($imagePath, $imagePath2) {

    $imagick = new \Imagick(realpath($imagePath));
    $imagick2 = new \Imagick(realpath($imagePath2));

    $imagick->addimage($imagick2);
    $smushed = $imagick->smushImages(false, 50);
    $smushed->setImageFormat('jpg');
    header("Content-Type: image/jpg");
    echo $smushed->getImageBlob();
}

?>


Applies a solarizing effect to the image

  • ? Imagick::smushImages
  • Imagick::sparseColorImage ?
  • PHP Manual
  • Imagick
  • Applies a solarizing effect to the image

Imagick::solarizeImage

(PECL imagick 2, PECL imagick 3)

Imagick::solarizeImage — Applies a solarizing effect to the image

说明

public Imagick::solarizeImage ( int $threshold ) : bool

Applies a special effect to the image, similar to the effect achieved in a photo darkroom by selectively exposing areas of photo sensitive paper to light. Threshold ranges from 0 to QuantumRange and is a measure of the extent of the solarization.

参数

threshold

返回值

成功时返回 true。

范例

Example #1 Imagick::solarizeImage()

<?php
function solarizeImage($imagePath, $solarizeThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->solarizeImage($solarizeThreshold * \Imagick::getQuantum());
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Interpolates colors

  • ? Imagick::solarizeImage
  • Imagick::spliceImage ?
  • PHP Manual
  • Imagick
  • Interpolates colors

Imagick::sparseColorImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::sparseColorImage — Interpolates colors

说明

public Imagick::sparseColorImage ( int $SPARSE_METHOD , array $arguments , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Given the arguments array containing numeric values this method interpolates the colors found at those coordinates across the whole image using sparse_method. 此方法在Imagick基于ImageMagick 6.4.5以上版本编译时可用。

参数

SPARSE_METHOD

Refer to this list of sparse method constants

arguments

An array containing the coordinates. The array is in format array(1,1, 2,45)

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channel constants using bitwise operators. 缺省为Imagick::CHANNEL_DEFAULT. 参考此 通道常数列表

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage()

<?php
    function renderImageBarycentric2() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(
            400, 400,
            $points,
            \Imagick::SPARSECOLORMETHOD_BARYCENTRIC
        );
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Example #2 SPARSECOLORMETHOD_BILINEAR Imagick::sparseColorImage()

<?php
    function renderImageBilinear() {
        $points = [[0.30, 0.10, 'red'], [0.10, 0.80, 'blue'], [0.70, 0.60, 'lime'], [0.80, 0.20, 'yellow'],];
        $imagick = createGradientImage(500, 500, $points, \Imagick::SPARSECOLORMETHOD_BILINEAR);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Example #3 SPARSECOLORMETHOD_SPEPARDS Imagick::sparseColorImage()

<?php
    function renderImageShepards() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(600, 600, $points, \Imagick::SPARSECOLORMETHOD_SPEPARDS);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Example #4 SPARSECOLORMETHOD_VORONOI Imagick::sparseColorImage()

<?php
    function renderImageVoronoi() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(500, 500, $points, \Imagick::SPARSECOLORMETHOD_VORONOI);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Example #5 SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage()

<?php
    function renderImageBarycentric() {
        $points = [
            [0, 0, 'skyblue'],
            [-1, 1, 'skyblue'],
            [1, 1, 'black'],
        ];
        $imagick = createGradientImage(600, 200, $points, \Imagick::SPARSECOLORMETHOD_BARYCENTRIC);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Example #6 createGradientImage is used by other examples. Imagick::sparseColorImage()

<?php
function createGradientImage($width, $height, $colorPoints, $sparseMethod, $absolute = false) {

    $imagick = new \Imagick();
    $imagick->newImage($width, $height, "white");
    $imagick->setImageFormat("png");

    $barycentricPoints = array();

    foreach ($colorPoints as $colorPoint) {

        if ($absolute == true) {
            $barycentricPoints[] = $colorPoint[0];
            $barycentricPoints[] = $colorPoint[1];
        }
        else {
            $barycentricPoints[] = $colorPoint[0] * $width;
            $barycentricPoints[] = $colorPoint[1] * $height;
        }

        if (is_string($colorPoint[2])) {
            $imagickPixel = new \ImagickPixel($colorPoint[2]);
        }
        else if ($colorPoint[2] instanceof \ImagickPixel) {
            $imagickPixel = $colorPoint[2];
        }
        else{
            $errorMessage = sprintf(
                "Value %s is neither a string nor an ImagickPixel class. Cannot use as a color.",
                $colorPoint[2]
            );

            throw new \InvalidArgumentException(
                $errorMessage
            );
        }

        $red = $imagickPixel->getColorValue(\Imagick::COLOR_RED);
        $green = $imagickPixel->getColorValue(\Imagick::COLOR_GREEN);
        $blue = $imagickPixel->getColorValue(\Imagick::COLOR_BLUE);
        $alpha = $imagickPixel->getColorValue(\Imagick::COLOR_ALPHA);

        $barycentricPoints[] = $red;
        $barycentricPoints[] = $green;
        $barycentricPoints[] = $blue;
        $barycentricPoints[] = $alpha;
    }

    $imagick->sparseColorImage($sparseMethod, $barycentricPoints);

    return $imagick;
}

?>


Splices a solid color into the image

  • ? Imagick::sparseColorImage
  • Imagick::spreadImage ?
  • PHP Manual
  • Imagick
  • Splices a solid color into the image

Imagick::spliceImage

(PECL imagick 2, PECL imagick 3)

Imagick::spliceImage — Splices a solid color into the image

说明

public Imagick::spliceImage ( int $width , int $height , int $x , int $y ) : bool

Splices a solid color into the image.

参数

width

height

x

y

返回值

成功时返回 true。

范例

Example #1 Imagick::spliceImage()

<?php
function spliceImage($imagePath, $startX, $startY, $width, $height) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->spliceImage($width, $height, $startX, $startY);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Randomly displaces each pixel in a block

  • ? Imagick::spliceImage
  • Imagick::statisticImage ?
  • PHP Manual
  • Imagick
  • Randomly displaces each pixel in a block

Imagick::spreadImage

(PECL imagick 2, PECL imagick 3)

Imagick::spreadImage — Randomly displaces each pixel in a block

说明

public Imagick::spreadImage ( float $radius ) : bool

Special effects method that randomly displaces each pixel in a block defined by the radius parameter.

参数

radius

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::spreadImage()

<?php
function spreadImage($imagePath, $radius) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->spreadImage($radius);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Description

  • ? Imagick::spreadImage
  • Imagick::steganoImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::statisticImage

(PECL imagick 3 >= 3.3.0)

Imagick::statisticImage — Description

说明

public Imagick::statisticImage ( int $type , int $width , int $height , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Replace each pixel with corresponding statistic from the neighborhood of the specified width and height.

参数

type

width

height

channel

返回值

成功时返回 true。

范例

Example #1 Imagick::statisticImage()

<?php
function statisticImage($imagePath, $statisticType, $width, $height, $channel) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->statisticImage(
        $statisticType,
        $width,
        $height,
        $channel
    );

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

statisticImage($imagePath, \Imagick::STATISTIC_MEDIAN, 5, 5, \Imagick::CHANNEL_DEFAULT);

?>


Hides a digital watermark within the image

  • ? Imagick::statisticImage
  • Imagick::stereoImage ?
  • PHP Manual
  • Imagick
  • Hides a digital watermark within the image

Imagick::steganoImage

(PECL imagick 2, PECL imagick 3)

Imagick::steganoImage — Hides a digital watermark within the image

说明

public Imagick::steganoImage ( Imagick $watermark_wand , int $offset ) : Imagick

Hides a digital watermark within the image. Recover the hidden watermark later to prove that the authenticity of an image. Offset defines the start position within the image to hide the watermark.

参数

watermark_wand

offset

返回值

成功时返回 true。


Composites two images

  • ? Imagick::steganoImage
  • Imagick::stripImage ?
  • PHP Manual
  • Imagick
  • Composites two images

Imagick::stereoImage

(PECL imagick 2, PECL imagick 3)

Imagick::stereoImage — Composites two images

说明

public Imagick::stereoImage ( Imagick $offset_wand ) : bool

Composites two images and produces a single image that is the composite of a left and right image of a stereo pair.

参数

offset_wand

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


去掉图片的所有配置和设置

  • ? Imagick::stereoImage
  • Imagick::subImageMatch ?
  • PHP Manual
  • Imagick
  • 去掉图片的所有配置和设置

Imagick::stripImage

(PECL imagick 2, PECL imagick 3)

Imagick::stripImage — 去掉图片的所有配置和设置

说明

Imagick::stripImage ( ) : bool

去掉图片的所有配置和设置

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。


Description

  • ? Imagick::stripImage
  • Imagick::swirlImage ?
  • PHP Manual
  • Imagick
  • Description

Imagick::subImageMatch

(PECL imagick 3 >= 3.3.0)

Imagick::subImageMatch — Description

说明

public Imagick::subImageMatch ( Imagick $Imagick , array &$offset = ? , float &$similarity = ? ) : Imagick

Searches for a subimage in the current image and returns a similarity image such that an exact match location is completely white and if none of the pixels match, black, otherwise some gray level in-between. You can also pass in the optional parameters bestMatch and similarity. After calling the function similarity will be set to the 'score' of the similarity between the subimage and the matching position in the larger image, bestMatch will contain an associative array with elements x, y, width, height that describe the matching region.

参数

Imagick

offset

similarity

A new image that displays the amount of similarity at each pixel.

返回值

范例

Example #1 Imagick::subImageMatch()

<?php
function subImageMatch($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick2 = clone $imagick;
    $imagick2->cropimage(40, 40, 250, 110);
    $imagick2->vignetteimage(0, 1, 3, 3);

    $similarity = null;
    $bestMatch = null;
    $comparison = $imagick->subImageMatch($imagick2, $bestMatch, $similarity);

    $comparison->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Swirls the pixels about the center of the image

  • ? Imagick::subImageMatch
  • Imagick::textureImage ?
  • PHP Manual
  • Imagick
  • Swirls the pixels about the center of the image

Imagick::swirlImage

(PECL imagick 2, PECL imagick 3)

Imagick::swirlImage — Swirls the pixels about the center of the image

说明

Imagick::swirlImage ( float $degrees ) : bool

Swirls the pixels about the center of the image, where degrees indicates the sweep of the arc through which each pixel is moved. You get a more dramatic effect as the degrees move from 1 to 360.

参数

degrees

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::swirlImage()

<?php
function swirlImage($imagePath, $swirl) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->swirlImage($swirl);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Repeatedly tiles the texture image

  • ? Imagick::swirlImage
  • Imagick::thresholdImage ?
  • PHP Manual
  • Imagick
  • Repeatedly tiles the texture image

Imagick::textureImage

(PECL imagick 2, PECL imagick 3)

Imagick::textureImage — Repeatedly tiles the texture image

说明

Imagick::textureImage ( Imagick $texture_wand ) : Imagick

Repeatedly tiles the texture image across and down the image canvas.

参数

texture_wand

Imagick object to use as texture image

返回值

Returns a new Imagick object that has the repeated texture applied.

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::textureImage()

<?php
function textureImage($imagePath) {
    $image = new \Imagick();
    $image->newImage(640, 480, new \ImagickPixel('pink'));
    $image->setImageFormat("jpg");
    $texture = new \Imagick(realpath($imagePath));
    $texture->scaleimage($image->getimagewidth() / 4, $image->getimageheight() / 4);
    $image = $image->textureImage($texture);
    header("Content-Type: image/jpg");
    echo $image;
}

?>


Changes the value of individual pixels based on a threshold

  • ? Imagick::textureImage
  • Imagick::thumbnailImage ?
  • PHP Manual
  • Imagick
  • Changes the value of individual pixels based on a threshold

Imagick::thresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::thresholdImage — Changes the value of individual pixels based on a threshold

说明

public Imagick::thresholdImage ( float $threshold , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Changes the value of individual pixels based on the intensity of each pixel compared to threshold. The result is a high-contrast, two color image.

参数

threshold

channel

返回值

成功时返回 true。

范例

Example #1 Imagick::thresholdImage()

<?php
function thresholdimage($imagePath, $threshold, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->thresholdimage($threshold * \Imagick::getQuantum(), $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Changes the size of an image

  • ? Imagick::thresholdImage
  • Imagick::tintImage ?
  • PHP Manual
  • Imagick
  • Changes the size of an image

Imagick::thumbnailImage

(PECL imagick 2, PECL imagick 3)

Imagick::thumbnailImage — Changes the size of an image

说明

public Imagick::thumbnailImage ( int $columns , int $rows , bool $bestfit = false , bool $fill = false , bool $legacy = false ) : bool

Changes the size of an image to the given dimensions and removes any associated profiles. The goal is to produce small, low cost thumbnail images suited for display on the Web. If true is given as a third parameter then columns and rows parameters are used as maximums for each side. Both sides will be scaled down until they match or are smaller than the parameter given for the side.

Note: 参数 bestfit 的特性在 Imagick 3.0.0 中已改变。在此版本以前，当目标尺寸设为 400x400 时，原尺寸为 200x150 的图像将不会被改变。自 Imagick 3.0.0 起，源图像将会被放大到 400x300 因为这将更好的适合目标尺寸。当使用参数 bestfit 时，必须同时给出宽度和高度。

参数

columns

Image width

rows

Image height

bestfit

Whether to force maximum values

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::thumbnailImage()

<?php
function thumbnailImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setbackgroundcolor('rgb(64, 64, 64)');
    $imagick->thumbnailImage(100, 100, true, true);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Applies a color vector to each pixel in the image

  • ? Imagick::thumbnailImage
  • Imagick::__toString ?
  • PHP Manual
  • Imagick
  • Applies a color vector to each pixel in the image

Imagick::tintImage

(PECL imagick 2, PECL imagick 3)

Imagick::tintImage — Applies a color vector to each pixel in the image

说明

public Imagick::tintImage ( mixed $tint , mixed $opacity , bool $legacy = false ) : bool

Applies a color vector to each pixel in the image. The length of the vector is 0 for black and white and at its maximum for the midtones. The vector weighing function is f(x)=(1-(4.0*((x-0.5)*(x-0.5)))).

参数

tint

opacity

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as the first parameter and a float representing the opacity value as the second parameter. Previous versions allow only an ImagickPixel objects.

范例

Example #1 Imagick::tintImage()

<?php
function tintImage($r, $g, $b, $a) {
    $a = $a / 100;

    $imagick = new \Imagick();
    $imagick->newPseudoImage(400, 400, 'gradient:black-white');

    $tint = new \ImagickPixel("rgb($r, $g, $b)");
    $opacity = new \ImagickPixel("rgb(128, 128, 128, $a)");
    $imagick->tintImage($tint, $opacity);
    $imagick->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Returns the image as a string

  • ? Imagick::tintImage
  • Imagick::transformImage ?
  • PHP Manual
  • Imagick
  • Returns the image as a string

Imagick::__toString

(PECL imagick 2, PECL imagick 3)

Imagick::__toString — Returns the image as a string

说明

public Imagick::__toString ( ) : string

Returns the current image as string. This will only return a single image; it should not be used for Imagick objects that contain multiple images e.g. an animated GIF or PDF with multiple pages.

参数

此函数没有参数。

返回值

Returns the string content on success or an empty string on failure.

参见

  • Imagick::getImageBlob() - Returns the image sequence as a blob
  • Imagick::getImagesBlob() - Returns all image sequences as a blob


Convenience method for setting crop size and the image geometry

  • ? Imagick::__toString
  • Imagick::transformImageColorspace ?
  • PHP Manual
  • Imagick
  • Convenience method for setting crop size and the image geometry

Imagick::transformImage

(PECL imagick 2, PECL imagick 3)

Imagick::transformImage — Convenience method for setting crop size and the image geometry

Warning

此函数在 Imagick 3.4.4 中被 废弃，强烈建议不要应用此函数。

说明

public Imagick::transformImage ( string $crop , string $geometry ) : Imagick

A convenience method for setting crop size and the image geometry from strings. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

crop

A crop geometry string. This geometry defines a subregion of the image to crop.

geometry

An image geometry string. This geometry defines the final size of the image.

返回值

Returns an Imagick object containing the transformed image.

范例

Example #1 Using Imagick::transformImage():

The example creates a 100x100 black image.

<?php
$image = new Imagick();
$image->newImage(300, 200, "black");
$new_image = $image->transformImage("100x100", "100x100");
$new_image->writeImage('test_out.jpg');
?>

参见

  • Imagick::cropImage() - 截图图片的一块区域
  • Imagick::resizeImage() - Scales an image
  • Imagick::thumbnailImage() - Changes the size of an image


Transforms an image to a new colorspace

  • ? Imagick::transformImage
  • Imagick::transparentPaintImage ?
  • PHP Manual
  • Imagick
  • Transforms an image to a new colorspace

Imagick::transformImageColorspace

(PECL imagick 3)

Imagick::transformImageColorspace — Transforms an image to a new colorspace

说明

public Imagick::transformImageColorspace ( int $colorspace ) : bool

Transforms an image to a new colorspace.

参数

colorspace

The colorspace the image should be transformed to, one of the COLORSPACE constants e.g. Imagick::COLORSPACE_CMYK.

返回值

成功时返回 true。

范例

Example #1 Imagick::transformImageColorspace() example

Transforms an image to a new colorspace, and then extracts a single channel so that the individual channel values can be viewed.

<?php
function transformImageColorspace($imagePath, $colorSpace, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transformimagecolorspace($colorSpace);
    //channel should be one of the channel constants e.g. \Imagick::CHANNEL_BLUE
    $imagick->separateImageChannel($channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}
?>

参见

  • Imagick::setColorSpace() - Set colorspace

范例

Example #2 Imagick::transformImageColorspace()

<?php
function transformImageColorspace($imagePath, $colorSpace, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transformimagecolorspace($colorSpace);
    $imagick->separateImageChannel($channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Paints pixels transparent

  • ? Imagick::transformImageColorspace
  • Imagick::transposeImage ?
  • PHP Manual
  • Imagick
  • Paints pixels transparent

Imagick::transparentPaintImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::transparentPaintImage — Paints pixels transparent

说明

public Imagick::transparentPaintImage ( mixed $target , float $alpha , float $fuzz , bool $invert ) : bool

Paints pixels matching the target color transparent. 此方法在Imagick基于ImageMagick 6.3.8以上版本编译时可用。

参数

target

The target color to paint

alpha

透明级别：1.0 是完全不透明，0.0 是完全透明。

fuzz

The amount of fuzz. For example, set fuzz to 10 and the color red at intensities of 100 and 102 respectively are now interpreted as the same color.

invert

If true paints any pixel that does not match the target color.

返回值

成功时返回 true。

范例

Example #1 Imagick::transparentPaintImage()

<?php
function transparentPaintImage($color, $alpha, $fuzz) {
    $imagick = new \Imagick(realpath("images/BlueScreen.jpg"));

    //Need to be in a format that supports transparency
    $imagick->setimageformat('png');

    $imagick->transparentPaintImage(
        $color, $alpha, $fuzz * \Imagick::getQuantum(), false
    );

    //Not required, but helps tidy up left over pixels
    $imagick->despeckleimage();

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Creates a vertical mirror image

  • ? Imagick::transparentPaintImage
  • Imagick::transverseImage ?
  • PHP Manual
  • Imagick
  • Creates a vertical mirror image

Imagick::transposeImage

(PECL imagick 2, PECL imagick 3)

Imagick::transposeImage — Creates a vertical mirror image

说明

public Imagick::transposeImage ( ) : bool

Creates a vertical mirror image by reflecting the pixels around the central x-axis while rotating them 90-degrees. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

返回值

成功时返回 true。

参见

  • Imagick::transverseImage() - Creates a horizontal mirror image

范例

Example #1 Imagick::transposeImage()

<?php
function transposeImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transposeImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Creates a horizontal mirror image

  • ? Imagick::transposeImage
  • Imagick::trimImage ?
  • PHP Manual
  • Imagick
  • Creates a horizontal mirror image

Imagick::transverseImage

(PECL imagick 2, PECL imagick 3)

Imagick::transverseImage — Creates a horizontal mirror image

说明

public Imagick::transverseImage ( ) : bool

Creates a horizontal mirror image by reflecting the pixels around the central y-axis while rotating them 270-degrees. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

返回值

成功时返回 true。

参见

  • Imagick::transposeImage() - Creates a vertical mirror image

范例

Example #1 Imagick::transverseImage()

<?php
function transverseImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transverseImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Remove edges from the image

  • ? Imagick::transverseImage
  • Imagick::uniqueImageColors ?
  • PHP Manual
  • Imagick
  • Remove edges from the image

Imagick::trimImage

(PECL imagick 2, PECL imagick 3)

Imagick::trimImage — Remove edges from the image

说明

public Imagick::trimImage ( float $fuzz ) : bool

Remove edges that are the background color from the image. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

fuzz

By default target must match a particular pixel color exactly. However, in many cases two colors may differ by a small amount. The fuzz member of image defines how much tolerance is acceptable to consider two colors as the same. This parameter represents the variation on the quantum range.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Using Imagick::trimImage():

Trim an image, then display to the browser.

<?php
/* Create the object and read the image in */
$im = new Imagick("image.jpg");

/* Trim the image. */
$im->trimImage(0);

/* Ouput the image */
header("Content-Type: image/" . $im->getImageFormat());
echo $im;
?>

参见

  • Imagick::getQuantumDepth() - Gets the quantum depth
  • Imagick::getQuantumRange() - Returns the Imagick quantum range
  • imagecropauto() - Crop an image automatically using one of the available modes


Discards all but one of any pixel color

  • ? Imagick::trimImage
  • Imagick::unsharpMaskImage ?
  • PHP Manual
  • Imagick
  • Discards all but one of any pixel color

Imagick::uniqueImageColors

(PECL imagick 2,PECL imagick 3)

Imagick::uniqueImageColors — Discards all but one of any pixel color

说明

public Imagick::uniqueImageColors ( ) : bool

Discards all but one of any pixel color. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

返回值

成功时返回 true。

范例

Example #1 Imagick::uniqueImageColors()

<?php
function uniqueImageColors($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    //Reduce the image to 256 colours nicely.
    $imagick->quantizeImage(256, \Imagick::COLORSPACE_YIQ, 0, false, false);
    $imagick->uniqueImageColors();
    $imagick->scaleimage($imagick->getImageWidth(), $imagick->getImageHeight() * 20);
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sharpens an image

  • ? Imagick::uniqueImageColors
  • Imagick::valid ?
  • PHP Manual
  • Imagick
  • Sharpens an image

Imagick::unsharpMaskImage

(PECL imagick 2, PECL imagick 3)

Imagick::unsharpMaskImage — Sharpens an image

说明

public Imagick::unsharpMaskImage ( float $radius , float $sigma , float $amount , float $threshold , int $channel = Imagick::CHANNEL_DEFAULT ) : bool

Sharpens an image. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and Imagick::UnsharpMaskImage() selects a suitable radius for you.

参数

radius

sigma

amount

threshold

channel

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

范例

Example #1 Imagick::unsharpMaskImage()

<?php
function unsharpMaskImage($imagePath, $radius, $sigma, $amount, $unsharpThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->unsharpMaskImage($radius, $sigma, $amount, $unsharpThreshold);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Checks if the current item is valid

  • ? Imagick::unsharpMaskImage
  • Imagick::vignetteImage ?
  • PHP Manual
  • Imagick
  • Checks if the current item is valid

Imagick::valid

(PECL imagick 2, PECL imagick 3)

Imagick::valid — Checks if the current item is valid

说明

public Imagick::valid ( ) : bool

Checks if the current item is valid.

返回值

成功时返回 true。


Adds vignette filter to the image

  • ? Imagick::valid
  • Imagick::waveImage ?
  • PHP Manual
  • Imagick
  • Adds vignette filter to the image

Imagick::vignetteImage

(PECL imagick 2, PECL imagick 3)

Imagick::vignetteImage — Adds vignette filter to the image

说明

public Imagick::vignetteImage ( float $blackPoint , float $whitePoint , int $x , int $y ) : bool

Softens the edges of the image in vignette style. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

blackPoint

The black point.

whitePoint

The white point

x

X offset of the ellipse

y

Y offset of the ellipse

返回值

成功时返回 true。

参见

  • Imagick::waveImage() - Applies wave filter to the image
  • Imagick::swirlImage() - Swirls the pixels about the center of the image

范例

Example #1 Imagick::vignetteImage()

<?php
function vignetteImage($imagePath, $blackPoint, $whitePoint, $x, $y) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->vignetteImage($blackPoint, $whitePoint, $x, $y);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Applies wave filter to the image

  • ? Imagick::vignetteImage
  • Imagick::whiteThresholdImage ?
  • PHP Manual
  • Imagick
  • Applies wave filter to the image

Imagick::waveImage

(PECL imagick 2, PECL imagick 3)

Imagick::waveImage — Applies wave filter to the image

说明

public Imagick::waveImage ( float $amplitude , float $length ) : bool

Applies a wave filter to the image. 此方法在Imagick基于ImageMagick 6.2.9以上版本编译时可用。

参数

amplitude

The amplitude of the wave.

length

The length of the wave.

返回值

成功时返回 true。

错误／异常

错误时抛出 ImagickException。

参见

  • Imagick::solarizeImage() - Applies a solarizing effect to the image
  • Imagick::oilpaintImage() - Simulates an oil painting
  • Imagick::embossImage() - Returns a grayscale image with a three-dimensional effect
  • Imagick::addNoiseImage() - Adds random noise to the image
  • Imagick::swirlImage() - Swirls the pixels about the center of the image

范例

Example #1 WaveImage can be quite slow Imagick::waveImage()

<?php
function waveImage($imagePath, $amplitude, $length) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->waveImage($amplitude, $length);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


Force all pixels above the threshold into white

  • ? Imagick::waveImage
  • Imagick::writeImage ?
  • PHP Manual
  • Imagick
  • Force all pixels above the threshold into white

Imagick::whiteThresholdImage

(PECL imagick 2, PECL imagick 3)

Imagick::whiteThresholdImage — Force all pixels above the threshold into white

说明

public Imagick::whiteThresholdImage ( mixed $threshold ) : bool

Is like Imagick::ThresholdImage() but force all pixels above the threshold into white while leaving all pixels below the threshold unchanged.

参数

threshold

返回值

成功时返回 true。

更新日志

版本 | 说明
PECL imagick 2.1.0 | Now allows a string representing the color as a parameter. Previous versions allow only an ImagickPixel object.

范例

Example #1 Imagick::whiteThresholdImage()

<?php
function whiteThresholdImage($imagePath, $color) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->whiteThresholdImage($color);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>


把图片写入指定的文件

  • ? Imagick::whiteThresholdImage
  • Imagick::writeImageFile ?
  • PHP Manual
  • Imagick
  • 把图片写入指定的文件

Imagick::writeImage

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::writeImage — 把图片写入指定的文件

说明

Imagick::writeImage ( string $filename = NULL ) : bool

把图片写入指定的文件。如果指定文件参数的值是 NULL ，图片将会写入通过 Imagick::readImage() 或者 Imagick::setImageFilename() 设定的文件。

参数

filename

图片将被写入的文件名。文件的后缀指定了文件的类型。 可以强制指定图片的格式而不管文件的后缀名。在文件名前面加上一个前缀，例如 "jpg:test.png"。

返回值

成功时返回 true。


Writes an image to a filehandle

  • ? Imagick::writeImage
  • Imagick::writeImages ?
  • PHP Manual
  • Imagick
  • Writes an image to a filehandle

Imagick::writeImageFile

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::writeImageFile — Writes an image to a filehandle

说明

public Imagick::writeImageFile ( resource $filehandle , string $format = ? ) : bool

Writes the image sequence to an open filehandle. The handle must be opened with for example fopen. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

filehandle

Filehandle where to write the image

返回值

成功时返回 true。


Writes an image or image sequence

  • ? Imagick::writeImageFile
  • Imagick::writeImagesFile ?
  • PHP Manual
  • Imagick
  • Writes an image or image sequence

Imagick::writeImages

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::writeImages — Writes an image or image sequence

说明

public Imagick::writeImages ( string $filename , bool $adjoin ) : bool

Writes an image or image sequence.

参数

filename

adjoin

返回值

成功时返回 true。


Writes frames to a filehandle

  • ? Imagick::writeImages
  • ImagickDraw ?
  • PHP Manual
  • Imagick
  • Writes frames to a filehandle

Imagick::writeImagesFile

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

Imagick::writeImagesFile — Writes frames to a filehandle

说明

public Imagick::writeImagesFile ( resource $filehandle , string $format = ? ) : bool

Writes all image frames into an open filehandle. This method can be used to write animated gifs or other multiframe images into open filehandle. 此方法在Imagick基于ImageMagick 6.3.6以上版本编译时可用。

参数

filehandle

Filehandle where to write the images

返回值

成功时返回 true。


The ImagickDraw class

(PECL imagick 2, PECL imagick 3)

类摘要

ImagickDraw {
public affine ( array $affine ) : bool
public annotation ( float $x , float $y , string $text ) : bool
public arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed ) : bool
public bezier ( array $coordinates ) : bool
public circle ( float $ox , float $oy , float $px , float $py ) : bool
public clear ( ) : bool
public clone ( ) : ImagickDraw
public color ( float $x , float $y , int $paintMethod ) : bool
public comment ( string $comment ) : bool
public composite ( int $compose , float $x , float $y , float $width , float $height , Imagick $compositeWand ) : bool
public __construct ( )
public destroy ( ) : bool
public ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end ) : bool
public getClipPath ( ) : string
public getClipRule ( ) : int
public getClipUnits ( ) : int
public getFillColor ( ) : ImagickPixel
public getFillOpacity ( ) : float
public getFillRule ( ) : int
public getFont ( ) : string
public getFontFamily ( ) : string
public getFontSize ( ) : float
public getFontStretch ( ) : int
public getFontStyle ( ) : int
public getFontWeight ( ) : int
public getGravity ( ) : int
public getStrokeAntialias ( ) : bool
public getStrokeColor ( ) : ImagickPixel
public getStrokeDashArray ( ) : array
public getStrokeDashOffset ( ) : float
public getStrokeLineCap ( ) : int
public getStrokeLineJoin ( ) : int
public getStrokeMiterLimit ( ) : int
public getStrokeOpacity ( ) : float
public getStrokeWidth ( ) : float
public getTextAlignment ( ) : int
public getTextAntialias ( ) : bool
public getTextDecoration ( ) : int
public getTextEncoding ( ) : string
public getTextInterlineSpacing ( ) : float
public getTextInterwordSpacing ( ) : float
public getTextKerning ( ) : float
public getTextUnderColor ( ) : ImagickPixel
public getVectorGraphics ( ) : string
public line ( float $sx , float $sy , float $ex , float $ey ) : bool
public matte ( float $x , float $y , int $paintMethod ) : bool
public pathClose ( ) : bool
public pathCurveToAbsolute ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y ) : bool
public pathCurveToQuadraticBezierAbsolute ( float $x1 , float $y1 , float $x , float $y ) : bool
public pathCurveToQuadraticBezierRelative ( float $x1 , float $y1 , float $x , float $y ) : bool
public pathCurveToQuadraticBezierSmoothAbsolute ( float $x , float $y ) : bool
public pathCurveToQuadraticBezierSmoothRelative ( float $x , float $y ) : bool
public pathCurveToRelative ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y ) : bool
public pathCurveToSmoothAbsolute ( float $x2 , float $y2 , float $x , float $y ) : bool
public pathCurveToSmoothRelative ( float $x2 , float $y2 , float $x , float $y ) : bool
public pathEllipticArcAbsolute ( float $rx , float $ry , float $x_axis_rotation , bool $large_arc_flag , bool $sweep_flag , float $x , float $y ) : bool
public pathEllipticArcRelative ( float $rx , float $ry , float $x_axis_rotation , bool $large_arc_flag , bool $sweep_flag , float $x , float $y ) : bool
public pathFinish ( ) : bool
public pathLineToAbsolute ( float $x , float $y ) : bool
public pathLineToHorizontalAbsolute ( float $x ) : bool
public pathLineToHorizontalRelative ( float $x ) : bool
public pathLineToRelative ( float $x , float $y ) : bool
public pathLineToVerticalAbsolute ( float $y ) : bool
public pathLineToVerticalRelative ( float $y ) : bool
public pathMoveToAbsolute ( float $x , float $y ) : bool
public pathMoveToRelative ( float $x , float $y ) : bool
public pathStart ( ) : bool
public point ( float $x , float $y ) : bool
public polygon ( array $coordinates ) : bool
public polyline ( array $coordinates ) : bool
public pop ( ) : bool
public popClipPath ( ) : bool
public popDefs ( ) : bool
public popPattern ( ) : bool
public push ( ) : bool
public pushClipPath ( string $clip_mask_id ) : bool
public pushDefs ( ) : bool
public pushPattern ( string $pattern_id , float $x , float $y , float $width , float $height ) : bool
public rectangle ( float $x1 , float $y1 , float $x2 , float $y2 ) : bool
public render ( ) : bool
public resetVectorGraphics ( ) : bool
public rotate ( float $degrees ) : bool
public roundRectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry ) : bool
public scale ( float $x , float $y ) : bool
public setClipPath ( string $clip_mask ) : bool
public setClipRule ( int $fill_rule ) : bool
public setClipUnits ( int $clip_units ) : bool
public setFillAlpha ( float $opacity ) : bool
public setFillColor ( ImagickPixel $fill_pixel ) : bool
public setFillOpacity ( float $fillOpacity ) : bool
public setFillPatternURL ( string $fill_url ) : bool
public setFillRule ( int $fill_rule ) : bool
public setFont ( string $font_name ) : bool
public setFontFamily ( string $font_family ) : bool
public setFontSize ( float $pointsize ) : bool
public setFontStretch ( int $fontStretch ) : bool
public setFontStyle ( int $style ) : bool
public setFontWeight ( int $font_weight ) : bool
public setGravity ( int $gravity ) : bool
public setResolution ( float $x_resolution , float $y_resolution ) : bool
public setStrokeAlpha ( float $opacity ) : bool
public setStrokeAntialias ( bool $stroke_antialias ) : bool
public setStrokeColor ( ImagickPixel $stroke_pixel ) : bool
public setStrokeDashArray ( array $dashArray ) : bool
public setStrokeDashOffset ( float $dash_offset ) : bool
public setStrokeLineCap ( int $linecap ) : bool
public setStrokeLineJoin ( int $linejoin ) : bool
public setStrokeMiterLimit ( int $miterlimit ) : bool
public setStrokeOpacity ( float $stroke_opacity ) : bool
public setStrokePatternURL ( string $stroke_url ) : bool
public setStrokeWidth ( float $stroke_width ) : bool
public setTextAlignment ( int $alignment ) : bool
public setTextAntialias ( bool $antiAlias ) : bool
public setTextDecoration ( int $decoration ) : bool
public setTextEncoding ( string $encoding ) : bool
public setTextInterlineSpacing ( float $spacing ) : bool
public setTextInterwordSpacing ( float $spacing ) : bool
public setTextKerning ( float $kerning ) : bool
public setTextUnderColor ( ImagickPixel $under_color ) : bool
public setVectorGraphics ( string $xml ) : bool
public setViewbox ( int $x1 , int $y1 , int $x2 , int $y2 ) : bool
public skewX ( float $degrees ) : bool
public skewY ( float $degrees ) : bool
public translate ( float $x , float $y ) : bool
}

Table of Contents

  • ImagickDraw::affine — Adjusts the current affine transformation matrix
  • ImagickDraw::annotation — Draws text on the image
  • ImagickDraw::arc — Draws an arc
  • ImagickDraw::bezier — Draws a bezier curve
  • ImagickDraw::circle — Draws a circle
  • ImagickDraw::clear — Clears the ImagickDraw
  • ImagickDraw::clone — Makes an exact copy of the specified ImagickDraw object
  • ImagickDraw::color — Draws color on image
  • ImagickDraw::comment — Adds a comment
  • ImagickDraw::composite — Composites an image onto the current image
  • ImagickDraw::__construct — The ImagickDraw constructor
  • ImagickDraw::destroy — Frees all associated resources
  • ImagickDraw::ellipse — Draws an ellipse on the image
  • ImagickDraw::getClipPath — Obtains the current clipping path ID
  • ImagickDraw::getClipRule — Returns the current polygon fill rule
  • ImagickDraw::getClipUnits — Returns the interpretation of clip path units
  • ImagickDraw::getFillColor — Returns the fill color
  • ImagickDraw::getFillOpacity — Returns the opacity used when drawing
  • ImagickDraw::getFillRule — Returns the fill rule
  • ImagickDraw::getFont — Returns the font
  • ImagickDraw::getFontFamily — Returns the font family
  • ImagickDraw::getFontSize — Returns the font pointsize
  • ImagickDraw::getFontStretch — Description
  • ImagickDraw::getFontStyle — Returns the font style
  • ImagickDraw::getFontWeight — Returns the font weight
  • ImagickDraw::getGravity — Returns the text placement gravity
  • ImagickDraw::getStrokeAntialias — Returns the current stroke antialias setting
  • ImagickDraw::getStrokeColor — Returns the color used for stroking object outlines
  • ImagickDraw::getStrokeDashArray — Returns an array representing the pattern of dashes and gaps used to stroke paths
  • ImagickDraw::getStrokeDashOffset — Returns the offset into the dash pattern to start the dash
  • ImagickDraw::getStrokeLineCap — Returns the shape to be used at the end of open subpaths when they are stroked
  • ImagickDraw::getStrokeLineJoin — Returns the shape to be used at the corners of paths when they are stroked
  • ImagickDraw::getStrokeMiterLimit — Returns the stroke miter limit
  • ImagickDraw::getStrokeOpacity — Returns the opacity of stroked object outlines
  • ImagickDraw::getStrokeWidth — Returns the width of the stroke used to draw object outlines
  • ImagickDraw::getTextAlignment — Returns the text alignment
  • ImagickDraw::getTextAntialias — Returns the current text antialias setting
  • ImagickDraw::getTextDecoration — Returns the text decoration
  • ImagickDraw::getTextEncoding — Returns the code set used for text annotations
  • ImagickDraw::getTextInterlineSpacing — Description
  • ImagickDraw::getTextInterwordSpacing — Description
  • ImagickDraw::getTextKerning — Description
  • ImagickDraw::getTextUnderColor — Returns the text under color
  • ImagickDraw::getVectorGraphics — Returns a string containing vector graphics
  • ImagickDraw::line — Draws a line
  • ImagickDraw::matte — Paints on the image's opacity channel
  • ImagickDraw::pathClose — Adds a path element to the current path
  • ImagickDraw::pathCurveToAbsolute — Draws a cubic Bezier curve
  • ImagickDraw::pathCurveToQuadraticBezierAbsolute — Draws a quadratic Bezier curve
  • ImagickDraw::pathCurveToQuadraticBezierRelative — Draws a quadratic Bezier curve
  • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — Draws a quadratic Bezier curve
  • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — Draws a quadratic Bezier curve
  • ImagickDraw::pathCurveToRelative — Draws a cubic Bezier curve
  • ImagickDraw::pathCurveToSmoothAbsolute — Draws a cubic Bezier curve
  • ImagickDraw::pathCurveToSmoothRelative — Draws a cubic Bezier curve
  • ImagickDraw::pathEllipticArcAbsolute — Draws an elliptical arc
  • ImagickDraw::pathEllipticArcRelative — Draws an elliptical arc
  • ImagickDraw::pathFinish — Terminates the current path
  • ImagickDraw::pathLineToAbsolute — Draws a line path
  • ImagickDraw::pathLineToHorizontalAbsolute — Draws a horizontal line path
  • ImagickDraw::pathLineToHorizontalRelative — Draws a horizontal line
  • ImagickDraw::pathLineToRelative — Draws a line path
  • ImagickDraw::pathLineToVerticalAbsolute — Draws a vertical line
  • ImagickDraw::pathLineToVerticalRelative — Draws a vertical line path
  • ImagickDraw::pathMoveToAbsolute — Starts a new sub-path
  • ImagickDraw::pathMoveToRelative — Starts a new sub-path
  • ImagickDraw::pathStart — Declares the start of a path drawing list
  • ImagickDraw::point — Draws a point
  • ImagickDraw::polygon — Draws a polygon
  • ImagickDraw::polyline — Draws a polyline
  • ImagickDraw::pop — Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw
  • ImagickDraw::popClipPath — Terminates a clip path definition
  • ImagickDraw::popDefs — Terminates a definition list
  • ImagickDraw::popPattern — Terminates a pattern definition
  • ImagickDraw::push — Clones the current ImagickDraw and pushes it to the stack
  • ImagickDraw::pushClipPath — Starts a clip path definition
  • ImagickDraw::pushDefs — Indicates that following commands create named elements for early processing
  • ImagickDraw::pushPattern — Indicates that subsequent commands up to a ImagickDraw::opPattern() command comprise the definition of a named pattern
  • ImagickDraw::rectangle — Draws a rectangle
  • ImagickDraw::render — Renders all preceding drawing commands onto the image
  • ImagickDraw::resetVectorGraphics — Description
  • ImagickDraw::rotate — Applies the specified rotation to the current coordinate space
  • ImagickDraw::roundRectangle — Draws a rounded rectangle
  • ImagickDraw::scale — Adjusts the scaling factor
  • ImagickDraw::setClipPath — Associates a named clipping path with the image
  • ImagickDraw::setClipRule — Set the polygon fill rule to be used by the clipping path
  • ImagickDraw::setClipUnits — Sets the interpretation of clip path units
  • ImagickDraw::setFillAlpha — Sets the opacity to use when drawing using the fill color or fill texture
  • ImagickDraw::setFillColor — Sets the fill color to be used for drawing filled objects
  • ImagickDraw::setFillOpacity — Sets the opacity to use when drawing using the fill color or fill texture
  • ImagickDraw::setFillPatternURL — Sets the URL to use as a fill pattern for filling objects
  • ImagickDraw::setFillRule — Sets the fill rule to use while drawing polygons
  • ImagickDraw::setFont — Sets the fully-specified font to use when annotating with text
  • ImagickDraw::setFontFamily — Sets the font family to use when annotating with text
  • ImagickDraw::setFontSize — Sets the font pointsize to use when annotating with text
  • ImagickDraw::setFontStretch — Sets the font stretch to use when annotating with text
  • ImagickDraw::setFontStyle — Sets the font style to use when annotating with text
  • ImagickDraw::setFontWeight — Sets the font weight
  • ImagickDraw::setGravity — Sets the text placement gravity
  • ImagickDraw::setResolution — Description
  • ImagickDraw::setStrokeAlpha — Specifies the opacity of stroked object outlines
  • ImagickDraw::setStrokeAntialias — Controls whether stroked outlines are antialiased
  • ImagickDraw::setStrokeColor — Sets the color used for stroking object outlines
  • ImagickDraw::setStrokeDashArray — Specifies the pattern of dashes and gaps used to stroke paths
  • ImagickDraw::setStrokeDashOffset — Specifies the offset into the dash pattern to start the dash
  • ImagickDraw::setStrokeLineCap — Specifies the shape to be used at the end of open subpaths when they are stroked
  • ImagickDraw::setStrokeLineJoin — Specifies the shape to be used at the corners of paths when they are stroked
  • ImagickDraw::setStrokeMiterLimit — Specifies the miter limit
  • ImagickDraw::setStrokeOpacity — Specifies the opacity of stroked object outlines
  • ImagickDraw::setStrokePatternURL — Sets the pattern used for stroking object outlines
  • ImagickDraw::setStrokeWidth — Sets the width of the stroke used to draw object outlines
  • ImagickDraw::setTextAlignment — Specifies a text alignment
  • ImagickDraw::setTextAntialias — Controls whether text is antialiased
  • ImagickDraw::setTextDecoration — Specifies a decoration
  • ImagickDraw::setTextEncoding — Specifies the text code set
  • ImagickDraw::setTextInterlineSpacing — Description
  • ImagickDraw::setTextInterwordSpacing — Description
  • ImagickDraw::setTextKerning — Description
  • ImagickDraw::setTextUnderColor — Specifies the color of a background rectangle
  • ImagickDraw::setVectorGraphics — Sets the vector graphics
  • ImagickDraw::setViewbox — Sets the overall canvas size
  • ImagickDraw::skewX — Skews the current coordinate system in the horizontal direction
  • ImagickDraw::skewY — Skews the current coordinate system in the vertical direction
  • ImagickDraw::translate — Applies a translation to the current coordinate system


Adjusts the current affine transformation matrix

  • ? ImagickDraw
  • ImagickDraw::annotation ?
  • PHP Manual
  • ImagickDraw
  • Adjusts the current affine transformation matrix

ImagickDraw::affine

(PECL imagick 2, PECL imagick 3)

ImagickDraw::affine — Adjusts the current affine transformation matrix

说明

public ImagickDraw::affine ( array $affine ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Adjusts the current affine transformation matrix with the specified affine transformation matrix.

参数

affine

Affine matrix parameters

返回值

没有返回值。

范例

Example #1 ImagickDraw::affine()

<?php
function affine($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeWidth(1);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);

    $PI = 3.141592653589794;
    $angle = 60 * $PI / 360;

    //Scale the drawing co-ordinates.
    $affineScale = array("sx" => 1.75, "sy" => 1.75, "rx" => 0, "ry" => 0, "tx" => 0, "ty" => 0);

    //Shear the drawing co-ordinates.
    $affineShear = array("sx" => 1, "sy" => 1, "rx" => sin($angle), "ry" => -sin($angle), "tx" => 0, "ty" => 0);

    //Rotate the drawing co-ordinates. The shear affine matrix
    //produces incorrectly scaled drawings.
    $affineRotate = array("sx" => cos($angle), "sy" => cos($angle), "rx" => sin($angle), "ry" => -sin($angle), "tx" => 0, "ty" => 0,);

    //Translate (offset) the drawing
    $affineTranslate = array("sx" => 1, "sy" => 1, "rx" => 0, "ry" => 0, "tx" => 30, "ty" => 30);

    //The identiy affine matrix
    $affineIdentity = array("sx" => 1, "sy" => 1, "rx" => 0, "ry" => 0, "tx" => 0, "ty" => 0);

    $examples = [$affineScale, $affineShear, $affineRotate, $affineTranslate, $affineIdentity,];

    $count = 0;

    foreach ($examples as $example) {
        $draw->push();
        $draw->translate(($count % 2) * 250, intval($count / 2) * 250);
        $draw->translate(100, 100);
        $draw->affine($example);
        $draw->rectangle(-50, -50, 50, 50);
        $draw->pop();
        $count++;
    }

    //Create an image object which the draw commands can be rendered into
    $image = new \Imagick();
    $image->newImage(500, 750, $backgroundColor);
    $image->setImageFormat("png");

    //Render the draw commands in the ImagickDraw object
    //into the image.
    $image->drawImage($draw);

    //Send the image to the browser
    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Draws text on the image

  • ? ImagickDraw::affine
  • ImagickDraw::arc ?
  • PHP Manual
  • ImagickDraw
  • Draws text on the image

ImagickDraw::annotation

(PECL imagick 2, PECL imagick 3)

ImagickDraw::annotation — Draws text on the image

说明

public ImagickDraw::annotation ( float $x , float $y , string $text ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws text on the image.

参数

x

The x coordinate where text is drawn

y

The y coordinate where text is drawn

text

The text to draw on the image

返回值

没有返回值。


Draws an arc

  • ? ImagickDraw::annotation
  • ImagickDraw::bezier ?
  • PHP Manual
  • ImagickDraw
  • Draws an arc

ImagickDraw::arc

(PECL imagick 2, PECL imagick 3)

ImagickDraw::arc — Draws an arc

说明

public ImagickDraw::arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws an arc falling within a specified bounding rectangle on the image.

参数

sx

Starting x ordinate of bounding rectangle

sy

starting y ordinate of bounding rectangle

ex

ending x ordinate of bounding rectangle

ey

ending y ordinate of bounding rectangle

sd

starting degrees of rotation

ed

ending degrees of rotation

返回值

没有返回值。

范例

Example #1 ImagickDraw::arc()

<?php
function arc($strokeColor, $fillColor, $backgroundColor, $startX, $startY, $endX, $endY, $startAngle, $endAngle) {

    //Create a ImagickDraw object to draw into.
    $draw = new \ImagickDraw();
    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);

    $draw->arc($startX, $startY, $endX, $endY, $startAngle, $endAngle);

    //Create an image object which the draw commands can be rendered into
    $image = new \Imagick();
    $image->newImage(IMAGE_WIDTH, IMAGE_HEIGHT, $backgroundColor);
    $image->setImageFormat("png");

    //Render the draw commands in the ImagickDraw object
    //into the image.
    $image->drawImage($draw);

    //Send the image to the browser
    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Draws a bezier curve

  • ? ImagickDraw::arc
  • ImagickDraw::circle ?
  • PHP Manual
  • ImagickDraw
  • Draws a bezier curve

ImagickDraw::bezier

(PECL imagick 2, PECL imagick 3)

ImagickDraw::bezier — Draws a bezier curve

说明

public ImagickDraw::bezier ( array $coordinates ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a bezier curve through a set of points on the image.

参数

coordinates

Multidimensional array like array( array( 'x' => 1, 'y' => 2 ), array( 'x' => 3, 'y' => 4 ) )

返回值

没有返回值。

范例

Example #1 ImagickDraw::bezier()

<?php
function bezier($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $strokeColor = new \ImagickPixel($strokeColor);
    $fillColor = new \ImagickPixel($fillColor);

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);

    $smoothPointsSet = [
        [
            ['x' => 10.0 * 5, 'y' => 10.0 * 5],
            ['x' => 30.0 * 5, 'y' => 90.0 * 5],
            ['x' => 25.0 * 5, 'y' => 10.0 * 5],
            ['x' => 50.0 * 5, 'y' => 50.0 * 5],
        ],
        [
            ['x' => 50.0 * 5, 'y' => 50.0 * 5],
            ['x' => 75.0 * 5, 'y' => 90.0 * 5],
            ['x' => 70.0 * 5, 'y' => 10.0 * 5],
            ['x' => 90.0 * 5, 'y' => 40.0 * 5],
        ],
    ];

    foreach ($smoothPointsSet as $points) {
        $draw->bezier($points);
    }

    $disjointPoints = [
        [
            ['x' => 10 * 5, 'y' => 10 * 5],
            ['x' => 30 * 5, 'y' => 90 * 5],
            ['x' => 25 * 5, 'y' => 10 * 5],
            ['x' => 50 * 5, 'y' => 50 * 5],
        ],
        [
            ['x' => 50 * 5, 'y' => 50 * 5],
            ['x' => 80 * 5, 'y' => 50 * 5],
            ['x' => 70 * 5, 'y' => 10 * 5],
            ['x' => 90 * 5, 'y' => 40 * 5],
         ]
    ];
    $draw->translate(0, 200);

    foreach ($disjointPoints as $points) {
        $draw->bezier($points);
    }

    //Create an image object which the draw commands can be rendered into
    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    //Render the draw commands in the ImagickDraw object
    //into the image.
    $imagick->drawImage($draw);

    //Send the image to the browser
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Draws a circle

  • ? ImagickDraw::bezier
  • ImagickDraw::clear ?
  • PHP Manual
  • ImagickDraw
  • Draws a circle

ImagickDraw::circle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::circle — Draws a circle

说明

public ImagickDraw::circle ( float $ox , float $oy , float $px , float $py ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a circle on the image.

参数

ox

origin x coordinate

oy

origin y coordinate

px

perimeter x coordinate

py

perimeter y coordinate

返回值

没有返回值。

范例

Example #1 ImagickDraw::circle()

<?php
function circle($strokeColor, $fillColor, $backgroundColor, $originX, $originY, $endX, $endY) {

    //Create a ImagickDraw object to draw into.
    $draw = new \ImagickDraw();

    $strokeColor = new \ImagickPixel($strokeColor);
    $fillColor = new \ImagickPixel($fillColor);

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->circle($originX, $originY, $endX, $endY);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Clears the ImagickDraw

  • ? ImagickDraw::circle
  • ImagickDraw::clone ?
  • PHP Manual
  • ImagickDraw
  • Clears the ImagickDraw

ImagickDraw::clear

(PECL imagick 2, PECL imagick 3)

ImagickDraw::clear — Clears the ImagickDraw

说明

public ImagickDraw::clear ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Clears the ImagickDraw object of any accumulated commands, and resets the settings it contains to their defaults.

返回值

Returns an ImagickDraw object.


Makes an exact copy of the specified ImagickDraw object

  • ? ImagickDraw::clear
  • ImagickDraw::color ?
  • PHP Manual
  • ImagickDraw
  • Makes an exact copy of the specified ImagickDraw object

ImagickDraw::clone

(PECL imagick 2, PECL imagick 3)

ImagickDraw::clone — Makes an exact copy of the specified ImagickDraw object

说明

public ImagickDraw::clone ( ) : ImagickDraw
Warning

本函数还未编写文档，仅有参数列表。

Makes an exact copy of the specified ImagickDraw object.

返回值

What the function returns, first on success, then on failure. See also the &return.success; entity


Draws color on image

  • ? ImagickDraw::clone
  • ImagickDraw::comment ?
  • PHP Manual
  • ImagickDraw
  • Draws color on image

ImagickDraw::color

(PECL imagick 2, PECL imagick 3)

ImagickDraw::color — Draws color on image

说明

public ImagickDraw::color ( float $x , float $y , int $paintMethod ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws color on image using the current fill color, starting at specified position, and using specified paint method.

参数

x

x coordinate of the paint

y

y coordinate of the paint

paintMethod

one of the PAINT_ constants

返回值

没有返回值。


Adds a comment

  • ? ImagickDraw::color
  • ImagickDraw::composite ?
  • PHP Manual
  • ImagickDraw
  • Adds a comment

ImagickDraw::comment

(PECL imagick 2, PECL imagick 3)

ImagickDraw::comment — Adds a comment

说明

public ImagickDraw::comment ( string $comment ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Adds a comment to a vector output stream.

参数

comment

The comment string to add to vector output stream

返回值

没有返回值。


Composites an image onto the current image

  • ? ImagickDraw::comment
  • ImagickDraw::__construct ?
  • PHP Manual
  • ImagickDraw
  • Composites an image onto the current image

ImagickDraw::composite

(PECL imagick 2, PECL imagick 3)

ImagickDraw::composite — Composites an image onto the current image

说明

public ImagickDraw::composite ( int $compose , float $x , float $y , float $width , float $height , Imagick $compositeWand ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Composites an image onto the current image, using the specified composition operator, specified position, and at the specified size.

参数

compose

composition operator. One of COMPOSITE_ constants

x

x coordinate of the top left corner

y

y coordinate of the top left corner

width

width of the composition image

height

height of the composition image

compositeWand

the Imagick object where composition image is taken from

返回值

成功时返回 true。

范例

Example #1 ImagickDraw::composite()

<?php
function composite($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setFillOpacity(1);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(2);
    $draw->setFont("../fonts/CANDY.TTF");
    $draw->setFontSize(140);
    $draw->rectangle(0, 0, 1000, 300);
    $draw->setFillColor('white');
    $draw->setfillopacity(1);
    $draw->annotation(50, 180, "Lorem Ipsum!");

    //Create an image object which the draw commands can be rendered into
    $imagick = new \Imagick();
    $imagick->newImage(1000, 302, $backgroundColor);
    $imagick->setImageFormat("png");

    //Render the draw commands in the ImagickDraw object
    //into the image.
    $imagick->drawImage($draw);

    //Send the image to the browser
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


The ImagickDraw constructor

  • ? ImagickDraw::composite
  • ImagickDraw::destroy ?
  • PHP Manual
  • ImagickDraw
  • The ImagickDraw constructor

ImagickDraw::__construct

(PECL imagick 2, PECL imagick 3)

ImagickDraw::__construct — The ImagickDraw constructor

说明

public ImagickDraw::__construct ( )
Warning

本函数还未编写文档，仅有参数列表。

The ImagickDraw constructor

返回值

没有返回值。


Frees all associated resources

  • ? ImagickDraw::__construct
  • ImagickDraw::ellipse ?
  • PHP Manual
  • ImagickDraw
  • Frees all associated resources

ImagickDraw::destroy

(PECL imagick 2, PECL imagick 3)

ImagickDraw::destroy — Frees all associated resources

说明

public ImagickDraw::destroy ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Frees all resources associated with the ImagickDraw object.

返回值

没有返回值。


Draws an ellipse on the image

  • ? ImagickDraw::destroy
  • ImagickDraw::getClipPath ?
  • PHP Manual
  • ImagickDraw
  • Draws an ellipse on the image

ImagickDraw::ellipse

(PECL imagick 2, PECL imagick 3)

ImagickDraw::ellipse — Draws an ellipse on the image

说明

public ImagickDraw::ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws an ellipse on the image.

参数

ox

oy

rx

ry

start

end

返回值

没有返回值。

范例

Example #1 ImagickDraw::ellipse()

<?php
function ellipse($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->ellipse(125, 70, 100, 50, 0, 360);
    $draw->ellipse(350, 70, 100, 50, 0, 315);

    $draw->push();
    $draw->translate(125, 250);
    $draw->rotate(30);
    $draw->ellipse(0, 0, 100, 50, 0, 360);
    $draw->pop();

    $draw->push();
    $draw->translate(350, 250);
    $draw->rotate(30);
    $draw->ellipse(0, 0, 100, 50, 0, 315);
    $draw->pop();

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Obtains the current clipping path ID

  • ? ImagickDraw::ellipse
  • ImagickDraw::getClipRule ?
  • PHP Manual
  • ImagickDraw
  • Obtains the current clipping path ID

ImagickDraw::getClipPath

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getClipPath — Obtains the current clipping path ID

说明

public ImagickDraw::getClipPath ( ) : string
Warning

本函数还未编写文档，仅有参数列表。

Obtains the current clipping path ID.

返回值

Returns a string containing the clip path ID or false if no clip path exists.


Returns the current polygon fill rule

  • ? ImagickDraw::getClipPath
  • ImagickDraw::getClipUnits ?
  • PHP Manual
  • ImagickDraw
  • Returns the current polygon fill rule

ImagickDraw::getClipRule

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getClipRule — Returns the current polygon fill rule

说明

public ImagickDraw::getClipRule ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the current polygon fill rule to be used by the clipping path.

返回值

Returns one of the FILLRULE_ constants.


Returns the interpretation of clip path units

  • ? ImagickDraw::getClipRule
  • ImagickDraw::getFillColor ?
  • PHP Manual
  • ImagickDraw
  • Returns the interpretation of clip path units

ImagickDraw::getClipUnits

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getClipUnits — Returns the interpretation of clip path units

说明

public ImagickDraw::getClipUnits ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the interpretation of clip path units.

返回值

Returns an int on success.


Returns the fill color

  • ? ImagickDraw::getClipUnits
  • ImagickDraw::getFillOpacity ?
  • PHP Manual
  • ImagickDraw
  • Returns the fill color

ImagickDraw::getFillColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFillColor — Returns the fill color

说明

public ImagickDraw::getFillColor ( ) : ImagickPixel
Warning

本函数还未编写文档，仅有参数列表。

Returns the fill color used for drawing filled objects.

返回值

Returns an ImagickPixel object.


Returns the opacity used when drawing

  • ? ImagickDraw::getFillColor
  • ImagickDraw::getFillRule ?
  • PHP Manual
  • ImagickDraw
  • Returns the opacity used when drawing

ImagickDraw::getFillOpacity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFillOpacity — Returns the opacity used when drawing

说明

public ImagickDraw::getFillOpacity ( ) : float
Warning

本函数还未编写文档，仅有参数列表。

Returns the opacity used when drawing using the fill color or fill texture. Fully opaque is 1.0.

返回值

The opacity.


Returns the fill rule

  • ? ImagickDraw::getFillOpacity
  • ImagickDraw::getFont ?
  • PHP Manual
  • ImagickDraw
  • Returns the fill rule

ImagickDraw::getFillRule

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFillRule — Returns the fill rule

说明

public ImagickDraw::getFillRule ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the fill rule used while drawing polygons.

返回值

Returns a FILLRULE_ constant


Returns the font

  • ? ImagickDraw::getFillRule
  • ImagickDraw::getFontFamily ?
  • PHP Manual
  • ImagickDraw
  • Returns the font

ImagickDraw::getFont

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFont — Returns the font

说明

public ImagickDraw::getFont ( ) : string
Warning

本函数还未编写文档，仅有参数列表。

Returns a string specifying the font used when annotating with text.

返回值

Returns a string on success and false if no font is set.


Returns the font family

  • ? ImagickDraw::getFont
  • ImagickDraw::getFontSize ?
  • PHP Manual
  • ImagickDraw
  • Returns the font family

ImagickDraw::getFontFamily

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFontFamily — Returns the font family

说明

public ImagickDraw::getFontFamily ( ) : string
Warning

本函数还未编写文档，仅有参数列表。

Returns the font family to use when annotating with text.

返回值

Returns the font family currently selected or false if font family is not set.


Returns the font pointsize

  • ? ImagickDraw::getFontFamily
  • ImagickDraw::getFontStretch ?
  • PHP Manual
  • ImagickDraw
  • Returns the font pointsize

ImagickDraw::getFontSize

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFontSize — Returns the font pointsize

说明

public ImagickDraw::getFontSize ( ) : float
Warning

本函数还未编写文档，仅有参数列表。

Returns the font pointsize used when annotating with text.

返回值

Returns the font size associated with the current ImagickDraw object.


Description

  • ? ImagickDraw::getFontSize
  • ImagickDraw::getFontStyle ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::getFontStretch

(PECL imagick 2 >=2.3.0, PECL imagick 3)

ImagickDraw::getFontStretch — Description

说明

public ImagickDraw::getFontStretch ( ) : int

Gets the font stretch to use when annotating with text. Returns a StretchType.

参数

此函数没有参数。

返回值


Returns the font style

  • ? ImagickDraw::getFontStretch
  • ImagickDraw::getFontWeight ?
  • PHP Manual
  • ImagickDraw
  • Returns the font style

ImagickDraw::getFontStyle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFontStyle — Returns the font style

说明

public ImagickDraw::getFontStyle ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the font style used when annotating with text.

返回值

Returns the font style constant (STYLE_) associated with the ImagickDraw object or 0 if no style is set.


Returns the font weight

  • ? ImagickDraw::getFontStyle
  • ImagickDraw::getGravity ?
  • PHP Manual
  • ImagickDraw
  • Returns the font weight

ImagickDraw::getFontWeight

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getFontWeight — Returns the font weight

说明

public ImagickDraw::getFontWeight ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the font weight used when annotating with text.

返回值

Returns an int on success and 0 if no weight is set.


Returns the text placement gravity

  • ? ImagickDraw::getFontWeight
  • ImagickDraw::getStrokeAntialias ?
  • PHP Manual
  • ImagickDraw
  • Returns the text placement gravity

ImagickDraw::getGravity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getGravity — Returns the text placement gravity

说明

public ImagickDraw::getGravity ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the text placement gravity used when annotating with text.

返回值

Returns a GRAVITY_ constant on success and 0 if no gravity is set.


Returns the current stroke antialias setting

  • ? ImagickDraw::getGravity
  • ImagickDraw::getStrokeColor ?
  • PHP Manual
  • ImagickDraw
  • Returns the current stroke antialias setting

ImagickDraw::getStrokeAntialias

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeAntialias — Returns the current stroke antialias setting

说明

public ImagickDraw::getStrokeAntialias ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Returns the current stroke antialias setting. Stroked outlines are antialiased by default. When antialiasing is disabled stroked pixels are thresholded to determine if the stroke color or underlying canvas color should be used.

返回值

Returns true if antialiasing is on and false if it is off.


Returns the color used for stroking object outlines

  • ? ImagickDraw::getStrokeAntialias
  • ImagickDraw::getStrokeDashArray ?
  • PHP Manual
  • ImagickDraw
  • Returns the color used for stroking object outlines

ImagickDraw::getStrokeColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeColor — Returns the color used for stroking object outlines

说明

public ImagickDraw::getStrokeColor ( ) : ImagickPixel
Warning

本函数还未编写文档，仅有参数列表。

Returns the color used for stroking object outlines.

参数

stroke_color

返回值

Returns an ImagickPixel object which describes the color.


Returns an array representing the pattern of dashes and gaps used to stroke paths

  • ? ImagickDraw::getStrokeColor
  • ImagickDraw::getStrokeDashOffset ?
  • PHP Manual
  • ImagickDraw
  • Returns an array representing the pattern of dashes and gaps used to stroke paths

ImagickDraw::getStrokeDashArray

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeDashArray — Returns an array representing the pattern of dashes and gaps used to stroke paths

说明

public ImagickDraw::getStrokeDashArray ( ) : array
Warning

本函数还未编写文档，仅有参数列表。

Returns an array representing the pattern of dashes and gaps used to stroke paths.

返回值

Returns an array on success and empty array if not set.


Returns the offset into the dash pattern to start the dash

  • ? ImagickDraw::getStrokeDashArray
  • ImagickDraw::getStrokeLineCap ?
  • PHP Manual
  • ImagickDraw
  • Returns the offset into the dash pattern to start the dash

ImagickDraw::getStrokeDashOffset

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeDashOffset — Returns the offset into the dash pattern to start the dash

说明

public ImagickDraw::getStrokeDashOffset ( ) : float
Warning

本函数还未编写文档，仅有参数列表。

Returns the offset into the dash pattern to start the dash.

返回值

Returns a float representing the offset and 0 if it's not set.


Returns the shape to be used at the end of open subpaths when they are stroked

  • ? ImagickDraw::getStrokeDashOffset
  • ImagickDraw::getStrokeLineJoin ?
  • PHP Manual
  • ImagickDraw
  • Returns the shape to be used at the end of open subpaths when they are stroked

ImagickDraw::getStrokeLineCap

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeLineCap — Returns the shape to be used at the end of open subpaths when they are stroked

说明

public ImagickDraw::getStrokeLineCap ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the shape to be used at the end of open subpaths when they are stroked.

返回值

Returns one of the LINECAP_ constants or 0 if stroke linecap is not set.


Returns the shape to be used at the corners of paths when they are stroked

  • ? ImagickDraw::getStrokeLineCap
  • ImagickDraw::getStrokeMiterLimit ?
  • PHP Manual
  • ImagickDraw
  • Returns the shape to be used at the corners of paths when they are stroked

ImagickDraw::getStrokeLineJoin

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeLineJoin — Returns the shape to be used at the corners of paths when they are stroked

说明

public ImagickDraw::getStrokeLineJoin ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the shape to be used at the corners of paths (or other vector shapes) when they are stroked.

返回值

Returns one of the LINEJOIN_ constants or 0 if stroke line join is not set.


Returns the stroke miter limit

  • ? ImagickDraw::getStrokeLineJoin
  • ImagickDraw::getStrokeOpacity ?
  • PHP Manual
  • ImagickDraw
  • Returns the stroke miter limit

ImagickDraw::getStrokeMiterLimit

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeMiterLimit — Returns the stroke miter limit

说明

public ImagickDraw::getStrokeMiterLimit ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the miter limit. When two line segments meet at a sharp angle and miter joins have been specified for 'lineJoin', it is possible for the miter to extend far beyond the thickness of the line stroking the path. The 'miterLimit' imposes a limit on the ratio of the miter length to the 'lineWidth'.

返回值

Returns an int describing the miter limit and 0 if no miter limit is set.


Returns the opacity of stroked object outlines

  • ? ImagickDraw::getStrokeMiterLimit
  • ImagickDraw::getStrokeWidth ?
  • PHP Manual
  • ImagickDraw
  • Returns the opacity of stroked object outlines

ImagickDraw::getStrokeOpacity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeOpacity — Returns the opacity of stroked object outlines

说明

public ImagickDraw::getStrokeOpacity ( ) : float
Warning

本函数还未编写文档，仅有参数列表。

Returns the opacity of stroked object outlines.

返回值

Returns a double describing the opacity.


Returns the width of the stroke used to draw object outlines

  • ? ImagickDraw::getStrokeOpacity
  • ImagickDraw::getTextAlignment ?
  • PHP Manual
  • ImagickDraw
  • Returns the width of the stroke used to draw object outlines

ImagickDraw::getStrokeWidth

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getStrokeWidth — Returns the width of the stroke used to draw object outlines

说明

public ImagickDraw::getStrokeWidth ( ) : float
Warning

本函数还未编写文档，仅有参数列表。

Returns the width of the stroke used to draw object outlines.

返回值

Returns a double describing the stroke width.


Returns the text alignment

  • ? ImagickDraw::getStrokeWidth
  • ImagickDraw::getTextAntialias ?
  • PHP Manual
  • ImagickDraw
  • Returns the text alignment

ImagickDraw::getTextAlignment

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextAlignment — Returns the text alignment

说明

public ImagickDraw::getTextAlignment ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the alignment applied when annotating with text.

返回值

Returns one of the ALIGN_ constants and 0 if no align is set.


Returns the current text antialias setting

  • ? ImagickDraw::getTextAlignment
  • ImagickDraw::getTextDecoration ?
  • PHP Manual
  • ImagickDraw
  • Returns the current text antialias setting

ImagickDraw::getTextAntialias

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextAntialias — Returns the current text antialias setting

说明

public ImagickDraw::getTextAntialias ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Returns the current text antialias setting, which determines whether text is antialiased. Text is antialiased by default.

返回值

Returns true if text is antialiased and false if not.


Returns the text decoration

  • ? ImagickDraw::getTextAntialias
  • ImagickDraw::getTextEncoding ?
  • PHP Manual
  • ImagickDraw
  • Returns the text decoration

ImagickDraw::getTextDecoration

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextDecoration — Returns the text decoration

说明

public ImagickDraw::getTextDecoration ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the decoration applied when annotating with text.

返回值

Returns one of the DECORATION_ constants and 0 if no decoration is set.


Returns the code set used for text annotations

  • ? ImagickDraw::getTextDecoration
  • ImagickDraw::getTextInterlineSpacing ?
  • PHP Manual
  • ImagickDraw
  • Returns the code set used for text annotations

ImagickDraw::getTextEncoding

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextEncoding — Returns the code set used for text annotations

说明

public ImagickDraw::getTextEncoding ( ) : string
Warning

本函数还未编写文档，仅有参数列表。

Returns a string which specifies the code set used for text annotations.

返回值

Returns a string specifying the code set or false if text encoding is not set.


Description

  • ? ImagickDraw::getTextEncoding
  • ImagickDraw::getTextInterwordSpacing ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::getTextInterlineSpacing

(PECL imagick 3 >= 3.1.0)

ImagickDraw::getTextInterlineSpacing — Description

说明

public ImagickDraw::getTextInterlineSpacing ( ) : float

Gets the text interword spacing.

参数

此函数没有参数。

返回值


Description

  • ? ImagickDraw::getTextInterlineSpacing
  • ImagickDraw::getTextKerning ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::getTextInterwordSpacing

(PECL imagick 2 >= 2.3.0, PECL imagick 3 >= 3.1.0)

ImagickDraw::getTextInterwordSpacing — Description

说明

public ImagickDraw::getTextInterwordSpacing ( ) : float

Gets the text interword spacing.

参数

此函数没有参数。

返回值


Description

  • ? ImagickDraw::getTextInterwordSpacing
  • ImagickDraw::getTextUnderColor ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::getTextKerning

(PECL imagick 2 >= 2.3.0, PECL imagick 3 >= 3.1.0)

ImagickDraw::getTextKerning — Description

说明

public ImagickDraw::getTextKerning ( ) : float

Gets the text kerning.

参数

此函数没有参数。

返回值


Returns the text under color

  • ? ImagickDraw::getTextKerning
  • ImagickDraw::getVectorGraphics ?
  • PHP Manual
  • ImagickDraw
  • Returns the text under color

ImagickDraw::getTextUnderColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getTextUnderColor — Returns the text under color

说明

public ImagickDraw::getTextUnderColor ( ) : ImagickPixel
Warning

本函数还未编写文档，仅有参数列表。

Returns the color of a background rectangle to place under text annotations.

返回值

Returns an ImagickPixel object describing the color.


Returns a string containing vector graphics

  • ? ImagickDraw::getTextUnderColor
  • ImagickDraw::line ?
  • PHP Manual
  • ImagickDraw
  • Returns a string containing vector graphics

ImagickDraw::getVectorGraphics

(PECL imagick 2, PECL imagick 3)

ImagickDraw::getVectorGraphics — Returns a string containing vector graphics

说明

public ImagickDraw::getVectorGraphics ( ) : string
Warning

本函数还未编写文档，仅有参数列表。

Returns a string which specifies the vector graphics generated by any graphics calls made since the ImagickDraw object was instantiated.

返回值

Returns a string containing the vector graphics.


Draws a line

  • ? ImagickDraw::getVectorGraphics
  • ImagickDraw::matte ?
  • PHP Manual
  • ImagickDraw
  • Draws a line

ImagickDraw::line

(PECL imagick 2, PECL imagick 3)

ImagickDraw::line — Draws a line

说明

public ImagickDraw::line ( float $sx , float $sy , float $ex , float $ey ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a line on the image using the current stroke color, stroke opacity, and stroke width.

参数

sx

starting x coordinate

sy

starting y coordinate

ex

ending x coordinate

ey

ending y coordinate

返回值

没有返回值。

范例

Example #1 ImagickDraw::line()

<?php
function line($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->line(125, 70, 100, 50);
    $draw->line(350, 170, 100, 150);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Paints on the image's opacity channel

  • ? ImagickDraw::line
  • ImagickDraw::pathClose ?
  • PHP Manual
  • ImagickDraw
  • Paints on the image's opacity channel

ImagickDraw::matte

(PECL imagick 2, PECL imagick 3)

ImagickDraw::matte — Paints on the image's opacity channel

说明

public ImagickDraw::matte ( float $x , float $y , int $paintMethod ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Paints on the image's opacity channel in order to set effected pixels to transparent, to influence the opacity of pixels.

参数

x

x coordinate of the matte

y

y coordinate of the matte

paintMethod

PAINT_ constant

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ImagickDraw::matte()

<?php
function matte($strokeColor, $fillColor, $backgroundColor, $paintType) {
    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->matte(120, 120, $paintType);
    $draw->rectangle(100, 100, 300, 200);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Adds a path element to the current path

  • ? ImagickDraw::matte
  • ImagickDraw::pathCurveToAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Adds a path element to the current path

ImagickDraw::pathClose

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathClose — Adds a path element to the current path

说明

public ImagickDraw::pathClose ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Adds a path element to the current path which closes the current subpath by drawing a straight line from the current point to the current subpath's most recent starting point (usually, the most recent moveto point).

返回值

没有返回值。


Draws a cubic Bezier curve

  • ? ImagickDraw::pathClose
  • ImagickDraw::pathCurveToQuadraticBezierAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Draws a cubic Bezier curve

ImagickDraw::pathCurveToAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToAbsolute — Draws a cubic Bezier curve

说明

public ImagickDraw::pathCurveToAbsolute ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a cubic Bezier curve from the current point to (x,y) using (x1,y1) as the control point at the beginning of the curve and (x2,y2) as the control point at the end of the curve using absolute coordinates. At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

参数

x1

x coordinate of the first control point

y1

y coordinate of the first control point

x2

x coordinate of the second control point

y2

y coordinate of the first control point

x

x coordinate of the curve end

y

y coordinate of the curve end

返回值

没有返回值。


Draws a quadratic Bezier curve

  • ? ImagickDraw::pathCurveToAbsolute
  • ImagickDraw::pathCurveToQuadraticBezierRelative ?
  • PHP Manual
  • ImagickDraw
  • Draws a quadratic Bezier curve

ImagickDraw::pathCurveToQuadraticBezierAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToQuadraticBezierAbsolute — Draws a quadratic Bezier curve

说明

public ImagickDraw::pathCurveToQuadraticBezierAbsolute ( float $x1 , float $y1 , float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a quadratic Bezier curve from the current point to (x,y) using (x1,y1) as the control point using absolute coordinates. At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

参数

x1

x coordinate of the control point

y1

y coordinate of the control point

x

x coordinate of the end point

y

y coordinate of the end point

返回值

没有返回值。

范例

Example #1 ImagickDraw::pathCurveToQuadraticBezierAbsolute()

<?php
function pathCurveToQuadraticBezierAbsolute($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->pathStart();
    $draw->pathMoveToAbsolute(50,250);

    // This specifies a quadratic bezier curve with the current position as the start
    // point, the control point is the first two params, and the end point is the last two params.
    $draw->pathCurveToQuadraticBezierAbsolute(
        150,50,
        250,250
    );

    // This specifies a quadratic bezier curve with the current position as the start
    // point, the control point is mirrored from the previous curves control point
    // and the end point is defined by the x, y values.
    $draw->pathCurveToQuadraticBezierSmoothAbsolute(
        450,250
    );

    // This specifies a quadratic bezier curve with the current position as the start
    // point, the control point is mirrored from the previous curves control point
    // and the end point is defined relative from the current position by the x, y values.
    $draw->pathCurveToQuadraticBezierSmoothRelative(
        200,-100
    );

    $draw->pathFinish();

    $imagick = new \Imagick();
    $imagick->newImage(700, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();

}

?>


Draws a quadratic Bezier curve

  • ? ImagickDraw::pathCurveToQuadraticBezierAbsolute
  • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Draws a quadratic Bezier curve

ImagickDraw::pathCurveToQuadraticBezierRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToQuadraticBezierRelative — Draws a quadratic Bezier curve

说明

public ImagickDraw::pathCurveToQuadraticBezierRelative ( float $x1 , float $y1 , float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a quadratic Bezier curve from the current point to (x,y) using (x1,y1) as the control point using relative coordinates. At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

参数

x1

starting x coordinate

y1

starting y coordinate

x

ending x coordinate

y

ending y coordinate

返回值

没有返回值。


Draws a quadratic Bezier curve

  • ? ImagickDraw::pathCurveToQuadraticBezierRelative
  • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative ?
  • PHP Manual
  • ImagickDraw
  • Draws a quadratic Bezier curve

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — Draws a quadratic Bezier curve

说明

public ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute ( float $x , float $y ) : bool

Draws a quadratic Bezier curve (using absolute coordinates) from the current point to (x,y). The control point is assumed to be the reflection of the control point on the previous command relative to the current point. (If there is no previous command or if the previous command was not a DrawPathCurveToQuadraticBezierAbsolute, DrawPathCurveToQuadraticBezierRelative, DrawPathCurveToQuadraticBezierSmoothAbsolut or DrawPathCurveToQuadraticBezierSmoothRelative, assume the control point is coincident with the current point.). At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

This function cannot be used to continue a cubic Bezier curve smoothly. It can only continue from a quadratic curve smoothly.

参数

x

ending x coordinate

y

ending y coordinate

返回值

没有返回值。

范例

Example #1 ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute()

<?php
$draw = new \ImagickDraw();

$draw->setStrokeOpacity(1);
$draw->setStrokeColor("black");
$draw->setFillColor("blue");

$draw->setStrokeWidth(2);
$draw->setFontSize(72);

$draw->pathStart();
$draw->pathMoveToAbsolute(50,250);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is the first two params, and the end point is the last two params.
$draw->pathCurveToQuadraticBezierAbsolute(
    150,50,
    250,250
);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is mirrored from the previous curves control point
// and the end point is defined by the x, y values.
$draw->pathCurveToQuadraticBezierSmoothAbsolute(
    450,250
);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is mirrored from the previous curves control point
// and the end point is defined relative from the current position by the x, y values.
$draw->pathCurveToQuadraticBezierSmoothRelative(
    200,-100
);

$draw->pathFinish();

$imagick = new \Imagick();
$imagick->newImage(700, 500, $backgroundColor);
$imagick->setImageFormat("png");

$imagick->drawImage($draw);

header("Content-Type: image/png");
echo $imagick->getImageBlob();
?>


Draws a quadratic Bezier curve

  • ? ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute
  • ImagickDraw::pathCurveToRelative ?
  • PHP Manual
  • ImagickDraw
  • Draws a quadratic Bezier curve

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — Draws a quadratic Bezier curve

说明

public ImagickDraw::pathCurveToQuadraticBezierSmoothRelative ( float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a quadratic Bezier curve (using relative coordinates) from the current point to (x, y). The control point is assumed to be the reflection of the control point on the previous command relative to the current point. (If there is no previous command or if the previous command was not a DrawPathCurveToQuadraticBezierAbsolute, DrawPathCurveToQuadraticBezierRelative, DrawPathCurveToQuadraticBezierSmoothAbsolut or DrawPathCurveToQuadraticBezierSmoothRelative, assume the control point is coincident with the current point). At the end of the command, the new current point becomes the final (x, y) coordinate pair used in the polybezier.

This function cannot be used to continue a cubic Bezier curve smoothly. It can only continue from a quadratic curve smoothly.

参数

x

ending x coordinate

y

ending y coordinate

返回值

没有返回值。

范例

Example #1 ImagickDraw::pathCurveToQuadraticBezierSmoothRelative()

<?php
$draw = new \ImagickDraw();

$draw->setStrokeOpacity(1);
$draw->setStrokeColor("black");
$draw->setFillColor("blue");

$draw->setStrokeWidth(2);
$draw->setFontSize(72);

$draw->pathStart();
$draw->pathMoveToAbsolute(50,250);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is the first two params, and the end point is the last two params.
$draw->pathCurveToQuadraticBezierAbsolute(
    150,50,
    250,250
);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is mirrored from the previous curves control point
// and the end point is defined by the x, y values.
$draw->pathCurveToQuadraticBezierSmoothAbsolute(
    450,250
);

// This specifies a quadratic bezier curve with the current position as the start
// point, the control point is mirrored from the previous curves control point
// and the end point is defined relative from the current position by the x, y values.
$draw->pathCurveToQuadraticBezierSmoothRelative(
    200,-100
);

$draw->pathFinish();

$imagick = new \Imagick();
$imagick->newImage(700, 500, $backgroundColor);
$imagick->setImageFormat("png");

$imagick->drawImage($draw);

header("Content-Type: image/png");
echo $imagick->getImageBlob();
?>


Draws a cubic Bezier curve

  • ? ImagickDraw::pathCurveToQuadraticBezierSmoothRelative
  • ImagickDraw::pathCurveToSmoothAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Draws a cubic Bezier curve

ImagickDraw::pathCurveToRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToRelative — Draws a cubic Bezier curve

说明

public ImagickDraw::pathCurveToRelative ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a cubic Bezier curve from the current point to (x,y) using (x1,y1) as the control point at the beginning of the curve and (x2,y2) as the control point at the end of the curve using relative coordinates. At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

参数

x1

x coordinate of starting control point

y1

y coordinate of starting control point

x2

x coordinate of ending control point

y2

y coordinate of ending control point

x

ending x coordinate

y

ending y coordinate

返回值

没有返回值。


Draws a cubic Bezier curve

  • ? ImagickDraw::pathCurveToRelative
  • ImagickDraw::pathCurveToSmoothRelative ?
  • PHP Manual
  • ImagickDraw
  • Draws a cubic Bezier curve

ImagickDraw::pathCurveToSmoothAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToSmoothAbsolute — Draws a cubic Bezier curve

说明

public ImagickDraw::pathCurveToSmoothAbsolute ( float $x2 , float $y2 , float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a cubic Bezier curve from the current point to (x,y) using absolute coordinates. The first control point is assumed to be the reflection of the second control point on the previous command relative to the current point. (If there is no previous command or if the previous command was not an DrawPathCurveToAbsolute, DrawPathCurveToRelative, DrawPathCurveToSmoothAbsolute or DrawPathCurveToSmoothRelative, assume the first control point is coincident with the current point.) (x2,y2) is the second control point (i.e., the control point at the end of the curve). At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

参数

x2

x coordinate of the second control point

y2

y coordinate of the second control point

x

x coordinate of the ending point

y

y coordinate of the ending point

返回值

没有返回值。


Draws a cubic Bezier curve

  • ? ImagickDraw::pathCurveToSmoothAbsolute
  • ImagickDraw::pathEllipticArcAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Draws a cubic Bezier curve

ImagickDraw::pathCurveToSmoothRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathCurveToSmoothRelative — Draws a cubic Bezier curve

说明

public ImagickDraw::pathCurveToSmoothRelative ( float $x2 , float $y2 , float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a cubic Bezier curve from the current point to (x,y) using relative coordinates. The first control point is assumed to be the reflection of the second control point on the previous command relative to the current point. (If there is no previous command or if the previous command was not an DrawPathCurveToAbsolute, DrawPathCurveToRelative, DrawPathCurveToSmoothAbsolute or DrawPathCurveToSmoothRelative, assume the first control point is coincident with the current point.) (x2,y2) is the second control point (i.e., the control point at the end of the curve). At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

参数

x2

x coordinate of the second control point

y2

y coordinate of the second control point

x

x coordinate of the ending point

y

y coordinate of the ending point

返回值

没有返回值。


Draws an elliptical arc

  • ? ImagickDraw::pathCurveToSmoothRelative
  • ImagickDraw::pathEllipticArcRelative ?
  • PHP Manual
  • ImagickDraw
  • Draws an elliptical arc

ImagickDraw::pathEllipticArcAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathEllipticArcAbsolute — Draws an elliptical arc

说明

public ImagickDraw::pathEllipticArcAbsolute ( float $rx , float $ry , float $x_axis_rotation , bool $large_arc_flag , bool $sweep_flag , float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws an elliptical arc from the current point to (x, y) using absolute coordinates. The size and orientation of the ellipse are defined by two radii (rx, ry) and an xAxisRotation, which indicates how the ellipse as a whole is rotated relative to the current coordinate system. The center (cx, cy) of the ellipse is calculated automatically to satisfy the constraints imposed by the other parameters. largeArcFlag and sweepFlag contribute to the automatic calculations and help determine how the arc is drawn. If largeArcFlag is true then draw the larger of the available arcs. If sweepFlag is true, then draw the arc matching a clock-wise rotation.

参数

rx

x radius

ry

y radius

x_axis_rotation

x axis rotation

large_arc_flag

large arc flag

sweep_flag

sweep flag

x

x coordinate

y

y coordinate

返回值

没有返回值。


Draws an elliptical arc

  • ? ImagickDraw::pathEllipticArcAbsolute
  • ImagickDraw::pathFinish ?
  • PHP Manual
  • ImagickDraw
  • Draws an elliptical arc

ImagickDraw::pathEllipticArcRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathEllipticArcRelative — Draws an elliptical arc

说明

public ImagickDraw::pathEllipticArcRelative ( float $rx , float $ry , float $x_axis_rotation , bool $large_arc_flag , bool $sweep_flag , float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws an elliptical arc from the current point to (x, y) using relative coordinates. The size and orientation of the ellipse are defined by two radii (rx, ry) and an xAxisRotation, which indicates how the ellipse as a whole is rotated relative to the current coordinate system. The center (cx, cy) of the ellipse is calculated automatically to satisfy the constraints imposed by the other parameters. largeArcFlag and sweepFlag contribute to the automatic calculations and help determine how the arc is drawn. If largeArcFlag is true then draw the larger of the available arcs. If sweepFlag is true, then draw the arc matching a clock-wise rotation.

参数

rx

x radius

ry

y radius

x_axis_rotation

x axis rotation

large_arc_flag

large arc flag

sweep_flag

sweep flag

x

x coordinate

y

y coordinate

返回值

没有返回值。


Terminates the current path

  • ? ImagickDraw::pathEllipticArcRelative
  • ImagickDraw::pathLineToAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Terminates the current path

ImagickDraw::pathFinish

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathFinish — Terminates the current path

说明

public ImagickDraw::pathFinish ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Terminates the current path.

返回值

没有返回值。


Draws a line path

  • ? ImagickDraw::pathFinish
  • ImagickDraw::pathLineToHorizontalAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Draws a line path

ImagickDraw::pathLineToAbsolute

(PECL imagick 2)

ImagickDraw::pathLineToAbsolute — Draws a line path

说明

public ImagickDraw::pathLineToAbsolute ( float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a line path from the current point to the given coordinate using absolute coordinates. The coordinate then becomes the new current point.

参数

x

starting x coordinate

y

ending x coordinate

返回值

没有返回值。


Draws a horizontal line path

  • ? ImagickDraw::pathLineToAbsolute
  • ImagickDraw::pathLineToHorizontalRelative ?
  • PHP Manual
  • ImagickDraw
  • Draws a horizontal line path

ImagickDraw::pathLineToHorizontalAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToHorizontalAbsolute — Draws a horizontal line path

说明

public ImagickDraw::pathLineToHorizontalAbsolute ( float $x ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a horizontal line path from the current point to the target point using absolute coordinates. The target point then becomes the new current point.

参数

x

x coordinate

返回值

没有返回值。


Draws a horizontal line

  • ? ImagickDraw::pathLineToHorizontalAbsolute
  • ImagickDraw::pathLineToRelative ?
  • PHP Manual
  • ImagickDraw
  • Draws a horizontal line

ImagickDraw::pathLineToHorizontalRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToHorizontalRelative — Draws a horizontal line

说明

public ImagickDraw::pathLineToHorizontalRelative ( float $x ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a horizontal line path from the current point to the target point using relative coordinates. The target point then becomes the new current point.

参数

x

x coordinate

返回值

没有返回值。


Draws a line path

  • ? ImagickDraw::pathLineToHorizontalRelative
  • ImagickDraw::pathLineToVerticalAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Draws a line path

ImagickDraw::pathLineToRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToRelative — Draws a line path

说明

public ImagickDraw::pathLineToRelative ( float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a line path from the current point to the given coordinate using relative coordinates. The coordinate then becomes the new current point.

参数

x

starting x coordinate

y

starting y coordinate

返回值

没有返回值。


Draws a vertical line

  • ? ImagickDraw::pathLineToRelative
  • ImagickDraw::pathLineToVerticalRelative ?
  • PHP Manual
  • ImagickDraw
  • Draws a vertical line

ImagickDraw::pathLineToVerticalAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToVerticalAbsolute — Draws a vertical line

说明

public ImagickDraw::pathLineToVerticalAbsolute ( float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a vertical line path from the current point to the target point using absolute coordinates. The target point then becomes the new current point.

参数

y

y coordinate

返回值

没有返回值。


Draws a vertical line path

  • ? ImagickDraw::pathLineToVerticalAbsolute
  • ImagickDraw::pathMoveToAbsolute ?
  • PHP Manual
  • ImagickDraw
  • Draws a vertical line path

ImagickDraw::pathLineToVerticalRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathLineToVerticalRelative — Draws a vertical line path

说明

public ImagickDraw::pathLineToVerticalRelative ( float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a vertical line path from the current point to the target point using relative coordinates. The target point then becomes the new current point.

参数

y

y coordinate

返回值

没有返回值。


Starts a new sub-path

  • ? ImagickDraw::pathLineToVerticalRelative
  • ImagickDraw::pathMoveToRelative ?
  • PHP Manual
  • ImagickDraw
  • Starts a new sub-path

ImagickDraw::pathMoveToAbsolute

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathMoveToAbsolute — Starts a new sub-path

说明

public ImagickDraw::pathMoveToAbsolute ( float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Starts a new sub-path at the given coordinate using absolute coordinates. The current point then becomes the specified coordinate.

参数

x

x coordinate of the starting point

y

y coordinate of the starting point

返回值

没有返回值。


Starts a new sub-path

  • ? ImagickDraw::pathMoveToAbsolute
  • ImagickDraw::pathStart ?
  • PHP Manual
  • ImagickDraw
  • Starts a new sub-path

ImagickDraw::pathMoveToRelative

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathMoveToRelative — Starts a new sub-path

说明

public ImagickDraw::pathMoveToRelative ( float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Starts a new sub-path at the given coordinate using relative coordinates. The current point then becomes the specified coordinate.

参数

x

target x coordinate

y

target y coordinate

返回值

没有返回值。


Declares the start of a path drawing list

  • ? ImagickDraw::pathMoveToRelative
  • ImagickDraw::point ?
  • PHP Manual
  • ImagickDraw
  • Declares the start of a path drawing list

ImagickDraw::pathStart

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pathStart — Declares the start of a path drawing list

说明

public ImagickDraw::pathStart ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Declares the start of a path drawing list which is terminated by a matching DrawPathFinish() command. All other DrawPath commands must be enclosed between a and a DrawPathFinish() command. This is because path drawing commands are subordinate commands and they do not function by themselves.

返回值

没有返回值。

范例

Example #1 ImagickDraw::pathStart()

<?php
function pathStart($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    $draw->pathStart();
    $draw->pathMoveToAbsolute(50, 50);
    $draw->pathLineToAbsolute(100, 50);
    $draw->pathLineToRelative(0, 50);
    $draw->pathLineToHorizontalRelative(-50);
    $draw->pathFinish();

    $draw->pathStart();
    $draw->pathMoveToAbsolute(50, 50);
    $draw->pathMoveToRelative(300, 0);
    $draw->pathLineToRelative(50, 0);
    $draw->pathLineToVerticalRelative(50);
    $draw->pathLineToHorizontalAbsolute(350);
    $draw->pathclose();
    $draw->pathFinish();

    $draw->pathStart();
    $draw->pathMoveToAbsolute(50, 300);
    $draw->pathCurveToAbsolute(50, 300, 100, 200, 300, 300);
    $draw->pathLineToVerticalAbsolute(350);
    $draw->pathFinish();

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Draws a point

  • ? ImagickDraw::pathStart
  • ImagickDraw::polygon ?
  • PHP Manual
  • ImagickDraw
  • Draws a point

ImagickDraw::point

(PECL imagick 2, PECL imagick 3)

ImagickDraw::point — Draws a point

说明

public ImagickDraw::point ( float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a point using the current stroke color and stroke thickness at the specified coordinates.

参数

x

point's x coordinate

y

point's y coordinate

返回值

没有返回值。

范例

Example #1 ImagickDraw::point()

<?php
function point($fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setFillColor($fillColor);

    for ($x = 0; $x < 10000; $x++) {
        $draw->point(rand(0, 500), rand(0, 500));
    }

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Draws a polygon

  • ? ImagickDraw::point
  • ImagickDraw::polyline ?
  • PHP Manual
  • ImagickDraw
  • Draws a polygon

ImagickDraw::polygon

(PECL imagick 2, PECL imagick 3)

ImagickDraw::polygon — Draws a polygon

说明

public ImagickDraw::polygon ( array $coordinates ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a polygon using the current stroke, stroke width, and fill color or texture, using the specified array of coordinates.

参数

coordinates

multidimensional array like array( array( 'x' => 3, 'y' => 4 ), array( 'x' => 2, 'y' => 6 ) );

返回值

成功时返回 true。

范例

Example #1 ImagickDraw::polygon()

<?php
function polygon($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(4);

    $draw->setFillColor($fillColor);

    $points = [
        ['x' => 40 * 5, 'y' => 10 * 5],
        ['x' => 20 * 5, 'y' => 20 * 5],
        ['x' => 70 * 5, 'y' => 50 * 5],
        ['x' => 60 * 5, 'y' => 15 * 5],
    ];

    $draw->polygon($points);

    $image = new \Imagick();
    $image->newImage(500, 300, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Draws a polyline

  • ? ImagickDraw::polygon
  • ImagickDraw::pop ?
  • PHP Manual
  • ImagickDraw
  • Draws a polyline

ImagickDraw::polyline

(PECL imagick 2, PECL imagick 3)

ImagickDraw::polyline — Draws a polyline

说明

public ImagickDraw::polyline ( array $coordinates ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a polyline using the current stroke, stroke width, and fill color or texture, using the specified array of coordinates.

参数

coordinates

array of x and y coordinates: array( array( 'x' => 4, 'y' => 6 ), array( 'x' => 8, 'y' => 10 ) )

返回值

成功时返回 true。

范例

Example #1 ImagickDraw::polyline()

<?php
function polyline($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(5);

    $points = [
        ['x' => 40 * 5, 'y' => 10 * 5],
        ['x' => 20 * 5, 'y' => 20 * 5],
        ['x' => 70 * 5, 'y' => 50 * 5],
        ['x' => 60 * 5, 'y' => 15 * 5]
    ];

    $draw->polyline($points);

    $image = new \Imagick();
    $image->newImage(500, 300, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw

  • ? ImagickDraw::polyline
  • ImagickDraw::popClipPath ?
  • PHP Manual
  • ImagickDraw
  • Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw

ImagickDraw::pop

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pop — Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw

说明

public ImagickDraw::pop ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw. Multiple ImagickDraws may exist. It is an error to attempt to pop more ImagickDraws than have been pushed, and it is proper form to pop all ImagickDraws which have been pushed.

返回值

Returns true on success and false on failure.


Terminates a clip path definition

  • ? ImagickDraw::pop
  • ImagickDraw::popDefs ?
  • PHP Manual
  • ImagickDraw
  • Terminates a clip path definition

ImagickDraw::popClipPath

(PECL imagick 2, PECL imagick 3)

ImagickDraw::popClipPath — Terminates a clip path definition

说明

public ImagickDraw::popClipPath ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Terminates a clip path definition.

返回值

没有返回值。


Terminates a definition list

  • ? ImagickDraw::popClipPath
  • ImagickDraw::popPattern ?
  • PHP Manual
  • ImagickDraw
  • Terminates a definition list

ImagickDraw::popDefs

(PECL imagick 2, PECL imagick 3)

ImagickDraw::popDefs — Terminates a definition list

说明

public ImagickDraw::popDefs ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Terminates a definition list.

返回值

没有返回值。

范例

Example #1 ImagickDraw::popDefs()

<?php
function popDefs($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setstrokeOpacity(1);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->pushDefs();
    $draw->setStrokeColor('white');
    $draw->rectangle(50, 50, 200, 200);
    $draw->popDefs();

    $draw->rectangle(300, 50, 450, 200);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Terminates a pattern definition

  • ? ImagickDraw::popDefs
  • ImagickDraw::push ?
  • PHP Manual
  • ImagickDraw
  • Terminates a pattern definition

ImagickDraw::popPattern

(PECL imagick 2, PECL imagick 3)

ImagickDraw::popPattern — Terminates a pattern definition

说明

public ImagickDraw::popPattern ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Terminates a pattern definition.

返回值

成功时返回 true， 或者在失败时返回 false。


Clones the current ImagickDraw and pushes it to the stack

  • ? ImagickDraw::popPattern
  • ImagickDraw::pushClipPath ?
  • PHP Manual
  • ImagickDraw
  • Clones the current ImagickDraw and pushes it to the stack

ImagickDraw::push

(PECL imagick 2, PECL imagick 3)

ImagickDraw::push — Clones the current ImagickDraw and pushes it to the stack

说明

public ImagickDraw::push ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Clones the current ImagickDraw to create a new ImagickDraw, which is then added to the ImagickDraw stack. The original drawing ImagickDraw(s) may be returned to by invoking pop(). The ImagickDraws are stored on a ImagickDraw stack. For every Pop there must have already been an equivalent Push.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ImagickDraw::push()

<?php
function push($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillModifiedColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->push();
    $draw->translate(50, 50);
    $draw->rectangle(200, 200, 300, 300);
    $draw->pop();
    $draw->setFillColor($fillColor);
    $draw->rectangle(200, 200, 300, 300);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Starts a clip path definition

  • ? ImagickDraw::push
  • ImagickDraw::pushDefs ?
  • PHP Manual
  • ImagickDraw
  • Starts a clip path definition

ImagickDraw::pushClipPath

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pushClipPath — Starts a clip path definition

说明

public ImagickDraw::pushClipPath ( string $clip_mask_id ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Starts a clip path definition which is comprised of any number of drawing commands and terminated by a ImagickDraw::popClipPath() command.

参数

clip_mask_id

Clip mask Id

返回值

没有返回值。


Indicates that following commands create named elements for early processing

  • ? ImagickDraw::pushClipPath
  • ImagickDraw::pushPattern ?
  • PHP Manual
  • ImagickDraw
  • Indicates that following commands create named elements for early processing

ImagickDraw::pushDefs

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pushDefs — Indicates that following commands create named elements for early processing

说明

public ImagickDraw::pushDefs ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Indicates that commands up to a terminating ImagickDraw::popDefs() command create named elements (e.g. clip-paths, textures, etc.) which may safely be processed earlier for the sake of efficiency.

返回值

没有返回值。


Indicates that subsequent commands up to a ImagickDraw::opPattern() command comprise the definition of a named pattern

  • ? ImagickDraw::pushDefs
  • ImagickDraw::rectangle ?
  • PHP Manual
  • ImagickDraw
  • Indicates that subsequent commands up to a ImagickDraw::opPattern() command comprise the definition of a named pattern

ImagickDraw::pushPattern

(PECL imagick 2, PECL imagick 3)

ImagickDraw::pushPattern — Indicates that subsequent commands up to a ImagickDraw::opPattern() command comprise the definition of a named pattern

说明

public ImagickDraw::pushPattern ( string $pattern_id , float $x , float $y , float $width , float $height ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Indicates that subsequent commands up to a DrawPopPattern() command comprise the definition of a named pattern. The pattern space is assigned top left corner coordinates, a width and height, and becomes its own drawing space. Anything which can be drawn may be used in a pattern definition. Named patterns may be used as stroke or brush definitions.

参数

pattern_id

the pattern Id

x

x coordinate of the top-left corner

y

y coordinate of the top-left corner

width

width of the pattern

height

height of the pattern

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ImagickDraw::pushPattern()

<?php
function pushPattern($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(1);

    $draw->pushPattern("MyFirstPattern", 0, 0, 50, 50);
    for ($x = 0; $x < 50; $x += 10) {
        for ($y = 0; $y < 50; $y += 5) {
            $positionX = $x + (($y / 5) % 5);
            $draw->rectangle($positionX, $y, $positionX + 5, $y + 5);
        }
    }
    $draw->popPattern();

    $draw->setFillOpacity(0);
    $draw->rectangle(100, 100, 400, 400);
    $draw->setFillOpacity(1);

    $draw->setFillOpacity(1);

    $draw->push();
    $draw->setFillPatternURL('#MyFirstPattern');
    $draw->setFillColor('yellow');
    $draw->rectangle(100, 100, 400, 400);
    $draw->pop();

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Draws a rectangle

  • ? ImagickDraw::pushPattern
  • ImagickDraw::render ?
  • PHP Manual
  • ImagickDraw
  • Draws a rectangle

ImagickDraw::rectangle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::rectangle — Draws a rectangle

说明

public ImagickDraw::rectangle ( float $x1 , float $y1 , float $x2 , float $y2 ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a rectangle given two coordinates and using the current stroke, stroke width, and fill settings.

参数

x1

x coordinate of the top left corner

y1

y coordinate of the top left corner

x2

x coordinate of the bottom right corner

y2

y coordinate of the bottom right corner

返回值

没有返回值。

范例

Example #1 ImagickDraw::rectangle()

<?php
function rectangle($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();
    $strokeColor = new \ImagickPixel($strokeColor);
    $fillColor = new \ImagickPixel($fillColor);

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);

    $draw->rectangle(200, 200, 300, 300);
    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Renders all preceding drawing commands onto the image

  • ? ImagickDraw::rectangle
  • ImagickDraw::resetVectorGraphics ?
  • PHP Manual
  • ImagickDraw
  • Renders all preceding drawing commands onto the image

ImagickDraw::render

(PECL imagick 2, PECL imagick 3)

ImagickDraw::render — Renders all preceding drawing commands onto the image

说明

public ImagickDraw::render ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Renders all preceding drawing commands onto the image.

返回值

成功时返回 true， 或者在失败时返回 false。


Description

  • ? ImagickDraw::render
  • ImagickDraw::rotate ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::resetVectorGraphics

(PECL imagick 2, PECL imagick 3)

ImagickDraw::resetVectorGraphics — Description

说明

public ImagickDraw::resetVectorGraphics ( ) : bool

Resets the vector graphics.

参数

此函数没有参数。

返回值

成功时返回 true。


Applies the specified rotation to the current coordinate space

  • ? ImagickDraw::resetVectorGraphics
  • ImagickDraw::roundRectangle ?
  • PHP Manual
  • ImagickDraw
  • Applies the specified rotation to the current coordinate space

ImagickDraw::rotate

(PECL imagick 2, PECL imagick 3)

ImagickDraw::rotate — Applies the specified rotation to the current coordinate space

说明

public ImagickDraw::rotate ( float $degrees ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Applies the specified rotation to the current coordinate space.

参数

degrees

degrees to rotate

返回值

没有返回值。

范例

Example #1 ImagickDraw::rotate()

<?php
function rotate($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor) {
    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeOpacity(1);
    $draw->setFillColor($fillColor);
    $draw->rectangle(200, 200, 300, 300);
    $draw->setFillColor($fillModifiedColor);
    $draw->rotate(15);
    $draw->rectangle(200, 200, 300, 300);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Draws a rounded rectangle

  • ? ImagickDraw::rotate
  • ImagickDraw::scale ?
  • PHP Manual
  • ImagickDraw
  • Draws a rounded rectangle

ImagickDraw::roundRectangle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::roundRectangle — Draws a rounded rectangle

说明

public ImagickDraw::roundRectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Draws a rounded rectangle given two coordinates, x & y corner radiuses and using the current stroke, stroke width, and fill settings.

参数

x1

x coordinate of the top left corner

y1

y coordinate of the top left corner

x2

x coordinate of the bottom right

y2

y coordinate of the bottom right

rx

x rounding

ry

y rounding

返回值

没有返回值。

范例

Example #1 ImagickDraw::roundRectangle()

<?php
function roundRectangle($strokeColor, $fillColor, $backgroundColor, $startX, $startY, $endX, $endY, $roundX, $roundY) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);

    $draw->roundRectangle($startX, $startY, $endX, $endY, $roundX, $roundY);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Adjusts the scaling factor

  • ? ImagickDraw::roundRectangle
  • ImagickDraw::setClipPath ?
  • PHP Manual
  • ImagickDraw
  • Adjusts the scaling factor

ImagickDraw::scale

(PECL imagick 2, PECL imagick 3)

ImagickDraw::scale — Adjusts the scaling factor

说明

public ImagickDraw::scale ( float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Adjusts the scaling factor to apply in the horizontal and vertical directions to the current coordinate space.

参数

x

horizontal factor

y

vertical factor

返回值

没有返回值。

范例

Example #1 ImagickDraw::scale()

<?php
function scale($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(4);
    $draw->setFillColor($fillColor);
    $draw->rectangle(200, 200, 300, 300);
    $draw->setFillColor($fillModifiedColor);
    $draw->scale(1.4, 1.4);
    $draw->rectangle(200, 200, 300, 300);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Associates a named clipping path with the image

  • ? ImagickDraw::scale
  • ImagickDraw::setClipRule ?
  • PHP Manual
  • ImagickDraw
  • Associates a named clipping path with the image

ImagickDraw::setClipPath

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setClipPath — Associates a named clipping path with the image

说明

public ImagickDraw::setClipPath ( string $clip_mask ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Associates a named clipping path with the image. Only the areas drawn on by the clipping path will be modified as long as it remains in effect.

参数

clip_mask

the clipping path name

返回值

没有返回值。

范例

Example #1 ImagickDraw::setClipPath()

<?php
function setClipPath($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);

    $clipPathName = 'testClipPath';

    $draw->pushClipPath($clipPathName);
    $draw->rectangle(0, 0, 250, 250);
    $draw->popClipPath();
    $draw->setClipPath($clipPathName);
    $draw->rectangle(100, 100, 400, 400);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Set the polygon fill rule to be used by the clipping path

  • ? ImagickDraw::setClipPath
  • ImagickDraw::setClipUnits ?
  • PHP Manual
  • ImagickDraw
  • Set the polygon fill rule to be used by the clipping path

ImagickDraw::setClipRule

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setClipRule — Set the polygon fill rule to be used by the clipping path

说明

public ImagickDraw::setClipRule ( int $fill_rule ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Set the polygon fill rule to be used by the clipping path.

参数

fill_rule

FILLRULE_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setClipRule()

<?php
function setClipRule($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);
    //\Imagick::FILLRULE_EVENODD
    //\Imagick::FILLRULE_NONZERO

    $clipPathName = 'testClipPath';
    $draw->pushClipPath($clipPathName);
    $draw->setClipRule(\Imagick::FILLRULE_EVENODD);
    $draw->rectangle(0, 0, 300, 500);
    $draw->rectangle(200, 0, 500, 500);
    $draw->popClipPath();
    $draw->setClipPath($clipPathName);
    $draw->rectangle(200, 200, 300, 300);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the interpretation of clip path units

  • ? ImagickDraw::setClipRule
  • ImagickDraw::setFillAlpha ?
  • PHP Manual
  • ImagickDraw
  • Sets the interpretation of clip path units

ImagickDraw::setClipUnits

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setClipUnits — Sets the interpretation of clip path units

说明

public ImagickDraw::setClipUnits ( int $clip_units ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the interpretation of clip path units.

参数

clip_units

the number of clip units

返回值

没有返回值。

范例

Example #1 ImagickDraw::setClipUnits()

<?php
function setClipUnits($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);
    $clipPathName = 'testClipPath';
    $draw->setClipUnits(\Imagick::RESOLUTION_PIXELSPERINCH);
    $draw->pushClipPath($clipPathName);
    $draw->rectangle(0, 0, 250, 250);
    $draw->popClipPath();
    $draw->setClipPath($clipPathName);

    //RESOLUTION_PIXELSPERINCH
    //RESOLUTION_PIXELSPERCENTIMETER

    $draw->rectangle(200, 200, 300, 300);
    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the opacity to use when drawing using the fill color or fill texture

  • ? ImagickDraw::setClipUnits
  • ImagickDraw::setFillColor ?
  • PHP Manual
  • ImagickDraw
  • Sets the opacity to use when drawing using the fill color or fill texture

ImagickDraw::setFillAlpha

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillAlpha — Sets the opacity to use when drawing using the fill color or fill texture

说明

public ImagickDraw::setFillAlpha ( float $opacity ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the opacity to use when drawing using the fill color or fill texture. Fully opaque is 1.0.

参数

opacity

fill alpha

返回值

没有返回值。

范例

Example #1 ImagickDraw::setFillAlpha()

<?php
function setFillAlpha($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);
    $draw->rectangle(100, 200, 200, 300);
    @$draw->setFillAlpha(0.4);
    $draw->rectangle(300, 200, 400, 300);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the fill color to be used for drawing filled objects

  • ? ImagickDraw::setFillAlpha
  • ImagickDraw::setFillOpacity ?
  • PHP Manual
  • ImagickDraw
  • Sets the fill color to be used for drawing filled objects

ImagickDraw::setFillColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillColor — Sets the fill color to be used for drawing filled objects

说明

public ImagickDraw::setFillColor ( ImagickPixel $fill_pixel ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the fill color to be used for drawing filled objects.

参数

fill_pixel

ImagickPixel to use to set the color

返回值

没有返回值。

范例

Example #1 ImagickDraw::setFillColor()

<?php
function setFillColor($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(1.5);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->rectangle(50, 50, 150, 150);

    $draw->setFillColor("rgb(200, 32, 32)");
    $draw->rectangle(200, 50, 300, 150);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Sets the opacity to use when drawing using the fill color or fill texture

  • ? ImagickDraw::setFillColor
  • ImagickDraw::setFillPatternURL ?
  • PHP Manual
  • ImagickDraw
  • Sets the opacity to use when drawing using the fill color or fill texture

ImagickDraw::setFillOpacity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillOpacity — Sets the opacity to use when drawing using the fill color or fill texture

说明

public ImagickDraw::setFillOpacity ( float $fillOpacity ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the opacity to use when drawing using the fill color or fill texture. Fully opaque is 1.0.

参数

fillOpacity

the fill opacity

返回值

没有返回值。

范例

Example #1 ImagickDraw::setFillOpacity()

<?php
function setFillOpacity($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeOpacity(1);
    $draw->setStrokeWidth(2);

    $draw->rectangle(100, 200, 200, 300);

    $draw->setFillOpacity(0.4);
    $draw->rectangle(300, 200, 400, 300);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the URL to use as a fill pattern for filling objects

  • ? ImagickDraw::setFillOpacity
  • ImagickDraw::setFillRule ?
  • PHP Manual
  • ImagickDraw
  • Sets the URL to use as a fill pattern for filling objects

ImagickDraw::setFillPatternURL

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillPatternURL — Sets the URL to use as a fill pattern for filling objects

说明

public ImagickDraw::setFillPatternURL ( string $fill_url ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the URL to use as a fill pattern for filling objects. Only local URLs ("#identifier") are supported at this time. These local URLs are normally created by defining a named fill pattern with DrawPushPattern/DrawPopPattern.

参数

fill_url

URL to use to obtain fill pattern.

返回值

成功时返回 true， 或者在失败时返回 false。


Sets the fill rule to use while drawing polygons

  • ? ImagickDraw::setFillPatternURL
  • ImagickDraw::setFont ?
  • PHP Manual
  • ImagickDraw
  • Sets the fill rule to use while drawing polygons

ImagickDraw::setFillRule

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFillRule — Sets the fill rule to use while drawing polygons

说明

public ImagickDraw::setFillRule ( int $fill_rule ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the fill rule to use while drawing polygons.

参数

fill_rule

FILLRULE_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setFillRule()

<?php
function setFillRule($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $fillRules = [\Imagick::FILLRULE_NONZERO, \Imagick::FILLRULE_EVENODD];

    $points = 11;
    $size = 150;

    $draw->translate(175, 160);

    for ($x = 0; $x < 2; $x++) {
        $draw->setFillRule($fillRules[$x]);
        $draw->pathStart();
        for ($n = 0; $n < $points * 2; $n++) {

            if ($n >= $points) {
                $angle = fmod($n * 360 * 4 / $points, 360) * pi() / 180;
            }
            else {
                $angle = fmod($n * 360 * 3 / $points, 360) * pi() / 180;
            }

            $positionX = $size * sin($angle);
            $positionY = $size * cos($angle);

            if ($n == 0) {
                $draw->pathMoveToAbsolute($positionX, $positionY);
            }
            else {
                $draw->pathLineToAbsolute($positionX, $positionY);
            }
        }

        $draw->pathClose();
        $draw->pathFinish();

        $draw->translate(325, 0);
    }

    $image = new \Imagick();
    $image->newImage(700, 320, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Sets the fully-specified font to use when annotating with text

  • ? ImagickDraw::setFillRule
  • ImagickDraw::setFontFamily ?
  • PHP Manual
  • ImagickDraw
  • Sets the fully-specified font to use when annotating with text

ImagickDraw::setFont

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFont — Sets the fully-specified font to use when annotating with text

说明

public ImagickDraw::setFont ( string $font_name ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the fully-specified font to use when annotating with text.

参数

font_name

返回值

成功时返回 true。

范例

Example #1 ImagickDraw::setFont()

<?php
function setFont($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);
    $draw->setFontSize(36);

    $draw->setFont("../fonts/Arial.ttf");
    $draw->annotation(50, 50, "Lorem Ipsum!");

    $draw->setFont("../fonts/Consolas.ttf");
    $draw->annotation(50, 100, "Lorem Ipsum!");

    $draw->setFont("../fonts/CANDY.TTF");
    $draw->annotation(50, 150, "Lorem Ipsum!");

    $draw->setFont("../fonts/Inconsolata-dz.otf");
    $draw->annotation(50, 200, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(500, 300, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the font family to use when annotating with text

  • ? ImagickDraw::setFont
  • ImagickDraw::setFontSize ?
  • PHP Manual
  • ImagickDraw
  • Sets the font family to use when annotating with text

ImagickDraw::setFontFamily

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontFamily — Sets the font family to use when annotating with text

说明

public ImagickDraw::setFontFamily ( string $font_family ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the font family to use when annotating with text.

参数

font_family

the font family

返回值

成功时返回 true。

范例

Example #1 ImagickDraw::setFontFamily()

<?php
function setFontFamily($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $strokeColor = new \ImagickPixel($strokeColor);
    $fillColor = new \ImagickPixel($fillColor);

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(2);

    $draw->setFontSize(48);

    $draw->setFontFamily("Times");
    $draw->annotation(50, 50, "Lorem Ipsum!");

    $draw->setFontFamily("AvantGarde");
    $draw->annotation(50, 100, "Lorem Ipsum!");

    $draw->setFontFamily("NewCenturySchlbk");
    $draw->annotation(50, 150, "Lorem Ipsum!");

    $draw->setFontFamily("Palatino");
    $draw->annotation(50, 200, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(450, 250, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the font pointsize to use when annotating with text

  • ? ImagickDraw::setFontFamily
  • ImagickDraw::setFontStretch ?
  • PHP Manual
  • ImagickDraw
  • Sets the font pointsize to use when annotating with text

ImagickDraw::setFontSize

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontSize — Sets the font pointsize to use when annotating with text

说明

public ImagickDraw::setFontSize ( float $pointsize ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the font pointsize to use when annotating with text.

参数

pointsize

the point size

返回值

没有返回值。

范例

Example #1 ImagickDraw::setFontSize()

<?php
function setFontSize($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFont("../fonts/Arial.ttf");

    $sizes = [24, 36, 48, 60, 72];

    foreach ($sizes as $size) {
        $draw->setFontSize($size);
        $draw->annotation(50, ($size * $size / 16), "Lorem Ipsum!");
    }

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the font stretch to use when annotating with text

  • ? ImagickDraw::setFontSize
  • ImagickDraw::setFontStyle ?
  • PHP Manual
  • ImagickDraw
  • Sets the font stretch to use when annotating with text

ImagickDraw::setFontStretch

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontStretch — Sets the font stretch to use when annotating with text

说明

public ImagickDraw::setFontStretch ( int $fontStretch ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the font stretch to use when annotating with text. The AnyStretch enumeration acts as a wild-card "don't care" option.

参数

fontStretch

STRETCH_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setFontStretch()

<?php
function setFontStretch($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(36);

    $fontStretchTypes = [
        \Imagick::STRETCH_ULTRACONDENSED,
        \Imagick::STRETCH_CONDENSED,
        \Imagick::STRETCH_SEMICONDENSED,
        \Imagick::STRETCH_SEMIEXPANDED,
        \Imagick::STRETCH_EXPANDED,
        \Imagick::STRETCH_EXTRAEXPANDED,
        \Imagick::STRETCH_ULTRAEXPANDED,
        \Imagick::STRETCH_ANY
    ];

    $offset = 0;
    foreach ($fontStretchTypes as $fontStretch) {
        $draw->setFontStretch($fontStretch);
        $draw->annotation(50, 75 + $offset, "Lorem Ipsum!");
        $offset += 50;
    }

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the font style to use when annotating with text

  • ? ImagickDraw::setFontStretch
  • ImagickDraw::setFontWeight ?
  • PHP Manual
  • ImagickDraw
  • Sets the font style to use when annotating with text

ImagickDraw::setFontStyle

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontStyle — Sets the font style to use when annotating with text

说明

public ImagickDraw::setFontStyle ( int $style ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the font style to use when annotating with text. The AnyStyle enumeration acts as a wild-card "don't care" option.

参数

style

STYLETYPE_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setFontStyle()

<?php
function setFontStyle($fillColor, $strokeColor, $backgroundColor) {
    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setFontSize(36);
    $draw->setFontStyle(\Imagick::STYLE_NORMAL);
    $draw->annotation(50, 50, "Lorem Ipsum!");

    $draw->setFontStyle(\Imagick::STYLE_ITALIC);
    $draw->annotation(50, 100, "Lorem Ipsum!");

    $draw->setFontStyle(\Imagick::STYLE_OBLIQUE);
    $draw->annotation(50, 150, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(350, 300, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the font weight

  • ? ImagickDraw::setFontStyle
  • ImagickDraw::setGravity ?
  • PHP Manual
  • ImagickDraw
  • Sets the font weight

ImagickDraw::setFontWeight

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setFontWeight — Sets the font weight

说明

public ImagickDraw::setFontWeight ( int $font_weight ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the font weight to use when annotating with text.

参数

font_weight

返回值

范例

Example #1 ImagickDraw::setFontWeight()

<?php
function setFontWeight($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(1);

    $draw->setFontSize(36);

    $draw->setFontWeight(100);
    $draw->annotation(50, 50, "Lorem Ipsum!");

    $draw->setFontWeight(200);
    $draw->annotation(50, 100, "Lorem Ipsum!");

    $draw->setFontWeight(400);
    $draw->annotation(50, 150, "Lorem Ipsum!");

    $draw->setFontWeight(800);
    $draw->annotation(50, 200, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the text placement gravity

  • ? ImagickDraw::setFontWeight
  • ImagickDraw::setResolution ?
  • PHP Manual
  • ImagickDraw
  • Sets the text placement gravity

ImagickDraw::setGravity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setGravity — Sets the text placement gravity

说明

public ImagickDraw::setGravity ( int $gravity ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the text placement gravity to use when annotating with text.

参数

gravity

GRAVITY_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setGravity()

<?php
function setGravity($fillColor, $strokeColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setFontSize(24);

    $gravitySettings = array(
        \Imagick::GRAVITY_NORTHWEST => 'NorthWest',
        \Imagick::GRAVITY_NORTH => 'North',
        \Imagick::GRAVITY_NORTHEAST => 'NorthEast',
        \Imagick::GRAVITY_WEST => 'West',
        \Imagick::GRAVITY_CENTER => 'Centre',
        \Imagick::GRAVITY_SOUTHWEST => 'SouthWest',
        \Imagick::GRAVITY_SOUTH => 'South',
        \Imagick::GRAVITY_SOUTHEAST => 'SouthEast',
        \Imagick::GRAVITY_EAST => 'East'
    );

    $draw->setFont("../fonts/Arial.ttf");

    foreach ($gravitySettings as $type => $description) {
        $draw->setGravity($type);
        $draw->annotation(50, 50, '"' . $description . '"');
    }

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Description

  • ? ImagickDraw::setGravity
  • ImagickDraw::setStrokeAlpha ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::setResolution

(PECL imagick 3 >= 3.1.0)

ImagickDraw::setResolution — Description

说明

public ImagickDraw::setResolution ( float $x_resolution , float $y_resolution ) : bool

Sets the resolution.

参数

x_resolution

y_resolution

返回值

成功时返回 true。


Specifies the opacity of stroked object outlines

  • ? ImagickDraw::setResolution
  • ImagickDraw::setStrokeAntialias ?
  • PHP Manual
  • ImagickDraw
  • Specifies the opacity of stroked object outlines

ImagickDraw::setStrokeAlpha

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeAlpha — Specifies the opacity of stroked object outlines

说明

public ImagickDraw::setStrokeAlpha ( float $opacity ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the opacity of stroked object outlines.

参数

opacity

opacity

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeAlpha()

<?php
function setStrokeAlpha($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(4);
    $draw->line(100, 100, 400, 145);
    $draw->rectangle(100, 200, 225, 350);
    $draw->setStrokeOpacity(0.1);
    $draw->line(100, 120, 400, 165);
    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Controls whether stroked outlines are antialiased

  • ? ImagickDraw::setStrokeAlpha
  • ImagickDraw::setStrokeColor ?
  • PHP Manual
  • ImagickDraw
  • Controls whether stroked outlines are antialiased

ImagickDraw::setStrokeAntialias

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeAntialias — Controls whether stroked outlines are antialiased

说明

public ImagickDraw::setStrokeAntialias ( bool $stroke_antialias ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Controls whether stroked outlines are antialiased. Stroked outlines are antialiased by default. When antialiasing is disabled stroked pixels are thresholded to determine if the stroke color or underlying canvas color should be used.

参数

stroke_antialias

the antialias setting

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeAntialias()

<?php
function setStrokeAntialias($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setStrokeAntialias(false);
    $draw->line(100, 100, 400, 105);

    $draw->line(100, 140, 400, 185);

    $draw->setStrokeAntialias(true);
    $draw->line(100, 110, 400, 115);
    $draw->line(100, 150, 400, 195);

    $image = new \Imagick();
    $image->newImage(500, 250, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Sets the color used for stroking object outlines

  • ? ImagickDraw::setStrokeAntialias
  • ImagickDraw::setStrokeDashArray ?
  • PHP Manual
  • ImagickDraw
  • Sets the color used for stroking object outlines

ImagickDraw::setStrokeColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeColor — Sets the color used for stroking object outlines

说明

public ImagickDraw::setStrokeColor ( ImagickPixel $stroke_pixel ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the color used for stroking object outlines.

参数

stroke_pixel

the stroke color

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeColor()

<?php
function setStrokeColor($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(5);

    $draw->line(100, 100, 400, 145);
    $draw->rectangle(100, 200, 225, 350);

    $draw->setStrokeOpacity(0.1);
    $draw->line(100, 120, 400, 165);
    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Specifies the pattern of dashes and gaps used to stroke paths

  • ? ImagickDraw::setStrokeColor
  • ImagickDraw::setStrokeDashOffset ?
  • PHP Manual
  • ImagickDraw
  • Specifies the pattern of dashes and gaps used to stroke paths

ImagickDraw::setStrokeDashArray

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeDashArray — Specifies the pattern of dashes and gaps used to stroke paths

说明

public ImagickDraw::setStrokeDashArray ( array $dashArray ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the pattern of dashes and gaps used to stroke paths. The strokeDashArray represents an array of numbers that specify the lengths of alternating dashes and gaps in pixels. If an odd number of values is provided, then the list of values is repeated to yield an even number of values. To remove an existing dash array, pass a zero number_elements argument and null dash_array. A typical strokeDashArray_ array might contain the members 5 3 2.

参数

dashArray

array of floats

返回值

成功时返回 true。

范例

Example #1 ImagickDraw::setStrokeDashArray()

<?php
function setStrokeDashArray($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(4);

    $draw->setStrokeDashArray([10, 10]);
    $draw->rectangle(100, 50, 225, 175);

    $draw->setStrokeDashArray([20, 5, 20, 5, 5, 5,]);
    $draw->rectangle(275, 50, 400, 175);

    $draw->setStrokeDashArray([20, 5, 20, 5, 5]);
    $draw->rectangle(100, 200, 225, 350);

    $draw->setStrokeDashArray([1, 1, 1, 1, 2, 2, 3, 3, 5, 5, 8, 8, 13, 13, 21, 21, 34, 34, 55, 55, 89, 89, 144, 144, 233, 233, 377, 377, 610, 610, 987, 987, 1597, 1597, 2584, 2584, 4181, 4181,]);

    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Specifies the offset into the dash pattern to start the dash

  • ? ImagickDraw::setStrokeDashArray
  • ImagickDraw::setStrokeLineCap ?
  • PHP Manual
  • ImagickDraw
  • Specifies the offset into the dash pattern to start the dash

ImagickDraw::setStrokeDashOffset

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeDashOffset — Specifies the offset into the dash pattern to start the dash

说明

public ImagickDraw::setStrokeDashOffset ( float $dash_offset ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the offset into the dash pattern to start the dash.

参数

dash_offset

dash offset

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeDashOffset()

<?php
function setStrokeDashOffset($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(4);
    $draw->setStrokeDashArray([20, 20]);
    $draw->setStrokeDashOffset(0);
    $draw->rectangle(100, 50, 225, 175);

    //Start the dash effect halfway through the solid portion
    $draw->setStrokeDashOffset(10);
    $draw->rectangle(275, 50, 400, 175);

    //Start the dash effect on the space portion
    $draw->setStrokeDashOffset(20);
    $draw->rectangle(100, 200, 225, 350);
    $draw->setStrokeDashOffset(5);
    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Specifies the shape to be used at the end of open subpaths when they are stroked

  • ? ImagickDraw::setStrokeDashOffset
  • ImagickDraw::setStrokeLineJoin ?
  • PHP Manual
  • ImagickDraw
  • Specifies the shape to be used at the end of open subpaths when they are stroked

ImagickDraw::setStrokeLineCap

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeLineCap — Specifies the shape to be used at the end of open subpaths when they are stroked

说明

public ImagickDraw::setStrokeLineCap ( int $linecap ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the shape to be used at the end of open subpaths when they are stroked.

参数

linecap

LINECAP_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeLineCap()

<?php
function setStrokeLineCap($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(25);

    $lineTypes = [\Imagick::LINECAP_BUTT, \Imagick::LINECAP_ROUND, \Imagick::LINECAP_SQUARE,];

    $offset = 0;

    foreach ($lineTypes as $lineType) {
        $draw->setStrokeLineCap($lineType);
        $draw->line(50 + $offset, 50, 50 + $offset, 250);
        $offset += 50;
    }

    $imagick = new \Imagick();
    $imagick->newImage(300, 300, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Specifies the shape to be used at the corners of paths when they are stroked

  • ? ImagickDraw::setStrokeLineCap
  • ImagickDraw::setStrokeMiterLimit ?
  • PHP Manual
  • ImagickDraw
  • Specifies the shape to be used at the corners of paths when they are stroked

ImagickDraw::setStrokeLineJoin

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeLineJoin — Specifies the shape to be used at the corners of paths when they are stroked

说明

public ImagickDraw::setStrokeLineJoin ( int $linejoin ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the shape to be used at the corners of paths (or other vector shapes) when they are stroked.

参数

linejoin

LINEJOIN_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeLineJoin()

<?php
function setStrokeLineJoin($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);

    $draw->setStrokeWidth(20);

    $offset = 220;

    $lineJoinStyle = [
        \Imagick::LINEJOIN_MITER,
        \Imagick::LINEJOIN_ROUND,
        \Imagick::LINEJOIN_BEVEL,
        ];

    for ($x = 0; $x < count($lineJoinStyle); $x++) {
        $draw->setStrokeLineJoin($lineJoinStyle[$x]);
        $points = [
            ['x' => 40 * 5, 'y' => 10 * 5 + $x * $offset],
            ['x' => 20 * 5, 'y' => 20 * 5 + $x * $offset],
            ['x' => 70 * 5, 'y' => 50 * 5 + $x * $offset],
            ['x' => 40 * 5, 'y' => 10 * 5 + $x * $offset],
        ];

        $draw->polyline($points);
    }

    $image = new \Imagick();
    $image->newImage(500, 700, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Specifies the miter limit

  • ? ImagickDraw::setStrokeLineJoin
  • ImagickDraw::setStrokeOpacity ?
  • PHP Manual
  • ImagickDraw
  • Specifies the miter limit

ImagickDraw::setStrokeMiterLimit

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeMiterLimit — Specifies the miter limit

说明

public ImagickDraw::setStrokeMiterLimit ( int $miterlimit ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the miter limit. When two line segments meet at a sharp angle and miter joins have been specified for 'lineJoin', it is possible for the miter to extend far beyond the thickness of the line stroking the path. The miterLimit' imposes a limit on the ratio of the miter length to the 'lineWidth'.

参数

miterlimit

the miter limit

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeMiterLimit()

<?php
function setStrokeMiterLimit($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeOpacity(0.6);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(10);

    $yOffset = 100;

    $draw->setStrokeLineJoin(\Imagick::LINEJOIN_MITER);

    for ($y = 0; $y < 3; $y++) {

        $draw->setStrokeMiterLimit(40 * $y);

        $points = [
            ['x' => 22 * 3, 'y' => 15 * 4 + $y * $yOffset],
            ['x' => 20 * 3, 'y' => 20 * 4 + $y * $yOffset],
            ['x' => 70 * 5, 'y' => 45 * 4 + $y * $yOffset],
        ];

        $draw->polygon($points);
    }

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    $image->setImageType(\Imagick::IMGTYPE_PALETTE);
    $image->setImageCompressionQuality(100);
    $image->stripImage();

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Specifies the opacity of stroked object outlines

  • ? ImagickDraw::setStrokeMiterLimit
  • ImagickDraw::setStrokePatternURL ?
  • PHP Manual
  • ImagickDraw
  • Specifies the opacity of stroked object outlines

ImagickDraw::setStrokeOpacity

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeOpacity — Specifies the opacity of stroked object outlines

说明

public ImagickDraw::setStrokeOpacity ( float $stroke_opacity ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the opacity of stroked object outlines.

参数

stroke_opacity

stroke opacity. 1.0 is fully opaque

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeOpacity()

<?php
function setStrokeOpacity($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();

    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(10);
    $draw->setStrokeOpacity(1);
    $draw->line(100, 80, 400, 125);
    $draw->rectangle(25, 200, 150, 350);
    $draw->setStrokeOpacity(0.5);
    $draw->line(100, 100, 400, 145);
    $draw->rectangle(200, 200, 325, 350);
    $draw->setStrokeOpacity(0.2);
    $draw->line(100, 120, 400, 165);
    $draw->rectangle(375, 200, 500, 350);

    $image = new \Imagick();
    $image->newImage(550, 400, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Sets the pattern used for stroking object outlines

  • ? ImagickDraw::setStrokeOpacity
  • ImagickDraw::setStrokeWidth ?
  • PHP Manual
  • ImagickDraw
  • Sets the pattern used for stroking object outlines

ImagickDraw::setStrokePatternURL

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokePatternURL — Sets the pattern used for stroking object outlines

说明

public ImagickDraw::setStrokePatternURL ( string $stroke_url ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the pattern used for stroking object outlines.

参数

stroke_url

stroke URL

返回值

imagick.imagickdraw.return.success;


Sets the width of the stroke used to draw object outlines

  • ? ImagickDraw::setStrokePatternURL
  • ImagickDraw::setTextAlignment ?
  • PHP Manual
  • ImagickDraw
  • Sets the width of the stroke used to draw object outlines

ImagickDraw::setStrokeWidth

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setStrokeWidth — Sets the width of the stroke used to draw object outlines

说明

public ImagickDraw::setStrokeWidth ( float $stroke_width ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the width of the stroke used to draw object outlines.

参数

stroke_width

stroke width

返回值

没有返回值。

范例

Example #1 ImagickDraw::setStrokeWidth()

<?php
function setStrokeWidth($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeWidth(1);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->line(100, 100, 400, 145);
    $draw->rectangle(100, 200, 225, 350);
    $draw->setStrokeWidth(5);
    $draw->line(100, 120, 400, 165);
    $draw->rectangle(275, 200, 400, 350);

    $image = new \Imagick();
    $image->newImage(500, 400, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Specifies a text alignment

  • ? ImagickDraw::setStrokeWidth
  • ImagickDraw::setTextAntialias ?
  • PHP Manual
  • ImagickDraw
  • Specifies a text alignment

ImagickDraw::setTextAlignment

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextAlignment — Specifies a text alignment

说明

public ImagickDraw::setTextAlignment ( int $alignment ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies a text alignment to be applied when annotating with text.

参数

alignment

ALIGN_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setTextAlignment()

<?php
function setTextAlignment($strokeColor, $fillColor, $backgroundColor) {
    $draw = new \ImagickDraw();
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setFontSize(36);

    $draw->setTextAlignment(\Imagick::ALIGN_LEFT);
    $draw->annotation(250, 75, "Lorem Ipsum!");
    $draw->setTextAlignment(\Imagick::ALIGN_CENTER);
    $draw->annotation(250, 150, "Lorem Ipsum!");
    $draw->setTextAlignment(\Imagick::ALIGN_RIGHT);
    $draw->annotation(250, 225, "Lorem Ipsum!");
    $draw->line(250, 0, 250, 500);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Controls whether text is antialiased

  • ? ImagickDraw::setTextAlignment
  • ImagickDraw::setTextDecoration ?
  • PHP Manual
  • ImagickDraw
  • Controls whether text is antialiased

ImagickDraw::setTextAntialias

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextAntialias — Controls whether text is antialiased

说明

public ImagickDraw::setTextAntialias ( bool $antiAlias ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Controls whether text is antialiased. Text is antialiased by default.

参数

antiAlias

返回值

没有返回值。

范例

Example #1 ImagickDraw::setTextAntialias()

<?php
function setTextAntialias($fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();
    $draw->setStrokeColor('none');
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(1);
    $draw->setFontSize(32);
    $draw->setTextAntialias(false);
    $draw->annotation(5, 30, "Lorem Ipsum!");
    $draw->setTextAntialias(true);
    $draw->annotation(5, 65, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(220, 80, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    //Scale the image so that people can see the aliasing.
    $imagick->scaleImage(220 * 6, 80 * 6);
    $imagick->cropImage(640, 480, 0, 0);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Specifies a decoration

  • ? ImagickDraw::setTextAntialias
  • ImagickDraw::setTextEncoding ?
  • PHP Manual
  • ImagickDraw
  • Specifies a decoration

ImagickDraw::setTextDecoration

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextDecoration — Specifies a decoration

说明

public ImagickDraw::setTextDecoration ( int $decoration ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies a decoration to be applied when annotating with text.

参数

decoration

DECORATION_ constant

返回值

没有返回值。

范例

Example #1 ImagickDraw::setTextDecoration()

<?php
function setTextDecoration($strokeColor, $fillColor, $backgroundColor, $textDecoration) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->setTextDecoration($textDecoration);
    $draw->annotation(50, 75, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(500, 200, $backgroundColor);
    $imagick->setImageFormat("png");
    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Specifies the text code set

  • ? ImagickDraw::setTextDecoration
  • ImagickDraw::setTextInterlineSpacing ?
  • PHP Manual
  • ImagickDraw
  • Specifies the text code set

ImagickDraw::setTextEncoding

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextEncoding — Specifies the text code set

说明

public ImagickDraw::setTextEncoding ( string $encoding ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the code set to use for text annotations. The only character encoding which may be specified at this time is "UTF-8" for representing Unicode as a sequence of bytes. Specify an empty string to set text encoding to the system's default. Successful text annotation using Unicode may require fonts designed to support Unicode.

参数

encoding

the encoding name

返回值

没有返回值。


Description

  • ? ImagickDraw::setTextEncoding
  • ImagickDraw::setTextInterwordSpacing ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::setTextInterlineSpacing

(PECL imagick 3 >= 3.1.0)

ImagickDraw::setTextInterlineSpacing — Description

说明

public ImagickDraw::setTextInterlineSpacing ( float $spacing ) : bool

Sets the text interline spacing.

Warning

本函数还未编写文档，仅有参数列表。

参数

spacing

返回值

成功时返回 true。


Description

  • ? ImagickDraw::setTextInterlineSpacing
  • ImagickDraw::setTextKerning ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::setTextInterwordSpacing

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickDraw::setTextInterwordSpacing — Description

说明

public ImagickDraw::setTextInterwordSpacing ( float $spacing ) : bool

Sets the text interword spacing.

参数

spacing

返回值

成功时返回 true。


Description

  • ? ImagickDraw::setTextInterwordSpacing
  • ImagickDraw::setTextUnderColor ?
  • PHP Manual
  • ImagickDraw
  • Description

ImagickDraw::setTextKerning

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickDraw::setTextKerning — Description

说明

public ImagickDraw::setTextKerning ( float $kerning ) : bool

Sets the text kerning

Warning

本函数还未编写文档，仅有参数列表。

参数

kerning

返回值

成功时返回 true。


Specifies the color of a background rectangle

  • ? ImagickDraw::setTextKerning
  • ImagickDraw::setVectorGraphics ?
  • PHP Manual
  • ImagickDraw
  • Specifies the color of a background rectangle

ImagickDraw::setTextUnderColor

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setTextUnderColor — Specifies the color of a background rectangle

说明

public ImagickDraw::setTextUnderColor ( ImagickPixel $under_color ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Specifies the color of a background rectangle to place under text annotations.

参数

under_color

the under color

返回值

没有返回值。

范例

Example #1 ImagickDraw::setTextUnderColor()

<?php
function setTextUnderColor($strokeColor, $fillColor, $backgroundColor, $textUnderColor) {
    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);
    $draw->annotation(50, 75, "Lorem Ipsum!");
    $draw->setTextUnderColor($textUnderColor);
    $draw->annotation(50, 175, "Lorem Ipsum!");

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the vector graphics

  • ? ImagickDraw::setTextUnderColor
  • ImagickDraw::setViewbox ?
  • PHP Manual
  • ImagickDraw
  • Sets the vector graphics

ImagickDraw::setVectorGraphics

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setVectorGraphics — Sets the vector graphics

说明

public ImagickDraw::setVectorGraphics ( string $xml ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the vector graphics associated with the specified ImagickDraw object. Use this method with ImagickDraw::getVectorGraphics() as a method to persist the vector graphics state.

参数

xml

xml containing the vector graphics

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ImagickDraw::setVectorGraphics()

<?php
function setVectorGraphics() {
    //Setup a draw object with some drawing in it.
    $draw = new \ImagickDraw();
    $draw->setFillColor("red");
    $draw->circle(20, 20, 50, 50);
    $draw->setFillColor("blue");
    $draw->circle(50, 70, 50, 50);
    $draw->rectangle(50, 120, 80, 150);

    //Get the drawing as a string
    $SVG = $draw->getVectorGraphics();

    //$svg is a string, and could be saved anywhere a string can be saved

    //Use the saved drawing to generate a new draw object
    $draw2 = new \ImagickDraw();
    //Apparently the SVG text is missing the root element.
    $draw2->setVectorGraphics("<root>".$SVG."</root>");

    $imagick = new \Imagick();
    $imagick->newImage(200, 200, 'white');
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw2);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Sets the overall canvas size

  • ? ImagickDraw::setVectorGraphics
  • ImagickDraw::skewX ?
  • PHP Manual
  • ImagickDraw
  • Sets the overall canvas size

ImagickDraw::setViewbox

(PECL imagick 2, PECL imagick 3)

ImagickDraw::setViewbox — Sets the overall canvas size

说明

public ImagickDraw::setViewbox ( int $x1 , int $y1 , int $x2 , int $y2 ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the overall canvas size to be recorded with the drawing vector data. Usually this will be specified using the same size as the canvas image. When the vector data is saved to SVG or MVG formats, the viewbox is use to specify the size of the canvas image that a viewer will render the vector data on.

参数

x1

left x coordinate

y1

left y coordinate

x2

right x coordinate

y2

right y coordinate

返回值

没有返回值。

范例

Example #1 ImagickDraw::setViewBox()

<?php
function setViewBox($strokeColor, $fillColor, $backgroundColor) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->setStrokeWidth(2);
    $draw->setFontSize(72);

    /*

    Sets the overall canvas size to be recorded with the drawing vector data. Usually this will be specified using the same size as the canvas image. When the vector data is saved to SVG or MVG formats, the viewbox is use to specify the size of the canvas image that a viewer will render the vector data on.

     */

    $draw->circle(250, 250, 250, 0);
    $draw->setviewbox(0, 0, 200, 200);
    $draw->circle(125, 250, 250, 250);
    $draw->translate(250, 125);
    $draw->circle(0, 0, 125, 0);

    $imagick = new \Imagick();
    $imagick->newImage(500, 500, $backgroundColor);
    $imagick->setImageFormat("png");

    $imagick->drawImage($draw);

    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>


Skews the current coordinate system in the horizontal direction

  • ? ImagickDraw::setViewbox
  • ImagickDraw::skewY ?
  • PHP Manual
  • ImagickDraw
  • Skews the current coordinate system in the horizontal direction

ImagickDraw::skewX

(PECL imagick 2, PECL imagick 3)

ImagickDraw::skewX — Skews the current coordinate system in the horizontal direction

说明

public ImagickDraw::skewX ( float $degrees ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Skews the current coordinate system in the horizontal direction.

参数

degrees

degrees to skew

返回值

没有返回值。

范例

Example #1 ImagickDraw::skewX()

<?php
function skewX($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor,
               $startX, $startY, $endX, $endY, $skew) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(2);
    $draw->setFillColor($fillColor);
    $draw->rectangle($startX, $startY, $endX, $endY);
    $draw->setFillColor($fillModifiedColor);
    $draw->skewX($skew);
    $draw->rectangle($startX, $startY, $endX, $endY);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Skews the current coordinate system in the vertical direction

  • ? ImagickDraw::skewX
  • ImagickDraw::translate ?
  • PHP Manual
  • ImagickDraw
  • Skews the current coordinate system in the vertical direction

ImagickDraw::skewY

(PECL imagick 2, PECL imagick 3)

ImagickDraw::skewY — Skews the current coordinate system in the vertical direction

说明

public ImagickDraw::skewY ( float $degrees ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Skews the current coordinate system in the vertical direction.

参数

degrees

degrees to skew

返回值

没有返回值。

范例

Example #1 ImagickDraw::skewY()

<?php
function skewY($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor,
               $startX, $startY, $endX, $endY, $skew) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setStrokeWidth(2);
    $draw->setFillColor($fillColor);
    $draw->rectangle($startX, $startY, $endX, $endY);
    $draw->setFillColor($fillModifiedColor);
    $draw->skewY($skew);
    $draw->rectangle($startX, $startY, $endX, $endY);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");
    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Applies a translation to the current coordinate system

  • ? ImagickDraw::skewY
  • ImagickPixel ?
  • PHP Manual
  • ImagickDraw
  • Applies a translation to the current coordinate system

ImagickDraw::translate

(PECL imagick 2, PECL imagick 3)

ImagickDraw::translate — Applies a translation to the current coordinate system

说明

public ImagickDraw::translate ( float $x , float $y ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Applies a translation to the current coordinate system which moves the coordinate system origin to the specified coordinate.

参数

x

horizontal translation

y

vertical translation

返回值

没有返回值。

范例

Example #1 ImagickDraw::translate()

<?php
function translate($strokeColor, $fillColor, $backgroundColor, $fillModifiedColor,
                   $startX, $startY, $endX, $endY, $translateX, $translateY) {

    $draw = new \ImagickDraw();

    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->rectangle($startX, $startY, $endX, $endY);

    $draw->setFillColor($fillModifiedColor);
    $draw->translate($translateX, $translateY);
    $draw->rectangle($startX, $startY, $endX, $endY);

    $image = new \Imagick();
    $image->newImage(500, 500, $backgroundColor);
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


The ImagickPixel class

(PECL imagick 2, PECL imagick 3)

类摘要

ImagickPixel {
public clear ( ) : bool
public __construct ( string $color = ? )
public destroy ( ) : bool
public getColor ( int $normalized = 0 ) : array
public getColorAsString ( ) : string
public getColorCount ( ) : int
public getColorQuantum ( ) : array
public getColorValue ( int $color ) : float
public getColorValueQuantum ( int $color ) : int|float
public getHSL ( ) : array
public getIndex ( ) : int
public isPixelSimilar ( ImagickPixel $color , float $fuzz ) : bool
public isPixelSimilarQuantum ( string $color , string $fuzz = ? ) : bool
public isSimilar ( ImagickPixel $color , float $fuzz ) : bool
public setColor ( string $color ) : bool
public setcolorcount ( int $colorCount ) : bool
public setColorValue ( int $color , float $value ) : bool
public setColorValueQuantum ( int $color , int|float $value ) : bool
public setHSL ( float $hue , float $saturation , float $luminosity ) : bool
public setIndex ( int $index ) : bool
}

Table of Contents

  • ImagickPixel::clear — Clears resources associated with this object
  • ImagickPixel::__construct — The ImagickPixel constructor
  • ImagickPixel::destroy — Deallocates resources associated with this object
  • ImagickPixel::getColor — Returns the color
  • ImagickPixel::getColorAsString — Returns the color as a string
  • ImagickPixel::getColorCount — Returns the color count associated with this color
  • ImagickPixel::getColorQuantum — Description
  • ImagickPixel::getColorValue — Gets the normalized value of the provided color channel
  • ImagickPixel::getColorValueQuantum — Description
  • ImagickPixel::getHSL — Returns the normalized HSL color of the ImagickPixel object
  • ImagickPixel::getIndex — Description
  • ImagickPixel::isPixelSimilar — Check the distance between this color and another
  • ImagickPixel::isPixelSimilarQuantum — Description
  • ImagickPixel::isSimilar — Check the distance between this color and another
  • ImagickPixel::setColor — Sets the color
  • ImagickPixel::setColorCount — Description
  • ImagickPixel::setColorValue — Sets the normalized value of one of the channels
  • ImagickPixel::setColorValueQuantum — Description
  • ImagickPixel::setHSL — Sets the normalized HSL color
  • ImagickPixel::setIndex — Description


Clears resources associated with this object

  • ? ImagickPixel
  • ImagickPixel::__construct ?
  • PHP Manual
  • ImagickPixel
  • Clears resources associated with this object

ImagickPixel::clear

(PECL imagick 2, PECL imagick 3)

ImagickPixel::clear — Clears resources associated with this object

说明

public ImagickPixel::clear ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Clears the ImagickPixel object, leaving it in a fresh state. This also unsets any color associated with the object.

返回值

成功时返回 true。


The ImagickPixel constructor

  • ? ImagickPixel::clear
  • ImagickPixel::destroy ?
  • PHP Manual
  • ImagickPixel
  • The ImagickPixel constructor

ImagickPixel::__construct

(PECL imagick 2, PECL imagick 3)

ImagickPixel::__construct — The ImagickPixel constructor

说明

public ImagickPixel::__construct ( string $color = ? )
Warning

本函数还未编写文档，仅有参数列表。

Constructs an ImagickPixel object. If a color is specified, the object is constructed and then initialised with that color before being returned.

参数

color

The optional color string to use as the initial value of this object.

返回值

Returns an ImagickPixel object on success, throwing ImagickPixelException on failure.

范例

Example #1 ImagickPixel::construct()

<?php
function construct() {

    $columns = 4;

    $exampleColors = array(
        "rgba(100%, 0%, 0%, 0.5)",
        "hsb(33.3333%, 100%,  75%)", // medium green
        "hsl(120, 255,   191.25)", //medium green
        "graya(50%, 0.5)", //  semi-transparent mid gray
        "LightCoral", "none", //"cmyk(0.9, 0.48, 0.83, 0.50)",
        "#f00", //  #rgb
        "#ff0000", //  #rrggbb
        "#ff0000ff", //  #rrggbbaa
        "#ffff00000000", //  #rrrrggggbbbb
        "#ffff00000000ffff", //  #rrrrggggbbbbaaaa
        "rgb(255, 0, 0)", //  an integer in the range 0—255 for each component
        "rgb(100.0%, 0.0%, 0.0%)", //  a float in the range 0—100% for each component
        "rgb(255, 0, 0)", //  range 0 - 255
        "rgba(255, 0, 0, 1.0)", //  the same, with an explicit alpha value
        "rgb(100%, 0%, 0%)", //  range 0.0% - 100.0%
        "rgba(100%, 0%, 0%, 1.0)", //  the same, with an explicit alpha value
    );

    $draw = new \ImagickDraw();
    $count = 0;
    $black = new \ImagickPixel('rgb(0, 0, 0)');

    foreach ($exampleColors as $exampleColor) {
        $color = new \ImagickPixel($exampleColor);

        $draw->setstrokewidth(1.0);
        $draw->setStrokeColor($black);
        $draw->setFillColor($color);
        $offsetX = ($count % $columns) * 50 + 5;
        $offsetY = intval($count / $columns) * 50 + 5;
        $draw->rectangle(0 + $offsetX, 0 + $offsetY, 40 + $offsetX, 40 + $offsetY);
        $count++;
    }

    $image = new \Imagick();
    $image->newImage(350, 350, "blue");
    $image->setImageFormat("png");
    $image->drawImage($draw);
    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Deallocates resources associated with this object

  • ? ImagickPixel::__construct
  • ImagickPixel::getColor ?
  • PHP Manual
  • ImagickPixel
  • Deallocates resources associated with this object

ImagickPixel::destroy

(PECL imagick 2, PECL imagick 3)

ImagickPixel::destroy — Deallocates resources associated with this object

说明

public ImagickPixel::destroy ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Deallocates any resources used by the ImagickPixel object, and unsets any associated color. The object should not be used after the destroy function has been called.

返回值

成功时返回 true。


Returns the color

  • ? ImagickPixel::destroy
  • ImagickPixel::getColorAsString ?
  • PHP Manual
  • ImagickPixel
  • Returns the color

ImagickPixel::getColor

(PECL imagick 2, PECL imagick 3)

ImagickPixel::getColor — Returns the color

说明

public ImagickPixel::getColor ( int $normalized = 0 ) : array

Returns the color described by the ImagickPixel object, as an array. If the color has an opacity channel set, this is provided as a fourth value in the list.

参数

normalized

Normalize the color values. Possible values are 0, 1 or 2.

List of possible values for normalized
normalized | Description
0 | The RGB values are returned as ints in the range 0 to 255 (inclusive.) The alpha value is returned as int and is either 0 or 1.
1 | The RGBA values are returned as floats in the range 0 to 1 (inclusive.)
2 | The RGBA values are returned as ints in the range 0 to 255 (inclusive.)

返回值

An array of channel values. Throws ImagickPixelException on error.

范例

Example #1 Basic Imagick::getColor() usage

<?php

//Create an ImagickPixel with the predefined color 'brown'
$color = new ImagickPixel('brown');

//Set the color to have an alpha of 25%
$color->setColorValue(Imagick::COLOR_ALPHA, 64 / 256.0);

$colorInfo = $color->getColor();

echo "Standard values".PHP_EOL;
print_r($colorInfo);

$colorInfo = $color->getColor(1);

echo "Normalized values:".PHP_EOL;
print_r($colorInfo);

?>

以上例程会输出：

Standard values
Array
(
    [r] => 165
    [g] => 42
    [b] => 42
    [a] => 0
)
Normalized values:
Array
(
    [r] => 0.64705882352941
    [g] => 0.16470588235294
    [b] => 0.16470588235294
    [a] => 0.25000381475547
)


Returns the color as a string

  • ? ImagickPixel::getColor
  • ImagickPixel::getColorCount ?
  • PHP Manual
  • ImagickPixel
  • Returns the color as a string

ImagickPixel::getColorAsString

(PECL imagick 2 >= 2.1.0, PECL imagick 3)

ImagickPixel::getColorAsString — Returns the color as a string

说明

public ImagickPixel::getColorAsString ( ) : string

Returns the color of the ImagickPixel object as a string.

参数

此函数没有参数。

返回值

Returns the color of the ImagickPixel object as a string.

范例

Example #1 Basic Imagick::getColorAsString() usage

<?php

//Create an ImagickPixel with the predefined color 'brown'
$color = new ImagickPixel('brown');

$color->setColorValue(Imagick::COLOR_ALPHA, 64 / 256.0);

$colorInfo = $color->getColorAsString();

print_r($colorInfo);
?>

以上例程会输出：

rgb(165,42,42)

注释

Note: Alpha not returned

This function does not return the alpha value of the color in the string.


Returns the color count associated with this color

  • ? ImagickPixel::getColorAsString
  • ImagickPixel::getColorQuantum ?
  • PHP Manual
  • ImagickPixel
  • Returns the color count associated with this color

ImagickPixel::getColorCount

(PECL imagick 2, PECL imagick 3)

ImagickPixel::getColorCount — Returns the color count associated with this color

说明

public ImagickPixel::getColorCount ( ) : int

Returns the color count associated with this color.

The color count is the number of pixels in the image that have the same color as this ImagickPixel.

ImagickPixel::getColorCount appears to only work for ImagickPixel objects created through Imagick::getImageHistogram()

返回值

Returns the color count as an integer on success, throws ImagickPixelException on failure.

范例

Example #1 ImagickPixel getColorCount()

<?php
    $imagick = new \Imagick();
    $imagick->newPseudoImage(640, 480, "magick:logo");
    $histogramElements = $imagick->getImageHistogram();
    $lastColor = array_pop($histogramElements);
    echo "Last pixel color count is: ".$lastColor->getColorCount();
?>

The output for this will be similar to:

Last pixel color count is: 256244


Description

  • ? ImagickPixel::getColorCount
  • ImagickPixel::getColorValue ?
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::getColorQuantum

(No version information available, might only be in Git)

ImagickPixel::getColorQuantum — Description

说明

public ImagickPixel::getColorQuantum ( ) : array

Returns the color of the pixel in an array as Quantum values. If ImageMagick was compiled as HDRI these will be floats, otherwise they will be integers.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns an array with keys "r", "g", "b", "a".


Gets the normalized value of the provided color channel

  • ? ImagickPixel::getColorQuantum
  • ImagickPixel::getColorValueQuantum ?
  • PHP Manual
  • ImagickPixel
  • Gets the normalized value of the provided color channel

ImagickPixel::getColorValue

(PECL imagick 2, PECL imagick 3)

ImagickPixel::getColorValue — Gets the normalized value of the provided color channel

说明

public ImagickPixel::getColorValue ( int $color ) : float

Retrieves the value of the color channel specified, as a floating-point number between 0 and 1.

参数

color

The color to get the value of, specified as one of the Imagick color constants. This can be one of the RGB colors, CMYK colors, alpha and opacity e.g (Imagick::COLOR_BLUE, Imagick::COLOR_MAGENTA).

返回值

The value of the channel, as a normalized floating-point number, throwing ImagickPixelException on error.

范例

Example #1 Basic Imagick::getColorValue() usage

<?php

$color = new ImagickPixel('rgba(90%, 20%, 20%, 0.75)');

echo "Alpha value is ".$color->getColorValue(Imagick::COLOR_ALPHA).PHP_EOL;
echo "".PHP_EOL;
echo "Red value is ".$color->getColorValue(Imagick::COLOR_RED).PHP_EOL;
echo "Green value is ".$color->getColorValue(Imagick::COLOR_GREEN).PHP_EOL;
echo "Blue value is ".$color->getColorValue(Imagick::COLOR_BLUE).PHP_EOL;
echo "".PHP_EOL;
echo "Cyan value is ".$color->getColorValue(Imagick::COLOR_CYAN).PHP_EOL;
echo "Magenta value is ".$color->getColorValue(Imagick::COLOR_MAGENTA).PHP_EOL;
echo "Yellow value is ".$color->getColorValue(Imagick::COLOR_YELLOW).PHP_EOL;
echo "Black value is ".$color->getColorValue(Imagick::COLOR_BLACK).PHP_EOL;

?>

以上例程会输出：

Alpha value is 0.74999618524453

Red value is 0.90000762951095
Green value is 0.2
Blue value is 0.2

Cyan value is 0.90000762951095
Magenta value is 0.2
Yellow value is 0.2
Black value is 0


Description

  • ? ImagickPixel::getColorValue
  • ImagickPixel::getHSL ?
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::getColorValueQuantum

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickPixel::getColorValueQuantum — Description

说明

public ImagickPixel::getColorValueQuantum ( int $color ) : int|float

Gets the quantum value of a color in the ImagickPixel. Return value is a float if ImageMagick was compiled with HDRI, otherwise an integer.

参数

此函数没有参数。

返回值

The quantum value of the color element. Float if ImageMagick was compiled with HDRI, otherwise an int.

范例

Example #1 ImagickPixel::getColorValueQuantum()

<?php
        $color = new \ImagickPixel('rgb(128, 5, 255)');
        $colorRed = $color->getColorValueQuantum(\Imagick::COLOR_RED);
        $colorGreen = $color->getColorValueQuantum(\Imagick::COLOR_GREEN);
        $colorBlue = $color->getColorValueQuantum(\Imagick::COLOR_BLUE);
        $colorAlpha = $color->getColorValueQuantum(\Imagick::COLOR_ALPHA);

        printf(
            "Red: %s Green: %s  Blue %s Alpha: %s",
            $colorRed,
            $colorGreen,
            $colorBlue,
            $colorAlpha
        );

?>


Returns the normalized HSL color of the ImagickPixel object

  • ? ImagickPixel::getColorValueQuantum
  • ImagickPixel::getIndex ?
  • PHP Manual
  • ImagickPixel
  • Returns the normalized HSL color of the ImagickPixel object

ImagickPixel::getHSL

(PECL imagick 2, PECL imagick 3)

ImagickPixel::getHSL — Returns the normalized HSL color of the ImagickPixel object

说明

public ImagickPixel::getHSL ( ) : array

Returns the normalized HSL color described by the ImagickPixel object, with each of the three values as floating point numbers between 0.0 and 1.0.

返回值

Returns the HSL value in an array with the keys "hue", "saturation", and "luminosity". Throws ImagickPixelException on failure.

范例

Example #1 Basic Imagick::getHSL() example

<?php

$color = new ImagickPixel('rgb(90%, 10%, 10%)');

$colorInfo = $color->getHSL();

print_r($colorInfo);

?>

以上例程会输出：

Array
(
    [hue] => 0
    [saturation] => 0.80001220740379
    [luminosity] => 0.50000762951095
)

注释

Note:

Available with ImageMagick library version 6.2.9 and higher.


Description

  • ? ImagickPixel::getHSL
  • ImagickPixel::isPixelSimilar ?
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::getIndex

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickPixel::getIndex — Description

说明

public ImagickPixel::getIndex ( ) : int

Gets the colormap index of the pixel wand.

参数

此函数没有参数。

返回值


Check the distance between this color and another

  • ? ImagickPixel::getIndex
  • ImagickPixel::isPixelSimilarQuantum ?
  • PHP Manual
  • ImagickPixel
  • Check the distance between this color and another

ImagickPixel::isPixelSimilar

(PECL imagick 3 >= 3.3.0)

ImagickPixel::isPixelSimilar — Check the distance between this color and another

说明

public ImagickPixel::isPixelSimilar ( ImagickPixel $color , float $fuzz ) : bool

Checks the distance between the color described by this ImagickPixel object and that of the provided object, by plotting their RGB values on the color cube. If the distance between the two points is less than the fuzz value given, the colors are similar. This method replaces ImagickPixel::isSimilar() and correctly normalises the fuzz value to ImageMagick QuantumRange.

参数

color

The ImagickPixel object to compare this object against.

fuzz

The maximum distance within which to consider these colors as similar. The theoretical maximum for this value is the square root of three (1.732).

返回值

成功时返回 true。


Description

  • ? ImagickPixel::isPixelSimilar
  • ImagickPixel::isSimilar ?
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::isPixelSimilarQuantum

(PECL imagick 3 >= 3.3.0)

ImagickPixel::isPixelSimilarQuantum — Description

说明

public ImagickPixel::isPixelSimilarQuantum ( string $color , string $fuzz = ? ) : bool

Returns true if the distance between two colors is less than the specified distance. The fuzz value should be in the range 0-QuantumRange. The maximum value represents the longest possible distance in the colorspace. e.g. from RGB(0, 0, 0) to RGB(255, 255, 255) for the RGB colorspace

参数

color

fuzz

返回值


Check the distance between this color and another

  • ? ImagickPixel::isPixelSimilarQuantum
  • ImagickPixel::setColor ?
  • PHP Manual
  • ImagickPixel
  • Check the distance between this color and another

ImagickPixel::isSimilar

(PECL imagick 2, PECL imagick 3)

ImagickPixel::isSimilar — Check the distance between this color and another

说明

public ImagickPixel::isSimilar ( ImagickPixel $color , float $fuzz ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Checks the distance between the color described by this ImagickPixel object and that of the provided object, by plotting their RGB values on the color cube. If the distance between the two points is less than the fuzz value given, the colors are similar. Deprecated in favour of ImagickPixel::isPixelSimilar().

参数

color

The ImagickPixel object to compare this object against.

fuzz

The maximum distance within which to consider these colors as similar. The theoretical maximum for this value is the square root of three (1.732).

返回值

成功时返回 true。

范例

Example #1 ImagickPixel::isSimilar()

<?php
        // The tests below are written with the maximum distance expressed as 255
        // so we need to scale them by the square root of 3 - the diagonal length
        // of a unit cube.
        $root3 = 1.732050807568877;

        $tests = array(
            ['rgb(245, 0, 0)',      'rgb(255, 0, 0)',   9 / $root3,         false,],
            ['rgb(245, 0, 0)',      'rgb(255, 0, 0)',  10 / $root3,         true,],
            ['rgb(0, 0, 0)',        'rgb(7, 7, 0)',     9 / $root3,         false,],
            ['rgb(0, 0, 0)',        'rgb(7, 7, 0)',    10 / $root3,         true,],
            ['rgba(0, 0, 0, 1)',    'rgba(7, 7, 0, 1)', 9 / $root3,         false,],
            ['rgba(0, 0, 0, 1)',    'rgba(7, 7, 0, 1)',    10 / $root3,     true,],
            ['rgb(128, 128, 128)',  'rgb(128, 128, 120)',   7 / $root3,     false,],
            ['rgb(128, 128, 128)',  'rgb(128, 128, 120)',   8 / $root3,     true,],
            ['rgb(0, 0, 0)',        'rgb(255, 255, 255)',   254.9,          false,],
            ['rgb(0, 0, 0)',        'rgb(255, 255, 255)',   255,            true,],
            ['rgb(255, 0, 0)',      'rgb(0, 255, 255)',     254.9,          false,],
            ['rgb(255, 0, 0)',      'rgb(0, 255, 255)',     255,            true,],
            ['black',               'rgba(0, 0, 0)',        0.0,            true],
            ['black',               'rgba(10, 0, 0, 1.0)',  10.0 / $root3,  true],);

        $output = "<table width='100%' class='infoTable'><thead>
                <tr>
                <th>
                Color 1
                </th>
                <th>
                Color 2
                </th>
                <th>
                    Test distance * 255
                </th>
                <th>
                    Is within distance
                </th>
                </tr>
        </thead>";

        $output .= "<tbody>";

        foreach ($tests as $testInfo) {
            $color1 = $testInfo[0];
            $color2 = $testInfo[1];
            $distance = $testInfo[2];
            $expectation = $testInfo[3];
            $testDistance = ($distance / 255.0);

            $color1Pixel = new \ImagickPixel($color1);
            $color2Pixel = new \ImagickPixel($color2);

            $isSimilar = $color1Pixel->isPixelSimilar($color2Pixel, $testDistance);

            if ($isSimilar !== $expectation) {
                echo "Test distance failed. Color [$color1] compared to color [$color2] is not within distance $testDistance FAILED.".NL;
            }

            $layout = "<tr>
                <td>%s</td>
                <td>%s</td>
                <td>%s</td>
                <td style='text-align: center;'>%s</td>
            </tr>";

            $output .= sprintf(
                $layout,
                $color1,
                $color2,
                $distance,
                $isSimilar ? 'yes' : 'no'
            );
        }

        $output .= "</tbody></table>";

        return $output;

?>


Sets the color

  • ? ImagickPixel::isSimilar
  • ImagickPixel::setColorCount ?
  • PHP Manual
  • ImagickPixel
  • Sets the color

ImagickPixel::setColor

(PECL imagick 2, PECL imagick 3)

ImagickPixel::setColor — Sets the color

说明

public ImagickPixel::setColor ( string $color ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the color described by the ImagickPixel object, with a string (e.g. "blue", "#0000ff", "rgb(0,0,255)", "cmyk(100,100,100,10)", etc.).

参数

color

The color definition to use in order to initialise the ImagickPixel object.

返回值

Returns true if the specified color was set, false otherwise.

范例

Example #1 ImagickPixel::setColor()

<?php
function setColor() {
    $draw = new \ImagickDraw();

    $strokeColor = new \ImagickPixel('green');
    $fillColor = new \ImagickPixel();
    $fillColor->setColor('rgba(100%, 75%, 0%, 1.0)');

    $draw->setstrokewidth(3.0);
    $draw->setStrokeColor($strokeColor);
    $draw->setFillColor($fillColor);
    $draw->rectangle(200, 200, 300, 300);

    $image = new \Imagick();
    $image->newImage(500, 500, "SteelBlue2");
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Description

  • ? ImagickPixel::setColor
  • ImagickPixel::setColorValue ?
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::setColorCount

(PECL imagick 2, PECL imagick 3)

ImagickPixel::setColorCount — Description

说明

public ImagickPixel::setcolorcount ( int $colorCount ) : bool

Sets the color count associated with this color.

参数

colorCount

返回值

成功时返回 true。


Sets the normalized value of one of the channels

  • ? ImagickPixel::setColorCount
  • ImagickPixel::setColorValueQuantum ?
  • PHP Manual
  • ImagickPixel
  • Sets the normalized value of one of the channels

ImagickPixel::setColorValue

(PECL imagick 2, PECL imagick 3)

ImagickPixel::setColorValue — Sets the normalized value of one of the channels

说明

public ImagickPixel::setColorValue ( int $color , float $value ) : bool

Sets the value of the specified channel of this object to the provided value, which should be between 0 and 1. This function can be used to provide an opacity channel to an ImagickPixel object.

参数

color

One of the Imagick color constants e.g. \Imagick::COLOR_GREEN or \Imagick::COLOR_ALPHA.

value

The value to set this channel to, ranging from 0 to 1.

返回值

成功时返回 true。

范例

Example #1 Basic Imagick::setColorValue() usage

<?php

$color  = new \ImagickPixel('firebrick');

$color->setColorValue(Imagick::COLOR_ALPHA, 0.5);

print_r($color->getcolor(true));
?>

以上例程会输出：

Array
(
    [r] => 0.69803921568627
    [g] => 0.13333333333333
    [b] => 0.13333333333333
    [a] => 0.50000762951095
)


Description

  • ? ImagickPixel::setColorValue
  • ImagickPixel::setHSL ?
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::setColorValueQuantum

(PECL imagick 2 >=2.3.0, PECL imagick 3)

ImagickPixel::setColorValueQuantum — Description

说明

public ImagickPixel::setColorValueQuantum ( int $color , int|float $value ) : bool

Sets the quantum value of a color element of the ImagickPixel.

Warning

本函数还未编写文档，仅有参数列表。

参数

color

Which color element to set e.g. \Imagick::COLOR_GREEN.

value

The quantum value to set the color element to. This should be a float if ImageMagick was compiled with HDRI otherwise an int in the range 0 to Imagick::getQuantum().

返回值

成功时返回 true。

范例

Example #1 ImagickPixel::setColorValueQuantum()

<?php
function setColorValueQuantum() {
    $image = new \Imagick();

    $quantumRange = $image->getQuantumRange();

    $draw = new \ImagickDraw();
    $color = new \ImagickPixel('blue');
    $color->setcolorValueQuantum(\Imagick::COLOR_RED, 128 * $quantumRange['quantumRangeLong'] / 256);

    $draw->setstrokewidth(1.0);
    $draw->setStrokeColor($color);
    $draw->setFillColor($color);
    $draw->rectangle(200, 200, 300, 300);

    $image->newImage(500, 500, "SteelBlue2");
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>


Sets the normalized HSL color

  • ? ImagickPixel::setColorValueQuantum
  • ImagickPixel::setIndex ?
  • PHP Manual
  • ImagickPixel
  • Sets the normalized HSL color

ImagickPixel::setHSL

(PECL imagick 2, PECL imagick 3)

ImagickPixel::setHSL — Sets the normalized HSL color

说明

public ImagickPixel::setHSL ( float $hue , float $saturation , float $luminosity ) : bool

Sets the color described by the ImagickPixel object using normalized values for hue, saturation and luminosity.

参数

hue

The normalized value for hue, described as a fractional arc (between 0 and 1) of the hue circle, where the zero value is red.

saturation

The normalized value for saturation, with 1 as full saturation.

luminosity

The normalized value for luminosity, on a scale from black at 0 to white at 1, with the full HS value at 0.5 luminosity.

返回值

成功时返回 true。

范例

Example #1 Use ImagickPixel::setHSL() to modify a color

<?php

//Create an almost pure red color
$color = new ImagickPixel('rgb(90%, 10%, 10%)');

//Get it's HSL values
$colorInfo = $color->getHSL();

//Rotate the hue by 180 degrees
$newHue = $colorInfo['hue'] + 0.5;
if ($newHue > 1) {
    $newHue = $newHue - 1;
}

//Set the ImagickPixel to the new color
$colorInfo = $color->setHSL($newHue, $colorInfo['saturation'], $colorInfo['luminosity']);

//Check that the new color is blue/green
$colorInfo = $color->getcolor();
print_r($colorInfo);

?>

以上例程会输出：

Array
(
    [r] => 26
    [g] => 230
    [b] => 230
    [a] => 255
)

注释

Note:

Available with ImageMagick library version 6.2.9 and higher.


Description

  • ? ImagickPixel::setHSL
  • ImagickPixelIterator ?
  • PHP Manual
  • ImagickPixel
  • Description

ImagickPixel::setIndex

(PECL imagick 2 >= 2.3.0, PECL imagick 3)

ImagickPixel::setIndex — Description

说明

public ImagickPixel::setIndex ( int $index ) : bool

Sets the colormap index of the pixel wand.

参数

index

返回值

成功时返回 true。


The ImagickPixelIterator class

(PECL imagick 2, PECL imagick 3)

类摘要

ImagickPixelIterator {
public clear ( ) : bool
public __construct ( Imagick $wand )
public destroy ( ) : bool
public getCurrentIteratorRow ( ) : array
public getIteratorRow ( ) : int
public getNextIteratorRow ( ) : array
public getPreviousIteratorRow ( ) : array
public newPixelIterator ( Imagick $wand ) : bool
public newPixelRegionIterator ( Imagick $wand , int $x , int $y , int $columns , int $rows ) : bool
public resetIterator ( ) : bool
public setIteratorFirstRow ( ) : bool
public setIteratorLastRow ( ) : bool
public setIteratorRow ( int $row ) : bool
public syncIterator ( ) : bool
}

Table of Contents

  • ImagickPixelIterator::clear — Clear resources associated with a PixelIterator
  • ImagickPixelIterator::__construct — The ImagickPixelIterator constructor
  • ImagickPixelIterator::destroy — Deallocates resources associated with a PixelIterator
  • ImagickPixelIterator::getCurrentIteratorRow — Returns the current row of ImagickPixel objects
  • ImagickPixelIterator::getIteratorRow — Returns the current pixel iterator row
  • ImagickPixelIterator::getNextIteratorRow — Returns the next row of the pixel iterator
  • ImagickPixelIterator::getPreviousIteratorRow — Returns the previous row
  • ImagickPixelIterator::newPixelIterator — Returns a new pixel iterator
  • ImagickPixelIterator::newPixelRegionIterator — Returns a new pixel iterator
  • ImagickPixelIterator::resetIterator — Resets the pixel iterator
  • ImagickPixelIterator::setIteratorFirstRow — Sets the pixel iterator to the first pixel row
  • ImagickPixelIterator::setIteratorLastRow — Sets the pixel iterator to the last pixel row
  • ImagickPixelIterator::setIteratorRow — Set the pixel iterator row
  • ImagickPixelIterator::syncIterator — Syncs the pixel iterator


Clear resources associated with a PixelIterator

  • ? ImagickPixelIterator
  • ImagickPixelIterator::__construct ?
  • PHP Manual
  • ImagickPixelIterator
  • Clear resources associated with a PixelIterator

ImagickPixelIterator::clear

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::clear — Clear resources associated with a PixelIterator

说明

public ImagickPixelIterator::clear ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Clear resources associated with a PixelIterator.

返回值

成功时返回 true。

范例

Example #1 ImagickPixelIterator::clear()

<?php
function clear($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));

    $imageIterator = $imagick->getPixelRegionIterator(100, 100, 250, 200);

    /* Loop through pixel rows */
    foreach ($imageIterator as $pixels) {
        /** @var $pixel \ImagickPixel */
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $column => $pixel) {
            if ($column % 2) {
                /* Paint every second pixel black*/
                $pixel->setColor("rgba(0, 0, 0, 0)");
            }
        }
        /* Sync the iterator, this is important to do on each iteration */
        $imageIterator->syncIterator();
    }

    $imageIterator->clear();

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


The ImagickPixelIterator constructor

  • ? ImagickPixelIterator::clear
  • ImagickPixelIterator::destroy ?
  • PHP Manual
  • ImagickPixelIterator
  • The ImagickPixelIterator constructor

ImagickPixelIterator::__construct

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::__construct — The ImagickPixelIterator constructor

说明

public ImagickPixelIterator::__construct ( Imagick $wand )
Warning

本函数还未编写文档，仅有参数列表。

The ImagickPixelIterator constructor

返回值

成功时返回 true。

范例

Example #1 ImagickPixelIterator::construct()

<?php
function construct($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imageIterator = new \ImagickPixelIterator($imagick);

    /* Loop through pixel rows */
    foreach ($imageIterator as $pixels) {
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $column => $pixel) {
            /** @var $pixel \ImagickPixel */
            if ($column % 2) {
                /* Paint every second pixel black*/
                $pixel->setColor("rgba(0, 0, 0, 0)");
            }
        }
        /* Sync the iterator, this is important to do on each iteration */
        $imageIterator->syncIterator();
    }

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Deallocates resources associated with a PixelIterator

  • ? ImagickPixelIterator::__construct
  • ImagickPixelIterator::getCurrentIteratorRow ?
  • PHP Manual
  • ImagickPixelIterator
  • Deallocates resources associated with a PixelIterator

ImagickPixelIterator::destroy

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::destroy — Deallocates resources associated with a PixelIterator

说明

public ImagickPixelIterator::destroy ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Deallocates resources associated with a PixelIterator.

返回值

成功时返回 true。


Returns the current row of ImagickPixel objects

  • ? ImagickPixelIterator::destroy
  • ImagickPixelIterator::getIteratorRow ?
  • PHP Manual
  • ImagickPixelIterator
  • Returns the current row of ImagickPixel objects

ImagickPixelIterator::getCurrentIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::getCurrentIteratorRow — Returns the current row of ImagickPixel objects

说明

public ImagickPixelIterator::getCurrentIteratorRow ( ) : array
Warning

本函数还未编写文档，仅有参数列表。

Returns the current row as an array of ImagickPixel objects from the pixel iterator.

返回值

Returns a row as an array of ImagickPixel objects that can themselves be iterated.


Returns the current pixel iterator row

  • ? ImagickPixelIterator::getCurrentIteratorRow
  • ImagickPixelIterator::getNextIteratorRow ?
  • PHP Manual
  • ImagickPixelIterator
  • Returns the current pixel iterator row

ImagickPixelIterator::getIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::getIteratorRow — Returns the current pixel iterator row

说明

public ImagickPixelIterator::getIteratorRow ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the current pixel iterator row.

返回值

Returns the integer offset of the row, throwing ImagickPixelIteratorException on error.


Returns the next row of the pixel iterator

  • ? ImagickPixelIterator::getIteratorRow
  • ImagickPixelIterator::getPreviousIteratorRow ?
  • PHP Manual
  • ImagickPixelIterator
  • Returns the next row of the pixel iterator

ImagickPixelIterator::getNextIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::getNextIteratorRow — Returns the next row of the pixel iterator

说明

public ImagickPixelIterator::getNextIteratorRow ( ) : array
Warning

本函数还未编写文档，仅有参数列表。

Returns the next row as an array of pixel wands from the pixel iterator.

返回值

Returns the next row as an array of ImagickPixel objects, throwing ImagickPixelIteratorException on error.

范例

Example #1 ImagickPixelIterator::getNextIteratorRow()

<?php
function getNextIteratorRow($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imageIterator = $imagick->getPixelIterator();

    $count = 0;
    while ($pixels = $imageIterator->getNextIteratorRow()) {
        if (($count % 3) == 0) {
            /* Loop through the pixels in the row (columns) */
            foreach ($pixels as $column => $pixel) {
                /** @var $pixel \ImagickPixel */
                if ($column % 2) {
                    /* Paint every second pixel black*/
                    $pixel->setColor("rgba(0, 0, 0, 0)");
                }
            }
            /* Sync the iterator, this is important to do on each iteration */
            $imageIterator->syncIterator();
        }

        $count += 1;
    }

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Returns the previous row

  • ? ImagickPixelIterator::getNextIteratorRow
  • ImagickPixelIterator::newPixelIterator ?
  • PHP Manual
  • ImagickPixelIterator
  • Returns the previous row

ImagickPixelIterator::getPreviousIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::getPreviousIteratorRow — Returns the previous row

说明

public ImagickPixelIterator::getPreviousIteratorRow ( ) : array
Warning

本函数还未编写文档，仅有参数列表。

Returns the previous row as an array of pixel wands from the pixel iterator.

返回值

Returns the previous row as an array of ImagickPixelWand objects from the ImagickPixelIterator, throwing ImagickPixelIteratorException on error.


Returns a new pixel iterator

  • ? ImagickPixelIterator::getPreviousIteratorRow
  • ImagickPixelIterator::newPixelRegionIterator ?
  • PHP Manual
  • ImagickPixelIterator
  • Returns a new pixel iterator

ImagickPixelIterator::newPixelIterator

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::newPixelIterator — Returns a new pixel iterator

说明

public ImagickPixelIterator::newPixelIterator ( Imagick $wand ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Returns a new pixel iterator.

返回值

成功时返回 true。 Throwing ImagickPixelIteratorException.


Returns a new pixel iterator

  • ? ImagickPixelIterator::newPixelIterator
  • ImagickPixelIterator::resetIterator ?
  • PHP Manual
  • ImagickPixelIterator
  • Returns a new pixel iterator

ImagickPixelIterator::newPixelRegionIterator

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::newPixelRegionIterator — Returns a new pixel iterator

说明

public ImagickPixelIterator::newPixelRegionIterator ( Imagick $wand , int $x , int $y , int $columns , int $rows ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Returns a new pixel iterator.

参数

wand

x

y

columns

rows

返回值

Returns a new ImagickPixelIterator on success; on failure, throws ImagickPixelIteratorException.


Resets the pixel iterator

  • ? ImagickPixelIterator::newPixelRegionIterator
  • ImagickPixelIterator::setIteratorFirstRow ?
  • PHP Manual
  • ImagickPixelIterator
  • Resets the pixel iterator

ImagickPixelIterator::resetIterator

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::resetIterator — Resets the pixel iterator

说明

public ImagickPixelIterator::resetIterator ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Resets the pixel iterator. Use it in conjunction with ImagickPixelIterator::getNextIteratorRow() to iterate over all the pixels in a pixel container.

返回值

成功时返回 true。

范例

Example #1 ImagickPixelIterator::resetIterator()

<?php
function resetIterator($imagePath) {

    $imagick = new \Imagick(realpath($imagePath));

    $imageIterator = $imagick->getPixelIterator();

    /* Loop trough pixel rows */
    foreach ($imageIterator as $pixels) {
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $column => $pixel) {
            /** @var $pixel \ImagickPixel */
            if ($column % 2) {

                /* Make every second pixel 25% red*/
                $pixel->setColorValue(\Imagick::COLOR_RED, 64);
            }
        }
        /* Sync the iterator, this is important to do on each iteration */
        $imageIterator->syncIterator();
    }

    $imageIterator->resetiterator();

    /* Loop trough pixel rows */
    foreach ($imageIterator as $pixels) {
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $column => $pixel) {
            /** @var $pixel \ImagickPixel */
            if ($column % 3) {
                $pixel->setColorValue(\Imagick::COLOR_BLUE, 64); /* Make every second pixel a little blue*/
                //$pixel->setColor("rgba(0, 0, 128, 0)"); /* Paint every second pixel black*/
            }
        }
        $imageIterator->syncIterator(); /* Sync the iterator, this is important to do on each iteration */
    }

    $imageIterator->clear();

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Sets the pixel iterator to the first pixel row

  • ? ImagickPixelIterator::resetIterator
  • ImagickPixelIterator::setIteratorLastRow ?
  • PHP Manual
  • ImagickPixelIterator
  • Sets the pixel iterator to the first pixel row

ImagickPixelIterator::setIteratorFirstRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::setIteratorFirstRow — Sets the pixel iterator to the first pixel row

说明

public ImagickPixelIterator::setIteratorFirstRow ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the pixel iterator to the first pixel row.

返回值

成功时返回 true。


Sets the pixel iterator to the last pixel row

  • ? ImagickPixelIterator::setIteratorFirstRow
  • ImagickPixelIterator::setIteratorRow ?
  • PHP Manual
  • ImagickPixelIterator
  • Sets the pixel iterator to the last pixel row

ImagickPixelIterator::setIteratorLastRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::setIteratorLastRow — Sets the pixel iterator to the last pixel row

说明

public ImagickPixelIterator::setIteratorLastRow ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Sets the pixel iterator to the last pixel row.

返回值

成功时返回 true。


Set the pixel iterator row

  • ? ImagickPixelIterator::setIteratorLastRow
  • ImagickPixelIterator::syncIterator ?
  • PHP Manual
  • ImagickPixelIterator
  • Set the pixel iterator row

ImagickPixelIterator::setIteratorRow

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::setIteratorRow — Set the pixel iterator row

说明

public ImagickPixelIterator::setIteratorRow ( int $row ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Set the pixel iterator row.

参数

row

返回值

成功时返回 true。

范例

Example #1 ImagickPixelIterator::setIteratorRow()

<?php
function setIteratorRow($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imageIterator = $imagick->getPixelRegionIterator(200, 100, 200, 200);

    for ($x = 0; $x < 20; $x++) {
        $imageIterator->setIteratorRow($x * 5);
        $pixels = $imageIterator->getCurrentIteratorRow();
        /* Loop through the pixels in the row (columns) */
        foreach ($pixels as $pixel) {
            /** @var $pixel \ImagickPixel */
            /* Paint every second pixel black*/
            $pixel->setColor("rgba(0, 0, 0, 0)");
        }

        /* Sync the iterator, this is important to do on each iteration */
        $imageIterator->syncIterator();
    }

    header("Content-Type: image/jpg");
    echo $imagick;
}

?>


Syncs the pixel iterator

  • ? ImagickPixelIterator::setIteratorRow
  • 邮件相关扩展 ?
  • PHP Manual
  • ImagickPixelIterator
  • Syncs the pixel iterator

ImagickPixelIterator::syncIterator

(PECL imagick 2, PECL imagick 3)

ImagickPixelIterator::syncIterator — Syncs the pixel iterator

说明

public ImagickPixelIterator::syncIterator ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Syncs the pixel iterator.

返回值

成功时返回 true。


邮件相关扩展

  • IMAP — IMAP, POP3 和 NNTP
    • 简介
    • 安装／配置
    • 预定义常量
    • IMAP 函数
  • Mail
    • 简介
    • 安装／配置
    • 预定义常量
    • Mail 函数
  • Mailparse
    • 简介
    • 安装／配置
    • 预定义常量
    • Mailparse 函数


IMAP, POP3 和 NNTP

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • IMAP 函数
    • imap_8bit — Convert an 8bit string to a quoted-printable string
    • imap_alerts — Returns all IMAP alert messages that have occurred
    • imap_append — Append a string message to a specified mailbox
    • imap_base64 — Decode BASE64 encoded text
    • imap_binary — Convert an 8bit string to a base64 string
    • imap_body — Read the message body
    • imap_bodystruct — Read the structure of a specified body section of a specific message
    • imap_check — Check current mailbox
    • imap_clearflag_full — Clears flags on messages
    • imap_close — Close an IMAP stream
    • imap_create — 别名 imap_createmailbox
    • imap_createmailbox — Create a new mailbox
    • imap_delete — Mark a message for deletion from current mailbox
    • imap_deletemailbox — Delete a mailbox
    • imap_errors — Returns all of the IMAP errors that have occurred
    • imap_expunge — Delete all messages marked for deletion
    • imap_fetch_overview — Read an overview of the information in the headers of the given message
    • imap_fetchbody — Fetch a particular section of the body of the message
    • imap_fetchheader — Returns header for a message
    • imap_fetchmime — Fetch MIME headers for a particular section of the message
    • imap_fetchstructure — Read the structure of a particular message
    • imap_fetchtext — 别名 imap_body
    • imap_gc — Clears IMAP cache
    • imap_get_quota — Retrieve the quota level settings, and usage statics per mailbox
    • imap_get_quotaroot — Retrieve the quota settings per user
    • imap_getacl — Gets the ACL for a given mailbox
    • imap_getmailboxes — Read the list of mailboxes, returning detailed information on each one
    • imap_getsubscribed — List all the subscribed mailboxes
    • imap_header — 别名 imap_headerinfo
    • imap_headerinfo — Read the header of the message
    • imap_headers — Returns headers for all messages in a mailbox
    • imap_last_error — Gets the last IMAP error that occurred during this page request
    • imap_list — Read the list of mailboxes
    • imap_listmailbox — 别名 imap_list
    • imap_listscan — Returns the list of mailboxes that matches the given text
    • imap_listsubscribed — 别名 imap_lsub
    • imap_lsub — List all the subscribed mailboxes
    • imap_mail_compose — Create a MIME message based on given envelope and body sections
    • imap_mail_copy — Copy specified messages to a mailbox
    • imap_mail_move — Move specified messages to a mailbox
    • imap_mail — Send an email message
    • imap_mailboxmsginfo — Get information about the current mailbox
    • imap_mime_header_decode — Decode MIME header elements
    • imap_msgno — Gets the message sequence number for the given UID
    • imap_mutf7_to_utf8 — Decode a modified UTF-7 string to UTF-8
    • imap_num_msg — Gets the number of messages in the current mailbox
    • imap_num_recent — Gets the number of recent messages in current mailbox
    • imap_open — Open an IMAP stream to a mailbox
    • imap_ping — Check if the IMAP stream is still active
    • imap_qprint — Convert a quoted-printable string to an 8 bit string
    • imap_rename — 别名 imap_renamemailbox
    • imap_renamemailbox — Rename an old mailbox to new mailbox
    • imap_reopen — Reopen IMAP stream to new mailbox
    • imap_rfc822_parse_adrlist — Parses an address string
    • imap_rfc822_parse_headers — Parse mail headers from a string
    • imap_rfc822_write_address — Returns a properly formatted email address given the mailbox, host, and personal info
    • imap_savebody — Save a specific body section to a file
    • imap_scan — 别名 imap_listscan
    • imap_scanmailbox — 别名 imap_listscan
    • imap_search — This function returns an array of messages matching the given search criteria
    • imap_set_quota — Sets a quota for a given mailbox
    • imap_setacl — Sets the ACL for a given mailbox
    • imap_setflag_full — Sets flags on messages
    • imap_sort — Gets and sort messages
    • imap_status — Returns status information on a mailbox
    • imap_subscribe — Subscribe to a mailbox
    • imap_thread — Returns a tree of threaded message
    • imap_timeout — Set or fetch imap timeout
    • imap_uid — This function returns the UID for the given message sequence number
    • imap_undelete — Unmark the message which is marked deleted
    • imap_unsubscribe — Unsubscribe from a mailbox
    • imap_utf7_decode — Decodes a modified UTF-7 encoded string
    • imap_utf7_encode — Converts ISO-8859-1 string to modified UTF-7 text
    • imap_utf8_to_mutf7 — Encode a UTF-8 string to modified UTF-7
    • imap_utf8 — Converts MIME-encoded text to UTF-8


简介

这些函数提供了可以操作 IMAP 以及 NNTP，POP3 和本地邮箱的方法。

注意，有些 IMAP 函数在 POP3 协议下将不能正常的工作。


需求

This extension requires the c-client library to be installed. Grab the latest version from » https://github.com/uw-imap/imap and compile it.

It's important that you do not copy the IMAP source files directly into the system include directory as there may be conflicts. Instead, create a new directory inside the system include directory, such as /usr/local/imap-2000b/ (location and name depend on your setup and IMAP version), and inside this new directory create additional directories named lib/ and include/. From the c-client directory from your IMAP source tree, copy all the *.h files into include/ and all the *.c files into lib/. Additionally when you compiled IMAP, a file named c-client.a was created. Also put this in the lib/ directory but rename it as libc-client.a.

Note:

To build the c-client library with SSL or/and Kerberos support read the docs supplied with the package.

Note: In Mandrake Linux, the IMAP library (libc-client.a) is compiled without Kerberos support. A separate version with SSL (client-PHP4.a) is installed. The library must be recompiled in order to add Kerberos support.


安装

要使这些函数生效，你必须在编译 PHP 的时候添加 --with-imap[=DIR] 选项, DIR 表示c-client安装前缀。比如上面提到的例子中，你可以使用 --with-imap=/usr/local/imap-2000b. 根据以上描述，这个路径是指向你先前创建的文件夹。对于 Windows 用户，应该在 php.ini 文件中引入php_imap.dll.

Windows 2000之前的系统是不支持的 IMAP 的。这是因为通过SSL连接邮件服务器时使用了加密功能。

Note: 因为取决于 c-client 是如何配置的，所以你应该向 PHP 配置行添加--with-imap-ssl=/path/to/openssl/ 或者 --with-kerberos=/path/to/kerberos 配置信息。

Warning

IMAP，recode，和 YAZ 扩展不能同时使用，因为它们共享了相同 的内部符号。注意：Yaz 2.0 及以上版本不存在此问题。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

IMAP 配置选项
名字 | 默认 | 可修改范围 | 更新日志
imap.enable_insecure_rsh | "0" | PHP_INI_SYSTEM | Available as of PHP 7.1.25, 7.2.13 and 7.3.0. Formerly, it was implicitly enabled.
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

imap.enable_insecure_rsh bool

Establishing a connection to a server may invoke rsh or ssh commands, unless this php.ini option is disabled.

Warning

Neither PHP nor the IMAP library filter mailbox names before passing them to rsh or ssh commands, thus passing untrusted data to this function without disabling this php.ini option is insecure.


资源类型

The imap resource as returned by imap_open() references an opened IMAP stream.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

NIL (int)
OP_DEBUG (int)
OP_READONLY (int)
Open mailbox read-only
OP_ANONYMOUS (int)
Don't use or update a .newsrc for news (NNTP only)
OP_SHORTCACHE (int)
OP_SILENT (int)
OP_PROTOTYPE (int)
OP_HALFOPEN (int)
For IMAP and NNTP names, open a connection but don't open a mailbox.
OP_EXPUNGE (int)
OP_SECURE (int)
CL_EXPUNGE (int)
silently expunge the mailbox before closing when calling imap_close()
FT_UID (int)
The parameter is a UID
FT_PEEK (int)
Do not set the \Seen flag if not already set
FT_NOT (int)
FT_INTERNAL (int)
The return string is in internal format, will not canonicalize to CRLF.
FT_PREFETCHTEXT (int)
ST_UID (int)
The sequence argument contains UIDs instead of sequence numbers
ST_SILENT (int)
ST_SET (int)
CP_UID (int)
the sequence numbers contain UIDS
CP_MOVE (int)
Delete the messages from the current mailbox after copying with imap_mail_copy()
SE_UID (int)
Return UIDs instead of sequence numbers
SE_FREE (int)
SE_NOPREFETCH (int)
Don't prefetch searched messages
SO_FREE (int)
SO_NOSERVER (int)
SA_MESSAGES (int)
SA_RECENT (int)
SA_UNSEEN (int)
SA_UIDNEXT (int)
SA_UIDVALIDITY (int)
SA_ALL (int)
LATT_NOINFERIORS (int)
This mailbox has no "children" (there are no mailboxes below this one).
LATT_NOSELECT (int)
This is only a container, not a mailbox - you cannot open it.
LATT_MARKED (int)
This mailbox is marked. Only used by UW-IMAPD.
LATT_UNMARKED (int)
This mailbox is not marked. Only used by UW-IMAPD.
LATT_REFERRAL (int)
This container has a referral to a remote mailbox.
LATT_HASCHILDREN (int)
This mailbox has selectable inferiors.
LATT_HASNOCHILDREN (int)
This mailbox has no selectable inferiors.
SORTDATE (int)
Sort criteria for imap_sort(): message Date
SORTARRIVAL (int)
Sort criteria for imap_sort(): arrival date
SORTFROM (int)
Sort criteria for imap_sort(): mailbox in first From address
SORTSUBJECT (int)
Sort criteria for imap_sort(): message subject
SORTTO (int)
Sort criteria for imap_sort(): mailbox in first To address
SORTCC (int)
Sort criteria for imap_sort(): mailbox in first cc address
SORTSIZE (int)
Sort criteria for imap_sort(): size of message in octets
TYPETEXT (int)
Primary body type: unformatted text
TYPEMULTIPART (int)
Primary body type: multiple part
TYPEMESSAGE (int)
Primary body type: encapsulated message
TYPEAPPLICATION (int)
Primary body type: application data
TYPEAUDIO (int)
Primary body type: audio
TYPEIMAGE (int)
Primary body type: static image
TYPEVIDEO (int)
Primary body type: video
TYPEMODEL (int)
Primary body type: model
TYPEOTHER (int)
Primary body type: unknown
ENC7BIT (int)
Body encoding: 7 bit SMTP semantic data
ENC8BIT (int)
Body encoding: 8 bit SMTP semantic data
ENCBINARY (int)
Body encoding: 8 bit binary data
ENCBASE64 (int)
Body encoding: base-64 encoded data
ENCQUOTEDPRINTABLE (int)
Body encoding: human-readable 8-as-7 bit data
ENCOTHER (int)
Body encoding: unknown
IMAP_OPENTIMEOUT (int)
IMAP_READTIMEOUT (int)
IMAP_WRITETIMEOUT (int)
IMAP_CLOSETIMEOUT (int)
IMAP_GC_ELT (int)
Garbage collector, clear message cache elements.
IMAP_GC_ENV (int)
Garbage collector, clear envelopes and bodies.
IMAP_GC_TEXTS (int)
Garbage collector, clear texts.


IMAP 函数

参见

This document can't go into detail on all the topics touched by the provided functions. Further information is provided by the documentation of the c-client library source (docs/internal.txt). and the following RFC documents:

  • » RFC2821: Simple Mail Transfer Protocol (SMTP).
  • » RFC2822: Standard for ARPA internet text messages.
  • » RFC2060: Internet Message Access Protocol (IMAP) Version 4rev1.
  • » RFC1939: Post Office Protocol Version 3 (POP3).
  • » RFC977: Network News Transfer Protocol (NNTP).
  • » RFC2076: Common Internet Message Headers.
  • » RFC2045 , » RFC2046 , » RFC2047 , » RFC2048 & » RFC2049: Multipurpose Internet Mail Extensions (MIME).
A detailed overview is also available in the books » Programming Internet Email by David Wood and » Managing IMAP by Dianna Mullet & Kevin Mullet.

Table of Contents

  • imap_8bit — Convert an 8bit string to a quoted-printable string
  • imap_alerts — Returns all IMAP alert messages that have occurred
  • imap_append — Append a string message to a specified mailbox
  • imap_base64 — Decode BASE64 encoded text
  • imap_binary — Convert an 8bit string to a base64 string
  • imap_body — Read the message body
  • imap_bodystruct — Read the structure of a specified body section of a specific message
  • imap_check — Check current mailbox
  • imap_clearflag_full — Clears flags on messages
  • imap_close — Close an IMAP stream
  • imap_create — 别名 imap_createmailbox
  • imap_createmailbox — Create a new mailbox
  • imap_delete — Mark a message for deletion from current mailbox
  • imap_deletemailbox — Delete a mailbox
  • imap_errors — Returns all of the IMAP errors that have occurred
  • imap_expunge — Delete all messages marked for deletion
  • imap_fetch_overview — Read an overview of the information in the headers of the given message
  • imap_fetchbody — Fetch a particular section of the body of the message
  • imap_fetchheader — Returns header for a message
  • imap_fetchmime — Fetch MIME headers for a particular section of the message
  • imap_fetchstructure — Read the structure of a particular message
  • imap_fetchtext — 别名 imap_body
  • imap_gc — Clears IMAP cache
  • imap_get_quota — Retrieve the quota level settings, and usage statics per mailbox
  • imap_get_quotaroot — Retrieve the quota settings per user
  • imap_getacl — Gets the ACL for a given mailbox
  • imap_getmailboxes — Read the list of mailboxes, returning detailed information on each one
  • imap_getsubscribed — List all the subscribed mailboxes
  • imap_header — 别名 imap_headerinfo
  • imap_headerinfo — Read the header of the message
  • imap_headers — Returns headers for all messages in a mailbox
  • imap_last_error — Gets the last IMAP error that occurred during this page request
  • imap_list — Read the list of mailboxes
  • imap_listmailbox — 别名 imap_list
  • imap_listscan — Returns the list of mailboxes that matches the given text
  • imap_listsubscribed — 别名 imap_lsub
  • imap_lsub — List all the subscribed mailboxes
  • imap_mail_compose — Create a MIME message based on given envelope and body sections
  • imap_mail_copy — Copy specified messages to a mailbox
  • imap_mail_move — Move specified messages to a mailbox
  • imap_mail — Send an email message
  • imap_mailboxmsginfo — Get information about the current mailbox
  • imap_mime_header_decode — Decode MIME header elements
  • imap_msgno — Gets the message sequence number for the given UID
  • imap_mutf7_to_utf8 — Decode a modified UTF-7 string to UTF-8
  • imap_num_msg — Gets the number of messages in the current mailbox
  • imap_num_recent — Gets the number of recent messages in current mailbox
  • imap_open — Open an IMAP stream to a mailbox
  • imap_ping — Check if the IMAP stream is still active
  • imap_qprint — Convert a quoted-printable string to an 8 bit string
  • imap_rename — 别名 imap_renamemailbox
  • imap_renamemailbox — Rename an old mailbox to new mailbox
  • imap_reopen — Reopen IMAP stream to new mailbox
  • imap_rfc822_parse_adrlist — Parses an address string
  • imap_rfc822_parse_headers — Parse mail headers from a string
  • imap_rfc822_write_address — Returns a properly formatted email address given the mailbox, host, and personal info
  • imap_savebody — Save a specific body section to a file
  • imap_scan — 别名 imap_listscan
  • imap_scanmailbox — 别名 imap_listscan
  • imap_search — This function returns an array of messages matching the given search criteria
  • imap_set_quota — Sets a quota for a given mailbox
  • imap_setacl — Sets the ACL for a given mailbox
  • imap_setflag_full — Sets flags on messages
  • imap_sort — Gets and sort messages
  • imap_status — Returns status information on a mailbox
  • imap_subscribe — Subscribe to a mailbox
  • imap_thread — Returns a tree of threaded message
  • imap_timeout — Set or fetch imap timeout
  • imap_uid — This function returns the UID for the given message sequence number
  • imap_undelete — Unmark the message which is marked deleted
  • imap_unsubscribe — Unsubscribe from a mailbox
  • imap_utf7_decode — Decodes a modified UTF-7 encoded string
  • imap_utf7_encode — Converts ISO-8859-1 string to modified UTF-7 text
  • imap_utf8_to_mutf7 — Encode a UTF-8 string to modified UTF-7
  • imap_utf8 — Converts MIME-encoded text to UTF-8


Convert an 8bit string to a quoted-printable string

  • ? IMAP 函数
  • imap_alerts ?
  • PHP Manual
  • IMAP 函数
  • Convert an 8bit string to a quoted-printable string

imap_8bit

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_8bit — Convert an 8bit string to a quoted-printable string

说明

imap_8bit ( string $string ) : string|false

Convert an 8bit string to a quoted-printable string (according to » RFC2045, section 6.7).

参数

string

The 8bit string to convert

返回值

Returns a quoted-printable string, 或者在失败时返回 false.

参见

  • imap_qprint() - Convert a quoted-printable string to an 8 bit string


Returns all IMAP alert messages that have occurred

  • ? imap_8bit
  • imap_append ?
  • PHP Manual
  • IMAP 函数
  • Returns all IMAP alert messages that have occurred

imap_alerts

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_alerts — Returns all IMAP alert messages that have occurred

说明

imap_alerts ( ) : array|false

Returns all of the IMAP alert messages generated since the last imap_alerts() call, or the beginning of the page.

When imap_alerts() is called, the alert stack is subsequently cleared. The IMAP specification requires that these messages be passed to the user.

返回值

Returns an array of all of the IMAP alert messages generated or false if no alert messages are available.

参见

  • imap_errors() - Returns all of the IMAP errors that have occurred


Append a string message to a specified mailbox

  • ? imap_alerts
  • imap_base64 ?
  • PHP Manual
  • IMAP 函数
  • Append a string message to a specified mailbox

imap_append

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_append — Append a string message to a specified mailbox

说明

imap_append ( resource $imap , string $folder , string $message , string|null $options = null , string|null $internal_date = null ) : bool

Appends a string message to the specified folder.

参数

imap

由 imap_open() 返回的 IMAP 流。

folder

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

message

The message to be append, as a string

When talking to the Cyrus IMAP server, you must use "\r\n" as your end-of-line terminator instead of "\n" or the operation will fail

options

If provided, the options will also be written to the folder

internal_date

If this parameter is set, it will set the INTERNALDATE on the appended message. The parameter should be a date string that conforms to the rfc2060 specifications for a date_time value.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | options and internal_date are now nullable.

范例

Example #1 imap_append() example

<?php
$stream = imap_open("{imap.example.org}INBOX.Drafts", "username", "password");

$check = imap_check($stream);
echo "Msg Count before append: ". $check->Nmsgs . "\n";

imap_append($stream, "{imap.example.org}INBOX.Drafts"
                   , "From: me@example.com\r\n"
                   . "To: you@example.com\r\n"
                   . "Subject: test\r\n"
                   . "\r\n"
                   . "this is a test message, please ignore\r\n"
                   );

$check = imap_check($stream);
echo "Msg Count after append : ". $check->Nmsgs . "\n";

imap_close($stream);
?>


Decode BASE64 encoded text

  • ? imap_append
  • imap_binary ?
  • PHP Manual
  • IMAP 函数
  • Decode BASE64 encoded text

imap_base64

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_base64 — Decode BASE64 encoded text

说明

imap_base64 ( string $string ) : string|false

Decodes the given BASE-64 encoded string.

参数

string

The encoded text

返回值

Returns the decoded message as a string, 或者在失败时返回 false.

参见

  • imap_binary() - Convert an 8bit string to a base64 string
  • base64_encode() - 使用 MIME base64 对数据进行编码
  • base64_decode() - 对使用 MIME base64 编码的数据进行解码
  • » RFC2045, Section 6.8


Convert an 8bit string to a base64 string

  • ? imap_base64
  • imap_body ?
  • PHP Manual
  • IMAP 函数
  • Convert an 8bit string to a base64 string

imap_binary

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_binary — Convert an 8bit string to a base64 string

说明

imap_binary ( string $string ) : string|false

Convert an 8bit string to a base64 string according to » RFC2045, Section 6.8.

参数

string

The 8bit string

返回值

Returns a base64 encoded string, 或者在失败时返回 false.

参见

  • imap_base64() - Decode BASE64 encoded text


Read the message body

  • ? imap_binary
  • imap_bodystruct ?
  • PHP Manual
  • IMAP 函数
  • Read the message body

imap_body

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_body — Read the message body

说明

imap_body ( resource $imap , int $message_num , int $flags = 0 ) : string|false

imap_body() returns the body of the message, numbered message_num in the current mailbox.

imap_body() will only return a verbatim copy of the message body. To extract single parts of a multipart MIME-encoded message you have to use imap_fetchstructure() to analyze its structure and imap_fetchbody() to extract a copy of a single body component.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

flags

The optional flags are a bit mask with one or more of the following:

  • FT_UID - The message_num is a UID
  • FT_PEEK - Do not set the \Seen flag if not already set
  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

返回值

Returns the body of the specified message, as a string, 或者在失败时返回 false.


Read the structure of a specified body section of a specific message

  • ? imap_body
  • imap_check ?
  • PHP Manual
  • IMAP 函数
  • Read the structure of a specified body section of a specific message

imap_bodystruct

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_bodystruct — Read the structure of a specified body section of a specific message

说明

imap_bodystruct ( resource $imap , int $message_num , string $section ) : stdClass|false

Read the structure of a specified body section of a specific message.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

section

The body section to read

返回值

Returns the information in an object, 或者在失败时返回 false. For a detailed description of the object structure and properties see imap_fetchstructure().

参见

  • imap_fetchstructure() - Read the structure of a particular message


Check current mailbox

  • ? imap_bodystruct
  • imap_clearflag_full ?
  • PHP Manual
  • IMAP 函数
  • Check current mailbox

imap_check

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_check — Check current mailbox

说明

imap_check ( resource $imap ) : stdClass|false

Checks information about the current mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

返回值

Returns the information in an object with following properties:

  • Date - current system time formatted according to » RFC2822
  • Driver - protocol used to access this mailbox: POP3, IMAP, NNTP
  • Mailbox - the mailbox name
  • Nmsgs - number of messages in the mailbox
  • Recent - number of recent messages in the mailbox

Returns false on failure.

范例

Example #1 imap_check() example

<?php

$imap_obj = imap_check($imap_stream);
var_dump($imap_obj);

?>

以上例程的输出类似于：

object(stdClass)(5) {
  ["Date"]=>
  string(37) "Wed, 10 Dec 2003 17:56:54 +0100 (CET)"
  ["Driver"]=>
  string(4) "imap"
  ["Mailbox"]=>
  string(54)
  "{www.example.com:143/imap/user="foo@example.com"}INBOX"
  ["Nmsgs"]=>
  int(1)
  ["Recent"]=>
  int(0)
}


Clears flags on messages

  • ? imap_check
  • imap_close ?
  • PHP Manual
  • IMAP 函数
  • Clears flags on messages

imap_clearflag_full

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_clearflag_full — Clears flags on messages

说明

imap_clearflag_full ( resource $imap , string $sequence , string $flag , int $options = 0 ) : bool

This function causes a store to delete the specified flag to the flags set for the messages in the specified sequence.

参数

imap

由 imap_open() 返回的 IMAP 流。

sequence

A sequence of message numbers. You can enumerate desired messages with the X,Y syntax, or retrieve all messages within an interval with the X:Y syntax

flag

The flags which you can unset are "\\Seen", "\\Answered", "\\Flagged", "\\Deleted", and "\\Draft" (as defined by » RFC2060)

options

options are a bit mask and may contain the single option:

  • ST_UID - The sequence argument contains UIDs instead of sequence numbers

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_setflag_full() - Sets flags on messages


Close an IMAP stream

  • ? imap_clearflag_full
  • imap_create ?
  • PHP Manual
  • IMAP 函数
  • Close an IMAP stream

imap_close

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_close — Close an IMAP stream

说明

imap_close ( resource $imap , int $flags = 0 ) : bool

Closes the imap stream.

参数

imap

由 imap_open() 返回的 IMAP 流。

flags

If set to CL_EXPUNGE, the function will silently expunge the mailbox before closing, removing all messages marked for deletion. You can achieve the same thing by using imap_expunge()

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_open() - Open an IMAP stream to a mailbox


别名 imap_createmailbox

  • ? imap_close
  • imap_createmailbox ?
  • PHP Manual
  • IMAP 函数
  • 别名 imap_createmailbox

imap_create

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_create — 别名 imap_createmailbox()

说明

此函数是该函数的别名： imap_createmailbox().


Create a new mailbox

  • ? imap_create
  • imap_delete ?
  • PHP Manual
  • IMAP 函数
  • Create a new mailbox

imap_createmailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_createmailbox — Create a new mailbox

说明

imap_createmailbox ( resource $imap , string $mailbox ) : bool

Creates a new mailbox specified by mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

The mailbox name, see imap_open() for more information. Names containing international characters should be encoded by imap_utf7_encode()

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imap_createmailbox() example

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
     or die("can't connect: " . imap_last_error());

$name1 = "phpnewbox";
$name2 = imap_utf7_encode("phpnewb?x"); // phpnewb&w7Y-x

$newname = $name1;

echo "Newname will be '$name1'<br />\n";

// we will now create a new mailbox "phptestbox" in your inbox folder,
// check its status after creation and finally remove it to restore
// your inbox to its initial state

if (@imap_createmailbox($mbox, imap_utf7_encode("{imap.example.org}INBOX.$newname"))) {
    $status = @imap_status($mbox, "{imap.example.org}INBOX.$newname", SA_ALL);
    if ($status) {
        echo "your new mailbox '$name1' has the following status:<br />\n";
        echo "Messages:   " . $status->messages    . "<br />\n";
        echo "Recent:     " . $status->recent      . "<br />\n";
        echo "Unseen:     " . $status->unseen      . "<br />\n";
        echo "UIDnext:    " . $status->uidnext     . "<br />\n";
        echo "UIDvalidity:" . $status->uidvalidity . "<br />\n";

        if (imap_renamemailbox($mbox, "{imap.example.org}INBOX.$newname", "{imap.example.org}INBOX.$name2")) {
            echo "renamed new mailbox from '$name1' to '$name2'<br />\n";
            $newname = $name2;
        } else {
            echo "imap_renamemailbox on new mailbox failed: " . imap_last_error() . "<br />\n";
        }
    } else {
        echo "imap_status on new mailbox failed: " . imap_last_error() . "<br />\n";
    }

    if (@imap_deletemailbox($mbox, "{imap.example.org}INBOX.$newname")) {
        echo "new mailbox removed to restore initial state<br />\n";
    } else {
        echo "imap_deletemailbox on new mailbox failed: " . implode("<br />\n", imap_errors()) . "<br />\n";
    }

} else {
    echo "could not create new mailbox: " . implode("<br />\n", imap_errors()) . "<br />\n";
}

imap_close($mbox);
?>

参见

  • imap_renamemailbox() - Rename an old mailbox to new mailbox
  • imap_deletemailbox() - Delete a mailbox


Mark a message for deletion from current mailbox

  • ? imap_createmailbox
  • imap_deletemailbox ?
  • PHP Manual
  • IMAP 函数
  • Mark a message for deletion from current mailbox

imap_delete

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_delete — Mark a message for deletion from current mailbox

说明

imap_delete ( resource $imap , string $message_num , int $flags = 0 ) : bool

Marks messages listed in message_num for deletion. Messages marked for deletion will stay in the mailbox until either imap_expunge() is called or imap_close() is called with the optional parameter CL_EXPUNGE.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

flags

You can set the FT_UID which tells the function to treat the message_num argument as a UID.

返回值

Returns true.

范例

Example #1 imap_delete() example

<?php

$mbox = imap_open("{imap.example.org}INBOX", "username", "password")
    or die("Can't connect: " . imap_last_error());

$check = imap_mailboxmsginfo($mbox);
echo "Messages before delete: " . $check->Nmsgs . "<br />\n";

imap_delete($mbox, 1);

$check = imap_mailboxmsginfo($mbox);
echo "Messages after  delete: " . $check->Nmsgs . "<br />\n";

imap_expunge($mbox);

$check = imap_mailboxmsginfo($mbox);
echo "Messages after expunge: " . $check->Nmsgs . "<br />\n";

imap_close($mbox);
?>

注释

Note:

IMAP mailboxes may not have their message flags saved between connections, so imap_expunge() should be called during the same connection in order to guarantee that messages marked for deletion will actually be purged.

参见

  • imap_undelete() - Unmark the message which is marked deleted
  • imap_expunge() - Delete all messages marked for deletion
  • imap_close() - Close an IMAP stream


Delete a mailbox

  • ? imap_delete
  • imap_errors ?
  • PHP Manual
  • IMAP 函数
  • Delete a mailbox

imap_deletemailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_deletemailbox — Delete a mailbox

说明

imap_deletemailbox ( resource $imap , string $mailbox ) : bool

Deletes the specified mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_createmailbox() - Create a new mailbox
  • imap_renamemailbox() - Rename an old mailbox to new mailbox
  • imap_open() - Open an IMAP stream to a mailbox for the format of mbox


Returns all of the IMAP errors that have occurred

  • ? imap_deletemailbox
  • imap_expunge ?
  • PHP Manual
  • IMAP 函数
  • Returns all of the IMAP errors that have occurred

imap_errors

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_errors — Returns all of the IMAP errors that have occurred

说明

imap_errors ( ) : array|false

Gets all of the IMAP errors (if any) that have occurred during this page request or since the error stack was reset.

When imap_errors() is called, the error stack is subsequently cleared.

返回值

This function returns an array of all of the IMAP error messages generated since the last imap_errors() call, or the beginning of the page. Returns false if no error messages are available.

参见

  • imap_last_error() - Gets the last IMAP error that occurred during this page request
  • imap_alerts() - Returns all IMAP alert messages that have occurred


Delete all messages marked for deletion

  • ? imap_errors
  • imap_fetch_overview ?
  • PHP Manual
  • IMAP 函数
  • Delete all messages marked for deletion

imap_expunge

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_expunge — Delete all messages marked for deletion

说明

imap_expunge ( resource $imap ) : bool

Deletes all the messages marked for deletion by imap_delete(), imap_mail_move(), or imap_setflag_full().

参数

imap

由 imap_open() 返回的 IMAP 流。

返回值

Returns true.


Read an overview of the information in the headers of the given message

  • ? imap_expunge
  • imap_fetchbody ?
  • PHP Manual
  • IMAP 函数
  • Read an overview of the information in the headers of the given message

imap_fetch_overview

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetch_overview — Read an overview of the information in the headers of the given message

说明

imap_fetch_overview ( resource $imap , string $sequence , int $flags = 0 ) : array|false

This function fetches mail headers for the given sequence and returns an overview of their contents.

参数

imap

由 imap_open() 返回的 IMAP 流。

sequence

A message sequence description. You can enumerate desired messages with the X,Y syntax, or retrieve all messages within an interval with the X:Y syntax

flags

sequence will contain a sequence of message indices or UIDs, if this parameter is set to FT_UID.

返回值

Returns an array of objects describing one message header each. The object will only define a property if it exists. The possible properties are:

  • subject - the messages subject
  • from - who sent it
  • to - recipient
  • date - when was it sent
  • message_id - Message-ID
  • references - is a reference to this message id
  • in_reply_to - is a reply to this message id
  • size - size in bytes
  • uid - UID the message has in the mailbox
  • msgno - message sequence number in the mailbox
  • recent - this message is flagged as recent
  • flagged - this message is flagged
  • answered - this message is flagged as answered
  • deleted - this message is flagged for deletion
  • seen - this message is flagged as already read
  • draft - this message is flagged as being a draft
  • udate - the UNIX timestamp of the arrival date
The function returns false on failure.

范例

Example #1 imap_fetch_overview() example

<?php
$mbox = imap_open("{imap.example.org:143}INBOX", "username", "password")
     or die("can't connect: " . imap_last_error());

$MC = imap_check($mbox);

// Fetch an overview for all messages in INBOX
$result = imap_fetch_overview($mbox,"1:{$MC->Nmsgs}",0);
foreach ($result as $overview) {
    echo "#{$overview->msgno} ({$overview->date}) - From: {$overview->from}
    {$overview->subject}\n";
}
imap_close($mbox);
?>

参见

  • imap_fetchheader() - Returns header for a message


Fetch a particular section of the body of the message

  • ? imap_fetch_overview
  • imap_fetchheader ?
  • PHP Manual
  • IMAP 函数
  • Fetch a particular section of the body of the message

imap_fetchbody

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetchbody — Fetch a particular section of the body of the message

说明

imap_fetchbody ( resource $imap , int $message_num , string $section , int $flags = 0 ) : string|false

Fetch of a particular section of the body of the specified messages. Body parts are not decoded by this function.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

section

The part number. It is a string of integers delimited by period which index into a body part list as per the IMAP4 specification

flags

A bitmask with one or more of the following:

  • FT_UID - The message_num is a UID
  • FT_PEEK - Do not set the \Seen flag if not already set
  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

返回值

Returns a particular section of the body of the specified messages as a text string, 或者在失败时返回 false.

参见

  • imap_savebody() - Save a specific body section to a file
  • imap_fetchstructure() - Read the structure of a particular message


Returns header for a message

  • ? imap_fetchbody
  • imap_fetchmime ?
  • PHP Manual
  • IMAP 函数
  • Returns header for a message

imap_fetchheader

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetchheader — Returns header for a message

说明

imap_fetchheader ( resource $imap , int $message_num , int $flags = 0 ) : string|false

This function causes a fetch of the complete, unfiltered » RFC2822 format header of the specified message.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

flags

The possible flags are:

  • FT_UID - The msgno argument is a UID
  • FT_INTERNAL - The return string is in "internal" format, without any attempt to canonicalize to CRLF newlines
  • FT_PREFETCHTEXT - The RFC822.TEXT should be pre-fetched at the same time. This avoids an extra RTT on an IMAP connection if a full message text is desired (e.g. in a "save to local file" operation)

返回值

Returns the header of the specified message as a text string, 或者在失败时返回 false.

参见

  • imap_fetch_overview() - Read an overview of the information in the headers of the given message


Fetch MIME headers for a particular section of the message

  • ? imap_fetchheader
  • imap_fetchstructure ?
  • PHP Manual
  • IMAP 函数
  • Fetch MIME headers for a particular section of the message

imap_fetchmime

(PHP 5 >= 5.3.6, PHP 7, PHP 8)

imap_fetchmime — Fetch MIME headers for a particular section of the message

说明

imap_fetchmime ( resource $imap , int $message_num , string $section , int $flags = 0 ) : string|false

Fetch the MIME headers of a particular section of the body of the specified messages.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

section

The part number. It is a string of integers delimited by period which index into a body part list as per the IMAP4 specification

flags

A bitmask with one or more of the following:

  • FT_UID - The message_num is a UID
  • FT_PEEK - Do not set the \Seen flag if not already set
  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

返回值

Returns the MIME headers of a particular section of the body of the specified messages as a text string, 或者在失败时返回 false.

参见

  • imap_fetchbody() - Fetch a particular section of the body of the message
  • imap_fetchstructure() - Read the structure of a particular message
  • imap_fetchheader() - Returns header for a message


Read the structure of a particular message

  • ? imap_fetchmime
  • imap_fetchtext ?
  • PHP Manual
  • IMAP 函数
  • Read the structure of a particular message

imap_fetchstructure

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetchstructure — Read the structure of a particular message

说明

imap_fetchstructure ( resource $imap , int $message_num , int $flags = 0 ) : stdClass|false

Fetches all the structured information for a given message.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

flags

This optional parameter only has a single option, FT_UID, which tells the function to treat the message_num argument as a UID.

返回值

Returns an object with properties listed in the table below, 或者在失败时返回 false.

Returned Object for imap_fetchstructure()
type | Primary body type
encoding | Body transfer encoding
ifsubtype | true if there is a subtype string
subtype | MIME subtype
ifdescription | true if there is a description string
description | Content description string
ifid | true if there is an identification string
id | Identification string
lines | Number of lines
bytes | Number of bytes
ifdisposition | true if there is a disposition string
disposition | Disposition string
ifdparameters | true if the dparameters array exists
dparameters | An array of objects where each object has an "attribute" and a "value" property corresponding to the parameters on the Content-disposition MIME header.
ifparameters | true if the parameters array exists
parameters | An array of objects where each object has an "attribute" and a "value" property.
parts | An array of objects identical in structure to the top-level object, each of which corresponds to a MIME body part.

Primary body type (value may vary with used library, use of constants is recommended)
Value | Type | Constant
0 | text | TYPETEXT
1 | multipart | TYPEMULTIPART
2 | message | TYPEMESSAGE
3 | application | TYPEAPPLICATION
4 | audio | TYPEAUDIO
5 | image | TYPEIMAGE
6 | video | TYPEVIDEO
7 | model | TYPEMODEL
8 | other | TYPEOTHER

Transfer encodings (value may vary with used library, use of constants is recommended)
Value | Type | Constant
0 | 7bit | ENC7BIT
1 | 8bit | ENC8BIT
2 | Binary | ENCBINARY
3 | Base64 | ENCBASE64
4 | Quoted-Printable | ENCQUOTEDPRINTABLE
5 | other | ENCOTHER

参见

  • imap_fetchbody() - Fetch a particular section of the body of the message
  • imap_bodystruct() - Read the structure of a specified body section of a specific message


别名 imap_body

  • ? imap_fetchstructure
  • imap_gc ?
  • PHP Manual
  • IMAP 函数
  • 别名 imap_body

imap_fetchtext

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_fetchtext — 别名 imap_body()

说明

此函数是该函数的别名： imap_body().


Clears IMAP cache

  • ? imap_fetchtext
  • imap_get_quota ?
  • PHP Manual
  • IMAP 函数
  • Clears IMAP cache

imap_gc

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

imap_gc — Clears IMAP cache

说明

imap_gc ( resource $imap , int $flags ) : bool

Purges the cache of entries of a specific type.

参数

imap

由 imap_open() 返回的 IMAP 流。

flags

Specifies the cache to purge. It may one or a combination of the following constants: IMAP_GC_ELT (message cache elements), IMAP_GC_ENV (envelope and bodies), IMAP_GC_TEXTS (texts).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imap_gc() example

<?php

$mbox = imap_open("{imap.example.org:143}", "username", "password");

imap_gc($mbox, IMAP_GC_ELT);

?>


Retrieve the quota level settings, and usage statics per mailbox

  • ? imap_gc
  • imap_get_quotaroot ?
  • PHP Manual
  • IMAP 函数
  • Retrieve the quota level settings, and usage statics per mailbox

imap_get_quota

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

imap_get_quota — Retrieve the quota level settings, and usage statics per mailbox

说明

imap_get_quota ( resource $imap , string $quota_root ) : array|false

Retrieve the quota level settings, and usage statics per mailbox.

For a non-admin user version of this function, please see the imap_get_quotaroot() function of PHP.

参数

imap

由 imap_open() 返回的 IMAP 流。

quota_root

quota_root should normally be in the form of user.name where name is the mailbox you wish to retrieve information about.

返回值

Returns an array with integer values limit and usage for the given mailbox. The value of limit represents the total amount of space allowed for this mailbox. The usage value represents the mailboxes current level of capacity. Will return false in the case of failure.

As of PHP 4.3, the function more properly reflects the functionality as dictated by the » RFC2087. The array return value has changed to support an unlimited number of returned resources (i.e. messages, or sub-folders) with each named resource receiving an individual array key. Each key value then contains an another array with the usage and limit values within it.

For backwards compatibility reasons, the original access methods are still available for use, although it is suggested to update.

范例

Example #1 imap_get_quota() example

<?php
$mbox = imap_open("{imap.example.org}", "mailadmin", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota_value = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_value)) {
    echo "Usage level is: " . $quota_value['usage'];
    echo "Limit level is: " . $quota_value['limit'];
}

imap_close($mbox);
?>

Example #2 imap_get_quota() 4.3 or greater example

<?php
$mbox = imap_open("{imap.example.org}", "mailadmin", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota_values = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_values)) {
   $storage = $quota_values['STORAGE'];
   echo "STORAGE usage level is: " .  $storage['usage'];
   echo "STORAGE limit level is: " .  $storage['limit'];

   $message = $quota_values['MESSAGE'];
   echo "MESSAGE usage level is: " .  $message['usage'];
   echo "MESSAGE limit is: " .  $message['limit'];

   /* ...  */
}

imap_close($mbox);
?>

注释

This function is currently only available to users of the c-client2000 or greater library.

The given imap must be opened as the mail administrator, otherwise this function will fail.

参见

  • imap_open() - Open an IMAP stream to a mailbox
  • imap_set_quota() - Sets a quota for a given mailbox
  • imap_get_quotaroot() - Retrieve the quota settings per user


Retrieve the quota settings per user

  • ? imap_get_quota
  • imap_getacl ?
  • PHP Manual
  • IMAP 函数
  • Retrieve the quota settings per user

imap_get_quotaroot

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

imap_get_quotaroot — Retrieve the quota settings per user

说明

imap_get_quotaroot ( resource $imap , string $mailbox ) : array|false

Retrieve the quota settings per user. The limit value represents the total amount of space allowed for this user's total mailbox usage. The usage value represents the user's current total mailbox capacity.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

mailbox should normally be in the form of which mailbox (i.e. INBOX).

返回值

Returns an array of integer values pertaining to the specified user mailbox. All values contain a key based upon the resource name, and a corresponding array with the usage and limit values within.

This function will return false in the case of call failure, and an array of information about the connection upon an un-parsable response from the server.

范例

Example #1 imap_get_quotaroot() example

<?php
$mbox = imap_open("{imap.example.org}", "kalowsky", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota = imap_get_quotaroot($mbox, "INBOX");
if (is_array($quota)) {
   $storage = $quota['STORAGE'];
   echo "STORAGE usage level is: " .  $storage['usage'];
   echo "STORAGE limit level is: " .  $storage['limit'];

   $message = $quota['MESSAGE'];
   echo "MESSAGE usage level is: " .  $message['usage'];
   echo "MESSAGE limit level is: " .  $message['limit'];

   /* ...  */

}

imap_close($mbox);
?>

注释

This function is currently only available to users of the c-client2000 or greater library.

The imap should be opened as the user whose mailbox you wish to check.

参见

  • imap_open() - Open an IMAP stream to a mailbox
  • imap_set_quota() - Sets a quota for a given mailbox
  • imap_get_quota() - Retrieve the quota level settings, and usage statics per mailbox


Gets the ACL for a given mailbox

  • ? imap_get_quotaroot
  • imap_getmailboxes ?
  • PHP Manual
  • IMAP 函数
  • Gets the ACL for a given mailbox

imap_getacl

(PHP 5, PHP 7, PHP 8)

imap_getacl — Gets the ACL for a given mailbox

说明

imap_getacl ( resource $imap , string $mailbox ) : array|false

Gets the ACL for a given mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

返回值

Returns an associative array of "folder" => "acl" pairs, 或者在失败时返回 false.

范例

Example #1 imap_getacl() example

<?php

print_r(imap_getacl($conn_id, 'user.joecool'));

?>

以上例程的输出类似于：

Array
(
    [asubfolder] => lrswipcda
    [anothersubfolder] => lrswipcda
)

注释

This function is currently only available to users of the c-client2000 or greater library.

参见

  • imap_setacl() - Sets the ACL for a given mailbox


Read the list of mailboxes, returning detailed information on each one

  • ? imap_getacl
  • imap_getsubscribed ?
  • PHP Manual
  • IMAP 函数
  • Read the list of mailboxes, returning detailed information on each one

imap_getmailboxes

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_getmailboxes — Read the list of mailboxes, returning detailed information on each one

说明

imap_getmailboxes ( resource $imap , string $reference , string $pattern ) : array|false

Gets information on the mailboxes.

参数

imap

由 imap_open() 返回的 IMAP 流。

reference

reference should normally be just the server specification as described in imap_open()

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

pattern

指定在邮箱层级的何处开始查找。

在组成 pattern 的字符中可使用两个特殊字符： '*' 和 '%'。 '*' 是指返回所有邮箱目录. 如果将 '*' 作为 pattern 参数时, 则会返回整个邮箱层级结构。 '%' 是指只返回当前级次。 '%' 作为 pattern 参数则只会返回顶层邮箱； '~/mail/%' 用于 UW_IMAPD 则会返回名为 ~/mail 的目录, 但不包含其子目录。

返回值

Returns an array of objects containing mailbox information. Each object has the attributes name, specifying the full name of the mailbox; delimiter, which is the hierarchy delimiter for the part of the hierarchy this mailbox is in; and attributes. Attributes is a bitmask that can be tested against:

  • LATT_NOINFERIORS - This mailbox not contains, and may not contain any "children" (there are no mailboxes below this one). Calling imap_createmailbox() will not work on this mailbox.

  • LATT_NOSELECT - This is only a container, not a mailbox - you cannot open it.

  • LATT_MARKED - This mailbox is marked. This means that it may contain new messages since the last time it was checked. Not provided by all IMAP servers.

  • LATT_UNMARKED - This mailbox is not marked, does not contain new messages. If either MARKED or UNMARKED is provided, you can assume the IMAP server supports this feature for this mailbox.

  • LATT_REFERRAL - This container has a referral to a remote mailbox.

  • LATT_HASCHILDREN - This mailbox has selectable inferiors.

  • LATT_HASNOCHILDREN - This mailbox has no selectable inferiors.

The function returns false on failure.

范例

Example #1 imap_getmailboxes() example

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$list = imap_getmailboxes($mbox, "{imap.example.org}", "*");
if (is_array($list)) {
    foreach ($list as $key => $val) {
        echo "($key) ";
        echo imap_utf7_decode($val->name) . ",";
        echo "'" . $val->delimiter . "',";
        echo $val->attributes . "<br />\n";
    }
} else {
    echo "imap_getmailboxes failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

参见

  • imap_getsubscribed() - List all the subscribed mailboxes


List all the subscribed mailboxes

  • ? imap_getmailboxes
  • imap_header ?
  • PHP Manual
  • IMAP 函数
  • List all the subscribed mailboxes

imap_getsubscribed

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_getsubscribed — List all the subscribed mailboxes

说明

imap_getsubscribed ( resource $imap , string $reference , string $pattern ) : array|false

Gets information about the subscribed mailboxes.

Identical to imap_getmailboxes(), except that it only returns mailboxes that the user is subscribed to.

参数

imap

由 imap_open() 返回的 IMAP 流。

reference

reference should normally be just the server specification as described in imap_open()

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

pattern

指定在邮箱层级的何处开始查找。

在组成 pattern 的字符中可使用两个特殊字符： '*' 和 '%'。 '*' 是指返回所有邮箱目录. 如果将 '*' 作为 pattern 参数时, 则会返回整个邮箱层级结构。 '%' 是指只返回当前级次。 '%' 作为 pattern 参数则只会返回顶层邮箱； '~/mail/%' 用于 UW_IMAPD 则会返回名为 ~/mail 的目录, 但不包含其子目录。

返回值

Returns an array of objects containing mailbox information. Each object has the attributes name, specifying the full name of the mailbox; delimiter, which is the hierarchy delimiter for the part of the hierarchy this mailbox is in; and attributes. Attributes is a bitmask that can be tested against:

  • LATT_NOINFERIORS - This mailbox has no "children" (there are no mailboxes below this one).
  • LATT_NOSELECT - This is only a container, not a mailbox - you cannot open it.
  • LATT_MARKED - This mailbox is marked. Only used by UW-IMAPD.
  • LATT_UNMARKED - This mailbox is not marked. Only used by UW-IMAPD.
  • LATT_REFERRAL - This container has a referral to a remote mailbox.
  • LATT_HASCHILDREN - This mailbox has selectable inferiors.
  • LATT_HASNOCHILDREN - This mailbox has no selectable inferiors.
The function returns false on failure.


别名 imap_headerinfo

  • ? imap_getsubscribed
  • imap_headerinfo ?
  • PHP Manual
  • IMAP 函数
  • 别名 imap_headerinfo

imap_header

(PHP 4, PHP 5, PHP 7)

imap_header — 别名 imap_headerinfo()

Warning

该别名已在 PHP 8.0.0 中被 移除。

说明

此函数是该函数的别名： imap_headerinfo().


Read the header of the message

  • ? imap_header
  • imap_headers ?
  • PHP Manual
  • IMAP 函数
  • Read the header of the message

imap_headerinfo

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_headerinfo — Read the header of the message

说明

imap_headerinfo ( resource $imap , int $message_num , int $from_length = 0 , int $subject_length = 0 ) : stdClass|false

Gets information about the given message number by reading its headers.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

from_length

Number of characters for the fetchfrom property. Must be greater than or equal to zero.

subject_length

Number of characters for the fetchsubject property Must be greater than or equal to zero.

defaulthost

返回值

Returns false on error or, if successful, the information in an object with following properties:

  • toaddress - full to: line, up to 1024 characters
  • to - an array of objects from the To: line, with the following properties: personal, adl, mailbox, and host
  • fromaddress - full from: line, up to 1024 characters
  • from - an array of objects from the From: line, with the following properties: personal, adl, mailbox, and host
  • ccaddress - full cc: line, up to 1024 characters
  • cc - an array of objects from the Cc: line, with the following properties: personal, adl, mailbox, and host
  • bccaddress - full bcc: line, up to 1024 characters
  • bcc - an array of objects from the Bcc: line, with the following properties: personal, adl, mailbox, and host
  • reply_toaddress - full Reply-To: line, up to 1024 characters
  • reply_to - an array of objects from the Reply-To: line, with the following properties: personal, adl, mailbox, and host
  • senderaddress - full sender: line, up to 1024 characters
  • sender - an array of objects from the Sender: line, with the following properties: personal, adl, mailbox, and host
  • return_pathaddress - full Return-Path: line, up to 1024 characters
  • return_path - an array of objects from the Return-Path: line, with the following properties: personal, adl, mailbox, and host
  • remail -
  • date - The message date as found in its headers
  • Date - Same as date
  • subject - The message subject
  • Subject - Same as subject
  • in_reply_to -
  • message_id -
  • newsgroups -
  • followup_to -
  • references -
  • Recent - R if recent and seen, N if recent and not seen, ' ' if not recent.
  • Unseen - U if not seen AND not recent, ' ' if seen OR not seen and recent
  • Flagged - F if flagged, ' ' if not flagged
  • Answered - A if answered, ' ' if unanswered
  • Deleted - D if deleted, ' ' if not deleted
  • Draft - X if draft, ' ' if not draft
  • Msgno - The message number
  • MailDate -
  • Size - The message size
  • udate - mail message date in Unix time
  • fetchfrom - from line formatted to fit from_length characters
  • fetchsubject - subject line formatted to fit subject_length characters

更新日志

版本 | 说明
8.0.0 | The unused defaulthost parameter has been removed.

参见

  • imap_fetch_overview() - Read an overview of the information in the headers of the given message


Returns headers for all messages in a mailbox

  • ? imap_headerinfo
  • imap_last_error ?
  • PHP Manual
  • IMAP 函数
  • Returns headers for all messages in a mailbox

imap_headers

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_headers — Returns headers for all messages in a mailbox

说明

imap_headers ( resource $imap ) : array|false

Returns headers for all messages in a mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

返回值

Returns an array of string formatted with header info. One element per mail message. Returns false on failure.


Gets the last IMAP error that occurred during this page request

  • ? imap_headers
  • imap_list ?
  • PHP Manual
  • IMAP 函数
  • Gets the last IMAP error that occurred during this page request

imap_last_error

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_last_error — Gets the last IMAP error that occurred during this page request

说明

imap_last_error ( ) : string|false

Gets the full text of the last IMAP error message that occurred on the current page. The error stack is untouched; calling imap_last_error() subsequently, with no intervening errors, will return the same error.

返回值

Returns the full text of the last IMAP error message that occurred on the current page. Returns false if no error messages are available.

参见

  • imap_errors() - Returns all of the IMAP errors that have occurred


Read the list of mailboxes

  • ? imap_last_error
  • imap_listmailbox ?
  • PHP Manual
  • IMAP 函数
  • Read the list of mailboxes

imap_list

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_list — Read the list of mailboxes

说明

imap_list ( resource $imap , string $reference , string $pattern ) : array|false

Read the list of mailboxes.

参数

imap

由 imap_open() 返回的 IMAP 流。

reference

reference should normally be just the server specification as described in imap_open().

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

pattern

指定在邮箱层级的何处开始查找。

在组成 pattern 的字符中可使用两个特殊字符： '*' 和 '%'。 '*' 是指返回所有邮箱目录. 如果将 '*' 作为 pattern 参数时, 则会返回整个邮箱层级结构。 '%' 是指只返回当前级次。 '%' 作为 pattern 参数则只会返回顶层邮箱； '~/mail/%' 用于 UW_IMAPD 则会返回名为 ~/mail 的目录, 但不包含其子目录。

返回值

Returns an array containing the names of the mailboxes or false in case of failure.

范例

Example #1 imap_list() example

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$list = imap_list($mbox, "{imap.example.org}", "*");
if (is_array($list)) {
    foreach ($list as $val) {
        echo imap_utf7_decode($val) . "\n";
    }
} else {
    echo "imap_list failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

参见

  • imap_getmailboxes() - Read the list of mailboxes, returning detailed information on each one
  • imap_lsub() - List all the subscribed mailboxes


别名 imap_list

  • ? imap_list
  • imap_listscan ?
  • PHP Manual
  • IMAP 函数
  • 别名 imap_list

imap_listmailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_listmailbox — 别名 imap_list()

说明

此函数是该函数的别名： imap_list().


Returns the list of mailboxes that matches the given text

  • ? imap_listmailbox
  • imap_listsubscribed ?
  • PHP Manual
  • IMAP 函数
  • Returns the list of mailboxes that matches the given text

imap_listscan

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_listscan — Returns the list of mailboxes that matches the given text

说明

imap_listscan ( resource $imap , string $reference , string $pattern , string $content ) : array|false

Returns an array containing the names of the mailboxes that have content in the text of the mailbox.

This function is similar to imap_listmailbox(), but it will additionally check for the presence of the string content inside the mailbox data.

参数

imap

由 imap_open() 返回的 IMAP 流。

reference

reference should normally be just the server specification as described in imap_open()

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

pattern

指定在邮箱层级的何处开始查找。

在组成 pattern 的字符中可使用两个特殊字符： '*' 和 '%'。 '*' 是指返回所有邮箱目录. 如果将 '*' 作为 pattern 参数时, 则会返回整个邮箱层级结构。 '%' 是指只返回当前级次。 '%' 作为 pattern 参数则只会返回顶层邮箱； '~/mail/%' 用于 UW_IMAPD 则会返回名为 ~/mail 的目录, 但不包含其子目录。

content

The searched string

返回值

Returns an array containing the names of the mailboxes that have content in the text of the mailbox, 或者在失败时返回 false.

参见

  • imap_listmailbox() - 别名 imap_list
  • imap_search() - This function returns an array of messages matching the given search criteria


别名 imap_lsub

  • ? imap_listscan
  • imap_lsub ?
  • PHP Manual
  • IMAP 函数
  • 别名 imap_lsub

imap_listsubscribed

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_listsubscribed — 别名 imap_lsub()

说明

此函数是该函数的别名： imap_lsub().


List all the subscribed mailboxes

  • ? imap_listsubscribed
  • imap_mail_compose ?
  • PHP Manual
  • IMAP 函数
  • List all the subscribed mailboxes

imap_lsub

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_lsub — List all the subscribed mailboxes

说明

imap_lsub ( resource $imap , string $reference , string $pattern ) : array|false

Gets an array of all the mailboxes that you have subscribed.

参数

imap

由 imap_open() 返回的 IMAP 流。

reference

reference should normally be just the server specification as described in imap_open()

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

pattern

指定在邮箱层级的何处开始查找。

在组成 pattern 的字符中可使用两个特殊字符： '*' 和 '%'。 '*' 是指返回所有邮箱目录. 如果将 '*' 作为 pattern 参数时, 则会返回整个邮箱层级结构。 '%' 是指只返回当前级次。 '%' 作为 pattern 参数则只会返回顶层邮箱； '~/mail/%' 用于 UW_IMAPD 则会返回名为 ~/mail 的目录, 但不包含其子目录。

返回值

Returns an array of all the subscribed mailboxes, 或者在失败时返回 false.

参见

  • imap_list() - Read the list of mailboxes
  • imap_getmailboxes() - Read the list of mailboxes, returning detailed information on each one


Create a MIME message based on given envelope and body sections

  • ? imap_lsub
  • imap_mail_copy ?
  • PHP Manual
  • IMAP 函数
  • Create a MIME message based on given envelope and body sections

imap_mail_compose

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mail_compose — Create a MIME message based on given envelope and body sections

说明

imap_mail_compose ( array $envelope , array $bodies ) : string|false

Create a MIME message based on the given envelope and bodies sections.

参数

envelope

An associative array of header fields. Valid keys are: "remail", "return_path", "date", "from", "reply_to", "in_reply_to", "subject", "to", "cc", "bcc" and "message_id", which set the respective message headers to the given string. To set additional headers, the key "custom_headers" is supported, which expects an array of those headers, e.g. ["User-Agent: My Mail Client"].

bodies

An indexed array of bodies. The first body is the main body of the message; only if it has a type of TYPEMULTIPART, further bodies are processed; these bodies constitute the bodies of the parts.

Body Array Structure
Key | Type | Description
type | int | The MIME type. One of TYPETEXT (default), TYPEMULTIPART, TYPEMESSAGE, TYPEAPPLICATION, TYPEAUDIO, TYPEIMAGE, TYPEMODEL or TYPEOTHER.
encoding | int | The Content-Transfer-Encoding. One of ENC7BIT (default), ENC8BIT, ENCBINARY, ENCBASE64, ENCQUOTEDPRINTABLE or ENCOTHER.
charset | string | The charset parameter of the MIME type.
type.parameters | array | An associative array of Content-Type parameter names and their values.
subtype | string | The MIME subtype, e.g. 'jpeg' for TYPEIMAGE.
id | string | The Content-ID.
description | string | The Content-Description.
disposition.type | string | The Content-Disposition, e.g. 'attachment'.
disposition | array | An associative array of Content-Disposition parameter names and values.
contents.data | string | The payload.
lines | int | The size of the payload in lines.
bytes | int | The size of the payload in bytes.
md5 | string | The MD5 checksum of the payload.

返回值

Returns the MIME message as string, 或者在失败时返回 false.

范例

Example #1 imap_mail_compose() example

<?php

$envelope["from"]= "joe@example.com";
$envelope["to"]  = "foo@example.com";
$envelope["cc"]  = "bar@example.com";

$part1["type"] = TYPEMULTIPART;
$part1["subtype"] = "mixed";

$filename = "/tmp/imap.c.gz";
$fp = fopen($filename, "r");
$contents = fread($fp, filesize($filename));
fclose($fp);

$part2["type"] = TYPEAPPLICATION;
$part2["encoding"] = ENCBINARY;
$part2["subtype"] = "octet-stream";
$part2["description"] = basename($filename);
$part2["contents.data"] = $contents;

$part3["type"] = TYPETEXT;
$part3["subtype"] = "plain";
$part3["description"] = "description3";
$part3["contents.data"] = "contents.data3\n\n\n\t";

$body[1] = $part1;
$body[2] = $part2;
$body[3] = $part3;

echo nl2br(imap_mail_compose($envelope, $body));

?>


Copy specified messages to a mailbox

  • ? imap_mail_compose
  • imap_mail_move ?
  • PHP Manual
  • IMAP 函数
  • Copy specified messages to a mailbox

imap_mail_copy

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mail_copy — Copy specified messages to a mailbox

说明

imap_mail_copy ( resource $imap , string $message_nums , string $mailbox , int $flags = 0 ) : bool

Copies mail messages specified by message_nums to specified mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_nums

message_nums is a range not just message numbers (as described in » RFC2060).

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

flags

flags is a bitmask of one or more of

  • CP_UID - the sequence numbers contain UIDS
  • CP_MOVE - Delete the messages from the current mailbox after copying

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_mail_move() - Move specified messages to a mailbox


Move specified messages to a mailbox

  • ? imap_mail_copy
  • imap_mail ?
  • PHP Manual
  • IMAP 函数
  • Move specified messages to a mailbox

imap_mail_move

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mail_move — Move specified messages to a mailbox

说明

imap_mail_move ( resource $imap , string $message_nums , string $mailbox , int $flags = 0 ) : bool

Moves mail messages specified by message_nums to the specified mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

message_nums

message_nums is a range not just message numbers (as described in » RFC2060).

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

flags

flags is a bitmask and may contain the single option:

  • CP_UID - the sequence numbers contain UIDS

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

imap_mail_move() will flag the original mail with a delete flag, to successfully delete it a call to the imap_expunge() function must be made.

参见

  • imap_mail_copy() - Copy specified messages to a mailbox


Send an email message

  • ? imap_mail_move
  • imap_mailboxmsginfo ?
  • PHP Manual
  • IMAP 函数
  • Send an email message

imap_mail

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mail — Send an email message

说明

imap_mail ( string $to , string $subject , string $message , string|null $additional_headers = null , string|null $cc = null , string|null $bcc = null , string|null $return_path = null ) : bool

This function allows sending of emails with correct handling of Cc and Bcc receivers.

The parameters to, cc and bcc are all strings and are all parsed as » RFC822 address lists.

参数

to

The receiver

subject

The mail subject

message

The mail body, see imap_mail_compose()

additional_headers

As string with additional headers to be set on the mail

cc

bcc

The receivers specified in bcc will get the mail, but are excluded from the headers.

return_path

Use this parameter to specify return path upon mail delivery failure. This is useful when using PHP as a mail client for multiple users.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | additional_headers, cc, bcc, and return_path are now nullable.

参见

  • mail() - 发送邮件
  • imap_mail_compose() - Create a MIME message based on given envelope and body sections


Get information about the current mailbox

  • ? imap_mail
  • imap_mime_header_decode ?
  • PHP Manual
  • IMAP 函数
  • Get information about the current mailbox

imap_mailboxmsginfo

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mailboxmsginfo — Get information about the current mailbox

说明

imap_mailboxmsginfo ( resource $imap ) : stdClass

Checks the current mailbox status on the server. It is similar to imap_status(), but will additionally sum up the size of all messages in the mailbox, which will take some additional time to execute.

参数

imap

由 imap_open() 返回的 IMAP 流。

返回值

Returns the information in an object with following properties:

Mailbox properties
Date | date of last change (current datetime)
Driver | driver
Mailbox | name of the mailbox
Nmsgs | number of messages
Recent | number of recent messages
Unread | number of unread messages
Deleted | number of deleted messages
Size | mailbox size

Returns false on failure.

范例

Example #1 imap_mailboxmsginfo() example

<?php

$mbox = imap_open("{imap.example.org}INBOX", "username", "password")
      or die("can't connect: " . imap_last_error());

$check = imap_mailboxmsginfo($mbox);

if ($check) {
    echo "Date: "     . $check->Date    . "<br />\n" ;
    echo "Driver: "   . $check->Driver  . "<br />\n" ;
    echo "Mailbox: "  . $check->Mailbox . "<br />\n" ;
    echo "Messages: " . $check->Nmsgs   . "<br />\n" ;
    echo "Recent: "   . $check->Recent  . "<br />\n" ;
    echo "Unread: "   . $check->Unread  . "<br />\n" ;
    echo "Deleted: "  . $check->Deleted . "<br />\n" ;
    echo "Size: "     . $check->Size    . "<br />\n" ;
} else {
    echo "imap_mailboxmsginfo() failed: " . imap_last_error() . "<br />\n";
}

imap_close($mbox);

?>


Decode MIME header elements

  • ? imap_mailboxmsginfo
  • imap_msgno ?
  • PHP Manual
  • IMAP 函数
  • Decode MIME header elements

imap_mime_header_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_mime_header_decode — Decode MIME header elements

说明

imap_mime_header_decode ( string $string ) : array|false

Decodes MIME message header extensions that are non ASCII text (see » RFC2047).

参数

string

The MIME text

返回值

The decoded elements are returned in an array of objects, where each object has two properties, charset and text.

If the element hasn't been encoded, and in other words is in plain US-ASCII, the charset property of that element is set to default.

The function returns false on failure.

范例

Example #1 imap_mime_header_decode() example

<?php
$text = "=?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <keld@example.com>";

$elements = imap_mime_header_decode($text);
for ($i=0; $i<count($elements); $i++) {
    echo "Charset: {$elements[$i]->charset}\n";
    echo "Text: {$elements[$i]->text}\n\n";
}
?>

以上例程会输出：

Charset: ISO-8859-1
Text: Keld J?rn Simonsen

Charset: default
Text:  <keld@example.com>

In the above example we would have two elements, whereas the first element had previously been encoded with ISO-8859-1, and the second element would be plain US-ASCII.

参见

  • imap_utf8() - Converts MIME-encoded text to UTF-8


Gets the message sequence number for the given UID

  • ? imap_mime_header_decode
  • imap_mutf7_to_utf8 ?
  • PHP Manual
  • IMAP 函数
  • Gets the message sequence number for the given UID

imap_msgno

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_msgno — Gets the message sequence number for the given UID

说明

imap_msgno ( resource $imap , int $message_uid ) : int

Returns the message sequence number for the given message_uid.

This function is the inverse of imap_uid().

参数

imap

由 imap_open() 返回的 IMAP 流。

message_uid

The message UID

返回值

Returns the message sequence number for the given message_uid.

参见

  • imap_uid() - This function returns the UID for the given message sequence number


Decode a modified UTF-7 string to UTF-8

  • ? imap_msgno
  • imap_num_msg ?
  • PHP Manual
  • IMAP 函数
  • Decode a modified UTF-7 string to UTF-8

imap_mutf7_to_utf8

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

imap_mutf7_to_utf8 — Decode a modified UTF-7 string to UTF-8

说明

imap_mutf7_to_utf8 ( string $string ) : string|false

Decode a modified UTF-7 (as specified in RFC 2060, section 5.1.3) string to UTF-8.

Note:

This function is only available, if libcclient exports utf8_to_mutf7().

参数

string

A string encoded in modified UTF-7.

返回值

Returns string converted to UTF-8, 或者在失败时返回 false.

参见

  • imap_utf8_to_mutf7() - Encode a UTF-8 string to modified UTF-7


Gets the number of messages in the current mailbox

  • ? imap_mutf7_to_utf8
  • imap_num_recent ?
  • PHP Manual
  • IMAP 函数
  • Gets the number of messages in the current mailbox

imap_num_msg

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_num_msg — Gets the number of messages in the current mailbox

说明

imap_num_msg ( resource $imap ) : int|false

Gets the number of messages in the current mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

返回值

Return the number of messages in the current mailbox, as an integer, or false on error.

参见

  • imap_num_recent() - Gets the number of recent messages in current mailbox
  • imap_status() - Returns status information on a mailbox


Gets the number of recent messages in current mailbox

  • ? imap_num_msg
  • imap_open ?
  • PHP Manual
  • IMAP 函数
  • Gets the number of recent messages in current mailbox

imap_num_recent

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_num_recent — Gets the number of recent messages in current mailbox

说明

imap_num_recent ( resource $imap ) : int

Gets the number of recent messages in the current mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

返回值

Returns the number of recent messages in the current mailbox, as an integer.

参见

  • imap_num_msg() - Gets the number of messages in the current mailbox
  • imap_status() - Returns status information on a mailbox


Open an IMAP stream to a mailbox

  • ? imap_num_recent
  • imap_ping ?
  • PHP Manual
  • IMAP 函数
  • Open an IMAP stream to a mailbox

imap_open

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_open — Open an IMAP stream to a mailbox

说明

imap_open ( string $mailbox , string $user , string $password , int $flags = 0 , int $retries = 0 , array $options = [] ) : resource|false

Opens an IMAP stream to a mailbox.

This function can also be used to open streams to POP3 and NNTP servers, but some functions and features are only available on IMAP servers.

参数

mailbox

A mailbox name consists of a server and a mailbox path on this server. The special name INBOX stands for the current users personal mailbox. Mailbox names that contain international characters besides those in the printable ASCII space have to be encoded with imap_utf7_encode().

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

The server part, which is enclosed in '{' and '}', consists of the servers name or ip address, an optional port (prefixed by ':'), and an optional protocol specification (prefixed by '/').

The server part is mandatory in all mailbox parameters.

All names which start with { are remote names, and are in the form "{" remote_system_name [":" port] [flags] "}" [mailbox_name] where:

  • remote_system_name - Internet domain name or bracketed IP address of server.
  • port - optional TCP port number, default is the default port for that service
  • flags - optional flags, see following table.
  • mailbox_name - remote mailbox name, default is INBOX

Optional flags for names
Flag | Description
/service=service | mailbox access service, default is "imap"
/user=user | remote user name for login on the server
/authuser=user | remote authentication user; if specified this is the user name whose password is used (e.g. administrator)
/anonymous | remote access as anonymous user
/debug | record protocol telemetry in application's debug log
/secure | do not transmit a plaintext password over the network
/imap, /imap2, /imap2bis, /imap4, /imap4rev1 | equivalent to /service=imap
/pop3 | equivalent to /service=pop3
/nntp | equivalent to /service=nntp
/norsh | do not use rsh or ssh to establish a preauthenticated IMAP session
/ssl | use the Secure Socket Layer to encrypt the session
/validate-cert | validate certificates from TLS/SSL server (this is the default behavior)
/novalidate-cert | do not validate certificates from TLS/SSL server, needed if server uses self-signed certificates
/tls | force use of start-TLS to encrypt the session, and reject connection to servers that do not support it
/notls | do not do start-TLS to encrypt the session, even with servers that support it
/readonly | request read-only mailbox open (IMAP only; ignored on NNTP, and an error with SMTP and POP3)

user

The user name

password

The password associated with the user

flags

The flags are a bit mask with one or more of the following:

  • OP_READONLY - Open mailbox read-only
  • OP_ANONYMOUS - Don't use or update a .newsrc for news (NNTP only)
  • OP_HALFOPEN - For IMAP and NNTP names, open a connection but don't open a mailbox.
  • CL_EXPUNGE - Expunge mailbox automatically upon mailbox close (see also imap_delete() and imap_expunge())
  • OP_DEBUG - Debug protocol negotiations
  • OP_SHORTCACHE - Short (elt-only) caching
  • OP_SILENT - Don't pass up events (internal use)
  • OP_PROTOTYPE - Return driver prototype
  • OP_SECURE - Don't do non-secure authentication

retries

Number of maximum connect attempts

options

Connection parameters, the following (string) keys maybe used to set one or more connection parameters:

  • DISABLE_AUTHENTICATOR - Disable authentication properties

返回值

Returns an IMAP stream on success or false on error.

范例

Example #1 Different use of imap_open()

<?php
// To connect to an IMAP server running on port 143 on the local machine,
// do the following:
$mbox = imap_open("{localhost:143}INBOX", "user_id", "password");

// To connect to a POP3 server on port 110 on the local server, use:
$mbox = imap_open ("{localhost:110/pop3}INBOX", "user_id", "password");

// To connect to an SSL IMAP or POP3 server, add /ssl after the protocol
// specification:
$mbox = imap_open ("{localhost:993/imap/ssl}INBOX", "user_id", "password");

// To connect to an SSL IMAP or POP3 server with a self-signed certificate,
// add /ssl/novalidate-cert after the protocol specification:
$mbox = imap_open ("{localhost:995/pop3/ssl/novalidate-cert}", "user_id", "password");

// To connect to an NNTP server on port 119 on the local server, use:
$nntp = imap_open ("{localhost:119/nntp}comp.test", "", "");
// To connect to a remote server replace "localhost" with the name or the
// IP address of the server you want to connect to.
?>

Example #2 imap_open() example

<?php
$mbox = imap_open("{imap.example.org:143}", "username", "password");

echo "<h1>Mailboxes</h1>\n";
$folders = imap_listmailbox($mbox, "{imap.example.org:143}", "*");

if ($folders == false) {
    echo "Call failed<br />\n";
} else {
    foreach ($folders as $val) {
        echo $val . "<br />\n";
    }
}

echo "<h1>Headers in INBOX</h1>\n";
$headers = imap_headers($mbox);

if ($headers == false) {
    echo "Call failed<br />\n";
} else {
    foreach ($headers as $val) {
        echo $val . "<br />\n";
    }
}

imap_close($mbox);
?>

参见

  • imap_close() - Close an IMAP stream


Check if the IMAP stream is still active

  • ? imap_open
  • imap_qprint ?
  • PHP Manual
  • IMAP 函数
  • Check if the IMAP stream is still active

imap_ping

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_ping — Check if the IMAP stream is still active

说明

imap_ping ( resource $imap ) : bool

imap_ping() pings the stream to see if it's still active. It may discover new mail; this is the preferred method for a periodic "new mail check" as well as a "keep alive" for servers which have inactivity timeout.

参数

imap

由 imap_open() 返回的 IMAP 流。

返回值

Returns true if the stream is still alive, false otherwise.

范例

Example #1 imap_ping() Example

<?php

$imap = imap_open("{imap.example.org}", "mailadmin", "password");

// after some sleeping
if (!imap_ping($imap)) {
    // do some stuff to reconnect
}

?>


Convert a quoted-printable string to an 8 bit string

  • ? imap_ping
  • imap_rename ?
  • PHP Manual
  • IMAP 函数
  • Convert a quoted-printable string to an 8 bit string

imap_qprint

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_qprint — Convert a quoted-printable string to an 8 bit string

说明

imap_qprint ( string $string ) : string|false

Convert a quoted-printable string to an 8 bit string according to » RFC2045, section 6.7.

参数

string

A quoted-printable string

返回值

Returns an 8 bits string, 或者在失败时返回 false.

参见

  • imap_8bit() - Convert an 8bit string to a quoted-printable string


别名 imap_renamemailbox

  • ? imap_qprint
  • imap_renamemailbox ?
  • PHP Manual
  • IMAP 函数
  • 别名 imap_renamemailbox

imap_rename

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_rename — 别名 imap_renamemailbox()

说明

此函数是该函数的别名： imap_renamemailbox().


Rename an old mailbox to new mailbox

  • ? imap_rename
  • imap_reopen ?
  • PHP Manual
  • IMAP 函数
  • Rename an old mailbox to new mailbox

imap_renamemailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_renamemailbox — Rename an old mailbox to new mailbox

说明

imap_renamemailbox ( resource $imap , string $from , string $to ) : bool

This function renames on old mailbox to new mailbox (see imap_open() for the format of mbox names).

参数

imap

由 imap_open() 返回的 IMAP 流。

from

The old mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

to

The new mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_createmailbox() - Create a new mailbox
  • imap_deletemailbox() - Delete a mailbox


Reopen IMAP stream to new mailbox

  • ? imap_renamemailbox
  • imap_rfc822_parse_adrlist ?
  • PHP Manual
  • IMAP 函数
  • Reopen IMAP stream to new mailbox

imap_reopen

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_reopen — Reopen IMAP stream to new mailbox

说明

imap_reopen ( resource $imap , string $mailbox , int $flags = 0 , int $retries = 0 ) : bool

Reopens the specified stream to a new mailbox on an IMAP or NNTP server.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

flags

The flags are a bit mask with one or more of the following:

  • OP_READONLY - Open mailbox read-only
  • OP_ANONYMOUS - Don't use or update a .newsrc for news (NNTP only)
  • OP_HALFOPEN - For IMAP and NNTP names, open a connection but don't open a mailbox.
  • OP_EXPUNGE - Silently expunge recycle stream
  • CL_EXPUNGE - Expunge mailbox automatically upon mailbox close (see also imap_delete() and imap_expunge())

retries

Number of maximum connect attempts

返回值

Returns true if the stream is reopened, false otherwise.

范例

Example #1 imap_reopen() example

<?php
$mbox = imap_open("{imap.example.org:143}INBOX", "username", "password") or die(implode(", ", imap_errors()));
// ...
imap_reopen($mbox, "{imap.example.org:143}INBOX.Sent") or die(implode(", ", imap_errors()));
// ..
?>


Parses an address string

  • ? imap_reopen
  • imap_rfc822_parse_headers ?
  • PHP Manual
  • IMAP 函数
  • Parses an address string

imap_rfc822_parse_adrlist

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_rfc822_parse_adrlist — Parses an address string

说明

imap_rfc822_parse_adrlist ( string $string , string $default_hostname ) : array

Parses the address string as defined in » RFC2822 and for each address.

参数

string

A string containing addresses

default_hostname

The default host name

返回值

Returns an array of objects. The objects properties are:

  • mailbox - the mailbox name (username)
  • host - the host name
  • personal - the personal name
  • adl - at domain source route

范例

Example #1 imap_rfc822_parse_adrlist() example

<?php

$address_string = "Joe Doe <doe@example.com>, postmaster@example.com, root";
$address_array  = imap_rfc822_parse_adrlist($address_string, "example.com");
if (!is_array($address_array) || count($address_array) < 1) {
    die("something is wrong\n");
}

foreach ($address_array as $id => $val) {
    echo "# $id\n";
    echo "  mailbox : " . $val->mailbox . "\n";
    echo "  host    : " . $val->host . "\n";
    echo "  personal: " . $val->personal . "\n";
    echo "  adl     : " . $val->adl . "\n";
}
?>

以上例程会输出：

# 0
  mailbox : doe
  host    : example.com
  personal: Joe Doe
  adl     :
# 1
  mailbox : postmaster
  host    : example.com
  personal:
  adl     :
# 2
  mailbox : root
  host    : example.com
  personal:
  adl     :

参见

  • imap_rfc822_parse_headers() - Parse mail headers from a string


Parse mail headers from a string

  • ? imap_rfc822_parse_adrlist
  • imap_rfc822_write_address ?
  • PHP Manual
  • IMAP 函数
  • Parse mail headers from a string

imap_rfc822_parse_headers

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_rfc822_parse_headers — Parse mail headers from a string

说明

imap_rfc822_parse_headers ( string $headers , string $default_hostname = "UNKNOWN" ) : stdClass

Gets an object of various header elements, similar to imap_header().

参数

headers

The parsed headers data

default_hostname

The default host name

返回值

Returns an object similar to the one returned by imap_header(), except for the flags and other properties that come from the IMAP server.

参见

  • imap_rfc822_parse_adrlist() - Parses an address string


Returns a properly formatted email address given the mailbox, host, and personal info

  • ? imap_rfc822_parse_headers
  • imap_savebody ?
  • PHP Manual
  • IMAP 函数
  • Returns a properly formatted email address given the mailbox, host, and personal info

imap_rfc822_write_address

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_rfc822_write_address — Returns a properly formatted email address given the mailbox, host, and personal info

说明

imap_rfc822_write_address ( string $mailbox , string $hostname , string $personal ) : string|false

Returns a properly formatted email address as defined in » RFC2822 given the needed information.

参数

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

hostname

The email host part

personal

The name of the account owner

返回值

Returns a string properly formatted email address as defined in » RFC2822, 或者在失败时返回 false.

范例

Example #1 imap_rfc822_write_address() example

<?php
echo imap_rfc822_write_address("hartmut", "example.com", "Hartmut Holzgraefe");
?>

以上例程会输出：

Hartmut Holzgraefe <hartmut@example.com>


Save a specific body section to a file

  • ? imap_rfc822_write_address
  • imap_scan ?
  • PHP Manual
  • IMAP 函数
  • Save a specific body section to a file

imap_savebody

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

imap_savebody — Save a specific body section to a file

说明

imap_savebody ( resource $imap , resource|string|int $file , int $message_num , string $section = "" , int $flags = 0 ) : bool

Saves a part or the whole body of the specified message.

参数

imap

由 imap_open() 返回的 IMAP 流。

file

The path to the saved file as a string, or a valid file descriptor returned by fopen().

message_num

The message number

section

The part number. It is a string of integers delimited by period which index into a body part list as per the IMAP4 specification

flags

A bitmask with one or more of the following:

  • FT_UID - The message_num is a UID
  • FT_PEEK - Do not set the \Seen flag if not already set
  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_fetchbody() - Fetch a particular section of the body of the message


别名 imap_listscan

  • ? imap_savebody
  • imap_scanmailbox ?
  • PHP Manual
  • IMAP 函数
  • 别名 imap_listscan

imap_scan

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_scan — 别名 imap_listscan()

说明

此函数是该函数的别名： imap_listscan().


别名 imap_listscan

  • ? imap_scan
  • imap_search ?
  • PHP Manual
  • IMAP 函数
  • 别名 imap_listscan

imap_scanmailbox

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_scanmailbox — 别名 imap_listscan()

说明

此函数是该函数的别名： imap_listscan().


This function returns an array of messages matching the given search criteria

  • ? imap_scanmailbox
  • imap_set_quota ?
  • PHP Manual
  • IMAP 函数
  • This function returns an array of messages matching the given search criteria

imap_search

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_search — This function returns an array of messages matching the given search criteria

说明

imap_search ( resource $imap , string $criteria , int $flags = SE_FREE , string $charset = "" ) : array|false

This function performs a search on the mailbox currently opened in the given IMAP stream.

For example, to match all unanswered messages sent by Mom, you'd use: "UNANSWERED FROM mom". Searches appear to be case insensitive. This list of criteria is from a reading of the UW c-client source code and may be incomplete or inaccurate (see also » RFC1176, section "tag SEARCH search_criteria").

参数

imap

由 imap_open() 返回的 IMAP 流。

criteria

A string, delimited by spaces, in which the following keywords are allowed. Any multi-word arguments (e.g. FROM "joey smith") must be quoted. Results will match all criteria entries.

  • ALL - return all messages matching the rest of the criteria
  • ANSWERED - match messages with the \\ANSWERED flag set
  • BCC "string" - match messages with "string" in the Bcc: field
  • BEFORE "date" - match messages with Date: before "date"
  • BODY "string" - match messages with "string" in the body of the message
  • CC "string" - match messages with "string" in the Cc: field
  • DELETED - match deleted messages
  • FLAGGED - match messages with the \\FLAGGED (sometimes referred to as Important or Urgent) flag set
  • FROM "string" - match messages with "string" in the From: field
  • KEYWORD "string" - match messages with "string" as a keyword
  • NEW - match new messages
  • OLD - match old messages
  • ON "date" - match messages with Date: matching "date"
  • RECENT - match messages with the \\RECENT flag set
  • SEEN - match messages that have been read (the \\SEEN flag is set)
  • SINCE "date" - match messages with Date: after "date"
  • SUBJECT "string" - match messages with "string" in the Subject:
  • TEXT "string" - match messages with text "string"
  • TO "string" - match messages with "string" in the To:
  • UNANSWERED - match messages that have not been answered
  • UNDELETED - match messages that are not deleted
  • UNFLAGGED - match messages that are not flagged
  • UNKEYWORD "string" - match messages that do not have the keyword "string"
  • UNSEEN - match messages which have not been read yet

flags

Valid values for flags are SE_UID, which causes the returned array to contain UIDs instead of messages sequence numbers.

charset

MIME character set to use when searching strings.

返回值

Returns an array of message numbers or UIDs.

Return false if it does not understand the search criteria or no messages have been found.

范例

Example #1 imap_search() example

<?php
$conn   = imap_open('{imap.example.com:993/imap/ssl}INBOX', 'foo@example.com', 'pass123', OP_READONLY);

$some   = imap_search($conn, 'SUBJECT "HOWTO be Awesome" SINCE "8 August 2008"', SE_UID);
$msgnos = imap_search($conn, 'ALL');
$uids   = imap_search($conn, 'ALL', SE_UID);

print_r($some);
print_r($msgnos);
print_r($uids);
?>

以上例程的输出类似于：

Array
(
    [0] => 4
    [1] => 6
    [2] => 11
)
Array
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
    [5] => 6
)
Array
(
    [0] => 1
    [1] => 4
    [2] => 6
    [3] => 8
    [4] => 11
    [5] => 12
)

参见

  • imap_listscan() - Returns the list of mailboxes that matches the given text


Sets a quota for a given mailbox

  • ? imap_search
  • imap_setacl ?
  • PHP Manual
  • IMAP 函数
  • Sets a quota for a given mailbox

imap_set_quota

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

imap_set_quota — Sets a quota for a given mailbox

说明

imap_set_quota ( resource $imap , string $quota_root , int $mailbox_size ) : bool

Sets an upper limit quota on a per mailbox basis.

参数

imap

由 imap_open() 返回的 IMAP 流。

quota_root

The mailbox to have a quota set. This should follow the IMAP standard format for a mailbox: user.name.

mailbox_size

The maximum size (in KB) for the quota_root

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imap_set_quota() example

<?php
$mbox = imap_open("{imap.example.org:143}", "mailadmin", "password");

if (!imap_set_quota($mbox, "user.kalowsky", 3000)) {
    echo "Error in setting quota\n";
    return;
}

imap_close($mbox);
?>

注释

This function is currently only available to users of the c-client2000 or greater library.

The given imap must be opened as the mail administrator, other wise this function will fail.

参见

  • imap_open() - Open an IMAP stream to a mailbox
  • imap_get_quota() - Retrieve the quota level settings, and usage statics per mailbox


Sets the ACL for a given mailbox

  • ? imap_set_quota
  • imap_setflag_full ?
  • PHP Manual
  • IMAP 函数
  • Sets the ACL for a given mailbox

imap_setacl

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imap_setacl — Sets the ACL for a given mailbox

说明

imap_setacl ( resource $imap , string $mailbox , string $user_id , string $rights ) : bool

Sets the ACL for a giving mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

user_id

The user to give the rights to.

rights

The rights to give to the user. Passing an empty string will delete acl.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

This function is currently only available to users of the c-client2000 or greater library.

参见

  • imap_getacl() - Gets the ACL for a given mailbox


Sets flags on messages

  • ? imap_setacl
  • imap_sort ?
  • PHP Manual
  • IMAP 函数
  • Sets flags on messages

imap_setflag_full

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_setflag_full — Sets flags on messages

说明

imap_setflag_full ( resource $imap , string $sequence , string $flag , int $options = 0 ) : bool

Causes a store to add the specified flag to the flags set for the messages in the specified sequence.

参数

imap

由 imap_open() 返回的 IMAP 流。

sequence

A sequence of message numbers. You can enumerate desired messages with the X,Y syntax, or retrieve all messages within an interval with the X:Y syntax

flag

The flags which you can set are \Seen, \Answered, \Flagged, \Deleted, and \Draft as defined by » RFC2060.

options

A bit mask that may contain the single option:

  • ST_UID - The sequence argument contains UIDs instead of sequence numbers

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 imap_setflag_full() example

<?php
$mbox = imap_open("{imap.example.org:143}", "username", "password")
     or die("can't connect: " . imap_last_error());

$status = imap_setflag_full($mbox, "2,5", "\\Seen \\Flagged");

echo gettype($status) . "\n";
echo $status . "\n";

imap_close($mbox);
?>

参见

  • imap_clearflag_full() - Clears flags on messages


Gets and sort messages

  • ? imap_setflag_full
  • imap_status ?
  • PHP Manual
  • IMAP 函数
  • Gets and sort messages

imap_sort

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_sort — Gets and sort messages

说明

imap_sort ( resource $imap , int $criteria , bool $reverse , int $flags = 0 , string|null $search_criteria = null , string|null $charset = null ) : array|false

Gets and sorts message numbers by the given parameters.

参数

imap

由 imap_open() 返回的 IMAP 流。

criteria

Criteria can be one (and only one) of the following:

  • SORTDATE - message Date
  • SORTARRIVAL - arrival date
  • SORTFROM - mailbox in first From address
  • SORTSUBJECT - message subject
  • SORTTO - mailbox in first To address
  • SORTCC - mailbox in first cc address
  • SORTSIZE - size of message in octets

reverse

Whether to sort in reverse order.

flags

The flags are a bitmask of one or more of the following:

  • SE_UID - Return UIDs instead of sequence numbers
  • SE_NOPREFETCH - Don't prefetch searched messages

search_criteria

IMAP2-format search criteria string. For details see imap_search().

charset

MIME character set to use when sorting strings.

返回值

Returns an array of message numbers sorted by the given parameters, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | reverse is now bool instead of int.
8.0.0 | search_criteria and charset are now nullable.


Returns status information on a mailbox

  • ? imap_sort
  • imap_subscribe ?
  • PHP Manual
  • IMAP 函数
  • Returns status information on a mailbox

imap_status

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_status — Returns status information on a mailbox

说明

imap_status ( resource $imap , string $mailbox , int $flags ) : stdClass|false

Gets status information about the given mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

flags

Valid flags are:

  • SA_MESSAGES - set $status->messages to the number of messages in the mailbox
  • SA_RECENT - set $status->recent to the number of recent messages in the mailbox
  • SA_UNSEEN - set $status->unseen to the number of unseen (new) messages in the mailbox
  • SA_UIDNEXT - set $status->uidnext to the next uid to be used in the mailbox
  • SA_UIDVALIDITY - set $status->uidvalidity to a constant that changes when uids for the mailbox may no longer be valid
  • SA_ALL - set all of the above

返回值

This function returns an object containing status information, 或者在失败时返回 false. The object has the following properties: messages, recent, unseen, uidnext, and uidvalidity.

flags is also set, which contains a bitmask which can be checked against any of the above constants.

范例

Example #1 imap_status() example

<?php
$mbox = imap_open("{imap.example.com}", "username", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$status = imap_status($mbox, "{imap.example.org}INBOX", SA_ALL);
if ($status) {
  echo "Messages:   " . $status->messages    . "<br />\n";
  echo "Recent:     " . $status->recent      . "<br />\n";
  echo "Unseen:     " . $status->unseen      . "<br />\n";
  echo "UIDnext:    " . $status->uidnext     . "<br />\n";
  echo "UIDvalidity:" . $status->uidvalidity . "<br />\n";
} else {
  echo "imap_status failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>


Subscribe to a mailbox

  • ? imap_status
  • imap_thread ?
  • PHP Manual
  • IMAP 函数
  • Subscribe to a mailbox

imap_subscribe

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_subscribe — Subscribe to a mailbox

说明

imap_subscribe ( resource $imap , string $mailbox ) : bool

Subscribe to a new mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_unsubscribe() - Unsubscribe from a mailbox


Returns a tree of threaded message

  • ? imap_subscribe
  • imap_timeout ?
  • PHP Manual
  • IMAP 函数
  • Returns a tree of threaded message

imap_thread

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

imap_thread — Returns a tree of threaded message

说明

imap_thread ( resource $imap , int $flags = SE_FREE ) : array|false

Gets a tree of a threaded message.

参数

imap

由 imap_open() 返回的 IMAP 流。

flags

返回值

imap_thread() returns an associative array containing a tree of messages threaded by REFERENCES, or false on error.

Every message in the current mailbox will be represented by three entries in the resulting array:

  • $thread["XX.num"] - current message number

  • $thread["XX.next"]

  • $thread["XX.branch"]

范例

Example #1 imap_thread() Example

<?php

// Here we're outputting the threads of a newsgroup, in HTML

$nntp = imap_open('{news.example.com:119/nntp}some.newsgroup', '', '');
$threads = imap_thread($nntp);

foreach ($threads as $key => $val) {
  $tree = explode('.', $key);
  if ($tree[1] == 'num') {
    $header = imap_headerinfo($nntp, $val);
    echo "<ul>\n\t<li>" . $header->fromaddress . "\n";
  } elseif ($tree[1] == 'branch') {
    echo "\t</li>\n</ul>\n";
  }
}

imap_close($nntp);

?>


Set or fetch imap timeout

  • ? imap_thread
  • imap_uid ?
  • PHP Manual
  • IMAP 函数
  • Set or fetch imap timeout

imap_timeout

(PHP 4 >= 4.3.3, PHP 5, PHP 7, PHP 8)

imap_timeout — Set or fetch imap timeout

说明

imap_timeout ( int $timeout_type , int $timeout = -1 ) : int|bool

Sets or fetches the imap timeout.

参数

timeout_type

One of the following: IMAP_OPENTIMEOUT, IMAP_READTIMEOUT, IMAP_WRITETIMEOUT, or IMAP_CLOSETIMEOUT.

timeout

The timeout, in seconds.

返回值

If the timeout parameter is set, this function returns true on success and false on failure.

If timeout is not provided or evaluates to -1, the current timeout value of timeout_type is returned as an integer.

范例

Example #1 imap_timeout() example

<?php

echo "The current read timeout is " . imap_timeout(IMAP_READTIMEOUT) . "\n";

?>


This function returns the UID for the given message sequence number

  • ? imap_timeout
  • imap_undelete ?
  • PHP Manual
  • IMAP 函数
  • This function returns the UID for the given message sequence number

imap_uid

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_uid — This function returns the UID for the given message sequence number

说明

imap_uid ( resource $imap , int $message_num ) : int|false

This function returns the UID for the given message sequence number. An UID is a unique identifier that will not change over time while a message sequence number may change whenever the content of the mailbox changes.

This function is the inverse of imap_msgno().

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number.

返回值

The UID of the given message.

注释

Note:

This function is not supported by POP3 mailboxes.

参见

  • imap_msgno() - Gets the message sequence number for the given UID


Unmark the message which is marked deleted

  • ? imap_uid
  • imap_unsubscribe ?
  • PHP Manual
  • IMAP 函数
  • Unmark the message which is marked deleted

imap_undelete

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_undelete — Unmark the message which is marked deleted

说明

imap_undelete ( resource $imap , string $message_num , int $flags = 0 ) : bool

Removes the deletion flag for a specified message, which is set by imap_delete() or imap_mail_move().

参数

imap

由 imap_open() 返回的 IMAP 流。

message_num

The message number

flags

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_delete() - Mark a message for deletion from current mailbox
  • imap_mail_move() - Move specified messages to a mailbox


Unsubscribe from a mailbox

  • ? imap_undelete
  • imap_utf7_decode ?
  • PHP Manual
  • IMAP 函数
  • Unsubscribe from a mailbox

imap_unsubscribe

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_unsubscribe — Unsubscribe from a mailbox

说明

imap_unsubscribe ( resource $imap , string $mailbox ) : bool

Unsubscribe from the specified mailbox.

参数

imap

由 imap_open() 返回的 IMAP 流。

mailbox

The mailbox name, see imap_open() for more information

Warning

Passing untrusted data to this parameter is insecure, unless imap.enable_insecure_rsh is disabled.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • imap_subscribe() - Subscribe to a mailbox


Decodes a modified UTF-7 encoded string

  • ? imap_unsubscribe
  • imap_utf7_encode ?
  • PHP Manual
  • IMAP 函数
  • Decodes a modified UTF-7 encoded string

imap_utf7_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_utf7_decode — Decodes a modified UTF-7 encoded string

说明

imap_utf7_decode ( string $string ) : string|false

Decodes modified UTF-7 string into ISO-8859-1 string.

This function is needed to decode mailbox names that contain certain characters which are not in range of printable ASCII characters.

参数

string

A modified UTF-7 encoding string, as defined in » RFC 2060, section 5.1.3.

返回值

Returns a string that is encoded in ISO-8859-1 and consists of the same sequence of characters in string, or false if string contains invalid modified UTF-7 sequence or string contains a character that is not part of ISO-8859-1 character set.

参见

  • imap_utf7_encode() - Converts ISO-8859-1 string to modified UTF-7 text


Converts ISO-8859-1 string to modified UTF-7 text

  • ? imap_utf7_decode
  • imap_utf8_to_mutf7 ?
  • PHP Manual
  • IMAP 函数
  • Converts ISO-8859-1 string to modified UTF-7 text

imap_utf7_encode

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_utf7_encode — Converts ISO-8859-1 string to modified UTF-7 text

说明

imap_utf7_encode ( string $string ) : string

Converts string to modified UTF-7 text.

This is needed to encode mailbox names that contain certain characters which are not in range of printable ASCII characters.

参数

string

An ISO-8859-1 string.

返回值

Returns string encoded with the modified UTF-7 encoding as defined in » RFC 2060, section 5.1.3.

参见

  • imap_utf7_decode() - Decodes a modified UTF-7 encoded string


Encode a UTF-8 string to modified UTF-7

  • ? imap_utf7_encode
  • imap_utf8 ?
  • PHP Manual
  • IMAP 函数
  • Encode a UTF-8 string to modified UTF-7

imap_utf8_to_mutf7

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

imap_utf8_to_mutf7 — Encode a UTF-8 string to modified UTF-7

说明

imap_utf8_to_mutf7 ( string $string ) : string|false

Encode a UTF-8 string to modified UTF-7 (as specified in RFC 2060, section 5.1.3).

Note:

This function is only available, if libcclient exports utf8_to_mutf7().

参数

string

A UTF-8 encoded string.

返回值

Returns string converted to modified UTF-7, 或者在失败时返回 false.

参见

  • imap_mutf7_to_utf8() - Decode a modified UTF-7 string to UTF-8


Converts MIME-encoded text to UTF-8

  • ? imap_utf8_to_mutf7
  • Mail ?
  • PHP Manual
  • IMAP 函数
  • Converts MIME-encoded text to UTF-8

imap_utf8

(PHP 4, PHP 5, PHP 7, PHP 8)

imap_utf8 — Converts MIME-encoded text to UTF-8

说明

imap_utf8 ( string $mime_encoded_text ) : string

Converts the given mime_encoded_text to UTF-8, if the declared charset is known to libc-client. Otherwise the given text is decoded, but not converted to UTF-8.

参数

mime_encoded_text

A MIME encoded string. MIME encoding method and the UTF-8 specification are described in » RFC2047 and » RFC2044 respectively.

返回值

Returns the decoded string, if possible converted to UTF-8.

范例

Example #1 Basic imap_utf8() Usage

<?php
echo imap_utf8("Johannes =?ISO-8859-1?Q?Schl=FCter?=");
?>

以上例程的输出类似于：

Johannes Schlu?ter

参见

  • imap_mime_header_decode() - Decode MIME header elements


Mail

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Mail 函数
    • ezmlm_hash — 计算 EZMLM 所需的散列值
    • mail — 发送邮件


  • ? Mail
  • 安装／配置 ?
  • PHP Manual
  • Mail
  • 简介

简介

mail() 函数可以让你发送邮件。


需求

为了使右键函数正常运行，PHP 必须在编译时访问你系统里的 sendmail 可执行文件。 如果你使用了其他邮件程序，例如 qmail 或者 postfix，请确保它们使用了与 sendmail 适配的包装器。 PHP 首先会在你的 PATH 变量里查找 sendmail，然后在下面的路径里查找： /usr/bin:/usr/sbin:/usr/etc:/etc:/usr/ucblib:/usr/lib。 强烈建议 sendmail 在您的 PATH 变量里。并且，运行编译后PHP程序的用户也必须有执行 sendmail 的权限。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Mail 配置选项
名字 | 默认 | 可修改范围 | 更新日志
mail.add_x_header | "0" | PHP_INI_PERDIR | 自 PHP 5.3.0 起生效
mail.log | NULL | PHP_INI_PERDIR | 自 PHP 5.3.0 起生效
SMTP | "localhost" | PHP_INI_ALL |
smtp_port | "25" | PHP_INI_ALL | 自 PHP 4.3.0 起可用
sendmail_from | NULL | PHP_INI_ALL |
sendmail_path | NULL | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

mail.add_x_header bool

Add X-PHP-Originating-Script that will include UID of the script followed by the filename.

mail.log string

The path to a log file that will log all mail() calls. Log entries include the full path of the script, line number, To address and headers.

SMTP string

仅用于 Windows：PHP 在 mail() 函数中用来发送邮件的 SMTP 服务器的主机名称或者 IP 地址。

smtp_port int

仅用于 Windows：SMTP 服务器的端口号，默认为 25。自 PHP 4.3.0 起可用。

sendmail_from string

在 Windows 下用 PHP 发送邮件时的"From:"邮件地址的值。该选项同时设置了 "Return-Path:"头。

sendmail_path string

sendmail 程序的路径，通常为 /usr/sbin/sendmail 或 /usr/lib/sendmail。configure 脚本会尝试找到该程序并设定为默认值，但是如果失败的话，可以在这里设定。

不使用 sendmail 的系统应将此指令设定为其邮件系统提供的 sendmail 替代程序，如果有的话。例如，» Qmail 用户通常可以设为 /var/qmail/bin/sendmail 或 /var/qmail/bin/qmail-inject。

qmail-inject 不需要任何选项就能正确处理邮件。

此指令也可用于 Windows。如果设定，smtp，smtp_port 和 sendmail_from 都被忽略并运行指定的命令。


  • ? 资源类型
  • Mail 函数 ?
  • PHP Manual
  • Mail
  • 预定义常量

预定义常量

此扩展没有定义常量。


Mail 函数

Table of Contents

  • ezmlm_hash — 计算 EZMLM 所需的散列值
  • mail — 发送邮件


计算 EZMLM 所需的散列值

  • ? Mail 函数
  • mail ?
  • PHP Manual
  • Mail 函数
  • 计算 EZMLM 所需的散列值

ezmlm_hash

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

ezmlm_hash — 计算 EZMLM 所需的散列值

Warning

This function has been DEPRECATED as of PHP 7.4.0, and REMOVED as of PHP 8.0.0. Relying on this function is highly discouraged.

说明

ezmlm_hash ( string $addr ) : int

ezmlm_hash() 计算用于在 MySQL 数据库中保存 EZMLM 邮件列表的散列值。

参数

addr

要进行散列算法的电子邮件地址。

返回值

addr 的散列值。

范例

Example #1 计算散列值并订阅一个用户

<?php

$user = "joecool@example.com";
$hash = ezmlm_hash($user);
$query = sprintf("INSERT INTO sample VALUES (%s, '%s')", $hash, $user);
$db->query($query); // using PHPLIB db interface

?>


发送邮件

  • ? ezmlm_hash
  • Mailparse ?
  • PHP Manual
  • Mail 函数
  • 发送邮件

mail

(PHP 4, PHP 5, PHP 7, PHP 8)

mail — 发送邮件

说明

mail ( string $to , string $subject , string $message , string $additional_headers = ? , string $additional_parameters = ? ) : bool

发送一封电子邮件。

参数

to

电子邮件收件人，或收件人列表。

本字符串的格式必须符合 » RFC 2822。例如：

  • user@example.com
  • user@example.com, anotheruser@example.com
  • User <user@example.com>
  • User <user@example.com>, Another User <anotheruser@example.com>

subject

电子邮件的主题。

Caution

本项不能包含任何换行符，否则邮件可能无法正确发送。

message

所要发送的消息。

行之间必须以一个 LF（\n）分隔。每行不能超过 70 个字符。

Caution

（Windows 下）当 PHP 直接连接到 SMTP 服务器时，如果在一行开头发现一个句号，则会被删掉。要避免此问题，将单个句号替换成两个句号。

<?php
$text = str_replace("\n.", "\n..", $text);
?>

additional_headers（可选项）

String to be inserted at the end of the email header.

This is typically used to add extra headers (From, Cc, and Bcc). Multiple extra headers should be separated with a CRLF (\r\n).

Note:

When sending mail, the mail must contain a From header. This can be set with the additional_headers parameter, or a default can be set in php.ini.

Failing to do this will result in an error message similar to Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing.

Note:

If messages are not received, try using a LF (\n) only. Some poor quality Unix mail transfer agents replace LF by CRLF automatically (which leads to doubling CR if CRLF is used). This should be a last resort, as it does not comply with » RFC 2822.

additional_parameters (optional)

The additional_parameters parameter can be used to pass an additional parameter to the program configured to use when sending mail using the sendmail_path configuration setting. For example, this can be used to set the envelope sender address when using sendmail with the -f sendmail option.

The user that the webserver runs as should be added as a trusted user to the sendmail configuration to prevent a 'X-Warning' header from being added to the message when the envelope sender (-f) is set using this method. For sendmail users, this file is /etc/mail/trusted-users.

返回值

Returns true if the mail was successfully accepted for delivery, false otherwise.

It is important to note that just because the mail was accepted for delivery, it does NOT mean the mail will actually reach the intended destination.

更新日志

版本 | 说明
7.2.0 | 现在 additional_headers 参数开始支持 array。

范例

Example #1 Sending mail.

Using mail() to send a simple email:

<?php
// The message
$message = "Line 1\nLine 2\nLine 3";

// In case any of our lines are larger than 70 characters, we should use wordwrap()
$message = wordwrap($message, 70);

// Send
mail('caffinated@example.com', 'My Subject', $message);
?>

Example #2 Sending mail with extra headers.

The addition of basic headers, telling the MUA the From and Reply-To addresses:

<?php
$to      = 'nobody@example.com';
$subject = 'the subject';
$message = 'hello';
$headers = 'From: webmaster@example.com' . "\r\n" .
    'Reply-To: webmaster@example.com' . "\r\n" .
    'X-Mailer: PHP/' . phpversion();

mail($to, $subject, $message, $headers);
?>

Example #3 Sending mail with an additional command line parameter.

The additional_parameters parameter can be used to pass an additional parameter to the program configured to use when sending mail using the sendmail_path.

<?php
mail('nobody@example.com', 'the subject', 'the message', null,
   '-fwebmaster@example.com');
?>

Example #4 Sending HTML email

It is also possible to send HTML email with mail().

<?php
// multiple recipients
$to  = 'aidan@example.com' . ', '; // note the comma
$to .= 'wez@example.com';

// subject
$subject = 'Birthday Reminders for August';

// message
$message = '
<html>
<head>
  <title>Birthday Reminders for August</title>
</head>
<body>
  <p>Here are the birthdays upcoming in August!</p>
  <table>
    <tr>
      <th>Person</th><th>Day</th><th>Month</th><th>Year</th>
    </tr>
    <tr>
      <td>Joe</td><td>3rd</td><td>August</td><td>1970</td>
    </tr>
    <tr>
      <td>Sally</td><td>17th</td><td>August</td><td>1973</td>
    </tr>
  </table>
</body>
</html>
';

// To send HTML mail, the Content-type header must be set
$headers  = 'MIME-Version: 1.0' . "\r\n";
$headers .= 'Content-type: text/html; charset=iso-8859-1' . "\r\n";

// Additional headers
$headers .= 'To: Mary <mary@example.com>, Kelly <kelly@example.com>' . "\r\n";
$headers .= 'From: Birthday Reminder <birthday@example.com>' . "\r\n";
$headers .= 'Cc: birthdayarchive@example.com' . "\r\n";
$headers .= 'Bcc: birthdaycheck@example.com' . "\r\n";

// Mail it
mail($to, $subject, $message, $headers);
?>

Note:

If intending to send HTML or otherwise Complex mails, it is recommended to use the PEAR package » PEAR::Mail.

注释

Note:

The Windows implementation of mail() differs in many ways from the Unix implementation. First, it doesn't use a local binary for composing messages but only operates on direct sockets which means a MTA is needed listening on a network socket (which can either on the localhost or a remote machine).

Second, the custom headers like From:, Cc:, Bcc: and Date: are not interpreted by the MTA in the first place, but are parsed by PHP.

As such, the to parameter should not be an address in the form of "Something <someone@example.com>". The mail command may not parse this properly while talking with the MTA.

Note:

It is worth noting that the mail() function is not suitable for larger volumes of email in a loop. This function opens and closes an SMTP socket for each email, which is not very efficient.

For the sending of large amounts of email, see the » PEAR::Mail, and » PEAR::Mail_Queue packages.

Note:

The following RFCs may be useful: » RFC 1896, » RFC 2045, » RFC 2046, » RFC 2047, » RFC 2048, » RFC 2049, and » RFC 2822.

参见

  • imap_mail() - Send an email message
  • » PEAR::Mail
  • » PEAR::Mail_Mime


Mailparse

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Mailparse 函数
    • mailparse_determine_best_xfer_encoding — Gets the best way of encoding
    • mailparse_msg_create — Create a mime mail resource
    • mailparse_msg_extract_part_file — Extracts/decodes a message section
    • mailparse_msg_extract_part — Extracts/decodes a message section
    • mailparse_msg_extract_whole_part_file — Extracts a message section including headers without decoding the transfer encoding
    • mailparse_msg_free — Frees a MIME resource
    • mailparse_msg_get_part_data — Returns an associative array of info about the message
    • mailparse_msg_get_part — Returns a handle on a given section in a mimemessage
    • mailparse_msg_get_structure — Returns an array of mime section names in the supplied message
    • mailparse_msg_parse_file — Parses a file
    • mailparse_msg_parse — Incrementally parse data into buffer
    • mailparse_rfc822_parse_addresses — Parse RFC 822 compliant addresses
    • mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp
    • mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file


简介

Mailparse is an extension for parsing and working with email messages. It can deal with » RFC 822 and » RFC 2045 (MIME) compliant messages.

Mailparse is stream based, which means that it does not keep in-memory copies of the files it processes - so it is very resource efficient when dealing with large messages.

Note:

Mailparse requires the mbstring extension, and mbstring must be loaded before mailparse.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Mailparse
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

此 » PECL 扩展未与 PHP 捆绑。 安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mailparse.

In order to use these functions you must compile PHP with mailparse support by using the --enable-mailparse configure option.

Windows users will enable php_mailparse.dll inside of php.ini in order to use these functions. 此扩展在 Windows 平台的二进制扩展 (DLL 文件) PECL 可以在 PECL 官方网站上下载。

It is necessary that the mbstring extension is loaded before mailparse.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

MAILPARSE_EXTRACT_OUTPUT (int)
MAILPARSE_EXTRACT_STREAM (int)
MAILPARSE_EXTRACT_RETURN (int)


Mailparse 函数

Table of Contents

  • mailparse_determine_best_xfer_encoding — Gets the best way of encoding
  • mailparse_msg_create — Create a mime mail resource
  • mailparse_msg_extract_part_file — Extracts/decodes a message section
  • mailparse_msg_extract_part — Extracts/decodes a message section
  • mailparse_msg_extract_whole_part_file — Extracts a message section including headers without decoding the transfer encoding
  • mailparse_msg_free — Frees a MIME resource
  • mailparse_msg_get_part_data — Returns an associative array of info about the message
  • mailparse_msg_get_part — Returns a handle on a given section in a mimemessage
  • mailparse_msg_get_structure — Returns an array of mime section names in the supplied message
  • mailparse_msg_parse_file — Parses a file
  • mailparse_msg_parse — Incrementally parse data into buffer
  • mailparse_rfc822_parse_addresses — Parse RFC 822 compliant addresses
  • mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp
  • mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file


Gets the best way of encoding

  • ? Mailparse 函数
  • mailparse_msg_create ?
  • PHP Manual
  • Mailparse 函数
  • Gets the best way of encoding

mailparse_determine_best_xfer_encoding

(PECL mailparse >= 0.9.0)

mailparse_determine_best_xfer_encoding — Gets the best way of encoding

说明

mailparse_determine_best_xfer_encoding ( resource $fp ) : string

Figures out the best way of encoding the content read from the given file pointer.

参数

fp

A valid file pointer, which must be seek-able.

返回值

Returns one of the character encodings supported by the mbstring module.

范例

Example #1 mailparse_determine_best_xfer_encoding() example

<?php

$fp = fopen('somemail.eml', 'r');
echo 'Best encoding: ' . mailparse_determine_best_xfer_encoding($fp);

?>

以上例程的输出类似于：

Best encoding: 7bit


Create a mime mail resource

  • ? mailparse_determine_best_xfer_encoding
  • mailparse_msg_extract_part_file ?
  • PHP Manual
  • Mailparse 函数
  • Create a mime mail resource

mailparse_msg_create

(PECL mailparse >= 0.9.0)

mailparse_msg_create — Create a mime mail resource

说明

mailparse_msg_create ( ) : resource

Create a MIME mail resource.

返回值

Returns a handle that can be used to parse a message.

参见

  • mailparse_msg_free() - Frees a MIME resource
  • mailparse_msg_parse_file() - Parses a file


Extracts/decodes a message section

  • ? mailparse_msg_create
  • mailparse_msg_extract_part ?
  • PHP Manual
  • Mailparse 函数
  • Extracts/decodes a message section

mailparse_msg_extract_part_file

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_part_file — Extracts/decodes a message section

说明

mailparse_msg_extract_part_file ( resource $mimemail , mixed $filename , callable $callbackfunc = ? ) : string

Extracts/decodes a message section from the supplied filename.

The contents of the section will be decoded according to their transfer encoding - base64, quoted-printable and uuencoded text are supported.

参数

mimemail

A valid MIME resource, created with mailparse_msg_create().

filename

Can be a file name or a valid stream resource.

callbackfunc

If set, this must be either a valid callback that will be passed the extracted section, or null to make this function return the extracted section.

If not specified, the contents will be sent to "stdout".

返回值

If callbackfunc is not null returns true on success.

If callbackfunc is set to null, returns the extracted section as a string.

Returns false on error.

参见

  • mailparse_msg_extract_part() - Extracts/decodes a message section
  • mailparse_msg_extract_whole_part_file() - Extracts a message section including headers without decoding the transfer encoding


Extracts/decodes a message section

  • ? mailparse_msg_extract_part_file
  • mailparse_msg_extract_whole_part_file ?
  • PHP Manual
  • Mailparse 函数
  • Extracts/decodes a message section

mailparse_msg_extract_part

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_part — Extracts/decodes a message section

说明

mailparse_msg_extract_part ( resource $mimemail , string $msgbody , callable $callbackfunc = ? ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

mimemail

A valid MIME resource.

msgbody

callbackfunc

返回值

没有返回值。

参见

  • mailparse_msg_extract_part_file() - Extracts/decodes a message section
  • mailparse_msg_extract_whole_part_file() - Extracts a message section including headers without decoding the transfer encoding


Extracts a message section including headers without decoding the transfer encoding

  • ? mailparse_msg_extract_part
  • mailparse_msg_free ?
  • PHP Manual
  • Mailparse 函数
  • Extracts a message section including headers without decoding the transfer encoding

mailparse_msg_extract_whole_part_file

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_whole_part_file — Extracts a message section including headers without decoding the transfer encoding

说明

mailparse_msg_extract_whole_part_file ( resource $mimemail , string $filename , callable $callbackfunc = ? ) : string
Warning

本函数还未编写文档，仅有参数列表。

参数

mimemail

A valid MIME resource.

filename

callbackfunc

返回值

参见

  • mailparse_msg_extract_part() - Extracts/decodes a message section
  • mailparse_msg_extract_part_file() - Extracts/decodes a message section


Frees a MIME resource

  • ? mailparse_msg_extract_whole_part_file
  • mailparse_msg_get_part_data ?
  • PHP Manual
  • Mailparse 函数
  • Frees a MIME resource

mailparse_msg_free

(PECL mailparse >= 0.9.0)

mailparse_msg_free — Frees a MIME resource

说明

mailparse_msg_free ( resource $mimemail ) : bool

Frees a MIME resource.

参数

mimemail

A valid MIME resource allocated by mailparse_msg_create() or mailparse_msg_parse_file().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • mailparse_msg_create() - Create a mime mail resource
  • mailparse_msg_parse_file() - Parses a file


Returns an associative array of info about the message

  • ? mailparse_msg_free
  • mailparse_msg_get_part ?
  • PHP Manual
  • Mailparse 函数
  • Returns an associative array of info about the message

mailparse_msg_get_part_data

(PECL mailparse >= 0.9.0)

mailparse_msg_get_part_data — Returns an associative array of info about the message

说明

mailparse_msg_get_part_data ( resource $mimemail ) : array
Warning

本函数还未编写文档，仅有参数列表。

参数

mimemail

A valid MIME resource.


Returns a handle on a given section in a mimemessage

  • ? mailparse_msg_get_part_data
  • mailparse_msg_get_structure ?
  • PHP Manual
  • Mailparse 函数
  • Returns a handle on a given section in a mimemessage

mailparse_msg_get_part

(PECL mailparse >= 0.9.0)

mailparse_msg_get_part — Returns a handle on a given section in a mimemessage

说明

mailparse_msg_get_part ( resource $mimemail , string $mimesection ) : resource
Warning

本函数还未编写文档，仅有参数列表。

参数

mimemail

A valid MIME resource.

mimesection


Returns an array of mime section names in the supplied message

  • ? mailparse_msg_get_part
  • mailparse_msg_parse_file ?
  • PHP Manual
  • Mailparse 函数
  • Returns an array of mime section names in the supplied message

mailparse_msg_get_structure

(PECL mailparse >= 0.9.0)

mailparse_msg_get_structure — Returns an array of mime section names in the supplied message

说明

mailparse_msg_get_structure ( resource $mimemail ) : array
Warning

本函数还未编写文档，仅有参数列表。

参数

mimemail

A valid MIME resource.


Parses a file

  • ? mailparse_msg_get_structure
  • mailparse_msg_parse ?
  • PHP Manual
  • Mailparse 函数
  • Parses a file

mailparse_msg_parse_file

(PECL mailparse >= 0.9.0)

mailparse_msg_parse_file — Parses a file

说明

mailparse_msg_parse_file ( string $filename ) : resource

Parses a file. This is the optimal way of parsing a mail file that you have on disk.

参数

filename

Path to the file holding the message. The file is opened and streamed through the parser.

Note:

The message contained in filename is supposed to end with a newline (CRLF); otherwise the last line of the message will not be parsed.

返回值

Returns a MIME resource representing the structure, or false on error.

参见

  • mailparse_msg_free() - Frees a MIME resource
  • mailparse_msg_create() - Create a mime mail resource


Incrementally parse data into buffer

  • ? mailparse_msg_parse_file
  • mailparse_rfc822_parse_addresses ?
  • PHP Manual
  • Mailparse 函数
  • Incrementally parse data into buffer

mailparse_msg_parse

(PECL mailparse >= 0.9.0)

mailparse_msg_parse — Incrementally parse data into buffer

说明

mailparse_msg_parse ( resource $mimemail , string $data ) : bool

Incrementally parse data into the supplied mime mail resource.

This function allow you to stream portions of a file at a time, rather than read and parse the whole thing.

参数

mimemail

A valid MIME resource.

data

Note:

The final chunk of data is supposed to end with a newline (CRLF); otherwise the last line of the message will not be parsed.

返回值

成功时返回 true， 或者在失败时返回 false。


Parse RFC 822 compliant addresses

  • ? mailparse_msg_parse
  • mailparse_stream_encode ?
  • PHP Manual
  • Mailparse 函数
  • Parse RFC 822 compliant addresses

mailparse_rfc822_parse_addresses

(PECL mailparse >= 0.9.0)

mailparse_rfc822_parse_addresses — Parse RFC 822 compliant addresses

说明

mailparse_rfc822_parse_addresses ( string $addresses ) : array

Parses a » RFC 822 compliant recipient list, such as that found in the To: header.

参数

addresses

A string containing addresses, like in: Wez Furlong <wez@example.com>, doe@example.com

Note:

This string must not include the header name.

返回值

Returns an array of associative arrays with the following keys for each recipient:

display | The recipient name, for display purpose. If this part is not set for a recipient, this key will hold the same value as address.
address | The email address
is_group | true if the recipient is a newsgroup, false otherwise.

范例

Example #1 mailparse_rfc822_parse_addresses() example

<?php

$to = 'Wez Furlong <wez@example.com>, doe@example.com';
var_dump(mailparse_rfc822_parse_addresses($to));

?>

以上例程会输出：

array(2) {
  [0]=>
  array(3) {
    ["display"]=>
    string(11) "Wez Furlong"
    ["address"]=>
    string(15) "wez@example.com"
    ["is_group"]=>
    bool(false)
  }
  [1]=>
  array(3) {
    ["display"]=>
    string(15) "doe@example.com"
    ["address"]=>
    string(15) "doe@example.com"
    ["is_group"]=>
    bool(false)
  }
}


Streams data from source file pointer, apply encoding and write to destfp

  • ? mailparse_rfc822_parse_addresses
  • mailparse_uudecode_all ?
  • PHP Manual
  • Mailparse 函数
  • Streams data from source file pointer, apply encoding and write to destfp

mailparse_stream_encode

(PECL mailparse >= 0.9.0)

mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp

说明

mailparse_stream_encode ( resource $sourcefp , resource $destfp , string $encoding ) : bool

Streams data from the source file pointer, apply encoding and write to the destination file pointer.

参数

sourcefp

A valid file handle. The file is streamed through the parser.

destfp

The destination file handle in which the encoded data will be written.

encoding

One of the character encodings supported by the mbstring module.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 mailparse_stream_encode() example

<?php

// email.eml contents: hello, this is some text=hello.
$fp = fopen('email.eml', 'r');

$dest = tmpfile();

mailparse_stream_encode($fp, $dest, "quoted-printable");

rewind($dest);

// Display new file contents
fpassthru($dest);

?>

以上例程会输出：

hello, this is some text=3Dhello.


Scans the data from fp and extract each embedded uuencoded file

  • ? mailparse_stream_encode
  • 数学扩展 ?
  • PHP Manual
  • Mailparse 函数
  • Scans the data from fp and extract each embedded uuencoded file

mailparse_uudecode_all

(PECL mailparse >= 0.9.0)

mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file

说明

mailparse_uudecode_all ( resource $fp ) : array

Scans the data from the given file pointer and extract each embedded uuencoded file into a temporary file.

参数

fp

A valid file pointer.

返回值

Returns an array of associative arrays listing filename information.

filename | Path to the temporary file name created
origfilename | The original filename, for uuencoded parts only
The first filename entry is the message body. The next entries are the decoded uuencoded files.

范例

Example #1 mailparse_uudecode_all() example

<?php

$text = <<<EOD
To: fred@example.com

hello, this is some text hello.
blah blah blah.

begin 644 test.txt
/=&AI<R!I<R!A('1E<W0*
`
end

EOD;

$fp = tmpfile();
fwrite($fp, $text);

$data = mailparse_uudecode_all($fp);

echo "BODY\n";
readfile($data[0]["filename"]);
echo "UUE ({$data[1]['origfilename']})\n";
readfile($data[1]["filename"]);

// Clean up
unlink($data[0]["filename"]);
unlink($data[1]["filename"]);

?>

以上例程会输出：

BODY
To: fred@example.com

hello, this is some text hello.
blah blah blah.

UUE (test.txt)
this is a test


数学扩展

  • BC Math — BCMath 任意精度数学
    • 简介
    • 安装／配置
    • 预定义常量
    • BC 数学 函数
  • GMP — GNU Multiple Precision
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • GMP 函数
    • GMP — The GMP class
  • Math — Mathematical Functions
    • 简介
    • 安装／配置
    • 预定义常量
    • Math 函数
  • Statistics
    • 简介
    • 安装／配置
    • 预定义常量
    • Statistic 函数
  • Trader — Technical Analysis for Traders
    • 简介
    • 安装／配置
    • 预定义常量
    • Trader 函数


BCMath 任意精度数学

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • BC 数学 函数
    • bcadd — 2个任意精度数字的加法计算
    • bccomp — 比较两个任意精度的数字
    • bcdiv — 2个任意精度的数字除法计算
    • bcmod — 对一个任意精度数字取模
    • bcmul — 2个任意精度数字乘法计算
    • bcpow — 任意精度数字的乘方
    • bcpowmod — Raise an arbitrary precision number to another, reduced by a specified modulus
    • bcscale — 设置所有bc数学函数的默认小数点保留位数
    • bcsqrt — 任意精度数字的二次方根
    • bcsub — 2个任意精度数字的减法


简介

对于任意精度的数学，PHP提供了支持用字符串表示的任意大小和精度的数字的二进制计算，最多为2147483647-1（或0x7FFFFFFF-1）。


安装

本类函数仅在 PHP 编译时配置了 --enable-bcmath 时可用。

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

BC 数学库配置选项
名字 | 默认 | 可修改范围 | 更新日志
bcmath.scale | "0" | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

bcmath.scale int

所有 bcmath 函数中十进制数字的数目。参见 bcscale()。


  • ? 资源类型
  • BC 数学 函数 ?
  • PHP Manual
  • BC Math
  • 预定义常量

预定义常量

此扩展没有定义常量。


BC 数学 函数

Table of Contents

  • bcadd — 2个任意精度数字的加法计算
  • bccomp — 比较两个任意精度的数字
  • bcdiv — 2个任意精度的数字除法计算
  • bcmod — 对一个任意精度数字取模
  • bcmul — 2个任意精度数字乘法计算
  • bcpow — 任意精度数字的乘方
  • bcpowmod — Raise an arbitrary precision number to another, reduced by a specified modulus
  • bcscale — 设置所有bc数学函数的默认小数点保留位数
  • bcsqrt — 任意精度数字的二次方根
  • bcsub — 2个任意精度数字的减法


2个任意精度数字的加法计算

  • ? BC 数学 函数
  • bccomp ?
  • PHP Manual
  • BC 数学 函数
  • 2个任意精度数字的加法计算

bcadd

(PHP 4, PHP 5, PHP 7, PHP 8)

bcadd — 2个任意精度数字的加法计算

说明

bcadd ( string $left_operand , string $right_operand , int $scale = ? ) : string

左操作数和右操作数求和

参数

left_operand

左操作数，字符串类型

right_operand

右操作数，字符串类型

scale

此可选参数用于设置结果中小数点后的小数位数。也可通过使用 bcscale() 来设置全局默认的小数位数，用于所有函数。如果未设置，则默认为 0。

返回值

2个操作数求和之后的结果以字符串返回

范例

Example #1 bcadd() 示例

<?php

$a = '1.234';
$b = '5';

echo bcadd($a, $b);     // 6
echo bcadd($a, $b, 4);  // 6.2340

?>

参见

  • bcsub() - 2个任意精度数字的减法


比较两个任意精度的数字

  • ? bcadd
  • bcdiv ?
  • PHP Manual
  • BC 数学 函数
  • 比较两个任意精度的数字

bccomp

(PHP 4, PHP 5, PHP 7, PHP 8)

bccomp — 比较两个任意精度的数字

说明

bccomp ( string $left_operand , string $right_operand , int $scale = int ) : int

把right_operand和left_operand作比较, 并且返回一个整数的结果.

参数

left_operand

左边的运算数, 是一个字符串.

right_operand

右边的运算数, 是一个字符串.

scale

可选的scale参数被用作设置指示数字， 在使用来作比较的小数点部分.

返回值

如果两个数相等返回0, 左边的数left_operand比较右边的数right_operand大返回1, 否则返回-1.

范例

Example #1 bccomp() example

<?php

echo bccomp('1', '2') . "\n";   // -1
echo bccomp('1.00001', '1', 3); // 0
echo bccomp('1.00001', '1', 5); // 1

?>


2个任意精度的数字除法计算

  • ? bccomp
  • bcmod ?
  • PHP Manual
  • BC 数学 函数
  • 2个任意精度的数字除法计算

bcdiv

(PHP 4, PHP 5, PHP 7, PHP 8)

bcdiv — 2个任意精度的数字除法计算

说明

bcdiv ( string $left_operand , string $right_operand , int $scale = int ) : string

左操作数除以右操作数

参数

left_operand

左操作数，字符串类型

right_operand

右操作数，字符串类型

scale

此可选参数用于设置结果中小数点后的小数位数。也可通过使用 bcscale() 来设置全局默认的小数位数，用于所有函数。如果未设置，则默认为 0。

返回值

返回结果为字符串类型的结果，如果右操作数是0结果为null

范例

Example #1 bcdiv() 示例

<?php

echo bcdiv('105', '6.55957', 3);  // 16.007

?>

参见

  • bcmul() - 2个任意精度数字乘法计算


对一个任意精度数字取模

  • ? bcdiv
  • bcmul ?
  • PHP Manual
  • BC 数学 函数
  • 对一个任意精度数字取模

bcmod

(PHP 4, PHP 5, PHP 7, PHP 8)

bcmod — 对一个任意精度数字取模

说明

bcmod ( string $left_operand , string $modulus ) : string

对左操作数使用系数取模

参数

left_operand

字符串类型的左操作数

modulus

字符串类型系数

返回值

返回字符串类型取模后结果，如果系数为0则返回null

范例

Example #1 bcmod() example

<?php
echo bcmod('4', '2'); // 0
echo bcmod('2', '4'); // 2
?>

参见

  • bcdiv() - 2个任意精度的数字除法计算


2个任意精度数字乘法计算

  • ? bcmod
  • bcpow ?
  • PHP Manual
  • BC 数学 函数
  • 2个任意精度数字乘法计算

bcmul

(PHP 4, PHP 5, PHP 7, PHP 8)

bcmul — 2个任意精度数字乘法计算

说明

bcmul ( string $left_operand , string $right_operand , int $scale = int ) : string

左操作数乘以右操作数

参数

left_operand

字符串类型的左操作数.

right_operand

字符串类型的右操作数.

scale

此可选参数用于设置结果中小数点后的小数位数。也可通过使用 bcscale() 来设置全局默认的小数位数，用于所有函数。如果未设置，则默认为 0。

返回值

返回结果为字符串类型.

范例

Example #1 bcmul() 示例

<?php
echo bcmul('1.34747474747', '35', 3); // 47.161
echo bcmul('2', '4'); // 8
?>

参见

  • bcdiv() - 2个任意精度的数字除法计算


任意精度数字的乘方

  • ? bcmul
  • bcpowmod ?
  • PHP Manual
  • BC 数学 函数
  • 任意精度数字的乘方

bcpow

(PHP 4, PHP 5, PHP 7, PHP 8)

bcpow — 任意精度数字的乘方

说明

bcpow ( string $left_operand , string $right_operand , int $scale = ? ) : string

左操作数的右操作数次方运算.

参数

left_operand

字符串类型的左操作数.

right_operand

字符串类型的右操作数.

scale

此可选参数用于设置结果中小数点后的小数位数。也可通过使用 bcscale() 来设置全局默认的小数位数，用于所有函数。如果未设置，则默认为 0。

返回值

返回结果为字符串类型.

范例

Example #1 bcpow() 示例

<?php

echo bcpow('4.2', '3', 2); // 74.08

?>

注释

Note:

bcpow() may return a result with fewer digits after the decimal point than the scale parameter would indicate. This only occurs when the result doesn't require all of the precision allowed by the scale. For example:

Example #2 bcpow() scale example

<?php
echo bcpow('5', '2', 2);     // prints "25", not "25.00"
?>

参见

  • bcpowmod() - Raise an arbitrary precision number to another, reduced by a specified modulus
  • bcsqrt() - 任意精度数字的二次方根


Raise an arbitrary precision number to another, reduced by a specified modulus

  • ? bcpow
  • bcscale ?
  • PHP Manual
  • BC 数学 函数
  • Raise an arbitrary precision number to another, reduced by a specified modulus

bcpowmod

(PHP 5, PHP 7, PHP 8)

bcpowmod — Raise an arbitrary precision number to another, reduced by a specified modulus

说明

bcpowmod ( string $num , string $exponent , string $modulus , int|null $scale = null ) : string

Use the fast-exponentiation method to raise num to the power exponent with respect to the modulus modulus.

参数

num

The base, as an integral string (i.e. the scale has to be zero).

exponent

The exponent, as an non-negative, integral string (i.e. the scale has to be zero).

modulus

The modulus, as an integral string (i.e. the scale has to be zero).

scale

此可选参数用于设置结果中小数点后的小数位数。也可通过使用 bcscale() 来设置全局默认的小数位数，用于所有函数。如果未设置，则默认为 0。

返回值

Returns the result as a string, or false if modulus is 0 or exponent is negative.

注释

Note:

Because this method uses the modulus operation, numbers which are not positive integers may give unexpected results.

更新日志

版本 | 说明
8.0.0 | scale is now nullable.

范例

The following two statements are functionally identical. The bcpowmod() version however, executes in less time and can accept larger parameters.

<?php
$a = bcpowmod($x, $y, $mod);

$b = bcmod(bcpow($x, $y), $mod);

// $a and $b are equal to each other.

?>

参见

  • bcpow() - 任意精度数字的乘方
  • bcmod() - 对一个任意精度数字取模


设置所有bc数学函数的默认小数点保留位数

  • ? bcpowmod
  • bcsqrt ?
  • PHP Manual
  • BC 数学 函数
  • 设置所有bc数学函数的默认小数点保留位数

bcscale

(PHP 4, PHP 5, PHP 7, PHP 8)

bcscale — 设置所有bc数学函数的默认小数点保留位数

说明

bcscale ( int $scale ) : bool

设置所有bc数学函数的未设定情况下得小数点保留位数.

参数

scale

小数点保留位数.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 bcscale() example

<?php

// default scale : 3
bcscale(3);
echo bcdiv('105', '6.55957'); // 16.007

// this is the same without bcscale()
echo bcdiv('105', '6.55957', 3); // 16.007

?>


任意精度数字的二次方根

  • ? bcscale
  • bcsub ?
  • PHP Manual
  • BC 数学 函数
  • 任意精度数字的二次方根

bcsqrt

(PHP 4, PHP 5, PHP 7, PHP 8)

bcsqrt — 任意精度数字的二次方根

说明

bcsqrt ( string $operand , int $scale = ? ) : string

返回操作数的二次方根.

参数

operand

字符串类型的操作数.

scale

此可选参数用于设置结果中小数点后的小数位数。也可通过使用 bcscale() 来设置全局默认的小数位数，用于所有函数。如果未设置，则默认为 0。

返回值

返回二次方根的结果为字符串类型，如果操作数是负数则返回null.

范例

Example #1 bcsqrt() 示例

<?php

echo bcsqrt('2', 3); // 1.414

?>

参见

  • bcpow() - 任意精度数字的乘方


2个任意精度数字的减法

  • ? bcsqrt
  • GMP ?
  • PHP Manual
  • BC 数学 函数
  • 2个任意精度数字的减法

bcsub

(PHP 4, PHP 5, PHP 7, PHP 8)

bcsub — 2个任意精度数字的减法

说明

bcsub ( string $left_operand , string $right_operand , int $scale = int ) : string

左操作数减去右操作数.

参数

left_operand

字符串类型的左操作数.

right_operand

字符串类型的右操作数.

scale

此可选参数用于设置结果中小数点后的小数位数。也可通过使用 bcscale() 来设置全局默认的小数位数，用于所有函数。如果未设置，则默认为 0。

返回值

返回减法之后结果为字符串类型.

范例

Example #1 bcsub() example

<?php

$a = '1.234';
$b = '5';

echo bcsub($a, $b);     // -3
echo bcsub($a, $b, 4);  // -3.7660

?>

参见

  • bcadd() - 2个任意精度数字的加法计算


GNU Multiple Precision

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • GMP 函数
    • gmp_abs — Absolute value
    • gmp_add — Add numbers
    • gmp_and — Bitwise AND
    • gmp_binomial — Calculates binomial coefficient
    • gmp_clrbit — Clear bit
    • gmp_cmp — Compare numbers
    • gmp_com — Calculates one's complement
    • gmp_div_q — Divide numbers
    • gmp_div_qr — Divide numbers and get quotient and remainder
    • gmp_div_r — Remainder of the division of numbers
    • gmp_div — 别名 gmp_div_q
    • gmp_divexact — Exact division of numbers
    • gmp_export — Export to a binary string
    • gmp_fact — Factorial
    • gmp_gcd — Calculate GCD
    • gmp_gcdext — Calculate GCD and multipliers
    • gmp_hamdist — Hamming distance
    • gmp_import — Import from a binary string
    • gmp_init — Create GMP number
    • gmp_intval — Convert GMP number to integer
    • gmp_invert — Inverse by modulo
    • gmp_jacobi — Jacobi symbol
    • gmp_kronecker — Kronecker symbol
    • gmp_lcm — Calculate LCM
    • gmp_legendre — Legendre symbol
    • gmp_mod — Modulo operation
    • gmp_mul — Multiply numbers
    • gmp_neg — Negate number
    • gmp_nextprime — Find next prime number
    • gmp_or — Bitwise OR
    • gmp_perfect_power — Perfect power check
    • gmp_perfect_square — Perfect square check
    • gmp_popcount — Population count
    • gmp_pow — Raise number into power
    • gmp_powm — Raise number into power with modulo
    • gmp_prob_prime — Check if number is "probably prime"
    • gmp_random_bits — Random number
    • gmp_random_range — Random number
    • gmp_random_seed — Sets the RNG seed
    • gmp_random — Random number
    • gmp_root — Take the integer part of nth root
    • gmp_rootrem — Take the integer part and remainder of nth root
    • gmp_scan0 — Scan for 0
    • gmp_scan1 — Scan for 1
    • gmp_setbit — Set bit
    • gmp_sign — Sign of number
    • gmp_sqrt — Calculate square root
    • gmp_sqrtrem — Square root with remainder
    • gmp_strval — Convert GMP number to string
    • gmp_sub — Subtract numbers
    • gmp_testbit — Tests if a bit is set
    • gmp_xor — Bitwise XOR
  • GMP — The GMP class


简介

These functions allow for arbitrary-length integers to be worked with using the GNU MP library.

Note:

Most GMP functions accept GMP number arguments. These are shown in this documentation as GMP objects. However, note that PHP 5.5 and earlier represented GMP numbers as resources. Most of these functions will also accept numeric and string arguments, so long as it is possible to convert the latter to a number. Also, if there is a more performant function that can operate on the arguments (integers only), then it will be used instead (this is done transparently). See also the gmp_init() function.

Note:

From PHP 5.6 onwards, the arithmetic, bitwise, and comparison operators may be used with the GMP objects returned from gmp_init() and other GMP functions.

Warning

Large integers must be specified as strings - otherwise, PHP will coerce them to floats, resulting in a loss of precision.

Note: This extension is available on Windows platforms since PHP 5.1.0.


需求

The GMP library can be downloaded from » http://gmplib.org/#DOWNLOAD. This site also has the GMP manual available.

At least GMP version 2 is required, with some functions requiring a more recent version of the GMP library.


安装

In order to have these functions available, PHP must be compiled with GMP support by using the --with-gmp option.


资源类型

Prior to PHP 5.6, most GMP functions operate on or return GMP number resources. PHP 5.6 onwards uses GMP objects in place of GMP number resources.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

GMP_ROUND_ZERO (int)
GMP_ROUND_PLUSINF (int)
GMP_ROUND_MINUSINF (int)
GMP_MSW_FIRST (int)
GMP_LSW_FIRST (int)
GMP_LITTLE_ENDIAN (int)
GMP_BIG_ENDIAN (int)
GMP_NATIVE_ENDIAN (int)
GMP_VERSION (string)
The GMP library version


范例

Example #1 Factorial function using GMP

<?php
function fact($x)
{
    $return = 1;
    for ($i=2; $i <= $x; $i++) {
        $return = gmp_mul($return, $i);
    }
    return $return;
}

echo gmp_strval(fact(1000)) . "\n";
?>

This will calculate factorial of 1000 (pretty big number) very fast.


GMP 函数

参见

More mathematical functions can be found in the 数学扩展 section

Table of Contents

  • gmp_abs — Absolute value
  • gmp_add — Add numbers
  • gmp_and — Bitwise AND
  • gmp_binomial — Calculates binomial coefficient
  • gmp_clrbit — Clear bit
  • gmp_cmp — Compare numbers
  • gmp_com — Calculates one's complement
  • gmp_div_q — Divide numbers
  • gmp_div_qr — Divide numbers and get quotient and remainder
  • gmp_div_r — Remainder of the division of numbers
  • gmp_div — 别名 gmp_div_q
  • gmp_divexact — Exact division of numbers
  • gmp_export — Export to a binary string
  • gmp_fact — Factorial
  • gmp_gcd — Calculate GCD
  • gmp_gcdext — Calculate GCD and multipliers
  • gmp_hamdist — Hamming distance
  • gmp_import — Import from a binary string
  • gmp_init — Create GMP number
  • gmp_intval — Convert GMP number to integer
  • gmp_invert — Inverse by modulo
  • gmp_jacobi — Jacobi symbol
  • gmp_kronecker — Kronecker symbol
  • gmp_lcm — Calculate LCM
  • gmp_legendre — Legendre symbol
  • gmp_mod — Modulo operation
  • gmp_mul — Multiply numbers
  • gmp_neg — Negate number
  • gmp_nextprime — Find next prime number
  • gmp_or — Bitwise OR
  • gmp_perfect_power — Perfect power check
  • gmp_perfect_square — Perfect square check
  • gmp_popcount — Population count
  • gmp_pow — Raise number into power
  • gmp_powm — Raise number into power with modulo
  • gmp_prob_prime — Check if number is "probably prime"
  • gmp_random_bits — Random number
  • gmp_random_range — Random number
  • gmp_random_seed — Sets the RNG seed
  • gmp_random — Random number
  • gmp_root — Take the integer part of nth root
  • gmp_rootrem — Take the integer part and remainder of nth root
  • gmp_scan0 — Scan for 0
  • gmp_scan1 — Scan for 1
  • gmp_setbit — Set bit
  • gmp_sign — Sign of number
  • gmp_sqrt — Calculate square root
  • gmp_sqrtrem — Square root with remainder
  • gmp_strval — Convert GMP number to string
  • gmp_sub — Subtract numbers
  • gmp_testbit — Tests if a bit is set
  • gmp_xor — Bitwise XOR


Absolute value

  • ? GMP 函数
  • gmp_add ?
  • PHP Manual
  • GMP 函数
  • Absolute value

gmp_abs

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_abs — Absolute value

说明

gmp_abs ( GMP|int|string $num ) : GMP

Get the absolute value of a number.

参数

num

GMP 对象或 int ，或数字string。

返回值

Returns the absolute value of num, as a GMP number.

范例

Example #1 gmp_abs() example

<?php
$abs1 = gmp_abs("274982683358");
$abs2 = gmp_abs("-274982683358");

echo gmp_strval($abs1) . "\n";
echo gmp_strval($abs2) . "\n";
?>

以上例程会输出：

274982683358
274982683358


Add numbers

  • ? gmp_abs
  • gmp_and ?
  • PHP Manual
  • GMP 函数
  • Add numbers

gmp_add

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_add — Add numbers

说明

gmp_add ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Add two numbers.

参数

num1

The first summand (augent).

GMP 对象或 int ，或数字string。

num2

The second summand (addend).

GMP 对象或 int ，或数字string。

返回值

A GMP number representing the sum of the arguments.

范例

Example #1 gmp_add() example

<?php
$sum = gmp_add("123456789012345", "76543210987655");
echo gmp_strval($sum) . "\n";
?>

以上例程会输出：

200000000000000


Bitwise AND

  • ? gmp_add
  • gmp_binomial ?
  • PHP Manual
  • GMP 函数
  • Bitwise AND

gmp_and

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_and — Bitwise AND

说明

gmp_and ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Calculates bitwise AND of two GMP numbers.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

A GMP number representing the bitwise AND comparison.

范例

Example #1 gmp_and() example

<?php
$and1 = gmp_and("0xfffffffff4", "0x4");
$and2 = gmp_and("0xfffffffff4", "0x8");
echo gmp_strval($and1) . "\n";
echo gmp_strval($and2) . "\n";
?>

以上例程会输出：

4
0


Calculates binomial coefficient

  • ? gmp_and
  • gmp_clrbit ?
  • PHP Manual
  • GMP 函数
  • Calculates binomial coefficient

gmp_binomial

(PHP 7 >= 7.3.0, PHP 8)

gmp_binomial — Calculates binomial coefficient

说明

gmp_binomial ( GMP|int|string $n , int $k ) : GMP

Calculates the binomial coefficient C(n, k).

参数

n

GMP 对象或 int ，或数字string。

k

返回值

Returns the binomial coefficient C(n, k).

错误／异常

Throws ValueError if k is negative. Prior to PHP 8.0.0, E_WARNING was issued instead.

更新日志

版本 | 说明
8.0.0 | This function no longer returns false on failure.


Clear bit

  • ? gmp_binomial
  • gmp_cmp ?
  • PHP Manual
  • GMP 函数
  • Clear bit

gmp_clrbit

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_clrbit — Clear bit

说明

gmp_clrbit ( GMP $num , int $index ) : void

Clears (sets to 0) bit index in num. The index starts at 0.

参数

num

GMP 对象或 int ，或数字string。

index

The index of the bit to clear. Index 0 represents the least significant bit.

返回值

GMP 对象。

范例

Example #1 gmp_clrbit() example

<?php
$a = gmp_init("0xff");
gmp_clrbit($a, 0); // index starts at 0, least significant bit
echo gmp_strval($a) . "\n";
?>

以上例程会输出：

254

注释

Note:

Unlike most of the other GMP functions, gmp_clrbit() must be called with a GMP object that already exists (using gmp_init() for example). One will not be automatically created.

参见

  • gmp_setbit() - Set bit
  • gmp_testbit() - Tests if a bit is set


Compare numbers

  • ? gmp_clrbit
  • gmp_com ?
  • PHP Manual
  • GMP 函数
  • Compare numbers

gmp_cmp

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_cmp — Compare numbers

说明

gmp_cmp ( GMP|int|string $num1 , GMP|int|string $num2 ) : int

Compares two numbers.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

Returns a positive value if a > b, zero if a = b and a negative value if a < b.

范例

Example #1 gmp_cmp() example

<?php
$cmp1 = gmp_cmp("1234", "1000"); // greater than
$cmp2 = gmp_cmp("1000", "1234"); // less than
$cmp3 = gmp_cmp("1234", "1234"); // equal to

echo "$cmp1 $cmp2 $cmp3\n";
?>

以上例程会输出：

1 -1 0


Calculates one's complement

  • ? gmp_cmp
  • gmp_div_q ?
  • PHP Manual
  • GMP 函数
  • Calculates one's complement

gmp_com

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_com — Calculates one's complement

说明

gmp_com ( GMP|int|string $num ) : GMP

Returns the one's complement of num.

参数

num

GMP 对象或 int ，或数字string。

返回值

Returns the one's complement of num, as a GMP number.

范例

Example #1 gmp_com() example

<?php
$com = gmp_com("1234");
echo gmp_strval($com) . "\n";
?>

以上例程会输出：

-1235


Divide numbers

  • ? gmp_com
  • gmp_div_qr ?
  • PHP Manual
  • GMP 函数
  • Divide numbers

gmp_div_q

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_div_q — Divide numbers

说明

gmp_div_q ( GMP|int|string $num1 , GMP|int|string $num2 , int $rounding_mode = GMP_ROUND_ZERO ) : GMP

Divides num1 by num2 and returns the integer result.

参数

num1

The number being divided.

GMP 对象或 int ，或数字string。

num2

The number that num1 is being divided by.

GMP 对象或 int ，或数字string。

rounding_mode

The result rounding is defined by the rounding_mode, which can have the following values:

  • GMP_ROUND_ZERO: The result is truncated towards 0.
  • GMP_ROUND_PLUSINF: The result is rounded towards +infinity.
  • GMP_ROUND_MINUSINF: The result is rounded towards -infinity.

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

范例

Example #1 gmp_div_q() example

<?php
$div1 = gmp_div_q("100", "5");
echo gmp_strval($div1) . "\n";

$div2 = gmp_div_q("1", "3");
echo gmp_strval($div2) . "\n";

$div3 = gmp_div_q("1", "3", GMP_ROUND_PLUSINF);
echo gmp_strval($div3) . "\n";

$div4 = gmp_div_q("-1", "4", GMP_ROUND_PLUSINF);
echo gmp_strval($div4) . "\n";

$div5 = gmp_div_q("-1", "4", GMP_ROUND_MINUSINF);
echo gmp_strval($div5) . "\n";
?>

以上例程会输出：

20
0
1
0
-1

注释

Note:

This function can also be called as gmp_div().

参见

  • gmp_div_r() - Remainder of the division of numbers
  • gmp_div_qr() - Divide numbers and get quotient and remainder


Divide numbers and get quotient and remainder

  • ? gmp_div_q
  • gmp_div_r ?
  • PHP Manual
  • GMP 函数
  • Divide numbers and get quotient and remainder

gmp_div_qr

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_div_qr — Divide numbers and get quotient and remainder

说明

gmp_div_qr ( GMP|int|string $num1 , GMP|int|string $num2 , int $rounding_mode = GMP_ROUND_ZERO ) : array

The function divides num1 by num2.

参数

num1

The number being divided.

GMP 对象或 int ，或数字string。

num2

The number that num1 is being divided by.

GMP 对象或 int ，或数字string。

rounding_mode

See the gmp_div_q() function for description of the rounding_mode argument.

返回值

Returns an array, with the first element being [n/d] (the integer result of the division) and the second being (n - [n/d] * d) (the remainder of the division).

范例

Example #1 Division of GMP numbers

<?php
$a = gmp_init("0x41682179fbf5");
$res = gmp_div_qr($a, "0xDEFE75");
printf("Result is: q - %s, r - %s",
       gmp_strval($res[0]), gmp_strval($res[1]));
?>

参见

  • gmp_div_q() - Divide numbers
  • gmp_div_r() - Remainder of the division of numbers


Remainder of the division of numbers

  • ? gmp_div_qr
  • gmp_div ?
  • PHP Manual
  • GMP 函数
  • Remainder of the division of numbers

gmp_div_r

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_div_r — Remainder of the division of numbers

说明

gmp_div_r ( GMP|int|string $num1 , GMP|int|string $num2 , int $rounding_mode = GMP_ROUND_ZERO ) : GMP

Calculates remainder of the integer division of num1 by num2. The remainder has the sign of the num1 argument, if not zero.

参数

num1

The number being divided.

GMP 对象或 int ，或数字string。

num2

The number that num1 is being divided by.

GMP 对象或 int ，或数字string。

rounding_mode

See the gmp_div_q() function for description of the rounding_mode argument.

返回值

The remainder, as a GMP number.

范例

Example #1 gmp_div_r() example

<?php
$div = gmp_div_r("105", "20");
echo gmp_strval($div) . "\n";
?>

以上例程会输出：

5

参见

  • gmp_div_q() - Divide numbers
  • gmp_div_qr() - Divide numbers and get quotient and remainder


别名 gmp_div_q

  • ? gmp_div_r
  • gmp_divexact ?
  • PHP Manual
  • GMP 函数
  • 别名 gmp_div_q

gmp_div

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_div — 别名 gmp_div_q()

说明

此函数是该函数的别名： gmp_div_q().


Exact division of numbers

  • ? gmp_div
  • gmp_export ?
  • PHP Manual
  • GMP 函数
  • Exact division of numbers

gmp_divexact

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_divexact — Exact division of numbers

说明

gmp_divexact ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Divides num1 by num2, using fast "exact division" algorithm. This function produces correct results only when it is known in advance that num2 divides num1.

参数

num1

The number being divided.

GMP 对象或 int ，或数字string。

num2

The number that a is being divided by.

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

范例

Example #1 gmp_divexact() example

<?php
$div1 = gmp_divexact("10", "2");
echo gmp_strval($div1) . "\n";

$div2 = gmp_divexact("10", "3"); // bogus result
echo gmp_strval($div2) . "\n";
?>

以上例程会输出：

5
2863311534


Export to a binary string

  • ? gmp_divexact
  • gmp_fact ?
  • PHP Manual
  • GMP 函数
  • Export to a binary string

gmp_export

(PHP 5 >= 5.6.1, PHP 7, PHP 8)

gmp_export — Export to a binary string

说明

gmp_export ( GMP|int|string $num , int $word_size = 1 , int $flags = GMP_MSW_FIRST | GMP_NATIVE_ENDIAN ) : string

Export a GMP number to a binary string

参数

num

The GMP number being exported

word_size

Default value is 1. The number of bytes in each chunk of binary data. This is mainly used in conjunction with the options parameter.

flags

Default value is GMP_MSW_FIRST | GMP_NATIVE_ENDIAN.

返回值

Returns a string.

更新日志

版本 | 说明
8.0.0 | This function no longer returns false on failure.

范例

Example #1 gmp_export() example

<?php
$number = gmp_init(16705);
echo gmp_export($number) . "\n";
?>

以上例程会输出：

AA

参见

  • gmp_import() - Import from a binary string


Factorial

  • ? gmp_export
  • gmp_gcd ?
  • PHP Manual
  • GMP 函数
  • Factorial

gmp_fact

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_fact — Factorial

说明

gmp_fact ( GMP|int|string $num ) : GMP

Calculates factorial (num!) of num.

参数

num

The factorial number.

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

范例

Example #1 gmp_fact() example

<?php
$fact1 = gmp_fact(5); // 5 * 4 * 3 * 2 * 1
echo gmp_strval($fact1) . "\n";

$fact2 = gmp_fact(50); // 50 * 49 * 48, ... etc
echo gmp_strval($fact2) . "\n";
?>

以上例程会输出：

120
30414093201713378043612608166064768844377641568960512000000000000


Calculate GCD

  • ? gmp_fact
  • gmp_gcdext ?
  • PHP Manual
  • GMP 函数
  • Calculate GCD

gmp_gcd

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_gcd — Calculate GCD

说明

gmp_gcd ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Calculate greatest common divisor of num1 and num2. The result is always positive even if either of, or both, input operands are negative.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

A positive GMP number that divides into both num1 and num2.

范例

Example #1 gmp_gcd() example

<?php
$gcd = gmp_gcd("12", "21");
echo gmp_strval($gcd) . "\n";
?>

以上例程会输出：

3

参见

  • gmp_lcm() - Calculate LCM


Calculate GCD and multipliers

  • ? gmp_gcd
  • gmp_hamdist ?
  • PHP Manual
  • GMP 函数
  • Calculate GCD and multipliers

gmp_gcdext

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_gcdext — Calculate GCD and multipliers

说明

gmp_gcdext ( GMP|int|string $num1 , GMP|int|string $num2 ) : array

Calculates g, s, and t, such that a*s + b*t = g = gcd(a,b), where gcd is the greatest common divisor. Returns an array with respective elements g, s and t.

This function can be used to solve linear Diophantine equations in two variables. These are equations that allow only integer solutions and have the form: a*x + b*y = c. For more information, go to the » "Diophantine Equation" page at MathWorld

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

An array of GMP numbers.

范例

Example #1 Solving a linear Diophantine equation

<?php
// Solve the equation a*s + b*t = g
// where a = 12, b = 21, g = gcd(12, 21) = 3
$a = gmp_init(12);
$b = gmp_init(21);
$g = gmp_gcd($a, $b);
$r = gmp_gcdext($a, $b);

$check_gcd = (gmp_strval($g) == gmp_strval($r['g']));
$eq_res = gmp_add(gmp_mul($a, $r['s']), gmp_mul($b, $r['t']));
$check_res = (gmp_strval($g) == gmp_strval($eq_res));

if ($check_gcd && $check_res) {
    $fmt = "Solution: %d*%d + %d*%d = %d\n";
    printf($fmt, gmp_strval($a), gmp_strval($r['s']), gmp_strval($b),
    gmp_strval($r['t']), gmp_strval($r['g']));
} else {
    echo "Error while solving the equation\n";
}

// output: Solution: 12*2 + 21*-1 = 3
?>


Hamming distance

  • ? gmp_gcdext
  • gmp_import ?
  • PHP Manual
  • GMP 函数
  • Hamming distance

gmp_hamdist

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_hamdist — Hamming distance

说明

gmp_hamdist ( GMP|int|string $num1 , GMP|int|string $num2 ) : int

Returns the hamming distance between num1 and num2. Both operands should be non-negative.

参数

num1

GMP 对象或 int ，或数字string。

It should be positive.

num2

GMP 对象或 int ，或数字string。

It should be positive.

返回值

The hamming distance between num1 and num2, as an int.

范例

Example #1 gmp_hamdist() example

<?php
$ham1 = gmp_init("1001010011", 2);
$ham2 = gmp_init("1011111100", 2);
echo gmp_hamdist($ham1, $ham2) . "\n";

/* hamdist is equivalent to: */
echo gmp_popcount(gmp_xor($ham1, $ham2)) . "\n";
?>

以上例程会输出：

6
6

参见

  • gmp_popcount() - Population count
  • gmp_xor() - Bitwise XOR


Import from a binary string

  • ? gmp_hamdist
  • gmp_init ?
  • PHP Manual
  • GMP 函数
  • Import from a binary string

gmp_import

(PHP 5 >= 5.6.1, PHP 7, PHP 8)

gmp_import — Import from a binary string

说明

gmp_import ( string $data , int $word_size = 1 , int $flags = GMP_MSW_FIRST | GMP_NATIVE_ENDIAN ) : GMP

Import a GMP number from a binary string

参数

data

The binary string being imported

word_size

Default value is 1. The number of bytes in each chunk of binary data. This is mainly used in conjunction with the options parameter.

flags

Default value is GMP_MSW_FIRST | GMP_NATIVE_ENDIAN.

返回值

Returns a GMP number.

更新日志

版本 | 说明
8.0.0 | This function no longer returns false on failure.

范例

Example #1 gmp_import() example

<?php
$number = gmp_import("\0");
echo gmp_strval($number) . "\n";

$number = gmp_import("\0\1\2");
echo gmp_strval($number) . "\n";
?>

以上例程会输出：

0
258

参见

  • gmp_export() - Export to a binary string


Create GMP number

  • ? gmp_import
  • gmp_intval ?
  • PHP Manual
  • GMP 函数
  • Create GMP number

gmp_init

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_init — Create GMP number

说明

gmp_init ( int|string $num , int $base = 0 ) : GMP

Creates a GMP number from an integer or string.

参数

num

An integer or a string. The string representation can be decimal, hexadecimal or octal.

base

The base.

The base may vary from 2 to 62. If base is 0 (default value), the actual base is determined from the leading characters: if the first two characters are 0x or 0X, hexadecimal is assumed, if the first two characters are 0b or 0B, binary is assumed, otherwise if the first character is 0, octal is assumed, otherwise decimal is assumed. For bases up to 36, case is ignored; upper-case and lower-case letters have the same value. For bases 37 to 62, upper-case letter represent the usual 10 to 35 while lower-case letter represent 36 to 61.

返回值

GMP 对象。

范例

Example #1 Creating GMP number

<?php
$a = gmp_init(123456);
$b = gmp_init("0xFFFFDEBACDFEDF7200");
?>

注释

Note:

It is not necessary to call this function in order to use integers or strings in place of GMP numbers in GMP functions (such as with gmp_add()). Function arguments are automatically converted to GMP numbers, if such conversion is possible and needed, using the same rules as gmp_init().


Convert GMP number to integer

  • ? gmp_init
  • gmp_invert ?
  • PHP Manual
  • GMP 函数
  • Convert GMP number to integer

gmp_intval

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_intval — Convert GMP number to integer

说明

gmp_intval ( GMP|int|string $num ) : int

This function converts GMP number into native PHP ints.

参数

num

GMP 对象或 int ，或数字string。

返回值

The int value of num.

范例

Example #1 gmp_intval() example

<?php
// displays correct result
echo gmp_intval("2147483647") . "\n";

// displays wrong result, above PHP integer limit
echo gmp_intval("2147483648") . "\n";

// displays correct result
echo gmp_strval("2147483648") . "\n";
?>

以上例程会输出：

2147483647
2147483647
2147483648

注释

Warning

This function returns a useful result only if the number actually fits the PHP integer (i.e., signed long type). To simply print the GMP number, use gmp_strval().


Inverse by modulo

  • ? gmp_intval
  • gmp_jacobi ?
  • PHP Manual
  • GMP 函数
  • Inverse by modulo

gmp_invert

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_invert — Inverse by modulo

说明

gmp_invert ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP|false

Computes the inverse of num1 modulo num2.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

A GMP number on success or false if an inverse does not exist.

范例

Example #1 gmp_invert() example

<?php
echo gmp_invert("5", "10"); // no inverse, outputs nothing, result is FALSE
$invert = gmp_invert("5", "11");
echo gmp_strval($invert) . "\n";
?>

以上例程会输出：

9


Jacobi symbol

  • ? gmp_invert
  • gmp_kronecker ?
  • PHP Manual
  • GMP 函数
  • Jacobi symbol

gmp_jacobi

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_jacobi — Jacobi symbol

说明

gmp_jacobi ( GMP|int|string $num1 , GMP|int|string $num2 ) : int

Computes » Jacobi symbol of num1 and num2. num2 should be odd and must be positive.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

Should be odd and must be positive.

返回值

GMP 对象。

范例

Example #1 gmp_jacobi() example

<?php
echo gmp_jacobi("1", "3") . "\n";
echo gmp_jacobi("2", "3") . "\n";
?>

以上例程会输出：

1
0

参见

  • gmp_kronecker() - Kronecker symbol
  • gmp_legendre() - Legendre symbol


Kronecker symbol

  • ? gmp_jacobi
  • gmp_lcm ?
  • PHP Manual
  • GMP 函数
  • Kronecker symbol

gmp_kronecker

(PHP 7 >= 7.3.0, PHP 8)

gmp_kronecker — Kronecker symbol

说明

gmp_kronecker ( GMP|int|string $num1 , GMP|int|string $num2 ) : int

This function computes the Kronecker symbol of num1 and num2.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

Returns the Kronecker symbol of num1 and num2

参见

  • gmp_jacobi() - Jacobi symbol
  • gmp_legendre() - Legendre symbol


Calculate LCM

  • ? gmp_kronecker
  • gmp_legendre ?
  • PHP Manual
  • GMP 函数
  • Calculate LCM

gmp_lcm

(PHP 7 >= 7.3.0, PHP 8)

gmp_lcm — Calculate LCM

说明

gmp_lcm ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

This function computes the least common multiple (lcm) of num1 and num2.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

参见

  • gmp_gcd() - Calculate GCD


Legendre symbol

  • ? gmp_lcm
  • gmp_mod ?
  • PHP Manual
  • GMP 函数
  • Legendre symbol

gmp_legendre

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_legendre — Legendre symbol

说明

gmp_legendre ( GMP|int|string $num1 , GMP|int|string $num2 ) : int

Compute the » Legendre symbol of num1 and num2. num2 should be odd and must be positive.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

Should be odd and must be positive.

返回值

GMP 对象。

范例

Example #1 gmp_legendre() example

<?php
echo gmp_legendre("1", "3") . "\n";
echo gmp_legendre("2", "3") . "\n";
?>

以上例程会输出：

1
0

参见

  • gmp_jacobi() - Jacobi symbol
  • gmp_kronecker() - Kronecker symbol


Modulo operation

  • ? gmp_legendre
  • gmp_mul ?
  • PHP Manual
  • GMP 函数
  • Modulo operation

gmp_mod

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_mod — Modulo operation

说明

gmp_mod ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Calculates num1 modulo num2. The result is always non-negative, the sign of num2 is ignored.

参数

num1

GMP 对象或 int ，或数字string。

num2

The modulo that is being evaluated.

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

范例

Example #1 gmp_mod() example

<?php
$mod = gmp_mod("8", "3");
echo gmp_strval($mod) . "\n";
?>

以上例程会输出：

2


Multiply numbers

  • ? gmp_mod
  • gmp_neg ?
  • PHP Manual
  • GMP 函数
  • Multiply numbers

gmp_mul

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_mul — Multiply numbers

说明

gmp_mul ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Multiplies num1 by num2 and returns the result.

参数

num1

A number that will be multiplied by num2.

GMP 对象或 int ，或数字string。

num2

A number that will be multiplied by num1.

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

范例

Example #1 gmp_mul() example

<?php
$mul = gmp_mul("12345678", "2000");
echo gmp_strval($mul) . "\n";
?>

以上例程会输出：

24691356000


Negate number

  • ? gmp_mul
  • gmp_nextprime ?
  • PHP Manual
  • GMP 函数
  • Negate number

gmp_neg

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_neg — Negate number

说明

gmp_neg ( GMP|int|string $num ) : GMP

Returns the negative value of a number.

参数

num

GMP 对象或 int ，或数字string。

返回值

Returns -num, as a GMP number.

范例

Example #1 gmp_neg() example

<?php
$neg1 = gmp_neg("1");
echo gmp_strval($neg1) . "\n";
$neg2 = gmp_neg("-1");
echo gmp_strval($neg2) . "\n";
?>

以上例程会输出：

-1
1


Find next prime number

  • ? gmp_neg
  • gmp_or ?
  • PHP Manual
  • GMP 函数
  • Find next prime number

gmp_nextprime

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

gmp_nextprime — Find next prime number

说明

gmp_nextprime ( GMP|int|string $num ) : GMP

Find next prime number

参数

num

GMP 对象或 int ，或数字string。

返回值

Return the next prime number greater than num, as a GMP number.

范例

Example #1 gmp_nextprime() example

<?php
$prime1 = gmp_nextprime(10); // next prime number greater than 10
$prime2 = gmp_nextprime(-1000); // next prime number greater than -1000

echo gmp_strval($prime1) . "\n";
echo gmp_strval($prime2) . "\n";
?>

以上例程会输出：

11
2

注释

Note:

This function uses a probabilistic algorithm to identify primes and chances to get a composite number are extremely small.


Bitwise OR

  • ? gmp_nextprime
  • gmp_perfect_power ?
  • PHP Manual
  • GMP 函数
  • Bitwise OR

gmp_or

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_or — Bitwise OR

说明

gmp_or ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Calculates bitwise inclusive OR of two GMP numbers.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

范例

Example #1 gmp_or() example

<?php
$or1 = gmp_or("0xfffffff2", "4");
echo gmp_strval($or1, 16) . "\n";
$or2 = gmp_or("0xfffffff2", "2");
echo gmp_strval($or2, 16) . "\n";
?>

以上例程会输出：

fffffff6
fffffff2


Perfect power check

  • ? gmp_or
  • gmp_perfect_square ?
  • PHP Manual
  • GMP 函数
  • Perfect power check

gmp_perfect_power

(PHP 7 >= 7.3.0, PHP 8)

gmp_perfect_power — Perfect power check

说明

gmp_perfect_power ( GMP|int|string $num ) : bool

Checks whether num is a perfect power.

参数

num

GMP 对象或 int ，或数字string。

返回值

Returns true if num is a perfect power, false otherwise.

参见

  • gmp_perfect_square() - Perfect square check


Perfect square check

  • ? gmp_perfect_power
  • gmp_popcount ?
  • PHP Manual
  • GMP 函数
  • Perfect square check

gmp_perfect_square

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_perfect_square — Perfect square check

说明

gmp_perfect_square ( GMP|int|string $num ) : bool

Check if a number is a perfect square.

参数

num

The number being checked as a perfect square.

GMP 对象或 int ，或数字string。

返回值

Returns true if num is a perfect square, false otherwise.

范例

Example #1 gmp_perfect_square() example

<?php
// 3 * 3, perfect square
var_dump(gmp_perfect_square("9"));

// not a perfect square
var_dump(gmp_perfect_square("7"));

// 1234567890 * 1234567890, perfect square
var_dump(gmp_perfect_square("1524157875019052100"));
?>

以上例程会输出：

bool(true)
bool(false)
bool(true)

参见

  • gmp_perfect_power() - Perfect power check
  • gmp_sqrt() - Calculate square root
  • gmp_sqrtrem() - Square root with remainder


Population count

  • ? gmp_perfect_square
  • gmp_pow ?
  • PHP Manual
  • GMP 函数
  • Population count

gmp_popcount

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_popcount — Population count

说明

gmp_popcount ( GMP|int|string $num ) : int

Get the population count.

参数

num

GMP 对象或 int ，或数字string。

返回值

The population count of num, as an int.

范例

Example #1 gmp_popcount() example

<?php
$pop1 = gmp_init("10000101", 2); // 3 1's
echo gmp_popcount($pop1) . "\n";
$pop2 = gmp_init("11111110", 2); // 7 1's
echo gmp_popcount($pop2) . "\n";
?>

以上例程会输出：

3
7


Raise number into power

  • ? gmp_popcount
  • gmp_powm ?
  • PHP Manual
  • GMP 函数
  • Raise number into power

gmp_pow

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_pow — Raise number into power

说明

gmp_pow ( GMP|int|string $num , int $exponent ) : GMP

Raise num into power exponent.

参数

num

The base number.

GMP 对象或 int ，或数字string。

exponent

The positive power to raise the num.

返回值

The new (raised) number, as a GMP number. The case of 0^0 yields 1.

范例

Example #1 gmp_pow() example

<?php
$pow1 = gmp_pow("2", 31);
echo gmp_strval($pow1) . "\n";
$pow2 = gmp_pow("0", 0);
echo gmp_strval($pow2) . "\n";
$pow3 = gmp_pow("2", -1); // Negative exp, generates warning
echo gmp_strval($pow3) . "\n";
?>

以上例程会输出：

2147483648
1


Raise number into power with modulo

  • ? gmp_pow
  • gmp_prob_prime ?
  • PHP Manual
  • GMP 函数
  • Raise number into power with modulo

gmp_powm

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_powm — Raise number into power with modulo

说明

gmp_powm ( GMP|int|string $num , GMP|int|string $exponent , GMP|int|string $modulus ) : GMP

Calculate (num raised into power exponent) modulo modulus. If exponent is negative, result is undefined.

参数

num

The base number.

GMP 对象或 int ，或数字string。

exponent

The positive power to raise the num.

GMP 对象或 int ，或数字string。

modulus

The modulo.

GMP 对象或 int ，或数字string。

返回值

The new (raised) number, as a GMP number.

范例

Example #1 gmp_powm() example

<?php
$pow1 = gmp_powm("2", "31", "2147483649");
echo gmp_strval($pow1) . "\n";
?>

以上例程会输出：

2147483648


Check if number is "probably prime"

  • ? gmp_powm
  • gmp_random_bits ?
  • PHP Manual
  • GMP 函数
  • Check if number is "probably prime"

gmp_prob_prime

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_prob_prime — Check if number is "probably prime"

说明

gmp_prob_prime ( GMP|int|string $num , int $repetitions = 10 ) : int

The function uses Miller-Rabin's probabilistic test to check if a number is a prime.

参数

num

The number being checked as a prime.

GMP 对象或 int ，或数字string。

repetitions

Reasonable values of repetitions vary from 5 to 10 (default being 10); a higher value lowers the probability for a non-prime to pass as a "probable" prime.

GMP 对象或 int ，或数字string。

返回值

If this function returns 0, num is definitely not prime. If it returns 1, then num is "probably" prime. If it returns 2, then num is surely prime.

范例

Example #1 gmp_prob_prime() example

<?php
// definitely not a prime
echo gmp_prob_prime("6") . "\n";

// probably a prime
echo gmp_prob_prime("1111111111111111111") . "\n";

// definitely a prime
echo gmp_prob_prime("11") . "\n";
?>

以上例程会输出：

0
1
2


Random number

  • ? gmp_prob_prime
  • gmp_random_range ?
  • PHP Manual
  • GMP 函数
  • Random number

gmp_random_bits

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

gmp_random_bits — Random number

说明

gmp_random_bits ( int $bits ) : GMP

Generate a random number. The number will be between 0 and (2 ** bits) - 1.

bits must greater than 0, and the maximum value is restricted by available memory.

参数

bits

The number of bits.

返回值

A random GMP number.

范例

Example #1 gmp_random_bits() example

<?php
$rand1 = gmp_random_bits(3); // random number from 0 to 7
$rand2 = gmp_random_bits(5); // random number from 0 to 31

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

以上例程会输出：

3
15


Random number

  • ? gmp_random_bits
  • gmp_random_seed ?
  • PHP Manual
  • GMP 函数
  • Random number

gmp_random_range

(PHP 5 >= 5.6.3, PHP 7, PHP 8)

gmp_random_range — Random number

说明

gmp_random_range ( GMP|int|string $min , GMP|int|string $max ) : GMP

Generate a random number. The number will be between min and max.

min and max can both be negative but min must always be less than max.

参数

min

A GMP number representing the lower bound for the random number

max

A GMP number representing the upper bound for the random number

返回值

A random GMP number.

范例

Example #1 gmp_random_range() example

<?php
$rand1 = gmp_random_range(0, 100);    // random number between 0 and 100
$rand2 = gmp_random_range(-100, -10); // random number between -100 and -10

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

以上例程会输出：

42
-67


Sets the RNG seed

  • ? gmp_random_range
  • gmp_random ?
  • PHP Manual
  • GMP 函数
  • Sets the RNG seed

gmp_random_seed

(PHP 7, PHP 8)

gmp_random_seed — Sets the RNG seed

说明

gmp_random_seed ( GMP|int|string $seed ) : void

参数

seed

The seed to be set for the gmp_random(), gmp_random_bits(), and gmp_random_range() functions.

GMP 对象或 int ，或数字string。

返回值

成功时返回 null， 或者在失败时返回 false。

错误／异常

Issues an E_WARNING and returns false if seed is not valid.

范例

Example #1 gmp_random_seed() example

<?php
// set the seed
gmp_random_seed(100);

var_dump(gmp_strval(gmp_random(1)));

// set the seed to something else
gmp_random_seed(gmp_init(-100));

var_dump(gmp_strval(gmp_random_bits(10)));

// set the seed to something invalid
var_dump(gmp_random_seed('not a number'));

以上例程会输出：

string(20) "15370156633245019617"
string(3) "683"

Warning: gmp_random_seed(): Unable to convert variable to GMP - string is not an integer in %s on line %d
bool(false)

参见

  • gmp_init() - Create GMP number
  • gmp_random() - Random number
  • gmp_random_bits() - Random number
  • gmp_random_range() - Random number


Random number

  • ? gmp_random_seed
  • gmp_root ?
  • PHP Manual
  • GMP 函数
  • Random number

gmp_random

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_random — Random number

Warning

本函数已自 PHP 7.2.0 起被废弃，并自 PHP 8.0.0 起被移除。 强烈建议不要依赖本函数。

说明

gmp_random ( int $limiter = 20 ) : GMP

Generate a random number. The number will be between 0 and (2 ** n) - 1, where n is the number of bits per limb multiplied by limiter. If limiter is negative, negative numbers are generated.

A limb is an internal GMP mechanism. The number of bits in a limb is not static, and can vary from system to system. Generally, the number of bits in a limb is either 32 or 64, but this is not guaranteed.

参数

limiter

The limiter.

GMP 对象或 int ，或数字string。

返回值

A random GMP number.

范例

Example #1 gmp_random() example

<?php
$rand1 = gmp_random(1); // random number from 0 to 1 * bits per limb
$rand2 = gmp_random(2); // random number from 0 to 2 * bits per limb

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

以上例程会输出：

1915834968
8642564075890328087


Take the integer part of nth root

  • ? gmp_random
  • gmp_rootrem ?
  • PHP Manual
  • GMP 函数
  • Take the integer part of nth root

gmp_root

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

gmp_root — Take the integer part of nth root

说明

gmp_root ( GMP|int|string $num , int $nth ) : GMP

Takes the nth root of num and returns the integer component of the result.

参数

num

GMP 对象或 int ，或数字string。

nth

The positive root to take of num.

返回值

The integer component of the resultant root, as a GMP number.


Take the integer part and remainder of nth root

  • ? gmp_root
  • gmp_scan0 ?
  • PHP Manual
  • GMP 函数
  • Take the integer part and remainder of nth root

gmp_rootrem

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

gmp_rootrem — Take the integer part and remainder of nth root

说明

gmp_rootrem ( GMP|int|string $num , int $nth ) : array

Takes the nth root of num and returns the integer component and remainder of the result.

参数

num

GMP 对象或 int ，或数字string。

nth

The positive root to take of num.

返回值

A two element array, where the first element is the integer component of the root, and the second element is the remainder, both represented as GMP numbers.


Scan for 0

  • ? gmp_rootrem
  • gmp_scan1 ?
  • PHP Manual
  • GMP 函数
  • Scan for 0

gmp_scan0

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_scan0 — Scan for 0

说明

gmp_scan0 ( GMP|int|string $num1 , int $start ) : int

Scans num1, starting with bit start, towards more significant bits, until the first clear bit is found.

参数

num1

The number to scan.

GMP 对象或 int ，或数字string。

start

The starting bit.

返回值

Returns the index of the found bit, as an int. The index starts from 0.

范例

Example #1 gmp_scan0() example

<?php
// "0" bit is found at position 3. index starts at 0
$s1 = gmp_init("10111", 2);
echo gmp_scan0($s1, 0) . "\n";

// "0" bit is found at position 7. index starts at 5
$s2 = gmp_init("101110000", 2);
echo gmp_scan0($s2, 5) . "\n";
?>

以上例程会输出：

3
7


Scan for 1

  • ? gmp_scan0
  • gmp_setbit ?
  • PHP Manual
  • GMP 函数
  • Scan for 1

gmp_scan1

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_scan1 — Scan for 1

说明

gmp_scan1 ( GMP|int|string $num1 , int $start ) : int

Scans num1, starting with bit start, towards more significant bits, until the first set bit is found.

参数

num1

The number to scan.

GMP 对象或 int ，或数字string。

start

The starting bit.

返回值

Returns the index of the found bit, as an int. If no set bit is found, -1 is returned.

范例

Example #1 gmp_scan1() example

<?php
// "1" bit is found at position 3. index starts at 0
$s1 = gmp_init("01000", 2);
echo gmp_scan1($s1, 0) . "\n";

// "1" bit is found at position 9. index starts at 5
$s2 = gmp_init("01000001111", 2);
echo gmp_scan1($s2, 5) . "\n";
?>

以上例程会输出：

3
9


Set bit

  • ? gmp_scan1
  • gmp_sign ?
  • PHP Manual
  • GMP 函数
  • Set bit

gmp_setbit

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_setbit — Set bit

说明

gmp_setbit ( GMP $num , int $index , bool $value = true ) : void

Sets bit index in num.

参数

num

The value to modify.

GMP 对象或 int ，或数字string。

index

The index of the bit to set. Index 0 represents the least significant bit.

value

True to set the bit (set it to 1/on); false to clear the bit (set it to 0/off).

返回值

GMP 对象。

范例

Example #1 gmp_setbit() example - 0 index

<?php
$a = gmp_init("2"); //
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 0); // 0b10 now becomes 0b11
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

以上例程会输出：

2 -> 0b10
3 -> 0b11

Example #2 gmp_setbit() example - 1 index

<?php
$a = gmp_init("0xfd");
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 1); // index starts at 0
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

以上例程会输出：

253 -> 0b11111101
255 -> 0b11111111

Example #3 gmp_setbit() example - clearing a bit

<?php
$a = gmp_init("0xff");
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 0, false); // clear bit at index 0
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

以上例程会输出：

255 -> 0b11111111
254 -> 0b11111110

注释

Note:

Unlike most of the other GMP functions, gmp_setbit() must be called with a GMP object that already exists (using gmp_init() for example). One will not be automatically created.

参见

  • gmp_clrbit() - Clear bit
  • gmp_testbit() - Tests if a bit is set


Sign of number

  • ? gmp_setbit
  • gmp_sqrt ?
  • PHP Manual
  • GMP 函数
  • Sign of number

gmp_sign

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_sign — Sign of number

说明

gmp_sign ( GMP|int|string $num ) : int

Checks the sign of a number.

参数

num

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to an int.

返回值

Returns 1 if num is positive, -1 if num is negative, and 0 if num is zero.

范例

Example #1 gmp_sign() example

<?php
// positive
echo gmp_sign("500") . "\n";

// negative
echo gmp_sign("-500") . "\n";

// zero
echo gmp_sign("0") . "\n";
?>

以上例程会输出：

1
-1
0

参见

  • gmp_abs() - Absolute value
  • abs() - 绝对值


Calculate square root

  • ? gmp_sign
  • gmp_sqrtrem ?
  • PHP Manual
  • GMP 函数
  • Calculate square root

gmp_sqrt

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_sqrt — Calculate square root

说明

gmp_sqrt ( GMP|int|string $num ) : GMP

Calculates square root of num.

参数

num

GMP 对象或 int ，或数字string。

返回值

The integer portion of the square root, as a GMP number.

范例

Example #1 gmp_sqrt() example

<?php
$sqrt1 = gmp_sqrt("9");
$sqrt2 = gmp_sqrt("7");
$sqrt3 = gmp_sqrt("1524157875019052100");

echo gmp_strval($sqrt1) . "\n";
echo gmp_strval($sqrt2) . "\n";
echo gmp_strval($sqrt3) . "\n";
?>

以上例程会输出：

3
2
1234567890


Square root with remainder

  • ? gmp_sqrt
  • gmp_strval ?
  • PHP Manual
  • GMP 函数
  • Square root with remainder

gmp_sqrtrem

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_sqrtrem — Square root with remainder

说明

gmp_sqrtrem ( GMP|int|string $num ) : array

Calculate the square root of a number, with remainder.

参数

num

The number being square rooted.

GMP 对象或 int ，或数字string。

返回值

Returns array where first element is the integer square root of num and the second is the remainder (i.e., the difference between num and the first element squared).

范例

Example #1 gmp_sqrtrem() example

<?php
list($sqrt1, $sqrt1rem) = gmp_sqrtrem("9");
list($sqrt2, $sqrt2rem) = gmp_sqrtrem("7");
list($sqrt3, $sqrt3rem) = gmp_sqrtrem("1048576");

echo gmp_strval($sqrt1) . ", " . gmp_strval($sqrt1rem) . "\n";
echo gmp_strval($sqrt2) . ", " . gmp_strval($sqrt2rem) . "\n";
echo gmp_strval($sqrt3) . ", " . gmp_strval($sqrt3rem) . "\n";
?>

以上例程会输出：

3, 0
2, 3
1024, 0


Convert GMP number to string

  • ? gmp_sqrtrem
  • gmp_sub ?
  • PHP Manual
  • GMP 函数
  • Convert GMP number to string

gmp_strval

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_strval — Convert GMP number to string

说明

gmp_strval ( GMP|int|string $num , int $base = 10 ) : string

Convert GMP number to string representation in base base. The default base is 10.

参数

num

The GMP number that will be converted to a string.

GMP 对象或 int ，或数字string。

base

The base of the returned number. The default base is 10. Allowed values for the base are from 2 to 62 and -2 to -36.

返回值

The number, as a string.

范例

Example #1 Converting a GMP number to a string

<?php
$a = gmp_init("0x41682179fbf5");
printf("Decimal: %s, 36-based: %s", gmp_strval($a), gmp_strval($a,36));
?>


Subtract numbers

  • ? gmp_strval
  • gmp_testbit ?
  • PHP Manual
  • GMP 函数
  • Subtract numbers

gmp_sub

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_sub — Subtract numbers

说明

gmp_sub ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Subtracts num2 from num1 and returns the result.

参数

num1

The number being subtracted from.

GMP 对象或 int ，或数字string。

num2

The number subtracted from num1.

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

范例

Example #1 gmp_sub() example

<?php
$sub = gmp_sub("281474976710656", "4294967296"); // 2^48 - 2^32
echo gmp_strval($sub) . "\n";
?>

以上例程会输出：

281470681743360


Tests if a bit is set

  • ? gmp_sub
  • gmp_xor ?
  • PHP Manual
  • GMP 函数
  • Tests if a bit is set

gmp_testbit

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gmp_testbit — Tests if a bit is set

说明

gmp_testbit ( GMP|int|string $num , int $index ) : bool

Tests if the specified bit is set.

参数

num

GMP 对象或 int ，或数字string。

index

The bit to test

返回值

Returns true if the bit is set in resource $a, otherwise false.

错误／异常

An E_WARNING level error is issued when index is less than zero, and false is returned.

范例

Example #1 gmp_testbit() example

<?php
$n = gmp_init("1000000");
var_dump(gmp_testbit($n, 1));
gmp_setbit($n, 1);
var_dump(gmp_testbit($n, 1));
?>

以上例程会输出：

bool(false)
bool(true)

参见

  • gmp_setbit() - Set bit
  • gmp_clrbit() - Clear bit


Bitwise XOR

  • ? gmp_testbit
  • GMP ?
  • PHP Manual
  • GMP 函数
  • Bitwise XOR

gmp_xor

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

gmp_xor — Bitwise XOR

说明

gmp_xor ( GMP|int|string $num1 , GMP|int|string $num2 ) : GMP

Calculates bitwise exclusive OR (XOR) of two GMP numbers.

参数

num1

GMP 对象或 int ，或数字string。

num2

GMP 对象或 int ，或数字string。

返回值

GMP 对象。

范例

Example #1 gmp_xor() example

<?php
$xor1 = gmp_init("1101101110011101", 2);
$xor2 = gmp_init("0110011001011001", 2);

$xor3 = gmp_xor($xor1, $xor2);

echo gmp_strval($xor3, 2) . "\n";
?>

以上例程会输出：

1011110111000100


The GMP class

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

简介

A GMP number. These objects support overloaded arithmetic, bitwise and comparison operators.

Note:

No object oriented interface is provided to manipulate GMP objects. Please use the procedural GMP API.

GMP implements Serializable {
}


Mathematical Functions

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Math 函数
    • abs — 绝对值
    • acos — 反余弦
    • acosh — 反双曲余弦
    • asin — 反正弦
    • asinh — 反双曲正弦
    • atan2 — 两个参数的反正切
    • atan — 反正切
    • atanh — 反双曲正切
    • base_convert — 在任意进制之间转换数字
    • bindec — 二进制转换为十进制
    • ceil — 进一法取整
    • cos — 余弦
    • cosh — 双曲余弦
    • decbin — 十进制转换为二进制
    • dechex — 十进制转换为十六进制
    • decoct — 十进制转换为八进制
    • deg2rad — 将角度转换为弧度
    • exp — 计算 e 的指数
    • expm1 — 返回 exp(number) - 1，甚至当 number 的值接近零也能计算出准确结果
    • fdiv — Divides two numbers, according to IEEE 754
    • floor — 舍去法取整
    • fmod — 返回除法的浮点数余数
    • getrandmax — 显示随机数最大的可能值
    • hexdec — 十六进制转换为十进制
    • hypot — 计算一直角三角形的斜边长度
    • intdiv — 对除法结果取整
    • is_finite — 判断是否为有限值
    • is_infinite — 判断是否为无限值
    • is_nan — 判断是否为合法数值
    • lcg_value — 组合线性同余发生器
    • log10 — 以 10 为底的对数
    • log1p — 返回 log(1 + number)，甚至当 number 的值接近零也能计算出准确结果
    • log — 自然对数
    • max — 找出最大值
    • min — 找出最小值
    • mt_getrandmax — 显示随机数的最大可能值
    • mt_rand — 生成更好的随机数
    • mt_srand — 播下一个更好的随机数发生器种子
    • octdec — 八进制转换为十进制
    • pi — 得到圆周率值
    • pow — 指数表达式
    • rad2deg — 将弧度数转换为相应的角度数
    • rand — 产生一个随机整数
    • round — 对浮点数进行四舍五入
    • sin — 正弦
    • sinh — 双曲正弦
    • sqrt — 平方根
    • srand — 播下随机数发生器种子
    • tan — 正切
    • tanh — 双曲正切


简介

These math functions will only handle values within the range of the int and float types on your computer (this corresponds currently to the C types long resp. double). If you need to handle bigger numbers, take a look at the arbitrary precision math functions.

See also the manual page on arithmetic operators.


预定义常量

下列常量作为 PHP 核心的一部分总是可用的。

数学常量
常量名 | 常量值 | 描述
M_PI | 3.14159265358979323846 | Pi
M_E | 2.7182818284590452354 | e
M_LOG2E | 1.4426950408889634074 | log_2 e
M_LOG10E | 0.43429448190325182765 | log_10 e
M_LN2 | 0.69314718055994530942 | log_e 2
M_LN10 | 2.30258509299404568402 | log_e 10
M_PI_2 | 1.57079632679489661923 | pi/2
M_PI_4 | 0.78539816339744830962 | pi/4
M_1_PI | 0.31830988618379067154 | 1/pi
M_2_PI | 0.63661977236758134308 | 2/pi
M_SQRTPI | 1.77245385090551602729 | sqrt(pi) [5.2.0]
M_2_SQRTPI | 1.12837916709551257390 | 2/sqrt(pi)
M_SQRT2 | 1.41421356237309504880 | sqrt(2)
M_SQRT3 | 1.73205080756887729352 | sqrt(3) [5.2.0]
M_SQRT1_2 | 0.70710678118654752440 | 1/sqrt(2)
M_LNPI | 1.14472988584940017414 | log_e(pi) [5.2.0]
M_EULER | 0.57721566490153286061 | Euler constant [5.2.0]
只有常量 M_PI 在 PHP 4.0.0 之前就存在，其它所有常量从 PHP 4.0.0 起开始存在。用 [5.2.0] 标记的常量是在 PHP 5.2.0 中增加的。


Math 函数

Table of Contents

  • abs — 绝对值
  • acos — 反余弦
  • acosh — 反双曲余弦
  • asin — 反正弦
  • asinh — 反双曲正弦
  • atan2 — 两个参数的反正切
  • atan — 反正切
  • atanh — 反双曲正切
  • base_convert — 在任意进制之间转换数字
  • bindec — 二进制转换为十进制
  • ceil — 进一法取整
  • cos — 余弦
  • cosh — 双曲余弦
  • decbin — 十进制转换为二进制
  • dechex — 十进制转换为十六进制
  • decoct — 十进制转换为八进制
  • deg2rad — 将角度转换为弧度
  • exp — 计算 e 的指数
  • expm1 — 返回 exp(number) - 1，甚至当 number 的值接近零也能计算出准确结果
  • fdiv — Divides two numbers, according to IEEE 754
  • floor — 舍去法取整
  • fmod — 返回除法的浮点数余数
  • getrandmax — 显示随机数最大的可能值
  • hexdec — 十六进制转换为十进制
  • hypot — 计算一直角三角形的斜边长度
  • intdiv — 对除法结果取整
  • is_finite — 判断是否为有限值
  • is_infinite — 判断是否为无限值
  • is_nan — 判断是否为合法数值
  • lcg_value — 组合线性同余发生器
  • log10 — 以 10 为底的对数
  • log1p — 返回 log(1 + number)，甚至当 number 的值接近零也能计算出准确结果
  • log — 自然对数
  • max — 找出最大值
  • min — 找出最小值
  • mt_getrandmax — 显示随机数的最大可能值
  • mt_rand — 生成更好的随机数
  • mt_srand — 播下一个更好的随机数发生器种子
  • octdec — 八进制转换为十进制
  • pi — 得到圆周率值
  • pow — 指数表达式
  • rad2deg — 将弧度数转换为相应的角度数
  • rand — 产生一个随机整数
  • round — 对浮点数进行四舍五入
  • sin — 正弦
  • sinh — 双曲正弦
  • sqrt — 平方根
  • srand — 播下随机数发生器种子
  • tan — 正切
  • tanh — 双曲正切


绝对值

  • ? Math 函数
  • acos ?
  • PHP Manual
  • Math 函数
  • 绝对值

abs

(PHP 4, PHP 5, PHP 7, PHP 8)

abs — 绝对值

说明

abs ( mixed $number ) : number

返回参数 number 的绝对值。

参数

number

要处理的数字值

返回值

number 的绝对值。 如果参数 number 是 float，则返回的类型也是 float，否则返回 integer（因为 float 通常比 integer 有更大的取值范围）。

范例

Example #1 abs() 例子

<?php
$abs = abs(-4.2); // $abs = 4.2; (double/float)
$abs2 = abs(5);   // $abs2 = 5; (integer)
$abs3 = abs(-5);  // $abs3 = 5; (integer)
?>

参见

  • gmp_abs() - Absolute value
  • gmp_sign() - Sign of number


反余弦

  • ? abs
  • acosh ?
  • PHP Manual
  • Math 函数
  • 反余弦

acos

(PHP 4, PHP 5, PHP 7, PHP 8)

acos — 反余弦

说明

acos ( float $arg ) : float

返回 arg 的反余弦值，单位是弧度。acos()
是 cos() 的反函数，它的意思是在
acos() 范围里的每个值都是
a==cos(acos(a)) 。

参数

arg

要处理的参数

返回值

arg 的反余弦弧度。

参见

  • cos() - 余弦
  • acosh() - 反双曲余弦
  • asin() - 反正弦
  • atan() - 反正切


反双曲余弦

  • ? acos
  • asin ?
  • PHP Manual
  • Math 函数
  • 反双曲余弦

acosh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

acosh — 反双曲余弦

说明

acosh ( float $arg ) : float

返回 arg 的反双曲余弦值，即，其双曲余弦为 arg 的那个值。

参数

arg

要处理的值

返回值

The inverse hyperbolic cosine of arg

更新日志

版本 | 说明
5.3.0 | This function is now available on all platforms

参见

  • cosh() - 双曲余弦
  • acos() - 反余弦
  • asinh() - 反双曲正弦
  • atanh() - 反双曲正切


反正弦

  • ? acosh
  • asinh ?
  • PHP Manual
  • Math 函数
  • 反正弦

asin

(PHP 4, PHP 5, PHP 7, PHP 8)

asin — 反正弦

说明

asin ( float $arg ) : float

返回 arg 的反正弦值，单位是弧度。asin()
是 sin() 的反函数，它的意思是在
asin() 范围里的每个值都是
a==sin(asin(a)) 。

参数

arg

待处理的参数

返回值

arg 的反正弦弧度。

参见

  • sin() - 正弦
  • asinh() - 反双曲正弦
  • acos() - 反余弦
  • atan() - 反正切


反双曲正弦

  • ? asin
  • atan2 ?
  • PHP Manual
  • Math 函数
  • 反双曲正弦

asinh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

asinh — 反双曲正弦

说明

asinh ( float $arg ) : float

返回 arg 的反双曲正弦值，即，其双曲正弦为 arg 的那个值。

参数

arg

要处理的参数

返回值

返回 arg 的反双曲正弦值

更新日志

版本 | 说明
5.3.0 | 此函数在所有平台上均可用

参见

  • sinh() - 双曲正弦
  • asin() - 反正弦
  • acosh() - 反双曲余弦
  • atanh() - 反双曲正切


两个参数的反正切

  • ? asinh
  • atan ?
  • PHP Manual
  • Math 函数
  • 两个参数的反正切

atan2

(PHP 4, PHP 5, PHP 7, PHP 8)

atan2 — 两个参数的反正切

说明

atan2 ( float $y , float $x ) : float

本函数计算两个变量 x 和 y 的反正切值。和计算 y / x 的反正切相似，只除了两个参数的符号是用来确定结果的象限之外。

本函数的结果为弧度，其值在 -PI 和 PI 之间（包括 -PI 和 PI）。

参数

y

Dividend parameter

x

Divisor parameter

返回值

x 和 y 的反正切弧度值。

参见

  • atan() - 反正切


反正切

  • ? atan2
  • atanh ?
  • PHP Manual
  • Math 函数
  • 反正切

atan

(PHP 4, PHP 5, PHP 7, PHP 8)

atan — 反正切

说明

atan ( float $arg ) : float

返回 arg 的反正切值，单位是弧度。atan() 是
tan() 的反函数，它的意思是在
atan() 范围里的每个值都是
a==tan(atan(a))。

参数

arg

要处理的参数

返回值

arg 的反正切弧度。

参见

  • tan() - 正切
  • atanh() - 反双曲正切
  • asin() - 反正弦
  • acos() - 反余弦


反双曲正切

  • ? atan
  • base_convert ?
  • PHP Manual
  • Math 函数
  • 反双曲正切

atanh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

atanh — 反双曲正切

说明

atanh ( float $arg ) : float

返回 arg 的反双曲正切值，即，其双曲正切为 arg 的那个值。

参数

arg

要处理的参数

返回值

Inverse hyperbolic tangent of arg

更新日志

版本 | 说明
5.3.0 | 此函数在所有平台上都可以用了

参见

  • tanh() - 双曲正切
  • atan() - 反正切
  • asinh() - 反双曲正弦
  • acosh() - 反双曲余弦


在任意进制之间转换数字

  • ? atanh
  • bindec ?
  • PHP Manual
  • Math 函数
  • 在任意进制之间转换数字

base_convert

(PHP 4, PHP 5, PHP 7, PHP 8)

base_convert — 在任意进制之间转换数字

说明

base_convert ( string $number , int $frombase , int $tobase ) : string

返回一字符串，包含 number 以 tobase 进制的表示。number 本身的进制由 frombase 指定。frombase 和 tobase 都只能在 2 和 36 之间（包括 2 和 36）。高于十进制的数字用字母 a-z 表示，例如 a 表示 10，b 表示 11 以及 z 表示 35。

Warning

由于使用内部的 "double" 或 "float" 类型，base_convert() 的操作可能会导致大数值中的精度丢失。请参见本手册的 浮点数 章节以便获得更多详细信息。

参数

number

要转换的数字

frombase

The base number is in

tobase

The base to convert number to

返回值

number converted to base tobase

范例

Example #1 base_convert() 例子

<?php
$hexadecimal = 'A37334';
echo base_convert($hexadecimal, 16, 2);
?>

以上例程会输出：

101000110111001100110100

参见

  • intval() - 获取变量的整数值


二进制转换为十进制

  • ? base_convert
  • ceil ?
  • PHP Manual
  • Math 函数
  • 二进制转换为十进制

bindec

(PHP 4, PHP 5, PHP 7, PHP 8)

bindec — 二进制转换为十进制

说明

bindec ( string $binary_string ) : number

返回 binary_string 参数所表示的二进制数的十进制等价值。

bindec() 将一个二进制数转换成 integer，或者出于大小的需要，转换为 float 类型。

bindec() 将所有的 binary_string 值解释为无符号整数。这是由于 bindec() 函数将其最高有效位视为数量级而非符号位。

参数

binary_string

要转换的二进制字符串

Warning

参数必须为字符串。使用其他数据类型会导致不可预知的结果。

返回值

binary_string 的十进制数值

更新日志

版本 | 说明
4.1.0 | 本函数如今可以转换超过程序运行平台中 integer 类型最大值的数，此时其值会返回为 float 类型。

范例

Example #1 bindec() 例子

<?php
echo bindec('110011') . "\n";
echo bindec('000110011') . "\n";

echo bindec('111');
?>

以上例程会输出：

51
51
7

Example #2 bindec() 将输入解读为无符号整数

<?php
/*
 * The lesson from this example is in the output
 * rather than the PHP code itself.
 */

$magnitude_lower = pow(2, (PHP_INT_SIZE * 8) - 2);
p($magnitude_lower - 1);
p($magnitude_lower, 'See the rollover?  Watch it next time around...');

p(PHP_INT_MAX, 'PHP_INT_MAX');
p(~PHP_INT_MAX, 'interpreted to be one more than PHP_INT_MAX');

if (PHP_INT_SIZE == 4) {
    $note = 'interpreted to be the largest unsigned integer';
} else {
    $note = 'interpreted to be the largest unsigned integer
              (18446744073709551615) but skewed by float precision';
}
p(-1, $note);

function p($input, $note = '') {
    echo "input:        $input\n";

    $format = '%0' . (PHP_INT_SIZE * 8) . 'b';
    $bin = sprintf($format, $input);
    echo "binary:       $bin\n";

    ini_set('precision', 20);  // For readability on 64 bit boxes.
    $dec = bindec($bin);
    echo 'bindec():     ' . $dec . "\n";

    if ($note) {
        echo "NOTE:         $note\n";
    }

    echo "\n";
}
?>

以上例程在 32 位机器上的输出:

input:        1073741823
binary:       00111111111111111111111111111111
bindec():     1073741823

input:        1073741824
binary:       01000000000000000000000000000000
bindec():     1073741824
NOTE:         See the rollover?  Watch it next time around...

input:        2147483647
binary:       01111111111111111111111111111111
bindec():     2147483647
NOTE:         PHP_INT_MAX

input:        -2147483648
binary:       10000000000000000000000000000000
bindec():     2147483648
NOTE:         interpreted to be one more than PHP_INT_MAX

input:        -1
binary:       11111111111111111111111111111111
bindec():     4294967295
NOTE:         interpreted to be the largest unsigned integer

以上例程在 64 位机器上的输出:

input:        4611686018427387903
binary:       0011111111111111111111111111111111111111111111111111111111111111
bindec():     4611686018427387903

input:        4611686018427387904
binary:       0100000000000000000000000000000000000000000000000000000000000000
bindec():     4611686018427387904
NOTE:         See the rollover?  Watch it next time around...

input:        9223372036854775807
binary:       0111111111111111111111111111111111111111111111111111111111111111
bindec():     9223372036854775807
NOTE:         PHP_INT_MAX

input:        -9223372036854775808
binary:       1000000000000000000000000000000000000000000000000000000000000000
bindec():     9223372036854775808
NOTE:         interpreted to be one more than PHP_INT_MAX

input:        -1
binary:       1111111111111111111111111111111111111111111111111111111111111111
bindec():     18446744073709551616
NOTE:         interpreted to be the largest unsigned integer
              (18446744073709551615) but skewed by float precision

参见

  • decbin() - 十进制转换为二进制
  • octdec() - 八进制转换为十进制
  • hexdec() - 十六进制转换为十进制
  • base_convert() - 在任意进制之间转换数字


进一法取整

  • ? bindec
  • cos ?
  • PHP Manual
  • Math 函数
  • 进一法取整

ceil

(PHP 4, PHP 5, PHP 7, PHP 8)

ceil — 进一法取整

说明

ceil ( float $value ) : float

返回不小于 value 的下一个整数，value 如果有小数部分则进一位。

参数

value

要进一法取整的值

返回值

返回不小于 value 的下一个整数。 ceil() 返回的类型仍然是 float，因为 float 值的范围通常比 integer 要大。

范例

Example #1 ceil() 例子

<?php
echo ceil(4.3);    // 5
echo ceil(9.999);  // 10
echo ceil(-3.14);  // -3
?>

参见

  • floor() - 舍去法取整
  • round() - 对浮点数进行四舍五入


余弦

  • ? ceil
  • cosh ?
  • PHP Manual
  • Math 函数
  • 余弦

cos

(PHP 4, PHP 5, PHP 7, PHP 8)

cos — 余弦

说明

cos ( float $arg ) : float

cos() 返回参数 arg 的余弦值。参数 arg 的单位为弧度。

参数

arg

以弧度表示的角度

返回值

arg的余弦值

范例

Example #1 cos() 例子

<?php

echo cos(M_PI); // -1

?>

参见

  • acos() - 反余弦
  • sin() - 正弦
  • tan() - 正切
  • deg2rad() - 将角度转换为弧度


双曲余弦

  • ? cos
  • decbin ?
  • PHP Manual
  • Math 函数
  • 双曲余弦

cosh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

cosh — 双曲余弦

说明

cosh ( float $arg ) : float

返回 arg 的双曲余弦值，定义为 (exp(arg) + exp(-arg))/2。

参数

arg

要处理的参数

返回值

arg 的双曲余弦值。

参见

  • cos() - 余弦
  • acosh() - 反双曲余弦
  • sinh() - 双曲正弦
  • cosh()


十进制转换为二进制

  • ? cosh
  • dechex ?
  • PHP Manual
  • Math 函数
  • 十进制转换为二进制

decbin

(PHP 4, PHP 5, PHP 7, PHP 8)

decbin — 十进制转换为二进制

说明

decbin ( int $number ) : string

返回一字符串，包含有给定 number 参数的二进制表示。所能转换的最大数值为十进制的 4294967295，其结果为 32 个 1 的字符串。

参数

number

Decimal value to convert

Range of inputs on 32-bit machines
positive number | negative number | return value
0 | 0
1 | 1
2 | 10
... normal progression ...
2147483646 | 1111111111111111111111111111110
2147483647 (largest signed integer) | 1111111111111111111111111111111 (31 1's)
2147483648 | -2147483648 | 10000000000000000000000000000000
... normal progression ...
4294967294 | -2 | 11111111111111111111111111111110
4294967295 (largest unsigned integer) | -1 | 11111111111111111111111111111111 (32 1's)
Range of inputs on 64-bit machines
positive number | negative number | return value
0 | 0
1 | 1
2 | 10
... normal progression ...
9223372036854775806 | 111111111111111111111111111111111111111111111111111111111111110
9223372036854775807 (largest signed integer) | 111111111111111111111111111111111111111111111111111111111111111 (63 1's)
-9223372036854775808 | 1000000000000000000000000000000000000000000000000000000000000000
... normal progression ...
-2 | 1111111111111111111111111111111111111111111111111111111111111110
-1 | 1111111111111111111111111111111111111111111111111111111111111111 (64 1's)

返回值

Binary string representation of number

范例

Example #1 decbin() 例子

<?php
echo decbin(12) . "\n";
echo decbin(26);
?>

以上例程会输出：

1100
11010

参见

  • bindec() - 二进制转换为十进制
  • decoct() - 十进制转换为八进制
  • dechex() - 十进制转换为十六进制
  • base_convert() - 在任意进制之间转换数字
  • printf() - 输出格式化字符串, using %b, %032b or %064b as the format
  • sprintf(), using %b, %032b or %064b as the format


十进制转换为十六进制

  • ? decbin
  • decoct ?
  • PHP Manual
  • Math 函数
  • 十进制转换为十六进制

dechex

(PHP 4, PHP 5, PHP 7, PHP 8)

dechex — 十进制转换为十六进制

说明

dechex ( int $number ) : string

返回一字符串，包含有给定 number 参数的十六进制表示。

所能转换的最大数值为十进制的 PHP_INT_MAX * 2 + 1 (或 -1)：在 32 位平台上是十进制的 4294967295，其 dechex() 的结果为 ffffffff。

参数

number

要转换的十进制值

PHP 的 integer 类型是有符号的，但 dechex() 处理无符号整数，负正数会以无符号处理。

返回值

number 的16进制表示

范例

Example #1 dechex() 例子

<?php
echo dechex(10) . "\n";
echo dechex(47);
?>

以上例程会输出：

a
2f

Example #2 大整数的 dechex() 例子

<?php
// The output below assumes a 32-bit platform.
// Note that the output is the same for all values.
echo dechex(-1)."\n";
echo dechex(PHP_INT_MAX * 2 + 1)."\n";
echo dechex(pow(2, 32) - 1)."\n";
?>

以上例程会输出：

ffffffff
ffffffff
ffffffff

参见

  • hexdec() - 十六进制转换为十进制
  • decbin() - 十进制转换为二进制
  • decoct() - 十进制转换为八进制
  • base_convert() - 在任意进制之间转换数字


十进制转换为八进制

  • ? dechex
  • deg2rad ?
  • PHP Manual
  • Math 函数
  • 十进制转换为八进制

decoct

(PHP 4, PHP 5, PHP 7, PHP 8)

decoct — 十进制转换为八进制

说明

decoct ( int $number ) : string

返回一字符串，包含有给定 number 参数的八进制表示。所能转换的最大数值为十进制的 4294967295，其结果为 "37777777777"。

参数

number

待转换的十进制值

返回值

number 参数八进制表示的字符串。

范例

Example #1 decoct() 范例

<?php
echo decoct(15) . "\n";
echo decoct(264);
?>

以上例程会输出：

17
410

参见

  • octdec() - 八进制转换为十进制
  • decbin() - 十进制转换为二进制
  • dechex() - 十进制转换为十六进制
  • base_convert() - 在任意进制之间转换数字


将角度转换为弧度

  • ? decoct
  • exp ?
  • PHP Manual
  • Math 函数
  • 将角度转换为弧度

deg2rad

(PHP 4, PHP 5, PHP 7, PHP 8)

deg2rad — 将角度转换为弧度

说明

deg2rad ( float $number ) : float

本函数把 number 从角度转换成弧度。

参数

number

以角度为单位的值

返回值

number 等量的弧度值

范例

Example #1 deg2rad() 例子

<?php

echo deg2rad(45); // 0.785398163397
var_dump(deg2rad(45) === M_PI_4); // bool(true)

?>

参见

  • rad2deg() - 将弧度数转换为相应的角度数


计算 e 的指数

  • ? deg2rad
  • expm1 ?
  • PHP Manual
  • Math 函数
  • 计算 e 的指数

exp

(PHP 4, PHP 5, PHP 7, PHP 8)

exp — 计算 e 的指数

说明

exp ( float $arg ) : float

返回 e 的 arg 次方值。

Note:

用 'e' 作为自然对数的底 2.718282.

参数

arg

要处理的参数

返回值

'e' raised to the power of arg

范例

Example #1 exp() 例子

<?php
echo exp(12) . "\n";
echo exp(5.7);
?>

以上例程会输出：

1.6275E+005
298.87

参见

  • log() - 自然对数
  • pow() - 指数表达式


返回 exp(number) - 1，甚至当 number 的值接近零也能计算出准确结果

  • ? exp
  • fdiv ?
  • PHP Manual
  • Math 函数
  • 返回 exp(number) - 1，甚至当 number 的值接近零也能计算出准确结果

expm1

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

expm1 — 返回 exp(number) - 1，甚至当 number 的值接近零也能计算出准确结果

说明

expm1 ( float $arg ) : float

expm1() 返回 'exp(number) - 1'，甚至当 number 的值接近零也能计算出准确结果。但是当两个数值趋近于相等的时候， 'exp (number) - 1' 就会变得不太准确。

参数

arg

要处理的参数

返回值

'e' to the power of arg minus one

更新日志

版本 | 说明
5.3.0 | 此函数在所有平台上均可用

参见

  • log1p() - 返回 log(1 + number)，甚至当 number 的值接近零也能计算出准确结果
  • exp() - 计算 e 的指数


Divides two numbers, according to IEEE 754

  • ? expm1
  • floor ?
  • PHP Manual
  • Math 函数
  • Divides two numbers, according to IEEE 754

fdiv

(PHP 8)

fdiv — Divides two numbers, according to IEEE 754

说明

fdiv ( float $num1 , float $num2 ) : float

Returns the floating point result of dividing the num1 by the num2. If the num2 is zero, then one of INF, -INF, or NAN will be returned.

Note that in comparisons, NAN will never == or ===, any value, including itself.

参数

num1

The dividend (numerator)

num2

The divisor

返回值

The floating point result of num1/num2

范例

Example #1 Using fdiv()

<?php
var_dump(fdiv(5.7, 1.3)); // float(4.384615384615385)
var_dump(fdiv(4, 2)); // float(2)
var_dump(fdiv(1.0, 0.0)); // float(INF)
var_dump(fdiv(-1.0, 0.0)); // float(-INF)
var_dump(fdiv(0.0, 0.0)); // float(NAN)
?>

参见

  • / - Floating-point division
  • intdiv() - Integer division
  • fmod() - Modulus


舍去法取整

  • ? fdiv
  • fmod ?
  • PHP Manual
  • Math 函数
  • 舍去法取整

floor

(PHP 4, PHP 5, PHP 7, PHP 8)

floor — 舍去法取整

说明

floor ( float $value ) : float

返回不大于 value 的最接近的整数，舍去小数部分取整。

参数

value

要取整的数字

返回值

返回不大于 value 的最接近的整数，将 value 的小数部分舍去取整。floor() 返回的类型仍然是 float，因为 float 值的范围通常比 integer 要大。

范例

Example #1 floor() 例子

<?php
echo floor(4.3);   // 4
echo floor(9.999); // 9
echo floor(-3.14); // -4
?>

参见

  • ceil() - 进一法取整
  • round() - 对浮点数进行四舍五入


返回除法的浮点数余数

  • ? floor
  • getrandmax ?
  • PHP Manual
  • Math 函数
  • 返回除法的浮点数余数

fmod

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

fmod — 返回除法的浮点数余数

说明

fmod ( float $x , float $y ) : float

返回被除数（x）除以除数（y）所得的浮点数余数。余数（r）的定义是：x = i * y + r，其中 i 是整数。如果 y 是非零值，则 r 和 x 的符号相同并且其数量值小于 y。

参数

x

被除数

y

除数

返回值

x/y的浮点数余数。

范例

Example #1 fmod() 的使用

<?php
$x = 5.7;
$y = 1.3;
$r = fmod($x, $y);
// $r equals 0.5, because 4 * 1.3 + 0.5 = 5.7
?>


显示随机数最大的可能值

  • ? fmod
  • hexdec ?
  • PHP Manual
  • Math 函数
  • 显示随机数最大的可能值

getrandmax

(PHP 4, PHP 5, PHP 7, PHP 8)

getrandmax — 显示随机数最大的可能值

说明

getrandmax ( ) : int

返回调用 rand() 可能返回的最大值。

返回值

rand() 返回 随机数可能返回的最大值

参见

  • rand() - 产生一个随机整数
  • srand() - 播下随机数发生器种子
  • mt_getrandmax() - 显示随机数的最大可能值


十六进制转换为十进制

  • ? getrandmax
  • hypot ?
  • PHP Manual
  • Math 函数
  • 十六进制转换为十进制

hexdec

(PHP 4, PHP 5, PHP 7, PHP 8)

hexdec — 十六进制转换为十进制

说明

hexdec ( string $hex_string ) : number

返回与 hex_string 参数所表示的十六进制数等值的的十进制数。hexdec() 将一个十六进制字符串转换为十进制数。

hexdec() 会忽略它遇到的任意非十六进制的字符。

参数

hex_string

要转换的十六进制的字符串

返回值

hex_string 十进制的表示

更新日志

版本 | 说明
4.1.0 | PHP 4.1.0 开始，该函数可以处理 integer 大数字，这种情况下，它会返回 float 类型。

范例

Example #1 hexdec() 例子

<?php
var_dump(hexdec("See"));
var_dump(hexdec("ee"));
// both print "int(238)"

var_dump(hexdec("that")); // print "int(10)"
var_dump(hexdec("a0")); // print "int(160)"
?>

参见

  • dechex() - 十进制转换为十六进制
  • bindec() - 二进制转换为十进制
  • octdec() - 八进制转换为十进制
  • base_convert() - 在任意进制之间转换数字


计算一直角三角形的斜边长度

  • ? hexdec
  • intdiv ?
  • PHP Manual
  • Math 函数
  • 计算一直角三角形的斜边长度

hypot

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

hypot — 计算一直角三角形的斜边长度

说明

hypot ( float $x , float $y ) : float

hypot() 函数将会跟据直角三角形的两直解边长度 x 和 y 计算其斜边的长度。或者是从标点 (x, y) 到原点的距离。该函数的算法等同于 sqrt(x*x + y*y)。

参数

x

第一条边的长度

y

第二条边的长度

返回值

计算斜边的长度


对除法结果取整

  • ? hypot
  • is_finite ?
  • PHP Manual
  • Math 函数
  • 对除法结果取整

intdiv

(PHP 7, PHP 8)

intdiv — 对除法结果取整

说明

intdiv ( int $dividend , int $divisor ) : int

返回 dividend 除以 divisor 商数的整数部分。

参数

dividend

被除数。

divisor

除数。

返回值

dividend 除以 divisor 的商，对该商取整。

错误／异常

如果 divisor 是 0，将抛出 DivisionByZeroError 异常。 如果 dividend 是 PHP_INT_MIN 并且 divisor 是 -1，将抛出 ArithmeticError 异常.

范例

Example #1 intdiv() 的一些例子

<?php
var_dump(intdiv(3, 2));
var_dump(intdiv(-3, 2));
var_dump(intdiv(3, -2));
var_dump(intdiv(-3, -2));
var_dump(intdiv(PHP_INT_MAX, PHP_INT_MAX));
var_dump(intdiv(PHP_INT_MIN, PHP_INT_MIN));
var_dump(intdiv(PHP_INT_MIN, -1));
var_dump(intdiv(1, 0));
?>
int(1)
int(-1)
int(-1)
int(1)
int(1)
int(1)

Fatal error: Uncaught ArithmeticError: Division of PHP_INT_MIN by -1 is not an integer in %s on line 8
Fatal error: Uncaught DivisionByZeroError: Division by zero in %s on line 9


判断是否为有限值

  • ? intdiv
  • is_infinite ?
  • PHP Manual
  • Math 函数
  • 判断是否为有限值

is_finite

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

is_finite — 判断是否为有限值

说明

is_finite ( float $val ) : bool

检查 val 是否是是本机平台上浮点数所允许范围中的一个合法的有限值。

参数

val

要检查的值

返回值

如果 val 是本机平台上 PHP 浮点数所允许范围中的一个合法的有限值，则返回 true。

参见

  • is_infinite() - 判断是否为无限值
  • is_nan() - 判断是否为合法数值


判断是否为无限值

  • ? is_finite
  • is_nan ?
  • PHP Manual
  • Math 函数
  • 判断是否为无限值

is_infinite

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

is_infinite — 判断是否为无限值

说明

is_infinite ( float $val ) : bool

如果 val 为无穷大（正的或负的），例如 log(0) 的结果或者任何超出本平台的浮点数范围的值，则返回 true。

参数

val

要检查的值

返回值

如果 val 为无穷大返回 true，否则返回 false。

参见

  • is_finite() - 判断是否为有限值
  • is_nan() - 判断是否为合法数值


判断是否为合法数值

  • ? is_infinite
  • lcg_value ?
  • PHP Manual
  • Math 函数
  • 判断是否为合法数值

is_nan

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

is_nan — 判断是否为合法数值

说明

is_nan ( float $val ) : bool

如果 val 为"非数值"，例如 acos(1.01) 的结果，则返回 true。

参数

val

要检查的值

返回值

如果 val 不是一个数字（not a number）返回 true，否则返回 false。

范例

Example #1 is_nan() 例子

<?php
// Invalid calculation, will return a
// NaN value
$nan = acos(8);

var_dump($nan, is_nan($nan));
?>

以上例程会输出：

float(NAN)
bool(true)

参见

  • is_finite() - 判断是否为有限值
  • is_infinite() - 判断是否为无限值


组合线性同余发生器

  • ? is_nan
  • log10 ?
  • PHP Manual
  • Math 函数
  • 组合线性同余发生器

lcg_value

(PHP 4, PHP 5, PHP 7, PHP 8)

lcg_value — 组合线性同余发生器

说明

lcg_value ( ) : float

lcg_value() 返回范围为 (0, 1) 的一个伪随机数。本函数组合了周期为 2^31 - 85 和 2^31 - 249 的两个同余发生器。本函数的周期等于这两个素数的乘积。

返回值

范围为 (0, 1) 的伪随机数。

参见

  • rand() - 产生一个随机整数
  • mt_rand() - 生成更好的随机数


以 10 为底的对数

  • ? lcg_value
  • log1p ?
  • PHP Manual
  • Math 函数
  • 以 10 为底的对数

log10

(PHP 4, PHP 5, PHP 7, PHP 8)

log10 — 以 10 为底的对数

说明

log10 ( float $arg ) : float

返回参数 arg 以 10 为底的对数。

参数

arg

要处理的参数

返回值

arg 以 10 为底的对数。

参见

  • log() - 自然对数


返回 log(1 + number)，甚至当 number 的值接近零也能计算出准确结果

  • ? log10
  • log ?
  • PHP Manual
  • Math 函数
  • 返回 log(1 + number)，甚至当 number 的值接近零也能计算出准确结果

log1p

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

log1p — 返回 log(1 + number)，甚至当 number 的值接近零也能计算出准确结果

说明

log1p ( float $number ) : float

log1p() 返回 log(1 + number)，甚至当 number 的值接近零也能计算出准确结果。 log() might only return log(1) in this case due to lack of precision.

参数

number

要处理的参数

返回值

log(1 + number)

更新日志

版本 | 说明
5.3.0 | 此函数在所有平台上均可用

参见

  • expm1() - 返回 exp(number) - 1，甚至当 number 的值接近零也能计算出准确结果
  • log() - 自然对数
  • log10() - 以 10 为底的对数


自然对数

  • ? log1p
  • max ?
  • PHP Manual
  • Math 函数
  • 自然对数

log

(PHP 4, PHP 5, PHP 7, PHP 8)

log — 自然对数

说明

log ( float $arg , float $base = M_E ) : float

如果指定了可选的参数 base，log() 返回 logbase arg，否则 log() 返回参数 arg 的自然对数。

参数

arg

要计算对数的值

base

The optional logarithmic base to use (defaults to 'e' and so to the natural logarithm).

返回值

返回 logbase arg，或者它的自然对数。

更新日志

版本 | 说明
4.3.0 | 可选参数 base可用。 你可以计算任意以 b 为底 n 的对数，但其实使用的是数学等式：logb(n) = log(n)/log(b)，其中 log 是自然对数。

参见

  • log10() - 以 10 为底的对数
  • exp() - 计算 e 的指数
  • pow() - 指数表达式


找出最大值

  • ? log
  • min ?
  • PHP Manual
  • Math 函数
  • 找出最大值

max

(PHP 4, PHP 5, PHP 7, PHP 8)

max — 找出最大值

说明

max ( array $values ) : mixed
max ( mixed $value1 , mixed $value2 , mixed $... = ? ) : mixed

如果仅有一个参数且为数组，max() 返回该数组中最大的值。如果第一个参数是整数、字符串或浮点数，则至少需要两个参数而 max() 会返回这些值中最大的一个。可以比较无限多个值。

Note:

PHP 会将非数值的 string 当成 0，但如果这个正是最大的数值则仍然会返回一个字符串。如果多个参数都求值为 0 且是最大值，max() 会返回其中数值的 0，如果参数中没有数值的 0，则返回按字母表顺序最大的字符串。

参数

values

包含了多个值的数组。

value1

Any comparable value.

value2

Any comparable value.

...

Any comparable value.

返回值

max() 返回参数中数值最大的值。 If multiple values can be considered of the same size, the one that is listed first will be returned.

When max() is given multiple arrays, the longest array is returned. If all the arrays have the same length, max() will use lexicographic ordering to find the return value.

When given a string it will be cast as an integer when comparing.

范例

Example #1 使用 max() 的例子

<?php
echo max(1, 3, 5, 6, 7);  // 7
echo max(array(2, 4, 5)); // 5

// When 'hello' is cast as integer it will be 0. Both the parameters are equally
// long, so the order they are given in determines the result
echo max(0, 'hello');     // 0
echo max('hello', 0);     // hello

echo max('42', 3); // '42'

// Here 0 > -1, so 'hello' is the return value.
echo max(-1, 'hello');    // hello

// With multiple arrays of different lengths, max returns the longest
$val = max(array(2, 2, 2), array(1, 1, 1, 1)); // array(1, 1, 1, 1)

// 对多个数组，max 从左向右比较。
   // 因此在本例中：2 == 2，但 4 < 5
$val = max(array(2, 4, 8), array(2, 5, 7)); // array(2, 5, 7)

// 如果同时给出数组和非数组作为参数，则总是将数组视为
   // 最大值返回
$val = max('string', array(2, 5, 7), 42);   // array(2, 5, 7)
?>

参见

  • min() - 找出最小值
  • count() - 计算数组中的单元数目，或对象中的属性个数


找出最小值

  • ? max
  • mt_getrandmax ?
  • PHP Manual
  • Math 函数
  • 找出最小值

min

(PHP 4, PHP 5, PHP 7, PHP 8)

min — 找出最小值

说明

min ( array $values ) : mixed
min ( mixed $value1 , mixed $value2 , mixed $... = ? ) : mixed

如果仅有一个参数且为数组，min() 返回该数组中最小的值。如果给出了两个或更多参数, min() 会返回这些值中最小的一个。

Note:

PHP 会将非数值的 string 当成 0，但如果这个正是最小的数值则仍然会返回一个字符串。如果多个参数都求值为 0 且是最小值，min() 会返回按字母表顺序最小的字符串，如果其中没有字符串的话，则返回数值的 0。

参数

values

包含值的数组。

value1

Any comparable value.

value2

Any comparable value.

...

Any comparable value.

返回值

min() 返回参数中数值最小的。

范例

Example #1 min() 用法的例子

<?php
echo min(2, 3, 1, 6, 7);  // 1
echo min(array(2, 4, 5)); // 2

echo min(0, 'hello');     // 0
echo min('hello', 0);     // hello
echo min('hello', -1);    // -1

// 对多个数组，min 从左向右比较。
// 因此在本例中：2 == 2，但 4 < 5
$val = min(array(2, 4, 8), array(2, 5, 1)); // array(2, 4, 8)

// 如果同时给出数组和非数组作为参数，则不可能返回数组，因为
// 数组被视为最大的
$val = min('string', array(2, 5, 7), 42);   // string
?>

参见

  • max() - 找出最大值
  • count() - 计算数组中的单元数目，或对象中的属性个数


显示随机数的最大可能值

  • ? min
  • mt_rand ?
  • PHP Manual
  • Math 函数
  • 显示随机数的最大可能值

mt_getrandmax

(PHP 4, PHP 5, PHP 7, PHP 8)

mt_getrandmax — 显示随机数的最大可能值

说明

mt_getrandmax ( ) : int

返回调用 mt_rand() 所能返回的最大的随机数。

返回值

返回调用 mt_rand() 所能返回的最大的随机数。

范例

Example #1 计算一个随机浮点数

<?php
function randomFloat($min = 0, $max = 1) {
    return $min + mt_rand() / mt_getrandmax() * ($max - $min);
}

var_dump(randomFloat());
var_dump(randomFloat(2, 20));
?>

以上例程的输出类似于：

float(0.91601131712832)
float(16.511210331931)

参见

  • mt_rand() - 生成更好的随机数
  • mt_srand() - 播下一个更好的随机数发生器种子
  • getrandmax() - 显示随机数最大的可能值


生成更好的随机数

  • ? mt_getrandmax
  • mt_srand ?
  • PHP Manual
  • Math 函数
  • 生成更好的随机数

mt_rand

(PHP 4, PHP 5, PHP 7, PHP 8)

mt_rand — 生成更好的随机数

说明

mt_rand ( ) : int
mt_rand ( int $min , int $max ) : int

很多老的 libc 的随机数发生器具有一些不确定和未知的特性而且很慢。PHP 的 rand() 函数默认使用 libc 随机数发生器。mt_rand() 函数是非正式用来替换它的。该函数用了 » Mersenne Twister 中已知的特性作为随机数发生器，它可以产生随机数值的平均速度比 libc 提供的 rand() 快四倍。

如果没有提供可选参数 min 和 max，mt_rand() 返回 0 到 mt_getrandmax() 之间的伪随机数。例如想要 5 到 15（包括 5 和 15）之间的随机数，用 mt_rand(5, 15)。

参数

min

可选的、返回的最小值（默认：0）

max

可选的、返回的最大值（默认：mt_getrandmax()）

返回值

返回 min （或者 0） 到 max （或者是到 mt_getrandmax() ，包含这个值）之间的随机整数。

更新日志

版本 | 说明
4.2.0 | 随机数发生器自动进行播种。

范例

Example #1 mt_rand() 例子

<?php
echo mt_rand() . "\n";
echo mt_rand() . "\n";

echo mt_rand(5, 15);
?>

以上例程的输出类似于：

1604716014
1478613278
6

注释

Caution

The distribution of mt_rand() return values is biased towards even numbers on 64-bit builds of PHP when max is beyond 2^32.

参见

  • mt_srand() - 播下一个更好的随机数发生器种子
  • mt_getrandmax() - 显示随机数的最大可能值
  • rand() - 产生一个随机整数


播下一个更好的随机数发生器种子

  • ? mt_rand
  • octdec ?
  • PHP Manual
  • Math 函数
  • 播下一个更好的随机数发生器种子

mt_srand

(PHP 4, PHP 5, PHP 7, PHP 8)

mt_srand — 播下一个更好的随机数发生器种子

说明

mt_srand ( int $seed = ? ) : void

用 seed 来给随机数发生器播种。 没有设定 seed 参数时，会被设为随时数。

Note: 不再需要用 srand() 或 mt_srand() 给随机数发生器播种，因为现在是由系统自动完成的。

参数

seed

可选的种子值

返回值

没有返回值。

更新日志

版本 | 说明
4.2.0 | The seed becomes optional and defaults to a random value if omitted.
5.2.1 | The Mersenne Twister implementation in PHP now uses a new seeding algorithm by Richard Wagner. Identical seeds no longer produce the same sequence of values they did in previous versions. This behavior is not expected to change again, but it is considered unsafe to rely upon it nonetheless.

范例

Example #1 mt_srand() 例子

<?php
// seed with microseconds
function make_seed()
{
  list($usec, $sec) = explode(' ', microtime());
  return (float) $sec + ((float) $usec * 100000);
}
mt_srand(make_seed());
$randval = mt_rand();
?>

参见

  • mt_rand() - 生成更好的随机数
  • mt_getrandmax() - 显示随机数的最大可能值
  • srand() - 播下随机数发生器种子


八进制转换为十进制

  • ? mt_srand
  • pi ?
  • PHP Manual
  • Math 函数
  • 八进制转换为十进制

octdec

(PHP 4, PHP 5, PHP 7, PHP 8)

octdec — 八进制转换为十进制

说明

octdec ( string $octal_string ) : number

返回 octal_string 参数所表示的八进制数的十进制等值。

参数

octal_string

要转换的八进制的字符串

返回值

octal_string 的十进制的表示

更新日志

版本 | 说明
4.1.0 | 该函数可以处理 integer 大数字，这种情况下，它会返回 float 类型。

范例

Example #1 octdec() 例子

<?php
echo octdec('77') . "\n";
echo octdec(decoct(45));
?>

以上例程会输出：

63
45

参见

  • decoct() - 十进制转换为八进制
  • bindec() - 二进制转换为十进制
  • hexdec() - 十六进制转换为十进制
  • base_convert() - 在任意进制之间转换数字


得到圆周率值

  • ? octdec
  • pow ?
  • PHP Manual
  • Math 函数
  • 得到圆周率值

pi

(PHP 4, PHP 5, PHP 7, PHP 8)

pi — 得到圆周率值

说明

pi ( ) : float

返回圆周率的近似值。返回值的 float 精度是由 php.ini 中的 precision 指令确定。默认值是 14。你也可以使用 M_PI 常量，该常量产生与 pi() 完全相同的结果。

返回值

圆周率（pi）的浮点近似值。

范例

Example #1 pi() 例子

<?php
echo pi(); // 3.1415926535898
echo M_PI; // 3.1415926535898
?>


指数表达式

  • ? pi
  • rad2deg ?
  • PHP Manual
  • Math 函数
  • 指数表达式

pow

(PHP 4, PHP 5, PHP 7, PHP 8)

pow — 指数表达式

说明

pow ( number $base , number $exp ) : number

返回 base 的 exp 次方的幂。如果可能，本函数会返回 integer。

参数

base

The base to use

exp

指数

返回值

base 的 exp 次方的幂。 If both arguments are non-negative integers and the result can be represented as an integer, the result will be returned with integer type, otherwise it will be returned as a float.

更新日志

版本 | 说明
4.2.0 | 如果不能计算幂，将发出一条警告，pow() 将返回 false。pow() 开始不产生任何的警告。
4.0.6 | 如果可能函数现在会返回 integer 的结果，之前 总是返回 float，For older versions, you may receive a bogus result for complex numbers.

范例

Example #1 pow() 的一些例子

<?php

var_dump(pow(2, 8)); // int(256)
echo pow(-1, 20); // 1
echo pow(0, 0); // 1

echo pow(-1, 5.5); // PHP >4.0.6  NAN
echo pow(-1, 5.5); // PHP <=4.0.6 1.#IND
?>

注释

Note:

本函数会转换所有输入为数字，即使是非标量值，会导致怪异的（weird）结果。

参见

  • exp() - 计算 e 的指数
  • sqrt() - 平方根
  • bcpow() - 任意精度数字的乘方
  • gmp_pow() - Raise number into power


将弧度数转换为相应的角度数

  • ? pow
  • rand ?
  • PHP Manual
  • Math 函数
  • 将弧度数转换为相应的角度数

rad2deg

(PHP 4, PHP 5, PHP 7, PHP 8)

rad2deg — 将弧度数转换为相应的角度数

说明

rad2deg ( float $number ) : float

本函数将 number 从弧度转换为角度。

参数

number

一个弧度值

返回值

number 相应的角度数

范例

Example #1 rad2deg() 例子

<?php

echo rad2deg(M_PI_4); // 45

?>

参见

  • deg2rad() - 将角度转换为弧度


产生一个随机整数

  • ? rad2deg
  • round ?
  • PHP Manual
  • Math 函数
  • 产生一个随机整数

rand

(PHP 4, PHP 5, PHP 7, PHP 8)

rand — 产生一个随机整数

说明

rand ( ) : int
rand ( int $min , int $max ) : int

如果没有提供可选参数 min 和 max，rand() 返回 0 到 getrandmax() 之间的伪随机整数。例如想要 5 到 15（包括 5 和 15）之间的随机数，用 rand(5, 15)。

Note: 在某些平台下（例如 Windows）getrandmax() 只有 32767。如果需要的范围大于 32767，那么指定 min 和 max 参数就可以生成更大的数了，或者考虑用 mt_rand() 来替代之。

参数

min

返回的最低值（默认：0）

max

返回的最高值（默认：getrandmax()）

返回值

A pseudo random value between min (or 0) and max (or getrandmax(), inclusive).

更新日志

版本 | 说明
4.2.0 | 随机数发生器自动进行播种。

范例

Example #1 rand() 例子

<?php
echo rand() . "\n";
echo rand() . "\n";

echo rand(5, 15);
?>

以上例程的输出类似于：

7771
22264
11

参见

  • srand() - 播下随机数发生器种子
  • getrandmax() - 显示随机数最大的可能值
  • mt_rand() - 生成更好的随机数


对浮点数进行四舍五入

  • ? rand
  • sin ?
  • PHP Manual
  • Math 函数
  • 对浮点数进行四舍五入

round

(PHP 4, PHP 5, PHP 7, PHP 8)

round — 对浮点数进行四舍五入

说明

round ( float $val , int $precision = 0 , int $mode = PHP_ROUND_HALF_UP ) : float

返回将 val 根据指定精度 precision（十进制小数点后数字的数目）进行四舍五入的结果。precision 也可以是负数或零（默认值）。

Note: PHP 默认不能正确处理类似 "12,300.2" 的字符串。见字符串转换为数值。

参数

val

要处理的值

precision

可选的十进制小数点后数字的数目。

mode

以下之一： PHP_ROUND_HALF_UP、 PHP_ROUND_HALF_DOWN PHP_ROUND_HALF_EVEN 或 PHP_ROUND_HALF_ODD

返回值

四舍五入后的值

范例

Example #1 round() 例子

<?php
echo round(3.4);         // 3
echo round(3.5);         // 4
echo round(3.6);         // 4
echo round(3.6, 0);      // 4
echo round(1.95583, 2);  // 1.96
echo round(1241757, -3); // 1242000
echo round(5.045, 2);    // 5.05
echo round(5.055, 2);    // 5.06
?>

Example #2 mode 例子

<?php
echo round(9.5, 0, PHP_ROUND_HALF_UP);   // 10
echo round(9.5, 0, PHP_ROUND_HALF_DOWN); // 9
echo round(9.5, 0, PHP_ROUND_HALF_EVEN); // 10
echo round(9.5, 0, PHP_ROUND_HALF_ODD);  // 9

echo round(8.5, 0, PHP_ROUND_HALF_UP);   // 9
echo round(8.5, 0, PHP_ROUND_HALF_DOWN); // 8
echo round(8.5, 0, PHP_ROUND_HALF_EVEN); // 8
echo round(8.5, 0, PHP_ROUND_HALF_ODD);  // 9
?>

更新日志

版本 | 说明
5.3.0 | 引入了 mode 参数
5.2.7 | round() 的内部运作修改符合 C99 的标准。

参见

  • ceil() - 进一法取整
  • floor() - 舍去法取整
  • number_format() - 以千位分隔符方式格式化一个数字


正弦

  • ? round
  • sinh ?
  • PHP Manual
  • Math 函数
  • 正弦

sin

(PHP 4, PHP 5, PHP 7, PHP 8)

sin — 正弦

说明

sin ( float $arg ) : float

sin() 返回参数 arg 的正弦值。参数 arg 的单位为弧度。

参数

arg

单位是弧度的值。

返回值

arg 的正弦值

范例

Example #1 sin() 例子

<?php

// 返回值的精度由配置中的 precision 指示确定
echo sin(deg2rad(60));  //  0.866025403 ...
echo sin(60);           // -0.304810621 ...

?>

参见

  • asin() - 反正弦
  • sinh() - 双曲正弦
  • cos() - 余弦
  • tan() - 正切
  • deg2rad() - 将角度转换为弧度


双曲正弦

  • ? sin
  • sqrt ?
  • PHP Manual
  • Math 函数
  • 双曲正弦

sinh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

sinh — 双曲正弦

说明

sinh ( float $arg ) : float

返回 arg 的双曲正弦值，定义为 (exp(arg) - exp(-arg))/2。

参数

arg

要处理的参数

返回值

arg 的双曲正弦值

参见

  • sin() - 正弦
  • asinh() - 反双曲正弦
  • cosh() - 双曲余弦
  • tanh() - 双曲正切


平方根

  • ? sinh
  • srand ?
  • PHP Manual
  • Math 函数
  • 平方根

sqrt

(PHP 4, PHP 5, PHP 7, PHP 8)

sqrt — 平方根

说明

sqrt ( float $arg ) : float

返回 arg 的平方根。

参数

arg

要处理的参数

返回值

返回 arg 的平方根，负数时返回 NAN。

范例

Example #1 sqrt() 例子

<?php
// Precision depends on your precision directive
echo sqrt(9); // 3
echo sqrt(10); // 3.16227766 ...
?>

参见

  • pow() - 指数表达式


播下随机数发生器种子

  • ? sqrt
  • tan ?
  • PHP Manual
  • Math 函数
  • 播下随机数发生器种子

srand

(PHP 4, PHP 5, PHP 7, PHP 8)

srand — 播下随机数发生器种子

说明

srand ( int $seed = ? ) : void

用 seed 播下随机数发生器种子。seed 参数没有给出时，会被设为随时数。

Note: 不再需要用 srand() 或 mt_srand() 给随机数发生器播种，因为现在是由系统自动完成的。

参数

seed

可选的种子值

返回值

没有返回值。

更新日志

版本 | 说明
Since 4.2.0 | seed 成为可选，省略时会默认使用随机值。

范例

Example #1 srand() 例子

<?php
// seed with microseconds
function make_seed()
{
  list($usec, $sec) = explode(' ', microtime());
  return (float) $sec + ((float) $usec * 100000);
}
srand(make_seed());
$randval = rand();
?>

参见

  • rand() - 产生一个随机整数
  • getrandmax() - 显示随机数最大的可能值
  • mt_srand() - 播下一个更好的随机数发生器种子


正切

  • ? srand
  • tanh ?
  • PHP Manual
  • Math 函数
  • 正切

tan

(PHP 4, PHP 5, PHP 7, PHP 8)

tan — 正切

说明

tan ( float $arg ) : float

tan() 返回参数 arg 的正切值。参数 arg 的单位为弧度。

参数

arg

要处理的以弧度为单位的参数

返回值

arg 的正切值

范例

Example #1 tan() 例子

<?php

echo tan(M_PI_4); // 1

?>

参见

  • atan() - 反正切
  • atan2() - 两个参数的反正切
  • sin() - 正弦
  • cos() - 余弦
  • tanh() - 双曲正切
  • deg2rad() - 将角度转换为弧度


双曲正切

  • ? tan
  • Statistics ?
  • PHP Manual
  • Math 函数
  • 双曲正切

tanh

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

tanh — 双曲正切

说明

tanh ( float $arg ) : float

返回 arg 的双曲正切值，定义为 sinh(arg)/cosh(arg)。

参数

arg

要处理的参数

返回值

arg 的双曲正切值

参见

  • tan() - 正切
  • atanh() - 反双曲正切
  • sinh() - 双曲正弦
  • cosh() - 双曲余弦


Statistics

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Statistic 函数
    • stats_absolute_deviation — Returns the absolute deviation of an array of values
    • stats_cdf_beta — Calculates any one parameter of the beta distribution given values for the others
    • stats_cdf_binomial — Calculates any one parameter of the binomial distribution given values for the others
    • stats_cdf_cauchy — Calculates any one parameter of the Cauchy distribution given values for the others
    • stats_cdf_chisquare — Calculates any one parameter of the chi-square distribution given values for the others
    • stats_cdf_exponential — Calculates any one parameter of the exponential distribution given values for the others
    • stats_cdf_f — Calculates any one parameter of the F distribution given values for the others
    • stats_cdf_gamma — Calculates any one parameter of the gamma distribution given values for the others
    • stats_cdf_laplace — Calculates any one parameter of the Laplace distribution given values for the others
    • stats_cdf_logistic — Calculates any one parameter of the logistic distribution given values for the others
    • stats_cdf_negative_binomial — Calculates any one parameter of the negative binomial distribution given values for the others
    • stats_cdf_noncentral_chisquare — Calculates any one parameter of the non-central chi-square distribution given values for the others
    • stats_cdf_noncentral_f — Calculates any one parameter of the non-central F distribution given values for the others
    • stats_cdf_noncentral_t — Calculates any one parameter of the non-central t-distribution give values for the others
    • stats_cdf_normal — Calculates any one parameter of the normal distribution given values for the others
    • stats_cdf_poisson — Calculates any one parameter of the Poisson distribution given values for the others
    • stats_cdf_t — Calculates any one parameter of the t-distribution given values for the others
    • stats_cdf_uniform — Calculates any one parameter of the uniform distribution given values for the others
    • stats_cdf_weibull — Calculates any one parameter of the Weibull distribution given values for the others
    • stats_covariance — Computes the covariance of two data sets
    • stats_dens_beta — Probability density function of the beta distribution
    • stats_dens_cauchy — Probability density function of the Cauchy distribution
    • stats_dens_chisquare — Probability density function of the chi-square distribution
    • stats_dens_exponential — Probability density function of the exponential distribution
    • stats_dens_f — Probability density function of the F distribution
    • stats_dens_gamma — Probability density function of the gamma distribution
    • stats_dens_laplace — Probability density function of the Laplace distribution
    • stats_dens_logistic — Probability density function of the logistic distribution
    • stats_dens_normal — Probability density function of the normal distribution
    • stats_dens_pmf_binomial — Probability mass function of the binomial distribution
    • stats_dens_pmf_hypergeometric — Probability mass function of the hypergeometric distribution
    • stats_dens_pmf_negative_binomial — Probability mass function of the negative binomial distribution
    • stats_dens_pmf_poisson — Probability mass function of the Poisson distribution
    • stats_dens_t — Probability density function of the t-distribution
    • stats_dens_uniform — Probability density function of the uniform distribution
    • stats_dens_weibull — Probability density function of the Weibull distribution
    • stats_harmonic_mean — Returns the harmonic mean of an array of values
    • stats_kurtosis — Computes the kurtosis of the data in the array
    • stats_rand_gen_beta — Generates a random deviate from the beta distribution
    • stats_rand_gen_chisquare — Generates a random deviate from the chi-square distribution
    • stats_rand_gen_exponential — Generates a random deviate from the exponential distribution
    • stats_rand_gen_f — Generates a random deviate from the F distribution
    • stats_rand_gen_funiform — Generates uniform float between low (exclusive) and high (exclusive)
    • stats_rand_gen_gamma — Generates a random deviate from the gamma distribution
    • stats_rand_gen_ibinomial_negative — Generates a random deviate from the negative binomial distribution
    • stats_rand_gen_ibinomial — Generates a random deviate from the binomial distribution
    • stats_rand_gen_int — Generates random integer between 1 and 2147483562
    • stats_rand_gen_ipoisson — Generates a single random deviate from a Poisson distribution
    • stats_rand_gen_iuniform — Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)
    • stats_rand_gen_noncentral_chisquare — Generates a random deviate from the non-central chi-square distribution
    • stats_rand_gen_noncentral_f — Generates a random deviate from the noncentral F distribution
    • stats_rand_gen_noncentral_t — Generates a single random deviate from a non-central t-distribution
    • stats_rand_gen_normal — Generates a single random deviate from a normal distribution
    • stats_rand_gen_t — Generates a single random deviate from a t-distribution
    • stats_rand_get_seeds — Get the seed values of the random number generator
    • stats_rand_phrase_to_seeds — Generate two seeds for the RGN random number generator
    • stats_rand_ranf — Generates a random floating point number between 0 and 1
    • stats_rand_setall — Set seed values to the random generator
    • stats_skew — Computes the skewness of the data in the array
    • stats_standard_deviation — Returns the standard deviation
    • stats_stat_binomial_coef — Returns a binomial coefficient
    • stats_stat_correlation — Returns the Pearson correlation coefficient of two data sets
    • stats_stat_factorial — Returns the factorial of an integer
    • stats_stat_independent_t — Returns the t-value from the independent two-sample t-test
    • stats_stat_innerproduct — Returns the inner product of two vectors
    • stats_stat_paired_t — Returns the t-value of the dependent t-test for paired samples
    • stats_stat_percentile — Returns the percentile value
    • stats_stat_powersum — Returns the power sum of a vector
    • stats_variance — Returns the variance


简介

This is the statistics extension. It contains few dozens of functions useful for statistical computations. It is a wrapper around 2 scientific libraries, namely DCDFLIB (Library of C routines for Cumulative Distributions Functions, Inverses, and Other parameters) by B. Brown & J. Lavato and RANDLIB by Barry Brown, James Lavato & Kathy Russell. Includes CD and PD functions.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Statistics
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

No external libraries are needed. The extension comes bundled with the libraries used.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/stats.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


  • ? 资源类型
  • Statistic 函数 ?
  • PHP Manual
  • Statistics
  • 预定义常量

预定义常量

此扩展没有定义常量。


Statistic 函数

Table of Contents

  • stats_absolute_deviation — Returns the absolute deviation of an array of values
  • stats_cdf_beta — Calculates any one parameter of the beta distribution given values for the others
  • stats_cdf_binomial — Calculates any one parameter of the binomial distribution given values for the others
  • stats_cdf_cauchy — Calculates any one parameter of the Cauchy distribution given values for the others
  • stats_cdf_chisquare — Calculates any one parameter of the chi-square distribution given values for the others
  • stats_cdf_exponential — Calculates any one parameter of the exponential distribution given values for the others
  • stats_cdf_f — Calculates any one parameter of the F distribution given values for the others
  • stats_cdf_gamma — Calculates any one parameter of the gamma distribution given values for the others
  • stats_cdf_laplace — Calculates any one parameter of the Laplace distribution given values for the others
  • stats_cdf_logistic — Calculates any one parameter of the logistic distribution given values for the others
  • stats_cdf_negative_binomial — Calculates any one parameter of the negative binomial distribution given values for the others
  • stats_cdf_noncentral_chisquare — Calculates any one parameter of the non-central chi-square distribution given values for the others
  • stats_cdf_noncentral_f — Calculates any one parameter of the non-central F distribution given values for the others
  • stats_cdf_noncentral_t — Calculates any one parameter of the non-central t-distribution give values for the others
  • stats_cdf_normal — Calculates any one parameter of the normal distribution given values for the others
  • stats_cdf_poisson — Calculates any one parameter of the Poisson distribution given values for the others
  • stats_cdf_t — Calculates any one parameter of the t-distribution given values for the others
  • stats_cdf_uniform — Calculates any one parameter of the uniform distribution given values for the others
  • stats_cdf_weibull — Calculates any one parameter of the Weibull distribution given values for the others
  • stats_covariance — Computes the covariance of two data sets
  • stats_dens_beta — Probability density function of the beta distribution
  • stats_dens_cauchy — Probability density function of the Cauchy distribution
  • stats_dens_chisquare — Probability density function of the chi-square distribution
  • stats_dens_exponential — Probability density function of the exponential distribution
  • stats_dens_f — Probability density function of the F distribution
  • stats_dens_gamma — Probability density function of the gamma distribution
  • stats_dens_laplace — Probability density function of the Laplace distribution
  • stats_dens_logistic — Probability density function of the logistic distribution
  • stats_dens_normal — Probability density function of the normal distribution
  • stats_dens_pmf_binomial — Probability mass function of the binomial distribution
  • stats_dens_pmf_hypergeometric — Probability mass function of the hypergeometric distribution
  • stats_dens_pmf_negative_binomial — Probability mass function of the negative binomial distribution
  • stats_dens_pmf_poisson — Probability mass function of the Poisson distribution
  • stats_dens_t — Probability density function of the t-distribution
  • stats_dens_uniform — Probability density function of the uniform distribution
  • stats_dens_weibull — Probability density function of the Weibull distribution
  • stats_harmonic_mean — Returns the harmonic mean of an array of values
  • stats_kurtosis — Computes the kurtosis of the data in the array
  • stats_rand_gen_beta — Generates a random deviate from the beta distribution
  • stats_rand_gen_chisquare — Generates a random deviate from the chi-square distribution
  • stats_rand_gen_exponential — Generates a random deviate from the exponential distribution
  • stats_rand_gen_f — Generates a random deviate from the F distribution
  • stats_rand_gen_funiform — Generates uniform float between low (exclusive) and high (exclusive)
  • stats_rand_gen_gamma — Generates a random deviate from the gamma distribution
  • stats_rand_gen_ibinomial_negative — Generates a random deviate from the negative binomial distribution
  • stats_rand_gen_ibinomial — Generates a random deviate from the binomial distribution
  • stats_rand_gen_int — Generates random integer between 1 and 2147483562
  • stats_rand_gen_ipoisson — Generates a single random deviate from a Poisson distribution
  • stats_rand_gen_iuniform — Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)
  • stats_rand_gen_noncentral_chisquare — Generates a random deviate from the non-central chi-square distribution
  • stats_rand_gen_noncentral_f — Generates a random deviate from the noncentral F distribution
  • stats_rand_gen_noncentral_t — Generates a single random deviate from a non-central t-distribution
  • stats_rand_gen_normal — Generates a single random deviate from a normal distribution
  • stats_rand_gen_t — Generates a single random deviate from a t-distribution
  • stats_rand_get_seeds — Get the seed values of the random number generator
  • stats_rand_phrase_to_seeds — Generate two seeds for the RGN random number generator
  • stats_rand_ranf — Generates a random floating point number between 0 and 1
  • stats_rand_setall — Set seed values to the random generator
  • stats_skew — Computes the skewness of the data in the array
  • stats_standard_deviation — Returns the standard deviation
  • stats_stat_binomial_coef — Returns a binomial coefficient
  • stats_stat_correlation — Returns the Pearson correlation coefficient of two data sets
  • stats_stat_factorial — Returns the factorial of an integer
  • stats_stat_independent_t — Returns the t-value from the independent two-sample t-test
  • stats_stat_innerproduct — Returns the inner product of two vectors
  • stats_stat_paired_t — Returns the t-value of the dependent t-test for paired samples
  • stats_stat_percentile — Returns the percentile value
  • stats_stat_powersum — Returns the power sum of a vector
  • stats_variance — Returns the variance


Returns the absolute deviation of an array of values

  • ? Statistic 函数
  • stats_cdf_beta ?
  • PHP Manual
  • Statistic 函数
  • Returns the absolute deviation of an array of values

stats_absolute_deviation

(PECL stats >= 1.0.0)

stats_absolute_deviation — Returns the absolute deviation of an array of values

说明

stats_absolute_deviation ( array $a ) : float

Returns the absolute deviation of the values in a.

参数

a

The input array

返回值

Returns the absolute deviation of the values in a, or false if a is empty or is not an array.


Calculates any one parameter of the beta distribution given values for the others

  • ? stats_absolute_deviation
  • stats_cdf_binomial ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the beta distribution given values for the others

stats_cdf_beta

(PECL stats >= 1.0.0)

stats_cdf_beta — Calculates any one parameter of the beta distribution given values for the others

说明

stats_cdf_beta ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the beta distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, alpha, and beta denotes cumulative distribution function, the value of the random variable, and shape parameters of the beta distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | alpha | beta
2 | x | CDF | alpha | beta
3 | alpha | x | CDF | beta
4 | beta | x | CDF | alpha

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, alpha, or beta, determined by which.


Calculates any one parameter of the binomial distribution given values for the others

  • ? stats_cdf_beta
  • stats_cdf_cauchy ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the binomial distribution given values for the others

stats_cdf_binomial

(PECL stats >= 1.0.0)

stats_cdf_binomial — Calculates any one parameter of the binomial distribution given values for the others

说明

stats_cdf_binomial ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the binomial distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, n, and p denotes cumulative distribution function, the number of successes, the number of trials, and the success rate for each trial, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | n | p
2 | x | CDF | n | p
3 | n | x | CDF | p
4 | p | x | CDF | n

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, n, or p, determined by which.


Calculates any one parameter of the Cauchy distribution given values for the others

  • ? stats_cdf_binomial
  • stats_cdf_chisquare ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the Cauchy distribution given values for the others

stats_cdf_cauchy

(PECL stats >= 1.0.0)

stats_cdf_cauchy — Calculates any one parameter of the Cauchy distribution given values for the others

说明

stats_cdf_cauchy ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the Cauchy distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, x0, and gamma denotes cumulative distribution function, the value of the random variable, the location and the scale parameter of the Cauchy distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | x0 | gamma
2 | x | CDF | x0 | gamma
3 | x0 | x | CDF | gamma
4 | gamma | x | CDF | x0

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, x0, or gamma, determined by which.


Calculates any one parameter of the chi-square distribution given values for the others

  • ? stats_cdf_cauchy
  • stats_cdf_exponential ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the chi-square distribution given values for the others

stats_cdf_chisquare

(PECL stats >= 1.0.0)

stats_cdf_chisquare — Calculates any one parameter of the chi-square distribution given values for the others

说明

stats_cdf_chisquare ( float $par1 , float $par2 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the chi-square distribution. The kind of the return value and parameters (par1 and par2) are determined by which.

The following table lists the return value and parameters by which. CDF, x, and k denotes cumulative distribution function, the value of the random variable, and the degree of freedom of the chi-square distribution, respectively.

Return value and parameters
which | Return value | par1 | par2
1 | CDF | x | k
2 | x | CDF | k
3 | k | x | CDF

参数

par1

The first parameter

par2

The second parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, or k, determined by which.


Calculates any one parameter of the exponential distribution given values for the others

  • ? stats_cdf_chisquare
  • stats_cdf_f ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the exponential distribution given values for the others

stats_cdf_exponential

(PECL stats >= 1.0.0)

stats_cdf_exponential — Calculates any one parameter of the exponential distribution given values for the others

说明

stats_cdf_exponential ( float $par1 , float $par2 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the exponential distribution. The kind of the return value and parameters (par1 and par2) are determined by which.

The following table lists the return value and parameters by which. CDF, x, and lambda denotes cumulative distribution function, the value of the random variable, and the rate parameter of the exponential distribution, respectively.

Return value and parameters
which | Return value | par1 | par2
1 | CDF | x | lambda
2 | x | CDF | lambda
3 | lambda | x | CDF

参数

par1

The first parameter

par2

The second parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, or lambda, determined by which.


Calculates any one parameter of the F distribution given values for the others

  • ? stats_cdf_exponential
  • stats_cdf_gamma ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the F distribution given values for the others

stats_cdf_f

(PECL stats >= 1.0.0)

stats_cdf_f — Calculates any one parameter of the F distribution given values for the others

说明

stats_cdf_f ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the F distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, d1, and d2 denotes cumulative distribution function, the value of the random variable, and the degree of freedoms of the F distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | d1 | d2
2 | x | CDF | d1 | d2
3 | d1 | x | CDF | d2
4 | d2 | x | CDF | d1

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, d1, or d2, determined by which.


Calculates any one parameter of the gamma distribution given values for the others

  • ? stats_cdf_f
  • stats_cdf_laplace ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the gamma distribution given values for the others

stats_cdf_gamma

(PECL stats >= 1.0.0)

stats_cdf_gamma — Calculates any one parameter of the gamma distribution given values for the others

说明

stats_cdf_gamma ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the gamma distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, k, and theta denotes cumulative distribution function, the value of the random variable, and the shape and the scale parameter of the gamma distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | k | theta
2 | x | CDF | k | theta
3 | k | x | CDF | theta
4 | theta | x | CDF | k

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, k, or theta, determined by which.


Calculates any one parameter of the Laplace distribution given values for the others

  • ? stats_cdf_gamma
  • stats_cdf_logistic ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the Laplace distribution given values for the others

stats_cdf_laplace

(PECL stats >= 1.0.0)

stats_cdf_laplace — Calculates any one parameter of the Laplace distribution given values for the others

说明

stats_cdf_laplace ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the Laplace distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, mu, and b denotes cumulative distribution function, the value of the random variable, and the location and the scale parameter of the Laplace distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | mu | b
2 | x | CDF | mu | b
3 | mu | x | CDF | b
4 | b | x | CDF | mu

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, mu, or b, determined by which.


Calculates any one parameter of the logistic distribution given values for the others

  • ? stats_cdf_laplace
  • stats_cdf_negative_binomial ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the logistic distribution given values for the others

stats_cdf_logistic

(PECL stats >= 1.0.0)

stats_cdf_logistic — Calculates any one parameter of the logistic distribution given values for the others

说明

stats_cdf_logistic ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the logistic distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, mu, and s denotes cumulative distribution function, the value of the random variable, and the location and the scale parameter of the logistic distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | mu | s
2 | x | CDF | mu | s
3 | mu | x | CDF | s
4 | s | x | CDF | mu

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, mu, or s, determined by which.


Calculates any one parameter of the negative binomial distribution given values for the others

  • ? stats_cdf_logistic
  • stats_cdf_noncentral_chisquare ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the negative binomial distribution given values for the others

stats_cdf_negative_binomial

(PECL stats >= 1.0.0)

stats_cdf_negative_binomial — Calculates any one parameter of the negative binomial distribution given values for the others

说明

stats_cdf_negative_binomial ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the negative binomial distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, r, and p denotes cumulative distribution function, the number of failure, the number of success, and the success rate for each trial, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | r | p
2 | x | CDF | r | p
3 | r | x | CDF | p
4 | p | x | CDF | r

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, r, or p, determined by which.


Calculates any one parameter of the non-central chi-square distribution given values for the others

  • ? stats_cdf_negative_binomial
  • stats_cdf_noncentral_f ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the non-central chi-square distribution given values for the others

stats_cdf_noncentral_chisquare

(PECL stats >= 1.0.0)

stats_cdf_noncentral_chisquare — Calculates any one parameter of the non-central chi-square distribution given values for the others

说明

stats_cdf_noncentral_chisquare ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the non-central chi-square distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, k, and lambda denotes cumulative distribution function, the value of the random variable, the degree of freedom and the non-centrality parameter of the distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | k | lambda
2 | x | CDF | k | lambda
3 | k | x | CDF | lambda
4 | lambda | x | CDF | k

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, k, or lambda, determined by which.


Calculates any one parameter of the non-central F distribution given values for the others

  • ? stats_cdf_noncentral_chisquare
  • stats_cdf_noncentral_t ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the non-central F distribution given values for the others

stats_cdf_noncentral_f

(PECL stats >= 1.0.0)

stats_cdf_noncentral_f — Calculates any one parameter of the non-central F distribution given values for the others

说明

stats_cdf_noncentral_f ( float $par1 , float $par2 , float $par3 , float $par4 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the non-central F distribution. The kind of the return value and parameters (par1, par2, par3, and par4) are determined by which.

The following table lists the return value and parameters by which. CDF, x, nu1, nu2, and lambda denotes cumulative distribution function, the value of the random variable, the degree of freedoms and the non-centrality parameter of the distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3 | par4
1 | CDF | x | nu1 | nu2 | lambda
2 | x | CDF | nu1 | nu2 | lambda
3 | nu1 | x | CDF | nu2 | lambda
4 | nu2 | x | CDF | nu1 | lambda
5 | lambda | x | CDF | nu1 | nu2

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

par4

The fourth parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, nu1, nu2, or lambda, determined by which.


Calculates any one parameter of the non-central t-distribution give values for the others

  • ? stats_cdf_noncentral_f
  • stats_cdf_normal ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the non-central t-distribution give values for the others

stats_cdf_noncentral_t

(PECL stats >= 1.0.0)

stats_cdf_noncentral_t — Calculates any one parameter of the non-central t-distribution give values for the others

说明

stats_cdf_noncentral_t ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the non-central t-distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, nu, and mu denotes cumulative distribution function, the value of the random variable, the degrees of freedom and the non-centrality parameter of the distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | nu | mu
2 | x | CDF | nu | mu
3 | nu | x | CDF | mu
4 | mu | x | CDF | nu

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, nu, or mu, determined by which.


Calculates any one parameter of the normal distribution given values for the others

  • ? stats_cdf_noncentral_t
  • stats_cdf_poisson ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the normal distribution given values for the others

stats_cdf_normal

(PECL stats >= 1.0.0)

stats_cdf_normal — Calculates any one parameter of the normal distribution given values for the others

说明

stats_cdf_normal ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the normal distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, mu, and sigma denotes cumulative distribution function, the value of the random variable, the mean and the standard deviation of the normal distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | mu | sigma
2 | x | CDF | mu | sigma
3 | mu | x | CDF | sigma
4 | sigma | x | CDF | mu

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, mu, or sigma, determined by which.


Calculates any one parameter of the Poisson distribution given values for the others

  • ? stats_cdf_normal
  • stats_cdf_t ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the Poisson distribution given values for the others

stats_cdf_poisson

(PECL stats >= 1.0.0)

stats_cdf_poisson — Calculates any one parameter of the Poisson distribution given values for the others

说明

stats_cdf_poisson ( float $par1 , float $par2 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the Poisson distribution. The kind of the return value and parameters (par1 and par2) are determined by which.

The following table lists the return value and parameters by which. CDF, x, and lambda denotes cumulative distribution function, the value of the random variable, and the parameter of the Poisson distribution, respectively.

Return value and parameters
which | Return value | par1 | par2
1 | CDF | x | lambda
2 | x | CDF | lambda
3 | lambda | x | CDF

参数

par1

The first parameter

par2

The second parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, or lambda, determined by which.


Calculates any one parameter of the t-distribution given values for the others

  • ? stats_cdf_poisson
  • stats_cdf_uniform ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the t-distribution given values for the others

stats_cdf_t

(PECL stats >= 1.0.0)

stats_cdf_t — Calculates any one parameter of the t-distribution given values for the others

说明

stats_cdf_t ( float $par1 , float $par2 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the t-distribution. The kind of the return value and parameters (par1 and par2) are determined by which.

The following table lists the return value and parameters by which. CDF, x, and nu denotes cumulative distribution function, the value of the random variable, and the degrees of freedom of the t-distribution, respectively.

Return value and parameters
which | Return value | par1 | par2
1 | CDF | x | nu
2 | x | CDF | nu
3 | nu | x | CDF

参数

par1

The first parameter

par2

The second parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, or nu, determined by which.


Calculates any one parameter of the uniform distribution given values for the others

  • ? stats_cdf_t
  • stats_cdf_weibull ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the uniform distribution given values for the others

stats_cdf_uniform

(PECL stats >= 1.0.0)

stats_cdf_uniform — Calculates any one parameter of the uniform distribution given values for the others

说明

stats_cdf_uniform ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the uniform distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, a, and b denotes cumulative distribution function, the value of the random variable, the lower bound and the higher bound of the uniform distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | a | b
2 | x | CDF | a | b
3 | a | x | CDF | b
4 | b | x | CDF | a

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, a, or b, determined by which.


Calculates any one parameter of the Weibull distribution given values for the others

  • ? stats_cdf_uniform
  • stats_covariance ?
  • PHP Manual
  • Statistic 函数
  • Calculates any one parameter of the Weibull distribution given values for the others

stats_cdf_weibull

(PECL stats >= 1.0.0)

stats_cdf_weibull — Calculates any one parameter of the Weibull distribution given values for the others

说明

stats_cdf_weibull ( float $par1 , float $par2 , float $par3 , int $which ) : float

Returns the cumulative distribution function, its inverse, or one of its parameters, of the Weibull distribution. The kind of the return value and parameters (par1, par2, and par3) are determined by which.

The following table lists the return value and parameters by which. CDF, x, k, and lambda denotes cumulative distribution function, the value of the random variable, the shape and the scale parameter of the Weibull distribution, respectively.

Return value and parameters
which | Return value | par1 | par2 | par3
1 | CDF | x | k | lambda
2 | x | CDF | k | lambda
3 | k | x | CDF | lambda
4 | lambda | x | CDF | k

参数

par1

The first parameter

par2

The second parameter

par3

The third parameter

which

The flag to determine what to be calculated

返回值

Returns CDF, x, k, or lambda, determined by which.


Computes the covariance of two data sets

  • ? stats_cdf_weibull
  • stats_dens_beta ?
  • PHP Manual
  • Statistic 函数
  • Computes the covariance of two data sets

stats_covariance

(PECL stats >= 1.0.0)

stats_covariance — Computes the covariance of two data sets

说明

stats_covariance ( array $a , array $b ) : float

Returns the covariance of a and b.

参数

a

The first array

b

The second array

返回值

Returns the covariance of a and b, or false on failure.


Probability density function of the beta distribution

  • ? stats_covariance
  • stats_dens_cauchy ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the beta distribution

stats_dens_beta

(PECL stats >= 1.0.0)

stats_dens_beta — Probability density function of the beta distribution

说明

stats_dens_beta ( float $x , float $a , float $b ) : float

Returns the probability density at x, where the random variable follows the beta distribution of which the shape parameters are a and b.

参数

x

The value at which the probability density is calculated

a

The shape parameter of the distribution

b

The shape parameter of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the Cauchy distribution

  • ? stats_dens_beta
  • stats_dens_chisquare ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the Cauchy distribution

stats_dens_cauchy

(PECL stats >= 1.0.0)

stats_dens_cauchy — Probability density function of the Cauchy distribution

说明

stats_dens_cauchy ( float $x , float $ave , float $stdev ) : float

Returns the probability density at x, where the random variable follows the Cauchy distribution whose location and scale are ave and stdev, respectively.

参数

x

The value at which the probability density is calculated

ave

The location parameter of the distribution

stdev

The scale parameter of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the chi-square distribution

  • ? stats_dens_cauchy
  • stats_dens_exponential ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the chi-square distribution

stats_dens_chisquare

(PECL stats >= 1.0.0)

stats_dens_chisquare — Probability density function of the chi-square distribution

说明

stats_dens_chisquare ( float $x , float $dfr ) : float

Returns the probability density at x, where the random variable follows the chi-square distribution of which the degree of freedom is dfr.

参数

x

The value at which the probability density is calculated

dfr

The degree of freedom of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the exponential distribution

  • ? stats_dens_chisquare
  • stats_dens_f ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the exponential distribution

stats_dens_exponential

(PECL stats >= 1.0.0)

stats_dens_exponential — Probability density function of the exponential distribution

说明

stats_dens_exponential ( float $x , float $scale ) : float

Returns the probability density at x, where the random variable follows the exponential distribution of which the scale is scale.

参数

x

The value at which the probability density is calculated

scale

The scale of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the F distribution

  • ? stats_dens_exponential
  • stats_dens_gamma ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the F distribution

stats_dens_f

(PECL stats >= 1.0.0)

stats_dens_f — Probability density function of the F distribution

说明

stats_dens_f ( float $x , float $dfr1 , float $dfr2 ) : float

Returns the probability density at x, where the random variable follows the F distribution of which the degree of freedoms are dfr1 and dfr2.

参数

x

The value at which the probability density is calculated

dfr1

The degree of freedom of the distribution

dfr2

The degree of freedom of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the gamma distribution

  • ? stats_dens_f
  • stats_dens_laplace ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the gamma distribution

stats_dens_gamma

(PECL stats >= 1.0.0)

stats_dens_gamma — Probability density function of the gamma distribution

说明

stats_dens_gamma ( float $x , float $shape , float $scale ) : float

Returns the probability density at x, where the random variable follows the gamma distribution of which the shape parameter is shape and the scale parameter is scale.

参数

x

The value at which the probability density is calculated

shape

The shape parameter of the distribution

scale

The scale parameter of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the Laplace distribution

  • ? stats_dens_gamma
  • stats_dens_logistic ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the Laplace distribution

stats_dens_laplace

(PECL stats >= 1.0.0)

stats_dens_laplace — Probability density function of the Laplace distribution

说明

stats_dens_laplace ( float $x , float $ave , float $stdev ) : float

Returns the probability density at x, where the random variable follows the Laplace distribution of which the location parameter is ave and the scale parameter is stdev.

参数

x

The value at which the probability density is calculated

ave

The location parameter of the distribution

stdev

The shape parameter of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the logistic distribution

  • ? stats_dens_laplace
  • stats_dens_normal ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the logistic distribution

stats_dens_logistic

(PECL stats >= 1.0.0)

stats_dens_logistic — Probability density function of the logistic distribution

说明

stats_dens_logistic ( float $x , float $ave , float $stdev ) : float

Returns the probability density at x, where the random variable follows the logistic distribution of which the location parameter is ave and the scale parameter is stdev.

参数

x

The value at which the probability density is calculated

ave

The location parameter of the distribution

stdev

The shape parameter of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the normal distribution

  • ? stats_dens_logistic
  • stats_dens_pmf_binomial ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the normal distribution

stats_dens_normal

(PECL stats >= 1.0.0)

stats_dens_normal — Probability density function of the normal distribution

说明

stats_dens_normal ( float $x , float $ave , float $stdev ) : float

Returns the probability density at x, where the random variable follows the normal distribution of which the mean is ave and the standard deviation is stdev.

参数

x

The value at which the probability density is calculated

ave

The mean of the distribution

stdev

The standard deviation of the distribution

返回值

The probability density at x or false for failure.


Probability mass function of the binomial distribution

  • ? stats_dens_normal
  • stats_dens_pmf_hypergeometric ?
  • PHP Manual
  • Statistic 函数
  • Probability mass function of the binomial distribution

stats_dens_pmf_binomial

(PECL stats >= 1.0.0)

stats_dens_pmf_binomial — Probability mass function of the binomial distribution

说明

stats_dens_pmf_binomial ( float $x , float $n , float $pi ) : float

Returns the probability mass at x, where the random variable follows the binomial distribution of which the number of trials is n and the success rate is pi.

参数

x

The value at which the probability mass is calculated

n

The number of trials of the distribution

pi

The success rate of the distribution

返回值

The probability mass at x or false for failure.


Probability mass function of the hypergeometric distribution

  • ? stats_dens_pmf_binomial
  • stats_dens_pmf_negative_binomial ?
  • PHP Manual
  • Statistic 函数
  • Probability mass function of the hypergeometric distribution

stats_dens_pmf_hypergeometric

(PECL stats >= 1.0.0)

stats_dens_pmf_hypergeometric — Probability mass function of the hypergeometric distribution

说明

stats_dens_pmf_hypergeometric ( float $n1 , float $n2 , float $N1 , float $N2 ) : float

Returns the probability mass at n1, where the random variable follows the hypergeometric distribution of which the number of failure is n2, the number of success samples is N1, and the number of failure samples is N2.

参数

n1

The number of success, at which the probability mass is calculated

n2

The number of failure of the distribution

N1

The number of success samples of the distribution

N2

The number of failure samples of the distribution

返回值

The probability mass at n1 or false for failure.


Probability mass function of the negative binomial distribution

  • ? stats_dens_pmf_hypergeometric
  • stats_dens_pmf_poisson ?
  • PHP Manual
  • Statistic 函数
  • Probability mass function of the negative binomial distribution

stats_dens_pmf_negative_binomial

(PECL stats >= 1.0.0)

stats_dens_pmf_negative_binomial — Probability mass function of the negative binomial distribution

说明

stats_dens_pmf_negative_binomial ( float $x , float $n , float $pi ) : float

Returns the probability mass at x, where the random variable follows the negative binomial distribution of which the number of the success is n and the success rate is pi.

参数

x

The value at which the probability mass is calculated

n

The number of the success of the distribution

pi

The success rate of the distribution

返回值

The probability mass at x or false for failure.


Probability mass function of the Poisson distribution

  • ? stats_dens_pmf_negative_binomial
  • stats_dens_t ?
  • PHP Manual
  • Statistic 函数
  • Probability mass function of the Poisson distribution

stats_dens_pmf_poisson

(PECL stats >= 1.0.0)

stats_dens_pmf_poisson — Probability mass function of the Poisson distribution

说明

stats_dens_pmf_poisson ( float $x , float $lb ) : float

Returns the probability mass at x, where the random variable follows the Poisson distribution whose parameter is lb.

参数

x

The value at which the probability mass is calculated

lb

The parameter of the Poisson distribution

返回值

The probability mass at x or false for failure.


Probability density function of the t-distribution

  • ? stats_dens_pmf_poisson
  • stats_dens_uniform ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the t-distribution

stats_dens_t

(PECL stats >= 1.0.0)

stats_dens_t — Probability density function of the t-distribution

说明

stats_dens_t ( float $x , float $dfr ) : float

Returns the probability density at x, where the random variable follows the t-distribution of which the degree of freedom is dfr.

参数

x

The value at which the probability density is calculated

dfr

The degree of freedom of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the uniform distribution

  • ? stats_dens_t
  • stats_dens_weibull ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the uniform distribution

stats_dens_uniform

(PECL stats >= 1.0.0)

stats_dens_uniform — Probability density function of the uniform distribution

说明

stats_dens_uniform ( float $x , float $a , float $b ) : float

Returns the probability density at x, where the random variable follows the uniform distribution of which the lower bound is a and the upper bound is b.

参数

x

The value at which the probability density is calculated

a

The lower bound of the distribution

b

The upper bound of the distribution

返回值

The probability density at x or false for failure.


Probability density function of the Weibull distribution

  • ? stats_dens_uniform
  • stats_harmonic_mean ?
  • PHP Manual
  • Statistic 函数
  • Probability density function of the Weibull distribution

stats_dens_weibull

(PECL stats >= 1.0.0)

stats_dens_weibull — Probability density function of the Weibull distribution

说明

stats_dens_weibull ( float $x , float $a , float $b ) : float

Returns the probability density at x, where the random variable follows the Weibull distribution of which the shape parameter is a and the scale parameter is b.

参数

x

The value at which the probability density is calculated

a

The shape parameter of the distribution

b

The scale parameter of the distribution

返回值

The probability density at x or false for failure.


Returns the harmonic mean of an array of values

  • ? stats_dens_weibull
  • stats_kurtosis ?
  • PHP Manual
  • Statistic 函数
  • Returns the harmonic mean of an array of values

stats_harmonic_mean

(PECL stats >= 1.0.0)

stats_harmonic_mean — Returns the harmonic mean of an array of values

说明

stats_harmonic_mean ( array $a ) : number

Returns the harmonic mean of the values in a.

参数

a

The input array

返回值

Returns the harmonic mean of the values in a, or false if a is empty or is not an array.


Computes the kurtosis of the data in the array

  • ? stats_harmonic_mean
  • stats_rand_gen_beta ?
  • PHP Manual
  • Statistic 函数
  • Computes the kurtosis of the data in the array

stats_kurtosis

(PECL stats >= 1.0.0)

stats_kurtosis — Computes the kurtosis of the data in the array

说明

stats_kurtosis ( array $a ) : float

Returns the kurtosis of the values in a.

参数

a

The input array

返回值

Returns the kurtosis of the values in a, or false if a is empty or is not an array.


Generates a random deviate from the beta distribution

  • ? stats_kurtosis
  • stats_rand_gen_chisquare ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the beta distribution

stats_rand_gen_beta

(PECL stats >= 1.0.0)

stats_rand_gen_beta — Generates a random deviate from the beta distribution

说明

stats_rand_gen_beta ( float $a , float $b ) : float

Returns a random deviate from the beta distribution with parameters A and B. The density of the beta is x^(a-1) * (1-x)^(b-1) / B(a,b) for 0 < x <. Method R. C. H. Cheng.

参数

a

The shape parameter of the beta distribution

b

The shape parameter of the beta distribution

返回值

A random deviate


Generates a random deviate from the chi-square distribution

  • ? stats_rand_gen_beta
  • stats_rand_gen_exponential ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the chi-square distribution

stats_rand_gen_chisquare

(PECL stats >= 1.0.0)

stats_rand_gen_chisquare — Generates a random deviate from the chi-square distribution

说明

stats_rand_gen_chisquare ( float $df ) : float

Returns a random deviate from the chi-square distribution where the degrees of freedom is df.

参数

df

The degrees of freedom

返回值

A random deviate


Generates a random deviate from the exponential distribution

  • ? stats_rand_gen_chisquare
  • stats_rand_gen_f ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the exponential distribution

stats_rand_gen_exponential

(PECL stats >= 1.0.0)

stats_rand_gen_exponential — Generates a random deviate from the exponential distribution

说明

stats_rand_gen_exponential ( float $av ) : float

Returns a random deviate from the exponential distribution of which the scale is av.

参数

av

The scale parameter

返回值

A random deviate


Generates a random deviate from the F distribution

  • ? stats_rand_gen_exponential
  • stats_rand_gen_funiform ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the F distribution

stats_rand_gen_f

(PECL stats >= 1.0.0)

stats_rand_gen_f — Generates a random deviate from the F distribution

说明

stats_rand_gen_f ( float $dfn , float $dfd ) : float

Generates a random deviate from the F (variance ratio) distribution with "dfn" degrees of freedom in the numerator and "dfd" degrees of freedom in the denominator. Method : directly generates ratio of chisquare variates.

参数

dfn

The degrees of freedom in the numerator

dfd

The degrees of freedom in the denominator

返回值

A random deviate


Generates uniform float between low (exclusive) and high (exclusive)

  • ? stats_rand_gen_f
  • stats_rand_gen_gamma ?
  • PHP Manual
  • Statistic 函数
  • Generates uniform float between low (exclusive) and high (exclusive)

stats_rand_gen_funiform

(PECL stats >= 1.0.0)

stats_rand_gen_funiform — Generates uniform float between low (exclusive) and high (exclusive)

说明

stats_rand_gen_funiform ( float $low , float $high ) : float

Returns a random deviate from the uniform distribution from low to high.

参数

low

The lower bound (inclusive)

high

The upper bound (exclusive)

返回值

A random deviate


Generates a random deviate from the gamma distribution

  • ? stats_rand_gen_funiform
  • stats_rand_gen_ibinomial_negative ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the gamma distribution

stats_rand_gen_gamma

(PECL stats >= 1.0.0)

stats_rand_gen_gamma — Generates a random deviate from the gamma distribution

说明

stats_rand_gen_gamma ( float $a , float $r ) : float

Generates a random deviate from the gamma distribution whose density is (A**R)/Gamma(R) * X**(R-1) * Exp(-A*X).

参数

a

location parameter of Gamma distribution (a > 0).

r

shape parameter of Gamma distribution (r > 0).

返回值

A random deviate


Generates a random deviate from the negative binomial distribution

  • ? stats_rand_gen_gamma
  • stats_rand_gen_ibinomial ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the negative binomial distribution

stats_rand_gen_ibinomial_negative

(PECL stats >= 1.0.0)

stats_rand_gen_ibinomial_negative — Generates a random deviate from the negative binomial distribution

说明

stats_rand_gen_ibinomial_negative ( int $n , float $p ) : int

Returns a random deviate from a negative binomial distribution where the number of success is n and the success rate is p.

参数

n

The number of success

p

The success rate

返回值

A random deviate, which is the number of failure.


Generates a random deviate from the binomial distribution

  • ? stats_rand_gen_ibinomial_negative
  • stats_rand_gen_int ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the binomial distribution

stats_rand_gen_ibinomial

(PECL stats >= 1.0.0)

stats_rand_gen_ibinomial — Generates a random deviate from the binomial distribution

说明

stats_rand_gen_ibinomial ( int $n , float $pp ) : int

Returns a random deviate from the binomial distribution whose number of trials is n and whose probability of an event in each trial is pp.

参数

n

The number of trials

pp

The probability of an event in each trial

返回值

A random deviate


Generates random integer between 1 and 2147483562

  • ? stats_rand_gen_ibinomial
  • stats_rand_gen_ipoisson ?
  • PHP Manual
  • Statistic 函数
  • Generates random integer between 1 and 2147483562

stats_rand_gen_int

(PECL stats >= 1.0.0)

stats_rand_gen_int — Generates random integer between 1 and 2147483562

说明

stats_rand_gen_int ( ) : int

Returns a random integer between 1 and 2147483562

返回值

A random integer


Generates a single random deviate from a Poisson distribution

  • ? stats_rand_gen_int
  • stats_rand_gen_iuniform ?
  • PHP Manual
  • Statistic 函数
  • Generates a single random deviate from a Poisson distribution

stats_rand_gen_ipoisson

(PECL stats >= 1.0.0)

stats_rand_gen_ipoisson — Generates a single random deviate from a Poisson distribution

说明

stats_rand_gen_ipoisson ( float $mu ) : int

Returns a random deviate from the Poisson distribution with parameter mu.

参数

mu

The parameter of the Poisson distribution

返回值

A random deviate


Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)

  • ? stats_rand_gen_ipoisson
  • stats_rand_gen_noncentral_chisquare ?
  • PHP Manual
  • Statistic 函数
  • Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)

stats_rand_gen_iuniform

(PECL stats >= 1.0.0)

stats_rand_gen_iuniform — Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)

说明

stats_rand_gen_iuniform ( int $low , int $high ) : int

Returns a random integer from the discrete uniform distribution between low (inclusive) and high (inclusive).

参数

low

The lower bound

high

The upper bound

返回值

A random integer


Generates a random deviate from the non-central chi-square distribution

  • ? stats_rand_gen_iuniform
  • stats_rand_gen_noncentral_f ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the non-central chi-square distribution

stats_rand_gen_noncentral_chisquare

(PECL stats >= 1.0.0)

stats_rand_gen_noncentral_chisquare — Generates a random deviate from the non-central chi-square distribution

说明

stats_rand_gen_noncentral_chisquare ( float $df , float $xnonc ) : float

Returns a random deviate from the non-central chi-square distribution with degrees of freedom, df, and non-centrality parameter, xnonc.

参数

df

The degrees of freedom

xnonc

The non-centrality parameter

返回值

A random deviate


Generates a random deviate from the noncentral F distribution

  • ? stats_rand_gen_noncentral_chisquare
  • stats_rand_gen_noncentral_t ?
  • PHP Manual
  • Statistic 函数
  • Generates a random deviate from the noncentral F distribution

stats_rand_gen_noncentral_f

(PECL stats >= 1.0.0)

stats_rand_gen_noncentral_f — Generates a random deviate from the noncentral F distribution

说明

stats_rand_gen_noncentral_f ( float $dfn , float $dfd , float $xnonc ) : float

Returns a random deviate from the non-central F distribution where the degrees of freedoms are dfn (numerator) and dfd (denominator), and the non-centrality parameter is xnonc.

参数

dfn

The degrees of freedom of the numerator

dfd

The degrees of freedom of the denominator

xnonc

The non-centrality parameter

返回值

A random deviate


Generates a single random deviate from a non-central t-distribution

  • ? stats_rand_gen_noncentral_f
  • stats_rand_gen_normal ?
  • PHP Manual
  • Statistic 函数
  • Generates a single random deviate from a non-central t-distribution

stats_rand_gen_noncentral_t

(PECL stats >= 1.0.0)

stats_rand_gen_noncentral_t — Generates a single random deviate from a non-central t-distribution

说明

stats_rand_gen_noncentral_t ( float $df , float $xnonc ) : float

Returns a random deviate from the non-central t-distribution with the degrees of freedom, df, and the non-centrality parameter, xnonc.

参数

df

The degrees of freedom

xnonc

The non-centrality parameter

返回值

A random deviate


Generates a single random deviate from a normal distribution

  • ? stats_rand_gen_noncentral_t
  • stats_rand_gen_t ?
  • PHP Manual
  • Statistic 函数
  • Generates a single random deviate from a normal distribution

stats_rand_gen_normal

(PECL stats >= 1.0.0)

stats_rand_gen_normal — Generates a single random deviate from a normal distribution

说明

stats_rand_gen_normal ( float $av , float $sd ) : float

Returns a random deviate from the normal distribution with mean, av, and standard deviation, sd.

参数

av

The mean of the normal distribution

sd

The standard deviation of the normal distribution

返回值

A random deviate


Generates a single random deviate from a t-distribution

  • ? stats_rand_gen_normal
  • stats_rand_get_seeds ?
  • PHP Manual
  • Statistic 函数
  • Generates a single random deviate from a t-distribution

stats_rand_gen_t

(PECL stats >= 1.0.0)

stats_rand_gen_t — Generates a single random deviate from a t-distribution

说明

stats_rand_gen_t ( float $df ) : float

Returns a random deviate from the t-distribution with the degrees of freedom, df.

参数

df

The degrees of freedom

返回值

A random deviate


Get the seed values of the random number generator

  • ? stats_rand_gen_t
  • stats_rand_phrase_to_seeds ?
  • PHP Manual
  • Statistic 函数
  • Get the seed values of the random number generator

stats_rand_get_seeds

(PECL stats >= 1.0.0)

stats_rand_get_seeds — Get the seed values of the random number generator

说明

stats_rand_get_seeds ( ) : array

Returns the current seed values of the random number generator

返回值

Returns an array of two integers.


Generate two seeds for the RGN random number generator

  • ? stats_rand_get_seeds
  • stats_rand_ranf ?
  • PHP Manual
  • Statistic 函数
  • Generate two seeds for the RGN random number generator

stats_rand_phrase_to_seeds

(PECL stats >= 1.0.0)

stats_rand_phrase_to_seeds — Generate two seeds for the RGN random number generator

说明

stats_rand_phrase_to_seeds ( string $phrase ) : array

Generate two seeds for the random number generator from a phrase.

参数

phrase

The input phrase

返回值

Returns an array of two integers.


Generates a random floating point number between 0 and 1

  • ? stats_rand_phrase_to_seeds
  • stats_rand_setall ?
  • PHP Manual
  • Statistic 函数
  • Generates a random floating point number between 0 and 1

stats_rand_ranf

(PECL stats >= 1.0.0)

stats_rand_ranf — Generates a random floating point number between 0 and 1

说明

stats_rand_ranf ( ) : float

Returns a random floating point number from a uniform distribution between 0 (exclusive) and 1 (exclusive).

返回值

A random floating point number


Set seed values to the random generator

  • ? stats_rand_ranf
  • stats_skew ?
  • PHP Manual
  • Statistic 函数
  • Set seed values to the random generator

stats_rand_setall

(PECL stats >= 1.0.0)

stats_rand_setall — Set seed values to the random generator

说明

stats_rand_setall ( int $iseed1 , int $iseed2 ) : void

Set iseed1 and iseed2 as seed values to the random generator used in statistic functions.

参数

iseed1

The value which is used as the random seed

iseed2

The value which is used as the random seed

返回值

No values are returned.


Computes the skewness of the data in the array

  • ? stats_rand_setall
  • stats_standard_deviation ?
  • PHP Manual
  • Statistic 函数
  • Computes the skewness of the data in the array

stats_skew

(PECL stats >= 1.0.0)

stats_skew — Computes the skewness of the data in the array

说明

stats_skew ( array $a ) : float

Returns the skewness of the values in a.

参数

a

The input array

返回值

Returns the skewness of the values in a, or false if a is empty or is not an array.


Returns the standard deviation

  • ? stats_skew
  • stats_stat_binomial_coef ?
  • PHP Manual
  • Statistic 函数
  • Returns the standard deviation

stats_standard_deviation

(PECL stats >= 1.0.0)

stats_standard_deviation — Returns the standard deviation

说明

stats_standard_deviation ( array $a , bool $sample = false ) : float

Returns the standard deviation of the values in a.

参数

a

The array of data to find the standard deviation for. Note that all values of the array will be cast to float.

sample

Indicates if a represents a sample of the population; defaults to false.

返回值

Returns the standard deviation on success; false on failure.

错误／异常

Raises an E_WARNING when there are fewer than 2 values in a.


Returns a binomial coefficient

  • ? stats_standard_deviation
  • stats_stat_correlation ?
  • PHP Manual
  • Statistic 函数
  • Returns a binomial coefficient

stats_stat_binomial_coef

(PECL stats >= 1.0.0)

stats_stat_binomial_coef — Returns a binomial coefficient

说明

stats_stat_binomial_coef ( int $x , int $n ) : float

Returns the binomial coefficient of n choose x.

参数

x

The number of chooses from the set

n

The number of elements in the set

返回值

Returns the binomial coefficient


Returns the Pearson correlation coefficient of two data sets

  • ? stats_stat_binomial_coef
  • stats_stat_factorial ?
  • PHP Manual
  • Statistic 函数
  • Returns the Pearson correlation coefficient of two data sets

stats_stat_correlation

(PECL stats >= 1.0.0)

stats_stat_correlation — Returns the Pearson correlation coefficient of two data sets

说明

stats_stat_correlation ( array $arr1 , array $arr2 ) : float

Returns the Pearson correlation coefficient between arr1 and arr2.

参数

arr1

The first array

arr2

The second array

返回值

Returns the Pearson correlation coefficient between arr1 and arr2, or false on failure.


Returns the factorial of an integer

  • ? stats_stat_correlation
  • stats_stat_independent_t ?
  • PHP Manual
  • Statistic 函数
  • Returns the factorial of an integer

stats_stat_factorial

(PECL stats >= 1.0.0)

stats_stat_factorial — Returns the factorial of an integer

说明

stats_stat_factorial ( int $n ) : float

Returns the factorial of an integer, n.

参数

n

An integer

返回值

The factorial of n.


Returns the t-value from the independent two-sample t-test

  • ? stats_stat_factorial
  • stats_stat_innerproduct ?
  • PHP Manual
  • Statistic 函数
  • Returns the t-value from the independent two-sample t-test

stats_stat_independent_t

(PECL stats >= 1.0.0)

stats_stat_independent_t — Returns the t-value from the independent two-sample t-test

说明

stats_stat_independent_t ( array $arr1 , array $arr2 ) : float

Returns the t-value of the independent two-sample t-test between arr1 and arr2.

Warning

本函数还未编写文档，仅有参数列表。

参数

arr1

The first set of values

arr2

The second set of values

返回值

Returns the t-value, or false if failure.


Returns the inner product of two vectors

  • ? stats_stat_independent_t
  • stats_stat_paired_t ?
  • PHP Manual
  • Statistic 函数
  • Returns the inner product of two vectors

stats_stat_innerproduct

(PECL stats >= 1.0.0)

stats_stat_innerproduct — Returns the inner product of two vectors

说明

stats_stat_innerproduct ( array $arr1 , array $arr2 ) : float

Returns the inner product of arr1 and arr2.

参数

arr1

The first array

arr2

The second array

返回值

Returns the inner product of arr1 and arr2, or false on failure.


Returns the t-value of the dependent t-test for paired samples

  • ? stats_stat_innerproduct
  • stats_stat_percentile ?
  • PHP Manual
  • Statistic 函数
  • Returns the t-value of the dependent t-test for paired samples

stats_stat_paired_t

(PECL stats >= 1.0.0)

stats_stat_paired_t — Returns the t-value of the dependent t-test for paired samples

说明

stats_stat_paired_t ( array $arr1 , array $arr2 ) : float

Returns the t-value of the dependent t-test for paired samples arr1 and arr2.

参数

arr1

The first samples

arr2

The second samples

返回值

Returns the t-value, or false if failure.


Returns the percentile value

  • ? stats_stat_paired_t
  • stats_stat_powersum ?
  • PHP Manual
  • Statistic 函数
  • Returns the percentile value

stats_stat_percentile

(PECL stats >= 1.0.0)

stats_stat_percentile — Returns the percentile value

说明

stats_stat_percentile ( array $arr , float $perc ) : float

Returns the perc-th percentile value of the array arr.

参数

arr

The input array

perc

The percentile

返回值

Returns the percentile values of the input array.


Returns the power sum of a vector

  • ? stats_stat_percentile
  • stats_variance ?
  • PHP Manual
  • Statistic 函数
  • Returns the power sum of a vector

stats_stat_powersum

(PECL stats >= 1.0.0)

stats_stat_powersum — Returns the power sum of a vector

说明

stats_stat_powersum ( array $arr , float $power ) : float

Returns the sum of the power-th power of a vector represented as an array arr.

参数

arr

The input array

power

The power

返回值

Returns the power sum of the input array.


Returns the variance

  • ? stats_stat_powersum
  • Trader ?
  • PHP Manual
  • Statistic 函数
  • Returns the variance

stats_variance

(PECL stats >= 1.0.0)

stats_variance — Returns the variance

说明

stats_variance ( array $a , bool $sample = false ) : float

Returns the variance of the values in a.

参数

a

The array of data to find the standard deviation for. Note that all values of the array will be cast to float.

sample

Indicates if a represents a sample of the population; defaults to false.

返回值

Returns the variance on success; false on failure.


Technical Analysis for Traders

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • Trader 函数
    • trader_acos — Vector Trigonometric ACos
    • trader_ad — Chaikin A/D Line
    • trader_add — Vector Arithmetic Add
    • trader_adosc — Chaikin A/D Oscillator
    • trader_adx — Average Directional Movement Index
    • trader_adxr — Average Directional Movement Index Rating
    • trader_apo — Absolute Price Oscillator
    • trader_aroon — Aroon
    • trader_aroonosc — Aroon Oscillator
    • trader_asin — Vector Trigonometric ASin
    • trader_atan — Vector Trigonometric ATan
    • trader_atr — Average True Range
    • trader_avgprice — Average Price
    • trader_bbands — Bollinger Bands
    • trader_beta — Beta
    • trader_bop — Balance Of Power
    • trader_cci — Commodity Channel Index
    • trader_cdl2crows — Two Crows
    • trader_cdl3blackcrows — Three Black Crows
    • trader_cdl3inside — Three Inside Up/Down
    • trader_cdl3linestrike — Three-Line Strike
    • trader_cdl3outside — Three Outside Up/Down
    • trader_cdl3starsinsouth — Three Stars In The South
    • trader_cdl3whitesoldiers — Three Advancing White Soldiers
    • trader_cdlabandonedbaby — Abandoned Baby
    • trader_cdladvanceblock — Advance Block
    • trader_cdlbelthold — Belt-hold
    • trader_cdlbreakaway — Breakaway
    • trader_cdlclosingmarubozu — Closing Marubozu
    • trader_cdlconcealbabyswall — Concealing Baby Swallow
    • trader_cdlcounterattack — Counterattack
    • trader_cdldarkcloudcover — Dark Cloud Cover
    • trader_cdldoji — Doji
    • trader_cdldojistar — Doji Star
    • trader_cdldragonflydoji — Dragonfly Doji
    • trader_cdlengulfing — Engulfing Pattern
    • trader_cdleveningdojistar — Evening Doji Star
    • trader_cdleveningstar — Evening Star
    • trader_cdlgapsidesidewhite — Up/Down-gap side-by-side white lines
    • trader_cdlgravestonedoji — Gravestone Doji
    • trader_cdlhammer — Hammer
    • trader_cdlhangingman — Hanging Man
    • trader_cdlharami — Harami Pattern
    • trader_cdlharamicross — Harami Cross Pattern
    • trader_cdlhighwave — High-Wave Candle
    • trader_cdlhikkake — Hikkake Pattern
    • trader_cdlhikkakemod — Modified Hikkake Pattern
    • trader_cdlhomingpigeon — Homing Pigeon
    • trader_cdlidentical3crows — Identical Three Crows
    • trader_cdlinneck — In-Neck Pattern
    • trader_cdlinvertedhammer — Inverted Hammer
    • trader_cdlkicking — Kicking
    • trader_cdlkickingbylength — Kicking - bull/bear determined by the longer marubozu
    • trader_cdlladderbottom — Ladder Bottom
    • trader_cdllongleggeddoji — Long Legged Doji
    • trader_cdllongline — Long Line Candle
    • trader_cdlmarubozu — Marubozu
    • trader_cdlmatchinglow — Matching Low
    • trader_cdlmathold — Mat Hold
    • trader_cdlmorningdojistar — Morning Doji Star
    • trader_cdlmorningstar — Morning Star
    • trader_cdlonneck — On-Neck Pattern
    • trader_cdlpiercing — Piercing Pattern
    • trader_cdlrickshawman — Rickshaw Man
    • trader_cdlrisefall3methods — Rising/Falling Three Methods
    • trader_cdlseparatinglines — Separating Lines
    • trader_cdlshootingstar — Shooting Star
    • trader_cdlshortline — Short Line Candle
    • trader_cdlspinningtop — Spinning Top
    • trader_cdlstalledpattern — Stalled Pattern
    • trader_cdlsticksandwich — Stick Sandwich
    • trader_cdltakuri — Takuri (Dragonfly Doji with very long lower shadow)
    • trader_cdltasukigap — Tasuki Gap
    • trader_cdlthrusting — Thrusting Pattern
    • trader_cdltristar — Tristar Pattern
    • trader_cdlunique3river — Unique 3 River
    • trader_cdlupsidegap2crows — Upside Gap Two Crows
    • trader_cdlxsidegap3methods — Upside/Downside Gap Three Methods
    • trader_ceil — Vector Ceil
    • trader_cmo — Chande Momentum Oscillator
    • trader_correl — Pearson's Correlation Coefficient (r)
    • trader_cos — Vector Trigonometric Cos
    • trader_cosh — Vector Trigonometric Cosh
    • trader_dema — Double Exponential Moving Average
    • trader_div — Vector Arithmetic Div
    • trader_dx — Directional Movement Index
    • trader_ema — Exponential Moving Average
    • trader_errno — Get error code
    • trader_exp — Vector Arithmetic Exp
    • trader_floor — Vector Floor
    • trader_get_compat — Get compatibility mode
    • trader_get_unstable_period — Get unstable period
    • trader_ht_dcperiod — Hilbert Transform - Dominant Cycle Period
    • trader_ht_dcphase — Hilbert Transform - Dominant Cycle Phase
    • trader_ht_phasor — Hilbert Transform - Phasor Components
    • trader_ht_sine — Hilbert Transform - SineWave
    • trader_ht_trendline — Hilbert Transform - Instantaneous Trendline
    • trader_ht_trendmode — Hilbert Transform - Trend vs Cycle Mode
    • trader_kama — Kaufman Adaptive Moving Average
    • trader_linearreg_angle — Linear Regression Angle
    • trader_linearreg_intercept — Linear Regression Intercept
    • trader_linearreg_slope — Linear Regression Slope
    • trader_linearreg — Linear Regression
    • trader_ln — Vector Log Natural
    • trader_log10 — Vector Log10
    • trader_ma — Moving average
    • trader_macd — Moving Average Convergence/Divergence
    • trader_macdext — MACD with controllable MA type
    • trader_macdfix — Moving Average Convergence/Divergence Fix 12/26
    • trader_mama — MESA Adaptive Moving Average
    • trader_mavp — Moving average with variable period
    • trader_max — Highest value over a specified period
    • trader_maxindex — Index of highest value over a specified period
    • trader_medprice — Median Price
    • trader_mfi — Money Flow Index
    • trader_midpoint — MidPoint over period
    • trader_midprice — Midpoint Price over period
    • trader_min — Lowest value over a specified period
    • trader_minindex — Index of lowest value over a specified period
    • trader_minmax — Lowest and highest values over a specified period
    • trader_minmaxindex — Indexes of lowest and highest values over a specified period
    • trader_minus_di — Minus Directional Indicator
    • trader_minus_dm — Minus Directional Movement
    • trader_mom — Momentum
    • trader_mult — Vector Arithmetic Mult
    • trader_natr — Normalized Average True Range
    • trader_obv — On Balance Volume
    • trader_plus_di — Plus Directional Indicator
    • trader_plus_dm — Plus Directional Movement
    • trader_ppo — Percentage Price Oscillator
    • trader_roc — Rate of change : ((price/prevPrice)-1)*100
    • trader_rocp — Rate of change Percentage: (price-prevPrice)/prevPrice
    • trader_rocr100 — Rate of change ratio 100 scale: (price/prevPrice)*100
    • trader_rocr — Rate of change ratio: (price/prevPrice)
    • trader_rsi — Relative Strength Index
    • trader_sar — Parabolic SAR
    • trader_sarext — Parabolic SAR - Extended
    • trader_set_compat — Set compatibility mode
    • trader_set_unstable_period — Set unstable period
    • trader_sin — Vector Trigonometric Sin
    • trader_sinh — Vector Trigonometric Sinh
    • trader_sma — Simple Moving Average
    • trader_sqrt — Vector Square Root
    • trader_stddev — Standard Deviation
    • trader_stoch — Stochastic
    • trader_stochf — Stochastic Fast
    • trader_stochrsi — Stochastic Relative Strength Index
    • trader_sub — Vector Arithmetic Subtraction
    • trader_sum — Summation
    • trader_t3 — Triple Exponential Moving Average (T3)
    • trader_tan — Vector Trigonometric Tan
    • trader_tanh — Vector Trigonometric Tanh
    • trader_tema — Triple Exponential Moving Average
    • trader_trange — True Range
    • trader_trima — Triangular Moving Average
    • trader_trix — 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA
    • trader_tsf — Time Series Forecast
    • trader_typprice — Typical Price
    • trader_ultosc — Ultimate Oscillator
    • trader_var — Variance
    • trader_wclprice — Weighted Close Price
    • trader_willr — Williams' %R
    • trader_wma — Weighted Moving Average


简介

The trader extension is a free open source stock library based on TA-Lib. It's dedicated to trading software developers requiring to perform technical analysis of financial market data. Alongside many indicators like ADX, MACD, RSI, Stochastic, TRIX the candlestick pattern recognition and several vector arithmetic and algebraic functions are present.

Calculations can be done in two modes - TA-Lib and Metastock. Changing it using trader_set_compat() will affect the way some trader functions work.

Some trader functions provide different results depending of the "starting point" of the data being involved. This is often referred as a function having memories. An example of such function is the Exponential Moving Average. It is possible to control the unstable period (the amount of data to strip off) using trader_set_unstable_period() function.

Extended documentation about indicators, formulas and implementations in other programming languages can be found under » tadoc.org.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Trader
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

The trader extension is based on » TA-Lib. TA-Lib is fully integrated into the extension, therefore no external libraries are needed.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/trader.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/trader/.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Trader 配置选项
名字 | 默认 | 可修改范围 | 更新日志
trader.real_precision | 3 | PHP_INI_ALL | Since trader 0.2.1
trader.real_round_mode | HALF_DOWN | PHP_INI_ALL | Since trader 0.3.0

这是配置指令的简短说明。

trader.real_precision int

All the values in the returned arrays will be rounded to this precision. However the calculations inside TA-Lib happen with unrounded values.

trader.real_round_mode string

Controls the trader real rounding policy. Valid values are HALF_UP, HALF_DOWN, HALF_EVEN and HALF_ODD. The behaviour is identical to the round() function used with the mode argument.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

TRADER_MA_TYPE_SMA (int)
TRADER_MA_TYPE_EMA (int)
TRADER_MA_TYPE_WMA (int)
TRADER_MA_TYPE_DEMA (int)
TRADER_MA_TYPE_TEMA (int)
TRADER_MA_TYPE_TRIMA (int)
TRADER_MA_TYPE_KAMA (int)
TRADER_MA_TYPE_MAMA (int)
TRADER_MA_TYPE_T3 (int)
TRADER_REAL_MIN (float)
TRADER_REAL_MAX (float)
TRADER_FUNC_UNST_ADX (int)
TRADER_FUNC_UNST_ADXR (int)
TRADER_FUNC_UNST_ATR (int)
TRADER_FUNC_UNST_CMO (int)
TRADER_FUNC_UNST_DX (int)
TRADER_FUNC_UNST_EMA (int)
TRADER_FUNC_UNST_HT_DCPERIOD (int)
TRADER_FUNC_UNST_HT_DCPHASE (int)
TRADER_FUNC_UNST_HT_PHASOR (int)
TRADER_FUNC_UNST_HT_SINE (int)
TRADER_FUNC_UNST_HT_TRENDLINE (int)
TRADER_FUNC_UNST_HT_TRENDMODE (int)
TRADER_FUNC_UNST_KAMA (int)
TRADER_FUNC_UNST_MAMA (int)
TRADER_FUNC_UNST_MFI (int)
TRADER_FUNC_UNST_MINUS_DI (int)
TRADER_FUNC_UNST_MINUS_DM (int)
TRADER_FUNC_UNST_NATR (int)
TRADER_FUNC_UNST_PLUS_DI (int)
TRADER_FUNC_UNST_PLUS_DM (int)
TRADER_FUNC_UNST_RSI (int)
TRADER_FUNC_UNST_STOCHRSI (int)
TRADER_FUNC_UNST_T3 (int)
TRADER_FUNC_UNST_ALL (int)
TRADER_FUNC_UNST_NONE (int)
TRADER_COMPATIBILITY_DEFAULT (int)
TRADER_COMPATIBILITY_METASTOCK (int)
TRADER_ERR_SUCCESS (int)
TRADER_ERR_LIB_NOT_INITIALIZE (int)
TRADER_ERR_BAD_PARAM (int)
TRADER_ERR_ALLOC_ERR (int)
TRADER_ERR_GROUP_NOT_FOUND (int)
TRADER_ERR_FUNC_NOT_FOUND (int)
TRADER_ERR_INVALID_HANDLE (int)
TRADER_ERR_INVALID_PARAM_HOLDER (int)
TRADER_ERR_INVALID_PARAM_HOLDER_TYPE (int)
TRADER_ERR_INVALID_PARAM_FUNCTION (int)
TRADER_ERR_INPUT_NOT_ALL_INITIALIZE (int)
TRADER_ERR_OUTPUT_NOT_ALL_INITIALIZE (int)
TRADER_ERR_OUT_OF_RANGE_START_INDEX (int)
TRADER_ERR_OUT_OF_RANGE_END_INDEX (int)
TRADER_ERR_INVALID_LIST_TYPE (int)
TRADER_ERR_BAD_OBJECT (int)
TRADER_ERR_NOT_SUPPORTED (int)
TRADER_ERR_INTERNAL_ERROR (int)
TRADER_ERR_UNKNOWN_ERROR (int)


Trader 函数

Table of Contents

  • trader_acos — Vector Trigonometric ACos
  • trader_ad — Chaikin A/D Line
  • trader_add — Vector Arithmetic Add
  • trader_adosc — Chaikin A/D Oscillator
  • trader_adx — Average Directional Movement Index
  • trader_adxr — Average Directional Movement Index Rating
  • trader_apo — Absolute Price Oscillator
  • trader_aroon — Aroon
  • trader_aroonosc — Aroon Oscillator
  • trader_asin — Vector Trigonometric ASin
  • trader_atan — Vector Trigonometric ATan
  • trader_atr — Average True Range
  • trader_avgprice — Average Price
  • trader_bbands — Bollinger Bands
  • trader_beta — Beta
  • trader_bop — Balance Of Power
  • trader_cci — Commodity Channel Index
  • trader_cdl2crows — Two Crows
  • trader_cdl3blackcrows — Three Black Crows
  • trader_cdl3inside — Three Inside Up/Down
  • trader_cdl3linestrike — Three-Line Strike
  • trader_cdl3outside — Three Outside Up/Down
  • trader_cdl3starsinsouth — Three Stars In The South
  • trader_cdl3whitesoldiers — Three Advancing White Soldiers
  • trader_cdlabandonedbaby — Abandoned Baby
  • trader_cdladvanceblock — Advance Block
  • trader_cdlbelthold — Belt-hold
  • trader_cdlbreakaway — Breakaway
  • trader_cdlclosingmarubozu — Closing Marubozu
  • trader_cdlconcealbabyswall — Concealing Baby Swallow
  • trader_cdlcounterattack — Counterattack
  • trader_cdldarkcloudcover — Dark Cloud Cover
  • trader_cdldoji — Doji
  • trader_cdldojistar — Doji Star
  • trader_cdldragonflydoji — Dragonfly Doji
  • trader_cdlengulfing — Engulfing Pattern
  • trader_cdleveningdojistar — Evening Doji Star
  • trader_cdleveningstar — Evening Star
  • trader_cdlgapsidesidewhite — Up/Down-gap side-by-side white lines
  • trader_cdlgravestonedoji — Gravestone Doji
  • trader_cdlhammer — Hammer
  • trader_cdlhangingman — Hanging Man
  • trader_cdlharami — Harami Pattern
  • trader_cdlharamicross — Harami Cross Pattern
  • trader_cdlhighwave — High-Wave Candle
  • trader_cdlhikkake — Hikkake Pattern
  • trader_cdlhikkakemod — Modified Hikkake Pattern
  • trader_cdlhomingpigeon — Homing Pigeon
  • trader_cdlidentical3crows — Identical Three Crows
  • trader_cdlinneck — In-Neck Pattern
  • trader_cdlinvertedhammer — Inverted Hammer
  • trader_cdlkicking — Kicking
  • trader_cdlkickingbylength — Kicking - bull/bear determined by the longer marubozu
  • trader_cdlladderbottom — Ladder Bottom
  • trader_cdllongleggeddoji — Long Legged Doji
  • trader_cdllongline — Long Line Candle
  • trader_cdlmarubozu — Marubozu
  • trader_cdlmatchinglow — Matching Low
  • trader_cdlmathold — Mat Hold
  • trader_cdlmorningdojistar — Morning Doji Star
  • trader_cdlmorningstar — Morning Star
  • trader_cdlonneck — On-Neck Pattern
  • trader_cdlpiercing — Piercing Pattern
  • trader_cdlrickshawman — Rickshaw Man
  • trader_cdlrisefall3methods — Rising/Falling Three Methods
  • trader_cdlseparatinglines — Separating Lines
  • trader_cdlshootingstar — Shooting Star
  • trader_cdlshortline — Short Line Candle
  • trader_cdlspinningtop — Spinning Top
  • trader_cdlstalledpattern — Stalled Pattern
  • trader_cdlsticksandwich — Stick Sandwich
  • trader_cdltakuri — Takuri (Dragonfly Doji with very long lower shadow)
  • trader_cdltasukigap — Tasuki Gap
  • trader_cdlthrusting — Thrusting Pattern
  • trader_cdltristar — Tristar Pattern
  • trader_cdlunique3river — Unique 3 River
  • trader_cdlupsidegap2crows — Upside Gap Two Crows
  • trader_cdlxsidegap3methods — Upside/Downside Gap Three Methods
  • trader_ceil — Vector Ceil
  • trader_cmo — Chande Momentum Oscillator
  • trader_correl — Pearson's Correlation Coefficient (r)
  • trader_cos — Vector Trigonometric Cos
  • trader_cosh — Vector Trigonometric Cosh
  • trader_dema — Double Exponential Moving Average
  • trader_div — Vector Arithmetic Div
  • trader_dx — Directional Movement Index
  • trader_ema — Exponential Moving Average
  • trader_errno — Get error code
  • trader_exp — Vector Arithmetic Exp
  • trader_floor — Vector Floor
  • trader_get_compat — Get compatibility mode
  • trader_get_unstable_period — Get unstable period
  • trader_ht_dcperiod — Hilbert Transform - Dominant Cycle Period
  • trader_ht_dcphase — Hilbert Transform - Dominant Cycle Phase
  • trader_ht_phasor — Hilbert Transform - Phasor Components
  • trader_ht_sine — Hilbert Transform - SineWave
  • trader_ht_trendline — Hilbert Transform - Instantaneous Trendline
  • trader_ht_trendmode — Hilbert Transform - Trend vs Cycle Mode
  • trader_kama — Kaufman Adaptive Moving Average
  • trader_linearreg_angle — Linear Regression Angle
  • trader_linearreg_intercept — Linear Regression Intercept
  • trader_linearreg_slope — Linear Regression Slope
  • trader_linearreg — Linear Regression
  • trader_ln — Vector Log Natural
  • trader_log10 — Vector Log10
  • trader_ma — Moving average
  • trader_macd — Moving Average Convergence/Divergence
  • trader_macdext — MACD with controllable MA type
  • trader_macdfix — Moving Average Convergence/Divergence Fix 12/26
  • trader_mama — MESA Adaptive Moving Average
  • trader_mavp — Moving average with variable period
  • trader_max — Highest value over a specified period
  • trader_maxindex — Index of highest value over a specified period
  • trader_medprice — Median Price
  • trader_mfi — Money Flow Index
  • trader_midpoint — MidPoint over period
  • trader_midprice — Midpoint Price over period
  • trader_min — Lowest value over a specified period
  • trader_minindex — Index of lowest value over a specified period
  • trader_minmax — Lowest and highest values over a specified period
  • trader_minmaxindex — Indexes of lowest and highest values over a specified period
  • trader_minus_di — Minus Directional Indicator
  • trader_minus_dm — Minus Directional Movement
  • trader_mom — Momentum
  • trader_mult — Vector Arithmetic Mult
  • trader_natr — Normalized Average True Range
  • trader_obv — On Balance Volume
  • trader_plus_di — Plus Directional Indicator
  • trader_plus_dm — Plus Directional Movement
  • trader_ppo — Percentage Price Oscillator
  • trader_roc — Rate of change : ((price/prevPrice)-1)*100
  • trader_rocp — Rate of change Percentage: (price-prevPrice)/prevPrice
  • trader_rocr100 — Rate of change ratio 100 scale: (price/prevPrice)*100
  • trader_rocr — Rate of change ratio: (price/prevPrice)
  • trader_rsi — Relative Strength Index
  • trader_sar — Parabolic SAR
  • trader_sarext — Parabolic SAR - Extended
  • trader_set_compat — Set compatibility mode
  • trader_set_unstable_period — Set unstable period
  • trader_sin — Vector Trigonometric Sin
  • trader_sinh — Vector Trigonometric Sinh
  • trader_sma — Simple Moving Average
  • trader_sqrt — Vector Square Root
  • trader_stddev — Standard Deviation
  • trader_stoch — Stochastic
  • trader_stochf — Stochastic Fast
  • trader_stochrsi — Stochastic Relative Strength Index
  • trader_sub — Vector Arithmetic Subtraction
  • trader_sum — Summation
  • trader_t3 — Triple Exponential Moving Average (T3)
  • trader_tan — Vector Trigonometric Tan
  • trader_tanh — Vector Trigonometric Tanh
  • trader_tema — Triple Exponential Moving Average
  • trader_trange — True Range
  • trader_trima — Triangular Moving Average
  • trader_trix — 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA
  • trader_tsf — Time Series Forecast
  • trader_typprice — Typical Price
  • trader_ultosc — Ultimate Oscillator
  • trader_var — Variance
  • trader_wclprice — Weighted Close Price
  • trader_willr — Williams' %R
  • trader_wma — Weighted Moving Average


Vector Trigonometric ACos

  • ? Trader 函数
  • trader_ad ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric ACos

trader_acos

(PECL trader >= 0.2.0)

trader_acos — Vector Trigonometric ACos

说明

trader_acos ( array $real ) : array

Calculates the arc cosine for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Chaikin A/D Line

  • ? trader_acos
  • trader_add ?
  • PHP Manual
  • Trader 函数
  • Chaikin A/D Line

trader_ad

(PECL trader >= 0.2.0)

trader_ad — Chaikin A/D Line

说明

trader_ad ( array $high , array $low , array $close , array $volume ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

volume

成交量，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Vector Arithmetic Add

  • ? trader_ad
  • trader_adosc ?
  • PHP Manual
  • Trader 函数
  • Vector Arithmetic Add

trader_add

(PECL trader >= 0.2.0)

trader_add — Vector Arithmetic Add

说明

trader_add ( array $real0 , array $real1 ) : array

Calculates the vector addition of real0 to real1 and returns the resulting vector.

参数

real0

浮点数数组。

real1

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Chaikin A/D Oscillator

  • ? trader_add
  • trader_adx ?
  • PHP Manual
  • Trader 函数
  • Chaikin A/D Oscillator

trader_adosc

(PECL trader >= 0.2.0)

trader_adosc — Chaikin A/D Oscillator

说明

trader_adosc ( array $high , array $low , array $close , array $volume , int $fastPeriod = ? , int $slowPeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

volume

成交量，浮点数数组。

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Average Directional Movement Index

  • ? trader_adosc
  • trader_adxr ?
  • PHP Manual
  • Trader 函数
  • Average Directional Movement Index

trader_adx

(PECL trader >= 0.2.0)

trader_adx — Average Directional Movement Index

说明

trader_adx ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Average Directional Movement Index Rating

  • ? trader_adx
  • trader_apo ?
  • PHP Manual
  • Trader 函数
  • Average Directional Movement Index Rating

trader_adxr

(PECL trader >= 0.2.0)

trader_adxr — Average Directional Movement Index Rating

说明

trader_adxr ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Absolute Price Oscillator

  • ? trader_adxr
  • trader_aroon ?
  • PHP Manual
  • Trader 函数
  • Absolute Price Oscillator

trader_apo

(PECL trader >= 0.2.0)

trader_apo — Absolute Price Oscillator

说明

trader_apo ( array $real , int $fastPeriod = ? , int $slowPeriod = ? , int $mAType = ? ) : array

参数

real

浮点数数组。

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Aroon

  • ? trader_apo
  • trader_aroonosc ?
  • PHP Manual
  • Trader 函数
  • Aroon

trader_aroon

(PECL trader >= 0.2.0)

trader_aroon — Aroon

说明

trader_aroon ( array $high , array $low , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Aroon Oscillator

  • ? trader_aroon
  • trader_asin ?
  • PHP Manual
  • Trader 函数
  • Aroon Oscillator

trader_aroonosc

(PECL trader >= 0.2.0)

trader_aroonosc — Aroon Oscillator

说明

trader_aroonosc ( array $high , array $low , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Vector Trigonometric ASin

  • ? trader_aroonosc
  • trader_atan ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric ASin

trader_asin

(PECL trader >= 0.2.0)

trader_asin — Vector Trigonometric ASin

说明

trader_asin ( array $real ) : array

Calculates the arc sine for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Vector Trigonometric ATan

  • ? trader_asin
  • trader_atr ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric ATan

trader_atan

(PECL trader >= 0.2.0)

trader_atan — Vector Trigonometric ATan

说明

trader_atan ( array $real ) : array

Calculates the arc tangent for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Average True Range

  • ? trader_atan
  • trader_avgprice ?
  • PHP Manual
  • Trader 函数
  • Average True Range

trader_atr

(PECL trader >= 0.2.0)

trader_atr — Average True Range

说明

trader_atr ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Average Price

  • ? trader_atr
  • trader_bbands ?
  • PHP Manual
  • Trader 函数
  • Average Price

trader_avgprice

(PECL trader >= 0.2.0)

trader_avgprice — Average Price

说明

trader_avgprice ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Bollinger Bands

  • ? trader_avgprice
  • trader_beta ?
  • PHP Manual
  • Trader 函数
  • Bollinger Bands

trader_bbands

(PECL trader >= 0.2.0)

trader_bbands — Bollinger Bands

说明

trader_bbands ( array $real , int $timePeriod = ? , float $nbDevUp = ? , float $nbDevDn = ? , int $mAType = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

nbDevUp

Deviation multiplier for upper band. Valid range from TRADER_REAL_MIN to TRADER_REAL_MAX.

nbDevDn

Deviation multiplier for lower band. Valid range from TRADER_REAL_MIN to TRADER_REAL_MAX.

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Beta

  • ? trader_bbands
  • trader_bop ?
  • PHP Manual
  • Trader 函数
  • Beta

trader_beta

(PECL trader >= 0.2.0)

trader_beta — Beta

说明

trader_beta ( array $real0 , array $real1 , int $timePeriod = ? ) : array

参数

real0

浮点数数组。

real1

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Balance Of Power

  • ? trader_beta
  • trader_cci ?
  • PHP Manual
  • Trader 函数
  • Balance Of Power

trader_bop

(PECL trader >= 0.2.0)

trader_bop — Balance Of Power

说明

trader_bop ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Commodity Channel Index

  • ? trader_bop
  • trader_cdl2crows ?
  • PHP Manual
  • Trader 函数
  • Commodity Channel Index

trader_cci

(PECL trader >= 0.2.0)

trader_cci — Commodity Channel Index

说明

trader_cci ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Two Crows

  • ? trader_cci
  • trader_cdl3blackcrows ?
  • PHP Manual
  • Trader 函数
  • Two Crows

trader_cdl2crows

(PECL trader >= 0.2.0)

trader_cdl2crows — Two Crows

说明

trader_cdl2crows ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Three Black Crows

  • ? trader_cdl2crows
  • trader_cdl3inside ?
  • PHP Manual
  • Trader 函数
  • Three Black Crows

trader_cdl3blackcrows

(PECL trader >= 0.2.0)

trader_cdl3blackcrows — Three Black Crows

说明

trader_cdl3blackcrows ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Three Inside Up/Down

  • ? trader_cdl3blackcrows
  • trader_cdl3linestrike ?
  • PHP Manual
  • Trader 函数
  • Three Inside Up/Down

trader_cdl3inside

(PECL trader >= 0.2.0)

trader_cdl3inside — Three Inside Up/Down

说明

trader_cdl3inside ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Three-Line Strike

  • ? trader_cdl3inside
  • trader_cdl3outside ?
  • PHP Manual
  • Trader 函数
  • Three-Line Strike

trader_cdl3linestrike

(PECL trader >= 0.2.0)

trader_cdl3linestrike — Three-Line Strike

说明

trader_cdl3linestrike ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Three Outside Up/Down

  • ? trader_cdl3linestrike
  • trader_cdl3starsinsouth ?
  • PHP Manual
  • Trader 函数
  • Three Outside Up/Down

trader_cdl3outside

(PECL trader >= 0.2.0)

trader_cdl3outside — Three Outside Up/Down

说明

trader_cdl3outside ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Three Stars In The South

  • ? trader_cdl3outside
  • trader_cdl3whitesoldiers ?
  • PHP Manual
  • Trader 函数
  • Three Stars In The South

trader_cdl3starsinsouth

(PECL trader >= 0.2.0)

trader_cdl3starsinsouth — Three Stars In The South

说明

trader_cdl3starsinsouth ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Three Advancing White Soldiers

  • ? trader_cdl3starsinsouth
  • trader_cdlabandonedbaby ?
  • PHP Manual
  • Trader 函数
  • Three Advancing White Soldiers

trader_cdl3whitesoldiers

(PECL trader >= 0.2.0)

trader_cdl3whitesoldiers — Three Advancing White Soldiers

说明

trader_cdl3whitesoldiers ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Abandoned Baby

  • ? trader_cdl3whitesoldiers
  • trader_cdladvanceblock ?
  • PHP Manual
  • Trader 函数
  • Abandoned Baby

trader_cdlabandonedbaby

(PECL trader >= 0.2.0)

trader_cdlabandonedbaby — Abandoned Baby

说明

trader_cdlabandonedbaby ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

penetration

一个烛台渗入到另一个烛台的百分比。

返回值

Returns an array with calculated data or false on failure.


Advance Block

  • ? trader_cdlabandonedbaby
  • trader_cdlbelthold ?
  • PHP Manual
  • Trader 函数
  • Advance Block

trader_cdladvanceblock

(PECL trader >= 0.2.0)

trader_cdladvanceblock — Advance Block

说明

trader_cdladvanceblock ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Belt-hold

  • ? trader_cdladvanceblock
  • trader_cdlbreakaway ?
  • PHP Manual
  • Trader 函数
  • Belt-hold

trader_cdlbelthold

(PECL trader >= 0.2.0)

trader_cdlbelthold — Belt-hold

说明

trader_cdlbelthold ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Breakaway

  • ? trader_cdlbelthold
  • trader_cdlclosingmarubozu ?
  • PHP Manual
  • Trader 函数
  • Breakaway

trader_cdlbreakaway

(PECL trader >= 0.2.0)

trader_cdlbreakaway — Breakaway

说明

trader_cdlbreakaway ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Closing Marubozu

  • ? trader_cdlbreakaway
  • trader_cdlconcealbabyswall ?
  • PHP Manual
  • Trader 函数
  • Closing Marubozu

trader_cdlclosingmarubozu

(PECL trader >= 0.2.0)

trader_cdlclosingmarubozu — Closing Marubozu

说明

trader_cdlclosingmarubozu ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Concealing Baby Swallow

  • ? trader_cdlclosingmarubozu
  • trader_cdlcounterattack ?
  • PHP Manual
  • Trader 函数
  • Concealing Baby Swallow

trader_cdlconcealbabyswall

(PECL trader >= 0.2.0)

trader_cdlconcealbabyswall — Concealing Baby Swallow

说明

trader_cdlconcealbabyswall ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Counterattack

  • ? trader_cdlconcealbabyswall
  • trader_cdldarkcloudcover ?
  • PHP Manual
  • Trader 函数
  • Counterattack

trader_cdlcounterattack

(PECL trader >= 0.2.0)

trader_cdlcounterattack — Counterattack

说明

trader_cdlcounterattack ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Dark Cloud Cover

  • ? trader_cdlcounterattack
  • trader_cdldoji ?
  • PHP Manual
  • Trader 函数
  • Dark Cloud Cover

trader_cdldarkcloudcover

(PECL trader >= 0.2.0)

trader_cdldarkcloudcover — Dark Cloud Cover

说明

trader_cdldarkcloudcover ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

penetration

一个烛台渗入到另一个烛台的百分比。

返回值

Returns an array with calculated data or false on failure.


Doji

  • ? trader_cdldarkcloudcover
  • trader_cdldojistar ?
  • PHP Manual
  • Trader 函数
  • Doji

trader_cdldoji

(PECL trader >= 0.2.0)

trader_cdldoji — Doji

说明

trader_cdldoji ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Doji Star

  • ? trader_cdldoji
  • trader_cdldragonflydoji ?
  • PHP Manual
  • Trader 函数
  • Doji Star

trader_cdldojistar

(PECL trader >= 0.2.0)

trader_cdldojistar — Doji Star

说明

trader_cdldojistar ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Dragonfly Doji

  • ? trader_cdldojistar
  • trader_cdlengulfing ?
  • PHP Manual
  • Trader 函数
  • Dragonfly Doji

trader_cdldragonflydoji

(PECL trader >= 0.2.0)

trader_cdldragonflydoji — Dragonfly Doji

说明

trader_cdldragonflydoji ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Engulfing Pattern

  • ? trader_cdldragonflydoji
  • trader_cdleveningdojistar ?
  • PHP Manual
  • Trader 函数
  • Engulfing Pattern

trader_cdlengulfing

(PECL trader >= 0.2.0)

trader_cdlengulfing — Engulfing Pattern

说明

trader_cdlengulfing ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Evening Doji Star

  • ? trader_cdlengulfing
  • trader_cdleveningstar ?
  • PHP Manual
  • Trader 函数
  • Evening Doji Star

trader_cdleveningdojistar

(PECL trader >= 0.2.0)

trader_cdleveningdojistar — Evening Doji Star

说明

trader_cdleveningdojistar ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

penetration

一个烛台渗入到另一个烛台的百分比。

返回值

Returns an array with calculated data or false on failure.


Evening Star

  • ? trader_cdleveningdojistar
  • trader_cdlgapsidesidewhite ?
  • PHP Manual
  • Trader 函数
  • Evening Star

trader_cdleveningstar

(PECL trader >= 0.2.0)

trader_cdleveningstar — Evening Star

说明

trader_cdleveningstar ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

penetration

一个烛台渗入到另一个烛台的百分比。

返回值

Returns an array with calculated data or false on failure.


Up/Down-gap side-by-side white lines

  • ? trader_cdleveningstar
  • trader_cdlgravestonedoji ?
  • PHP Manual
  • Trader 函数
  • Up/Down-gap side-by-side white lines

trader_cdlgapsidesidewhite

(PECL trader >= 0.2.0)

trader_cdlgapsidesidewhite — Up/Down-gap side-by-side white lines

说明

trader_cdlgapsidesidewhite ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Gravestone Doji

  • ? trader_cdlgapsidesidewhite
  • trader_cdlhammer ?
  • PHP Manual
  • Trader 函数
  • Gravestone Doji

trader_cdlgravestonedoji

(PECL trader >= 0.2.0)

trader_cdlgravestonedoji — Gravestone Doji

说明

trader_cdlgravestonedoji ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Hammer

  • ? trader_cdlgravestonedoji
  • trader_cdlhangingman ?
  • PHP Manual
  • Trader 函数
  • Hammer

trader_cdlhammer

(PECL trader >= 0.2.0)

trader_cdlhammer — Hammer

说明

trader_cdlhammer ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Hanging Man

  • ? trader_cdlhammer
  • trader_cdlharami ?
  • PHP Manual
  • Trader 函数
  • Hanging Man

trader_cdlhangingman

(PECL trader >= 0.2.0)

trader_cdlhangingman — Hanging Man

说明

trader_cdlhangingman ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Harami Pattern

  • ? trader_cdlhangingman
  • trader_cdlharamicross ?
  • PHP Manual
  • Trader 函数
  • Harami Pattern

trader_cdlharami

(PECL trader >= 0.2.0)

trader_cdlharami — Harami Pattern

说明

trader_cdlharami ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Harami Cross Pattern

  • ? trader_cdlharami
  • trader_cdlhighwave ?
  • PHP Manual
  • Trader 函数
  • Harami Cross Pattern

trader_cdlharamicross

(PECL trader >= 0.2.0)

trader_cdlharamicross — Harami Cross Pattern

说明

trader_cdlharamicross ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


High-Wave Candle

  • ? trader_cdlharamicross
  • trader_cdlhikkake ?
  • PHP Manual
  • Trader 函数
  • High-Wave Candle

trader_cdlhighwave

(PECL trader >= 0.2.0)

trader_cdlhighwave — High-Wave Candle

说明

trader_cdlhighwave ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Hikkake Pattern

  • ? trader_cdlhighwave
  • trader_cdlhikkakemod ?
  • PHP Manual
  • Trader 函数
  • Hikkake Pattern

trader_cdlhikkake

(PECL trader >= 0.2.0)

trader_cdlhikkake — Hikkake Pattern

说明

trader_cdlhikkake ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Modified Hikkake Pattern

  • ? trader_cdlhikkake
  • trader_cdlhomingpigeon ?
  • PHP Manual
  • Trader 函数
  • Modified Hikkake Pattern

trader_cdlhikkakemod

(PECL trader >= 0.2.0)

trader_cdlhikkakemod — Modified Hikkake Pattern

说明

trader_cdlhikkakemod ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Homing Pigeon

  • ? trader_cdlhikkakemod
  • trader_cdlidentical3crows ?
  • PHP Manual
  • Trader 函数
  • Homing Pigeon

trader_cdlhomingpigeon

(PECL trader >= 0.2.0)

trader_cdlhomingpigeon — Homing Pigeon

说明

trader_cdlhomingpigeon ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Identical Three Crows

  • ? trader_cdlhomingpigeon
  • trader_cdlinneck ?
  • PHP Manual
  • Trader 函数
  • Identical Three Crows

trader_cdlidentical3crows

(PECL trader >= 0.2.0)

trader_cdlidentical3crows — Identical Three Crows

说明

trader_cdlidentical3crows ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


In-Neck Pattern

  • ? trader_cdlidentical3crows
  • trader_cdlinvertedhammer ?
  • PHP Manual
  • Trader 函数
  • In-Neck Pattern

trader_cdlinneck

(PECL trader >= 0.2.0)

trader_cdlinneck — In-Neck Pattern

说明

trader_cdlinneck ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Inverted Hammer

  • ? trader_cdlinneck
  • trader_cdlkicking ?
  • PHP Manual
  • Trader 函数
  • Inverted Hammer

trader_cdlinvertedhammer

(PECL trader >= 0.2.0)

trader_cdlinvertedhammer — Inverted Hammer

说明

trader_cdlinvertedhammer ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Kicking

  • ? trader_cdlinvertedhammer
  • trader_cdlkickingbylength ?
  • PHP Manual
  • Trader 函数
  • Kicking

trader_cdlkicking

(PECL trader >= 0.2.0)

trader_cdlkicking — Kicking

说明

trader_cdlkicking ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Kicking - bull/bear determined by the longer marubozu

  • ? trader_cdlkicking
  • trader_cdlladderbottom ?
  • PHP Manual
  • Trader 函数
  • Kicking - bull/bear determined by the longer marubozu

trader_cdlkickingbylength

(PECL trader >= 0.2.0)

trader_cdlkickingbylength — Kicking - bull/bear determined by the longer marubozu

说明

trader_cdlkickingbylength ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Ladder Bottom

  • ? trader_cdlkickingbylength
  • trader_cdllongleggeddoji ?
  • PHP Manual
  • Trader 函数
  • Ladder Bottom

trader_cdlladderbottom

(PECL trader >= 0.2.0)

trader_cdlladderbottom — Ladder Bottom

说明

trader_cdlladderbottom ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Long Legged Doji

  • ? trader_cdlladderbottom
  • trader_cdllongline ?
  • PHP Manual
  • Trader 函数
  • Long Legged Doji

trader_cdllongleggeddoji

(PECL trader >= 0.2.0)

trader_cdllongleggeddoji — Long Legged Doji

说明

trader_cdllongleggeddoji ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Long Line Candle

  • ? trader_cdllongleggeddoji
  • trader_cdlmarubozu ?
  • PHP Manual
  • Trader 函数
  • Long Line Candle

trader_cdllongline

(PECL trader >= 0.2.0)

trader_cdllongline — Long Line Candle

说明

trader_cdllongline ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Marubozu

  • ? trader_cdllongline
  • trader_cdlmatchinglow ?
  • PHP Manual
  • Trader 函数
  • Marubozu

trader_cdlmarubozu

(PECL trader >= 0.2.0)

trader_cdlmarubozu — Marubozu

说明

trader_cdlmarubozu ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Matching Low

  • ? trader_cdlmarubozu
  • trader_cdlmathold ?
  • PHP Manual
  • Trader 函数
  • Matching Low

trader_cdlmatchinglow

(PECL trader >= 0.2.0)

trader_cdlmatchinglow — Matching Low

说明

trader_cdlmatchinglow ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Mat Hold

  • ? trader_cdlmatchinglow
  • trader_cdlmorningdojistar ?
  • PHP Manual
  • Trader 函数
  • Mat Hold

trader_cdlmathold

(PECL trader >= 0.2.0)

trader_cdlmathold — Mat Hold

说明

trader_cdlmathold ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

penetration

一个烛台渗入到另一个烛台的百分比。

返回值

Returns an array with calculated data or false on failure.


Morning Doji Star

  • ? trader_cdlmathold
  • trader_cdlmorningstar ?
  • PHP Manual
  • Trader 函数
  • Morning Doji Star

trader_cdlmorningdojistar

(PECL trader >= 0.2.0)

trader_cdlmorningdojistar — Morning Doji Star

说明

trader_cdlmorningdojistar ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

penetration

一个烛台渗入到另一个烛台的百分比。

返回值

Returns an array with calculated data or false on failure.


Morning Star

  • ? trader_cdlmorningdojistar
  • trader_cdlonneck ?
  • PHP Manual
  • Trader 函数
  • Morning Star

trader_cdlmorningstar

(PECL trader >= 0.2.0)

trader_cdlmorningstar — Morning Star

说明

trader_cdlmorningstar ( array $open , array $high , array $low , array $close , float $penetration = ? ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

penetration

一个烛台渗入到另一个烛台的百分比。

返回值

Returns an array with calculated data or false on failure.


On-Neck Pattern

  • ? trader_cdlmorningstar
  • trader_cdlpiercing ?
  • PHP Manual
  • Trader 函数
  • On-Neck Pattern

trader_cdlonneck

(PECL trader >= 0.2.0)

trader_cdlonneck — On-Neck Pattern

说明

trader_cdlonneck ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Piercing Pattern

  • ? trader_cdlonneck
  • trader_cdlrickshawman ?
  • PHP Manual
  • Trader 函数
  • Piercing Pattern

trader_cdlpiercing

(PECL trader >= 0.2.0)

trader_cdlpiercing — Piercing Pattern

说明

trader_cdlpiercing ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Rickshaw Man

  • ? trader_cdlpiercing
  • trader_cdlrisefall3methods ?
  • PHP Manual
  • Trader 函数
  • Rickshaw Man

trader_cdlrickshawman

(PECL trader >= 0.2.0)

trader_cdlrickshawman — Rickshaw Man

说明

trader_cdlrickshawman ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Rising/Falling Three Methods

  • ? trader_cdlrickshawman
  • trader_cdlseparatinglines ?
  • PHP Manual
  • Trader 函数
  • Rising/Falling Three Methods

trader_cdlrisefall3methods

(PECL trader >= 0.2.0)

trader_cdlrisefall3methods — Rising/Falling Three Methods

说明

trader_cdlrisefall3methods ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Separating Lines

  • ? trader_cdlrisefall3methods
  • trader_cdlshootingstar ?
  • PHP Manual
  • Trader 函数
  • Separating Lines

trader_cdlseparatinglines

(PECL trader >= 0.2.0)

trader_cdlseparatinglines — Separating Lines

说明

trader_cdlseparatinglines ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Shooting Star

  • ? trader_cdlseparatinglines
  • trader_cdlshortline ?
  • PHP Manual
  • Trader 函数
  • Shooting Star

trader_cdlshootingstar

(PECL trader >= 0.2.0)

trader_cdlshootingstar — Shooting Star

说明

trader_cdlshootingstar ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Short Line Candle

  • ? trader_cdlshootingstar
  • trader_cdlspinningtop ?
  • PHP Manual
  • Trader 函数
  • Short Line Candle

trader_cdlshortline

(PECL trader >= 0.2.0)

trader_cdlshortline — Short Line Candle

说明

trader_cdlshortline ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Spinning Top

  • ? trader_cdlshortline
  • trader_cdlstalledpattern ?
  • PHP Manual
  • Trader 函数
  • Spinning Top

trader_cdlspinningtop

(PECL trader >= 0.2.0)

trader_cdlspinningtop — Spinning Top

说明

trader_cdlspinningtop ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Stalled Pattern

  • ? trader_cdlspinningtop
  • trader_cdlsticksandwich ?
  • PHP Manual
  • Trader 函数
  • Stalled Pattern

trader_cdlstalledpattern

(PECL trader >= 0.2.0)

trader_cdlstalledpattern — Stalled Pattern

说明

trader_cdlstalledpattern ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Stick Sandwich

  • ? trader_cdlstalledpattern
  • trader_cdltakuri ?
  • PHP Manual
  • Trader 函数
  • Stick Sandwich

trader_cdlsticksandwich

(PECL trader >= 0.2.0)

trader_cdlsticksandwich — Stick Sandwich

说明

trader_cdlsticksandwich ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Takuri (Dragonfly Doji with very long lower shadow)

  • ? trader_cdlsticksandwich
  • trader_cdltasukigap ?
  • PHP Manual
  • Trader 函数
  • Takuri (Dragonfly Doji with very long lower shadow)

trader_cdltakuri

(PECL trader >= 0.2.0)

trader_cdltakuri — Takuri (Dragonfly Doji with very long lower shadow)

说明

trader_cdltakuri ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Tasuki Gap

  • ? trader_cdltakuri
  • trader_cdlthrusting ?
  • PHP Manual
  • Trader 函数
  • Tasuki Gap

trader_cdltasukigap

(PECL trader >= 0.2.0)

trader_cdltasukigap — Tasuki Gap

说明

trader_cdltasukigap ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Thrusting Pattern

  • ? trader_cdltasukigap
  • trader_cdltristar ?
  • PHP Manual
  • Trader 函数
  • Thrusting Pattern

trader_cdlthrusting

(PECL trader >= 0.2.0)

trader_cdlthrusting — Thrusting Pattern

说明

trader_cdlthrusting ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Tristar Pattern

  • ? trader_cdlthrusting
  • trader_cdlunique3river ?
  • PHP Manual
  • Trader 函数
  • Tristar Pattern

trader_cdltristar

(PECL trader >= 0.2.0)

trader_cdltristar — Tristar Pattern

说明

trader_cdltristar ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Unique 3 River

  • ? trader_cdltristar
  • trader_cdlupsidegap2crows ?
  • PHP Manual
  • Trader 函数
  • Unique 3 River

trader_cdlunique3river

(PECL trader >= 0.2.0)

trader_cdlunique3river — Unique 3 River

说明

trader_cdlunique3river ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Upside Gap Two Crows

  • ? trader_cdlunique3river
  • trader_cdlxsidegap3methods ?
  • PHP Manual
  • Trader 函数
  • Upside Gap Two Crows

trader_cdlupsidegap2crows

(PECL trader >= 0.2.0)

trader_cdlupsidegap2crows — Upside Gap Two Crows

说明

trader_cdlupsidegap2crows ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Upside/Downside Gap Three Methods

  • ? trader_cdlupsidegap2crows
  • trader_ceil ?
  • PHP Manual
  • Trader 函数
  • Upside/Downside Gap Three Methods

trader_cdlxsidegap3methods

(PECL trader >= 0.2.0)

trader_cdlxsidegap3methods — Upside/Downside Gap Three Methods

说明

trader_cdlxsidegap3methods ( array $open , array $high , array $low , array $close ) : array

参数

open

开盘价，浮点数数组。

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Vector Ceil

  • ? trader_cdlxsidegap3methods
  • trader_cmo ?
  • PHP Manual
  • Trader 函数
  • Vector Ceil

trader_ceil

(PECL trader >= 0.2.0)

trader_ceil — Vector Ceil

说明

trader_ceil ( array $real ) : array

Calculates the next highest integer for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Chande Momentum Oscillator

  • ? trader_ceil
  • trader_correl ?
  • PHP Manual
  • Trader 函数
  • Chande Momentum Oscillator

trader_cmo

(PECL trader >= 0.2.0)

trader_cmo — Chande Momentum Oscillator

说明

trader_cmo ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Pearson's Correlation Coefficient (r)

  • ? trader_cmo
  • trader_cos ?
  • PHP Manual
  • Trader 函数
  • Pearson's Correlation Coefficient (r)

trader_correl

(PECL trader >= 0.2.0)

trader_correl — Pearson's Correlation Coefficient (r)

说明

trader_correl ( array $real0 , array $real1 , int $timePeriod = ? ) : array

参数

real0

浮点数数组。

real1

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Vector Trigonometric Cos

  • ? trader_correl
  • trader_cosh ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric Cos

trader_cos

(PECL trader >= 0.2.0)

trader_cos — Vector Trigonometric Cos

说明

trader_cos ( array $real ) : array

Calculates the cosine for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Vector Trigonometric Cosh

  • ? trader_cos
  • trader_dema ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric Cosh

trader_cosh

(PECL trader >= 0.2.0)

trader_cosh — Vector Trigonometric Cosh

说明

trader_cosh ( array $real ) : array

Calculates the hyperbolic cosine for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Double Exponential Moving Average

  • ? trader_cosh
  • trader_div ?
  • PHP Manual
  • Trader 函数
  • Double Exponential Moving Average

trader_dema

(PECL trader >= 0.2.0)

trader_dema — Double Exponential Moving Average

说明

trader_dema ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Vector Arithmetic Div

  • ? trader_dema
  • trader_dx ?
  • PHP Manual
  • Trader 函数
  • Vector Arithmetic Div

trader_div

(PECL trader >= 0.2.0)

trader_div — Vector Arithmetic Div

说明

trader_div ( array $real0 , array $real1 ) : array

Divides each value from real0 by the corresponding value from real1 and returns the resulting array.

参数

real0

浮点数数组。

real1

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Directional Movement Index

  • ? trader_div
  • trader_ema ?
  • PHP Manual
  • Trader 函数
  • Directional Movement Index

trader_dx

(PECL trader >= 0.2.0)

trader_dx — Directional Movement Index

说明

trader_dx ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Exponential Moving Average

  • ? trader_dx
  • trader_errno ?
  • PHP Manual
  • Trader 函数
  • Exponential Moving Average

trader_ema

(PECL trader >= 0.2.0)

trader_ema — Exponential Moving Average

说明

trader_ema ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Get error code

  • ? trader_ema
  • trader_exp ?
  • PHP Manual
  • Trader 函数
  • Get error code

trader_errno

(PECL trader >= 0.3.0)

trader_errno — Get error code

说明

trader_errno ( ) : int

Get error code of the last operation.

返回值

Returns the error code identified by one of the TRADER_ERR_* constants.


Vector Arithmetic Exp

  • ? trader_errno
  • trader_floor ?
  • PHP Manual
  • Trader 函数
  • Vector Arithmetic Exp

trader_exp

(PECL trader >= 0.2.0)

trader_exp — Vector Arithmetic Exp

说明

trader_exp ( array $real ) : array

Calculates e raised to the power of each value in real. Returns an array with the calculated data.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Vector Floor

  • ? trader_exp
  • trader_get_compat ?
  • PHP Manual
  • Trader 函数
  • Vector Floor

trader_floor

(PECL trader >= 0.2.0)

trader_floor — Vector Floor

说明

trader_floor ( array $real ) : array

Calculates the next lowest integer for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Get compatibility mode

  • ? trader_floor
  • trader_get_unstable_period ?
  • PHP Manual
  • Trader 函数
  • Get compatibility mode

trader_get_compat

(PECL trader >= 0.2.2)

trader_get_compat — Get compatibility mode

说明

trader_get_compat ( ) : int

Get compatibility mode which affects the way calculations are done by all the extension functions.

返回值

Returns the compatibility mode id which can be identified by TRADER_COMPATIBILITY_* series of constants.


Get unstable period

  • ? trader_get_compat
  • trader_ht_dcperiod ?
  • PHP Manual
  • Trader 函数
  • Get unstable period

trader_get_unstable_period

(PECL trader >= 0.2.2)

trader_get_unstable_period — Get unstable period

说明

trader_get_unstable_period ( int $functionId ) : int

Get unstable period factor for a particular function.

参数

functionId

Function ID the factor to be read for. TRADER_FUNC_UNST_* series of constants should be used.

返回值

Returns the unstable period factor for the corresponding function.


Hilbert Transform - Dominant Cycle Period

  • ? trader_get_unstable_period
  • trader_ht_dcphase ?
  • PHP Manual
  • Trader 函数
  • Hilbert Transform - Dominant Cycle Period

trader_ht_dcperiod

(PECL trader >= 0.2.0)

trader_ht_dcperiod — Hilbert Transform - Dominant Cycle Period

说明

trader_ht_dcperiod ( array $real ) : array

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Hilbert Transform - Dominant Cycle Phase

  • ? trader_ht_dcperiod
  • trader_ht_phasor ?
  • PHP Manual
  • Trader 函数
  • Hilbert Transform - Dominant Cycle Phase

trader_ht_dcphase

(PECL trader >= 0.2.0)

trader_ht_dcphase — Hilbert Transform - Dominant Cycle Phase

说明

trader_ht_dcphase ( array $real ) : array

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Hilbert Transform - Phasor Components

  • ? trader_ht_dcphase
  • trader_ht_sine ?
  • PHP Manual
  • Trader 函数
  • Hilbert Transform - Phasor Components

trader_ht_phasor

(PECL trader >= 0.2.0)

trader_ht_phasor — Hilbert Transform - Phasor Components

说明

trader_ht_phasor ( array $real ) : array

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Hilbert Transform - SineWave

  • ? trader_ht_phasor
  • trader_ht_trendline ?
  • PHP Manual
  • Trader 函数
  • Hilbert Transform - SineWave

trader_ht_sine

(PECL trader >= 0.2.0)

trader_ht_sine — Hilbert Transform - SineWave

说明

trader_ht_sine ( array $real ) : array

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Hilbert Transform - Instantaneous Trendline

  • ? trader_ht_sine
  • trader_ht_trendmode ?
  • PHP Manual
  • Trader 函数
  • Hilbert Transform - Instantaneous Trendline

trader_ht_trendline

(PECL trader >= 0.2.0)

trader_ht_trendline — Hilbert Transform - Instantaneous Trendline

说明

trader_ht_trendline ( array $real ) : array

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Hilbert Transform - Trend vs Cycle Mode

  • ? trader_ht_trendline
  • trader_kama ?
  • PHP Manual
  • Trader 函数
  • Hilbert Transform - Trend vs Cycle Mode

trader_ht_trendmode

(PECL trader >= 0.2.0)

trader_ht_trendmode — Hilbert Transform - Trend vs Cycle Mode

说明

trader_ht_trendmode ( array $real ) : array

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Kaufman Adaptive Moving Average

  • ? trader_ht_trendmode
  • trader_linearreg_angle ?
  • PHP Manual
  • Trader 函数
  • Kaufman Adaptive Moving Average

trader_kama

(PECL trader >= 0.2.0)

trader_kama — Kaufman Adaptive Moving Average

说明

trader_kama ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Linear Regression Angle

  • ? trader_kama
  • trader_linearreg_intercept ?
  • PHP Manual
  • Trader 函数
  • Linear Regression Angle

trader_linearreg_angle

(PECL trader >= 0.2.0)

trader_linearreg_angle — Linear Regression Angle

说明

trader_linearreg_angle ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Linear Regression Intercept

  • ? trader_linearreg_angle
  • trader_linearreg_slope ?
  • PHP Manual
  • Trader 函数
  • Linear Regression Intercept

trader_linearreg_intercept

(PECL trader >= 0.2.0)

trader_linearreg_intercept — Linear Regression Intercept

说明

trader_linearreg_intercept ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Linear Regression Slope

  • ? trader_linearreg_intercept
  • trader_linearreg ?
  • PHP Manual
  • Trader 函数
  • Linear Regression Slope

trader_linearreg_slope

(PECL trader >= 0.2.0)

trader_linearreg_slope — Linear Regression Slope

说明

trader_linearreg_slope ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Linear Regression

  • ? trader_linearreg_slope
  • trader_ln ?
  • PHP Manual
  • Trader 函数
  • Linear Regression

trader_linearreg

(PECL trader >= 0.2.0)

trader_linearreg — Linear Regression

说明

trader_linearreg ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Vector Log Natural

  • ? trader_linearreg
  • trader_log10 ?
  • PHP Manual
  • Trader 函数
  • Vector Log Natural

trader_ln

(PECL trader >= 0.2.0)

trader_ln — Vector Log Natural

说明

trader_ln ( array $real ) : array

Calculates the natural logarithm for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Vector Log10

  • ? trader_ln
  • trader_ma ?
  • PHP Manual
  • Trader 函数
  • Vector Log10

trader_log10

(PECL trader >= 0.2.0)

trader_log10 — Vector Log10

说明

trader_log10 ( array $real ) : array

Calculates the base-10 logarithm for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Moving average

  • ? trader_log10
  • trader_macd ?
  • PHP Manual
  • Trader 函数
  • Moving average

trader_ma

(PECL trader >= 0.2.0)

trader_ma — Moving average

说明

trader_ma ( array $real , int $timePeriod = ? , int $mAType = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Moving Average Convergence/Divergence

  • ? trader_ma
  • trader_macdext ?
  • PHP Manual
  • Trader 函数
  • Moving Average Convergence/Divergence

trader_macd

(PECL trader >= 0.2.0)

trader_macd — Moving Average Convergence/Divergence

说明

trader_macd ( array $real , int $fastPeriod = ? , int $slowPeriod = ? , int $signalPeriod = ? ) : array

参数

real

浮点数数组。

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

signalPeriod

Smoothing for the signal line (nb of period). Valid range from 1 to 100000.

返回值

Returns an array with calculated data or false on failure.


MACD with controllable MA type

  • ? trader_macd
  • trader_macdfix ?
  • PHP Manual
  • Trader 函数
  • MACD with controllable MA type

trader_macdext

(PECL trader >= 0.2.0)

trader_macdext — MACD with controllable MA type

说明

trader_macdext ( array $real , int $fastPeriod = ? , int $fastMAType = ? , int $slowPeriod = ? , int $slowMAType = ? , int $signalPeriod = ? , int $signalMAType = ? ) : array

参数

real

浮点数数组。

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

fastMAType

Type of Moving Average for fast MA. TRADER_MA_TYPE_* series of constants should be used.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

slowMAType

Type of Moving Average for slow MA. TRADER_MA_TYPE_* series of constants should be used.

signalPeriod

Smoothing for the signal line (nb of period). Valid range from 1 to 100000.

signalMAType

Type of Moving Average for signal line. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Moving Average Convergence/Divergence Fix 12/26

  • ? trader_macdext
  • trader_mama ?
  • PHP Manual
  • Trader 函数
  • Moving Average Convergence/Divergence Fix 12/26

trader_macdfix

(PECL trader >= 0.2.0)

trader_macdfix — Moving Average Convergence/Divergence Fix 12/26

说明

trader_macdfix ( array $real , int $signalPeriod = ? ) : array

参数

real

浮点数数组。

signalPeriod

Smoothing for the signal line (nb of period). Valid range from 1 to 100000.

返回值

Returns an array with calculated data or false on failure.


MESA Adaptive Moving Average

  • ? trader_macdfix
  • trader_mavp ?
  • PHP Manual
  • Trader 函数
  • MESA Adaptive Moving Average

trader_mama

(PECL trader >= 0.2.0)

trader_mama — MESA Adaptive Moving Average

说明

trader_mama ( array $real , float $fastLimit = ? , float $slowLimit = ? ) : array

参数

real

浮点数数组。

fastLimit

Upper limit use in the adaptive algorithm. Valid range from 0.01 to 0.99.

slowLimit

Lower limit use in the adaptive algorithm. Valid range from 0.01 to 0.99.

返回值

Returns an array with calculated data or false on failure.


Moving average with variable period

  • ? trader_mama
  • trader_max ?
  • PHP Manual
  • Trader 函数
  • Moving average with variable period

trader_mavp

(PECL trader >= 0.2.0)

trader_mavp — Moving average with variable period

说明

trader_mavp ( array $real , array $periods , int $minPeriod = ? , int $maxPeriod = ? , int $mAType = ? ) : array

参数

real

浮点数数组。

periods

浮点数数组。

minPeriod

Value less than minimum will be changed to Minimum period. Valid range from 2 to 100000

maxPeriod

Value higher than minimum will be changed to Maximum period. Valid range from 2 to 100000

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Highest value over a specified period

  • ? trader_mavp
  • trader_maxindex ?
  • PHP Manual
  • Trader 函数
  • Highest value over a specified period

trader_max

(PECL trader >= 0.2.0)

trader_max — Highest value over a specified period

说明

trader_max ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Index of highest value over a specified period

  • ? trader_max
  • trader_medprice ?
  • PHP Manual
  • Trader 函数
  • Index of highest value over a specified period

trader_maxindex

(PECL trader >= 0.2.0)

trader_maxindex — Index of highest value over a specified period

说明

trader_maxindex ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Median Price

  • ? trader_maxindex
  • trader_mfi ?
  • PHP Manual
  • Trader 函数
  • Median Price

trader_medprice

(PECL trader >= 0.2.0)

trader_medprice — Median Price

说明

trader_medprice ( array $high , array $low ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Money Flow Index

  • ? trader_medprice
  • trader_midpoint ?
  • PHP Manual
  • Trader 函数
  • Money Flow Index

trader_mfi

(PECL trader >= 0.2.0)

trader_mfi — Money Flow Index

说明

trader_mfi ( array $high , array $low , array $close , array $volume , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

volume

成交量，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


MidPoint over period

  • ? trader_mfi
  • trader_midprice ?
  • PHP Manual
  • Trader 函数
  • MidPoint over period

trader_midpoint

(PECL trader >= 0.2.0)

trader_midpoint — MidPoint over period

说明

trader_midpoint ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Midpoint Price over period

  • ? trader_midpoint
  • trader_min ?
  • PHP Manual
  • Trader 函数
  • Midpoint Price over period

trader_midprice

(PECL trader >= 0.2.0)

trader_midprice — Midpoint Price over period

说明

trader_midprice ( array $high , array $low , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Lowest value over a specified period

  • ? trader_midprice
  • trader_minindex ?
  • PHP Manual
  • Trader 函数
  • Lowest value over a specified period

trader_min

(PECL trader >= 0.2.0)

trader_min — Lowest value over a specified period

说明

trader_min ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Index of lowest value over a specified period

  • ? trader_min
  • trader_minmax ?
  • PHP Manual
  • Trader 函数
  • Index of lowest value over a specified period

trader_minindex

(PECL trader >= 0.2.0)

trader_minindex — Index of lowest value over a specified period

说明

trader_minindex ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Lowest and highest values over a specified period

  • ? trader_minindex
  • trader_minmaxindex ?
  • PHP Manual
  • Trader 函数
  • Lowest and highest values over a specified period

trader_minmax

(PECL trader >= 0.2.0)

trader_minmax — Lowest and highest values over a specified period

说明

trader_minmax ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Indexes of lowest and highest values over a specified period

  • ? trader_minmax
  • trader_minus_di ?
  • PHP Manual
  • Trader 函数
  • Indexes of lowest and highest values over a specified period

trader_minmaxindex

(PECL trader >= 0.2.0)

trader_minmaxindex — Indexes of lowest and highest values over a specified period

说明

trader_minmaxindex ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Minus Directional Indicator

  • ? trader_minmaxindex
  • trader_minus_dm ?
  • PHP Manual
  • Trader 函数
  • Minus Directional Indicator

trader_minus_di

(PECL trader >= 0.2.0)

trader_minus_di — Minus Directional Indicator

说明

trader_minus_di ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Minus Directional Movement

  • ? trader_minus_di
  • trader_mom ?
  • PHP Manual
  • Trader 函数
  • Minus Directional Movement

trader_minus_dm

(PECL trader >= 0.2.0)

trader_minus_dm — Minus Directional Movement

说明

trader_minus_dm ( array $high , array $low , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Momentum

  • ? trader_minus_dm
  • trader_mult ?
  • PHP Manual
  • Trader 函数
  • Momentum

trader_mom

(PECL trader >= 0.2.0)

trader_mom — Momentum

说明

trader_mom ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Vector Arithmetic Mult

  • ? trader_mom
  • trader_natr ?
  • PHP Manual
  • Trader 函数
  • Vector Arithmetic Mult

trader_mult

(PECL trader >= 0.2.0)

trader_mult — Vector Arithmetic Mult

说明

trader_mult ( array $real0 , array $real1 ) : array

Calculates the vector dot product of real0 with real1 and returns the resulting vector.

参数

real0

浮点数数组。

real1

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Normalized Average True Range

  • ? trader_mult
  • trader_obv ?
  • PHP Manual
  • Trader 函数
  • Normalized Average True Range

trader_natr

(PECL trader >= 0.2.0)

trader_natr — Normalized Average True Range

说明

trader_natr ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


On Balance Volume

  • ? trader_natr
  • trader_plus_di ?
  • PHP Manual
  • Trader 函数
  • On Balance Volume

trader_obv

(PECL trader >= 0.2.0)

trader_obv — On Balance Volume

说明

trader_obv ( array $real , array $volume ) : array

参数

real

浮点数数组。

volume

成交量，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Plus Directional Indicator

  • ? trader_obv
  • trader_plus_dm ?
  • PHP Manual
  • Trader 函数
  • Plus Directional Indicator

trader_plus_di

(PECL trader >= 0.2.0)

trader_plus_di — Plus Directional Indicator

说明

trader_plus_di ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Plus Directional Movement

  • ? trader_plus_di
  • trader_ppo ?
  • PHP Manual
  • Trader 函数
  • Plus Directional Movement

trader_plus_dm

(PECL trader >= 0.2.0)

trader_plus_dm — Plus Directional Movement

说明

trader_plus_dm ( array $high , array $low , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Percentage Price Oscillator

  • ? trader_plus_dm
  • trader_roc ?
  • PHP Manual
  • Trader 函数
  • Percentage Price Oscillator

trader_ppo

(PECL trader >= 0.2.0)

trader_ppo — Percentage Price Oscillator

说明

trader_ppo ( array $real , int $fastPeriod = ? , int $slowPeriod = ? , int $mAType = ? ) : array

参数

real

浮点数数组。

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Rate of change : ((price/prevPrice)-1)*100

  • ? trader_ppo
  • trader_rocp ?
  • PHP Manual
  • Trader 函数
  • Rate of change : ((price/prevPrice)-1)*100

trader_roc

(PECL trader >= 0.2.0)

trader_roc — Rate of change : ((price/prevPrice)-1)*100

说明

trader_roc ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Rate of change Percentage: (price-prevPrice)/prevPrice

  • ? trader_roc
  • trader_rocr100 ?
  • PHP Manual
  • Trader 函数
  • Rate of change Percentage: (price-prevPrice)/prevPrice

trader_rocp

(PECL trader >= 0.2.0)

trader_rocp — Rate of change Percentage: (price-prevPrice)/prevPrice

说明

trader_rocp ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Rate of change ratio 100 scale: (price/prevPrice)*100

  • ? trader_rocp
  • trader_rocr ?
  • PHP Manual
  • Trader 函数
  • Rate of change ratio 100 scale: (price/prevPrice)*100

trader_rocr100

(PECL trader >= 0.2.0)

trader_rocr100 — Rate of change ratio 100 scale: (price/prevPrice)*100

说明

trader_rocr100 ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Rate of change ratio: (price/prevPrice)

  • ? trader_rocr100
  • trader_rsi ?
  • PHP Manual
  • Trader 函数
  • Rate of change ratio: (price/prevPrice)

trader_rocr

(PECL trader >= 0.2.0)

trader_rocr — Rate of change ratio: (price/prevPrice)

说明

trader_rocr ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Relative Strength Index

  • ? trader_rocr
  • trader_sar ?
  • PHP Manual
  • Trader 函数
  • Relative Strength Index

trader_rsi

(PECL trader >= 0.2.0)

trader_rsi — Relative Strength Index

说明

trader_rsi ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Parabolic SAR

  • ? trader_rsi
  • trader_sarext ?
  • PHP Manual
  • Trader 函数
  • Parabolic SAR

trader_sar

(PECL trader >= 0.2.0)

trader_sar — Parabolic SAR

说明

trader_sar ( array $high , array $low , float $acceleration = ? , float $maximum = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

acceleration

Acceleration Factor used up to the Maximum value. Valid range from 0 to TRADER_REAL_MAX.

maximum

Acceleration Factor Maximum value. Valid range from 0 to TRADER_REAL_MAX.

返回值

Returns an array with calculated data or false on failure.


Parabolic SAR - Extended

  • ? trader_sar
  • trader_set_compat ?
  • PHP Manual
  • Trader 函数
  • Parabolic SAR - Extended

trader_sarext

(PECL trader >= 0.2.0)

trader_sarext — Parabolic SAR - Extended

说明

trader_sarext ( array $high , array $low , float $startValue = ? , float $offsetOnReverse = ? , float $accelerationInitLong = ? , float $accelerationLong = ? , float $accelerationMaxLong = ? , float $accelerationInitShort = ? , float $accelerationShort = ? , float $accelerationMaxShort = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

startValue

Start value and direction. 0 for Auto, >0 for Long, <0 for Short. Valid range from TRADER_REAL_MIN to TRADER_REAL_MAX.

offsetOnReverse

Percent offset added/removed to initial stop on short/long reversal. Valid range from 0 to TRADER_REAL_MAX.

accelerationInitLong

Acceleration Factor initial value for the Long direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationLong

Acceleration Factor for the Long direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationMaxLong

Acceleration Factor maximum value for the Long direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationInitShort

Acceleration Factor initial value for the Short direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationShort

Acceleration Factor for the Short direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationMaxShort

Acceleration Factor maximum value for the Short direction. Valid range from 0 to TRADER_REAL_MAX.

返回值

Returns an array with calculated data or false on failure.


Set compatibility mode

  • ? trader_sarext
  • trader_set_unstable_period ?
  • PHP Manual
  • Trader 函数
  • Set compatibility mode

trader_set_compat

(PECL trader >= 0.2.2)

trader_set_compat — Set compatibility mode

说明

trader_set_compat ( int $compatId ) : void

Set compatibility mode which will affect the way calculations are done by all the extension functions.

参数

compatId

Compatibility Id. TRADER_COMPATIBILITY_* series of constants should be used.

返回值

没有返回值。


Set unstable period

  • ? trader_set_compat
  • trader_sin ?
  • PHP Manual
  • Trader 函数
  • Set unstable period

trader_set_unstable_period

(PECL trader >= 0.2.2)

trader_set_unstable_period — Set unstable period

说明

trader_set_unstable_period ( int $functionId , int $timePeriod ) : void

Influences unstable period factor for functions, which are sensible to it. More information about unstable periods can be found on the » TA-Lib API documentation page.

参数

functionId

Function ID the factor should be set for. TRADER_FUNC_UNST_* constant series can be used to affect the corresponding function.

timePeriod

Unstable period value.

返回值

没有返回值。


Vector Trigonometric Sin

  • ? trader_set_unstable_period
  • trader_sinh ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric Sin

trader_sin

(PECL trader >= 0.2.0)

trader_sin — Vector Trigonometric Sin

说明

trader_sin ( array $real ) : array

Calculates the sine for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Vector Trigonometric Sinh

  • ? trader_sin
  • trader_sma ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric Sinh

trader_sinh

(PECL trader >= 0.2.0)

trader_sinh — Vector Trigonometric Sinh

说明

trader_sinh ( array $real ) : array

Calculates the hyperbolic sine for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Simple Moving Average

  • ? trader_sinh
  • trader_sqrt ?
  • PHP Manual
  • Trader 函数
  • Simple Moving Average

trader_sma

(PECL trader >= 0.2.0)

trader_sma — Simple Moving Average

说明

trader_sma ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Vector Square Root

  • ? trader_sma
  • trader_stddev ?
  • PHP Manual
  • Trader 函数
  • Vector Square Root

trader_sqrt

(PECL trader >= 0.2.0)

trader_sqrt — Vector Square Root

说明

trader_sqrt ( array $real ) : array

Calculates the square root of each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Standard Deviation

  • ? trader_sqrt
  • trader_stoch ?
  • PHP Manual
  • Trader 函数
  • Standard Deviation

trader_stddev

(PECL trader >= 0.2.0)

trader_stddev — Standard Deviation

说明

trader_stddev ( array $real , int $timePeriod = ? , float $nbDev = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

nbDev

返回值

Returns an array with calculated data or false on failure.


Stochastic

  • ? trader_stddev
  • trader_stochf ?
  • PHP Manual
  • Trader 函数
  • Stochastic

trader_stoch

(PECL trader >= 0.2.0)

trader_stoch — Stochastic

说明

trader_stoch ( array $high , array $low , array $close , int $fastK_Period = ? , int $slowK_Period = ? , int $slowK_MAType = ? , int $slowD_Period = ? , int $slowD_MAType = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

fastK_Period

Time period for building the Fast-K line. Valid range from 1 to 100000.

slowK_Period

Smoothing for making the Slow-K line. Valid range from 1 to 100000, usually set to 3.

slowK_MAType

Type of Moving Average for Slow-K. TRADER_MA_TYPE_* series of constants should be used.

slowD_Period

Smoothing for making the Slow-D line. Valid range from 1 to 100000.

slowD_MAType

Type of Moving Average for Slow-D. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Stochastic Fast

  • ? trader_stoch
  • trader_stochrsi ?
  • PHP Manual
  • Trader 函数
  • Stochastic Fast

trader_stochf

(PECL trader >= 0.2.0)

trader_stochf — Stochastic Fast

说明

trader_stochf ( array $high , array $low , array $close , int $fastK_Period = ? , int $fastD_Period = ? , int $fastD_MAType = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

fastK_Period

Time period for building the Fast-K line. Valid range from 1 to 100000.

fastD_Period

Smoothing for making the Fast-D line. Valid range from 1 to 100000, usually set to 3.

fastD_MAType

Type of Moving Average for Fast-D. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Stochastic Relative Strength Index

  • ? trader_stochf
  • trader_sub ?
  • PHP Manual
  • Trader 函数
  • Stochastic Relative Strength Index

trader_stochrsi

(PECL trader >= 0.2.0)

trader_stochrsi — Stochastic Relative Strength Index

说明

trader_stochrsi ( array $real , int $timePeriod = ? , int $fastK_Period = ? , int $fastD_Period = ? , int $fastD_MAType = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

fastK_Period

Time period for building the Fast-K line. Valid range from 1 to 100000.

fastD_Period

Smoothing for making the Fast-D line. Valid range from 1 to 100000, usually set to 3.

fastD_MAType

Type of Moving Average for Fast-D. TRADER_MA_TYPE_* series of constants should be used.

返回值

Returns an array with calculated data or false on failure.


Vector Arithmetic Subtraction

  • ? trader_stochrsi
  • trader_sum ?
  • PHP Manual
  • Trader 函数
  • Vector Arithmetic Subtraction

trader_sub

(PECL trader >= 0.2.0)

trader_sub — Vector Arithmetic Subtraction

说明

trader_sub ( array $real0 , array $real1 ) : array

Calculates the vector subtraction of real1 from real0 and returns the resulting vector.

参数

real0

浮点数数组。

real1

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Summation

  • ? trader_sub
  • trader_t3 ?
  • PHP Manual
  • Trader 函数
  • Summation

trader_sum

(PECL trader >= 0.2.0)

trader_sum — Summation

说明

trader_sum ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Triple Exponential Moving Average (T3)

  • ? trader_sum
  • trader_tan ?
  • PHP Manual
  • Trader 函数
  • Triple Exponential Moving Average (T3)

trader_t3

(PECL trader >= 0.2.0)

trader_t3 — Triple Exponential Moving Average (T3)

说明

trader_t3 ( array $real , int $timePeriod = ? , float $vFactor = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

vFactor

成交量因子。有效值从 0 到 1。

返回值

Returns an array with calculated data or false on failure.


Vector Trigonometric Tan

  • ? trader_t3
  • trader_tanh ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric Tan

trader_tan

(PECL trader >= 0.2.0)

trader_tan — Vector Trigonometric Tan

说明

trader_tan ( array $real ) : array

Calculates the tangent for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Vector Trigonometric Tanh

  • ? trader_tan
  • trader_tema ?
  • PHP Manual
  • Trader 函数
  • Vector Trigonometric Tanh

trader_tanh

(PECL trader >= 0.2.0)

trader_tanh — Vector Trigonometric Tanh

说明

trader_tanh ( array $real ) : array

Calculates the hyperbolic tangent for each value in real and returns the resulting array.

参数

real

浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Triple Exponential Moving Average

  • ? trader_tanh
  • trader_trange ?
  • PHP Manual
  • Trader 函数
  • Triple Exponential Moving Average

trader_tema

(PECL trader >= 0.2.0)

trader_tema — Triple Exponential Moving Average

说明

trader_tema ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


True Range

  • ? trader_tema
  • trader_trima ?
  • PHP Manual
  • Trader 函数
  • True Range

trader_trange

(PECL trader >= 0.2.0)

trader_trange — True Range

说明

trader_trange ( array $high , array $low , array $close ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Triangular Moving Average

  • ? trader_trange
  • trader_trix ?
  • PHP Manual
  • Trader 函数
  • Triangular Moving Average

trader_trima

(PECL trader >= 0.2.0)

trader_trima — Triangular Moving Average

说明

trader_trima ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


1-day Rate-Of-Change (ROC) of a Triple Smooth EMA

  • ? trader_trima
  • trader_tsf ?
  • PHP Manual
  • Trader 函数
  • 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA

trader_trix

(PECL trader >= 0.2.0)

trader_trix — 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA

说明

trader_trix ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Time Series Forecast

  • ? trader_trix
  • trader_typprice ?
  • PHP Manual
  • Trader 函数
  • Time Series Forecast

trader_tsf

(PECL trader >= 0.2.0)

trader_tsf — Time Series Forecast

说明

trader_tsf ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Typical Price

  • ? trader_tsf
  • trader_ultosc ?
  • PHP Manual
  • Trader 函数
  • Typical Price

trader_typprice

(PECL trader >= 0.2.0)

trader_typprice — Typical Price

说明

trader_typprice ( array $high , array $low , array $close ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Ultimate Oscillator

  • ? trader_typprice
  • trader_var ?
  • PHP Manual
  • Trader 函数
  • Ultimate Oscillator

trader_ultosc

(PECL trader >= 0.2.0)

trader_ultosc — Ultimate Oscillator

说明

trader_ultosc ( array $high , array $low , array $close , int $timePeriod1 = ? , int $timePeriod2 = ? , int $timePeriod3 = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod1

Number of bars for 1st period. Valid range from 1 to 100000.

timePeriod2

Number of bars for 2nd period. Valid range from 1 to 100000.

timePeriod3

Number of bars for 3rd period. Valid range from 1 to 100000.

返回值

Returns an array with calculated data or false on failure.


Variance

  • ? trader_ultosc
  • trader_wclprice ?
  • PHP Manual
  • Trader 函数
  • Variance

trader_var

(PECL trader >= 0.2.0)

trader_var — Variance

说明

trader_var ( array $real , int $timePeriod = ? , float $nbDev = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

nbDev

返回值

Returns an array with calculated data or false on failure.


Weighted Close Price

  • ? trader_var
  • trader_willr ?
  • PHP Manual
  • Trader 函数
  • Weighted Close Price

trader_wclprice

(PECL trader >= 0.2.0)

trader_wclprice — Weighted Close Price

说明

trader_wclprice ( array $high , array $low , array $close ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

返回值

Returns an array with calculated data or false on failure.


Williams' %R

  • ? trader_wclprice
  • trader_wma ?
  • PHP Manual
  • Trader 函数
  • Williams' %R

trader_willr

(PECL trader >= 0.2.0)

trader_willr — Williams' %R

说明

trader_willr ( array $high , array $low , array $close , int $timePeriod = ? ) : array

参数

high

高价，浮点数数组。

low

低价，浮点数数组。

close

收盘价，浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


Weighted Moving Average

  • ? trader_willr
  • 非文本内容的 MIME 输出 ?
  • PHP Manual
  • Trader 函数
  • Weighted Moving Average

trader_wma

(PECL trader >= 0.2.0)

trader_wma — Weighted Moving Average

说明

trader_wma ( array $real , int $timePeriod = ? ) : array

参数

real

浮点数数组。

timePeriod

Number of period. Valid range from 2 to 100000.

返回值

Returns an array with calculated data or false on failure.


非文本内容的 MIME 输出

  • FDF — Forms Data Format
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • FDF 函数
  • GnuPG — GNU Privacy Guard
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • GnuPG 函数
  • wkhtmltox
    • 简介
    • 安装／配置
    • wkhtmltox\PDF\Converter — The wkhtmltox\PDF\Converter class
    • wkhtmltox\PDF\Object — The wkhtmltox\PDF\Object class
    • wkhtmltox\Image\Converter — The wkhtmltox\Image\Converter class
  • PS — PostScript document creation
    • 简介
    • 安装／配置
    • 预定义常量
    • PS 函数
  • RpmInfo
    • 简介
    • 安装／配置
    • 预定义常量
    • RpmInfo 函数
  • XLSWriter
    • 简介
    • 安装／配置
    • 预定义常量
    • Vtiful\Kernel\Excel — The Vtiful\Kernel\Excel class
    • Vtiful\Kernel\Format — The Vtiful\Kernel\Format class


Forms Data Format

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • FDF 函数
    • fdf_add_doc_javascript — Adds javascript code to the FDF document
    • fdf_add_template — Adds a template into the FDF document
    • fdf_close — Close an FDF document
    • fdf_create — Create a new FDF document
    • fdf_enum_values — Call a user defined function for each document value
    • fdf_errno — Return error code for last fdf operation
    • fdf_error — Return error description for FDF error code
    • fdf_get_ap — Get the appearance of a field
    • fdf_get_attachment — Extracts uploaded file embedded in the FDF
    • fdf_get_encoding — Get the value of the /Encoding key
    • fdf_get_file — Get the value of the /F key
    • fdf_get_flags — Gets the flags of a field
    • fdf_get_opt — Gets a value from the opt array of a field
    • fdf_get_status — Get the value of the /STATUS key
    • fdf_get_value — Get the value of a field
    • fdf_get_version — Gets version number for FDF API or file
    • fdf_header — Sets FDF-specific output headers
    • fdf_next_field_name — Get the next field name
    • fdf_open_string — Read a FDF document from a string
    • fdf_open — Open a FDF document
    • fdf_remove_item — Sets target frame for form
    • fdf_save_string — Returns the FDF document as a string
    • fdf_save — Save a FDF document
    • fdf_set_ap — Set the appearance of a field
    • fdf_set_encoding — Sets FDF character encoding
    • fdf_set_file — Set PDF document to display FDF data in
    • fdf_set_flags — Sets a flag of a field
    • fdf_set_javascript_action — Sets an javascript action of a field
    • fdf_set_on_import_javascript — Adds javascript code to be executed when Acrobat opens the FDF
    • fdf_set_opt — Sets an option of a field
    • fdf_set_status — Set the value of the /STATUS key
    • fdf_set_submit_form_action — Sets a submit form action of a field
    • fdf_set_target_frame — Set target frame for form display
    • fdf_set_value — Set the value of a field
    • fdf_set_version — Sets version number for a FDF file


简介

Forms Data Format (FDF) is a format for handling forms within PDF documents. You should read the documentation at » http://www.adobe.com/devnet/acrobat/fdftoolkit.html for more information on what FDF is and how it is used in general.

The general idea of FDF is similar to HTML forms. The difference is basically the format how data is transmitted to the server when the submit button is pressed (this is actually the Form Data Format) and the format of the form itself (which is the Portable Document Format, PDF). Processing the FDF data is one of the features provided by the fdf functions. But there is more. One may as well take an existing PDF form and populated the input fields with data without modifying the form itself. In such a case one would create a FDF document (fdf_create()) set the values of each input field (fdf_set_value()) and associate it with a PDF form (fdf_set_file()). Finally it has to be sent to the browser with MimeType application/vnd.fdf. The Acrobat reader plugin of your browser recognizes the MimeType, reads the associated PDF form and fills in the data from the FDF document.

If you look at an FDF-document with a text editor you will find a catalogue object with the name FDF. Such an object may contain a number of entries like Fields, F, Status etc.. The most commonly used entries are Fields which points to a list of input fields, and F which contains the filename of the PDF-document this data belongs to. Those entries are referred to in the FDF documentation as /F-Key or /Status-Key. Modifying this entries is done by functions like fdf_set_file() and fdf_set_status(). Fields are modified with fdf_set_value(), fdf_set_opt() etc..


需求

You need the FDF toolkit SDK available from » http://www.adobe.com/devnet/acrobat/fdftoolkit.html. As of PHP 4.3.0 you need at least SDK version 5.0. The FDF toolkit library is available in binary form only, platforms supported by Adobe are Win32, Linux, Solaris and AIX.


安装

此扩展被认为已无人维护及已消亡。然而，此扩展的源代码还可在 PECL SVN 找到： » https://svn.php.net/viewvc/pecl/fdf.

This extension is no longer bundled with PHP as of PHP 5.3.0.

Note: If you run into problems configuring PHP with fdftk support, check whether the header file fdftk.h and the library libfdftk.so are at the right place. The configure script supports both the directory structure of the FDF SDK distribution and the usual DIR/include / DIR/lib layout, so you can point it either directly to the unpacked distribution directory or put the header file and the appropriate library for your platform into e.g. /usr/local/include and /usr/local/lib and configure with --with-fdftk=/usr/local.

Note: Note to Win32 Users

为了使此扩展生效， DLL 文件必须能在 Windows 系统的 PATH 指示的路径下找到。如何操作的信息，请参见题为"如何在 Windows 中将 PHP 目录加到 PATH 中"的FAQ。虽然将 DLL 文件从 PHP 文件夹复制到 Windows 系统目录也行，但不建议这样做。 此扩展需要下列文件在 PATH 路径中： fdftk.dll


资源类型

Most fdf functions require a fdf resource as their first parameter. A fdf resource is a handle to an opened fdf file. fdf resources may be obtained using fdf_create(), fdf_open() and fdf_open_string().


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

FDFValue (int)
FDFStatus (int)
FDFFile (int)
FDFID (int)
FDFFf (int)
FDFSetFf (int)
FDFClearFf (int)
FDFFlags (int)
FDFSetF (int)
FDFClrF (int)
FDFAP (int)
FDFAS (int)
FDFAction (int)
FDFAA (int)
FDFAPRef (int)
FDFIF (int)
FDFEnter (int)
FDFExit (int)
FDFDown (int)
FDFUp (int)
FDFFormat (int)
FDFValidate (int)
FDFKeystroke (int)
FDFCalculate (int)
FDFNormalAP (int)
FDFRolloverAP (int)
FDFDownAP (int)


范例

The following examples shows just the evaluation of form data.

Example #1 Evaluating a FDF document

<?php
// Open fdf from input string provided by the extension
// The pdf form contained several input text fields with the names
// volume, date, comment, publisher, preparer, and two checkboxes
// show_publisher and show_preparer.
$fdf = fdf_open_string($HTTP_FDF_DATA);
$volume = fdf_get_value($fdf, "volume");
echo "The volume field has the value '<b>$volume</b>'<br />";

$date = fdf_get_value($fdf, "date");
echo "The date field has the value '<b>$date</b>'<br />";

$comment = fdf_get_value($fdf, "comment");
echo "The comment field has the value '<b>$comment</b>'<br />";

if (fdf_get_value($fdf, "show_publisher") == "On") {
  $publisher = fdf_get_value($fdf, "publisher");
  echo "The publisher field has the value '<b>$publisher</b>'<br />";
} else
  echo "Publisher shall not be shown.<br />";

if (fdf_get_value($fdf, "show_preparer") == "On") {
  $preparer = fdf_get_value($fdf, "preparer");
  echo "The preparer field has the value '<b>$preparer</b>'<br />";
} else
  echo "Preparer shall not be shown.<br />";
fdf_close($fdf);
?>


FDF 函数

Table of Contents

  • fdf_add_doc_javascript — Adds javascript code to the FDF document
  • fdf_add_template — Adds a template into the FDF document
  • fdf_close — Close an FDF document
  • fdf_create — Create a new FDF document
  • fdf_enum_values — Call a user defined function for each document value
  • fdf_errno — Return error code for last fdf operation
  • fdf_error — Return error description for FDF error code
  • fdf_get_ap — Get the appearance of a field
  • fdf_get_attachment — Extracts uploaded file embedded in the FDF
  • fdf_get_encoding — Get the value of the /Encoding key
  • fdf_get_file — Get the value of the /F key
  • fdf_get_flags — Gets the flags of a field
  • fdf_get_opt — Gets a value from the opt array of a field
  • fdf_get_status — Get the value of the /STATUS key
  • fdf_get_value — Get the value of a field
  • fdf_get_version — Gets version number for FDF API or file
  • fdf_header — Sets FDF-specific output headers
  • fdf_next_field_name — Get the next field name
  • fdf_open_string — Read a FDF document from a string
  • fdf_open — Open a FDF document
  • fdf_remove_item — Sets target frame for form
  • fdf_save_string — Returns the FDF document as a string
  • fdf_save — Save a FDF document
  • fdf_set_ap — Set the appearance of a field
  • fdf_set_encoding — Sets FDF character encoding
  • fdf_set_file — Set PDF document to display FDF data in
  • fdf_set_flags — Sets a flag of a field
  • fdf_set_javascript_action — Sets an javascript action of a field
  • fdf_set_on_import_javascript — Adds javascript code to be executed when Acrobat opens the FDF
  • fdf_set_opt — Sets an option of a field
  • fdf_set_status — Set the value of the /STATUS key
  • fdf_set_submit_form_action — Sets a submit form action of a field
  • fdf_set_target_frame — Set target frame for form display
  • fdf_set_value — Set the value of a field
  • fdf_set_version — Sets version number for a FDF file


Adds javascript code to the FDF document

  • ? FDF 函数
  • fdf_add_template ?
  • PHP Manual
  • FDF 函数
  • Adds javascript code to the FDF document

fdf_add_doc_javascript

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_add_doc_javascript — Adds javascript code to the FDF document

说明

fdf_add_doc_javascript ( resource $fdf_document , string $script_name , string $script_code ) : bool

Adds a script to the FDF, which Acrobat then adds to the doc-level scripts of a document, once the FDF is imported into it.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

script_name

The script name.

script_code

The script code. It is strongly suggested to use \r for linebreaks within the script code.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Adding JavaScript code to a FDF

<?php
$fdf = fdf_create();
fdf_add_doc_javascript($fdf, "PlusOne", "function PlusOne(x)\r{\r  return x+1;\r}\r");
fdf_save($fdf);
?>

will create a FDF like this:

%FDF-1.2
%a??ó
1 0 obj
<<
/FDF << /JavaScript << /Doc [ (PlusOne)(function PlusOne\(x\)\r{\r  return x+1;\r}\r)] >> >>
>>
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF


Adds a template into the FDF document

  • ? fdf_add_doc_javascript
  • fdf_close ?
  • PHP Manual
  • FDF 函数
  • Adds a template into the FDF document

fdf_add_template

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_add_template — Adds a template into the FDF document

说明

fdf_add_template ( resource $fdf_document , int $newpage , string $filename , string $template , int $rename ) : bool
Warning

本函数还未编写文档，仅有参数列表。


Close an FDF document

  • ? fdf_add_template
  • fdf_create ?
  • PHP Manual
  • FDF 函数
  • Close an FDF document

fdf_close

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_close — Close an FDF document

说明

fdf_close ( resource $fdf_document ) : void

Closes the FDF document.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

返回值

没有返回值。

参见

  • fdf_open() - Open a FDF document


Create a new FDF document

  • ? fdf_close
  • fdf_enum_values ?
  • PHP Manual
  • FDF 函数
  • Create a new FDF document

fdf_create

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_create — Create a new FDF document

说明

fdf_create ( ) : resource

Creates a new FDF document.

This function is needed if one would like to populate input fields in a PDF document with data.

返回值

Returns a FDF document handle, or false on error.

范例

Example #1 Populating a PDF document

<?php
$outfdf = fdf_create();
fdf_set_value($outfdf, "volume", $volume, 0);

fdf_set_file($outfdf, "http:/testfdf/resultlabel.pdf");
fdf_save($outfdf, "outtest.fdf");
fdf_close($outfdf);
Header("Content-type: application/vnd.fdf");
$fp = fopen("outtest.fdf", "r");
fpassthru($fp);
unlink("outtest.fdf");
?>

参见

  • fdf_close() - Close an FDF document
  • fdf_save() - Save a FDF document
  • fdf_open() - Open a FDF document


Call a user defined function for each document value

  • ? fdf_create
  • fdf_errno ?
  • PHP Manual
  • FDF 函数
  • Call a user defined function for each document value

fdf_enum_values

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_enum_values — Call a user defined function for each document value

说明

fdf_enum_values ( resource $fdf_document , callable $function , mixed $userdata = ? ) : bool
Warning

本函数还未编写文档，仅有参数列表。


Return error code for last fdf operation

  • ? fdf_enum_values
  • fdf_error ?
  • PHP Manual
  • FDF 函数
  • Return error code for last fdf operation

fdf_errno

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_errno — Return error code for last fdf operation

说明

fdf_errno ( ) : int

Gets the error code set by the last FDF function call.

A textual description of the error may be obtained using with fdf_error().

返回值

Returns the error code as an integer, or zero if there was no errors.

参见

  • fdf_error() - Return error description for FDF error code


Return error description for FDF error code

  • ? fdf_errno
  • fdf_get_ap ?
  • PHP Manual
  • FDF 函数
  • Return error description for FDF error code

fdf_error

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_error — Return error description for FDF error code

说明

fdf_error ( int $error_code = -1 ) : string

Gets a textual description for the FDF error code given in error_code.

参数

error_code

An error code obtained with fdf_errno(). If not provided, this function uses the internal error code set by the last operation.

返回值

Returns the error message as a string, or the string no error if nothing went wrong.

参见

  • fdf_errno() - Return error code for last fdf operation


Get the appearance of a field

  • ? fdf_error
  • fdf_get_attachment ?
  • PHP Manual
  • FDF 函数
  • Get the appearance of a field

fdf_get_ap

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_ap — Get the appearance of a field

说明

fdf_get_ap ( resource $fdf_document , string $field , int $face , string $filename ) : bool

Gets the appearance of a field (i.e. the value of the /AP key) and stores it in a file.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

field

face

The possible values are FDFNormalAP, FDFRolloverAP and FDFDownAP.

filename

The appearance will be stored in this parameter.

返回值

成功时返回 true， 或者在失败时返回 false。


Extracts uploaded file embedded in the FDF

  • ? fdf_get_ap
  • fdf_get_encoding ?
  • PHP Manual
  • FDF 函数
  • Extracts uploaded file embedded in the FDF

fdf_get_attachment

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_attachment — Extracts uploaded file embedded in the FDF

说明

fdf_get_attachment ( resource $fdf_document , string $fieldname , string $savepath ) : array

Extracts a file uploaded by means of the "file selection" field fieldname and stores it under savepath.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

savepath

May be the name of a plain file or an existing directory in which the file is to be created under its original name. Any existing file under the same name will be overwritten.

Note:

There seems to be no other way to find out the original filename but to store the file using a directory as savepath and check for the basename it was stored under.

返回值

The returned array contains the following fields:

  • path - path were the file got stored
  • size - size of the stored file in bytes
  • type - mimetype if given in the FDF

范例

Example #1 Storing an uploaded file

<?php
  $fdf = fdf_open_string($HTTP_FDF_DATA);
  $data = fdf_get_attachment($fdf, "filename", "/tmpdir");
  echo "The uploaded file is stored in $data[path]";
?>


Get the value of the /Encoding key

  • ? fdf_get_attachment
  • fdf_get_file ?
  • PHP Manual
  • FDF 函数
  • Get the value of the /Encoding key

fdf_get_encoding

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_encoding — Get the value of the /Encoding key

说明

fdf_get_encoding ( resource $fdf_document ) : string

Gets the value of the /Encoding key.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

返回值

Returns the encoding as a string. An empty string is returned if the default PDFDocEncoding/Unicode scheme is used.

参见

  • fdf_set_encoding() - Sets FDF character encoding


Get the value of the /F key

  • ? fdf_get_encoding
  • fdf_get_flags ?
  • PHP Manual
  • FDF 函数
  • Get the value of the /F key

fdf_get_file

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_file — Get the value of the /F key

说明

fdf_get_file ( resource $fdf_document ) : string

Gets the value of the /F key.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

返回值

Returns the key value, as a string.

参见

  • fdf_set_file() - Set PDF document to display FDF data in


Gets the flags of a field

  • ? fdf_get_file
  • fdf_get_opt ?
  • PHP Manual
  • FDF 函数
  • Gets the flags of a field

fdf_get_flags

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_flags — Gets the flags of a field

说明

fdf_get_flags ( resource $fdf_document , string $fieldname , int $whichflags ) : int
Warning

本函数还未编写文档，仅有参数列表。


Gets a value from the opt array of a field

  • ? fdf_get_flags
  • fdf_get_status ?
  • PHP Manual
  • FDF 函数
  • Gets a value from the opt array of a field

fdf_get_opt

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECLv)

fdf_get_opt — Gets a value from the opt array of a field

说明

fdf_get_opt ( resource $fdf_document , string $fieldname , int $element = -1 ) : mixed
Warning

本函数还未编写文档，仅有参数列表。


Get the value of the /STATUS key

  • ? fdf_get_opt
  • fdf_get_value ?
  • PHP Manual
  • FDF 函数
  • Get the value of the /STATUS key

fdf_get_status

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_status — Get the value of the /STATUS key

说明

fdf_get_status ( resource $fdf_document ) : string

Gets the value of the /STATUS key.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

返回值

Returns the key value, as a string.

参见

  • fdf_set_status() - Set the value of the /STATUS key


Get the value of a field

  • ? fdf_get_status
  • fdf_get_version ?
  • PHP Manual
  • FDF 函数
  • Get the value of a field

fdf_get_value

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_value — Get the value of a field

说明

fdf_get_value ( resource $fdf_document , string $fieldname , int $which = -1 ) : mixed

Gets the value for the requested field.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

which

Elements of an array field can be retrieved by passing this optional parameter, starting at zero. For non-array fields, this parameter will be ignored.

返回值

Returns the field value.

更新日志

版本 | 说明
4.3.0 | Support for arrays and the which parameter were added.

参见

  • fdf_set_value() - Set the value of a field


Gets version number for FDF API or file

  • ? fdf_get_value
  • fdf_header ?
  • PHP Manual
  • FDF 函数
  • Gets version number for FDF API or file

fdf_get_version

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_get_version — Gets version number for FDF API or file

说明

fdf_get_version ( resource $fdf_document = ? ) : string

Return the FDF version for the given document, or the toolkit API version number if no parameter is given.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

返回值

Returns the version as a string. For the current FDF toolkit 5.0 the API version number is 5.0 and the document version number is either 1.2, 1.3 or 1.4.

参见

  • fdf_set_version() - Sets version number for a FDF file


Sets FDF-specific output headers

  • ? fdf_get_version
  • fdf_next_field_name ?
  • PHP Manual
  • FDF 函数
  • Sets FDF-specific output headers

fdf_header

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVNf)

fdf_header — Sets FDF-specific output headers

说明

fdf_header ( ) : void

This is a convenience function to set appropriate HTTP headers for FDF output. It sets the Content-type: to application/vnd.fdf.

返回值

没有返回值。


Get the next field name

  • ? fdf_header
  • fdf_open_string ?
  • PHP Manual
  • FDF 函数
  • Get the next field name

fdf_next_field_name

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_next_field_name — Get the next field name

说明

fdf_next_field_name ( resource $fdf_document , string $fieldname = ? ) : string

Gets the name of the field after the given field. This name can be used with several functions.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string. If not given, the first field will be assumed.

返回值

Returns the field name as a string.

范例

Example #1 Detecting all fieldnames in a FDF

<?php
$fdf = fdf_open($HTTP_FDF_DATA);
for ($field = fdf_next_field_name($fdf);
    $field != "";
    $field = fdf_next_field_name($fdf, $field)) {
    echo "field: $field\n";
}
?>

参见

  • fdf_get_value() - Get the value of a field


Read a FDF document from a string

  • ? fdf_next_field_name
  • fdf_open ?
  • PHP Manual
  • FDF 函数
  • Read a FDF document from a string

fdf_open_string

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_open_string — Read a FDF document from a string

说明

fdf_open_string ( string $fdf_data ) : resource

Reads form data from a string.

You can use fdf_open_string() together with $HTTP_FDF_DATA to process FDF form input from a remote client.

参数

fdf_data

The data as returned from a PDF form or created using fdf_create() and fdf_save_string().

返回值

Returns a FDF document handle, or false on error.

范例

Example #1 Accessing the form data

<?php
$fdf = fdf_open_string($HTTP_FDF_DATA);
/* ... */
fdf_close($fdf);
?>

参见

  • fdf_open() - Open a FDF document
  • fdf_close() - Close an FDF document
  • fdf_create() - Create a new FDF document
  • fdf_save_string() - Returns the FDF document as a string


Open a FDF document

  • ? fdf_open_string
  • fdf_remove_item ?
  • PHP Manual
  • FDF 函数
  • Open a FDF document

fdf_open

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_open — Open a FDF document

说明

fdf_open ( string $filename ) : resource

Opens a file with form data.

You can also use fdf_open_string() to process the results of a PDF form POST request.

参数

filename

Path to the FDF file. This file must contain the data as returned from a PDF form or created using fdf_create() and fdf_save().

返回值

Returns a FDF document handle, or false on error.

范例

Example #1 Accessing the form data

<?php
// Save the FDF data into a temp file
$fdffp = fopen("test.fdf", "w");
fwrite($fdffp, $HTTP_FDF_DATA, strlen($HTTP_FDF_DATA));
fclose($fdffp);

// Open temp file and evaluate data
$fdf = fdf_open("test.fdf");
/* ... */
fdf_close($fdf);
?>

参见

  • fdf_open_string() - Read a FDF document from a string
  • fdf_close() - Close an FDF document
  • fdf_create() - Create a new FDF document
  • fdf_save() - Save a FDF document


Sets target frame for form

  • ? fdf_open
  • fdf_save_string ?
  • PHP Manual
  • FDF 函数
  • Sets target frame for form

fdf_remove_item

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_remove_item — Sets target frame for form

说明

fdf_remove_item ( resource $fdf_document , string $fieldname , int $item ) : bool
Warning

本函数还未编写文档，仅有参数列表。


Returns the FDF document as a string

  • ? fdf_remove_item
  • fdf_save ?
  • PHP Manual
  • FDF 函数
  • Returns the FDF document as a string

fdf_save_string

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_save_string — Returns the FDF document as a string

说明

fdf_save_string ( resource $fdf_document ) : string

Returns the FDF document as a string.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

返回值

Returns the document as a string, or false on error.

范例

Example #1 Retrieving FDF as a string

<?php
$fdf = fdf_create();
fdf_set_value($fdf, "foo", "bar");
$str = fdf_save_string($fdf);
fdf_close($fdf);
echo $str;
?>

以上例程会输出：

%FDF-1.2
%a??ó
1 0 obj
<<
/FDF << /Fields 2 0 R >>
>>
endobj
2 0 obj
[
<< /T (foo)/V (bar)>>
]
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF

参见

  • fdf_open_string() - Read a FDF document from a string
  • fdf_close() - Close an FDF document
  • fdf_create() - Create a new FDF document
  • fdf_save() - Save a FDF document


Save a FDF document

  • ? fdf_save_string
  • fdf_set_ap ?
  • PHP Manual
  • FDF 函数
  • Save a FDF document

fdf_save

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_save — Save a FDF document

说明

fdf_save ( resource $fdf_document , string $filename = ? ) : bool

Saves a FDF document.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

filename

If provided, the resulting FDF will be written in this parameter. Otherwise, this function will write the FDF to the default PHP output stream.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fdf_close() - Close an FDF document
  • fdf_create() - Create a new FDF document
  • fdf_save_string() - Returns the FDF document as a string


Set the appearance of a field

  • ? fdf_save
  • fdf_set_encoding ?
  • PHP Manual
  • FDF 函数
  • Set the appearance of a field

fdf_set_ap

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_ap — Set the appearance of a field

说明

fdf_set_ap ( resource $fdf_document , string $field_name , int $face , string $filename , int $page_number ) : bool

Sets the appearance of a field (i.e. the value of the /AP key).

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

field_name

face

The possible values FDFNormalAP, FDFRolloverAP and FDFDownAP.

filename

page_number

返回值

成功时返回 true， 或者在失败时返回 false。


Sets FDF character encoding

  • ? fdf_set_ap
  • fdf_set_file ?
  • PHP Manual
  • FDF 函数
  • Sets FDF character encoding

fdf_set_encoding

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_encoding — Sets FDF character encoding

说明

fdf_set_encoding ( resource $fdf_document , string $encoding ) : bool

Sets the character encoding for the FDF document.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

encoding

The encoding name. The following values are supported: "Shift-JIS", "UHC", "GBK" and "BigFive".

An empty string resets the encoding to the default PDFDocEncoding/Unicode scheme.

返回值

成功时返回 true， 或者在失败时返回 false。


Set PDF document to display FDF data in

  • ? fdf_set_encoding
  • fdf_set_flags ?
  • PHP Manual
  • FDF 函数
  • Set PDF document to display FDF data in

fdf_set_file

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_file — Set PDF document to display FDF data in

说明

fdf_set_file ( resource $fdf_document , string $url , string $target_frame = ? ) : bool

Selects a different PDF document to display the form results in then the form it originated from.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

url

Should be given as an absolute URL.

target_frame

Use this parameter to specify the frame in which the document will be displayed. You can also set the default value for this parameter using fdf_set_target_frame().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Passing FDF data to a second form

<?php
  /* set content type for Adobe FDF */
  fdf_header();

  /* start new fdf */
  $fdf = fdf_create();

  /* set field "foo" to value "bar" */
  fdf_set_value($fdf, "foo", "bar");

  /* tell client to display FDF data using "fdf_form.pdf" */
  fdf_set_file($fdf, "http://www.example.com/fdf_form.pdf");

  /* output fdf */
  fdf_save($fdf);

  /* clean up */
  fdf_close($fdf);
?>

参见

  • fdf_get_file() - Get the value of the /F key
  • fdf_set_target_frame() - Set target frame for form display


Sets a flag of a field

  • ? fdf_set_file
  • fdf_set_javascript_action ?
  • PHP Manual
  • FDF 函数
  • Sets a flag of a field

fdf_set_flags

(PHP 4 >= 4.0.2, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_flags — Sets a flag of a field

说明

fdf_set_flags ( resource $fdf_document , string $fieldname , int $whichFlags , int $newFlags ) : bool

Sets certain flags of the given field.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

whichFlags

newFlags

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fdf_set_opt() - Sets an option of a field


Sets an javascript action of a field

  • ? fdf_set_flags
  • fdf_set_on_import_javascript ?
  • PHP Manual
  • FDF 函数
  • Sets an javascript action of a field

fdf_set_javascript_action

(PHP 4 >= 4.0.2, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_javascript_action — Sets an javascript action of a field

说明

fdf_set_javascript_action ( resource $fdf_document , string $fieldname , int $trigger , string $script ) : bool

Sets a javascript action for the given field.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

trigger

script

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fdf_set_submit_form_action() - Sets a submit form action of a field


Adds javascript code to be executed when Acrobat opens the FDF

  • ? fdf_set_javascript_action
  • fdf_set_opt ?
  • PHP Manual
  • FDF 函数
  • Adds javascript code to be executed when Acrobat opens the FDF

fdf_set_on_import_javascript

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_on_import_javascript — Adds javascript code to be executed when Acrobat opens the FDF

说明

fdf_set_on_import_javascript ( resource $fdf_document , string $script , bool $before_data_import ) : bool
Warning

本函数还未编写文档，仅有参数列表。

参见

  • fdf_add_doc_javascript() - Adds javascript code to the FDF document
  • fdf_set_javascript_action() - Sets an javascript action of a field


Sets an option of a field

  • ? fdf_set_on_import_javascript
  • fdf_set_status ?
  • PHP Manual
  • FDF 函数
  • Sets an option of a field

fdf_set_opt

(PHP 4 >= 4.0.2, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_opt — Sets an option of a field

说明

fdf_set_opt ( resource $fdf_document , string $fieldname , int $element , string $str1 , string $str2 ) : bool

Sets options of the given field.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

element

str1

str2

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fdf_set_flags() - Sets a flag of a field


Set the value of the /STATUS key

  • ? fdf_set_opt
  • fdf_set_submit_form_action ?
  • PHP Manual
  • FDF 函数
  • Set the value of the /STATUS key

fdf_set_status

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_status — Set the value of the /STATUS key

说明

fdf_set_status ( resource $fdf_document , string $status ) : bool

Sets the value of the /STATUS key. When a client receives a FDF with a status set it will present the value in an alert box.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

status

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fdf_get_status() - Get the value of the /STATUS key


Sets a submit form action of a field

  • ? fdf_set_status
  • fdf_set_target_frame ?
  • PHP Manual
  • FDF 函数
  • Sets a submit form action of a field

fdf_set_submit_form_action

(PHP 4 >= 4.0.2, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_submit_form_action — Sets a submit form action of a field

说明

fdf_set_submit_form_action ( resource $fdf_document , string $fieldname , int $trigger , string $script , int $flags ) : bool

Sets a submit form action for the given field.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

trigger

script

flags

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fdf_set_javascript_action() - Sets an javascript action of a field


Set target frame for form display

  • ? fdf_set_submit_form_action
  • fdf_set_value ?
  • PHP Manual
  • FDF 函数
  • Set target frame for form display

fdf_set_target_frame

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_target_frame — Set target frame for form display

说明

fdf_set_target_frame ( resource $fdf_document , string $frame_name ) : bool

Sets the target frame to display a result PDF defined with fdf_save_file() in.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

frame_name

The frame name, as a string.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fdf_save_file()


Set the value of a field

  • ? fdf_set_target_frame
  • fdf_set_version ?
  • PHP Manual
  • FDF 函数
  • Set the value of a field

fdf_set_value

(PHP 4, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_value — Set the value of a field

说明

fdf_set_value ( resource $fdf_document , string $fieldname , mixed $value , int $isName = ? ) : bool

Sets the value for the given field.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

value

This parameter will be stored as a string unless it is an array. In this case all array elements will be stored as a value array.

isName

Note:

In older versions of the FDF toolkit last parameter determined if the field value was to be converted to a PDF Name (= 1) or set to a PDF String (= 0).

The value is no longer used in the current toolkit version 5.0. For compatibility reasons it is still supported as an optional parameter beginning with PHP 4.3, but ignored internally.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
4.3.0 | Support for arrays in the value parameter was added.

参见

  • fdf_get_value() - Get the value of a field
  • fdf_remove_item() - Sets target frame for form


Sets version number for a FDF file

  • ? fdf_set_value
  • GnuPG ?
  • PHP Manual
  • FDF 函数
  • Sets version number for a FDF file

fdf_set_version

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL fdf SVN)

fdf_set_version — Sets version number for a FDF file

说明

fdf_set_version ( resource $fdf_document , string $version ) : bool

Sets the FDF version for the given document.

Some features supported by this extension are only available in newer FDF versions.

参数

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

version

The version number. For the current FDF toolkit 5.0, this may be either 1.2, 1.3 or 1.4.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • fdf_get_version() - Gets version number for FDF API or file


GNU Privacy Guard

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Clearsign text
  • GnuPG 函数
    • gnupg_adddecryptkey — Add a key for decryption
    • gnupg_addencryptkey — Add a key for encryption
    • gnupg_addsignkey — Add a key for signing
    • gnupg_cleardecryptkeys — Removes all keys which were set for decryption before
    • gnupg_clearencryptkeys — Removes all keys which were set for encryption before
    • gnupg_clearsignkeys — Removes all keys which were set for signing before
    • gnupg_decrypt — Decrypts a given text
    • gnupg_decryptverify — Decrypts and verifies a given text
    • gnupg_encrypt — Encrypts a given text
    • gnupg_encryptsign — Encrypts and signs a given text
    • gnupg_export — Exports a key
    • gnupg_geterror — Returns the errortext, if a function fails
    • gnupg_getprotocol — Returns the currently active protocol for all operations
    • gnupg_import — Imports a key
    • gnupg_init — Initialize a connection
    • gnupg_keyinfo — Returns an array with information about all keys that matches the given pattern
    • gnupg_setarmor — Toggle armored output
    • gnupg_seterrormode — Sets the mode for error_reporting
    • gnupg_setsignmode — Sets the mode for signing
    • gnupg_sign — Signs a given text
    • gnupg_verify — Verifies a signed text


  • ? GnuPG
  • 安装／配置 ?
  • PHP Manual
  • GnuPG
  • 简介

简介

This module allows you to interact with » gnupg.


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

This extension requires the » gpgme library


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/gnupg.


预定义常量

GNUPG_SIG_MODE_NORMAL (int)
GNUPG_SIG_MODE_DETACH (int)
GNUPG_SIG_MODE_CLEAR (int)
GNUPG_VALIDITY_UNKNOWN (int)
GNUPG_VALIDITY_UNDEFINED (int)
GNUPG_VALIDITY_NEVER (int)
GNUPG_VALIDITY_MARGINAL (int)
GNUPG_VALIDITY_FULL (int)
GNUPG_VALIDITY_ULTIMATE (int)
GNUPG_PROTOCOL_OpenPGP (int)
GNUPG_PROTOCOL_CMS (int)
GNUPG_SIGSUM_VALID (int)
GNUPG_SIGSUM_GREEN (int)
GNUPG_SIGSUM_RED (int)
GNUPG_SIGSUM_KEY_REVOKED (int)
GNUPG_SIGSUM_KEY_EXPIRED (int)
GNUPG_SIGSUM_KEY_MISSING (int)
GNUPG_SIGSUM_SIG_EXPIRED (int)
GNUPG_SIGSUM_CRL_MISSING (int)
GNUPG_SIGSUM_CRL_TOO_OLD (int)
GNUPG_SIGSUM_BAD_POLICY (int)
GNUPG_SIGSUM_SYS_ERROR (int)
GNUPG_ERROR_WARNING (int)
GNUPG_ERROR_EXCEPTION (int)
GNUPG_ERROR_SILENT (int)


  • ? 预定义常量
  • Clearsign text ?
  • PHP Manual
  • GnuPG
  • 范例

范例

Table of Contents

  • Clearsign text


Clearsign text

This example will clearsign a given text.

Example #1 gnupg clearsign example (procedural)

<?php
// init gnupg
$res = gnupg_init();
// not really needed. Clearsign is default
gnupg_setsignmode($res,GNUPG_SIG_MODE_CLEAR);
// add key with passphrase 'test' for signing
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
// sign
$signed = gnupg_sign($res,"just a test");
echo $signed;
?>

Example #2 gnupg clearsign example (OO)

<?php
// new class
$gnupg = new gnupg();
// not really needed. Clearsign is default
$gnupg->setsignmode(gnupg::SIG_MODE_CLEAR);
// add key with passphrase 'test' for signing
$gnupg->addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
// sign
$signed = $gnupg->sign("just a test");
echo $signed;
?>

Example #3 keylistiterator

This extension also comes with an Iterator for your keyring.

<?php
// create a new iterator for listing all public keys that matches 'example'
$iterator = new gnupg_keylistiterator("example");
foreach($iterator as $fingerprint => $userid){
    echo $fingerprint." -> ".$userid."\n";
}
?>


GnuPG 函数

注释

This extension makes use of the keyring of the current user. This keyring is normally located in ~./.gnupg/. To specify a custom location, store the path to the keyring in the environment variable GNUPGHOME. See putenv for more information how to do this.

Some functions require the specification of a key. This specification can be anything that refers to a unique key (userid, key-id, fingerprint, ...). This documentation uses the fingerprint in all examples.

Note:

As alternative to the explicitly documented functions using resources, you can also use an object-oriented style using gnupg objects.

Table of Contents

  • gnupg_adddecryptkey — Add a key for decryption
  • gnupg_addencryptkey — Add a key for encryption
  • gnupg_addsignkey — Add a key for signing
  • gnupg_cleardecryptkeys — Removes all keys which were set for decryption before
  • gnupg_clearencryptkeys — Removes all keys which were set for encryption before
  • gnupg_clearsignkeys — Removes all keys which were set for signing before
  • gnupg_decrypt — Decrypts a given text
  • gnupg_decryptverify — Decrypts and verifies a given text
  • gnupg_encrypt — Encrypts a given text
  • gnupg_encryptsign — Encrypts and signs a given text
  • gnupg_export — Exports a key
  • gnupg_geterror — Returns the errortext, if a function fails
  • gnupg_getprotocol — Returns the currently active protocol for all operations
  • gnupg_import — Imports a key
  • gnupg_init — Initialize a connection
  • gnupg_keyinfo — Returns an array with information about all keys that matches the given pattern
  • gnupg_setarmor — Toggle armored output
  • gnupg_seterrormode — Sets the mode for error_reporting
  • gnupg_setsignmode — Sets the mode for signing
  • gnupg_sign — Signs a given text
  • gnupg_verify — Verifies a signed text


Add a key for decryption

  • ? GnuPG 函数
  • gnupg_addencryptkey ?
  • PHP Manual
  • GnuPG 函数
  • Add a key for decryption

gnupg_adddecryptkey

(PECL gnupg >= 0.5)

gnupg_adddecryptkey — Add a key for decryption

说明

gnupg_adddecryptkey ( resource $identifier , string $fingerprint , string $passphrase ) : bool

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

fingerprint

指纹键名。

passphrase

The pass phrase.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Procedural gnupg_adddecryptkey() example

<?php
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Example #2 OO gnupg_adddecryptkey() example

<?php
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
?>


Add a key for encryption

  • ? gnupg_adddecryptkey
  • gnupg_addsignkey ?
  • PHP Manual
  • GnuPG 函数
  • Add a key for encryption

gnupg_addencryptkey

(PECL gnupg >= 0.5)

gnupg_addencryptkey — Add a key for encryption

说明

gnupg_addencryptkey ( resource $identifier , string $fingerprint ) : bool

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

fingerprint

指纹键名。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Procedural gnupg_addencryptkey() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
?>

Example #2 OO gnupg_addencryptkey() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
?>


Add a key for signing

  • ? gnupg_addencryptkey
  • gnupg_cleardecryptkeys ?
  • PHP Manual
  • GnuPG 函数
  • Add a key for signing

gnupg_addsignkey

(PECL gnupg >= 0.5)

gnupg_addsignkey — Add a key for signing

说明

gnupg_addsignkey ( resource $identifier , string $fingerprint , string $passphrase = ? ) : bool

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

fingerprint

指纹键名。

passphrase

The pass phrase.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Procedural gnupg_addsignkey() example

<?php
$res = gnupg_init();
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Example #2 OO gnupg_addsignkey() example

<?php
$gpg = new gnupg();
$gpg -> addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
?>


Removes all keys which were set for decryption before

  • ? gnupg_addsignkey
  • gnupg_clearencryptkeys ?
  • PHP Manual
  • GnuPG 函数
  • Removes all keys which were set for decryption before

gnupg_cleardecryptkeys

(PECL gnupg >= 0.5)

gnupg_cleardecryptkeys — Removes all keys which were set for decryption before

说明

gnupg_cleardecryptkeys ( resource $identifier ) : bool

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Procedural gnupg_cleardecryptkeys() example

<?php
$res = gnupg_init();
gnupg_cleardecryptkeys($res);
?>

Example #2 OO gnupg_cleardecryptkeys() example

<?php
$gpg = new gnupg();
$gpg -> cleardecryptkeys();
?>


Removes all keys which were set for encryption before

  • ? gnupg_cleardecryptkeys
  • gnupg_clearsignkeys ?
  • PHP Manual
  • GnuPG 函数
  • Removes all keys which were set for encryption before

gnupg_clearencryptkeys

(PECL gnupg >= 0.5)

gnupg_clearencryptkeys — Removes all keys which were set for encryption before

说明

gnupg_clearencryptkeys ( resource $identifier ) : bool

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Procedural gnupg_clearencryptkeys() example

<?php
$res = gnupg_init();
gnupg_clearencryptkeys($res);
?>

Example #2 OO gnupg_clearencryptkeys() example

<?php
$gpg = new gnupg();
$gpg -> clearencryptkeys();
?>


Removes all keys which were set for signing before

  • ? gnupg_clearencryptkeys
  • gnupg_decrypt ?
  • PHP Manual
  • GnuPG 函数
  • Removes all keys which were set for signing before

gnupg_clearsignkeys

(PECL gnupg >= 0.5)

gnupg_clearsignkeys — Removes all keys which were set for signing before

说明

gnupg_clearsignkeys ( resource $identifier ) : bool

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Procedural gnupg_clearsignkeys() example

<?php
$res = gnupg_init();
gnupg_clearsignkeys($res);
?>

Example #2 OO gnupg_clearsignkeys() example

<?php
$gpg = new gnupg();
$gpg -> clearsignkeys();
?>


Decrypts a given text

  • ? gnupg_clearsignkeys
  • gnupg_decryptverify ?
  • PHP Manual
  • GnuPG 函数
  • Decrypts a given text

gnupg_decrypt

(PECL gnupg >= 0.1)

gnupg_decrypt — Decrypts a given text

说明

gnupg_decrypt ( resource $identifier , string $text ) : string

Decrypts the given text with the keys, which were set with gnupg_adddecryptkey before.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

text

The text being decrypted.

返回值

On success, this function returns the decrypted text. On failure, this function returns false.

范例

Example #1 Procedural gnupg_decrypt() example

<?php
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$plain = gnupg_decrypt($res,$encrypted_text);
echo $plain;
?>

Example #2 OO gnupg_decrypt() example

<?php
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$plain = $gpg -> decrypt($encrypted_text);
echo $plain;
?>


Decrypts and verifies a given text

  • ? gnupg_decrypt
  • gnupg_encrypt ?
  • PHP Manual
  • GnuPG 函数
  • Decrypts and verifies a given text

gnupg_decryptverify

(PECL gnupg >= 0.2)

gnupg_decryptverify — Decrypts and verifies a given text

说明

gnupg_decryptverify ( resource $identifier , string $text , string &$plaintext ) : array

Decrypts and verifies a given text and returns information about the signature.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

text

The text being decrypted.

plaintext

The parameter plaintext gets filled with the decrypted text.

返回值

On success, this function returns information about the signature and fills the plaintext parameter with the decrypted text. On failure, this function returns false.

范例

Example #1 Procedural gnupg_decryptverify() example

<?php
$plaintext = "";
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$info = gnupg_decryptverify($res,$text,$plaintext);
print_r($info);
?>

Example #2 OO gnupg_decryptverify() example

<?php
$plaintext = "";
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$info = $gpg -> decryptverify($text,$plaintext);
print_r($info);
?>


Encrypts a given text

  • ? gnupg_decryptverify
  • gnupg_encryptsign ?
  • PHP Manual
  • GnuPG 函数
  • Encrypts a given text

gnupg_encrypt

(PECL gnupg >= 0.1)

gnupg_encrypt — Encrypts a given text

说明

gnupg_encrypt ( resource $identifier , string $plaintext ) : string

Encrypts the given plaintext with the keys, which were set with gnupg_addencryptkey before and returns the encrypted text.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

plaintext

The text being encrypted.

返回值

On success, this function returns the encrypted text. On failure, this function returns false.

范例

Example #1 Procedural gnupg_encrypt() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
$enc = gnupg_encrypt($res, "just a test");
echo $enc;
?>

Example #2 OO gnupg_encrypt() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
$enc = $gpg -> encrypt("just a test");
echo $enc;
?>


Encrypts and signs a given text

  • ? gnupg_encrypt
  • gnupg_export ?
  • PHP Manual
  • GnuPG 函数
  • Encrypts and signs a given text

gnupg_encryptsign

(PECL gnupg >= 0.2)

gnupg_encryptsign — Encrypts and signs a given text

说明

gnupg_encryptsign ( resource $identifier , string $plaintext ) : string

Encrypts and signs the given plaintext with the keys, which were set with gnupg_addsignkey and gnupg_addencryptkey before and returns the encrypted and signed text.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

plaintext

The text being encrypted.

返回值

On success, this function returns the encrypted and signed text. On failure, this function returns false.

范例

Example #1 Procedural gnupg_encryptsign() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$enc = gnupg_encryptsign($res, "just a test");
echo $enc;
?>

Example #2 OO gnupg_encryptsign() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
$gpg -> addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$enc = $gpg -> encryptsign("just a test");
echo $enc;
?>


Exports a key

  • ? gnupg_encryptsign
  • gnupg_geterror ?
  • PHP Manual
  • GnuPG 函数
  • Exports a key

gnupg_export

(PECL gnupg >= 0.1)

gnupg_export — Exports a key

说明

gnupg_export ( resource $identifier , string $fingerprint ) : string

Exports the key fingerprint.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

fingerprint

指纹键名。

返回值

On success, this function returns the keydata. On failure, this function returns false.

范例

Example #1 Procedural gnupg_export() example

<?php
$res = gnupg_init();
$export = gnupg_export($res,"8660281B6051D071D94B5B230549F9DC851566DC");
echo $export;
?>

Example #2 OO gnupg_export() example

<?php
$gpg = new gnupg();
$export = $gpg -> export("8660281B6051D071D94B5B230549F9DC851566DC");
?>


Returns the errortext, if a function fails

  • ? gnupg_export
  • gnupg_getprotocol ?
  • PHP Manual
  • GnuPG 函数
  • Returns the errortext, if a function fails

gnupg_geterror

(PECL gnupg >= 0.1)

gnupg_geterror — Returns the errortext, if a function fails

说明

gnupg_geterror ( resource $identifier ) : string

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

返回值

Returns an errortext, if an error has occurred, otherwise false.

范例

Example #1 Procedural gnupg_geterror() example

<?php
$res = gnupg_init();
echo gnupg_geterror($res);
?>

Example #2 OO gnupg_geterror() example

<?php
$gpg = new gnupg();
echo $gpg -> geterror();
?>


Returns the currently active protocol for all operations

  • ? gnupg_geterror
  • gnupg_import ?
  • PHP Manual
  • GnuPG 函数
  • Returns the currently active protocol for all operations

gnupg_getprotocol

(PECL gnupg >= 0.1)

gnupg_getprotocol — Returns the currently active protocol for all operations

说明

gnupg_getprotocol ( resource $identifier ) : int

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

返回值

Returns the currently active protocol, which can be one of GNUPG_PROTOCOL_OpenPGP or GNUPG_PROTOCOL_CMS.

范例

Example #1 Procedural gnupg_getprotocol() example

<?php
$res = gnupg_init();
echo gnupg_getprotocol($res);
?>

Example #2 OO gnupg_getprotocol() example

<?php
$gpg = new gnupg();
echo $gpg -> getprotocol();
?>


Imports a key

  • ? gnupg_getprotocol
  • gnupg_init ?
  • PHP Manual
  • GnuPG 函数
  • Imports a key

gnupg_import

(PECL gnupg >= 0.3)

gnupg_import — Imports a key

说明

gnupg_import ( resource $identifier , string $keydata ) : array

Imports the key keydata and returns an array with information about the importprocess.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

keydata

The data key that is being imported.

返回值

On success, this function returns and info-array about the importprocess. On failure, this function returns false.

范例

Example #1 Procedural gnupg_import() example

<?php
$res = gnupg_init();
$info = gnupg_import($res,$keydata);
print_r($info);
?>

Example #2 OO gnupg_import() example

<?php
$gpg = new gnupg();
$info = $gpg -> import($keydata);
print_r($info);
?>


Initialize a connection

  • ? gnupg_import
  • gnupg_keyinfo ?
  • PHP Manual
  • GnuPG 函数
  • Initialize a connection

gnupg_init

(PECL gnupg >= 0.4)

gnupg_init — Initialize a connection

说明

gnupg_init ( ) : resource

参数

此函数没有参数。

返回值

A GnuPG resource connection used by other GnuPG functions.

范例

Example #1 Procedural gnupg_init() example

<?php
$res = gnupg_init();
?>

Example #2 OO gnupg initializer example

<?php
$gpg = new gnupg();
?>


Returns an array with information about all keys that matches the given pattern

  • ? gnupg_init
  • gnupg_setarmor ?
  • PHP Manual
  • GnuPG 函数
  • Returns an array with information about all keys that matches the given pattern

gnupg_keyinfo

(PECL gnupg >= 0.1)

gnupg_keyinfo — Returns an array with information about all keys that matches the given pattern

说明

gnupg_keyinfo ( resource $identifier , string $pattern ) : array

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

pattern

The pattern being checked against the keys.

返回值

Returns an array with information about all keys that matches the given pattern or false, if an error has occurred.

范例

Example #1 Procedural gnupg_keyinfo() example

<?php
$res = gnupg_init();
$info = gnupg_keyinfo($res, 'test');
print_r($info);
?>

Example #2 OO gnupg_keyinfo() example

<?php
$gpg = new gnupg();
$info = $gpg -> keyinfo("test");
print_r($info);
?>


Toggle armored output

  • ? gnupg_keyinfo
  • gnupg_seterrormode ?
  • PHP Manual
  • GnuPG 函数
  • Toggle armored output

gnupg_setarmor

(PECL gnupg >= 0.1)

gnupg_setarmor — Toggle armored output

说明

gnupg_setarmor ( resource $identifier , int $armor ) : bool

Toggle the armored output.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

armor

Pass a non-zero integer-value to this function to enable armored-output (default). Pass 0 to disable armored output.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Procedural gnupg_setarmor() example

<?php
$res = gnupg_init();
gnupg_setarmor($res,1); // enable armored output;
gnupg_setarmor($res,0); // disable armored output;
?>

Example #2 OO gnupg_setarmor() example

<?php
$gpg = new gnupg();
$gpg -> setarmor(1); // enable armored output;
$gpg -> setarmor(0); // disable armored output;
?>


Sets the mode for error_reporting

  • ? gnupg_setarmor
  • gnupg_setsignmode ?
  • PHP Manual
  • GnuPG 函数
  • Sets the mode for error_reporting

gnupg_seterrormode

(PECL gnupg >= 0.6)

gnupg_seterrormode — Sets the mode for error_reporting

说明

gnupg_seterrormode ( resource $identifier , int $errormode ) : void

Sets the mode for error_reporting.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

errormode

The error mode.

errormode takes a constant indicating what type of error_reporting should be used. The possible values are GNUPG_ERROR_WARNING, GNUPG_ERROR_EXCEPTION and GNUPG_ERROR_SILENT. By default GNUPG_ERROR_SILENT is used.

返回值

没有返回值。

范例

Example #1 Procedural gnupg_seterrormode() example

<?php
$res = gnupg_init();
gnupg_seterrormode($res,GNUPG_ERROR_WARNING); // raise a PHP-Warning in case of an error
?>

Example #2 OO gnupg_seterrormode() example

<?php
$gpg = new gnupg();
$gpg -> seterrormode(gnupg::ERROR_EXCEPTION); // throw an exception in case of an error
?>


Sets the mode for signing

  • ? gnupg_seterrormode
  • gnupg_sign ?
  • PHP Manual
  • GnuPG 函数
  • Sets the mode for signing

gnupg_setsignmode

(PECL gnupg >= 0.1)

gnupg_setsignmode — Sets the mode for signing

说明

gnupg_setsignmode ( resource $identifier , int $signmode ) : bool

Sets the mode for signing.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

sigmode

The mode for signing.

signmode takes a constant indicating what type of signature should be produced. The possible values are GNUPG_SIG_MODE_NORMAL, GNUPG_SIG_MODE_DETACH and GNUPG_SIG_MODE_CLEAR. By default GNUPG_SIG_MODE_CLEAR is used.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Procedural gnupg_setsignmode() example

<?php
$res = gnupg_init();
gnupg_setsignmode($res,GNUPG_SIG_MODE_DETACH); // produce a detached signature
?>

Example #2 OO gnupg_setsignmode() example

<?php
$gpg = new gnupg();
$gpg -> setsignmode(gnupg::SIG_MODE_DETACH); // produce a detached signature
?>


Signs a given text

  • ? gnupg_setsignmode
  • gnupg_verify ?
  • PHP Manual
  • GnuPG 函数
  • Signs a given text

gnupg_sign

(PECL gnupg >= 0.1)

gnupg_sign — Signs a given text

说明

gnupg_sign ( resource $identifier , string $plaintext ) : string

Signs the given plaintext with the keys, which were set with gnupg_addsignkey before and returns the signed text or the signature, depending on what was set with gnupg_setsignmode.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

plaintext

The plain text being signed.

返回值

On success, this function returns the signed text or the signature. On failure, this function returns false.

范例

Example #1 Procedural gnupg_sign() example

<?php
$res = gnupg_init();
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$signed = gnupg_sign($res, "just a test");
echo $signed;
?>

Example #2 OO gnupg_sign() example

<?php
$gpg = new gnupg();
$gpg->addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$signed = $gpg->sign("just a test");
echo $signed;
?>


Verifies a signed text

  • ? gnupg_sign
  • wkhtmltox ?
  • PHP Manual
  • GnuPG 函数
  • Verifies a signed text

gnupg_verify

(PECL gnupg >= 0.1)

gnupg_verify — Verifies a signed text

说明

gnupg_verify ( resource $identifier , string $signed_text , string $signature , string &$plaintext = ? ) : array

Verifies the given signed_text and returns information about the signature.

参数

identifier

gnupg 标识符，由对 gnupg_init() 或 gnupg 的调用生成。

signed_text

The signed text.

signature

The signature. To verify a clearsigned text, set signature to false.

plaintext

The plain text. If this optional parameter is passed, it is filled with the plain text.

返回值

On success, this function returns information about the signature. On failure, this function returns false.

范例

Example #1 Procedural gnupg_verify() example

<?php
$plaintext = "";
$res = gnupg_init();
// clearsigned
$info = gnupg_verify($res,$signed_text,false,$plaintext);
print_r($info);
// detached signature
$info = gnupg_verify($res,$signed_text,$signature);
print_r($info);
?>

Example #2 OO gnupg_verify() example

<?php
$plaintext = "";
$gpg = new gnupg();
// clearsigned
$info = $gpg -> verify($signed_text,false,$plaintext);
print_r($info);
// detached signature
$info = $gpg -> verify($signed_text,$signature);
print_r($info);
?>


wkhtmltox

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • wkhtmltox\PDF\Converter — The wkhtmltox\PDF\Converter class
    • wkhtmltox\PDF\Converter::add — Add an object for conversion
    • wkhtmltox\PDF\Converter::__construct — Create a new PDF converter
    • wkhtmltox\PDF\Converter::convert — Perform PDF conversion
    • wkhtmltox\PDF\Converter::getVersion — Determine version of Converter
  • wkhtmltox\PDF\Object — The wkhtmltox\PDF\Object class
    • wkhtmltox\PDF\Object::__construct — Create a new PDF Object
  • wkhtmltox\Image\Converter — The wkhtmltox\Image\Converter class
    • wkhtmltox\Image\Converter::__construct — Create a new Image converter
    • wkhtmltox\Image\Converter::convert — Perform Image conversion
    • wkhtmltox\Image\Converter::getVersion — Determine version of Converter


简介

libwkhtmltox is an open source LGPLv3 library for rendering HTML into PDF and various image formats using the QtWebKit rendering engine.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • wkhtmltox
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

libwkhtmltox source and binary releases are distributed at » wkhtmltopdf.org.

Caution

Windows users need to take the additional step of adding wkhtmltox.dll to their PATH.


安装

The source code of this extension, and binaries for Windows are hosted by » github,

Fetching the source code and building the extension:

git clone https://github.com/krakjoe/wkhtmltox
cd wkhtmltox
phpize
./configure --with-wkhtmltox=/path/to/wkhtmltox/installation
make
sudo make install

Fetching updates and rebuilding the extension:

cd wkhtmltox
phpize --clean
git pull origin master
phpize
./configure --with-wkhtmltox=/path/to/wkhtmltox/installation
make
sudo make install


运行时配置

Name | Description | Default | Stage | Changelog
wkhtmltox.graphics | allow libwkhtmltox to use graphics | Off | PHP_INI_SYSTEM | PHP_INI_PERDIR | >= 0.3.2


The wkhtmltox\PDF\Converter class

(wkhtmltox >= 0.1.0)

简介

Converts an HTML input, or set of HTML inputs, into PDF output

类摘要

wkhtmltox\PDF\Converter {
/* Constructor */
public __construct ( array $settings = ? )
/* 方法 */
public add ( wkhtmltox\PDF\Object $object ) : void
public convert ( ) : string|null
public getVersion ( ) : string
}

Table of Contents

  • wkhtmltox\PDF\Converter::add — Add an object for conversion
  • wkhtmltox\PDF\Converter::__construct — Create a new PDF converter
  • wkhtmltox\PDF\Converter::convert — Perform PDF conversion
  • wkhtmltox\PDF\Converter::getVersion — Determine version of Converter


Add an object for conversion

  • ? wkhtmltox\PDF\Converter
  • wkhtmltox\PDF\Converter::__construct ?
  • PHP Manual
  • wkhtmltox\PDF\Converter
  • Add an object for conversion

wkhtmltox\PDF\Converter::add

(wkhtmltox >= 0.1.0)

wkhtmltox\PDF\Converter::add — Add an object for conversion

说明

public wkhtmltox\PDF\Converter::add ( wkhtmltox\PDF\Object $object ) : void

Adds the given object to conversion

参数

object

The object to add


Create a new PDF converter

  • ? wkhtmltox\PDF\Converter::add
  • wkhtmltox\PDF\Converter::convert ?
  • PHP Manual
  • wkhtmltox\PDF\Converter
  • Create a new PDF converter

wkhtmltox\PDF\Converter::__construct

(wkhtmltox >= 0.1.0)

wkhtmltox\PDF\Converter::__construct — Create a new PDF converter

说明

public wkhtmltox\PDF\Converter::__construct ( array $settings = ? )

Creates a PDF converter, using optional configuration settings

参数

settings

Name | Description | Values | Changelog
size.pageSize | paper size of output document | A4 | >= 0.1.0
size.width | with of the output document | 210mm | >= 0.1.0
size.height | height of the output document | 297mm | >= 0.1.0
orientation orientation of the output document
Landscape
Portrait
>= 0.1.0
colorMode color mode of the output document
Color
Greyscale
>= 0.1.0
resolution | resoluition of the output document | most likely has no effect | >= 0.1.0
dpi | dpi to use while printing | 80 | >= 0.1.0
pageOffset | integer added to page numbers generating headers, footers, and toc | >= 0.1.0
copies | >= 0.1.0
collate | collate copies | boolean | >= 0.1.0
outline | generate PDF outline | boolean | >= 0.1.0
outlineDepth | maximum depth of outline | >= 0.1.0
dumpOutline | path of file to dump outline XML | >= 0.1.0
out | path of output file, if "-" stdout is used | >= 0.1.0
documentTitle | title for the output document | >= 0.1.0
useCompression | enable or disable lossless compression | boolean | >= 0.1.0
margin.top | size of the top margin | 2cm | >= 0.1.0
margin.bottom | size of the bottom margin | 2cm | >= 0.1.0
margin.left | size of the left margin | 2cm | >= 0.1.0
margin.right | size of the right margin | 2cm | >= 0.1.0
imageDPI | maximum DPI for images in the output document | >= 0.1.0
imageQuality | the jpeg compression factor for images in the output document | 94 | >= 0.1.0
load.cookieJar | path of file used to load and store cookies | /tmp/cookies.txt | >= 0.1.0


Perform PDF conversion

  • ? wkhtmltox\PDF\Converter::__construct
  • wkhtmltox\PDF\Converter::getVersion ?
  • PHP Manual
  • wkhtmltox\PDF\Converter
  • Perform PDF conversion

wkhtmltox\PDF\Converter::convert

(wkhtmltox >= 0.1.0)

wkhtmltox\PDF\Converter::convert — Perform PDF conversion

说明

public wkhtmltox\PDF\Converter::convert ( ) : string|null

Performs conversion of all previously added Objects

参数

此函数没有参数。

返回值

Where the return value is used, it will be populated with the contents of the conversion buffer


Determine version of Converter

  • ? wkhtmltox\PDF\Converter::convert
  • wkhtmltox\PDF\Object ?
  • PHP Manual
  • wkhtmltox\PDF\Converter
  • Determine version of Converter

wkhtmltox\PDF\Converter::getVersion

(wkhtmltox >= 0.3.2)

wkhtmltox\PDF\Converter::getVersion — Determine version of Converter

说明

public wkhtmltox\PDF\Converter::getVersion ( ) : string

Determines the version of Converter as reported by libwkhtmltox

参数

此函数没有参数。

返回值

Returns a version string


The wkhtmltox\PDF\Object class

(wkhtmltox >= 0.1.0)

简介

Represents an HTML document, input to PDF converter

类摘要

wkhtmltox\PDF\Object {
/* Constructor */
public __construct ( string $buffer , array $settings = ? )
}

Table of Contents

  • wkhtmltox\PDF\Object::__construct — Create a new PDF Object


Create a new PDF Object

  • ? wkhtmltox\PDF\Object
  • wkhtmltox\Image\Converter ?
  • PHP Manual
  • wkhtmltox\PDF\Object
  • Create a new PDF Object

wkhtmltox\PDF\Object::__construct

(wkhtmltox >= 0.1.0)

wkhtmltox\PDF\Object::__construct — Create a new PDF Object

说明

public wkhtmltox\PDF\Object::__construct ( string $buffer , array $settings = ? )

Creates a new PDF Object from the given buffer and optional configuration settings

参数

buffer

HTML

settings

Name | Description | Values | Changelog
page | URL or path of the HTML to convert | >= 0.1.0
useExternalLinks | set true to convert external links in the input into external PDF links in the output | boolean | >= 0.1.0
useLocalLinks | set true to convert internal links in the input into internal PDF links in the output | boolean | >= 0.1.0
produceForms | set true to turn HTML forms into PDF forms | boolean | >= 0.1.0
replacements | undocumented | >= 0.1.0
includeInOutline | set true to include sections from this object in the outline and toc | boolean | >= 0.1.0
pagesCount | set true to make page count in toc inclusive of the number of pages in this object | boolean | >= 0.1.0
tocXsl | set to style sheet to convert this object into a toc object | >= 0.1.0
toc.useDottedLines | set true to use dotted lines in toc | boolean | >= 0.1.0
toc.captionText | the caption text for toc | >= 0.1.0
toc.forwardLinks | set true to create links from toc to content | boolean | >= 0.1.0
toc.backLinks | set true to create links from content to toc | boolean | >= 0.1.0
toc.indentation | indentation for toc | 2em | >= 0.1.0
toc.fontScale | the factor to scale down the font at every toc level | 0.8 | >= 0.1.0
header.fontSize | font size for use in header | 13 | >= 0.1.0
header.fontName | name of font for use in header | times | >= 0.1.0
header.left | text for left of header | >= 0.1.0
header.center | text for center of header | >= 0.1.0
header.right | text for right of header | >= 0.1.0
header.line | enable or disable horizontal rule under header | boolean | >= 0.1.0
header.spacing | space between header and content | 1.8 | >= 0.1.0
header.htmlUrl | URL or path of HTML to use in header | >= 0.1.0
footer.fontSize | font size for use in footer | 13 | >= 0.1.0
footer.fontName | name of font for use in footer | times | >= 0.1.0
footer.left | text for left of footer | >= 0.1.0
footer.center | text for center of footer | >= 0.1.0
footer.right | text for right of footer | >= 0.1.0
footer.line | enable or disable horizontal rule under footer | boolean | >= 0.1.0
footer.spacing | space between footer and content | 1.8 | >= 0.1.0
footer.htmlUrl | URL or path of HTML to use in footer | >= 0.1.0
load.username | user name to use when loging into a website | bart | >= 0.1.0
load.password | the password to used when logging into a website | elbarto | >= 0.1.0
load.jsdelay | the amount of time in milliseconds to wait after a page is loaded until it is captured | 1200 | >= 0.1.0
load.zoomFactor | how much zoom should be applied to the content | 2.2 | >= 0.1.0
load.customHeaders | custom headers to send when requesting the main web page | >= 0.1.0
load.repertCustomHeaders | set true to send with all requests | boolean | >= 0.1.0
load.cookies | cookie string to send when requesting the main web page | >= 0.1.0
load.post | post string to send when requesting the main web page | >= 0.1.0
load.blockLocalFileAccess | disallow local and piped files to access other local files | boolean | >= 0.1.0
load.stopSlowScript | stop slow running javascript | boolean
load.debugJavascript | allow javascript to raise warnings | boolean | >= 0.1.0
load.loadErrorHandling set error handling strategy
abort | abort the convertion process
skip | do not add the object to the final output
ignore | try to add the object to the final output
>= 0.1.0
load.proxy | >= 0.1.0
web.background | include background image in output | boolean | >= 0.1.0
web.loadImages | include images in output | boolean | >= 0.1.0
web.enableJavascript | enable or disable javascript | boolean | >= 0.1.0
web.enableIntelligentShrinking | enable to attempt to fit more content on page, only applies to PDF output | boolean | >= 0.1.0
web.minimumFontSize | the minimum font size allowed | 9 | >= 0.1.0
web.printMediaType | print content using print media type instead of screen media type | boolean | >= 0.1.0
web.defaultEncoding | content to use where no encoding is specified | utf-8 | >= 0.1.0
web.userStyleSheet | URL or path to a user specified style sheet | /path/to/style.css | >= 0.1.0
web.enablePlugins | enable or disable NS plugins | boolean | >= 0.1.0


The wkhtmltox\Image\Converter class

(wkhtmltox >= 0.1.0)

简介

Converts an HTML input into various image formats

类摘要

wkhtmltox\Image\Converter {
/* Constructor */
public __construct ( string $buffer = ? , array $settings = ? )
/* 方法 */
public convert ( ) : string|null
public getVersion ( ) : string
}

Table of Contents

  • wkhtmltox\Image\Converter::__construct — Create a new Image converter
  • wkhtmltox\Image\Converter::convert — Perform Image conversion
  • wkhtmltox\Image\Converter::getVersion — Determine version of Converter


Create a new Image converter

  • ? wkhtmltox\Image\Converter
  • wkhtmltox\Image\Converter::convert ?
  • PHP Manual
  • wkhtmltox\Image\Converter
  • Create a new Image converter

wkhtmltox\Image\Converter::__construct

(wkhtmltox >= 0.1.0)

wkhtmltox\Image\Converter::__construct — Create a new Image converter

说明

public wkhtmltox\Image\Converter::__construct ( string $buffer = ? , array $settings = ? )

Creates an Image converter, optionally taking an input buffer and configuration settings

参数

buffer

HTML

settings

Name | Description | Values | Changelog
in | URL or path of the input file, if "-" stdin is used | /path/to/markup.html | >= 0.1.0
out | path of output file, if "-" stdout is used, by default an internal buffer is used | /path/to/output.png | >= 0.1.0
fmt output format to use
"" default
jpg | output as JPEG
png | output as PNG
bmp | output as bitmap
svg | output as SVG
>= 0.1.0
transparent | when outputting a PNG or SVG, make the white background transparent | boolean | >= 0.1.0
screenWidth | the with of the screen used to render in pixels | 800 | >= 0.1.0
smartWidth | when true, screenWidth is expanded to the content width | boolean | >= 0.1.0
quality | compression factor to use when outputting a JPEG image | 94 | >= 0.1.0
crop.left | left/x coordinate of the window to capture in pixels | 200 | >= 0.1.0
crop.top | top/y coordinate of the window to capture in pixels | 200 | >= 0.1.0
crop.width | width of the window to capture in pixels | 200 | >= 0.1.0
crop.height | height of the window to capture in pixels | 200 | >= 0.1.0
load.cookieJar | path of file used to load and store cookies | /tmp/cookies.txt | >= 0.1.0
load.username | user name to use when loging into a website | bart | >= 0.1.0
load.password | the password to used when logging into a website | elbarto | >= 0.1.0
load.jsdelay | the amount of time in milliseconds to wait after a page is loaded until it is captured | 1200 | >= 0.1.0
load.zoomFactor | how much zoom should be applied to the content | 2.2 | >= 0.1.0
load.customHeaders | custom headers to send when requesting the main web page | >= 0.1.0
load.repertCustomHeaders | set true to send with all requests | boolean | >= 0.1.0
load.cookies | cookie string to send when requesting the main web page | >= 0.1.0
load.post | post string to send when requesting the main web page | >= 0.1.0
load.blockLocalFileAccess | disallow local and piped files to access other local files | boolean | >= 0.1.0
load.stopSlowScript | stop slow running javascript | boolean
load.debugJavascript | allow javascript to raise warnings | boolean | >= 0.1.0
load.loadErrorHandling set error handling strategy
abort | abort the convertion process
skip | do not add the object to the final output
ignore | try to add the object to the final output
>= 0.1.0
load.proxy | >= 0.1.0
web.background | include background image in output | boolean | >= 0.1.0
web.loadImages | include images in output | boolean | >= 0.1.0
web.enableJavascript | enable or disable javascript | boolean | >= 0.1.0
web.enableIntelligentShrinking | enable to attempt to fit more content on page, only applies to PDF output | boolean | >= 0.1.0
web.minimumFontSize | the minimum font size allowed | 9 | >= 0.1.0
web.printMediaType | print content using print media type instead of screen media type | boolean | >= 0.1.0
web.defaultEncoding | content to use where no encoding is specified | utf-8 | >= 0.1.0
web.userStyleSheet | URL or path to a user specified style sheet | /path/to/style.css | >= 0.1.0
web.enablePlugins | enable or disable NS plugins | boolean | >= 0.1.0


Perform Image conversion

  • ? wkhtmltox\Image\Converter::__construct
  • wkhtmltox\Image\Converter::getVersion ?
  • PHP Manual
  • wkhtmltox\Image\Converter
  • Perform Image conversion

wkhtmltox\Image\Converter::convert

(wkhtmltox >= 0.1.0)

wkhtmltox\Image\Converter::convert — Perform Image conversion

说明

public wkhtmltox\Image\Converter::convert ( ) : string|null

Performs conversion of the input buffer

参数

此函数没有参数。

返回值

Where the return value is used, it will be populated with the contents of the conversion buffer


Determine version of Converter

  • ? wkhtmltox\Image\Converter::convert
  • PS ?
  • PHP Manual
  • wkhtmltox\Image\Converter
  • Determine version of Converter

wkhtmltox\Image\Converter::getVersion

(wkhtmltox >= 0.3.2)

wkhtmltox\Image\Converter::getVersion — Determine version of Converter

说明

public wkhtmltox\Image\Converter::getVersion ( ) : string

Determines the version of Converter as reported by libwkhtmltox

参数

此函数没有参数。

返回值

Returns a version string

Warning

This is not yet implemented by libwkhtmltox


PostScript document creation

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • PS 函数
    • ps_add_bookmark — Add bookmark to current page
    • ps_add_launchlink — Adds link which launches file
    • ps_add_locallink — Adds link to a page in the same document
    • ps_add_note — Adds note to current page
    • ps_add_pdflink — Adds link to a page in a second pdf document
    • ps_add_weblink — Adds link to a web location
    • ps_arc — Draws an arc counterclockwise
    • ps_arcn — Draws an arc clockwise
    • ps_begin_page — Start a new page
    • ps_begin_pattern — Start a new pattern
    • ps_begin_template — Start a new template
    • ps_circle — Draws a circle
    • ps_clip — Clips drawing to current path
    • ps_close_image — Closes image and frees memory
    • ps_close — Closes a PostScript document
    • ps_closepath_stroke — Closes and strokes path
    • ps_closepath — Closes path
    • ps_continue_text — Continue text in next line
    • ps_curveto — Draws a curve
    • ps_delete — Deletes all resources of a PostScript document
    • ps_end_page — End a page
    • ps_end_pattern — End a pattern
    • ps_end_template — End a template
    • ps_fill_stroke — Fills and strokes the current path
    • ps_fill — Fills the current path
    • ps_findfont — Loads a font
    • ps_get_buffer — Fetches the full buffer containig the generated PS data
    • ps_get_parameter — Gets certain parameters
    • ps_get_value — Gets certain values
    • ps_hyphenate — Hyphenates a word
    • ps_include_file — Reads an external file with raw PostScript code
    • ps_lineto — Draws a line
    • ps_makespotcolor — Create spot color
    • ps_moveto — Sets current point
    • ps_new — Creates a new PostScript document object
    • ps_open_file — Opens a file for output
    • ps_open_image_file — Opens image from file
    • ps_open_image — Reads an image for later placement
    • ps_open_memory_image — Takes an GD image and returns an image for placement in a PS document
    • ps_place_image — Places image on the page
    • ps_rect — Draws a rectangle
    • ps_restore — Restore previously save context
    • ps_rotate — Sets rotation factor
    • ps_save — Save current context
    • ps_scale — Sets scaling factor
    • ps_set_border_color — Sets color of border for annotations
    • ps_set_border_dash — Sets length of dashes for border of annotations
    • ps_set_border_style — Sets border style of annotations
    • ps_set_info — Sets information fields of document
    • ps_set_parameter — Sets certain parameters
    • ps_set_text_pos — Sets position for text output
    • ps_set_value — Sets certain values
    • ps_setcolor — Sets current color
    • ps_setdash — Sets appearance of a dashed line
    • ps_setflat — Sets flatness
    • ps_setfont — Sets font to use for following output
    • ps_setgray — Sets gray value
    • ps_setlinecap — Sets appearance of line ends
    • ps_setlinejoin — Sets how contected lines are joined
    • ps_setlinewidth — Sets width of a line
    • ps_setmiterlimit — Sets the miter limit
    • ps_setoverprintmode — Sets overprint mode
    • ps_setpolydash — Sets appearance of a dashed line
    • ps_shading_pattern — Creates a pattern based on a shading
    • ps_shading — Creates a shading for later use
    • ps_shfill — Fills an area with a shading
    • ps_show_boxed — Output text in a box
    • ps_show_xy2 — Output text at position
    • ps_show_xy — Output text at given position
    • ps_show2 — Output a text at current position
    • ps_show — Output text
    • ps_string_geometry — Gets geometry of a string
    • ps_stringwidth — Gets width of a string
    • ps_stroke — Draws the current path
    • ps_symbol_name — Gets name of a glyph
    • ps_symbol_width — Gets width of a glyph
    • ps_symbol — Output a glyph
    • ps_translate — Sets translation


简介

This module allows to create PostScript documents. It has many similarities with the pdf extension. Actually the API is almost identical and one can in many cases just replace the prefix of each function from pdf_ to ps_. This also works for functions which has no meaning in the PostScript document (like adding hyperlinks) but will have an effect if the document is converted to PDF.

Documents created by this extension are sometimes even superior to documents created with the pdf extension, because pslib's text rendering functions can handle kerning, hyphenation and ligatures which results in much better output of boxed text.


需求

You need at least pslib >= 0.1.12. The ps library (pslib) is available at » http://pslib.sourceforge.net/.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ps.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


资源类型

This extension defines a PostScript document resource returned by ps_new().


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

The following two tables lists all constants defined by the ps extension.

Contants for line caps
Name | Meaning
ps_LINECAP_BUTT |
ps_LINECAP_ROUND |
ps_LINECAP_SQUARED |
Contants for line joins
Name | Meaning
ps_LINEJOIN_MITER |
ps_LINEJOIN_ROUND |
ps_LINEJOIN_BEVEL |


PS 函数

Contact Information

If you have comments, bugfixes, enhancements for either this extension or pslib then please drop me a mail » steinm@php.net. Any help is very welcome.

Table of Contents

  • ps_add_bookmark — Add bookmark to current page
  • ps_add_launchlink — Adds link which launches file
  • ps_add_locallink — Adds link to a page in the same document
  • ps_add_note — Adds note to current page
  • ps_add_pdflink — Adds link to a page in a second pdf document
  • ps_add_weblink — Adds link to a web location
  • ps_arc — Draws an arc counterclockwise
  • ps_arcn — Draws an arc clockwise
  • ps_begin_page — Start a new page
  • ps_begin_pattern — Start a new pattern
  • ps_begin_template — Start a new template
  • ps_circle — Draws a circle
  • ps_clip — Clips drawing to current path
  • ps_close_image — Closes image and frees memory
  • ps_close — Closes a PostScript document
  • ps_closepath_stroke — Closes and strokes path
  • ps_closepath — Closes path
  • ps_continue_text — Continue text in next line
  • ps_curveto — Draws a curve
  • ps_delete — Deletes all resources of a PostScript document
  • ps_end_page — End a page
  • ps_end_pattern — End a pattern
  • ps_end_template — End a template
  • ps_fill_stroke — Fills and strokes the current path
  • ps_fill — Fills the current path
  • ps_findfont — Loads a font
  • ps_get_buffer — Fetches the full buffer containig the generated PS data
  • ps_get_parameter — Gets certain parameters
  • ps_get_value — Gets certain values
  • ps_hyphenate — Hyphenates a word
  • ps_include_file — Reads an external file with raw PostScript code
  • ps_lineto — Draws a line
  • ps_makespotcolor — Create spot color
  • ps_moveto — Sets current point
  • ps_new — Creates a new PostScript document object
  • ps_open_file — Opens a file for output
  • ps_open_image_file — Opens image from file
  • ps_open_image — Reads an image for later placement
  • ps_open_memory_image — Takes an GD image and returns an image for placement in a PS document
  • ps_place_image — Places image on the page
  • ps_rect — Draws a rectangle
  • ps_restore — Restore previously save context
  • ps_rotate — Sets rotation factor
  • ps_save — Save current context
  • ps_scale — Sets scaling factor
  • ps_set_border_color — Sets color of border for annotations
  • ps_set_border_dash — Sets length of dashes for border of annotations
  • ps_set_border_style — Sets border style of annotations
  • ps_set_info — Sets information fields of document
  • ps_set_parameter — Sets certain parameters
  • ps_set_text_pos — Sets position for text output
  • ps_set_value — Sets certain values
  • ps_setcolor — Sets current color
  • ps_setdash — Sets appearance of a dashed line
  • ps_setflat — Sets flatness
  • ps_setfont — Sets font to use for following output
  • ps_setgray — Sets gray value
  • ps_setlinecap — Sets appearance of line ends
  • ps_setlinejoin — Sets how contected lines are joined
  • ps_setlinewidth — Sets width of a line
  • ps_setmiterlimit — Sets the miter limit
  • ps_setoverprintmode — Sets overprint mode
  • ps_setpolydash — Sets appearance of a dashed line
  • ps_shading_pattern — Creates a pattern based on a shading
  • ps_shading — Creates a shading for later use
  • ps_shfill — Fills an area with a shading
  • ps_show_boxed — Output text in a box
  • ps_show_xy2 — Output text at position
  • ps_show_xy — Output text at given position
  • ps_show2 — Output a text at current position
  • ps_show — Output text
  • ps_string_geometry — Gets geometry of a string
  • ps_stringwidth — Gets width of a string
  • ps_stroke — Draws the current path
  • ps_symbol_name — Gets name of a glyph
  • ps_symbol_width — Gets width of a glyph
  • ps_symbol — Output a glyph
  • ps_translate — Sets translation


Add bookmark to current page

  • ? PS 函数
  • ps_add_launchlink ?
  • PHP Manual
  • PS 函数
  • Add bookmark to current page

ps_add_bookmark

(PECL ps >= 1.1.0)

ps_add_bookmark — Add bookmark to current page

说明

ps_add_bookmark ( resource $psdoc , string $text , int $parent = 0 , int $open = 0 ) : int

Adds a bookmark for the current page. Bookmarks usually appear in PDF-Viewers left of the page in a hierarchical tree. Clicking on a bookmark will jump to the given page.

此说明在文档被打印或显示时不可见，只在文档用 Acrobat Distiller 或 Ghostview 转换成 PDF 时显示。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text used for displaying the bookmark.

parent

A bookmark previously created by this function which is used as the parent of the new bookmark.

open

If open is unequal to zero the bookmark will be shown open by the pdf viewer.

返回值

The returned value is a reference for the bookmark. It is only used if the bookmark shall be used as a parent. The value is greater zero if the function succeeds. In case of an error zero will be returned.

参见

  • ps_add_launchlink() - Adds link which launches file
  • ps_add_pdflink() - Adds link to a page in a second pdf document
  • ps_add_weblink() - Adds link to a web location


Adds link which launches file

  • ? ps_add_bookmark
  • ps_add_locallink ?
  • PHP Manual
  • PS 函数
  • Adds link which launches file

ps_add_launchlink

(PECL ps >= 1.1.0)

ps_add_launchlink — Adds link which launches file

说明

ps_add_launchlink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $filename ) : bool

Places a hyperlink at the given position pointing to a file program which is being started when clicked on. The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

此说明在文档被打印或显示时不可见，只在文档用 Acrobat Distiller 或 Ghostview 转换成 PDF 时显示。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

filename

The path of the program to be started, when the link is clicked on.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_add_locallink() - Adds link to a page in the same document
  • ps_add_pdflink() - Adds link to a page in a second pdf document
  • ps_add_weblink() - Adds link to a web location


Adds link to a page in the same document

  • ? ps_add_launchlink
  • ps_add_note ?
  • PHP Manual
  • PS 函数
  • Adds link to a page in the same document

ps_add_locallink

(PECL ps >= 1.1.0)

ps_add_locallink — Adds link to a page in the same document

说明

ps_add_locallink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , int $page , string $dest ) : bool

Places a hyperlink at the given position pointing to a page in the same document. Clicking on the link will jump to the given page. The first page in a document has number 1.

The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

此说明在文档被打印或显示时不可见，只在文档用 Acrobat Distiller 或 Ghostview 转换成 PDF 时显示。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

page

The number of the page displayed when clicking on the link.

dest

The parameter dest determines how the document is being viewed. It can be fitpage, fitwidth, fitheight, or fitbbox.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_add_launchlink() - Adds link which launches file
  • ps_add_pdflink() - Adds link to a page in a second pdf document
  • ps_add_weblink() - Adds link to a web location


Adds note to current page

  • ? ps_add_locallink
  • ps_add_pdflink ?
  • PHP Manual
  • PS 函数
  • Adds note to current page

ps_add_note

(PECL ps >= 1.1.0)

ps_add_note — Adds note to current page

说明

ps_add_note ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $contents , string $title , string $icon , int $open ) : bool

Adds a note at a certain position on the page. Notes are like little rectangular sheets with text on it, which can be placed anywhere on a page. They are shown either folded or unfolded. If folded, the specified icon is used as a placeholder.

此说明在文档被打印或显示时不可见，只在文档用 Acrobat Distiller 或 Ghostview 转换成 PDF 时显示。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

contents

The text of the note.

title

The title of the note as displayed in the header of the note.

icon

The icon shown if the note is folded. This parameter can be set to comment, insert, note, paragraph, newparagraph, key, or help.

open

If open is unequal to zero the note will be shown unfolded after opening the document with a pdf viewer.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_add_pdflink() - Adds link to a page in a second pdf document
  • ps_add_launchlink() - Adds link which launches file
  • ps_add_locallink() - Adds link to a page in the same document
  • ps_add_weblink() - Adds link to a web location


Adds link to a page in a second pdf document

  • ? ps_add_note
  • ps_add_weblink ?
  • PHP Manual
  • PS 函数
  • Adds link to a page in a second pdf document

ps_add_pdflink

(PECL ps >= 1.1.0)

ps_add_pdflink — Adds link to a page in a second pdf document

说明

ps_add_pdflink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $filename , int $page , string $dest ) : bool

Places a hyperlink at the given position pointing to a second pdf document. Clicking on the link will branch to the document at the given page. The first page in a document has number 1.

The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

此说明在文档被打印或显示时不可见，只在文档用 Acrobat Distiller 或 Ghostview 转换成 PDF 时显示。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

filename

The name of the pdf document to be opened when clicking on this link.

page

The page number of the destination pdf document

dest

The parameter dest determines how the document is being viewed. It can be fitpage, fitwidth, fitheight, or fitbbox.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_add_launchlink() - Adds link which launches file
  • ps_add_locallink() - Adds link to a page in the same document
  • ps_add_weblink() - Adds link to a web location


Adds link to a web location

  • ? ps_add_pdflink
  • ps_arc ?
  • PHP Manual
  • PS 函数
  • Adds link to a web location

ps_add_weblink

(PECL ps >= 1.1.0)

ps_add_weblink — Adds link to a web location

说明

ps_add_weblink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $url ) : bool

Places a hyperlink at the given position pointing to a web page. The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

此说明在文档被打印或显示时不可见，只在文档用 Acrobat Distiller 或 Ghostview 转换成 PDF 时显示。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

url

The url of the hyperlink to be opened when clicking on this link, e.g. http://www.php.net.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_add_launchlink() - Adds link which launches file
  • ps_add_locallink() - Adds link to a page in the same document
  • ps_add_pdflink() - Adds link to a page in a second pdf document


Draws an arc counterclockwise

  • ? ps_add_weblink
  • ps_arcn ?
  • PHP Manual
  • PS 函数
  • Draws an arc counterclockwise

ps_arc

(PECL ps >= 1.1.0)

ps_arc — Draws an arc counterclockwise

说明

ps_arc ( resource $psdoc , float $x , float $y , float $radius , float $alpha , float $beta ) : bool

Draws a portion of a circle with at middle point at (x, y). The arc starts at an angle of alpha and ends at an angle of beta. It is drawn counterclockwise (use ps_arcn() to draw clockwise). The subpath added to the current path starts on the arc at angle alpha and ends on the arc at angle beta.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

alpha

The start angle given in degrees.

beta

The end angle given in degrees.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_arcn() - Draws an arc clockwise


Draws an arc clockwise

  • ? ps_arc
  • ps_begin_page ?
  • PHP Manual
  • PS 函数
  • Draws an arc clockwise

ps_arcn

(PECL ps >= 1.1.0)

ps_arcn — Draws an arc clockwise

说明

ps_arcn ( resource $psdoc , float $x , float $y , float $radius , float $alpha , float $beta ) : bool

Draws a portion of a circle with at middle point at (x, y). The arc starts at an angle of alpha and ends at an angle of beta. It is drawn clockwise (use ps_arc() to draw counterclockwise). The subpath added to the current path starts on the arc at angle beta and ends on the arc at angle alpha.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

alpha

The starting angle given in degrees.

beta

The end angle given in degrees.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_arc() - Draws an arc counterclockwise


Start a new page

  • ? ps_arcn
  • ps_begin_pattern ?
  • PHP Manual
  • PS 函数
  • Start a new page

ps_begin_page

(PECL ps >= 1.1.0)

ps_begin_page — Start a new page

说明

ps_begin_page ( resource $psdoc , float $width , float $height ) : bool

Starts a new page. Although the parameters width and height imply a different page size for each page, this is not possible in PostScript. The first call of ps_begin_page() will set the page size for the whole document. Consecutive calls will have no effect, except for creating a new page. The situation is different if you intent to convert the PostScript document into PDF. This function places pdfmarks into the document which can set the size for each page indiviually. The resulting PDF document will have different page sizes.

Though PostScript does not know different page sizes, pslib places a bounding box for each page into the document. This size is evaluated by some PostScript viewers and will have precedence over the BoundingBox in the Header of the document. This can lead to unexpected results when you set a BoundingBox whose lower left corner is not (0, 0), because the bounding box of the page will always have a lower left corner (0, 0) and overwrites the global setting.

Each page is encapsulated into save/restore. This means, that most of the settings made on one page will not be retained on the next page.

If there is up to the first call of ps_begin_page() no call of ps_findfont(), then the header of the PostScript document will be output and the bounding box will be set to the size of the first page. The lower left corner of the bounding box is set to (0, 0). If ps_findfont() was called before, then the header has been output already, and the document will not have a valid bounding box. In order to prevent this, one should call ps_set_info() to set the info field BoundingBox and possibly Orientation before any ps_findfont() or ps_begin_page() calls.

Note:

Up to version 0.2.6 of pslib, this function will always overwrite the BoundingBox and Orientation, if it has been set before with ps_set_info() and ps_findfont() has not been called before.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the page in pixel, e.g. 596 for A4 format.

height

The height of the page in pixel, e.g. 842 for A4 format.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_end_page() - End a page
  • ps_findfont() - Loads a font
  • ps_set_info() - Sets information fields of document


Start a new pattern

  • ? ps_begin_page
  • ps_begin_template ?
  • PHP Manual
  • PS 函数
  • Start a new pattern

ps_begin_pattern

(PECL ps >= 1.2.0)

ps_begin_pattern — Start a new pattern

说明

ps_begin_pattern ( resource $psdoc , float $width , float $height , float $xstep , float $ystep , int $painttype ) : int|false

Starts a new pattern. A pattern is like a page containing e.g. a drawing which can be used for filling areas. It is used like a color by calling ps_setcolor() and setting the color space to pattern.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the pattern in pixel.

height

The height of the pattern in pixel.

x-step

The distance in pixel of placements of the pattern in horizontal direction.

y-step

The distance in pixel of placements of the pattern in vertical direction.

painttype

Must be 1 or 2.

返回值

The identifier of the pattern 或者在失败时返回 false.

范例

Example #1 Creating and using a pattern

<?php
$ps = ps_new();

if (!ps_open_file($ps, "pattern.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_parameter($ps, "warning", "true");
ps_set_info($ps, "Creator", "pattern.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Pattern example");

$pspattern = ps_begin_pattern($ps, 10.0, 10.0, 10.0, 10.0, 1);
ps_setlinewidth($ps, 0.2);
ps_setcolor($ps, "stroke", "rgb", 0.0, 0.0, 1.0, 0.0);
ps_moveto($ps, 0, 0);
ps_lineto($ps, 7, 7);
ps_stroke($ps);
ps_moveto($ps, 0, 7);
ps_lineto($ps, 7, 0);
ps_stroke($ps);
ps_end_pattern($ps);

ps_begin_page($ps, 596, 842);
ps_setcolor($ps, "both", "pattern", $pspattern, 0.0, 0.0, 0.0);
ps_rect($ps, 50, 400, 200, 200);
ps_fill($ps);
ps_end_page($ps);

ps_close($ps);
ps_delete($ps);
?>

参见

  • ps_end_pattern() - End a pattern
  • ps_setcolor() - Sets current color
  • ps_shading_pattern() - Creates a pattern based on a shading


Start a new template

  • ? ps_begin_pattern
  • ps_circle ?
  • PHP Manual
  • PS 函数
  • Start a new template

ps_begin_template

(PECL ps >= 1.2.0)

ps_begin_template — Start a new template

说明

ps_begin_template ( resource $psdoc , float $width , float $height ) : int

Starts a new template. A template is called a form in the postscript language. It is created similar to a pattern but used like an image. Templates are often used for drawings which are placed several times through out the document, e.g. like a company logo. All drawing functions may be used within a template. The template will not be drawn until it is placed by ps_place_image().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the template in pixel.

height

The height of the template in pixel.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Creating and using a template

<?php
$ps = ps_new();

if (!ps_open_file($ps, "template.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_parameter($ps, "warning", "true");
ps_set_info($ps, "Creator", "template.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Template example");

$pstemplate = ps_begin_template($ps, 30.0, 30.0);
ps_moveto($ps, 0, 0);
ps_lineto($ps, 30, 30);
ps_moveto($ps, 0, 30);
ps_lineto($ps, 30, 0);
ps_stroke($ps);
ps_end_template($ps);

ps_begin_page($ps, 596, 842);
ps_place_image($ps, $pstemplate, 20.0, 20.0, 1.0);
ps_place_image($ps, $pstemplate, 50.0, 30.0, 0.5);
ps_place_image($ps, $pstemplate, 70.0, 70.0, 0.6);
ps_place_image($ps, $pstemplate, 30.0, 50.0, 1.3);
ps_end_page($ps);

ps_close($ps);
ps_delete($ps);
?>

参见

  • ps_end_template() - End a template


Draws a circle

  • ? ps_begin_template
  • ps_clip ?
  • PHP Manual
  • PS 函数
  • Draws a circle

ps_circle

(PECL ps >= 1.1.0)

ps_circle — Draws a circle

说明

ps_circle ( resource $psdoc , float $x , float $y , float $radius ) : bool

Draws a circle with its middle point at (x, y). The circle starts and ends at position (x+radius, y). If this function is called outside a path it will start a new path. If it is called within a path it will add the circle as a subpath. If the last drawing operation does not end in point (x+radius, y) then there will be a gap in the path.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_arc() - Draws an arc counterclockwise
  • ps_arcn() - Draws an arc clockwise


Clips drawing to current path

  • ? ps_circle
  • ps_close_image ?
  • PHP Manual
  • PS 函数
  • Clips drawing to current path

ps_clip

(PECL ps >= 1.1.0)

ps_clip — Clips drawing to current path

说明

ps_clip ( resource $psdoc ) : bool

Takes the current path and uses it to define the border of a clipping area. Everything drawn outside of that area will not be visible.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_closepath() - Closes path


Closes image and frees memory

  • ? ps_clip
  • ps_close ?
  • PHP Manual
  • PS 函数
  • Closes image and frees memory

ps_close_image

(PECL ps >= 1.1.0)

ps_close_image — Closes image and frees memory

说明

ps_close_image ( resource $psdoc , int $imageid ) : void|false

Closes an image and frees its resources. Once an image is closed it cannot be used anymore.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

imageid

Resource identifier of the image as returned by ps_open_image() or ps_open_image_file().

返回值

Returns null on success 或者在失败时返回 false.

参见

  • ps_open_image() - Reads an image for later placement
  • ps_open_image_file() - Opens image from file


Closes a PostScript document

  • ? ps_close_image
  • ps_closepath_stroke ?
  • PHP Manual
  • PS 函数
  • Closes a PostScript document

ps_close

(PECL ps >= 1.1.0)

ps_close — Closes a PostScript document

说明

ps_close ( resource $psdoc ) : bool

Closes the PostScript document.

This function writes the trailer of the PostScript document. It also writes the bookmark tree. ps_close() does not free any resources, which is done by ps_delete().

This function is also called by ps_delete() if it has not been called before.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_open_file() - Opens a file for output
  • ps_delete() - Deletes all resources of a PostScript document


Closes and strokes path

  • ? ps_close
  • ps_closepath ?
  • PHP Manual
  • PS 函数
  • Closes and strokes path

ps_closepath_stroke

(PECL ps >= 1.1.0)

ps_closepath_stroke — Closes and strokes path

说明

ps_closepath_stroke ( resource $psdoc ) : bool

Connects the last point with first point of a path and draws the resulting closed line.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_closepath() - Closes path


Closes path

  • ? ps_closepath_stroke
  • ps_continue_text ?
  • PHP Manual
  • PS 函数
  • Closes path

ps_closepath

(PECL ps >= 1.1.0)

ps_closepath — Closes path

说明

ps_closepath ( resource $psdoc ) : bool

Connects the last point with the first point of a path. The resulting path can be used for stroking, filling, clipping, etc..

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_clip() - Clips drawing to current path
  • ps_closepath_stroke() - Closes and strokes path


Continue text in next line

  • ? ps_closepath
  • ps_curveto ?
  • PHP Manual
  • PS 函数
  • Continue text in next line

ps_continue_text

(PECL ps >= 1.1.0)

ps_continue_text — Continue text in next line

说明

ps_continue_text ( resource $psdoc , string $text ) : bool

Output a text one line below the last line. The line spacing is taken from the value "leading" which must be set with ps_set_value(). The actual position of the text is determined by the values "textx" and "texty" which can be requested with ps_get_value()

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to output.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_show() - Output text
  • ps_show_xy() - Output text at given position
  • ps_show_boxed() - Output text in a box


Draws a curve

  • ? ps_continue_text
  • ps_delete ?
  • PHP Manual
  • PS 函数
  • Draws a curve

ps_curveto

(PECL ps >= 1.1.0)

ps_curveto — Draws a curve

说明

ps_curveto ( resource $psdoc , float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 ) : bool

Add a section of a cubic Bézier curve described by the three given control points to the current path.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x1

x-coordinate of first control point.

y1

y-coordinate of first control point.

x2

x-coordinate of second control point.

y2

y-coordinate of second control point.

x3

x-coordinate of third control point.

y3

y-coordinate of third control point.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_lineto() - Draws a line


Deletes all resources of a PostScript document

  • ? ps_curveto
  • ps_end_page ?
  • PHP Manual
  • PS 函数
  • Deletes all resources of a PostScript document

ps_delete

(PECL ps >= 1.1.0)

ps_delete — Deletes all resources of a PostScript document

说明

ps_delete ( resource $psdoc ) : bool

Mainly frees memory used by the document. Also closes a file, if it was not closed before with ps_close(). You should in any case close the file with ps_close() before, because ps_close() not just closes the file but also outputs a trailor containing PostScript comments like the number of pages in the document and adding the bookmark hierarchy.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_close() - Closes a PostScript document


End a page

  • ? ps_delete
  • ps_end_pattern ?
  • PHP Manual
  • PS 函数
  • End a page

ps_end_page

(PECL ps >= 1.1.0)

ps_end_page — End a page

说明

ps_end_page ( resource $psdoc ) : bool

Ends a page which was started with ps_begin_page(). Ending a page will leave the current drawing context, which e.g. requires to reload fonts if they were loading within the page, and to set many other drawing parameters like the line width, or color.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_begin_page() - Start a new page


End a pattern

  • ? ps_end_page
  • ps_end_template ?
  • PHP Manual
  • PS 函数
  • End a pattern

ps_end_pattern

(PECL ps >= 1.2.0)

ps_end_pattern — End a pattern

说明

ps_end_pattern ( resource $psdoc ) : bool

Ends a pattern which was started with ps_begin_pattern(). Once a pattern has been ended, it can be used like a color to fill areas.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_begin_pattern() - Start a new pattern


End a template

  • ? ps_end_pattern
  • ps_fill_stroke ?
  • PHP Manual
  • PS 函数
  • End a template

ps_end_template

(PECL ps >= 1.2.0)

ps_end_template — End a template

说明

ps_end_template ( resource $psdoc ) : bool

Ends a template which was started with ps_begin_template(). Once a template has been ended, it can be used like an image.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_begin_template() - Start a new template


Fills and strokes the current path

  • ? ps_end_template
  • ps_fill ?
  • PHP Manual
  • PS 函数
  • Fills and strokes the current path

ps_fill_stroke

(PECL ps >= 1.1.0)

ps_fill_stroke — Fills and strokes the current path

说明

ps_fill_stroke ( resource $psdoc ) : bool

Fills and draws the path constructed with previously called drawing functions like ps_lineto().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_fill() - Fills the current path
  • ps_stroke() - Draws the current path


Fills the current path

  • ? ps_fill_stroke
  • ps_findfont ?
  • PHP Manual
  • PS 函数
  • Fills the current path

ps_fill

(PECL ps >= 1.1.0)

ps_fill — Fills the current path

说明

ps_fill ( resource $psdoc ) : bool

Fills the path constructed with previously called drawing functions like ps_lineto().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_fill_stroke() - Fills and strokes the current path
  • ps_stroke() - Draws the current path


Loads a font

  • ? ps_fill
  • ps_get_buffer ?
  • PHP Manual
  • PS 函数
  • Loads a font

ps_findfont

(PECL ps >= 1.1.0)

ps_findfont — Loads a font

说明

ps_findfont ( resource $psdoc , string $fontname , string $encoding , bool $embed = false ) : int

Loads a font for later use. Before text is output with a loaded font it must be set with ps_setfont(). This function needs the adobe font metric file in order to calculate the space used up by the characters. A font which is loaded within a page will only be available on that page. Fonts which are to be used in the complete document have to be loaded before the first call of ps_begin_page(). Calling ps_findfont() between pages will make that font available for all following pages.

The name of the afm file must be fontname.afm. If the font shall be embedded the file fontname.pfb containing the font outline must be present as well.

Calling ps_findfont() before the first page requires to output the postscript header which includes the BoundingBox for the whole document. Usually the BoundingBox is set with the first call of ps_begin_page() which now comes after ps_findfont(). Consequently the BoundingBox has not been set and a warning will be issued when ps_findfont() is called. In order to prevent this situation, one should call ps_set_parameter() to set the BoundingBox before ps_findfont() is called.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

fontname

The name of the font.

encoding

ps_findfont() will try to load the file passed in the parameter encoding. Encoding files are of the same syntax as those used by dvips(1). They contain a font encoding vector (which is currently not used but must be present) and a list of extra ligatures to extend the list of ligatures derived from the afm file.

encoding can be null or the empty string if the default encoding (TeXBase1) shall be used.

If the encoding is set to builtin then there will be no reencoding and the font specific encoding will be used. This is very useful with symbol fonts.

embed

If set to a value >0 the font will be embedded into the document. This requires the font outline (.pfb file) to be present.

返回值

Returns the identifier of the font or zero in case of an error. The identifier is a positive number.

参见

  • ps_begin_page() - Start a new page
  • ps_setfont() - Sets font to use for following output


Fetches the full buffer containig the generated PS data

  • ? ps_findfont
  • ps_get_parameter ?
  • PHP Manual
  • PS 函数
  • Fetches the full buffer containig the generated PS data

ps_get_buffer

(PECL ps >= 1.1.0)

ps_get_buffer — Fetches the full buffer containig the generated PS data

说明

ps_get_buffer ( resource $psdoc ) : string

This function is not implemented yet. It will always return an empty string. The idea for a later implementation is to write the contents of the postscript file into an internal buffer if in memory creation is requested, and retrieve the buffer content with this function. Currently, documents created in memory are send to the browser without buffering.

Warning

本函数还未编写文档，仅有参数列表。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

参见

  • ps_open_file() - Opens a file for output


Gets certain parameters

  • ? ps_get_buffer
  • ps_get_value ?
  • PHP Manual
  • PS 函数
  • Gets certain parameters

ps_get_parameter

(PECL ps >= 1.1.0)

ps_get_parameter — Gets certain parameters

说明

ps_get_parameter ( resource $psdoc , string $name , float $modifier = ? ) : string|false

Gets several parameters which were directly set by ps_set_parameter() or indirectly by one of the other functions. Parameters are by definition string values. This function cannot be used to retrieve resources which were also set by ps_set_parameter().

The parameter name can have the following values.

fontname

The name of the currently active font or the font whose identifier is passed in parameter modifier.

fontencoding

The encoding of the currently active font.

dottedversion

The version of the underlying pslib library in the format <major>.<minor>.<subminor>

scope

The current drawing scope. Can be object, document, null, page, pattern, path, template, prolog, font, glyph.

ligaturedisolvechar

The character which dissolves a ligature. If your are using a font which contains the ligature `ff' and `|' is the char to dissolve the ligature, then `f|f' will result in two `f' instead of the ligature `ff'.

imageencoding

The encoding used for encoding images. Can be either hex or 85. hex encoding uses two bytes in the postscript file each byte in the image. 85 stand for Ascii85 encoding.

linenumbermode

Set to paragraph if lines are numbered within a paragraph or box if they are numbered within the surrounding box.

linebreak

Only used if text is output with ps_show_boxed(). If set to true a carriage return will add a line break.

parbreak

Only used if text is output with ps_show_boxed(). If set to true a carriage return will start a new paragraph.

hyphenation

Only used if text is output with ps_show_boxed(). If set to true the paragraph will be hyphenated if a hypen dictionary is set and exists.

hyphendict

Filename of the dictionary used for hyphenation pattern.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the parameter.

modifier

An identifier needed if a parameter of a resource is requested, e.g. the size of an image. In such a case the resource id is passed.

返回值

Returns the value of the parameter 或者在失败时返回 false.

参见

  • ps_set_parameter() - Sets certain parameters


Gets certain values

  • ? ps_get_parameter
  • ps_hyphenate ?
  • PHP Manual
  • PS 函数
  • Gets certain values

ps_get_value

(PECL ps >= 1.1.0)

ps_get_value — Gets certain values

说明

ps_get_value ( resource $psdoc , string $name , float $modifier = ? ) : float

Gets several values which were set by ps_set_value(). Values are by definition float values.

The parameter name can have the following values.

fontsize

The size of the currently active font or the font whose identifier is passed in parameter modifier.

font

The currently active font itself.

imagewidth

The width of the image whose id is passed in the parameter modifier.

imageheight

The height of the image whose id is passed in the parameter modifier.

capheight

The height of a capital M in the currently active font or the font whose identifier is passed in parameter modifier.

ascender

The ascender of the currently active font or the font whose identifier is passed in parameter modifier.

descender

The descender of the currently active font or the font whose identifier is passed in parameter modifier.

italicangle

The italicangle of the currently active font or the font whose identifier is passed in parameter modifier.

underlineposition

The underlineposition of the currently active font or the font whose identifier is passed in parameter modifier.

underlinethickness

The underlinethickness of the currently active font or the font whose identifier is passed in parameter modifier.

textx

The current x-position for text output.

texty

The current y-position for text output.

textrendering

The current mode for text rendering.

textrise

The space by which text is risen above the base line.

leading

The distance between text lines in points.

wordspacing

The space between words as a multiple of the width of a space char.

charspacing

The space between chars. If charspacing is != 0.0 ligatures will always be dissolved.

hyphenminchars

Minimum number of chars hyphenated at the end of a word.

parindent

Indention of the first n line in a paragraph.

numindentlines

Number of line in a paragraph to indent if parindent != 0.0.

parskip

Distance between paragraphs.

linenumberspace

Overall space in front of each line for the line number.

linenumbersep

Space between the line and the line number.

major

The major version number of pslib.

minor

The minor version number of pslib.

subminor, revision

The subminor version number of pslib.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the value.

modifier

The parameter modifier specifies the resource for which the value is to be retrieved. This can be the id of a font or an image.

返回值

Returns the value of the parameter or false.

参见

  • ps_set_value() - Sets certain values


Hyphenates a word

  • ? ps_get_value
  • ps_include_file ?
  • PHP Manual
  • PS 函数
  • Hyphenates a word

ps_hyphenate

(PECL ps >= 1.1.1)

ps_hyphenate — Hyphenates a word

说明

ps_hyphenate ( resource $psdoc , string $text ) : array|false

Hyphenates the passed word. ps_hyphenate() evaluates the value hyphenminchars (set by ps_set_value()) and the parameter hyphendict (set by ps_set_parameter()). hyphendict must be set before calling this function.

This function requires the locale category LC_CTYPE to be set properly. This is done when the extension is initialized by using the environment variables. On Unix systems read the man page of locale for more information.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

text should not contain any non alpha characters. Possible positions for breaks are returned in an array of interger numbers. Each number is the position of the char in text after which a hyphenation can take place.

返回值

An array of integers indicating the position of possible breaks in the text 或者在失败时返回 false.

范例

Example #1 Hyphennate a text

<?php
$word = "Koordinatensystem";
$psdoc = ps_new();
ps_set_parameter($psdoc, "hyphendict", "hyph_de.dic");
$hyphens = ps_hyphenate($psdoc, $word);
for($i=0; $i<strlen($word); $i++) {
  echo $word[$i];
  if(in_array($i, $hyphens))
    echo "-";
}
ps_delete($psdoc);
?>

以上例程会输出：

Ko-ordi-na-ten-sys-tem

参见

  • ps_show_boxed() - Output text in a box
  • locale(1)


Reads an external file with raw PostScript code

  • ? ps_hyphenate
  • ps_lineto ?
  • PHP Manual
  • PS 函数
  • Reads an external file with raw PostScript code

ps_include_file

(PECL ps >= 1.3.4)

ps_include_file — Reads an external file with raw PostScript code

说明

ps_include_file ( resource $psdoc , string $file ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

file

返回值

成功时返回 true， 或者在失败时返回 false。


Draws a line

  • ? ps_include_file
  • ps_makespotcolor ?
  • PHP Manual
  • PS 函数
  • Draws a line

ps_lineto

(PECL ps >= 1.1.0)

ps_lineto — Draws a line

说明

ps_lineto ( resource $psdoc , float $x , float $y ) : bool

Adds a straight line from the current point to the given coordinates to the current path. Use ps_moveto() to set the starting point of the line.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the end point of the line.

y

y-coordinate of the end point of the line.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Drawing a rectangle

<?php
$ps = ps_new();
if (!ps_open_file($ps, "rectangle.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rectangle.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Lineto example");

ps_begin_page($ps, 596, 842);
ps_moveto($ps, 100, 100);
ps_lineto($ps, 100, 200);
ps_lineto($ps, 200, 200);
ps_lineto($ps, 200, 100);
ps_lineto($ps, 100, 100);
ps_stroke($ps);
ps_end_page($ps);

ps_delete($ps);
?>

参见

  • ps_moveto() - Sets current point


Create spot color

  • ? ps_lineto
  • ps_moveto ?
  • PHP Manual
  • PS 函数
  • Create spot color

ps_makespotcolor

(PECL ps >= 1.1.0)

ps_makespotcolor — Create spot color

说明

ps_makespotcolor ( resource $psdoc , string $name , int $reserved = 0 ) : int

Creates a spot color from the current fill color. The fill color must be defined in rgb, cmyk or gray colorspace. The spot color name can be an arbitrary name. A spot color can be set as any color with ps_setcolor(). When the document is not printed but displayed by an postscript viewer the given color in the specified color space is use.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the spot color, e.g. Pantone 5565.

返回值

The id of the new spot color or 0 in case of an error.

范例

Example #1 Creating and using a spot color

<?php
$ps = ps_new();
if (!ps_open_file($ps, "spotcolor.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "spotcolor.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Spot color example");

ps_begin_page($ps, 596, 842);
ps_setcolor($ps, "fill", "cmyk", 0.37, 0.0, 0.34, 0.34);
$spotcolor = ps_makespotcolor($ps, "PANTONE 5565 C", 0);
ps_setcolor($ps, "fill", "spot", $spotcolor, 0.5, 0.0, 0.0);
ps_moveto($ps, 100, 100);
ps_lineto($ps, 100, 200);
ps_lineto($ps, 200, 200);
ps_lineto($ps, 200, 100);
ps_lineto($ps, 100, 100);
ps_fill($ps);
ps_end_page($ps);

ps_delete($ps);
?>

This example creates the spot color "PANTONE 5565 C" which is a darker green (olive) and fills a rectangle with 50% intensity.

参见

  • ps_setcolor() - Sets current color


Sets current point

  • ? ps_makespotcolor
  • ps_new ?
  • PHP Manual
  • PS 函数
  • Sets current point

ps_moveto

(PECL ps >= 1.1.0)

ps_moveto — Sets current point

说明

ps_moveto ( resource $psdoc , float $x , float $y ) : bool

Sets the current point to new coordinates. If this is the first call of ps_moveto() after a previous path has been ended then it will start a new path. If this function is called in the middle of a path it will just set the current point and start a subpath.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the point to move to.

y

y-coordinate of the point to move to.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_lineto() - Draws a line


Creates a new PostScript document object

  • ? ps_moveto
  • ps_open_file ?
  • PHP Manual
  • PS 函数
  • Creates a new PostScript document object

ps_new

(PECL ps >= 1.1.0)

ps_new — Creates a new PostScript document object

说明

ps_new ( ) : resource|false

Creates a new document instance. It does not create the file on disk or in memory, it just sets up everything. ps_new() is usually followed by a call of ps_open_file() to actually create the postscript document.

返回值

Resource of PostScript document 或者在失败时返回 false. The return value is passed to all other functions as the first argument.

参见

  • ps_delete() - Deletes all resources of a PostScript document


Opens a file for output

  • ? ps_new
  • ps_open_image_file ?
  • PHP Manual
  • PS 函数
  • Opens a file for output

ps_open_file

(PECL ps >= 1.1.0)

ps_open_file — Opens a file for output

说明

ps_open_file ( resource $psdoc , string $filename = ? ) : bool

Creates a new file on disk and writes the PostScript document into it. The file will be closed when ps_close() is called.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

filename

The name of the postscript file. If filename is not passed the document will be created in memory and all output will go straight to the browser.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_close() - Closes a PostScript document


Opens image from file

  • ? ps_open_file
  • ps_open_image ?
  • PHP Manual
  • PS 函数
  • Opens image from file

ps_open_image_file

(PECL ps >= 1.1.0)

ps_open_image_file — Opens image from file

说明

ps_open_image_file ( resource $psdoc , string $type , string $filename , string $stringparam = ? , int $intparam = 0 ) : int

Loads an image for later use.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of the image. Possible values are png, jpeg, or eps.

filename

The name of the file containing the image data.

stringparam

Not used.

intparam

Not used.

返回值

Returns identifier of image or zero in case of an error. The identifier is a positive number greater than 0.

参见

  • ps_open_image() - Reads an image for later placement
  • ps_place_image() - Places image on the page
  • ps_close_image() - Closes image and frees memory


Reads an image for later placement

  • ? ps_open_image_file
  • ps_open_memory_image ?
  • PHP Manual
  • PS 函数
  • Reads an image for later placement

ps_open_image

(PECL ps >= 1.1.0)

ps_open_image — Reads an image for later placement

说明

ps_open_image ( resource $psdoc , string $type , string $source , string $data , int $lenght , int $width , int $height , int $components , int $bpc , string $params ) : int

Reads an image which is already available in memory. The parameter source is currently not evaluated and assumed to be memory. The image data is a sequence of pixels starting in th upper left corner and ending in the lower right corner. Each pixel consists of components color components, and each component has bpc bits.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of the image. Possible values are png, jpeg, or eps.

source

Not used.

data

The image data.

length

The length of the image data.

width

The width of the image.

height

The height of the image.

components

The number of components for each pixel. This can be 1 (gray scale images), 3 (rgb images), or 4 (cmyk, rgba images).

bpc

Number of bits per component (quite often 8).

params

返回值

Returns identifier of image or zero in case of an error. The identifier is a positive number greater than 0.

参见

  • ps_open_image_file() - Opens image from file
  • ps_place_image() - Places image on the page
  • ps_close_image() - Closes image and frees memory


Takes an GD image and returns an image for placement in a PS document

  • ? ps_open_image
  • ps_place_image ?
  • PHP Manual
  • PS 函数
  • Takes an GD image and returns an image for placement in a PS document

ps_open_memory_image

(PECL ps >= 1.1.0)

ps_open_memory_image — Takes an GD image and returns an image for placement in a PS document

说明

ps_open_memory_image ( resource $psdoc , int $gd ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

gd


Places image on the page

  • ? ps_open_memory_image
  • ps_rect ?
  • PHP Manual
  • PS 函数
  • Places image on the page

ps_place_image

(PECL ps >= 1.1.0)

ps_place_image — Places image on the page

说明

ps_place_image ( resource $psdoc , int $imageid , float $x , float $y , float $scale ) : bool

Places a formerly loaded image on the page. The image can be scaled. If the image shall be rotated as well, you will have to rotate the coordinate system before with ps_rotate().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

imageid

The resource identifier of the image as returned by ps_open_image() or ps_open_image_file().

x

x-coordinate of the lower left corner of the image.

y

y-coordinate of the lower left corner of the image.

scale

The scaling factor for the image. A scale of 1.0 will result in a resolution of 72 dpi, because each pixel is equivalent to 1 point.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_open_image() - Reads an image for later placement
  • ps_open_image_file() - Opens image from file


Draws a rectangle

  • ? ps_place_image
  • ps_restore ?
  • PHP Manual
  • PS 函数
  • Draws a rectangle

ps_rect

(PECL ps >= 1.1.0)

ps_rect — Draws a rectangle

说明

ps_rect ( resource $psdoc , float $x , float $y , float $width , float $height ) : bool

Draws a rectangle with its lower left corner at (x, y). The rectangle starts and ends in its lower left corner. If this function is called outside a path it will start a new path. If it is called within a path it will add the rectangle as a subpath. If the last drawing operation does not end in the lower left corner then there will be a gap in the path.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the lower left corner of the rectangle.

y

y-coordinate of the lower left corner of the rectangle.

width

The width of the image.

height

The height of the image.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_arc() - Draws an arc counterclockwise
  • ps_cirle()
  • ps_lineto() - Draws a line


Restore previously save context

  • ? ps_rect
  • ps_rotate ?
  • PHP Manual
  • PS 函数
  • Restore previously save context

ps_restore

(PECL ps >= 1.1.0)

ps_restore — Restore previously save context

说明

ps_restore ( resource $psdoc ) : bool

Restores a previously saved graphics context. Any call of ps_save() must be accompanied by a call to ps_restore(). All coordinate transformations, line style settings, color settings, etc. are being restored to the state before the call of ps_save().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_save() - Save current context


Sets rotation factor

  • ? ps_restore
  • ps_save ?
  • PHP Manual
  • PS 函数
  • Sets rotation factor

ps_rotate

(PECL ps >= 1.1.0)

ps_rotate — Sets rotation factor

说明

ps_rotate ( resource $psdoc , float $rot ) : bool

Sets the rotation of the coordinate system.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

rot

Angle of rotation in degree.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Rotation of the coordinate system

<?php
function rectangle($ps) {
    ps_moveto($ps, 0, 0);
    ps_lineto($ps, 0, 50);
    ps_lineto($ps, 50, 50);
    ps_lineto($ps, 50, 0);
    ps_lineto($ps, 0, 0);
    ps_stroke($ps);
}

$ps = ps_new();
if (!ps_open_file($ps, "rotation.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rotation.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Rotation example");
ps_set_info($ps, "BoundingBox", "0 0 596 842");

$psfont = ps_findfont($ps, "Helvetica", "", 0);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_save($ps);
ps_translate($ps, 100, 100);
ps_rotate($ps, 45);
rectangle($ps);
ps_restore($ps);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text without rotation");
ps_end_page($ps);

ps_delete($ps);
?>

The above example illustrates a very common way of rotating a graphic (in this case just a rectangle) by simply rotating the coordinate system. Since the graphic's coordinate system assumes (0,0) to be the origin, the page coordinate system is also translated to place the graphics not on the edge of the page. Pay attention to the order of ps_translate() and ps_rotate(). In the above case the rectancle is rotated around the point (100, 100) in the untranslated coordinate system. Switching the two statements has a completely different result.

In order to output the following text at the original position, all modifications of the coordinate system are encapsulated in ps_save() and ps_restore().

参见

  • ps_scale() - Sets scaling factor
  • ps_translate() - Sets translation


Save current context

  • ? ps_rotate
  • ps_scale ?
  • PHP Manual
  • PS 函数
  • Save current context

ps_save

(PECL ps >= 1.1.0)

ps_save — Save current context

说明

ps_save ( resource $psdoc ) : bool

Saves the current graphics context, containing colors, translation and rotation settings and some more. A saved context can be restored with ps_restore().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_restore() - Restore previously save context


Sets scaling factor

  • ? ps_save
  • ps_set_border_color ?
  • PHP Manual
  • PS 函数
  • Sets scaling factor

ps_scale

(PECL ps >= 1.1.0)

ps_scale — Sets scaling factor

说明

ps_scale ( resource $psdoc , float $x , float $y ) : bool

Sets horizontal and vertical scaling of the coordinate system.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

Scaling factor in horizontal direction.

y

Scaling factor in vertical direction.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_rotate() - Sets rotation factor
  • ps_translate() - Sets translation


Sets color of border for annotations

  • ? ps_scale
  • ps_set_border_dash ?
  • PHP Manual
  • PS 函数
  • Sets color of border for annotations

ps_set_border_color

(PECL ps >= 1.1.0)

ps_set_border_color — Sets color of border for annotations

说明

ps_set_border_color ( resource $psdoc , float $red , float $green , float $blue ) : bool

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the color of the rectangle's border line.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

red

The red component of the border color.

green

The green component of the border color.

blue

The blue component of the border color.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_set_border_dash() - Sets length of dashes for border of annotations
  • ps_set_border_style() - Sets border style of annotations


Sets length of dashes for border of annotations

  • ? ps_set_border_color
  • ps_set_border_style ?
  • PHP Manual
  • PS 函数
  • Sets length of dashes for border of annotations

ps_set_border_dash

(PECL ps >= 1.1.0)

ps_set_border_dash — Sets length of dashes for border of annotations

说明

ps_set_border_dash ( resource $psdoc , float $black , float $white ) : bool

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the length of the black and white portion of a dashed border line.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

black

The length of the dash.

white

The length of the gap between dashes.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_set_border_color() - Sets color of border for annotations
  • ps_set_border_style() - Sets border style of annotations


Sets border style of annotations

  • ? ps_set_border_dash
  • ps_set_info ?
  • PHP Manual
  • PS 函数
  • Sets border style of annotations

ps_set_border_style

(PECL ps >= 1.1.0)

ps_set_border_style — Sets border style of annotations

说明

ps_set_border_style ( resource $psdoc , string $style , float $width ) : bool

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the appearance and width of the border line.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

style

style can be solid or dashed.

width

The line width of the border.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_set_border_color() - Sets color of border for annotations
  • ps_set_border_dash() - Sets length of dashes for border of annotations


Sets information fields of document

  • ? ps_set_border_style
  • ps_set_parameter ?
  • PHP Manual
  • PS 函数
  • Sets information fields of document

ps_set_info

(PECL ps >= 1.1.0)

ps_set_info — Sets information fields of document

说明

ps_set_info ( resource $p , string $key , string $val ) : bool

Sets certain information fields of the document. This fields will be shown as a comment in the header of the PostScript file. If the document is converted to pdf this fields will also be used for the document information.

The BoundingBox is usually set to the value given to the first page. This only works if ps_findfont() has not been called before. In such cases the BoundingBox would be left unset unless you set it explicitly with this function.

This function will have no effect anymore when the header of the postscript file has been already written. It must be called before the first page or the first call of ps_findfont().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

key

The name of the information field to set. The values which can be set are Keywords, Subject, Title, Creator, Author, BoundingBox, and Orientation. Be aware that some of them has a meaning to PostScript viewers.

value

The value of the information field. The field Orientation can be set to either Portrait or Landscape. The BoundingBox is a string consisting of four numbers. The first two numbers are the coordinates of the lower left corner of the page. The last two numbers are the coordinates of the upper right corner.

Note:

Up to version 0.2.6 of pslib, the BoundingBox and Orientation will be overwritten by ps_begin_page(), unless ps_findfont() has been called before.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_findfont() - Loads a font
  • ps_begin_page() - Start a new page


Sets certain parameters

  • ? ps_set_info
  • ps_set_text_pos ?
  • PHP Manual
  • PS 函数
  • Sets certain parameters

ps_set_parameter

(PECL ps >= 1.1.0)

ps_set_parameter — Sets certain parameters

说明

ps_set_parameter ( resource $psdoc , string $name , string $value ) : bool

Sets several parameters which are used by many functions. Parameters are by definition string values.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

For a list of possible names see ps_get_parameter().

value

The value of the parameter.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_get_parameters()
  • ps_set_value() - Sets certain values


Sets position for text output

  • ? ps_set_parameter
  • ps_set_value ?
  • PHP Manual
  • PS 函数
  • Sets position for text output

ps_set_text_pos

(PECL ps >= 1.1.0)

ps_set_text_pos — Sets position for text output

说明

ps_set_text_pos ( resource $psdoc , float $x , float $y ) : bool

Set the position for the next text output. You may alternatively set the x and y value separately by calling ps_set_value() and choosing textx respectively texty as the value name.

If you want to output text at a certain position it is more convenient to use ps_show_xy() instead of setting the text position and calling ps_show().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the new text position.

y

y-coordinate of the new text position.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Placing text at a given position

<?php
$ps = ps_new();
if (!ps_open_file($ps, "text.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rectangle.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Text placement example");

ps_begin_page($ps, 596, 842);
$psfont = ps_findfont($ps, "Helvetica", "", 0);
ps_setfont($ps, $psfont, 8.0);
ps_show_xy($ps, "Some text at (100, 100)", 100, 100);

ps_set_value($ps, "textx", 100);
ps_set_value($ps, "texty", 120);
ps_show($ps, "Some text at (100, 120)");
ps_end_page($ps);

ps_delete($ps);
?>

参见

  • ps_set_value() - Sets certain values
  • ps_show() - Output text


Sets certain values

  • ? ps_set_text_pos
  • ps_setcolor ?
  • PHP Manual
  • PS 函数
  • Sets certain values

ps_set_value

(PECL ps >= 1.1.0)

ps_set_value — Sets certain values

说明

ps_set_value ( resource $psdoc , string $name , float $value ) : bool

Sets several values which are used by many functions. Parameters are by definition float values.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

The name can be one of the following:

textrendering

The way how text is shown.

textx

The x coordinate for text output.

texty

The y coordinate for text output.

wordspacing

The distance between words relative to the width of a space.

leading

The distance between lines in pixels.

value

The value of the parameter.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_get_value() - Gets certain values
  • ps_set_parameter() - Sets certain parameters


Sets current color

  • ? ps_set_value
  • ps_setdash ?
  • PHP Manual
  • PS 函数
  • Sets current color

ps_setcolor

(PECL ps >= 1.1.0)

ps_setcolor — Sets current color

说明

ps_setcolor ( resource $psdoc , string $type , string $colorspace , float $c1 , float $c2 , float $c3 , float $c4 ) : bool

Sets the color for drawing, filling, or both.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The parameter type can be both, fill, or fillstroke.

colorspace

The colorspace should be one of gray, rgb, cmyk, spot, pattern. Depending on the colorspace either only the first, the first three or all parameters will be used.

c1

Depending on the colorspace this is either the red component (rgb), the cyan component (cmyk), the gray value (gray), the identifier of the spot color or the identifier of the pattern.

c2

Depending on the colorspace this is either the green component (rgb), the magenta component (cmyk).

c3

Depending on the colorspace this is either the blue component (rgb), the yellow component (cmyk).

c4

This must only be set in cmyk colorspace and specifies the black component.

Bugs

The second parameter is currently not always evaluated. The color is sometimes set for filling and drawing just as if fillstroke were passed.

返回值

成功时返回 true， 或者在失败时返回 false。


Sets appearance of a dashed line

  • ? ps_setcolor
  • ps_setflat ?
  • PHP Manual
  • PS 函数
  • Sets appearance of a dashed line

ps_setdash

(PECL ps >= 1.1.0)

ps_setdash — Sets appearance of a dashed line

说明

ps_setdash ( resource $psdoc , float $on , float $off ) : bool

Sets the length of the black and white portions of a dashed line.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

on

The length of the dash.

off

The length of the gap between dashes.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_setpolydash() - Sets appearance of a dashed line


Sets flatness

  • ? ps_setdash
  • ps_setfont ?
  • PHP Manual
  • PS 函数
  • Sets flatness

ps_setflat

(PECL ps >= 1.1.0)

ps_setflat — Sets flatness

说明

ps_setflat ( resource $psdoc , float $value ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

value

The value must be between 0.2 and 1.

返回值

成功时返回 true， 或者在失败时返回 false。


Sets font to use for following output

  • ? ps_setflat
  • ps_setgray ?
  • PHP Manual
  • PS 函数
  • Sets font to use for following output

ps_setfont

(PECL ps >= 1.1.0)

ps_setfont — Sets font to use for following output

说明

ps_setfont ( resource $psdoc , int $fontid , float $size ) : bool

Sets a font, which has to be loaded before with ps_findfont(). Outputting text without setting a font results in an error.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

fontid

The font identifier as returned by ps_findfont().

size

The size of the font.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_findfont() - Loads a font
  • ps_set_text_pos() - Sets position for text output for an example.


Sets gray value

  • ? ps_setfont
  • ps_setlinecap ?
  • PHP Manual
  • PS 函数
  • Sets gray value

ps_setgray

(PECL ps >= 1.1.0)

ps_setgray — Sets gray value

说明

ps_setgray ( resource $psdoc , float $gray ) : bool

Sets the gray value for all following drawing operations.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

gray

The value must be between 0 (white) and 1 (black).

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_setcolor() - Sets current color


Sets appearance of line ends

  • ? ps_setgray
  • ps_setlinejoin ?
  • PHP Manual
  • PS 函数
  • Sets appearance of line ends

ps_setlinecap

(PECL ps >= 1.1.0)

ps_setlinecap — Sets appearance of line ends

说明

ps_setlinecap ( resource $psdoc , int $type ) : bool

Sets how line ends look like.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of line ends. Possible values are PS_LINECAP_BUTT, PS_LINECAP_ROUND, or PS_LINECAP_SQUARED.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_setlinejoin() - Sets how contected lines are joined
  • ps_setlinewidth() - Sets width of a line
  • ps_setmiterlimit() - Sets the miter limit


Sets how contected lines are joined

  • ? ps_setlinecap
  • ps_setlinewidth ?
  • PHP Manual
  • PS 函数
  • Sets how contected lines are joined

ps_setlinejoin

(PECL ps >= 1.1.0)

ps_setlinejoin — Sets how contected lines are joined

说明

ps_setlinejoin ( resource $psdoc , int $type ) : bool

Sets how lines are joined.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The way lines are joined. Possible values are PS_LINEJOIN_MITER, PS_LINEJOIN_ROUND, or PS_LINEJOIN_BEVEL.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_setlinecap() - Sets appearance of line ends
  • ps_setlinewidth() - Sets width of a line
  • ps_setmiterlimit() - Sets the miter limit


Sets width of a line

  • ? ps_setlinejoin
  • ps_setmiterlimit ?
  • PHP Manual
  • PS 函数
  • Sets width of a line

ps_setlinewidth

(PECL ps >= 1.1.0)

ps_setlinewidth — Sets width of a line

说明

ps_setlinewidth ( resource $psdoc , float $width ) : bool

Sets the line width for all following drawing operations.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of lines in points.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_setlinecap() - Sets appearance of line ends
  • ps_setlinejoin() - Sets how contected lines are joined
  • ps_setmiterlimit() - Sets the miter limit


Sets the miter limit

  • ? ps_setlinewidth
  • ps_setoverprintmode ?
  • PHP Manual
  • PS 函数
  • Sets the miter limit

ps_setmiterlimit

(PECL ps >= 1.1.0)

ps_setmiterlimit — Sets the miter limit

说明

ps_setmiterlimit ( resource $psdoc , float $value ) : bool

If two lines join in a small angle and the line join is set to PS_LINEJOIN_MITER, then the resulting spike will be very long. The miter limit is the maximum ratio of the miter length (the length of the spike) and the line width.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

value

The maximum ratio between the miter length and the line width. Larger values (> 10) will result in very long spikes when two lines meet in a small angle. Keep the default unless you know what you are doing.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_setlinecap() - Sets appearance of line ends
  • ps_setlinejoin() - Sets how contected lines are joined
  • ps_setlinewidth() - Sets width of a line


Sets overprint mode

  • ? ps_setmiterlimit
  • ps_setpolydash ?
  • PHP Manual
  • PS 函数
  • Sets overprint mode

ps_setoverprintmode

(PECL ps >= 1.3.0)

ps_setoverprintmode — Sets overprint mode

说明

ps_setoverprintmode ( resource $psdoc , int $mode ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

mode

返回值

成功时返回 true， 或者在失败时返回 false。


Sets appearance of a dashed line

  • ? ps_setoverprintmode
  • ps_shading_pattern ?
  • PHP Manual
  • PS 函数
  • Sets appearance of a dashed line

ps_setpolydash

(PECL ps >= 1.1.0)

ps_setpolydash — Sets appearance of a dashed line

说明

ps_setpolydash ( resource $psdoc , float $arr ) : bool

Sets the length of the black and white portions of a dashed line. ps_setpolydash() is used to set more complicated dash patterns.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

arr

arr is a list of length elements alternately for the black and white portion.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Drawing a dashed line

<?php
$ps = ps_new();
if (!ps_open_file($ps, "polydash.ps")) {
   print "Cannot open PostScript file\n";
     exit;
}

ps_set_info($ps, "Creator", "polydash.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Poly dash example");

ps_begin_page($ps, 596, 842);
ps_setpolydash($ps, array(10, 5, 2, 5));
ps_moveto($ps, 100, 100);
ps_lineto($ps, 200, 200);
ps_stroke($ps);
ps_end_page($ps);

ps_delete($ps);
?>

This example draws a line with a 10 and 2 points long line, and gaps of 5 points inbetween.

参见

  • ps_setdash() - Sets appearance of a dashed line


Creates a pattern based on a shading

  • ? ps_setpolydash
  • ps_shading ?
  • PHP Manual
  • PS 函数
  • Creates a pattern based on a shading

ps_shading_pattern

(PECL ps >= 1.3.0)

ps_shading_pattern — Creates a pattern based on a shading

说明

ps_shading_pattern ( resource $psdoc , int $shadingid , string $optlist ) : int|false

Creates a pattern based on a shading, which has to be created before with ps_shading(). Shading patterns can be used like regular patterns.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

shadingid

The identifier of a shading previously created with ps_shading().

optlist

This argument is not currently used.

返回值

The identifier of the pattern 或者在失败时返回 false.

参见

  • ps_shading() - Creates a shading for later use
  • ps_shfill() - Fills an area with a shading


Creates a shading for later use

  • ? ps_shading_pattern
  • ps_shfill ?
  • PHP Manual
  • PS 函数
  • Creates a shading for later use

ps_shading

(PECL ps >= 1.3.0)

ps_shading — Creates a shading for later use

说明

ps_shading ( resource $psdoc , string $type , float $x0 , float $y0 , float $x1 , float $y1 , float $c1 , float $c2 , float $c3 , float $c4 , string $optlist ) : int|false

Creates a shading, which can be used by ps_shfill() or ps_shading_pattern().

The color of the shading can be in any color space except for pattern.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of shading can be either radial or axial. Each shading starts with the current fill color and ends with the given color values passed in the parameters c1 to c4 (see ps_setcolor() for their meaning).

x0, x1, y0, y1

The coordinates x0, y0, x1, y1 are the start and end point of the shading. If the type of shading is radial the two points are the middle points of a starting and ending circle.

c1, c2, c3, c4

See ps_setcolor() for their meaning.

optlist

If the shading is of type radial the optlist must also contain the parameters r0 and r1 with the radius of the start and end circle.

返回值

Returns the identifier of the pattern 或者在失败时返回 false.

参见

  • ps_shading_pattern() - Creates a pattern based on a shading
  • ps_shfill() - Fills an area with a shading


Fills an area with a shading

  • ? ps_shading
  • ps_show_boxed ?
  • PHP Manual
  • PS 函数
  • Fills an area with a shading

ps_shfill

(PECL ps >= 1.3.0)

ps_shfill — Fills an area with a shading

说明

ps_shfill ( resource $psdoc , int $shadingid ) : bool

Fills an area with a shading, which has to be created before with ps_shading(). This is an alternative way to creating a pattern from a shading ps_shading_pattern() and using the pattern as the filling color.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

shadingid

The identifier of a shading previously created with ps_shading().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_shading() - Creates a shading for later use
  • ps_shading_pattern() - Creates a pattern based on a shading


Output text in a box

  • ? ps_shfill
  • ps_show_xy2 ?
  • PHP Manual
  • PS 函数
  • Output text in a box

ps_show_boxed

(PECL ps >= 1.1.0)

ps_show_boxed — Output text in a box

说明

ps_show_boxed ( resource $psdoc , string $text , float $left , float $bottom , float $width , float $height , string $hmode , string $feature = ? ) : int

Outputs a text in a given box. The lower left corner of the box is at (left, bottom). Line breaks will be inserted where needed. Multiple spaces are treated as one. Tabulators are treated as spaces.

The text will be hyphenated if the parameter hyphenation is set to true and the parameter hyphendict contains a valid filename for a hyphenation file. The line spacing is taken from the value leading. Paragraphs can be separated by an empty line just like in TeX. If the value parindent is set to value > 0.0 then the first n lines will be indented. The number n of lines is set by the parameter numindentlines. In order to prevent indenting of the first m paragraphs set the value parindentskip to a positive number.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output into the given box.

left

x-coordinate of the lower left corner of the box.

bottom

y-coordinate of the lower left corner of the box.

width

Width of the box.

height

Height of the box.

hmode

The parameter hmode can be "justify", "fulljustify", "right", "left", or "center". The difference of "justify" and "fulljustify" just affects the last line of the box. In fulljustify mode the last line will be left and right justified unless this is also the last line of paragraph. In justify mode it will always be left justified.

feature

Used parameters

The output of ps_show_boxed() can be configured with several parameters and values which must be set with either ps_set_parameter() or ps_set_value(). Beside the parameters and values which affect text output, the following parameters and values are evaluated.

leading (value)

Distance between baselines of two consecutive lines.

linebreak (parameter)

Set to "true" if you want a carriage return to start a new line instead of treating it as a space. Defaults to "false".

parbreak (parameter)

Set to "true" if you want a carriage return on a single line to start a new paragraph instead of treating it as a space. Defaults to "true".

hyphenation (parameter)

Set to "true" in order to turn hyphenation on. This requires a dictionary to be set with the parameter "hyphendict". Defaults to "false".

hyphendict (parameter)

Filename of the dictionary used for hyphenation pattern (see below).

hyphenminchar (value)

The number of chars which must at least be left over before or after the hyphen. This implies that only words of at least two times this value will be hyphenated. The default value is three. Setting a value of zero will result in the default value.

parindent (value)

Set the amount of space in pixel for indenting the first m lines of a paragraph. m can be set with the value "numindentlines".

parskip (value)

Set the amount of extra space in pixel between paragraphs. Defaults to 0 which will result in a normal line distance.

numindentlines (value)

Number of lines from the start of the paragraph which will be indented. Defaults to 1.

parindentskip (value)

Number of paragraphs in the box whose first lines will not be indented. This defaults to 0. This is useful for paragraphs right after a section heading or text being continued in a second box. In both case one would set this to 1.

linenumbermode (parameter)

Set how lines are to be numbered. Possible values are "box" for numbering lines in the whole box or "paragraph" to number lines within each paragraph.

linenumberspace (value)

The space for the column left of the numbered line containing the line number. The line number will be right justified into this column. Defaults to 20.

linenumbersep (value)

The space between the column with line numbers and the line itself. Defaults to 5.

Hyphenation

Text is hyphenated if the parameter hyphenation is set to true and a valid hyphenation dictionary is set. pslib does not ship its own hyphenation dictionary but uses one from openoffice, scribus or koffice. You can find their dictionaries for different languages in one of the following directories if the software is installed:

  • /usr/share/apps/koffice/hyphdicts/
  • /usr/lib/scribus/dicts/
  • /usr/lib/openoffice/share/dict/ooo/
Currently scribus appears to have the most complete hyphenation dictionaries.

返回值

Number of characters that could not be written.

参见

  • ps_continue_text() - Continue text in next line


Output text at position

  • ? ps_show_boxed
  • ps_show_xy ?
  • PHP Manual
  • PS 函数
  • Output text at position

ps_show_xy2

(PECL ps >= 1.1.0)

ps_show_xy2 — Output text at position

说明

ps_show_xy2 ( resource $psdoc , string $text , int $len , float $xcoor , float $ycoor ) : bool

Warning

本函数还未编写文档，仅有参数列表。

返回值

成功时返回 true， 或者在失败时返回 false。


Output text at given position

  • ? ps_show_xy2
  • ps_show2 ?
  • PHP Manual
  • PS 函数
  • Output text at given position

ps_show_xy

(PECL ps >= 1.1.0)

ps_show_xy — Output text at given position

说明

ps_show_xy ( resource $psdoc , string $text , float $x , float $y ) : bool

Output a text at the given text position.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output.

x

x-coordinate of the lower left corner of the box surrounding the text.

y

y-coordinate of the lower left corner of the box surrounding the text.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_continue_text() - Continue text in next line
  • ps_show() - Output text


Output a text at current position

  • ? ps_show_xy
  • ps_show ?
  • PHP Manual
  • PS 函数
  • Output a text at current position

ps_show2

(PECL ps >= 1.1.0)

ps_show2 — Output a text at current position

说明

ps_show2 ( resource $psdoc , string $text , int $len ) : bool

Output text at the current position. Do not print more than len characters.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output.

len

The maximum number of characters to print.

返回值

成功时返回 true， 或者在失败时返回 false。


Output text

  • ? ps_show2
  • ps_string_geometry ?
  • PHP Manual
  • PS 函数
  • Output text

ps_show

(PECL ps >= 1.1.0)

ps_show — Output text

说明

ps_show ( resource $psdoc , string $text ) : bool

Output a text at the current text position. The text position can be set by storing the x and y coordinates into the values textx and texty with the function ps_set_value(). The function will issue an error if a font was not set before with ps_setfont().

ps_show() evaluates the following parameters and values as set by ps_set_parameter() and ps_set_value().

charspacing (value)

Distance between two consecutive glyphs. If this value is unequal to zero then all ligatures will be resolved. Values less than zero are allowed.

kerning (parameter)

Setting this parameter to "false" will turn off kerning. Kerning is turned on by default.

ligatures (parameter)

Setting this parameter to "false" will turn off the use of ligatures. Ligatures are turned on by default.

underline (parameter)

Setting this parameter to "true" will turn on underlining. Underlining is turned off by default.

overline (parameter)

Setting this parameter to "true" will turn on overlining. Overlining is turned off by default.

strikeout (parameter)

Setting this parameter to "true" will turn on striking out. Striking out is turned off by default.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_continue_text() - Continue text in next line
  • ps_show_xy() - Output text at given position
  • ps_setfont() - Sets font to use for following output


Gets geometry of a string

  • ? ps_show
  • ps_stringwidth ?
  • PHP Manual
  • PS 函数
  • Gets geometry of a string

ps_string_geometry

(PECL ps >= 1.2.0)

ps_string_geometry — Gets geometry of a string

说明

ps_string_geometry ( resource $psdoc , string $text , int $fontid = 0 , float $size = 0.0 ) : array

This function is similar to ps_stringwidth() but returns an array of dimensions containing the width, ascender, and descender of the text.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text for which the geometry is to be calculated.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

返回值

An array of the dimensions of a string. The element 'width' contains the width of the string as returned by ps_stringwidth(). The element 'descender' contains the maximum descender and 'ascender' the maximum ascender of the string.

参见

  • ps_continue_text() - Continue text in next line
  • ps_stringwidth() - Gets width of a string


Gets width of a string

  • ? ps_string_geometry
  • ps_stroke ?
  • PHP Manual
  • PS 函数
  • Gets width of a string

ps_stringwidth

(PECL ps >= 1.1.0)

ps_stringwidth — Gets width of a string

说明

ps_stringwidth ( resource $psdoc , string $text , int $fontid = 0 , float $size = 0.0 ) : float

Calculates the width of a string in points if it was output in the given font and font size. This function needs an Adobe font metrics file to calculate the precise width. If kerning is turned on, it will be taken into account.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text for which the width is to be calculated.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

返回值

Width of a string in points.

参见

  • ps_string_geometry() - Gets geometry of a string


Draws the current path

  • ? ps_stringwidth
  • ps_symbol_name ?
  • PHP Manual
  • PS 函数
  • Draws the current path

ps_stroke

(PECL ps >= 1.1.0)

ps_stroke — Draws the current path

说明

ps_stroke ( resource $psdoc ) : bool

Draws the path constructed with previously called drawing functions like ps_lineto().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_closepath_stroke() - Closes and strokes path
  • ps_fill() - Fills the current path
  • ps_fill_stroke() - Fills and strokes the current path


Gets name of a glyph

  • ? ps_stroke
  • ps_symbol_width ?
  • PHP Manual
  • PS 函数
  • Gets name of a glyph

ps_symbol_name

(PECL ps >= 1.2.0)

ps_symbol_name — Gets name of a glyph

说明

ps_symbol_name ( resource $psdoc , int $ord , int $fontid = 0 ) : string

This function needs an Adobe font metrics file to know which glyphs are available.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The parameter ord is the position of the glyph in the font encoding vector.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

返回值

The name of a glyph in the given font.

参见

  • ps_symbol() - Output a glyph
  • ps_symbol_width() - Gets width of a glyph


Gets width of a glyph

  • ? ps_symbol_name
  • ps_symbol ?
  • PHP Manual
  • PS 函数
  • Gets width of a glyph

ps_symbol_width

(PECL ps >= 1.2.0)

ps_symbol_width — Gets width of a glyph

说明

ps_symbol_width ( resource $psdoc , int $ord , int $fontid = 0 , float $size = 0.0 ) : float

Calculates the width of a glyph in points if it was output in the given font and font size. This function needs an Adobe font metrics file to calculate the precise width.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The position of the glyph in the font encoding vector.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

返回值

The width of a glyph in points.

参见

  • ps_symbol() - Output a glyph
  • ps_symbol_name() - Gets name of a glyph


Output a glyph

  • ? ps_symbol_width
  • ps_translate ?
  • PHP Manual
  • PS 函数
  • Output a glyph

ps_symbol

(PECL ps >= 1.2.0)

ps_symbol — Output a glyph

说明

ps_symbol ( resource $psdoc , int $ord ) : bool

Output the glyph at position ord in the font encoding vector of the current font. The font encoding for a font can be set when loading the font with ps_findfont().

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The position of the glyph in the font encoding vector.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ps_symbol_name() - Gets name of a glyph
  • ps_symbol_width() - Gets width of a glyph


Sets translation

  • ? ps_symbol
  • RpmInfo ?
  • PHP Manual
  • PS 函数
  • Sets translation

ps_translate

(PECL ps >= 1.1.0)

ps_translate — Sets translation

说明

ps_translate ( resource $psdoc , float $x , float $y ) : bool

Sets a new initial point of the coordinate system.

参数

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the origin of the translated coordinate system.

y

y-coordinate of the origin of the translated coordinate system.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Translation of the coordinate system

<?php
function rectangle($ps) {
    ps_moveto($ps, 0, 0);
    ps_lineto($ps, 0, 50);
    ps_lineto($ps, 50, 50);
    ps_lineto($ps, 50, 0);
    ps_lineto($ps, 0, 0);
    ps_stroke($ps);
}

$ps = ps_new();
if (!ps_open_file($ps, "translate.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "translate.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Translated example");
ps_set_info($ps, "BoundingBox", "0 0 596 842");

$psfont = ps_findfont($ps, "Helvetica", "", 0);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_translate($ps, 500, 750);
rectangle($ps);
ps_translate($ps, -500, -750);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text at initial position");
ps_end_page($ps);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_save($ps);
ps_translate($ps, 500, 750);
rectangle($ps);
ps_restore($ps);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text at initial position");
ps_end_page($ps);

ps_delete($ps);
?>

The above example demonstrates two possible ways to place a graphic (in this case just a rectangle) at any position on the page, while the graphic itself uses its own coordinate system. The trick is to change the origin of the current coordinate system before drawing the rectangle. The translation has to be undone after the graphic has been drawn.

On the second page a slightly different and more elegant approach is applied. Instead of undoing the translation with a second call of ps_translate() the graphics context is saved before modifying the coordinate system and restored after drawing the rectangle.

参见

  • ps_scale() - Sets scaling factor
  • ps_rotate() - Sets rotation factor


RpmInfo

  • 简介
  • 安装／配置
    • 需求
    • Installation via PECL
    • 运行时配置
    • 资源类型
  • 预定义常量
  • RpmInfo 函数
    • rpmaddtag — Add tag retrieved in query
    • rpmdbinfo — Get information from installed RPM
    • rpmdbsearch — Search RPM packages
    • rpminfo — Get information from a RPM file
    • rpmvercmp — RPM version comparison


简介

This extension enables you to retrieve information from RPM files or from the installed RPMs database.


安装／配置

Table of Contents

  • 需求
  • Installation via PECL
  • 运行时配置
  • 资源类型


  • ? 安装／配置
  • Installation via PECL ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

This extension requires » librpm version 4.11.3 or higher.


Installation via PECL

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/rpminfo.


  • ? Installation via PECL
  • 资源类型 ?
  • PHP Manual
  • 安装／配置
  • 运行时配置

运行时配置

此扩展没有在 php.ini 中定义配置指令。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

RPMVERSION (string)
System librpm version.
RPMSENSE_ANY (int)
RPMSENSE_LESS (int)
RPMSENSE_GREATER (int)
RPMSENSE_EQUAL (int)
RPMSENSE_POSTTRANS (int)
RPMSENSE_PREREQ (int)
RPMSENSE_PRETRANS (int)
RPMSENSE_INTERP (int)
RPMSENSE_SCRIPT_PRE (int)
RPMSENSE_SCRIPT_POST (int)
RPMSENSE_SCRIPT_PREUN (int)
RPMSENSE_SCRIPT_POSTUN (int)
RPMSENSE_SCRIPT_VERIFY (int)
RPMSENSE_FIND_REQUIRES (int)
RPMSENSE_FIND_PROVIDES (int)
RPMSENSE_TRIGGERIN (int)
RPMSENSE_TRIGGERUN (int)
RPMSENSE_TRIGGERPOSTUN (int)
RPMSENSE_MISSINGOK (int)
RPMSENSE_RPMLIB (int)
RPMSENSE_TRIGGERPREIN (int)
RPMSENSE_KEYRING (int)
RPMSENSE_CONFIG (int)
RPMMIRE_DEFAULT (int)
Search pattern is a regular expression with \., .* and ^...$ added.
RPMMIRE_STRCMP (int)
Search pattern is a string, using strcmp(3).
RPMMIRE_REGEX (int)
Search pattern is a regular expression, using regcomp(3).
RPMMIRE_GLOB (int)
Search pattern is a glob expression, using fnmatch(3).
RPMTAG_ARCH (int)
RPMTAG_ARCHIVESIZE (int)
RPMTAG_BASENAMES (int)
Name (not path) of files, with database index.
RPMTAG_BUGURL (int)
RPMTAG_BUILDARCHS (int)
RPMTAG_BUILDHOST (int)
RPMTAG_BUILDTIME (int)
RPMTAG_C (int)
RPMTAG_CHANGELOGNAME (int)
RPMTAG_CHANGELOGTEXT (int)
RPMTAG_CHANGELOGTIME (int)
RPMTAG_CLASSDICT (int)
RPMTAG_CONFLICTFLAGS (int)
RPMTAG_CONFLICTNAME (int)
Conflicting dependencies, with database index.
RPMTAG_CONFLICTNEVRS (int)
RPMTAG_CONFLICTS (int)
RPMTAG_CONFLICTVERSION (int)
RPMTAG_COOKIE (int)
RPMTAG_DBINSTANCE (int)
RPMTAG_DEPENDSDICT (int)
RPMTAG_DESCRIPTION (int)
RPMTAG_DIRINDEXES (int)
RPMTAG_DIRNAMES (int)
Directory of files, with database index.
RPMTAG_DISTRIBUTION (int)
RPMTAG_DISTTAG (int)
RPMTAG_DISTURL (int)
RPMTAG_DSAHEADER (int)
RPMTAG_E (int)
RPMTAG_ENCODING (int)
RPMTAG_ENHANCEFLAGS (int)
RPMTAG_ENHANCENAME (int)
Weak dependencies, with database index, requires librpm >= 4.13.
RPMTAG_ENHANCENEVRS (int)
RPMTAG_ENHANCES (int)
RPMTAG_ENHANCEVERSION (int)
RPMTAG_EPOCH (int)
RPMTAG_EPOCHNUM (int)
RPMTAG_EVR (int)
RPMTAG_EXCLUDEARCH (int)
RPMTAG_EXCLUDEOS (int)
RPMTAG_EXCLUSIVEARCH (int)
RPMTAG_EXCLUSIVEOS (int)
RPMTAG_FILECAPS (int)
RPMTAG_FILECLASS (int)
RPMTAG_FILECOLORS (int)
RPMTAG_FILECONTEXTS (int)
RPMTAG_FILEDEPENDSN (int)
RPMTAG_FILEDEPENDSX (int)
RPMTAG_FILEDEVICES (int)
RPMTAG_FILEDIGESTALGO (int)
RPMTAG_FILEDIGESTS (int)
RPMTAG_FILEFLAGS (int)
RPMTAG_FILEGROUPNAME (int)
RPMTAG_FILEINODES (int)
RPMTAG_FILELANGS (int)
RPMTAG_FILELINKTOS (int)
RPMTAG_FILEMD5S (int)
RPMTAG_FILEMODES (int)
RPMTAG_FILEMTIMES (int)
RPMTAG_FILENAMES (int)
RPMTAG_FILENLINKS (int)
RPMTAG_FILEPROVIDE (int)
RPMTAG_FILERDEVS (int)
RPMTAG_FILEREQUIRE (int)
RPMTAG_FILESIGNATURELENGTH (int)
RPMTAG_FILESIGNATURES (int)
RPMTAG_FILESIZES (int)
RPMTAG_FILESTATES (int)
RPMTAG_FILETRIGGERCONDS (int)
RPMTAG_FILETRIGGERFLAGS (int)
RPMTAG_FILETRIGGERINDEX (int)
RPMTAG_FILETRIGGERNAME (int)
File trigger name, with database index, requires librpm >= 4.13.
RPMTAG_FILETRIGGERPRIORITIES (int)
RPMTAG_FILETRIGGERSCRIPTFLAGS (int)
RPMTAG_FILETRIGGERSCRIPTPROG (int)
RPMTAG_FILETRIGGERSCRIPTS (int)
RPMTAG_FILETRIGGERTYPE (int)
RPMTAG_FILETRIGGERVERSION (int)
RPMTAG_FILEUSERNAME (int)
RPMTAG_FILEVERIFYFLAGS (int)
RPMTAG_FSCONTEXTS (int)
RPMTAG_GIF (int)
RPMTAG_GROUP (int)
Group of the package, with database index.
RPMTAG_HDRID (int)
RPMTAG_HEADERCOLOR (int)
RPMTAG_HEADERI18NTABLE (int)
RPMTAG_HEADERIMAGE (int)
RPMTAG_HEADERIMMUTABLE (int)
RPMTAG_HEADERREGIONS (int)
RPMTAG_HEADERSIGNATURES (int)
RPMTAG_ICON (int)
RPMTAG_INSTALLCOLOR (int)
RPMTAG_INSTALLTID (int)
Installation transaction ID, with database index.
RPMTAG_INSTALLTIME (int)
RPMTAG_INSTFILENAMES (int)
Path of files, with database index.
RPMTAG_INSTPREFIXES (int)
RPMTAG_LICENSE (int)
RPMTAG_LONGARCHIVESIZE (int)
RPMTAG_LONGFILESIZES (int)
RPMTAG_LONGSIGSIZE (int)
RPMTAG_LONGSIZE (int)
RPMTAG_MODULARITYLABEL (int)
RPMTAG_N (int)
RPMTAG_NAME (int)
Package name, with database index.
RPMTAG_NEVR (int)
RPMTAG_NEVRA (int)
RPMTAG_NOPATCH (int)
RPMTAG_NOSOURCE (int)
RPMTAG_NVR (int)
RPMTAG_NVRA (int)
RPMTAG_O (int)
RPMTAG_OBSOLETEFLAGS (int)
RPMTAG_OBSOLETENAME (int)
Obsoleted packages, with database index.
RPMTAG_OBSOLETENEVRS (int)
RPMTAG_OBSOLETES (int)
RPMTAG_OBSOLETEVERSION (int)
RPMTAG_OLDENHANCES (int)
RPMTAG_OLDENHANCESFLAGS (int)
RPMTAG_OLDENHANCESNAME (int)
RPMTAG_OLDENHANCESVERSION (int)
RPMTAG_OLDFILENAMES (int)
RPMTAG_OLDSUGGESTS (int)
RPMTAG_OLDSUGGESTSFLAGS (int)
RPMTAG_OLDSUGGESTSNAME (int)
RPMTAG_OLDSUGGESTSVERSION (int)
RPMTAG_OPTFLAGS (int)
RPMTAG_ORDERFLAGS (int)
RPMTAG_ORDERNAME (int)
RPMTAG_ORDERVERSION (int)
RPMTAG_ORIGBASENAMES (int)
RPMTAG_ORIGDIRINDEXES (int)
RPMTAG_ORIGDIRNAMES (int)
RPMTAG_ORIGFILENAMES (int)
RPMTAG_OS (int)
RPMTAG_P (int)
RPMTAG_PACKAGER (int)
RPMTAG_PATCH (int)
RPMTAG_PATCHESFLAGS (int)
RPMTAG_PATCHESNAME (int)
RPMTAG_PATCHESVERSION (int)
RPMTAG_PAYLOADCOMPRESSOR (int)
RPMTAG_PAYLOADDIGEST (int)
RPMTAG_PAYLOADDIGESTALT (int)
Since librpm >= 4.16.
RPMTAG_PAYLOADDIGESTALGO (int)
RPMTAG_PAYLOADFLAGS (int)
RPMTAG_PAYLOADFORMAT (int)
RPMTAG_PKGID (int)
RPMTAG_PLATFORM (int)
RPMTAG_POLICIES (int)
RPMTAG_POLICYFLAGS (int)
RPMTAG_POLICYNAMES (int)
RPMTAG_POLICYTYPES (int)
RPMTAG_POLICYTYPESINDEXES (int)
RPMTAG_POSTIN (int)
RPMTAG_POSTINFLAGS (int)
RPMTAG_POSTINPROG (int)
RPMTAG_POSTTRANS (int)
RPMTAG_POSTTRANSFLAGS (int)
RPMTAG_POSTTRANSPROG (int)
RPMTAG_POSTUN (int)
RPMTAG_POSTUNFLAGS (int)
RPMTAG_POSTUNPROG (int)
RPMTAG_PREFIXES (int)
RPMTAG_PREIN (int)
RPMTAG_PREINFLAGS (int)
RPMTAG_PREINPROG (int)
RPMTAG_PRETRANS (int)
RPMTAG_PRETRANSFLAGS (int)
RPMTAG_PRETRANSPROG (int)
RPMTAG_PREUN (int)
RPMTAG_PREUNFLAGS (int)
RPMTAG_PREUNPROG (int)
RPMTAG_PROVIDEFLAGS (int)
RPMTAG_PROVIDENAME (int)
Provided dependencies, with database index.
RPMTAG_PROVIDENEVRS (int)
RPMTAG_PROVIDES (int)
RPMTAG_PROVIDEVERSION (int)
RPMTAG_PUBKEYS (int)
RPMTAG_R (int)
RPMTAG_RECOMMENDFLAGS (int)
RPMTAG_RECOMMENDNAME (int)
Recommended weak dependencies, with database index, requires librpm >= 4.13.
RPMTAG_RECOMMENDNEVRS (int)
RPMTAG_RECOMMENDS (int)
RPMTAG_RECOMMENDVERSION (int)
RPMTAG_RECONTEXTS (int)
RPMTAG_RELEASE (int)
RPMTAG_REMOVETID (int)
RPMTAG_REQUIREFLAGS (int)
RPMTAG_REQUIRENAME (int)
Required dependencies, with database index.
RPMTAG_REQUIRENEVRS (int)
RPMTAG_REQUIRES (int)
RPMTAG_REQUIREVERSION (int)
RPMTAG_RPMVERSION (int)
RPMTAG_RSAHEADER (int)
RPMTAG_SHA1HEADER (int)
SHA1 signature, with database index.
RPMTAG_SHA256HEADER (int)
RPMTAG_SIGGPG (int)
RPMTAG_SIGMD5 (int)
MD5 signature, with database index.
RPMTAG_SIGPGP (int)
RPMTAG_SIGSIZE (int)
RPMTAG_SIZE (int)
RPMTAG_SOURCE (int)
RPMTAG_SOURCEPACKAGE (int)
RPMTAG_SOURCEPKGID (int)
RPMTAG_SOURCERPM (int)
RPMTAG_SUGGESTFLAGS (int)
RPMTAG_SUGGESTNAME (int)
Suggested weak dependencies, with database index, requires librpm >= 4.13.
RPMTAG_SUGGESTNEVRS (int)
RPMTAG_SUGGESTS (int)
RPMTAG_SUGGESTVERSION (int)
RPMTAG_SUMMARY (int)
RPMTAG_SUPPLEMENTFLAGS (int)
RPMTAG_SUPPLEMENTNAME (int)
Weak dependencies, with database index, requires librpm >= 4.13.
RPMTAG_SUPPLEMENTNEVRS (int)
RPMTAG_SUPPLEMENTS (int)
RPMTAG_SUPPLEMENTVERSION (int)
RPMTAG_TRANSFILETRIGGERCONDS (int)
RPMTAG_TRANSFILETRIGGERFLAGS (int)
RPMTAG_TRANSFILETRIGGERINDEX (int)
RPMTAG_TRANSFILETRIGGERNAME (int)
Transaction file trigger name, with database index, requires librpm >= 4.13.
RPMTAG_TRANSFILETRIGGERPRIORITIES (int)
RPMTAG_TRANSFILETRIGGERSCRIPTFLAGS (int)
RPMTAG_TRANSFILETRIGGERSCRIPTPROG (int)
RPMTAG_TRANSFILETRIGGERSCRIPTS (int)
RPMTAG_TRANSFILETRIGGERTYPE (int)
RPMTAG_TRANSFILETRIGGERVERSION (int)
RPMTAG_TRIGGERCONDS (int)
RPMTAG_TRIGGERFLAGS (int)
RPMTAG_TRIGGERINDEX (int)
RPMTAG_TRIGGERNAME (int)
Trigger name, with database index.
RPMTAG_TRIGGERSCRIPTFLAGS (int)
RPMTAG_TRIGGERSCRIPTPROG (int)
RPMTAG_TRIGGERSCRIPTS (int)
RPMTAG_TRIGGERTYPE (int)
RPMTAG_TRIGGERVERSION (int)
RPMTAG_URL (int)
RPMTAG_V (int)
RPMTAG_VCS (int)
RPMTAG_VENDOR (int)
RPMTAG_VERBOSE (int)
RPMTAG_VERIFYSCRIPT (int)
RPMTAG_VERIFYSCRIPTFLAGS (int)
RPMTAG_VERIFYSCRIPTPROG (int)
RPMTAG_VERSION (int)
RPMTAG_XPM (int)


RpmInfo 函数

Table of Contents

  • rpmaddtag — Add tag retrieved in query
  • rpmdbinfo — Get information from installed RPM
  • rpmdbsearch — Search RPM packages
  • rpminfo — Get information from a RPM file
  • rpmvercmp — RPM version comparison


Add tag retrieved in query

  • ? RpmInfo 函数
  • rpmdbinfo ?
  • PHP Manual
  • RpmInfo 函数
  • Add tag retrieved in query

rpmaddtag

(PECL rpminfo >= 0.5.0)

rpmaddtag — Add tag retrieved in query

说明

rpmaddtag ( int $tag ) : bool

Add an additional retrieved tag in subsequent queries.

参数

tag

One of RPMTAG_* constant, see the rpminfo constants page.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • rpminfo() - Get information from a RPM file
  • rpmdbinfo() - Get information from installed RPM
  • rpmdbsearch() - Search RPM packages


Get information from installed RPM

  • ? rpmaddtag
  • rpmdbsearch ?
  • PHP Manual
  • RpmInfo 函数
  • Get information from installed RPM

rpmdbinfo

(PECL rpminfo >= 0.2.0)

rpmdbinfo — Get information from installed RPM

说明

rpmdbinfo ( string $nevr , bool $full = false ) : array

Retrieve information about an installed package, from the system RPM database.

参数

nevr

Name with optional epoch, version and release.

full

If true all information headers for the file are retrieved, else only a minimal set.

返回值

An array of array of information or NULL on error.

参见

  • rpmaddtag() - Add tag retrieved in query

范例

Example #1 A rpmdbinfo() example

<?php
rpmaddtag(RPMTAG_INSTALLTIME);
$info = rpmdbinfo("php-pecl-rpminfo");
print_r($info);
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [Name] => php-pecl-rpminfo
            [Version] => 0.4.2
            [Release] => 1.fc31
            [Summary] => RPM information
            [Installtime] => 1586244687
            [Arch] => x86_64
        )
)


Search RPM packages

  • ? rpmdbinfo
  • rpminfo ?
  • PHP Manual
  • RpmInfo 函数
  • Search RPM packages

rpmdbsearch

(PECL rpminfo >= 0.3.0)

rpmdbsearch — Search RPM packages

说明

rpmdbsearch ( string $pattern , int $rpmtag = RPMTAG_NAME , int $rpmmire = -1 , bool $full = false ) : array

Search packages in the system RPM database.

参数

pattern

Value to search for.

rpmtag

Search criterion, one of RPMTAG_* constant, see the rpminfo constants page.

rpmmire

Pattern type, one of RPMMIRE_* constant, see the rpminfo constants page. When < 0 the criterion must equals the value, and database index is used if possible.

full

If true all information headers for the file are retrieved, else only a minimal set.

返回值

An array of array of information or NULL on error.

参见

  • rpmaddtag() - Add tag retrieved in query

范例

Example #1 Searching for the package owning a file

<?php
$info = rpmdbsearch("/usr/bin/php", RPMTAG_INSTFILENAMES);
print_r($info);
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [Name] => php-cli
            [Version] => 7.4.4
            [Release] => 1.fc32
            [Summary] => Command-line interface for PHP
            [Arch] => x86_64
        )

)


Get information from a RPM file

  • ? rpmdbsearch
  • rpmvercmp ?
  • PHP Manual
  • RpmInfo 函数
  • Get information from a RPM file

rpminfo

(PECL rpminfo >= 0.1.0)

rpminfo — Get information from a RPM file

说明

rpminfo ( string $path , bool $full = false , string &$error = ? ) : array

Retrieve information about a local file, a RPM package.

参数

path

Path of the RPM file.

full

If true all information headers for the file are retrieved, else only a minimal set.

error

If provided, will receive the possible error message, and will avoid a runtime warning.

返回值

An array of information or NULL on error.

参见

  • rpmaddtag() - Add tag retrieved in query

范例

Example #1 A rpminfo() example

<?php
rpmaddtag(RPMTAG_BUILDTIME);
$info = rpminfo("./php-pecl-rpminfo-0.4.2-1.el8.remi.7.4.x86_64.rpm");
print_r($info);
?>

以上例程会输出：

Array
(
    [Name] => php-pecl-rpminfo
    [Version] => 0.4.2
    [Release] => 1.el8
    [Summary] => RPM information
    [Buildtime] => 1586244821
    [Arch] => x86_64
)


RPM version comparison

  • ? rpminfo
  • XLSWriter ?
  • PHP Manual
  • RpmInfo 函数
  • RPM version comparison

rpmvercmp

(PECL rpminfo >= 0.1.0)

rpmvercmp — RPM version comparison

说明

rpmvercmp ( string $evr1 , string $evr2 ) : int

Compare 2 RPM versions.

参数

evr1

First epoch:version-release string

evr2

Second epoch:version-release string

返回值

Returns < 0 if evr1 is less than evr2, > 0 if evr1 is greater than evr2, and 0 if they are equal.


XLSWriter

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 资源类型
  • 预定义常量
  • Vtiful\Kernel\Excel — The Vtiful\Kernel\Excel class
    • Vtiful\Kernel\Excel::addSheet — Vtiful\Kernel\Excel addSheet
    • Vtiful\Kernel\Excel::autoFilter — Vtiful\Kernel\Excel autoFilter
    • Vtiful\Kernel\Excel::constMemory — Vtiful\Kernel\Excel constMemory
    • Vtiful\Kernel\Excel::__construct — Vtiful\Kernel\Excel constructor
    • Vtiful\Kernel\Excel::data — Vtiful\Kernel\Excel data
    • Vtiful\Kernel\Excel::fileName — Vtiful\Kernel\Excel fileName
    • Vtiful\Kernel\Excel::getHandle — Vtiful\Kernel\Excel getHandle
    • Vtiful\Kernel\Excel::header — Vtiful\Kernel\Excel header
    • Vtiful\Kernel\Excel::insertFormula — Vtiful\Kernel\Excel insertFormula
    • Vtiful\Kernel\Excel::insertImage — Vtiful\Kernel\Excel insertImage
    • Vtiful\Kernel\Excel::insertText — Vtiful\Kernel\Excel insertText
    • Vtiful\Kernel\Excel::mergeCells — Vtiful\Kernel\Excel mergeCells
    • Vtiful\Kernel\Excel::output — Vtiful\Kernel\Excel output
    • Vtiful\Kernel\Excel::setColumn — Vtiful\Kernel\Excel setColumn
    • Vtiful\Kernel\Excel::setRow — Vtiful\Kernel\Excel setRow
  • Vtiful\Kernel\Format — The Vtiful\Kernel\Format class
    • Vtiful\Kernel\Format::align — Vtiful\Kernel\Format align
    • Vtiful\Kernel\Format::bold — Vtiful\Kernel\Format bold
    • Vtiful\Kernel\Format::italic — Vtiful\Kernel\Format italic
    • Vtiful\Kernel\Format::underline — Vtiful\Kernel\Format underline


  • ? XLSWriter
  • 安装／配置 ?
  • PHP Manual
  • XLSWriter
  • 简介

简介

An efficient and fast xlsx file export extension.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • XLSWriter
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 资源类型


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

XLSWriter requires PHP 7.0 and above.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/xlswriter


资源类型

There is one resource used by the procedural version of the XLSWriter extension: returned by fileName() or \Vtiful\Kernel\Format.


  • ? 资源类型
  • Vtiful\Kernel\Excel ?
  • PHP Manual
  • XLSWriter
  • 预定义常量

预定义常量

此扩展没有定义常量。


The Vtiful\Kernel\Excel class

(PECL xlswriter >= 1.2.1)

简介

Create xlsx files and set cells and output xlsx files

类摘要

Vtiful\Kernel\Excel {
/* 方法 */
public addSheet ( string $sheetName )
public autoFilter ( string $scope )
public constMemory ( string $fileName , string $sheetName = ? )
public __construct ( array $config )
public data ( array $data )
public fileName ( string $fileName , string $sheetName = ? )
public getHandle ( )
public header ( array $headerData )
public insertFormula ( int $row , int $column , string $formula )
public insertImage ( int $row , int $column , string $localImagePath )
public insertText ( int $row , int $column , stringintdouble $data , string $format = ? )
public mergeCells ( string $scope , string $data )
public output ( )
public setColumn ( string $range , float $width , resource $format = ? )
public setRow ( string $range , float $height , resource $format = ? )
}

Table of Contents

  • Vtiful\Kernel\Excel::addSheet — Vtiful\Kernel\Excel addSheet
  • Vtiful\Kernel\Excel::autoFilter — Vtiful\Kernel\Excel autoFilter
  • Vtiful\Kernel\Excel::constMemory — Vtiful\Kernel\Excel constMemory
  • Vtiful\Kernel\Excel::__construct — Vtiful\Kernel\Excel constructor
  • Vtiful\Kernel\Excel::data — Vtiful\Kernel\Excel data
  • Vtiful\Kernel\Excel::fileName — Vtiful\Kernel\Excel fileName
  • Vtiful\Kernel\Excel::getHandle — Vtiful\Kernel\Excel getHandle
  • Vtiful\Kernel\Excel::header — Vtiful\Kernel\Excel header
  • Vtiful\Kernel\Excel::insertFormula — Vtiful\Kernel\Excel insertFormula
  • Vtiful\Kernel\Excel::insertImage — Vtiful\Kernel\Excel insertImage
  • Vtiful\Kernel\Excel::insertText — Vtiful\Kernel\Excel insertText
  • Vtiful\Kernel\Excel::mergeCells — Vtiful\Kernel\Excel mergeCells
  • Vtiful\Kernel\Excel::output — Vtiful\Kernel\Excel output
  • Vtiful\Kernel\Excel::setColumn — Vtiful\Kernel\Excel setColumn
  • Vtiful\Kernel\Excel::setRow — Vtiful\Kernel\Excel setRow


Vtiful\Kernel\Excel addSheet

  • ? Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel::autoFilter ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel addSheet

Vtiful\Kernel\Excel::addSheet

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::addSheet — Vtiful\Kernel\Excel addSheet

说明

public Vtiful\Kernel\Excel::addSheet ( string $sheetName )

Create a new worksheet in the xlsx file.

参数

sheetName

Worksheet name

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age'])
    ->data([
        ['viest', 23],
        ['wjx', 23]
    ]);

$file->addSheet('sheet_two')
    ->header(['name', 'age'])
    ->data([
        ['james', 33],
        ['king', 33]
    ]);

$file->output();
?>


Vtiful\Kernel\Excel autoFilter

  • ? Vtiful\Kernel\Excel::addSheet
  • Vtiful\Kernel\Excel::constMemory ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel autoFilter

Vtiful\Kernel\Excel::autoFilter

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::autoFilter — Vtiful\Kernel\Excel autoFilter

说明

public Vtiful\Kernel\Excel::autoFilter ( string $scope )

Add autofilter to a worksheet.

参数

scope

Cell start and end coordinate string.

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $excel->fileName('test.xlsx')
        ->header(['name', 'age'])
        ->data($data)
        ->autoFilter('A1:B11')  // auto filter
        ->output();
?>


Vtiful\Kernel\Excel constMemory

  • ? Vtiful\Kernel\Excel::autoFilter
  • Vtiful\Kernel\Excel::__construct ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel constMemory

Vtiful\Kernel\Excel::constMemory

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::constMemory — Vtiful\Kernel\Excel constMemory

说明

public Vtiful\Kernel\Excel::constMemory ( string $fileName , string $sheetName = ? )

Write a large file with constant memory usage.

参数

fileName

XLSX file name

sheetName

Worksheet name

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
  'path' => '/home/viest'
];

$fileObject = new \Vtiful\Kernel\Excel($config);

$file = $instance->constMemory('tutorial.xlsx', 'sheet');
?>


Vtiful\Kernel\Excel constructor

  • ? Vtiful\Kernel\Excel::constMemory
  • Vtiful\Kernel\Excel::data ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel constructor

Vtiful\Kernel\Excel::__construct

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::__construct — Vtiful\Kernel\Excel constructor

说明

public Vtiful\Kernel\Excel::__construct ( array $config )

Vtiful\Kernel\Excel constructor, create a class object.

参数

config

XLSX file export configuration

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
  'path' => '/home/viest'
];

$excelObject = new \Vtiful\Kernel\Excel($config);
?>


Vtiful\Kernel\Excel data

  • ? Vtiful\Kernel\Excel::__construct
  • Vtiful\Kernel\Excel::fileName ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel data

Vtiful\Kernel\Excel::data

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::data — Vtiful\Kernel\Excel data

说明

public Vtiful\Kernel\Excel::data ( array $data )

Write a data in the worksheet.

参数

data

worksheet data

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age'])
    ->data([
      ['viest', 23],
      ['wjx', 23],
    ]);
?>


Vtiful\Kernel\Excel fileName

  • ? Vtiful\Kernel\Excel::data
  • Vtiful\Kernel\Excel::getHandle ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel fileName

Vtiful\Kernel\Excel::fileName

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::fileName — Vtiful\Kernel\Excel fileName

说明

public Vtiful\Kernel\Excel::fileName ( string $fileName , string $sheetName = ? )

Create a brand new xlsx file and create a worksheet.

参数

fileName

XLSX file name

sheetName

Worksheet name

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
  'path' => '/home/viest'
];

$fileObject = new \Vtiful\Kernel\Excel($config);

$file = $instance->fileName('tutorial.xlsx', 'sheet');
?>


Vtiful\Kernel\Excel getHandle

  • ? Vtiful\Kernel\Excel::fileName
  • Vtiful\Kernel\Excel::header ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel getHandle

Vtiful\Kernel\Excel::getHandle

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::getHandle — Vtiful\Kernel\Excel getHandle

说明

public Vtiful\Kernel\Excel::getHandle ( )

Get the xlsx text resource handle.

参数

此函数没有参数。

返回值

Resource

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age']);

$handle = $file->getHandle();
?>


Vtiful\Kernel\Excel header

  • ? Vtiful\Kernel\Excel::getHandle
  • Vtiful\Kernel\Excel::insertFormula ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel header

Vtiful\Kernel\Excel::header

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::header — Vtiful\Kernel\Excel header

说明

public Vtiful\Kernel\Excel::header ( array $headerData )

Write a header in the worksheet.

参数

headerData

worksheet header data

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age']);
?>


Vtiful\Kernel\Excel insertFormula

  • ? Vtiful\Kernel\Excel::header
  • Vtiful\Kernel\Excel::insertImage ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel insertFormula

Vtiful\Kernel\Excel::insertFormula

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::insertFormula — Vtiful\Kernel\Excel insertFormula

说明

public Vtiful\Kernel\Excel::insertFormula ( int $row , int $column , string $formula )

Insert calculation formula.

参数

row

cell row

column

cell column

formula

formula string

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel = new \Vtiful\Kernel\Excel($config);

$file = $excel->fileName("free.xlsx")
    ->header(['name', 'money']);

for($index = 1; $index < 10; $index++) {
    $file->insertText($index, 0, 'viest');
    $file->insertText($index, 1, 10);
}

$file->insertText(12, 0, "Total");
$file->insertFormula(12, 1, '=SUM(B2:B11)'); // insert formula

$file->output();


Vtiful\Kernel\Excel insertImage

  • ? Vtiful\Kernel\Excel::insertFormula
  • Vtiful\Kernel\Excel::insertText ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel insertImage

Vtiful\Kernel\Excel::insertImage

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::insertImage — Vtiful\Kernel\Excel insertImage

说明

public Vtiful\Kernel\Excel::insertImage ( int $row , int $column , string $localImagePath )

Insert a local image into the cell.

参数

row

cell row

column

cell column

localImagePath

local image path

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel = new \Vtiful\Kernel\Excel($config);

$file = $excel->fileName("free.xlsx");

$file->insertImage(5, 0, '/vagrant/ASW-G-66.jpg');

$file->output();


Vtiful\Kernel\Excel insertText

  • ? Vtiful\Kernel\Excel::insertImage
  • Vtiful\Kernel\Excel::mergeCells ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel insertText

Vtiful\Kernel\Excel::insertText

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::insertText — Vtiful\Kernel\Excel insertText

说明

public Vtiful\Kernel\Excel::insertText ( int $row , int $column , stringintdouble $data , string $format = ? )

Write text in a cell.

参数

row

cell row

column

cell column

data

data to be written

format

String format

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel = new \Vtiful\Kernel\Excel($config);

$file = $excel->fileName("free.xlsx")
    ->header(['name', 'money']);

for ($index = 0; $index < 10; $index++) {
    $file->insertText($index+1, 0, 'viest');
    $file->insertText($index+1, 1, 10000, '#,##0');
}

$textFile->output();


Vtiful\Kernel\Excel mergeCells

  • ? Vtiful\Kernel\Excel::insertText
  • Vtiful\Kernel\Excel::output ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel mergeCells

Vtiful\Kernel\Excel::mergeCells

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::mergeCells — Vtiful\Kernel\Excel mergeCells

说明

public Vtiful\Kernel\Excel::mergeCells ( string $scope , string $data )

Merge Cells.

参数

scope

cell start and end coordinate strings

data

string data

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel = new \Vtiful\Kernel\Excel($config);

$excel->fileName("test.xlsx")
        ->mergeCells('A1:C1', 'Merge cells')
        ->output();


Vtiful\Kernel\Excel output

  • ? Vtiful\Kernel\Excel::mergeCells
  • Vtiful\Kernel\Excel::setColumn ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel output

Vtiful\Kernel\Excel::output

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::output — Vtiful\Kernel\Excel output

说明

public Vtiful\Kernel\Excel::output ( )

Output xlsx file to disk.

参数

此函数没有参数。

返回值

XLSX file path;

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$fileObject  = new \Vtiful\Kernel\Excel($config);

$file = $fileObject->fileName('tutorial.xlsx', 'sheet_one')
    ->header(['name', 'age'])
    ->data([
      ['viest', 23],
      ['wjx', 23],
    ]);

$path = $file->output();
?>


Vtiful\Kernel\Excel setColumn

  • ? Vtiful\Kernel\Excel::output
  • Vtiful\Kernel\Excel::setRow ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel setColumn

Vtiful\Kernel\Excel::setColumn

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::setColumn — Vtiful\Kernel\Excel setColumn

说明

public Vtiful\Kernel\Excel::setColumn ( string $range , float $width , resource $format = ? )

Set the format of the column.

参数

range

cell start and end coordinate strings

width

column width

format

cell format resource

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$boldStyle = \Vtiful\Kernel\Format::bold($fileHandle);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $boldStyle)
    ->output();


Vtiful\Kernel\Excel setRow

  • ? Vtiful\Kernel\Excel::setColumn
  • Vtiful\Kernel\Format ?
  • PHP Manual
  • Vtiful\Kernel\Excel
  • Vtiful\Kernel\Excel setRow

Vtiful\Kernel\Excel::setRow

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Excel::setRow — Vtiful\Kernel\Excel setRow

说明

public Vtiful\Kernel\Excel::setRow ( string $range , float $height , resource $format = ? )

Set the format of the column.

参数

range

cell start and end coordinate strings

height

row height

format

cell format resource

返回值

Vtiful\Kernel\Excel instance

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$boldStyle = \Vtiful\Kernel\Format::bold($fileHandle);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setRow('A1', 20, $boldStyle,)
    ->output();


The Vtiful\Kernel\Format class

(PECL xlswriter >= 1.2.1)

简介

Create a cell format object

类摘要

Vtiful\Kernel\Format {
/* Constants */
const int FORMAT_ALIGN_LEFT = 1 ;
const int FORMAT_ALIGN_CENTER = 2 ;
const int FORMAT_ALIGN_RIGHT = 3 ;
const int FORMAT_ALIGN_FILL = 4 ;
const int FORMAT_ALIGN_JUSTIFY = 5 ;
const int FORMAT_ALIGN_CENTER_ACROSS = 6 ;
const int FORMAT_ALIGN_DISTRIBUTED = 7 ;
const int FORMAT_ALIGN_VERTICAL_TOP = 8 ;
const int FORMAT_ALIGN_VERTICAL_BOTTOM = 9 ;
const int FORMAT_ALIGN_VERTICAL_CENTER = 10 ;
const int FORMAT_ALIGN_VERTICAL_JUSTIFY = 11 ;
const int FORMAT_ALIGN_VERTICAL_DISTRIBUTED = 12 ;
const int UNDERLINE_SINGLE = 1 ;
const int UNDERLINE_DOUBLE = 2 ;
const int UNDERLINE_SINGLE_ACCOUNTING = 3 ;
const int UNDERLINE_DOUBLE_ACCOUNTING = 4 ;
/* 方法 */
public align ( resource $handle , int $style )
public bold ( resource $handle )
public italic ( resource $handle )
public underline ( resource $handle , int $style )
}

预定义常量

Vtiful\Kernel\Format::FORMAT_ALIGN_LEFT

Vtiful\Kernel\Format::FORMAT_ALIGN_CENTER

Vtiful\Kernel\Format::FORMAT_ALIGN_RIGHT

Vtiful\Kernel\Format::FORMAT_ALIGN_FILL

Vtiful\Kernel\Format::FORMAT_ALIGN_JUSTIFY

Vtiful\Kernel\Format::FORMAT_ALIGN_CENTER_ACROSS

Vtiful\Kernel\Format::FORMAT_ALIGN_DISTRIBUTED

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_TOP

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_BOTTOM

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_CENTER

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_JUSTIFY

Vtiful\Kernel\Format::FORMAT_ALIGN_VERTICAL_DISTRIBUTED

Vtiful\Kernel\Format::UNDERLINE_SINGLE

Vtiful\Kernel\Format::UNDERLINE_DOUBLE

Vtiful\Kernel\Format::UNDERLINE_SINGLE_ACCOUNTING

Vtiful\Kernel\Format::UNDERLINE_DOUBLE_ACCOUNTING

Table of Contents

  • Vtiful\Kernel\Format::align — Vtiful\Kernel\Format align
  • Vtiful\Kernel\Format::bold — Vtiful\Kernel\Format bold
  • Vtiful\Kernel\Format::italic — Vtiful\Kernel\Format italic
  • Vtiful\Kernel\Format::underline — Vtiful\Kernel\Format underline


Vtiful\Kernel\Format align

  • ? Vtiful\Kernel\Format
  • Vtiful\Kernel\Format::bold ?
  • PHP Manual
  • Vtiful\Kernel\Format
  • Vtiful\Kernel\Format align

Vtiful\Kernel\Format::align

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Format::align — Vtiful\Kernel\Format align

说明

public Vtiful\Kernel\Format::align ( resource $handle , int $style )

set cell align

参数

handle

xlsx file handle

style

Vtiful\Kernel\Format constant

返回值

Resource

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$alignStyle = \Vtiful\Kernel\Format::align($fileHandle, \Vtiful\Kernel\Format::FORMAT_ALIGN_LEFT);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $align)
    ->output();
?>


Vtiful\Kernel\Format bold

  • ? Vtiful\Kernel\Format::align
  • Vtiful\Kernel\Format::italic ?
  • PHP Manual
  • Vtiful\Kernel\Format
  • Vtiful\Kernel\Format bold

Vtiful\Kernel\Format::bold

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Format::bold — Vtiful\Kernel\Format bold

说明

public Vtiful\Kernel\Format::bold ( resource $handle )

Vtiful\Kernel\Format bold format

参数

handle

xlsx file handle

返回值

Resource

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$boldStyle = \Vtiful\Kernel\Format::bold($fileHandle);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $boldStyle)
    ->output();
?>


Vtiful\Kernel\Format italic

  • ? Vtiful\Kernel\Format::bold
  • Vtiful\Kernel\Format::underline ?
  • PHP Manual
  • Vtiful\Kernel\Format
  • Vtiful\Kernel\Format italic

Vtiful\Kernel\Format::italic

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Format::italic — Vtiful\Kernel\Format italic

说明

public Vtiful\Kernel\Format::italic ( resource $handle )

Vtiful\Kernel\Format italic format

参数

handle

xlsx file handle

返回值

Resource

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$italicStyle = \Vtiful\Kernel\Format::italic($fileHandle);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $italicStyle)
    ->output();
?>


Vtiful\Kernel\Format underline

  • ? Vtiful\Kernel\Format::italic
  • 进程控制扩展 ?
  • PHP Manual
  • Vtiful\Kernel\Format
  • Vtiful\Kernel\Format underline

Vtiful\Kernel\Format::underline

(PECL xlswriter >= 1.2.1)

Vtiful\Kernel\Format::underline — Vtiful\Kernel\Format underline

说明

public Vtiful\Kernel\Format::underline ( resource $handle , int $style )

Vtiful\Kernel\Format underline format

参数

handle

xlsx file handle

style

Vtiful\Kernel\Format constant

返回值

Resource

范例

Example #1 example

<?php
$config = [
    'path' => './tests'
];

$excel  = new \Vtiful\Kernel\Excel($config);

$fileObject = $excel->fileName('tutorial01.xlsx');
$fileHandle = $fileObject->getHandle();

$underlineStyle = \Vtiful\Kernel\Format::underline($fileHandle, \Vtiful\Kernel\Format::UNDERLINE_SINGLE);

$fileObject->header(['name', 'age'])
    ->data([['viest', 21]])
    ->setColumn('A:A', 200, $underlineStyle)
    ->output();
?>


进程控制扩展

  • Eio
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Eio 函数
  • Ev
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Watchers
    • Watcher callbacks
    • Periodic watcher operation modes
    • Ev — The Ev class
    • EvCheck — The EvCheck class
    • EvChild — The EvChild class
    • EvEmbed — The EvEmbed class
    • EvFork — The EvFork class
    • EvIdle — The EvIdle class
    • EvIo — The EvIo class
    • EvLoop — The EvLoop class
    • EvPeriodic — The EvPeriodic class
    • EvPrepare — The EvPrepare class
    • EvSignal — The EvSignal class
    • EvStat — The EvStat class
    • EvTimer — The EvTimer class
    • EvWatcher — The EvWatcher class
  • Expect
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Expect 函数
  • PCNTL — 进程控制
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • PCNTL 函数
  • POSIX
    • 简介
    • 安装／配置
    • 预定义常量
    • POSIX 函数
  • 程序执行 — 系统程序执行
    • 简介
    • 安装／配置
    • 预定义常量
    • 程序执行函数
  • parallel
    • 简介
    • Installation
    • Philosophy
    • Functional API
    • parallel\Runtime — The parallel\Runtime class
    • parallel\Future — The parallel\Future class
    • parallel\Channel — The parallel\Channel class
    • parallel\Events — The parallel\Events class
    • parallel\Events\Input — The parallel\Events\Input class
    • parallel\Events\Event — The parallel\Events\Event class
    • parallel\Events\Event\Type — The parallel\Events\Event\Type class
    • parallel\Sync — The parallel\Sync class
  • pthreads
    • 简介
    • 安装／配置
    • 预定义常量
    • Threaded — Threaded 类
    • Thread — Thread 类
    • Worker — Worker 类
    • Collectable — The Collectable interface
    • Modifiers — 方法修饰符
    • Pool — Pool 类
    • Mutex — Mutex 类
    • Cond — Cond 类
    • Volatile — The Volatile class
  • pht
    • 简介
    • 安装／配置
    • pht\Thread — The Thread class
    • pht\Runnable — The Runnable interface
    • pht\HashTable — The HashTable class
    • pht\Vector — The Vector class
    • pht\Queue — The Queue class
    • pht\AtomicInteger — The AtomicInteger class
    • pht\Threaded — The Threaded interface
  • Semaphore — Semaphore, Shared Memory and IPC
    • 简介
    • 安装／配置
    • 预定义常量
    • Semaphore 函数
  • Shared Memory
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Shared Memory 函数
    • Shmop — The Shmop class
  • Sync
    • 简介
    • 安装／配置
    • 预定义常量
    • SyncMutex — The SyncMutex class
    • SyncSemaphore — The SyncSemaphore class
    • SyncEvent — The SyncEvent class
    • SyncReaderWriter — The SyncReaderWriter class
    • SyncSharedMemory — The SyncSharedMemory class


Eio

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Eio 函数
    • eio_busy — Artificially increase load. Could be useful in tests, benchmarking
    • eio_cancel — Cancels a request
    • eio_chmod — Change file/directory permissions
    • eio_chown — Change file/directory permissions
    • eio_close — Close file
    • eio_custom — Execute custom request like any other eio_* call
    • eio_dup2 — Duplicate a file descriptor
    • eio_event_loop — Polls libeio until all requests proceeded
    • eio_fallocate — Allows the caller to directly manipulate the allocated disk space for a file
    • eio_fchmod — Change file permissions
    • eio_fchown — Change file ownership
    • eio_fdatasync — Synchronize a file's in-core state with storage device
    • eio_fstat — Get file status
    • eio_fstatvfs — Get file system statistics
    • eio_fsync — Synchronize a file's in-core state with storage device
    • eio_ftruncate — Truncate a file
    • eio_futime — Change file last access and modification times
    • eio_get_event_stream — Get stream representing a variable used in internal communications with libeio
    • eio_get_last_error — Returns string describing the last error associated with a request resource
    • eio_grp_add — Adds a request to the request group
    • eio_grp_cancel — Cancels a request group
    • eio_grp_limit — Set group limit
    • eio_grp — Creates a request group
    • eio_init — (Re-)initialize Eio
    • eio_link — Create a hardlink for file
    • eio_lstat — Get file status
    • eio_mkdir — Create directory
    • eio_mknod — Create a special or ordinary file
    • eio_nop — Does nothing, except go through the whole request cycle
    • eio_npending — Returns number of finished, but unhandled requests
    • eio_nready — Returns number of not-yet handled requests
    • eio_nreqs — Returns number of requests to be processed
    • eio_nthreads — Returns number of threads currently in use
    • eio_open — Opens a file
    • eio_poll — Can be to be called whenever there are pending requests that need finishing
    • eio_read — Read from a file descriptor at given offset
    • eio_readahead — Perform file readahead into page cache
    • eio_readdir — Reads through a whole directory
    • eio_readlink — Read value of a symbolic link
    • eio_realpath — Get the canonicalized absolute pathname
    • eio_rename — Change the name or location of a file
    • eio_rmdir — Remove a directory
    • eio_seek — Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence
    • eio_sendfile — Transfer data between file descriptors
    • eio_set_max_idle — Set maximum number of idle threads
    • eio_set_max_parallel — Set maximum parallel threads
    • eio_set_max_poll_reqs — Set maximum number of requests processed in a poll
    • eio_set_max_poll_time — Set maximum poll time
    • eio_set_min_parallel — Set minimum parallel thread number
    • eio_stat — Get file status
    • eio_statvfs — Get file system statistics
    • eio_symlink — Create a symbolic link
    • eio_sync_file_range — Sync a file segment with disk
    • eio_sync — Commit buffer cache to disk
    • eio_syncfs — Calls Linux' syncfs syscall, if available
    • eio_truncate — Truncate a file
    • eio_unlink — Delete a name and possibly the file it refers to
    • eio_utime — Change file last access and modification times
    • eio_write — Write to file


简介

This extension provides asyncronous POSIX I/O by means of » libeio C library written by Marc Lehmann.

Note: 此扩展在 Windows 平台上不可用。

Warning

It is important to be aware that each request is executed in a thread, and the order of execution of continuously queued requests basically is unpredictable. For instance, the following piece of code is incorrect.

Example #1 Incorrect requests

<?php
// Request to create symlink of $filename to $link
eio_symlink($filename, $link);

// Request to move $filename to $new_filename
eio_rename($filename, $new_filename);

// Process requests
eio_event_loop();
?>
In the example above eio_rename() request may finish before eio_symlink(). To fix it you might call eio_rename() in the callback of eio_symlink():

Example #2 Calling request from a request callback

<?php
function my_symlink_done($filename, $result) {
 // Request to move $filename to $new_filename
 eio_rename($filename, "/path/to/new-name");

 // Process requests
 eio_event_loop();
}

// Request to create symlink of $filename to $link
eio_symlink($filename, $link, EIO_PRI_DEFAULT, "my_symlink_done", $filename);

// Process requests
eio_event_loop();
?>
Alternatively, you might want to create a request group:

Example #3 Calling request from a request callback

<?php
/* Is called when the group requests are done */
function my_grp_done($data, $result) {
 // ...
}

function my_symlink_done($filename, $result) {
 // Create eio_rename request and add it to the group
 $req = eio_rename($filename, "/path/to/new-name");
 eio_grp_add($grp, $req);
 // You might want to add more requests...
}

// Create a request group
$grp = eio_grp("my_grp_done", "my_grp_data");

// Create eio_symlink request and add it to the group
// Pass $filename to the callback
$req = eio_symlink($filename, $link,
  EIO_PRI_DEFAULT, "my_symlink_done", $filename);
eio_grp_add($grp, $req);

// Process requests
eio_event_loop();
?>
Group is a special kind of request that could accumulate a set of regular eio requests. This could be used to create a complex request that opens, reads and closes a file.

Since version 0.3.0 alpha, a variable used in communications with libeio internally, could be retrieved with eio_get_event_stream(). The variable could be used to bind to an event loop supported by some other extension. You might organize a simple event loop where eio and libevent work together:

Example #4 Using eio with libevent

<?php
function my_eio_poll($fd, $events, $arg) {
    /* Some libevent regulation might go here .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. and here */
}

function my_res_cb($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$event = event_new();

// This stream is used to bind with libevent
$fd = eio_get_event_stream();

eio_nop(EIO_PRI_DEFAULT, "my_res_cb", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "my_res_cb", "mkdir data");
/* some other eio_* calls here ... */

// set event flags
event_set($event, $fd, EV_READ /*| EV_PERSIST*/, "my_eio_poll", array($event, $base));

// set event base
event_base_set($event, $base);

// enable event
event_add($event);

// start event loop
event_base_loop($base);

/* The same will be available via buffered libevent interface */
?>


需求

This extension has » libeio library embedded. So you do NOT need to install libeio separately.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/eio.

For information about manual installation, please read the file INSTALL included in the package.


资源类型

There are two resource types in this extension: request and request group.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Request priority constants:

EIO_PRI_MIN (int)
Request minimal prioriry
EIO_PRI_DEFAULT (int)
Request default prioriry
EIO_PRI_MAX (int)
Request maximal prioriry

eio_seek() whence argument:

EIO_SEEK_SET (int)
The offset is set to specified number of bytes(offset).
EIO_SEEK_CUR (int)
The offset is set to its current location plus offset bytes.
EIO_SEEK_END (int)
The offset is set to the size of the file plus offset bytes.

Flags used with eio_readdir():

EIO_READDIR_DENTS (int)
eio_readdir() flag. If specified, the result argument of the callback becomes an array with the following keys: 'names' - array of directory names 'dents' - array of struct eio_dirent-like arrays having the following keys each: 'name' - the directory name; 'type' - one of EIO_DT_* constants; 'inode' - the inode number, if available, otherwise unspecified;
EIO_READDIR_DIRS_FIRST (int)
When this flag is specified, the names will be returned in an order where likely directories come first, in optimal stat order.
EIO_READDIR_STAT_ORDER (int)
When this flag is specified, then the names will be returned in an order suitable for stat'ing each one. When planning to stat() all files in the given directory, the returned order will likely be fastest.
EIO_READDIR_FOUND_UNKNOWN (int)
EIO_DT_UNKNOWN (int)
Unknown node type(very common). Further stat() needed.
EIO_DT_FIFO (int)
FIFO node type
EIO_DT_CHR (int)
Node type
EIO_DT_MPC (int)
Multiplexed char device (v7+coherent) node type
EIO_DT_DIR (int)
Directory node type
EIO_DT_NAM (int)
Xenix special named file node type
EIO_DT_BLK (int)
Node type
EIO_DT_MPB (int)
Multiplexed block device (v7+coherent)
EIO_DT_REG (int)
Node type
EIO_DT_NWK (int)
EIO_DT_CMP (int)
HP-UX network special node type
EIO_DT_LNK (int)
Link node type
EIO_DT_SOCK (int)
Socket node type
EIO_DT_DOOR (int)
Solaris door node type
EIO_DT_WHT (int)
Node type
EIO_DT_MAX (int)
Highest node type value

Access modes for eio_open() flags argument:

EIO_O_RDONLY (int)
EIO_O_WRONLY (int)
EIO_O_RDWR (int)
EIO_O_NONBLOCK (int)
EIO_O_APPEND (int)
EIO_O_CREAT (int)
EIO_O_TRUNC (int)
EIO_O_EXCL (int)
EIO_O_FSYNC (int)

mode argument flags for eio_open():

EIO_S_IRUSR (int)
EIO_S_IWUSR (int)
EIO_S_IXUSR (int)
EIO_S_IRGRP (int)
EIO_S_IWGRP (int)
EIO_S_IXGRP (int)
EIO_S_IROTH (int)
EIO_S_IWOTH (int)
EIO_S_IXOTH (int)
EIO_S_IFREG (int)
EIO_S_IFCHR (int)
EIO_S_IFBLK (int)
EIO_S_IFIFO (int)
EIO_S_IFSOCK (int)

eio_sync_file_range() flags:

EIO_SYNC_FILE_RANGE_WAIT_BEFORE (int)
EIO_SYNC_FILE_RANGE_WRITE (int)
EIO_SYNC_FILE_RANGE_WAIT_AFTER (int)

eio_fallocate() flags:

EIO_FALLOC_FL_KEEP_SIZE (int)

Note:

EIO_S_I* constants have the same meaning as their S_I* POSIX counterparts.

Note:

EIO_SYNC_FILE_* constants have the same meaning as their SYNC_FILE_** counterparts.

Note:

EIO_O_* constants have the same meaning as their O_* POSIX counterparts.


范例

Example #1 Cancelling a request

<?php
 /* Is called when eio_nop() finished */
 function my_nop_cb($data, $result) {
  echo "my_nop ", $data, "\n";
 }

// This eio_nop() call will be cancelled
$req = eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "1");
var_dump($req);
eio_cancel($req);

// This time eio_nop() will be processed
eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "2");

// Process requests
eio_event_loop();
?>

以上例程的输出类似于：

resource(4) of type (EIO Request Descriptor)
my_nop 2

Example #2 Calling eio_chmod()

<?php
$temp_filename = dirname(__FILE__) ."/eio-temp-file.tmp";
touch($temp_filename);

/* Is called when eio_chmod() finished */
function my_chmod_callback($data, $result) {
    global $temp_filename;

    if ($result == 0 && !is_readable($temp_filename) && is_writable($temp_filename)) {
        echo "eio_chmod_ok";
    }

    @unlink($temp_filename);
}

eio_chmod($temp_filename, 0200, EIO_PRI_DEFAULT, "my_chmod_callback");
eio_event_loop();
?>

以上例程的输出类似于：

eio_chmod_ok

Example #3 Making a custom request

<?php
/* Callback for the custom callback */
function my_custom_callback($data, $result) {
    var_dump($data);
    var_dump(count($result));
    var_dump($result['data_modified']);
    var_dump($result['result']);
}

/* The custom request */
function my_custom($data) {
    var_dump($data);

    $result  = array(
        'result'        => 1001,
        'data_modified' => "my custom data",
    );

    return $result;
}

$data = "my_custom_data";
$req = eio_custom("my_custom", EIO_PRI_DEFAULT, "my_custom_callback", $data);
var_dump($req);
eio_event_loop();
?>

以上例程的输出类似于：

resource(4) of type (EIO Request Descriptor)
string(14) "my_custom_data"
string(14) "my_custom_data"
int(2)
string(14) "my custom data"
int(1001)

Example #4 Grouping requests

<?php
/*
 * Create a group request to open, read and close a file
 */

$temp_filename = dirname(__FILE__) ."/eio-file.tmp";
$fp = fopen($temp_filename, "w");
fwrite($fp, "some data");
fclose($fp);

/* Is called when the group requests are done */
function my_grp_done($data, $result) {
 global $temp_filename;
 var_dump($result == 0);
 @unlink($temp_filename);
}

/* Is called when eio_open() done */
function my_grp_file_opened_callback($data, $result) {
 global $my_file_fd, $grp;

 $my_file_fd = $result;

 var_dump($result > 0);

 // Create eio_read() request and add it to the group
 $req = eio_read($my_file_fd, 4, 0, EIO_PRI_DEFAULT, "my_grp_file_read_callback");
 eio_grp_add($grp, $req);
}

/* Is called when eio_read() done */
function my_grp_file_read_callback($data, $result) {
 global $my_file_fd, $grp;

 var_dump($result);

 // Create eio_close() request and add it to the group
 $req = eio_close($my_file_fd);
 eio_grp_add($grp, $req);
}

$grp = eio_grp("my_grp_done", "my_grp_data");

// Create eio_open() request and add it to the group
$req = eio_open($temp_filename, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "my_grp_file_opened_callback", NULL);
eio_grp_add($grp, $req);
var_dump($grp);

eio_event_loop();
?>

以上例程的输出类似于：

resource(6) of type (EIO Group Descriptor)
bool(true)
string(4) "some"
bool(true)

Example #5 Using eio with libevent extension

<?php
function my_eio_poll($fd, $events, $arg) {
    /* Some libevent regulation might go here .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. and here */
}

function my_nop_cb($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$event = event_new();

$fd = eio_get_event_stream();
var_dump($fd);

eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "my_nop_cb", "nop data");
/* some other eio_* calls here ... */

// set event flags
event_set($event, $fd, EV_READ /*| EV_PERSIST*/, "my_eio_poll", array($event, $base));

// set event base
event_base_set($event, $base);

// enable event
event_add($event);

// start event loop
event_base_loop($base);

/* The same will be available via buffered libevent interface */
?>

以上例程的输出类似于：

int(3)
int(0)
string(8) "nop data"
int(0)
string(10) "mkdir data"

Example #6 Using eio with event extension

<?php
$base = new EventBase();

// Retrieve eio polling stream.
// Note, this variable should be alive as long as the event loop is running.
$eio_stream = eio_get_event_stream();

// Bind eio polling stream to the event loop.
$poll_event = new Event($base, $eio_stream, Event::READ, function () {
  if (eio_nreqs()) {
    eio_poll();
  }
});
$poll_event->add();

// Add eio jobs
eio_nop(EIO_PRI_DEFAULT, function () {
  echo "eio_nop\n";
});

// Add events
$timer = Event::timer($base, function () {
  echo "2 seconds elapsed\n";
});
$timer->add(2);

// Dispatch events.
$base->dispatch();
?>

以上例程的输出类似于：

eio_nop
2 seconds elapsed


Eio 函数

Table of Contents

  • eio_busy — Artificially increase load. Could be useful in tests, benchmarking
  • eio_cancel — Cancels a request
  • eio_chmod — Change file/directory permissions
  • eio_chown — Change file/directory permissions
  • eio_close — Close file
  • eio_custom — Execute custom request like any other eio_* call
  • eio_dup2 — Duplicate a file descriptor
  • eio_event_loop — Polls libeio until all requests proceeded
  • eio_fallocate — Allows the caller to directly manipulate the allocated disk space for a file
  • eio_fchmod — Change file permissions
  • eio_fchown — Change file ownership
  • eio_fdatasync — Synchronize a file's in-core state with storage device
  • eio_fstat — Get file status
  • eio_fstatvfs — Get file system statistics
  • eio_fsync — Synchronize a file's in-core state with storage device
  • eio_ftruncate — Truncate a file
  • eio_futime — Change file last access and modification times
  • eio_get_event_stream — Get stream representing a variable used in internal communications with libeio
  • eio_get_last_error — Returns string describing the last error associated with a request resource
  • eio_grp_add — Adds a request to the request group
  • eio_grp_cancel — Cancels a request group
  • eio_grp_limit — Set group limit
  • eio_grp — Creates a request group
  • eio_init — (Re-)initialize Eio
  • eio_link — Create a hardlink for file
  • eio_lstat — Get file status
  • eio_mkdir — Create directory
  • eio_mknod — Create a special or ordinary file
  • eio_nop — Does nothing, except go through the whole request cycle
  • eio_npending — Returns number of finished, but unhandled requests
  • eio_nready — Returns number of not-yet handled requests
  • eio_nreqs — Returns number of requests to be processed
  • eio_nthreads — Returns number of threads currently in use
  • eio_open — Opens a file
  • eio_poll — Can be to be called whenever there are pending requests that need finishing
  • eio_read — Read from a file descriptor at given offset
  • eio_readahead — Perform file readahead into page cache
  • eio_readdir — Reads through a whole directory
  • eio_readlink — Read value of a symbolic link
  • eio_realpath — Get the canonicalized absolute pathname
  • eio_rename — Change the name or location of a file
  • eio_rmdir — Remove a directory
  • eio_seek — Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence
  • eio_sendfile — Transfer data between file descriptors
  • eio_set_max_idle — Set maximum number of idle threads
  • eio_set_max_parallel — Set maximum parallel threads
  • eio_set_max_poll_reqs — Set maximum number of requests processed in a poll
  • eio_set_max_poll_time — Set maximum poll time
  • eio_set_min_parallel — Set minimum parallel thread number
  • eio_stat — Get file status
  • eio_statvfs — Get file system statistics
  • eio_symlink — Create a symbolic link
  • eio_sync_file_range — Sync a file segment with disk
  • eio_sync — Commit buffer cache to disk
  • eio_syncfs — Calls Linux' syncfs syscall, if available
  • eio_truncate — Truncate a file
  • eio_unlink — Delete a name and possibly the file it refers to
  • eio_utime — Change file last access and modification times
  • eio_write — Write to file


Artificially increase load. Could be useful in tests, benchmarking

  • ? Eio 函数
  • eio_cancel ?
  • PHP Manual
  • Eio 函数
  • Artificially increase load. Could be useful in tests, benchmarking

eio_busy

(PECL eio >= 0.0.1dev)

eio_busy — Artificially increase load. Could be useful in tests, benchmarking

说明

eio_busy ( int $delay , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_busy() artificially increases load taking delay seconds to execute. May be used for debugging, or benchmarking.

参数

delay

Delay in seconds

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

This callback is called when all the group requests are done.

data

Arbitrary variable passed to callback.

返回值

eio_busy() returns request resource on success or false on error.

参见

  • eio_nop() - Does nothing, except go through the whole request cycle


Cancels a request

  • ? eio_busy
  • eio_chmod ?
  • PHP Manual
  • Eio 函数
  • Cancels a request

eio_cancel

(PECL eio >= 0.0.1dev)

eio_cancel — Cancels a request

说明

eio_cancel ( resource $req ) : void

eio_cancel() cancels a request specified by req

参数

req

The request resource

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

没有返回值。

范例

Example #1 eio_cancel() example

<?php
 /* Is called when eio_nop() finished */
 function my_nop_cb($data, $result) {
  echo "my_nop ", $data, "\n";
 }

// This eio_nop() call will be cancelled
$req = eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "1");
var_dump($req);
eio_cancel($req);

// This time eio_nop() will be processed
eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "2");

// Process requests
eio_event_loop();
?>

以上例程的输出类似于：

resource(4) of type (EIO Request Descriptor)
my_nop 2

参见

  • eio_grp_cancel() - Cancels a request group


Change file/directory permissions

  • ? eio_cancel
  • eio_chown ?
  • PHP Manual
  • Eio 函数
  • Change file/directory permissions

eio_chmod

(PECL eio >= 0.0.1dev)

eio_chmod — Change file/directory permissions

说明

eio_chmod ( string $path , int $mode , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_chmod() changes file, or directory permissions. The new permissions are specified by mode.

参数

path

Path to the target file or directory

Warning

避免相对路径。

mode

The new permissions. E.g. 0644.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_chmod() returns request resource on success or false on error.

参见

  • eio_chown() - Change file/directory permissions


Change file/directory permissions

  • ? eio_chmod
  • eio_close ?
  • PHP Manual
  • Eio 函数
  • Change file/directory permissions

eio_chown

(PECL eio >= 0.0.1dev)

eio_chown — Change file/directory permissions

说明

eio_chown ( string $path , int $uid , int $gid = -1 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

Changes file, or directory permissions.

参数

path

Path to file or directory.

Warning

避免相对路径。

uid

User ID. Is ignored when equal to -1.

gid

Group ID. Is ignored when equal to -1.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_chown() returns request resource on success or false on error.

参见

  • eio_chmod() - Change file/directory permissions


Close file

  • ? eio_chown
  • eio_custom ?
  • PHP Manual
  • Eio 函数
  • Close file

eio_close

(PECL eio >= 0.0.1dev)

eio_close — Close file

说明

eio_close ( mixed $fd , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_close() closes file specified by fd.

参数

fd

Stream, Socket resource, or numeric file descriptor

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_close() returns request resource on success or false on error.

参见

  • eio_open() - Opens a file


Execute custom request like any other eio_* call

  • ? eio_close
  • eio_dup2 ?
  • PHP Manual
  • Eio 函数
  • Execute custom request like any other eio_* call

eio_custom

(PECL eio >= 0.0.1dev)

eio_custom — Execute custom request like any other eio_* call

说明

eio_custom ( callable $execute , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_custom() executes custom function specified by execute processing it just like any other eio_* call.

参数

execute

Specifies the request function that should match the following prototype:

      mixed execute(mixed data);
callback is event completion callback that should match the following prototype:
      void callback(mixed data, mixed result);
data is the data passed to execute via data argument without modifications result value returned by execute

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_custom() returns request resource on success or false on error.

范例

Example #1 eio_custom() example

<?php
/* Callback for the custom callback */
function my_custom_callback($data, $result) {
    var_dump($data);
    var_dump(count($result));
    var_dump($result['data_modified']);
    var_dump($result['result']);
}

/* The custom request */
function my_custom($data) {
    var_dump($data);

    $result  = array(
        'result'        => 1001,
        'data_modified' => "my custom data",
    );

    return $result;
}

$data = "my_custom_data";
$req = eio_custom("my_custom", EIO_PRI_DEFAULT, "my_custom_callback", $data);
var_dump($req);
eio_event_loop();
?>

以上例程的输出类似于：

resource(4) of type (EIO Request Descriptor)
string(14) "my_custom_data"
string(14) "my_custom_data"
int(2)
string(14) "my custom data"
int(1001)


Duplicate a file descriptor

  • ? eio_custom
  • eio_event_loop ?
  • PHP Manual
  • Eio 函数
  • Duplicate a file descriptor

eio_dup2

(PECL eio >= 0.0.1dev)

eio_dup2 — Duplicate a file descriptor

说明

eio_dup2 ( mixed $fd , mixed $fd2 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_dup2() duplicates file descriptor.

参数

fd

Source stream, Socket resource, or numeric file descriptor

fd2

Target stream, Socket resource, or numeric file descriptor

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_dup2() returns request resource on success or false on error.


Polls libeio until all requests proceeded

  • ? eio_dup2
  • eio_fallocate ?
  • PHP Manual
  • Eio 函数
  • Polls libeio until all requests proceeded

eio_event_loop

(PECL eio >= 0.0.1dev)

eio_event_loop — Polls libeio until all requests proceeded

说明

eio_event_loop ( ) : bool

eio_event_loop() polls libeio until all requests proceeded.

参数

此函数没有参数。

返回值

eio_event_loop() returns true on success or false on error.

范例

Example #1 eio_event_loop() example

<?php
$temp_filename = "eio-temp-file.tmp";
touch($temp_filename);

/* Is called when eio_chmod() finished */
function my_chmod_callback($data, $result) {
    global $temp_filename;

    if ($result == 0 && !is_readable($temp_filename) && is_writable($temp_filename)) {
        echo "eio_chmod_ok";
    }

    @unlink($temp_filename);
}

eio_chmod($temp_filename, 0200, EIO_PRI_DEFAULT, "my_chmod_callback");
eio_event_loop();
?>

以上例程的输出类似于：

eio_chmod_ok

参见

  • eio_poll() - Can be to be called whenever there are pending requests that need finishing


Allows the caller to directly manipulate the allocated disk space for a file

  • ? eio_event_loop
  • eio_fchmod ?
  • PHP Manual
  • Eio 函数
  • Allows the caller to directly manipulate the allocated disk space for a file

eio_fallocate

(PECL eio >= 0.0.1dev)

eio_fallocate — Allows the caller to directly manipulate the allocated disk space for a file

说明

eio_fallocate ( mixed $fd , int $mode , int $offset , int $length , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_fallocate() allows the caller to directly manipulate the allocated disk space for the file specified by fd file descriptor for the byte range starting at offset and continuing for length bytes.

Note: File should be opened for writing

EIO_O_CREAT should be logically OR'd with EIO_O_WRONLY, or EIO_O_RDWR

参数

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open().

mode

Currently only one flag is supported for mode: EIO_FALLOC_FL_KEEP_SIZE (the same as POSIX constant FALLOC_FL_KEEP_SIZE).

offset

Specifies start of the byte range.

length

Specifies length the byte range.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_fallocate() returns request resource on success or false on error.


Change file permissions

  • ? eio_fallocate
  • eio_fchown ?
  • PHP Manual
  • Eio 函数
  • Change file permissions

eio_fchmod

(PECL eio >= 0.0.1dev)

eio_fchmod — Change file permissions

说明

eio_fchmod ( mixed $fd , int $mode , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_fchmod() changes permissions for the file specified by fd file descriptor.

参数

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open().

mode

The new permissions. E.g. 0644.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_fchmod() returns request resource on success or false on error.

参见

  • eio_fchown() - Change file ownership


Change file ownership

  • ? eio_fchmod
  • eio_fdatasync ?
  • PHP Manual
  • Eio 函数
  • Change file ownership

eio_fchown

(PECL eio >= 0.0.1dev)

eio_fchown — Change file ownership

说明

eio_fchown ( mixed $fd , int $uid , int $gid = -1 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_fchown() changes ownership of the file specified by fd file descriptor.

参数

fd

Stream, Socket resource, or numeric file descriptor.

uid

User ID. Is ignored when equal to -1.

gid

Group ID. Is ignored when equal to -1.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

参见

  • eio_fchmod() - Change file permissions


Synchronize a file's in-core state with storage device

  • ? eio_fchown
  • eio_fstat ?
  • PHP Manual
  • Eio 函数
  • Synchronize a file's in-core state with storage device

eio_fdatasync

(PECL eio >= 0.0.1dev)

eio_fdatasync — Synchronize a file's in-core state with storage device

说明

eio_fdatasync ( mixed $fd , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_fdatasync() synchronizes a file's in-core state with storage device.

参数

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open().

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_fdatasync() returns request resource on success or false on error.


Get file status

  • ? eio_fdatasync
  • eio_fstatvfs ?
  • PHP Manual
  • Eio 函数
  • Get file status

eio_fstat

(PECL eio >= 0.0.1dev)

eio_fstat — Get file status

说明

eio_fstat ( mixed $fd , int $pri , callable $callback , mixed $data = ? ) : resource

eio_fstat() returns file status information in result argument of callback

参数

fd

Stream, Socket resource, or numeric file descriptor.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_busy() returns request resource on success or false on error.

范例

Example #1 eio_lstat() example

<?php
// Create temporary file
$tmp_filename = dirname(__FILE__) ."/eio-file.tmp";
touch($tmp_filename);

/* Is called when eio_fstat() done */
function my_res_cb($data, $result) {
 // Should output array with stat info
 var_dump($result);

 if ($data['fd']) {
  // Close temporary file
  eio_close($data['fd']);
  eio_event_loop();
 }
 // Remove temporary file
 @unlink($data['file']);
}

/* Is called when eio_open() done */
function my_open_cb($data, $result) {
 // Prepare data for callback
 $d = array(
  'fd'  => $result,
  'file'=> $data
 );
 // Request stat info
 eio_fstat($result, EIO_PRI_DEFAULT, "my_res_cb", $d);
 // Process request(s)
 eio_event_loop();
}

// Open temporary file
eio_open($tmp_filename, EIO_O_RDONLY, NULL, EIO_PRI_DEFAULT,
  "my_open_cb", $tmp_filename);
eio_event_loop();
?>

以上例程的输出类似于：

array(12) {
 ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2489159)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318239506)
  ["st_mtime"]=>
  int(1318239506)
  ["st_ctime"]=>
  int(1318239506)
}

参见

  • eio_lstat() - Get file status
  • eio_stat() - Get file status


Get file system statistics

  • ? eio_fstat
  • eio_fsync ?
  • PHP Manual
  • Eio 函数
  • Get file system statistics

eio_fstatvfs

(PECL eio >= 0.0.1dev)

eio_fstatvfs — Get file system statistics

说明

eio_fstatvfs ( mixed $fd , int $pri , callable $callback , mixed $data = ? ) : resource

eio_fstatvfs() returns file system statistics in result of callback.

参数

fd

A file descriptor of a file within the mounted file system.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_fstatvfs() returns request resource on success or false on error.

参见

  • eio_statvfs() - Get file system statistics


Synchronize a file's in-core state with storage device

  • ? eio_fstatvfs
  • eio_ftruncate ?
  • PHP Manual
  • Eio 函数
  • Synchronize a file's in-core state with storage device

eio_fsync

(PECL eio >= 0.0.1dev)

eio_fsync — Synchronize a file's in-core state with storage device

说明

eio_fsync ( mixed $fd , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

Synchronize a file's in-core state with storage device

参数

fd

Stream, Socket resource, or numeric file descriptor.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_fsync() returns request resource on success or false on error.

参见

  • eio_sync() - Commit buffer cache to disk


Truncate a file

  • ? eio_fsync
  • eio_futime ?
  • PHP Manual
  • Eio 函数
  • Truncate a file

eio_ftruncate

(PECL eio >= 0.0.1dev)

eio_ftruncate — Truncate a file

说明

eio_ftruncate ( mixed $fd , int $offset = 0 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_ftruncate() causes a regular file referenced by fd file descriptor to be truncated to precisely length bytes.

参数

fd

Stream, Socket resource, or numeric file descriptor.

offset

Offset from beginning of the file

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_ftruncate() returns request resource on success or false on error.

参见

  • eio_truncate() - Truncate a file


Change file last access and modification times

  • ? eio_ftruncate
  • eio_get_event_stream ?
  • PHP Manual
  • Eio 函数
  • Change file last access and modification times

eio_futime

(PECL eio >= 0.0.1dev)

eio_futime — Change file last access and modification times

说明

eio_futime ( mixed $fd , float $atime , float $mtime , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_futime() changes file last access and modification times.

参数

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open()

atime

Access time

mtime

Modification time

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_futime() returns request resource on success or false on error.

参见

  • eio_utime() - Change file last access and modification times


Get stream representing a variable used in internal communications with libeio

  • ? eio_futime
  • eio_get_last_error ?
  • PHP Manual
  • Eio 函数
  • Get stream representing a variable used in internal communications with libeio

eio_get_event_stream

(PECL eio >= 0.3.1b)

eio_get_event_stream — Get stream representing a variable used in internal communications with libeio

说明

eio_get_event_stream ( ) : mixed

eio_get_event_stream() acquires stream representing a variable used in internal communications with libeio. Could be used to bind with some event loop provided by other PECL extension, for example libevent.

参数

此函数没有参数。

返回值

eio_get_event_stream() returns stream on success; otherwise, null

范例

Example #1 Using eio with libevent

<?php
function my_eio_poll($fd, $events, $arg) {
    /* Some libevent regulation might go here .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. and here */
}

function my_res_cb($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$event = event_new();

$fd = eio_get_event_stream();
var_dump($fd);

eio_nop(EIO_PRI_DEFAULT, "my_res_cb", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "my_res_cb", "mkdir data");
/* some other eio_* calls here ... */

// set event flags
event_set($event, $fd, EV_READ /*| EV_PERSIST*/, "my_eio_poll", array($event, $base));

// set event base
event_base_set($event, $base);

// enable event
event_add($event);

// start event loop
event_base_loop($base);

/* The same will be available via buffered libevent interface */
?>

以上例程的输出类似于：

int(3)
int(0)
string(8) "nop data"
int(0)
string(10) "mkdir data"


Returns string describing the last error associated with a request resource

  • ? eio_get_event_stream
  • eio_grp_add ?
  • PHP Manual
  • Eio 函数
  • Returns string describing the last error associated with a request resource

eio_get_last_error

(PECL eio >= 1.0.0)

eio_get_last_error — Returns string describing the last error associated with a request resource

说明

eio_get_last_error ( resource $req ) : string

eio_get_last_error() returns string describing the last error associated with req.

参数

req

The request resource

返回值

eio_get_last_error() returns string describing the last error associated with the request resource specified by req.

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Adds a request to the request group

  • ? eio_get_last_error
  • eio_grp_cancel ?
  • PHP Manual
  • Eio 函数
  • Adds a request to the request group

eio_grp_add

(PECL eio >= 0.0.1dev)

eio_grp_add — Adds a request to the request group

说明

eio_grp_add ( resource $grp , resource $req ) : void

eio_grp_add() adds a request to the request group.

参数

grp

The request group resource returned by eio_grp()

req

The request resource

返回值

eio_grp_add() doesn't return a value.

范例

Example #1 Grouping requests

<?php
/*
 * Create a group request to open, read and close a file
 */

// Create temporary file and write some bytes to it
$temp_filename = dirname(__FILE__) ."/eio-file.tmp";
$fp = fopen($temp_filename, "w");
fwrite($fp, "some data");
fclose($fp);

/* Is called when the group requests are done */
function my_grp_done($data, $result) {
 var_dump($result == 0);
 @unlink($data);
}

/* Is called when eio_open() done */
function my_grp_file_opened_callback($data, $result) {
 global $grp;

 // $result should contain the file descriptor
 var_dump($result > 0);

 // Create eio_read() request and add it to the group
 // Pass file descriptor to the callback
 $req = eio_read($result, 4, 0,
   EIO_PRI_DEFAULT, "my_grp_file_read_callback", $result);
 eio_grp_add($grp, $req);
}

/* Is called when eio_read() done */
function my_grp_file_read_callback($data, $result) {
 global $grp;

 // Read bytes
 var_dump($result);

 // Create eio_close() request and add it to the group
 // $data should contain the file descriptor
 $req = eio_close($data);
 eio_grp_add($grp, $req);
}

// Create request group
$grp = eio_grp("my_grp_done", $temp_filename);
var_dump($grp);

// Create eio_open() request and add it to the group
$req = eio_open($temp_filename, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "my_grp_file_opened_callback", NULL);
eio_grp_add($grp, $req);

// Process requests
eio_event_loop();
?>

以上例程的输出类似于：

resource(6) of type (EIO Group Descriptor)
bool(true)
string(4) "some"
bool(true)

参见

  • eio_grp() - Creates a request group
  • eio_grp_cancel() - Cancels a request group
  • eio_grp_limit() - Set group limit


Cancels a request group

  • ? eio_grp_add
  • eio_grp_limit ?
  • PHP Manual
  • Eio 函数
  • Cancels a request group

eio_grp_cancel

(PECL eio >= 0.0.1dev)

eio_grp_cancel — Cancels a request group

说明

eio_grp_cancel ( resource $grp ) : void

eio_grp_cancel() cancels a group request specified by grp request group resource.

参数

grp

The request group resource returned by eio_grp().

返回值

没有返回值。

参见

  • eio_grp() - Creates a request group
  • eio_grp_add() - Adds a request to the request group


Set group limit

  • ? eio_grp_cancel
  • eio_grp ?
  • PHP Manual
  • Eio 函数
  • Set group limit

eio_grp_limit

(PECL eio >= 0.0.1dev)

eio_grp_limit — Set group limit

说明

eio_grp_limit ( resource $grp , int $limit ) : void

Limit number of requests in the request group.

参数

grp

The request group resource.

limit

Number of requests in the group.

返回值

没有返回值。

参见

  • eio_grp_add() - Adds a request to the request group


Creates a request group

  • ? eio_grp_limit
  • eio_init ?
  • PHP Manual
  • Eio 函数
  • Creates a request group

eio_grp

(PECL eio >= 0.0.1dev)

eio_grp — Creates a request group

说明

eio_grp ( callable $callback , string $data = NULL ) : resource

eio_grp() creates a request group.

参数

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_grp() returns request group resource on success or false on error.

范例

Example #1 eio_grp() example

<?php
$temp_filename = dirname(__FILE__) ."/eio-file.tmp";
$fp = fopen($temp_filename, "w");
fwrite($fp, "some data");
fclose($fp);
$my_file_fd = NULL;

/* Is called when the group requests are done */
function my_grp_done($data, $result) {
 // Remove the file, if it still exists
 @unlink($data);
}

/* Is called when the temporary file is opened */
function my_grp_file_opened_callback($data, $result) {
 global $my_file_fd, $grp;

 $my_file_fd = $result;

 $req = eio_read($my_file_fd, 4, 0,
   EIO_PRI_DEFAULT, "my_grp_file_read_callback");
 eio_grp_add($grp, $req);
}

/* Is called when the file is read */
function my_grp_file_read_callback($data, $result) {
 global $my_file_fd, $grp;

 var_dump($result);

 // Create request to close the file
 $req = eio_close($my_file_fd);

 // Add request to the group
 eio_grp_add($grp, $req);
}

// Create request group
$grp = eio_grp("my_grp_done", $temp_filename);

// Create request
$req = eio_open($temp_filename, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "my_grp_file_opened_callback", NULL);

// Add request to the group
eio_grp_add($grp, $req);

// Process requests
eio_event_loop();
?>

以上例程的输出类似于：

string(4) "some"

参见

  • eio_grp_cancel() - Cancels a request group
  • eio_grp_add() - Adds a request to the request group


(Re-)initialize Eio

  • ? eio_grp
  • eio_link ?
  • PHP Manual
  • Eio 函数
  • (Re-)initialize Eio

eio_init

(PECL eio = 1.0.0)

eio_init — (Re-)initialize Eio

说明

eio_init ( ) : void

eio_init() (re-)initializes Eio. It allocates memory for internal structures of libeio and Eio itself. You may call eio_init() before using Eio functions. Otherwise it will be called internally first time you invoke an Eio function in a process.

Warning

本过时特性将肯定会在未来被移除。 Since Eio 1.1.0 eio_init() is deprecated. In Eio 1.0.0 because of » libeio's restrictions you must call eio_init() in child process, if you fork one by any means. You have to avoid using Eio in parent process, if you use it in childs.

参数

此函数没有参数。

返回值

没有返回值。


Create a hardlink for file

  • ? eio_init
  • eio_lstat ?
  • PHP Manual
  • Eio 函数
  • Create a hardlink for file

eio_link

(PECL eio >= 0.0.1dev)

eio_link — Create a hardlink for file

说明

eio_link ( string $path , string $new_path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_link() creates a hardlink new_path for a file specified by path.

参数

path

Source file path.

new_path

Target file path.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

范例

Example #1 eio_link() example

<?php
$filename = dirname(__FILE__)."/symlink.dat";
touch($filename);
$link = dirname(__FILE__)."/symlink.link";
$hardlink = dirname(__FILE__)."/hardlink.link";

function my_hardlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && !is_link($data));
    @unlink($data);

    eio_symlink($filename, $link, EIO_PRI_DEFAULT, "my_symlink_cb", $link);
}

function my_symlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && is_link($data));

    if (!eio_readlink($data, EIO_PRI_DEFAULT, "my_readlink_cb", NULL)) {
        @unlink($link);
        @unlink($filename);
    }
}

function my_readlink_cb($data, $result) {
    global $filename, $link;
    var_dump($result);

    @unlink($link);
    @unlink($filename);
}

eio_link($filename, $hardlink, EIO_PRI_DEFAULT, "my_hardlink_cb", $hardlink);
eio_event_loop();
?>

以上例程的输出类似于：

bool(true)
bool(true)
string(%d) "%ssymlink.dat"

参见

  • eio_symlink() - Create a symbolic link


Get file status

  • ? eio_link
  • eio_mkdir ?
  • PHP Manual
  • Eio 函数
  • Get file status

eio_lstat

(PECL eio >= 0.0.1dev)

eio_lstat — Get file status

说明

eio_lstat ( string $path , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_lstat() returns file status information in result argument of callback

参数

path

The file path

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_lstat() returns request resource on success or false on error.

范例

Example #1 eio_lstat() example

<?php
$tmp_filename = dirname(__FILE__). "/eio-file.tmp";
touch($tmp_filename);

function my_res_cb($data, $result) {
    var_dump($data);
    var_dump($result);
}

function my_open_cb($data, $result) {
    eio_close($result);
    eio_event_loop();

    @unlink($data);
}

eio_lstat($tmp_filename, EIO_PRI_DEFAULT, "my_res_cb", "eio_lstat");
eio_open($tmp_filename, EIO_O_RDONLY, NULL,
 EIO_PRI_DEFAULT, "my_open_cb", $tmp_filename);
eio_event_loop();
?>

以上例程的输出类似于：

string(9) "eio_lstat"
array(12) {
 ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2099197)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318235777)
  ["st_mtime"]=>
  int(1318235777)
  ["st_ctime"]=>
  int(1318235777)
}

参见

  • eio_stat() - Get file status
  • eio_fstat() - Get file status


Create directory

  • ? eio_lstat
  • eio_mknod ?
  • PHP Manual
  • Eio 函数
  • Create directory

eio_mkdir

(PECL eio >= 0.0.1dev)

eio_mkdir — Create directory

说明

eio_mkdir ( string $path , int $mode , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_mkdir() creates directory with specified access mode.

参数

path

Path for the new directory.

mode

Access mode, e.g. 0755

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_mkdir() returns request resource on success or false on error.

范例

Example #1 eio_mkdir() example

<?php
$temp_dirname = "eio-temp-dir";

/* Is called when eio_mkdir() finishes */
function my_mkdir_callback($data, $result) {
 if ($result == 0 && is_dir($temp_dirname)
   && !is_readable($temp_dirname)
   && is_writable($temp_dirname)) {
  echo "eio_mkdir_ok";
 }

 // Remove directory
    if (file_exists($data))
        rmdir($temp_dirname);
}

// Create directory with access mode 0300
eio_mkdir($temp_dirname, 0300, EIO_PRI_DEFAULT, "my_mkdir_callback", $temp_dirname);
eio_event_loop();
?>

以上例程的输出类似于：

eio_mkdir_ok

参见

  • eio_rmdir() - Remove a directory


Create a special or ordinary file

  • ? eio_mkdir
  • eio_nop ?
  • PHP Manual
  • Eio 函数
  • Create a special or ordinary file

eio_mknod

(PECL eio >= 0.0.1dev)

eio_mknod — Create a special or ordinary file

说明

eio_mknod ( string $path , int $mode , int $dev , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_mknod() creates ordinary or special(often) file.

Warning

本函数还未编写文档，仅有参数列表。

参数

path

Path for the new node(file).

mode

Specifies both the permissions to use and the type of node to be created. It should be a combination (using bitwise OR) of one of the file types listed below and the permissions for the new node(e.g. 0640). Possible file types are: EIO_S_IFREG(regular file), EIO_S_IFCHR(character file), EIO_S_IFBLK(block special file), EIO_S_IFIFO(FIFO - named pipe) and EIO_S_IFSOCK(UNIX domain socket). To specify permissions EIO_S_I* constants could be used.

dev

If the file type is EIO_S_IFCHR or EIO_S_IFBLK then dev specifies the major and minor numbers of the newly created device special file. Otherwise dev ignored. See mknod(2) man page for details.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_mknod() returns request resource on success or false on error.

范例

Example #1 eio_mknod() example

<?php
// FIFO name
$temp_filename = "/tmp/eio-temp-fifo";

/* Is called when eio_mknod() finishes */
function my_mknod_callback($data, $result) {
    $s = stat($data);
    var_dump($s);

    if ($result == 0) {
        echo "eio_mknod_ok";
    }

    @unlink($data);
}

eio_mknod($temp_filename, EIO_S_IFIFO, 0,
    EIO_PRI_DEFAULT, "my_mknod_callback", $temp_filename);
eio_event_loop();
?>

以上例程的输出类似于：

array(26) {
  [0]=>
  int(17)
  [1]=>
  int(2337608)
  [2]=>
  int(4096)
  [3]=>
  int(1)
  [4]=>
  int(1000)
  [5]=>
  int(100)
  [6]=>
  int(0)
  [7]=>
  int(0)
  [8]=>
  int(1318241261)
  [9]=>
  int(1318241261)
  [10]=>
  int(1318241261)
  [11]=>
  int(4096)
  [12]=>
  int(0)
  ["dev"]=>
  int(17)
  ["ino"]=>
  int(2337608)
  ["mode"]=>
  int(4096)
  ["nlink"]=>
  int(1)
  ["uid"]=>
  int(1000)
  ["gid"]=>
  int(100)
  ["rdev"]=>
  int(0)
  ["size"]=>
  int(0)
  ["atime"]=>
  int(1318241261)
  ["mtime"]=>
  int(1318241261)
  ["ctime"]=>
  int(1318241261)
  ["blksize"]=>
  int(4096)
  ["blocks"]=>
  int(0)
}
eio_mknod_ok

参见

  • eio_open() - Opens a file


Does nothing, except go through the whole request cycle

  • ? eio_mknod
  • eio_npending ?
  • PHP Manual
  • Eio 函数
  • Does nothing, except go through the whole request cycle

eio_nop

(PECL eio >= 0.0.1dev)

eio_nop — Does nothing, except go through the whole request cycle

说明

eio_nop ( int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_nop() does nothing, except go through the whole request cycle. Could be useful in debugging.

参数

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_nop() returns request resource on success or false on error.

参见

  • eio_busy() - Artificially increase load. Could be useful in tests, benchmarking


Returns number of finished, but unhandled requests

  • ? eio_nop
  • eio_nready ?
  • PHP Manual
  • Eio 函数
  • Returns number of finished, but unhandled requests

eio_npending

(PECL eio >= 0.0.1dev)

eio_npending — Returns number of finished, but unhandled requests

说明

eio_npending ( ) : int

eio_npending() returns number of finished, but unhandled requests

参数

此函数没有参数。

返回值

eio_npending() returns number of finished, but unhandled requests.

参见

  • eio_nreqs() - Returns number of requests to be processed
  • eio_nready() - Returns number of not-yet handled requests
  • eio_nthreads() - Returns number of threads currently in use


Returns number of not-yet handled requests

  • ? eio_npending
  • eio_nreqs ?
  • PHP Manual
  • Eio 函数
  • Returns number of not-yet handled requests

eio_nready

(PECL eio >= 0.0.1dev)

eio_nready — Returns number of not-yet handled requests

说明

eio_nready ( ) : int

参数

此函数没有参数。

返回值

eio_nready() returns number of not-yet handled requests

参见

  • eio_nreqs() - Returns number of requests to be processed
  • eio_nready()
  • eio_nthreads() - Returns number of threads currently in use


Returns number of requests to be processed

  • ? eio_nready
  • eio_nthreads ?
  • PHP Manual
  • Eio 函数
  • Returns number of requests to be processed

eio_nreqs

(PECL eio >= 0.0.1dev)

eio_nreqs — Returns number of requests to be processed

说明

eio_nreqs ( ) : int

eio_nreqs() could be called in a custom loop calling eio_poll().

参数

此函数没有参数。

返回值

eio_nreqs() returns number of requests to be processed.

范例

Example #1 eio_nreqs() example

<?php
function res_cb($data, $result) {
    var_dump($data);
    var_dump($result);
}

eio_nop(EIO_PRI_DEFAULT, "res_cb", "1");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "2");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "3");

while (eio_nreqs()) {
    eio_poll();
}
?>

以上例程的输出类似于：

string(1) "1"
int(0)
string(1) "3"
int(0)
string(1) "2"
int(0)

参见

  • eio_poll() - Can be to be called whenever there are pending requests that need finishing
  • eio_nready() - Returns number of not-yet handled requests


Returns number of threads currently in use

  • ? eio_nreqs
  • eio_open ?
  • PHP Manual
  • Eio 函数
  • Returns number of threads currently in use

eio_nthreads

(PECL eio >= 0.0.1dev)

eio_nthreads — Returns number of threads currently in use

说明

eio_nthreads ( ) : int

参数

此函数没有参数。

返回值

eio_nthreads() returns number of threads currently in use.

参见

  • eio_npending() - Returns number of finished, but unhandled requests
  • eio_nready() - Returns number of not-yet handled requests
  • eio_nreqs() - Returns number of requests to be processed
  • eio_set_max_idle() - Set maximum number of idle threads
  • eio_set_max_parallel() - Set maximum parallel threads
  • eio_set_min_parallel() - Set minimum parallel thread number


Opens a file

  • ? eio_nthreads
  • eio_poll ?
  • PHP Manual
  • Eio 函数
  • Opens a file

eio_open

(PECL eio >= 0.0.1dev)

eio_open — Opens a file

说明

eio_open ( string $path , int $flags , int $mode , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_open() opens file specified by path in access mode mode with

参数

path

Path of the file to be opened.

Warning

In some SAPIs(e.g. PHP-FPM) it could fail, if you don't specify full path.

flags

One of EIO_O_* constants, or their combinations. EIO_O_* constants have the same meaning, as their corresponding O_* counterparts defined in fnctl.h C header file. Default is EIO_O_RDWR.

mode

One of EIO_S_I* constants, or their combination (via bitwise OR operator). The constants have the same meaning as their S_I* counterparts defined in » sys/stat.h C header file. Required, if a file is created. Otherwise ignored.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_open() returns file descriptor in result argument of callback on success; otherwise, result is equal to -1.

范例

Example #1 eio_open() example

<?php
$temp_filename = "eio-temp-file.tmp";

/* Is called when eio_close() finishes */
function my_close_cb($data, $result) {
 // Zero indicates success
    var_dump($result == 0);
 @unlink($data);
}

/* Is called when eio_open() finishes */
function my_file_opened_callback($data, $result) {
 // $result should contain the file descriptor
    var_dump($result > 0);

    if ($result > 0) {
  // Close the file
        eio_close($result, EIO_PRI_DEFAULT, "my_close_cb", $data);
        eio_event_loop();
    }
}

// Create new file for reading and writing
// Deny group and others to do anything with that file
eio_open($temp_filename, EIO_O_CREAT | EIO_O_RDWR, EIO_S_IRUSR | EIO_S_IWUSR,
  EIO_PRI_DEFAULT, "my_file_opened_callback", $temp_filename);
eio_event_loop();
?>

以上例程的输出类似于：

bool(true)
bool(true)

参见

  • eio_mknod() - Create a special or ordinary file


Can be to be called whenever there are pending requests that need finishing

  • ? eio_open
  • eio_read ?
  • PHP Manual
  • Eio 函数
  • Can be to be called whenever there are pending requests that need finishing

eio_poll

(PECL eio >= 0.0.1dev)

eio_poll — Can be to be called whenever there are pending requests that need finishing

说明

eio_poll ( ) : int

eio_poll() can be used to implement special event loop. For this eio_nreqs() could be used to test if there are unprocessed requests.

Note:

Applicable only when implementing userspace event loop.

参数

此函数没有参数。

返回值

If any request invocation returns a non-zero value, returns that value. Otherwise, it returns 0.

范例

Example #1 eio_poll() example

<?php
function res_cb($data, $result) {
    var_dump($data);
    var_dump($result);
}

eio_nop(EIO_PRI_DEFAULT, "res_cb", "1");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "2");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "3");

while (eio_nreqs()) {
    // Some specific IPC or so
    eio_poll();
}
?>

以上例程的输出类似于：

string(1) "1"
int(0)
string(1) "3"
int(0)
string(1) "2"
int(0)

参见

  • eio_nreqs() - Returns number of requests to be processed


Read from a file descriptor at given offset

  • ? eio_poll
  • eio_readahead ?
  • PHP Manual
  • Eio 函数
  • Read from a file descriptor at given offset

eio_read

(PECL eio >= 0.0.1dev)

eio_read — Read from a file descriptor at given offset

说明

eio_read ( mixed $fd , int $length , int $offset , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_read() reads up to length bytes from fd file descriptor at offset. The read bytes are stored in result argument of callback.

参数

fd

Stream, Socket resource, or numeric file descriptor

length

Maximum number of bytes to read.

offset

Offset within the file.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_read() stores read bytes in result argument of callback function.

范例

Example #1 eio_read() example

<?php
// Open a temporary file and write some bytes there
$temp_filename = "eio-temp-file.tmp";
$fp = fopen($temp_filename, "w");
fwrite($fp, "1234567890");
fclose($fp);

/* Is called when eio_read() is done */
function my_read_cb($data, $result) {
    global $temp_filename;

 // Output read bytes
    var_dump($result);

 // Close file
    eio_close($data);
    eio_event_loop();

 // Remove temporary file
    @unlink($temp_filename);
}

/* Is called when eio_open() is done */
function my_file_opened_callback($data, $result) {
 // $result should contain the file descriptor
    if ($result > 0) {
  // Read 5 bytes starting from third
        eio_read($result, 5, 2, EIO_PRI_DEFAULT, "my_read_cb", $result);
        eio_event_loop();
    } else {
  // eio_open() failed
        unlink($data);
    }
}

// Open the file for reading and writing
eio_open($temp_filename, EIO_O_RDWR, NULL,
    EIO_PRI_DEFAULT, "my_file_opened_callback", $temp_filename);
eio_event_loop();
?>

以上例程的输出类似于：

string(5) "34567"

参见

  • eio_open() - Opens a file
  • eio_write() - Write to file
  • eio_close() - Close file
  • eio_event_loop() - Polls libeio until all requests proceeded


Perform file readahead into page cache

  • ? eio_read
  • eio_readdir ?
  • PHP Manual
  • Eio 函数
  • Perform file readahead into page cache

eio_readahead

(PECL eio >= 0.0.1dev)

eio_readahead — Perform file readahead into page cache

说明

eio_readahead ( mixed $fd , int $offset , int $length , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_readahead() populates the page cache with data from a file so that subsequent reads from that file will not block on disk I/O. See READAHEAD(2) man page for details.

参数

fd

Stream, Socket resource, or numeric file descriptor

offset

Starting point from which data is to be read.

length

Number of bytes to be read.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_readahead() returns request resource on success or false on error.


Reads through a whole directory

  • ? eio_readahead
  • eio_readlink ?
  • PHP Manual
  • Eio 函数
  • Reads through a whole directory

eio_readdir

(PECL eio >= 0.0.1dev)

eio_readdir — Reads through a whole directory

说明

eio_readdir ( string $path , int $flags , int $pri , callable $callback , string $data = NULL ) : resource

Reads through a whole directory(via the opendir, readdir and closedir system calls) and returns either the names or an array in result argument of callback function, depending on the flags argument.

参数

path

Directory path.

flags

Combination of EIO_READDIR_* constants.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_readdir() returns request resource on success, or false on error. Sets result argument of callback function according to flags:

EIO_READDIR_DENTS (int)
eio_readdir() flag. If specified, the result argument of the callback becomes an array with the following keys: 'names' - array of directory names 'dents' - array of struct eio_dirent-like arrays having the following keys each: 'name' - the directory name; 'type' - one of EIO_DT_* constants; 'inode' - the inode number, if available, otherwise unspecified;
EIO_READDIR_DIRS_FIRST (int)
When this flag is specified, the names will be returned in an order where likely directories come first, in optimal stat order.
EIO_READDIR_STAT_ORDER (int)
When this flag is specified, then the names will be returned in an order suitable for stat'ing each one. When planning to stat() all files in the given directory, the returned order will likely be fastest.
EIO_READDIR_FOUND_UNKNOWN (int)

Node types:

EIO_DT_UNKNOWN (int)
Unknown node type(very common). Further stat() needed.
EIO_DT_FIFO (int)
FIFO node type
EIO_DT_CHR (int)
Node type
EIO_DT_MPC (int)
Multiplexed char device (v7+coherent) node type
EIO_DT_DIR (int)
Directory node type
EIO_DT_NAM (int)
Xenix special named file node type
EIO_DT_BLK (int)
Node type
EIO_DT_MPB (int)
Multiplexed block device (v7+coherent)
EIO_DT_REG (int)
Node type
EIO_DT_NWK (int)
EIO_DT_CMP (int)
HP-UX network special node type
EIO_DT_LNK (int)
Link node type
EIO_DT_SOCK (int)
Socket node type
EIO_DT_DOOR (int)
Solaris door node type
EIO_DT_WHT (int)
Node type
EIO_DT_MAX (int)
Highest node type value

范例

Example #1 eio_readdir() example

<?php
/* Is called when eio_readdir() finishes */
function my_readdir_callback($data, $result) {
    echo __FUNCTION__, " called\n";
    echo "data: "; var_dump($data);
    echo "result: "; var_dump($result);
    echo "\n";
}

eio_readdir("/var/spool/news", EIO_READDIR_STAT_ORDER | EIO_READDIR_DIRS_FIRST,
  EIO_PRI_DEFAULT, "my_readdir_callback");
eio_event_loop();
?>

以上例程的输出类似于：

my_readdir_callback called
data: NULL
result: array(2) {
 ["names"]=>
  array(7) {
   [0]=>
    string(7) "archive"
    [1]=>
    string(8) "articles"
    [2]=>
    string(8) "incoming"
    [3]=>
    string(7) "innfeed"
    [4]=>
    string(8) "outgoing"
    [5]=>
    string(8) "overview"
    [6]=>
    string(3) "tmp"
  }
 ["dents"]=>
  array(7) {
   [0]=>
    array(3)
    {
     ["name"]=>
      string(7)
      "archive"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393265)
    }
   [1]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "articles"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393266)
    }
   [2]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "incoming"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393267)
    }
   [3]=>
    array(3)
    {
     ["name"]=>
      string(7)
      "innfeed"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393269)
    }
   [4]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "outgoing"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393270)
    }
   [5]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "overview"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393271)
    }
   [6]=>
    array(3)
    {
     ["name"]=>
      string(3)
      "tmp"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393272)
    }
  }
}


Read value of a symbolic link

  • ? eio_readdir
  • eio_realpath ?
  • PHP Manual
  • Eio 函数
  • Read value of a symbolic link

eio_readlink

(PECL eio >= 0.0.1dev)

eio_readlink — Read value of a symbolic link

说明

eio_readlink ( string $path , int $pri , callable $callback , string $data = NULL ) : resource

参数

path

Source symbolic link path

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_readlink() returns request resource on success or false on error.

范例

Example #1 eio_readlink() example

<?php
$filename = dirname(__FILE__)."/symlink.dat";
touch($filename);
$link = dirname(__FILE__)."/symlink.link";
$hardlink = dirname(__FILE__)."/hardlink.link";

function my_hardlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && !is_link($data));
    @unlink($data);

    eio_symlink($filename, $link, EIO_PRI_DEFAULT, "my_symlink_cb", $link);
}

function my_symlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && is_link($data));

    if (!eio_readlink($data, EIO_PRI_DEFAULT, "my_readlink_cb", NULL)) {
        @unlink($link);
        @unlink($filename);
    }
}

function my_readlink_cb($data, $result) {
    global $filename, $link;
    var_dump($result);

    @unlink($link);
    @unlink($filename);
}

eio_link($filename, $hardlink, EIO_PRI_DEFAULT, "my_hardlink_cb", $hardlink);
eio_event_loop();
?>

以上例程的输出类似于：

bool(true)
bool(true)
string(16) "/tmp/symlink.dat"

参见

  • eio_symlink() - Create a symbolic link


Get the canonicalized absolute pathname

  • ? eio_readlink
  • eio_rename ?
  • PHP Manual
  • Eio 函数
  • Get the canonicalized absolute pathname

eio_realpath

(PECL eio >= 0.0.1dev)

eio_realpath — Get the canonicalized absolute pathname

说明

eio_realpath ( string $path , int $pri , callable $callback , string $data = NULL ) : resource

eio_realpath() returns the canonicalized absolute pathname in result argument of callback function.

参数

path

Short pathname

pri

callback

data

返回值

范例

Example #1 eio_realpath() example

<?php
var_dump(getcwd());

function my_realpath_allback($data, $result) {
    var_dump($result);
}

eio_realpath("../", EIO_PRI_DEFAULT, "my_realpath_allback");
eio_event_loop();
?>

以上例程的输出类似于：

string(12) "/home/ruslan"
string(5) "/home"


Change the name or location of a file

  • ? eio_realpath
  • eio_rmdir ?
  • PHP Manual
  • Eio 函数
  • Change the name or location of a file

eio_rename

(PECL eio >= 0.0.1dev)

eio_rename — Change the name or location of a file

说明

eio_rename ( string $path , string $new_path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_rename() renames or moves a file to new location.

参数

path

Source path

new_path

Target path

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_rename() returns request resource on success or false on error.

范例

Example #1 eio_rename() example

<?php
$filename = dirname(__FILE__)."/eio-temp-file.dat";
touch($filename);
$new_filename = dirname(__FILE__)."/eio-temp-file-new.dat";

function my_rename_cb($data, $result) {
    global $filename, $new_filename;

    if ($result == 0 && !file_exists($filename) && file_exists($new_filename)) {
        @unlink($new_filename);
        echo "eio_rename_ok";
    } else {
        @unlink($filename);
    }
}

eio_rename($filename, $new_filename, EIO_PRI_DEFAULT, "my_rename_cb", $filename);
eio_event_loop();
?>

以上例程的输出类似于：

eio_rename_ok


Remove a directory

  • ? eio_rename
  • eio_seek ?
  • PHP Manual
  • Eio 函数
  • Remove a directory

eio_rmdir

(PECL eio >= 0.0.1dev)

eio_rmdir — Remove a directory

说明

eio_rmdir ( string $path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_rmdir() removes a directory.

参数

path

Directory path

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_rmdir() returns request resource on success or false on error.

范例

Example #1 eio_rmdir() example

<?php
$temp_dirname = "eio-temp-dir";
mkdir($temp_dirname);

function my_rmdir_callback($data, $result) {
    if ($result == 0 && !file_exists($data)) {
        echo "eio_rmdir_ok";
    } else if (file_exists($data)) {
        rmdir($data);
    }
}

eio_rmdir($temp_dirname, EIO_PRI_DEFAULT, "my_rmdir_callback", $temp_dirname);
eio_event_loop();
?>

以上例程的输出类似于：

eio_rmdir_ok

参见

  • eio_mkdir() - Create directory


Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence

  • ? eio_rmdir
  • eio_sendfile ?
  • PHP Manual
  • Eio 函数
  • Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence

eio_seek

(PECL eio >= 0.5.0b)

eio_seek — Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence

说明

eio_seek ( mixed $fd , int $offset , int $whence , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_seek() repositions the offset of the open file associated with stream, Socket resource, or file descriptor specified by fd to the argument offset according to the directive whence as follows:

  • EIO_SEEK_SET - Set position equal to offset bytes.
  • EIO_SEEK_CUR - Set position to current location plus offset.
  • EIO_SEEK_END - Set position to end-of-file plus offset.

参数

fd

Stream, Socket resource, or numeric file descriptor

offset

Starting point from which data is to be read.

length

Number of bytes to be read.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_seek() returns request resource on success or false on error.


Transfer data between file descriptors

  • ? eio_seek
  • eio_set_max_idle ?
  • PHP Manual
  • Eio 函数
  • Transfer data between file descriptors

eio_sendfile

(PECL eio >= 0.0.1dev)

eio_sendfile — Transfer data between file descriptors

说明

eio_sendfile ( mixed $out_fd , mixed $in_fd , int $offset , int $length , int $pri = ? , callable $callback = ? , string $data = ? ) : resource

eio_sendfile() copies data between one file descriptor and another. See SENDFILE(2) man page for details.

参数

out_fd

Output stream, Socket resource, or file descriptor. Should be opened for writing.

in_fd

Input stream, Socket resource, or file descriptor. Should be opened for reading.

offset

Offset within the source file.

length

Number of bytes to copy.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_sendfile() returns request resource on success or false on error.


Set maximum number of idle threads

  • ? eio_sendfile
  • eio_set_max_parallel ?
  • PHP Manual
  • Eio 函数
  • Set maximum number of idle threads

eio_set_max_idle

(PECL eio >= 0.0.1dev)

eio_set_max_idle — Set maximum number of idle threads

说明

eio_set_max_idle ( int $nthreads ) : void

参数

nthreads

Number of idle threads.

返回值

没有返回值。

参见

  • eio_nthreads() - Returns number of threads currently in use
  • eio_set_min_parallel() - Set minimum parallel thread number
  • eio_set_max_parallel() - Set maximum parallel threads


Set maximum parallel threads

  • ? eio_set_max_idle
  • eio_set_max_poll_reqs ?
  • PHP Manual
  • Eio 函数
  • Set maximum parallel threads

eio_set_max_parallel

(PECL eio >= 0.0.1dev)

eio_set_max_parallel — Set maximum parallel threads

说明

eio_set_max_parallel ( int $nthreads ) : void

参数

nthreads

Number of parallel threads

返回值

没有返回值。

参见

  • eio_nthreads() - Returns number of threads currently in use
  • eio_set_max_idle() - Set maximum number of idle threads
  • eio_set_min_parallel() - Set minimum parallel thread number


Set maximum number of requests processed in a poll

  • ? eio_set_max_parallel
  • eio_set_max_poll_time ?
  • PHP Manual
  • Eio 函数
  • Set maximum number of requests processed in a poll

eio_set_max_poll_reqs

(PECL eio >= 0.0.1dev)

eio_set_max_poll_reqs — Set maximum number of requests processed in a poll

说明

eio_set_max_poll_reqs ( int $nreqs ) : void

参数

nreqs

Number of requests

返回值

没有返回值。


Set maximum poll time

  • ? eio_set_max_poll_reqs
  • eio_set_min_parallel ?
  • PHP Manual
  • Eio 函数
  • Set maximum poll time

eio_set_max_poll_time

(PECL eio >= 0.0.1dev)

eio_set_max_poll_time — Set maximum poll time

说明

eio_set_max_poll_time ( float $nseconds ) : void

Polling stops, if poll took longer than nseconds seconds.

参数

nseconds

Number of seconds

返回值

没有返回值。


Set minimum parallel thread number

  • ? eio_set_max_poll_time
  • eio_stat ?
  • PHP Manual
  • Eio 函数
  • Set minimum parallel thread number

eio_set_min_parallel

(PECL eio >= 0.0.1dev)

eio_set_min_parallel — Set minimum parallel thread number

说明

eio_set_min_parallel ( string $nthreads ) : void

参数

nthreads

Number of parallel threads.

返回值

没有返回值。

参见

  • eio_nthreads() - Returns number of threads currently in use
  • eio_set_max_idle() - Set maximum number of idle threads
  • eio_set_max_parallel() - Set maximum parallel threads


Get file status

  • ? eio_set_min_parallel
  • eio_statvfs ?
  • PHP Manual
  • Eio 函数
  • Get file status

eio_stat

(PECL eio >= 0.0.1dev)

eio_stat — Get file status

说明

eio_stat ( string $path , int $pri , callable $callback , mixed $data = NULL ) : resource

eio_stat() returns file status information in result argument of callback

参数

path

The file path

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_stat() returns request resource on success or false on error. On success assigns result argument of callback to an array.

范例

Example #1 eio_stat() example

<?php
$tmp_filename = "eio-file.tmp";
touch($tmp_filename);

function my_res_cb($data, $result) {
    var_dump($data);
    var_dump($result);
}

function my_open_cb($data, $result) {
    eio_close($result);
    eio_event_loop();

    @unlink($data);
}

eio_stat($tmp_filename, EIO_PRI_DEFAULT, "my_res_cb", "eio_stat");
eio_open($tmp_filename, EIO_O_RDONLY, NULL,
 EIO_PRI_DEFAULT, "my_open_cb", $tmp_filename);
eio_event_loop();
?>

以上例程的输出类似于：

string(8) "eio_stat"
array(12) {
  ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2489173)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318250380)
  ["st_mtime"]=>
  int(1318250380)
  ["st_ctime"]=>
  int(1318250380)
}

参见

  • eio_lstat() - Get file status
  • eio_fstat() - Get file status


Get file system statistics

  • ? eio_stat
  • eio_symlink ?
  • PHP Manual
  • Eio 函数
  • Get file system statistics

eio_statvfs

(PECL eio >= 0.0.1dev)

eio_statvfs — Get file system statistics

说明

eio_statvfs ( string $path , int $pri , callable $callback , mixed $data = ? ) : resource

eio_statvfs() returns file system statistics information in result argument of callback

参数

path

Pathname of any file within the mounted file system

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_statvfs() returns request resource on success or false on error. On success assigns result argument of callback to an array.

范例

Example #1 eio_statvfs() example

<?php
$tmp_filename = '/tmp/eio-file.tmp';
touch($tmp_filename);

function my_statvfs_callback($data, $result) {
    var_dump($data);
    var_dump($result);

 @unlink($data);
}

eio_statvfs($tmp_filename, EIO_PRI_DEFAULT, "my_statvfs_callback", $tmp_filename);
eio_event_loop();
?>

以上例程的输出类似于：

string(17) "/tmp/eio-file.tmp"
array(11) {
  ["f_bsize"]=>
  int(4096)
  ["f_frsize"]=>
  int(4096)
  ["f_blocks"]=>
  int(262144)
  ["f_bfree"]=>
  int(262111)
  ["f_bavail"]=>
  int(262111)
  ["f_files"]=>
  int(1540815)
  ["f_ffree"]=>
  int(1540743)
  ["f_favail"]=>
  int(1540743)
  ["f_fsid"]=>
  int(0)
  ["f_flag"]=>
  int(4102)
  ["f_namemax"]=>
  int(255)
}


Create a symbolic link

  • ? eio_statvfs
  • eio_sync_file_range ?
  • PHP Manual
  • Eio 函数
  • Create a symbolic link

eio_symlink

(PECL eio >= 0.0.1dev)

eio_symlink — Create a symbolic link

说明

eio_symlink ( string $path , string $new_path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_symlink() creates a symbolic link new_path to path.

参数

path

Source path

new_path

Target path

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_symlink() returns request resource on success or false on error.

范例

Example #1 eio_symlink() example

<?php
$filename = dirname(__FILE__)."/symlink.dat";
touch($filename);
$link = dirname(__FILE__)."/symlink.link";

function my_symlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && is_link($data));

    if (!eio_readlink($data, EIO_PRI_DEFAULT, "my_readlink_cb", NULL)) {
        @unlink($link);
        @unlink($filename);
    }
}

function my_readlink_cb($data, $result) {
    global $filename, $link;
    var_dump($result);

    @unlink($link);
    @unlink($filename);
}

eio_symlink($filename, $link, EIO_PRI_DEFAULT, "my_symlink_cb", $link);
eio_event_loop();
?>

以上例程的输出类似于：

bool(true)
string(16) "/tmp/symlink.dat"

参见

  • eio_link() - Create a hardlink for file


Sync a file segment with disk

  • ? eio_symlink
  • eio_sync ?
  • PHP Manual
  • Eio 函数
  • Sync a file segment with disk

eio_sync_file_range

(PECL eio >= 0.0.1dev)

eio_sync_file_range — Sync a file segment with disk

说明

eio_sync_file_range ( mixed $fd , int $offset , int $nbytes , int $flags , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_sync_file_range() permits fine control when synchronizing the open file referred to by the file descriptor fd with disk.

参数

fd

File descriptor

offset

The starting byte of the file range to be synchronized

nbytes

Specifies the length of the range to be synchronized, in bytes. If nbytes is zero, then all bytes from offset through to the end of file are synchronized.

flags

A bit-mask. Can include any of the following values: EIO_SYNC_FILE_RANGE_WAIT_BEFORE, EIO_SYNC_FILE_RANGE_WRITE, EIO_SYNC_FILE_RANGE_WAIT_AFTER. These flags have the same meaning as their SYNC_FILE_RANGE_* counterparts(see SYNC_FILE_RANGE(2) man page).

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_sync_file_range() returns request resource on success or false on error.


Commit buffer cache to disk

  • ? eio_sync_file_range
  • eio_syncfs ?
  • PHP Manual
  • Eio 函数
  • Commit buffer cache to disk

eio_sync

(PECL eio >= 0.0.1dev)

eio_sync — Commit buffer cache to disk

说明

eio_sync ( int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

参数

此函数没有参数。

返回值

eio_sync() returns request resource on success or false on error.


Calls Linux' syncfs syscall, if available

  • ? eio_sync
  • eio_truncate ?
  • PHP Manual
  • Eio 函数
  • Calls Linux' syncfs syscall, if available

eio_syncfs

(PECL eio >= 0.0.1dev)

eio_syncfs — Calls Linux' syncfs syscall, if available

说明

eio_syncfs ( mixed $fd , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

参数

fd

File descriptor

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_syncfs() returns request resource on success or false on error.


Truncate a file

  • ? eio_syncfs
  • eio_unlink ?
  • PHP Manual
  • Eio 函数
  • Truncate a file

eio_truncate

(PECL eio >= 0.0.1dev)

eio_truncate — Truncate a file

说明

eio_truncate ( string $path , int $offset = 0 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_truncate() causes the regular file named by path to be truncated to a size of precisely length bytes

参数

path

File path

offset

Offset from beginning of the file.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_busy() returns request resource on success or false on error.

参见

  • eio_ftruncate() - Truncate a file


Delete a name and possibly the file it refers to

  • ? eio_truncate
  • eio_utime ?
  • PHP Manual
  • Eio 函数
  • Delete a name and possibly the file it refers to

eio_unlink

(PECL eio >= 0.0.1dev)

eio_unlink — Delete a name and possibly the file it refers to

说明

eio_unlink ( string $path , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_unlink() deletes a name from the file system.

参数

path

Path to file

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_unlink() returns request resource on success or false on error.


Change file last access and modification times

  • ? eio_unlink
  • eio_write ?
  • PHP Manual
  • Eio 函数
  • Change file last access and modification times

eio_utime

(PECL eio >= 0.0.1dev)

eio_utime — Change file last access and modification times

说明

eio_utime ( string $path , float $atime , float $mtime , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

参数

path

Path to the file.

atime

Access time

mtime

Modification time

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_utime() returns request resource on success or false on error.

参见

  • eio_futime() - Change file last access and modification times


Write to file

  • ? eio_utime
  • Ev ?
  • PHP Manual
  • Eio 函数
  • Write to file

eio_write

(PECL eio >= 0.0.1dev)

eio_write — Write to file

说明

eio_write ( mixed $fd , string $str , int $length = 0 , int $offset = 0 , int $pri = EIO_PRI_DEFAULT , callable $callback = NULL , mixed $data = NULL ) : resource

eio_write() writes up to length bytes from str at offset offset from the beginning of the file.

参数

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open()

str

Source string

length

Maximum number of bytes to write.

offset

Offset from the beginning of file.

pri

请求的优先级：EIO_PRI_DEFAULT，EIO_PRI_MIN，EIO_PRI_MAX 或 null。如果是 null，pri 将设为 EIO_PRI_DEFAULT。

callback

callback 函数在请求完成时被调用。其应匹配一下原型：

void callback(mixed $data, int $result[, resource $req]);
data

传递给请求的用户数据。

result

针对请求的结果的值。通常是相应的系统调用返回的值。

req

可选的请求资源，可被 eio_get_last_error() 之类的函数使用。

data

Arbitrary variable passed to callback.

返回值

eio_write() returns request resource on success or false on error.

参见

  • eio_open() - Opens a file


Ev

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Watchers
  • Watcher callbacks
  • Periodic watcher operation modes
  • Ev — The Ev class
    • Ev::backend — Returns an integer describing the backend used by libev
    • Ev::depth — Returns recursion depth
    • Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops
    • Ev::feedSignal — Feed a signal event info Ev
    • Ev::feedSignalEvent — Feed signal event into the default loop
    • Ev::iteration — Return the number of times the default event loop has polled for new events
    • Ev::now — Returns the time when the last iteration of the default event loop has started
    • Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress
    • Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform
    • Ev::resume — Resume previously suspended default event loop
    • Ev::run — Begin checking for events and calling callbacks for the default loop
    • Ev::sleep — Block the process for the given number of seconds
    • Ev::stop — Stops the default event loop
    • Ev::supportedBackends — Returns the set of backends supported by current libev configuration
    • Ev::suspend — Suspend the default event loop
    • Ev::time — Returns the current time in fractional seconds since the epoch
    • Ev::verify — Performs internal consistency checks(for debugging)
  • EvCheck — The EvCheck class
    • EvCheck::__construct — Constructs the EvCheck watcher object
    • EvCheck::createStopped — Create instance of a stopped EvCheck watcher
  • EvChild — The EvChild class
    • EvChild::__construct — Constructs the EvChild watcher object
    • EvChild::createStopped — Create instance of a stopped EvCheck watcher
    • EvChild::set — Configures the watcher
  • EvEmbed — The EvEmbed class
    • EvEmbed::__construct — Constructs the EvEmbed object
    • EvEmbed::createStopped — Create stopped EvEmbed watcher object
    • EvEmbed::set — Configures the watcher
    • EvEmbed::sweep — Make a single, non-blocking sweep over the embedded loop
  • EvFork — The EvFork class
    • EvFork::__construct — Constructs the EvFork watcher object
    • EvFork::createStopped — Creates a stopped instance of EvFork watcher class
  • EvIdle — The EvIdle class
    • EvIdle::__construct — Constructs the EvIdle watcher object
    • EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object
  • EvIo — The EvIo class
    • EvIo::__construct — Constructs EvIo watcher object
    • EvIo::createStopped — Create stopped EvIo watcher object
    • EvIo::set — Configures the watcher
  • EvLoop — The EvLoop class
    • EvLoop::backend — Returns an integer describing the backend used by libev
    • EvLoop::check — Creates EvCheck object associated with the current event loop instance
    • EvLoop::child — Creates EvChild object associated with the current event loop
    • EvLoop::__construct — Constructs the event loop object
    • EvLoop::defaultLoop — Returns or creates the default event loop
    • EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object
    • EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance
    • EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance
    • EvLoop::invokePending — Invoke all pending watchers while resetting their pending state
    • EvLoop::io — Create EvIo watcher object associated with the current event loop instance
    • EvLoop::loopFork — Must be called after a fork
    • EvLoop::now — Returns the current "event loop time"
    • EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress
    • EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance
    • EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance
    • EvLoop::resume — Resume previously suspended default event loop
    • EvLoop::run — Begin checking for events and calling callbacks for the loop
    • EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance
    • EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance
    • EvLoop::stop — Stops the event loop
    • EvLoop::suspend — Suspend the loop
    • EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance
    • EvLoop::verify — Performs internal consistency checks(for debugging)
  • EvPeriodic — The EvPeriodic class
    • EvPeriodic::again — Simply stops and restarts the periodic watcher again
    • EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next
    • EvPeriodic::__construct — Constructs EvPeriodic watcher object
    • EvPeriodic::createStopped — Create a stopped EvPeriodic watcher
    • EvPeriodic::set — Configures the watcher
  • EvPrepare — The EvPrepare class
    • EvPrepare::__construct — Constructs EvPrepare watcher object
    • EvPrepare::createStopped — Creates a stopped instance of EvPrepare watcher
  • EvSignal — The EvSignal class
    • EvSignal::__construct — Constructs EvSignal watcher object
    • EvSignal::createStopped — Create stopped EvSignal watcher object
    • EvSignal::set — Configures the watcher
  • EvStat — The EvStat class
    • EvStat::attr — Returns the values most recently detected by Ev
    • EvStat::__construct — Constructs EvStat watcher object
    • EvStat::createStopped — Create a stopped EvStat watcher object
    • EvStat::prev — Returns the previous set of values returned by EvStat::attr
    • EvStat::set — Configures the watcher
    • EvStat::stat — Initiates the stat call
  • EvTimer — The EvTimer class
    • EvTimer::again — Restarts the timer watcher
    • EvTimer::__construct — Constructs an EvTimer watcher object
    • EvTimer::createStopped — Creates EvTimer stopped watcher object
    • EvTimer::set — Configures the watcher
  • EvWatcher — The EvWatcher class
    • EvWatcher::clear — Clear watcher pending status
    • EvWatcher::__construct — Abstract constructor of a watcher object
    • EvWatcher::feed — Feeds the given revents set into the event loop
    • EvWatcher::getLoop — Returns the loop responsible for the watcher
    • EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask
    • EvWatcher::keepalive — Configures whether to keep the loop from returning
    • EvWatcher::setCallback — Sets new callback for the watcher
    • EvWatcher::start — Starts the watcher
    • EvWatcher::stop — Stops the watcher


简介

This extension provides inteface to » libev library - a high performance full-featured event loop written in C.

Note: 此扩展在 Windows 平台上不可用。

Libev is an event loop: one registers interest in certain events (such as a file descriptor being readable or a timeout occurring), and it will manage these event sources and provide the program with events.

To do this, it must take more or less complete control over the process (or thread) by executing the event loop handler, and will then communicate events via a callback mechanism.

You register interest in certain events by registering so-called event watchers, and then hand it over to libev by starting the watcher.

For details refer to the » documentation of libev


需求

libev library is embedded into this extension. You don't need to install it separately.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ev .


预定义常量

此扩展没有定义常量。

Most constants are moved to Ev singleton class.


范例

Example #1 Simple timers

<?php
// Create and start timer firing after 2 seconds
$w1 = new EvTimer(2, 0, function () {
    echo "2 seconds elapsed\n";
});

// Create and launch timer firing after 2 seconds repeating each second
// until we manually stop it
$w2 = new EvTimer(2, 1, function ($w) {
    echo "is called every second, is launched after 2 seconds\n";
    echo "iteration = ", Ev::iteration(), PHP_EOL;

    // Stop the watcher after 5 iterations
    Ev::iteration() == 5 and $w->stop();
    // Stop the watcher if further calls cause more than 10 iterations
    Ev::iteration() >= 10 and $w->stop();
});

// Create stopped timer. It will be inactive until we start it ourselves
$w_stopped = EvTimer::createStopped(10, 5, function($w) {
    echo "Callback of a timer created as stopped\n";

    // Stop the watcher after 2 iterations
    Ev::iteration() >= 2 and $w->stop();
});

// Loop until Ev::stop() is called or all of watchers stop
Ev::run();

// Start and look if it works
$w_stopped->start();
echo "Run single iteration\n";
Ev::run(Ev::RUN_ONCE);

echo "Restart the second watcher and try to handle the same events, but don't block\n";
$w2->again();
Ev::run(Ev::RUN_NOWAIT);

$w = new EvTimer(10, 0, function() {});
echo "Running a blocking loop\n";
Ev::run();
echo "END\n";
?>

以上例程的输出类似于：

2 seconds elapsed
is called every second, is launched after 2 seconds
iteration = 1
is called every second, is launched after 2 seconds
iteration = 2
is called every second, is launched after 2 seconds
iteration = 3
is called every second, is launched after 2 seconds
iteration = 4
is called every second, is launched after 2 seconds
iteration = 5
Run single iteration
Callback of a timer created as stopped
Restart the second watcher and try to handle the same events, but don't block
Running a blocking loop
is called every second, is launched after 2 seconds
iteration = 8
is called every second, is launched after 2 seconds
iteration = 9
is called every second, is launched after 2 seconds
iteration = 10
END

Example #2 Periodic timer. Tick each 10.5 seconds

<?php
$w = new EvPeriodic(0., 10.5, NULL, function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Example #3 Periodic timer. Use reschedule callback

<?php
// Tick each 10.5 seconds

function reschedule_cb ($watcher, $now) {
    return $now + (10.5. - fmod($now, 10.5));
}

$w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Example #4 Periodic timer. Tick every 10.5 seconds starting at now

<?php
// Tick every 10.5 seconds starting at now
$w = new EvPeriodic(fmod(Ev::now(), 10.5), 10.5, NULL, function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Example #5 Wait until STDIN is readable

<?php
// Wait until STDIN is readable
$w = new EvIo(STDIN, Ev::READ, function ($watcher, $revents) {
    echo "STDIN is readable\n";
});

Ev::run(Ev::RUN_ONCE);
?>

Example #6 Use some async I/O to access a socket

<?php
/* Use some async I/O to access a socket */

// `sockets' extension still logs warnings
// for EINPROGRESS, EAGAIN/EWOULDBLOCK etc.
error_reporting(E_ERROR);

$e_nonblocking = array (/*EAGAIN or EWOULDBLOCK*/11, /*EINPROGRESS*/115);

// Get the port for the WWW service
$service_port = getservbyname('www', 'tcp');

// Get the IP address for the target host
$address = gethostbyname('google.co.uk');

// Create a TCP/IP socket
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === FALSE) {
    echo "socket_create() failed: reason: "
        .socket_strerror(socket_last_error()) . "\n";
}

// Set O_NONBLOCK flag
socket_set_nonblock($socket);

// Abort on timeout
$timeout_watcher = new EvTimer(10.0, 0., function () use ($socket) {
    socket_close($socket);
    Ev::stop(Ev::BREAK_ALL);
});

// Make HEAD request when the socket is writable
$write_watcher = new EvIo($socket, Ev::WRITE, function ($w)
    use ($socket, $timeout_watcher, $e_nonblocking)
{
    // Stop timeout watcher
    $timeout_watcher->stop();
    // Stop write watcher
    $w->stop();

    $in = "HEAD / HTTP/1.1\r\n";
    $in .= "Host: google.co.uk\r\n";
    $in .= "Connection: Close\r\n\r\n";

    if (!socket_write($socket, $in, strlen($in))) {
        trigger_error("Failed writing $in to socket", E_USER_ERROR);
    }

    $read_watcher = new EvIo($socket, Ev::READ, function ($w, $re)
        use ($socket, $e_nonblocking)
    {
        // Socket is readable. recv() 20 bytes using non-blocking mode
        $ret = socket_recv($socket, $out, 20, MSG_DONTWAIT);

        if ($ret) {
            echo $out;
        } elseif ($ret === 0) {
            // All read
            $w->stop();
            socket_close($socket);
            return;
        }

        // Caught EINPROGRESS, EAGAIN, or EWOULDBLOCK
        if (in_array(socket_last_error(), $e_nonblocking)) {
            return;
        }

        $w->stop();
        socket_close($socket);
    });

    Ev::run();
});

$result = socket_connect($socket, $address, $service_port);

Ev::run();
?>

以上例程的输出类似于：

HTTP/1.1 301 Moved Permanently
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=gb2312
Date: Sun, 23 Dec 2012 16:08:27 GMT
Expires: Tue, 22 Jan 2013 16:08:27 GMT
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Connection: close

Example #7 Embedding one loop into another

<?php
/*
* Try to get an embeddable event loop and embed it into the default event loop.
* If it is impossible, use the default
* loop. The default loop is stored in $loop_hi, while the embeddable loop is
* stored in $loop_lo(which is $loop_hi in the case no embeddable loop can be
* used).
*
* Sample translated to PHP
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop_hi = EvLoop::defaultLoop();
$loop_lo = NULL;
$embed   = NULL;

/*
* See if there is a chance of getting one that works
* (flags' value of 0 means autodetection)
*/
$loop_lo = Ev::embeddableBackends() & Ev::recommendedBackends()
    ? new EvLoop(Ev::embeddableBackends() & Ev::recommendedBackends())
    : 0;

if ($loop_lo) {
    $embed = new EvEmbed($loop_lo, function () {});
} else {
    $loop_lo = $loop_hi;
}
?>

Example #8 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
    if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
        $embed = new EvEmbed($loop);
    }
}

if (!$socket_loop) {
    $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Example #9 Handle SIGTERM signal

<?php
$w = new EvSignal(SIGTERM, function ($watcher) {
    echo "SIGTERM received\n";
    $watcher->stop();
});

Ev::run();
?>

Example #10 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
    echo "/var/log/messages changed\n";

    $attr = $w->attr();

    if ($attr['nlink']) {
        printf("Current size: %ld\n", $attr['size']);
        printf("Current atime: %ld\n", $attr['atime']);
        printf("Current mtime: %ld\n", $attr['mtime']);
    } else {
        fprintf(STDERR, "`messages` file is not there!");
        $w->stop();
    }
});

Ev::run();
?>

Example #11 Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay

<?php
$timer = EvTimer::createStopped(0., 1.02, function ($w) {
    $w->stop();

    $stat = $w->data;

    // 1 second after the most recent change of the file
    printf("Current size: %ld\n", $stat->attr()['size']);
});

$stat = new EvStat("/var/log/messages", 0., function () use ($timer) {
    // Reset timer watcher
    $timer->again();
});

$timer->data = $stat;

Ev::run();
?>

Example #12 Process status changes

<?php
$pid = pcntl_fork();

if ($pid == -1) {
    fprintf(STDERR, "pcntl_fork failed\n");
} elseif ($pid) {
    $w = new EvChild($pid, FALSE, function ($w, $revents) {
        $w->stop();

        printf("Process %d exited with status %d\n", $w->rpid, $w->rstatus);
    });

    Ev::run();

    // Protect against Zombies
    pcntl_wait($status);
} else {
    //Forked child
    exit(2);
}
?>


Watchers

A watcher is an object that gets created to record interest in some event. For instance, the following code waits for STDIN to become readable:

<?php
// Wait until STDIN is readable
$w = new EvIo(STDIN, Ev::READ, function ($watcher, $revents) {
 echo "STDIN is readable\n";
});
Ev::run(Ev::RUN_ONCE);
?>

All the watcher constructors automatically start the watchers. createStopped methods create stopped watchers(e.g. EvIo::createStopped() )

Note that a watcher will automatically be stopped when the watcher object is destroyed. Therefore, the watcher objects returned by the constructors or factory methods should be kept.

Note also that all methods changing some watcher property( set , priority etc.) automatically stop and start it again if it is active, which means pending events get lost.

See also: Watcher callbacks .


Watcher callbacks

All watchers can be active(waiting for events) or inactive(paused). Only active watchers will have their callbacks invoked. All callbacks will be called with at least two arguments: watcher - the watcher, and revents a bitmask of received events.

Watcher callbacks are passed to the watcher constructors (the classes derived from EvWatcher - EvCheck::__construct() , EvChild::__construct() etc.). A watcher callback should match the following prototype:

callback ( object $watcher = NULL , int $revents = NULL ) : void

watcher

The watcher instance(of a class extending EvWatcher ).

revents

Watcher received events .

Each watcher type has its associated bit in revents , so one can use the same callback for multiple watchers. The event mask is named after the type, i.e. EvChild (or EvLoop::child() ) sets EV::CHILD , EvPrepare (or EvLoop::prepare() ) sets Ev::PREPARE , EvPeriodic (or EvLoop::periodic() ) sets Ev::PERIODIC and so on, with the exception of I/O events (which can set both Ev::READ and Ev::WRITE bits).


Periodic watcher operation modes

EvPeriodic watcher works in different modes depending on the offset , interval and reschedule_cb parameters.

  1. Absolute timer . In this mode interval = 0 , reschedule_cb = null. This time simply fires at the wallclock time offset and doesn't repeat. It will not adjust when a time jump occurs, that is, if it is to be run at January 1st 2014 then it will run when the system time reaches or surpasses this time.

  2. Repeating interval timer . In this mode interval > 0 , reschedule_cb = null; the watcher will always be scheduled to timeout at the next offset + N * interval time(for some integer N ) and then repeat, regardless of any time jumps.

    This can be used to create timers that do not drift with respect to system time:

    <?php
    $hourly     = EvPeriodic(0, 3600, NULL, function () {
      echo     "once per hour\n";
    });
    ?>
    That doesn't mean there will always be 3600 seconds in between triggers, but only that the callback will be called when the system time shows a full hour( UTC ).

    EvPeriodic will try to run the callback in this mode at the next possible time where time = offset ( mod interval ), regardless of any time jumps.

  3. Manual reschedule mode . In this mode reschedule_cb is a callable .

    interval and offset are both being ignored. Instead, each time the periodic watcher gets scheduled, the reschedule callback ( reschedule_cb ) will be called with the watcher as first, and the current time as second argument.

    This callback must not stop or destroy this or any other periodic watchers, ever, and must not call any event loop functions or methods. To stop it return 1e30 and stop it afterwards. An EvPrepare watcher may be used for this task.

    It must return the next time to trigger, based on the passed time value (that is, the lowest time value larger than or equal to the second argument). It will usually be called just before the callback will be triggered, but might be called at other times, too.

    Example #1 Using reschedule callback

    <?php
    // Tick each 10.5 seconds

    function reschedule_cb ($watcher, $now) {
       return     $now + (10.5. - fmod($now, 10.5));
    }

    $w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
       echo     time(), PHP_EOL;
    });

    Ev::run();
    ?>


The Ev class

(PECL ev >= 0.2.0)

简介

Ev is a static class providing access to the default loop and to some common operations.

类摘要

final Ev {
/* Constants */
const int FLAG_AUTO = 0 ;
const int FLAG_NOENV = 16777216 ;
const int FLAG_FORKCHECK = 33554432 ;
const int FLAG_NOINOTIFY = 1048576 ;
const int FLAG_SIGNALFD = 2097152 ;
const int FLAG_NOSIGMASK = 4194304 ;
const int RUN_NOWAIT = 1 ;
const int RUN_ONCE = 2 ;
const int BREAK_CANCEL = 0 ;
const int BREAK_ONE = 1 ;
const int BREAK_ALL = 2 ;
const int MINPRI = -2 ;
const int MAXPRI = 2 ;
const int READ = 1 ;
const int WRITE = 2 ;
const int TIMER = 256 ;
const int PERIODIC = 512 ;
const int SIGNAL = 1024 ;
const int CHILD = 2048 ;
const int STAT = 4096 ;
const int IDLE = 8192 ;
const int PREPARE = 16384 ;
const int CHECK = 32768 ;
const int EMBED = 65536 ;
const int CUSTOM = 16777216 ;
const int ERROR = 2147483648 ;
const int BACKEND_SELECT = 1 ;
const int BACKEND_POLL = 2 ;
const int BACKEND_EPOLL = 4 ;
const int BACKEND_KQUEUE = 8 ;
const int BACKEND_DEVPOLL = 16 ;
const int BACKEND_PORT = 32 ;
const int BACKEND_ALL = 63 ;
const int BACKEND_MASK = 65535 ;
/* 方法 */
final public static backend ( ) : int
final public static depth ( ) : int
final public static embeddableBackends ( ) : int
final public static feedSignal ( int $signum ) : void
final public static feedSignalEvent ( int $signum ) : void
final public static iteration ( ) : int
final public static now ( ) : float
final public static nowUpdate ( ) : void
final public static recommendedBackends ( ) : int
final public static resume ( ) : void
final public static run ( int $flags = ? ) : void
final public static sleep ( float $seconds ) : void
final public static stop ( int $how = ? ) : void
final public static supportedBackends ( ) : int
final public static suspend ( ) : void
final public static time ( ) : float
final public static verify ( ) : void
}

预定义常量

Flags passed to create a loop:

Ev::FLAG_AUTO

The default flags value

Ev::FLAG_NOENV

If this flag used(or the program runs setuid or setgid), libev won't look at the environment variable LIBEV_FLAGS . Otherwise(by default), LIBEV_FLAGS will override the flags completely if it is found. Useful for performance tests and searching for bugs.

Ev::FLAG_FORKCHECK

Makes libev check for a fork in each iteration, instead of calling EvLoop::fork() manually. This works by calling getpid() on every iteration of the loop, and thus this might slow down the event loop with lots of loop iterations, but usually is not noticeable. This flag setting cannot be overridden or specified in the LIBEV_FLAGS environment variable.

Ev::FLAG_NOINOTIFY

When this flag is specified, libev won't attempt to use the inotify API for its » ev_stat watchers. The flag can be useful to conserve inotify file descriptors, as otherwise each loop using ev_stat watchers consumes one inotify handle.

Ev::FLAG_SIGNALFD

When this flag is specified, libev will attempt to use the signalfd API for its » ev_signal (and » ev_child ) watchers. This API delivers signals synchronously, which makes it both faster and might make it possible to get the queued signal data. It can also simplify signal handling with threads, as long as signals are properly blocked in threads. Signalfd will not be used by default.

Ev::FLAG_NOSIGMASK

When this flag is specified, libev will avoid to modify the signal mask. Specifically, this means having to make sure signals are unblocked before receiving them.

This behaviour is useful for custom signal handling, or handling signals only in specific threads.

Flags passed to Ev::run() , or EvLoop::run()

Ev::RUN_NOWAIT

Means that event loop will look for new events, will handle those events and any already outstanding ones, but will not wait and block the process in case there are no events and will return after one iteration of the loop. This is sometimes useful to poll and handle new events while doing lengthy calculations, to keep the program responsive.

Ev::RUN_ONCE

Means that event loop will look for new events (waiting if necessary) and will handle those and any already outstanding ones. It will block the process until at least one new event arrives (which could be an event internal to libev itself, so there is no guarantee that a user-registered callback will be called), and will return after one iteration of the loop.

Flags passed to Ev::stop() , or EvLoop::stop()

Ev::BREAK_CANCEL

Cancel the break operation.

Ev::BREAK_ONE

Makes the innermost Ev::run() (or EvLoop::run() ) call return.

Ev::BREAK_ALL

Makes all nested Ev::run() (or EvLoop::run() ) calls return.

Watcher priorities:

Ev::MINPRI

Minimum allowed watcher priority.

Ev::MAXPRI

Maximum allowed watcher priority.

Bit masks of (received) events:

Ev::READ

The file descriptor in the EvIo watcher has become readable.

Ev::WRITE

The file descriptor in the EvIo watcher has become writable.

Ev::TIMER

EvTimer watcher has been timed out.

Ev::PERIODIC

EvPeriodic watcher has been timed out.

Ev::SIGNAL

A signal specified in EvSignal::__construct() has been received.

Ev::CHILD

The pid specified in EvChild::__construct() has received a status change.

Ev::STAT

The path specified in EvStat watcher changed its attributes.

Ev::IDLE

EvIdle watcher works when there is nothing to do with other watchers.

Ev::PREPARE

All EvPrepare watchers are invoked just before Ev::run() starts. Thus, EvPrepare watchers are the last watchers invoked before the event loop sleeps or polls for new events.

Ev::CHECK

All EvCheck watchers are queued just after Ev::run() has gathered the new events, but before it queues any callbacks for any received events. Thus, EvCheck watchers will be invoked before any other watchers of the same or lower priority within an event loop iteration.

Ev::EMBED

The embedded event loop specified in the EvEmbed watcher needs attention.

Ev::CUSTOM

Not ever sent(or otherwise used) by libev itself, but can be freely used by libev users to signal watchers (e.g. via EvWatcher::feed() ).

Ev::ERROR

An unspecified error has occurred, the watcher has been stopped. This might happen because the watcher could not be properly started because libev ran out of memory, a file descriptor was found to be closed or any other problem. Libev considers these application bugs. See also » ANATOMY OF A WATCHER

Backend flags:

Ev::BACKEND_SELECT

select(2) backend

Ev::BACKEND_POLL

poll(2) backend

Ev::BACKEND_EPOLL

Linux-specific epoll(7) backend for both pre- and post-2.6.9 kernels

Ev::BACKEND_KQUEUE

kqueue backend used on most BSD systems. EvEmbed watcher could be used to embed one loop(with kqueue backend) into another. For instance, one can try to create an event loop with kqueue backend and use it for sockets only.

Ev::BACKEND_DEVPOLL

Solaris 8 backend. This is not implemented yet.

Ev::BACKEND_PORT

Solaris 10 event port mechanism with a good scaling.

Ev::BACKEND_ALL

Try all backends(even currupted ones). It's not recommended to use it explicitly. Bitwise operators should be applied here(e.g. Ev::BACKEND_ALL & ~ Ev::BACKEND_KQUEUE ) Use Ev::recommendedBackends() , or don't specify any backends at all.

Ev::BACKEND_MASK

Not a backend, but a mask to select all backend bits from flags value to mask out any backends(e.g. when modifying the LIBEV_FLAGS environment variable).

Note:

For the default loop during module initialization phase Ev registers » ev_loop_fork call by means of pthread_atfork (if available).

Note:

There are methods providing access to the default event loop in Ev class(e.g. Ev::iteration() , Ev::depth() etc.) For custom loops (created with EvLoop::__construct() ) these values may be accessed via corresponding properties and methods of the EvLoop class.

The instance of the default event loop itself can be fetched by means of EvLoop::defaultLoop() method.

Table of Contents

  • Ev::backend — Returns an integer describing the backend used by libev
  • Ev::depth — Returns recursion depth
  • Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops
  • Ev::feedSignal — Feed a signal event info Ev
  • Ev::feedSignalEvent — Feed signal event into the default loop
  • Ev::iteration — Return the number of times the default event loop has polled for new events
  • Ev::now — Returns the time when the last iteration of the default event loop has started
  • Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress
  • Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform
  • Ev::resume — Resume previously suspended default event loop
  • Ev::run — Begin checking for events and calling callbacks for the default loop
  • Ev::sleep — Block the process for the given number of seconds
  • Ev::stop — Stops the default event loop
  • Ev::supportedBackends — Returns the set of backends supported by current libev configuration
  • Ev::suspend — Suspend the default event loop
  • Ev::time — Returns the current time in fractional seconds since the epoch
  • Ev::verify — Performs internal consistency checks(for debugging)


Returns an integer describing the backend used by libev

  • ? Ev
  • Ev::depth ?
  • PHP Manual
  • Ev
  • Returns an integer describing the backend used by libev

Ev::backend

(PECL ev >= 0.2.0)

Ev::backend — Returns an integer describing the backend used by libev

说明

final public static Ev::backend ( ) : int

Returns an integer describing the backend used by libev . See Backend flags

参数

此函数没有参数。

返回值

Returns an integer(bit mask) describing the backend used by libev .

参见

  • EvEmbed
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration
  • Backend flags


Returns recursion depth

  • ? Ev::backend
  • Ev::embeddableBackends ?
  • PHP Manual
  • Ev
  • Returns recursion depth

Ev::depth

(PECL ev >= 0.2.0)

Ev::depth — Returns recursion depth

说明

final public static Ev::depth ( ) : int

The number of times Ev::run() was entered minus the number of times Ev::run() was exited normally, in other words, the recursion depth. Outside Ev::run() , this number is 0 . In a callback, this number is 1 , unless Ev::run() was invoked recursively (or from another thread), in which case it is higher.

参数

此函数没有参数。

返回值

ev_depth() returns recursion depth of the default loop.

参见

  • Ev::iteration() - Return the number of times the default event loop has polled for new events


Returns the set of backends that are embeddable in other event loops

  • ? Ev::depth
  • Ev::feedSignal ?
  • PHP Manual
  • Ev
  • Returns the set of backends that are embeddable in other event loops

Ev::embeddableBackends

(PECL ev >= 0.2.0)

Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops

说明

final public static Ev::embeddableBackends ( ) : int

Returns the set of backends that are embeddable in other event loops.

参数

此函数没有参数。

返回值

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

范例

Example #1 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
 if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
  $embed = new EvEmbed($loop);
 }
}

if (!$socket_loop) {
 $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

参见

  • EvEmbed
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration
  • Backend flags
  • Examples


Feed a signal event info Ev

  • ? Ev::embeddableBackends
  • Ev::feedSignalEvent ?
  • PHP Manual
  • Ev
  • Feed a signal event info Ev

Ev::feedSignal

(PECL ev >= 0.2.0)

Ev::feedSignal — Feed a signal event info Ev

说明

final public static Ev::feedSignal ( int $signum ) : void

Simulates a signal receive. It is safe to call this function at any time, from any context, including signal handlers or random threads. Its main use is to customise signal handling in the process.

Unlike Ev::feedSignalEvent() , this works regardless of which loop has registered the signal.

参数

signum

Signal number. See signal(7) man page for detals. You can use constants exported by pcntl extension.

返回值

没有返回值。

参见

  • Ev::feedSignalEvent() - Feed signal event into the default loop


Feed signal event into the default loop

  • ? Ev::feedSignal
  • Ev::iteration ?
  • PHP Manual
  • Ev
  • Feed signal event into the default loop

Ev::feedSignalEvent

(No version information available, might only be in Git)

Ev::feedSignalEvent — Feed signal event into the default loop

说明

final public static Ev::feedSignalEvent ( int $signum ) : void

Feed signal event into the default loop. Ev will react to this call as if the signal specified by signal had occurred.

参数

signum

Signal number. See signal(7) man page for detals. See also constants exported by pcntl extension.

返回值

没有返回值。

参见

  • Ev::feedSignal() - Feed a signal event info Ev


Return the number of times the default event loop has polled for new events

  • ? Ev::feedSignalEvent
  • Ev::now ?
  • PHP Manual
  • Ev
  • Return the number of times the default event loop has polled for new events

Ev::iteration

(PECL ev >= 0.2.0)

Ev::iteration — Return the number of times the default event loop has polled for new events

说明

final public static Ev::iteration ( ) : int

Return the number of times the event loop has polled for new events. Sometimes useful as a generation counter.

参数

此函数没有参数。

返回值

Returns number of polls of the default event loop.

参见

  • Ev::depth() - Returns recursion depth


Returns the time when the last iteration of the default event loop has started

  • ? Ev::iteration
  • Ev::nowUpdate ?
  • PHP Manual
  • Ev
  • Returns the time when the last iteration of the default event loop has started

Ev::now

(PECL ev >= 0.2.0)

Ev::now — Returns the time when the last iteration of the default event loop has started

说明

final public static Ev::now ( ) : float

Returns the time when the last iteration of the default event loop has started. This is the time that timers( EvTimer and EvPeriodic ) are based on, and referring to it is usually faster then calling Ev::time() .

参数

此函数没有参数。

返回值

Returns number of seconds(fractional) representing the time when the last iteration of the default event loop has started.

参见

  • Ev::nowUpdate() - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress


Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress

  • ? Ev::now
  • Ev::recommendedBackends ?
  • PHP Manual
  • Ev
  • Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress

Ev::nowUpdate

(PECL ev >= 0.2.0)

Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress

说明

final public static Ev::nowUpdate ( ) : void

Establishes the current time by querying the kernel, updating the time returned by Ev::now() in the progress. This is a costly operation and is usually done automatically within Ev::run() .

This method is rarely useful, but when some event callback runs for a very long time without entering the event loop, updating libev 's consideration of the current time is a good idea.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • Ev::now() - Returns the time when the last iteration of the default event loop has started


Returns a bit mask of recommended backends for current platform

  • ? Ev::nowUpdate
  • Ev::resume ?
  • PHP Manual
  • Ev
  • Returns a bit mask of recommended backends for current platform

Ev::recommendedBackends

(PECL ev >= 0.2.0)

Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform

说明

final public static Ev::recommendedBackends ( ) : int

Returns the set of all backends compiled into this binary of libev and also recommended for this platform, meaning it will work for most file descriptor types. This set is often smaller than the one returned by ev_supported_backends() , as for example kqueue is broken on most BSD systems and will not be auto-detected unless it is requested explicitly. This is the set of backends that libev will probe no backends specified explicitly.

参数

此函数没有参数。

返回值

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

范例

Example #1 Embedding one loop into another

<?php
/*
* Try to get an embeddable event loop and embed it into the default event loop.
* If it is impossible, use the default
* loop. The default loop is stored in $loop_hi, while the embeddable loop is
* stored in $loop_lo(which is $loop_hi in the case no embeddable loop can be
* used).
*
* Sample translated to PHP
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop_hi = EvLoop::defaultLoop();
$loop_lo = NULL;
$embed   = NULL;

/*
* See if there is a chance of getting one that works
* (flags' value of 0 means autodetection)
*/
$loop_lo = Ev::embeddableBackends() & Ev::recommendedBackends()
 ? new EvLoop(Ev::embeddableBackends() & Ev::recommendedBackends())
 : 0;

if ($loop_lo) {
 $embed = new EvEmbed($loop_lo, function () {});
} else {
 $loop_lo = $loop_hi;
}
?>

参见

  • EvEmbed
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration
  • Backend flags
  • Examples


Resume previously suspended default event loop

  • ? Ev::recommendedBackends
  • Ev::run ?
  • PHP Manual
  • Ev
  • Resume previously suspended default event loop

Ev::resume

(PECL ev >= 0.2.0)

Ev::resume — Resume previously suspended default event loop

说明

final public static Ev::resume ( ) : void

Ev::suspend() and Ev::resume() methods suspend and resume a loop correspondingly.

All timer watchers will be delayed by the time spend between suspend and resume , and all periodic watchers will be rescheduled(that is, they will lose any events that would have occurred while suspended).

After calling Ev::suspend() it is not allowed to call any function on the given loop other than Ev::resume() . Also it is not allowed to call Ev::resume() without a previous call to Ev::suspend() .

Calling suspend / resume has the side effect of updating the event loop time(see Ev::nowUpdate() ).

参数

此函数没有参数。

返回值

没有返回值。

参见

  • Ev::suspend() - Suspend the default event loop


Begin checking for events and calling callbacks for the default loop

  • ? Ev::resume
  • Ev::sleep ?
  • PHP Manual
  • Ev
  • Begin checking for events and calling callbacks for the default loop

Ev::run

(PECL ev >= 0.2.0)

Ev::run — Begin checking for events and calling callbacks for the default loop

说明

final public static Ev::run ( int $flags = ? ) : void

Begin checking for events and calling callbacks for the default loop . Returns when a callback calls Ev::stop() method, or the flags are nonzero(in which case the return value is true) or when there are no active watchers which reference the loop( EvWatcher::keepalive() is true), in which case the return value will be false. The return value can generally be interpreted as if true, there is more work left to do .

参数

flags

Optional parameter flags can be one of the following:

List for possible values of flags
flags | Description
0 | The default behavior described above
Ev::RUN_ONCE | Block at most one(wait, but don't loop)
Ev::RUN_NOWAIT | Don't block at all(fetch/handle events, but don't wait)

See the run flag constants .

返回值

没有返回值。

参见

  • Ev::stop() - Stops the default event loop
  • EvLoop::run() - Begin checking for events and calling callbacks for the loop


Block the process for the given number of seconds

  • ? Ev::run
  • Ev::stop ?
  • PHP Manual
  • Ev
  • Block the process for the given number of seconds

Ev::sleep

(PECL ev >= 0.2.0)

Ev::sleep — Block the process for the given number of seconds

说明

final public static Ev::sleep ( float $seconds ) : void

Block the process for the given number of seconds.

参数

seconds

Fractional number of seconds

返回值

没有返回值。


Stops the default event loop

  • ? Ev::sleep
  • Ev::supportedBackends ?
  • PHP Manual
  • Ev
  • Stops the default event loop

Ev::stop

(PECL ev >= 0.2.0)

Ev::stop — Stops the default event loop

说明

final public static Ev::stop ( int $how = ? ) : void

Stops the default event loop

参数

how

One of Ev::BREAK_* constants .

返回值

没有返回值。

参见

  • Ev::run() - Begin checking for events and calling callbacks for the default loop


Returns the set of backends supported by current libev configuration

  • ? Ev::stop
  • Ev::suspend ?
  • PHP Manual
  • Ev
  • Returns the set of backends supported by current libev configuration

Ev::supportedBackends

(PECL ev >= 0.2.0)

Ev::supportedBackends — Returns the set of backends supported by current libev configuration

说明

final public static Ev::supportedBackends ( ) : int

Returns the set of backends supported by current libev configuration.

参数

此函数没有参数。

返回值

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

范例

Example #1 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
 if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
  $embed = new EvEmbed($loop);
 }
}

if (!$socket_loop) {
 $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

参见

  • EvEmbed
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops
  • Backend flags
  • Examples


Suspend the default event loop

  • ? Ev::supportedBackends
  • Ev::time ?
  • PHP Manual
  • Ev
  • Suspend the default event loop

Ev::suspend

(PECL ev >= 0.2.0)

Ev::suspend — Suspend the default event loop

说明

final public static Ev::suspend ( ) : void

Ev::suspend() and Ev::resume() methods suspend and resume the default loop correspondingly.

All timer watchers will be delayed by the time spend between suspend and resume , and all periodic watchers will be rescheduled(that is, they will lose any events that would have occurred while suspended).

After calling Ev::suspend() it is not allowed to call any function on the given loop other than Ev::resume() . Also it is not allowed to call Ev::resume() without a previous call to Ev::suspend() .

参数

此函数没有参数。

返回值

没有返回值。

参见

  • Ev::resume() - Resume previously suspended default event loop


Returns the current time in fractional seconds since the epoch

  • ? Ev::suspend
  • Ev::verify ?
  • PHP Manual
  • Ev
  • Returns the current time in fractional seconds since the epoch

Ev::time

(PECL ev >= 0.2.0)

Ev::time — Returns the current time in fractional seconds since the epoch

说明

final public static Ev::time ( ) : float

Returns the current time in fractional seconds since the epoch. Consider using Ev::now()

参数

此函数没有参数。

返回值

Returns the current time in fractional seconds since the epoch.

参见

  • Ev::now() - Returns the time when the last iteration of the default event loop has started


Performs internal consistency checks(for debugging)

  • ? Ev::time
  • EvCheck ?
  • PHP Manual
  • Ev
  • Performs internal consistency checks(for debugging)

Ev::verify

(PECL ev >= 0.2.0)

Ev::verify — Performs internal consistency checks(for debugging)

说明

final public static Ev::verify ( ) : void

Performs internal consistency checks(for debugging libev ) and abort the program if any data structures were found to be corrupted.

参数

此函数没有参数。

返回值

没有返回值。


The EvCheck class

(PECL ev >= 0.2.0)

简介

EvPrepare and EvCheck watchers are usually used in pairs. EvPrepare watchers get invoked before the process blocks, EvCheck afterwards.

It is not allowed to call EvLoop::run() or similar methods or functions that enter the current event loop from either EvPrepare or EvCheck watchers. Other loops than the current one are fine, however. The rationale behind this is that one don't need to check for recursion in those watchers, i.e. the sequence will always be: EvPrepare -> blocking -> EvCheck , so having a watcher of each kind they will always be called in pairs bracketing the blocking call.

The main purpose is to integrate other event mechanisms into libev and their use is somewhat advanced. They could be used, for example, to track variable changes, implement custom watchers, integrate net-snmp or a coroutine library and lots more. They are also occasionally useful to cache some data and want to flush it before blocking.

It is recommended to give EvCheck watchers highest( Ev::MAXPRI ) priority, to ensure that they are being run before any other watchers after the poll (this doesn't matter for EvPrepare watchers).

Also, EvCheck watchers should not activate/feed events. While libev fully supports this, they might get executed before other EvCheck watchers did their job.

类摘要

EvCheck extends EvWatcher {
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public __construct ( callable $callback , mixed $data = ? , int $priority = ? )
final public static createStopped ( string $callback , string $data = ? , string $priority = ? ) : object
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Table of Contents

  • EvCheck::__construct — Constructs the EvCheck watcher object
  • EvCheck::createStopped — Create instance of a stopped EvCheck watcher


Constructs the EvCheck watcher object

  • ? EvCheck
  • EvCheck::createStopped ?
  • PHP Manual
  • EvCheck
  • Constructs the EvCheck watcher object

EvCheck::__construct

(PECL ev >= 0.2.0)

EvCheck::__construct — Constructs the EvCheck watcher object

说明

public EvCheck::__construct ( callable $callback , mixed $data = ? , int $priority = ? )

Constructs the EvCheck watcher object.

参数

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvCheck object on success.

参见

  • EvPrepare
  • EvLoop::check() - Creates EvCheck object associated with the current event loop instance


Create instance of a stopped EvCheck watcher

  • ? EvCheck::__construct
  • EvChild ?
  • PHP Manual
  • EvCheck
  • Create instance of a stopped EvCheck watcher

EvCheck::createStopped

(PECL ev >= 0.2.0)

EvCheck::createStopped — Create instance of a stopped EvCheck watcher

说明

final public static EvCheck::createStopped ( string $callback , string $data = ? , string $priority = ? ) : object

Create instance of a stopped EvCheck watcher

参数

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvCheck object on success.

参见

  • EvPrepare


The EvChild class

(PECL ev >= 0.2.0)

简介

EvChild watchers trigger when the process receives a SIGCHLD in response to some child status changes (most typically when a child dies or exits). It is permissible to install an EvChild watcher after the child has been forked(which implies it might have already exited), as long as the event loop isn't entered(or is continued from a watcher), i.e. forking and then immediately registering a watcher for the child is fine, but forking and registering a watcher a few event loop iterations later or in the next callback invocation is not.

It is allowed to register EvChild watchers in the default loop only.

类摘要

EvChild extends EvWatcher {
/* 属性 */
public $pid ;
public $rpid ;
public $rstatus ;
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public __construct ( int $pid , bool $trace , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( int $pid , bool $trace , callable $callback , mixed $data = ? , int $priority = ? ) : object
public set ( int $pid , bool $trace ) : void
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

属性

pid

Readonly . The process ID this watcher watches out for, or 0 , meaning any process ID.

rpid

Readonly .The process ID that detected a status change.

rstatus

Readonly . The process exit status caused by rpid .

Table of Contents

  • EvChild::__construct — Constructs the EvChild watcher object
  • EvChild::createStopped — Create instance of a stopped EvCheck watcher
  • EvChild::set — Configures the watcher


Constructs the EvChild watcher object

  • ? EvChild
  • EvChild::createStopped ?
  • PHP Manual
  • EvChild
  • Constructs the EvChild watcher object

EvChild::__construct

(PECL ev >= 0.2.0)

EvChild::__construct — Constructs the EvChild watcher object

说明

public EvChild::__construct ( int $pid , bool $trace , callable $callback , mixed $data = null , int $priority = 0 )

Constructs the EvChild watcher object.

Call the callback when a status change for process ID pid (or any PID if pid is 0 ) has been received(a status change happens when the process terminates or is killed, or, when trace is true, additionally when it is stopped or continued). In other words, when the process receives a SIGCHLD , Ev will fetch the outstanding exit/wait status for all changed/zombie children and call the callback.

It is valid to install a child watcher after an EvChild has exited but before the event loop has started its next iteration. For example, first one calls fork , then the new child process might exit, and only then an EvChild watcher is installed in the parent for the new PID .

You can access both exit/tracing status and pid by using the rstatus and rpid properties of the watcher object.

The number of PID watchers per PID is unlimited. All of them will be called.

The EvChild::createStopped() method doesn't start(activate) the newly created watcher.

参数

pid

Wait for status changes of process PID(or any process if PID is specified as 0 ).

trace

If false, only activate the watcher when the process terminates. Otherwise(true) additionally activate the watcher when the process is stopped or continued.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvChild object on success.

参见

  • EvLoop::child() - Creates EvChild object associated with the current event loop


Create instance of a stopped EvCheck watcher

  • ? EvChild::__construct
  • EvChild::set ?
  • PHP Manual
  • EvChild
  • Create instance of a stopped EvCheck watcher

EvChild::createStopped

(PECL ev >= 0.2.0)

EvChild::createStopped — Create instance of a stopped EvCheck watcher

说明

final public static EvChild::createStopped ( int $pid , bool $trace , callable $callback , mixed $data = ? , int $priority = ? ) : object

The same as EvChild::__construct() , but doesn't start the watcher automatically.

参数

pid

The same as for EvChild::__construct()

trace

The same as for EvChild::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

参见

  • EvChild::__construct() - Constructs the EvChild watcher object
  • EvLoop::child() - Creates EvChild object associated with the current event loop


Configures the watcher

  • ? EvChild::createStopped
  • EvEmbed ?
  • PHP Manual
  • EvChild
  • Configures the watcher

EvChild::set

(PECL ev >= 0.2.0)

EvChild::set — Configures the watcher

说明

public EvChild::set ( int $pid , bool $trace ) : void

参数

pid

The same as for EvChild::__construct()

trace

The same as for EvChild::__construct()

返回值

没有返回值。

参见

  • EvChild::__construct() - Constructs the EvChild watcher object


The EvEmbed class

(PECL ev >= 0.2.0)

简介

Used to embed one event loop into another.

类摘要

EvEmbed extends EvWatcher {
/* 属性 */
public $embed ;
/* 方法 */
public __construct ( object $other , callable $callback = ? , mixed $data = ? , int $priority = ? )
final public static createStopped ( object $other , callable $callback = ? , mixed $data = ? , int $priority = ? ) : void
public set ( object $other ) : void
public sweep ( ) : void
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

属性

is_active

data

is_pending

priority

embed

Table of Contents

  • EvEmbed::__construct — Constructs the EvEmbed object
  • EvEmbed::createStopped — Create stopped EvEmbed watcher object
  • EvEmbed::set — Configures the watcher
  • EvEmbed::sweep — Make a single, non-blocking sweep over the embedded loop


Constructs the EvEmbed object

  • ? EvEmbed
  • EvEmbed::createStopped ?
  • PHP Manual
  • EvEmbed
  • Constructs the EvEmbed object

EvEmbed::__construct

(PECL ev >= 0.2.0)

EvEmbed::__construct — Constructs the EvEmbed object

说明

public EvEmbed::__construct ( object $other , callable $callback = ? , mixed $data = ? , int $priority = ? )

This is a rather advanced watcher type that lets to embed one event loop into another(currently only IO events are supported in the embedded loop, other types of watchers might be handled in a delayed or incorrect fashion and must not be used).

See » the libev documentation for details.

This watcher is most useful on BSD systems without working kqueue to still be able to handle a large number of sockets. See example below.

参数

other

Instance of EvLoop . The loop to embed, this loop must be embeddable(see Ev::embeddableBackends() ).

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvEmbed object on success.

范例

Example #1 Embedding loop created with kqueue backend into the default loop

<?php
/*
 * Check if kqueue is available but not recommended and create a kqueue backend
 * for use with sockets (which usually work with any kqueue implementation).
 * Store the kqueue/socket-only event loop in loop_socket. (One might optionally
 * use EVFLAG_NOENV, too)
 *
 * Example borrowed from
 * http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
 */
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
    if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
        $embed = new EvEmbed($loop);
    }
}

if (!$socket_loop) {
    $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

参见

  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops


Create stopped EvEmbed watcher object

  • ? EvEmbed::__construct
  • EvEmbed::set ?
  • PHP Manual
  • EvEmbed
  • Create stopped EvEmbed watcher object

EvEmbed::createStopped

(PECL ev >= 0.2.0)

EvEmbed::createStopped — Create stopped EvEmbed watcher object

说明

final public static EvEmbed::createStopped ( object $other , callable $callback = ? , mixed $data = ? , int $priority = ? ) : void

The same as EvEmbed::__construct() , but doesn't start the watcher automatically.

参数

other

The same as for EvEmbed::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns stopped EvEmbed object on success.

参见

  • EvEmbed::__construct() - Constructs the EvEmbed object
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops


Configures the watcher

  • ? EvEmbed::createStopped
  • EvEmbed::sweep ?
  • PHP Manual
  • EvEmbed
  • Configures the watcher

EvEmbed::set

(PECL ev >= 0.2.0)

EvEmbed::set — Configures the watcher

说明

public EvEmbed::set ( object $other ) : void

Configures the watcher to use other event loop object.

参数

other

The same as for EvEmbed::__construct()

返回值

没有返回值。


Make a single, non-blocking sweep over the embedded loop

  • ? EvEmbed::set
  • EvFork ?
  • PHP Manual
  • EvEmbed
  • Make a single, non-blocking sweep over the embedded loop

EvEmbed::sweep

(PECL ev >= 0.2.0)

EvEmbed::sweep — Make a single, non-blocking sweep over the embedded loop

说明

public EvEmbed::sweep ( ) : void

Make a single, non-blocking sweep over the embedded loop. Works similarly to the following, but in the most appropriate way for embedded loops:

<?php
$other->start(Ev::RUN_NOWAIT);
?>

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EvWatcher::start() - Starts the watcher


The EvFork class

(PECL ev >= 0.2.0)

简介

Fork watchers are called when a fork() was detected (usually because whoever signalled libev about it by calling EvLoop::fork() ). The invocation is done before the event loop blocks next and before EvCheck watchers are being called, and only in the child after the fork. Note, that if whoever calling EvLoop::fork() calls it in the wrong process, the fork handlers will be invoked, too.

类摘要

EvFork extends EvWatcher {
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public __construct ( callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( string $callback , string $data = ? , string $priority = ? ) : object
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Table of Contents

  • EvFork::__construct — Constructs the EvFork watcher object
  • EvFork::createStopped — Creates a stopped instance of EvFork watcher class


Constructs the EvFork watcher object

  • ? EvFork
  • EvFork::createStopped ?
  • PHP Manual
  • EvFork
  • Constructs the EvFork watcher object

EvFork::__construct

(PECL ev >= 0.2.0)

EvFork::__construct — Constructs the EvFork watcher object

说明

public EvFork::__construct ( callable $callback , mixed $data = null , int $priority = 0 )

Constructs the EvFork watcher object and starts the watcher automatically.

参数

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvFork object on success.

参见

  • EvLoop::fork() - Creates EvFork watcher object associated with the current event loop instance
  • EvCheck


Creates a stopped instance of EvFork watcher class

  • ? EvFork::__construct
  • EvIdle ?
  • PHP Manual
  • EvFork
  • Creates a stopped instance of EvFork watcher class

EvFork::createStopped

(PECL ev >= 0.2.0)

EvFork::createStopped — Creates a stopped instance of EvFork watcher class

说明

final public static EvFork::createStopped ( string $callback , string $data = ? , string $priority = ? ) : object

The same as EvFork::__construct() , but doesn't start the watcher automatically.

参数

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvFork(stopped) object on success.

参见

  • EvFork::__construct() - Constructs the EvFork watcher object


The EvIdle class

(PECL ev >= 0.2.0)

简介

EvIdle watchers trigger events when no other events of the same or higher priority are pending ( EvPrepare , EvCheck and other EvIdle watchers do not count as receiving events ).

Thus, as long as the process is busy handling sockets or timeouts(or even signals) of the same or higher priority it will not be triggered. But when the process is in idle(or only lower-priority watchers are pending), the EvIdle watchers are being called once per event loop iteration - until stopped, that is, or the process receives more events and becomes busy again with higher priority stuff.

Apart from keeping the process non-blocking(which is a useful on its own sometimes), EvIdle watchers are a good place to do "pseudo-background processing" , or delay processing stuff to after the event loop has handled all outstanding events.

The most noticeable effect is that as long as any idle watchers are active, the process will not block when waiting for new events.

类摘要

EvIdle extends EvWatcher {
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public __construct ( callable $callback , mixed $data = ? , int $priority = ? )
final public static createStopped ( string $callback , mixed $data = ? , int $priority = ? ) : object
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Table of Contents

  • EvIdle::__construct — Constructs the EvIdle watcher object
  • EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object


Constructs the EvIdle watcher object

  • ? EvIdle
  • EvIdle::createStopped ?
  • PHP Manual
  • EvIdle
  • Constructs the EvIdle watcher object

EvIdle::__construct

(PECL ev >= 0.2.0)

EvIdle::__construct — Constructs the EvIdle watcher object

说明

public EvIdle::__construct ( callable $callback , mixed $data = ? , int $priority = ? )

Constructs the EvIdle watcher object and starts the watcher automatically.

参数

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvIdle object on success.

参见

  • EvIdle::createStopped() - Creates instance of a stopped EvIdle watcher object
  • EvLoop::idle() - Creates EvIdle watcher object associated with the current event loop instance


Creates instance of a stopped EvIdle watcher object

  • ? EvIdle::__construct
  • EvIo ?
  • PHP Manual
  • EvIdle
  • Creates instance of a stopped EvIdle watcher object

EvIdle::createStopped

(PECL ev >= 0.2.0)

EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object

说明

final public static EvIdle::createStopped ( string $callback , mixed $data = ? , int $priority = ? ) : object

The same as EvIdle::__construct() , but doesn't start the watcher automatically.

参数

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvIdle object on success.

参见

  • EvIdle::__construct() - Constructs the EvIdle watcher object
  • EvLoop::idle() - Creates EvIdle watcher object associated with the current event loop instance


The EvIo class

(PECL ev >= 0.2.0)

简介

EvIo watchers check whether a file descriptor(or socket, or a stream castable to numeric file descriptor) is readable or writable in each iteration of the event loop, or, more precisely, when reading would not block the process and writing would at least be able to write some data. This behaviour is called level-triggering because events are kept receiving as long as the condition persists. To stop receiving events just stop the watcher.

The number of read and/or write event watchers per fd is unlimited. Setting all file descriptors to non-blocking mode is also usually a good idea(but not required).

Another thing to watch out for is that it is quite easy to receive false readiness notifications, i.e. the callback might be called with Ev::READ but a subsequent read() will actually block because there is no data. It is very easy to get into this situation. Thus it is best to always use non-blocking I/O: An extra read() returning EAGAIN (or similar) is far preferable to a program hanging until some data arrives.

If for some reason it is impossible to run the fd in non-blocking mode, then separately re-test whether a file descriptor is really ready. Some people additionally use SIGALRM and an interval timer, just to be sure thry won't block infinitely.

Always consider using non-blocking mode.

类摘要

EvIo extends EvWatcher {
/* 属性 */
public $fd ;
public $events ;
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public __construct ( mixed $fd , int $events , callable $callback , mixed $data = ? , int $priority = ? )
final public static createStopped ( mixed $fd , int $events , callable $callback , mixed $data = null , int $priority = 0 ) : EvIo
public set ( mixed $fd , int $events ) : void
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

属性

fd

events

Table of Contents

  • EvIo::__construct — Constructs EvIo watcher object
  • EvIo::createStopped — Create stopped EvIo watcher object
  • EvIo::set — Configures the watcher


Constructs EvIo watcher object

  • ? EvIo
  • EvIo::createStopped ?
  • PHP Manual
  • EvIo
  • Constructs EvIo watcher object

EvIo::__construct

(PECL ev >= 0.2.0)

EvIo::__construct — Constructs EvIo watcher object

说明

public EvIo::__construct ( mixed $fd , int $events , callable $callback , mixed $data = ? , int $priority = ? )

Constructs EvIo watcher object and starts the watcher automatically.

参数

fd

Can be a stream opened with fopen() or similar functions, numeric file descriptor, or socket.

events

Ev::READ and/or Ev::WRITE . See the bit masks .

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvIo object on success.

参见

  • EvIo::createStopped() - Create stopped EvIo watcher object
  • EvLoop::io() - Create EvIo watcher object associated with the current event loop instance


Create stopped EvIo watcher object

  • ? EvIo::__construct
  • EvIo::set ?
  • PHP Manual
  • EvIo
  • Create stopped EvIo watcher object

EvIo::createStopped

(PECL ev >= 0.2.0)

EvIo::createStopped — Create stopped EvIo watcher object

说明

final public static EvIo::createStopped ( mixed $fd , int $events , callable $callback , mixed $data = null , int $priority = 0 ) : EvIo

The same as EvIo::__construct() , but doesn't start the watcher automatically.

参数

fd

The same as for EvIo::__construct()

events

The same as for EvIo::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvIo object on success.

参见

  • EvIo::__construct() - Constructs EvIo watcher object
  • EvLoop::io() - Create EvIo watcher object associated with the current event loop instance


Configures the watcher

  • ? EvIo::createStopped
  • EvLoop ?
  • PHP Manual
  • EvIo
  • Configures the watcher

EvIo::set

(PECL ev >= 0.2.0)

EvIo::set — Configures the watcher

说明

public EvIo::set ( mixed $fd , int $events ) : void

Configures the EvIo watcher

参数

fd

The same as for EvIo::__construct()

events

The same as for EvIo::__construct()

返回值

没有返回值。


The EvLoop class

(PECL ev >= 0.2.0)

简介

Represents an event loop that is always distinct from the default loop . Unlike the default loop , it cannot handle EvChild watchers.

Having threads we have to create a loop per thread, and use the default loop in the parent thread.

The default event loop is initialized automatically by Ev . It is accessible via methods of the Ev class, or via EvLoop::defaultLoop() method.

类摘要

final EvLoop {
/* 属性 */
public $data ;
public $backend ;
public $is_default_loop ;
public $iteration ;
public $pending ;
public $io_interval ;
public $timeout_interval ;
public $depth ;
/* 方法 */
public backend ( ) : int
final public check ( string $callback , string $data = ? , string $priority = ? ) : EvCheck
final public child ( string $pid , string $trace , string $callback , string $data = ? , string $priority = ? ) : EvChild
public __construct ( int $flags = ? , mixed $data = NULL , float $io_interval = 0.0 , float $timeout_interval = 0.0 )
public static defaultLoop ( int $flags = Ev::FLAG_AUTO , mixed $data = NULL , float $io_interval = 0. , float $timeout_interval = 0. ) : EvLoop
final public embed ( string $other , string $callback = ? , string $data = ? , string $priority = ? ) : EvEmbed
final public fork ( callable $callback , mixed $data = null , int $priority = 0 ) : EvFork
final public idle ( callable $callback , mixed $data = null , int $priority = 0 ) : EvIdle
public invokePending ( ) : void
final public io ( mixed $fd , int $events , callable $callback , mixed $data = null , int $priority = 0 ) : EvIo
public loopFork ( ) : void
public now ( ) : float
public nowUpdate ( ) : void
final public periodic ( float $offset , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : EvPeriodic
final public prepare ( callable $callback , mixed $data = null , int $priority = 0 ) : EvPrepare
public resume ( ) : void
public run ( int $flags = 0 ) : void
final public signal ( int $signum , callable $callback , mixed $data = null , int $priority = 0 ) : EvSignal
final public stat ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : EvStat
public stop ( int $how = ? ) : void
public suspend ( ) : void
final public timer ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 ) : EvTimer
public verify ( ) : void
}

属性

data

Custom data attached to loop

backend

Readonly . The backend flags indicating the event backend in use.

is_default_loop

Readonly . true if it is the default event loop.

iteration

The current iteration count of the loop. See Ev::iteration()

pending

The number of pending watchers. 0 indicates that there are no watchers pending.

io_interval

Higher io_interval allows libev to spend more time collecting EvIo events, so more events can be handled per iteration, at the cost of increasing latency. Timeouts (both EvPeriodic and EvTimer ) will not be affected. Setting this to a non-zero value will introduce an additional sleep() call into most loop iterations. The sleep time ensures that libev will not poll for EvIo events more often than once per this interval, on average. Many programs can usually benefit by setting the io_interval to a value near 0.1 , which is often enough for interactive servers(not for games). It usually doesn't make much sense to set it to a lower value than 0.01 , as this approaches the timing granularity of most systems.

See also » FUNCTIONS CONTROLLING EVENT LOOPS .

timeout_interval

Higher timeout_interval allows libev to spend more time collecting timeouts, at the expense of increased latency/jitter/inexactness(the watcher callback will be called later). EvIo watchers will not be affected. Setting this to a non-null value will not introduce any overhead in libev . See also » FUNCTIONS CONTROLLING EVENT LOOPS .

depth

The recursion depth. See Ev::depth() .

Table of Contents

  • EvLoop::backend — Returns an integer describing the backend used by libev
  • EvLoop::check — Creates EvCheck object associated with the current event loop instance
  • EvLoop::child — Creates EvChild object associated with the current event loop
  • EvLoop::__construct — Constructs the event loop object
  • EvLoop::defaultLoop — Returns or creates the default event loop
  • EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object
  • EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance
  • EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance
  • EvLoop::invokePending — Invoke all pending watchers while resetting their pending state
  • EvLoop::io — Create EvIo watcher object associated with the current event loop instance
  • EvLoop::loopFork — Must be called after a fork
  • EvLoop::now — Returns the current "event loop time"
  • EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress
  • EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance
  • EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance
  • EvLoop::resume — Resume previously suspended default event loop
  • EvLoop::run — Begin checking for events and calling callbacks for the loop
  • EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance
  • EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance
  • EvLoop::stop — Stops the event loop
  • EvLoop::suspend — Suspend the loop
  • EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance
  • EvLoop::verify — Performs internal consistency checks(for debugging)


Returns an integer describing the backend used by libev

  • ? EvLoop
  • EvLoop::check ?
  • PHP Manual
  • EvLoop
  • Returns an integer describing the backend used by libev

EvLoop::backend

(PECL ev >= 0.2.0)

EvLoop::backend — Returns an integer describing the backend used by libev

说明

public EvLoop::backend ( ) : int

The same as Ev::backend() , but for the loop instance.

参数

此函数没有参数。

返回值

Returns an integer describing the backend used by libev. See Ev::backend() .

参见

  • Ev::backend() - Returns an integer describing the backend used by libev


Creates EvCheck object associated with the current event loop instance

  • ? EvLoop::backend
  • EvLoop::child ?
  • PHP Manual
  • EvLoop
  • Creates EvCheck object associated with the current event loop instance

EvLoop::check

(PECL ev >= 0.2.0)

EvLoop::check — Creates EvCheck object associated with the current event loop instance

说明

final public EvLoop::check ( string $callback , string $data = ? , string $priority = ? ) : EvCheck

Creates EvCheck object associated with the current event loop instance.

参数

All parameters have the same meaning as for EvCheck::__construct()

返回值

Returns EvCheck object on success.

参见

  • EvCheck::__construct() - Constructs the EvCheck watcher object


Creates EvChild object associated with the current event loop

  • ? EvLoop::check
  • EvLoop::__construct ?
  • PHP Manual
  • EvLoop
  • Creates EvChild object associated with the current event loop

EvLoop::child

(PECL ev >= 0.2.0)

EvLoop::child — Creates EvChild object associated with the current event loop

说明

final public EvLoop::child ( string $pid , string $trace , string $callback , string $data = ? , string $priority = ? ) : EvChild

Creates EvChild object associated with the current event loop.

参数

All parameters have the same meaning as for EvChild::__construct()

返回值

Returns EvChild object on success.

参见

  • EvChild::__construct() - Constructs the EvChild watcher object


Constructs the event loop object

  • ? EvLoop::child
  • EvLoop::defaultLoop ?
  • PHP Manual
  • EvLoop
  • Constructs the event loop object

EvLoop::__construct

(PECL ev >= 0.2.0)

EvLoop::__construct — Constructs the event loop object

说明

public EvLoop::__construct ( int $flags = ? , mixed $data = NULL , float $io_interval = 0.0 , float $timeout_interval = 0.0 )

Constructs the event loop object.

参数

flags

One of the event loop flags

data

Custom data associated with the loop.

io_interval

See io_interval

timeout_interval

See timeout_interval

返回值

Returns new EvLoop object.

参见

  • EvLoop::defaultLoop() - Returns or creates the default event loop


Returns or creates the default event loop

  • ? EvLoop::__construct
  • EvLoop::embed ?
  • PHP Manual
  • EvLoop
  • Returns or creates the default event loop

EvLoop::defaultLoop

(PECL ev >= 0.2.0)

EvLoop::defaultLoop — Returns or creates the default event loop

说明

public static EvLoop::defaultLoop ( int $flags = Ev::FLAG_AUTO , mixed $data = NULL , float $io_interval = 0. , float $timeout_interval = 0. ) : EvLoop

If the default event loop is not created, EvLoop::defaultLoop() creates it with the specified parameters. Otherwise, it just returns the object representing previously created instance ignoring all the parameters.

参数

flags

One of the event loop flags

data

Custom data to associate with the loop.

io_collect_interval

See io_interval

timeout_collect_interval

See timeout_interval

返回值

Returns EvLoop object on success.

参见

  • EvLoop::__construct() - Constructs the event loop object


Creates an instance of EvEmbed watcher associated with the current EvLoop object

  • ? EvLoop::defaultLoop
  • EvLoop::fork ?
  • PHP Manual
  • EvLoop
  • Creates an instance of EvEmbed watcher associated with the current EvLoop object

EvLoop::embed

(PECL ev >= 0.2.0)

EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object

说明

final public EvLoop::embed ( string $other , string $callback = ? , string $data = ? , string $priority = ? ) : EvEmbed

Creates an instance of EvEmbed watcher associated with the current EvLoop object.

参数

All parameters have the same meaning as for EvEmbed::__construct() .

返回值

Returns EvEmbed object on success.

参见

  • EvEmbed::__construct() - Constructs the EvEmbed object


Creates EvFork watcher object associated with the current event loop instance

  • ? EvLoop::embed
  • EvLoop::idle ?
  • PHP Manual
  • EvLoop
  • Creates EvFork watcher object associated with the current event loop instance

EvLoop::fork

(PECL ev >= 0.2.0)

EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance

说明

final public EvLoop::fork ( callable $callback , mixed $data = null , int $priority = 0 ) : EvFork

Creates EvFork watcher object associated with the current event loop instance

参数

All parameters have the same meaning as for EvFork::__construct()

返回值

Returns EvFork object on success.

参见

  • EvFork::__construct() - Constructs the EvFork watcher object


Creates EvIdle watcher object associated with the current event loop instance

  • ? EvLoop::fork
  • EvLoop::invokePending ?
  • PHP Manual
  • EvLoop
  • Creates EvIdle watcher object associated with the current event loop instance

EvLoop::idle

(PECL ev >= 0.2.0)

EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance

说明

final public EvLoop::idle ( callable $callback , mixed $data = null , int $priority = 0 ) : EvIdle

Creates EvIdle watcher object associated with the current event loop instance

参数

All the parameters have the same meaning as for EvIdle::__construct()

返回值

Returns EvIdle object on success.

参见

  • EvIdle::__construct() - Constructs the EvIdle watcher object


Invoke all pending watchers while resetting their pending state

  • ? EvLoop::idle
  • EvLoop::io ?
  • PHP Manual
  • EvLoop
  • Invoke all pending watchers while resetting their pending state

EvLoop::invokePending

(PECL ev >= 0.2.0)

EvLoop::invokePending — Invoke all pending watchers while resetting their pending state

说明

public EvLoop::invokePending ( ) : void

Invoke all pending watchers while resetting their pending state.

参数

此函数没有参数。

返回值

没有返回值。


Create EvIo watcher object associated with the current event loop instance

  • ? EvLoop::invokePending
  • EvLoop::loopFork ?
  • PHP Manual
  • EvLoop
  • Create EvIo watcher object associated with the current event loop instance

EvLoop::io

(PECL ev >= 0.2.0)

EvLoop::io — Create EvIo watcher object associated with the current event loop instance

说明

final public EvLoop::io ( mixed $fd , int $events , callable $callback , mixed $data = null , int $priority = 0 ) : EvIo

Create EvIo watcher object associated with the current event loop instance.

参数

All parameters have the same meaning as for EvIo::__construct()

返回值

Returns EvIo object on success.

参见

  • EvIo::__construct() - Constructs EvIo watcher object


Must be called after a fork

  • ? EvLoop::io
  • EvLoop::now ?
  • PHP Manual
  • EvLoop
  • Must be called after a fork

EvLoop::loopFork

(PECL ev >= 0.2.0)

EvLoop::loopFork — Must be called after a fork

说明

public EvLoop::loopFork ( ) : void

Must be called after a fork in the child, before entering or continuing the event loop. An alternative is to use Ev::FLAG_FORKCHECK which calls this function automatically, at some performance loss (refer to the » libev documentation ).

参数

此函数没有参数。

返回值

没有返回值。


Returns the current "event loop time"

  • ? EvLoop::loopFork
  • EvLoop::nowUpdate ?
  • PHP Manual
  • EvLoop
  • Returns the current "event loop time"

EvLoop::now

(PECL ev >= 0.2.0)

EvLoop::now — Returns the current "event loop time"

说明

public EvLoop::now ( ) : float

Returns the current "event loop time", which is the time the event loop received events and started processing them. This timestamp does not change as long as callbacks are being processed, and this is also the base time used for relative timers. You can treat it as the timestamp of the event occurring(or more correctly, libev finding out about it).

参数

此函数没有参数。

返回值

Returns time of the event loop in (fractional) seconds.

参见

  • Ev::now() - Returns the time when the last iteration of the default event loop has started


Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress

  • ? EvLoop::now
  • EvLoop::periodic ?
  • PHP Manual
  • EvLoop
  • Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress

EvLoop::nowUpdate

(PECL ev >= 0.2.0)

EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress

说明

public EvLoop::nowUpdate ( ) : void

Establishes the current time by querying the kernel, updating the time returned by EvLoop::now() in the progress. This is a costly operation and is usually done automatically within EvLoop::run() .

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EvLoop::now() - Returns the current "event loop time"
  • Ev::nowUpdate() - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress


Creates EvPeriodic watcher object associated with the current event loop instance

  • ? EvLoop::nowUpdate
  • EvLoop::prepare ?
  • PHP Manual
  • EvLoop
  • Creates EvPeriodic watcher object associated with the current event loop instance

EvLoop::periodic

(PECL ev >= 0.2.0)

EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance

说明

final public EvLoop::periodic ( float $offset , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : EvPeriodic

Creates EvPeriodic watcher object associated with the current event loop instance

参数

All parameters have the same maening as for EvPeriodic::__construct()

返回值

Returns EvPeriodic object on success.

参见

  • EvPeriodic::__construct() - Constructs EvPeriodic watcher object


Creates EvPrepare watcher object associated with the current event loop instance

  • ? EvLoop::periodic
  • EvLoop::resume ?
  • PHP Manual
  • EvLoop
  • Creates EvPrepare watcher object associated with the current event loop instance

EvLoop::prepare

(PECL ev >= 0.2.0)

EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance

说明

final public EvLoop::prepare ( callable $callback , mixed $data = null , int $priority = 0 ) : EvPrepare

Creates EvPrepare watcher object associated with the current event loop instance

参数

All parameters have the same maening as for EvPrepare()

返回值

Returns EvPrepare object on success

参见

  • EvPrepare::__construct() - Constructs EvPrepare watcher object


Resume previously suspended default event loop

  • ? EvLoop::prepare
  • EvLoop::run ?
  • PHP Manual
  • EvLoop
  • Resume previously suspended default event loop

EvLoop::resume

(PECL ev >= 0.2.0)

EvLoop::resume — Resume previously suspended default event loop

说明

public EvLoop::resume ( ) : void

EvLoop::suspend() and EvLoop::resume() methods suspend and resume a loop correspondingly.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EvLoop::suspend() - Suspend the loop
  • Ev::resume() - Resume previously suspended default event loop


Begin checking for events and calling callbacks for the loop

  • ? EvLoop::resume
  • EvLoop::signal ?
  • PHP Manual
  • EvLoop
  • Begin checking for events and calling callbacks for the loop

EvLoop::run

(PECL ev >= 0.2.0)

EvLoop::run — Begin checking for events and calling callbacks for the loop

说明

public EvLoop::run ( int $flags = 0 ) : void

Begin checking for events and calling callbacks for the current event loop. Returns when a callback calls Ev::stop() method, or the flags are nonzero(in which case the return value is true) or when there are no active watchers which reference the loop( EvWatcher::keepalive() is true), in which case the return value will be false. The return value can generally be interpreted as if true, there is more work left to do .

参数

flags

Optional parameter flags can be one of the following:

List for possible values of flags
flags | Description
0 | The default behavior described above
Ev::RUN_ONCE | Block at most one(wait, but don't loop)
Ev::RUN_NOWAIT | Don't block at all(fetch/handle events, but don't wait)

See the run flag constants .

返回值

没有返回值。

参见

  • EvLoop::stop() - Stops the event loop
  • Ev::run() - Begin checking for events and calling callbacks for the default loop


Creates EvSignal watcher object associated with the current event loop instance

  • ? EvLoop::run
  • EvLoop::stat ?
  • PHP Manual
  • EvLoop
  • Creates EvSignal watcher object associated with the current event loop instance

EvLoop::signal

(PECL ev >= 0.2.0)

EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance

说明

final public EvLoop::signal ( int $signum , callable $callback , mixed $data = null , int $priority = 0 ) : EvSignal

Creates EvSignal watcher object associated with the current event loop instance

参数

All parameters have the same meaning as for EvSignal::__construct()

返回值

Returns EvSignal object on success

参见

  • EvSignal::__construct() - Constructs EvSignal watcher object


Creates EvStat watcher object associated with the current event loop instance

  • ? EvLoop::signal
  • EvLoop::stop ?
  • PHP Manual
  • EvLoop
  • Creates EvStat watcher object associated with the current event loop instance

EvLoop::stat

(PECL ev >= 0.2.0)

EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance

说明

final public EvLoop::stat ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : EvStat

Creates EvStat watcher object associated with the current event loop instance

参数

All parameters have the same meaning as for EvSignal::__construct()

返回值

Returns EvStat object on success

参见

  • EvSignal::__construct() - Constructs EvSignal watcher object


Stops the event loop

  • ? EvLoop::stat
  • EvLoop::suspend ?
  • PHP Manual
  • EvLoop
  • Stops the event loop

EvLoop::stop

(PECL ev >= 0.2.0)

EvLoop::stop — Stops the event loop

说明

public EvLoop::stop ( int $how = ? ) : void

Stops the event loop

参数

how

One of Ev::BREAK_* constants .

返回值

没有返回值。

参见

  • EvLoop::run() - Begin checking for events and calling callbacks for the loop
  • Ev::stop() - Stops the default event loop


Suspend the loop

  • ? EvLoop::stop
  • EvLoop::timer ?
  • PHP Manual
  • EvLoop
  • Suspend the loop

EvLoop::suspend

(PECL ev >= 0.2.0)

EvLoop::suspend — Suspend the loop

说明

public EvLoop::suspend ( ) : void

EvLoop::suspend() and EvLoop::resume() methods suspend and resume a loop correspondingly.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EvLoop::resume() - Resume previously suspended default event loop
  • Ev::suspend() - Suspend the default event loop


Creates EvTimer watcher object associated with the current event loop instance

  • ? EvLoop::suspend
  • EvLoop::verify ?
  • PHP Manual
  • EvLoop
  • Creates EvTimer watcher object associated with the current event loop instance

EvLoop::timer

(PECL ev >= 0.2.0)

EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance

说明

final public EvLoop::timer ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 ) : EvTimer

Creates EvTimer watcher object associated with the current event loop instance

参数

All parameters have the same meaning as for EvTimer::__construct()

返回值

Returns EvTimer object on success

参见

  • EvTimer::__construct() - Constructs an EvTimer watcher object


Performs internal consistency checks(for debugging)

  • ? EvLoop::timer
  • EvPeriodic ?
  • PHP Manual
  • EvLoop
  • Performs internal consistency checks(for debugging)

EvLoop::verify

(PECL ev >= 0.2.0)

EvLoop::verify — Performs internal consistency checks(for debugging)

说明

public EvLoop::verify ( ) : void

Performs internal consistency checks(for debugging libev ) and abort the program if any data structures were found to be corrupted.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • Ev::verify() - Performs internal consistency checks(for debugging)


The EvPeriodic class

(PECL ev >= 0.2.0)

简介

Periodic watchers are also timers of a kind, but they are very versatile.

Unlike EvTimer , EvPeriodic watchers are not based on real time(or relative time, the physical time that passes) but on wall clock time(absolute time, calendar or clock). The difference is that wall clock time can run faster or slower than real time, and time jumps are not uncommon(e.g. when adjusting it).

EvPeriodic watcher can be configured to trigger after some specific point in time. For example, if an EvPeriodic watcher is configured to trigger "in 10 seconds" (e.g. EvLoop::now() + 10.0 , i.e. an absolute time, not a delay), and the system clock is reset to January of the previous year , then it will take a year or more to trigger the event (unlike an EvTimer , which would still trigger roughly 10 seconds after starting it as it uses a relative timeout).

As with timers, the callback is guaranteed to be invoked only when the point in time where it is supposed to trigger has passed. If multiple timers become ready during the same loop iteration then the ones with earlier time-out values are invoked before ones with later time-out values (but this is no longer true when a callback calls EvLoop::run() recursively).

类摘要

EvPeriodic extends EvWatcher {
/* 属性 */
public $offset ;
public $interval ;
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public again ( ) : void
public at ( ) : float
public __construct ( float $offset , string $interval , callable $reschedule_cb , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( float $offset , float $interval , callable $reschedule_cb , callable $callback , mixed $data = null , int $priority = 0 ) : EvPeriodic
public set ( float $offset , float $interval ) : void
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

属性

offset

When repeating, this contains the offset value, otherwise this is the absolute point in time(the offset value passed to EvPeriodic::set() , although libev might modify this value for better numerical stability).

interval

The current interval value. Can be modified any time, but changes only take effect when the periodic timer fires or EvPeriodic::again() is being called.

Table of Contents

  • EvPeriodic::again — Simply stops and restarts the periodic watcher again
  • EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next
  • EvPeriodic::__construct — Constructs EvPeriodic watcher object
  • EvPeriodic::createStopped — Create a stopped EvPeriodic watcher
  • EvPeriodic::set — Configures the watcher


Simply stops and restarts the periodic watcher again

  • ? EvPeriodic
  • EvPeriodic::at ?
  • PHP Manual
  • EvPeriodic
  • Simply stops and restarts the periodic watcher again

EvPeriodic::again

(PECL ev >= 0.2.0)

EvPeriodic::again — Simply stops and restarts the periodic watcher again

说明

public EvPeriodic::again ( ) : void

Simply stops and restarts the periodic watcher again. This is only useful when attributes are changed.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EvTimer::again() - Restarts the timer watcher


Returns the absolute time that this watcher is supposed to trigger next

  • ? EvPeriodic::again
  • EvPeriodic::__construct ?
  • PHP Manual
  • EvPeriodic
  • Returns the absolute time that this watcher is supposed to trigger next

EvPeriodic::at

(PECL ev >= 0.2.0)

EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next

说明

public EvPeriodic::at ( ) : float

When the watcher is active, returns the absolute time that this watcher is supposed to trigger next. This is not the same as the offset argument to EvPeriodic::set() or EvPeriodic::__construct() , but indeed works even in interval mode.

参数

此函数没有参数。

返回值

Returns the absolute time this watcher is supposed to trigger next in seconds.


Constructs EvPeriodic watcher object

  • ? EvPeriodic::at
  • EvPeriodic::createStopped ?
  • PHP Manual
  • EvPeriodic
  • Constructs EvPeriodic watcher object

EvPeriodic::__construct

(PECL ev >= 0.2.0)

EvPeriodic::__construct — Constructs EvPeriodic watcher object

说明

public EvPeriodic::__construct ( float $offset , string $interval , callable $reschedule_cb , callable $callback , mixed $data = null , int $priority = 0 )

Constructs EvPeriodic watcher object and starts it automatically. EvPeriodic::createStopped() method creates stopped periodic watcher.

参数

offset

See Periodic watcher operation modes

interval

See Periodic watcher operation modes

reschedule_cb

Reschedule callback. You can pass null. See Periodic watcher operation modes

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvPeriodic object on success.

范例

Example #1 Periodic timer. Use reschedule callback

<?php
// Tick each 10.5 seconds

function reschedule_cb ($watcher, $now) {
 return $now + (10.5. - fmod($now, 10.5));
}

$w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
 echo time(), PHP_EOL;
});
Ev::run();
?>

Example #2 Periodic timer. Tick every 10.5 seconds starting at now

<?php
// Tick every 10.5 seconds starting at now
$w = new EvPeriodic(fmod(Ev::now(), 10.5), 10.5, NULL, function ($w, $revents) {
 echo time(), PHP_EOL;
});
Ev::run();
?>

Example #3 Hourly watcher

<?php
$hourly = EvPeriodic(0, 3600, NULL, function () {
 echo "once per hour\n";
});
?>

参见

  • Periodic watcher operation modes
  • EvTimer
  • EvPeriodic::createStopped() - Create a stopped EvPeriodic watcher


Create a stopped EvPeriodic watcher

  • ? EvPeriodic::__construct
  • EvPeriodic::set ?
  • PHP Manual
  • EvPeriodic
  • Create a stopped EvPeriodic watcher

EvPeriodic::createStopped

(PECL ev >= 0.2.0)

EvPeriodic::createStopped — Create a stopped EvPeriodic watcher

说明

final public static EvPeriodic::createStopped ( float $offset , float $interval , callable $reschedule_cb , callable $callback , mixed $data = null , int $priority = 0 ) : EvPeriodic

Create EvPeriodic object. Unlike EvPeriodic::__construct() this method doesn't start the watcher automatically.

参数

offset

See Periodic watcher operation modes

interval

See Periodic watcher operation modes

reschedule_cb

Reschedule callback. You can pass null. See Periodic watcher operation modes

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvPeriodic watcher object on success.

参见

  • EvPeriodic::__construct() - Constructs EvPeriodic watcher object
  • EvTimer::createStopped() - Creates EvTimer stopped watcher object


Configures the watcher

  • ? EvPeriodic::createStopped
  • EvPrepare ?
  • PHP Manual
  • EvPeriodic
  • Configures the watcher

EvPeriodic::set

(PECL ev >= 0.2.0)

EvPeriodic::set — Configures the watcher

说明

public EvPeriodic::set ( float $offset , float $interval ) : void

(Re-)Configures EvPeriodic watcher

参数

offset

The same meaning as for EvPeriodic::__construct() . See Periodic watcher operation modes

interval

The same meaning as for EvPeriodic::__construct() . See Periodic watcher operation modes

返回值

没有返回值。


The EvPrepare class

(PECL ev >= 0.2.0)

简介

EvPrepare and EvCheck watchers are usually used in pairs. EvPrepare watchers get invoked before the process blocks, EvCheck afterwards.

It is not allowed to call EvLoop::run() or similar methods or functions that enter the current event loop from either EvPrepare or EvCheck watchers. Other loops than the current one are fine, however. The rationale behind this is that one don't need to check for recursion in those watchers, i.e. the sequence will always be: EvPrepare -> blocking -> EvCheck , so having a watcher of each kind they will always be called in pairs bracketing the blocking call.

The main purpose is to integrate other event mechanisms into libev and their use is somewhat advanced. They could be used, for example, to track variable changes, implement custom watchers, integrate net-snmp or a coroutine library and lots more. They are also occasionally useful to cache some data and want to flush it before blocking.

It is recommended to give EvCheck watchers highest( Ev::MAXPRI ) priority, to ensure that they are being run before any other watchers after the poll (this doesn't matter for EvPrepare watchers).

Also, EvCheck watchers should not activate/feed events. While libev fully supports this, they might get executed before other EvCheck watchers did their job.

类摘要

EvPrepare extends EvWatcher {
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public __construct ( string $callback , string $data = ? , string $priority = ? )
final public static createStopped ( callable $callback , mixed $data = null , int $priority = 0 ) : EvPrepare
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

Table of Contents

  • EvPrepare::__construct — Constructs EvPrepare watcher object
  • EvPrepare::createStopped — Creates a stopped instance of EvPrepare watcher


Constructs EvPrepare watcher object

  • ? EvPrepare
  • EvPrepare::createStopped ?
  • PHP Manual
  • EvPrepare
  • Constructs EvPrepare watcher object

EvPrepare::__construct

(PECL ev >= 0.2.0)

EvPrepare::__construct — Constructs EvPrepare watcher object

说明

public EvPrepare::__construct ( string $callback , string $data = ? , string $priority = ? )

Constructs EvPrepare watcher object. And starts the watcher automatically. If need a stopped watcher consider using EvPrepare::createStopped()

参数

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvPrepare object on success.

参见

  • EvCheck


Creates a stopped instance of EvPrepare watcher

  • ? EvPrepare::__construct
  • EvSignal ?
  • PHP Manual
  • EvPrepare
  • Creates a stopped instance of EvPrepare watcher

EvPrepare::createStopped

(PECL ev >= 0.2.0)

EvPrepare::createStopped — Creates a stopped instance of EvPrepare watcher

说明

final public static EvPrepare::createStopped ( callable $callback , mixed $data = null , int $priority = 0 ) : EvPrepare

Creates a stopped instance of EvPrepare watcher. Unlike EvPrepare::__construct() , this method doesn' start the watcher automatically.

参数

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Return EvPrepare object on success.

参见

  • EvPrepare::__construct() - Constructs EvPrepare watcher object
  • EvWatcher::start() - Starts the watcher


The EvSignal class

(PECL ev >= 0.2.0)

简介

EvSignal watchers will trigger an event when the process receives a specific signal one or more times. Even though signals are very asynchronous, libev will try its best to deliver signals synchronously, i.e. as part of the normal event processing, like any other event.

There is no limit for the number of watchers for the same signal, but only within the same loop, i.e. one can watch for SIGINT in the default loop and for SIGIO in another loop, but it is not allowed to watch for SIGINT in both the default loop and another loop at the same time. At the moment, SIGCHLD is permanently tied to the default loop.

If possible and supported, libev will install its handlers with SA_RESTART (or equivalent) behaviour enabled, so system calls should not be unduly interrupted. In case of a problem with system calls getting interrupted by signals, all the signals can be blocked in an EvCheck watcher and unblocked in a EvPrepare watcher.

类摘要

EvSignal extends EvWatcher {
/* 属性 */
public $signum ;
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public __construct ( int $signum , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( int $signum , callable $callback , mixed $data = null , int $priority = 0 ) : EvSignal
public set ( int $signum ) : void
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

属性

signum

Signal number. See the constants exported by pcntl extension. See also signal(7) man page.

Table of Contents

  • EvSignal::__construct — Constructs EvSignal watcher object
  • EvSignal::createStopped — Create stopped EvSignal watcher object
  • EvSignal::set — Configures the watcher


Constructs EvSignal watcher object

  • ? EvSignal
  • EvSignal::createStopped ?
  • PHP Manual
  • EvSignal
  • Constructs EvSignal watcher object

EvSignal::__construct

(PECL ev >= 0.2.0)

EvSignal::__construct — Constructs EvSignal watcher object

说明

public EvSignal::__construct ( int $signum , callable $callback , mixed $data = null , int $priority = 0 )

Constructs EvSignal watcher object and starts it automatically. For a stopped periodic watcher consider using EvSignal::createStopped() method.

参数

signum

Signal number. See constants exported by pcntl extension. See also signal(7) man page.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvSignal object on success.

范例

Example #1 Handle SIGTERM signal

<?php
$w = new EvSignal(SIGTERM, function ($watcher) {
    echo "SIGTERM received\n";
    $watcher->stop();
});

Ev::run();
?>

参见

  • EvSignal::createStopped() - Create stopped EvSignal watcher object


Create stopped EvSignal watcher object

  • ? EvSignal::__construct
  • EvSignal::set ?
  • PHP Manual
  • EvSignal
  • Create stopped EvSignal watcher object

EvSignal::createStopped

(PECL ev >= 0.2.0)

EvSignal::createStopped — Create stopped EvSignal watcher object

说明

final public static EvSignal::createStopped ( int $signum , callable $callback , mixed $data = null , int $priority = 0 ) : EvSignal

Create stopped EvSignal watcher object. Unlike EvSignal::__construct() , this method does't start the watcher automatically.

参数

signum

Signal number. See constants exported by pcntl extension. See also signal(7) man page.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvSignal object on success.

参见

  • EvWatcher::start() - Starts the watcher
  • EvSignal::__construct() - Constructs EvSignal watcher object


Configures the watcher

  • ? EvSignal::createStopped
  • EvStat ?
  • PHP Manual
  • EvSignal
  • Configures the watcher

EvSignal::set

(PECL ev >= 0.2.0)

EvSignal::set — Configures the watcher

说明

public EvSignal::set ( int $signum ) : void

Configures the watcher.

参数

signum

Signal number. The same as for EvSignal::__construct()

返回值

没有返回值。


The EvStat class

(PECL ev >= 0.2.0)

简介

EvStat monitors a file system path for attribute changes. It calls stat() on that path in regular intervals(or when the OS signals it changed) and sees if it changed compared to the last time, invoking the callback if it did.

The path does not need to exist: changing from "path exists" to "path does not exist" is a status change like any other. The condition "path does not exist" is signified by the 'nlink' item being 0(returned by EvStat::attr() method).

The path must not end in a slash or contain special components such as '.' or .. . The path should be absolute: if it is relative and the working directory changes, then the behaviour is undefined.

Since there is no portable change notification interface available, the portable implementation simply calls stat() regularly on the path to see if it changed somehow. For this case a recommended polling interval can be specified. If one specifies a polling interval of 0.0 (highly recommended) then a suitable, unspecified default value will be used(which could be expected to be around 5 seconds, although this might change dynamically). libev will also impose a minimum interval which is currently around 0.1 , but that's usually overkill.

This watcher type is not meant for massive numbers of EvStat watchers, as even with OS-supported change notifications, this can be resource-intensive.

类摘要

EvStat extends EvWatcher {
/* 属性 */
public $path ;
public $interval ;
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public attr ( ) : array
public __construct ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : void
public prev ( ) : void
public set ( string $path , float $interval ) : void
public stat ( ) : bool
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

属性

interval

Readonly . Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

path

Readonly . The path to wait for status changes on.

Table of Contents

  • EvStat::attr — Returns the values most recently detected by Ev
  • EvStat::__construct — Constructs EvStat watcher object
  • EvStat::createStopped — Create a stopped EvStat watcher object
  • EvStat::prev — Returns the previous set of values returned by EvStat::attr
  • EvStat::set — Configures the watcher
  • EvStat::stat — Initiates the stat call


Returns the values most recently detected by Ev

  • ? EvStat
  • EvStat::__construct ?
  • PHP Manual
  • EvStat
  • Returns the values most recently detected by Ev

EvStat::attr

(PECL ev >= 0.2.0)

EvStat::attr — Returns the values most recently detected by Ev

说明

public EvStat::attr ( ) : array

Returns array of the values most recently detected by Ev

参数

此函数没有参数。

返回值

Returns array with the values most recently detect by Ev(without actual stat 'ing):

List for item keys of the array returned by EvStat::attr()
Key | Description
'dev' | ID of device containing file
'ino' | inode number
'mode' | protection
'nlink' | number of hard links
'uid' | user ID of owner
'size' | total size, in bytes
'gid' | group ID of owner
'rdev' | device ID (if special file)
'blksize' | blocksize for file system I/O
'blocks' | number of 512B blocks allocated
'atime' | time of last access
'ctime' | time of last status change
'mtime' | time of last modification

See stat(2) man page for details.

范例

Example #1 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
    echo "/var/log/messages changed\n";

    $attr = $w->attr();

    if ($attr['nlink']) {
        printf("Current size: %ld\n", $attr['size']);
        printf("Current atime: %ld\n", $attr['atime']);
        printf("Current mtime: %ld\n", $attr['mtime']);
    } else {
        fprintf(STDERR, "`messages` file is not there!");
        $w->stop();
    }
});

Ev::run();
?>

参见

  • EvStat::prev() - Returns the previous set of values returned by EvStat::attr
  • EvStat::stat() - Initiates the stat call


Constructs EvStat watcher object

  • ? EvStat::attr
  • EvStat::createStopped ?
  • PHP Manual
  • EvStat
  • Constructs EvStat watcher object

EvStat::__construct

(PECL ev >= 0.2.0)

EvStat::__construct — Constructs EvStat watcher object

说明

public EvStat::__construct ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 )

Constructs EvStat watcher object and starts the watcher automatically.

参数

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvStat watcher object on succes.

范例

Example #1 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
 echo "/var/log/messages changed\n";

 $attr = $w->attr();

 if ($attr['nlink']) {
  printf("Current size: %ld\n", $attr['size']);
  printf("Current atime: %ld\n", $attr['atime']);
  printf("Current mtime: %ld\n", $attr['mtime']);
 } else {
  fprintf(STDERR, "`messages` file is not there!");
  $w->stop();
 }
});

Ev::run();
?>


Create a stopped EvStat watcher object

  • ? EvStat::__construct
  • EvStat::prev ?
  • PHP Manual
  • EvStat
  • Create a stopped EvStat watcher object

EvStat::createStopped

(PECL ev >= 0.2.0)

EvStat::createStopped — Create a stopped EvStat watcher object

说明

final public static EvStat::createStopped ( string $path , float $interval , callable $callback , mixed $data = null , int $priority = 0 ) : void

Creates EvStat watcher object, but doesn't start it automatically(unlike EvStat::__construct() ).

参数

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns a stopped EvStat watcher object on success.

参见

  • EvStat::__construct() - Constructs EvStat watcher object
  • EvWatcher::start() - Starts the watcher


Returns the previous set of values returned by EvStat::attr

  • ? EvStat::createStopped
  • EvStat::set ?
  • PHP Manual
  • EvStat
  • Returns the previous set of values returned by EvStat::attr

EvStat::prev

(PECL ev >= 0.2.0)

EvStat::prev — Returns the previous set of values returned by EvStat::attr

说明

public EvStat::prev ( ) : void

Just like EvStat::attr() , but returns the previous set of values.

参数

此函数没有参数。

返回值

Returns an array with the same structure as the array returned by EvStat::attr() . The array contains previously detected values.

参见

  • EvStat::attr() - Returns the values most recently detected by Ev
  • EvStat::stat() - Initiates the stat call


Configures the watcher

  • ? EvStat::prev
  • EvStat::stat ?
  • PHP Manual
  • EvStat
  • Configures the watcher

EvStat::set

(PECL ev >= 0.2.0)

EvStat::set — Configures the watcher

说明

public EvStat::set ( string $path , float $interval ) : void

Configures the watcher.

参数

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

返回值

没有返回值。


Initiates the stat call

  • ? EvStat::set
  • EvTimer ?
  • PHP Manual
  • EvStat
  • Initiates the stat call

EvStat::stat

(PECL ev >= 0.2.0)

EvStat::stat — Initiates the stat call

说明

public EvStat::stat ( ) : bool

Initiates the stat call(updates internal cache). It stats(using lstat ) the path specified in the watcher and sets to the values found.

参数

此函数没有参数。

返回值

Returns true if path exists. Otherwise false.

参见

  • EvStat::attr() - Returns the values most recently detected by Ev
  • EvStat::prev() - Returns the previous set of values returned by EvStat::attr


The EvTimer class

(PECL ev >= 0.2.0)

简介

EvTimer watchers are simple relative timers that generate an event after a given time, and optionally repeating in regular intervals after that.

The timers are based on real time, that is, if one registers an event that times out after an hour and resets the system clock to January last year , it will still time out after(roughly) one hour. "Roughly" because detecting time jumps is hard, and some inaccuracies are unavoidable.

The callback is guaranteed to be invoked only after its timeout has passed (not at, so on systems with very low-resolution clocks this might introduce a small delay). If multiple timers become ready during the same loop iteration then the ones with earlier time-out values are invoked before ones of the same priority with later time-out values (but this is no longer true when a callback calls EvLoop::run() recursively).

The timer itself will do a best-effort at avoiding drift, that is, if a timer is configured to trigger every 10 seconds, then it will normally trigger at exactly 10 second intervals. If, however, the script cannot keep up with the timer because it takes longer than those 10 seconds to do) the timer will not fire more than once per event loop iteration.

类摘要

EvTimer extends EvWatcher {
/* 属性 */
public $repeat ;
public $remaining ;
/* 继承的属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public again ( ) : void
public __construct ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 )
final public static createStopped ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 ) : EvTimer
public set ( float $after , float $repeat ) : void
/* 继承的方法 */
public EvWatcher::clear ( ) : int
abstract public EvWatcher::__construct ( )
public EvWatcher::feed ( int $revents ) : void
public EvWatcher::getLoop ( ) : EvLoop
public EvWatcher::invoke ( int $revents ) : void
public EvWatcher::keepalive ( bool $value = ? ) : bool
public EvWatcher::setCallback ( callable $callback ) : void
public EvWatcher::start ( ) : void
public EvWatcher::stop ( ) : void
}

属性

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

remaining

Returns the remaining time until a timer fires. If the timer is active, then this time is relative to the current event loop time, otherwise it's the timeout value currently configured.

That is, after instanciating an EvTimer with an after value of 5.0 and repeat value of 7.0 , remaining returns 5.0 . When the timer is started and one second passes, remaining will return 4.0 . When the timer expires and is restarted, it will return roughly 7.0 (likely slightly less as callback invocation takes some time too), and so on.

Table of Contents

  • EvTimer::again — Restarts the timer watcher
  • EvTimer::__construct — Constructs an EvTimer watcher object
  • EvTimer::createStopped — Creates EvTimer stopped watcher object
  • EvTimer::set — Configures the watcher


Restarts the timer watcher

  • ? EvTimer
  • EvTimer::__construct ?
  • PHP Manual
  • EvTimer
  • Restarts the timer watcher

EvTimer::again

(PECL ev >= 0.2.0)

EvTimer::again — Restarts the timer watcher

说明

public EvTimer::again ( ) : void

This will act as if the timer timed out and restart it again if it is repeating. The exact semantics are:

  1. if the timer is pending, its pending status is cleared.

  2. if the timer is started but non-repeating, stop it (as if it timed out).

  3. if the timer is repeating, either start it if necessary (with the repeat value), or reset the running timer to the repeat value.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EvWatcher::stop() - Stops the watcher


Constructs an EvTimer watcher object

  • ? EvTimer::again
  • EvTimer::createStopped ?
  • PHP Manual
  • EvTimer
  • Constructs an EvTimer watcher object

EvTimer::__construct

(PECL ev >= 0.2.0)

EvTimer::__construct — Constructs an EvTimer watcher object

说明

public EvTimer::__construct ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 )

Constructs an EvTimer watcher object.

参数

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvTimer object on success.

范例

Example #1 Simple timers

<?php
// Create and start timer firing after 2 seconds
$w1 = new EvTimer(2, 0, function () {
    echo "2 seconds elapsed\n";
});

// Create and launch timer firing after 2 seconds repeating each second
// until we manually stop it
$w2 = new EvTimer(2, 1, function ($w) {
    echo "is called every second, is launched after 2 seconds\n";
    echo "iteration = ", Ev::iteration(), PHP_EOL;

    // Stop the watcher after 5 iterations
    Ev::iteration() == 5 and $w->stop();
    // Stop the watcher if further calls cause more than 10 iterations
    Ev::iteration() >= 10 and $w->stop();
});

// Create stopped timer. It will be inactive until we start it ourselves
$w_stopped = EvTimer::createStopped(10, 5, function($w) {
    echo "Callback of a timer created as stopped\n";

    // Stop the watcher after 2 iterations
    Ev::iteration() >= 2 and $w->stop();
});

// Loop until Ev::stop() is called or all of watchers stop
Ev::run();

// Start and look if it works
$w_stopped->start();
echo "Run single iteration\n";
Ev::run(Ev::RUN_ONCE);

echo "Restart the second watcher and try to handle the same events, but don't block\n";
$w2->again();
Ev::run(Ev::RUN_NOWAIT);

$w = new EvTimer(10, 0, function() {});
echo "Running a blocking loop\n";
Ev::run();
echo "END\n";
?>

以上例程的输出类似于：

2 seconds elapsed
is called every second, is launched after 2 seconds
iteration = 1
is called every second, is launched after 2 seconds
iteration = 2
is called every second, is launched after 2 seconds
iteration = 3
is called every second, is launched after 2 seconds
iteration = 4
is called every second, is launched after 2 seconds
iteration = 5
Run single iteration
Callback of a timer created as stopped
Restart the second watcher and try to handle the same events, but don't block
Running a blocking loop
is called every second, is launched after 2 seconds
iteration = 8
is called every second, is launched after 2 seconds
iteration = 9
is called every second, is launched after 2 seconds
iteration = 10
END

参见

  • EvTimer::createStopped() - Creates EvTimer stopped watcher object
  • EvPeriodic
  • » ev_timer - relative and optionally repeating timeouts
  • » Be smart about timeouts


Creates EvTimer stopped watcher object

  • ? EvTimer::__construct
  • EvTimer::set ?
  • PHP Manual
  • EvTimer
  • Creates EvTimer stopped watcher object

EvTimer::createStopped

(PECL ev >= 0.2.0)

EvTimer::createStopped — Creates EvTimer stopped watcher object

说明

final public static EvTimer::createStopped ( float $after , float $repeat , callable $callback , mixed $data = null , int $priority = 0 ) : EvTimer

Creates EvTimer stopped watcher object. Unlike EvTimer::__construct() , this method doesn't start the watcher automatically.

参数

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

返回值

Returns EvTimer watcher object on success.

范例

Example #1 Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay

<?php
$timer = EvTimer::createStopped(0., 1.02, function ($w) {
    $w->stop();

    $stat = $w->data;

    // 1 second after the most recent change of the file
    printf("Current size: %ld\n", $stat->attr()['size']);
});

$stat = new EvStat("/var/log/messages", 0., function () use ($timer) {
    // Reset timer watcher
    $timer->again();
});

$timer->data = $stat;

Ev::run();
?>

参见

  • EvTimer::__construct() - Constructs an EvTimer watcher object
  • EvPeriodic


Configures the watcher

  • ? EvTimer::createStopped
  • EvWatcher ?
  • PHP Manual
  • EvTimer
  • Configures the watcher

EvTimer::set

(PECL ev >= 0.2.0)

EvTimer::set — Configures the watcher

说明

public EvTimer::set ( float $after , float $repeat ) : void

Configures the watcher

参数

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

返回值

没有返回值。


The EvWatcher class

(PECL ev >= 0.2.0)

简介

EvWatcher is a base class for all watchers( EvCheck , EvChild etc.). Since EvWatcher 's constructor is abstract , one can't(and don't need to) create EvWatcher objects directly.

类摘要

abstract EvWatcher {
/* 属性 */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* 方法 */
public clear ( ) : int
abstract public __construct ( )
public feed ( int $revents ) : void
public getLoop ( ) : EvLoop
public invoke ( int $revents ) : void
public keepalive ( bool $value = ? ) : bool
public setCallback ( callable $callback ) : void
public start ( ) : void
public stop ( ) : void
}

属性

is_active

Readonly . true if the watcher is active. false otherwise.

data

User custom data associated with the watcher

is_pending

Readonly .true if the watcher is pending, i.e. it has outstanding events, but its callback has not yet been invoked. false otherwise. As long, as a watcher is pending(but not active), one must not change its priority.

priority

int between Ev::MINPRI and Ev::MAXPRI . Pending watchers with higher priority will be invoked before watchers with lower priority, but priority will not keep watchers from being executed(except for EvIdle watchers). EvIdle watchers provide functionality to suppress invocation when higher priority events are pending.

Table of Contents

  • EvWatcher::clear — Clear watcher pending status
  • EvWatcher::__construct — Abstract constructor of a watcher object
  • EvWatcher::feed — Feeds the given revents set into the event loop
  • EvWatcher::getLoop — Returns the loop responsible for the watcher
  • EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask
  • EvWatcher::keepalive — Configures whether to keep the loop from returning
  • EvWatcher::setCallback — Sets new callback for the watcher
  • EvWatcher::start — Starts the watcher
  • EvWatcher::stop — Stops the watcher


Clear watcher pending status

  • ? EvWatcher
  • EvWatcher::__construct ?
  • PHP Manual
  • EvWatcher
  • Clear watcher pending status

EvWatcher::clear

(PECL ev >= 0.2.0)

EvWatcher::clear — Clear watcher pending status

说明

public EvWatcher::clear ( ) : int

If the watcher is pending, this method clears its pending status and returns its revents bitset(as if its callback was invoked). If the watcher isn't pending it does nothing and returns 0 .

Sometimes it can be useful to "poll" a watcher instead of waiting for its callback to be invoked, which can be accomplished with this function.

参数

此函数没有参数。

返回值

In case if the watcher is pending, returns revents bitset as if the watcher callback had been invoked. Otherwise returns 0 .


Abstract constructor of a watcher object

  • ? EvWatcher::clear
  • EvWatcher::feed ?
  • PHP Manual
  • EvWatcher
  • Abstract constructor of a watcher object

EvWatcher::__construct

(PECL ev >= 0.2.0)

EvWatcher::__construct — Abstract constructor of a watcher object

说明

abstract public EvWatcher::__construct ( )

EvWatcher::__construct() is an abstract constructor of a watcher object implemented in the derived classes.


Feeds the given revents set into the event loop

  • ? EvWatcher::__construct
  • EvWatcher::getLoop ?
  • PHP Manual
  • EvWatcher
  • Feeds the given revents set into the event loop

EvWatcher::feed

(PECL ev >= 0.2.0)

EvWatcher::feed — Feeds the given revents set into the event loop

说明

public EvWatcher::feed ( int $revents ) : void

Feeds the given revents set into the event loop, as if the specified event had happened for the watcher.

参数

revents

Bit mask of watcher received events .

返回值

没有返回值。


Returns the loop responsible for the watcher

  • ? EvWatcher::feed
  • EvWatcher::invoke ?
  • PHP Manual
  • EvWatcher
  • Returns the loop responsible for the watcher

EvWatcher::getLoop

(PECL ev >= 0.2.0)

EvWatcher::getLoop — Returns the loop responsible for the watcher

说明

public EvWatcher::getLoop ( ) : EvLoop

Returns the loop responsible for the watcher

参数

此函数没有参数。

返回值

Returns EvLoop event loop object responsible for the watcher.


Invokes the watcher callback with the given received events bit mask

  • ? EvWatcher::getLoop
  • EvWatcher::keepalive ?
  • PHP Manual
  • EvWatcher
  • Invokes the watcher callback with the given received events bit mask

EvWatcher::invoke

(PECL ev >= 0.2.0)

EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask

说明

public EvWatcher::invoke ( int $revents ) : void

Invokes the watcher callback with the given received events bit mask.

参数

revents

Bit mask of watcher received events .

返回值

没有返回值。


Configures whether to keep the loop from returning

  • ? EvWatcher::invoke
  • EvWatcher::setCallback ?
  • PHP Manual
  • EvWatcher
  • Configures whether to keep the loop from returning

EvWatcher::keepalive

(PECL ev >= 0.2.0)

EvWatcher::keepalive — Configures whether to keep the loop from returning

说明

public EvWatcher::keepalive ( bool $value = ? ) : bool

Configures whether to keep the loop from returning. With keepalive value set to false the watcher won't keep Ev::run() / EvLoop::run() from returning even though the watcher is active.

Watchers have keepalive value true by default.

Clearing keepalive status is useful when returning from Ev::run() / EvLoop::run() just because of the watcher is undesirable. It could be a long running UDP socket watcher or so.

参数

value

With keepalive value set to false the watcher won't keep Ev::run() / EvLoop::run() from returning even though the watcher is active.

返回值

Returns the previous state.

范例

Example #1 Register an I/O watcher for some UDP socket but do not keep the event loop from running just because of that watcher.

<?php
$udp_socket = ...
$udp_watcher = new EvIo($udp_socket, Ev::READ, function () { /* ... */ });
$udp_watcher->keepalive(FALSE);
?>


Sets new callback for the watcher

  • ? EvWatcher::keepalive
  • EvWatcher::start ?
  • PHP Manual
  • EvWatcher
  • Sets new callback for the watcher

EvWatcher::setCallback

(PECL ev >= 0.2.0)

EvWatcher::setCallback — Sets new callback for the watcher

说明

public EvWatcher::setCallback ( callable $callback ) : void

Sets new callback for the watcher

参数

callback

See Watcher callbacks .

返回值

没有返回值。


Starts the watcher

  • ? EvWatcher::setCallback
  • EvWatcher::stop ?
  • PHP Manual
  • EvWatcher
  • Starts the watcher

EvWatcher::start

(PECL ev >= 0.2.0)

EvWatcher::start — Starts the watcher

说明

public EvWatcher::start ( ) : void

Marks the watcher as active. Note that only active watchers will receive events.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EvWatcher::stop() - Stops the watcher


Stops the watcher

  • ? EvWatcher::start
  • Expect ?
  • PHP Manual
  • EvWatcher
  • Stops the watcher

EvWatcher::stop

(PECL ev >= 0.2.0)

EvWatcher::stop — Stops the watcher

说明

public EvWatcher::stop ( ) : void

Marks the watcher as inactive. Note that only active watchers will receive events.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EvWatcher::start() - Starts the watcher


Expect

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Expect Usage Examples
  • Expect 函数
    • expect_expectl — Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen
    • expect_popen — Execute command via Bourne shell, and open the PTY stream to the process


简介

This extension allows to interact with processes through PTY. You may consider using the expect:// wrapper with the filesystem functions which provide a simpler and more intuitive interface.


需求

This module uses the functions of the » expect library. You need libexpect version >= 5.43.0.


安装

此 » PECL 扩展未与 PHP 捆绑。 安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/expect.

In order to use these functions you must compile PHP with expect support by using the --with-expect[=DIR] configure option.

Windows users will enable php_expect.dll inside of php.ini in order to use these functions. PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

In order to configure expect extension, there are configuration options in the configuration file php.ini.

Expect 配置选项
名字 | 默认 | 可修改范围 | Changelog
expect.timeout | "10" | PHP_INI_ALL |
expect.loguser | "1" | PHP_INI_ALL |
expect.logfile | "" | PHP_INI_ALL |
expect.match_max | "" | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

expect.timeout int

The timeout period for waiting for the data, when using the expect_expectl() function.

A value of "-1" disables a timeout from occurring.

Note:

A value of "0" causes the expect_expectl() function to return immediately.

expect.loguser bool

Whether expect should send any output from the spawned process to stdout. Since interactive programs typically echo their input, this usually suffices to show both sides of the conversation.

expect.logfile string

Name of the file, where the output from the spawned process will be written. If this file doesn't exist, it will be created.

Note:

If this configuration is not empty, the output is written regardless of the value of expect.loguser.

expect.match_max int

Changes default size (2000 bytes) of the buffer used to match asterisks in patterns.


资源类型

expect_popen() returns an open PTY stream used by expect_expectl().


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

EXP_GLOB (int)
Indicates that the pattern is a glob-style string pattern.
EXP_EXACT (int)
Indicates that the pattern is an exact string.
EXP_REGEXP (int)
Indicates that the pattern is a regexp-style string pattern.
EXP_EOF (int)
Value, returned by expect_expectl(), when EOF is reached.
EXP_TIMEOUT (int)
Value, returned by expect_expectl() upon timeout of seconds, specified in value of expect.timeout
EXP_FULLBUFFER (int)
Value, returned by expect_expectl() if no pattern have been matched.


  • ? 预定义常量
  • Expect Usage Examples ?
  • PHP Manual
  • Expect
  • 范例

范例

Table of Contents

  • Expect Usage Examples


Expect Usage Examples

Example #1 Expect Usage Example

This example connects to the remote host via SSH, and prints the remote uptime.

<?php
ini_set("expect.loguser", "Off");

$stream = fopen("expect://ssh root@remotehost uptime", "r");

$cases = array (
    array (0 => "password:", 1 => PASSWORD)
);

switch (expect_expectl ($stream, $cases)) {
    case PASSWORD:
        fwrite ($stream, "password\n");
        break;

    default:
        die ("Error was occurred while connecting to the remote host!\n");
}

while ($line = fgets($stream)) {
      print $line;
}
fclose ($stream);
?>

The following example connects to the remote host, determines whether installed OS is for 32 or 64 bit, then runs update for specific package.

Example #2 Another Expect Usage Example

<?php
ini_set("expect.timeout", -1);
ini_set("expect.loguser", "Off");

$stream = expect_popen("ssh root@remotehost");

while (true) {
    switch (expect_expectl ($stream, array (
            array ("password:", PASSWORD), // SSH is asking for password
            array ("yes/no)?", YESNO), // SSH is asking whether to store the host entry
            array ("~$ ", SHELL, EXP_EXACT), // We've got the shell!
    ))) {
        case PASSWORD:
            fwrite ($stream, "secret\n");
            break;

        case YESNO:
            fwrite ($stream, "yes\n");
            break;

        case SHELL:
            fwrite ($stream, "uname -a\n");
            while (true) {
                    switch (expect_expectl ($stream, array (
                            array ("~$ ", SHELL, EXP_EXACT), // We've got the shell!
                            array ("^Linux.*$", UNAME, EXP_REGEXP), // uname -a output
                    ), $match)) {
                        case UNAME:
                            $uname .= $match[0];
                            break;

                        case SHELL:
                            // Run update:
                            if (strstr ($uname, "x86_64")) {
                                    fwrite ($stream, "rpm -Uhv http://mirrorsite/somepath/some_64bit.rpm\n");
                            } else {
                                    fwrite ($stream, "rpm -Uhv http://mirrorsite/somepath/some_32bit.rpm\n");
                            }
                            fwrite ($stream, "exit\n");
                            break 2;

                        case EXP_TIMEOUT:
                        case EXP_EOF:
                            break 2;

                        default:
                            die ("Error has occurred!\n");
                    }
            }
            break 2;

        case EXP_TIMEOUT:
        case EXP_EOF:
            break 2;

        default:
            die ("Error has occurred!\n");
    }
}

fclose ($stream);
?>


Expect 函数

Table of Contents

  • expect_expectl — Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen
  • expect_popen — Execute command via Bourne shell, and open the PTY stream to the process


Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen

  • ? Expect 函数
  • expect_popen ?
  • PHP Manual
  • Expect 函数
  • Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen

expect_expectl

(PECL expect >= 0.1.0)

expect_expectl — Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen

说明

expect_expectl ( resource $expect , array $cases , array &$match = ? ) : int

Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen.

If match is provided, then it is filled with the result of search. The matched string can be found in match[0]. The match substrings (according to the parentheses) in the original pattern can be found in match[1], match[2], and so on, up to match[9] (the limitation of libexpect).

参数

expect

An Expect stream, previously opened with expect_popen().

cases

An array of expect cases. Each expect case is an indexed array, as described in the following table:

Expect Case Array
Index Key | Value Type | Description | Is Mandatory | Default Value
0 | string | pattern, that will be matched against the output from the stream | yes
1 | mixed | value, that will be returned by this function, if the pattern matches | yes
2 | integer | pattern type, one of: EXP_GLOB, EXP_EXACT or EXP_REGEXP | no | EXP_GLOB

返回值

Returns value associated with the pattern that was matched.

On failure this function returns: EXP_EOF, EXP_TIMEOUT or EXP_FULLBUFFER

更新日志

版本 | 说明
PECL expect 0.2.1 | Prior to version 0.2.1, in match parameter a match string was returned, not an array of match substrings.

范例

Example #1 expect_expectl() example

<?php
// Copies file from remote host:
ini_set("expect.timeout", 30);

$stream = fopen("expect://scp user@remotehost:/var/log/messages /home/user/messages.txt", "r");

$cases = array(
    // array(pattern, value to return if pattern matched)
    array("password:", "asked for password"),
    array("yes/no)?",  "asked for yes/no")
);

while (true) {
    switch (expect_expectl($stream, $cases)) {
        case "asked for password":
            fwrite($stream, "my password\n");
            break;
        case "asked for yes/no":
            fwrite($stream, "yes\n");
            break;
        case EXP_TIMEOUT:
        case EXP_EOF:
            break 2; // break both the switch statement and the while loop
        default:
            die "Error has occurred!";
    }
}

fclose($stream);
?>

参见

  • expect_popen() - Execute command via Bourne shell, and open the PTY stream to the process


Execute command via Bourne shell, and open the PTY stream to the process

  • ? expect_expectl
  • PCNTL ?
  • PHP Manual
  • Expect 函数
  • Execute command via Bourne shell, and open the PTY stream to the process

expect_popen

(PECL expect >= 0.1.0)

expect_popen — Execute command via Bourne shell, and open the PTY stream to the process

说明

expect_popen ( string $command ) : resource

Execute command via Bourne shell, and open the PTY stream to the process.

参数

command

Command to execute.

返回值

Returns an open PTY stream to the processes stdio, stdout, and stderr.

On failure this function returns false.

范例

Example #1 expect_popen() example

<?php
// Login to the PHP.net CVS repository:
$stream = expect_popen ("cvs -d :pserver:anonymous@cvs.php.net:/repository login");
sleep (3);
fwrite ($stream, "phpfi\n");
fclose ($stream);
?>

参见

  • popen() - 打开进程文件指针


进程控制

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • PCNTL 函数
    • pcntl_alarm — 为进程设置一个alarm闹钟信号
    • pcntl_async_signals — Enable/disable asynchronous signal handling or return the old setting
    • pcntl_errno — 别名 pcntl_get_last_error
    • pcntl_exec — 在当前进程空间执行指定程序
    • pcntl_fork — 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。
    • pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed
    • pcntl_getpriority — 获取任意进程的优先级
    • pcntl_setpriority — 修改任意进程的优先级
    • pcntl_signal_dispatch — 调用等待信号的处理器
    • pcntl_signal_get_handler — Get the current handler for specified signal
    • pcntl_signal — 安装一个信号处理器
    • pcntl_sigprocmask — 设置或检索阻塞信号
    • pcntl_sigtimedwait — 带超时机制的信号等待
    • pcntl_sigwaitinfo — 等待信号
    • pcntl_strerror — Retrieve the system error message associated with the given errno
    • pcntl_wait — 等待或返回 fork 的子进程状态
    • pcntl_waitpid — 等待或返回fork的子进程状态
    • pcntl_wexitstatus — 返回一个中断的子进程的返回代码
    • pcntl_wifexited — 检查状态代码是否代表一个正常的退出。
    • pcntl_wifsignaled — 检查子进程状态码是否代表由于某个信号而中断
    • pcntl_wifstopped — 检查子进程当前是否已经停止
    • pcntl_wstopsig — 返回导致子进程停止的信号
    • pcntl_wtermsig — 返回导致子进程中断的信号


简介

PHP的进程控制支持实现了Unix方式的进程创建, 程序执行, 信号处理以及进程的中断。 进程控制不能被应用在Web服务器环境，当其被用于Web服务环境时可能会带来意外的结果。

这份文档用于阐述每个进程控制函数的通常用法。关于Unix进程控制的更多信息建议您查阅 系统文档中关于fork（2）,waitpid（2），signal（2）等的部分或更全面的参考资料比如 《Unix环境高级编程》（作者：W. Richard Stevens，Addison-Wesley出版）。

PCNTL现在使用了ticks作为信号处理的回调机制，ticks在速度上远远超过了之前的处理机制。 这个变化与"用户ticks"遵循了相同的语义。您可以使用declare() 语句在程序中指定允许发生回调的位置。这使得我们对异步事件处理的开销最小化。在编译PHP时 启用pcntl将始终承担这种开销，不论您的脚本中是否真正使用了pcntl。

有一个调整是PHP 4.3.0之前的所有pcntl脚本要使其工作，要么在期望允许回调的（代码）部分使用 declare() ，要么使用declare()新的全局语法 使其在整个脚本范围有效。

Note: 此扩展在 Windows 平台上不可用。


安装

在PHP中进程控制支持默认是关闭的。您需要使用 --enable-pcntl配置选项重新编译PHP的 CGI或CLI版本以打开进程控制支持。

Note:

当前，这个模块没有非Unix平台可用的函数（即非Unix类系统不支持此模块）。


预定义常量

下面列出的信号列表用于支持进程控制函数。关于这些信号默认行为的更详细信息请查看您系统的 signal（7）手册

WNOHANG (integer)
WUNTRACED (integer)
SIG_IGN (integer)
SIG_DFL (integer)
SIG_ERR (integer)
SIGHUP (integer)
SIGINT (integer)
SIGQUIT (integer)
SIGILL (integer)
SIGTRAP (integer)
SIGABRT (integer)
SIGIOT (integer)
SIGBUS (integer)
SIGFPE (integer)
SIGKILL (integer)
SIGUSR1 (integer)
SIGSEGV (integer)
SIGUSR2 (integer)
SIGPIPE (integer)
SIGALRM (integer)
SIGTERM (integer)
SIGSTKFLT (integer)
SIGCLD (integer)
SIGCHLD (integer)
SIGCONT (integer)
SIGSTOP (integer)
SIGTSTP (integer)
SIGTTIN (integer)
SIGTTOU (integer)
SIGURG (integer)
SIGXCPU (integer)
SIGXFSZ (integer)
SIGVTALRM (integer)
SIGPROF (integer)
SIGWINCH (integer)
SIGPOLL (integer)
SIGIO (integer)
SIGPWR (integer)
SIGSYS (integer)
SIGBABY (integer)
SIG_BLOCK (integer)
PHP 5.3.0之后版本可用。
SIG_UNBLOCK (integer)
PHP 5.3.0之后版本可用。
SIG_SETMASK (integer)
PHP 5.3.0之后版本可用。
SI_USER (integer)
PHP 5.3.0之后版本可用。
SI_NOINFO (integer)
PHP 5.3.0之后版本可用。
SI_KERNEL (integer)
PHP 5.3.0之后版本可用。
SI_QUEUE (integer)
PHP 5.3.0之后版本可用。
SI_TIMER (integer)
PHP 5.3.0之后版本可用。
SI_MSGGQ (integer)
PHP 5.3.0之后版本可用。
SI_ASYNCIO (integer)
PHP 5.3.0之后版本可用。
SI_SIGIO (integer)
PHP 5.3.0之后版本可用。
SI_TKILL (integer)
PHP 5.3.0之后版本可用。
CLD_EXITED (integer)
PHP 5.3.0之后版本可用。
CLD_KILLED (integer)
PHP 5.3.0之后版本可用。
CLD_DUMPED (integer)
PHP 5.3.0之后版本可用。
CLD_TRAPPED (integer)
PHP 5.3.0之后版本可用。
CLD_STOPPED (integer)
PHP 5.3.0之后版本可用。
CLD_CONTINUED (integer)
PHP 5.3.0之后版本可用。
TRAP_BRKPT (integer)
PHP 5.3.0之后版本可用。
TRAP_TRACE (integer)
PHP 5.3.0之后版本可用。
POLL_IN (integer)
PHP 5.3.0之后版本可用。
POLL_OUT (integer)
PHP 5.3.0之后版本可用。
POLL_MSG (integer)
PHP 5.3.0之后版本可用。
POLL_ERR (integer)
PHP 5.3.0之后版本可用。
POLL_PRI (integer)
PHP 5.3.0之后版本可用。
POLL_HUP (integer)
PHP 5.3.0之后版本可用。
ILL_ILLOPC (integer)
PHP 5.3.0之后版本可用。
ILL_ILLOPN (integer)
PHP 5.3.0之后版本可用。
ILL_ILLADR (integer)
PHP 5.3.0之后版本可用。
ILL_ILLTRP (integer)
PHP 5.3.0之后版本可用。
ILL_PRVOPC (integer)
PHP 5.3.0之后版本可用。
ILL_PRVREG (integer)
PHP 5.3.0之后版本可用。
ILL_COPROC (integer)
PHP 5.3.0之后版本可用。
ILL_BADSTK (integer)
PHP 5.3.0之后版本可用。
FPE_INTDIV (integer)
PHP 5.3.0之后版本可用。
FPE_INTOVF (integer)
PHP 5.3.0之后版本可用。
FPE_FLTDIV (integer)
PHP 5.3.0之后版本可用。
FPE_FLTOVF (integer)
PHP 5.3.0之后版本可用。
FPE_FLTUND (integer)
PHP 5.3.0之后版本可用。
FPE_FLTRES (integer)
PHP 5.3.0之后版本可用。
FPE_FLTINV (integer)
PHP 5.3.0之后版本可用。
FPE_FLTSUB (integer)
PHP 5.3.0之后版本可用。
SEGV_MAPERR (integer)
PHP 5.3.0之后版本可用。
SEGV_ACCERR (integer)
PHP 5.3.0之后版本可用。
BUS_ADRALN (integer)
PHP 5.3.0之后版本可用。
BUS_ADRERR (integer)
PHP 5.3.0之后版本可用。
BUS_OBJERR (integer)
PHP 5.3.0之后版本可用。


  • ? 预定义常量
  • ?
  • PHP Manual
  • PCNTL
  • 范例

范例

Table of Contents


  • ? 范例
  • PCNTL 函数 ?
  • PHP Manual
  • 范例

这个示例用于产生一个守护进程并可以通过信号处理进行关闭。

Example #1 进程控制示例

<?php
//定义ticks
declare(ticks=1);

//产生子进程分支
$pid = pcntl_fork();
if ($pid == -1) {
     die("could not fork"); //pcntl_fork返回-1标明创建子进程失败
} else if ($pid) {
     exit(); //父进程中pcntl_fork返回创建的子进程进程号
} else {
     // 子进程pcntl_fork返回的时0
}

// 从当前终端分离
if (posix_setsid() == -1) {
    die("could not detach from terminal");
}

// 安装信号处理器
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP, "sig_handler");

// 执行无限循环任务
while (1) {

    // do something interesting here

}

function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // 处理中断信号
             exit;
             break;
         case SIGHUP:
             // 处理重启信号
             break;
         default:
             // 处理所有其他信号
     }

}

?>


PCNTL 函数

参见

参考一下 POSIX functions 对有助于理解使用。

Table of Contents

  • pcntl_alarm — 为进程设置一个alarm闹钟信号
  • pcntl_async_signals — Enable/disable asynchronous signal handling or return the old setting
  • pcntl_errno — 别名 pcntl_get_last_error
  • pcntl_exec — 在当前进程空间执行指定程序
  • pcntl_fork — 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。
  • pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed
  • pcntl_getpriority — 获取任意进程的优先级
  • pcntl_setpriority — 修改任意进程的优先级
  • pcntl_signal_dispatch — 调用等待信号的处理器
  • pcntl_signal_get_handler — Get the current handler for specified signal
  • pcntl_signal — 安装一个信号处理器
  • pcntl_sigprocmask — 设置或检索阻塞信号
  • pcntl_sigtimedwait — 带超时机制的信号等待
  • pcntl_sigwaitinfo — 等待信号
  • pcntl_strerror — Retrieve the system error message associated with the given errno
  • pcntl_wait — 等待或返回 fork 的子进程状态
  • pcntl_waitpid — 等待或返回fork的子进程状态
  • pcntl_wexitstatus — 返回一个中断的子进程的返回代码
  • pcntl_wifexited — 检查状态代码是否代表一个正常的退出。
  • pcntl_wifsignaled — 检查子进程状态码是否代表由于某个信号而中断
  • pcntl_wifstopped — 检查子进程当前是否已经停止
  • pcntl_wstopsig — 返回导致子进程停止的信号
  • pcntl_wtermsig — 返回导致子进程中断的信号


为进程设置一个alarm闹钟信号

  • ? PCNTL 函数
  • pcntl_async_signals ?
  • PHP Manual
  • PCNTL 函数
  • 为进程设置一个alarm闹钟信号

pcntl_alarm

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

pcntl_alarm — 为进程设置一个alarm闹钟信号

说明

pcntl_alarm ( int $seconds ) : int

创建一个计时器，在指定的秒数后向进程发送一个SIGALRM信号。每次对 pcntl_alarm()的调用都会取消之前设置的alarm信号。

参数

seconds

等待的秒数。如果seconds设置为0,将不会创建alarm信号。

返回值

返回上次alarm调度（离alarm信号发送）剩余的秒数，或者之前没有alarm调度（译注：或者之前调度已完成） 时返回0。


Enable/disable asynchronous signal handling or return the old setting

  • ? pcntl_alarm
  • pcntl_errno ?
  • PHP Manual
  • PCNTL 函数
  • Enable/disable asynchronous signal handling or return the old setting

pcntl_async_signals

(PHP 7 >= 7.1.0, PHP 8)

pcntl_async_signals — Enable/disable asynchronous signal handling or return the old setting

说明

pcntl_async_signals ( bool $on = null ) : bool

If the on parameter is omitted, pcntl_async_signals() returns whether asynchronous signal handling is enabled. Otherwise, asynchronous signal handling is enabled or disabled.

参数

on

Whether asynchronous signal handling should be enabled.

返回值

When used as getter (that is without the optional parameter) it returns whether asynchronous signal handling is enabled. When used as setter (that is with the optional parameter given), it returns whether asynchronous signal handling was enabled before the function call.

参见

  • declare


别名 pcntl_get_last_error

  • ? pcntl_async_signals
  • pcntl_exec ?
  • PHP Manual
  • PCNTL 函数
  • 别名 pcntl_get_last_error

pcntl_errno

(PHP 5 >= 5.3.4, PHP 7, PHP 8)

pcntl_errno — 别名 pcntl_get_last_error()

说明

此函数是该函数的别名： pcntl_get_last_error()


在当前进程空间执行指定程序

  • ? pcntl_errno
  • pcntl_fork ?
  • PHP Manual
  • PCNTL 函数
  • 在当前进程空间执行指定程序

pcntl_exec

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

pcntl_exec — 在当前进程空间执行指定程序

说明

pcntl_exec ( string $path , array $args = ? , array $envs = ? ) : void

以给定参数执行程序。

参数

path

path必须时可执行二进制文件路径或一个在文件第一行指定了 一个可执行文件路径标头的脚本（比如文件第一行是#!/usr/local/bin/perl的perl脚本）。 更多的信息请查看您系统的execve（2）手册。

args

args是一个要传递给程序的参数的字符串数组。

envs

envs是一个要传递给程序作为环境变量的字符串数组。这个数组是 key => value格式的，key代表要传递的环境变量的名称，value代表该环境变量值。

返回值

当发生错误时返回 false ，没有错误时没有返回。


在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。

  • ? pcntl_exec
  • pcntl_get_last_error ?
  • PHP Manual
  • PCNTL 函数
  • 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。

pcntl_fork

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_fork — 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。

说明

pcntl_fork ( ) : int

pcntl_fork()函数创建一个子进程，这个子进程仅PID（进程号） 和PPID（父进程号）与其父进程不同。fork怎样在您的系统工作的详细信息请查阅您的系统 的fork（2）手册。

返回值

成功时，在父进程执行线程内返回产生的子进程的PID，在子进程执行线程内返回0。失败时，在 父进程上下文返回-1，不会创建子进程，并且会引发一个PHP错误。

范例

Example #1 pcntl_fork() 示例

<?php

$pid = pcntl_fork();
//父进程和子进程都会执行下面代码
if ($pid == -1) {
    //错误处理：创建子进程失败时返回-1.
     die('could not fork');
} else if ($pid) {
     //父进程会得到子进程号，所以这里是父进程执行的逻辑
     pcntl_wait($status); //等待子进程中断，防止子进程成为僵尸进程。
} else {
     //子进程得到的$pid为0, 所以这里是子进程执行的逻辑。
}

?>

参见

  • pcntl_waitpid() - 等待或返回fork的子进程状态
  • pcntl_signal() - 安装一个信号处理器


Retrieve the error number set by the last pcntl function which failed

  • ? pcntl_fork
  • pcntl_getpriority ?
  • PHP Manual
  • PCNTL 函数
  • Retrieve the error number set by the last pcntl function which failed

pcntl_get_last_error

(PHP 5 >= 5.3.4, PHP 7, PHP 8)

pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed

说明

pcntl_get_last_error ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns error code.

参见

  • pcntl_strerror() - Retrieve the system error message associated with the given errno


获取任意进程的优先级

  • ? pcntl_get_last_error
  • pcntl_setpriority ?
  • PHP Manual
  • PCNTL 函数
  • 获取任意进程的优先级

pcntl_getpriority

(PHP 5, PHP 7, PHP 8)

pcntl_getpriority — 获取任意进程的优先级

说明

pcntl_getpriority ( int $pid = getmypid() , int $process_identifier = PRIO_PROCESS ) : int

pcntl_getpriority() 获取进程号为 pid的进程的优先级。由于不同的系统类型以及内核版本下 优先级可能不同，因此请参考您系统的getpriority（2）手册以获取详细的规范。

参数

pid

如果没有指定，默认是当前进程的进程号。

process_identifier

PRIO_PGRP（译注：获取进程组优先级）, PRIO_USER （译注：获取用户进程优先级）或 PRIO_PROCESS（译注：默认值;获取进程优先级）三者之一。

返回值

pcntl_getpriority() 返回进程的优先级或在错误时返回 false 。 值越小代表优先级越高。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

参见

  • pcntl_setpriority() - 修改任意进程的优先级


修改任意进程的优先级

  • ? pcntl_getpriority
  • pcntl_signal_dispatch ?
  • PHP Manual
  • PCNTL 函数
  • 修改任意进程的优先级

pcntl_setpriority

(PHP 5, PHP 7, PHP 8)

pcntl_setpriority — 修改任意进程的优先级

说明

pcntl_setpriority ( int $priority , int $pid = getmypid() , int $process_identifier = PRIO_PROCESS ) : bool

pcntl_setpriority() 设置进程号为 pid的进程的优先级。

参数

priority

priority 通常时-20至20这个范围内的值。默认优先级是0,值越小代表 优先级越高。由于不同的系统类型以及内核版本下优先级可能不同，因此请参考您系统的setpriority（2） 手册以获取详细的规范。

pid

如果没有指定，默认是当前进程的进程号。

process_identifier

PRIO_PGRP（译注：获取进程组优先级）, PRIO_USER （译注：获取用户进程优先级）或 PRIO_PROCESS（译注：默认值;获取进程优先级）三者之一。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • pcntl_getpriority() - 获取任意进程的优先级


调用等待信号的处理器

  • ? pcntl_setpriority
  • pcntl_signal_get_handler ?
  • PHP Manual
  • PCNTL 函数
  • 调用等待信号的处理器

pcntl_signal_dispatch

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

pcntl_signal_dispatch — 调用等待信号的处理器

说明

pcntl_signal_dispatch ( ) : bool

函数pcntl_signal_dispatch()调用每个等待信号通过pcntl_signal() 安装的处理器。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pcntl_signal_dispatch() 示例

<?php
echo "安装信号处理器...\n";
pcntl_signal(SIGHUP,  function($signo) {
     echo "信号处理器被调用\n";
});

echo "为自己生成SIGHUP信号...\n";
posix_kill(posix_getpid(), SIGHUP);

echo "分发...\n";
pcntl_signal_dispatch();

echo "完成\n";

?>

以上例程的输出类似于：

安装信号处理器...
为自己生成SIGHUP信号...
分发...
信号处理器被调用
完成

参见

  • pcntl_signal() - 安装一个信号处理器
  • pcntl_sigprocmask() - 设置或检索阻塞信号
  • pcntl_sigwaitinfo() - 等待信号
  • pcntl_sigtimedwait() - 带超时机制的信号等待


Get the current handler for specified signal

  • ? pcntl_signal_dispatch
  • pcntl_signal ?
  • PHP Manual
  • PCNTL 函数
  • Get the current handler for specified signal

pcntl_signal_get_handler

(PHP 7 >= 7.1.0, PHP 8)

pcntl_signal_get_handler — Get the current handler for specified signal

说明

pcntl_signal_get_handler ( int $signo ) : mixed

The pcntl_signal_get_handler() function will get the current handler for the specified signo.

参数

signo

The signal number.

返回值

This function may return an integer value that refers to SIG_DFL or SIG_IGN. If you set a custom handler a string value containing the function name is returned.

更新日志

版本 | 说明
7.1.0 | pcntl_signal_get_handler() has been added.

范例

Example #1 pcntl_signal_get_handler() example

<?php
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(0)

function pcntl_test($signo) {}
pcntl_signal(SIGUSR1, 'pcntl_test');
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: string(10) "pcntl_test"

pcntl_signal(SIGUSR1, SIG_DFL);
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(0)

pcntl_signal(SIGUSR1, SIG_IGN);
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(1)
?>

参见

  • pcntl_signal() - 安装一个信号处理器


安装一个信号处理器

  • ? pcntl_signal_get_handler
  • pcntl_sigprocmask ?
  • PHP Manual
  • PCNTL 函数
  • 安装一个信号处理器

pcntl_signal

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_signal — 安装一个信号处理器

说明

pcntl_signal ( int $signo , callback $handler , bool $restart_syscalls = true ) : bool

函数pcntl_signal()为signo指定的信号安装一个新 的信号处理器。

参数

signo

信号编号。

handler

信号处理器可以是用户创建的函数或方法的名字，也可以是系统常量 SIG_IGN（译注：忽略信号处理程序）或SIG_DFL（默认信号处理程序）.

Note:

注意当你使用一个对象方法的时候，该对象的引用计数回增加使得它在你改变为其他处理或脚本结束之前是持久存在的。

restart_syscalls

指定当信号到达时系统调用重启是否可用。（译注：经查资料，此参数意为系统调用被信号打断时，系统调用是否从 开始处重新开始，但根据http://bugs.php.net/bug.php?id=52121，此参数存在bug无效。）

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
4.3.0 | 增加参数restart_syscalls。
4.3.0 | 对象方法可以作为回调被使用。
4.3.0 | PCNTL现在使用了ticks作为信号处理的回调机制，ticks在速度上远远超过了之前的处理机制。 这个变化与"用户ticks"遵循了相同的语义。您可以使用declare() 语句在程序中指定允许发生回调的位置。这使得我们对异步事件处理的开销最小化。在编译PHP时 启用pcntl将始终承担这种开销，不论您的脚本中是否真正使用了pcntl。 PHP 4.3.0使用ticks作为信号处理回调机制，这比以前的机制快了很多。这个变化与 "用户ticks" 遵循了相同的语义。您可以使用declare() 语句在程序中指定允许发生回调的位置。

范例

Example #1 pcntl_signal()示例

<?php
//使用ticks需要PHP 4.3.0以上版本
declare(ticks = 1);

//信号处理函数
function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // 处理SIGTERM信号
             exit;
             break;
         case SIGHUP:
             //处理SIGHUP信号
             break;
         case SIGUSR1:
             echo "Caught SIGUSR1...\n";
             break;
         default:
             // 处理所有其他信号
     }

}

echo "Installing signal handler...\n";

//安装信号处理器
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP,  "sig_handler");
pcntl_signal(SIGUSR1, "sig_handler");

// 或者在PHP 4.3.0以上版本可以使用对象方法
// pcntl_signal(SIGUSR1, array($obj, "do_something");

echo "Generating signal SIGTERM to self...\n";

//向当前进程发送SIGUSR1信号
posix_kill(posix_getpid(), SIGUSR1);

echo "Done\n"

?>

参见

  • pcntl_fork() - 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。
  • pcntl_waitpid() - 等待或返回fork的子进程状态


设置或检索阻塞信号

  • ? pcntl_signal
  • pcntl_sigtimedwait ?
  • PHP Manual
  • PCNTL 函数
  • 设置或检索阻塞信号

pcntl_sigprocmask

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

pcntl_sigprocmask — 设置或检索阻塞信号

说明

pcntl_sigprocmask ( int $how , array $set , array &$oldset = ? ) : bool

函数pcntl_sigprocmask()用来增加，删除或设置阻塞信号，具体行为 依赖于参数how。

参数

how

设置pcntl_sigprocmask()函数的行为。 可选值:

  • SIG_BLOCK: 把信号加入到当前阻塞信号中。
  • SIG_UNBLOCK: 从当前阻塞信号中移出信号。
  • SIG_SETMASK: 用给定的信号列表替换当前阻塞信号列表。

set

信号列表。

oldset

oldset是一个输出参数，用来返回之前的阻塞信号列表数组。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 pcntl_sigprocmask() 示例

<?php
//将SIGHUP信号加入到阻塞信号中
pcntl_sigprocmask(SIG_BLOCK, array(SIGHUP));
$oldset = array();
//将SIGHUP从阻塞信号列表中移除并返回之前的阻塞信号列表。
pcntl_sigprocmask(SIG_UNBLOCK, array(SIGHUP), $oldset);
?>

参见

  • pcntl_sigwaitinfo() - 等待信号
  • pcntl_sigtimedwait() - 带超时机制的信号等待


带超时机制的信号等待

  • ? pcntl_sigprocmask
  • pcntl_sigwaitinfo ?
  • PHP Manual
  • PCNTL 函数
  • 带超时机制的信号等待

pcntl_sigtimedwait

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

pcntl_sigtimedwait — 带超时机制的信号等待

说明

pcntl_sigtimedwait ( array $set , array &$siginfo = ? , int $seconds = 0 , int $nanoseconds = 0 ) : int

函数pcntl_sigtimedwait()实际上与pcntl_sigwaitinfo() 的行为一致，不同在于它多了两个增强参数seconds和 nanoseconds，这使得脚本等待的事件有了一个时间的上限。

参数

set

要等待的信号列表数组。

siginfo

siginfo是一个输出参数，用来返回信号的信息。更详细情况参见 pcntl_sigwaitinfo()。

seconds

超时秒数。

nanoseconds

超时纳秒数。

返回值

成功时，函数pcntl_sigtimedwait()返回信号编号。

参见

  • pcntl_sigprocmask() - 设置或检索阻塞信号
  • pcntl_sigwaitinfo() - 等待信号


等待信号

  • ? pcntl_sigtimedwait
  • pcntl_strerror ?
  • PHP Manual
  • PCNTL 函数
  • 等待信号

pcntl_sigwaitinfo

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

pcntl_sigwaitinfo — 等待信号

说明

pcntl_sigwaitinfo ( array $set , array &$siginfo = ? ) : int

pcntl_sigwaitinfo()函数暂停调用脚本的执行直到接收到set 参数中列出的某个信号。只要其中的一个信号已经在等待状态(比如： 通过 pcntl_sigprocmask()函数阻塞)， 函数pcntl_sigwaitinfo()就回立刻返回。

参数

set

要等待的信号数组。

siginfo

siginfo是一个输出参数，用来返回信号的信息。

以下元素会为所有信号设置：

  • signo: 信号编号
  • errno: 错误编号
  • code: 信号代码

下面元素可能会为SIGCHLD信号设置:

  • status: 退出的值或信号
  • utime: 用户消耗的时间
  • stime: 系统（内核）消耗的时间
  • pid: 发送进程ID
  • uid: 发送进程的实际用户ID

信号SIGILL, SIGFPE, SIGSEGV 和 SIGBUS 可能会被设置的元素:

  • addr: 发生故障的内存位置

可能会为SIGPOLL 信号设置的元素：

  • band: Band event
  • fd: 文件描述符

返回值

成功时，函数pcntl_sigwaitinfo()返回一个信号编号。

范例

Example #1 pcntl_sigwaitinfo() example

<?php
echo "Blocking SIGHUP signal\n";
pcntl_sigprocmask(SIG_BLOCK, array(SIGHUP));

echo "Sending SIGHUP to self\n";
posix_kill(posix_getpid(), SIGHUP);

echo "Waiting for signals\n";
$info = array();
pcntl_sigwaitinfo(array(SIGHUP), $info);
?>

参见

  • pcntl_sigprocmask() - 设置或检索阻塞信号
  • pcntl_sigtimedwait() - 带超时机制的信号等待


Retrieve the system error message associated with the given errno

  • ? pcntl_sigwaitinfo
  • pcntl_wait ?
  • PHP Manual
  • PCNTL 函数
  • Retrieve the system error message associated with the given errno

pcntl_strerror

(PHP 5 >= 5.3.4, PHP 7, PHP 8)

pcntl_strerror — Retrieve the system error message associated with the given errno

说明

pcntl_strerror ( int $errno ) : string|false

Warning

本函数还未编写文档，仅有参数列表。

参数

errno

返回值

Returns error description on success 或者在失败时返回 false.

参见

  • pcntl_get_last_error() - Retrieve the error number set by the last pcntl function which failed


等待或返回 fork 的子进程状态

  • ? pcntl_strerror
  • pcntl_waitpid ?
  • PHP Manual
  • PCNTL 函数
  • 等待或返回 fork 的子进程状态

pcntl_wait

(PHP 5, PHP 7, PHP 8)

pcntl_wait — 等待或返回 fork 的子进程状态

说明

pcntl_wait ( int &$status , int $options = 0 , array &$rusage = ? ) : int

wait函数挂起当前进程的执行直到一个子进程退出或接收到一个信号要求中断当前进程或调用一个信号处理函数。如果一个子进程在调用此函数时已经退出（俗称僵尸进程），此函数立刻返回。子进程使用的所有系统资源将被释放。关于 wait 在您系统上工作的详细规范请查看您系统的 wait（2）手册。

Note:

这个函数等同于以 -1 作为参数 pid 的值并且没有 options 参数来调用 pcntl_waitpid() 函数。

参数

status

pcntl_wait() 将会存储状态信息到 status
参数上，这个通过 status 参数返回的状态信息可以用以下函数
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() 以及
pcntl_wstopsig() 获取其具体的值。

options

如果您的操作系统（多数BSD类系统）允许使用 wait3，您可以提供可选的options 参数。如果这个参数没有提供，wait将会被用作系统调用。如果wait3不可用，提供参数 options 不会有任何效果。options 的值可以是0 或者以下两个常量或两个常量"或运算"结果（即两个常量代表意义都有效）。

options可用值
WNOHANG | 如果没有子进程退出立刻返回。
WUNTRACED | 子进程已经退出并且其状态未报告时返回。

返回值

pcntl_wait() 返回退出的子进程进程号，发生错误时返回 -1,如果提供了 WNOHANG 作为 option（wait3可用的系统）并且没有可用子进程时返回 0。

参见

  • pcntl_fork() - 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。
  • pcntl_signal() - 安装一个信号处理器
  • pcntl_wifexited() - 检查状态代码是否代表一个正常的退出。
  • pcntl_wifstopped() - 检查子进程当前是否已经停止
  • pcntl_wifsignaled() - 检查子进程状态码是否代表由于某个信号而中断
  • pcntl_wexitstatus() - 返回一个中断的子进程的返回代码
  • pcntl_wtermsig() - 返回导致子进程中断的信号
  • pcntl_wstopsig() - 返回导致子进程停止的信号
  • pcntl_waitpid() - 等待或返回fork的子进程状态


等待或返回fork的子进程状态

  • ? pcntl_wait
  • pcntl_wexitstatus ?
  • PHP Manual
  • PCNTL 函数
  • 等待或返回fork的子进程状态

pcntl_waitpid

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_waitpid — 等待或返回fork的子进程状态

说明

pcntl_waitpid ( int $pid , int &$status , int $options = 0 ) : int

挂起当前进程的执行直到参数pid指定的进程号的进程退出， 或接收到一个信号要求中断当前进程或调用一个信号处理函数。

如果pid指定的子进程在此函数调用时已经退出（俗称僵尸进程），此函数 将立刻返回。关于waitpid更详细的规范请参见您系统的waitpid（2）手册。

参数

pid

参数pid的值可以是以下之一：

pid可选值
< -1 | 等待任意进程组ID等于参数pid给定值的绝对值的进程。
-1 | 等待任意子进程;与pcntl_wait函数行为一致。
0 | 等待任意与调用进程组ID相同的子进程。
> 0 | 等待进程号等于参数pid值的子进程。

Note:

指定-1作为pid的值等同于pcntl_wait() 提供(负的options)。

status

pcntl_waitpid()将会存储状态信息到status
参数上，这个通过status参数返回的状态信息可以用以下函数
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig()以及
pcntl_wstopsig()获取其具体的值。

options

如果您的操作系统（多数BSD类系统）允许使用wait3，您可以提供可选的options 参数。如果这个参数没有提供，wait将会被用作系统调用。如果wait3不可用，提供参数 options不会有任何效果。options的值可以是0 或者以下两个常量或两个常量"或运算"结果（即两个常量代表意义都有效）。

options可用的值
WNOHANG | 如果没有子进程退出立刻返回。
WUNTRACED | 子进程已经退出并且其状态未报告时返回。

返回值

pcntl_waitpid()返回退出的子进程进程号，发生错误时返回-1,如果提供了 WNOHANG作为option（wait3可用的系统）并且没有可用子进程时返回0。

参见

  • pcntl_fork() - 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。
  • pcntl_signal() - 安装一个信号处理器
  • pcntl_wifexited() - 检查状态代码是否代表一个正常的退出。
  • pcntl_wifstopped() - 检查子进程当前是否已经停止
  • pcntl_wifsignaled() - 检查子进程状态码是否代表由于某个信号而中断
  • pcntl_wexitstatus() - 返回一个中断的子进程的返回代码
  • pcntl_wtermsig() - 返回导致子进程中断的信号
  • pcntl_wstopsig() - 返回导致子进程停止的信号


返回一个中断的子进程的返回代码

  • ? pcntl_waitpid
  • pcntl_wifexited ?
  • PHP Manual
  • PCNTL 函数
  • 返回一个中断的子进程的返回代码

pcntl_wexitstatus

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wexitstatus — 返回一个中断的子进程的返回代码

说明

pcntl_wexitstatus ( int $status ) : int

返回一个中断的子进程的返回代码。这个函数仅在函数pcntl_wifexited()返回 true.时有效。

参数

status

参数 status 是提供给成功调用 pcntl_waitpid() 时的状态参数。

返回值

返回整形的子进程返回代码。

参见

  • pcntl_waitpid() - 等待或返回fork的子进程状态
  • pcntl_wifexited() - 检查状态代码是否代表一个正常的退出。


检查状态代码是否代表一个正常的退出。

  • ? pcntl_wexitstatus
  • pcntl_wifsignaled ?
  • PHP Manual
  • PCNTL 函数
  • 检查状态代码是否代表一个正常的退出。

pcntl_wifexited

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wifexited — 检查状态代码是否代表一个正常的退出。

说明

pcntl_wifexited ( int $status ) : bool

检查子进程状态代码是否代表正常退出。

参数

status

参数 status 是提供给成功调用 pcntl_waitpid() 时的状态参数。

返回值

当子进程状态代码代表正常退出时返回 true ，其他情况返回 false。

参见

  • pcntl_waitpid() - 等待或返回fork的子进程状态
  • pcntl_wexitstatus() - 返回一个中断的子进程的返回代码


检查子进程状态码是否代表由于某个信号而中断

  • ? pcntl_wifexited
  • pcntl_wifstopped ?
  • PHP Manual
  • PCNTL 函数
  • 检查子进程状态码是否代表由于某个信号而中断

pcntl_wifsignaled

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wifsignaled — 检查子进程状态码是否代表由于某个信号而中断

说明

pcntl_wifsignaled ( int $status ) : bool

检查子进程是否是由于某个未捕获的信号退出的。

参数

status

参数 status 是提供给成功调用 pcntl_waitpid() 时的状态参数。

返回值

如果子进程是由于某个未捕获的信号退出的返回 true ，其他情况返回 false 。

参见

  • pcntl_waitpid() - 等待或返回fork的子进程状态
  • pcntl_signal() - 安装一个信号处理器


检查子进程当前是否已经停止

  • ? pcntl_wifsignaled
  • pcntl_wstopsig ?
  • PHP Manual
  • PCNTL 函数
  • 检查子进程当前是否已经停止

pcntl_wifstopped

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wifstopped — 检查子进程当前是否已经停止

说明

pcntl_wifstopped ( int $status ) : bool

仅查子进程当前是否停止; 此函数只有作用于使用了WUNTRACED作为 option的pcntl_waitpid()函数调用产生的status时才有效。

参数

status

参数 status 是提供给成功调用 pcntl_waitpid() 时的状态参数。

返回值

如果子进程当前是停止的返回 true ，其他情况返回 false 。

参见

  • pcntl_waitpid() - 等待或返回fork的子进程状态


返回导致子进程停止的信号

  • ? pcntl_wifstopped
  • pcntl_wtermsig ?
  • PHP Manual
  • PCNTL 函数
  • 返回导致子进程停止的信号

pcntl_wstopsig

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wstopsig — 返回导致子进程停止的信号

说明

pcntl_wstopsig ( int $status ) : int

返回导致子进程停止的信号编号。这个函数仅在pcntl_wifstopped()返回 true 时有效。

参数

status

参数 status 是提供给成功调用 pcntl_waitpid() 时的状态参数。

返回值

返回信号编号。

参见

  • pcntl_waitpid() - 等待或返回fork的子进程状态
  • pcntl_wifstopped() - 检查子进程当前是否已经停止


返回导致子进程中断的信号

  • ? pcntl_wstopsig
  • POSIX ?
  • PHP Manual
  • PCNTL 函数
  • 返回导致子进程中断的信号

pcntl_wtermsig

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

pcntl_wtermsig — 返回导致子进程中断的信号

说明

pcntl_wtermsig ( int $status ) : int

返回导致子进程中断的信号编号。这个函数仅在pcntl_wifsignaled() 返回 true 时有效。

参数

status

参数 status 是提供给成功调用 pcntl_waitpid() 时的状态参数。

返回值

返回整型的信号编号。

参见

  • pcntl_waitpid() - 等待或返回fork的子进程状态
  • pcntl_signal() - 安装一个信号处理器
  • pcntl_wifsignaled() - 检查子进程状态码是否代表由于某个信号而中断


POSIX

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
    • posix_access constants
    • posix_mknod constants
    • posix_setrlimit constants
  • POSIX 函数
    • posix_access — Determine accessibility of a file
    • posix_ctermid — Get path name of controlling terminal
    • posix_errno — 别名 posix_get_last_error
    • posix_get_last_error — Retrieve the error number set by the last posix function that failed
    • posix_getcwd — Pathname of current directory
    • posix_getegid — Return the effective group ID of the current process
    • posix_geteuid — Return the effective user ID of the current process
    • posix_getgid — Return the real group ID of the current process
    • posix_getgrgid — Return info about a group by group id
    • posix_getgrnam — Return info about a group by name
    • posix_getgroups — Return the group set of the current process
    • posix_getlogin — Return login name
    • posix_getpgid — Get process group id for job control
    • posix_getpgrp — Return the current process group identifier
    • posix_getpid — 返回当前进程 id
    • posix_getppid — Return the parent process identifier
    • posix_getpwnam — Return info about a user by username
    • posix_getpwuid — Return info about a user by user id
    • posix_getrlimit — Return info about system resource limits
    • posix_getsid — Get the current sid of the process
    • posix_getuid — Return the real user ID of the current process
    • posix_initgroups — Calculate the group access list
    • posix_isatty — Determine if a file descriptor is an interactive terminal
    • posix_kill — Send a signal to a process
    • posix_mkfifo — Create a fifo special file (a named pipe)
    • posix_mknod — Create a special or ordinary file (POSIX.1)
    • posix_setegid — Set the effective GID of the current process
    • posix_seteuid — Set the effective UID of the current process
    • posix_setgid — Set the GID of the current process
    • posix_setpgid — Set process group id for job control
    • posix_setrlimit — Set system resource limits
    • posix_setsid — Make the current process a session leader
    • posix_setuid — Set the UID of the current process
    • posix_strerror — Retrieve the system error message associated with the given errno
    • posix_times — Get process times
    • posix_ttyname — Determine terminal device name
    • posix_uname — Get system name


简介

This module contains an interface to those functions defined in the IEEE 1003.1 (POSIX.1) standards document which are not accessible through other means.

Warning

Sensitive data can be retrieved with the POSIX functions, e.g. posix_getpwnam() and friends.

Note: 此扩展在 Windows 平台上不可用。


安装

POSIX functions are enabled by default. You can disable POSIX-like functions with --disable-posix.


预定义常量

Table of Contents

  • posix_access constants
  • posix_mknod constants
  • posix_setrlimit constants

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。


posix_access constants

  • ? 预定义常量
  • posix_mknod constants ?
  • PHP Manual
  • 预定义常量
  • posix_access constants

posix_access() constants

Note:

These constants are available starting with PHP 5.1.0. Please note that some of them may not be available on your system.

POSIX_F_OK (int)
Check whether the file exists.
POSIX_R_OK (int)
Check whether the file exists and has read permissions.
POSIX_W_OK (int)
Check whether the file exists and has write permissions.
POSIX_X_OK (int)
Check whether the file exists and has execute permissions.


posix_mknod constants

  • ? posix_access constants
  • posix_setrlimit constants ?
  • PHP Manual
  • 预定义常量
  • posix_mknod constants

posix_mknod() constants

Note:

These constants are available starting with PHP 5.1.0. Please note that some of them may not be available on your system.

POSIX_S_IFBLK (int)
Block special file
POSIX_S_IFCHR (int)
Character special file
POSIX_S_IFIFO (int)
FIFO (named pipe) special file
POSIX_S_IFREG (int)
Normal file
POSIX_S_IFSOCK (int)
Socket


posix_setrlimit constants

  • ? posix_mknod constants
  • POSIX 函数 ?
  • PHP Manual
  • 预定义常量
  • posix_setrlimit constants

posix_setrlimit() constants

Note:

These constants are available starting with PHP 7.0.0. Please note that some of them may not be available on your system.

Note:

You may wish to read the below notes in conjunction with the manpage for setrlimit() on your specific operating system, as there is variance in how these limits are interpreted, even across operating systems that claim to implement POSIX in full.

POSIX_RLIMIT_AS (int)
The maximum size of the process's address space in bytes. See also PHP's memory_limit configuration directive.
POSIX_RLIMIT_CORE (int)
The maximum size of a core file. If the limit is set to 0, no core file will be generated.
POSIX_RLIMIT_CPU (int)
The maximum amount of CPU time that the process can use, in seconds. When the soft limit is hit, a SIGXCPU signal will be sent, which can be caught with pcntl_signal(). Depending on the operating system, additional SIGXCPU signals may be sent each second until the hard limit is hit, at which point an uncatchable SIGKILL signal is sent. See also set_time_limit().
POSIX_RLIMIT_DATA (int)
The maximum size of the process's data segment, in bytes. It is extremely unlikely that this will have any effect on the execution of PHP unless an extension is in use that calls brk() or sbrk().
POSIX_RLIMIT_FSIZE (int)
The maximum size of files that the process can create, in bytes.
POSIX_RLIMIT_LOCKS (int)
The maximum number of locks that the process can create. This is only supported on extremely old Linux kernels.
POSIX_RLIMIT_MEMLOCK (int)
The maximum number of bytes that can be locked into memory.
POSIX_RLIMIT_MSGQUEUE (int)
The maximum number of bytes that can be allocated for POSIX message queues. PHP does not ship with support for POSIX message queues, so this limit will not have any effect unless you are using an extension that implements that support.
POSIX_RLIMIT_NICE (int)
The maximum value to which the process can be reniced to. The value that will be used will be 20 - limit, as resource limit values cannot be negative.
POSIX_RLIMIT_NOFILE (int)
A value one greater than the maximum file descriptor number that can be opened by this process.
POSIX_RLIMIT_NPROC (int)
The maximum number of processes (and/or threads, on some operating systems) that can be created for the real user ID of the process.
POSIX_RLIMIT_RSS (int)
The maximum size of the process's resident set, in pages.
POSIX_RLIMIT_RTPRIO (int)
The maximum real time priority that can be set via the sched_setscheduler() and sched_setparam() system calls.
POSIX_RLIMIT_RTTIME (int)
The maximum amount of CPU time, in microseconds, that the process can consume without making a blocking system call if it is using real time scheduling.
POSIX_RLIMIT_SIGPENDING (int)
The maximum number of signals that can be queued for the real user ID of the process.
POSIX_RLIMIT_STACK (int)
The maximum size of the process stack, in bytes.
POSIX_RLIMIT_INFINITY (int)
Used to indicate an infinite value for a resource limit.


POSIX 函数

参见

The section about Process Control Functions maybe of interest for you.

Table of Contents

  • posix_access — Determine accessibility of a file
  • posix_ctermid — Get path name of controlling terminal
  • posix_errno — 别名 posix_get_last_error
  • posix_get_last_error — Retrieve the error number set by the last posix function that failed
  • posix_getcwd — Pathname of current directory
  • posix_getegid — Return the effective group ID of the current process
  • posix_geteuid — Return the effective user ID of the current process
  • posix_getgid — Return the real group ID of the current process
  • posix_getgrgid — Return info about a group by group id
  • posix_getgrnam — Return info about a group by name
  • posix_getgroups — Return the group set of the current process
  • posix_getlogin — Return login name
  • posix_getpgid — Get process group id for job control
  • posix_getpgrp — Return the current process group identifier
  • posix_getpid — 返回当前进程 id
  • posix_getppid — Return the parent process identifier
  • posix_getpwnam — Return info about a user by username
  • posix_getpwuid — Return info about a user by user id
  • posix_getrlimit — Return info about system resource limits
  • posix_getsid — Get the current sid of the process
  • posix_getuid — Return the real user ID of the current process
  • posix_initgroups — Calculate the group access list
  • posix_isatty — Determine if a file descriptor is an interactive terminal
  • posix_kill — Send a signal to a process
  • posix_mkfifo — Create a fifo special file (a named pipe)
  • posix_mknod — Create a special or ordinary file (POSIX.1)
  • posix_setegid — Set the effective GID of the current process
  • posix_seteuid — Set the effective UID of the current process
  • posix_setgid — Set the GID of the current process
  • posix_setpgid — Set process group id for job control
  • posix_setrlimit — Set system resource limits
  • posix_setsid — Make the current process a session leader
  • posix_setuid — Set the UID of the current process
  • posix_strerror — Retrieve the system error message associated with the given errno
  • posix_times — Get process times
  • posix_ttyname — Determine terminal device name
  • posix_uname — Get system name


Determine accessibility of a file

  • ? POSIX 函数
  • posix_ctermid ?
  • PHP Manual
  • POSIX 函数
  • Determine accessibility of a file

posix_access

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

posix_access — Determine accessibility of a file

说明

posix_access ( string $filename , int $flags = 0 ) : bool

posix_access() checks the user's permission of a file.

参数

filename

The name of the file to be tested.

flags

A mask consisting of one or more of POSIX_F_OK, POSIX_R_OK, POSIX_W_OK and POSIX_X_OK.

POSIX_R_OK, POSIX_W_OK and POSIX_X_OK request checking whether the file exists and has read, write and execute permissions, respectively. POSIX_F_OK just requests checking for the existence of the file.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 posix_access() example

This example will check if the $file is readable and writable, otherwise will print an error message.

<?php

$file = 'some_file';

if (posix_access($file, POSIX_R_OK | POSIX_W_OK)) {
    echo 'The file is readable and writable!';

} else {
    $error = posix_get_last_error();

    echo "Error $error: " . posix_strerror($error);
}

?>

注释

参见

  • posix_get_last_error() - Retrieve the error number set by the last posix function that failed
  • posix_strerror() - Retrieve the system error message associated with the given errno


Get path name of controlling terminal

  • ? posix_access
  • posix_errno ?
  • PHP Manual
  • POSIX 函数
  • Get path name of controlling terminal

posix_ctermid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_ctermid — Get path name of controlling terminal

说明

posix_ctermid ( ) : string|false

Generates a string which is the pathname for the current controlling terminal for the process. On error this will set errno, which can be checked using posix_get_last_error()

返回值

Upon successful completion, returns string of the pathname to the current controlling terminal. Otherwise false is returned and errno is set, which can be checked with posix_get_last_error().

范例

Example #1 posix_ctermid() example

This example will display the path to the current TTY.

<?php
echo "I am running from ".posix_ctermid();
?>

参见

  • posix_ttyname() - Determine terminal device name
  • posix_get_last_error() - Retrieve the error number set by the last posix function that failed


别名 posix_get_last_error

  • ? posix_ctermid
  • posix_get_last_error ?
  • PHP Manual
  • POSIX 函数
  • 别名 posix_get_last_error

posix_errno

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

posix_errno — 别名 posix_get_last_error()

说明

此函数是该函数的别名： posix_get_last_error().


Retrieve the error number set by the last posix function that failed

  • ? posix_errno
  • posix_getcwd ?
  • PHP Manual
  • POSIX 函数
  • Retrieve the error number set by the last posix function that failed

posix_get_last_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

posix_get_last_error — Retrieve the error number set by the last posix function that failed

说明

posix_get_last_error ( ) : int

Retrieve the error number set by the last posix function that failed. The system error message associated with the errno may be checked with posix_strerror().

返回值

Returns the errno (error number) set by the last posix function that failed. If no errors exist, 0 is returned.

范例

Example #1 posix_get_last_error() example

This example attempt to kill a bogus process id, which will set the last error. We will then print out the last errno.

<?php
posix_kill(999459,SIGKILL);
echo 'Your error returned was '.posix_get_last_error(); //Your error was ___
?>

参见

  • posix_strerror() - Retrieve the system error message associated with the given errno


Pathname of current directory

  • ? posix_get_last_error
  • posix_getegid ?
  • PHP Manual
  • POSIX 函数
  • Pathname of current directory

posix_getcwd

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getcwd — Pathname of current directory

说明

posix_getcwd ( ) : string|false

Gets the absolute pathname of the script's current working directory. On error, it sets errno which can be checked using posix_get_last_error()

返回值

Returns a string of the absolute pathname on success. On error, returns false and sets errno which can be checked with posix_get_last_error().

范例

Example #1 posix_getcwd() example

This example will return the absolute path of the current working directory of the script.

<?php
echo 'My current working directory is '.posix_getcwd();
?>

注释

Note:

This function can fail on

  • Read or Search permission was denied
  • Pathname no longer exists


Return the effective group ID of the current process

  • ? posix_getcwd
  • posix_geteuid ?
  • PHP Manual
  • POSIX 函数
  • Return the effective group ID of the current process

posix_getegid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getegid — Return the effective group ID of the current process

说明

posix_getegid ( ) : int

Return the numeric effective group ID of the current process.

返回值

Returns an int of the effective group ID.

范例

Example #1 posix_getegid() example

This example will print out the effective group id, once it is changed with posix_setegid().

<?php
echo 'My real group id is '.posix_getgid(); //20
posix_setegid(40);
echo 'My real group id is '.posix_getgid(); //20
echo 'My effective group id is '.posix_getegid(); //40
?>

注释

posix_getegid() is different than posix_getgid() because effective group ID can be changed by a calling process using posix_setegid().

参见

  • posix_getgrgid() - Return info about a group by group id
  • posix_getgid() - Return the real group ID of the current process
  • posix_setgid() - Set the GID of the current process


Return the effective user ID of the current process

  • ? posix_getegid
  • posix_getgid ?
  • PHP Manual
  • POSIX 函数
  • Return the effective user ID of the current process

posix_geteuid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_geteuid — Return the effective user ID of the current process

说明

posix_geteuid ( ) : int

Return the numeric effective user ID of the current process. See also posix_getpwuid() for information on how to convert this into a useable username.

返回值

Returns the user id, as an int

范例

Example #1 posix_geteuid() example

This example will show the current user id then set the effective user id to a separate id using posix_seteuid(), then show the difference between the real id and the effective id.

<?php
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10001
posix_seteuid(10000);
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10000
?>

参见

  • posix_getpwuid() - Return info about a user by user id
  • posix_getuid() - Return the real user ID of the current process
  • posix_setuid() - Set the UID of the current process
  • POSIX man page GETEUID(2)


Return the real group ID of the current process

  • ? posix_geteuid
  • posix_getgrgid ?
  • PHP Manual
  • POSIX 函数
  • Return the real group ID of the current process

posix_getgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getgid — Return the real group ID of the current process

说明

posix_getgid ( ) : int

Return the numeric real group ID of the current process.

返回值

Returns the real group id, as an int.

范例

Example #1 posix_getgid() example

This example will print out the real group id, even once the effective group id has been changed.

<?php
echo 'My real group id is '.posix_getgid(); //20
posix_setegid(40);
echo 'My real group id is '.posix_getgid(); //20
echo 'My effective group id is '.posix_getegid(); //40
?>

参见

  • posix_getgrgid() - Return info about a group by group id
  • posix_getegid() - Return the effective group ID of the current process
  • posix_setgid() - Set the GID of the current process
  • POSIX man page GETGID(2)


Return info about a group by group id

  • ? posix_getgid
  • posix_getgrnam ?
  • PHP Manual
  • POSIX 函数
  • Return info about a group by group id

posix_getgrgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getgrgid — Return info about a group by group id

说明

posix_getgrgid ( int $group_id ) : array|false

Gets information about a group provided its id.

参数

group_id

The group id.

返回值

The array elements returned are:

The group information array
Element | Description
name | The name element contains the name of the group. This is a short, usually less than 16 character "handle" of the group, not the real, full name.
passwd | The passwd element contains the group's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
gid | Group ID, should be the same as the group_id parameter used when calling the function, and hence redundant.
members | This consists of an array of string's for all the members in the group.
The function returns false on failure.

范例

Example #1 Example use of posix_getgrgid()

<?php

$groupid   = posix_getegid();
$groupinfo = posix_getgrgid($groupid);

print_r($groupinfo);
?>

以上例程的输出类似于：

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

参见

  • posix_getegid() - Return the effective group ID of the current process
  • posix_getgrnam() - Return info about a group by name
  • filegroup() - 取得文件的组
  • stat() - 给出文件的信息
  • POSIX man page GETGRNAM(3)


Return info about a group by name

  • ? posix_getgrgid
  • posix_getgroups ?
  • PHP Manual
  • POSIX 函数
  • Return info about a group by name

posix_getgrnam

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getgrnam — Return info about a group by name

说明

posix_getgrnam ( string $name ) : array|false

Gets information about a group provided its name.

参数

name

The name of the group

返回值

Returns an array on success, 或者在失败时返回 false. The array elements returned are:

The group information array
Element | Description
name | The name element contains the name of the group. This is a short, usually less than 16 character "handle" of the group, not the real, full name. This should be the same as the name parameter used when calling the function, and hence redundant.
passwd | The passwd element contains the group's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
gid | Group ID of the group in numeric form.
members | This consists of an array of string's for all the members in the group.

范例

Example #1 Example use of posix_getgrnam()

<?php

$groupinfo = posix_getgrnam("toons");

print_r($groupinfo);
?>

以上例程的输出类似于：

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

参见

  • posix_getegid() - Return the effective group ID of the current process
  • posix_getgrgid() - Return info about a group by group id
  • filegroup() - 取得文件的组
  • stat() - 给出文件的信息
  • POSIX man page GETGRNAM(3)


Return the group set of the current process

  • ? posix_getgrnam
  • posix_getlogin ?
  • PHP Manual
  • POSIX 函数
  • Return the group set of the current process

posix_getgroups

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getgroups — Return the group set of the current process

说明

posix_getgroups ( ) : array|false

Gets the group set of the current process.

返回值

Returns an array of integers containing the numeric group ids of the group set of the current process, 或者在失败时返回 false.

范例

Example #1 Example use of posix_getgroups()

<?php

$groups = posix_getgroups();

print_r($groups);
?>

以上例程的输出类似于：

Array
(
    [0] => 4
    [1] => 20
    [2] => 24
    [3] => 25
    [4] => 29
    [5] => 30
    [6] => 33
    [7] => 44
    [8] => 46
    [9] => 104
    [10] => 109
    [11] => 110
    [12] => 1000
)

参见

  • posix_getgrgid() - Return info about a group by group id


Return login name

  • ? posix_getgroups
  • posix_getpgid ?
  • PHP Manual
  • POSIX 函数
  • Return login name

posix_getlogin

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getlogin — Return login name

说明

posix_getlogin ( ) : string|false

Returns the login name of the user owning the current process.

返回值

Returns the login name of the user, as a string, 或者在失败时返回 false.

范例

Example #1 Example use of posix_getlogin()

<?php
echo posix_getlogin(); //apache
?>

参见

  • posix_getpwnam() - Return info about a user by username
  • POSIX man page GETLOGIN(3)


Get process group id for job control

  • ? posix_getlogin
  • posix_getpgrp ?
  • PHP Manual
  • POSIX 函数
  • Get process group id for job control

posix_getpgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpgid — Get process group id for job control

说明

posix_getpgid ( int $process_id ) : int|false

Returns the process group identifier of the process process_id 或者在失败时返回 false.

参数

process_id

The process id.

返回值

Returns the identifier, as an int.

范例

Example #1 Example use of posix_getpgid()

<?php
$pid = posix_getppid();
echo posix_getpgid($pid); //35
?>

注释

Note:

This is a not POSIX function, but is common on BSD and System V systems. If the system does not support this function, then it will not be included at compile time. This may be checked with function_exists().

参见

  • posix_getppid() - Return the parent process identifier
  • man page SETPGID(2)


Return the current process group identifier

  • ? posix_getpgid
  • posix_getpid ?
  • PHP Manual
  • POSIX 函数
  • Return the current process group identifier

posix_getpgrp

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpgrp — Return the current process group identifier

说明

posix_getpgrp ( ) : int

Return the process group identifier of the current process.

返回值

Returns the identifier, as an int.

参见

  • POSIX.1 and the getpgrp(2) manual page on the POSIX system for more information on process groups.


返回当前进程 id

  • ? posix_getpgrp
  • posix_getppid ?
  • PHP Manual
  • POSIX 函数
  • 返回当前进程 id

posix_getpid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpid — 返回当前进程 id

说明

posix_getpid ( ) : int

Return the process identifier of the current process. 返回当前进程的 id

返回值

返回进程 id 号，是整型（integer）。

范例

Example #1 posix_getpid() 的使用例子

<?php
echo posix_getpid(); //8805
?>

参见

  • posix_kill() - Send a signal to a process
  • POSIX man page GETPID(2)


Return the parent process identifier

  • ? posix_getpid
  • posix_getpwnam ?
  • PHP Manual
  • POSIX 函数
  • Return the parent process identifier

posix_getppid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getppid — Return the parent process identifier

说明

posix_getppid ( ) : int

Return the process identifier of the parent process of the current process.

返回值

Returns the identifier, as an int.

范例

Example #1 Example use of posix_getppid()

<?php
echo posix_getppid(); //8259
?>


Return info about a user by username

  • ? posix_getppid
  • posix_getpwuid ?
  • PHP Manual
  • POSIX 函数
  • Return info about a user by username

posix_getpwnam

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpwnam — Return info about a user by username

说明

posix_getpwnam ( string $username ) : array|false

Returns an array of information about the given user.

参数

username

An alphanumeric username.

返回值

On success an array with the following elements is returned, else false is returned:

The user information array
Element | Description
name | The name element contains the username of the user. This is a short, usually less than 16 character "handle" of the user, not the real, full name. This should be the same as the username parameter used when calling the function, and hence redundant.
passwd | The passwd element contains the user's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
uid | User ID of the user in numeric form.
gid | The group ID of the user. Use the function posix_getgrgid() to resolve the group name and a list of its members.
gecos | GECOS is an obsolete term that refers to the finger information field on a Honeywell batch processing system. The field, however, lives on, and its contents have been formalized by POSIX. The field contains a comma separated list containing the user's full name, office phone, office number, and home phone number. On most systems, only the user's full name is available.
dir | This element contains the absolute path to the home directory of the user.
shell | The shell element contains the absolute path to the executable of the user's default shell.

范例

Example #1 Example use of posix_getpwnam()

<?php

$userinfo = posix_getpwnam("tom");

print_r($userinfo);
?>

以上例程的输出类似于：

Array
(
    [name]    => tom
    [passwd]  => x
    [uid]     => 10000
    [gid]     => 42
    [gecos]   => "tom,,,"
    [dir]     => "/home/tom"
    [shell]   => "/bin/bash"
)

参见

  • posix_getpwuid() - Return info about a user by user id
  • POSIX man page GETPWNAM(3)


Return info about a user by user id

  • ? posix_getpwnam
  • posix_getrlimit ?
  • PHP Manual
  • POSIX 函数
  • Return info about a user by user id

posix_getpwuid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getpwuid — Return info about a user by user id

说明

posix_getpwuid ( int $user_id ) : array|false

Returns an array of information about the user referenced by the given user ID.

参数

user_id

The user identifier.

返回值

Returns an associative array with the following elements:

The user information array
Element | Description
name | The name element contains the username of the user. This is a short, usually less than 16 character "handle" of the user, not the real, full name.
passwd | The passwd element contains the user's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
uid | User ID, should be the same as the user_id parameter used when calling the function, and hence redundant.
gid | The group ID of the user. Use the function posix_getgrgid() to resolve the group name and a list of its members.
gecos | GECOS is an obsolete term that refers to the finger information field on a Honeywell batch processing system. The field, however, lives on, and its contents have been formalized by POSIX. The field contains a comma separated list containing the user's full name, office phone, office number, and home phone number. On most systems, only the user's full name is available.
dir | This element contains the absolute path to the home directory of the user.
shell | The shell element contains the absolute path to the executable of the user's default shell.
The function returns false on failure.

范例

Example #1 Example use of posix_getpwuid()

<?php

$userinfo = posix_getpwuid(10000);

print_r($userinfo);
?>

以上例程的输出类似于：

Array
(
    [name]    => tom
    [passwd]  => x
    [uid]     => 10000
    [gid]     => 42
    [gecos]   => "tom,,,"
    [dir]     => "/home/tom"
    [shell]   => "/bin/bash"
)

参见

  • posix_getpwnam() - Return info about a user by username
  • POSIX man page GETPWNAM(3)


Return info about system resource limits

  • ? posix_getpwuid
  • posix_getsid ?
  • PHP Manual
  • POSIX 函数
  • Return info about system resource limits

posix_getrlimit

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getrlimit — Return info about system resource limits

说明

posix_getrlimit ( ) : array|false

posix_getrlimit() returns an array of information about the current resource's soft and hard limits.

Each resource has an associated soft and hard limit. The soft limit is the value that the kernel enforces for the corresponding resource. The hard limit acts as a ceiling for the soft limit. An unprivileged process may only set its soft limit to a value from 0 to the hard limit, and irreversibly lower its hard limit.

返回值

Returns an associative array of elements for each limit that is defined. Each limit has a soft and a hard limit.

List of possible limits returned
Limit name | Limit description
core | The maximum size of the core file. When 0, not core files are created. When core files are larger than this size, they will be truncated at this size.
totalmem | The maximum size of the memory of the process, in bytes.
virtualmem | The maximum size of the virtual memory for the process, in bytes.
data | The maximum size of the data segment for the process, in bytes.
stack | The maximum size of the process stack, in bytes.
rss | The maximum number of virtual pages resident in RAM
maxproc | The maximum number of processes that can be created for the real user ID of the calling process.
memlock | The maximum number of bytes of memory that may be locked into RAM.
cpu | The amount of time the process is allowed to use the CPU.
filesize | The maximum size of the data segment for the process, in bytes.
openfiles | One more than the maximum number of open file descriptors.
The function returns false on failure.

范例

Example #1 Example use of posix_getrlimit()

<?php

$limits = posix_getrlimit();

print_r($limits);
?>

以上例程的输出类似于：

Array
(
    [soft core] => 0
    [hard core] => unlimited
    [soft data] => unlimited
    [hard data] => unlimited
    [soft stack] => 8388608
    [hard stack] => unlimited
    [soft totalmem] => unlimited
    [hard totalmem] => unlimited
    [soft rss] => unlimited
    [hard rss] => unlimited
    [soft maxproc] => unlimited
    [hard maxproc] => unlimited
    [soft memlock] => unlimited
    [hard memlock] => unlimited
    [soft cpu] => unlimited
    [hard cpu] => unlimited
    [soft filesize] => unlimited
    [hard filesize] => unlimited
    [soft openfiles] => 1024
    [hard openfiles] => 1024
)

参见

  • man page GETRLIMIT(2)
  • posix_setrlimit() - Set system resource limits


Get the current sid of the process

  • ? posix_getrlimit
  • posix_getuid ?
  • PHP Manual
  • POSIX 函数
  • Get the current sid of the process

posix_getsid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getsid — Get the current sid of the process

说明

posix_getsid ( int $process_id ) : int|false

Return the session id of the process process_id. The session id of a process is the process group id of the session leader.

参数

process_id

The process identifier. If set to 0, the current process is assumed. If an invalid process_id is specified, then false is returned and an error is set which can be checked with posix_get_last_error().

返回值

Returns the identifier, as an int, 或者在失败时返回 false.

范例

Example #1 Example use of posix_getsid()

<?php
$pid = posix_getpid();
echo posix_getsid($pid); //8805
?>

参见

  • posix_getpgid() - Get process group id for job control
  • posix_setsid() - Make the current process a session leader
  • POSIX man page GETSID(2)


Return the real user ID of the current process

  • ? posix_getsid
  • posix_initgroups ?
  • PHP Manual
  • POSIX 函数
  • Return the real user ID of the current process

posix_getuid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_getuid — Return the real user ID of the current process

说明

posix_getuid ( ) : int

Return the numeric real user ID of the current process.

返回值

Returns the user id, as an int

范例

Example #1 Example use of posix_getuid()

<?php
echo posix_getuid(); //10000
?>

参见

  • posix_getpwuid() - Return info about a user by user id
  • POSIX man page GETUID(2)


Calculate the group access list

  • ? posix_getuid
  • posix_isatty ?
  • PHP Manual
  • POSIX 函数
  • Calculate the group access list

posix_initgroups

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

posix_initgroups — Calculate the group access list

说明

posix_initgroups ( string $username , int $group_id ) : bool

Calculates the group access list for the user specified in name.

参数

username

The user to calculate the list for.

group_id

Typically the group number from the password file.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • The Unix manual page for initgroups(3).


Determine if a file descriptor is an interactive terminal

  • ? posix_initgroups
  • posix_kill ?
  • PHP Manual
  • POSIX 函数
  • Determine if a file descriptor is an interactive terminal

posix_isatty

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_isatty — Determine if a file descriptor is an interactive terminal

说明

posix_isatty ( resource|int $file_descriptor ) : bool

Determines if the file descriptor file_descriptor refers to a valid terminal type device.

参数

fd

The file descriptor, which is expected to be either a file resource or an int. An int will be assumed to be a file descriptor that can be passed directly to the underlying system call.

In almost all cases, you will want to provide a file resource.

返回值

Returns true if file_descriptor is an open descriptor connected to a terminal and false otherwise.

参见

  • posix_ttyname() - Determine terminal device name
  • stream_isatty() - Check if a stream is a TTY


Send a signal to a process

  • ? posix_isatty
  • posix_mkfifo ?
  • PHP Manual
  • POSIX 函数
  • Send a signal to a process

posix_kill

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_kill — Send a signal to a process

说明

posix_kill ( int $process_id , int $signal ) : bool

Send the signal signal to the process with the process identifier process_id.

参数

process_id

The process identifier.

signal

One of the PCNTL signals constants.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • The kill(2) manual page of the POSIX system, which contains additional information about negative process identifiers, the special pid 0, the special pid -1, and the signal number 0.


Create a fifo special file (a named pipe)

  • ? posix_kill
  • posix_mknod ?
  • PHP Manual
  • POSIX 函数
  • Create a fifo special file (a named pipe)

posix_mkfifo

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_mkfifo — Create a fifo special file (a named pipe)

说明

posix_mkfifo ( string $filename , int $permissions ) : bool

posix_mkfifo() creates a special FIFO file which exists in the file system and acts as a bidirectional communication endpoint for processes.

参数

filename

Path to the FIFO file.

permissions

The second parameter permissions has to be given in octal notation (e.g. 0644). The permission of the newly created FIFO also depends on the setting of the current umask(). The permissions of the created file are (mode & ~umask).

返回值

成功时返回 true， 或者在失败时返回 false。


Create a special or ordinary file (POSIX.1)

  • ? posix_mkfifo
  • posix_setegid ?
  • PHP Manual
  • POSIX 函数
  • Create a special or ordinary file (POSIX.1)

posix_mknod

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

posix_mknod — Create a special or ordinary file (POSIX.1)

说明

posix_mknod ( string $filename , int $flags , int $major = 0 , int $minor = 0 ) : bool

Creates a special or ordinary file.

参数

filename

The file to create

flags

This parameter is constructed by a bitwise OR between file type (one of the following constants: POSIX_S_IFREG, POSIX_S_IFCHR, POSIX_S_IFBLK, POSIX_S_IFIFO or POSIX_S_IFSOCK) and permissions.

major

The major device kernel identifier (required to pass when using S_IFCHR or S_IFBLK).

minor

The minor device kernel identifier.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 A posix_mknod() example

<?php

$file = '/tmp/tmpfile';  // file name
$type = POSIX_S_IFBLK;   // file type
$permissions = 0777;     // octal
$major = 1;
$minor = 8;              // /dev/random

if (!posix_mknod($file, $type | $permissions, $major, $minor)) {
    die('Error ' . posix_get_last_error() . ': ' . posix_strerror(posix_get_last_error()));
}

?>

参见

  • posix_mkfifo() - Create a fifo special file (a named pipe)


Set the effective GID of the current process

  • ? posix_mknod
  • posix_seteuid ?
  • PHP Manual
  • POSIX 函数
  • Set the effective GID of the current process

posix_setegid

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

posix_setegid — Set the effective GID of the current process

说明

posix_setegid ( int $group_id ) : bool

Set the effective group ID of the current process. This is a privileged function and needs appropriate privileges (usually root) on the system to be able to perform this function.

参数

group_id

The group id.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 posix_setegid() example

This example will print out the effective group id, once changed.

<?php
echo 'My real group id is '.posix_getgid(); //20
posix_setegid(40);
echo 'My real group id is '.posix_getgid(); //20
echo 'My effective group id is '.posix_getegid(); //40
?>

参见

  • posix_getgrgid() - Return info about a group by group id
  • posix_getgid() - Return the real group ID of the current process
  • posix_setgid() - Set the GID of the current process


Set the effective UID of the current process

  • ? posix_setegid
  • posix_setgid ?
  • PHP Manual
  • POSIX 函数
  • Set the effective UID of the current process

posix_seteuid

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

posix_seteuid — Set the effective UID of the current process

说明

posix_seteuid ( int $user_id ) : bool

Set the effective user ID of the current process. This is a privileged function and needs appropriate privileges (usually root) on the system to be able to perform this function.

参数

user_id

The user id.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • posix_geteuid() - Return the effective user ID of the current process
  • posix_setuid() - Set the UID of the current process
  • posix_getuid() - Return the real user ID of the current process


Set the GID of the current process

  • ? posix_seteuid
  • posix_setpgid ?
  • PHP Manual
  • POSIX 函数
  • Set the GID of the current process

posix_setgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_setgid — Set the GID of the current process

说明

posix_setgid ( int $group_id ) : bool

Set the real group ID of the current process. This is a privileged function and needs appropriate privileges (usually root) on the system to be able to perform this function. The appropriate order of function calls is posix_setgid() first, posix_setuid() last.

Note:

If the caller is a super user, this will also set the effective group id.

参数

group_id

The group id.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 posix_setgid() example

This example will print out the effective group id, once it is changed.

<?php
echo 'My real group id is '.posix_getgid(); //20
posix_setgid(40);
echo 'My real group id is '.posix_getgid(); //40
echo 'My effective group id is '.posix_getegid(); //40
?>

参见

  • posix_getgrgid() - Return info about a group by group id
  • posix_getgid() - Return the real group ID of the current process


Set process group id for job control

  • ? posix_setgid
  • posix_setrlimit ?
  • PHP Manual
  • POSIX 函数
  • Set process group id for job control

posix_setpgid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_setpgid — Set process group id for job control

说明

posix_setpgid ( int $process_id , int $process_group_id ) : bool

Let the process process_id join the process group process_group_id.

参数

process_id

The process id.

process_group_id

The process group id.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • See POSIX.1 and the setsid(2) manual page on the POSIX system for more information on process groups and job control.


Set system resource limits

  • ? posix_setpgid
  • posix_setsid ?
  • PHP Manual
  • POSIX 函数
  • Set system resource limits

posix_setrlimit

(PHP 7, PHP 8)

posix_setrlimit — Set system resource limits

说明

posix_setrlimit ( int $resource , int $soft_limit , int $hard_limit ) : bool

posix_setrlimit() sets the soft and hard limits for a given system resource.

Each resource has an associated soft and hard limit. The soft limit is the value that the kernel enforces for the corresponding resource. The hard limit acts as a ceiling for the soft limit. An unprivileged process may only set its soft limit to a value from 0 to the hard limit, and irreversibly lower its hard limit.

参数

resource

The resource limit constant corresponding to the limit that is being set.

soft_limit

The soft limit, in whatever unit the resource limit requires, or POSIX_RLIMIT_INFINITY.

hard_limit

The hard limit, in whatever unit the resource limit requires, or POSIX_RLIMIT_INFINITY.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • man page SETRLIMIT(2)
  • posix_getrlimit() - Return info about system resource limits


Make the current process a session leader

  • ? posix_setrlimit
  • posix_setuid ?
  • PHP Manual
  • POSIX 函数
  • Make the current process a session leader

posix_setsid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_setsid — Make the current process a session leader

说明

posix_setsid ( ) : int

Make the current process a session leader.

返回值

Returns the session id, or -1 on errors.

参见

  • The POSIX.1 and the setsid(2) manual page on the POSIX system for more information on process groups and job control.


Set the UID of the current process

  • ? posix_setsid
  • posix_strerror ?
  • PHP Manual
  • POSIX 函数
  • Set the UID of the current process

posix_setuid

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_setuid — Set the UID of the current process

说明

posix_setuid ( int $user_id ) : bool

Set the real user ID of the current process. This is a privileged function that needs appropriate privileges (usually root) on the system to be able to perform this function.

参数

user_id

The user id.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 posix_setuid() example

This example will show the current user id and then set it to a different value.

<?php
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10001
posix_setuid(10000);
echo posix_getuid()."\n"; //10000
echo posix_geteuid()."\n"; //10000
?>

参见

  • posix_setgid() - Set the GID of the current process
  • posix_seteuid() - Set the effective UID of the current process
  • posix_getuid() - Return the real user ID of the current process
  • posix_geteuid() - Return the effective user ID of the current process


Retrieve the system error message associated with the given errno

  • ? posix_setuid
  • posix_times ?
  • PHP Manual
  • POSIX 函数
  • Retrieve the system error message associated with the given errno

posix_strerror

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

posix_strerror — Retrieve the system error message associated with the given errno

说明

posix_strerror ( int $error_code ) : string

Returns the POSIX system error message associated with the given error_code. You may get the error_code parameter by calling posix_get_last_error().

参数

error_code

A POSIX error number, returned by posix_get_last_error(). If set to 0, then the string "Success" is returned.

返回值

Returns the error message, as a string.

范例

Example #1 posix_strerror() example

This example will attempt to kill a process which does not exist, then will print out the corresponding error message.

<?php
posix_kill(50,SIGKILL);
echo posix_strerror(posix_get_last_error())."\n";
?>

以上例程的输出类似于：

No such process

参见

  • posix_get_last_error() - Retrieve the error number set by the last posix function that failed


Get process times

  • ? posix_strerror
  • posix_ttyname ?
  • PHP Manual
  • POSIX 函数
  • Get process times

posix_times

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_times — Get process times

说明

posix_times ( ) : array|false

Gets information about the current CPU usage.

返回值

Returns a hash of strings with information about the current process CPU usage. The indices of the hash are:

  • ticks - the number of clock ticks that have elapsed since reboot.
  • utime - user time used by the current process.
  • stime - system time used by the current process.
  • cutime - user time used by current process and children.
  • cstime - system time used by current process and children.
The function returns false on failure.

注释

Warning

This function isn't reliable to use, it may return negative values for high times.

范例

Example #1 Example use of posix_times()

<?php

$times = posix_times();

print_r($times);
?>

以上例程的输出类似于：

Array
(
    [ticks] => 25814410
    [utime] => 1
    [stime] => 1
    [cutime] => 0
    [cstime] => 0
)


Determine terminal device name

  • ? posix_times
  • posix_uname ?
  • PHP Manual
  • POSIX 函数
  • Determine terminal device name

posix_ttyname

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_ttyname — Determine terminal device name

说明

posix_ttyname ( resource|int $file_descriptor ) : string|false

Returns a string for the absolute path to the current terminal device that is open on the file descriptor file_descriptor.

参数

fd

The file descriptor, which is expected to be either a file resource or an int. An int will be assumed to be a file descriptor that can be passed directly to the underlying system call.

In almost all cases, you will want to provide a file resource.

返回值

On success, returns a string of the absolute path of the file_descriptor. On failure, returns false


Get system name

  • ? posix_ttyname
  • 程序执行 ?
  • PHP Manual
  • POSIX 函数
  • Get system name

posix_uname

(PHP 4, PHP 5, PHP 7, PHP 8)

posix_uname — Get system name

说明

posix_uname ( ) : array|false

Gets information about the system.

Posix requires that assumptions must not be made about the format of the values, e.g. the assumption that a release may contain three digits or anything else returned by this function.

返回值

Returns a hash of strings with information about the system. The indices of the hash are

  • sysname - operating system name (e.g. Linux)
  • nodename - system name (e.g. valiant)
  • release - operating system release (e.g. 2.2.10)
  • version - operating system version (e.g. #4 Tue Jul 20 17:01:36 MEST 1999)
  • machine - system architecture (e.g. i586)
  • domainname - DNS domainname (e.g. example.com)

domainname is a GNU extension and not part of POSIX.1, so this field is only available on GNU systems or when using the GNU libc.

The function returns false on failure.

范例

Example #1 Example use of posix_uname()

<?php
$uname=posix_uname();
print_r($uname);
?>

以上例程的输出类似于：

Array
(
    [sysname] => Linux
    [nodename] => funbox
    [release] => 2.6.20-15-server
    [version] => #2 SMP Sun Apr 15 07:41:34 UTC 2007
    [machine] => i686
)


系统程序执行

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 程序执行函数
    • escapeshellarg — 把字符串转码为可以在 shell 命令里使用的参数
    • escapeshellcmd — shell 元字符转义
    • exec — 执行一个外部程序
    • passthru — 执行外部程序并且显示原始输出
    • proc_close — 关闭由 proc_open 打开的进程并且返回进程退出码
    • proc_get_status — 获取由 proc_open 函数打开的进程的信息
    • proc_nice — 修改当前进程的优先级
    • proc_open — 执行一个命令，并且打开用来输入/输出的文件指针。
    • proc_terminate — 杀除由 proc_open 打开的进程
    • shell_exec — 通过 shell 环境执行命令，并且将完整的输出以字符串的方式返回。
    • system — 执行外部程序，并且显示输出


简介

这些函数提供执行系统本身命令的能力， 以及安全执行系统命令。

Note:

在 Windows 平台上，所有命令执行都是通过 cmd.exe 来完成的。 因此，调用这些函数的用户需要拥有运行此命令的相应权限。 但是当使用 bypass_shell 选项来调用 proc_open() 函数时是个例外。


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

本扩展定义了 process 资源， proc_open() 函数会返回此资源。


  • ? 资源类型
  • 程序执行函数 ?
  • PHP Manual
  • 程序执行
  • 预定义常量

预定义常量

此扩展没有定义常量。


程序执行函数

注释

Warning

以加锁方式打开的文件（特别是在打开会话时）， 必须在执行后台程序之前关闭。

参见

这些函数和 执行运算符 是紧密关联的。

Table of Contents

  • escapeshellarg — 把字符串转码为可以在 shell 命令里使用的参数
  • escapeshellcmd — shell 元字符转义
  • exec — 执行一个外部程序
  • passthru — 执行外部程序并且显示原始输出
  • proc_close — 关闭由 proc_open 打开的进程并且返回进程退出码
  • proc_get_status — 获取由 proc_open 函数打开的进程的信息
  • proc_nice — 修改当前进程的优先级
  • proc_open — 执行一个命令，并且打开用来输入/输出的文件指针。
  • proc_terminate — 杀除由 proc_open 打开的进程
  • shell_exec — 通过 shell 环境执行命令，并且将完整的输出以字符串的方式返回。
  • system — 执行外部程序，并且显示输出


把字符串转码为可以在 shell 命令里使用的参数

  • ? 程序执行函数
  • escapeshellcmd ?
  • PHP Manual
  • 程序执行函数
  • 把字符串转码为可以在 shell 命令里使用的参数

escapeshellarg

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

escapeshellarg — 把字符串转码为可以在 shell 命令里使用的参数

说明

escapeshellarg ( string $arg ) : string

escapeshellarg() 将给字符串增加一个单引号并且能引用或者转码任何已经存在的单引号，这样以确保能够直接将一个字符串传入 shell 函数，并且还是确保安全的。对于用户输入的部分参数就应该使用这个函数。shell 函数包含 exec(), system() 执行运算符 。

参数

arg

需要被转码的参数。

返回值

转换之后字符串。

范例

Example #1 escapeshellarg() 的例子

<?php
system('ls '.escapeshellarg($dir));
?>

参见

  • escapeshellcmd() - shell 元字符转义
  • exec() - 执行一个外部程序
  • popen() - 打开进程文件指针
  • system() - 执行外部程序，并且显示输出
  • 执行运算符


shell 元字符转义

  • ? escapeshellarg
  • exec ?
  • PHP Manual
  • 程序执行函数
  • shell 元字符转义

escapeshellcmd

(PHP 4, PHP 5, PHP 7, PHP 8)

escapeshellcmd — shell 元字符转义

说明

escapeshellcmd ( string $command ) : string

escapeshellcmd() 对字符串中可能会欺骗 shell 命令执行任意命令的字符进行转义。 此函数保证用户输入的数据在传送到 exec() 或 system() 函数，或者 执行操作符 之前进行转义。

反斜线（\）会在以下字符之前插入： &#;`|*?~<>^()[]{}$\, \x0A 和 \xFF。 ' 和 " 仅在不配对儿的时候被转义。 在 Windows 平台上，所有这些字符以及 % 和 ! 字符都会被空格代替。

参数

command

要转义的命令。

返回值

转义后的字符串。

范例

Example #1 escapeshellcmd() example

<?php
// 我们故意允许任意数量的参数
$command = './configure '.$_POST['configure_options'];

$escaped_command = escapeshellcmd($command);

system($escaped_command);
?>

Warning

escapeshellcmd() 应被用在完整的命令字符串上。 即使如此，攻击者还是可以传入任意数量的参数。 请使用 escapeshellarg() 函数 对单个参数进行转义。

更新日志

版本 | 说明
5.4.43, 5.5.27, 5.6.11 | 感叹号会被空格所替换。

参见

  • escapeshellarg() - 把字符串转码为可以在 shell 命令里使用的参数
  • exec() - 执行一个外部程序
  • popen() - 打开进程文件指针
  • system() - 执行外部程序，并且显示输出
  • 执行运算符


执行一个外部程序

  • ? escapeshellcmd
  • passthru ?
  • PHP Manual
  • 程序执行函数
  • 执行一个外部程序

exec

(PHP 4, PHP 5, PHP 7, PHP 8)

exec — 执行一个外部程序

说明

exec ( string $command , array &$output = ? , int &$return_var = ? ) : string

exec() 执行 command 参数所指定的命令。

参数

command

要执行的命令。

output

如果提供了 output 参数， 那么会用命令执行的输出填充此数组， 每行输出填充数组中的一个元素。 数组中的数据不包含行尾的空白字符，例如 \n 字符。 请注意，如果数组中已经包含了部分元素，exec() 函数会在数组末尾追加内容。如果你不想在数组末尾进行追加， 请在传入 exec() 函数之前 对数组使用 unset() 函数进行重置。

return_var

如果同时提供 output 和 return_var 参数， 命令执行后的返回状态会被写入到此变量。

返回值

命令执行结果的最后一行内容。 如果你需要获取未经处理的全部输出数据， 请使用 passthru() 函数。

如果想要获取命令的输出内容， 请确保使用 output 参数。

范例

Example #1 exec() 例程

<?php
// 输出运行中的 php/httpd 进程的创建者用户名
// （在可以执行 "whoami" 命令的系统上）
echo exec('whoami');
?>

注释

Warning

当用户提供的数据传入此函数，使用 escapeshellarg() 或 escapeshellcmd() 来确保用户欺骗系统从而执行任意命令。

Note:

如何程序使用此函数启动，为了能保持在后台运行，此程序必须将输出重定向到文件或其它输出流。否则会导致 PHP 挂起，直至程序执行结束。

Note:

在 Windows 下，exec() 函数会先启动 cmd.exe 来执行指定的命令。如果你希望启动一个额外的应用而不用先启动 cmd.exe 可使用 proc_open() 函数加上 bypass_shell 参数。

参见

  • system() - 执行外部程序，并且显示输出
  • passthru() - 执行外部程序并且显示原始输出
  • escapeshellcmd() - shell 元字符转义
  • pcntl_exec() - 在当前进程空间执行指定程序
  • 执行运算符


执行外部程序并且显示原始输出

  • ? exec
  • proc_close ?
  • PHP Manual
  • 程序执行函数
  • 执行外部程序并且显示原始输出

passthru

(PHP 4, PHP 5, PHP 7, PHP 8)

passthru — 执行外部程序并且显示原始输出

说明

passthru ( string $command , int &$return_var = ? ) : void

同 exec() 函数类似， passthru() 函数 也是用来执行外部命令（command）的。 当所执行的 Unix 命令输出二进制数据， 并且需要直接传送到浏览器的时候， 需要用此函数来替代 exec() 或 system() 函数。 常用来执行诸如 pbmplus 之类的可以直接输出图像流的命令。 通过设置 Content-type 为 image/gif， 然后调用 pbmplus 程序输出 gif 文件， 就可以从 PHP 脚本中直接输出图像到浏览器。

参数

command

要执行的命令。

return_var

如果提供 return_var 参数， Unix 命令的返回状态会被记录到此参数。

返回值

没有返回值。

注释

Warning

当用户提供的数据传入此函数，使用 escapeshellarg() 或 escapeshellcmd() 来确保用户欺骗系统从而执行任意命令。

Note:

如何程序使用此函数启动，为了能保持在后台运行，此程序必须将输出重定向到文件或其它输出流。否则会导致 PHP 挂起，直至程序执行结束。

参见

  • exec() - 执行一个外部程序
  • system() - 执行外部程序，并且显示输出
  • popen() - 打开进程文件指针
  • escapeshellcmd() - shell 元字符转义
  • 执行运算符


关闭由 proc_open 打开的进程并且返回进程退出码

  • ? passthru
  • proc_get_status ?
  • PHP Manual
  • 程序执行函数
  • 关闭由 proc_open 打开的进程并且返回进程退出码

proc_close

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

proc_close — 关闭由 proc_open() 打开的进程并且返回进程退出码

说明

proc_close ( resource $process ) : int

proc_close() 同 pclose() 函数类似，
只是 proc_close()
只能用来关闭由 proc_open() 函数打开的进程。
proc_close() 函数会等待进程终止，
并且返回进程的返回值。
如果有连接到进程的已经打开的管道，
那么需要在调用此函数之前调用 fclose() 函数来关闭管道，
否则会引发死锁 - 在管道处于打开状态时，子进程将不能退出。

参数

process

要关闭的由 proc_open() 打开的 resource 。

返回值

返回进程的终止状态码。 如果发生错误，将返回 -1。

Note:

如果 PHP 是通过 --enable-sigchild 编译的，此函数将没有返回值。


获取由 proc_open 函数打开的进程的信息

  • ? proc_close
  • proc_nice ?
  • PHP Manual
  • 程序执行函数
  • 获取由 proc_open 函数打开的进程的信息

proc_get_status

(PHP 5, PHP 7, PHP 8)

proc_get_status — 获取由 proc_open() 函数打开的进程的信息

说明

proc_get_status ( resource $process ) : array

proc_get_status() 函数可以获取由 proc_open() 函数打开的进程的信息。

参数

process

要检查的由 proc_open() 打开的进程 resource。

返回值

如果调用成功，则返回一个包含了进程信息的 array，如果发生错误，返回 false。 返回的数组包含下列元素：

元素 | 类型 | 描述
command | string | 传入 proc_open() 函数的命令行字符串。
pid | int | 进程 ID
running | bool | true 表示进程还在运行中， false 表示进程已经终止
signaled | bool | true 表示子进程被未捕获的信号所终止。 在 Windows 平台永远为 false。
stopped | bool | true 表示子进程被信号停止。 在 Windows 平台永远为 false。
exitcode | int | 进程的退出码（仅在 running 为 false 时有意义）。 仅在第一次调用此函数时会返回实际的值， 后续的调用将返回 -1。
termsig | int | 导致子进程终止执行的信号值 （仅在 signaled 为 true 时有意义）。
stopsig | int | 导致子进程停止执行的信号值 （仅在 stopped 为 true 时有意义）。

参见

  • proc_open() - 执行一个命令，并且打开用来输入/输出的文件指针。


修改当前进程的优先级

  • ? proc_get_status
  • proc_open ?
  • PHP Manual
  • 程序执行函数
  • 修改当前进程的优先级

proc_nice

(PHP 5, PHP 7, PHP 8)

proc_nice — 修改当前进程的优先级

说明

proc_nice ( int $increment ) : bool

proc_nice() 修改当前进程的优先级， 修改量由 increment 参数指定。 increment 为正数会降低当前进程优先级， 反之，为负数会提高优先级。

proc_nice() 和 proc_open() 函数以及和 proc_open() 相关的函数并无什么关系。

参数

increment

新的优先级值，具体的设定取决于所运行的平台。

在 Unix 系统上，较小的值表示较高的优先级，例如：-20， 而正数值表示更低的优先级。

在 Windows 平台上，increment 参数 的含义如下：

优先级 | 可能的值
高优先级 | increment < -9
较高优先级 | increment < -4
正常优先级 | increment < 5 & increment > -5
较低优先级 | increment > 5
低优先级 | increment > 9

返回值

成功时返回 true， 或者在失败时返回 false。。 如果发生错误，例如用户无权修改当前进程的优先级， 会生成 E_WARNING 级别的错误。

范例

Example #1 使用 proc_open() 函数将进程设置为高优先级

<?php
// Highest priority
proc_nice(-20);
?>

更新日志

版本 | 说明
7.2.0 | 在 Windows 平台上可用。

注释

Note: 可用性

仅在具有 'nice' 能力的系统上才可以使用 proc_nice() 函数。 下列系统含有 'nice'：SVr4, SVID EXT, AT&T, X/OPEN, BSD 4.3。

Note: Windows 平台

proc_nice() 函数会改变 当前 进程优先级，即使 PHP 是使用线程安全模式编译的。


执行一个命令，并且打开用来输入/输出的文件指针。

  • ? proc_nice
  • proc_terminate ?
  • PHP Manual
  • 程序执行函数
  • 执行一个命令，并且打开用来输入/输出的文件指针。

proc_open

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

proc_open — 执行一个命令，并且打开用来输入/输出的文件指针。

说明

proc_open ( string $cmd , array $descriptorspec , array &$pipes , string $cwd = null , array $env = null , array $other_options = null ) : resource

类似 popen() 函数， 但是 proc_open() 提供了更加强大的控制程序执行的能力。

参数

cmd

要执行的命令

descriptorspec

一个索引数组。 数组的键表示描述符，数组元素值表示 PHP 如何将这些描述符传送至子进程。 0 表示标准输入（stdin），1 表示标准输出（stdout），2 表示标准错误（stderr）。

数组中的元素可以是：

  • 包含了要传送至进程的管道的描述信息。 第一个元素为描述符类型， 第二个元素是针对该描述符的选项。 有效的类型有：pipe （第二个元素可以是： r 向进程传送该管道的读取端，w 向进程传送该管道的写入端）， 以及 file（第二个元素为文件名）。
  • 表达一个真实文件描述符的流资源类型 （例如：已打开的文件，一个 socket 端口，STDIN）。

文件描述符的值不限于 0，1 和 2，你可以使用任何有效的文件描述符 并将其传送至子进程。 这使得你的脚本可以和其他脚本交互操作。 例如，可以通过指定文件描述符将密码以更加安全的方式 传送至诸如 PGP，GPG 和 openssl 程序， 同时也可以很方便的获取这些程序的状态信息。

pipes

将被置为索引数组， 其中的元素是被执行程序创建的管道对应到 PHP 这一端的文件指针。

cwd

要执行命令的初始工作目录。 必须是 绝对 路径， 设置此参数为 null 表示使用默认值（当前 PHP 进程的工作目录）。

env

要执行的命令所使用的环境变量。 设置此参数为 null 表示使用和当前 PHP 进程相同的环境变量。

other_options

你还可以指定一些附加选项。 目前支持的选项包括：

  • suppress_errors （仅用于 Windows 平台）： 设置为 true 表示抑制本函数产生的错误。
  • bypass_shell （仅用于 Windows 平台）： 设置为 true 表示绕过 cmd.exe shell。

返回值

返回表示进程的资源类型， 当使用完毕之后，请调用 proc_close() 函数来关闭此资源。 如果失败，返回 false。

更新日志

版本 | 说明
5.2.1 | 为 other_options 参数增加 bypass_shell 选项。

范例

Example #1 proc_open() 例程

<?php
$descriptorspec = array(
   0 => array("pipe", "r"),  // 标准输入，子进程从此管道中读取数据
   1 => array("pipe", "w"),  // 标准输出，子进程向此管道中写入数据
   2 => array("file", "/tmp/error-output.txt", "a") // 标准错误，写入到一个文件
);

$cwd = '/tmp';
$env = array('some_option' => 'aeiou');

$process = proc_open('php', $descriptorspec, $pipes, $cwd, $env);

if (is_resource($process)) {
    // $pipes 现在看起来是这样的：
    // 0 => 可以向子进程标准输入写入的句柄
    // 1 => 可以从子进程标准输出读取的句柄
    // 错误输出将被追加到文件 /tmp/error-output.txt

    fwrite($pipes[0], '<?php print_r($_ENV); ?>');
    fclose($pipes[0]);

    echo stream_get_contents($pipes[1]);
    fclose($pipes[1]);

    // 切记：在调用 proc_close 之前关闭所有的管道以避免死锁。
    $return_value = proc_close($process);

    echo "command returned $return_value\n";
}
?>

以上例程的输出类似于：

Array
(
    [some_option] => aeiou
    [PWD] => /tmp
    [SHLVL] => 1
    [_] => /usr/local/bin/php
)
command returned 0

注释

Note:

Windows 兼容性：超过 2 的描述符也可以作为可继承的句柄传送到子进程。 但是，由于 Windows 的架构并不将文件描述符和底层句柄进行关联， 所以，子进程无法访问这样的句柄。 标准输入，标准输出和标注错误会按照预期工作。

Note:

如果你只需要单向的进程管道， 使用 popen() 函数会更加简单。

参见

  • popen() - 打开进程文件指针
  • exec() - 执行一个外部程序
  • system() - 执行外部程序，并且显示输出
  • passthru() - 执行外部程序并且显示原始输出
  • stream_select() - Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
  • The 执行操作符


杀除由 proc_open 打开的进程

  • ? proc_open
  • shell_exec ?
  • PHP Manual
  • 程序执行函数
  • 杀除由 proc_open 打开的进程

proc_terminate

(PHP 5, PHP 7, PHP 8)

proc_terminate — 杀除由 proc_open 打开的进程

说明

proc_terminate ( resource $process , int $signal = 15 ) : bool

向 process （由 proc_open() 函数创建） 发送信号通知其终止。 proc_terminate() 调用之后将会立即返回， 而不会等待进程终止。

可以使用 proc_terminate() 终止进程 并且继续其他的任务。 可以使用 proc_get_status() 函数来检查进程是否已经终止。

参数

process

由 proc_open() 打开的 resource。

signal

可选参数，仅用于 POSIX 操作系统。 表示调用系统命令 kill(2) 来向进程发送的信号。 默认值为 SIGTERM。

返回值

返回进程的终止状态。

更新日志

版本 | 说明
5.2.2 | 之前的版本被用来销毁进程 resource。

参见

  • proc_open() - 执行一个命令，并且打开用来输入/输出的文件指针。
  • proc_close() - 关闭由 proc_open 打开的进程并且返回进程退出码
  • proc_get_status() - 获取由 proc_open 函数打开的进程的信息


通过 shell 环境执行命令，并且将完整的输出以字符串的方式返回。

  • ? proc_terminate
  • system ?
  • PHP Manual
  • 程序执行函数
  • 通过 shell 环境执行命令，并且将完整的输出以字符串的方式返回。

shell_exec

(PHP 4, PHP 5, PHP 7, PHP 8)

shell_exec — 通过 shell 环境执行命令，并且将完整的输出以字符串的方式返回。

说明

shell_exec ( string $cmd ) : string

本函数同 执行操作符。

Note:

On Windows, the underlying pipe is opened in text mode which can cause the function to fail for binary output. Consider to use popen() instead for such cases.

参数

cmd

要执行的命令。

返回值

命令执行的输出。 如果执行过程中发生错误或者进程不产生输出，则返回 null。

Note:

当进程执行过程中发生错误，或者进程不产生输出的情况下，都会返回 null， 所以，使用本函数无法通过返回值检测进程是否成功执行。 如果需要检查进程执行的退出码，请使用 exec() 函数。

范例

Example #1 shell_exec() 例程

<?php
$output = shell_exec('ls -lart');
echo "<pre>$output</pre>";
?>

参见

  • exec() - 执行一个外部程序
  • escapeshellcmd() - shell 元字符转义


执行外部程序，并且显示输出

  • ? shell_exec
  • parallel ?
  • PHP Manual
  • 程序执行函数
  • 执行外部程序，并且显示输出

system

(PHP 4, PHP 5, PHP 7, PHP 8)

system — 执行外部程序，并且显示输出

说明

system ( string $command , int &$return_var = ? ) : string

同 C 版本的 system() 函数一样， 本函数执行 command 参数所指定的命令， 并且输出执行结果。

如果 PHP 运行在服务器模块中， system() 函数还会尝试在每行输出完毕之后， 自动刷新 web 服务器的输出缓存。

如果要获取一个命令未经任何处理的 原始输出， 请使用 passthru() 函数。

参数

command

要执行的命令。

return_var

如果提供 return_var 参数， 则外部命令执行后的返回状态将会被设置到此变量中。

返回值

成功则返回命令输出的最后一行， 失败则返回 false

范例

Example #1 system() 例程

<?php
echo '<pre>';

// 输出 shell 命令 "ls" 的返回结果
// 并且将输出的最后一样内容返回到 $last_line。
// 将命令的返回值保存到 $retval。
$last_line = system('ls', $retval);

// 打印更多信息
echo '
</pre>
<hr />Last line of the output: ' . $last_line . '
<hr />Return value: ' . $retval;
?>

注释

Warning

当用户提供的数据传入此函数，使用 escapeshellarg() 或 escapeshellcmd() 来确保用户欺骗系统从而执行任意命令。

Note:

如何程序使用此函数启动，为了能保持在后台运行，此程序必须将输出重定向到文件或其它输出流。否则会导致 PHP 挂起，直至程序执行结束。

参见

  • exec() - 执行一个外部程序
  • passthru() - 执行外部程序并且显示原始输出
  • popen() - 打开进程文件指针
  • escapeshellcmd() - shell 元字符转义
  • pcntl_exec() - 在当前进程空间执行指定程序
  • 执行操作符


parallel

  • 简介
  • Installation
  • Philosophy
  • Functional API
    • parallel\bootstrap — Bootstrapping
    • parallel\run — Execution
  • parallel\Runtime — The parallel\Runtime class
    • parallel\Runtime::__construct — Runtime Construction
    • parallel\Runtime::run — Execution
    • parallel\Runtime::close — Runtime Graceful Join
    • parallel\Runtime::kill — Runtime Join
  • parallel\Future — The parallel\Future class
    • parallel\Future::cancel — Cancellation
    • parallel\Future::cancelled — State Detection
    • parallel\Future::done — State Detection
    • parallel\Future::value — Resolution
  • parallel\Channel — The parallel\Channel class
    • parallel\Channel::__construct — Channel Construction
    • parallel\Channel::make — Access
    • parallel\Channel::open — Access
    • parallel\Channel::recv — Sharing
    • parallel\Channel::send — Sharing
    • parallel\Channel::close — Closing
  • parallel\Events — The parallel\Events class
    • parallel\Events::setBlocking — Behaviour
    • parallel\Events::setTimeout — Behaviour
    • parallel\Events::setInput — Input
    • parallel\Events::addChannel — Targets
    • parallel\Events::addFuture — Targets
    • parallel\Events::remove — Targets
    • parallel\Events::poll — Polling
  • parallel\Events\Input — The parallel\Events\Input class
    • parallel\Events\Input::add — Inputs
    • parallel\Events\Input::clear — Inputs
    • parallel\Events\Input::remove — Inputs
  • parallel\Events\Event — The parallel\Events\Event class
  • parallel\Events\Event\Type — The parallel\Events\Event\Type class
  • parallel\Sync — The parallel\Sync class
    • parallel\Sync::__construct — Construction
    • parallel\Sync::get — Access
    • parallel\Sync::set — Access
    • parallel\Sync::wait — Synchronization
    • parallel\Sync::notify — Synchronization
    • parallel\Sync::__invoke — Synchronization


简介

parallel is a parallel concurrency extension for PHP 7.2+.

A brief description of the concepts core to parallel follows, more detailed information may be found within this section of the manual.

Runtime

A parallel\Runtime represents a PHP interpreter thread. A parallel\Runtime is configured with an optional bootstrap file passed to parallel\Runtime::__construct(), this is typically an autoloader, or some other preloading routine: The bootstrap file will be included before any task is executed.

After construction the parallel\Runtime remains available until it is closed, killed, or destroyed by the normal scoping rules of PHP objects. parallel\Runtime::run() allows the programmer to schedule tasks for execution in parallel. A parallel\Runtime has a FIFO schedule, tasks will be executed in the order that they are scheduled.

Functional API

parallel implements a functional, higher level API on top of parallel\Runtime that provides a single function entry point to executing parallel code with automatic scheduling: parallel\run().

Task

A task is simply a Closure intended for parallel execution. The Closure may contain almost any instruction, including nested closures. However, there are some instructions that are prohibited in tasks:

  • yield

  • use by-reference

  • declare class

  • declare named function

Note:

Nested closures may yield or use by-reference, but must not contain class or named function declarations.

Note:

No instructions are prohibited in the files which the task may include.

Future

The parallel\Future is used to access the return value from the task, and exposes an API for cancellation of the task.

Channel

A task may be scheduled with arguments, use lexical scope variables (by-value), and return a value (via a parallel\Future), but these only allow uni-directional communication: They allow the programmer to send data into and retrieve data from a task, but do not allow bi-directional communication between tasks. The parallel\Channel API allows bi-directional communication between tasks, a parallel\Channel is a socket-like link between tasks that the programmer can use to send and receive data.

Events

The parallel\Events API implements a native feel (Traversable) event loop, and parallel\Events::poll() method. It allows the programmer to work with sets of channels and or futures. The programmer simply adds channels and futures to the event loop, optionally setting the input for writes with parallel\Events::setInput(), and enters into a foreach: parallel will read from and write to objects as they become available yielding parallel\Events\Event objects describing the operations that have occurred.

参见

  • Philosophy


Installation

需求

parallel requires a build of PHP with ZTS (Zend Thread Safety) enabled ( --enable-maintainer-zts or --enable-zts on Windows )

Caution

Zend Thread Safety cannot be enabled post build; it is a build time configuration option.

parallel should build anywhere there is a working Posix Threads header (pthread.h) and ZTS build of PHP, including Windows (using the pthread-w32 project from redhat).

安装

parallel releases are hosted by PECL and the source code by » github, the easiest route to installation is the normal PECL route: » https://pecl.php.net/package/parallel.

Windows users can download prebuilt release binaries from the » PECL website.

Caution

Windows users need to take the additional step of adding pthreadVC2.dll (distributed with Windows releases) to their PATH.


Philosophy

This section contains philosophies important to writing parallel code and some details about the internal implementation of parallel.

Do not communicate by sharing memory; instead, share memory by communicating.

This philosophy which is embraced by parallel has its origins in Go, one of the most widely admired if not used platforms for writing parallel code at the moment. Go programmers have to work hard to live up to this ideal: PHP and parallel do all the hard work for the programmer, and by default.

In conventional threading models found in other languages, generally threads are communicating with one another through nothing more than by virtue of the fact that they operate in the same address space. The programmer must deploy mutual exclusion, condition variables, and other low level threading or synchronization primitives in order to ensure proper communication of state and consistency.

When the conventional model is inversed, it means that threads only share memory as a result of communication (a variable is passed over a Channel for example).

When parallel passes a variable from one thread to another by any means - Task arguments, return via Future, and Channels - it is passed by value. In all but the case of unbuffered channels, the variable is also buffered so that it may not change (or be destroyed) before it is used in whichever thread the variable is being passed to. An unbuffered read over a channel is the only instance in which a thread directly reads memory allocated by another thread, it can do so safely because the thread that owns the memory is waiting for the read to complete before it can continue to manipulate it, and the thread that does not own the memory reads by value. When both threads continue, they are no longer sharing memory.

This makes writing and reasoning about parallel code much easier than the conventional model of threading. It means the programmer does not need to consider that threads may be manipulating data concurrently, because that is not possible.

This also makes PHP the perfect platform for implementing a parallel concurrency API based on CSP (message passing over channels), because PHP itself is shared nothing - PHP threads operate in their own virtual address space by default, and so may only share memory by communicating.

Data should have a definitive single owner

When approaching the CSP model for the first time, a programmer versed in the traditional model of threading may find themselves looking for concurrent data structures, because that is what they are used too: they pass around shared objects for manipulation.

When it comes to the CSP model, there is no need for data structures to be shared by many tasks, and indeed, it is simpler if they are not. The data should be owned by a single task, changes to (or operations on) that data structure should be communicated over channels and performed by the owner of the data, the success, failure, or result (state) of the change (or operation) being communicated back.

Once again the share nothing nature of PHP and copy by value nature of parallel helps the programmer to achieve this goal, no data will be shared by accident, only ever as a result of communication.


Functional API

The parallel\Runtime API provides a great degree of control to the power PHP programmer, and those intimately familiar with writing applications that use parallel concurrency.

The functional API provides less control in exchange for the ability to make decisions for the programmer:

  • all executing runtimes are bootstrapped identically

  • scheduling is determined by the API, not the programmer

parallel\run() provides the guarantee that the task will begin to execute in parallel as soon as allowed by hardware and operating system constraints, without needlessly creating runtimes. For most applications the functional API should be preferred.

Table of Contents

  • parallel\bootstrap — Bootstrapping
  • parallel\run — Execution


Bootstrapping

  • ? Functional API
  • parallel\run ?
  • PHP Manual
  • Functional API
  • Bootstrapping

parallel\bootstrap

(1.0.0)

parallel\bootstrap — Bootstrapping

说明

parallel\bootstrap ( string $file ) : void

Shall use the provided file to bootstrap all runtimes created for automatic scheduling via parallel\run().

Exceptions

Warning

Shall throw parallel\Runtime\Error\Bootstrap if previously called for this process.

Warning

Shall throw parallel\Runtime\Error\Bootstrap if called after parallel\run().

参见

  • parallel\Runtime::run


Execution

  • ? parallel\bootstrap
  • parallel\Runtime ?
  • PHP Manual
  • Functional API
  • Execution

parallel\run

(1.0.0)

parallel\run — Execution

说明

parallel\run ( Closure $task ) : Future|null

Shall schedule task for execution in parallel.

parallel\run ( Closure $task , array $argv ) : Future|null

Shall schedule task for execution in parallel, passing argv at execution time.

Automatic Scheduling

If a \parallel\Runtime internally created and cached by a previous call to parallel\run() is idle, it will be used to execute the task. If no \parallel\Runtime is idle parallel will create and cache a \parallel\Runtime.

Note:

\parallel\Runtime objects created by the programmer are not used for automatic scheduling.

参数

task

A Closure with specific characteristics.

argv

An array of arguments with specific characteristics to be passed to task at execution time.

Task Characteristics

Closures scheduled for parallel execution must not:

  • accept or return by reference
  • accept or return internal objects (see notes)
  • execute a limited set of instructions

Instructions prohibited in Closures intended for parallel execution are:

  • yield
  • use by-reference
  • declare class
  • declare named function

Note:

Nested closures may yield or use by-reference, but must not contain class or named function declarations.

Note:

No instructions are prohibited in the files which the task may include.

Arguments Characteristics

Arguments must not:

  • contain references
  • contain resources
  • contain internal objects (see notes)

Note:

In the case of file stream resources, the resource will be cast to the file descriptor and passed as int where possible, this is unsupported on Windows.

Internal Objects Notes

Internal objects generally use a custom structure which cannot be copied by value safely, PHP currently lacks the mechanics to do this (without serialization) and so only objects that do not use a custom structure may be shared.

Some internal objects do not use a custom structure, for example parallel\Events\Event and so may be shared.

Closures are a special kind of internal object and support being copied by value, and so may be shared.

Channels are central to writing parallel code and support concurrent access and execution by necessity, and so may be shared.

Warning

A user class that extends an internal class may use a custom structure as defined by the internal class, in which case they cannot be copied by value safely, and so may not be shared.

返回值

Warning

The return parallel\Future must not be ignored when the task contains a return or throw statement.

Exceptions

Warning

Shall throw parallel\Runtime\Error\Closed if parallel\Runtime was closed.

Warning

Shall throw parallel\Runtime\Error\IllegalFunction if task is a closure created from an internal function.

Warning

Shall throw parallel\Runtime\Error\IllegalInstruction if task contains illegal instructions.

Warning

Shall throw parallel\Runtime\Error\IllegalParameter if task accepts or argv contains illegal variables.

Warning

Shall throw parallel\Runtime\Error\IllegalReturn if task returns illegally.

参见

  • parallel\Runtime::run


The parallel\Runtime class

(0.8.0)

Runtime Objects

Each runtime represents a single PHP thread, the thread is created (and bootstrapped) upon construction. The thread then waits for tasks to be scheduled: Scheduled tasks will be executed FIFO and then the thread will resume waiting until more tasks are scheduled, or it's closed, killed, or destroyed by the normal scoping rules of PHP objects.

Warning

When a runtime is destroyed by the normal scoping rules of PHP objects, it will first execute all of the tasks that were scheduled, and block while doing so.

Runtime Bootstrapping

When a new runtime is created, it does not share code with the thread (or process) that created it. This means it doesn't have the same classes and functions loaded, nor the same autoloader set. In some cases, a very lightweight runtime is desirable because the tasks that will be scheduled do not need access to the code in the parent thread. In those cases where the tasks do need to access the same code, it is enough to set an autoloader as the bootstrap.

Note:

preloading may be used in conjunction with parallel, in this case preloaded code is available without bootstrapping

类摘要

final parallel\Runtime {
/* Create */
public __construct ( )
public __construct ( string $bootstrap )
/* Execute */
public run ( Closure $task ) : Future|null
public run ( Closure $task , array $argv ) : Future|null
/* Join */
public close ( ) : void
public kill ( ) : void
}

Table of Contents

  • parallel\Runtime::__construct — Runtime Construction
  • parallel\Runtime::run — Execution
  • parallel\Runtime::close — Runtime Graceful Join
  • parallel\Runtime::kill — Runtime Join


Runtime Construction

  • ? parallel\Runtime
  • parallel\Runtime::run ?
  • PHP Manual
  • parallel\Runtime
  • Runtime Construction

parallel\Runtime::__construct

(0.8.0)

parallel\Runtime::__construct — Runtime Construction

说明

public parallel\Runtime::__construct ( )

Shall construct a new runtime without bootstrapping.

public parallel\Runtime::__construct ( string $bootstrap )

Shall construct a bootstrapped runtime.

参数

bootstrap

The location of a bootstrap file, generally an autoloader.

Exceptions

Warning

Shall throw parallel\Runtime\Error if thread could not be created

Warning

Shall throw parallel\Runtime\Bootstrap if bootstrapping failed


Execution

  • ? parallel\Runtime::__construct
  • parallel\Runtime::close ?
  • PHP Manual
  • parallel\Runtime
  • Execution

parallel\Runtime::run

(0.8.0)

parallel\Runtime::run — Execution

说明

public parallel\Runtime::run ( Closure $task ) : Future|null

Shall schedule task for execution in parallel.

public parallel\Runtime::run ( Closure $task , array $argv ) : Future|null

Shall schedule task for execution in parallel, passing argv at execution time.

参数

task

A Closure with specific characteristics.

argv

An array of arguments with specific characteristics to be passed to task at execution time.

Task Characteristics

Closures scheduled for parallel execution must not:

  • accept or return by reference
  • accept or return internal objects (see notes)
  • execute a limited set of instructions

Instructions prohibited in Closures intended for parallel execution are:

  • yield
  • use by-reference
  • declare class
  • declare named function

Note:

Nested closures may yield or use by-reference, but must not contain class or named function declarations.

Note:

No instructions are prohibited in the files which the task may include.

Arguments Characteristics

Arguments must not:

  • contain references
  • contain resources
  • contain internal objects (see notes)

Note:

In the case of file stream resources, the resource will be cast to the file descriptor and passed as int where possible, this is unsupported on Windows.

Internal Objects Notes

Internal objects generally use a custom structure which cannot be copied by value safely, PHP currently lacks the mechanics to do this (without serialization) and so only objects that do not use a custom structure may be shared.

Some internal objects do not use a custom structure, for example parallel\Events\Event and so may be shared.

Closures are a special kind of internal object and support being copied by value, and so may be shared.

Channels are central to writing parallel code and support concurrent access and execution by necessity, and so may be shared.

Warning

A user class that extends an internal class may use a custom structure as defined by the internal class, in which case they cannot be copied by value safely, and so may not be shared.

返回值

Warning

The return parallel\Future must not be ignored when the task contains a return or throw statement.

Exceptions

Warning

Shall throw parallel\Runtime\Error\Closed if parallel\Runtime was closed.

Warning

Shall throw parallel\Runtime\Error\IllegalFunction if task is a closure created from an internal function.

Warning

Shall throw parallel\Runtime\Error\IllegalInstruction if task contains illegal instructions.

Warning

Shall throw parallel\Runtime\Error\IllegalParameter if task accepts or argv contains illegal variables.

Warning

Shall throw parallel\Runtime\Error\IllegalReturn if task returns illegally.


Runtime Graceful Join

  • ? parallel\Runtime::run
  • parallel\Runtime::kill ?
  • PHP Manual
  • parallel\Runtime
  • Runtime Graceful Join

parallel\Runtime::close

(0.8.0)

parallel\Runtime::close — Runtime Graceful Join

说明

public parallel\Runtime::close ( ) : void

Shall request that the runtime shutsdown.

Note:

Tasks scheduled for execution will be executed before the shutdown occurs.

Exceptions

Warning

Shall throw parallel\Runtime\Error\Closed if Runtime was already closed.


Runtime Join

  • ? parallel\Runtime::close
  • parallel\Future ?
  • PHP Manual
  • parallel\Runtime
  • Runtime Join

parallel\Runtime::kill

(0.8.0)

parallel\Runtime::kill — Runtime Join

说明

public parallel\Runtime::kill ( ) : void

Shall attempt to force the runtime to shutdown.

Note:

Tasks scheduled for execution will not be executed, the currently running task shall be interrupted.

Warning

Internal function calls in progress cannot be interrupted.

Exceptions

Warning

Shall throw parallel\Runtime\Error\Closed if Runtime was closed.


The parallel\Future class

(0.8.0)

Futures

A Future represents the return value or uncaught exception from a task, and exposes an API for cancellation.

Example #1 Example showing Future as return value

<?php
$runtime = new \parallel\Runtime;
$future  = $runtime->run(function(){
    return "World";
});
printf("Hello %s\n", $future->value());
?>

以上例程的输出类似于：

Hello World

The behaviour of a future also allows it to be used as a simple synchronization point even where the task does not return a value explicitly.

Example #2 Example showing Future as synchronization point

<?php
$runtime = new \parallel\Runtime;
$future  = $runtime->run(function(){
    echo "in child ";
    for ($i = 0; $i < 500; $i++) {
        if ($i % 10 == 0) {
            echo ".";
        }
    }
    echo " leaving child";
});

$future->value();
echo "\nparent continues\n";
?>

以上例程的输出类似于：

in child .................................................. leaving child
parent continues

类摘要

final parallel\Future {
/* Resolution */
public value ( ) : mixed
/* State */
public cancelled ( ) : bool
public done ( ) : bool
/* Cancellation */
public cancel ( ) : bool
}

Table of Contents

  • parallel\Future::cancel — Cancellation
  • parallel\Future::cancelled — State Detection
  • parallel\Future::done — State Detection
  • parallel\Future::value — Resolution


Cancellation

  • ? parallel\Future
  • parallel\Future::cancelled ?
  • PHP Manual
  • parallel\Future
  • Cancellation

parallel\Future::cancel

(0.9.0)

parallel\Future::cancel — Cancellation

说明

public parallel\Future::cancel ( ) : bool

Shall try to cancel the task

Note:

If task is running, it will be interrupted.

Warning

Internal function calls in progress cannot be interrupted.

Exceptions

Warning

Shall throw parallel\Future\Error\Killed if parallel\Runtime executing task was killed.

Warning

Shall throw parallel\Future\Error\Cancelled if task was already cancelled.


State Detection

  • ? parallel\Future::cancel
  • parallel\Future::done ?
  • PHP Manual
  • parallel\Future
  • State Detection

parallel\Future::cancelled

(0.9.0)

parallel\Future::cancelled — State Detection

说明

public parallel\Future::cancelled ( ) : bool

Shall indicate if the task was cancelled


State Detection

  • ? parallel\Future::cancelled
  • parallel\Future::value ?
  • PHP Manual
  • parallel\Future
  • State Detection

parallel\Future::done

(0.8.0)

parallel\Future::done — State Detection

说明

public parallel\Future::done ( ) : bool

Shall indicate if the task is completed


Resolution

  • ? parallel\Future::done
  • parallel\Channel ?
  • PHP Manual
  • parallel\Future
  • Resolution

parallel\Future::value

(0.8.0)

parallel\Future::value — Resolution

说明

public parallel\Future::value ( ) : mixed

Shall return (and if necessary wait for) return from task

Exceptions

Warning

Shall throw parallel\Future\Error if waiting failed (internal error).

Warning

Shall throw parallel\Future\Error\Killed if parallel\Runtime executing task was killed.

Warning

Shall throw parallel\Future\Error\Cancelled if task was cancelled.

Warning

Shall throw parallel\Future\Error\Foreign if task raised an unrecognized uncaught exception.

Warning

Shall rethrow Throwable uncaught in task


The parallel\Channel class

(0.9.0)

Unbuffered Channels

An unbuffered channel will block on calls to parallel\Channel::send() until there is a receiver, and block on calls to parallel\Channel::recv() until there is a sender. This means an unbuffered channel is not only a way to share data among tasks but also a simple method of synchronization.

An unbuffered channel is the fastest way to share data among tasks, requiring the least copying.

Buffered Channels

A buffered channel will not block on calls to parallel\Channel::send() until capacity is reached, calls to parallel\Channel::recv() will block until there is data in the buffer.

Closures over Channels

A powerful feature of parallel channels is that they allow the exchange of closures between tasks (and runtimes).

When a closure is sent over a channel the closure is buffered, it doesn't change the buffering of the channel transmitting the closure, but it does effect the static scope inside the closure: The same closure sent to different runtimes, or the same runtime, will not share their static scope.

This means that whenever a closure is executed that was transmitted by a channel, static state will be as it was when the closure was buffered.

Anonymous Channels

The anonymous channel constructor allows the programmer to avoid assigning names to every channel: parallel will generate a unique name for anonymous channels.

类摘要

final parallel\Channel {
/* Anonymous Constructor */
public __construct ( )
public __construct ( int $capacity )
/* Access */
public make ( string $name ) : Channel
public make ( string $name , int $capacity ) : Channel
public open ( string $name ) : Channel
/* Sharing */
public recv ( ) : mixed
public send ( mixed $value ) : void
/* Closing */
public close ( ) : void
/* Constant for Infinitely Buffered */
const Infinite ;
}

Table of Contents

  • parallel\Channel::__construct — Channel Construction
  • parallel\Channel::make — Access
  • parallel\Channel::open — Access
  • parallel\Channel::recv — Sharing
  • parallel\Channel::send — Sharing
  • parallel\Channel::close — Closing


Channel Construction

  • ? parallel\Channel
  • parallel\Channel::make ?
  • PHP Manual
  • parallel\Channel
  • Channel Construction

parallel\Channel::__construct

(1.1.0)

parallel\Channel::__construct — Channel Construction

说明

public parallel\Channel::__construct ( )

Shall make an anonymous unbuffered channel

public parallel\Channel::__construct ( int $capacity )

Shall make an anonymous buffered channel with the given capacity

参数

capacity

May be Channel::Infinite or a positive integer


Access

  • ? parallel\Channel::__construct
  • parallel\Channel::open ?
  • PHP Manual
  • parallel\Channel
  • Access

parallel\Channel::make

(0.9.0)

parallel\Channel::make — Access

说明

public parallel\Channel::make ( string $name ) : Channel

Shall make an unbuffered channel with the given name

public parallel\Channel::make ( string $name , int $capacity ) : Channel

Shall make a buffered channel with the given name and capacity

参数

name

The name of the channel.

capacity

May be Channel::Infinite or a positive integer

Exceptions

Warning

Shall throw parallel\Channel\Error\Existence if channel already exists.


Access

  • ? parallel\Channel::make
  • parallel\Channel::recv ?
  • PHP Manual
  • parallel\Channel
  • Access

parallel\Channel::open

(0.9.0)

parallel\Channel::open — Access

说明

public parallel\Channel::open ( string $name ) : Channel

Shall open the channel with the given name

Exceptions

Warning

Shall throw parallel\Channel\Error\Existence if channel does not exist.


Sharing

  • ? parallel\Channel::open
  • parallel\Channel::send ?
  • PHP Manual
  • parallel\Channel
  • Sharing

parallel\Channel::recv

(0.9.0)

parallel\Channel::recv — Sharing

说明

public parallel\Channel::recv ( ) : mixed

Shall recv a value from this channel

Exceptions

Warning

Shall throw parallel\Channel\Error\Closed if channel is closed.


Sharing

  • ? parallel\Channel::recv
  • parallel\Channel::close ?
  • PHP Manual
  • parallel\Channel
  • Sharing

parallel\Channel::send

(0.9.0)

parallel\Channel::send — Sharing

说明

public parallel\Channel::send ( mixed $value ) : void

Shall send the given value on this channel

Exceptions

Warning

Shall throw parallel\Channel\Error\Closed if channel is closed.

Warning

Shall throw parallel\Channel\Error\IllegalValue if value is illegal.


Closing

  • ? parallel\Channel::send
  • parallel\Events ?
  • PHP Manual
  • parallel\Channel
  • Closing

parallel\Channel::close

(0.9.0)

parallel\Channel::close — Closing

说明

public parallel\Channel::close ( ) : void

Shall close this channel

Exceptions

Warning

Shall throw parallel\Channel\Error\Closed if channel is closed.


The parallel\Events class

(0.9.0)

The Event Loop

The Event loop monitors the state of sets of futures and or channels (targets) in order to perform read (parallel\Future::value(), parallel\Channel::recv()) and write (parallel\Channel::send()) operations as the targets become available and the operations may be performed without blocking the event loop.

类摘要

final parallel\Events implements Countable , Traversable {
/* Input */
public setInput ( Input $input ) : void
/* Targets */
public addChannel ( parallel\Channel $channel ) : void
public addFuture ( string $name , parallel\Future $future ) : void
public remove ( string $target ) : void
/* Behaviour */
public setBlocking ( bool $blocking ) : void
public setTimeout ( int $timeout ) : void
/* Polling */
public poll ( ) : Event|null
}

Table of Contents

  • parallel\Events::setBlocking — Behaviour
  • parallel\Events::setTimeout — Behaviour
  • parallel\Events::setInput — Input
  • parallel\Events::addChannel — Targets
  • parallel\Events::addFuture — Targets
  • parallel\Events::remove — Targets
  • parallel\Events::poll — Polling


Behaviour

  • ? parallel\Events
  • parallel\Events::setTimeout ?
  • PHP Manual
  • parallel\Events
  • Behaviour

parallel\Events::setBlocking

(0.9.0)

parallel\Events::setBlocking — Behaviour

说明

By default when events are polled for, blocking will occur (at the PHP level) until the first event can be returned: Setting blocking mode to false will cause poll to return control if the first target polled is not ready.

This differs from setting a timeout of 0 with parallel\Events::setTimeout(), since a timeout of 0, while allowed, will cause an exception to be raised, which may be extremely slow or wasteful if what is really desired is non-blocking behaviour.

A non-blocking loop effects the return value of parallel\Events::poll(), such that it may be null before all events have been processed.

public parallel\Events::setBlocking ( bool $blocking ) : void

Shall set blocking mode

Exceptions

Warning

Shall throw parallel\Events\Error if loop has timeout set.


Behaviour

  • ? parallel\Events::setBlocking
  • parallel\Events::setInput ?
  • PHP Manual
  • parallel\Events
  • Behaviour

parallel\Events::setTimeout

(0.9.0)

parallel\Events::setTimeout — Behaviour

说明

By default when events are polled for, blocking will occur (at the PHP level) until the first event can be returned: Setting the timeout causes an exception to be thrown when the timeout is reached.

This differs from setting blocking mode to false with parallel\Events::setBlocking(), which will not cause an exception to be thrown.

public parallel\Events::setTimeout ( int $timeout ) : void

Shall set the timeout in microseconds

Exceptions

Warning

Shall throw parallel\Events\Error if loop is non-blocking.


Input

  • ? parallel\Events::setTimeout
  • parallel\Events::addChannel ?
  • PHP Manual
  • parallel\Events
  • Input

parallel\Events::setInput

(0.9.0)

parallel\Events::setInput — Input

说明

public parallel\Events::setInput ( Input $input ) : void

Shall set input for this event loop


Targets

  • ? parallel\Events::setInput
  • parallel\Events::addFuture ?
  • PHP Manual
  • parallel\Events
  • Targets

parallel\Events::addChannel

(0.9.0)

parallel\Events::addChannel — Targets

说明

public parallel\Events::addChannel ( parallel\Channel $channel ) : void

Shall watch for events on the given channel

Exceptions

Warning

Shall throw parallel\Events\Error\Existence if channel was already added.


Targets

  • ? parallel\Events::addChannel
  • parallel\Events::remove ?
  • PHP Manual
  • parallel\Events
  • Targets

parallel\Events::addFuture

(0.9.0)

parallel\Events::addFuture — Targets

说明

public parallel\Events::addFuture ( string $name , parallel\Future $future ) : void

Shall watch for events on the given future

Exceptions

Warning

Shall throw parallel\Events\Error\Existence if target with the given name was already added.


Targets

  • ? parallel\Events::addFuture
  • parallel\Events::poll ?
  • PHP Manual
  • parallel\Events
  • Targets

parallel\Events::remove

(0.9.0)

parallel\Events::remove — Targets

说明

public parallel\Events::remove ( string $target ) : void

Shall remove the given target

Exceptions

Warning

Shall throw parallel\Events\Error\Existence if target with the given name was not found.


Polling

  • ? parallel\Events::remove
  • parallel\Events\Input ?
  • PHP Manual
  • parallel\Events
  • Polling

parallel\Events::poll

(0.9.0)

parallel\Events::poll — Polling

说明

public parallel\Events::poll ( ) : Event|null

Shall poll for the next event

返回值

Should there be no targets remaining, null shall be returned

Should this be a non-blocking loop, and blocking would occur, null shall be returned

Otherwise, the parallel\Events\Event returned describes the event.

Exceptions

Warning

Shall throw parallel\Events\Error\Timeout if timeout is used and reached.


The parallel\Events\Input class

(0.9.0)

Events Input

An Input object is a container for data that the parallel\Events object will write to parallel\Channel objects as they become available. Multiple event loops may share an Input container - parallel does not verify the contents of the container when it is set as the input for a parallel\Events object.

Note:

When a parallel\Events object performs a write, the target is removed from the input object as if parallel\Events\Input::remove() were called.

类摘要

final parallel\Events\Input {
public add ( string $target , mixed $value ) : void
public remove ( string $target ) : void
public clear ( ) : void
}

Table of Contents

  • parallel\Events\Input::add — Inputs
  • parallel\Events\Input::clear — Inputs
  • parallel\Events\Input::remove — Inputs


Inputs

  • ? parallel\Events\Input
  • parallel\Events\Input::clear ?
  • PHP Manual
  • parallel\Events\Input
  • Inputs

parallel\Events\Input::add

(0.9.0)

parallel\Events\Input::add — Inputs

说明

public parallel\Events\Input::add ( string $target , mixed $value ) : void

Shall set input for the given target

Exceptions

Warning

Shall throw parallel\Events\Input\Error\Existence if input for target already exists.

Warning

Shall throw parallel\Events\Input\Error\IllegalValue if value is illegal (object, null).


Inputs

  • ? parallel\Events\Input::add
  • parallel\Events\Input::remove ?
  • PHP Manual
  • parallel\Events\Input
  • Inputs

parallel\Events\Input::clear

(0.9.0)

parallel\Events\Input::clear — Inputs

说明

public parallel\Events\Input::clear ( ) : void

Shall remove input for all targets


Inputs

  • ? parallel\Events\Input::clear
  • parallel\Events\Event ?
  • PHP Manual
  • parallel\Events\Input
  • Inputs

parallel\Events\Input::remove

(0.9.0)

parallel\Events\Input::remove — Inputs

说明

public parallel\Events\Input::remove ( string $target ) : void

Shall remove input for the given target

Exceptions

Warning

Shall throw parallel\Events\Input\Error\Existence if input for target does not exist.


The parallel\Events\Event class

(0.9.0)

Event Objects

When an Event is returned, Event::$object shall be removed from the loop that returned it, should the event be a write event the Input for Event::$source shall also be removed.

类摘要

final parallel\Events\Event {
/* Shall be one of Event\Type constants */
public int $type ;
/* Shall be the source of the event (target name) */
public string $source ;
/* Shall be either Future or Channel */
public object $object ;
/* Shall be set for Read/Error events */
public $value ;
}


The parallel\Events\Event\Type class

(0.9.0)

类摘要

final parallel\Events\Event\Type {
/* Event::$object was read into Event::$value */
const Read ;
/* Input for Event::$source written to Event::$object */
const Write ;
/* Event::$object (Channel) was closed */
const Close ;
/* Event::$object (Future) was cancelled */
const Cancel ;
/* Runtime executing Event::$object (Future) was killed */
const Kill ;
/* Event::$object (Future) raised error */
const Error ;
}


The parallel\Sync class

(1.1.0)

Low Level Synchronization

The parallel\Sync class provides access to low level synchronization primitives, mutex, condition variables, and allows the implementation of semaphores.

Synchronization for most applications is much better implemented using channels, however, in some cases authors of low level code may find it useful to be able to access these lower level mechanisms.

类摘要

final parallel\Sync {
/* Constructor */
public __construct ( )
public __construct ( scalar $value )
/* Access */
public get ( ) : scalar
public set ( scalar $value )
/* Synchronization */
public wait ( )
public notify ( bool $all = ? )
public __invoke ( callable $critical )
}

Table of Contents

  • parallel\Sync::__construct — Construction
  • parallel\Sync::get — Access
  • parallel\Sync::set — Access
  • parallel\Sync::wait — Synchronization
  • parallel\Sync::notify — Synchronization
  • parallel\Sync::__invoke — Synchronization


Construction

  • ? parallel\Sync
  • parallel\Sync::get ?
  • PHP Manual
  • parallel\Sync
  • Construction

parallel\Sync::__construct

(1.1.0)

parallel\Sync::__construct — Construction

说明

public parallel\Sync::__construct ( )

Shall construct a new synchronization object with no value

public parallel\Sync::__construct ( scalar $value )

Shall construct a new synchronization object containing the given scalar value

Exceptions

Warning

Shall throw parallel\Sync\Error\IllegalValue if value is non-scalar.


Access

  • ? parallel\Sync::__construct
  • parallel\Sync::set ?
  • PHP Manual
  • parallel\Sync
  • Access

parallel\Sync::get

(1.1.0)

parallel\Sync::get — Access

说明

public parallel\Sync::get ( ) : scalar

Shall atomically return the syncrhonization objects value


Access

  • ? parallel\Sync::get
  • parallel\Sync::wait ?
  • PHP Manual
  • parallel\Sync
  • Access

parallel\Sync::set

(1.1.0)

parallel\Sync::set — Access

说明

public parallel\Sync::set ( scalar $value )

Shall atomically set the value of the synchronization object

Exceptions

Warning

Shall throw parallel\Sync\Error\IllegalValue if value is non-scalar.


Synchronization

  • ? parallel\Sync::set
  • parallel\Sync::notify ?
  • PHP Manual
  • parallel\Sync
  • Synchronization

parallel\Sync::wait

(1.1.0)

parallel\Sync::wait — Synchronization

说明

public parallel\Sync::wait ( )

Shall wait for notification on this synchronization object


Synchronization

  • ? parallel\Sync::wait
  • parallel\Sync::__invoke ?
  • PHP Manual
  • parallel\Sync
  • Synchronization

parallel\Sync::notify

(1.1.0)

parallel\Sync::notify — Synchronization

说明

public parallel\Sync::notify ( bool $all = ? )

Shall notify one (by default) or all threads waiting on the synchronization object


Synchronization

  • ? parallel\Sync::notify
  • pthreads ?
  • PHP Manual
  • parallel\Sync
  • Synchronization

parallel\Sync::__invoke

(1.1.0)

parallel\Sync::__invoke — Synchronization

说明

public parallel\Sync::__invoke ( callable $critical )

Shall exclusively enter into the critical code


pthreads

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • Threaded — Threaded 类
    • Threaded::chunk — 操作
    • Threaded::count — 操作
    • Threaded::extend — Runtime Manipulation
    • Threaded::from — Creation
    • Threaded::getTerminationInfo — 错误检测
    • Threaded::isRunning — 状态检测
    • Threaded::isTerminated — 状态检测
    • Threaded::isWaiting — 状态检测
    • Threaded::lock — 同步控制
    • Threaded::merge — 操作
    • Threaded::notify — 同步控制
    • Threaded::notifyOne — Synchronization
    • Threaded::pop — 操作
    • Threaded::run — 执行
    • Threaded::shift — Manipulation
    • Threaded::synchronized — 同步控制
    • Threaded::unlock — 同步控制
    • Threaded::wait — Synchronization
  • Thread — Thread 类
    • Thread::detach — 执行
    • Thread::getCreatorId — 识别
    • Thread::getCurrentThread — 识别
    • Thread::getCurrentThreadId — 识别
    • Thread::getThreadId — 识别
    • Thread::globally — 执行
    • Thread::isJoined — 状态监测
    • Thread::isStarted — 状态检测
    • Thread::join — 同步
    • Thread::kill — 执行
    • Thread::start — 执行
  • Worker — Worker 类
    • Worker::collect — Collect references to completed tasks
    • Worker::getStacked — 获取剩余的栈大小
    • Worker::isShutdown — 状态检测
    • Worker::isWorking — 状态检测
    • Worker::shutdown — 关闭 Worker
    • Worker::stack — 将要执行的任务入栈
    • Worker::unstack — 将要执行的任务出栈
  • Collectable — The Collectable interface
    • Collectable::isGarbage — Determine whether an object has been marked as garbage
    • Collectable::setGarbage — Mark an object as garbage
  • Modifiers — 方法修饰符
  • Pool — Pool 类
    • Pool::collect — 回收已完成任务的引用
    • Pool::__construct — 创建新的 Worker 对象池
    • Pool::resize — 改变 Pool 对象的可容纳 Worker 对象的数量
    • Pool::shutdown — 停止所有的 Worker 对象
    • Pool::submit — 提交对象以执行
    • Pool::submitTo — 提交一个任务到特定的 Worker 以执行
  • Mutex — Mutex 类
    • Mutex::create — 创建一个互斥量
    • Mutex::destroy — 销毁互斥量
    • Mutex::lock — 给互斥量加锁
    • Mutex::trylock — 尝试给互斥量加锁
    • Mutex::unlock — 释放互斥量上的锁
  • Cond — Cond 类
    • Cond::broadcast — 广播条件变量
    • Cond::create — 创建一个条件变量
    • Cond::destroy — 销毁条件变量
    • Cond::signal — 发送唤醒信号
    • Cond::wait — 等待
  • Volatile — The Volatile class


简介

pthreads 是一组允许用户在 PHP 中使用多线程技术的面向对象的 API。 它提供了创建多线程应用所需的全套工具。 通过使用 Thread， Worker 以及 Threaded 对象，PHP 应用可以创建、读取、写入以及执行多线程应用，并可以在多个线程之间进行同步控制。

Warning

此扩展已被声明为停止维护状态。

Tip

建议使用 parallel 作为替代。

Warning

不可以在 web 服务器环境中使用 pthreads 扩展， PHP 多线程开发仅限于命令行模式的应用。

Warning

只能在 PHP 7.2+ 版本中使用 pthreads (v3) 扩展， 在 PHP 7.0 和 7.1 版本中，ZTS 模式是不安全的。

Threaded 对象： Threaded 对象提供支持 pthreads 操作的基本功能，包括同步方法以及其他对程序员很有帮助的接口。

Thread 对象： 通过继承 pthreads 中提供的 Thread 对象并实现 run 方法，用户可以创建自己的 Thread 对象。 只要线程上下文中持有某个 Thread 对象的引用，就可以读/写该对象的属性，也可以调用该对象的公有（public）或者受保护（protected）的方法。 当在创建 Thread 对象的上下文中调用该对象的 Thread::start() 方法时，pthreads 扩展会在另外的独立线程中执行该对象的 run 方法。 仅有创建 Thread 对象的线程/进程方可开始（start）或者加入（join）这个 Thread 对象。

Worker 对象： Worker 是有状态的线程对象，它在线程开始（通过调用 Thread::start() 方法）之后就可用， 除非代码中显式地关闭线程（通过调用 Worker::shutdown() 方法）， 否则该对象在线程对象超出作用范围之后才会失效。 持有 Worker 对象引用的线程上下文可以向 Worker 中入栈（通过调用 Worker::stack() 方法）其他线程对象，Worker 对象将在独立线程中执行入栈对象的代码。 Woker 对象的 run 方法会在它的栈中入栈对象之前执行，这样就可以进行一些必需的资源初始化工作。

Pool 对象： Pool 对象是 Worker 线程对象池，可以用来在多个 Worker 对象之间分发 Threaded 对象， 这是最易用且高效的多线程编程方式。

Caution

Pool 是标准的 PHP 对象，它并没有继承 Threaded 类，所以不可以在多个线程上下文中共享同一个 Pool 对象。

Volatile 类是在 pthreads v3 中新增加的， 用来表示可变的 Threaded 类中的 Threaded 属性（默认情况下是不可变的）。 它也可以被用来在 Threaded 上下文中存储数组。

线程间同步： 由 pthreads 扩展创建的所有对象拥有内置的线程间同步机制， 和 Java 语言很类似， 使用 Threaded::wait() 和 Threaded::notify() 方法来实现线程间同步。 调用某一个对象的 Threaded::wait() 方法 会导致当前线程上下文进入等待状态， 等待另外一个线程上下文调用同一个对象的 Threaded::notify() 方法。 为 PHP Threaded 对象提供了强有力的线程间同步控制机制。

Caution

应用中会用在多线程场景中的对象都应该从 Threaded 类继承。

数据存储： 一般来说，任何可以序列化的数据类型都可以作为 Threaded 对象的属性，它可以从持有该对象引用的任何线程上下文读/写。 并不是所有的数据都采用序列化方式存储，比如基本类型就是以其真实形态存储的。 对于不是 Threaded 派生的对象，例如复杂类型、数组以及对象等，都是序列化存储的，可以从持有 Threaded 对象引用的任何线程上下文中读取和写入， 区别就在于对于 Threaed 的派生对象，设置它的成员变量的过程是在独立线程上下文中执行的。 对于 Threaded 派生对象，在同一时间，不同的线程上下文都可以从该对象中读取到同样的数据。

静态成员： 当创建新的线程上下文（Thread 或 Worker 对象）的时候，静态成员会被拷贝到新的上下文中。出于安全考虑，资源类型以及包含内部状态的对象类型的静态成员会被置空。 实际上这个特性实现了类似线程本地存储的功能。举例说明，假设某个类拥有包含数据库连接信息以及数据库连接对象静态成员， 那么当新的线程上下文启动的时候，仅有数据库连接信息会被复制到新上下文中，而数据库连接对象并不会被复制。 所以，需要在新的上下文中根据复制过来的数据库连接基本信息来初始化数据库连接对象，新创建的数据库连接对象是独立的， 不影响在原上下文中的数据库连接对象。

Caution

当使用 print_r, var_dump 或者其他函数来进行对象调试的时候，是没有递归保护机制的。

Note:

资源类型： PHP 中很多使用到 Resource 资源类型的扩展或函数并未针对多线程场景进行特殊设计，也就是说，虽然 pthreads 扩展提供了 在多个线程上下文中共享资源类型变量的能力，但是通常来说，你应该把它们视为非线程安全的。 所以，如果要在多个线程上下文中共享资源类型的变量，你应该特别谨慎对待。

Caution

为了提供一个稳定的运行环境，pthreads 扩展在执行过程中会有一些必需的额外限制。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • pthreads
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

要使用 pthreads 扩展，需要构建 PHP 时启用 ZTS （Zend Thread Safety）。（--enable-maintainer-zts 选项， Windows 平台为 --enable-zts）

Caution

ZTS 是构建期配置选项，只能通过构建时通过选项启用，无法在构建之后启用。

要构建 pthreads 扩展，你需要启用了 ZTS 的 PHP 以及 Posix Threads 头文件（pthread.h）。对于 Windows 平台，需要使用 redhat 的 pthread-w32 项目中的 pthread.h 头文件。


安装

pthreads 扩展由 PECL 主持，使用 » github 管理源代码。 使用标准的 PECL 包安装方式就可以完成安装：» https://pecl.php.net/package/pthreads。

Windows 用户可以从 » PECL 下载已经构建的二进制发行包。

Caution

Windows 用户需要将 pthreadVC2.dll （包含在 Windows 版二进制发行包中）所在路径加入到 PATH 环境变量中。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

PTHREADS_INHERIT_ALL (integer)
线程的默认选项。线程开始的时候，pthreads 扩展会将环境复制到线程上下文中。
PTHREADS_INHERIT_NONE (integer)
新线程开始时，不继承任何内容。
PTHREADS_INHERIT_INI (integer)
新线程开始时，仅继承 INI 配置。
PTHREADS_INHERIT_CONSTANTS (integer)
新线程开始时，继承用户定义的常量。
PTHREADS_INHERIT_CLASSES (integer)
新线程开始时，继承用户定义的类。
PTHREADS_INHERIT_FUNCTIONS (integer)
新线程开始时，继承用户定义的函数。
PTHREADS_INHERIT_INCLUDES (integer)
新线程开始时，继承包含文件。
PTHREADS_INHERIT_COMMENTS (integer)
新线程开始时，继承所有的注释。
PTHREADS_ALLOW_HEADERS (integer)
允许新线程向标准输出发送头信息（通常情况下是被禁止的）。


Threaded 类

(PECL pthreads >= 2.0.0)

简介

Threaded 对象提供支持 pthreads 操作的基本功能，包括同步方法以及其他对程序员很有帮助的接口。

重要的是，Threaded 提供了隐式的线程安全机制，这个对象中的所有操作都是线程安全的。

类摘要

Threaded implements Collectable , Traversable , Countable , ArrayAccess {
/* 方法 */
public chunk ( int $size , bool $preserve ) : array
public count ( ) : int
public extend ( string $class ) : bool
public from ( Closure $run , Closure $construct = ? , array $args = ? ) : Threaded
public getTerminationInfo ( ) : array
public isRunning ( ) : bool
public isTerminated ( ) : bool
public isWaiting ( ) : bool
public lock ( ) : bool
public merge ( mixed $from , bool $overwrite = ? ) : bool
public notify ( ) : bool
public notifyOne ( ) : bool
public pop ( ) : bool
public run ( ) : void
public shift ( ) : boolean
public synchronized ( Closure $block , mixed $... = ? ) : mixed
public unlock ( ) : bool
public wait ( int $timeout = ? ) : bool
}

Table of Contents

  • Threaded::chunk — 操作
  • Threaded::count — 操作
  • Threaded::extend — Runtime Manipulation
  • Threaded::from — Creation
  • Threaded::getTerminationInfo — 错误检测
  • Threaded::isRunning — 状态检测
  • Threaded::isTerminated — 状态检测
  • Threaded::isWaiting — 状态检测
  • Threaded::lock — 同步控制
  • Threaded::merge — 操作
  • Threaded::notify — 同步控制
  • Threaded::notifyOne — Synchronization
  • Threaded::pop — 操作
  • Threaded::run — 执行
  • Threaded::shift — Manipulation
  • Threaded::synchronized — 同步控制
  • Threaded::unlock — 同步控制
  • Threaded::wait — Synchronization


操作

  • ? Threaded
  • Threaded::count ?
  • PHP Manual
  • Threaded
  • 操作

Threaded::chunk

(PECL pthreads >= 2.0.0)

Threaded::chunk — 操作

说明

public Threaded::chunk ( int $size , bool $preserve ) : array

获取给定数量的对象属性表，可以选择是否保留键名称。

参数

size

要获取的条目数量

preserve

保留成员原有的键名称，默认为 false

返回值

数组对象，包含从对象属性表中返回的给定数量的条目。

范例

Example #1 获取对象属性表中的部分条目

<?php
$safe = new Threaded();

while (count($safe) < 10) {
    $safe[] = count($safe);
}

var_dump($safe->chunk(5));
?>

以上例程会输出：

array(5) {
  [0]=>
  int(0)
  [1]=>
  int(1)
  [2]=>
  int(2)
  [3]=>
  int(3)
  [4]=>
  int(4)
}


操作

  • ? Threaded::chunk
  • Threaded::extend ?
  • PHP Manual
  • Threaded
  • 操作

Threaded::count

(PECL pthreads >= 2.0.0)

Threaded::count — 操作

说明

public Threaded::count ( ) : int

返回对象的属性数量

参数

此函数没有参数。

返回值

范例

Example #1 计算对象中的属性数量

<?php
$safe = new Threaded();

while (count($safe) < 10) {
    $safe[] = count($safe);
}

var_dump(count($safe));
?>

以上例程会输出：

int(10)


Runtime Manipulation

  • ? Threaded::count
  • Threaded::from ?
  • PHP Manual
  • Threaded
  • Runtime Manipulation

Threaded::extend

(PECL pthreads >= 2.0.8)

Threaded::extend — Runtime Manipulation

说明

public Threaded::extend ( string $class ) : bool

Makes thread safe standard class at runtime

参数

class

The class to extend

返回值

A boolean indication of success

范例

Example #1 Runtime inheritance

<?php
class My {}

Threaded::extend(My::class);

$my = new My();

var_dump($my instanceof Threaded);
?>

以上例程会输出：

bool(true)


Creation

  • ? Threaded::extend
  • Threaded::getTerminationInfo ?
  • PHP Manual
  • Threaded
  • Creation

Threaded::from

(PECL pthreads >= 2.0.9)

Threaded::from — Creation

Warning

This method has been removed in pthreads v3. With the introduction of anonymous classes in PHP 7, these can now be used instead.

说明

public Threaded::from ( Closure $run , Closure $construct = ? , array $args = ? ) : Threaded

Creates an anonymous Threaded object from closures

参数

run

The closure to use for ::run

construct

The constructor to use for anonymous object

args

The arguments to pass to constructor

返回值

A new anonymous Threaded object

范例

Example #1 Thread safe objects from closures

<?php
$pool = new Pool(4);
$pool->submit(Collectable::from(function(){
    echo "Hello World";
    $this->setGarbage();
}));
/* ... */
$pool->shutdown();
?>

以上例程会输出：

Hello World


错误检测

  • ? Threaded::from
  • Threaded::isRunning ?
  • PHP Manual
  • Threaded
  • 错误检测

Threaded::getTerminationInfo

(PECL pthreads < 3.0.0)

Threaded::getTerminationInfo — 错误检测

Warning

pthreads v3 中已移除此方法。 另外，Threaded::run() 中的代码， 应该使用 try...catch 来进行异常检测（因为在 PHP 7 中大部分 error 都改为抛出异常的方式了）。

说明

public Threaded::getTerminationInfo ( ) : array

返回对象的终端错误信息

参数

此函数没有参数。

返回值

包含终端信息的数组对象

范例

Example #1 检测线程运行时的致命错误

<?php
class My extends Thread {
    public function run() {
        @not_found();
    }
}

$my = new My();
$my->start();
$my->join();

var_dump($my->isTerminated(), $my->getTerminationInfo());
?>

以上例程会输出：

bool(true)
array(4) {
  ["scope"]=>
  string(2) "My"
  ["function"]=>
  string(3) "run"
  ["file"]=>
  string(29) "/usr/src/pthreads/sandbox.php"
  ["line"]=>
  int(4)
}


状态检测

  • ? Threaded::getTerminationInfo
  • Threaded::isTerminated ?
  • PHP Manual
  • Threaded
  • 状态检测

Threaded::isRunning

(PECL pthreads >= 2.0.0)

Threaded::isRunning — 状态检测

说明

public Threaded::isRunning ( ) : bool

对象是否正在运行

参数

此函数没有参数。

返回值

表示运行状态的布尔值

Note:

如果对象的 run 方法正在执行，则视该对象为处于运行状态

范例

Example #1 检测对象状态

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
var_dump($my->isRunning());
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
?>

以上例程会输出：

bool(true)


状态检测

  • ? Threaded::isRunning
  • Threaded::isWaiting ?
  • PHP Manual
  • Threaded
  • 状态检测

Threaded::isTerminated

(PECL pthreads >= 2.0.0)

Threaded::isTerminated — 状态检测

说明

public Threaded::isTerminated ( ) : bool

检测是否因致命错误或未捕获的异常而导致执行过程异常终止

参数

此函数没有参数。

返回值

布尔值，表示是否异常终止

范例

Example #1 检测对象状态

<?php
class My extends Thread {
    public function run() {
        i_do_not_exist();
    }
}
$my = new My();
$my->start();
$my->join();
var_dump($my->isTerminated());
?>

以上例程会输出：

bool(true)


状态检测

  • ? Threaded::isTerminated
  • Threaded::lock ?
  • PHP Manual
  • Threaded
  • 状态检测

Threaded::isWaiting

(PECL pthreads < 3.0.0)

Threaded::isWaiting — 状态检测

Warning

pthreads v3 中已移除此方法。

说明

public Threaded::isWaiting ( ) : bool

检测对象是否在等待其他线程唤醒

参数

此函数没有参数。

返回值

布尔值，表示是否处于等待唤醒状态

范例

Example #1 检测对象状态

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$this->done)
                $thread->wait();
        }, $this);
    }

    protected $done;
}
$my = new My();
$my->start();
$my->synchronized(function($thread){
    var_dump(
        $thread->isWaiting());
    $thread->done = true;
    $thread->notify();
}, $my);
?>

以上例程会输出：

bool(true)


同步控制

  • ? Threaded::isWaiting
  • Threaded::merge ?
  • PHP Manual
  • Threaded
  • 同步控制

Threaded::lock

(PECL pthreads < 3.0.0)

Threaded::lock — 同步控制

Warning

pthreads v3 中已移除此方法。 请使用 Threaded::synchronized() 方法。

说明

public Threaded::lock ( ) : bool

给对象属性表加锁

参数

此函数没有参数。

返回值

布尔值，表示加锁是否成功

范例

Example #1 给对象属性加锁

<?php
class My extends Thread {
    public function run() {
        var_dump($this->lock());
        /** 其他线程无法进行读/写操作 **/
        var_dump($this->unlock());
        /** 其他线程可以进行读/写操作 */
    }
}
$my = new My();
$my->start();
?>

以上例程会输出：

bool(true)
bool(true)


操作

  • ? Threaded::lock
  • Threaded::notify ?
  • PHP Manual
  • Threaded
  • 操作

Threaded::merge

(PECL pthreads >= 2.0.0)

Threaded::merge — 操作

说明

public Threaded::merge ( mixed $from , bool $overwrite = ? ) : bool

将数据合并到当前对象

参数

from

要合并的数据

overwrite

如果现有对象已经存在同键的数据，是否覆盖。默认为 true

返回值

布尔值，表示操作是否成功

范例

Example #1 合并数据到对象的属性表

<?php
$array = [];

while (count($array) < 10)
    $array[] = count($array);

$stdClass = new stdClass();
$stdClass->foo = "foo";
$stdClass->bar = "bar";
$stdClass->baz = "baz";

$safe = new Threaded();
$safe->merge($array);
$safe->merge($stdClass);

var_dump($safe);
?>

以上例程会输出：

object(Threaded)#2 (13) {
  ["0"]=>
  int(0)
  ["1"]=>
  int(1)
  ["2"]=>
  int(2)
  ["3"]=>
  int(3)
  ["4"]=>
  int(4)
  ["5"]=>
  int(5)
  ["6"]=>
  int(6)
  ["7"]=>
  int(7)
  ["8"]=>
  int(8)
  ["9"]=>
  int(9)
  ["foo"]=>
  string(3) "foo"
  ["bar"]=>
  string(3) "bar"
  ["baz"]=>
  string(3) "baz"
}


同步控制

  • ? Threaded::merge
  • Threaded::notifyOne ?
  • PHP Manual
  • Threaded
  • 同步控制

Threaded::notify

(PECL pthreads >= 2.0.0)

Threaded::notify — 同步控制

说明

public Threaded::notify ( ) : bool

向对象发送唤醒通知

参数

此函数没有参数。

返回值

布尔值，表示操作是否成功

范例

Example #1 等待和唤醒

<?php
class My extends Thread {
    public function run() {
        /** 让线程等待 **/
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
/** 向处于等待状态的线程发送唤醒通知 **/
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

以上例程会输出：

bool(true)


Synchronization

  • ? Threaded::notify
  • Threaded::pop ?
  • PHP Manual
  • Threaded
  • Synchronization

Threaded::notifyOne

(PECL pthreads >= 3.0.0)

Threaded::notifyOne — Synchronization

说明

public Threaded::notifyOne ( ) : bool

Send notification to the referenced object. This unblocks at least one of the blocked threads (as opposed to unblocking all of them, as seen with Threaded::notify()).

参数

此函数没有参数。

返回值

A boolean indication of success

范例

Example #1 Notifications and Waiting

<?php
class My extends Thread {
    public function run() {
        /** cause this thread to wait **/
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
/** send notification to the waiting thread **/
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notifyOne();
}, $my);
var_dump($my->join());
?>

以上例程会输出：

bool(true)


操作

  • ? Threaded::notifyOne
  • Threaded::run ?
  • PHP Manual
  • Threaded
  • 操作

Threaded::pop

(PECL pthreads >= 2.0.0)

Threaded::pop — 操作

说明

public Threaded::pop ( ) : bool

弹出对象属性表中的最后一项数据

返回值

对象属性表中最后一项数据

范例

Example #1 弹出对象属性表中的最后一项数据

<?php
$safe = new Threaded();

while (count($safe) < 10)
    $safe[] = count($safe);

var_dump($safe->pop());
?>

以上例程会输出：

int(9)


执行

  • ? Threaded::pop
  • Threaded::shift ?
  • PHP Manual
  • Threaded
  • 执行

Threaded::run

(PECL pthreads >= 2.0.0)

Threaded::run — 执行

说明

public Threaded::run ( ) : void

如果需要在多线程环境下执行代码，必须实现本方法

参数

此函数没有参数。

返回值

无返回值。即使代码中 run 方法有返回值，也会被忽略


Manipulation

  • ? Threaded::run
  • Threaded::synchronized ?
  • PHP Manual
  • Threaded
  • Manipulation

Threaded::shift

(PECL pthreads >= 2.0.0)

Threaded::shift — Manipulation

说明

public Threaded::shift ( ) : boolean

弹出对象属性表中第一项数据

返回值

对象属性表中的第一项数据

范例

Example #1 弹出对象属性表中第一项数据

<?php
$safe = new Threaded();

while (count($safe) < 10)
    $safe[] = count($safe);

var_dump($safe->shift());
?>

以上例程会输出：

int(0)


同步控制

  • ? Threaded::shift
  • Threaded::unlock ?
  • PHP Manual
  • Threaded
  • 同步控制

Threaded::synchronized

(PECL pthreads >= 2.0.0)

Threaded::synchronized — 同步控制

说明

public Threaded::synchronized ( Closure $block , mixed $... = ? ) : mixed

在发起调用的线程上下文中获取对象同步锁，然后同步执行代码块

参数

block

要执行的代码块

...

传送给代码块的不定长参数

返回值

代码块的返回值

范例

Example #1 同步

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

以上例程会输出：

bool(true)


同步控制

  • ? Threaded::synchronized
  • Threaded::wait ?
  • PHP Manual
  • Threaded
  • 同步控制

Threaded::unlock

(PECL pthreads < 3.0.0)

Threaded::unlock — 同步控制

Warning

pthreads v3 中已移除此方法。 请使用 Threaded::synchronized() 方法。

说明

public Threaded::unlock ( ) : bool

从调用上下文中解锁被引用的对象

参数

此函数没有参数。

返回值

布尔值，表示操作是否成功

范例

Example #1 给对象属性表加锁

<?php
class My extends Thread {
    public function run() {
        var_dump($this->lock());
        /** 其他线程无法执行读/写操作 **/
        var_dump($this->unlock());
        /** 其他线程可以执行读/写操作 */
    }
}
$my = new My();
$my->start();
?>

以上例程会输出：

bool(true)
bool(true)


Synchronization

  • ? Threaded::unlock
  • Thread ?
  • PHP Manual
  • Threaded
  • Synchronization

Threaded::wait

(PECL pthreads >= 2.0.0)

Threaded::wait — Synchronization

说明

public Threaded::wait ( int $timeout = ? ) : bool

让发起调用的线程上下文进入等待状态，直到收到其他线程的唤醒通知

参数

timeout

可选参数，等待时间，以微秒计

返回值

布尔值，表示操作是否成功

范例

Example #1 等待和唤醒

<?php
class My extends Thread {
    public function run() {
        /** 让本线程进入等待状态 **/
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
/** 向处于等待状态的线程发送唤醒通知 **/
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

以上例程会输出：

bool(true)


Thread 类

(PECL pthreads >= 2.0.0)

简介

当调用 Thread 对象的 start 方法时，该对象的 run 方法中的代码将在独立线程中并行执行。

run 方法中的代码执行完毕之后，独立线程立即退出，并且等待合适的时机由创建者线程加入（join）。

Warning

依赖于引擎本身的机制检测何时加入线程可能引发非预期的行为，程序员应该尽可能的显式控制线程加入的时机。

类摘要

Thread extends Threaded implements Countable , Traversable , ArrayAccess {
/* 方法 */
public detach ( ) : void
public getCreatorId ( ) : int
public static getCurrentThread ( ) : Thread
public static getCurrentThreadId ( ) : int
public getThreadId ( ) : int
public static globally ( ) : mixed
public isJoined ( ) : bool
public isStarted ( ) : bool
public join ( ) : bool
public kill ( ) : void
public start ( int $options = ? ) : bool
/* 继承的方法 */
public Threaded::chunk ( int $size , bool $preserve ) : array
public Threaded::count ( ) : int
public Threaded::extend ( string $class ) : bool
public Threaded::from ( Closure $run , Closure $construct = ? , array $args = ? ) : Threaded
public Threaded::getTerminationInfo ( ) : array
public Threaded::isRunning ( ) : bool
public Threaded::isTerminated ( ) : bool
public Threaded::isWaiting ( ) : bool
public Threaded::lock ( ) : bool
public Threaded::merge ( mixed $from , bool $overwrite = ? ) : bool
public Threaded::notify ( ) : bool
public Threaded::notifyOne ( ) : bool
public Threaded::pop ( ) : bool
public Threaded::run ( ) : void
public Threaded::shift ( ) : boolean
public Threaded::synchronized ( Closure $block , mixed $... = ? ) : mixed
public Threaded::unlock ( ) : bool
public Threaded::wait ( int $timeout = ? ) : bool
}

Table of Contents

  • Thread::detach — 执行
  • Thread::getCreatorId — 识别
  • Thread::getCurrentThread — 识别
  • Thread::getCurrentThreadId — 识别
  • Thread::getThreadId — 识别
  • Thread::globally — 执行
  • Thread::isJoined — 状态监测
  • Thread::isStarted — 状态检测
  • Thread::join — 同步
  • Thread::kill — 执行
  • Thread::start — 执行


执行

  • ? Thread
  • Thread::getCreatorId ?
  • PHP Manual
  • Thread
  • 执行

Thread::detach

(PECL pthreads < 3.0.0)

Thread::detach — 执行

Warning

pthreads v3 中已经移除此方法.

说明

public Thread::detach ( ) : void

从调用上下文中将引用线程分离出来，非常危险！

Warning

本方法会引发未定义的、不安全的行为。 通常情况下不会用到本方法，提供这个方法主要是出于完备性以及高级用法的考虑。

参数

此函数没有参数。

返回值


识别

  • ? Thread::detach
  • Thread::getCurrentThread ?
  • PHP Manual
  • Thread
  • 识别

Thread::getCreatorId

(PECL pthreads >= 2.0.0)

Thread::getCreatorId — 识别

说明

public Thread::getCreatorId ( ) : int

返回创建当前线程的线程ID。

参数

此函数没有参数。

返回值

线程ID，数字格式

范例

Example #1 返回创建线程的线程或进程ID

<?php
class My extends Thread {
    public function run() {
        printf("%s created by Thread #%lu\n", __CLASS__, $this->getCreatorId());
    }
}
$my = new My();
$my->start();
?>

以上例程会输出：

My created by Thread #123456778899


识别

  • ? Thread::getCreatorId
  • Thread::getCurrentThreadId ?
  • PHP Manual
  • Thread
  • 识别

Thread::getCurrentThread

(PECL pthreads >= 2.0.0)

Thread::getCurrentThread — 识别

说明

public static Thread::getCurrentThread ( ) : Thread

获取当前执行线程的引用。

参数

此函数没有参数。

返回值

表示当前执行线程的对象。

范例

Example #1 获取当前执行线程

<?php
class My extends Thread {
    public function run() {
        var_dump(Thread::getCurrentThread());
    }
}
$my = new My();
$my->start();
?>

以上例程会输出：

object(My)#2 (0) {
}


识别

  • ? Thread::getCurrentThread
  • Thread::getThreadId ?
  • PHP Manual
  • Thread
  • 识别

Thread::getCurrentThreadId

(PECL pthreads >= 2.0.0)

Thread::getCurrentThreadId — 识别

说明

public static Thread::getCurrentThreadId ( ) : int

返回当前执行线程的ID

参数

此函数没有参数。

返回值

线程ID，数字格式

范例

Example #1 返回当前执行线程的ID

<?php
class My extends Thread {
    public function run() {
        printf("%s is Thread #%lu\n", __CLASS__, Thread::getCurrentThreadId());
    }
}
$my = new My();
$my->start();
?>

以上例程会输出：

My is Thread #123456778899


识别

  • ? Thread::getCurrentThreadId
  • Thread::globally ?
  • PHP Manual
  • Thread
  • 识别

Thread::getThreadId

(PECL pthreads >= 2.0.0)

Thread::getThreadId — 识别

说明

public Thread::getThreadId ( ) : int

返回引用线程的ID

参数

此函数没有参数。

返回值

线程ID，数字格式

范例

Example #1 返回引用线程的ID

<?php
class My extends Thread {
    public function run() {
        printf("%s is Thread #%lu\n", __CLASS__, $this->getThreadId());
    }
}
$my = new My();
$my->start();
?>

以上例程会输出：

My is Thread #123456778899


执行

  • ? Thread::getThreadId
  • Thread::isJoined ?
  • PHP Manual
  • Thread
  • 执行

Thread::globally

(PECL pthreads < 3.0.0)

Thread::globally — 执行

Warning

pthreads v3 中已移除此方法。

说明

public static Thread::globally ( ) : mixed

在全局范围中执行代码块

参数

此函数没有参数。

返回值

被调用代码块的返回值

范例

Example #1 在全局范围执行代码块

<?php
class My extends Thread {
    public function run() {
        global $std;

        Thread::globally(function(){
            $std = new stdClass;
        });

        var_dump($std);
    }
}
$my = new My();
$my->start();
?>

以上例程会输出：

object(stdClass)#3 (0) {
}


状态监测

  • ? Thread::globally
  • Thread::isStarted ?
  • PHP Manual
  • Thread
  • 状态监测

Thread::isJoined

(PECL pthreads >= 2.0.0)

Thread::isJoined — 状态监测

说明

public Thread::isJoined ( ) : bool

线程是否已经被加入（join）

参数

此函数没有参数。

返回值

布尔值，表示是否被加入

范例

Example #1 检测线程状态

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
var_dump($my->isJoined());
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
?>

以上例程会输出：

bool(false)


状态检测

  • ? Thread::isJoined
  • Thread::join ?
  • PHP Manual
  • Thread
  • 状态检测

Thread::isStarted

(PECL pthreads >= 2.0.0)

Thread::isStarted — 状态检测

说明

public Thread::isStarted ( ) : bool

线程是否开始执行

参数

此函数没有参数。

返回值

布尔值，表示线程是否开始执行

范例

Example #1 监测线程是否开始执行

<?php
$worker = new Worker();
$worker->start();
var_dump($worker->isStarted());
?>

以上例程会输出：

bool(true)


同步

  • ? Thread::isStarted
  • Thread::kill ?
  • PHP Manual
  • Thread
  • 同步

Thread::join

(PECL pthreads >= 2.0.0)

Thread::join — 同步

说明

public Thread::join ( ) : bool

让当前执行上下文等待被引用线程执行完毕

参数

此函数没有参数。

返回值

布尔值，表示操作成功与否

范例

Example #1 加入线程

<?php
class My extends Thread {
    public function run() {
        /* ... */
    }
}
$my = new My();
$my->start();
/* ... */
var_dump($my->join());
/* ... */
?>

以上例程会输出：

bool(true)


执行

  • ? Thread::join
  • Thread::start ?
  • PHP Manual
  • Thread
  • 执行

Thread::kill

(PECL pthreads < 3.0.0)

Thread::kill — 执行

Warning

pthreads v3 中已移除此方法。

说明

public Thread::kill ( ) : void

强制线程中止

Warning

通常情况下，程序员不应该强制杀除线程

参数

此函数没有参数。

返回值

布尔值，表示操作成功与否

范例

Example #1 杀除线程

<?php
class T extends Thread {
    public function run() {
        $stdin = fopen("php://stdin", "r");
        while(($line = fgets($stdin))) {
            echo $line;
        }
    }
}

$t = new T();
$t->start();

var_dump($t->kill());
?>

以上例程会输出：

bool(true)


执行

  • ? Thread::kill
  • Worker ?
  • PHP Manual
  • Thread
  • 执行

Thread::start

(PECL pthreads >= 2.0.0)

Thread::start — 执行

说明

public Thread::start ( int $options = ? ) : bool

在独立线程中执行 run 方法

参数

options

可选参数，用来控制线程继承。默认值为 PTHREADS_INHERIT_ALL

返回值

布尔值，表示操作成功与否

范例

Example #1 开始线程

<?php
class My extends Thread {
    public function run() {
        /** ... **/
    }
}
$my = new My();
var_dump($my->start());
?>

以上例程会输出：

bool(true)


Worker 类

(PECL pthreads >= 2.0.0)

简介

Worker 是一个具有持久化上下文的线程对象，通常用来在多个线程中使用。

当一个 Worker 对象开始之后，会执行它的 run 方法，但是即使 run 方法执行完毕，线程本身也不会消亡，除非遇到以下情况：

  • Worker 对象超出作用范围（没有指向它的引用了）

  • 代码调用了 Worker 对象的 shutdown 方法

  • 整个脚本终止了

这意味着程序员可以在程序执行过程中重用这个线程上下文： 在 Worker 对象的栈中添加对象会激活 Worker 对象执行被加入对象的 run 方法。

类摘要

Worker extends Thread implements Traversable , Countable , ArrayAccess {
/* 方法 */
public collect ( Callable $collector = ? ) : int
public getStacked ( ) : int
public isShutdown ( ) : bool
public isWorking ( ) : bool
public shutdown ( ) : bool
public stack ( Threaded &$work ) : int
public unstack ( ) : int
/* 继承的方法 */
public Thread::detach ( ) : void
public Thread::getCreatorId ( ) : int
public static Thread::getCurrentThread ( ) : Thread
public static Thread::getCurrentThreadId ( ) : int
public Thread::getThreadId ( ) : int
public static Thread::globally ( ) : mixed
public Thread::isJoined ( ) : bool
public Thread::isStarted ( ) : bool
public Thread::join ( ) : bool
public Thread::kill ( ) : void
public Thread::start ( int $options = ? ) : bool
}

Table of Contents

  • Worker::collect — Collect references to completed tasks
  • Worker::getStacked — 获取剩余的栈大小
  • Worker::isShutdown — 状态检测
  • Worker::isWorking — 状态检测
  • Worker::shutdown — 关闭 Worker
  • Worker::stack — 将要执行的任务入栈
  • Worker::unstack — 将要执行的任务出栈


Collect references to completed tasks

  • ? Worker
  • Worker::getStacked ?
  • PHP Manual
  • Worker
  • Collect references to completed tasks

Worker::collect

(PECL pthreads >= 3.0.0)

Worker::collect — Collect references to completed tasks

说明

public Worker::collect ( Callable $collector = ? ) : int

Allows the worker to collect references determined to be garbage by the optionally given collector.

参数

collector

A Callable collector that returns a boolean on whether the task can be collected or not. Only in rare cases should a custom collector need to be used.

返回值

The number of remaining tasks on the worker's stack to be collected.

范例

Example #1 A basic example of Worker::collect()

<?php
$worker = new Worker();

echo "There are currently {$worker->collect()} tasks on the stack to be collected\n";

for ($i = 0; $i < 15; ++$i) {
    $worker->stack(new class extends Threaded {});
}

echo "There are {$worker->collect()} tasks remaining on the stack to be collected\n";

$worker->start();

while ($worker->collect()); // blocks until all tasks have finished executing

echo "There are now {$worker->collect()} tasks on the stack to be collected\n";

$worker->shutdown();

以上例程会输出：

There are currently 0 tasks on the stack to be collected
There are 15 tasks remaining on the stack to be collected
There are now 0 tasks on the stack to be collected


获取剩余的栈大小

  • ? Worker::collect
  • Worker::isShutdown ?
  • PHP Manual
  • Worker
  • 获取剩余的栈大小

Worker::getStacked

(PECL pthreads >= 2.0.0)

Worker::getStacked — 获取剩余的栈大小

说明

public Worker::getStacked ( ) : int

返回栈中剩余的任务数量

参数

此函数没有参数。

返回值

返回 worker 中等待执行的任务数量

范例

Example #1 Worker::getStacked 基本示例

<?php
$worker = new Worker();

for ($i = 0; $i < 5; ++$i) {
    $worker->stack(new class extends Threaded {});
}

echo "There are {$worker->getStacked()} stacked tasks\n";

以上例程会输出：

There are 5 stacked tasks


状态检测

  • ? Worker::getStacked
  • Worker::isWorking ?
  • PHP Manual
  • Worker
  • 状态检测

Worker::isShutdown

(PECL pthreads >= 2.0.0)

Worker::isShutdown — 状态检测

说明

public Worker::isShutdown ( ) : bool

Worker 对象是否被关闭

参数

此函数没有参数。

返回值

布尔值，表示 worker 是否已经被关闭

范例

Example #1 检测 Worker 对象状态

<?php
$worker = new Worker();
$worker->start();

var_dump($worker->isShutdown());

$worker->shutdown();

var_dump($worker->isShutdown());

以上例程会输出：

bool(false)
bool(true)


状态检测

  • ? Worker::isShutdown
  • Worker::shutdown ?
  • PHP Manual
  • Worker
  • 状态检测

Worker::isWorking

(PECL pthreads >= 2.0.0)

Worker::isWorking — 状态检测

Warning

pthreads v3 中已移除此方法。 请使用 Worker::getStacked() 方法来检测 worker 中是还有 尚待执行的任务。

说明

public Worker::isWorking ( ) : bool

Worker 对象是否正在执行栈中对象

参数

此函数没有参数。

返回值

布尔值，表示 Worker 对象是否在执行栈中对象

范例

Example #1 检测 Worker 对象状态

<?php
$my = new Worker();
$my->start();
/* ... */
if ($my->isWorking()) {
    /* ... the Worker is busy executing another object */
}
?>


关闭 Worker

  • ? Worker::isWorking
  • Worker::stack ?
  • PHP Manual
  • Worker
  • 关闭 Worker

Worker::shutdown

(PECL pthreads >= 2.0.0)

Worker::shutdown — 关闭 Worker

说明

public Worker::shutdown ( ) : bool

在执行完已入栈对象之后，关闭这个 Worker 对象

参数

此函数没有参数。

返回值

布尔值，表示这个 worker 是否被成功关闭。

范例

Example #1 关闭 Worker

<?php
$my = new Worker();
$my->start();
/* 入栈和执行任务 */
var_dump($my->shutdown());

以上例程会输出：

bool(true)


将要执行的任务入栈

  • ? Worker::shutdown
  • Worker::unstack ?
  • PHP Manual
  • Worker
  • 将要执行的任务入栈

Worker::stack

(PECL pthreads >= 2.0.0)

Worker::stack — 将要执行的任务入栈

说明

public Worker::stack ( Threaded &$work ) : int

将要执行的任务入栈到 Worker 对象

参数

work

要被 Worker 执行的 Threaded 派生对象

返回值

入栈之后，Worker 对象栈的大小。

范例

Example #1 向 Worker 中入栈任务并执行

<?php
$worker = new Worker();
$work = new class extends Threaded {};

var_dump($worker->stack($work));

以上例程会输出：

int(1)


将要执行的任务出栈

  • ? Worker::stack
  • Collectable ?
  • PHP Manual
  • Worker
  • 将要执行的任务出栈

Worker::unstack

(PECL pthreads >= 2.0.0)

Worker::unstack — 将要执行的任务出栈

说明

public Worker::unstack ( ) : int

把 Worker 栈顶的（最老的那个）任务从栈中移除。

参数

此函数没有参数。

返回值

出栈之后，Worker 栈的大小。

更新日志

版本 | 说明
v3 | 移除了要出栈的任务参数。 现在只能移除栈顶元素。

范例

Example #1 从 Worker 栈中移除对象

<?php
$my = new Worker();
$work = new class extends Threaded {};

var_dump($my->stack($work));
var_dump($my->unstack());

以上例程会输出：

int(1)
int(0)


The Collectable interface

(PECL pthreads >= 2.0.8)

简介

Caution

Collectable was previously a class (in pthreads v2 and below). Now, it is an interface in pthreads v3 that is implemented by the Threaded class.

Represents a garbage-collectable object.

接口摘要

Collectable {
/* 方法 */
public isGarbage ( ) : bool
public setGarbage ( ) : void
}

Table of Contents

  • Collectable::isGarbage — Determine whether an object has been marked as garbage
  • Collectable::setGarbage — Mark an object as garbage


Determine whether an object has been marked as garbage

  • ? Collectable
  • Collectable::setGarbage ?
  • PHP Manual
  • Collectable
  • Determine whether an object has been marked as garbage

Collectable::isGarbage

(PECL pthreads >= 2.0.8)

Collectable::isGarbage — Determine whether an object has been marked as garbage

说明

public Collectable::isGarbage ( ) : bool

Can be called in Pool::collect() to determine if this object is garbage.

参见

  • Pool::collect() - 回收已完成任务的引用


Mark an object as garbage

  • ? Collectable::isGarbage
  • Modifiers ?
  • PHP Manual
  • Collectable
  • Mark an object as garbage

Collectable::setGarbage

(PECL pthreads < 3.0.0)

Collectable::setGarbage — Mark an object as garbage

Warning

This method has been removed in pthreads v3.

说明

public Collectable::setGarbage ( ) : void

Should be called once per object when the object is finished being executed or referenced.

参见

  • Collectable::isGarbage() - Determine whether an object has been marked as garbage


方法修饰符

Warning

仅适用于 pthreads v2。在 pthreads v3 中已经被移除。

pthreads 将会改写标明为 protected 和 private 的方法来提供更加适合多线程环境的对象。 对于所有的 Threaded 对象，pthreads 都会进行改写操作。

Example #1 protected 方法示例： 标记为 protected 的方法在同一时间仅允许一个线程访问

<?php
class ExampleThread extends Thread {
    public function run() {
        /* thread code */
        if ($this->synchronized()) {

        }
    }

    protected function exclusive() {
        /* synchronized method */
    }
}

$thread = new ExampleThread();
if ($thread->start()) {
    $thread->exclusive();
}
?>

Example #2 private 方法示例：标记为 private 的方法只能由创建该对象的线程调用

<?php
class ExampleThread extends Thread {
    public function run() {
        /* thread code */
        if ($this->insideonly()) {

        }
    }

    private function insideonly() {
        /* private method */
    }
}

$thread = new ExampleThread();
if ($thread->start()) {
    $thread->insideonly();
}
?>


Pool 类

(PECL pthreads >= 2.0.0)

简介

Pool 对象是多个 Worker 对象的容器，同时也是它们的控制器。

线程池是对 Worker 功能的高层抽象，包括按照 pthreads 需要的方式来管理应用的功能。

类摘要

Pool {
/* 属性 */
protected $size ;
protected $class ;
protected $workers ;
protected $ctor ;
protected $last ;
/* 方法 */
public collect ( Callable $collector = ? ) : int
public __construct ( int $size , string $class = ? , array $ctor = ? ) : Pool
public resize ( int $size ) : void
public shutdown ( ) : void
public submit ( Threaded $task ) : int
public submitTo ( int $worker , Threaded $task ) : int
}

属性

size

Pool 对象可容纳的 Worker 对象的最大数量

class

Worker 的类

workers

指向 Worker 对象的引用

ctor

构造新的 Worker 对象时所需的参数

last

最后使用的 Worker 对象在池中的位置偏移量

Table of Contents

  • Pool::collect — 回收已完成任务的引用
  • Pool::__construct — 创建新的 Worker 对象池
  • Pool::resize — 改变 Pool 对象的可容纳 Worker 对象的数量
  • Pool::shutdown — 停止所有的 Worker 对象
  • Pool::submit — 提交对象以执行
  • Pool::submitTo — 提交一个任务到特定的 Worker 以执行


回收已完成任务的引用

  • ? Pool
  • Pool::__construct ?
  • PHP Manual
  • Pool
  • 回收已完成任务的引用

Pool::collect

(PECL pthreads >= 2.0.0)

Pool::collect — 回收已完成任务的引用

说明

public Pool::collect ( Callable $collector = ? ) : int

对于视为垃圾的引用，使用给定的垃圾收集器进行收集

参数

collector

垃圾收集器，它返回一个布尔值表示这个任务是否可以被进行垃圾收集。 仅在极少的情况下需要一个自定义的垃圾收集器。

返回值

池中剩余的待收集的任务数量。

更新日志

版本 | 说明
v3 | collector 参数变为可选参数， 并且返回值改为整数。

范例

Example #1 Pool::collect() 基本用法示例

<?php
$pool = new Pool(4);

for ($i = 0; $i < 15; ++$i) {
    $pool->submit(new class extends Threaded {});
}

while ($pool->collect()); // 直到全部的任务都完成执行之后才会继续下面的代码

$pool->shutdown();


创建新的 Worker 对象池

  • ? Pool::collect
  • Pool::resize ?
  • PHP Manual
  • Pool
  • 创建新的 Worker 对象池

Pool::__construct

(PECL pthreads >= 2.0.0)

Pool::__construct — 创建新的 Worker 对象池

说明

public Pool::__construct ( int $size , string $class = ? , array $ctor = ? ) : Pool

创建新的 Worker 对象池，但是所对应的线程是延迟创建的的，也就是说， 直到需要执行任务的时候 才会创建对应的线程。

参数

size

此 Pool 对象可创建的 Worker 对象的最大数量

class

新创建的 Worker 对象的类。 如果不指定类，那么会使用默认的 Worker 类。

ctor

创建 Worker 对象时所用到的参数，以数组方式传入

返回值

新创建的 Pool 对象

范例

Example #1 创建 Pool 对象

<?php
class MyWorker extends Worker {

    public function __construct(Something $something) {
        $this->something = $something;
    }

    public function run() {
        /** ... **/
    }
}

$pool = new Pool(8, \MyWorker::class, [new Something()]);

var_dump($pool);
?>

以上例程会输出：

object(Pool)#1 (6) {
  ["size":protected]=>
  int(8)
  ["class":protected]=>
  string(8) "MyWorker"
  ["workers":protected]=>
  NULL
  ["work":protected]=>
  NULL
  ["ctor":protected]=>
  array(1) {
    [0]=>
    object(Something)#2 (0) {
    }
  }
  ["last":protected]=>
  int(0)
}


改变 Pool 对象的可容纳 Worker 对象的数量

  • ? Pool::__construct
  • Pool::shutdown ?
  • PHP Manual
  • Pool
  • 改变 Pool 对象的可容纳 Worker 对象的数量

Pool::resize

(PECL pthreads >= 2.0.0)

Pool::resize — 改变 Pool 对象的可容纳 Worker 对象的数量

说明

public Pool::resize ( int $size ) : void

改变 Pool 对象的可容纳 Worker 对象的数量

参数

size

此 Pool 对象可创建 Worker 对象的最大数量

返回值

void


停止所有的 Worker 对象

  • ? Pool::resize
  • Pool::submit ?
  • PHP Manual
  • Pool
  • 停止所有的 Worker 对象

Pool::shutdown

(PECL pthreads >= 2.0.0)

Pool::shutdown — 停止所有的 Worker 对象

说明

public Pool::shutdown ( ) : void

停止此 Pool 中所有的 Worker 对象。此方法调用会进入阻塞状态， 直到所有已经提交到这个 Pool 中的任务都执行完毕。

参数

此函数没有参数。

返回值

无返回值

范例

Example #1 完全停止一个 Pool

<?php
class Task extends Threaded
{
    public function run()
    {
        usleep(500000);
    }
}

$pool = new Pool(4);

for ($i = 0; $i < 10; ++$i) {
    $pool->submit(new Task());
}

$pool->shutdown(); // 进入阻塞状态，直到所有已经提交到 Pool 中的任务都执行完毕


提交对象以执行

  • ? Pool::shutdown
  • Pool::submitTo ?
  • PHP Manual
  • Pool
  • 提交对象以执行

Pool::submit

(PECL pthreads >= 2.0.0)

Pool::submit — 提交对象以执行

说明

public Pool::submit ( Threaded $task ) : int

将任务提交到 Pool 中的下一个 Worker 对象

参数

task

要执行的任务

返回值

执行新加入对象的 Worker 对象 ID

范例

Example #1 提交任务

<?php
class MyWork extends Threaded {

    public function run() {
        /* ... */
    }
}

class MyWorker extends Worker {

    public function __construct(Something $something) {
        $this->something = $something;
    }

    public function run() {
        /** ... **/
    }
}

$pool = new Pool(8, \MyWorker::class, [new Something()]);
$pool->submit(new MyWork());
var_dump($pool);
?>

以上例程会输出：

object(Pool)#1 (6) {
  ["size":protected]=>
  int(8)
  ["class":protected]=>
  string(8) "MyWorker"
  ["workers":protected]=>
  array(1) {
    [0]=>
    object(MyWorker)#4 (1) {
      ["something"]=>
      object(Something)#5 (0) {
      }
    }
  }
  ["work":protected]=>
  array(1) {
    [0]=>
    object(MyWork)#3 (1) {
      ["worker"]=>
      object(MyWorker)#5 (1) {
        ["something"]=>
        object(Something)#6 (0) {
        }
      }
    }
  }
  ["ctor":protected]=>
  array(1) {
    [0]=>
    object(Something)#2 (0) {
    }
  }
  ["last":protected]=>
  int(1)
}


提交一个任务到特定的 Worker 以执行

  • ? Pool::submit
  • Mutex ?
  • PHP Manual
  • Pool
  • 提交一个任务到特定的 Worker 以执行

Pool::submitTo

(PECL pthreads >= 2.0.0)

Pool::submitTo — 提交一个任务到特定的 Worker 以执行

说明

public Pool::submitTo ( int $worker , Threaded $task ) : int

将对象提交到 Pool 中某个特定的 Worker 对象来执行。Worker 的下标从 0 开始， 由于 Pool 中的线程是懒加载机制， 所以 Worker 对象仅在 Pool 需要执行任务的时候才会真正被创建。

参数

worker

用来执行任务的 Worker 对象，下标从 0 开始。

task

要执行的任务

返回值

接受新加入对象的 Worker 对象ID

范例

Example #1 提交任务到特定的 Worker

<?php
class Task extends Threaded {
    public function run() {
        var_dump(Thread::getCurrentThreadID());
    }
}

$pool = new Pool(2);

$pool->submit(new Task());

for ($i = 0; $i < 5; ++$i) {
    $pool->submitTo(0, new Task()); // 将所有的任务都入栈到下标为 0 的 Worker
}

$pool->submitTo(1, new Task()); // 由于第二个 Worker 尚未存在，所以不可以将任务入栈到第二个 Worker

$pool->shutdown();

以上例程会输出：

int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)

Fatal error: Uncaught Exception: The selected worker (1) does not exist in %s:%d


Mutex 类

(PECL pthreads < 3.0.0)

简介

Warning

pthreads v3 中已经将 Mutex 类移除。

Mutex 类中包含一些直接访问 Posix 互斥量的静态方法

类摘要

Mutex {
/* 方法 */
final public static create ( bool $lock = ? ) : int
final public static destroy ( int $mutex ) : bool
final public static lock ( int $mutex ) : bool
final public static trylock ( int $mutex ) : bool
final public static unlock ( int $mutex , bool $destroy = ? ) : bool
}

Table of Contents

  • Mutex::create — 创建一个互斥量
  • Mutex::destroy — 销毁互斥量
  • Mutex::lock — 给互斥量加锁
  • Mutex::trylock — 尝试给互斥量加锁
  • Mutex::unlock — 释放互斥量上的锁


创建一个互斥量

  • ? Mutex
  • Mutex::destroy ?
  • PHP Manual
  • Mutex
  • 创建一个互斥量

Mutex::create

(PECL pthreads < 3.0.0)

Mutex::create — 创建一个互斥量

Warning

pthreads v3 中已经将 Mutex 类移除。

说明

final public static Mutex::create ( bool $lock = ? ) : int

为调用者创建一个互斥量，同时也可以通过 lock 参数设置是否在创建完成之后立即加锁此互斥量

参数

lock

如果设置 lock 参数为 true，表示创建互斥量之后，立即加锁，然后再将互斥量句柄返回给调用者

返回值

新创建的互斥量句柄，这个互斥量可能已经处于加锁状态，由 lock 参数控制

范例

Example #1 互斥量的创建与销毁

<?php
/** 不可以使用 new 关键字，因为互斥量不是 PHP 对象 **/
$mutex = Mutex::create();
/** 你已经持有了这个互斥量的物理地址 **/
var_dump($mutex);
/** 不要忘记销毁你创建的互斥量 **/
Mutex::destroy($mutex);
?>

以上例程会输出：

int(40096976)


销毁互斥量

  • ? Mutex::create
  • Mutex::lock ?
  • PHP Manual
  • Mutex
  • 销毁互斥量

Mutex::destroy

(PECL pthreads < 3.0.0)

Mutex::destroy — 销毁互斥量

Warning

pthreads v3 中已经将 Mutex 类移除。

说明

final public static Mutex::destroy ( int $mutex ) : bool

当不再使用某个已经创建的互斥量句柄之后，程序员需要显式的销毁它。

参数

mutex

通过调用函数 Mutex::create() 返回的互斥量句柄。 当调用 Mutex::destroy() 函数之后，任何线程都无法再给这个互斥量加锁了。

返回值

布尔值，表示操作是否成功

范例

Example #1 互斥量的创建与销毁

<?php
/** 不可以使用 new 关键字，因为互斥量不是 PHP 对象 **/
$mutex = Mutex::create();
/** 你已经持有了这个互斥量的物理地址 **/
var_dump($mutex);
/** 不要忘记销毁你创建的互斥量 **/
Mutex::destroy($mutex);
?>

以上例程会输出：

int(40096976)


给互斥量加锁

  • ? Mutex::destroy
  • Mutex::trylock ?
  • PHP Manual
  • Mutex
  • 给互斥量加锁

Mutex::lock

(PECL pthreads < 3.0.0)

Mutex::lock — 给互斥量加锁

Warning

pthreads v3 中已经将 Mutex 类移除。

说明

final public static Mutex::lock ( int $mutex ) : bool

尝试为调用者给互斥量加锁。

尝试给已经被其他线程加锁的互斥量再次加锁会导致调用者线程进入阻塞状态。

参数

mutex

通过调用函数 Mutex::create() 产生的互斥量句柄。

返回值

布尔值，表示操作是否成功。

范例

Example #1 互斥量加锁与解锁

<?php
/** 不可以使用 new 关键字，因为互斥量不是 PHP 对象 **/
$mutex = Mutex::create();
/** 现在可以在任何线程上下文中给这个互斥量加锁了 **/
var_dump(Mutex::lock($mutex));
/** 销毁一个处于加锁状态的互斥量的操作是无效的 **/
var_dump(Mutex::unlock($mutex));
/** 永远不要忘记销毁你创建的互斥量 **/
Mutex::destroy($mutex);
?>

以上例程会输出：

bool(true)
bool(true)


尝试给互斥量加锁

  • ? Mutex::lock
  • Mutex::unlock ?
  • PHP Manual
  • Mutex
  • 尝试给互斥量加锁

Mutex::trylock

(PECL pthreads < 3.0.0)

Mutex::trylock — 尝试给互斥量加锁

Warning

pthreads v3 中已经将 Mutex 类移除。

说明

final public static Mutex::trylock ( int $mutex ) : bool

尝试给一个互斥量加锁，即使这个互斥量已经被其他线程锁定，也不会导致调用者线程进入阻塞状态。

参数

mutex

通过调用函数 Mutex::create() 产生的互斥量句柄。

返回值

布尔值，表示操作是否成功

范例

Example #1 互斥量的加锁与解锁

<?php
/** 不可以使用 new 关键字，因为互斥量不是 PHP 对象 **/
$mutex = Mutex::create();
/** 现在可以在任何线程上下文中给这个互斥量加锁了 **/
var_dump(Mutex::lock($mutex));
/** 销毁一个处于加锁状态的互斥量的操作是无效的 **/
var_dump(Mutex::unlock($mutex));
/** 永远不要忘记销毁你创建的互斥量 **/
Mutex::destroy($mutex);
?>

以上例程会输出：

bool(true)
bool(true)


释放互斥量上的锁

  • ? Mutex::trylock
  • Cond ?
  • PHP Manual
  • Mutex
  • 释放互斥量上的锁

Mutex::unlock

(PECL pthreads < 3.0.0)

Mutex::unlock — 释放互斥量上的锁

Warning

pthreads v3 中已经将 Mutex 类移除。

说明

final public static Mutex::unlock ( int $mutex , bool $destroy = ? ) : bool

尝试为互斥量解锁，也可以通过 destroy 参数控制是否在解锁之后同时销毁此互斥量。 只有持有互斥量锁的线程才可以对这个互斥量进行解锁操作。

参数

mutex

通过调用函数 Mutex::create() 产生的互斥量句柄。

destroy

此参数为 true 表示如果解锁成功，则同时销毁此互斥量。

返回值

A boolean indication of success.

范例

Example #1 互斥量的加锁与解锁

<?php
/** 不可以使用 new 关键字，因为互斥量不是 PHP 对象 **/
$mutex = Mutex::create();
/** 现在可以在任何线程上下文中给这个互斥量加锁了 **/
var_dump(Mutex::lock($mutex));
/** 销毁一个处于加锁状态的互斥量的操作是无效的 **/
var_dump(Mutex::unlock($mutex));
/** 永远不要忘记销毁你创建的互斥量 **/
Mutex::destroy($mutex);
?>

以上例程会输出：

bool(true)
bool(true)


Cond 类

(PECL pthreads < 3.0.0)

简介

Warning

pthreads v3 中已经将 Cond 类移除。

Cond 类中的静态方法可以用来直接访问 Posix 的条件变量。

类摘要

Cond {
/* 方法 */
final public static broadcast ( int $condition ) : bool
final public static create ( ) : int
final public static destroy ( int $condition ) : bool
final public static signal ( int $condition ) : bool
final public static wait ( int $condition , int $mutex , int $timeout = ? ) : bool
}

Table of Contents

  • Cond::broadcast — 广播条件变量
  • Cond::create — 创建一个条件变量
  • Cond::destroy — 销毁条件变量
  • Cond::signal — 发送唤醒信号
  • Cond::wait — 等待


广播条件变量

  • ? Cond
  • Cond::create ?
  • PHP Manual
  • Cond
  • 广播条件变量

Cond::broadcast

(PECL pthreads < 3.0.0)

Cond::broadcast — 广播条件变量

Warning

pthreads v3 中已经将 Cond 类移除。

说明

final public static Cond::broadcast ( int $condition ) : bool

向所有由于调用 Cond::wait() 函数而进入条件阻塞状态的线程发送广播。

参数

condition

通过调用函数 Cond::create() 获得的条件变量句柄。

返回值

布尔值，表示操作是否成功。

范例

Example #1 广播条件变量

<?php
/** 不可以使用 new 关键字，因为 Cond 不是 PHP 对象 **/
$cond = Cond::create();
/** 调用者必须给关联的互斥量加锁，然后才可以进行广播（调用 broadcast 方法） **/
var_dump(Cond::broadcast($cond));
/** 永远不要忘记销毁你创建的条件变量 **/
Cond::destroy($cond);
?>

以上例程会输出：

bool(true)


创建一个条件变量

  • ? Cond::broadcast
  • Cond::destroy ?
  • PHP Manual
  • Cond
  • 创建一个条件变量

Cond::create

(PECL pthreads < 3.0.0)

Cond::create — 创建一个条件变量

Warning

pthreads v3 中已经将 Cond 类移除。

说明

final public static Cond::create ( ) : int

创建一个条件变量。

参数

此函数没有参数。

返回值

指向条件变量的句柄。

范例

Example #1 条件变量的创建与销毁

<?php
/** 不可以使用 new 关键字，因为 Cond 不是 PHP 对象 **/
$cond = Cond::create();
/** 现在你可以在任意线程上下文中使用此条件变量 **/
var_dump($cond);
/** 永远不要忘记销毁你创建的条件变量 **/
Cond::destroy($cond);
?>

以上例程会输出：

int(4540682)


销毁条件变量

  • ? Cond::create
  • Cond::signal ?
  • PHP Manual
  • Cond
  • 销毁条件变量

Cond::destroy

(PECL pthreads < 3.0.0)

Cond::destroy — 销毁条件变量

Warning

pthreads v3 中已经将 Cond 类移除。

说明

final public static Cond::destroy ( int $condition ) : bool

当不再需要所创建的条件变量时，程序员必须显式的销毁它。 当调用 Cond::destroy() 函数时，必须保证其他线程没有处于等待此条件变量的阻塞状态（通过调用函数 Cond::wait() 进入条件阻塞状态）。

参数

condition

通过调用 Cond::create() 函数获得的条件变量句柄

返回值

布尔值，表示操作是否成功。

范例

Example #1 条件变量的创建与销毁

<?php
/** 不可以使用 new 关键字，因为 Cond 不是 PHP 对象 **/
$cond = Cond::create();
/** 现在你可以在任意线程上下文中使用此条件变量 **/
var_dump($cond);
/** 永远不要忘记销毁你创建的条件变量 **/
Cond::destroy($cond);
?>

以上例程会输出：

int(4540682)


发送唤醒信号

  • ? Cond::destroy
  • Cond::wait ?
  • PHP Manual
  • Cond
  • 发送唤醒信号

Cond::signal

(PECL pthreads < 3.0.0)

Cond::signal — 发送唤醒信号

Warning

pthreads v3 中已经将 Cond 类移除。

说明

final public static Cond::signal ( int $condition ) : bool

参数

condition

通过调用 Cond::create() 函数获得的条件变量句柄

返回值

布尔值，表示操作是否成功。

范例

Example #1 发送唤醒信号

<?php
/** 不可以使用 new 关键字，因为 Cond 不是 PHP 对象 **/
$cond = Cond::create();
/** 调用者必须持有关联的互斥量锁，然后才可以进行唤醒信号发送（调用 signal 方法）  **/
var_dump(Cond::signal($cond));
/** 永远不要忘记销毁你创建的条件变量 **/
Cond::destroy($cond);
?>

以上例程会输出：

bool(true)


等待

  • ? Cond::signal
  • Volatile ?
  • PHP Manual
  • Cond
  • 等待

Cond::wait

(PECL pthreads < 3.0.0)

Cond::wait — 等待

Warning

pthreads v3 中已经将 Cond 类移除。

说明

final public static Cond::wait ( int $condition , int $mutex , int $timeout = ? ) : bool

进入条件变量等待状态。通过 timeout 参数可以设置等待超时时间。

参数

condition

通过调用 Cond::create() 函数获得的条件变量句柄

mutex

通过调用 Mutex::create() 函数获得的互斥量，并且已经被调用者线程加锁。

timeout

等待超时，以毫秒为单位。

返回值

布尔值，表示操作是否成功。

范例

Example #1 等待条件变量

<?php
/** 请注意，本示例会导致进程挂起 **/
$mutex = Mutex::create(true);
/** 不可以使用 new 关键字，因为 Cond 不是 PHP 对象 **/
$cond = Cond::create();
/** The caller must lock the associated Mutex before a call to broadcast **/
var_dump(Cond::wait($cond, $mutex));
/** 永远不要忘记销毁你创建的条件变量及互斥量 **/
Cond::destroy($cond);
Mutex::unlock($mutex);
Mutex::destroy($mutex);
?>

以上例程会输出：

int(49685473)


The Volatile class

(PECL pthreads >= 3.0.0)

简介

The Volatile class is new to pthreads v3. Its introduction is a consequence of the new immutability semantics of Threaded members of Threaded classes. The Volatile class enables for mutability of its Threaded members, and is also used to store PHP arrays in Threaded contexts.

类摘要

Volatile extends Threaded implements Collectable , Traversable {
/* 继承的方法 */
public Threaded::chunk ( int $size , bool $preserve ) : array
public Threaded::count ( ) : int
public Threaded::extend ( string $class ) : bool
public Threaded::from ( Closure $run , Closure $construct = ? , array $args = ? ) : Threaded
public Threaded::getTerminationInfo ( ) : array
public Threaded::isRunning ( ) : bool
public Threaded::isTerminated ( ) : bool
public Threaded::isWaiting ( ) : bool
public Threaded::lock ( ) : bool
public Threaded::merge ( mixed $from , bool $overwrite = ? ) : bool
public Threaded::notify ( ) : bool
public Threaded::notifyOne ( ) : bool
public Threaded::pop ( ) : bool
public Threaded::run ( ) : void
public Threaded::shift ( ) : boolean
public Threaded::synchronized ( Closure $block , mixed $... = ? ) : mixed
public Threaded::unlock ( ) : bool
public Threaded::wait ( int $timeout = ? ) : bool
}

范例

Example #1 New immutability semantics of Threaded

<?php

class Task extends Threaded
{
    public function __construct()
    {
        $this->data = new Threaded();

        // attempt to overwrite a Threaded property of a Threaded class (invalid)
        $this->data = new StdClass();
    }
}

var_dump((new Task())->data);

以上例程的输出类似于：

RuntimeException: Threaded members previously set to Threaded objects are immutable, cannot overwrite data in %s:%d

Example #2 Volatile use-case

<?php

class Task extends Volatile
{
    public function __construct()
    {
        $this->data = new Threaded();

        // attempt to overwrite a Threaded property of a Volatile class (valid)
        $this->data = new StdClass();
    }
}

var_dump((new Task())->data);

以上例程的输出类似于：

object(stdClass)#3 (0) {
}


pht

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • pht\Thread — The Thread class
    • pht\Thread::addClassTask — Class threading
    • pht\Thread::addFileTask — File threading
    • pht\Thread::addFunctionTask — Function threading
    • pht\Thread::join — Joins a thread
    • pht\Thread::start — Starts the new thread
    • pht\Thread::taskCount — Gets a thread's task count
  • pht\Runnable — The Runnable interface
    • pht\Runnable::run — The entry point of a threaded class
  • pht\HashTable — The HashTable class
    • pht\HashTable::lock — Acquires the hash table's mutex lock
    • pht\HashTable::size — Gets the size of the hash table
    • pht\HashTable::unlock — Releases the hash table's mutex lock
  • pht\Vector — The Vector class
    • pht\Vector::__construct — Vector creation
    • pht\Vector::deleteAt — Deletes a value in the vector
    • pht\Vector::insertAt — Inserts a value into the vector
    • pht\Vector::lock — Acquires the vector's mutex lock
    • pht\Vector::pop — Pops a value to the vector
    • pht\Vector::push — Pushes a value to the vector
    • pht\Vector::resize — Resizes a vector
    • pht\Vector::shift — Shifts a value from the vector
    • pht\Vector::size — Gets the size of the vector
    • pht\Vector::unlock — Releases the vector's mutex lock
    • pht\Vector::unshift — Unshifts a value to the vector front
    • pht\Vector::updateAt — Updates a value in the vector
  • pht\Queue — The Queue class
    • pht\Queue::front — Returns the first value from a queue
    • pht\Queue::lock — Acquires the queue's mutex lock
    • pht\Queue::pop — Pops a value off of the front of a queue
    • pht\Queue::push — Pushes a value to the end of a queue
    • pht\Queue::size — Gets the size of the queue
    • pht\Queue::unlock — Releases the queue's mutex lock
  • pht\AtomicInteger — The AtomicInteger class
    • pht\AtomicInteger::__construct — AtomicInteger creation
    • pht\AtomicInteger::dec — Decrements the atomic integer's value by one
    • pht\AtomicInteger::get — Gets the atomic integer's value
    • pht\AtomicInteger::inc — Increments the atomic integer's value by one
    • pht\AtomicInteger::lock — Acquires the atomic integer's mutex lock
    • pht\AtomicInteger::set — Sets the atomic integer's value
    • pht\AtomicInteger::unlock — Releases the atomic integer's mutex lock
  • pht\Threaded — The Threaded interface
    • pht\Threaded::lock — Acquires the mutex lock
    • pht\Threaded::unlock — Releases the mutex lock


简介

pht is a new threading extension for PHP. It enables for classes, functions, and even entire files to be threaded. Currently, pht can only be used with PHP 7.2. This is due to ZTS mode being unsafe in PHP 7.0 and 7.1. Support for PHP >7.2 is coming soon.

Warning

The pht extension should not be used in a web server environment. Threading should be restricted to CLI-based applications only.

The approach to threading that pht takes is to abstract away the thread itself behind a dedicated object (pht\Thread). Tasks are then added to the thread's internal task queue, where they are processed when the thread is started (via pht\Thread::start()).

All thread tasks will execute in isolation inside of the newly spawned thread. For class tasks, this means the spawned objects cannot be passed around between threads. By keeping the threading contexts completely separate from one-another, there becomes no need to serialise the properties of threaded objects (which is a necessary evil if such objects have to operate in multiple threads).

The isolation of threading contexts makes the passing around of data between them somewhat problematic. To solve this problem, threadable data structures (pht\HashTable, pht\Vector, and pht\Queue) have been implemented to allow for a two-way communication style between threads, where they expose mutex locks to control their integrity. These data structures can be safely passed around between threads, and manipulated by multiple threads using the mutex locks that have been packed in with them. They are reference-counted across threads, and so they do not need to be explicitly destroyed. This approach to threading means that only the given built-in data structures need to be safely passed around between threads.

Atomic values are also supported by pht. Currently, only an pht\AtomicInteger class exists. Like the threaded data structures, it too can safely be passed around between threads.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • pht
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

pht requires a ZTS (Zend Thread Safety) version of PHP. Currently, only PHP 7.2 is supported. Support for PHP 7.3 (which will be released at the end of 2018) will be coming soon. PHP 7.0 and 7.1 are unsafe to support, due to race conditions in ZTS mode.

pht should be compatible for any OS with the pthread library (or pthread-win32 library, which is for Windows).


安装

pht releases are hosted (along with its source code) on the » pht GitHub repository. Unix developers will need to build from source (» instructions here). Windows developers can download the appropriate .dll file from the » repository's releases page. They will need to ensure that the provided pthreadVC2.dll file (which is distributed alongside the extension's .dll file) is made available in their PATH environment variable.


  • ? 安装
  • pht\Thread ?
  • PHP Manual
  • 安装／配置
  • 运行时配置

运行时配置

此扩展没有在 php.ini 中定义配置指令。


The Thread class

(PECL pht >= 0.0.1)

简介

The pht\Thread class abstracts away a native thread. It has an internal task queue, where the methods pht\Thread::addClassTask(), pht\Thread::addFunctionTask(), and pht\Thread::addFileTask() push new tasks onto this queue. Invoking the pht\Thread::start() method will cause the new thread to be spawned, where it will then begin working through the task queue. A thread may be reused for any number of tasks.

类摘要

pht\Thread {
/* 方法 */
public addClassTask ( string $className , mixed ...$ctorArgs ) : void
public addFileTask ( string $fileName , mixed ...$globals ) : void
public addFunctionTask ( callable $func , mixed ...$funcArgs ) : void
public join ( ) : void
public start ( ) : void
public taskCount ( ) : int
}

Table of Contents

  • pht\Thread::addClassTask — Class threading
  • pht\Thread::addFileTask — File threading
  • pht\Thread::addFunctionTask — Function threading
  • pht\Thread::join — Joins a thread
  • pht\Thread::start — Starts the new thread
  • pht\Thread::taskCount — Gets a thread's task count


Class threading

  • ? pht\Thread
  • pht\Thread::addFileTask ?
  • PHP Manual
  • pht\Thread
  • Class threading

pht\Thread::addClassTask

(PECL pht >= 0.0.1)

pht\Thread::addClassTask — Class threading

说明

public pht\Thread::addClassTask ( string $className , mixed ...$ctorArgs ) : void

Adds a new class task to a pht\Threads internal task queue.

参数

className

The name of the class to be threaded. This class must implement the pht\Runnable interface.

ctorArgs

An optional list of arguments for the threaded class' constructor. These arguments will be serialised (since they are being passed to another thread).

返回值

No return value.

范例

Example #1 Adding a new class task to a thread

<?php

use pht\{Thread, Runnable};

class Task implements Runnable
{
    private $one;

    public function __construct(int $one)
    {
        $this->one = $one;
    }

    public function run()
    {
        var_dump($this->one);
    }
}

$thread = new Thread();

$thread->addClassTask(Task::class, 1);

$thread->start();
$thread->join();

以上例程会输出：

int(1)


File threading

  • ? pht\Thread::addClassTask
  • pht\Thread::addFunctionTask ?
  • PHP Manual
  • pht\Thread
  • File threading

pht\Thread::addFileTask

(PECL pht >= 0.0.1)

pht\Thread::addFileTask — File threading

说明

public pht\Thread::addFileTask ( string $fileName , mixed ...$globals ) : void

Adds a new file task to a pht\Threads internal task queue.

参数

func

The name of the file to be threaded.

globals

An optional list of arguments for the file. These arguments will be placed into a $_THREAD superglobal, which will be made available inside of the threaded file. All arguments will be serialised (since they are being passed to another thread).

返回值

No return value.

范例

Example #1 Adding a new file task to a thread

<?php

use pht\Thread;

$thread = new Thread();

$thread->addFileTask('file.php', 1, 2, 3);

$thread->start();
$thread->join();

file.php:

<?php

[$one, $two, $three] = $_THREAD;

var_dump($one, $two, $three);

以上例程会输出：

int(1)
int(2)
int(3)


Function threading

  • ? pht\Thread::addFileTask
  • pht\Thread::join ?
  • PHP Manual
  • pht\Thread
  • Function threading

pht\Thread::addFunctionTask

(PECL pht >= 0.0.1)

pht\Thread::addFunctionTask — Function threading

说明

public pht\Thread::addFunctionTask ( callable $func , mixed ...$funcArgs ) : void

Adds a new function task to a pht\Threads internal task queue.

参数

func

The function to be threaded. If it is bound to an instance, then $this will become null.

funcArgs

An optional list of arguments for the function. These arguments will be serialised (since they are being passed to another thread).

返回值

No return value.

范例

Example #1 Adding a new function task to a thread

<?php

use pht\Thread;

class Test
{
    public static function run(){var_dump(5);}
    public static function run2(){var_dump(6);}
}

function aFunc(){var_dump(3);}

$thread = new Thread();

$thread->addFunctionTask(static function($one) {var_dump($one);}, 1);
$thread->addFunctionTask(function() {var_dump(2);});
$thread->addFunctionTask('aFunc');
$thread->addFunctionTask('array_map', function ($n) {var_dump($n);}, [4]);
$thread->addFunctionTask(['Test', 'run']);
$thread->addFunctionTask([new Test, 'run2']);

$thread->start();
$thread->join();

以上例程会输出：

int(1)
int(2)
int(3)
int(4)
int(5)
int(6)


Joins a thread

  • ? pht\Thread::addFunctionTask
  • pht\Thread::start ?
  • PHP Manual
  • pht\Thread
  • Joins a thread

pht\Thread::join

(PECL pht >= 0.0.1)

pht\Thread::join — Joins a thread

说明

public pht\Thread::join ( ) : void

This method will join the spawned thread (though it will first wait for that thread's internal task queue to finish). As a matter of good practice, threads should always be joined. Not joining a thread may lead to undefined behaviour.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Joining a thread

<?php

use pht\Thread;

$thread = new Thread();

$thread->start();
$thread->join();


Starts the new thread

  • ? pht\Thread::join
  • pht\Thread::taskCount ?
  • PHP Manual
  • pht\Thread
  • Starts the new thread

pht\Thread::start

(PECL pht >= 0.0.1)

pht\Thread::start — Starts the new thread

说明

public pht\Thread::start ( ) : void

This will cause a new thread to be spawned for the associated pht\Thread object, where its internal task queue will begin to be processed.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Starting a new thread

<?php

use pht\Thread;

$thread = new Thread();

$thread->start();
$thread->join();


Gets a thread's task count

  • ? pht\Thread::start
  • pht\Runnable ?
  • PHP Manual
  • pht\Thread
  • Gets a thread's task count

pht\Thread::taskCount

(PECL pht >= 0.0.1)

pht\Thread::taskCount — Gets a thread's task count

说明

public pht\Thread::taskCount ( ) : int

Retrieves the current task count of a pht\Thread.

参数

此函数没有参数。

返回值

The number of tasks remaining to be processed.

范例

Example #1 Getting the task count of a thread

<?php

use pht\Thread;

$thread = new Thread();

$thread->addFunctionTask(function (){});
$thread->addFunctionTask(function (){});
$thread->addFunctionTask(function (){});

var_dump($thread->taskCount());

以上例程会输出：

int(3)


The Runnable interface

(PECL pht >= 0.0.1)

简介

The pht\Runnable interface enforces the implementation of a run() method on classes that should be threaded. This method acts as the entry point of the threaded class.

接口摘要

pht\Runnable {
/* 方法 */
public run ( ) : void
}

Table of Contents

  • pht\Runnable::run — The entry point of a threaded class


The entry point of a threaded class

  • ? pht\Runnable
  • pht\HashTable ?
  • PHP Manual
  • pht\Runnable
  • The entry point of a threaded class

pht\Runnable::run

(PECL pht >= 0.0.1)

pht\Runnable::run — The entry point of a threaded class

说明

public pht\Runnable::run ( ) : void

This method acts as the entry point of execution for a threaded class. It must be defined by all classes that will be threaded.

参数

此函数没有参数。

返回值

No return value.


The HashTable class

(PECL pht >= 0.0.1)

简介

The pht\HashTable class is one of the Inter-Thread Communication (ITC) data structures exposed by pht. It can be safely passed around between threads, and manipulated by multiple threads using the mutex locks that have been packed in with the data structure. It is reference-counted across threads, and so it does not need to be explicitly destroyed.

The pht\HashTable class enables for array access upon its objects (along with the isset() and unset() functions). The ArrayAccess interface is not explicitly implemented, however, because it is only needed for such abilities by userland classes.

类摘要

pht\HashTable implements pht\Threaded {
/* 方法 */
public lock ( ) : void
public size ( ) : int
public unlock ( ) : void
}

Table of Contents

  • pht\HashTable::lock — Acquires the hash table's mutex lock
  • pht\HashTable::size — Gets the size of the hash table
  • pht\HashTable::unlock — Releases the hash table's mutex lock


Acquires the hash table's mutex lock

  • ? pht\HashTable
  • pht\HashTable::size ?
  • PHP Manual
  • pht\HashTable
  • Acquires the hash table's mutex lock

pht\HashTable::lock

(PECL pht >= 0.0.1)

pht\HashTable::lock — Acquires the hash table's mutex lock

说明

public pht\HashTable::lock ( ) : void

This method will acquire the mutex lock associated with the hash table. The mutex lock should always be acquired when manipulating the hash table if it is being used by multiple threads.

The mutex locks of the Inter-Thread Communication (ITC) data structures are not reentrant. Attempting to reacquire an already-acquired mutex lock by the same thread will therefore cause a deadlock.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Locking a hash table's mutex lock

<?php

use pht\{Thread, HashTable};

$thread = new Thread();
$hashTable = new HashTable();

$thread->addFunctionTask(function ($hashTable) {
    $hashTable->lock();
    $hashTable['a'] = 1;
    $hashTable->unlock();
}, $hashTable);

$thread->start();

// $hashTable is currently being used by multiple threads
$hashTable->lock();
$hashTable['b'] = 2;
$hashTable->unlock();

$thread->join();


Gets the size of the hash table

  • ? pht\HashTable::lock
  • pht\HashTable::unlock ?
  • PHP Manual
  • pht\HashTable
  • Gets the size of the hash table

pht\HashTable::size

(PECL pht >= 0.0.1)

pht\HashTable::size — Gets the size of the hash table

说明

public pht\HashTable::size ( ) : int

Returns the current size of the hash table. This operation requires a pht\HashTable's mutex lock to be held if it is being used by multiple threads.

参数

此函数没有参数。

返回值

The size of the hash table.

范例

Example #1 Getting a hash table's size

<?php

use pht\HashTable;

$hashTable = new HashTable();

$hashTable['a'] = 1;
$hashTable['b'] = 2;

var_dump($hashTable->size());

以上例程会输出：

int(2)


Releases the hash table's mutex lock

  • ? pht\HashTable::size
  • pht\Vector ?
  • PHP Manual
  • pht\HashTable
  • Releases the hash table's mutex lock

pht\HashTable::unlock

(PECL pht >= 0.0.1)

pht\HashTable::unlock — Releases the hash table's mutex lock

说明

public pht\HashTable::unlock ( ) : void

This method will release the mutex lock associated with the hash table.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Locking a hash table's mutex lock

<?php

use pht\{Thread, HashTable};

$thread = new Thread();
$hashTable = new HashTable();

$thread->addFunctionTask(function ($hashTable) {
    $hashTable->lock();
    $hashTable['a'] = 1;
    $hashTable->unlock();
}, $hashTable);

$thread->start();

// $hashTable is currently being used by multiple threads
$hashTable->lock();
$hashTable['b'] = 2;
$hashTable->unlock();

$thread->join();


The Vector class

(PECL pht >= 0.0.1)

简介

The pht\Vector class is one of the Inter-Thread Communication (ITC) data structures exposed by pht. It can be safely passed around between threads, and manipulated by multiple threads using the mutex locks that have been packed in with the data structure. It is reference-counted across threads, and so is does not need to be explicitly destroyed.

The pht\Vector class enables for array access upon its objects (along with the isset() and unset() functions). The ArrayAccess interface is not explicitly implemented, however, because it is only needed for such abilities by userland classes.

类摘要

pht\Vector implements pht\Threaded {
/* 方法 */
public __construct ( int $size = 0 , mixed $value = 0 ) : Vector
public deleteAt ( int $offset ) : void
public insertAt ( mixed $value , int $offset ) : void
public lock ( ) : void
public pop ( ) : mixed
public push ( mixed $value ) : void
public resize ( int $size , mixed $value = 0 ) : void
public shift ( ) : mixed
public size ( ) : int
public unlock ( ) : void
public unshift ( mixed $value ) : void
public updateAt ( mixed $value , int $offset ) : void
}

Table of Contents

  • pht\Vector::__construct — Vector creation
  • pht\Vector::deleteAt — Deletes a value in the vector
  • pht\Vector::insertAt — Inserts a value into the vector
  • pht\Vector::lock — Acquires the vector's mutex lock
  • pht\Vector::pop — Pops a value to the vector
  • pht\Vector::push — Pushes a value to the vector
  • pht\Vector::resize — Resizes a vector
  • pht\Vector::shift — Shifts a value from the vector
  • pht\Vector::size — Gets the size of the vector
  • pht\Vector::unlock — Releases the vector's mutex lock
  • pht\Vector::unshift — Unshifts a value to the vector front
  • pht\Vector::updateAt — Updates a value in the vector


Vector creation

  • ? pht\Vector
  • pht\Vector::deleteAt ?
  • PHP Manual
  • pht\Vector
  • Vector creation

pht\Vector::__construct

(PECL pht >= 0.0.1)

pht\Vector::__construct — Vector creation

说明

public pht\Vector::__construct ( int $size = 0 , mixed $value = 0 ) : Vector

Handles the creation of a new vector.

参数

size

The size of the vector that will be created.

value

The value to initialise the empty slots in the vector to.

返回值

No return value.

范例

Example #1 Creating a new vector

<?php

use pht\Vector;

$vector1 = new Vector(1);
$vector2 = new Vector(2, 1);

var_dump($vector1, $vector2);

以上例程会输出：

object(pht\Vector)#1 (1) {
  [0]=>
  int(0)
}
object(pht\Vector)#2 (2) {
  [0]=>
  int(1)
  [1]=>
  int(1)
}


Deletes a value in the vector

  • ? pht\Vector::__construct
  • pht\Vector::insertAt ?
  • PHP Manual
  • pht\Vector
  • Deletes a value in the vector

pht\Vector::deleteAt

(PECL pht >= 0.0.1)

pht\Vector::deleteAt — Deletes a value in the vector

说明

public pht\Vector::deleteAt ( int $offset ) : void

This method deletes a value at the specified offset in the vector (in linear time).

Since the pht\Vector class supports array access, deleting values can also be performed using the array subset notation ([]) in combination with the unset() function.

参数

offset

The offset at which the value will be deleted at. This offset must be within the 0..(N-1) range (inclusive), where N is the size of the vector. Attempting to delete at offsets outside of this range will result in an Error exception.

返回值

No return value.

范例

Example #1 Deleting values in a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector[] = 1;
$vector[] = 2;
$vector[] = 3;
$vector[] = 4;

$vector->deleteAt(1);
unset($vector[1]);

var_dump($vector);

以上例程会输出：

object(pht\Vector)#1 (2) {
  [0]=>
  int(1)
  [1]=>
  int(4)
}


Inserts a value into the vector

  • ? pht\Vector::deleteAt
  • pht\Vector::lock ?
  • PHP Manual
  • pht\Vector
  • Inserts a value into the vector

pht\Vector::insertAt

(PECL pht >= 0.0.1)

pht\Vector::insertAt — Inserts a value into the vector

说明

public pht\Vector::insertAt ( mixed $value , int $offset ) : void

This method inserts a value at the specified offset into the vector (in linear time). The vector will automatically be resized if it is not large enough.

参数

value

The value to be inserted into the vector. This value will be serialised (since it may be passed around between threads).

offset

The offset at which the value will be inserted at. This offset must be within the 0..N range (inclusive), where N is the size of the vector. Inserting at position N is the equivalent of using pht\Vector::push(), and inserting at position 0 is the equivalent of using pht\Vector::unshift(). Attempting to insert at offsets outside of this range will result in an Error exception.

返回值

No return value.

范例

Example #1 Inserting a value into a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector->insertAt(3, 0); // insert 3 at start
$vector->insertAt(1, 0); // insert 1 at start (before 3)
$vector->insertAt(2, 1); // insert 2 in middle (after 1 and before 3)

var_dump($vector);

以上例程会输出：

object(pht\Vector)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Acquires the vector's mutex lock

  • ? pht\Vector::insertAt
  • pht\Vector::pop ?
  • PHP Manual
  • pht\Vector
  • Acquires the vector's mutex lock

pht\Vector::lock

(PECL pht >= 0.0.1)

pht\Vector::lock — Acquires the vector's mutex lock

说明

public pht\Vector::lock ( ) : void

This method will acquire the mutex lock associated with the vector. The mutex lock should always be acquired when manipulating the vector if it is being used by multiple threads.

The mutex locks of the Inter-Thread Communication (ITC) data structures are not reentrant. Attempting to reacquire an already-acquired mutex lock by the same thread will therefore cause a deadlock.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Locking a vector's mutex lock

<?php

use pht\{Thread, Vector};

$thread = new Thread();
$vector = new Vector();

$thread->addFunctionTask(function ($vector) {
    $vector->lock();
    $vector[] = 1;
    $vector->unlock();
}, $vector);

$thread->start();

// $vector is currently being used by multiple threads
$vector->lock();
$vector[] = 2;
$vector->unlock();

$thread->join();


Pops a value to the vector

  • ? pht\Vector::lock
  • pht\Vector::push ?
  • PHP Manual
  • pht\Vector
  • Pops a value to the vector

pht\Vector::pop

(PECL pht >= 0.0.1)

pht\Vector::pop — Pops a value to the vector

说明

public pht\Vector::pop ( ) : mixed

This method pops a value from the end of a vector (in constant time). Popping a value from an empty vector will result in an Error exception.

参数

此函数没有参数。

返回值

The value from the end of the vector.

范例

Example #1 Popping a value from a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector->push(1);
$vector[] = 2;

var_dump($vector->pop());

以上例程会输出：

int(2)


Pushes a value to the vector

  • ? pht\Vector::pop
  • pht\Vector::resize ?
  • PHP Manual
  • pht\Vector
  • Pushes a value to the vector

pht\Vector::push

(PECL pht >= 0.0.1)

pht\Vector::push — Pushes a value to the vector

说明

public pht\Vector::push ( mixed $value ) : void

This method pushes a value onto the end of a vector (in constant time). The vector will automatically be resized if it is not large enough.

Since the pht\Vector class supports array access, new values can also be pushed onto the vector using the empty subset notation ([]).

参数

value

The value to be pushed onto the end of the vector. This value will be serialised (since it may be passed around between threads).

返回值

No return value.

范例

Example #1 Pushing values to a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector->push(1);
$vector[] = 2;

var_dump($vector);

以上例程会输出：

object(pht\Vector)#1 (2) {
  [0]=>
  int(1)
  [1]=>
  int(2)
}


Resizes a vector

  • ? pht\Vector::push
  • pht\Vector::shift ?
  • PHP Manual
  • pht\Vector
  • Resizes a vector

pht\Vector::resize

(PECL pht >= 0.0.1)

pht\Vector::resize — Resizes a vector

说明

public pht\Vector::resize ( int $size , mixed $value = 0 ) : void

Resizes the vector. If it is enlarged, then the value parameter will be used to fill in the new slots. If it is made smaller, then the end values will be truncated.

参数

size

The new size of the vector.

value

The value to initialise the empty vector slots to (only used if the vector is enlarged).

返回值

No return value.

范例

Example #1 Resizing a vector

<?php

use pht\Vector;

$vector = new Vector(1);
var_dump($vector);
$vector->resize(2, 1);
var_dump($vector);
$vector->resize(1, 2); // unused second arg
var_dump($vector);

以上例程会输出：

object(pht\Vector)#1 (1) {
  [0]=>
  int(0)
}
object(pht\Vector)#1 (2) {
  [0]=>
  int(0)
  [1]=>
  int(1)
}
object(pht\Vector)#1 (1) {
  [0]=>
  int(0)
}


Shifts a value from the vector

  • ? pht\Vector::resize
  • pht\Vector::size ?
  • PHP Manual
  • pht\Vector
  • Shifts a value from the vector

pht\Vector::shift

(PECL pht >= 0.0.1)

pht\Vector::shift — Shifts a value from the vector

说明

public pht\Vector::shift ( ) : mixed

This method shifts a value from the front of a vector (in linear time). Shifting a value from an empty vector will result in an Error exception.

参数

此函数没有参数。

返回值

The value from the front of the vector.

范例

Example #1 Shifting a value from a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector->push(1);
$vector[] = 2;

var_dump($vector->shift());

以上例程会输出：

int(1)


Gets the size of the vector

  • ? pht\Vector::shift
  • pht\Vector::unlock ?
  • PHP Manual
  • pht\Vector
  • Gets the size of the vector

pht\Vector::size

(PECL pht >= 0.0.1)

pht\Vector::size — Gets the size of the vector

说明

public pht\Vector::size ( ) : int

Returns the current size of the vector. This operation requires a pht\Vector's mutex lock to be held if it is being used by multiple threads.

参数

此函数没有参数。

返回值

The size of the vector.

范例

Example #1 Getting a vector's size

<?php

use pht\Vector;

$vector = new Vector();

$vector[] = 1;
$vector[] = 2;
$vector[] = 3;

var_dump($vector->size());

以上例程会输出：

int(3)


Releases the vector's mutex lock

  • ? pht\Vector::size
  • pht\Vector::unshift ?
  • PHP Manual
  • pht\Vector
  • Releases the vector's mutex lock

pht\Vector::unlock

(PECL pht >= 0.0.1)

pht\Vector::unlock — Releases the vector's mutex lock

说明

public pht\Vector::unlock ( ) : void

This method will release the mutex lock associated with the vector.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Locking a vector's mutex lock

<?php

use pht\{Thread, Vector};

$thread = new Thread();
$vector = new Vector();

$thread->addFunctionTask(function ($vector) {
    $vector->lock();
    $vector[] = 1;
    $vector->unlock();
}, $vector);

$thread->start();

// $vector is currently being used by multiple threads
$vector->lock();
$vector[] = 2;
$vector->unlock();

$thread->join();


Unshifts a value to the vector front

  • ? pht\Vector::unlock
  • pht\Vector::updateAt ?
  • PHP Manual
  • pht\Vector
  • Unshifts a value to the vector front

pht\Vector::unshift

(PECL pht >= 0.0.1)

pht\Vector::unshift — Unshifts a value to the vector front

说明

public pht\Vector::unshift ( mixed $value ) : void

This method unshifts a value to the front of a vector (in linear time). The vector will automatically be resized if it is not large enough.

参数

value

The value to be pushed onto the beginning of the vector. This value will be serialised (since it may be passed around between threads).

返回值

No return value.

范例

Example #1 Unshifting a value to the front of a vector

<?php

use pht\Vector;

$vector = new Vector();

for ($i = 0; $i < 3; ++$i) {
    $vector->unshift($i); // causes a quadratic runtime, beware
}

var_dump($vector);

以上例程会输出：

object(pht\Vector)#1 (3) {
  [0]=>
  int(2)
  [1]=>
  int(1)
  [2]=>
  int(0)
}


Updates a value in the vector

  • ? pht\Vector::unshift
  • pht\Queue ?
  • PHP Manual
  • pht\Vector
  • Updates a value in the vector

pht\Vector::updateAt

(PECL pht >= 0.0.1)

pht\Vector::updateAt — Updates a value in the vector

说明

public pht\Vector::updateAt ( mixed $value , int $offset ) : void

This method updates a value at the specified offset in the vector (in linear time). The vector will automatically be resized if it is not large enough.

Since the pht\Vector class supports array access, updating values can also be performed using the array subset notation ([]).

参数

value

The value to be inserted into the vector. This value will be serialised (since it may be passed around between threads).

offset

The offset at which the value will be updated at. This offset must be within the 0..(N-1) range (inclusive), where N is the size of the vector. Attempting to update at offsets outside of this range will result in an Error exception.

返回值

No return value.

范例

Example #1 Updating a value in a vector

<?php

use pht\Vector;

$vector = new Vector();

$vector[] = 1;
$vector[] = 2;

$vector->updateAt(3, 0);
$vector[1] = 4;

var_dump($vector);

以上例程会输出：

object(pht\Vector)#1 (2) {
  [0]=>
  int(3)
  [1]=>
  int(4)
}


The Queue class

(PECL pht >= 0.0.1)

简介

The pht\Queue class is one of the Inter-Thread Communication (ITC) data structures exposed by pht. It can be safely passed around between threads, and manipulated by multiple threads using the mutex locks that have been packed in with the data structure. It is reference-counted across threads, and so it does not need to be explicitly destroyed.

类摘要

pht\Queue implements pht\Threaded {
/* 方法 */
public front ( ) : mixed
public lock ( ) : void
public pop ( ) : mixed
public push ( mixed $value ) : void
public size ( ) : int
public unlock ( ) : void
}

Table of Contents

  • pht\Queue::front — Returns the first value from a queue
  • pht\Queue::lock — Acquires the queue's mutex lock
  • pht\Queue::pop — Pops a value off of the front of a queue
  • pht\Queue::push — Pushes a value to the end of a queue
  • pht\Queue::size — Gets the size of the queue
  • pht\Queue::unlock — Releases the queue's mutex lock


Returns the first value from a queue

  • ? pht\Queue
  • pht\Queue::lock ?
  • PHP Manual
  • pht\Queue
  • Returns the first value from a queue

pht\Queue::front

(PECL pht >= 0.0.1)

pht\Queue::front — Returns the first value from a queue

说明

public pht\Queue::front ( ) : mixed

This method will remove a value from the front of the queue (in constant time). Attempting to return the front value from an empty queue will result in an Error exception.

Caution

Due to the fact that all values in a pht\Queue are serialised, extracting a value from the queue will require it to be deserialised. This can incur a noticeable performance hit if the inspection of the queue's front value is performed within a loop.

参数

此函数没有参数。

返回值

The value on the front of the queue.

范例

Example #1 Retrieving the front value of a queue

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(1);

var_dump($queue->front());

以上例程会输出：

int(1)

Example #2 Retrieving the front value in a loop (bad example - don't do this)

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(array_fill(0, 2000, 0));

for ($i = 0; $i < count($queue->front()); ++$i); // quadratic runtime

Example #3 Retrieving the front value in a loop (good example)

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(array_fill(0, 2000, 0));

$front = $queue->front(); // create a separate variable
for ($i = 0; $i < count($front); ++$i); // linear runtime


Acquires the queue's mutex lock

  • ? pht\Queue::front
  • pht\Queue::pop ?
  • PHP Manual
  • pht\Queue
  • Acquires the queue's mutex lock

pht\Queue::lock

(PECL pht >= 0.0.1)

pht\Queue::lock — Acquires the queue's mutex lock

说明

public pht\Queue::lock ( ) : void

This method will acquire the mutex lock associated with the queue. The mutex lock should always be acquired when manipulating the queue if it is being used by multiple threads.

The mutex locks of the Inter-Thread Communication (ITC) data structures are not reentrant. Attempting to reacquire an already-acquired mutex lock by the same thread will therefore cause a deadlock.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Locking a queue's mutex lock

<?php

use pht\{Thread, Queue};

$thread = new Thread();
$queue = new Queue();

$thread->addFunctionTask(function ($queue) {
    $queue->lock();
    $queue->push(1);
    $queue->unlock();
}, $queue);

$thread->start();

// $queue is currently being used by multiple threads
$queue->lock();
$queue->push(1);
$queue->unlock();

$thread->join();

// $queue is only being used in this thread now, so no need to lock it
while ($queue->size()) {
    var_dump($queue->pop());
}

以上例程会输出：

int(1)
int(1)


Pops a value off of the front of a queue

  • ? pht\Queue::lock
  • pht\Queue::push ?
  • PHP Manual
  • pht\Queue
  • Pops a value off of the front of a queue

pht\Queue::pop

(PECL pht >= 0.0.1)

pht\Queue::pop — Pops a value off of the front of a queue

说明

public pht\Queue::pop ( ) : mixed

This method will remove a value from the front of the queue (in constant time). Attempting to pop a value from an empty queue will result in an Error exception.

参数

此函数没有参数。

返回值

The value removed from the queue.

范例

Example #1 Popping a value from a queue

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(1);

var_dump($queue->pop());

以上例程会输出：

int(1)


Pushes a value to the end of a queue

  • ? pht\Queue::pop
  • pht\Queue::size ?
  • PHP Manual
  • pht\Queue
  • Pushes a value to the end of a queue

pht\Queue::push

(PECL pht >= 0.0.1)

pht\Queue::push — Pushes a value to the end of a queue

说明

public pht\Queue::push ( mixed $value ) : void

This method will add a value onto the queue.

参数

value

The value to be added to a pht\Queue. This value will be serialised (since it may be passed around between threads).

返回值

No return value.

范例

Example #1 Pushing a value to a queue

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(1);

var_dump($queue);

以上例程会输出：

object(pht\Queue)#1 (1) {
  [0]=>
  int(1)
}


Gets the size of the queue

  • ? pht\Queue::push
  • pht\Queue::unlock ?
  • PHP Manual
  • pht\Queue
  • Gets the size of the queue

pht\Queue::size

(PECL pht >= 0.0.1)

pht\Queue::size — Gets the size of the queue

说明

public pht\Queue::size ( ) : int

Returns the current size of the queue. This operation requires a pht\Queue's mutex lock to be held if it is being used by multiple threads.

参数

此函数没有参数。

返回值

The size of the queue.

范例

Example #1 Getting a queue's size

<?php

use pht\Queue;

$queue = new Queue();

$queue->push(1);
$queue->push(1);

var_dump($queue->size());

以上例程会输出：

int(2)


Releases the queue's mutex lock

  • ? pht\Queue::size
  • pht\AtomicInteger ?
  • PHP Manual
  • pht\Queue
  • Releases the queue's mutex lock

pht\Queue::unlock

(PECL pht >= 0.0.1)

pht\Queue::unlock — Releases the queue's mutex lock

说明

public pht\Queue::unlock ( ) : void

This method will release the mutex lock associated with the queue.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Locking a queue's mutex lock

<?php

use pht\{Thread, Queue};

$thread = new Thread();
$queue = new Queue();

$thread->addFunctionTask(function ($queue) {
    $queue->lock();
    $queue->push(1);
    $queue->unlock();
}, $queue);

$thread->start();

// $queue is currently being used by multiple threads
$queue->lock();
$queue->push(1);
$queue->unlock();

$thread->join();

// $queue is only being used in this thread now, so no need to lock it
while ($queue->size()) {
    var_dump($queue->pop());
}

以上例程会输出：

int(1)
int(1)


The AtomicInteger class

(PECL pht >= 0.0.1)

简介

The pht\AtomicInteger class is currently the only supported atomic value. It allows for an integer to be safely passed around between, and manipulated, by multiple threads. The methods exposed by this class do not need mutex locking, since they will acquire the internal mutex lock implicitly. pht\AtomicInteger::lock() and pht\AtomicInteger::unlock() are still exposed, however, for when multiple operations involving the same pht\AtomicInteger object need to be grouped together.

The mutex locks of the atomic values are reentrant safe.

类摘要

pht\AtomicInteger implements pht\Threaded {
/* 方法 */
public __construct ( int $value = 0 ) : AtomicInteger
public dec ( ) : void
public get ( ) : int
public inc ( ) : void
public lock ( ) : void
public set ( int $value ) : void
public unlock ( ) : void
}

Table of Contents

  • pht\AtomicInteger::__construct — AtomicInteger creation
  • pht\AtomicInteger::dec — Decrements the atomic integer's value by one
  • pht\AtomicInteger::get — Gets the atomic integer's value
  • pht\AtomicInteger::inc — Increments the atomic integer's value by one
  • pht\AtomicInteger::lock — Acquires the atomic integer's mutex lock
  • pht\AtomicInteger::set — Sets the atomic integer's value
  • pht\AtomicInteger::unlock — Releases the atomic integer's mutex lock


AtomicInteger creation

  • ? pht\AtomicInteger
  • pht\AtomicInteger::dec ?
  • PHP Manual
  • pht\AtomicInteger
  • AtomicInteger creation

pht\AtomicInteger::__construct

(PECL pht >= 0.0.1)

pht\AtomicInteger::__construct — AtomicInteger creation

说明

public pht\AtomicInteger::__construct ( int $value = 0 ) : AtomicInteger

Handles the creation of a new atomic integer.

参数

value

The value to initialise the atomic integer to.

返回值

No return value.

范例

Example #1 Creating a new atomic integer

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger(100);

var_dump($atomicInteger->get());

以上例程会输出：

int(100)


Decrements the atomic integer's value by one

  • ? pht\AtomicInteger::__construct
  • pht\AtomicInteger::get ?
  • PHP Manual
  • pht\AtomicInteger
  • Decrements the atomic integer's value by one

pht\AtomicInteger::dec

(PECL pht >= 0.0.1)

pht\AtomicInteger::dec — Decrements the atomic integer's value by one

说明

public pht\AtomicInteger::dec ( ) : void

This method will decrement the atomic integer's value by one. Internally, the mutex lock of the atomic integer will be acquired, and so there is no need to manually acquire it (unless this operation needs to be grouped with other operations on the same atomic integer - see the example in pht\AtomicInteger::lock() for a demonstration of this).

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Decrementing an atomic integer's value

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger();

$atomicInteger->dec();
$atomicInteger->dec();

var_dump($atomicInteger->get());

以上例程会输出：

int(-2)


Gets the atomic integer's value

  • ? pht\AtomicInteger::dec
  • pht\AtomicInteger::inc ?
  • PHP Manual
  • pht\AtomicInteger
  • Gets the atomic integer's value

pht\AtomicInteger::get

(PECL pht >= 0.0.1)

pht\AtomicInteger::get — Gets the atomic integer's value

说明

public pht\AtomicInteger::get ( ) : int

This method will fetch the current value of the atomic integer. Internally, the mutex lock of the atomic integer will be acquired, and so there is no need to manually acquire it (unless this operation needs to be grouped with other operations on the same atomic integer - see the example in pht\AtomicInteger::lock() for a demonstration of this).

参数

此函数没有参数。

返回值

The current integer value of the atomic integer.

范例

Example #1 Getting an atomic integer's value

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger(2);

var_dump($atomicInteger->get());

以上例程会输出：

int(2)


Increments the atomic integer's value by one

  • ? pht\AtomicInteger::get
  • pht\AtomicInteger::lock ?
  • PHP Manual
  • pht\AtomicInteger
  • Increments the atomic integer's value by one

pht\AtomicInteger::inc

(PECL pht >= 0.0.1)

pht\AtomicInteger::inc — Increments the atomic integer's value by one

说明

public pht\AtomicInteger::inc ( ) : void

This method will increment the atomic integer's value by one. Internally, the mutex lock of the atomic integer will be acquired, and so there is no need to manually acquire it (unless this operation needs to be grouped with other operations on the same atomic integer - see the example in pht\AtomicInteger::lock() for a demonstration of this).

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Incrementing an atomic integer's value

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger();

$atomicInteger->inc();
$atomicInteger->inc();

var_dump($atomicInteger->get());

以上例程会输出：

int(2)


Acquires the atomic integer's mutex lock

  • ? pht\AtomicInteger::inc
  • pht\AtomicInteger::set ?
  • PHP Manual
  • pht\AtomicInteger
  • Acquires the atomic integer's mutex lock

pht\AtomicInteger::lock

(PECL pht >= 0.0.1)

pht\AtomicInteger::lock — Acquires the atomic integer's mutex lock

说明

public pht\AtomicInteger::lock ( ) : void

This method will acquire the mutex lock associated with the atomic integer. The mutex lock only needs to be acquired when needing to group together multiple operations.

The mutex locks of the atomic values are reentrant safe. It is therefore valid for the same thread to reacquire a mutex lock that it has already acquired.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Grouping together an atomic integer's operations (requiring a mutex lock)

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger(2);

// assumes $atomicInteger is being used by multiple threads
$atomicInteger->lock();
$atomicInteger->set($atomicInteger->get() * 2); // double the value
$atomicInteger->unlock();

var_dump($atomicInteger->get());

以上例程会输出：

int(4)


Sets the atomic integer's value

  • ? pht\AtomicInteger::lock
  • pht\AtomicInteger::unlock ?
  • PHP Manual
  • pht\AtomicInteger
  • Sets the atomic integer's value

pht\AtomicInteger::set

(PECL pht >= 0.0.1)

pht\AtomicInteger::set — Sets the atomic integer's value

说明

public pht\AtomicInteger::set ( int $value ) : void

This method will set the value of the atomic integer. Internally, the mutex lock of the atomic integer will be acquired, and so there is no need to manually acquire it (unless this operation needs to be grouped with other operations on the same atomic integer - see the example in pht\AtomicInteger::lock() for a demonstration of this).

参数

value

The value to set the atomic integer to.

返回值

No return value.

范例

Example #1 Setting an atomic integer's value

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger();

$atomicInteger->set(20);

var_dump($atomicInteger->get());

以上例程会输出：

int(20)


Releases the atomic integer's mutex lock

  • ? pht\AtomicInteger::set
  • pht\Threaded ?
  • PHP Manual
  • pht\AtomicInteger
  • Releases the atomic integer's mutex lock

pht\AtomicInteger::unlock

(PECL pht >= 0.0.1)

pht\AtomicInteger::unlock — Releases the atomic integer's mutex lock

说明

public pht\AtomicInteger::unlock ( ) : void

This method will release the mutex lock associated with the atomic integer.

参数

此函数没有参数。

返回值

No return value.

范例

Example #1 Grouping together an atomic integer's operations (requiring a mutex lock)

<?php

use pht\AtomicInteger;

$atomicInteger = new AtomicInteger(2);

// assumes $atomicInteger is being used by multiple threads
$atomicInteger->lock();
$atomicInteger->set($atomicInteger->get() * 2); // double the value
$atomicInteger->unlock();

var_dump($atomicInteger->get());

以上例程会输出：

int(4)


The Threaded interface

(PECL pht >= 0.0.1)

简介

The pht\Threaded interface is an internal interface used by the Inter-Thread Communication (ITC) data structures (pht\HashTable, pht\Queue, and pht\Vector). It allows those data structures to be threaded and ensures that the mutex locking API (pht\Threaded::lock() and pht\Threaded::unlock()) is implemented by each of the ITC data structures. It is not implementable by userland classes (since standalone mutex locks are not exposed).

接口摘要

pht\Threaded {
/* 方法 */
public lock ( ) : void
public unlock ( ) : void
}

Table of Contents

  • pht\Threaded::lock — Acquires the mutex lock
  • pht\Threaded::unlock — Releases the mutex lock


Acquires the mutex lock

  • ? pht\Threaded
  • pht\Threaded::unlock ?
  • PHP Manual
  • pht\Threaded
  • Acquires the mutex lock

pht\Threaded::lock

(PECL pht >= 0.0.1)

pht\Threaded::lock — Acquires the mutex lock

说明

public pht\Threaded::lock ( ) : void

This method will acquire the mutex lock associated with the given class (either a pht\HashTable, pht\Queue, pht\Vector, or pht\AtomicInteger).

参数

此函数没有参数。

返回值

No return value.


Releases the mutex lock

  • ? pht\Threaded::lock
  • Semaphore ?
  • PHP Manual
  • pht\Threaded
  • Releases the mutex lock

pht\Threaded::unlock

(PECL pht >= 0.0.1)

pht\Threaded::unlock — Releases the mutex lock

说明

public pht\Threaded::unlock ( ) : void

This method will unlock the mutex lock associated with the given class (either a pht\HashTable, pht\Queue, pht\Vector, or pht\AtomicInteger).

参数

此函数没有参数。

返回值

No return value.


Semaphore, Shared Memory and IPC

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Semaphore 函数
    • ftok — Convert a pathname and a project identifier to a System V IPC key
    • msg_get_queue — Create or attach to a message queue
    • msg_queue_exists — Check whether a message queue exists
    • msg_receive — Receive a message from a message queue
    • msg_remove_queue — Destroy a message queue
    • msg_send — Send a message to a message queue
    • msg_set_queue — Set information in the message queue data structure
    • msg_stat_queue — Returns information from the message queue data structure
    • sem_acquire — Acquire a semaphore
    • sem_get — Get a semaphore id
    • sem_release — Release a semaphore
    • sem_remove — Remove a semaphore
    • shm_attach — Creates or open a shared memory segment
    • shm_detach — Disconnects from shared memory segment
    • shm_get_var — Returns a variable from shared memory
    • shm_has_var — Check whether a specific entry exists
    • shm_put_var — Inserts or updates a variable in shared memory
    • shm_remove_var — Removes a variable from shared memory
    • shm_remove — Removes shared memory from Unix systems


简介

This module provides wrappers for the System V IPC family of functions. It includes semaphores, shared memory and inter-process messaging (IPC).

Semaphores may be used to provide exclusive access to resources on the current machine, or to limit the number of processes that may simultaneously use a resource.

This module provides also shared memory functions using System V shared memory. Shared memory may be used to provide access to global variables. Different httpd-daemons and even other programs (such as Perl, C, ...) are able to access this data to provide a global data-exchange. Remember, that shared memory is NOT safe against simultaneous access. Use semaphores for synchronization.

Limits of Shared Memory by the Unix OS
SHMMAX | max size of shared memory, normally 131072 bytes
SHMMIN | minimum size of shared memory, normally 1 byte
SHMMNI | max amount of shared memory segments on a system, normally 100
SHMSEG | max amount of shared memory segments per process, normally 6

The messaging functions may be used to send and receive messages to/from other processes. They provide a simple and effective means of exchanging data between processes, without the need for setting up an alternative using Unix domain sockets.

Note: 此扩展在 Windows 平台上不可用。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Semaphore
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

Support for this functions are not enabled by default. To enable System V semaphore support compile PHP with the option --enable-sysvsem. To enable the System V shared memory support compile PHP with the option --enable-sysvshm. To enable the System V messages support compile PHP with the option --enable-sysvmsg.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Semaphore Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
sysvshm.init_mem | 10000 | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

sysvshm.init_mem int

A default size of the shared memory segment.


资源类型

Prior to PHP 8.0.0, this extension defined the resource types sysvmsg queue (System V Message Queue), sysvsem (System V Semaphore) and sysvshm (System V Shared Memory).


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

System V message constants
Constant | Type | Changelog
MSG_IPC_NOWAIT | int |
MSG_EAGAIN | int | As of 5.2.0
MSG_ENOMSG | int | As of 5.2.0
MSG_NOERROR | int |
MSG_EXCEPT | int |


Semaphore 函数

Table of Contents

  • ftok — Convert a pathname and a project identifier to a System V IPC key
  • msg_get_queue — Create or attach to a message queue
  • msg_queue_exists — Check whether a message queue exists
  • msg_receive — Receive a message from a message queue
  • msg_remove_queue — Destroy a message queue
  • msg_send — Send a message to a message queue
  • msg_set_queue — Set information in the message queue data structure
  • msg_stat_queue — Returns information from the message queue data structure
  • sem_acquire — Acquire a semaphore
  • sem_get — Get a semaphore id
  • sem_release — Release a semaphore
  • sem_remove — Remove a semaphore
  • shm_attach — Creates or open a shared memory segment
  • shm_detach — Disconnects from shared memory segment
  • shm_get_var — Returns a variable from shared memory
  • shm_has_var — Check whether a specific entry exists
  • shm_put_var — Inserts or updates a variable in shared memory
  • shm_remove_var — Removes a variable from shared memory
  • shm_remove — Removes shared memory from Unix systems


Convert a pathname and a project identifier to a System V IPC key

  • ? Semaphore 函数
  • msg_get_queue ?
  • PHP Manual
  • Semaphore 函数
  • Convert a pathname and a project identifier to a System V IPC key

ftok

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ftok — Convert a pathname and a project identifier to a System V IPC key

说明

ftok ( string $filename , string $project_id ) : int

The function converts the filename of an existing accessible file and a project identifier into an integer for use with for example shmop_open() and other System V IPC keys.

参数

filename

Path to an accessible file.

project_id

Project identifier. This must be a one character string.

返回值

On success the return value will be the created key value, otherwise -1 is returned.

参见

  • shmop_open() - Create or open shared memory block
  • sem_get() - Get a semaphore id


Create or attach to a message queue

  • ? ftok
  • msg_queue_exists ?
  • PHP Manual
  • Semaphore 函数
  • Create or attach to a message queue

msg_get_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_get_queue — Create or attach to a message queue

说明

msg_get_queue ( int $key , int $permissions = 0666 ) : SysvMessageQueue|false

msg_get_queue() returns an id that can be used to access the System V message queue with the given key. The first call creates the message queue with the optional permissions. A second call to msg_get_queue() for the same key will return a different message queue identifier, but both identifiers access the same underlying message queue.

参数

key

Message queue numeric ID

permissions

Queue permissions. Default to 0666. If the message queue already exists, the permissions will be ignored.

返回值

Returns SysvMessageQueue instance that can be used to access the System V message queue, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | On success, this function returns a SysvMessageQueue instance now; previously, a resource was returned.

参见

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_send() - Send a message to a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_set_queue() - Set information in the message queue data structure


Check whether a message queue exists

  • ? msg_get_queue
  • msg_receive ?
  • PHP Manual
  • Semaphore 函数
  • Check whether a message queue exists

msg_queue_exists

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

msg_queue_exists — Check whether a message queue exists

说明

msg_queue_exists ( int $key ) : bool

Checks whether the message queue key exists.

参数

key

Queue key.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_stat_queue() - Returns information from the message queue data structure


Receive a message from a message queue

  • ? msg_queue_exists
  • msg_remove_queue ?
  • PHP Manual
  • Semaphore 函数
  • Receive a message from a message queue

msg_receive

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_receive — Receive a message from a message queue

说明

msg_receive ( SysvMessageQueue $queue , int $desired_message_type , int &$received_message_type , int $max_message_size , mixed &$message , bool $unserialize = true , int $flags = 0 , int &$error_code = null ) : bool

msg_receive() will receive the first message from the specified queue of the type specified by desired_message_type.

参数

queue

The message queue.

desired_message_type

If desired_message_type is 0, the message from the front of the queue is returned. If desired_message_type is greater than 0, then the first message of that type is returned. If desired_message_type is less than 0, the first message on the queue with a type less than or equal to the absolute value of desired_message_type will be read. If no messages match the criteria, your script will wait until a suitable message arrives on the queue. You can prevent the script from blocking by specifying MSG_IPC_NOWAIT in the flags parameter.

received_message_type

The type of the message that was received will be stored in this parameter.

max_message_size

The maximum size of message to be accepted is specified by the max_message_size; if the message in the queue is larger than this size the function will fail (unless you set flags as described below).

message

The received message will be stored in message, unless there were errors receiving the message.

unserialize

If set to true, the message is treated as though it was serialized using the same mechanism as the session module. The message will be unserialized and then returned to your script. This allows you to easily receive arrays or complex object structures from other PHP scripts, or if you are using the WDDX serializer, from any WDDX compatible source.

If unserialize is false, the message will be returned as a binary-safe string.

flags

The optional flags allows you to pass flags to the low-level msgrcv system call. It defaults to 0, but you may specify one or more of the following values (by adding or ORing them together).

Flag values for msg_receive
MSG_IPC_NOWAIT | If there are no messages of the desired_message_type, return immediately and do not wait. The function will fail and return an integer value corresponding to MSG_ENOMSG.
MSG_EXCEPT | Using this flag in combination with a desired_message_type greater than 0 will cause the function to receive the first message that is not equal to desired_message_type.
MSG_NOERROR | If the message is longer than max_message_size, setting this flag will truncate the message to max_message_size and will not signal an error.

error_code

If the function fails, the optional error_code will be set to the value of the system errno variable.

返回值

成功时返回 true， 或者在失败时返回 false。

Upon successful completion the message queue data structure is updated as follows: msg_lrpid is set to the process-ID of the calling process, msg_qnum is decremented by 1 and msg_rtime is set to the current time.

更新日志

版本 | 说明
8.0.0 | queue expects a SysvMessageQueue instance now; previously, a resource was expected.

参见

  • msg_remove_queue() - Destroy a message queue
  • msg_send() - Send a message to a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_set_queue() - Set information in the message queue data structure


Destroy a message queue

  • ? msg_receive
  • msg_send ?
  • PHP Manual
  • Semaphore 函数
  • Destroy a message queue

msg_remove_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_remove_queue — Destroy a message queue

说明

msg_remove_queue ( SysvMessageQueue $queue ) : bool

msg_remove_queue() destroys the message queue specified by the queue. Only use this function when all processes have finished working with the message queue and you need to release the system resources held by it.

参数

queue

The message queue.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | queue expects a SysvMessageQueue instance now; previously, a resource was expected.

参见

  • msg_get_queue() - Create or attach to a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_set_queue() - Set information in the message queue data structure


Send a message to a message queue

  • ? msg_remove_queue
  • msg_set_queue ?
  • PHP Manual
  • Semaphore 函数
  • Send a message to a message queue

msg_send

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_send — Send a message to a message queue

说明

msg_send ( SysvMessageQueue $queue , int $message_type , string|int|float|bool $message , bool $serialize = true , bool $blocking = true , int &$error_code = null ) : bool

msg_send() sends a message of type message_type (which MUST be greater than 0) to the message queue specified by queue.

参数

queue

The message queue.

message_type

The type of the message (MUST be greater than 0)

message

The body of the message.

Note:

If serialize set to false is supplied, MUST be of type: string, int, float or bool. In other case a warning will be issued.

serialize

The optional serialize controls how the message is sent. serialize defaults to true which means that the message is serialized using the same mechanism as the session module before being sent to the queue. This allows complex arrays and objects to be sent to other PHP scripts, or if you are using the WDDX serializer, to any WDDX compatible client.

blocking

If the message is too large to fit in the queue, your script will wait until another process reads messages from the queue and frees enough space for your message to be sent. This is called blocking; you can prevent blocking by setting the optional blocking parameter to false, in which case msg_send() will immediately return false if the message is too big for the queue, and set the optional error_code to MSG_EAGAIN, indicating that you should try to send your message again a little later on.

error_code

If the function fails, the optional errorcode will be set to the value of the system errno variable.

返回值

成功时返回 true， 或者在失败时返回 false。

Upon successful completion the message queue data structure is updated as follows: msg_lspid is set to the process-ID of the calling process, msg_qnum is incremented by 1 and msg_stime is set to the current time.

更新日志

版本 | 说明
8.0.0 | queue expects a SysvMessageQueue instance now; previously, a resource was expected.

参见

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_set_queue() - Set information in the message queue data structure


Set information in the message queue data structure

  • ? msg_send
  • msg_stat_queue ?
  • PHP Manual
  • Semaphore 函数
  • Set information in the message queue data structure

msg_set_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_set_queue — Set information in the message queue data structure

说明

msg_set_queue ( SysvMessageQueue $queue , array $data ) : bool

msg_set_queue() allows you to change the values of the msg_perm.uid, msg_perm.gid, msg_perm.mode and msg_qbytes fields of the underlying message queue data structure.

Changing the data structure will require that PHP be running as the same user that created the queue, owns the queue (as determined by the existing msg_perm.xxx fields), or be running with root privileges. root privileges are required to raise the msg_qbytes values above the system defined limit.

参数

queue

The message queue.

data

You specify the values you require by setting the value of the keys that you require in the data array.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | queue expects a SysvMessageQueue instance now; previously, a resource was expected.

参见

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_get_queue() - Create or attach to a message queue


Returns information from the message queue data structure

  • ? msg_set_queue
  • sem_acquire ?
  • PHP Manual
  • Semaphore 函数
  • Returns information from the message queue data structure

msg_stat_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

msg_stat_queue — Returns information from the message queue data structure

说明

msg_stat_queue ( SysvMessageQueue $queue ) : array|false

msg_stat_queue() returns the message queue meta data for the message queue specified by the queue. This is useful, for example, to determine which process sent the message that was just received.

参数

queue

The message queue.

返回值

On success, the return value is an array whose keys and values have the following meanings:

Array structure for msg_stat_queue
msg_perm.uid | The uid of the owner of the queue.
msg_perm.gid | The gid of the owner of the queue.
msg_perm.mode | The file access mode of the queue.
msg_stime | The time that the last message was sent to the queue.
msg_rtime | The time that the last message was received from the queue.
msg_ctime | The time that the queue was last changed.
msg_qnum | The number of messages waiting to be read from the queue.
msg_qbytes | The maximum number of bytes allowed in one message queue. On Linux, this value may be read and modified via /proc/sys/kernel/msgmnb.
msg_lspid | The pid of the process that sent the last message to the queue.
msg_lrpid | The pid of the process that received the last message from the queue.

Returns false on failure.

更新日志

版本 | 说明
8.0.0 | queue expects a SysvMessageQueue instance now; previously, a resource was expected.

参见

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_get_queue() - Create or attach to a message queue
  • msg_set_queue() - Set information in the message queue data structure


Acquire a semaphore

  • ? msg_stat_queue
  • sem_get ?
  • PHP Manual
  • Semaphore 函数
  • Acquire a semaphore

sem_acquire

(PHP 4, PHP 5, PHP 7, PHP 8)

sem_acquire — Acquire a semaphore

说明

sem_acquire ( SysvSemaphore $semaphore , bool $non_blocking = false ) : bool

sem_acquire() by default blocks (if necessary) until the semaphore can be acquired. A process attempting to acquire a semaphore which it has already acquired will block forever if acquiring the semaphore would cause its maximum number of semaphore to be exceeded.

After processing a request, any semaphores acquired by the process but not explicitly released will be released automatically and a warning will be generated.

参数

semaphore

semaphore is a semaphore obtained from sem_get().

non_blocking

Specifies if the process shouldn't wait for the semaphore to be acquired. If set to true, the call will return false immediately if a semaphore cannot be immediately acquired.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | semaphore expects a SysvSemaphore instance now; previously, a resource was expected.

参见

  • sem_get() - Get a semaphore id
  • sem_release() - Release a semaphore


Get a semaphore id

  • ? sem_acquire
  • sem_release ?
  • PHP Manual
  • Semaphore 函数
  • Get a semaphore id

sem_get

(PHP 4, PHP 5, PHP 7, PHP 8)

sem_get — Get a semaphore id

说明

sem_get ( int $key , int $max_acquire = 1 , int $permissions = 0666 , bool $auto_release = true ) : SysvSemaphore|false

sem_get() returns an id that can be used to access the System V semaphore with the given key.

A second call to sem_get() for the same key will return a different semaphore identifier, but both identifiers access the same underlying semaphore.

If key is 0, a new private semaphore is created for each call to sem_get().

参数

key

max_acquire

The number of processes that can acquire the semaphore simultaneously is set to max_acquire.

permissions

The semaphore permissions. Actually this value is set only if the process finds it is the only process currently attached to the semaphore.

auto_release

Specifies if the semaphore should be automatically released on request shutdown.

返回值

Returns a positive semaphore identifier on success, or false on error.

更新日志

版本 | 说明
8.0.0 | On success, this function returns a SysvSemaphore instance now; previously, a resource was returned.
8.0.0 | The type of auto_release has been changed from int to bool.

注释

Warning

When using sem_get() to access a semaphore created outside PHP, note that the semaphore must have been created as a set of 3 semaphores (for example, by specifying 3 as the nsems parameter when calling the C semget() function), otherwise PHP will be unable to access the semaphore.

参见

  • sem_acquire() - Acquire a semaphore
  • sem_release() - Release a semaphore
  • ftok() - Convert a pathname and a project identifier to a System V IPC key


Release a semaphore

  • ? sem_get
  • sem_remove ?
  • PHP Manual
  • Semaphore 函数
  • Release a semaphore

sem_release

(PHP 4, PHP 5, PHP 7, PHP 8)

sem_release — Release a semaphore

说明

sem_release ( SysvSemaphore $semaphore ) : bool

sem_release() releases the semaphore if it is currently acquired by the calling process, otherwise a warning is generated.

After releasing the semaphore, sem_acquire() may be called to re-acquire it.

参数

semaphore

A Semaphore as returned by sem_get().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | semaphore expects a SysvSemaphore instance now; previously, a resource was expected.

参见

  • sem_get() - Get a semaphore id
  • sem_acquire() - Acquire a semaphore


Remove a semaphore

  • ? sem_release
  • shm_attach ?
  • PHP Manual
  • Semaphore 函数
  • Remove a semaphore

sem_remove

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

sem_remove — Remove a semaphore

说明

sem_remove ( SysvSemaphore $semaphore ) : bool

sem_remove() removes the given semaphore.

After removing the semaphore, it is no longer accessible.

参数

semaphore

A semaphore as returned by sem_get().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | semaphore expects a SysvSemaphore instance now; previously, a resource was expected.

参见

  • sem_get() - Get a semaphore id
  • sem_release() - Release a semaphore
  • sem_acquire() - Acquire a semaphore


Creates or open a shared memory segment

  • ? sem_remove
  • shm_detach ?
  • PHP Manual
  • Semaphore 函数
  • Creates or open a shared memory segment

shm_attach

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_attach — Creates or open a shared memory segment

说明

shm_attach ( int $key , int|null $size = null , int $permissions = 0666 ) : SysvSharedMemory|false

shm_attach() returns an id that can be used to access the System V shared memory with the given key, the first call creates the shared memory segment with size and the optional perm-bits permissions.

A second call to shm_attach() for the same key will return a different SysvSharedMemory instance, but both instances access the same underlying shared memory. size and permissions will be ignored.

参数

key

A numeric shared memory segment ID

size

The memory size. If not provided, default to the sysvshm.init_mem in the php.ini, otherwise 10000 bytes.

permissions

The optional permission bits. Default to 0666.

返回值

Returns a SysvSharedMemory instance on success, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | On success, this function returns an SysvSharedMemory instance now; previously, a resource was returned.
8.0.0 | size is nullable now.

参见

  • shm_detach() - Disconnects from shared memory segment
  • ftok() - Convert a pathname and a project identifier to a System V IPC key


Disconnects from shared memory segment

  • ? shm_attach
  • shm_get_var ?
  • PHP Manual
  • Semaphore 函数
  • Disconnects from shared memory segment

shm_detach

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_detach — Disconnects from shared memory segment

说明

shm_detach ( SysvSharedMemory $shm ) : bool

shm_detach() disconnects from the shared memory given by the shm created by shm_attach(). Remember, that shared memory still exist in the Unix system and the data is still present.

参数

shm

A shared memory segment obtained from shm_attach().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | shm expects a SysvSharedMemory instance now; previously, a resource was expected.

参见

  • shm_attach() - Creates or open a shared memory segment
  • shm_remove() - Removes shared memory from Unix systems
  • shm_remove_var() - Removes a variable from shared memory


Returns a variable from shared memory

  • ? shm_detach
  • shm_has_var ?
  • PHP Manual
  • Semaphore 函数
  • Returns a variable from shared memory

shm_get_var

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_get_var — Returns a variable from shared memory

说明

shm_get_var ( SysvSharedMemory $shm , int $key ) : mixed

shm_get_var() returns the variable with a given key, in the given shared memory segment. The variable is still present in the shared memory.

参数

shm

A shared memory segment obtained from shm_attach().

key

The variable key.

返回值

Returns the variable with the given key.

更新日志

版本 | 说明
8.0.0 | shm expects a SysvSharedMemory instance now; previously, a resource was expected.

参见

  • shm_has_var() - Check whether a specific entry exists
  • shm_put_var() - Inserts or updates a variable in shared memory


Check whether a specific entry exists

  • ? shm_get_var
  • shm_put_var ?
  • PHP Manual
  • Semaphore 函数
  • Check whether a specific entry exists

shm_has_var

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

shm_has_var — Check whether a specific entry exists

说明

shm_has_var ( SysvSharedMemory $shm , int $key ) : bool

Checks whether a specific key exists inside a shared memory segment.

参数

shm

A shared memory segment obtained from shm_attach().

key

The variable key.

返回值

Returns true if the entry exists, otherwise false

更新日志

版本 | 说明
8.0.0 | shm expects a SysvSharedMemory instance now; previously, a resource was expected.

参见

  • shm_get_var() - Returns a variable from shared memory
  • shm_put_var() - Inserts or updates a variable in shared memory


Inserts or updates a variable in shared memory

  • ? shm_has_var
  • shm_remove_var ?
  • PHP Manual
  • Semaphore 函数
  • Inserts or updates a variable in shared memory

shm_put_var

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_put_var — Inserts or updates a variable in shared memory

说明

shm_put_var ( SysvSharedMemory $shm , int $key , mixed $value ) : bool

shm_put_var() inserts or updates the value with the given key.

Warnings (E_WARNING level) will be issued if shm is not a valid SysV shared memory index or if there was not enough shared memory remaining to complete your request.

参数

shm

A shared memory segment obtained from shm_attach().

key

The variable key.

value

The variable. All variable types that serialize() supports may be used: generally this means all types except for resources and some internal objects that cannot be serialized.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | shm expects a SysvSharedMemory instance now; previously, a resource was expected.

参见

  • shm_get_var() - Returns a variable from shared memory
  • shm_has_var() - Check whether a specific entry exists


Removes a variable from shared memory

  • ? shm_put_var
  • shm_remove ?
  • PHP Manual
  • Semaphore 函数
  • Removes a variable from shared memory

shm_remove_var

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_remove_var — Removes a variable from shared memory

说明

shm_remove_var ( SysvSharedMemory $shm , int $key ) : bool

Removes a variable with a given key and frees the occupied memory.

参数

shm

A shared memory segment obtained from shm_attach().

key

The variable key.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | shm expects a SysvSharedMemory instance now; previously, a resource was expected.

参见

  • shm_remove() - Removes shared memory from Unix systems


Removes shared memory from Unix systems

  • ? shm_remove_var
  • Shared Memory ?
  • PHP Manual
  • Semaphore 函数
  • Removes shared memory from Unix systems

shm_remove

(PHP 4, PHP 5, PHP 7, PHP 8)

shm_remove — Removes shared memory from Unix systems

说明

shm_remove ( SysvSharedMemory $shm ) : bool

shm_remove() removes the shared memory shm. All data will be destroyed.

参数

shm

A shared memory segment obtained from shm_attach().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | shm expects a SysvSharedMemory instance now; previously, a resource was expected.

参见

  • shm_remove_var() - Removes a variable from shared memory


Shared Memory

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic usage
  • Shared Memory 函数
    • shmop_close — Close shared memory block
    • shmop_delete — Delete shared memory block
    • shmop_open — Create or open shared memory block
    • shmop_read — Read data from shared memory block
    • shmop_size — Get size of shared memory block
    • shmop_write — Write data into shared memory block
  • Shmop — The Shmop class


简介

Shmop is an easy to use set of functions that allows PHP to read, write, create and delete Unix shared memory segments.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Shared Memory
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

To use shmop you will need to compile PHP with the --enable-shmop parameter in your configure line.


资源类型

Prior to PHP 8.0.0, this extension defined the resource type shmop which is a handle to a shared memory block.


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • Shared Memory
  • 预定义常量

预定义常量

此扩展没有定义常量。


  • ? 预定义常量
  • Basic usage ?
  • PHP Manual
  • Shared Memory
  • 范例

范例

Table of Contents

  • Basic usage


Basic usage

Example #1 Shared Memory Operations Overview

<?php

// Create 100 byte shared memory block with system id of 0xff3
$shm_id = shmop_open(0xff3, "c", 0644, 100);
if (!$shm_id) {
    echo "Couldn't create shared memory segment\n";
}

// Get shared memory block's size
$shm_size = shmop_size($shm_id);
echo "SHM Block Size: " . $shm_size . " has been created.\n";

// Lets write a test string into shared memory
$shm_bytes_written = shmop_write($shm_id, "my shared memory block", 0);
if ($shm_bytes_written != strlen("my shared memory block")) {
    echo "Couldn't write the entire length of data\n";
}

// Now lets read the string back
$my_string = shmop_read($shm_id, 0, $shm_size);
if (!$my_string) {
    echo "Couldn't read from shared memory block\n";
}
echo "The data inside shared memory was: " . $my_string . "\n";

//Now lets delete the block and close the shared memory segment
if (!shmop_delete($shm_id)) {
    echo "Couldn't mark shared memory block for deletion.";
}
shmop_close($shm_id);

?>


Shared Memory 函数

Table of Contents

  • shmop_close — Close shared memory block
  • shmop_delete — Delete shared memory block
  • shmop_open — Create or open shared memory block
  • shmop_read — Read data from shared memory block
  • shmop_size — Get size of shared memory block
  • shmop_write — Write data into shared memory block


Close shared memory block

  • ? Shared Memory 函数
  • shmop_delete ?
  • PHP Manual
  • Shared Memory 函数
  • Close shared memory block

shmop_close

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_close — Close shared memory block

说明

shmop_close ( Shmop $shmop ) : void

shmop_close() is used to close a shared memory block.

参数

shmop

The shared memory block resource created by shmop_open()

返回值

没有返回值。

更新日志

版本 | 说明
8.0.0 | shmop expects a Shmop instance now; previously, a resource was expected.

范例

Example #1 Closing shared memory block

<?php
shmop_close($shm_id);
?>

This example will close shared memory block identified by $shm_id.

参见

  • shmop_open() - Create or open shared memory block


Delete shared memory block

  • ? shmop_close
  • shmop_open ?
  • PHP Manual
  • Shared Memory 函数
  • Delete shared memory block

shmop_delete

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_delete — Delete shared memory block

说明

shmop_delete ( Shmop $shmop ) : bool

shmop_delete() is used to delete a shared memory block.

参数

shmop

The shared memory block resource created by shmop_open()

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | shmop expects a Shmop instance now; previously, a resource was expected.

范例

Example #1 Deleting shared memory block

<?php
shmop_delete($shm_id);
?>

This example will delete shared memory block identified by $shm_id.


Create or open shared memory block

  • ? shmop_delete
  • shmop_read ?
  • PHP Manual
  • Shared Memory 函数
  • Create or open shared memory block

shmop_open

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_open — Create or open shared memory block

说明

shmop_open ( int $key , string $mode , int $permissions , int $size ) : Shmop|false

shmop_open() can create or open a shared memory block.

参数

key

System's id for the shared memory block. Can be passed as a decimal or hex.

mode

The flags that you can use:

  • "a" for access (sets SHM_RDONLY for shmat) use this flag when you need to open an existing shared memory segment for read only
  • "c" for create (sets IPC_CREATE) use this flag when you need to create a new shared memory segment or if a segment with the same key exists, try to open it for read and write
  • "w" for read & write access use this flag when you need to read and write to a shared memory segment, use this flag in most cases.
  • "n" create a new memory segment (sets IPC_CREATE|IPC_EXCL) use this flag when you want to create a new shared memory segment but if one already exists with the same flag, fail. This is useful for security purposes, using this you can prevent race condition exploits.

permissions

The permissions that you wish to assign to your memory segment, those are the same as permission for a file. Permissions need to be passed in octal form, like for example 0644

size

The size of the shared memory block you wish to create in bytes

Note:

Note: the 3rd and 4th should be entered as 0 if you are opening an existing memory segment.

返回值

On success shmop_open() will return a Shmop instance that you can use to access the shared memory segment you've created. false is returned on failure.

更新日志

版本 | 说明
8.0.0 | On success, this function returns an Shmop instance now; previously, a resource was returned.

范例

Example #1 Create a new shared memory block

<?php
$shm_key = ftok(__FILE__, 't');
$shm_id = shmop_open($shm_key, "c", 0644, 100);
?>

This example opened a shared memory block with a system id returned by ftok().

参见

  • shmop_close() - Close shared memory block
  • shmop_delete() - Delete shared memory block


Read data from shared memory block

  • ? shmop_open
  • shmop_size ?
  • PHP Manual
  • Shared Memory 函数
  • Read data from shared memory block

shmop_read

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_read — Read data from shared memory block

说明

shmop_read ( Shmop $shmop , int $offset , int $size ) : string

shmop_read() will read a string from shared memory block.

参数

shmop

The shared memory block identifier created by shmop_open()

offset

Offset from which to start reading

size

The number of bytes to read. 0 reads shmop_size($shmid) - $start bytes.

返回值

Returns the data 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | shmop expects a Shmop instance now; previously, a resource was expected.

范例

Example #1 Reading shared memory block

<?php
$shm_data = shmop_read($shm_id, 0, 50);
?>

This example will read 50 bytes from shared memory block and place the data inside $shm_data.

参见

  • shmop_write() - Write data into shared memory block


Get size of shared memory block

  • ? shmop_read
  • shmop_write ?
  • PHP Manual
  • Shared Memory 函数
  • Get size of shared memory block

shmop_size

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_size — Get size of shared memory block

说明

shmop_size ( Shmop $shmop ) : int

shmop_size() is used to get the size, in bytes of the shared memory block.

参数

shmop

The shared memory block identifier created by shmop_open()

返回值

Returns an int, which represents the number of bytes the shared memory block occupies.

更新日志

版本 | 说明
8.0.0 | shmop expects a Shmop instance now; previously, a resource was expected.

范例

Example #1 Getting the size of the shared memory block

<?php
$shm_size = shmop_size($shm_id);
?>

This example will put the size of shared memory block identified by $shm_id into $shm_size.


Write data into shared memory block

  • ? shmop_size
  • Shmop ?
  • PHP Manual
  • Shared Memory 函数
  • Write data into shared memory block

shmop_write

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

shmop_write — Write data into shared memory block

说明

shmop_write ( Shmop $shmop , string $data , int $offset ) : int

shmop_write() will write a string into shared memory block.

参数

shmop

The shared memory block identifier created by shmop_open()

data

A string to write into shared memory block

offset

Specifies where to start writing data inside the shared memory segment.

返回值

The size of the written data.

更新日志

版本 | 说明
8.0.0 | Prior to PHP 8.0.0, false was returned on failure.
8.0.0 | shmop expects a Shmop instance now; previously, a resource was expected.

范例

Example #1 Writing to shared memory block

<?php
$shm_bytes_written = shmop_write($shm_id, $my_string, 0);
?>

This example will write data inside $my_string into shared memory block, $shm_bytes_written will contain the number of bytes written.

参见

  • shmop_read() - Read data from shared memory block


The Shmop class

(PHP 8)

简介

A fully opaque class which replaces shmop resources as of PHP 8.0.0.

类摘要

final Shmop {
}


Sync

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • SyncMutex — The SyncMutex class
    • SyncMutex::__construct — Constructs a new SyncMutex object
    • SyncMutex::lock — Waits for an exclusive lock
    • SyncMutex::unlock — Unlocks the mutex
  • SyncSemaphore — The SyncSemaphore class
    • SyncSemaphore::__construct — Constructs a new SyncSemaphore object
    • SyncSemaphore::lock — Decreases the count of the semaphore or waits
    • SyncSemaphore::unlock — Increases the count of the semaphore
  • SyncEvent — The SyncEvent class
    • SyncEvent::__construct — Constructs a new SyncEvent object
    • SyncEvent::fire — Fires/sets the event
    • SyncEvent::reset — Resets a manual event
    • SyncEvent::wait — Waits for the event to be fired/set
  • SyncReaderWriter — The SyncReaderWriter class
    • SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object
    • SyncReaderWriter::readlock — Waits for a read lock
    • SyncReaderWriter::readunlock — Releases a read lock
    • SyncReaderWriter::writelock — Waits for an exclusive write lock
    • SyncReaderWriter::writeunlock — Releases a write lock
  • SyncSharedMemory — The SyncSharedMemory class
    • SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object
    • SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory
    • SyncSharedMemory::read — Copy data from named shared memory
    • SyncSharedMemory::size — Returns the size of the named shared memory
    • SyncSharedMemory::write — Copy data to named shared memory


简介

The 'sync' extension introduces cross-platform synchonization objects into PHP. Named and unnamed Mutex, Semaphore, Event, Reader-Writer, and named Shared Memory objects provide OS-level synchronization on both POSIX (e.g. Linux) and Windows platforms.

Automatic cleanup of acquired synchronization objects takes place during extension teardown. This means that if PHP prematurely terminates a script (e.g. script execution time is exceeded), objects will not be left in an unknown state. The only exception to this is if PHP itself crashes (e.g. an internal buffer overflow).

Unnamed synchronization objects don't have a lot of use outside of a multithreaded scenario. Unnamed objects are more useful in conjunction with the pthreads PECL extension.

Note:

Named objects require additional care to be used on all systems. If an object is instantiated with a specific set of parameters, it must always be instantiated with those parameters or the object will probably end up in an inconsistent state until the next reboot or a system administrator cleans up the mess.


需求

A system with support for POSIX shared memory (shm_open()) or running Windows.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/sync.


  • ? 资源类型
  • SyncMutex ?
  • PHP Manual
  • Sync
  • 预定义常量

预定义常量

此扩展没有定义常量。


The SyncMutex class

(PECL sync >= 1.0.0)

简介

A cross-platform, native implementation of named and unnamed countable mutex objects.

A mutex is a mutual exclusion object that restricts access to a shared resource (e.g. a file) to a single instance. Countable mutexes acquire the mutex a single time and internally track the number of times the mutex is locked. The mutex is unlocked as soon as it goes out of scope or is unlocked the same number of times that it was locked.

类摘要

SyncMutex {
/* 方法 */
public __construct ( string $name = ? )
public lock ( int $wait = -1 ) : bool
public unlock ( bool $all = false ) : bool
}

Table of Contents

  • SyncMutex::__construct — Constructs a new SyncMutex object
  • SyncMutex::lock — Waits for an exclusive lock
  • SyncMutex::unlock — Unlocks the mutex


Constructs a new SyncMutex object

  • ? SyncMutex
  • SyncMutex::lock ?
  • PHP Manual
  • SyncMutex
  • Constructs a new SyncMutex object

SyncMutex::__construct

(PECL sync >= 1.0.0)

SyncMutex::__construct — Constructs a new SyncMutex object

说明

public SyncMutex::__construct ( string $name = ? )

Constructs a named or unnamed countable mutex.

参数

name

The name of the mutex if this is a named mutex object.

Note:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

返回值

The new SyncMutex object. An exception is thrown if the mutex cannot be created or opened.

范例

Example #1 SyncMutex::__construct() named mutex with lock timeout example

<?php
$mutex = new SyncMutex("UniqueName");

if (!$mutex->lock(3000))
{
    echo "Unable to lock mutex.";

    exit();
}

/* ... */

$mutex->unlock();
?>

Example #2 SyncMutex::__construct() unnamed mutex example

<?php
$mutex = new SyncMutex();

$mutex->lock();

/* ... */

$mutex->unlock();
?>

参见

  • SyncMutex::lock() - Waits for an exclusive lock
  • SyncMutex::unlock() - Unlocks the mutex


Waits for an exclusive lock

  • ? SyncMutex::__construct
  • SyncMutex::unlock ?
  • PHP Manual
  • SyncMutex
  • Waits for an exclusive lock

SyncMutex::lock

(PECL sync >= 1.0.0)

SyncMutex::lock — Waits for an exclusive lock

说明

public SyncMutex::lock ( int $wait = -1 ) : bool

Obtains an exclusive lock on a SyncMutex object. If the lock is already acquired, then this increments an internal counter.

参数

wait

The number of milliseconds to wait for the exclusive lock. A value of -1 is infinite.

返回值

A boolean of TRUE if the lock was obtained, FALSE otherwise.

范例

Example #1 SyncMutex::lock() example

<?php
$mutex = new SyncMutex("UniqueName");

if (!$mutex->lock(3000))
{
    echo "Unable to lock mutex.";

    exit();
}

/* ... */

$mutex->unlock();
?>

参见

  • SyncMutex::unlock() - Unlocks the mutex


Unlocks the mutex

  • ? SyncMutex::lock
  • SyncSemaphore ?
  • PHP Manual
  • SyncMutex
  • Unlocks the mutex

SyncMutex::unlock

(PECL sync >= 1.0.0)

SyncMutex::unlock — Unlocks the mutex

说明

public SyncMutex::unlock ( bool $all = false ) : bool

Decreases the internal counter of a SyncMutex object. When the internal counter reaches zero, the actual lock on the object is released.

参数

all

Specifies whether or not to set the internal counter to zero and therefore release the lock.

返回值

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

范例

Example #1 SyncMutex::unlock() example

<?php
$mutex = new SyncMutex("UniqueName");

$mutex->lock();

/* ... */

$mutex->unlock();
?>

参见

  • SyncMutex::lock() - Waits for an exclusive lock


The SyncSemaphore class

(PECL sync >= 1.0.0)

简介

A cross-platform, native implementation of named and unnamed semaphore objects.

A semaphore restricts access to a limited resource to a limited number of instances. Semaphores differ from mutexes in that they can allow more than one instance to access a resource at one time while a mutex only allows one instance at a time.

类摘要

SyncSemaphore {
/* 方法 */
public __construct ( string $name = ? , int $initialval = 1 , bool $autounlock = true )
public lock ( int $wait = -1 ) : bool
public unlock ( int &$prevcount = ? ) : bool
}

Table of Contents

  • SyncSemaphore::__construct — Constructs a new SyncSemaphore object
  • SyncSemaphore::lock — Decreases the count of the semaphore or waits
  • SyncSemaphore::unlock — Increases the count of the semaphore


Constructs a new SyncSemaphore object

  • ? SyncSemaphore
  • SyncSemaphore::lock ?
  • PHP Manual
  • SyncSemaphore
  • Constructs a new SyncSemaphore object

SyncSemaphore::__construct

(PECL sync >= 1.0.0)

SyncSemaphore::__construct — Constructs a new SyncSemaphore object

说明

public SyncSemaphore::__construct ( string $name = ? , int $initialval = 1 , bool $autounlock = true )

Constructs a named or unnamed semaphore.

参数

name

The name of the semaphore if this is a named semaphore object.

Note:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

initialval

The initial value of the semaphore. This is the number of locks that may be obtained.

autounlock

Specifies whether or not to automatically unlock the semaphore at the conclusion of the PHP script.

Warning

If an object is: A named semaphore with an autounlock of FALSE, the object is locked, and the PHP script concludes before the object is unlocked, then the underlying semaphore will end up in an inconsistent state.

返回值

The new SyncSemaphore object. An exception is thrown if the semaphore cannot be created or opened.

范例

Example #1 SyncSemaphore::__construct() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

参见

  • SyncSemaphore::lock() - Decreases the count of the semaphore or waits
  • SyncSemaphore::unlock() - Increases the count of the semaphore


Decreases the count of the semaphore or waits

  • ? SyncSemaphore::__construct
  • SyncSemaphore::unlock ?
  • PHP Manual
  • SyncSemaphore
  • Decreases the count of the semaphore or waits

SyncSemaphore::lock

(PECL sync >= 1.0.0)

SyncSemaphore::lock — Decreases the count of the semaphore or waits

说明

public SyncSemaphore::lock ( int $wait = -1 ) : bool

Decreases the count of a SyncSemaphore object or waits until the semaphore becomes non-zero.

参数

wait

The number of milliseconds to wait for the semaphore. A value of -1 is infinite.

返回值

A boolean of TRUE if the lock operation was successful, FALSE otherwise.

范例

Example #1 SyncSemaphore::lock() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

参见

  • SyncSemaphore::unlock() - Increases the count of the semaphore


Increases the count of the semaphore

  • ? SyncSemaphore::lock
  • SyncEvent ?
  • PHP Manual
  • SyncSemaphore
  • Increases the count of the semaphore

SyncSemaphore::unlock

(PECL sync >= 1.0.0)

SyncSemaphore::unlock — Increases the count of the semaphore

说明

public SyncSemaphore::unlock ( int &$prevcount = ? ) : bool

Increases the count of a SyncSemaphore object.

参数

prevcount

Returns the previous count of the semaphore.

返回值

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

范例

Example #1 SyncSemaphore::unlock() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

参见

  • SyncSemaphore::lock() - Decreases the count of the semaphore or waits


The SyncEvent class

(PECL sync >= 1.0.0)

简介

A cross-platform, native implementation of named and unnamed event objects. Both automatic and manual event objects are supported.

An event object waits, without polling, for the object to be fired/set. One instance waits on the event object while another instance fires/sets the event. Event objects are useful wherever a long-running process would otherwise poll a resource (e.g. checking to see if uploaded data needs to be processed).

类摘要

SyncEvent {
/* 方法 */
public __construct ( string $name = ? , bool $manual = false , bool $prefire = false )
public fire ( ) : bool
public reset ( ) : bool
public wait ( int $wait = -1 ) : bool
}

Table of Contents

  • SyncEvent::__construct — Constructs a new SyncEvent object
  • SyncEvent::fire — Fires/sets the event
  • SyncEvent::reset — Resets a manual event
  • SyncEvent::wait — Waits for the event to be fired/set


Constructs a new SyncEvent object

  • ? SyncEvent
  • SyncEvent::fire ?
  • PHP Manual
  • SyncEvent
  • Constructs a new SyncEvent object

SyncEvent::__construct

(PECL sync >= 1.0.0)

SyncEvent::__construct — Constructs a new SyncEvent object

说明

public SyncEvent::__construct ( string $name = ? , bool $manual = false , bool $prefire = false )

Constructs a named or unnamed event object.

参数

name

The name of the event if this is a named event object.

Note:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

manual

Specifies whether or not the event object must be reset manually.

Note:

Manual reset event objects allow all waiting processes through until the object is reset.

prefire

Specifies whether or not to prefire (signal) the event object.

Note:

Only has impact if the calling process/thread is the first to create the object.

返回值

The new SyncEvent object. An exception is thrown if the event object cannot be created or opened.

范例

Example #1 SyncEvent::__construct() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

更新日志

版本 | 说明
PECL sync 1.1.0 | Added prefire.

参见

  • SyncEvent::fire() - Fires/sets the event
  • SyncEvent::reset() - Resets a manual event
  • SyncEvent::wait() - Waits for the event to be fired/set


Fires/sets the event

  • ? SyncEvent::__construct
  • SyncEvent::reset ?
  • PHP Manual
  • SyncEvent
  • Fires/sets the event

SyncEvent::fire

(PECL sync >= 1.0.0)

SyncEvent::fire — Fires/sets the event

说明

public SyncEvent::fire ( ) : bool

Fires/sets a SyncEvent object. Lets multiple threads through that are waiting if the event object was created with a manual value of TRUE.

参数

此函数没有参数。

返回值

A boolean of TRUE if the event was fired, FALSE otherwise.

范例

Example #1 SyncEvent::fire() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

参见

  • SyncEvent::reset() - Resets a manual event
  • SyncEvent::wait() - Waits for the event to be fired/set


Resets a manual event

  • ? SyncEvent::fire
  • SyncEvent::wait ?
  • PHP Manual
  • SyncEvent
  • Resets a manual event

SyncEvent::reset

(PECL sync >= 1.0.0)

SyncEvent::reset — Resets a manual event

说明

public SyncEvent::reset ( ) : bool

Resets a SyncEvent object that has been fired/set. Only valid for manual event objects.

参数

此函数没有参数。

返回值

A boolean value of TRUE if the object was successfully reset, FALSE otherwise.

范例

Example #1 SyncEvent::reset() example

<?php
// In a web application:
$event = new SyncEvent("DemoApplication", true);
$event->wait();

// In a cron job:
$event = new SyncEvent("DemoApplication", true);
$event->reset();
/* ... Do some maintenance task(s) ... */
$event->fire();
?>

参见

  • SyncEvent::fire() - Fires/sets the event
  • SyncEvent::reset()
  • SyncEvent::wait() - Waits for the event to be fired/set


Waits for the event to be fired/set

  • ? SyncEvent::reset
  • SyncReaderWriter ?
  • PHP Manual
  • SyncEvent
  • Waits for the event to be fired/set

SyncEvent::wait

(PECL sync >= 1.0.0)

SyncEvent::wait — Waits for the event to be fired/set

说明

public SyncEvent::wait ( int $wait = -1 ) : bool

Waits for the SyncEvent object to be fired.

参数

wait

The number of milliseconds to wait for the event to be fired. A value of -1 is infinite.

返回值

A boolean of TRUE if the event was fired, FALSE otherwise.

范例

Example #1 SyncEvent::wait() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

参见

  • SyncEvent::fire() - Fires/sets the event


The SyncReaderWriter class

(PECL sync >= 1.0.0)

简介

A cross-platform, native implementation of named and unnamed reader-writer objects.

A reader-writer object allows many readers or one writer to access a resource. This is an efficient solution for managing resources where access will primarily be read-only but exclusive write access is occasionally necessary.

类摘要

SyncReaderWriter {
/* 方法 */
public __construct ( string $name = ? , bool $autounlock = true )
public readlock ( int $wait = -1 ) : bool
public readunlock ( ) : bool
public writelock ( int $wait = -1 ) : bool
public writeunlock ( ) : bool
}

Table of Contents

  • SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object
  • SyncReaderWriter::readlock — Waits for a read lock
  • SyncReaderWriter::readunlock — Releases a read lock
  • SyncReaderWriter::writelock — Waits for an exclusive write lock
  • SyncReaderWriter::writeunlock — Releases a write lock


Constructs a new SyncReaderWriter object

  • ? SyncReaderWriter
  • SyncReaderWriter::readlock ?
  • PHP Manual
  • SyncReaderWriter
  • Constructs a new SyncReaderWriter object

SyncReaderWriter::__construct

(PECL sync >= 1.0.0)

SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object

说明

public SyncReaderWriter::__construct ( string $name = ? , bool $autounlock = true )

Constructs a named or unnamed reader-writer object.

参数

name

The name of the reader-writer if this is a named reader-writer object.

Note:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

autounlock

Specifies whether or not to automatically unlock the reader-writer at the conclusion of the PHP script.

Warning

If an object is: A named reader-writer with an autounlock of FALSE, the object is locked for either reading or writing, and the PHP script concludes before the object is unlocked, then the underlying objects will end up in an inconsistent state.

返回值

The new SyncReaderWriter object. An exception is thrown if the reader-writer cannot be created or opened.

范例

Example #1 SyncReaderWriter::__construct() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();

$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

参见

  • SyncReaderWriter::readlock() - Waits for a read lock
  • SyncReaderWriter::readunlock() - Releases a read lock
  • SyncReaderWriter::writelock() - Waits for an exclusive write lock
  • SyncReaderWriter::writeunlock() - Releases a write lock


Waits for a read lock

  • ? SyncReaderWriter::__construct
  • SyncReaderWriter::readunlock ?
  • PHP Manual
  • SyncReaderWriter
  • Waits for a read lock

SyncReaderWriter::readlock

(PECL sync >= 1.0.0)

SyncReaderWriter::readlock — Waits for a read lock

说明

public SyncReaderWriter::readlock ( int $wait = -1 ) : bool

Obtains a read lock on a SyncReaderWriter object.

参数

wait

The number of milliseconds to wait for a lock. A value of -1 is infinite.

返回值

A boolean of TRUE if the lock was obtained, FALSE otherwise.

范例

Example #1 SyncReaderWriter::readlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();
?>

参见

  • SyncReaderWriter::readunlock() - Releases a read lock


Releases a read lock

  • ? SyncReaderWriter::readlock
  • SyncReaderWriter::writelock ?
  • PHP Manual
  • SyncReaderWriter
  • Releases a read lock

SyncReaderWriter::readunlock

(PECL sync >= 1.0.0)

SyncReaderWriter::readunlock — Releases a read lock

说明

public SyncReaderWriter::readunlock ( ) : bool

Releases a read lock on a SyncReaderWriter object.

参数

此函数没有参数。

返回值

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

范例

Example #1 SyncReaderWriter::readunlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();
?>

参见

  • SyncReaderWriter::readlock() - Waits for a read lock


Waits for an exclusive write lock

  • ? SyncReaderWriter::readunlock
  • SyncReaderWriter::writeunlock ?
  • PHP Manual
  • SyncReaderWriter
  • Waits for an exclusive write lock

SyncReaderWriter::writelock

(PECL sync >= 1.0.0)

SyncReaderWriter::writelock — Waits for an exclusive write lock

说明

public SyncReaderWriter::writelock ( int $wait = -1 ) : bool

Obtains an exclusive write lock on a SyncReaderWriter object.

参数

wait

The number of milliseconds to wait for a lock. A value of -1 is infinite.

返回值

A boolean of TRUE if the lock was obtained, FALSE otherwise.

范例

Example #1 SyncReaderWriter::writelock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

参见

  • SyncReaderWriter::writeunlock() - Releases a write lock


Releases a write lock

  • ? SyncReaderWriter::writelock
  • SyncSharedMemory ?
  • PHP Manual
  • SyncReaderWriter
  • Releases a write lock

SyncReaderWriter::writeunlock

(PECL sync >= 1.0.0)

SyncReaderWriter::writeunlock — Releases a write lock

说明

public SyncReaderWriter::writeunlock ( ) : bool

Releases a write lock on a SyncReaderWriter object.

参数

此函数没有参数。

返回值

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

范例

Example #1 SyncReaderWriter::writeunlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

参见

  • SyncReaderWriter::writelock() - Waits for an exclusive write lock


The SyncSharedMemory class

(PECL sync >= 1.1.0)

简介

A cross-platform, native, consistent implementation of named shared memory objects.

Shared memory lets two separate processes communicate without the need for complex pipes or sockets. There are several integer-based shared memory implementations for PHP. Named shared memory is an alternative.

Synchronization objects (e.g. SyncMutex) are still required to protect most uses of shared memory.

类摘要

SyncSharedMemory {
/* 方法 */
public __construct ( string $name , int $size )
public first ( ) : bool
public read ( int $start = 0 , int $length = ? )
public size ( ) : bool
public write ( string $string = ? , int $start = 0 )
}

Table of Contents

  • SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::read — Copy data from named shared memory
  • SyncSharedMemory::size — Returns the size of the named shared memory
  • SyncSharedMemory::write — Copy data to named shared memory


Constructs a new SyncSharedMemory object

  • ? SyncSharedMemory
  • SyncSharedMemory::first ?
  • PHP Manual
  • SyncSharedMemory
  • Constructs a new SyncSharedMemory object

SyncSharedMemory::__construct

(PECL sync >= 1.1.0)

SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object

说明

public SyncSharedMemory::__construct ( string $name , int $size )

Constructs a named shared memory object.

参数

name

The name of the shared memory object.

Note:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

size

The size, in bytes, of shared memory to reserve.

Note:

The amount of memory cannot be resized later. Request sufficient storage up front.

返回值

The new SyncSharedMemory object. An exception is thrown if the shared memory object cannot be created or opened.

范例

Example #1 SyncSharedMemory::__construct() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write(json_encode(array("name" => "my_report.txt")));
?>

参见

  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::size() - Returns the size of the named shared memory
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory


Check to see if the object is the first instance system-wide of named shared memory

  • ? SyncSharedMemory::__construct
  • SyncSharedMemory::read ?
  • PHP Manual
  • SyncSharedMemory
  • Check to see if the object is the first instance system-wide of named shared memory

SyncSharedMemory::first

(PECL sync >= 1.1.0)

SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory

说明

public SyncSharedMemory::first ( ) : bool

Retrieves the system-wide first instance status of a SyncSharedMemory object.

参数

此函数没有参数。

返回值

A boolean of TRUE if the object is the first instance system-wide, FALSE otherwise.

范例

Example #1 SyncSharedMemory::first() example

<?php
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

var_dump($mem->first());

$mem2 = new SyncSharedMemory("AppReportName", 1024);

var_dump($mem2->first());
?>

以上例程的输出类似于：

bool(true)
bool(false)

参见

  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory


Copy data from named shared memory

  • ? SyncSharedMemory::first
  • SyncSharedMemory::size ?
  • PHP Manual
  • SyncSharedMemory
  • Copy data from named shared memory

SyncSharedMemory::read

(PECL sync >= 1.1.0)

SyncSharedMemory::read — Copy data from named shared memory

说明

public SyncSharedMemory::read ( int $start = 0 , int $length = ? )

Copies data from named shared memory.

参数

start

The start/offset, in bytes, to begin reading.

Note:

If the value is negative, the starting position will begin at the specified number of bytes from the end of the shared memory segment.

length

The number of bytes to read.

Note:

If unspecified, reading will stop at the end of the shared memory segment.

If the value is negative, reading will stop the specified number of bytes from the end of the shared memory segment.

返回值

A string containing the data read from shared memory.

范例

Example #1 SyncSharedMemory::__construct() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write("report.txt");

$result = $mem->read(3, -4);
var_dump($result);
?>

以上例程的输出类似于：

string(3) "ort"

参见

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read()


Returns the size of the named shared memory

  • ? SyncSharedMemory::read
  • SyncSharedMemory::write ?
  • PHP Manual
  • SyncSharedMemory
  • Returns the size of the named shared memory

SyncSharedMemory::size

(PECL sync >= 1.1.0)

SyncSharedMemory::size — Returns the size of the named shared memory

说明

public SyncSharedMemory::size ( ) : bool

Retrieves the shared memory size of a SyncSharedMemory object.

参数

此函数没有参数。

返回值

An integer containing the size of the shared memory. This will be the same size that was passed to the constructor.

范例

Example #1 SyncSharedMemory::size() example

<?php
$mem = new SyncSharedMemory("AppReportName", 1024);
var_dump($mem->size());
?>

以上例程的输出类似于：

int(1024)

参见

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory


Copy data to named shared memory

  • ? SyncSharedMemory::size
  • 其它基本扩展 ?
  • PHP Manual
  • SyncSharedMemory
  • Copy data to named shared memory

SyncSharedMemory::write

(PECL sync >= 1.1.0)

SyncSharedMemory::write — Copy data to named shared memory

说明

public SyncSharedMemory::write ( string $string = ? , int $start = 0 )

Copies data to named shared memory.

参数

string

The data to write to shared memoy.

Note:

If the size of the data exceeds the size of the shared memory, the number of bytes written returned will be less than the length of the input.

start

The start/offset, in bytes, to begin writing.

Note:

If the value is negative, the starting position will begin at the specified number of bytes from the end of the shared memory segment.

返回值

An integer containing the number of bytes written to shared memory.

范例

Example #1 SyncSharedMemory::write() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write("report.txt");
var_dump($result);

$result = $mem->write("report.txt", -3);
var_dump($result);
?>

以上例程的输出类似于：

int(10)
int(3)

参见

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::write()
  • SyncSharedMemory::read() - Copy data from named shared memory


其它基本扩展

  • GeoIP — Geo IP 定位
    • 简介
    • 安装／配置
    • 预定义常量
    • GeoIP 函数
  • FANN — FANN (快速人工神经网络)
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Fann 函数
    • FANNConnection — FANNConnection 类
  • JSON — JavaScript对象符号（JSON）
    • 简介
    • 安装／配置
    • 预定义常量
    • JsonException — The JsonException class
    • JsonSerializable — JSON 序列化接口
    • JSON 函数
  • Lua
    • 简介
    • 安装／配置
    • Lua — Lua类
    • LuaClosure — LuaClosure类
  • LuaSandbox
    • 简介
    • 安装／配置
    • Differences from Standard Lua
    • 范例
    • LuaSandbox — The LuaSandbox class
    • LuaSandboxFunction — The LuaSandboxFunction class
    • LuaSandboxError — The LuaSandboxError class
    • LuaSandboxErrorError — The LuaSandboxErrorError class
    • LuaSandboxFatalError — The LuaSandboxFatalError class
    • LuaSandboxMemoryError — The LuaSandboxMemoryError class
    • LuaSandboxRuntimeError — The LuaSandboxRuntimeError class
    • LuaSandboxSyntaxError — The LuaSandboxSyntaxError class
    • LuaSandboxTimeoutError — The LuaSandboxTimeoutError class
  • Misc. — 杂项函数
    • 简介
    • 安装／配置
    • 预定义常量
    • 杂项 函数
    • 更新日志
  • SeasLog
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Seaslog 函数
    • SeasLog — The SeasLog class
  • SPL — PHP标准库 (SPL)
    • 简介
    • 安装／配置
    • 预定义常量
    • 数据结构
    • 迭代器
    • 接口
    • 异常
    • SPL 函数
    • 文件处理
    • 各种类及接口
  • Streams
    • 简介
    • 安装／配置
    • 预定义常量
    • Stream Filters
    • Stream Contexts
    • Stream Errors
    • 范例
    • php_user_filter — The php_user_filter class
    • streamWrapper — The streamWrapper class
    • Stream 函数
  • Swoole
    • 简介
    • 安装／配置
    • 预定义常量
    • Swoole 函数
    • Swoole\Async — The Swoole\Async class
    • Swoole\Atomic — The Swoole\Atomic class
    • Swoole\Buffer — The Swoole\Buffer class
    • Swoole\Channel — The Swoole\Channel class
    • Swoole\Client — The Swoole\Client class
    • Swoole\Connection\Iterator — The Swoole\Connection\Iterator class
    • Swoole\Coroutine — The Swoole\Coroutine class
    • Swoole\Event — The Swoole\Event class
    • Swoole\Exception — The Swoole\Exception class
    • Swoole\Http\Client — The Swoole\Http\Client class
    • Swoole\Http\Request — The Swoole\Http\Request class
    • Swoole\Http\Response — The Swoole\Http\Response class
    • Swoole\Http\Server — The Swoole\Http\Server class
    • Swoole\Lock — The Swoole\Lock class
    • Swoole\Mmap — The Swoole\Mmap class
    • Swoole\MySQL — The Swoole\MySQL class
    • Swoole\MySQL\Exception — The Swoole\MySQL\Exception class
    • Swoole\Process — The Swoole\Process class
    • Swoole\Redis\Server — The Swoole\Redis\Server class
    • Swoole\Serialize — The Swoole\Serialize class
    • Swoole\Server — The Swoole\Server class
    • Swoole\Table — The Swoole\Table class
    • Swoole\Timer — The Swoole\Timer class
    • Swoole\WebSocket\Frame — The Swoole\WebSocket\Frame class
    • Swoole\WebSocket\Server — The Swoole\WebSocket\Server class
  • Tidy
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • tidy — The tidy class
    • tidyNode — The tidyNode class
    • Tidy 函数
  • Tokenizer
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • PhpToken — The PhpToken class
    • Tokenizer 函数
  • URLs
    • 简介
    • 安装／配置
    • 预定义常量
    • URL 函数
  • V8js — V8 Javascript Engine Integration
    • 简介
    • 安装／配置
    • 范例
    • V8Js — The V8Js class
    • V8JsException — The V8JsException class
  • Yaml — YAML 数据序列化
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Callbacks
    • Yaml 函数
  • Yaf — Yet Another Framework
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • 应用配置
    • Yaf_Application — The Yaf_Application class
    • Yaf_Bootstrap_Abstract — The Yaf_Bootstrap_Abstract class
    • Yaf_Dispatcher — Yaf_Dispatcher 类
    • Yaf_Config_Abstract — The Yaf_Config_Abstract class
    • Yaf_Config_Ini — The Yaf_Config_Ini class
    • Yaf_Config_Simple — The Yaf_Config_Simple class
    • Yaf_Controller_Abstract — The Yaf_Controller_Abstract class
    • Yaf_Action_Abstract — The Yaf_Action_Abstract class
    • Yaf_View_Interface — The Yaf_View_Interface class
    • Yaf_View_Simple — The Yaf_View_Simple Class
    • Yaf_Loader — The Yaf_Loader class
    • Yaf_Plugin_Abstract — The Yaf_Plugin_Abstract class
    • Yaf_Registry — The Yaf_Registry class
    • Yaf_Request_Abstract — The Yaf_Request_Abstract class
    • Yaf_Request_Http — The Yaf_Request_Http class
    • Yaf_Request_Simple — The Yaf_Request_Simple class
    • Yaf_Response_Abstract — The Yaf_Response_Abstract class
    • Yaf_Route_Interface — The Yaf_Route_Interface class
    • Yaf_Route_Map — The Yaf_Route_Map class
    • Yaf_Route_Regex — The Yaf_Route_Regex class
    • Yaf_Route_Rewrite — The Yaf_Route_Rewrite class
    • Yaf_Router — The Yaf_Router class
    • Yaf_Route_Simple — The Yaf_Route_Simple class
    • Yaf_Route_Static — The Yaf_Route_Static class
    • Yaf_Route_Supervar — The Yaf_Route_Supervar class
    • Yaf_Session — The Yaf_Session class
    • Yaf_Exception — The Yaf_Exception class
    • Yaf_Exception_TypeError — The Yaf_Exception_TypeError class
    • Yaf_Exception_StartupError — The Yaf_Exception_StartupError class
    • Yaf_Exception_DispatchFailed — The Yaf_Exception_DispatchFailed class
    • Yaf_Exception_RouterFailed — The Yaf_Exception_RouterFailed class
    • Yaf_Exception_LoadFailed — The Yaf_Exception_LoadFailed class
    • Yaf_Exception_LoadFailed_Module — The Yaf_Exception_LoadFailed_Module class
    • Yaf_Exception_LoadFailed_Controller — The Yaf_Exception_LoadFailed_Controller class
    • Yaf_Exception_LoadFailed_Action — The Yaf_Exception_LoadFailed_Action class
    • Yaf_Exception_LoadFailed_View — The Yaf_Exception_LoadFailed_View class
  • Yaconf
    • 简介
    • 安装／配置
    • 预定义常量
    • Yaconf — The Yaconf class
  • Taint
    • 简介
    • 安装／配置
    • More Details
    • Taint 函数
  • Data Structures
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Collection — The Collection interface
    • Hashable — The Hashable interface
    • Sequence — The Sequence interface
    • Vector — The Vector class
    • Deque — The Deque class
    • Map — The Map class
    • Pair — The Pair class
    • Set — The Set class
    • Stack — The Stack class
    • Queue — The Queue class
    • PriorityQueue — The PriorityQueue class


Geo IP 定位

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • GeoIP 函数
    • geoip_asnum_by_name — 获取自治系统号(ASN)
    • geoip_continent_code_by_name — 获取七大洲的大写字母简称
    • geoip_country_code_by_name — 获取国家代码
    • geoip_country_code3_by_name — 获取三个字母组成的国家简称
    • geoip_country_name_by_name — 获取国家的全称
    • geoip_database_info — 获取 GeoIP 数据库的信息
    • geoip_db_avail — GeoIP 数据库是否可用
    • geoip_db_filename — 返回 GeoIP 数据库相对应的文件名
    • geoip_db_get_all_info — 返回所有 GeoIP 数据库类型的详细信息
    • geoip_domain_by_name — 获取二级域名
    • geoip_id_by_name — 获取网络连接类型
    • geoip_isp_by_name — 获取 ISP (网络服务提供商)的名称
    • geoip_netspeedcell_by_name — 获取网络连接速度
    • geoip_org_by_name — 获取机构的名称
    • geoip_record_by_name — 返回 GeoIP 数据库中详细的城市信息
    • geoip_region_by_name — 获取国家和地区代码
    • geoip_region_name_by_code — 返回给定的国家和地区代码组合所对应的地区名称
    • geoip_setup_custom_directory — 自定义 GeoIP 数据库的目录
    • geoip_time_zone_by_country_and_region — 返回国家和地区的时区


简介

GeoIP 扩展可以通过 IP 地址来确定地理位置。比如城市、州、国家、经度、纬度以及其他信息，比如 ISP (因特网服务提供商)和网络连接类型。


需求

这个扩展要求系统安装了 GeoIP C 语言库的1.4.0及以上版本。可通过以下链接 » http://www.maxmind.com/app/c 下载编译该库。

默认情况下只能使用免费的 GeoIP Country 或者 GeoLite City 的数据库。然而这个模块可以使用其他类型的数据库，但必须从以下链接购买商业许可 » Maxmind.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/geoip.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

GeoIP 配置选项
名字 | 默认 | 可修改范围 | 更新日志
geoip.custom_directory | "" | PHP_INI_ALL |

这是配置指令的简短说明。

geoip.custom_directory string

默认为空，但是可以设置一个不同的数据库来覆盖该扩展自带的数据库。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

GEOIP_COUNTRY_EDITION (integer)
GEOIP_REGION_EDITION_REV0 (integer)
GEOIP_CITY_EDITION_REV0 (integer)
GEOIP_ORG_EDITION (integer)
GEOIP_ISP_EDITION (integer)
GEOIP_CITY_EDITION_REV1 (integer)
GEOIP_REGION_EDITION_REV1 (integer)
GEOIP_PROXY_EDITION (integer)
GEOIP_ASNUM_EDITION (integer)
GEOIP_NETSPEED_EDITION (integer)
GEOIP_DOMAIN_EDITION (integer)

以下常量是用来表示网速的:

GEOIP_UNKNOWN_SPEED (integer)
GEOIP_DIALUP_SPEED (integer)
GEOIP_CABLEDSL_SPEED (integer)
GEOIP_CORPORATE_SPEED (integer)


GeoIP 函数

Table of Contents

  • geoip_asnum_by_name — 获取自治系统号(ASN)
  • geoip_continent_code_by_name — 获取七大洲的大写字母简称
  • geoip_country_code_by_name — 获取国家代码
  • geoip_country_code3_by_name — 获取三个字母组成的国家简称
  • geoip_country_name_by_name — 获取国家的全称
  • geoip_database_info — 获取 GeoIP 数据库的信息
  • geoip_db_avail — GeoIP 数据库是否可用
  • geoip_db_filename — 返回 GeoIP 数据库相对应的文件名
  • geoip_db_get_all_info — 返回所有 GeoIP 数据库类型的详细信息
  • geoip_domain_by_name — 获取二级域名
  • geoip_id_by_name — 获取网络连接类型
  • geoip_isp_by_name — 获取 ISP (网络服务提供商)的名称
  • geoip_netspeedcell_by_name — 获取网络连接速度
  • geoip_org_by_name — 获取机构的名称
  • geoip_record_by_name — 返回 GeoIP 数据库中详细的城市信息
  • geoip_region_by_name — 获取国家和地区代码
  • geoip_region_name_by_code — 返回给定的国家和地区代码组合所对应的地区名称
  • geoip_setup_custom_directory — 自定义 GeoIP 数据库的目录
  • geoip_time_zone_by_country_and_region — 返回国家和地区的时区


获取自治系统号(ASN)

  • ? GeoIP 函数
  • geoip_continent_code_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取自治系统号(ASN)

geoip_asnum_by_name

(PECL geoip >= 1.1.0)

geoip_asnum_by_name — 获取自治系统号(ASN)

说明

geoip_asnum_by_name ( string $hostname ) : string

geoip_asnum_by_name() 函数将会返回和 IP 地址相关联的自治系统号(ASN)。

参数

hostname

主机的 IP 地址。

返回值

如果成功将会返回自治系统号，如果在数据库中未找到相关信息则返回 false 。

范例

Example #1 geoip_asnum_by_name()函数的范例：

以下代码将会输出 www.example.com 域名的 ASN。

<?php
$asn = geoip_asnum_by_name('www.example.com');

if ($asn) {
    echo 'The ASN is: ' $asn;
}
?>

以上例程会输出：

The ASN is: AS15133 EdgeCast Networks, Inc


获取七大洲的大写字母简称

  • ? geoip_asnum_by_name
  • geoip_country_code_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取七大洲的大写字母简称

geoip_continent_code_by_name

(PECL geoip >= 1.0.3)

geoip_continent_code_by_name — 获取七大洲的大写字母简称

说明

geoip_continent_code_by_name ( string $hostname ) : string

geoip_continent_code_by_name() 函数将会返回主机或者IP地址相对应的七大洲大写字母简称。

参数

hostname

所要定位的主机或IP地址。

返回值

成功，返回两个大写字母组成的七大洲简称字符串, 如果在数据库中未找到相关信息则返回 false 。

洲代码
Code | 洲名
AF | 非洲
AN | 南极洲
AS | 亚洲
EU | 欧洲
NA | 北美洲
OC | 大洋洲
SA | 南美洲

范例

Example #1 geoip_continent_code_by_name() 函数的使用范例：

以下代码将会打印 example.com 的定位信息。

<?php
$continent = geoip_continent_code_by_name('www.example.com');
if ($continent) {
    echo 'This host is located in: ' . $continent;
}
?>

以上例程会输出：

 This host is located in: NA

参见

  • geoip_country_code_by_name() - 获取国家代码


获取国家代码

  • ? geoip_continent_code_by_name
  • geoip_country_code3_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取国家代码

geoip_country_code_by_name

(PECL geoip >= 0.2.0)

geoip_country_code_by_name — 获取国家代码

说明

geoip_country_code_by_name ( string $hostname ) : string

geoip_country_code_by_name() 函数将会返回主机或者IP地址所在的国家代码。

参数

hostname

定位的主机名或者IP地址。

返回值

成功，返回 ISO 定义的国家代码，如果在数据库中未找到相关信息则返回 false 。

范例

Example #1 geoip_country_code_by_name() 函数的范例：

以下代码将会打印 example.com 主机的定位信息。

<?php
$country = geoip_country_code_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

以上例程会输出：

This host is located in: US

注释

Caution

请点击 » http://www.maxmind.com/en/iso3166 来查看所有可能的返回值列表，包括特殊代码。

参见

  • geoip_country_code3_by_name() - 获取三个字母组成的国家简称
  • geoip_country_name_by_name() - 获取国家的全称


获取三个字母组成的国家简称

  • ? geoip_country_code_by_name
  • geoip_country_name_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取三个字母组成的国家简称

geoip_country_code3_by_name

(PECL geoip >= 0.2.0)

geoip_country_code3_by_name — 获取三个字母组成的国家简称

说明

geoip_country_code3_by_name ( string $hostname ) : string

geoip_country_code3_by_name() 函数返回由三个字母组成和主机或者 IP 相对应的国家代码。

参数

hostname

定位所用的主机名或者 IP 地址。

返回值

成功，返回由三个字母组成的国家简称，如果在数据库中未找到相关信息则返回 false 。

范例

Example #1 geoip_country_code3_by_name() 函数的使用范例：

以下代码将会打印 example.com 主机的定位信息。

<?php
$country = geoip_country_code3_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

以上例程会输出：

This host is located in: USA

参见

  • geoip_country_code_by_name() - 获取国家代码
  • geoip_country_name_by_name() - 获取国家的全称


获取国家的全称

  • ? geoip_country_code3_by_name
  • geoip_database_info ?
  • PHP Manual
  • GeoIP 函数
  • 获取国家的全称

geoip_country_name_by_name

(PECL geoip >= 0.2.0)

geoip_country_name_by_name — 获取国家的全称

说明

geoip_country_name_by_name ( string $hostname ) : string

geoip_country_name_by_name() 函数返回主机或者 IP 地址所对应的国家名全称。

参数

hostname

定位所用的主机或者 IP 地址。

返回值

成功，返回国家全称，如果在数据库中未找到相关信息则返回 false 。

范例

Example #1 geoip_country_name_by_name() 函数的使用范例：

以下代码将会打印 example.com 主机的定位信息。

<?php
$country = geoip_country_name_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

以上例程会输出：

 This host is located in: United States

参见

  • geoip_country_code_by_name() - 获取国家代码
  • geoip_country_code3_by_name() - 获取三个字母组成的国家简称


获取 GeoIP 数据库的信息

  • ? geoip_country_name_by_name
  • geoip_db_avail ?
  • PHP Manual
  • GeoIP 函数
  • 获取 GeoIP 数据库的信息

geoip_database_info

(PECL geoip >= 0.2.0)

geoip_database_info — 获取 GeoIP 数据库的信息

说明

geoip_database_info ( int $database = GEOIP_COUNTRY_EDITION ) : string

geoip_database_info() 函数返回 GeoIP 数据库版本的信息。

如果无参调用该函数，则返回 GeoIP 免费国家版的版本信息。

参数

database

该变量的类型为整型。你可以使用该扩展的预定义常量(类似: GEOIP_*_EDITION)。

返回值

如果成功，返回数据库的版本信息，错误则返回null 。

范例

Example #1 geoip_database_info() 函数的使用范例：

以下代码将会输出数据库的相关信息。

<?php
print geoip_database_info(GEOIP_COUNTRY_EDITION);
?>

以上例程会输出：

GEO-106FREE 20060801 Build 1 Copyright (c) 2006 MaxMind LLC All Rights Reserved


GeoIP 数据库是否可用

  • ? geoip_database_info
  • geoip_db_filename ?
  • PHP Manual
  • GeoIP 函数
  • GeoIP 数据库是否可用

geoip_db_avail

(PECL geoip >= 1.0.1)

geoip_db_avail — GeoIP 数据库是否可用

说明

geoip_db_avail ( int $database ) : bool

geoip_db_avail() 函数返回 GeoI P数据库是否可以在磁盘上打开并且可用。

该函数不能用来判断是否是个合适的数据库，除非这个数据库可读。

参数

database

变量类型为整型。你可以使用该扩展的预定义常量(比如: GEOIP_*_EDITION)。

返回值

如果存在则返回 true , 未找到则返回 false , 错误则返回 null 。

范例

Example #1 geoip_db_avail() 函数的使用范例：

以下代码将会输出当前数据库的版本信息。

<?php

if (geoip_db_avail(GEOIP_COUNTRY_EDITION))
    print geoip_database_info(GEOIP_COUNTRY_EDITION);
?>

以上例程会输出：

GEO-106FREE 20080801 Build 1 Copyright (c) 2006 MaxMind LLC All Rights Reserved


返回 GeoIP 数据库相对应的文件名

  • ? geoip_db_avail
  • geoip_db_get_all_info ?
  • PHP Manual
  • GeoIP 函数
  • 返回 GeoIP 数据库相对应的文件名

geoip_db_filename

(PECL geoip >= 1.0.1)

geoip_db_filename — 返回 GeoIP 数据库相对应的文件名

说明

geoip_db_filename ( int $database ) : string

geoip_db_filename() 函数将会返回和 GeoIP 数据库相对应的文件名。

这个函数不会判别文件是否存在在磁盘上，只会表明拓展库在哪里查找数据库。

参数

database

该参数为整型。你可以使用该扩展的预定义常量 (比如: GEOIP_*_EDITION)。

返回值

成功则返回相对应的数据库文件名，错误则返回null 。

范例

Example #1 geoip_db_filename()函数的使用范例：

如下代码将会打印数据库相对应的文件名。

<?php

print geoip_db_filename(GEOIP_COUNTRY_EDITION);

?>

以上例程会输出：

/usr/share/GeoIP/GeoIP.dat


返回所有 GeoIP 数据库类型的详细信息

  • ? geoip_db_filename
  • geoip_domain_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 返回所有 GeoIP 数据库类型的详细信息

geoip_db_get_all_info

(PECL geoip >= 1.0.1)

geoip_db_get_all_info — 返回所有 GeoIP 数据库类型的详细信息

说明

geoip_db_get_all_info ( ) : array

geoip_db_get_all_info() 函数将会返回包含所有 GeoIP 数据库类型详细信息的多维数组

即使没有安装数据库，这个函数依旧可用。它将会列出数据库是否可用。

返回的关联数组，各键值所代表的含义如下：

  • "available" -- 布尔值, 表示数据库是否可用(请参考 geoip_db_avail())
  • "description" -- 数据库的描述
  • "filename" -- 磁盘上的数据库文件名(请参考 geoip_db_filename())

返回值

返回一个关联数组。

范例

Example #1 geoip_db_get_all_info() 使用范例：

以下代码将会打印包含所有信息的数组。

<?php
$infos = geoip_db_get_all_info();
if (is_array($infos)) {
    var_dump($infos);
}
?>

以上例程会输出：

array(11) {
  [1]=>
  array(3) {
    ["available"]=>
    bool(true)
    ["description"]=>
    string(21) "GeoIP Country Edition"
    ["filename"]=>
    string(32) "/usr/share/GeoIP/GeoIP.dat"
  }

[ ... ]

  [11]=>
  array(3) {
    ["available"]=>
    bool(false)
    ["description"]=>
    string(25) "GeoIP Domain Name Edition"
    ["filename"]=>
    string(38) "/usr/share/GeoIP/GeoIPDomain.dat"
  }
}

Example #2 geoip_db_get_all_info() 使用范例：

你可以使用不同的常量作为键来获取部分信息。

<?php
$infos = geoip_db_get_all_info();
if ($infos[GEOIP_COUNTRY_EDITION]['available']) {
    echo $infos[GEOIP_COUNTRY_EDITION]['description'];
}
?>

以上例程会输出：

GeoIP Country Edition


获取二级域名

  • ? geoip_db_get_all_info
  • geoip_id_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取二级域名

geoip_domain_by_name

(PECL geoip >= 1.1.0)

geoip_domain_by_name — 获取二级域名

说明

geoip_domain_by_name ( string $hostname ) : string

geoip_domain_by_name() 函数将会返回和主机或者 IP 地址相关联的二级域名。

当前该函数只对购买了商业 GeoIP 域名版本的用户是可用的。如果没有该版本的数据库，使用该函数时将会抛出一个警告。

参数

hostname

主机名或者 IP 地址。

返回值

成功，返回域名，如果在数据库中未找到信息则返回 false 。

范例

Example #1 一个 geoip_domain_by_name() 使用范例：

以下代码将会输出和 IP 61.106.139.1相关联的域名。

<?php
$domain = geoip_domain_by_name('61.106.139.1');

if ($domain) {
    echo 'The domain is: '. $domain;
}

?>

以上例程会输出：

The domain is: von.co.kr


获取网络连接类型

  • ? geoip_domain_by_name
  • geoip_isp_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取网络连接类型

geoip_id_by_name

(PECL geoip >= 0.2.0)

geoip_id_by_name — 获取网络连接类型

说明

geoip_id_by_name ( string $hostname ) : int

geoip_id_by_name() 函数将会返回和主机名或者 IP 地址相对应的网络连接类型。

函数返回值是数字可以和以下常量对照：

  • GEOIP_UNKNOWN_SPEED
  • GEOIP_DIALUP_SPEED
  • GEOIP_CABLEDSL_SPEED
  • GEOIP_CORPORATE_SPEED

参数

hostname

要查找连接类型的主机或者 IP 地址。

返回值

返回连接类型。

范例

Example #1 一个 geoip_id_by_name() 使用范例：

以下将会输出 example.com 主机的连接类型。

<?php
$netspeed = geoip_id_by_name('www.example.com');

echo 'The connection type is ';

switch ($netspeed) {
    case GEOIP_DIALUP_SPEED:
        echo 'dial-up';
        break;
    case GEOIP_CABLEDSL_SPEED:
        echo 'cable or DSL';
        break;
    case GEOIP_CORPORATE_SPEED:
        echo 'corporate';
        break;
    case GEOIP_UNKNOWN_SPEED:
    default:
        echo 'unknown';
}
?>

以上例程会输出：

The connection type is corporate


获取 ISP (网络服务提供商)的名称

  • ? geoip_id_by_name
  • geoip_netspeedcell_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取 ISP (网络服务提供商)的名称

geoip_isp_by_name

(PECL geoip >= 1.0.2)

geoip_isp_by_name — 获取 ISP (网络服务提供商)的名称

说明

geoip_isp_by_name ( string $hostname ) : string

geoip_isp_by_name() 函数将会返回 IP 地址所归属的网络服务提供商(ISP)的名称。

目前，该函数只对购买了商业 GeoIP ISP 版本的用户可用，否则将会抛出一个警告！

参数

hostname

主机或者 IP 地址。

返回值

成功，则返回 ISP 名称，未找到相关信息则返回 false 。

范例

Example #1 一个 geoip_isp_by_name() 使用范例：

以下代码将会输出 example.com 主机的 ISP 名称。

<?php
$isp = geoip_isp_by_name('www.example.com');
if ($isp) {
    echo 'This host IP is from ISP: ' . $isp;
}
?>

以上例程会输出：

This host IP is from ISP: ICANN c/o Internet Assigned Numbers Authority


获取网络连接速度

  • ? geoip_isp_by_name
  • geoip_org_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取网络连接速度

geoip_netspeedcell_by_name

(PECL geoip >= 1.1.0)

geoip_netspeedcell_by_name — 获取网络连接速度

说明

geoip_netspeedcell_by_name ( string $hostname ) : string

geoip_netspeedcell_by_name() 函数将会返回主机或者 IP 地址对应的网络连接类型和速度。

该函数只有在 GeoIP 1.4.8 版本以上才能使用。

目前，该函数只对购买了商业 GeoIP NetSpeedCell 版本的用户可用，否则将会抛出一个警告！

返回值为字符串，结果集如下：

  • Cable/DSL
  • Dialup
  • Cellular
  • Corporate

参数

hostname

主机名或者 IP 地址。

返回值

成功，返回连接速度，未找到相关信息则返回 false 。

范例

Example #1 一个 geoip_netspeedcell_by_name() 使用范例：

以下代码将会输出 example.com 主机的连接速度。

<?php
$netspeed = geoip_netspeedcell_by_name('www.example.com');

if ($netspeed) {
    echo 'The connection type is: '. $netspeed;
}
?>

以上例程会输出：

The connection type is: Corporate


获取机构的名称

  • ? geoip_netspeedcell_by_name
  • geoip_record_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 获取机构的名称

geoip_org_by_name

(PECL geoip >= 0.2.0)

geoip_org_by_name — 获取机构的名称

说明

geoip_org_by_name ( string $hostname ) : string

geoip_org_by_name() 函数将会返回 IP 地址所分配的机构名称。

目前，该函数只对购买了商业 GeoIP Organization， ISP 或者 AS 版本的用户可用，否则将会抛出一个警告！

参数

hostname

主机名或者 IP 地址。

返回值

成功， 返回组织的名称，未找到相关信息则返回 false 。

范例

Example #1 一个 geoip_org_by_name() 使用范例：

以下代码将会打印 example.com 主机的所有者。

<?php
$org = geoip_org_by_name('www.example.com');
if ($org) {
    echo 'This host IP is allocated to: ' . $org;
}
?>

以上例程会输出：

This host IP is allocated to: ICANN c/o Internet Assigned Numbers Authority


返回 GeoIP 数据库中详细的城市信息

  • ? geoip_org_by_name
  • geoip_region_by_name ?
  • PHP Manual
  • GeoIP 函数
  • 返回 GeoIP 数据库中详细的城市信息

geoip_record_by_name

(PECL geoip >= 0.2.0)

geoip_record_by_name — 返回 GeoIP 数据库中详细的城市信息

说明

geoip_record_by_name ( string $hostname ) : array

geoip_record_by_name() 函数将会返回主机或者 IP 地址所对应的记录信息。

该函数在 GeoLite City 版本和商业 GeoIP City 版本中可用。 版本不对的话，将会抛出一个警告。

返回的关联数组不同的键名对应如下：

  • "continent_code" -- 由两个字符组成的洲简称。(要求 GeoIP 的库版本是1.0.4以上)
  • "country_code" -- 由2个字母组成的国家简称。(参见 geoip_country_code_by_name())
  • "country_code3" -- 由三个字母组成的国家简称。(参见 geoip_country_code3_by_name())
  • "country_name" -- 国家名称 (参见 geoip_country_name_by_name())
  • "region" -- 地区代码 (比如: CA 对应 California)
  • "city" -- 城市名称。
  • "postal_code" -- 邮编，FSA 或者 Zip 编码。
  • "latitude" -- 有符号的双精度纬度。
  • "longitude" -- 有符号的双精度经度。
  • "dma_code" -- 指定市场区号 (只支持美国和加拿大)
  • "area_code" -- PSTN （公共交换电话网络）地区代码。 (比如: 212)

参数

hostname

所要查找的主机或者 IP 地址。

返回值

成功，返回关联数组，未找到相关信息则返回 false 。

更新日志

版本 | 说明
1.0.4 | 给 GeoIP 1.4.4及以上版本的库添加 continent_code 字段。
1.0.3 | 添加 country_code3 和 country_name 字段。

范例

Example #1 geoip_record_by_name() 例子：

以下例程将会输出包含 example.com 主机记录的数组。

<?php
$record = geoip_record_by_name('www.example.com');
if ($record) {
    print_r($record);
}
?>

以上例程会输出：

Array
(
    [continent_code] => NA
    [country_code] => US
    [country_code3] => USA
    [country_name] => United States
    [region] => CA
    [city] => Marina Del Rey
    [postal_code] =>
    [latitude] => 33.9776992798
    [longitude] => -118.435096741
    [dma_code] => 803
    [area_code] => 310
)


获取国家和地区代码

  • ? geoip_record_by_name
  • geoip_region_name_by_code ?
  • PHP Manual
  • GeoIP 函数
  • 获取国家和地区代码

geoip_region_by_name

(PECL geoip >= 0.2.0)

geoip_region_by_name — 获取国家和地区代码

说明

geoip_region_by_name ( string $hostname ) : array

geoip_region_by_name() 函数将会返回与主机或者 IP 地址相关的国家和地区代码。

该函数只对购买了商业 GeoIP Region 版本的用户可用。否则将会抛出一个警告！

所返回的关联数组的各字段具体含义如下：

  • "country_code" -- 由两个字母组成的国家代码(参见 geoip_country_code_by_name())
  • "region" -- 地区代码。 (比如: CA 对应 California)

参数

hostname

查找的主机或者 IP 地址。

返回值

成功，返回关联数组， 如果信息未找到则返回 false。

范例

Example #1 geoip_region_by_name() 例子：

以下例程将会打印对应 example.com 主机的包含国家和地区代码的关联数组。

<?php
$region = geoip_region_by_name('www.example.com');
if ($region) {
    print_r($region);
}
?>

以上例程会输出：

Array
(
    [country_code] => US
    [region] => CA
)


返回给定的国家和地区代码组合所对应的地区名称

  • ? geoip_region_by_name
  • geoip_setup_custom_directory ?
  • PHP Manual
  • GeoIP 函数
  • 返回给定的国家和地区代码组合所对应的地区名称

geoip_region_name_by_code

(PECL geoip >= 1.0.4)

geoip_region_name_by_code — 返回给定的国家和地区代码组合所对应的地区名称

说明

geoip_region_name_by_code ( string $country_code , string $region_code ) : string

geoip_region_name_by_code() 函数将会返回与给定的国家和地区代码组合相对应的地区名称。

在美国，地区代码是每个州对应的两个字母的缩写，而在加拿大，则是由两个字母组成的每个省的邮政编码。

在世界其他地区，GeoIP使用 FIPS 给定的10到4位的代码来表示各地区。你可以点击以下连接 » http://www.maxmind.com/app/fips10_4 查看详细信息。

该函数只在 GeoIP 1.4.1版本以上的库才可用。并且结果集的数据来源是直接从 GeoIP 库中获取的，而不是从任何数据库中。

参数

country_code

由两个字母组成的国家代码 (参见 geoip_country_code_by_name())

region_code

由两个字母组成的地区代码 (参见 geoip_region_by_name())

返回值

成功，返回地区名字，如果相关信息未找到则返回 false 。

范例

Example #1 geoip_region_name_by_code() 使用美国和加拿大地区的范例。

以下例程将会打印国家简称为 CA (加拿大)，地区简称为 QC (魁北克)的地区名：

<?php
$region = geoip_region_name_by_code('CA', 'QC');
if ($region) {
    echo 'Region name for CA/QC is: ' . $region;
}
?>

以上例程会输出：

Region name for CA/QC is: Quebec

Example #2 geoip_region_name_by_code() 使用 FIPS 代码的范例：

以下例程将会打印国家简称为 JP (日本)地区代码为 01的地区名称。

<?php
$region = geoip_region_name_by_code('JP', '01');
if ($region) {
    echo 'Region name for JP/01 is: ' . $region;
}
?>

以上例程会输出：

Region name for JP/01 is: Aichi


自定义 GeoIP 数据库的目录

  • ? geoip_region_name_by_code
  • geoip_time_zone_by_country_and_region ?
  • PHP Manual
  • GeoIP 函数
  • 自定义 GeoIP 数据库的目录

geoip_setup_custom_directory

(PECL geoip >= 1.1.0)

geoip_setup_custom_directory — 自定义 GeoIP 数据库的目录

说明

geoip_setup_custom_directory ( string $path ) : void

geoip_setup_custom_directory() 函数将会更改 GeoIP 数据库的默认目录。这个设置和直接在 php 配置文件中设置的geoip.custom_directory参数效果是一样的。

参数

path

磁盘上 GeoIP 数据库的绝对路径。

返回值

没有返回值。

范例

Example #1 geoip_setup_custom_directory() 例子：

以下例程将会更改 GeoIP 默认数据库的路径。

<?php

geoip_setup_custom_directory('/some/other/path');

print geoip_db_filename(GEOIP_COUNTRY_EDITION);

?>

以上例程会输出：

/some/other/path/GeoIP.dat


返回国家和地区的时区

  • ? geoip_setup_custom_directory
  • FANN ?
  • PHP Manual
  • GeoIP 函数
  • 返回国家和地区的时区

geoip_time_zone_by_country_and_region

(PECL geoip >= 1.0.4)

geoip_time_zone_by_country_and_region — 返回国家和地区的时区

说明

geoip_time_zone_by_country_and_region ( string $country_code , string $region_code = ? ) : string

geoip_time_zone_by_country_and_region() 函数将会返回与国家或者地区相对应的时区。

在美国，地区代码是每个州对应的两个字母的缩写，而在加拿大，则是由两个字母组成的每个省的邮政编码。

在世界上其他地区，GeoIP 使用 FIPS 给定的10到4位的代码来表示各地区。你可以点击以下连接 » http://www.maxmind.com/app/fips10_4 查看详细信息。

该函数只在 GeoIP 1.4.1版本以上的库才可用。并且结果集的数据来源是直接从 GeoIP 库中获取的，而不是从任何数据库中。

参数

country_code

由两个字母组成的国家代码 (参见 geoip_country_code_by_name())

region_code

由两个字母组成的地区代码 (参见 geoip_region_by_name())

返回值

成功，返回地区名字，如果相关信息未找到则返回 false 。

范例

Example #1 geoip_time_zone_by_country_and_region() 使用美国和加拿大地区的范例：

以下例程将会打印国家简称为 CA (加拿大)，地区简称为 QC (魁北克)的时区。

<?php
$timezone = geoip_time_zone_by_country_and_region('CA', 'QC');
if ($timezone) {
    echo 'Time zone for CA/QC is: ' . $timezone;
}
?>

以上例程会输出：

Time zone for CA/QC is: America/Montreal

Example #2 geoip_time_zone_by_country_and_region() 使用 FIPS 代码的范例：

以下例程将会打印国家简称为 JP (日本),地区代码为 01的时区。

<?php
$timezone = geoip_time_zone_by_country_and_region('JP', '01');
if ($timezone) {
    echo 'Time zone for JP/01 is: ' . $timezone;
}
?>

以上例程会输出：

Time zone for JP/01 is: Asia/Tokyo


FANN (快速人工神经网络)

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • XOR (异或)训练
  • Fann 函数
    • fann_cascadetrain_on_data — 在整个数据集上训练，使用一段时间的 Cascade2 训练算法。
    • fann_cascadetrain_on_file — 读取文件并在整个数据集上训练，使用 Cascade2 训练算法训练一段时间。
    • fann_clear_scaling_params — 清除缩放参数
    • fann_copy — 创建一个 fann 结构体的副本。
    • fann_create_from_file — 从配置文件中构建一个反向传播神经网络。
    • fann_create_shortcut_array — 创建一个含快捷连接而非全连接的标准反向传播神经网络。
    • fann_create_shortcut — 创建一个含快捷连接而非全连接的标准反向传播神经网络。
    • fann_create_sparse_array — 创建一个标准的反向传播神经网络，该网络使用一个表示每层大小的数组来构造，但是并不是全连接的。
    • fann_create_sparse — 创建一个标准的反向传播神经网络，该网络不是全连接。
    • fann_create_standard_array — 创建一个全连接的反向传播神经网络，该网络使用一个表示每层大小的数组来构造。
    • fann_create_standard — 创建标准的全连接反向传播神经网络。
    • fann_create_train_from_callback — 从用户提供的函数创建训练数据结构。
    • fann_create_train — 创建一个空的训练数据结构。
    • fann_descale_input — 在获取基于先前计算的参数之后，在输入向量中缩小数据
    • fann_descale_output — 在获取基于先前计算的参数之后，在输出向量中缩小数据
    • fann_descale_train — 基于先前计算的参数来缩小输入和输出数据
    • fann_destroy_train — 销毁训练数据。
    • fann_destroy — 销毁整个网络并且适当地释放所有的关联内存。
    • fann_duplicate_train_data — 返回 fann 训练数据精确的副本。
    • fann_get_activation_function — 返回激励函数
    • fann_get_activation_steepness — 为提供的神经和网络层数返回激活陡度
    • fann_get_bias_array — 获取网络中每一层的偏差数
    • fann_get_bit_fail_limit — 返回训练期间使用的误差限制
    • fann_get_bit_fail — 失败位的数量
    • fann_get_cascade_activation_functions_count — 返回级联激活函数的数量
    • fann_get_cascade_activation_functions — 返回级联激活函数
    • fann_get_cascade_activation_steepnesses_count — 激活陡度的数量
    • fann_get_cascade_activation_steepnesses — 返回级联激活陡度
    • fann_get_cascade_candidate_change_fraction — 返回级联候选变化分数
    • fann_get_cascade_candidate_limit — 返回候选限度
    • fann_get_cascade_candidate_stagnation_epochs — 返回层叠候选停滞周期的数量
    • fann_get_cascade_max_cand_epochs — 返回候选周期的最大值
    • fann_get_cascade_max_out_epochs — 返回输出周期的最大值
    • fann_get_cascade_min_cand_epochs — 返回最小的候选周期
    • fann_get_cascade_min_out_epochs — 返回最小输出周期
    • fann_get_cascade_num_candidate_groups — 返回候选组的数量
    • fann_get_cascade_num_candidates — 返回训练期间使用的候选数量
    • fann_get_cascade_output_change_fraction — 返回级联输出变化分数
    • fann_get_cascade_output_stagnation_epochs — 返回级联输出停滞周期的数量
    • fann_get_cascade_weight_multiplier — 返回权重因子
    • fann_get_connection_array — 获取网络中的连接。
    • fann_get_connection_rate — 获取当网络创建时连接的使用率。
    • fann_get_errno — 返回最后一个错误数字。
    • fann_get_errstr — 返回最后的错误字符串。
    • fann_get_layer_array — 获取网络中每层的神经元数量。
    • fann_get_learning_momentum — 返回学习动量
    • fann_get_learning_rate — 返回学习速率
    • fann_get_MSE — 从网络中读取均方误差。
    • fann_get_network_type — 获取所创建的神经网络类型。
    • fann_get_num_input — 获取输入神经元的数量。
    • fann_get_num_layers — 获取神经网络的层数。
    • fann_get_num_output — 获取输出神经元的数量。
    • fann_get_quickprop_decay — 返回衰退值，用于在 quickprop 训练迭代时衰减权重
    • fann_get_quickprop_mu — 返回放大系数
    • fann_get_rprop_decrease_factor — 返回 RPROP 训练期间的衰减系数
    • fann_get_rprop_delta_max — 返回最大步长
    • fann_get_rprop_delta_min — 返回最小步长
    • fann_get_rprop_delta_zero — 返回初始步长
    • fann_get_rprop_increase_factor — 返回 RPROP 训练的递增系数
    • fann_get_sarprop_step_error_shift — 返回 sarprop 步值的误差偏移
    • fann_get_sarprop_step_error_threshold_factor — 返回 sarprop 算法步值的误差阈值系数
    • fann_get_sarprop_temperature — 返回 sarprop 算法温度
    • fann_get_sarprop_weight_decay_shift — 返回 sarprop 算法权重衰减变化值
    • fann_get_total_connections — 获取整个网络中所有的连接数。
    • fann_get_total_neurons — 获取整个网络中神经元的数量。
    • fann_get_train_error_function — 返回训练中使用的错误函数。
    • fann_get_train_stop_function — 返回训练中使用的停止函数。
    • fann_get_training_algorithm — 返回训练算法。
    • fann_init_weights — 使用 Widrow 和 Nguyen 算法初始化权重。
    • fann_length_train_data — 返回训练数据中训练模式的数量。
    • fann_merge_train_data — 合并训练数据。
    • fann_num_input_train_data — 返回训练数据中每个训练模式输入的数量。
    • fann_num_output_train_data — 返回训练数据中每个训练模式输出的数量。
    • fann_print_error — 打印错误字符串。
    • fann_randomize_weights — 给每个连接赋一个介于 min_weight 和 max_weight 之间的随机权重。
    • fann_read_train_from_file — 读取存储训练数据的文件。
    • fann_reset_errno — 重置最后的错误代码。
    • fann_reset_errstr — 重置最后的错误字符串。
    • fann_reset_MSE — 重置网络中的均方误差。
    • fann_run — 将通过神经网络运行输入。
    • fann_save_train — 将训练结构体保存至文件。
    • fann_save — 将整个网络保存至配置文件。
    • fann_scale_input_train_data — 在训练数据中缩放输入至指定范围
    • fann_scale_input — 在以前计算参数的基础上，在训练之前放大输入向量中的数据
    • fann_scale_output_train_data — 在训练数据中缩放输出至指定范围
    • fann_scale_output — 在以前计算参数的基础上，在训练之前放大输出向量中的数据
    • fann_scale_train_data — 在训练数据中缩放输入和输出到指定的范围
    • fann_scale_train — 在以前计算参数的基础上，缩放输入和输出数据
    • fann_set_activation_function_hidden — 为所有隐藏层设置激活函数
    • fann_set_activation_function_layer — 为已应用的层中所有的神经元设置激活函数。
    • fann_set_activation_function_output — 为输出层设置激活函数
    • fann_set_activation_function — 为已应用的神经元和层设置激活函数
    • fann_set_activation_steepness_hidden — 为所有隐藏层中所有的神经元设置激活函数陡度
    • fann_set_activation_steepness_layer — 为提供的层中所有的神经元设置激活陡度
    • fann_set_activation_steepness_output — 在输出层中设置激活陡度
    • fann_set_activation_steepness — 为提供的神经元和层设置激活陡度
    • fann_set_bit_fail_limit — 设置训练期间使用的误差
    • fann_set_callback — 设置训练期间使用的回调函数。
    • fann_set_cascade_activation_functions — 设置级联候选激活函数的数组
    • fann_set_cascade_activation_steepnesses — 设置级联候选激活陡度的数组。
    • fann_set_cascade_candidate_change_fraction — 设置级联候选更改分数
    • fann_set_cascade_candidate_limit — 设置候选限度
    • fann_set_cascade_candidate_stagnation_epochs — 设置级联候选停止周期数
    • fann_set_cascade_max_cand_epochs — 设置最大候选周期数
    • fann_set_cascade_max_out_epochs — 设置最大输出周期
    • fann_set_cascade_min_cand_epochs — 设置最小候选周期
    • fann_set_cascade_min_out_epochs — 设置最小输出周期
    • fann_set_cascade_num_candidate_groups — 设置候选组数量
    • fann_set_cascade_output_change_fraction — 设置级联输出改变分数
    • fann_set_cascade_output_stagnation_epochs — 设置级联输出停滞周期的值
    • fann_set_cascade_weight_multiplier — 设置权重因子
    • fann_set_error_log — 设置错误记录保存的位置。
    • fann_set_input_scaling_params — 根据训练数据计算将来使用的输入比例参数
    • fann_set_learning_momentum — 设置学习动量。
    • fann_set_learning_rate — 设置学习速率。
    • fann_set_output_scaling_params — 根据训练数据计算将来使用的输出缩放参数
    • fann_set_quickprop_decay — 设置quickprop算法衰减因子
    • fann_set_quickprop_mu — 设置 quickprop 算法放大因子
    • fann_set_rprop_decrease_factor — 使用 RPROP 算法训练时，设置下降因子
    • fann_set_rprop_delta_max — 设置最大步长
    • fann_set_rprop_delta_min — 设置最小步长
    • fann_set_rprop_delta_zero — 设置初始步长
    • fann_set_rprop_increase_factor — 使用 RPROP 算法训练时，设置增长因子
    • fann_set_sarprop_step_error_shift — 设置 sarprop 算法的步误差偏移量
    • fann_set_sarprop_step_error_threshold_factor — 设置 sarprop 算法的步误差阈值因子
    • fann_set_sarprop_temperature — 设置 sarprop 算法的温度
    • fann_set_sarprop_weight_decay_shift — 设置 sarprop 算法的权重衰减偏移值
    • fann_set_scaling_params — 根据训练数据计算输入和输出缩放参数以供将来使用
    • fann_set_train_error_function — 设置训练期间使用的错误函数。
    • fann_set_train_stop_function — 设置训练期间使用的停止函数。
    • fann_set_training_algorithm — 设置训练算法。
    • fann_set_weight_array — 在网络中设置一个连接。
    • fann_set_weight — 在网络中设置一个连接。
    • fann_shuffle_train_data — 打算训练数据，使顺序随机。
    • fann_subset_train_data — 返回一个训练数据子集的副本。
    • fann_test_data — 使用训练数据来测试并且计算出 MSE
    • fann_test — 使用一组输入和一组期望的输出来测试。
    • fann_train_epoch — 使用一组训练数据训练一个周期。
    • fann_train_on_data — 在整个数据集上训练一段时间。
    • fann_train_on_file — 在从某个文件读取的整个数据集上训练一段时间。
    • fann_train — 使用一个输入集和一个期望的输出集来迭代训练一次。
  • FANNConnection — FANNConnection 类
    • FANNConnection::__construct — 连接构造器
    • FANNConnection::getFromNeuron — 返回开始连接的神经元。
    • FANNConnection::getToNeuron — 返回终止神经元的位置。
    • FANNConnection::getWeight — 返回连接权重。
    • FANNConnection::setWeight — 设置连接权重。


简介

PHP绑定了 FANN (快速人工神经网络) 库，该库实现了多层人工神经网络从而为全连接网络和稀疏连接网络提供支持。 该库是一个让训练数据集变得简单的框架。上手时快速，简单，文档也很丰富。


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

PHP >= 5.2.0 and libfann >= 2.1.0


安装

FANN PHP 扩展在所有的 Linux 系统都可以运行的。

  • FANN 库安装
  • PECL 安装
  • 手动安装

FANN 库安装

在你安装扩展之前确认 libfann 库已经安装在你的系统上了。在大部分的 Linux 发行版本的源中都包含了这个库 (搜索 fann). 你需要安装开发版本。

如果 libfann 没安装，你得先安装它。随便你从» 官方网站下载或者从你系统自带源中下载。比如在 Fedora 系统中：

$ sudo yum install fann-devel
或者 Ubuntu 系统中：

$ sudo apt-get install libfann-dev

如果该库被手动重装，在安装之前所有的老版本库文件应该先被删除，否则老版本的库还是会被连接。

PECL 安装

在 PECL 库里这个扩展是可用的。 安装起来也很容易。只要运行：

$ sudo pecl install fann

手动安装

如果开发者和用户对最新的更改很感兴趣，你可以编译 » Github 上最新的源代码。 前往 Github 点击 "Download ZIP" 按钮，然后运行:

$ unzip php-fann-master.zip
$ cd php-fann-master
$ phpize
$ ./configure
$ make all
$ sudo make install

在 php.ini 配置文件中做如下更改:

  • 确认 extension_dir 变量指向 fann.so 文件的目录. 该扩展构建过程中，在控制台输出时将会显示这个模块的安装路径，比如：

Installing '/usr/lib/php/extensions/no-debug-non-zts-20060613/fann.so'
    确认这个路径和 PHP 扩展是一致的，运行命令：

$ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/no-debug-non-zts-20060613 =>
                   /usr/lib/php/extensions/no-debug-non-zts-20060613
    如果不是，更改 php.ini 文件的 extension_dir 值或者移动 fann.so 文件到相应的目录。

  • 在 PHP 启动时添加该扩展，添加如下行代码：

extension=fann.so


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

训练算法
FANN_TRAIN_INCREMENTAL (integer)
标准反向传播算法，每次训练匹配后权重都会更新。这意味着在每个单历元中权重会被更新很多次。因为这个原因，很多问题使用这个算法将会训练的非常快，然而其他更高级的问题的训练效果不是很好。
FANN_TRAIN_BATCH (integer)
标准反向传播算法，计算均方差误差后权重值将会更新。 这意味着每个单历元只会更新一次。因为这个原因，很多问题使用这个算法会训练的很慢。但是计算出的均方差误差比增量训练的效果更好，使用这个算法某些问题将会得到更好的解决方案。
FANN_TRAIN_RPROP (integer)
一个更高级的批训练算法，对于很多问题该算法还会获得很好的结果。RPROP 训练算法是自适应的，因此不需要使用 learning_rate. 其他一些参数用来设置 RPROP 算法工作的方式，只推荐给那些知道 RPROP 算法如何工作的人来设置。RPROP 训练算法是被 Riedmiller 和 BraunSome 在1993年提出来的，实际上此处使用的是由 Igel 和 Husken 在2000年提出来的 iRPROP 训练算法，它是标准 RPROP 训练算法的一个变种。
FANN_TRAIN_QUICKPROP (integer)
一个更高级的批训练算法，对于很多问题该算法还会获得很好的结果。quickprop 训练算法使用 learning_rate 参数和其他更高级的参数， 但是只有当用户真正明白 quickprop 训练算法如何工作的时候才建议修改这些高级参数。 quickprop 训练算法是被 Fahlman 在1988年描述的。
FANN_TRAIN_SARPROP (integer)
更高级的训练算法，只在2.2版本中可用。
Activation functions
FANN_LINEAR (integer)
线性激励函数。
FANN_THRESHOLD (integer)
阈值激励函数。
FANN_THRESHOLD_SYMMETRIC (integer)
阈值激励函数。
FANN_SIGMOID (integer)
Sigmoid激励函数。
FANN_SIGMOID_STEPWISE (integer)
逐步线性逼近 Sigmoid 激励函数。
FANN_SIGMOID_SYMMETRIC (integer)
对称 Sigmoid 激励函数， 又名：tanh.
FANN_SIGMOID_SYMMETRIC_STEPWISE (integer)
逐步线性逼近对称 Sigmoid 激励函数。
FANN_GAUSSIAN (integer)
Gaussian (高斯) 激励函数。
FANN_GAUSSIAN_SYMMETRIC (integer)
对称 gaussian (高斯)激励函数。
FANN_GAUSSIAN_STEPWISE (integer)
逐步 gaussian (高斯)激励函数。
FANN_ELLIOT (integer)
快速(类sigmoid)激励函数，由 David Elliott 定义的。
FANN_ELLIOT_SYMMETRIC (integer)
快速(类对称sigmoid)激励函数，由 David Elliott定义的。
FANN_LINEAR_PIECE (integer)
有界线性激励函数。
FANN_LINEAR_PIECE_SYMMETRIC (integer)
有界线性激励函数。
FANN_SIN_SYMMETRIC (integer)
周期sin(正弦)激励函数。
FANN_COS_SYMMETRIC (integer)
周期cos(余弦)激励函数。
FANN_SIN (integer)
周期sin(正弦)激励函数。
FANN_COS (integer)
周期cos(余弦)激励函数。
Error function used during training
FANN_ERRORFUNC_LINEAR (integer)
标准线性误差函数。
FANN_ERRORFUNC_TANH (integer)
Tanh 误差函数， 通常更好但是要求更低的学习率。该误差函数当有目标输出时将会和期望值有很大的不同，然而没有目标输出时只有很小不同。此激励函数在层叠训练和增量训练。
Stop criteria used during training
FANN_STOPFUNC_MSE (integer)
停止准则是均方误差(MSE)值。
FANN_STOPFUNC_BIT (integer)
停止准则是失败时的比特位数。比特位数意味着输出神经元的个数超过了失败时的比特位数 (参考 fann_get_bit_fail_limit, fann_set_bit_fail_limit). 位数在所有的训练数据中都会被计数，所以这个数组将会比训练数据的数量更高。
fann_get_network_type() 是用来定义网络类型
FANN_NETTYPE_LAYER (integer)
每一层只能连接下一层。
FANN_NETTYPE_SHORTCUT (integer)
每一层与所有以下层有连接。
Errors
FANN_E_NO_ERROR (integer)
无误差。
FANN_E_CANT_OPEN_CONFIG_R (integer)
无法打开读取配置文件。
FANN_E_CANT_OPEN_CONFIG_W (integer)
无法打开写入配置文件。
FANN_E_WRONG_CONFIG_VERSION (integer)
配置文件的错误版本。
FANN_E_CANT_READ_CONFIG (integer)
从配置文件读取信息的错误。
FANN_E_CANT_READ_NEURON (integer)
从配置文件读取神经元信息的错误。
FANN_E_CANT_READ_CONNECTIONS (integer)
从配置文件读取连接的错误。
FANN_E_WRONG_NUM_CONNECTIONS (integer)
连接数和期望的值不相等。
FANN_E_CANT_OPEN_TD_W (integer)
无法打开训练数据文件写入内容。
FANN_E_CANT_OPEN_TD_R (integer)
无法打开训练数据文件读取内容。
FANN_E_CANT_READ_TD (integer)
从文件读取训练数据错误。
FANN_E_CANT_ALLOCATE_MEM (integer)
无法分配内存。
FANN_E_CANT_TRAIN_ACTIVATION (integer)
无法使用已选的激励函数训练。
FANN_E_CANT_USE_ACTIVATION (integer)
无法使用已选的激励函数。
FANN_E_TRAIN_DATA_MISMATCH (integer)
两个 fann_train_data 结构体之间存在不可调和的差异。
FANN_E_CANT_USE_TRAIN_ALG (integer)
不能使用已选的训练算法。
FANN_E_TRAIN_DATA_SUBSET (integer)
尝试获取不在训练集内的子集。
FANN_E_INDEX_OUT_OF_BOUND (integer)
索引超出了界限。
FANN_E_SCALE_NOT_PRESENT (integer)
标定参数不存在。
FANN_E_INPUT_NO_MATCH (integer)
在人工神经网络和数据中的输入神经元个数不匹配。
FANN_E_OUTPUT_NO_MATCH (integer)
在人工神经网络和数据中的输出神经元个数不匹配。


  • ? 预定义常量
  • XOR (异或)训练 ?
  • PHP Manual
  • FANN
  • 范例

范例

Table of Contents

  • XOR (异或)训练


XOR (异或)训练

以下例子展示了怎么训练数据来实现 XOR (异或)功能。

Example #1 xor.data file

4 2 1
-1 -1
-1
-1 1
1
1 -1
1
1 1
-1

Example #2 一般训练

<?php
$num_input = 2;
$num_output = 1;
$num_layers = 3;
$num_neurons_hidden = 3;
$desired_error = 0.001;
$max_epochs = 500000;
$epochs_between_reports = 1000;

$ann = fann_create_standard($num_layers, $num_input, $num_neurons_hidden, $num_output);

if ($ann) {
    fann_set_activation_function_hidden($ann, FANN_SIGMOID_SYMMETRIC);
    fann_set_activation_function_output($ann, FANN_SIGMOID_SYMMETRIC);

    $filename = dirname(__FILE__) . "/xor.data";
    if (fann_train_on_file($ann, $filename, $max_epochs, $epochs_between_reports, $desired_error))
        fann_save($ann, dirname(__FILE__) . "/xor_float.net");

    fann_destroy($ann);
}
?>

这个例子展示怎么读取神经网络并且使用 XOR (异或)功能来运行数据。

Example #3 一般测试

<?php
$train_file = (dirname(__FILE__) . "/xor_float.net");
if (!is_file($train_file))
    die("The file xor_float.net has not been created! Please run simple_train.php to generate it");

$ann = fann_create_from_file($train_file);
if (!$ann)
    die("ANN could not be created");

$input = array(-1, 1);
$calc_out = fann_run($ann, $input);
printf("xor test (%f,%f) -> %f\n", $input[0], $input[1], $calc_out[0]);
fann_destroy($ann);
?>


Fann 函数

Table of Contents

  • fann_cascadetrain_on_data — 在整个数据集上训练，使用一段时间的 Cascade2 训练算法。
  • fann_cascadetrain_on_file — 读取文件并在整个数据集上训练，使用 Cascade2 训练算法训练一段时间。
  • fann_clear_scaling_params — 清除缩放参数
  • fann_copy — 创建一个 fann 结构体的副本。
  • fann_create_from_file — 从配置文件中构建一个反向传播神经网络。
  • fann_create_shortcut_array — 创建一个含快捷连接而非全连接的标准反向传播神经网络。
  • fann_create_shortcut — 创建一个含快捷连接而非全连接的标准反向传播神经网络。
  • fann_create_sparse_array — 创建一个标准的反向传播神经网络，该网络使用一个表示每层大小的数组来构造，但是并不是全连接的。
  • fann_create_sparse — 创建一个标准的反向传播神经网络，该网络不是全连接。
  • fann_create_standard_array — 创建一个全连接的反向传播神经网络，该网络使用一个表示每层大小的数组来构造。
  • fann_create_standard — 创建标准的全连接反向传播神经网络。
  • fann_create_train_from_callback — 从用户提供的函数创建训练数据结构。
  • fann_create_train — 创建一个空的训练数据结构。
  • fann_descale_input — 在获取基于先前计算的参数之后，在输入向量中缩小数据
  • fann_descale_output — 在获取基于先前计算的参数之后，在输出向量中缩小数据
  • fann_descale_train — 基于先前计算的参数来缩小输入和输出数据
  • fann_destroy_train — 销毁训练数据。
  • fann_destroy — 销毁整个网络并且适当地释放所有的关联内存。
  • fann_duplicate_train_data — 返回 fann 训练数据精确的副本。
  • fann_get_activation_function — 返回激励函数
  • fann_get_activation_steepness — 为提供的神经和网络层数返回激活陡度
  • fann_get_bias_array — 获取网络中每一层的偏差数
  • fann_get_bit_fail_limit — 返回训练期间使用的误差限制
  • fann_get_bit_fail — 失败位的数量
  • fann_get_cascade_activation_functions_count — 返回级联激活函数的数量
  • fann_get_cascade_activation_functions — 返回级联激活函数
  • fann_get_cascade_activation_steepnesses_count — 激活陡度的数量
  • fann_get_cascade_activation_steepnesses — 返回级联激活陡度
  • fann_get_cascade_candidate_change_fraction — 返回级联候选变化分数
  • fann_get_cascade_candidate_limit — 返回候选限度
  • fann_get_cascade_candidate_stagnation_epochs — 返回层叠候选停滞周期的数量
  • fann_get_cascade_max_cand_epochs — 返回候选周期的最大值
  • fann_get_cascade_max_out_epochs — 返回输出周期的最大值
  • fann_get_cascade_min_cand_epochs — 返回最小的候选周期
  • fann_get_cascade_min_out_epochs — 返回最小输出周期
  • fann_get_cascade_num_candidate_groups — 返回候选组的数量
  • fann_get_cascade_num_candidates — 返回训练期间使用的候选数量
  • fann_get_cascade_output_change_fraction — 返回级联输出变化分数
  • fann_get_cascade_output_stagnation_epochs — 返回级联输出停滞周期的数量
  • fann_get_cascade_weight_multiplier — 返回权重因子
  • fann_get_connection_array — 获取网络中的连接。
  • fann_get_connection_rate — 获取当网络创建时连接的使用率。
  • fann_get_errno — 返回最后一个错误数字。
  • fann_get_errstr — 返回最后的错误字符串。
  • fann_get_layer_array — 获取网络中每层的神经元数量。
  • fann_get_learning_momentum — 返回学习动量
  • fann_get_learning_rate — 返回学习速率
  • fann_get_MSE — 从网络中读取均方误差。
  • fann_get_network_type — 获取所创建的神经网络类型。
  • fann_get_num_input — 获取输入神经元的数量。
  • fann_get_num_layers — 获取神经网络的层数。
  • fann_get_num_output — 获取输出神经元的数量。
  • fann_get_quickprop_decay — 返回衰退值，用于在 quickprop 训练迭代时衰减权重
  • fann_get_quickprop_mu — 返回放大系数
  • fann_get_rprop_decrease_factor — 返回 RPROP 训练期间的衰减系数
  • fann_get_rprop_delta_max — 返回最大步长
  • fann_get_rprop_delta_min — 返回最小步长
  • fann_get_rprop_delta_zero — 返回初始步长
  • fann_get_rprop_increase_factor — 返回 RPROP 训练的递增系数
  • fann_get_sarprop_step_error_shift — 返回 sarprop 步值的误差偏移
  • fann_get_sarprop_step_error_threshold_factor — 返回 sarprop 算法步值的误差阈值系数
  • fann_get_sarprop_temperature — 返回 sarprop 算法温度
  • fann_get_sarprop_weight_decay_shift — 返回 sarprop 算法权重衰减变化值
  • fann_get_total_connections — 获取整个网络中所有的连接数。
  • fann_get_total_neurons — 获取整个网络中神经元的数量。
  • fann_get_train_error_function — 返回训练中使用的错误函数。
  • fann_get_train_stop_function — 返回训练中使用的停止函数。
  • fann_get_training_algorithm — 返回训练算法。
  • fann_init_weights — 使用 Widrow 和 Nguyen 算法初始化权重。
  • fann_length_train_data — 返回训练数据中训练模式的数量。
  • fann_merge_train_data — 合并训练数据。
  • fann_num_input_train_data — 返回训练数据中每个训练模式输入的数量。
  • fann_num_output_train_data — 返回训练数据中每个训练模式输出的数量。
  • fann_print_error — 打印错误字符串。
  • fann_randomize_weights — 给每个连接赋一个介于 min_weight 和 max_weight 之间的随机权重。
  • fann_read_train_from_file — 读取存储训练数据的文件。
  • fann_reset_errno — 重置最后的错误代码。
  • fann_reset_errstr — 重置最后的错误字符串。
  • fann_reset_MSE — 重置网络中的均方误差。
  • fann_run — 将通过神经网络运行输入。
  • fann_save_train — 将训练结构体保存至文件。
  • fann_save — 将整个网络保存至配置文件。
  • fann_scale_input_train_data — 在训练数据中缩放输入至指定范围
  • fann_scale_input — 在以前计算参数的基础上，在训练之前放大输入向量中的数据
  • fann_scale_output_train_data — 在训练数据中缩放输出至指定范围
  • fann_scale_output — 在以前计算参数的基础上，在训练之前放大输出向量中的数据
  • fann_scale_train_data — 在训练数据中缩放输入和输出到指定的范围
  • fann_scale_train — 在以前计算参数的基础上，缩放输入和输出数据
  • fann_set_activation_function_hidden — 为所有隐藏层设置激活函数
  • fann_set_activation_function_layer — 为已应用的层中所有的神经元设置激活函数。
  • fann_set_activation_function_output — 为输出层设置激活函数
  • fann_set_activation_function — 为已应用的神经元和层设置激活函数
  • fann_set_activation_steepness_hidden — 为所有隐藏层中所有的神经元设置激活函数陡度
  • fann_set_activation_steepness_layer — 为提供的层中所有的神经元设置激活陡度
  • fann_set_activation_steepness_output — 在输出层中设置激活陡度
  • fann_set_activation_steepness — 为提供的神经元和层设置激活陡度
  • fann_set_bit_fail_limit — 设置训练期间使用的误差
  • fann_set_callback — 设置训练期间使用的回调函数。
  • fann_set_cascade_activation_functions — 设置级联候选激活函数的数组
  • fann_set_cascade_activation_steepnesses — 设置级联候选激活陡度的数组。
  • fann_set_cascade_candidate_change_fraction — 设置级联候选更改分数
  • fann_set_cascade_candidate_limit — 设置候选限度
  • fann_set_cascade_candidate_stagnation_epochs — 设置级联候选停止周期数
  • fann_set_cascade_max_cand_epochs — 设置最大候选周期数
  • fann_set_cascade_max_out_epochs — 设置最大输出周期
  • fann_set_cascade_min_cand_epochs — 设置最小候选周期
  • fann_set_cascade_min_out_epochs — 设置最小输出周期
  • fann_set_cascade_num_candidate_groups — 设置候选组数量
  • fann_set_cascade_output_change_fraction — 设置级联输出改变分数
  • fann_set_cascade_output_stagnation_epochs — 设置级联输出停滞周期的值
  • fann_set_cascade_weight_multiplier — 设置权重因子
  • fann_set_error_log — 设置错误记录保存的位置。
  • fann_set_input_scaling_params — 根据训练数据计算将来使用的输入比例参数
  • fann_set_learning_momentum — 设置学习动量。
  • fann_set_learning_rate — 设置学习速率。
  • fann_set_output_scaling_params — 根据训练数据计算将来使用的输出缩放参数
  • fann_set_quickprop_decay — 设置quickprop算法衰减因子
  • fann_set_quickprop_mu — 设置 quickprop 算法放大因子
  • fann_set_rprop_decrease_factor — 使用 RPROP 算法训练时，设置下降因子
  • fann_set_rprop_delta_max — 设置最大步长
  • fann_set_rprop_delta_min — 设置最小步长
  • fann_set_rprop_delta_zero — 设置初始步长
  • fann_set_rprop_increase_factor — 使用 RPROP 算法训练时，设置增长因子
  • fann_set_sarprop_step_error_shift — 设置 sarprop 算法的步误差偏移量
  • fann_set_sarprop_step_error_threshold_factor — 设置 sarprop 算法的步误差阈值因子
  • fann_set_sarprop_temperature — 设置 sarprop 算法的温度
  • fann_set_sarprop_weight_decay_shift — 设置 sarprop 算法的权重衰减偏移值
  • fann_set_scaling_params — 根据训练数据计算输入和输出缩放参数以供将来使用
  • fann_set_train_error_function — 设置训练期间使用的错误函数。
  • fann_set_train_stop_function — 设置训练期间使用的停止函数。
  • fann_set_training_algorithm — 设置训练算法。
  • fann_set_weight_array — 在网络中设置一个连接。
  • fann_set_weight — 在网络中设置一个连接。
  • fann_shuffle_train_data — 打算训练数据，使顺序随机。
  • fann_subset_train_data — 返回一个训练数据子集的副本。
  • fann_test_data — 使用训练数据来测试并且计算出 MSE
  • fann_test — 使用一组输入和一组期望的输出来测试。
  • fann_train_epoch — 使用一组训练数据训练一个周期。
  • fann_train_on_data — 在整个数据集上训练一段时间。
  • fann_train_on_file — 在从某个文件读取的整个数据集上训练一段时间。
  • fann_train — 使用一个输入集和一个期望的输出集来迭代训练一次。


在整个数据集上训练，使用一段时间的 Cascade2 训练算法。

  • ? Fann 函数
  • fann_cascadetrain_on_file ?
  • PHP Manual
  • Fann 函数
  • 在整个数据集上训练，使用一段时间的 Cascade2 训练算法。

fann_cascadetrain_on_data

(PECL fann >= 1.0.0)

fann_cascadetrain_on_data — 在整个数据集上训练，使用一段时间的 Cascade2 训练算法。

说明

fann_cascadetrain_on_data ( resource $ann , resource $data , int $max_neurons , int $neurons_between_reports , float $desired_error ) : bool

级联输出改变小数是一个0到1之间的数字，表示在输出连接的训练中，为了使训练不停滞的情况下，经过 fann_get_cascade_output_stagnation_epochs() 次迭代的后，fann_get_MSE() 将会改变多大。如果训练停滞了，训练的输出连接将会结束，新的候选神经元将会准备好。

该训练使用由 fann_set_cascade_ 前缀设置的参数，但它也采用了另一种训练算法，即内部训练算法。该训练算法要么是 fann_set_training_algorithm() 设置的 FANN_TRAIN_RPROP 算法，要么是 FANN_TRAIN_QUICKPROP，这些算法设置的参数同样也会影响到级联训练。

参数

ann

神经网络 资源。

data

神经网络训练数据 资源。

max_neurons

被添加入神经网络中最大的神经元数。

neurons_between_reports

打印状态报告之间的神经元数。0表示没有报告会被打印。

desired_error

预期的 fann_get_MSE() 或 fann_get_bit_fail(), 取决于 fann_set_train_stop_function() 选择的停止函数

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_cascadetrain_on_file() - 读取文件并在整个数据集上训练，使用 Cascade2 训练算法训练一段时间。


读取文件并在整个数据集上训练，使用 Cascade2 训练算法训练一段时间。

  • ? fann_cascadetrain_on_data
  • fann_clear_scaling_params ?
  • PHP Manual
  • Fann 函数
  • 读取文件并在整个数据集上训练，使用 Cascade2 训练算法训练一段时间。

fann_cascadetrain_on_file

(PECL fann >= 1.0.0)

fann_cascadetrain_on_file — 读取文件并在整个数据集上训练，使用 Cascade2 训练算法训练一段时间。

说明

fann_cascadetrain_on_file ( resource $ann , string $filename , int $max_neurons , int $neurons_between_reports , float $desired_error ) : bool

和 fann_cascadetrain_on_data() 函数做一样的工作，但是该函数是直接从文件读取训练数据的。

参数

ann

神经网络 资源。

filename

添加在神经网络中神经元的最大数量。

max_neurons

在打印状态报告到标准输出之间的神经元数量。0值表示没有报告打印。

neurons_between_reports

打印状态报告之间的神经元数量。0值表示没有报告打印。

desired_error

期望的 fann_get_MSE() 值或者 fann_get_bit_fail() 值， 取决于 fann_set_train_stop_function() 函数选择的停止函数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_cascadetrain_on_data() - 在整个数据集上训练，使用一段时间的 Cascade2 训练算法。


清除缩放参数

  • ? fann_cascadetrain_on_file
  • fann_copy ?
  • PHP Manual
  • Fann 函数
  • 清除缩放参数

fann_clear_scaling_params

(PECL fann >= 1.0.0)

fann_clear_scaling_params — 清除缩放参数

说明

fann_clear_scaling_params ( resource $ann ) : bool

清除缩放参数

参数

ann

神经网络 资源。

返回值

成功时返回 true，其它情况下返回 false。


创建一个 fann 结构体的副本。

  • ? fann_clear_scaling_params
  • fann_create_from_file ?
  • PHP Manual
  • Fann 函数
  • 创建一个 fann 结构体的副本。

fann_copy

(PECL fann >= 1.0.0)

fann_copy — 创建一个 fann 结构体的副本。

说明

fann_copy ( resource $ann ) : resource

创建一个 fann 结构体的副本。

参数

ann

神经网络 资源。

返回值

成功，返回神经网络资源的副本，失败则返回false

参见

  • fann_test() - 使用一组输入和一组期望的输出来测试。


从配置文件中构建一个反向传播神经网络。

  • ? fann_copy
  • fann_create_shortcut_array ?
  • PHP Manual
  • Fann 函数
  • 从配置文件中构建一个反向传播神经网络。

fann_create_from_file

(PECL fann >= 1.0.0)

fann_create_from_file — 从配置文件中构建一个反向传播神经网络。

说明

fann_create_from_file ( string $configuration_file ) : resource

从一个由 fann_save() 函数保存的配置文件中构建一个反向传播神经网络。

参数

configuration_file

配置文件的路径。

返回值

成功时返回神经网络 资源，发生错误返回 false。

参见

  • fann_save() - 将整个网络保存至配置文件。


创建一个含快捷连接而非全连接的标准反向传播神经网络。

  • ? fann_create_from_file
  • fann_create_shortcut ?
  • PHP Manual
  • Fann 函数
  • 创建一个含快捷连接而非全连接的标准反向传播神经网络。

fann_create_shortcut_array

(PECL fann >= 1.0.0)

fann_create_shortcut_array — 创建一个含快捷连接而非全连接的标准反向传播神经网络。

说明

fann_create_shortcut_array ( int $num_layers , array $layers ) : resource

使用包含各层大小的数组创建一个含快捷连接而非全连接的标准反向传播神经网络。

参数

num_layers

网络层数的总数，包含输入输出层。

layers

一个包含各层大小的数组。

返回值

成功，返回一个神经网络的资源，错误则返回 false

参见

  • fann_create_shortcut() - 创建一个含快捷连接而非全连接的标准反向传播神经网络。
  • fann_create_sparse() - 创建一个标准的反向传播神经网络，该网络不是全连接。
  • fann_create_standard() - 创建标准的全连接反向传播神经网络。


创建一个含快捷连接而非全连接的标准反向传播神经网络。

  • ? fann_create_shortcut_array
  • fann_create_sparse_array ?
  • PHP Manual
  • Fann 函数
  • 创建一个含快捷连接而非全连接的标准反向传播神经网络。

fann_create_shortcut

(PECL fann >= 1.0.0)

fann_create_shortcut — 创建一个含快捷连接而非全连接的标准反向传播神经网络。

说明

fann_create_shortcut ( int $num_layers , int $num_neurons1 , int $num_neurons2 , int $... = ? ) : reference

创建一个含快捷连接而非全连接标准反向传播神经网络。

快捷连接是可以跳过网络层次的连接。一个包含快捷连接的全连接网络，表示在之后的网络层里所有的神经元都是互相连接的。包括输出层直接连接到输出层的连接。

参数

num_layers

包括输入输出层在内的网络层的层数。。

num_neurons1

第一层神经元的数量。

num_neurons2

第二层神经元的数量。

...

其它层神经元的数量。

返回值

成功，返回神经网络的资源，错误则返回 false .

参见

  • fann_create_shortcut_array() - 创建一个含快捷连接而非全连接的标准反向传播神经网络。
  • fann_create_sparse() - 创建一个标准的反向传播神经网络，该网络不是全连接。
  • fann_create_standard() - 创建标准的全连接反向传播神经网络。


创建一个标准的反向传播神经网络，该网络使用一个表示每层大小的数组来构造，但是并不是全连接的。

  • ? fann_create_shortcut
  • fann_create_sparse ?
  • PHP Manual
  • Fann 函数
  • 创建一个标准的反向传播神经网络，该网络使用一个表示每层大小的数组来构造，但是并不是全连接的。

fann_create_sparse_array

(PECL fann >= 1.0.0)

fann_create_sparse_array — 创建一个标准的反向传播神经网络，该网络使用一个表示每层大小的数组来构造，但是并不是全连接的。

说明

fann_create_sparse_array ( float $connection_rate , int $num_layers , array $layers ) : ReturnType

创建一个标准的反向传播神经网络，该网络使用一个表示每层大小的数组来构造，但是并不是全连接的。

参数

connection_rate

连接率控制着在网络中将会有多少连接，如果连接率设置为1，那么这个网络就是全连接网络，但是如果设置为0.5将会设置一半的连接。连接率为1的结果和使用fann_create_standard()函数的效果是一样的。

num_layers

神经网络层数，包括输入输出层。

layers

表示每层大小的数组。

返回值

成功，返回神经网络的资源，错误则返回 false .

参见

  • fann_create_sparse() - 创建一个标准的反向传播神经网络，该网络不是全连接。
  • fann_create_standard() - 创建标准的全连接反向传播神经网络。
  • fann_create_shortcut() - 创建一个含快捷连接而非全连接的标准反向传播神经网络。


创建一个标准的反向传播神经网络，该网络不是全连接。

  • ? fann_create_sparse_array
  • fann_create_standard_array ?
  • PHP Manual
  • Fann 函数
  • 创建一个标准的反向传播神经网络，该网络不是全连接。

fann_create_sparse

(PECL fann >= 1.0.0)

fann_create_sparse — 创建一个标准的反向传播神经网络，该网络不是全连接。

说明

fann_create_sparse ( float $connection_rate , int $num_layers , int $num_neurons1 , int $num_neurons2 , int $... = ? ) : ReturnType

创建一个标准的反向传播神经网络，该网络不是全连接。

参数

connection_rate

连接率控制着在网络中将会有多少连接，如果连接率设置为1，那么这个网络就是全连接网络，但是如果设置为 0.5 将会设置一半的连接。连接率为1的结果和使用 fann_create_standard()函数的效果是一样的。

num_layers

神经网络层数，包括输入输出层。

num_neurons1

第一层网络的神经数。

num_neurons2

第二层网络的神经数。

...

其它层网络的神经数。

返回值

返回一个神经网络资源，错误则返回 false .

参见

  • fann_create_sparse_array() - 创建一个标准的反向传播神经网络，该网络使用一个表示每层大小的数组来构造，但是并不是全连接的。
  • fann_create_standard() - 创建标准的全连接反向传播神经网络。
  • fann_create_shortcut() - 创建一个含快捷连接而非全连接的标准反向传播神经网络。


创建一个全连接的反向传播神经网络，该网络使用一个表示每层大小的数组来构造。

  • ? fann_create_sparse
  • fann_create_standard ?
  • PHP Manual
  • Fann 函数
  • 创建一个全连接的反向传播神经网络，该网络使用一个表示每层大小的数组来构造。

fann_create_standard_array

(PECL fann >= 1.0.0)

fann_create_standard_array — 创建一个全连接的反向传播神经网络，该网络使用一个表示每层大小的数组来构造。

说明

fann_create_standard_array ( int $num_layers , array $layers ) : resource

创建一个标准的全连接反向传播神经网络。

每一层都将会有一个偏置神经元 (除了输出层),该偏置神经元将会连接下一层所有的神经元。当运行网络时，偏置神经节点一直发出1信号。

请使用 fann_destroy() 函数来销毁神经网络。

参数

num_layers

神经网络层数，包括输入输出层。

layers

表示每层大小的数组。

返回值

成功则返回神经网络，错误则返回 false .

参见

  • fann_create_standard() - 创建标准的全连接反向传播神经网络。
  • fann_create_sparse() - 创建一个标准的反向传播神经网络，该网络不是全连接。
  • fann_create_shortcut() - 创建一个含快捷连接而非全连接的标准反向传播神经网络。


创建标准的全连接反向传播神经网络。

  • ? fann_create_standard_array
  • fann_create_train_from_callback ?
  • PHP Manual
  • Fann 函数
  • 创建标准的全连接反向传播神经网络。

fann_create_standard

(PECL fann >= 1.0.0)

fann_create_standard — 创建标准的全连接反向传播神经网络。

说明

fann_create_standard ( int $num_layers , int $num_neurons1 , int $num_neurons2 , int $... = ? ) : resource

创建一个标准的全连接反向传播神经网络。

每一层都将会有一个偏置神经元 (除了输出层), 该偏置神经元将会连接下一层所有的神经元。当运行网络时，偏置神经节点一直发出1信号。

请使用 fann_destroy() 函数来销毁神经网络。

参数

num_layers

神经网络层数，包括输入输出层。

num_neurons1

第一层神经元的数量。

num_neurons2

第二层神经元的数量。

...

其他层的神经数量。

返回值

成功，返回神经网络的资源，失败则返回 false .

参见

  • fann_create_standard_array() - 创建一个全连接的反向传播神经网络，该网络使用一个表示每层大小的数组来构造。
  • fann_create_sparse() - 创建一个标准的反向传播神经网络，该网络不是全连接。
  • fann_create_shortcut() - 创建一个含快捷连接而非全连接的标准反向传播神经网络。


从用户提供的函数创建训练数据结构。

  • ? fann_create_standard
  • fann_create_train ?
  • PHP Manual
  • Fann 函数
  • 从用户提供的函数创建训练数据结构。

fann_create_train_from_callback

(PECL fann >= 1.0.0)

fann_create_train_from_callback — 从用户提供的函数创建训练数据结构。

说明

fann_create_train_from_callback ( int $num_data , int $num_input , int $num_output , callable $user_function ) : resource

从用户提供的函数创建训练数据结构。当训练数据可数，用户需要构造一个用来接收训练数据集(包括输入，输出)数量和返回值为集合的函数。

参数

num_data

训练数据的数量。

num_input

每个训练数据的输入数。

num_output

每个训练数据的输出数。

user_function

用户提供的函数包含以下参数：

  • num - 训练数据集的数量。
  • num_input - 数量数据的输入数。
  • num_output - 数量数据的输出数。

函数应该返回一个包含input 和 output 键的数组，并且这两个键的值分别表示输入输出的值(皆为数组)。

返回值

成功时返回训练数据 资源，发生错误返回 false。

范例

Example #1 fann_create_train_from_callback() example

<?php
function create_train_callback($num_data, $num_input, $num_output) {
    return array(
        "input" => array_fill(0, $num_input, 1),
        "output" => array_fill(0, $num_output, 1),
    );
}

$num_data = 3;
$num_input = 2;
$num_output = 1;
$train_data = fann_create_train_from_callback($num_data, $num_input, $num_output, "create_train_callback");
if ($train_data) {
    // Do something with $train_data
}
?>

参见

  • fann_read_train_from_file() - 读取存储训练数据的文件。
  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_destroy_train() - 销毁训练数据。
  • fann_save_train() - 将训练结构体保存至文件。


创建一个空的训练数据结构。

  • ? fann_create_train_from_callback
  • fann_descale_input ?
  • PHP Manual
  • Fann 函数
  • 创建一个空的训练数据结构。

fann_create_train

(PECL fann >= 1.0.0)

fann_create_train — 创建一个空的训练数据结构。

说明

fann_create_train ( int $num_data , int $num_input , int $num_output ) : resource

创建一个空的训练数据结构。

参数

num_data

训练数据的数量。

num_input

每个训练数据集输入的数量。

num_output

每个训练数据集输出的数量。

返回值

成功时返回训练数据 资源，发生错误返回 false。

参见

  • fann_read_train_from_file() - 读取存储训练数据的文件。
  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_destroy_train() - 销毁训练数据。
  • fann_save_train() - 将训练结构体保存至文件。


在获取基于先前计算的参数之后，在输入向量中缩小数据

  • ? fann_create_train
  • fann_descale_output ?
  • PHP Manual
  • Fann 函数
  • 在获取基于先前计算的参数之后，在输入向量中缩小数据

fann_descale_input

(PECL fann >= 1.0.0)

fann_descale_input — 在获取基于先前计算的参数之后，在输入向量中缩小数据

说明

fann_descale_input ( resource $ann , array $input_vector ) : bool

在获取基于先前计算的参数之后，在输入向量中缩小数据。

参数

ann

神经网络 资源。

input_vector

将要被缩小的输入向量

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_scale_input() - 在以前计算参数的基础上，在训练之前放大输入向量中的数据
  • fann_descale_output() - 在获取基于先前计算的参数之后，在输出向量中缩小数据


在获取基于先前计算的参数之后，在输出向量中缩小数据

  • ? fann_descale_input
  • fann_descale_train ?
  • PHP Manual
  • Fann 函数
  • 在获取基于先前计算的参数之后，在输出向量中缩小数据

fann_descale_output

(PECL fann >= 1.0.0)

fann_descale_output — 在获取基于先前计算的参数之后，在输出向量中缩小数据

说明

fann_descale_output ( resource $ann , array $output_vector ) : bool

在获取基于先前计算的参数之后，在输出向量中缩小数据。

参数

ann

神经网络 资源。

output_vector

将被缩小的输出向量。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_scale_output() - 在以前计算参数的基础上，在训练之前放大输出向量中的数据
  • fann_descale_input() - 在获取基于先前计算的参数之后，在输入向量中缩小数据


基于先前计算的参数来缩小输入和输出数据

  • ? fann_descale_output
  • fann_destroy_train ?
  • PHP Manual
  • Fann 函数
  • 基于先前计算的参数来缩小输入和输出数据

fann_descale_train

(PECL fann >= 1.0.0)

fann_descale_train — 基于先前计算的参数来缩小输入和输出数据

说明

fann_descale_train ( resource $ann , resource $train_data ) : bool

基于先前计算的参数来缩小输入和输出数据。

参数

ann

神经网络 资源。

train_data

神经网络训练数据 资源。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_scale_train() - 在以前计算参数的基础上，缩放输入和输出数据
  • fann_set_scaling_params() - 根据训练数据计算输入和输出缩放参数以供将来使用


销毁训练数据。

  • ? fann_descale_train
  • fann_destroy ?
  • PHP Manual
  • Fann 函数
  • 销毁训练数据。

fann_destroy_train

(PECL fann >= 1.0.0)

fann_destroy_train — 销毁训练数据。

说明

fann_destroy_train ( resource $train_data ) : bool

销毁训练数据。

参数

train_data

神经网络训练数据 资源。

返回值

成功时返回 true，其它情况下返回 false。


销毁整个网络并且适当地释放所有的关联内存。

  • ? fann_destroy_train
  • fann_duplicate_train_data ?
  • PHP Manual
  • Fann 函数
  • 销毁整个网络并且适当地释放所有的关联内存。

fann_destroy

(PECL fann >= 1.0.0)

fann_destroy — 销毁整个网络并且适当地释放所有的关联内存。

说明

fann_destroy ( resource $ann ) : bool

销毁整个网络并且适当地释放所有的关联内存。

参数

ann

神经网络 资源。

返回值

成功时返回 true，其它情况下返回 false。


返回 fann 训练数据精确的副本。

  • ? fann_destroy
  • fann_get_activation_function ?
  • PHP Manual
  • Fann 函数
  • 返回 fann 训练数据精确的副本。

fann_duplicate_train_data

(PECL fann >= 1.0.0)

fann_duplicate_train_data — 返回 fann 训练数据精确的副本。

说明

fann_duplicate_train_data ( resource $data ) : resource

返回 fann 训练数据精确的副本 resource。

参数

data

神经网络训练数据 资源。

返回值

成功时返回训练数据 资源，发生错误返回 false。


返回激励函数

  • ? fann_duplicate_train_data
  • fann_get_activation_steepness ?
  • PHP Manual
  • Fann 函数
  • 返回激励函数

fann_get_activation_function

(PECL fann >= 1.0.0)

fann_get_activation_function — 返回激励函数

说明

fann_get_activation_function ( resource $ann , int $layer , int $neuron ) : int

获取在层数为 layer 的网络中神经元数为 neuron的激励函数，输入层被计为 0.

在输入层是不能获取神经元激励函数的。

返回值将会是激励函数 常量之一。

参数

ann

神经网络 资源。

layer

层数。

neuron

神经元数

返回值

学习函数 常量或者如果神经未在神经网络中定义返回 -1， 错误则返回 false .

参见

  • fann_set_activation_function_layer() - 为已应用的层中所有的神经元设置激活函数。
  • fann_set_activation_function_hidden() - 为所有隐藏层设置激活函数
  • fann_set_activation_function_output() - 为输出层设置激活函数
  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度
  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数


为提供的神经和网络层数返回激活陡度

  • ? fann_get_activation_function
  • fann_get_bias_array ?
  • PHP Manual
  • Fann 函数
  • 为提供的神经和网络层数返回激活陡度

fann_get_activation_steepness

(PECL fann >= 1.0.0)

fann_get_activation_steepness — 为提供的神经和网络层数返回激活陡度

说明

fann_get_activation_steepness ( resource $ann , int $layer , int $neuron ) : float

获取神经元数为 neuron 层数为 layer神经网络的激活陡度，将输入层数计为1层。

在输入层中是不可能获取激活陡度。

激活函数的陡度表明了激活函数从最小到最大有多块。一个高值表明将会提供一个更高效的训练。

在训练神经网络时，输出值应该处于极端(通常是 0 和 1，取决于激励函数)，一般陡峭的激活函数将会被使用(比如为1.0时)。

默认的激活陡度是0.5.

参数

ann

神经网络 资源。

layer

层数

neuron

神经元数

返回值

激活陡度，当神经元在神经网络中没定义时为-1，错误时返回 false .

参见

  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数
  • fann_set_activation_steepness_layer() - 为提供的层中所有的神经元设置激活陡度
  • fann_set_activation_steepness_hidden() - 为所有隐藏层中所有的神经元设置激活函数陡度
  • fann_set_activation_steepness_output() - 在输出层中设置激活陡度
  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度


获取网络中每一层的偏差数

  • ? fann_get_activation_steepness
  • fann_get_bit_fail_limit ?
  • PHP Manual
  • Fann 函数
  • 获取网络中每一层的偏差数

fann_get_bias_array

(PECL fann >= 1.0.0)

fann_get_bias_array — 获取网络中每一层的偏差数

说明

fann_get_bias_array ( resource $ann ) : array

获取网络中每一层的偏差数。

参数

ann

神经网络 资源。

返回值

包含每一层偏差数的数组。


返回训练期间使用的误差限制

  • ? fann_get_bias_array
  • fann_get_bit_fail ?
  • PHP Manual
  • Fann 函数
  • 返回训练期间使用的误差限制

fann_get_bit_fail_limit

(PECL fann >= 1.0.0)

fann_get_bit_fail_limit — 返回训练期间使用的误差限制

说明

fann_get_bit_fail_limit ( resource $ann ) : float

返回训练期间使用的误差限制。

训练期间使用的误差限制，在 停止函数 中设置的 FANN_STOPFUNC_BIT.

限度是训练过程中期望输出和实际输出之间的最大可接受差值。每个输出偏离超过这个限度将会被算作误差。不同的是在使用对称激活函数的时候这个值要除以2，因此对称或者不对称可以使用同样的限度。

默认的误差限度是 0.35.

参数

ann

神经网络 资源。

返回值

成功，返回误差限度，错误则返回 false .

参见

  • fann_set_bit_fail_limit() - 设置训练期间使用的误差


失败位的数量

  • ? fann_get_bit_fail_limit
  • fann_get_cascade_activation_functions_count ?
  • PHP Manual
  • Fann 函数
  • 失败位的数量

fann_get_bit_fail

(PECL fann >= 1.0.0)

fann_get_bit_fail — 失败位的数量

说明

fann_get_bit_fail ( resource $ann ) : int

失败位的数量：意味着输出神经元的数量多于失败位的限度 (参见 fann_get_bit_fail_limit(), fann_set_bit_fail_limit()). 位数将会在所有的训练数据中被计数，因此这个数字将会比训练数据的数量高一点。

该值可以被 fann_reset_MSE() 函数重置，并且可以被能够更新MSE值的函数更新。(比如 fann_test_data(), fann_train_epoch())

参数

ann

神经网络 资源。

返回值

成功 ，返回失败位的数量，错误则返回 false .

参见

  • fann_get_MSE() - 从网络中读取均方误差。
  • fann_reset_MSE() - 重置网络中的均方误差。
  • fann_test_data() - 使用训练数据来测试并且计算出 MSE
  • fann_train_epoch() - 使用一组训练数据训练一个周期。
  • fann_get_bit_fail_limit() - 返回训练期间使用的误差限制
  • fann_set_bit_fail_limit() - 设置训练期间使用的误差


返回级联激活函数的数量

  • ? fann_get_bit_fail
  • fann_get_cascade_activation_functions ?
  • PHP Manual
  • Fann 函数
  • 返回级联激活函数的数量

fann_get_cascade_activation_functions_count

(PECL fann >= 1.0.0)

fann_get_cascade_activation_functions_count — 返回级联激活函数的数量

说明

fann_get_cascade_activation_functions_count ( resource $ann ) : int

在 fann_get_cascade_activation_functions() 函数数组的激活函数的数量。

默认激活函数的数量为6.

参数

ann

神经网络 资源。

返回值

成功，返回级联激活函数的数量，错误则返回false .

参见

  • fann_get_cascade_activation_functions() - 返回级联激活函数
  • fann_set_cascade_activation_functions() - 设置级联候选激活函数的数组


返回级联激活函数

  • ? fann_get_cascade_activation_functions_count
  • fann_get_cascade_activation_steepnesses_count ?
  • PHP Manual
  • Fann 函数
  • 返回级联激活函数

fann_get_cascade_activation_functions

(PECL fann >= 1.0.0)

fann_get_cascade_activation_functions — 返回级联激活函数

说明

fann_get_cascade_activation_functions ( resource $ann ) : array

层级激活函数数组是一个和被候选使用的不同的数组。

参见 fann_get_cascade_num_candidates() 的描述，这个数组将会生成候选神经元。

默认的激活函数是 FANN_SIGMOID, FANN_SIGMOID_SYMMETRIC, FANN_GAUSSIAN, FANN_GAUSSIAN_SYMMETRIC, FANN_ELLIOT, FANN_ELLIOT_SYMMETRIC.

参数

ann

神经网络 资源。

返回值

成功，返回层级激活函数数组，错误则返回 false .

参见

  • fann_get_cascade_activation_functions_count() - 返回级联激活函数的数量
  • fann_set_cascade_activation_functions() - 设置级联候选激活函数的数组


激活陡度的数量

  • ? fann_get_cascade_activation_functions
  • fann_get_cascade_activation_steepnesses ?
  • PHP Manual
  • Fann 函数
  • 激活陡度的数量

fann_get_cascade_activation_steepnesses_count

(PECL fann >= 1.0.0)

fann_get_cascade_activation_steepnesses_count — 激活陡度的数量

说明

fann_get_cascade_activation_steepnesses_count ( resource $ann ) : int

fann_get_cascade_activation_functions() 数组中激活陡度的数量。

默认的激活陡度的数量是 4.

参数

ann

神经网络 资源。

返回值

成功返回激活陡度数量，错误，则返回false .

参见

  • fann_get_cascade_activation_steepnesses() - 返回级联激活陡度
  • fann_set_cascade_activation_functions() - 设置级联候选激活函数的数组


返回级联激活陡度

  • ? fann_get_cascade_activation_steepnesses_count
  • fann_get_cascade_candidate_change_fraction ?
  • PHP Manual
  • Fann 函数
  • 返回级联激活陡度

fann_get_cascade_activation_steepnesses

(PECL fann >= 1.0.0)

fann_get_cascade_activation_steepnesses — 返回级联激活陡度

说明

fann_get_cascade_activation_steepnesses ( resource $ann ) : array

层级激活函数数组是一个和被候选使用的不同的数组。

参见 fann_get_cascade_num_candidates() 的描述，这个数组将会生成候选神经元。

默认的激活陡度是{0.25, 0.50, 0.75, 1.00}.

参数

ann

神经网络 资源。

返回值

成功，返回级联激活陡度，错误则返回 false.

参见

  • fann_get_cascade_activation_steepnesses_count() - 激活陡度的数量
  • fann_set_cascade_activation_steepnesses() - 设置级联候选激活陡度的数组。


返回级联候选变化分数

  • ? fann_get_cascade_activation_steepnesses
  • fann_get_cascade_candidate_limit ?
  • PHP Manual
  • Fann 函数
  • 返回级联候选变化分数

fann_get_cascade_candidate_change_fraction

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_change_fraction — 返回级联候选变化分数

说明

fann_get_cascade_candidate_change_fraction ( resource $ann ) : float

返回级联候选变化分数是一个介于0到1之间的数字。该数字决定了在训练候选神经元使用 fann_get_cascade_candidate_stagnation_epochs() 函数时 fann_get_MSE() 将会改变多大的分数,是为了不让这个训练停止。如果训练停止，候选神经元的训练将会被终止并且会选出最好的候选。

这意味在fann_get_cascade_candidate_stagnation_epochs()期间如果 MSE 被fann_get_cascade_candidate_change_fraction()的分数更改，候选神经元的训练会因为训练的停滞而被停止。

如果级联候选变化分数很低，这个候选神经元将训练越多，如果这个分数很高则训练的越少。

默认的级联候选变化分数是 0.01, 等于 MSE 中1%的变化值。

参数

ann

神经网络 资源。

返回值

成功，则返回级联候选变化分数，错误则返回 false .

参见

  • fann_set_cascade_candidate_change_fraction() - 设置级联候选更改分数
  • fann_get_MSE() - 从网络中读取均方误差。
  • fann_get_cascade_candidate_stagnation_epochs() - 返回层叠候选停滞周期的数量


返回候选限度

  • ? fann_get_cascade_candidate_change_fraction
  • fann_get_cascade_candidate_stagnation_epochs ?
  • PHP Manual
  • Fann 函数
  • 返回候选限度

fann_get_cascade_candidate_limit

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_limit — 返回候选限度

说明

fann_get_cascade_candidate_limit ( resource $ann ) : float

候选限度表明将会有多少候选神经元被训练。该限度是 MSE 和候选分数之间的比例限度。

将此值设置为低值以避免过于拟合，如果过度拟合并不是问题，则将其设置为更高的值。

默认的候选限度是 1000.0.

参数

ann

神经网络 资源。

返回值

成功，返回候选限度，错误则返回 false .

参见

  • fann_set_cascade_candidate_limit() - 设置候选限度


返回层叠候选停滞周期的数量

  • ? fann_get_cascade_candidate_limit
  • fann_get_cascade_max_cand_epochs ?
  • PHP Manual
  • Fann 函数
  • 返回层叠候选停滞周期的数量

fann_get_cascade_candidate_stagnation_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_stagnation_epochs — 返回层叠候选停滞周期的数量

说明

fann_get_cascade_candidate_stagnation_epochs ( resource $ann ) : float

层叠候选停滞周期的数量决定了在 fann_get_cascade_candidate_change_fraction() 不改变MSE分数的情况下继续进行的epochs训练的数量。

更多信息参见 fann_get_cascade_candidate_change_fraction().

层叠候选停滞周期的数量是 12.

参数

ann

神经网络 资源。

返回值

成功，返回层叠候选停滞周期的数量，错误则返回 false.

参见

  • fann_set_cascade_candidate_stagnation_epochs() - 设置级联候选停止周期数
  • fann_get_cascade_candidate_change_fraction() - 返回级联候选变化分数


返回候选周期的最大值

  • ? fann_get_cascade_candidate_stagnation_epochs
  • fann_get_cascade_max_out_epochs ?
  • PHP Manual
  • Fann 函数
  • 返回候选周期的最大值

fann_get_cascade_max_cand_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_max_cand_epochs — 返回候选周期的最大值

说明

fann_get_cascade_max_cand_epochs ( resource $ann ) : int

候选周期的最大值决定了在添加新的候选神经元之前，候选输入连接周期的最大值。

默认的最大候选周期是 150.

参数

ann

神经网络 资源。

返回值

成功，返回最大的候选周期，错误则返回false .

参见

  • fann_set_cascade_max_cand_epochs() - 设置最大候选周期数


返回输出周期的最大值

  • ? fann_get_cascade_max_cand_epochs
  • fann_get_cascade_min_cand_epochs ?
  • PHP Manual
  • Fann 函数
  • 返回输出周期的最大值

fann_get_cascade_max_out_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_max_out_epochs — 返回输出周期的最大值

说明

fann_get_cascade_max_out_epochs ( resource $ann ) : int

输出周期的最大值决定了在添加新的候选神经元之后，输出连接周期的最大值。

默认输出周期的最大值是 150.

参数

ann

神经网络 资源。

返回值

成功，则返回输出周期的最大值，错误则返回 false .

参见

  • fann_set_cascade_max_out_epochs() - 设置最大输出周期


返回最小的候选周期

  • ? fann_get_cascade_max_out_epochs
  • fann_get_cascade_min_out_epochs ?
  • PHP Manual
  • Fann 函数
  • 返回最小的候选周期

fann_get_cascade_min_cand_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_min_cand_epochs — 返回最小的候选周期

说明

fann_get_cascade_min_cand_epochs ( resource $ann ) : int

最小候选周期表示在添加新的候选神经元之前，输入连接到被训练的候选神经元最小的周期数。

默认的最小候选周期是50.

参数

ann

神经网络 资源。

返回值

成功，返回最小候选周期，错误则返回 false .

参见

  • fann_set_cascade_min_cand_epochs() - 设置最小候选周期


返回最小输出周期

  • ? fann_get_cascade_min_cand_epochs
  • fann_get_cascade_num_candidate_groups ?
  • PHP Manual
  • Fann 函数
  • 返回最小输出周期

fann_get_cascade_min_out_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_min_out_epochs — 返回最小输出周期

说明

fann_get_cascade_min_out_epochs ( resource $ann ) : int

最小输出周期表明在加入新的候选神经元后输出连接必须训练的最小周期。

默认的最小输出周期是50。

参数

ann

神经网络 资源。

返回值

成功，返回最小的输出周期，错误则返回 false .

参见

  • fann_set_cascade_min_out_epochs() - 设置最小输出周期


返回候选组的数量

  • ? fann_get_cascade_min_out_epochs
  • fann_get_cascade_num_candidates ?
  • PHP Manual
  • Fann 函数
  • 返回候选组的数量

fann_get_cascade_num_candidate_groups

(PECL fann >= 1.0.0)

fann_get_cascade_num_candidate_groups — 返回候选组的数量

说明

fann_get_cascade_num_candidate_groups ( resource $ann ) : int

候选组的数目是在训练期间使用的相同候选组的个数。

这个数字可以用来有更多的候选，而不必为候选定义新的参数。

参见 fann_get_cascade_num_candidates() 的描述。其中解释了这个参数将会生哪个成候选神经元。

默认的候选组数为2.

参数

ann

神经网络 资源。

返回值

成功，返回候选组数量，错误则返回 false .

参见

  • fann_set_cascade_num_candidate_groups() - 设置候选组数量


返回训练期间使用的候选数量

  • ? fann_get_cascade_num_candidate_groups
  • fann_get_cascade_output_change_fraction ?
  • PHP Manual
  • Fann 函数
  • 返回训练期间使用的候选数量

fann_get_cascade_num_candidates

(PECL fann >= 1.0.0)

fann_get_cascade_num_candidates — 返回训练期间使用的候选数量

说明

fann_get_cascade_num_candidates ( resource $ann ) : int

返回训练期间使用的候选数量 (
fann_get_cascade_activation_functions_count(),
fann_get_cascade_activation_steepnesses_count() 和
fann_get_cascade_num_candidate_groups())的和。

实际的候选数是由 fann_get_cascade_activation_functions() 和 fann_get_cascade_activation_steepnesses() 数组定义的。 这些数组定义的激活功能和激活的陡度用于候选神经元。如果在激活函数数组中有两个激活函数并且陡度数组中有三个陡度，则将会有2x3=6个不同的候选神经元被训练。 这6个不同的候选神经元将会被复制到几个候选组中，这些候选组不同之处在于他们的初始权重。如果组的数量设为2，则候选神经元的数量为2x3x2=12.候选组的数量是有 fann_set_cascade_num_candidate_groups() 函数定义的。

默认的候选神经元数量为 6x4x2 = 48

参数

ann

神经网络 资源。

返回值

成功，返回训练期间候选神经元的数量，错误则返回 false .

参见

  • fann_get_cascade_activation_functions() - 返回级联激活函数
  • fann_get_cascade_activation_functions_count() - 返回级联激活函数的数量
  • fann_get_cascade_activation_steepnesses() - 返回级联激活陡度
  • fann_get_cascade_activation_steepnesses_count() - 激活陡度的数量
  • fann_get_cascade_num_candidate_groups() - 返回候选组的数量


返回级联输出变化分数

  • ? fann_get_cascade_num_candidates
  • fann_get_cascade_output_stagnation_epochs ?
  • PHP Manual
  • Fann 函数
  • 返回级联输出变化分数

fann_get_cascade_output_change_fraction

(PECL fann >= 1.0.0)

fann_get_cascade_output_change_fraction — 返回级联输出变化分数

说明

fann_get_cascade_output_change_fraction ( resource $ann ) : float

级联输出变化分数是一个介于0到1之间的数字，决定了在fann_get_cascade_output_stagnation_epochs()的输出连接训练中，fann_get_MSE()的值将改变多大才能保持训练不至于停滞。如果训练停滞了， If the training stagnates, 输出连接的训练将结束，新的候选神经元将准备。

这就意味着如果在fann_get_cascade_output_stagnation_epochs()期间， MSE没有被 fann_get_cascade_output_change_fraction() 改变, 因为训练的停滞将导致输出连接将被停止。

如果级联输出改变分数很小，输出连接将会训练的更多，如果分数很大则会训练的更少。

默认的级联输出改变分数是0.01，和MSE中的1%相等。

参数

ann

神经网络 资源。

返回值

成功，返回级联输出更改分数，错误则返回 false .

参见

  • fann_set_cascade_output_change_fraction() - 设置级联输出改变分数
  • fann_get_MSE() - 从网络中读取均方误差。
  • fann_get_cascade_output_stagnation_epochs() - 返回级联输出停滞周期的数量


返回级联输出停滞周期的数量

  • ? fann_get_cascade_output_change_fraction
  • fann_get_cascade_weight_multiplier ?
  • PHP Manual
  • Fann 函数
  • 返回级联输出停滞周期的数量

fann_get_cascade_output_stagnation_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_output_stagnation_epochs — 返回级联输出停滞周期的数量

说明

fann_get_cascade_output_stagnation_epochs ( resource $ann ) : int

级联输出停滞周期的数量表示在fann_get_cascade_output_change_fraction()不改变MSE的情况下，运行训练的周期数。

更多详情参见 fann_get_cascade_output_change_fraction()。

级联输出停滞周期的默认值是12。

参数

ann

神经网络 资源。

返回值

成功，则返回级联输出停滞周期，错误则返回 false .

参见

  • fann_set_cascade_output_stagnation_epochs() - 设置级联输出停滞周期的值
  • fann_get_cascade_output_change_fraction() - 返回级联输出变化分数


返回权重因子

  • ? fann_get_cascade_output_stagnation_epochs
  • fann_get_connection_array ?
  • PHP Manual
  • Fann 函数
  • 返回权重因子

fann_get_cascade_weight_multiplier

(PECL fann >= 1.0.0)

fann_get_cascade_weight_multiplier — 返回权重因子

说明

fann_get_cascade_weight_multiplier ( resource $ann ) : float

权重因子是用于在添加神经元到神经网络之前，和候选神经元权重相乘的参数。该参数的值通常介于0到1之间，用来使训练变得不那么积极。

默认权重因子是 0.4.

参数

ann

神经网络 资源。

返回值

成功，返回权重因子，错误则返回 false .

参见

  • fann_set_cascade_weight_multiplier() - 设置权重因子


获取网络中的连接。

  • ? fann_get_cascade_weight_multiplier
  • fann_get_connection_rate ?
  • PHP Manual
  • Fann 函数
  • 获取网络中的连接。

fann_get_connection_array

(PECL fann >= 1.0.0)

fann_get_connection_array — 获取网络中的连接。

说明

fann_get_connection_array ( resource $ann ) : array

获取网络中的连接。

参数

ann

神经网络 资源。

返回值

包含网络中所有连接的数组。


获取当网络创建时连接的使用率。

  • ? fann_get_connection_array
  • fann_get_errno ?
  • PHP Manual
  • Fann 函数
  • 获取当网络创建时连接的使用率。

fann_get_connection_rate

(PECL fann >= 1.0.0)

fann_get_connection_rate — 获取当网络创建时连接的使用率。

说明

fann_get_connection_rate ( resource $ann ) : float

获取当网络创建时连接的使用率。

参数

ann

神经网络 资源。

返回值

成功，则返回当网络创建时连接的使用率, 错误则返回 false .


返回最后一个错误数字。

  • ? fann_get_connection_rate
  • fann_get_errstr ?
  • PHP Manual
  • Fann 函数
  • 返回最后一个错误数字。

fann_get_errno

(PECL fann >= 1.0.0)

fann_get_errno — 返回最后一个错误数字。

说明

fann_get_errno ( resource $errdat ) : int

返回最后一个错误数字。

参数

errdat

Either neural network resource or neural network trainining data resource.

返回值

成功，返回错误数字，错误则返回 false .

参见

  • fann_reset_errno() - 重置最后的错误代码。
  • fann_get_errstr() - 返回最后的错误字符串。


返回最后的错误字符串。

  • ? fann_get_errno
  • fann_get_layer_array ?
  • PHP Manual
  • Fann 函数
  • 返回最后的错误字符串。

fann_get_errstr

(PECL fann >= 1.0.0)

fann_get_errstr — 返回最后的错误字符串。

说明

fann_get_errstr ( resource $errdat ) : string

返回最后的错误字符串。

参数

errdat

Either neural network resource or neural network trainining data resource.

返回值

成功，返回最后的错误字符串,，失败则返回 false 。

参见

  • fann_reset_errstr() - 重置最后的错误字符串。
  • fann_get_errno() - 返回最后一个错误数字。


获取网络中每层的神经元数量。

  • ? fann_get_errstr
  • fann_get_learning_momentum ?
  • PHP Manual
  • Fann 函数
  • 获取网络中每层的神经元数量。

fann_get_layer_array

(PECL fann >= 1.0.0)

fann_get_layer_array — 获取网络中每层的神经元数量。

说明

fann_get_layer_array ( resource $ann ) : array

获取网络中每层的神经元数量。

偏差神经元不包括在内，所以层数是和 fann_create 函数组想匹配的。

参数

ann

神经网络 资源。

返回值

包含每层神经元数量的数组。


返回学习动量

  • ? fann_get_layer_array
  • fann_get_learning_rate ?
  • PHP Manual
  • Fann 函数
  • 返回学习动量

fann_get_learning_momentum

(PECL fann >= 1.0.0)

fann_get_learning_momentum — 返回学习动量

说明

fann_get_learning_momentum ( resource $ann ) : float

学习动量可用来加速 FANN_TRAIN_INCREMENTAL 训练。 一个过高的学习动量不利于训练。 动量设为0效果和没设一样。该参数的值建议在0.0到1.0之间。

默认动量是 0.

参数

ann

神经网络 资源。

返回值

成功时返回 true，其它情况下返回 false。

正确，返回学习动量，错误则返回 false .

参见

  • fann_set_learning_momentum() - 设置学习动量。
  • fann_set_training_algorithm() - 设置训练算法。


返回学习速率

  • ? fann_get_learning_momentum
  • fann_get_MSE ?
  • PHP Manual
  • Fann 函数
  • 返回学习速率

fann_get_learning_rate

(PECL fann >= 1.0.0)

fann_get_learning_rate — 返回学习速率

说明

fann_get_learning_rate ( resource $ann ) : float

学习率用来确定训练算法(FANN_TRAIN_INCREMENTAL, FANN_TRAIN_BATCH, FANN_TRAIN_QUICKPROP)中应该如何进行积极的训练。 不过，请注意这个函数不能用于 FANN_TRAIN_RPROP中。

默认的学习速率是 0.7。

参数

ann

神经网络 资源。

返回值

成功，返回学习速率，错误则返回 false .

参见

  • fann_set_learning_rate() - 设置学习速率。
  • fann_set_training_algorithm() - 设置训练算法。


从网络中读取均方误差。

  • ? fann_get_learning_rate
  • fann_get_network_type ?
  • PHP Manual
  • Fann 函数
  • 从网络中读取均方误差。

fann_get_MSE

(PECL fann >= 1.0.0)

fann_get_MSE — 从网络中读取均方误差。

说明

fann_get_MSE ( resource $ann ) : float

从网络中读取均方误差。

从网络中读取均方误差。该值是在训练或或测试中被计算的，因此如果权重在最后一次计算时已经改变，有时候会有点不太对劲。

参数

ann

神经网络 资源。

返回值

成功，则返回均方误差, 错误则返回 false .

参见

  • fann_test_data() - 使用训练数据来测试并且计算出 MSE


获取所创建的神经网络类型。

  • ? fann_get_MSE
  • fann_get_num_input ?
  • PHP Manual
  • Fann 函数
  • 获取所创建的神经网络类型。

fann_get_network_type

(PECL fann >= 1.0.0)

fann_get_network_type — 获取所创建的神经网络类型。

说明

fann_get_network_type ( resource $ann ) : int

获取所创建的神经网络的类型。

参数

ann

神经网络 资源。

返回值

成功，则返回网络类型 常量, 错误则返回 false .


获取输入神经元的数量。

  • ? fann_get_network_type
  • fann_get_num_layers ?
  • PHP Manual
  • Fann 函数
  • 获取输入神经元的数量。

fann_get_num_input

(PECL fann >= 1.0.0)

fann_get_num_input — 获取输入神经元的数量。

说明

fann_get_num_input ( resource $ann ) : int

获取输入神经元的数量。

参数

ann

神经网络 资源。

返回值

成功，则返回输入神经元的数量, 错误则返回 false


获取神经网络的层数。

  • ? fann_get_num_input
  • fann_get_num_output ?
  • PHP Manual
  • Fann 函数
  • 获取神经网络的层数。

fann_get_num_layers

(PECL fann >= 1.0.0)

fann_get_num_layers — 获取神经网络的层数。

说明

fann_get_num_layers ( resource $ann ) : int

获取神经网络的层数。

参数

ann

神经网络 资源。

返回值

成功，则返回神经网络的层数，错误则返回 false .


获取输出神经元的数量。

  • ? fann_get_num_layers
  • fann_get_quickprop_decay ?
  • PHP Manual
  • Fann 函数
  • 获取输出神经元的数量。

fann_get_num_output

(PECL fann >= 1.0.0)

fann_get_num_output — 获取输出神经元的数量。

说明

fann_get_num_output ( resource $ann ) : int

获取输出神经元的数量。

参数

ann

神经网络 资源。

返回值

成功，则返回输出神经元的数量, 错误则返回 false .


返回衰退值，用于在 quickprop 训练迭代时衰减权重

  • ? fann_get_num_output
  • fann_get_quickprop_mu ?
  • PHP Manual
  • Fann 函数
  • 返回衰退值，用于在 quickprop 训练迭代时衰减权重

fann_get_quickprop_decay

(PECL fann >= 1.0.0)

fann_get_quickprop_decay — 返回衰退值，用于在 quickprop 训练迭代时衰减权重

说明

fann_get_quickprop_decay ( resource $ann ) : float

衰退值是一个小的负数，用于在 quickprop 训练迭代时衰减权重。 这是用来确保训练时权重不要太高。

默认衰退值是 -0.0001.

参数

ann

神经网络 资源。

返回值

成功，返回衰退值，错误则返回 false .

参见

  • fann_set_quickprop_decay() - 设置quickprop算法衰减因子


返回放大系数

  • ? fann_get_quickprop_decay
  • fann_get_rprop_decrease_factor ?
  • PHP Manual
  • Fann 函数
  • 返回放大系数

fann_get_quickprop_mu

(PECL fann >= 1.0.0)

fann_get_quickprop_mu — 返回放大系数

说明

fann_get_quickprop_mu ( resource $ann ) : float

放大系数被用来增加和降低 quickprop 训练期间的步长。放大系数应该始终大于1，因为当它增加时，它会减少步长。

默认放大系数是 1.75.

参数

ann

神经网络 资源。

返回值

成功，返回放大系数，错误则返回 false .

参见

  • fann_set_quickprop_mu() - 设置 quickprop 算法放大因子


返回 RPROP 训练期间的衰减系数

  • ? fann_get_quickprop_mu
  • fann_get_rprop_delta_max ?
  • PHP Manual
  • Fann 函数
  • 返回 RPROP 训练期间的衰减系数

fann_get_rprop_decrease_factor

(PECL fann >= 1.0.0)

fann_get_rprop_decrease_factor — 返回 RPROP 训练期间的衰减系数

说明

fann_get_rprop_decrease_factor ( resource $ann ) : float

衰减系数的值小于1，用于在 RPROP 训练期间减少的步长。

The default decrease factor is 0.5.

参数

ann

神经网络 资源。

返回值

成功，返回衰减系数，错误则返回 false .

参见

  • fann_set_rprop_decrease_factor() - 使用 RPROP 算法训练时，设置下降因子


返回最大步长

  • ? fann_get_rprop_decrease_factor
  • fann_get_rprop_delta_min ?
  • PHP Manual
  • Fann 函数
  • 返回最大步长

fann_get_rprop_delta_max

(PECL fann >= 1.0.0)

fann_get_rprop_delta_max — 返回最大步长

说明

fann_get_rprop_delta_max ( resource $ann ) : float

最大步长是正数，决定最大步长可能有多大。.

默认的最大值是 50.0.

参数

ann

神经网络 资源。

返回值

成功,返回最大步长，错误则返回 false .

参见

  • fann_set_rprop_delta_max() - 设置最大步长
  • fann_get_rprop_delta_min() - 返回最小步长


返回最小步长

  • ? fann_get_rprop_delta_max
  • fann_get_rprop_delta_zero ?
  • PHP Manual
  • Fann 函数
  • 返回最小步长

fann_get_rprop_delta_min

(PECL fann >= 1.0.0)

fann_get_rprop_delta_min — 返回最小步长

说明

fann_get_rprop_delta_min ( resource $ann ) : float

最小步长是一个小的正数，决定最小步长可能有多小。.

默认的最小步长是 0.0.

参数

ann

神经网络 资源。

返回值

成功，返回最小步长，错误则返回 false .

参见

  • fann_set_rprop_delta_min() - 设置最小步长


返回初始步长

  • ? fann_get_rprop_delta_min
  • fann_get_rprop_increase_factor ?
  • PHP Manual
  • Fann 函数
  • 返回初始步长

fann_get_rprop_delta_zero

(PECL fann >= 1.0.0)

fann_get_rprop_delta_zero — 返回初始步长

说明

fann_get_rprop_delta_zero ( resource $ann ) : ReturnType

初始步长是确定初始步长的正数。

默认的初始步长是 0.1.

参数

ann

神经网络 资源。

返回值

成功，返回初始步长，错误则返回 false .

参见

  • fann_set_rprop_delta_zero() - 设置初始步长
  • fann_get_rprop_delta_min() - 返回最小步长
  • fann_get_rprop_delta_max() - 返回最大步长


返回 RPROP 训练的递增系数

  • ? fann_get_rprop_delta_zero
  • fann_get_sarprop_step_error_shift ?
  • PHP Manual
  • Fann 函数
  • 返回 RPROP 训练的递增系数

fann_get_rprop_increase_factor

(PECL fann >= 1.0.0)

fann_get_rprop_increase_factor — 返回 RPROP 训练的递增系数

说明

fann_get_rprop_increase_factor ( resource $ann ) : float

递增系数是一个大于1的值，用于递增 RPROP 训练中的步长。

默认的递进系数是 1.2

参数

ann

神经网络 资源。

返回值

成功，返回递进系数，错误则返回 false .

参见

  • fann_set_rprop_increase_factor() - 使用 RPROP 算法训练时，设置增长因子


返回 sarprop 步值的误差偏移

  • ? fann_get_rprop_increase_factor
  • fann_get_sarprop_step_error_threshold_factor ?
  • PHP Manual
  • Fann 函数
  • 返回 sarprop 步值的误差偏移

fann_get_sarprop_step_error_shift

(PECL fann >= 1.0.0)

fann_get_sarprop_step_error_shift — 返回 sarprop 步值的误差偏移

说明

fann_get_sarprop_step_error_shift ( resource $ann ) : float

返回 sarprop 步值的误差偏移。

默认的步值误差偏移是 1.385.

参数

ann

神经网络 资源。

返回值

成功，返回 sarprop 步值误差偏移，错误则返回 false .

参见

  • fann_set_sarprop_step_error_shift() - 设置 sarprop 算法的步误差偏移量


返回 sarprop 算法步值的误差阈值系数

  • ? fann_get_sarprop_step_error_shift
  • fann_get_sarprop_temperature ?
  • PHP Manual
  • Fann 函数
  • 返回 sarprop 算法步值的误差阈值系数

fann_get_sarprop_step_error_threshold_factor

(PECL fann >= 1.0.0)

fann_get_sarprop_step_error_threshold_factor — 返回 sarprop 算法步值的误差阈值系数

说明

fann_get_sarprop_step_error_threshold_factor ( resource $ann ) : float

sarprop 算法步值的误差阈值系数。

默认的系数是 0.1.

参数

ann

神经网络 资源。

返回值

成功，返回 sarprop 算法步值的误差阈值系数，错误则返回 false .

参见

  • fann_set_sarprop_step_error_threshold_factor() - 设置 sarprop 算法的步误差阈值因子


返回 sarprop 算法温度

  • ? fann_get_sarprop_step_error_threshold_factor
  • fann_get_sarprop_weight_decay_shift ?
  • PHP Manual
  • Fann 函数
  • 返回 sarprop 算法温度

fann_get_sarprop_temperature

(PECL fann >= 1.0.0)

fann_get_sarprop_temperature — 返回 sarprop 算法温度

说明

fann_get_sarprop_temperature ( resource $ann ) : float

返回 sarprop 算法温度。

默认温度是 0.015.

参数

ann

神经网络 资源。

返回值

成功，返回 sarprop 温度，错误则返回 false .

参见

  • fann_set_sarprop_temperature() - 设置 sarprop 算法的温度


返回 sarprop 算法权重衰减变化值

  • ? fann_get_sarprop_temperature
  • fann_get_total_connections ?
  • PHP Manual
  • Fann 函数
  • 返回 sarprop 算法权重衰减变化值

fann_get_sarprop_weight_decay_shift

(PECL fann >= 1.0.0)

fann_get_sarprop_weight_decay_shift — 返回 sarprop 算法权重衰减变化值

说明

fann_get_sarprop_weight_decay_shift ( resource $ann ) : float

sarprop 算法权重衰减变化值。

默认的最大值是 -6.644.

参数

ann

神经网络 资源。

返回值

成功，返回 sarprop 算法权重衰减变化值，错误则返回 false .

参见

  • fann_set_sarprop_weight_decay_shift() - 设置 sarprop 算法的权重衰减偏移值


获取整个网络中所有的连接数。

  • ? fann_get_sarprop_weight_decay_shift
  • fann_get_total_neurons ?
  • PHP Manual
  • Fann 函数
  • 获取整个网络中所有的连接数。

fann_get_total_connections

(PECL fann >= 1.0.0)

fann_get_total_connections — 获取整个网络中所有的连接数。

说明

fann_get_total_connections ( resource $ann ) : int

获取整个网络中所有的连接数。

参数

ann

神经网络 资源。

返回值

成功，则返回整个网络中所有的连接数, 错误则返回 false .


获取整个网络中神经元的数量。

  • ? fann_get_total_connections
  • fann_get_train_error_function ?
  • PHP Manual
  • Fann 函数
  • 获取整个网络中神经元的数量。

fann_get_total_neurons

(PECL fann >= 1.0.0)

fann_get_total_neurons — 获取整个网络中神经元的数量。

说明

fann_get_total_neurons ( resource $ann ) : int

获取整个网络中神经元的数量。 这个数量也包括偏置神经元，因此一个2-4-2的网络有2+4+2+2（偏置神经元）=10个神经元。

参数

ann

神经网络 资源。

返回值

成功，则返回整个网络神经元的数量, 错误则返回 false .


返回训练中使用的错误函数。

  • ? fann_get_total_neurons
  • fann_get_train_stop_function ?
  • PHP Manual
  • Fann 函数
  • 返回训练中使用的错误函数。

fann_get_train_error_function

(PECL fann >= 1.0.0)

fann_get_train_error_function — 返回训练中使用的错误函数。

说明

fann_get_train_error_function ( resource $ann ) : int

返回训练中使用的错误函数。

有关于错误函数的详细描述，参见 error functions 静态变量。

默认的错误函数是 FANN_ERRORFUNC_TANH.

参数

ann

神经网络 资源。

返回值

成功，则返回 error function 静态变量, 错误则返回 false .

参见

  • fann_set_train_error_function() - 设置训练期间使用的错误函数。


返回训练中使用的停止函数。

  • ? fann_get_train_error_function
  • fann_get_training_algorithm ?
  • PHP Manual
  • Fann 函数
  • 返回训练中使用的停止函数。

fann_get_train_stop_function

(PECL fann >= 1.0.0)

fann_get_train_stop_function — 返回训练中使用的停止函数。

说明

fann_get_train_stop_function ( resource $ann ) : int

返回训练中使用的停止函数。

停止函数的详细描述，参见stop functions 常量。

默认的停止函数是 FANN_STOPFUNC_MSE.

参数

ann

神经网络 资源。

返回值

成功，则返回 stop function 常量, 错误则返回 false .

参见

  • fann_set_train_stop_function() - 设置训练期间使用的停止函数。


返回训练算法。

  • ? fann_get_train_stop_function
  • fann_init_weights ?
  • PHP Manual
  • Fann 函数
  • 返回训练算法。

fann_get_training_algorithm

(PECL fann >= 1.0.0)

fann_get_training_algorithm — 返回训练算法。

说明

fann_get_training_algorithm ( resource $ann ) : int

返回训练算法。该训练算法是被 fann_train_on_data() 和相关函数使用的。

要注意的是这个算法在fann_cascadetrain_on_data()函数中也是可以使用的, 尽管在层叠训练中只有FANN_TRAIN_RPROP 和 FANN_TRAIN_QUICKPROP 算法被允许使用。

参数

ann

神经网络 资源。

返回值

成功，返回训练算法 常量, 错误则返回 false .

参见

  • fann_set_training_algorithm() - 设置训练算法。


使用 Widrow 和 Nguyen 算法初始化权重。

  • ? fann_get_training_algorithm
  • fann_length_train_data ?
  • PHP Manual
  • Fann 函数
  • 使用 Widrow 和 Nguyen 算法初始化权重。

fann_init_weights

(PECL fann >= 1.0.0)

fann_init_weights — 使用 Widrow 和 Nguyen 算法初始化权重。

说明

fann_init_weights ( resource $ann , resource $train_data ) : bool

使用 Widrow 和 Nguyen 算法初始化权重。

该函数的作用和 fann_randomize_weights()函数相似。 该函数将会使用 Derrick Nguyen 和 Bernard Widrow 开发的算法来设置权重用于加速训练。 该技术不是经常奏效，在某些场景下比纯粹的随机初始化来得更低效。

该算法要求获取输入数据的范围(比如 最大和最小输入)，因此接受别的参数，数据(将会在网络中训练的数据)。

参数

ann

神经网络 资源。

train_data

神经网络训练数据 资源。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_randomize_weights() - 给每个连接赋一个介于 min_weight 和 max_weight 之间的随机权重。
  • fann_read_train_from_file() - 读取存储训练数据的文件。


返回训练数据中训练模式的数量。

  • ? fann_init_weights
  • fann_merge_train_data ?
  • PHP Manual
  • Fann 函数
  • 返回训练数据中训练模式的数量。

fann_length_train_data

(PECL fann >= 1.0.0)

fann_length_train_data — 返回训练数据中训练模式的数量。

说明

fann_length_train_data ( resource $data ) : int

返回训练数据中训练模式的数量。 resource.

参数

data

神经网络训练数据 资源。

返回值

成功，则返回训练数据resource中的元素数，错误则返回 false .


合并训练数据。

  • ? fann_length_train_data
  • fann_num_input_train_data ?
  • PHP Manual
  • Fann 函数
  • 合并训练数据。

fann_merge_train_data

(PECL fann >= 1.0.0)

fann_merge_train_data — 合并训练数据。

说明

fann_merge_train_data ( resource $data1 , resource $data2 ) : resource

将 data1 和 data2 数据集合并为新的训练数据 resource.

参数

data1

神经网络训练数据 资源。

data2

神经网络训练数据 资源。

返回值

成功，则返回合并的训练数据 resource, 错误则返回 false .


返回训练数据中每个训练模式输入的数量。

  • ? fann_merge_train_data
  • fann_num_output_train_data ?
  • PHP Manual
  • Fann 函数
  • 返回训练数据中每个训练模式输入的数量。

fann_num_input_train_data

(PECL fann >= 1.0.0)

fann_num_input_train_data — 返回训练数据中每个训练模式输入的数量。

说明

fann_num_input_train_data ( resource $data ) : int

返回训练数据resource中每个训练模式输入的数量。

参数

data

神经网络训练数据 资源。

返回值

成功，则返回输入数，错误则返回 false .

参见

  • fann_length_train_data() - 返回训练数据中训练模式的数量。
  • fann_num_output_train_data() - 返回训练数据中每个训练模式输出的数量。


返回训练数据中每个训练模式输出的数量。

  • ? fann_num_input_train_data
  • fann_print_error ?
  • PHP Manual
  • Fann 函数
  • 返回训练数据中每个训练模式输出的数量。

fann_num_output_train_data

(PECL fann >= 1.0.0)

fann_num_output_train_data — 返回训练数据中每个训练模式输出的数量。

说明

fann_num_output_train_data ( resource $data ) : int

返回训练数据 resource中每个训练模式输出的数量。

参数

data

神经网络训练数据 资源。

返回值

成功，则返回输出数, 错误则返回 false .

参见

  • fann_length_train_data() - 返回训练数据中训练模式的数量。
  • fann_num_input_train_data() - 返回训练数据中每个训练模式输入的数量。


打印错误字符串。

  • ? fann_num_output_train_data
  • fann_randomize_weights ?
  • PHP Manual
  • Fann 函数
  • 打印错误字符串。

fann_print_error

(PECL fann >= 1.0.0)

fann_print_error — 打印错误字符串。

说明

fann_print_error ( string $errdat ) : void

打印错误字符串。

参数

errdat

Either neural network resource or neural network trainining data resource.

返回值

无返回值。

参见

  • fann_get_errstr() - 返回最后的错误字符串。


给每个连接赋一个介于 min_weight 和 max_weight 之间的随机权重。

  • ? fann_print_error
  • fann_read_train_from_file ?
  • PHP Manual
  • Fann 函数
  • 给每个连接赋一个介于 min_weight 和 max_weight 之间的随机权重。

fann_randomize_weights

(PECL fann >= 1.0.0)

fann_randomize_weights — 给每个连接赋一个介于 min_weight 和 max_weight 之间的随机权重。

说明

fann_randomize_weights ( resource $ann , float $min_weight , float $max_weight ) : bool

给每个连接赋一个介于 min_weight 和 max_weight之间的随机权重。

从一开始权重介于 -0.1 和 0.1之间。

参数

ann

神经网络 资源。

min_weight

最小权重值

max_weight

最大权重值

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_init_weights() - 使用 Widrow 和 Nguyen 算法初始化权重。


读取存储训练数据的文件。

  • ? fann_randomize_weights
  • fann_reset_errno ?
  • PHP Manual
  • Fann 函数
  • 读取存储训练数据的文件。

fann_read_train_from_file

(PECL fann >= 1.0.0)

fann_read_train_from_file — 读取存储训练数据的文件。

说明

fann_read_train_from_file ( string $filename ) : resource

读取存储训练数据的文件。

参数

filename

输入文件的格式如下:

num_train_data num_input num_output
inputdata seperated by space
outputdata seperated by space

.
.
.

inputdata seperated by space
outputdata seperated by space

返回值

成功时返回训练数据 资源，发生错误返回 false。

范例

Example #1 fann_read_train_from_file() 函数的使用范例：

<?php
$train_data = fann_read_train_from_file("xor.data");
if ($train_data) {
    // Do something with $train_data for XOR function
}
?>

xor.data 文件的内容：

4 2 1
-1 -1
-1
-1 1
1
1 -1
1
1 1
-1

参见

  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_destroy_train() - 销毁训练数据。
  • fann_save_train() - 将训练结构体保存至文件。


重置最后的错误代码。

  • ? fann_read_train_from_file
  • fann_reset_errstr ?
  • PHP Manual
  • Fann 函数
  • 重置最后的错误代码。

fann_reset_errno

(PECL fann >= 1.0.0)

fann_reset_errno — 重置最后的错误代码。

说明

fann_reset_errno ( resource $errdat ) : void

重置最后的错误代码。

参数

errdat

Either neural network resource or neural network trainining data resource.

返回值

无返回值。

参见

  • fann_get_errno() - 返回最后一个错误数字。
  • fann_reset_errstr() - 重置最后的错误字符串。


重置最后的错误字符串。

  • ? fann_reset_errno
  • fann_reset_MSE ?
  • PHP Manual
  • Fann 函数
  • 重置最后的错误字符串。

fann_reset_errstr

(PECL fann >= 1.0.0)

fann_reset_errstr — 重置最后的错误字符串。

说明

fann_reset_errstr ( resource $errdat ) : void

重置最后的错误字符串。

参数

errdat

Either neural network resource or neural network trainining data resource.

返回值

无返回值。

参见

  • fann_get_errstr() - 返回最后的错误字符串。
  • fann_reset_errno() - 重置最后的错误代码。


重置网络中的均方误差。

  • ? fann_reset_errstr
  • fann_run ?
  • PHP Manual
  • Fann 函数
  • 重置网络中的均方误差。

fann_reset_MSE

(PECL fann >= 1.0.0)

fann_reset_MSE — 重置网络中的均方误差。

说明

fann_reset_MSE ( string $ann ) : bool

重置网络中的均方误差。

该函数也会重置失败时位的数量。

参数

ann

神经网络 资源。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_MSE() - 从网络中读取均方误差。
  • fann_get_bit_fail() - 失败位的数量
  • fann_get_bit_fail_limit() - 返回训练期间使用的误差限制


将通过神经网络运行输入。

  • ? fann_reset_MSE
  • fann_save_train ?
  • PHP Manual
  • Fann 函数
  • 将通过神经网络运行输入。

fann_run

(PECL fann >= 1.0.0)

fann_run — 将通过神经网络运行输入。

说明

fann_run ( resource $ann , array $input ) : array

将通过神经网络运行输入，返回输出数组，数组的长度等于输出层神经元的个数。

参数

ann

神经网络 资源。

input

输入数组的值。

返回值

成功，返回输出数组，错误则返回 false .


将训练结构体保存至文件。

  • ? fann_run
  • fann_save ?
  • PHP Manual
  • Fann 函数
  • 将训练结构体保存至文件。

fann_save_train

(PECL fann >= 1.0.0)

fann_save_train — 将训练结构体保存至文件。

说明

fann_save_train ( resource $data , string $file_name ) : bool

将训练结构体保存至文件， 格式和 fann_read_train_from_file() 函数中指定的一样。

参数

data

神经网络训练数据 资源。

file_name

保存训练数据的文件名。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_read_train_from_file() - 读取存储训练数据的文件。


将整个网络保存至配置文件。

  • ? fann_save_train
  • fann_scale_input_train_data ?
  • PHP Manual
  • Fann 函数
  • 将整个网络保存至配置文件。

fann_save

(PECL fann >= 1.0.0)

fann_save — 将整个网络保存至配置文件。

说明

fann_save ( resource $ann , string $configuration_file ) : bool

将整个网络保存至配置文件。

配置文件包含了神经网络的所有信息，并且能够通过 fann_create_from_file() 函数来创建一个原神经网络的精确副本以及与神经网络关联的所有参数。

这三个参数 (fann_set_callback(), fann_set_error_log(), fann_set_user_data()) 不保存在文件中，因为他们不能被安全地移植到不同的位置。当使用类似 fann_get_MSE() 函数训练时，生成的临时参数也不会被保存起来。

参数

ann

神经网络 资源。

configuration_file

配置文件的路径。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_create_from_file() - 从配置文件中构建一个反向传播神经网络。


在训练数据中缩放输入至指定范围

  • ? fann_save
  • fann_scale_input ?
  • PHP Manual
  • Fann 函数
  • 在训练数据中缩放输入至指定范围

fann_scale_input_train_data

(PECL fann >= 1.0.0)

fann_scale_input_train_data — 在训练数据中缩放输入至指定范围

说明

fann_scale_input_train_data ( resource $train_data , float $new_min , float $new_max ) : bool

在训练数据中缩放输入至指定范围。

参数

train_data

神经网络训练数据 资源。

new_min

训练数据中缩放输入后新的最小值。

new_max

训练数据中缩放数据后新的最大值。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_scale_output_train_data() - 在训练数据中缩放输出至指定范围
  • fann_scale_train_data() - 在训练数据中缩放输入和输出到指定的范围


在以前计算参数的基础上，在训练之前放大输入向量中的数据

  • ? fann_scale_input_train_data
  • fann_scale_output_train_data ?
  • PHP Manual
  • Fann 函数
  • 在以前计算参数的基础上，在训练之前放大输入向量中的数据

fann_scale_input

(PECL fann >= 1.0.0)

fann_scale_input — 在以前计算参数的基础上，在训练之前放大输入向量中的数据

说明

fann_scale_input ( resource $ann , array $input_vector ) : bool

在以前计算参数的基础上，在训练之前放大输入向量中的数据。

参数

ann

神经网络 资源。

input_vector

将要被缩放的输入向量。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_descale_input() - 在获取基于先前计算的参数之后，在输入向量中缩小数据
  • fann_scale_output() - 在以前计算参数的基础上，在训练之前放大输出向量中的数据


在训练数据中缩放输出至指定范围

  • ? fann_scale_input
  • fann_scale_output ?
  • PHP Manual
  • Fann 函数
  • 在训练数据中缩放输出至指定范围

fann_scale_output_train_data

(PECL fann >= 1.0.0)

fann_scale_output_train_data — 在训练数据中缩放输出至指定范围

说明

fann_scale_output_train_data ( resource $train_data , float $new_min , float $new_max ) : bool

在训练数据中缩放输出至指定范围。

参数

train_data

神经网络训练数据 资源。

new_min

训练数据中缩放输出后新的最小值。

new_max

训练数据中缩放输出后新的最大值。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_scale_input_train_data() - 在训练数据中缩放输入至指定范围
  • fann_scale_train_data() - 在训练数据中缩放输入和输出到指定的范围


在以前计算参数的基础上，在训练之前放大输出向量中的数据

  • ? fann_scale_output_train_data
  • fann_scale_train_data ?
  • PHP Manual
  • Fann 函数
  • 在以前计算参数的基础上，在训练之前放大输出向量中的数据

fann_scale_output

(PECL fann >= 1.0.0)

fann_scale_output — 在以前计算参数的基础上，在训练之前放大输出向量中的数据

说明

fann_scale_output ( resource $ann , array $output_vector ) : bool

在以前计算参数的基础上，在训练之前放大输出向量中的数据。

参数

ann

神经网络 资源。

output_vector

将要被缩放的输出向量

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_descale_output() - 在获取基于先前计算的参数之后，在输出向量中缩小数据
  • fann_scale_input() - 在以前计算参数的基础上，在训练之前放大输入向量中的数据


在训练数据中缩放输入和输出到指定的范围

  • ? fann_scale_output
  • fann_scale_train ?
  • PHP Manual
  • Fann 函数
  • 在训练数据中缩放输入和输出到指定的范围

fann_scale_train_data

(PECL fann >= 1.0.0)

fann_scale_train_data — 在训练数据中缩放输入和输出到指定的范围

说明

fann_scale_train_data ( resource $train_data , float $new_min , float $new_max ) : bool

在训练数据中缩放输入和输出到指定的范围。

参数

train_data

神经网络训练数据 资源。

new_min

在训练数据中缩放输入和输出后新的最小值。

new_max

在训练数据中缩放输入和输出后新的最大值。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_scale_output_train_data() - 在训练数据中缩放输出至指定范围
  • fann_scale_input_train_data() - 在训练数据中缩放输入至指定范围


在以前计算参数的基础上，缩放输入和输出数据

  • ? fann_scale_train_data
  • fann_set_activation_function_hidden ?
  • PHP Manual
  • Fann 函数
  • 在以前计算参数的基础上，缩放输入和输出数据

fann_scale_train

(PECL fann >= 1.0.0)

fann_scale_train — 在以前计算参数的基础上，缩放输入和输出数据

说明

fann_scale_train ( resource $ann , resource $train_data ) : bool

在以前计算参数的基础上，缩放输入和输出数据。

参数

ann

神经网络 资源。

train_data

神经网络训练数据 资源。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_descale_train() - 基于先前计算的参数来缩小输入和输出数据
  • fann_set_scaling_params() - 根据训练数据计算输入和输出缩放参数以供将来使用


为所有隐藏层设置激活函数

  • ? fann_scale_train
  • fann_set_activation_function_layer ?
  • PHP Manual
  • Fann 函数
  • 为所有隐藏层设置激活函数

fann_set_activation_function_hidden

(PECL fann >= 1.0.0)

fann_set_activation_function_hidden — 为所有隐藏层设置激活函数

说明

fann_set_activation_function_hidden ( resource $ann , int $activation_function ) : bool

为所有隐藏层设置激活函数。

参数

ann

神经网络 资源。

activation_function

激活函数 常量。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数
  • fann_set_activation_function_layer() - 为已应用的层中所有的神经元设置激活函数。
  • fann_set_activation_function_output() - 为输出层设置激活函数
  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度


为已应用的层中所有的神经元设置激活函数。

  • ? fann_set_activation_function_hidden
  • fann_set_activation_function_output ?
  • PHP Manual
  • Fann 函数
  • 为已应用的层中所有的神经元设置激活函数。

fann_set_activation_function_layer

(PECL fann >= 1.0.0)

fann_set_activation_function_layer — 为已应用的层中所有的神经元设置激活函数。

说明

fann_set_activation_function_layer ( resource $ann , int $activation_function , int $layer ) : bool

为层数为 layer 的所有神经元设置激活函数，将输入层计为0.

在输入层中为神经元设置激活函数是不可能的。

参数

ann

神经网络 资源。

activation_function

激活函数 常量。

layer

层数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数
  • fann_set_activation_function_hidden() - 为所有隐藏层设置激活函数
  • fann_set_activation_function_output() - 为输出层设置激活函数
  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度


为输出层设置激活函数

  • ? fann_set_activation_function_layer
  • fann_set_activation_function ?
  • PHP Manual
  • Fann 函数
  • 为输出层设置激活函数

fann_set_activation_function_output

(PECL fann >= 1.0.0)

fann_set_activation_function_output — 为输出层设置激活函数

说明

fann_set_activation_function_output ( resource $ann , int $activation_function ) : bool

为输出层设置激活函数。

参数

ann

神经网络 资源。

activation_function

激活函数 常量。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数
  • fann_set_activation_function_layer() - 为已应用的层中所有的神经元设置激活函数。
  • fann_set_activation_function_hidden() - 为所有隐藏层设置激活函数
  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度


为已应用的神经元和层设置激活函数

  • ? fann_set_activation_function_output
  • fann_set_activation_steepness_hidden ?
  • PHP Manual
  • Fann 函数
  • 为已应用的神经元和层设置激活函数

fann_set_activation_function

(PECL fann >= 1.0.0)

fann_set_activation_function — 为已应用的神经元和层设置激活函数

说明

fann_set_activation_function ( resource $ann , int $activation_function , int $layer , int $neuron ) : bool

为层数为 layer，神经经元数为 neuron 的神经元设置激活函数，将输入层记为0.

在输出层中的神经元设置激活函数是不可能的。

在选择激活函数时，注意激活函数有不同的范围，这个很重要哦。 FANN_SIGMOID 就是个例子。它的范围是0 -1，然而 FANN_SIGMOID_SYMMETRIC 的范围是-1 - 1， FANN_LINEAR 却是无限的。

应用的激活函数应该是激活函数常量之一。

返回值是激活函数常量之一。

参数

ann

神经网络 资源。

activation_function

激活函数常量。

layer

层数。

neuron

神经元数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_activation_function_layer() - 为已应用的层中所有的神经元设置激活函数。
  • fann_set_activation_function_hidden() - 为所有隐藏层设置激活函数
  • fann_set_activation_function_output() - 为输出层设置激活函数
  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度
  • fann_get_activation_function() - 返回激励函数


为所有隐藏层中所有的神经元设置激活函数陡度

  • ? fann_set_activation_function
  • fann_set_activation_steepness_layer ?
  • PHP Manual
  • Fann 函数
  • 为所有隐藏层中所有的神经元设置激活函数陡度

fann_set_activation_steepness_hidden

(PECL fann >= 1.0.0)

fann_set_activation_steepness_hidden — 为所有隐藏层中所有的神经元设置激活函数陡度

说明

fann_set_activation_steepness_hidden ( resource $ann , float $activation_steepness ) : bool

为所有隐藏层中所有的神经元设置激活陡度。

参数

ann

神经网络 资源。

activation_steepness

激活陡度。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度
  • fann_set_activation_steepness_layer() - 为提供的层中所有的神经元设置激活陡度
  • fann_set_activation_steepness_output() - 在输出层中设置激活陡度
  • fann_get_activation_steepness() - 为提供的神经和网络层数返回激活陡度
  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数


为提供的层中所有的神经元设置激活陡度

  • ? fann_set_activation_steepness_hidden
  • fann_set_activation_steepness_output ?
  • PHP Manual
  • Fann 函数
  • 为提供的层中所有的神经元设置激活陡度

fann_set_activation_steepness_layer

(PECL fann >= 1.0.0)

fann_set_activation_steepness_layer — 为提供的层中所有的神经元设置激活陡度

说明

fann_set_activation_steepness_layer ( resource $ann , float $activation_steepness , int $layer ) : bool

为层数为 layer 中所有的神经元设置激活陡度，将输入层计为0。

在输出层中设置激活陡度是不可能的。

参数

ann

神经网络 资源。

activation_steepness

激活陡度。

layer

层数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度
  • fann_set_activation_steepness_hidden() - 为所有隐藏层中所有的神经元设置激活函数陡度
  • fann_set_activation_steepness_output() - 在输出层中设置激活陡度
  • fann_get_activation_steepness() - 为提供的神经和网络层数返回激活陡度
  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数


在输出层中设置激活陡度

  • ? fann_set_activation_steepness_layer
  • fann_set_activation_steepness ?
  • PHP Manual
  • Fann 函数
  • 在输出层中设置激活陡度

fann_set_activation_steepness_output

(PECL fann >= 1.0.0)

fann_set_activation_steepness_output — 在输出层中设置激活陡度

说明

fann_set_activation_steepness_output ( resource $ann , float $activation_steepness ) : bool

在输出层中设置激活陡度。

参数

ann

神经网络 资源。

activation_steepness

激活陡度。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_activation_steepness() - 为提供的神经元和层设置激活陡度
  • fann_set_activation_steepness_layer() - 为提供的层中所有的神经元设置激活陡度
  • fann_set_activation_steepness_hidden() - 为所有隐藏层中所有的神经元设置激活函数陡度
  • fann_get_activation_steepness() - 为提供的神经和网络层数返回激活陡度
  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数


为提供的神经元和层设置激活陡度

  • ? fann_set_activation_steepness_output
  • fann_set_bit_fail_limit ?
  • PHP Manual
  • Fann 函数
  • 为提供的神经元和层设置激活陡度

fann_set_activation_steepness

(PECL fann >= 1.0.0)

fann_set_activation_steepness — 为提供的神经元和层设置激活陡度

说明

fann_set_activation_steepness ( resource $ann , float $activation_steepness , int $layer , int $neuron ) : bool

为层数为 layer，神经元数为 neuron 的神经元设置激活陡度，输出层的层数计为0。

为输入层中的神经元设置激活陡度是不可能的。.

激活函数的陡度表示激活从最大值到最小值有多快。一个高的激活函数值也会导致一个更积极的训练。

当训练神经网络中输出值处于一个极端值(通常为0或者1，取决于激活函数)时，可以使用陡峭的激活函数(比如 1.0)。

默认激活陡度是0.5。

参数

ann

神经网络 资源。

activation_steepness

激活陡度。

layer

层数。

neuron

神经元数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_activation_steepness_layer() - 为提供的层中所有的神经元设置激活陡度
  • fann_set_activation_steepness_hidden() - 为所有隐藏层中所有的神经元设置激活函数陡度
  • fann_set_activation_steepness_output() - 在输出层中设置激活陡度
  • fann_get_activation_steepness() - 为提供的神经和网络层数返回激活陡度
  • fann_set_activation_function() - 为已应用的神经元和层设置激活函数


设置训练期间使用的误差

  • ? fann_set_activation_steepness
  • fann_set_callback ?
  • PHP Manual
  • Fann 函数
  • 设置训练期间使用的误差

fann_set_bit_fail_limit

(PECL fann >= 1.0.0)

fann_set_bit_fail_limit — 设置训练期间使用的误差

说明

fann_set_bit_fail_limit ( resource $ann , float $bit_fail_limit ) : bool

设置训练期间使用的误差。

参数

ann

神经网络 资源。

bit_fail_limit

误差。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_bit_fail_limit() - 返回训练期间使用的误差限制


设置训练期间使用的回调函数。

  • ? fann_set_bit_fail_limit
  • fann_set_cascade_activation_functions ?
  • PHP Manual
  • Fann 函数
  • 设置训练期间使用的回调函数。

fann_set_callback

(PECL fann >= 1.0.0)

fann_set_callback — 设置训练期间使用的回调函数。

说明

fann_set_callback ( resource $ann , collable $callback ) : bool

设置训练期间使用的回调函数。 这意味着它被fann_train_on_data() 或 fann_train_on_file()调用。

参数

ann

神经网络 资源。

callback

提供的回调函数接受以下参数：

  • ann - 神经网络 resource
  • train - 训练数据 resource 或者 当被 fann_train_on_file() 为 null
  • max_epochs - 训练将进行的最大周期数。
  • epochs_between_reports - 在调用该函数之前训练进行的最大周期数。
  • desired_error - 期望的 fann_get_MSE() 或者 fann_get_bit_fail(), 取决于fann_set_train_stop_function()函数选择的停止函数。
  • epochs - The current epoch

回调将会返回 true. 如果返回 false, 表明训练将会终止。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_train_on_file() - 在从某个文件读取的整个数据集上训练一段时间。


设置级联候选激活函数的数组

  • ? fann_set_callback
  • fann_set_cascade_activation_steepnesses ?
  • PHP Manual
  • Fann 函数
  • 设置级联候选激活函数的数组

fann_set_cascade_activation_functions

(PECL fann >= 1.0.0)

fann_set_cascade_activation_functions — 设置级联候选激活函数的数组

说明

fann_set_cascade_activation_functions ( resource $ann , array $cascade_activation_functions ) : bool

设置级联候选激活函数的数组。

想知道哪个候选神经元将会被该数组生成,参见 fann_get_cascade_num_candidates() .

参数

ann

神经网络 资源。

cascade_activation_functions

级联候选激活函数数组。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_activation_functions_count() - 返回级联激活函数的数量
  • fann_set_cascade_activation_functions()


设置级联候选激活陡度的数组。

  • ? fann_set_cascade_activation_functions
  • fann_set_cascade_candidate_change_fraction ?
  • PHP Manual
  • Fann 函数
  • 设置级联候选激活陡度的数组。

fann_set_cascade_activation_steepnesses

(PECL fann >= 1.0.0)

fann_set_cascade_activation_steepnesses — 设置级联候选激活陡度的数组。

说明

fann_set_cascade_activation_steepnesses ( resource $ann , array $cascade_activation_steepnesses_count ) : bool

设置级联候选激活陡度的数组。

想知道哪个候选神经元将会被该数组生成，参见 fann_get_cascade_num_candidates() .

参数

ann

神经网络 资源。

cascade_activation_steepnesses_count

级联候选激活陡度数组。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_activation_steepnesses() - 返回级联激活陡度
  • fann_get_cascade_activation_steepnesses_count() - 激活陡度的数量


设置级联候选更改分数

  • ? fann_set_cascade_activation_steepnesses
  • fann_set_cascade_candidate_limit ?
  • PHP Manual
  • Fann 函数
  • 设置级联候选更改分数

fann_set_cascade_candidate_change_fraction

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_change_fraction — 设置级联候选更改分数

说明

fann_set_cascade_candidate_change_fraction ( resource $ann , float $cascade_candidate_change_fraction ) : bool

设置级联候选更改分数。

参数

ann

神经网络 资源。

cascade_candidate_change_fraction

级联候选更改分数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_candidate_change_fraction() - 返回级联候选变化分数


设置候选限度

  • ? fann_set_cascade_candidate_change_fraction
  • fann_set_cascade_candidate_stagnation_epochs ?
  • PHP Manual
  • Fann 函数
  • 设置候选限度

fann_set_cascade_candidate_limit

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_limit — 设置候选限度

说明

fann_set_cascade_candidate_limit ( resource $ann , float $cascade_candidate_limit ) : bool

设置候选限度。

参数

ann

神经网络 资源。

cascade_candidate_limit

候选限度。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_candidate_limit() - 返回候选限度


设置级联候选停止周期数

  • ? fann_set_cascade_candidate_limit
  • fann_set_cascade_max_cand_epochs ?
  • PHP Manual
  • Fann 函数
  • 设置级联候选停止周期数

fann_set_cascade_candidate_stagnation_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_stagnation_epochs — 设置级联候选停止周期数

说明

fann_set_cascade_candidate_stagnation_epochs ( resource $ann , int $cascade_candidate_stagnation_epochs ) : bool

设置级联候选停止周期数。

参数

ann

神经网络 资源。

cascade_candidate_stagnation_epochs

级联候选停止周期数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_candidate_stagnation_epochs() - 返回层叠候选停滞周期的数量


设置最大候选周期数

  • ? fann_set_cascade_candidate_stagnation_epochs
  • fann_set_cascade_max_out_epochs ?
  • PHP Manual
  • Fann 函数
  • 设置最大候选周期数

fann_set_cascade_max_cand_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_max_cand_epochs — 设置最大候选周期数

说明

fann_set_cascade_max_cand_epochs ( resource $ann , int $cascade_max_cand_epochs ) : bool

设置最大候选周期数。

参数

ann

神经网络 资源。

cascade_max_cand_epochs

设置最大候选周期数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_max_cand_epochs() - 返回候选周期的最大值


设置最大输出周期

  • ? fann_set_cascade_max_cand_epochs
  • fann_set_cascade_min_cand_epochs ?
  • PHP Manual
  • Fann 函数
  • 设置最大输出周期

fann_set_cascade_max_out_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_max_out_epochs — 设置最大输出周期

说明

fann_set_cascade_max_out_epochs ( resource $ann , int $cascade_max_out_epochs ) : bool

设置最大输出周期。

参数

ann

神经网络 资源。

cascade_max_out_epochs

最大输出周期。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_max_out_epochs() - 返回输出周期的最大值


设置最小候选周期

  • ? fann_set_cascade_max_out_epochs
  • fann_set_cascade_min_out_epochs ?
  • PHP Manual
  • Fann 函数
  • 设置最小候选周期

fann_set_cascade_min_cand_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_min_cand_epochs — 设置最小候选周期

说明

fann_set_cascade_min_cand_epochs ( resource $ann , int $cascade_min_cand_epochs ) : bool

设置最小候选周期。

参数

ann

神经网络 资源。

cascade_min_cand_epochs

设置最小候选周期。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_min_cand_epochs() - 返回最小的候选周期


设置最小输出周期

  • ? fann_set_cascade_min_cand_epochs
  • fann_set_cascade_num_candidate_groups ?
  • PHP Manual
  • Fann 函数
  • 设置最小输出周期

fann_set_cascade_min_out_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_min_out_epochs — 设置最小输出周期

说明

fann_set_cascade_min_out_epochs ( resource $ann , int $cascade_min_out_epochs ) : bool

设置最小输出周期。

参数

ann

神经网络 资源。

cascade_min_out_epochs

最小输出周期。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_min_out_epochs() - 返回最小输出周期


设置候选组数量

  • ? fann_set_cascade_min_out_epochs
  • fann_set_cascade_output_change_fraction ?
  • PHP Manual
  • Fann 函数
  • 设置候选组数量

fann_set_cascade_num_candidate_groups

(PECL fann >= 1.0.0)

fann_set_cascade_num_candidate_groups — 设置候选组数量

说明

fann_set_cascade_num_candidate_groups ( resource $ann , int $cascade_num_candidate_groups ) : bool

设置候选组数量。

参数

ann

神经网络 资源。

cascade_num_candidate_groups

候选组数量。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_num_candidate_groups() - 返回候选组的数量


设置级联输出改变分数

  • ? fann_set_cascade_num_candidate_groups
  • fann_set_cascade_output_stagnation_epochs ?
  • PHP Manual
  • Fann 函数
  • 设置级联输出改变分数

fann_set_cascade_output_change_fraction

(PECL fann >= 1.0.0)

fann_set_cascade_output_change_fraction — 设置级联输出改变分数

说明

fann_set_cascade_output_change_fraction ( resource $ann , float $cascade_output_change_fraction ) : bool

设置级联输出改变分数。

参数

ann

神经网络 资源。

cascade_output_change_fraction

级联输出改变分数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_output_change_fraction() - 返回级联输出变化分数


设置级联输出停滞周期的值

  • ? fann_set_cascade_output_change_fraction
  • fann_set_cascade_weight_multiplier ?
  • PHP Manual
  • Fann 函数
  • 设置级联输出停滞周期的值

fann_set_cascade_output_stagnation_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_output_stagnation_epochs — 设置级联输出停滞周期的值

说明

fann_set_cascade_output_stagnation_epochs ( resource $ann , int $cascade_output_stagnation_epochs ) : bool

设置级联输出停滞周期的值。

参数

ann

神经网络 资源。

cascade_output_stagnation_epochs

级联输出停滞周期的值

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_output_stagnation_epochs() - 返回级联输出停滞周期的数量


设置权重因子

  • ? fann_set_cascade_output_stagnation_epochs
  • fann_set_error_log ?
  • PHP Manual
  • Fann 函数
  • 设置权重因子

fann_set_cascade_weight_multiplier

(PECL fann >= 1.0.0)

fann_set_cascade_weight_multiplier — 设置权重因子

说明

fann_set_cascade_weight_multiplier ( resource $ann , float $cascade_weight_multiplier ) : bool

设置权重因子。

参数

ann

神经网络 资源。

cascade_weight_multiplier

权重因子。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_cascade_weight_multiplier() - 返回权重因子


设置错误记录保存的位置。

  • ? fann_set_cascade_weight_multiplier
  • fann_set_input_scaling_params ?
  • PHP Manual
  • Fann 函数
  • 设置错误记录保存的位置。

fann_set_error_log

(PECL fann >= 1.0.0)

fann_set_error_log — 设置错误记录保存的位置。

说明

fann_set_error_log ( resource $errdat , string $log_file ) : void

设置错误记录保存的位置。

参数

errdat

Either neural network resource or neural network trainining data resource.

log_file

日志文件的路径。

返回值

无返回值。


根据训练数据计算将来使用的输入比例参数

  • ? fann_set_error_log
  • fann_set_learning_momentum ?
  • PHP Manual
  • Fann 函数
  • 根据训练数据计算将来使用的输入比例参数

fann_set_input_scaling_params

(PECL fann >= 1.0.0)

fann_set_input_scaling_params — 根据训练数据计算将来使用的输入比例参数

说明

fann_set_input_scaling_params ( resource $ann , resource $train_data , float $new_input_min , float $new_input_max ) : bool

根据训练数据计算将来使用的输入比例参数。

参数

ann

神经网络 资源。

train_data

神经网络训练数据 资源。

new_input_min

缩放后输入数据的期望下限 (不严格遵循)

new_input_max

缩放后输入数据的期望上线 (不严格遵循)

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_output_scaling_params() - 根据训练数据计算将来使用的输出缩放参数


设置学习动量。

  • ? fann_set_input_scaling_params
  • fann_set_learning_rate ?
  • PHP Manual
  • Fann 函数
  • 设置学习动量。

fann_set_learning_momentum

(PECL fann >= 1.0.0)

fann_set_learning_momentum — 设置学习动量。

说明

fann_set_learning_momentum ( resource $ann , float $learning_momentum ) : bool

设置学习动量。

更多信息，参见 fann_get_learning_momentum().

参数

ann

神经网络 资源。

learning_momentum

学习动量。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_learning_momentum() - 返回学习动量
  • fann_set_training_algorithm() - 设置训练算法。


设置学习速率。

  • ? fann_set_learning_momentum
  • fann_set_output_scaling_params ?
  • PHP Manual
  • Fann 函数
  • 设置学习速率。

fann_set_learning_rate

(PECL fann >= 1.0.0)

fann_set_learning_rate — 设置学习速率。

说明

fann_set_learning_rate ( resource $ann , float $learning_rate ) : bool

设置学习速率。

更新信息，参见 fann_get_learning_rate().

参数

ann

神经网络 资源。

learning_rate

学习速率。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_learning_rate() - 返回学习速率
  • fann_set_training_algorithm() - 设置训练算法。


根据训练数据计算将来使用的输出缩放参数

  • ? fann_set_learning_rate
  • fann_set_quickprop_decay ?
  • PHP Manual
  • Fann 函数
  • 根据训练数据计算将来使用的输出缩放参数

fann_set_output_scaling_params

(PECL fann >= 1.0.0)

fann_set_output_scaling_params — 根据训练数据计算将来使用的输出缩放参数

说明

fann_set_output_scaling_params ( resource $ann , resource $train_data , float $new_output_min , float $new_output_max ) : bool

根据训练数据计算将来使用的输出缩放参数

参数

ann

神经网络 资源。

train_data

神经网络训练数据 资源。

new_output_min

缩放后输出数据的期望下限(不严格遵循)

new_output_max

缩放后输出数据的期望上限(不严格遵循)

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_input_scaling_params() - 根据训练数据计算将来使用的输入比例参数


设置quickprop算法衰减因子

  • ? fann_set_output_scaling_params
  • fann_set_quickprop_mu ?
  • PHP Manual
  • Fann 函数
  • 设置quickprop算法衰减因子

fann_set_quickprop_decay

(PECL fann >= 1.0.0)

fann_set_quickprop_decay — 设置quickprop算法衰减因子

说明

fann_set_quickprop_decay ( resource $ann , float $quickprop_decay ) : bool

设置quickprop算法衰减因子。

参数

ann

神经网络 资源。

quickprop_decay

quickprop算法衰减因子。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_quickprop_decay() - 返回衰退值，用于在 quickprop 训练迭代时衰减权重


设置 quickprop 算法放大因子

  • ? fann_set_quickprop_decay
  • fann_set_rprop_decrease_factor ?
  • PHP Manual
  • Fann 函数
  • 设置 quickprop 算法放大因子

fann_set_quickprop_mu

(PECL fann >= 1.0.0)

fann_set_quickprop_mu — 设置 quickprop 算法放大因子

说明

fann_set_quickprop_mu ( resource $ann , float $quickprop_mu ) : bool

设置 quickprop 算法放大因子。

参数

ann

神经网络 资源。

quickprop_mu

放大因子。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_quickprop_mu() - 返回放大系数


使用 RPROP 算法训练时，设置下降因子

  • ? fann_set_quickprop_mu
  • fann_set_rprop_delta_max ?
  • PHP Manual
  • Fann 函数
  • 使用 RPROP 算法训练时，设置下降因子

fann_set_rprop_decrease_factor

(PECL fann >= 1.0.0)

fann_set_rprop_decrease_factor — 使用 RPROP 算法训练时，设置下降因子

说明

fann_set_rprop_decrease_factor ( resource $ann , float $rprop_decrease_factor ) : bool

使用 RPROP 算法训练时，设置下降因子。

参数

ann

神经网络 资源。

rprop_decrease_factor

下降因子。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_rprop_decrease_factor() - 返回 RPROP 训练期间的衰减系数


设置最大步长

  • ? fann_set_rprop_decrease_factor
  • fann_set_rprop_delta_min ?
  • PHP Manual
  • Fann 函数
  • 设置最大步长

fann_set_rprop_delta_max

(PECL fann >= 1.0.0)

fann_set_rprop_delta_max — 设置最大步长

说明

fann_set_rprop_delta_max ( resource $ann , float $rprop_delta_max ) : bool

最大步长是一个正数，决定最大步长可能有多大。

参数

ann

神经网络 资源。

rprop_delta_max

最大步长。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_rprop_delta_max() - 返回最大步长
  • fann_get_rprop_delta_min() - 返回最小步长


设置最小步长

  • ? fann_set_rprop_delta_max
  • fann_set_rprop_delta_zero ?
  • PHP Manual
  • Fann 函数
  • 设置最小步长

fann_set_rprop_delta_min

(PECL fann >= 1.0.0)

fann_set_rprop_delta_min — 设置最小步长

说明

fann_set_rprop_delta_min ( resource $ann , float $rprop_delta_min ) : bool

最小步长是一个小的正数，决定最小步长可能有多小。

参数

ann

神经网络 资源。

rprop_delta_min

最小步长。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_rprop_delta_min() - 返回最小步长


设置初始步长

  • ? fann_set_rprop_delta_min
  • fann_set_rprop_increase_factor ?
  • PHP Manual
  • Fann 函数
  • 设置初始步长

fann_set_rprop_delta_zero

(PECL fann >= 1.0.0)

fann_set_rprop_delta_zero — 设置初始步长

说明

fann_set_rprop_delta_zero ( resource $ann , float $rprop_delta_zero ) : bool

初始步长是确定初始步长的正数。

参数

ann

神经网络 资源。

rprop_delta_zero

初始步长。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_rprop_delta_zero() - 返回初始步长
  • fann_get_rprop_delta_min() - 返回最小步长
  • fann_get_rprop_delta_max() - 返回最大步长


使用 RPROP 算法训练时，设置增长因子

  • ? fann_set_rprop_delta_zero
  • fann_set_sarprop_step_error_shift ?
  • PHP Manual
  • Fann 函数
  • 使用 RPROP 算法训练时，设置增长因子

fann_set_rprop_increase_factor

(PECL fann >= 1.0.0)

fann_set_rprop_increase_factor — 使用 RPROP 算法训练时，设置增长因子

说明

fann_set_rprop_increase_factor ( resource $ann , float $rprop_increase_factor ) : bool

使用 RPROP 算法训练时，设置增长因子。

参数

ann

神经网络 资源。

rprop_increase_factor

增长因子。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_rprop_increase_factor() - 返回 RPROP 训练的递增系数


设置 sarprop 算法的步误差偏移量

  • ? fann_set_rprop_increase_factor
  • fann_set_sarprop_step_error_threshold_factor ?
  • PHP Manual
  • Fann 函数
  • 设置 sarprop 算法的步误差偏移量

fann_set_sarprop_step_error_shift

(PECL fann >= 1.0.0)

fann_set_sarprop_step_error_shift — 设置 sarprop 算法的步误差偏移量

说明

fann_set_sarprop_step_error_shift ( resource $ann , float $sarprop_step_error_shift ) : bool

设置 sarprop 算法的步误差偏移量。

参数

ann

神经网络 资源。

sarprop_step_error_shift

sarprop 算法的步误差偏移量.

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_sarprop_step_error_shift() - 返回 sarprop 步值的误差偏移


设置 sarprop 算法的步误差阈值因子

  • ? fann_set_sarprop_step_error_shift
  • fann_set_sarprop_temperature ?
  • PHP Manual
  • Fann 函数
  • 设置 sarprop 算法的步误差阈值因子

fann_set_sarprop_step_error_threshold_factor

(PECL fann >= 1.0.0)

fann_set_sarprop_step_error_threshold_factor — 设置 sarprop 算法的步误差阈值因子

说明

fann_set_sarprop_step_error_threshold_factor ( resource $ann , float $sarprop_step_error_threshold_factor ) : bool

设置 sarprop 算法的步误差阈值因子。

参数

ann

神经网络 资源。

sarprop_step_error_threshold_factor

sarprop 算法的步误差阈值因子。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_sarprop_step_error_threshold_factor() - 返回 sarprop 算法步值的误差阈值系数


设置 sarprop 算法的温度

  • ? fann_set_sarprop_step_error_threshold_factor
  • fann_set_sarprop_weight_decay_shift ?
  • PHP Manual
  • Fann 函数
  • 设置 sarprop 算法的温度

fann_set_sarprop_temperature

(PECL fann >= 1.0.0)

fann_set_sarprop_temperature — 设置 sarprop 算法的温度

说明

fann_set_sarprop_temperature ( resource $ann , float $sarprop_temperature ) : bool

设置 sarprop 算法的温度。

参数

ann

神经网络 资源。

sarprop_temperature

sarprop 算法的温度。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_sarprop_temperature() - 返回 sarprop 算法温度


设置 sarprop 算法的权重衰减偏移值

  • ? fann_set_sarprop_temperature
  • fann_set_scaling_params ?
  • PHP Manual
  • Fann 函数
  • 设置 sarprop 算法的权重衰减偏移值

fann_set_sarprop_weight_decay_shift

(PECL fann >= 1.0.0)

fann_set_sarprop_weight_decay_shift — 设置 sarprop 算法的权重衰减偏移值

说明

fann_set_sarprop_weight_decay_shift ( resource $ann , float $sarprop_weight_decay_shift ) : bool

设置 sarprop 算法的权重衰减偏移值。

参数

ann

神经网络 资源。

sarprop_weight_decay_shift

sarprop 算法的权重衰减偏移值。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_sarprop_weight_decay_shift() - 返回 sarprop 算法权重衰减变化值


根据训练数据计算输入和输出缩放参数以供将来使用

  • ? fann_set_sarprop_weight_decay_shift
  • fann_set_train_error_function ?
  • PHP Manual
  • Fann 函数
  • 根据训练数据计算输入和输出缩放参数以供将来使用

fann_set_scaling_params

(PECL fann >= 1.0.0)

fann_set_scaling_params — 根据训练数据计算输入和输出缩放参数以供将来使用

说明

fann_set_scaling_params ( resource $ann , resource $train_data , float $new_input_min , float $new_input_max , float $new_output_min , float $new_output_max ) : bool

根据训练数据计算输入和输出缩放参数以供将来使用。

参数

ann

神经网络 资源。

train_data

神经网络训练数据 资源。

new_input_min

缩放后输入数据的期望下限 (不严格遵循)

new_input_max

缩放后输入数据的期望上限 (不严格遵循)

new_output_min

缩放后输出数据的期望下限 (不严格遵循)

new_output_max

缩放后输出数据的期望上限 (不严格遵循)

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_set_input_scaling_params() - 根据训练数据计算将来使用的输入比例参数
  • fann_set_output_scaling_params() - 根据训练数据计算将来使用的输出缩放参数


设置训练期间使用的错误函数。

  • ? fann_set_scaling_params
  • fann_set_train_stop_function ?
  • PHP Manual
  • Fann 函数
  • 设置训练期间使用的错误函数。

fann_set_train_error_function

(PECL fann >= 1.0.0)

fann_set_train_error_function — 设置训练期间使用的错误函数。

说明

fann_set_train_error_function ( resource $ann , int $error_function ) : bool

设置训练期间使用的错误函数。

更多错误函数的信息，参见 error functions 常量.

参数

ann

神经网络 资源。

error_function

error function 常量。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_train_error_function() - 返回训练中使用的错误函数。


设置训练期间使用的停止函数。

  • ? fann_set_train_error_function
  • fann_set_training_algorithm ?
  • PHP Manual
  • Fann 函数
  • 设置训练期间使用的停止函数。

fann_set_train_stop_function

(PECL fann >= 1.0.0)

fann_set_train_stop_function — 设置训练期间使用的停止函数。

说明

fann_set_train_stop_function ( resource $ann , int $stop_function ) : bool

设置训练期间使用的停止函数。

停止函数更多详情，参见 stop functions 常量。

参数

ann

神经网络 资源。

stop_function

stop function 常量。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_train_stop_function() - 返回训练中使用的停止函数。


设置训练算法。

  • ? fann_set_train_stop_function
  • fann_set_weight_array ?
  • PHP Manual
  • Fann 函数
  • 设置训练算法。

fann_set_training_algorithm

(PECL fann >= 1.0.0)

fann_set_training_algorithm — 设置训练算法。

说明

fann_set_training_algorithm ( resource $ann , int $training_algorithm ) : bool

设置训练算法。

更多信息参见 fann_get_training_algorithm().

参数

ann

神经网络 资源。

training_algorithm

Training algorithm 常量

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_get_training_algorithm() - 返回训练算法。


在网络中设置一个连接。

  • ? fann_set_training_algorithm
  • fann_set_weight ?
  • PHP Manual
  • Fann 函数
  • 在网络中设置一个连接。

fann_set_weight_array

(PECL fann >= 1.0.0)

fann_set_weight_array — 在网络中设置一个连接。

说明

fann_set_weight_array ( resource $ann , array $connections ) : bool

在网络中设置一个连接。

只有权重将会被改变，连接和权重将被忽略如果它们不存在于网络中。

参数

ann

神经网络 资源。

connections

一个包含 FANNConnection 对象的数组。

返回值

成功时返回 true，其它情况下返回 false。


在网络中设置一个连接。

  • ? fann_set_weight_array
  • fann_shuffle_train_data ?
  • PHP Manual
  • Fann 函数
  • 在网络中设置一个连接。

fann_set_weight

(PECL fann >= 1.0.0)

fann_set_weight — 在网络中设置一个连接。

说明

fann_set_weight ( resource $ann , int $from_neuron , int $to_neuron , float $weight ) : bool

在网络中设置一个连接。

参数

ann

神经网络 资源。

from_neuron

连接开始处的神经元。

to_neuron

连接结束处的神经元。

weight

连接权重。

返回值

成功时返回 true，其它情况下返回 false。


打算训练数据，使顺序随机。

  • ? fann_set_weight
  • fann_subset_train_data ?
  • PHP Manual
  • Fann 函数
  • 打算训练数据，使顺序随机。

fann_shuffle_train_data

(PECL fann >= 1.0.0)

fann_shuffle_train_data — 打算训练数据，使顺序随机。

说明

fann_shuffle_train_data ( resource $train_data ) : bool

打算训练数据，使顺序随机。 增量训练时推荐使用，但是批训练时并没有什么明显的效果。

参数

train_data

神经网络训练数据 资源。

返回值

成功时返回 true，其它情况下返回 false。


返回一个训练数据子集的副本。

  • ? fann_shuffle_train_data
  • fann_test_data ?
  • PHP Manual
  • Fann 函数
  • 返回一个训练数据子集的副本。

fann_subset_train_data

(PECL fann >= 1.0.0)

fann_subset_train_data — 返回一个训练数据子集的副本。

说明

fann_subset_train_data ( resource $data , int $pos , int $length ) : resource

返回一个训练数据子集的副本 resource, 从 pos 位置开始向前步进 length 个元素。

fann_subset_train_data(train_data, 0, fann_length_train_data(train_data)) 和 fann_duplicate_train_data()函数的效果是一样的。

参数

data

神经网络训练数据 资源。

pos

起始位置。

length

复制元素的数量。

返回值

成功时返回训练数据 资源，发生错误返回 false。

参见

  • fann_duplicate_train_data() - 返回 fann 训练数据精确的副本。


使用训练数据来测试并且计算出 MSE

  • ? fann_subset_train_data
  • fann_test ?
  • PHP Manual
  • Fann 函数
  • 使用训练数据来测试并且计算出 MSE

fann_test_data

(PECL fann >= 1.0.0)

fann_test_data — 使用训练数据来测试并且计算出 MSE

说明

fann_test_data ( resource $ann , resource $data ) : float

使用训练数据来测试并且计算出 MSE。

该函数将会更新 MSE 和 误差的值。

参数

ann

神经网络 资源。

data

神经网络训练数据 资源。

返回值

成功，则更新 MSE, 错误则返回 false。

参见

  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_train_epoch() - 使用一组训练数据训练一个周期。
  • fann_get_bit_fail() - 失败位的数量
  • fann_get_MSE() - 从网络中读取均方误差。
  • fann_set_training_algorithm() - 设置训练算法。


使用一组输入和一组期望的输出来测试。

  • ? fann_test_data
  • fann_train_epoch ?
  • PHP Manual
  • Fann 函数
  • 使用一组输入和一组期望的输出来测试。

fann_test

(PECL fann >= 1.0.0)

fann_test — 使用一组输入和一组期望的输出来测试。

说明

fann_test ( resource $ann , array $input , array $desired_output ) : bool

使用一组输入和一组期望的输出来测试。 这个操作将会更新均方误差，但是无论如何都不会改变网络。

参数

ann

神经网络 资源。

input

输入数组。 这个数组必须和 fann_get_num_input() 一样长。

desired_output

期望的输出数组。 这个数组必须和 fann_get_num_output() 一样长.

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_test_data() - 使用训练数据来测试并且计算出 MSE
  • fann_train() - 使用一个输入集和一个期望的输出集来迭代训练一次。
  • fann_get_num_input() - 获取输入神经元的数量。
  • fann_get_num_output() - 获取输出神经元的数量。


使用一组训练数据训练一个周期。

  • ? fann_test
  • fann_train_on_data ?
  • PHP Manual
  • Fann 函数
  • 使用一组训练数据训练一个周期。

fann_train_epoch

(PECL fann >= 1.0.0)

fann_train_epoch — 使用一组训练数据训练一个周期。

说明

fann_train_epoch ( resource $ann , resource $data ) : float

使用保存在 data 中训练数据训练一个周期。一个训练周期表示所有的训练数据正好使用了一次。

这个函数将会返回在其实际计算之前或当中被计算的 MSE 错误。但是因为计算需要再次走一遍整个训练集，所有训练周期之后的不是真正的 MSE。 在训练中使用这个值是绰绰有余的。

该函数使用的是被 fann_set_training_algorithm() 函数选中的训练算法。

参数

ann

神经网络 资源。

data

神经网络训练数据 资源。

返回值

成功，则返回 MSE, 错误则返回 false .

参见

  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_test_data() - 使用训练数据来测试并且计算出 MSE
  • fann_get_MSE() - 从网络中读取均方误差。
  • fann_set_training_algorithm() - 设置训练算法。


在整个数据集上训练一段时间。

  • ? fann_train_epoch
  • fann_train_on_file ?
  • PHP Manual
  • Fann 函数
  • 在整个数据集上训练一段时间。

fann_train_on_data

(PECL fann >= 1.0.0)

fann_train_on_data — 在整个数据集上训练一段时间。

说明

fann_train_on_data ( resource $ann , resource $data , int $max_epochs , int $epochs_between_reports , float $desired_error ) : bool

在整个数据集上训练一段时间。

该训练使用 fann_set_training_algorithm() 函数选择的算法和这些训练算法设置的参数。

参数

ann

神经网络 资源。

data

神经网络训练数据 资源。

max_epochs

训练应该继续的最大周期数。

epochs_between_reports

用户函数之间的周期数。当为0时表示没有用户函数被调用。

desired_error

期望的是 fann_get_MSE() 或 fann_get_bit_fail()的返回值, 取决于 fann_set_train_stop_function() 选择的停止函数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_train_on_file() - 在从某个文件读取的整个数据集上训练一段时间。
  • fann_train_epoch() - 使用一组训练数据训练一个周期。
  • fann_get_bit_fail() - 失败位的数量
  • fann_get_MSE() - 从网络中读取均方误差。
  • fann_set_train_stop_function() - 设置训练期间使用的停止函数。
  • fann_set_training_algorithm() - 设置训练算法。
  • fann_set_callback() - 设置训练期间使用的回调函数。


在从某个文件读取的整个数据集上训练一段时间。

  • ? fann_train_on_data
  • fann_train ?
  • PHP Manual
  • Fann 函数
  • 在从某个文件读取的整个数据集上训练一段时间。

fann_train_on_file

(PECL fann >= 1.0.0)

fann_train_on_file — 在从某个文件读取的整个数据集上训练一段时间。

说明

fann_train_on_file ( resource $ann , string $filename , int $max_epochs , int $epochs_between_reports , float $desired_error ) : bool

在从某个文件读取的整个数据集上训练一段时间。

该训练使用 fann_set_training_algorithm() 函数选择的算法和这些训练算法设置的参数。

参数

ann

神经网络 资源。

filename

包含训练数据的文件。

max_epochs

训练应该继续的最大周期数。

epochs_between_reports

用户函数之间的周期数。当为0时表示没有用户函数被调用。

desired_error

期望的是 fann_get_MSE() 或 fann_get_bit_fail()的返回值, 取决于 fann_set_train_stop_function() 选择的停止函数。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_train_epoch() - 使用一组训练数据训练一个周期。
  • fann_get_bit_fail() - 失败位的数量
  • fann_get_MSE() - 从网络中读取均方误差。
  • fann_set_train_stop_function() - 设置训练期间使用的停止函数。
  • fann_set_training_algorithm() - 设置训练算法。
  • fann_set_callback() - 设置训练期间使用的回调函数。


使用一个输入集和一个期望的输出集来迭代训练一次。

  • ? fann_train_on_file
  • FANNConnection ?
  • PHP Manual
  • Fann 函数
  • 使用一个输入集和一个期望的输出集来迭代训练一次。

fann_train

(PECL fann >= 1.0.0)

fann_train — 使用一个输入集和一个期望的输出集来迭代训练一次。

说明

fann_train ( resource $ann , array $input , array $desired_output ) : bool

使用一个输入集和一个期望的输出集来迭代训练一次。 该训练一直是递增训练，因此只会出现一个模式。

参数

ann

神经网络 资源。

input

输入数组，这个数组的长度应该恰好和 fann_get_num_input() 一样长。

desired_output

期望输出数组，这个数组的长度应该恰好和fann_get_num_output() 一样长。

返回值

成功时返回 true，其它情况下返回 false。

参见

  • fann_train_on_data() - 在整个数据集上训练一段时间。
  • fann_train_epoch() - 使用一组训练数据训练一个周期。
  • fann_get_num_input() - 获取输入神经元的数量。
  • fann_get_num_output() - 获取输出神经元的数量。


FANNConnection 类

(No version information available, might only be in Git)

简介

FANNConnection 被用于神经网络的连接。 该类的对象一般在fann_get_connection_array() 和 fann_set_weight_array()函数中被使用。

类摘要

FANNConnection {
/* 属性 */
public $from_neuron ;
public $to_neuron ;
public $weight ;
/* 方法 */
public __construct ( int $from_neuron , int $to_neuron , float $weight )
public getFromNeuron ( ) : int
public getToNeuron ( ) : int
public getWeight ( ) : void
public setWeight ( float $weight ) : bool
}

属性

from_neuron

开始连接的神经元。

to_neuron

结束连接的神经元。

weight

连接的权重。

Table of Contents

  • FANNConnection::__construct — 连接构造器
  • FANNConnection::getFromNeuron — 返回开始连接的神经元。
  • FANNConnection::getToNeuron — 返回终止神经元的位置。
  • FANNConnection::getWeight — 返回连接权重。
  • FANNConnection::setWeight — 设置连接权重。


连接构造器

  • ? FANNConnection
  • FANNConnection::getFromNeuron ?
  • PHP Manual
  • FANNConnection
  • 连接构造器

FANNConnection::__construct

(PECL fann >= 1.0.0)

FANNConnection::__construct — 连接构造器

说明

public FANNConnection::__construct ( int $from_neuron , int $to_neuron , float $weight )

创建一个新的连接并且初始化它的参数。一旦连接被初始化，只有其权重能被修改。

参数

from_neuron

开始连接的神经元。

to_neuron

结束连接的神经元。

weight

连接的权重。


返回开始连接的神经元。

  • ? FANNConnection::__construct
  • FANNConnection::getToNeuron ?
  • PHP Manual
  • FANNConnection
  • 返回开始连接的神经元。

FANNConnection::getFromNeuron

(PECL fann >= 1.0.0)

FANNConnection::getFromNeuron — 返回开始连接的神经元。

说明

public FANNConnection::getFromNeuron ( ) : int

返回开始连接的神经元。

参数

此函数没有参数。

返回值

开始连接的神经元。


返回终止神经元的位置。

  • ? FANNConnection::getFromNeuron
  • FANNConnection::getWeight ?
  • PHP Manual
  • FANNConnection
  • 返回终止神经元的位置。

FANNConnection::getToNeuron

(PECL fann >= 1.0.0)

FANNConnection::getToNeuron — 返回终止神经元的位置。

说明

public FANNConnection::getToNeuron ( ) : int

返回终止神经元的位置。

参数

此函数没有参数。

返回值

终止神经元的位置。


返回连接权重。

  • ? FANNConnection::getToNeuron
  • FANNConnection::setWeight ?
  • PHP Manual
  • FANNConnection
  • 返回连接权重。

FANNConnection::getWeight

(PECL fann >= 1.0.0)

FANNConnection::getWeight — 返回连接权重。

说明

public FANNConnection::getWeight ( ) : void

返回连接权重。

参数

此函数没有参数。

返回值

连接权重。


设置连接权重。

  • ? FANNConnection::getWeight
  • JSON ?
  • PHP Manual
  • FANNConnection
  • 设置连接权重。

FANNConnection::setWeight

(PECL fann >= 1.0.0)

FANNConnection::setWeight — 设置连接权重。

说明

public FANNConnection::setWeight ( float $weight ) : bool

设置连接权重。

该方法不同于 fann_set_weight() 方法. 该方法不会网络中的权重值。只有当调用了 fann_set_weight_array() 方法后网络中的权重值才会更改。

参数

weight

连接权重。

返回值

成功时返回 true，其它情况下返回 false。


JavaScript对象符号（JSON）

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • JsonException — The JsonException class
  • JsonSerializable — JSON 序列化接口
    • JsonSerializable::jsonSerialize — 指定需要被序列化成 JSON 的数据
  • JSON 函数
    • json_decode — 对 JSON 格式的字符串进行解码
    • json_encode — 对变量进行 JSON 编码
    • json_last_error_msg — Returns the error string of the last json_encode() or json_decode() call
    • json_last_error — 返回最后发生的错误


简介

本扩展实现了 » JavaScript对象符号（JSON） 数据转换格式。 PHP 5 中的解码分析器基于 Douglas Crockford 的 JSON_checker。 PHP 7 中是改进的全新解析器，专门为 PHP 订制，软件许可证为 PHP license。

Note:

PHP 实现了 JSON 的一个超集，参考 » RFC 7159.


安装

自 PHP 5.2.0 起，JSON 扩展默认内置并编译进了 PHP。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/json


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

以下常量表示了 json_last_error() 函数，或 JsonException 类中的 code 变量所返回的错误类型。

JSON_ERROR_NONE (int)
没有错误发生。自 PHP 5.3.0 起生效。
JSON_ERROR_DEPTH (int)
到达了最大堆栈深度。自 PHP 5.3.0 起生效。
JSON_ERROR_STATE_MISMATCH (int)
出现了下溢（underflow）或者模式不匹配。自 PHP 5.3.0 起生效。
JSON_ERROR_CTRL_CHAR (int)
控制字符错误，可能是编码不对。自 PHP 5.3.0 起生效。
JSON_ERROR_SYNTAX (int)
语法错误。自 PHP 5.3.0 起生效。
JSON_ERROR_UTF8 (int)
异常的 UTF-8 字符，也许是因为不正确的编码。自 PHP 5.3.3 起生效。
JSON_ERROR_RECURSION (int)
传递给 json_encode() 函数的对象或数组包含了递归引用，导致无法被编码。如果打开了 JSON_PARTIAL_OUTPUT_ON_ERROR 选项，则牵涉到递归引用的数据会转换成 null 后返回。自 PHP 5.5.0 起生效。
JSON_ERROR_INF_OR_NAN (int)
传递给 json_encode() 函数的参数中包含了 NAN 或 INF，导致编码出错。如果打开了 JSON_PARTIAL_OUTPUT_ON_ERROR 选项，则牵涉到对应不可编码的数字，会转换成数字 0 后返回。自 PHP 5.5.0 起生效。
JSON_ERROR_UNSUPPORTED_TYPE (int)
传递了不支持的数据类型给 json_encode() 函数，比如 资源(resource)。如果打开了 JSON_PARTIAL_OUTPUT_ON_ERROR 选项，则对于不支持的数据类型，会转换成 null 后返回。自 PHP 5.5.0 起生效。
JSON_ERROR_INVALID_PROPERTY_NAME (int)
A key starting with \u0000 character was in the string passed to json_decode() when decoding a JSON object into a PHP object. Available since PHP 7.0.0.
JSON_ERROR_UTF16 (int)
Single unpaired UTF-16 surrogate in unicode escape contained in the JSON string passed to json_encode(). Available since PHP 7.0.0.

下面的常量可以和 json_decode() 的 form 选项结合使用。

JSON_BIGINT_AS_STRING (int)
将大数字编码成原始字符原来的值。 自 PHP 5.4.0 起生效。
JSON_OBJECT_AS_ARRAY (int)
Decodes JSON objects as PHP array. This option can be added automatically by calling json_decode() with the second parameter equal to true. Available since PHP 5.4.0.

下面的常量可以和 json_encode() 的 form 选项结合使用。

JSON_HEX_TAG (int)
所有的 < 和 > 转换成 \u003C 和 \u003E。 自 PHP 5.3.0 起生效。
JSON_HEX_AMP (int)
所有的 & 转换成 \u0026。 自 PHP 5.3.0 起生效。
JSON_HEX_APOS (int)
所有的 ' 转换成 \u0027。 自 PHP 5.3.0 起生效。
JSON_HEX_QUOT (int)
所有的 " 转换成 \u0022。 自 PHP 5.3.0 起生效。
JSON_FORCE_OBJECT (int)
使一个非关联数组输出一个类（Object）而非数组。 在数组为空而接受者需要一个类（Object）的时候尤其有用。 自 PHP 5.3.0 起生效。
JSON_NUMERIC_CHECK (int)
将所有数字字符串编码成数字（numbers）。 自 PHP 5.3.3 起生效。
JSON_PRETTY_PRINT (int)
用空白字符格式化返回的数据。 自 PHP 5.4.0 起生效。
JSON_UNESCAPED_SLASHES (int)
不要编码 /。 自 PHP 5.4.0 起生效。
JSON_UNESCAPED_UNICODE (int)
以字面编码多字节 Unicode 字符（默认是编码成 \uXXXX）。 自 PHP 5.4.0 起生效。
JSON_PARTIAL_OUTPUT_ON_ERROR (int)
Substitute some unencodable values instead of failing. Available since PHP 5.5.0.
JSON_PRESERVE_ZERO_FRACTION (int)
Ensures that float values are always encoded as a float value. Available since PHP 5.6.6.
JSON_UNESCAPED_LINE_TERMINATORS (int)
The line terminators are kept unescaped when JSON_UNESCAPED_UNICODE is supplied. It uses the same behaviour as it was before PHP 7.1 without this constant. Available since PHP 7.1.0.

下面的常量可以和 json_decode() 及 json_encode() 的 form 选项结合使用。

JSON_INVALID_UTF8_IGNORE (int)
Ignore invalid UTF-8 characters. Available as of PHP 7.2.0.
JSON_INVALID_UTF8_SUBSTITUTE (int)
Convert invalid UTF-8 characters to \0xfffd (Unicode Character 'REPLACEMENT CHARACTER') Available as of PHP 7.2.0.
JSON_THROW_ON_ERROR (int)
Throws JsonException if an error occurs instead of setting the global error state that is retrieved with json_last_error() and json_last_error_msg(). JSON_PARTIAL_OUTPUT_ON_ERROR takes precedence over JSON_THROW_ON_ERROR. Available as of PHP 7.3.0.


The JsonException class

(PHP 7 >= 7.3.0, PHP 8)

简介

Exception thrown if JSON_THROW_ON_ERROR option is
set for json_encode() or
json_decode(). code contains the error
type, for possible values see json_last_error().

类摘要

JsonException extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


JSON 序列化接口

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

简介

实现 JsonSerializable 的类可以 在 json_encode() 时定制他们的 JSON 表示法。

接口摘要

JsonSerializable {
/* 方法 */
abstract public jsonSerialize ( ) : mixed
}

Table of Contents

  • JsonSerializable::jsonSerialize — 指定需要被序列化成 JSON 的数据


指定需要被序列化成 JSON 的数据

  • ? JsonSerializable
  • JSON 函数 ?
  • PHP Manual
  • JsonSerializable
  • 指定需要被序列化成 JSON 的数据

JsonSerializable::jsonSerialize

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

JsonSerializable::jsonSerialize — 指定需要被序列化成 JSON 的数据

说明

abstract public JsonSerializable::jsonSerialize ( ) : mixed

序列化物体（Object）成能被 json_encode() 原生地序列化的值。

参数

此函数没有参数。

返回值

返回能被 json_encode() 序列化的数据， 这个值可以是除了 resource 外的任意类型。

范例

Example #1 JsonSerializable::jsonSerialize() 例子 returning an array

<?php
class ArrayValue implements JsonSerializable {
    public function __construct(array $array) {
        $this->array = $array;
    }

    public function jsonSerialize() {
        return $this->array;
    }
}

$array = [1, 2, 3];
echo json_encode(new ArrayValue($array), JSON_PRETTY_PRINT);
?>

以上例程会输出：

[
    1,
    2,
    3
]

Example #2 JsonSerializable::jsonSerialize() 例子 返回了一个关联数组 array

<?php
class ArrayValue implements JsonSerializable {
    public function __construct(array $array) {
        $this->array = $array;
    }

    public function jsonSerialize() {
        return $this->array;
    }
}

$array = ['foo' => 'bar', 'quux' => 'baz'];
echo json_encode(new ArrayValue($array), JSON_PRETTY_PRINT);
?>

以上例程会输出：

{
    "foo": "bar",
    "quux": "baz"
}

Example #3 JsonSerializable::jsonSerialize() 例子 返回一个 integer

<?php
class IntegerValue implements JsonSerializable {
    public function __construct($number) {
        $this->number = (integer) $number;
    }

    public function jsonSerialize() {
        return $this->number;
    }
}

echo json_encode(new IntegerValue(1), JSON_PRETTY_PRINT);
?>

以上例程会输出：

1

Example #4 JsonSerializable::jsonSerialize() 例子 返回一个 string

<?php
class StringValue implements JsonSerializable {
    public function __construct($string) {
        $this->string = (string) $string;
    }

    public function jsonSerialize() {
        return $this->string;
    }
}

echo json_encode(new StringValue('Hello!'), JSON_PRETTY_PRINT);
?>

以上例程会输出：

"Hello!"


JSON 函数

Table of Contents

  • json_decode — 对 JSON 格式的字符串进行解码
  • json_encode — 对变量进行 JSON 编码
  • json_last_error_msg — Returns the error string of the last json_encode() or json_decode() call
  • json_last_error — 返回最后发生的错误


对 JSON 格式的字符串进行解码

  • ? JSON 函数
  • json_encode ?
  • PHP Manual
  • JSON 函数
  • 对 JSON 格式的字符串进行解码

json_decode

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL json >= 1.2.0)

json_decode — 对 JSON 格式的字符串进行解码

说明

json_decode ( string $json , bool $assoc = false , int $depth = 512 , int $options = 0 ) : mixed

接受一个 JSON 编码的字符串并且把它转换为 PHP 变量

参数

json

待解码的 json string 格式的字符串。

这个函数仅能处理 UTF-8 编码的数据。

Note:

PHP 实现了 JSON 的一个超集，参考 » RFC 7159.

assoc

当该参数为 true 时，将返回 array 而非 object 。

depth

指定递归深度。

options

由 JSON_BIGINT_AS_STRING, JSON_INVALID_UTF8_IGNORE, JSON_INVALID_UTF8_SUBSTITUTE, JSON_OBJECT_AS_ARRAY, JSON_THROW_ON_ERROR 组成的掩码。 这些常量的行为在JSON constants页面有进一步描述。

返回值

通过恰当的 PHP 类型返回在 json 中编码的数据。值true, false 和 null 会相应地返回 true, false 和 null。 如果 json 无法被解码， 或者编码数据深度超过了递归限制的话，将会返回null 。

更新日志

版本 | 说明
7.3.0 | JSON_THROW_ON_ERROR options was added.
7.2.0 | JSON_INVALID_UTF8_IGNORE, and JSON_INVALID_UTF8_SUBSTITUTE options were added.
7.1.0 | An empty JSON key ("") can be encoded to the empty object property instead of using a key with value _empty_.
7.0.0 | Rejected RFC 7159 incompatible number formats - top level (07, 0xff, .1, -.1) and all levels ([1.], [1.e1])
7.0.0 | An empty PHP string or value that after casting to string is an empty string (NULL, FALSE) results in JSON syntax error.
5.6.0 | Invalid non-lowercased variants of the true, false and null literals are no longer accepted as valid input, and will generate warnings.
5.4.0 | JSON_BIGINT_AS_STRING, and JSON_OBJECT_AS_ARRAY options were added.
5.4.0 | The options parameter was added.
5.3.0 | Added the optional depth. The default recursion depth was increased from 128 to 512
5.2.3 | The nesting limit was increased from 20 to 128
5.2.1 | Added support for JSON decoding of basic types.

范例

Example #1 json_decode() 的例子

<?php
$json = '{"a":1,"b":2,"c":3,"d":4,"e":5}';

var_dump(json_decode($json));
var_dump(json_decode($json, true));

?>

以上例程会输出：

object(stdClass)#1 (5) {
    ["a"] => int(1)
    ["b"] => int(2)
    ["c"] => int(3)
    ["d"] => int(4)
    ["e"] => int(5)
}

array(5) {
    ["a"] => int(1)
    ["b"] => int(2)
    ["c"] => int(3)
    ["d"] => int(4)
    ["e"] => int(5)
}

Example #2 Accessing invalid object properties

Accessing elements within an object that contain characters not permitted under PHP's naming convention (e.g. the hyphen) can be accomplished by encapsulating the element name within braces and the apostrophe.

<?php

$json = '{"foo-bar": 12345}';

$obj = json_decode($json);
print $obj->{'foo-bar'}; // 12345

?>

Example #3 common mistakes using json_decode()

<?php

// the following strings are valid JavaScript but not valid JSON

// the name and value must be enclosed in double quotes
// single quotes are not valid
$bad_json = "{ 'bar': 'baz' }";
json_decode($bad_json); // null

// the name must be enclosed in double quotes
$bad_json = '{ bar: "baz" }';
json_decode($bad_json); // null

// trailing commas are not allowed
$bad_json = '{ bar: "baz", }';
json_decode($bad_json); // null

?>

Example #4 depth errors

<?php
// Encode the data.
$json = json_encode(
    array(
        1 => array(
            'English' => array(
                'One',
                'January'
            ),
            'French' => array(
                'Une',
                'Janvier'
            )
        )
    )
);

// Define the errors.
$constants = get_defined_constants(true);
$json_errors = array();
foreach ($constants["json"] as $name => $value) {
    if (!strncmp($name, "JSON_ERROR_", 11)) {
        $json_errors[$value] = $name;
    }
}

// Show the errors for different depths.
foreach (range(4, 3, -1) as $depth) {
    var_dump(json_decode($json, true, $depth));
    echo 'Last error: ', $json_errors[json_last_error()], PHP_EOL, PHP_EOL;
}
?>

以上例程会输出：

array(1) {
  [1]=>
  array(2) {
    ["English"]=>
    array(2) {
      [0]=>
      string(3) "One"
      [1]=>
      string(7) "January"
    }
    ["French"]=>
    array(2) {
      [0]=>
      string(3) "Une"
      [1]=>
      string(7) "Janvier"
    }
  }
}
Last error: JSON_ERROR_NONE

NULL
Last error: JSON_ERROR_DEPTH

Example #5 json_decode() of large integers

<?php
$json = '{"number": 12345678901234567890}';

var_dump(json_decode($json));
var_dump(json_decode($json, false, 512, JSON_BIGINT_AS_STRING));

?>

以上例程会输出：

object(stdClass)#1 (1) {
  ["number"]=>
  float(1.2345678901235E+19)
}
object(stdClass)#1 (1) {
  ["number"]=>
  string(20) "12345678901234567890"
}

注释

Note:

The JSON spec is not JavaScript, but a subset of JavaScript.

Note:

In the event of a failure to decode, json_last_error() can be used to determine the exact nature of the error.

参见

  • json_encode() - 对变量进行 JSON 编码
  • json_last_error() - 返回最后发生的错误


对变量进行 JSON 编码

  • ? json_decode
  • json_last_error_msg ?
  • PHP Manual
  • JSON 函数
  • 对变量进行 JSON 编码

json_encode

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL json >= 1.2.0)

json_encode — 对变量进行 JSON 编码

说明

json_encode ( mixed $value , int $options = 0 , int $depth = 512 ) : string|false

返回字符串，包含了 value 值 JSON 形式的表示。

编码受传入的 options 参数影响，此外浮点值的编码依赖于 serialize_precision。

参数

value

待编码的 value ，除了 资源(resource) 类型之外，可以为任何数据类型。

所有字符串数据的编码必须是 UTF-8。

Note:

PHP 实现了 JSON 的一个超集，参考 » RFC 7159.

options

由以下常量组成的二进制掩码： JSON_FORCE_OBJECT, JSON_HEX_QUOT, JSON_HEX_TAG, JSON_HEX_AMP, JSON_HEX_APOS, JSON_INVALID_UTF8_IGNORE, JSON_INVALID_UTF8_SUBSTITUTE, JSON_NUMERIC_CHECK, JSON_PARTIAL_OUTPUT_ON_ERROR, JSON_PRESERVE_ZERO_FRACTION, JSON_PRETTY_PRINT, JSON_UNESCAPED_LINE_TERMINATORS, JSON_UNESCAPED_SLASHES, JSON_UNESCAPED_UNICODE, JSON_THROW_ON_ERROR。 关于 JSON 常量详情参考 JSON 常量页面。

depth

设置最大深度。 必须大于0。

返回值

成功则返回 JSON 编码的 string 或者在失败时返回 false 。

更新日志

版本 | 说明
7.3.0 | options 参数新增 JSON_THROW_ON_ERROR 常量。
7.2.0 | options 参数新增 JSON_INVALID_UTF8_IGNORE 和 JSON_INVALID_UTF8_SUBSTITUTE 常量。
7.1.0 | options 参数新增 JSON_UNESCAPED_LINE_TERMINATORS 常量。
7.1.0 | 对 Double 的值进行编码时，使用 serialize_precision 代替 precision。

范例

Example #1 json_encode() 例子

<?php
$arr = array ('a'=>1,'b'=>2,'c'=>3,'d'=>4,'e'=>5);

echo json_encode($arr);
?>

以上例程会输出：

{"a":1,"b":2,"c":3,"d":4,"e":5}

Example #2 json_encode() 函数中 options 参数的用法

<?php
$a = array('<foo>',"'bar'",'"baz"','&blong&', "\xc3\xa9");

echo "Normal: ",  json_encode($a), "\n";
echo "Tags: ",    json_encode($a, JSON_HEX_TAG), "\n";
echo "Apos: ",    json_encode($a, JSON_HEX_APOS), "\n";
echo "Quot: ",    json_encode($a, JSON_HEX_QUOT), "\n";
echo "Amp: ",     json_encode($a, JSON_HEX_AMP), "\n";
echo "Unicode: ", json_encode($a, JSON_UNESCAPED_UNICODE), "\n";
echo "All: ",     json_encode($a, JSON_HEX_TAG | JSON_HEX_APOS | JSON_HEX_QUOT | JSON_HEX_AMP | JSON_UNESCAPED_UNICODE), "\n\n";

$b = array();

echo "Empty array output as array: ", json_encode($b), "\n";
echo "Empty array output as object: ", json_encode($b, JSON_FORCE_OBJECT), "\n\n";

$c = array(array(1,2,3));

echo "Non-associative array output as array: ", json_encode($c), "\n";
echo "Non-associative array output as object: ", json_encode($c, JSON_FORCE_OBJECT), "\n\n";

$d = array('foo' => 'bar', 'baz' => 'long');

echo "Associative array always output as object: ", json_encode($d), "\n";
echo "Associative array always output as object: ", json_encode($d, JSON_FORCE_OBJECT), "\n\n";
?>

以上例程会输出：

Normal: ["<foo>","'bar'","\"baz\"","&blong&","\u00e9"]
Tags: ["\u003Cfoo\u003E","'bar'","\"baz\"","&blong&","\u00e9"]
Apos: ["<foo>","\u0027bar\u0027","\"baz\"","&blong&","\u00e9"]
Quot: ["<foo>","'bar'","\u0022baz\u0022","&blong&","\u00e9"]
Amp: ["<foo>","'bar'","\"baz\"","\u0026blong\u0026","\u00e9"]
Unicode: ["<foo>","'bar'","\"baz\"","&blong&","é"]
All: ["\u003Cfoo\u003E","\u0027bar\u0027","\u0022baz\u0022","\u0026blong\u0026","é"]

Empty array output as array: []
Empty array output as object: {}

Non-associative array output as array: [[1,2,3]]
Non-associative array output as object: {"0":{"0":1,"1":2,"2":3}}

Associative array always output as object: {"foo":"bar","baz":"long"}
Associative array always output as object: {"foo":"bar","baz":"long"}

Example #3 选项 JSON_NUMERIC_CHECK 例子

<?php
echo "Strings representing numbers automatically turned into numbers".PHP_EOL;
$numbers = array('+123123', '-123123', '1.2e3', '0.00001');
var_dump(
 $numbers,
 json_encode($numbers, JSON_NUMERIC_CHECK)
);
echo "Strings containing improperly formatted numbers".PHP_EOL;
$strings = array('+a33123456789', 'a123');
var_dump(
 $strings,
 json_encode($strings, JSON_NUMERIC_CHECK)
);
?>

以上例程的输出类似于：

Strings representing numbers automatically turned into numbers
array(4) {
  [0]=>
  string(7) "+123123"
  [1]=>
  string(7) "-123123"
  [2]=>
  string(5) "1.2e3"
  [3]=>
  string(7) "0.00001"
}
string(28) "[123123,-123123,1200,1.0e-5]"
Strings containing improperly formatted numbers
array(2) {
  [0]=>
  string(13) "+a33123456789"
  [1]=>
  string(4) "a123"
}
string(24) "["+a33123456789","a123"]"

Example #4 连续与非连续数组示例

<?php
echo "连续数组".PHP_EOL;
$sequential = array("foo", "bar", "baz", "blong");
var_dump(
 $sequential,
 json_encode($sequential)
);

echo PHP_EOL."非连续数组".PHP_EOL;
$nonsequential = array(1=>"foo", 2=>"bar", 3=>"baz", 4=>"blong");
var_dump(
 $nonsequential,
 json_encode($nonsequential)
);

echo PHP_EOL."删除一个连续数组值的方式产生的非连续数组".PHP_EOL;
unset($sequential[1]);
var_dump(
 $sequential,
 json_encode($sequential)
);
?>

以上例程会输出：

连续数组
array(4) {
  [0]=>
  string(3) "foo"
  [1]=>
  string(3) "bar"
  [2]=>
  string(3) "baz"
  [3]=>
  string(5) "blong"
}
string(27) "["foo","bar","baz","blong"]"

非连续数组
array(4) {
  [1]=>
  string(3) "foo"
  [2]=>
  string(3) "bar"
  [3]=>
  string(3) "baz"
  [4]=>
  string(5) "blong"
}
string(43) "{"1":"foo","2":"bar","3":"baz","4":"blong"}"

删除一个连续数组值的方式产生的非连续数组
array(3) {
  [0]=>
  string(3) "foo"
  [2]=>
  string(3) "baz"
  [3]=>
  string(5) "blong"
}
string(33) "{"0":"foo","2":"baz","3":"blong"}"

Example #5 选项 JSON_PRESERVE_ZERO_FRACTION 的例子

<?php
var_dump(json_encode(12.0, JSON_PRESERVE_ZERO_FRACTION));
var_dump(json_encode(12.0));
?>

以上例程会输出：

string(4) "12.0"
string(2) "12"

注释

Note:

如果执行失败，可以通过 json_last_error() 函数来获取详细错误信息。

Note:

如果要编码的数组的键不是从0开始的数字，所有的键将会被当作字符串，并明确声明为 key-value 对。

Note:

Like the reference JSON encoder, json_encode() will generate JSON that is a simple value (that is, neither an object nor an array) if given a string, integer, float or boolean as an input value. While most decoders will accept these values as valid JSON, some may not, as the specification is ambiguous on this point.

总而言之，应该测试下 JSON decoder 能否处理 json_encode() 生成的数据。

参见

  • JsonSerializable
  • json_decode() - 对 JSON 格式的字符串进行解码
  • json_last_error() - 返回最后发生的错误
  • serialize() - 产生一个可存储的值的表示


Returns the error string of the last json_encode() or json_decode() call

  • ? json_encode
  • json_last_error ?
  • PHP Manual
  • JSON 函数
  • Returns the error string of the last json_encode() or json_decode() call

json_last_error_msg

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

json_last_error_msg — Returns the error string of the last json_encode() or json_decode() call

说明

json_last_error_msg ( ) : string

Returns the error string of the last json_encode() or json_decode() call, which did not specify JSON_THROW_ON_ERROR.

参数

此函数没有参数。

返回值

Returns the error message on success, or "No error" if no error has occurred.

参见

  • json_last_error() - 返回最后发生的错误


返回最后发生的错误

  • ? json_last_error_msg
  • Lua ?
  • PHP Manual
  • JSON 函数
  • 返回最后发生的错误

json_last_error

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

json_last_error — 返回最后发生的错误

说明

json_last_error ( ) : int

如果有，返回 JSON 编码解码时最后发生的错误。

参数

此函数没有参数。

返回值

返回一个整型（integer），这个值会是以下的常量之一：

JSON 错误码
常量 | 含义 | 可用性
JSON_ERROR_NONE | 没有错误发生 |
JSON_ERROR_DEPTH | 到达了最大堆栈深度 |
JSON_ERROR_STATE_MISMATCH | 无效或异常的 JSON |
JSON_ERROR_CTRL_CHAR | 控制字符错误，可能是编码不对 |
JSON_ERROR_SYNTAX | 语法错误 |
JSON_ERROR_UTF8 | 异常的 UTF-8 字符，也许是因为不正确的编码。 | PHP 5.3.3
JSON_ERROR_RECURSION | One or more recursive references in the value to be encoded | PHP 5.5.0
JSON_ERROR_INF_OR_NAN | One or more NAN or INF values in the value to be encoded | PHP 5.5.0
JSON_ERROR_UNSUPPORTED_TYPE | 指定的类型，值无法编码。 | PHP 5.5.0
JSON_ERROR_INVALID_PROPERTY_NAME | 指定的属性名无法编码。 | PHP 7.0.0
JSON_ERROR_UTF16 | 畸形的 UTF-16 字符，可能因为字符编码不正确。 | PHP 7.0.0

范例

Example #1 json_last_error() 例子

<?php
// 一个有效的 json 字符串
$json[] = '{"Organization": "PHP Documentation Team"}';

// 一个无效的 json 字符串会导致一个语法错误，在这个例子里我们使用 ' 代替了 " 作为引号
$json[] = "{'Organization': 'PHP Documentation Team'}";

foreach ($json as $string) {
    echo 'Decoding: ' . $string;
    json_decode($string);

    switch (json_last_error()) {
        case JSON_ERROR_NONE:
            echo ' - No errors';
        break;
        case JSON_ERROR_DEPTH:
            echo ' - Maximum stack depth exceeded';
        break;
        case JSON_ERROR_STATE_MISMATCH:
            echo ' - Underflow or the modes mismatch';
        break;
        case JSON_ERROR_CTRL_CHAR:
            echo ' - Unexpected control character found';
        break;
        case JSON_ERROR_SYNTAX:
            echo ' - Syntax error, malformed JSON';
        break;
        case JSON_ERROR_UTF8:
            echo ' - Malformed UTF-8 characters, possibly incorrectly encoded';
        break;
        default:
            echo ' - Unknown error';
        break;
    }

    echo PHP_EOL;
}
?>

以上例程会输出：

Decoding: {"Organization": "PHP Documentation Team"} - No errors
Decoding: {'Organization': 'PHP Documentation Team'} - Syntax error, malformed JSON

Example #2 json_encode() 的 json_last_error()

<?php
// 无效的 UTF8 序列
$text = "\xB1\x31";

$json  = json_encode($text);
$error = json_last_error();

var_dump($json, $error === JSON_ERROR_UTF8);
?>

以上例程会输出：

string(4) "null"
bool(true)

参见

  • json_last_error_msg() - Returns the error string of the last json_encode() or json_decode() call
  • json_decode() - 对 JSON 格式的字符串进行解码
  • json_encode() - 对变量进行 JSON 编码


Lua

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • Lua — Lua类
    • Lua::assign — 将一个php变量赋值给Lua
    • Lua::call — 调用Lua函数
    • Lua::__construct — Lua 构造方法
    • Lua::eval — 将字符串当做Lua代码执行
    • Lua::getVersion — 获取Lua版本
    • Lua::include — 解析Lua脚本文件
    • Lua::registerCallback — 向Lua中注册php函数
  • LuaClosure — LuaClosure类
    • LuaClosure::__invoke — 调用luaclosure


简介

"Lua是一个功能强大，速度快，轻量级，可嵌入的脚本语言。" 这个扩展嵌入Lua解释器，并对lua变量和函数提供面向对象的API。


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

使用这个扩展，需要先安装Lua» Lua主页。


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/lua.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


  • ? 运行时配置
  • Lua ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


Lua类

(PECL lua >=0.9.0)

简介

类摘要

Lua {
/* 常量 */
const string LUA_VERSION = Lua 5.1.4 ;
/* 方法 */
public assign ( string $name , string $value ) : mixed
public call ( callable $lua_func , array $args = ? , int $use_self = 0 ) : mixed
public __call ( callable $lua_func , array $args = ? , int $use_self = 0 ) : mixed
public __construct ( string $lua_script_file = NULL )
public eval ( string $statements ) : mixed
public getVersion ( ) : string
public include ( string $file ) : mixed
public registerCallback ( string $name , callable $function ) : mixed
}

预定义常量

Lua::LUA_VERSION

Table of Contents

  • Lua::assign — 将一个php变量赋值给Lua
  • Lua::call — 调用Lua函数
  • Lua::__construct — Lua 构造方法
  • Lua::eval — 将字符串当做Lua代码执行
  • Lua::getVersion — 获取Lua版本
  • Lua::include — 解析Lua脚本文件
  • Lua::registerCallback — 向Lua中注册php函数


将一个php变量赋值给Lua

  • ? Lua
  • Lua::call ?
  • PHP Manual
  • Lua
  • 将一个php变量赋值给Lua

Lua::assign

(PECL lua >=0.9.0)

Lua::assign — 将一个php变量赋值给Lua

说明

public Lua::assign ( string $name , string $value ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值

赋值成功返回$this否则返回null

范例

Example #1 Lua::assign()示例

<?php
$lua = new Lua();
$lua->assign("php_var", array(1=>1, 2, 3)); //lua table index begin with 1
$lua->eval(<<<CODE
    print(php_var);
CODE
);
?>

以上例程会输出：

Array
 (
     [1] => 1
     [2] => 2
     [3] => 3
 )


调用Lua函数

  • ? Lua::assign
  • Lua::__construct ?
  • PHP Manual
  • Lua
  • 调用Lua函数

Lua::call

Lua::__call

(PECL lua >=0.9.0)

Lua::call -- Lua::__call — 调用Lua函数

说明

public Lua::call ( callable $lua_func , array $args = ? , int $use_self = 0 ) : mixed
public Lua::__call ( callable $lua_func , array $args = ? , int $use_self = 0 ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

lua_func

lua中的函数名。

args

向Lua函数传入的参数。

use_self

是否使用self。

返回值

返回调用函数的结果，参数错误返回null ，其它错误返回false。

范例

Example #1 Lua::call()示例

<?php
$lua = new Lua();
$lua->eval(<<<CODE
    function dummy(foo, bar)
        print(foo, ",", bar)
    end
CODE
);
$lua->call("dummy", array("Lua", "geiliable\n"));
$lua->dummy("Lua", "geiliable"); // __call()
var_dump($lua->call(array("table", "concat"), array(array(1=>1, 2=>2, 3=>3), "-")));
?>

以上例程会输出：

Lua,geiliable
Lua,geiliable
string(5) "1-2-3"

参见

  • __call()


Lua 构造方法

  • ? Lua::call
  • Lua::eval ?
  • PHP Manual
  • Lua
  • Lua 构造方法

Lua::__construct

(PECL lua >=0.9.0)

Lua::__construct — Lua 构造方法

说明

public Lua::__construct ( string $lua_script_file = NULL )

Warning

本函数还未编写文档，仅有参数列表。

参数

lua_script_file

返回值


将字符串当做Lua代码执行

  • ? Lua::__construct
  • Lua::getVersion ?
  • PHP Manual
  • Lua
  • 将字符串当做Lua代码执行

Lua::eval

(PECL lua >=0.9.0)

Lua::eval — 将字符串当做Lua代码执行

说明

public Lua::eval ( string $statements ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

statements

返回值

返回运行结果，参数错误返回null ，其它错误返回false。

范例

Example #1 Lua::eval()示例

<?php
$lua = new Lua();
$lua->eval(<<<CODE
    print(2);
CODE
);
?>

以上例程会输出：

2


获取Lua版本

  • ? Lua::eval
  • Lua::include ?
  • PHP Manual
  • Lua
  • 获取Lua版本

Lua::getVersion

(PECL lua >=0.9.0)

Lua::getVersion — 获取Lua版本

说明

public Lua::getVersion ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回 Lua::LUA_VERSION。


解析Lua脚本文件

  • ? Lua::getVersion
  • Lua::registerCallback ?
  • PHP Manual
  • Lua
  • 解析Lua脚本文件

Lua::include

(PECL lua >=0.9.0)

Lua::include — 解析Lua脚本文件

说明

public Lua::include ( string $file ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

file

返回值

返回脚本文件运行结果，参数错误返回null ，其它错误返回false。


向Lua中注册php函数

  • ? Lua::include
  • LuaClosure ?
  • PHP Manual
  • Lua
  • 向Lua中注册php函数

Lua::registerCallback

(No version information available, might only be in Git)

Lua::registerCallback — 向Lua中注册php函数

说明

public Lua::registerCallback ( string $name , callable $function ) : mixed

向Lua注册php函数，函数名为"$name"

参数

name

function

一个有效的PHP回调函数

返回值

成功返回$this，参数错误返回null ，其它错误返回false。

范例

Example #1 Lua::registerCallback()示例

<?php
$lua = new Lua();
$lua->registerCallback("echo", "var_dump");
$lua->eval(<<<CODE
    echo({1, 2, 3});
CODE
);
?>

以上例程会输出：

array(3) {
  [1]=>
  float(1)
  [2]=>
  float(2)
  [3]=>
  float(3)
}


LuaClosure类

(PECL lua >=0.9.0)

简介

LuaClosure是对LUA_TFUNCTION的封装类，可以作为调用Lua函数的返回值。

类摘要

LuaClosure {
/* 方法 */
public __invoke ( mixed $arg , mixed $... = ? ) : void
}

Table of Contents

  • LuaClosure::__invoke — 调用luaclosure


调用luaclosure

  • ? LuaClosure
  • LuaSandbox ?
  • PHP Manual
  • LuaClosure
  • 调用luaclosure

LuaClosure::__invoke

(PECL lua >=0.9.0)

LuaClosure::__invoke — 调用luaclosure

说明

public LuaClosure::__invoke ( mixed $arg , mixed $... = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

arg

...

返回值

范例

Example #1 LuaClosure::__invoke()示例

<?php
$lua = new Lua();
$closure = $lua->eval(<<<CODE
    return (function ()
        print("hello world")
    end)
CODE
);

$lua->call($closure);
/* after PHP 5.3 */
$closure();
?>

以上例程会输出：

hello worldhello world


LuaSandbox

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • Differences from Standard Lua
  • 范例
    • Basic usage for LuaSandbox
  • LuaSandbox — The LuaSandbox class
    • LuaSandbox::callFunction — Call a function in a Lua global variable
    • LuaSandbox::disableProfiler — Disable the profiler
    • LuaSandbox::enableProfiler — Enable the profiler.
    • LuaSandbox::getCPUUsage — Fetch the current CPU time usage of the Lua environment
    • LuaSandbox::getMemoryUsage — Fetch the current memory usage of the Lua environment
    • LuaSandbox::getPeakMemoryUsage — Fetch the peak memory usage of the Lua environment
    • LuaSandbox::getProfilerFunctionReport — Fetch profiler data
    • LuaSandbox::getVersionInfo — Return the versions of LuaSandbox and Lua
    • LuaSandbox::loadBinary — Load a precompiled binary chunk into the Lua environment
    • LuaSandbox::loadString — Load Lua code into the Lua environment
    • LuaSandbox::pauseUsageTimer — Pause the CPU usage timer
    • LuaSandbox::registerLibrary — Register a set of PHP functions as a Lua library
    • LuaSandbox::setCPULimit — Set the CPU time limit for the Lua environment
    • LuaSandbox::setMemoryLimit — Set the memory limit for the Lua environment
    • LuaSandbox::unpauseUsageTimer — Unpause the timer paused by LuaSandbox::pauseUsageTimer
    • LuaSandbox::wrapPhpFunction — Wrap a PHP callable in a LuaSandboxFunction
  • LuaSandboxFunction — The LuaSandboxFunction class
    • LuaSandboxFunction::call — Call a Lua function
    • LuaSandboxFunction::__construct — Unused
    • LuaSandboxFunction::dump — Dump the function as a binary blob
  • LuaSandboxError — The LuaSandboxError class
  • LuaSandboxErrorError — The LuaSandboxErrorError class
  • LuaSandboxFatalError — The LuaSandboxFatalError class
  • LuaSandboxMemoryError — The LuaSandboxMemoryError class
  • LuaSandboxRuntimeError — The LuaSandboxRuntimeError class
  • LuaSandboxSyntaxError — The LuaSandboxSyntaxError class
  • LuaSandboxTimeoutError — The LuaSandboxTimeoutError class


简介

LuaSandbox is an extension for PHP 5, PHP 7, and HHVM to allow safely running untrusted Lua 5.1 code from within PHP.

Differences compared to the Lua extension:

  • LuaSandbox has support for time and memory limits.

  • LuaSandbox provides a default-safe environment for running untrusted code. Stock Lua functions were reviewed for security, and several were patched accordingly.

  • LuaSandbox has a PHP interface which is more complex, precise and powerful, but it is less convenient for developers.

  • LuaSandbox supports only Lua 5.1. It is difficult to change this, because LuaSandbox uses heavily modified Lua standard libraries, and due to the lack of backwards compatibility between major Lua versions. LuaSandbox aims to maximise backwards compatibility with user-supplied scripts.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • LuaSandbox
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

To use this extension, Lua 5.1 will need to be installed, available on the » Lua homepage.

To make full use of the timer features, LuaSandbox should be installed on Linux.

If FreeBSD or Mac OS X is used, only real (wall-clock) time is supported, the functions purporting to return CPU time will actually return wall clock time.

If Windows is used, no timer functions will be supported. The time limits will be inoperable.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/luasandbox.

If the operating system is Debian 9 or later, or Ubuntu 18.04 or later, then LuaSandbox should typically be installed from the package php-luasandbox:

sudo apt-get install php-luasandbox

Debian 9 users may need to add

deb http://ftp.debian.org/debian stretch-backports main
to their » sources.list.


  • ? 运行时配置
  • Differences from Standard Lua ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


Differences from Standard Lua

LuaSandbox provides a sandboxed environment which differs in some ways from standard Lua 5.1.

Features that are not available

  • dofile(), loadfile(), and the io package, as they allow direct filesystem access. If needed, filesystem access should be done via PHP callbacks.

  • The package package, including require() and module(), as it depends heavily on direct filesystem access. A pure-Lua rewrite such as that used in the MediaWiki Scribunto extension may be used instead.

  • load() and loadstring(), to allow for static analysis of Lua code.

  • print(), since it outputs to standard output. If needed, output should be done via PHP callbacks.

  • Most of the os package, as it allows manipulation of the process and executing of other processes.

    • os.clock(), os.date(), os.difftime(), and os.time() remain available.

  • Most of the debug package, as it allows manipulation of Lua state and metadata in ways that can break sandboxing.

    • debug.traceback() remains available.

  • string.dump(), as it may expose internal data.

  • collectgarbage(), gcinfo(), and the coroutine package have not been reviewed for security.

Features that have been modified

  • pcall() and xpcall() cannot catch certain errors, particularly timeout errors.

  • tostring() does not include pointer addresses.

  • string.match() has been patched to limit the recursion depth and to periodically check for a timeout.

  • math.random() and math.randomseed() are replaced with versions that don't share state with PHP's rand().

  • The Lua 5.2 __pairs and __ipairs metamethods are supported by pairs() and ipairs().


  • ? Differences from Standard Lua
  • Basic usage for LuaSandbox ?
  • PHP Manual
  • LuaSandbox
  • 范例

范例

Table of Contents

  • Basic usage for LuaSandbox


Basic usage for LuaSandbox

Once you've compiled PHP with LuaSandbox support, you can begin using LuaSandbox to safely run user-provided Lua code.

Example #1 Execute some Lua code

<?php

$sandbox = new LuaSandbox;
$sandbox->setMemoryLimit( 50 * 1024 * 1024 );
$sandbox->setCPULimit( 10 );

// Register some functions in the Lua environment

function frobnosticate( $v ) {
    return [ $v + 42 ];
}

$sandbox->registerLibrary( 'php', [
    'frobnosticate' => 'frobnosticate',
    'output' => function ( $string ) {
        echo "$string\n";
    },
    'error' => function () {
        throw new LuaSandboxRuntimeError( "Something is wrong" );
    }
] );

// Execute some Lua code, including callbacks into PHP and into Lua

$luaCode = <<<EOF
php.output( "Hello, world" );

return "Hi", function ( v )
    return php.frobnosticate( v + 200 )
end
EOF;

list( $hi, $frob ) = $sandbox->loadString( $luaCode )->call();
assert( $frob->call( 4000 ) === [ 4242 ] );

// PHP-thrown LuaSandboxRuntimeError exceptions can be caught inside Lua

list( $ok, $message ) = $sandbox->loadString( 'return pcall( php.error )' )->call();
assert( !$ok );
assert( $message === 'Something is wrong' );

?>


The LuaSandbox class

(PECL luasandbox >= 1.0.0)

简介

The LuaSandbox class creates a Lua environment and allows for execution of Lua code.

类摘要

LuaSandbox {
/* Constants */
const int SAMPLES = 0 ;
const int SECONDS = 1 ;
const int PERCENT = 2 ;
/* 方法 */
public callFunction ( string $name , mixed ...$args ) : array|bool
public disableProfiler ( ) : void
public enableProfiler ( float $period = 0.02 ) : bool
public getCPUUsage ( ) : float
public getMemoryUsage ( ) : int
public getPeakMemoryUsage ( ) : int
public getProfilerFunctionReport ( int $units = LuaSandbox::SECONDS ) : array
public static getVersionInfo ( ) : array
public loadBinary ( string $code , string $chunkName = '' ) : LuaSandboxFunction
public loadString ( string $code , string $chunkName = '' ) : LuaSandboxFunction
public pauseUsageTimer ( ) : bool
public registerLibrary ( string $libname , array $functions ) : void
public setCPULimit ( float|bool $limit ) : void
public setMemoryLimit ( int $limit ) : void
public unpauseUsageTimer ( ) : void
public wrapPhpFunction ( callable $function ) : LuaSandboxFunction
}

预定义常量

LuaSandbox::SAMPLES

Used with LuaSandbox::getProfilerFunctionReport() to return timings in samples.

LuaSandbox::SECONDS

Used with LuaSandbox::getProfilerFunctionReport() to return timings in seconds.

LuaSandbox::PERCENT

Used with LuaSandbox::getProfilerFunctionReport() to return timings in percentages of the total.

Table of Contents

  • LuaSandbox::callFunction — Call a function in a Lua global variable
  • LuaSandbox::disableProfiler — Disable the profiler
  • LuaSandbox::enableProfiler — Enable the profiler.
  • LuaSandbox::getCPUUsage — Fetch the current CPU time usage of the Lua environment
  • LuaSandbox::getMemoryUsage — Fetch the current memory usage of the Lua environment
  • LuaSandbox::getPeakMemoryUsage — Fetch the peak memory usage of the Lua environment
  • LuaSandbox::getProfilerFunctionReport — Fetch profiler data
  • LuaSandbox::getVersionInfo — Return the versions of LuaSandbox and Lua
  • LuaSandbox::loadBinary — Load a precompiled binary chunk into the Lua environment
  • LuaSandbox::loadString — Load Lua code into the Lua environment
  • LuaSandbox::pauseUsageTimer — Pause the CPU usage timer
  • LuaSandbox::registerLibrary — Register a set of PHP functions as a Lua library
  • LuaSandbox::setCPULimit — Set the CPU time limit for the Lua environment
  • LuaSandbox::setMemoryLimit — Set the memory limit for the Lua environment
  • LuaSandbox::unpauseUsageTimer — Unpause the timer paused by LuaSandbox::pauseUsageTimer
  • LuaSandbox::wrapPhpFunction — Wrap a PHP callable in a LuaSandboxFunction


Call a function in a Lua global variable

  • ? LuaSandbox
  • LuaSandbox::disableProfiler ?
  • PHP Manual
  • LuaSandbox
  • Call a function in a Lua global variable

LuaSandbox::callFunction

(PECL luasandbox >= 1.0.0)

LuaSandbox::callFunction — Call a function in a Lua global variable

说明

public LuaSandbox::callFunction ( string $name , mixed ...$args ) : array|bool

Calls a function in a Lua global variable.

If the name contains "." characters, the function is located via recursive table accesses, as if the name were a Lua expression.

If the variable does not exist, or is not a function, false will be returned and a warning issued.

For more information about calling Lua functions and the return values, see LuaSandboxFunction::call().

参数

name

Lua variable name.

args

Arguments to the function.

返回值

Returns an array of values returned by the Lua function, which may be empty, or false in case of failure.

范例

Example #1 Calling a Lua function

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// Call Lua's string.match
$captures = $sandbox->callFunction( 'string.match', $string, $pattern );

?>


Disable the profiler

  • ? LuaSandbox::callFunction
  • LuaSandbox::enableProfiler ?
  • PHP Manual
  • LuaSandbox
  • Disable the profiler

LuaSandbox::disableProfiler

(PECL luasandbox >= 1.1.0)

LuaSandbox::disableProfiler — Disable the profiler

说明

public LuaSandbox::disableProfiler ( ) : void

Disables the profiler.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • LuaSandbox::enableProfiler() - Enable the profiler.
  • LuaSandbox::getProfilerFunctionReport() - Fetch profiler data


Enable the profiler.

  • ? LuaSandbox::disableProfiler
  • LuaSandbox::getCPUUsage ?
  • PHP Manual
  • LuaSandbox
  • Enable the profiler.

LuaSandbox::enableProfiler

(PECL luasandbox >= 1.1.0)

LuaSandbox::enableProfiler — Enable the profiler.

说明

public LuaSandbox::enableProfiler ( float $period = 0.02 ) : bool

Enables the profiler. Profiling will begin when Lua code is entered.

The profiler periodically samples the Lua environment to record the running function. Testing indicates that at least on Linux, setting a period less than 1ms will lead to a high overrun count but no performance problems.

参数

period

Sampling period in seconds.

返回值

Returns a boolean indicating whether the profiler is enabled.

参见

  • LuaSandbox::disableProfiler() - Disable the profiler
  • LuaSandbox::getProfilerFunctionReport() - Fetch profiler data


Fetch the current CPU time usage of the Lua environment

  • ? LuaSandbox::enableProfiler
  • LuaSandbox::getMemoryUsage ?
  • PHP Manual
  • LuaSandbox
  • Fetch the current CPU time usage of the Lua environment

LuaSandbox::getCPUUsage

(PECL luasandbox >= 1.0.0)

LuaSandbox::getCPUUsage — Fetch the current CPU time usage of the Lua environment

说明

public LuaSandbox::getCPUUsage ( ) : float

Fetches the current CPU time usage of the Lua environment.

This includes time spent in PHP callbacks.

参数

此函数没有参数。

返回值

Returns the current CPU time usage in seconds.

Note:

On Windows, this function always returns zero. On operating systems that do not support CLOCK_THREAD_CPUTIME_ID, such as FreeBSD and Mac OS X, this function will return the elapsed wall-clock time, not CPU time.

参见

  • LuaSandbox::getMemoryUsage() - Fetch the current memory usage of the Lua environment
  • LuaSandbox::getPeakMemoryUsage() - Fetch the peak memory usage of the Lua environment
  • LuaSandbox::setCPULimit() - Set the CPU time limit for the Lua environment


Fetch the current memory usage of the Lua environment

  • ? LuaSandbox::getCPUUsage
  • LuaSandbox::getPeakMemoryUsage ?
  • PHP Manual
  • LuaSandbox
  • Fetch the current memory usage of the Lua environment

LuaSandbox::getMemoryUsage

(PECL luasandbox >= 1.0.0)

LuaSandbox::getMemoryUsage — Fetch the current memory usage of the Lua environment

说明

public LuaSandbox::getMemoryUsage ( ) : int

Fetches the current memory usage of the Lua environment.

参数

此函数没有参数。

返回值

Returns the current memory usage in bytes.

参见

  • LuaSandbox::getPeakMemoryUsage() - Fetch the peak memory usage of the Lua environment
  • LuaSandbox::getCPUUsage() - Fetch the current CPU time usage of the Lua environment
  • LuaSandbox::setMemoryLimit() - Set the memory limit for the Lua environment


Fetch the peak memory usage of the Lua environment

  • ? LuaSandbox::getMemoryUsage
  • LuaSandbox::getProfilerFunctionReport ?
  • PHP Manual
  • LuaSandbox
  • Fetch the peak memory usage of the Lua environment

LuaSandbox::getPeakMemoryUsage

(PECL luasandbox >= 1.0.0)

LuaSandbox::getPeakMemoryUsage — Fetch the peak memory usage of the Lua environment

说明

public LuaSandbox::getPeakMemoryUsage ( ) : int

Fetches the peak memory usage of the Lua environment.

参数

此函数没有参数。

返回值

Returns the peak memory usage in bytes.

参见

  • LuaSandbox::getMemoryUsage() - Fetch the current memory usage of the Lua environment
  • LuaSandbox::getCPUUsage() - Fetch the current CPU time usage of the Lua environment
  • LuaSandbox::setMemoryLimit() - Set the memory limit for the Lua environment


Fetch profiler data

  • ? LuaSandbox::getPeakMemoryUsage
  • LuaSandbox::getVersionInfo ?
  • PHP Manual
  • LuaSandbox
  • Fetch profiler data

LuaSandbox::getProfilerFunctionReport

(PECL luasandbox >= 1.1.0)

LuaSandbox::getProfilerFunctionReport — Fetch profiler data

说明

public LuaSandbox::getProfilerFunctionReport ( int $units = LuaSandbox::SECONDS ) : array

For a profiling instance previously started by LuaSandbox::enableProfiler(), get a report of the cost of each function.

The measurement unit used for the cost is determined by the $units parameter:

LuaSandbox::SAMPLES

Measure in number of samples.

LuaSandbox::SECONDS

Measure in seconds of CPU time.

LuaSandbox::PERCENT

Measure percentage of CPU time.

参数

units

Measurement unit constant.

返回值

Returns profiler measurements, sorted in descending order, as an associative array. Keys are the Lua function names (with source file and line defined in angle brackets), values are the measurements as int or float.

Note:

On Windows, this function always returns an empty array. On operating systems that do not support CLOCK_THREAD_CPUTIME_ID, such as FreeBSD and Mac OS X, this function will report the elapsed wall-clock time, not CPU time.

范例

Example #1 Profiling Lua code

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// Start the profiler
$sandbox->enableProfiler( 0.01 );

// ... Execute some Lua code here ...

// Fetch the profiler data
$data = $sandbox->getProfilerFunctionReport();

?>


Return the versions of LuaSandbox and Lua

  • ? LuaSandbox::getProfilerFunctionReport
  • LuaSandbox::loadBinary ?
  • PHP Manual
  • LuaSandbox
  • Return the versions of LuaSandbox and Lua

LuaSandbox::getVersionInfo

(PECL luasandbox >= 1.6.0)

LuaSandbox::getVersionInfo — Return the versions of LuaSandbox and Lua

说明

public static LuaSandbox::getVersionInfo ( ) : array

Returns the versions of LuaSandbox and Lua.

参数

此函数没有参数。

返回值

Returns an array with two keys:

element | type | description
LuaSandbox | string | The version of the LuaSandbox extension.
Lua | string | The library name and version as defined by the LUA_RELEASE macro, for example, "Lua 5.1.5".


Load a precompiled binary chunk into the Lua environment

  • ? LuaSandbox::getVersionInfo
  • LuaSandbox::loadString ?
  • PHP Manual
  • LuaSandbox
  • Load a precompiled binary chunk into the Lua environment

LuaSandbox::loadBinary

(PECL luasandbox >= 1.0.0)

LuaSandbox::loadBinary — Load a precompiled binary chunk into the Lua environment

说明

public LuaSandbox::loadBinary ( string $code , string $chunkName = '' ) : LuaSandboxFunction

Loads data generated by LuaSandboxFunction::dump().

参数

code

Data from LuaSandboxFunction::dump().

chunkName

Name for the loaded function.

返回值

Returns a LuaSandboxFunction.

参见

  • LuaSandbox::loadString() - Load Lua code into the Lua environment


Load Lua code into the Lua environment

  • ? LuaSandbox::loadBinary
  • LuaSandbox::pauseUsageTimer ?
  • PHP Manual
  • LuaSandbox
  • Load Lua code into the Lua environment

LuaSandbox::loadString

(PECL luasandbox >= 1.0.0)

LuaSandbox::loadString — Load Lua code into the Lua environment

说明

public LuaSandbox::loadString ( string $code , string $chunkName = '' ) : LuaSandboxFunction

Loads Lua code into the Lua environment.

This is the equivalent of standard Lua's loadstring() function.

参数

code

Lua code.

chunkName

Name for the loaded chunk, for use in error traces.

返回值

Returns a LuaSandboxFunction which, when executed, will execute the passed $code.

范例

Example #1 Loading code into Lua

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// Load the code
$function = $sandbox->loadString(
<<<CODE
    return "Hello, world"
CODE
);

// Execute the loaded code
var_dump( $function->call() );

?>

以上例程会输出：

array(1) {
  [0]=>
  string(12) "Hello, world"
}

参见

  • LuaSandbox::registerLibrary() - Register a set of PHP functions as a Lua library
  • LuaSandbox::wrapPhpFunction() - Wrap a PHP callable in a LuaSandboxFunction


Pause the CPU usage timer

  • ? LuaSandbox::loadString
  • LuaSandbox::registerLibrary ?
  • PHP Manual
  • LuaSandbox
  • Pause the CPU usage timer

LuaSandbox::pauseUsageTimer

(PECL luasandbox >= 1.4.0)

LuaSandbox::pauseUsageTimer — Pause the CPU usage timer

说明

public LuaSandbox::pauseUsageTimer ( ) : bool

Pauses the CPU usage timer.

This only has effect when called from within a callback from Lua. When execution returns to Lua, the timer will be automatically unpaused. If a new call into Lua is made, the timer will be unpaused for the duration of that call.

If a PHP callback calls into Lua again with timer not paused, and then that Lua function calls into PHP again, the second PHP call will not be able to pause the timer. The logic is that even though the second PHP call would avoid counting the CPU usage against the limit, the first call still counts it.

参数

此函数没有参数。

返回值

Returns a bool indicating whether the timer is now paused.

范例

Example #1 Manipulating the usage timer

<?php

// create a new LuaSandbox and set a CPU limit
$sandbox = new LuaSandbox();
$sandbox->setCPULimit( 1 );

function doWait( $t ) {
    $end = microtime( true ) + $t;
    while ( microtime( true ) < $end ) {
        // waste CPU cycles
    }
}

// Register a PHP callback
$sandbox->registerLibrary( 'php', [
    'test' => function () use ( $sandbox ) {
        $sandbox->pauseUsageTimer();
        doWait( 5 );

        $sandbox->unpauseUsageTimer();
        doWait( 0.1 );
    },
    'test2' => function () use ( $sandbox ) {
        $sandbox->pauseUsageTimer();
        $sandbox->unpauseUsageTimer();
        doWait( 1.1 );
    }
] );

echo "This should not time out...\n";
$sandbox->loadString( 'php.test()' )->call();

echo "This should time out.\n";
try {
    $sandbox->loadString( 'php.test2()' )->call();
    echo "It did not?\n";
} catch ( LuaSandboxTimeoutError $ex ) {
    echo "It did! " . $ex->getMessage() . "\n";
}

?>

以上例程会输出：

This should not time out...
This should time out.
It did! The maximum execution time for this script was exceeded

参见

  • LuaSandbox::setCPULimit() - Set the CPU time limit for the Lua environment
  • LuaSandbox::unpauseUsageTimer() - Unpause the timer paused by LuaSandbox::pauseUsageTimer


Register a set of PHP functions as a Lua library

  • ? LuaSandbox::pauseUsageTimer
  • LuaSandbox::setCPULimit ?
  • PHP Manual
  • LuaSandbox
  • Register a set of PHP functions as a Lua library

LuaSandbox::registerLibrary

(PECL luasandbox >= 1.0.0)

LuaSandbox::registerLibrary — Register a set of PHP functions as a Lua library

说明

public LuaSandbox::registerLibrary ( string $libname , array $functions ) : void

Registers a set of PHP functions as a Lua library, so that Lua can call the relevant PHP code.

For more information about calling Lua functions and the return values, see LuaSandboxFunction::call().

参数

libname

The name of the library. In the Lua state, the global variable of this name will be set to the table of functions. If the table already exists, the new functions will be added to it.

functions

An array, where each key is a function name, and each value is a corresponding PHP callable.

返回值

没有返回值。

范例

Example #1 Registering PHP functions to call from Lua

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// Register some functions in the Lua environment

function frobnosticate( $v ) {
    return [ $v + 42 ];
}

$sandbox->registerLibrary( 'php', [
    'frobnosticate' => 'frobnosticate',
    'output' => function ( $string ) {
        echo "$string\n";
    },
    'error' => function () {
        throw new LuaSandboxRuntimeError( "Something is wrong" );
    }
] );

?>

参见

  • LuaSandbox::loadString() - Load Lua code into the Lua environment
  • LuaSandbox::wrapPhpFunction() - Wrap a PHP callable in a LuaSandboxFunction


Set the CPU time limit for the Lua environment

  • ? LuaSandbox::registerLibrary
  • LuaSandbox::setMemoryLimit ?
  • PHP Manual
  • LuaSandbox
  • Set the CPU time limit for the Lua environment

LuaSandbox::setCPULimit

(PECL luasandbox >= 1.0.0)

LuaSandbox::setCPULimit — Set the CPU time limit for the Lua environment

说明

public LuaSandbox::setCPULimit ( float|bool $limit ) : void

Sets the CPU time limit for the Lua environment.

If the total user and system time used by the environment after the call to this method exceeds this limit, a LuaSandboxTimeoutError exception is thrown.

Time used in PHP callbacks is included in the limit.

Setting the time limit from a callback while Lua is running causes the timer to be reset, or started if it was not already running.

Note:

On Windows, the CPU limit will be ignored. On operating systems that do not support CLOCK_THREAD_CPUTIME_ID, such as FreeBSD and Mac OS X, wall-clock time rather than CPU time will be limited.

参数

limit

Limit as a float in seconds, or false for no limit.

返回值

没有返回值。

范例

Example #1 Calling a Lua function

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// set a time limit
$sandbox->setCPULimit( 2 );

// Run Lua code
$sandbox->loadString( 'while true do end' )->call();

?>

以上例程的输出类似于：

PHP Fatal error:  Uncaught LuaSandboxTimeoutError: The maximum execution time for this script was exceeded

参见

  • LuaSandbox::getCPUUsage() - Fetch the current CPU time usage of the Lua environment
  • LuaSandbox::setMemoryLimit() - Set the memory limit for the Lua environment


Set the memory limit for the Lua environment

  • ? LuaSandbox::setCPULimit
  • LuaSandbox::unpauseUsageTimer ?
  • PHP Manual
  • LuaSandbox
  • Set the memory limit for the Lua environment

LuaSandbox::setMemoryLimit

(PECL luasandbox >= 1.0.0)

LuaSandbox::setMemoryLimit — Set the memory limit for the Lua environment

说明

public LuaSandbox::setMemoryLimit ( int $limit ) : void

Sets the memory limit for the Lua environment.

If this limit is exceeded, a LuaSandboxMemoryError exception is thrown.

参数

limit

Memory limit in bytes.

返回值

没有返回值。

范例

Example #1 Calling a Lua function

<?php

// create a new LuaSandbox
$sandbox = new LuaSandbox();

// set a memory limit
$sandbox->setMemoryLimit( 50 * 1024 * 1024 );

// Run Lua code
$sandbox->loadString( 'local x = "x"; while true do x = x .. x; end' )->call();

?>

以上例程的输出类似于：

PHP Fatal error:  Uncaught LuaSandboxMemoryError: not enough memory

参见

  • LuaSandbox::getMemoryUsage() - Fetch the current memory usage of the Lua environment
  • LuaSandbox::getPeakMemoryUsage() - Fetch the peak memory usage of the Lua environment
  • LuaSandbox::setCPULimit() - Set the CPU time limit for the Lua environment


Unpause the timer paused by LuaSandbox::pauseUsageTimer

  • ? LuaSandbox::setMemoryLimit
  • LuaSandbox::wrapPhpFunction ?
  • PHP Manual
  • LuaSandbox
  • Unpause the timer paused by LuaSandbox::pauseUsageTimer

LuaSandbox::unpauseUsageTimer

(PECL luasandbox >= 1.4.0)

LuaSandbox::unpauseUsageTimer — Unpause the timer paused by LuaSandbox::pauseUsageTimer()

说明

public LuaSandbox::unpauseUsageTimer ( ) : void

Unpauses the timer paused by LuaSandbox::pauseUsageTimer().

参数

此函数没有参数。

返回值

没有返回值。

参见

  • LuaSandbox::pauseUsageTimer() - Pause the CPU usage timer
  • LuaSandbox::setCPULimit() - Set the CPU time limit for the Lua environment


Wrap a PHP callable in a LuaSandboxFunction

  • ? LuaSandbox::unpauseUsageTimer
  • LuaSandboxFunction ?
  • PHP Manual
  • LuaSandbox
  • Wrap a PHP callable in a LuaSandboxFunction

LuaSandbox::wrapPhpFunction

(PECL luasandbox >= 1.2.0)

LuaSandbox::wrapPhpFunction — Wrap a PHP callable in a LuaSandboxFunction

说明

public LuaSandbox::wrapPhpFunction ( callable $function ) : LuaSandboxFunction

Wraps a PHP callable in a LuaSandboxFunction, so it can be passed into Lua as an anonymous function.

The function must return either an array of values (which may be empty), or null which is equivalent to returning the empty array.

Exceptions will be raised as errors in Lua, however only LuaSandboxRuntimeError exceptions may be caught inside Lua with pcall() or xpcall().

For more information about calling Lua functions and the return values, see LuaSandboxFunction::call().

参数

function

Callable to wrap.

返回值

Returns a LuaSandboxFunction.

参见

  • LuaSandbox::loadString() - Load Lua code into the Lua environment
  • LuaSandbox::registerLibrary() - Register a set of PHP functions as a Lua library


The LuaSandboxFunction class

(PECL luasandbox >= 1.0.0)

简介

Represents a Lua function, allowing it to be called from PHP.

A LuaSandboxFunction may be obtained as a return value from Lua, as a parameter
passed to a callback from Lua, or by using
LuaSandbox::wrapPhpFunction(),
LuaSandbox::loadString(), or
LuaSandbox::loadBinary().

类摘要

LuaSandboxFunction {
/* 方法 */
public call ( string ...$args ) : array|bool
public dump ( ) : string
}

Table of Contents

  • LuaSandboxFunction::call — Call a Lua function
  • LuaSandboxFunction::__construct — Unused
  • LuaSandboxFunction::dump — Dump the function as a binary blob


Call a Lua function

  • ? LuaSandboxFunction
  • LuaSandboxFunction::__construct ?
  • PHP Manual
  • LuaSandboxFunction
  • Call a Lua function

LuaSandboxFunction::call

(PECL luasandbox >= 1.0.0)

LuaSandboxFunction::call — Call a Lua function

说明

public LuaSandboxFunction::call ( string ...$args ) : array|bool

Calls a Lua function.

Errors considered to be the fault of the PHP code will result in the function returning false and E_WARNING being raised, for example, a resource type being used as an argument. Lua errors will result in a LuaSandboxRuntimeError exception being thrown.

PHP and Lua types are converted as follows:

  • PHP null is Lua nil, and vice versa.

  • PHP ints and floats are converted to Lua numbers. Infinity and NAN are supported.

  • Lua numbers without a fractional part between approximately -2**53 and 2**53 are converted to PHP ints, with others being converted to PHP floats.

  • PHP bools are Lua booleans, and vice versa.

  • PHP strings are Lua strings, and vice versa.

  • Lua functions are PHP LuaSandboxFunction objects, and vice versa. General PHP callables are not supported.

  • PHP arrays are converted to Lua tables, and vice versa.

    • Note that Lua typically indexes arrays from 1, while PHP indexes arrays from 0. No adjustment is made for these differing conventions.

    • Self-referential arrays are not supported in either direction.

    • PHP references are dereferenced.

    • Lua __pairs and __ipairs are processed. __index is ignored.

    • When converting from PHP to Lua, integer keys between -2**53 and 2**53 are represented as Lua numbers. All other keys are represented as Lua strings.

    • When converting from Lua to PHP, keys other than strings and numbers will result in an error, as will collisions when converting numbers to strings or vice versa (since PHP considers things like $a[0] and $a["0"] as being equivalent).

  • All other types are unsupported and will raise an error/exception, including general PHP objects and Lua userdata and thread types.

Lua functions inherently return a list of results. So on success, this method returns an array containing all of the values returned by Lua, with int keys starting from zero. Lua may return no results, in which case an empty array is returned.

参数

args

Arguments passed to the function.

返回值

Returns an array of values returned by the function, which may be empty, or false on error.


Unused

  • ? LuaSandboxFunction::call
  • LuaSandboxFunction::dump ?
  • PHP Manual
  • LuaSandboxFunction
  • Unused

LuaSandboxFunction::__construct

(PECL luasandbox >= 1.0.0)

LuaSandboxFunction::__construct — Unused

说明

final private LuaSandboxFunction::__construct ( )

LuaSandboxFunction are obtained as a return value from Lua,
as a parameter passed to a callback from Lua, or by using
LuaSandbox::wrapPhpFunction(),
LuaSandbox::loadString(), or
LuaSandbox::loadBinary(). They cannot be constructed directly.

参数

此函数没有参数。


Dump the function as a binary blob

  • ? LuaSandboxFunction::__construct
  • LuaSandboxError ?
  • PHP Manual
  • LuaSandboxFunction
  • Dump the function as a binary blob

LuaSandboxFunction::dump

(PECL luasandbox >= 1.0.0)

LuaSandboxFunction::dump — Dump the function as a binary blob

说明

public LuaSandboxFunction::dump ( ) : string

Dumps the function as a binary blob.

参数

此函数没有参数。

返回值

Returns a string that may be passed to LuaSandbox::loadBinary().


The LuaSandboxError class

(PECL luasandbox >= 1.0.0)

简介

Base class for LuaSandbox exceptions

类摘要

LuaSandboxError extends Exception {
/* Constants */
const int RUN = 2 ;
const int SYNTAX = 3 ;
const int MEM = 4 ;
const int ERR = 5 ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

预定义常量

LuaSandboxError::RUN

LuaSandboxError::SYNTAX

LuaSandboxError::MEM

LuaSandboxError::ERR


The LuaSandboxErrorError class

(PECL luasandbox >= 1.0.0)

简介

Exception thrown when Lua encounters an error inside an error handler.

类摘要

LuaSandboxErrorError extends LuaSandboxFatalError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LuaSandboxFatalError class

(PECL luasandbox >= 1.0.0)

简介

Uncatchable LuaSandbox exceptions.

These may not be caught inside Lua using pcall() or xpcall().

类摘要

LuaSandboxFatalError extends LuaSandboxError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LuaSandboxMemoryError class

(PECL luasandbox >= 1.0.0)

简介

Exception thrown when Lua cannot allocate memory.

类摘要

LuaSandboxMemoryError extends LuaSandboxFatalError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

参见

  • LuaSandbox::setMemoryLimit()


The LuaSandboxRuntimeError class

(PECL luasandbox >= 1.0.0)

简介

Catchable LuaSandbox runtime exceptions.

These may be caught inside Lua using pcall() or xpcall().

类摘要

LuaSandboxRuntimeError extends LuaSandboxError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LuaSandboxSyntaxError class

(PECL luasandbox >= 1.0.0)

简介

Exception thrown when Lua code cannot be parsed.

类摘要

LuaSandboxSyntaxError extends LuaSandboxFatalError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LuaSandboxTimeoutError class

(PECL luasandbox >= 1.0.0)

简介

Exception thrown when the configured CPU time limit is exceeded.

类摘要

LuaSandboxTimeoutError extends LuaSandboxFatalError {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

参见

  • LuaSandbox::setCPULimit()


杂项函数

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 杂项 函数
    • connection_aborted — 检查客户端是否已经断开
    • connection_status — 返回连接的状态位
    • constant — 返回一个常量的值
    • define — 定义一个常量
    • defined — 检查某个名称的常量是否存在
    • die — 等同于 exit
    • eval — 把字符串作为PHP代码执行
    • exit — 输出一个消息并且退出当前脚本
    • get_browser — 获取浏览器具有的功能
    • __halt_compiler — 中断编译器的执行
    • highlight_file — 语法高亮一个文件
    • highlight_string — 字符串的语法高亮
    • hrtime — 获取系统的高精度时间
    • ignore_user_abort — 设置客户端断开连接时是否中断脚本的执行
    • pack — 将数据打包成二进制字符串
    • php_strip_whitespace — 返回删除注释和空格后的PHP源码
    • sapi_windows_cp_conv — Convert string from one codepage to another
    • sapi_windows_cp_get — Get current codepage
    • sapi_windows_cp_is_utf8 — Indicates whether the codepage is UTF-8 compatible
    • sapi_windows_cp_set — Set process codepage
    • sapi_windows_generate_ctrl_event — Send a CTRL event to another process
    • sapi_windows_set_ctrl_handler — Set or remove a CTRL event handler
    • sapi_windows_vt100_support — Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.
    • show_source — 别名 highlight_file
    • sleep — 延缓执行
    • sys_getloadavg — 获取系统的负载（load average）
    • time_nanosleep — 延缓执行若干秒和纳秒
    • time_sleep_until — 使脚本睡眠到指定的时间为止。
    • uniqid — 生成一个唯一ID
    • unpack — Unpack data from binary string
    • usleep — 以指定的微秒数延迟执行
  • 更新日志


  • ? Misc.
  • 安装／配置 ?
  • PHP Manual
  • Misc.
  • 简介

简介

因为这些函数不适合其他章节，所以放置于此。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

杂项配置选项
名字 | 默认 | 可修改范围 | 更新日志
ignore_user_abort | "0" | PHP_INI_ALL |
highlight.string | "#DD0000" | PHP_INI_ALL |
highlight.comment | "#FF8000" | PHP_INI_ALL |
highlight.keyword | "#007700" | PHP_INI_ALL |
highlight.bg | "#FFFFFF" | PHP_INI_ALL | 在PHP 5.4.0.中已移除
highlight.html | "#0000BB" | PHP_INI_ALL |
highlight.html | "#000000" | PHP_INI_ALL |
browscap | NULL | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

ignore_user_abort boolean

默认值为 false 。 如果设置为 true ，在客户端断开连接后，脚本不会被中止。

参见 ignore_user_abort().

highlight.bg string
highlight.comment string
highlight.default string
highlight.html string
highlight.keyword string
highlight.string string

语法高亮的颜色。可设置为 <font color="??????"> 中任何可接受的代码。

browscap string

浏览器功能文件的位置和文件名 (例如 browscap.ini)。 参见 get_browser()。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

CONNECTION_ABORTED (integer)
CONNECTION_NORMAL (integer)
CONNECTION_TIMEOUT (integer)
__COMPILER_HALT_OFFSET__ (integer)
在PHP 5.1中加入。


杂项 函数

Table of Contents

  • connection_aborted — 检查客户端是否已经断开
  • connection_status — 返回连接的状态位
  • constant — 返回一个常量的值
  • define — 定义一个常量
  • defined — 检查某个名称的常量是否存在
  • die — 等同于 exit
  • eval — 把字符串作为PHP代码执行
  • exit — 输出一个消息并且退出当前脚本
  • get_browser — 获取浏览器具有的功能
  • __halt_compiler — 中断编译器的执行
  • highlight_file — 语法高亮一个文件
  • highlight_string — 字符串的语法高亮
  • hrtime — 获取系统的高精度时间
  • ignore_user_abort — 设置客户端断开连接时是否中断脚本的执行
  • pack — 将数据打包成二进制字符串
  • php_strip_whitespace — 返回删除注释和空格后的PHP源码
  • sapi_windows_cp_conv — Convert string from one codepage to another
  • sapi_windows_cp_get — Get current codepage
  • sapi_windows_cp_is_utf8 — Indicates whether the codepage is UTF-8 compatible
  • sapi_windows_cp_set — Set process codepage
  • sapi_windows_generate_ctrl_event — Send a CTRL event to another process
  • sapi_windows_set_ctrl_handler — Set or remove a CTRL event handler
  • sapi_windows_vt100_support — Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.
  • show_source — 别名 highlight_file
  • sleep — 延缓执行
  • sys_getloadavg — 获取系统的负载（load average）
  • time_nanosleep — 延缓执行若干秒和纳秒
  • time_sleep_until — 使脚本睡眠到指定的时间为止。
  • uniqid — 生成一个唯一ID
  • unpack — Unpack data from binary string
  • usleep — 以指定的微秒数延迟执行


检查客户端是否已经断开

  • ? 杂项 函数
  • connection_status ?
  • PHP Manual
  • 杂项 函数
  • 检查客户端是否已经断开

connection_aborted

(PHP 4, PHP 5, PHP 7, PHP 8)

connection_aborted — 检查客户端是否已经断开

说明

connection_aborted ( ) : int

检查客户端是否已经断开。

返回值

如果客户端已经断开则返回1，否则返回0。

参见

  • connection_status() - 返回连接的状态位
  • ignore_user_abort() - 设置客户端断开连接时是否中断脚本的执行
  • 查看连接处理 了解PHP处理连接的详情。


返回连接的状态位

  • ? connection_aborted
  • constant ?
  • PHP Manual
  • 杂项 函数
  • 返回连接的状态位

connection_status

(PHP 4, PHP 5, PHP 7, PHP 8)

connection_status — 返回连接的状态位

说明

connection_status ( ) : int

获得当前连接的状态位。

返回值

获得当前连接的状态位, 可以用于与 CONNECTION_XXX 定义的常量来确定连接状态。

参见

  • connection_aborted() - 检查客户端是否已经断开
  • ignore_user_abort() - 设置客户端断开连接时是否中断脚本的执行
  • 查看连接处理 了解PHP处理连接的详情。


返回一个常量的值

  • ? connection_status
  • define ?
  • PHP Manual
  • 杂项 函数
  • 返回一个常量的值

constant

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

constant — 返回一个常量的值

说明

constant ( string $name ) : mixed

通过 name 返回常量的值。

当你不知道常量名，却需要获取常量的值时，constant() 就很有用了。也就是常量名储存在一个变量里，或者由函数返回常量名。

该函数也适用 class constants。

参数

name

常量名。

返回值

返回常量的值。如果常量未定义则返回 null。

错误／异常

如果常量未定义，会产生一个 E_WARNING 级别的错误。

范例

Example #1 constant() 的例子

<?php

define("MAXSIZE", 100);

echo MAXSIZE;
echo constant("MAXSIZE"); // same thing as the previous line

interface bar {
    const test = 'foobar!';
}

class foo {
    const test = 'foobar!';
}

$const = 'test';

var_dump(constant('bar::'. $const)); // string(7) "foobar!"
var_dump(constant('foo::'. $const)); // string(7) "foobar!"

?>

参见

  • define() - 定义一个常量
  • defined() - 检查某个名称的常量是否存在
  • Constants 这一节


定义一个常量

  • ? constant
  • defined ?
  • PHP Manual
  • 杂项 函数
  • 定义一个常量

define

(PHP 4, PHP 5, PHP 7, PHP 8)

define — 定义一个常量

说明

define ( string $name , mixed $value , bool $case_insensitive = false ) : bool

在运行时定义一个常量。

参数

name

常量名。

Note:

可以用 define() 定义保留关键词甚至无效名称的常量，并且可以（仅可以）通过 constant() 获取值。 不过，不推荐这么做。

value

常量的值；在 PHP 5 中，value 必须是标量( int、 float、string、boolean、null）在 PHP 7 中还允许是个 array 的值。

Warning

常量还可以定义为 resource 类型，但并不推荐这样做，因为可能会有不可预知的行为发生。

case_insensitive

如果设置为 true，该常量则大小写不敏感。默认是大小写敏感的。比如， CONSTANT 和 Constant 代表了不同的值。

Warning

PHP 7.3.0 起废弃了定义大小写不敏感的常量。

Note:

大小写不敏感的常量以小写的方式储存。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.3.0 | 废弃了 case_insensitive，并将在 8.0.0 版中移除。
7.0.0 | 允许 array 的值。

范例

Example #1 定义常量

<?php
define("CONSTANT", "Hello world.");
echo CONSTANT; // 输出 "Hello world."
echo Constant; // 输出 "Constant" 并导致 Notice

define("GREETING", "Hello you.", true);
echo GREETING; // 输出 "Hello you."
echo Greeting; // 输出 "Hello you."

//  PHP 7 起就可以运行了
define('ANIMALS', array(
    'dog',
    'cat',
    'bird'
));
echo ANIMALS[1]; // 输出 "cat"

?>

Example #2 以保留名称定义常量

本例子说明了以 魔术常量 相同名称定义常量的能力。 由于行为结果过于令人迷惑，所以实践中不推荐。

<?php
var_dump(defined('__LINE__'));
var_dump(define('__LINE__', 'test'));
var_dump(constant('__LINE__'));
var_dump(__LINE__);
?>

以上例程会输出：

bool(false)
bool(true)
string(4) "test"
int(5)

参见

  • defined() - 检查某个名称的常量是否存在
  • constant() - 返回一个常量的值
  • 常量这一节


检查某个名称的常量是否存在

  • ? define
  • die ?
  • PHP Manual
  • 杂项 函数
  • 检查某个名称的常量是否存在

defined

(PHP 4, PHP 5, PHP 7, PHP 8)

defined — 检查某个名称的常量是否存在

说明

defined ( string $name ) : bool

检查该名称的常量是否已定义。

Note:

如果你要检查一个变量是否存在，请使用 isset()。 defined() 函数仅对 constants 有效。如果你要检测某个函数是否存在，使用 function_exists()。

参数

name

常量的名称。

返回值

如果名称 name 的常量已定义，返回 true；未定义则返回 false。

范例

Example #1 检查常量

<?php
/* Note the use of quotes, this is important.  This example is checking
 * if the string 'TEST' is the name of a constant named TEST */
if (defined('TEST')) {
    echo TEST;
}
?>

参见

  • define() - 定义一个常量
  • constant() - 返回一个常量的值
  • get_defined_constants() - 返回所有常量的关联数组，键是常量名，值是常量值
  • function_exists() - 如果给定的函数已经被定义就返回 true
  • 章节 Constants


等同于 exit

  • ? defined
  • eval ?
  • PHP Manual
  • 杂项 函数
  • 等同于 exit

die

(PHP 4, PHP 5, PHP 7, PHP 8)

die — 等同于 exit()

说明

语法结构等同于 exit()。


把字符串作为PHP代码执行

  • ? die
  • exit ?
  • PHP Manual
  • 杂项 函数
  • 把字符串作为PHP代码执行

eval

(PHP 4, PHP 5, PHP 7, PHP 8)

eval — 把字符串作为PHP代码执行

说明

eval ( string $code ) : mixed

把字符串 code 作为PHP代码执行。

Caution

函数eval()语言结构是 非常危险的， 因为它允许执行任意 PHP 代码。 它这样用是很危险的。 如果您仔细的确认过，除了使用此结构以外 别无方法, 请多加注意，不要允许传入任何由用户 提供的、未经完整验证过的数据 。

参数

code

需要被执行的字符串

代码不能包含打开/关闭 PHP tags。比如， 'echo "Hi!";' 不能这样传入： '<?php echo "Hi!"; ?>'。但仍然可以用合适的 PHP tag 来离开、重新进入 PHP 模式。比如 'echo "In PHP mode!"; ?>In HTML mode!<?php echo "Back in PHP mode!";'。

除此之外，传入的必须是有效的 PHP 代码。所有的语句必须以分号结尾。比如 'echo "Hi!"' 会导致一个 parse error，而 'echo "Hi!";' 则会正常运行。

return 语句会立即中止当前字符串的执行。

代码执行的作用域是调用 eval() 处的作用域。因此，eval() 里任何的变量定义、修改，都会在函数结束后被保留。

返回值

eval() 返回 null，除非在执行的代码中 return 了一个值，函数返回传递给 return 的值。 PHP 7 开始，执行的代码里如果有一个 parse error，eval() 会抛出 ParseError 异常。在 PHP 7 之前， 如果在执行的代码中有 parse error，eval() 返回 false，之后的代码将正常执行。无法使用 set_error_handler() 捕获 eval() 中的解析错误。

范例

Example #1 eval() 例子 - 简单的文本合并

<?php
$string = 'cup';
$name = 'coffee';
$str = 'This is a $string with my $name in it.';
echo $str. "\n";
eval("\$str = \"$str\";");
echo $str. "\n";
?>

以上例程会输出：

This is a $string with my $name in it.
This is a cup with my coffee in it.

注释

Note: 因为是一个语言构造器而不是一个函数，不能被 可变函数 调用。

Tip

和直接将结果输出到浏览器一样，可使用输出控制函数来捕获当前函数的输出，然后(例如)保存到一个 string 中。

Note:

如果在执行的代码中产生了一个致命的错误（fatal error），整个脚本会退出。

参见

  • call_user_func() - 把第一个参数作为回调函数调用


输出一个消息并且退出当前脚本

  • ? eval
  • get_browser ?
  • PHP Manual
  • 杂项 函数
  • 输出一个消息并且退出当前脚本

exit

(PHP 4, PHP 5, PHP 7, PHP 8)

exit — 输出一个消息并且退出当前脚本

说明

exit ( string $status = ? ) : void
exit ( int $status ) : void

中止脚本的执行。 尽管调用了 exit()， Shutdown函数 以及 object destructors 总是会被执行。

exit 是个语法结构，如果没有 status 参数要传入，可以省略圆括号。

参数

status

如果 status 是一个字符串，在退出之前该函数会打印 status 。

如果 status 是一个 int，该值会作为退出状态码，并且不会被打印输出。 退出状态码应该在范围0至254，不应使用被PHP保留的退出状态码255。 状态码0用于成功中止程序。

返回值

没有返回值。

范例

Example #1 exit() 例子

<?php

$filename = '/path/to/data-file';
$file = fopen($filename, 'r')
    or exit("unable to open file ($filename)");

?>

Example #2 exit() 状态码例子

<?php

//exit program normally
exit;
exit();
exit(0);

//exit with an error code
exit(1);
exit(0376); //octal

?>

Example #3 无论如何，Shutdown函数与析构函数都会被执行

<?php
class Foo
{
    public function __destruct()
    {
        echo 'Destruct: ' . __METHOD__ . '()' . PHP_EOL;
    }
}

function shutdown()
{
    echo 'Shutdown: ' . __FUNCTION__ . '()' . PHP_EOL;
}

$foo = new Foo();
register_shutdown_function('shutdown');

exit();
echo 'This will not be output.';
?>

以上例程会输出：

 Shutdown: shutdown()
 Destruct: Foo::__destruct()

注释

Note: 因为是一个语言构造器而不是一个函数，不能被 可变函数 调用。

Note:

该语法结构等同于 die()。

参见

  • register_shutdown_function() - 注册一个会在php中止时执行的函数


获取浏览器具有的功能

  • ? exit
  • __halt_compiler ?
  • PHP Manual
  • 杂项 函数
  • 获取浏览器具有的功能

get_browser

(PHP 4, PHP 5, PHP 7, PHP 8)

get_browser — 获取浏览器具有的功能

说明

get_browser ( string $user_agent = ? , bool $return_array = false ) : mixed

通过查找 browscap.ini 文件中的浏览器信息，尝试检测用户的浏览器所具有的功能。

参数

user_agent

要分析的用户代理。默认使用HTTP头中User-Agent的值，不过，你可以通过传递该参数改变User-Agent。(比如查找另一个浏览器的信息)

你可以传递一个 null 来忽略该参数。

return_array

如果设置为 true，该函数会返回一个 array，而不是 object。

返回值

信息会以包含一系列数据的数组或者对象返回。例如：浏览器的主版本号、次版本号和ID字符串；框架、JavaScript、cookies等功能是否支持 true/false 的值。

cookies 的值仅意味着浏览器是否具有接收cookies的功能，不代表用户是否已允许启用cookies。 测试的唯一办法，只有通过 setcookie() 设置一个cookie，刷新页面并检测该cookie的值。

范例

Example #1 列出所有用户浏览器的信息

<?php
echo $_SERVER['HTTP_USER_AGENT'] . "\n\n";

$browser = get_browser(null, true);
print_r($browser);
?>

以上例程的输出类似于：

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Array
(
    [browser_name_regex] => ^mozilla/5\.0 (windows; .; windows nt 5\.1; .*rv:.*) gecko/.* firefox/0\.9.*$
    [browser_name_pattern] => Mozilla/5.0 (Windows; ?; Windows NT 5.1; *rv:*) Gecko/* Firefox/0.9*
    [parent] => Firefox 0.9
    [platform] => WinXP
    [browser] => Firefox
    [version] => 0.9
    [majorver] => 0
    [minorver] => 9
    [cssversion] => 2
    [frames] => 1
    [iframes] => 1
    [tables] => 1
    [cookies] => 1
    [backgroundsounds] =>
    [vbscript] =>
    [javascript] => 1
    [javaapplets] => 1
    [activexcontrols] =>
    [cdf] =>
    [aol] =>
    [beta] => 1
    [win16] =>
    [crawler] =>
    [stripper] =>
    [wap] =>
    [netclr] =>
)

注释

Note:

为了能让该函数运作，在 php.ini 中配置的 browscap 必须指向 browscap.ini 文件的正确位置。

browscap.ini 并未内置在PHP中，不过你可以在这里找到最新的 » php_browscap.ini。

browscap.ini 包含的诸多浏览器信息依赖于用户更新该数据库。该文件的格式不言自明。


中断编译器的执行

  • ? get_browser
  • highlight_file ?
  • PHP Manual
  • 杂项 函数
  • 中断编译器的执行

__halt_compiler

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

__halt_compiler — 中断编译器的执行

说明

__halt_compiler ( ) : void

中断编译器的执行。常用于在PHP脚本内嵌入数据，类似于安装文件。

可以通过常量 __COMPILER_HALT_OFFSET__ 获取数据开始字节所在的位置，且该常量仅被定义于使用了__halt_compiler的文件。

返回值

没有返回值。

范例

Example #1 __halt_compiler() 例子

<?php

// open this file
$fp = fopen(__FILE__, 'r');

// seek file pointer to data
fseek($fp, __COMPILER_HALT_OFFSET__);

// and output it
var_dump(stream_get_contents($fp));

// the end of the script execution
__halt_compiler(); the installation data (eg. tar, gz, PHP, etc.)

注释

Note:

__halt_compiler() 仅能够在最外层使用。


语法高亮一个文件

  • ? __halt_compiler
  • highlight_string ?
  • PHP Manual
  • 杂项 函数
  • 语法高亮一个文件

highlight_file

(PHP 4, PHP 5, PHP 7, PHP 8)

highlight_file — 语法高亮一个文件

说明

highlight_file ( string $filename , bool $return = false ) : mixed

使用PHP内置的语法高亮器所定义的颜色，打印输出或者返回 filename 文件中语法高亮版本的代码。

许多服务器配置了自动高亮 phps 扩展的文件。 比如，访问 example.phps 会显示语法高亮后的文件。 添加以下一行代码到 httpd.conf 使此生效：

AddType application/x-httpd-php-source .phps

参数

filename

欲高亮文件的路径。

return

设置该参数为 true 使函数返回高亮后的代码。

返回值

如果 return 设置为 true，高亮后的代码不会被打印输出，而是以字符串的形式返回。 高亮成功返回 true，否则返回 false。

注释

Caution

应当注意在使用 highlight_file() 时，确认没有在不经意间泄漏敏感信息，类似密码或者其他任何具有潜在安全风险的信息。

Note:

当使用了return 参数时，本函数使用其内部输出缓冲，因此不能在 ob_start() 回调函数的内部使用。

参见

  • highlight_string() - 字符串的语法高亮
  • Highlighting INI 指令


字符串的语法高亮

  • ? highlight_file
  • hrtime ?
  • PHP Manual
  • 杂项 函数
  • 字符串的语法高亮

highlight_string

(PHP 4, PHP 5, PHP 7, PHP 8)

highlight_string — 字符串的语法高亮

说明

highlight_string ( string $str , bool $return = false ) : mixed

使用PHP内置的语法高亮器所定义的颜色，打印输出或者返回输出或者返回语法高亮版本的PHP代码。

参数

str

需要高亮的PHP代码，应当包含开始标签。

return

设置该参数为 true 使函数返回高亮后的代码。

返回值

如果 return 设置为 true，高亮后的代码不会被打印输出，而是以字符串的形式返回。 高亮成功返回 true，否则返回 false。

范例

Example #1 highlight_string() 例子

<?php
highlight_string('<?php phpinfo(); ?>');
?>

以上例程会输出：

<code><span style="color: #000000">
<span style="color: #0000BB">&lt;?php phpinfo</span><span style="color: #007700">(); </span><span style="color: #0000BB">?&gt;</span>
</span>
</code>

注释

Note:

当使用了return 参数时，本函数使用其内部输出缓冲，因此不能在 ob_start() 回调函数的内部使用。

产生的 HTML 标记可能会有更改。

参见

  • highlight_file() - 语法高亮一个文件
  • 高亮 INI 指令


获取系统的高精度时间

  • ? highlight_string
  • ignore_user_abort ?
  • PHP Manual
  • 杂项 函数
  • 获取系统的高精度时间

hrtime

(PHP 7 >= 7.3.0, PHP 8)

hrtime — 获取系统的高精度时间

说明

hrtime ( bool $get_as_number = false ) : mixed

从任意时间点开始统计，返回系统的高精度时间（high resolution time）。 获取的时间戳为单调时间，无法被用户调整。

参数

get_as_number

以 array 还是数字返回高精度时间。

返回值

参数 get_as_number 为 false 时，返回的整型数组格式为 [seconds, nanoseconds]。 否则会以 int （64 位平台）或 float （32 位平台）返回奈秒（nanoseconds）。

范例

Example #1 hrtime() 的用法

<?php
echo hrtime(true), PHP_EOL;
print_r(hrtime());
?>

以上例程的输出类似于：

10444739687370679
Array
(
    [0] => 10444739
    [1] => 687464812
)

参见

  • 高精度记时 扩展
  • microtime() - 返回当前 Unix 时间戳和微秒数


设置客户端断开连接时是否中断脚本的执行

  • ? hrtime
  • pack ?
  • PHP Manual
  • 杂项 函数
  • 设置客户端断开连接时是否中断脚本的执行

ignore_user_abort

(PHP 4, PHP 5, PHP 7, PHP 8)

ignore_user_abort — 设置客户端断开连接时是否中断脚本的执行

说明

ignore_user_abort ( bool $value = ? ) : int

设置客户端断开连接时是否中断脚本的执行

PHP 以命令行脚本执行时，当脚本终端结束，脚本不会被立即中止，除非设置 value 为 true，否则脚本输出任意字符时会被中止。

参数

value

如果设置了该值，函数会把 ignore_user_abort ini 的值设置为 value。 如果未设置该值，函数不会改变设置，仅会返回之前的设置。

返回值

以整型返回之前的设置

范例

Example #1 ignore_user_abort()例子

<?php
// Ignore user aborts and allow the script
// to run forever
ignore_user_abort(true);
set_time_limit(0);

echo 'Testing connection handling in PHP';

// Run a pointless loop that sometime
// hopefully will make us click away from
// page or click the "Stop" button.
while(1)
{
    // Did the connection fail?
    if(connection_status() != CONNECTION_NORMAL)
    {
        break;
    }

    // Sleep for 10 seconds
    sleep(10);
}

// If this is reached, then the 'break'
// was triggered from inside the while loop

// So here we can log, or perform any other tasks
// we need without actually being dependent on the
// browser.
?>

注释

在PHP尝试发送信息到客户端之前，不会检测到用户是否已中断连接。 仅使用 echo 语句不能确保信息已发送，参见 flush() 函数。

参见

  • connection_aborted() - 检查客户端是否已经断开
  • connection_status() - 返回连接的状态位
  • Connection Handling 关于PHP连接处理的完整描述。


将数据打包成二进制字符串

  • ? ignore_user_abort
  • php_strip_whitespace ?
  • PHP Manual
  • 杂项 函数
  • 将数据打包成二进制字符串

pack

(PHP 4, PHP 5, PHP 7, PHP 8)

pack — 将数据打包成二进制字符串

说明

pack ( string $format , mixed $... = ? ) : string

将输入参数打包成 format 格式的二进制字符串。

这个函数的思想来自 Perl，所有格式化代码（format）的工作原理都与 Perl 相同。 但是，缺少了部分格式代码，比如 Perl 的 "u"。

注意，有符号值和无符号值之间的区别只影响函数 unpack()，在那些使用有符号和无符号格式代码的地方 pack() 函数产生相同的结果。

参数

format

format 字符串由格式代码组成，后面跟着一个可选的重复参数。重复参数可以是一个整数值或者 * 值来重复到输入数据的末尾。对于 a, A, h, H 格式化代码，其后的重复参数指定了给定数据将会被使用几个字符串。对于 @，其后的数字表示放置剩余数据的绝对定位（之前的数据将会被空字符串填充），对于其他所有内容，重复数量指定消耗多少个数据参数并将其打包到生成的二进制字符串中。

目前已实现的格式如下：

pack() 格式字符
代码 | 描述
a | 以 NUL 字节填充字符串
A | 以 SPACE(空格) 填充字符串
h | 十六进制字符串，低位在前
H | 十六进制字符串，高位在前
c | 有符号字符
C | 无符号字符
s | 有符号短整型(16位，主机字节序)
S | 无符号短整型(16位，主机字节序)
n | 无符号短整型(16位，大端字节序)
v | 无符号短整型(16位，小端字节序)
i | 有符号整型(机器相关大小字节序)
I | 无符号整型(机器相关大小字节序)
l | 有符号长整型(32位，主机字节序)
L | 无符号长整型(32位，主机字节序)
N | 无符号长整型(32位，大端字节序)
V | 无符号长整型(32位，小端字节序)
q | 有符号长长整型(64位，主机字节序)
Q | 无符号长长整型(64位，主机字节序)
J | 无符号长长整型(64位，大端字节序)
P | 无符号长长整型(64位，小端字节序)
f | 单精度浮点型(机器相关大小)
g | 单精度浮点型(机器相关大小，小端字节序)
G | 单精度浮点型(机器相关大小，大端字节序)
d | 双精度浮点型(机器相关大小)
e | 双精度浮点型(机器相关大小，小端字节序)
E | 双精度浮点型(机器相关大小，大端字节序)
x | NUL 字节
X | 回退已字节
Z | 以 NUL 字节填充字符串空白(自 PHP 5.5 加入)
@ NUL 填充到绝对位置

...

返回值

返回包含数据的二进制字符串， 或者在失败时返回 false。

更新日志

版本 | 说明
7.2.0 | float 和 double 类型支持打断和小端。
7.0.15,7.1.1 | 添加了 "e","E","g" 和 "G" 代码以启用 float 和 double 的字节顺序支持。
5.6.3 | 添加了 "q"、"q"、"J" 和 "P" 代码以支持处理 64 位数字。
5.5.0 | "Z" 代码添加了与 "a" 等效的功能，以实现 Perl 兼容性。

范例

Example #1 pack() 范例

<?php
$binarydata = pack("nvc*", 0x1234, 0x5678, 65, 66);
?>

输出结果为长度为 6 字节的二进制字符串，包含以下序列 0x12, 0x34, 0x78, 0x56, 0x41, 0x42。

注释

Caution

Note that PHP internally stores integer values as signed values of a machine-dependent size (C type long). Integer literals and operations that yield numbers outside the bounds of the integer type will be stored as float. When packing these floats as integers, they are first cast into the integer type. This may or may not result in the desired byte pattern.

The most relevant case is when packing unsigned numbers that would be representable with the integer type if it were unsigned. In systems where the integer type has a 32-bit size, the cast usually results in the same byte pattern as if the integer were unsigned (although this relies on implementation-defined unsigned to signed conversions, as per the C standard). In systems where the integer type has 64-bit size, the float most likely does not have a mantissa large enough to hold the value without loss of precision. If those systems also have a native 64-bit C int type (most UNIX-like systems don't), the only way to use the I pack format in the upper range is to create integer negative values with the same byte representation as the desired unsigned value.

参见

  • unpack() - Unpack data from binary string


返回删除注释和空格后的PHP源码

  • ? pack
  • sapi_windows_cp_conv ?
  • PHP Manual
  • 杂项 函数
  • 返回删除注释和空格后的PHP源码

php_strip_whitespace

(PHP 5, PHP 7, PHP 8)

php_strip_whitespace — 返回删除注释和空格后的PHP源码

说明

php_strip_whitespace ( string $filename ) : string

返回删除注释和空格后 filename 的PHP源码。这对实际代码数量和注释数量的对比很有用。 此函数与 命令行 下执行 php -w 相似。

参数

filename

PHP文件的路径。

返回值

在成功时返回过滤后的代码，或者在失败时返回空字符串。

Note:

此函数在PHP 5.0.1后以所述方式工作。之前它仅会返回一个空字符串。关于更多此BUG的信息与其行为，详见BUG报告 » #29606。

范例

Example #1 php_strip_whitespace() 的例子

<?php
// PHP comment here

/*
 * Another PHP comment
 */

echo        php_strip_whitespace(__FILE__);
// Newlines are considered whitespace, and are removed too:
do_nothing();
?>

以上例程会输出：

<?php
 echo php_strip_whitespace(__FILE__); do_nothing(); ?>

可以注意到PHP的注释已不存在，成为第一个echo语句前的换行和空格。


Convert string from one codepage to another

  • ? php_strip_whitespace
  • sapi_windows_cp_get ?
  • PHP Manual
  • 杂项 函数
  • Convert string from one codepage to another

sapi_windows_cp_conv

(PHP 7 >= 7.1.0, PHP 8)

sapi_windows_cp_conv — Convert string from one codepage to another

说明

sapi_windows_cp_conv ( int|string $in_codepage , int|string $out_codepage , string $subject ) : string

Convert string from one codepage to another.

参数

in_codepage

The codepage of the subject string. Either the codepage name or identifier.

out_codepage

The codepage to convert the subject string to. Either the codepage name or identifier.

subject

The string to convert.

返回值

The subject string converted to out_codepage, or null on failure.

错误／异常

This function issues E_WARNING level errors, if invalid codepages are given, or if the subject is not valid for in_codepage.

参见

  • sapi_windows_cp_get() - Get current codepage
  • iconv() - 字符串按要求的字符编码来转换


Get current codepage

  • ? sapi_windows_cp_conv
  • sapi_windows_cp_is_utf8 ?
  • PHP Manual
  • 杂项 函数
  • Get current codepage

sapi_windows_cp_get

(PHP 7 >= 7.1.0, PHP 8)

sapi_windows_cp_get — Get current codepage

说明

sapi_windows_cp_get ( string $kind = "" ) : int

Gets the current codepage.

参数

kind

The kind of operating system codepage to get, either 'ansi' or 'oem'. Any other value refers to the current codepage of the process.

返回值

If kind is 'ansi', the current ANSI code page of the operating system is returned. If kind is 'oem', the current OEM code page of the operating system is returned. Otherwise, the current codepage of the process is returned.

参见

  • sapi_windows_cp_set() - Set process codepage


Indicates whether the codepage is UTF-8 compatible

  • ? sapi_windows_cp_get
  • sapi_windows_cp_set ?
  • PHP Manual
  • 杂项 函数
  • Indicates whether the codepage is UTF-8 compatible

sapi_windows_cp_is_utf8

(PHP 7 >= 7.1.0, PHP 8)

sapi_windows_cp_is_utf8 — Indicates whether the codepage is UTF-8 compatible

说明

sapi_windows_cp_is_utf8 ( ) : bool

Indicates whether the codepage of the current process is UTF-8 compatible.

参数

此函数没有参数。

返回值

Returns whether the codepage of the current process is UTF-8 compatible.

参见

  • sapi_windows_cp_get() - Get current codepage


Set process codepage

  • ? sapi_windows_cp_is_utf8
  • sapi_windows_generate_ctrl_event ?
  • PHP Manual
  • 杂项 函数
  • Set process codepage

sapi_windows_cp_set

(PHP 7 >= 7.1.0, PHP 8)

sapi_windows_cp_set — Set process codepage

说明

sapi_windows_cp_set ( int $cp ) : bool

Set the codepage of the current process.

参数

cp

A codepage identifier.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • sapi_windows_cp_get() - Get current codepage


Send a CTRL event to another process

  • ? sapi_windows_cp_set
  • sapi_windows_set_ctrl_handler ?
  • PHP Manual
  • 杂项 函数
  • Send a CTRL event to another process

sapi_windows_generate_ctrl_event

(PHP 7 >= 7.4.0, PHP 8)

sapi_windows_generate_ctrl_event — Send a CTRL event to another process

说明

sapi_windows_generate_ctrl_event ( int $event , int $pid = 0 ) : bool

Sends a CTRL event to another process in the same process group.

参数

event

The CTRL even to send; either PHP_WINDOWS_EVENT_CTRL_C or PHP_WINDOWS_EVENT_CTRL_BREAK.

pid

The ID of the process to which to send the event to. If 0 is given, the event is sent to all processes of the process group.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Basic sapi_windows_generate_ctrl_event() Usage

This example shows how to pass along CTRL+BREAK events to a child process. In this case the child process echoes I'm still alive every second, until the user presses CTRL+BREAK, what causes only the child process to be terminated.

<?php
// forward CTRL+BREAK events to the child process
sapi_windows_set_ctrl_handler('sapi_windows_generate_ctrl_event');

// create a child process which echoes every second
$cmd = ['php', '-r', 'while (true) { echo "I\'m still alive\n"; sleep(1); }'];
$descspec = array(['pipe', 'r'], ['pipe', 'w'], ['pipe', 'w']);
$options = ['create_process_group' => true];
$proc = proc_open($cmd, $descspec, $pipes, null, null, $options);
while (true) {
    echo fgets($pipes[1]);
}
?>

参见

  • proc_open() - 执行一个命令，并且打开用来输入/输出的文件指针。
  • sapi_windows_set_ctrl_handler() - Set or remove a CTRL event handler


Set or remove a CTRL event handler

  • ? sapi_windows_generate_ctrl_event
  • sapi_windows_vt100_support ?
  • PHP Manual
  • 杂项 函数
  • Set or remove a CTRL event handler

sapi_windows_set_ctrl_handler

(PHP 7 >= 7.4.0, PHP 8)

sapi_windows_set_ctrl_handler — Set or remove a CTRL event handler

说明

sapi_windows_set_ctrl_handler ( callable $callable , bool $add = true ) : bool

Sets or removes a CTRL event handler, which allows Windows CLI processes to intercept or ignore CTRL+C and CTRL+BREAK events. Note that in multithreaded environments, this is only possible when called from the main thread.

参数

callable

A callback function to set or remove. If set, this function will be called whenever a CTRL+C or CTRL+BREAK event occurs. The function is supposed to have the following signature:

handler ( int $event ) : void
event
The CTRL event which has been received; either PHP_WINDOWS_EVENT_CTRL_C or PHP_WINDOWS_EVENT_CTRL_BREAK.
Setting a null callable causes the process to ignore CTRL+C events, but not CTRL+BREAK events.

add

If true, the handler is set. If false, the handler is removed.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Basic sapi_windows_set_ctrl_handler() Usage

This example shows how to intercept CTRL events.

<?php
function ctrl_handler(int $event)
{
    switch ($event) {
        case PHP_WINDOWS_EVENT_CTRL_C:
            echo "You have pressed CTRL+C\n";
            break;
        case PHP_WINDOWS_EVENT_CTRL_BREAK:
            echo "You have pressed CTRL+BREAK\n";
            break;
    }
}

sapi_windows_set_ctrl_handler('ctrl_handler');
while (true); // infinite loop, so the handler can be triggered
?>

参见

  • sapi_windows_generate_ctrl_event() - Send a CTRL event to another process


Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.

  • ? sapi_windows_set_ctrl_handler
  • show_source ?
  • PHP Manual
  • 杂项 函数
  • Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.

sapi_windows_vt100_support

(PHP 7 >= 7.2.0, PHP 8)

sapi_windows_vt100_support — Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.

说明

sapi_windows_vt100_support ( resource $stream , bool $enable = ? ) : bool

If enable is omitted, the function returns true if the stream stream has VT100 control codes enabled, false otherwise.

If enable is specified, the function will try to enable or disable the VT100 features of the stream stream. If the feature has been successfully enabled (or disabled), the function will return true, or false otherwise.

At startup, PHP tries to enable the VT100 feature of the STDOUT/STDERR streams. By the way, if those streams are redirected to a file, the VT100 features may not be enabled.

If VT100 support is enabled, it is possible to use control sequences as they are known from the VT100 terminal. They allow the modification of the terminal's output. On Windows these sequences are called Console Virtual Terminal Sequences.

Warning

This function uses the ENABLE_VIRTUAL_TERMINAL_PROCESSING flag implemented in the Windows 10 API, so the VT100 feature may not be available on older Windows versions.

参数

stream

The stream on which the function will operate.

enable

If specified, the VT100 feature will be enabled (if true) or disabled (if false).

返回值

If enable is not specified: returns true if the VT100 feature is enabled, false otherwise.

If enable is specified: 成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sapi_windows_vt100_support() default state

By default, STDOUT and STDERR have the VT100 feature enabled.

php -r "var_export(sapi_windows_vt100_support(STDOUT));echo ' ';var_export(sapi_windows_vt100_support(STDERR));"

以上例程的输出类似于：

true true

By the way, if a stream is redirected, the VT100 feature will not be enabled:

php -r "var_export(sapi_windows_vt100_support(STDOUT));echo ' ';var_export(sapi_windows_vt100_support(STDERR));" 2>NUL

以上例程的输出类似于：

true false

Example #2 sapi_windows_vt100_support() changing state

You won't be able to enable the VT100 feature of STDOUT or STDERR if the stream is redirected.

php -r "var_export(sapi_windows_vt100_support(STDOUT, true));echo ' ';var_export(sapi_windows_vt100_support(STDERR, true));" 2>NUL

以上例程的输出类似于：

true false

Example #3 Example usage of VT100 support enabled

<?php
$out = fopen('php://stdout','w');
fwrite($out, 'Just forgot a lettr.');
// Moves the cursor two characters backwards
fwrite($out, "\033[2D");
// Inserts one blank, shifting existing text to the right -> Just forgot a lett r.
fwrite($out, "\033[1@");
fwrite($out, 'e');
?>

以上例程会输出：

Just forgot a letter.


别名 highlight_file

  • ? sapi_windows_vt100_support
  • sleep ?
  • PHP Manual
  • 杂项 函数
  • 别名 highlight_file

show_source

(PHP 4, PHP 5, PHP 7, PHP 8)

show_source — 别名 highlight_file()

说明

此函数是该函数的别名： highlight_file().


延缓执行

  • ? show_source
  • sys_getloadavg ?
  • PHP Manual
  • 杂项 函数
  • 延缓执行

sleep

(PHP 4, PHP 5, PHP 7, PHP 8)

sleep — 延缓执行

说明

sleep ( int $seconds ) : int

程序延迟执行指定的 seconds 的秒数。

参数

seconds

暂停的秒数。

返回值

成功时返回 0，错误时返回 false。

如果函数的调用被一个信号中止，sleep() 会返回一个非零的值。在Windows上，该值总是 192（即Windows API常量WAIT_IO_COMPLETION的值）。其他平台上，该返回值是剩余未sleep的秒数。

错误／异常

如果指定的 seconds 是负数，该函数会产生一个 E_WARNING 级别的错误。

范例

Example #1 sleep() 的例子

<?php

// current time
echo date('h:i:s') . "\n";

// sleep for 10 seconds
sleep(10);

// wake up !
echo date('h:i:s') . "\n";

?>

该例子会在休眠10秒后输出。

05:31:23
05:31:33

参见

  • usleep() - 以指定的微秒数延迟执行
  • time_nanosleep() - 延缓执行若干秒和纳秒
  • time_sleep_until() - 使脚本睡眠到指定的时间为止。
  • set_time_limit() - 设置脚本最大执行时间


获取系统的负载（load average）

  • ? sleep
  • time_nanosleep ?
  • PHP Manual
  • 杂项 函数
  • 获取系统的负载（load average）

sys_getloadavg

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

sys_getloadavg — 获取系统的负载（load average）

说明

sys_getloadavg ( ) : array

返回三个系统负载（系统运行队列中的进程数）的样本数据，分别是1分钟、5分钟和15分钟之前。

返回值

返回一个包含1分钟、5分钟和15分钟之前采样数据的array。

范例

Example #1 sys_getloadavg() 的例子

<?php
$load = sys_getloadavg();
if ($load[0] > 80) {
    header('HTTP/1.1 503 Too busy, try again later');
    die('Server too busy. Please try again later.');
}
?>

注释

Note: 此函数未在 Windows 平台下实现。


延缓执行若干秒和纳秒

  • ? sys_getloadavg
  • time_sleep_until ?
  • PHP Manual
  • 杂项 函数
  • 延缓执行若干秒和纳秒

time_nanosleep

(PHP 5, PHP 7, PHP 8)

time_nanosleep — 延缓执行若干秒和纳秒

说明

time_nanosleep ( int $seconds , int $nanoseconds ) : mixed

程序延缓执行指定数量的 seconds 和 nanoseconds。

参数

seconds

必须是一个非负整数。

nanoseconds

必须是一个小于1亿的非负整数。

返回值

成功时返回 true， 或者在失败时返回 false。

如果延迟被中断，一个关联数组会返回，内容为：

  • seconds - 延迟剩余未执行的秒数
  • nanoseconds - 延迟剩余未执行的纳秒数

更新日志

版本 | 说明
5.3.0 | 至此之后该函数在Windows平台下可用。

范例

Example #1 time_nanosleep() 的例子

<?php
// Careful! This won't work as expected if an array is returned
if (time_nanosleep(0, 500000000)) {
    echo "Slept for half a second.\n";
}

// This is better:
if (time_nanosleep(0, 500000000) === true) {
    echo "Slept for half a second.\n";
}

// And this is the best:
$nano = time_nanosleep(2, 100000);

if ($nano === true) {
    echo "Slept for 2 seconds, 100 microseconds.\n";
} elseif ($nano === false) {
    echo "Sleeping failed.\n";
} elseif (is_array($nano)) {
    $seconds = $nano['seconds'];
    $nanoseconds = $nano['nanoseconds'];
    echo "Interrupted by a signal.\n";
    echo "Time remaining: $seconds seconds, $nanoseconds nanoseconds.";
}
?>

参见

  • sleep() - 延缓执行
  • usleep() - 以指定的微秒数延迟执行
  • time_sleep_until() - 使脚本睡眠到指定的时间为止。
  • set_time_limit() - 设置脚本最大执行时间


使脚本睡眠到指定的时间为止。

  • ? time_nanosleep
  • uniqid ?
  • PHP Manual
  • 杂项 函数
  • 使脚本睡眠到指定的时间为止。

time_sleep_until

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

time_sleep_until — 使脚本睡眠到指定的时间为止。

说明

time_sleep_until ( float $timestamp ) : bool

使脚本睡眠到指定的 timestamp。

参数

timestamp

将脚本唤醒的时间戳。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.3.0 | 自此，函数在Windows平台可用。

错误／异常

如果设定的 timestamp 为过去的时间，脚本将会产生一个 E_WARNING 级别的错误。

范例

Example #1 time_sleep_until() 的一个例子

<?php

//returns false and generates a warning
var_dump(time_sleep_until(time()-1));

// may only work on faster computers, will sleep up to 0.2 seconds
var_dump(time_sleep_until(microtime(true)+0.2));

?>

注释

Note: 所有的信号会被延迟至脚本唤醒以后。

参见

  • sleep() - 延缓执行
  • usleep() - 以指定的微秒数延迟执行
  • time_nanosleep() - 延缓执行若干秒和纳秒
  • set_time_limit() - 设置脚本最大执行时间


生成一个唯一ID

  • ? time_sleep_until
  • unpack ?
  • PHP Manual
  • 杂项 函数
  • 生成一个唯一ID

uniqid

(PHP 4, PHP 5, PHP 7, PHP 8)

uniqid — 生成一个唯一ID

说明

uniqid ( string $prefix = "" , bool $more_entropy = false ) : string

获取一个带前缀、基于当前时间微秒数的唯一ID。

Caution

本函数并不会生成安全加密的值，不应用于加密用途。若需要安全加密的值，考虑使用 random_int()、random_bytes() 或 openssl_random_pseudo_bytes() 替代。

Warning

此函数不保证返回值的唯一性。 由于绝大多数系统使用 NTP 或者类似服务调整系统的时间，所以系统时间经常发生变化。 此外，进程/线程可能不会返回唯一的 ID。 用 more_entropy 来增加唯一性的概率。

参数

prefix

有用的参数。例如：如果在多台主机上可能在同一微秒生成唯一ID。

prefix为空，则返回的字符串长度为13。more_entropy 为 true，则返回的字符串长度为23。

more_entropy

如果设置为 true，uniqid() 会在返回的字符串结尾增加额外的熵（使用combined linear congruential generator）。 使得唯一ID更具唯一性。

返回值

返回字符串形式的唯一ID。

Warning

此函数努力创建唯一识别符，但它不保证返回值得唯一性。

范例

Example #1 uniqid() 例子

<?php
/* A uniqid, like: 4b3403665fea6 */
printf("uniqid(): %s\r\n", uniqid());

/* We can also prefix the uniqid, this the same as
 * doing:
 *
 * $uniqid = $prefix . uniqid();
 * $uniqid = uniqid($prefix);
 */
printf("uniqid('php_'): %s\r\n", uniqid('php_'));

/* We can also activate the more_entropy parameter, which is
 * required on some systems, like Cygwin. This makes uniqid()
 * produce a value like: 4b340550242239.64159797
 */
printf("uniqid('', true): %s\r\n", uniqid('', true));
?>

注释

Note:

在Cygwin环境下，为了使此函数能够工作，more_entropy 必须设置为 true。


Unpack data from binary string

  • ? uniqid
  • usleep ?
  • PHP Manual
  • 杂项 函数
  • Unpack data from binary string

unpack

(PHP 4, PHP 5, PHP 7, PHP 8)

unpack — Unpack data from binary string

说明

unpack ( string $format , string $string , int $offset = 0 ) : array|false

Unpacks from a binary string into an array according to the given format.

The unpacked data is stored in an associative array. To accomplish this you have to name the different format codes and separate them by a slash /. If a repeater argument is present, then each of the array keys will have a sequence number behind the given name.

参数

format

See pack() for an explanation of the format codes.

string

The packed data.

offset

The offset to begin unpacking from.

返回值

Returns an associative array containing unpacked elements of binary string, 或者在失败时返回 false.

更新日志

版本 | 说明
7.2.0 | float and double types supports both Big Endian and Little Endian.
7.1.0 | The optional offset has been added.
5.5.0 | Changes were made to bring this function into line with Perl: The "a" code now retains trailing NULL bytes. The "A" code now strips all trailing ASCII whitespace (spaces, tabs, newlines, carriage returns, and NULL bytes). The "Z" code was added for NULL-padded strings, and removes trailing NULL bytes.

范例

Example #1 unpack() example

<?php
$binarydata = "\x04\x00\xa0\x00";
$array = unpack("cchars/nint", $binarydata);
print_r($array);
?>

以上例程会输出：

Array
(
    [chars] => 4
    [int] => 160
)

Example #2 unpack() example with a repeater

<?php
$binarydata = "\x04\x00\xa0\x00";
$array = unpack("c2chars/nint", $binarydata);
print_r($array);
?>

以上例程会输出：

Array
(
    [chars1] => 4
    [chars2] => 0
    [int] => 40960
)

注释

Caution

Note that PHP internally stores integral values as signed. If you unpack a large unsigned long and it is of the same size as PHP internally stored values the result will be a negative number even though unsigned unpacking was specified.

Caution

If you do not name an element, numeric indices starting from 1 are used. Be aware that if you have more than one unnamed element, some data is overwritten because the numbering restarts from 1 for each element.

Example #3 unpack() example with unnamed keys

<?php
$binarydata = "\x32\x42\x00\xa0";
$array = unpack("c2/n", $binarydata);
var_dump($array);
?>

以上例程会输出：

array(2) {
  [1]=>
  int(160)
  [2]=>
  int(66)
}

Note that the first value from the c specifier is overwritten by the first value from the n specifier.

参见

  • pack() - 将数据打包成二进制字符串


以指定的微秒数延迟执行

  • ? unpack
  • 更新日志 ?
  • PHP Manual
  • 杂项 函数
  • 以指定的微秒数延迟执行

usleep

(PHP 4, PHP 5, PHP 7, PHP 8)

usleep — 以指定的微秒数延迟执行

说明

usleep ( int $micro_seconds ) : void

以指定的微秒数延缓程序的执行。

参数

micro_seconds

暂停的时间以微秒计。1微秒（micro second）是百万分之一秒。

返回值

没有返回值。

范例

Example #1 usleep()例子

<?php

// Current time
echo date('h:i:s') . "\n";

// wait for 2 seconds
usleep(2000000);

// back!
echo date('h:i:s') . "\n";

?>

以上例程会输出：

11:13:28
11:13:30

参见

  • sleep() - 延缓执行
  • time_nanosleep() - 延缓执行若干秒和纳秒
  • time_sleep_until() - 使脚本睡眠到指定的时间为止。
  • set_time_limit() - 设置脚本最大执行时间


更新日志

对本扩展的类／函数／方法有以下更新。

Version | Function | Description
7.3.0 | define | 废弃了 case_insensitive，并将在 8.0.0 版中移除。
7.2.0 | pack | float 和 double 类型支持打断和小端。
 | unpack | float and double types supports both Big Endian and Little Endian.
7.1.0 | unpack | The optional offset has been added.
7.0.15,7.1.1 | pack | 添加了 “e”,“E”,“g” 和 “G” 代码以启用 float 和 double 的字节顺序支持。
7.0.0 | define | 允许 array 的值。
5.6.3 | pack | 添加了 “q”、“q”、“J” 和 “P” 代码以支持处理 64 位数字。
5.5.0 | pack | “Z” 代码添加了与 “a” 等效的功能，以实现 Perl 兼容性。
 | unpack | Changes were made to bring this function into line with Perl: The "a" code now retains trailing NULL bytes. The "A" code now strips all trailing ASCII whitespace (spaces, tabs, newlines, carriage returns, and NULL bytes). The "Z" code was added for NULL-padded strings, and removes trailing NULL bytes.
5.3.0 | time_nanosleep | 至此之后该函数在Windows平台下可用。
 | time_sleep_until | 自此，函数在Windows平台可用。


SeasLog

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Seaslog 函数
    • seaslog_get_author — 获取 SeasLog 作者
    • seaslog_get_version — 获取 SeasLog 的版本
  • SeasLog — The SeasLog class
    • SeasLog::alert — 记录 alert 日志
    • SeasLog::analyzerCount — Get log count by level, log_path and key_word
    • SeasLog::analyzerDetail — Get log detail by level, log_path, key_word, start, limit, order
    • SeasLog::closeLoggerStream — Manually release stream flow from logger
    • SeasLog::__construct — Description
    • SeasLog::critical — 记录 critical 日志
    • SeasLog::debug — 记录 debug 日志
    • SeasLog::__destruct — Description
    • SeasLog::emergency — 记录 emergency 日志
    • SeasLog::error — 记录 error 日志
    • SeasLog::flushBuffer — 将日志缓存刷新到介质中，文件介质，或者发送到远端的 TCP/UDP 服务地址。
    • SeasLog::getBasePath — 获得 SeasLog 根目录
    • SeasLog::getBuffer — 获取内存中的日志缓存数组
    • SeasLog::getBufferEnabled — Determin if buffer enabled
    • SeasLog::getDatetimeFormat — 获取 SeasLog 日期格式
    • SeasLog::getLastLogger — 获得 SeasLog 最近的一次 Logger 名称
    • SeasLog::getRequestID — 获得当前 SeasLog 中用于区分请求的 request_id
    • SeasLog::getRequestVariable — Get SeasLog request variable
    • SeasLog::info — Record info log information
    • SeasLog::log — 公共的日志记录函数
    • SeasLog::notice — 记录 notice 日志
    • SeasLog::setBasePath — 设置 SeasLog 根目录
    • SeasLog::setDatetimeFormat — 设置 SeasLog 日期格式
    • SeasLog::setLogger — 设置 SeasLog 的 Logger 名
    • SeasLog::setRequestID — 设置可以由 SeasLog 用于区分请求的 request_id
    • SeasLog::setRequestVariable — Manually set SeasLog request variable
    • SeasLog::warning — Record warning log information


简介

SeasLog 是一个高效、快速、稳定的 PHP 日志扩展。

SeasLog 需要 PHP 5.2.0 或更高版本。过早的 PHP 版本可能无法工作。

Log 日志，通常是系统或软件、应用的运行记录。通过 Log 的分析，可以方便用户了解系统或软件、应用的运行情况；如果你的应用 Log 足够丰富，也可以分析以往用户的操作行为、类型喜好、地域分布或其他更多信息；如果一个应用的 Log 同时也分了多个级别，那么可以很轻易地分析得到该应用的健康状况，及时发现问题并快速定位、解决问题，补救损失。

PHP 内置 error_log、syslog 函数功能强大且性能极好，但由于各种缺陷(error_log 无错误级别、无固定格式，syslog 不分模块、与系统日志混合)，灵活度降低了很多，不能满足应用需求。

好消息是，有不少第三方的log类库弥补了上述缺陷，如 log4php、plog、monolog 等(当然也有很多应用在项目中自己开发的 Log 类)。

那么有没有一种 Log 类库满足以下需求呢：

  • 分模块、分级别
  • 配置简单(最好是勿须配置)
  • 日志格式清晰易读
  • 应用简单、性能很棒
SeasLog 正是应此需求而生。

目前提供了什么:

  • 在 PHP 项目中便捷、规范地记录 Log
  • 可配置的默认 Log 目录与模块
  • 指定 Log 目录与获取当前配置
  • 初步的分析预警框架
  • 高效的日志缓冲、便捷的缓冲 debug
  • 遵循 PSR-3 日志接口规范
  • 自动记录错误信息
  • 自动记录异常信息
  • 连接 TCP 端口，以 RFC5424 格式发送日志
  • 连接 UDP 端口，以 RFC5424 格式发送日志
  • 支持 RequestId 区分请求
  • 支持日志模板自定义

从Github上获取更多文档 » SeasLog 文档 。


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/seaslog


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Seaslog 配置选项
名字 | 默认 | 可修改范围 | 更新日志
seaslog.appender | 1 | PHP_INI_SYSTEM |
seaslog.appender_retry | 0 | PHP_INI_ALL |
seaslog.level | 8 | PHP_INI_ALL |
seaslog.remote_host | 127.0.0.1 | PHP_INI_ALL |
seaslog.remote_port | 514 | PHP_INI_ALL |
seaslog.remote_timeout | 1 | PHP_INI_SYSTEM |
seaslog.default_basepath | /var/log/www | PHP_INI_SYSTEM |
seaslog.default_logger | default | PHP_INI_SYSTEM |
seaslog.default_template | %T | %L | %P | %Q | %t | %M | PHP_INI_SYSTEM |
seaslog.default_datetime_format | Y-m-d H:i:s | PHP_INI_SYSTEM |
seaslog.trace_error | 1 | PHP_INI_ALL |
seaslog.trace_exception | 0 | PHP_INI_SYSTEM |
seaslog.trace_notice | 0 | PHP_INI_ALL |
seaslog.trace_warning | 0 | PHP_INI_ALL |
seaslog.use_buffer | 0 | PHP_INI_SYSTEM |
seaslog.buffer_size | 0 | PHP_INI_ALL |
seaslog.buffer_disabled_in_cli | 0 | PHP_INI_SYSTEM |
seaslog.disting_type | 0 | PHP_INI_SYSTEM |
seaslog.disting_folder | 1 | PHP_INI_SYSTEM |
seaslog.disting_by_hour | 0 | PHP_INI_SYSTEM |
seaslog.recall_depth | 0 | PHP_INI_ALL |
seaslog.trim_wrap | 0 | PHP_INI_ALL |
seaslog.ignore_warning | 1 | PHP_INI_ALL |
seaslog.throw_exception | 1 | PHP_INI_ALL |

这是配置指令的简短说明。

seaslog.appender integer

日志存储介质的切换选型。1File 2TCP 3UDP (默认为1)

当 seaslog.appender 被切换至 `2 (TCP)` 或者 `3 (UDP)` 时， SeasLog 会将日志发送至 tcp://remote_host:remote_port 或者 udp://remote_host:remote_port 服务器。

当 SeasLog 将日志发往 TCP/UDP 时，格式遵守 RFC5424 规范。 此时 `{logInfo}` 受配置项中 seaslog.default_template 的影响。

The log style finally formatted such as:
<15>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | DEBUG | 21423 | 599157af4e937 | 1466787583.322 | this is a neeke debug
<14>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | INFO | 21423 | 599157af4e937 | 1466787583.323 | this is a info log
<13>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | NOTICE | 21423 | 599157af4e937 | 1466787583.324 | this is a notice log
seaslog.appender_retry integer

记录日志时的重试次数。 默认为 0 (不重试)

seaslog.buffer_disabled_in_cli integer

在 CLI 模式下是否关闭 Buffer 的选项。 1-Y 0-N(默认值)

在配置中留有 buffer_disabled_in_cli 的开关项。 默认情况下，这个选项是关闭的。 如果将 buffer_disabled_in_cli 设为开启，并且运行在 CLI 时， 配置中的 seaslog.use_buffer 设置将是被忽略的，此时 Seaslog 将立即把日志信息写往存储介质。

seaslog.buffer_size integer

可以通过该配置项将内存中 Buffer 的条数修改为 100 条。 配置项中 buffer_size 默认值为 0， 这意味着将不使用 Buffer。 如果 buffer_size > 0，SeasLog 将预先将日志写入内存 Buffer，并在 Buffer 的条数大于或等于该值时，写往存储介质，然后刷新内存中的 Buffer。

seaslog.default_basepath string

日志存储的默认根路径。默认值为 "/var/log/www"。

seaslog.default_datetime_format string

时间的格式。默认值为 "Y-m-d H:i:s"。

seaslog.default_logger string

日志记录的默认 Logger。默认值为 "default"。

seaslog.disting_by_hour integer

是否按每小时一个记录进行区分。1-Y 0-N(默认值)

Note:

当 seaslog.disting_by_hour = 1 时，会将日志区分小时记录。 这意味着，SeasLog 将每隔一个小时创建一个文件。

seaslog.disting_folder integer

是否按目录进行区分。1-Y(默认值) 0-N

Note:

当 seaslog.disting_folder = 1 时，按目录区分地使用 Logger。 这意味着，SeasLog 将为每一个 Logger 创建一个单独的目录进行区分，比如 default/20180211.log， 而当该选项关闭时，SeasLog 将使用下划线连接 Logger 与时间，比如 default_20180211.log。

seaslog.disting_type integer

是否按日志级别进行区分。1-Y 0-N(默认值)

Note:

当 seaslog.disting_type = 1 时，按日志级别使用 Logger。 这意味着，SeasLog 将在创建日志文件时，使用 info/warn/error 或其他级别进行区分。

seaslog.ignore_warning integer

是否忽略 SeasLog 警告。1-On(默认值) 0-Off

Note:

当 seaslog.ignore_warning = 1 时，忽略 SeasLog 自身的警告， 此时日志目录权限不足、或从远端 Server 端口不能正常响应等导致的警告，将被忽略； 而当关闭该选项时，警告将会出现。

seaslog.level integer

允许日志被记录的级别。默认为 8 (全部日志)。 0-EMERGENCY 1-ALERT 2-CRITICAL 3-ERROR 4-WARNING 5-NOTICE 6-INFO 7-DEBUG 8-ALL

Note:

提示: 该配置项从 1.7.0 版本开始有所改变。 在 1.7.0 之前的版本中，越小的值将代表越多的级别日志被记录下来： 0-all 1-debug 2-info 3-notice 4-warning 5-error 6-critical 7-alert 8-emergency 在 1.7.0 之前的版本中，默认值是 0 (全部日志)。

seaslog.recall_depth integer

日志函数所在的层级。这将影响预置变量中的行号取值 `%F`。 默认值为 0。

seaslog.remote_host string

如果要使用 TCP 或者 UDP 为存储介质，需要配置远端的 IP。默认值为 "127.0.0.1"

seaslog.remote_port integer

如果要使用 TCP 或者 UDP 为存储介质，需要配置远端服务的端口号。默认值为 514

seaslog.remote_timeout integer

如果要使用 TCP 或者 UDP 为存储介质，需要配置超时时间。默认值为 1 秒。

seaslog.throw_exception integer

是否接受 SeasLog 抛出异常。1-On(默认值) 0-Off

Note:

当seaslog.throw_exception = 1时，接受 SeasLog 抛出自身的异常， 此时由于日志目录权限问题、或者从远端 Server 端口不能正常响应而导致的中断， 将抛出一个异常；而当关闭该选项时，将不抛出异常。

seaslog.trace_error integer

自动将 PHP 的 Final Error 记录在默认 Logger中。1-Y(默认值) 0-N

seaslog.trace_exception integer

自动将 PHP 的异常记录在默认 Logger中。1-Y 0-N(默认值)

seaslog.trace_notice integer

自动将 PHP 的 Notice 记录在默认 Logger中。1-Y 0-N(默认值)

seaslog.trace_warning integer

自动将 PHP 的 Warning 记录在默认 Logger中。1-Y 0-N(默认值)

seaslog.trim_wrap integer

自动地 Trim 掉日志信息中的 \n 和 \r。1-On 0-Off(默认值)

seaslog.use_buffer integer

开启使用内存中的日志 Buffer。1-Y 0-N(默认值)

Note:

当seaslog.use_buffer = 1时，开启使用内存 Buffer。 默认情况下，内存 Buffer 是关闭的。 如果 Buffer 是开启状态，SeasLog 会将日志预先记录在内存中， 并且在请求结束时、或 PHP 进程结束时（PHP RSHUTGOWN 或 PHP MSHUTDOWN）时写往存储介质。

seaslog.default_template string

默认日志模板。 默认值是 "%T | %L | %P | %Q | %t | %M".

Note:

SeasLog 提供了一系列的默认变量，可以在日志模板中使用，并在最终日志生成时，这些变量的占位符会被替换成对应的值。

默认的日志模板是：`seaslog.default_template = "%T | %L | %P | %Q | %t | %M"`， 这意味着，默认的日志格式会是：`{dateTime} | {level} | {pid} | {uniqid} | {timeStamp} | {logInfo}`

如果修改了日志模板，比如：`seaslog.default_template = "[%T]:%L %P %Q %t %M" `， 这意味着，日志的格式将会成改变为：`[{dateTime}]:{level} {pid} {uniqid} {timeStamp} {logInfo}`

Seaslog 内置变量表
变量名 | 描述
%L | 日志级别。
%M | 日志信息。
%T | 时间。 比如：`2017-08-16 19:15:02`，受配置项 `seaslog.default_datetime_format` 的影响。
%t | 时间戳。比如：`1502882102.862`，精确到毫秒。
%Q | 请求ID。用于区分每一个请求， 如果没有调用 `SeasLog::setRequestId($string)` 函数， 将在请求初始化的时候，使用 PHP 内置函数 `static char *get_uniqid ()` 来生成 Unique ID。
%H | 主机名。
%P | 进程ID。
%D | 域名:端口号。比如：`www.cloudwise.com:80`；在 CLI 下运行时，该值为 `cli`。
%R | 请求 URI。比如：`/app/user/signin`。 在 CLI 下运行时，值为 Index Script 名称，比如：`CliIndex.php`。
%m | 请求 Method。比如：`Get`。 在 CLI 下运行时，值为 Command Script，比如：`/bin/bash`。
%I | 客户端IP；在 CLI 下运行时，值为`local`。 取值优先级为：HTTP_X_REAL_IP > HTTP_X_FORWARDED_FOR > REMOTE_ADDR
%F | 文件名:行号。比如：`UserService.php:118`。
%U | 内存使用量。单位为 byte。 调用 PHP 内置方法`zend_memory_usage`得到该值。
%u | 最大内存使用峰值。单位为 byte。 调用 PHP 内置方法`zend_memory_peak_usage`得到该值。
%C | `TODO` Class::Action. Such as `UserService::getUserInfo`


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SEASLOG_VERSION (string)
SEASLOG_AUTHOR (string)
SEASLOG_ALL (string)
"ALL"
SEASLOG_DEBUG (string)
"DEBUG" - 详细的调试信息。细粒度的信息事件。
SEASLOG_INFO (string)
"INFO" - 重要事件、强调应用程序的运行过程。
SEASLOG_NOTICE (string)
"NOTICE" - 一般重要性事件、执行过程中较INFO级别更为重要的信息。
SEASLOG_WARNING (string)
"WARNING" - 出现了非错误性的异常信息、潜在异常信息、需要关注并且需要修复。
SEASLOG_ERROR (string)
"ERROR" - 运行时出现的错误，不需要立刻采取行动，但必须记录下来以备检测。
SEASLOG_CRITICAL (string)
"CRITICAL" - 紧急情况、需要立刻进行修复、程序组件已经不可用。
SEASLOG_ALERT (string)
"ALERT" - 必级立即采取行动的紧急事件、需要立即通知相关人员紧急修复。
SEASLOG_EMERGENCY (string)
"EMERGENCY" - 系统不可用。
SEASLOG_DETAIL_ORDER_ASC (integer)
1
SEASLOG_DETAIL_ORDER_DESC (integer)
2
SEASLOG_APPENDER_FILE (integer)
1
SEASLOG_APPENDER_TCP (integer)
2
SEASLOG_APPENDER_UDP (integer)
3
SEASLOG_CLOSE_LOGGER_STREAM_MOD_ALL (integer)
1
SEASLOG_CLOSE_LOGGER_STREAM_MOD_ASSIGN (integer)
2
SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT (integer)
1
SEASLOG_REQUEST_VARIABLE_REQUEST_URI (integer)
2
SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD (integer)
3
SEASLOG_REQUEST_VARIABLE_CLIENT_IP (integer)
4


范例

Example #1 获取与设置根目录

<?php
  $basePath1 = SeasLog::getBasePath();

  SeasLog::setBasePath('/log/base_test');
  $basePath2 = SeasLog::getBasePath();

  var_dump($basePath1,$basePath2);

  ?>

以上例程的输出类似于：

  string(12) "/var/log/www"
  string(14) "/log/base_test"

Example #2 获取与设置 Logger

<?php
$lastLogger1 = SeasLog::getLastLogger();

SeasLog::setLogger('testModule/app1');
$lastLogger2 = SeasLog::getLastLogger();

var_dump($lastLogger1,$lastLogger2);

?>

以上例程的输出类似于：

string(7) "default"
string(15) "testModule/app1"

Example #3 快速写入日志

<?php
SeasLog::log(SEASLOG_ERROR,'this is a error test by ::log');
SeasLog::debug('this is a {userName} debug',array('{userName}' => 'neeke'));
SeasLog::info('this is a info log');
SeasLog::notice('this is a notice log');
SeasLog::warning('your {website} was down,please {action} it ASAP!',array('{website}' => 'github.com','{action}' => 'rboot'));
SeasLog::error('a error log');
SeasLog::critical('some thing was critical');
SeasLog::alert('yes this is a {messageName}',array('{messageName}' => 'alertMSG'));
SeasLog::emergency('Just now, the house next door was completely burnt out! {note}',array('{note}' => 'it`s a joke'));
?>

日志的默认模板是 seaslog.default_template = "%T | %L | %P | %Q | %t | %M". 这意味着，在默认情况下，日志的记录格式是： `{dateTime} | {level} | {pid} | {uniqid} | {timeStamp} | {logInfo}`.

以上例程的输出类似于：

seaslog.appender = 1

2014-07-27 08:53:52 | ERROR | 23625 | 599159975a9ff | 1406422432.786 | this is a error test by log
2014-07-27 08:53:52 | DEBUG | 23625 | 599159975a9ff | 1406422432.786 | this is a neeke debug
2014-07-27 08:53:52 | INFO | 23625 | 599159975a9ff | 1406422432.787 | this is a info log
2014-07-27 08:53:52 | NOTICE | 23625 | 599159975a9ff | 1406422432.787 | this is a notice log
2014-07-27 08:53:52 | WARNING | 23625 | 599159975a9ff | 1406422432.787 | your github.com was down,please rboot it ASAP!
2014-07-27 08:53:52 | ERROR | 23625 | 599159975a9ff | 1406422432.787 | a error log
2014-07-27 08:53:52 | CRITICAL | 23625 | 599159975a9ff | 1406422432.787 | some thing was critical
2014-07-27 08:53:52 | EMERGENCY | 23625 | 599159975a9ff | 1406422432.787 | Just now, the house next door was completely burnt out! it is a joke

以上例程的输出类似于：

seaslog.appender = 2 or seaslog.appender = 3

The log style finally formatted such as:
<15>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | DEBUG | 21423 | 599157af4e937 | 1466787583.322 | this is a neeke debug
<14>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | INFO | 21423 | 599157af4e937 | 1466787583.323 | this is a info log
<13>1 2017-08-27T01:24:59+08:00 vagrant-ubuntu-trusty test/logger[27171]: 2016-06-25 00:59:43 | NOTICE | 21423 | 599157af4e937 | 1466787583.324 | this is a notice log

Example #4 快速获取某级别下日志的数量

SeasLog 通过系统命令管道调用 `grep -wc` 获取数量，并返回给 PHP (返回数组或单个数值).

<?php
$countResult1 = SeasLog::analyzerCount();
$countResult2 = SeasLog::analyzerCount(SEASLOG_WARNING);
$countResult3 = SeasLog::analyzerCount(SEASLOG_ERROR,date('Ymd',time()));

var_dump($countResult1,$countResult2,$countResult3);

?>

以上例程的输出类似于：

array(8) {
  ["DEBUG"]=>
  int(3)
  ["INFO"]=>
  int(3)
  ["NOTICE"]=>
  int(3)
  ["WARNING"]=>
  int(3)
  ["ERROR"]=>
  int(6)
  ["CRITICAL"]=>
  int(3)
  ["ALERT"]=>
  int(3)
  ["EMERGENCY"]=>
  int(3)
}
int(7)
int(1)

Example #5 获取某级别下日志的详情

SeasLog 通过系统命令管道调用 `grep -w` 获取日志详情，并返回数组给 PHP.

<?php
$detailErrorArray = SeasLog::analyzerDetail(SEASLOG_ERROR);
var_dump($detailErrorArray);

var_dump(SeasLog::analyzerDetail(SEASLOG_ERROR,date('Ymd',time())));
?>

以上例程的输出类似于：

array(6) {
  [0] =>
  string(83) "2014-02-24 00:14:02 | ERROR | 8568 | 599157af4e937 | 1393172042.717 | test error 3 "
  [1] =>
  string(83) "2014-02-24 00:14:04 | ERROR | 8594 | 5991576584446 | 1393172044.104 | test error 3 "
  [2] =>
  string(83) "2014-02-24 00:14:04 | ERROR | 8620 | 1502697015147 | 1393172044.862 | test error 3 "
  [3] =>
  string(83) "2014-02-24 00:14:05 | ERROR | 8646 | 599159975a9ff | 1393172045.989 | test error 3 "
  [4] =>
  string(83) "2014-02-24 00:14:07 | ERROR | 8672 | 599159986ec28 | 1393172047.882 | test error 3 "
  [5] =>
  string(83) "2014-02-24 00:14:08 | ERROR | 8698 | 5991599981cec | 1393172048.736 | test error 3 "
}

array(2) {
  [0] =>
  string(83) "2014-02-24 00:14:02 | ERROR | 8568 | 599157af4e937 | 1393172042.717 | test error 3 "
  [1] =>
  string(83) "2014-02-24 00:14:04 | ERROR | 8594 | 5991576584446 | 1393172044.104 | test error 3 "
}


Seaslog 函数

Table of Contents

  • seaslog_get_author — 获取 SeasLog 作者
  • seaslog_get_version — 获取 SeasLog 的版本


获取 SeasLog 作者

  • ? Seaslog 函数
  • seaslog_get_version ?
  • PHP Manual
  • Seaslog 函数
  • 获取 SeasLog 作者

seaslog_get_author

(PECL seaslog >=1.0.0)

seaslog_get_author — 获取 SeasLog 作者

说明

seaslog_get_author ( ) : string

参数

此函数没有参数。

返回值

返回一个 SeasLog 作者的字符串

范例

Example #1 seaslog_get_author() example

<?php

var_dump(seaslog_get_author());

?>

以上例程的输出类似于：

string(29) "Chitao.Gao  [ neeke@php.net ]"


获取 SeasLog 的版本

  • ? seaslog_get_author
  • SeasLog ?
  • PHP Manual
  • Seaslog 函数
  • 获取 SeasLog 的版本

seaslog_get_version

(PECL seaslog >=1.0.0)

seaslog_get_version — 获取 SeasLog 的版本

说明

seaslog_get_version ( ) : string

参数

此函数没有参数。

返回值

返回一个 SeasLog 版本号的字符串

范例

Example #1 seaslog_get_version() example

<?php

var_dump(seaslog_get_version());

?>

以上例程的输出类似于：

string(5) "1.8.4"


The SeasLog class

(PECL seaslog >=1.0.0)

简介

类摘要

SeasLog {
/* 方法 */
public static alert ( string $message , array $content = ? , string $logger = ? ) : bool
public static analyzerCount ( string $level , string $log_path = ? , string $key_word = ? ) : mixed
public static analyzerDetail ( string $level , string $log_path = ? , string $key_word = ? , int $start = ? , int $limit = ? , int $order = ? ) : mixed
public static closeLoggerStream ( int $model , string $logger ) : bool
public static critical ( string $message , array $content = ? , string $logger = ? ) : bool
public static debug ( string $message , array $content = ? , string $logger = ? ) : bool
public __destruct ( )
public static emergency ( string $message , array $content = ? , string $logger = ? ) : bool
public static error ( string $message , array $content = ? , string $logger = ? ) : bool
public static flushBuffer ( ) : bool
public static Seaslog::getBasePath ( ) : string
public static getBuffer ( ) : array
public static getBufferEnabled ( ) : bool
public static getDatetimeFormat ( ) : string
public static getLastLogger ( ) : string
public static getRequestID ( ) : string
public static getRequestVariable ( int $key ) : bool
public static info ( string $message , array $content = ? , string $logger = ? ) : bool
public static log ( string $level , string $message = ? , array $content = ? , string $logger = ? ) : bool
public static notice ( string $message , array $content = ? , string $logger = ? ) : bool
public static setBasePath ( string $base_path ) : bool
public static setDatetimeFormat ( string $format ) : bool
public static setLogger ( string $logger ) : bool
public static setRequestID ( string $request_id ) : bool
public static setRequestVariable ( int $key , string $value ) : bool
public static warning ( string $message , array $content = ? , string $logger = ? ) : bool
}

Table of Contents

  • SeasLog::alert — 记录 alert 日志
  • SeasLog::analyzerCount — Get log count by level, log_path and key_word
  • SeasLog::analyzerDetail — Get log detail by level, log_path, key_word, start, limit, order
  • SeasLog::closeLoggerStream — Manually release stream flow from logger
  • SeasLog::__construct — Description
  • SeasLog::critical — 记录 critical 日志
  • SeasLog::debug — 记录 debug 日志
  • SeasLog::__destruct — Description
  • SeasLog::emergency — 记录 emergency 日志
  • SeasLog::error — 记录 error 日志
  • SeasLog::flushBuffer — 将日志缓存刷新到介质中，文件介质，或者发送到远端的 TCP/UDP 服务地址。
  • SeasLog::getBasePath — 获得 SeasLog 根目录
  • SeasLog::getBuffer — 获取内存中的日志缓存数组
  • SeasLog::getBufferEnabled — Determin if buffer enabled
  • SeasLog::getDatetimeFormat — 获取 SeasLog 日期格式
  • SeasLog::getLastLogger — 获得 SeasLog 最近的一次 Logger 名称
  • SeasLog::getRequestID — 获得当前 SeasLog 中用于区分请求的 request_id
  • SeasLog::getRequestVariable — Get SeasLog request variable
  • SeasLog::info — Record info log information
  • SeasLog::log — 公共的日志记录函数
  • SeasLog::notice — 记录 notice 日志
  • SeasLog::setBasePath — 设置 SeasLog 根目录
  • SeasLog::setDatetimeFormat — 设置 SeasLog 日期格式
  • SeasLog::setLogger — 设置 SeasLog 的 Logger 名
  • SeasLog::setRequestID — 设置可以由 SeasLog 用于区分请求的 request_id
  • SeasLog::setRequestVariable — Manually set SeasLog request variable
  • SeasLog::warning — Record warning log information


记录 alert 日志

  • ? SeasLog
  • SeasLog::analyzerCount ?
  • PHP Manual
  • SeasLog
  • 记录 alert 日志

SeasLog::alert

(PECL seaslog >=1.0.0)

SeasLog::alert — 记录 alert 日志

说明

public static SeasLog::alert ( string $message , array $content = ? , string $logger = ? ) : bool

记录 alert 日志

Note:

"ALERT" -必须立即采取行动的紧急事件 需要立即通知相关人员紧急修复。

参数

message

日志的消息

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为NULL 或 ""，那么 SeasLog 将使用由SeasLog::setLogger()设置的最新日志记录程序。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::alert()例子

<?php

var_dump(SeasLog::alert('log message'));

//with content
var_dump(SeasLog::alert('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::alert('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | ALERT | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | ALERT | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | ALERT | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::debug() - 记录 debug 日志
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - 记录 notice 日志
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - 记录 error 日志
  • SeasLog::critical() - 记录 critical 日志
  • SeasLog::emergency() - 记录 emergency 日志
  • SeasLog::log() - 公共的日志记录函数


Get log count by level, log_path and key_word

  • ? SeasLog::alert
  • SeasLog::analyzerDetail ?
  • PHP Manual
  • SeasLog
  • Get log count by level, log_path and key_word

SeasLog::analyzerCount

(PECL seaslog >=1.1.6)

SeasLog::analyzerCount — Get log count by level, log_path and key_word

说明

public static SeasLog::analyzerCount ( string $level , string $log_path = ? , string $key_word = ? ) : mixed

`SeasLog` get count value of `grep -ai '{level}' | grep -aic '{key_word}'` use system pipe and return to PHP (array or int).

参数

level

String. The log information level.

log_path

String. The log information path.

key_word

String. The search key word for log information.

返回值

If `level` is SEASLOG_ALL or Empty, return all levels count as `array`. If `level` is SEASLOG_INFO or the other level, return count as `int`.

范例

Example #1 SeasLog::analyzerCount() example

<?php

$countResult1 = SeasLog::analyzerCount();

//with `level`
$countResult2 = SeasLog::analyzerCount(SEASLOG_DEBUG);

//with `level` and `log_path`
$countResult3 = SeasLog::analyzerCount(SEASLOG_ERROR,date('Ymd',time()));

//with `level` and `key_word`
$countResult4 = SeasLog::analyzerCount(SEASLOG_DEBUG,NULL,'accessToken');

var_dump($countResult1,$countResult2,$countResult3,$countResult4);

?>

以上例程的输出类似于：

array(8) {
  ["DEBUG"]=>
  int(180)
  ["INFO"]=>
  int(214)
  ["NOTICE"]=>
  int(0)
  ["WARNING"]=>
  int(0)
  ["ERROR"]=>
  int(228)
  ["CRITICAL"]=>
  int(244)
  ["ALERT"]=>
  int(1)
  ["EMERGENCY"]=>
  int(0)
}

int(180)

int(228)

int(29)

参见

  • SeasLog::analyzerDetail() - Get log detail by level, log_path, key_word, start, limit, order


Get log detail by level, log_path, key_word, start, limit, order

  • ? SeasLog::analyzerCount
  • SeasLog::closeLoggerStream ?
  • PHP Manual
  • SeasLog
  • Get log detail by level, log_path, key_word, start, limit, order

SeasLog::analyzerDetail

(PECL seaslog >=1.1.6)

SeasLog::analyzerDetail — Get log detail by level, log_path, key_word, start, limit, order

说明

public static SeasLog::analyzerDetail ( string $level , string $log_path = ? , string $key_word = ? , int $start = ? , int $limit = ? , int $order = ? ) : mixed

`SeasLog` get results of `grep -ai '{level}' | grep -ai '{key_word}' | sed -n '{start},{limit}'p` use system pipe and return array to PHP.

参数

level

String. The log information level.

log_path

String. The log information path.

key_word

String. The search key word for log information.

start

Int. Default is `1`.

limit

Int. Default is `20`.

order

Int. Default is SEASLOG_DETAIL_ORDER_ASC. See also:

  • SEASLOG_DETAIL_ORDER_ASC
  • SEASLOG_DETAIL_ORDER_DESC

返回值

Return results as array.

Note:

When `start`,`limit` is not NULL and in Windows, SeasLog will threw exception with message 'Param start and limit don't support Windows'.

范例

Example #1 SeasLog::analyzerDetail() example

<?php

$result1 = SeasLog::analyzerDetail(SEASLOG_ERROR);

//with `logger` and `key_word`
$result2 = SeasLog::analyzerDetail(SEASLOG_ERROR,'test/logger/','neeke');

//with `start` and `limit`
$result3 = SeasLog::analyzerDetail(SEASLOG_ERROR,'test/logger/','neeke',1,2);

var_dump($result1,$result2,$result3);
?>

以上例程的输出类似于：

array(20) {
  [0]=>
  string(93) "2018-07-09 12:52:53 | ERROR | 12247 | 5b42ea2580e51 | 1531111973.528 | log message from neeke"
  [1]=>
  string(93) "2018-07-09 12:52:54 | ERROR | 12256 | 5b42ea26d6657 | 1531111974.878 | log message from neeke"
  [2]=>
  string(93) "2018-07-09 12:52:55 | ERROR | 12265 | 5b42ea277b8d4 | 1531111975.506 | log message from neeke"
  [3]=>
  string(104) "2018-07-09 12:52:55 | ERROR | 12274 | 5b42ea27db5dc | 1531111975.898 | log message from the other people"
...
}

array(3) {
  [0]=>
  string(93) "2018-07-09 12:52:53 | ERROR | 12247 | 5b42ea2580e51 | 1531111973.528 | log message from neeke"
  [1]=>
  string(93) "2018-07-09 12:52:54 | ERROR | 12256 | 5b42ea26d6657 | 1531111974.878 | log message from neeke"
  [2]=>
  string(93) "2018-07-09 12:52:55 | ERROR | 12265 | 5b42ea277b8d4 | 1531111975.506 | log message from neeke"
}

array(2) {
  [0]=>
  string(93) "2018-07-09 12:52:53 | ERROR | 12247 | 5b42ea2580e51 | 1531111973.528 | log message from neeke"
  [1]=>
  string(93) "2018-07-09 12:52:54 | ERROR | 12256 | 5b42ea26d6657 | 1531111974.878 | log message from neeke"
}

参见

  • SeasLog::analyzerCount() - Get log count by level, log_path and key_word


Manually release stream flow from logger

  • ? SeasLog::analyzerDetail
  • SeasLog::__construct ?
  • PHP Manual
  • SeasLog
  • Manually release stream flow from logger

SeasLog::closeLoggerStream

(PECL seaslog >=1.8.6)

SeasLog::closeLoggerStream — Manually release stream flow from logger

说明

public static SeasLog::closeLoggerStream ( int $model , string $logger ) : bool

Manually release stream flow from logger. SeasLog caches the stream handle opened by the log logger to save the overhead of creating a stream. The handle will be automatically released at the end of the request. If in CLI mode, the process will also automatically release when it exits. Or you can use the following functions to manually release(manually release function needs to update SeasLog 1.8.6 or updated version).

参数

model

Constant int.

  • SEASLOG_CLOSE_LOGGER_STREAM_MOD_ALL
  • SEASLOG_CLOSE_LOGGER_STREAM_MOD_ASSIGN

logger

The logger name.

返回值

Return TRUE on released stream flow success, FALSE on failure.

范例

Example #1 SeasLog::closeLoggerStream() example

<?php

var_dump(SeasLog::closeLoggerStream());
var_dump(SeasLog::closeLoggerStream(SEASLOG_CLOSE_LOGGER_STREAM_MOD_ALL));
var_dump(SeasLog::closeLoggerStream(SEASLOG_CLOSE_LOGGER_STREAM_MOD_ASSIGN, 'logger_name'));

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)

参见

  • SeasLog::setLogger() - 设置 SeasLog 的 Logger 名
  • SeasLog::getLastLogger() - 获得 SeasLog 最近的一次 Logger 名称


Description

  • ? SeasLog::closeLoggerStream
  • SeasLog::critical ?
  • PHP Manual
  • SeasLog
  • Description

SeasLog::__construct

(PECL seaslog >=1.0.0)

SeasLog::__construct — Description

说明

public SeasLog::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

范例

Example #1 SeasLog::__construct() example

<?php

/* ... */

?>

以上例程的输出类似于：

...


记录 critical 日志

  • ? SeasLog::__construct
  • SeasLog::debug ?
  • PHP Manual
  • SeasLog
  • 记录 critical 日志

SeasLog::critical

(PECL seaslog >=1.0.0)

SeasLog::critical — 记录 critical 日志

说明

public static SeasLog::critical ( string $message , array $content = ? , string $logger = ? ) : bool

记录 critical 日志

Note:

"CRITICAL" - 紧急情况、需要立刻进行修复、程序组件不可用

参数

message

日志的消息

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为NULL 或 ""，那么SeasLog将使用由SeasLog::setLogger()设置的最新日志记录程序。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::critical() example

<?php

var_dump(SeasLog::critical('log message'));

//with content
var_dump(SeasLog::critical('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::critical('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | CRITICAL | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | CRITICAL | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | CRITICAL | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::debug() - 记录 debug 日志
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - 记录 notice 日志
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - 记录 error 日志
  • SeasLog::alert() - 记录 alert 日志
  • SeasLog::emergency() - 记录 emergency 日志
  • SeasLog::log() - 公共的日志记录函数


记录 debug 日志

  • ? SeasLog::critical
  • SeasLog::__destruct ?
  • PHP Manual
  • SeasLog
  • 记录 debug 日志

SeasLog::debug

(PECL seaslog >=1.0.0)

SeasLog::debug — 记录 debug 日志

说明

public static SeasLog::debug ( string $message , array $content = ? , string $logger = ? ) : bool

记录debug日志

Note:

"DEBUG" - debug 信息、细粒度信息事件

参数

message

日志的消息

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为NULL 或 ""，那么 SeasLog 将使用由SeasLog::setLogger()设置的最新日志记录程序。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::debug() example

<?php

var_dump(SeasLog::debug('log message'));

//with content
var_dump(SeasLog::debug('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::debug('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | DEBUG | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | DEBUG | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | DEBUG | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - 记录 notice 日志
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - 记录 error 日志
  • SeasLog::critical() - 记录 critical 日志
  • SeasLog::alert() - 记录 alert 日志
  • SeasLog::emergency() - 记录 emergency 日志
  • SeasLog::log() - 公共的日志记录函数


Description

  • ? SeasLog::debug
  • SeasLog::emergency ?
  • PHP Manual
  • SeasLog
  • Description

SeasLog::__destruct

(PECL seaslog >=1.0.0)

SeasLog::__destruct — Description

说明

public SeasLog::__destruct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 SeasLog::__destruct() example

<?php

/* ... */

?>

以上例程的输出类似于：

...


记录 emergency 日志

  • ? SeasLog::__destruct
  • SeasLog::error ?
  • PHP Manual
  • SeasLog
  • 记录 emergency 日志

SeasLog::emergency

(PECL seaslog >=1.0.0)

SeasLog::emergency — 记录 emergency 日志

说明

public static SeasLog::emergency ( string $message , array $content = ? , string $logger = ? ) : bool

记录 emergency 日志

Note:

"EMERGENCY" - 系统不可用。

参数

message

日志的消息

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为 NULL 或 ""，那么 SeasLog 将使用由SeasLog::setLogger()设置的最新 Logger。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::emergency() example

<?php

var_dump(SeasLog::emergency('log message'));

//with content
var_dump(SeasLog::emergency('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::emergency('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | EMERGENCY | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | EMERGENCY | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | EMERGENCY | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::debug() - 记录 debug 日志
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - 记录 notice 日志
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - 记录 error 日志
  • SeasLog::critical() - 记录 critical 日志
  • SeasLog::alert() - 记录 alert 日志
  • SeasLog::log() - 公共的日志记录函数


记录 error 日志

  • ? SeasLog::emergency
  • SeasLog::flushBuffer ?
  • PHP Manual
  • SeasLog
  • 记录 error 日志

SeasLog::error

(PECL seaslog >=1.0.0)

SeasLog::error — 记录 error 日志

说明

public static SeasLog::error ( string $message , array $content = ? , string $logger = ? ) : bool

记录 error 日志

Note:

"ERROR" - 运行时出现的错误、不必要立即进行修复、不影响整个逻辑的运行、需要记录并做检测

参数

message

日志的消息

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为NULL 或 ""，那么 SeasLog 将使用由SeasLog::setLogger()设置的最新日志记录程序。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::error() example

<?php

var_dump(SeasLog::error('log message'));

//with content
var_dump(SeasLog::error('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::error('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | ERROR | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | ERROR | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | ERROR | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::debug() - 记录 debug 日志
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - 记录 notice 日志
  • SeasLog::warning() - Record warning log information
  • SeasLog::critical() - 记录 critical 日志
  • SeasLog::alert() - 记录 alert 日志
  • SeasLog::emergency() - 记录 emergency 日志
  • SeasLog::log() - 公共的日志记录函数


将日志缓存刷新到介质中，文件介质，或者发送到远端的 TCP/UDP 服务地址。

  • ? SeasLog::error
  • SeasLog::getBasePath ?
  • PHP Manual
  • SeasLog
  • 将日志缓存刷新到介质中，文件介质，或者发送到远端的 TCP/UDP 服务地址。

SeasLog::flushBuffer

(PECL seaslog >=1.0.0)

SeasLog::flushBuffer — 将日志缓存刷新到介质中，文件介质，或者发送到远端的 TCP/UDP 服务地址。

说明

public static SeasLog::flushBuffer ( ) : bool

将日志缓存按照 seaslog.appender 刷新到介质： 文件介质，或发送到远端的 TCP/UDP 服务地址。

Note:

同时请留意： seaslog.appender_retry seaslog.remote_host seaslog.remote_port

参数

此函数没有参数。

返回值

刷新成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::flushBuffer() example

<?php

SeasLog::info('info log');
SeasLog::debug('debug log');
var_dump(SeasLog::getBuffer());
var_dump(SeasLog::flushBuffer());
var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(79) "2018-07-07 10:47:58 | INFO | 71910 | 5b4029ded6009 | 1530931678.877 | info log
"
    [1]=>
    string(81) "2018-07-07 10:47:58 | DEBUG | 71910 | 5b4029ded6009 | 1530931678.877 | debug log
"
  }
}
bool(true)
array(0) {
}

参见

  • seaslog.use_buffer
  • seaslog.buffer_size
  • seaslog.buffer_disabled_in_cli
  • SeasLog::getBufferEnabled() - Determin if buffer enabled
  • SeasLog::getBuffer() - 获取内存中的日志缓存数组


获得 SeasLog 根目录

  • ? SeasLog::flushBuffer
  • SeasLog::getBuffer ?
  • PHP Manual
  • SeasLog
  • 获得 SeasLog 根目录

SeasLog::getBasePath

(PECL seaslog >=1.0.0)

SeasLog::getBasePath — 获得 SeasLog 根目录

说明

public static Seaslog::getBasePath ( ) : string

使用函数 SeasLog::getBasePath() 可以获得在 php.ini(seaslog.ini) 中设置的seaslog.default_basepath。

如果使用函数 Seaslog::setBasePath()，将改变函数取值。

参数

此函数没有参数。

返回值

Return seaslog.default_basepath as string.

范例

Example #1 SeasLog::getBasePath() example

<?php

var_dump(SeasLog::getBasePath());

?>

以上例程的输出类似于：

string(12) "/var/log/www"


获取内存中的日志缓存数组

  • ? SeasLog::getBasePath
  • SeasLog::getBufferEnabled ?
  • PHP Manual
  • SeasLog
  • 获取内存中的日志缓存数组

SeasLog::getBuffer

(PECL seaslog >=1.0.0)

SeasLog::getBuffer — 获取内存中的日志缓存数组

说明

public static SeasLog::getBuffer ( ) : array

参数

此函数没有参数。

返回值

以 Array 形式返回内存中的日志缓存。

范例

Example #1 SeasLog::getBuffer() example

<?php

var_dump(SeasLog::info('info log'));
var_dump(SeasLog::debug('debug log'));
var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(79) "2018-07-07 10:43:32 | INFO | 71785 | 5b4028d4c58d5 | 1530931412.810 | info log
"
    [1]=>
    string(81) "2018-07-07 10:43:32 | DEBUG | 71785 | 5b4028d4c58d5 | 1530931412.810 | debug log
"
  }
}

参见

  • seaslog.use_buffer
  • seaslog.buffer_size
  • seaslog.buffer_disabled_in_cli
  • SeasLog::getBufferEnabled() - Determin if buffer enabled
  • SeasLog::flushBuffer() - 将日志缓存刷新到介质中，文件介质，或者发送到远端的 TCP/UDP 服务地址。


Determin if buffer enabled

  • ? SeasLog::getBuffer
  • SeasLog::getDatetimeFormat ?
  • PHP Manual
  • SeasLog
  • Determin if buffer enabled

SeasLog::getBufferEnabled

(PECL seaslog >=1.0.0)

SeasLog::getBufferEnabled — Determin if buffer enabled

说明

public static SeasLog::getBufferEnabled ( ) : bool

Result join seaslog.use_buffer and seaslog.buffer_disabled_in_cli.

参数

此函数没有参数。

返回值

Return TRUE on seaslog.use_buffer is true. If switch seaslog.buffer_disabled_in_cli on, and running in cli, seaslog.use_buffer setting will be discarded, Seaslog write to the Data Store IMMEDIATELY.

范例

Example #1 SeasLog::getBufferEnabled() example

<?php

var_dump(SeasLog::getBufferEnabled());

?>

以上例程的输出类似于：

bool(false)

参见

  • seaslog.use_buffer
  • seaslog.buffer_size
  • seaslog.buffer_disabled_in_cli
  • SeasLog::getBuffer() - 获取内存中的日志缓存数组
  • SeasLog::flushBuffer() - 将日志缓存刷新到介质中，文件介质，或者发送到远端的 TCP/UDP 服务地址。


获取 SeasLog 日期格式

  • ? SeasLog::getBufferEnabled
  • SeasLog::getLastLogger ?
  • PHP Manual
  • SeasLog
  • 获取 SeasLog 日期格式

SeasLog::getDatetimeFormat

(PECL seaslog >=1.0.0)

SeasLog::getDatetimeFormat — 获取 SeasLog 日期格式

说明

public static SeasLog::getDatetimeFormat ( ) : string

获取 SeasLog 日期格式。 使用函数 SeasLog::getDatetimeFormat() 将获取 php.ini(seaslog.ini) 配置的 seaslog.default_datetime_format 值。

参数

此函数没有参数。

返回值

获取 SeasLog 配置中的 seaslog.default_datetime_format 值。 使用函数 SeasLog::setDatetimeFormat() 将改变本函数的取值。

范例

Example #1 SeasLog::getDatetimeFormat() example

<?php

var_dump(SeasLog::getDateTimeFormat());
var_dump(SeasLog::setDateTimeFormat('Ymd His'));
var_dump(SeasLog::getDateTimeFormat());

?>

以上例程的输出类似于：

string(11) "Y-m-d H:i:s"
bool(true)
string(7) "Ymd His"

参见

  • SeasLog::setDatetimeFormat() - 设置 SeasLog 日期格式


获得 SeasLog 最近的一次 Logger 名称

  • ? SeasLog::getDatetimeFormat
  • SeasLog::getRequestID ?
  • PHP Manual
  • SeasLog
  • 获得 SeasLog 最近的一次 Logger 名称

SeasLog::getLastLogger

(PECL seaslog >=1.0.0)

SeasLog::getLastLogger — 获得 SeasLog 最近的一次 Logger 名称

说明

public static SeasLog::getLastLogger ( ) : string

使用函数 SeasLog::getLastLogger() 将获取 php.ini(seaslog.ini) 中配置的 seaslog.default_logger 值。

参数

此函数没有参数。

返回值

使用函数 SeasLog::setLogger() 将改变函数 SeasLog::getLastLogger() 的取值。

范例

Example #1 SeasLog::getLastLogger() example

<?php

var_dump(SeasLog::getLastLogger());
SeasLog::setLogger('theNewLogger');
var_dump(SeasLog::getLastLogger());
?>

以上例程的输出类似于：

string(7) "default"
string(12) "theNewLogger"

参见

  • SeasLog::setLogger() - 设置 SeasLog 的 Logger 名


获得当前 SeasLog 中用于区分请求的 request_id

  • ? SeasLog::getLastLogger
  • SeasLog::getRequestVariable ?
  • PHP Manual
  • SeasLog
  • 获得当前 SeasLog 中用于区分请求的 request_id

SeasLog::getRequestID

(PECL seaslog >=1.0.0)

SeasLog::getRequestID — 获得当前 SeasLog 中用于区分请求的 request_id

说明

public static SeasLog::getRequestID ( ) : string

为了区分一个独立的请求，如果没有调用函数 SeasLog::setRequestId() 进行指定，SeasLog 将会在请求初始化时，使用内置函数 `static char *get_uniqid ()` 生成一个 unique 值。

参数

此函数没有参数。

返回值

返回一个由内置函数 `static char *get_uniqid ()` 生成的、 或由用户调用函数 SeasLog::setRequestId() 指定的字符串。

范例

Example #1 SeasLog::getRequestID() example

<?php

var_dump(SeasLog::getRequestID());
var_dump(SeasLog::setRequestID('reqeust_id_test_'.time()))
var_dump(SeasLog::getRequestID());

?>

以上例程的输出类似于：

string(13) "5b3f21a209519"
bool(true)
string(26) "reqeust_id_test_1530864034"

参见

  • SeasLog::setRequestID() - 设置可以由 SeasLog 用于区分请求的 request_id
  • 在 Seaslog 默认变量表中的 `%Q` seaslog.configuration.html#ini.seaslog.default-template


Get SeasLog request variable

  • ? SeasLog::getRequestID
  • SeasLog::info ?
  • PHP Manual
  • SeasLog
  • Get SeasLog request variable

SeasLog::getRequestVariable

(PECL seaslog >=1.9.0)

SeasLog::getRequestVariable — Get SeasLog request variable

说明

public static SeasLog::getRequestVariable ( int $key ) : bool

Get SeasLog request variable.

参数

key

Constant int.

  • SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT
  • SEASLOG_REQUEST_VARIABLE_REQUEST_URI
  • SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD
  • SEASLOG_REQUEST_VARIABLE_CLIENT_IP

返回值

Return request variable value on set success.

范例

Example #1 SeasLog::getRequestVariable() example

<?php

$sDomainPort = 'domain:port';
$sRequestUri = 'uri';
$sRequestMethod = 'method';
$sClientIp = 'client_ip';

$iErrorKey = 1000;

$oSeasLog = new SeasLog();

var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT, $sDomainPort));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_URI, $sRequestUri));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD, $sRequestMethod));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_CLIENT_IP, $sClientIp));

var_dump($oSeasLog->setRequestVariable($iErrorKey,NULL));

var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT) == $sDomainPort);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_URI) == $sRequestUri);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD) == $sRequestMethod);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_CLIENT_IP) == $sClientIp);

var_dump($oSeasLog->getRequestVariable($iErrorKey));

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)
bool(false)

参见

  • SeasLog::setRequestVariable() - Manually set SeasLog request variable


Record info log information

  • ? SeasLog::getRequestVariable
  • SeasLog::log ?
  • PHP Manual
  • SeasLog
  • Record info log information

SeasLog::info

(PECL seaslog >=1.0.0)

SeasLog::info — Record info log information

说明

public static SeasLog::info ( string $message , array $content = ? , string $logger = ? ) : bool

记录 info 日志

Note:

"INFO" - 重要事件、强调应用程序的运行过程。

参数

message

The log message.

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为NULL 或 ""，那么 SeasLog 将使用由SeasLog::setLogger()设置的最新日志记录程序。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::info() example

<?php

var_dump(SeasLog::info('log message'));

//with content
var_dump(SeasLog::info('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::info('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | INFO | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | INFO | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | INFO | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::debug() - 记录 debug 日志
  • SeasLog::notice() - 记录 notice 日志
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - 记录 error 日志
  • SeasLog::critical() - 记录 critical 日志
  • SeasLog::alert() - 记录 alert 日志
  • SeasLog::emergency() - 记录 emergency 日志
  • SeasLog::log() - 公共的日志记录函数


公共的日志记录函数

  • ? SeasLog::info
  • SeasLog::notice ?
  • PHP Manual
  • SeasLog
  • 公共的日志记录函数

SeasLog::log

(PECL seaslog >=1.0.0)

SeasLog::log — 公共的日志记录函数

说明

public static SeasLog::log ( string $level , string $message = ? , array $content = ? , string $logger = ? ) : bool

公共的日志记录函数。可用于调用者扩展日志模板或级别。

参数

level

可以使用以下预设级别：

  • SEASLOG_DEBUG
  • SEASLOG_INFO
  • SEASLOG_NOTICE
  • SEASLOG_WARNING
  • SEASLOG_ERROR
  • SEASLOG_CRITICAL
  • SEASLOG_ALERT
  • SEASLOG_EMERGENCY
或者你可以自助创建新的级别。

message

日志消息

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为 NULL 或 ""，那么 SeasLog 将使用由SeasLog::setLogger()设置的最新 Logger。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::log() example

<?php

var_dump(SeasLog::log(SEASLOG_INFO,'info log'));
var_dump(SeasLog::getBuffer());

//create a new level self-help.
var_dump(SeasLog::log('MySelfLevel','info log'));
var_dump(SeasLog::getBuffer());

//with `content`
var_dump(SeasLog::log('MySelfLevel','info log {NAME}',array('NAME' => 'neeke')));
var_dump(SeasLog::getBuffer());

//with `logger`
var_dump(SeasLog::log('MySelfLevel','info log {NAME}',array('NAME' => 'neeke'),'tmp_logger'));
var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(1) {
    [0]=>
    string(79) "2018-07-07 11:12:37 | INFO | 72427 | 5b402fa56a2ea | 1530933157.436 | info log
"
  }
}

bool(true)
array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(1) {
    [0]=>
    string(86) "2018-07-07 11:13:59 | MySelfLevel | 72470 | 5b402ff781c5e | 1530933239.532 | info log
"
  }
}

bool(true)
array(1) {
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:28:12 | MySelfLevel | 72833 | 5b40334ce6a2f | 1530934092.946 | info log neeke
"
  }
}

bool(true)
array(1) {
  ["/var/log/www/default/20180707.log"]=>
  array(1) {
    [0]=>
    string(86) "2018-07-07 11:20:12 | INFO | 72616 | 5b40316c3641e | 1530933612.222 | info log neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::debug() - 记录 debug 日志
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - 记录 notice 日志
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - 记录 error 日志
  • SeasLog::critical() - 记录 critical 日志
  • SeasLog::alert() - 记录 alert 日志
  • SeasLog::emergency() - 记录 emergency 日志


记录 notice 日志

  • ? SeasLog::log
  • SeasLog::setBasePath ?
  • PHP Manual
  • SeasLog
  • 记录 notice 日志

SeasLog::notice

(PECL seaslog >=1.0.0)

SeasLog::notice — 记录 notice 日志

说明

public static SeasLog::notice ( string $message , array $content = ? , string $logger = ? ) : bool

记录 notice 日志。

Note:

"NOTICE" - 一般重要性事件、执行过程中较 INFO 级别更为重要的信息。

参数

message

日志的消息

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为 NULL 或 ""，那么 SeasLog 将使用由SeasLog::setLogger()设置的最新 Logger。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::notice() example

<?php

var_dump(SeasLog::notice('log message'));

//with content
var_dump(SeasLog::notice('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::notice('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | NOTICE | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | NOTICE | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | NOTICE | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::debug() - 记录 debug 日志
  • SeasLog::info() - Record info log information
  • SeasLog::warning() - Record warning log information
  • SeasLog::error() - 记录 error 日志
  • SeasLog::critical() - 记录 critical 日志
  • SeasLog::alert() - 记录 alert 日志
  • SeasLog::emergency() - 记录 emergency 日志
  • SeasLog::log() - 公共的日志记录函数


设置 SeasLog 根目录

  • ? SeasLog::notice
  • SeasLog::setDatetimeFormat ?
  • PHP Manual
  • SeasLog
  • 设置 SeasLog 根目录

SeasLog::setBasePath

(PECL seaslog >=1.0.0)

SeasLog::setBasePath — 设置 SeasLog 根目录

说明

public static SeasLog::setBasePath ( string $base_path ) : bool

设置 SeasLog 根目录。

参数

base_path

String.

返回值

设置根目录成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::setBasePath() example

<?php

/* ... */

?>

以上例程的输出类似于：

...


设置 SeasLog 日期格式

  • ? SeasLog::setBasePath
  • SeasLog::setLogger ?
  • PHP Manual
  • SeasLog
  • 设置 SeasLog 日期格式

SeasLog::setDatetimeFormat

(PECL seaslog >=1.0.0)

SeasLog::setDatetimeFormat — 设置 SeasLog 日期格式

说明

public static SeasLog::setDatetimeFormat ( string $format ) : bool

设置 SeasLog 日期格式。

Warning

本函数还未编写文档，仅有参数列表。

参数

format

字符串。比如 `Y-m-d H:i:s` 或者 `Ymd His`。查看函数 date() 的第一个参数 `format`。

返回值

Return TRUE on setted datetime format success, FALSE on failure.

范例

Example #1 SeasLog::setDatetimeFormat() example

<?php

var_dump(SeasLog::setDateTimeFormat('Ymd His'));

?>

以上例程的输出类似于：

bool(true)

参见

  • SeasLog::getDateTimeFormat() - 获取 SeasLog 日期格式


设置 SeasLog 的 Logger 名

  • ? SeasLog::setDatetimeFormat
  • SeasLog::setRequestID ?
  • PHP Manual
  • SeasLog
  • 设置 SeasLog 的 Logger 名

SeasLog::setLogger

(PECL seaslog >=1.0.0)

SeasLog::setLogger — 设置 SeasLog 的 Logger 名

说明

public static SeasLog::setLogger ( string $logger ) : bool

使用函数 SeasLog::setLogger() 将改变函数 SeasLog::getLastLogger() 的取值。 这意味着，SeasLog 将会把日志信息记录在该 Logger 下。

参数

logger

Logger name.

返回值

设置 Logger 成功（在存储介质为文件时将创建目录或文件）返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::setLogger() example

<?php

var_dump(SeasLog::setLogger('testModule/testLogger'));

?>

以上例程的输出类似于：

bool(true)

参见

  • SeasLog::getLastLogger() - 获得 SeasLog 最近的一次 Logger 名称


设置可以由 SeasLog 用于区分请求的 request_id

  • ? SeasLog::setLogger
  • SeasLog::setRequestVariable ?
  • PHP Manual
  • SeasLog
  • 设置可以由 SeasLog 用于区分请求的 request_id

SeasLog::setRequestID

(PECL seaslog >=1.0.0)

SeasLog::setRequestID — 设置可以由 SeasLog 用于区分请求的 request_id

说明

public static SeasLog::setRequestID ( string $request_id ) : bool

为了区分一个独立的请求，如果没有调用函数 SeasLog::setRequestId() 进行指定，SeasLog 将会在请求初始化时，使用内置函数 `static char *get_uniqid ()` 生成一个 unique 值。

参数

request_id

String.

返回值

设置 request_id 成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::setRequestID() example

<?php

var_dump(SeasLog::setRequestID(time() . rand()));

?>

以上例程的输出类似于：

bool(true)

参见

  • SeasLog::getRequestID() - 获得当前 SeasLog 中用于区分请求的 request_id


Manually set SeasLog request variable

  • ? SeasLog::setRequestID
  • SeasLog::warning ?
  • PHP Manual
  • SeasLog
  • Manually set SeasLog request variable

SeasLog::setRequestVariable

(PECL seaslog >=1.9.0)

SeasLog::setRequestVariable — Manually set SeasLog request variable

说明

public static SeasLog::setRequestVariable ( int $key , string $value ) : bool

Manually set SeasLog request variable.

参数

key

Constant int.

  • SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT
  • SEASLOG_REQUEST_VARIABLE_REQUEST_URI
  • SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD
  • SEASLOG_REQUEST_VARIABLE_CLIENT_IP

value

The request variable value.

返回值

Return TRUE on set success, FALSE on failure.

范例

Example #1 SeasLog::setRequestVariable() example

<?php

$sDomainPort = 'domain:port';
$sRequestUri = 'uri';
$sRequestMethod = 'method';
$sClientIp = 'client_ip';

$iErrorKey = 1000;

$oSeasLog = new SeasLog();

var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT, $sDomainPort));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_URI, $sRequestUri));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD, $sRequestMethod));
var_dump($oSeasLog->setRequestVariable(SEASLOG_REQUEST_VARIABLE_CLIENT_IP, $sClientIp));

var_dump($oSeasLog->setRequestVariable($iErrorKey,NULL));

var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_DOMAIN_PORT) == $sDomainPort);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_URI) == $sRequestUri);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_REQUEST_METHOD) == $sRequestMethod);
var_dump($oSeasLog->getRequestVariable(SEASLOG_REQUEST_VARIABLE_CLIENT_IP) == $sClientIp);

var_dump($oSeasLog->getRequestVariable($iErrorKey));

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)
bool(false)

参见

  • SeasLog::getRequestVariable() - Get SeasLog request variable


Record warning log information

  • ? SeasLog::setRequestVariable
  • SPL ?
  • PHP Manual
  • SeasLog
  • Record warning log information

SeasLog::warning

(PECL seaslog >=1.0.0)

SeasLog::warning — Record warning log information

说明

public static SeasLog::warning ( string $message , array $content = ? , string $logger = ? ) : bool

Record warning log information.

Note:

"WARNING" - 出现了非错误性的异常信息、潜在异常信息、需要关注并且需要修复。

参数

message

The log message.

content

"消息"包含占位符，实现用 content 数组中的值替换这些占位符。 例如'消息'是 `log info from {NAME}`, '内容'是 `array('NAME' => neeke)`， 日志信息是 `log info from neeke`

logger

当函数调用 SeasLog::setLogger() 时，就像临时 logger 一样，在第三个参数中使用这个"logger"。 如果 `logger` 为 NULL 或 ""，那么 SeasLog 将使用由SeasLog::setLogger()设置的最新 Logger。

返回值

记录日志信息成功返回 TRUE，失败返回 FALSE。

范例

Example #1 SeasLog::warning() example

<?php

var_dump(SeasLog::warning('log message'));

//with content
var_dump(SeasLog::warning('log message from {NAME}',array('NAME' => 'neeke')));

//with tmp logger
var_dump(SeasLog::warning('log message from {NAME}',array('NAME' => 'neeke'),'tmp_logger'));

var_dump(SeasLog::getBuffer());

?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
array(2) {
  ["/var/log/www/default/20180707.log"]=>
  array(2) {
    [0]=>
    string(81) "2018-07-07 11:45:49 | WARNING | 73263 | 5b40376d1067c | 1530935149.68 | log message
"
    [1]=>
    string(92) "2018-07-07 11:45:49 | WARNING | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
  ["/var/log/www/tmp_logger/20180707.log"]=>
  array(1) {
    [0]=>
    string(92) "2018-07-07 11:45:49 | WARNING | 73263 | 5b40376d1067c | 1530935149.68 | log message from neeke
"
  }
}

参见

  • seaslog.default_template
  • SeasLog::debug() - 记录 debug 日志
  • SeasLog::info() - Record info log information
  • SeasLog::notice() - 记录 notice 日志
  • SeasLog::error() - 记录 error 日志
  • SeasLog::critical() - 记录 critical 日志
  • SeasLog::alert() - 记录 alert 日志
  • SeasLog::emergency() - 记录 emergency 日志
  • SeasLog::log() - 公共的日志记录函数


PHP标准库 (SPL)

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 数据结构
    • SplDoublyLinkedList — The SplDoublyLinkedList class
    • SplStack — The SplStack class
    • SplQueue — The SplQueue class
    • SplHeap — The SplHeap class
    • SplMaxHeap — The SplMaxHeap class
    • SplMinHeap — The SplMinHeap class
    • SplPriorityQueue — The SplPriorityQueue class
    • SplFixedArray — The SplFixedArray class
    • SplObjectStorage — The SplObjectStorage class
  • 迭代器
    • AppendIterator — The AppendIterator class
    • ArrayIterator — ArrayIterator 类
    • CachingIterator — The CachingIterator class
    • CallbackFilterIterator — The CallbackFilterIterator class
    • DirectoryIterator — The DirectoryIterator class
    • EmptyIterator — The EmptyIterator class
    • FilesystemIterator — The FilesystemIterator class
    • FilterIterator — The FilterIterator class
    • GlobIterator — The GlobIterator class
    • InfiniteIterator — The InfiniteIterator class
    • IteratorIterator — The IteratorIterator class
    • LimitIterator — The LimitIterator class
    • MultipleIterator — The MultipleIterator class
    • NoRewindIterator — The NoRewindIterator class
    • ParentIterator — The ParentIterator class
    • RecursiveArrayIterator — The RecursiveArrayIterator class
    • RecursiveCachingIterator — The RecursiveCachingIterator class
    • RecursiveCallbackFilterIterator — The RecursiveCallbackFilterIterator class
    • RecursiveDirectoryIterator — The RecursiveDirectoryIterator class
    • RecursiveFilterIterator — The RecursiveFilterIterator class
    • RecursiveIteratorIterator — The RecursiveIteratorIterator class
    • RecursiveRegexIterator — The RecursiveRegexIterator class
    • RecursiveTreeIterator — The RecursiveTreeIterator class
    • RegexIterator — The RegexIterator class
  • 接口
    • Countable — The Countable interface
    • OuterIterator — The OuterIterator interface
    • RecursiveIterator — The RecursiveIterator interface
    • SeekableIterator — The SeekableIterator interface
  • 异常
    • BadFunctionCallException — The BadFunctionCallException class
    • BadMethodCallException — The BadMethodCallException class
    • DomainException — The DomainException class
    • InvalidArgumentException — The InvalidArgumentException class
    • LengthException — The LengthException class
    • LogicException — The LogicException class
    • OutOfBoundsException — The OutOfBoundsException class
    • OutOfRangeException — The OutOfRangeException class
    • OverflowException — The OverflowException class
    • RangeException — The RangeException class
    • RuntimeException — The RuntimeException class
    • UnderflowException — The UnderflowException class
    • UnexpectedValueException — The UnexpectedValueException class
  • SPL 函数
    • class_implements — 返回指定的类实现的所有接口。
    • class_parents — 返回指定类的父类。
    • class_uses — Return the traits used by the given class
    • iterator_apply — 为迭代器中每个元素调用一个用户自定义函数
    • iterator_count — 计算迭代器中元素的个数
    • iterator_to_array — 将迭代器中的元素拷贝到数组
    • spl_autoload_call — 尝试调用所有已注册的 __autoload() 函数来装载请求类
    • spl_autoload_extensions — 注册并返回 spl_autoload 函数使用的默认文件扩展名
    • spl_autoload_functions — 返回所有已注册的 __autoload() 函数
    • spl_autoload_register — 注册给定的函数作为 __autoload 的实现
    • spl_autoload_unregister — 注销已注册的 __autoload() 函数
    • spl_autoload — __autoload()函数的默认实现
    • spl_classes — 返回所有可用的SPL类
    • spl_object_hash — 返回指定对象的hash id
    • spl_object_id — Return the integer object handle for given object
  • 文件处理
    • SplFileInfo — The SplFileInfo class
    • SplFileObject — The SplFileObject class
    • SplTempFileObject — The SplTempFileObject class
  • 各种类及接口
    • ArrayObject — The ArrayObject class
    • SplObserver — The SplObserver interface
    • SplSubject — The SplSubject interface


简介

SPL是用于解决典型问题(standard problems)的一组接口与类的集合。

Note:

更详细的SPL文档请参考 这里.


安装

此扩展只能在php 5.0以后使用

Note:

此扩展从PHP 5.3.0 不再被关闭,会一直有效.成为php内核组件一部份


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Warning

SPL uses class constants since PHP 5.1. Prior releases use global constants in the form RIT_LEAVES_ONLY.


数据结构

Table of Contents

  • SplDoublyLinkedList
  • SplStack
  • SplQueue
  • SplHeap
  • SplMaxHeap
  • SplMinHeap
  • SplPriorityQueue
  • SplFixedArray
  • SplObjectStorage

SPL 提供了一套标准的数据结构。它们按底层实现进行分组, 通常定义了它们的一般应用领域。

双向链表

双链表 (DLL) 是一个链接到两个方向的节点列表。当底层结构是 DLL 时, 迭代器的操作、对两端的访问、节点的添加或删除都具有 O (1) 的开销。因此, 它为栈和队列提供了一个合适的实现。

  • SplDoublyLinkedList
    • SplStack
    • SplQueue

堆

堆是遵循堆属性的树状结构: 每个节点都大于或等于其子级, 使用对堆全局的已实现的比较方法进行比较。

  • SplHeap
    • SplMaxHeap
    • SplMinHeap
  • SplPriorityQueue

数组

数组是以连续方式存储数据的结构, 可通过索引进行访问。不要将它们与 php 数组混淆: php 数组实际上是按照有序的列表实现的。

  • SplFixedArray

映射

映射是一个数据拥有键值对。PHP 数组可以被看作是从整数/字符串到值的映射。SPL 提供了从对象到数据的映射。此映射也可用作对象集。

  • SplObjectStorage


The SplDoublyLinkedList class

(PHP 5 >= 5.3.0, PHP 7)

简介

The SplDoublyLinkedList class provides the main functionalities of a doubly linked list.

类摘要

SplDoublyLinkedList implements Iterator , ArrayAccess , Countable , Serializable {
/* 常量 */
const int IT_MODE_LIFO = 2 ;
const int IT_MODE_FIFO = 0 ;
const int IT_MODE_DELETE = 1 ;
const int IT_MODE_KEEP = 0 ;
/* 方法 */
public __construct ( )
public add ( mixed $index , mixed $newval ) : void
public bottom ( ) : mixed
public count ( ) : int
public current ( ) : mixed
public getIteratorMode ( ) : int
public isEmpty ( ) : bool
public key ( ) : mixed
public next ( ) : void
public offsetExists ( mixed $index ) : bool
public offsetGet ( mixed $index ) : mixed
public offsetSet ( mixed $index , mixed $newval ) : void
public offsetUnset ( mixed $index ) : void
public pop ( ) : mixed
public prev ( ) : void
public push ( mixed $value ) : void
public rewind ( ) : void
public serialize ( ) : string
public setIteratorMode ( int $mode ) : void
public shift ( ) : mixed
public top ( ) : mixed
public unserialize ( string $serialized ) : void
public unshift ( mixed $value ) : void
public valid ( ) : bool
}

预定义常量

Iteration Direction

SplDoublyLinkedList::IT_MODE_LIFO

The list will be iterated in a last in, first out order, like a stack.

SplDoublyLinkedList::IT_MODE_FIFO

The list will be iterated in a first in, first out order, like a queue.

Iteration Behavior

SplDoublyLinkedList::IT_MODE_DELETE

Iteration will remove the iterated elements.

SplDoublyLinkedList::IT_MODE_KEEP

Iteration will not remove the iterated elements.

Table of Contents

  • SplDoublyLinkedList::add — Add/insert a new value at the specified index
  • SplDoublyLinkedList::bottom — Peeks at the node from the beginning of the doubly linked list
  • SplDoublyLinkedList::__construct — Constructs a new doubly linked list
  • SplDoublyLinkedList::count — Counts the number of elements in the doubly linked list
  • SplDoublyLinkedList::current — Return current array entry
  • SplDoublyLinkedList::getIteratorMode — Returns the mode of iteration
  • SplDoublyLinkedList::isEmpty — Checks whether the doubly linked list is empty
  • SplDoublyLinkedList::key — Return current node index
  • SplDoublyLinkedList::next — Move to next entry
  • SplDoublyLinkedList::offsetExists — Returns whether the requested $index exists
  • SplDoublyLinkedList::offsetGet — Returns the value at the specified $index
  • SplDoublyLinkedList::offsetSet — Sets the value at the specified $index to $newval
  • SplDoublyLinkedList::offsetUnset — Unsets the value at the specified $index
  • SplDoublyLinkedList::pop — Pops a node from the end of the doubly linked list
  • SplDoublyLinkedList::prev — Move to previous entry
  • SplDoublyLinkedList::push — Pushes an element at the end of the doubly linked list
  • SplDoublyLinkedList::rewind — Rewind iterator back to the start
  • SplDoublyLinkedList::serialize — Serializes the storage
  • SplDoublyLinkedList::setIteratorMode — Sets the mode of iteration
  • SplDoublyLinkedList::shift — Shifts a node from the beginning of the doubly linked list
  • SplDoublyLinkedList::top — Peeks at the node from the end of the doubly linked list
  • SplDoublyLinkedList::unserialize — Unserializes the storage
  • SplDoublyLinkedList::unshift — Prepends the doubly linked list with an element
  • SplDoublyLinkedList::valid — Check whether the doubly linked list contains more nodes


Add/insert a new value at the specified index

  • ? SplDoublyLinkedList
  • SplDoublyLinkedList::bottom ?
  • PHP Manual
  • SplDoublyLinkedList
  • Add/insert a new value at the specified index

SplDoublyLinkedList::add

(PHP 5 >= 5.5.0, PHP 7)

SplDoublyLinkedList::add — Add/insert a new value at the specified index

说明

public SplDoublyLinkedList::add ( mixed $index , mixed $newval ) : void

Insert the value newval at the specified index, shuffling the previous value at that index (and all subsequent values) up through the list.

参数

index

The index where the new value is to be inserted.

newval

The new value for the index.

返回值

没有返回值。

错误／异常

Throws OutOfRangeException when index is out of bounds or when index cannot be parsed as an integer.


Peeks at the node from the beginning of the doubly linked list

  • ? SplDoublyLinkedList::add
  • SplDoublyLinkedList::__construct ?
  • PHP Manual
  • SplDoublyLinkedList
  • Peeks at the node from the beginning of the doubly linked list

SplDoublyLinkedList::bottom

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::bottom — Peeks at the node from the beginning of the doubly linked list

说明

public SplDoublyLinkedList::bottom ( ) : mixed

参数

此函数没有参数。

返回值

The value of the first node.

错误／异常

Throws RuntimeException when the data-structure is empty.


Constructs a new doubly linked list

  • ? SplDoublyLinkedList::bottom
  • SplDoublyLinkedList::count ?
  • PHP Manual
  • SplDoublyLinkedList
  • Constructs a new doubly linked list

SplDoublyLinkedList::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::__construct — Constructs a new doubly linked list

说明

public SplDoublyLinkedList::__construct ( )

This constructs a new empty doubly linked list.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 SplDoublyLinkedList::__construct() example

<?php
$dll = new SplDoublyLinkedList();

$dll->push(2);
$dll->push(3);
$dll->unshift(5);

var_dump($dll);
?>

以上例程会输出：

object(SplDoublyLinkedList)#1 (2) {
  ["flags":"SplDoublyLinkedList":private]=>
  int(0)
  ["dllist":"SplDoublyLinkedList":private]=>
  array(3) {
    [0]=>
    int(5)
    [1]=>
    int(2)
    [2]=>
    int(3)
  }
}


Counts the number of elements in the doubly linked list

  • ? SplDoublyLinkedList::__construct
  • SplDoublyLinkedList::current ?
  • PHP Manual
  • SplDoublyLinkedList
  • Counts the number of elements in the doubly linked list

SplDoublyLinkedList::count

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::count — Counts the number of elements in the doubly linked list

说明

public SplDoublyLinkedList::count ( ) : int

参数

此函数没有参数。

返回值

Returns the number of elements in the doubly linked list.


Return current array entry

  • ? SplDoublyLinkedList::count
  • SplDoublyLinkedList::getIteratorMode ?
  • PHP Manual
  • SplDoublyLinkedList
  • Return current array entry

SplDoublyLinkedList::current

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::current — Return current array entry

说明

public SplDoublyLinkedList::current ( ) : mixed

Get the current doubly linked list node.

参数

此函数没有参数。

返回值

The current node value.


Returns the mode of iteration

  • ? SplDoublyLinkedList::current
  • SplDoublyLinkedList::isEmpty ?
  • PHP Manual
  • SplDoublyLinkedList
  • Returns the mode of iteration

SplDoublyLinkedList::getIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::getIteratorMode — Returns the mode of iteration

说明

public SplDoublyLinkedList::getIteratorMode ( ) : int

参数

此函数没有参数。

返回值

Returns the different modes and flags that affect the iteration.


Checks whether the doubly linked list is empty

  • ? SplDoublyLinkedList::getIteratorMode
  • SplDoublyLinkedList::key ?
  • PHP Manual
  • SplDoublyLinkedList
  • Checks whether the doubly linked list is empty

SplDoublyLinkedList::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::isEmpty — Checks whether the doubly linked list is empty

说明

public SplDoublyLinkedList::isEmpty ( ) : bool

参数

此函数没有参数。

返回值

Returns whether the doubly linked list is empty.


Return current node index

  • ? SplDoublyLinkedList::isEmpty
  • SplDoublyLinkedList::next ?
  • PHP Manual
  • SplDoublyLinkedList
  • Return current node index

SplDoublyLinkedList::key

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::key — Return current node index

说明

public SplDoublyLinkedList::key ( ) : mixed

This function returns the current node index

参数

此函数没有参数。

返回值

The current node index.


Move to next entry

  • ? SplDoublyLinkedList::key
  • SplDoublyLinkedList::offsetExists ?
  • PHP Manual
  • SplDoublyLinkedList
  • Move to next entry

SplDoublyLinkedList::next

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::next — Move to next entry

说明

public SplDoublyLinkedList::next ( ) : void

Move the iterator to the next node.

参数

此函数没有参数。

返回值

没有返回值。


Returns whether the requested $index exists

  • ? SplDoublyLinkedList::next
  • SplDoublyLinkedList::offsetGet ?
  • PHP Manual
  • SplDoublyLinkedList
  • Returns whether the requested $index exists

SplDoublyLinkedList::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetExists — Returns whether the requested $index exists

说明

public SplDoublyLinkedList::offsetExists ( mixed $index ) : bool

参数

index

The index being checked.

返回值

true if the requested index exists, otherwise false


Returns the value at the specified $index

  • ? SplDoublyLinkedList::offsetExists
  • SplDoublyLinkedList::offsetSet ?
  • PHP Manual
  • SplDoublyLinkedList
  • Returns the value at the specified $index

SplDoublyLinkedList::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetGet — Returns the value at the specified $index

说明

public SplDoublyLinkedList::offsetGet ( mixed $index ) : mixed

参数

index

The index with the value.

返回值

The value at the specified index.

错误／异常

Throws OutOfRangeException when index is out of bounds or when index cannot be parsed as an integer.


Sets the value at the specified $index to $newval

  • ? SplDoublyLinkedList::offsetGet
  • SplDoublyLinkedList::offsetUnset ?
  • PHP Manual
  • SplDoublyLinkedList
  • Sets the value at the specified $index to $newval

SplDoublyLinkedList::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetSet — Sets the value at the specified $index to $newval

说明

public SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval ) : void

Sets the value at the specified index to newval.

参数

index

The index being set.

newval

The new value for the index.

返回值

没有返回值。

错误／异常

Throws OutOfRangeException when index is out of bounds or when index cannot be parsed as an integer.


Unsets the value at the specified $index

  • ? SplDoublyLinkedList::offsetSet
  • SplDoublyLinkedList::pop ?
  • PHP Manual
  • SplDoublyLinkedList
  • Unsets the value at the specified $index

SplDoublyLinkedList::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetUnset — Unsets the value at the specified $index

说明

public SplDoublyLinkedList::offsetUnset ( mixed $index ) : void

Unsets the value at the specified index.

参数

index

The index being unset.

返回值

没有返回值。

错误／异常

Throws OutOfRangeException when index is out of bounds or when index cannot be parsed as an integer.


Pops a node from the end of the doubly linked list

  • ? SplDoublyLinkedList::offsetUnset
  • SplDoublyLinkedList::prev ?
  • PHP Manual
  • SplDoublyLinkedList
  • Pops a node from the end of the doubly linked list

SplDoublyLinkedList::pop

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::pop — Pops a node from the end of the doubly linked list

说明

public SplDoublyLinkedList::pop ( ) : mixed

参数

此函数没有参数。

返回值

The value of the popped node.

错误／异常

Throws RuntimeException when the data-structure is empty.


Move to previous entry

  • ? SplDoublyLinkedList::pop
  • SplDoublyLinkedList::push ?
  • PHP Manual
  • SplDoublyLinkedList
  • Move to previous entry

SplDoublyLinkedList::prev

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::prev — Move to previous entry

说明

public SplDoublyLinkedList::prev ( ) : void

Move the iterator to the previous node.

参数

此函数没有参数。

返回值

没有返回值。


Pushes an element at the end of the doubly linked list

  • ? SplDoublyLinkedList::prev
  • SplDoublyLinkedList::rewind ?
  • PHP Manual
  • SplDoublyLinkedList
  • Pushes an element at the end of the doubly linked list

SplDoublyLinkedList::push

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::push — Pushes an element at the end of the doubly linked list

说明

public SplDoublyLinkedList::push ( mixed $value ) : void

Pushes value at the end of the doubly linked list.

参数

value

The value to push.

返回值

没有返回值。


Rewind iterator back to the start

  • ? SplDoublyLinkedList::push
  • SplDoublyLinkedList::serialize ?
  • PHP Manual
  • SplDoublyLinkedList
  • Rewind iterator back to the start

SplDoublyLinkedList::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::rewind — Rewind iterator back to the start

说明

public SplDoublyLinkedList::rewind ( ) : void

This rewinds the iterator to the beginning.

参数

此函数没有参数。

返回值

没有返回值。


Serializes the storage

  • ? SplDoublyLinkedList::rewind
  • SplDoublyLinkedList::setIteratorMode ?
  • PHP Manual
  • SplDoublyLinkedList
  • Serializes the storage

SplDoublyLinkedList::serialize

(PHP 5 >= 5.4.0, PHP 7)

SplDoublyLinkedList::serialize — Serializes the storage

说明

public SplDoublyLinkedList::serialize ( ) : string

Serializes the storage.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The serialized string.

参见

  • SplDoublyLinkedList::unserialize() - Unserializes the storage


Sets the mode of iteration

  • ? SplDoublyLinkedList::serialize
  • SplDoublyLinkedList::shift ?
  • PHP Manual
  • SplDoublyLinkedList
  • Sets the mode of iteration

SplDoublyLinkedList::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::setIteratorMode — Sets the mode of iteration

说明

public SplDoublyLinkedList::setIteratorMode ( int $mode ) : void

参数

mode

There are two orthogonal sets of modes that can be set:

  • The direction of the iteration (either one or the other):
    • SplDoublyLinkedList::IT_MODE_LIFO (Stack style)
    • SplDoublyLinkedList::IT_MODE_FIFO (Queue style)
  • The behavior of the iterator (either one or the other):
    • SplDoublyLinkedList::IT_MODE_DELETE (Elements are deleted by the iterator)
    • SplDoublyLinkedList::IT_MODE_KEEP (Elements are traversed by the iterator)

The default mode is: SplDoublyLinkedList::IT_MODE_FIFO | SplDoublyLinkedList::IT_MODE_KEEP

返回值

没有返回值。


Shifts a node from the beginning of the doubly linked list

  • ? SplDoublyLinkedList::setIteratorMode
  • SplDoublyLinkedList::top ?
  • PHP Manual
  • SplDoublyLinkedList
  • Shifts a node from the beginning of the doubly linked list

SplDoublyLinkedList::shift

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::shift — Shifts a node from the beginning of the doubly linked list

说明

public SplDoublyLinkedList::shift ( ) : mixed

参数

此函数没有参数。

返回值

The value of the shifted node.

错误／异常

Throws RuntimeException when the data-structure is empty.


Peeks at the node from the end of the doubly linked list

  • ? SplDoublyLinkedList::shift
  • SplDoublyLinkedList::unserialize ?
  • PHP Manual
  • SplDoublyLinkedList
  • Peeks at the node from the end of the doubly linked list

SplDoublyLinkedList::top

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::top — Peeks at the node from the end of the doubly linked list

说明

public SplDoublyLinkedList::top ( ) : mixed

参数

此函数没有参数。

返回值

The value of the last node.

错误／异常

Throws RuntimeException when the data-structure is empty.


Unserializes the storage

  • ? SplDoublyLinkedList::top
  • SplDoublyLinkedList::unshift ?
  • PHP Manual
  • SplDoublyLinkedList
  • Unserializes the storage

SplDoublyLinkedList::unserialize

(PHP 5 >= 5.4.0, PHP 7)

SplDoublyLinkedList::unserialize — Unserializes the storage

说明

public SplDoublyLinkedList::unserialize ( string $serialized ) : void

Unserializes the storage, from SplDoublyLinkedList::serialize().

Warning

本函数还未编写文档，仅有参数列表。

参数

serialized

The serialized string.

返回值

没有返回值。

参见

  • SplDoublyLinkedList::serialize() - Serializes the storage


Prepends the doubly linked list with an element

  • ? SplDoublyLinkedList::unserialize
  • SplDoublyLinkedList::valid ?
  • PHP Manual
  • SplDoublyLinkedList
  • Prepends the doubly linked list with an element

SplDoublyLinkedList::unshift

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::unshift — Prepends the doubly linked list with an element

说明

public SplDoublyLinkedList::unshift ( mixed $value ) : void

Prepends value at the beginning of the doubly linked list.

参数

value

The value to unshift.

返回值

没有返回值。


Check whether the doubly linked list contains more nodes

  • ? SplDoublyLinkedList::unshift
  • SplStack ?
  • PHP Manual
  • SplDoublyLinkedList
  • Check whether the doubly linked list contains more nodes

SplDoublyLinkedList::valid

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::valid — Check whether the doubly linked list contains more nodes

说明

public SplDoublyLinkedList::valid ( ) : bool

Checks if the doubly linked list contains any more nodes.

参数

此函数没有参数。

返回值

Returns true if the doubly linked list contains any more nodes, false otherwise.


The SplStack class

(PHP 5 >= 5.3.0, PHP 7)

简介

SplStack类通过使用一个双向链表来提供栈的主要功能。

类摘要

SplStack extends SplDoublyLinkedList implements Iterator , ArrayAccess , Countable {
/* 方法 */
public __construct ( )
public setIteratorMode ( int $mode ) : void
/* 继承的方法 */
public SplDoublyLinkedList::add ( mixed $index , mixed $newval ) : void
public SplDoublyLinkedList::bottom ( ) : mixed
public SplDoublyLinkedList::count ( ) : int
public SplDoublyLinkedList::current ( ) : mixed
public SplDoublyLinkedList::getIteratorMode ( ) : int
public SplDoublyLinkedList::isEmpty ( ) : bool
public SplDoublyLinkedList::key ( ) : mixed
public SplDoublyLinkedList::next ( ) : void
public SplDoublyLinkedList::offsetExists ( mixed $index ) : bool
public SplDoublyLinkedList::offsetGet ( mixed $index ) : mixed
public SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval ) : void
public SplDoublyLinkedList::offsetUnset ( mixed $index ) : void
public SplDoublyLinkedList::pop ( ) : mixed
public SplDoublyLinkedList::prev ( ) : void
public SplDoublyLinkedList::push ( mixed $value ) : void
public SplDoublyLinkedList::rewind ( ) : void
public SplDoublyLinkedList::serialize ( ) : string
public SplDoublyLinkedList::setIteratorMode ( int $mode ) : void
public SplDoublyLinkedList::shift ( ) : mixed
public SplDoublyLinkedList::top ( ) : mixed
public SplDoublyLinkedList::unserialize ( string $serialized ) : void
public SplDoublyLinkedList::unshift ( mixed $value ) : void
public SplDoublyLinkedList::valid ( ) : bool
}

Table of Contents

  • SplStack::__construct — Constructs a new stack implemented using a doubly linked list
  • SplStack::setIteratorMode — Sets the mode of iteration


Constructs a new stack implemented using a doubly linked list

  • ? SplStack
  • SplStack::setIteratorMode ?
  • PHP Manual
  • SplStack
  • Constructs a new stack implemented using a doubly linked list

SplStack::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplStack::__construct — Constructs a new stack implemented using a doubly linked list

说明

public SplStack::__construct ( )

This constructs a new empty stack.

Note:

This method automatically sets the iterator mode to SplDoublyLinkedList::IT_MODE_LIFO.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 SplStack::__construct() example

<?php
$q = new SplStack();

$q[] = 1;
$q[] = 2;
$q[] = 3;

foreach ($q as $elem)  {
 echo $elem."\n";
}
?>

以上例程会输出：

3
2
1


Sets the mode of iteration

  • ? SplStack::__construct
  • SplQueue ?
  • PHP Manual
  • SplStack
  • Sets the mode of iteration

SplStack::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplStack::setIteratorMode — Sets the mode of iteration

说明

public SplStack::setIteratorMode ( int $mode ) : void

参数

mode

There is only one iteration parameter you can modify.

  • The behavior of the iterator (either one or the other):
    • SplDoublyLinkedList::IT_MODE_DELETE (Elements are deleted by the iterator)
    • SplDoublyLinkedList::IT_MODE_KEEP (Elements are traversed by the iterator)

The default mode is 0x2 : SplDoublyLinkedList::IT_MODE_LIFO | SplDoublyLinkedList::IT_MODE_KEEP

Warning

The direction of iteration can no longer be changed for SplStacks. Trying to do so will result in a RuntimeException being thrown.

返回值

没有返回值。


The SplQueue class

(PHP 5 >= 5.3.0, PHP 7)

简介

SplQueue 类通过使用一个双向链表来提供队列的主要功能。

类摘要

SplQueue extends SplDoublyLinkedList implements Iterator , ArrayAccess , Countable {
/* 方法 */
public __construct ( )
public dequeue ( ) : mixed
public enqueue ( mixed $value ) : void
public setIteratorMode ( int $mode ) : void
/* 继承的方法 */
public SplDoublyLinkedList::add ( mixed $index , mixed $newval ) : void
public SplDoublyLinkedList::bottom ( ) : mixed
public SplDoublyLinkedList::count ( ) : int
public SplDoublyLinkedList::current ( ) : mixed
public SplDoublyLinkedList::getIteratorMode ( ) : int
public SplDoublyLinkedList::isEmpty ( ) : bool
public SplDoublyLinkedList::key ( ) : mixed
public SplDoublyLinkedList::next ( ) : void
public SplDoublyLinkedList::offsetExists ( mixed $index ) : bool
public SplDoublyLinkedList::offsetGet ( mixed $index ) : mixed
public SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval ) : void
public SplDoublyLinkedList::offsetUnset ( mixed $index ) : void
public SplDoublyLinkedList::pop ( ) : mixed
public SplDoublyLinkedList::prev ( ) : void
public SplDoublyLinkedList::push ( mixed $value ) : void
public SplDoublyLinkedList::rewind ( ) : void
public SplDoublyLinkedList::serialize ( ) : string
public SplDoublyLinkedList::setIteratorMode ( int $mode ) : void
public SplDoublyLinkedList::shift ( ) : mixed
public SplDoublyLinkedList::top ( ) : mixed
public SplDoublyLinkedList::unserialize ( string $serialized ) : void
public SplDoublyLinkedList::unshift ( mixed $value ) : void
public SplDoublyLinkedList::valid ( ) : bool
}

Table of Contents

  • SplQueue::__construct — Constructs a new queue implemented using a doubly linked list
  • SplQueue::dequeue — Dequeues a node from the queue
  • SplQueue::enqueue — Adds an element to the queue
  • SplQueue::setIteratorMode — Sets the mode of iteration


Constructs a new queue implemented using a doubly linked list

  • ? SplQueue
  • SplQueue::dequeue ?
  • PHP Manual
  • SplQueue
  • Constructs a new queue implemented using a doubly linked list

SplQueue::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::__construct — Constructs a new queue implemented using a doubly linked list

说明

public SplQueue::__construct ( )

This constructs a new empty queue.

Note:

This method automatically sets the iterator mode to SplDoublyLinkedList::IT_MODE_FIFO.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 SplQueue::__construct() example

<?php
$q = new SplQueue();

$q[] = 1;
$q[] = 2;
$q[] = 3;

foreach ($q as $elem)  {
 echo $elem."\n";
}
?>

以上例程会输出：

1
2
3

Example #2 Efficiently handling tasks with SplQueue

<?php
$q = new SplQueue();
$q->setIteratorMode(SplQueue::IT_MODE_DELETE);

// ... enqueue some tasks on the queue ...

// process them
foreach ($q as $task) {
    // ... process $task ...

    // add new tasks on the queue
    $q[] = $newTask;
    // ...
}
?>


Dequeues a node from the queue

  • ? SplQueue::__construct
  • SplQueue::enqueue ?
  • PHP Manual
  • SplQueue
  • Dequeues a node from the queue

SplQueue::dequeue

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::dequeue — Dequeues a node from the queue

说明

public SplQueue::dequeue ( ) : mixed

Dequeues value from the top of the queue.

Note:

SplQueue::dequeue() is an alias of SplDoublyLinkedList::shift().

参数

此函数没有参数。

返回值

The value of the dequeued node.


Adds an element to the queue

  • ? SplQueue::dequeue
  • SplQueue::setIteratorMode ?
  • PHP Manual
  • SplQueue
  • Adds an element to the queue

SplQueue::enqueue

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::enqueue — Adds an element to the queue

说明

public SplQueue::enqueue ( mixed $value ) : void

Enqueues value at the end of the queue.

Note:

SplQueue::enqueue() is an alias of SplDoublyLinkedList::push().

参数

value

The value to enqueue.

返回值

没有返回值。


Sets the mode of iteration

  • ? SplQueue::enqueue
  • SplHeap ?
  • PHP Manual
  • SplQueue
  • Sets the mode of iteration

SplQueue::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::setIteratorMode — Sets the mode of iteration

说明

public SplQueue::setIteratorMode ( int $mode ) : void

参数

mode

There is only one iteration parameter you can modify.

  • The behavior of the iterator (either one or the other):
    • SplDoublyLinkedList::IT_MODE_DELETE (Elements are deleted by the iterator)
    • SplDoublyLinkedList::IT_MODE_KEEP (Elements are traversed by the iterator)

The default mode is: SplDoublyLinkedList::IT_MODE_FIFO | SplDoublyLinkedList::IT_MODE_KEEP

Warning

The direction of iteration can not be changed for SplQueues, it is always SplDoublyLinkedList::IT_MODE_FIFO.

返回值

没有返回值。

错误／异常

Throws a RuntimeException on trying to change the direction of iteration by using SplDoublyLinkedList::IT_MODE_LIFO.


The SplHeap class

(PHP 5 >= 5.3.0, PHP 7)

简介

The SplHeap class provides the main functionalities of a Heap.

类摘要

abstract SplHeap implements Iterator , Countable {
/* 方法 */
public __construct ( )
abstract protected compare ( mixed $value1 , mixed $value2 ) : int
public count ( ) : int
public current ( ) : mixed
public extract ( ) : mixed
public insert ( mixed $value ) : void
public isCorrupted ( ) : bool
public isEmpty ( ) : bool
public key ( ) : mixed
public next ( ) : void
public recoverFromCorruption ( ) : void
public rewind ( ) : void
public top ( ) : mixed
public valid ( ) : bool
}

Table of Contents

  • SplHeap::compare — Compare elements in order to place them correctly in the heap while sifting up
  • SplHeap::__construct — Constructs a new empty heap
  • SplHeap::count — Counts the number of elements in the heap
  • SplHeap::current — Return current node pointed by the iterator
  • SplHeap::extract — Extracts a node from top of the heap and sift up
  • SplHeap::insert — Inserts an element in the heap by sifting it up
  • SplHeap::isCorrupted — Tells if the heap is in a corrupted state
  • SplHeap::isEmpty — Checks whether the heap is empty
  • SplHeap::key — Return current node index
  • SplHeap::next — Move to the next node
  • SplHeap::recoverFromCorruption — Recover from the corrupted state and allow further actions on the heap
  • SplHeap::rewind — Rewind iterator back to the start (no-op)
  • SplHeap::top — Peeks at the node from the top of the heap
  • SplHeap::valid — Check whether the heap contains more nodes


Compare elements in order to place them correctly in the heap while sifting up

  • ? SplHeap
  • SplHeap::__construct ?
  • PHP Manual
  • SplHeap
  • Compare elements in order to place them correctly in the heap while sifting up

SplHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::compare — Compare elements in order to place them correctly in the heap while sifting up

说明

abstract protected SplHeap::compare ( mixed $value1 , mixed $value2 ) : int

Compare value1 with value2.

Warning

Throwing exceptions in SplHeap::compare() can corrupt the Heap and place it in a blocked state. You can unblock it by calling SplHeap::recoverFromCorruption(). However, some elements might not be placed correctly and it may hence break the heap-property.

参数

value1

The value of the first node being compared.

value2

The value of the second node being compared.

返回值

Result of the comparison, positive integer if value1 is greater than value2, 0 if they are equal, negative integer otherwise.

Note:

Having multiple elements with the same value in a Heap is not recommended. They will end up in an arbitrary relative position.


Constructs a new empty heap

  • ? SplHeap::compare
  • SplHeap::count ?
  • PHP Manual
  • SplHeap
  • Constructs a new empty heap

SplHeap::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::__construct — Constructs a new empty heap

说明

public SplHeap::__construct ( )

This constructs a new empty heap.

参数

此函数没有参数。

返回值

没有返回值。


Counts the number of elements in the heap

  • ? SplHeap::__construct
  • SplHeap::current ?
  • PHP Manual
  • SplHeap
  • Counts the number of elements in the heap

SplHeap::count

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::count — Counts the number of elements in the heap

说明

public SplHeap::count ( ) : int

参数

此函数没有参数。

返回值

Returns the number of elements in the heap.


Return current node pointed by the iterator

  • ? SplHeap::count
  • SplHeap::extract ?
  • PHP Manual
  • SplHeap
  • Return current node pointed by the iterator

SplHeap::current

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::current — Return current node pointed by the iterator

说明

public SplHeap::current ( ) : mixed

Get the current datastructure node.

参数

此函数没有参数。

返回值

The current node value.


Extracts a node from top of the heap and sift up

  • ? SplHeap::current
  • SplHeap::insert ?
  • PHP Manual
  • SplHeap
  • Extracts a node from top of the heap and sift up

SplHeap::extract

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::extract — Extracts a node from top of the heap and sift up

说明

public SplHeap::extract ( ) : mixed

参数

此函数没有参数。

返回值

The value of the extracted node.

错误／异常

Throws RuntimeException when the data-structure is empty.


Inserts an element in the heap by sifting it up

  • ? SplHeap::extract
  • SplHeap::isCorrupted ?
  • PHP Manual
  • SplHeap
  • Inserts an element in the heap by sifting it up

SplHeap::insert

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::insert — Inserts an element in the heap by sifting it up

说明

public SplHeap::insert ( mixed $value ) : void

Insert value in the heap.

参数

value

The value to insert.

返回值

没有返回值。


Tells if the heap is in a corrupted state

  • ? SplHeap::insert
  • SplHeap::isEmpty ?
  • PHP Manual
  • SplHeap
  • Tells if the heap is in a corrupted state

SplHeap::isCorrupted

(PHP 7)

SplHeap::isCorrupted — Tells if the heap is in a corrupted state

说明

public SplHeap::isCorrupted ( ) : bool

参数

此函数没有参数。

返回值

Returns true if the heap is corrupted, false otherwise.


Checks whether the heap is empty

  • ? SplHeap::isCorrupted
  • SplHeap::key ?
  • PHP Manual
  • SplHeap
  • Checks whether the heap is empty

SplHeap::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::isEmpty — Checks whether the heap is empty

说明

public SplHeap::isEmpty ( ) : bool

参数

此函数没有参数。

返回值

Returns whether the heap is empty.


Return current node index

  • ? SplHeap::isEmpty
  • SplHeap::next ?
  • PHP Manual
  • SplHeap
  • Return current node index

SplHeap::key

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::key — Return current node index

说明

public SplHeap::key ( ) : mixed

This function returns the current node index

参数

此函数没有参数。

返回值

The current node index.


Move to the next node

  • ? SplHeap::key
  • SplHeap::recoverFromCorruption ?
  • PHP Manual
  • SplHeap
  • Move to the next node

SplHeap::next

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::next — Move to the next node

说明

public SplHeap::next ( ) : void

Move to the next node. This will delete the top node of the heap.

参数

此函数没有参数。

返回值

没有返回值。


Recover from the corrupted state and allow further actions on the heap

  • ? SplHeap::next
  • SplHeap::rewind ?
  • PHP Manual
  • SplHeap
  • Recover from the corrupted state and allow further actions on the heap

SplHeap::recoverFromCorruption

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::recoverFromCorruption — Recover from the corrupted state and allow further actions on the heap

说明

public SplHeap::recoverFromCorruption ( ) : void

参数

此函数没有参数。

返回值

没有返回值。


Rewind iterator back to the start (no-op)

  • ? SplHeap::recoverFromCorruption
  • SplHeap::top ?
  • PHP Manual
  • SplHeap
  • Rewind iterator back to the start (no-op)

SplHeap::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::rewind — Rewind iterator back to the start (no-op)

说明

public SplHeap::rewind ( ) : void

This rewinds the iterator to the beginning. This is a no-op for heaps as the iterator is virtual and in fact never moves from the top of the heap.

参数

此函数没有参数。

返回值

没有返回值。


Peeks at the node from the top of the heap

  • ? SplHeap::rewind
  • SplHeap::valid ?
  • PHP Manual
  • SplHeap
  • Peeks at the node from the top of the heap

SplHeap::top

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::top — Peeks at the node from the top of the heap

说明

public SplHeap::top ( ) : mixed

参数

此函数没有参数。

返回值

The value of the node on the top.

错误／异常

Throws RuntimeException when the data-structure is empty.


Check whether the heap contains more nodes

  • ? SplHeap::top
  • SplMaxHeap ?
  • PHP Manual
  • SplHeap
  • Check whether the heap contains more nodes

SplHeap::valid

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::valid — Check whether the heap contains more nodes

说明

public SplHeap::valid ( ) : bool

Checks if the heap contains any more nodes.

参数

此函数没有参数。

返回值

Returns true if the heap contains any more nodes, false otherwise.


The SplMaxHeap class

(PHP 5 >= 5.3.0, PHP 7)

简介

The SplMaxHeap class provides the main functionalities of a heap, keeping the maximum on the top.

类摘要

SplMaxHeap extends SplHeap implements Iterator , Countable {
/* 方法 */
protected compare ( mixed $value1 , mixed $value2 ) : int
/* 继承的方法 */
abstract protected SplHeap::compare ( mixed $value1 , mixed $value2 ) : int
public SplHeap::count ( ) : int
public SplHeap::current ( ) : mixed
public SplHeap::extract ( ) : mixed
public SplHeap::insert ( mixed $value ) : void
public SplHeap::isCorrupted ( ) : bool
public SplHeap::isEmpty ( ) : bool
public SplHeap::key ( ) : mixed
public SplHeap::next ( ) : void
public SplHeap::recoverFromCorruption ( ) : void
public SplHeap::rewind ( ) : void
public SplHeap::top ( ) : mixed
public SplHeap::valid ( ) : bool
}

Table of Contents

  • SplMaxHeap::compare — Compare elements in order to place them correctly in the heap while sifting up


Compare elements in order to place them correctly in the heap while sifting up

  • ? SplMaxHeap
  • SplMinHeap ?
  • PHP Manual
  • SplMaxHeap
  • Compare elements in order to place them correctly in the heap while sifting up

SplMaxHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplMaxHeap::compare — Compare elements in order to place them correctly in the heap while sifting up

说明

protected SplMaxHeap::compare ( mixed $value1 , mixed $value2 ) : int

Compare value1 with value2.

参数

value1

The value of the first node being compared.

value2

The value of the second node being compared.

返回值

Result of the comparison, positive integer if value1 is greater than value2, 0 if they are equal, negative integer otherwise.

Note:

Having multiple elements with the same value in a Heap is not recommended. They will end up in an arbitrary relative position.


The SplMinHeap class

(PHP 5 >= 5.3.0, PHP 7)

简介

The SplMinHeap class provides the main functionalities of a heap, keeping the minimum on the top.

类摘要

SplMinHeap extends SplHeap implements Iterator , Countable {
/* 方法 */
protected compare ( mixed $value1 , mixed $value2 ) : int
/* 继承的方法 */
abstract protected SplHeap::compare ( mixed $value1 , mixed $value2 ) : int
public SplHeap::count ( ) : int
public SplHeap::current ( ) : mixed
public SplHeap::extract ( ) : mixed
public SplHeap::insert ( mixed $value ) : void
public SplHeap::isCorrupted ( ) : bool
public SplHeap::isEmpty ( ) : bool
public SplHeap::key ( ) : mixed
public SplHeap::next ( ) : void
public SplHeap::recoverFromCorruption ( ) : void
public SplHeap::rewind ( ) : void
public SplHeap::top ( ) : mixed
public SplHeap::valid ( ) : bool
}

Table of Contents

  • SplMinHeap::compare — Compare elements in order to place them correctly in the heap while sifting up


Compare elements in order to place them correctly in the heap while sifting up

  • ? SplMinHeap
  • SplPriorityQueue ?
  • PHP Manual
  • SplMinHeap
  • Compare elements in order to place them correctly in the heap while sifting up

SplMinHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplMinHeap::compare — Compare elements in order to place them correctly in the heap while sifting up

说明

protected SplMinHeap::compare ( mixed $value1 , mixed $value2 ) : int

Compare value1 with value2.

参数

value1

The value of the first node being compared.

value2

The value of the second node being compared.

返回值

Result of the comparison, positive integer if value1 is lower than value2, 0 if they are equal, negative integer otherwise.

Note:

Having multiple elements with the same value in a Heap is not recommended. They will end up in an arbitrary relative position.


The SplPriorityQueue class

(PHP 5 >= 5.3.0, PHP 7)

简介

The SplPriorityQueue class provides the main functionalities of a prioritized queue, implemented using a max heap.

Note: The order of elements with identical priority is undefined. It may differ from the order in which they have been inserted.

类摘要

SplPriorityQueue implements Iterator , Countable {
/* 方法 */
public __construct ( )
public compare ( mixed $priority1 , mixed $priority2 ) : int
public count ( ) : int
public current ( ) : mixed
public extract ( ) : mixed
public getExtractFlags ( ) : int
public insert ( mixed $value , mixed $priority ) : bool
public isCorrupted ( ) : bool
public isEmpty ( ) : bool
public key ( ) : mixed
public next ( ) : void
public recoverFromCorruption ( ) : void
public rewind ( ) : void
public setExtractFlags ( int $flags ) : void
public top ( ) : mixed
public valid ( ) : bool
}

Table of Contents

  • SplPriorityQueue::compare — Compare priorities in order to place elements correctly in the heap while sifting up
  • SplPriorityQueue::__construct — Constructs a new empty queue
  • SplPriorityQueue::count — Counts the number of elements in the queue
  • SplPriorityQueue::current — Return current node pointed by the iterator
  • SplPriorityQueue::extract — Extracts a node from top of the heap and sift up
  • SplPriorityQueue::getExtractFlags — Get the flags of extraction
  • SplPriorityQueue::insert — Inserts an element in the queue by sifting it up
  • SplPriorityQueue::isCorrupted — Tells if the priority queue is in a corrupted state
  • SplPriorityQueue::isEmpty — Checks whether the queue is empty
  • SplPriorityQueue::key — Return current node index
  • SplPriorityQueue::next — Move to the next node
  • SplPriorityQueue::recoverFromCorruption — Recover from the corrupted state and allow further actions on the queue
  • SplPriorityQueue::rewind — Rewind iterator back to the start (no-op)
  • SplPriorityQueue::setExtractFlags — Sets the mode of extraction
  • SplPriorityQueue::top — Peeks at the node from the top of the queue
  • SplPriorityQueue::valid — Check whether the queue contains more nodes


Compare priorities in order to place elements correctly in the heap while sifting up

  • ? SplPriorityQueue
  • SplPriorityQueue::__construct ?
  • PHP Manual
  • SplPriorityQueue
  • Compare priorities in order to place elements correctly in the heap while sifting up

SplPriorityQueue::compare

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::compare — Compare priorities in order to place elements correctly in the heap while sifting up

说明

public SplPriorityQueue::compare ( mixed $priority1 , mixed $priority2 ) : int

Compare priority1 with priority2.

参数

priority1

The priority of the first node being compared.

priority2

The priority of the second node being compared.

返回值

Result of the comparison, positive integer if priority1 is greater than priority2, 0 if they are equal, negative integer otherwise.

Note:

Multiple elements with the same priority will get dequeued in no particular order.


Constructs a new empty queue

  • ? SplPriorityQueue::compare
  • SplPriorityQueue::count ?
  • PHP Manual
  • SplPriorityQueue
  • Constructs a new empty queue

SplPriorityQueue::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::__construct — Constructs a new empty queue

说明

public SplPriorityQueue::__construct ( )

This constructs a new empty queue.

参数

此函数没有参数。

返回值

没有返回值。


Counts the number of elements in the queue

  • ? SplPriorityQueue::__construct
  • SplPriorityQueue::current ?
  • PHP Manual
  • SplPriorityQueue
  • Counts the number of elements in the queue

SplPriorityQueue::count

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::count — Counts the number of elements in the queue

说明

public SplPriorityQueue::count ( ) : int

参数

此函数没有参数。

返回值

Returns the number of elements in the queue.


Return current node pointed by the iterator

  • ? SplPriorityQueue::count
  • SplPriorityQueue::extract ?
  • PHP Manual
  • SplPriorityQueue
  • Return current node pointed by the iterator

SplPriorityQueue::current

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::current — Return current node pointed by the iterator

说明

public SplPriorityQueue::current ( ) : mixed

Get the current datastructure node.

参数

此函数没有参数。

返回值

The value or priority (or both) of the current node, depending on the extract flag.


Extracts a node from top of the heap and sift up

  • ? SplPriorityQueue::current
  • SplPriorityQueue::getExtractFlags ?
  • PHP Manual
  • SplPriorityQueue
  • Extracts a node from top of the heap and sift up

SplPriorityQueue::extract

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::extract — Extracts a node from top of the heap and sift up

说明

public SplPriorityQueue::extract ( ) : mixed

参数

此函数没有参数。

返回值

The value or priority (or both) of the extracted node, depending on the extract flag.


Get the flags of extraction

  • ? SplPriorityQueue::extract
  • SplPriorityQueue::insert ?
  • PHP Manual
  • SplPriorityQueue
  • Get the flags of extraction

SplPriorityQueue::getExtractFlags

(PHP 7)

SplPriorityQueue::getExtractFlags — Get the flags of extraction

说明

public SplPriorityQueue::getExtractFlags ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Inserts an element in the queue by sifting it up

  • ? SplPriorityQueue::getExtractFlags
  • SplPriorityQueue::isCorrupted ?
  • PHP Manual
  • SplPriorityQueue
  • Inserts an element in the queue by sifting it up

SplPriorityQueue::insert

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::insert — Inserts an element in the queue by sifting it up

说明

public SplPriorityQueue::insert ( mixed $value , mixed $priority ) : bool

Insert value with the priority priority in the queue.

参数

value

The value to insert.

priority

The associated priority.

返回值

Returns true.


Tells if the priority queue is in a corrupted state

  • ? SplPriorityQueue::insert
  • SplPriorityQueue::isEmpty ?
  • PHP Manual
  • SplPriorityQueue
  • Tells if the priority queue is in a corrupted state

SplPriorityQueue::isCorrupted

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::isCorrupted — Tells if the priority queue is in a corrupted state

说明

public SplPriorityQueue::isCorrupted ( ) : bool

参数

此函数没有参数。

返回值

Returns true if the priority queue is corrupted, false otherwise.


Checks whether the queue is empty

  • ? SplPriorityQueue::isCorrupted
  • SplPriorityQueue::key ?
  • PHP Manual
  • SplPriorityQueue
  • Checks whether the queue is empty

SplPriorityQueue::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::isEmpty — Checks whether the queue is empty

说明

public SplPriorityQueue::isEmpty ( ) : bool

参数

此函数没有参数。

返回值

Returns whether the queue is empty.


Return current node index

  • ? SplPriorityQueue::isEmpty
  • SplPriorityQueue::next ?
  • PHP Manual
  • SplPriorityQueue
  • Return current node index

SplPriorityQueue::key

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::key — Return current node index

说明

public SplPriorityQueue::key ( ) : mixed

This function returns the current node index

参数

此函数没有参数。

返回值

The current node index.


Move to the next node

  • ? SplPriorityQueue::key
  • SplPriorityQueue::recoverFromCorruption ?
  • PHP Manual
  • SplPriorityQueue
  • Move to the next node

SplPriorityQueue::next

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::next — Move to the next node

说明

public SplPriorityQueue::next ( ) : void

Extracts the top node from the queue.

参数

此函数没有参数。

返回值

没有返回值。


Recover from the corrupted state and allow further actions on the queue

  • ? SplPriorityQueue::next
  • SplPriorityQueue::rewind ?
  • PHP Manual
  • SplPriorityQueue
  • Recover from the corrupted state and allow further actions on the queue

SplPriorityQueue::recoverFromCorruption

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::recoverFromCorruption — Recover from the corrupted state and allow further actions on the queue

说明

public SplPriorityQueue::recoverFromCorruption ( ) : void

参数

此函数没有参数。

返回值

没有返回值。


Rewind iterator back to the start (no-op)

  • ? SplPriorityQueue::recoverFromCorruption
  • SplPriorityQueue::setExtractFlags ?
  • PHP Manual
  • SplPriorityQueue
  • Rewind iterator back to the start (no-op)

SplPriorityQueue::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::rewind — Rewind iterator back to the start (no-op)

说明

public SplPriorityQueue::rewind ( ) : void

This rewinds the iterator to the beginning. This is a no-op for heaps as the iterator is virtual and in fact never moves from the top of the heap.

参数

此函数没有参数。

返回值

没有返回值。


Sets the mode of extraction

  • ? SplPriorityQueue::rewind
  • SplPriorityQueue::top ?
  • PHP Manual
  • SplPriorityQueue
  • Sets the mode of extraction

SplPriorityQueue::setExtractFlags

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::setExtractFlags — Sets the mode of extraction

说明

public SplPriorityQueue::setExtractFlags ( int $flags ) : void

参数

flags

Defines what is extracted by SplPriorityQueue::current(),
SplPriorityQueue::top() and
SplPriorityQueue::extract().

  • SplPriorityQueue::EXTR_DATA (0x00000001): Extract the data
  • SplPriorityQueue::EXTR_PRIORITY (0x00000002): Extract the priority
  • SplPriorityQueue::EXTR_BOTH (0x00000003): Extract an array containing both

The default mode is SplPriorityQueue::EXTR_DATA.

返回值

没有返回值。


Peeks at the node from the top of the queue

  • ? SplPriorityQueue::setExtractFlags
  • SplPriorityQueue::valid ?
  • PHP Manual
  • SplPriorityQueue
  • Peeks at the node from the top of the queue

SplPriorityQueue::top

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::top — Peeks at the node from the top of the queue

说明

public SplPriorityQueue::top ( ) : mixed

参数

此函数没有参数。

返回值

The value or priority (or both) of the top node, depending on the extract flag.


Check whether the queue contains more nodes

  • ? SplPriorityQueue::top
  • SplFixedArray ?
  • PHP Manual
  • SplPriorityQueue
  • Check whether the queue contains more nodes

SplPriorityQueue::valid

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::valid — Check whether the queue contains more nodes

说明

public SplPriorityQueue::valid ( ) : bool

Checks if the queue contains any more nodes.

参数

此函数没有参数。

返回值

Returns true if the queue contains any more nodes, false otherwise.


The SplFixedArray class

(PHP 5 >= 5.3.0, PHP 7)

简介

The SplFixedArray class provides the main functionalities of array. The main difference between a SplFixedArray and a normal PHP array is that the SplFixedArray must be resized manually and allows only integers within the range as indexes. The advantage is that it uses less memory than a standard array.

类摘要

SplFixedArray implements Iterator , ArrayAccess , Countable {
/* 方法 */
public __construct ( int $size = 0 )
public count ( ) : int
public current ( ) : mixed
public static fromArray ( array $array , bool $save_indexes = true ) : SplFixedArray
public getSize ( ) : int
public key ( ) : int
public next ( ) : void
public offsetExists ( int $index ) : bool
public offsetGet ( int $index ) : mixed
public offsetSet ( int $index , mixed $newval ) : void
public offsetUnset ( int $index ) : void
public rewind ( ) : void
public setSize ( int $size ) : bool
public toArray ( ) : array
public valid ( ) : bool
public __wakeup ( ) : void
}

范例

Example #1 SplFixedArray usage example

<?php
// Initialize the array with a fixed length
$array = new SplFixedArray(5);

$array[1] = 2;
$array[4] = "foo";

var_dump($array[0]); // NULL
var_dump($array[1]); // int(2)

var_dump($array["4"]); // string(3) "foo"

// Increase the size of the array to 10
$array->setSize(10);

$array[9] = "asdf";

// Shrink the array to a size of 2
$array->setSize(2);

// The following lines throw a RuntimeException: Index invalid or out of range
try {
    var_dump($array["non-numeric"]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}

try {
    var_dump($array[-1]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}

try {
    var_dump($array[5]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}
?>

以上例程会输出：

NULL
int(2)
string(3) "foo"
RuntimeException: Index invalid or out of range
RuntimeException: Index invalid or out of range
RuntimeException: Index invalid or out of range

Table of Contents

  • SplFixedArray::__construct — Constructs a new fixed array
  • SplFixedArray::count — Returns the size of the array
  • SplFixedArray::current — Return current array entry
  • SplFixedArray::fromArray — Import a PHP array in a SplFixedArray instance
  • SplFixedArray::getSize — Gets the size of the array
  • SplFixedArray::key — Return current array index
  • SplFixedArray::next — Move to next entry
  • SplFixedArray::offsetExists — Returns whether the requested index exists
  • SplFixedArray::offsetGet — Returns the value at the specified index
  • SplFixedArray::offsetSet — Sets a new value at a specified index
  • SplFixedArray::offsetUnset — Unsets the value at the specified $index
  • SplFixedArray::rewind — Rewind iterator back to the start
  • SplFixedArray::setSize — Change the size of an array
  • SplFixedArray::toArray — Returns a PHP array from the fixed array
  • SplFixedArray::valid — Check whether the array contains more elements
  • SplFixedArray::__wakeup — Reinitialises the array after being unserialised


Constructs a new fixed array

  • ? SplFixedArray
  • SplFixedArray::count ?
  • PHP Manual
  • SplFixedArray
  • Constructs a new fixed array

SplFixedArray::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::__construct — Constructs a new fixed array

说明

public SplFixedArray::__construct ( int $size = 0 )

Initializes a fixed array with a number of null values equal to size.

参数

size

The size of the fixed array. This expects a number between 0 and PHP_INT_MAX.

返回值

没有返回值。

错误／异常

Throws InvalidArgumentException when size is a negative number.

Raises E_WARNING when size cannot be parsed as a number.

范例

Example #1 SplFixedArray::__construct() example

<?php
$array = new SplFixedArray(5);

$array[1] = 2;
$array[4] = "foo";

foreach($array as $v) {
  var_dump($v);
}
?>

以上例程会输出：

NULL
int(2)
NULL
NULL
string(3) "foo"


Returns the size of the array

  • ? SplFixedArray::__construct
  • SplFixedArray::current ?
  • PHP Manual
  • SplFixedArray
  • Returns the size of the array

SplFixedArray::count

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::count — Returns the size of the array

说明

public SplFixedArray::count ( ) : int

Returns the size of the array.

参数

此函数没有参数。

返回值

Returns the size of the array.

范例

Example #1 SplFixedArray::count() example

<?php
$array = new SplFixedArray(5);
echo $array->count() . "\n";
echo count($array) . "\n";
?>

以上例程会输出：

5
5

注释

Note:

This method is functionally equivalent to SplFixedArray::getSize().

Note:

The count of elements is always equal to the set size because all values are initially initialized with null.

参见

  • SplFixedArray::getSize() - Gets the size of the array


Return current array entry

  • ? SplFixedArray::count
  • SplFixedArray::fromArray ?
  • PHP Manual
  • SplFixedArray
  • Return current array entry

SplFixedArray::current

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::current — Return current array entry

说明

public SplFixedArray::current ( ) : mixed

Get the current array element.

参数

此函数没有参数。

返回值

The current element value.

错误／异常

Throws RuntimeException when the internal array pointer points to an invalid index or is out of bounds.


Import a PHP array in a SplFixedArray instance

  • ? SplFixedArray::current
  • SplFixedArray::getSize ?
  • PHP Manual
  • SplFixedArray
  • Import a PHP array in a SplFixedArray instance

SplFixedArray::fromArray

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::fromArray — Import a PHP array in a SplFixedArray instance

说明

public static SplFixedArray::fromArray ( array $array , bool $save_indexes = true ) : SplFixedArray

Import the PHP array array in a new SplFixedArray instance

参数

array

The array to import.

save_indexes

Try to save the numeric indexes used in the original array.

返回值

Returns an instance of SplFixedArray containing the array content.

范例

Example #1 SplFixedArray::fromArray() example

<?php
$fa = SplFixedArray::fromArray(array(1 => 1, 0 => 2, 3 => 3));

var_dump($fa);

$fa = SplFixedArray::fromArray(array(1 => 1, 0 => 2, 3 => 3), false);

var_dump($fa);
?>

以上例程会输出：

object(SplFixedArray)#1 (4) {
  [0]=>
  int(2)
  [1]=>
  int(1)
  [2]=>
  NULL
  [3]=>
  int(3)
}
object(SplFixedArray)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Gets the size of the array

  • ? SplFixedArray::fromArray
  • SplFixedArray::key ?
  • PHP Manual
  • SplFixedArray
  • Gets the size of the array

SplFixedArray::getSize

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::getSize — Gets the size of the array

说明

public SplFixedArray::getSize ( ) : int

Gets the size of the array.

参数

此函数没有参数。

返回值

Returns the size of the array, as an int.

范例

Example #1 SplFixedArray::getSize() example

<?php
$array = new SplFixedArray(5);
echo $array->getSize()."\n";
$array->setSize(10);
echo $array->getSize()."\n";
?>

以上例程会输出：

5
10

注释

Note:

This method is functionally equivalent to SplFixedArray::count()

参见

  • SplFixedArray::count() - Returns the size of the array


Return current array index

  • ? SplFixedArray::getSize
  • SplFixedArray::next ?
  • PHP Manual
  • SplFixedArray
  • Return current array index

SplFixedArray::key

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::key — Return current array index

说明

public SplFixedArray::key ( ) : int

Returns the current array index.

参数

此函数没有参数。

返回值

The current array index.


Move to next entry

  • ? SplFixedArray::key
  • SplFixedArray::offsetExists ?
  • PHP Manual
  • SplFixedArray
  • Move to next entry

SplFixedArray::next

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::next — Move to next entry

说明

public SplFixedArray::next ( ) : void

Move the iterator to the next array entry.

参数

此函数没有参数。

返回值

没有返回值。


Returns whether the requested index exists

  • ? SplFixedArray::next
  • SplFixedArray::offsetGet ?
  • PHP Manual
  • SplFixedArray
  • Returns whether the requested index exists

SplFixedArray::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetExists — Returns whether the requested index exists

说明

public SplFixedArray::offsetExists ( int $index ) : bool

Checks whether the requested index index exists.

参数

index

The index being checked.

返回值

true if the requested index exists, otherwise false


Returns the value at the specified index

  • ? SplFixedArray::offsetExists
  • SplFixedArray::offsetSet ?
  • PHP Manual
  • SplFixedArray
  • Returns the value at the specified index

SplFixedArray::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetGet — Returns the value at the specified index

说明

public SplFixedArray::offsetGet ( int $index ) : mixed

Returns the value at the index index.

参数

index

The index with the value.

返回值

The value at the specified index.

错误／异常

Throws RuntimeException when index is outside the defined size of the array or when index cannot be parsed as an integer.


Sets a new value at a specified index

  • ? SplFixedArray::offsetGet
  • SplFixedArray::offsetUnset ?
  • PHP Manual
  • SplFixedArray
  • Sets a new value at a specified index

SplFixedArray::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetSet — Sets a new value at a specified index

说明

public SplFixedArray::offsetSet ( int $index , mixed $newval ) : void

Sets the value at the specified index to newval.

参数

index

The index being set.

newval

The new value for the index.

返回值

没有返回值。

错误／异常

Throws RuntimeException when index is outside the defined size of the array or when index cannot be parsed as an integer.


Unsets the value at the specified $index

  • ? SplFixedArray::offsetSet
  • SplFixedArray::rewind ?
  • PHP Manual
  • SplFixedArray
  • Unsets the value at the specified $index

SplFixedArray::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetUnset — Unsets the value at the specified $index

说明

public SplFixedArray::offsetUnset ( int $index ) : void

Unsets the value at the specified index.

参数

index

The index being unset.

返回值

没有返回值。

错误／异常

Throws RuntimeException when index is outside the defined size of the array or when index cannot be parsed as an integer.


Rewind iterator back to the start

  • ? SplFixedArray::offsetUnset
  • SplFixedArray::setSize ?
  • PHP Manual
  • SplFixedArray
  • Rewind iterator back to the start

SplFixedArray::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::rewind — Rewind iterator back to the start

说明

public SplFixedArray::rewind ( ) : void

Rewinds the iterator to the beginning.

参数

此函数没有参数。

返回值

没有返回值。


Change the size of an array

  • ? SplFixedArray::rewind
  • SplFixedArray::toArray ?
  • PHP Manual
  • SplFixedArray
  • Change the size of an array

SplFixedArray::setSize

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::setSize — Change the size of an array

说明

public SplFixedArray::setSize ( int $size ) : bool

Change the size of an array to the new size of size. If size is less than the current array size, any values after the new size will be discarded. If size is greater than the current array size, the array will be padded with null values.

参数

size

The new array size. This should be a value between 0 and PHP_INT_MAX.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws InvalidArgumentException when size is less than zero.

Raises E_WARNING when size cannot be used as a number.

范例

Example #1 SplFixedArray::setSize() example

<?php
   $array = new SplFixedArray(5);
   echo $array->getSize()."\n";
   $array->setSize(10);
   echo $array->getSize()."\n";
?>

以上例程会输出：

5
10


Returns a PHP array from the fixed array

  • ? SplFixedArray::setSize
  • SplFixedArray::valid ?
  • PHP Manual
  • SplFixedArray
  • Returns a PHP array from the fixed array

SplFixedArray::toArray

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::toArray — Returns a PHP array from the fixed array

说明

public SplFixedArray::toArray ( ) : array

Returns a PHP array from the fixed array.

参数

此函数没有参数。

返回值

Returns a PHP array, similar to the fixed array.

范例

Example #1 SplFixedArray::toArray() example

<?php
$fa = new SplFixedArray(3);
$fa[0] = 0;
$fa[2] = 2;
var_dump($fa->toArray());
?>

以上例程会输出：

array(3) {
  [0]=>
  int(0)
  [1]=>
  NULL
  [2]=>
  int(2)
}


Check whether the array contains more elements

  • ? SplFixedArray::toArray
  • SplFixedArray::__wakeup ?
  • PHP Manual
  • SplFixedArray
  • Check whether the array contains more elements

SplFixedArray::valid

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::valid — Check whether the array contains more elements

说明

public SplFixedArray::valid ( ) : bool

Checks if the array contains any more elements.

参数

此函数没有参数。

返回值

Returns true if the array contains any more elements, false otherwise.


Reinitialises the array after being unserialised

  • ? SplFixedArray::valid
  • SplObjectStorage ?
  • PHP Manual
  • SplFixedArray
  • Reinitialises the array after being unserialised

SplFixedArray::__wakeup

(PHP 5 >= 5.5.0, PHP 7)

SplFixedArray::__wakeup — Reinitialises the array after being unserialised

说明

public SplFixedArray::__wakeup ( ) : void

Reinitialises the array after being unserialised.

参数

此函数没有参数。

返回值

没有返回值。


The SplObjectStorage class

(PHP 5 >= 5.1.0, PHP 7)

简介

The SplObjectStorage class provides a map from objects to data or, by ignoring data, an object set. This dual purpose can be useful in many cases involving the need to uniquely identify objects.

类摘要

SplObjectStorage implements Countable , Iterator , Serializable , ArrayAccess {
/* 方法 */
public addAll ( SplObjectStorage $storage ) : void
public attach ( object $object , mixed $data = null ) : void
public contains ( object $object ) : bool
public count ( ) : int
public current ( ) : object
public detach ( object $object ) : void
public getHash ( object $object ) : string
public getInfo ( ) : mixed
public key ( ) : int
public next ( ) : void
public offsetExists ( object $object ) : bool
public offsetGet ( object $object ) : mixed
public offsetSet ( object $object , mixed $data = null ) : void
public offsetUnset ( object $object ) : void
public removeAll ( SplObjectStorage $storage ) : void
public removeAllExcept ( SplObjectStorage $storage ) : void
public rewind ( ) : void
public serialize ( ) : string
public setInfo ( mixed $data ) : void
public unserialize ( string $serialized ) : void
public valid ( ) : bool
}

范例

Example #1 SplObjectStorage as a set

<?php
// As an object set
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;
$o3 = new StdClass;

$s->attach($o1);
$s->attach($o2);

var_dump($s->contains($o1));
var_dump($s->contains($o2));
var_dump($s->contains($o3));

$s->detach($o2);

var_dump($s->contains($o1));
var_dump($s->contains($o2));
var_dump($s->contains($o3));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

Example #2 SplObjectStorage as a map

<?php
// As a map from objects to data
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;
$o3 = new StdClass;

$s[$o1] = "data for object 1";
$s[$o2] = array(1,2,3);

if (isset($s[$o2])) {
    var_dump($s[$o2]);
}
?>

以上例程会输出：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

Table of Contents

  • SplObjectStorage::addAll — Adds all objects from another storage
  • SplObjectStorage::attach — Adds an object in the storage
  • SplObjectStorage::contains — Checks if the storage contains a specific object
  • SplObjectStorage::count — Returns the number of objects in the storage
  • SplObjectStorage::current — Returns the current storage entry
  • SplObjectStorage::detach — Removes an object from the storage
  • SplObjectStorage::getHash — Calculate a unique identifier for the contained objects
  • SplObjectStorage::getInfo — Returns the data associated with the current iterator entry
  • SplObjectStorage::key — Returns the index at which the iterator currently is
  • SplObjectStorage::next — Move to the next entry
  • SplObjectStorage::offsetExists — Checks whether an object exists in the storage
  • SplObjectStorage::offsetGet — Returns the data associated with an object
  • SplObjectStorage::offsetSet — Associates data to an object in the storage
  • SplObjectStorage::offsetUnset — Removes an object from the storage
  • SplObjectStorage::removeAll — Removes objects contained in another storage from the current storage
  • SplObjectStorage::removeAllExcept — Removes all objects except for those contained in another storage from the current storage
  • SplObjectStorage::rewind — Rewind the iterator to the first storage element
  • SplObjectStorage::serialize — Serializes the storage
  • SplObjectStorage::setInfo — Sets the data associated with the current iterator entry
  • SplObjectStorage::unserialize — Unserializes a storage from its string representation
  • SplObjectStorage::valid — Returns if the current iterator entry is valid


Adds all objects from another storage

  • ? SplObjectStorage
  • SplObjectStorage::attach ?
  • PHP Manual
  • SplObjectStorage
  • Adds all objects from another storage

SplObjectStorage::addAll

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::addAll — Adds all objects from another storage

说明

public SplObjectStorage::addAll ( SplObjectStorage $storage ) : void

Adds all objects-data pairs from a different storage in the current storage.

参数

storage

The storage you want to import.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::addAll() example

<?php
$o = new StdClass;
$a = new SplObjectStorage();
$a[$o] = "hello";

$b = new SplObjectStorage();
$b->addAll($a);
echo $b[$o]."\n";
?>

以上例程的输出类似于：

hello

参见

  • SplObjectStorage::removeAll() - Removes objects contained in another storage from the current storage


Adds an object in the storage

  • ? SplObjectStorage::addAll
  • SplObjectStorage::contains ?
  • PHP Manual
  • SplObjectStorage
  • Adds an object in the storage

SplObjectStorage::attach

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::attach — Adds an object in the storage

说明

public SplObjectStorage::attach ( object $object , mixed $data = null ) : void

Adds an object inside the storage, and optionally associate it to some data.

参数

object

The object to add.

data

The data to associate with the object.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::attach() example

<?php
$o1 = new StdClass;
$o2 = new StdClass;
$s = new SplObjectStorage();
$s->attach($o1); // similar to $s[$o1] = NULL;
$s->attach($o2, "hello"); // similar to $s[$o2] = "hello";

var_dump($s[$o1]);
var_dump($s[$o2]);

?>

以上例程的输出类似于：

NULL
string(5) "hello"

参见

  • SplObjectStorage::detach() - Removes an object from the storage
  • SplObjectStorage::offsetSet() - Associates data to an object in the storage


Checks if the storage contains a specific object

  • ? SplObjectStorage::attach
  • SplObjectStorage::count ?
  • PHP Manual
  • SplObjectStorage
  • Checks if the storage contains a specific object

SplObjectStorage::contains

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::contains — Checks if the storage contains a specific object

说明

public SplObjectStorage::contains ( object $object ) : bool

Checks if the storage contains the object provided.

参数

object

The object to look for.

返回值

Returns true if the object is in the storage, false otherwise.

范例

Example #1 SplObjectStorage::contains() example

<?php
$o1 = new StdClass;
$o2 = new StdClass;

$s = new SplObjectStorage();

$s[$o1] = "hello";
var_dump($s->contains($o1));
var_dump($s->contains($o2));
?>

以上例程的输出类似于：

bool(true)
bool(false)

参见

  • SplObjectStorage::offsetExists() - Checks whether an object exists in the storage


Returns the number of objects in the storage

  • ? SplObjectStorage::contains
  • SplObjectStorage::current ?
  • PHP Manual
  • SplObjectStorage
  • Returns the number of objects in the storage

SplObjectStorage::count

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::count — Returns the number of objects in the storage

说明

public SplObjectStorage::count ( ) : int

Counts the number of objects in the storage.

参数

此函数没有参数。

返回值

The number of objects in the storage.

范例

Example #1 SplObjectStorage::count() example

<?php
$s = new SplObjectStorage();
$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1);
$s->attach($o2);
$s->attach($o1);
var_dump($s->count());
var_dump(count($s));
?>

以上例程的输出类似于：

int(2)
int(2)

参见

  • SplObjectStorage::attach() - Adds an object in the storage
  • SplObjectStorage::detach() - Removes an object from the storage


Returns the current storage entry

  • ? SplObjectStorage::count
  • SplObjectStorage::detach ?
  • PHP Manual
  • SplObjectStorage
  • Returns the current storage entry

SplObjectStorage::current

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::current — Returns the current storage entry

说明

public SplObjectStorage::current ( ) : object

Returns the current storage entry.

参数

此函数没有参数。

返回值

The object at the current iterator position.

范例

Example #1 SplObjectStorage::current() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

以上例程的输出类似于：

object(stdClass)#2 (0) {
}
string(2) "d1"
object(stdClass)#3 (0) {
}
string(2) "d2"

参见

  • SplObjectStorage::rewind() - Rewind the iterator to the first storage element
  • SplObjectStorage::key() - Returns the index at which the iterator currently is
  • SplObjectStorage::next() - Move to the next entry
  • SplObjectStorage::valid() - Returns if the current iterator entry is valid
  • SplObjectStorage::getInfo() - Returns the data associated with the current iterator entry


Removes an object from the storage

  • ? SplObjectStorage::current
  • SplObjectStorage::getHash ?
  • PHP Manual
  • SplObjectStorage
  • Removes an object from the storage

SplObjectStorage::detach

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::detach — Removes an object from the storage

说明

public SplObjectStorage::detach ( object $object ) : void

Removes the object from the storage.

参数

object

The object to remove.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::detach() example

<?php
$o = new StdClass;
$s = new SplObjectStorage();
$s->attach($o);
var_dump(count($s));
$s->detach($o);
var_dump(count($s));
?>

以上例程的输出类似于：

int(1)
int(0)

参见

  • SplObjectStorage::attach() - Adds an object in the storage
  • SplObjectStorage::removeAll() - Removes objects contained in another storage from the current storage


Calculate a unique identifier for the contained objects

  • ? SplObjectStorage::detach
  • SplObjectStorage::getInfo ?
  • PHP Manual
  • SplObjectStorage
  • Calculate a unique identifier for the contained objects

SplObjectStorage::getHash

(PHP 5 >= 5.4.0, PHP 7)

SplObjectStorage::getHash — Calculate a unique identifier for the contained objects

说明

public SplObjectStorage::getHash ( object $object ) : string

This method calculates an identifier for the objects added to an SplObjectStorage object.

The implementation in SplObjectStorage returns the same value as spl_object_hash().

The storage object will never contain more than one object with the same identifier. As such, it can be used to implement a set (a collection of unique values) where the quality of an object being unique is determined by the value returned by this function being unique.

参数

object

The object whose identifier is to be calculated.

返回值

A string with the calculated identifier.

错误／异常

A RuntimeException is thrown when the returned value is not a string.

范例

Example #1 SplObjectStorage::getHash() example

<?php
class OneSpecimenPerClassStorage extends SplObjectStorage {
    public function getHash($o) {
        return get_class($o);
    }
}
class A {}

$s = new OneSpecimenPerClassStorage;
$o1 = new stdClass;
$o2 = new stdClass;
$o3 = new A;

$s[$o1] = 1;
//$o2 is considered equal to $o1 so the value is replaced
$s[$o2] = 2;
$s[$o3] = 3;

//these are considered equal to the objects before
//so they can be used to access the values stored under them
$p1 = new stdClass;
$p2 = new A;
echo $s[$p1], "\n";
echo $s[$p2], "\n";
?>

以上例程的输出类似于：

2
3

参见

  • spl_object_hash() - 返回指定对象的hash id


Returns the data associated with the current iterator entry

  • ? SplObjectStorage::getHash
  • SplObjectStorage::key ?
  • PHP Manual
  • SplObjectStorage
  • Returns the data associated with the current iterator entry

SplObjectStorage::getInfo

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::getInfo — Returns the data associated with the current iterator entry

说明

public SplObjectStorage::getInfo ( ) : mixed

Returns the data, or info, associated with the object pointed by the current iterator position.

参数

此函数没有参数。

返回值

The data associated with the current iterator position.

范例

Example #1 SplObjectStorage::getInfo() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

以上例程的输出类似于：

object(stdClass)#2 (0) {
}
string(2) "d1"
object(stdClass)#3 (0) {
}
string(2) "d2"

参见

  • SplObjectStorage::current() - Returns the current storage entry
  • SplObjectStorage::rewind() - Rewind the iterator to the first storage element
  • SplObjectStorage::key() - Returns the index at which the iterator currently is
  • SplObjectStorage::next() - Move to the next entry
  • SplObjectStorage::valid() - Returns if the current iterator entry is valid
  • SplObjectStorage::setInfo() - Sets the data associated with the current iterator entry


Returns the index at which the iterator currently is

  • ? SplObjectStorage::getInfo
  • SplObjectStorage::next ?
  • PHP Manual
  • SplObjectStorage
  • Returns the index at which the iterator currently is

SplObjectStorage::key

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::key — Returns the index at which the iterator currently is

说明

public SplObjectStorage::key ( ) : int

Returns the index at which the iterator currently is.

参数

此函数没有参数。

返回值

The index corresponding to the position of the iterator.

范例

Example #1 SplObjectStorage::key() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)

    var_dump($index);
    var_dump($object);
    $s->next();
}
?>

以上例程的输出类似于：

int(0)
object(stdClass)#2 (0) {
}
int(1)
object(stdClass)#3 (0) {
}

参见

  • SplObjectStorage::rewind() - Rewind the iterator to the first storage element
  • SplObjectStorage::current() - Returns the current storage entry
  • SplObjectStorage::next() - Move to the next entry
  • SplObjectStorage::valid() - Returns if the current iterator entry is valid


Move to the next entry

  • ? SplObjectStorage::key
  • SplObjectStorage::offsetExists ?
  • PHP Manual
  • SplObjectStorage
  • Move to the next entry

SplObjectStorage::next

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::next — Move to the next entry

说明

public SplObjectStorage::next ( ) : void

Moves the iterator to the next object in the storage.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 SplObjectStorage::next() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)

    var_dump($index);
    var_dump($object);
    $s->next();
}
?>

以上例程的输出类似于：

int(0)
object(stdClass)#2 (0) {
}
int(1)
object(stdClass)#3 (0) {
}

参见

  • SPLObjectStorage::rewind() - Rewind the iterator to the first storage element


Checks whether an object exists in the storage

  • ? SplObjectStorage::next
  • SplObjectStorage::offsetGet ?
  • PHP Manual
  • SplObjectStorage
  • Checks whether an object exists in the storage

SplObjectStorage::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetExists — Checks whether an object exists in the storage

说明

public SplObjectStorage::offsetExists ( object $object ) : bool

Checks whether an object exists in the storage.

Note:

SplObjectStorage::offsetExists() is an alias of SplObjectStorage::contains().

参数

object

The object to look for.

返回值

Returns true if the object exists in the storage, and false otherwise.

范例

Example #1 SplObjectStorage::offsetExists() example

<?php
$s = new SplObjectStorage;
$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1);

var_dump($s->offsetExists($o1)); // Similar to isset($s[$o1])
var_dump($s->offsetExists($o2)); // Similar to isset($s[$o2])
?>

以上例程的输出类似于：

bool(true)
bool(false)

参见

  • SplObjectStorage::offsetSet() - Associates data to an object in the storage
  • SplObjectStorage::offsetGet() - Returns the data associated with an object
  • SplObjectStorage::offsetUnset() - Removes an object from the storage


Returns the data associated with an object

  • ? SplObjectStorage::offsetExists
  • SplObjectStorage::offsetSet ?
  • PHP Manual
  • SplObjectStorage
  • Returns the data associated with an object

SplObjectStorage::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetGet — Returns the data associated with an object

说明

public SplObjectStorage::offsetGet ( object $object ) : mixed

Returns the data associated with an object in the storage.

参数

object

The object to look for.

返回值

The data previously associated with the object in the storage.

错误／异常

Throws UnexpectedValueException when object could not be found.

范例

Example #1 SplObjectStorage::offsetGet() example

<?php
$s = new SplObjectStorage;

$o1 = new StdClass;
$o2 = new StdClass;

$s[$o1] = "hello";
$s->attach($o2);

var_dump($s->offsetGet($o1)); // Similar to $s[$o1]
var_dump($s->offsetGet($o2)); // Similar to $s[$o2]
?>

以上例程的输出类似于：

string(5) "hello"
NULL

参见

  • SplObjectStorage::offsetSet() - Associates data to an object in the storage
  • SplObjectStorage::offsetExists() - Checks whether an object exists in the storage
  • SplObjectStorage::offsetUnset() - Removes an object from the storage


Associates data to an object in the storage

  • ? SplObjectStorage::offsetGet
  • SplObjectStorage::offsetUnset ?
  • PHP Manual
  • SplObjectStorage
  • Associates data to an object in the storage

SplObjectStorage::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetSet — Associates data to an object in the storage

说明

public SplObjectStorage::offsetSet ( object $object , mixed $data = null ) : void

Associate data to an object in the storage.

Note:

SplObjectStorage::offsetSet() is an alias of SplObjectStorage::attach().

参数

object

The object to associate data with.

data

The data to associate with the object.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::offsetSet() example

<?php
$s = new SplObjectStorage;

$o1 = new StdClass;

$s->offsetSet($o1, "hello"); // Similar to $s[$o1] = "hello";

var_dump($s[$o1]);
?>

以上例程的输出类似于：

string(5) "hello"

参见

  • SplObjectStorage::attach() - Adds an object in the storage
  • SplObjectStorage::offsetGet() - Returns the data associated with an object
  • SplObjectStorage::offsetExists() - Checks whether an object exists in the storage
  • SplObjectStorage::offsetUnset() - Removes an object from the storage


Removes an object from the storage

  • ? SplObjectStorage::offsetSet
  • SplObjectStorage::removeAll ?
  • PHP Manual
  • SplObjectStorage
  • Removes an object from the storage

SplObjectStorage::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetUnset — Removes an object from the storage

说明

public SplObjectStorage::offsetUnset ( object $object ) : void

Removes an object from the storage.

Note:

SplObjectStorage::offsetUnset() is an alias of SplObjectStorage::detach().

参数

object

The object to remove.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::offsetUnset() example

<?php
$o = new StdClass;
$s = new SplObjectStorage();
$s->attach($o);
var_dump(count($s));
$s->offsetUnset($o); // Similar to unset($s[$o])
var_dump(count($s));
?>

以上例程的输出类似于：

int(1)
int(0)

参见

  • SplObjectStorage::offsetGet() - Returns the data associated with an object
  • SplObjectStorage::offsetSet() - Associates data to an object in the storage
  • SplObjectStorage::offsetExists() - Checks whether an object exists in the storage


Removes objects contained in another storage from the current storage

  • ? SplObjectStorage::offsetUnset
  • SplObjectStorage::removeAllExcept ?
  • PHP Manual
  • SplObjectStorage
  • Removes objects contained in another storage from the current storage

SplObjectStorage::removeAll

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::removeAll — Removes objects contained in another storage from the current storage

说明

public SplObjectStorage::removeAll ( SplObjectStorage $storage ) : void

Removes objects contained in another storage from the current storage.

参数

storage

The storage containing the elements to remove.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::removeAll() example

<?php
$o1 = new StdClass;
$o2 = new StdClass;
$a = new SplObjectStorage();
$a[$o1] = "foo";

$b = new SplObjectStorage();
$b[$o1] = "bar";
$b[$o2] = "gee";

var_dump(count($b));
$b->removeAll($a);
var_dump(count($b));
?>

以上例程的输出类似于：

int(2)
int(1)

参见

  • SplObjectStorage::addAll() - Adds all objects from another storage


Removes all objects except for those contained in another storage from the current storage

  • ? SplObjectStorage::removeAll
  • SplObjectStorage::rewind ?
  • PHP Manual
  • SplObjectStorage
  • Removes all objects except for those contained in another storage from the current storage

SplObjectStorage::removeAllExcept

(PHP 5 >= 5.3.6, PHP 7)

SplObjectStorage::removeAllExcept — Removes all objects except for those contained in another storage from the current storage

说明

public SplObjectStorage::removeAllExcept ( SplObjectStorage $storage ) : void

Removes all objects except for those contained in another storage from the current storage.

参数

storage

The storage containing the elements to retain in the current storage.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::removeAllExcept() example

<?php
$a = (object) 'a';
$b = (object) 'b';
$c = (object) 'c';

$foo = new SplObjectStorage;
$foo->attach($a);
$foo->attach($b);

$bar = new SplObjectStorage;
$bar->attach($b);
$bar->attach($c);

$foo->removeAllExcept($bar);
var_dump($foo->contains($a));
var_dump($foo->contains($b));
?>

以上例程的输出类似于：

bool(false)
bool(true)


Rewind the iterator to the first storage element

  • ? SplObjectStorage::removeAllExcept
  • SplObjectStorage::serialize ?
  • PHP Manual
  • SplObjectStorage
  • Rewind the iterator to the first storage element

SplObjectStorage::rewind

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::rewind — Rewind the iterator to the first storage element

说明

public SplObjectStorage::rewind ( ) : void

Rewind the iterator to the first storage element.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 SplObjectStorage::rewind() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

以上例程的输出类似于：

int(1)
int(0)

参见

  • SplObjectStorage::next() - Move to the next entry


Serializes the storage

  • ? SplObjectStorage::rewind
  • SplObjectStorage::setInfo ?
  • PHP Manual
  • SplObjectStorage
  • Serializes the storage

SplObjectStorage::serialize

(PHP 5 >= 5.2.2, PHP 7)

SplObjectStorage::serialize — Serializes the storage

说明

public SplObjectStorage::serialize ( ) : string

Returns a string representation of the storage.

参数

此函数没有参数。

返回值

A string representing the storage.

范例

Example #1 SplObjectStorage::serialize() example

<?php
$s = new SplObjectStorage;
$o = new StdClass;
$s[$o] = "data";

echo $s->serialize()."\n";
?>

以上例程的输出类似于：

x:i:1;O:8:"stdClass":0:{},s:4:"data";;m:a:0:{}

参见

  • SplObjectStorage::unserialize() - Unserializes a storage from its string representation


Sets the data associated with the current iterator entry

  • ? SplObjectStorage::serialize
  • SplObjectStorage::unserialize ?
  • PHP Manual
  • SplObjectStorage
  • Sets the data associated with the current iterator entry

SplObjectStorage::setInfo

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::setInfo — Sets the data associated with the current iterator entry

说明

public SplObjectStorage::setInfo ( mixed $data ) : void

Associates data, or info, with the object currently pointed to by the iterator.

参数

data

The data to associate with the current iterator entry.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::setInfo() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $s->setInfo("new");
    $s->next();
}
var_dump($s[$o1]);
var_dump($s[$o2]);
?>

以上例程的输出类似于：

string(3) "new"
string(3) "new"

参见

  • SplObjectStorage::current() - Returns the current storage entry
  • SplObjectStorage::rewind() - Rewind the iterator to the first storage element
  • SplObjectStorage::key() - Returns the index at which the iterator currently is
  • SplObjectStorage::next() - Move to the next entry
  • SplObjectStorage::valid() - Returns if the current iterator entry is valid
  • SplObjectStorage::getInfo() - Returns the data associated with the current iterator entry


Unserializes a storage from its string representation

  • ? SplObjectStorage::setInfo
  • SplObjectStorage::valid ?
  • PHP Manual
  • SplObjectStorage
  • Unserializes a storage from its string representation

SplObjectStorage::unserialize

(PHP 5 >= 5.2.2, PHP 7)

SplObjectStorage::unserialize — Unserializes a storage from its string representation

说明

public SplObjectStorage::unserialize ( string $serialized ) : void

Unserializes storage entries and attach them to the current storage.

参数

serialized

The serialized representation of a storage.

返回值

没有返回值。

范例

Example #1 SplObjectStorage::unserialize() example

<?php
$s1 = new SplObjectStorage;
$s2 = new SplObjectStorage;
$o = new StdClass;
$s1[$o] = "data";

$s2->unserialize($s1->serialize());

var_dump(count($s2));
?>

以上例程的输出类似于：

int(1)

参见

  • SplObjectStorage::serialize() - Serializes the storage


Returns if the current iterator entry is valid

  • ? SplObjectStorage::unserialize
  • 迭代器 ?
  • PHP Manual
  • SplObjectStorage
  • Returns if the current iterator entry is valid

SplObjectStorage::valid

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::valid — Returns if the current iterator entry is valid

说明

public SplObjectStorage::valid ( ) : bool

Returns if the current iterator entry is valid.

参数

此函数没有参数。

返回值

Returns true if the iterator entry is valid, false otherwise.

范例

Example #1 SplObjectStorage::valid() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    echo $s->key()."\n";
    $s->next();
}
?>

以上例程的输出类似于：

0
1

参见

  • SplObjectStorage::current() - Returns the current storage entry
  • SplObjectStorage::getInfo() - Returns the data associated with the current iterator entry


迭代器

Table of Contents

  • AppendIterator
  • ArrayIterator
  • CachingIterator
  • CallbackFilterIterator
  • DirectoryIterator
  • EmptyIterator
  • FilesystemIterator
  • FilterIterator
  • GlobIterator
  • InfiniteIterator
  • IteratorIterator
  • LimitIterator
  • MultipleIterator
  • NoRewindIterator
  • ParentIterator
  • RecursiveArrayIterator
  • RecursiveCachingIterator
  • RecursiveCallbackFilterIterator
  • RecursiveDirectoryIterator
  • RecursiveFilterIterator
  • RecursiveIteratorIterator
  • RecursiveRegexIterator
  • RecursiveTreeIterator
  • RegexIterator

SPL 提供一系列迭代器以遍历不同的对象。

SPL Iterators Class Tree

  • ArrayIterator
    • RecursiveArrayIterator
  • EmptyIterator
  • IteratorIterator
    • AppendIterator
    • CachingIterator
      • RecursiveCachingIterator
    • FilterIterator
      • CallbackFilterIterator
        • RecursiveCallbackFilterIterator
      • RecursiveFilterIterator
        • ParentIterator
      • RegexIterator
        • RecursiveRegexIterator
    • InfiniteIterator
    • LimitIterator
    • NoRewindIterator
  • MultipleIterator
  • RecursiveIteratorIterator
    • RecursiveTreeIterator
  • DirectoryIterator (extends SplFileInfo)
    • FilesystemIterator
      • GlobIterator
      • RecursiveDirectoryIterator


The AppendIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

这个迭代器能陆续遍历几个迭代器

类摘要

AppendIterator extends IteratorIterator implements OuterIterator {
/* 方法 */
public __construct ( )
public append ( Iterator $iterator ) : void
public current ( ) : mixed
public getArrayIterator ( ) : ArrayIterator
public getInnerIterator ( ) : Iterator
public getIteratorIndex ( ) : int
public key ( ) : scalar
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
/* 继承的方法 */
public IteratorIterator::__construct ( Traversable $iterator )
public IteratorIterator::current ( ) : mixed
public IteratorIterator::getInnerIterator ( ) : Traversable
public IteratorIterator::key ( ) : mixed
public IteratorIterator::next ( ) : void
public IteratorIterator::rewind ( ) : void
public IteratorIterator::valid ( ) : bool
}

Table of Contents

  • AppendIterator::append — Appends an iterator
  • AppendIterator::__construct — Constructs an AppendIterator
  • AppendIterator::current — Gets the current value
  • AppendIterator::getArrayIterator — Gets the ArrayIterator
  • AppendIterator::getInnerIterator — Gets the inner iterator
  • AppendIterator::getIteratorIndex — Gets an index of iterators
  • AppendIterator::key — Gets the current key
  • AppendIterator::next — Moves to the next element
  • AppendIterator::rewind — Rewinds the Iterator
  • AppendIterator::valid — Checks validity of the current element


Appends an iterator

  • ? AppendIterator
  • AppendIterator::__construct ?
  • PHP Manual
  • AppendIterator
  • Appends an iterator

AppendIterator::append

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::append — Appends an iterator

说明

public AppendIterator::append ( Iterator $iterator ) : void

Appends an iterator.

参数

iterator

The iterator to append.

返回值

没有返回值。

范例

Example #1 AppendIterator::append() example

<?php
$array_a = new ArrayIterator(array('a', 'b', 'c'));
$array_b = new ArrayIterator(array('d', 'e', 'f'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $current) {
    echo $current;
}
?>

以上例程会输出：

abcdef

参见

  • AppendIterator::__construct() - Constructs an AppendIterator


Constructs an AppendIterator

  • ? AppendIterator::append
  • AppendIterator::current ?
  • PHP Manual
  • AppendIterator
  • Constructs an AppendIterator

AppendIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::__construct — Constructs an AppendIterator

说明

public AppendIterator::__construct ( )

Constructs an AppendIterator.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Iterating AppendIterator with foreach

<?php
$pizzas   = new ArrayIterator(array('Margarita', 'Siciliana', 'Hawaii'));
$toppings = new ArrayIterator(array('Cheese', 'Anchovies', 'Olives', 'Pineapple', 'Ham'));

$appendIterator = new AppendIterator;
$appendIterator->append($pizzas);
$appendIterator->append($toppings);

foreach ($appendIterator as $key => $item) {
    echo $key . ' => ' . $item . PHP_EOL;
}
?>

以上例程会输出：

0 => Margarita
1 => Siciliana
2 => Hawaii
0 => Cheese
1 => Anchovies
2 => Olives
3 => Pineapple
4 => Ham

Example #2 Iterating AppendIterator with the AppendIterator API

<?php
$pizzas   = new ArrayIterator(array('Margarita', 'Siciliana', 'Hawaii'));
$toppings = new ArrayIterator(array('Cheese', 'Anchovies', 'Olives', 'Pineapple', 'Ham'));

$appendIterator = new AppendIterator;
$appendIterator->append($pizzas);
$appendIterator->append($toppings);

while ($appendIterator->valid()) {
    printf(
        '%s => %s => %s%s',
        $appendIterator->getIteratorIndex(),
        $appendIterator->key(),
        $appendIterator->current(),
        PHP_EOL
    );
    $appendIterator->next();
}
?>

以上例程会输出：

0 => 0 => Margarita
0 => 1 => Siciliana
0 => 2 => Hawaii
1 => 0 => Cheese
1 => 1 => Anchovies
1 => 2 => Olives
1 => 3 => Pineapple
1 => 4 => Ham

注释

Caution

When using iterator_to_array() to copy the values of the AppendIterator into an array, you have to set the optional use_key argument to false. When use_key is not false any keys reoccuring in inner iterators will get overwritten in the returned array. There is no way to preserve the original keys.

参见

  • AppendIterator::append() - Appends an iterator


Gets the current value

  • ? AppendIterator::__construct
  • AppendIterator::getArrayIterator ?
  • PHP Manual
  • AppendIterator
  • Gets the current value

AppendIterator::current

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::current — Gets the current value

说明

public AppendIterator::current ( ) : mixed

Gets the current value.

参数

此函数没有参数。

返回值

The current value if it is valid or null otherwise.

参见

  • Iterator::current() - 返回当前元素
  • AppendIterator::key() - Gets the current key
  • AppendIterator::valid() - Checks validity of the current element
  • AppendIterator::next() - Moves to the next element
  • AppendIterator::rewind() - Rewinds the Iterator


Gets the ArrayIterator

  • ? AppendIterator::current
  • AppendIterator::getInnerIterator ?
  • PHP Manual
  • AppendIterator
  • Gets the ArrayIterator

AppendIterator::getArrayIterator

(PHP 5 >= 5.2.0, PHP 7)

AppendIterator::getArrayIterator — Gets the ArrayIterator

说明

public AppendIterator::getArrayIterator ( ) : ArrayIterator

This method gets the ArrayIterator that is used to store the iterators added with AppendIterator::append().

参数

此函数没有参数。

返回值

Returns an ArrayIterator containing the appended iterators.

参见

  • AppendIterator::getInnerIterator() - Gets the inner iterator


Gets the inner iterator

  • ? AppendIterator::getArrayIterator
  • AppendIterator::getIteratorIndex ?
  • PHP Manual
  • AppendIterator
  • Gets the inner iterator

AppendIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::getInnerIterator — Gets the inner iterator

说明

public AppendIterator::getInnerIterator ( ) : Iterator

This method returns the current inner iterator.

参数

此函数没有参数。

返回值

The current inner iterator, or null if there is not one.

范例

Example #1 AppendIterator::getInnerIterator() example

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new RegexIterator($array_a, '/^[ac]/');

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $current) {
    $inner = $iterator->getInnerIterator();
    if ($inner instanceOf RegexIterator) {
        echo 'Filtered: ';
    } else {
        echo 'Original: ';
    }
    echo $current . PHP_EOL;
}
?>

以上例程会输出：

Original: aardwolf
Original: bear
Original: capybara
Filtered: aardwolf
Filtered: capybara

参见

  • AppendIterator::getIteratorIndex() - Gets an index of iterators


Gets an index of iterators

  • ? AppendIterator::getInnerIterator
  • AppendIterator::key ?
  • PHP Manual
  • AppendIterator
  • Gets an index of iterators

AppendIterator::getIteratorIndex

(PHP 5 >= 5.2.0, PHP 7)

AppendIterator::getIteratorIndex — Gets an index of iterators

说明

public AppendIterator::getIteratorIndex ( ) : int

Gets the index of the current inner iterator.

参数

此函数没有参数。

返回值

Returns an int, which is the zero-based index of the current inner iterator.

范例

Example #1 AppendIterator.getIteratorIndex() basic example

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new ArrayIterator(array('apple', 'orange', 'lemon'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $key => $current) {
    echo $iterator->getIteratorIndex() . '  ' . $key . ' ' . $current . PHP_EOL;
}
?>

以上例程会输出：

0  a aardwolf
0  b bear
0  c capybara
1  0 apple
1  1 orange
1  2 lemon

参见

  • AppendIterator::getInnerIterator() - Gets the inner iterator
  • AppendIterator::getArrayIterator() - Gets the ArrayIterator


Gets the current key

  • ? AppendIterator::getIteratorIndex
  • AppendIterator::next ?
  • PHP Manual
  • AppendIterator
  • Gets the current key

AppendIterator::key

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::key — Gets the current key

说明

public AppendIterator::key ( ) : scalar

Get the current key.

参数

此函数没有参数。

返回值

The current key if it is valid or null otherwise.

范例

Example #1 AppendIterator::key() basic example

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new ArrayIterator(array('apple', 'orange', 'lemon'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

// Manual iteration
$iterator->rewind();
while ($iterator->valid()) {
    echo $iterator->key() . ' ' . $iterator->current() . PHP_EOL;
    $iterator->next();
}

echo PHP_EOL;

// With foreach
foreach ($iterator as $key => $current) {
    echo $key . ' ' . $current . PHP_EOL;
}
?>

以上例程会输出：

a aardwolf
b bear
c capybara
0 apple
1 orange
2 lemon

a aardwolf
b bear
c capybara
0 apple
1 orange
2 lemon

参见

  • Iterator::key() - 返回当前元素的键
  • AppendIterator::current() - Gets the current value
  • AppendIterator::valid() - Checks validity of the current element
  • AppendIterator::next() - Moves to the next element
  • AppendIterator::rewind() - Rewinds the Iterator


Moves to the next element

  • ? AppendIterator::key
  • AppendIterator::rewind ?
  • PHP Manual
  • AppendIterator
  • Moves to the next element

AppendIterator::next

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::next — Moves to the next element

说明

public AppendIterator::next ( ) : void

Moves to the next element. If this means to another Iterator then it rewinds that Iterator.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • Iterator::next() - 向前移动到下一个元素
  • AppendIterator::current() - Gets the current value
  • AppendIterator::key() - Gets the current key
  • AppendIterator::valid() - Checks validity of the current element
  • AppendIterator::rewind() - Rewinds the Iterator


Rewinds the Iterator

  • ? AppendIterator::next
  • AppendIterator::valid ?
  • PHP Manual
  • AppendIterator
  • Rewinds the Iterator

AppendIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::rewind — Rewinds the Iterator

说明

public AppendIterator::rewind ( ) : void

Rewind to the first element of the first inner Iterator.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • Iterator::rewind() - 返回到迭代器的第一个元素
  • AppendIterator::current() - Gets the current value
  • AppendIterator::key() - Gets the current key
  • AppendIterator::next() - Moves to the next element
  • AppendIterator::valid() - Checks validity of the current element


Checks validity of the current element

  • ? AppendIterator::rewind
  • ArrayIterator ?
  • PHP Manual
  • AppendIterator
  • Checks validity of the current element

AppendIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::valid — Checks validity of the current element

说明

public AppendIterator::valid ( ) : bool

Checks validity of the current element.

参数

此函数没有参数。

返回值

Returns true if the current iteration is valid, false otherwise.

参见

  • AppendIterator::current() - Gets the current value
  • AppendIterator::key() - Gets the current key
  • AppendIterator::next() - Moves to the next element
  • AppendIterator::rewind() - Rewinds the Iterator


ArrayIterator 类

(PHP 5, PHP 7)

简介

这个迭代器允许在遍历数组和对象时删除和更新值与键。

当你想多次遍历相同数组时你需要实例化 ArrayObject，然后让这个实例创建一个 ArrayIteratror 实例。 当你想遍历相同数组时多次你需要实例 ArrayObject 并且让这个实例创建一个 ArrayIteratror 实例，然后使用foreach 或者 手动调用 getIterator() 方法。

类摘要

ArrayIterator implements ArrayAccess , SeekableIterator , Countable , Serializable {
/* 常量 */
const integer STD_PROP_LIST = 1 ;
const integer ARRAY_AS_PROPS = 2 ;
/* 方法 */
public append ( mixed $value ) : void
public asort ( ) : void
public __construct ( mixed $array = array() , int $flags = 0 )
public count ( ) : int
public current ( ) : mixed
public getArrayCopy ( ) : array
public getFlags ( ) : int
public key ( ) : mixed
public ksort ( ) : void
public natcasesort ( ) : void
public natsort ( ) : void
public next ( ) : void
public offsetExists ( mixed $index ) : bool
public offsetGet ( mixed $index ) : mixed
public offsetSet ( mixed $index , mixed $newval ) : void
public offsetUnset ( mixed $index ) : void
public rewind ( ) : void
public seek ( int $position ) : void
public serialize ( ) : string
public setFlags ( string $flags ) : void
public uasort ( callable $cmp_function ) : void
public uksort ( callable $cmp_function ) : void
public unserialize ( string $serialized ) : void
public valid ( ) : bool
}

预定义常量

ArrayIterator 标记

ArrayIterator::STD_PROP_LIST

Properties of the object have their normal functionality when accessed as list (var_dump, foreach, etc.).

ArrayIterator::ARRAY_AS_PROPS

可以通过属性访问条目（读写都支持）。

Table of Contents

  • ArrayIterator::append — Append an element
  • ArrayIterator::asort — Sort array by values
  • ArrayIterator::__construct — Construct an ArrayIterator
  • ArrayIterator::count — Count elements
  • ArrayIterator::current — Return current array entry
  • ArrayIterator::getArrayCopy — Get array copy
  • ArrayIterator::getFlags — Get behavior flags
  • ArrayIterator::key — Return current array key
  • ArrayIterator::ksort — Sort array by keys
  • ArrayIterator::natcasesort — Sort an array naturally, case insensitive
  • ArrayIterator::natsort — Sort an array naturally
  • ArrayIterator::next — Move to next entry
  • ArrayIterator::offsetExists — Check if offset exists
  • ArrayIterator::offsetGet — Get value for an offset
  • ArrayIterator::offsetSet — Set value for an offset
  • ArrayIterator::offsetUnset — Unset value for an offset
  • ArrayIterator::rewind — Rewind array back to the start
  • ArrayIterator::seek — Seek to position
  • ArrayIterator::serialize — Serialize
  • ArrayIterator::setFlags — Set behaviour flags
  • ArrayIterator::uasort — Sort with a user-defined comparison function and maintain index association
  • ArrayIterator::uksort — Sort by keys using a user-defined comparison function
  • ArrayIterator::unserialize — Unserialize
  • ArrayIterator::valid — Check whether array contains more entries


Append an element

  • ? ArrayIterator
  • ArrayIterator::asort ?
  • PHP Manual
  • ArrayIterator
  • Append an element

ArrayIterator::append

(PHP 5, PHP 7)

ArrayIterator::append — Append an element

说明

public ArrayIterator::append ( mixed $value ) : void

Appends value as the last element.

Warning

本函数还未编写文档，仅有参数列表。

参数

value

The value to append.

返回值

没有返回值。

注释

Note:

This method cannot be called when the ArrayIterator refers to an object.

参见

  • ArrayIterator::next() - Move to next entry


Sort array by values

  • ? ArrayIterator::append
  • ArrayIterator::__construct ?
  • PHP Manual
  • ArrayIterator
  • Sort array by values

ArrayIterator::asort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::asort — Sort array by values

说明

public ArrayIterator::asort ( ) : void

Sorts an array by values.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • ArrayIterator::ksort() - Sort array by keys
  • ArrayIterator::natcasesort() - Sort an array naturally, case insensitive
  • ArrayIterator::natsort() - Sort an array naturally


Construct an ArrayIterator

  • ? ArrayIterator::asort
  • ArrayIterator::count ?
  • PHP Manual
  • ArrayIterator
  • Construct an ArrayIterator

ArrayIterator::__construct

(PHP 5, PHP 7)

ArrayIterator::__construct — Construct an ArrayIterator

说明

public ArrayIterator::__construct ( mixed $array = array() , int $flags = 0 )

Constructs an ArrayIterator object.

Warning

本函数还未编写文档，仅有参数列表。

参数

array

The array or object to be iterated on.

flags

Flags to control the behaviour of the ArrayIterator object. See ArrayIterator::setFlags().

返回值

An ArrayIterator object.

错误／异常

ArrayIterator::__construct() throws an InvalidArgumentException if anything besides an array or an object is given.

参见

  • ArrayIterator::getArrayCopy() - Get array copy


Count elements

  • ? ArrayIterator::__construct
  • ArrayIterator::current ?
  • PHP Manual
  • ArrayIterator
  • Count elements

ArrayIterator::count

(PHP 5, PHP 7)

ArrayIterator::count — Count elements

说明

public ArrayIterator::count ( ) : int

Gets the number of elements in the array, or the number of public properties in the object.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The number of elements or public properties in the associated array or object, respectively.

参见

  • ArrayIterator::getFlags() - Get behavior flags


Return current array entry

  • ? ArrayIterator::count
  • ArrayIterator::getArrayCopy ?
  • PHP Manual
  • ArrayIterator
  • Return current array entry

ArrayIterator::current

(PHP 5, PHP 7)

ArrayIterator::current — Return current array entry

说明

public ArrayIterator::current ( ) : mixed

Get the current array entry.

参数

此函数没有参数。

返回值

The current array entry.

范例

Example #1 ArrayIterator::current() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

for($iterator = $arrayobject->getIterator();
    $iterator->valid();
    $iterator->next()) {

    echo $iterator->key() . ' => ' . $iterator->current() . "\n";
}
?>

以上例程会输出：

1 => one
2 => two
3 => three


Get array copy

  • ? ArrayIterator::current
  • ArrayIterator::getFlags ?
  • PHP Manual
  • ArrayIterator
  • Get array copy

ArrayIterator::getArrayCopy

(PHP 5, PHP 7)

ArrayIterator::getArrayCopy — Get array copy

说明

public ArrayIterator::getArrayCopy ( ) : array

Get a copy of an array.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A copy of the array, or array of public properties if ArrayIterator refers to an object.

参见

  • ArrayIterator::valid() - Check whether array contains more entries


Get behavior flags

  • ? ArrayIterator::getArrayCopy
  • ArrayIterator::key ?
  • PHP Manual
  • ArrayIterator
  • Get behavior flags

ArrayIterator::getFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayIterator::getFlags — Get behavior flags

说明

public ArrayIterator::getFlags ( ) : int

Gets the behavior flags of the ArrayIterator. See the ArrayIterator::setFlags method for a list of the available flags.

参数

此函数没有参数。

返回值

Returns the behavior flags of the ArrayIterator.

参见

  • >ArrayIterator::setFlags()
  • ArrayIterator::valid() - Check whether array contains more entries


Return current array key

  • ? ArrayIterator::getFlags
  • ArrayIterator::ksort ?
  • PHP Manual
  • ArrayIterator
  • Return current array key

ArrayIterator::key

(PHP 5, PHP 7)

ArrayIterator::key — Return current array key

说明

public ArrayIterator::key ( ) : mixed

This function returns the current array key

参数

此函数没有参数。

返回值

The current array key.

范例

Example #1 ArrayIterator::key() example

<?php
$array = array('key' => 'value');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

echo $iterator->key(); //key
?>


Sort array by keys

  • ? ArrayIterator::key
  • ArrayIterator::natcasesort ?
  • PHP Manual
  • ArrayIterator
  • Sort array by keys

ArrayIterator::ksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::ksort — Sort array by keys

说明

public ArrayIterator::ksort ( ) : void

Sorts an array by the keys.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • ArrayIterator::asort() - Sort array by values
  • ArrayIterator::natcasesort() - Sort an array naturally, case insensitive
  • ArrayIterator::natsort() - Sort an array naturally


Sort an array naturally, case insensitive

  • ? ArrayIterator::ksort
  • ArrayIterator::natsort ?
  • PHP Manual
  • ArrayIterator
  • Sort an array naturally, case insensitive

ArrayIterator::natcasesort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::natcasesort — Sort an array naturally, case insensitive

说明

public ArrayIterator::natcasesort ( ) : void

Sort the entries by values using a case insensitive "natural order" algorithm.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • ArrayIterator::asort() - Sort array by values
  • ArrayIterator::ksort() - Sort array by keys
  • ArrayIterator::natsort() - Sort an array naturally
  • natcasesort() - 用“自然排序”算法对数组进行不区分大小写字母的排序


Sort an array naturally

  • ? ArrayIterator::natcasesort
  • ArrayIterator::next ?
  • PHP Manual
  • ArrayIterator
  • Sort an array naturally

ArrayIterator::natsort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::natsort — Sort an array naturally

说明

public ArrayIterator::natsort ( ) : void

Sort the entries by values using "natural order" algorithm.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • ArrayIterator::asort() - Sort array by values
  • ArrayIterator::ksort() - Sort array by keys
  • ArrayIterator::natcasesort() - Sort an array naturally, case insensitive
  • natsort() - 用“自然排序”算法对数组排序


Move to next entry

  • ? ArrayIterator::natsort
  • ArrayIterator::offsetExists ?
  • PHP Manual
  • ArrayIterator
  • Move to next entry

ArrayIterator::next

(PHP 5, PHP 7)

ArrayIterator::next — Move to next entry

说明

public ArrayIterator::next ( ) : void

The iterator to the next entry.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 ArrayIterator::next() example

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

以上例程会输出：

0 => zero
1 => one


Check if offset exists

  • ? ArrayIterator::next
  • ArrayIterator::offsetGet ?
  • PHP Manual
  • ArrayIterator
  • Check if offset exists

ArrayIterator::offsetExists

(PHP 5, PHP 7)

ArrayIterator::offsetExists — Check if offset exists

说明

public ArrayIterator::offsetExists ( mixed $index ) : bool

Checks if the offset exists.

Warning

本函数还未编写文档，仅有参数列表。

参数

index

The offset being checked.

返回值

true if the offset exists, otherwise false

参见

  • ArrayIterator::valid() - Check whether array contains more entries


Get value for an offset

  • ? ArrayIterator::offsetExists
  • ArrayIterator::offsetSet ?
  • PHP Manual
  • ArrayIterator
  • Get value for an offset

ArrayIterator::offsetGet

(PHP 5, PHP 7)

ArrayIterator::offsetGet — Get value for an offset

说明

public ArrayIterator::offsetGet ( mixed $index ) : mixed

Gets the value from the provided offset.

Warning

本函数还未编写文档，仅有参数列表。

参数

index

The offset to get the value from.

返回值

The value at offset index.

参见

  • ArrayIterator::offsetSet() - Set value for an offset
  • ArrayIterator::offsetUnset() - Unset value for an offset


Set value for an offset

  • ? ArrayIterator::offsetGet
  • ArrayIterator::offsetUnset ?
  • PHP Manual
  • ArrayIterator
  • Set value for an offset

ArrayIterator::offsetSet

(PHP 5, PHP 7)

ArrayIterator::offsetSet — Set value for an offset

说明

public ArrayIterator::offsetSet ( mixed $index , mixed $newval ) : void

Sets a value for a given offset.

Warning

本函数还未编写文档，仅有参数列表。

参数

index

The index to set for.

newval

The new value to store at the index.

返回值

没有返回值。

参见

  • ArrayIterator::offsetGet() - Get value for an offset
  • ArrayIterator::offsetUnset() - Unset value for an offset


Unset value for an offset

  • ? ArrayIterator::offsetSet
  • ArrayIterator::rewind ?
  • PHP Manual
  • ArrayIterator
  • Unset value for an offset

ArrayIterator::offsetUnset

(PHP 5, PHP 7)

ArrayIterator::offsetUnset — Unset value for an offset

说明

public ArrayIterator::offsetUnset ( mixed $index ) : void

Unsets a value for an offset.

If iteration is in progress, and ArrayIterator::offsetUnset() is used to unset the current index of iteration, the iteration position will be advanced to the next index. Since the iteration position is also advanced at the end of a foreach loop body, use of ArrayIterator::offsetUnset() inside a foreach loop may result in indices being skipped.

参数

index

The offset to unset.

返回值

没有返回值。

参见

  • ArrayIterator::offsetGet() - Get value for an offset
  • ArrayIterator::offsetSet() - Set value for an offset


Rewind array back to the start

  • ? ArrayIterator::offsetUnset
  • ArrayIterator::seek ?
  • PHP Manual
  • ArrayIterator
  • Rewind array back to the start

ArrayIterator::rewind

(PHP 5, PHP 7)

ArrayIterator::rewind — Rewind array back to the start

说明

public ArrayIterator::rewind ( ) : void

This rewinds the iterator to the beginning.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 ArrayIterator::rewind() example

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';
$arrayobject[] = 'two';

$iterator = $arrayobject->getIterator();

$iterator->next();
echo $iterator->key(); //1

$iterator->rewind(); //rewinding to the beginning
echo $iterator->key(); //0
?>


Seek to position

  • ? ArrayIterator::rewind
  • ArrayIterator::serialize ?
  • PHP Manual
  • ArrayIterator
  • Seek to position

ArrayIterator::seek

(PHP 5, PHP 7)

ArrayIterator::seek — Seek to position

说明

public ArrayIterator::seek ( int $position ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

position

The position to seek to.

返回值

没有返回值。


Serialize

  • ? ArrayIterator::seek
  • ArrayIterator::setFlags ?
  • PHP Manual
  • ArrayIterator
  • Serialize

ArrayIterator::serialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayIterator::serialize — Serialize

说明

public ArrayIterator::serialize ( ) : string

Serialize.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The serialized ArrayIterator.

参见

  • ArrayIterator::unserialize() - Unserialize


Set behaviour flags

  • ? ArrayIterator::serialize
  • ArrayIterator::uasort ?
  • PHP Manual
  • ArrayIterator
  • Set behaviour flags

ArrayIterator::setFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayIterator::setFlags — Set behaviour flags

说明

public ArrayIterator::setFlags ( string $flags ) : void

Set the flags that change the behavior of the ArrayIterator.

参数

flags

The new ArrayIterator behavior. It takes on either a bitmask, or named constants. Using named constants is strongly encouraged to ensure compatibility for future versions.

The available behavior flags are listed below. The actual meanings of these flags are described in the predefined constants.

ArrayIterator behavior flags
value | constant
1 | ArrayIterator::STD_PROP_LIST
2 | ArrayIterator::ARRAY_AS_PROPS

返回值

没有返回值。

参见

  • ArrayIterator::getFlags() - Get behavior flags


Sort with a user-defined comparison function and maintain index association

  • ? ArrayIterator::setFlags
  • ArrayIterator::uksort ?
  • PHP Manual
  • ArrayIterator
  • Sort with a user-defined comparison function and maintain index association

ArrayIterator::uasort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::uasort — Sort with a user-defined comparison function and maintain index association

说明

public ArrayIterator::uasort ( callable $cmp_function ) : void

This method sorts the elements such that indices maintain their correlation with the values they are associated with, using a user-defined comparison function.

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

cmp_function

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

没有返回值。

参见

  • ArrayIterator::asort() - Sort array by values
  • ArrayIterator::uksort() - Sort by keys using a user-defined comparison function
  • usort() - 使用用户自定义的比较函数对数组中的值进行排序


Sort by keys using a user-defined comparison function

  • ? ArrayIterator::uasort
  • ArrayIterator::unserialize ?
  • PHP Manual
  • ArrayIterator
  • Sort by keys using a user-defined comparison function

ArrayIterator::uksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::uksort — Sort by keys using a user-defined comparison function

说明

public ArrayIterator::uksort ( callable $cmp_function ) : void

This method sorts the elements by keys using a user-supplied comparison function.

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

cmp_function

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

没有返回值。

参见

  • ArrayIterator::ksort() - Sort array by keys
  • ArrayIterator::uasort() - Sort with a user-defined comparison function and maintain index association
  • uksort() - 使用用户自定义的比较函数对数组中的键名进行排序


Unserialize

  • ? ArrayIterator::uksort
  • ArrayIterator::valid ?
  • PHP Manual
  • ArrayIterator
  • Unserialize

ArrayIterator::unserialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayIterator::unserialize — Unserialize

说明

public ArrayIterator::unserialize ( string $serialized ) : void

Unserialize.

Warning

本函数还未编写文档，仅有参数列表。

参数

serialized

The serialized ArrayIterator object to be unserialized.

返回值

没有返回值。

参见

  • ArrayIterator::serialize() - Serialize


Check whether array contains more entries

  • ? ArrayIterator::unserialize
  • CachingIterator ?
  • PHP Manual
  • ArrayIterator
  • Check whether array contains more entries

ArrayIterator::valid

(PHP 5, PHP 7)

ArrayIterator::valid — Check whether array contains more entries

说明

public ArrayIterator::valid ( ) : bool

Checks if the array contains any more entries.

参数

此函数没有参数。

返回值

Returns true if the iterator is valid, otherwise false

范例

Example #1 ArrayIterator::valid() example

<?php
$array = array('1' => 'one');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

var_dump($iterator->valid()); //bool(true)

$iterator->next(); // advance to the next item

//bool(false) because there is only one array element
var_dump($iterator->valid());
?>


The CachingIterator class

(PHP 5, PHP 7)

简介

This object supports cached iteration over another iterator.

类摘要

CachingIterator extends IteratorIterator implements OuterIterator , ArrayAccess , Countable {
/* 常量 */
const int CALL_TOSTRING = 1 ;
const int CATCH_GET_CHILD = 16 ;
const int TOSTRING_USE_KEY = 2 ;
const int TOSTRING_USE_CURRENT = 4 ;
const int TOSTRING_USE_INNER = 8 ;
const int FULL_CACHE = 256 ;
/* 方法 */
public __construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )
public count ( ) : int
public current ( ) : mixed
public getCache ( ) : array
public getFlags ( ) : int
public getInnerIterator ( ) : Iterator
public hasNext ( ) : void
public key ( ) : scalar
public next ( ) : void
public offsetExists ( mixed $index ) : void
public offsetGet ( string $index ) : void
public offsetSet ( mixed $index , mixed $newval ) : void
public offsetUnset ( string $index ) : void
public rewind ( ) : void
public setFlags ( int $flags ) : void
public __toString ( ) : void
public valid ( ) : void
}

预定义常量

CachingIterator::CALL_TOSTRING

Convert every element to string.

CachingIterator::CATCH_GET_CHILD

Don't throw exception in accessing children.

CachingIterator::TOSTRING_USE_KEY

Use key for conversion to string.

CachingIterator::TOSTRING_USE_CURRENT

Use current for conversion to string.

CachingIterator::TOSTRING_USE_INNER

Use inner for conversion to string.

CachingIterator::FULL_CACHE

Cache all read data.

Table of Contents

  • CachingIterator::__construct — Construct a new CachingIterator object for the iterator
  • CachingIterator::count — The number of elements in the iterator
  • CachingIterator::current — Return the current element
  • CachingIterator::getCache — Retrieve the contents of the cache
  • CachingIterator::getFlags — Get flags used
  • CachingIterator::getInnerIterator — Returns the inner iterator
  • CachingIterator::hasNext — Check whether the inner iterator has a valid next element
  • CachingIterator::key — Return the key for the current element
  • CachingIterator::next — Move the iterator forward
  • CachingIterator::offsetExists — The offsetExists purpose
  • CachingIterator::offsetGet — The offsetGet purpose
  • CachingIterator::offsetSet — The offsetSet purpose
  • CachingIterator::offsetUnset — The offsetUnset purpose
  • CachingIterator::rewind — Rewind the iterator
  • CachingIterator::setFlags — The setFlags purpose
  • CachingIterator::__toString — Return the string representation of the current element
  • CachingIterator::valid — Check whether the current element is valid


Construct a new CachingIterator object for the iterator

  • ? CachingIterator
  • CachingIterator::count ?
  • PHP Manual
  • CachingIterator
  • Construct a new CachingIterator object for the iterator

CachingIterator::__construct

(PHP 5, PHP 7)

CachingIterator::__construct — Construct a new CachingIterator object for the iterator

说明

public CachingIterator::__construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )
Warning

本函数还未编写文档，仅有参数列表。

参数

iterator

Iterator to cache

flags

Bitmask of flags.


The number of elements in the iterator

  • ? CachingIterator::__construct
  • CachingIterator::current ?
  • PHP Manual
  • CachingIterator
  • The number of elements in the iterator

CachingIterator::count

(PHP 5 >= 5.2.2, PHP 7)

CachingIterator::count — The number of elements in the iterator

说明

public CachingIterator::count ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

May return the number of elements in the iterator.

参数

此函数没有参数。

返回值

The count of the elements iterated over.


Return the current element

  • ? CachingIterator::count
  • CachingIterator::getCache ?
  • PHP Manual
  • CachingIterator
  • Return the current element

CachingIterator::current

(PHP 5, PHP 7)

CachingIterator::current — Return the current element

说明

public CachingIterator::current ( ) : mixed
Warning

本函数还未编写文档，仅有参数列表。

May return the current element in the iteration.

参数

此函数没有参数。

返回值

Mixed

参见

  • Iterator::current() - 返回当前元素


Retrieve the contents of the cache

  • ? CachingIterator::current
  • CachingIterator::getFlags ?
  • PHP Manual
  • CachingIterator
  • Retrieve the contents of the cache

CachingIterator::getCache

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::getCache — Retrieve the contents of the cache

说明

public CachingIterator::getCache ( ) : array

Retrieve the contents of the cache.

Note:

The CachingIterator::FULL_CACHE flag must be being used.

参数

此函数没有参数。

返回值

An array containing the cache items.

错误／异常

Throws a BadMethodCallException when the CachingIterator::FULL_CACHE flag is not being used.

范例

Example #1 CachingIterator::getCache() example

<?php
$iterator = new ArrayIterator(array(1, 2, 3));
$cache    = new CachingIterator($iterator, CachingIterator::FULL_CACHE);

$cache->next();
$cache->next();
var_dump($cache->getCache());

$cache->next();
var_dump($cache->getCache());
?>

以上例程会输出：

array(2) {
  [0]=>
  int(1)
  [1]=>
  int(2)
}
array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Get flags used

  • ? CachingIterator::getCache
  • CachingIterator::getInnerIterator ?
  • PHP Manual
  • CachingIterator
  • Get flags used

CachingIterator::getFlags

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::getFlags — Get flags used

说明

public CachingIterator::getFlags ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

Get the bitmask of the flags used for this CachingIterator instance.

参数

此函数没有参数。

返回值

Description...


Returns the inner iterator

  • ? CachingIterator::getFlags
  • CachingIterator::hasNext ?
  • PHP Manual
  • CachingIterator
  • Returns the inner iterator

CachingIterator::getInnerIterator

(PHP 5, PHP 7)

CachingIterator::getInnerIterator — Returns the inner iterator

说明

public CachingIterator::getInnerIterator ( ) : Iterator
Warning

本函数还未编写文档，仅有参数列表。

Returns the iterator sent to the constructor.

参数

此函数没有参数。

返回值

Returns an object implementing the Iterator interface.


Check whether the inner iterator has a valid next element

  • ? CachingIterator::getInnerIterator
  • CachingIterator::key ?
  • PHP Manual
  • CachingIterator
  • Check whether the inner iterator has a valid next element

CachingIterator::hasNext

(PHP 5, PHP 7)

CachingIterator::hasNext — Check whether the inner iterator has a valid next element

说明

public CachingIterator::hasNext ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Return the key for the current element

  • ? CachingIterator::hasNext
  • CachingIterator::next ?
  • PHP Manual
  • CachingIterator
  • Return the key for the current element

CachingIterator::key

(PHP 5, PHP 7)

CachingIterator::key — Return the key for the current element

说明

public CachingIterator::key ( ) : scalar
Warning

本函数还未编写文档，仅有参数列表。

This method may return a key for the current element.

参数

此函数没有参数。


Move the iterator forward

  • ? CachingIterator::key
  • CachingIterator::offsetExists ?
  • PHP Manual
  • CachingIterator
  • Move the iterator forward

CachingIterator::next

(PHP 5, PHP 7)

CachingIterator::next — Move the iterator forward

说明

public CachingIterator::next ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

Move the iterator forward.

参数

此函数没有参数。

返回值

没有返回值。


The offsetExists purpose

  • ? CachingIterator::next
  • CachingIterator::offsetGet ?
  • PHP Manual
  • CachingIterator
  • The offsetExists purpose

CachingIterator::offsetExists

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetExists — The offsetExists purpose

说明

public CachingIterator::offsetExists ( mixed $index ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

index

The index being checked.

返回值

Returns true if an entry referenced by the offset exists, false otherwise.


The offsetGet purpose

  • ? CachingIterator::offsetExists
  • CachingIterator::offsetSet ?
  • PHP Manual
  • CachingIterator
  • The offsetGet purpose

CachingIterator::offsetGet

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetGet — The offsetGet purpose

说明

public CachingIterator::offsetGet ( string $index ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

index

Description...

返回值

Description...


The offsetSet purpose

  • ? CachingIterator::offsetGet
  • CachingIterator::offsetUnset ?
  • PHP Manual
  • CachingIterator
  • The offsetSet purpose

CachingIterator::offsetSet

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetSet — The offsetSet purpose

说明

public CachingIterator::offsetSet ( mixed $index , mixed $newval ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

index

The index of the element to be set.

newval

The new value for the index.

返回值

没有返回值。


The offsetUnset purpose

  • ? CachingIterator::offsetSet
  • CachingIterator::rewind ?
  • PHP Manual
  • CachingIterator
  • The offsetUnset purpose

CachingIterator::offsetUnset

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetUnset — The offsetUnset purpose

说明

public CachingIterator::offsetUnset ( string $index ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

index

The index of the element to be unset.

返回值

没有返回值。


Rewind the iterator

  • ? CachingIterator::offsetUnset
  • CachingIterator::setFlags ?
  • PHP Manual
  • CachingIterator
  • Rewind the iterator

CachingIterator::rewind

(PHP 5, PHP 7)

CachingIterator::rewind — Rewind the iterator

说明

public CachingIterator::rewind ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

Rewind the iterator.

参数

此函数没有参数。

返回值

没有返回值。


The setFlags purpose

  • ? CachingIterator::rewind
  • CachingIterator::__toString ?
  • PHP Manual
  • CachingIterator
  • The setFlags purpose

CachingIterator::setFlags

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::setFlags — The setFlags purpose

说明

public CachingIterator::setFlags ( int $flags ) : void
Warning

本函数还未编写文档，仅有参数列表。

Set the flags for the CachingIterator object.

参数

flags

Bitmask of the flags to set.

返回值

没有返回值。


Return the string representation of the current element

  • ? CachingIterator::setFlags
  • CachingIterator::valid ?
  • PHP Manual
  • CachingIterator
  • Return the string representation of the current element

CachingIterator::__toString

(PHP 5, PHP 7)

CachingIterator::__toString — Return the string representation of the current element

说明

public CachingIterator::__toString ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

Get the string representation of the current element.

参数

此函数没有参数。

返回值

The string representation of the current element.


Check whether the current element is valid

  • ? CachingIterator::__toString
  • CallbackFilterIterator ?
  • PHP Manual
  • CachingIterator
  • Check whether the current element is valid

CachingIterator::valid

(PHP 5, PHP 7)

CachingIterator::valid — Check whether the current element is valid

说明

public CachingIterator::valid ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

Check whether the current element is valid.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


The CallbackFilterIterator class

(PHP 5 >= 5.4.0, PHP 7)

简介

类摘要

CallbackFilterIterator extends FilterIterator implements OuterIterator {
/* 方法 */
public __construct ( Iterator $iterator , callable $callback )
public accept ( ) : bool
/* 继承的方法 */
public abstract FilterIterator::accept ( ) : bool
public FilterIterator::__construct ( Iterator $iterator )
public FilterIterator::current ( ) : mixed
public FilterIterator::getInnerIterator ( ) : Iterator
public FilterIterator::key ( ) : mixed
public FilterIterator::next ( ) : void
public FilterIterator::rewind ( ) : void
public FilterIterator::valid ( ) : bool
}

范例

The callback should accept up to three arguments: the current item, the current key and the iterator, respectively.

Example #1 Available callback arguments

<?php

/**
 * Callback for CallbackFilterIterator
 *
 * @param $current   Current item's value
 * @param $key       Current item's key
 * @param $iterator  Iterator being filtered
 * @return boolean   TRUE to accept the current item, FALSE otherwise
 */
function my_callback($current, $key, $iterator) {
    // Your filtering code here
}

?>

Any callable may be used; such as a string containing a function name, an array for a method, or an anonymous function.

Example #2 Callback basic examples

<?php

$dir = new FilesystemIterator(__DIR__);

// Filter large files ( > 100MB)
function is_large_file($current) {
    return $current->isFile() && $current->getSize() > 104857600;
}
$large_files = new CallbackFilterIterator($dir, 'is_large_file');

// Filter directories
$files = new CallbackFilterIterator($dir, function ($current, $key, $iterator) {
    return $current->isDir() && ! $iterator->isDot();
});

?>

Table of Contents

  • CallbackFilterIterator::accept — Calls the callback with the current value, the current key and the inner iterator as arguments
  • CallbackFilterIterator::__construct — Create a filtered iterator from another iterator


Calls the callback with the current value, the current key and the inner iterator as arguments

  • ? CallbackFilterIterator
  • CallbackFilterIterator::__construct ?
  • PHP Manual
  • CallbackFilterIterator
  • Calls the callback with the current value, the current key and the inner iterator as arguments

CallbackFilterIterator::accept

(PHP 5 >= 5.4.0, PHP 7)

CallbackFilterIterator::accept — Calls the callback with the current value, the current key and the inner iterator as arguments

说明

public CallbackFilterIterator::accept ( ) : bool

This method calls the callback with the current value, current key and the inner iterator.

The callback is expected to return true if the current item is to be accepted, or false otherwise.

参数

此函数没有参数。

返回值

Returns true to accept the current item, or false otherwise.

参见

  • CallbackFilterIterator Examples
  • CallbackFilterIterator::__construct() - Create a filtered iterator from another iterator


Create a filtered iterator from another iterator

  • ? CallbackFilterIterator::accept
  • DirectoryIterator ?
  • PHP Manual
  • CallbackFilterIterator
  • Create a filtered iterator from another iterator

CallbackFilterIterator::__construct

(PHP 5 >= 5.4.0, PHP 7)

CallbackFilterIterator::__construct — Create a filtered iterator from another iterator

说明

public CallbackFilterIterator::__construct ( Iterator $iterator , callable $callback )

Creates a filtered iterator using the callback to determine which items are accepted or rejected.

参数

iterator

The iterator to be filtered.

callback

The callback, which should return true to accept the current item or false otherwise. See Examples.

May be any valid callable value.

返回值

没有返回值。

参见

  • CallbackFilterIterator Examples
  • CallbackFilterIterator::accept() - Calls the callback with the current value, the current key and the inner iterator as arguments


The DirectoryIterator class

(PHP 5, PHP 7)

简介

The DirectoryIterator class provides a simple interface for viewing the contents of filesystem directories.

类摘要

DirectoryIterator extends SplFileInfo implements SeekableIterator {
/* 方法 */
public __construct ( string $path )
public current ( ) : DirectoryIterator
public getATime ( ) : int
public getBasename ( string $suffix = ? ) : string
public getCTime ( ) : int
public getExtension ( ) : string
public getFilename ( ) : string
public getGroup ( ) : int
public getInode ( ) : int
public getMTime ( ) : int
public getOwner ( ) : int
public getPath ( ) : string
public getPathname ( ) : string
public getPerms ( ) : int
public getSize ( ) : int
public getType ( ) : string
public isDir ( ) : bool
public isDot ( ) : bool
public isExecutable ( ) : bool
public isFile ( ) : bool
public isLink ( ) : bool
public isReadable ( ) : bool
public isWritable ( ) : bool
public key ( ) : string
public next ( ) : void
public rewind ( ) : void
public seek ( int $position ) : void
public __toString ( ) : string
public valid ( ) : bool
}

更新日志

版本 | 说明
5.1.2 | DirectoryIterator extends SplFileInfo.

Table of Contents

  • DirectoryIterator::__construct — Constructs a new directory iterator from a path
  • DirectoryIterator::current — Return the current DirectoryIterator item
  • DirectoryIterator::getATime — Get last access time of the current DirectoryIterator item
  • DirectoryIterator::getBasename — Get base name of current DirectoryIterator item
  • DirectoryIterator::getCTime — Get inode change time of the current DirectoryIterator item
  • DirectoryIterator::getExtension — Gets the file extension
  • DirectoryIterator::getFilename — Return file name of current DirectoryIterator item
  • DirectoryIterator::getGroup — Get group for the current DirectoryIterator item
  • DirectoryIterator::getInode — Get inode for the current DirectoryIterator item
  • DirectoryIterator::getMTime — Get last modification time of current DirectoryIterator item
  • DirectoryIterator::getOwner — Get owner of current DirectoryIterator item
  • DirectoryIterator::getPath — Get path of current Iterator item without filename
  • DirectoryIterator::getPathname — Return path and file name of current DirectoryIterator item
  • DirectoryIterator::getPerms — Get the permissions of current DirectoryIterator item
  • DirectoryIterator::getSize — Get size of current DirectoryIterator item
  • DirectoryIterator::getType — Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDir — Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isDot — Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isExecutable — Determine if current DirectoryIterator item is executable
  • DirectoryIterator::isFile — Determine if current DirectoryIterator item is a regular file
  • DirectoryIterator::isLink — Determine if current DirectoryIterator item is a symbolic link
  • DirectoryIterator::isReadable — Determine if current DirectoryIterator item can be read
  • DirectoryIterator::isWritable — Determine if current DirectoryIterator item can be written to
  • DirectoryIterator::key — Return the key for the current DirectoryIterator item
  • DirectoryIterator::next — Move forward to next DirectoryIterator item
  • DirectoryIterator::rewind — Rewind the DirectoryIterator back to the start
  • DirectoryIterator::seek — Seek to a DirectoryIterator item
  • DirectoryIterator::__toString — Get file name as a string
  • DirectoryIterator::valid — Check whether current DirectoryIterator position is a valid file


Constructs a new directory iterator from a path

  • ? DirectoryIterator
  • DirectoryIterator::current ?
  • PHP Manual
  • DirectoryIterator
  • Constructs a new directory iterator from a path

DirectoryIterator::__construct

(PHP 5, PHP 7)

DirectoryIterator::__construct — Constructs a new directory iterator from a path

说明

public DirectoryIterator::__construct ( string $path )

Constructs a new directory iterator from a path.

参数

path

The path of the directory to traverse.

错误／异常

Throws an UnexpectedValueException if the path cannot be opened.

Throws a RuntimeException if the path is an empty string.

范例

Example #1 A DirectoryIterator::__construct() example

This example will list the contents of the directory containing the script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if (!$fileinfo->isDot()) {
        var_dump($fileinfo->getFilename());
    }
}
?>

参见

  • SplFileInfo
  • Iterator


Return the current DirectoryIterator item

  • ? DirectoryIterator::__construct
  • DirectoryIterator::getATime ?
  • PHP Manual
  • DirectoryIterator
  • Return the current DirectoryIterator item

DirectoryIterator::current

(PHP 5, PHP 7)

DirectoryIterator::current — Return the current DirectoryIterator item

说明

public DirectoryIterator::current ( ) : DirectoryIterator

Get the current DirectoryIterator item.

参数

此函数没有参数。

返回值

The current DirectoryIterator item.

范例

Example #1 A DirectoryIterator::current() example

This example will list the contents of the directory containing the script.

<?php
$iterator = new DirectoryIterator(__DIR__);
while($iterator->valid()) {
    $file = $iterator->current();
    echo $iterator->key() . " => " . $file->getFilename() . "\n";
    $iterator->next();
}
?>

以上例程的输出类似于：

0 => .
1 => ..
2 => apple.jpg
3 => banana.jpg
4 => index.php
5 => pear.jpg

参见

  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • DirectoryIterator::valid() - Check whether current DirectoryIterator position is a valid file
  • Iterator::current() - 返回当前元素


Get last access time of the current DirectoryIterator item

  • ? DirectoryIterator::current
  • DirectoryIterator::getBasename ?
  • PHP Manual
  • DirectoryIterator
  • Get last access time of the current DirectoryIterator item

DirectoryIterator::getATime

(PHP 5, PHP 7)

DirectoryIterator::getATime — Get last access time of the current DirectoryIterator item

说明

public DirectoryIterator::getATime ( ) : int

Get the last access time of the current DirectoryIterator item.

参数

此函数没有参数。

返回值

Returns the time the file was last accessed, as a Unix timestamp.

范例

Example #1 A DirectoryIterator::getATime() example

Displays a list of the files in the directory of the script and their last access times.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getATime() . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg 1240047118
banana.jpg 1240065176
index.php 1240047208
pear.jpg 12240047979

参见

  • DirectoryIterator::getCTime() - Get inode change time of the current DirectoryIterator item
  • DirectoryIterator::getMTime() - Get last modification time of current DirectoryIterator item
  • fileatime() - 取得文件的上次访问时间


Get base name of current DirectoryIterator item

  • ? DirectoryIterator::getATime
  • DirectoryIterator::getCTime ?
  • PHP Manual
  • DirectoryIterator
  • Get base name of current DirectoryIterator item

DirectoryIterator::getBasename

(PHP 5 >= 5.2.2, PHP 7)

DirectoryIterator::getBasename — Get base name of current DirectoryIterator item

说明

public DirectoryIterator::getBasename ( string $suffix = ? ) : string

Get the base name of the current DirectoryIterator item.

参数

suffix

If the base name ends in suffix, this will be cut.

返回值

The base name of the current DirectoryIterator item.

范例

Example #1 A DirectoryIterator::getBasename() example

This example will list the full base name and the base name with suffix .jpg removed for the files in the directory containing the script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getBasename() . "\n";
        echo $fileinfo->getBasename('.jpg') . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg
apple
banana.jpg
banana
index.php
index.php
pear.jpg
pear

参见

  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item
  • DirectoryIterator::getPath() - Get path of current Iterator item without filename
  • DirectoryIterator::getPathname() - Return path and file name of current DirectoryIterator item
  • basename() - 返回路径中的文件名部分
  • pathinfo() - 返回文件路径的信息


Get inode change time of the current DirectoryIterator item

  • ? DirectoryIterator::getBasename
  • DirectoryIterator::getExtension ?
  • PHP Manual
  • DirectoryIterator
  • Get inode change time of the current DirectoryIterator item

DirectoryIterator::getCTime

(PHP 5, PHP 7)

DirectoryIterator::getCTime — Get inode change time of the current DirectoryIterator item

说明

public DirectoryIterator::getCTime ( ) : int

Get the inode change time for the current DirectoryIterator item.

参数

此函数没有参数。

返回值

Returns the last change time of the file, as a Unix timestamp.

范例

Example #1 DirectoryIterator::getCTime() example

This example displays the file name and last change time of the files in the directory containing the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " changed at " . $fileinfo->getCTime() . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg changed at 1240398312
banana.jpg changed at 1238605440
index.php changed at 1240398935
pear.jpg changed at 1237423740

参见

  • DirectoryIterator::getATime() - Get last access time of the current DirectoryIterator item
  • DirectoryIterator::getMTime() - Get last modification time of current DirectoryIterator item
  • filectime() - 取得文件的 inode 修改时间


Gets the file extension

  • ? DirectoryIterator::getCTime
  • DirectoryIterator::getFilename ?
  • PHP Manual
  • DirectoryIterator
  • Gets the file extension

DirectoryIterator::getExtension

(PHP 5 >= 5.3.6, PHP 7)

DirectoryIterator::getExtension — Gets the file extension

说明

public DirectoryIterator::getExtension ( ) : string

Retrieves the file extension.

参数

此函数没有参数。

返回值

Returns a string containing the file extension, or an empty string if the file has no extension.

范例

Example #1 DirectoryIterator::getExtension() example

<?php

$directory = new DirectoryIterator(__DIR__);
foreach ($directory as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getExtension() . "\n";
    }
}

?>

以上例程的输出类似于：

php
txt
jpg
gz

注释

Note:

This method is only available as of PHP 5.3.6. Another way of getting the extension is to use the pathinfo() function.

<?php
$extension = pathinfo($fileinfo->getFilename(), PATHINFO_EXTENSION);
?>

参见

  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item
  • DirectoryIterator::getBasename() - Get base name of current DirectoryIterator item
  • pathinfo() - 返回文件路径的信息


Return file name of current DirectoryIterator item

  • ? DirectoryIterator::getExtension
  • DirectoryIterator::getGroup ?
  • PHP Manual
  • DirectoryIterator
  • Return file name of current DirectoryIterator item

DirectoryIterator::getFilename

(PHP 5, PHP 7)

DirectoryIterator::getFilename — Return file name of current DirectoryIterator item

说明

public DirectoryIterator::getFilename ( ) : string

Get the file name of the current DirectoryIterator item.

参数

此函数没有参数。

返回值

Returns the file name of the current DirectoryIterator item.

范例

Example #1 A DirectoryIterator::getFilename() example

This example will list the contents of the directory containing the script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    echo $fileinfo->getFilename() . "\n";
}
?>

以上例程的输出类似于：

.
..
apple.jpg
banana.jpg
index.php
pear.jpg

参见

  • DirectoryIterator::getBasename() - Get base name of current DirectoryIterator item
  • DirectoryIterator::getPath() - Get path of current Iterator item without filename
  • DirectoryIterator::getPathname() - Return path and file name of current DirectoryIterator item
  • pathinfo() - 返回文件路径的信息


Get group for the current DirectoryIterator item

  • ? DirectoryIterator::getFilename
  • DirectoryIterator::getInode ?
  • PHP Manual
  • DirectoryIterator
  • Get group for the current DirectoryIterator item

DirectoryIterator::getGroup

(PHP 5, PHP 7)

DirectoryIterator::getGroup — Get group for the current DirectoryIterator item

说明

public DirectoryIterator::getGroup ( ) : int

Get the group id of the file.

参数

此函数没有参数。

返回值

Returns the group id of the current DirectoryIterator item in numerical format.

范例

Example #1 DirectoryIterator::getGroup() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
$groupid  = $iterator->getGroup();
echo 'Directory belongs to group id ' . $groupid . "\n";
print_r(posix_getgrgid($groupid));
?>

以上例程的输出类似于：

Directory belongs to group id 42
Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

参见

  • DirectoryIterator::getiNode() - Get inode for the current DirectoryIterator item
  • DirectoryIterator::getOwner() - Get owner of current DirectoryIterator item
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item
  • filegroup() - 取得文件的组
  • posix_getgrgid() - Return info about a group by group id


Get inode for the current DirectoryIterator item

  • ? DirectoryIterator::getGroup
  • DirectoryIterator::getMTime ?
  • PHP Manual
  • DirectoryIterator
  • Get inode for the current DirectoryIterator item

DirectoryIterator::getInode

(PHP 5, PHP 7)

DirectoryIterator::getInode — Get inode for the current DirectoryIterator item

说明

public DirectoryIterator::getInode ( ) : int

Get the inode number for the current DirectoryIterator item.

参数

此函数没有参数。

返回值

Returns the inode number for the file.

范例

Example #1 DirectoryIterator::getInode() example

This example displays the inode number for the directory containing the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
echo $iterator->getInode();
?>

参见

  • DirectoryIterator::getGroup() - Get group for the current DirectoryIterator item
  • DirectoryIterator::getOwner() - Get owner of current DirectoryIterator item
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item
  • fileinode() - 取得文件的 inode


Get last modification time of current DirectoryIterator item

  • ? DirectoryIterator::getInode
  • DirectoryIterator::getOwner ?
  • PHP Manual
  • DirectoryIterator
  • Get last modification time of current DirectoryIterator item

DirectoryIterator::getMTime

(PHP 5, PHP 7)

DirectoryIterator::getMTime — Get last modification time of current DirectoryIterator item

说明

public DirectoryIterator::getMTime ( ) : int

Get the last modification time of the current DirectoryIterator item, as a Unix timestamp.

参数

此函数没有参数。

返回值

The last modification time of the file, as a Unix timestamp.

范例

Example #1 A DirectoryIterator::getMTime() example

Displays a list of the files in the directory of the script and their last modified times.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getMTime() . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg 1240047118
banana.jpg 1240065176
index.php 1240047208
pear.jpg 12240047979

参见

  • DirectoryIterator::getATime() - Get last access time of the current DirectoryIterator item
  • DirectoryIterator::getCTime() - Get inode change time of the current DirectoryIterator item
  • filemtime() - 取得文件修改时间


Get owner of current DirectoryIterator item

  • ? DirectoryIterator::getMTime
  • DirectoryIterator::getPath ?
  • PHP Manual
  • DirectoryIterator
  • Get owner of current DirectoryIterator item

DirectoryIterator::getOwner

(PHP 5, PHP 7)

DirectoryIterator::getOwner — Get owner of current DirectoryIterator item

说明

public DirectoryIterator::getOwner ( ) : int

Get the owner of the current DirectoryIterator item, in numerical format.

参数

此函数没有参数。

返回值

The file owner of the file, in numerical format.

范例

Example #1 DirectoryIterator::getOwner() example

This example displays the owner of the directory which contains the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
print_r(posix_getpwuid($iterator->getOwner()));
?>

以上例程的输出类似于：

Array
(
    [name] => tom
    [passwd] => x
    [uid] => 501
    [gid] => 42
    [gecos] => Tom Cat
    [dir] => /home/tom
    [shell] => /bin/bash
)

参见

  • DirectoryIterator::getGroup() - Get group for the current DirectoryIterator item
  • DirectoryIterator::getiNode() - Get inode for the current DirectoryIterator item
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item
  • posix_getpwuid() - Return info about a user by user id


Get path of current Iterator item without filename

  • ? DirectoryIterator::getOwner
  • DirectoryIterator::getPathname ?
  • PHP Manual
  • DirectoryIterator
  • Get path of current Iterator item without filename

DirectoryIterator::getPath

(PHP 5, PHP 7)

DirectoryIterator::getPath — Get path of current Iterator item without filename

说明

public DirectoryIterator::getPath ( ) : string

Get the path to the current DirectoryIterator item.

参数

此函数没有参数。

返回值

Returns the path to the file, omitting the file name and any trailing slash.

范例

Example #1 DirectoryIterator::getPath() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
echo $iterator->getPath();
?>

以上例程的输出类似于：

/home/examples/public_html

参见

  • DirectoryIterator::getBasename() - Get base name of current DirectoryIterator item
  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item
  • DirectoryIterator::getPathname() - Return path and file name of current DirectoryIterator item
  • pathinfo() - 返回文件路径的信息


Return path and file name of current DirectoryIterator item

  • ? DirectoryIterator::getPath
  • DirectoryIterator::getPerms ?
  • PHP Manual
  • DirectoryIterator
  • Return path and file name of current DirectoryIterator item

DirectoryIterator::getPathname

(PHP 5, PHP 7)

DirectoryIterator::getPathname — Return path and file name of current DirectoryIterator item

说明

public DirectoryIterator::getPathname ( ) : string

Get the path and file name of the current file.

参数

此函数没有参数。

返回值

Returns the path and file name of current file. Directories do not have a trailing slash.

范例

Example #1 DirectoryIterator::getPathname() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    echo $fileinfo->getPathname() . "\n";
}
?>

以上例程的输出类似于：

/home/examples/.
/home/examples/..
/home/examples/apple.jpg
/home/examples/banana.jpg
/home/examples/getpathname.php
/home/examples/pear.jpg

参见

  • DirectoryIterator::getBasename() - Get base name of current DirectoryIterator item
  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item
  • DirectoryIterator::getPath() - Get path of current Iterator item without filename
  • pathinfo() - 返回文件路径的信息


Get the permissions of current DirectoryIterator item

  • ? DirectoryIterator::getPathname
  • DirectoryIterator::getSize ?
  • PHP Manual
  • DirectoryIterator
  • Get the permissions of current DirectoryIterator item

DirectoryIterator::getPerms

(PHP 5, PHP 7)

DirectoryIterator::getPerms — Get the permissions of current DirectoryIterator item

说明

public DirectoryIterator::getPerms ( ) : int

Get the permissions of the current DirectoryIterator item.

参数

此函数没有参数。

返回值

Returns the permissions of the file, as a decimal int.

范例

Example #1 DirectoryIterator::getPerms() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if (!$fileinfo->isDot()) {
        $octal_perms = substr(sprintf('%o', $fileinfo->getPerms()), -4);
        echo $fileinfo->getFilename() . " " . $octal_perms . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg 0644
banana.jpg 0644
index.php 0744
pear.jpg 0644

参见

  • DirectoryIterator::isExecutable() - Determine if current DirectoryIterator item is executable
  • DirectoryIterator::isReadable() - Determine if current DirectoryIterator item can be read
  • DirectoryIterator::isWritable() - Determine if current DirectoryIterator item can be written to


Get size of current DirectoryIterator item

  • ? DirectoryIterator::getPerms
  • DirectoryIterator::getType ?
  • PHP Manual
  • DirectoryIterator
  • Get size of current DirectoryIterator item

DirectoryIterator::getSize

(PHP 5, PHP 7)

DirectoryIterator::getSize — Get size of current DirectoryIterator item

说明

public DirectoryIterator::getSize ( ) : int

Get the file size for the current DirectoryIterator item.

参数

此函数没有参数。

返回值

Returns the size of the file, in bytes.

范例

Example #1 DirectoryIterator::getSize() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getSize() . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg 15385
banana.jpg 15190
example.php 170
pear.jpg 34406

参见

  • filesize() - 取得文件大小


Determine the type of the current DirectoryIterator item

  • ? DirectoryIterator::getSize
  • DirectoryIterator::isDir ?
  • PHP Manual
  • DirectoryIterator
  • Determine the type of the current DirectoryIterator item

DirectoryIterator::getType

(PHP 5, PHP 7)

DirectoryIterator::getType — Determine the type of the current DirectoryIterator item

说明

public DirectoryIterator::getType ( ) : string

Determines which file type the current DirectoryIterator item belongs to. One of file, link, or dir.

参数

此函数没有参数。

返回值

Returns a string representing the type of the file. May be one of file, link, or dir.

范例

Example #1 DirectoryIterator::getType() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    echo $fileinfo->getFilename() . " " . $fileinfo->getType() . "\n";
}
?>

以上例程的输出类似于：

. dir
.. dir
apple.jpg file
banana.jpg file
example.php file
pear.jpg file

参见

  • DirectoryIterator::isDir() - Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isDot() - Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isFile() - Determine if current DirectoryIterator item is a regular file
  • DirectoryIterator::isLink() - Determine if current DirectoryIterator item is a symbolic link


Determine if current DirectoryIterator item is a directory

  • ? DirectoryIterator::getType
  • DirectoryIterator::isDot ?
  • PHP Manual
  • DirectoryIterator
  • Determine if current DirectoryIterator item is a directory

DirectoryIterator::isDir

(PHP 5, PHP 7)

DirectoryIterator::isDir — Determine if current DirectoryIterator item is a directory

说明

public DirectoryIterator::isDir ( ) : bool

Determines if the current DirectoryIterator item is a directory.

参数

此函数没有参数。

返回值

Returns true if it is a directory, otherwise false

范例

Example #1 DirectoryIterator::isDir() example

This example lists the directories within the directory of the current script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isDir()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

以上例程的输出类似于：

.
..
apples
bananas
pears

参见

  • DirectoryIterator::getType() - Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDot() - Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isFile() - Determine if current DirectoryIterator item is a regular file
  • DirectoryIterator::isLink() - Determine if current DirectoryIterator item is a symbolic link


Determine if current DirectoryIterator item is '.' or '..'

  • ? DirectoryIterator::isDir
  • DirectoryIterator::isExecutable ?
  • PHP Manual
  • DirectoryIterator
  • Determine if current DirectoryIterator item is '.' or '..'

DirectoryIterator::isDot

(PHP 5, PHP 7)

DirectoryIterator::isDot — Determine if current DirectoryIterator item is '.' or '..'

说明

public DirectoryIterator::isDot ( ) : bool

Determines if the current DirectoryIterator item is a directory and either . or ..

参数

此函数没有参数。

返回值

true if the entry is . or .., otherwise false

范例

Example #1 A DirectoryIterator::isDot() example

This example will list all files, omitting the . and .. entries.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if (!$fileinfo->isDot()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg
banana.jpg
example.php
pears.jpg

参见

  • DirectoryIterator::getType() - Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDir() - Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isFile() - Determine if current DirectoryIterator item is a regular file
  • DirectoryIterator::isLink() - Determine if current DirectoryIterator item is a symbolic link


Determine if current DirectoryIterator item is executable

  • ? DirectoryIterator::isDot
  • DirectoryIterator::isFile ?
  • PHP Manual
  • DirectoryIterator
  • Determine if current DirectoryIterator item is executable

DirectoryIterator::isExecutable

(PHP 5, PHP 7)

DirectoryIterator::isExecutable — Determine if current DirectoryIterator item is executable

说明

public DirectoryIterator::isExecutable ( ) : bool

Determines if the current DirectoryIterator item is executable.

参数

此函数没有参数。

返回值

Returns true if the entry is executable, otherwise false

范例

Example #1 DirectoryIterator::isExecutable() example

This example lists files in the directory containing the script which are executable.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isExecutable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

以上例程的输出类似于：

example.php
myscript.sh

参见

  • DirectoryIterator::isReadable() - Determine if current DirectoryIterator item can be read
  • DirectoryIterator::isWritable() - Determine if current DirectoryIterator item can be written to
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item


Determine if current DirectoryIterator item is a regular file

  • ? DirectoryIterator::isExecutable
  • DirectoryIterator::isLink ?
  • PHP Manual
  • DirectoryIterator
  • Determine if current DirectoryIterator item is a regular file

DirectoryIterator::isFile

(PHP 5, PHP 7)

DirectoryIterator::isFile — Determine if current DirectoryIterator item is a regular file

说明

public DirectoryIterator::isFile ( ) : bool

Determines if the current DirectoryIterator item is a regular file.

参数

此函数没有参数。

返回值

Returns true if the file exists and is a regular file (not a link or dir), otherwise false

范例

Example #1 DirectoryIterator::isFile() example

This example will list all regular files in the directory containing the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg
banana.jpg
example.php
pears.jpg

参见

  • DirectoryIterator::getType() - Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDir() - Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isDot() - Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isLink() - Determine if current DirectoryIterator item is a symbolic link


Determine if current DirectoryIterator item is a symbolic link

  • ? DirectoryIterator::isFile
  • DirectoryIterator::isReadable ?
  • PHP Manual
  • DirectoryIterator
  • Determine if current DirectoryIterator item is a symbolic link

DirectoryIterator::isLink

(PHP 5, PHP 7)

DirectoryIterator::isLink — Determine if current DirectoryIterator item is a symbolic link

说明

public DirectoryIterator::isLink ( ) : bool

Determines if the current DirectoryIterator item is a symbolic link.

参数

此函数没有参数。

返回值

Returns true if the item is a symbolic link, otherwise false

范例

Example #1 A DirectoryIterator::isLink() example

This example contains a recursive function for removing a directory tree.

<?php
/**
 * This function will recursively delete all files in the given path, without
 * following symlinks.
 *
 * @param string $path Path to the directory to remove.
 */
function removeDir($path) {
    $dir = new DirectoryIterator($path);
    foreach ($dir as $fileinfo) {
        if ($fileinfo->isFile() || $fileinfo->isLink()) {
            unlink($fileinfo->getPathName());
        } elseif (!$fileinfo->isDot() && $fileinfo->isDir()) {
            removeDir($fileinfo->getPathName());
        }
    }
    rmdir($path);
}

removeDir('foo');
?>

参见

  • DirectoryIterator::getType() - Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDir() - Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isDot() - Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isFile() - Determine if current DirectoryIterator item is a regular file


Determine if current DirectoryIterator item can be read

  • ? DirectoryIterator::isLink
  • DirectoryIterator::isWritable ?
  • PHP Manual
  • DirectoryIterator
  • Determine if current DirectoryIterator item can be read

DirectoryIterator::isReadable

(PHP 5, PHP 7)

DirectoryIterator::isReadable — Determine if current DirectoryIterator item can be read

说明

public DirectoryIterator::isReadable ( ) : bool

Determines if the current DirectoryIterator item is readable.

参数

此函数没有参数。

返回值

Returns true if the file is readable, otherwise false

范例

Example #1 DirectoryIterator::isReadable() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isReadable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

以上例程的输出类似于：

apple.jpg
banana.jpg
example.php
pears.jpg

参见

  • DirectoryIterator::isExecutable() - Determine if current DirectoryIterator item is executable
  • DirectoryIterator::isWritable() - Determine if current DirectoryIterator item can be written to
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item


Determine if current DirectoryIterator item can be written to

  • ? DirectoryIterator::isReadable
  • DirectoryIterator::key ?
  • PHP Manual
  • DirectoryIterator
  • Determine if current DirectoryIterator item can be written to

DirectoryIterator::isWritable

(PHP 5, PHP 7)

DirectoryIterator::isWritable — Determine if current DirectoryIterator item can be written to

说明

public DirectoryIterator::isWritable ( ) : bool

Determines if the current DirectoryIterator item is writable.

参数

此函数没有参数。

返回值

Returns true if the file/directory is writable, otherwise false

范例

Example #1 DirectoryIterator::isWritable() example

This example lists the files and directories which can be opened for writing in the directory containing the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isWritable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

以上例程的输出类似于：

apples.txt
bananas.html
pears

参见

  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item
  • DirectoryIterator::isExecutable() - Determine if current DirectoryIterator item is executable
  • DirectoryIterator::isReadable() - Determine if current DirectoryIterator item can be read


Return the key for the current DirectoryIterator item

  • ? DirectoryIterator::isWritable
  • DirectoryIterator::next ?
  • PHP Manual
  • DirectoryIterator
  • Return the key for the current DirectoryIterator item

DirectoryIterator::key

(PHP 5, PHP 7)

DirectoryIterator::key — Return the key for the current DirectoryIterator item

说明

public DirectoryIterator::key ( ) : string

Get the key for the current DirectoryIterator item.

参数

此函数没有参数。

返回值

The key for the current DirectoryIterator item.

范例

Example #1 A DirectoryIterator::key() example

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if (!$fileinfo->isDot()) {
        echo $fileinfo->key() . " => " . $fileinfo->getFilename() . "\n";
    }
}
?>

以上例程的输出类似于：

0 => apple.jpg
1 => banana.jpg
2 => index.php
3 => pear.jpg

参见

  • DirectoryIterator::current() - Return the current DirectoryIterator item
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • DirectoryIterator::valid() - Check whether current DirectoryIterator position is a valid file
  • Iterator::key() - 返回当前元素的键


Move forward to next DirectoryIterator item

  • ? DirectoryIterator::key
  • DirectoryIterator::rewind ?
  • PHP Manual
  • DirectoryIterator
  • Move forward to next DirectoryIterator item

DirectoryIterator::next

(PHP 5, PHP 7)

DirectoryIterator::next — Move forward to next DirectoryIterator item

说明

public DirectoryIterator::next ( ) : void

Move forward to the next DirectoryIterator item.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 DirectoryIterator::next() example

List the contents of a directory using a while loop.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
while($iterator->valid()) {
    echo $iterator->getFilename() . "\n";
    $iterator->next();
}
?>

以上例程的输出类似于：

.
..
apple.jpg
banana.jpg
index.php
pear.jpg

参见

  • DirectoryIterator::current() - Return the current DirectoryIterator item
  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • DirectoryIterator::valid() - Check whether current DirectoryIterator position is a valid file
  • Iterator::next() - 向前移动到下一个元素


Rewind the DirectoryIterator back to the start

  • ? DirectoryIterator::next
  • DirectoryIterator::seek ?
  • PHP Manual
  • DirectoryIterator
  • Rewind the DirectoryIterator back to the start

DirectoryIterator::rewind

(PHP 5, PHP 7)

DirectoryIterator::rewind — Rewind the DirectoryIterator back to the start

说明

public DirectoryIterator::rewind ( ) : void

Rewind the DirectoryIterator back to the start.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 DirectoryIterator::rewind() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));

$iterator->next();
echo $iterator->key(); //1

$iterator->rewind(); //rewinding to the beginning
echo $iterator->key(); //0
?>

参见

  • DirectoryIterator::current() - Return the current DirectoryIterator item
  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • DirectoryIterator::valid() - Check whether current DirectoryIterator position is a valid file
  • Iterator::rewind() - 返回到迭代器的第一个元素


Seek to a DirectoryIterator item

  • ? DirectoryIterator::rewind
  • DirectoryIterator::__toString ?
  • PHP Manual
  • DirectoryIterator
  • Seek to a DirectoryIterator item

DirectoryIterator::seek

(PHP 5 >= 5.3.0, PHP 7)

DirectoryIterator::seek — Seek to a DirectoryIterator item

说明

public DirectoryIterator::seek ( int $position ) : void

Seek to a given position in the DirectoryIterator.

参数

position

The zero-based numeric position to seek to.

返回值

没有返回值。

范例

Example #1 DirectoryIterator::seek() example

Seek to the fourth item in the directory containing the script. The first two are usually . and ..

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
$iterator->seek(3);
if ($iterator->valid()) {
    echo $iterator->getFilename();
} else {
    echo 'No file at position 3';
}
?>

参见

  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • SeekableIterator::seek() - Seeks to a position


Get file name as a string

  • ? DirectoryIterator::seek
  • DirectoryIterator::valid ?
  • PHP Manual
  • DirectoryIterator
  • Get file name as a string

DirectoryIterator::__toString

(PHP 5, PHP 7)

DirectoryIterator::__toString — Get file name as a string

说明

public DirectoryIterator::__toString ( ) : string

Get the file name of the current DirectoryIterator item.

参数

此函数没有参数。

返回值

Returns the file name of the current DirectoryIterator item.

范例

Example #1 A DirectoryIterator::__toString() example

This example will list the contents of the directory containing the script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    echo $fileinfo;
}
?>

以上例程的输出类似于：

.
..
apple.jpg
banana.jpg
index.php
pear.jpg

参见

  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item
  • The __toString() magic method


Check whether current DirectoryIterator position is a valid file

  • ? DirectoryIterator::__toString
  • EmptyIterator ?
  • PHP Manual
  • DirectoryIterator
  • Check whether current DirectoryIterator position is a valid file

DirectoryIterator::valid

(PHP 5, PHP 7)

DirectoryIterator::valid — Check whether current DirectoryIterator position is a valid file

说明

public DirectoryIterator::valid ( ) : bool

Check whether current DirectoryIterator position is a valid file.

参数

此函数没有参数。

返回值

Returns true if the position is valid, otherwise false

范例

Example #1 A DirectoryIterator::valid() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));

// Loop to end of iterator
while($iterator->valid()) {
    $iterator->next();
}

$iterator->valid(); // FALSE
$iterator->rewind();
$iterator->valid(); // TRUE

?>

参见

  • DirectoryIterator::current() - Return the current DirectoryIterator item
  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • Iterator::valid() - 检查当前位置是否有效


The EmptyIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

The EmptyIterator class for an empty iterator.

类摘要

EmptyIterator implements Iterator {
/* 方法 */
public current ( ) : mixed
public key ( ) : scalar
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Table of Contents

  • EmptyIterator::current — The current() method
  • EmptyIterator::key — The key() method
  • EmptyIterator::next — The next() method
  • EmptyIterator::rewind — The rewind() method
  • EmptyIterator::valid — The valid() method


The current() method

  • ? EmptyIterator
  • EmptyIterator::key ?
  • PHP Manual
  • EmptyIterator
  • The current() method

EmptyIterator::current

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::current — The current() method

说明

public EmptyIterator::current ( ) : mixed

This function must not be called. It throws an exception upon access.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

错误／异常

Throws an Exception if called.

返回值

没有返回值。


The key() method

  • ? EmptyIterator::current
  • EmptyIterator::next ?
  • PHP Manual
  • EmptyIterator
  • The key() method

EmptyIterator::key

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::key — The key() method

说明

public EmptyIterator::key ( ) : scalar

This function must not be called. It throws an exception upon access.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

错误／异常

Throws an Exception if called.

返回值

没有返回值。


The next() method

  • ? EmptyIterator::key
  • EmptyIterator::rewind ?
  • PHP Manual
  • EmptyIterator
  • The next() method

EmptyIterator::next

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::next — The next() method

说明

public EmptyIterator::next ( ) : void

No operation, nothing to do.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


The rewind() method

  • ? EmptyIterator::next
  • EmptyIterator::valid ?
  • PHP Manual
  • EmptyIterator
  • The rewind() method

EmptyIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::rewind — The rewind() method

说明

public EmptyIterator::rewind ( ) : void

No operation, nothing to do.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


The valid() method

  • ? EmptyIterator::rewind
  • FilesystemIterator ?
  • PHP Manual
  • EmptyIterator
  • The valid() method

EmptyIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::valid — The valid() method

说明

public EmptyIterator::valid ( ) : bool

The EmptyIterator valid() method.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

false


The FilesystemIterator class

(PHP 5 >= 5.3.0, PHP 7)

简介

The Filesystem iterator

类摘要

FilesystemIterator extends DirectoryIterator implements SeekableIterator {
/* 常量 */
const int CURRENT_AS_PATHNAME = 32 ;
const int CURRENT_AS_FILEINFO = 0 ;
const int CURRENT_AS_SELF = 16 ;
const int CURRENT_MODE_MASK = 240 ;
const int KEY_AS_PATHNAME = 0 ;
const int KEY_AS_FILENAME = 256 ;
const int FOLLOW_SYMLINKS = 512 ;
const int KEY_MODE_MASK = 3840 ;
const int NEW_CURRENT_AND_KEY = 256 ;
const int SKIP_DOTS = 4096 ;
const int UNIX_PATHS = 8192 ;
/* 方法 */
public __construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS )
public current ( ) : mixed
public getFlags ( ) : int
public key ( ) : string
public next ( ) : void
public rewind ( ) : void
public setFlags ( int $flags = ? ) : void
/* 继承的方法 */
public DirectoryIterator::current ( ) : DirectoryIterator
public DirectoryIterator::getATime ( ) : int
public DirectoryIterator::getBasename ( string $suffix = ? ) : string
public DirectoryIterator::getCTime ( ) : int
public DirectoryIterator::getExtension ( ) : string
public DirectoryIterator::getFilename ( ) : string
public DirectoryIterator::getGroup ( ) : int
public DirectoryIterator::getInode ( ) : int
public DirectoryIterator::getMTime ( ) : int
public DirectoryIterator::getOwner ( ) : int
public DirectoryIterator::getPath ( ) : string
public DirectoryIterator::getPathname ( ) : string
public DirectoryIterator::getPerms ( ) : int
public DirectoryIterator::getSize ( ) : int
public DirectoryIterator::getType ( ) : string
public DirectoryIterator::isDir ( ) : bool
public DirectoryIterator::isDot ( ) : bool
public DirectoryIterator::isExecutable ( ) : bool
public DirectoryIterator::isFile ( ) : bool
public DirectoryIterator::isLink ( ) : bool
public DirectoryIterator::isReadable ( ) : bool
public DirectoryIterator::isWritable ( ) : bool
public DirectoryIterator::key ( ) : string
public DirectoryIterator::next ( ) : void
public DirectoryIterator::rewind ( ) : void
public DirectoryIterator::seek ( int $position ) : void
public DirectoryIterator::__toString ( ) : string
public DirectoryIterator::valid ( ) : bool
}

预定义常量

FilesystemIterator::CURRENT_AS_PATHNAME

Makes FilesystemIterator::current() return the pathname.

FilesystemIterator::CURRENT_AS_FILEINFO

Makes FilesystemIterator::current() return an SplFileInfo instance.

FilesystemIterator::CURRENT_AS_SELF

Makes FilesystemIterator::current() return $this (the FilesystemIterator).

FilesystemIterator::CURRENT_MODE_MASK

Masks FilesystemIterator::current()

FilesystemIterator::KEY_AS_PATHNAME

Makes FilesystemIterator::key() return the pathname.

FilesystemIterator::KEY_AS_FILENAME

Makes FilesystemIterator::key() return the filename.

FilesystemIterator::FOLLOW_SYMLINKS

Makes RecursiveDirectoryIterator::hasChildren() follow symlinks.

FilesystemIterator::KEY_MODE_MASK

Masks FilesystemIterator::key()

FilesystemIterator::NEW_CURRENT_AND_KEY

Same as FilesystemIterator::KEY_AS_FILENAME | FilesystemIterator::CURRENT_AS_FILEINFO.

FilesystemIterator::SKIP_DOTS

Skips dot files (. and ..).

FilesystemIterator::UNIX_PATHS

Makes paths use Unix-style forward slash irrespective of system default. Note that the path that is passed to the constructor is not modified.

更新日志

版本 | 说明
5.3.1 | Added FilesystemIterator::FOLLOW_SYMLINKS

Table of Contents

  • FilesystemIterator::__construct — Constructs a new filesystem iterator
  • FilesystemIterator::current — The current file
  • FilesystemIterator::getFlags — Get the handling flags
  • FilesystemIterator::key — Retrieve the key for the current file
  • FilesystemIterator::next — Move to the next file
  • FilesystemIterator::rewind — Rewinds back to the beginning
  • FilesystemIterator::setFlags — Sets handling flags


Constructs a new filesystem iterator

  • ? FilesystemIterator
  • FilesystemIterator::current ?
  • PHP Manual
  • FilesystemIterator
  • Constructs a new filesystem iterator

FilesystemIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::__construct — Constructs a new filesystem iterator

说明

public FilesystemIterator::__construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS )

Constructs a new filesystem iterator from the path.

参数

path

The path of the filesystem item to be iterated over.

flags

Flags may be provided which will affect the behavior of some methods. A list of the flags can found under FilesystemIterator predefined constants. They can also be set later with FilesystemIterator::setFlags()

Note:

FilesystemIterator::SKIP_DOTS is always set, and cannot be removed.

返回值

没有返回值。

错误／异常

Throws an UnexpectedValueException if the path cannot be found.

范例

Example #1 FilesystemIterator::__construct() example

<?php
$it = new FilesystemIterator(dirname(__FILE__));
foreach ($it as $fileinfo) {
    echo $fileinfo->getFilename() . "\n";
}
?>

以上例程会输出：

apples.jpg
banana.jpg
example.php

参见

  • FilesystemIterator::setFlags() - Sets handling flags
  • DirectoryIterator::__construct() - Constructs a new directory iterator from a path


The current file

  • ? FilesystemIterator::__construct
  • FilesystemIterator::getFlags ?
  • PHP Manual
  • FilesystemIterator
  • The current file

FilesystemIterator::current

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::current — The current file

说明

public FilesystemIterator::current ( ) : mixed

Get file information of the current element.

参数

此函数没有参数。

返回值

The filename, file information, or $this depending on the set flags. See the FilesystemIterator constants.

范例

Example #1 FilesystemIterator::current() example

This example will list the contents of the directory containing the script.

<?php
$iterator = new FilesystemIterator(__DIR__, FilesystemIterator::CURRENT_AS_PATHNAME);
foreach ($iterator as $fileinfo) {
    echo $iterator->current() . "\n";
}
?>

以上例程的输出类似于：

/www/examples/apple.jpg
/www/examples/banana.jpg
/www/examples/example.php

参见

  • FilesystemIterator constants
  • DirectoryIterator::current() - Return the current DirectoryIterator item
  • DirectoryIterator::getFileName() - Return file name of current DirectoryIterator item


Get the handling flags

  • ? FilesystemIterator::current
  • FilesystemIterator::key ?
  • PHP Manual
  • FilesystemIterator
  • Get the handling flags

FilesystemIterator::getFlags

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::getFlags — Get the handling flags

说明

public FilesystemIterator::getFlags ( ) : int

Gets the handling flags, as set in FilesystemIterator::__construct() or FilesystemIterator::setFlags().

参数

此函数没有参数。

返回值

The integer value of the set flags.

参见

  • FilesystemIterator::__construct() - Constructs a new filesystem iterator
  • FilesystemIterator::setFlags() - Sets handling flags


Retrieve the key for the current file

  • ? FilesystemIterator::getFlags
  • FilesystemIterator::next ?
  • PHP Manual
  • FilesystemIterator
  • Retrieve the key for the current file

FilesystemIterator::key

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::key — Retrieve the key for the current file

说明

public FilesystemIterator::key ( ) : string

参数

此函数没有参数。

返回值

Returns the pathname or filename depending on the set flags. See the FilesystemIterator constants.

范例

Example #1 FilesystemIterator::key() example

This example will list the contents of the directory containing the script.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_FILENAME);
foreach ($iterator as $fileinfo) {
    echo $iterator->key() . "\n";
}
?>

以上例程的输出类似于：

apple.jpg
banana.jpg
example.php

参见

  • FilesystemIterator constants
  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item
  • DirectoryIterator::getPathname() - Return path and file name of current DirectoryIterator item


Move to the next file

  • ? FilesystemIterator::key
  • FilesystemIterator::rewind ?
  • PHP Manual
  • FilesystemIterator
  • Move to the next file

FilesystemIterator::next

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::next — Move to the next file

说明

public FilesystemIterator::next ( ) : void

Move to the next file.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 FilesystemIterator::next() example

List the contents of a directory using a while loop.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__));
while($iterator->valid()) {
    echo $iterator->getFilename() . "\n";
    $iterator->next();
}
?>

以上例程的输出类似于：

apple.jpg
banana.jpg
example.php

参见

  • DirectoryIterator::next() - Move forward to next DirectoryIterator item


Rewinds back to the beginning

  • ? FilesystemIterator::next
  • FilesystemIterator::setFlags ?
  • PHP Manual
  • FilesystemIterator
  • Rewinds back to the beginning

FilesystemIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::rewind — Rewinds back to the beginning

说明

public FilesystemIterator::rewind ( ) : void

Rewinds the directory back to the start.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 FilesystemIterator::rewind() example

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_FILENAME);

echo $iterator->key() . "\n";

$iterator->next();
echo $iterator->key() . "\n";

$iterator->rewind();
echo $iterator->key() . "\n";
?>

以上例程的输出类似于：

apple.jpg
banana.jpg
apple.jpg

参见

  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start


Sets handling flags

  • ? FilesystemIterator::rewind
  • FilterIterator ?
  • PHP Manual
  • FilesystemIterator
  • Sets handling flags

FilesystemIterator::setFlags

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::setFlags — Sets handling flags

说明

public FilesystemIterator::setFlags ( int $flags = ? ) : void

Sets handling flags.

参数

flags

The handling flags to set. See the FilesystemIterator constants.

返回值

没有返回值。

范例

Example #1 FilesystemIterator::key() example

This example demonstrates the difference between the FilesystemIterator::KEY_AS_PATHNAME and FilesystemIterator::KEY_AS_FILENAME flags.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_PATHNAME);
echo "Key as Pathname:\n";
foreach ($iterator as $key => $fileinfo) {
    echo $key . "\n";
}

$iterator->setFlags(FilesystemIterator::KEY_AS_FILENAME);
echo "\nKey as Filename:\n";
foreach ($iterator as $key => $fileinfo) {
    echo $key . "\n";
}
?>

以上例程的输出类似于：

Key as Pathname:
/www/examples/apple.jpg
/www/examples/banana.jpg
/www/examples/example.php

Key as Filename:
apple.jpg
banana.jpg
example.php

参见

  • FilesystemIterator::__construct() - Constructs a new filesystem iterator
  • FilesystemIterator::getFlags() - Get the handling flags


The FilterIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

这个抽象类的遍历并过滤出不想要的值.这个类应该被实现了迭代过滤器的类继承 FilterIterator::accept()方法必须被子类实现.

类摘要

abstract FilterIterator extends IteratorIterator implements OuterIterator {
/* 方法 */
public abstract accept ( ) : bool
public __construct ( Iterator $iterator )
public current ( ) : mixed
public getInnerIterator ( ) : Iterator
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Table of Contents

  • FilterIterator::accept — Check whether the current element of the iterator is acceptable
  • FilterIterator::__construct — Construct a filterIterator
  • FilterIterator::current — Get the current element value
  • FilterIterator::getInnerIterator — Get the inner iterator
  • FilterIterator::key — Get the current key
  • FilterIterator::next — Move the iterator forward
  • FilterIterator::rewind — Rewind the iterator
  • FilterIterator::valid — Check whether the current element is valid


Check whether the current element of the iterator is acceptable

  • ? FilterIterator
  • FilterIterator::__construct ?
  • PHP Manual
  • FilterIterator
  • Check whether the current element of the iterator is acceptable

FilterIterator::accept

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::accept — Check whether the current element of the iterator is acceptable

说明

public abstract FilterIterator::accept ( ) : bool

Returns whether the current element of the iterator is acceptable through this filter.

参数

此函数没有参数。

返回值

true if the current element is acceptable, otherwise false.

范例

Example #1 FilterIterator::accept() example

<?php
// This iterator filters all values with less than 10 characters
class LengthFilterIterator extends FilterIterator {

    public function accept() {
        // Only accept strings with a length of 10 and greater
        return strlen(parent::current()) >= 10;
    }

}

$arrayIterator = new ArrayIterator(array('test1', 'more than 10 characters'));
$lengthFilter = new LengthFilterIterator($arrayIterator);

foreach ($lengthFilter as $value) {
    echo $value . "\n";
}
?>

以上例程会输出：

more than 10 characters


Construct a filterIterator

  • ? FilterIterator::accept
  • FilterIterator::current ?
  • PHP Manual
  • FilterIterator
  • Construct a filterIterator

FilterIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::__construct — Construct a filterIterator

说明

public FilterIterator::__construct ( Iterator $iterator )

Constructs a new FilterIterator, which consists of a passed in iterator with filters applied to it.

Warning

本函数还未编写文档，仅有参数列表。

参数

iterator

The iterator that is being filtered.

返回值

The FilterIterator.

参见

  • LimitIterator::__construct() - Construct a LimitIterator


Get the current element value

  • ? FilterIterator::__construct
  • FilterIterator::getInnerIterator ?
  • PHP Manual
  • FilterIterator
  • Get the current element value

FilterIterator::current

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::current — Get the current element value

说明

public FilterIterator::current ( ) : mixed
Warning

本函数还未编写文档，仅有参数列表。

Get the current element value.

参数

此函数没有参数。

返回值

The current element value.

参见

  • FilterIterator::key() - Get the current key
  • FilterIterator::next() - Move the iterator forward


Get the inner iterator

  • ? FilterIterator::current
  • FilterIterator::key ?
  • PHP Manual
  • FilterIterator
  • Get the inner iterator

FilterIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::getInnerIterator — Get the inner iterator

说明

public FilterIterator::getInnerIterator ( ) : Iterator
Warning

本函数还未编写文档，仅有参数列表。

Get the inner iterator.

参数

此函数没有参数。

返回值

The inner iterator.


Get the current key

  • ? FilterIterator::getInnerIterator
  • FilterIterator::next ?
  • PHP Manual
  • FilterIterator
  • Get the current key

FilterIterator::key

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::key — Get the current key

说明

public FilterIterator::key ( ) : mixed
Warning

本函数还未编写文档，仅有参数列表。

Get the current key.

参数

此函数没有参数。

返回值

The current key.

参见

  • FilterIterator::next() - Move the iterator forward
  • FilterIterator::current() - Get the current element value


Move the iterator forward

  • ? FilterIterator::key
  • FilterIterator::rewind ?
  • PHP Manual
  • FilterIterator
  • Move the iterator forward

FilterIterator::next

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::next — Move the iterator forward

说明

public FilterIterator::next ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

Move the iterator forward.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • FilterIterator::current() - Get the current element value
  • FilterIterator::key() - Get the current key


Rewind the iterator

  • ? FilterIterator::next
  • FilterIterator::valid ?
  • PHP Manual
  • FilterIterator
  • Rewind the iterator

FilterIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::rewind — Rewind the iterator

说明

public FilterIterator::rewind ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

Rewind the iterator.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • FilterIterator::current() - Get the current element value
  • FilterIterator::key() - Get the current key
  • FilterIterator::next() - Move the iterator forward


Check whether the current element is valid

  • ? FilterIterator::rewind
  • GlobIterator ?
  • PHP Manual
  • FilterIterator
  • Check whether the current element is valid

FilterIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::valid — Check whether the current element is valid

说明

public FilterIterator::valid ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Checks whether the current element is valid.

参数

此函数没有参数。

返回值

true if the current element is valid, otherwise false


The GlobIterator class

(PHP 5 >= 5.3.0, PHP 7)

简介

遍历一个文件系统行为类似于 glob().

类摘要

GlobIterator extends FilesystemIterator implements SeekableIterator , Countable {
/* 方法 */
public __construct ( string $pattern , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO )
public count ( ) : int
/* 继承的方法 */
public FilesystemIterator::__construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS )
public FilesystemIterator::current ( ) : mixed
public FilesystemIterator::getFlags ( ) : int
public FilesystemIterator::key ( ) : string
public FilesystemIterator::next ( ) : void
public FilesystemIterator::rewind ( ) : void
public FilesystemIterator::setFlags ( int $flags = ? ) : void
}

Table of Contents

  • GlobIterator::__construct — Construct a directory using glob
  • GlobIterator::count — Get the number of directories and files


Construct a directory using glob

  • ? GlobIterator
  • GlobIterator::count ?
  • PHP Manual
  • GlobIterator
  • Construct a directory using glob

GlobIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

GlobIterator::__construct — Construct a directory using glob

说明

public GlobIterator::__construct ( string $pattern , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO )

Constructs a new directory iterator from a glob expression.

参数

pattern

A glob() pattern.

flags

Option flags, the flags may be a bitmask of the FilesystemIterator constants.

范例

Example #1 GlobIterator example

<?php
$iterator = new GlobIterator('*.dll', FilesystemIterator::KEY_AS_FILENAME);

if (!$iterator->count()) {
    echo 'No matches';
} else {
    $n = 0;

    printf("Matched %d item(s)\r\n", $iterator->count());

    foreach ($iterator as $item) {
        printf("[%d] %s\r\n", ++$n, $iterator->key());
    }
}
?>

以上例程的输出类似于：

Matched 2 item(s)
[1] php5ts.dll
[2] php_gd2.dll

参见

  • DirectoryIterator::__construct() - Constructs a new directory iterator from a path
  • GlobIterator::count() - Get the number of directories and files
  • glob() - 寻找与模式匹配的文件路径


Get the number of directories and files

  • ? GlobIterator::__construct
  • InfiniteIterator ?
  • PHP Manual
  • GlobIterator
  • Get the number of directories and files

GlobIterator::count

(PHP 5 >= 5.3.0, PHP 7)

GlobIterator::count — Get the number of directories and files

说明

public GlobIterator::count ( ) : int

Gets the number of directories and files found by the glob expression.

参数

此函数没有参数。

返回值

The number of returned directories and files, as an int.

范例

Example #1 GlobIterator::count() example

<?php
$iterator = new GlobIterator('*.xml');

printf("Matched %d item(s)\r\n", $iterator->count());
?>

以上例程的输出类似于：

Matched 8 item(s)

参见

  • GlobIterator::__construct() - Construct a directory using glob
  • count() - 计算数组中的单元数目，或对象中的属性个数
  • glob() - 寻找与模式匹配的文件路径


The InfiniteIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

The InfiniteIterator allows one to infinitely iterate over an iterator without having to manually rewind the iterator upon reaching its end.

类摘要

InfiniteIterator extends IteratorIterator implements OuterIterator {
/* 方法 */
public __construct ( Iterator $iterator )
public next ( ) : void
/* 继承的方法 */
public IteratorIterator::__construct ( Traversable $iterator )
public IteratorIterator::current ( ) : mixed
public IteratorIterator::getInnerIterator ( ) : Traversable
public IteratorIterator::key ( ) : mixed
public IteratorIterator::next ( ) : void
public IteratorIterator::rewind ( ) : void
public IteratorIterator::valid ( ) : bool
}

Table of Contents

  • InfiniteIterator::__construct — Constructs an InfiniteIterator
  • InfiniteIterator::next — Moves the inner Iterator forward or rewinds it


Constructs an InfiniteIterator

  • ? InfiniteIterator
  • InfiniteIterator::next ?
  • PHP Manual
  • InfiniteIterator
  • Constructs an InfiniteIterator

InfiniteIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

InfiniteIterator::__construct — Constructs an InfiniteIterator

说明

public InfiniteIterator::__construct ( Iterator $iterator )

Constructs an InfiniteIterator from an Iterator.

参数

iterator

The iterator to infinitely iterate over.

返回值

没有返回值。

错误／异常

Throws an E_RECOVERABLE_ERROR if the iterator parameter is not an Iterator.

范例

Example #1 InfiniteIterator::__construct() example

<?php
$arrayit  = new ArrayIterator(array('cat','dog'));
$infinite = new InfiniteIterator($arrayit);
$limit    = new LimitIterator($infinite, 0, 7);
foreach($limit as $value)
{
    echo "$value\n";
}
?>

以上例程会输出：

cat
dog
cat
dog
cat
dog
cat

参见

  • InfiniteIterator::next() - Moves the inner Iterator forward or rewinds it


Moves the inner Iterator forward or rewinds it

  • ? InfiniteIterator::__construct
  • IteratorIterator ?
  • PHP Manual
  • InfiniteIterator
  • Moves the inner Iterator forward or rewinds it

InfiniteIterator::next

(PHP 5 >= 5.1.0, PHP 7)

InfiniteIterator::next — Moves the inner Iterator forward or rewinds it

说明

public InfiniteIterator::next ( ) : void

Moves the inner Iterator forward to its next element if there is one, otherwise rewinds the inner Iterator back to the beginning.

Note:

Even an InfiniteIterator stops if its inner Iterator is empty.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • InfiniteIterator::__construct() - Constructs an InfiniteIterator


The IteratorIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

This iterator wrapper allows the conversion of anything that is Traversable into an Iterator. It is important to understand that most classes that do not implement Iterators have reasons as most likely they do not allow the full Iterator feature set. If so, techniques should be provided to prevent misuse, otherwise expect exceptions or fatal errors.

类摘要

IteratorIterator implements OuterIterator {
/* 方法 */
public __construct ( Traversable $iterator )
public current ( ) : mixed
public getInnerIterator ( ) : Traversable
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
}

注释

Note:

This class permits access to methods of the inner iterator via the __call magic method.

Table of Contents

  • IteratorIterator::__construct — Create an iterator from anything that is traversable
  • IteratorIterator::current — Get the current value
  • IteratorIterator::getInnerIterator — Get the inner iterator
  • IteratorIterator::key — Get the key of the current element
  • IteratorIterator::next — Forward to the next element
  • IteratorIterator::rewind — Rewind to the first element
  • IteratorIterator::valid — Checks if the iterator is valid


Create an iterator from anything that is traversable

  • ? IteratorIterator
  • IteratorIterator::current ?
  • PHP Manual
  • IteratorIterator
  • Create an iterator from anything that is traversable

IteratorIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::__construct — Create an iterator from anything that is traversable

说明

public IteratorIterator::__construct ( Traversable $iterator )

Creates an iterator from anything that is traversable.

参数

iterator

The traversable iterator.

返回值

没有返回值。

参见

  • Traversable


Get the current value

  • ? IteratorIterator::__construct
  • IteratorIterator::getInnerIterator ?
  • PHP Manual
  • IteratorIterator
  • Get the current value

IteratorIterator::current

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::current — Get the current value

说明

public IteratorIterator::current ( ) : mixed

Get the value of the current element.

参数

此函数没有参数。

返回值

The value of the current element.

参见

  • IteratorIterator::key() - Get the key of the current element


Get the inner iterator

  • ? IteratorIterator::current
  • IteratorIterator::key ?
  • PHP Manual
  • IteratorIterator
  • Get the inner iterator

IteratorIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::getInnerIterator — Get the inner iterator

说明

public IteratorIterator::getInnerIterator ( ) : Traversable

Get the inner iterator.

参数

此函数没有参数。

返回值

The inner iterator as passed to IteratorIterator::__construct().

参见

  • Iterator
  • OuterIterator


Get the key of the current element

  • ? IteratorIterator::getInnerIterator
  • IteratorIterator::next ?
  • PHP Manual
  • IteratorIterator
  • Get the key of the current element

IteratorIterator::key

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::key — Get the key of the current element

说明

public IteratorIterator::key ( ) : mixed

Get the key of the current element.

参数

此函数没有参数。

返回值

The key of the current element.

参见

  • IteratorIterator::current() - Get the current value


Forward to the next element

  • ? IteratorIterator::key
  • IteratorIterator::rewind ?
  • PHP Manual
  • IteratorIterator
  • Forward to the next element

IteratorIterator::next

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::next — Forward to the next element

说明

public IteratorIterator::next ( ) : void

Forward to the next element.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • IteratorIterator::rewind() - Rewind to the first element
  • IteratorIterator::valid() - Checks if the iterator is valid


Rewind to the first element

  • ? IteratorIterator::next
  • IteratorIterator::valid ?
  • PHP Manual
  • IteratorIterator
  • Rewind to the first element

IteratorIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::rewind — Rewind to the first element

说明

public IteratorIterator::rewind ( ) : void

Rewinds to the first element.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • IteratorIterator::next() - Forward to the next element
  • IteratorIterator::valid() - Checks if the iterator is valid


Checks if the iterator is valid

  • ? IteratorIterator::rewind
  • LimitIterator ?
  • PHP Manual
  • IteratorIterator
  • Checks if the iterator is valid

IteratorIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::valid — Checks if the iterator is valid

说明

public IteratorIterator::valid ( ) : bool

Checks if the iterator is valid.

参数

此函数没有参数。

返回值

Returns true if the iterator is valid, otherwise false

参见

  • iterator_count() - 计算迭代器中元素的个数
  • IteratorIterator::current() - Get the current value


The LimitIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

LimitIterator类允许遍历一个 Iterator 的限定子集的元素.

类摘要

LimitIterator extends IteratorIterator implements OuterIterator {
/* 方法 */
public __construct ( Iterator $iterator , int $offset = 0 , int $limit = -1 )
public current ( ) : mixed
public getInnerIterator ( ) : Iterator
public getPosition ( ) : int
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public seek ( int $position ) : int
public valid ( ) : bool
}

范例

Example #1 LimitIterator usage example

<?php

// Create an iterator to be limited
$fruits = new ArrayIterator(array(
    'apple',
    'banana',
    'cherry',
    'damson',
    'elderberry'
));

// Loop over first three fruits only
foreach (new LimitIterator($fruits, 0, 3) as $fruit) {
    var_dump($fruit);
}

echo "\n";

// Loop from third fruit until the end
// Note: offset starts from zero for apple
foreach (new LimitIterator($fruits, 2) as $fruit) {
    var_dump($fruit);
}

?>

以上例程会输出：

string(5) "apple"
string(6) "banana"
string(6) "cherry"

string(6) "cherry"
string(6) "damson"
string(10) "elderberry"

Table of Contents

  • LimitIterator::__construct — Construct a LimitIterator
  • LimitIterator::current — Get current element
  • LimitIterator::getInnerIterator — Get inner iterator
  • LimitIterator::getPosition — Return the current position
  • LimitIterator::key — Get current key
  • LimitIterator::next — Move the iterator forward
  • LimitIterator::rewind — Rewind the iterator to the specified starting offset
  • LimitIterator::seek — Seek to the given position
  • LimitIterator::valid — Check whether the current element is valid


Construct a LimitIterator

  • ? LimitIterator
  • LimitIterator::current ?
  • PHP Manual
  • LimitIterator
  • Construct a LimitIterator

LimitIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::__construct — Construct a LimitIterator

说明

public LimitIterator::__construct ( Iterator $iterator , int $offset = 0 , int $limit = -1 )

Constructs a new LimitIterator from an iterator with a given starting offset and maximum limit.

参数

iterator

The Iterator to limit.

offset

Optional offset of the limit.

limit

Optional count of the limit.

返回值

The new LimitIterator.

错误／异常

Throws an OutOfRangeException if the offset is less than 0 or the limit is less than -1.

范例

Example #1 LimitIterator::__construct() example

<?php
$ait = new ArrayIterator(array('a', 'b', 'c', 'd', 'e'));
$lit = new LimitIterator($ait, 1, 3);
foreach ($lit as $value) {
    echo $value . "\n";
}
?>

以上例程会输出：

b
c
d

参见

  • LimitIterator examples


Get current element

  • ? LimitIterator::__construct
  • LimitIterator::getInnerIterator ?
  • PHP Manual
  • LimitIterator
  • Get current element

LimitIterator::current

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::current — Get current element

说明

public LimitIterator::current ( ) : mixed

Gets the current element of the inner Iterator.

参数

此函数没有参数。

返回值

Returns the current element or null if there is none.

参见

  • LimitIterator::key() - Get current key
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::seek() - Seek to the given position
  • LimitIterator::valid() - Check whether the current element is valid


Get inner iterator

  • ? LimitIterator::current
  • LimitIterator::getPosition ?
  • PHP Manual
  • LimitIterator
  • Get inner iterator

LimitIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::getInnerIterator — Get inner iterator

说明

public LimitIterator::getInnerIterator ( ) : Iterator

Gets the inner Iterator.

参数

此函数没有参数。

返回值

The inner iterator passed to LimitIterator::__construct().

参见

  • LimitIterator::__construct() - Construct a LimitIterator
  • IteratorIterator::getInnerIterator() - Get the inner iterator


Return the current position

  • ? LimitIterator::getInnerIterator
  • LimitIterator::key ?
  • PHP Manual
  • LimitIterator
  • Return the current position

LimitIterator::getPosition

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::getPosition — Return the current position

说明

public LimitIterator::getPosition ( ) : int

Gets the current zero-based position of the inner Iterator.

参数

此函数没有参数。

返回值

The current position.

范例

Example #1 LimitIterator::getPosition() example

<?php
$fruits = array(
    'a' => 'apple',
    'b' => 'banana',
    'c' => 'cherry',
    'd' => 'damson',
    'e' => 'elderberry'
);
$array_it = new ArrayIterator($fruits);
$limit_it = new LimitIterator($array_it, 2, 3);
foreach ($limit_it as $item) {
    echo $limit_it->getPosition() . ' ' . $item . "\n";
}
?>

以上例程会输出：

2 cherry
3 damson
4 elderberry

参见

  • FilterIterator::key() - Get the current key


Get current key

  • ? LimitIterator::getPosition
  • LimitIterator::next ?
  • PHP Manual
  • LimitIterator
  • Get current key

LimitIterator::key

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::key — Get current key

说明

public LimitIterator::key ( ) : mixed

Gets the key for the current item in the inner Iterator.

参数

此函数没有参数。

返回值

Returns the key for the current item.

参见

  • LimitIterator::getPosition() - Return the current position
  • LimitIterator::current() - Get current element
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::seek() - Seek to the given position
  • LimitIterator::valid() - Check whether the current element is valid


Move the iterator forward

  • ? LimitIterator::key
  • LimitIterator::rewind ?
  • PHP Manual
  • LimitIterator
  • Move the iterator forward

LimitIterator::next

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::next — Move the iterator forward

说明

public LimitIterator::next ( ) : void

Moves the iterator forward.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • LimitIterator::current() - Get current element
  • LimitIterator::key() - Get current key
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::seek() - Seek to the given position
  • LimitIterator::valid() - Check whether the current element is valid


Rewind the iterator to the specified starting offset

  • ? LimitIterator::next
  • LimitIterator::seek ?
  • PHP Manual
  • LimitIterator
  • Rewind the iterator to the specified starting offset

LimitIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::rewind — Rewind the iterator to the specified starting offset

说明

public LimitIterator::rewind ( ) : void

Rewinds the iterator to the starting offset specified in LimitIterator::__construct().

参数

此函数没有参数。

返回值

没有返回值。

参见

  • LimitIterator::current() - Get current element
  • LimitIterator::key() - Get current key
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::seek() - Seek to the given position
  • LimitIterator::valid() - Check whether the current element is valid


Seek to the given position

  • ? LimitIterator::rewind
  • LimitIterator::valid ?
  • PHP Manual
  • LimitIterator
  • Seek to the given position

LimitIterator::seek

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::seek — Seek to the given position

说明

public LimitIterator::seek ( int $position ) : int

Moves the iterator to the offset specified by position.

参数

position

The position to seek to.

返回值

Returns the offset position after seeking.

错误／异常

Throws an OutOfBoundsException if the position is outside of the limits specified in LimitIterator::__construct().

参见

  • LimitIterator::current() - Get current element
  • LimitIterator::key() - Get current key
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::valid() - Check whether the current element is valid


Check whether the current element is valid

  • ? LimitIterator::seek
  • MultipleIterator ?
  • PHP Manual
  • LimitIterator
  • Check whether the current element is valid

LimitIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::valid — Check whether the current element is valid

说明

public LimitIterator::valid ( ) : bool

Checks whether the current element is valid.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • LimitIterator::current() - Get current element
  • LimitIterator::key() - Get current key
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::seek() - Seek to the given position


The MultipleIterator class

(PHP 5 >= 5.3.0, PHP 7)

简介

An Iterator that sequentially iterates over all attached iterators

类摘要

MultipleIterator implements Iterator {
/* 常量 */
const int MIT_NEED_ANY = 0 ;
const int MIT_NEED_ALL = 1 ;
const int MIT_KEYS_NUMERIC = 0 ;
const int MIT_KEYS_ASSOC = 2 ;
/* 方法 */
public __construct ( int $flags = MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC )
public attachIterator ( Iterator $iterator , string $infos = ? ) : void
public containsIterator ( Iterator $iterator ) : bool
public countIterators ( ) : int
public current ( ) : array
public detachIterator ( Iterator $iterator ) : void
public getFlags ( ) : int
public key ( ) : array
public next ( ) : void
public rewind ( ) : void
public setFlags ( int $flags ) : void
public valid ( ) : bool
}

预定义常量

MultipleIterator::MIT_NEED_ANY

Do not require all sub iterators to be valid in iteration.

MultipleIterator::MIT_NEED_ALL

Require all sub iterators to be valid in iteration.

MultipleIterator::MIT_KEYS_NUMERIC

Keys are created from the sub iterators position.

MultipleIterator::MIT_KEYS_ASSOC

Keys are created from sub iterators associated information.

Table of Contents

  • MultipleIterator::attachIterator — Attaches iterator information
  • MultipleIterator::__construct — Constructs a new MultipleIterator
  • MultipleIterator::containsIterator — Checks if an iterator is attached
  • MultipleIterator::countIterators — Gets the number of attached iterator instances
  • MultipleIterator::current — Gets the registered iterator instances
  • MultipleIterator::detachIterator — Detaches an iterator
  • MultipleIterator::getFlags — Gets the flag information
  • MultipleIterator::key — Gets the registered iterator instances
  • MultipleIterator::next — Moves all attached iterator instances forward
  • MultipleIterator::rewind — Rewinds all attached iterator instances
  • MultipleIterator::setFlags — Sets flags
  • MultipleIterator::valid — Checks the validity of sub iterators


Attaches iterator information

  • ? MultipleIterator
  • MultipleIterator::__construct ?
  • PHP Manual
  • MultipleIterator
  • Attaches iterator information

MultipleIterator::attachIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::attachIterator — Attaches iterator information

说明

public MultipleIterator::attachIterator ( Iterator $iterator , string $infos = ? ) : void

Attaches iterator information.

Warning

本函数还未编写文档，仅有参数列表。

参数

iterator

The new iterator to attach.

infos

The associative information for the Iterator, which must be an int, a string, or null.

返回值

Description...

错误／异常

An IllegalValueException if the iterator parameter is invalid, or if infos is already associated information.

参见

  • MultipleIterator::__construct() - Constructs a new MultipleIterator


Constructs a new MultipleIterator

  • ? MultipleIterator::attachIterator
  • MultipleIterator::containsIterator ?
  • PHP Manual
  • MultipleIterator
  • Constructs a new MultipleIterator

MultipleIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::__construct — Constructs a new MultipleIterator

说明

public MultipleIterator::__construct ( int $flags = MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC )

Construct a new MultipleIterator.

参数

flags

The flags to set, according to the Flag Constants.

  • MultipleIterator::MIT_NEED_ALL or MultipleIterator::MIT_NEED_ANY
  • MultipleIterator::MIT_KEYS_NUMERIC or MultipleIterator::MIT_KEYS_ASSOC

Defaults to MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC.

返回值

没有返回值。

范例

Example #1 Iterating a MultipleIterator

<?php
$people = new ArrayIterator(array('John', 'Jane', 'Jack', 'Judy'));
$roles  = new ArrayIterator(array('Developer', 'Scrum Master', 'Project Owner'));

$team = new MultipleIterator($flags);
$team->attachIterator($people, 'person');
$team->attachIterator($roles, 'role');

foreach ($team as $member) {
    print_r($member);
}
?>

Output with $flags = MIT_NEED_ALL|MIT_KEYS_NUMERIC

Array
(
    [0] => John
    [1] => Developer
)
Array
(
    [0] => Jane
    [1] => Scrum Master
)
Array
(
    [0] => Jack
    [1] => Project Owner
)

Output with $flags = MIT_NEED_ANY|MIT_KEYS_NUMERIC

Array
(
    [0] => John
    [1] => Developer
)
Array
(
    [0] => Jane
    [1] => Scrum Master
)
Array
(
    [0] => Jack
    [1] => Project Owner
)
Array
(
    [0] => Judy
    [1] =>
)

Output with $flags = MIT_NEED_ALL|MIT_KEYS_ASSOC

Array
(
    [person] => John
    [role] => Developer
)
Array
(
    [person] => Jane
    [role] => Scrum Master
)
Array
(
    [person] => Jack
    [role] => Project Owner
)

Output with $flags = MIT_NEED_ANY|MIT_KEYS_ASSOC

Array
(
    [person] => John
    [role] => Developer
)
Array
(
    [person] => Jane
    [role] => Scrum Master
)
Array
(
    [person] => Jack
    [role] => Project Owner
)
Array
(
    [person] => Judy
    [role] =>
)

参见

  • Flag Constants
  • MultipleIterator::valid() - Checks the validity of sub iterators


Checks if an iterator is attached

  • ? MultipleIterator::__construct
  • MultipleIterator::countIterators ?
  • PHP Manual
  • MultipleIterator
  • Checks if an iterator is attached

MultipleIterator::containsIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::containsIterator — Checks if an iterator is attached

说明

public MultipleIterator::containsIterator ( Iterator $iterator ) : bool

Checks if an iterator is attached or not.

Warning

本函数还未编写文档，仅有参数列表。

参数

iterator

The iterator to check.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • MultipleIterator::valid() - Checks the validity of sub iterators


Gets the number of attached iterator instances

  • ? MultipleIterator::containsIterator
  • MultipleIterator::current ?
  • PHP Manual
  • MultipleIterator
  • Gets the number of attached iterator instances

MultipleIterator::countIterators

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::countIterators — Gets the number of attached iterator instances

说明

public MultipleIterator::countIterators ( ) : int

Gets the number of attached iterator instances.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The number of attached iterator instances (as an int).

参见

  • MultipleIterator::containsIterator() - Checks if an iterator is attached


Gets the registered iterator instances

  • ? MultipleIterator::countIterators
  • MultipleIterator::detachIterator ?
  • PHP Manual
  • MultipleIterator
  • Gets the registered iterator instances

MultipleIterator::current

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::current — Gets the registered iterator instances

说明

public MultipleIterator::current ( ) : array

Get the registered iterator instances current() result.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

An array containing the current values of each attached iterator, or false if no iterators are attached.

错误／异常

A RuntimeException if mode MIT_NEED_ALL is set and at least one attached iterator is not valid. Or an IllegalValueException if a key is null and MIT_KEYS_ASSOC is set.

参见

  • MultipleIterator::valid() - Checks the validity of sub iterators


Detaches an iterator

  • ? MultipleIterator::current
  • MultipleIterator::getFlags ?
  • PHP Manual
  • MultipleIterator
  • Detaches an iterator

MultipleIterator::detachIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::detachIterator — Detaches an iterator

说明

public MultipleIterator::detachIterator ( Iterator $iterator ) : void

Detaches an iterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

iterator

The iterator to detach.

返回值

没有返回值。

参见

  • MultipleIterator::attachIterator() - Attaches iterator information


Gets the flag information

  • ? MultipleIterator::detachIterator
  • MultipleIterator::key ?
  • PHP Manual
  • MultipleIterator
  • Gets the flag information

MultipleIterator::getFlags

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::getFlags — Gets the flag information

说明

public MultipleIterator::getFlags ( ) : int

Gets information about the flags.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Information about the flags, as an int.

参见

  • Flag Constants
  • MultipleIterator::__construct() - Constructs a new MultipleIterator
  • MultipleIterator::setFlags() - Sets flags


Gets the registered iterator instances

  • ? MultipleIterator::getFlags
  • MultipleIterator::next ?
  • PHP Manual
  • MultipleIterator
  • Gets the registered iterator instances

MultipleIterator::key

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::key — Gets the registered iterator instances

说明

public MultipleIterator::key ( ) : array

Get the registered iterator instances key() result.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

An array of all registered iterator instances, or false if no sub iterator is attached.

错误／异常

A LogicException if mode MIT_NEED_ALL is set, and at least one attached iterator is not valid.

Calling this method from foreach triggers warning "Illegal type returned".

参见

  • MultipleIterator::current() - Gets the registered iterator instances


Moves all attached iterator instances forward

  • ? MultipleIterator::key
  • MultipleIterator::rewind ?
  • PHP Manual
  • MultipleIterator
  • Moves all attached iterator instances forward

MultipleIterator::next

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::next — Moves all attached iterator instances forward

说明

public MultipleIterator::next ( ) : void

Moves all attached iterator instances forward.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • MultipleIterator::rewind() - Rewinds all attached iterator instances


Rewinds all attached iterator instances

  • ? MultipleIterator::next
  • MultipleIterator::setFlags ?
  • PHP Manual
  • MultipleIterator
  • Rewinds all attached iterator instances

MultipleIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::rewind — Rewinds all attached iterator instances

说明

public MultipleIterator::rewind ( ) : void

Rewinds all attached iterator instances.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • MultipleIterator::next() - Moves all attached iterator instances forward


Sets flags

  • ? MultipleIterator::rewind
  • MultipleIterator::valid ?
  • PHP Manual
  • MultipleIterator
  • Sets flags

MultipleIterator::setFlags

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::setFlags — Sets flags

说明

public MultipleIterator::setFlags ( int $flags ) : void

Sets flags.

Warning

本函数还未编写文档，仅有参数列表。

参数

flags

The flags to set, according to the Flag Constants

返回值

没有返回值。

参见

  • Flag Constants
  • MultipleIterator::__construct() - Constructs a new MultipleIterator
  • MultipleIterator::getFlags() - Gets the flag information


Checks the validity of sub iterators

  • ? MultipleIterator::setFlags
  • NoRewindIterator ?
  • PHP Manual
  • MultipleIterator
  • Checks the validity of sub iterators

MultipleIterator::valid

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::valid — Checks the validity of sub iterators

说明

public MultipleIterator::valid ( ) : bool

Checks the validity of sub iterators.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns true if one or all sub iterators are valid depending on flags, otherwise false

参见

  • MultipleIterator::__construct() - Constructs a new MultipleIterator


The NoRewindIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

This iterator ignores rewind operations. This allows processing an iterator in multiple partial foreach loops.

类摘要

NoRewindIterator extends IteratorIterator {
/* 方法 */
public __construct ( Iterator $iterator )
public current ( ) : mixed
public getInnerIterator ( ) : iterator
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
/* 继承的方法 */
public IteratorIterator::__construct ( Traversable $iterator )
public IteratorIterator::current ( ) : mixed
public IteratorIterator::getInnerIterator ( ) : Traversable
public IteratorIterator::key ( ) : mixed
public IteratorIterator::next ( ) : void
public IteratorIterator::rewind ( ) : void
public IteratorIterator::valid ( ) : bool
}

Table of Contents

  • NoRewindIterator::__construct — Construct a NoRewindIterator
  • NoRewindIterator::current — Get the current value
  • NoRewindIterator::getInnerIterator — Get the inner iterator
  • NoRewindIterator::key — Get the current key
  • NoRewindIterator::next — Forward to the next element
  • NoRewindIterator::rewind — Prevents the rewind operation on the inner iterator
  • NoRewindIterator::valid — Validates the iterator


Construct a NoRewindIterator

  • ? NoRewindIterator
  • NoRewindIterator::current ?
  • PHP Manual
  • NoRewindIterator
  • Construct a NoRewindIterator

NoRewindIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::__construct — Construct a NoRewindIterator

说明

public NoRewindIterator::__construct ( Iterator $iterator )

Constructs a NoRewindIterator.

参数

iterator

The iterator being used.

返回值

A NoRewindIterator() based on the passed in iterator.

范例

Example #1 NoRewindIterator::__construct() example

The second loop does not output because the iterator is only used once, as it does not rewind.

<?php
$fruit = array('apple', 'banana', 'cranberry');

$arr = new ArrayObject($fruit);
$it  = new NoRewindIterator($arr->getIterator());

echo "Fruit A:\n";
foreach( $it as $item ) {
    echo $item . "\n";
}

echo "Fruit B:\n";
foreach( $it as $item ) {
    echo $item . "\n";
}
?>

以上例程的输出类似于：

Fruit A:
apple
banana
cranberry
Fruit B:

参见

  • NoRewindIterator::valid() - Validates the iterator


Get the current value

  • ? NoRewindIterator::__construct
  • NoRewindIterator::getInnerIterator ?
  • PHP Manual
  • NoRewindIterator
  • Get the current value

NoRewindIterator::current

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::current — Get the current value

说明

public NoRewindIterator::current ( ) : mixed

Gets the current value.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The current value.

参见

  • NoRewindIterator::key() - Get the current key


Get the inner iterator

  • ? NoRewindIterator::current
  • NoRewindIterator::key ?
  • PHP Manual
  • NoRewindIterator
  • Get the inner iterator

NoRewindIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::getInnerIterator — Get the inner iterator

说明

public NoRewindIterator::getInnerIterator ( ) : iterator

Gets the inner iterator, that was passed in to NoRewindIterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The inner iterator, as passed to NoRewindIterator::__construct().

参见

  • NoRewindIterator::valid() - Validates the iterator


Get the current key

  • ? NoRewindIterator::getInnerIterator
  • NoRewindIterator::next ?
  • PHP Manual
  • NoRewindIterator
  • Get the current key

NoRewindIterator::key

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::key — Get the current key

说明

public NoRewindIterator::key ( ) : mixed

Gets the current key.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The current key.

参见

  • NoRewindIterator::next() - Forward to the next element


Forward to the next element

  • ? NoRewindIterator::key
  • NoRewindIterator::rewind ?
  • PHP Manual
  • NoRewindIterator
  • Forward to the next element

NoRewindIterator::next

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::next — Forward to the next element

说明

public NoRewindIterator::next ( ) : void

Forwards to the next element.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • NoRewindIterator::rewind() - Prevents the rewind operation on the inner iterator


Prevents the rewind operation on the inner iterator

  • ? NoRewindIterator::next
  • NoRewindIterator::valid ?
  • PHP Manual
  • NoRewindIterator
  • Prevents the rewind operation on the inner iterator

NoRewindIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::rewind — Prevents the rewind operation on the inner iterator

说明

public NoRewindIterator::rewind ( ) : void

Prevents the rewind operation on the inner iterator.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 NoRewindIterator::rewind() example

This example demonstrates that calling rewind on a NoRewindIterator object has no effect.

<?php
$fruits = array("lemon", "orange", "apple", "pear");

$noRewindIterator = new NoRewindIterator(new ArrayIterator($fruits));

echo $noRewindIterator->current() . "\n";
$noRewindIterator->next();
// now rewind the iterator (nothing should happen)
$noRewindIterator->rewind();
echo $noRewindIterator->current() . "\n";
?>

以上例程会输出：

lemon
orange


Validates the iterator

  • ? NoRewindIterator::rewind
  • ParentIterator ?
  • PHP Manual
  • NoRewindIterator
  • Validates the iterator

NoRewindIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::valid — Validates the iterator

说明

public NoRewindIterator::valid ( ) : bool

Checks whether the iterator is valid.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • NoRewindIterator::getInnerIterator() - Get the inner iterator


The ParentIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

This extended FilterIterator allows a recursive iteration using RecursiveIteratorIterator that only shows those elements which have children.

类摘要

ParentIterator extends RecursiveFilterIterator implements RecursiveIterator , OuterIterator {
/* 方法 */
public accept ( ) : bool
public __construct ( RecursiveIterator $iterator )
public getChildren ( ) : ParentIterator
public hasChildren ( ) : bool
public next ( ) : void
public rewind ( ) : void
/* 继承的方法 */
public OuterIterator::getInnerIterator ( ) : Iterator
}

Table of Contents

  • ParentIterator::accept — Determines acceptability
  • ParentIterator::__construct — Constructs a ParentIterator
  • ParentIterator::getChildren — Return the inner iterator's children contained in a ParentIterator
  • ParentIterator::hasChildren — Check whether the inner iterator's current element has children
  • ParentIterator::next — Move the iterator forward
  • ParentIterator::rewind — Rewind the iterator


Determines acceptability

  • ? ParentIterator
  • ParentIterator::__construct ?
  • PHP Manual
  • ParentIterator
  • Determines acceptability

ParentIterator::accept

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::accept — Determines acceptability

说明

public ParentIterator::accept ( ) : bool

Determines if the current element has children.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the current element is acceptable, otherwise false.

参见

  • ParentIterator::hasChildren() - Check whether the inner iterator's current element has children
  • FilterIterator::accept() - Check whether the current element of the iterator is acceptable


Constructs a ParentIterator

  • ? ParentIterator::accept
  • ParentIterator::getChildren ?
  • PHP Manual
  • ParentIterator
  • Constructs a ParentIterator

ParentIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::__construct — Constructs a ParentIterator

说明

public ParentIterator::__construct ( RecursiveIterator $iterator )

Constructs a ParentIterator on an iterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

iterator

The iterator being constructed upon.

返回值

The ParentIterator.


Return the inner iterator's children contained in a ParentIterator

  • ? ParentIterator::__construct
  • ParentIterator::hasChildren ?
  • PHP Manual
  • ParentIterator
  • Return the inner iterator's children contained in a ParentIterator

ParentIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::getChildren — Return the inner iterator's children contained in a ParentIterator

说明

public ParentIterator::getChildren ( ) : ParentIterator

Get the inner iterator's children contained in a ParentIterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

An object.


Check whether the inner iterator's current element has children

  • ? ParentIterator::getChildren
  • ParentIterator::next ?
  • PHP Manual
  • ParentIterator
  • Check whether the inner iterator's current element has children

ParentIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::hasChildren — Check whether the inner iterator's current element has children

说明

public ParentIterator::hasChildren ( ) : bool

Check whether the inner iterator's current element has children.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Move the iterator forward

  • ? ParentIterator::hasChildren
  • ParentIterator::rewind ?
  • PHP Manual
  • ParentIterator
  • Move the iterator forward

ParentIterator::next

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::next — Move the iterator forward

说明

public ParentIterator::next ( ) : void

Moves the iterator forward.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Rewind the iterator

  • ? ParentIterator::next
  • RecursiveArrayIterator ?
  • PHP Manual
  • ParentIterator
  • Rewind the iterator

ParentIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::rewind — Rewind the iterator

说明

public ParentIterator::rewind ( ) : void

Rewinds the iterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


The RecursiveArrayIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

This iterator allows to unset and modify values and keys while iterating over Arrays and Objects in the same way as the ArrayIterator. Additionally it is possible to iterate over the current iterator entry.

类摘要

RecursiveArrayIterator extends ArrayIterator implements RecursiveIterator {
/* 继承的常量 */
const integer STD_PROP_LIST = 1 ;
const integer ARRAY_AS_PROPS = 2 ;
/* 常量 */
const int CHILD_ARRAYS_ONLY = 4 ;
/* 方法 */
public getChildren ( ) : RecursiveArrayIterator
public hasChildren ( ) : bool
/* Inherits */
public ArrayIterator::append ( mixed $value ) : void
public ArrayIterator::asort ( ) : void
public ArrayIterator::__construct ( mixed $array = array() , int $flags = 0 )
public ArrayIterator::count ( ) : int
public ArrayIterator::current ( ) : mixed
public ArrayIterator::getArrayCopy ( ) : array
public ArrayIterator::getFlags ( ) : int
public ArrayIterator::key ( ) : mixed
public ArrayIterator::ksort ( ) : void
public ArrayIterator::natcasesort ( ) : void
public ArrayIterator::natsort ( ) : void
public ArrayIterator::next ( ) : void
public ArrayIterator::offsetExists ( mixed $index ) : bool
public ArrayIterator::offsetGet ( mixed $index ) : mixed
public ArrayIterator::offsetSet ( mixed $index , mixed $newval ) : void
public ArrayIterator::offsetUnset ( mixed $index ) : void
public ArrayIterator::rewind ( ) : void
public ArrayIterator::seek ( int $position ) : void
public ArrayIterator::serialize ( ) : string
public ArrayIterator::setFlags ( string $flags ) : void
public ArrayIterator::uasort ( callable $cmp_function ) : void
public ArrayIterator::uksort ( callable $cmp_function ) : void
public ArrayIterator::unserialize ( string $serialized ) : void
public ArrayIterator::valid ( ) : bool
}

预定义常量

RecursiveArrayIterator Flags

RecursiveArrayIterator::CHILD_ARRAYS_ONLY

Treat only arrays (not objects) as having children for recursive iteration.

更新日志

版本 | 说明
5.3.0 | CHILD_ARRAYS_ONLY flag was added.

Table of Contents

  • RecursiveArrayIterator::getChildren — Returns an iterator for the current entry if it is an array or an object
  • RecursiveArrayIterator::hasChildren — Returns whether current entry is an array or an object


Returns an iterator for the current entry if it is an array or an object

  • ? RecursiveArrayIterator
  • RecursiveArrayIterator::hasChildren ?
  • PHP Manual
  • RecursiveArrayIterator
  • Returns an iterator for the current entry if it is an array or an object

RecursiveArrayIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveArrayIterator::getChildren — Returns an iterator for the current entry if it is an array or an object

说明

public RecursiveArrayIterator::getChildren ( ) : RecursiveArrayIterator

Returns an iterator for the current iterator entry.

参数

此函数没有参数。

返回值

An iterator for the current entry, if it is an array or object.

错误／异常

An InvalidArgumentException will be thrown if the current entry does not contain an array or an object.

范例

Example #1 RecursiveArrayIterator::getChildren() example

<?php
$fruits = array("a" => "lemon", "b" => "orange", array("a" => "apple", "p" => "pear"));

$iterator = new RecursiveArrayIterator($fruits);

while ($iterator->valid()) {

    if ($iterator->hasChildren()) {
        // print all children
        foreach ($iterator->getChildren() as $key => $value) {
            echo $key . ' : ' . $value . "\n";
        }
    } else {
        echo "No children.\n";
    }

    $iterator->next();
}
?>

以上例程会输出：

No children.
No children.
a : apple
p : pear

参见

  • RecursiveArrayIterator::hasChildren() - Returns whether current entry is an array or an object


Returns whether current entry is an array or an object

  • ? RecursiveArrayIterator::getChildren
  • RecursiveCachingIterator ?
  • PHP Manual
  • RecursiveArrayIterator
  • Returns whether current entry is an array or an object

RecursiveArrayIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveArrayIterator::hasChildren — Returns whether current entry is an array or an object

说明

public RecursiveArrayIterator::hasChildren ( ) : bool

Returns whether current entry is an array or an object for which an iterator can be obtained via RecursiveArrayIterator::getChildren().

参数

此函数没有参数。

返回值

Returns true if the current entry is an array or an object, otherwise false is returned.

范例

Example #1 RecursiveArrayIterator::hasChildren() example

<?php
$fruits = array("a" => "lemon", "b" => "orange", array("a" => "apple", "p" => "pear"));

$iterator = new RecursiveArrayIterator($fruits);

while ($iterator->valid()) {

    // Check if there are children
    if ($iterator->hasChildren()) {
        // print all children
        foreach ($iterator->getChildren() as $key => $value) {
            echo $key . ' : ' . $value . "\n";
        }
    } else {
        echo "No children.\n";
    }

    $iterator->next();
}
?>

以上例程会输出：

No children.
No children.
a : apple
p : pear

参见

  • RecursiveArrayIterator::getChildren() - Returns an iterator for the current entry if it is an array or an object


The RecursiveCachingIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

...

类摘要

RecursiveCachingIterator extends CachingIterator implements Countable , ArrayAccess , OuterIterator , RecursiveIterator {
/* 继承的常量 */
const int CachingIterator::CALL_TOSTRING = 1 ;
const int CachingIterator::CATCH_GET_CHILD = 16 ;
const int CachingIterator::TOSTRING_USE_KEY = 2 ;
const int CachingIterator::TOSTRING_USE_CURRENT = 4 ;
const int CachingIterator::TOSTRING_USE_INNER = 8 ;
const int CachingIterator::FULL_CACHE = 256 ;
/* 方法 */
public __construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )
public getChildren ( ) : RecursiveCachingIterator
public hasChildren ( ) : bool
/* Inherits */
public CachingIterator::__construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )
public CachingIterator::count ( ) : int
public CachingIterator::current ( ) : mixed
public CachingIterator::getCache ( ) : array
public CachingIterator::getFlags ( ) : int
public CachingIterator::getInnerIterator ( ) : Iterator
public CachingIterator::hasNext ( ) : void
public CachingIterator::key ( ) : scalar
public CachingIterator::next ( ) : void
public CachingIterator::offsetExists ( mixed $index ) : void
public CachingIterator::offsetGet ( string $index ) : void
public CachingIterator::offsetSet ( mixed $index , mixed $newval ) : void
public CachingIterator::offsetUnset ( string $index ) : void
public CachingIterator::rewind ( ) : void
public CachingIterator::setFlags ( int $flags ) : void
public CachingIterator::__toString ( ) : void
public CachingIterator::valid ( ) : void
}

Table of Contents

  • RecursiveCachingIterator::__construct — Construct
  • RecursiveCachingIterator::getChildren — Return the inner iterator's children as a RecursiveCachingIterator
  • RecursiveCachingIterator::hasChildren — Check whether the current element of the inner iterator has children


Construct

  • ? RecursiveCachingIterator
  • RecursiveCachingIterator::getChildren ?
  • PHP Manual
  • RecursiveCachingIterator
  • Construct

RecursiveCachingIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::__construct — Construct

说明

public RecursiveCachingIterator::__construct ( Iterator $iterator , int $flags = self::CALL_TOSTRING )

Constructs a new RecursiveCachingIterator, which consists of a passed in iterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

iterator

The iterator being used.

flags

The flags. Use CALL_TOSTRING to call RecursiveCachingIterator::__toString() for every element (the default), and/or CATCH_GET_CHILD to catch exceptions when trying to get children.

返回值

The RecursiveCachingIterator.

参见

  • CachingIterator::__construct() - Construct a new CachingIterator object for the iterator


Return the inner iterator's children as a RecursiveCachingIterator

  • ? RecursiveCachingIterator::__construct
  • RecursiveCachingIterator::hasChildren ?
  • PHP Manual
  • RecursiveCachingIterator
  • Return the inner iterator's children as a RecursiveCachingIterator

RecursiveCachingIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::getChildren — Return the inner iterator's children as a RecursiveCachingIterator

说明

public RecursiveCachingIterator::getChildren ( ) : RecursiveCachingIterator
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The inner iterator's children, as a RecursiveCachingIterator.


Check whether the current element of the inner iterator has children

  • ? RecursiveCachingIterator::getChildren
  • RecursiveCallbackFilterIterator ?
  • PHP Manual
  • RecursiveCachingIterator
  • Check whether the current element of the inner iterator has children

RecursiveCachingIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::hasChildren — Check whether the current element of the inner iterator has children

说明

public RecursiveCachingIterator::hasChildren ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the inner iterator has children, otherwise false


The RecursiveCallbackFilterIterator class

(PHP 5 >= 5.4.0, PHP 7)

简介

类摘要

RecursiveCallbackFilterIterator extends CallbackFilterIterator implements OuterIterator , RecursiveIterator {
/* 方法 */
public __construct ( RecursiveIterator $iterator , string $callback )
public getChildren ( ) : RecursiveCallbackFilterIterator
public hasChildren ( ) : bool
/* 继承的方法 */
public CallbackFilterIterator::accept ( ) : bool
}

范例

The callback should accept up to three arguments: the current item, the current key and the iterator, respectively.

Example #1 Available callback arguments

<?php

/**
 * Callback for RecursiveCallbackFilterIterator
 *
 * @param $current   Current item's value
 * @param $key       Current item's key
 * @param $iterator  Iterator being filtered
 * @return boolean   TRUE to accept the current item, FALSE otherwise
 */
function my_callback($current, $key, $iterator) {
    // Your filtering code here
}

?>

Filtering a recursive iterator generally involves two conditions. The first is that, to allow recursion, the callback function should return true if the current iterator item has children. The second is the normal filter condition, such as a file size or extension check as in the example below.

Example #2 Recursive callback basic example

<?php

$dir = new RecursiveDirectoryIterator(__DIR__);

// Filter large files ( > 100MB)
$files = new RecursiveCallbackFilterIterator($dir, function ($current, $key, $iterator) {
    // Allow recursion
    if ($iterator->hasChildren()) {
        return TRUE;
    }
    // Check for large file
    if ($current->isFile() && $current->getSize() > 104857600) {
        return TRUE;
    }
    return FALSE;
});

foreach (new RecursiveIteratorIterator($files) as $file) {
    echo $file->getPathname() . PHP_EOL;
}

?>

Table of Contents

  • RecursiveCallbackFilterIterator::__construct — Create a RecursiveCallbackFilterIterator from a RecursiveIterator
  • RecursiveCallbackFilterIterator::getChildren — Return the inner iterator's children contained in a RecursiveCallbackFilterIterator
  • RecursiveCallbackFilterIterator::hasChildren — Check whether the inner iterator's current element has children


Create a RecursiveCallbackFilterIterator from a RecursiveIterator

  • ? RecursiveCallbackFilterIterator
  • RecursiveCallbackFilterIterator::getChildren ?
  • PHP Manual
  • RecursiveCallbackFilterIterator
  • Create a RecursiveCallbackFilterIterator from a RecursiveIterator

RecursiveCallbackFilterIterator::__construct

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::__construct — Create a RecursiveCallbackFilterIterator from a RecursiveIterator

说明

public RecursiveCallbackFilterIterator::__construct ( RecursiveIterator $iterator , string $callback )

Creates a filtered iterator from a RecursiveIterator using the callback to determine which items are accepted or rejected.

参数

iterator

The recursive iterator to be filtered.

callback

The callback, which should return true to accept the current item or false otherwise. See Examples.

May be any valid callable value.

返回值

没有返回值。

参见

  • RecursiveCallbackFilterIterator Examples
  • RecursiveCallbackFilterIterator::getChildren() - Return the inner iterator's children contained in a RecursiveCallbackFilterIterator
  • RecursiveCallbackFilteriterator::hasChildren() - Check whether the inner iterator's current element has children


Return the inner iterator's children contained in a RecursiveCallbackFilterIterator

  • ? RecursiveCallbackFilterIterator::__construct
  • RecursiveCallbackFilterIterator::hasChildren ?
  • PHP Manual
  • RecursiveCallbackFilterIterator
  • Return the inner iterator's children contained in a RecursiveCallbackFilterIterator

RecursiveCallbackFilterIterator::getChildren

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::getChildren — Return the inner iterator's children contained in a RecursiveCallbackFilterIterator

说明

public RecursiveCallbackFilterIterator::getChildren ( ) : RecursiveCallbackFilterIterator

Fetches the filtered children of the inner iterator.

RecursiveCallbackFilterIterator::hasChildren() should be used to determine if there are children to be fetched.

参数

此函数没有参数。

返回值

Returns a RecursiveCallbackFilterIterator containing the children.

参见

  • RecursiveCallbackFilterIterator Examples
  • RecursiveCallbackFilterIterator::__construct() - Create a RecursiveCallbackFilterIterator from a RecursiveIterator
  • RecursiveCallbackFilteriterator::hasChildren() - Check whether the inner iterator's current element has children


Check whether the inner iterator's current element has children

  • ? RecursiveCallbackFilterIterator::getChildren
  • RecursiveDirectoryIterator ?
  • PHP Manual
  • RecursiveCallbackFilterIterator
  • Check whether the inner iterator's current element has children

RecursiveCallbackFilterIterator::hasChildren

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::hasChildren — Check whether the inner iterator's current element has children

说明

public RecursiveCallbackFilterIterator::hasChildren ( ) : bool

Returns true if the current element has children, false otherwise.

参数

此函数没有参数。

返回值

Returns true if the current element has children, false otherwise.

范例

Example #1 RecursiveCallbackFilterIterator::hasChildren() basic usage

<?php

$dir = new RecursiveDirectoryIterator(__DIR__);

// Recursively iterate over XML files
$files = new RecursiveCallbackFilterIterator($dir, function ($current, $key, $iterator) {
    // Allow recursion into directories
    if ($iterator->hasChildren()) {
        return TRUE;
    }
    // Check for XML file
    if (!strcasecmp($current->getExtension(), 'xml')) {
        return TRUE;
    }
    return FALSE;
});

?>

参见

  • RecursiveCallbackFilterIterator Examples
  • RecursiveCallbackFilterIterator::__construct() - Create a RecursiveCallbackFilterIterator from a RecursiveIterator
  • RecursiveCallbackFilteriterator::getChildren() - Return the inner iterator's children contained in a RecursiveCallbackFilterIterator


The RecursiveDirectoryIterator class

(PHP 5, PHP 7)

简介

The RecursiveDirectoryIterator provides an interface for iterating recursively over filesystem directories.

类摘要

RecursiveDirectoryIterator extends FilesystemIterator implements SeekableIterator , RecursiveIterator {
/* 继承的常量 */
const int FilesystemIterator::CURRENT_AS_PATHNAME = 32 ;
const int FilesystemIterator::CURRENT_AS_FILEINFO = 0 ;
const int FilesystemIterator::CURRENT_AS_SELF = 16 ;
const int FilesystemIterator::CURRENT_MODE_MASK = 240 ;
const int FilesystemIterator::KEY_AS_PATHNAME = 0 ;
const int FilesystemIterator::KEY_AS_FILENAME = 256 ;
const int FilesystemIterator::FOLLOW_SYMLINKS = 512 ;
const int FilesystemIterator::KEY_MODE_MASK = 3840 ;
const int FilesystemIterator::NEW_CURRENT_AND_KEY = 256 ;
const int FilesystemIterator::SKIP_DOTS = 4096 ;
const int FilesystemIterator::UNIX_PATHS = 8192 ;
/* 方法 */
public __construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO )
public getChildren ( ) : mixed
public getSubPath ( ) : string
public getSubPathname ( ) : string
public hasChildren ( bool $allow_links = false ) : bool
public key ( ) : string
public next ( ) : void
public rewind ( ) : void
/* Inherits */
public FilesystemIterator::__construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS )
public FilesystemIterator::current ( ) : mixed
public FilesystemIterator::getFlags ( ) : int
public FilesystemIterator::key ( ) : string
public FilesystemIterator::next ( ) : void
public FilesystemIterator::rewind ( ) : void
public FilesystemIterator::setFlags ( int $flags = ? ) : void
}

更新日志

版本 | 说明
5.3.0 | The FilesystemIterator was introduced as the parent class. Previously, the parent was the DirectoryIterator.
5.3.0 | Implements SeekableIterator.
5.2.11, 5.3.1 | Added RecursiveDirectoryIterator::FOLLOW_SYMLINKS

Table of Contents

  • RecursiveDirectoryIterator::__construct — Constructs a RecursiveDirectoryIterator
  • RecursiveDirectoryIterator::getChildren — Returns an iterator for the current entry if it is a directory
  • RecursiveDirectoryIterator::getSubPath — Get sub path
  • RecursiveDirectoryIterator::getSubPathname — Get sub path and name
  • RecursiveDirectoryIterator::hasChildren — Returns whether current entry is a directory and not '.' or '..'
  • RecursiveDirectoryIterator::key — Return path and filename of current dir entry
  • RecursiveDirectoryIterator::next — Move to next entry
  • RecursiveDirectoryIterator::rewind — Rewind dir back to the start


Constructs a RecursiveDirectoryIterator

  • ? RecursiveDirectoryIterator
  • RecursiveDirectoryIterator::getChildren ?
  • PHP Manual
  • RecursiveDirectoryIterator
  • Constructs a RecursiveDirectoryIterator

RecursiveDirectoryIterator::__construct

(PHP 5 >= 5.1.2, PHP 7)

RecursiveDirectoryIterator::__construct — Constructs a RecursiveDirectoryIterator

说明

public RecursiveDirectoryIterator::__construct ( string $path , int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO )

Constructs a RecursiveDirectoryIterator() for the provided path.

参数

path

The path of the directory to be iterated over.

flags

Flags may be provided which will affect the behavior of some methods. A list of the flags can found under FilesystemIterator predefined constants. They can also be set later with FilesystemIterator::setFlags().

返回值

Returns the newly created RecursiveDirectoryIterator.

错误／异常

Throws an UnexpectedValueException if the path cannot be found or is not a directory.

范例

Example #1 RecursiveDirectoryIterator example

<?php

$directory = '/tmp';

$it = new RecursiveIteratorIterator(new RecursiveDirectoryIterator($directory));

$it->rewind();
while($it->valid()) {

    if (!$it->isDot()) {
        echo 'SubPathName: ' . $it->getSubPathName() . "\n";
        echo 'SubPath:     ' . $it->getSubPath() . "\n";
        echo 'Key:         ' . $it->key() . "\n\n";
    }

    $it->next();
}

?>

以上例程的输出类似于：

SubPathName: fruit/apple.xml
SubPath:     fruit
Key:         /tmp/fruit/apple.xml

SubPathName: stuff.xml
SubPath:
Key:         /tmp/stuff.xml

SubPathName: veggies/carrot.xml
SubPath:     veggies
Key:         /tmp/veggies/carrot.xml

参见

  • FilesystemIterator::__construct() - Constructs a new filesystem iterator
  • RecursiveIteratorIterator::__construct() - Construct a RecursiveIteratorIterator
  • FilesystemIterator predefined constants


Returns an iterator for the current entry if it is a directory

  • ? RecursiveDirectoryIterator::__construct
  • RecursiveDirectoryIterator::getSubPath ?
  • PHP Manual
  • RecursiveDirectoryIterator
  • Returns an iterator for the current entry if it is a directory

RecursiveDirectoryIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getChildren — Returns an iterator for the current entry if it is a directory

说明

public RecursiveDirectoryIterator::getChildren ( ) : mixed
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The filename, file information, or $this depending on the set flags. See the FilesystemIterator constants.


Get sub path

  • ? RecursiveDirectoryIterator::getChildren
  • RecursiveDirectoryIterator::getSubPathname ?
  • PHP Manual
  • RecursiveDirectoryIterator
  • Get sub path

RecursiveDirectoryIterator::getSubPath

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getSubPath — Get sub path

说明

public RecursiveDirectoryIterator::getSubPath ( ) : string

Returns the sub path relative to the directory given in the constructor.

参数

此函数没有参数。

返回值

The sub path.

范例

Example #1 getSubPath() example

$directory = '/tmp';

      $it = new RecursiveIteratorIterator(new RecursiveDirectoryIterator($directory));

      foreach ($it as $file) {
          echo 'SubPathName: ' . $it->getSubPathName() . "\n";
          echo 'SubPath:     ' . $it->getSubPath() . "\n\n";
      }

以上例程的输出类似于：

     SubPathName: fruit/apple.xml
     SubPath:     fruit

     SubPathName: stuff.xml
     SubPath:

     SubPathName: veggies/carrot.xml
     SubPath:     veggies

参见

  • RecursiveDirectoryIterator::getSubPathName() - Get sub path and name
  • RecursiveDirectoryIterator::key() - Return path and filename of current dir entry


Get sub path and name

  • ? RecursiveDirectoryIterator::getSubPath
  • RecursiveDirectoryIterator::hasChildren ?
  • PHP Manual
  • RecursiveDirectoryIterator
  • Get sub path and name

RecursiveDirectoryIterator::getSubPathname

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getSubPathname — Get sub path and name

说明

public RecursiveDirectoryIterator::getSubPathname ( ) : string

Gets the sub path and filename.

参数

此函数没有参数。

返回值

The sub path (sub directory) and filename.

范例

Example #1 getSubPathname() example

$directory = '/tmp';

      $it = new RecursiveIteratorIterator(new RecursiveDirectoryIterator($directory));

      foreach ($it as $file) {
          echo 'SubPathName: ' . $it->getSubPathName() . "\n";
          echo 'SubPath:     ' . $it->getSubPath() . "\n\n";
      }

以上例程的输出类似于：

     SubPathName: fruit/apple.xml
     SubPath:     fruit

     SubPathName: stuff.xml
     SubPath:

     SubPathName: veggies/carrot.xml
     SubPath:     veggies

参见

  • RecursiveDirectoryIterator::getSubPath() - Get sub path
  • RecursiveDirectoryIterator::key() - Return path and filename of current dir entry


Returns whether current entry is a directory and not '.' or '..'

  • ? RecursiveDirectoryIterator::getSubPathname
  • RecursiveDirectoryIterator::key ?
  • PHP Manual
  • RecursiveDirectoryIterator
  • Returns whether current entry is a directory and not '.' or '..'

RecursiveDirectoryIterator::hasChildren

(PHP 5, PHP 7)

RecursiveDirectoryIterator::hasChildren — Returns whether current entry is a directory and not '.' or '..'

说明

public RecursiveDirectoryIterator::hasChildren ( bool $allow_links = false ) : bool
Warning

本函数还未编写文档，仅有参数列表。

参数

allow_links

返回值

Returns whether the current entry is a directory, but not '.' or '..'


Return path and filename of current dir entry

  • ? RecursiveDirectoryIterator::hasChildren
  • RecursiveDirectoryIterator::next ?
  • PHP Manual
  • RecursiveDirectoryIterator
  • Return path and filename of current dir entry

RecursiveDirectoryIterator::key

(PHP 5, PHP 7)

RecursiveDirectoryIterator::key — Return path and filename of current dir entry

说明

public RecursiveDirectoryIterator::key ( ) : string
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The path and filename of the current dir entry.


Move to next entry

  • ? RecursiveDirectoryIterator::key
  • RecursiveDirectoryIterator::rewind ?
  • PHP Manual
  • RecursiveDirectoryIterator
  • Move to next entry

RecursiveDirectoryIterator::next

(PHP 5, PHP 7)

RecursiveDirectoryIterator::next — Move to next entry

说明

public RecursiveDirectoryIterator::next ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Rewind dir back to the start

  • ? RecursiveDirectoryIterator::next
  • RecursiveFilterIterator ?
  • PHP Manual
  • RecursiveDirectoryIterator
  • Rewind dir back to the start

RecursiveDirectoryIterator::rewind

(PHP 5, PHP 7)

RecursiveDirectoryIterator::rewind — Rewind dir back to the start

说明

public RecursiveDirectoryIterator::rewind ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


The RecursiveFilterIterator class

(PHP 5 >= 5.1.0, PHP 7)

简介

This abstract iterator filters out unwanted values for a RecursiveIterator. This class should be extended to implement custom filters. The RecursiveFilterIterator::accept() must be implemented in the subclass.

类摘要

abstract RecursiveFilterIterator extends FilterIterator implements OuterIterator , RecursiveIterator {
/* 方法 */
public __construct ( RecursiveIterator $iterator )
public getChildren ( ) : RecursiveFilterIterator
public hasChildren ( ) : bool
/* 继承的方法 */
public abstract FilterIterator::accept ( ) : bool
public FilterIterator::__construct ( Iterator $iterator )
public FilterIterator::current ( ) : mixed
public FilterIterator::getInnerIterator ( ) : Iterator
public FilterIterator::key ( ) : mixed
public FilterIterator::next ( ) : void
public FilterIterator::rewind ( ) : void
public FilterIterator::valid ( ) : bool
}

Table of Contents

  • RecursiveFilterIterator::__construct — Create a RecursiveFilterIterator from a RecursiveIterator
  • RecursiveFilterIterator::getChildren — Return the inner iterator's children contained in a RecursiveFilterIterator
  • RecursiveFilterIterator::hasChildren — Check whether the inner iterator's current element has children


Create a RecursiveFilterIterator from a RecursiveIterator

  • ? RecursiveFilterIterator
  • RecursiveFilterIterator::getChildren ?
  • PHP Manual
  • RecursiveFilterIterator
  • Create a RecursiveFilterIterator from a RecursiveIterator

RecursiveFilterIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::__construct — Create a RecursiveFilterIterator from a RecursiveIterator

说明

public RecursiveFilterIterator::__construct ( RecursiveIterator $iterator )

Create a RecursiveFilterIterator from a RecursiveIterator.

参数

iterator

The RecursiveIterator to be filtered.

返回值

没有返回值。

范例

Example #1 Basic RecursiveFilterIterator() example

<?php
class TestsOnlyFilter extends RecursiveFilterIterator {
    public function accept() {
        // Accept the current item if we can recurse into it
        // or it is a value starting with "test"
        return $this->hasChildren() || (strpos($this->current(), "test") !== FALSE);
    }
}

$array    = array("test1", array("taste2", "test3", "test4"), "test5");
$iterator = new RecursiveArrayIterator($array);
$filter   = new TestsOnlyFilter($iterator);

foreach(new RecursiveIteratorIterator($filter) as $key => $value)
{
    echo $value . "\n";
}
?>

以上例程的输出类似于：

test1
test3
test4
test5

Example #2 RecursiveFilterIterator() example

<?php
class StartsWithFilter extends RecursiveFilterIterator {

    protected $word;

    public function __construct(RecursiveIterator $rit, $word) {
        $this->word = $word;
        parent::__construct($rit);
    }

    public function accept() {
        return $this->hasChildren() OR strpos($this->current(), $this->word) === 0;
    }

    public function getChildren() {
        return new self($this->getInnerIterator()->getChildren(), $this->word);
    }
}

$array    = array("test1", array("taste2", "test3", "test4"), "test5");
$iterator = new RecursiveArrayIterator($array);
$filter   = new StartsWithFilter($iterator, "test");

foreach(new RecursiveIteratorIterator($filter) as $key => $value)
{
    echo $value . "\n";
}
?>

以上例程的输出类似于：

test1
test3
test4
test5

参见

  • RecursiveFilterIterator::getChildren() - Return the inner iterator's children contained in a RecursiveFilterIterator
  • RecursiveFilterIterator::hasChildren() - Check whether the inner iterator's current element has children
  • FilterIterator::accept() - Check whether the current element of the iterator is acceptable


Return the inner iterator's children contained in a RecursiveFilterIterator

  • ? RecursiveFilterIterator::__construct
  • RecursiveFilterIterator::hasChildren ?
  • PHP Manual
  • RecursiveFilterIterator
  • Return the inner iterator's children contained in a RecursiveFilterIterator

RecursiveFilterIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::getChildren — Return the inner iterator's children contained in a RecursiveFilterIterator

说明

public RecursiveFilterIterator::getChildren ( ) : RecursiveFilterIterator

Return the inner iterator's children contained in a RecursiveFilterIterator.

参数

此函数没有参数。

返回值

Returns a RecursiveFilterIterator containing the inner iterator's children.

参见

  • RecursiveFilterIterator::hasChildren() - Check whether the inner iterator's current element has children
  • RecursiveIterator::getChildren() - Returns an iterator for the current entry


Check whether the inner iterator's current element has children

  • ? RecursiveFilterIterator::getChildren
  • RecursiveIteratorIterator ?
  • PHP Manual
  • RecursiveFilterIterator
  • Check whether the inner iterator's current element has children

RecursiveFilterIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::hasChildren — Check whether the inner iterator's current element has children

说明

public RecursiveFilterIterator::hasChildren ( ) : bool

Check whether the inner iterator's current element has children.

参数

此函数没有参数。

返回值

true if the inner iterator has children, otherwise false

参见

  • RecursiveFilterIterator::getChildren() - Return the inner iterator's children contained in a RecursiveFilterIterator
  • RecursiveIterator::hasChildren() - Returns if an iterator can be created for the current entry


The RecursiveIteratorIterator class

(PHP 5, PHP 7)

简介

Can be used to iterate through recursive iterators.

类摘要

RecursiveIteratorIterator implements OuterIterator {
/* 常量 */
const int LEAVES_ONLY = 0 ;
const int SELF_FIRST = 1 ;
const int CHILD_FIRST = 2 ;
const int CATCH_GET_CHILD = 16 ;
/* 方法 */
public beginChildren ( ) : void
public beginIteration ( ) : void
public callGetChildren ( ) : RecursiveIterator
public callHasChildren ( ) : bool
public __construct ( Traversable $iterator , int $mode = RecursiveIteratorIterator::LEAVES_ONLY , int $flags = 0 )
public current ( ) : mixed
public endChildren ( ) : void
public endIteration ( ) : void
public getDepth ( ) : int
public getInnerIterator ( ) : iterator
public getMaxDepth ( ) : mixed
public getSubIterator ( int $level = ? ) : RecursiveIterator
public key ( ) : mixed
public next ( ) : void
public nextElement ( ) : void
public rewind ( ) : void
public setMaxDepth ( int $max_depth = -1 ) : void
public valid ( ) : bool
/* 继承的方法 */
public OuterIterator::getInnerIterator ( ) : Iterator
}

预定义常量

RecursiveIteratorIterator::LEAVES_ONLY

RecursiveIteratorIterator::SELF_FIRST

RecursiveIteratorIterator::CHILD_FIRST

RecursiveIteratorIterator::CATCH_GET_CHILD

Table of Contents

  • RecursiveIteratorIterator::beginChildren — Begin children
  • RecursiveIteratorIterator::beginIteration — Begin Iteration
  • RecursiveIteratorIterator::callGetChildren — Get children
  • RecursiveIteratorIterator::callHasChildren — Has children
  • RecursiveIteratorIterator::__construct — Construct a RecursiveIteratorIterator
  • RecursiveIteratorIterator::current — Access the current element value
  • RecursiveIteratorIterator::endChildren — End children
  • RecursiveIteratorIterator::endIteration — End Iteration
  • RecursiveIteratorIterator::getDepth — Get the current depth of the recursive iteration
  • RecursiveIteratorIterator::getInnerIterator — Get inner iterator
  • RecursiveIteratorIterator::getMaxDepth — Get max depth
  • RecursiveIteratorIterator::getSubIterator — The current active sub iterator
  • RecursiveIteratorIterator::key — Access the current key
  • RecursiveIteratorIterator::next — Move forward to the next element
  • RecursiveIteratorIterator::nextElement — Next element
  • RecursiveIteratorIterator::rewind — Rewind the iterator to the first element of the top level inner iterator
  • RecursiveIteratorIterator::setMaxDepth — Set max depth
  • RecursiveIteratorIterator::valid — Check whether the current position is valid


Begin children

  • ? RecursiveIteratorIterator
  • RecursiveIteratorIterator::beginIteration ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Begin children

RecursiveIteratorIterator::beginChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::beginChildren — Begin children

说明

public RecursiveIteratorIterator::beginChildren ( ) : void

Is called after calling RecursiveIteratorIterator::getChildren(), and its associated RecursiveIteratorIterator::rewind().

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Begin Iteration

  • ? RecursiveIteratorIterator::beginChildren
  • RecursiveIteratorIterator::callGetChildren ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Begin Iteration

RecursiveIteratorIterator::beginIteration

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::beginIteration — Begin Iteration

说明

public RecursiveIteratorIterator::beginIteration ( ) : void

Called when iteration begins (after the first RecursiveIteratorIterator::rewind() call.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Get children

  • ? RecursiveIteratorIterator::beginIteration
  • RecursiveIteratorIterator::callHasChildren ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Get children

RecursiveIteratorIterator::callGetChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::callGetChildren — Get children

说明

public RecursiveIteratorIterator::callGetChildren ( ) : RecursiveIterator

Get children of the current element.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A RecursiveIterator().


Has children

  • ? RecursiveIteratorIterator::callGetChildren
  • RecursiveIteratorIterator::__construct ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Has children

RecursiveIteratorIterator::callHasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::callHasChildren — Has children

说明

public RecursiveIteratorIterator::callHasChildren ( ) : bool

Called for each element to test whether it has children.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the element has children, otherwise false


Construct a RecursiveIteratorIterator

  • ? RecursiveIteratorIterator::callHasChildren
  • RecursiveIteratorIterator::current ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Construct a RecursiveIteratorIterator

RecursiveIteratorIterator::__construct

(PHP 5 >= 5.1.3, PHP 7)

RecursiveIteratorIterator::__construct — Construct a RecursiveIteratorIterator

说明

public RecursiveIteratorIterator::__construct ( Traversable $iterator , int $mode = RecursiveIteratorIterator::LEAVES_ONLY , int $flags = 0 )

Creates a RecursiveIteratorIterator from a RecursiveIterator.

参数

iterator

The iterator being constructed from. Either a RecursiveIterator or IteratorAggregate.

mode

Optional mode. Possible values are

  • RecursiveIteratorIterator::LEAVES_ONLY - The default. Lists only leaves in iteration.
  • RecursiveIteratorIterator::SELF_FIRST - Lists leaves and parents in iteration with parents coming first.
  • RecursiveIteratorIterator::CHILD_FIRST - Lists leaves and parents in iteration with leaves coming first.

flags

Optional flag. Possible values are RecursiveIteratorIterator::CATCH_GET_CHILD which will then ignore exceptions thrown in calls to RecursiveIteratorIterator::getChildren().

返回值

没有返回值。

范例

Example #1 Iterating a RecursiveIteratorIterator

<?php
$array = array(
    array(
        array(
            array(
                'leaf-0-0-0-0',
                'leaf-0-0-0-1'
            ),
            'leaf-0-0-0'
        ),
        array(
            array(
                'leaf-0-1-0-0',
                'leaf-0-1-0-1'
            ),
            'leaf-0-1-0'
        ),
        'leaf-0-0'
    )
);

$iterator = new RecursiveIteratorIterator(
    new RecursiveArrayIterator($array),
    $mode
);
foreach ($iterator as $key => $leaf) {
    echo "$key => $leaf", PHP_EOL;
}
?>

Output with $mode = RecursiveIteratorIterator::LEAVES_ONLY

0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
0 => leaf-0-0-0
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
0 => leaf-0-1-0
0 => leaf-0-0

Output with $mode = RecursiveIteratorIterator::SELF_FIRST

0 => Array
0 => Array
0 => Array
0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
1 => leaf-0-0-0
1 => Array
0 => Array
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
1 => leaf-0-1-0
2 => leaf-0-0

Output with $mode = RecursiveIteratorIterator::CHILD_FIRST

0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
0 => Array
1 => leaf-0-0-0
0 => Array
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
0 => Array
1 => leaf-0-1-0
1 => Array
2 => leaf-0-0
0 => Array


Access the current element value

  • ? RecursiveIteratorIterator::__construct
  • RecursiveIteratorIterator::endChildren ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Access the current element value

RecursiveIteratorIterator::current

(PHP 5, PHP 7)

RecursiveIteratorIterator::current — Access the current element value

说明

public RecursiveIteratorIterator::current ( ) : mixed
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The current elements value.


End children

  • ? RecursiveIteratorIterator::current
  • RecursiveIteratorIterator::endIteration ?
  • PHP Manual
  • RecursiveIteratorIterator
  • End children

RecursiveIteratorIterator::endChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::endChildren — End children

说明

public RecursiveIteratorIterator::endChildren ( ) : void

Called when end recursing one level.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


End Iteration

  • ? RecursiveIteratorIterator::endChildren
  • RecursiveIteratorIterator::getDepth ?
  • PHP Manual
  • RecursiveIteratorIterator
  • End Iteration

RecursiveIteratorIterator::endIteration

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::endIteration — End Iteration

说明

public RecursiveIteratorIterator::endIteration ( ) : void

Called when the iteration ends (when RecursiveIteratorIterator::valid() first returns false.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Get the current depth of the recursive iteration

  • ? RecursiveIteratorIterator::endIteration
  • RecursiveIteratorIterator::getInnerIterator ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Get the current depth of the recursive iteration

RecursiveIteratorIterator::getDepth

(PHP 5, PHP 7)

RecursiveIteratorIterator::getDepth — Get the current depth of the recursive iteration

说明

public RecursiveIteratorIterator::getDepth ( ) : int
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The current depth of the recursive iteration.


Get inner iterator

  • ? RecursiveIteratorIterator::getDepth
  • RecursiveIteratorIterator::getMaxDepth ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Get inner iterator

RecursiveIteratorIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::getInnerIterator — Get inner iterator

说明

public RecursiveIteratorIterator::getInnerIterator ( ) : iterator

Gets the current active sub iterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The current active sub iterator.


Get max depth

  • ? RecursiveIteratorIterator::getInnerIterator
  • RecursiveIteratorIterator::getSubIterator ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Get max depth

RecursiveIteratorIterator::getMaxDepth

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::getMaxDepth — Get max depth

说明

public RecursiveIteratorIterator::getMaxDepth ( ) : mixed

Gets the maximum allowable depth.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The maximum accepted depth, or false if any depth is allowed.

参见

  • RecursiveIteratorIterator::setMaxDepth() - Set max depth


The current active sub iterator

  • ? RecursiveIteratorIterator::getMaxDepth
  • RecursiveIteratorIterator::key ?
  • PHP Manual
  • RecursiveIteratorIterator
  • The current active sub iterator

RecursiveIteratorIterator::getSubIterator

(PHP 5, PHP 7)

RecursiveIteratorIterator::getSubIterator — The current active sub iterator

说明

public RecursiveIteratorIterator::getSubIterator ( int $level = ? ) : RecursiveIterator
Warning

本函数还未编写文档，仅有参数列表。

参数

level

返回值

The current active sub iterator.


Access the current key

  • ? RecursiveIteratorIterator::getSubIterator
  • RecursiveIteratorIterator::next ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Access the current key

RecursiveIteratorIterator::key

(PHP 5, PHP 7)

RecursiveIteratorIterator::key — Access the current key

说明

public RecursiveIteratorIterator::key ( ) : mixed
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The current key.


Move forward to the next element

  • ? RecursiveIteratorIterator::key
  • RecursiveIteratorIterator::nextElement ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Move forward to the next element

RecursiveIteratorIterator::next

(PHP 5, PHP 7)

RecursiveIteratorIterator::next — Move forward to the next element

说明

public RecursiveIteratorIterator::next ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Next element

  • ? RecursiveIteratorIterator::next
  • RecursiveIteratorIterator::rewind ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Next element

RecursiveIteratorIterator::nextElement

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::nextElement — Next element

说明

public RecursiveIteratorIterator::nextElement ( ) : void

Called when the next element is available.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Rewind the iterator to the first element of the top level inner iterator

  • ? RecursiveIteratorIterator::nextElement
  • RecursiveIteratorIterator::setMaxDepth ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Rewind the iterator to the first element of the top level inner iterator

RecursiveIteratorIterator::rewind

(PHP 5, PHP 7)

RecursiveIteratorIterator::rewind — Rewind the iterator to the first element of the top level inner iterator

说明

public RecursiveIteratorIterator::rewind ( ) : void
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Set max depth

  • ? RecursiveIteratorIterator::rewind
  • RecursiveIteratorIterator::valid ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Set max depth

RecursiveIteratorIterator::setMaxDepth

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::setMaxDepth — Set max depth

说明

public RecursiveIteratorIterator::setMaxDepth ( int $max_depth = -1 ) : void

Set the maximum allowed depth.

Warning

本函数还未编写文档，仅有参数列表。

参数

max_depth

The maximum allowed depth. -1 is used for any depth.

返回值

没有返回值。

错误／异常

Emits an Exception if max_depth is less than -1.


Check whether the current position is valid

  • ? RecursiveIteratorIterator::setMaxDepth
  • RecursiveRegexIterator ?
  • PHP Manual
  • RecursiveIteratorIterator
  • Check whether the current position is valid

RecursiveIteratorIterator::valid

(PHP 5, PHP 7)

RecursiveIteratorIterator::valid — Check whether the current position is valid

说明

public RecursiveIteratorIterator::valid ( ) : bool
Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the current position is valid, otherwise false


The RecursiveRegexIterator class

(PHP 5 >= 5.2.0, PHP 7)

简介

This recursive iterator can filter another recursive iterator via a regular expression.

类摘要

RecursiveRegexIterator extends RegexIterator implements RecursiveIterator {
/* 继承的常量 */
const int MATCH = 0 ;
const int GET_MATCH = 1 ;
const int ALL_MATCHES = 2 ;
const int SPLIT = 3 ;
const int REPLACE = 4 ;
const int USE_KEY = 1 ;
/* 方法 */
public __construct ( RecursiveIterator $iterator , string $regex , int $mode = self::MATCH , int $flags = 0 , int $preg_flags = 0 )
public getChildren ( ) : RecursiveRegexIterator
public hasChildren ( ) : bool
/* 继承的方法 */
public RecursiveIterator::getChildren ( ) : RecursiveIterator
public RecursiveIterator::hasChildren ( ) : bool
public RegexIterator::accept ( ) : bool
public RegexIterator::getFlags ( ) : int
public RegexIterator::getMode ( ) : int
public RegexIterator::getPregFlags ( ) : int
public RegexIterator::getRegex ( ) : string
public RegexIterator::setFlags ( int $flags ) : void
public RegexIterator::setMode ( int $mode ) : void
public RegexIterator::setPregFlags ( int $preg_flags ) : void
}

Table of Contents

  • RecursiveRegexIterator::__construct — Creates a new RecursiveRegexIterator
  • RecursiveRegexIterator::getChildren — Returns an iterator for the current entry
  • RecursiveRegexIterator::hasChildren — Returns whether an iterator can be obtained for the current entry


Creates a new RecursiveRegexIterator

  • ? RecursiveRegexIterator
  • RecursiveRegexIterator::getChildren ?
  • PHP Manual
  • RecursiveRegexIterator
  • Creates a new RecursiveRegexIterator

RecursiveRegexIterator::__construct

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::__construct — Creates a new RecursiveRegexIterator

说明

public RecursiveRegexIterator::__construct ( RecursiveIterator $iterator , string $regex , int $mode = self::MATCH , int $flags = 0 , int $preg_flags = 0 )

Creates a new regular expression iterator.

参数

iterator

The recursive iterator to apply this regex filter to.

regex

The regular expression to match.

mode

Operation mode, see RegexIterator::setMode() for a list of modes.

flags

Special flags, see RegexIterator::setFlags() for a list of available flags.

preg_flags

The regular expression flags. These flags depend on the operation mode parameter:

RegexIterator preg_flags
operation mode | available flags
RecursiveRegexIterator::ALL_MATCHES | See preg_match_all().
RecursiveRegexIterator::GET_MATCH | See preg_match().
RecursiveRegexIterator::MATCH | See preg_match().
RecursiveRegexIterator::REPLACE | none.
RecursiveRegexIterator::SPLIT | See preg_split().

范例

Example #1 RecursiveRegexIterator::__construct() example

Creates a new RegexIterator that filters all strings that start with 'test'.

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $key1 => $value1) {

    if ($rRegexIterator->hasChildren()) {

        // print all children
        echo "Children: ";
        foreach ($rRegexIterator->getChildren() as $key => $value) {
            echo $value . " ";
        }
        echo "\n";
    } else {
        echo "No children\n";
    }

}
?>

以上例程的输出类似于：

No children
Children: test4 test5

参见

  • preg_match() - 执行匹配正则表达式
  • preg_match_all() - 执行一个全局正则表达式匹配
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • preg_split() - 通过一个正则表达式分隔字符串


Returns an iterator for the current entry

  • ? RecursiveRegexIterator::__construct
  • RecursiveRegexIterator::hasChildren ?
  • PHP Manual
  • RecursiveRegexIterator
  • Returns an iterator for the current entry

RecursiveRegexIterator::getChildren

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::getChildren — Returns an iterator for the current entry

说明

public RecursiveRegexIterator::getChildren ( ) : RecursiveRegexIterator

Returns an iterator for the current iterator entry.

参数

此函数没有参数。

返回值

An iterator for the current entry, if it can be iterated over by the inner iterator.

错误／异常

An InvalidArgumentException will be thrown if the current entry does not contain a value that can be iterated over by the inner iterator.

范例

Example #1 RecursiveRegexIterator::getChildren() example

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $key1 => $value1) {

    if ($rRegexIterator->hasChildren()) {

        // print all children
        echo "Children: ";
        foreach ($rRegexIterator->getChildren() as $key => $value) {
            echo $value . " ";
        }
        echo "\n";
    } else {
        echo "No children\n";
    }

}
?>

以上例程会输出：

No children
Children: test4 test5

参见

  • RecursiveRegexIterator::hasChildren() - Returns whether an iterator can be obtained for the current entry


Returns whether an iterator can be obtained for the current entry

  • ? RecursiveRegexIterator::getChildren
  • RecursiveTreeIterator ?
  • PHP Manual
  • RecursiveRegexIterator
  • Returns whether an iterator can be obtained for the current entry

RecursiveRegexIterator::hasChildren

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::hasChildren — Returns whether an iterator can be obtained for the current entry

说明

public RecursiveRegexIterator::hasChildren ( ) : bool

Returns whether an iterator can be obtained for the current entry. This iterator can be obtained via RecursiveRegexIterator::getChildren().

参数

此函数没有参数。

返回值

Returns true if an iterator can be obtained for the current entry, otherwise returns false.

范例

Example #1 RecursiveRegexIterator::hasChildren() example

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $value) {
    var_dump($rRegexIterator->hasChildren());
}
?>

以上例程会输出：

bool(false)
bool(true)

参见

  • RecursiveRegexIterator::getChildren() - Returns an iterator for the current entry


The RecursiveTreeIterator class

(PHP 5 >= 5.3.0, PHP 7)

简介

Allows iterating over a RecursiveIterator to generate an ASCII graphic tree.

类摘要

RecursiveTreeIterator extends RecursiveIteratorIterator implements OuterIterator {
/* 继承的常量 */
const int RecursiveIteratorIterator::LEAVES_ONLY = 0 ;
const int RecursiveIteratorIterator::SELF_FIRST = 1 ;
const int RecursiveIteratorIterator::CHILD_FIRST = 2 ;
const int RecursiveIteratorIterator::CATCH_GET_CHILD = 16 ;
/* 常量 */
const int BYPASS_CURRENT = 4 ;
const int BYPASS_KEY = 8 ;
const int PREFIX_LEFT = 0 ;
const int PREFIX_MID_HAS_NEXT = 1 ;
const int PREFIX_MID_LAST = 2 ;
const int PREFIX_END_HAS_NEXT = 3 ;
const int PREFIX_END_LAST = 4 ;
const int PREFIX_RIGHT = 5 ;
/* 方法 */
public beginChildren ( ) : void
public beginIteration ( ) : RecursiveIterator
public callGetChildren ( ) : RecursiveIterator
public callHasChildren ( ) : bool
public __construct ( RecursiveIterator|IteratorAggregate $it , int $flags = RecursiveTreeIterator::BYPASS_KEY , int $cit_flags = CachingIterator::CATCH_GET_CHILD , int $mode = RecursiveIteratorIterator::SELF_FIRST )
public current ( ) : string
public endChildren ( ) : void
public endIteration ( ) : void
public getEntry ( ) : string
public getPostfix ( ) : string
public getPrefix ( ) : string
public key ( ) : string
public next ( ) : void
public nextElement ( ) : void
public rewind ( ) : void
public setPostfix ( string $postfix ) : void
public setPrefixPart ( int $part , string $value ) : void
public valid ( ) : bool
/* 继承的方法 */
public RecursiveIteratorIterator::beginChildren ( ) : void
public RecursiveIteratorIterator::beginIteration ( ) : void
public RecursiveIteratorIterator::callGetChildren ( ) : RecursiveIterator
public RecursiveIteratorIterator::callHasChildren ( ) : bool
public RecursiveIteratorIterator::__construct ( Traversable $iterator , int $mode = RecursiveIteratorIterator::LEAVES_ONLY , int $flags = 0 )
public RecursiveIteratorIterator::current ( ) : mixed
public RecursiveIteratorIterator::endChildren ( ) : void
public RecursiveIteratorIterator::endIteration ( ) : void
public RecursiveIteratorIterator::getDepth ( ) : int
public RecursiveIteratorIterator::getInnerIterator ( ) : iterator
public RecursiveIteratorIterator::getMaxDepth ( ) : mixed
public RecursiveIteratorIterator::getSubIterator ( int $level = ? ) : RecursiveIterator
public RecursiveIteratorIterator::key ( ) : mixed
public RecursiveIteratorIterator::next ( ) : void
public RecursiveIteratorIterator::nextElement ( ) : void
public RecursiveIteratorIterator::rewind ( ) : void
public RecursiveIteratorIterator::setMaxDepth ( int $max_depth = -1 ) : void
public RecursiveIteratorIterator::valid ( ) : bool
}

预定义常量

RecursiveTreeIterator::BYPASS_CURRENT

RecursiveTreeIterator::BYPASS_KEY

RecursiveTreeIterator::PREFIX_LEFT

RecursiveTreeIterator::PREFIX_MID_HAS_NEXT

RecursiveTreeIterator::PREFIX_MID_LAST

RecursiveTreeIterator::PREFIX_END_HAS_NEXT

RecursiveTreeIterator::PREFIX_END_LAST

RecursiveTreeIterator::PREFIX_RIGHT

Table of Contents

  • RecursiveTreeIterator::beginChildren — Begin children
  • RecursiveTreeIterator::beginIteration — Begin iteration
  • RecursiveTreeIterator::callGetChildren — Get children
  • RecursiveTreeIterator::callHasChildren — Has children
  • RecursiveTreeIterator::__construct — Construct a RecursiveTreeIterator
  • RecursiveTreeIterator::current — Get current element
  • RecursiveTreeIterator::endChildren — End children
  • RecursiveTreeIterator::endIteration — End iteration
  • RecursiveTreeIterator::getEntry — Get current entry
  • RecursiveTreeIterator::getPostfix — Get the postfix
  • RecursiveTreeIterator::getPrefix — Get the prefix
  • RecursiveTreeIterator::key — Get the key of the current element
  • RecursiveTreeIterator::next — Move to next element
  • RecursiveTreeIterator::nextElement — Next element
  • RecursiveTreeIterator::rewind — Rewind iterator
  • RecursiveTreeIterator::setPostfix — Set postfix
  • RecursiveTreeIterator::setPrefixPart — Set a part of the prefix
  • RecursiveTreeIterator::valid — Check validity


Begin children

  • ? RecursiveTreeIterator
  • RecursiveTreeIterator::beginIteration ?
  • PHP Manual
  • RecursiveTreeIterator
  • Begin children

RecursiveTreeIterator::beginChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::beginChildren — Begin children

说明

public RecursiveTreeIterator::beginChildren ( ) : void

Called when recursing one level down.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Begin iteration

  • ? RecursiveTreeIterator::beginChildren
  • RecursiveTreeIterator::callGetChildren ?
  • PHP Manual
  • RecursiveTreeIterator
  • Begin iteration

RecursiveTreeIterator::beginIteration

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::beginIteration — Begin iteration

说明

public RecursiveTreeIterator::beginIteration ( ) : RecursiveIterator

Called when iteration begins (after the first RecursiveTreeIterator::rewind() call).

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A RecursiveIterator.


Get children

  • ? RecursiveTreeIterator::beginIteration
  • RecursiveTreeIterator::callHasChildren ?
  • PHP Manual
  • RecursiveTreeIterator
  • Get children

RecursiveTreeIterator::callGetChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::callGetChildren — Get children

说明

public RecursiveTreeIterator::callGetChildren ( ) : RecursiveIterator

Gets children of the current element.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A RecursiveIterator.


Has children

  • ? RecursiveTreeIterator::callGetChildren
  • RecursiveTreeIterator::__construct ?
  • PHP Manual
  • RecursiveTreeIterator
  • Has children

RecursiveTreeIterator::callHasChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::callHasChildren — Has children

说明

public RecursiveTreeIterator::callHasChildren ( ) : bool

Called for each element to test whether it has children.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if there are children, otherwise false


Construct a RecursiveTreeIterator

  • ? RecursiveTreeIterator::callHasChildren
  • RecursiveTreeIterator::current ?
  • PHP Manual
  • RecursiveTreeIterator
  • Construct a RecursiveTreeIterator

RecursiveTreeIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::__construct — Construct a RecursiveTreeIterator

说明

public RecursiveTreeIterator::__construct
 ( RecursiveIterator|IteratorAggregate $it
, int $flags = RecursiveTreeIterator::BYPASS_KEY
, int $cit_flags = CachingIterator::CATCH_GET_CHILD
, int $mode = RecursiveIteratorIterator::SELF_FIRST
)

Constructs a new RecursiveTreeIterator from the supplied recursive iterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

it

The RecursiveIterator or IteratorAggregate to iterate over.

flags

Flags may be provided which will affect the behavior of some methods. A list of the flags can found under RecursiveTreeIterator predefined constants.

caching_it_flags

Flags to affect the behavior of the RecursiveCachingIterator used internally.

mode

Flags to affect the behavior of the RecursiveIteratorIterator used internally.

返回值

没有返回值。


Get current element

  • ? RecursiveTreeIterator::__construct
  • RecursiveTreeIterator::endChildren ?
  • PHP Manual
  • RecursiveTreeIterator
  • Get current element

RecursiveTreeIterator::current

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::current — Get current element

说明

public RecursiveTreeIterator::current ( ) : string

Gets the current element prefixed and postfixed.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns the current element prefixed and postfixed.


End children

  • ? RecursiveTreeIterator::current
  • RecursiveTreeIterator::endIteration ?
  • PHP Manual
  • RecursiveTreeIterator
  • End children

RecursiveTreeIterator::endChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::endChildren — End children

说明

public RecursiveTreeIterator::endChildren ( ) : void

Called when end recursing one level.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


End iteration

  • ? RecursiveTreeIterator::endChildren
  • RecursiveTreeIterator::getEntry ?
  • PHP Manual
  • RecursiveTreeIterator
  • End iteration

RecursiveTreeIterator::endIteration

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::endIteration — End iteration

说明

public RecursiveTreeIterator::endIteration ( ) : void

Called when the iteration ends (when RecursiveTreeIterator::valid() first returns false)

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Get current entry

  • ? RecursiveTreeIterator::endIteration
  • RecursiveTreeIterator::getPostfix ?
  • PHP Manual
  • RecursiveTreeIterator
  • Get current entry

RecursiveTreeIterator::getEntry

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getEntry — Get current entry

说明

public RecursiveTreeIterator::getEntry ( ) : string

Gets the part of the tree built for the current element.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns the part of the tree built for the current element.


Get the postfix

  • ? RecursiveTreeIterator::getEntry
  • RecursiveTreeIterator::getPrefix ?
  • PHP Manual
  • RecursiveTreeIterator
  • Get the postfix

RecursiveTreeIterator::getPostfix

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getPostfix — Get the postfix

说明

public RecursiveTreeIterator::getPostfix ( ) : string

Gets the string to place after the current element.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns the string to place after the current element.


Get the prefix

  • ? RecursiveTreeIterator::getPostfix
  • RecursiveTreeIterator::key ?
  • PHP Manual
  • RecursiveTreeIterator
  • Get the prefix

RecursiveTreeIterator::getPrefix

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getPrefix — Get the prefix

说明

public RecursiveTreeIterator::getPrefix ( ) : string

Gets the string to place in front of current element

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns the string to place in front of current element


Get the key of the current element

  • ? RecursiveTreeIterator::getPrefix
  • RecursiveTreeIterator::next ?
  • PHP Manual
  • RecursiveTreeIterator
  • Get the key of the current element

RecursiveTreeIterator::key

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::key — Get the key of the current element

说明

public RecursiveTreeIterator::key ( ) : string

Gets the current key prefixed and postfixed.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns the current key prefixed and postfixed.


Move to next element

  • ? RecursiveTreeIterator::key
  • RecursiveTreeIterator::nextElement ?
  • PHP Manual
  • RecursiveTreeIterator
  • Move to next element

RecursiveTreeIterator::next

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::next — Move to next element

说明

public RecursiveTreeIterator::next ( ) : void

Moves forward to the next element.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Next element

  • ? RecursiveTreeIterator::next
  • RecursiveTreeIterator::rewind ?
  • PHP Manual
  • RecursiveTreeIterator
  • Next element

RecursiveTreeIterator::nextElement

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::nextElement — Next element

说明

public RecursiveTreeIterator::nextElement ( ) : void

Called when the next element is available.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Rewind iterator

  • ? RecursiveTreeIterator::nextElement
  • RecursiveTreeIterator::setPostfix ?
  • PHP Manual
  • RecursiveTreeIterator
  • Rewind iterator

RecursiveTreeIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::rewind — Rewind iterator

说明

public RecursiveTreeIterator::rewind ( ) : void

Rewinds the iterator to the first element of the top level inner iterator.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Set postfix

  • ? RecursiveTreeIterator::rewind
  • RecursiveTreeIterator::setPrefixPart ?
  • PHP Manual
  • RecursiveTreeIterator
  • Set postfix

RecursiveTreeIterator::setPostfix

(PHP 5 >= 5.5.3, PHP 7)

RecursiveTreeIterator::setPostfix — Set postfix

说明

public RecursiveTreeIterator::setPostfix ( string $postfix ) : void

Sets postfix as used in RecursiveTreeIterator::getPostfix().

Warning

本函数还未编写文档，仅有参数列表。

参数

postfix

返回值

没有返回值。


Set a part of the prefix

  • ? RecursiveTreeIterator::setPostfix
  • RecursiveTreeIterator::valid ?
  • PHP Manual
  • RecursiveTreeIterator
  • Set a part of the prefix

RecursiveTreeIterator::setPrefixPart

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::setPrefixPart — Set a part of the prefix

说明

public RecursiveTreeIterator::setPrefixPart ( int $part , string $value ) : void

Sets a part of the prefix used in the graphic tree.

Warning

本函数还未编写文档，仅有参数列表。

参数

part

One of the RecursiveTreeIterator::PREFIX_* constants.

value

The value to assign to the part of the prefix specified in part.

返回值

没有返回值。


Check validity

  • ? RecursiveTreeIterator::setPrefixPart
  • RegexIterator ?
  • PHP Manual
  • RecursiveTreeIterator
  • Check validity

RecursiveTreeIterator::valid

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::valid — Check validity

说明

public RecursiveTreeIterator::valid ( ) : bool

Check whether the current position is valid.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the current position is valid, otherwise false


The RegexIterator class

(PHP 5 >= 5.2.0, PHP 7)

简介

This iterator can be used to filter another iterator based on a regular expression.

类摘要

RegexIterator extends FilterIterator {
/* 常量 */
const int MATCH = 0 ;
const int GET_MATCH = 1 ;
const int ALL_MATCHES = 2 ;
const int SPLIT = 3 ;
const int REPLACE = 4 ;
const int USE_KEY = 1 ;
/* 方法 */
public __construct ( Iterator $iterator , string $regex , int $mode = self::MATCH , int $flags = 0 , int $preg_flags = 0 )
public accept ( ) : bool
public getFlags ( ) : int
public getMode ( ) : int
public getPregFlags ( ) : int
public getRegex ( ) : string
public setFlags ( int $flags ) : void
public setMode ( int $mode ) : void
public setPregFlags ( int $preg_flags ) : void
/* 继承的方法 */
public abstract FilterIterator::accept ( ) : bool
public FilterIterator::__construct ( Iterator $iterator )
public FilterIterator::current ( ) : mixed
public FilterIterator::getInnerIterator ( ) : Iterator
public FilterIterator::key ( ) : mixed
public FilterIterator::next ( ) : void
public FilterIterator::rewind ( ) : void
public FilterIterator::valid ( ) : bool
}

预定义常量

RegexIterator operation modes

RegexIterator::ALL_MATCHES

Return all matches for the current entry (see preg_match_all()).

RegexIterator::GET_MATCH

Return the first match for the current entry (see preg_match()).

RegexIterator::MATCH

Only execute match (filter) for the current entry (see preg_match()).

RegexIterator::REPLACE

Replace the current entry (see preg_replace(); Not fully implemented yet)

RegexIterator::SPLIT

Returns the split values for the current entry (see preg_split()).

RegexIterator Flags

RegexIterator::USE_KEY

Special flag: Match the entry key instead of the entry value.

Table of Contents

  • RegexIterator::accept — Get accept status
  • RegexIterator::__construct — Create a new RegexIterator
  • RegexIterator::getFlags — Get flags
  • RegexIterator::getMode — Returns operation mode
  • RegexIterator::getPregFlags — Returns the regular expression flags
  • RegexIterator::getRegex — Returns current regular expression
  • RegexIterator::setFlags — Sets the flags
  • RegexIterator::setMode — Sets the operation mode
  • RegexIterator::setPregFlags — Sets the regular expression flags


Get accept status

  • ? RegexIterator
  • RegexIterator::__construct ?
  • PHP Manual
  • RegexIterator
  • Get accept status

RegexIterator::accept

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::accept — Get accept status

说明

public RegexIterator::accept ( ) : bool

Matches (string) RegexIterator::current()
(or RegexIterator::key() if the
RegexIterator::USE_KEY flag is set)
against the regular expression.

参数

此函数没有参数。

返回值

true if a match, false otherwise.

范例

Example #1 RegexIterator::accept() example

This example shows that only items matching the regular expression are accepted.

<?php
$names = new ArrayIterator(array('Ann', 'Bob', 'Charlie', 'David'));
$filter = new RegexIterator($names, '/^[B-D]/');
foreach ($filter as $name) {
    echo $name . PHP_EOL;
}
?>

以上例程会输出：

Bob
Charlie
David

参见

  • RegexIterator constants
  • RegexIterator::setFlags() - Sets the flags


Create a new RegexIterator

  • ? RegexIterator::accept
  • RegexIterator::getFlags ?
  • PHP Manual
  • RegexIterator
  • Create a new RegexIterator

RegexIterator::__construct

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::__construct — Create a new RegexIterator

说明

public RegexIterator::__construct ( Iterator $iterator , string $regex , int $mode = self::MATCH , int $flags = 0 , int $preg_flags = 0 )

Create a new RegexIterator which filters an Iterator using a regular expression.

参数

iterator

The iterator to apply this regex filter to.

regex

The regular expression to match.

mode

Operation mode, see RegexIterator::setMode() for a list of modes.

flags

Special flags, see RegexIterator::setFlags() for a list of available flags.

preg_flags

The regular expression flags. These flags depend on the operation mode parameter:

RegexIterator preg_flags
operation mode | available flags
RegexIterator::ALL_MATCHES | See preg_match_all().
RegexIterator::GET_MATCH | See preg_match().
RegexIterator::MATCH | See preg_match().
RegexIterator::REPLACE | none.
RegexIterator::SPLIT | See preg_split().

错误／异常

Throws an InvalidArgumentException if the regex argument is invalid.

范例

Example #1 RegexIterator::__construct() example

Creates a new RegexIterator that filters all strings that start with 'test'.

<?php
$arrayIterator = new ArrayIterator(array('test 1', 'another test', 'test 123'));
$regexIterator = new RegexIterator($arrayIterator, '/^test/');

foreach ($regexIterator as $value) {
    echo $value . "\n";
}
?>

以上例程的输出类似于：

test 1
test 123

参见

  • preg_match() - 执行匹配正则表达式
  • preg_match_all() - 执行一个全局正则表达式匹配
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • preg_split() - 通过一个正则表达式分隔字符串


Get flags

  • ? RegexIterator::__construct
  • RegexIterator::getMode ?
  • PHP Manual
  • RegexIterator
  • Get flags

RegexIterator::getFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getFlags — Get flags

说明

public RegexIterator::getFlags ( ) : int

Returns the flags, see RegexIterator::setFlags() for a list of available flags.

返回值

Returns the set flags.

范例

Example #1 RegexIterator::getFlags() example

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/');
$regexIterator->setFlags(RegexIterator::USE_KEY);

if ($regexIterator->getFlags() & RegexIterator::USE_KEY) {
    echo 'Filtering based on the array keys.';
} else {
    echo 'Filtering based on the array values.';
}
?>

以上例程会输出：

Filtering based on the array keys.

参见

  • RegexIterator::setFlags() - Sets the flags


Returns operation mode

  • ? RegexIterator::getFlags
  • RegexIterator::getPregFlags ?
  • PHP Manual
  • RegexIterator
  • Returns operation mode

RegexIterator::getMode

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getMode — Returns operation mode

说明

public RegexIterator::getMode ( ) : int

Returns the operation mode, see RegexIterator::setMode() for the list of operation modes.

返回值

Returns the operation mode.

范例

Example #1 RegexIterator::getMode() example

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^[a-z]+/', RegexIterator::GET_MATCH);

$mode = $regexIterator->getMode();
if ($mode & RegexIterator::GET_MATCH) {
    echo 'Getting the match for each item.';
} elseif ($mode & RegexIterator::ALL_MATCHES) {
    echo 'Getting all matches for each item.';
} elseif ($mode & RegexIterator::MATCH) {
    echo 'Getting each item if it matches.';
} elseif ($mode & RegexIterator::SPLIT) {
    echo 'Getting split pieces of each.';
}
?>

以上例程会输出：

Getting the match for each item.

参见

  • RegexIterator::setMode() - Sets the operation mode


Returns the regular expression flags

  • ? RegexIterator::getMode
  • RegexIterator::getRegex ?
  • PHP Manual
  • RegexIterator
  • Returns the regular expression flags

RegexIterator::getPregFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getPregFlags — Returns the regular expression flags

说明

public RegexIterator::getPregFlags ( ) : int

Returns the regular expression flags, see RegexIterator::__construct() for the list of flags.

返回值

Returns a bitmask of the regular expression flags.

范例

Example #1 RegexIterator::getPregFlags() example

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/\s/', RegexIterator::SPLIT);
$regexIterator->setPregFlags(PREG_SPLIT_NO_EMPTY | PREG_SPLIT_OFFSET_CAPTURE);

if ($regexIterator->getPregFlags() & PREG_SPLIT_NO_EMPTY) {
    echo 'Ignoring empty pieces';
} else {
    echo 'Not ignoring empty pieces';
}

?>

以上例程会输出：

Ignoring empty pieces

参见

  • RegexIterator::setPregFlags() - Sets the regular expression flags


Returns current regular expression

  • ? RegexIterator::getPregFlags
  • RegexIterator::setFlags ?
  • PHP Manual
  • RegexIterator
  • Returns current regular expression

RegexIterator::getRegex

(PHP 5 >= 5.4.0, PHP 7)

RegexIterator::getRegex — Returns current regular expression

说明

public RegexIterator::getRegex ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Sets the flags

  • ? RegexIterator::getRegex
  • RegexIterator::setMode ?
  • PHP Manual
  • RegexIterator
  • Sets the flags

RegexIterator::setFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setFlags — Sets the flags

说明

public RegexIterator::setFlags ( int $flags ) : void

Sets the flags.

参数

flags

The flags to set, a bitmask of class constants.

The available flags are listed below. The actual meanings of these flags are described in the predefined constants.

RegexIterator flags
value | constant
1 | RegexIterator::USE_KEY

返回值

没有返回值。

范例

Example #1 RegexIterator::setFlags() example

Creates a new RegexIterator that filters all entries whose key starts with 'test'.

<?php
$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/');
$regexIterator->setFlags(RegexIterator::USE_KEY);

foreach ($regexIterator as $key => $value) {
    echo $key . ' => ' . $value . "\n";
}
?>

以上例程会输出：

teststr2 => another test

参见

  • RegexIterator::getFlags() - Get flags


Sets the operation mode

  • ? RegexIterator::setFlags
  • RegexIterator::setPregFlags ?
  • PHP Manual
  • RegexIterator
  • Sets the operation mode

RegexIterator::setMode

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setMode — Sets the operation mode

说明

public RegexIterator::setMode ( int $mode ) : void

Sets the operation mode.

参数

mode

The operation mode.

The available modes are listed below. The actual meanings of these modes are described in the predefined constants.

RegexIterator modes
value | constant
0 | RegexIterator::MATCH
1 | RegexIterator::GET_MATCH
2 | RegexIterator::ALL_MATCHES
3 | RegexIterator::SPLIT
4 | RegexIterator::REPLACE

返回值

没有返回值。

范例

Example #1 RegexIterator::setMode() example

<?php
$test = array ('str1' => 'test 1', 'test str2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
// Filter everything that starts with 'test ' followed by one or more numbers.
$regexIterator = new RegexIterator($arrayIterator, '/^test (\d+)/');
// Operation mode: Replace actual value with the matches
$regexIterator->setMode(RegexIterator::GET_MATCH);

foreach ($regexIterator as $key => $value) {
    // print out the matched number(s)
    echo $key . ' => ' . $value[1] . PHP_EOL;
}
?>

以上例程的输出类似于：

str1 => 1
str3 => 123

参见

  • RegexIterator::getMode() - Returns operation mode


Sets the regular expression flags

  • ? RegexIterator::setMode
  • 接口 ?
  • PHP Manual
  • RegexIterator
  • Sets the regular expression flags

RegexIterator::setPregFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setPregFlags — Sets the regular expression flags

说明

public RegexIterator::setPregFlags ( int $preg_flags ) : void

Sets the regular expression flags.

参数

preg_flags

The regular expression flags. See RegexIterator::__construct() for an overview of available flags.

返回值

没有返回值。

范例

Example #1 RegexIterator::setPregFlags() example

Creates a new RegexIterator that filters all entries with where the array key starts with 'test'.

<?php
$test = array ('test 1', 'another test', 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/', RegexIterator::GET_MATCH);

$regexIterator->setPregFlags(PREG_OFFSET_CAPTURE);

foreach ($regexIterator as $key => $value) {
    var_dump($value);
}
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(4) "test"
    [1]=>
    int(0)
  }
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(4) "test"
    [1]=>
    int(0)
  }
}

参见

  • RegexIterator::getPregFlags() - Returns the regular expression flags


接口

Table of Contents

  • Countable
  • OuterIterator
  • RecursiveIterator
  • SeekableIterator

SPL 提供一系列接口。

可参考预定义接口。

接口列表

  • Countable
  • OuterIterator
  • RecursiveIterator
  • SeekableIterator
  • SplObserver
  • SplSubject


The Countable interface

(PHP 5 >= 5.1.0, PHP 7)

简介

类实现 Countable 可被用于 count() 函数.

接口摘要

Countable {
/* 方法 */
abstract public count ( ) : int
}

Table of Contents

  • Countable::count — 统计一个对象的元素个数


统计一个对象的元素个数

  • ? Countable
  • OuterIterator ?
  • PHP Manual
  • Countable
  • 统计一个对象的元素个数

Countable::count

(PHP 5 >= 5.1.0, PHP 7)

Countable::count — 统计一个对象的元素个数

说明

abstract public Countable::count ( ) : int

当使用 count()函数作用于一个实现了 Countable的对象时这个方法会被执行.

参数

此函数没有参数。

返回值

The custom count as an integer.

Note:

The return value is cast to an integer.

范例

Example #1 Countable::count() example

<?php
class myCounter implements Countable {
    public function count() {
        static $count = 0;
        return ++$count;
    }
}

$counter = new myCounter;

for($i=0; $i<10; ++$i) {
    echo "I have been count()ed " . count($counter) . " times\n";
}
?>

以上例程的输出类似于：

I have been count()ed 1 times
I have been count()ed 2 times
I have been count()ed 3 times
I have been count()ed 4 times
I have been count()ed 5 times
I have been count()ed 6 times
I have been count()ed 7 times
I have been count()ed 8 times
I have been count()ed 9 times
I have been count()ed 10 times


The OuterIterator interface

(PHP 5 >= 5.1.0, PHP 7)

简介

Classes implementing OuterIterator can be used to iterate over iterators.

接口摘要

OuterIterator extends Iterator {
/* 方法 */
public getInnerIterator ( ) : Iterator
/* 继承的方法 */
abstract public Iterator::current ( ) : mixed
abstract public Iterator::key ( ) : scalar
abstract public Iterator::next ( ) : void
abstract public Iterator::rewind ( ) : void
abstract public Iterator::valid ( ) : bool
}

Table of Contents

  • OuterIterator::getInnerIterator — Returns the inner iterator for the current entry


Returns the inner iterator for the current entry

  • ? OuterIterator
  • RecursiveIterator ?
  • PHP Manual
  • OuterIterator
  • Returns the inner iterator for the current entry

OuterIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

OuterIterator::getInnerIterator — Returns the inner iterator for the current entry

说明

public OuterIterator::getInnerIterator ( ) : Iterator

Returns the inner iterator for the current iterator entry.

参数

此函数没有参数。

返回值

The inner iterator for the current entry.


The RecursiveIterator interface

(PHP 5 >= 5.1.0, PHP 7)

简介

Classes implementing RecursiveIterator can be used to iterate over iterators recursively.

接口摘要

RecursiveIterator extends Iterator {
/* 方法 */
public getChildren ( ) : RecursiveIterator
public hasChildren ( ) : bool
/* 继承的方法 */
abstract public Iterator::current ( ) : mixed
abstract public Iterator::key ( ) : scalar
abstract public Iterator::next ( ) : void
abstract public Iterator::rewind ( ) : void
abstract public Iterator::valid ( ) : bool
}

Table of Contents

  • RecursiveIterator::getChildren — Returns an iterator for the current entry
  • RecursiveIterator::hasChildren — Returns if an iterator can be created for the current entry


Returns an iterator for the current entry

  • ? RecursiveIterator
  • RecursiveIterator::hasChildren ?
  • PHP Manual
  • RecursiveIterator
  • Returns an iterator for the current entry

RecursiveIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIterator::getChildren — Returns an iterator for the current entry

说明

public RecursiveIterator::getChildren ( ) : RecursiveIterator

Returns an iterator for the current iterator entry.

参数

此函数没有参数。

返回值

An iterator for the current entry.

参见

  • RecursiveIterator::hasChildren() - Returns if an iterator can be created for the current entry


Returns if an iterator can be created for the current entry

  • ? RecursiveIterator::getChildren
  • SeekableIterator ?
  • PHP Manual
  • RecursiveIterator
  • Returns if an iterator can be created for the current entry

RecursiveIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIterator::hasChildren — Returns if an iterator can be created for the current entry

说明

public RecursiveIterator::hasChildren ( ) : bool

Returns if an iterator can be created for the current entry. RecursiveIterator::getChildren().

参数

此函数没有参数。

返回值

Returns true if the current entry can be iterated over, otherwise returns false.

参见

  • RecursiveIterator::getChildren() - Returns an iterator for the current entry


The SeekableIterator interface

(PHP 5 >= 5.1.0, PHP 7)

简介

The Seekable iterator.

接口摘要

SeekableIterator extends Iterator {
/* 方法 */
abstract public seek ( int $position ) : void
/* 继承的方法 */
abstract public Iterator::current ( ) : mixed
abstract public Iterator::key ( ) : scalar
abstract public Iterator::next ( ) : void
abstract public Iterator::rewind ( ) : void
abstract public Iterator::valid ( ) : bool
}

Example #1 Basic usage

This example demonstrates creating a custom SeekableIterator, seeking to a position and handling an invalid position.

<?php
class MySeekableIterator implements SeekableIterator {

    private $position;

    private $array = array(
        "first element",
        "second element",
        "third element",
        "fourth element"
    );

    /* Method required for SeekableIterator interface */

    public function seek($position) {
      if (!isset($this->array[$position])) {
          throw new OutOfBoundsException("invalid seek position ($position)");
      }

      $this->position = $position;
    }

    /* Methods required for Iterator interface */

    public function rewind() {
        $this->position = 0;
    }

    public function current() {
        return $this->array[$this->position];
    }

    public function key() {
        return $this->position;
    }

    public function next() {
        ++$this->position;
    }

    public function valid() {
        return isset($this->array[$this->position]);
    }
}

try {

    $it = new MySeekableIterator;
    echo $it->current(), "\n";

    $it->seek(2);
    echo $it->current(), "\n";

    $it->seek(1);
    echo $it->current(), "\n";

    $it->seek(10);

} catch (OutOfBoundsException $e) {
    echo $e->getMessage();
}
?>

以上例程的输出类似于：

first element
third element
second element
invalid seek position (10)

Table of Contents

  • SeekableIterator::seek — Seeks to a position


Seeks to a position

  • ? SeekableIterator
  • 异常 ?
  • PHP Manual
  • SeekableIterator
  • Seeks to a position

SeekableIterator::seek

(PHP 5 >= 5.1.0, PHP 7)

SeekableIterator::seek — Seeks to a position

说明

abstract public SeekableIterator::seek ( int $position ) : void

Seeks to a given position in the iterator.

参数

position

The position to seek to.

返回值

没有返回值。

错误／异常

Implementations should throw an OutOfBoundsException if the position is not seekable.

范例

Example #1 SeekableIterator::seek() example

Seek to the item at position 3 in the iterator (ArrayIterator implements SeekableIterator).

<?php
$array = array("apple", "banana", "cherry", "damson", "elderberry");
$iterator = new ArrayIterator($array);
$iterator->seek(3);
echo $iterator->current();
?>

以上例程的输出类似于：

damson

参见

  • SeekableIterator
  • Iterator


异常

Table of Contents

  • BadFunctionCallException
  • BadMethodCallException
  • DomainException
  • InvalidArgumentException
  • LengthException
  • LogicException
  • OutOfBoundsException
  • OutOfRangeException
  • OverflowException
  • RangeException
  • RuntimeException
  • UnderflowException
  • UnexpectedValueException

SPL 提供一系列标准异常。

可参考预定义异常。

SPL Exceptions Class Tree

  • LogicException (extends Exception)
    • BadFunctionCallException
      • BadMethodCallException
    • DomainException
    • InvalidArgumentException
    • LengthException
    • OutOfRangeException
  • RuntimeException (extends Exception)
    • OutOfBoundsException
    • OverflowException
    • RangeException
    • UnderflowException
    • UnexpectedValueException


The BadFunctionCallException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown if a callback refers to an undefined function or if some arguments are missing.

类摘要

BadFunctionCallException extends LogicException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The BadMethodCallException class

(PHP 5 >= 5.1.0, PHP 7)

简介

当一个回调方法是一个未定义的方法或缺失一些参数时会抛出该异常。

类摘要

BadMethodCallException extends BadFunctionCallException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The DomainException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown if a value does not adhere to a defined valid data domain.

类摘要

DomainException extends LogicException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The InvalidArgumentException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown if an argument is not of the expected type.

类摘要

InvalidArgumentException extends LogicException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LengthException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown if a length is invalid.

类摘要

LengthException extends LogicException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The LogicException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception that represents error in the program logic. This kind of exception should lead directly to a fix in your code.

类摘要

LogicException extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The OutOfBoundsException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown if a value is not a valid key. This represents errors that cannot be detected at compile time.

类摘要

OutOfBoundsException extends RuntimeException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The OutOfRangeException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown when an illegal index was requested. This represents errors that should be detected at compile time.

类摘要

OutOfRangeException extends LogicException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The OverflowException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown when adding an element to a full container.

类摘要

OverflowException extends RuntimeException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The RangeException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown to indicate range errors during program execution. Normally this means there was an arithmetic error other than under/overflow. This is the runtime version of DomainException.

类摘要

RangeException extends RuntimeException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The RuntimeException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown if an error which can only be found on runtime occurs.

类摘要

RuntimeException extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The UnderflowException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown when performing an invalid operation on an empty container, such as removing an element.

类摘要

UnderflowException extends RuntimeException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The UnexpectedValueException class

(PHP 5 >= 5.1.0, PHP 7)

简介

Exception thrown if a value does not match with a set of values. Typically this happens when a function calls another function and expects the return value to be of a certain type or value not including arithmetic or buffer related errors.

类摘要

UnexpectedValueException extends RuntimeException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
public Exception::__construct ( string $message = "" , int $code = 0 , Throwable $previous = null )
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


SPL 函数

Table of Contents

  • class_implements — 返回指定的类实现的所有接口。
  • class_parents — 返回指定类的父类。
  • class_uses — Return the traits used by the given class
  • iterator_apply — 为迭代器中每个元素调用一个用户自定义函数
  • iterator_count — 计算迭代器中元素的个数
  • iterator_to_array — 将迭代器中的元素拷贝到数组
  • spl_autoload_call — 尝试调用所有已注册的 __autoload() 函数来装载请求类
  • spl_autoload_extensions — 注册并返回 spl_autoload 函数使用的默认文件扩展名
  • spl_autoload_functions — 返回所有已注册的 __autoload() 函数
  • spl_autoload_register — 注册给定的函数作为 __autoload 的实现
  • spl_autoload_unregister — 注销已注册的 __autoload() 函数
  • spl_autoload — __autoload()函数的默认实现
  • spl_classes — 返回所有可用的SPL类
  • spl_object_hash — 返回指定对象的hash id
  • spl_object_id — Return the integer object handle for given object


返回指定的类实现的所有接口。

  • ? SPL 函数
  • class_parents ?
  • PHP Manual
  • SPL 函数
  • 返回指定的类实现的所有接口。

class_implements

(PHP 5, PHP 7)

class_implements — 返回指定的类实现的所有接口。

说明

class_implements ( mixed $class , bool $autoload = ? ) : array

本函数返回一个数组，该数组中包含了指定类class及其父类所实现的所有接口的名称。

参数

class

对象（类实例）或字符串（类名称）。

autoload

是否允许使用__autoload 魔术函数来自动装载该类。默认值为true。

返回值

调用成功则返回一个数组，否则返回false。

更新日志

版本 | 说明
5.1.0 | 增加了允许参数class为字符串的选项。增加了autoload参数。

范例

Example #1 class_implements() example

<?php

interface foo { }
class bar implements foo {}

print_r(class_implements(new bar));

// since PHP 5.1.0 you may also specify the parameter as a string
print_r(class_implements('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// use __autoload to load the 'not_loaded' class
print_r(class_implements('not_loaded', true));

?>

以上例程的输出类似于：

Array
(
    [foo] => foo
)

Array
(
    [interface_of_not_loaded] => interface_of_not_loaded
)

参见

  • class_parents() - 返回指定类的父类。
  • get_declared_interfaces() - 返回一个数组包含所有已声明的接口


返回指定类的父类。

  • ? class_implements
  • class_uses ?
  • PHP Manual
  • SPL 函数
  • 返回指定类的父类。

class_parents

(PHP 5, PHP 7)

class_parents — 返回指定类的父类。

说明

class_parents ( mixed $class , bool $autoload = ? ) : array

本函数返回一个包含了指定类class父类名称的数组。

参数

class

对象（类实例）或字符串（类名称）。

autoload

是否允许使用__autoload 魔术函数来自动装载该类。默认值为true。

返回值

调用成功则返回一个数组，否则返回false。

更新日志

版本 | 说明
5.1.0 | 增加了允许参数class为字符串的选项。增加了autoload参数。

范例

Example #1 class_parents() example

<?php

class foo { }
class bar extends foo {}

print_r(class_parents(new bar));

// since PHP 5.1.0 you may also specify the parameter as a string
print_r(class_parents('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// use __autoload to load the 'not_loaded' class
print_r(class_parents('not_loaded', true));
?>

以上例程的输出类似于：

Array
(
    [foo] => foo
)

Array
(
    [parent_of_not_loaded] => parent_of_not_loaded
)

参见

  • class_implements() - 返回指定的类实现的所有接口。


Return the traits used by the given class

  • ? class_parents
  • iterator_apply ?
  • PHP Manual
  • SPL 函数
  • Return the traits used by the given class

class_uses

(PHP 5 >= 5.4.0, PHP 7)

class_uses — Return the traits used by the given class

说明

class_uses ( mixed $class , bool $autoload = true ) : array

This function returns an array with the names of the traits that the given class uses. This does however not include any traits used by a parent class.

参数

class

An object (class instance) or a string (class name).

autoload

Whether to allow this function to load the class automatically through the __autoload() magic method.

返回值

An array on success, or false on error.

范例

Example #1 class_uses() example

<?php

trait foo { }
class bar {
  use foo;
}

print_r(class_uses(new bar));

print_r(class_uses('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// use __autoload to load the 'not_loaded' class
print_r(class_uses('not_loaded', true));

?>

以上例程的输出类似于：

Array
(
    [foo] => foo
)

Array
(
    [foo] => foo
)

Array
(
    [trait_of_not_loaded] => trait_of_not_loaded
)

参见

  • class_parents() - 返回指定类的父类。
  • get_declared_traits() - 返回所有已定义的 traits 的数组


为迭代器中每个元素调用一个用户自定义函数

  • ? class_uses
  • iterator_count ?
  • PHP Manual
  • SPL 函数
  • 为迭代器中每个元素调用一个用户自定义函数

iterator_apply

(PHP 5 >= 5.1.0, PHP 7)

iterator_apply — 为迭代器中每个元素调用一个用户自定义函数

说明

iterator_apply ( Traversable $iterator , callable $function , array $args = ? ) : int

循环迭代每个元素时调用某一回调函数。

参数

iterator

需要循环迭代的类对象。

function

迭代到每个元素时的调用的回调函数。

Note: 为了遍历 iterator 这个函数必须返回 true。

args

传递到回调函数的参数。

返回值

返回已迭代的元素个数。

范例

Example #1 iterator_apply() example

<?php
function print_caps(Iterator $iterator) {
    echo strtoupper($iterator->current()) . "\n";
    return TRUE;
}

$it = new ArrayIterator(array("Apples", "Bananas", "Cherries"));
iterator_apply($it, "print_caps", array($it));
?>

以上例程会输出：

APPLES
BANANAS
CHERRIES

参见

  • array_walk() - 使用用户自定义函数对数组中的每个元素做回调处理


计算迭代器中元素的个数

  • ? iterator_apply
  • iterator_to_array ?
  • PHP Manual
  • SPL 函数
  • 计算迭代器中元素的个数

iterator_count

(PHP 5 >= 5.1.0, PHP 7)

iterator_count — 计算迭代器中元素的个数

说明

iterator_count ( Traversable $iterator ) : int

计算迭代器中的元素个数。

参数

iterator

要计数的迭代器。

返回值

迭代器iterator中的元素个数。

范例

Example #1 iterator_count() example

<?php
$iterator = new ArrayIterator(array('recipe'=>'pancakes', 'egg', 'milk', 'flour'));
var_dump(iterator_count($iterator));
?>

以上例程会输出：

int(4)


将迭代器中的元素拷贝到数组

  • ? iterator_count
  • spl_autoload_call ?
  • PHP Manual
  • SPL 函数
  • 将迭代器中的元素拷贝到数组

iterator_to_array

(PHP 5 >= 5.1.0, PHP 7)

iterator_to_array — 将迭代器中的元素拷贝到数组

说明

iterator_to_array ( Traversable $iterator , bool $use_keys = true ) : array

将迭代器中的元素拷贝到数组。

参数

iterator

被拷贝的迭代器。

use_keys

是否使用迭代器元素键作为索引。

返回值

一个数组，包含迭代器中的元素。

更新日志

版本 | 说明
5.2.1 | 添加了 use_keys 参数。

范例

Example #1 iterator_to_array() example

<?php
$iterator = new ArrayIterator(array('recipe'=>'pancakes', 'egg', 'milk', 'flour'));
var_dump(iterator_to_array($iterator, true));
var_dump(iterator_to_array($iterator, false));
?>

以上例程会输出：

array(4) {
  ["recipe"]=>
  string(8) "pancakes"
  [0]=>
  string(3) "egg"
  [1]=>
  string(4) "milk"
  [2]=>
  string(5) "flour"
}
array(4) {
  [0]=>
  string(8) "pancakes"
  [1]=>
  string(3) "egg"
  [2]=>
  string(4) "milk"
  [3]=>
  string(5) "flour"
}


尝试调用所有已注册的 __autoload() 函数来装载请求类

  • ? iterator_to_array
  • spl_autoload_extensions ?
  • PHP Manual
  • SPL 函数
  • 尝试调用所有已注册的 __autoload() 函数来装载请求类

spl_autoload_call

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_call — 尝试调用所有已注册的 __autoload() 函数来装载请求类

说明

spl_autoload_call ( string $class_name ) : void

可以直接在程序中手动调用此函数来使用所有已注册的 __autoload 函数装载类或接口。

参数

class_name

搜索的类名。

返回值

没有返回值。


注册并返回 spl_autoload 函数使用的默认文件扩展名

  • ? spl_autoload_call
  • spl_autoload_functions ?
  • PHP Manual
  • SPL 函数
  • 注册并返回 spl_autoload 函数使用的默认文件扩展名

spl_autoload_extensions

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_extensions — 注册并返回 spl_autoload 函数使用的默认文件扩展名

说明

spl_autoload_extensions ( string $file_extensions = ? ) : string

本函数用来修改和检查 __autoload() 函数内置的默认实现函数 spl_autoload() 所使用的扩展名。

Note: 在定义的文件扩展名之间不应该有空格。

参数

file_extensions

当不使用任何参数调用此函数时，它返回当前的文件扩展名的列表，不同的扩展名用逗号分隔。要修改文件扩展名列表，用一个逗号分隔的新的扩展名列表字符串来调用本函数即可。中文注：默认的 spl_autoload 函数使用的扩展名是 ".inc,.php"。

返回值

逗号分隔的 spl_autoload() 函数的默认文件扩展名。

范例

Example #1 spl_autoload_extensions() 示例

<?php
spl_autoload_extensions(".php,.inc");
?>


返回所有已注册的 __autoload() 函数

  • ? spl_autoload_extensions
  • spl_autoload_register ?
  • PHP Manual
  • SPL 函数
  • 返回所有已注册的 __autoload() 函数

spl_autoload_functions

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_functions — 返回所有已注册的 __autoload() 函数

说明

spl_autoload_functions ( ) : array

获取所有已注册的 __autoload() 函数。

参数

此函数没有参数。

返回值

包含所有已注册的 __autoload 函数的数组（array）。如果自动装载函数队列未激活，则返回 false。如果没有已注册的函数，则返回一个空数组。


注册给定的函数作为 __autoload 的实现

  • ? spl_autoload_functions
  • spl_autoload_unregister ?
  • PHP Manual
  • SPL 函数
  • 注册给定的函数作为 __autoload 的实现

spl_autoload_register

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_register — 注册给定的函数作为 __autoload 的实现

说明

spl_autoload_register ( callable $autoload_function = ? , bool $throw = true , bool $prepend = false ) : bool

将函数注册到SPL __autoload函数队列中。如果该队列中的函数尚未激活，则激活它们。

如果在你的程序中已经实现了__autoload()函数，它必须显式注册到__autoload()队列中。因为 spl_autoload_register()函数会将Zend Engine中的__autoload()函数取代为spl_autoload()或spl_autoload_call()。

如果需要多条 autoload 函数，spl_autoload_register() 满足了此类需求。 它实际上创建了 autoload 函数的队列，按定义时的顺序逐个执行。相比之下， __autoload() 只可以定义一次。

参数

autoload_function

欲注册的自动装载函数。如果没有提供任何参数，则自动注册 autoload 的默认实现函数spl_autoload()。

throw

此参数设置了 autoload_function 无法成功注册时， spl_autoload_register()是否抛出异常。

prepend

如果是 true，spl_autoload_register() 会添加函数到队列之首，而不是队列尾部。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.3.0 | 引入了命名空间的支持。
5.3.0 | 添加了 prepend 参数。

范例

Example #1 spl_autoload_register() 作为 __autoload() 函数的替代

<?php

// function __autoload($class) {
//     include 'classes/' . $class . '.class.php';
// }

function my_autoloader($class) {
    include 'classes/' . $class . '.class.php';
}

spl_autoload_register('my_autoloader');

// 或者，自 PHP 5.3.0 起可以使用一个匿名函数
spl_autoload_register(function ($class) {
    include 'classes/' . $class . '.class.php';
});

?>

Example #2 class 未能加载的 spl_autoload_register() 例子

<?php

namespace Foobar;

class Foo {
    static public function test($name) {
        print '[['. $name .']]';
    }
}

spl_autoload_register(__NAMESPACE__ .'\Foo::test'); // 自 PHP 5.3.0 起

new InexistentClass;

?>

以上例程的输出类似于：

[[Foobar\InexistentClass]]
Fatal error: Class 'Foobar\InexistentClass' not found in ...

参见

  • __autoload() - 尝试加载未定义的类


注销已注册的 __autoload() 函数

  • ? spl_autoload_register
  • spl_autoload ?
  • PHP Manual
  • SPL 函数
  • 注销已注册的 __autoload() 函数

spl_autoload_unregister

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload_unregister — 注销已注册的 __autoload() 函数

说明

spl_autoload_unregister ( mixed $autoload_function ) : bool

从 autoload 自动装载函数队列中移除指定的函数。如果该函数队列处于激活状态，并且在给定函数注销后该队列变为空，则该函数队列将会变为无效。

如果该函数注销后使得自动装载函数队列无效，即使存在有 __autoload 函数它也不会自动激活。

参数

autoload_function

要注销的自动装载函数。

返回值

成功时返回 true， 或者在失败时返回 false。


__autoload()函数的默认实现

  • ? spl_autoload_unregister
  • spl_classes ?
  • PHP Manual
  • SPL 函数
  • __autoload()函数的默认实现

spl_autoload

(PHP 5 >= 5.1.0, PHP 7)

spl_autoload — __autoload()函数的默认实现

说明

spl_autoload ( string $class_name , string $file_extensions = ? ) : void

本函数提供了__autoload()的一个默认实现。如果不使用任何参数调用 spl_autoload_register() 函数，则以后在进行 __autoload() 调用时会自动使用此函数。

参数

class_name

file_extensions

在默认情况下，本函数先将类名转换成小写，再在小写的类名后加上 .inc 或 .php 的扩展名作为文件名，然后在所有的包含路径(include paths)中检查是否存在该文件。

返回值

没有返回值。


返回所有可用的SPL类

  • ? spl_autoload
  • spl_object_hash ?
  • PHP Manual
  • SPL 函数
  • 返回所有可用的SPL类

spl_classes

(PHP 5, PHP 7)

spl_classes — 返回所有可用的SPL类

说明

spl_classes ( ) : array

本函数返回当前所有可用的 SPL 类的数组。

参数

此函数没有参数。

返回值

Returns an array containing the currently available SPL classes.

范例

Example #1 spl_classes() example

<?php

print_r(spl_classes());

?>

以上例程的输出类似于：

Array
(
    [ArrayObject] => ArrayObject
    [ArrayIterator] => ArrayIterator
    [CachingIterator] => CachingIterator
    [RecursiveCachingIterator] => RecursiveCachingIterator
    [DirectoryIterator] => DirectoryIterator
    [FilterIterator] => FilterIterator
    [LimitIterator] => LimitIterator
    [ParentIterator] => ParentIterator
    [RecursiveDirectoryIterator] => RecursiveDirectoryIterator
    [RecursiveIterator] => RecursiveIterator
    [RecursiveIteratorIterator] => RecursiveIteratorIterator
    [SeekableIterator] => SeekableIterator
    [SimpleXMLIterator] => SimpleXMLIterator
)


返回指定对象的hash id

  • ? spl_classes
  • spl_object_id ?
  • PHP Manual
  • SPL 函数
  • 返回指定对象的hash id

spl_object_hash

(PHP 5 >= 5.2.0, PHP 7)

spl_object_hash — 返回指定对象的hash id

说明

spl_object_hash ( object $obj ) : string

本函数为指定对象返回一个唯一标识符。这个标识符可用于作为保存对象或区分不同对象的hash key。

参数

object

Any object.

返回值

字符串，对于每个对象它都是唯一的，并且对同一个对象它总是相同。

范例

Example #1 A spl_object_hash() example

<?php
$id = spl_object_hash($object);
$storage[$id] = $object;
?>

注释

Note:

When an object is destroyed, its hash may be reused for other objects.


Return the integer object handle for given object

  • ? spl_object_hash
  • 文件处理 ?
  • PHP Manual
  • SPL 函数
  • Return the integer object handle for given object

spl_object_id

(PHP 7 >= 7.2.0)

spl_object_id — Return the integer object handle for given object

说明

spl_object_id ( object $obj ) : int

This function returns a unique identifier for the object. The object id is unique for the lifetime of the object. Once the object is destroyed, its id may be reused for other objects. This behavior is similar to spl_object_hash().

参数

object

Any object.

返回值

An integer identifier that is unique for each currently existing object and is always the same for each object.

范例

Example #1 A spl_object_id() example

<?php
$id = spl_object_id($object);
$storage[$id] = $object;
?>

注释

Note:

When an object is destroyed, its id may be reused for other objects.


文件处理

Table of Contents

  • SplFileInfo
  • SplFileObject
  • SplTempFileObject

SPL 提供 一些与文件相关的类。


The SplFileInfo class

(PHP 5 >= 5.1.2, PHP 7)

简介

The SplFileInfo class offers a high-level object oriented interface to information for an individual file.

类摘要

SplFileInfo {
/* 方法 */
public __construct ( string $file_name )
public getATime ( ) : int
public getBasename ( string $suffix = ? ) : string
public getCTime ( ) : int
public getExtension ( ) : string
public getFileInfo ( string $class_name = ? ) : SplFileInfo
public getFilename ( ) : string
public getGroup ( ) : int
public getInode ( ) : int
public getLinkTarget ( ) : string
public getMTime ( ) : int
public getOwner ( ) : int
public getPath ( ) : string
public getPathInfo ( string $class_name = ? ) : SplFileInfo
public getPathname ( ) : string
public getPerms ( ) : int
public getRealPath ( ) : string
public getSize ( ) : int
public getType ( ) : string
public isDir ( ) : bool
public isExecutable ( ) : bool
public isFile ( ) : bool
public isLink ( ) : bool
public isReadable ( ) : bool
public isWritable ( ) : bool
public openFile ( string $open_mode = "r" , bool $use_include_path = false , resource $context = null ) : SplFileObject
public setFileClass ( string $class_name = "SplFileObject" ) : void
public setInfoClass ( string $class_name = "SplFileInfo" ) : void
public __toString ( ) : string
}

Table of Contents

  • SplFileInfo::__construct — 构建一个新的 SplFileInfo 对象
  • SplFileInfo::getATime — Gets last access time of the file
  • SplFileInfo::getBasename — Gets the base name of the file
  • SplFileInfo::getCTime — 获取文件 inode 修改时间
  • SplFileInfo::getExtension — Gets the file extension
  • SplFileInfo::getFileInfo — Gets an SplFileInfo object for the file
  • SplFileInfo::getFilename — Gets the filename
  • SplFileInfo::getGroup — Gets the file group
  • SplFileInfo::getInode — Gets the inode for the file
  • SplFileInfo::getLinkTarget — Gets the target of a link
  • SplFileInfo::getMTime — Gets the last modified time
  • SplFileInfo::getOwner — Gets the owner of the file
  • SplFileInfo::getPath — Gets the path without filename
  • SplFileInfo::getPathInfo — Gets an SplFileInfo object for the path
  • SplFileInfo::getPathname — Gets the path to the file
  • SplFileInfo::getPerms — Gets file permissions
  • SplFileInfo::getRealPath — Gets absolute path to file
  • SplFileInfo::getSize — Gets file size
  • SplFileInfo::getType — Gets file type
  • SplFileInfo::isDir — Tells if the file is a directory
  • SplFileInfo::isExecutable — Tells if the file is executable
  • SplFileInfo::isFile — Tells if the object references a regular file
  • SplFileInfo::isLink — Tells if the file is a link
  • SplFileInfo::isReadable — Tells if file is readable
  • SplFileInfo::isWritable — Tells if the entry is writable
  • SplFileInfo::openFile — Gets an SplFileObject object for the file
  • SplFileInfo::setFileClass — Sets the class used with SplFileInfo::openFile
  • SplFileInfo::setInfoClass — Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo
  • SplFileInfo::__toString — Returns the path to the file as a string


构建一个新的 SplFileInfo 对象

  • ? SplFileInfo
  • SplFileInfo::getATime ?
  • PHP Manual
  • SplFileInfo
  • 构建一个新的 SplFileInfo 对象

SplFileInfo::__construct

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::__construct — 构建一个新的 SplFileInfo 对象

说明

public SplFileInfo::__construct ( string $file_name )

为指定的 file_name 创建一个新的 SplFileInfo 对象，该文件不需要存在或者可读。

参数

file_name

文件路径

范例

Example #1 SplFileInfo::__construct() 示例

<?php
$info = new SplFileInfo('example.php');
if ($info->isFile()) {
    echo $info->getRealPath();
}
?>


Gets last access time of the file

  • ? SplFileInfo::__construct
  • SplFileInfo::getBasename ?
  • PHP Manual
  • SplFileInfo
  • Gets last access time of the file

SplFileInfo::getATime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getATime — Gets last access time of the file

说明

public SplFileInfo::getATime ( ) : int

Gets the last access time for the file.

参数

此函数没有参数。

返回值

Returns the time the file was last accessed.

错误／异常

Throws RunTimeException on error.

参见

  • fileatime() - 取得文件的上次访问时间


Gets the base name of the file

  • ? SplFileInfo::getATime
  • SplFileInfo::getCTime ?
  • PHP Manual
  • SplFileInfo
  • Gets the base name of the file

SplFileInfo::getBasename

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getBasename — Gets the base name of the file

说明

public SplFileInfo::getBasename ( string $suffix = ? ) : string

This method returns the base name of the file, directory, or link without path info.

Caution

SplFileInfo::getBasename() is locale aware, so for it to see the correct basename with multibyte character paths, the matching locale must be set using the setlocale() function.

参数

suffix

Optional suffix to omit from the base name returned.

返回值

Returns the base name without path information.

范例

Example #1 SplFileInfo::getBasename() example

<?php
$info = new SplFileInfo('file.txt');
var_dump($info->getBasename());

$info = new SplFileInfo('/path/to/file.txt');
var_dump($info->getBasename());

$info = new SplFileInfo('/path/to/file.txt');
var_dump($info->getBasename('.txt'));
?>

以上例程的输出类似于：

string(8) "file.txt"
string(8) "file.txt"
string(4) "file"

参见

  • SplFileInfo::getFilename() - Gets the filename


获取文件 inode 修改时间

  • ? SplFileInfo::getBasename
  • SplFileInfo::getExtension ?
  • PHP Manual
  • SplFileInfo
  • 获取文件 inode 修改时间

SplFileInfo::getCTime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getCTime — 获取文件 inode 修改时间

说明

public SplFileInfo::getCTime ( ) : int

返回此文件 inode 的修改时间，返回的时间是个 Unix 时间戳。

参数

此函数没有参数。

返回值

返回inode最后一次变更的时间戳。

错误／异常

错误时抛出 RunTimeException。

范例

Example #1 SplFileInfo::getCTime() 例子

<?php
$info = new SplFileInfo(__FILE__);
echo 'Last changed at ' . date('g:i a', $info->getCTime());
?>

以上例程的输出类似于：

Last changed at 1:49 pm

参见

  • filectime() - 取得文件的 inode 修改时间


Gets the file extension

  • ? SplFileInfo::getCTime
  • SplFileInfo::getFileInfo ?
  • PHP Manual
  • SplFileInfo
  • Gets the file extension

SplFileInfo::getExtension

(PHP 5 >= 5.3.6, PHP 7)

SplFileInfo::getExtension — Gets the file extension

说明

public SplFileInfo::getExtension ( ) : string

Retrieves the file extension.

参数

此函数没有参数。

返回值

Returns a string containing the file extension, or an empty string if the file has no extension.

范例

Example #1 SplFileInfo::getExtension() example

<?php

$info = new SplFileInfo('foo.txt');
var_dump($info->getExtension());

$info = new SplFileInfo('photo.jpg');
var_dump($info->getExtension());

$info = new SplFileInfo('something.tar.gz');
var_dump($info->getExtension());

?>

以上例程会输出：

string(3) "txt"
string(3) "jpg"
string(2) "gz"

注释

Note:

This method is only available as of PHP 5.3.6. Another way of getting the extension is to use the pathinfo() function.

<?php
$extension = pathinfo($info->getFilename(), PATHINFO_EXTENSION);
?>

参见

  • SplFileInfo::getFilename() - Gets the filename
  • SplFileInfo::getBasename() - Gets the base name of the file
  • pathinfo() - 返回文件路径的信息


Gets an SplFileInfo object for the file

  • ? SplFileInfo::getExtension
  • SplFileInfo::getFilename ?
  • PHP Manual
  • SplFileInfo
  • Gets an SplFileInfo object for the file

SplFileInfo::getFileInfo

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getFileInfo — Gets an SplFileInfo object for the file

说明

public SplFileInfo::getFileInfo ( string $class_name = ? ) : SplFileInfo

This method gets an SplFileInfo object for the referenced file.

参数

class_name

Name of an SplFileInfo derived class to use.

返回值

An SplFileInfo object created for the file.

参见

  • SplFileInfo::setInfoClass() - Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo


Gets the filename

  • ? SplFileInfo::getFileInfo
  • SplFileInfo::getGroup ?
  • PHP Manual
  • SplFileInfo
  • Gets the filename

SplFileInfo::getFilename

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getFilename — Gets the filename

说明

public SplFileInfo::getFilename ( ) : string

Gets the filename without any path information.

参数

此函数没有参数。

返回值

The filename.

范例

Example #1 SplFileInfo::getFilename() example

<?php
$info = new SplFileInfo('foo.txt');
var_dump($info->getFilename());

$info = new SplFileInfo('/path/to/foo.txt');
var_dump($info->getFilename());

$info = new SplFileInfo('http://www.php.net/');
var_dump($info->getFilename());

$info = new SplFileInfo('http://www.php.net/svn.php');
var_dump($info->getFilename());
?>

以上例程的输出类似于：

string(7) "foo.txt"
string(7) "foo.txt"
string(0) ""
string(7) "svn.php"

参见

  • SplFileInfo::getBasename() - Gets the base name of the file


Gets the file group

  • ? SplFileInfo::getFilename
  • SplFileInfo::getInode ?
  • PHP Manual
  • SplFileInfo
  • Gets the file group

SplFileInfo::getGroup

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getGroup — Gets the file group

说明

public SplFileInfo::getGroup ( ) : int

Gets the file group. The group ID is returned in numerical format.

参数

此函数没有参数。

返回值

The group id in numerical format.

错误／异常

Throws RuntimeException on error.

范例

Example #1 SplFileInfo::getGroup() example

<?php
$info = new SplFileInfo(__FILE__);
print_r(posix_getgrgid($info->getGroup()));
?>

以上例程的输出类似于：

参见

  • posix_getgrgid() - Return info about a group by group id


Gets the inode for the file

  • ? SplFileInfo::getGroup
  • SplFileInfo::getLinkTarget ?
  • PHP Manual
  • SplFileInfo
  • Gets the inode for the file

SplFileInfo::getInode

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getInode — Gets the inode for the file

说明

public SplFileInfo::getInode ( ) : int

Gets the inode number for the filesystem object.

参数

此函数没有参数。

返回值

Returns the inode number for the filesystem object.

错误／异常

Throws RuntimeException on error.

参见

  • fileinode() - 取得文件的 inode


Gets the target of a link

  • ? SplFileInfo::getInode
  • SplFileInfo::getMTime ?
  • PHP Manual
  • SplFileInfo
  • Gets the target of a link

SplFileInfo::getLinkTarget

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getLinkTarget — Gets the target of a link

说明

public SplFileInfo::getLinkTarget ( ) : string

Gets the target of a filesystem link.

Note:

The target may not be the real path on the filesystem. Use SplFileInfo::getRealPath() to determine the true path on the filesystem.

参数

此函数没有参数。

返回值

Returns the target of the filesystem link.

错误／异常

Throws RuntimeException on error.

范例

Example #1 SplFileInfo::getLinkTarget() example

<?php
$info = new SplFileInfo('/Users/bbieber/workspace');
if ($info->isLink()) {
    var_dump($info->getLinkTarget());
    var_dump($info->getRealPath());
}
?>

以上例程的输出类似于：

string(19) "Documents/workspace"
string(34) "/Users/bbieber/Documents/workspace"

参见

  • SplFileInfo::isLink() - Tells if the file is a link
  • SplFileInfo::getRealPath() - Gets absolute path to file


Gets the last modified time

  • ? SplFileInfo::getLinkTarget
  • SplFileInfo::getOwner ?
  • PHP Manual
  • SplFileInfo
  • Gets the last modified time

SplFileInfo::getMTime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getMTime — Gets the last modified time

说明

public SplFileInfo::getMTime ( ) : int

Returns the time when the contents of the file were changed. The time returned is a Unix timestamp.

参数

此函数没有参数。

返回值

Returns the last modified time for the file, in a Unix timestamp.

参见

  • filemtime() - 取得文件修改时间


Gets the owner of the file

  • ? SplFileInfo::getMTime
  • SplFileInfo::getPath ?
  • PHP Manual
  • SplFileInfo
  • Gets the owner of the file

SplFileInfo::getOwner

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getOwner — Gets the owner of the file

说明

public SplFileInfo::getOwner ( ) : int

Gets the file owner. The owner ID is returned in numerical format.

参数

此函数没有参数。

返回值

The owner id in numerical format.

错误／异常

Throws RuntimeException on error.

范例

Example #1 SplFileInfo::getOwner() example

<?php
$info = new SplFileInfo('file.txt');
print_r(posix_getpwuid($info->getOwner()));
?>

参见

  • posix_getpwuid() - Return info about a user by user id
  • SplFileInfo::getGroup() - Gets the file group


Gets the path without filename

  • ? SplFileInfo::getOwner
  • SplFileInfo::getPathInfo ?
  • PHP Manual
  • SplFileInfo
  • Gets the path without filename

SplFileInfo::getPath

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPath — Gets the path without filename

说明

public SplFileInfo::getPath ( ) : string

Returns the path to the file, omitting the filename and any trailing slash.

参数

此函数没有参数。

返回值

Returns the path to the file.

范例

Example #1 SplFileInfo::getPath() example

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->getPath());

$info = new SplFileInfo('/usr/');
var_dump($info->getPath());?>

以上例程的输出类似于：

string(8) "/usr/bin"
string(4) "/usr"

参见

  • SplFileInfo::getRealPath() - Gets absolute path to file
  • SplFileInfo::getFilename() - Gets the filename
  • SplFileInfo::getPathInfo() - Gets an SplFileInfo object for the path


Gets an SplFileInfo object for the path

  • ? SplFileInfo::getPath
  • SplFileInfo::getPathname ?
  • PHP Manual
  • SplFileInfo
  • Gets an SplFileInfo object for the path

SplFileInfo::getPathInfo

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPathInfo — Gets an SplFileInfo object for the path

说明

public SplFileInfo::getPathInfo ( string $class_name = ? ) : SplFileInfo

Gets an SplFileInfo object for the parent of the current file.

参数

class_name

Name of an SplFileInfo derived class to use.

返回值

Returns an SplFileInfo object for the parent path of the file.

范例

Example #1 SplFileInfo::getPathInfo() example

<?php
$info = new SplFileInfo('/usr/bin/php');
$parent_info = $info->getPathInfo();
var_dump($parent_info->getRealPath());
?>

以上例程的输出类似于：

string(8) "/usr/bin"

参见

  • SplFileInfo::setInfoClass() - Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo


Gets the path to the file

  • ? SplFileInfo::getPathInfo
  • SplFileInfo::getPerms ?
  • PHP Manual
  • SplFileInfo
  • Gets the path to the file

SplFileInfo::getPathname

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPathname — Gets the path to the file

说明

public SplFileInfo::getPathname ( ) : string

Returns the path to the file.

参数

此函数没有参数。

返回值

The path to the file.

范例

Example #1 SplFileInfo::getPathname() example

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->getPathname());
?>

以上例程的输出类似于：

string(12) "/usr/bin/php"

参见

  • SplFileInfo::getRealPath() - Gets absolute path to file


Gets file permissions

  • ? SplFileInfo::getPathname
  • SplFileInfo::getRealPath ?
  • PHP Manual
  • SplFileInfo
  • Gets file permissions

SplFileInfo::getPerms

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPerms — Gets file permissions

说明

public SplFileInfo::getPerms ( ) : int

Gets the file permissions for the file.

参数

此函数没有参数。

返回值

Returns the file permissions.

范例

Example #1 SplFileInfo::getPerms() example

<?php
$info = new SplFileInfo('/tmp');
echo substr(sprintf('%o', $info->getPerms()), -4);

$info = new SplFileInfo(__FILE__);
echo substr(sprintf('%o', $info->getPerms()), -4);
?>

以上例程的输出类似于：

1777
0644


Gets absolute path to file

  • ? SplFileInfo::getPerms
  • SplFileInfo::getSize ?
  • PHP Manual
  • SplFileInfo
  • Gets absolute path to file

SplFileInfo::getRealPath

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getRealPath — Gets absolute path to file

说明

public SplFileInfo::getRealPath ( ) : string

This method expands all symbolic links, resolves relative references and returns the real path to the file.

参数

此函数没有参数。

返回值

Returns the path to the file, or false if the file does not exist.

范例

Example #1 SplFileInfo::getRealPath() example

<?php
$info = new SplFileInfo('/..//./../../'.__FILE__);
var_dump($info->getRealPath());

$info = new SplFileInfo('/tmp');
var_dump($info->getRealPath());

$info = new SplFileInfo('/I/Do/Not/Exist');
var_dump($info->getRealPath());

$info = new SplFileInfo('php://output');
var_dump($info->getRealPath());

$info = new SplFileInfo("");
var_dump($info->getRealPath());
?>

以上例程的输出类似于：

string(28) "/private/tmp/phptempfile.php"
string(12) "/private/tmp"
bool(false)
bool(false)
string(12) "/private/tmp"

参见

  • SplFileInfo::isLink() - Tells if the file is a link
  • realpath() - 返回规范化的绝对路径名


Gets file size

  • ? SplFileInfo::getRealPath
  • SplFileInfo::getType ?
  • PHP Manual
  • SplFileInfo
  • Gets file size

SplFileInfo::getSize

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getSize — Gets file size

说明

public SplFileInfo::getSize ( ) : int

Returns the filesize in bytes for the file referenced.

参数

此函数没有参数。

返回值

The filesize in bytes.

错误／异常

A RuntimeException will be thrown if the file does not exist or an error occurs.

参见

  • filesize() - 取得文件大小


Gets file type

  • ? SplFileInfo::getSize
  • SplFileInfo::isDir ?
  • PHP Manual
  • SplFileInfo
  • Gets file type

SplFileInfo::getType

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getType — Gets file type

说明

public SplFileInfo::getType ( ) : string

Returns the type of the file referenced.

参数

此函数没有参数。

返回值

A string representing the type of the entry. May be one of file, link, dir, block, fifo, char, socket, or unknown

错误／异常

Throws a RuntimeException on error.

范例

Example #1 SplFileInfo::getType() example

<?php

$info = new SplFileInfo(__FILE__);
echo $info->getType().PHP_EOL;

$info = new SplFileInfo(dirname(__FILE__));
echo $info->getType();

?>

以上例程的输出类似于：

file
dir


Tells if the file is a directory

  • ? SplFileInfo::getType
  • SplFileInfo::isExecutable ?
  • PHP Manual
  • SplFileInfo
  • Tells if the file is a directory

SplFileInfo::isDir

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isDir — Tells if the file is a directory

说明

public SplFileInfo::isDir ( ) : bool

This method can be used to determine if the file is a directory.

参数

此函数没有参数。

返回值

Returns true if a directory, false otherwise.

范例

Example #1 SplFileInfo::isDir() example

<?php
$d = new SplFileInfo(dirname(__FILE__));
var_dump($d->isDir());

$d = new SplFileInfo(__FILE__);
var_dump($d->isDir());
?>

以上例程的输出类似于：

bool(true)
bool(false)


Tells if the file is executable

  • ? SplFileInfo::isDir
  • SplFileInfo::isFile ?
  • PHP Manual
  • SplFileInfo
  • Tells if the file is executable

SplFileInfo::isExecutable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isExecutable — Tells if the file is executable

说明

public SplFileInfo::isExecutable ( ) : bool

Checks if the file is executable.

参数

此函数没有参数。

返回值

Returns true if executable, false otherwise.

范例

Example #1 SplFileInfo::isExecutable() example

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->isExecutable());

$info = new SplFileInfo('/usr/bin');
var_dump($info->isExecutable());

$info = new SplFileInfo('foo');
var_dump($info->isExecutable());
?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(false)


Tells if the object references a regular file

  • ? SplFileInfo::isExecutable
  • SplFileInfo::isLink ?
  • PHP Manual
  • SplFileInfo
  • Tells if the object references a regular file

SplFileInfo::isFile

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isFile — Tells if the object references a regular file

说明

public SplFileInfo::isFile ( ) : bool

Checks if the file referenced by this SplFileInfo object exists and is a regular file.

参数

此函数没有参数。

返回值

Returns true if the file exists and is a regular file (not a link), false otherwise.

范例

Example #1 SplFileInfo::isFile() example

<?php
$info = new SplFileInfo(__FILE__);
var_dump($info->isFile());

$info = new SplFileInfo(dirname(__FILE__));
var_dump($info->isFile());
?>

以上例程的输出类似于：

bool(true)
bool(false)


Tells if the file is a link

  • ? SplFileInfo::isFile
  • SplFileInfo::isReadable ?
  • PHP Manual
  • SplFileInfo
  • Tells if the file is a link

SplFileInfo::isLink

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isLink — Tells if the file is a link

说明

public SplFileInfo::isLink ( ) : bool

Use this method to check if the file referenced by the SplFileInfo object is a link.

参数

此函数没有参数。

返回值

Returns true if the file is a link, false otherwise.

范例

Example #1 SplFileInfo::isLink() example

<?php
$info = new SplFileInfo('/path/to/symlink');
if ($info->isLink()) {
    echo 'The real path is '.$info->getRealPath();
}
?>

参见

  • SplFileInfo::getRealPath() - Gets absolute path to file


Tells if file is readable

  • ? SplFileInfo::isLink
  • SplFileInfo::isWritable ?
  • PHP Manual
  • SplFileInfo
  • Tells if file is readable

SplFileInfo::isReadable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isReadable — Tells if file is readable

说明

public SplFileInfo::isReadable ( ) : bool

Check if the file is readable.

参数

此函数没有参数。

返回值

Returns true if readable, false otherwise.

范例

Example #1 SplFileInfo::isReadable() example

<?php
$info = new SplFileInfo(__FILE__);
var_dump($info->isReadable());

$info = new SplFileInfo('foo');
var_dump($info->isReadable());
?>

以上例程的输出类似于：

bool(true)
bool(false)


Tells if the entry is writable

  • ? SplFileInfo::isReadable
  • SplFileInfo::openFile ?
  • PHP Manual
  • SplFileInfo
  • Tells if the entry is writable

SplFileInfo::isWritable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isWritable — Tells if the entry is writable

说明

public SplFileInfo::isWritable ( ) : bool

Checks if the current entry is writable.

参数

此函数没有参数。

返回值

Returns true if writable, false otherwise;


Gets an SplFileObject object for the file

  • ? SplFileInfo::isWritable
  • SplFileInfo::setFileClass ?
  • PHP Manual
  • SplFileInfo
  • Gets an SplFileObject object for the file

SplFileInfo::openFile

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::openFile — Gets an SplFileObject object for the file

说明

public SplFileInfo::openFile ( string $open_mode = "r" , bool $use_include_path = false , resource $context = null ) : SplFileObject

Creates an SplFileObject object of the file. This is useful because SplFileObject contains additional methods for manipulating the file whereas SplFileInfo is only useful for gaining information, like whether the file is writable.

参数

open_mode

The mode for opening the file. See the fopen() documentation for descriptions of possible modes. The default is read only.

use_include_path

值 设为 true 时, 也会在 include_path搜索文件名。

context

上下文（context）的说明请参考手册中的 上下文（context）章节.

返回值

The opened file as an SplFileObject object.

错误／异常

A RuntimeException if the file cannot be opened (e.g. insufficient access rights).

范例

Example #1 SplFileInfo::openFile() example

<?php
$fileinfo = new SplFileInfo('/tmp/foo.txt');

if ($fileinfo->isWritable()) {

    $fileobj = $fileinfo->openFile('a');

    $fileobj->fwrite("appended this sample text");
}
?>

参见

  • SplFileObject
  • stream_context_create() - 创建资源流上下文
  • fopen() - 打开文件或者 URL


Sets the class used with SplFileInfo::openFile

  • ? SplFileInfo::openFile
  • SplFileInfo::setInfoClass ?
  • PHP Manual
  • SplFileInfo
  • Sets the class used with SplFileInfo::openFile

SplFileInfo::setFileClass

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::setFileClass — Sets the class used with SplFileInfo::openFile()

说明

public SplFileInfo::setFileClass ( string $class_name = "SplFileObject" ) : void

Use this method to set a custom class which will be used when SplFileInfo::openFile() is called. The class name passed to this method must be SplFileObject or a class derived from SplFileObject.

参数

class_name

The class name to use when SplFileInfo::openFile() is called.

返回值

没有返回值。

范例

Example #1 SplFileInfo::setFileClass() example

<?php
// Create a class extending SplFileObject
class MyFoo extends SplFileObject {}

$info = new SplFileInfo(__FILE__);
// Set the class to use
$info->setFileClass('MyFoo');
var_dump($info->openFile());
?>

以上例程的输出类似于：

object(MyFoo)#2 (0) { }

参见

  • SplFileInfo::openFile() - Gets an SplFileObject object for the file


Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo

  • ? SplFileInfo::setFileClass
  • SplFileInfo::__toString ?
  • PHP Manual
  • SplFileInfo
  • Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo

SplFileInfo::setInfoClass

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::setInfoClass — Sets the class used with SplFileInfo::getFileInfo() and SplFileInfo::getPathInfo()

说明

public SplFileInfo::setInfoClass ( string $class_name = "SplFileInfo" ) : void

Use this method to set a custom class which will be used when SplFileInfo::getFileInfo() and SplFileInfo::getPathInfo() are called. The class name passed to this method must be SplFileInfo or a class derived from SplFileInfo.

参数

class_name

The class name to use when SplFileInfo::getFileInfo() and SplFileInfo::getPathInfo() are called.

返回值

没有返回值。

范例

Example #1 SplFileInfo::setFileClass() example

<?php
// Define a class which extends SplFileInfo
class MyFoo extends SplFileInfo {}

$info = new SplFileInfo('foo');
// Set the class name to use
$info->setInfoClass('MyFoo');
var_dump($info->getFileInfo());
?>

以上例程的输出类似于：

object(MyFoo)#2 (0) { }

参见

  • SplFileInfo::getFileInfo() - Gets an SplFileInfo object for the file


Returns the path to the file as a string

  • ? SplFileInfo::setInfoClass
  • SplFileObject ?
  • PHP Manual
  • SplFileInfo
  • Returns the path to the file as a string

SplFileInfo::__toString

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::__toString — Returns the path to the file as a string

说明

public SplFileInfo::__toString ( ) : string

This method will return the file name of the referenced file.

参数

此函数没有参数。

返回值

Returns the path to the file.

范例

Example #1 SplFileInfo::__toString() example

<?php
$info = new SplFileInfo('foo');
var_dump($info->__toString());
echo $info.PHP_EOL;

$info = new SplFileInfo('/usr/bin/php');
var_dump($info->__toString());
echo $info.PHP_EOL;
?>

以上例程的输出类似于：

string(3) "foo"
foo
string(12) "/usr/bin/php"
/usr/bin/php


The SplFileObject class

(PHP 5 >= 5.1.0, PHP 7)

简介

SplFileObject类为文件提供了一个面向对象接口.

类摘要

SplFileObject extends SplFileInfo implements RecursiveIterator , SeekableIterator {
/* 常量 */
const integer DROP_NEW_LINE = 1 ;
const integer READ_AHEAD = 2 ;
const integer SKIP_EMPTY = 4 ;
const integer READ_CSV = 8 ;
/* 方法 */
public current ( ) : string|array
public eof ( ) : bool
public fflush ( ) : bool
public fgetc ( ) : string
public fgetcsv
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : array
public fgets ( ) : string
public fgetss ( string $allowable_tags = ? ) : string
public flock ( int $operation , int &$wouldblock = ? ) : bool
public fpassthru ( ) : int
public fputcsv ( array $fields , string $delimiter = "," , string $enclosure = '"' , string $escape = "\\" ) : int|false
public fread ( int $length ) : string|false
public fscanf ( string $format , mixed &...$vars ) : mixed
public fseek ( int $offset , int $whence = SEEK_SET ) : int
public fstat ( ) : array
public ftell ( ) : int
public ftruncate ( int $size ) : bool
public fwrite ( string $str , int $length = ? ) : int
public getChildren ( ) : void
public getCsvControl ( ) : array
public getFlags ( ) : int
public getMaxLineLen ( ) : int
public hasChildren ( ) : bool
public key ( ) : int
public next ( ) : void
public rewind ( ) : void
public seek ( int $line_pos ) : void
public setCsvControl
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : void
public setFlags ( int $flags ) : void
public setMaxLineLen ( int $max_len ) : void
public valid ( ) : bool
/* 继承的方法 */
public SplFileInfo::getATime ( ) : int
public SplFileInfo::getBasename ( string $suffix = ? ) : string
public SplFileInfo::getCTime ( ) : int
public SplFileInfo::getExtension ( ) : string
public SplFileInfo::getFileInfo ( string $class_name = ? ) : SplFileInfo
public SplFileInfo::getFilename ( ) : string
public SplFileInfo::getGroup ( ) : int
public SplFileInfo::getInode ( ) : int
public SplFileInfo::getLinkTarget ( ) : string
public SplFileInfo::getMTime ( ) : int
public SplFileInfo::getOwner ( ) : int
public SplFileInfo::getPath ( ) : string
public SplFileInfo::getPathInfo ( string $class_name = ? ) : SplFileInfo
public SplFileInfo::getPathname ( ) : string
public SplFileInfo::getPerms ( ) : int
public SplFileInfo::getRealPath ( ) : string
public SplFileInfo::getSize ( ) : int
public SplFileInfo::getType ( ) : string
public SplFileInfo::isDir ( ) : bool
public SplFileInfo::isExecutable ( ) : bool
public SplFileInfo::isFile ( ) : bool
public SplFileInfo::isLink ( ) : bool
public SplFileInfo::isReadable ( ) : bool
public SplFileInfo::isWritable ( ) : bool
public SplFileInfo::openFile ( string $open_mode = "r" , bool $use_include_path = false , resource $context = null ) : SplFileObject
public SplFileInfo::setFileClass ( string $class_name = "SplFileObject" ) : void
public SplFileInfo::setInfoClass ( string $class_name = "SplFileInfo" ) : void
public SplFileInfo::__toString ( ) : string
}

预定义常量

SplFileObject::DROP_NEW_LINE

Drop newlines at the end of a line.

SplFileObject::READ_AHEAD

Read on rewind/next.

SplFileObject::SKIP_EMPTY

Skips empty lines in the file. This requires the READ_AHEAD flag be enabled, to work as expected.

SplFileObject::READ_CSV

Read lines as CSV rows.

更新日志

版本 | 说明
5.3.9 | SplFileObject::SKIP_EMPTY value changed to 4. Previously, value was 6.

Table of Contents

  • SplFileObject::__construct — Construct a new file object
  • SplFileObject::current — Retrieve current line of file
  • SplFileObject::eof — Reached end of file
  • SplFileObject::fflush — Flushes the output to the file
  • SplFileObject::fgetc — Gets character from file
  • SplFileObject::fgetcsv — Gets line from file and parse as CSV fields
  • SplFileObject::fgets — Gets line from file
  • SplFileObject::fgetss — Gets line from file and strip HTML tags
  • SplFileObject::flock — Portable file locking
  • SplFileObject::fpassthru — Output all remaining data on a file pointer
  • SplFileObject::fputcsv — Write a field array as a CSV line
  • SplFileObject::fread — Read from file
  • SplFileObject::fscanf — Parses input from file according to a format
  • SplFileObject::fseek — Seek to a position
  • SplFileObject::fstat — Gets information about the file
  • SplFileObject::ftell — Return current file position
  • SplFileObject::ftruncate — Truncates the file to a given length
  • SplFileObject::fwrite — Write to file
  • SplFileObject::getChildren — No purpose
  • SplFileObject::getCsvControl — Get the delimiter, enclosure and escape character for CSV
  • SplFileObject::getCurrentLine — Alias of SplFileObject::fgets
  • SplFileObject::getFlags — Gets flags for the SplFileObject
  • SplFileObject::getMaxLineLen — Get maximum line length
  • SplFileObject::hasChildren — SplFileObject does not have children
  • SplFileObject::key — Get line number
  • SplFileObject::next — Read next line
  • SplFileObject::rewind — Rewind the file to the first line
  • SplFileObject::seek — Seek to specified line
  • SplFileObject::setCsvControl — Set the delimiter, enclosure and escape character for CSV
  • SplFileObject::setFlags — Sets flags for the SplFileObject
  • SplFileObject::setMaxLineLen — Set maximum line length
  • SplFileObject::__toString — Alias of SplFileObject::fgets
  • SplFileObject::valid — Not at EOF


Construct a new file object

  • ? SplFileObject
  • SplFileObject::current ?
  • PHP Manual
  • SplFileObject
  • Construct a new file object

SplFileObject::__construct

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::__construct — Construct a new file object

说明

public SplFileObject::__construct ( string $filename , string $open_mode = "r" , bool $use_include_path = false , resource $context = ? )

Construct a new file object.

参数

filename

The file to read.

Tip

如已启用fopen 包装器，在此函数中， URL 可作为文件名。关于如何指定文件名详见 fopen()。各种 wapper 的不同功能请参见 支持的协议和封装协议，注意其用法及其可提供的预定义变量。

open_mode

The mode in which to open the file. See fopen() for a list of allowed modes.

use_include_path

Whether to search in the include_path for filename.

context

A valid context resource created with stream_context_create().

返回值

没有返回值。

错误／异常

Throws a RuntimeException if the filename cannot be opened.

Throws a LogicException if the filename is a directory.

范例

Example #1 SplFileObject::__construct() example

This example opens the current file and iterates over its contents line by line.

<?php
$file = new SplFileObject(__FILE__);
foreach ($file as $line_num => $line) {
    echo "Line $line_num is $line";
}
?>

以上例程的输出类似于：

Line 0 is <?php
Line 1 is $file = new SplFileObject(__FILE__);
Line 2 is foreach ($file as $line_num => $line) {
Line 3 is     echo "Line $line_num is $line";
Line 4 is }
Line 5 is ?>

参见

  • SplFileInfo::openFile() - Gets an SplFileObject object for the file
  • fopen() - 打开文件或者 URL


Retrieve current line of file

  • ? SplFileObject::__construct
  • SplFileObject::eof ?
  • PHP Manual
  • SplFileObject
  • Retrieve current line of file

SplFileObject::current

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::current — Retrieve current line of file

说明

public SplFileObject::current ( ) : string|array

Retrieves the current line of the file.

参数

此函数没有参数。

返回值

Retrieves the current line of the file. If the SplFileObject::READ_CSV flag is set, this method returns an array containing the current line parsed as CSV data.

范例

Example #1 SplFileObject::current() example

<?php
$file = new SplFileObject(__FILE__);
foreach ($file as $k => $line) {
   echo ($file->key() + 1) . ': ' . $file->current();
}
?>

以上例程的输出类似于：

1: <?php
2: $file = new SplFileObject(__FILE__);
3: foreach ($file as $line) {
4:     echo ($file->key() + 1) . ': ' . $file->current();
5: }
6: ?>

参见

  • SplFileObject::key() - Get line number
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::next() - Read next line
  • SplFileObject::rewind() - Rewind the file to the first line
  • SplFileObject::valid() - Not at EOF


Reached end of file

  • ? SplFileObject::current
  • SplFileObject::fflush ?
  • PHP Manual
  • SplFileObject
  • Reached end of file

SplFileObject::eof

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::eof — Reached end of file

说明

public SplFileObject::eof ( ) : bool

Determine whether the end of file has been reached

参数

此函数没有参数。

返回值

Returns true if file is at EOF, false otherwise.

范例

Example #1 SplFileObject::eof() example

<?php
$file = new SplFileObject("fruits.txt");
while ( ! $file->eof()) {
    echo $file->fgets();
}
?>

以上例程的输出类似于：

apple
banana
cherry
date
elderberry

参见

  • SplFileObject::valid() - Not at EOF
  • feof() - 测试文件指针是否到了文件结束的位置


Flushes the output to the file

  • ? SplFileObject::eof
  • SplFileObject::fgetc ?
  • PHP Manual
  • SplFileObject
  • Flushes the output to the file

SplFileObject::fflush

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fflush — Flushes the output to the file

说明

public SplFileObject::fflush ( ) : bool

Forces a write of all buffered output to the file.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SplFileObject::fflush() example

<?php
$file = new SplFileObject('misc.txt', 'r+');
$file->rewind();
$file->fwrite("Foo");
$file->fflush();
$file->ftruncate($file->ftell());
?>

参见

  • SplFileObject::fwrite() - Write to file


Gets character from file

  • ? SplFileObject::fflush
  • SplFileObject::fgetcsv ?
  • PHP Manual
  • SplFileObject
  • Gets character from file

SplFileObject::fgetc

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetc — Gets character from file

说明

public SplFileObject::fgetc ( ) : string

Gets a character from the file.

参数

此函数没有参数。

返回值

Returns a string containing a single character read from the file or false on EOF.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 SplFileObject::fgetc() example

<?php
$file = new SplFileObject('file.txt');
while (false !== ($char = $file->fgetc())) {
    echo "$char\n";
}
?>

参见

  • SplFileObject::fgets() - Gets line from file


Gets line from file and parse as CSV fields

  • ? SplFileObject::fgetc
  • SplFileObject::fgets ?
  • PHP Manual
  • SplFileObject
  • Gets line from file and parse as CSV fields

SplFileObject::fgetcsv

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetcsv — Gets line from file and parse as CSV fields

说明

public SplFileObject::fgetcsv
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : array

Gets a line from the file which is in CSV format and returns an array containing the fields read.

Note:

The locale settings are taken into account by this function. If LC_CTYPE is e.g. en_US.UTF-8, files in one-byte encodings may be read wrongly by this function.

参数

delimiter

The field delimiter (one character only). Defaults as a comma or the value set using SplFileObject::setCsvControl().

enclosure

The field enclosure character (one character only). Defaults as a double quotation mark or the value set using SplFileObject::setCsvControl().

escape

The escape character (at most one character). Defaults as a backslash (\) or the value set using SplFileObject::setCsvControl(). An empty string ("") disables the proprietary escape mechanism.

Note: Usually an enclosure character is escpaped inside a field by doubling it; however, the escape character can be used as an alternative. So for the default parameter values "" and \" have the same meaning. Other than allowing to escape the enclosure character the escape character has no special meaning; it isn't even meant to escape itself.

返回值

Returns an indexed array containing the fields read, or false on error.

Note:

A blank line in a CSV file will be returned as an array comprising a single null field unless using SplFileObject::SKIP_EMPTY | SplFileObject::DROP_NEW_LINE, in which case empty lines are skipped.

更新日志

版本 | 说明
7.4.0 | The escape parameter now also accepts an empty string to disable the proprietary escape mechanism.

范例

Example #1 SplFileObject::fgetcsv() example

<?php
$file = new SplFileObject("data.csv");
while (!$file->eof()) {
    var_dump($file->fgetcsv());
}
?>

Example #2 SplFileObject::READ_CSV example

<?php
$file = new SplFileObject("animals.csv");
$file->setFlags(SplFileObject::READ_CSV);
foreach ($file as $row) {
    list($animal, $class, $legs) = $row;
    printf("A %s is a %s with %d legs\n", $animal, $class, $legs);
}
?>

Contents of animals.csv

crocodile,reptile,4
dolphin,mammal,0
duck,bird,2
koala,mammal,4
salmon,fish,0

以上例程的输出类似于：

A crocodile is a reptile with 4 legs
A dolphin is a mammal with 0 legs
A duck is a bird with 2 legs
A koala is a mammal with 4 legs
A salmon is a fish with 0 legs

参见

  • SplFileObject::setCsvControl() - Set the delimiter, enclosure and escape character for CSV
  • SplFileObject::setFlags() - Sets flags for the SplFileObject
  • SplFileObject::READ_CSV
  • SplFileObject::current() - Retrieve current line of file


Gets line from file

  • ? SplFileObject::fgetcsv
  • SplFileObject::fgetss ?
  • PHP Manual
  • SplFileObject
  • Gets line from file

SplFileObject::fgets

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgets — Gets line from file

说明

public SplFileObject::fgets ( ) : string

Gets a line from the file.

参数

此函数没有参数。

返回值

Returns a string containing the next line from the file, or false on error.

错误／异常

Throws a RuntimeException if the file cannot be read.

范例

Example #1 SplFileObject::fgets() example

This example simply outputs the contents of file.txt line-by-line.

<?php
$file = new SplFileObject("file.txt");
while (!$file->eof()) {
    echo $file->fgets();
}
?>

参见

  • fgets() - 从文件指针中读取一行
  • SplFileObject::fgetss() - Gets line from file and strip HTML tags
  • SplFileObject::fgetc() - Gets character from file
  • SplFileObject::current() - Retrieve current line of file


Gets line from file and strip HTML tags

  • ? SplFileObject::fgets
  • SplFileObject::flock ?
  • PHP Manual
  • SplFileObject
  • Gets line from file and strip HTML tags

SplFileObject::fgetss

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetss — Gets line from file and strip HTML tags

Warning

This function has been DEPRECATED as of PHP 7.3.0, and REMOVED as of PHP 8.0.0. Relying on this function is highly discouraged.

说明

public SplFileObject::fgetss ( string $allowable_tags = ? ) : string

Identical to SplFileObject::fgets(), except that SplFileObject::fgetss() attempts to strip any HTML and PHP tags from the text it reads. The function retains the parsing state from call to call, and as such is not equivalent to calling strip_tags() on the return value of SplFileObject::fgets().

参数

allowable_tags

Optional parameter to specify tags which should not be stripped.

返回值

Returns a string containing the next line of the file with HTML and PHP code stripped, or false on error.

范例

Example #1 SplFileObject::fgetss() example

<?php
$str = <<<EOD
<html><body>
 <p>Welcome! Today is the <?php echo(date('jS')); ?> of <?= date('F'); ?>.</p>
</body></html>
Text outside of the HTML block.
EOD;
file_put_contents("sample.php", $str);

$file = new SplFileObject("sample.php");
while (!$file->eof()) {
    echo $file->fgetss();
}
?>

以上例程的输出类似于：

 Welcome! Today is the  of .

Text outside of the HTML block.

参见

  • fgetss() - 从文件指针中读取一行并过滤掉 HTML 标记
  • SplFileObject::fgets() - Gets line from file
  • SplFileObject::fgetc() - Gets character from file
  • SplFileObject::current() - Retrieve current line of file
  • The string.strip_tags filter


Portable file locking

  • ? SplFileObject::fgetss
  • SplFileObject::fpassthru ?
  • PHP Manual
  • SplFileObject
  • Portable file locking

SplFileObject::flock

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::flock — Portable file locking

说明

public SplFileObject::flock ( int $operation , int &$wouldblock = ? ) : bool

Locks or unlocks the file in the same portable way as flock().

参数

operation

operation is one of the following:

  • LOCK_SH to acquire a shared lock (reader).
  • LOCK_EX to acquire an exclusive lock (writer).
  • LOCK_UN to release a lock (shared or exclusive).

It is also possible to add LOCK_NB as a bitmask to one of the above operations, if flock() should not block during the locking attempt.

wouldblock

Set to true if the lock would block (EWOULDBLOCK errno condition).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SplFileObject::flock() example

<?php
$file = new SplFileObject("/tmp/lock.txt", "w");
if ($file->flock(LOCK_EX)) { // do an exclusive lock
    $file->ftruncate(0);     // truncate file
    $file->fwrite("Write something here\n");
    $file->flock(LOCK_UN);   // release the lock
} else {
    echo "Couldn't get the lock!";
}
?>

参见

  • flock() - 轻便的咨询文件锁定


Output all remaining data on a file pointer

  • ? SplFileObject::flock
  • SplFileObject::fputcsv ?
  • PHP Manual
  • SplFileObject
  • Output all remaining data on a file pointer

SplFileObject::fpassthru

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fpassthru — Output all remaining data on a file pointer

说明

public SplFileObject::fpassthru ( ) : int

Reads to EOF on the given file pointer from the current position and writes the results to the output buffer.

You may need to call SplFileObject::rewind() to reset the file pointer to the beginning of the file if you have already written data to the file.

参数

此函数没有参数。

返回值

Returns the number of characters read from handle and passed through to the output.

范例

Example #1 SplFileObject::fpassthru() example

<?php

// Open the file in binary mode
$file = new SplFileObject("./img/ok.png", "rb");

// Send the right headers
header("Content-Type: image/png");
header("Content-Length: " . $file->getSize());

// Dump the picture and end script
$file->fpassthru();
exit;

?>

参见

  • fpassthru() - 输出文件指针处的所有剩余数据


Write a field array as a CSV line

  • ? SplFileObject::fpassthru
  • SplFileObject::fread ?
  • PHP Manual
  • SplFileObject
  • Write a field array as a CSV line

SplFileObject::fputcsv

(PHP 5 >= 5.4.0, PHP 7)

SplFileObject::fputcsv — Write a field array as a CSV line

说明

public SplFileObject::fputcsv
 ( array $fields
, string $delimiter = ","
, string $enclosure = '"'
, string $escape = "\\"
) : int|false

Writes the fields array to the file as a CSV line.

参数

fields

An array of values.

delimiter

The optional delimiter parameter sets the field delimiter (one character only).

enclosure

The optional enclosure parameter sets the field enclosure (one character only).

escape

The optional escape parameter sets the escape character (at most one character). An empty string ("") disables the proprietary escape mechanism.

Note:

If an enclosure character is contained in a field, it will be escaped by doubling it, unless it is immediately preceded by an escape_char.

返回值

Returns the length of the written string 或者在失败时返回 false.

Returns false, and does not write the CSV line to the file, if the delimiter or enclosure parameter is not a single character.

错误／异常

An E_WARNING level error is issued if the delimiter or enclosure parameter is not a single character.

更新日志

版本 | 说明
7.4.0 | The escape parameter now also accepts an empty string to disable the proprietary escape mechanism.
5.5.21, 5.6.5 | Added the escape parameter.

范例

Example #1 SplFileObject::fputcsv() example

<?php

$list = array (
    array('aaa', 'bbb', 'ccc', 'dddd'),
    array('123', '456', '789'),
    array('"aaa"', '"bbb"')
);

$file = new SplFileObject('file.csv', 'w');

foreach ($list as $fields) {
    $file->fputcsv($fields);
}

?>

The above example will write the following to file.csv:

aaa,bbb,ccc,dddd
123,456,789
"""aaa""","""bbb"""

参见

  • fputcsv() - 将行格式化为 CSV 并写入文件指针
  • SplFileObject::fgetcsv() - Gets line from file and parse as CSV fields


Read from file

  • ? SplFileObject::fputcsv
  • SplFileObject::fscanf ?
  • PHP Manual
  • SplFileObject
  • Read from file

SplFileObject::fread

(PHP 5 >= 5.5.11, PHP 7)

SplFileObject::fread — Read from file

说明

public SplFileObject::fread ( int $length ) : string|false

Reads the given number of bytes from the file.

参数

length

The number of bytes to read.

返回值

Returns the string read from the file 或者在失败时返回 false.

范例

Example #1 SplFileObject::fread() example

<?php
// Get contents of a file into a string
$filename = "/usr/local/something.txt";
$file = new SplFileObject($filename, "r");
$contents = $file->fread($file->getSize());
?>

注释

Note:

Note that SplFileObject::fread() reads from the current position of the file pointer. Use SplFileObject::ftell() to find the current position of the pointer and SplFileObject::rewind() (or SplFileObject::fseek()) to rewind the pointer position.

参见

  • fread() - 读取文件（可安全用于二进制文件）


Parses input from file according to a format

  • ? SplFileObject::fread
  • SplFileObject::fseek ?
  • PHP Manual
  • SplFileObject
  • Parses input from file according to a format

SplFileObject::fscanf

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fscanf — Parses input from file according to a format

说明

public SplFileObject::fscanf ( string $format , mixed &...$vars ) : mixed

Reads a line from the file and interprets it according to the specified format, which is described in the documentation for sprintf().

Any whitespace in the format string matches any whitespace in the line from the file. This means that even a tab \t in the format string can match a single space character in the input stream.

参数

format

The format string is composed of zero or more directives: ordinary characters (excluding %) that are copied directly to the result and conversion specifications, each of which results in fetching its own parameter.

A conversion specification follows this prototype: %[argnum$][flags][width][.precision]specifier.

Argnum

An integer followed by a dollar sign $, to specify which number argument to treat in the conversion.

Flags
Flag | 说明
- Left-justify within the given field width; Right justification is the default
+ Prefix positive numbers with a plus sign +; Default only negative are prefixed with a negative sign.
(space) | Pads the result with spaces. This is the default.
0 | Only left-pads numbers with zeros. With s specifiers this can also right-pad with zeros.
'(char) | Pads the result with the character (char).

Width

An integer that says how many characters (minimum) this conversion should result in.

Precision

A period . followed by an integer who's meaning depends on the specifier:

  • For e, E, f and F specifiers: this is the number of digits to be printed after the decimal point (by default, this is 6).
  • For g and G specifiers: this is the maximum number of significant digits to be printed.
  • For s specifier: it acts as a cutoff point, setting a maximum character limit to the string.

Note: If the period is specified without an explicit value for precision, 0 is assumed.

Note: Attempting to use a position specifier greater than PHP_INT_MAX will generate warnings.

Specifiers
Specifier | 说明
% A literal percent character. No argument is required.
b | The argument is treated as an integer and presented as a binary number.
c | The argument is treated as an integer and presented as the character with that ASCII.
d | The argument is treated as an integer and presented as a (signed) decimal number.
e | The argument is treated as scientific notation (e.g. 1.2e+2). The precision specifier stands for the number of digits after the decimal point since PHP 5.2.1. In earlier versions, it was taken as number of significant digits (one less).
E | Like the e specifier but uses uppercase letter (e.g. 1.2E+2).
f | The argument is treated as a float and presented as a floating-point number (locale aware).
F | The argument is treated as a float and presented as a floating-point number (non-locale aware). Available as of PHP 5.0.3.
g

General format.

Let P equal the precision if nonzero, 6 if the precision is omitted, or 1 if the precision is zero. Then, if a conversion with style E would have an exponent of X:

If P > X ≥ ?4, the conversion is with style f and precision P ? (X + 1). Otherwise, the conversion is with style e and precision P ? 1.

G | Like the g specifier but uses E and f.
h | Like the g specifier but uses F. Available as of PHP 8.0.0.
H | Like the g specifier but uses E and F. Available as of PHP 8.0.0.
o | The argument is treated as an integer and presented as an octal number.
s | The argument is treated and presented as a string.
u | The argument is treated as an integer and presented as an unsigned decimal number.
x | The argument is treated as an integer and presented as a hexadecimal number (with lowercase letters).
X | The argument is treated as an integer and presented as a hexadecimal number (with uppercase letters).

Warning

The c type specifier ignores padding and width

Warning

Attempting to use a combination of the string and width specifiers with character sets that require more than one byte per character may result in unexpected results

Variables will be co-erced to a suitable type for the specifier:

Type Handling
Type | Specifiers
string | s
integer | d, u, c, o, x, X, b
double | g, G, e, E, f, F

vars

The optional assigned values.

返回值

If only one parameter is passed to this method, the values parsed will be returned as an array. Otherwise, if optional parameters are passed, the function will return the number of assigned values. The optional parameters must be passed by reference.

范例

Example #1 SplFileObject::fscanf() example

<?php
$file = new SplFileObject("misc.txt");
while ($userinfo = $file->fscanf("%s %s %s")) {
    list ($name, $profession, $countrycode) = $userinfo;
    // Do something with $name $profession $countrycode
}
?>

Contents of users.txt

javier   argonaut    pe
hiroshi  sculptor    jp
robert   slacker     us
luigi    florist     it

参见

  • fscanf() - 从文件中格式化输入
  • sscanf() - 根据指定格式解析输入的字符
  • printf() - 输出格式化字符串
  • sprintf() - Return a formatted string


Seek to a position

  • ? SplFileObject::fscanf
  • SplFileObject::fstat ?
  • PHP Manual
  • SplFileObject
  • Seek to a position

SplFileObject::fseek

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fseek — Seek to a position

说明

public SplFileObject::fseek ( int $offset , int $whence = SEEK_SET ) : int

Seek to a position in the file measured in bytes from the beginning of the file, obtained by adding offset to the position specified by whence.

参数

offset

The offset. A negative value can be used to move backwards through the file which is useful when SEEK_END is used as the whence value.

whence

whence values are:

  • SEEK_SET - Set position equal to offset bytes.
  • SEEK_CUR - Set position to current location plus offset.
  • SEEK_END - Set position to end-of-file plus offset.

If whence is not specified, it is assumed to be SEEK_SET.

返回值

Returns 0 if the seek was successful, -1 otherwise. Note that seeking past EOF is not considered an error.

范例

Example #1 SplFileObject::fseek() example

<?php
$file = new SplFileObject("somefile.txt");

// Read first line
$data = $file->fgets();

// Move back to the beginning of the file
// Same as $file->rewind();
$file->fseek(0);
?>

参见

  • fseek() - 在文件指针中定位


Gets information about the file

  • ? SplFileObject::fseek
  • SplFileObject::ftell ?
  • PHP Manual
  • SplFileObject
  • Gets information about the file

SplFileObject::fstat

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fstat — Gets information about the file

说明

public SplFileObject::fstat ( ) : array

Gathers the statistics of the file. Behaves identically to fstat().

参数

此函数没有参数。

返回值

Returns an array with the statistics of the file; the format of the array is described in detail on the stat() manual page.

范例

Example #1 SplFileObject::fstat() example

<?php
$file = new SplFileObject("/etc/passwd");
$stat = $file->fstat();

// Print only the associative part
print_r(array_slice($stat, 13));

?>

以上例程的输出类似于：

Array
(
    [dev] => 771
    [ino] => 488704
    [mode] => 33188
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 1114
    [atime] => 1061067181
    [mtime] => 1056136526
    [ctime] => 1056136526
    [blksize] => 4096
    [blocks] => 8
)

参见

  • fstat() - 通过已打开的文件指针取得文件信息
  • stat() - 给出文件的信息


Return current file position

  • ? SplFileObject::fstat
  • SplFileObject::ftruncate ?
  • PHP Manual
  • SplFileObject
  • Return current file position

SplFileObject::ftell

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::ftell — Return current file position

说明

public SplFileObject::ftell ( ) : int

Returns the position of the file pointer which represents the current offset in the file stream.

参数

此函数没有参数。

返回值

Returns the position of the file pointer as an integer, or false on error.

范例

Example #1 SplFileObject::ftell() example

<?php
$file = new SplFileObject("/etc/passwd");

// Read first line
$data = $file->fgets();

// Where are we?
echo $file->ftell();
?>

参见

  • ftell() - 返回文件指针读/写的位置


Truncates the file to a given length

  • ? SplFileObject::ftell
  • SplFileObject::fwrite ?
  • PHP Manual
  • SplFileObject
  • Truncates the file to a given length

SplFileObject::ftruncate

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::ftruncate — Truncates the file to a given length

说明

public SplFileObject::ftruncate ( int $size ) : bool

Truncates the file to size bytes.

参数

size

The size to truncate to.

Note:

If size is larger than the file it is extended with null bytes.

If size is smaller than the file, the extra data will be lost.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SplFileObject::ftruncate() example

<?php
// Create file containing "Hello World!"
$file = new SplFileObject("/tmp/ftruncate", "w+");
$file->fwrite("Hello World!");

// Truncate to 5 bytes
$file->ftruncate(5);

// Rewind and read data
$file->rewind();
echo $file->fgets();
?>

以上例程的输出类似于：

Hello

参见

  • ftruncate() - 将文件截断到给定的长度


Write to file

  • ? SplFileObject::ftruncate
  • SplFileObject::getChildren ?
  • PHP Manual
  • SplFileObject
  • Write to file

SplFileObject::fwrite

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fwrite — Write to file

说明

public SplFileObject::fwrite ( string $str , int $length = ? ) : int

Writes the contents of string to the file

参数

str

The string to be written to the file.

length

If the length argument is given, writing will stop after length bytes have been written or the end of string is reached, whichever comes first.

返回值

Returns the number of bytes written, or false on error.

更新日志

版本 | 说明
7.4.0 | The function now returns false instead of zero on failure.

范例

Example #1 SplFileObject::fwrite() example

<?php
$file = new SplFileObject("fwrite.txt", "w");
$written = $file->fwrite("12345");
echo "Wrote $written bytes to file";
?>

以上例程的输出类似于：

Wrote 5 bytes to file

参见

  • fwrite() - 写入文件（可安全用于二进制文件）


No purpose

  • ? SplFileObject::fwrite
  • SplFileObject::getCsvControl ?
  • PHP Manual
  • SplFileObject
  • No purpose

SplFileObject::getChildren

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getChildren — No purpose

说明

public SplFileObject::getChildren ( ) : void

An SplFileObject does not have children so this method returns null.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • RecursiveIterator::getChildren() - Returns an iterator for the current entry


Get the delimiter, enclosure and escape character for CSV

  • ? SplFileObject::getChildren
  • SplFileObject::getCurrentLine ?
  • PHP Manual
  • SplFileObject
  • Get the delimiter, enclosure and escape character for CSV

SplFileObject::getCsvControl

(PHP 5 >= 5.2.0, PHP 7)

SplFileObject::getCsvControl — Get the delimiter, enclosure and escape character for CSV

说明

public SplFileObject::getCsvControl ( ) : array

Gets the delimiter, enclosure and escape character used for parsing CSV fields.

参数

此函数没有参数。

返回值

Returns an indexed array containing the delimiter, enclosure and escape character.

更新日志

版本 | 说明
7.4.0 | The escape character can now be an empty string.
5.6.25, 7.0.10 | Added the escape character to the returned array.

范例

Example #1 SplFileObject::getCsvControl() example

<?php
$file = new SplFileObject("data.txt");
print_r($file->getCsvControl());
?>

以上例程的输出类似于：

Array
(
    [0] => ,
    [1] => "
    [2] => \
)

参见

  • SplFileObject::setCsvControl() - Set the delimiter, enclosure and escape character for CSV
  • SplFileObject::fgetcsv() - Gets line from file and parse as CSV fields


Alias of SplFileObject::fgets

  • ? SplFileObject::getCsvControl
  • SplFileObject::getFlags ?
  • PHP Manual
  • SplFileObject
  • Alias of SplFileObject::fgets

SplFileObject::getCurrentLine

(PHP 5 >= 5.1.2, PHP 7)

SplFileObject::getCurrentLine — Alias of SplFileObject::fgets()

说明

此方法是该方法的别名： SplFileObject::fgets().


Gets flags for the SplFileObject

  • ? SplFileObject::getCurrentLine
  • SplFileObject::getMaxLineLen ?
  • PHP Manual
  • SplFileObject
  • Gets flags for the SplFileObject

SplFileObject::getFlags

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getFlags — Gets flags for the SplFileObject

说明

public SplFileObject::getFlags ( ) : int

Gets the flags set for an instance of SplFileObject as an int.

参数

此函数没有参数。

返回值

Returns an int representing the flags.

范例

Example #1 SplFileObject::getFlags() example

<?php
$file = new SplFileObject(__FILE__, "r");

if ($file->getFlags() & SplFileObject::SKIP_EMPTY) {
    echo "Skipping empty lines\n";
} else {
    echo "Not skipping empty lines\n";
}

$file->setFlags(SplFileObject::SKIP_EMPTY);

if ($file->getFlags() & SplFileObject::SKIP_EMPTY) {
    echo "Skipping empty lines\n";
} else {
    echo "Not skipping empty lines\n";
}
?>

以上例程的输出类似于：

Not skipping empty lines
Skipping empty lines

参见

  • SplFileObject::setFlags() - Sets flags for the SplFileObject


Get maximum line length

  • ? SplFileObject::getFlags
  • SplFileObject::hasChildren ?
  • PHP Manual
  • SplFileObject
  • Get maximum line length

SplFileObject::getMaxLineLen

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getMaxLineLen — Get maximum line length

说明

public SplFileObject::getMaxLineLen ( ) : int

Gets the maximum line length as set by SplFileObject::setMaxLineLen().

参数

此函数没有参数。

返回值

Returns the maximum line length if one has been set with SplFileObject::setMaxLineLen(), default is 0.

范例

Example #1 SplFileObject::getMaxLineLen() example

<?php
$file = new SplFileObject("file.txt");
var_dump($file->getMaxLineLen());

$file->setMaxLineLen(20);
var_dump($file->getMaxLineLen());
?>

以上例程的输出类似于：

int(0)
int(20)

参见

  • SplFileObject::setMaxLineLen() - Set maximum line length


SplFileObject does not have children

  • ? SplFileObject::getMaxLineLen
  • SplFileObject::key ?
  • PHP Manual
  • SplFileObject
  • SplFileObject does not have children

SplFileObject::hasChildren

(PHP 5 >= 5.1.2, PHP 7)

SplFileObject::hasChildren — SplFileObject does not have children

说明

public SplFileObject::hasChildren ( ) : bool

An SplFileObject does not have children so this method always return false.

参数

此函数没有参数。

返回值

Returns false

参见

  • RecursiveIterator::hasChildren() - Returns if an iterator can be created for the current entry


Get line number

  • ? SplFileObject::hasChildren
  • SplFileObject::next ?
  • PHP Manual
  • SplFileObject
  • Get line number

SplFileObject::key

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::key — Get line number

说明

public SplFileObject::key ( ) : int

Gets the current line number.

Note:

This number may not reflect the actual line number in the file if SplFileObject::setMaxLineLen() is used to read fixed lengths of the file.

参数

此函数没有参数。

返回值

Returns the current line number.

范例

Example #1 SplFileObject::key() example

<?php
$file = new SplFileObject("lipsum.txt");
foreach ($file as $line) {
    echo $file->key() . ". " . $line;
}
?>

以上例程的输出类似于：

0. Lorem ipsum dolor sit amet, consectetur adipiscing elit.
1. Duis nec sapien felis, ac sodales nisl.
2. Lorem ipsum dolor sit amet, consectetur adipiscing elit.

Example #2 SplFileObject::key() example with SplFileObject::setMaxLineLen()

<?php
$file = new SplFileObject("lipsum.txt");
$file->setMaxLineLen(20);
foreach ($file as $line) {
    echo $file->key() . ". " . $line . "\n";
}
?>

以上例程的输出类似于：

0. Lorem ipsum dolor s
1. it amet, consectetu
2. r adipiscing elit.
3.

4. Duis nec sapien fel
5. is, ac sodales nisl
6. .

7. Lorem ipsum dolor s
8. it amet, consectetu
9. r adipiscing elit.

参见

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::next() - Read next line
  • SplFileObject::rewind() - Rewind the file to the first line
  • SplFileObject::valid() - Not at EOF


Read next line

  • ? SplFileObject::key
  • SplFileObject::rewind ?
  • PHP Manual
  • SplFileObject
  • Read next line

SplFileObject::next

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::next — Read next line

说明

public SplFileObject::next ( ) : void

Moves ahead to the next line in the file.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 SplFileObject::next() example

<?php
// Read through file line by line
$file = new SplFileObject("misc.txt");
while (!$file->eof()) {
    echo $file->current();
    $file->next();
}
?>

参见

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::key() - Get line number
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::rewind() - Rewind the file to the first line
  • SplFileObject::valid() - Not at EOF


Rewind the file to the first line

  • ? SplFileObject::next
  • SplFileObject::seek ?
  • PHP Manual
  • SplFileObject
  • Rewind the file to the first line

SplFileObject::rewind

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::rewind — Rewind the file to the first line

说明

public SplFileObject::rewind ( ) : void

Rewinds the file back to the first line.

参数

此函数没有参数。

返回值

没有返回值。

错误／异常

Throws a RuntimeException if cannot be rewound.

范例

Example #1 SplFileObject::rewind() example

<?php
$file = new SplFileObject("misc.txt");

// Loop over whole file
foreach ($file as $line) { }

// Rewind to first line
$file->rewind();

// Output first line
echo $file->current();
?>

参见

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::key() - Get line number
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::next() - Read next line
  • SplFileObject::valid() - Not at EOF


Seek to specified line

  • ? SplFileObject::rewind
  • SplFileObject::setCsvControl ?
  • PHP Manual
  • SplFileObject
  • Seek to specified line

SplFileObject::seek

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::seek — Seek to specified line

说明

public SplFileObject::seek ( int $line_pos ) : void

Seek to specified line in the file.

参数

line_pos

The zero-based line number to seek to.

返回值

没有返回值。

错误／异常

Throws a LogicException if the line_pos is negative.

范例

Example #1 SplFileObject::seek() example

This example outputs the third line of the script which is found at position 2.

<?php
$file = new SplFileObject(__FILE__);
$file->seek(2);
echo $file->current();
?>

以上例程的输出类似于：

$file->seek(2);

参见

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::key() - Get line number
  • SplFileObject::next() - Read next line
  • SplFileObject::rewind() - Rewind the file to the first line
  • SplFileObject::valid() - Not at EOF


Set the delimiter, enclosure and escape character for CSV

  • ? SplFileObject::seek
  • SplFileObject::setFlags ?
  • PHP Manual
  • SplFileObject
  • Set the delimiter, enclosure and escape character for CSV

SplFileObject::setCsvControl

(PHP 5 >= 5.2.0, PHP 7)

SplFileObject::setCsvControl — Set the delimiter, enclosure and escape character for CSV

说明

public SplFileObject::setCsvControl
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : void

Sets the delimiter, enclosure and escape character for parsing CSV fields.

参数

delimiter

The field delimiter (one character only).

enclosure

The field enclosure character (one character only).

escape

The field escape character (at most one character). An empty string ("") disables the proprietary escape mechanism.

返回值

没有返回值。

更新日志

版本 | 说明
7.4.0 | The escape parameter now also accepts an empty string to disable the proprietary escape mechanism.

范例

Example #1 SplFileObject::setCsvControl() example

<?php
$file = new SplFileObject("data.csv");
$file->setFlags(SplFileObject::READ_CSV);
$file->setCsvControl('|');
foreach ($file as $row) {
    list ($fruit, $quantity) = $row;
    // Do something with values
}
?>

Contents of data.csv

<?php
apples|20
bananas|14
cherries|87
?>

参见

  • SplFileObject::getCsvControl() - Get the delimiter, enclosure and escape character for CSV
  • SplFileObject::fgetcsv() - Gets line from file and parse as CSV fields


Sets flags for the SplFileObject

  • ? SplFileObject::setCsvControl
  • SplFileObject::setMaxLineLen ?
  • PHP Manual
  • SplFileObject
  • Sets flags for the SplFileObject

SplFileObject::setFlags

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::setFlags — Sets flags for the SplFileObject

说明

public SplFileObject::setFlags ( int $flags ) : void

Sets the flags to be used by the SplFileObject.

参数

flags

Bit mask of the flags to set. See SplFileObject constants for the available flags.

返回值

没有返回值。

范例

Example #1 SplFileObject::setFlags() example

<?php
$file = new SplFileObject("data.csv");
$file->setFlags(SplFileObject::READ_CSV);
foreach ($file as $fields) {
    var_dump($fields);
}
?>

参见

  • SplFileObject::getFlags() - Gets flags for the SplFileObject


Set maximum line length

  • ? SplFileObject::setFlags
  • SplFileObject::__toString ?
  • PHP Manual
  • SplFileObject
  • Set maximum line length

SplFileObject::setMaxLineLen

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::setMaxLineLen — Set maximum line length

说明

public SplFileObject::setMaxLineLen ( int $max_len ) : void

Sets the maximum length of a line to be read.

参数

max_len

The maximum length of a line.

返回值

没有返回值。

错误／异常

Throws DomainException when max_len is less than zero.

范例

Example #1 SplFileObject::setMaxLineLen() example

<?php
$file = new SplFileObject("lipsum.txt");
$file->setMaxLineLen(20);
foreach ($file as $line) {
    echo $line . "\n";
}
?>

Contents of lipsum.txt

Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Duis nec sapien felis, ac sodales nisl.
Nulla vitae magna vitae purus aliquet consequat.

以上例程的输出类似于：

Lorem ipsum dolor s
it amet, consectetu
r adipiscing elit.

Duis nec sapien fel
is, ac sodales nisl
.

Nulla vitae magna v
itae purus aliquet
consequat.

参见

  • SplFileObject::getMaxLineLen() - Get maximum line length


Alias of SplFileObject::fgets

  • ? SplFileObject::setMaxLineLen
  • SplFileObject::valid ?
  • PHP Manual
  • SplFileObject
  • Alias of SplFileObject::fgets

SplFileObject::__toString

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::__toString — Alias of SplFileObject::fgets()

说明

此方法是该方法的别名： SplFileObject::fgets().

更新日志

版本 | 说明
7.2.19, 7.3.6 | Changed from an alias of SplFileObject::current() to an alias of SplFileObject::fgets().


Not at EOF

  • ? SplFileObject::__toString
  • SplTempFileObject ?
  • PHP Manual
  • SplFileObject
  • Not at EOF

SplFileObject::valid

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::valid — Not at EOF

说明

public SplFileObject::valid ( ) : bool

Check whether EOF has been reached.

参数

此函数没有参数。

返回值

Returns true if not reached EOF, false otherwise.

范例

Example #1 SplFileObject::valid() example

<?php
// Loop over a file, line by line
$file = new SplFileObject("file.txt");
while ($file->valid()) {
    echo $file->fgets();
}
?>

参见

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::key() - Get line number
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::next() - Read next line
  • SplFileObject::rewind() - Rewind the file to the first line


The SplTempFileObject class

(PHP 5 >= 5.1.2, PHP 7)

简介

The SplTempFileObject class offers an object oriented interface for a temporary file.

类摘要

SplTempFileObject extends SplFileObject implements SeekableIterator , RecursiveIterator {
/* 继承的常量 */
const integer SplFileObject::DROP_NEW_LINE = 1 ;
const integer SplFileObject::READ_AHEAD = 2 ;
const integer SplFileObject::SKIP_EMPTY = 4 ;
const integer SplFileObject::READ_CSV = 8 ;
/* 方法 */
public __construct ( int $max_memory = ? )
/* 继承的方法 */
public SplFileObject::current ( ) : string|array
public SplFileObject::eof ( ) : bool
public SplFileObject::fflush ( ) : bool
public SplFileObject::fgetc ( ) : string
public SplFileObject::fgetcsv
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : array
public SplFileObject::fgets ( ) : string
public SplFileObject::fgetss ( string $allowable_tags = ? ) : string
public SplFileObject::flock ( int $operation , int &$wouldblock = ? ) : bool
public SplFileObject::fpassthru ( ) : int
public SplFileObject::fputcsv
 ( array $fields
, string $delimiter = ","
, string $enclosure = '"'
, string $escape = "\\"
) : int|false
public SplFileObject::fread ( int $length ) : string|false
public SplFileObject::fscanf ( string $format , mixed &...$vars ) : mixed
public SplFileObject::fseek ( int $offset , int $whence = SEEK_SET ) : int
public SplFileObject::fstat ( ) : array
public SplFileObject::ftell ( ) : int
public SplFileObject::ftruncate ( int $size ) : bool
public SplFileObject::fwrite ( string $str , int $length = ? ) : int
public SplFileObject::getChildren ( ) : void
public SplFileObject::getCsvControl ( ) : array
public SplFileObject::getFlags ( ) : int
public SplFileObject::getMaxLineLen ( ) : int
public SplFileObject::hasChildren ( ) : bool
public SplFileObject::key ( ) : int
public SplFileObject::next ( ) : void
public SplFileObject::rewind ( ) : void
public SplFileObject::seek ( int $line_pos ) : void
public SplFileObject::setCsvControl
 ( string $delimiter = ","
, string $enclosure = "\""
, string $escape = "\\"
) : void
public SplFileObject::setFlags ( int $flags ) : void
public SplFileObject::setMaxLineLen ( int $max_len ) : void
public SplFileObject::valid ( ) : bool
}

Table of Contents

  • SplTempFileObject::__construct — Construct a new temporary file object


Construct a new temporary file object

  • ? SplTempFileObject
  • 各种类及接口 ?
  • PHP Manual
  • SplTempFileObject
  • Construct a new temporary file object

SplTempFileObject::__construct

(PHP 5 >= 5.1.2, PHP 7)

SplTempFileObject::__construct — Construct a new temporary file object

说明

public SplTempFileObject::__construct ( int $max_memory = ? )

Construct a new temporary file object.

参数

max_memory

The maximum amount of memory (in bytes, default is 2 MB) for the temporary file to use. If the temporary file exceeds this size, it will be moved to a file in the system's temp directory.

If max_memory is negative, only memory will be used. If max_memory is zero, no memory will be used.

返回值

没有返回值。

错误／异常

Throws a RuntimeException if an error occurs.

范例

Example #1 SplTempFileObject() example

This example writes a temporary file in memory which can be written to and read from.

<?php
$temp = new SplTempFileObject();
$temp->fwrite("This is the first line\n");
$temp->fwrite("And this is the second.\n");
echo "Written " . $temp->ftell() . " bytes to temporary file.\n\n";

// Rewind and read what was written
$temp->rewind();
foreach ($temp as $line) {
    echo $line;
}
?>

以上例程的输出类似于：

Written 47 bytes to temporary file.

This is the first line
And this is the second.

参见

  • SplFileObject
  • PHP input/output streams (for php://temp and php://memory)


各种类及接口

Table of Contents

  • ArrayObject
  • SplObserver
  • SplSubject

无法归入其它 SPL 分类的类和接口。


The ArrayObject class

(PHP 5, PHP 7)

简介

This class allows objects to work as arrays.

类摘要

ArrayObject implements IteratorAggregate , ArrayAccess , Serializable , Countable {
/* 常量 */
const int STD_PROP_LIST = 1 ;
const int ARRAY_AS_PROPS = 2 ;
/* 方法 */
public __construct ( mixed $input = array() , int $flags = 0 , string $iterator_class = "ArrayIterator" )
public append ( mixed $value ) : void
public asort ( int $flags = SORT_REGULAR ) : void
public count ( ) : int
public exchangeArray ( mixed $input ) : array
public getArrayCopy ( ) : array
public getFlags ( ) : int
public getIterator ( ) : ArrayIterator
public getIteratorClass ( ) : string
public ksort ( int $flags = SORT_REGULAR ) : void
public natcasesort ( ) : void
public natsort ( ) : void
public offsetExists ( mixed $index ) : bool
public offsetGet ( mixed $index ) : mixed
public offsetSet ( mixed $index , mixed $newval ) : void
public offsetUnset ( mixed $index ) : void
public serialize ( ) : string
public setFlags ( int $flags ) : void
public setIteratorClass ( string $iterator_class ) : void
public uasort ( callable $cmp_function ) : void
public uksort ( callable $cmp_function ) : void
public unserialize ( string $serialized ) : void
}

预定义常量

ArrayObject Flags

ArrayObject::STD_PROP_LIST

Properties of the object have their normal functionality when accessed as list (var_dump, foreach, etc.).

ArrayObject::ARRAY_AS_PROPS

Entries can be accessed as properties (read and write).

更新日志

版本 | 说明
5.3.0 | Implements Serializable.

Table of Contents

  • ArrayObject::append — 追加新的值作为最后一个元素。
  • ArrayObject::asort — Sort the entries by value
  • ArrayObject::__construct — Construct a new array object
  • ArrayObject::count — 统计 ArrayObject 内 public 属性的数量
  • ArrayObject::exchangeArray — Exchange the array for another one
  • ArrayObject::getArrayCopy — Creates a copy of the ArrayObject
  • ArrayObject::getFlags — Gets the behavior flags
  • ArrayObject::getIterator — Create a new iterator from an ArrayObject instance
  • ArrayObject::getIteratorClass — Gets the iterator classname for the ArrayObject
  • ArrayObject::ksort — Sort the entries by key
  • ArrayObject::natcasesort — Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::natsort — Sort entries using a "natural order" algorithm
  • ArrayObject::offsetExists — Returns whether the requested index exists
  • ArrayObject::offsetGet — Returns the value at the specified index
  • ArrayObject::offsetSet — 为指定索引设定新的值
  • ArrayObject::offsetUnset — Unsets the value at the specified index
  • ArrayObject::serialize — Serialize an ArrayObject
  • ArrayObject::setFlags — Sets the behavior flags
  • ArrayObject::setIteratorClass — Sets the iterator classname for the ArrayObject
  • ArrayObject::uasort — Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort — Sort the entries by keys using a user-defined comparison function
  • ArrayObject::unserialize — Unserialize an ArrayObject


追加新的值作为最后一个元素。

  • ? ArrayObject
  • ArrayObject::asort ?
  • PHP Manual
  • ArrayObject
  • 追加新的值作为最后一个元素。

ArrayObject::append

(PHP 5, PHP 7)

ArrayObject::append — 追加新的值作为最后一个元素。

说明

public ArrayObject::append ( mixed $value ) : void

追加新的值作为最后一个元素。

Note:

当 ArrayObject 从 object 初始化时不能调用此方法。使用 ArrayObject::offsetSet() 代替。

参数

value

将要被追加的值

返回值

没有返回值。

范例

Example #1 ArrayObject::append() 例子

<?php
$arrayobj = new ArrayObject(array('first','second','third'));
$arrayobj->append('fourth');
$arrayobj->append(array('five', 'six'));
var_dump($arrayobj);
?>

以上例程会输出：

object(ArrayObject)#1 (5) {
  [0]=>
  string(5) "first"
  [1]=>
  string(6) "second"
  [2]=>
  string(5) "third"
  [3]=>
  string(6) "fourth"
  [4]=>
  array(2) {
    [0]=>
    string(4) "five"
    [1]=>
    string(3) "six"
  }
}

参见

  • ArrayObject::offsetSet() - 为指定索引设定新的值


Sort the entries by value

  • ? ArrayObject::append
  • ArrayObject::__construct ?
  • PHP Manual
  • ArrayObject
  • Sort the entries by value

ArrayObject::asort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::asort — Sort the entries by value

说明

public ArrayObject::asort ( int $flags = SORT_REGULAR ) : void

Sorts the entries such that the keys maintain their correlation with the entries they are associated with. This is used mainly when sorting associative arrays where the actual element order is significant.

参数

flags

The optional second parameter flags may be used to modify the sorting behavior using these values:

Sorting type flags:

  • SORT_REGULAR - compare items normally; the details are described in the comparison operators section
  • SORT_NUMERIC - compare items numerically
  • SORT_STRING - compare items as strings
  • SORT_LOCALE_STRING - compare items as strings, based on the current locale. It uses the locale, which can be changed using setlocale()
  • SORT_NATURAL - compare items as strings using "natural ordering" like natsort()
  • SORT_FLAG_CASE - can be combined (bitwise OR) with SORT_STRING or SORT_NATURAL to sort strings case-insensitively

返回值

没有返回值。

范例

Example #1 ArrayObject::asort() example

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
$fruitArrayObject = new ArrayObject($fruits);
$fruitArrayObject->asort();

foreach ($fruitArrayObject as $key => $val) {
    echo "$key = $val\n";
}
?>

以上例程会输出：

c = apple
b = banana
d = lemon
a = orange

The fruits have been sorted in alphabetical order, and the key associated with each entry has been maintained.

参见

  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function


Construct a new array object

  • ? ArrayObject::asort
  • ArrayObject::count ?
  • PHP Manual
  • ArrayObject
  • Construct a new array object

ArrayObject::__construct

(PHP 5, PHP 7)

ArrayObject::__construct — Construct a new array object

说明

public ArrayObject::__construct ( mixed $input = array() , int $flags = 0 , string $iterator_class = "ArrayIterator" )

This constructs a new array object.

参数

input

The input parameter accepts an array or an Object.

flags

Flags to control the behaviour of the ArrayObject object. See ArrayObject::setFlags().

iterator_class

Specify the class that will be used for iteration of the ArrayObject object.

返回值

Returns an ArrayObject object on success.

错误／异常

Throws InvalidArgumentException when:

  • input is not an array or object
  • flags is not an integer
  • iterator_class is not an object that implements Iterator

范例

Example #1 ArrayObject::__construct() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

var_dump($arrayobject);
?>

以上例程会输出：

object(ArrayObject)#1 (3) {
  [1]=>
  string(3) "one"
  [2]=>
  string(3) "two"
  [3]=>
  string(5) "three"
}

参见

  • ArrayObject::setflags() - Sets the behavior flags


统计 ArrayObject 内 public 属性的数量

  • ? ArrayObject::__construct
  • ArrayObject::exchangeArray ?
  • PHP Manual
  • ArrayObject
  • 统计 ArrayObject 内 public 属性的数量

ArrayObject::count

(PHP 5, PHP 7)

ArrayObject::count — 统计 ArrayObject 内 public 属性的数量

说明

public ArrayObject::count ( ) : int

获取 ArrayObject 的 public 属性数量

参数

此函数没有参数。

返回值

对象 ArrayObject 的 public 属性数量

Note:

当对象 ArrayObject 是从数组构造而来时，所有属性都是 public 的。

范例

Example #1 ArrayObject::count() 例子

<?php
class Example {
    public $public = 'prop:public';
    private $prv   = 'prop:private';
    protected $prt = 'prop:protected';
}

$arrayobj = new ArrayObject(new Example());
var_dump($arrayobj->count());

$arrayobj = new ArrayObject(array('first','second','third'));
var_dump($arrayobj->count());
?>

以上例程会输出：

int(1)
int(3)


Exchange the array for another one

  • ? ArrayObject::count
  • ArrayObject::getArrayCopy ?
  • PHP Manual
  • ArrayObject
  • Exchange the array for another one

ArrayObject::exchangeArray

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::exchangeArray — Exchange the array for another one

说明

public ArrayObject::exchangeArray ( mixed $input ) : array

Exchange the current array with another array or object.

参数

input

The new array or object to exchange with the current array.

返回值

Returns the old array.

范例

Example #1 ArrayObject::exchangeArray() example

<?php
// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);
// Array of locations in Europe
$locations = array('Amsterdam', 'Paris', 'London');

$fruitsArrayObject = new ArrayObject($fruits);

// Now exchange fruits for locations
$old = $fruitsArrayObject->exchangeArray($locations);
print_r($old);
print_r($fruitsArrayObject);

?>

以上例程会输出：

Array
(
    [lemons] => 1
    [oranges] => 4
    [bananas] => 5
    [apples] => 10
)
ArrayObject Object
(
    [0] => Amsterdam
    [1] => Paris
    [2] => London
)


Creates a copy of the ArrayObject

  • ? ArrayObject::exchangeArray
  • ArrayObject::getFlags ?
  • PHP Manual
  • ArrayObject
  • Creates a copy of the ArrayObject

ArrayObject::getArrayCopy

(PHP 5, PHP 7)

ArrayObject::getArrayCopy — Creates a copy of the ArrayObject

说明

public ArrayObject::getArrayCopy ( ) : array

Exports the ArrayObject to an array.

参数

此函数没有参数。

返回值

Returns a copy of the array. When the ArrayObject refers to an object, an array of the properties of that object will be returned.

范例

Example #1 ArrayObject::getArrayCopy() example

<?php
// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);
$fruitsArrayObject['pears'] = 4;

// create a copy of the array
$copy = $fruitsArrayObject->getArrayCopy();
print_r($copy);

?>

以上例程会输出：

Array
(
    [lemons] => 1
    [oranges] => 4
    [bananas] => 5
    [apples] => 10
    [pears] => 4
)


Gets the behavior flags

  • ? ArrayObject::getArrayCopy
  • ArrayObject::getIterator ?
  • PHP Manual
  • ArrayObject
  • Gets the behavior flags

ArrayObject::getFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::getFlags — Gets the behavior flags

说明

public ArrayObject::getFlags ( ) : int

Gets the behavior flags of the ArrayObject. See the ArrayObject::setFlags method for a list of the available flags.

参数

此函数没有参数。

返回值

Returns the behavior flags of the ArrayObject.

范例

Example #1 ArrayObject::getFlags() example

<?php
// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Get the current flags
$flags = $fruitsArrayObject->getFlags();
var_dump($flags);

// Set new flags
$fruitsArrayObject->setFlags(ArrayObject::ARRAY_AS_PROPS);

// Get the new flags
$flags = $fruitsArrayObject->getFlags();
var_dump($flags);
?>

以上例程会输出：

int(0)
int(2)

参见

  • ArrayObject::setFlags() - Sets the behavior flags


Create a new iterator from an ArrayObject instance

  • ? ArrayObject::getFlags
  • ArrayObject::getIteratorClass ?
  • PHP Manual
  • ArrayObject
  • Create a new iterator from an ArrayObject instance

ArrayObject::getIterator

(PHP 5, PHP 7)

ArrayObject::getIterator — Create a new iterator from an ArrayObject instance

说明

public ArrayObject::getIterator ( ) : ArrayIterator

Create a new iterator from an ArrayObject instance.

参数

此函数没有参数。

返回值

An iterator from an ArrayObject.

范例

Example #1 ArrayObject::getIterator() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

以上例程会输出：

1 => one
2 => two
3 => three


Gets the iterator classname for the ArrayObject

  • ? ArrayObject::getIterator
  • ArrayObject::ksort ?
  • PHP Manual
  • ArrayObject
  • Gets the iterator classname for the ArrayObject

ArrayObject::getIteratorClass

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::getIteratorClass — Gets the iterator classname for the ArrayObject

说明

public ArrayObject::getIteratorClass ( ) : string

Gets the class name of the array iterator that is used by ArrayObject::getIterator().

参数

此函数没有参数。

返回值

Returns the iterator class name that is used to iterate over this object.

范例

Example #1 ArrayObject::getIteratorClass() example

<?php
// Custom ArrayIterator (inherits from ArrayIterator)
class MyArrayIterator extends ArrayIterator {
    // custom implementation
}

// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Get the current class name
$className = $fruitsArrayObject->getIteratorClass();
var_dump($className);

// Set new classname
$fruitsArrayObject->setIteratorClass('MyArrayIterator');

// Get the new iterator classname
$className = $fruitsArrayObject->getIteratorClass();
var_dump($className);
?>

以上例程会输出：

string(13) "ArrayIterator"
string(15) "MyArrayIterator"

参见

  • The ArrayObject::setIteratorClass method


Sort the entries by key

  • ? ArrayObject::getIteratorClass
  • ArrayObject::natcasesort ?
  • PHP Manual
  • ArrayObject
  • Sort the entries by key

ArrayObject::ksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::ksort — Sort the entries by key

说明

public ArrayObject::ksort ( int $flags = SORT_REGULAR ) : void

Sorts the entries by key, maintaining key to entry correlations. This is useful mainly for associative arrays.

参数

flags

The optional second parameter flags may be used to modify the sorting behavior using these values:

Sorting type flags:

  • SORT_REGULAR - compare items normally; the details are described in the comparison operators section
  • SORT_NUMERIC - compare items numerically
  • SORT_STRING - compare items as strings
  • SORT_LOCALE_STRING - compare items as strings, based on the current locale. It uses the locale, which can be changed using setlocale()
  • SORT_NATURAL - compare items as strings using "natural ordering" like natsort()
  • SORT_FLAG_CASE - can be combined (bitwise OR) with SORT_STRING or SORT_NATURAL to sort strings case-insensitively

返回值

没有返回值。

范例

Example #1 ArrayObject::ksort() example

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
$fruitArrayObject = new ArrayObject($fruits);
$fruitArrayObject->ksort();

foreach ($fruitArrayObject as $key => $val) {
    echo "$key = $val\n";
}
 ?>

以上例程会输出：

a = orange
b = banana
c = apple
d = lemon

参见

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function


Sort an array using a case insensitive "natural order" algorithm

  • ? ArrayObject::ksort
  • ArrayObject::natsort ?
  • PHP Manual
  • ArrayObject
  • Sort an array using a case insensitive "natural order" algorithm

ArrayObject::natcasesort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::natcasesort — Sort an array using a case insensitive "natural order" algorithm

说明

public ArrayObject::natcasesort ( ) : void

This method is a case insensitive version of ArrayObject::natsort.

This method implements a sort algorithm that orders alphanumeric strings in the way a human being would while maintaining key/value associations. This is described as a "natural ordering".

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 ArrayObject::natcasesort() example

<?php
$array = array('IMG0.png', 'img12.png', 'img10.png', 'img2.png', 'img1.png', 'IMG3.png');

$arr1 = new ArrayObject($array);
$arr2 = clone $arr1;

$arr1->asort();
echo "Standard sorting\n";
print_r($arr1);

$arr2->natcasesort();
echo "\nNatural order sorting (case-insensitive)\n";
print_r($arr2);
?>

以上例程会输出：

Standard sorting
ArrayObject Object
(
    [0] => IMG0.png
    [5] => IMG3.png
    [4] => img1.png
    [2] => img10.png
    [1] => img12.png
    [3] => img2.png
)

Natural order sorting (case-insensitive)
ArrayObject Object
(
    [0] => IMG0.png
    [4] => img1.png
    [3] => img2.png
    [5] => IMG3.png
    [2] => img10.png
    [1] => img12.png
)

For more information see: Martin Pool's » Natural Order String Comparison page.

参见

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function


Sort entries using a "natural order" algorithm

  • ? ArrayObject::natcasesort
  • ArrayObject::offsetExists ?
  • PHP Manual
  • ArrayObject
  • Sort entries using a "natural order" algorithm

ArrayObject::natsort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::natsort — Sort entries using a "natural order" algorithm

说明

public ArrayObject::natsort ( ) : void

This method implements a sort algorithm that orders alphanumeric strings in the way a human being would while maintaining key/value associations. This is described as a "natural ordering". An example of the difference between this algorithm and the regular computer string sorting algorithms (used in ArrayObject::asort) method can be seen in the example below.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 ArrayObject::natsort() example

<?php
$array = array("img12.png", "img10.png", "img2.png", "img1.png");

$arr1 = new ArrayObject($array);
$arr2 = clone $arr1;

$arr1->asort();
echo "Standard sorting\n";
print_r($arr1);

$arr2->natsort();
echo "\nNatural order sorting\n";
print_r($arr2);
?>

以上例程会输出：

Standard sorting
ArrayObject Object
(
    [3] => img1.png
    [1] => img10.png
    [0] => img12.png
    [2] => img2.png
)

Natural order sorting
ArrayObject Object
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)

For more information see: Martin Pool's » Natural Order String Comparison page.

参见

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function


Returns whether the requested index exists

  • ? ArrayObject::natsort
  • ArrayObject::offsetGet ?
  • PHP Manual
  • ArrayObject
  • Returns whether the requested index exists

ArrayObject::offsetExists

(PHP 5, PHP 7)

ArrayObject::offsetExists — Returns whether the requested index exists

说明

public ArrayObject::offsetExists ( mixed $index ) : bool

参数

index

The index being checked.

返回值

true if the requested index exists, otherwise false

范例

Example #1 ArrayObject::offsetExists() example

<?php
$arrayobj = new ArrayObject(array('zero', 'one', 'example'=>'e.g.'));
var_dump($arrayobj->offsetExists(1));
var_dump($arrayobj->offsetExists('example'));
var_dump($arrayobj->offsetExists('notfound'));
?>

以上例程会输出：

bool(true)
bool(true)
bool(false)


Returns the value at the specified index

  • ? ArrayObject::offsetExists
  • ArrayObject::offsetSet ?
  • PHP Manual
  • ArrayObject
  • Returns the value at the specified index

ArrayObject::offsetGet

(PHP 5, PHP 7)

ArrayObject::offsetGet — Returns the value at the specified index

说明

public ArrayObject::offsetGet ( mixed $index ) : mixed

参数

index

The index with the value.

返回值

The value at the specified index or null.

错误／异常

Produces an E_NOTICE error message when the specified index does not exist.

范例

Example #1 ArrayObject::offsetGet() example

<?php
$arrayobj = new ArrayObject(array('zero', 7, 'example'=>'e.g.'));
var_dump($arrayobj->offsetGet(1));
var_dump($arrayobj->offsetGet('example'));
var_dump($arrayobj->offsetExists('notfound'));
?>

以上例程会输出：

int(7)
string(4) "e.g."
bool(false)


为指定索引设定新的值

  • ? ArrayObject::offsetGet
  • ArrayObject::offsetUnset ?
  • PHP Manual
  • ArrayObject
  • 为指定索引设定新的值

ArrayObject::offsetSet

(PHP 5, PHP 7)

ArrayObject::offsetSet — 为指定索引设定新的值

说明

public ArrayObject::offsetSet ( mixed $index , mixed $newval ) : void

设置指定的索引为新的值

参数

index

将要被设置的索引

newval

参数 index 所对应的新值。

返回值

没有返回值。

范例

Example #1 ArrayObject::offsetSet() 例子

<?php
class Example {
    public $property = 'prop:public';
}
$arrayobj = new ArrayObject(new Example());
$arrayobj->offsetSet(4, 'four');
$arrayobj->offsetSet('group', array('g1', 'g2'));
var_dump($arrayobj);

$arrayobj = new ArrayObject(array('zero','one'));
$arrayobj->offsetSet(null, 'last');
var_dump($arrayobj);
?>

以上例程会输出：

object(ArrayObject)#1 (3) {
  ["property"]=>
  string(11) "prop:public"
  [4]=>
  string(4) "four"
  ["group"]=>
  array(2) {
    [0]=>
    string(2) "g1"
    [1]=>
    string(2) "g2"
  }
}
object(ArrayObject)#3 (3) {
  [0]=>
  string(4) "zero"
  [1]=>
  string(3) "one"
  [2]=>
  string(4) "last"
}

参见

  • ArrayObject::append() - 追加新的值作为最后一个元素。


Unsets the value at the specified index

  • ? ArrayObject::offsetSet
  • ArrayObject::serialize ?
  • PHP Manual
  • ArrayObject
  • Unsets the value at the specified index

ArrayObject::offsetUnset

(PHP 5, PHP 7)

ArrayObject::offsetUnset — Unsets the value at the specified index

说明

public ArrayObject::offsetUnset ( mixed $index ) : void

Unsets the value at the specified index.

参数

index

The index being unset.

返回值

没有返回值。

范例

Example #1 ArrayObject::offsetUnset() example

<?php
$arrayobj = new ArrayObject(array(0=>'zero',2=>'two'));
$arrayobj->offsetUnset(2);
var_dump($arrayobj);
?>

以上例程会输出：

object(ArrayObject)#1 (1) {
  [0]=>
  string(4) "zero"
}


Serialize an ArrayObject

  • ? ArrayObject::offsetUnset
  • ArrayObject::setFlags ?
  • PHP Manual
  • ArrayObject
  • Serialize an ArrayObject

ArrayObject::serialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayObject::serialize — Serialize an ArrayObject

说明

public ArrayObject::serialize ( ) : string

Serializes an ArrayObject.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The serialized representation of the ArrayObject.

范例

Example #1 ArrayObject::serialize() example

<?php
$o = new ArrayObject();

$s1 = serialize($o);
$s2 = $o->serialize();

var_dump($s1);
var_dump($s2);
?>

以上例程会输出：

string(45) "C:11:"ArrayObject":21:{x:i:0;a:0:{};m:a:0:{}}"
string(21) "x:i:0;a:0:{};m:a:0:{}"

参见

  • ArrayObject::unserialize() - Unserialize an ArrayObject
  • serialize() - 产生一个可存储的值的表示
  • Serializing Objects


Sets the behavior flags

  • ? ArrayObject::serialize
  • ArrayObject::setIteratorClass ?
  • PHP Manual
  • ArrayObject
  • Sets the behavior flags

ArrayObject::setFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::setFlags — Sets the behavior flags

说明

public ArrayObject::setFlags ( int $flags ) : void

Set the flags that change the behavior of the ArrayObject.

参数

flags

The new ArrayObject behavior. It takes on either a bitmask, or named constants. Using named constants is strongly encouraged to ensure compatibility for future versions.

The available behavior flags are listed below. The actual meanings of these flags are described in the predefined constants.

ArrayObject behavior flags
value | constant
1 | ArrayObject::STD_PROP_LIST
2 | ArrayObject::ARRAY_AS_PROPS

返回值

没有返回值。

范例

Example #1 ArrayObject::setFlags() example

<?php
// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Try to use array key as property
var_dump($fruitsArrayObject->lemons);
// Set the flag so that the array keys can be used as properties of the ArrayObject
$fruitsArrayObject->setFlags(ArrayObject::ARRAY_AS_PROPS);
// Try it again
var_dump($fruitsArrayObject->lemons);
?>

以上例程会输出：

NULL
int(1)


Sets the iterator classname for the ArrayObject

  • ? ArrayObject::setFlags
  • ArrayObject::uasort ?
  • PHP Manual
  • ArrayObject
  • Sets the iterator classname for the ArrayObject

ArrayObject::setIteratorClass

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::setIteratorClass — Sets the iterator classname for the ArrayObject

说明

public ArrayObject::setIteratorClass ( string $iterator_class ) : void

Sets the classname of the array iterator that is used by ArrayObject::getIterator().

参数

iterator_class

The classname of the array iterator to use when iterating over this object.

返回值

没有返回值。

范例

Example #1 ArrayObject::setIteratorClass() example

<?php
// Custom ArrayIterator (inherits from ArrayIterator)
class MyArrayIterator extends ArrayIterator {
    // custom implementation
}

// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Set the iterator classname to the newly
$fruitsArrayObject->setIteratorClass('MyArrayIterator');
print_r($fruitsArrayObject->getIterator());

?>

以上例程会输出：

MyArrayIterator Object
(
    [lemons] => 1
    [oranges] => 4
    [bananas] => 5
    [apples] => 10
)


Sort the entries with a user-defined comparison function and maintain key association

  • ? ArrayObject::setIteratorClass
  • ArrayObject::uksort ?
  • PHP Manual
  • ArrayObject
  • Sort the entries with a user-defined comparison function and maintain key association

ArrayObject::uasort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::uasort — Sort the entries with a user-defined comparison function and maintain key association

说明

public ArrayObject::uasort ( callable $cmp_function ) : void

This function sorts the entries such that keys maintain their correlation with the entry that they are associated with, using a user-defined comparison function.

This is used mainly when sorting associative arrays where the actual element order is significant.

参数

cmp_function

Function cmp_function should accept two parameters which will be filled by pairs of entries. The comparison function must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

返回值

没有返回值。

范例

Example #1 ArrayObject::uasort() example

<?php
// Comparison function
function cmp($a, $b) {
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

// Array to be sorted
$array = array('a' => 4, 'b' => 8, 'c' => -1, 'd' => -9, 'e' => 2, 'f' => 5, 'g' => 3, 'h' => -4);
$arrayObject = new ArrayObject($array);
print_r($arrayObject);

// Sort and print the resulting array
$arrayObject->uasort('cmp');
print_r($arrayObject);
?>

以上例程会输出：

Array
(
    [a] => 4
    [b] => 8
    [c] => -1
    [d] => -9
    [e] => 2
    [f] => 5
    [g] => 3
    [h] => -4
)
Array
(
    [d] => -9
    [h] => -4
    [c] => -1
    [e] => 2
    [g] => 3
    [a] => 4
    [f] => 5
    [b] => 8
)

参见

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function


Sort the entries by keys using a user-defined comparison function

  • ? ArrayObject::uasort
  • ArrayObject::unserialize ?
  • PHP Manual
  • ArrayObject
  • Sort the entries by keys using a user-defined comparison function

ArrayObject::uksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::uksort — Sort the entries by keys using a user-defined comparison function

说明

public ArrayObject::uksort ( callable $cmp_function ) : void

This function sorts the keys of the entries using a user-supplied comparison function. The key to entry correlations will be maintained.

参数

cmp_function

The callback comparison function.

Function cmp_function should accept two parameters which will be filled by pairs of entry keys. The comparison function must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

返回值

没有返回值。

范例

Example #1 ArrayObject::uksort() example

<?php
function cmp($a, $b) {
    $a = preg_replace('@^(a|an|the) @', '', $a);
    $b = preg_replace('@^(a|an|the) @', '', $b);
    return strcasecmp($a, $b);
}

$array = array("John" => 1, "the Earth" => 2, "an apple" => 3, "a banana" => 4);
$arrayObject = new ArrayObject($array);
$arrayObject->uksort('cmp');

foreach ($arrayObject as $key => $value) {
    echo "$key: $value\n";
}
?>

以上例程会输出：

an apple: 3
a banana: 4
the Earth: 2
John: 1

参见

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association


Unserialize an ArrayObject

  • ? ArrayObject::uksort
  • SplObserver ?
  • PHP Manual
  • ArrayObject
  • Unserialize an ArrayObject

ArrayObject::unserialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayObject::unserialize — Unserialize an ArrayObject

说明

public ArrayObject::unserialize ( string $serialized ) : void

Unserializes a serialized ArrayObject.

Warning

本函数还未编写文档，仅有参数列表。

参数

serialized

The serialized ArrayObject.

返回值

The unserialized ArrayObject.

参见

  • ArrayIterator::serialize() - Serialize
  • unserialize() - 从已存储的表示中创建 PHP 的值
  • Serializing Objects


The SplObserver interface

(PHP 5 >= 5.1.0, PHP 7)

简介

The SplObserver interface is used alongside SplSubject to implement the Observer Design Pattern.

接口摘要

SplObserver {
/* 方法 */
abstract public update ( SplSubject $subject ) : void
}

Table of Contents

  • SplObserver::update — Receive update from subject


Receive update from subject

  • ? SplObserver
  • SplSubject ?
  • PHP Manual
  • SplObserver
  • Receive update from subject

SplObserver::update

(PHP 5 >= 5.1.0, PHP 7)

SplObserver::update — Receive update from subject

说明

abstract public SplObserver::update ( SplSubject $subject ) : void

This method is called when any SplSubject to which the observer is attached calls SplSubject::notify().

Warning

本函数还未编写文档，仅有参数列表。

参数

subject

The SplSubject notifying the observer of an update.

返回值

没有返回值。


The SplSubject interface

(PHP 5 >= 5.1.0, PHP 7)

简介

The SplSubject interface is used alongside SplObserver to implement the Observer Design Pattern.

接口摘要

SplSubject {
/* 方法 */
abstract public attach ( SplObserver $observer ) : void
abstract public detach ( SplObserver $observer ) : void
abstract public notify ( ) : void
}

Table of Contents

  • SplSubject::attach — Attach an SplObserver
  • SplSubject::detach — Detach an observer
  • SplSubject::notify — Notify an observer


Attach an SplObserver

  • ? SplSubject
  • SplSubject::detach ?
  • PHP Manual
  • SplSubject
  • Attach an SplObserver

SplSubject::attach

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::attach — Attach an SplObserver

说明

abstract public SplSubject::attach ( SplObserver $observer ) : void

Attaches an SplObserver so that it can be notified of updates.

Warning

本函数还未编写文档，仅有参数列表。

参数

observer

The SplObserver to attach.

返回值

没有返回值。


Detach an observer

  • ? SplSubject::attach
  • SplSubject::notify ?
  • PHP Manual
  • SplSubject
  • Detach an observer

SplSubject::detach

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::detach — Detach an observer

说明

abstract public SplSubject::detach ( SplObserver $observer ) : void

Detaches an observer from the subject to no longer notify it of updates.

Warning

本函数还未编写文档，仅有参数列表。

参数

observer

The SplObserver to detach.

返回值

没有返回值。


Notify an observer

  • ? SplSubject::detach
  • Streams ?
  • PHP Manual
  • SplSubject
  • Notify an observer

SplSubject::notify

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::notify — Notify an observer

说明

abstract public SplSubject::notify ( ) : void

Notifies all attached observers.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。


Streams

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • Stream Classes
  • 预定义常量
  • Stream Filters
  • Stream Contexts
  • Stream Errors
  • 范例
    • Example class registered as stream wrapper
  • php_user_filter — The php_user_filter class
    • php_user_filter::filter — Called when applying the filter
    • php_user_filter::onClose — Called when closing the filter
    • php_user_filter::onCreate — Called when creating the filter
  • streamWrapper — The streamWrapper class
    • streamWrapper::__construct — Constructs a new stream wrapper
    • streamWrapper::__destruct — Destructs an existing stream wrapper
    • streamWrapper::dir_closedir — Close directory handle
    • streamWrapper::dir_opendir — Open directory handle
    • streamWrapper::dir_readdir — Read entry from directory handle
    • streamWrapper::dir_rewinddir — Rewind directory handle
    • streamWrapper::mkdir — Create a directory
    • streamWrapper::rename — Renames a file or directory
    • streamWrapper::rmdir — Removes a directory
    • streamWrapper::stream_cast — Retrieve the underlaying resource
    • streamWrapper::stream_close — Close a resource
    • streamWrapper::stream_eof — Tests for end-of-file on a file pointer
    • streamWrapper::stream_flush — Flushes the output
    • streamWrapper::stream_lock — Advisory file locking
    • streamWrapper::stream_metadata — Change stream metadata
    • streamWrapper::stream_open — Opens file or URL
    • streamWrapper::stream_read — Read from stream
    • streamWrapper::stream_seek — Seeks to specific location in a stream
    • streamWrapper::stream_set_option — Change stream options
    • streamWrapper::stream_stat — Retrieve information about a file resource
    • streamWrapper::stream_tell — Retrieve the current position of a stream
    • streamWrapper::stream_truncate — Truncate stream
    • streamWrapper::stream_write — Write to stream
    • streamWrapper::unlink — Delete a file
    • streamWrapper::url_stat — Retrieve information about a file
  • Stream 函数
    • stream_bucket_append — Append bucket to brigade
    • stream_bucket_make_writeable — Return a bucket object from the brigade for operating on
    • stream_bucket_new — Create a new bucket for use on the current stream
    • stream_bucket_prepend — Prepend bucket to brigade
    • stream_context_create — 创建资源流上下文
    • stream_context_get_default — Retrieve the default stream context
    • stream_context_get_options — 获取资源流/数据包/上下文的参数
    • stream_context_get_params — Retrieves parameters from a context
    • stream_context_set_default — Set the default stream context
    • stream_context_set_option — 对资源流、数据包或者上下文设置参数
    • stream_context_set_params — Set parameters for a stream/wrapper/context
    • stream_copy_to_stream — Copies data from one stream to another
    • stream_filter_append — Attach a filter to a stream
    • stream_filter_prepend — Attach a filter to a stream
    • stream_filter_register — Register a user defined stream filter
    • stream_filter_remove — 从资源流里移除某个过滤器
    • stream_get_contents — 读取资源流到一个字符串
    • stream_get_filters — 获取已注册的数据流过滤器列表
    • stream_get_line — 从资源流里读取一行直到给定的定界符
    • stream_get_meta_data — 从封装协议文件指针中取得报头／元数据
    • stream_get_transports — 获取已注册的套接字传输协议列表
    • stream_get_wrappers — 获取已注册的流类型
    • stream_is_local — Checks if a stream is a local stream
    • stream_isatty — Check if a stream is a TTY
    • stream_notification_callback — A callback function for the notification context parameter
    • stream_register_wrapper — 别名 stream_wrapper_register
    • stream_resolve_include_path — Resolve filename against the include path
    • stream_select — Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
    • stream_set_blocking — 为资源流设置阻塞或者阻塞模式
    • stream_set_chunk_size — 设置资源流区块大小
    • stream_set_read_buffer — Set read file buffering on the given stream
    • stream_set_timeout — Set timeout period on a stream
    • stream_set_write_buffer — Sets write file buffering on the given stream
    • stream_socket_accept — 接受由 stream_socket_server 创建的套接字连接
    • stream_socket_client — Open Internet or Unix domain socket connection
    • stream_socket_enable_crypto — Turns encryption on/off on an already connected socket
    • stream_socket_get_name — 获取本地或者远程的套接字名称
    • stream_socket_pair — 创建一对完全一样的网络套接字连接流
    • stream_socket_recvfrom — Receives data from a socket, connected or not
    • stream_socket_sendto — Sends a message to a socket, whether it is connected or not
    • stream_socket_server — Create an Internet or Unix domain server socket
    • stream_socket_shutdown — Shutdown a full-duplex connection
    • stream_supports_lock — Tells whether the stream supports locking
    • stream_wrapper_register — 注册一个用 PHP 类实现的 URL 封装协议
    • stream_wrapper_restore — Restores a previously unregistered built-in wrapper
    • stream_wrapper_unregister — Unregister a URL wrapper


简介

Streams are the way of generalizing file, network, data compression, and other operations which share a common set of functions and uses. In its simplest definition, a stream is a resource object which exhibits streamable behavior. That is, it can be read from or written to in a linear fashion, and may be able to fseek() to an arbitrary location within the stream.

A wrapper is additional code which tells the stream how to handle specific protocols/encodings. For example, the http wrapper knows how to translate a URL into an HTTP/1.0 request for a file on a remote server. There are many wrappers built into PHP by default (See 支持的协议和封装协议), and additional, custom wrappers may be added either within a PHP script using stream_wrapper_register(), or directly from an extension. Because any variety of wrapper may be added to PHP, there is no set limit on what can be done with them. To access the list of currently registered wrappers, use stream_get_wrappers().

A stream is referenced as: scheme://target

  • scheme(string) - The name of the wrapper to be used. Examples include: file, http, https, ftp, ftps, compress.zlib, compress.bz2, and php. See 支持的协议和封装协议 for a list of PHP built-in wrappers. If no wrapper is specified, the function default is used (typically file://).
  • target - Depends on the wrapper used. For filesystem related streams this is typically a path and filename of the desired file. For network related streams this is typically a hostname, often with a path appended. Again, see 支持的协议和封装协议 for a description of targets for built-in streams.


安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • Stream Classes


  • ? 安装
  • Stream Classes ?
  • PHP Manual
  • 安装／配置
  • 运行时配置

运行时配置

此扩展没有在 php.ini 中定义配置指令。


Stream Classes

User designed wrappers can be registered via stream_wrapper_register(), using the class definition shown on that manual page.

Class php_user_filter is predefined and is an abstract baseclass for use with user defined filters. See the manual page for stream_filter_register() for details on implementing user defined filters.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Constant | Description
STREAM_FILTER_READ | Used with stream_filter_append() and stream_filter_prepend() to indicate that the specified filter should only be applied when reading
STREAM_FILTER_WRITE | Used with stream_filter_append() and stream_filter_prepend() to indicate that the specified filter should only be applied when writing
STREAM_FILTER_ALL | This constant is equivalent to STREAM_FILTER_READ | STREAM_FILTER_WRITE
PSFS_PASS_ON | Return Code indicating that the userspace filter returned buckets in $out.
PSFS_FEED_ME | Return Code indicating that the userspace filter did not return buckets in $out (i.e. No data available).
PSFS_ERR_FATAL | Return Code indicating that the userspace filter encountered an unrecoverable error (i.e. Invalid data received).
PSFS_FLAG_NORMAL | Regular read/write.
PSFS_FLAG_FLUSH_INC | An incremental flush.
PSFS_FLAG_FLUSH_CLOSE | Final flush prior to closing.
STREAM_USE_PATH | Flag indicating if the stream used the include path.
STREAM_REPORT_ERRORS | Flag indicating if the wrapper is responsible for raising errors using trigger_error() during opening of the stream. If this flag is not set, you should not raise any errors.
STREAM_CLIENT_ASYNC_CONNECT | Open client socket asynchronously. This option must be used together with the STREAM_CLIENT_CONNECT flag. Used with stream_socket_client().
STREAM_CLIENT_CONNECT | Open client socket connection. Client sockets should always include this flag. Used with stream_socket_client().
STREAM_CLIENT_PERSISTENT | Client socket opened with stream_socket_client() should remain persistent between page loads.
STREAM_SERVER_BIND | Tells a stream created with stream_socket_server() to bind to the specified target. Server sockets should always include this flag.
STREAM_SERVER_LISTEN | Tells a stream created with stream_socket_server() and bound using the STREAM_SERVER_BIND flag to start listening on the socket. Connection-orientated transports (such as TCP) must use this flag, otherwise the server socket will not be enabled. Using this flag for connect-less transports (such as UDP) is an error.
STREAM_NOTIFY_RESOLVE | A remote address required for this stream has been resolved, or the resolution failed. See severity for an indication of which happened.
STREAM_NOTIFY_CONNECT | A connection with an external resource has been established.
STREAM_NOTIFY_AUTH_REQUIRED | Additional authorization is required to access the specified resource. Typical issued with severity level of STREAM_NOTIFY_SEVERITY_ERR.
STREAM_NOTIFY_MIME_TYPE_IS | The mime-type of resource has been identified, refer to message for a description of the discovered type.
STREAM_NOTIFY_FILE_SIZE_IS | The size of the resource has been discovered.
STREAM_NOTIFY_REDIRECTED | The external resource has redirected the stream to an alternate location. Refer to message.
STREAM_NOTIFY_PROGRESS | Indicates current progress of the stream transfer in bytes_transferred and possibly bytes_max as well.
STREAM_NOTIFY_COMPLETED | There is no more data available on the stream.
STREAM_NOTIFY_FAILURE | A generic error occurred on the stream, consult message and message_code for details.
STREAM_NOTIFY_AUTH_RESULT | Authorization has been completed (with or without success).
STREAM_NOTIFY_SEVERITY_INFO | Normal, non-error related, notification.
STREAM_NOTIFY_SEVERITY_WARN | Non critical error condition. Processing may continue.
STREAM_NOTIFY_SEVERITY_ERR | A critical error occurred. Processing cannot continue.
STREAM_IPPROTO_ICMP + | Provides a ICMP socket.
STREAM_IPPROTO_IP + | Provides a IP socket.
STREAM_IPPROTO_RAW + | Provides a RAW socket.
STREAM_IPPROTO_TCP + | Provides a TCP socket.
STREAM_IPPROTO_UDP + | Provides a UDP socket.
STREAM_PF_INET + | Internet Protocol Version 4 (IPv4).
STREAM_PF_INET6 + | Internet Protocol Version 6 (IPv6).
STREAM_PF_UNIX + | Unix system internal protocols.
STREAM_SOCK_DGRAM + | Provides datagrams, which are connectionless messages (UDP, for example).
STREAM_SOCK_RAW + | Provides a raw socket, which provides access to internal network protocols and interfaces. Usually this type of socket is just available to the root user.
STREAM_SOCK_RDM + | Provides a RDM (Reliably-delivered messages) socket.
STREAM_SOCK_SEQPACKET + | Provides a sequenced packet stream socket.
STREAM_SOCK_STREAM + | Provides sequenced, two-way byte streams with a transmission mechanism for out-of-band data (TCP, for example).
STREAM_SHUT_RD | Used with stream_socket_shutdown() to disable further receptions. Added in PHP 5.2.1.
STREAM_SHUT_WR | Used with stream_socket_shutdown() to disable further transmissions. Added in PHP 5.2.1.
STREAM_SHUT_RDWR | Used with stream_socket_shutdown() to disable further receptions and transmissions. Added in PHP 5.2.1.
STREAM_CAST_FOR_SELECT | Stream casting, for when stream_select() is calling stream_cast().
STREAM_CAST_AS_STREAM | Stream casting, when stream_cast() is called otherwise (see above).
STREAM_META_TOUCH | Used with stream_metadata(), to specify touch() call.
STREAM_META_OWNER | Used with stream_metadata(), to specify chown() call.
STREAM_META_OWNER_NAME | Used with stream_metadata(), to specify chown() call.
STREAM_META_GROUP | Used with stream_metadata(), to specify chgrp() call.
STREAM_META_GROUP_NAME | Used with stream_metadata(), to specify chgrp() call.
STREAM_META_ACCESS | Used with stream_metadata(), to specify chmod() call.
STREAM_BUFFER_NONE | No buffering.
STREAM_BUFFER_LINE | Line buffering.
STREAM_BUFFER_FULL | Full buffering.

Note: The constants marked with + are available since PHP 5.1.0 and are meant to be used with stream_socket_pair(). Please note that some of these constants might not be available in your system.

Note: The STREAM_META_* constants are available since PHP 5.4.0 and are meant to be used with stream_metadata().


Stream Filters

A filter is a final piece of code which may perform operations on data as it is being read from or written to a stream. Any number of filters may be stacked onto a stream. Custom filters can be defined in a PHP script using stream_filter_register() or in an extension. To access the list of currently registered filters, use stream_get_filters().


Stream Contexts

A context is a set of parameters and wrapper specific options which modify or enhance the behavior of a stream. Contexts are created using stream_context_create() and can be passed to most filesystem related stream creation functions (i.e. fopen(), file(), file_get_contents(), etc...).

Options can be specified when calling stream_context_create(), or later using stream_context_set_option(). A list of wrapper specific options can be found in the 上下文（Context）选项和参数 chapter.

Parameters can be specified for contexts using the stream_context_set_params() function.


Stream Errors

As with any file or socket related function, an operation on a stream may fail for a variety of normal reasons (i.e.: Unable to connect to remote host, file not found, etc...). A stream related call may also fail because the desired stream is not registered on the running system. See the array returned by stream_get_wrappers() for a list of streams supported by your installation of PHP. As with most PHP internal functions if a failure occurs an E_WARNING message will be generated describing the nature of the error.


范例

Table of Contents

  • Example class registered as stream wrapper

Example #1 Using file_get_contents() to retrieve data from multiple sources

<?php
/* Read local file from /home/bar */
$localfile = file_get_contents("/home/bar/foo.txt");

/* Identical to above, explicitly naming FILE scheme */
$localfile = file_get_contents("file:///home/bar/foo.txt");

/* Read remote file from www.example.com using HTTP */
$httpfile  = file_get_contents("http://www.example.com/foo.txt");

/* Read remote file from www.example.com using HTTPS */
$httpsfile = file_get_contents("https://www.example.com/foo.txt");

/* Read remote file from ftp.example.com using FTP */
$ftpfile   = file_get_contents("ftp://user:pass@ftp.example.com/foo.txt");

/* Read remote file from ftp.example.com using FTPS */
$ftpsfile  = file_get_contents("ftps://user:pass@ftp.example.com/foo.txt");
?>

Example #2 Making a POST request to an https server

<?php
/* Send POST request to https://secure.example.com/form_action.php
* Include form elements named "foo" and "bar" with dummy values
*/

$sock = fsockopen("ssl://secure.example.com", 443, $errno, $errstr, 30);
if (!$sock) die("$errstr ($errno)\n");

$data = "foo=" . urlencode("Value for Foo") . "&bar=" . urlencode("Value for Bar");

fwrite($sock, "POST /form_action.php HTTP/1.0\r\n");
fwrite($sock, "Host: secure.example.com\r\n");
fwrite($sock, "Content-type: application/x-www-form-urlencoded\r\n");
fwrite($sock, "Content-length: " . strlen($data) . "\r\n");
fwrite($sock, "Accept: */*\r\n");
fwrite($sock, "\r\n");
fwrite($sock, $data);

$headers = "";
while ($str = trim(fgets($sock, 4096)))
$headers .= "$str\n";

echo "\n";

$body = "";
while (!feof($sock))
$body .= fgets($sock, 4096);

fclose($sock);
?>

Example #3 Writing data to a compressed file

<?php
/* Create a compressed file containing an arbitrarty string
* File can be read back using compress.zlib stream or just
* decompressed from the command line using 'gzip -d foo-bar.txt.gz'
*/
$fp = fopen("compress.zlib://foo-bar.txt.gz", "wb");
if (!$fp) die("Unable to create file.");

fwrite($fp, "This is a test.\n");

fclose($fp);
?>


Example class registered as stream wrapper

The example below implements a var:// protocol handler that allows read/write access to a named global variable using standard filesystem stream functions such as fread(). The var:// protocol implemented below, given the URL "var://foo" will read/write data to/from $GLOBALS["foo"].

Example #1 A Stream for reading/writing global variables

<?php

class VariableStream {
    var $position;
    var $varname;

    function stream_open($path, $mode, $options, &$opened_path)
    {
        $url = parse_url($path);
        $this->varname = $url["host"];
        $this->position = 0;

        return true;
    }

    function stream_read($count)
    {
        $ret = substr($GLOBALS[$this->varname], $this->position, $count);
        $this->position += strlen($ret);
        return $ret;
    }

    function stream_write($data)
    {
        $left = substr($GLOBALS[$this->varname], 0, $this->position);
        $right = substr($GLOBALS[$this->varname], $this->position + strlen($data));
        $GLOBALS[$this->varname] = $left . $data . $right;
        $this->position += strlen($data);
        return strlen($data);
    }

    function stream_tell()
    {
        return $this->position;
    }

    function stream_eof()
    {
        return $this->position >= strlen($GLOBALS[$this->varname]);
    }

    function stream_seek($offset, $whence)
    {
        switch ($whence) {
            case SEEK_SET:
                if ($offset < strlen($GLOBALS[$this->varname]) && $offset >= 0) {
                     $this->position = $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            case SEEK_CUR:
                if ($offset >= 0) {
                     $this->position += $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            case SEEK_END:
                if (strlen($GLOBALS[$this->varname]) + $offset >= 0) {
                     $this->position = strlen($GLOBALS[$this->varname]) + $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            default:
                return false;
        }
    }

    function stream_metadata($path, $option, $var)
    {
        if($option == STREAM_META_TOUCH) {
            $url = parse_url($path);
            $varname = $url["host"];
            if(!isset($GLOBALS[$varname])) {
                $GLOBALS[$varname] = '';
            }
            return true;
        }
        return false;
    }
}

stream_wrapper_register("var", "VariableStream")
    or die("Failed to register protocol");

$myvar = "";

$fp = fopen("var://myvar", "r+");

fwrite($fp, "line1\n");
fwrite($fp, "line2\n");
fwrite($fp, "line3\n");

rewind($fp);
while (!feof($fp)) {
    echo fgets($fp);
}
fclose($fp);
var_dump($myvar);

?>

以上例程会输出：

line1
line2
line3
string(18) "line1
line2
line3
"


The php_user_filter class

(PHP 5, PHP 7, PHP 8)

简介

Children of this class are passed to
stream_filter_register().
Note that the __construct method is not called;
instead, php_user_filter::onCreate() should be used for
initialization.

类摘要

php_user_filter {
/* 属性 */
public $filtername ;
public $params ;
/* 方法 */
public filter ( resource $in , resource $out , int &$consumed , bool $closing ) : int
public onClose ( ) : void
public onCreate ( ) : bool
}

属性

filtername

Name of the filter registered by stream_filter_append().

params

Table of Contents

  • php_user_filter::filter — Called when applying the filter
  • php_user_filter::onClose — Called when closing the filter
  • php_user_filter::onCreate — Called when creating the filter


Called when applying the filter

  • ? php_user_filter
  • php_user_filter::onClose ?
  • PHP Manual
  • php_user_filter
  • Called when applying the filter

php_user_filter::filter

(PHP 5, PHP 7, PHP 8)

php_user_filter::filter — Called when applying the filter

说明

public php_user_filter::filter ( resource $in , resource $out , int &$consumed , bool $closing ) : int

This method is called whenever data is read from or written to the attached stream (such as with fread() or fwrite()).

参数

in

in is a resource pointing to a bucket brigade which contains one or more bucket objects containing data to be filtered.

out

out is a resource pointing to a second bucket brigade into which your modified buckets should be placed.

consumed

consumed, which must always be declared by reference, should be incremented by the length of the data which your filter reads in and alters. In most cases this means you will increment consumed by $bucket->datalen for each $bucket.

closing

If the stream is in the process of closing (and therefore this is the last pass through the filterchain), the closing parameter will be set to true.

返回值

The filter() method must return one of three values upon completion.

Return Value | Meaning
PSFS_PASS_ON | Filter processed successfully with data available in the out bucket brigade.
PSFS_FEED_ME | Filter processed successfully, however no data was available to return. More data is required from the stream or prior filter.
PSFS_ERR_FATAL (default) | The filter experienced an unrecoverable error and cannot continue.


Called when closing the filter

  • ? php_user_filter::filter
  • php_user_filter::onCreate ?
  • PHP Manual
  • php_user_filter
  • Called when closing the filter

php_user_filter::onClose

(PHP 5, PHP 7, PHP 8)

php_user_filter::onClose — Called when closing the filter

说明

public php_user_filter::onClose ( ) : void

This method is called upon filter shutdown (typically, this is also during stream shutdown), and is executed after the flush method is called. If any resources were allocated or initialized during onCreate() this would be the time to destroy or dispose of them.

参数

此函数没有参数。

返回值

Return value is ignored.


Called when creating the filter

  • ? php_user_filter::onClose
  • streamWrapper ?
  • PHP Manual
  • php_user_filter
  • Called when creating the filter

php_user_filter::onCreate

(PHP 5, PHP 7, PHP 8)

php_user_filter::onCreate — Called when creating the filter

说明

public php_user_filter::onCreate ( ) : bool

This method is called during instantiation of the filter class object. If your filter allocates or initializes any other resources (such as a buffer), this is the place to do it.

When your filter is first instantiated, and yourfilter->onCreate() is called, a number of properties will be available as shown in the table below.

Property | Contents
FilterClass->filtername | A string containing the name the filter was instantiated with. Filters may be registered under multiple names or under wildcards. Use this property to determine which name was used.
FilterClass->params | The contents of the params parameter passed to stream_filter_append() or stream_filter_prepend().
FilterClass->stream | The stream resource being filtered. Maybe available only during filter() calls when the closing parameter is set to false.

参数

此函数没有参数。

返回值

Your implementation of this method should return false on failure, or true on success.


The streamWrapper class

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

简介

Allows you to implement your own protocol handlers and streams for use with all the other filesystem functions (such as fopen(), fread() etc.).

Note:

This is NOT a real class, only a prototype of how a class defining its own protocol should be.

Note:

Implementing the methods in other ways than described here can lead to undefined behaviour.

An instance of this class is initialized as soon as a stream function tries to access the protocol it is associated with.

类摘要

streamWrapper {
/* 属性 */
public resource $context ;
/* 方法 */
__construct ( )
__destruct ( )
public dir_closedir ( ) : bool
public dir_opendir ( string $path , int $options ) : bool
public dir_readdir ( ) : string
public dir_rewinddir ( ) : bool
public mkdir ( string $path , int $mode , int $options ) : bool
public rename ( string $path_from , string $path_to ) : bool
public rmdir ( string $path , int $options ) : bool
public stream_cast ( int $cast_as ) : resource
public stream_close ( ) : void
public stream_eof ( ) : bool
public stream_flush ( ) : bool
public stream_lock ( int $operation ) : bool
public stream_metadata ( string $path , int $option , mixed $value ) : bool
public stream_open ( string $path , string $mode , int $options , string &$opened_path ) : bool
public stream_read ( int $count ) : string
public stream_seek ( int $offset , int $whence = SEEK_SET ) : bool
public stream_set_option ( int $option , int $arg1 , int $arg2 ) : bool
public stream_stat ( ) : array
public stream_tell ( ) : int
public stream_truncate ( int $new_size ) : bool
public stream_write ( string $data ) : int
public unlink ( string $path ) : bool
public url_stat ( string $path , int $flags ) : array
}

属性

resource context

The current context, or null if no context was passed to the caller function.

Use the stream_context_get_options() to parse the context.

Note:

This property must be public so PHP can populate it with the actual context resource.

参见

  • Example class registered as stream wrapper
  • stream_wrapper_register()
  • stream_wrapper_unregister()
  • stream_wrapper_restore()

Table of Contents

  • streamWrapper::__construct — Constructs a new stream wrapper
  • streamWrapper::__destruct — Destructs an existing stream wrapper
  • streamWrapper::dir_closedir — Close directory handle
  • streamWrapper::dir_opendir — Open directory handle
  • streamWrapper::dir_readdir — Read entry from directory handle
  • streamWrapper::dir_rewinddir — Rewind directory handle
  • streamWrapper::mkdir — Create a directory
  • streamWrapper::rename — Renames a file or directory
  • streamWrapper::rmdir — Removes a directory
  • streamWrapper::stream_cast — Retrieve the underlaying resource
  • streamWrapper::stream_close — Close a resource
  • streamWrapper::stream_eof — Tests for end-of-file on a file pointer
  • streamWrapper::stream_flush — Flushes the output
  • streamWrapper::stream_lock — Advisory file locking
  • streamWrapper::stream_metadata — Change stream metadata
  • streamWrapper::stream_open — Opens file or URL
  • streamWrapper::stream_read — Read from stream
  • streamWrapper::stream_seek — Seeks to specific location in a stream
  • streamWrapper::stream_set_option — Change stream options
  • streamWrapper::stream_stat — Retrieve information about a file resource
  • streamWrapper::stream_tell — Retrieve the current position of a stream
  • streamWrapper::stream_truncate — Truncate stream
  • streamWrapper::stream_write — Write to stream
  • streamWrapper::unlink — Delete a file
  • streamWrapper::url_stat — Retrieve information about a file


Constructs a new stream wrapper

  • ? streamWrapper
  • streamWrapper::__destruct ?
  • PHP Manual
  • streamWrapper
  • Constructs a new stream wrapper

streamWrapper::__construct

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::__construct — Constructs a new stream wrapper

说明

streamWrapper::__construct ( )

Called when opening the stream wrapper, right before streamWrapper::stream_open().

参数

此函数没有参数。


Destructs an existing stream wrapper

  • ? streamWrapper::__construct
  • streamWrapper::dir_closedir ?
  • PHP Manual
  • streamWrapper
  • Destructs an existing stream wrapper

streamWrapper::__destruct

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::__destruct — Destructs an existing stream wrapper

说明

streamWrapper::__destruct ( )

Called when closing the stream wrapper, right before streamWrapper::stream_flush().

参数

此函数没有参数。


Close directory handle

  • ? streamWrapper::__destruct
  • streamWrapper::dir_opendir ?
  • PHP Manual
  • streamWrapper
  • Close directory handle

streamWrapper::dir_closedir

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::dir_closedir — Close directory handle

说明

public streamWrapper::dir_closedir ( ) : bool

This method is called in response to closedir().

Any resources which were locked, or allocated, during opening and use of the directory stream should be released.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • closedir() - 关闭目录句柄
  • streamWrapper::dir_opendir() - Open directory handle


Open directory handle

  • ? streamWrapper::dir_closedir
  • streamWrapper::dir_readdir ?
  • PHP Manual
  • streamWrapper
  • Open directory handle

streamWrapper::dir_opendir

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::dir_opendir — Open directory handle

说明

public streamWrapper::dir_opendir ( string $path , int $options ) : bool

This method is called in response to opendir().

参数

path

Specifies the URL that was passed to opendir().

Note:

The URL can be broken apart with parse_url().

options

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • opendir() - 打开目录句柄
  • streamWrapper::dir_closedir() - Close directory handle
  • parse_url() - 解析 URL，返回其组成部分


Read entry from directory handle

  • ? streamWrapper::dir_opendir
  • streamWrapper::dir_rewinddir ?
  • PHP Manual
  • streamWrapper
  • Read entry from directory handle

streamWrapper::dir_readdir

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::dir_readdir — Read entry from directory handle

说明

public streamWrapper::dir_readdir ( ) : string

This method is called in response to readdir().

参数

此函数没有参数。

返回值

Should return string representing the next filename, or false if there is no next file.

Note:

The return value will be casted to string.

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

范例

Example #1 Listing files from tar archives

<?php
class streamWrapper {
    protected $fp;

    public function dir_opendir($path, $options) {
        $url = parse_url($path);

        $path = $url["host"] . $url["path"];

        if (!is_readable($path)) {
            trigger_error("$path isn't readable for me", E_USER_NOTICE);
            return false;
        }
        if (!is_file($path)) {
            trigger_error("$path isn't a file", E_USER_NOTICE);
            return false;
        }

        $this->fp = fopen($path, "rb");
        return true;
    }

    public function dir_readdir() {
        // Extract the header for this entry
        $header      = fread($this->fp, 512);
        $data = unpack("a100filename/a8mode/a8uid/a8gid/a12size/a12mtime/a8checksum/a1filetype/a100link/a100linkedfile", $header);

        // Trim the filename and filesize
        $filename    = trim($data["filename"]);

        // No filename? We are the end of the archive
        if (!$filename) {
            return false;
        }

        $octal_bytes = trim($data["size"]);
        // Filesize is defined in octects
        $bytes       = octdec($octal_bytes);

        // tar rounds up filesizes up to multiple of 512 bytes (zero filled)
        $rest        = $bytes % 512;
        if ($rest > 0) {
            $bytes      += 512 - $rest;
        }

        // Seek over the file
        fseek($this->fp, $bytes, SEEK_CUR);

        return $filename;
    }

    public function dir_closedir() {
        return fclose($this->fp);
    }

    public function dir_rewinddir() {
        return fseek($this->fp, 0, SEEK_SET);
    }
}

stream_wrapper_register("tar", "streamWrapper");
$handle = opendir("tar://example.tar");
while (false !== ($file = readdir($handle))) {
    var_dump($file);
}

echo "Rewinding..\n";
rewind($handle);
var_dump(readdir($handle));

closedir($handle);
?>

以上例程的输出类似于：

string(13) "construct.xml"
string(16) "dir-closedir.xml"
string(15) "dir-opendir.xml"
string(15) "dir-readdir.xml"
string(17) "dir-rewinddir.xml"
string(9) "mkdir.xml"
string(10) "rename.xml"
string(9) "rmdir.xml"
string(15) "stream-cast.xml"
string(16) "stream-close.xml"
string(14) "stream-eof.xml"
string(16) "stream-flush.xml"
string(15) "stream-lock.xml"
string(15) "stream-open.xml"
string(15) "stream-read.xml"
string(15) "stream-seek.xml"
string(21) "stream-set-option.xml"
string(15) "stream-stat.xml"
string(15) "stream-tell.xml"
string(16) "stream-write.xml"
string(10) "unlink.xml"
string(12) "url-stat.xml"
Rewinding..
string(13) "construct.xml"

参见

  • readdir() - 从目录句柄中读取条目


Rewind directory handle

  • ? streamWrapper::dir_readdir
  • streamWrapper::mkdir ?
  • PHP Manual
  • streamWrapper
  • Rewind directory handle

streamWrapper::dir_rewinddir

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::dir_rewinddir — Rewind directory handle

说明

public streamWrapper::dir_rewinddir ( ) : bool

This method is called in response to rewinddir().

Should reset the output generated by streamWrapper::dir_readdir(). i.e.: The next call to streamWrapper::dir_readdir() should return the first entry in the location returned by streamWrapper::dir_opendir().

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • rewinddir() - 倒回目录句柄
  • streamWrapper::dir_readdir() - Read entry from directory handle


Create a directory

  • ? streamWrapper::dir_rewinddir
  • streamWrapper::rename ?
  • PHP Manual
  • streamWrapper
  • Create a directory

streamWrapper::mkdir

(PHP 5, PHP 7, PHP 8)

streamWrapper::mkdir — Create a directory

说明

public streamWrapper::mkdir ( string $path , int $mode , int $options ) : bool

This method is called in response to mkdir().

Note:

In order for the appropriate error message to be returned this method should not be defined if the wrapper does not support creating directories.

参数

path

Directory which should be created.

mode

The value passed to mkdir().

options

A bitwise mask of values, such as STREAM_MKDIR_RECURSIVE.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

注释

Note:

当合法的上下文传递给调用函数时，属性 streamWrapper::$context 会被改变。

参见

  • mkdir() - 新建目录
  • streamwrapper::rmdir() - Removes a directory


Renames a file or directory

  • ? streamWrapper::mkdir
  • streamWrapper::rmdir ?
  • PHP Manual
  • streamWrapper
  • Renames a file or directory

streamWrapper::rename

(PHP 5, PHP 7, PHP 8)

streamWrapper::rename — Renames a file or directory

说明

public streamWrapper::rename ( string $path_from , string $path_to ) : bool

This method is called in response to rename().

Should attempt to rename path_from to path_to

Note:

In order for the appropriate error message to be returned this method should not be defined if the wrapper does not support renaming files.

参数

path_from

The URL to the current file.

path_to

The URL which the path_from should be renamed to.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

注释

Note:

当合法的上下文传递给调用函数时，属性 streamWrapper::$context 会被改变。

参见

  • rename() - 重命名一个文件或目录


Removes a directory

  • ? streamWrapper::rename
  • streamWrapper::stream_cast ?
  • PHP Manual
  • streamWrapper
  • Removes a directory

streamWrapper::rmdir

(PHP 5, PHP 7, PHP 8)

streamWrapper::rmdir — Removes a directory

说明

public streamWrapper::rmdir ( string $path , int $options ) : bool

This method is called in response to rmdir().

Note:

In order for the appropriate error message to be returned this method should not be defined if the wrapper does not support removing directories.

参数

path

The directory URL which should be removed.

options

A bitwise mask of values, such as STREAM_MKDIR_RECURSIVE.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

注释

Note:

当合法的上下文传递给调用函数时，属性 streamWrapper::$context 会被改变。

参见

  • rmdir() - 删除目录
  • streamwrapper::mkdir() - Create a directory
  • streamwrapper::unlink() - Delete a file


Retrieve the underlaying resource

  • ? streamWrapper::rmdir
  • streamWrapper::stream_close ?
  • PHP Manual
  • streamWrapper
  • Retrieve the underlaying resource

streamWrapper::stream_cast

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

streamWrapper::stream_cast — Retrieve the underlaying resource

说明

public streamWrapper::stream_cast ( int $cast_as ) : resource

This method is called in response to stream_select().

参数

cast_as

Can be STREAM_CAST_FOR_SELECT when stream_select() is calling stream_cast() or STREAM_CAST_AS_STREAM when stream_cast() is called for other uses.

返回值

Should return the underlying stream resource used by the wrapper, or false.

参见

  • stream_select() - Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec


Close a resource

  • ? streamWrapper::stream_cast
  • streamWrapper::stream_eof ?
  • PHP Manual
  • streamWrapper
  • Close a resource

streamWrapper::stream_close

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_close — Close a resource

说明

public streamWrapper::stream_close ( ) : void

This method is called in response to fclose().

All resources that were locked, or allocated, by the wrapper should be released.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • fclose() - 关闭一个已打开的文件指针
  • streamWrapper::dir_closedir() - Close directory handle


Tests for end-of-file on a file pointer

  • ? streamWrapper::stream_close
  • streamWrapper::stream_flush ?
  • PHP Manual
  • streamWrapper
  • Tests for end-of-file on a file pointer

streamWrapper::stream_eof

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_eof — Tests for end-of-file on a file pointer

说明

public streamWrapper::stream_eof ( ) : bool

This method is called in response to feof().

参数

此函数没有参数。

返回值

Should return true if the read/write position is at the end of the stream and if no more data is available to be read, or false otherwise.

注释

Warning

When reading the whole file (for example, with file_get_contents()), PHP will call streamWrapper::stream_read() followed by streamWrapper::stream_eof() in a loop but as long as streamWrapper::stream_read() returns a non-empty string, the return value of streamWrapper::stream_eof() is ignored.

参见

  • feof() - 测试文件指针是否到了文件结束的位置


Flushes the output

  • ? streamWrapper::stream_eof
  • streamWrapper::stream_lock ?
  • PHP Manual
  • streamWrapper
  • Flushes the output

streamWrapper::stream_flush

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_flush — Flushes the output

说明

public streamWrapper::stream_flush ( ) : bool

This method is called in response to fflush() and when the stream is being closed while any unflushed data has been written to it before.

If you have cached data in your stream but not yet stored it into the underlying storage, you should do so now.

参数

此函数没有参数。

返回值

Should return true if the cached data was successfully stored (or if there was no data to store), or false if the data could not be stored.

注释

Note:

If not implemented, false is assumed as the return value.

参见

  • fflush() - 将缓冲内容输出到文件


Advisory file locking

  • ? streamWrapper::stream_flush
  • streamWrapper::stream_metadata ?
  • PHP Manual
  • streamWrapper
  • Advisory file locking

streamWrapper::stream_lock

(PHP 5, PHP 7, PHP 8)

streamWrapper::stream_lock — Advisory file locking

说明

public streamWrapper::stream_lock ( int $operation ) : bool

This method is called in response to flock(), when file_put_contents() (when flags contains LOCK_EX), stream_set_blocking() and when closing the stream (LOCK_UN).

参数

operation

operation is one of the following:

  • LOCK_SH to acquire a shared lock (reader).
  • LOCK_EX to acquire an exclusive lock (writer).
  • LOCK_UN to release a lock (shared or exclusive).
  • LOCK_NB if you don't want flock() to block while locking. (not supported on Windows)

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Emits E_WARNING if call to this method fails (i.e. not implemented).

参见

  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式
  • flock() - 轻便的咨询文件锁定


Change stream metadata

  • ? streamWrapper::stream_lock
  • streamWrapper::stream_open ?
  • PHP Manual
  • streamWrapper
  • Change stream metadata

streamWrapper::stream_metadata

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

streamWrapper::stream_metadata — Change stream metadata

说明

public streamWrapper::stream_metadata ( string $path , int $option , mixed $value ) : bool

This method is called to set metadata on the stream. It is called when one of the following functions is called on a stream URL:

  • touch()
  • chmod()
  • chown()
  • chgrp()
Please note that some of these operations may not be available on your system.

参数

path

The file path or URL to set metadata. Note that in the case of a URL, it must be a :// delimited URL. Other URL forms are not supported.

option

One of:

  • STREAM_META_TOUCH (The method was called in response to touch())
  • STREAM_META_OWNER_NAME (The method was called in response to chown() with string parameter)
  • STREAM_META_OWNER (The method was called in response to chown())
  • STREAM_META_GROUP_NAME (The method was called in response to chgrp())
  • STREAM_META_GROUP (The method was called in response to chgrp())
  • STREAM_META_ACCESS (The method was called in response to chmod())

value

If option is

  • STREAM_META_TOUCH: Array consisting of two arguments of the touch() function.
  • STREAM_META_OWNER_NAME or STREAM_META_GROUP_NAME: The name of the owner user/group as string.
  • STREAM_META_OWNER or STREAM_META_GROUP: The value owner user/group argument as int.
  • STREAM_META_ACCESS: The argument of the chmod() as int.

返回值

成功时返回 true， 或者在失败时返回 false。 If option is not implemented, false should be returned.

参见

  • touch() - 设定文件的访问和修改时间
  • chmod() - 改变文件模式
  • chown() - 改变文件的所有者
  • chgrp() - 改变文件所属的组


Opens file or URL

  • ? streamWrapper::stream_metadata
  • streamWrapper::stream_read ?
  • PHP Manual
  • streamWrapper
  • Opens file or URL

streamWrapper::stream_open

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_open — Opens file or URL

说明

public streamWrapper::stream_open ( string $path , string $mode , int $options , string &$opened_path ) : bool

This method is called immediately after the wrapper is initialized (f.e. by fopen() and file_get_contents()).

参数

path

Specifies the URL that was passed to the original function.

Note:

The URL can be broken apart with parse_url(). Note that only URLs delimited by :// are supported. : and :/ while technically valid URLs, are not.

mode

The mode used to open the file, as detailed for fopen().

Note:

Remember to check if the mode is valid for the path requested.

options

Holds additional flags set by the streams API. It can hold one or more of the following values OR'd together.

Flag | Description
STREAM_USE_PATH | If path is relative, search for the resource using the include_path.
STREAM_REPORT_ERRORS | If this flag is set, you are responsible for raising errors using trigger_error() during opening of the stream. If this flag is not set, you should not raise any errors.

opened_path

If the path is opened successfully, and STREAM_USE_PATH is set in options, opened_path should be set to the full path of the file/resource that was actually opened.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

注释

Note:

当合法的上下文传递给调用函数时，属性 streamWrapper::$context 会被改变。

参见

  • fopen() - 打开文件或者 URL
  • parse_url() - 解析 URL，返回其组成部分


Read from stream

  • ? streamWrapper::stream_open
  • streamWrapper::stream_seek ?
  • PHP Manual
  • streamWrapper
  • Read from stream

streamWrapper::stream_read

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_read — Read from stream

说明

public streamWrapper::stream_read ( int $count ) : string

This method is called in response to fread() and fgets().

Note:

Remember to update the read/write position of the stream (by the number of bytes that were successfully read).

参数

count

How many bytes of data from the current position should be returned.

返回值

If there are less than count bytes available, return as many as are available. If no more data is available, return either false or an empty string.

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

Note:

If the return value is longer then count an E_WARNING error will be emitted, and excess data will be lost.

注释

Note:

streamWrapper::stream_eof() is called directly after calling streamWrapper::stream_read() to check if EOF has been reached. If not implemented, EOF is assumed.

Warning

When reading the whole file (for example, with file_get_contents()), PHP will call streamWrapper::stream_read() followed by streamWrapper::stream_eof() in a loop but as long as streamWrapper::stream_read() returns a non-empty string, the return value of streamWrapper::stream_eof() is ignored.

参见

  • fread() - 读取文件（可安全用于二进制文件）
  • fgets() - 从文件指针中读取一行


Seeks to specific location in a stream

  • ? streamWrapper::stream_read
  • streamWrapper::stream_set_option ?
  • PHP Manual
  • streamWrapper
  • Seeks to specific location in a stream

streamWrapper::stream_seek

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_seek — Seeks to specific location in a stream

说明

public streamWrapper::stream_seek ( int $offset , int $whence = SEEK_SET ) : bool

This method is called in response to fseek().

The read/write position of the stream should be updated according to the offset and whence.

参数

offset

The stream offset to seek to.

whence

Possible values:

  • SEEK_SET - Set position equal to offset bytes.
  • SEEK_CUR - Set position to current location plus offset.
  • SEEK_END - Set position to end-of-file plus offset.

Note: The current implementation never sets whence to SEEK_CUR; instead such seeks are internally converted to SEEK_SET seeks.

返回值

Return true if the position was updated, false otherwise.

注释

Note:

If not implemented, false is assumed as the return value.

Note:

Upon success,
streamWrapper::stream_tell() is called directly after
calling streamWrapper::stream_seek(). If
streamWrapper::stream_tell() fails, the return
value to the caller function will be set to false

Note:

Not all seeks operations on the stream will result in this function being called. PHP streams have read buffering enabled by default (see also stream_set_read_buffer()) and seeking may be done by merely moving the buffer pointer.

参见

  • fseek() - 在文件指针中定位


Change stream options

  • ? streamWrapper::stream_seek
  • streamWrapper::stream_stat ?
  • PHP Manual
  • streamWrapper
  • Change stream options

streamWrapper::stream_set_option

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

streamWrapper::stream_set_option — Change stream options

说明

public streamWrapper::stream_set_option ( int $option , int $arg1 , int $arg2 ) : bool

This method is called to set options on the stream.

参数

option

One of:

  • STREAM_OPTION_BLOCKING (The method was called in response to stream_set_blocking())
  • STREAM_OPTION_READ_TIMEOUT (The method was called in response to stream_set_timeout())
  • STREAM_OPTION_WRITE_BUFFER (The method was called in response to stream_set_write_buffer())

arg1

If option is

  • STREAM_OPTION_BLOCKING: requested blocking mode (1 meaning block 0 not blocking).
  • STREAM_OPTION_READ_TIMEOUT: the timeout in seconds.
  • STREAM_OPTION_WRITE_BUFFER: buffer mode (STREAM_BUFFER_NONE or STREAM_BUFFER_FULL).

arg2

If option is

  • STREAM_OPTION_BLOCKING: This option is not set.
  • STREAM_OPTION_READ_TIMEOUT: the timeout in microseconds.
  • STREAM_OPTION_WRITE_BUFFER: the requested buffer size.

返回值

成功时返回 true， 或者在失败时返回 false。 If option is not implemented, false should be returned.

参见

  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式
  • stream_set_timeout() - Set timeout period on a stream
  • stream_set_write_buffer() - Sets write file buffering on the given stream


Retrieve information about a file resource

  • ? streamWrapper::stream_set_option
  • streamWrapper::stream_tell ?
  • PHP Manual
  • streamWrapper
  • Retrieve information about a file resource

streamWrapper::stream_stat

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_stat — Retrieve information about a file resource

说明

public streamWrapper::stream_stat ( ) : array

This method is called in response to fstat().

参数

此函数没有参数。

返回值

See stat().

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

参见

  • stat() - 给出文件的信息
  • streamwrapper::url_stat() - Retrieve information about a file


Retrieve the current position of a stream

  • ? streamWrapper::stream_stat
  • streamWrapper::stream_truncate ?
  • PHP Manual
  • streamWrapper
  • Retrieve the current position of a stream

streamWrapper::stream_tell

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_tell — Retrieve the current position of a stream

说明

public streamWrapper::stream_tell ( ) : int

This method is called in response to fseek() to determine the current position.

参数

此函数没有参数。

返回值

Should return the current position of the stream.

参见

  • streamWrapper::stream_tell()


Truncate stream

  • ? streamWrapper::stream_tell
  • streamWrapper::stream_write ?
  • PHP Manual
  • streamWrapper
  • Truncate stream

streamWrapper::stream_truncate

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

streamWrapper::stream_truncate — Truncate stream

说明

public streamWrapper::stream_truncate ( int $new_size ) : bool

Will respond to truncation, e.g., through ftruncate().

参数

new_size

The new size.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ftruncate() - 将文件截断到给定的长度


Write to stream

  • ? streamWrapper::stream_truncate
  • streamWrapper::unlink ?
  • PHP Manual
  • streamWrapper
  • Write to stream

streamWrapper::stream_write

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::stream_write — Write to stream

说明

public streamWrapper::stream_write ( string $data ) : int

This method is called in response to fwrite().

Note:

Remember to update the current position of the stream by number of bytes that were successfully written.

参数

data

Should be stored into the underlying stream.

Note:

If there is not enough room in the underlying stream, store as much as possible.

返回值

Should return the number of bytes that were successfully stored, or 0 if none could be stored.

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

Note:

If the return value is greater the length of data, E_WARNING will be emitted and the return value will truncated to its length.

参见

  • fwrite() - 写入文件（可安全用于二进制文件）


Delete a file

  • ? streamWrapper::stream_write
  • streamWrapper::url_stat ?
  • PHP Manual
  • streamWrapper
  • Delete a file

streamWrapper::unlink

(PHP 5, PHP 7, PHP 8)

streamWrapper::unlink — Delete a file

说明

public streamWrapper::unlink ( string $path ) : bool

This method is called in response to unlink().

Note:

In order for the appropriate error message to be returned this method should not be defined if the wrapper does not support removing files.

参数

path

The file URL which should be deleted.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

注释

Note:

当合法的上下文传递给调用函数时，属性 streamWrapper::$context 会被改变。

参见

  • unlink() - 删除文件
  • streamWrapper::rmdir() - Removes a directory


Retrieve information about a file

  • ? streamWrapper::unlink
  • Stream 函数 ?
  • PHP Manual
  • streamWrapper
  • Retrieve information about a file

streamWrapper::url_stat

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

streamWrapper::url_stat — Retrieve information about a file

说明

public streamWrapper::url_stat ( string $path , int $flags ) : array

This method is called in response to all stat() related functions, such as:

  • copy()
  • fileperms()
  • fileinode()
  • filesize()
  • fileowner()
  • filegroup()
  • fileatime()
  • filemtime()
  • filectime()
  • filetype()
  • is_writable()
  • is_readable()
  • is_executable()
  • is_file()
  • is_dir()
  • is_link()
  • file_exists()
  • lstat()
  • stat()
  • SplFileInfo::getPerms()
  • SplFileInfo::getInode()
  • SplFileInfo::getSize()
  • SplFileInfo::getOwner()
  • SplFileInfo::getGroup()
  • SplFileInfo::getATime()
  • SplFileInfo::getMTime()
  • SplFileInfo::getCTime()
  • SplFileInfo::getType()
  • SplFileInfo::isWritable()
  • SplFileInfo::isReadable()
  • SplFileInfo::isExecutable()
  • SplFileInfo::isFile()
  • SplFileInfo::isDir()
  • SplFileInfo::isLink()
  • RecursiveDirectoryIterator::hasChildren()

参数

path

The file path or URL to stat. Note that in the case of a URL, it must be a :// delimited URL. Other URL forms are not supported.

flags

Holds additional flags set by the streams API. It can hold one or more of the following values OR'd together.

Flag | Description
STREAM_URL_STAT_LINK | For resources with the ability to link to other resource (such as an HTTP Location: forward, or a filesystem symlink). This flag specified that only information about the link itself should be returned, not the resource pointed to by the link. This flag is set in response to calls to lstat(), is_link(), or filetype().
STREAM_URL_STAT_QUIET | If this flag is set, your wrapper should not raise any errors. If this flag is not set, you are responsible for reporting errors using the trigger_error() function during stating of the path.

返回值

Should return as many elements as stat() does. Unknown or unavailable values should be set to a rational value (usually 0). Pay special attention to mode as documented under stat().

错误／异常

调用此方法失败将给出 E_WARNING（未实现）。

注释

Note:

当合法的上下文传递给调用函数时，属性 streamWrapper::$context 会被改变。

参见

  • stat() - 给出文件的信息
  • streamwrapper::stream_stat() - Retrieve information about a file resource


Stream 函数

Table of Contents

  • stream_bucket_append — Append bucket to brigade
  • stream_bucket_make_writeable — Return a bucket object from the brigade for operating on
  • stream_bucket_new — Create a new bucket for use on the current stream
  • stream_bucket_prepend — Prepend bucket to brigade
  • stream_context_create — 创建资源流上下文
  • stream_context_get_default — Retrieve the default stream context
  • stream_context_get_options — 获取资源流/数据包/上下文的参数
  • stream_context_get_params — Retrieves parameters from a context
  • stream_context_set_default — Set the default stream context
  • stream_context_set_option — 对资源流、数据包或者上下文设置参数
  • stream_context_set_params — Set parameters for a stream/wrapper/context
  • stream_copy_to_stream — Copies data from one stream to another
  • stream_filter_append — Attach a filter to a stream
  • stream_filter_prepend — Attach a filter to a stream
  • stream_filter_register — Register a user defined stream filter
  • stream_filter_remove — 从资源流里移除某个过滤器
  • stream_get_contents — 读取资源流到一个字符串
  • stream_get_filters — 获取已注册的数据流过滤器列表
  • stream_get_line — 从资源流里读取一行直到给定的定界符
  • stream_get_meta_data — 从封装协议文件指针中取得报头／元数据
  • stream_get_transports — 获取已注册的套接字传输协议列表
  • stream_get_wrappers — 获取已注册的流类型
  • stream_is_local — Checks if a stream is a local stream
  • stream_isatty — Check if a stream is a TTY
  • stream_notification_callback — A callback function for the notification context parameter
  • stream_register_wrapper — 别名 stream_wrapper_register
  • stream_resolve_include_path — Resolve filename against the include path
  • stream_select — Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
  • stream_set_blocking — 为资源流设置阻塞或者阻塞模式
  • stream_set_chunk_size — 设置资源流区块大小
  • stream_set_read_buffer — Set read file buffering on the given stream
  • stream_set_timeout — Set timeout period on a stream
  • stream_set_write_buffer — Sets write file buffering on the given stream
  • stream_socket_accept — 接受由 stream_socket_server 创建的套接字连接
  • stream_socket_client — Open Internet or Unix domain socket connection
  • stream_socket_enable_crypto — Turns encryption on/off on an already connected socket
  • stream_socket_get_name — 获取本地或者远程的套接字名称
  • stream_socket_pair — 创建一对完全一样的网络套接字连接流
  • stream_socket_recvfrom — Receives data from a socket, connected or not
  • stream_socket_sendto — Sends a message to a socket, whether it is connected or not
  • stream_socket_server — Create an Internet or Unix domain server socket
  • stream_socket_shutdown — Shutdown a full-duplex connection
  • stream_supports_lock — Tells whether the stream supports locking
  • stream_wrapper_register — 注册一个用 PHP 类实现的 URL 封装协议
  • stream_wrapper_restore — Restores a previously unregistered built-in wrapper
  • stream_wrapper_unregister — Unregister a URL wrapper


Append bucket to brigade

  • ? Stream 函数
  • stream_bucket_make_writeable ?
  • PHP Manual
  • Stream 函数
  • Append bucket to brigade

stream_bucket_append

(PHP 5, PHP 7, PHP 8)

stream_bucket_append — Append bucket to brigade

说明

stream_bucket_append ( resource $brigade , object $bucket ) : void
Warning

本函数还未编写文档，仅有参数列表。


Return a bucket object from the brigade for operating on

  • ? stream_bucket_append
  • stream_bucket_new ?
  • PHP Manual
  • Stream 函数
  • Return a bucket object from the brigade for operating on

stream_bucket_make_writeable

(PHP 5, PHP 7, PHP 8)

stream_bucket_make_writeable — Return a bucket object from the brigade for operating on

说明

stream_bucket_make_writeable ( resource $brigade ) : object
Warning

本函数还未编写文档，仅有参数列表。


Create a new bucket for use on the current stream

  • ? stream_bucket_make_writeable
  • stream_bucket_prepend ?
  • PHP Manual
  • Stream 函数
  • Create a new bucket for use on the current stream

stream_bucket_new

(PHP 5, PHP 7, PHP 8)

stream_bucket_new — Create a new bucket for use on the current stream

说明

stream_bucket_new ( resource $stream , string $buffer ) : object
Warning

本函数还未编写文档，仅有参数列表。


Prepend bucket to brigade

  • ? stream_bucket_new
  • stream_context_create ?
  • PHP Manual
  • Stream 函数
  • Prepend bucket to brigade

stream_bucket_prepend

(PHP 5, PHP 7, PHP 8)

stream_bucket_prepend — Prepend bucket to brigade

说明

stream_bucket_prepend ( resource $brigade , object $bucket ) : void

This function can be called to prepend a bucket to a bucket brigade. It is typically called from php_user_filter::filter().

参数

brigade

brigade is a resource pointing to a bucket brigade which contains one or more bucket objects.

bucket

A bucket object.

返回值

没有返回值。

范例

Example #1 stream_bucket_prepend() examples

<?php

class foo extends php_user_filter {
  protected $calls = 0;
  public function filter($in, $out, &$consumed, $closing) {
    while ($bucket = stream_bucket_make_writeable($in)) {
      $consumed += $bucket->datalen;
      if ($this->calls++ == 2) {
        // This bucket will appear again before any other bucket.
        stream_bucket_prepend($in, $bucket);
      }
    }
    return PSFS_FEED_ME;
  }
}
stream_filter_register('test', 'foo');
print  file_get_contents('php://filter/read=test/resource=foo');
?>


创建资源流上下文

  • ? stream_bucket_prepend
  • stream_context_get_default ?
  • PHP Manual
  • Stream 函数
  • 创建资源流上下文

stream_context_create

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_context_create — 创建资源流上下文

说明

stream_context_create ( array $options = ? , array $params = ? ) : resource

创建并返回一个资源流上下文，该资源流中包含了 options 中提前设定的所有参数的值。

参数

options

必须是一个二维关联数组，格式如下：$arr['wrapper']['option'] = $value 。

默认是一个空数组。

params

必须是 $arr['parameter'] = $value 格式的关联数组。 请参考 context parameters 里的标准资源流参数列表。

返回值

上下文资源流，类型为 resource 。

更新日志

版本 | 说明
5.3.0 | 增加了可选参数 params 。

范例

Example #1 使用 stream_context_create()

<?php
$opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar\r\n"
  )
);

$context = stream_context_create($opts);

/* Sends an http request to www.example.com
   with additional headers shown above */
$fp = fopen('http://www.example.com', 'r', false, $context);
fpassthru($fp);
fclose($fp);
?>

参见

  • stream_context_set_option() - 对资源流、数据包或者上下文设置参数
  • Listing of supported wrappers (支持的协议和封装协议)
  • Context options (上下文（Context）选项和参数)


Retrieve the default stream context

  • ? stream_context_create
  • stream_context_get_options ?
  • PHP Manual
  • Stream 函数
  • Retrieve the default stream context

stream_context_get_default

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_context_get_default — Retrieve the default stream context

说明

stream_context_get_default ( array $options = ? ) : resource

Returns the default stream context which is used whenever file operations (fopen(), file_get_contents(), etc...) are called without a context parameter. Options for the default context can optionally be specified with this function using the same syntax as stream_context_create().

参数

options
options must be an associative array of associative arrays in the format $arr['wrapper']['option'] = $value.

Note:

As of PHP 5.3.0, the stream_context_set_default() function can be used to set the default context.

返回值

A stream context resource.

范例

Example #1 Using stream_context_get_default()

<?php
$default_opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar",
    'proxy'=>"tcp://10.54.1.39:8000"
  )
);

$alternate_opts = array(
  'http'=>array(
    'method'=>"POST",
    'header'=>"Content-type: application/x-www-form-urlencoded\r\n" .
              "Content-length: " . strlen("baz=bomb"),
    'content'=>"baz=bomb"
  )
);

$default = stream_context_get_default($default_opts);
$alternate = stream_context_create($alternate_opts);

/* Sends a regular GET request to proxy server at 10.54.1.39
 * For www.example.com using context options specified in $default_opts
 */
readfile('http://www.example.com');

/* Sends a POST request directly to www.example.com
 * Using context options specified in $alternate_opts
 */
readfile('http://www.example.com', false, $alternate);

?>

参见

  • stream_context_create() - 创建资源流上下文
  • Listing of supported wrappers with context options (支持的协议和封装协议).


获取资源流/数据包/上下文的参数

  • ? stream_context_get_default
  • stream_context_get_params ?
  • PHP Manual
  • Stream 函数
  • 获取资源流/数据包/上下文的参数

stream_context_get_options

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_context_get_options — 获取资源流/数据包/上下文的参数

说明

stream_context_get_options ( resource $stream_or_context ) : array

返回指定资源流或者上下文的数组参数。

参数

stream_or_context

获取参数信息的 stream 或者 context 。

返回值

返回一个包含有原参数的关联数组。

范例

Example #1 stream_context_get_options() 的例子

<?php
$params = array("method" => "POST");

stream_context_get_default(array("http" => $params));

var_dump(stream_context_get_options(stream_context_get_default()));

?>

以上例程的输出类似于：

array(1) {
  ["http"]=>
  array(1) {
    ["method"]=>
    string(4) "POST"
  }
}


Retrieves parameters from a context

  • ? stream_context_get_options
  • stream_context_set_default ?
  • PHP Manual
  • Stream 函数
  • Retrieves parameters from a context

stream_context_get_params

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

stream_context_get_params — Retrieves parameters from a context

说明

stream_context_get_params ( resource $stream_or_context ) : array

Retrieves parameter and options information from the stream or context.

参数

stream_or_context

A stream resource or a context resource

返回值

Returns an associate array containing all context options and parameters.

范例

Example #1 stream_context_get_params() example

Basic usage example

<?php
$ctx = stream_context_create();
$params = array("notification" => "stream_notification_callback");
stream_context_set_params($ctx, $params);

var_dump(stream_context_get_params($ctx));
?>

以上例程的输出类似于：

array(2) {
  ["notification"]=>
  string(28) "stream_notification_callback"
  ["options"]=>
  array(0) {
  }
}

参见

  • stream_context_set_option() - 对资源流、数据包或者上下文设置参数
  • stream_context_set_params() - Set parameters for a stream/wrapper/context


Set the default stream context

  • ? stream_context_get_params
  • stream_context_set_option ?
  • PHP Manual
  • Stream 函数
  • Set the default stream context

stream_context_set_default

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

stream_context_set_default — Set the default stream context

说明

stream_context_set_default ( array $options ) : resource

Set the default stream context which will be used whenever file operations (fopen(), file_get_contents(), etc...) are called without a context parameter. Uses the same syntax as stream_context_create().

参数

options

The options to set for the default context.

Note:

options must be an associative array of associative arrays in the format $arr['wrapper']['option'] = $value.

返回值

Returns the default stream context.

范例

Example #1 stream_context_set_default() example

<?php
$default_opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar",
    'proxy'=>"tcp://10.54.1.39:8000"
  )
);

$default = stream_context_set_default($default_opts);

/* Sends a regular GET request to proxy server at 10.54.1.39
 * For www.example.com using context options specified in $default_opts
 */
readfile('http://www.example.com');
?>

参见

  • stream_context_create() - 创建资源流上下文
  • stream_context_get_default() - Retrieve the default stream context
  • Listing of supported wrappers with context options (支持的协议和封装协议).


对资源流、数据包或者上下文设置参数

  • ? stream_context_set_default
  • stream_context_set_params ?
  • PHP Manual
  • Stream 函数
  • 对资源流、数据包或者上下文设置参数

stream_context_set_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_context_set_option — 对资源流、数据包或者上下文设置参数

说明

stream_context_set_option ( resource $stream_or_context , string $wrapper , string $option , mixed $value ) : bool
stream_context_set_option ( resource $stream_or_context , array $options ) : bool

给指定的上下文设置参数。参数 value 是设置 wrapper 的 option 参数的值。

参数

stream_or_context

需要添加参数的资源流或者上下文。

options

添加给默认的上下文的参数。

Note:

options 必须是一个 $arr['wrapper']['option'] = $value 格式二维关联数组 。

请参考 context options and parameters 查看资源流参数列表。

返回值

成功时返回 true， 或者在失败时返回 false。


Set parameters for a stream/wrapper/context

  • ? stream_context_set_option
  • stream_copy_to_stream ?
  • PHP Manual
  • Stream 函数
  • Set parameters for a stream/wrapper/context

stream_context_set_params

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_context_set_params — Set parameters for a stream/wrapper/context

说明

stream_context_set_params ( resource $context , array $params ) : bool

Sets parameters on the specified context.

参数

context

The stream or context to apply the parameters too.

params

An array of parameters to set.

Note:

params should be an associative array of the structure: $params['paramname'] = "paramvalue";.

Supported parameters

Parameters | Purpose
notification | Name of user-defined callback function to be called whenever a stream triggers a notification. Only supported for http:// and ftp:// stream wrappers.
options | Array of options as in context options and parameters.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • stream_notification_callback() - A callback function for the notification context parameter


Copies data from one stream to another

  • ? stream_context_set_params
  • stream_filter_append ?
  • PHP Manual
  • Stream 函数
  • Copies data from one stream to another

stream_copy_to_stream

(PHP 5, PHP 7, PHP 8)

stream_copy_to_stream — Copies data from one stream to another

说明

stream_copy_to_stream ( resource $source , resource $dest , int $maxlength = -1 , int $offset = 0 ) : int|false

Makes a copy of up to maxlength bytes of data from the current position (or from the offset position, if specified) in source to dest. If maxlength is not specified, all remaining content in source will be copied.

参数

source

The source stream

dest

The destination stream

maxlength

Maximum bytes to copy

offset

The offset where to start to copy data

返回值

Returns the total count of bytes copied, 或者在失败时返回 false.

范例

Example #1 A stream_copy_to_stream() example

<?php
$src = fopen('http://www.example.com', 'r');
$dest1 = fopen('first1k.txt', 'w');
$dest2 = fopen('remainder.txt', 'w');

echo stream_copy_to_stream($src, $dest1, 1024) . " bytes copied to first1k.txt\n";
echo stream_copy_to_stream($src, $dest2) . " bytes copied to remainder.txt\n";

?>

参见

  • copy() - 拷贝文件


Attach a filter to a stream

  • ? stream_copy_to_stream
  • stream_filter_prepend ?
  • PHP Manual
  • Stream 函数
  • Attach a filter to a stream

stream_filter_append

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_filter_append — Attach a filter to a stream

说明

stream_filter_append ( resource $stream , string $filtername , int $read_write = ? , mixed $params = ? ) : resource

Adds filtername to the list of filters attached to stream.

参数

stream

The target stream.

filtername

The filter name.

read_write

By default, stream_filter_append() will attach the filter to the read filter chain if the file was opened for reading (i.e. File Mode: r, and/or +). The filter will also be attached to the write filter chain if the file was opened for writing (i.e. File Mode: w, a, and/or +). STREAM_FILTER_READ, STREAM_FILTER_WRITE, and/or STREAM_FILTER_ALL can also be passed to the read_write parameter to override this behavior.

params

This filter will be added with the specified params to the end of the list and will therefore be called last during stream operations. To add a filter to the beginning of the list, use stream_filter_prepend().

返回值

Returns a resource on success or false on failure. The resource can be used to refer to this filter instance during a call to stream_filter_remove().

false is returned if stream is not a resource or if filtername cannot be located.

范例

Example #1 Controlling where filters are applied

<?php
/* Open a test file for reading and writing */
$fp = fopen('test.txt', 'w+');

/* Apply the ROT13 filter to the
 * write filter chain, but not the
 * read filter chain */
stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);

/* Write a simple string to the file
 * it will be ROT13 transformed on the
 * way out */
fwrite($fp, "This is a test\n");

/* Back up to the beginning of the file */
rewind($fp);

/* Read the contents of the file back out.
 * Had the filter been applied to the
 * read filter chain as well, we would see
 * the text ROT13ed back to its original state */
fpassthru($fp);

fclose($fp);

/* Expected Output
   ---------------

Guvf vf n grfg

 */
?>

注释

Note: When using custom (user) filters
stream_filter_register() must be called first in order to register the desired user filter to filtername.

Note: Stream data is read from resources (both local and remote) in chunks, with any unconsumed data kept in internal buffers. When a new filter is appended to a stream, data in the internal buffers is processed through the new filter at that time. This differs from the behavior of stream_filter_prepend().

Note: When a filter is added for read and write, two instances of the filter are created. stream_filter_append() must be called twice with STREAM_FILTER_READ and STREAM_FILTER_WRITE to get both filter resources.

参见

  • stream_filter_register() - Register a user defined stream filter
  • stream_filter_prepend() - Attach a filter to a stream
  • stream_get_filters() - 获取已注册的数据流过滤器列表


Attach a filter to a stream

  • ? stream_filter_append
  • stream_filter_register ?
  • PHP Manual
  • Stream 函数
  • Attach a filter to a stream

stream_filter_prepend

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_filter_prepend — Attach a filter to a stream

说明

stream_filter_prepend ( resource $stream , string $filtername , int $read_write = ? , mixed $params = ? ) : resource

Adds filtername to the list of filters attached to stream.

参数

stream

The target stream.

filtername

The filter name.

read_write

By default, stream_filter_prepend() will attach the filter to the read filter chain if the file was opened for reading (i.e. File Mode: r, and/or +). The filter will also be attached to the write filter chain if the file was opened for writing (i.e. File Mode: w, a, and/or +). STREAM_FILTER_READ, STREAM_FILTER_WRITE, and/or STREAM_FILTER_ALL can also be passed to the read_write parameter to override this behavior. See stream_filter_append() for an example of using this parameter.

params

This filter will be added with the specified params to the beginning of the list and will therefore be called first during stream operations. To add a filter to the end of the list, use stream_filter_append().

返回值

Returns a resource on success or false on failure. The resource can be used to refer to this filter instance during a call to stream_filter_remove().

false is returned if stream is not a resource or if filtername cannot be located.

注释

Note: When using custom (user) filters
stream_filter_register() must be called first in order to register the desired user filter to filtername.

Note: Stream data is read from resources (both local and remote) in chunks, with any unconsumed data kept in internal buffers. When a new filter is prepended to a stream, data in the internal buffers, which has already been processed through other filters will not be reprocessed through the new filter at that time. This differs from the behavior of stream_filter_append().

Note: When a filter is added for read and write, two instances of the filter are created. stream_filter_prepend() must be called twice with STREAM_FILTER_READ and STREAM_FILTER_WRITE to get both filter resources.

参见

  • stream_filter_register() - Register a user defined stream filter
  • stream_filter_append() - Attach a filter to a stream


Register a user defined stream filter

  • ? stream_filter_prepend
  • stream_filter_remove ?
  • PHP Manual
  • Stream 函数
  • Register a user defined stream filter

stream_filter_register

(PHP 5, PHP 7, PHP 8)

stream_filter_register — Register a user defined stream filter

说明

stream_filter_register ( string $filter_name , string $class ) : bool

stream_filter_register() allows you to implement your own filter on any registered stream used with all the other filesystem functions (such as fopen(), fread() etc.).

参数

filter_name

The filter name to be registered.

class

To implement a filter, you need to define a class as an extension of php_user_filter with a number of member functions. When performing read/write operations on the stream to which your filter is attached, PHP will pass the data through your filter (and any other filters attached to that stream) so that the data may be modified as desired. You must implement the methods exactly as described in php_user_filter - doing otherwise will lead to undefined behaviour.

返回值

成功时返回 true， 或者在失败时返回 false。

stream_filter_register() will return false if the filter_name is already defined.

范例

Example #1 Filter for capitalizing characters on foo-bar.txt stream

The example below implements a filter named strtoupper on the foo-bar.txt stream which will capitalize all letter characters written to/read from that stream.

<?php

/* Define our filter class */
class strtoupper_filter extends php_user_filter {
  function filter($in, $out, &$consumed, $closing)
  {
    while ($bucket = stream_bucket_make_writeable($in)) {
      $bucket->data = strtoupper($bucket->data);
      $consumed += $bucket->datalen;
      stream_bucket_append($out, $bucket);
    }
    return PSFS_PASS_ON;
  }
}

/* Register our filter with PHP */
stream_filter_register("strtoupper", "strtoupper_filter")
    or die("Failed to register filter");

$fp = fopen("foo-bar.txt", "w");

/* Attach the registered filter to the stream just opened */
stream_filter_append($fp, "strtoupper");

fwrite($fp, "Line1\n");
fwrite($fp, "Word - 2\n");
fwrite($fp, "Easy As 123\n");

fclose($fp);

/* Read the contents back out
 */
readfile("foo-bar.txt");

?>

以上例程会输出：

LINE1
WORD - 2
EASY AS 123

Example #2 Registering a generic filter class to match multiple filter names.

<?php

/* Define our filter class */
class string_filter extends php_user_filter {
  var $mode;

  function filter($in, $out, &$consumed, $closing)
  {
    while ($bucket = stream_bucket_make_writeable($in)) {
      if ($this->mode == 1) {
        $bucket->data = strtoupper($bucket->data);
      } elseif ($this->mode == 0) {
        $bucket->data = strtolower($bucket->data);
      }

      $consumed += $bucket->datalen;
      stream_bucket_append($out, $bucket);
    }
    return PSFS_PASS_ON;
  }

  function onCreate()
  {
    if ($this->filtername == 'str.toupper') {
      $this->mode = 1;
    } elseif ($this->filtername == 'str.tolower') {
      $this->mode = 0;
    } else {
      /* Some other str.* filter was asked for,
         report failure so that PHP will keep looking */
      return false;
    }

    return true;
  }
}

/* Register our filter with PHP */
stream_filter_register("str.*", "string_filter")
    or die("Failed to register filter");

$fp = fopen("foo-bar.txt", "w");

/* Attach the registered filter to the stream just opened
   We could alternately bind to str.tolower here */
stream_filter_append($fp, "str.toupper");

fwrite($fp, "Line1\n");
fwrite($fp, "Word - 2\n");
fwrite($fp, "Easy As 123\n");

fclose($fp);

/* Read the contents back out
 */
readfile("foo-bar.txt");
?>

以上例程会输出：

LINE1
WORD - 2
EASY AS 123

参见

  • stream_wrapper_register() - 注册一个用 PHP 类实现的 URL 封装协议
  • stream_filter_append() - Attach a filter to a stream
  • stream_filter_prepend() - Attach a filter to a stream


从资源流里移除某个过滤器

  • ? stream_filter_register
  • stream_get_contents ?
  • PHP Manual
  • Stream 函数
  • 从资源流里移除某个过滤器

stream_filter_remove

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_filter_remove — 从资源流里移除某个过滤器

说明

stream_filter_remove ( resource $stream_filter ) : bool

移除之前通过 stream_filter_prepend() 或者 stream_filter_append() 添加到资源流里面的过滤器。 在移除之前，残留在过滤器内部缓冲区里的所有数据刷新到下一个过滤器。

参数

stream_filter

需要被移除的资源流过滤器。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 动态地重新过滤一个资源流

<?php
/* Open a test file for reading and writing */
$fp = fopen("test.txt", "rw");

$rot13_filter = stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);
fwrite($fp, "This is ");
stream_filter_remove($rot13_filter);
fwrite($fp, "a test\n");

rewind($fp);
fpassthru($fp);
fclose($fp);

?>

以上例程会输出：

Guvf vf a test

参见

  • stream_filter_register() - Register a user defined stream filter
  • stream_filter_append() - Attach a filter to a stream
  • stream_filter_prepend() - Attach a filter to a stream


读取资源流到一个字符串

  • ? stream_filter_remove
  • stream_get_filters ?
  • PHP Manual
  • Stream 函数
  • 读取资源流到一个字符串

stream_get_contents

(PHP 5, PHP 7, PHP 8)

stream_get_contents — 读取资源流到一个字符串

说明

stream_get_contents ( resource $handle , int $maxlength = -1 , int $offset = -1 ) : string

与 file_get_contents() 一样，但是 stream_get_contents() 是对一个已经打开的资源流进行操作，并将其内容写入一个字符串返回。 返回的内容取决于 maxlength 字节长度和 offset 指定的起始位置。

参数

handle (resource)

一个资源流（例如 fopen() 操作之后返回的结果）

maxlength (integer)

需要读取的最大的字节数。默认是-1（读取全部的缓冲数据）。

offset (integer)

在读取数据之前先查找指定的偏移量。如果这个数字是负数，就不进行查找，直接从当前位置开始读取。

返回值

返回一个字符串 或者在失败时返回 false.

更新日志

版本 | 说明
5.1.0 | 增加参数 offset 。

范例

Example #1 stream_get_contents() 例子

<?php

if ($stream = fopen('http://www.example.com', 'r')) {
    // print all the page starting at the offset 10
    echo stream_get_contents($stream, -1, 10);

    fclose($stream);
}

if ($stream = fopen('http://www.example.net', 'r')) {
    // print the first 5 bytes
    echo stream_get_contents($stream, 5);

    fclose($stream);
}

?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • fgets() - 从文件指针中读取一行
  • fread() - 读取文件（可安全用于二进制文件）
  • fpassthru() - 输出文件指针处的所有剩余数据


获取已注册的数据流过滤器列表

  • ? stream_get_contents
  • stream_get_line ?
  • PHP Manual
  • Stream 函数
  • 获取已注册的数据流过滤器列表

stream_get_filters

(PHP 5, PHP 7, PHP 8)

stream_get_filters — 获取已注册的数据流过滤器列表

说明

stream_get_filters ( ) : array

获取当前运行系统中已注册的数据流过滤器列表。

返回值

返回一个包含所有有效的数据流过滤器名字的索引数组。

范例

Example #1 使用 stream_get_filters()

<?php
$streamlist = stream_get_filters();
print_r($streamlist);
?>

以上例程的输出类似于：

Array (
  [0] => string.rot13
  [1] => string.toupper
  [2] => string.tolower
  [3] => string.base64
  [4] => string.quoted-printable
)

参见

  • stream_filter_register() - Register a user defined stream filter
  • stream_get_wrappers() - 获取已注册的流类型


从资源流里读取一行直到给定的定界符

  • ? stream_get_filters
  • stream_get_meta_data ?
  • PHP Manual
  • Stream 函数
  • 从资源流里读取一行直到给定的定界符

stream_get_line

(PHP 5, PHP 7, PHP 8)

stream_get_line — 从资源流里读取一行直到给定的定界符

说明

stream_get_line ( resource $handle , int $length , string $ending = ? ) : string

从给定的资源流里读取一行。

当读取到 length 个字节数就结束，或者当在读取的字符串中发现 ending （不包含到返回值里）也结束，又或者遇到了 EOF 也结束（总之以上条件中哪个先出现就以哪个为准）。

这个函数与 fgets() 几乎是相同的，唯一的区别是在这个函数里面允许指定行尾的定界符，而不是使用标准的 \n， \r 还有 \r\n ，并且返回值中不包含定界符。（翻译注：也可以把 \n 等作为定界符传入 ending ）

参数

handle

一个有效的文件句柄。

length

需要从句柄里读取的字节数。

ending

可选参数，字符串定界符。

返回值

返回一个字符串，该字符串的内容根据 length 字节数从 handle 里读取。

如果发生错误，则返回 false.

参见

  • fread() - 读取文件（可安全用于二进制文件）
  • fgets() - 从文件指针中读取一行
  • fgetc() - 从文件指针中读取字符


从封装协议文件指针中取得报头／元数据

  • ? stream_get_line
  • stream_get_transports ?
  • PHP Manual
  • Stream 函数
  • 从封装协议文件指针中取得报头／元数据

stream_get_meta_data

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_get_meta_data — 从封装协议文件指针中取得报头／元数据

说明

stream_get_meta_data ( int $fp ) : array

返回现有 stream 的信息。可以是任何通过 fopen()，fsockopen() 和 pfsockopen() 建立的流。返回的数组包含以下项目：

  • timed_out (bool) - 如果在上次调用 fread() 或者 fgets() 中等待数据时流超时了则为 true。

  • blocked (bool) - 如果流处于阻塞 IO 模式时为 true。参见 stream_set_blocking()。

  • eof (bool) - 如果流到达文件末尾时为 true。注意对于 socket 流甚至当 unread_bytes 为非零值时也可以为 true。要测定是否有更多数据可读，用 feof() 替代读取本项目的值。

  • unread_bytes (int) - 当前在 PHP 自己的内部缓冲区中的字节数。

    Note: 不要在脚本中使用此值。

以下项目是 PHP 4.3 新加的：

  • stream_type (string) - 一个描述流底层实现的标注。

  • wrapper_type (string) - 一个描述流的分层协议封装实现的标注。更多关于封装协议的信息见 支持的协议和封装协议。

  • wrapper_data (mixed) - 当前流附加的封装协议数据。更多封装协议及其数据的信息见 支持的协议和封装协议。

  • filters (array) - 包含有被叠加在当前流的任何过滤器名的数组。过滤器的文档见附录中的可用过滤器列表。

Note:

本函数是 PHP 4.3 引进的，在此版本之前，可以用 socket_get_status() 来取得前四个项目并且仅能用于基于 socket 的流。

在 PHP 4.3 及以后版本中，socket_get_status() 是本函数的别名。

Note: 本函数不能作用于通过 Socket 扩展库创建的流。

以下项目为 PHP 5.0 新加：

  • mode (string) - 对当前流所要求的访问类型（见 fopen() 中的表格 1）。

  • seekable (bool) - 是否可以在当前流中定位。

  • uri (string) - 与当前流关联的 URI 或文件名。


获取已注册的套接字传输协议列表

  • ? stream_get_meta_data
  • stream_get_wrappers ?
  • PHP Manual
  • Stream 函数
  • 获取已注册的套接字传输协议列表

stream_get_transports

(PHP 5, PHP 7, PHP 8)

stream_get_transports — 获取已注册的套接字传输协议列表

说明

stream_get_transports ( ) : array

返回一个包含当前运行系统中所有套接字传输协议名称的索引数组。

返回值

返回一个套接字传输协议名称的索引数组。

范例

Example #1 使用 stream_get_transports()

<?php
$xportlist = stream_get_transports();
print_r($xportlist);
?>

以上例程的输出类似于：

Array (
  [0] => tcp
  [1] => udp
  [2] => unix
  [3] => udg
)

参见

  • stream_get_filters() - 获取已注册的数据流过滤器列表
  • stream_get_wrappers() - 获取已注册的流类型


获取已注册的流类型

  • ? stream_get_transports
  • stream_is_local ?
  • PHP Manual
  • Stream 函数
  • 获取已注册的流类型

stream_get_wrappers

(PHP 5, PHP 7, PHP 8)

stream_get_wrappers — 获取已注册的流类型

说明

stream_get_wrappers ( ) : array

获取在当前运行系统中已经注册并可使用的流类型列表。

返回值

返回一个索引数组，该数组里包含了当前运行系统中可使用的流类型的名称。

范例

Example #1 stream_get_wrappers() 例子

<?php
print_r(stream_get_wrappers());
?>

以上例程的输出类似于：

Array
(
    [0] => php
    [1] => file
    [2] => http
    [3] => ftp
    [4] => compress.bzip2
    [5] => compress.zlib
)

Example #2 检查一个流类型是否存在

<?php
// check for the existence of the bzip2 stream wrapper
if (in_array('compress.bzip2', stream_get_wrappers())) {
    echo 'compress.bzip2:// support enabled.';
} else {
    echo 'compress.bzip2:// support not enabled.';
}
?>

参见

  • stream_wrapper_register() - 注册一个用 PHP 类实现的 URL 封装协议


Checks if a stream is a local stream

  • ? stream_get_wrappers
  • stream_isatty ?
  • PHP Manual
  • Stream 函数
  • Checks if a stream is a local stream

stream_is_local

(PHP 5 >= 5.2.4, PHP 7, PHP 8)

stream_is_local — Checks if a stream is a local stream

说明

stream_is_local ( resource|string $stream ) : bool

Checks if a stream, or a URL, is a local one or not.

参数

stream

The stream resource or URL to check.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 stream_is_local() example

Basic usage example.

<?php
var_dump(stream_is_local("http://example.com"));
var_dump(stream_is_local("/etc"));
?>

以上例程的输出类似于：

bool(false)
bool(true)


Check if a stream is a TTY

  • ? stream_is_local
  • stream_notification_callback ?
  • PHP Manual
  • Stream 函数
  • Check if a stream is a TTY

stream_isatty

(PHP 7 >= 7.2.0, PHP 8)

stream_isatty — Check if a stream is a TTY

说明

stream_isatty ( resource $stream ) : bool

Determines if stream stream refers to a valid terminal type device. This is a more portable version of posix_isatty(), since it works on Windows systems too.

参数

stream

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 stream_isatty() example

This command can be used to determine if a standard output / standard error stream is redirected to a file.

php -r "var_export(stream_isatty(STDERR));"

以上例程的输出类似于：

true
php -r "var_export(stream_isatty(STDERR));" 2>output.txt

以上例程的输出类似于：

false


A callback function for the notification context parameter

  • ? stream_isatty
  • stream_register_wrapper ?
  • PHP Manual
  • Stream 函数
  • A callback function for the notification context parameter

stream_notification_callback

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

stream_notification_callback — A callback function for the notification context parameter

说明

stream_notification_callback ( int $notification_code , int $severity , string $message , int $message_code , int $bytes_transferred , int $bytes_max ) : void

A callable function, used by the notification context parameter, called during an event.

Note:

This is not a real function, only a prototype of how the function should be.

参数

notification_code

One of the STREAM_NOTIFY_* notification constants.

severity

One of the STREAM_NOTIFY_SEVERITY_* notification constants.

message

Passed if a descriptive message is available for the event.

message_code

Passed if a descriptive message code is available for the event.

The meaning of this value is dependent on the specific wrapper in use.

bytes_transferred

If applicable, the bytes_transferred will be populated.

bytes_max

If applicable, the bytes_max will be populated.

返回值

没有返回值。

范例

Example #1 stream_notification_callback() example

<?php
function stream_notification_callback($notification_code, $severity, $message, $message_code, $bytes_transferred, $bytes_max) {

    switch($notification_code) {
        case STREAM_NOTIFY_RESOLVE:
        case STREAM_NOTIFY_AUTH_REQUIRED:
        case STREAM_NOTIFY_COMPLETED:
        case STREAM_NOTIFY_FAILURE:
        case STREAM_NOTIFY_AUTH_RESULT:
            var_dump($notification_code, $severity, $message, $message_code, $bytes_transferred, $bytes_max);
            /* Ignore */
            break;

        case STREAM_NOTIFY_REDIRECTED:
            echo "Being redirected to: ", $message;
            break;

        case STREAM_NOTIFY_CONNECT:
            echo "Connected...";
            break;

        case STREAM_NOTIFY_FILE_SIZE_IS:
            echo "Got the filesize: ", $bytes_max;
            break;

        case STREAM_NOTIFY_MIME_TYPE_IS:
            echo "Found the mime-type: ", $message;
            break;

        case STREAM_NOTIFY_PROGRESS:
            echo "Made some progress, downloaded ", $bytes_transferred, " so far";
            break;
    }
    echo "\n";
}

$ctx = stream_context_create();
stream_context_set_params($ctx, array("notification" => "stream_notification_callback"));

file_get_contents("http://php.net/contact", false, $ctx);
?>

以上例程的输出类似于：

Connected...
Found the mime-type: text/html; CHARSET=gb2312
Being redirected to: http://no.php.net/contact
Connected...
Got the filesize: 0
Found the mime-type: text/html; CHARSET=gb2312
Being redirected to: http://no.php.net/contact.php
Connected...
Got the filesize: 4589
Found the mime-type: text/html;CHARSET=gb2312
Made some progress, downloaded 0 so far
Made some progress, downloaded 0 so far
Made some progress, downloaded 0 so far
Made some progress, downloaded 1440 so far
Made some progress, downloaded 2880 so far
Made some progress, downloaded 4320 so far
Made some progress, downloaded 5760 so far
Made some progress, downloaded 6381 so far
Made some progress, downloaded 7002 so far

Example #2 Simple progressbar for commandline download client

<?php
function usage($argv) {
    echo "Usage:\n";
    printf("\tphp %s <http://example.com/file> <localfile>\n", $argv[0]);
    exit(1);
}

function stream_notification_callback($notification_code, $severity, $message, $message_code, $bytes_transferred, $bytes_max) {
    static $filesize = null;

    switch($notification_code) {
    case STREAM_NOTIFY_RESOLVE:
    case STREAM_NOTIFY_AUTH_REQUIRED:
    case STREAM_NOTIFY_COMPLETED:
    case STREAM_NOTIFY_FAILURE:
    case STREAM_NOTIFY_AUTH_RESULT:
        /* Ignore */
        break;

    case STREAM_NOTIFY_REDIRECTED:
        echo "Being redirected to: ", $message, "\n";
        break;

    case STREAM_NOTIFY_CONNECT:
        echo "Connected...\n";
        break;

    case STREAM_NOTIFY_FILE_SIZE_IS:
        $filesize = $bytes_max;
        echo "Filesize: ", $filesize, "\n";
        break;

    case STREAM_NOTIFY_MIME_TYPE_IS:
        echo "Mime-type: ", $message, "\n";
        break;

    case STREAM_NOTIFY_PROGRESS:
        if ($bytes_transferred > 0) {
            if (!isset($filesize)) {
                printf("\rUnknown filesize.. %2d kb done..", $bytes_transferred/1024);
            } else {
                $length = (int)(($bytes_transferred/$filesize)*100);
                printf("\r[%-100s] %d%% (%2d/%2d kb)", str_repeat("=", $length). ">", $length, ($bytes_transferred/1024), $filesize/1024);
            }
        }
        break;
    }
}

isset($argv[1], $argv[2]) or usage($argv);

$ctx = stream_context_create();
stream_context_set_params($ctx, array("notification" => "stream_notification_callback"));

$fp = fopen($argv[1], "r", false, $ctx);
if (is_resource($fp) && file_put_contents($argv[2], $fp)) {
    echo "\nDone!\n";
    exit(0);
}

$err = error_get_last();
echo "\nErrrrrorr..\n", $err["message"], "\n";
exit(1);
?>

Executing the example above with: php -n fetch.php http://no2.php.net/get/php-5-LATEST.tar.bz2/from/this/mirror php-latest.tar.bz2 will output something similar too:

Connected...
Mime-type: text/html; CHARSET=gb2312
Being redirected to: http://no2.php.net/distributions/php-5.2.5.tar.bz2
Connected...
Filesize: 7773024
Mime-type: application/octet-stream
[========================================>                                                           ] 40% (3076/7590 kb)

参见

  • Context 参数


别名 stream_wrapper_register

  • ? stream_notification_callback
  • stream_resolve_include_path ?
  • PHP Manual
  • Stream 函数
  • 别名 stream_wrapper_register

stream_register_wrapper

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_register_wrapper — 别名 stream_wrapper_register()

说明

此函数是该函数的别名： stream_wrapper_register().


Resolve filename against the include path

  • ? stream_register_wrapper
  • stream_select ?
  • PHP Manual
  • Stream 函数
  • Resolve filename against the include path

stream_resolve_include_path

(PHP 5 >= 5.3.2, PHP 7, PHP 8)

stream_resolve_include_path — Resolve filename against the include path

说明

stream_resolve_include_path ( string $filename ) : string|false

Resolve filename against the include path according to the same rules as fopen()/include.

参数

filename

The filename to resolve.

返回值

Returns a string containing the resolved absolute filename, 或者在失败时返回 false.

范例

Example #1 stream_resolve_include_path() example

Basic usage example.

<?php
var_dump(stream_resolve_include_path("test.php"));
?>

以上例程的输出类似于：

string(22) "/var/www/html/test.php"


Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec

  • ? stream_resolve_include_path
  • stream_set_blocking ?
  • PHP Manual
  • Stream 函数
  • Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec

stream_select

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_select — Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec

说明

stream_select ( array &$read , array &$write , array &$except , int $tv_sec , int $tv_usec = 0 ) : int

The stream_select() function accepts arrays of streams and waits for them to change status. Its operation is equivalent to that of the socket_select() function except in that it acts on streams.

参数

read

The streams listed in the read array will be watched to see if characters become available for reading (more precisely, to see if a read will not block - in particular, a stream resource is also ready on end-of-file, in which case an fread() will return a zero length string).

write

The streams listed in the write array will be watched to see if a write will not block.

except

The streams listed in the except array will be watched for high priority exceptional ("out-of-band") data arriving.

Note:

When stream_select() returns, the arrays read, write and except are modified to indicate which stream resource(s) actually changed status. The original keys of the arrays are preserved.

tv_sec

The tv_sec and tv_usec together form the timeout parameter, tv_sec specifies the number of seconds while tv_usec the number of microseconds. The timeout is an upper bound on the amount of time that stream_select() will wait before it returns. If tv_sec and tv_usec are both set to 0, stream_select() will not wait for data - instead it will return immediately, indicating the current status of the streams.

If tv_sec is null stream_select() can block indefinitely, returning only when an event on one of the watched streams occurs (or if a signal interrupts the system call).

Warning

Using a timeout value of 0 allows you to instantaneously poll the status of the streams, however, it is NOT a good idea to use a 0 timeout value in a loop as it will cause your script to consume too much CPU time.

It is much better to specify a timeout value of a few seconds, although if you need to be checking and running other code concurrently, using a timeout value of at least 200000 microseconds will help reduce the CPU usage of your script.

Remember that the timeout value is the maximum time that will elapse; stream_select() will return as soon as the requested streams are ready for use.

tv_usec

See tv_sec description.

返回值

On success stream_select() returns the number of stream resources contained in the modified arrays, which may be zero if the timeout expires before anything interesting happens. On error false is returned and a warning raised (this can happen if the system call is interrupted by an incoming signal).

范例

Example #1 stream_select() Example

This example checks to see if data has arrived for reading on either $stream1 or $stream2. Since the timeout value is 0 it will return immediately:

<?php
/* Prepare the read array */
$read   = array($stream1, $stream2);
$write  = NULL;
$except = NULL;
if (false === ($num_changed_streams = stream_select($read, $write, $except, 0))) {
    /* Error handling */
} elseif ($num_changed_streams > 0) {
    /* At least on one of the streams something interesting happened */
}
?>

注释

Note:

Due to a limitation in the current Zend Engine it is not possible to pass a constant modifier like null directly as a parameter to a function which expects this parameter to be passed by reference. Instead use a temporary variable or an expression with the leftmost member being a temporary variable:

<?php
$e = NULL;
stream_select($r, $w, $e, 0);
?>

Note:

Be sure to use the === operator when checking for an error. Since the stream_select() may return 0 the comparison with == would evaluate to true:

<?php
$e = NULL;
if (false === stream_select($r, $w, $e, 0)) {
    echo "stream_select() failed\n";
}
?>

Note:

If you read/write to a stream returned in the arrays be aware that they do not necessarily read/write the full amount of data you have requested. Be prepared to even only be able to read/write a single byte.

Note:

Some streams (like zlib) cannot be selected by this function.

Note: Windows compatibility

Use of stream_select() on file descriptors returned by proc_open() will fail and return false under Windows.

STDIN from a console changes status as soon as any input events are available, but reading from the stream may still block.

参见

  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式


为资源流设置阻塞或者阻塞模式

  • ? stream_select
  • stream_set_chunk_size ?
  • PHP Manual
  • Stream 函数
  • 为资源流设置阻塞或者阻塞模式

stream_set_blocking

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_set_blocking — 为资源流设置阻塞或者阻塞模式

说明

stream_set_blocking ( resource $stream , bool $mode ) : bool

为 stream 设置阻塞或者阻塞模。

此函数适用于支持非阻塞模式的任何资源流（常规文件，套接字资源流等）。

参数

stream

资源流。

mode

如果 mode 为 false，资源流将会被转换为非阻塞模式；如果是 true，资源流将会被转换为阻塞模式。 该参数的设置将会影响到像 fgets() 和 fread() 这样的函数从资源流里读取数据。 在非阻塞模式下，调用 fgets() 总是会立即返回；而在阻塞模式下，将会一直等到从资源流里面获取到数据才能返回。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

该函数之前叫作 set_socket_blocking() 后来又叫做 socket_set_blocking() ，但是这种用法都已经被废弃。

Note:

在 Windows 系统上，这对本地文件没有影响。Windows 不支持本地文件的非阻塞 IO。

参见

  • stream_select() - Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec


设置资源流区块大小

  • ? stream_set_blocking
  • stream_set_read_buffer ?
  • PHP Manual
  • Stream 函数
  • 设置资源流区块大小

stream_set_chunk_size

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

stream_set_chunk_size — 设置资源流区块大小

说明

stream_set_chunk_size ( resource $fp , int $chunk_size ) : int

设置资源流区块大小。

参数

fp

目标资源流。

chunk_size

想设置的新的区块大小。

返回值

成功的情况下返回资源流之前的区块大小。

如果 chunk_size 比 1 小或者比 PHP_INT_MAX 还大，就将返回 false 。

错误／异常

当 chunk_size 比 1 小或者比 PHP_INT_MAX 还大的时候将会产生一个 E_WARNING 级别的错误。


Set read file buffering on the given stream

  • ? stream_set_chunk_size
  • stream_set_timeout ?
  • PHP Manual
  • Stream 函数
  • Set read file buffering on the given stream

stream_set_read_buffer

(PHP 5 >= 5.3.3, PHP 7, PHP 8)

stream_set_read_buffer — Set read file buffering on the given stream

说明

stream_set_read_buffer ( resource $stream , int $size ) : int

Sets the read buffer. It's the equivalent of stream_set_write_buffer(), but for read operations.

参数

stream

The file pointer.

size

The number of bytes to buffer. If size is 0 then read operations are unbuffered. This ensures that all reads with fread() are completed before other processes are allowed to read from that input stream.

返回值

Returns 0 on success, or another value if the request cannot be honored.

参见

  • stream_set_write_buffer() - Sets write file buffering on the given stream


Set timeout period on a stream

  • ? stream_set_read_buffer
  • stream_set_write_buffer ?
  • PHP Manual
  • Stream 函数
  • Set timeout period on a stream

stream_set_timeout

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_set_timeout — Set timeout period on a stream

说明

stream_set_timeout ( resource $stream , int $seconds , int $microseconds = 0 ) : bool

Sets the timeout value on stream, expressed in the sum of seconds and microseconds.

When the stream times out, the 'timed_out' key of the array returned by stream_get_meta_data() is set to true, although no error/warning is generated.

参数

stream

The target stream.

seconds

The seconds part of the timeout to be set.

microseconds

The microseconds part of the timeout to be set.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 stream_set_timeout() example

<?php
$fp = fsockopen("www.example.com", 80);
if (!$fp) {
    echo "Unable to open\n";
} else {

    fwrite($fp, "GET / HTTP/1.0\r\n\r\n");
    stream_set_timeout($fp, 2);
    $res = fread($fp, 2000);

    $info = stream_get_meta_data($fp);
    fclose($fp);

    if ($info['timed_out']) {
        echo 'Connection timed out!';
    } else {
        echo $res;
    }

}
?>

注释

Note:

This function doesn't work with advanced operations like stream_socket_recvfrom(), use stream_select() with timeout parameter instead.

This function was previously called as set_socket_timeout() and later socket_set_timeout() but this usage is deprecated.

参见

  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接
  • fopen() - 打开文件或者 URL


Sets write file buffering on the given stream

  • ? stream_set_timeout
  • stream_socket_accept ?
  • PHP Manual
  • Stream 函数
  • Sets write file buffering on the given stream

stream_set_write_buffer

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

stream_set_write_buffer — Sets write file buffering on the given stream

说明

stream_set_write_buffer ( resource $stream , int $buffer ) : int

Sets the buffering for write operations on the given stream to buffer bytes.

参数

stream

The file pointer.

buffer

The number of bytes to buffer. If buffer is 0 then write operations are unbuffered. This ensures that all writes with fwrite() are completed before other processes are allowed to write to that output stream.

返回值

Returns 0 on success, or another value if the request cannot be honored.

范例

Example #1 stream_set_write_buffer() example

The following example demonstrates how to use stream_set_write_buffer() to create an unbuffered stream.

<?php
$fp = fopen($file, "w");
if ($fp) {
  if (stream_set_write_buffer($fp, 0) !== 0) {
      // changing the buffering failed
  }
  fwrite($fp, $output);
  fclose($fp);
}
?>

参见

  • fopen() - 打开文件或者 URL
  • fwrite() - 写入文件（可安全用于二进制文件）


接受由 stream_socket_server 创建的套接字连接

  • ? stream_set_write_buffer
  • stream_socket_client ?
  • PHP Manual
  • Stream 函数
  • 接受由 stream_socket_server 创建的套接字连接

stream_socket_accept

(PHP 5, PHP 7, PHP 8)

stream_socket_accept — 接受由 stream_socket_server() 创建的套接字连接

说明

stream_socket_accept ( resource $server_socket , float $timeout = ini_get("default_socket_timeout") , string &$peername = ? ) : resource

接受由 stream_socket_server() 创建的套接字连接。

参数

server_socket

需要接受的服务器创建的套接字连接。

timeout

覆盖默认的套接字接受的超时时限。输入的时间需以秒为单位。

peername

如果包含该参数并且是可以从选中的传输数据中获取到，则将被设置给连接中的客户端主机的名称（地址）（怕出入很大，附带上原文：Will be set to the name (address) of the client which connected, if included and available from the selected transport.）

Note:

也可以之后通过 stream_socket_get_name() 来确定。

返回值

返回接受套接之后的资源流 或者在失败时返回 false。

注释

Warning

该函数不能被用于 UDP 套接字。可以使用 stream_socket_recvfrom() 和 stream_socket_sendto() 来取而代之。

参见

  • stream_socket_server() - Create an Internet or Unix domain server socket
  • stream_socket_get_name() - 获取本地或者远程的套接字名称
  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式
  • stream_set_timeout() - Set timeout period on a stream
  • fgets() - 从文件指针中读取一行
  • fgetss() - 从文件指针中读取一行并过滤掉 HTML 标记
  • fwrite() - 写入文件（可安全用于二进制文件）
  • fclose() - 关闭一个已打开的文件指针
  • feof() - 测试文件指针是否到了文件结束的位置
  • cURL 函数


Open Internet or Unix domain socket connection

  • ? stream_socket_accept
  • stream_socket_enable_crypto ?
  • PHP Manual
  • Stream 函数
  • Open Internet or Unix domain socket connection

stream_socket_client

(PHP 5, PHP 7, PHP 8)

stream_socket_client — Open Internet or Unix domain socket connection

说明

stream_socket_client ( string $remote_socket , int &$errno = ? , string &$errstr = ? , float $timeout = ini_get("default_socket_timeout") , int $flags = STREAM_CLIENT_CONNECT , resource $context = ? ) : resource

Initiates a stream or datagram connection to the destination specified by remote_socket. The type of socket created is determined by the transport specified using standard URL formatting: transport://target. For Internet Domain sockets (AF_INET) such as TCP and UDP, the target portion of the remote_socket parameter should consist of a hostname or IP address followed by a colon and a port number. For Unix domain sockets, the target portion should point to the socket file on the filesystem.

Note:

The stream will by default be opened in blocking mode. You can switch it to non-blocking mode by using stream_set_blocking().

参数

remote_socket

Address to the socket to connect to.

errno

Will be set to the system level error number if connection fails.

errstr

Will be set to the system level error message if the connection fails.

timeout

Number of seconds until the connect() system call should timeout.

Note: This parameter only applies when not making asynchronous connection attempts.

Note:

To set a timeout for reading/writing data over the socket, use the stream_set_timeout(), as the timeout only applies while making connecting the socket.

flags

Bitmask field which may be set to any combination of connection flags. Currently the select of connection flags is limited to STREAM_CLIENT_CONNECT (default), STREAM_CLIENT_ASYNC_CONNECT and STREAM_CLIENT_PERSISTENT.

context

A valid context resource created with stream_context_create().

返回值

On success a stream resource is returned which may
be used together with the other file functions (such as
fgets(), fgetss(),
fwrite(), fclose(), and
feof()), false on failure.

错误／异常

On failure the errno and errstr arguments will be populated with the actual system level error that occurred in the system-level connect() call. If the value returned in errno is 0 and the function returned false, it is an indication that the error occurred before the connect() call. This is most likely due to a problem initializing the socket. Note that the errno and errstr arguments will always be passed by reference.

范例

Example #1 stream_socket_client() example

<?php
$fp = stream_socket_client("tcp://www.example.com:80", $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br />\n";
} else {
    fwrite($fp, "GET / HTTP/1.0\r\nHost: www.example.com\r\nAccept: */*\r\n\r\n");
    while (!feof($fp)) {
        echo fgets($fp, 1024);
    }
    fclose($fp);
}
?>

Example #2 Using UDP connection

Retrieving the day and time from the UDP service "daytime" (port 13) on localhost.

<?php
$fp = stream_socket_client("udp://127.0.0.1:13", $errno, $errstr);
if (!$fp) {
    echo "ERROR: $errno - $errstr<br />\n";
} else {
    fwrite($fp, "\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

注释

Warning

UDP sockets will sometimes appear to have opened without an error, even if the remote host is unreachable. The error will only become apparent when you read or write data to/from the socket. The reason for this is because UDP is a "connectionless" protocol, which means that the operating system does not try to establish a link for the socket until it actually needs to send or receive data.

Note: 当指定数值型的 IPv6 地址（例如 fe80::1）时必须用方括号将 IP 围起来——例如， tcp://[fe80::1]:80。

Note:

Depending on the environment, the Unix domain or the optional connect timeout may not be available. A list of available transports can be retrieved using stream_get_transports(). See 所支持的套接字传输器（Socket Transports）列表 for a list of built in transports.

参见

  • stream_socket_server() - Create an Internet or Unix domain server socket
  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式
  • stream_set_timeout() - Set timeout period on a stream
  • stream_select() - Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
  • fgets() - 从文件指针中读取一行
  • fgetss() - 从文件指针中读取一行并过滤掉 HTML 标记
  • fwrite() - 写入文件（可安全用于二进制文件）
  • fclose() - 关闭一个已打开的文件指针
  • feof() - 测试文件指针是否到了文件结束的位置
  • cURL 函数


Turns encryption on/off on an already connected socket

  • ? stream_socket_client
  • stream_socket_get_name ?
  • PHP Manual
  • Stream 函数
  • Turns encryption on/off on an already connected socket

stream_socket_enable_crypto

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_socket_enable_crypto — Turns encryption on/off on an already connected socket

说明

stream_socket_enable_crypto ( resource $stream , bool $enable , int $crypto_type = ? , resource $session_stream = ? ) : mixed

Enable or disable encryption on the stream.

Once the crypto settings are established, cryptography can be turned on and off dynamically by passing true or false in the enable parameter.

参数

stream

The stream resource.

enable

Enable/disable cryptography on the stream.

crypto_type

Setup encryption on the stream. Valid methods are

  • STREAM_CRYPTO_METHOD_SSLv2_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv3_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv23_CLIENT
  • STREAM_CRYPTO_METHOD_ANY_CLIENT
  • STREAM_CRYPTO_METHOD_TLS_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv2_SERVER
  • STREAM_CRYPTO_METHOD_SSLv3_SERVER
  • STREAM_CRYPTO_METHOD_SSLv23_SERVER
  • STREAM_CRYPTO_METHOD_ANY_SERVER
  • STREAM_CRYPTO_METHOD_TLS_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_0_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_1_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_2_SERVER

If omitted, the crypto_method context option on the stream's SSL context will be used instead.

session_stream

Seed the stream with settings from session_stream.

返回值

Returns true on success, false if negotiation has failed or 0 if there isn't enough data and you should try again (only for non-blocking sockets).

更新日志

版本 | 说明
5.6.0 | Introduce STREAM_CRYPTO_METHOD_ANY_CLIENT, STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT, STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT, STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT, STREAM_CRYPTO_METHOD_ANY_SERVER, STREAM_CRYPTO_METHOD_TLSv1_0_SERVER, STREAM_CRYPTO_METHOD_TLSv1_1_SERVER, STREAM_CRYPTO_METHOD_TLSv1_2_SERVER.
5.6.0 | The crypto_type is now optional.

范例

Example #1 stream_socket_enable_crypto() example

<?php
$fp = stream_socket_client("tcp://myproto.example.com:31337", $errno, $errstr, 30);
if (!$fp) {
    die("Unable to connect: $errstr ($errno)");
}

/* Turn on encryption for login phase */
stream_socket_enable_crypto($fp, true, STREAM_CRYPTO_METHOD_SSLv23_CLIENT);
fwrite($fp, "USER god\r\n");
fwrite($fp, "PASS secret\r\n");

/* Turn off encryption for the rest */
stream_socket_enable_crypto($fp, false);

while ($motd = fgets($fp)) {
    echo $motd;
}

fclose($fp);
?>

以上例程的输出类似于：

参见

  • OpenSSL 函数
    •

  • 所支持的套接字传输器（Socket Transports）列表
    •


获取本地或者远程的套接字名称

  • ? stream_socket_enable_crypto
  • stream_socket_pair ?
  • PHP Manual
  • Stream 函数
  • 获取本地或者远程的套接字名称

stream_socket_get_name

(PHP 5, PHP 7, PHP 8)

stream_socket_get_name — 获取本地或者远程的套接字名称

说明

stream_socket_get_name ( resource $handle , bool $want_peer ) : string

返回给定的本地或者远程套接字连接的名称。

参数

handle

需要获取其名称的套接字连接。

want_peer

如果设置为 true ，那么将返回 remote 套接字连接名称；如果设置为 false 则返回 local 套接字连接名称。

返回值

套接字连接的名称。

参见

  • stream_socket_accept() - 接受由 stream_socket_server 创建的套接字连接


创建一对完全一样的网络套接字连接流

  • ? stream_socket_get_name
  • stream_socket_recvfrom ?
  • PHP Manual
  • Stream 函数
  • 创建一对完全一样的网络套接字连接流

stream_socket_pair

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_socket_pair — 创建一对完全一样的网络套接字连接流

说明

stream_socket_pair ( int $domain , int $type , int $protocol ) : array

stream_socket_pair() 创建一对完全一样的网络套接字连接，这个函数通常会被用在进程间通信(Inter-Process Communication)

参数

domain

使用的协议族： STREAM_PF_INET, STREAM_PF_INET6 or STREAM_PF_UNIX

type

通信类型: STREAM_SOCK_DGRAM, STREAM_SOCK_RAW, STREAM_SOCK_RDM, STREAM_SOCK_SEQPACKET or STREAM_SOCK_STREAM

protocol

使用的传输协议: STREAM_IPPROTO_ICMP, STREAM_IPPROTO_IP, STREAM_IPPROTO_RAW, STREAM_IPPROTO_TCP or STREAM_IPPROTO_UDP

Note: Please consult the Streams constant list for further details on each constant.

返回值

如果成功将返回一个数组包括了两个socket资源，错误时返回false

更新日志

版本 | 说明
5.3.0 | 这个函数在windows平台不可用

范例

Example #1 A stream_socket_pair() example

This example shows the basic usage of stream_socket_pair() in Inter-Process Comunication.

<?php

$sockets = stream_socket_pair(STREAM_PF_UNIX, STREAM_SOCK_STREAM, STREAM_IPPROTO_IP);
$pid     = pcntl_fork();

if ($pid == -1) {
     die('could not fork');

} else if ($pid) {
     /* parent */
    fclose($sockets[0]);

    fwrite($sockets[1], "child PID: $pid\n");
    echo fgets($sockets[1]);

    fclose($sockets[1]);

} else {
    /* child */
    fclose($sockets[1]);

    fwrite($sockets[0], "message from child\n");
    echo fgets($sockets[0]);

    fclose($sockets[0]);
}

?>

以上例程的输出类似于：

child PID: 1378
message from child


Receives data from a socket, connected or not

  • ? stream_socket_pair
  • stream_socket_sendto ?
  • PHP Manual
  • Stream 函数
  • Receives data from a socket, connected or not

stream_socket_recvfrom

(PHP 5, PHP 7, PHP 8)

stream_socket_recvfrom — Receives data from a socket, connected or not

说明

stream_socket_recvfrom ( resource $socket , int $length , int $flags = 0 , string &$address = ? ) : string

stream_socket_recvfrom() accepts data from a remote socket up to length bytes.

参数

socket

The remote socket.

length

The number of bytes to receive from the socket.

flags

The value of flags can be any combination of the following:

Possible values for flags
STREAM_OOB | Process OOB (out-of-band) data.
STREAM_PEEK | Retrieve data from the socket, but do not consume the buffer. Subsequent calls to fread() or stream_socket_recvfrom() will see the same data.

address

If address is provided it will be populated with the address of the remote socket.

返回值

Returns the read data, as a string

范例

Example #1 stream_socket_recvfrom() example

<?php
/* Open a server socket to port 1234 on localhost */
$server = stream_socket_server('tcp://127.0.0.1:1234');

/* Accept a connection */
$socket = stream_socket_accept($server);

/* Grab a packet (1500 is a typical MTU size) of OOB data */
echo "Received Out-Of-Band: '" . stream_socket_recvfrom($socket, 1500, STREAM_OOB) . "'\n";

/* Take a peek at the normal in-band data, but don't consume it. */
echo "Data: '" . stream_socket_recvfrom($socket, 1500, STREAM_PEEK) . "'\n";

/* Get the exact same packet again, but remove it from the buffer this time. */
echo "Data: '" . stream_socket_recvfrom($socket, 1500) . "'\n";

/* Close it up */
fclose($socket);
fclose($server);
?>

注释

Note:

If a message received is longer than the length parameter, excess bytes may be discarded depending on the type of socket the message is received from (such as UDP).

Note:

Calls to stream_socket_recvfrom() on socket-based streams, after calls to buffer-based stream functions (like fread() or stream_get_line()) read data directly from the socket and bypass the stream buffer.

参见

  • stream_socket_sendto() - Sends a message to a socket, whether it is connected or not
  • stream_socket_client() - Open Internet or Unix domain socket connection
  • stream_socket_server() - Create an Internet or Unix domain server socket


Sends a message to a socket, whether it is connected or not

  • ? stream_socket_recvfrom
  • stream_socket_server ?
  • PHP Manual
  • Stream 函数
  • Sends a message to a socket, whether it is connected or not

stream_socket_sendto

(PHP 5, PHP 7, PHP 8)

stream_socket_sendto — Sends a message to a socket, whether it is connected or not

说明

stream_socket_sendto ( resource $socket , string $data , int $flags = 0 , string $address = ? ) : int

Sends the specified data through the socket.

参数

socket

The socket to send data to.

data

The data to be sent.

flags

The value of flags can be any combination of the following:

possible values for flags
STREAM_OOB Process OOB (out-of-band) data.

address

The address specified when the socket stream was created will be used unless an alternate address is specified in address.

If specified, it must be in dotted quad (or [ipv6]) format.

返回值

Returns a result code, as an integer.

范例

Example #1 stream_socket_sendto() Example

<?php
/* Open a socket to port 1234 on localhost */
$socket = stream_socket_client('tcp://127.0.0.1:1234');

/* Send ordinary data via ordinary channels. */
fwrite($socket, "Normal data transmit.");

/* Send more data out of band. */
stream_socket_sendto($socket, "Out of Band data.", STREAM_OOB);

/* Close it up */
fclose($socket);
?>

参见

  • stream_socket_recvfrom() - Receives data from a socket, connected or not
  • stream_socket_client() - Open Internet or Unix domain socket connection
  • stream_socket_server() - Create an Internet or Unix domain server socket


Create an Internet or Unix domain server socket

  • ? stream_socket_sendto
  • stream_socket_shutdown ?
  • PHP Manual
  • Stream 函数
  • Create an Internet or Unix domain server socket

stream_socket_server

(PHP 5, PHP 7, PHP 8)

stream_socket_server — Create an Internet or Unix domain server socket

说明

stream_socket_server ( string $local_socket , int &$errno = ? , string &$errstr = ? , int $flags = STREAM_SERVER_BIND | STREAM_SERVER_LISTEN , resource $context = ? ) : resource

Creates a stream or datagram socket on the specified local_socket.

This function only creates a socket, to begin accepting connections use stream_socket_accept().

参数

local_socket

The type of socket created is determined by the transport specified using standard URL formatting: transport://target.

For Internet Domain sockets (AF_INET) such as TCP and UDP, the target portion of the remote_socket parameter should consist of a hostname or IP address followed by a colon and a port number. For Unix domain sockets, the target portion should point to the socket file on the filesystem.

Depending on the environment, Unix domain sockets may not be available. A list of available transports can be retrieved using stream_get_transports(). See 所支持的套接字传输器（Socket Transports）列表 for a list of bulitin transports.

errno

If the optional errno and errstr arguments are present they will be set to indicate the actual system level error that occurred in the system-level socket(), bind(), and listen() calls. If the value returned in errno is 0 and the function returned false, it is an indication that the error occurred before the bind() call. This is most likely due to a problem initializing the socket. Note that the errno and errstr arguments will always be passed by reference.

errstr

See errno description.

flags

A bitmask field which may be set to any combination of socket creation flags.

Note:

For UDP sockets, you must use STREAM_SERVER_BIND as the flags parameter.

context

返回值

Returns the created stream, or false on error.

范例

Example #1 Using TCP server sockets

<?php
$socket = stream_socket_server("tcp://0.0.0.0:8000", $errno, $errstr);
if (!$socket) {
  echo "$errstr ($errno)<br />\n";
} else {
  while ($conn = stream_socket_accept($socket)) {
    fwrite($conn, 'The local time is ' . date('n/j/Y g:i a') . "\n");
    fclose($conn);
  }
  fclose($socket);
}
?>

The example below shows how to act as a time server which can respond to time queries as shown in an example on stream_socket_client().

Note: Most systems require root access to create a server socket on a port below 1024.

Example #2 Using UDP server sockets

<?php
$socket = stream_socket_server("udp://127.0.0.1:1113", $errno, $errstr, STREAM_SERVER_BIND);
if (!$socket) {
    die("$errstr ($errno)");
}

do {
    $pkt = stream_socket_recvfrom($socket, 1, 0, $peer);
    echo "$peer\n";
    stream_socket_sendto($socket, date("D M j H:i:s Y\r\n"), 0, $peer);
} while ($pkt !== false);

?>

注释

Note: 当指定数值型的 IPv6 地址（例如 fe80::1）时必须用方括号将 IP 围起来——例如， tcp://[fe80::1]:80。

参见

  • stream_socket_client() - Open Internet or Unix domain socket connection
  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式
  • stream_set_timeout() - Set timeout period on a stream
  • fgets() - 从文件指针中读取一行
  • fgetss() - 从文件指针中读取一行并过滤掉 HTML 标记
  • fwrite() - 写入文件（可安全用于二进制文件）
  • fclose() - 关闭一个已打开的文件指针
  • feof() - 测试文件指针是否到了文件结束的位置
  • Curl extension


Shutdown a full-duplex connection

  • ? stream_socket_server
  • stream_supports_lock ?
  • PHP Manual
  • Stream 函数
  • Shutdown a full-duplex connection

stream_socket_shutdown

(PHP 5 >= 5.2.1, PHP 7, PHP 8)

stream_socket_shutdown — Shutdown a full-duplex connection

说明

stream_socket_shutdown ( resource $stream , int $mode ) : bool

Shutdowns (partially or not) a full-duplex connection.

Note:

The associated buffer, or buffers, may or may not be emptied.

参数

stream

An open stream (opened with stream_socket_client(), for example)

mode

One of the following constants: STREAM_SHUT_RD (disable further receptions), STREAM_SHUT_WR (disable further transmissions) or STREAM_SHUT_RDWR (disable further receptions and transmissions).

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 A stream_socket_shutdown() example

<?php

$server = stream_socket_server('tcp://127.0.0.1:1337');
$client = stream_socket_client('tcp://127.0.0.1:1337');

var_dump(fputs($client, "hello"));

stream_socket_shutdown($client, STREAM_SHUT_WR);
var_dump(fputs($client, "hello")); // doesn't work now

?>

以上例程的输出类似于：

int(5)

Notice: fputs(): send of 5 bytes failed with errno=32 Broken pipe in test.php on line 9
int(0)

参见

  • fclose() - 关闭一个已打开的文件指针


Tells whether the stream supports locking

  • ? stream_socket_shutdown
  • stream_wrapper_register ?
  • PHP Manual
  • Stream 函数
  • Tells whether the stream supports locking

stream_supports_lock

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

stream_supports_lock — Tells whether the stream supports locking

说明

stream_supports_lock ( resource $stream ) : bool

Tells whether the stream supports locking through flock().

参数

stream

The stream to check.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • flock() - 轻便的咨询文件锁定


注册一个用 PHP 类实现的 URL 封装协议

  • ? stream_supports_lock
  • stream_wrapper_restore ?
  • PHP Manual
  • Stream 函数
  • 注册一个用 PHP 类实现的 URL 封装协议

stream_wrapper_register

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

stream_wrapper_register — 注册一个用 PHP 类实现的 URL 封装协议

说明

stream_wrapper_register ( string $protocol , string $classname , int $flags = 0 ) : bool

允许用户实现自定义的协议处理器和流，用于所有其它的文件系统函数中（例如 fopen()，fread() 等）。

参数

protocol

待注册的封装的名字。

classname

实现了protocol的类名。

flags

Should be set to STREAM_IS_URL if protocol is a URL protocol. Default is 0, local stream.

返回值

成功时返回 true， 或者在失败时返回 false。

当 protocol 已经有处理者时，stream_wrapper_register() 将返回false

更新日志

版本 | 说明
5.2.4 | 添加 flags 参数.

范例

Example #1 如何注册一个 stream wrapper

<?php
$existed = in_array("var", stream_get_wrappers());
if ($existed) {
    stream_wrapper_unregister("var");
}
stream_wrapper_register("var", "VariableStream");
$myvar = "";

$fp = fopen("var://myvar", "r+");

fwrite($fp, "line1\n");
fwrite($fp, "line2\n");
fwrite($fp, "line3\n");

rewind($fp);
while (!feof($fp)) {
    echo fgets($fp);
}
fclose($fp);
var_dump($myvar);

if ($existed) {
    stream_wrapper_restore("var");
}

?>

以上例程会输出：

line1
line2
line3
string(18) "line1
line2
line3
"

参见

  • The streamWrapper prototype class
  • Example class registered as stream wrapper
  • stream_wrapper_unregister() - Unregister a URL wrapper
  • stream_wrapper_restore() - Restores a previously unregistered built-in wrapper
  • stream_get_wrappers() - 获取已注册的流类型


Restores a previously unregistered built-in wrapper

  • ? stream_wrapper_register
  • stream_wrapper_unregister ?
  • PHP Manual
  • Stream 函数
  • Restores a previously unregistered built-in wrapper

stream_wrapper_restore

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_wrapper_restore — Restores a previously unregistered built-in wrapper

说明

stream_wrapper_restore ( string $protocol ) : bool

Restores a built-in wrapper previously unregistered with stream_wrapper_unregister().

参数

protocol

返回值

成功时返回 true， 或者在失败时返回 false。


Unregister a URL wrapper

  • ? stream_wrapper_restore
  • Swoole ?
  • PHP Manual
  • Stream 函数
  • Unregister a URL wrapper

stream_wrapper_unregister

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

stream_wrapper_unregister — Unregister a URL wrapper

说明

stream_wrapper_unregister ( string $protocol ) : bool

Allows you to disable an already defined stream wrapper. Once the wrapper has been disabled you may override it with a user-defined wrapper using stream_wrapper_register() or reenable it later on with stream_wrapper_restore().

参数

protocol

返回值

成功时返回 true， 或者在失败时返回 false。


Swoole

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Swoole 函数
    • swoole_async_dns_lookup — Async and non-blocking hostname to IP lookup
    • swoole_async_read — Read file stream asynchronously
    • swoole_async_readfile — Read a file asynchronously
    • swoole_async_set — Update the async I/O options
    • swoole_async_write — Write data to a file stream asynchronously
    • swoole_async_writefile — Write data to a file asynchronously
    • swoole_client_select — Get the file description which are ready to read/write or error
    • swoole_cpu_num — Get the number of CPU
    • swoole_errno — Get the error code of the latest system call
    • swoole_event_add — Add new callback functions of a socket into the EventLoop
    • swoole_event_defer — Add callback function to the next event loop
    • swoole_event_del — Remove all event callback functions of a socket
    • swoole_event_exit — Exit the eventloop, only available at the client side
    • swoole_event_set — Update the event callback functions of a socket
    • swoole_event_wait — Start the event loop
    • swoole_event_write — Write data to a socket
    • swoole_get_local_ip — Get the IPv4 IP addresses of each NIC on the machine
    • swoole_last_error — Get the lastest error message
    • swoole_load_module — Load a swoole extension
    • swoole_select — Select the file descriptions which are ready to read/write or error in the eventloop
    • swoole_set_process_name — Set the process name
    • swoole_strerror — Convert the Errno into error messages
    • swoole_timer_after — Trigger a one time callback function in the future
    • swoole_timer_exists — Check if a timer callback function is existed
    • swoole_timer_tick — Trigger a timer tick callback function by time interval
    • swoole_version — Get the version of Swoole
  • Swoole\Async — The Swoole\Async class
    • Swoole\Async::dnsLookup — Async and non-blocking hostname to IP lookup.
    • Swoole\Async::read — Read file stream asynchronously.
    • Swoole\Async::readFile — Read a file asynchronously.
    • Swoole\Async::set — Update the async I/O options.
    • Swoole\Async::write — Write data to a file stream asynchronously.
    • Swoole\Async::writeFile — Description
  • Swoole\Atomic — The Swoole\Atomic class
    • Swoole\Atomic::add — Add a number to the value to the atomic object.
    • Swoole\Atomic::cmpset — Compare and set the value of the atomic object.
    • Swoole\Atomic::__construct — Construct a swoole atomic object.
    • Swoole\Atomic::get — Get the current value of the atomic object.
    • Swoole\Atomic::set — Set a new value to the atomic object.
    • Swoole\Atomic::sub — Subtract a number to the value of the atomic object.
  • Swoole\Buffer — The Swoole\Buffer class
    • Swoole\Buffer::append — Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.
    • Swoole\Buffer::clear — Reset the memory buffer.
    • Swoole\Buffer::__construct — Fixed size memory blocks allocation.
    • Swoole\Buffer::__destruct — Destruct the Swoole memory buffer.
    • Swoole\Buffer::expand — Expand the size of memory buffer.
    • Swoole\Buffer::read — Read data from the memory buffer based on offset and length.
    • Swoole\Buffer::recycle — Release the memory to OS which is not used by the memory buffer.
    • Swoole\Buffer::substr — Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.
    • Swoole\Buffer::__toString — Get the string value of the memory buffer.
    • Swoole\Buffer::write — Write data to the memory buffer. The memory allocated for the buffer will not be changed.
  • Swoole\Channel — The Swoole\Channel class
    • Swoole\Channel::__construct — Construct a Swoole Channel
    • Swoole\Channel::__destruct — Destruct a Swoole channel.
    • Swoole\Channel::pop — Read and pop data from swoole channel.
    • Swoole\Channel::push — Write and push data into Swoole channel.
    • Swoole\Channel::stats — Get stats of swoole channel.
  • Swoole\Client — The Swoole\Client class
    • Swoole\Client::close — Close the connection established.
    • Swoole\Client::connect — Connect to the remote TCP or UDP port.
    • Swoole\Client::__construct — Create Swoole sync or async TCP/UDP client, with or without SSL.
    • Swoole\Client::__destruct — Destruct the Swoole client.
    • Swoole\Client::getpeername — Get the remote socket name of the connection.
    • Swoole\Client::getsockname — Get the local socket name of the connection.
    • Swoole\Client::isConnected — Check if the connection is established.
    • Swoole\Client::on — Add callback functions triggered by events.
    • Swoole\Client::pause — Pause receiving data.
    • Swoole\Client::pipe — Redirect the data to another file descriptor.
    • Swoole\Client::recv — Receive data from the remote socket.
    • Swoole\Client::resume — Resume receiving data.
    • Swoole\Client::send — Send data to the remote TCP socket.
    • Swoole\Client::sendfile — Send file to the remote TCP socket.
    • Swoole\Client::sendto — Send data to the remote UDP address.
    • Swoole\Client::set — Set the Swoole client parameters before the connection is established.
    • Swoole\Client::sleep — Remove the TCP client from system event loop.
    • Swoole\Client::wakeup — Add the TCP client back into the system event loop.
  • Swoole\Connection\Iterator — The Swoole\Connection\Iterator class
    • Swoole\Connection\Iterator::count — Count connections.
    • Swoole\Connection\Iterator::current — Return current connection entry.
    • Swoole\Connection\Iterator::key — Return key of the current connection.
    • Swoole\Connection\Iterator::next — Move to the next connection.
    • Swoole\Connection\Iterator::offsetExists — Check if offet exists.
    • Swoole\Connection\Iterator::offsetGet — Offset to retrieve.
    • Swoole\Connection\Iterator::offsetSet — Assign a Connection to the specified offset.
    • Swoole\Connection\Iterator::offsetUnset — Unset an offset.
    • Swoole\Connection\Iterator::rewind — Rewinds iterator
    • Swoole\Connection\Iterator::valid — Check if current position is valid.
  • Swoole\Coroutine — The Swoole\Coroutine class
    • Swoole\Coroutine::call_user_func_array — Call a callback with an array of parameters
    • Swoole\Coroutine::call_user_func — Call a callback given by the first parameter
    • Swoole\Coroutine::cli_wait — Description
    • Swoole\Coroutine::create — Description
    • Swoole\Coroutine\Client::close — Description
    • Swoole\Coroutine\Client::connect — Description
    • Swoole\Coroutine\Client::__construct — Description
    • Swoole\Coroutine\Client::__destruct — Description
    • Swoole\Coroutine\Client::getpeername — Description
    • Swoole\Coroutine\Client::getsockname — Description
    • Swoole\Coroutine\Client::isConnected — Description
    • Swoole\Coroutine\Client::recv — Description
    • Swoole\Coroutine\Client::send — Description
    • Swoole\Coroutine\Client::sendfile — Description
    • Swoole\Coroutine\Client::sendto — Description
    • Swoole\Coroutine\Client::set — Description
    • Swoole\Coroutine\Http\Client::addFile — Description
    • Swoole\Coroutine\Http\Client::close — Description
    • Swoole\Coroutine\Http\Client::__construct — Description
    • Swoole\Coroutine\Http\Client::__destruct — Description
    • Swoole\Coroutine\Http\Client::execute — Description
    • Swoole\Coroutine\Http\Client::get — Description
    • Swoole\Coroutine\Http\Client::getDefer — Description
    • Swoole\Coroutine\Http\Client::isConnected — Description
    • Swoole\Coroutine\Http\Client::post — Description
    • Swoole\Coroutine\Http\Client::recv — Description
    • Swoole\Coroutine\Http\Client::set — Description
    • Swoole\Coroutine\Http\Client::setCookies — Description
    • Swoole\Coroutine\Http\Client::setData — Description
    • Swoole\Coroutine\Http\Client::setDefer — Description
    • Swoole\Coroutine\Http\Client::setHeaders — Description
    • Swoole\Coroutine\Http\Client::setMethod — Description
    • Swoole\Coroutine\MySQL::close — Description
    • Swoole\Coroutine\MySQL::connect — Description
    • Swoole\Coroutine\MySQL::__construct — Description
    • Swoole\Coroutine\MySQL::__destruct — Description
    • Swoole\Coroutine\MySQL::getDefer — Description
    • Swoole\Coroutine\MySQL::query — Description
    • Swoole\Coroutine\MySQL::recv — Description
    • Swoole\Coroutine\MySQL::setDefer — Description
    • Swoole\Coroutine::getuid — Description
    • Swoole\Coroutine::resume — Description
    • Swoole\Coroutine::suspend — Description
  • Swoole\Event — The Swoole\Event class
    • Swoole\Event::add — Add new callback functions of a socket into the EventLoop.
    • Swoole\Event::defer — Add a callback function to the next event loop.
    • Swoole\Event::del — Remove all event callback functions of a socket.
    • Swoole\Event::exit — Exit the eventloop, only available at client side.
    • Swoole\Event::set — Update the event callback functions of a socket.
    • Swoole\Event::wait — Description
    • Swoole\Event::write — Write data to the socket.
  • Swoole\Exception — The Swoole\Exception class
  • Swoole\Http\Client — The Swoole\Http\Client class
    • Swoole\Http\Client::addFile — Add a file to the post form.
    • Swoole\Http\Client::close — Close the http connection.
    • Swoole\Http\Client::__construct — Construct the async HTTP client.
    • Swoole\Http\Client::__destruct — Destruct the HTTP client.
    • Swoole\Http\Client::download — Download a file from the remote server.
    • Swoole\Http\Client::execute — Send the HTTP request after setting the parameters.
    • Swoole\Http\Client::get — Send GET http request to the remote server.
    • Swoole\Http\Client::isConnected — Check if the HTTP connection is connected.
    • Swoole\Http\Client::on — Register callback function by event name.
    • Swoole\Http\Client::post — Send POST http request to the remote server.
    • Swoole\Http\Client::push — Push data to websocket client.
    • Swoole\Http\Client::set — Update the HTTP client paramters.
    • Swoole\Http\Client::setCookies — Set the http request cookies.
    • Swoole\Http\Client::setData — Set the HTTP request body data.
    • Swoole\Http\Client::setHeaders — Set the HTTP request headers.
    • Swoole\Http\Client::setMethod — Set the HTTP request method.
    • Swoole\Http\Client::upgrade — Upgrade to websocket protocol.
  • Swoole\Http\Request — The Swoole\Http\Request class
    • Swoole\Http\Request::__destruct — Destruct the HTTP request.
    • Swoole\Http\Request::rawcontent — Get the raw HTTP POST body.
  • Swoole\Http\Response — The Swoole\Http\Response class
    • Swoole\Http\Response::cookie — Set the cookies of the HTTP response.
    • Swoole\Http\Response::__destruct — Destruct the HTTP response.
    • Swoole\Http\Response::end — Send data for the HTTP request and finish the response.
    • Swoole\Http\Response::gzip — Enable the gzip of response content.
    • Swoole\Http\Response::header — Set the HTTP response headers.
    • Swoole\Http\Response::initHeader — Init the HTTP response header.
    • Swoole\Http\Response::rawcookie — Set the raw cookies to the HTTP response.
    • Swoole\Http\Response::sendfile — Send file through the HTTP response.
    • Swoole\Http\Response::status — Set the status code of the HTTP response.
    • Swoole\Http\Response::write — Append HTTP body content to the HTTP response.
  • Swoole\Http\Server — The Swoole\Http\Server class
    • Swoole\Http\Server::on — Bind callback function to HTTP server by event name.
    • Swoole\Http\Server::start — Start the swoole http server.
  • Swoole\Lock — The Swoole\Lock class
    • Swoole\Lock::__construct — Construct a memory lock.
    • Swoole\Lock::__destruct — Destory a Swoole memory lock.
    • Swoole\Lock::lock_read — Lock a read-write lock for reading.
    • Swoole\Lock::lock — Try to acquire the lock. It will block if the lock is not available.
    • Swoole\Lock::trylock_read — Try to lock a read-write lock for reading and return straight away even the lock is not available.
    • Swoole\Lock::trylock — Try to acquire the lock and return straight away even the lock is not available.
    • Swoole\Lock::unlock — Release the lock.
  • Swoole\Mmap — The Swoole\Mmap class
    • Swoole\Mmap::open — Map a file into memory and return the stream resource which can be used by PHP stream operations.
  • Swoole\MySQL — The Swoole\MySQL class
    • Swoole\MySQL::close — Close the async MySQL connection.
    • Swoole\MySQL::connect — Connect to the remote MySQL server.
    • Swoole\MySQL::__construct — Construct an async MySQL client.
    • Swoole\MySQL::__destruct — Destory the async MySQL client.
    • Swoole\MySQL::getBuffer — Description
    • Swoole\MySQL::on — Register callback function based on event name.
    • Swoole\MySQL::query — Run the SQL query.
  • Swoole\MySQL\Exception — The Swoole\MySQL\Exception class
  • Swoole\Process — The Swoole\Process class
    • Swoole\Process::alarm — High precision timer which triggers signal with fixed interval.
    • Swoole\Process::close — Close the pipe to the child process.
    • Swoole\Process::__construct — Construct a process.
    • Swoole\Process::daemon — Change the process to be a daemon process.
    • Swoole\Process::__destruct — Destory the process.
    • Swoole\Process::exec — Execute system commands.
    • Swoole\Process::exit — Stop the child processes.
    • Swoole\Process::freeQueue — Destroy the message queue created by swoole_process::useQueue.
    • Swoole\Process::kill — Send signal to the child process.
    • Swoole\Process::name — Set name of the process.
    • Swoole\Process::pop — Read and pop data from the message queue.
    • Swoole\Process::push — Write and push data into the message queue.
    • Swoole\Process::read — Read data sending to the process.
    • Swoole\Process::signal — Send signal to the child processes.
    • Swoole\Process::start — Start the process.
    • Swoole\Process::statQueue — Get the stats of the message queue used as the communication method between processes.
    • Swoole\Process::useQueue — Create a message queue as the communication method between the parent process and child processes.
    • Swoole\Process::wait — Wait for the events of child processes.
    • Swoole\Process::write — Write data into the pipe and communicate with the parent process or child processes.
  • Swoole\Redis\Server — The Swoole\Redis\Server class
    • Swoole\Redis\Server::format — Description
    • Swoole\Redis\Server::setHandler — Description
    • Swoole\Redis\Server::start — Description
  • Swoole\Serialize — The Swoole\Serialize class
    • Swoole\Serialize::pack — Serialize the data.
    • Swoole\Serialize::unpack — Unserialize the data.
  • Swoole\Server — The Swoole\Server class
    • Swoole\Server::addlistener — Add a new listener to the server.
    • Swoole\Server::addProcess — Add a user defined swoole_process to the server.
    • Swoole\Server::after — Trigger a callback function after a period of time.
    • Swoole\Server::bind — Bind the connection to a user defined user ID.
    • Swoole\Server::clearTimer — Stop and destory a timer.
    • Swoole\Server::close — Close a connection to the client.
    • Swoole\Server::confirm — Check status of the connection.
    • Swoole\Server::connection_info — Get the connection info by file description.
    • Swoole\Server::connection_list — Get all of the established connections.
    • Swoole\Server::__construct — Construct a Swoole server.
    • Swoole\Server::defer — Delay execution of the callback function at the end of current EventLoop.
    • Swoole\Server\Port::__construct — Construct a server port
    • Swoole\Server\Port::__destruct — Destory server port
    • Swoole\Server\Port::on — Register callback functions by event.
    • Swoole\Server\Port::set — Set protocol of the server port.
    • Swoole\Server::exist — Check if the connection is existed.
    • Swoole\Server::finish — Used in task process for sending result to the worker process when the task is finished.
    • Swoole\Server::getClientInfo — Get the connection info by file description.
    • Swoole\Server::getClientList — Get all of the established connections.
    • Swoole\Server::getLastError — Get the error code of the most recent error.
    • Swoole\Server::heartbeat — Check all the connections on the server.
    • Swoole\Server::listen — Listen on the given IP and port, socket type.
    • Swoole\Server::on — Register a callback function by event name.
    • Swoole\Server::pause — Stop receiving data from the connection.
    • Swoole\Server::protect — Set the connection to be protected mode.
    • Swoole\Server::reload — Restart all the worker process.
    • Swoole\Server::resume — Start receving data from the connection.
    • Swoole\Server::send — Send data to the client.
    • Swoole\Server::sendfile — Send file to the connection.
    • Swoole\Server::sendMessage — Send message to worker processes by ID.
    • Swoole\Server::sendto — Send data to the remote UDP address.
    • Swoole\Server::sendwait — Send data to the remote socket in the blocking way.
    • Swoole\Server::set — Set the runtime settings of the swoole server.
    • Swoole\Server::shutdown — Shutdown the master server process, this function can be called in worker processes.
    • Swoole\Server::start — Start the Swoole server.
    • Swoole\Server::stats — Get the stats of the Swoole server.
    • Swoole\Server::stop — Stop the Swoole server.
    • Swoole\Server::task — Send data to the task worker processes.
    • Swoole\Server::taskwait — Send data to the task worker processes in blocking way.
    • Swoole\Server::taskWaitMulti — Execute multiple tasks concurrently.
    • Swoole\Server::tick — Repeats a given function at every given time-interval.
  • Swoole\Table — The Swoole\Table class
    • Swoole\Table::column — Set the data type and size of the columns.
    • Swoole\Table::__construct — Construct a Swoole memory table with fixed size.
    • Swoole\Table::count — Count the rows in the table, or count all the elements in the table if $mode = 1.
    • Swoole\Table::create — Create the swoole memory table.
    • Swoole\Table::current — Get the current row.
    • Swoole\Table::decr — Decrement the value in the Swoole table by $row_key and $column_key.
    • Swoole\Table::del — Delete a row in the Swoole table by $row_key.
    • Swoole\Table::destroy — Destroy the Swoole table.
    • Swoole\Table::exist — Check if a row is existed by $row_key.
    • Swoole\Table::get — Get the value in the Swoole table by $row_key and $column_key.
    • Swoole\Table::incr — Increment the value by $row_key and $column_key.
    • Swoole\Table::key — Get the key of current row.
    • Swoole\Table::next — Iterator the next row.
    • Swoole\Table::rewind — Rewind the iterator.
    • Swoole\Table::set — Update a row of the table by $row_key.
    • Swoole\Table::valid — Check current if the current row is valid.
  • Swoole\Timer — The Swoole\Timer class
    • Swoole\Timer::after — Trigger a callback function after a period of time.
    • Swoole\Timer::clear — Delete a timer by timer ID.
    • Swoole\Timer::exists — Check if a timer is existed.
    • Swoole\Timer::tick — Repeats a given function at every given time-interval.
  • Swoole\WebSocket\Frame — The Swoole\WebSocket\Frame class
  • Swoole\WebSocket\Server — The Swoole\WebSocket\Server class
    • Swoole\WebSocket\Server::exist — Check if the file descriptor exists.
    • Swoole\WebSocket\Server::on — Register event callback function
    • Swoole\WebSocket\Server::pack — Get a pack of binary data to send in a single frame.
    • Swoole\WebSocket\Server::push — Push data to the remote client.
    • Swoole\WebSocket\Server::unpack — Unpack the binary data received from the client.


简介

Swoole is a high-performance networking framework using an event-driven, asynchronous, non-blocking I/O model. It can be used to develop high-performance, scalable, concurrent TCP, UDP, Unix socket, HTTP, Websocket services. To get started, please check the » Swoole Docs.

Note: 此扩展在 Windows 平台上不可用。


安装

Use --with-swoole[=DIR] when compiling PHP.

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/swoole


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Swoole 配置选项
名字 | 默认 | 可修改范围 | 更新日志
swoole.aio_thread_num | 2 | PHP_INI_ALL |
swoole.display_errors | On | PHP_INI_ALL |
swoole.fast_serialize | Off | PHP_INI_ALL |
swoole.unixsock_buffer_size | 8388608 | PHP_INI_ALL |
swoole.use_namespace | On | PHP_INI_SYSTEM |

这是配置指令的简短说明。

swoole.aio_thread_num int

POSIX asynchronous I/O thread number

swoole.display_errors string

This determines whether Swoole errors should be printed to the screen.

swoole.fast_serialize string

Whether to enable Swoole fast_serialize.

swoole.unixsock_buffer_size int

Buffer size of Unix socket.

swoole.use_namespace string

Whether to use PHP namespaces


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SWOOLE_BASE (int)
SWOOLE_THREAD (int)
SWOOLE_PROCESS (int)
SWOOLE_IPC_UNSOCK (int)
SWOOLE_IPC_MSGQUEUE (int)
SWOOLE_IPC_PREEMPTIVE (int)
SWOOLE_SOCK_TCP (int)
SWOOLE_SOCK_TCP6 (int)
SWOOLE_SOCK_UDP (int)
SWOOLE_SOCK_UDP6 (int)
SWOOLE_SOCK_UNIX_DGRAM (int)
SWOOLE_SOCK_UNIX_STREAM (int)
SWOOLE_TCP (int)
SWOOLE_TCP6 (int)
SWOOLE_UDP (int)
SWOOLE_UDP6 (int)
SWOOLE_UNIX_DGRAM (int)
SWOOLE_UNIX_STREAM (int)
SWOOLE_SOCK_SYNC (int)
SWOOLE_SOCK_ASYNC (int)
SWOOLE_SYNC (int)
SWOOLE_ASYNC (int)
SWOOLE_KEEP (int)
SWOOLE_EVENT_READ (int)
SWOOLE_EVENT_WRITE (int)
SWOOLE_VERSION (string)
SWOOLE_AIO_BASE (int)
SWOOLE_AIO_LINUX (int)
SWOOLE_FILELOCK (int)
SWOOLE_MUTEX (int)
SWOOLE_SEM (int)
SWOOLE_RWLOCK (int)
WEBSOCKET_OPCODE_TEXT (int)
WEBSOCKET_OPCODE_BINARY (int)
WEBSOCKET_OPCODE_PING (int)
WEBSOCKET_STATUS_CONNECTION (int)
WEBSOCKET_STATUS_HANDSHAKE (int)
WEBSOCKET_STATUS_FRAME (int)
WEBSOCKET_STATUS_ACTIVE (int)
SWOOLE_FAST_PACK (int)


Swoole 函数

Table of Contents

  • swoole_async_dns_lookup — Async and non-blocking hostname to IP lookup
  • swoole_async_read — Read file stream asynchronously
  • swoole_async_readfile — Read a file asynchronously
  • swoole_async_set — Update the async I/O options
  • swoole_async_write — Write data to a file stream asynchronously
  • swoole_async_writefile — Write data to a file asynchronously
  • swoole_client_select — Get the file description which are ready to read/write or error
  • swoole_cpu_num — Get the number of CPU
  • swoole_errno — Get the error code of the latest system call
  • swoole_event_add — Add new callback functions of a socket into the EventLoop
  • swoole_event_defer — Add callback function to the next event loop
  • swoole_event_del — Remove all event callback functions of a socket
  • swoole_event_exit — Exit the eventloop, only available at the client side
  • swoole_event_set — Update the event callback functions of a socket
  • swoole_event_wait — Start the event loop
  • swoole_event_write — Write data to a socket
  • swoole_get_local_ip — Get the IPv4 IP addresses of each NIC on the machine
  • swoole_last_error — Get the lastest error message
  • swoole_load_module — Load a swoole extension
  • swoole_select — Select the file descriptions which are ready to read/write or error in the eventloop
  • swoole_set_process_name — Set the process name
  • swoole_strerror — Convert the Errno into error messages
  • swoole_timer_after — Trigger a one time callback function in the future
  • swoole_timer_exists — Check if a timer callback function is existed
  • swoole_timer_tick — Trigger a timer tick callback function by time interval
  • swoole_version — Get the version of Swoole


Async and non-blocking hostname to IP lookup

  • ? Swoole 函数
  • swoole_async_read ?
  • PHP Manual
  • Swoole 函数
  • Async and non-blocking hostname to IP lookup

swoole_async_dns_lookup

(PECL swoole >= 1.9.0)

swoole_async_dns_lookup — Async and non-blocking hostname to IP lookup

说明

swoole_async_dns_lookup ( string $hostname , callable $callback ) : bool

参数

hostname

The host name.

callback
callback ( string $hostname , string $ip ) : mixed
hostname

The host name.

IP

The IP address.

返回值

成功时返回 true， 或者在失败时返回 false。


Read file stream asynchronously

  • ? swoole_async_dns_lookup
  • swoole_async_readfile ?
  • PHP Manual
  • Swoole 函数
  • Read file stream asynchronously

swoole_async_read

(PECL swoole >= 1.9.0)

swoole_async_read — Read file stream asynchronously

说明

swoole_async_read ( string $filename , callable $callback , int $chunk_size = 65536 , int $offset = 0 ) : bool

参数

filename

The filename of the file being read.

callback
callback ( string $filename , string $content ) : mixed
filename

The name of the file.

content

The content readed from the file stream.

chunk_size

The chunk length.

offset

The offset.

返回值

Whether the read is succeed.


Read a file asynchronously

  • ? swoole_async_read
  • swoole_async_set ?
  • PHP Manual
  • Swoole 函数
  • Read a file asynchronously

swoole_async_readfile

(PECL swoole >= 1.9.0)

swoole_async_readfile — Read a file asynchronously

说明

swoole_async_readfile ( string $filename , callable $callback ) : bool

参数

filename

The filename of the file being read.

callback
callback ( string $filename , string $content ) : mixed
filename

The name of the file.

content

The content readed from the file.

返回值

成功时返回 true， 或者在失败时返回 false。


Update the async I/O options

  • ? swoole_async_readfile
  • swoole_async_write ?
  • PHP Manual
  • Swoole 函数
  • Update the async I/O options

swoole_async_set

(PECL swoole >= 1.9.0)

swoole_async_set — Update the async I/O options

说明

swoole_async_set ( array $settings ) : void

参数

settings


Write data to a file stream asynchronously

  • ? swoole_async_set
  • swoole_async_writefile ?
  • PHP Manual
  • Swoole 函数
  • Write data to a file stream asynchronously

swoole_async_write

(PECL swoole >= 1.9.0)

swoole_async_write — Write data to a file stream asynchronously

说明

swoole_async_write ( string $filename , string $content , int $offset = ? , callable $callback = ? ) : bool

参数

filename

The filename being written.

content

The content writing to the file.

offset

The offset.

callback

返回值

成功时返回 true， 或者在失败时返回 false。


Write data to a file asynchronously

  • ? swoole_async_write
  • swoole_client_select ?
  • PHP Manual
  • Swoole 函数
  • Write data to a file asynchronously

swoole_async_writefile

(PECL swoole >= 1.9.0)

swoole_async_writefile — Write data to a file asynchronously

说明

swoole_async_writefile ( string $filename , string $content , callable $callback = ? , int $flags = 0 ) : bool

参数

filename

The filename being written.

content

The content writing to the file.

callback

flags

返回值

成功时返回 true， 或者在失败时返回 false。


Get the file description which are ready to read/write or error

  • ? swoole_async_writefile
  • swoole_cpu_num ?
  • PHP Manual
  • Swoole 函数
  • Get the file description which are ready to read/write or error

swoole_client_select

(PECL swoole >= 1.9.0)

swoole_client_select — Get the file description which are ready to read/write or error

说明

swoole_client_select ( array &$read_array , array &$write_array , array &$error_array , float $timeout = 0.5 ) : int

参数

read_array

write_array

error_array

timeout

返回值


Get the number of CPU

  • ? swoole_client_select
  • swoole_errno ?
  • PHP Manual
  • Swoole 函数
  • Get the number of CPU

swoole_cpu_num

(PECL swoole >= 1.9.0)

swoole_cpu_num — Get the number of CPU

说明

swoole_cpu_num ( ) : int

参数

此函数没有参数。

返回值

The number of CPU.


Get the error code of the latest system call

  • ? swoole_cpu_num
  • swoole_event_add ?
  • PHP Manual
  • Swoole 函数
  • Get the error code of the latest system call

swoole_errno

(PECL swoole >= 1.9.0)

swoole_errno — Get the error code of the latest system call

说明

swoole_errno ( ) : int

参数

此函数没有参数。

返回值


Add new callback functions of a socket into the EventLoop

  • ? swoole_errno
  • swoole_event_defer ?
  • PHP Manual
  • Swoole 函数
  • Add new callback functions of a socket into the EventLoop

swoole_event_add

(PECL swoole >= 1.9.0)

swoole_event_add — Add new callback functions of a socket into the EventLoop

说明

swoole_event_add ( int $fd , callable $read_callback = ? , callable $write_callback = ? , int $events = 0 ) : int

参数

fd

read_callback

write_callback

events

返回值


Add callback function to the next event loop

  • ? swoole_event_add
  • swoole_event_del ?
  • PHP Manual
  • Swoole 函数
  • Add callback function to the next event loop

swoole_event_defer

(PECL swoole >= 1.9.0)

swoole_event_defer — Add callback function to the next event loop

说明

swoole_event_defer ( callable $callback ) : bool

参数

callback

返回值

成功时返回 true， 或者在失败时返回 false。


Remove all event callback functions of a socket

  • ? swoole_event_defer
  • swoole_event_exit ?
  • PHP Manual
  • Swoole 函数
  • Remove all event callback functions of a socket

swoole_event_del

(PECL swoole >= 1.9.0)

swoole_event_del — Remove all event callback functions of a socket

说明

swoole_event_del ( int $fd ) : bool

参数

fd

返回值

成功时返回 true， 或者在失败时返回 false。


Exit the eventloop, only available at the client side

  • ? swoole_event_del
  • swoole_event_set ?
  • PHP Manual
  • Swoole 函数
  • Exit the eventloop, only available at the client side

swoole_event_exit

(PECL swoole >= 1.9.0)

swoole_event_exit — Exit the eventloop, only available at the client side

说明

swoole_event_exit ( ) : void

参数

此函数没有参数。

返回值


Update the event callback functions of a socket

  • ? swoole_event_exit
  • swoole_event_wait ?
  • PHP Manual
  • Swoole 函数
  • Update the event callback functions of a socket

swoole_event_set

(PECL swoole >= 1.9.0)

swoole_event_set — Update the event callback functions of a socket

说明

swoole_event_set ( int $fd , callable $read_callback = ? , callable $write_callback = ? , int $events = 0 ) : bool

参数

fd

read_callback

write_callback

events

返回值


Start the event loop

  • ? swoole_event_set
  • swoole_event_write ?
  • PHP Manual
  • Swoole 函数
  • Start the event loop

swoole_event_wait

(PECL swoole >= 1.9.0)

swoole_event_wait — Start the event loop

说明

swoole_event_wait ( ) : void

参数

此函数没有参数。

返回值


Write data to a socket

  • ? swoole_event_wait
  • swoole_get_local_ip ?
  • PHP Manual
  • Swoole 函数
  • Write data to a socket

swoole_event_write

(PECL swoole >= 1.9.0)

swoole_event_write — Write data to a socket

说明

swoole_event_write ( int $fd , string $data ) : bool

参数

fd

data

返回值

成功时返回 true， 或者在失败时返回 false。


Get the IPv4 IP addresses of each NIC on the machine

  • ? swoole_event_write
  • swoole_last_error ?
  • PHP Manual
  • Swoole 函数
  • Get the IPv4 IP addresses of each NIC on the machine

swoole_get_local_ip

(PECL swoole >= 1.9.0)

swoole_get_local_ip — Get the IPv4 IP addresses of each NIC on the machine

说明

swoole_get_local_ip ( ) : array

参数

此函数没有参数。

返回值


Get the lastest error message

  • ? swoole_get_local_ip
  • swoole_load_module ?
  • PHP Manual
  • Swoole 函数
  • Get the lastest error message

swoole_last_error

(PECL swoole >= 1.9.0)

swoole_last_error — Get the lastest error message

说明

swoole_last_error ( ) : int

参数

此函数没有参数。

返回值


Load a swoole extension

  • ? swoole_last_error
  • swoole_select ?
  • PHP Manual
  • Swoole 函数
  • Load a swoole extension

swoole_load_module

(PECL swoole >= 1.9.0)

swoole_load_module — Load a swoole extension

说明

swoole_load_module ( string $filename ) : mixed

参数

此函数没有参数。

返回值


Select the file descriptions which are ready to read/write or error in the eventloop

  • ? swoole_load_module
  • swoole_set_process_name ?
  • PHP Manual
  • Swoole 函数
  • Select the file descriptions which are ready to read/write or error in the eventloop

swoole_select

(PECL swoole >= 1.9.0)

swoole_select — Select the file descriptions which are ready to read/write or error in the eventloop

说明

swoole_select ( array &$read_array , array &$write_array , array &$error_array , float $timeout = ? ) : int

参数

read_array

write_array

error_array

timeout

返回值


Set the process name

  • ? swoole_select
  • swoole_strerror ?
  • PHP Manual
  • Swoole 函数
  • Set the process name

swoole_set_process_name

(PECL swoole >= 1.9.0)

swoole_set_process_name — Set the process name

说明

swoole_set_process_name ( string $process_name , int $size = 128 ) : void

参数

process_name

返回值


Convert the Errno into error messages

  • ? swoole_set_process_name
  • swoole_timer_after ?
  • PHP Manual
  • Swoole 函数
  • Convert the Errno into error messages

swoole_strerror

(PECL swoole >= 1.9.0)

swoole_strerror — Convert the Errno into error messages

说明

swoole_strerror ( int $errno , int $error_type = 0 ) : string

参数

errno

返回值


Trigger a one time callback function in the future

  • ? swoole_strerror
  • swoole_timer_exists ?
  • PHP Manual
  • Swoole 函数
  • Trigger a one time callback function in the future

swoole_timer_after

(PECL swoole >= 1.9.0)

swoole_timer_after — Trigger a one time callback function in the future

说明

swoole_timer_after ( int $ms , callable $callback , mixed $param = ? ) : int

参数

ms

callback

param

返回值


Check if a timer callback function is existed

  • ? swoole_timer_after
  • swoole_timer_tick ?
  • PHP Manual
  • Swoole 函数
  • Check if a timer callback function is existed

swoole_timer_exists

(PECL swoole >= 1.9.0)

swoole_timer_exists — Check if a timer callback function is existed

说明

swoole_timer_exists ( int $timer_id ) : bool

参数

timer_id

返回值


Trigger a timer tick callback function by time interval

  • ? swoole_timer_exists
  • swoole_version ?
  • PHP Manual
  • Swoole 函数
  • Trigger a timer tick callback function by time interval

swoole_timer_tick

(PECL swoole >= 1.9.0)

swoole_timer_tick — Trigger a timer tick callback function by time interval

说明

swoole_timer_tick ( int $ms , callable $callback , mixed $param = ? ) : int

参数

ms

callback

返回值


Get the version of Swoole

  • ? swoole_timer_tick
  • Swoole\Async ?
  • PHP Manual
  • Swoole 函数
  • Get the version of Swoole

swoole_version

(PECL swoole >= 1.9.0)

swoole_version — Get the version of Swoole

说明

swoole_version ( ) : string

参数

此函数没有参数。

返回值

The version of Swoole.


The Swoole\Async class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Async {
/* 方法 */
public static dnsLookup ( string $hostname , callable $callback ) : void
public static read ( string $filename , callable $callback , int $chunk_size = ? , int $offset = ? ) : bool
public static readFile ( string $filename , callable $callback ) : void
public static set ( array $settings ) : void
public static write ( string $filename , string $content , int $offset = ? , callable $callback = ? ) : void
public static writeFile ( string $filename , string $content , callable $callback = ? , string $flags = ? ) : void
}

Table of Contents

  • Swoole\Async::dnsLookup — Async and non-blocking hostname to IP lookup.
  • Swoole\Async::read — Read file stream asynchronously.
  • Swoole\Async::readFile — Read a file asynchronously.
  • Swoole\Async::set — Update the async I/O options.
  • Swoole\Async::write — Write data to a file stream asynchronously.
  • Swoole\Async::writeFile — Description


Async and non-blocking hostname to IP lookup.

  • ? Swoole\Async
  • Swoole\Async::read ?
  • PHP Manual
  • Swoole\Async
  • Async and non-blocking hostname to IP lookup.

Swoole\Async::dnsLookup

(PECL swoole >= 1.9.0)

Swoole\Async::dnsLookup — Async and non-blocking hostname to IP lookup.

说明

public static Swoole\Async::dnsLookup ( string $hostname , callable $callback ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

hostname

The host name.

callback
callback ( string $hostname , string $ip ) : mixed
hostname

The host name.

IP

The IP address.


Read file stream asynchronously.

  • ? Swoole\Async::dnsLookup
  • Swoole\Async::readFile ?
  • PHP Manual
  • Swoole\Async
  • Read file stream asynchronously.

Swoole\Async::read

(PECL swoole >= 1.9.0)

Swoole\Async::read — Read file stream asynchronously.

说明

public static Swoole\Async::read ( string $filename , callable $callback , int $chunk_size = ? , int $offset = ? ) : bool

参数

filename

The name of the file.

callback
callback ( string $filename , string $content ) : mixed
filename

The name of the file.

content

The content readed from the file stream.

chunk_size

The chunk length.

offset

The offset.

返回值

Whether the read is succeed.


Read a file asynchronously.

  • ? Swoole\Async::read
  • Swoole\Async::set ?
  • PHP Manual
  • Swoole\Async
  • Read a file asynchronously.

Swoole\Async::readFile

(PECL swoole >= 1.9.0)

Swoole\Async::readFile — Read a file asynchronously.

说明

public static Swoole\Async::readFile ( string $filename , callable $callback ) : void

参数

filename

The filename of the file being read.

callback
callback ( string $filename , string $content ) : mixed
filename

The name of the file.

content

The content readed from the file.


Update the async I/O options.

  • ? Swoole\Async::readFile
  • Swoole\Async::write ?
  • PHP Manual
  • Swoole\Async
  • Update the async I/O options.

Swoole\Async::set

(PECL swoole >= 1.9.0)

Swoole\Async::set — Update the async I/O options.

说明

public static Swoole\Async::set ( array $settings ) : void

参数

settings


Write data to a file stream asynchronously.

  • ? Swoole\Async::set
  • Swoole\Async::writeFile ?
  • PHP Manual
  • Swoole\Async
  • Write data to a file stream asynchronously.

Swoole\Async::write

(PECL swoole >= 1.9.0)

Swoole\Async::write — Write data to a file stream asynchronously.

说明

public static Swoole\Async::write ( string $filename , string $content , int $offset = ? , callable $callback = ? ) : void

参数

filename

The filename being written.

content

The content writing to the file.

offset

The offset.

callback


Description

  • ? Swoole\Async::write
  • Swoole\Atomic ?
  • PHP Manual
  • Swoole\Async
  • Description

Swoole\Async::writeFile

(PECL swoole >= 1.9.0)

Swoole\Async::writeFile — Description

说明

public static Swoole\Async::writeFile ( string $filename , string $content , callable $callback = ? , string $flags = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

filename

The filename being written.

content

The content writing to the file.

callback

flags


The Swoole\Atomic class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Atomic {
/* 方法 */
public add ( int $add_value = ? ) : int
public cmpset ( int $cmp_value , int $new_value ) : int
public get ( ) : int
public set ( int $value ) : int
public sub ( int $sub_value = ? ) : int
}

Table of Contents

  • Swoole\Atomic::add — Add a number to the value to the atomic object.
  • Swoole\Atomic::cmpset — Compare and set the value of the atomic object.
  • Swoole\Atomic::__construct — Construct a swoole atomic object.
  • Swoole\Atomic::get — Get the current value of the atomic object.
  • Swoole\Atomic::set — Set a new value to the atomic object.
  • Swoole\Atomic::sub — Subtract a number to the value of the atomic object.


Add a number to the value to the atomic object.

  • ? Swoole\Atomic
  • Swoole\Atomic::cmpset ?
  • PHP Manual
  • Swoole\Atomic
  • Add a number to the value to the atomic object.

Swoole\Atomic::add

(PECL swoole >= 1.9.0)

Swoole\Atomic::add — Add a number to the value to the atomic object.

说明

public Swoole\Atomic::add ( int $add_value = ? ) : int

Add a number to the value to the atomic object.

参数

add_value

The value which will be added to the current value.

返回值

The new value of the atomic object.


Compare and set the value of the atomic object.

  • ? Swoole\Atomic::add
  • Swoole\Atomic::__construct ?
  • PHP Manual
  • Swoole\Atomic
  • Compare and set the value of the atomic object.

Swoole\Atomic::cmpset

(PECL swoole >= 1.9.0)

Swoole\Atomic::cmpset — Compare and set the value of the atomic object.

说明

public Swoole\Atomic::cmpset ( int $cmp_value , int $new_value ) : int

参数

cmp_value

The value to compare with the current value of the atomic object.

new_value

The value to set to the atomic object if the cmp_value is the same as the current value of the atomic object.

返回值

The new value of the atomic object.


Construct a swoole atomic object.

  • ? Swoole\Atomic::cmpset
  • Swoole\Atomic::get ?
  • PHP Manual
  • Swoole\Atomic
  • Construct a swoole atomic object.

Swoole\Atomic::__construct

(PECL swoole >= 1.9.0)

Swoole\Atomic::__construct — Construct a swoole atomic object.

说明

public Swoole\Atomic::__construct ( int $value = ? )

Swoole atomic object is a integer variable allows any processor to atomically test and modify. It is implemented based on CPU atomic instructions. The Swoole atomic variables have to defined before swoole_server->start.

Compare-and-swap (CAS) is an atomic instruction used in multithreading to achieve synchronization. It compares the content of a memory location with a given value and, only if they are the same, modifies the content of that memory location to a new given value.

参数

value

The value of the atomic object.


Get the current value of the atomic object.

  • ? Swoole\Atomic::__construct
  • Swoole\Atomic::set ?
  • PHP Manual
  • Swoole\Atomic
  • Get the current value of the atomic object.

Swoole\Atomic::get

(PECL swoole >= 1.9.0)

Swoole\Atomic::get — Get the current value of the atomic object.

说明

public Swoole\Atomic::get ( ) : int

Get the current value of the atomic object.

参数

此函数没有参数。

返回值

The current value of the atomic object.


Set a new value to the atomic object.

  • ? Swoole\Atomic::get
  • Swoole\Atomic::sub ?
  • PHP Manual
  • Swoole\Atomic
  • Set a new value to the atomic object.

Swoole\Atomic::set

(PECL swoole >= 1.9.0)

Swoole\Atomic::set — Set a new value to the atomic object.

说明

public Swoole\Atomic::set ( int $value ) : int

Set a new value to the atomic object.

Warning

本函数还未编写文档，仅有参数列表。

参数

value

The value to set to the atomic object.

返回值

The current value of the atomic object.


Subtract a number to the value of the atomic object.

  • ? Swoole\Atomic::set
  • Swoole\Buffer ?
  • PHP Manual
  • Swoole\Atomic
  • Subtract a number to the value of the atomic object.

Swoole\Atomic::sub

(PECL swoole >= 1.9.0)

Swoole\Atomic::sub — Subtract a number to the value of the atomic object.

说明

public Swoole\Atomic::sub ( int $sub_value = ? ) : int

Subtract a number to the value of the atomic object.

参数

sub_value

The value which will be subtracted to the current value.

返回值

The current value of the atomic object.


The Swoole\Buffer class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Buffer {
/* 方法 */
public append ( string $data ) : int
public clear ( ) : void
public __destruct ( ) : void
public expand ( int $size ) : int
public read ( int $offset , int $length ) : string
public recycle ( ) : void
public substr ( int $offset , int $length = ? , bool $remove = ? ) : string
public __toString ( ) : string
public write ( int $offset , string $data ) : void
}

Table of Contents

  • Swoole\Buffer::append — Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.
  • Swoole\Buffer::clear — Reset the memory buffer.
  • Swoole\Buffer::__construct — Fixed size memory blocks allocation.
  • Swoole\Buffer::__destruct — Destruct the Swoole memory buffer.
  • Swoole\Buffer::expand — Expand the size of memory buffer.
  • Swoole\Buffer::read — Read data from the memory buffer based on offset and length.
  • Swoole\Buffer::recycle — Release the memory to OS which is not used by the memory buffer.
  • Swoole\Buffer::substr — Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.
  • Swoole\Buffer::__toString — Get the string value of the memory buffer.
  • Swoole\Buffer::write — Write data to the memory buffer. The memory allocated for the buffer will not be changed.


Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.

  • ? Swoole\Buffer
  • Swoole\Buffer::clear ?
  • PHP Manual
  • Swoole\Buffer
  • Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.

Swoole\Buffer::append

(PECL swoole >= 1.9.0)

Swoole\Buffer::append — Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.

说明

public Swoole\Buffer::append ( string $data ) : int

参数

data

The string or binary data to append at the end of the memory buffer.

返回值

The new size of the memory buffer.


Reset the memory buffer.

  • ? Swoole\Buffer::append
  • Swoole\Buffer::__construct ?
  • PHP Manual
  • Swoole\Buffer
  • Reset the memory buffer.

Swoole\Buffer::clear

(PECL swoole >= 1.9.0)

Swoole\Buffer::clear — Reset the memory buffer.

说明

public Swoole\Buffer::clear ( ) : void

参数

此函数没有参数。


Fixed size memory blocks allocation.

  • ? Swoole\Buffer::clear
  • Swoole\Buffer::__destruct ?
  • PHP Manual
  • Swoole\Buffer
  • Fixed size memory blocks allocation.

Swoole\Buffer::__construct

(PECL swoole >= 1.9.0)

Swoole\Buffer::__construct — Fixed size memory blocks allocation.

说明

public Swoole\Buffer::__construct ( int $size = ? )

参数

size

The size of the memory to allocate.


Destruct the Swoole memory buffer.

  • ? Swoole\Buffer::__construct
  • Swoole\Buffer::expand ?
  • PHP Manual
  • Swoole\Buffer
  • Destruct the Swoole memory buffer.

Swoole\Buffer::__destruct

(PECL swoole >= 1.9.0)

Swoole\Buffer::__destruct — Destruct the Swoole memory buffer.

说明

public Swoole\Buffer::__destruct ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。


Expand the size of memory buffer.

  • ? Swoole\Buffer::__destruct
  • Swoole\Buffer::read ?
  • PHP Manual
  • Swoole\Buffer
  • Expand the size of memory buffer.

Swoole\Buffer::expand

(PECL swoole >= 1.9.0)

Swoole\Buffer::expand — Expand the size of memory buffer.

说明

public Swoole\Buffer::expand ( int $size ) : int

参数

size

The new size of the memory buffer.

返回值

The new size of the memory buffer.


Read data from the memory buffer based on offset and length.

  • ? Swoole\Buffer::expand
  • Swoole\Buffer::recycle ?
  • PHP Manual
  • Swoole\Buffer
  • Read data from the memory buffer based on offset and length.

Swoole\Buffer::read

(PECL swoole >= 1.9.0)

Swoole\Buffer::read — Read data from the memory buffer based on offset and length.

说明

public Swoole\Buffer::read ( int $offset , int $length ) : string

参数

offset

The offset.

length

The length.

返回值

The data readed from the memory buffer.


Release the memory to OS which is not used by the memory buffer.

  • ? Swoole\Buffer::read
  • Swoole\Buffer::substr ?
  • PHP Manual
  • Swoole\Buffer
  • Release the memory to OS which is not used by the memory buffer.

Swoole\Buffer::recycle

(PECL swoole >= 1.9.0)

Swoole\Buffer::recycle — Release the memory to OS which is not used by the memory buffer.

说明

public Swoole\Buffer::recycle ( ) : void

参数

此函数没有参数。


Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.

  • ? Swoole\Buffer::recycle
  • Swoole\Buffer::__toString ?
  • PHP Manual
  • Swoole\Buffer
  • Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.

Swoole\Buffer::substr

(PECL swoole >= 1.9.0)

Swoole\Buffer::substr — Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.

说明

public Swoole\Buffer::substr ( int $offset , int $length = ? , bool $remove = ? ) : string

If $remove is set to be true and $offset is set to be 0, the data will be removed from the buffer. The memory for storing the data will be released when the buffer object is deconstructed.

参数

offset

The offset.

length

The length.

remove

Whether to remove the data from the memory buffer.

返回值

The data or string readed from the memory buffer.


Get the string value of the memory buffer.

  • ? Swoole\Buffer::substr
  • Swoole\Buffer::write ?
  • PHP Manual
  • Swoole\Buffer
  • Get the string value of the memory buffer.

Swoole\Buffer::__toString

(PECL swoole >= 1.9.0)

Swoole\Buffer::__toString — Get the string value of the memory buffer.

说明

public Swoole\Buffer::__toString ( ) : string

参数

此函数没有参数。

返回值

The string value of the memory buffer.


Write data to the memory buffer. The memory allocated for the buffer will not be changed.

  • ? Swoole\Buffer::__toString
  • Swoole\Channel ?
  • PHP Manual
  • Swoole\Buffer
  • Write data to the memory buffer. The memory allocated for the buffer will not be changed.

Swoole\Buffer::write

(PECL swoole >= 1.9.0)

Swoole\Buffer::write — Write data to the memory buffer. The memory allocated for the buffer will not be changed.

说明

public Swoole\Buffer::write ( int $offset , string $data ) : void

参数

offset

The offset.

data

The data to write to the memory buffer.

返回值


The Swoole\Channel class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Channel {
/* 方法 */
public __destruct ( ) : void
public pop ( ) : mixed
public push ( string $data ) : bool
public stats ( ) : array
}

Table of Contents

  • Swoole\Channel::__construct — Construct a Swoole Channel
  • Swoole\Channel::__destruct — Destruct a Swoole channel.
  • Swoole\Channel::pop — Read and pop data from swoole channel.
  • Swoole\Channel::push — Write and push data into Swoole channel.
  • Swoole\Channel::stats — Get stats of swoole channel.


Construct a Swoole Channel

  • ? Swoole\Channel
  • Swoole\Channel::__destruct ?
  • PHP Manual
  • Swoole\Channel
  • Construct a Swoole Channel

Swoole\Channel::__construct

(PECL swoole >= 1.9.0)

Swoole\Channel::__construct — Construct a Swoole Channel

说明

public Swoole\Channel::__construct ( string $size )

Swoole channel is memory data structure works like Chan in Golang, implemented based on shared memory and mutex locks. It can be used as high performance message queue in memory. Construct a swoole channel with a fixed size. The minimum size of a swoole channel is 64KB. Exceptions will be thrown if there is not enough memory.

参数

size

The size of the Swoole channel.


Destruct a Swoole channel.

  • ? Swoole\Channel::__construct
  • Swoole\Channel::pop ?
  • PHP Manual
  • Swoole\Channel
  • Destruct a Swoole channel.

Swoole\Channel::__destruct

(PECL swoole >= 1.9.0)

Swoole\Channel::__destruct — Destruct a Swoole channel.

说明

public Swoole\Channel::__destruct ( ) : void

参数

此函数没有参数。


Read and pop data from swoole channel.

  • ? Swoole\Channel::__destruct
  • Swoole\Channel::push ?
  • PHP Manual
  • Swoole\Channel
  • Read and pop data from swoole channel.

Swoole\Channel::pop

(PECL swoole >= 1.9.0)

Swoole\Channel::pop — Read and pop data from swoole channel.

说明

public Swoole\Channel::pop ( ) : mixed

参数

此函数没有参数。

返回值

If the channel is empty, the function will return false, or return the unserialized data.


Write and push data into Swoole channel.

  • ? Swoole\Channel::pop
  • Swoole\Channel::stats ?
  • PHP Manual
  • Swoole\Channel
  • Write and push data into Swoole channel.

Swoole\Channel::push

(PECL swoole >= 1.9.0)

Swoole\Channel::push — Write and push data into Swoole channel.

说明

public Swoole\Channel::push ( string $data ) : bool

Data can be any non-empty PHP variable, the variable will be serialized if it is not string type.

If size of the data is more than 8KB, swoole channel will use temp files storage.

The function will return true if the write operation is succeeded, or return false if there is not enough space.

参数

data

The data to push into the Swoole channel.

返回值

Wheter the data is pushed into he Swoole channel.


Get stats of swoole channel.

  • ? Swoole\Channel::push
  • Swoole\Client ?
  • PHP Manual
  • Swoole\Channel
  • Get stats of swoole channel.

Swoole\Channel::stats

(PECL swoole >= 1.9.0)

Swoole\Channel::stats — Get stats of swoole channel.

说明

public Swoole\Channel::stats ( ) : array

Get the numbers of queued elements and total size of the memory used by the queue.

参数

此函数没有参数。

返回值

The stats of the Swoole channel.


The Swoole\Client class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Client {
/* Constants */
const int MSG_OOB = 1 ;
const int MSG_PEEK = 2 ;
const int MSG_DONTWAIT = 128 ;
const int MSG_WAITALL = 64 ;
/* 属性 */
public $errCode ;
public $sock ;
public $reuse ;
public $reuseCount ;
/* 方法 */
public close ( bool $force = ? ) : bool
public connect ( string $host , int $port = ? , int $timeout = ? , int $flag = ? ) : bool
public __destruct ( ) : void
public getpeername ( ) : array
public getsockname ( ) : array
public isConnected ( ) : bool
public on ( string $event , callable $callback ) : void
public pause ( ) : void
public pipe ( string $socket ) : void
public recv ( string $size = ? , string $flag = ? ) : void
public resume ( ) : void
public send ( string $data , string $flag = ? ) : int
public sendfile ( string $filename , int $offset = ? ) : bool
public sendto ( string $ip , int $port , string $data ) : bool
public set ( array $settings ) : void
public sleep ( ) : void
public wakeup ( ) : void
}

属性

errCode

sock

reuse

reuseCount

预定义常量

Swoole\Client::MSG_OOB

Swoole\Client::MSG_PEEK

Swoole\Client::MSG_DONTWAIT

Swoole\Client::MSG_WAITALL

Table of Contents

  • Swoole\Client::close — Close the connection established.
  • Swoole\Client::connect — Connect to the remote TCP or UDP port.
  • Swoole\Client::__construct — Create Swoole sync or async TCP/UDP client, with or without SSL.
  • Swoole\Client::__destruct — Destruct the Swoole client.
  • Swoole\Client::getpeername — Get the remote socket name of the connection.
  • Swoole\Client::getsockname — Get the local socket name of the connection.
  • Swoole\Client::isConnected — Check if the connection is established.
  • Swoole\Client::on — Add callback functions triggered by events.
  • Swoole\Client::pause — Pause receiving data.
  • Swoole\Client::pipe — Redirect the data to another file descriptor.
  • Swoole\Client::recv — Receive data from the remote socket.
  • Swoole\Client::resume — Resume receiving data.
  • Swoole\Client::send — Send data to the remote TCP socket.
  • Swoole\Client::sendfile — Send file to the remote TCP socket.
  • Swoole\Client::sendto — Send data to the remote UDP address.
  • Swoole\Client::set — Set the Swoole client parameters before the connection is established.
  • Swoole\Client::sleep — Remove the TCP client from system event loop.
  • Swoole\Client::wakeup — Add the TCP client back into the system event loop.


Close the connection established.

  • ? Swoole\Client
  • Swoole\Client::connect ?
  • PHP Manual
  • Swoole\Client
  • Close the connection established.

Swoole\Client::close

(PECL swoole >= 1.9.0)

Swoole\Client::close — Close the connection established.

说明

public Swoole\Client::close ( bool $force = ? ) : bool

参数

force

Whether force to close the connection.

返回值

Whether the connection is closed.


Connect to the remote TCP or UDP port.

  • ? Swoole\Client::close
  • Swoole\Client::__construct ?
  • PHP Manual
  • Swoole\Client
  • Connect to the remote TCP or UDP port.

Swoole\Client::connect

(PECL swoole >= 1.9.0)

Swoole\Client::connect — Connect to the remote TCP or UDP port.

说明

public Swoole\Client::connect ( string $host , int $port = ? , int $timeout = ? , int $flag = ? ) : bool

参数

host

The host name of the remote address.

port

The port number of the remote address.

timeout

The timeout(second) of connect/send/recv, the dafault value is 0.1s

flag

If the type of client is UDP, the $flag means if to enable the configuration udp_connect. If the configuration udp_connect is enabled, the client will only receive the data from specified ip:port. If the type of client is TCP and the $flag is set to 1, it must use swoole_client_select to check the connection status before send/recv.

返回值

Whether the connection is established.


Create Swoole sync or async TCP/UDP client, with or without SSL.

  • ? Swoole\Client::connect
  • Swoole\Client::__destruct ?
  • PHP Manual
  • Swoole\Client
  • Create Swoole sync or async TCP/UDP client, with or without SSL.

Swoole\Client::__construct

(PECL swoole >= 1.9.0)

Swoole\Client::__construct — Create Swoole sync or async TCP/UDP client, with or without SSL.

说明

public Swoole\Client::__construct ( int $sock_type , int $is_async = ? )

参数

sock_type

The type of socket: SWOOLE_TCP, SWOOLE_UDP, SWOOLE_ASYNC, SWOOLE_SSL, SWOOLE_KEEP.

is_async

Synchronous or asynchronous client.


Destruct the Swoole client.

  • ? Swoole\Client::__construct
  • Swoole\Client::getpeername ?
  • PHP Manual
  • Swoole\Client
  • Destruct the Swoole client.

Swoole\Client::__destruct

(PECL swoole >= 1.9.0)

Swoole\Client::__destruct — Destruct the Swoole client.

说明

public Swoole\Client::__destruct ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。


Get the remote socket name of the connection.

  • ? Swoole\Client::__destruct
  • Swoole\Client::getsockname ?
  • PHP Manual
  • Swoole\Client
  • Get the remote socket name of the connection.

Swoole\Client::getpeername

(PECL swoole >= 1.9.0)

Swoole\Client::getpeername — Get the remote socket name of the connection.

说明

public Swoole\Client::getpeername ( ) : array

参数

此函数没有参数。

返回值

The host and port of the remote socket.


Get the local socket name of the connection.

  • ? Swoole\Client::getpeername
  • Swoole\Client::isConnected ?
  • PHP Manual
  • Swoole\Client
  • Get the local socket name of the connection.

Swoole\Client::getsockname

(PECL swoole >= 1.9.0)

Swoole\Client::getsockname — Get the local socket name of the connection.

说明

public Swoole\Client::getsockname ( ) : array

参数

此函数没有参数。

返回值

The host and port of the local socket.


Check if the connection is established.

  • ? Swoole\Client::getsockname
  • Swoole\Client::on ?
  • PHP Manual
  • Swoole\Client
  • Check if the connection is established.

Swoole\Client::isConnected

(PECL swoole >= 1.9.0)

Swoole\Client::isConnected — Check if the connection is established.

说明

public Swoole\Client::isConnected ( ) : bool

This method returns the connection status of application layer.

参数

此函数没有参数。

返回值

Whether the connection is established.


Add callback functions triggered by events.

  • ? Swoole\Client::isConnected
  • Swoole\Client::pause ?
  • PHP Manual
  • Swoole\Client
  • Add callback functions triggered by events.

Swoole\Client::on

(PECL swoole >= 1.9.0)

Swoole\Client::on — Add callback functions triggered by events.

说明

public Swoole\Client::on ( string $event , callable $callback ) : void

参数

event

callback


Pause receiving data.

  • ? Swoole\Client::on
  • Swoole\Client::pipe ?
  • PHP Manual
  • Swoole\Client
  • Pause receiving data.

Swoole\Client::pause

(PECL swoole >= 1.9.0)

Swoole\Client::pause — Pause receiving data.

说明

public Swoole\Client::pause ( ) : void

参数

此函数没有参数。


Redirect the data to another file descriptor.

  • ? Swoole\Client::pause
  • Swoole\Client::recv ?
  • PHP Manual
  • Swoole\Client
  • Redirect the data to another file descriptor.

Swoole\Client::pipe

(PECL swoole >= 1.9.0)

Swoole\Client::pipe — Redirect the data to another file descriptor.

说明

public Swoole\Client::pipe ( string $socket ) : void

参数

socket


Receive data from the remote socket.

  • ? Swoole\Client::pipe
  • Swoole\Client::resume ?
  • PHP Manual
  • Swoole\Client
  • Receive data from the remote socket.

Swoole\Client::recv

(PECL swoole >= 1.9.0)

Swoole\Client::recv — Receive data from the remote socket.

说明

public Swoole\Client::recv ( string $size = ? , string $flag = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

size

flag

返回值


Resume receiving data.

  • ? Swoole\Client::recv
  • Swoole\Client::send ?
  • PHP Manual
  • Swoole\Client
  • Resume receiving data.

Swoole\Client::resume

(PECL swoole >= 1.9.0)

Swoole\Client::resume — Resume receiving data.

说明

public Swoole\Client::resume ( ) : void

参数

此函数没有参数。


Send data to the remote TCP socket.

  • ? Swoole\Client::resume
  • Swoole\Client::sendfile ?
  • PHP Manual
  • Swoole\Client
  • Send data to the remote TCP socket.

Swoole\Client::send

(PECL swoole >= 1.9.0)

Swoole\Client::send — Send data to the remote TCP socket.

说明

public Swoole\Client::send ( string $data , string $flag = ? ) : int

参数

data

The data to send which can be string or binary

flag

返回值

If the client sends data successfully, it returns the length of data sent. Or it returns false and sets $swoole_client->errCode. For sync client, there is no limit for the data to send. For async client, The limit for the data to send is socket_buffer_size.


Send file to the remote TCP socket.

  • ? Swoole\Client::send
  • Swoole\Client::sendto ?
  • PHP Manual
  • Swoole\Client
  • Send file to the remote TCP socket.

Swoole\Client::sendfile

(PECL swoole >= 1.9.0)

Swoole\Client::sendfile — Send file to the remote TCP socket.

说明

public Swoole\Client::sendfile ( string $filename , int $offset = ? ) : bool

This is a wrapper of the Linux sendfile system call.

参数

filename

File path of the file to send.

offset

Offset of the file to send

返回值


Send data to the remote UDP address.

  • ? Swoole\Client::sendfile
  • Swoole\Client::set ?
  • PHP Manual
  • Swoole\Client
  • Send data to the remote UDP address.

Swoole\Client::sendto

(PECL swoole >= 1.9.0)

Swoole\Client::sendto — Send data to the remote UDP address.

说明

public Swoole\Client::sendto ( string $ip , int $port , string $data ) : bool

The swoole client should be type of SWOOLE_SOCK_UDP or SWOOLE_SOCK_UDP6.

参数

ip

The IP address of remote host, IPv4 or IPv6.

port

The port number of remote host.

data

The data to send which should be less-than 64K.

返回值


Set the Swoole client parameters before the connection is established.

  • ? Swoole\Client::sendto
  • Swoole\Client::sleep ?
  • PHP Manual
  • Swoole\Client
  • Set the Swoole client parameters before the connection is established.

Swoole\Client::set

(PECL swoole >= 1.9.0)

Swoole\Client::set — Set the Swoole client parameters before the connection is established.

说明

public Swoole\Client::set ( array $settings ) : void

参数

settings

返回值


Remove the TCP client from system event loop.

  • ? Swoole\Client::set
  • Swoole\Client::wakeup ?
  • PHP Manual
  • Swoole\Client
  • Remove the TCP client from system event loop.

Swoole\Client::sleep

(PECL swoole >= 1.9.0)

Swoole\Client::sleep — Remove the TCP client from system event loop.

说明

public Swoole\Client::sleep ( ) : void

Remove the TCP client from system event loop.

参数

此函数没有参数。

返回值


Add the TCP client back into the system event loop.

  • ? Swoole\Client::sleep
  • Swoole\Connection\Iterator ?
  • PHP Manual
  • Swoole\Client
  • Add the TCP client back into the system event loop.

Swoole\Client::wakeup

(PECL swoole >= 1.9.0)

Swoole\Client::wakeup — Add the TCP client back into the system event loop.

说明

public Swoole\Client::wakeup ( ) : void

参数

此函数没有参数。

返回值


The Swoole\Connection\Iterator class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Connection\Iterator implements Iterator , Countable , ArrayAccess {
/* 方法 */
public count ( ) : int
public current ( ) : Connection
public key ( ) : int
public next ( ) : Connection
public offsetExists ( int $index ) : bool
public offsetGet ( string $index ) : Connection
public offsetSet ( int $offset , mixed $connection ) : void
public offsetUnset ( int $offset ) : void
public rewind ( ) : void
public valid ( ) : bool
}

Table of Contents

  • Swoole\Connection\Iterator::count — Count connections.
  • Swoole\Connection\Iterator::current — Return current connection entry.
  • Swoole\Connection\Iterator::key — Return key of the current connection.
  • Swoole\Connection\Iterator::next — Move to the next connection.
  • Swoole\Connection\Iterator::offsetExists — Check if offet exists.
  • Swoole\Connection\Iterator::offsetGet — Offset to retrieve.
  • Swoole\Connection\Iterator::offsetSet — Assign a Connection to the specified offset.
  • Swoole\Connection\Iterator::offsetUnset — Unset an offset.
  • Swoole\Connection\Iterator::rewind — Rewinds iterator
  • Swoole\Connection\Iterator::valid — Check if current position is valid.


Count connections.

  • ? Swoole\Connection\Iterator
  • Swoole\Connection\Iterator::current ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Count connections.

Swoole\Connection\Iterator::count

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::count — Count connections.

说明

public Swoole\Connection\Iterator::count ( ) : int

Gets the number of connections.

参数

此函数没有参数。

返回值

The number of connections.


Return current connection entry.

  • ? Swoole\Connection\Iterator::count
  • Swoole\Connection\Iterator::key ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Return current connection entry.

Swoole\Connection\Iterator::current

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::current — Return current connection entry.

说明

public Swoole\Connection\Iterator::current ( ) : Connection

Get current connection entry.

参数

此函数没有参数。

返回值

The current connection entry.


Return key of the current connection.

  • ? Swoole\Connection\Iterator::current
  • Swoole\Connection\Iterator::next ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Return key of the current connection.

Swoole\Connection\Iterator::key

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::key — Return key of the current connection.

说明

public Swoole\Connection\Iterator::key ( ) : int

This function returns key of the current connection.

参数

此函数没有参数。

返回值

Key of the current connection.


Move to the next connection.

  • ? Swoole\Connection\Iterator::key
  • Swoole\Connection\Iterator::offsetExists ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Move to the next connection.

Swoole\Connection\Iterator::next

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::next — Move to the next connection.

说明

public Swoole\Connection\Iterator::next ( ) : Connection

The iterator to the next connection.

参数

此函数没有参数。

返回值


Check if offet exists.

  • ? Swoole\Connection\Iterator::next
  • Swoole\Connection\Iterator::offsetGet ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Check if offet exists.

Swoole\Connection\Iterator::offsetExists

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::offsetExists — Check if offet exists.

说明

public Swoole\Connection\Iterator::offsetExists ( int $index ) : bool

Check if offset exists.

参数

index

The offset being checked.

返回值

Returns TRUE if the offset exists, otherwise FALSE.


Offset to retrieve.

  • ? Swoole\Connection\Iterator::offsetExists
  • Swoole\Connection\Iterator::offsetSet ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Offset to retrieve.

Swoole\Connection\Iterator::offsetGet

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::offsetGet — Offset to retrieve.

说明

public Swoole\Connection\Iterator::offsetGet ( string $index ) : Connection

Return the connection at specified offset.

参数

index

The offset to retrieve.

返回值


Assign a Connection to the specified offset.

  • ? Swoole\Connection\Iterator::offsetGet
  • Swoole\Connection\Iterator::offsetUnset ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Assign a Connection to the specified offset.

Swoole\Connection\Iterator::offsetSet

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::offsetSet — Assign a Connection to the specified offset.

说明

public Swoole\Connection\Iterator::offsetSet ( int $offset , mixed $connection ) : void

Assign a Connection to the specified offset.

参数

offset

The offset to assign the Connection to.

connection

The connection to set.

返回值


Unset an offset.

  • ? Swoole\Connection\Iterator::offsetSet
  • Swoole\Connection\Iterator::rewind ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Unset an offset.

Swoole\Connection\Iterator::offsetUnset

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::offsetUnset — Unset an offset.

说明

public Swoole\Connection\Iterator::offsetUnset ( int $offset ) : void

Unsets an offset.

参数

offset

The offset to unset.

返回值


Rewinds iterator

  • ? Swoole\Connection\Iterator::offsetUnset
  • Swoole\Connection\Iterator::valid ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Rewinds iterator

Swoole\Connection\Iterator::rewind

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::rewind — Rewinds iterator

说明

public Swoole\Connection\Iterator::rewind ( ) : void

参数

此函数没有参数。

返回值


Check if current position is valid.

  • ? Swoole\Connection\Iterator::rewind
  • Swoole\Coroutine ?
  • PHP Manual
  • Swoole\Connection\Iterator
  • Check if current position is valid.

Swoole\Connection\Iterator::valid

(PECL swoole >= 1.9.0)

Swoole\Connection\Iterator::valid — Check if current position is valid.

说明

public Swoole\Connection\Iterator::valid ( ) : bool

Checks if the current position is valid.

参数

此函数没有参数。

返回值

Returns TRUE if the current iterator position is valid, otherwise FALSE.


The Swoole\Coroutine class

(PECL swoole >= 2.0.0)

简介

类摘要

Swoole\Coroutine {
/* 方法 */
public static call_user_func_array ( callable $callback , array $param_array ) : mixed
public static call_user_func ( callable $callback , mixed ...$args ) : mixed
public static cli_wait ( ) : ReturnType
public static create ( ) : ReturnType
public Swoole\Coroutine\Client::close ( ) : ReturnType
public Swoole\Coroutine\Client::connect ( ) : ReturnType
public Swoole\Coroutine\Client::__destruct ( ) : ReturnType
public Swoole\Coroutine\Client::getpeername ( ) : ReturnType
public Swoole\Coroutine\Client::getsockname ( ) : ReturnType
public Swoole\Coroutine\Client::isConnected ( ) : ReturnType
public Swoole\Coroutine\Client::recv ( ) : ReturnType
public Swoole\Coroutine\Client::send ( ) : ReturnType
public Swoole\Coroutine\Client::sendfile ( ) : ReturnType
public Swoole\Coroutine\Client::sendto ( ) : ReturnType
public Swoole\Coroutine\Client::set ( ) : ReturnType
public Swoole\Coroutine\Http\Client::addFile ( ) : ReturnType
public Swoole\Coroutine\Http\Client::close ( ) : ReturnType
public Swoole\Coroutine\Http\Client::__destruct ( ) : ReturnType
public Swoole\Coroutine\Http\Client::execute ( ) : ReturnType
public Swoole\Coroutine\Http\Client::get ( ) : ReturnType
public Swoole\Coroutine\Http\Client::getDefer ( ) : ReturnType
public Swoole\Coroutine\Http\Client::isConnected ( ) : ReturnType
public Swoole\Coroutine\Http\Client::post ( ) : ReturnType
public Swoole\Coroutine\Http\Client::recv ( ) : ReturnType
public Swoole\Coroutine\Http\Client::set ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setCookies ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setData ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setDefer ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setHeaders ( ) : ReturnType
public Swoole\Coroutine\Http\Client::setMethod ( ) : ReturnType
public Swoole\Coroutine\MySQL::close ( ) : ReturnType
public Swoole\Coroutine\MySQL::connect ( ) : ReturnType
public Swoole\Coroutine\MySQL::__destruct ( ) : ReturnType
public Swoole\Coroutine\MySQL::getDefer ( ) : ReturnType
public Swoole\Coroutine\MySQL::query ( ) : ReturnType
public Swoole\Coroutine\MySQL::recv ( ) : ReturnType
public Swoole\Coroutine\MySQL::setDefer ( ) : ReturnType
public static getuid ( ) : ReturnType
public static resume ( ) : ReturnType
public static suspend ( ) : ReturnType
}

Table of Contents

  • Swoole\Coroutine::call_user_func_array — Call a callback with an array of parameters
  • Swoole\Coroutine::call_user_func — Call a callback given by the first parameter
  • Swoole\Coroutine::cli_wait — Description
  • Swoole\Coroutine::create — Description
  • Swoole\Coroutine\Client::close — Description
  • Swoole\Coroutine\Client::connect — Description
  • Swoole\Coroutine\Client::__construct — Description
  • Swoole\Coroutine\Client::__destruct — Description
  • Swoole\Coroutine\Client::getpeername — Description
  • Swoole\Coroutine\Client::getsockname — Description
  • Swoole\Coroutine\Client::isConnected — Description
  • Swoole\Coroutine\Client::recv — Description
  • Swoole\Coroutine\Client::send — Description
  • Swoole\Coroutine\Client::sendfile — Description
  • Swoole\Coroutine\Client::sendto — Description
  • Swoole\Coroutine\Client::set — Description
  • Swoole\Coroutine\Http\Client::addFile — Description
  • Swoole\Coroutine\Http\Client::close — Description
  • Swoole\Coroutine\Http\Client::__construct — Description
  • Swoole\Coroutine\Http\Client::__destruct — Description
  • Swoole\Coroutine\Http\Client::execute — Description
  • Swoole\Coroutine\Http\Client::get — Description
  • Swoole\Coroutine\Http\Client::getDefer — Description
  • Swoole\Coroutine\Http\Client::isConnected — Description
  • Swoole\Coroutine\Http\Client::post — Description
  • Swoole\Coroutine\Http\Client::recv — Description
  • Swoole\Coroutine\Http\Client::set — Description
  • Swoole\Coroutine\Http\Client::setCookies — Description
  • Swoole\Coroutine\Http\Client::setData — Description
  • Swoole\Coroutine\Http\Client::setDefer — Description
  • Swoole\Coroutine\Http\Client::setHeaders — Description
  • Swoole\Coroutine\Http\Client::setMethod — Description
  • Swoole\Coroutine\MySQL::close — Description
  • Swoole\Coroutine\MySQL::connect — Description
  • Swoole\Coroutine\MySQL::__construct — Description
  • Swoole\Coroutine\MySQL::__destruct — Description
  • Swoole\Coroutine\MySQL::getDefer — Description
  • Swoole\Coroutine\MySQL::query — Description
  • Swoole\Coroutine\MySQL::recv — Description
  • Swoole\Coroutine\MySQL::setDefer — Description
  • Swoole\Coroutine::getuid — Description
  • Swoole\Coroutine::resume — Description
  • Swoole\Coroutine::suspend — Description


Call a callback with an array of parameters

  • ? Swoole\Coroutine
  • Swoole\Coroutine::call_user_func ?
  • PHP Manual
  • Swoole\Coroutine
  • Call a callback with an array of parameters

Swoole\Coroutine::call_user_func_array

(PECL swoole >= 2.0.0)

Swoole\Coroutine::call_user_func_array — Call a callback with an array of parameters

说明

public static Swoole\Coroutine::call_user_func_array ( callable $callback , array $param_array ) : mixed

Calls the callback given by the first parameter with the parameters in param_array.

参数

callback

The callable to be called.

param_array

Zero or more parameters in the array to be passed to the callback.

返回值


Call a callback given by the first parameter

  • ? Swoole\Coroutine::call_user_func_array
  • Swoole\Coroutine::cli_wait ?
  • PHP Manual
  • Swoole\Coroutine
  • Call a callback given by the first parameter

Swoole\Coroutine::call_user_func

(PECL swoole >= 2.0.0)

Swoole\Coroutine::call_user_func — Call a callback given by the first parameter

说明

public static Swoole\Coroutine::call_user_func ( callable $callback , mixed ...$args ) : mixed

Calls the callback given by the first parameter and passes the remaining parameters as arguments.

参数

callback

The callable to be called.

args

Zero or more parameters to be passed to the callback.

返回值


Description

  • ? Swoole\Coroutine::call_user_func
  • Swoole\Coroutine::create ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::cli_wait

(PECL swoole >= 2.0.0)

Swoole\Coroutine::cli_wait — Description

说明

public static Swoole\Coroutine::cli_wait ( ) : ReturnType

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine::cli_wait
  • Swoole\Coroutine\Client::close ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::create

(PECL swoole >= 2.0.0)

Swoole\Coroutine::create — Description

说明

public static Swoole\Coroutine::create ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine::create
  • Swoole\Coroutine\Client::connect ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::close

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::close — Description

说明

public Swoole\Coroutine\Client::close ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::close
  • Swoole\Coroutine\Client::__construct ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::connect

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::connect — Description

说明

public Swoole\Coroutine\Client::connect ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::connect
  • Swoole\Coroutine\Client::__destruct ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::__construct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::__construct — Description

说明

public Swoole\Coroutine\Client::__construct ( )

参数

此函数没有参数。


Description

  • ? Swoole\Coroutine\Client::__construct
  • Swoole\Coroutine\Client::getpeername ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::__destruct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::__destruct — Description

说明

public Swoole\Coroutine\Client::__destruct ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::__destruct
  • Swoole\Coroutine\Client::getsockname ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::getpeername

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::getpeername — Description

说明

public Swoole\Coroutine\Client::getpeername ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::getpeername
  • Swoole\Coroutine\Client::isConnected ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::getsockname

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::getsockname — Description

说明

public Swoole\Coroutine\Client::getsockname ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::getsockname
  • Swoole\Coroutine\Client::recv ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::isConnected

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::isConnected — Description

说明

public Swoole\Coroutine\Client::isConnected ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::isConnected
  • Swoole\Coroutine\Client::send ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::recv

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::recv — Description

说明

public Swoole\Coroutine\Client::recv ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::recv
  • Swoole\Coroutine\Client::sendfile ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::send

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::send — Description

说明

public Swoole\Coroutine\Client::send ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::send
  • Swoole\Coroutine\Client::sendto ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::sendfile

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::sendfile — Description

说明

public Swoole\Coroutine\Client::sendfile ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::sendfile
  • Swoole\Coroutine\Client::set ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::sendto

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::sendto — Description

说明

public Swoole\Coroutine\Client::sendto ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::sendto
  • Swoole\Coroutine\Http\Client::addFile ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Client::set

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Client::set — Description

说明

public Swoole\Coroutine\Client::set ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Client::set
  • Swoole\Coroutine\Http\Client::close ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::addFile

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::addFile — Description

说明

public Swoole\Coroutine\Http\Client::addFile ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::addFile
  • Swoole\Coroutine\Http\Client::__construct ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::close

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::close — Description

说明

public Swoole\Coroutine\Http\Client::close ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::close
  • Swoole\Coroutine\Http\Client::__destruct ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::__construct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::__construct — Description

说明

public Swoole\Coroutine\Http\Client::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。


Description

  • ? Swoole\Coroutine\Http\Client::__construct
  • Swoole\Coroutine\Http\Client::execute ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::__destruct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::__destruct — Description

说明

public Swoole\Coroutine\Http\Client::__destruct ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::__destruct
  • Swoole\Coroutine\Http\Client::get ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::execute

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::execute — Description

说明

public Swoole\Coroutine\Http\Client::execute ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::execute
  • Swoole\Coroutine\Http\Client::getDefer ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::get

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::get — Description

说明

public Swoole\Coroutine\Http\Client::get ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::get
  • Swoole\Coroutine\Http\Client::isConnected ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::getDefer

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::getDefer — Description

说明

public Swoole\Coroutine\Http\Client::getDefer ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::getDefer
  • Swoole\Coroutine\Http\Client::post ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::isConnected

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::isConnected — Description

说明

public Swoole\Coroutine\Http\Client::isConnected ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::isConnected
  • Swoole\Coroutine\Http\Client::recv ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::post

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::post — Description

说明

public Swoole\Coroutine\Http\Client::post ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::post
  • Swoole\Coroutine\Http\Client::set ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::recv

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::recv — Description

说明

public Swoole\Coroutine\Http\Client::recv ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::recv
  • Swoole\Coroutine\Http\Client::setCookies ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::set

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::set — Description

说明

public Swoole\Coroutine\Http\Client::set ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::set
  • Swoole\Coroutine\Http\Client::setData ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setCookies

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setCookies — Description

说明

public Swoole\Coroutine\Http\Client::setCookies ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::setCookies
  • Swoole\Coroutine\Http\Client::setDefer ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setData

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setData — Description

说明

public Swoole\Coroutine\Http\Client::setData ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::setData
  • Swoole\Coroutine\Http\Client::setHeaders ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setDefer

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setDefer — Description

说明

public Swoole\Coroutine\Http\Client::setDefer ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::setDefer
  • Swoole\Coroutine\Http\Client::setMethod ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setHeaders

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setHeaders — Description

说明

public Swoole\Coroutine\Http\Client::setHeaders ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::setHeaders
  • Swoole\Coroutine\MySQL::close ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\Http\Client::setMethod

(PECL swoole >= 2.0.0)

Swoole\Coroutine\Http\Client::setMethod — Description

说明

public Swoole\Coroutine\Http\Client::setMethod ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\Http\Client::setMethod
  • Swoole\Coroutine\MySQL::connect ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::close

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::close — Description

说明

public Swoole\Coroutine\MySQL::close ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\MySQL::close
  • Swoole\Coroutine\MySQL::__construct ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::connect

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::connect — Description

说明

public Swoole\Coroutine\MySQL::connect ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\MySQL::connect
  • Swoole\Coroutine\MySQL::__destruct ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::__construct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::__construct — Description

说明

public Swoole\Coroutine\MySQL::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。


Description

  • ? Swoole\Coroutine\MySQL::__construct
  • Swoole\Coroutine\MySQL::getDefer ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::__destruct

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::__destruct — Description

说明

public Swoole\Coroutine\MySQL::__destruct ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\MySQL::__destruct
  • Swoole\Coroutine\MySQL::query ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::getDefer

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::getDefer — Description

说明

public Swoole\Coroutine\MySQL::getDefer ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\MySQL::getDefer
  • Swoole\Coroutine\MySQL::recv ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::query

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::query — Description

说明

public Swoole\Coroutine\MySQL::query ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\MySQL::query
  • Swoole\Coroutine\MySQL::setDefer ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::recv

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::recv — Description

说明

public Swoole\Coroutine\MySQL::recv ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\MySQL::recv
  • Swoole\Coroutine::getuid ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine\MySQL::setDefer

(PECL swoole >= 2.0.0)

Swoole\Coroutine\MySQL::setDefer — Description

说明

public Swoole\Coroutine\MySQL::setDefer ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine\MySQL::setDefer
  • Swoole\Coroutine::resume ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::getuid

(PECL swoole >= 2.0.0)

Swoole\Coroutine::getuid — Description

说明

public static Swoole\Coroutine::getuid ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine::getuid
  • Swoole\Coroutine::suspend ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::resume

(PECL swoole >= 2.0.0)

Swoole\Coroutine::resume — Description

说明

public static Swoole\Coroutine::resume ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Description

  • ? Swoole\Coroutine::resume
  • Swoole\Event ?
  • PHP Manual
  • Swoole\Coroutine
  • Description

Swoole\Coroutine::suspend

(PECL swoole >= 2.0.0)

Swoole\Coroutine::suspend — Description

说明

public static Swoole\Coroutine::suspend ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Swoole\Event class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Event {
/* 方法 */
public static add ( int $fd , callable $read_callback , callable $write_callback = ? , string $events = ? ) : bool
public static defer ( mixed $callback ) : void
public static del ( string $fd ) : bool
public static exit ( ) : void
public static set ( int $fd , string $read_callback = ? , string $write_callback = ? , string $events = ? ) : bool
public static wait ( ) : void
public static write ( string $fd , string $data ) : void
}

Table of Contents

  • Swoole\Event::add — Add new callback functions of a socket into the EventLoop.
  • Swoole\Event::defer — Add a callback function to the next event loop.
  • Swoole\Event::del — Remove all event callback functions of a socket.
  • Swoole\Event::exit — Exit the eventloop, only available at client side.
  • Swoole\Event::set — Update the event callback functions of a socket.
  • Swoole\Event::wait — Description
  • Swoole\Event::write — Write data to the socket.


Add new callback functions of a socket into the EventLoop.

  • ? Swoole\Event
  • Swoole\Event::defer ?
  • PHP Manual
  • Swoole\Event
  • Add new callback functions of a socket into the EventLoop.

Swoole\Event::add

(PECL swoole >= 1.9.0)

Swoole\Event::add — Add new callback functions of a socket into the EventLoop.

说明

public static Swoole\Event::add ( int $fd , callable $read_callback , callable $write_callback = ? , string $events = ? ) : bool

参数

fd

read_callback

write_callback

events

返回值


Add a callback function to the next event loop.

  • ? Swoole\Event::add
  • Swoole\Event::del ?
  • PHP Manual
  • Swoole\Event
  • Add a callback function to the next event loop.

Swoole\Event::defer

(PECL swoole >= 1.9.0)

Swoole\Event::defer — Add a callback function to the next event loop.

说明

public static Swoole\Event::defer ( mixed $callback ) : void

参数

callback

返回值


Remove all event callback functions of a socket.

  • ? Swoole\Event::defer
  • Swoole\Event::exit ?
  • PHP Manual
  • Swoole\Event
  • Remove all event callback functions of a socket.

Swoole\Event::del

(PECL swoole >= 1.9.0)

Swoole\Event::del — Remove all event callback functions of a socket.

说明

public static Swoole\Event::del ( string $fd ) : bool

参数

fd

返回值


Exit the eventloop, only available at client side.

  • ? Swoole\Event::del
  • Swoole\Event::set ?
  • PHP Manual
  • Swoole\Event
  • Exit the eventloop, only available at client side.

Swoole\Event::exit

(PECL swoole >= 1.9.0)

Swoole\Event::exit — Exit the eventloop, only available at client side.

说明

public static Swoole\Event::exit ( ) : void

参数

此函数没有参数。

返回值


Update the event callback functions of a socket.

  • ? Swoole\Event::exit
  • Swoole\Event::wait ?
  • PHP Manual
  • Swoole\Event
  • Update the event callback functions of a socket.

Swoole\Event::set

(PECL swoole >= 1.9.0)

Swoole\Event::set — Update the event callback functions of a socket.

说明

public static Swoole\Event::set ( int $fd , string $read_callback = ? , string $write_callback = ? , string $events = ? ) : bool

参数

fd

read_callback

write_callback

events

返回值


Description

  • ? Swoole\Event::set
  • Swoole\Event::write ?
  • PHP Manual
  • Swoole\Event
  • Description

Swoole\Event::wait

(PECL swoole >= 1.9.0)

Swoole\Event::wait — Description

说明

public static Swoole\Event::wait ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Write data to the socket.

  • ? Swoole\Event::wait
  • Swoole\Exception ?
  • PHP Manual
  • Swoole\Event
  • Write data to the socket.

Swoole\Event::write

(PECL swoole >= 1.9.0)

Swoole\Event::write — Write data to the socket.

说明

public static Swoole\Event::write ( string $fd , string $data ) : void

参数

fd

data

返回值


The Swoole\Exception class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Exception extends Exception implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}


The Swoole\Http\Client class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Http\Client {
/* 属性 */
public $errCode ;
public $sock ;
/* 方法 */
public addFile ( string $path , string $name , string $type = ? , string $filename = ? , string $offset = ? ) : void
public close ( ) : void
public __destruct ( ) : void
public download ( string $path , string $file , callable $callback , int $offset = ? ) : void
public execute ( string $path , string $callback ) : void
public get ( string $path , callable $callback ) : void
public isConnected ( ) : bool
public on ( string $event_name , callable $callback ) : void
public post ( string $path , string $data , callable $callback ) : void
public push ( string $data , string $opcode = ? , string $finish = ? ) : void
public set ( array $settings ) : void
public setCookies ( array $cookies ) : void
public setData ( string $data ) : ReturnType
public setHeaders ( array $headers ) : void
public setMethod ( string $method ) : void
public upgrade ( string $path , string $callback ) : void
}

属性

errCode

sock

Table of Contents

  • Swoole\Http\Client::addFile — Add a file to the post form.
  • Swoole\Http\Client::close — Close the http connection.
  • Swoole\Http\Client::__construct — Construct the async HTTP client.
  • Swoole\Http\Client::__destruct — Destruct the HTTP client.
  • Swoole\Http\Client::download — Download a file from the remote server.
  • Swoole\Http\Client::execute — Send the HTTP request after setting the parameters.
  • Swoole\Http\Client::get — Send GET http request to the remote server.
  • Swoole\Http\Client::isConnected — Check if the HTTP connection is connected.
  • Swoole\Http\Client::on — Register callback function by event name.
  • Swoole\Http\Client::post — Send POST http request to the remote server.
  • Swoole\Http\Client::push — Push data to websocket client.
  • Swoole\Http\Client::set — Update the HTTP client paramters.
  • Swoole\Http\Client::setCookies — Set the http request cookies.
  • Swoole\Http\Client::setData — Set the HTTP request body data.
  • Swoole\Http\Client::setHeaders — Set the HTTP request headers.
  • Swoole\Http\Client::setMethod — Set the HTTP request method.
  • Swoole\Http\Client::upgrade — Upgrade to websocket protocol.


Add a file to the post form.

  • ? Swoole\Http\Client
  • Swoole\Http\Client::close ?
  • PHP Manual
  • Swoole\Http\Client
  • Add a file to the post form.

Swoole\Http\Client::addFile

(PECL swoole >= 1.9.0)

Swoole\Http\Client::addFile — Add a file to the post form.

说明

public Swoole\Http\Client::addFile ( string $path , string $name , string $type = ? , string $filename = ? , string $offset = ? ) : void

参数

path

name

type

filename

offset

返回值


Close the http connection.

  • ? Swoole\Http\Client::addFile
  • Swoole\Http\Client::__construct ?
  • PHP Manual
  • Swoole\Http\Client
  • Close the http connection.

Swoole\Http\Client::close

(PECL swoole >= 1.9.0)

Swoole\Http\Client::close — Close the http connection.

说明

public Swoole\Http\Client::close ( ) : void

参数

此函数没有参数。

返回值


Construct the async HTTP client.

  • ? Swoole\Http\Client::close
  • Swoole\Http\Client::__destruct ?
  • PHP Manual
  • Swoole\Http\Client
  • Construct the async HTTP client.

Swoole\Http\Client::__construct

(PECL swoole >= 1.9.0)

Swoole\Http\Client::__construct — Construct the async HTTP client.

说明

public Swoole\Http\Client::__construct ( string $host , string $port = ? , bool $ssl = ? )

参数

host

The hostname of the remote host.

port

The port number of the remote host.

ssl

Whether to enable SSL.


Destruct the HTTP client.

  • ? Swoole\Http\Client::__construct
  • Swoole\Http\Client::download ?
  • PHP Manual
  • Swoole\Http\Client
  • Destruct the HTTP client.

Swoole\Http\Client::__destruct

(PECL swoole >= 1.9.0)

Swoole\Http\Client::__destruct — Destruct the HTTP client.

说明

public Swoole\Http\Client::__destruct ( ) : void

参数

此函数没有参数。

返回值


Download a file from the remote server.

  • ? Swoole\Http\Client::__destruct
  • Swoole\Http\Client::execute ?
  • PHP Manual
  • Swoole\Http\Client
  • Download a file from the remote server.

Swoole\Http\Client::download

(PECL swoole >= 1.9.0)

Swoole\Http\Client::download — Download a file from the remote server.

说明

public Swoole\Http\Client::download ( string $path , string $file , callable $callback , int $offset = ? ) : void

参数

path

file

callback

offset

返回值


Send the HTTP request after setting the parameters.

  • ? Swoole\Http\Client::download
  • Swoole\Http\Client::get ?
  • PHP Manual
  • Swoole\Http\Client
  • Send the HTTP request after setting the parameters.

Swoole\Http\Client::execute

(PECL swoole >= 1.9.0)

Swoole\Http\Client::execute — Send the HTTP request after setting the parameters.

说明

public Swoole\Http\Client::execute ( string $path , string $callback ) : void

参数

path

callback

返回值


Send GET http request to the remote server.

  • ? Swoole\Http\Client::execute
  • Swoole\Http\Client::isConnected ?
  • PHP Manual
  • Swoole\Http\Client
  • Send GET http request to the remote server.

Swoole\Http\Client::get

(PECL swoole >= 1.9.0)

Swoole\Http\Client::get — Send GET http request to the remote server.

说明

public Swoole\Http\Client::get ( string $path , callable $callback ) : void

参数

path

callback

返回值


Check if the HTTP connection is connected.

  • ? Swoole\Http\Client::get
  • Swoole\Http\Client::on ?
  • PHP Manual
  • Swoole\Http\Client
  • Check if the HTTP connection is connected.

Swoole\Http\Client::isConnected

(PECL swoole >= 1.9.0)

Swoole\Http\Client::isConnected — Check if the HTTP connection is connected.

说明

public Swoole\Http\Client::isConnected ( ) : bool

参数

此函数没有参数。

返回值


Register callback function by event name.

  • ? Swoole\Http\Client::isConnected
  • Swoole\Http\Client::post ?
  • PHP Manual
  • Swoole\Http\Client
  • Register callback function by event name.

Swoole\Http\Client::on

(PECL swoole >= 1.9.0)

Swoole\Http\Client::on — Register callback function by event name.

说明

public Swoole\Http\Client::on ( string $event_name , callable $callback ) : void

参数

event_name

callback

返回值


Send POST http request to the remote server.

  • ? Swoole\Http\Client::on
  • Swoole\Http\Client::push ?
  • PHP Manual
  • Swoole\Http\Client
  • Send POST http request to the remote server.

Swoole\Http\Client::post

(PECL swoole >= 1.9.0)

Swoole\Http\Client::post — Send POST http request to the remote server.

说明

public Swoole\Http\Client::post ( string $path , string $data , callable $callback ) : void

参数

path

data

callback

返回值


Push data to websocket client.

  • ? Swoole\Http\Client::post
  • Swoole\Http\Client::set ?
  • PHP Manual
  • Swoole\Http\Client
  • Push data to websocket client.

Swoole\Http\Client::push

(PECL swoole >= 1.9.0)

Swoole\Http\Client::push — Push data to websocket client.

说明

public Swoole\Http\Client::push ( string $data , string $opcode = ? , string $finish = ? ) : void

参数

data

opcode

finish

返回值


Update the HTTP client paramters.

  • ? Swoole\Http\Client::push
  • Swoole\Http\Client::setCookies ?
  • PHP Manual
  • Swoole\Http\Client
  • Update the HTTP client paramters.

Swoole\Http\Client::set

(PECL swoole >= 1.9.0)

Swoole\Http\Client::set — Update the HTTP client paramters.

说明

public Swoole\Http\Client::set ( array $settings ) : void

参数

settings

返回值


Set the http request cookies.

  • ? Swoole\Http\Client::set
  • Swoole\Http\Client::setData ?
  • PHP Manual
  • Swoole\Http\Client
  • Set the http request cookies.

Swoole\Http\Client::setCookies

(PECL swoole >= 1.9.0)

Swoole\Http\Client::setCookies — Set the http request cookies.

说明

public Swoole\Http\Client::setCookies ( array $cookies ) : void

参数

cookies

返回值


Set the HTTP request body data.

  • ? Swoole\Http\Client::setCookies
  • Swoole\Http\Client::setHeaders ?
  • PHP Manual
  • Swoole\Http\Client
  • Set the HTTP request body data.

Swoole\Http\Client::setData

(PECL swoole >= 1.9.0)

Swoole\Http\Client::setData — Set the HTTP request body data.

说明

public Swoole\Http\Client::setData ( string $data ) : ReturnType

The HTTP method will be changed to be POST.

参数

data

返回值


Set the HTTP request headers.

  • ? Swoole\Http\Client::setData
  • Swoole\Http\Client::setMethod ?
  • PHP Manual
  • Swoole\Http\Client
  • Set the HTTP request headers.

Swoole\Http\Client::setHeaders

(PECL swoole >= 1.9.0)

Swoole\Http\Client::setHeaders — Set the HTTP request headers.

说明

public Swoole\Http\Client::setHeaders ( array $headers ) : void

参数

headers

返回值


Set the HTTP request method.

  • ? Swoole\Http\Client::setHeaders
  • Swoole\Http\Client::upgrade ?
  • PHP Manual
  • Swoole\Http\Client
  • Set the HTTP request method.

Swoole\Http\Client::setMethod

(PECL swoole >= 1.9.0)

Swoole\Http\Client::setMethod — Set the HTTP request method.

说明

public Swoole\Http\Client::setMethod ( string $method ) : void

参数

method

返回值


Upgrade to websocket protocol.

  • ? Swoole\Http\Client::setMethod
  • Swoole\Http\Request ?
  • PHP Manual
  • Swoole\Http\Client
  • Upgrade to websocket protocol.

Swoole\Http\Client::upgrade

(PECL swoole >= 1.9.0)

Swoole\Http\Client::upgrade — Upgrade to websocket protocol.

说明

public Swoole\Http\Client::upgrade ( string $path , string $callback ) : void

参数

path

callback

返回值


The Swoole\Http\Request class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Http\Request {
/* 方法 */
public __destruct ( ) : void
public rawcontent ( ) : string
}

Table of Contents

  • Swoole\Http\Request::__destruct — Destruct the HTTP request.
  • Swoole\Http\Request::rawcontent — Get the raw HTTP POST body.


Destruct the HTTP request.

  • ? Swoole\Http\Request
  • Swoole\Http\Request::rawcontent ?
  • PHP Manual
  • Swoole\Http\Request
  • Destruct the HTTP request.

Swoole\Http\Request::__destruct

(PECL swoole >= 1.9.0)

Swoole\Http\Request::__destruct — Destruct the HTTP request.

说明

public Swoole\Http\Request::__destruct ( ) : void

参数

此函数没有参数。

返回值


Get the raw HTTP POST body.

  • ? Swoole\Http\Request::__destruct
  • Swoole\Http\Response ?
  • PHP Manual
  • Swoole\Http\Request
  • Get the raw HTTP POST body.

Swoole\Http\Request::rawcontent

(PECL swoole >= 1.9.0)

Swoole\Http\Request::rawcontent — Get the raw HTTP POST body.

说明

public Swoole\Http\Request::rawcontent ( ) : string

This method is used for the POST data which isn't in the form of `application/x-www-form-urlencoded`.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Swoole\Http\Response class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Http\Response {
/* 方法 */
public cookie ( string $name , string $value = ? , string $expires = ? , string $path = ? , string $domain = ? , string $secure = ? , string $httponly = ? ) : string
public __destruct ( ) : void
public end ( string $content = ? ) : void
public gzip ( string $compress_level = ? ) : ReturnType
public header ( string $key , string $value , string $ucwords = ? ) : void
public initHeader ( ) : ReturnType
public rawcookie ( string $name , string $value = ? , string $expires = ? , string $path = ? , string $domain = ? , string $secure = ? , string $httponly = ? ) : ReturnType
public sendfile ( string $filename , int $offset = ? ) : ReturnType
public status ( string $http_code ) : ReturnType
public write ( string $content ) : void
}

Table of Contents

  • Swoole\Http\Response::cookie — Set the cookies of the HTTP response.
  • Swoole\Http\Response::__destruct — Destruct the HTTP response.
  • Swoole\Http\Response::end — Send data for the HTTP request and finish the response.
  • Swoole\Http\Response::gzip — Enable the gzip of response content.
  • Swoole\Http\Response::header — Set the HTTP response headers.
  • Swoole\Http\Response::initHeader — Init the HTTP response header.
  • Swoole\Http\Response::rawcookie — Set the raw cookies to the HTTP response.
  • Swoole\Http\Response::sendfile — Send file through the HTTP response.
  • Swoole\Http\Response::status — Set the status code of the HTTP response.
  • Swoole\Http\Response::write — Append HTTP body content to the HTTP response.


Set the cookies of the HTTP response.

  • ? Swoole\Http\Response
  • Swoole\Http\Response::__destruct ?
  • PHP Manual
  • Swoole\Http\Response
  • Set the cookies of the HTTP response.

Swoole\Http\Response::cookie

(PECL swoole >= 1.9.0)

Swoole\Http\Response::cookie — Set the cookies of the HTTP response.

说明

public Swoole\Http\Response::cookie ( string $name , string $value = ? , string $expires = ? , string $path = ? , string $domain = ? , string $secure = ? , string $httponly = ? ) : string

参数

name

value

expires

path

domain

secure

httponly

返回值


Destruct the HTTP response.

  • ? Swoole\Http\Response::cookie
  • Swoole\Http\Response::end ?
  • PHP Manual
  • Swoole\Http\Response
  • Destruct the HTTP response.

Swoole\Http\Response::__destruct

(PECL swoole >= 1.9.0)

Swoole\Http\Response::__destruct — Destruct the HTTP response.

说明

public Swoole\Http\Response::__destruct ( ) : void

参数

此函数没有参数。

返回值


Send data for the HTTP request and finish the response.

  • ? Swoole\Http\Response::__destruct
  • Swoole\Http\Response::gzip ?
  • PHP Manual
  • Swoole\Http\Response
  • Send data for the HTTP request and finish the response.

Swoole\Http\Response::end

(PECL swoole >= 1.9.0)

Swoole\Http\Response::end — Send data for the HTTP request and finish the response.

说明

public Swoole\Http\Response::end ( string $content = ? ) : void

参数

content

返回值


Enable the gzip of response content.

  • ? Swoole\Http\Response::end
  • Swoole\Http\Response::header ?
  • PHP Manual
  • Swoole\Http\Response
  • Enable the gzip of response content.

Swoole\Http\Response::gzip

(PECL swoole >= 1.9.0)

Swoole\Http\Response::gzip — Enable the gzip of response content.

说明

public Swoole\Http\Response::gzip ( string $compress_level = ? ) : ReturnType

The header about Content-Encoding will be added automatically.

参数

compress_level

返回值


Set the HTTP response headers.

  • ? Swoole\Http\Response::gzip
  • Swoole\Http\Response::initHeader ?
  • PHP Manual
  • Swoole\Http\Response
  • Set the HTTP response headers.

Swoole\Http\Response::header

(PECL swoole >= 1.9.0)

Swoole\Http\Response::header — Set the HTTP response headers.

说明

public Swoole\Http\Response::header ( string $key , string $value , string $ucwords = ? ) : void

参数

key

value

ucwords

返回值


Init the HTTP response header.

  • ? Swoole\Http\Response::header
  • Swoole\Http\Response::rawcookie ?
  • PHP Manual
  • Swoole\Http\Response
  • Init the HTTP response header.

Swoole\Http\Response::initHeader

(PECL swoole >= 1.9.0)

Swoole\Http\Response::initHeader — Init the HTTP response header.

说明

public Swoole\Http\Response::initHeader ( ) : ReturnType

Init the HTTP response header.

参数

此函数没有参数。

返回值


Set the raw cookies to the HTTP response.

  • ? Swoole\Http\Response::initHeader
  • Swoole\Http\Response::sendfile ?
  • PHP Manual
  • Swoole\Http\Response
  • Set the raw cookies to the HTTP response.

Swoole\Http\Response::rawcookie

(PECL swoole >= 1.9.0)

Swoole\Http\Response::rawcookie — Set the raw cookies to the HTTP response.

说明

public Swoole\Http\Response::rawcookie ( string $name , string $value = ? , string $expires = ? , string $path = ? , string $domain = ? , string $secure = ? , string $httponly = ? ) : ReturnType

参数

name

value

expires

path

domain

secure

httponly

返回值


Send file through the HTTP response.

  • ? Swoole\Http\Response::rawcookie
  • Swoole\Http\Response::status ?
  • PHP Manual
  • Swoole\Http\Response
  • Send file through the HTTP response.

Swoole\Http\Response::sendfile

(PECL swoole >= 1.9.0)

Swoole\Http\Response::sendfile — Send file through the HTTP response.

说明

public Swoole\Http\Response::sendfile ( string $filename , int $offset = ? ) : ReturnType

Send file through the HTTP response.

参数

filename

offset

返回值


Set the status code of the HTTP response.

  • ? Swoole\Http\Response::sendfile
  • Swoole\Http\Response::write ?
  • PHP Manual
  • Swoole\Http\Response
  • Set the status code of the HTTP response.

Swoole\Http\Response::status

(PECL swoole >= 1.9.0)

Swoole\Http\Response::status — Set the status code of the HTTP response.

说明

public Swoole\Http\Response::status ( string $http_code ) : ReturnType

Set the status code of the HTTP response.

参数

http_code

返回值


Append HTTP body content to the HTTP response.

  • ? Swoole\Http\Response::status
  • Swoole\Http\Server ?
  • PHP Manual
  • Swoole\Http\Response
  • Append HTTP body content to the HTTP response.

Swoole\Http\Response::write

(PECL swoole >= 1.9.0)

Swoole\Http\Response::write — Append HTTP body content to the HTTP response.

说明

public Swoole\Http\Response::write ( string $content ) : void

Append HTTP body content to the HTTP response.

参数

content

返回值


The Swoole\Http\Server class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Http\Server extends Swoole\Server {
/* 方法 */
public on ( string $event_name , callable $callback ) : void
public start ( ) : void
/* 继承的方法 */
public Swoole\Server::addlistener ( string $host , int $port , string $socket_type ) : void
public Swoole\Server::addProcess ( swoole_process $process ) : bool
public Swoole\Server::after ( int $after_time_ms , callable $callback , string $param = ? ) : ReturnType
public Swoole\Server::bind ( int $fd , int $uid ) : bool
public Swoole\Server::clearTimer ( int $timer_id ) : void
swoole_timer_clear ( int $timer_id ) : void
public Swoole\Server::close ( int $fd , bool $reset = ? ) : bool
public Swoole\Server::confirm ( int $fd ) : bool
public Swoole\Server::connection_info ( int $fd , int $reactor_id = ? ) : array
public Swoole\Server::connection_list ( int $start_fd , int $pagesize = ? ) : array
public Swoole\Server::defer ( callable $callback ) : void
public Swoole\Server\Port::__destruct ( ) : void
public Swoole\Server\Port::on ( string $event_name , callable $callback ) : ReturnType
public Swoole\Server\Port::set ( array $settings ) : void
public Swoole\Server::exist ( int $fd ) : bool
public Swoole\Server::finish ( string $data ) : void
public Swoole\Server::getClientInfo ( int $fd , int $reactor_id = ? ) : ReturnType
public Swoole\Server::getClientList ( int $start_fd , int $pagesize = ? ) : array
public Swoole\Server::getLastError ( ) : int
public Swoole\Server::heartbeat ( bool $if_close_connection ) : mixed
public Swoole\Server::listen ( string $host , int $port , string $socket_type ) : bool
public Swoole\Server::on ( string $event_name , callable $callback ) : void
public Swoole\Server::pause ( int $fd ) : void
public Swoole\Server::protect ( int $fd , bool $is_protected = ? ) : void
public Swoole\Server::reload ( ) : bool
public Swoole\Server::resume ( int $fd ) : void
public Swoole\Server::send ( int $fd , string $data , int $reactor_id = ? ) : bool
public Swoole\Server::sendfile ( int $fd , string $filename , int $offset = ? ) : bool
public Swoole\Server::sendMessage ( int $worker_id , string $data ) : bool
public Swoole\Server::sendto ( string $ip , int $port , string $data , string $server_socket = ? ) : bool
public Swoole\Server::sendwait ( int $fd , string $data ) : bool
public Swoole\Server::set ( array $settings ) : ReturnType
public Swoole\Server::shutdown ( ) : void
public Swoole\Server::start ( ) : void
public Swoole\Server::stats ( ) : array
public Swoole\Server::stop ( int $worker_id = ? ) : bool
public Swoole\Server::task ( string $data , int $dst_worker_id = ? , callable $callback = ? ) : mixed
public Swoole\Server::taskwait ( string $data , float $timeout = ? , int $worker_id = ? ) : void
public Swoole\Server::taskWaitMulti ( array $tasks , double $timeout_ms = ? ) : void
public Swoole\Server::tick ( int $interval_ms , callable $callback ) : void
}

Table of Contents

  • Swoole\Http\Server::on — Bind callback function to HTTP server by event name.
  • Swoole\Http\Server::start — Start the swoole http server.


Bind callback function to HTTP server by event name.

  • ? Swoole\Http\Server
  • Swoole\Http\Server::start ?
  • PHP Manual
  • Swoole\Http\Server
  • Bind callback function to HTTP server by event name.

Swoole\Http\Server::on

(PECL swoole >= 1.9.0)

Swoole\Http\Server::on — Bind callback function to HTTP server by event name.

说明

public Swoole\Http\Server::on ( string $event_name , callable $callback ) : void

Bind callback function to HTTP server by event name.

参数

event_name

callback

返回值


Start the swoole http server.

  • ? Swoole\Http\Server::on
  • Swoole\Lock ?
  • PHP Manual
  • Swoole\Http\Server
  • Start the swoole http server.

Swoole\Http\Server::start

(PECL swoole >= 1.9.0)

Swoole\Http\Server::start — Start the swoole http server.

说明

public Swoole\Http\Server::start ( ) : void

Start the swoole http server.

参数

此函数没有参数。

返回值


The Swoole\Lock class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Lock {
/* 方法 */
public __destruct ( ) : void
public lock_read ( ) : void
public lock ( ) : void
public trylock_read ( ) : void
public trylock ( ) : void
public unlock ( ) : void
}

Table of Contents

  • Swoole\Lock::__construct — Construct a memory lock.
  • Swoole\Lock::__destruct — Destory a Swoole memory lock.
  • Swoole\Lock::lock_read — Lock a read-write lock for reading.
  • Swoole\Lock::lock — Try to acquire the lock. It will block if the lock is not available.
  • Swoole\Lock::trylock_read — Try to lock a read-write lock for reading and return straight away even the lock is not available.
  • Swoole\Lock::trylock — Try to acquire the lock and return straight away even the lock is not available.
  • Swoole\Lock::unlock — Release the lock.


Construct a memory lock.

  • ? Swoole\Lock
  • Swoole\Lock::__destruct ?
  • PHP Manual
  • Swoole\Lock
  • Construct a memory lock.

Swoole\Lock::__construct

(PECL swoole >= 1.9.0)

Swoole\Lock::__construct — Construct a memory lock.

说明

public Swoole\Lock::__construct ( string $type = ? , string $file_lock_location = ? )

Swoole lock is used for data synchronization between multiple theads or processes.

参数

type

file_lock_location


Destory a Swoole memory lock.

  • ? Swoole\Lock::__construct
  • Swoole\Lock::lock_read ?
  • PHP Manual
  • Swoole\Lock
  • Destory a Swoole memory lock.

Swoole\Lock::__destruct

(PECL swoole >= 1.9.0)

Swoole\Lock::__destruct — Destory a Swoole memory lock.

说明

public Swoole\Lock::__destruct ( ) : void

参数

此函数没有参数。

返回值


Lock a read-write lock for reading.

  • ? Swoole\Lock::__destruct
  • Swoole\Lock::lock ?
  • PHP Manual
  • Swoole\Lock
  • Lock a read-write lock for reading.

Swoole\Lock::lock_read

(PECL swoole >= 1.9.0)

Swoole\Lock::lock_read — Lock a read-write lock for reading.

说明

public Swoole\Lock::lock_read ( ) : void

Lock a read-write lock for reading.

参数

此函数没有参数。

返回值


Try to acquire the lock. It will block if the lock is not available.

  • ? Swoole\Lock::lock_read
  • Swoole\Lock::trylock_read ?
  • PHP Manual
  • Swoole\Lock
  • Try to acquire the lock. It will block if the lock is not available.

Swoole\Lock::lock

(PECL swoole >= 1.9.0)

Swoole\Lock::lock — Try to acquire the lock. It will block if the lock is not available.

说明

public Swoole\Lock::lock ( ) : void

参数

此函数没有参数。

返回值


Try to lock a read-write lock for reading and return straight away even the lock is not available.

  • ? Swoole\Lock::lock
  • Swoole\Lock::trylock ?
  • PHP Manual
  • Swoole\Lock
  • Try to lock a read-write lock for reading and return straight away even the lock is not available.

Swoole\Lock::trylock_read

(PECL swoole >= 1.9.0)

Swoole\Lock::trylock_read — Try to lock a read-write lock for reading and return straight away even the lock is not available.

说明

public Swoole\Lock::trylock_read ( ) : void

参数

此函数没有参数。

返回值


Try to acquire the lock and return straight away even the lock is not available.

  • ? Swoole\Lock::trylock_read
  • Swoole\Lock::unlock ?
  • PHP Manual
  • Swoole\Lock
  • Try to acquire the lock and return straight away even the lock is not available.

Swoole\Lock::trylock

(PECL swoole >= 1.9.0)

Swoole\Lock::trylock — Try to acquire the lock and return straight away even the lock is not available.

说明

public Swoole\Lock::trylock ( ) : void

参数

此函数没有参数。

返回值


Release the lock.

  • ? Swoole\Lock::trylock
  • Swoole\Mmap ?
  • PHP Manual
  • Swoole\Lock
  • Release the lock.

Swoole\Lock::unlock

(PECL swoole >= 1.9.0)

Swoole\Lock::unlock — Release the lock.

说明

public Swoole\Lock::unlock ( ) : void

参数

此函数没有参数。

返回值


The Swoole\Mmap class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Mmap {
/* 方法 */
public static open ( string $filename , string $size = ? , string $offset = ? ) : ReturnType
}

Table of Contents

  • Swoole\Mmap::open — Map a file into memory and return the stream resource which can be used by PHP stream operations.


Map a file into memory and return the stream resource which can be used by PHP stream operations.

  • ? Swoole\Mmap
  • Swoole\MySQL ?
  • PHP Manual
  • Swoole\Mmap
  • Map a file into memory and return the stream resource which can be used by PHP stream operations.

Swoole\Mmap::open

(PECL swoole >= 1.9.0)

Swoole\Mmap::open — Map a file into memory and return the stream resource which can be used by PHP stream operations.

说明

public static Swoole\Mmap::open ( string $filename , string $size = ? , string $offset = ? ) : ReturnType

参数

filename

size

offset

返回值


The Swoole\MySQL class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\MySQL {
/* 方法 */
public close ( ) : void
public connect ( array $server_config , callable $callback ) : void
public __destruct ( ) : void
public getBuffer ( ) : ReturnType
public on ( string $event_name , callable $callback ) : void
public query ( string $sql , callable $callback ) : ReturnType
}

Table of Contents

  • Swoole\MySQL::close — Close the async MySQL connection.
  • Swoole\MySQL::connect — Connect to the remote MySQL server.
  • Swoole\MySQL::__construct — Construct an async MySQL client.
  • Swoole\MySQL::__destruct — Destory the async MySQL client.
  • Swoole\MySQL::getBuffer — Description
  • Swoole\MySQL::on — Register callback function based on event name.
  • Swoole\MySQL::query — Run the SQL query.


Close the async MySQL connection.

  • ? Swoole\MySQL
  • Swoole\MySQL::connect ?
  • PHP Manual
  • Swoole\MySQL
  • Close the async MySQL connection.

Swoole\MySQL::close

(PECL swoole >= 1.9.0)

Swoole\MySQL::close — Close the async MySQL connection.

说明

public Swoole\MySQL::close ( ) : void

参数

此函数没有参数。

返回值


Connect to the remote MySQL server.

  • ? Swoole\MySQL::close
  • Swoole\MySQL::__construct ?
  • PHP Manual
  • Swoole\MySQL
  • Connect to the remote MySQL server.

Swoole\MySQL::connect

(PECL swoole >= 1.9.0)

Swoole\MySQL::connect — Connect to the remote MySQL server.

说明

public Swoole\MySQL::connect ( array $server_config , callable $callback ) : void

Connect to the remote MySQL server.

参数

server_config

callback

返回值


Construct an async MySQL client.

  • ? Swoole\MySQL::connect
  • Swoole\MySQL::__destruct ?
  • PHP Manual
  • Swoole\MySQL
  • Construct an async MySQL client.

Swoole\MySQL::__construct

(PECL swoole >= 1.9.0)

Swoole\MySQL::__construct — Construct an async MySQL client.

说明

public Swoole\MySQL::__construct ( )

Construct an async MySQL client.

参数

此函数没有参数。


Destory the async MySQL client.

  • ? Swoole\MySQL::__construct
  • Swoole\MySQL::getBuffer ?
  • PHP Manual
  • Swoole\MySQL
  • Destory the async MySQL client.

Swoole\MySQL::__destruct

(PECL swoole >= 1.9.0)

Swoole\MySQL::__destruct — Destory the async MySQL client.

说明

public Swoole\MySQL::__destruct ( ) : void

参数

此函数没有参数。

返回值


Description

  • ? Swoole\MySQL::__destruct
  • Swoole\MySQL::on ?
  • PHP Manual
  • Swoole\MySQL
  • Description

Swoole\MySQL::getBuffer

(PECL swoole >= 1.9.0)

Swoole\MySQL::getBuffer — Description

说明

public Swoole\MySQL::getBuffer ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Register callback function based on event name.

  • ? Swoole\MySQL::getBuffer
  • Swoole\MySQL::query ?
  • PHP Manual
  • Swoole\MySQL
  • Register callback function based on event name.

Swoole\MySQL::on

(PECL swoole >= 1.9.0)

Swoole\MySQL::on — Register callback function based on event name.

说明

public Swoole\MySQL::on ( string $event_name , callable $callback ) : void

Register callback function based on event name, current only 'close' event is supported.

参数

event_name

callback

返回值


Run the SQL query.

  • ? Swoole\MySQL::on
  • Swoole\MySQL\Exception ?
  • PHP Manual
  • Swoole\MySQL
  • Run the SQL query.

Swoole\MySQL::query

(PECL swoole >= 1.9.0)

Swoole\MySQL::query — Run the SQL query.

说明

public Swoole\MySQL::query ( string $sql , callable $callback ) : ReturnType

参数

sql

callback

返回值


The Swoole\MySQL\Exception class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\MySQL\Exception extends Exception implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}


The Swoole\Process class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Process {
/* Constants */
const int IPC_NOWAIT = 256 ;
/* 方法 */
public static alarm ( int $interval_usec ) : void
public close ( ) : void
public static daemon ( bool $nochdir = ? , bool $noclose = ? ) : void
public __destruct ( ) : void
public exec ( string $exec_file , string $args ) : ReturnType
public exit ( string $exit_code = ? ) : void
public freeQueue ( ) : void
public static kill ( int $pid , string $signal_no = ? ) : void
public name ( string $process_name ) : void
public pop ( int $maxsize = ? ) : mixed
public push ( string $data ) : bool
public read ( int $maxsize = ? ) : string
public static signal ( string $signal_no , callable $callback ) : void
public start ( ) : void
public statQueue ( ) : array
public useQueue ( int $key , int $mode = ? ) : bool
public static wait ( bool $blocking = ? ) : array
public write ( string $data ) : int
}

预定义常量

Swoole\Process::IPC_NOWAIT

Table of Contents

  • Swoole\Process::alarm — High precision timer which triggers signal with fixed interval.
  • Swoole\Process::close — Close the pipe to the child process.
  • Swoole\Process::__construct — Construct a process.
  • Swoole\Process::daemon — Change the process to be a daemon process.
  • Swoole\Process::__destruct — Destory the process.
  • Swoole\Process::exec — Execute system commands.
  • Swoole\Process::exit — Stop the child processes.
  • Swoole\Process::freeQueue — Destroy the message queue created by swoole_process::useQueue.
  • Swoole\Process::kill — Send signal to the child process.
  • Swoole\Process::name — Set name of the process.
  • Swoole\Process::pop — Read and pop data from the message queue.
  • Swoole\Process::push — Write and push data into the message queue.
  • Swoole\Process::read — Read data sending to the process.
  • Swoole\Process::signal — Send signal to the child processes.
  • Swoole\Process::start — Start the process.
  • Swoole\Process::statQueue — Get the stats of the message queue used as the communication method between processes.
  • Swoole\Process::useQueue — Create a message queue as the communication method between the parent process and child processes.
  • Swoole\Process::wait — Wait for the events of child processes.
  • Swoole\Process::write — Write data into the pipe and communicate with the parent process or child processes.


High precision timer which triggers signal with fixed interval.

  • ? Swoole\Process
  • Swoole\Process::close ?
  • PHP Manual
  • Swoole\Process
  • High precision timer which triggers signal with fixed interval.

Swoole\Process::alarm

(PECL swoole >= 1.9.0)

Swoole\Process::alarm — High precision timer which triggers signal with fixed interval.

说明

public static Swoole\Process::alarm ( int $interval_usec ) : void

参数

interval_usec

返回值


Close the pipe to the child process.

  • ? Swoole\Process::alarm
  • Swoole\Process::__construct ?
  • PHP Manual
  • Swoole\Process
  • Close the pipe to the child process.

Swoole\Process::close

(PECL swoole >= 1.9.0)

Swoole\Process::close — Close the pipe to the child process.

说明

public Swoole\Process::close ( ) : void

Close the pipe to the child process.

参数

此函数没有参数。

返回值


Construct a process.

  • ? Swoole\Process::close
  • Swoole\Process::daemon ?
  • PHP Manual
  • Swoole\Process
  • Construct a process.

Swoole\Process::__construct

(PECL swoole >= 1.9.0)

Swoole\Process::__construct — Construct a process.

说明

public Swoole\Process::__construct ( callable $callback , bool $redirect_stdin_and_stdout = ? , int $pipe_type = ? )

参数

callback

redirect_stdin_and_stdout

pipe_type


Change the process to be a daemon process.

  • ? Swoole\Process::__construct
  • Swoole\Process::__destruct ?
  • PHP Manual
  • Swoole\Process
  • Change the process to be a daemon process.

Swoole\Process::daemon

(PECL swoole >= 1.9.0)

Swoole\Process::daemon — Change the process to be a daemon process.

说明

public static Swoole\Process::daemon ( bool $nochdir = ? , bool $noclose = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

nochdir

noclose

返回值


Destory the process.

  • ? Swoole\Process::daemon
  • Swoole\Process::exec ?
  • PHP Manual
  • Swoole\Process
  • Destory the process.

Swoole\Process::__destruct

(PECL swoole >= 1.9.0)

Swoole\Process::__destruct — Destory the process.

说明

public Swoole\Process::__destruct ( ) : void

参数

此函数没有参数。

返回值


Execute system commands.

  • ? Swoole\Process::__destruct
  • Swoole\Process::exit ?
  • PHP Manual
  • Swoole\Process
  • Execute system commands.

Swoole\Process::exec

(PECL swoole >= 1.9.0)

Swoole\Process::exec — Execute system commands.

说明

public Swoole\Process::exec ( string $exec_file , string $args ) : ReturnType

The process will be replaced to be the system command process, but the pipe to the parent process will be kept.

参数

exec_file

args

返回值


Stop the child processes.

  • ? Swoole\Process::exec
  • Swoole\Process::freeQueue ?
  • PHP Manual
  • Swoole\Process
  • Stop the child processes.

Swoole\Process::exit

(PECL swoole >= 1.9.0)

Swoole\Process::exit — Stop the child processes.

说明

public Swoole\Process::exit ( string $exit_code = ? ) : void

参数

exit_code

返回值


Destroy the message queue created by swoole_process::useQueue.

  • ? Swoole\Process::exit
  • Swoole\Process::kill ?
  • PHP Manual
  • Swoole\Process
  • Destroy the message queue created by swoole_process::useQueue.

Swoole\Process::freeQueue

(PECL swoole >= 1.9.0)

Swoole\Process::freeQueue — Destroy the message queue created by swoole_process::useQueue.

说明

public Swoole\Process::freeQueue ( ) : void

参数

此函数没有参数。

返回值


Send signal to the child process.

  • ? Swoole\Process::freeQueue
  • Swoole\Process::name ?
  • PHP Manual
  • Swoole\Process
  • Send signal to the child process.

Swoole\Process::kill

(PECL swoole >= 1.9.0)

Swoole\Process::kill — Send signal to the child process.

说明

public static Swoole\Process::kill ( int $pid , string $signal_no = ? ) : void

Send signal to the child process.

参数

pid

signal_no

返回值


Set name of the process.

  • ? Swoole\Process::kill
  • Swoole\Process::pop ?
  • PHP Manual
  • Swoole\Process
  • Set name of the process.

Swoole\Process::name

(PECL swoole >= 1.9.0)

Swoole\Process::name — Set name of the process.

说明

public Swoole\Process::name ( string $process_name ) : void

参数

process_name

返回值


Read and pop data from the message queue.

  • ? Swoole\Process::name
  • Swoole\Process::push ?
  • PHP Manual
  • Swoole\Process
  • Read and pop data from the message queue.

Swoole\Process::pop

(PECL swoole >= 1.9.0)

Swoole\Process::pop — Read and pop data from the message queue.

说明

public Swoole\Process::pop ( int $maxsize = ? ) : mixed

参数

maxsize

返回值


Write and push data into the message queue.

  • ? Swoole\Process::pop
  • Swoole\Process::read ?
  • PHP Manual
  • Swoole\Process
  • Write and push data into the message queue.

Swoole\Process::push

(PECL swoole >= 1.9.0)

Swoole\Process::push — Write and push data into the message queue.

说明

public Swoole\Process::push ( string $data ) : bool

参数

data

返回值


Read data sending to the process.

  • ? Swoole\Process::push
  • Swoole\Process::signal ?
  • PHP Manual
  • Swoole\Process
  • Read data sending to the process.

Swoole\Process::read

(PECL swoole >= 1.9.0)

Swoole\Process::read — Read data sending to the process.

说明

public Swoole\Process::read ( int $maxsize = ? ) : string

参数

maxsize

返回值


Send signal to the child processes.

  • ? Swoole\Process::read
  • Swoole\Process::start ?
  • PHP Manual
  • Swoole\Process
  • Send signal to the child processes.

Swoole\Process::signal

(PECL swoole >= 1.9.0)

Swoole\Process::signal — Send signal to the child processes.

说明

public static Swoole\Process::signal ( string $signal_no , callable $callback ) : void

参数

signal_no

callback

返回值

If signal sent successfully, it returns TRUE, otherwise it returns FALSE.


Start the process.

  • ? Swoole\Process::signal
  • Swoole\Process::statQueue ?
  • PHP Manual
  • Swoole\Process
  • Start the process.

Swoole\Process::start

(PECL swoole >= 1.9.0)

Swoole\Process::start — Start the process.

说明

public Swoole\Process::start ( ) : void

参数

此函数没有参数。

返回值


Get the stats of the message queue used as the communication method between processes.

  • ? Swoole\Process::start
  • Swoole\Process::useQueue ?
  • PHP Manual
  • Swoole\Process
  • Get the stats of the message queue used as the communication method between processes.

Swoole\Process::statQueue

(PECL swoole >= 1.9.0)

Swoole\Process::statQueue — Get the stats of the message queue used as the communication method between processes.

说明

public Swoole\Process::statQueue ( ) : array

参数

此函数没有参数。

返回值

The array of status of the message queue.


Create a message queue as the communication method between the parent process and child processes.

  • ? Swoole\Process::statQueue
  • Swoole\Process::wait ?
  • PHP Manual
  • Swoole\Process
  • Create a message queue as the communication method between the parent process and child processes.

Swoole\Process::useQueue

(PECL swoole >= 1.9.0)

Swoole\Process::useQueue — Create a message queue as the communication method between the parent process and child processes.

说明

public Swoole\Process::useQueue ( int $key , int $mode = ? ) : bool

参数

key

mode

返回值


Wait for the events of child processes.

  • ? Swoole\Process::useQueue
  • Swoole\Process::write ?
  • PHP Manual
  • Swoole\Process
  • Wait for the events of child processes.

Swoole\Process::wait

(PECL swoole >= 1.9.0)

Swoole\Process::wait — Wait for the events of child processes.

说明

public static Swoole\Process::wait ( bool $blocking = ? ) : array

参数

blocking

返回值


Write data into the pipe and communicate with the parent process or child processes.

  • ? Swoole\Process::wait
  • Swoole\Redis\Server ?
  • PHP Manual
  • Swoole\Process
  • Write data into the pipe and communicate with the parent process or child processes.

Swoole\Process::write

(PECL swoole >= 1.9.0)

Swoole\Process::write — Write data into the pipe and communicate with the parent process or child processes.

说明

public Swoole\Process::write ( string $data ) : int

参数

data

返回值


The Swoole\Redis\Server class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Redis\Server extends Swoole\Server {
/* Constants */
const int NIL = 1 ;
const int ERROR = 0 ;
const int STATUS = 2 ;
const int INT = 3 ;
const int STRING = 4 ;
const int SET = 5 ;
const int MAP = 6 ;
/* 方法 */
public static format ( string $type , string $value = ? ) : ReturnType
public setHandler ( string $command , string $callback , string $number_of_string_param = ? , string $type_of_array_param = ? ) : ReturnType
public start ( ) : ReturnType
/* 继承的方法 */
public Swoole\Server::addlistener ( string $host , int $port , string $socket_type ) : void
public Swoole\Server::addProcess ( swoole_process $process ) : bool
public Swoole\Server::after ( int $after_time_ms , callable $callback , string $param = ? ) : ReturnType
public Swoole\Server::bind ( int $fd , int $uid ) : bool
public Swoole\Server::clearTimer ( int $timer_id ) : void
swoole_timer_clear ( int $timer_id ) : void
public Swoole\Server::close ( int $fd , bool $reset = ? ) : bool
public Swoole\Server::confirm ( int $fd ) : bool
public Swoole\Server::connection_info ( int $fd , int $reactor_id = ? ) : array
public Swoole\Server::connection_list ( int $start_fd , int $pagesize = ? ) : array
public Swoole\Server::defer ( callable $callback ) : void
public Swoole\Server\Port::__destruct ( ) : void
public Swoole\Server\Port::on ( string $event_name , callable $callback ) : ReturnType
public Swoole\Server\Port::set ( array $settings ) : void
public Swoole\Server::exist ( int $fd ) : bool
public Swoole\Server::finish ( string $data ) : void
public Swoole\Server::getClientInfo ( int $fd , int $reactor_id = ? ) : ReturnType
public Swoole\Server::getClientList ( int $start_fd , int $pagesize = ? ) : array
public Swoole\Server::getLastError ( ) : int
public Swoole\Server::heartbeat ( bool $if_close_connection ) : mixed
public Swoole\Server::listen ( string $host , int $port , string $socket_type ) : bool
public Swoole\Server::on ( string $event_name , callable $callback ) : void
public Swoole\Server::pause ( int $fd ) : void
public Swoole\Server::protect ( int $fd , bool $is_protected = ? ) : void
public Swoole\Server::reload ( ) : bool
public Swoole\Server::resume ( int $fd ) : void
public Swoole\Server::send ( int $fd , string $data , int $reactor_id = ? ) : bool
public Swoole\Server::sendfile ( int $fd , string $filename , int $offset = ? ) : bool
public Swoole\Server::sendMessage ( int $worker_id , string $data ) : bool
public Swoole\Server::sendto ( string $ip , int $port , string $data , string $server_socket = ? ) : bool
public Swoole\Server::sendwait ( int $fd , string $data ) : bool
public Swoole\Server::set ( array $settings ) : ReturnType
public Swoole\Server::shutdown ( ) : void
public Swoole\Server::start ( ) : void
public Swoole\Server::stats ( ) : array
public Swoole\Server::stop ( int $worker_id = ? ) : bool
public Swoole\Server::task ( string $data , int $dst_worker_id = ? , callable $callback = ? ) : mixed
public Swoole\Server::taskwait ( string $data , float $timeout = ? , int $worker_id = ? ) : void
public Swoole\Server::taskWaitMulti ( array $tasks , double $timeout_ms = ? ) : void
public Swoole\Server::tick ( int $interval_ms , callable $callback ) : void
}

预定义常量

Swoole\Redis\Server::NIL

Swoole\Redis\Server::ERROR

Swoole\Redis\Server::STATUS

Swoole\Redis\Server::INT

Swoole\Redis\Server::STRING

Swoole\Redis\Server::SET

Swoole\Redis\Server::MAP

Table of Contents

  • Swoole\Redis\Server::format — Description
  • Swoole\Redis\Server::setHandler — Description
  • Swoole\Redis\Server::start — Description


Description

  • ? Swoole\Redis\Server
  • Swoole\Redis\Server::setHandler ?
  • PHP Manual
  • Swoole\Redis\Server
  • Description

Swoole\Redis\Server::format

(PECL swoole >= 1.9.0)

Swoole\Redis\Server::format — Description

说明

public static Swoole\Redis\Server::format ( string $type , string $value = ? ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

type

value

返回值


Description

  • ? Swoole\Redis\Server::format
  • Swoole\Redis\Server::start ?
  • PHP Manual
  • Swoole\Redis\Server
  • Description

Swoole\Redis\Server::setHandler

(PECL swoole >= 1.9.0)

Swoole\Redis\Server::setHandler — Description

说明

public Swoole\Redis\Server::setHandler ( string $command , string $callback , string $number_of_string_param = ? , string $type_of_array_param = ? ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

command

callback

number_of_string_param

type_of_array_param

返回值


Description

  • ? Swoole\Redis\Server::setHandler
  • Swoole\Serialize ?
  • PHP Manual
  • Swoole\Redis\Server
  • Description

Swoole\Redis\Server::start

(PECL swoole >= 1.9.0)

Swoole\Redis\Server::start — Description

说明

public Swoole\Redis\Server::start ( ) : ReturnType

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Swoole\Serialize class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Serialize {
/* 方法 */
public static pack ( string $data , int $is_fast = ? ) : ReturnType
public static unpack ( string $data , string $args = ? ) : ReturnType
}

Table of Contents

  • Swoole\Serialize::pack — Serialize the data.
  • Swoole\Serialize::unpack — Unserialize the data.


Serialize the data.

  • ? Swoole\Serialize
  • Swoole\Serialize::unpack ?
  • PHP Manual
  • Swoole\Serialize
  • Serialize the data.

Swoole\Serialize::pack

(PECL swoole >= 1.9.0)

Swoole\Serialize::pack — Serialize the data.

说明

public static Swoole\Serialize::pack ( string $data , int $is_fast = ? ) : ReturnType

Swoole provides a fast and high performance serialization module.

参数

data

is_fast

返回值


Unserialize the data.

  • ? Swoole\Serialize::pack
  • Swoole\Server ?
  • PHP Manual
  • Swoole\Serialize
  • Unserialize the data.

Swoole\Serialize::unpack

(PECL swoole >= 1.9.0)

Swoole\Serialize::unpack — Unserialize the data.

说明

public static Swoole\Serialize::unpack ( string $data , string $args = ? ) : ReturnType

Unserialize the data.

参数

string

args

返回值


The Swoole\Server class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Server {
/* 方法 */
public addlistener ( string $host , int $port , string $socket_type ) : void
public addProcess ( swoole_process $process ) : bool
public after ( int $after_time_ms , callable $callback , string $param = ? ) : ReturnType
public bind ( int $fd , int $uid ) : bool
public clearTimer ( int $timer_id ) : void
swoole_timer_clear ( int $timer_id ) : void
public close ( int $fd , bool $reset = ? ) : bool
public confirm ( int $fd ) : bool
public connection_info ( int $fd , int $reactor_id = ? ) : array
public connection_list ( int $start_fd , int $pagesize = ? ) : array
public defer ( callable $callback ) : void
public Swoole\Server\Port::__destruct ( ) : void
public Swoole\Server\Port::on ( string $event_name , callable $callback ) : ReturnType
public Swoole\Server\Port::set ( array $settings ) : void
public exist ( int $fd ) : bool
public finish ( string $data ) : void
public getClientInfo ( int $fd , int $reactor_id = ? ) : ReturnType
public getClientList ( int $start_fd , int $pagesize = ? ) : array
public getLastError ( ) : int
public heartbeat ( bool $if_close_connection ) : mixed
public listen ( string $host , int $port , string $socket_type ) : bool
public on ( string $event_name , callable $callback ) : void
public pause ( int $fd ) : void
public protect ( int $fd , bool $is_protected = ? ) : void
public reload ( ) : bool
public resume ( int $fd ) : void
public send ( int $fd , string $data , int $reactor_id = ? ) : bool
public sendfile ( int $fd , string $filename , int $offset = ? ) : bool
public sendMessage ( int $worker_id , string $data ) : bool
public sendto ( string $ip , int $port , string $data , string $server_socket = ? ) : bool
public sendwait ( int $fd , string $data ) : bool
public set ( array $settings ) : ReturnType
public shutdown ( ) : void
public start ( ) : void
public stats ( ) : array
public stop ( int $worker_id = ? ) : bool
public task ( string $data , int $dst_worker_id = ? , callable $callback = ? ) : mixed
public taskwait ( string $data , float $timeout = ? , int $worker_id = ? ) : void
public taskWaitMulti ( array $tasks , double $timeout_ms = ? ) : void
public tick ( int $interval_ms , callable $callback ) : void
}

Table of Contents

  • Swoole\Server::addlistener — Add a new listener to the server.
  • Swoole\Server::addProcess — Add a user defined swoole_process to the server.
  • Swoole\Server::after — Trigger a callback function after a period of time.
  • Swoole\Server::bind — Bind the connection to a user defined user ID.
  • Swoole\Server::clearTimer — Stop and destory a timer.
  • Swoole\Server::close — Close a connection to the client.
  • Swoole\Server::confirm — Check status of the connection.
  • Swoole\Server::connection_info — Get the connection info by file description.
  • Swoole\Server::connection_list — Get all of the established connections.
  • Swoole\Server::__construct — Construct a Swoole server.
  • Swoole\Server::defer — Delay execution of the callback function at the end of current EventLoop.
  • Swoole\Server\Port::__construct — Construct a server port
  • Swoole\Server\Port::__destruct — Destory server port
  • Swoole\Server\Port::on — Register callback functions by event.
  • Swoole\Server\Port::set — Set protocol of the server port.
  • Swoole\Server::exist — Check if the connection is existed.
  • Swoole\Server::finish — Used in task process for sending result to the worker process when the task is finished.
  • Swoole\Server::getClientInfo — Get the connection info by file description.
  • Swoole\Server::getClientList — Get all of the established connections.
  • Swoole\Server::getLastError — Get the error code of the most recent error.
  • Swoole\Server::heartbeat — Check all the connections on the server.
  • Swoole\Server::listen — Listen on the given IP and port, socket type.
  • Swoole\Server::on — Register a callback function by event name.
  • Swoole\Server::pause — Stop receiving data from the connection.
  • Swoole\Server::protect — Set the connection to be protected mode.
  • Swoole\Server::reload — Restart all the worker process.
  • Swoole\Server::resume — Start receving data from the connection.
  • Swoole\Server::send — Send data to the client.
  • Swoole\Server::sendfile — Send file to the connection.
  • Swoole\Server::sendMessage — Send message to worker processes by ID.
  • Swoole\Server::sendto — Send data to the remote UDP address.
  • Swoole\Server::sendwait — Send data to the remote socket in the blocking way.
  • Swoole\Server::set — Set the runtime settings of the swoole server.
  • Swoole\Server::shutdown — Shutdown the master server process, this function can be called in worker processes.
  • Swoole\Server::start — Start the Swoole server.
  • Swoole\Server::stats — Get the stats of the Swoole server.
  • Swoole\Server::stop — Stop the Swoole server.
  • Swoole\Server::task — Send data to the task worker processes.
  • Swoole\Server::taskwait — Send data to the task worker processes in blocking way.
  • Swoole\Server::taskWaitMulti — Execute multiple tasks concurrently.
  • Swoole\Server::tick — Repeats a given function at every given time-interval.


Add a new listener to the server.

  • ? Swoole\Server
  • Swoole\Server::addProcess ?
  • PHP Manual
  • Swoole\Server
  • Add a new listener to the server.

Swoole\Server::addlistener

(PECL swoole >= 1.9.0)

Swoole\Server::addlistener — Add a new listener to the server.

说明

public Swoole\Server::addlistener ( string $host , int $port , string $socket_type ) : void

参数

host

port

socket_type

返回值


Add a user defined swoole_process to the server.

  • ? Swoole\Server::addlistener
  • Swoole\Server::after ?
  • PHP Manual
  • Swoole\Server
  • Add a user defined swoole_process to the server.

Swoole\Server::addProcess

(PECL swoole >= 1.9.0)

Swoole\Server::addProcess — Add a user defined swoole_process to the server.

说明

public Swoole\Server::addProcess ( swoole_process $process ) : bool

参数

process

返回值


Trigger a callback function after a period of time.

  • ? Swoole\Server::addProcess
  • Swoole\Server::bind ?
  • PHP Manual
  • Swoole\Server
  • Trigger a callback function after a period of time.

Swoole\Server::after

(PECL swoole >= 1.9.0)

Swoole\Server::after — Trigger a callback function after a period of time.

说明

public Swoole\Server::after ( int $after_time_ms , callable $callback , string $param = ? ) : ReturnType

参数

after_time_ms

callback

param

返回值


Bind the connection to a user defined user ID.

  • ? Swoole\Server::after
  • Swoole\Server::clearTimer ?
  • PHP Manual
  • Swoole\Server
  • Bind the connection to a user defined user ID.

Swoole\Server::bind

(PECL swoole >= 1.9.0)

Swoole\Server::bind — Bind the connection to a user defined user ID.

说明

public Swoole\Server::bind ( int $fd , int $uid ) : bool

参数

fd

uid

返回值


Stop and destory a timer.

  • ? Swoole\Server::bind
  • Swoole\Server::close ?
  • PHP Manual
  • Swoole\Server
  • Stop and destory a timer.

Swoole\Server::clearTimer

swoole_timer_clear

(PECL swoole >= 1.9.0)

Swoole\Server::clearTimer -- swoole_timer_clear — Stop and destory a timer.

说明

面向对象风格 (method):

public Swoole\Server::clearTimer ( int $timer_id ) : void

过程化风格:

swoole_timer_clear ( int $timer_id ) : void

Stop and destory a timer

参数

timer_id

返回值


Close a connection to the client.

  • ? Swoole\Server::clearTimer
  • Swoole\Server::confirm ?
  • PHP Manual
  • Swoole\Server
  • Close a connection to the client.

Swoole\Server::close

(PECL swoole >= 1.9.0)

Swoole\Server::close — Close a connection to the client.

说明

public Swoole\Server::close ( int $fd , bool $reset = ? ) : bool

参数

fd

reset

返回值


Check status of the connection.

  • ? Swoole\Server::close
  • Swoole\Server::connection_info ?
  • PHP Manual
  • Swoole\Server
  • Check status of the connection.

Swoole\Server::confirm

(PECL swoole >= 1.9.0)

Swoole\Server::confirm — Check status of the connection.

说明

public Swoole\Server::confirm ( int $fd ) : bool

参数

fd

返回值


Get the connection info by file description.

  • ? Swoole\Server::confirm
  • Swoole\Server::connection_list ?
  • PHP Manual
  • Swoole\Server
  • Get the connection info by file description.

Swoole\Server::connection_info

(PECL swoole >= 1.9.0)

Swoole\Server::connection_info — Get the connection info by file description.

说明

public Swoole\Server::connection_info ( int $fd , int $reactor_id = ? ) : array

参数

fd

reactor_id

返回值


Get all of the established connections.

  • ? Swoole\Server::connection_info
  • Swoole\Server::__construct ?
  • PHP Manual
  • Swoole\Server
  • Get all of the established connections.

Swoole\Server::connection_list

(PECL swoole >= 1.9.0)

Swoole\Server::connection_list — Get all of the established connections.

说明

public Swoole\Server::connection_list ( int $start_fd , int $pagesize = ? ) : array

参数

start_fd

pagesize

返回值


Construct a Swoole server.

  • ? Swoole\Server::connection_list
  • Swoole\Server::defer ?
  • PHP Manual
  • Swoole\Server
  • Construct a Swoole server.

Swoole\Server::__construct

(PECL swoole >= 1.9.0)

Swoole\Server::__construct — Construct a Swoole server.

说明

public Swoole\Server::__construct ( string $host , int $port = ? , integr $mode = ? , int $sock_type = ? )

参数

host

port

mode

sock_type


Delay execution of the callback function at the end of current EventLoop.

  • ? Swoole\Server::__construct
  • Swoole\Server\Port::__construct ?
  • PHP Manual
  • Swoole\Server
  • Delay execution of the callback function at the end of current EventLoop.

Swoole\Server::defer

(PECL swoole >= 1.9.0)

Swoole\Server::defer — Delay execution of the callback function at the end of current EventLoop.

说明

public Swoole\Server::defer ( callable $callback ) : void

参数

callback

返回值


Construct a server port

  • ? Swoole\Server::defer
  • Swoole\Server\Port::__destruct ?
  • PHP Manual
  • Swoole\Server
  • Construct a server port

Swoole\Server\Port::__construct

(PECL swoole >= 1.9.0)

Swoole\Server\Port::__construct — Construct a server port

说明

private Swoole\Server\Port::__construct ( )

参数

此函数没有参数。


Destory server port

  • ? Swoole\Server\Port::__construct
  • Swoole\Server\Port::on ?
  • PHP Manual
  • Swoole\Server
  • Destory server port

Swoole\Server\Port::__destruct

(PECL swoole >= 1.9.0)

Swoole\Server\Port::__destruct — Destory server port

说明

public Swoole\Server\Port::__destruct ( ) : void

参数

此函数没有参数。

返回值


Register callback functions by event.

  • ? Swoole\Server\Port::__destruct
  • Swoole\Server\Port::set ?
  • PHP Manual
  • Swoole\Server
  • Register callback functions by event.

Swoole\Server\Port::on

(PECL swoole >= 1.9.0)

Swoole\Server\Port::on — Register callback functions by event.

说明

public Swoole\Server\Port::on ( string $event_name , callable $callback ) : ReturnType

参数

event_name

callback

返回值


Set protocol of the server port.

  • ? Swoole\Server\Port::on
  • Swoole\Server::exist ?
  • PHP Manual
  • Swoole\Server
  • Set protocol of the server port.

Swoole\Server\Port::set

(PECL swoole >= 1.9.0)

Swoole\Server\Port::set — Set protocol of the server port.

说明

public Swoole\Server\Port::set ( array $settings ) : void

参数

settings

返回值


Check if the connection is existed.

  • ? Swoole\Server\Port::set
  • Swoole\Server::finish ?
  • PHP Manual
  • Swoole\Server
  • Check if the connection is existed.

Swoole\Server::exist

(PECL swoole >= 1.9.0)

Swoole\Server::exist — Check if the connection is existed.

说明

public Swoole\Server::exist ( int $fd ) : bool

参数

fd

返回值


Used in task process for sending result to the worker process when the task is finished.

  • ? Swoole\Server::exist
  • Swoole\Server::getClientInfo ?
  • PHP Manual
  • Swoole\Server
  • Used in task process for sending result to the worker process when the task is finished.

Swoole\Server::finish

(PECL swoole >= 1.9.0)

Swoole\Server::finish — Used in task process for sending result to the worker process when the task is finished.

说明

public Swoole\Server::finish ( string $data ) : void

参数

data

返回值


Get the connection info by file description.

  • ? Swoole\Server::finish
  • Swoole\Server::getClientList ?
  • PHP Manual
  • Swoole\Server
  • Get the connection info by file description.

Swoole\Server::getClientInfo

(PECL swoole >= 1.9.0)

Swoole\Server::getClientInfo — Get the connection info by file description.

说明

public Swoole\Server::getClientInfo ( int $fd , int $reactor_id = ? ) : ReturnType

参数

fd

reactor_id

返回值


Get all of the established connections.

  • ? Swoole\Server::getClientInfo
  • Swoole\Server::getLastError ?
  • PHP Manual
  • Swoole\Server
  • Get all of the established connections.

Swoole\Server::getClientList

(PECL swoole >= 1.9.0)

Swoole\Server::getClientList — Get all of the established connections.

说明

public Swoole\Server::getClientList ( int $start_fd , int $pagesize = ? ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

start_fd

pagesize

返回值


Get the error code of the most recent error.

  • ? Swoole\Server::getClientList
  • Swoole\Server::heartbeat ?
  • PHP Manual
  • Swoole\Server
  • Get the error code of the most recent error.

Swoole\Server::getLastError

(PECL swoole >= 1.9.0)

Swoole\Server::getLastError — Get the error code of the most recent error.

说明

public Swoole\Server::getLastError ( ) : int

参数

此函数没有参数。

返回值


Check all the connections on the server.

  • ? Swoole\Server::getLastError
  • Swoole\Server::listen ?
  • PHP Manual
  • Swoole\Server
  • Check all the connections on the server.

Swoole\Server::heartbeat

(PECL swoole >= 1.9.0)

Swoole\Server::heartbeat — Check all the connections on the server.

说明

public Swoole\Server::heartbeat ( bool $if_close_connection ) : mixed

参数

if_close_connection

返回值


Listen on the given IP and port, socket type.

  • ? Swoole\Server::heartbeat
  • Swoole\Server::on ?
  • PHP Manual
  • Swoole\Server
  • Listen on the given IP and port, socket type.

Swoole\Server::listen

(PECL swoole >= 1.9.0)

Swoole\Server::listen — Listen on the given IP and port, socket type.

说明

public Swoole\Server::listen ( string $host , int $port , string $socket_type ) : bool

参数

host

port

socket_type

返回值


Register a callback function by event name.

  • ? Swoole\Server::listen
  • Swoole\Server::pause ?
  • PHP Manual
  • Swoole\Server
  • Register a callback function by event name.

Swoole\Server::on

(PECL swoole >= 1.9.0)

Swoole\Server::on — Register a callback function by event name.

说明

public Swoole\Server::on ( string $event_name , callable $callback ) : void

参数

event_name

callback

返回值


Stop receiving data from the connection.

  • ? Swoole\Server::on
  • Swoole\Server::protect ?
  • PHP Manual
  • Swoole\Server
  • Stop receiving data from the connection.

Swoole\Server::pause

(PECL swoole >= 1.9.0)

Swoole\Server::pause — Stop receiving data from the connection.

说明

public Swoole\Server::pause ( int $fd ) : void

参数

fd

返回值


Set the connection to be protected mode.

  • ? Swoole\Server::pause
  • Swoole\Server::reload ?
  • PHP Manual
  • Swoole\Server
  • Set the connection to be protected mode.

Swoole\Server::protect

(PECL swoole >= 1.9.0)

Swoole\Server::protect — Set the connection to be protected mode.

说明

public Swoole\Server::protect ( int $fd , bool $is_protected = ? ) : void

参数

fd

is_protected

返回值


Restart all the worker process.

  • ? Swoole\Server::protect
  • Swoole\Server::resume ?
  • PHP Manual
  • Swoole\Server
  • Restart all the worker process.

Swoole\Server::reload

(PECL swoole >= 1.9.0)

Swoole\Server::reload — Restart all the worker process.

说明

public Swoole\Server::reload ( ) : bool

参数

此函数没有参数。

返回值


Start receving data from the connection.

  • ? Swoole\Server::reload
  • Swoole\Server::send ?
  • PHP Manual
  • Swoole\Server
  • Start receving data from the connection.

Swoole\Server::resume

(PECL swoole >= 1.9.0)

Swoole\Server::resume — Start receving data from the connection.

说明

public Swoole\Server::resume ( int $fd ) : void

参数

fd

返回值


Send data to the client.

  • ? Swoole\Server::resume
  • Swoole\Server::sendfile ?
  • PHP Manual
  • Swoole\Server
  • Send data to the client.

Swoole\Server::send

(PECL swoole >= 1.9.0)

Swoole\Server::send — Send data to the client.

说明

public Swoole\Server::send ( int $fd , string $data , int $reactor_id = ? ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

fd

data

reactor_id

返回值


Send file to the connection.

  • ? Swoole\Server::send
  • Swoole\Server::sendMessage ?
  • PHP Manual
  • Swoole\Server
  • Send file to the connection.

Swoole\Server::sendfile

(PECL swoole >= 1.9.0)

Swoole\Server::sendfile — Send file to the connection.

说明

public Swoole\Server::sendfile ( int $fd , string $filename , int $offset = ? ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

fd

filename

offset

返回值


Send message to worker processes by ID.

  • ? Swoole\Server::sendfile
  • Swoole\Server::sendto ?
  • PHP Manual
  • Swoole\Server
  • Send message to worker processes by ID.

Swoole\Server::sendMessage

(PECL swoole >= 1.9.0)

Swoole\Server::sendMessage — Send message to worker processes by ID.

说明

public Swoole\Server::sendMessage ( int $worker_id , string $data ) : bool

参数

dst_worker_id

data

返回值


Send data to the remote UDP address.

  • ? Swoole\Server::sendMessage
  • Swoole\Server::sendwait ?
  • PHP Manual
  • Swoole\Server
  • Send data to the remote UDP address.

Swoole\Server::sendto

(PECL swoole >= 1.9.0)

Swoole\Server::sendto — Send data to the remote UDP address.

说明

public Swoole\Server::sendto ( string $ip , int $port , string $data , string $server_socket = ? ) : bool

参数

ip

port

data

server_socket

返回值


Send data to the remote socket in the blocking way.

  • ? Swoole\Server::sendto
  • Swoole\Server::set ?
  • PHP Manual
  • Swoole\Server
  • Send data to the remote socket in the blocking way.

Swoole\Server::sendwait

(PECL swoole >= 1.9.0)

Swoole\Server::sendwait — Send data to the remote socket in the blocking way.

说明

public Swoole\Server::sendwait ( int $fd , string $data ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

fd

data

返回值


Set the runtime settings of the swoole server.

  • ? Swoole\Server::sendwait
  • Swoole\Server::shutdown ?
  • PHP Manual
  • Swoole\Server
  • Set the runtime settings of the swoole server.

Swoole\Server::set

(PECL swoole >= 1.9.0)

Swoole\Server::set — Set the runtime settings of the swoole server.

说明

public Swoole\Server::set ( array $settings ) : ReturnType

Set the runtime settings of the swoole server. The settings can be accessed by $server->setting when the swoole server has started.

参数

settings

返回值


Shutdown the master server process, this function can be called in worker processes.

  • ? Swoole\Server::set
  • Swoole\Server::start ?
  • PHP Manual
  • Swoole\Server
  • Shutdown the master server process, this function can be called in worker processes.

Swoole\Server::shutdown

(PECL swoole >= 1.9.0)

Swoole\Server::shutdown — Shutdown the master server process, this function can be called in worker processes.

说明

public Swoole\Server::shutdown ( ) : void

参数

此函数没有参数。

返回值


Start the Swoole server.

  • ? Swoole\Server::shutdown
  • Swoole\Server::stats ?
  • PHP Manual
  • Swoole\Server
  • Start the Swoole server.

Swoole\Server::start

(PECL swoole >= 1.9.0)

Swoole\Server::start — Start the Swoole server.

说明

public Swoole\Server::start ( ) : void

参数

此函数没有参数。

返回值


Get the stats of the Swoole server.

  • ? Swoole\Server::start
  • Swoole\Server::stop ?
  • PHP Manual
  • Swoole\Server
  • Get the stats of the Swoole server.

Swoole\Server::stats

(PECL swoole >= 1.9.0)

Swoole\Server::stats — Get the stats of the Swoole server.

说明

public Swoole\Server::stats ( ) : array

参数

此函数没有参数。

返回值


Stop the Swoole server.

  • ? Swoole\Server::stats
  • Swoole\Server::task ?
  • PHP Manual
  • Swoole\Server
  • Stop the Swoole server.

Swoole\Server::stop

(PECL swoole >= 1.9.0)

Swoole\Server::stop — Stop the Swoole server.

说明

public Swoole\Server::stop ( int $worker_id = ? ) : bool

参数

worker_id

返回值


Send data to the task worker processes.

  • ? Swoole\Server::stop
  • Swoole\Server::taskwait ?
  • PHP Manual
  • Swoole\Server
  • Send data to the task worker processes.

Swoole\Server::task

(PECL swoole >= 1.9.0)

Swoole\Server::task — Send data to the task worker processes.

说明

public Swoole\Server::task ( string $data , int $dst_worker_id = ? , callable $callback = ? ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

data

dst_worker_id

callback

返回值


Send data to the task worker processes in blocking way.

  • ? Swoole\Server::task
  • Swoole\Server::taskWaitMulti ?
  • PHP Manual
  • Swoole\Server
  • Send data to the task worker processes in blocking way.

Swoole\Server::taskwait

(PECL swoole >= 1.9.0)

Swoole\Server::taskwait — Send data to the task worker processes in blocking way.

说明

public Swoole\Server::taskwait ( string $data , float $timeout = ? , int $worker_id = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

data

timeout

worker_id

返回值


Execute multiple tasks concurrently.

  • ? Swoole\Server::taskwait
  • Swoole\Server::tick ?
  • PHP Manual
  • Swoole\Server
  • Execute multiple tasks concurrently.

Swoole\Server::taskWaitMulti

(PECL swoole >= 1.9.0)

Swoole\Server::taskWaitMulti — Execute multiple tasks concurrently.

说明

public Swoole\Server::taskWaitMulti ( array $tasks , double $timeout_ms = ? ) : void

参数

tasks

timeout_ms

返回值


Repeats a given function at every given time-interval.

  • ? Swoole\Server::taskWaitMulti
  • Swoole\Table ?
  • PHP Manual
  • Swoole\Server
  • Repeats a given function at every given time-interval.

Swoole\Server::tick

(PECL swoole >= 1.9.0)

Swoole\Server::tick — Repeats a given function at every given time-interval.

说明

public Swoole\Server::tick ( int $interval_ms , callable $callback ) : void

参数

interval_ms

callback

返回值


The Swoole\Table class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Table implements Iterator , Countable {
/* Constants */
const int TYPE_INT = 1 ;
const int TYPE_STRING = 7 ;
const int TYPE_FLOAT = 6 ;
/* 方法 */
public column ( string $name , string $type , int $size = ? ) : ReturnType
public count ( ) : int
public create ( ) : void
public current ( ) : array
public decr ( string $key , string $column , int $decrby = ? ) : ReturnType
public del ( string $key ) : void
public destroy ( ) : void
public exist ( string $key ) : bool
public get ( string $row_key , string $column_key ) : int
public incr ( string $key , string $column , int $incrby = ? ) : void
public key ( ) : string
public next ( ) : ReturnType
public rewind ( ) : void
public set ( string $key , array $value ) : VOID
public valid ( ) : bool
}

预定义常量

Swoole\Table::TYPE_INT

Swoole\Table::TYPE_STRING

Swoole\Table::TYPE_FLOAT

Table of Contents

  • Swoole\Table::column — Set the data type and size of the columns.
  • Swoole\Table::__construct — Construct a Swoole memory table with fixed size.
  • Swoole\Table::count — Count the rows in the table, or count all the elements in the table if $mode = 1.
  • Swoole\Table::create — Create the swoole memory table.
  • Swoole\Table::current — Get the current row.
  • Swoole\Table::decr — Decrement the value in the Swoole table by $row_key and $column_key.
  • Swoole\Table::del — Delete a row in the Swoole table by $row_key.
  • Swoole\Table::destroy — Destroy the Swoole table.
  • Swoole\Table::exist — Check if a row is existed by $row_key.
  • Swoole\Table::get — Get the value in the Swoole table by $row_key and $column_key.
  • Swoole\Table::incr — Increment the value by $row_key and $column_key.
  • Swoole\Table::key — Get the key of current row.
  • Swoole\Table::next — Iterator the next row.
  • Swoole\Table::rewind — Rewind the iterator.
  • Swoole\Table::set — Update a row of the table by $row_key.
  • Swoole\Table::valid — Check current if the current row is valid.


Set the data type and size of the columns.

  • ? Swoole\Table
  • Swoole\Table::__construct ?
  • PHP Manual
  • Swoole\Table
  • Set the data type and size of the columns.

Swoole\Table::column

(PECL swoole >= 1.9.0)

Swoole\Table::column — Set the data type and size of the columns.

说明

public Swoole\Table::column ( string $name , string $type , int $size = ? ) : ReturnType

参数

name

type

size

返回值


Construct a Swoole memory table with fixed size.

  • ? Swoole\Table::column
  • Swoole\Table::count ?
  • PHP Manual
  • Swoole\Table
  • Construct a Swoole memory table with fixed size.

Swoole\Table::__construct

(PECL swoole >= 1.9.0)

Swoole\Table::__construct — Construct a Swoole memory table with fixed size.

说明

public Swoole\Table::__construct ( int $table_size )

参数

table_size


Count the rows in the table, or count all the elements in the table if $mode = 1.

  • ? Swoole\Table::__construct
  • Swoole\Table::create ?
  • PHP Manual
  • Swoole\Table
  • Count the rows in the table, or count all the elements in the table if $mode = 1.

Swoole\Table::count

(PECL swoole >= 1.9.0)

Swoole\Table::count — Count the rows in the table, or count all the elements in the table if $mode = 1.

说明

public Swoole\Table::count ( ) : int

参数

此函数没有参数。

返回值


Create the swoole memory table.

  • ? Swoole\Table::count
  • Swoole\Table::current ?
  • PHP Manual
  • Swoole\Table
  • Create the swoole memory table.

Swoole\Table::create

(PECL swoole >= 1.9.0)

Swoole\Table::create — Create the swoole memory table.

说明

public Swoole\Table::create ( ) : void

参数

此函数没有参数。

返回值


Get the current row.

  • ? Swoole\Table::create
  • Swoole\Table::decr ?
  • PHP Manual
  • Swoole\Table
  • Get the current row.

Swoole\Table::current

(PECL swoole >= 1.9.0)

Swoole\Table::current — Get the current row.

说明

public Swoole\Table::current ( ) : array

参数

此函数没有参数。

返回值


Decrement the value in the Swoole table by $row_key and $column_key.

  • ? Swoole\Table::current
  • Swoole\Table::del ?
  • PHP Manual
  • Swoole\Table
  • Decrement the value in the Swoole table by $row_key and $column_key.

Swoole\Table::decr

(PECL swoole >= 1.9.0)

Swoole\Table::decr — Decrement the value in the Swoole table by $row_key and $column_key.

说明

public Swoole\Table::decr ( string $key , string $column , int $decrby = ? ) : ReturnType

参数

key

column

decrby

返回值


Delete a row in the Swoole table by $row_key.

  • ? Swoole\Table::decr
  • Swoole\Table::destroy ?
  • PHP Manual
  • Swoole\Table
  • Delete a row in the Swoole table by $row_key.

Swoole\Table::del

(PECL swoole >= 1.9.0)

Swoole\Table::del — Delete a row in the Swoole table by $row_key.

说明

public Swoole\Table::del ( string $key ) : void

参数

key

返回值


Destroy the Swoole table.

  • ? Swoole\Table::del
  • Swoole\Table::exist ?
  • PHP Manual
  • Swoole\Table
  • Destroy the Swoole table.

Swoole\Table::destroy

(PECL swoole >= 1.9.0)

Swoole\Table::destroy — Destroy the Swoole table.

说明

public Swoole\Table::destroy ( ) : void

参数

此函数没有参数。

返回值


Check if a row is existed by $row_key.

  • ? Swoole\Table::destroy
  • Swoole\Table::get ?
  • PHP Manual
  • Swoole\Table
  • Check if a row is existed by $row_key.

Swoole\Table::exist

(PECL swoole >= 1.9.0)

Swoole\Table::exist — Check if a row is existed by $row_key.

说明

public Swoole\Table::exist ( string $key ) : bool

参数

key

返回值


Get the value in the Swoole table by $row_key and $column_key.

  • ? Swoole\Table::exist
  • Swoole\Table::incr ?
  • PHP Manual
  • Swoole\Table
  • Get the value in the Swoole table by $row_key and $column_key.

Swoole\Table::get

(PECL swoole >= 1.9.0)

Swoole\Table::get — Get the value in the Swoole table by $row_key and $column_key.

说明

public Swoole\Table::get ( string $row_key , string $column_key ) : int

参数

row_key

column_key

返回值


Increment the value by $row_key and $column_key.

  • ? Swoole\Table::get
  • Swoole\Table::key ?
  • PHP Manual
  • Swoole\Table
  • Increment the value by $row_key and $column_key.

Swoole\Table::incr

(PECL swoole >= 1.9.0)

Swoole\Table::incr — Increment the value by $row_key and $column_key.

说明

public Swoole\Table::incr ( string $key , string $column , int $incrby = ? ) : void

参数

key

column

incrby

返回值


Get the key of current row.

  • ? Swoole\Table::incr
  • Swoole\Table::next ?
  • PHP Manual
  • Swoole\Table
  • Get the key of current row.

Swoole\Table::key

(PECL swoole >= 1.9.0)

Swoole\Table::key — Get the key of current row.

说明

public Swoole\Table::key ( ) : string

参数

此函数没有参数。

返回值


Iterator the next row.

  • ? Swoole\Table::key
  • Swoole\Table::rewind ?
  • PHP Manual
  • Swoole\Table
  • Iterator the next row.

Swoole\Table::next

(PECL swoole >= 1.9.0)

Swoole\Table::next — Iterator the next row.

说明

public Swoole\Table::next ( ) : ReturnType

参数

此函数没有参数。

返回值


Rewind the iterator.

  • ? Swoole\Table::next
  • Swoole\Table::set ?
  • PHP Manual
  • Swoole\Table
  • Rewind the iterator.

Swoole\Table::rewind

(PECL swoole >= 1.9.0)

Swoole\Table::rewind — Rewind the iterator.

说明

public Swoole\Table::rewind ( ) : void

参数

此函数没有参数。

返回值


Update a row of the table by $row_key.

  • ? Swoole\Table::rewind
  • Swoole\Table::valid ?
  • PHP Manual
  • Swoole\Table
  • Update a row of the table by $row_key.

Swoole\Table::set

(PECL swoole >= 1.9.0)

Swoole\Table::set — Update a row of the table by $row_key.

说明

public Swoole\Table::set ( string $key , array $value ) : VOID

参数

key

value

返回值


Check current if the current row is valid.

  • ? Swoole\Table::set
  • Swoole\Timer ?
  • PHP Manual
  • Swoole\Table
  • Check current if the current row is valid.

Swoole\Table::valid

(PECL swoole >= 1.9.0)

Swoole\Table::valid — Check current if the current row is valid.

说明

public Swoole\Table::valid ( ) : bool

参数

此函数没有参数。

返回值


The Swoole\Timer class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\Timer {
/* 方法 */
public static after ( int $after_time_ms , callable $callback ) : void
public static clear ( int $timer_id ) : void
public static exists ( int $timer_id ) : bool
public static tick ( int $interval_ms , callable $callback , string $param = ? ) : void
}

Table of Contents

  • Swoole\Timer::after — Trigger a callback function after a period of time.
  • Swoole\Timer::clear — Delete a timer by timer ID.
  • Swoole\Timer::exists — Check if a timer is existed.
  • Swoole\Timer::tick — Repeats a given function at every given time-interval.


Trigger a callback function after a period of time.

  • ? Swoole\Timer
  • Swoole\Timer::clear ?
  • PHP Manual
  • Swoole\Timer
  • Trigger a callback function after a period of time.

Swoole\Timer::after

(PECL swoole >= 1.9.0)

Swoole\Timer::after — Trigger a callback function after a period of time.

说明

public static Swoole\Timer::after ( int $after_time_ms , callable $callback ) : void

Trigger a callback function after a period of time.

参数

after_time_ms

callback

返回值


Delete a timer by timer ID.

  • ? Swoole\Timer::after
  • Swoole\Timer::exists ?
  • PHP Manual
  • Swoole\Timer
  • Delete a timer by timer ID.

Swoole\Timer::clear

(PECL swoole >= 1.9.0)

Swoole\Timer::clear — Delete a timer by timer ID.

说明

public static Swoole\Timer::clear ( int $timer_id ) : void

Delete a timer by timer ID.

参数

timer_id

返回值


Check if a timer is existed.

  • ? Swoole\Timer::clear
  • Swoole\Timer::tick ?
  • PHP Manual
  • Swoole\Timer
  • Check if a timer is existed.

Swoole\Timer::exists

(PECL swoole >= 1.9.0)

Swoole\Timer::exists — Check if a timer is existed.

说明

public static Swoole\Timer::exists ( int $timer_id ) : bool

Check if a timer is existed.

参数

timer_id

返回值


Repeats a given function at every given time-interval.

  • ? Swoole\Timer::exists
  • Swoole\WebSocket\Frame ?
  • PHP Manual
  • Swoole\Timer
  • Repeats a given function at every given time-interval.

Swoole\Timer::tick

(PECL swoole >= 1.9.0)

Swoole\Timer::tick — Repeats a given function at every given time-interval.

说明

public static Swoole\Timer::tick ( int $interval_ms , callable $callback , string $param = ? ) : void

参数

interval_ms

callback

param

返回值


  • ? Swoole\Timer::tick
  • Swoole\WebSocket\Server ?
  • PHP Manual
  • Swoole
  • The Swoole\WebSocket\Frame class

The Swoole\WebSocket\Frame class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\WebSocket\Frame {
/* 方法 */
}


The Swoole\WebSocket\Server class

(PECL swoole >= 1.9.0)

简介

类摘要

Swoole\WebSocket\Server extends Swoole\Http\Server {
/* 方法 */
public exist ( int $fd ) : bool
public on ( string $event_name , callable $callback ) : ReturnType
public static pack ( string $data , string $opcode = ? , string $finish = ? , string $mask = ? ) : binary
public push ( string $fd , string $data , string $opcode = ? , string $finish = ? ) : void
public static unpack ( binary $data ) : string
/* 继承的方法 */
public Swoole\Http\Server::on ( string $event_name , callable $callback ) : void
public Swoole\Http\Server::start ( ) : void
}

Table of Contents

  • Swoole\WebSocket\Server::exist — Check if the file descriptor exists.
  • Swoole\WebSocket\Server::on — Register event callback function
  • Swoole\WebSocket\Server::pack — Get a pack of binary data to send in a single frame.
  • Swoole\WebSocket\Server::push — Push data to the remote client.
  • Swoole\WebSocket\Server::unpack — Unpack the binary data received from the client.


Check if the file descriptor exists.

  • ? Swoole\WebSocket\Server
  • Swoole\WebSocket\Server::on ?
  • PHP Manual
  • Swoole\WebSocket\Server
  • Check if the file descriptor exists.

Swoole\WebSocket\Server::exist

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::exist — Check if the file descriptor exists.

说明

public Swoole\WebSocket\Server::exist ( int $fd ) : bool

参数

fd

返回值


Register event callback function

  • ? Swoole\WebSocket\Server::exist
  • Swoole\WebSocket\Server::pack ?
  • PHP Manual
  • Swoole\WebSocket\Server
  • Register event callback function

Swoole\WebSocket\Server::on

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::on — Register event callback function

说明

public Swoole\WebSocket\Server::on ( string $event_name , callable $callback ) : ReturnType

Register event callback function

参数

event_name

callback

返回值


Get a pack of binary data to send in a single frame.

  • ? Swoole\WebSocket\Server::on
  • Swoole\WebSocket\Server::push ?
  • PHP Manual
  • Swoole\WebSocket\Server
  • Get a pack of binary data to send in a single frame.

Swoole\WebSocket\Server::pack

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::pack — Get a pack of binary data to send in a single frame.

说明

public static Swoole\WebSocket\Server::pack ( string $data , string $opcode = ? , string $finish = ? , string $mask = ? ) : binary

参数

data

opcode

finish

mask

返回值


Push data to the remote client.

  • ? Swoole\WebSocket\Server::pack
  • Swoole\WebSocket\Server::unpack ?
  • PHP Manual
  • Swoole\WebSocket\Server
  • Push data to the remote client.

Swoole\WebSocket\Server::push

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::push — Push data to the remote client.

说明

public Swoole\WebSocket\Server::push ( string $fd , string $data , string $opcode = ? , string $finish = ? ) : void

参数

fd

data

opcode

finish

返回值


Unpack the binary data received from the client.

  • ? Swoole\WebSocket\Server::push
  • Tidy ?
  • PHP Manual
  • Swoole\WebSocket\Server
  • Unpack the binary data received from the client.

Swoole\WebSocket\Server::unpack

(PECL swoole >= 1.9.0)

Swoole\WebSocket\Server::unpack — Unpack the binary data received from the client.

说明

public static Swoole\WebSocket\Server::unpack ( binary $data ) : string

参数

data

返回值


Tidy

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Tidy example
  • tidy — The tidy class
    • tidy::body — Returns a tidyNode object starting from the <body> tag of the tidy parse tree
    • tidy::cleanRepair — Execute configured cleanup and repair operations on parsed markup
    • tidy::__construct — Constructs a new tidy object
    • tidy::diagnose — Run configured diagnostics on parsed and repaired markup
    • tidy::$errorBuffer — Return warnings and errors which occurred parsing the specified document
    • tidy::getConfig — Get current Tidy configuration
    • tidy::getHtmlVer — Get the Detected HTML version for the specified document
    • tidy::getOpt — Returns the value of the specified configuration option for the tidy document
    • tidy::getOptDoc — Returns the documentation for the given option name
    • tidy::getRelease — Get release date (version) for Tidy library
    • tidy::getStatus — Get status of specified document
    • tidy::head — Returns a tidyNode object starting from the <head> tag of the tidy parse tree
    • tidy::html — Returns a tidyNode object starting from the <html> tag of the tidy parse tree
    • tidy::isXhtml — Indicates if the document is a XHTML document
    • tidy::isXml — Indicates if the document is a generic (non HTML/XHTML) XML document
    • tidy::parseFile — Parse markup in file or URI
    • tidy::parseString — Parse a document stored in a string
    • tidy::repairFile — Repair a file and return it as a string
    • tidy::repairString — Repair a string using an optionally provided configuration file
    • tidy::root — Returns a tidyNode object representing the root of the tidy parse tree
  • tidyNode — The tidyNode class
    • tidyNode::__construct — Private constructor to disallow direct instantiation
    • tidyNode::getParent — Returns the parent node of the current node
    • tidyNode::hasChildren — Checks if a node has children
    • tidyNode::hasSiblings — Checks if a node has siblings
    • tidyNode::isAsp — Checks if this node is ASP
    • tidyNode::isComment — Checks if a node represents a comment
    • tidyNode::isHtml — Checks if a node is an element node
    • tidyNode::isJste — Checks if this node is JSTE
    • tidyNode::isPhp — Checks if a node is PHP
    • tidyNode::isText — Checks if a node represents text (no markup)
  • Tidy 函数
    • ob_tidyhandler — ob_start callback function to repair the buffer
    • tidy_access_count — Returns the Number of Tidy accessibility warnings encountered for specified document
    • tidy_config_count — Returns the Number of Tidy configuration errors encountered for specified document
    • tidy_error_count — Returns the Number of Tidy errors encountered for specified document
    • tidy_get_output — Return a string representing the parsed tidy markup
    • tidy_warning_count — Returns the Number of Tidy warnings encountered for specified document


简介

Tidy is a binding for the Tidy HTML clean and repair utility which allows you to not only clean and otherwise manipulate HTML, XHTML, and XML documents, but also traverse the document tree, including ones with embedded scripting languages such as PHP or ASP within them using object oriented constructs.


需求

To use Tidy, you will need libtidy installed, available on the » tidy homepage. As of PHP 7.1.0, the HTML5 aware successor » libtidy5 can be used alternatively. As of PHP 7.3.0, another option is to use » libtidyp.


安装

This extension is bundled with PHP 5 and greater, and is installed using the --with-tidy configure option.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Tidy Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
tidy.default_config | "" | PHP_INI_SYSTEM |
tidy.clean_output | "0" | PHP_INI_USER | PHP_INI_PERDIR prior to PHP 5.4.0
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

tidy.default_config string

Default path for tidy config file.

tidy.clean_output bool

Turns on/off the output repairing by Tidy.

Warning

Do not turn on tidy.clean_output if you are generating non-html content such as dynamic images.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Each TIDY_TAG_XXX represents a HTML tag. For example, TIDY_TAG_A represents a "<a href="XX">link</a>" tag.

The following constants are defined:

tidy tag constants
Constant | Notes
TIDY_TAG_UNKNOWN |
TIDY_TAG_A |
TIDY_TAG_ABBR |
TIDY_TAG_ACRONYM |
TIDY_TAG_ALIGN |
TIDY_TAG_APPLET |
TIDY_TAG_AREA |
TIDY_TAG_ARTICLE | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_ASIDE | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_AUDIO | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_B |
TIDY_TAG_BASE |
TIDY_TAG_BASEFONT |
TIDY_TAG_BDI | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_BDO |
TIDY_TAG_BGSOUND |
TIDY_TAG_BIG |
TIDY_TAG_BLINK |
TIDY_TAG_BLOCKQUOTE |
TIDY_TAG_BODY |
TIDY_TAG_BR |
TIDY_TAG_BUTTON |
TIDY_TAG_CANVAS | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_CAPTION |
TIDY_TAG_CENTER |
TIDY_TAG_CITE |
TIDY_TAG_CODE |
TIDY_TAG_COL |
TIDY_TAG_COLGROUP |
TIDY_TAG_COMMAND | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_COMMENT |
TIDY_TAG_DATALIST | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_DD |
TIDY_TAG_DEL |
TIDY_TAG_DETAILS | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_DFN |
TIDY_TAG_DIALOG | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_DIR |
TIDY_TAG_DIV |
TIDY_TAG_DL |
TIDY_TAG_DT |
TIDY_TAG_EM |
TIDY_TAG_EMBED |
TIDY_TAG_FIELDSET |
TIDY_TAG_FIGCAPTION | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_FIGURE | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_FONT |
TIDY_TAG_FOOTER | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_FORM |
TIDY_TAG_FRAME |
TIDY_TAG_FRAMESET |
TIDY_TAG_H1 |
TIDY_TAG_H2 |
TIDY_TAG_H3 |
TIDY_TAG_H4 |
TIDY_TAG_H5 |
TIDY_TAG_H6 |
TIDY_TAG_HEAD |
TIDY_TAG_HEADER | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_HGROUP | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_HR |
TIDY_TAG_HTML |
TIDY_TAG_I |
TIDY_TAG_IFRAME |
TIDY_TAG_ILAYER |
TIDY_TAG_IMG |
TIDY_TAG_INPUT |
TIDY_TAG_INS |
TIDY_TAG_ISINDEX |
TIDY_TAG_KBD |
TIDY_TAG_KEYGEN |
TIDY_TAG_LABEL |
TIDY_TAG_LAYER |
TIDY_TAG_LEGEND |
TIDY_TAG_LI |
TIDY_TAG_LINK |
TIDY_TAG_LISTING |
TIDY_TAG_MAIN | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_MAP |
TIDY_TAG_MARK | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_MARQUEE |
TIDY_TAG_MENU |
TIDY_TAG_MENUITEM | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_META |
TIDY_TAG_METER | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_MULTICOL |
TIDY_TAG_NAV | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_NOBR |
TIDY_TAG_NOEMBED |
TIDY_TAG_NOFRAMES |
TIDY_TAG_NOLAYER |
TIDY_TAG_NOSAVE |
TIDY_TAG_NOSCRIPT |
TIDY_TAG_OBJECT |
TIDY_TAG_OL |
TIDY_TAG_OPTGROUP |
TIDY_TAG_OPTION |
TIDY_TAG_OUTPUT | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_P |
TIDY_TAG_PARAM |
TIDY_TAG_PLAINTEXT |
TIDY_TAG_PRE |
TIDY_TAG_PROGRESS | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_Q |
TIDY_TAG_RB |
TIDY_TAG_RBC |
TIDY_TAG_RP |
TIDY_TAG_RT |
TIDY_TAG_RTC |
TIDY_TAG_RUBY |
TIDY_TAG_S |
TIDY_TAG_SAMP |
TIDY_TAG_SCRIPT |
TIDY_TAG_SECTION | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_SELECT |
TIDY_TAG_SERVER |
TIDY_TAG_SERVLET |
TIDY_TAG_SMALL |
TIDY_TAG_SOURCE | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_SPACER |
TIDY_TAG_SPAN |
TIDY_TAG_STRIKE |
TIDY_TAG_STRONG |
TIDY_TAG_STYLE |
TIDY_TAG_SUB |
TIDY_TAG_SUMMARY | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_SUP |
TIDY_TAG_TABLE |
TIDY_TAG_TBODY |
TIDY_TAG_TD |
TIDY_TAG_TEMPLATE | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_TEXTAREA |
TIDY_TAG_TFOOT |
TIDY_TAG_TH |
TIDY_TAG_THEAD |
TIDY_TAG_TIME | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_TITLE |
TIDY_TAG_TR |
TIDY_TAG_TRACK | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_TT |
TIDY_TAG_U |
TIDY_TAG_UL |
TIDY_TAG_VAR |
TIDY_TAG_VIDEO | Added in libtidy 5.0.0. Available as of PHP 7.4.0.
TIDY_TAG_WBR |
TIDY_TAG_XMP |

tidy nodetype constants
constant | description
TIDY_NODETYPE_ROOT | root node
TIDY_NODETYPE_DOCTYPE | doctype
TIDY_NODETYPE_COMMENT | HTML comment
TIDY_NODETYPE_PROCINS | Processing Instruction
TIDY_NODETYPE_TEXT | Text
TIDY_NODETYPE_START | start tag
TIDY_NODETYPE_END | end tag
TIDY_NODETYPE_STARTEND | empty tag
TIDY_NODETYPE_CDATA | CDATA
TIDY_NODETYPE_SECTION | XML section
TIDY_NODETYPE_ASP | ASP code
TIDY_NODETYPE_JSTE | JSTE code
TIDY_NODETYPE_PHP | PHP code
TIDY_NODETYPE_XMLDECL | XML declaration


  • ? 预定义常量
  • Tidy example ?
  • PHP Manual
  • Tidy
  • 范例

范例

Table of Contents

  • Tidy example


Tidy example

This simple example shows basic Tidy usage.

Example #1 Basic Tidy usage

<?php
ob_start();
?>
<html>a html document</html>
<?php
$html = ob_get_clean();

// Specify configuration
$config = array(
           'indent'         => true,
           'output-xhtml'   => true,
           'wrap'           => 200);

// Tidy
$tidy = new tidy;
$tidy->parseString($html, $config, 'utf8');
$tidy->cleanRepair();

// Output
echo $tidy;
?>


The tidy class

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

简介

An HTML node in an HTML file, as detected by tidy.

类摘要

tidy {
/* 属性 */
public string $errorBuffer;
/* 方法 */
public __construct ( string|null $filename = null , array|string|null $config = null , string|null $encoding = null , bool $useIncludePath = false )
public body ( ) : tidyNode|null
public cleanRepair ( ) : bool
public diagnose ( ) : bool
tidy_get_error_buffer ( tidy $tidy ) : string|false
public getConfig ( ) : array
public getHtmlVer ( ) : int
public getOpt ( string $option ) : string|int|bool
public getOptDoc ( string $option ) : string|false
public getRelease ( ) : string
public getStatus ( ) : int
public head ( ) : tidyNode|null
public html ( ) : tidyNode|null
public isXhtml ( ) : bool
public isXml ( ) : bool
public parseFile ( string $filename , array|string|null $config = null , string|null $encoding = null , bool $useIncludePath = false ) : bool
public parseString ( string $string , array|string|null $config = null , string|null $encoding = null ) : bool
public static repairFile ( string $filename , array|string|null $config = null , string|null $encoding = null , bool $useIncludePath = false ) : string|false
public static repairString ( string $string , array|string|null $config = null , string|null $encoding = null ) : string|false
public root ( ) : tidyNode|null
}

Table of Contents

  • tidy::body — Returns a tidyNode object starting from the <body> tag of the tidy parse tree
  • tidy::cleanRepair — Execute configured cleanup and repair operations on parsed markup
  • tidy::__construct — Constructs a new tidy object
  • tidy::diagnose — Run configured diagnostics on parsed and repaired markup
  • tidy::$errorBuffer — Return warnings and errors which occurred parsing the specified document
  • tidy::getConfig — Get current Tidy configuration
  • tidy::getHtmlVer — Get the Detected HTML version for the specified document
  • tidy::getOpt — Returns the value of the specified configuration option for the tidy document
  • tidy::getOptDoc — Returns the documentation for the given option name
  • tidy::getRelease — Get release date (version) for Tidy library
  • tidy::getStatus — Get status of specified document
  • tidy::head — Returns a tidyNode object starting from the <head> tag of the tidy parse tree
  • tidy::html — Returns a tidyNode object starting from the <html> tag of the tidy parse tree
  • tidy::isXhtml — Indicates if the document is a XHTML document
  • tidy::isXml — Indicates if the document is a generic (non HTML/XHTML) XML document
  • tidy::parseFile — Parse markup in file or URI
  • tidy::parseString — Parse a document stored in a string
  • tidy::repairFile — Repair a file and return it as a string
  • tidy::repairString — Repair a string using an optionally provided configuration file
  • tidy::root — Returns a tidyNode object representing the root of the tidy parse tree


Returns a tidyNode object starting from the <body> tag of the tidy parse tree

  • ? tidy
  • tidy::cleanRepair ?
  • PHP Manual
  • tidy
  • Returns a tidyNode object starting from the <body> tag of the tidy parse tree

tidy::body

tidy_get_body

(PHP 5, PHP 7, PHP 8, PECL tidy 0.5.2-1.0)

tidy::body -- tidy_get_body — Returns a tidyNode object starting from the <body> tag of the tidy parse tree

说明

面向对象风格

public tidy::body ( ) : tidyNode|null

过程化风格

tidy_get_body ( tidy $tidy ) : tidyNode|null

Returns a tidyNode object starting from the <body> tag of the tidy parse tree.

参数

tidy

The Tidy 对象。

返回值

Returns a tidyNode object starting from the <body> tag of the tidy parse tree.

范例

Example #1 tidy::getBody() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$body = $tidy->Body();
echo $body->value;
?>

以上例程会输出：

<body>
<p>paragraph</p>
</body>

参见

  • tidy::head() - Returns a tidyNode object starting from the <head> tag of the tidy parse tree
  • tidy::html() - Returns a tidyNode object starting from the <html> tag of the tidy parse tree


Execute configured cleanup and repair operations on parsed markup

  • ? tidy::body
  • tidy::__construct ?
  • PHP Manual
  • tidy
  • Execute configured cleanup and repair operations on parsed markup

tidy::cleanRepair

tidy_clean_repair

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::cleanRepair -- tidy_clean_repair — Execute configured cleanup and repair operations on parsed markup

说明

面向对象风格

public tidy::cleanRepair ( ) : bool

过程化风格

tidy_clean_repair ( tidy $tidy ) : bool

This function cleans and repairs the given tidy tidy.

参数

tidy

The Tidy 对象。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 tidy::cleanrepair() example

<?php
$html = '<p>test</I>';

$tidy = tidy_parse_string($html);
$tidy->cleanRepair();

echo $tidy;
?>

以上例程会输出：

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

参见

  • tidy::repairFile() - Repair a file and return it as a string
  • tidy::repairString() - Repair a string using an optionally provided configuration file


Constructs a new tidy object

  • ? tidy::cleanRepair
  • tidy::diagnose ?
  • PHP Manual
  • tidy
  • Constructs a new tidy object

tidy::__construct

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::__construct — Constructs a new tidy object

说明

public tidy::__construct ( string|null $filename = null , array|string|null $config = null , string|null $encoding = null , bool $useIncludePath = false )

Constructs a new tidy object.

参数

filename

If the filename parameter is given, this function will also read that file and initialize the object with the file, acting like tidy_parse_file().

config

The config config can be passed either as an array or as a string. If a string is passed, it is interpreted as the name of the configuration file, otherwise, it is interpreted as the options themselves.

For an explanation about each option, visit » http://api.html-tidy.org/#quick-reference.

encoding

The encoding parameter sets the encoding for input/output documents. The possible values for encoding are: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, and shiftjis.

useIncludePath

Search for the file in the include_path.

返回值

Returns the new tidy instance.

更新日志

版本 | 说明
8.0.0 | filename, config, encoding and useIncludePath are nullable now.

范例

Example #1 tidy::__construct() example

<?php

$html = <<< HTML

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head><title>title</title></head>
<body>
<p>paragraph <bt />
text</p>
</body></html>

HTML;

$tidy = new tidy();
$tidy->ParseString($html);

$tidy->cleanRepair();

if ($tidy->errorBuffer) {
    echo "The following errors were detected:\n";
    echo $tidy->errorBuffer;
}

?>

以上例程会输出：

The following errors were detected:
line 8 column 14 - Error: <bt> is not recognized!
line 8 column 14 - Warning: discarding unexpected <bt>

参见

  • tidy::parseFile() - Parse markup in file or URI
  • tidy::parseString() - Parse a document stored in a string


Run configured diagnostics on parsed and repaired markup

  • ? tidy::__construct
  • tidy::$errorBuffer ?
  • PHP Manual
  • tidy
  • Run configured diagnostics on parsed and repaired markup

tidy::diagnose

tidy_diagnose

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::diagnose -- tidy_diagnose — Run configured diagnostics on parsed and repaired markup

说明

面向对象风格

public tidy::diagnose ( ) : bool

过程化风格

tidy_diagnose ( tidy $tidy ) : bool

Runs diagnostic tests on the given tidy tidy, adding some more information about the document in the error buffer.

参数

tidy

The Tidy 对象。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 tidy::diagnose() example

<?php

$html = <<< HTML
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<p>paragraph</p>
HTML;

$tidy = tidy_parse_string($html);
$tidy->cleanRepair();

// note the difference between the two outputs
echo $tidy->errorBuffer . "\n";

$tidy->diagnose();
echo $tidy->errorBuffer;

?>

以上例程会输出：

line 4 column 1 - Warning: <p> isn't allowed in <head> elements
line 4 column 1 - Warning: inserting missing 'title' element
line 4 column 1 - Warning: <p> isn't allowed in <head> elements
line 4 column 1 - Warning: inserting missing 'title' element
Info: Doctype given is "-//W3C//DTD XHTML 1.0 Strict//EN"
Info: Document content looks like XHTML 1.0 Strict
2 warnings, 0 errors were found!

参见

  • tidy::errorBuffer()


Return warnings and errors which occurred parsing the specified document

  • ? tidy::diagnose
  • tidy::getConfig ?
  • PHP Manual
  • tidy
  • Return warnings and errors which occurred parsing the specified document

tidy::$errorBuffer

tidy_get_error_buffer

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::$errorBuffer -- tidy_get_error_buffer — Return warnings and errors which occurred parsing the specified document

说明

面向对象风格 (property):

public string $tidy->errorBuffer;

过程化风格:

tidy_get_error_buffer ( tidy $tidy ) : string|false

Returns warnings and errors which occurred parsing the specified document.

参数

tidy

The Tidy 对象。

返回值

Returns the error buffer as a string, or false if the buffer is empty.

范例

Example #1 tidy_get_error_buffer() example

<?php
$html = '<p>paragraph</p>';

$tidy = tidy_parse_string($html);

echo tidy_get_error_buffer($tidy);
/* or in OO: */
echo $tidy->errorBuffer;
?>

以上例程会输出：

line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 1 - Warning: inserting missing 'title' element

参见

  • tidy_access_count() - Returns the Number of Tidy accessibility warnings encountered for specified document
  • tidy_error_count() - Returns the Number of Tidy errors encountered for specified document
  • tidy_warning_count() - Returns the Number of Tidy warnings encountered for specified document


Get current Tidy configuration

  • ? tidy::$errorBuffer
  • tidy::getHtmlVer ?
  • PHP Manual
  • tidy
  • Get current Tidy configuration

tidy::getConfig

tidy_get_config

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.7.0)

tidy::getConfig -- tidy_get_config — Get current Tidy configuration

说明

面向对象风格

public tidy::getConfig ( ) : array

过程化风格

tidy_get_config ( tidy $tidy ) : array

Gets the list of the configuration options in use by the given tidy tidy.

参数

tidy

The Tidy 对象。

返回值

Returns an array of configuration options.

For an explanation about each option, visit » http://api.html-tidy.org/#quick-reference.

范例

Example #1 tidy::getConfig() example

<?php
$html = '<p>test</p>';
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap' => 200);

$tidy = tidy_parse_string($html, $config);

print_r($tidy->getConfig());
?>

以上例程会输出：

Array
(
    [indent-spaces] => 2
    [wrap] => 200
    [tab-size] => 8
    [char-encoding] => 1
    [input-encoding] => 3
    [output-encoding] => 1
    [newline] => 1
    [doctype-mode] => 1
    [doctype] =>
    [repeated-attributes] => 1
    [alt-text] =>
    [slide-style] =>
    [error-file] =>
    [output-file] =>
    [write-back] =>
    [markup] => 1
    [show-warnings] => 1
    [quiet] =>
    [indent] => 1
    [hide-endtags] =>
    [input-xml] =>
    [output-xml] => 1
    [output-xhtml] => 1
    [output-html] =>
    [add-xml-decl] =>
    [uppercase-tags] =>
    [uppercase-attributes] =>
    [bare] =>
    [clean] =>
    [logical-emphasis] =>
    [drop-proprietary-attributes] =>
    [drop-font-tags] =>
    [drop-empty-paras] => 1
    [fix-bad-comments] => 1
    [break-before-br] =>
    [split] =>
    [numeric-entities] =>
    [quote-marks] =>
    [quote-nbsp] => 1
    [quote-ampersand] => 1
    [wrap-attributes] =>
    [wrap-script-literals] =>
    [wrap-sections] => 1
    [wrap-asp] => 1
    [wrap-jste] => 1
    [wrap-php] => 1
    [fix-backslash] => 1
    [indent-attributes] =>
    [assume-xml-procins] =>
    [add-xml-space] =>
    [enclose-text] =>
    [enclose-block-text] =>
    [keep-time] =>
    [word-2000] =>
    [tidy-mark] =>
    [gnu-emacs] =>
    [gnu-emacs-file] =>
    [literal-attributes] =>
    [show-body-only] =>
    [fix-uri] => 1
    [lower-literals] => 1
    [hide-comments] =>
    [indent-cdata] =>
    [force-output] => 1
    [show-errors] => 6
    [ascii-chars] => 1
    [join-classes] =>
    [join-styles] => 1
    [escape-cdata] =>
    [language] =>
    [ncr] => 1
    [output-bom] => 2
    [replace-color] =>
    [css-prefix] =>
    [new-inline-tags] =>
    [new-blocklevel-tags] =>
    [new-empty-tags] =>
    [new-pre-tags] =>
    [accessibility-check] => 0
    [vertical-space] =>
    [punctuation-wrap] =>
    [merge-divs] => 1
)

参见

  • tidy_reset_config()
  • tidy_save_config()


Get the Detected HTML version for the specified document

  • ? tidy::getConfig
  • tidy::getOpt ?
  • PHP Manual
  • tidy
  • Get the Detected HTML version for the specified document

tidy::getHtmlVer

tidy_get_html_ver

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::getHtmlVer -- tidy_get_html_ver — Get the Detected HTML version for the specified document

说明

面向对象风格

public tidy::getHtmlVer ( ) : int

过程化风格

tidy_get_html_ver ( tidy $tidy ) : int

Returns the detected HTML version for the specified tidy tidy.

参数

tidy

The Tidy 对象。

返回值

Returns the detected HTML version.

Warning

This function is not yet implemented in the Tidylib itself, so it always return 0.


Returns the value of the specified configuration option for the tidy document

  • ? tidy::getHtmlVer
  • tidy::getOptDoc ?
  • PHP Manual
  • tidy
  • Returns the value of the specified configuration option for the tidy document

tidy::getOpt

tidy_getopt

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::getOpt -- tidy_getopt — Returns the value of the specified configuration option for the tidy document

说明

面向对象风格

public tidy::getOpt ( string $option ) : string|int|bool

过程化风格

tidy_getopt ( tidy $tidy , string $option ) : string|int|bool

Returns the value of the specified option for the specified tidy tidy.

参数

tidy

The Tidy 对象。

option

You will find a list with each configuration option and their types at: » http://api.html-tidy.org/#quick-reference.

返回值

Returns the value of the specified option. The return type depends on the type of the specified one.

范例

Example #1 tidy_getopt() example

<?php

$html ='<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html><head><title>Title</title></head>
<body>

<p><img src="img.png"></p>

</body></html>';

$config = array('accessibility-check' => 3,
                'alt-text' => 'some text');

$tidy = new tidy();
$tidy->parseString($html, $config);

var_dump($tidy->getOpt('accessibility-check')); //integer
var_dump($tidy->getOpt('lower-literals')); //boolean
var_dump($tidy->getOpt('alt-text')); //string

?>

以上例程会输出：

int(3)
bool(true)
string(9) "some text"


Returns the documentation for the given option name

  • ? tidy::getOpt
  • tidy::getRelease ?
  • PHP Manual
  • tidy
  • Returns the documentation for the given option name

tidy::getOptDoc

tidy_get_opt_doc

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

tidy::getOptDoc -- tidy_get_opt_doc — Returns the documentation for the given option name

说明

面向对象风格

public tidy::getOptDoc ( string $option ) : string|false

过程化风格

tidy_get_opt_doc ( tidy $tidy , string $option ) : string|false

tidy_get_opt_doc() returns the documentation for the given option name.

Note:

You need at least libtidy from 25 April, 2005 for this function be available.

参数

tidy

The Tidy 对象。

option

The option name

返回值

Returns a string if the option exists and has documentation available, or false otherwise.

范例

Example #1 Print all options along with their documentation and default value

<?php

$tidy = new tidy;
$config = $tidy->getConfig();

ksort($config);

foreach ($config as $opt => $val) {

    if (!$doc = $tidy->getOptDoc($opt))
        $doc = 'no documentation available!';

    $val = ($tidy->getOpt($opt) === true)  ? 'true'  : $val;
    $val = ($tidy->getOpt($opt) === false) ? 'false' : $val;

    echo "<p><b>$opt</b> (default: '$val')<br />".
         "$doc</p><hr />\n";
}

?>

参见

  • tidy::getconfig() - Get current Tidy configuration
  • tidy::getopt() - Returns the value of the specified configuration option for the tidy document


Get release date (version) for Tidy library

  • ? tidy::getOptDoc
  • tidy::getStatus ?
  • PHP Manual
  • tidy
  • Get release date (version) for Tidy library

tidy::getRelease

tidy_get_release

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::getRelease -- tidy_get_release — Get release date (version) for Tidy library

说明

面向对象风格

public tidy::getRelease ( ) : string

过程化风格

tidy_get_release ( ) : string

Gets the release date of the Tidy library.

返回值

Returns a string with the release date of the Tidy library, which may be 'unknown'.


Get status of specified document

  • ? tidy::getRelease
  • tidy::head ?
  • PHP Manual
  • tidy
  • Get status of specified document

tidy::getStatus

tidy_get_status

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::getStatus -- tidy_get_status — Get status of specified document

说明

面向对象风格

public tidy::getStatus ( ) : int

过程化风格

tidy_get_status ( tidy $tidy ) : int

Returns the status for the specified tidy tidy.

参数

tidy

The Tidy 对象。

返回值

Returns 0 if no error/warning was raised, 1 for warnings or accessibility errors, or 2 for errors.

范例

Example #1 tidy::getStatus() example

<?php
$html = '<p>paragraph</i>';
$tidy = new tidy();
$tidy->parseString($html);

$tidy2 = new tidy();
$html2 = '<bogus>test</bogus>';
$tidy2->parseString($html2);

echo $tidy->getStatus(); //1

echo $tidy2->getStatus(); //2
?>


Returns a tidyNode object starting from the <head> tag of the tidy parse tree

  • ? tidy::getStatus
  • tidy::html ?
  • PHP Manual
  • tidy
  • Returns a tidyNode object starting from the <head> tag of the tidy parse tree

tidy::head

tidy_get_head

(PHP 5, PHP 7, PHP 8, PECL tidy 0.5.2-1.0.0)

tidy::head -- tidy_get_head — Returns a tidyNode object starting from the <head> tag of the tidy parse tree

说明

面向对象风格

public tidy::head ( ) : tidyNode|null

过程化风格

tidy_get_head ( tidy $tidy ) : tidyNode|null

Returns a tidyNode object starting from the <head> tag of the tidy parse tree.

参数

tidy

The Tidy 对象。

返回值

Returns the tidyNode object.

范例

Example #1 tidy::head() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$head = $tidy->head();
echo $head->value;
?>

以上例程会输出：

<head>
<title>test</title>
</head>

参见

  • tidy::body() - Returns a tidyNode object starting from the <body> tag of the tidy parse tree
  • tidy::html() - Returns a tidyNode object starting from the <html> tag of the tidy parse tree


Returns a tidyNode object starting from the <html> tag of the tidy parse tree

  • ? tidy::head
  • tidy::isXhtml ?
  • PHP Manual
  • tidy
  • Returns a tidyNode object starting from the <html> tag of the tidy parse tree

tidy::html

tidy_get_html

(PHP 5, PHP 7, PHP 8, PECL tidy 0.5.2-1.0.0)

tidy::html -- tidy_get_html — Returns a tidyNode object starting from the <html> tag of the tidy parse tree

说明

面向对象风格

public tidy::html ( ) : tidyNode|null

过程化风格

tidy_get_html ( tidy $tidy ) : tidyNode|null

Returns a tidyNode object starting from the <html> tag of the tidy parse tree.

参数

tidy

The Tidy 对象。

返回值

Returns the tidyNode object.

范例

Example #1 tidy::html() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$html = $tidy->html();
echo $html->value;
?>

以上例程会输出：

<html>
<head>
<title>test</title>
</head>
<body>
<p>paragraph</p>
</body>
</html>

参见

  • tidy::body() - Returns a tidyNode object starting from the <body> tag of the tidy parse tree
  • tidy::head() - Returns a tidyNode object starting from the <head> tag of the tidy parse tree


Indicates if the document is a XHTML document

  • ? tidy::html
  • tidy::isXml ?
  • PHP Manual
  • tidy
  • Indicates if the document is a XHTML document

tidy::isXhtml

tidy_is_xhtml

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::isXhtml -- tidy_is_xhtml — Indicates if the document is a XHTML document

说明

面向对象风格

public tidy::isXhtml ( ) : bool

过程化风格

tidy_is_xhtml ( tidy $tidy ) : bool

Tells if the document is a XHTML document.

参数

tidy

The Tidy 对象。

返回值

This function returns true if the specified tidy tidy is a XHTML document, or false otherwise.

Warning

This function is not yet implemented in the Tidylib itself, so it always return false.


Indicates if the document is a generic (non HTML/XHTML) XML document

  • ? tidy::isXhtml
  • tidy::parseFile ?
  • PHP Manual
  • tidy
  • Indicates if the document is a generic (non HTML/XHTML) XML document

tidy::isXml

tidy_is_xml

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::isXml -- tidy_is_xml — Indicates if the document is a generic (non HTML/XHTML) XML document

说明

面向对象风格

public tidy::isXml ( ) : bool

过程化风格

tidy_is_xml ( tidy $tidy ) : bool

Tells if the document is a generic (non HTML/XHTML) XML document.

参数

tidy

The Tidy 对象。

返回值

This function returns true if the specified tidy tidy is a generic XML document (non HTML/XHTML), or false otherwise.

Warning

This function is not yet implemented in the Tidylib itself, so it always return false.


Parse markup in file or URI

  • ? tidy::isXml
  • tidy::parseString ?
  • PHP Manual
  • tidy
  • Parse markup in file or URI

tidy::parseFile

tidy_parse_file

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::parseFile -- tidy_parse_file — Parse markup in file or URI

说明

面向对象风格

public tidy::parseFile ( string $filename , array|string|null $config = null , string|null $encoding = null , bool $useIncludePath = false ) : bool

过程化风格

tidy_parse_file ( string $filename , array|string|null $config = null , string|null $encoding = null , bool $useIncludePath = false ) : tidy|false

Parses the given file.

参数

filename

If the filename parameter is given, this function will also read that file and initialize the object with the file, acting like tidy_parse_file().

config

The config config can be passed either as an array or as a string. If a string is passed, it is interpreted as the name of the configuration file, otherwise, it is interpreted as the options themselves.

For an explanation about each option, see » http://api.html-tidy.org/#quick-reference.

encoding

The encoding parameter sets the encoding for input/output documents. The possible values for encoding are: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, and shiftjis.

useIncludePath

Search for the file in the include_path.

返回值

tidy::parseFile() returns true on success. tidy_parse_file() returns a new tidy instance on success. Both, the method and the function return false on failure.

更新日志

版本 | 说明
8.0.0 | config and encoding are nullable now.

范例

Example #1 tidy::parseFile() example

<?php
$tidy = new tidy();
$tidy->parseFile('file.html');

$tidy->cleanRepair();

if(!empty($tidy->errorBuffer)) {
    echo "The following errors or warnings occurred:\n";
    echo $tidy->errorBuffer;
}
?>

参见

  • tidy::parsestring() - Parse a document stored in a string
  • tidy::repairfile() - Repair a file and return it as a string
  • tidy::repairstring() - Repair a string using an optionally provided configuration file


Parse a document stored in a string

  • ? tidy::parseFile
  • tidy::repairFile ?
  • PHP Manual
  • tidy
  • Parse a document stored in a string

tidy::parseString

tidy_parse_string

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy::parseString -- tidy_parse_string — Parse a document stored in a string

说明

面向对象风格

public tidy::parseString ( string $string , array|string|null $config = null , string|null $encoding = null ) : bool

过程化风格

tidy_parse_string ( string $string , array|string|null $config = null , string|null $encoding = null ) : tidy|false

Parses a document stored in a string.

参数

string

The data to be parsed.

config

The config config can be passed either as an array or as a string. If a string is passed, it is interpreted as the name of the configuration file, otherwise, it is interpreted as the options themselves.

For an explanation about each option, visit » http://api.html-tidy.org/#quick-reference.

encoding

The encoding parameter sets the encoding for input/output documents. The possible values for encoding are: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, and shiftjis.

返回值

tidy::parseString() returns true on success. tidy_parse_string() returns a new tidy instance on success. Both, the method and the function return false on failure.

更新日志

版本 | 说明
8.0.0 | config and encoding are nullable now.

范例

Example #1 tidy::parseString() example

<?php
ob_start();
?>

<html>
  <head>
   <title>test</title>
  </head>
  <body>
   <p>error<br>another line</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap' => 200);

$tidy = tidy_parse_string($buffer, $config, 'UTF8');

$tidy->cleanRepair();
echo $tidy;
?>

以上例程会输出：

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>
      test
    </title>
  </head>
  <body>
    <p>
      error<br />
      another line
    </p>
  </body>
</html>

参见

  • tidy::parseFile() - Parse markup in file or URI
  • tidy::repairFile() - Repair a file and return it as a string
  • tidy::repairString() - Repair a string using an optionally provided configuration file


Repair a file and return it as a string

  • ? tidy::parseString
  • tidy::repairString ?
  • PHP Manual
  • tidy
  • Repair a file and return it as a string

tidy::repairFile

tidy_repair_file

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.7.0)

tidy::repairFile -- tidy_repair_file — Repair a file and return it as a string

说明

面向对象风格

public static tidy::repairFile ( string $filename , array|string|null $config = null , string|null $encoding = null , bool $useIncludePath = false ) : string|false

过程化风格

tidy_repair_file ( string $filename , array|string|null $config = null , string|null $encoding = null , bool $useIncludePath = false ) : string|false

Repairs the given file and returns it as a string.

参数

filename

The file to be repaired.

config

The config config can be passed either as an array or as a string. If a string is passed, it is interpreted as the name of the configuration file, otherwise, it is interpreted as the options themselves.

Check http://tidy.sourceforge.net/docs/quickref.html for an explanation about each option.

encoding

The encoding parameter sets the encoding for input/output documents. The possible values for encoding are: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, and shiftjis.

useIncludePath

Search for the file in the include_path.

返回值

Returns the repaired contents as a string, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | tidy::repairFile() is a static method now.
8.0.0 | config and encoding are nullable now.

范例

Example #1 tidy::repairFile() example

<?php
$file = 'file.html';

$tidy = new tidy();
$repaired = $tidy->repairfile($file);
rename($file, $file . '.bak');

file_put_contents($file, $repaired);
?>

参见

  • tidy::parseFile() - Parse markup in file or URI
  • tidy::parseString() - Parse a document stored in a string
  • tidy::repairString() - Repair a string using an optionally provided configuration file


Repair a string using an optionally provided configuration file

  • ? tidy::repairFile
  • tidy::root ?
  • PHP Manual
  • tidy
  • Repair a string using an optionally provided configuration file

tidy::repairString

tidy_repair_string

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.7.0)

tidy::repairString -- tidy_repair_string — Repair a string using an optionally provided configuration file

说明

面向对象风格

public static tidy::repairString ( string $string , array|string|null $config = null , string|null $encoding = null ) : string|false

过程化风格

tidy_repair_string ( string $string , array|string|null $config = null , string|null $encoding = null ) : string|false

Repairs the given string.

参数

string

The data to be repaired.

config

The config config can be passed either as an array or as a string. If a string is passed, it is interpreted as the name of the configuration file, otherwise, it is interpreted as the options themselves.

Check » http://api.html-tidy.org/#quick-reference for an explanation about each option.

encoding

The encoding parameter sets the encoding for input/output documents. The possible values for encoding are: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5, and shiftjis.

返回值

Returns the repaired string, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | tidy::repairString() is a static method now.
8.0.0 | config and encoding are nullable now.
8.0.0 | This function no longer accepts the useIncludePath parameter.

范例

Example #1 tidy::repairString() example

<?php
ob_start();
?>

<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>error</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$tidy = new tidy();
$clean = $tidy->repairString($buffer);

echo $clean;
?>

以上例程会输出：

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title>test</title>
</head>
<body>
<p>error</p>
</body>
</html>

参见

  • tidy::parseFile() - Parse markup in file or URI
  • tidy::parseString() - Parse a document stored in a string
  • tidy::repairFile() - Repair a file and return it as a string


Returns a tidyNode object representing the root of the tidy parse tree

  • ? tidy::repairString
  • tidyNode ?
  • PHP Manual
  • tidy
  • Returns a tidyNode object representing the root of the tidy parse tree

tidy::root

tidy_get_root

(PHP 5, PHP 7, PHP 8, PECL tidy 0.5.2-1.0.0)

tidy::root -- tidy_get_root — Returns a tidyNode object representing the root of the tidy parse tree

说明

面向对象风格

public tidy::root ( ) : tidyNode|null

过程化风格

tidy_get_root ( tidy $tidy ) : tidyNode|null

Returns a tidyNode object representing the root of the tidy parse tree.

参数

tidy

The Tidy 对象。

返回值

Returns the tidyNode object.

范例

Example #1 tidy::root() example

<?php

$html = <<< HTML
<html><body>

<p>paragraph</p>
<br/>

</body></html>
HTML;

$tidy = tidy_parse_string($html);
dump_nodes($tidy->root(), 1);

function dump_nodes($node, $indent) {

    if($node->hasChildren()) {
        foreach($node->child as $child) {
            echo str_repeat('.', $indent*2) . ($child->name ? $child->name : '"'.$child->value.'"'). "\n";

            dump_nodes($child, $indent+1);
        }
    }
}
?>

以上例程会输出：

..html
....head
......title
....body
......p
........"paragraph"
......br


The tidyNode class

(PHP 5, PHP 7, PHP 8)

简介

An HTML node in an HTML file, as detected by tidy.

类摘要

final
tidyNode {
/* 属性 */
public string $value;
public string $name;
public int $type;
public int $line;
public int $column;
public bool $proprietary;
public int $id;
public array $attribute;
public array $child;
/* 方法 */
private __construct ( )
public getParent ( ) : tidyNode|null
public hasChildren ( ) : bool
public hasSiblings ( ) : bool
public isAsp ( ) : bool
public isComment ( ) : bool
public isHtml ( ) : bool
public isJste ( ) : bool
public isPhp ( ) : bool
public isText ( ) : bool
}

属性

value

The HTML representation of the node, including the surrounding tags.

name

The name of the HTML node

type

The type of the node (one of the nodetype constants, e.g. TIDY_NODETYPE_PHP)

line

The line number at which the tags is located in the file

column

The column number at which the tags is located in the file

proprietary

Indicates if the node is a proprietary tag

id

The ID of the node (one of the tag constants, e.g. TIDY_TAG_FRAME)

attribute

An array of string, representing the attributes names (as keys) of the current node.

child

An array of tidyNode, representing the children of the current node.

版本 | 说明
5.1.0 | line, column and proprietary were added

Table of Contents

  • tidyNode::__construct — Private constructor to disallow direct instantiation
  • tidyNode::getParent — Returns the parent node of the current node
  • tidyNode::hasChildren — Checks if a node has children
  • tidyNode::hasSiblings — Checks if a node has siblings
  • tidyNode::isAsp — Checks if this node is ASP
  • tidyNode::isComment — Checks if a node represents a comment
  • tidyNode::isHtml — Checks if a node is an element node
  • tidyNode::isJste — Checks if this node is JSTE
  • tidyNode::isPhp — Checks if a node is PHP
  • tidyNode::isText — Checks if a node represents text (no markup)


Private constructor to disallow direct instantiation

  • ? tidyNode
  • tidyNode::getParent ?
  • PHP Manual
  • tidyNode
  • Private constructor to disallow direct instantiation

tidyNode::__construct

(PHP 5, PHP 7, PHP 8)

tidyNode::__construct — Private constructor to disallow direct instantiation

说明

private tidyNode::__construct ( )

参数

此函数没有参数。


Returns the parent node of the current node

  • ? tidyNode::__construct
  • tidyNode::hasChildren ?
  • PHP Manual
  • tidyNode
  • Returns the parent node of the current node

tidyNode::getParent

(PHP 5 >= 5.2.2, PHP 7, PHP 8)

tidyNode::getParent — Returns the parent node of the current node

说明

public tidyNode::getParent ( ) : tidyNode|null

Returns the parent node of the current node.

返回值

Returns a tidyNode if the node has a parent, or null otherwise.

范例

Example #1 tidyNode::hasChildren() example

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
 </head>
 <body>
 Hello World
 </body>
</html>

HTML;

$tidy = tidy_parse_string($html);
$num = 0;

$node = $tidy->html()->child[0]->child[0];

var_dump($node->getparent()->name);
?>

以上例程会输出：

string(4) "head"


Checks if a node has children

  • ? tidyNode::getParent
  • tidyNode::hasSiblings ?
  • PHP Manual
  • tidyNode
  • Checks if a node has children

tidyNode::hasChildren

(PHP 5, PHP 7, PHP 8)

tidyNode::hasChildren — Checks if a node has children

说明

public tidyNode::hasChildren ( ) : bool

Tells if the node has children.

返回值

Returns true if the node has children, false otherwise.

范例

Example #1 tidyNode::hasChildren() example

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
</head>
<body>

<?php
  // PHP code
  echo 'hello world!';
?>

<%
  /* ASP code */
  response.write("Hello World!")
%>

<!-- Comments -->
Hello World
</body></html>
Outside HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

// the head tag
var_dump($tidy->html()->child[0]->hasChildren());

// the php inside the head tag
var_dump($tidy->html()->child[0]->child[0]->hasChildren());

?>

以上例程会输出：

bool(true)
bool(false)


Checks if a node has siblings

  • ? tidyNode::hasChildren
  • tidyNode::isAsp ?
  • PHP Manual
  • tidyNode
  • Checks if a node has siblings

tidyNode::hasSiblings

(PHP 5, PHP 7, PHP 8)

tidyNode::hasSiblings — Checks if a node has siblings

说明

public tidyNode::hasSiblings ( ) : bool

Tells if the node has siblings.

返回值

Returns true if the node has siblings, false otherwise.

范例

Example #1 tidyNode::hasSiblings() example

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
</head>
<body>

<?php
  // PHP code
  echo 'hello world!';
?>

<%
  /* ASP code */
  response.write("Hello World!")
%>

<!-- Comments -->
Hello World
</body></html>
Outside HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

// the html tag
var_dump($tidy->html()->hasSiblings());

// the head tag
var_dump($tidy->html()->child[0]->hasSiblings());

?>

以上例程会输出：

bool(false)
bool(true)


Checks if this node is ASP

  • ? tidyNode::hasSiblings
  • tidyNode::isComment ?
  • PHP Manual
  • tidyNode
  • Checks if this node is ASP

tidyNode::isAsp

(PHP 5, PHP 7, PHP 8)

tidyNode::isAsp — Checks if this node is ASP

说明

public tidyNode::isAsp ( ) : bool

Tells whether the current node is ASP.

返回值

Returns true if the node is ASP, false otherwise.

范例

Example #1 Extract ASP code from a mixed HTML document

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
</head>
<body>

<?php
  // PHP code
  echo 'hello world!';
?>

<%
  /* ASP code */
  response.write("Hello World!")
%>

<!-- Comments -->
Hello World
</body></html>
Outside HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // check if the current node is of requested type
    if($node->isAsp()) {
        echo "\n\n# asp node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // check if the current node has childrens
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

以上例程会输出：

# asp node #1
<%
  /* ASP code */
  response.write("Hello World!")
%>


Checks if a node represents a comment

  • ? tidyNode::isAsp
  • tidyNode::isHtml ?
  • PHP Manual
  • tidyNode
  • Checks if a node represents a comment

tidyNode::isComment

(PHP 5, PHP 7, PHP 8)

tidyNode::isComment — Checks if a node represents a comment

说明

public tidyNode::isComment ( ) : bool

Tells if the node is a comment.

返回值

Returns true if the node is a comment, false otherwise.

范例

Example #1 Extract comments from a mixed HTML document

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
</head>
<body>

<?php
  // PHP code
  echo 'hello world!';
?>

<%
  /* ASP code */
  response.write("Hello World!")
%>

<!-- Comments -->
Hello World
</body></html>
Outside HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // check if the current node is of requested type
    if($node->isComment()) {
        echo "\n\n# comment node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // check if the current node has childrens
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

以上例程会输出：

# comment node #1
<!-- Comments -->


Checks if a node is an element node

  • ? tidyNode::isComment
  • tidyNode::isJste ?
  • PHP Manual
  • tidyNode
  • Checks if a node is an element node

tidyNode::isHtml

(PHP 5, PHP 7, PHP 8)

tidyNode::isHtml — Checks if a node is an element node

说明

public tidyNode::isHtml ( ) : bool

Tells if the node is an element node, but not the root node of the document.

返回值

Returns true if the node is an element node, but not the root node of the document, false otherwise.

更新日志

版本 | 说明
7.3.24, 7.4.12 | This function has been fixed to have reasonable behavior. Previously, almost any node was reported as being an HTML node.

范例

Example #1 Extract HTML code from a mixed HTML document

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
</head>
<body>

<?php
  // PHP code
  echo 'hello world!';
?>

<%
  /* ASP code */
  response.write("Hello World!")
%>

<!-- Comments -->
Hello World
</body></html>
Outside HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {
    // check if the current node is of requested type
    if($node->isHtml()) {
        echo "\n\n# html node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // check if the current node has childrens
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

以上例程会输出：

# html node #1
<html>
<head>
<?php echo '<title>title</title>'; ?><#
  /* JSTE code */
  alert('Hello World');
#>
<title></title>
</head>
<body>
<?php
  // PHP code
  echo 'hello world!';
?><%
  /* ASP code */
  response.write("Hello World!")
%><!-- Comments -->
Hello WorldOutside HTML
</body>
</html>

# html node #2
<head>
<?php echo '<title>title</title>'; ?><#
  /* JSTE code */
  alert('Hello World');
#>
<title></title>
</head>

# html node #3
<title></title>

# html node #4
<body>
<?php
  // PHP code
  echo 'hello world!';
?><%
  /* ASP code */
  response.write("Hello World!")
%><!-- Comments -->
Hello WorldOutside HTML
</body>


Checks if this node is JSTE

  • ? tidyNode::isHtml
  • tidyNode::isPhp ?
  • PHP Manual
  • tidyNode
  • Checks if this node is JSTE

tidyNode::isJste

(PHP 5, PHP 7, PHP 8)

tidyNode::isJste — Checks if this node is JSTE

说明

public tidyNode::isJste ( ) : bool

Tells if the node is JSTE.

返回值

Returns true if the node is JSTE, false otherwise.

范例

Example #1 Extract JSTE code from a mixed HTML document

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
</head>
<body>

<?php
  // PHP code
  echo 'hello world!';
?>

<%
  /* ASP code */
  response.write("Hello World!")
%>

<!-- Comments -->
Hello World
</body></html>
Outside HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // check if the current node is of requested type
    if($node->isJste()) {
        echo "\n\n# jste node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // check if the current node has childrens
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

以上例程会输出：

# jste node #1
<#
  /* JSTE code */
  alert('Hello World');
#>


Checks if a node is PHP

  • ? tidyNode::isJste
  • tidyNode::isText ?
  • PHP Manual
  • tidyNode
  • Checks if a node is PHP

tidyNode::isPhp

(PHP 5, PHP 7, PHP 8)

tidyNode::isPhp — Checks if a node is PHP

说明

public tidyNode::isPhp ( ) : bool

Tells if the node is PHP.

返回值

Returns true if the current node is PHP code, false otherwise.

范例

Example #1 Extract PHP code from a mixed HTML document

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
</head>
<body>

<?php
  // PHP code
  echo 'hello world!';
?>

<%
  /* ASP code */
  response.write("Hello World!")
%>

<!-- Comments -->
Hello World
</body></html>
Outside HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // check if the current node is of requested type
    if($node->isPhp()) {
        echo "\n\n# php node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // check if the current node has childrens
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

以上例程会输出：

# php node #1
<?php echo '<title>title</title>'; ?>

# php node #2
<?php
  // PHP code
  echo 'hello world!';
?>


Checks if a node represents text (no markup)

  • ? tidyNode::isPhp
  • Tidy 函数 ?
  • PHP Manual
  • tidyNode
  • Checks if a node represents text (no markup)

tidyNode::isText

(PHP 5, PHP 7, PHP 8)

tidyNode::isText — Checks if a node represents text (no markup)

说明

public tidyNode::isText ( ) : bool

Tells if the node represents a text (without any markup).

返回值

Returns true if the node represent a text, false otherwise.

范例

Example #1 Extract text from a mixed HTML document

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE code */
  alert('Hello World');
#>
</head>
<body>

<?php
  // PHP code
  echo 'hello world!';
?>

<%
  /* ASP code */
  response.write("Hello World!")
%>

<!-- Comments -->
Hello World
</body></html>
Outside HTML
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html());

function get_nodes($node) {

    // check if the current node is of requested type
    if($node->isText()) {
        echo "\n\n# text node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // check if the current node has childrens
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child);
        }
    }
}

?>

以上例程会输出：

# text node #1
Hello World

# text node #2
Outside HTML


Tidy 函数

Table of Contents

  • ob_tidyhandler — ob_start callback function to repair the buffer
  • tidy_access_count — Returns the Number of Tidy accessibility warnings encountered for specified document
  • tidy_config_count — Returns the Number of Tidy configuration errors encountered for specified document
  • tidy_error_count — Returns the Number of Tidy errors encountered for specified document
  • tidy_get_output — Return a string representing the parsed tidy markup
  • tidy_warning_count — Returns the Number of Tidy warnings encountered for specified document


ob_start callback function to repair the buffer

  • ? Tidy 函数
  • tidy_access_count ?
  • PHP Manual
  • Tidy 函数
  • ob_start callback function to repair the buffer

ob_tidyhandler

(PHP 5, PHP 7, PHP 8)

ob_tidyhandler — ob_start callback function to repair the buffer

说明

ob_tidyhandler ( string $input , int $mode = ? ) : string

Callback function for ob_start() to repair the buffer.

参数

input

The buffer.

mode

The buffer mode.

返回值

Returns the modified buffer.

范例

Example #1 ob_tidyhandler() example

<?php
ob_start('ob_tidyhandler');

echo '<p>test</i>';
?>

以上例程会输出：

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

参见

  • ob_start() - 打开输出控制缓冲


Returns the Number of Tidy accessibility warnings encountered for specified document

  • ? ob_tidyhandler
  • tidy_config_count ?
  • PHP Manual
  • Tidy 函数
  • Returns the Number of Tidy accessibility warnings encountered for specified document

tidy_access_count

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_access_count — Returns the Number of Tidy accessibility warnings encountered for specified document

说明

tidy_access_count ( tidy $tidy ) : int

tidy_access_count() returns the number of accessibility warnings found for the specified document.

参数

tidy

The Tidy 对象。

返回值

Returns the number of warnings.

范例

Example #1 tidy_access_count() example

<?php

$html ='<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html><head><title>Title</title></head>
<body>

<p><img src="img.png"></p>

</body></html>';

// select the accessibility check level: 1, 2 or 3
$config = array('accessibility-check' => 3);

$tidy = new tidy();
$tidy->parseString($html, $config);
$tidy->cleanRepair();

/* Never forget to call this! */
$tidy->diagnose();

echo tidy_access_count($tidy); //5

?>

注释

Note:

Due to the design of the TidyLib, you must call tidy_diagnose() before tidy_access_count() or it will return always 0. You must also need to enable the accessibility-check option.

参见

  • tidy_error_count() - Returns the Number of Tidy errors encountered for specified document
  • tidy_warning_count() - Returns the Number of Tidy warnings encountered for specified document


Returns the Number of Tidy configuration errors encountered for specified document

  • ? tidy_access_count
  • tidy_error_count ?
  • PHP Manual
  • Tidy 函数
  • Returns the Number of Tidy configuration errors encountered for specified document

tidy_config_count

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_config_count — Returns the Number of Tidy configuration errors encountered for specified document

说明

tidy_config_count ( tidy $tidy ) : int

Returns the number of errors encountered in the configuration of the specified tidy tidy.

参数

tidy

The Tidy 对象。

返回值

Returns the number of errors.

范例

Example #1 tidy_config_count() example

<?php
$html = '<p>test</I>';

$config = array('doctype' => 'bogus');

$tidy = tidy_parse_string($html, $config);

/* This outputs 1, because 'bogus' isn't a valid doctype */
echo tidy_config_count($tidy);
?>


Returns the Number of Tidy errors encountered for specified document

  • ? tidy_config_count
  • tidy_get_output ?
  • PHP Manual
  • Tidy 函数
  • Returns the Number of Tidy errors encountered for specified document

tidy_error_count

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_error_count — Returns the Number of Tidy errors encountered for specified document

说明

tidy_error_count ( tidy $tidy ) : int

Returns the number of Tidy errors encountered for the specified document.

参数

tidy

The Tidy 对象。

返回值

Returns the number of errors.

范例

Example #1 tidy_error_count() example

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1

echo $tidy->errorBuffer;
?>

以上例程会输出：

1
line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 8 - Warning: discarding unexpected </i>
line 2 column 1 - Error: <bogustag> is not recognized!
line 2 column 1 - Warning: discarding unexpected <bogustag>
line 2 column 16 - Warning: discarding unexpected </bogustag>
line 1 column 1 - Warning: inserting missing 'title' element

参见

  • tidy_access_count() - Returns the Number of Tidy accessibility warnings encountered for specified document
  • tidy_warning_count() - Returns the Number of Tidy warnings encountered for specified document


Return a string representing the parsed tidy markup

  • ? tidy_error_count
  • tidy_warning_count ?
  • PHP Manual
  • Tidy 函数
  • Return a string representing the parsed tidy markup

tidy_get_output

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_get_output — Return a string representing the parsed tidy markup

说明

tidy_get_output ( tidy $tidy ) : string

Gets a string with the repaired html.

参数

tidy

The Tidy 对象。

返回值

Returns the parsed tidy markup.

范例

Example #1 tidy_get_output() example

<?php

$html = '<p>paragraph</i>';
$tidy = tidy_parse_string($html);

$tidy->cleanRepair();

echo tidy_get_output($tidy);
?>

以上例程会输出：

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>paragraph</p>
</body>
</html>


Returns the Number of Tidy warnings encountered for specified document

  • ? tidy_get_output
  • Tokenizer ?
  • PHP Manual
  • Tidy 函数
  • Returns the Number of Tidy warnings encountered for specified document

tidy_warning_count

(PHP 5, PHP 7, PHP 8, PECL tidy >= 0.5.2)

tidy_warning_count — Returns the Number of Tidy warnings encountered for specified document

说明

tidy_warning_count ( tidy $tidy ) : int

Returns the number of Tidy warnings encountered for the specified document.

参数

tidy

The Tidy 对象。

返回值

Returns the number of warnings.

范例

Example #1 tidy_warning_count() example

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1
echo tidy_warning_count($tidy) . "\n"; //5
?>

参见

  • tidy_error_count() - Returns the Number of Tidy errors encountered for specified document
  • tidy_access_count() - Returns the Number of Tidy accessibility warnings encountered for specified document


Tokenizer

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • PhpToken — The PhpToken class
    • PhpToken::__construct — Returns a new PhpToken object
    • PhpToken::getTokenName — Returns the name of the token.
    • PhpToken::is — Tells whether the token is of given kind.
    • PhpToken::isIgnorable — Tells whether the token would be ignored by the PHP parser.
    • PhpToken::__toString — Returns the textual content of the token.
    • PhpToken::tokenize — Splits given source into PHP tokens, represented by PhpToken objects.
  • Tokenizer 函数
    • token_get_all — 将提供的源码按 PHP 标记进行分割
    • token_name — 获取提供的 PHP 解析器代号的符号名称


简介

The tokenizer functions provide an interface to the PHP tokenizer embedded in the Zend Engine. Using these functions you may write your own PHP source analyzing or modification tools without having to deal with the language specification at the lexical level.

See also the appendix about tokens.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Tokenizer
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

从 PHP 4.4.0 开始，这些函数默认是被激活的. 对于旧版本在配置和编译 PHP 是使用 --enable-tokenizer选项. 也能使用 --disable-tokenizer选项禁用 tokenizer 支持.

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。

Note: tokenizer 的内建支持在 PHP 4.3.0 后可用


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • Tokenizer
  • 预定义常量

预定义常量

当这个扩展被编译进 PHP 或者在运行时动态加载时，解析器代号列表中的标记会被定义为常量


范例

这里是一个简单使用 tokenizer 的PHP脚本例子，它将读取一个PHP文件，去掉代码中全部注释，然后只打印纯代码

Example #1 Strip comments with the tokenizer

<?php
/*
* T_ML_COMMENT does not exist in PHP 5.
* The following three lines define it in order to
* preserve backwards compatibility.
*
* The next two lines define the PHP 5 only T_DOC_COMMENT,
* which we will mask as T_ML_COMMENT for PHP 4.
*/
if (!defined('T_ML_COMMENT')) {
   define('T_ML_COMMENT', T_COMMENT);
} else {
   define('T_DOC_COMMENT', T_ML_COMMENT);
}

$source = file_get_contents('example.php');
$tokens = token_get_all($source);

foreach ($tokens as $token) {
   if (is_string($token)) {
       // simple 1-character token
       echo $token;
   } else {
       // token array
       list($id, $text) = $token;

       switch ($id) {
           case T_COMMENT:
           case T_ML_COMMENT: // we've defined this
           case T_DOC_COMMENT: // and this
               // no action on comments
               break;

           default:
               // anything else -> output "as is"
               echo $text;
               break;
       }
   }
}
?>


The PhpToken class

(PHP 8)

简介

This class provides an alternative to token_get_all(). While the function returns tokens either as a single-character string, or an array with a token ID, token text and line number, PhpToken::tokenize() normalizes all tokens into PhpToken objects, which makes code operating on tokens more memory efficient and readable.

类摘要

PhpToken {
/* 属性 */
public int $id ;
public string $text ;
public int $line ;
public int $pos ;
/* 方法 */
final public __construct ( int $id , string $text , int $line = -1 , int $pos = -1 )
public getTokenName ( ) : string|null
public is ( int|string|array $kind ) : bool
public isIgnorable ( ) : bool
public __toString ( ) : string
public static tokenize ( string $code , int $flags = 0 ) : array
}

属性

id

One of the T_* constants, or an ASCII codepoint representing a single-char token.

text

The textual content of the token.

line

The starting line number (1-based) of the token.

pos

The starting position (0-based) in the tokenized string.

Table of Contents

  • PhpToken::__construct — Returns a new PhpToken object
  • PhpToken::getTokenName — Returns the name of the token.
  • PhpToken::is — Tells whether the token is of given kind.
  • PhpToken::isIgnorable — Tells whether the token would be ignored by the PHP parser.
  • PhpToken::__toString — Returns the textual content of the token.
  • PhpToken::tokenize — Splits given source into PHP tokens, represented by PhpToken objects.


Returns a new PhpToken object

  • ? PhpToken
  • PhpToken::getTokenName ?
  • PHP Manual
  • PhpToken
  • Returns a new PhpToken object

PhpToken::__construct

(PHP 8)

PhpToken::__construct — Returns a new PhpToken object

说明

final public PhpToken::__construct ( int $id , string $text , int $line = -1 , int $pos = -1 )

Returns a new PhpToken object

参数

id

One of the T_* constants (see 解析器代号列表), or an ASCII codepoint representing a single-char token.

text

The textual content of the token.

line

The starting line number (1-based) of the token.

pos

The starting position (0-based) in the tokenized string.

返回值

Returns a new PhpToken instance.

参见

  • PhpToken::tokenize() - Splits given source into PHP tokens, represented by PhpToken objects.


Returns the name of the token.

  • ? PhpToken::__construct
  • PhpToken::is ?
  • PHP Manual
  • PhpToken
  • Returns the name of the token.

PhpToken::getTokenName

(PHP 8)

PhpToken::getTokenName — Returns the name of the token.

说明

public PhpToken::getTokenName ( ) : string|null

Returns the name of the token.

参数

此函数没有参数。

返回值

An ASCII character for single-char tokens, or one of T_* constant names for known tokens (see 解析器代号列表), or null for unknown tokens.

范例

Example #1 PhpToken::getTokenName() example

<?php
// known token
$token = new PhpToken(T_ECHO, 'echo');
var_dump($token->getTokenName());   // -> string(6) "T_ECHO"

// single-char token
$token = new PhpToken(ord(';'), ';');
var_dump($token->getTokenName());   // -> string(1) ";"

// unknown token
$token = new PhpToken(10000 , "\0");
var_dump($token->getTokenName());   // -> NULL

参见

  • PhpToken::tokenize() - Splits given source into PHP tokens, represented by PhpToken objects.
  • token_name() - 获取提供的 PHP 解析器代号的符号名称


Tells whether the token is of given kind.

  • ? PhpToken::getTokenName
  • PhpToken::isIgnorable ?
  • PHP Manual
  • PhpToken
  • Tells whether the token is of given kind.

PhpToken::is

(PHP 8)

PhpToken::is — Tells whether the token is of given kind.

说明

public PhpToken::is ( int|string|array $kind ) : bool

Tells whether the token is of given kind.

参数

kind

Either a single value to match the token's id or textual content, or an array thereof.

返回值

A boolean value whether the token is of given kind.

范例

Example #1 PhpToken::is() example

<?php
$token = new PhpToken(T_ECHO, 'echo');
var_dump($token->is(T_ECHO));        // -> bool(true)
var_dump($token->is('echo'));        // -> bool(true)
var_dump($token->is(T_FOREACH));     // -> bool(false)
var_dump($token->is('foreach'));     // -> bool(false)

Example #2 Usage with array

<?php
function isClassType(PhpToken $token): bool {
    return $token->is([T_CLASS, T_INTERFACE, T_TRAIT]);
}

$interface = new PhpToken(T_INTERFACE, 'interface');
var_dump(isClassType($interface));   // -> bool(true)

$function = new PhpToken(T_FUNCTION, 'function');
var_dump(isClassType($function));    // -> bool(false)

参见

  • token_name() - 获取提供的 PHP 解析器代号的符号名称


Tells whether the token would be ignored by the PHP parser.

  • ? PhpToken::is
  • PhpToken::__toString ?
  • PHP Manual
  • PhpToken
  • Tells whether the token would be ignored by the PHP parser.

PhpToken::isIgnorable

(PHP 8)

PhpToken::isIgnorable — Tells whether the token would be ignored by the PHP parser.

说明

public PhpToken::isIgnorable ( ) : bool

Tells whether the token would be ignored by the PHP parser.

参数

此函数没有参数。

返回值

A boolean value whether the token would be ignored by the PHP parser (such as whitespace or comments).

范例

Example #1 PhpToken::isIgnorable() example

<?php
$echo = new PhpToken(T_ECHO, 'echo');
var_dump($echo->isIgnorable());   // -> bool(false)

$space = new PhpToken(T_WHITESPACE, ' ');
var_dump($space->isIgnorable());  // -> bool(true)

参见

  • PhpToken::tokenize() - Splits given source into PHP tokens, represented by PhpToken objects.


Returns the textual content of the token.

  • ? PhpToken::isIgnorable
  • PhpToken::tokenize ?
  • PHP Manual
  • PhpToken
  • Returns the textual content of the token.

PhpToken::__toString

(PHP 8)

PhpToken::__toString — Returns the textual content of the token.

说明

public PhpToken::__toString ( ) : string

Returns the textual content of the token.

参数

此函数没有参数。

返回值

A textual content of the token.

范例

Example #1 PhpToken::__toString() example

<?php
$token = new PhpToken(T_ECHO, 'echo');
echo $token;

以上例程会输出：

echo

参见

  • token_name() - 获取提供的 PHP 解析器代号的符号名称


Splits given source into PHP tokens, represented by PhpToken objects.

  • ? PhpToken::__toString
  • Tokenizer 函数 ?
  • PHP Manual
  • PhpToken
  • Splits given source into PHP tokens, represented by PhpToken objects.

PhpToken::tokenize

(PHP 8)

PhpToken::tokenize — Splits given source into PHP tokens, represented by PhpToken objects.

说明

public static PhpToken::tokenize ( string $code , int $flags = 0 ) : array

Returns an array of PhpToken objects representing given code.

参数

code

The PHP source to parse.

flags

Valid flags:

  • TOKEN_PARSE - Recognises the ability to use reserved words in specific contexts.

返回值

An array of PHP tokens represented by instances of PhpToken or its descendants. This method returns static[] so that PhpToken can be seamlessly extended.

范例

Example #1 PhpToken::tokenize() example

<?php
$tokens = PhpToken::tokenize('<?php echo; ?>');

foreach ($tokens as $token) {
    echo "Line {$token->line}: {$token->getTokenName()} ('{$token->text}')", PHP_EOL;
}

以上例程会输出：

Line 1: T_OPEN_TAG ('<?php ')
Line 1: T_ECHO ('echo')
Line 1: ; (';')
Line 1: T_WHITESPACE (' ')
Line 1: T_CLOSE_TAG ('?>')

Example #2 Extending PhpToken

<?php

class MyPhpToken extends PhpToken {
    public function getUpperText() {
        return strtoupper($this->text);
    }
}

$tokens = MyPhpToken::tokenize('<?php echo; ?>');
echo "'{$tokens[0]->getUpperText()}'";

以上例程会输出：

'<?PHP '

参见

  • token_get_all() - 将提供的源码按 PHP 标记进行分割


Tokenizer 函数

Table of Contents

  • token_get_all — 将提供的源码按 PHP 标记进行分割
  • token_name — 获取提供的 PHP 解析器代号的符号名称


将提供的源码按 PHP 标记进行分割

  • ? Tokenizer 函数
  • token_name ?
  • PHP Manual
  • Tokenizer 函数
  • 将提供的源码按 PHP 标记进行分割

token_get_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

token_get_all — 将提供的源码按 PHP 标记进行分割

说明

token_get_all ( string $source ) : array

token_get_all() 解析提供的 source 源码字符，然后使用 Zend 引擎的语法分析器获取源码中的 PHP 语言的解析器代号

解析器代号列表见解析器代号列表, 或者使用 token_name() 翻译获取这个代号的字符串表示.

参数

source

需要解析的 PHP 源码.

返回值

An array of token identifiers. Each individual token identifier is either a single character (i.e.: ;, ., or a three element array containing the token index in element 0, the string content of the original token in element 1 and the line number in element 2.

范例

Example #1 token_get_all() examples

<?php
$tokens = token_get_all('<?php echo; ?>'); /* => array(
                                                  array(T_OPEN_TAG, '<?php'),
                                                  array(T_ECHO, 'echo'),
                                                  ';',
                                                  array(T_CLOSE_TAG, '?>') ); */

/* Note in the following example that the string is parsed as T_INLINE_HTML
   rather than the otherwise expected T_COMMENT (T_ML_COMMENT in PHP <5).
   This is because no open/close tags were used in the "code" provided.
   This would be equivalent to putting a comment outside of <?php ?> tags in a normal file. */
$tokens = token_get_all('/* comment */'); // => array(array(T_INLINE_HTML, '/* comment */'));
?>

更新日志

版本 | 说明
5.2.2 | Line numbers are returned in element 2


获取提供的 PHP 解析器代号的符号名称

  • ? token_get_all
  • URLs ?
  • PHP Manual
  • Tokenizer 函数
  • 获取提供的 PHP 解析器代号的符号名称

token_name

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

token_name — 获取提供的 PHP 解析器代号的符号名称

说明

token_name ( int $token ) : string

token_name() 获取一个 PHP token 的符号名称.

参数

token

解析器代号的值.

返回值

提供的token 的符号名.

范例

Example #1 token_name() example

<?php
// 260 is the token value for the T_EVAL token
echo token_name(260);        // -> "T_EVAL"

// a token constant maps to its own name
echo token_name(T_FUNCTION); // -> "T_FUNCTION"
?>

参见

  • List of Parser Tokens


URLs

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • URL 函数
    • base64_decode — 对使用 MIME base64 编码的数据进行解码
    • base64_encode — 使用 MIME base64 对数据进行编码
    • get_headers — 取得服务器响应一个 HTTP 请求所发送的所有标头
    • get_meta_tags — 从一个文件中提取所有的 meta 标签 content 属性，返回一个数组
    • http_build_query — 生成 URL-encode 之后的请求字符串
    • parse_url — 解析 URL，返回其组成部分
    • rawurldecode — 对已编码的 URL 字符串进行解码
    • rawurlencode — 按照 RFC 3986 对 URL 进行编码
    • urldecode — 解码已编码的 URL 字符串
    • urlencode — 编码 URL 字符串


  • ? URLs
  • 安装／配置 ?
  • PHP Manual
  • URLs
  • 简介

简介

处理URL字符串: 编码，解码和解析。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

以下常量是为了与 parse_url()使用 在PHP 5.1.2版本。

PHP_URL_SCHEME (integer)
PHP_URL_HOST (integer)
PHP_URL_PORT (integer)
PHP_URL_USER (integer)
PHP_URL_PASS (integer)
PHP_URL_PATH (integer)
PHP_URL_QUERY (integer)
PHP_URL_FRAGMENT (integer)
PHP_QUERY_RFC1738 (integer)
PHP_QUERY_RFC3986 (integer)


URL 函数

Table of Contents

  • base64_decode — 对使用 MIME base64 编码的数据进行解码
  • base64_encode — 使用 MIME base64 对数据进行编码
  • get_headers — 取得服务器响应一个 HTTP 请求所发送的所有标头
  • get_meta_tags — 从一个文件中提取所有的 meta 标签 content 属性，返回一个数组
  • http_build_query — 生成 URL-encode 之后的请求字符串
  • parse_url — 解析 URL，返回其组成部分
  • rawurldecode — 对已编码的 URL 字符串进行解码
  • rawurlencode — 按照 RFC 3986 对 URL 进行编码
  • urldecode — 解码已编码的 URL 字符串
  • urlencode — 编码 URL 字符串


对使用 MIME base64 编码的数据进行解码

  • ? URL 函数
  • base64_encode ?
  • PHP Manual
  • URL 函数
  • 对使用 MIME base64 编码的数据进行解码

base64_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

base64_decode — 对使用 MIME base64 编码的数据进行解码

说明

base64_decode ( string $data , bool $strict = false ) : string

对 base64 编码的 data 进行解码。

参数

data

编码过的数据。

strict

当设置 strict 为 true 时，一旦输入的数据超出了 base64 字母表，将返回 false。 否则会静默丢弃无效的字符。

返回值

返回原始数据， 或者在失败时返回 false。返回的数据可能是二进制的。

更新日志

版本 | 说明
5.2.0 | 增加了 strict 。

范例

Example #1 base64_decode() 示例

<?php
$str = 'VGhpcyBpcyBhbiBlbmNvZGVkIHN0cmluZw==';
echo base64_decode($str);
?>

以上例程会输出：

This is an encoded string

参见

  • base64_encode() - 使用 MIME base64 对数据进行编码
  • » RFC 2045 的 6.8 章节。


使用 MIME base64 对数据进行编码

  • ? base64_decode
  • get_headers ?
  • PHP Manual
  • URL 函数
  • 使用 MIME base64 对数据进行编码

base64_encode

(PHP 4, PHP 5, PHP 7, PHP 8)

base64_encode — 使用 MIME base64 对数据进行编码

说明

base64_encode ( string $data ) : string

使用 base64 对 data 进行编码。

设计此种编码是为了使二进制数据可以通过非纯 8-bit 的传输层传输，例如电子邮件的主体。

Base64-encoded 数据要比原始数据多占用 33% 左右的空间。

参数

data

要编码的数据。

返回值

编码后的字符串数据， 或者在失败时返回 false。

范例

Example #1 base64_encode() 示例

<?php
$str = 'This is an encoded string';
echo base64_encode($str);
?>

以上例程会输出：

VGhpcyBpcyBhbiBlbmNvZGVkIHN0cmluZw==

参见

  • base64_decode() - 对使用 MIME base64 编码的数据进行解码
  • chunk_split() - 将字符串分割成小块
  • convert_uuencode() - 使用 uuencode 编码一个字符串
  • » RFC 2045 6.8 章节


取得服务器响应一个 HTTP 请求所发送的所有标头

  • ? base64_encode
  • get_meta_tags ?
  • PHP Manual
  • URL 函数
  • 取得服务器响应一个 HTTP 请求所发送的所有标头

get_headers

(PHP 5, PHP 7, PHP 8)

get_headers — 取得服务器响应一个 HTTP 请求所发送的所有标头

说明

get_headers ( string $url , int $format = 0 ) : array

get_headers() 返回一个数组，包含有服务器响应一个 HTTP 请求所发送的标头。

参数

url

目标 URL。

format

如果将可选的 format 参数设为 1，则 get_headers() 会解析相应的信息并设定数组的键名。

返回值

返回包含有服务器响应一个 HTTP 请求所发送标头的索引或关联数组，如果失败则返回 false。

更新日志

版本 | 说明
5.1.3 | 自 PHP 5.1.3 起本函数使用默认的流上下文，其可以用 stream_context_get_default() 函数设定和修改。

范例

Example #1 get_headers() 例子

<?php
$url = 'http://www.example.com';

print_r(get_headers($url));

print_r(get_headers($url, 1));
?>

以上例程的输出类似于：

Array
(
    [0] => HTTP/1.1 200 OK
    [1] => Date: Sat, 29 May 2004 12:28:13 GMT
    [2] => Server: Apache/1.3.27 (Unix)  (Red-Hat/Linux)
    [3] => Last-Modified: Wed, 08 Jan 2003 23:11:55 GMT
    [4] => ETag: "3f80f-1b6-3e1cb03b"
    [5] => Accept-Ranges: bytes
    [6] => Content-Length: 438
    [7] => Connection: close
    [8] => Content-Type: text/html
)

Array
(
    [0] => HTTP/1.1 200 OK
    [Date] => Sat, 29 May 2004 12:28:14 GMT
    [Server] => Apache/1.3.27 (Unix)  (Red-Hat/Linux)
    [Last-Modified] => Wed, 08 Jan 2003 23:11:55 GMT
    [ETag] => "3f80f-1b6-3e1cb03b"
    [Accept-Ranges] => bytes
    [Content-Length] => 438
    [Connection] => close
    [Content-Type] => text/html
)

Example #2 get_headers() using HEAD example

<?php
// By default get_headers uses a GET request to fetch the headers. If you
// want to send a HEAD request instead, you can do so using a stream context:
stream_context_set_default(
    array(
        'http' => array(
            'method' => 'HEAD'
        )
    )
);
$headers = get_headers('http://example.com');
?>

参见

  • apache_request_headers() - 获取全部 HTTP 请求头信息


从一个文件中提取所有的 meta 标签 content 属性，返回一个数组

  • ? get_headers
  • http_build_query ?
  • PHP Manual
  • URL 函数
  • 从一个文件中提取所有的 meta 标签 content 属性，返回一个数组

get_meta_tags

(PHP 4, PHP 5, PHP 7, PHP 8)

get_meta_tags — 从一个文件中提取所有的 meta 标签 content 属性，返回一个数组

说明

get_meta_tags ( string $filename , bool $use_include_path = false ) : array

打开 filename 逐行解析文件中的 <meta> 标签。解析工作将在 </head> 处停止。

参数

filename

HTML 文件的路径字符串。 此参数可以是本地文件也可以是一个 URL。

Example #1 get_meta_tags() 解析了什么

<meta name="author" content="name">
<meta name="keywords" content="php documentation">
<meta name="DESCRIPTION" content="a php manual">
<meta name="geo.position" content="49.33;-86.59">
</head> <!-- 解析工作在此处停止 -->
（注意回车换行 － PHP 使用一个本地函数来解析输入，所以 Mac 上的文件将不能在 Unix 上正常工作）。

use_include_path

将 use_include_path 设置为 true 将使 PHP 尝试按照 include_path 标准包含路径中的每个指向去打开文件。这只用于本地文件，不适用于 URL。

返回值

返回一个数组，包含所有解析过的 meta 标签。

返回的关联数组以属性 name 的值作为键，属性 content 的值作为值，所以你可以很容易地使用标准数组函数遍历此关联数组或访问某个值。 属性 name 中的特殊字符将使用'_'替换，而其它字符则转换成小写。如果有两个 meta 标签拥有相同的 name，则只返回最后出现的那一个。

更新日志

版本 | 说明
4.0.5 | 开始支持没有使用引号括起来的 HTML 属性。

范例

Example #2 get_meta_tags() 返回什么些

<?php
// 假设上边的标签是在 www.example.com 中
$tags = get_meta_tags('http://www.example.com/');

// 注意所有的键（key）均为小写，而键中的'.'则转换成了'_'。
echo $tags['author'];       // name
echo $tags['keywords'];     // php documentation
echo $tags['description'];  // a php manual
echo $tags['geo_position']; // 49.33;-86.59
?>

注释

Note:

只有包含 name 属性的 meta 标签才会被解析。

参见

  • htmlentities() - 将字符转换为 HTML 转义字符
  • urlencode() - 编码 URL 字符串


生成 URL-encode 之后的请求字符串

  • ? get_meta_tags
  • parse_url ?
  • PHP Manual
  • URL 函数
  • 生成 URL-encode 之后的请求字符串

http_build_query

(PHP 5, PHP 7, PHP 8)

http_build_query — 生成 URL-encode 之后的请求字符串

说明

http_build_query ( mixed $query_data , string $numeric_prefix = ? , string $arg_separator = ? , int $enc_type = PHP_QUERY_RFC1738 ) : string

使用给出的关联（或下标）数组生成一个经过 URL-encode 的请求字符串。

参数

query_data

可以是数组或包含属性的对象。

一个 query_data 数组可以是简单的一维结构，也可以是由数组组成的数组（其依次可以包含其它数组）。

如果 query_data 是一个对象，只有 public 的属性会加入结果。

numeric_prefix

如果在基础数组中使用了数字下标同时给出了该参数，此参数值将会作为基础数组中的数字下标元素的前缀。

这是为了让 PHP 或其它 CGI 程序在稍后对数据进行解码时获取合法的变量名。

arg_separator

除非指定并使用了这个参数，否则会用 arg_separator.output 来分隔参数。

enc_type

默认使用 PHP_QUERY_RFC1738。

如果 enc_type 是 PHP_QUERY_RFC1738，则编码将会以 » RFC 1738 标准和 application/x-www-form-urlencoded 媒体类型进行编码，空格会被编码成加号（+）。

如果 enc_type 是 PHP_QUERY_RFC3986，将根据 » RFC 3986 编码，空格会被百分号编码（%20）。

返回值

返回一个 URL 编码后的字符串。

更新日志

版本 | 说明
5.4.0 | 加入了 enc_type 参数。
5.1.3 | 方括号也会被转义。
5.1.2 | 加入了参数 arg_separator。

范例

Example #1 http_build_query() 使用示例

<?php
$data = array('foo'=>'bar',
              'baz'=>'boom',
              'cow'=>'milk',
              'php'=>'hypertext processor');

echo http_build_query($data) . "\n";
echo http_build_query($data, '', '&amp;');

?>

以上例程会输出：

foo=bar&baz=boom&cow=milk&php=hypertext+processor
foo=bar&amp;baz=boom&amp;cow=milk&amp;php=hypertext+processor

Example #2 http_build_query() 使用数字下标的元素

<?php
$data = array('foo', 'bar', 'baz', 'boom', 'cow' => 'milk', 'php' =>'hypertext processor');

echo http_build_query($data) . "\n";
echo http_build_query($data, 'myvar_');
?>

以上例程会输出：

0=foo&1=bar&2=baz&3=boom&cow=milk&php=hypertext+processor
myvar_0=foo&myvar_1=bar&myvar_2=baz&myvar_3=boom&cow=milk&php=hypertext+processor

Example #3 http_build_query() 使用复杂的数组

<?php
$data = array('user'=>array('name'=>'Bob Smith',
                            'age'=>47,
                            'sex'=>'M',
                            'dob'=>'5/12/1956'),
              'pastimes'=>array('golf', 'opera', 'poker', 'rap'),
              'children'=>array('bobby'=>array('age'=>12,
                                               'sex'=>'M'),
                                'sally'=>array('age'=>8,
                                               'sex'=>'F')),
              'CEO');

echo http_build_query($data, 'flags_');
?>

这会输出：（为了可读性，字已经换行了）

user%5Bname%5D=Bob+Smith&user%5Bage%5D=47&user%5Bsex%5D=M&
user%5Bdob%5D=5%2F12%2F1956&pastimes%5B0%5D=golf&pastimes%5B1%5D=opera&
pastimes%5B2%5D=poker&pastimes%5B3%5D=rap&children%5Bbobby%5D%5Bage%5D=12&
children%5Bbobby%5D%5Bsex%5D=M&children%5Bsally%5D%5Bage%5D=8&
children%5Bsally%5D%5Bsex%5D=F&flags_0=CEO

Note:

只有基础数组中的数字下标元素"CEO"才获取了前缀，其它数字下标元素（如 pastimes 下的元素）则不需要为了合法的变量名而加上前缀。

Example #4 http_build_query() 使用对象

<?php
class parentClass {
    public    $pub      = 'publicParent';
    protected $prot     = 'protectedParent';
    private   $priv     = 'privateParent';
    public    $pub_bar  = Null;
    protected $prot_bar = Null;
    private   $priv_bar = Null;

    public function __construct(){
        $this->pub_bar  = new childClass();
        $this->prot_bar = new childClass();
        $this->priv_bar = new childClass();
    }
}

class childClass {
    public    $pub  = 'publicChild';
    protected $prot = 'protectedChild';
    private   $priv = 'privateChild';
}

$parent = new parentClass();

echo http_build_query($parent);
?>

以上例程会输出：

pub=publicParent&pub_bar%5Bpub%5D=publicChild

参见

  • parse_str() - 将字符串解析成多个变量
  • parse_url() - 解析 URL，返回其组成部分
  • urlencode() - 编码 URL 字符串
  • array_walk() - 使用用户自定义函数对数组中的每个元素做回调处理


解析 URL，返回其组成部分

  • ? http_build_query
  • rawurldecode ?
  • PHP Manual
  • URL 函数
  • 解析 URL，返回其组成部分

parse_url

(PHP 4, PHP 5, PHP 7, PHP 8)

parse_url — 解析 URL，返回其组成部分

说明

parse_url ( string $url , int $component = -1 ) : mixed

本函数解析一个 URL 并返回一个关联数组，包含在 URL 中出现的各种组成部分。

本函数不是用来验证给定 URL 的合法性的，只是将其分解为下面列出的部分。不完整的 URL 也被接受，parse_url() 会尝试尽量正确地将其解析。

参数

url

要解析的 URL。无效字符将使用 _ 来替换。

component

指定 PHP_URL_SCHEME、 PHP_URL_HOST、 PHP_URL_PORT、 PHP_URL_USER、 PHP_URL_PASS、 PHP_URL_PATH、 PHP_URL_QUERY 或 PHP_URL_FRAGMENT 的其中一个来获取 URL 中指定的部分的 string。 （除了指定为 PHP_URL_PORT 后，将返回一个 integer 的值）。

返回值

对严重不合格的 URL，parse_url() 可能会返回 false。

如果省略了 component 参数，将返回一个关联数组 array，在目前至少会有一个元素在该数组中。数组中可能的键有以下几种：

  • scheme - 如 http
  • host
  • port
  • user
  • pass
  • path
  • query - 在问号 ? 之后
  • fragment - 在散列符号 # 之后

如果指定了 component 参数， parse_url() 返回一个 string （或在指定为 PHP_URL_PORT 时返回一个 integer）而不是 array。如果 URL 中指定的组成部分不存在，将会返回 null。

更新日志

版本 | 说明
5.4.7 | 修复了 host 在 协议 省略时的识别。
5.3.3 | 在 URL 解析失败时将不会产生 E_WARNING 级别的错误。
5.1.2 | 增加了参数 component。

范例

Example #1 parse_url() 例子

<?php
$url = 'http://username:password@hostname/path?arg=value#anchor';

print_r(parse_url($url));

echo parse_url($url, PHP_URL_PATH);
?>

以上例程会输出：

Array
(
    [scheme] => http
    [host] => hostname
    [user] => username
    [pass] => password
    [path] => /path
    [query] => arg=value
    [fragment] => anchor
)
/path

Example #2 parse_url() 解析丢失协议的例子

<?php
$url = '//www.example.com/path?googleguy=googley';

// 在 5.4.7 之前这会输出路径 "//www.example.com/path"
var_dump(parse_url($url));
?>

以上例程会输出：

array(3) {
  ["host"]=>
  string(15) "www.example.com"
  ["path"]=>
  string(5) "/path"
  ["query"]=>
  string(17) "googleguy=googley"
}

注释

Note:

本函数不能用于相对 URL。

Note:

parse_url() 是专门用来解析 URL 而不是 URI 的。不过为遵从 PHP 向后兼容的需要有个例外，对 file:// 协议允许三个斜线（file:///...）。其它任何协议都不能这样。

参见

  • pathinfo() - 返回文件路径的信息
  • parse_str() - 将字符串解析成多个变量
  • http_build_query() - 生成 URL-encode 之后的请求字符串
  • http_build_url()
  • dirname() - 返回路径中的目录部分
  • basename() - 返回路径中的文件名部分
  • » RFC 3986


对已编码的 URL 字符串进行解码

  • ? parse_url
  • rawurlencode ?
  • PHP Manual
  • URL 函数
  • 对已编码的 URL 字符串进行解码

rawurldecode

(PHP 4, PHP 5, PHP 7, PHP 8)

rawurldecode — 对已编码的 URL 字符串进行解码

说明

rawurldecode ( string $str ) : string

返回字符串，此字符串中百分号（%）后跟两位十六进制数的序列都将被替换成原义字符。

参数

str

要解码的 URL。

返回值

返回解码后的 URL 字符串。

范例

Example #1 rawurldecode() 示例

<?php

echo rawurldecode('foo%20bar%40baz'); // foo bar@baz

?>

注释

Note:

rawurldecode() 不会把加号（'+'）解码为空格，而 urldecode() 可以。

参见

  • rawurlencode() - 按照 RFC 3986 对 URL 进行编码
  • urldecode() - 解码已编码的 URL 字符串
  • urlencode() - 编码 URL 字符串
  • » RFC 3986


按照 RFC 3986 对 URL 进行编码

  • ? rawurldecode
  • urldecode ?
  • PHP Manual
  • URL 函数
  • 按照 RFC 3986 对 URL 进行编码

rawurlencode

(PHP 4, PHP 5, PHP 7, PHP 8)

rawurlencode — 按照 RFC 3986 对 URL 进行编码

说明

rawurlencode ( string $str ) : string

根据 » RFC 3986 编码指定的字符。

参数

str

要编码的 URL。

返回值

返回字符串，此字符串中除了 -_. 之外的所有非字母数字字符都将被替换成百分号（%）后跟两位十六进制数。这是在 » RFC 3986 中描述的编码，是为了保护原义字符以免其被解释为特殊的 URL 定界符，同时保护 URL 格式以免其被传输媒体（像一些邮件系统）使用字符转换时弄乱。

Note:

在 PHP 5.3.0 之前，rawurlencode 根据 » RFC 1738 来编码波浪线（~）。

更新日志

版本 | 说明
5.3.4 | 因为 rawurlencode() 使用了 EBCDIC，所以波浪线字符不会再被编码。
5.3.0 | 现在符合了» RFC 3986。

范例

Example #1 在 FTP URL 里包含一个密码

<?php
echo '<a href="ftp://user:', rawurlencode('foo @+%/'),
     '@ftp.example.com/x.txt">';
?>

以上例程会输出：

<a href="ftp://user:foo%20%40%2B%25%2F@ftp.example.com/x.txt">

或者，如果你想通过 URL 的 PATH_INFO 构成部分去传递信息：

Example #2 rawurlencode() 示例 2

<?php
echo '<a href="http://example.com/department_list_script/',
    rawurlencode('sales and marketing/Miami'), '">';
?>

以上例程会输出：

<a href="http://example.com/department_list_script/sales%20and%20marketing%2FMiami">

参见

  • rawurldecode() - 对已编码的 URL 字符串进行解码
  • urldecode() - 解码已编码的 URL 字符串
  • urlencode() - 编码 URL 字符串
  • » RFC 3986


解码已编码的 URL 字符串

  • ? rawurlencode
  • urlencode ?
  • PHP Manual
  • URL 函数
  • 解码已编码的 URL 字符串

urldecode

(PHP 4, PHP 5, PHP 7, PHP 8)

urldecode — 解码已编码的 URL 字符串

说明

urldecode ( string $str ) : string

解码给出的已编码字符串中的任何 %##。 加号（'+'）被解码成一个空格字符。

参数

str

要解码的字符串。

返回值

返回解码后的字符串。

范例

Example #1 urldecode() 示例

<?php
$query = "my=apples&are=green+and+red";

foreach (explode('&', $query) as $chunk) {
    $param = explode("=", $chunk);

    if ($param) {
        printf("Value for parameter \"%s\" is \"%s\"<br/>\n", urldecode($param[0]), urldecode($param[1]));
    }
}
?>

注释

Warning

超全局变量 $_GET 和 $_REQUEST 已经被解码了。对 $_GET 或 $_REQUEST 里的元素使用 urldecode() 将会导致不可预计和危险的结果。

参见

  • urlencode() - 编码 URL 字符串
  • rawurlencode() - 按照 RFC 3986 对 URL 进行编码
  • rawurldecode() - 对已编码的 URL 字符串进行解码
  • » RFC 3986


编码 URL 字符串

  • ? urldecode
  • V8js ?
  • PHP Manual
  • URL 函数
  • 编码 URL 字符串

urlencode

(PHP 4, PHP 5, PHP 7, PHP 8)

urlencode — 编码 URL 字符串

说明

urlencode ( string $str ) : string

此函数便于将字符串编码并将其用于 URL 的请求部分，同时它还便于将变量传递给下一页。

参数

str

要编码的字符串。

返回值

返回字符串，此字符串中除了 -_. 之外的所有非字母数字字符都将被替换成百分号（%）后跟两位十六进制数，空格则编码为加号（+）。此编码与 WWW 表单 POST 数据的编码方式是一样的，同时与 application/x-www-form-urlencoded 的媒体类型编码方式一样。由于历史原因，此编码在将空格编码为加号（+）方面与 » RFC3986 编码（参见 rawurlencode()）不同。

范例

Example #1 urlencode() 例子

<?php
echo '<a href="mycgi?foo=', urlencode($userinput), '">';
?>

Example #2 urlencode() 与 htmlentities() 例子

<?php
$query_string = 'foo=' . urlencode($foo) . '&bar=' . urlencode($bar);
echo '<a href="mycgi?' . htmlentities($query_string) . '">';
?>

注释

Note:

注意：小心与 HTML 实体相匹配的变量。像 &amp、&copy 和 &pound 都将被浏览器解析，并使用实际实体替代所期待的变量名。这是明显的混乱，W3C 已经告诫人们好几年了。参考地址：» http://www.w3.org/TR/html4/appendix/notes.html#h-B.2.2。

PHP 通过 arg_separator.ini 指令，支持将参数分割符变成 W3C 所建议的分号。不幸的是大多数用户代理并不发送分号分隔符格式的表单数据。较为简单的解决办法是使用 &amp; 代替 & 作为分隔符。你不需要为此修改 PHP 的 arg_separator。让它仍为 &，而仅使用 htmlentities() 或 htmlspecialchars() 对你的 URL 进行编码。

参见

  • urldecode() - 解码已编码的 URL 字符串
  • htmlentities() - 将字符转换为 HTML 转义字符
  • rawurlencode() - 按照 RFC 3986 对 URL 进行编码
  • rawurldecode() - 对已编码的 URL 字符串进行解码
  • » RFC 3986


V8 Javascript Engine Integration

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 范例
  • V8Js — The V8Js class
    • V8Js::__construct — Construct a new V8Js object
    • V8Js::executeString — Execute a string as Javascript code
    • V8Js::getExtensions — Return an array of registered extensions
    • V8Js::getPendingException — Return pending uncaught Javascript exception
    • V8Js::registerExtension — Register Javascript extensions for V8Js
  • V8JsException — The V8JsException class
    • V8JsException::getJsFileName — The getJsFileName purpose
    • V8JsException::getJsLineNumber — The getJsLineNumber purpose
    • V8JsException::getJsSourceLine — The getJsSourceLine purpose
    • V8JsException::getJsTrace — The getJsTrace purpose


简介

This extension embeds the » V8 Javascript Engine into PHP.


需求

PHP 5.3.3+ and V8 library and headers installed in proper paths.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/v8js


运行时配置

这些函数的行为受 php.ini 中的设置影响。

V8js 配置选项
名字 | 默认 | 可修改范围 | 更新日志
v8js.max_disposed_contexts | 25 | PHP_INI_ALL |
v8js.flags |  | PHP_INI_ALL |

这是配置指令的简短说明。

v8js.max_disposed_contexts int

Sets limit for disposed contexts before forcing V8 to do garbage collection.

v8js.flags string

Sets V8 command line flags. The list of available flags can be obtained in CLI mode by setting this parameter to --help. Example:

$ php -r 'ini_set("v8js.flags", "--help"); new V8Js;' | less

Note:

For these flags to be effective in runtime the ini_set() call has to be done before any V8Js objects are instantiated!


  • ? 运行时配置
  • 范例 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


范例

Basic usage

Example #1 Basic Javascript execution

<?php

$v8 = new V8Js();

/* basic.js */
$JS = <<< EOT
len = print('Hello' + ' ' + 'World!' + "\\n");
len;
EOT;

try {
  var_dump($v8->executeString($JS, 'basic.js'));
} catch (V8JsException $e) {
  var_dump($e);
}

?>

以上例程会输出：

Hello World!
int(13)


The V8Js class

(PECL v8js >= 0.1.0)

简介

This is the core class for V8Js extension. Each instance created from this class has own context in which all JavaScript is compiled and executed.

See V8Js::__construct() for more information.

类摘要

V8Js {
/* Constants */
const string V8_VERSION ;
const int FLAG_NONE = 1 ;
const int FLAG_FORCE_ARRAY = 2 ;
/* Methods */
public __construct ( string $object_name = "PHP" , array $variables = array() , array $extensions = array() , bool $report_uncaught_exceptions = true )
public executeString ( string $script , string $identifier = "V8Js::executeString()" , int $flags = V8Js::FLAG_NONE ) : mixed
public static getExtensions ( ) : array
public getPendingException ( ) : V8JsException
public static registerExtension ( string $extension_name , string $script , array $dependencies = array() , bool $auto_enable = false ) : bool
}

预定义常量

V8Js::V8_VERSION

The V8 Javascript Engine version.

V8Js::FLAG_NONE

No flags.

V8Js::FLAG_FORCE_ARRAY

Forces all JS objects to be associative arrays in PHP.

Table of Contents

  • V8Js::__construct — Construct a new V8Js object
  • V8Js::executeString — Execute a string as Javascript code
  • V8Js::getExtensions — Return an array of registered extensions
  • V8Js::getPendingException — Return pending uncaught Javascript exception
  • V8Js::registerExtension — Register Javascript extensions for V8Js


Construct a new V8Js object

  • ? V8Js
  • V8Js::executeString ?
  • PHP Manual
  • V8Js
  • Construct a new V8Js object

V8Js::__construct

(PECL v8js >= 0.1.0)

V8Js::__construct — Construct a new V8Js object

说明

public V8Js::__construct
 ( string $object_name = "PHP"
, array $variables = array()
, array $extensions = array()
, bool $report_uncaught_exceptions = true
)

Constructs a new V8Js object.

参数

object_name

The name of the object passed to Javascript.

variables

Map of PHP variables that will be available in Javascript. Must be an associative array in format array("name-for-js" => "name-of-php-variable"). Defaults to empty array.

extensions

List of extensions registered using V8Js::registerExtension() which should be available in the Javascript context of the created V8Js object.

Note:

Extensions registered to be enabled automatically do not need to be listed in this array. Also if an extension has dependencies, those dependencies can be omitted as well. Defaults to empty array.

report_uncaught_exceptions

Controls whether uncaught Javascript exceptions are reported immediately or not. Defaults to true. If set to false the uncaught exception can be accessed using V8Js::getPendingException().

返回值

Returns a new V8Js context object.


Execute a string as Javascript code

  • ? V8Js::__construct
  • V8Js::getExtensions ?
  • PHP Manual
  • V8Js
  • Execute a string as Javascript code

V8Js::executeString

(PECL v8js >= 0.1.0)

V8Js::executeString — Execute a string as Javascript code

说明

public V8Js::executeString ( string $script , string $identifier = "V8Js::executeString()" , int $flags = V8Js::FLAG_NONE ) : mixed

Compiles and executes the string passed with script as Javascript code.

参数

script

The code string to be executed.

identifier

Identifier string for the executed code. Used for debugging.

flags

Execution flags. This value must be one of the V8Js::FLAG_* constants, defaulting to V8Js::FLAG_NONE.

  • V8Js::FLAG_NONE: no flags

  • V8Js::FLAG_FORCE_ARRAY: forces all Javascript objects passed to PHP to be associative arrays

返回值

Returns the last variable instantiated in the Javascript code converted to matching PHP variable type.


Return an array of registered extensions

  • ? V8Js::executeString
  • V8Js::getPendingException ?
  • PHP Manual
  • V8Js
  • Return an array of registered extensions

V8Js::getExtensions

(PECL v8js >= 0.1.0)

V8Js::getExtensions — Return an array of registered extensions

说明

public static V8Js::getExtensions ( ) : array

This function returns array of Javascript extensions registered using V8Js::registerExtension().

参数

此函数没有参数。

返回值

Returns an array of registered extensions or an empty array if there are none.


Return pending uncaught Javascript exception

  • ? V8Js::getExtensions
  • V8Js::registerExtension ?
  • PHP Manual
  • V8Js
  • Return pending uncaught Javascript exception

V8Js::getPendingException

(PECL v8js >= 0.1.0)

V8Js::getPendingException — Return pending uncaught Javascript exception

说明

public V8Js::getPendingException ( ) : V8JsException

Returns any pending uncaught Javascript exception as V8JsException left from earlier V8Js::executeString() call(s).

参数

此函数没有参数。

返回值

Either V8JsException or null.


Register Javascript extensions for V8Js

  • ? V8Js::getPendingException
  • V8JsException ?
  • PHP Manual
  • V8Js
  • Register Javascript extensions for V8Js

V8Js::registerExtension

(PECL v8js >= 0.1.0)

V8Js::registerExtension — Register Javascript extensions for V8Js

说明

public static V8Js::registerExtension ( string $extension_name , string $script , array $dependencies = array() , bool $auto_enable = false ) : bool

Registers passed Javascript script as extension to be used in V8Js contexts.

参数

extension_name

Name of the extension to be registered.

script

The Javascript code to be registered.

dependencies

Array of extension names the extension to be registered depends on. Any such extension is enabled automatically when this extension is loaded.

Note:

All extensions, including the dependencies, must be registered before any V8Js are created which use them.

auto_enable

If set to true, the extension will be enabled automatically in all V8Js contexts.

返回值

Returns true if extension was registered successfully, false otherwise.


The V8JsException class

(PECL v8js >= 0.1.0)

简介

类摘要

V8JsException extends Exception {
/* 属性 */
protected $JsFileName ;
protected $JsLineNumber ;
protected $JsSourceLine ;
protected $JsTrace ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
final public getJsFileName ( ) : string
final public getJsLineNumber ( ) : int
final public getJsSourceLine ( ) : string
final public getJsTrace ( ) : string
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

JsFileName

JsLineNumber

JsSourceLine

JsTrace

Table of Contents

  • V8JsException::getJsFileName — The getJsFileName purpose
  • V8JsException::getJsLineNumber — The getJsLineNumber purpose
  • V8JsException::getJsSourceLine — The getJsSourceLine purpose
  • V8JsException::getJsTrace — The getJsTrace purpose


The getJsFileName purpose

  • ? V8JsException
  • V8JsException::getJsLineNumber ?
  • PHP Manual
  • V8JsException
  • The getJsFileName purpose

V8JsException::getJsFileName

(PECL v8js >= 0.1.0)

V8JsException::getJsFileName — The getJsFileName purpose

说明

final public V8JsException::getJsFileName ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getJsLineNumber purpose

  • ? V8JsException::getJsFileName
  • V8JsException::getJsSourceLine ?
  • PHP Manual
  • V8JsException
  • The getJsLineNumber purpose

V8JsException::getJsLineNumber

(PECL v8js >= 0.1.0)

V8JsException::getJsLineNumber — The getJsLineNumber purpose

说明

final public V8JsException::getJsLineNumber ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getJsSourceLine purpose

  • ? V8JsException::getJsLineNumber
  • V8JsException::getJsTrace ?
  • PHP Manual
  • V8JsException
  • The getJsSourceLine purpose

V8JsException::getJsSourceLine

(PECL v8js >= 0.1.0)

V8JsException::getJsSourceLine — The getJsSourceLine purpose

说明

final public V8JsException::getJsSourceLine ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getJsTrace purpose

  • ? V8JsException::getJsSourceLine
  • Yaml ?
  • PHP Manual
  • V8JsException
  • The getJsTrace purpose

V8JsException::getJsTrace

(PECL v8js >= 0.1.0)

V8JsException::getJsTrace — The getJsTrace purpose

说明

final public V8JsException::getJsTrace ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


YAML 数据序列化

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Callbacks
    • Parse callbacks
    • Emit callbacks
  • Yaml 函数
    • yaml_emit_file — Send the YAML representation of a value to a file
    • yaml_emit — Returns the YAML representation of a value
    • yaml_parse_file — Parse a YAML stream from a file
    • yaml_parse_url — Parse a Yaml stream from a URL
    • yaml_parse — Parse a YAML stream


简介

本扩展实现了 » YAML Ain't Markup Language (YAML) 数据序列化标准。 通过 » LibYAML library 来解析和编码。


需求

This extension requires the » LibYAML C library version 0.1.0 or higher to be installed.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/yaml.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Yaml 配置选项
名字 | 默认 | 可修改范围 | 更新日志
yaml.decode_binary | 0 | PHP_INI_ALL |
yaml.decode_php | 0 | PHP_INI_ALL | Added in 1.2.0, before 2.0.0 the default was 1
yaml.decode_timestamp | 0 | PHP_INI_ALL |
yaml.output_canonical | 0 | PHP_INI_ALL |
yaml.output_indent | 2 | PHP_INI_ALL |
yaml.output_width | 80 | PHP_INI_ALL |

这是配置指令的简短说明。

yaml.decode_binary bool

Off by default, but can be set to on to cause base64 binary encoded entities which have the explicit tag "tag:yaml.org,2002:binary" to be decoded.

yaml.decode_php bool

Off by default, but can be set to on to cause serialized php objects which have the explicit tag "!php/object" to be unserialized.

yaml.decode_timestamp int

Controls the decoding of both implicit and explicit "tag:yaml.org,2002:timestamp" scalars in the YAML document stream. The default setting of 0 will not apply any decoding. A setting of 1 will use strtotime() to parse the timestamp value as a Unix timestamp. A setting of 2 will use date_create() to parse the timestamp value as DateTime object.

yaml.output_canonical bool

Off by default, but can be set to on to cause canonical form output.

yaml.output_indent int

Number of spaces to indent sections. Value should be between 1 and 10.

yaml.output_width int

Set the preferred line width. -1 means unlimited.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

yaml_parse() 回调方法所使用的实体标量的风格。
YAML_ANY_SCALAR_STYLE (integer)
YAML_PLAIN_SCALAR_STYLE (integer)
YAML_SINGLE_QUOTED_SCALAR_STYLE (integer)
YAML_DOUBLE_QUOTED_SCALAR_STYLE (integer)
YAML_LITERAL_SCALAR_STYLE (integer)
YAML_FOLDED_SCALAR_STYLE (integer)
yaml_parse() 回调方法 可使用的通用标签。
YAML_NULL_TAG (string)
"tag:yaml.org,2002:null"
YAML_BOOL_TAG (string)
"tag:yaml.org,2002:bool"
YAML_STR_TAG (string)
"tag:yaml.org,2002:str"
YAML_INT_TAG (string)
"tag:yaml.org,2002:int"
YAML_FLOAT_TAG (string)
"tag:yaml.org,2002:float"
YAML_TIMESTAMP_TAG (string)
"tag:yaml.org,2002:timestamp"
YAML_SEQ_TAG (string)
"tag:yaml.org,2002:seq"
YAML_MAP_TAG (string)
"tag:yaml.org,2002:map"
YAML_PHP_TAG (string)
"!php/object"
Encoding types for yaml_emit()
YAML_ANY_ENCODING (integer)
让发射器(emitter)选择一个编码。
YAML_UTF8_ENCODING (integer)
以 UTF8 编码。
YAML_UTF16LE_ENCODING (integer)
以 UTF16LE 编码。
YAML_UTF16BE_ENCODING (integer)
以 UTF16BE 编码。
yaml_emit() 的换行符类型
YAML_ANY_BREAK (integer)
让发射器(emitter)选择一个换行符。
YAML_CR_BREAK (integer)
使用 \r 作为换行符(Mac 风格)。
YAML_LN_BREAK (integer)
使用 \n 作为换行符(Unix 风格)。
YAML_CRLN_BREAK (integer)
使用 \r\n 作为换行符(DOS 风格)。


范例

Example #1 Yaml 范例

<?php
$addr = array(
    "given" => "Chris",
    "family"=> "Dumars",
    "address"=> array(
        "lines"=> "458 Walkman Dr.
        Suite #292",
        "city"=> "Royal Oak",
        "state"=> "MI",
        "postal"=> 48046,
      ),
  );
$invoice = array (
    "invoice"=> 34843,
    "date"=> "2001-01-23",
    "bill-to"=> $addr,
    "ship-to"=> $addr,
    "product"=> array(
        array(
            "sku"=> "BL394D",
            "quantity"=> 4,
            "description"=> "Basketball",
            "price"=> 450,
          ),
        array(
            "sku"=> "BL4438H",
            "quantity"=> 1,
            "description"=> "Super Hoop",
            "price"=> 2392,
          ),
      ),
    "tax"=> 251.42,
    "total"=> 4443.52,
    "comments"=> "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.",
    );

// 把该 invoice 转换生成 YAML 的表示法
$yaml = yaml_emit($invoice);
var_dump($yaml);

// 把 YAML 转换成 PHP 变量
$parsed = yaml_parse($yaml);

// 来回转换，以检查两个结构是否相等效
var_dump($parsed == $invoice);
?>

以上例程的输出类似于：

string(631) "---
invoice: 34843
date: "2001-01-23"
bill-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
"
bool(true)


  • ? 范例
  • Parse callbacks ?
  • PHP Manual
  • Yaml
  • Callbacks

Callbacks

Table of Contents

  • Parse callbacks
  • Emit callbacks


Parse callbacks

Parse callables are invoked by yaml_parse(), yaml_parse_file() or yaml_parse_url() functions when a registered YAML tag is encountered. The callback is passed the tagged entity's value, the tag, and flags indicating the scalar entity style. The callback must return the data that the YAML parser should emit for this entity.

Example #1 Parse callback example

<?php
/**
 * Parsing callback for yaml tag.
 * @param mixed $value Data from yaml file
 * @param string $tag Tag that triggered callback
 * @param int $flags Scalar entity style (see YAML_*_SCALAR_STYLE)
 * @return mixed Value that YAML parser should emit for the given value
 */
function tag_callback ($value, $tag, $flags) {
  var_dump(func_get_args()); // debugging
  return "Hello {$value}";
}

$yaml = <<<YAML
greeting: !example/hello World
YAML;

$result = yaml_parse($yaml, 0, $ndocs, array(
    '!example/hello' => 'tag_callback',
  ));

var_dump($result);
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  string(5) "World"
  [1]=>
  string(14) "!example/hello"
  [2]=>
  int(1)
}
array(1) {
  ["greeting"]=>
  string(11) "Hello World"
}


Emit callbacks

Emit callbacks are invoked when an instance of a registered class is emitted by yaml_emit() or yaml_emit_file(). The callback is passed the object to be emitted. The callback must return an array having two keys: "tag" and "data". The value associated with the "tag" key must be a string to be used as the YAML tag in the output. The value associated with the "data" key will be encoded as YAML and emitted in place of the intercepted object.

Example #1 Emit callback example

<?php
class EmitExample {
  public $data;    // data may be in any pecl/yaml suitable type

  public function __construct ($d) {
    $this->data = $d;
  }

  /**
   * Yaml emit callback function, referred on yaml_emit call by class name.
   *
   * Expected to return an array with 2 values:
   *   - 'tag': custom tag for this serialization
   *   - 'data': value to convert to yaml (array, string, bool, number)
   *
   * @param object $obj Object to be emitted
   * @return array Tag and surrogate data to emit
   */
  public static function yamlEmit (EmitExample $obj) {
    return array(
      'tag' => '!example/emit',
      'data' => $obj->data,
    );
  }
}

$emit_callbacks = array(
  'EmitExample' => array('EmitExample', 'yamlEmit')
);

$t = new EmitExample(array('a','b','c'));
$yaml = yaml_emit(
  array(
    'example' => $t,
  ),
  YAML_ANY_ENCODING,
  YAML_ANY_BREAK,
  $emit_callbacks
);
var_dump($yaml);
?>

以上例程的输出类似于：

string(43) "---
example: !example/emit
- a
- b
- c
...
"


Yaml 函数

Table of Contents

  • yaml_emit_file — Send the YAML representation of a value to a file
  • yaml_emit — Returns the YAML representation of a value
  • yaml_parse_file — Parse a YAML stream from a file
  • yaml_parse_url — Parse a Yaml stream from a URL
  • yaml_parse — Parse a YAML stream


Send the YAML representation of a value to a file

  • ? Yaml 函数
  • yaml_emit ?
  • PHP Manual
  • Yaml 函数
  • Send the YAML representation of a value to a file

yaml_emit_file

(PECL yaml >= 0.5.0)

yaml_emit_file — Send the YAML representation of a value to a file

说明

yaml_emit_file ( string $filename , mixed $data , int $encoding = YAML_ANY_ENCODING , int $linebreak = YAML_ANY_BREAK , array $callbacks = null ) : bool

Generate a YAML representation of the provided data in the filename.

参数

filename

Path to the file.

data

The data being encoded. Can be any type except a resource.

encoding

Output character encoding chosen from YAML_ANY_ENCODING, YAML_UTF8_ENCODING, YAML_UTF16LE_ENCODING, YAML_UTF16BE_ENCODING.

linebreak

Output linebreak style chosen from YAML_ANY_BREAK, YAML_CR_BREAK, YAML_LN_BREAK, YAML_CRLN_BREAK.

callbacks

Content handlers for emitting YAML nodes. Associative array of classname => callable mappings. See emit callbacks for more details.

返回值

Returns true on success.

更新日志

版本 | 说明
PECL yaml 1.1.0 | The callbacks parameter was added.

参见

  • yaml_emit() - Returns the YAML representation of a value
  • yaml_parse() - Parse a YAML stream


Returns the YAML representation of a value

  • ? yaml_emit_file
  • yaml_parse_file ?
  • PHP Manual
  • Yaml 函数
  • Returns the YAML representation of a value

yaml_emit

(PECL yaml >= 0.5.0)

yaml_emit — Returns the YAML representation of a value

说明

yaml_emit ( mixed $data , int $encoding = YAML_ANY_ENCODING , int $linebreak = YAML_ANY_BREAK , array $callbacks = null ) : string

Generate a YAML representation of the provided data.

参数

data

The data being encoded. Can be any type except a resource.

encoding

Output character encoding chosen from YAML_ANY_ENCODING, YAML_UTF8_ENCODING, YAML_UTF16LE_ENCODING, YAML_UTF16BE_ENCODING.

linebreak

Output linebreak style chosen from YAML_ANY_BREAK, YAML_CR_BREAK, YAML_LN_BREAK, YAML_CRLN_BREAK.

callbacks

Content handlers for emitting YAML nodes. Associative array of classname => callable mappings. See emit callbacks for more details.

返回值

Returns a YAML encoded string on success.

更新日志

版本 | 说明
PECL yaml 1.1.0 | The callbacks parameter was added.

范例

Example #1 yaml_emit() example

<?php
$addr = array(
    "given" => "Chris",
    "family"=> "Dumars",
    "address"=> array(
        "lines"=> "458 Walkman Dr.
        Suite #292",
        "city"=> "Royal Oak",
        "state"=> "MI",
        "postal"=> 48046,
      ),
  );
$invoice = array (
    "invoice"=> 34843,
    "date"=> 980208000,
    "bill-to"=> $addr,
    "ship-to"=> $addr,
    "product"=> array(
        array(
            "sku"=> "BL394D",
            "quantity"=> 4,
            "description"=> "Basketball",
            "price"=> 450,
          ),
        array(
            "sku"=> "BL4438H",
            "quantity"=> 1,
            "description"=> "Super Hoop",
            "price"=> 2392,
          ),
      ),
    "tax"=> 251.42,
    "total"=> 4443.52,
    "comments"=> "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.",
  );
var_dump(yaml_emit($invoice));
?>

以上例程的输出类似于：

string(628) "---
invoice: 34843
date: 980208000
bill-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
"

参见

  • yaml_emit_file() - Send the YAML representation of a value to a file
  • yaml_parse() - Parse a YAML stream


Parse a YAML stream from a file

  • ? yaml_emit
  • yaml_parse_url ?
  • PHP Manual
  • Yaml 函数
  • Parse a YAML stream from a file

yaml_parse_file

(PECL yaml >= 0.4.0)

yaml_parse_file — Parse a YAML stream from a file

说明

yaml_parse_file ( string $filename , int $pos = 0 , int &$ndocs = ? , array $callbacks = null ) : mixed

Convert all or part of a YAML document stream read from a file to a PHP variable.

参数

filename

Path to the file.

pos

Document to extract from stream (-1 for all documents, 0 for first document, ...).

ndocs

If ndocs is provided, then it is filled with the number of documents found in stream.

callbacks

Content handlers for YAML nodes. Associative array of YAML tag => callable mappings. See parse callbacks for more details.

返回值

Returns the value encoded in input in appropriate PHP type 或者在失败时返回 false. If pos is -1 an array will be returned with one entry for each document found in the stream.

注释

Warning

Processing untrusted user input with yaml_parse_file() is dangerous if the use of unserialize() is enabled for nodes using the !php/object tag. This behavior can be disabled by using the yaml.decode_php ini setting.

参见

  • yaml_parse() - Parse a YAML stream
  • yaml_parse_url() - Parse a Yaml stream from a URL
  • yaml_emit() - Returns the YAML representation of a value


Parse a Yaml stream from a URL

  • ? yaml_parse_file
  • yaml_parse ?
  • PHP Manual
  • Yaml 函数
  • Parse a Yaml stream from a URL

yaml_parse_url

(PECL yaml >= 0.4.0)

yaml_parse_url — Parse a Yaml stream from a URL

说明

yaml_parse_url ( string $url , int $pos = 0 , int &$ndocs = ? , array $callbacks = null ) : mixed

Convert all or part of a YAML document stream read from a URL to a PHP variable.

参数

url

url should be of the form "scheme://...". PHP will search for a protocol handler (also known as a wrapper) for that scheme. If no wrappers for that protocol are registered, PHP will emit a notice to help you track potential problems in your script and then continue as though filename specifies a regular file.

pos

Document to extract from stream (-1 for all documents, 0 for first document, ...).

ndocs

If ndocs is provided, then it is filled with the number of documents found in stream.

callbacks

Content handlers for YAML nodes. Associative array of YAML tag => callable mappings. See parse callbacks for more

返回值

Returns the value encoded in input in appropriate PHP type 或者在失败时返回 false. If pos is -1 an array will be returned with one entry for each document found in the stream.

注释

Warning

Processing untrusted user input with yaml_parse_url() is dangerous if the use of unserialize() is enabled for nodes using the !php/object tag. This behavior can be disabled by using the yaml.decode_php ini setting.

参见

  • yaml_parse() - Parse a YAML stream
  • yaml_parse_file() - Parse a YAML stream from a file
  • yaml_emit() - Returns the YAML representation of a value


Parse a YAML stream

  • ? yaml_parse_url
  • Yaf ?
  • PHP Manual
  • Yaml 函数
  • Parse a YAML stream

yaml_parse

(PECL yaml >= 0.4.0)

yaml_parse — Parse a YAML stream

说明

yaml_parse ( string $input , int $pos = 0 , int &$ndocs = ? , array $callbacks = null ) : mixed

Convert all or part of a YAML document stream to a PHP variable.

参数

input

The string to parse as a YAML document stream.

pos

Document to extract from stream (-1 for all documents, 0 for first document, ...).

ndocs

If ndocs is provided, then it is filled with the number of documents found in stream.

callbacks

Content handlers for YAML nodes. Associative array of YAML tag => callable mappings. See parse callbacks for more details.

返回值

Returns the value encoded in input in appropriate PHP type 或者在失败时返回 false. If pos is -1 an array will be returned with one entry for each document found in the stream.

范例

Example #1 yaml_parse() example

<?php
$yaml = <<<EOD
---
invoice: 34843
date: "2001-01-23"
bill-to: &id001
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to: *id001
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
EOD;

$parsed = yaml_parse($yaml);
var_dump($parsed);
?>

以上例程的输出类似于：

array(8) {
  ["invoice"]=>
  int(34843)
  ["date"]=>
  string(10) "2001-01-23"
  ["bill-to"]=>
  &array(3) {
    ["given"]=>
    string(5) "Chris"
    ["family"]=>
    string(6) "Dumars"
    ["address"]=>
    array(4) {
      ["lines"]=>
      string(34) "458 Walkman Dr.
        Suite #292"
      ["city"]=>
      string(9) "Royal Oak"
      ["state"]=>
      string(2) "MI"
      ["postal"]=>
      int(48046)
    }
  }
  ["ship-to"]=>
  &array(3) {
    ["given"]=>
    string(5) "Chris"
    ["family"]=>
    string(6) "Dumars"
    ["address"]=>
    array(4) {
      ["lines"]=>
      string(34) "458 Walkman Dr.
        Suite #292"
      ["city"]=>
      string(9) "Royal Oak"
      ["state"]=>
      string(2) "MI"
      ["postal"]=>
      int(48046)
    }
  }
  ["product"]=>
  array(2) {
    [0]=>
    array(4) {
      ["sku"]=>
      string(6) "BL394D"
      ["quantity"]=>
      int(4)
      ["description"]=>
      string(10) "Basketball"
      ["price"]=>
      int(450)
    }
    [1]=>
    array(4) {
      ["sku"]=>
      string(7) "BL4438H"
      ["quantity"]=>
      int(1)
      ["description"]=>
      string(10) "Super Hoop"
      ["price"]=>
      int(2392)
    }
  }
  ["tax"]=>
  float(251.42)
  ["total"]=>
  float(4443.52)
  ["comments"]=>
  string(68) "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338."
}

注释

Warning

Processing untrusted user input with yaml_parse() is dangerous if the use of unserialize() is enabled for nodes using the !php/object tag. This behavior can be disabled by using the yaml.decode_php ini setting.

参见

  • yaml_parse_file() - Parse a YAML stream from a file
  • yaml_parse_url() - Parse a Yaml stream from a URL
  • yaml_emit() - Returns the YAML representation of a value


Yet Another Framework

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • 应用配置
  • Yaf_Application — The Yaf_Application class
    • Yaf_Application::app — 获取当前的Yaf_Application实例
    • Yaf_Application::bootstrap — 调用bootstrap
    • Yaf_Application::clearLastError — 清除最后的错误信息
    • Yaf_Application::__construct — Yaf_Application的构造函数
    • Yaf_Application::__destruct — 析构函数
    • Yaf_Application::environ — 获取当前Yaf_Application的环境名
    • Yaf_Application::execute — 运行回调函数
    • Yaf_Application::getAppDirectory — 获取应用的目录
    • Yaf_Application::getConfig — 获取 Yaf_Config_Abstract 的实例
    • Yaf_Application::getDispatcher — 获取 Yaf_Dispatcher 的实例
    • Yaf_Application::getLastErrorMsg — 获取最近产生的错误的错误信息
    • Yaf_Application::getLastErrorNo — 获取最后产生的错误的错误代码
    • Yaf_Application::getModules — 获取在配置文件中申明的模块
    • Yaf_Application::run — 运行 Yaf_Application
    • Yaf_Application::setAppDirectory — 改变应用目录
  • Yaf_Bootstrap_Abstract — The Yaf_Bootstrap_Abstract class
  • Yaf_Dispatcher — Yaf_Dispatcher 类
    • Yaf_Dispatcher::autoRender — 开启/关闭自动渲染功能
    • Yaf_Dispatcher::catchException — 开启/关闭自动异常捕获功能
    • Yaf_Dispatcher::__construct — Yaf_Dispatcher 构造函数
    • Yaf_Dispatcher::disableView — 关闭自动渲染
    • Yaf_Dispatcher::dispatch — 分发请求
    • Yaf_Dispatcher::enableView — 开启自动渲染
    • Yaf_Dispatcher::flushInstantly — 打开关闭自动响应
    • Yaf_Dispatcher::getApplication — 获取当前的Yaf_Application实例
    • Yaf_Dispatcher::getDefaultAction — Retrive the default action name
    • Yaf_Dispatcher::getDefaultController — Retrive the default controller name
    • Yaf_Dispatcher::getDefaultModule — Retrive the default module name
    • Yaf_Dispatcher::getInstance — 获取当前的Yaf_Dispatcher实例
    • Yaf_Dispatcher::getRequest — 获取当前的请求实例
    • Yaf_Dispatcher::getRouter — 获取路由器
    • Yaf_Dispatcher::initView — 初始化视图引擎并返回它
    • Yaf_Dispatcher::registerPlugin — 注册一个插件
    • Yaf_Dispatcher::returnResponse — The returnResponse purpose
    • Yaf_Dispatcher::setDefaultAction — 设置路由的默认动作
    • Yaf_Dispatcher::setDefaultController — 设置路由的默认控制器
    • Yaf_Dispatcher::setDefaultModule — 设置路由的默认模块
    • Yaf_Dispatcher::setErrorHandler — 设置错误处理函数
    • Yaf_Dispatcher::setRequest — The setRequest purpose
    • Yaf_Dispatcher::setView — 设置视图引擎
    • Yaf_Dispatcher::throwException — 开启/关闭异常抛出
  • Yaf_Config_Abstract — The Yaf_Config_Abstract class
    • Yaf_Config_Abstract::get — Getter
    • Yaf_Config_Abstract::readonly — 寻找只读配置
    • Yaf_Config_Abstract::set — Setter
    • Yaf_Config_Abstract::toArray — 转换为数组
  • Yaf_Config_Ini — The Yaf_Config_Ini class
    • Yaf_Config_Ini::__construct — 构造函数
    • Yaf_Config_Ini::count — 返回配置的节数量
    • Yaf_Config_Ini::current — 返回当前节点
    • Yaf_Config_Ini::__get — 读取节点配置
    • Yaf_Config_Ini::__isset — 检查节点是否存在
    • Yaf_Config_Ini::key — 返回当前元素的键
    • Yaf_Config_Ini::next — 向前移动到下一个元素
    • Yaf_Config_Ini::offsetExists — 检查一个偏移位置是否存在
    • Yaf_Config_Ini::offsetGet — 获取一个偏移位置的值
    • Yaf_Config_Ini::offsetSet — 设置一个偏移位置的值
    • Yaf_Config_Ini::offsetUnset — 复位一个偏移位置的值
    • Yaf_Config_Ini::readonly — 检查配置是否只读
    • Yaf_Config_Ini::rewind — 检查当前位置是否有效
    • Yaf_Config_Ini::__set — The __set purpose
    • Yaf_Config_Ini::toArray — 转换为数组的格式
    • Yaf_Config_Ini::valid — 检查迭代器是否有效
  • Yaf_Config_Simple — The Yaf_Config_Simple class
    • Yaf_Config_Simple::__construct — 构造函数
    • Yaf_Config_Simple::count — 返回配置的节数量
    • Yaf_Config_Simple::current — 返回当前节点
    • Yaf_Config_Simple::__get — 读取节点配置
    • Yaf_Config_Simple::__isset — 检查节点是否存在
    • Yaf_Config_Simple::key — 返回当前元素的键
    • Yaf_Config_Simple::next — 向前移动到下一个元素
    • Yaf_Config_Simple::offsetExists — 检查一个偏移位置是否存在
    • Yaf_Config_Simple::offsetGet — 获取一个偏移位置的值
    • Yaf_Config_Simple::offsetSet — 设置一个偏移位置的值
    • Yaf_Config_Simple::offsetUnset — 复位一个偏移位置的值
    • Yaf_Config_Simple::readonly — 检查配置是否只读
    • Yaf_Config_Simple::rewind — 检查当前位置是否有效
    • Yaf_Config_Simple::__set — 设置节点配置
    • Yaf_Config_Simple::toArray — 转换为数组的格式
    • Yaf_Config_Simple::valid — 检查迭代器是否有效
  • Yaf_Controller_Abstract — The Yaf_Controller_Abstract class
    • Yaf_Controller_Abstract::__construct — Yaf_Controller_Abstract constructor
    • Yaf_Controller_Abstract::display — The display purpose
    • Yaf_Controller_Abstract::forward — The forward purpose
    • Yaf_Controller_Abstract::getInvokeArg — The getInvokeArg purpose
    • Yaf_Controller_Abstract::getInvokeArgs — The getInvokeArgs purpose
    • Yaf_Controller_Abstract::getModuleName — 获取当前控制器所属的模块名
    • Yaf_Controller_Abstract::getName — Get self name
    • Yaf_Controller_Abstract::getRequest — The getRequest purpose
    • Yaf_Controller_Abstract::getResponse — The getResponse purpose
    • Yaf_Controller_Abstract::getView — 获取当前的视图引擎
    • Yaf_Controller_Abstract::getViewpath — The getViewpath purpose
    • Yaf_Controller_Abstract::init — 控制器初始化
    • Yaf_Controller_Abstract::initView — The initView purpose
    • Yaf_Controller_Abstract::redirect — The redirect purpose
    • Yaf_Controller_Abstract::render — 渲染视图模板
    • Yaf_Controller_Abstract::setViewpath — The setViewpath purpose
  • Yaf_Action_Abstract — The Yaf_Action_Abstract class
    • Yaf_Action_Abstract::execute — 执行动作
    • Yaf_Action_Abstract::getController — 得到控制器实例
    • Yaf_Action_Abstract::getControllerName — Get controller name
  • Yaf_View_Interface — The Yaf_View_Interface class
    • Yaf_View_Interface::assign — 为视图引擎分配一个模板变量
    • Yaf_View_Interface::display — 渲染一个视图模板, 并直接输出给请求端
    • Yaf_View_Interface::getScriptPath — The getScriptPath purpose
    • Yaf_View_Interface::render — 渲染一个视图模板
    • Yaf_View_Interface::setScriptPath — The setScriptPath purpose
  • Yaf_View_Simple — The Yaf_View_Simple Class
    • Yaf_View_Simple::assign — 为视图引擎分配一个模板变量
    • Yaf_View_Simple::assignRef — The assignRef purpose
    • Yaf_View_Simple::clear — Clear Assigned values
    • Yaf_View_Simple::__construct — Constructor of Yaf_View_Simple
    • Yaf_View_Simple::display — 渲染一个视图模板, 并直接输出给请求端
    • Yaf_View_Simple::eval — 渲染模板
    • Yaf_View_Simple::__get — 获取视图引擎的一个模板变量值
    • Yaf_View_Simple::getScriptPath — 获取模板目录
    • Yaf_View_Simple::__isset — The __isset purpose
    • Yaf_View_Simple::render — 渲染模板
    • Yaf_View_Simple::__set — 为视图引擎分配一个模板变量
    • Yaf_View_Simple::setScriptPath — 设置模板的目录
  • Yaf_Loader — The Yaf_Loader class
    • Yaf_Loader::autoload — The autoload purpose
    • Yaf_Loader::clearLocalNamespace — The clearLocalNamespace purpose
    • Yaf_Loader::__construct — The __construct purpose
    • Yaf_Loader::getInstance — The getInstance purpose
    • Yaf_Loader::getLibraryPath — get the library path
    • Yaf_Loader::getLocalNamespace — The getLocalNamespace purpose
    • Yaf_Loader::getNamespacePath — Retieve path of a registered namespace
    • Yaf_Loader::getLocalNamespace — Retrive all register namespaces info
    • Yaf_Loader::import — The import purpose
    • Yaf_Loader::isLocalName — The isLocalName purpose
    • Yaf_Loader::registerLocalNamespace — 注册本地类前缀
    • Yaf_Loader::registerNamespace — Register namespace with searching path
    • Yaf_Loader::setLibraryPath — 改变library路径
  • Yaf_Plugin_Abstract — The Yaf_Plugin_Abstract class
    • Yaf_Plugin_Abstract::dispatchLoopShutdown — The dispatchLoopShutdown purpose
    • Yaf_Plugin_Abstract::dispatchLoopStartup — The dispatchLoopStartup purpose
    • Yaf_Plugin_Abstract::postDispatch — The postDispatch purpose
    • Yaf_Plugin_Abstract::preDispatch — The preDispatch purpose
    • Yaf_Plugin_Abstract::preResponse — The preResponse purpose
    • Yaf_Plugin_Abstract::routerShutdown — The routerShutdown purpose
    • Yaf_Plugin_Abstract::routerStartup — RouterStartup hook
  • Yaf_Registry — The Yaf_Registry class
    • Yaf_Registry::__construct — Yaf_Registry implements singleton
    • Yaf_Registry::del — Remove an item from registry
    • Yaf_Registry::get — Retrieve an item from registry
    • Yaf_Registry::has — Check whether an item exists
    • Yaf_Registry::set — Add an item into registry
  • Yaf_Request_Abstract — The Yaf_Request_Abstract class
    • Yaf_Request_Abstract::clearParams — Remove all params
    • Yaf_Request_Abstract::getActionName — The getActionName purpose
    • Yaf_Request_Abstract::getBaseUri — The getBaseUri purpose
    • Yaf_Request_Abstract::getControllerName — The getControllerName purpose
    • Yaf_Request_Abstract::getEnv — 取得ENV变量的值
    • Yaf_Request_Abstract::getException — The getException purpose
    • Yaf_Request_Abstract::getLanguage — The getLanguage purpose
    • Yaf_Request_Abstract::getMethod — The getMethod purpose
    • Yaf_Request_Abstract::getModuleName — The getModuleName purpose
    • Yaf_Request_Abstract::getParam — The getParam purpose
    • Yaf_Request_Abstract::getParams — The getParams purpose
    • Yaf_Request_Abstract::getRequestUri — The getRequestUri purpose
    • Yaf_Request_Abstract::getServer — 返回SERVER变量的值
    • Yaf_Request_Abstract::isCli — The isCli purpose
    • Yaf_Request_Abstract::isDispatched — The isDispatched purpose
    • Yaf_Request_Abstract::isGet — The isGet purpose
    • Yaf_Request_Abstract::isHead — The isHead purpose
    • Yaf_Request_Abstract::isOptions — The isOptions purpose
    • Yaf_Request_Abstract::isPost — The isPost purpose
    • Yaf_Request_Abstract::isPut — The isPut purpose
    • Yaf_Request_Abstract::isRouted — The isRouted purpose
    • Yaf_Request_Abstract::isXmlHttpRequest — The isXmlHttpRequest purpose
    • Yaf_Request_Abstract::setActionName — The setActionName purpose
    • Yaf_Request_Abstract::setBaseUri — The setBaseUri purpose
    • Yaf_Request_Abstract::setControllerName — The setControllerName purpose
    • Yaf_Request_Abstract::setDispatched — The setDispatched purpose
    • Yaf_Request_Abstract::setModuleName — The setModuleName purpose
    • Yaf_Request_Abstract::setParam — The setParam purpose
    • Yaf_Request_Abstract::setRequestUri — The setRequestUri purpose
    • Yaf_Request_Abstract::setRouted — The setRouted purpose
  • Yaf_Request_Http — The Yaf_Request_Http class
    • Yaf_Request_Http::__construct — The __construct purpose
    • Yaf_Request_Http::get — 从客户端返回变量
    • Yaf_Request_Http::getCookie — 返回Cookie变量
    • Yaf_Request_Http::getFiles — The getFiles purpose
    • Yaf_Request_Http::getPost — 返回POST变量
    • Yaf_Request_Http::getQuery — fetch a query parameter
    • Yaf_Request_Http::getRaw — Retrieve Raw request body
    • Yaf_Request_Http::getRequest — The getRequest purpose
    • Yaf_Request_Http::isXmlHttpRequest — 是否为Ajax请求
  • Yaf_Request_Simple — The Yaf_Request_Simple class
    • Yaf_Request_Simple::__construct — The __construct purpose
    • Yaf_Request_Simple::get — The get purpose
    • Yaf_Request_Simple::getCookie — The getCookie purpose
    • Yaf_Request_Simple::getFiles — The getFiles purpose
    • Yaf_Request_Simple::getPost — The getPost purpose
    • Yaf_Request_Simple::getQuery — The getQuery purpose
    • Yaf_Request_Simple::getRequest — The getRequest purpose
    • Yaf_Request_Simple::isXmlHttpRequest — The isXmlHttpRequest purpose
  • Yaf_Response_Abstract — The Yaf_Response_Abstract class
    • Yaf_Response_Abstract::appendBody — 往已有的响应body后附加新的内容
    • Yaf_Response_Abstract::clearBody — 清除已经设置的响应body
    • Yaf_Response_Abstract::clearHeaders — The clearHeaders purpose
    • Yaf_Response_Abstract::__construct — The __construct purpose
    • Yaf_Response_Abstract::__destruct — The __destruct purpose
    • Yaf_Response_Abstract::getBody — 获取已经设置的响应body
    • Yaf_Response_Abstract::getHeader — The getHeader purpose
    • Yaf_Response_Abstract::prependBody — The prependBody purpose
    • Yaf_Response_Abstract::response — send response
    • Yaf_Response_Abstract::setAllHeaders — The setAllHeaders purpose
    • Yaf_Response_Abstract::setBody — 设置响应的Body
    • Yaf_Response_Abstract::setHeader — The setHeader purpose
    • Yaf_Response_Abstract::setRedirect — The setRedirect purpose
    • Yaf_Response_Abstract::__toString — The __toString purpose
  • Yaf_Route_Interface — The Yaf_Route_Interface class
    • Yaf_Route_Interface::assemble — 将指定路由规则组合成一个url
    • Yaf_Route_Interface::route — route a request
  • Yaf_Route_Map — The Yaf_Route_Map class
    • Yaf_Route_Map::assemble — 组合url
    • Yaf_Route_Map::__construct — The __construct purpose
    • Yaf_Route_Map::route — The route purpose
  • Yaf_Route_Regex — The Yaf_Route_Regex class
    • Yaf_Route_Regex::assemble — 组合url
    • Yaf_Route_Regex::__construct — The __construct purpose
    • Yaf_Route_Regex::route — The route purpose
  • Yaf_Route_Rewrite — The Yaf_Route_Rewrite class
    • Yaf_Route_Rewrite::assemble — 组合url
    • Yaf_Route_Rewrite::__construct — The __construct purpose
    • Yaf_Route_Rewrite::route — The route purpose
  • Yaf_Router — The Yaf_Router class
    • Yaf_Router::addConfig — 向Router中添加配置文件中定义的路由
    • Yaf_Router::addRoute — 往Router中添加新的路由
    • Yaf_Router::__construct — Yaf_Router constructor
    • Yaf_Router::getCurrentRoute — 取得当前有效的路由名
    • Yaf_Router::getRoute — The getRoute purpose
    • Yaf_Router::getRoutes — The getRoutes purpose
    • Yaf_Router::route — The route purpose
  • Yaf_Route_Simple — The Yaf_Route_Simple class
    • Yaf_Route_Simple::assemble — 组合url
    • Yaf_Route_Simple::__construct — Yaf_Route_Simple constructor
    • Yaf_Route_Simple::route — Route a request
  • Yaf_Route_Static — The Yaf_Route_Static class
    • Yaf_Route_Static::assemble — 组合url
    • Yaf_Route_Static::match — The match purpose
    • Yaf_Route_Static::route — Route a request
  • Yaf_Route_Supervar — The Yaf_Route_Supervar class
    • Yaf_Route_Supervar::assemble — 组合url
    • Yaf_Route_Supervar::__construct — The __construct purpose
    • Yaf_Route_Supervar::route — The route purpose
  • Yaf_Session — The Yaf_Session class
    • Yaf_Session::__construct — The __construct purpose
    • Yaf_Session::count — The count purpose
    • Yaf_Session::current — The current purpose
    • Yaf_Session::del — The del purpose
    • Yaf_Session::__get — The __get purpose
    • Yaf_Session::getInstance — The getInstance purpose
    • Yaf_Session::has — The has purpose
    • Yaf_Session::__isset — The __isset purpose
    • Yaf_Session::key — The key purpose
    • Yaf_Session::next — The next purpose
    • Yaf_Session::offsetExists — The offsetExists purpose
    • Yaf_Session::offsetGet — The offsetGet purpose
    • Yaf_Session::offsetSet — The offsetSet purpose
    • Yaf_Session::offsetUnset — The offsetUnset purpose
    • Yaf_Session::rewind — The rewind purpose
    • Yaf_Session::__set — The __set purpose
    • Yaf_Session::start — The start purpose
    • Yaf_Session::__unset — The __unset purpose
    • Yaf_Session::valid — The valid purpose
  • Yaf_Exception — The Yaf_Exception class
    • Yaf_Exception::__construct — The __construct purpose
    • Yaf_Exception::getPrevious — The getPrevious purpose
  • Yaf_Exception_TypeError — The Yaf_Exception_TypeError class
  • Yaf_Exception_StartupError — The Yaf_Exception_StartupError class
  • Yaf_Exception_DispatchFailed — The Yaf_Exception_DispatchFailed class
  • Yaf_Exception_RouterFailed — The Yaf_Exception_RouterFailed class
  • Yaf_Exception_LoadFailed — The Yaf_Exception_LoadFailed class
  • Yaf_Exception_LoadFailed_Module — The Yaf_Exception_LoadFailed_Module class
  • Yaf_Exception_LoadFailed_Controller — The Yaf_Exception_LoadFailed_Controller class
  • Yaf_Exception_LoadFailed_Action — The Yaf_Exception_LoadFailed_Action class
  • Yaf_Exception_LoadFailed_View — The Yaf_Exception_LoadFailed_View class


简介

The Yet Another Framework (Yaf) 扩展是一个用来开发web应用的php框架。

Yaf需要5.2.1及以上版本PHP，早期版本可能不能正常工作。

这里有一个简单的Yaf性能测试。» Yaf性能 .

快速入门请参见 教程 .


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/yaf.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Yaf 配置选项
名字 | 默认 | 可修改范围 | 更新日志
yaf.library |  | its PHP_INI_ALL value |
yaf.action_prefer | 0 | its PHP_INI_ALL value |
yaf.lowcase_path | 0 | its PHP_INI_ALL value |
yaf.use_spl_autoload | 0 | its PHP_INI_ALL value |
yaf.forward_limit | 5 | its PHP_INI_ALL value |
yaf.name_suffix | 1 | its PHP_INI_ALL value |
yaf.name_separator |  | its PHP_INI_ALL value |
yaf.cache_config | 0 | its PHP_INI_SYSTEM value |
yaf.environ | product | its PHP_INI_SYSTEM value |
yaf.use_namespace | 0 | its PHP_INI_SYSTEM value |

这是配置指令的简短说明。

yaf.library string

The global library path, Yaf_loader will search global library in this directory.

yaf.action_prefer integer

If there is only one part in PATH_INFO, should it consider as a controller or action.

If this configure On, it will be considered as a Action name.

yaf.lowcase_path integer

Whether lowercase all the path during the class autoloading.

yaf.use_spl_autoload integer

When this value is On, if Yaf_Loader can not find a class, it will return FALSE, then give chance to other auto load function to be called.

When this value is Off(default), Yaf_Loader::autoload() will always return TRUE.

yaf.forward_limit integer

The max forward count, default is 5. that means you can have a max value of 5 in the forward stack.

This is a protection for prevent recursive Yaf_Controller_Abstract::forward().

yaf.name_suffix integer

When this On, Yaf_Loader will identify a class by it's suffix to decide whether it is a MVC Class.

When this Off, Yaf_Loader will look at the prefix of the class name.

yaf.name_separator string

When this is not empty, Yaf_Loader will identify the class suffix and string value of this.

For example, when this value is "_", Yaf_Loader will take Index_Controller as a Controller Class, IndexController as a normal class.

yaf.cache_config integer

If this is On, and in the meantime you are using ini config file as the parameter of Yaf_Application(), the compiling result of the ini config file will be cached in the PHP process.

Note:

Yaf examine the mtime of the ini file, if it was changed since last compiling, Yaf will reload it.

Warning

Yaf use the ini file path as the cache entry key, so do use the absolute path in ini file path, otherwise there might be some conflicts if two application use the same relative path of ini config.

yaf.environ string

This value is "product" by default, used for Yaf to fetch the config section of a ini config file.

That is, if this value is "product", Yaf will use the section named "product" in the ini config file(the first parameter of the Yaf_Application) as the final config of the Yaf_Application.

yaf.use_namespace integer

Only works as of PHP 5.3, if this value is On, All class of Yaf will named in namespace style.

For example, Yaf_Route_Rewrite => \Yaf\Route\Rewrite, Yaf_Controller_Abstract => \Yaf\Controller_Abstract (Abstract is the keyword, can not used as a class name)


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

YAF_VERSION (string)
YAF_ENVIRON (string)
YAF_ERR_STARTUP_FAILED (integer)
YAF_ERR_ROUTE_FAILED (integer)
YAF_ERR_DISPATCH_FAILED (integer)
YAF_ERR_AUTOLOAD_FAILED (integer)
YAF_ERR_NOTFOUND_MODULE (integer)
YAF_ERR_NOTFOUND_CONTROLLER (integer)
YAF_ERR_NOTFOUND_ACTION (integer)
YAF_ERR_NOTFOUND_VIEW (integer)
YAF_ERR_CALL_FAILED (integer)
YAF_ERR_TYPE_ERROR (integer)


范例

Example #1 一个典型的应用目录结构

- index.php
- .htaccess
+ conf
  |- application.ini //application config
- application/
  - Bootstrap.php
  + controllers
     - Index.php //default controller
  + views
     |+ index
        - index.phtml //view template for default action
  + modules
  - library
  - models
  - plugins

Example #2 入口文件

顶层目录下的 index.php 是整个应用的唯一入口，应该把所有请求都重定向到这个文件（在 Apache + php_mod 模式下可以使用 .htaccess）。

<?php
define("APPLICATION_PATH",  dirname(__FILE__));

$app  = new Yaf_Application(APPLICATION_PATH . "/conf/application.ini");
$app->bootstrap() //call bootstrap methods defined in Bootstrap.php
 ->run();
?>

Example #3 重写规则

#for apache (.htaccess)
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* index.php

#for nginx
server {
  listen ****;
  server_name  domain.com;
  root   document_root;
  index  index.php index.html index.htm;

  if (!-e $request_filename) {
    rewrite ^/(.*)  /index.php$1 last;
  }
}

#for lighttpd
$HTTP["host"] =~ "(www.)?domain.com$" {
  url.rewrite = (
     "^/(.+)/?$"  => "/index.php/$1",
  )
}

Example #4 应用配置文件

[yaf]
;APPLICATION_PATH is the constant defined in index.php
application.directory=APPLICATION_PATH "/application/"

;product section inherit from yaf section
[product:yaf]
foo=bar

Example #5 默认控制器

<?php
class IndexController extends Yaf_Controller_Abstract {
   /* default action */
   public function indexAction() {
       $this->_view->word = "hello world";
       //or
       // $this->getView()->word = "hello world";
   }
}
?>

Example #6 默认视图文件

<html>
 <head>
   <title>Hello World</title>
 </head>
 <body>
   <?php echo $word;?>
 </body>
</html>

Example #7 运行应用

以上例程的输出类似于：

<html>
 <head>
   <title>Hello World</title>
 </head>
 <body>
   hello world
 </body>
</html>

Note:

在 yaf@github 上有 Yaf 代码生成器，你也可以用它来生成上面的例子。


应用配置

你需要传递一个config数组或ini配置文件（参见 Yaf_Config_Ini） 给 Yaf_Application::__construct().

Yaf的配置文件会和用户的配置文件合并。区别在于，Yaf的配置文件是以"yaf."或"application."开头，如果两项都存在，则"application."生效。

Example #1 config为数组的例子

<?php
    $configs = array(
            "application" => array(
                "directory" => dirname(__FILE__),
                "dispatcher" => array(
                      "catchException" => 0,
                    ),
                "view" => array(
                       "ext" => "phtml",
                    ),
                ),
           );
    $app = new Yaf_Application($config);
?>

Example #2 config为ini文件的例子

[yaf]
yaf.directory = APPLICATION_PATH "/appliation"
yaf.dispatcher.catchException = 0

[product : yaf]
; user configuration list here

Yaf Application Config
名字 | 默认 | 更新日志
application.directory |  |
application.ext | "php" |
application.view.ext | "phtml" |
application.modules | "index" |
application.library | application.directory . "/library" |
application.library.directory | application.directory . "/library" |
application.library.namespace | "" |
application.bootstrap | application.directory . "/Bootstrap" . application.ext |
application.baseUri | "" |
application.dispatcher.defaultRoute |  |
application.dispatcher.throwException | 1 |
application.dispatcher.catchException | 0 |
application.dispatcher.defaultModule | "index" |
application.dispatcher.defaultController | "index" |
application.dispatcher.defaultAction | "index" |
application.system |  |

这是配置指令的简短说明。

application.directory string

应用程序的目录，包含"controllers", "views", "models", "plugins"等子目录。

Note:

这是唯一一个没有默认值的配置项，你需要手动指定它。

application.ext string

PHP脚本的扩展名，类的自动加载需要用到它( Yaf_Loader)。

application.view.ext string

视图模板扩展名。

application.modules string

注册的模块列表，以逗号分隔，用于路由处理，特别是当PATH_INFO超过三段的时候，

Yaf需要用它来判断第一段是否是一个模块。

application.library string

本地类库的目录，参见Yaf_Loader 和 yaf.library。

Note:

Yaf2.1.6以后，该配置项也可以是一个数组，当它是数组的时候，类库的路径将尝试使用application.library.directory的值。

application.library.directory string

Alias of application.library. Introduced in Yaf 2.1.6

application.library.namespace string

逗号分隔的本地类库命名空间前缀。

Yaf2.1.6以后加入

application.bootstrap string

Bootstrap类脚本文件的绝对路径。

application.baseUri string

路由处理中需要忽略的路径前缀。举个例子，请求"/prefix/controller/action"时。如果你将application.baseUri设置为"/prefix"，那么只有"/controller/action"会被当做路由路径。

通常不需要设置此值。

application.dispatcher.throwException bool

开启此项，Yaf会在发生错误的地方抛出异常。参见 Yaf_Dispatcher::throwException()。

application.dispatcher.catchException bool

开启此项，如果有未捕获的异常，Yaf将会把它定向到Error controller, Error Action。参见 Yaf_Dispatcher::catchException()。

application.dispatcher.defaultRoute string

默认路由，如果未指定，静态路由会被当做是默认路由，参见： Yaf_Router::addRoute()。

application.dispatcher.defaultModule string

默认模块名，参见 Yaf_Dispatcher::setDefaultModule()。

application.dispatcher.defaultController string

默认控制器名，参见 Yaf_Dispatcher::setDefaultController()。

application.dispatcher.defaultAction string

默认动作名，参见 Yaf_Dispatcher::setDefaultAction()。

application.system string

在application.ini中设置Yaf运行时配置，如： application.system.lowcase_path

Note:

仅有PHP_INI_ALL配置项能这样设置


The Yaf_Application class

(No version information available, might only be in Git)

简介

Yaf_Application为应用提供了一个辅助设施。 它提供了可重用的资源，常见的和模块化的引导类，还有依赖的检查。

Note:

Yaf_Application实现了单例模式。 Yaf_Application不能够被序列化和反序列化， 因为当你尝试使用PHPUnit来为Yaf写一些测试用例的时候会造成一些不必要的麻烦。

你可以使用PHPUnit的@backupGlobals注释来控制全局变量的备份和恢复操作， 从而可以解决这个问题。

类摘要

final Yaf_Application {
/* 属性 */
protected $config ;
protected $dispatcher ;
protected static $_app ;
protected $_modules ;
protected $_running ;
protected $_environ ;
/* 方法 */
public static app ( ) : void
public bootstrap ( Yaf_Bootstrap_Abstract $bootstrap = ? ) : void
public clearLastError ( ) : Yaf_Application
public__construct ( mixed $config , string $envrion = ? )
public __destruct ( ) : void
public environ ( ) : void
public execute ( callable $entry , string $... ) : void
public getAppDirectory ( ) : Yaf_Application
public getConfig ( ) : Yaf_Config_Abstract
public getDispatcher ( ) : Yaf_Dispatcher
public getLastErrorMsg ( ) : string
public getLastErrorNo ( ) : int
public getModules ( ) : array
public run ( ) : void
public setAppDirectory ( string $directory ) : Yaf_Application
}

属性

config

dispatcher

_app

_modules

_running

_environ

Table of Contents

  • Yaf_Application::app — 获取当前的Yaf_Application实例
  • Yaf_Application::bootstrap — 调用bootstrap
  • Yaf_Application::clearLastError — 清除最后的错误信息
  • Yaf_Application::__construct — Yaf_Application的构造函数
  • Yaf_Application::__destruct — 析构函数
  • Yaf_Application::environ — 获取当前Yaf_Application的环境名
  • Yaf_Application::execute — 运行回调函数
  • Yaf_Application::getAppDirectory — 获取应用的目录
  • Yaf_Application::getConfig — 获取 Yaf_Config_Abstract 的实例
  • Yaf_Application::getDispatcher — 获取 Yaf_Dispatcher 的实例
  • Yaf_Application::getLastErrorMsg — 获取最近产生的错误的错误信息
  • Yaf_Application::getLastErrorNo — 获取最后产生的错误的错误代码
  • Yaf_Application::getModules — 获取在配置文件中申明的模块
  • Yaf_Application::run — 运行 Yaf_Application
  • Yaf_Application::setAppDirectory — 改变应用目录


获取当前的Yaf_Application实例

  • ? Yaf_Application
  • Yaf_Application::bootstrap ?
  • PHP Manual
  • Yaf_Application
  • 获取当前的Yaf_Application实例

Yaf_Application::app

(Yaf >=1.0.0)

Yaf_Application::app — 获取当前的Yaf_Application实例

说明

public static Yaf_Application::app ( ) : void

返回Yaf_Application的实例， 也可以使用Yaf_Dispatcher::getApplication()来得到Yaf_Application的实例 Yaf_Dispatcher::getApplication().

参数

此函数没有参数。

返回值

返回值为一个Yaf_Application的实例， 如果在调用之前没有初始化一个Yaf_Application实例的话，它将返回NULL

参见

  • Yaf_Dispatcher::getApplication() - 获取当前的Yaf_Application实例


调用bootstrap

  • ? Yaf_Application::app
  • Yaf_Application::clearLastError ?
  • PHP Manual
  • Yaf_Application
  • 调用bootstrap

Yaf_Application::bootstrap

(Yaf >=1.0.0)

Yaf_Application::bootstrap — 调用bootstrap

说明

public Yaf_Application::bootstrap ( Yaf_Bootstrap_Abstract $bootstrap = ? ) : void

指示Yaf_Application去寻找Bootstrap，并按照声明的顺序，执行所有在Bootstrap类中定义的以_init开头的方法。 如果没有提供变量bootstrap，Yaf默认会去application.directory中寻找Bootstrap。

参数

bootstrap

A Yaf_Bootstrap_Abstract instance

返回值

Yaf_Application instance

范例

Example #1 A Bootstrap()example

<?php
/**
 * This file should be under the APPLICATION_PATH . "/application/"(which was defined in the config passed to Yaf_Application).
 * and named Bootstrap.php,  so the Yaf_Application can find it
 */
class Bootstrap extends Yaf_Bootstrap_Abstract {
    function _initConfig(Yaf_Dispatcher $dispatcher) {
        echo "1st called\n";
    }

    function _initPlugin($dispatcher) {
        echo "2nd called\n";
    }
}
?>

Example #2 Yaf_Application::bootstrap()example

<?php

defined('APPLICATION_PATH')                  // APPLICATION_PATH will be used in the ini config file
    || define('APPLICATION_PATH', __DIR__)); //__DIR__ was introduced after PHP 5.3

$application = new Yaf_Application(APPLICATION_PATH.'/conf/application.ini');
$application->bootstrap();
?>

以上例程的输出类似于：

1st called
2nd called

参见

  • Yaf_Bootstrap_Abstract


清除最后的错误信息

  • ? Yaf_Application::bootstrap
  • Yaf_Application::__construct ?
  • PHP Manual
  • Yaf_Application
  • 清除最后的错误信息

Yaf_Application::clearLastError

(Yaf >=2.1.2)

Yaf_Application::clearLastError — 清除最后的错误信息

说明

public Yaf_Application::clearLastError ( ) : Yaf_Application

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Application::clearLastError()example

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   Yaf_Application::app()->clearLastError();
   var_dump(Yaf_Application::app()->getLastErrorNo());
}

$config = array(
 "application" => array(
   "directory" => "/tmp/notexists",
     "dispatcher" => array(
       "throwException" => 0, //trigger error instead of throw exception when error occure
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

以上例程的输出类似于：

int(0)


Yaf_Application的构造函数

  • ? Yaf_Application::clearLastError
  • Yaf_Application::__destruct ?
  • PHP Manual
  • Yaf_Application
  • Yaf_Application的构造函数

Yaf_Application::__construct

(Yaf >=1.0.0)

Yaf_Application::__construct — Yaf_Application的构造函数

说明

publicYaf_Application::__construct ( mixed $config , string $envrion = ? )

初始化一个 Yaf_Application.

参数

config

关联数组的配置, 或者一个指向ini格式的配置文件的路径的字符串。

如果是一个ini配置文件，那配置文件中应该有一个定义了yaf.environ 的配置节。这个在生产环境中是默认的。

Note:

如果你使用了ini配置文件作为你应用配置的容器，你需要打开yaf.cache_config 来提升性能。

And the config entry(and there default value) list blow:

Example #1 A ini config file example

[product]
;this one should alway be defined, and have no default value
application.directory=APPLICATION_PATH

;following configs have default value, you may no need to define them
application.library = APPLICATION_PATH . "/library"
application.dispatcher.throwException=1
application.dispatcher.catchException=1

application.baseUri=""

;the php script ext name
ap.ext=php

;the view template ext name
ap.view.ext=phtml

ap.dispatcher.defaultModuel=Index
ap.dispatcher.defaultController=Index
ap.dispatcher.defaultAction=index

;defined modules
ap.modules=Index

envrion

Which section will be loaded as the final config

返回值

范例

Example #2 Yaf_Application::__construct()example

<?php
defined('APPLICATION_PATH')                  // APPLICATION_PATH will be used in the ini config file
    || define('APPLICATION_PATH', __DIR__)); //__DIR__ was introduced after PHP 5.3

$application = new Yaf_Application(APPLICATION_PATH.'/conf/application.ini');
$application->bootstrap()->run();
?>

以上例程的输出类似于：

Example #3 Yaf_Application::__construct()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
$application->bootstrap()->run();
?>

以上例程的输出类似于：

参见

  • Yaf_Config_Ini
    •


析构函数

  • ? Yaf_Application::__construct
  • Yaf_Application::environ ?
  • PHP Manual
  • Yaf_Application
  • 析构函数

Yaf_Application::__destruct

(Yaf >=1.0.0)

Yaf_Application::__destruct — 析构函数

说明

public Yaf_Application::__destruct ( ) : void

参数

此函数没有参数。

返回值


获取当前Yaf_Application的环境名

  • ? Yaf_Application::__destruct
  • Yaf_Application::execute ?
  • PHP Manual
  • Yaf_Application
  • 获取当前Yaf_Application的环境名

Yaf_Application::environ

(Yaf >=1.0.0)

Yaf_Application::environ — 获取当前Yaf_Application的环境名

说明

public Yaf_Application::environ ( ) : void

返回当前Yaf_Application的环境名，它被定义在yaf.environ，默认值为"product"。

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Application::environ()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->environ());
?>

以上例程的输出类似于：

product


运行回调函数

  • ? Yaf_Application::environ
  • Yaf_Application::getAppDirectory ?
  • PHP Manual
  • Yaf_Application
  • 运行回调函数

Yaf_Application::execute

(Yaf >=1.0.0)

Yaf_Application::execute — 运行回调函数

说明

public Yaf_Application::execute ( callable $entry , string $... ) : void

这个方法通常用于在cron任务中运行Yaf_Application。 在cron任务中也可以使用autoloader和Bootstrap机制。

参数

entry

一个有效的回调函数

...

零个或者多个要传递给函数的参数。

返回值

范例

Example #1 Yaf_Application::execute()example

<?php
function main($argc, $argv) {
}

$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
$application->execute("main", $argc,  $argv);
?>

以上例程的输出类似于：


获取应用的目录

  • ? Yaf_Application::execute
  • Yaf_Application::getConfig ?
  • PHP Manual
  • Yaf_Application
  • 获取应用的目录

Yaf_Application::getAppDirectory

(Yaf >=2.1.4)

Yaf_Application::getAppDirectory — 获取应用的目录

说明

public Yaf_Application::getAppDirectory ( ) : Yaf_Application

参数

directory

返回值


获取 Yaf_Config_Abstract 的实例

  • ? Yaf_Application::getAppDirectory
  • Yaf_Application::getDispatcher ?
  • PHP Manual
  • Yaf_Application
  • 获取 Yaf_Config_Abstract 的实例

Yaf_Application::getConfig

(Yaf >=1.0.0)

Yaf_Application::getConfig — 获取 Yaf_Config_Abstract 的实例

说明

public Yaf_Application::getConfig ( ) : Yaf_Config_Abstract

参数

此函数没有参数。

返回值

Yaf_Config_Abstract 的实例

范例

Example #1 Yaf_Application::getConfig()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getConfig());
?>

以上例程的输出类似于：

Yaf_Config_Simple Object
(
    [_config:protected] => Array
        (
            [application] => Array
                (
                    [directory] => /home/laruence/local/www/htdocs/application
                )

        )

    [_readonly:protected] => 1
)


获取 Yaf_Dispatcher 的实例

  • ? Yaf_Application::getConfig
  • Yaf_Application::getLastErrorMsg ?
  • PHP Manual
  • Yaf_Application
  • 获取 Yaf_Dispatcher 的实例

Yaf_Application::getDispatcher

(Yaf >=1.0.0)

Yaf_Application::getDispatcher — 获取 Yaf_Dispatcher 的实例

说明

public Yaf_Application::getDispatcher ( ) : Yaf_Dispatcher

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Application::getDispatcher()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getDispatcher());
?>

以上例程的输出类似于：

Yaf_Dispatcher Object
(
    [_router:protected] => Yaf_Router Object
        (
            [_routes:protected] => Array
                (
                    [_default] => Yaf_Route_Static Object
                        (
                        )

                )

            [_current:protected] =>
        )

    [_view:protected] =>
    [_request:protected] => Yaf_Request_Http Object
        (
            [module] =>
            [controller] =>
            [action] =>
            [method] => Cli
            [params:protected] => Array
                (
                )

            [language:protected] =>
            [_exception:protected] =>
            [_base_uri:protected] =>
            [uri:protected] =>
            [dispatched:protected] =>
            [routed:protected] =>
        )

    [_plugins:protected] => Array
        (
        )

    [_auto_render:protected] => 1
    [_return_response:protected] =>
    [_instantly_flush:protected] =>
    [_default_module:protected] => Index
    [_default_controller:protected] => Index
    [_default_action:protected] => index
    [_response] => Yaf_Response_Cli Object
        (
            [_header:protected] => Array
                (
                )

            [_body:protected] =>
            [_sendheader:protected] =>
        )

)


获取最近产生的错误的错误信息

  • ? Yaf_Application::getDispatcher
  • Yaf_Application::getLastErrorNo ?
  • PHP Manual
  • Yaf_Application
  • 获取最近产生的错误的错误信息

Yaf_Application::getLastErrorMsg

(Yaf >=2.1.2)

Yaf_Application::getLastErrorMsg — 获取最近产生的错误的错误信息

说明

public Yaf_Application::getLastErrorMsg ( ) : string

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Application::getLastErrorMsg()example

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   var_dump(Yaf_Application::app()->getLastErrorMsg());
}

$config = array(
 "application" => array(
   "directory" => "/tmp/notexists",
     "dispatcher" => array(
       "throwException" => 0, //trigger error instead of throw exception when error occure
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

以上例程的输出类似于：

string(69) "Could not find controller script /tmp/notexists/controllers/Index.php"


获取最后产生的错误的错误代码

  • ? Yaf_Application::getLastErrorMsg
  • Yaf_Application::getModules ?
  • PHP Manual
  • Yaf_Application
  • 获取最后产生的错误的错误代码

Yaf_Application::getLastErrorNo

(Yaf >=2.1.2)

Yaf_Application::getLastErrorNo — 获取最后产生的错误的错误代码

说明

public Yaf_Application::getLastErrorNo ( ) : int

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Application::getLastErrorNo()example

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   var_dump(Yaf_Application::app()->getLastErrorNo());
   var_dump(Yaf_Application::app()->getLastErrorNo() == YAF_ERR_NOTFOUND_CONTROLLER);
}

$config = array(
  "application" => array(
   "directory" => "/tmp/notexists",
     "dispatcher" => array(
       "throwException" => 0, //trigger error instead of throw exception when error occure
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

以上例程的输出类似于：

int(516)
bool(true)


获取在配置文件中申明的模块

  • ? Yaf_Application::getLastErrorNo
  • Yaf_Application::run ?
  • PHP Manual
  • Yaf_Application
  • 获取在配置文件中申明的模块

Yaf_Application::getModules

(Yaf >=1.0.0)

Yaf_Application::getModules — 获取在配置文件中申明的模块

说明

public Yaf_Application::getModules ( ) : array

获取在配置文件中声明的模块，如果没有声明，它的默认值将是"Index"。

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Application::getModules()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getModules());
?>

以上例程的输出类似于：

Array
(
    [0] => Index
)


运行 Yaf_Application

  • ? Yaf_Application::getModules
  • Yaf_Application::setAppDirectory ?
  • PHP Manual
  • Yaf_Application
  • 运行 Yaf_Application

Yaf_Application::run

(Yaf >=1.0.0)

Yaf_Application::run — 运行 Yaf_Application

说明

public Yaf_Application::run ( ) : void

运行一个Yaf_Application，开始接受并处理请求，分发路由，做出相应的响应。最终将响应返回给客户端。

参数

此函数没有参数。

返回值


改变应用目录

  • ? Yaf_Application::run
  • Yaf_Bootstrap_Abstract ?
  • PHP Manual
  • Yaf_Application
  • 改变应用目录

Yaf_Application::setAppDirectory

(Yaf >=2.1.4)

Yaf_Application::setAppDirectory — 改变应用目录

说明

public Yaf_Application::setAppDirectory ( string $directory ) : Yaf_Application

参数

directory

返回值


The Yaf_Bootstrap_Abstract class

(No version information available, might only be in Git)

简介

Bootstrap是用来在Application运行(run)之前做一些初始化工作的机制.

你可以通过继承Yaf_Bootstrap_Abstract 来定义自己的Bootstrap类.

在Bootstrap类中所有以"_init"开头的公有的方法, 都会被按照定义顺序依次在Yaf_Application::bootstrap() 被调用的时刻调用.

范例

Example #1 Bootstrap example

<?php
   /* bootstrap class should be defined under ./application/Bootstrap.php */
   class Bootstrap extends Yaf_Bootstrap_Abstract {
        public function _initConfig(Yaf_Dispatcher $dispatcher) {
            var_dump(__METHOD__);
        }
        public function _initPlugin(Yaf_Dispatcher $dispatcher) {
            var_dump(__METHOD__);
        }
   }

   $config = array(
       "application" => array(
           "directory" => dirname(__FILE__) . "/application/",
       ),
   );

   $app = new Yaf_Application($config);
   $app->bootstrap();
?>

以上例程的输出类似于：

string(22) "Bootstrap::_initConfig"
string(22) "Bootstrap::_initPlugin"

类摘要

abstract Yaf_Bootstrap_Abstract {
/* 属性 */
/* 方法 */
}


Yaf_Dispatcher 类

(Yaf >=1.0.0)

简介

Yaf_Dispatcher用于初始化处理请求的运行环境, 它协调路由来的请求, 并分发和执行发现的动作, 然后收集动作产生的响应, 输出响应给请求者, 并在整个过程完成以后返回响应.

Yaf_Dispatcher是单例模式运行的, 也就是说自始至终只生成一个Yaf_Dispatcher实例, 因此, 可以把它看成是在分发过程中生成的对象的注册表, 可以从中获取到分发过程中产生的对象.

类摘要

final Yaf_Dispatcher {
/* 属性 */
protected $_router ;
protected $_view ;
protected $_request ;
protected $_plugins ;
protected static $_instance ;
protected $_auto_render ;
protected $_return_response ;
protected $_instantly_flush ;
protected $_default_module ;
protected $_default_controller ;
protected $_default_action ;
/* 方法 */
public autoRender ( bool $flag ) : Yaf_Dispatcher
public catchException ( bool $flag = ? ) : Yaf_Dispatcher
public__construct ( )
public disableView ( ) : bool
public dispatch ( Yaf_Request_Abstract $request ) : Yaf_Response_Abstract
public enableView ( ) : Yaf_Dispatcher
public flushInstantly ( bool $flag ) : Yaf_Dispatcher
public getApplication ( ) : Yaf_Application
public getDefaultAction ( ) : string
public getDefaultController ( ) : string
public getDefaultModule ( ) : string
public static getInstance ( ) : Yaf_Dispatcher
public getRequest ( ) : Yaf_Request_Abstract
public getRouter ( ) : Yaf_Router
public initView ( string $templates_dir , array $options = ? ) : Yaf_View_Interface
public registerPlugin ( Yaf_Plugin_Abstract $plugin ) : Yaf_Dispatcher
public returnResponse ( bool $flag ) : Yaf_Dispatcher
public setDefaultAction ( string $action ) : Yaf_Dispatcher
public setDefaultController ( string $controller ) : Yaf_Dispatcher
public setDefaultModule ( string $module ) : Yaf_Dispatcher
public setErrorHandler ( call $callback , int $error_types ) : Yaf_Dispatcher
public setRequest ( Yaf_Request_Abstract $request ) : Yaf_Dispatcher
public setView ( Yaf_View_Interface $view ) : Yaf_Dispatcher
public throwException ( bool $flag = ? ) : Yaf_Dispatcher
}

属性

_router

_view

_request

_plugins

_instance

_auto_render

_return_response

_instantly_flush

_default_module

_default_controller

_default_action

Table of Contents

  • Yaf_Dispatcher::autoRender — 开启/关闭自动渲染功能
  • Yaf_Dispatcher::catchException — 开启/关闭自动异常捕获功能
  • Yaf_Dispatcher::__construct — Yaf_Dispatcher 构造函数
  • Yaf_Dispatcher::disableView — 关闭自动渲染
  • Yaf_Dispatcher::dispatch — 分发请求
  • Yaf_Dispatcher::enableView — 开启自动渲染
  • Yaf_Dispatcher::flushInstantly — 打开关闭自动响应
  • Yaf_Dispatcher::getApplication — 获取当前的Yaf_Application实例
  • Yaf_Dispatcher::getDefaultAction — Retrive the default action name
  • Yaf_Dispatcher::getDefaultController — Retrive the default controller name
  • Yaf_Dispatcher::getDefaultModule — Retrive the default module name
  • Yaf_Dispatcher::getInstance — 获取当前的Yaf_Dispatcher实例
  • Yaf_Dispatcher::getRequest — 获取当前的请求实例
  • Yaf_Dispatcher::getRouter — 获取路由器
  • Yaf_Dispatcher::initView — 初始化视图引擎并返回它
  • Yaf_Dispatcher::registerPlugin — 注册一个插件
  • Yaf_Dispatcher::returnResponse — The returnResponse purpose
  • Yaf_Dispatcher::setDefaultAction — 设置路由的默认动作
  • Yaf_Dispatcher::setDefaultController — 设置路由的默认控制器
  • Yaf_Dispatcher::setDefaultModule — 设置路由的默认模块
  • Yaf_Dispatcher::setErrorHandler — 设置错误处理函数
  • Yaf_Dispatcher::setRequest — The setRequest purpose
  • Yaf_Dispatcher::setView — 设置视图引擎
  • Yaf_Dispatcher::throwException — 开启/关闭异常抛出


开启/关闭自动渲染功能

  • ? Yaf_Dispatcher
  • Yaf_Dispatcher::catchException ?
  • PHP Manual
  • Yaf_Dispatcher
  • 开启/关闭自动渲染功能

Yaf_Dispatcher::autoRender

(Yaf >=1.0.0)

Yaf_Dispatcher::autoRender — 开启/关闭自动渲染功能

说明

public Yaf_Dispatcher::autoRender ( bool $flag ) : Yaf_Dispatcher

在开启的情况下(Yaf默认开启)，action执行完成以后，Yaf_Dispatcher 会自动调用view引擎去渲染该action对应的视图模板。 你也可以通过调用这个函数并将 flag 参数的值设为TRUE来人工干预它。

Note:

你可以在一个action中仅仅返回FALSE来阻止当前action对应视图的自动渲染

参数

flag

bool

返回值

范例

Example #1 Yaf_Dispatcher::autoRender()example

<?php
class IndexController extends Yaf_Controller_Abstract {
     /* init method will be called as soon as a controller is initialized */
     public function init() {
         if ($this->getRequest()->isXmlHttpRequest()) {
             //do not call render for ajax request
             //we will outpu a json string
             Yaf_Dispatcher::getInstance()->autoRender(FALSE);
         }
     }

}
?>

以上例程的输出类似于：


开启/关闭自动异常捕获功能

  • ? Yaf_Dispatcher::autoRender
  • Yaf_Dispatcher::__construct ?
  • PHP Manual
  • Yaf_Dispatcher
  • 开启/关闭自动异常捕获功能

Yaf_Dispatcher::catchException

(Yaf >=1.0.0)

Yaf_Dispatcher::catchException — 开启/关闭自动异常捕获功能

说明

public Yaf_Dispatcher::catchException ( bool $flag = ? ) : Yaf_Dispatcher

当 application.dispatcher.throwException 开启的时候（你也可以通过调用 Yaf_Dispatcher::throwException(TRUE)() 来开启它），Yaf将会抛出异常而不是触发异常发生。

如果开启了 Yaf_Dispatcher::catchException() （可以通过设置application.dispatcher.catchException来开启），并且在你定义了异常处理的controller的情况下，Yaf会将所有未捕获的异常交给Error Controller的Error Action来处理。

参数

flag

bool

返回值

范例

Example #1 Yaf_Dispatcher::catchException()example

/* if you defined a ErrorController like following */
<?php
class ErrorController extends Yaf_Controller_Abstract {
     /**
      * you can also call to Yaf_Request_Abstract::getException to get the
      * un-caught exception.
      */
     public function error($exception) {
        /* error occurs */
        switch ($exception->getCode()) {
            case YAF_ERR_NOTFOUND_MODULE:
            case YAF_ERR_NOTFOUND_CONTROLLER:
            case YAF_ERR_NOTFOUND_ACTION:
            case YAF_ERR_NOTFOUND_VIEW:
                echo 404, ":", $exception->getMessage();
                break;
            default :
                $message = $exception->getMessage();
                echo 0, ":", $exception->getMessage();
                break;
        }
     }
}
?>

以上例程的输出类似于：

/* now if some error occur, assuming access a non-exists controller(or you can throw a exception yourself): */
404:Could not find controller script **/application/controllers/No-exists-controller.php

参见

  • Yaf_Dispatcher::throwException() - 开启/关闭异常抛出
  • Yaf_Dispatcher::setErrorHandler() - 设置错误处理函数


Yaf_Dispatcher 构造函数

  • ? Yaf_Dispatcher::catchException
  • Yaf_Dispatcher::disableView ?
  • PHP Manual
  • Yaf_Dispatcher
  • Yaf_Dispatcher 构造函数

Yaf_Dispatcher::__construct

(Yaf >=1.0.0)

Yaf_Dispatcher::__construct — Yaf_Dispatcher 构造函数

说明

publicYaf_Dispatcher::__construct ( )

参数

此函数没有参数。

返回值


关闭自动渲染

  • ? Yaf_Dispatcher::__construct
  • Yaf_Dispatcher::dispatch ?
  • PHP Manual
  • Yaf_Dispatcher
  • 关闭自动渲染

Yaf_Dispatcher::disableView

(Yaf >=1.0.0)

Yaf_Dispatcher::disableView — 关闭自动渲染

说明

public Yaf_Dispatcher::disableView ( ) : bool

在一些用户自己会输出信息的情况下使用。

Note:

你可以在一个action中仅仅返回FALSE来阻止当前action对应视图的自动渲染

参数

此函数没有参数。

返回值


分发请求

  • ? Yaf_Dispatcher::disableView
  • Yaf_Dispatcher::enableView ?
  • PHP Manual
  • Yaf_Dispatcher
  • 分发请求

Yaf_Dispatcher::dispatch

(Yaf >=1.0.0)

Yaf_Dispatcher::dispatch — 分发请求

说明

public Yaf_Dispatcher::dispatch ( Yaf_Request_Abstract $request ) : Yaf_Response_Abstract

Yaf_Dispatcher 的这个方法做的工作很繁重.它需要一个request对象。

分发过程有三个不同的事件：

  • 路由
  • 分发
  • 响应
The dispatch process has three distinct events:
  • Routing
  • Dispatching
  • Response
路由只发生一次，当dispatch()被调用的时候，需要使用请求对象中的值。分发发生在一个循环中；一个请求可能会分发出多个action， 或者controller或者一个plugin可能重置请求对象来强制分发其他的action（参见 Yaf_Plugin_Abstract）。 当所有都执行完毕，Yaf_Dispatcher 会返回一个响应。

参数

request

返回值


开启自动渲染

  • ? Yaf_Dispatcher::dispatch
  • Yaf_Dispatcher::flushInstantly ?
  • PHP Manual
  • Yaf_Dispatcher
  • 开启自动渲染

Yaf_Dispatcher::enableView

(Yaf >=1.0.0)

Yaf_Dispatcher::enableView — 开启自动渲染

说明

public Yaf_Dispatcher::enableView ( ) : Yaf_Dispatcher

参数

此函数没有参数。

返回值


打开关闭自动响应

  • ? Yaf_Dispatcher::enableView
  • Yaf_Dispatcher::getApplication ?
  • PHP Manual
  • Yaf_Dispatcher
  • 打开关闭自动响应

Yaf_Dispatcher::flushInstantly

(Yaf >=1.0.0)

Yaf_Dispatcher::flushInstantly — 打开关闭自动响应

说明

public Yaf_Dispatcher::flushInstantly ( bool $flag ) : Yaf_Dispatcher

参数

flag

返回值


获取当前的Yaf_Application实例

  • ? Yaf_Dispatcher::flushInstantly
  • Yaf_Dispatcher::getDefaultAction ?
  • PHP Manual
  • Yaf_Dispatcher
  • 获取当前的Yaf_Application实例

Yaf_Dispatcher::getApplication

(Yaf >=1.0.0)

Yaf_Dispatcher::getApplication — 获取当前的Yaf_Application实例

说明

public Yaf_Dispatcher::getApplication ( ) : Yaf_Application

Retrive the Yaf_Application instance. same as Yaf_Application::app(). 获取当前的Yaf_Application实例。跟 Yaf_Application::app() 相同。

参数

此函数没有参数。

返回值

参见

  • Yaf_Application::app() - 获取当前的Yaf_Application实例


Retrive the default action name

  • ? Yaf_Dispatcher::getApplication
  • Yaf_Dispatcher::getDefaultController ?
  • PHP Manual
  • Yaf_Dispatcher
  • Retrive the default action name

Yaf_Dispatcher::getDefaultAction

(Yaf >=3.2.0)

Yaf_Dispatcher::getDefaultAction — Retrive the default action name

说明

public Yaf_Dispatcher::getDefaultAction ( ) : string

get the default action name

参数

此函数没有参数。

返回值

string, default action name, default is "index"


Retrive the default controller name

  • ? Yaf_Dispatcher::getDefaultAction
  • Yaf_Dispatcher::getDefaultModule ?
  • PHP Manual
  • Yaf_Dispatcher
  • Retrive the default controller name

Yaf_Dispatcher::getDefaultController

(Yaf >=3.2.0)

Yaf_Dispatcher::getDefaultController — Retrive the default controller name

说明

public Yaf_Dispatcher::getDefaultController ( ) : string

get the default controller name

参数

此函数没有参数。

返回值

string, default controller name, default is "Index"


Retrive the default module name

  • ? Yaf_Dispatcher::getDefaultController
  • Yaf_Dispatcher::getInstance ?
  • PHP Manual
  • Yaf_Dispatcher
  • Retrive the default module name

Yaf_Dispatcher::getDefaultModule

(Yaf >=3.2.0)

Yaf_Dispatcher::getDefaultModule — Retrive the default module name

说明

public Yaf_Dispatcher::getDefaultModule ( ) : string

get the default module name

参数

此函数没有参数。

返回值

string, module name, default is "Index"


获取当前的Yaf_Dispatcher实例

  • ? Yaf_Dispatcher::getDefaultModule
  • Yaf_Dispatcher::getRequest ?
  • PHP Manual
  • Yaf_Dispatcher
  • 获取当前的Yaf_Dispatcher实例

Yaf_Dispatcher::getInstance

(Yaf >=1.0.0)

Yaf_Dispatcher::getInstance — 获取当前的Yaf_Dispatcher实例

说明

public static Yaf_Dispatcher::getInstance ( ) : Yaf_Dispatcher

参数

此函数没有参数。

返回值


获取当前的请求实例

  • ? Yaf_Dispatcher::getInstance
  • Yaf_Dispatcher::getRouter ?
  • PHP Manual
  • Yaf_Dispatcher
  • 获取当前的请求实例

Yaf_Dispatcher::getRequest

(Yaf >=1.0.0)

Yaf_Dispatcher::getRequest — 获取当前的请求实例

说明

public Yaf_Dispatcher::getRequest ( ) : Yaf_Request_Abstract

参数

此函数没有参数。

返回值


获取路由器

  • ? Yaf_Dispatcher::getRequest
  • Yaf_Dispatcher::initView ?
  • PHP Manual
  • Yaf_Dispatcher
  • 获取路由器

Yaf_Dispatcher::getRouter

(Yaf >=1.0.0)

Yaf_Dispatcher::getRouter — 获取路由器

说明

public Yaf_Dispatcher::getRouter ( ) : Yaf_Router

参数

此函数没有参数。

返回值


初始化视图引擎并返回它

  • ? Yaf_Dispatcher::getRouter
  • Yaf_Dispatcher::registerPlugin ?
  • PHP Manual
  • Yaf_Dispatcher
  • 初始化视图引擎并返回它

Yaf_Dispatcher::initView

(Yaf >=1.0.0)

Yaf_Dispatcher::initView — 初始化视图引擎并返回它

说明

public Yaf_Dispatcher::initView ( string $templates_dir , array $options = ? ) : Yaf_View_Interface

参数

templates_dir

options

返回值


注册一个插件

  • ? Yaf_Dispatcher::initView
  • Yaf_Dispatcher::returnResponse ?
  • PHP Manual
  • Yaf_Dispatcher
  • 注册一个插件

Yaf_Dispatcher::registerPlugin

(Yaf >=1.0.0)

Yaf_Dispatcher::registerPlugin — 注册一个插件

说明

public Yaf_Dispatcher::registerPlugin ( Yaf_Plugin_Abstract $plugin ) : Yaf_Dispatcher

Yaf_Bootstrap_Abstract). 注册一个插件（参见 Yaf_Plugin_Abstract）。

参数

plugin

返回值

范例

Example #1 Yaf_Dispatcher::registerPlugin()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract {
  public function _initPlugin(Yaf_Dispatcher $dispatcher) {
    /**
    * Yaf assumes plugin scripts under [application.directory] .  "/plugins"
    * for this case, it will be:
    * [application.directory] . "/plugins/" . "User" . [application.ext]
    */
    $user = new UserPlugin();
    $dispatcher->registerPlugin($user);
  }
}
?>

参见

  • Yaf_Plugin_Abstract
  • Yaf_Bootstrap_Abstract


The returnResponse purpose

  • ? Yaf_Dispatcher::registerPlugin
  • Yaf_Dispatcher::setDefaultAction ?
  • PHP Manual
  • Yaf_Dispatcher
  • The returnResponse purpose

Yaf_Dispatcher::returnResponse

(Yaf >=1.0.0)

Yaf_Dispatcher::returnResponse — The returnResponse purpose

说明

public Yaf_Dispatcher::returnResponse ( bool $flag ) : Yaf_Dispatcher

参数

flag

返回值


设置路由的默认动作

  • ? Yaf_Dispatcher::returnResponse
  • Yaf_Dispatcher::setDefaultController ?
  • PHP Manual
  • Yaf_Dispatcher
  • 设置路由的默认动作

Yaf_Dispatcher::setDefaultAction

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultAction — 设置路由的默认动作

说明

public Yaf_Dispatcher::setDefaultAction ( string $action ) : Yaf_Dispatcher

参数

action

返回值


设置路由的默认控制器

  • ? Yaf_Dispatcher::setDefaultAction
  • Yaf_Dispatcher::setDefaultModule ?
  • PHP Manual
  • Yaf_Dispatcher
  • 设置路由的默认控制器

Yaf_Dispatcher::setDefaultController

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultController — 设置路由的默认控制器

说明

public Yaf_Dispatcher::setDefaultController ( string $controller ) : Yaf_Dispatcher

参数

controller

返回值


设置路由的默认模块

  • ? Yaf_Dispatcher::setDefaultController
  • Yaf_Dispatcher::setErrorHandler ?
  • PHP Manual
  • Yaf_Dispatcher
  • 设置路由的默认模块

Yaf_Dispatcher::setDefaultModule

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultModule — 设置路由的默认模块

说明

public Yaf_Dispatcher::setDefaultModule ( string $module ) : Yaf_Dispatcher

参数

module

返回值


设置错误处理函数

  • ? Yaf_Dispatcher::setDefaultModule
  • Yaf_Dispatcher::setRequest ?
  • PHP Manual
  • Yaf_Dispatcher
  • 设置错误处理函数

Yaf_Dispatcher::setErrorHandler

(Yaf >=1.0.0)

Yaf_Dispatcher::setErrorHandler — 设置错误处理函数

说明

public Yaf_Dispatcher::setErrorHandler ( call $callback , int $error_types ) : Yaf_Dispatcher

设置错误处理函数，一般在application.dispatcher.throwException关闭的情况下，Yaf会在出错的时候触发错误，这个时候，如果设置了错误处理函数，则会把控制交给错误处理函数处理。

因此，当错误发生的时候这个错误处理函数将被调用。

参数

callback

错误处理的回调函数

error_types

返回值

参见

  • Yaf_Dispatcher::throwException() - 开启/关闭异常抛出
  • Yaf_Application::getLastErrorNo() - 获取最后产生的错误的错误代码
  • Yaf_Application::getLastErrorMsg() - 获取最近产生的错误的错误信息


The setRequest purpose

  • ? Yaf_Dispatcher::setErrorHandler
  • Yaf_Dispatcher::setView ?
  • PHP Manual
  • Yaf_Dispatcher
  • The setRequest purpose

Yaf_Dispatcher::setRequest

(Yaf >=1.0.0)

Yaf_Dispatcher::setRequest — The setRequest purpose

说明

public Yaf_Dispatcher::setRequest ( Yaf_Request_Abstract $request ) : Yaf_Dispatcher

参数

plugin

返回值


设置视图引擎

  • ? Yaf_Dispatcher::setRequest
  • Yaf_Dispatcher::throwException ?
  • PHP Manual
  • Yaf_Dispatcher
  • 设置视图引擎

Yaf_Dispatcher::setView

(Yaf >=1.0.0)

Yaf_Dispatcher::setView — 设置视图引擎

说明

public Yaf_Dispatcher::setView ( Yaf_View_Interface $view ) : Yaf_Dispatcher

如果你想使用自己的视图引擎代替 Yaf_View_Simple ， 这个函数会帮你解决这个问题。

参数

view

A Yaf_View_Interface instance

返回值

范例

Example #1 A custom View engine()example

<?php
require "/path/to/smarty/Smarty.class.php";

class Smarty_Adapter implements Yaf_View_Interface
{
    /**
     * Smarty object
     * @var Smarty
     */
    public $_smarty;

    /**
     * Constructor
     *
     * @param string $tmplPath
     * @param array $extraParams
     * @return void
     */
    public function __construct($tmplPath = null, $extraParams = array()) {
        $this->_smarty = new Smarty;

        if (null !== $tmplPath) {
            $this->setScriptPath($tmplPath);
        }

        foreach ($extraParams as $key => $value) {
            $this->_smarty->$key = $value;
        }
    }

    /**
     * Set the path to the templates
     *
     * @param string $path The directory to set as the path.
     * @return void
     */
    public function setScriptPath($path)
    {
        if (is_readable($path)) {
            $this->_smarty->template_dir = $path;
            return;
        }

        throw new Exception('Invalid path provided');
    }

    /**
     * Assign a variable to the template
     *
     * @param string $key The variable name.
     * @param mixed $val The variable value.
     * @return void
     */
    public function __set($key, $val)
    {
        $this->_smarty->assign($key, $val);
    }

    /**
     * Allows testing with empty() and isset() to work
     *
     * @param string $key
     * @return boolean
     */
    public function __isset($key)
    {
        return (null !== $this->_smarty->get_template_vars($key));
    }

    /**
     * Allows unset() on object properties to work
     *
     * @param string $key
     * @return void
     */
    public function __unset($key)
    {
        $this->_smarty->clear_assign($key);
    }

    /**
     * Assign variables to the template
     *
     * Allows setting a specific key to the specified value, OR passing
     * an array of key => value pairs to set en masse.
     *
     * @see __set()
     * @param string|array $spec The assignment strategy to use (key or
     * array of key => value pairs)
     * @param mixed $value (Optional) If assigning a named variable,
     * use this as the value.
     * @return void
     */
    public function assign($spec, $value = null) {
        if (is_array($spec)) {
            $this->_smarty->assign($spec);
            return;
        }

        $this->_smarty->assign($spec, $value);
    }

    /**
     * Clear all assigned variables
     *
     * Clears all variables assigned to Yaf_View either via
     * {@link assign()} or property overloading
     * ({@link __get()}/{@link __set()}).
     *
     * @return void
     */
    public function clearVars() {
        $this->_smarty->clear_all_assign();
    }

    /**
     * Processes a template and returns the output.
     *
     * @param string $name The template to process.
     * @return string The output.
     */
    public function render($name, $value = NULL) {
        return $this->_smarty->fetch($name);
    }

    public function display($name, $value = NULL) {
        echo $this->_smarty->fetch($name);
    }

}
?>

Example #2 Yaf_Dispatcher::setView()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract {

    /**
     * there are some config for smarty in the config:
     *
     * smarty.left_delimiter   = "{{"
     * smarty.right_delimiter  = "}}"
     * smarty.template_dir     = APPLICATION_PATH "/views/scripts/"
     * smarty.compile_dir      = APPLICATION_PATH "/views/templates_c/"
     * smarty.cache_dir        = APPLICATION_PATH "/views/templates_d/"
     *
     */
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initLocalName() {
        /** we put class Smarty_Adapter under the local library directory */
        Yaf_Loader::getInstance()->registerLocalNamespace('Smarty');
    }

    public function _initSmarty(Yaf_Dispatcher $dispatcher) {
        $smarty = new Smarty_Adapter(null, Yaf_Registry::get("config")->get("smarty"));
        $dispatcher->setView($smarty);
        /* now the Smarty view engine become the default view engine of Yaf */
    }
}
?>

参见

  • Yaf_View_Interface
  • Yaf_View_Simple


开启/关闭异常抛出

  • ? Yaf_Dispatcher::setView
  • Yaf_Config_Abstract ?
  • PHP Manual
  • Yaf_Dispatcher
  • 开启/关闭异常抛出

Yaf_Dispatcher::throwException

(Yaf >=1.0.0)

Yaf_Dispatcher::throwException — 开启/关闭异常抛出

说明

public Yaf_Dispatcher::throwException ( bool $flag = ? ) : Yaf_Dispatcher

当意外的错误发生的时候，开启/关闭异常抛出。 当开启的时候，Yaf将会抛出异常而不是触发可捕捉的错误。

你也可以使用 application.dispatcher.throwException来达到相同的目的。

参数

flag

bool

返回值

范例

Example #1 Yaf_Dispatcher::throwexception()example

<?php

$config = array(
    'application' => array(
        'directory' => dirname(__FILE__),
    ),
);
$app = new Yaf_Application($config);

$app->getDispatcher()->throwException(true);

try {
    $app->run();
} catch (Yaf_Exception $e) {
    var_dump($e->getMessage());
}
?>

以上例程的输出类似于：

string(59) "Could not find controller script /tmp/controllers/Index.php"

Example #2 Yaf_Dispatcher::throwexception()example

<?php

$config = array(
    'application' => array(
        'directory' => dirname(__FILE__),
    ),
);
$app = new Yaf_Application($config);

$app->getDispatcher()->throwException(false);

$app->run();
?>

以上例程的输出类似于：

PHP Catchable fatal error:  Yaf_Application::run(): Could not find controller script /tmp/controllers/Index.php in /tmp/1.php on line 12

参见

  • Yaf_Dispatcher::catchException() - 开启/关闭自动异常捕获功能
  • Yaf_Exception


The Yaf_Config_Abstract class

(Yaf >=1.0.0)

简介

类摘要

abstract Yaf_Config_Abstract {
/* 属性 */
protected $_config ;
protected $_readonly ;
/* 方法 */
abstract public get ( string $name , mixed $value ) : mixed
abstract public readonly ( ) : bool
abstract public set ( ) : Yaf_Config_Abstract
abstract public toArray ( ) : array
}

属性

_config

_readonly

Table of Contents

  • Yaf_Config_Abstract::get — Getter
  • Yaf_Config_Abstract::readonly — 寻找只读配置
  • Yaf_Config_Abstract::set — Setter
  • Yaf_Config_Abstract::toArray — 转换为数组


Getter

  • ? Yaf_Config_Abstract
  • Yaf_Config_Abstract::readonly ?
  • PHP Manual
  • Yaf_Config_Abstract
  • Getter

Yaf_Config_Abstract::get

(Yaf >=1.0.0)

Yaf_Config_Abstract::get — Getter

说明

abstract public Yaf_Config_Abstract::get ( string $name , mixed $value ) : mixed

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


寻找只读配置

  • ? Yaf_Config_Abstract::get
  • Yaf_Config_Abstract::set ?
  • PHP Manual
  • Yaf_Config_Abstract
  • 寻找只读配置

Yaf_Config_Abstract::readonly

(Yaf >=1.0.0)

Yaf_Config_Abstract::readonly — 寻找只读配置

说明

abstract public Yaf_Config_Abstract::readonly ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Setter

  • ? Yaf_Config_Abstract::readonly
  • Yaf_Config_Abstract::toArray ?
  • PHP Manual
  • Yaf_Config_Abstract
  • Setter

Yaf_Config_Abstract::set

(Yaf >=1.0.0)

Yaf_Config_Abstract::set — Setter

说明

abstract public Yaf_Config_Abstract::set ( ) : Yaf_Config_Abstract

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


转换为数组

  • ? Yaf_Config_Abstract::set
  • Yaf_Config_Ini ?
  • PHP Manual
  • Yaf_Config_Abstract
  • 转换为数组

Yaf_Config_Abstract::toArray

(Yaf >=1.0.0)

Yaf_Config_Abstract::toArray — 转换为数组

说明

abstract public Yaf_Config_Abstract::toArray ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Config_Ini class

(Yaf >=1.0.0)

简介

Yaf_Config_Ini允许开发者通过嵌套的对象属性语法在应用程序中用熟悉的INI格式存储和读取配置数据。 INI格式在提供拥有配置数据键的等级结构和配置数据节之间的继承能力方面具有专长。 配置数据等级结构通过用点或者句号(.)分离键值。 一个节可以扩展或者通过在节的名称之后带一个冒号(:)和被继承的配置数据的节的名称来从另一个节继承。

Note:

Yaf_Config_Ini利用PHP的函数parse_ini_file()来解析配置文件的。 请仔细查看这个函数的文档，注意它的一些特殊用途。以及它传递给Yaf_Config_Ini的一些比如 "TRUE", "FALSE","yes", "no", 和"NULL"的特殊值的处理方式

类摘要

Yaf_Config_Ini extends Yaf_Config_Abstract implements Iterator , Traversable , ArrayAccess , Countable {
/* 属性 */
/* 方法 */
public __construct ( string $config_file , string $section = ? )
public count ( ) : void
public current ( ) : void
public __get ( string $name = ? ) : void
public __isset ( string $name ) : void
public key ( ) : void
public next ( ) : void
public offsetExists ( string $name ) : void
public offsetGet ( string $name ) : void
public offsetSet ( string $name , string $value ) : void
public offsetUnset ( string $name ) : void
public readonly ( ) : void
public rewind ( ) : void
public __set ( string $name , mixed $value ) : void
public toArray ( ) : void
public valid ( ) : void
/* 继承的方法 */
abstract public Yaf_Config_Abstract::get ( string $name , mixed $value ) : mixed
abstract public Yaf_Config_Abstract::readonly ( ) : bool
abstract public Yaf_Config_Abstract::set ( ) : Yaf_Config_Abstract
abstract public Yaf_Config_Abstract::toArray ( ) : array
}

属性

_config

_readonly

范例

Example #1 Yaf_Config_Ini()example

这个例子说明了使用Yaf_Config_Ini从一个INI配置文件中获取配置数据的基本用法。 这个例子中既有生产环境的配置方法也有演示环境的配置方法。 因为演示环境的配置跟生产环境的非常类似，所以演示环境的配置继承了生产环境的配置。 在复杂的情况下，决定是任意的，也可以写成相反的。在更复杂的情况下，生产环境继承自演示环境不是不可能的。 假设，以下配置数据都包含在/path/to/config.ini中：

; Production site configuration data
[production]
webhost                  = www.example.com
database.adapter         = pdo_mysql
database.params.host     = db.example.com
database.params.username = dbuser
database.params.password = secret
database.params.dbname   = dbname

; Staging site configuration data inherits from production and
; overrides values as necessary
[staging : production]
database.params.host     = dev.example.com
database.params.username = devuser
database.params.password = devsecret
<?php
$config = new Yaf_Config_Ini('/path/to/config.ini', 'staging');

var_dump($config->database->params->host);
var_dump($config->database->params->dbname);
var_dump($config->get("database.params.username"));
?>

以上例程的输出类似于：

string(15) "dev.example.com"
string(6) "dbname"
string(7) "devuser

Table of Contents

  • Yaf_Config_Ini::__construct — 构造函数
  • Yaf_Config_Ini::count — 返回配置的节数量
  • Yaf_Config_Ini::current — 返回当前节点
  • Yaf_Config_Ini::__get — 读取节点配置
  • Yaf_Config_Ini::__isset — 检查节点是否存在
  • Yaf_Config_Ini::key — 返回当前元素的键
  • Yaf_Config_Ini::next — 向前移动到下一个元素
  • Yaf_Config_Ini::offsetExists — 检查一个偏移位置是否存在
  • Yaf_Config_Ini::offsetGet — 获取一个偏移位置的值
  • Yaf_Config_Ini::offsetSet — 设置一个偏移位置的值
  • Yaf_Config_Ini::offsetUnset — 复位一个偏移位置的值
  • Yaf_Config_Ini::readonly — 检查配置是否只读
  • Yaf_Config_Ini::rewind — 检查当前位置是否有效
  • Yaf_Config_Ini::__set — The __set purpose
  • Yaf_Config_Ini::toArray — 转换为数组的格式
  • Yaf_Config_Ini::valid — 检查迭代器是否有效


构造函数

  • ? Yaf_Config_Ini
  • Yaf_Config_Ini::count ?
  • PHP Manual
  • Yaf_Config_Ini
  • 构造函数

Yaf_Config_Ini::__construct

(Yaf >=1.0.0)

Yaf_Config_Ini::__construct — 构造函数

说明

public Yaf_Config_Ini::__construct ( string $config_file , string $section = ? )

Warning

本函数还未编写文档，仅有参数列表。

参数

config_file

section

返回值


返回配置的节数量

  • ? Yaf_Config_Ini::__construct
  • Yaf_Config_Ini::current ?
  • PHP Manual
  • Yaf_Config_Ini
  • 返回配置的节数量

Yaf_Config_Ini::count

(Yaf >=1.0.0)

Yaf_Config_Ini::count — 返回配置的节数量

说明

public Yaf_Config_Ini::count ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


返回当前节点

  • ? Yaf_Config_Ini::count
  • Yaf_Config_Ini::__get ?
  • PHP Manual
  • Yaf_Config_Ini
  • 返回当前节点

Yaf_Config_Ini::current

(Yaf >=1.0.0)

Yaf_Config_Ini::current — 返回当前节点

说明

public Yaf_Config_Ini::current ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


读取节点配置

  • ? Yaf_Config_Ini::current
  • Yaf_Config_Ini::__isset ?
  • PHP Manual
  • Yaf_Config_Ini
  • 读取节点配置

Yaf_Config_Ini::__get

(Yaf >=1.0.0)

Yaf_Config_Ini::__get — 读取节点配置

说明

public Yaf_Config_Ini::__get ( string $name = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


检查节点是否存在

  • ? Yaf_Config_Ini::__get
  • Yaf_Config_Ini::key ?
  • PHP Manual
  • Yaf_Config_Ini
  • 检查节点是否存在

Yaf_Config_Ini::__isset

(Yaf >=1.0.0)

Yaf_Config_Ini::__isset — 检查节点是否存在

说明

public Yaf_Config_Ini::__isset ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


返回当前元素的键

  • ? Yaf_Config_Ini::__isset
  • Yaf_Config_Ini::next ?
  • PHP Manual
  • Yaf_Config_Ini
  • 返回当前元素的键

Yaf_Config_Ini::key

(Yaf >=1.0.0)

Yaf_Config_Ini::key — 返回当前元素的键

说明

public Yaf_Config_Ini::key ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


向前移动到下一个元素

  • ? Yaf_Config_Ini::key
  • Yaf_Config_Ini::offsetExists ?
  • PHP Manual
  • Yaf_Config_Ini
  • 向前移动到下一个元素

Yaf_Config_Ini::next

(Yaf >=1.0.0)

Yaf_Config_Ini::next — 向前移动到下一个元素

说明

public Yaf_Config_Ini::next ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


检查一个偏移位置是否存在

  • ? Yaf_Config_Ini::next
  • Yaf_Config_Ini::offsetGet ?
  • PHP Manual
  • Yaf_Config_Ini
  • 检查一个偏移位置是否存在

Yaf_Config_Ini::offsetExists

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetExists — 检查一个偏移位置是否存在

说明

public Yaf_Config_Ini::offsetExists ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


获取一个偏移位置的值

  • ? Yaf_Config_Ini::offsetExists
  • Yaf_Config_Ini::offsetSet ?
  • PHP Manual
  • Yaf_Config_Ini
  • 获取一个偏移位置的值

Yaf_Config_Ini::offsetGet

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetGet — 获取一个偏移位置的值

说明

public Yaf_Config_Ini::offsetGet ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


设置一个偏移位置的值

  • ? Yaf_Config_Ini::offsetGet
  • Yaf_Config_Ini::offsetUnset ?
  • PHP Manual
  • Yaf_Config_Ini
  • 设置一个偏移位置的值

Yaf_Config_Ini::offsetSet

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetSet — 设置一个偏移位置的值

说明

public Yaf_Config_Ini::offsetSet ( string $name , string $value ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值


复位一个偏移位置的值

  • ? Yaf_Config_Ini::offsetSet
  • Yaf_Config_Ini::readonly ?
  • PHP Manual
  • Yaf_Config_Ini
  • 复位一个偏移位置的值

Yaf_Config_Ini::offsetUnset

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetUnset — 复位一个偏移位置的值

说明

public Yaf_Config_Ini::offsetUnset ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


检查配置是否只读

  • ? Yaf_Config_Ini::offsetUnset
  • Yaf_Config_Ini::rewind ?
  • PHP Manual
  • Yaf_Config_Ini
  • 检查配置是否只读

Yaf_Config_Ini::readonly

(Yaf >=1.0.0)

Yaf_Config_Ini::readonly — 检查配置是否只读

说明

public Yaf_Config_Ini::readonly ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


检查当前位置是否有效

  • ? Yaf_Config_Ini::readonly
  • Yaf_Config_Ini::__set ?
  • PHP Manual
  • Yaf_Config_Ini
  • 检查当前位置是否有效

Yaf_Config_Ini::rewind

(Yaf >=1.0.0)

Yaf_Config_Ini::rewind — 检查当前位置是否有效

说明

public Yaf_Config_Ini::rewind ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The __set purpose

  • ? Yaf_Config_Ini::rewind
  • Yaf_Config_Ini::toArray ?
  • PHP Manual
  • Yaf_Config_Ini
  • The __set purpose

Yaf_Config_Ini::__set

(Yaf >=1.0.0)

Yaf_Config_Ini::__set — The __set purpose

说明

public Yaf_Config_Ini::__set ( string $name , mixed $value ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值


转换为数组的格式

  • ? Yaf_Config_Ini::__set
  • Yaf_Config_Ini::valid ?
  • PHP Manual
  • Yaf_Config_Ini
  • 转换为数组的格式

Yaf_Config_Ini::toArray

(Yaf >=1.0.0)

Yaf_Config_Ini::toArray — 转换为数组的格式

说明

public Yaf_Config_Ini::toArray ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


检查迭代器是否有效

  • ? Yaf_Config_Ini::toArray
  • Yaf_Config_Simple ?
  • PHP Manual
  • Yaf_Config_Ini
  • 检查迭代器是否有效

Yaf_Config_Ini::valid

(Yaf >=1.0.0)

Yaf_Config_Ini::valid — 检查迭代器是否有效

说明

public Yaf_Config_Ini::valid ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Config_Simple class

(Yaf >=1.0.0)

简介

Yaf_Config_Simple 是 Yad_Config_ini 的简洁版本，只允许传入数组进行初始化，并提供了设置readonly的参数。

类摘要

Yaf_Config_Simple extends Yaf_Config_Abstract implements Iterator , Traversable , ArrayAccess , Countable {
/* 属性 */
protected $_readonly ;
/* 方法 */
public __construct ( string $config_file , string $section = ? )
public count ( ) : void
public current ( ) : void
public __get ( string $name = ? ) : void
public __isset ( string $name ) : void
public key ( ) : void
public next ( ) : void
public offsetExists ( string $name ) : void
public offsetGet ( string $name ) : void
public offsetSet ( string $name , string $value ) : void
public offsetUnset ( string $name ) : void
public readonly ( ) : void
public rewind ( ) : void
public __set ( string $name , string $value ) : void
public toArray ( ) : void
public valid ( ) : void
/* 继承的方法 */
abstract public Yaf_Config_Abstract::get ( string $name , mixed $value ) : mixed
abstract public Yaf_Config_Abstract::readonly ( ) : bool
abstract public Yaf_Config_Abstract::set ( ) : Yaf_Config_Abstract
abstract public Yaf_Config_Abstract::toArray ( ) : array
}

属性

_config

_readonly

Table of Contents

  • Yaf_Config_Simple::__construct — 构造函数
  • Yaf_Config_Simple::count — 返回配置的节数量
  • Yaf_Config_Simple::current — 返回当前节点
  • Yaf_Config_Simple::__get — 读取节点配置
  • Yaf_Config_Simple::__isset — 检查节点是否存在
  • Yaf_Config_Simple::key — 返回当前元素的键
  • Yaf_Config_Simple::next — 向前移动到下一个元素
  • Yaf_Config_Simple::offsetExists — 检查一个偏移位置是否存在
  • Yaf_Config_Simple::offsetGet — 获取一个偏移位置的值
  • Yaf_Config_Simple::offsetSet — 设置一个偏移位置的值
  • Yaf_Config_Simple::offsetUnset — 复位一个偏移位置的值
  • Yaf_Config_Simple::readonly — 检查配置是否只读
  • Yaf_Config_Simple::rewind — 检查当前位置是否有效
  • Yaf_Config_Simple::__set — 设置节点配置
  • Yaf_Config_Simple::toArray — 转换为数组的格式
  • Yaf_Config_Simple::valid — 检查迭代器是否有效


构造函数

  • ? Yaf_Config_Simple
  • Yaf_Config_Simple::count ?
  • PHP Manual
  • Yaf_Config_Simple
  • 构造函数

Yaf_Config_Simple::__construct

(Yaf >=1.0.0)

Yaf_Config_Simple::__construct — 构造函数

说明

public Yaf_Config_Simple::__construct ( string $config_file , string $section = ? )

Warning

本函数还未编写文档，仅有参数列表。

参数

config_file

section

返回值


返回配置的节数量

  • ? Yaf_Config_Simple::__construct
  • Yaf_Config_Simple::current ?
  • PHP Manual
  • Yaf_Config_Simple
  • 返回配置的节数量

Yaf_Config_Simple::count

(Yaf >=1.0.0)

Yaf_Config_Simple::count — 返回配置的节数量

说明

public Yaf_Config_Simple::count ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


返回当前节点

  • ? Yaf_Config_Simple::count
  • Yaf_Config_Simple::__get ?
  • PHP Manual
  • Yaf_Config_Simple
  • 返回当前节点

Yaf_Config_Simple::current

(Yaf >=1.0.0)

Yaf_Config_Simple::current — 返回当前节点

说明

public Yaf_Config_Simple::current ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


读取节点配置

  • ? Yaf_Config_Simple::current
  • Yaf_Config_Simple::__isset ?
  • PHP Manual
  • Yaf_Config_Simple
  • 读取节点配置

Yaf_Config_Simple::__get

(Yaf >=1.0.0)

Yaf_Config_Simple::__get — 读取节点配置

说明

public Yaf_Config_Simple::__get ( string $name = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


检查节点是否存在

  • ? Yaf_Config_Simple::__get
  • Yaf_Config_Simple::key ?
  • PHP Manual
  • Yaf_Config_Simple
  • 检查节点是否存在

Yaf_Config_Simple::__isset

(Yaf >=1.0.0)

Yaf_Config_Simple::__isset — 检查节点是否存在

说明

public Yaf_Config_Simple::__isset ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


返回当前元素的键

  • ? Yaf_Config_Simple::__isset
  • Yaf_Config_Simple::next ?
  • PHP Manual
  • Yaf_Config_Simple
  • 返回当前元素的键

Yaf_Config_Simple::key

(Yaf >=1.0.0)

Yaf_Config_Simple::key — 返回当前元素的键

说明

public Yaf_Config_Simple::key ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


向前移动到下一个元素

  • ? Yaf_Config_Simple::key
  • Yaf_Config_Simple::offsetExists ?
  • PHP Manual
  • Yaf_Config_Simple
  • 向前移动到下一个元素

Yaf_Config_Simple::next

(Yaf >=1.0.0)

Yaf_Config_Simple::next — 向前移动到下一个元素

说明

public Yaf_Config_Simple::next ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


检查一个偏移位置是否存在

  • ? Yaf_Config_Simple::next
  • Yaf_Config_Simple::offsetGet ?
  • PHP Manual
  • Yaf_Config_Simple
  • 检查一个偏移位置是否存在

Yaf_Config_Simple::offsetExists

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetExists — 检查一个偏移位置是否存在

说明

public Yaf_Config_Simple::offsetExists ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


获取一个偏移位置的值

  • ? Yaf_Config_Simple::offsetExists
  • Yaf_Config_Simple::offsetSet ?
  • PHP Manual
  • Yaf_Config_Simple
  • 获取一个偏移位置的值

Yaf_Config_Simple::offsetGet

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetGet — 获取一个偏移位置的值

说明

public Yaf_Config_Simple::offsetGet ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


设置一个偏移位置的值

  • ? Yaf_Config_Simple::offsetGet
  • Yaf_Config_Simple::offsetUnset ?
  • PHP Manual
  • Yaf_Config_Simple
  • 设置一个偏移位置的值

Yaf_Config_Simple::offsetSet

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetSet — 设置一个偏移位置的值

说明

public Yaf_Config_Simple::offsetSet ( string $name , string $value ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值


复位一个偏移位置的值

  • ? Yaf_Config_Simple::offsetSet
  • Yaf_Config_Simple::readonly ?
  • PHP Manual
  • Yaf_Config_Simple
  • 复位一个偏移位置的值

Yaf_Config_Simple::offsetUnset

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetUnset — 复位一个偏移位置的值

说明

public Yaf_Config_Simple::offsetUnset ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


检查配置是否只读

  • ? Yaf_Config_Simple::offsetUnset
  • Yaf_Config_Simple::rewind ?
  • PHP Manual
  • Yaf_Config_Simple
  • 检查配置是否只读

Yaf_Config_Simple::readonly

(Yaf >=1.0.0)

Yaf_Config_Simple::readonly — 检查配置是否只读

说明

public Yaf_Config_Simple::readonly ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


检查当前位置是否有效

  • ? Yaf_Config_Simple::readonly
  • Yaf_Config_Simple::__set ?
  • PHP Manual
  • Yaf_Config_Simple
  • 检查当前位置是否有效

Yaf_Config_Simple::rewind

(Yaf >=1.0.0)

Yaf_Config_Simple::rewind — 检查当前位置是否有效

说明

public Yaf_Config_Simple::rewind ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


设置节点配置

  • ? Yaf_Config_Simple::rewind
  • Yaf_Config_Simple::toArray ?
  • PHP Manual
  • Yaf_Config_Simple
  • 设置节点配置

Yaf_Config_Simple::__set

(Yaf >=1.0.0)

Yaf_Config_Simple::__set — 设置节点配置

说明

public Yaf_Config_Simple::__set ( string $name , string $value ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值


转换为数组的格式

  • ? Yaf_Config_Simple::__set
  • Yaf_Config_Simple::valid ?
  • PHP Manual
  • Yaf_Config_Simple
  • 转换为数组的格式

Yaf_Config_Simple::toArray

(Yaf >=1.0.0)

Yaf_Config_Simple::toArray — 转换为数组的格式

说明

public Yaf_Config_Simple::toArray ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


检查迭代器是否有效

  • ? Yaf_Config_Simple::toArray
  • Yaf_Controller_Abstract ?
  • PHP Manual
  • Yaf_Config_Simple
  • 检查迭代器是否有效

Yaf_Config_Simple::valid

(Yaf >=1.0.0)

Yaf_Config_Simple::valid — 检查迭代器是否有效

说明

public Yaf_Config_Simple::valid ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Controller_Abstract class

(Yaf >=1.0.0)

简介

Yaf_Controller_Abstract 是Yaf的MVC体系的核心部分。 MVC是指Model-View-Controller, 是一个用于分离应用逻辑和表现逻辑的设计模式。

每个用户自定义controller都应当继承Yaf_Controller_Abstract。

你会发现在你自己的controller中无法定义__construct方法。因此，Yaf_Controller_Abstract 提供了一个魔术方法Yaf_Controller_Abstract::init()。

如果在你自己的controller里面已经定义了一个init()方法，当你的controller被实例化的时候，它将被调用。

Action可能需要参数，当一个请求来到的时候，在路由中如果请求的参数有相同名称的变量（例如：Yaf_Request_Abstract::getParam()）， Yaf将把他们传递给action方法（see Yaf_Action_Abstract::execute()）。

类摘要

abstract Yaf_Controller_Abstract {
/* 属性 */
public $actions ;
protected $_module ;
protected $_name ;
protected $_request ;
protected $_response ;
protected $_invoke_args ;
protected $_view ;
/* 方法 */
final private __construct ( )
protected display ( string $tpl , array $parameters = ? ) : bool
public forward ( string $module , string $controller = ? , string $action = ? , array $paramters = ? ) : void
public getInvokeArg ( string $name ) : void
public getInvokeArgs ( ) : void
public getModuleName ( ) : string
public getName ( ) : string
public getRequest ( ) : Yaf_Request_Abstract
public getResponse ( ) : Yaf_Response_Abstract
public getView ( ) : Yaf_View_Interface
public getViewpath ( ) : void
public init ( ) : void
public initView ( array $options = ? ) : void
public redirect ( string $url ) : void
protected render ( string $tpl , array $parameters = ? ) : string
public setViewpath ( string $view_directory ) : void
}

属性

actions

你也可以通过使用这个值和 Yaf_Action_Abstract 在一个单独的PHP脚本中定义action函数。

Example #1 在一个独立的文件中定义action

<?php
class IndexController extends Yaf_Controller_Abstract {
    protected $actions = array(
        /** now dummyAction is defined in a separate file */
        "dummy" => "actions/Dummy_action.php",
    );

    /* action method may have arguments */
    public indexAction($name, $id) {
       assert($name == $this->getRequest()->getParam("name"));
       assert($id   == $this->_request->getParam("id"));
    }
}
?>

Example #2 Dummy_action.php

<?php
class DummyAction extends Yaf_Action_Abstract {
    /* a action class shall define this method  as the entry point */
    public execute() {
    }
}
?>

_module

模块名

_name

_request

当前的请求实例

_response

_invoke_args

_view

视图引擎

Table of Contents

  • Yaf_Controller_Abstract::__construct — Yaf_Controller_Abstract constructor
  • Yaf_Controller_Abstract::display — The display purpose
  • Yaf_Controller_Abstract::forward — The forward purpose
  • Yaf_Controller_Abstract::getInvokeArg — The getInvokeArg purpose
  • Yaf_Controller_Abstract::getInvokeArgs — The getInvokeArgs purpose
  • Yaf_Controller_Abstract::getModuleName — 获取当前控制器所属的模块名
  • Yaf_Controller_Abstract::getName — Get self name
  • Yaf_Controller_Abstract::getRequest — The getRequest purpose
  • Yaf_Controller_Abstract::getResponse — The getResponse purpose
  • Yaf_Controller_Abstract::getView — 获取当前的视图引擎
  • Yaf_Controller_Abstract::getViewpath — The getViewpath purpose
  • Yaf_Controller_Abstract::init — 控制器初始化
  • Yaf_Controller_Abstract::initView — The initView purpose
  • Yaf_Controller_Abstract::redirect — The redirect purpose
  • Yaf_Controller_Abstract::render — 渲染视图模板
  • Yaf_Controller_Abstract::setViewpath — The setViewpath purpose


Yaf_Controller_Abstract constructor

  • ? Yaf_Controller_Abstract
  • Yaf_Controller_Abstract::display ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • Yaf_Controller_Abstract constructor

Yaf_Controller_Abstract::__construct

(Yaf >=1.0.0)

Yaf_Controller_Abstract::__construct — Yaf_Controller_Abstract constructor

说明

final private Yaf_Controller_Abstract::__construct ( )

参数

此函数没有参数。

返回值


The display purpose

  • ? Yaf_Controller_Abstract::__construct
  • Yaf_Controller_Abstract::forward ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The display purpose

Yaf_Controller_Abstract::display

(Yaf >=1.0.0)

Yaf_Controller_Abstract::display — The display purpose

说明

protected Yaf_Controller_Abstract::display ( string $tpl , array $parameters = ? ) : bool

参数

tpl

parameters

返回值


The forward purpose

  • ? Yaf_Controller_Abstract::display
  • Yaf_Controller_Abstract::getInvokeArg ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The forward purpose

Yaf_Controller_Abstract::forward

(Yaf >=1.0.0)

Yaf_Controller_Abstract::forward — The forward purpose

说明

public Yaf_Controller_Abstract::forward ( string $module , string $controller = ? , string $action = ? , array $paramters = ? ) : void

将当前的请求转交给另外的Action.

Note:

调用Yaf_Controller_Abstract::forward()以后, 不会直接立即跳转到目的Action执行, 而是会在当前的Action执行完成后, 下一轮的DispatchLoop中, 交给目的Action.

所以, 如果你希望立即跳转到目的Action, 那么请使用return结束当前的执行流程.

参数

module

要跳转的目的Action的Module, 如果是NULL, 则默认Module会被采用.

controller

要跳转的目的Action的Controller, 如果是NULL, 则默认Controller会被采用.

action

要跳转的目的Action.

paramters

跳转参数, 可以在目的Action中通过Yaf_Request_Abstrace::getParam()来获取.

范例

Example #1 Yaf_Controller_Abstract::forward()例子

<?php
class IndexController extends Yaf_Controller_Abstract
{
    public function indexAction(){
         $logined = $_SESSION["login"];
         if (!$logined) {
             $this->forward("login", array("from" => "Index")); // 跳转到login Action
             return FALSE;  // return立即结束当前的执行流程, 跳转到目的Action
                            // 而这里的FALSE是告诉Yaf不要自动渲染这个Action的视图
         }

         // other processes
    }

    public function loginAction() {
         echo "login, redirected from ", $this->_request->getParam("from") , " action";
    }
}
?>

以上例程的输出类似于：

   login, redirected from Index action

返回值

return FALSE on failure

参见

  • Yaf_Request_Abstrace::getParam()


The getInvokeArg purpose

  • ? Yaf_Controller_Abstract::forward
  • Yaf_Controller_Abstract::getInvokeArgs ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The getInvokeArg purpose

Yaf_Controller_Abstract::getInvokeArg

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getInvokeArg — The getInvokeArg purpose

说明

public Yaf_Controller_Abstract::getInvokeArg ( string $name ) : void

参数

name

返回值


The getInvokeArgs purpose

  • ? Yaf_Controller_Abstract::getInvokeArg
  • Yaf_Controller_Abstract::getModuleName ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The getInvokeArgs purpose

Yaf_Controller_Abstract::getInvokeArgs

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getInvokeArgs — The getInvokeArgs purpose

说明

public Yaf_Controller_Abstract::getInvokeArgs ( ) : void

参数

此函数没有参数。

返回值


获取当前控制器所属的模块名

  • ? Yaf_Controller_Abstract::getInvokeArgs
  • Yaf_Controller_Abstract::getName ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • 获取当前控制器所属的模块名

Yaf_Controller_Abstract::getModuleName

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getModuleName — 获取当前控制器所属的模块名

说明

public Yaf_Controller_Abstract::getModuleName ( ) : string

获取当前控制器所属的模块名

参数

此函数没有参数。

返回值


Get self name

  • ? Yaf_Controller_Abstract::getModuleName
  • Yaf_Controller_Abstract::getRequest ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • Get self name

Yaf_Controller_Abstract::getName

(Yaf >=3.2.0)

Yaf_Controller_Abstract::getName — Get self name

说明

public Yaf_Controller_Abstract::getName ( ) : string

get the controller's name

参数

此函数没有参数。

返回值

string, controller name


The getRequest purpose

  • ? Yaf_Controller_Abstract::getName
  • Yaf_Controller_Abstract::getResponse ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The getRequest purpose

Yaf_Controller_Abstract::getRequest

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getRequest — The getRequest purpose

说明

public Yaf_Controller_Abstract::getRequest ( ) : Yaf_Request_Abstract

参数

此函数没有参数。

返回值


The getResponse purpose

  • ? Yaf_Controller_Abstract::getRequest
  • Yaf_Controller_Abstract::getView ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The getResponse purpose

Yaf_Controller_Abstract::getResponse

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getResponse — The getResponse purpose

说明

public Yaf_Controller_Abstract::getResponse ( ) : Yaf_Response_Abstract

参数

此函数没有参数。

返回值


获取当前的视图引擎

  • ? Yaf_Controller_Abstract::getResponse
  • Yaf_Controller_Abstract::getViewpath ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • 获取当前的视图引擎

Yaf_Controller_Abstract::getView

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getView — 获取当前的视图引擎

说明

public Yaf_Controller_Abstract::getView ( ) : Yaf_View_Interface

获取当前的视图引擎

参数

此函数没有参数。

返回值


The getViewpath purpose

  • ? Yaf_Controller_Abstract::getView
  • Yaf_Controller_Abstract::init ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The getViewpath purpose

Yaf_Controller_Abstract::getViewpath

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getViewpath — The getViewpath purpose

说明

public Yaf_Controller_Abstract::getViewpath ( ) : void

参数

此函数没有参数。

返回值


控制器初始化

  • ? Yaf_Controller_Abstract::getViewpath
  • Yaf_Controller_Abstract::initView ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • 控制器初始化

Yaf_Controller_Abstract::init

(Yaf >=1.0.0)

Yaf_Controller_Abstract::init — 控制器初始化

说明

public Yaf_Controller_Abstract::init ( ) : void

Yaf_Controller_Abstract::__construct() 是final类型，所以用户不能重载它。但是用户可以定义 Yaf_Controller_Abstract::init()，该函数会在控制器对象实例化之后被调用。

参数

此函数没有参数。

返回值

参见

  • Yaf_Controller_Abstract::__construct() - Yaf_Controller_Abstract constructor


The initView purpose

  • ? Yaf_Controller_Abstract::init
  • Yaf_Controller_Abstract::redirect ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The initView purpose

Yaf_Controller_Abstract::initView

(Yaf >=1.0.0)

Yaf_Controller_Abstract::initView — The initView purpose

说明

public Yaf_Controller_Abstract::initView ( array $options = ? ) : void

参数

options

返回值


The redirect purpose

  • ? Yaf_Controller_Abstract::initView
  • Yaf_Controller_Abstract::render ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The redirect purpose

Yaf_Controller_Abstract::redirect

(Yaf >=1.0.0)

Yaf_Controller_Abstract::redirect — The redirect purpose

说明

public Yaf_Controller_Abstract::redirect ( string $url ) : void

参数

url

返回值


渲染视图模板

  • ? Yaf_Controller_Abstract::redirect
  • Yaf_Controller_Abstract::setViewpath ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • 渲染视图模板

Yaf_Controller_Abstract::render

(Yaf >=1.0.0)

Yaf_Controller_Abstract::render — 渲染视图模板

说明

protected Yaf_Controller_Abstract::render ( string $tpl , array $parameters = ? ) : string

参数

tpl

parameters

返回值


The setViewpath purpose

  • ? Yaf_Controller_Abstract::render
  • Yaf_Action_Abstract ?
  • PHP Manual
  • Yaf_Controller_Abstract
  • The setViewpath purpose

Yaf_Controller_Abstract::setViewpath

(Yaf >=1.0.0)

Yaf_Controller_Abstract::setViewpath — The setViewpath purpose

说明

public Yaf_Controller_Abstract::setViewpath ( string $view_directory ) : void

参数

view_directory

返回值


The Yaf_Action_Abstract class

(Yaf >=1.0.0)

简介

在Yaf中一个action可以采用单独定义Yaf_Action_Abstract来实现。 亦即，一个action方法也可以是一个Yaf_Action_Abstract的派生类

Yaf需要一个可以被它所调用的入口点（比如PHP 5.3，它有一个新的魔术方法__invoke，但是Yaf不只支持PHP 5.3+， 所以Yaf需要另一个魔术方法来执行完成这样的任务），所以在你自己的动作类里面必须要实现抽象方法 Yaf_Action_Abstract::execute()

类摘要

Yaf_Action_Abstract extends Yaf_Controller_Abstract {
/* 属性 */
protected $_controller ;
/* 方法 */
abstract publicexecute ( mixed $arg = ? , mixed $... = ? ) : mixed
publicgetController ( ) : Yaf_Controller_Abstract
public getControllerName ( ) : string
/* 继承的方法 */
final private Yaf_Controller_Abstract::__construct ( )
protected Yaf_Controller_Abstract::display ( string $tpl , array $parameters = ? ) : bool
public Yaf_Controller_Abstract::forward ( string $module , string $controller = ? , string $action = ? , array $paramters = ? ) : void
public Yaf_Controller_Abstract::getInvokeArg ( string $name ) : void
public Yaf_Controller_Abstract::getInvokeArgs ( ) : void
public Yaf_Controller_Abstract::getModuleName ( ) : string
public Yaf_Controller_Abstract::getName ( ) : string
public Yaf_Controller_Abstract::getRequest ( ) : Yaf_Request_Abstract
public Yaf_Controller_Abstract::getResponse ( ) : Yaf_Response_Abstract
public Yaf_Controller_Abstract::getView ( ) : Yaf_View_Interface
public Yaf_Controller_Abstract::getViewpath ( ) : void
public Yaf_Controller_Abstract::init ( ) : void
public Yaf_Controller_Abstract::initView ( array $options = ? ) : void
public Yaf_Controller_Abstract::redirect ( string $url ) : void
protected Yaf_Controller_Abstract::render ( string $tpl , array $parameters = ? ) : string
public Yaf_Controller_Abstract::setViewpath ( string $view_directory ) : void
}

属性

_module

_name

_request

_response

_invoke_args

_view

_controller

Table of Contents

  • Yaf_Action_Abstract::execute — 执行动作
  • Yaf_Action_Abstract::getController — 得到控制器实例
  • Yaf_Action_Abstract::getControllerName — Get controller name


执行动作

  • ? Yaf_Action_Abstract
  • Yaf_Action_Abstract::getController ?
  • PHP Manual
  • Yaf_Action_Abstract
  • 执行动作

Yaf_Action_Abstract::execute

(Yaf >=1.0.0)

Yaf_Action_Abstract::execute — 执行动作

说明

abstract publicYaf_Action_Abstract::execute ( mixed $arg = ? , mixed $... = ? ) : mixed

Yaf_Action_Abstract::execute() 可能会有参数

Note:

从请求返回的值可能是不安全的，在使用之前你需要对它们过滤一遍。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Action_Abstract::execute()example

<?php
/**
 * A controller example
 */
class ProductController extends Yaf_Controller_Abstract {
      protected $actions = array(
          "index" => "actions/Index.php",
      );
}
?>

Example #2 Yaf_Action_Abstract::execute()example

<?php
/**
 * ListAction
 */
class ListAction extends Yaf_Action_Abstract {
     public function execute ($name, $id) {
         assert($name == $this->getRequest()->getParam("name"));
         assert($id   == $this->getRequest()->getParam("id"));
     }
}
?>

以上例程的输出类似于：

/**
 * Now assuming we are using the Yaf_Route_Static route
 * for request: http://yourdomain/product/list/name/yaf/id/22
 * will result:
 */
 bool(true)
 bool(true)

参见


得到控制器实例

  • ? Yaf_Action_Abstract::execute
  • Yaf_Action_Abstract::getControllerName ?
  • PHP Manual
  • Yaf_Action_Abstract
  • 得到控制器实例

Yaf_Action_Abstract::getController

(Yaf >=1.0.0)

Yaf_Action_Abstract::getController — 得到控制器实例

说明

publicYaf_Action_Abstract::getController ( ) : Yaf_Controller_Abstract

返回控制器对象。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Get controller name

  • ? Yaf_Action_Abstract::getController
  • Yaf_View_Interface ?
  • PHP Manual
  • Yaf_Action_Abstract
  • Get controller name

Yaf_Action_Abstract::getControllerName

(No version information available, might only be in Git)

Yaf_Action_Abstract::getControllerName — Get controller name

说明

public Yaf_Action_Abstract::getControllerName ( ) : string

get the controller's name

参数

此函数没有参数。

返回值

string, controller name


The Yaf_View_Interface class

(Yaf >=1.0.0)

简介

Yaf给用户提供一个了一个可扩展的、可自定的视图引擎接口，用户可以使用自己的视图引擎来代替Yaf内置的Yaf_View_Simple。下面是一个关于怎么实现的例子，请看Yaf_Dispatcher::setView()。

类摘要

Yaf_View_Interface {
/* 方法 */
abstract public assign ( string $name , string $value = ? ) : bool
abstract public display ( string $tpl , array $tpl_vars = ? ) : bool
abstract public getScriptPath ( ) : void
abstract public render ( string $tpl , array $tpl_vars = ? ) : string
abstract public setScriptPath ( string $template_dir ) : void
}

Table of Contents

  • Yaf_View_Interface::assign — 为视图引擎分配一个模板变量
  • Yaf_View_Interface::display — 渲染一个视图模板, 并直接输出给请求端
  • Yaf_View_Interface::getScriptPath — The getScriptPath purpose
  • Yaf_View_Interface::render — 渲染一个视图模板
  • Yaf_View_Interface::setScriptPath — The setScriptPath purpose


为视图引擎分配一个模板变量

  • ? Yaf_View_Interface
  • Yaf_View_Interface::display ?
  • PHP Manual
  • Yaf_View_Interface
  • 为视图引擎分配一个模板变量

Yaf_View_Interface::assign

(Yaf >=1.0.0)

Yaf_View_Interface::assign — 为视图引擎分配一个模板变量

说明

abstract public Yaf_View_Interface::assign ( string $name , string $value = ? ) : bool

为视图引擎分配一个模板变量, 在视图模板中可以直接通过${$name}获取模板变量值

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值


渲染一个视图模板, 并直接输出给请求端

  • ? Yaf_View_Interface::assign
  • Yaf_View_Interface::getScriptPath ?
  • PHP Manual
  • Yaf_View_Interface
  • 渲染一个视图模板, 并直接输出给请求端

Yaf_View_Interface::display

(Yaf >=1.0.0)

Yaf_View_Interface::display — 渲染一个视图模板, 并直接输出给请求端

说明

abstract public Yaf_View_Interface::display ( string $tpl , array $tpl_vars = ? ) : bool

渲染一个视图模板, 并直接输出给请求端

Warning

本函数还未编写文档，仅有参数列表。

参数

tpl

tpl_vars

返回值


The getScriptPath purpose

  • ? Yaf_View_Interface::display
  • Yaf_View_Interface::render ?
  • PHP Manual
  • Yaf_View_Interface
  • The getScriptPath purpose

Yaf_View_Interface::getScriptPath

(Yaf >=1.0.0)

Yaf_View_Interface::getScriptPath — The getScriptPath purpose

说明

abstract public Yaf_View_Interface::getScriptPath ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


渲染一个视图模板

  • ? Yaf_View_Interface::getScriptPath
  • Yaf_View_Interface::setScriptPath ?
  • PHP Manual
  • Yaf_View_Interface
  • 渲染一个视图模板

Yaf_View_Interface::render

(Yaf >=1.0.0)

Yaf_View_Interface::render — 渲染一个视图模板

说明

abstract public Yaf_View_Interface::render ( string $tpl , array $tpl_vars = ? ) : string

渲染一个视图模板, 得到结果

Warning

本函数还未编写文档，仅有参数列表。

参数

tpl

tpl_vars

返回值


The setScriptPath purpose

  • ? Yaf_View_Interface::render
  • Yaf_View_Simple ?
  • PHP Manual
  • Yaf_View_Interface
  • The setScriptPath purpose

Yaf_View_Interface::setScriptPath

(Yaf >=1.0.0)

Yaf_View_Interface::setScriptPath — The setScriptPath purpose

说明

abstract public Yaf_View_Interface::setScriptPath ( string $template_dir ) : void

设置模板的基目录，这通常通过Yaf_Dispatcher调用。

Warning

本函数还未编写文档，仅有参数列表。

参数

template_dir

模板目录的绝对路径，默认的Yaf_Dispatcher会设置此目录为application.directory . "/views".

返回值


The Yaf_View_Simple Class

(Yaf >=1.0.0)

简介

Yaf_View_Simple 这是Yaf内建的一个模板引擎，是个简单而快速的模板引擎，只支持PHP脚本

类摘要

Yaf_View_Simple implements Yaf_View_Interface {
/* 属性 */
protected $_tpl_vars ;
protected $_tpl_dir ;
/* 方法 */
public assign ( string $name , mixed $value = ? ) : bool
public assignRef ( string $name , mixed &$value ) : bool
public clear ( string $name = ? ) : bool
final public __construct ( string $tempalte_dir , array $options = ? )
public display ( string $tpl , array $tpl_vars = ? ) : bool
public eval ( string $tpl_content , array $tpl_vars = ? ) : string
public __get ( string $name = ? ) : void
public getScriptPath ( ) : string
public __isset ( string $name ) : void
public render ( string $tpl , array $tpl_vars = ? ) : string
public __set ( string $name , mixed $value ) : void
public setScriptPath ( string $template_dir ) : bool
}

属性

_tpl_vars

_tpl_dir

Table of Contents

  • Yaf_View_Simple::assign — 为视图引擎分配一个模板变量
  • Yaf_View_Simple::assignRef — The assignRef purpose
  • Yaf_View_Simple::clear — Clear Assigned values
  • Yaf_View_Simple::__construct — Constructor of Yaf_View_Simple
  • Yaf_View_Simple::display — 渲染一个视图模板, 并直接输出给请求端
  • Yaf_View_Simple::eval — 渲染模板
  • Yaf_View_Simple::__get — 获取视图引擎的一个模板变量值
  • Yaf_View_Simple::getScriptPath — 获取模板目录
  • Yaf_View_Simple::__isset — The __isset purpose
  • Yaf_View_Simple::render — 渲染模板
  • Yaf_View_Simple::__set — 为视图引擎分配一个模板变量
  • Yaf_View_Simple::setScriptPath — 设置模板的目录


为视图引擎分配一个模板变量

  • ? Yaf_View_Simple
  • Yaf_View_Simple::assignRef ?
  • PHP Manual
  • Yaf_View_Simple
  • 为视图引擎分配一个模板变量

Yaf_View_Simple::assign

(Yaf >=1.0.0)

Yaf_View_Simple::assign — 为视图引擎分配一个模板变量

说明

public Yaf_View_Simple::assign ( string $name , mixed $value = ? ) : bool

为视图引擎分配一个模板变量

参数

name

字符串或者数组

如果为字符串, 则$value不能为空

value

mixed value

返回值

范例

Example #1 Yaf_View_Simple::assign()example

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->assign("foo", "bar");
        $this->_view->assign( array( "key" => "value", "name" => "value"));
    }
?>

Example #2 template()example

<html>
 <head>
  <title><?php echo $foo; ?></title>
 </head>
<body>
  <?php
    foreach ($this->_tpl_vars as $name => value) {
         echo $$name; // or echo $this->_tpl_vars[$name];
    }
  ?>
</body>
</html>

参见

  • Yaf_View_Simple::assignRef() - The assignRef purpose
  • Yaf_View_Interface::clear()
  • Yaf_View_Simple::__set() - 为视图引擎分配一个模板变量


The assignRef purpose

  • ? Yaf_View_Simple::assign
  • Yaf_View_Simple::clear ?
  • PHP Manual
  • Yaf_View_Simple
  • The assignRef purpose

Yaf_View_Simple::assignRef

(Yaf >=1.0.0)

Yaf_View_Simple::assignRef — The assignRef purpose

说明

public Yaf_View_Simple::assignRef ( string $name , mixed &$value ) : bool

不同于Yaf_View_Simple::assign()，这个方法传递一个引用变量给模板引擎

参数

name

一个字符串的名字，被用来传递值给模板。

value

mixed value

返回值

范例

Example #1 Yaf_View_Simple::assignRef()example

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $value = "bar";
        $this->getView()->assign("foo", $value);

        /* plz note that there was a bug before Yaf 2.1.4,
         * which make following output "bar";
         */
        $dummy = $this->getView()->render("index/index.phtml");
        echo $value;

        //prevent the auto-render
        Yaf_Dispatcher::getInstance()->autoRender(FALSE);
    }
?>

Example #2 template()example

<html>
 <head>
  <title><?php echo $foo;  $foo = "changed"; ?></title>
 </head>
<body>
</body>
</html>

以上例程的输出类似于：

/* access the index controller will result: */
changed

参见

  • Yaf_View_Simple::assign() - 为视图引擎分配一个模板变量
  • Yaf_View_Simple::__set() - 为视图引擎分配一个模板变量


Clear Assigned values

  • ? Yaf_View_Simple::assignRef
  • Yaf_View_Simple::__construct ?
  • PHP Manual
  • Yaf_View_Simple
  • Clear Assigned values

Yaf_View_Simple::clear

(Yaf >=2.2.0)

Yaf_View_Simple::clear — Clear Assigned values

说明

public Yaf_View_Simple::clear ( string $name = ? ) : bool

清除指定的变量

参数

name

分派的变量名

如果为空，将会清除所有的变量

返回值

范例

Example #1 Yaf_View_Simple::clear()example

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->clear("foo")->clear("bar"); // clear "foo" and "bar"
        $this->_view->clear(); //clear all assigned variables
    }
?>

参见

  • Yaf_View_Simple::assignRef() - The assignRef purpose
  • Yaf_View_Interface::assign() - 为视图引擎分配一个模板变量
  • Yaf_View_Simple::__set() - 为视图引擎分配一个模板变量


Constructor of Yaf_View_Simple

  • ? Yaf_View_Simple::clear
  • Yaf_View_Simple::display ?
  • PHP Manual
  • Yaf_View_Simple
  • Constructor of Yaf_View_Simple

Yaf_View_Simple::__construct

(Yaf >=1.0.0)

Yaf_View_Simple::__construct — Constructor of Yaf_View_Simple

说明

final public Yaf_View_Simple::__construct ( string $tempalte_dir , array $options = ? )

参数

tempalte_dir

模板的基本路劲，默认为APPLICATOIN . "/views"

options

Options for the engine, as of Yaf 2.1.13, you can use short tag
      "<?=$var?>" in your template(regardless of "short_open_tag"),
      so comes a option named "short_tag",  you can switch this off
      to prevent use short_tag in template.

范例

Example #1 Yaf_View_Simple::__constructor()example

<?php
   define ("TEMPLATE_DIRECTORY", APPLICATOIN_PATH . '/views');
   $view = new Yaf_View_Simple(TEMPLATE_DIRECTORY, array(
                           'short_tag' => false //doesn't allow use short tag in template
   ));
?>

返回值


渲染一个视图模板, 并直接输出给请求端

  • ? Yaf_View_Simple::__construct
  • Yaf_View_Simple::eval ?
  • PHP Manual
  • Yaf_View_Simple
  • 渲染一个视图模板, 并直接输出给请求端

Yaf_View_Simple::display

(Yaf >=1.0.0)

Yaf_View_Simple::display — 渲染一个视图模板, 并直接输出给请求端

说明

public Yaf_View_Simple::display ( string $tpl , array $tpl_vars = ? ) : bool

渲染一个视图模板, 并直接输出给请求端

参数

tpl

tpl_vars

返回值


渲染模板

  • ? Yaf_View_Simple::display
  • Yaf_View_Simple::__get ?
  • PHP Manual
  • Yaf_View_Simple
  • 渲染模板

Yaf_View_Simple::eval

(Yaf >=2.2.0)

Yaf_View_Simple::eval — 渲染模板

说明

public Yaf_View_Simple::eval ( string $tpl_content , array $tpl_vars = ? ) : string

渲染一个字符串模板，然后返回结果。

参数

tpl_content

string template

tpl_vars

返回值


获取视图引擎的一个模板变量值

  • ? Yaf_View_Simple::eval
  • Yaf_View_Simple::getScriptPath ?
  • PHP Manual
  • Yaf_View_Simple
  • 获取视图引擎的一个模板变量值

Yaf_View_Simple::__get

(Yaf >=1.0.0)

Yaf_View_Simple::__get — 获取视图引擎的一个模板变量值

说明

public Yaf_View_Simple::__get ( string $name = ? ) : void

获取视图引擎的一个模板变量值

Note:

从2.1.11以后，参数可以为空

参数

name

分配的变量名

如果为空，所有传递的变量都会被返回

返回值


获取模板目录

  • ? Yaf_View_Simple::__get
  • Yaf_View_Simple::__isset ?
  • PHP Manual
  • Yaf_View_Simple
  • 获取模板目录

Yaf_View_Simple::getScriptPath

(Yaf >=1.0.0)

Yaf_View_Simple::getScriptPath — 获取模板目录

说明

public Yaf_View_Simple::getScriptPath ( ) : string

参数

此函数没有参数。

返回值


The __isset purpose

  • ? Yaf_View_Simple::getScriptPath
  • Yaf_View_Simple::render ?
  • PHP Manual
  • Yaf_View_Simple
  • The __isset purpose

Yaf_View_Simple::__isset

(Yaf >=1.0.0)

Yaf_View_Simple::__isset — The __isset purpose

说明

public Yaf_View_Simple::__isset ( string $name ) : void

参数

name

返回值


渲染模板

  • ? Yaf_View_Simple::__isset
  • Yaf_View_Simple::__set ?
  • PHP Manual
  • Yaf_View_Simple
  • 渲染模板

Yaf_View_Simple::render

(Yaf >=1.0.0)

Yaf_View_Simple::render — 渲染模板

说明

public Yaf_View_Simple::render ( string $tpl , array $tpl_vars = ? ) : string

渲染一个视图模板, 得到结果

参数

tpl

tpl_vars

返回值


为视图引擎分配一个模板变量

  • ? Yaf_View_Simple::render
  • Yaf_View_Simple::setScriptPath ?
  • PHP Manual
  • Yaf_View_Simple
  • 为视图引擎分配一个模板变量

Yaf_View_Simple::__set

(Yaf >=1.0.0)

Yaf_View_Simple::__set — 为视图引擎分配一个模板变量

说明

public Yaf_View_Simple::__set ( string $name , mixed $value ) : void

这是一个更简单并且用来替代 Yaf_View_Simple::assign() 的方法

参数

name

一个字符串值的名字

value

Mixed value.

返回值

范例

Example #1 Yaf_View_Simple::__set()example

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->foo = "bar"; // same as assign("foo", "bar");
    }
?>

参见

  • Yaf_View_Simple::assignRef() - The assignRef purpose
  • Yaf_View_Interface::assign() - 为视图引擎分配一个模板变量


设置模板的目录

  • ? Yaf_View_Simple::__set
  • Yaf_Loader ?
  • PHP Manual
  • Yaf_View_Simple
  • 设置模板的目录

Yaf_View_Simple::setScriptPath

(Yaf >=1.0.0)

Yaf_View_Simple::setScriptPath — 设置模板的目录

说明

public Yaf_View_Simple::setScriptPath ( string $template_dir ) : bool

参数

template_dir

返回值


The Yaf_Loader class

(Yaf >=1.0.0)

简介

Yaf_Loader 类为Yaf提供了自动加载功能的全面解决方案。

在第一次使用的时候，将检索 Yaf_Application 的实例， Yaf_Loader 实现了单利模式，并使用spl_autoload注册它自己。 通过 Yaf_Loader::getInstance() 返回它的实例

Yaf_Loader 加载一个类时仅仅尝试一次，如果失败了， 后面的操作将取决于yaf.use_spl_auload， 如果这个配置项为On，Yaf_Loader::autoload() 将会返回FALSE， 从而把机会让给其他的自动加载功能。如果这个配置项为Off（默认）， Yaf_Loader::autoload() 将会返回TRUE， 最重要的是将会抛出一个非常有用的警告（对于找出一个类加载失败非常有用）。

Note:

请保持yaf.use_spl_autoload保持关闭，除非有一些library有自己的autoload机制，并且是无法改写的。

默认情况下，Yaf_Loader 收集所有library(类定义的脚本)储存进在 php.ini(yaf.library)定义的global library directory之中。

如果你想使用 Yaf_Loader 搜索本地类（库）（定义在application.ini， 默认情况下，它是 application.directory . "/libraray"）， 你需要使用 Yaf_Loader::registerLocalNameSpace() 注册本地类前缀。

让我们来看看一些例子（假设 APPLICATION_PATH 是 application.directory）：

Example #1 Config example

// Assuming the following configure in php.ini:
yaf.libraray = "/global_dir"

//Assuming the following configure in application.ini
application.libraray = APPLICATION_PATH "/library"
假设以下本地名称空间已被注册：

Example #2 注册本地命名空间

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
     public function _initLoader($dispatcher) {
          Yaf_Loader::getInstance()->registerLocalNameSpace(array("Foo", "Bar"));
     }
?>
自动加载例子：

Example #3 加载类

class Foo_Bar_Test =>
  // APPLICATION_PATH/library/Foo/Bar/Test.php

class GLO_Name  =>
  // /global_dir/Glo/Name.php

class BarNon_Test
  // /global_dir/Barnon/Test.php
在PHP 5.3中，你可以使用命名空间：

Example #4 加载命名空间类

class \Foo\Bar\Dummy =>
   // APPLICATION_PATH/library/Foo/Bar/Dummy.php

class \FooBar\Bar\Dummy =>
   // /global_dir/FooBar/Bar/Dummy.php

你可能会注意到所有文件夹名字的首字母是大写的，你可以通过在php.ini中设置 yaf.lowcase_path = On 来将它们小写。

Yaf_Loader 也是设计来加载MVC类，响应的规则如下：

Example #5 MVC类加载例子

Controller Classes =>
// APPLICATION_PATH/controllers/

Model Classes =>
// APPLICATION_PATH/models/

Plugin Classes =>
// APPLICATION_PATH/plugins/
Yaf 通过识别一个类的后缀（这个是默认的，你也可以通过改变配置项 yaf.name_suffix 来将它改为通过前缀识别）来决定它是否是一个MVC类：

Example #6 MVC 类区别

Controller Classes =>
    // ***Controller

Model Classes =>
    // ***Model

Plugin Classes =>
    // ***Plugin
some examples:

Example #7 MVC loading example

class IndexController
    // APPLICATION_PATH/controllers/Index.php

class DataModel =>
   // APPLICATION_PATH/models/Data.php

class DummyPlugin =>
  // APPLICATION_PATH/plugins/Dummy.php

class A_B_TestModel =>
  // APPLICATION_PATH/models/A/B/Test.php
该目录将受 yaf.lowcase_path 的影响。

类摘要

Yaf_Loader {
/* 属性 */
protected $_local_ns ;
protected $_library ;
protected $_global_library ;
static $_instance ;
/* 方法 */
public autoload ( ) : void
public clearLocalNamespace ( ) : void
private__construct ( )
public static getInstance ( ) : void
public getLibraryPath ( bool $is_global = false ) : Yaf_Loader
public getLocalNamespace ( ) : void
public getNamespacePath ( string $namespaces ) : string
public getNamespaces ( ) : array
public static import ( ) : void
public isLocalName ( ) : void
public registerLocalNamespace ( mixed $prefix = ? ) : void
public registerNamespace ( string|array $namespaces , string $path = ? ) : bool
public setLibraryPath ( string $directory , bool $is_global = false ) : Yaf_Loader
}

属性

_local_ns

_library

默认情况下，它的值是 application.directory . "/library"， 你可以通过修改application.ini(application.library)或者调用 Yaf_Loader::setLibraryPath() 改变它。

_global_library

_instance

Table of Contents

  • Yaf_Loader::autoload — The autoload purpose
  • Yaf_Loader::clearLocalNamespace — The clearLocalNamespace purpose
  • Yaf_Loader::__construct — The __construct purpose
  • Yaf_Loader::getInstance — The getInstance purpose
  • Yaf_Loader::getLibraryPath — get the library path
  • Yaf_Loader::getLocalNamespace — The getLocalNamespace purpose
  • Yaf_Loader::getNamespacePath — Retieve path of a registered namespace
  • Yaf_Loader::getLocalNamespace — Retrive all register namespaces info
  • Yaf_Loader::import — The import purpose
  • Yaf_Loader::isLocalName — The isLocalName purpose
  • Yaf_Loader::registerLocalNamespace — 注册本地类前缀
  • Yaf_Loader::registerNamespace — Register namespace with searching path
  • Yaf_Loader::setLibraryPath — 改变library路径


The autoload purpose

  • ? Yaf_Loader
  • Yaf_Loader::clearLocalNamespace ?
  • PHP Manual
  • Yaf_Loader
  • The autoload purpose

Yaf_Loader::autoload

(Yaf >=1.0.0)

Yaf_Loader::autoload — The autoload purpose

说明

public Yaf_Loader::autoload ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The clearLocalNamespace purpose

  • ? Yaf_Loader::autoload
  • Yaf_Loader::__construct ?
  • PHP Manual
  • Yaf_Loader
  • The clearLocalNamespace purpose

Yaf_Loader::clearLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::clearLocalNamespace — The clearLocalNamespace purpose

说明

public Yaf_Loader::clearLocalNamespace ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The __construct purpose

  • ? Yaf_Loader::clearLocalNamespace
  • Yaf_Loader::getInstance ?
  • PHP Manual
  • Yaf_Loader
  • The __construct purpose

Yaf_Loader::__construct

(Yaf >=1.0.0)

Yaf_Loader::__construct — The __construct purpose

说明

privateYaf_Loader::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getInstance purpose

  • ? Yaf_Loader::__construct
  • Yaf_Loader::getLibraryPath ?
  • PHP Manual
  • Yaf_Loader
  • The getInstance purpose

Yaf_Loader::getInstance

(Yaf >=1.0.0)

Yaf_Loader::getInstance — The getInstance purpose

说明

public static Yaf_Loader::getInstance ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


get the library path

  • ? Yaf_Loader::getInstance
  • Yaf_Loader::getLocalNamespace ?
  • PHP Manual
  • Yaf_Loader
  • get the library path

Yaf_Loader::getLibraryPath

(Yaf >=2.1.4)

Yaf_Loader::getLibraryPath — get the library path

说明

public Yaf_Loader::getLibraryPath ( bool $is_global = false ) : Yaf_Loader

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getLocalNamespace purpose

  • ? Yaf_Loader::getLibraryPath
  • Yaf_Loader::getNamespacePath ?
  • PHP Manual
  • Yaf_Loader
  • The getLocalNamespace purpose

Yaf_Loader::getLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::getLocalNamespace — The getLocalNamespace purpose

说明

public Yaf_Loader::getLocalNamespace ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Retieve path of a registered namespace

  • ? Yaf_Loader::getLocalNamespace
  • Yaf_Loader::getLocalNamespace ?
  • PHP Manual
  • Yaf_Loader
  • Retieve path of a registered namespace

Yaf_Loader::getNamespacePath

(Yaf >=3.2.0)

Yaf_Loader::getNamespacePath — Retieve path of a registered namespace

说明

public Yaf_Loader::getNamespacePath ( string $namespaces ) : string

retrieve path of a registered namespace

参数

namespace

a string of namespace.

返回值

string path, if the namespace is not registered, then null default library will be returned

范例

Example #1 Yaf_Loader::registerNamespace()example

<?php
$loader = Yaf_Loader::getInstance("/var/application/lib");
$loader->registerNamespace("\Vendor\PHP", "/var/lib/php");

$loader->getNamespacePath("\Vendor\PHP"); // '/var/lib/php'
$loader->getNamespacePath("\Vendor\JSP"); // '/var/application/lib'

?>


Retrive all register namespaces info

  • ? Yaf_Loader::getNamespacePath
  • Yaf_Loader::import ?
  • PHP Manual
  • Yaf_Loader
  • Retrive all register namespaces info

Yaf_Loader::getLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::getLocalNamespace — Retrive all register namespaces info

说明

public Yaf_Loader::getNamespaces ( ) : array

get registered namespaces info

参数

此函数没有参数。

返回值

array


The import purpose

  • ? Yaf_Loader::getLocalNamespace
  • Yaf_Loader::isLocalName ?
  • PHP Manual
  • Yaf_Loader
  • The import purpose

Yaf_Loader::import

(Yaf >=1.0.0)

Yaf_Loader::import — The import purpose

说明

public static Yaf_Loader::import ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isLocalName purpose

  • ? Yaf_Loader::import
  • Yaf_Loader::registerLocalNamespace ?
  • PHP Manual
  • Yaf_Loader
  • The isLocalName purpose

Yaf_Loader::isLocalName

(Yaf >=1.0.0)

Yaf_Loader::isLocalName — The isLocalName purpose

说明

public Yaf_Loader::isLocalName ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


注册本地类前缀

  • ? Yaf_Loader::isLocalName
  • Yaf_Loader::registerNamespace ?
  • PHP Manual
  • Yaf_Loader
  • 注册本地类前缀

Yaf_Loader::registerLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::registerLocalNamespace — 注册本地类前缀

说明

public Yaf_Loader::registerLocalNamespace ( mixed $prefix = ? ) : void

register local class prefix

参数

prefix

字符串或者是数组格式的类名前缀，所有拥有和这些前缀相同前缀的类将被加载到本地library路径。

返回值

bool

范例

Example #1 Yaf_Loader::registerLocalNamespace()example

<?php
$loader = Yaf_Loader::getInstance('/local/library/', '/global/library');
$loader->registerLocalNamespace("Baidu");
$loader->registerLocalNamespace(array("Sina", "Weibo");

$loader->autoload("Baidu_Name"); // search in '/local/library/'
$loader->autoload("Sina");       // search '/local/library/'
$loader->autoload("Global_Name");// search in '/global/library/'
$loader->autoload("Foo_Bar");    // search in '/global/library/'

?>


Register namespace with searching path

  • ? Yaf_Loader::registerLocalNamespace
  • Yaf_Loader::setLibraryPath ?
  • PHP Manual
  • Yaf_Loader
  • Register namespace with searching path

Yaf_Loader::registerNamespace

(Yaf >=3.2.0)

Yaf_Loader::registerNamespace — Register namespace with searching path

说明

public Yaf_Loader::registerNamespace ( string|array $namespaces , string $path = ? ) : bool

Register a namespace with searching path, Yaf_Loader searchs classes under this namespace in path, the one is also could be configureded via application.library.directory.namespace(in application.ini);

Note:

Yaf still think underline as folder separator.

参数

namespace

a string of namespace, or a array of namespaces with paths.

path

a string of path, it it better to use abosolute path here for performance

返回值

bool

范例

Example #1 Yaf_Loader::registerNamespace()example

<?php
$loader = Yaf_Loader::getInstance();
$loader->registerNamespace("\Vendor\PHP", "/var/lib/php");
$loader->registerNamespace(array(
     "\Vendor\ASP" => "/var/lib/asp",
     "\Vendor\JSP" => "/usr/lib/vendor/",
));

$loader->autoload("\Vendor\PHP\Dummy");   //load '/var/lib/php/Dummy.php'
$loader->autoload("\Vendor\PHP\Foo_Bar"); //load '/var/lib/php/Foo/Bar.php'
$loader->autoload("\Vendor\JSP\Dummy");   //load '/usr/lib/vendor/Dummy.php'

?>


改变library路径

  • ? Yaf_Loader::registerNamespace
  • Yaf_Plugin_Abstract ?
  • PHP Manual
  • Yaf_Loader
  • 改变library路径

Yaf_Loader::setLibraryPath

(Yaf >=2.1.4)

Yaf_Loader::setLibraryPath — 改变library路径

说明

public Yaf_Loader::setLibraryPath ( string $directory , bool $is_global = false ) : Yaf_Loader

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Plugin_Abstract class

(Yaf >=1.0.0)

简介

Plugins 可以让你轻松地定制和扩展框架

插件(Plugins)是一个类。 基于组件定义的类会有所变化 -- 你可能需要去实现这些接口。 但实际上，该插件(Plugin)本身就是一个类。

一个插件(plugin)会被Yaf_Dispatcher::registerPlugin()加载到Yaf框架中， 在框架注册(registerd)后，插件(plugin)类中定义方法将会在恰当的时间被该接口执行。

范例

Example #1 Plugin example

<?php
   /* bootstrap class should be defined under ./application/Bootstrap.php */
   class Bootstrap extends Yaf_Bootstrap_Abstract {
        public function _initPlugin(Yaf_Dispatcher $dispatcher) {
            /* register a plugin */
            $dispatcher->registerPlugin(new TestPlugin());
        }
   }

   /* plugin class should be placed under ./application/plugins/ */
   class TestPlugin extends Yaf_Plugin_Abstract {
        public function routerStartup(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            /* 在路由之前执行,这个钩子里，你可以做url重写等功能 */
            var_dump("routerStartup");
        }
        public function routerShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
           /* 路由完成后，在这个钩子里，你可以做登陆检测等功能*/
            var_dump("routerShutdown");
        }
        public function dispatchLoopStartup(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("dispatchLoopStartup");
        }
        public function preDispatch(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("preDispatch");
        }
        public function postDispatch(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("postDispatch");
        }
        public function dispatchLoopShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            /* final hoook
               in this hook user can do loging or implement layout */
            var_dump("dispatchLoopShutdown");
        }
   }

   Class IndexController extends Yaf_Controller_Abstract {
        public function indexAction() {
            return FALSE; //prevent rendering
        }
   }

   $config = array(
       "application" => array(
           "directory" => dirname(__FILE__) . "/application/",
       ),
   );

   $app = new Yaf_Application($config);
   $app->bootstrap()->run();
?>

以上例程的输出类似于：

string(13) "routerStartup"
string(14) "routerShutdown"
string(19) "dispatchLoopStartup"
string(11) "preDispatch"
string(12) "postDispatch"
string(20) "dispatchLoopShutdown"

类摘要

Yaf_Plugin_Abstract {
/* 方法 */
public dispatchLoopShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public dispatchLoopStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public postDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public preDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public preResponse ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public routerShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
public routerStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void
}

Table of Contents

  • Yaf_Plugin_Abstract::dispatchLoopShutdown — The dispatchLoopShutdown purpose
  • Yaf_Plugin_Abstract::dispatchLoopStartup — The dispatchLoopStartup purpose
  • Yaf_Plugin_Abstract::postDispatch — The postDispatch purpose
  • Yaf_Plugin_Abstract::preDispatch — The preDispatch purpose
  • Yaf_Plugin_Abstract::preResponse — The preResponse purpose
  • Yaf_Plugin_Abstract::routerShutdown — The routerShutdown purpose
  • Yaf_Plugin_Abstract::routerStartup — RouterStartup hook


The dispatchLoopShutdown purpose

  • ? Yaf_Plugin_Abstract
  • Yaf_Plugin_Abstract::dispatchLoopStartup ?
  • PHP Manual
  • Yaf_Plugin_Abstract
  • The dispatchLoopShutdown purpose

Yaf_Plugin_Abstract::dispatchLoopShutdown

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::dispatchLoopShutdown — The dispatchLoopShutdown purpose

说明

public Yaf_Plugin_Abstract::dispatchLoopShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

这个方式是Yaf插件钩子系统中最后的一个钩子，如果一个用户插件实现了这个方法，它将在分发循环结束之后触发。

Warning

本函数还未编写文档，仅有参数列表。

参数

request

response

返回值

参见

  • Yaf_Plugin_Abstract::routerStartup() - RouterStartup hook
  • Yaf_Plugin_Abstract::routerShutdown() - The routerShutdown purpose
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - The dispatchLoopStartup purpose
  • Yaf_Plugin_Abstract::preDispatch() - The preDispatch purpose
  • Yaf_Plugin_Abstract::postDispatch() - The postDispatch purpose


The dispatchLoopStartup purpose

  • ? Yaf_Plugin_Abstract::dispatchLoopShutdown
  • Yaf_Plugin_Abstract::postDispatch ?
  • PHP Manual
  • Yaf_Plugin_Abstract
  • The dispatchLoopStartup purpose

Yaf_Plugin_Abstract::dispatchLoopStartup

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::dispatchLoopStartup — The dispatchLoopStartup purpose

说明

public Yaf_Plugin_Abstract::dispatchLoopStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

这个钩子将在分发循环开始之前触发。

Warning

本函数还未编写文档，仅有参数列表。

参数

request

response

返回值


The postDispatch purpose

  • ? Yaf_Plugin_Abstract::dispatchLoopStartup
  • Yaf_Plugin_Abstract::preDispatch ?
  • PHP Manual
  • Yaf_Plugin_Abstract
  • The postDispatch purpose

Yaf_Plugin_Abstract::postDispatch

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::postDispatch — The postDispatch purpose

说明

public Yaf_Plugin_Abstract::postDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

request

response

返回值


The preDispatch purpose

  • ? Yaf_Plugin_Abstract::postDispatch
  • Yaf_Plugin_Abstract::preResponse ?
  • PHP Manual
  • Yaf_Plugin_Abstract
  • The preDispatch purpose

Yaf_Plugin_Abstract::preDispatch

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::preDispatch — The preDispatch purpose

说明

public Yaf_Plugin_Abstract::preDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

request

response

返回值


The preResponse purpose

  • ? Yaf_Plugin_Abstract::preDispatch
  • Yaf_Plugin_Abstract::routerShutdown ?
  • PHP Manual
  • Yaf_Plugin_Abstract
  • The preResponse purpose

Yaf_Plugin_Abstract::preResponse

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::preResponse — The preResponse purpose

说明

public Yaf_Plugin_Abstract::preResponse ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

这个钩子在响应(Yaf_Response)前被触发

Warning

本函数还未编写文档，仅有参数列表。

参数

request

response

返回值


The routerShutdown purpose

  • ? Yaf_Plugin_Abstract::preResponse
  • Yaf_Plugin_Abstract::routerStartup ?
  • PHP Manual
  • Yaf_Plugin_Abstract
  • The routerShutdown purpose

Yaf_Plugin_Abstract::routerShutdown

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::routerShutdown — The routerShutdown purpose

说明

public Yaf_Plugin_Abstract::routerShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

这个钩子在路由结束之后触发，通常被用于登陆检查。

参数

request

response

返回值

范例

Example #1 Yaf_Plugin_Abstract::routerShutdown()example

<?php
class UserInitPlugin extends Yaf_Plugin_Abstract {

    public function routerShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
        $controller = $request->getControllerName();

        /**
         * Use access controller is unecessary for APIs
         */
        if (in_array(strtolower($controller), array(
            'api',
        ))) {
            return TRUE;
        }

        if (Yaf_Session::getInstance()->has("login")) {
            return TRUE;
        }

        /* Use access check failed, need to login */
        $response->setRedirect("http://yourdomain.com/login/");
        return FALSE;
    }
?>

参见

  • Yaf_Plugin_Abstract::routerStartup() - RouterStartup hook
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - The dispatchLoopStartup purpose
  • Yaf_Plugin_Abstract::preDispatch() - The preDispatch purpose
  • Yaf_Plugin_Abstract::postDispatch() - The postDispatch purpose
  • Yaf_Plugin_Abstract::dispatchLoopShutdown() - The dispatchLoopShutdown purpose


RouterStartup hook

  • ? Yaf_Plugin_Abstract::routerShutdown
  • Yaf_Registry ?
  • PHP Manual
  • Yaf_Plugin_Abstract
  • RouterStartup hook

Yaf_Plugin_Abstract::routerStartup

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::routerStartup — RouterStartup hook

说明

public Yaf_Plugin_Abstract::routerStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response ) : void

这个是Yaf插件的勾子系统最早被触发的的一个方法，如果一个用户插件实现了这个方法，它将在路由之前触发。

Warning

本函数还未编写文档，仅有参数列表。

参数

request

response

返回值

参见

  • Yaf_Plugin_Abstract::routerShutdown() - The routerShutdown purpose
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - The dispatchLoopStartup purpose
  • Yaf_Plugin_Abstract::preDispatch() - The preDispatch purpose
  • Yaf_Plugin_Abstract::postDispatch() - The postDispatch purpose
  • Yaf_Plugin_Abstract::dispatchLoopShutdown() - The dispatchLoopShutdown purpose


The Yaf_Registry class

(Yaf >=1.0.0)

简介

Yaf_Registry, 对象注册表(或称对象仓库)是一个用于在整个应用空间(application space)内存储对象和值的容器. 通过把对象存储在其中,我们可以在整个项目的任何地方使用同一个对象.这种机制相当于一种全局存储. 我们可以通过Yaf_Registry类的静态方法来使用对象注册表. 另外,由于该类是一个数组对象,你可以使用数组形式来访问其中的类方法

类摘要

Yaf_Registry {
/* 属性 */
static $_instance ;
protected $_entries ;
/* 方法 */
__construct ( )
public static del ( string $name ) : void
public static get ( string $name ) : mixed
public static has ( string $name ) : bool
public static set ( string $name , string $value ) : bool
}

属性

_instance

_entries

Table of Contents

  • Yaf_Registry::__construct — Yaf_Registry implements singleton
  • Yaf_Registry::del — Remove an item from registry
  • Yaf_Registry::get — Retrieve an item from registry
  • Yaf_Registry::has — Check whether an item exists
  • Yaf_Registry::set — Add an item into registry


Yaf_Registry implements singleton

  • ? Yaf_Registry
  • Yaf_Registry::del ?
  • PHP Manual
  • Yaf_Registry
  • Yaf_Registry implements singleton

Yaf_Registry::__construct

(Yaf >=1.0.0)

Yaf_Registry::__construct — Yaf_Registry implements singleton

说明

Yaf_Registry::__construct ( )

参数

此函数没有参数。

返回值


Remove an item from registry

  • ? Yaf_Registry::__construct
  • Yaf_Registry::get ?
  • PHP Manual
  • Yaf_Registry
  • Remove an item from registry

Yaf_Registry::del

(Yaf >=1.0.0)

Yaf_Registry::del — Remove an item from registry

说明

public static Yaf_Registry::del ( string $name ) : void

删除存在于注册表中的一个项目

参数

name

返回值


Retrieve an item from registry

  • ? Yaf_Registry::del
  • Yaf_Registry::has ?
  • PHP Manual
  • Yaf_Registry
  • Retrieve an item from registry

Yaf_Registry::get

(Yaf >=1.0.0)

Yaf_Registry::get — Retrieve an item from registry

说明

public static Yaf_Registry::get ( string $name ) : mixed

获取注册表中寄存的项

参数

name

返回值


Check whether an item exists

  • ? Yaf_Registry::get
  • Yaf_Registry::set ?
  • PHP Manual
  • Yaf_Registry
  • Check whether an item exists

Yaf_Registry::has

(Yaf >=1.0.0)

Yaf_Registry::has — Check whether an item exists

说明

public static Yaf_Registry::has ( string $name ) : bool

查询某一项目是否存在于注册表中

参数

name

返回值


Add an item into registry

  • ? Yaf_Registry::has
  • Yaf_Request_Abstract ?
  • PHP Manual
  • Yaf_Registry
  • Add an item into registry

Yaf_Registry::set

(Yaf >=1.0.0)

Yaf_Registry::set — Add an item into registry

说明

public static Yaf_Registry::set ( string $name , string $value ) : bool

往全局注册表添加一个新的项

参数

name

value

返回值


The Yaf_Request_Abstract class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Request_Abstract {
/* Constants */
const string SCHEME_HTTP = http ;
const string SCHEME_HTTPS = https ;
/* 属性 */
public $module ;
public $controller ;
public $action ;
public $method ;
protected $params ;
protected $language ;
protected $_exception ;
protected $_base_uri ;
protected $uri ;
protected $dispatched ;
protected $routed ;
/* 方法 */
public clearParams ( ) : bool
public getActionName ( ) : void
public getBaseUri ( ) : void
public getControllerName ( ) : void
public getEnv ( string $name , string $default = ? ) : void
public getException ( ) : void
public getLanguage ( ) : void
public getMethod ( ) : void
public getModuleName ( ) : void
public getParam ( string $name , string $default = ? ) : void
public getParams ( ) : void
public getRequestUri ( ) : void
public getServer ( string $name , string $default = ? ) : void
public isCli ( ) : void
public isDispatched ( ) : void
public isGet ( ) : void
public isHead ( ) : void
public isOptions ( ) : void
public isPost ( ) : void
public isPut ( ) : void
public isRouted ( ) : void
public isXmlHttpRequest ( ) : void
public setActionName ( string $action ) : void
public setBaseUri ( string $uir ) : void
public setControllerName ( string $controller ) : void
public setDispatched ( ) : void
public setModuleName ( string $module ) : void
public setParam ( string $name , string $value = ? ) : void
public setRequestUri ( string $uir ) : void
public setRouted ( string $flag = ? ) : void
}

属性

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

预定义常量

Yaf_Request_Abstract::SCHEME_HTTP

Yaf_Request_Abstract::SCHEME_HTTPS

Table of Contents

  • Yaf_Request_Abstract::clearParams — Remove all params
  • Yaf_Request_Abstract::getActionName — The getActionName purpose
  • Yaf_Request_Abstract::getBaseUri — The getBaseUri purpose
  • Yaf_Request_Abstract::getControllerName — The getControllerName purpose
  • Yaf_Request_Abstract::getEnv — 取得ENV变量的值
  • Yaf_Request_Abstract::getException — The getException purpose
  • Yaf_Request_Abstract::getLanguage — The getLanguage purpose
  • Yaf_Request_Abstract::getMethod — The getMethod purpose
  • Yaf_Request_Abstract::getModuleName — The getModuleName purpose
  • Yaf_Request_Abstract::getParam — The getParam purpose
  • Yaf_Request_Abstract::getParams — The getParams purpose
  • Yaf_Request_Abstract::getRequestUri — The getRequestUri purpose
  • Yaf_Request_Abstract::getServer — 返回SERVER变量的值
  • Yaf_Request_Abstract::isCli — The isCli purpose
  • Yaf_Request_Abstract::isDispatched — The isDispatched purpose
  • Yaf_Request_Abstract::isGet — The isGet purpose
  • Yaf_Request_Abstract::isHead — The isHead purpose
  • Yaf_Request_Abstract::isOptions — The isOptions purpose
  • Yaf_Request_Abstract::isPost — The isPost purpose
  • Yaf_Request_Abstract::isPut — The isPut purpose
  • Yaf_Request_Abstract::isRouted — The isRouted purpose
  • Yaf_Request_Abstract::isXmlHttpRequest — The isXmlHttpRequest purpose
  • Yaf_Request_Abstract::setActionName — The setActionName purpose
  • Yaf_Request_Abstract::setBaseUri — The setBaseUri purpose
  • Yaf_Request_Abstract::setControllerName — The setControllerName purpose
  • Yaf_Request_Abstract::setDispatched — The setDispatched purpose
  • Yaf_Request_Abstract::setModuleName — The setModuleName purpose
  • Yaf_Request_Abstract::setParam — The setParam purpose
  • Yaf_Request_Abstract::setRequestUri — The setRequestUri purpose
  • Yaf_Request_Abstract::setRouted — The setRouted purpose


Remove all params

  • ? Yaf_Request_Abstract
  • Yaf_Request_Abstract::getActionName ?
  • PHP Manual
  • Yaf_Request_Abstract
  • Remove all params

Yaf_Request_Abstract::clearParams

(No version information available, might only be in Git)

Yaf_Request_Abstract::clearParams — Remove all params

说明

public Yaf_Request_Abstract::clearParams ( ) : bool

Remove all params set by router, or Yaf_Request_Abstract::setParam()

参数

此函数没有参数。

返回值

bool

参见

  • Yaf_Request_Abstract::isHead() - The isHead purpose
  • Yaf_Request_Abstract::isGet() - The isGet purpose
  • Yaf_Request_Abstract::isPost() - The isPost purpose
  • Yaf_Request_Abstract::isPut() - The isPut purpose
  • Yaf_Request_Abstract::isOptions() - The isOptions purpose
  • Yaf_Request_Abstract::isXmlHTTPRequest() - The isXmlHttpRequest purpose


The getActionName purpose

  • ? Yaf_Request_Abstract::clearParams
  • Yaf_Request_Abstract::getBaseUri ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getActionName purpose

Yaf_Request_Abstract::getActionName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getActionName — The getActionName purpose

说明

public Yaf_Request_Abstract::getActionName ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getBaseUri purpose

  • ? Yaf_Request_Abstract::getActionName
  • Yaf_Request_Abstract::getControllerName ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getBaseUri purpose

Yaf_Request_Abstract::getBaseUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::getBaseUri — The getBaseUri purpose

说明

public Yaf_Request_Abstract::getBaseUri ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getControllerName purpose

  • ? Yaf_Request_Abstract::getBaseUri
  • Yaf_Request_Abstract::getEnv ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getControllerName purpose

Yaf_Request_Abstract::getControllerName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getControllerName — The getControllerName purpose

说明

public Yaf_Request_Abstract::getControllerName ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


取得ENV变量的值

  • ? Yaf_Request_Abstract::getControllerName
  • Yaf_Request_Abstract::getException ?
  • PHP Manual
  • Yaf_Request_Abstract
  • 取得ENV变量的值

Yaf_Request_Abstract::getEnv

(Yaf >=1.0.0)

Yaf_Request_Abstract::getEnv — 取得ENV变量的值

说明

public Yaf_Request_Abstract::getEnv ( string $name , string $default = ? ) : void

取得ENV变量的值

参数

name

the variable name

default

如果这个参数被提供了，当参数找不到的时候它将被返回

返回值

参见

  • Yaf_Request_Abstract::getServer
  • Yaf_Request_Abstract::getParam


The getException purpose

  • ? Yaf_Request_Abstract::getEnv
  • Yaf_Request_Abstract::getLanguage ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getException purpose

Yaf_Request_Abstract::getException

(Yaf >=1.0.0)

Yaf_Request_Abstract::getException — The getException purpose

说明

public Yaf_Request_Abstract::getException ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getLanguage purpose

  • ? Yaf_Request_Abstract::getException
  • Yaf_Request_Abstract::getMethod ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getLanguage purpose

Yaf_Request_Abstract::getLanguage

(Yaf >=1.0.0)

Yaf_Request_Abstract::getLanguage — The getLanguage purpose

说明

public Yaf_Request_Abstract::getLanguage ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getMethod purpose

  • ? Yaf_Request_Abstract::getLanguage
  • Yaf_Request_Abstract::getModuleName ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getMethod purpose

Yaf_Request_Abstract::getMethod

(Yaf >=1.0.0)

Yaf_Request_Abstract::getMethod — The getMethod purpose

说明

public Yaf_Request_Abstract::getMethod ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getModuleName purpose

  • ? Yaf_Request_Abstract::getMethod
  • Yaf_Request_Abstract::getParam ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getModuleName purpose

Yaf_Request_Abstract::getModuleName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getModuleName — The getModuleName purpose

说明

public Yaf_Request_Abstract::getModuleName ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getParam purpose

  • ? Yaf_Request_Abstract::getModuleName
  • Yaf_Request_Abstract::getParams ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getParam purpose

Yaf_Request_Abstract::getParam

(Yaf >=1.0.0)

Yaf_Request_Abstract::getParam — The getParam purpose

说明

public Yaf_Request_Abstract::getParam ( string $name , string $default = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

default

返回值


The getParams purpose

  • ? Yaf_Request_Abstract::getParam
  • Yaf_Request_Abstract::getRequestUri ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getParams purpose

Yaf_Request_Abstract::getParams

(Yaf >=1.0.0)

Yaf_Request_Abstract::getParams — The getParams purpose

说明

public Yaf_Request_Abstract::getParams ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getRequestUri purpose

  • ? Yaf_Request_Abstract::getParams
  • Yaf_Request_Abstract::getServer ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The getRequestUri purpose

Yaf_Request_Abstract::getRequestUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::getRequestUri — The getRequestUri purpose

说明

public Yaf_Request_Abstract::getRequestUri ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


返回SERVER变量的值

  • ? Yaf_Request_Abstract::getRequestUri
  • Yaf_Request_Abstract::isCli ?
  • PHP Manual
  • Yaf_Request_Abstract
  • 返回SERVER变量的值

Yaf_Request_Abstract::getServer

(Yaf >=1.0.0)

Yaf_Request_Abstract::getServer — 返回SERVER变量的值

说明

public Yaf_Request_Abstract::getServer ( string $name , string $default = ? ) : void

返回SERVER变量的值

参数

name

the variable name

default

如果提供这个参数，在没找到变量值时候此参数的值将被返回

返回值

参见

  • Yaf_Request_Abstract::getParam
  • Yaf_Request_Abstract::getEnv


The isCli purpose

  • ? Yaf_Request_Abstract::getServer
  • Yaf_Request_Abstract::isDispatched ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isCli purpose

Yaf_Request_Abstract::isCli

(Yaf >=1.0.0)

Yaf_Request_Abstract::isCli — The isCli purpose

说明

public Yaf_Request_Abstract::isCli ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isDispatched purpose

  • ? Yaf_Request_Abstract::isCli
  • Yaf_Request_Abstract::isGet ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isDispatched purpose

Yaf_Request_Abstract::isDispatched

(Yaf >=1.0.0)

Yaf_Request_Abstract::isDispatched — The isDispatched purpose

说明

public Yaf_Request_Abstract::isDispatched ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isGet purpose

  • ? Yaf_Request_Abstract::isDispatched
  • Yaf_Request_Abstract::isHead ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isGet purpose

Yaf_Request_Abstract::isGet

(Yaf >=1.0.0)

Yaf_Request_Abstract::isGet — The isGet purpose

说明

public Yaf_Request_Abstract::isGet ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isHead purpose

  • ? Yaf_Request_Abstract::isGet
  • Yaf_Request_Abstract::isOptions ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isHead purpose

Yaf_Request_Abstract::isHead

(Yaf >=1.0.0)

Yaf_Request_Abstract::isHead — The isHead purpose

说明

public Yaf_Request_Abstract::isHead ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isOptions purpose

  • ? Yaf_Request_Abstract::isHead
  • Yaf_Request_Abstract::isPost ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isOptions purpose

Yaf_Request_Abstract::isOptions

(Yaf >=1.0.0)

Yaf_Request_Abstract::isOptions — The isOptions purpose

说明

public Yaf_Request_Abstract::isOptions ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isPost purpose

  • ? Yaf_Request_Abstract::isOptions
  • Yaf_Request_Abstract::isPut ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isPost purpose

Yaf_Request_Abstract::isPost

(Yaf >=1.0.0)

Yaf_Request_Abstract::isPost — The isPost purpose

说明

public Yaf_Request_Abstract::isPost ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isPut purpose

  • ? Yaf_Request_Abstract::isPost
  • Yaf_Request_Abstract::isRouted ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isPut purpose

Yaf_Request_Abstract::isPut

(Yaf >=1.0.0)

Yaf_Request_Abstract::isPut — The isPut purpose

说明

public Yaf_Request_Abstract::isPut ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isRouted purpose

  • ? Yaf_Request_Abstract::isPut
  • Yaf_Request_Abstract::isXmlHttpRequest ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isRouted purpose

Yaf_Request_Abstract::isRouted

(Yaf >=1.0.0)

Yaf_Request_Abstract::isRouted — The isRouted purpose

说明

public Yaf_Request_Abstract::isRouted ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isXmlHttpRequest purpose

  • ? Yaf_Request_Abstract::isRouted
  • Yaf_Request_Abstract::setActionName ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The isXmlHttpRequest purpose

Yaf_Request_Abstract::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Abstract::isXmlHttpRequest — The isXmlHttpRequest purpose

说明

public Yaf_Request_Abstract::isXmlHttpRequest ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The setActionName purpose

  • ? Yaf_Request_Abstract::isXmlHttpRequest
  • Yaf_Request_Abstract::setBaseUri ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The setActionName purpose

Yaf_Request_Abstract::setActionName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setActionName — The setActionName purpose

说明

public Yaf_Request_Abstract::setActionName ( string $action ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

action

返回值


The setBaseUri purpose

  • ? Yaf_Request_Abstract::setActionName
  • Yaf_Request_Abstract::setControllerName ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The setBaseUri purpose

Yaf_Request_Abstract::setBaseUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::setBaseUri — The setBaseUri purpose

说明

public Yaf_Request_Abstract::setBaseUri ( string $uir ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

uir

返回值


The setControllerName purpose

  • ? Yaf_Request_Abstract::setBaseUri
  • Yaf_Request_Abstract::setDispatched ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The setControllerName purpose

Yaf_Request_Abstract::setControllerName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setControllerName — The setControllerName purpose

说明

public Yaf_Request_Abstract::setControllerName ( string $controller ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

controller

返回值


The setDispatched purpose

  • ? Yaf_Request_Abstract::setControllerName
  • Yaf_Request_Abstract::setModuleName ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The setDispatched purpose

Yaf_Request_Abstract::setDispatched

(Yaf >=1.0.0)

Yaf_Request_Abstract::setDispatched — The setDispatched purpose

说明

public Yaf_Request_Abstract::setDispatched ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The setModuleName purpose

  • ? Yaf_Request_Abstract::setDispatched
  • Yaf_Request_Abstract::setParam ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The setModuleName purpose

Yaf_Request_Abstract::setModuleName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setModuleName — The setModuleName purpose

说明

public Yaf_Request_Abstract::setModuleName ( string $module ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

module

返回值


The setParam purpose

  • ? Yaf_Request_Abstract::setModuleName
  • Yaf_Request_Abstract::setRequestUri ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The setParam purpose

Yaf_Request_Abstract::setParam

(Yaf >=1.0.0)

Yaf_Request_Abstract::setParam — The setParam purpose

说明

public Yaf_Request_Abstract::setParam ( string $name , string $value = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值


The setRequestUri purpose

  • ? Yaf_Request_Abstract::setParam
  • Yaf_Request_Abstract::setRouted ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The setRequestUri purpose

Yaf_Request_Abstract::setRequestUri

(Yaf >=2.1.0)

Yaf_Request_Abstract::setRequestUri — The setRequestUri purpose

说明

public Yaf_Request_Abstract::setRequestUri ( string $uir ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

uir

返回值


The setRouted purpose

  • ? Yaf_Request_Abstract::setRequestUri
  • Yaf_Request_Http ?
  • PHP Manual
  • Yaf_Request_Abstract
  • The setRouted purpose

Yaf_Request_Abstract::setRouted

(Yaf >=1.0.0)

Yaf_Request_Abstract::setRouted — The setRouted purpose

说明

public Yaf_Request_Abstract::setRouted ( string $flag = ? ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

flag

返回值


The Yaf_Request_Http class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Request_Http extends Yaf_Request_Abstract {
/* 属性 */
/* 方法 */
__construct ( )
public get ( string $name , string $default = ? ) : mixed
public getCookie ( string $name , string $default = ? ) : mixed
public getFiles ( ) : void
public getPost ( string $name , string $default = ? ) : mixed
public getQuery ( string $name , string $default = ? ) : mixed
public getRaw ( ) : mixed
public getRequest ( ) : void
public isXmlHttpRequest ( ) : bool
/* 继承的方法 */
public Yaf_Request_Abstract::clearParams ( ) : bool
public Yaf_Request_Abstract::getActionName ( ) : void
public Yaf_Request_Abstract::getBaseUri ( ) : void
public Yaf_Request_Abstract::getControllerName ( ) : void
public Yaf_Request_Abstract::getEnv ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::getException ( ) : void
public Yaf_Request_Abstract::getLanguage ( ) : void
public Yaf_Request_Abstract::getMethod ( ) : void
public Yaf_Request_Abstract::getModuleName ( ) : void
public Yaf_Request_Abstract::getParam ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::getParams ( ) : void
public Yaf_Request_Abstract::getRequestUri ( ) : void
public Yaf_Request_Abstract::getServer ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::isCli ( ) : void
public Yaf_Request_Abstract::isDispatched ( ) : void
public Yaf_Request_Abstract::isGet ( ) : void
public Yaf_Request_Abstract::isHead ( ) : void
public Yaf_Request_Abstract::isOptions ( ) : void
public Yaf_Request_Abstract::isPost ( ) : void
public Yaf_Request_Abstract::isPut ( ) : void
public Yaf_Request_Abstract::isRouted ( ) : void
public Yaf_Request_Abstract::isXmlHttpRequest ( ) : void
public Yaf_Request_Abstract::setActionName ( string $action ) : void
public Yaf_Request_Abstract::setBaseUri ( string $uir ) : void
public Yaf_Request_Abstract::setControllerName ( string $controller ) : void
public Yaf_Request_Abstract::setDispatched ( ) : void
public Yaf_Request_Abstract::setModuleName ( string $module ) : void
public Yaf_Request_Abstract::setParam ( string $name , string $value = ? ) : void
public Yaf_Request_Abstract::setRequestUri ( string $uir ) : void
public Yaf_Request_Abstract::setRouted ( string $flag = ? ) : void
}

属性

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

Table of Contents

  • Yaf_Request_Http::__construct — The __construct purpose
  • Yaf_Request_Http::get — 从客户端返回变量
  • Yaf_Request_Http::getCookie — 返回Cookie变量
  • Yaf_Request_Http::getFiles — The getFiles purpose
  • Yaf_Request_Http::getPost — 返回POST变量
  • Yaf_Request_Http::getQuery — fetch a query parameter
  • Yaf_Request_Http::getRaw — Retrieve Raw request body
  • Yaf_Request_Http::getRequest — The getRequest purpose
  • Yaf_Request_Http::isXmlHttpRequest — 是否为Ajax请求


The __construct purpose

  • ? Yaf_Request_Http
  • Yaf_Request_Http::get ?
  • PHP Manual
  • Yaf_Request_Http
  • The __construct purpose

Yaf_Request_Http::__construct

(Yaf >=1.0.0)

Yaf_Request_Http::__construct — The __construct purpose

说明

Yaf_Request_Http::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


从客户端返回变量

  • ? Yaf_Request_Http::__construct
  • Yaf_Request_Http::getCookie ?
  • PHP Manual
  • Yaf_Request_Http
  • 从客户端返回变量

Yaf_Request_Http::get

(Yaf >=1.0.0)

Yaf_Request_Http::get — 从客户端返回变量

说明

public Yaf_Request_Http::get ( string $name , string $default = ? ) : mixed

从客户端返回变量，这个方法将从请求参数中寻找参数name，如果没有找到的话，将从POST, GET, Cookie, Server中寻找

参数

name

the variable name

default

如果提供了此参数，当变量在未被找到的情况下，它将被返回

返回值

参见

  • Yaf_Request_Http::getQuery
  • Yaf_Request_Http::getPost
  • Yaf_Request_Http::getCookie
  • Yaf_Request_Http::getServer
  • Yaf_Request_Http::getParam


返回Cookie变量

  • ? Yaf_Request_Http::get
  • Yaf_Request_Http::getFiles ?
  • PHP Manual
  • Yaf_Request_Http
  • 返回Cookie变量

Yaf_Request_Http::getCookie

(Yaf >=1.0.0)

Yaf_Request_Http::getCookie — 返回Cookie变量

说明

public Yaf_Request_Http::getCookie ( string $name , string $default = ? ) : mixed

返回Cookie变量

参数

name

the cookie name

default

如果提供了此参数，当变量在未被找到的情况下，提供的参数将被返回

返回值

参见

  • Yaf_Request_Http::get
  • Yaf_Request_Http::getQuery
  • Yaf_Request_Http::getPost
  • Yaf_Request_Http::getServer
  • Yaf_Request_Http::getParam


The getFiles purpose

  • ? Yaf_Request_Http::getCookie
  • Yaf_Request_Http::getPost ?
  • PHP Manual
  • Yaf_Request_Http
  • The getFiles purpose

Yaf_Request_Http::getFiles

(Yaf >=1.0.0)

Yaf_Request_Http::getFiles — The getFiles purpose

说明

public Yaf_Request_Http::getFiles ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


返回POST变量

  • ? Yaf_Request_Http::getFiles
  • Yaf_Request_Http::getQuery ?
  • PHP Manual
  • Yaf_Request_Http
  • 返回POST变量

Yaf_Request_Http::getPost

(Yaf >=1.0.0)

Yaf_Request_Http::getPost — 返回POST变量

说明

public Yaf_Request_Http::getPost ( string $name , string $default = ? ) : mixed

返回POST变量

参数

name

the variable name

default

如果提供了此参数，当变量在未被找到的情况下，提供的参数将被返回

返回值

参见

  • Yaf_Request_Http::get
  • Yaf_Request_Http::getQuery
  • Yaf_Request_Http::getCookie
  • Yaf_Request_Http::getServer
  • Yaf_Request_Http::getParam


fetch a query parameter

  • ? Yaf_Request_Http::getPost
  • Yaf_Request_Http::getRaw ?
  • PHP Manual
  • Yaf_Request_Http
  • fetch a query parameter

Yaf_Request_Http::getQuery

(Yaf >=1.0.0)

Yaf_Request_Http::getQuery — fetch a query parameter

说明

public Yaf_Request_Http::getQuery ( string $name , string $default = ? ) : mixed

返回Get变量

参数

name

the variable name

default

如果提供了此参数，当变量在未被找到的情况下，提供的参数将被返回

返回值

参见

  • Yaf_Request_Http::get
  • Yaf_Request_Http::getPost
  • Yaf_Request_Http::getCookie
  • Yaf_Request_Http::getServer
  • Yaf_Request_Http::getParam


Retrieve Raw request body

  • ? Yaf_Request_Http::getQuery
  • Yaf_Request_Http::getRequest ?
  • PHP Manual
  • Yaf_Request_Http
  • Retrieve Raw request body

Yaf_Request_Http::getRaw

(Yaf >=3.0.7)

Yaf_Request_Http::getRaw — Retrieve Raw request body

说明

public Yaf_Request_Http::getRaw ( ) : mixed

Retrieve Raw request body

参数

此函数没有参数。

返回值

Return string on success, FALSE on failure.

参见

  • Yaf_Request_Http::get() - 从客户端返回变量
  • Yaf_Request_Http::getPost() - 返回POST变量
  • Yaf_Request_Http::getCookie() - 返回Cookie变量
  • Yaf_Request_Http::getQuery() - fetch a query parameter
  • Yaf_Request_Abstract::getServer() - 返回SERVER变量的值
  • Yaf_Request_Abstract::getParam() - The getParam purpose


The getRequest purpose

  • ? Yaf_Request_Http::getRaw
  • Yaf_Request_Http::isXmlHttpRequest ?
  • PHP Manual
  • Yaf_Request_Http
  • The getRequest purpose

Yaf_Request_Http::getRequest

(Yaf >=1.0.0)

Yaf_Request_Http::getRequest — The getRequest purpose

说明

public Yaf_Request_Http::getRequest ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


是否为Ajax请求

  • ? Yaf_Request_Http::getRequest
  • Yaf_Request_Simple ?
  • PHP Manual
  • Yaf_Request_Http
  • 是否为Ajax请求

Yaf_Request_Http::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Http::isXmlHttpRequest — 是否为Ajax请求

说明

public Yaf_Request_Http::isXmlHttpRequest ( ) : bool

检查请求是否是Ajax请求

Note:

这个方法取决于请求报头：HTTP_X_REQUESTED_WITH，一些Javascript库在做Ajax请求时候不设置这个报文头。

参数

此函数没有参数。

返回值


The Yaf_Request_Simple class

(Yaf >=1.0.0)

简介

Yaf_Request_Simple 特别的被用于测试。例如：CLI模式下模拟一些特殊的要求

类摘要

Yaf_Request_Simple extends Yaf_Request_Abstract {
/* Constants */
const string SCHEME_HTTP = http ;
const string SCHEME_HTTPS = https ;
/* 属性 */
/* 方法 */
__construct ( )
public get ( ) : void
public getCookie ( ) : void
public getFiles ( ) : void
public getPost ( ) : void
public getQuery ( ) : void
public getRequest ( ) : void
public isXmlHttpRequest ( ) : void
/* 继承的方法 */
public Yaf_Request_Abstract::clearParams ( ) : bool
public Yaf_Request_Abstract::getActionName ( ) : void
public Yaf_Request_Abstract::getBaseUri ( ) : void
public Yaf_Request_Abstract::getControllerName ( ) : void
public Yaf_Request_Abstract::getEnv ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::getException ( ) : void
public Yaf_Request_Abstract::getLanguage ( ) : void
public Yaf_Request_Abstract::getMethod ( ) : void
public Yaf_Request_Abstract::getModuleName ( ) : void
public Yaf_Request_Abstract::getParam ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::getParams ( ) : void
public Yaf_Request_Abstract::getRequestUri ( ) : void
public Yaf_Request_Abstract::getServer ( string $name , string $default = ? ) : void
public Yaf_Request_Abstract::isCli ( ) : void
public Yaf_Request_Abstract::isDispatched ( ) : void
public Yaf_Request_Abstract::isGet ( ) : void
public Yaf_Request_Abstract::isHead ( ) : void
public Yaf_Request_Abstract::isOptions ( ) : void
public Yaf_Request_Abstract::isPost ( ) : void
public Yaf_Request_Abstract::isPut ( ) : void
public Yaf_Request_Abstract::isRouted ( ) : void
public Yaf_Request_Abstract::isXmlHttpRequest ( ) : void
public Yaf_Request_Abstract::setActionName ( string $action ) : void
public Yaf_Request_Abstract::setBaseUri ( string $uir ) : void
public Yaf_Request_Abstract::setControllerName ( string $controller ) : void
public Yaf_Request_Abstract::setDispatched ( ) : void
public Yaf_Request_Abstract::setModuleName ( string $module ) : void
public Yaf_Request_Abstract::setParam ( string $name , string $value = ? ) : void
public Yaf_Request_Abstract::setRequestUri ( string $uir ) : void
public Yaf_Request_Abstract::setRouted ( string $flag = ? ) : void
}

属性

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

预定义常量

Yaf_Request_Simple::SCHEME_HTTP

Yaf_Request_Simple::SCHEME_HTTPS

Table of Contents

  • Yaf_Request_Simple::__construct — The __construct purpose
  • Yaf_Request_Simple::get — The get purpose
  • Yaf_Request_Simple::getCookie — The getCookie purpose
  • Yaf_Request_Simple::getFiles — The getFiles purpose
  • Yaf_Request_Simple::getPost — The getPost purpose
  • Yaf_Request_Simple::getQuery — The getQuery purpose
  • Yaf_Request_Simple::getRequest — The getRequest purpose
  • Yaf_Request_Simple::isXmlHttpRequest — The isXmlHttpRequest purpose


The __construct purpose

  • ? Yaf_Request_Simple
  • Yaf_Request_Simple::get ?
  • PHP Manual
  • Yaf_Request_Simple
  • The __construct purpose

Yaf_Request_Simple::__construct

(Yaf >=1.0.0)

Yaf_Request_Simple::__construct — The __construct purpose

说明

Yaf_Request_Simple::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The get purpose

  • ? Yaf_Request_Simple::__construct
  • Yaf_Request_Simple::getCookie ?
  • PHP Manual
  • Yaf_Request_Simple
  • The get purpose

Yaf_Request_Simple::get

(Yaf >=1.0.0)

Yaf_Request_Simple::get — The get purpose

说明

public Yaf_Request_Simple::get ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getCookie purpose

  • ? Yaf_Request_Simple::get
  • Yaf_Request_Simple::getFiles ?
  • PHP Manual
  • Yaf_Request_Simple
  • The getCookie purpose

Yaf_Request_Simple::getCookie

(Yaf >=1.0.0)

Yaf_Request_Simple::getCookie — The getCookie purpose

说明

public Yaf_Request_Simple::getCookie ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getFiles purpose

  • ? Yaf_Request_Simple::getCookie
  • Yaf_Request_Simple::getPost ?
  • PHP Manual
  • Yaf_Request_Simple
  • The getFiles purpose

Yaf_Request_Simple::getFiles

(Yaf >=1.0.0)

Yaf_Request_Simple::getFiles — The getFiles purpose

说明

public Yaf_Request_Simple::getFiles ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getPost purpose

  • ? Yaf_Request_Simple::getFiles
  • Yaf_Request_Simple::getQuery ?
  • PHP Manual
  • Yaf_Request_Simple
  • The getPost purpose

Yaf_Request_Simple::getPost

(Yaf >=1.0.0)

Yaf_Request_Simple::getPost — The getPost purpose

说明

public Yaf_Request_Simple::getPost ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getQuery purpose

  • ? Yaf_Request_Simple::getPost
  • Yaf_Request_Simple::getRequest ?
  • PHP Manual
  • Yaf_Request_Simple
  • The getQuery purpose

Yaf_Request_Simple::getQuery

(Yaf >=1.0.0)

Yaf_Request_Simple::getQuery — The getQuery purpose

说明

public Yaf_Request_Simple::getQuery ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getRequest purpose

  • ? Yaf_Request_Simple::getQuery
  • Yaf_Request_Simple::isXmlHttpRequest ?
  • PHP Manual
  • Yaf_Request_Simple
  • The getRequest purpose

Yaf_Request_Simple::getRequest

(Yaf >=1.0.0)

Yaf_Request_Simple::getRequest — The getRequest purpose

说明

public Yaf_Request_Simple::getRequest ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The isXmlHttpRequest purpose

  • ? Yaf_Request_Simple::getRequest
  • Yaf_Response_Abstract ?
  • PHP Manual
  • Yaf_Request_Simple
  • The isXmlHttpRequest purpose

Yaf_Request_Simple::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Simple::isXmlHttpRequest — The isXmlHttpRequest purpose

说明

public Yaf_Request_Simple::isXmlHttpRequest ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Response_Abstract class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Response_Abstract {
/* Constants */
const string DEFAULT_BODY = "content" ;
/* 属性 */
protected $_header ;
protected $_body ;
protected $_sendheader ;
/* 方法 */
public appendBody ( string $content , string $key = ? ) : bool
public clearBody ( string $key = ? ) : bool
public clearHeaders ( ) : void
public __construct ( )
public __destruct ( ) : void
public getBody ( string $key = ? ) : mixed
public getHeader ( ) : void
public prependBody ( string $content , string $key = ? ) : bool
public response ( ) : void
protected setAllHeaders ( ) : void
public setBody ( string $content , string $key = ? ) : bool
public setHeader ( ) : void
public setRedirect ( string $url ) : bool
private __toString ( ) : void
}

属性

_header

_body

_sendheader

Table of Contents

  • Yaf_Response_Abstract::appendBody — 往已有的响应body后附加新的内容
  • Yaf_Response_Abstract::clearBody — 清除已经设置的响应body
  • Yaf_Response_Abstract::clearHeaders — The clearHeaders purpose
  • Yaf_Response_Abstract::__construct — The __construct purpose
  • Yaf_Response_Abstract::__destruct — The __destruct purpose
  • Yaf_Response_Abstract::getBody — 获取已经设置的响应body
  • Yaf_Response_Abstract::getHeader — The getHeader purpose
  • Yaf_Response_Abstract::prependBody — The prependBody purpose
  • Yaf_Response_Abstract::response — send response
  • Yaf_Response_Abstract::setAllHeaders — The setAllHeaders purpose
  • Yaf_Response_Abstract::setBody — 设置响应的Body
  • Yaf_Response_Abstract::setHeader — The setHeader purpose
  • Yaf_Response_Abstract::setRedirect — The setRedirect purpose
  • Yaf_Response_Abstract::__toString — The __toString purpose


往已有的响应body后附加新的内容

  • ? Yaf_Response_Abstract
  • Yaf_Response_Abstract::clearBody ?
  • PHP Manual
  • Yaf_Response_Abstract
  • 往已有的响应body后附加新的内容

Yaf_Response_Abstract::appendBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::appendBody — 往已有的响应body后附加新的内容

说明

public Yaf_Response_Abstract::appendBody ( string $content , string $key = ? ) : bool

往已有的响应body后附加新的内容

参数

body

content string

key

响应内容的key，你可以设置一个键值对，如果你没有具体的设置的话，系统默认使用Yaf_Response_Abstract::DEFAULT_BODY

Note:

this parameter is introduced as of 2.2.0

返回值

bool

范例

Example #1 Yaf_Response_Abstract::appendBody()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("Hello")->prependBody(" World");

echo $response;
?>

以上例程的输出类似于：

Hello World

参见

  • Yaf_Config_Ini

参见

  • Yaf_Response_Abstract::getBody() - 获取已经设置的响应body
  • Yaf_Response_Abstract::setBody() - 设置响应的Body
  • Yaf_Response_Abstract::prependBody() - The prependBody purpose
  • Yaf_Response_Abstract::clearBody() - 清除已经设置的响应body


清除已经设置的响应body

  • ? Yaf_Response_Abstract::appendBody
  • Yaf_Response_Abstract::clearHeaders ?
  • PHP Manual
  • Yaf_Response_Abstract
  • 清除已经设置的响应body

Yaf_Response_Abstract::clearBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::clearBody — 清除已经设置的响应body

说明

public Yaf_Response_Abstract::clearBody ( string $key = ? ) : bool

清除已经设置的响应body

参数

key

the content key, if you don't specific, then all contents will be cleared. 如果你没选择具体清除哪个key所对应的内容，那所有内容将被清除

Note:

this parameter is introduced as of 2.2.0

返回值

参见

  • Yaf_Response_Abstract::setBody() - 设置响应的Body
  • Yaf_Response_Abstract::appendBody() - 往已有的响应body后附加新的内容
  • Yaf_Response_Abstract::prependBody() - The prependBody purpose
  • Yaf_Response_Abstract::getBody() - 获取已经设置的响应body


The clearHeaders purpose

  • ? Yaf_Response_Abstract::clearBody
  • Yaf_Response_Abstract::__construct ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The clearHeaders purpose

Yaf_Response_Abstract::clearHeaders

(Yaf >=1.0.0)

Yaf_Response_Abstract::clearHeaders — The clearHeaders purpose

说明

public Yaf_Response_Abstract::clearHeaders ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The __construct purpose

  • ? Yaf_Response_Abstract::clearHeaders
  • Yaf_Response_Abstract::__destruct ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The __construct purpose

Yaf_Response_Abstract::__construct

(Yaf >=1.0.0)

Yaf_Response_Abstract::__construct — The __construct purpose

说明

public Yaf_Response_Abstract::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The __destruct purpose

  • ? Yaf_Response_Abstract::__construct
  • Yaf_Response_Abstract::getBody ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The __destruct purpose

Yaf_Response_Abstract::__destruct

(Yaf >=1.0.0)

Yaf_Response_Abstract::__destruct — The __destruct purpose

说明

public Yaf_Response_Abstract::__destruct ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


获取已经设置的响应body

  • ? Yaf_Response_Abstract::__destruct
  • Yaf_Response_Abstract::getHeader ?
  • PHP Manual
  • Yaf_Response_Abstract
  • 获取已经设置的响应body

Yaf_Response_Abstract::getBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::getBody — 获取已经设置的响应body

说明

public Yaf_Response_Abstract::getBody ( string $key = ? ) : mixed

获取已经设置的响应body

参数

key

body所对应的key，如果你没指定key，系统默认使用Yaf_Response_Abstract::DEFAULT_BODY。如果你传入一个NULL，所有的内容将会以数组形式被返回。

Note:

this parameter is introduced as of 2.2.0

返回值

范例

Example #1 Yaf_Response_Abstract::getBody()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("Hello")->setBody(" World", "footer");

var_dump($response->getBody()); //default
var_dump($response->getBody(Yaf_Response_Abstract::DEFAULT_BODY)); //same as above
var_dump($response->getBody("footer"));
var_dump($response->getBody(NULL)); //get all
?>

以上例程的输出类似于：

string(5) "Hello"
string(5) "Hello"
string(6) " World"
array(2) {
  ["content"]=>
  string(5) "Hello"
  ["footer"]=>
  string(6) " World"
}

参见

  • Yaf_Response_Abstract::setBody() - 设置响应的Body
  • Yaf_Response_Abstract::appendBody() - 往已有的响应body后附加新的内容
  • Yaf_Response_Abstract::prependBody() - The prependBody purpose
  • Yaf_Response_Abstract::clearBody() - 清除已经设置的响应body


The getHeader purpose

  • ? Yaf_Response_Abstract::getBody
  • Yaf_Response_Abstract::prependBody ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The getHeader purpose

Yaf_Response_Abstract::getHeader

(Yaf >=1.0.0)

Yaf_Response_Abstract::getHeader — The getHeader purpose

说明

public Yaf_Response_Abstract::getHeader ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The prependBody purpose

  • ? Yaf_Response_Abstract::getHeader
  • Yaf_Response_Abstract::response ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The prependBody purpose

Yaf_Response_Abstract::prependBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::prependBody — The prependBody purpose

说明

public Yaf_Response_Abstract::prependBody ( string $content , string $key = ? ) : bool

往已有的响应body前插入新的内容

参数

body

content string

key

body所对应的key，你可以设置一个body的键值对，如果你没有指定key，系统默认使用Yaf_Response_Abstract::DEFAULT_BODY

Note:

this parameter is introduced as of 2.2.0

返回值

bool

范例

Example #1 Yaf_Response_Abstract::prependBody()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("World")->prependBody("Hello ");

echo $response;
?>

以上例程的输出类似于：

Hello World

参见

  • Yaf_Response_Abstract::getBody() - 获取已经设置的响应body
  • Yaf_Response_Abstract::setBody() - 设置响应的Body
  • Yaf_Response_Abstract::appendBody() - 往已有的响应body后附加新的内容
  • Yaf_Response_Abstract::clearBody() - 清除已经设置的响应body


send response

  • ? Yaf_Response_Abstract::prependBody
  • Yaf_Response_Abstract::setAllHeaders ?
  • PHP Manual
  • Yaf_Response_Abstract
  • send response

Yaf_Response_Abstract::response

(Yaf >=1.0.0)

Yaf_Response_Abstract::response — send response

说明

public Yaf_Response_Abstract::response ( ) : void

send response

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Response_Abstract::response()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("Hello")->setBody(" World", "footer");

$response->response();
?>

以上例程的输出类似于：

Hello World

参见

  • Yaf_Response_Abstract::setBody() - 设置响应的Body
  • Yaf_Response_Abstract::clearBody() - 清除已经设置的响应body


The setAllHeaders purpose

  • ? Yaf_Response_Abstract::response
  • Yaf_Response_Abstract::setBody ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The setAllHeaders purpose

Yaf_Response_Abstract::setAllHeaders

(Yaf >=1.0.0)

Yaf_Response_Abstract::setAllHeaders — The setAllHeaders purpose

说明

protected Yaf_Response_Abstract::setAllHeaders ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


设置响应的Body

  • ? Yaf_Response_Abstract::setAllHeaders
  • Yaf_Response_Abstract::setHeader ?
  • PHP Manual
  • Yaf_Response_Abstract
  • 设置响应的Body

Yaf_Response_Abstract::setBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::setBody — 设置响应的Body

说明

public Yaf_Response_Abstract::setBody ( string $content , string $key = ? ) : bool

设置响应的Body

参数

body

content string

key

body所对应的key，你可以设置一个body的键值对，如果你没有指定key，系统默认使用Yaf_Response_Abstract::DEFAULT_BODY

Note:

this parameter is introduced as of 2.2.0

返回值

范例

Example #1 Yaf_Response_Abstract::setBody()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("Hello")->setBody(" World", "footer");

print_r($response);
echo $response;
?>

以上例程的输出类似于：

Yaf_Response_Http Object
(
    [_header:protected] => Array
        (
        )

    [_body:protected] => Array
        (
            [content] => Hello
            [footer] =>  World
        )

    [_sendheader:protected] => 1
    [_response_code:protected] => 200
)
Hello World

参见

  • Yaf_Response_Abstract::getBody() - 获取已经设置的响应body
  • Yaf_Response_Abstract::appendBody() - 往已有的响应body后附加新的内容
  • Yaf_Response_Abstract::prependBody() - The prependBody purpose
  • Yaf_Response_Abstract::clearBody() - 清除已经设置的响应body


The setHeader purpose

  • ? Yaf_Response_Abstract::setBody
  • Yaf_Response_Abstract::setRedirect ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The setHeader purpose

Yaf_Response_Abstract::setHeader

(Yaf >=1.0.0)

Yaf_Response_Abstract::setHeader — The setHeader purpose

说明

public Yaf_Response_Abstract::setHeader ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The setRedirect purpose

  • ? Yaf_Response_Abstract::setHeader
  • Yaf_Response_Abstract::__toString ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The setRedirect purpose

Yaf_Response_Abstract::setRedirect

(Yaf >=1.0.0)

Yaf_Response_Abstract::setRedirect — The setRedirect purpose

说明

public Yaf_Response_Abstract::setRedirect ( string $url ) : bool

参数

url

要跳转到的地址

返回值


The __toString purpose

  • ? Yaf_Response_Abstract::setRedirect
  • Yaf_Route_Interface ?
  • PHP Manual
  • Yaf_Response_Abstract
  • The __toString purpose

Yaf_Response_Abstract::__toString

(Yaf >=1.0.0)

Yaf_Response_Abstract::__toString — The __toString purpose

说明

private Yaf_Response_Abstract::__toString ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Route_Interface class

(Yaf >=1.0.0)

简介

Yaf_Route_Interface是Yaf路由协议的标准接口, 它的存在使得用户可以自定义路由协议

类摘要

Yaf_Route_Interface {
/* 方法 */
abstract public assemble ( array $info , array $query = ? ) : string
abstract public route ( Yaf_Request_Abstract $request ) : bool
}

Table of Contents

  • Yaf_Route_Interface::assemble — 将指定路由规则组合成一个url
  • Yaf_Route_Interface::route — route a request


将指定路由规则组合成一个url

  • ? Yaf_Route_Interface
  • Yaf_Route_Interface::route ?
  • PHP Manual
  • Yaf_Route_Interface
  • 将指定路由规则组合成一个url

Yaf_Route_Interface::assemble

(Yaf >=2.3.0)

Yaf_Route_Interface::assemble — 将指定路由规则组合成一个url

说明

abstract public Yaf_Route_Interface::assemble ( array $info , array $query = ? ) : string

这个方法会将指定的参数加上自定义的参数组合成一个url

所有route必须结合其路由规则来实现这个方法

参数

info

query

返回值


route a request

  • ? Yaf_Route_Interface::assemble
  • Yaf_Route_Map ?
  • PHP Manual
  • Yaf_Route_Interface
  • route a request

Yaf_Route_Interface::route

(Yaf >=1.0.0)

Yaf_Route_Interface::route — route a request

说明

abstract public Yaf_Route_Interface::route ( Yaf_Request_Abstract $request ) : bool

Yaf_Route_Interface::route() 是用户自定义路由唯一需要实现的方法。

如果这个方法返回TRUE，那么路由进程将会中止。否则，Yaf_Router 将会调用路由堆栈中的下一个路由来路由请求。

这个方法会设置路由的结果给参数请求，通过调用Yaf_Request_Abstract::setControllerName()，Yaf_Request_Abstract::setActionName() 和 Yaf_Request_Abstract::setModuleName()

这个方法也需要调用Yaf_Request_Abstract::setRouted()做最后的请求路由。

Warning

本函数还未编写文档，仅有参数列表。

参数

request

A Yaf_Request_Abstract instance.

返回值


The Yaf_Route_Map class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Route_Map implements Yaf_Route_Interface {
/* 属性 */
protected $_ctl_router ;
protected $_delimeter ;
/* 方法 */
public assemble ( array $info , array $query = ? ) : string
public __construct ( string $controller_prefer = false , string $delimiter = '' )
public route ( Yaf_Request_Abstract $request ) : bool
}

属性

_ctl_router

_delimeter

Table of Contents

  • Yaf_Route_Map::assemble — 组合url
  • Yaf_Route_Map::__construct — The __construct purpose
  • Yaf_Route_Map::route — The route purpose


组合url

  • ? Yaf_Route_Map
  • Yaf_Route_Map::__construct ?
  • PHP Manual
  • Yaf_Route_Map
  • 组合url

Yaf_Route_Map::assemble

(Yaf >=2.3.0)

Yaf_Route_Map::assemble — 组合url

说明

public Yaf_Route_Map::assemble ( array $info , array $query = ? ) : string

根据指定参数和自定义参数将map这个route组合成一个url

参数

info

需要传入一个数组，数组的key可以为:a或者:c，:a表示action，:c表示controller。

当map route初始化时，controller_prefer为false时，这个参数需要传入:c。当controller_prefer 为true时，这个参数需要传入:a。

query

用户自定义的query string，将根据此路由规则拼接在url中

范例

Example #1 Yaf_Route_Map::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Map();

$router->addRoute("map", $route);

var_dump($router->getRoute('map')->assemble(
                        array(
                                ':c' => 'foo_bar'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                        )
                   )
);

$route = new Yaf_Route_Map(true, '_');
$router->addRoute("map", $route);

var_dump($router->getRoute('map')->assemble(
                        array(
                                ':a' => 'foo_bar'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                        )
                   )
);

以上例程的输出类似于：

string(%d) "/foo/bar?tkey1=tval1&tkey2=tval2"
string(%d) "/foo/bar/_/tkey1/tval1/tkey2/tval2"

返回值


The __construct purpose

  • ? Yaf_Route_Map::assemble
  • Yaf_Route_Map::route ?
  • PHP Manual
  • Yaf_Route_Map
  • The __construct purpose

Yaf_Route_Map::__construct

(Yaf >=1.0.0)

Yaf_Route_Map::__construct — The __construct purpose

说明

public Yaf_Route_Map::__construct ( string $controller_prefer = false , string $delimiter = '' )

Warning

本函数还未编写文档，仅有参数列表。

参数

controller_prefer

结果是否应该考虑作为controller或action

delimiter

返回值

范例

Example #1 Yaf_Route_Map()example

<?php
   /**
    * Add a map route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Map());
?>

以上例程的输出类似于：

/* for http://yourdomain.com/product/foo/bar
 * route will result in following values:
 */
array(
  "controller" => "product_foo_bar",
)

Example #2 Yaf_Route_Map()example

<?php
   /**
    * Add a map route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Map(true, "_"));
?>

以上例程的输出类似于：

/* for http://yourdomain.com/user/list/_/foo/22
 * route will result in following values:
 */
array(
    "action" => "user_list",
)

/**
 * and request parameters:
 */
array(
  "foo"   => 22,
)

Example #3 Yaf_Route_Map()example

<?php
   /**
    * Add a map route to Yaf_Router route stack by calling addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "map",         //Yaf_Route_Map route
           "controllerPrefer" => FALSE,
           "delimiter"        => "#!",
           ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

参见

  • Yaf_Router::addRoute() - 往Router中添加新的路由
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite


The route purpose

  • ? Yaf_Route_Map::__construct
  • Yaf_Route_Regex ?
  • PHP Manual
  • Yaf_Route_Map
  • The route purpose

Yaf_Route_Map::route

(Yaf >=1.0.0)

Yaf_Route_Map::route — The route purpose

说明

public Yaf_Route_Map::route ( Yaf_Request_Abstract $request ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

request

返回值


The Yaf_Route_Regex class

(Yaf >=1.0.0)

简介

Yaf_Route_Regex 是Yaf内置的路由中最灵活的。

类摘要

Yaf_Route_Regex extends Yaf_Route_Interface implements Yaf_Route_Interface {
/* 属性 */
protected $_route ;
protected $_default ;
protected $_maps ;
protected $_verify ;
/* 方法 */
public assemble ( array $info , array $query = ? ) : string
public__construct ( string $match , array $route , array $map = ? , array $verify = ? )
public route ( Yaf_Request_Abstract $request ) : bool
/* 继承的方法 */
abstract public Yaf_Route_Interface::assemble ( array $info , array $query = ? ) : string
abstract public Yaf_Route_Interface::route ( Yaf_Request_Abstract $request ) : bool
}

属性

_route

_default

_maps

_verify

Table of Contents

  • Yaf_Route_Regex::assemble — 组合url
  • Yaf_Route_Regex::__construct — The __construct purpose
  • Yaf_Route_Regex::route — The route purpose


组合url

  • ? Yaf_Route_Regex
  • Yaf_Route_Regex::__construct ?
  • PHP Manual
  • Yaf_Route_Regex
  • 组合url

Yaf_Route_Regex::assemble

(Yaf >=2.3.0)

Yaf_Route_Regex::assemble — 组合url

说明

public Yaf_Route_Regex::assemble ( array $info , array $query = ? ) : string

根据指定参数和自定义参数将regex这个route组合成一个url

在regex route使用assemble需要在初始化时指定reverse参数，否则将不能正常工作

参数

info

需要传入一个数组，数组的key可以为:a、:c、:m，:a表示action，:c表示controller，:m表示module。

query

用户自定义的query string，将根据此路由规则拼接在url中

范例

Example #1 Yaf_Route_Regex::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Regex(
            "#^/product/([^/]+)/([^/])+#",
            array(
                'controller' => "product",  //route to product controller,
                ),
            array(),
            array(),
            '/:m/:c/:a'
        );

$router->addRoute("regex", $route);

var_dump($router->getRoute('regex')->assemble(
            array(
                ':m' => 'module',
                ':c' => 'controller',
                ':a' => 'action'
                ),
            array(
                'tkey1' => 'tval1',
                'tkey2' =>
                'tval2'
                )
            )
        );

以上例程的输出类似于：

string(49) "/module/controller/action?tkey1=tval1&tkey2=tval2"

返回值


The __construct purpose

  • ? Yaf_Route_Regex::assemble
  • Yaf_Route_Regex::route ?
  • PHP Manual
  • Yaf_Route_Regex
  • The __construct purpose

Yaf_Route_Regex::__construct

(Yaf >=1.0.0)

Yaf_Route_Regex::__construct — The __construct purpose

说明

publicYaf_Route_Regex::__construct ( string $match , array $route , array $map = ? , array $verify = ? )

参数

match

一个完整的正则表达式，用来匹配一个请求的uri，如果不能匹配，Yaf_Route_Regex 将返回FALSE。

route

当路由正则匹配成功请求uri时，Yaf_Route_Regex将会用它来决定哪一个m/c/a被路由。

在这个数组中无论是m/c/a都是最优的，如果你没有提供一个明确的值，它将会以默认方式被路由。 另外, 你也可以使用map的结果作为m/c/a的结果.

map

将匹配到的结果捕捉放到一个已经命名好的数组中。

verify

返回值

范例

Example #1 Yaf_Route_Regex()example

<?php
   /**
    * Add a regex route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Regex(
           "#^/product/([^/]+)/([^/])+#", //match request uri leading "/product"
           array(
               'controller' => "product",  //route to product controller,
           ),
           array(
              1 => "name",   // now you can call $request->getParam("name")
              2 => "id",     // to get the first captrue in the match pattern.
           )
        )
    );
?>

Example #2 Yaf_Route_Regex(as of 2.3.0)()example

<?php
   /**
    *  使用动态的controller
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Regex(
           "#^/product/([^/]+)/([^/])+#", //match request uri leading "/product"
           array(
              'controller' => ":name",  //使用上面匹配的:name, 也就是$1作为controller
           ),
           array(
              1 => "name",   // now you can call $request->getParam("name")
              2 => "id",     // to get the first captrue in the match pattern.
           )
        )
    );
?>

Example #3 Yaf_Route_Regex()example

<?php
   /**
    * Add a regex route to Yaf_Router route stack by calling addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "regex",          //Yaf_Route_Regex route
           "match" => "#(.*)#",         //match arbitrary request uri
           "route" => array(
               'controller' => "product",  //route to product controller,
               'action'     => "dummy",    //route to dummy action
           ),
           "map" => array(
              1 => "uri",   // now you can call $request->getParam("uri")
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

参见

  • Yaf_Router::addRoute() - 往Router中添加新的路由
  • Yaf_Router::addConfig() - 向Router中添加配置文件中定义的路由
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Rewrite
  • Yaf_Route_Map


The route purpose

  • ? Yaf_Route_Regex::__construct
  • Yaf_Route_Rewrite ?
  • PHP Manual
  • Yaf_Route_Regex
  • The route purpose

Yaf_Route_Regex::route

(Yaf >=1.0.0)

Yaf_Route_Regex::route — The route purpose

说明

public Yaf_Route_Regex::route ( Yaf_Request_Abstract $request ) : bool

路由一个传进来的请求。

Warning

本函数还未编写文档，仅有参数列表。

参数

request

返回值

如果正则表达式是Yaf_Route_Regex::_construct()的第一个参数，并且匹配了请求uri，返回TRUE，否则返回FALSE。


The Yaf_Route_Rewrite class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Route_Rewrite extends Yaf_Route_Interface implements Yaf_Route_Interface {
/* 属性 */
protected $_route ;
protected $_default ;
protected $_verify ;
/* 方法 */
public assemble ( array $info , array $query = ? ) : string
public__construct ( string $match , array $route , array $verify = ? )
public route ( Yaf_Request_Abstract $request ) : bool
/* 继承的方法 */
abstract public Yaf_Route_Interface::assemble ( array $info , array $query = ? ) : string
abstract public Yaf_Route_Interface::route ( Yaf_Request_Abstract $request ) : bool
}

属性

_route

_default

_verify

Table of Contents

  • Yaf_Route_Rewrite::assemble — 组合url
  • Yaf_Route_Rewrite::__construct — The __construct purpose
  • Yaf_Route_Rewrite::route — The route purpose


组合url

  • ? Yaf_Route_Rewrite
  • Yaf_Route_Rewrite::__construct ?
  • PHP Manual
  • Yaf_Route_Rewrite
  • 组合url

Yaf_Route_Rewrite::assemble

(Yaf >=2.3.0)

Yaf_Route_Rewrite::assemble — 组合url

说明

public Yaf_Route_Rewrite::assemble ( array $info , array $query = ? ) : string

根据指定参数和自定义参数将rewrite这个route组合成一个url

参数

info

需要传入一个数组，数组中每个key必须和初始化rewrite route时$match参数中的带冒号的参数名一致

query

用户自定义的query string，将根据此路由规则拼接在url中

范例

Example #1 Yaf_Route_Rewrite::assemble()example

router = new Yaf_Router();

$route  = new Yaf_Route_Rewrite(
                "/product/:name/:id/*",
                array(
                        'controller' => "product",
                ),
                array()
);

$router->addRoute("rewrite", $route);

var_dump($router->getRoute('rewrite')->assemble(
                        array(
                                ':name' => 'foo',
                                ':id' => 'bar',
                                ':tmpkey1' => 'tmpval1'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                             )
                        )
);

以上例程的输出类似于：

string(57) "/product/foo/bar/tmpkey1/tmpval1/?tkey1=tval1&tkey2=tval2"

返回值


The __construct purpose

  • ? Yaf_Route_Rewrite::assemble
  • Yaf_Route_Rewrite::route ?
  • PHP Manual
  • Yaf_Route_Rewrite
  • The __construct purpose

Yaf_Route_Rewrite::__construct

(Yaf >=1.0.0)

Yaf_Route_Rewrite::__construct — The __construct purpose

说明

publicYaf_Route_Rewrite::__construct ( string $match , array $route , array $verify = ? )

参数

match

一个类似正则表达式，会被用来匹配一个请求的uri，如果匹配失败，Yaf_Route_Rewrite 会返回FALSE。

route

当路由正则匹配成功请求uri时，Yaf_Route_Rewrite 将会用它来决定哪一个m/c/a被路由。

在这个数组中无论是m/c/a都是最优的，如果你没有提供一个明确的值，它将会以默认方式被路由。

verify

返回值

范例

Example #1 Yaf_Route_Rewrite()example

<?php
   /**
    * Add a rewrite route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_rewrite(
           "/product/:name/:id/*", //match request uri leading "/product"
           array(
               'controller' => "product",  //route to product controller,
           ),
        )
    );
?>

以上例程的输出类似于：

/* for http://yourdomain.com/product/foo/22/foo/bar
 * route will result in following values:
 */
array(
  "controller" => "product",
  "module"     => "index", //(default)
  "action"     => "index", //(default)
)

/**
 * and request parameters:
 */
array(
  "name" => "foo",
  "id"   => 22,
  "foo"  => bar
)

Example #2 Yaf_Route_Rewrite()example

<?php
   /**
    * Add a rewrite route to Yaf_Router route stack by calling addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "rewrite",        //Yaf_Route_Rewrite route
           "match" => "/user-list/:id", //match only /user/list/?/
           "route" => array(
               'controller' => "user",  //route to user controller,
               'action'     => "list",  //route to list action
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

以上例程的输出类似于：

/* for http://yourdomain.com/user-list/22
 * route will result in following values:
 */
array(
  "controller" => "user",
  "action"     => "list",
  "module"     => "index", //(default)
)

/**
 * and request parameters:
 */
array(
  "id"   => 22,
)

Example #3 Yaf_Route_Rewrite(as of 2.3.0)()example

<?php
   /**
    * 使用动态结果作为action名
    */
    $config = array(
        "name" => array(
           "type"  => "rewrite",        //Yaf_Route_Rewrite route
           "match" => "/user-list/:a/:id", //match only /user-list/开头的
           "route" => array(
               'controller' => "user",  //route to user controller,
               'action'     => ":a",  //使用动态的action
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

以上例程的输出类似于：

/* for http://yourdomain.com/user-list/list/22
 * route will result in following values:
 */
array(
  "controller" => "user",
  "action"     => "list",
  "module"     => "index", //(default)
)

/**
 * and request parameters:
 */
array(
  "id"   => 22,
)

参见

  • Yaf_Router::addRoute() - 往Router中添加新的路由
  • Yaf_Router::addConfig() - 向Router中添加配置文件中定义的路由
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Map


The route purpose

  • ? Yaf_Route_Rewrite::__construct
  • Yaf_Router ?
  • PHP Manual
  • Yaf_Route_Rewrite
  • The route purpose

Yaf_Route_Rewrite::route

(Yaf >=1.0.0)

Yaf_Route_Rewrite::route — The route purpose

说明

public Yaf_Route_Rewrite::route ( Yaf_Request_Abstract $request ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

request

返回值


The Yaf_Router class

(Yaf >=1.0.0)

简介

Yaf_Router是标准的框架路由.路由是一个拿到URI端点（URL中的URI的一部分）然后分解参数得到哪一个module, controller, 和action需要接受请求。module, controller, 和action，还有一些其他的参数是打包在一个Yaf_Request_Abstract的对象中，然后通过Yaf_Dispatcher来处理的。路由只发生一次:最初接到请求并且在第一个controller分发之前。 Yaf_Router 是设计来允许使用纯PHP结构的类似功能模块的跳转。它非常松散的基于Ruby on Rails的路由，并且不需要你提前就知道webserver URL跳转的相关知识。它是设计来处理一个Apache 跳转模块的规则（一个） Yaf_Router是设计来允许mod_rewrite

Example #1 Apache的跳转规则

RewriteEngine on
RewriteRule !\.(js|ico|gif|jpg|png|css|html)$ index.php
or (preferred):

Example #2 Apache的跳转规则

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
如果使用Lighttpd，下面的跳转规则是有效的：

Example #3 Lighttpd的跳转规则

url.rewrite-once = (
  ".*\?(.*)$" => "/index.php?$1",
  ".*\.(js|ico|gif|jpg|png|css|html)$" => "$0",
  "" => "/index.php"
)
如果使用Nginx，下面的跳转规则是有效的：

Example #4 Nginx的跳转规则

server {
  listen ****;
  server_name  yourdomain.com;
  root   document_root;
  index  index.php index.html;

  if (!-e $request_filename) {
    rewrite ^/(.*)  /index.php/$1 last;
  }
}

默认路由

Yaf_Router预设了一个默认路由，它将以controller/action的形式匹配URIs。此外，一个module的名字可以被指定为第一路径元素，允许URIs设置为module/controller/action的形式。最后，它也会匹配一些URI中额外附加的参数，默认形式是controller/action/var1/value1/var2/value2。

Note:

Module的名字必须要定义在配置中，就application.module="Index,Foo,Bar"而言，在这种情况下，仅仅index, foo 和 bar能被考虑作为为一个module的名称。如果没有在配置文件中定义，那么Yaf使用默认的module名字"Index"。

如何匹配这些路由的一些例子：

Example #5 Yaf_Route_Static(default route)example

// Assuming the following configure:
$conf = array(
   "application" => array(
      "modules" => "Index,Blog",
   ),
);

Controller only:
http://example/news
    controller == news
Action only(when defined yaf.action_prefer=1 in php.ini)
    action  == news

Invalid module maps to controller name:
http://example/foo
    controller == foo

Module + controller:
http://example/blog/archive
    module     == blog
    controller == archive

Module + controller + action:
http://example/blog/archive/list
    module     == blog
    controller == archive
    action     == list

Module + controller + action + params:
http://example/blog/archive/list/sort/alpha/date/desc
    module     == blog
    controller == archive
    action     == list
    sort       == alpha
    date       == desc

类摘要

Yaf_Router {
/* 属性 */
protected $_routes ;
protected $_current ;
/* 方法 */
public addConfig ( Yaf_Config_Abstract $config ) : void
public addRoute ( string $name , Yaf_Route_Abstract $route ) : Yaf_Router
public__construct ( )
public getCurrentRoute ( ) : string
public getRoute ( string $name ) : void
public getRoutes ( ) : void
public route ( Yaf_Request_Abstract $request ) : bool
}

属性

_routes

_current

Table of Contents

  • Yaf_Router::addConfig — 向Router中添加配置文件中定义的路由
  • Yaf_Router::addRoute — 往Router中添加新的路由
  • Yaf_Router::__construct — Yaf_Router constructor
  • Yaf_Router::getCurrentRoute — 取得当前有效的路由名
  • Yaf_Router::getRoute — The getRoute purpose
  • Yaf_Router::getRoutes — The getRoutes purpose
  • Yaf_Router::route — The route purpose


向Router中添加配置文件中定义的路由

  • ? Yaf_Router
  • Yaf_Router::addRoute ?
  • PHP Manual
  • Yaf_Router
  • 向Router中添加配置文件中定义的路由

Yaf_Router::addConfig

(Yaf >=1.0.0)

Yaf_Router::addConfig — 向Router中添加配置文件中定义的路由

说明

public Yaf_Router::addConfig ( Yaf_Config_Abstract $config ) : void

将application.ini中定义的路由规则添加到Yaf_Router的路由栈中

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 application.ini()example

;the order is very important, the prior one will be called first

;a rewrite route match request /product/*/*
routes.route_name.type="rewrite"
routes.route_name.match="/product/:name/:value"
routes.route_name.route.controller=product
routes.route_name.route.action=info

;a regex route match request /list/*/*
routes.route_name1.type="regex"
routes.route_name1.match="#^list/([^/]*)/([^/]*)#"
routes.route_name1.route.controller=Index
routes.route_name1.route.action=action
routes.route_name1.map.1=name
routes.route_name1.map.2=value

;a simple route match /**?c=controller&a=action&m=module
routes.route_name2.type="simple"
routes.route_name2.controller=c
routes.route_name2.module=m
routes.route_name2.action=a

;a simple router match /**?r=PATH_INFO
routes.route_name3.type="supervar"
routes.route_name3.varname=r

;a map route match any request to controller
routes.route_name4.type="map"
routes.route_name4.controllerPrefer=TRUE
routes.route_namer.delimiter="#!"

Example #2 Yaf_Dispatcher::autoConfig()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        /**
         * we can add some pre-defined routes in application.ini
         */
        $router->addConfig(Yaf_Registry::get("config")->routes);
    }
?>

参见

  • Yaf_Router::addRoute() - 往Router中添加新的路由
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite
  • Yaf_Route_Map


往Router中添加新的路由

  • ? Yaf_Router::addConfig
  • Yaf_Router::__construct ?
  • PHP Manual
  • Yaf_Router
  • 往Router中添加新的路由

Yaf_Router::addRoute

(Yaf >=1.0.0)

Yaf_Router::addRoute — 往Router中添加新的路由

说明

public Yaf_Router::addRoute ( string $name , Yaf_Route_Abstract $route ) : Yaf_Router

默认地，Yaf_Router使用Yaf_Route_Static作为它的默认的路由。你可以通过调用这个方法往Router的堆栈中添加一个新的路由

在路由栈中，新的路由规则会比老的规则先调用，如果新路由规则返回TRUE，那么路由进程将会结束。否则，老的规则将会被调用。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 Yaf_Dispatcher::autoRender()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        /**
         * we can add some pre-defined routes in application.ini
         */
        $router->addConfig(Yaf_Registry::get("config")->routes);
        /**
         * add a Rewrite route, then for a request uri:
         * http://***/product/list/22/foo
         * will be matched by this route, and result:
         *
         *  [module] =>
         *  [controller] => product
         *  [action] => info
         *  [method] => GET
         *  [params:protected] => Array
         *      (
         *          [id] => 22
         *          [name] => foo
         *      )
         *
         */
        $route  = new Yaf_Route_Rewrite(
            "/product/list/:id/:name",
            array(
                "controller" => "product",
                "action"     => "info",
            )
        );

        $router->addRoute('dummy', $route);
    }
?>

参见

  • Yaf_Router::addConfig() - 向Router中添加配置文件中定义的路由
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite
  • Yaf_Route_Map


Yaf_Router constructor

  • ? Yaf_Router::addRoute
  • Yaf_Router::getCurrentRoute ?
  • PHP Manual
  • Yaf_Router
  • Yaf_Router constructor

Yaf_Router::__construct

(Yaf >=1.0.0)

Yaf_Router::__construct — Yaf_Router constructor

说明

publicYaf_Router::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


取得当前有效的路由名

  • ? Yaf_Router::__construct
  • Yaf_Router::getRoute ?
  • PHP Manual
  • Yaf_Router
  • 取得当前有效的路由名

Yaf_Router::getCurrentRoute

(Yaf >=1.0.0)

Yaf_Router::getCurrentRoute — 取得当前有效的路由名

说明

public Yaf_Router::getCurrentRoute ( ) : string

获取当前路由进程中正在起作用的路由名

Note:

你需要在路由进程结束之后调用此方法，在这之前，这个方法会一直返回NULL

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

String，当前起效的路由的名字

范例

Example #1 注册一些路由到Bootstrap

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        $rewrite_route  = new Yaf_Route_Rewrite(
            "/product/list/:page",
            array(
                "controller" => "product",
                "action"     => "list",
            )
        );

        $regex_route  = new Yaf_Route_Rewrite(
            "#^/product/info/(\d+)",
            array(
                "controller" => "product",
                "action"     => "info",
            )
        );

        $router->addRoute('rewrite', $rewrite_route)->addRoute('regex', $regex_route);
    }

    /**
     * register plugin
     */
    public function __initPlugins(Yaf_Dispatcher $dispatcher) {
        $dispatcher->registerPlugin(new DummyPlugin());
    }
?>

Example #2 plugin Dummy.php (under application.directory/plugins)

<?php
class DummyPlugin extends Yaf_Plugin_Abstract {

    public function routerShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
         var_dump(Yaf_Dispatcher::getInstance()->getRouter()->getCurrentRoute());
    }
?>
?>

以上例程的输出类似于：

/* for http://yourdomain.com/product/list/1
 * DummyPlugin will output:
 */
string(7) "rewrite"

/* for http://yourdomain.com/product/info/34
 * DummyPlugin will output:
 */
string(5) "regex"

/* for other request URI
 * DummyPlugin will output:
 */
string(8) "_default"

参见

  • Yaf_Bootstrap_Abstract
  • Yaf_Plugin_Abstract
  • Yaf_Router::addRoute() - 往Router中添加新的路由


The getRoute purpose

  • ? Yaf_Router::getCurrentRoute
  • Yaf_Router::getRoutes ?
  • PHP Manual
  • Yaf_Router
  • The getRoute purpose

Yaf_Router::getRoute

(Yaf >=1.0.0)

Yaf_Router::getRoute — The getRoute purpose

说明

public Yaf_Router::getRoute ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getRoutes purpose

  • ? Yaf_Router::getRoute
  • Yaf_Router::route ?
  • PHP Manual
  • Yaf_Router
  • The getRoutes purpose

Yaf_Router::getRoutes

(Yaf >=1.0.0)

Yaf_Router::getRoutes — The getRoutes purpose

说明

public Yaf_Router::getRoutes ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The route purpose

  • ? Yaf_Router::getRoutes
  • Yaf_Route_Simple ?
  • PHP Manual
  • Yaf_Router
  • The route purpose

Yaf_Router::route

(Yaf >=1.0.0)

Yaf_Router::route — The route purpose

说明

public Yaf_Router::route ( Yaf_Request_Abstract $request ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Route_Simple class

(Yaf >=1.0.0)

简介

Yaf_Route_Simple 会匹配请求中的query string，然后找到路由信息。

你需要做的只是告诉 Yaf_Route_Simple，在$_GET中哪个是Module，哪个是Controller，哪个是Action。

Yaf_Route_Simple::route() 总是会返回TRUE，所以把Yaf_Route_Simple放在路由堆栈前面是很重要的，否则其他所有的路由都可能不会被调用到。

类摘要

Yaf_Route_Simple implements Yaf_Route_Interface {
/* 属性 */
protected $controller ;
protected $module ;
protected $action ;
/* 方法 */
public assemble ( array $info , array $query = ? ) : string
public__construct ( string $module_name , string $controller_name , string $action_name )
public route ( Yaf_Request_Abstract $request ) : bool
}

属性

controller

module

action

Table of Contents

  • Yaf_Route_Simple::assemble — 组合url
  • Yaf_Route_Simple::__construct — Yaf_Route_Simple constructor
  • Yaf_Route_Simple::route — Route a request


组合url

  • ? Yaf_Route_Simple
  • Yaf_Route_Simple::__construct ?
  • PHP Manual
  • Yaf_Route_Simple
  • 组合url

Yaf_Route_Simple::assemble

(Yaf >=2.3.0)

Yaf_Route_Simple::assemble — 组合url

说明

public Yaf_Route_Simple::assemble ( array $info , array $query = ? ) : string

根据指定参数和自定义参数将simple这个route组合成一个url

参数

info

需要传入一个数组，数组中每个key可为:m、:c、:a，:m代表module，:c代表controller, :a代表action

query

用户自定义的query string，将根据此路由规则拼接在url中

范例

Example #1 Yaf_Route_Simple::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Simple('m', 'c', 'a');

$router->addRoute("simple", $route);

var_dump($router->getRoute('simple')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
                ),
            array(
                'tkey1' => 'tval1',
                'tkey2' => 'tval2'
                )
            ));

以上例程的输出类似于：

string(64) "?m=yafmodule&c=yafcontroller&a=yafaction&tkey1=tval1&tkey2=tval2"

返回值


Yaf_Route_Simple constructor

  • ? Yaf_Route_Simple::assemble
  • Yaf_Route_Simple::route ?
  • PHP Manual
  • Yaf_Route_Simple
  • Yaf_Route_Simple constructor

Yaf_Route_Simple::__construct

(Yaf >=1.0.0)

Yaf_Route_Simple::__construct — Yaf_Route_Simple constructor

说明

publicYaf_Route_Simple::__construct ( string $module_name , string $controller_name , string $action_name )

Yaf_Route_Simple将从query string中获得路由信息。这个构造函数的参数会被作为键到$_GET中去寻找路由信息。

Warning

本函数还未编写文档，仅有参数列表。

参数

module_name

module信息的键名。

controller_name

controller信息的键名。

action_name

action信息的键名。

返回值

总是返回TRUE

范例

Example #1 Yaf_Route_Simple::route()example

<?php
   $route = new Yaf_Route_Simple("m", "controller", "act");
   Yaf_Router::getInstance()->addRoute("simple", $route);
?>

Example #2 Yaf_Route_Simple::route()example

Request: http://yourdomain.com/path/?controller=a&act=b
=> module = default(index), controller = a, action = b

Request: http://yourdomain.com/path
=> module = default(index), controller = default(index), action = default(index)

参见

  • Yaf_Route_Supervar::route() - The route purpose
  • Yaf_Route_Static::route() - Route a request
  • Yaf_Route_Regex::route() - The route purpose
  • Yaf_Route_Rewrite::route() - The route purpose
  • Yaf_Route_Map::route() - The route purpose


Route a request

  • ? Yaf_Route_Simple::__construct
  • Yaf_Route_Static ?
  • PHP Manual
  • Yaf_Route_Simple
  • Route a request

Yaf_Route_Simple::route

(Yaf >=1.0.0)

Yaf_Route_Simple::route — Route a request

说明

public Yaf_Route_Simple::route ( Yaf_Request_Abstract $request ) : bool

see Yaf_Route_Simple::__construct()

Warning

本函数还未编写文档，仅有参数列表。

参数

request

返回值

always be TRUE

参见

  • Yaf_Route_Supervar::route() - The route purpose
  • Yaf_Route_Static::route() - Route a request
  • Yaf_Route_Regex::route() - The route purpose
  • Yaf_Route_Rewrite::route() - The route purpose
  • Yaf_Route_Map::route() - The route purpose


The Yaf_Route_Static class

(Yaf >=1.0.0)

简介

默认的，Yaf_Router 只有一个Yaf_Route_Static 作为它默认的路由

Yaf_Route_Static 旨在处理80%的要求。

请注意：实例化 Yaf_Route_Static 是没有必要的，也没必要将它加入Yaf_Router的路由堆栈，因为在Yaf_Router的路由堆栈中总是存在它的一个实例，并且总是在最后被调用。

类摘要

Yaf_Route_Static implements Yaf_Router {
/* 方法 */
public assemble ( array $info , array $query = ? ) : string
public match ( string $uri ) : void
public route ( Yaf_Request_Abstract $request ) : bool
}

Table of Contents

  • Yaf_Route_Static::assemble — 组合url
  • Yaf_Route_Static::match — The match purpose
  • Yaf_Route_Static::route — Route a request


组合url

  • ? Yaf_Route_Static
  • Yaf_Route_Static::match ?
  • PHP Manual
  • Yaf_Route_Static
  • 组合url

Yaf_Route_Static::assemble

(Yaf >=2.3.0)

Yaf_Route_Static::assemble — 组合url

说明

public Yaf_Route_Static::assemble ( array $info , array $query = ? ) : string

根据指定参数和自定义参数将static这个route组合成一个url

参数

info

需要传入一个数组，数组中每个key可为:m、:c、:a，:m代表module，:c代表controller, :a代表action

query

用户自定义的query string，将根据此路由规则拼接在url中

范例

Example #1 Yaf_Route_Static::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Static();

$router->addRoute("static", $route);

var_dump($router->getRoute('static')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
            ),
        )
);

var_dump($router->getRoute('static')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
            ),
            array(
                'tkey1' => 'tval1',
                'tkey2' => 'tval2'
            )
        )
);

以上例程的输出类似于：

string(%d) "/yafmodule/yafcontroller/yafaction"
string(%d) "/yafmodule/yafcontroller/yafaction?tkey1=tval1&tkey2=tval2"

返回值


The match purpose

  • ? Yaf_Route_Static::assemble
  • Yaf_Route_Static::route ?
  • PHP Manual
  • Yaf_Route_Static
  • The match purpose

Yaf_Route_Static::match

(Yaf >=1.0.0)

Yaf_Route_Static::match — The match purpose

说明

public Yaf_Route_Static::match ( string $uri ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

uri

返回值


Route a request

  • ? Yaf_Route_Static::match
  • Yaf_Route_Supervar ?
  • PHP Manual
  • Yaf_Route_Static
  • Route a request

Yaf_Route_Static::route

(Yaf >=1.0.0)

Yaf_Route_Static::route — Route a request

说明

public Yaf_Route_Static::route ( Yaf_Request_Abstract $request ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

request

返回值

总是返回TRUE

范例

Example #1 Yaf_Route_Static::route()example

// assuming there is only one module defined:Index
Request: http://yourdomain.com/a/b
=> module = index, controller=a, action=b

//assuming ap.action_prefer = On
Request: http://yourdomain.com/b
=> module = default(index), controller = default(index), action = b

//assuming ap.action_prefer = Off
Request: http://yourdomain.com/b
=> module = default(index), controller = b, action = default(index)

Request: http://yourdomain.com/a/b/foo/bar/test/a/id/4
=> module = default(index), controller = a, action = b, request parameters: foo = bar, test = a, id = 4

参见

  • Yaf_Route_Supervar::route() - The route purpose
  • Yaf_Route_Simple::route() - Route a request
  • Yaf_Route_Regex::route() - The route purpose
  • Yaf_Route_Rewrite::route() - The route purpose
  • Yaf_Route_Map::route() - The route purpose


The Yaf_Route_Supervar class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Route_Supervar implements Yaf_Route_Interface {
/* 属性 */
protected $_var_name ;
/* 方法 */
public assemble ( array $info , array $query = ? ) : string
public__construct ( string $supervar_name )
public route ( Yaf_Request_Abstract $request ) : bool
}

属性

_var_name

Table of Contents

  • Yaf_Route_Supervar::assemble — 组合url
  • Yaf_Route_Supervar::__construct — The __construct purpose
  • Yaf_Route_Supervar::route — The route purpose


组合url

  • ? Yaf_Route_Supervar
  • Yaf_Route_Supervar::__construct ?
  • PHP Manual
  • Yaf_Route_Supervar
  • 组合url

Yaf_Route_Supervar::assemble

(Yaf >=2.3.0)

Yaf_Route_Supervar::assemble — 组合url

说明

public Yaf_Route_Supervar::assemble ( array $info , array $query = ? ) : string

根据指定参数和自定义参数将supervar这个route组合成一个url

参数

info

需要传入一个数组，数组中每个key可为:m、:c、:a，:m代表module，:c代表controller, :a代表action

query

用户自定义的query string，将根据此路由规则拼接在url中

范例

Example #1 Yaf_Route_Supervar::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Supervar('r');

$router->addRoute("supervar", $route);

var_dump($router->getRoute('supervar')->assemble(
        array(
              ':a' => 'yafaction',
              'tkey' => 'tval',
              ':c' => 'yafcontroller',
              ':m' => 'yafmodule'
        ),
        array(
              'tkey1' => 'tval1',
              'tkey2' => 'tval2'
        )
));

try {
var_dump($router->getRoute('supervar')->assemble(
        array(
              ':a' => 'yafaction',
              'tkey' => 'tval',
              ':m' => 'yafmodule'
        ),
        array(
              'tkey1' => 'tval1',
              'tkey2' => 'tval2',
              1 => array(),
        )
));
} catch (Exception $e) {
    var_dump($e->getMessage());
}

以上例程的输出类似于：

string(%d) "?r=/yafmodule/yafcontroller/yafaction&tkey1=tval1&tkey2=tval2"
string(%d) "You need to specify the controller by ':c'"

返回值


The __construct purpose

  • ? Yaf_Route_Supervar::assemble
  • Yaf_Route_Supervar::route ?
  • PHP Manual
  • Yaf_Route_Supervar
  • The __construct purpose

Yaf_Route_Supervar::__construct

(Yaf >=1.0.0)

Yaf_Route_Supervar::__construct — The __construct purpose

说明

publicYaf_Route_Supervar::__construct ( string $supervar_name )

Yaf_Route_Supervar 类似于 Yaf_Route_Static，不同的是Yaf_Route_Supervar 在query string 中寻找路劲信息，参数 supervar_name 是建。

Warning

本函数还未编写文档，仅有参数列表。

参数

supervar_name

键名

返回值

范例

Example #1 Yaf_Route_Supervar()example

<?php
   /**
    * Add a supervar route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Supervar("r"));
    );
?>

以上例程的输出类似于：

/** for request: http://yourdomain.com/xx/oo/?r=/ctr/act/var/value
  * will result in following:
  */
  array (
    "module"   => index(default),
    "controller" => ctr,
    "action"     => act,
    "params"     => array(
          "var" => value,
     )
  )

参见

  • Yaf_Router::addRoute() - 往Router中添加新的路由
  • Yaf_Router::addConfig() - 向Router中添加配置文件中定义的路由
  • Yaf_Route_Static
  • Yaf_Route_Regex
  • Yaf_Route_Simple
  • Yaf_Route_Rewrite
  • Yaf_Route_Map


The route purpose

  • ? Yaf_Route_Supervar::__construct
  • Yaf_Session ?
  • PHP Manual
  • Yaf_Route_Supervar
  • The route purpose

Yaf_Route_Supervar::route

(Yaf >=1.0.0)

Yaf_Route_Supervar::route — The route purpose

说明

public Yaf_Route_Supervar::route ( Yaf_Request_Abstract $request ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

request

返回值

如果在$_GET中有键（在Yaf_Route_Supervar::__construct()中定义），返回TRUE，否则返回FALSE。


The Yaf_Session class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Session implements Iterator , Traversable , ArrayAccess , Countable {
/* 属性 */
protected static $_instance ;
protected $_session ;
protected $_started ;
/* 方法 */
__construct ( )
public count ( ) : void
public current ( ) : void
public del ( string $name ) : void
public __get ( string $name ) : void
public static getInstance ( ) : void
public has ( string $name ) : void
public __isset ( string $name ) : void
public key ( ) : void
public next ( ) : void
public offsetExists ( string $name ) : void
public offsetGet ( string $name ) : void
public offsetSet ( string $name , string $value ) : void
public offsetUnset ( string $name ) : void
public rewind ( ) : void
public __set ( string $name , string $value ) : void
public start ( ) : void
public __unset ( string $name ) : void
public valid ( ) : void
}

属性

_instance

_session

_started

Table of Contents

  • Yaf_Session::__construct — The __construct purpose
  • Yaf_Session::count — The count purpose
  • Yaf_Session::current — The current purpose
  • Yaf_Session::del — The del purpose
  • Yaf_Session::__get — The __get purpose
  • Yaf_Session::getInstance — The getInstance purpose
  • Yaf_Session::has — The has purpose
  • Yaf_Session::__isset — The __isset purpose
  • Yaf_Session::key — The key purpose
  • Yaf_Session::next — The next purpose
  • Yaf_Session::offsetExists — The offsetExists purpose
  • Yaf_Session::offsetGet — The offsetGet purpose
  • Yaf_Session::offsetSet — The offsetSet purpose
  • Yaf_Session::offsetUnset — The offsetUnset purpose
  • Yaf_Session::rewind — The rewind purpose
  • Yaf_Session::__set — The __set purpose
  • Yaf_Session::start — The start purpose
  • Yaf_Session::__unset — The __unset purpose
  • Yaf_Session::valid — The valid purpose


The __construct purpose

  • ? Yaf_Session
  • Yaf_Session::count ?
  • PHP Manual
  • Yaf_Session
  • The __construct purpose

Yaf_Session::__construct

(Yaf >=1.0.0)

Yaf_Session::__construct — The __construct purpose

说明

Yaf_Session::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The count purpose

  • ? Yaf_Session::__construct
  • Yaf_Session::current ?
  • PHP Manual
  • Yaf_Session
  • The count purpose

Yaf_Session::count

(Yaf >=1.0.0)

Yaf_Session::count — The count purpose

说明

public Yaf_Session::count ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The current purpose

  • ? Yaf_Session::count
  • Yaf_Session::del ?
  • PHP Manual
  • Yaf_Session
  • The current purpose

Yaf_Session::current

(Yaf >=1.0.0)

Yaf_Session::current — The current purpose

说明

public Yaf_Session::current ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The del purpose

  • ? Yaf_Session::current
  • Yaf_Session::__get ?
  • PHP Manual
  • Yaf_Session
  • The del purpose

Yaf_Session::del

(Yaf >=1.0.0)

Yaf_Session::del — The del purpose

说明

public Yaf_Session::del ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


The __get purpose

  • ? Yaf_Session::del
  • Yaf_Session::getInstance ?
  • PHP Manual
  • Yaf_Session
  • The __get purpose

Yaf_Session::__get

(Yaf >=1.0.0)

Yaf_Session::__get — The __get purpose

说明

public Yaf_Session::__get ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


The getInstance purpose

  • ? Yaf_Session::__get
  • Yaf_Session::has ?
  • PHP Manual
  • Yaf_Session
  • The getInstance purpose

Yaf_Session::getInstance

(Yaf >=1.0.0)

Yaf_Session::getInstance — The getInstance purpose

说明

public static Yaf_Session::getInstance ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The has purpose

  • ? Yaf_Session::getInstance
  • Yaf_Session::__isset ?
  • PHP Manual
  • Yaf_Session
  • The has purpose

Yaf_Session::has

(Yaf >=1.0.0)

Yaf_Session::has — The has purpose

说明

public Yaf_Session::has ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


The __isset purpose

  • ? Yaf_Session::has
  • Yaf_Session::key ?
  • PHP Manual
  • Yaf_Session
  • The __isset purpose

Yaf_Session::__isset

(Yaf >=1.0.0)

Yaf_Session::__isset — The __isset purpose

说明

public Yaf_Session::__isset ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


The key purpose

  • ? Yaf_Session::__isset
  • Yaf_Session::next ?
  • PHP Manual
  • Yaf_Session
  • The key purpose

Yaf_Session::key

(Yaf >=1.0.0)

Yaf_Session::key — The key purpose

说明

public Yaf_Session::key ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The next purpose

  • ? Yaf_Session::key
  • Yaf_Session::offsetExists ?
  • PHP Manual
  • Yaf_Session
  • The next purpose

Yaf_Session::next

(Yaf >=1.0.0)

Yaf_Session::next — The next purpose

说明

public Yaf_Session::next ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The offsetExists purpose

  • ? Yaf_Session::next
  • Yaf_Session::offsetGet ?
  • PHP Manual
  • Yaf_Session
  • The offsetExists purpose

Yaf_Session::offsetExists

(Yaf >=1.0.0)

Yaf_Session::offsetExists — The offsetExists purpose

说明

public Yaf_Session::offsetExists ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


The offsetGet purpose

  • ? Yaf_Session::offsetExists
  • Yaf_Session::offsetSet ?
  • PHP Manual
  • Yaf_Session
  • The offsetGet purpose

Yaf_Session::offsetGet

(Yaf >=1.0.0)

Yaf_Session::offsetGet — The offsetGet purpose

说明

public Yaf_Session::offsetGet ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


The offsetSet purpose

  • ? Yaf_Session::offsetGet
  • Yaf_Session::offsetUnset ?
  • PHP Manual
  • Yaf_Session
  • The offsetSet purpose

Yaf_Session::offsetSet

(Yaf >=1.0.0)

Yaf_Session::offsetSet — The offsetSet purpose

说明

public Yaf_Session::offsetSet ( string $name , string $value ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值


The offsetUnset purpose

  • ? Yaf_Session::offsetSet
  • Yaf_Session::rewind ?
  • PHP Manual
  • Yaf_Session
  • The offsetUnset purpose

Yaf_Session::offsetUnset

(Yaf >=1.0.0)

Yaf_Session::offsetUnset — The offsetUnset purpose

说明

public Yaf_Session::offsetUnset ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


The rewind purpose

  • ? Yaf_Session::offsetUnset
  • Yaf_Session::__set ?
  • PHP Manual
  • Yaf_Session
  • The rewind purpose

Yaf_Session::rewind

(Yaf >=1.0.0)

Yaf_Session::rewind — The rewind purpose

说明

public Yaf_Session::rewind ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The __set purpose

  • ? Yaf_Session::rewind
  • Yaf_Session::start ?
  • PHP Manual
  • Yaf_Session
  • The __set purpose

Yaf_Session::__set

(Yaf >=1.0.0)

Yaf_Session::__set — The __set purpose

说明

public Yaf_Session::__set ( string $name , string $value ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

value

返回值


The start purpose

  • ? Yaf_Session::__set
  • Yaf_Session::__unset ?
  • PHP Manual
  • Yaf_Session
  • The start purpose

Yaf_Session::start

(Yaf >=1.0.0)

Yaf_Session::start — The start purpose

说明

public Yaf_Session::start ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The __unset purpose

  • ? Yaf_Session::start
  • Yaf_Session::valid ?
  • PHP Manual
  • Yaf_Session
  • The __unset purpose

Yaf_Session::__unset

(Yaf >=1.0.0)

Yaf_Session::__unset — The __unset purpose

说明

public Yaf_Session::__unset ( string $name ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


The valid purpose

  • ? Yaf_Session::__unset
  • Yaf_Exception ?
  • PHP Manual
  • Yaf_Session
  • The valid purpose

Yaf_Session::valid

(Yaf >=1.0.0)

Yaf_Session::valid — The valid purpose

说明

public Yaf_Session::valid ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Exception class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception extends Exception {
/* 属性 */
protected $message ;
protected $code ;
protected $previous ;
/* 方法 */
public __construct ( )
public getPrevious ( ) : void
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

message

code

file

line

previous

Table of Contents

  • Yaf_Exception::__construct — The __construct purpose
  • Yaf_Exception::getPrevious — The getPrevious purpose


The __construct purpose

  • ? Yaf_Exception
  • Yaf_Exception::getPrevious ?
  • PHP Manual
  • Yaf_Exception
  • The __construct purpose

Yaf_Exception::__construct

(Yaf >=1.0.0)

Yaf_Exception::__construct — The __construct purpose

说明

public Yaf_Exception::__construct ( )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The getPrevious purpose

  • ? Yaf_Exception::__construct
  • Yaf_Exception_TypeError ?
  • PHP Manual
  • Yaf_Exception
  • The getPrevious purpose

Yaf_Exception::getPrevious

(Yaf >=1.0.0)

Yaf_Exception::getPrevious — The getPrevious purpose

说明

public Yaf_Exception::getPrevious ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The Yaf_Exception_TypeError class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_TypeError extends Yaf_Exception {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


The Yaf_Exception_StartupError class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_StartupError extends Yaf_Exception {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


The Yaf_Exception_DispatchFailed class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_DispatchFailed extends Yaf_Exception {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


The Yaf_Exception_RouterFailed class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_RouterFailed extends Yaf_Exception {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


The Yaf_Exception_LoadFailed class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_LoadFailed extends Yaf_Exception {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


The Yaf_Exception_LoadFailed_Module class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_LoadFailed_Module extends Yaf_Exception_LoadFailed {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


The Yaf_Exception_LoadFailed_Controller class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_LoadFailed_Controller extends Yaf_Exception_LoadFailed {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


The Yaf_Exception_LoadFailed_Action class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_LoadFailed_Action extends Yaf_Exception_LoadFailed {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


The Yaf_Exception_LoadFailed_View class

(Yaf >=1.0.0)

简介

类摘要

Yaf_Exception_LoadFailed_View extends Yaf_Exception_LoadFailed {
/* 属性 */
/* 方法 */
/* 继承的方法 */
public Yaf_Exception::__construct ( )
public Yaf_Exception::getPrevious ( ) : void
}


Yaconf

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Yaconf — The Yaconf class
    • Yaconf::get — Retrieve a item
    • Yaconf::has — Determine if a item exists


简介

Yet Another Configurations Container (Yaconf) is a configurations container, it parses INI files, and store the result in PHP when PHP is started, the result lives with the whole PHP lifecycle.

Yaconf stores all configurations as interned string or immutable array, which means they are not refcounted-able, thus when you retrieving configurations from yaconf, it could be considered as zero-copy, very fast.

Yaconf supports sections and sections inheritance in INI files. if PHP is built as non-ZTS build, Yaconf also supports automatically reloading after INI files are changed.

Yaconf requires PHP 7.0 or greater.

Example #1 INI example

;simple key val
key=val
;hash
hash.a=val
;array
arr.0=val
;or
arr[]=val
;use PHP constants
version=PHP_VERION
;use enviroment
env=${PATH}

Example #2 INI sections example

[SectionA]
key=val
hash.a=val

;SectionB inherits SectionA
[SectionB:SectionA]
;override configuration key in SectionA
key=new_val


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

Yaconf requires PHP 7.0 and above.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/yaconf.

此扩展在 Windows 平台的二进制扩展 (DLL 文件) PECL 可以在 PECL 官方网站上下载。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Yaconf 配置选项
名字 | 默认 | 可修改范围 | 更新日志
yaconf.check_delay | 300 | PHP_INI_SYSTEM |
yaconf.directory | /tmp/conf/ | PHP_INI_SYSTEM |

这是配置指令的简短说明。

yaconf.check_delay int

In which interval Yaconf will detect ini file's change(by directory's mtime), if it is set to zero, you have to restart php to reloading configurations.

yaconf.directory string

Path to directory which all INI configuration files are placed in.


  • ? 资源类型
  • Yaconf ?
  • PHP Manual
  • Yaconf
  • 预定义常量

预定义常量

此扩展没有定义常量。


The Yaconf class

(PECL yaconf >= 1.0.0)

简介

Yaconf is a configurations container, it parses INIT files, stores the result in PHP when PHP is started, the result lives with the whole PHP lifecycle.

类摘要

Yaconf {
/* 方法 */
public static get ( string $name , mixed $default_value = NULL ) : mixed
public static has ( string $name ) : bool
}

Table of Contents

  • Yaconf::get — Retrieve a item
  • Yaconf::has — Determine if a item exists


Retrieve a item

  • ? Yaconf
  • Yaconf::has ?
  • PHP Manual
  • Yaconf
  • Retrieve a item

Yaconf::get

(PECL yaconf >= 1.0.0)

Yaconf::get — Retrieve a item

说明

public static Yaconf::get ( string $name , mixed $default_value = NULL ) : mixed

参数

name

Configuration key, the key looks like "filename.key", or "filename.sectionName,key".

default_value

if the key doesn't exists, Yaconf::get will return this as result.

返回值

Returns configuration result(string or array) if the key exists, return default_value if not.

范例

Example #1 INI()example

;filenmame foo.ini, placed in directory which is yaconf.directoy
[SectionA]
;key value pair
key=val
;hash[a]=val
hash.a=val
;arr[0]=val
arr.0=val
;or
arr[]=val

;SectionB inherits SectionA
[SectionB:SectionA]
;override configuration key in SectionA
key=new_val

以上例程的输出类似于：

php7 -r 'var_dump(Yaconf::get("foo.SectionA.key"));'
//string(3) "val"

php7 -r 'var_dump(Yaconf::get("foo.SectionB.key"));'
//string(7) "new_val"

php7 -r 'var_dump(Yaconf::get("foo")["SectionA"]["hash"]);'
//array(1)


Determine if a item exists

  • ? Yaconf::get
  • Taint ?
  • PHP Manual
  • Yaconf
  • Determine if a item exists

Yaconf::has

(PECL yaconf >= 1.0.0)

Yaconf::has — Determine if a item exists

说明

public static Yaconf::has ( string $name ) : bool

参数

name

返回值


Taint

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • More Details
    • Functions and Statements which will spread the tainted mark of a tainted string
    • Functions and statements which will check tainted string
    • Functions which untaint the tainted string
  • Taint 函数
    • is_tainted — Checks whether a string is tainted
    • taint — Taint a string
    • untaint — Untaint strings


简介

Taint is an extension, which is used for detecting XSS codes(tainted string). And also can be used to spot sql injection vulnerabilities, and shell inject, etc.

When taint is enabled, if you pass a tainted string (comes from $_GET, $_POST or $_COOKIE) to some functions, taint will warn you about that.

Example #1 Taint()example

<?php
$a = trim($_GET['a']);

$file_name = '/tmp' .  $a;
$output    = "Welcome, {$a} !!!";
$var       = "output";
$sql       = "Select *  from " . $a;
$sql      .= "ooxx";

echo $output;

print $$var;

include($file_name);

mysql_query($sql);
?>

以上例程的输出类似于：

Warning: main() [function.echo]: Attempt to echo a string that might be tainted

Warning: main() [function.echo]: Attempt to print a string that might be tainted

Warning: include() [function.include]: File path contains data that might be tainted

Warning: mysql_query() [function.mysql-query]: SQL statement contains data that might be tainted


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/taint.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Taint 配置选项
名字 | 默认 | 可修改范围 | 更新日志
taint.enable | 0 | PHP_INI_SYSTEM |
taint.error_level | E_WARNING | PHP_INI_ALL |

这是配置指令的简短说明。

taint.enable int

Whether enable the taint.

taint.error_level int

the error type which taint will report as when taint find a tainted string.


  • ? 运行时配置
  • More Details ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


More Details

Table of Contents

  • Functions and Statements which will spread the tainted mark of a tainted string
  • Functions and statements which will check tainted string
  • Functions which untaint the tainted string


Functions and Statements which will spread the tainted mark of a tainted string

Function/Statement | Since
= (assign) | 0.1.0
. (concat) | 0.1.0
"{$var}" (variable substitution) | 0.1.0
.= (assign concat) | 0.1.0
strval | 0.3.0
explode/split | 0.3.0
implode/join | 0.3.0
sprintf | 0.3.0
vsprintf | 0.3.0
trim | 0.4.0
rtrim | 0.4.0
ltrim | 0.4.0
strstr | 0.5.0
str_pad | 0.5.0
str_replace | 0.5.0
substr | 0.5.0
strtolower | 0.5.0
strtoupper | 0.5.0


Functions and statements which will check tainted string

Function/Statement | Since
Basic statments
eval | 0.1.0
include/include_once | 0.1.0
require/require_once | 0.1.0
Outputing Functions
echo | 0.1.0
print | 0.1.0
printf | 0.1.0
file_put_contents | 0.1.0
File System Functions
fopen | 0.2.0
opendir | 0.2.0
basename | 0.2.0
dirname | 0.2.0
file | 0.2.0
pathinfo | 0.2.0
Database relevant Functions
mysql_query | 0.2.0
mysqli_query/MySQLi::query | 0.2.0
sqlite_query/SqliteDataBase::query | 0.3.0
sqlite_single_query/SqliteDataBase::singleQuery | 0.3.0
oci_parse | 0.3.0
PDO::query | 0.3.0
PDO::prepare | 0.3.0
SQLite3::query | 2.0.1
SQLite3::prepare | 2.0.1
Command Line relevant Functions
system | 0.1.0
exec | 0.1.0
proc_open | 0.1.0
passthru | 0.1.0
shell_exec | 0.3.0


Functions which untaint the tainted string

Function | Since
addslashes | 0.1.0
addcslashes | 0.1.0
htmlspecialchars | 0.1.0
htmlentities | 0.1.0
escapeshellcmd | 0.1.0
mysql_escape_string | 0.1.0
mysql_real_escape_string | 0.1.0
mysqli_escape_string/MySQLi::escape_string | 0.1.0
mysqli_real_escape_string/MySQLi::real_escape_string | 0.1.0
sqlite_escape_string/SqliteDataBase::escapeString | 0.3.0
PDO::quote | 0.3.0


Taint 函数

Table of Contents

  • is_tainted — Checks whether a string is tainted
  • taint — Taint a string
  • untaint — Untaint strings


Checks whether a string is tainted

  • ? Taint 函数
  • taint ?
  • PHP Manual
  • Taint 函数
  • Checks whether a string is tainted

is_tainted

(PECL taint >=0.1.0)

is_tainted — Checks whether a string is tainted

说明

is_tainted ( string $string ) : bool

Checks whether a string is tainted

参数

string

返回值

Return TRUE if the string is tainted, FALSE otherwise.


Taint a string

  • ? is_tainted
  • untaint ?
  • PHP Manual
  • Taint 函数
  • Taint a string

taint

(PECL taint >=0.1.0)

taint — Taint a string

说明

taint ( string &$string , string ...$strings ) : bool

Make a string tainted. This is used for testing purpose only.

参数

string

strings

返回值

Return TRUE if the transformation is done. Always return TRUE if the taint extension is not enabled.


Untaint strings

  • ? taint
  • Data Structures ?
  • PHP Manual
  • Taint 函数
  • Untaint strings

untaint

(PECL taint >=0.1.0)

untaint — Untaint strings

说明

untaint ( string &$string , string ...$strings ) : bool

Untaint strings

参数

string

strings

返回值


Data Structures

  • 简介
  • 安装／配置
    • 需求
    • 安装
  • 预定义常量
  • 范例
  • Collection — The Collection interface
    • Ds\Collection::clear — Removes all values
    • Ds\Collection::copy — Returns a shallow copy of the collection
    • Ds\Collection::isEmpty — Returns whether the collection is empty
    • Ds\Collection::toArray — Converts the collection to an array
  • Hashable — The Hashable interface
    • Ds\Hashable::equals — Determines whether an object is equal to the current instance
    • Ds\Hashable::hash — Returns a scalar value to be used as a hash value
  • Sequence — The Sequence interface
    • Ds\Sequence::allocate — Allocates enough memory for a required capacity
    • Ds\Sequence::apply — Updates all values by applying a callback function to each value
    • Ds\Sequence::capacity — Returns the current capacity
    • Ds\Sequence::contains — Determines if the sequence contains given values
    • Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include
    • Ds\Sequence::find — Attempts to find a value's index
    • Ds\Sequence::first — Returns the first value in the sequence
    • Ds\Sequence::get — Returns the value at a given index
    • Ds\Sequence::insert — Inserts values at a given index
    • Ds\Sequence::join — Joins all values together as a string
    • Ds\Sequence::last — Returns the last value
    • Ds\Sequence::map — Returns the result of applying a callback to each value
    • Ds\Sequence::merge — Returns the result of adding all given values to the sequence
    • Ds\Sequence::pop — Removes and returns the last value
    • Ds\Sequence::push — Adds values to the end of the sequence
    • Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function
    • Ds\Sequence::remove — Removes and returns a value by index
    • Ds\Sequence::reverse — Reverses the sequence in-place
    • Ds\Sequence::reversed — Returns a reversed copy
    • Ds\Sequence::rotate — Rotates the sequence by a given number of rotations
    • Ds\Sequence::set — Updates a value at a given index
    • Ds\Sequence::shift — Removes and returns the first value
    • Ds\Sequence::slice — Returns a sub-sequence of a given range
    • Ds\Sequence::sort — Sorts the sequence in-place
    • Ds\Sequence::sorted — Returns a sorted copy
    • Ds\Sequence::sum — Returns the sum of all values in the sequence
    • Ds\Sequence::unshift — Adds values to the front of the sequence
  • Vector — The Vector class
    • Ds\Vector::allocate — Allocates enough memory for a required capacity
    • Ds\Vector::apply — Updates all values by applying a callback function to each value
    • Ds\Vector::capacity — Returns the current capacity
    • Ds\Vector::clear — Removes all values
    • Ds\Vector::__construct — Creates a new instance
    • Ds\Vector::contains — Determines if the vector contains given values
    • Ds\Vector::copy — Returns a shallow copy of the vector
    • Ds\Vector::count — Returns the number of values in the collection
    • Ds\Vector::filter — Creates a new vector using a callable to determine which values to include
    • Ds\Vector::find — Attempts to find a value's index
    • Ds\Vector::first — Returns the first value in the vector
    • Ds\Vector::get — Returns the value at a given index
    • Ds\Vector::insert — Inserts values at a given index
    • Ds\Vector::isEmpty — Returns whether the vector is empty
    • Ds\Vector::join — Joins all values together as a string
    • Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Vector::last — Returns the last value
    • Ds\Vector::map — Returns the result of applying a callback to each value
    • Ds\Vector::merge — Returns the result of adding all given values to the vector
    • Ds\Vector::pop — Removes and returns the last value
    • Ds\Vector::push — Adds values to the end of the vector
    • Ds\Vector::reduce — Reduces the vector to a single value using a callback function
    • Ds\Vector::remove — Removes and returns a value by index
    • Ds\Vector::reverse — Reverses the vector in-place
    • Ds\Vector::reversed — Returns a reversed copy
    • Ds\Vector::rotate — Rotates the vector by a given number of rotations
    • Ds\Vector::set — Updates a value at a given index
    • Ds\Vector::shift — Removes and returns the first value
    • Ds\Vector::slice — Returns a sub-vector of a given range
    • Ds\Vector::sort — Sorts the vector in-place
    • Ds\Vector::sorted — Returns a sorted copy
    • Ds\Vector::sum — Returns the sum of all values in the vector
    • Ds\Vector::toArray — Converts the vector to an array
    • Ds\Vector::unshift — Adds values to the front of the vector
  • Deque — The Deque class
    • Ds\Deque::allocate — Allocates enough memory for a required capacity
    • Ds\Deque::apply — Updates all values by applying a callback function to each value
    • Ds\Deque::capacity — Returns the current capacity
    • Ds\Deque::clear — Removes all values from the deque
    • Ds\Deque::__construct — Creates a new instance
    • Ds\Deque::contains — Determines if the deque contains given values
    • Ds\Deque::copy — Returns a shallow copy of the deque
    • Ds\Deque::count — Returns the number of values in the collection
    • Ds\Deque::filter — Creates a new deque using a callable to determine which values to include
    • Ds\Deque::find — Attempts to find a value's index
    • Ds\Deque::first — Returns the first value in the deque
    • Ds\Deque::get — Returns the value at a given index
    • Ds\Deque::insert — Inserts values at a given index
    • Ds\Deque::isEmpty — Returns whether the deque is empty
    • Ds\Deque::join — Joins all values together as a string
    • Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Deque::last — Returns the last value
    • Ds\Deque::map — Returns the result of applying a callback to each value
    • Ds\Deque::merge — Returns the result of adding all given values to the deque
    • Ds\Deque::pop — Removes and returns the last value
    • Ds\Deque::push — Adds values to the end of the deque
    • Ds\Deque::reduce — Reduces the deque to a single value using a callback function
    • Ds\Deque::remove — Removes and returns a value by index
    • Ds\Deque::reverse — Reverses the deque in-place
    • Ds\Deque::reversed — Returns a reversed copy
    • Ds\Deque::rotate — Rotates the deque by a given number of rotations
    • Ds\Deque::set — Updates a value at a given index
    • Ds\Deque::shift — Removes and returns the first value
    • Ds\Deque::slice — Returns a sub-deque of a given range
    • Ds\Deque::sort — Sorts the deque in-place
    • Ds\Deque::sorted — Returns a sorted copy
    • Ds\Deque::sum — Returns the sum of all values in the deque
    • Ds\Deque::toArray — Converts the deque to an array
    • Ds\Deque::unshift — Adds values to the front of the deque
  • Map — The Map class
    • Ds\Map::allocate — Allocates enough memory for a required capacity
    • Ds\Map::apply — Updates all values by applying a callback function to each value
    • Ds\Map::capacity — Returns the current capacity
    • Ds\Map::clear — Removes all values
    • Ds\Map::__construct — Creates a new instance
    • Ds\Map::copy — Returns a shallow copy of the map
    • Ds\Map::count — Returns the number of values in the map
    • Ds\Map::diff — Creates a new map using keys that aren't in another map
    • Ds\Map::filter — Creates a new map using a callable to determine which pairs to include
    • Ds\Map::first — Returns the first pair in the map
    • Ds\Map::get — Returns the value for a given key
    • Ds\Map::hasKey — Determines whether the map contains a given key
    • Ds\Map::hasValue — Determines whether the map contains a given value
    • Ds\Map::intersect — Creates a new map by intersecting keys with another map
    • Ds\Map::isEmpty — Returns whether the map is empty
    • Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Map::keys — Returns a set of the map's keys
    • Ds\Map::ksort — Sorts the map in-place by key
    • Ds\Map::ksorted — Returns a copy, sorted by key
    • Ds\Map::last — Returns the last pair of the map
    • Ds\Map::map — Returns the result of applying a callback to each value
    • Ds\Map::merge — Returns the result of adding all given associations
    • Ds\Map::pairs — Returns a sequence containing all the pairs of the map
    • Ds\Map::put — Associates a key with a value
    • Ds\Map::putAll — Associates all key-value pairs of a traversable object or array
    • Ds\Map::reduce — Reduces the map to a single value using a callback function
    • Ds\Map::remove — Removes and returns a value by key
    • Ds\Map::reverse — Reverses the map in-place
    • Ds\Map::reversed — Returns a reversed copy
    • Ds\Map::skip — Returns the pair at a given positional index
    • Ds\Map::slice — Returns a subset of the map defined by a starting index and length
    • Ds\Map::sort — Sorts the map in-place by value
    • Ds\Map::sorted — Returns a copy, sorted by value
    • Ds\Map::sum — Returns the sum of all values in the map
    • Ds\Map::toArray — Converts the map to an array
    • Ds\Map::union — Creates a new map using values from the current instance and another map
    • Ds\Map::values — Returns a sequence of the map's values
    • Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both
  • Pair — The Pair class
    • Ds\Pair::clear — Removes all values
    • Ds\Pair::__construct — Creates a new instance
    • Ds\Pair::copy — Returns a shallow copy of the pair
    • Ds\Pair::isEmpty — Returns whether the pair is empty
    • Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Pair::toArray — Converts the pair to an array
  • Set — The Set class
    • Ds\Set::add — Adds values to the set
    • Ds\Set::allocate — Allocates enough memory for a required capacity
    • Ds\Set::capacity — Returns the current capacity
    • Ds\Set::clear — Removes all values
    • Ds\Set::__construct — Creates a new instance
    • Ds\Set::contains — Determines if the set contains all values
    • Ds\Set::copy — Returns a shallow copy of the set
    • Ds\Set::count — Returns the number of values in the set
    • Ds\Set::diff — Creates a new set using values that aren't in another set
    • Ds\Set::filter — Creates a new set using a callable to determine which values to include
    • Ds\Set::first — Returns the first value in the set
    • Ds\Set::get — Returns the value at a given index
    • Ds\Set::intersect — Creates a new set by intersecting values with another set
    • Ds\Set::isEmpty — Returns whether the set is empty
    • Ds\Set::join — Joins all values together as a string
    • Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Set::last — Returns the last value in the set
    • Ds\Set::merge — Returns the result of adding all given values to the set
    • Ds\Set::reduce — Reduces the set to a single value using a callback function
    • Ds\Set::remove — Removes all given values from the set
    • Ds\Set::reverse — Reverses the set in-place
    • Ds\Set::reversed — Returns a reversed copy
    • Ds\Set::slice — Returns a sub-set of a given range
    • Ds\Set::sort — Sorts the set in-place
    • Ds\Set::sorted — Returns a sorted copy
    • Ds\Set::sum — Returns the sum of all values in the set
    • Ds\Set::toArray — Converts the set to an array
    • Ds\Set::union — Creates a new set using values from the current instance and another set
    • Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both
  • Stack — The Stack class
    • Ds\Stack::allocate — Allocates enough memory for a required capacity
    • Ds\Stack::capacity — Returns the current capacity
    • Ds\Stack::clear — Removes all values
    • Ds\Stack::__construct — Creates a new instance
    • Ds\Stack::copy — Returns a shallow copy of the stack
    • Ds\Stack::count — Returns the number of values in the stack
    • Ds\Stack::isEmpty — Returns whether the stack is empty
    • Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Stack::peek — Returns the value at the top of the stack
    • Ds\Stack::pop — Removes and returns the value at the top of the stack
    • Ds\Stack::push — Pushes values onto the stack
    • Ds\Stack::toArray — Converts the stack to an array
  • Queue — The Queue class
    • Ds\Queue::allocate — Allocates enough memory for a required capacity
    • Ds\Queue::capacity — Returns the current capacity
    • Ds\Queue::clear — Removes all values
    • Ds\Queue::__construct — Creates a new instance
    • Ds\Queue::copy — Returns a shallow copy of the queue
    • Ds\Queue::count — Returns the number of values in the queue
    • Ds\Queue::isEmpty — Returns whether the queue is empty
    • Ds\Queue::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\Queue::peek — Returns the value at the front of the queue
    • Ds\Queue::pop — Removes and returns the value at the front of the queue
    • Ds\Queue::push — Pushes values into the queue
    • Ds\Queue::toArray — Converts the queue to an array
  • PriorityQueue — The PriorityQueue class
    • Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity
    • Ds\PriorityQueue::capacity — Returns the current capacity
    • Ds\PriorityQueue::clear — Removes all values
    • Ds\PriorityQueue::__construct — Creates a new instance
    • Ds\PriorityQueue::copy — Returns a shallow copy of the queue
    • Ds\PriorityQueue::count — Returns the number of values in the queue
    • Ds\PriorityQueue::isEmpty — Returns whether the queue is empty
    • Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON
    • Ds\PriorityQueue::peek — Returns the value at the front of the queue
    • Ds\PriorityQueue::pop — Removes and returns the value with the highest priority
    • Ds\PriorityQueue::push — Pushes values into the queue
    • Ds\PriorityQueue::toArray — Converts the queue to an array


  • ? Data Structures
  • 安装／配置 ?
  • PHP Manual
  • Data Structures
  • 简介

简介

PHP7高效的数据结构，可以作为 array 的替代.

点击 » 博客帖子 查看 基准，讨论和常见问题。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Data Structures
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装


需求

PHP 7 is required by both the extension and the compatibility polyfill.


安装

The easiest way to install the extension is via » PECL

pecl install ds

You can also build directly from source:

# Dependencies you might need to install
# sudo apt-get install git build-essential php7.0-dev

git clone https://github.com/php-ds/extension "php-ds"
cd php-ds

# Build and install the extension
phpize
./configure
make
make install

# Clean up the build files
make clean
phpize --clean

If you're on Windows, you can » download a compiled .dll on PECL

Note:

If you're using Composer, it's highly recommended that you include » php-ds/php-ds in your project so that your code is still functional in an environment where the extension is not installed. The extension will take priority if installed.


  • ? 安装
  • 范例 ?
  • PHP Manual
  • Data Structures
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

Example #1 Vector

<?php

$vector = new \Ds\Vector();

$vector->push('a');
$vector->push('b', 'c');

$vector[] = 'd';

print_r($vector);

?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
)

Example #2 Map

<?php

$map = new \Ds\Map();

$map->put('a', 1);
$map->put('b', 2);

$map['c'] = 3;

print_r($map);

?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)


The Collection interface

(No version information available, might only be in Git)

简介

Collection is the base interface which covers functionality common to all the data structures in this library. It guarantees that all structures are traversable, countable, and can be converted to json using json_encode().

接口摘要

Ds\Collection implements Traversable , Countable , JsonSerializable {
/* 方法 */
abstract public clear ( ) : void
abstract public copy ( ) : Ds\Collection
abstract public isEmpty ( ) : bool
abstract public toArray ( ) : array
}

Table of Contents

  • Ds\Collection::clear — Removes all values
  • Ds\Collection::copy — Returns a shallow copy of the collection
  • Ds\Collection::isEmpty — Returns whether the collection is empty
  • Ds\Collection::toArray — Converts the collection to an array


Removes all values

  • ? Collection
  • Ds\Collection::copy ?
  • PHP Manual
  • Collection
  • Removes all values

Ds\Collection::clear

(PECL ds >= 1.0.0)

Ds\Collection::clear — Removes all values

说明

abstract public Ds\Collection::clear ( ) : void

Removes all values from the collection.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Collection::clear() example

<?php
$collection = new \Ds\Vector([1, 2, 3]);
print_r($collection);

$collection->clear();
print_r($collection);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
)


Returns a shallow copy of the collection

  • ? Ds\Collection::clear
  • Ds\Collection::isEmpty ?
  • PHP Manual
  • Collection
  • Returns a shallow copy of the collection

Ds\Collection::copy

(PECL ds >= 1.0.0)

Ds\Collection::copy — Returns a shallow copy of the collection

说明

abstract public Ds\Collection::copy ( ) : Ds\Collection

Returns a shallow copy of the collection.

参数

此函数没有参数。

返回值

Returns a shallow copy of the collection.

范例

Example #1 Ds\Collection::copy() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = $a->copy();

$b->push(4);

print_r($a);
print_r($b);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns whether the collection is empty

  • ? Ds\Collection::copy
  • Ds\Collection::toArray ?
  • PHP Manual
  • Collection
  • Returns whether the collection is empty

Ds\Collection::isEmpty

(PECL ds >= 1.0.0)

Ds\Collection::isEmpty — Returns whether the collection is empty

说明

abstract public Ds\Collection::isEmpty ( ) : bool

Returns whether the collection is empty.

参数

此函数没有参数。

返回值

Returns true if the collection is empty, false otherwise.

范例

Example #1 Ds\Collection::isEmpty() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = new \Ds\Vector();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Converts the collection to an array

  • ? Ds\Collection::isEmpty
  • Hashable ?
  • PHP Manual
  • Collection
  • Converts the collection to an array

Ds\Collection::toArray

(PECL ds >= 1.0.0)

Ds\Collection::toArray — Converts the collection to an array

说明

abstract public Ds\Collection::toArray ( ) : array

Converts the collection to an array.

Note:

Casting to an array is not supported yet.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the collection.

范例

Example #1 Ds\Collection::toArray() example

<?php
$collection = new \Ds\Vector([1, 2, 3]);

var_dump($collection->toArray());
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


The Hashable interface

(No version information available, might only be in Git)

简介

Hashable is an interface which allows objects to be used as keys. It's an alternative to spl_object_hash(), which determines an object's hash based on its handle: this means that two objects that are considered equal by an implicit definition would not treated as equal because they are not the same instance.

hash() is used to return a scalar value to be used as the object's hash value, which determines where it goes in the hash table. While this value does not have to be unique, objects which are equal must have the same hash value.

equals() is used to determine if two objects are equal. It's guaranteed that the comparing object will be an instance of the same class as the subject.

接口摘要

Ds\Hashable {
/* 方法 */
abstract public equals ( object $obj ) : bool
abstract public hash ( ) : mixed
}

Table of Contents

  • Ds\Hashable::equals — Determines whether an object is equal to the current instance
  • Ds\Hashable::hash — Returns a scalar value to be used as a hash value


Determines whether an object is equal to the current instance

  • ? Hashable
  • Ds\Hashable::hash ?
  • PHP Manual
  • Hashable
  • Determines whether an object is equal to the current instance

Ds\Hashable::equals

(PECL ds >= 1.0.0)

Ds\Hashable::equals — Determines whether an object is equal to the current instance

说明

abstract public Ds\Hashable::equals ( object $obj ) : bool

Determines whether another object is equal to the current instance.

This method allows objects to be used as keys in structures such as Ds\Map and Ds\Set, or any other lookup structure that honors this interface.

Note:

It's guaranteed that obj is an instance of the same class.

Caution

It's important that objects which are equal also have the same hash value. See Ds\Hashable::hash().

参数

obj

The object to compare the current instance to, which is always an instance of the same class.

返回值

true if equal, false otherwise.


Returns a scalar value to be used as a hash value

  • ? Ds\Hashable::equals
  • Sequence ?
  • PHP Manual
  • Hashable
  • Returns a scalar value to be used as a hash value

Ds\Hashable::hash

(PECL ds >= 1.0.0)

Ds\Hashable::hash — Returns a scalar value to be used as a hash value

说明

abstract public Ds\Hashable::hash ( ) : mixed

Returns a scalar value to be used as the hash value of the objects.

While the hash value does not define equality, all objects that are equal according to Ds\Hashable::equals() must have the same hash value. Hash values of equal objects don't have to be unique, for example you could just return true for all objects and nothing would break - the only implication would be that hash tables then turn into linked lists because all your objects will be hashed to the same bucket. It's therefore very important that you pick a good hash value, such as an ID or email address.

This method allows objects to be used as keys in structures such as Ds\Map and Ds\Set, or any other lookup structure that honors this interface.

Caution

Do not pick a value that might change within the object, such as a public property. Hash table lookups would fail because the hash has changed.

Caution

All objects that are equal must have the same hash value.

参数

此函数没有参数。

返回值

A scalar value to be used as this object's hash value.

范例

Example #1 Ds\Hashable::hash() example

<?php
class HashableObject implements \Ds\Hashable
{
    private $name;
    private $email;

    public function __construct($name, $email)
    {
        $this->name  = $name;
        $this->email = $email;
    }

    /**
     * Should return the same value for all equal objects, but doesn't have to
     * be unique. This value will not be used to determine equality.
     */
    public function hash()
    {
        return $this->email;
    }

    /**
     * This determines equality, usually during a hash table lookup to determine
     * if the bucket's key matches the lookup key. The hash has to be equal if
     * the objects are equal, otherwise this determination wouldn't be reached.
     */
    public function equals($obj): bool
    {
        return $this->name  === $obj->name
            && $this->email === $obj->email;
    }
}
?>


The Sequence interface

(No version information available, might only be in Git)

简介

A Sequence describes the behaviour of values arranged in a single, linear dimension. Some languages refer to this as a "List". It's similar to an array that uses incremental integer keys, with the exception of a few characteristics:

  • Values will always be indexed as [0, 1, 2, ..., size - 1].
  • Only allowed to access values by index in the range [0, size - 1].

Use cases:

  • Wherever you would use an array as a list (not concerned with keys).
  • A more efficient alternative to SplDoublyLinkedList and SplFixedArray.

接口摘要

Ds\Sequence implements Ds\Collection , ArrayAccess {
/* 方法 */
abstract public allocate ( int $capacity ) : void
abstract public apply ( callable $callback ) : void
abstract public capacity ( ) : int
abstract public contains ( mixed ...$values ) : bool
abstract public filter ( callable $callback = ? ) : Ds\Sequence
abstract public find ( mixed $value ) : mixed
abstract public first ( ) : mixed
abstract public get ( int $index ) : mixed
abstract public insert ( int $index , mixed ...$values ) : void
abstract public join ( string $glue = ? ) : string
abstract public last ( ) : mixed
abstract public map ( callable $callback ) : Ds\Sequence
abstract public merge ( mixed $values ) : Ds\Sequence
abstract public pop ( ) : mixed
abstract public push ( mixed ...$values ) : void
abstract public reduce ( callable $callback , mixed $initial = ? ) : mixed
abstract public remove ( int $index ) : mixed
abstract public reverse ( ) : void
abstract public reversed ( ) : Ds\Sequence
abstract public rotate ( int $rotations ) : void
abstract public set ( int $index , mixed $value ) : void
abstract public shift ( ) : mixed
abstract public slice ( int $index , int $length = ? ) : Ds\Sequence
abstract public sort ( callable $comparator = ? ) : void
abstract public sorted ( callable $comparator = ? ) : Ds\Sequence
abstract public sum ( ) : int|float
abstract public unshift ( mixed $values = ? ) : void
}

更新日志

版本 | 说明
PECL ds 1.3.0 | The interface now extends ArrayAccess.

Table of Contents

  • Ds\Sequence::allocate — Allocates enough memory for a required capacity
  • Ds\Sequence::apply — Updates all values by applying a callback function to each value
  • Ds\Sequence::capacity — Returns the current capacity
  • Ds\Sequence::contains — Determines if the sequence contains given values
  • Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include
  • Ds\Sequence::find — Attempts to find a value's index
  • Ds\Sequence::first — Returns the first value in the sequence
  • Ds\Sequence::get — Returns the value at a given index
  • Ds\Sequence::insert — Inserts values at a given index
  • Ds\Sequence::join — Joins all values together as a string
  • Ds\Sequence::last — Returns the last value
  • Ds\Sequence::map — Returns the result of applying a callback to each value
  • Ds\Sequence::merge — Returns the result of adding all given values to the sequence
  • Ds\Sequence::pop — Removes and returns the last value
  • Ds\Sequence::push — Adds values to the end of the sequence
  • Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function
  • Ds\Sequence::remove — Removes and returns a value by index
  • Ds\Sequence::reverse — Reverses the sequence in-place
  • Ds\Sequence::reversed — Returns a reversed copy
  • Ds\Sequence::rotate — Rotates the sequence by a given number of rotations
  • Ds\Sequence::set — Updates a value at a given index
  • Ds\Sequence::shift — Removes and returns the first value
  • Ds\Sequence::slice — Returns a sub-sequence of a given range
  • Ds\Sequence::sort — Sorts the sequence in-place
  • Ds\Sequence::sorted — Returns a sorted copy
  • Ds\Sequence::sum — Returns the sum of all values in the sequence
  • Ds\Sequence::unshift — Adds values to the front of the sequence


Allocates enough memory for a required capacity

  • ? Sequence
  • Ds\Sequence::apply ?
  • PHP Manual
  • Sequence
  • Allocates enough memory for a required capacity

Ds\Sequence::allocate

(PECL ds >= 1.0.0)

Ds\Sequence::allocate — Allocates enough memory for a required capacity

说明

abstract public Ds\Sequence::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

参数

capacity

The number of values for which capacity should be allocated.

Note:

Capacity will stay the same if this value is less than or equal to the current capacity.

返回值

没有返回值。

范例

Example #1 Ds\Sequence::allocate() example

<?php
$sequence = new \Ds\Vector();
var_dump($sequence->capacity());

$vector->allocate(100);
var_dump($sequence->capacity());
?>

以上例程的输出类似于：

int(10)
int(100)


Updates all values by applying a callback function to each value

  • ? Ds\Sequence::allocate
  • Ds\Sequence::capacity ?
  • PHP Manual
  • Sequence
  • Updates all values by applying a callback function to each value

Ds\Sequence::apply

(PECL ds >= 1.0.0)

Ds\Sequence::apply — Updates all values by applying a callback function to each value

说明

abstract public Ds\Sequence::apply ( callable $callback ) : void

Updates all values by applying a callback function to each value in the sequence.

参数

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the sequence.

The callback should return what the value should be replaced by.

返回值

没有返回值。

范例

Example #1 Ds\Sequence::apply() example

<?php
$sequence = new \Ds\Sequence([1, 2, 3]);
$sequence->apply(function($value) { return $value * 2; });

print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)


Returns the current capacity

  • ? Ds\Sequence::apply
  • Ds\Sequence::contains ?
  • PHP Manual
  • Sequence
  • Returns the current capacity

Ds\Sequence::capacity

(PECL ds >= 1.0.0)

Ds\Sequence::capacity — Returns the current capacity

说明

abstract public Ds\Sequence::capacity ( ) : int

Returns the current capacity.

参数

此函数没有参数。

返回值

The current capacity.

范例

Example #1 Ds\Sequence::capacity() example

<?php
$sequence = new \Ds\Vector();
var_dump($sequence->capacity());

$sequence->push(...range(1, 50));
var_dump($sequence->capacity());

$sequence[] = "a";
var_dump($sequence->capacity());
?>

以上例程的输出类似于：

int(10)
int(50)
int(75)


Determines if the sequence contains given values

  • ? Ds\Sequence::capacity
  • Ds\Sequence::filter ?
  • PHP Manual
  • Sequence
  • Determines if the sequence contains given values

Ds\Sequence::contains

(PECL ds >= 1.0.0)

Ds\Sequence::contains — Determines if the sequence contains given values

说明

abstract public Ds\Sequence::contains ( mixed ...$values ) : bool

Determines if the sequence contains all values.

参数

values

Values to check.

返回值

false if any of the provided values are not in the sequence, true otherwise.

范例

Example #1 Ds\Sequence::contains() example

<?php
$sequence = new \Ds\Vector(['a', 'b', 'c', 1, 2, 3]);

var_dump($sequence->contains('a'));                // true
var_dump($sequence->contains('a', 'b'));           // true
var_dump($sequence->contains('c', 'd'));           // false

var_dump($sequence->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($sequence->contains(1));                  // true
var_dump($sequence->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)


Creates a new sequence using a callable to determine which values to include

  • ? Ds\Sequence::contains
  • Ds\Sequence::find ?
  • PHP Manual
  • Sequence
  • Creates a new sequence using a callable to determine which values to include

Ds\Sequence::filter

(PECL ds >= 1.0.0)

Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include

说明

abstract public Ds\Sequence::filter ( callable $callback = ? ) : Ds\Sequence

Creates a new sequence using a callable to determine which values to include.

参数

callback

callback ( mixed $value ) : bool

Optional callable which returns true if the value should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

返回值

A new sequence containing all the values for which either the callback returned true, or all values that convert to true if a callback was not provided.

范例

Example #1 Ds\Sequence::filter() example using callback function

<?php
$sequence = new \Ds\Vector([1, 2, 3, 4, 5]);

var_dump($sequence->filter(function($value) {
    return $value % 2 == 0;
}));
?>

以上例程的输出类似于：

object(Ds\Vector)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Example #2 Ds\Sequence::filter() example without a callback function

<?php
$sequence = new \Ds\Vector([0, 1, 'a', true, false]);

var_dump($sequence->filter());
?>

以上例程的输出类似于：

object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Attempts to find a value's index

  • ? Ds\Sequence::filter
  • Ds\Sequence::first ?
  • PHP Manual
  • Sequence
  • Attempts to find a value's index

Ds\Sequence::find

(PECL ds >= 1.0.0)

Ds\Sequence::find — Attempts to find a value's index

说明

abstract public Ds\Sequence::find ( mixed $value ) : mixed

Returns the index of the value, or false if not found.

参数

value

The value to find.

返回值

The index of the value, or false if not found.

Note:

Values will be compared by value and by type.

范例

Example #1 Ds\Sequence::find() example

<?php
$sequence = new \Ds\Vector(["a", 1, true]);

var_dump($sequence->find("a")); // 0
var_dump($sequence->find("b")); // false
var_dump($sequence->find("1")); // false
var_dump($sequence->find(1));   // 1
?>

以上例程的输出类似于：

int(0)
bool(false)
bool(false)
int(1)


Returns the first value in the sequence

  • ? Ds\Sequence::find
  • Ds\Sequence::get ?
  • PHP Manual
  • Sequence
  • Returns the first value in the sequence

Ds\Sequence::first

(PECL ds >= 1.0.0)

Ds\Sequence::first — Returns the first value in the sequence

说明

abstract public Ds\Sequence::first ( ) : mixed

Returns the first value in the sequence.

参数

此函数没有参数。

返回值

The first value in the sequence.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Sequence::first() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->first());
?>

以上例程的输出类似于：

int(1)


Returns the value at a given index

  • ? Ds\Sequence::first
  • Ds\Sequence::insert ?
  • PHP Manual
  • Sequence
  • Returns the value at a given index

Ds\Sequence::get

(PECL ds >= 1.0.0)

Ds\Sequence::get — Returns the value at a given index

说明

abstract public Ds\Sequence::get ( int $index ) : mixed

Returns the value at a given index.

参数

index

The index to access, starting at 0.

返回值

The value at the requested index.

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Sequence::get() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->get(0));
var_dump($sequence->get(1));
var_dump($sequence->get(2));
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"

Example #2 Ds\Sequence::get() example using array syntax

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence[0]);
var_dump($sequence[1]);
var_dump($sequence[2]);
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Inserts values at a given index

  • ? Ds\Sequence::get
  • Ds\Sequence::join ?
  • PHP Manual
  • Sequence
  • Inserts values at a given index

Ds\Sequence::insert

(PECL ds >= 1.0.0)

Ds\Sequence::insert — Inserts values at a given index

说明

abstract public Ds\Sequence::insert ( int $index , mixed ...$values ) : void

Inserts values into the sequence at a given index.

参数

index

The index at which to insert. 0 <= index <= count

Note:

You can insert at the index equal to the number of values.

values

The value or values to insert.

返回值

没有返回值。

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Sequence::insert() example

<?php
$sequence = new \Ds\Vector();

$sequence->insert(0, "e");             // [e]
$sequence->insert(1, "f");             // [e, f]
$sequence->insert(2, "g");             // [e, f, g]
$sequence->insert(0, "a", "b");        // [a, b, e, f, g]
$sequence->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($sequence);
?>

以上例程的输出类似于：

object(Ds\Vector)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}


Joins all values together as a string

  • ? Ds\Sequence::insert
  • Ds\Sequence::last ?
  • PHP Manual
  • Sequence
  • Joins all values together as a string

Ds\Sequence::join

(PECL ds >= 1.0.0)

Ds\Sequence::join — Joins all values together as a string

说明

abstract public Ds\Sequence::join ( string $glue = ? ) : string

Joins all values together as a string using an optional separator between each value.

参数

glue

An optional string to separate each value.

返回值

All values of the sequence joined together as a string.

范例

Example #1 Ds\Sequence::join() example using a separator string

<?php
$sequence = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($sequence->join("|"));
?>

以上例程的输出类似于：

string(11) "a|b|c|1|2|3"

Example #2 Ds\Sequence::join() example without a separator string

<?php
$sequence = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($sequence->join());
?>

以上例程的输出类似于：

string(11) "abc123"


Returns the last value

  • ? Ds\Sequence::join
  • Ds\Sequence::map ?
  • PHP Manual
  • Sequence
  • Returns the last value

Ds\Sequence::last

(PECL ds >= 1.0.0)

Ds\Sequence::last — Returns the last value

说明

abstract public Ds\Sequence::last ( ) : mixed

Returns the last value in the sequence.

参数

此函数没有参数。

返回值

The last value in the sequence.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Sequence::last() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->last());
?>

以上例程的输出类似于：

int(3)


Returns the result of applying a callback to each value

  • ? Ds\Sequence::last
  • Ds\Sequence::merge ?
  • PHP Manual
  • Sequence
  • Returns the result of applying a callback to each value

Ds\Sequence::map

(PECL ds >= 1.0.0)

Ds\Sequence::map — Returns the result of applying a callback to each value

说明

abstract public Ds\Sequence::map ( callable $callback ) : Ds\Sequence

Returns the result of applying a callback function to each value in the sequence.

参数

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the sequence.

The callable should return what the new value will be in the new sequence.

返回值

The result of applying a callback to each value in the sequence.

Note:

The values of the current instance won't be affected.

范例

Example #1 Ds\Sequence::map() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

print_r($sequence->map(function($value) { return $value * 2; }));
print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)


Returns the result of adding all given values to the sequence

  • ? Ds\Sequence::map
  • Ds\Sequence::pop ?
  • PHP Manual
  • Sequence
  • Returns the result of adding all given values to the sequence

Ds\Sequence::merge

(PECL ds >= 1.0.0)

Ds\Sequence::merge — Returns the result of adding all given values to the sequence

说明

abstract public Ds\Sequence::merge ( mixed $values ) : Ds\Sequence

Returns the result of adding all given values to the sequence.

参数

values

A traversable object or an array.

返回值

The result of adding all given values to the sequence, effectively the same as adding the values to a copy, then returning that copy.

Note:

The current instance won't be affected.

范例

Example #1 Ds\Sequence::merge() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->merge([4, 5, 6]));
var_dump($sequence);
?>

以上例程的输出类似于：

object(Ds\Vector)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Vector)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Removes and returns the last value

  • ? Ds\Sequence::merge
  • Ds\Sequence::push ?
  • PHP Manual
  • Sequence
  • Removes and returns the last value

Ds\Sequence::pop

(PECL ds >= 1.0.0)

Ds\Sequence::pop — Removes and returns the last value

说明

abstract public Ds\Sequence::pop ( ) : mixed

Removes and returns the last value.

参数

此函数没有参数。

返回值

The removed last value.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Sequence::pop() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->pop());
var_dump($sequence->pop());
var_dump($sequence->pop());
?>

以上例程的输出类似于：

int(3)
int(2)
int(1)


Adds values to the end of the sequence

  • ? Ds\Sequence::pop
  • Ds\Sequence::reduce ?
  • PHP Manual
  • Sequence
  • Adds values to the end of the sequence

Ds\Sequence::push

(PECL ds >= 1.0.0)

Ds\Sequence::push — Adds values to the end of the sequence

说明

abstract public Ds\Sequence::push ( mixed ...$values ) : void

Adds values to the end of the sequence.

参数

values

The values to add.

返回值

没有返回值。

范例

Example #1 Ds\Sequence::push() example

<?php
$sequence = new \Ds\Vector();

$sequence->push("a");
$sequence->push("b");
$sequence->push("c", "d");
$sequence->push(...["e", "f"]);

print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Reduces the sequence to a single value using a callback function

  • ? Ds\Sequence::push
  • Ds\Sequence::remove ?
  • PHP Manual
  • Sequence
  • Reduces the sequence to a single value using a callback function

Ds\Sequence::reduce

(PECL ds >= 1.0.0)

Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function

说明

abstract public Ds\Sequence::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the sequence to a single value using a callback function.

参数

callback
callback ( mixed $carry , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

返回值

The return value of the final callback.

范例

Example #1 Ds\Sequence::reduce() with initial value example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($sequence->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

以上例程的输出类似于：

int(30)

Example #2 Ds\Sequence::reduce() without an initial value example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

以上例程的输出类似于：

int(21)


Removes and returns a value by index

  • ? Ds\Sequence::reduce
  • Ds\Sequence::reverse ?
  • PHP Manual
  • Sequence
  • Removes and returns a value by index

Ds\Sequence::remove

(PECL ds >= 1.0.0)

Ds\Sequence::remove — Removes and returns a value by index

说明

abstract public Ds\Sequence::remove ( int $index ) : mixed

Removes and returns a value by index.

参数

index

The index of the value to remove.

返回值

The value that was removed.

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Sequence::remove() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->remove(1));
var_dump($sequence->remove(0));
var_dump($sequence->remove(0));
?>

以上例程的输出类似于：

string(1) "b"
string(1) "a"
string(1) "c"


Reverses the sequence in-place

  • ? Ds\Sequence::remove
  • Ds\Sequence::reversed ?
  • PHP Manual
  • Sequence
  • Reverses the sequence in-place

Ds\Sequence::reverse

(PECL ds >= 1.0.0)

Ds\Sequence::reverse — Reverses the sequence in-place

说明

abstract public Ds\Sequence::reverse ( ) : void

Reverses the sequence in-place.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Sequence::reverse() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);
$sequence->reverse();

print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)


Returns a reversed copy

  • ? Ds\Sequence::reverse
  • Ds\Sequence::rotate ?
  • PHP Manual
  • Sequence
  • Returns a reversed copy

Ds\Sequence::reversed

(PECL ds >= 1.0.0)

Ds\Sequence::reversed — Returns a reversed copy

说明

abstract public Ds\Sequence::reversed ( ) : Ds\Sequence

Returns a reversed copy of the sequence.

参数

此函数没有参数。

返回值

A reversed copy of the sequence.

Note:

The current instance is not affected.

范例

Example #1 Ds\Sequence::reversed() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

print_r($sequence->reversed());
print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
)


Rotates the sequence by a given number of rotations

  • ? Ds\Sequence::reversed
  • Ds\Sequence::set ?
  • PHP Manual
  • Sequence
  • Rotates the sequence by a given number of rotations

Ds\Sequence::rotate

(PECL ds >= 1.0.0)

Ds\Sequence::rotate — Rotates the sequence by a given number of rotations

说明

abstract public Ds\Sequence::rotate ( int $rotations ) : void

Rotates the sequence by a given number of rotations, which is equivalent to successively calling $sequence->push($sequence->shift()) if the number of rotations is positive, or $sequence->unshift($sequence->pop()) if negative.

参数

rotations

The number of times the sequence should be rotated.

返回值

没有返回值。. The sequence of the current instance will be rotated.

范例

Example #1 Ds\Sequence::rotate() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c", "d"]);

$sequence->rotate(1);  // "a" is shifted, then pushed.
print_r($sequence);

$sequence->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($sequence);
?>

以上例程的输出类似于：

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Vector Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)


Updates a value at a given index

  • ? Ds\Sequence::rotate
  • Ds\Sequence::shift ?
  • PHP Manual
  • Sequence
  • Updates a value at a given index

Ds\Sequence::set

(PECL ds >= 1.0.0)

Ds\Sequence::set — Updates a value at a given index

说明

abstract public Ds\Sequence::set ( int $index , mixed $value ) : void

Updates a value at a given index.

参数

index

The index of the value to update.

value

The new value.

返回值

没有返回值。

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Sequence::set() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

$sequence->set(1, "_");
print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)

Example #2 Ds\Sequence::set() example using array syntax

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

$sequence[1] = "_";
print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)


Removes and returns the first value

  • ? Ds\Sequence::set
  • Ds\Sequence::slice ?
  • PHP Manual
  • Sequence
  • Removes and returns the first value

Ds\Sequence::shift

(PECL ds >= 1.0.0)

Ds\Sequence::shift — Removes and returns the first value

说明

abstract public Ds\Sequence::shift ( ) : mixed

Removes and returns the first value.

参数

此函数没有参数。

返回值

The first value, which was removed.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Sequence::shift() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->shift());
var_dump($sequence->shift());
var_dump($sequence->shift());
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Returns a sub-sequence of a given range

  • ? Ds\Sequence::shift
  • Ds\Sequence::sort ?
  • PHP Manual
  • Sequence
  • Returns a sub-sequence of a given range

Ds\Sequence::slice

(PECL ds >= 1.0.0)

Ds\Sequence::slice — Returns a sub-sequence of a given range

说明

abstract public Ds\Sequence::slice ( int $index , int $length = ? ) : Ds\Sequence

Creates a sub-sequence of a given range.

参数

index

The index at which the sub-sequence starts.

If positive, the sequence will start at that index in the sequence. If negative, the sequence will start that far from the end.

length

If a length is given and is positive, the resulting sequence will have up to that many values in it. If the length results in an overflow, only values up to the end of the sequence will be included. If a length is given and is negative, the sequence will stop that many values from the end. If a length is not provided, the resulting sequence will contain all values between the index and the end of the sequence.

返回值

A sub-sequence of the given range.

范例

Example #1 Ds\Sequence::slice() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($sequence->slice(2));

// Slice from 1, for a length of 3
print_r($sequence->slice(1, 3));

// Slice from 1 onwards
print_r($sequence->slice(1));

// Slice from 2 from the end onwards
print_r($sequence->slice(-2));

// Slice from 1 to 1 from the end
print_r($sequence->slice(1, -1));
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Vector Object
(
    [0] => d
    [1] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)


Sorts the sequence in-place

  • ? Ds\Sequence::slice
  • Ds\Sequence::sorted ?
  • PHP Manual
  • Sequence
  • Sorts the sequence in-place

Ds\Sequence::sort

(PECL ds >= 1.0.0)

Ds\Sequence::sort — Sorts the sequence in-place

说明

abstract public Ds\Sequence::sort ( callable $comparator = ? ) : void

Sorts the sequence in-place, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

没有返回值。

范例

Example #1 Ds\Sequence::sort() example

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);
$sequence->sort();

print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Example #2 Ds\Sequence::sort() example using a comparator

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

$sequence->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns a sorted copy

  • ? Ds\Sequence::sort
  • Ds\Sequence::sum ?
  • PHP Manual
  • Sequence
  • Returns a sorted copy

Ds\Sequence::sorted

(PECL ds >= 1.0.0)

Ds\Sequence::sorted — Returns a sorted copy

说明

abstract public Ds\Sequence::sorted ( callable $comparator = ? ) : Ds\Sequence

Returns a sorted copy, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

Returns a sorted copy of the sequence.

范例

Example #1 Ds\Sequence::sorted() example

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

print_r($sequence->sorted());
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Example #2 Ds\Sequence::sorted() example using a comparator

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

$sorted = $sequence->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns the sum of all values in the sequence

  • ? Ds\Sequence::sorted
  • Ds\Sequence::unshift ?
  • PHP Manual
  • Sequence
  • Returns the sum of all values in the sequence

Ds\Sequence::sum

(PECL ds >= 1.0.0)

Ds\Sequence::sum — Returns the sum of all values in the sequence

说明

abstract public Ds\Sequence::sum ( ) : int|float

Returns the sum of all values in the sequence.

Note:

Arrays and objects are considered equal to zero when calculating the sum.

参数

此函数没有参数。

返回值

The sum of all the values in the sequence as either a float or int depending on the values in the sequence.

范例

Example #1 Ds\Sequence::sum() integer example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->sum());
?>

以上例程的输出类似于：

int(6)

Example #2 Ds\Sequence::sum() float example

<?php
$sequence = new \Ds\Vector([1, 2.5, 3]);
var_dump($sequence->sum());
?>

以上例程的输出类似于：

float(6.5)


Adds values to the front of the sequence

  • ? Ds\Sequence::sum
  • Vector ?
  • PHP Manual
  • Sequence
  • Adds values to the front of the sequence

Ds\Sequence::unshift

(PECL ds >= 1.0.0)

Ds\Sequence::unshift — Adds values to the front of the sequence

说明

abstract public Ds\Sequence::unshift ( mixed $values = ? ) : void

Adds values to the front of the sequence, moving all the current values forward to make room for the new values.

参数

values

The values to add to the front of the sequence.

Note:

Multiple values will be added in the same order that they are passed.

返回值

没有返回值。

范例

Example #1 Ds\Sequence::unshift() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

$sequence->unshift("a");
$sequence->unshift("b", "c");

print_r($sequence);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)


The Vector class

(No version information available, might only be in Git)

简介

A Vector is a sequence of values in a contiguous buffer that grows and shrinks automatically. It's the most efficient sequential structure because a value's index is a direct mapping to its index in the buffer, and the growth factor isn't bound to a specific multiple or exponent.

Strengths

  • Supports array syntax (square brackets).
  • Uses less overall memory than an array for the same number of values.
  • Automatically frees allocated memory when its size drops low enough.
  • Capacity does not have to be a power of 2.
  • get(),
set(),
push(),
pop() are all O(1).

Weaknesses

  • shift(),
unshift(),
insert() and
remove() are all O(n).

类摘要

Ds\Vector implements Ds\Sequence , ArrayAccess {
/* Constants */
const int MIN_CAPACITY = 10 ;
/* 方法 */
public allocate ( int $capacity ) : void
public apply ( callable $callback ) : void
public capacity ( ) : int
public clear ( ) : void
public contains ( mixed ...$values ) : bool
public copy ( ) : Ds\Vector
public filter ( callable $callback = ? ) : Ds\Vector
public find ( mixed $value ) : mixed
public first ( ) : mixed
public get ( int $index ) : mixed
public insert ( int $index , mixed ...$values ) : void
public isEmpty ( ) : bool
public join ( string $glue = ? ) : string
public last ( ) : mixed
public map ( callable $callback ) : Ds\Vector
public merge ( mixed $values ) : Ds\Vector
public pop ( ) : mixed
public push ( mixed ...$values ) : void
public reduce ( callable $callback , mixed $initial = ? ) : mixed
public remove ( int $index ) : mixed
public reverse ( ) : void
public reversed ( ) : Ds\Vector
public rotate ( int $rotations ) : void
public set ( int $index , mixed $value ) : void
public shift ( ) : mixed
public slice ( int $index , int $length = ? ) : Ds\Vector
public sort ( callable $comparator = ? ) : void
public sorted ( callable $comparator = ? ) : Ds\Vector
public sum ( ) : int|float
public toArray ( ) : array
public unshift ( mixed $values = ? ) : void
}

预定义常量

Ds\Vector::MIN_CAPACITY

更新日志

版本 | 说明
PECL ds 1.3.0 | The class now implements ArrayAccess.

Table of Contents

  • Ds\Vector::allocate — Allocates enough memory for a required capacity
  • Ds\Vector::apply — Updates all values by applying a callback function to each value
  • Ds\Vector::capacity — Returns the current capacity
  • Ds\Vector::clear — Removes all values
  • Ds\Vector::__construct — Creates a new instance
  • Ds\Vector::contains — Determines if the vector contains given values
  • Ds\Vector::copy — Returns a shallow copy of the vector
  • Ds\Vector::count — Returns the number of values in the collection
  • Ds\Vector::filter — Creates a new vector using a callable to determine which values to include
  • Ds\Vector::find — Attempts to find a value's index
  • Ds\Vector::first — Returns the first value in the vector
  • Ds\Vector::get — Returns the value at a given index
  • Ds\Vector::insert — Inserts values at a given index
  • Ds\Vector::isEmpty — Returns whether the vector is empty
  • Ds\Vector::join — Joins all values together as a string
  • Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Vector::last — Returns the last value
  • Ds\Vector::map — Returns the result of applying a callback to each value
  • Ds\Vector::merge — Returns the result of adding all given values to the vector
  • Ds\Vector::pop — Removes and returns the last value
  • Ds\Vector::push — Adds values to the end of the vector
  • Ds\Vector::reduce — Reduces the vector to a single value using a callback function
  • Ds\Vector::remove — Removes and returns a value by index
  • Ds\Vector::reverse — Reverses the vector in-place
  • Ds\Vector::reversed — Returns a reversed copy
  • Ds\Vector::rotate — Rotates the vector by a given number of rotations
  • Ds\Vector::set — Updates a value at a given index
  • Ds\Vector::shift — Removes and returns the first value
  • Ds\Vector::slice — Returns a sub-vector of a given range
  • Ds\Vector::sort — Sorts the vector in-place
  • Ds\Vector::sorted — Returns a sorted copy
  • Ds\Vector::sum — Returns the sum of all values in the vector
  • Ds\Vector::toArray — Converts the vector to an array
  • Ds\Vector::unshift — Adds values to the front of the vector


Allocates enough memory for a required capacity

  • ? Vector
  • Ds\Vector::apply ?
  • PHP Manual
  • Vector
  • Allocates enough memory for a required capacity

Ds\Vector::allocate

(PECL ds >= 1.0.0)

Ds\Vector::allocate — Allocates enough memory for a required capacity

说明

public Ds\Vector::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

参数

capacity

The number of values for which capacity should be allocated.

Note:

Capacity will stay the same if this value is less than or equal to the current capacity.

返回值

没有返回值。

范例

Example #1 Ds\Vector::allocate() example

<?php
$vector = new \Ds\Vector();
var_dump($vector->capacity());

$vector->allocate(100);
var_dump($vector->capacity());
?>

以上例程的输出类似于：

int(10)
int(100)


Updates all values by applying a callback function to each value

  • ? Ds\Vector::allocate
  • Ds\Vector::capacity ?
  • PHP Manual
  • Vector
  • Updates all values by applying a callback function to each value

Ds\Vector::apply

(PECL ds >= 1.0.0)

Ds\Vector::apply — Updates all values by applying a callback function to each value

说明

public Ds\Vector::apply ( callable $callback ) : void

Updates all values by applying a callback function to each value in the vector.

参数

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the vector.

The callback should return what the value should be replaced by.

返回值

没有返回值。

范例

Example #1 Ds\Vector::apply() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
$vector->apply(function($value) { return $value * 2; });

print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)


Returns the current capacity

  • ? Ds\Vector::apply
  • Ds\Vector::clear ?
  • PHP Manual
  • Vector
  • Returns the current capacity

Ds\Vector::capacity

(PECL ds >= 1.0.0)

Ds\Vector::capacity — Returns the current capacity

说明

public Ds\Vector::capacity ( ) : int

Returns the current capacity.

参数

此函数没有参数。

返回值

The current capacity.

范例

Example #1 Ds\Vector::capacity() example

<?php
$vector = new \Ds\Vector();
var_dump($vector->capacity());

$vector->push(...range(1, 50));
var_dump($vector->capacity());

$vector[] = "a";
var_dump($vector->capacity());
?>

以上例程的输出类似于：

int(10)
int(50)
int(75)


Removes all values

  • ? Ds\Vector::capacity
  • Ds\Vector::__construct ?
  • PHP Manual
  • Vector
  • Removes all values

Ds\Vector::clear

(PECL ds >= 1.0.0)

Ds\Vector::clear — Removes all values

说明

public Ds\Vector::clear ( ) : void

Removes all values from the vector.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Vector::clear() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
print_r($vector);

$vector->clear();
print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
)


Creates a new instance

  • ? Ds\Vector::clear
  • Ds\Vector::contains ?
  • PHP Manual
  • Vector
  • Creates a new instance

Ds\Vector::__construct

(PECL ds >= 1.0.0)

Ds\Vector::__construct — Creates a new instance

说明

public Ds\Vector::__construct ( mixed $values = ? )

Creates a new instance, using either a traversable object or an array for the initial values.

参数

values

A traversable object or an array to use for the initial values.

范例

Example #1 Ds\Vector::__construct() example

<?php
$vector = new \Ds\Vector();
var_dump($vector);

$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector);
?>

以上例程的输出类似于：

object(Ds\Vector)#2 (0) {
}
object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Determines if the vector contains given values

  • ? Ds\Vector::__construct
  • Ds\Vector::copy ?
  • PHP Manual
  • Vector
  • Determines if the vector contains given values

Ds\Vector::contains

(PECL ds >= 1.0.0)

Ds\Vector::contains — Determines if the vector contains given values

说明

public Ds\Vector::contains ( mixed ...$values ) : bool

Determines if the vector contains all values.

参数

values

Values to check.

返回值

false if any of the provided values are not in the vector, true otherwise.

范例

Example #1 Ds\Vector::contains() example

<?php
$vector = new \Ds\Vector(['a', 'b', 'c', 1, 2, 3]);

var_dump($vector->contains('a'));                // true
var_dump($vector->contains('a', 'b'));           // true
var_dump($vector->contains('c', 'd'));           // false

var_dump($vector->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($vector->contains(1));                  // true
var_dump($vector->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)


Returns a shallow copy of the vector

  • ? Ds\Vector::contains
  • Ds\Vector::count ?
  • PHP Manual
  • Vector
  • Returns a shallow copy of the vector

Ds\Vector::copy

(PECL ds >= 1.0.0)

Ds\Vector::copy — Returns a shallow copy of the vector

说明

public Ds\Vector::copy ( ) : Ds\Vector

Returns a shallow copy of the vector.

参数

此函数没有参数。

返回值

Returns a shallow copy of the vector.

范例

Example #1 Ds\Vector::copy() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns the number of values in the collection

  • ? Ds\Vector::copy
  • Ds\Vector::filter ?
  • PHP Manual
  • Vector
  • Returns the number of values in the collection

Ds\Vector::count

(PECL ds >= 1.0.0)

Ds\Vector::count — Returns the number of values in the collection

See Countable::count()


Creates a new vector using a callable to determine which values to include

  • ? Ds\Vector::count
  • Ds\Vector::find ?
  • PHP Manual
  • Vector
  • Creates a new vector using a callable to determine which values to include

Ds\Vector::filter

(PECL ds >= 1.0.0)

Ds\Vector::filter — Creates a new vector using a callable to determine which values to include

说明

public Ds\Vector::filter ( callable $callback = ? ) : Ds\Vector

Creates a new vector using a callable to determine which values to include.

参数

callback

callback ( mixed $value ) : bool

Optional callable which returns true if the value should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

返回值

A new vector containing all the values for which either the callback returned true, or all values that convert to true if a callback was not provided.

范例

Example #1 Ds\Vector::filter() example using callback function

<?php
$vector = new \Ds\Vector([1, 2, 3, 4, 5]);

var_dump($vector->filter(function($value) {
    return $value % 2 == 0;
}));
?>

以上例程的输出类似于：

object(Ds\Vector)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Example #2 Ds\Vector::filter() example without a callback function

<?php
$vector = new \Ds\Vector([0, 1, 'a', true, false]);

var_dump($vector->filter());
?>

以上例程的输出类似于：

object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Attempts to find a value's index

  • ? Ds\Vector::filter
  • Ds\Vector::first ?
  • PHP Manual
  • Vector
  • Attempts to find a value's index

Ds\Vector::find

(PECL ds >= 1.0.0)

Ds\Vector::find — Attempts to find a value's index

说明

public Ds\Vector::find ( mixed $value ) : mixed

Returns the index of the value, or false if not found.

参数

value

The value to find.

返回值

The index of the value, or false if not found.

Note:

Values will be compared by value and by type.

范例

Example #1 Ds\Vector::find() example

<?php
$vector = new \Ds\Vector(["a", 1, true]);

var_dump($vector->find("a")); // 0
var_dump($vector->find("b")); // false
var_dump($vector->find("1")); // false
var_dump($vector->find(1));   // 1
?>

以上例程的输出类似于：

int(0)
bool(false)
bool(false)
int(1)


Returns the first value in the vector

  • ? Ds\Vector::find
  • Ds\Vector::get ?
  • PHP Manual
  • Vector
  • Returns the first value in the vector

Ds\Vector::first

(PECL ds >= 1.0.0)

Ds\Vector::first — Returns the first value in the vector

说明

public Ds\Vector::first ( ) : mixed

Returns the first value in the vector.

参数

此函数没有参数。

返回值

The first value in the vector.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Vector::first() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->first());
?>

以上例程的输出类似于：

int(1)


Returns the value at a given index

  • ? Ds\Vector::first
  • Ds\Vector::insert ?
  • PHP Manual
  • Vector
  • Returns the value at a given index

Ds\Vector::get

(PECL ds >= 1.0.0)

Ds\Vector::get — Returns the value at a given index

说明

public Ds\Vector::get ( int $index ) : mixed

Returns the value at a given index.

参数

index

The index to access, starting at 0.

返回值

The value at the requested index.

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Vector::get() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->get(0));
var_dump($vector->get(1));
var_dump($vector->get(2));
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"

Example #2 Ds\Vector::get() example using array syntax

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector[0]);
var_dump($vector[1]);
var_dump($vector[2]);
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Inserts values at a given index

  • ? Ds\Vector::get
  • Ds\Vector::isEmpty ?
  • PHP Manual
  • Vector
  • Inserts values at a given index

Ds\Vector::insert

(PECL ds >= 1.0.0)

Ds\Vector::insert — Inserts values at a given index

说明

public Ds\Vector::insert ( int $index , mixed ...$values ) : void

Inserts values into the vector at a given index.

参数

index

The index at which to insert. 0 <= index <= count

Note:

You can insert at the index equal to the number of values.

values

The value or values to insert.

返回值

没有返回值。

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Vector::insert() example

<?php
$vector = new \Ds\Vector();

$vector->insert(0, "e");             // [e]
$vector->insert(1, "f");             // [e, f]
$vector->insert(2, "g");             // [e, f, g]
$vector->insert(0, "a", "b");        // [a, b, e, f, g]
$vector->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($vector);
?>

以上例程的输出类似于：

object(Ds\Vector)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}


Returns whether the vector is empty

  • ? Ds\Vector::insert
  • Ds\Vector::join ?
  • PHP Manual
  • Vector
  • Returns whether the vector is empty

Ds\Vector::isEmpty

(PECL ds >= 1.0.0)

Ds\Vector::isEmpty — Returns whether the vector is empty

说明

public Ds\Vector::isEmpty ( ) : bool

Returns whether the vector is empty.

参数

此函数没有参数。

返回值

Returns true if the vector is empty, false otherwise.

范例

Example #1 Ds\Vector::isEmpty() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = new \Ds\Vector();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Joins all values together as a string

  • ? Ds\Vector::isEmpty
  • Ds\Vector::jsonSerialize ?
  • PHP Manual
  • Vector
  • Joins all values together as a string

Ds\Vector::join

(PECL ds >= 1.0.0)

Ds\Vector::join — Joins all values together as a string

说明

public Ds\Vector::join ( string $glue = ? ) : string

Joins all values together as a string using an optional separator between each value.

参数

glue

An optional string to separate each value.

返回值

All values of the vector joined together as a string.

范例

Example #1 Ds\Vector::join() example using a separator string

<?php
$vector = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($vector->join("|"));
?>

以上例程的输出类似于：

string(11) "a|b|c|1|2|3"

Example #2 Ds\Vector::join() example without a separator string

<?php
$vector = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($vector->join());
?>

以上例程的输出类似于：

string(11) "abc123"


Returns a representation that can be converted to JSON

  • ? Ds\Vector::join
  • Ds\Vector::last ?
  • PHP Manual
  • Vector
  • Returns a representation that can be converted to JSON

Ds\Vector::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Note:

You should never need to call this directly.


Returns the last value

  • ? Ds\Vector::jsonSerialize
  • Ds\Vector::map ?
  • PHP Manual
  • Vector
  • Returns the last value

Ds\Vector::last

(PECL ds >= 1.0.0)

Ds\Vector::last — Returns the last value

说明

public Ds\Vector::last ( ) : mixed

Returns the last value in the vector.

参数

此函数没有参数。

返回值

The last value in the vector.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Vector::last() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->last());
?>

以上例程的输出类似于：

int(3)


Returns the result of applying a callback to each value

  • ? Ds\Vector::last
  • Ds\Vector::merge ?
  • PHP Manual
  • Vector
  • Returns the result of applying a callback to each value

Ds\Vector::map

(PECL ds >= 1.0.0)

Ds\Vector::map — Returns the result of applying a callback to each value

说明

public Ds\Vector::map ( callable $callback ) : Ds\Vector

Returns the result of applying a callback function to each value in the vector.

参数

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the vector.

The callable should return what the new value will be in the new vector.

返回值

The result of applying a callback to each value in the vector.

Note:

The values of the current instance won't be affected.

范例

Example #1 Ds\Vector::map() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

print_r($vector->map(function($value) { return $value * 2; }));
print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)


Returns the result of adding all given values to the vector

  • ? Ds\Vector::map
  • Ds\Vector::pop ?
  • PHP Manual
  • Vector
  • Returns the result of adding all given values to the vector

Ds\Vector::merge

(PECL ds >= 1.0.0)

Ds\Vector::merge — Returns the result of adding all given values to the vector

说明

public Ds\Vector::merge ( mixed $values ) : Ds\Vector

Returns the result of adding all given values to the vector.

参数

values

A traversable object or an array.

返回值

The result of adding all given values to the vector, effectively the same as adding the values to a copy, then returning that copy.

Note:

The current instance won't be affected.

范例

Example #1 Ds\Vector::merge() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->merge([4, 5, 6]));
var_dump($vector);
?>

以上例程的输出类似于：

object(Ds\Vector)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Vector)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Removes and returns the last value

  • ? Ds\Vector::merge
  • Ds\Vector::push ?
  • PHP Manual
  • Vector
  • Removes and returns the last value

Ds\Vector::pop

(PECL ds >= 1.0.0)

Ds\Vector::pop — Removes and returns the last value

说明

public Ds\Vector::pop ( ) : mixed

Removes and returns the last value.

参数

此函数没有参数。

返回值

The removed last value.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Vector::pop() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->pop());
var_dump($vector->pop());
var_dump($vector->pop());
?>

以上例程的输出类似于：

int(3)
int(2)
int(1)


Adds values to the end of the vector

  • ? Ds\Vector::pop
  • Ds\Vector::reduce ?
  • PHP Manual
  • Vector
  • Adds values to the end of the vector

Ds\Vector::push

(PECL ds >= 1.0.0)

Ds\Vector::push — Adds values to the end of the vector

说明

public Ds\Vector::push ( mixed ...$values ) : void

Adds values to the end of the vector.

参数

values

The values to add.

返回值

没有返回值。

范例

Example #1 Ds\Vector::push() example

<?php
$vector = new \Ds\Vector();

$vector->push("a");
$vector->push("b");
$vector->push("c", "d");
$vector->push(...["e", "f"]);

print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Reduces the vector to a single value using a callback function

  • ? Ds\Vector::push
  • Ds\Vector::remove ?
  • PHP Manual
  • Vector
  • Reduces the vector to a single value using a callback function

Ds\Vector::reduce

(PECL ds >= 1.0.0)

Ds\Vector::reduce — Reduces the vector to a single value using a callback function

说明

public Ds\Vector::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the vector to a single value using a callback function.

参数

callback
callback ( mixed $carry , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

返回值

The return value of the final callback.

范例

Example #1 Ds\Vector::reduce() with initial value example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($vector->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

以上例程的输出类似于：

int(30)

Example #2 Ds\Vector::reduce() without an initial value example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

以上例程的输出类似于：

int(21)


Removes and returns a value by index

  • ? Ds\Vector::reduce
  • Ds\Vector::reverse ?
  • PHP Manual
  • Vector
  • Removes and returns a value by index

Ds\Vector::remove

(PECL ds >= 1.0.0)

Ds\Vector::remove — Removes and returns a value by index

说明

public Ds\Vector::remove ( int $index ) : mixed

Removes and returns a value by index.

参数

index

The index of the value to remove.

返回值

The value that was removed.

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Vector::remove() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->remove(1));
var_dump($vector->remove(0));
var_dump($vector->remove(0));
?>

以上例程的输出类似于：

string(1) "b"
string(1) "a"
string(1) "c"


Reverses the vector in-place

  • ? Ds\Vector::remove
  • Ds\Vector::reversed ?
  • PHP Manual
  • Vector
  • Reverses the vector in-place

Ds\Vector::reverse

(PECL ds >= 1.0.0)

Ds\Vector::reverse — Reverses the vector in-place

说明

public Ds\Vector::reverse ( ) : void

Reverses the vector in-place.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Vector::reverse() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);
$vector->reverse();

print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)


Returns a reversed copy

  • ? Ds\Vector::reverse
  • Ds\Vector::rotate ?
  • PHP Manual
  • Vector
  • Returns a reversed copy

Ds\Vector::reversed

(PECL ds >= 1.0.0)

Ds\Vector::reversed — Returns a reversed copy

说明

public Ds\Vector::reversed ( ) : Ds\Vector

Returns a reversed copy of the vector.

参数

此函数没有参数。

返回值

A reversed copy of the vector.

Note:

The current instance is not affected.

范例

Example #1 Ds\Vector::reversed() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

print_r($vector->reversed());
print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
)


Rotates the vector by a given number of rotations

  • ? Ds\Vector::reversed
  • Ds\Vector::set ?
  • PHP Manual
  • Vector
  • Rotates the vector by a given number of rotations

Ds\Vector::rotate

(PECL ds >= 1.0.0)

Ds\Vector::rotate — Rotates the vector by a given number of rotations

说明

public Ds\Vector::rotate ( int $rotations ) : void

Rotates the vector by a given number of rotations, which is equivalent to successively calling $vector->push($vector->shift()) if the number of rotations is positive, or $vector->unshift($vector->pop()) if negative.

参数

rotations

The number of times the vector should be rotated.

返回值

没有返回值。. The vector of the current instance will be rotated.

范例

Example #1 Ds\Vector::rotate() example

<?php
$vector = new \Ds\Vector(["a", "b", "c", "d"]);

$vector->rotate(1);  // "a" is shifted, then pushed.
print_r($vector);

$vector->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($vector);
?>

以上例程的输出类似于：

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Vector Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)


Updates a value at a given index

  • ? Ds\Vector::rotate
  • Ds\Vector::shift ?
  • PHP Manual
  • Vector
  • Updates a value at a given index

Ds\Vector::set

(PECL ds >= 1.0.0)

Ds\Vector::set — Updates a value at a given index

说明

public Ds\Vector::set ( int $index , mixed $value ) : void

Updates a value at a given index.

参数

index

The index of the value to update.

value

The new value.

返回值

没有返回值。

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Vector::set() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

$vector->set(1, "_");
print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)

Example #2 Ds\Vector::set() example using array syntax

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

$vector[1] = "_";
print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)


Removes and returns the first value

  • ? Ds\Vector::set
  • Ds\Vector::slice ?
  • PHP Manual
  • Vector
  • Removes and returns the first value

Ds\Vector::shift

(PECL ds >= 1.0.0)

Ds\Vector::shift — Removes and returns the first value

说明

public Ds\Vector::shift ( ) : mixed

Removes and returns the first value.

参数

此函数没有参数。

返回值

The first value, which was removed.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Vector::shift() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->shift());
var_dump($vector->shift());
var_dump($vector->shift());
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Returns a sub-vector of a given range

  • ? Ds\Vector::shift
  • Ds\Vector::sort ?
  • PHP Manual
  • Vector
  • Returns a sub-vector of a given range

Ds\Vector::slice

(PECL ds >= 1.0.0)

Ds\Vector::slice — Returns a sub-vector of a given range

说明

public Ds\Vector::slice ( int $index , int $length = ? ) : Ds\Vector

Creates a sub-vector of a given range.

参数

index

The index at which the sub-vector starts.

If positive, the vector will start at that index in the vector. If negative, the vector will start that far from the end.

length

If a length is given and is positive, the resulting vector will have up to that many values in it. If the length results in an overflow, only values up to the end of the vector will be included. If a length is given and is negative, the vector will stop that many values from the end. If a length is not provided, the resulting vector will contain all values between the index and the end of the vector.

返回值

A sub-vector of the given range.

范例

Example #1 Ds\Vector::slice() example

<?php
$vector = new \Ds\Vector(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($vector->slice(2));

// Slice from 1, for a length of 3
print_r($vector->slice(1, 3));

// Slice from 1 onwards
print_r($vector->slice(1));

// Slice from 2 from the end onwards
print_r($vector->slice(-2));

// Slice from 1 to 1 from the end
print_r($vector->slice(1, -1));
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Vector Object
(
    [0] => d
    [1] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)


Sorts the vector in-place

  • ? Ds\Vector::slice
  • Ds\Vector::sorted ?
  • PHP Manual
  • Vector
  • Sorts the vector in-place

Ds\Vector::sort

(PECL ds >= 1.0.0)

Ds\Vector::sort — Sorts the vector in-place

说明

public Ds\Vector::sort ( callable $comparator = ? ) : void

Sorts the vector in-place, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

没有返回值。

范例

Example #1 Ds\Vector::sort() example

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);
$vector->sort();

print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Example #2 Ds\Vector::sort() example using a comparator

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

$vector->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns a sorted copy

  • ? Ds\Vector::sort
  • Ds\Vector::sum ?
  • PHP Manual
  • Vector
  • Returns a sorted copy

Ds\Vector::sorted

(PECL ds >= 1.0.0)

Ds\Vector::sorted — Returns a sorted copy

说明

public Ds\Vector::sorted ( callable $comparator = ? ) : Ds\Vector

Returns a sorted copy, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

Returns a sorted copy of the vector.

范例

Example #1 Ds\Vector::sorted() example

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

print_r($vector->sorted());
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Example #2 Ds\Vector::sorted() example using a comparator

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

$sorted = $vector->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns the sum of all values in the vector

  • ? Ds\Vector::sorted
  • Ds\Vector::toArray ?
  • PHP Manual
  • Vector
  • Returns the sum of all values in the vector

Ds\Vector::sum

(PECL ds >= 1.0.0)

Ds\Vector::sum — Returns the sum of all values in the vector

说明

public Ds\Vector::sum ( ) : int|float

Returns the sum of all values in the vector.

Note:

Arrays and objects are considered equal to zero when calculating the sum.

参数

此函数没有参数。

返回值

The sum of all the values in the vector as either a float or int depending on the values in the vector.

范例

Example #1 Ds\Vector::sum() integer example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->sum());
?>

以上例程的输出类似于：

int(6)

Example #2 Ds\Vector::sum() float example

<?php
$vector = new \Ds\Vector([1, 2.5, 3]);
var_dump($vector->sum());
?>

以上例程的输出类似于：

float(6.5)


Converts the vector to an array

  • ? Ds\Vector::sum
  • Ds\Vector::unshift ?
  • PHP Manual
  • Vector
  • Converts the vector to an array

Ds\Vector::toArray

(PECL ds >= 1.0.0)

Ds\Vector::toArray — Converts the vector to an array

说明

public Ds\Vector::toArray ( ) : array

Converts the vector to an array.

Note:

Casting to an array is not supported yet.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the vector.

范例

Example #1 Ds\Vector::toArray() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->toArray());
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Adds values to the front of the vector

  • ? Ds\Vector::toArray
  • Deque ?
  • PHP Manual
  • Vector
  • Adds values to the front of the vector

Ds\Vector::unshift

(PECL ds >= 1.0.0)

Ds\Vector::unshift — Adds values to the front of the vector

说明

public Ds\Vector::unshift ( mixed $values = ? ) : void

Adds values to the front of the vector, moving all the current values forward to make room for the new values.

参数

values

The values to add to the front of the vector.

Note:

Multiple values will be added in the same order that they are passed.

返回值

没有返回值。

范例

Example #1 Ds\Vector::unshift() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

$vector->unshift("a");
$vector->unshift("b", "c");

print_r($vector);
?>

以上例程的输出类似于：

Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)


The Deque class

(No version information available, might only be in Git)

简介

A Deque (pronounced "deck") is a sequence of values in a contiguous buffer that grows and shrinks automatically. The name is a common abbreviation of "double-ended queue" and is used internally by Ds\Queue.

Two pointers are used to keep track of a head and a tail. The pointers can "wrap around" the end of the buffer, which avoids the need to move other values around to make room. This makes shift and unshift very fast?—? something a Ds\Vector can't compete with.

Accessing a value by index requires a translation between the index and its corresponding position in the buffer: ((head + position) % capacity).

Strengths

  • Supports array syntax (square brackets).
  • Uses less overall memory than an array for the same number of values.
  • Automatically frees allocated memory when its size drops low enough.
  • get(),
set(),
push(),
pop(),
shift(), and
unshift() are all O(1).

Weaknesses

  • Capacity must be a power of 2.
  • insert() and remove() are O(n).

类摘要

Ds\Deque implements Ds\Sequence , ArrayAccess {
/* Constants */
const int MIN_CAPACITY = 8 ;
/* 方法 */
public allocate ( int $capacity ) : void
public apply ( callable $callback ) : void
public capacity ( ) : int
public clear ( ) : void
public contains ( mixed ...$values ) : bool
public copy ( ) : Ds\Deque
public filter ( callable $callback = ? ) : Ds\Deque
public find ( mixed $value ) : mixed
public first ( ) : mixed
public get ( int $index ) : mixed
public insert ( int $index , mixed ...$values ) : void
public isEmpty ( ) : bool
public join ( string $glue = ? ) : string
public last ( ) : mixed
public map ( callable $callback ) : Ds\Deque
public merge ( mixed $values ) : Ds\Deque
public pop ( ) : mixed
public push ( mixed ...$values ) : void
public reduce ( callable $callback , mixed $initial = ? ) : mixed
public remove ( int $index ) : mixed
public reverse ( ) : void
public reversed ( ) : Ds\Deque
public rotate ( int $rotations ) : void
public set ( int $index , mixed $value ) : void
public shift ( ) : mixed
public slice ( int $index , int $length = ? ) : Ds\Deque
public sort ( callable $comparator = ? ) : void
public sorted ( callable $comparator = ? ) : Ds\Deque
public sum ( ) : int|float
public toArray ( ) : array
public unshift ( mixed $values = ? ) : void
}

预定义常量

Ds\Deque::MIN_CAPACITY

更新日志

版本 | 说明
PECL ds 1.3.0 | The class now implements ArrayAccess.

Table of Contents

  • Ds\Deque::allocate — Allocates enough memory for a required capacity
  • Ds\Deque::apply — Updates all values by applying a callback function to each value
  • Ds\Deque::capacity — Returns the current capacity
  • Ds\Deque::clear — Removes all values from the deque
  • Ds\Deque::__construct — Creates a new instance
  • Ds\Deque::contains — Determines if the deque contains given values
  • Ds\Deque::copy — Returns a shallow copy of the deque
  • Ds\Deque::count — Returns the number of values in the collection
  • Ds\Deque::filter — Creates a new deque using a callable to determine which values to include
  • Ds\Deque::find — Attempts to find a value's index
  • Ds\Deque::first — Returns the first value in the deque
  • Ds\Deque::get — Returns the value at a given index
  • Ds\Deque::insert — Inserts values at a given index
  • Ds\Deque::isEmpty — Returns whether the deque is empty
  • Ds\Deque::join — Joins all values together as a string
  • Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Deque::last — Returns the last value
  • Ds\Deque::map — Returns the result of applying a callback to each value
  • Ds\Deque::merge — Returns the result of adding all given values to the deque
  • Ds\Deque::pop — Removes and returns the last value
  • Ds\Deque::push — Adds values to the end of the deque
  • Ds\Deque::reduce — Reduces the deque to a single value using a callback function
  • Ds\Deque::remove — Removes and returns a value by index
  • Ds\Deque::reverse — Reverses the deque in-place
  • Ds\Deque::reversed — Returns a reversed copy
  • Ds\Deque::rotate — Rotates the deque by a given number of rotations
  • Ds\Deque::set — Updates a value at a given index
  • Ds\Deque::shift — Removes and returns the first value
  • Ds\Deque::slice — Returns a sub-deque of a given range
  • Ds\Deque::sort — Sorts the deque in-place
  • Ds\Deque::sorted — Returns a sorted copy
  • Ds\Deque::sum — Returns the sum of all values in the deque
  • Ds\Deque::toArray — Converts the deque to an array
  • Ds\Deque::unshift — Adds values to the front of the deque


Allocates enough memory for a required capacity

  • ? Deque
  • Ds\Deque::apply ?
  • PHP Manual
  • Deque
  • Allocates enough memory for a required capacity

Ds\Deque::allocate

(PECL ds >= 1.0.0)

Ds\Deque::allocate — Allocates enough memory for a required capacity

说明

public Ds\Deque::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

参数

capacity

The number of values for which capacity should be allocated.

Note:

Capacity will stay the same if this value is less than or equal to the current capacity.

Note:

Capacity will always be rounded up to the nearest power of 2.

返回值

没有返回值。

范例

Example #1 Ds\Deque::allocate() example

<?php
$deque = new \Ds\Deque();
var_dump($deque->capacity());

$deque->allocate(100);
var_dump($deque->capacity());
?>

以上例程的输出类似于：

int(8)
int(128)


Updates all values by applying a callback function to each value

  • ? Ds\Deque::allocate
  • Ds\Deque::capacity ?
  • PHP Manual
  • Deque
  • Updates all values by applying a callback function to each value

Ds\Deque::apply

(PECL ds >= 1.0.0)

Ds\Deque::apply — Updates all values by applying a callback function to each value

说明

public Ds\Deque::apply ( callable $callback ) : void

Updates all values by applying a callback function to each value in the deque.

参数

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the deque.

The callback should return what the value should be replaced by.

返回值

没有返回值。

范例

Example #1 Ds\Deque::apply() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
$deque->apply(function($value) { return $value * 2; });

print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)


Returns the current capacity

  • ? Ds\Deque::apply
  • Ds\Deque::clear ?
  • PHP Manual
  • Deque
  • Returns the current capacity

Ds\Deque::capacity

(PECL ds >= 1.0.0)

Ds\Deque::capacity — Returns the current capacity

说明

public Ds\Deque::capacity ( ) : int

Returns the current capacity.

参数

此函数没有参数。

返回值

The current capacity.

范例

Example #1 Ds\Deque::capacity() example

<?php
$deque = new \Ds\Deque();
var_dump($deque->capacity());

$deque->push(...range(1, 50));
var_dump($deque->capacity());
?>

以上例程的输出类似于：

int(8)
int(64)


Removes all values from the deque

  • ? Ds\Deque::capacity
  • Ds\Deque::__construct ?
  • PHP Manual
  • Deque
  • Removes all values from the deque

Ds\Deque::clear

(PECL ds >= 1.0.0)

Ds\Deque::clear — Removes all values from the deque

说明

public Ds\Deque::clear ( ) : void

Removes all values from the deque.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Deque::clear() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
print_r($deque);

$deque->clear();
print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Deque Object
(
)


Creates a new instance

  • ? Ds\Deque::clear
  • Ds\Deque::contains ?
  • PHP Manual
  • Deque
  • Creates a new instance

Ds\Deque::__construct

(PECL ds >= 1.0.0)

Ds\Deque::__construct — Creates a new instance

说明

public Ds\Deque::__construct ( mixed $values = ? )

Creates a new instance, using either a traversable object or an array for the initial values.

参数

values

A traversable object or an array to use for the initial values.

范例

Example #1 Ds\Deque::__construct() example

<?php
$deque = new \Ds\Deque();
var_dump($deque);

$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque);
?>

以上例程的输出类似于：

object(Ds\Deque)#2 (0) {
}
object(Ds\Deque)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Determines if the deque contains given values

  • ? Ds\Deque::__construct
  • Ds\Deque::copy ?
  • PHP Manual
  • Deque
  • Determines if the deque contains given values

Ds\Deque::contains

(PECL ds >= 1.0.0)

Ds\Deque::contains — Determines if the deque contains given values

说明

public Ds\Deque::contains ( mixed ...$values ) : bool

Determines if the deque contains all values.

参数

values

Values to check.

返回值

false if any of the provided values are not in the deque, true otherwise.

范例

Example #1 Ds\Deque::contains() example

<?php
$deque = new \Ds\Deque(['a', 'b', 'c', 1, 2, 3]);

var_dump($deque->contains('a'));                // true
var_dump($deque->contains('a', 'b'));           // true
var_dump($deque->contains('c', 'd'));           // false

var_dump($deque->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($deque->contains(1));                  // true
var_dump($deque->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)


Returns a shallow copy of the deque

  • ? Ds\Deque::contains
  • Ds\Deque::count ?
  • PHP Manual
  • Deque
  • Returns a shallow copy of the deque

Ds\Deque::copy

(PECL ds >= 1.0.0)

Ds\Deque::copy — Returns a shallow copy of the deque

说明

public Ds\Deque::copy ( ) : Ds\Deque

Returns a shallow copy of the deque.

参数

此函数没有参数。

返回值

A shallow copy of the deque.

范例

Example #1 Ds\Deque::copy() example

<?php
$a = new \Ds\Deque([1, 2, 3]);
$b = $a->copy();

$b->push(4);

print_r($a);
print_r($b);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns the number of values in the collection

  • ? Ds\Deque::copy
  • Ds\Deque::filter ?
  • PHP Manual
  • Deque
  • Returns the number of values in the collection

Ds\Deque::count

(PECL ds >= 1.0.0)

Ds\Deque::count — Returns the number of values in the collection

See Countable::count()


Creates a new deque using a callable to determine which values to include

  • ? Ds\Deque::count
  • Ds\Deque::find ?
  • PHP Manual
  • Deque
  • Creates a new deque using a callable to determine which values to include

Ds\Deque::filter

(PECL ds >= 1.0.0)

Ds\Deque::filter — Creates a new deque using a callable to determine which values to include

说明

public Ds\Deque::filter ( callable $callback = ? ) : Ds\Deque

Creates a new deque using a callable to determine which values to include.

参数

callback

callback ( mixed $value ) : bool

Optional callable which returns true if the value should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

返回值

A new deque containing all the values for which either the callback returned true, or all values that convert to true if a callback was not provided.

范例

Example #1 Ds\Deque::filter() example using callback function

<?php
$deque = new \Ds\Deque([1, 2, 3, 4, 5]);

var_dump($deque->filter(function($value) {
    return $value % 2 == 0;
}));
?>

以上例程的输出类似于：

object(Ds\Deque)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Example #2 Ds\Deque::filter() example without a callback function

<?php
$deque = new \Ds\Deque([0, 1, 'a', true, false]);

var_dump($deque->filter());
?>

以上例程的输出类似于：

object(Ds\Deque)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Attempts to find a value's index

  • ? Ds\Deque::filter
  • Ds\Deque::first ?
  • PHP Manual
  • Deque
  • Attempts to find a value's index

Ds\Deque::find

(PECL ds >= 1.0.0)

Ds\Deque::find — Attempts to find a value's index

说明

public Ds\Deque::find ( mixed $value ) : mixed

Returns the index of the value, or false if not found.

参数

value

The value to find.

返回值

The index of the value, or false if not found.

Note:

Values will be compared by value and by type.

范例

Example #1 Ds\Deque::find() example

<?php
$deque = new \Ds\Deque(["a", 1, true]);

var_dump($deque->find("a")); // 0
var_dump($deque->find("b")); // false
var_dump($deque->find("1")); // false
var_dump($deque->find(1));   // 1
?>

以上例程的输出类似于：

int(0)
bool(false)
bool(false)
int(1)


Returns the first value in the deque

  • ? Ds\Deque::find
  • Ds\Deque::get ?
  • PHP Manual
  • Deque
  • Returns the first value in the deque

Ds\Deque::first

(PECL ds >= 1.0.0)

Ds\Deque::first — Returns the first value in the deque

说明

public Ds\Deque::first ( ) : mixed

Returns the first value in the deque.

参数

此函数没有参数。

返回值

The first value in the deque.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Deque::first() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->first());
?>

以上例程的输出类似于：

int(1)


Returns the value at a given index

  • ? Ds\Deque::first
  • Ds\Deque::insert ?
  • PHP Manual
  • Deque
  • Returns the value at a given index

Ds\Deque::get

(PECL ds >= 1.0.0)

Ds\Deque::get — Returns the value at a given index

说明

public Ds\Deque::get ( int $index ) : mixed

Returns the value at a given index.

参数

index

The index to access, starting at 0.

返回值

The value at the requested index.

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Deque::get() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->get(0));
var_dump($deque->get(1));
var_dump($deque->get(2));
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"

Example #2 Ds\Deque::get() example using array syntax

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque[0]);
var_dump($deque[1]);
var_dump($deque[2]);
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Inserts values at a given index

  • ? Ds\Deque::get
  • Ds\Deque::isEmpty ?
  • PHP Manual
  • Deque
  • Inserts values at a given index

Ds\Deque::insert

(PECL ds >= 1.0.0)

Ds\Deque::insert — Inserts values at a given index

说明

public Ds\Deque::insert ( int $index , mixed ...$values ) : void

Inserts values into the deque at a given index.

参数

index

The index at which to insert. 0 <= index <= count

Note:

You can insert at the index equal to the number of values.

values

The value or values to insert.

返回值

没有返回值。

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Deque::insert() example

<?php
$deque = new \Ds\Deque();

$deque->insert(0, "e");             // [e]
$deque->insert(1, "f");             // [e, f]
$deque->insert(2, "g");             // [e, f, g]
$deque->insert(0, "a", "b");        // [a, b, e, f, g]
$deque->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($deque);
?>

以上例程的输出类似于：

object(Ds\Deque)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}


Returns whether the deque is empty

  • ? Ds\Deque::insert
  • Ds\Deque::join ?
  • PHP Manual
  • Deque
  • Returns whether the deque is empty

Ds\Deque::isEmpty

(PECL ds >= 1.0.0)

Ds\Deque::isEmpty — Returns whether the deque is empty

说明

public Ds\Deque::isEmpty ( ) : bool

Returns whether the deque is empty.

参数

此函数没有参数。

返回值

Returns true if the deque is empty, false otherwise.

范例

Example #1 Ds\Deque::isEmpty() example

<?php
$a = new \Ds\Deque([1, 2, 3]);
$b = new \Ds\Deque();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Joins all values together as a string

  • ? Ds\Deque::isEmpty
  • Ds\Deque::jsonSerialize ?
  • PHP Manual
  • Deque
  • Joins all values together as a string

Ds\Deque::join

(PECL ds >= 1.0.0)

Ds\Deque::join — Joins all values together as a string

说明

public Ds\Deque::join ( string $glue = ? ) : string

Joins all values together as a string using an optional separator between each value.

参数

glue

An optional string to separate each value.

返回值

All values of the deque joined together as a string.

范例

Example #1 Ds\Deque::join() example using a separator string

<?php
$deque = new \Ds\Deque(["a", "b", "c", 1, 2, 3]);

var_dump($deque->join("|"));
?>

以上例程的输出类似于：

string(11) "a|b|c|1|2|3"

Example #2 Ds\Deque::join() example without a separator string

<?php
$deque = new \Ds\Deque(["a", "b", "c", 1, 2, 3]);

var_dump($deque->join());
?>

以上例程的输出类似于：

string(11) "abc123"


Returns a representation that can be converted to JSON

  • ? Ds\Deque::join
  • Ds\Deque::last ?
  • PHP Manual
  • Deque
  • Returns a representation that can be converted to JSON

Ds\Deque::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Note:

You should never need to call this directly.


Returns the last value

  • ? Ds\Deque::jsonSerialize
  • Ds\Deque::map ?
  • PHP Manual
  • Deque
  • Returns the last value

Ds\Deque::last

(PECL ds >= 1.0.0)

Ds\Deque::last — Returns the last value

说明

public Ds\Deque::last ( ) : mixed

Returns the last value in the deque.

参数

此函数没有参数。

返回值

The last value in the deque.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Deque::last() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->last());
?>

以上例程的输出类似于：

int(3)


Returns the result of applying a callback to each value

  • ? Ds\Deque::last
  • Ds\Deque::merge ?
  • PHP Manual
  • Deque
  • Returns the result of applying a callback to each value

Ds\Deque::map

(PECL ds >= 1.0.0)

Ds\Deque::map — Returns the result of applying a callback to each value

说明

public Ds\Deque::map ( callable $callback ) : Ds\Deque

Returns the result of applying a callback function to each value in the deque.

参数

callback

callback ( mixed $value ) : mixed

A callable to apply to each value in the deque.

The callable should return what the new value will be in the new deque.

返回值

The result of applying a callback to each value in the deque.

Note:

The values of the current instance won't be affected.

范例

Example #1 Ds\Deque::map() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

print_r($deque->map(function($value) { return $value * 2; }));
print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)


Returns the result of adding all given values to the deque

  • ? Ds\Deque::map
  • Ds\Deque::pop ?
  • PHP Manual
  • Deque
  • Returns the result of adding all given values to the deque

Ds\Deque::merge

(PECL ds >= 1.0.0)

Ds\Deque::merge — Returns the result of adding all given values to the deque

说明

public Ds\Deque::merge ( mixed $values ) : Ds\Deque

Returns the result of adding all given values to the deque.

参数

values

A traversable object or an array.

返回值

The result of adding all given values to the deque, effectively the same as adding the values to a copy, then returning that copy.

Note:

The current instance won't be affected.

范例

Example #1 Ds\Deque::merge() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->merge([4, 5, 6]));
var_dump($deque);
?>

以上例程的输出类似于：

object(Ds\Deque)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Deque)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Removes and returns the last value

  • ? Ds\Deque::merge
  • Ds\Deque::push ?
  • PHP Manual
  • Deque
  • Removes and returns the last value

Ds\Deque::pop

(PECL ds >= 1.0.0)

Ds\Deque::pop — Removes and returns the last value

说明

public Ds\Deque::pop ( ) : mixed

Removes and returns the last value.

参数

此函数没有参数。

返回值

The removed last value.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Deque::pop() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->pop());
var_dump($deque->pop());
var_dump($deque->pop());
?>

以上例程的输出类似于：

int(3)
int(2)
int(1)


Adds values to the end of the deque

  • ? Ds\Deque::pop
  • Ds\Deque::reduce ?
  • PHP Manual
  • Deque
  • Adds values to the end of the deque

Ds\Deque::push

(PECL ds >= 1.0.0)

Ds\Deque::push — Adds values to the end of the deque

说明

public Ds\Deque::push ( mixed ...$values ) : void

Adds values to the end of the deque.

参数

values

The values to add.

返回值

没有返回值。

范例

Example #1 Ds\Deque::push() example

<?php
$deque = new \Ds\Deque();

$deque->push("a");
$deque->push("b");
$deque->push("c", "d");
$deque->push(...["e", "f"]);

print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Reduces the deque to a single value using a callback function

  • ? Ds\Deque::push
  • Ds\Deque::remove ?
  • PHP Manual
  • Deque
  • Reduces the deque to a single value using a callback function

Ds\Deque::reduce

(PECL ds >= 1.0.0)

Ds\Deque::reduce — Reduces the deque to a single value using a callback function

说明

public Ds\Deque::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the deque to a single value using a callback function.

参数

callback
callback ( mixed $carry , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

返回值

The return value of the final callback.

范例

Example #1 Ds\Deque::reduce() with initial value example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($deque->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

以上例程的输出类似于：

int(30)

Example #2 Ds\Deque::reduce() without an initial value example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

以上例程的输出类似于：

int(21)


Removes and returns a value by index

  • ? Ds\Deque::reduce
  • Ds\Deque::reverse ?
  • PHP Manual
  • Deque
  • Removes and returns a value by index

Ds\Deque::remove

(PECL ds >= 1.0.0)

Ds\Deque::remove — Removes and returns a value by index

说明

public Ds\Deque::remove ( int $index ) : mixed

Removes and returns a value by index.

参数

index

The index of the value to remove.

返回值

The value that was removed.

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Deque::remove() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->remove(1));
var_dump($deque->remove(0));
var_dump($deque->remove(0));
?>

以上例程的输出类似于：

string(1) "b"
string(1) "a"
string(1) "c"


Reverses the deque in-place

  • ? Ds\Deque::remove
  • Ds\Deque::reversed ?
  • PHP Manual
  • Deque
  • Reverses the deque in-place

Ds\Deque::reverse

(PECL ds >= 1.0.0)

Ds\Deque::reverse — Reverses the deque in-place

说明

public Ds\Deque::reverse ( ) : void

Reverses the deque in-place.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Deque::reverse() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);
$deque->reverse();

print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => c
    [1] => b
    [2] => a
)


Returns a reversed copy

  • ? Ds\Deque::reverse
  • Ds\Deque::rotate ?
  • PHP Manual
  • Deque
  • Returns a reversed copy

Ds\Deque::reversed

(PECL ds >= 1.0.0)

Ds\Deque::reversed — Returns a reversed copy

说明

public Ds\Deque::reversed ( ) : Ds\Deque

Returns a reversed copy of the deque.

参数

此函数没有参数。

返回值

A reversed copy of the deque.

Note:

The current instance is not affected.

范例

Example #1 Ds\Deque::reversed() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

print_r($deque->reversed());
print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Deque Object
(
    [0] => a
    [1] => b
    [2] => c
)


Rotates the deque by a given number of rotations

  • ? Ds\Deque::reversed
  • Ds\Deque::set ?
  • PHP Manual
  • Deque
  • Rotates the deque by a given number of rotations

Ds\Deque::rotate

(PECL ds >= 1.0.0)

Ds\Deque::rotate — Rotates the deque by a given number of rotations

说明

public Ds\Deque::rotate ( int $rotations ) : void

Rotates the deque by a given number of rotations, which is equivalent to successively calling $deque->push($deque->shift()) if the number of rotations is positive, or $deque->unshift($deque->pop()) if negative.

参数

rotations

The number of times the deque should be rotated.

返回值

没有返回值。. The deque of the current instance will be rotated.

范例

Example #1 Ds\Deque::rotate() example

<?php
$deque = new \Ds\Deque(["a", "b", "c", "d"]);

$deque->rotate(1);  // "a" is shifted, then pushed.
print_r($deque);

$deque->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($deque);
?>

以上例程的输出类似于：

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Deque Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)


Updates a value at a given index

  • ? Ds\Deque::rotate
  • Ds\Deque::shift ?
  • PHP Manual
  • Deque
  • Updates a value at a given index

Ds\Deque::set

(PECL ds >= 1.0.0)

Ds\Deque::set — Updates a value at a given index

说明

public Ds\Deque::set ( int $index , mixed $value ) : void

Updates a value at a given index.

参数

index

The index of the value to update.

value

The new value.

返回值

没有返回值。

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Deque::set() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

$deque->set(1, "_");
print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => a
    [1] => _
    [2] => c
)

Example #2 Ds\Deque::set() example using array syntax

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

$deque[1] = "_";
print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => a
    [1] => _
    [2] => c
)


Removes and returns the first value

  • ? Ds\Deque::set
  • Ds\Deque::slice ?
  • PHP Manual
  • Deque
  • Removes and returns the first value

Ds\Deque::shift

(PECL ds >= 1.0.0)

Ds\Deque::shift — Removes and returns the first value

说明

public Ds\Deque::shift ( ) : mixed

Removes and returns the first value.

参数

此函数没有参数。

返回值

The first value, which was removed.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Deque::shift() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->shift());
var_dump($deque->shift());
var_dump($deque->shift());
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Returns a sub-deque of a given range

  • ? Ds\Deque::shift
  • Ds\Deque::sort ?
  • PHP Manual
  • Deque
  • Returns a sub-deque of a given range

Ds\Deque::slice

(PECL ds >= 1.0.0)

Ds\Deque::slice — Returns a sub-deque of a given range

说明

public Ds\Deque::slice ( int $index , int $length = ? ) : Ds\Deque

Creates a sub-deque of a given range.

参数

index

The index at which the sub-deque starts.

If positive, the deque will start at that index in the deque. If negative, the deque will start that far from the end.

length

If a length is given and is positive, the resulting deque will have up to that many values in it. If the length results in an overflow, only values up to the end of the deque will be included. If a length is given and is negative, the deque will stop that many values from the end. If a length is not provided, the resulting deque will contain all values between the index and the end of the deque.

返回值

A sub-deque of the given range.

范例

Example #1 Ds\Deque::slice() example

<?php
$deque = new \Ds\Deque(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($deque->slice(2));

// Slice from 1, for a length of 3
print_r($deque->slice(1, 3));

// Slice from 1 onwards
print_r($deque->slice(1));

// Slice from 2 from the end onwards
print_r($deque->slice(-2));

// Slice from 1 to 1 from the end
print_r($deque->slice(1, -1));
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Deque Object
(
    [0] => d
    [1] => e
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
)


Sorts the deque in-place

  • ? Ds\Deque::slice
  • Ds\Deque::sorted ?
  • PHP Manual
  • Deque
  • Sorts the deque in-place

Ds\Deque::sort

(PECL ds >= 1.0.0)

Ds\Deque::sort — Sorts the deque in-place

说明

public Ds\Deque::sort ( callable $comparator = ? ) : void

Sorts the deque in-place, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

没有返回值。

范例

Example #1 Ds\Deque::sort() example

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);
$deque->sort();

print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Example #2 Ds\Deque::sort() example using a comparator

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

$deque->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns a sorted copy

  • ? Ds\Deque::sort
  • Ds\Deque::sum ?
  • PHP Manual
  • Deque
  • Returns a sorted copy

Ds\Deque::sorted

(PECL ds >= 1.0.0)

Ds\Deque::sorted — Returns a sorted copy

说明

public Ds\Deque::sorted ( callable $comparator = ? ) : Ds\Deque

Returns a sorted copy, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

Returns a sorted copy of the deque.

范例

Example #1 Ds\Deque::sorted() example

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

print_r($deque->sorted());
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Example #2 Ds\Deque::sorted() example using a comparator

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

$sorted = $deque->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns the sum of all values in the deque

  • ? Ds\Deque::sorted
  • Ds\Deque::toArray ?
  • PHP Manual
  • Deque
  • Returns the sum of all values in the deque

Ds\Deque::sum

(PECL ds >= 1.0.0)

Ds\Deque::sum — Returns the sum of all values in the deque

说明

public Ds\Deque::sum ( ) : int|float

Returns the sum of all values in the deque.

Note:

Arrays and objects are considered equal to zero when calculating the sum.

参数

此函数没有参数。

返回值

The sum of all the values in the deque as either a float or int depending on the values in the deque.

范例

Example #1 Ds\Deque::sum() integer example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->sum());
?>

以上例程的输出类似于：

int(6)

Example #2 Ds\Deque::sum() float example

<?php
$deque = new \Ds\Deque([1, 2.5, 3]);
var_dump($deque->sum());
?>

以上例程的输出类似于：

float(6.5)


Converts the deque to an array

  • ? Ds\Deque::sum
  • Ds\Deque::unshift ?
  • PHP Manual
  • Deque
  • Converts the deque to an array

Ds\Deque::toArray

(PECL ds >= 1.0.0)

Ds\Deque::toArray — Converts the deque to an array

说明

public Ds\Deque::toArray ( ) : array

Converts the deque to an array.

Note:

Casting to an array is not supported yet.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the deque.

范例

Example #1 Ds\Deque::toArray() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->toArray());
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Adds values to the front of the deque

  • ? Ds\Deque::toArray
  • Map ?
  • PHP Manual
  • Deque
  • Adds values to the front of the deque

Ds\Deque::unshift

(PECL ds >= 1.0.0)

Ds\Deque::unshift — Adds values to the front of the deque

说明

public Ds\Deque::unshift ( mixed $values = ? ) : void

Adds values to the front of the deque, moving all the current values forward to make room for the new values.

参数

values

The values to add to the front of the deque.

Note:

Multiple values will be added in the same order that they are passed.

返回值

没有返回值。

范例

Example #1 Ds\Deque::unshift() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

$deque->unshift("a");
$deque->unshift("b", "c");

print_r($deque);
?>

以上例程的输出类似于：

Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)


The Map class

(No version information available, might only be in Git)

简介

A Map is a sequential collection of key-value pairs, almost identical to an array used in a similar context. Keys can be any type, but must be unique. Values are replaced if added to the map using the same key.

Strengths

  • Keys and values can be any type, including objects.
  • Supports array syntax (square brackets).
  • Insertion order is preserved.
  • Performance and memory efficiency is very similar to an array.
  • Automatically frees allocated memory when its size drops low enough.

Weaknesses

  • Can't be converted to an array when objects are used as keys.

类摘要

Ds\Map implements Ds\Collection , ArrayAccess {
/* Constants */
const int MIN_CAPACITY = 16 ;
/* 方法 */
public allocate ( int $capacity ) : void
public apply ( callable $callback ) : void
public capacity ( ) : int
public clear ( ) : void
public copy ( ) : Ds\Map
public diff ( Ds\Map $map ) : Ds\Map
public filter ( callable $callback = ? ) : Ds\Map
public first ( ) : Ds\Pair
public get ( mixed $key , mixed $default = ? ) : mixed
public hasKey ( mixed $key ) : bool
public hasValue ( mixed $value ) : bool
public intersect ( Ds\Map $map ) : Ds\Map
public isEmpty ( ) : bool
public keys ( ) : Ds\Set
public ksort ( callable $comparator = ? ) : void
public ksorted ( callable $comparator = ? ) : Ds\Map
public last ( ) : Ds\Pair
public map ( callable $callback ) : Ds\Map
public merge ( mixed $values ) : Ds\Map
public pairs ( ) : Ds\Sequence
public put ( mixed $key , mixed $value ) : void
public putAll ( mixed $pairs ) : void
public reduce ( callable $callback , mixed $initial = ? ) : mixed
public remove ( mixed $key , mixed $default = ? ) : mixed
public reverse ( ) : void
public reversed ( ) : Ds\Map
public skip ( int $position ) : Ds\Pair
public slice ( int $index , int $length = ? ) : Ds\Map
public sort ( callable $comparator = ? ) : void
public sorted ( callable $comparator = ? ) : Ds\Map
public sum ( ) : int|float
public toArray ( ) : array
public union ( Ds\Map $map ) : Ds\Map
public values ( ) : Ds\Sequence
public xor ( Ds\Map $map ) : Ds\Map
}

预定义常量

Ds\Map::MIN_CAPACITY

更新日志

版本 | 说明
PECL ds 1.3.0 | The class now implements ArrayAccess.

Table of Contents

  • Ds\Map::allocate — Allocates enough memory for a required capacity
  • Ds\Map::apply — Updates all values by applying a callback function to each value
  • Ds\Map::capacity — Returns the current capacity
  • Ds\Map::clear — Removes all values
  • Ds\Map::__construct — Creates a new instance
  • Ds\Map::copy — Returns a shallow copy of the map
  • Ds\Map::count — Returns the number of values in the map
  • Ds\Map::diff — Creates a new map using keys that aren't in another map
  • Ds\Map::filter — Creates a new map using a callable to determine which pairs to include
  • Ds\Map::first — Returns the first pair in the map
  • Ds\Map::get — Returns the value for a given key
  • Ds\Map::hasKey — Determines whether the map contains a given key
  • Ds\Map::hasValue — Determines whether the map contains a given value
  • Ds\Map::intersect — Creates a new map by intersecting keys with another map
  • Ds\Map::isEmpty — Returns whether the map is empty
  • Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Map::keys — Returns a set of the map's keys
  • Ds\Map::ksort — Sorts the map in-place by key
  • Ds\Map::ksorted — Returns a copy, sorted by key
  • Ds\Map::last — Returns the last pair of the map
  • Ds\Map::map — Returns the result of applying a callback to each value
  • Ds\Map::merge — Returns the result of adding all given associations
  • Ds\Map::pairs — Returns a sequence containing all the pairs of the map
  • Ds\Map::put — Associates a key with a value
  • Ds\Map::putAll — Associates all key-value pairs of a traversable object or array
  • Ds\Map::reduce — Reduces the map to a single value using a callback function
  • Ds\Map::remove — Removes and returns a value by key
  • Ds\Map::reverse — Reverses the map in-place
  • Ds\Map::reversed — Returns a reversed copy
  • Ds\Map::skip — Returns the pair at a given positional index
  • Ds\Map::slice — Returns a subset of the map defined by a starting index and length
  • Ds\Map::sort — Sorts the map in-place by value
  • Ds\Map::sorted — Returns a copy, sorted by value
  • Ds\Map::sum — Returns the sum of all values in the map
  • Ds\Map::toArray — Converts the map to an array
  • Ds\Map::union — Creates a new map using values from the current instance and another map
  • Ds\Map::values — Returns a sequence of the map's values
  • Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both


Allocates enough memory for a required capacity

  • ? Map
  • Ds\Map::apply ?
  • PHP Manual
  • Map
  • Allocates enough memory for a required capacity

Ds\Map::allocate

(PECL ds >= 1.0.0)

Ds\Map::allocate — Allocates enough memory for a required capacity

说明

public Ds\Map::allocate ( int $capacity ) : void

Allocates enough memory for a required capacity.

参数

capacity

The number of values for which capacity should be allocated.

Note:

Capacity will stay the same if this value is less than or equal to the current capacity.

Note:

Capacity will always be rounded up to the nearest power of 2.

返回值

没有返回值。

范例

Example #1 Ds\Map::allocate() example

<?php
$map = new \Ds\Map();
var_dump($map->capacity());

$map->allocate(100);
var_dump($map->capacity());
?>

以上例程的输出类似于：

int(16)
int(128)


Updates all values by applying a callback function to each value

  • ? Ds\Map::allocate
  • Ds\Map::capacity ?
  • PHP Manual
  • Map
  • Updates all values by applying a callback function to each value

Ds\Map::apply

(PECL ds >= 1.0.0)

Ds\Map::apply — Updates all values by applying a callback function to each value

说明

public Ds\Map::apply ( callable $callback ) : void

Updates all values by applying a callback function to each value in the map.

参数

callback

callback ( mixed $key , mixed $value ) : mixed

A callable to apply to each value in the map.

The callback should return what the value should be replaced by.

返回值

没有返回值。

范例

Example #1 Ds\Map::apply() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$map->apply(function($key, $value) { return $value * 2; });

print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 4
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 6
        )

)


Returns the current capacity

  • ? Ds\Map::apply
  • Ds\Map::clear ?
  • PHP Manual
  • Map
  • Returns the current capacity

Ds\Map::capacity

(PECL ds >= 1.0.0)

Ds\Map::capacity — Returns the current capacity

说明

public Ds\Map::capacity ( ) : int

Returns the current capacity.

参数

此函数没有参数。

返回值

The current capacity.

范例

Example #1 Ds\Map::capacity() example

<?php
$map = new \Ds\Map();
var_dump($map->capacity());
?>

以上例程的输出类似于：

int(16)


Removes all values

  • ? Ds\Map::capacity
  • Ds\Map::__construct ?
  • PHP Manual
  • Map
  • Removes all values

Ds\Map::clear

(PECL ds >= 1.0.0)

Ds\Map::clear — Removes all values

说明

public Ds\Map::clear ( ) : void

Removes all values from the map.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Map::clear() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);
print_r($map);

$map->clear();
print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)
Ds\Map Object
(
)


Creates a new instance

  • ? Ds\Map::clear
  • Ds\Map::copy ?
  • PHP Manual
  • Map
  • Creates a new instance

Ds\Map::__construct

(PECL ds >= 1.0.0)

Ds\Map::__construct — Creates a new instance

说明

public Ds\Map::__construct ( mixed ...$values )

Creates a new instance, using either a traversable object or an array for the initial values.

参数

values

A traversable object or an array to use for the initial values.

范例

Example #1 Ds\Map::__construct() example

<?php
$map = new \Ds\Map();
var_dump($map);

$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map);
?>

以上例程的输出类似于：

object(Ds\Map)#1 (0) {
}
object(Ds\Map)#2 (3) {
  [0]=>
  object(Ds\Pair)#1 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
  [1]=>
  object(Ds\Pair)#3 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [2]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}


Returns a shallow copy of the map

  • ? Ds\Map::__construct
  • Ds\Map::count ?
  • PHP Manual
  • Map
  • Returns a shallow copy of the map

Ds\Map::copy

(PECL ds >= 1.0.0)

Ds\Map::copy — Returns a shallow copy of the map

说明

public Ds\Map::copy ( ) : Ds\Map

Returns a shallow copy of the map.

参数

此函数没有参数。

返回值

Returns a shallow copy of the map.

范例

Example #1 Ds\Map::copy() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

print_r($map->copy());
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)


Returns the number of values in the map

  • ? Ds\Map::copy
  • Ds\Map::diff ?
  • PHP Manual
  • Map
  • Returns the number of values in the map

Ds\Map::count

(PECL ds >= 1.0.0)

Ds\Map::count — Returns the number of values in the map

See Countable::count()


Creates a new map using keys that aren't in another map

  • ? Ds\Map::count
  • Ds\Map::filter ?
  • PHP Manual
  • Map
  • Creates a new map using keys that aren't in another map

Ds\Map::diff

(PECL ds >= 1.0.0)

Ds\Map::diff — Creates a new map using keys that aren't in another map

说明

public Ds\Map::diff ( Ds\Map $map ) : Ds\Map

Returns the result of removing all keys from the current instance that are present in a given map.

A \ B = {x ∈ A | x ? B}

参数

map

The map containing the keys to exclude in the resulting map.

返回值

The result of removing all keys from the current instance that are present in a given map.

See Also

  • » Compliment on Wikipedia

范例

Example #1 Ds\Map::diff() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

var_dump($a->diff($b));
?>

以上例程的输出类似于：

object(Ds\Map)#3 (1) {
  [0]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
}


Creates a new map using a callable to determine which pairs to include

  • ? Ds\Map::diff
  • Ds\Map::first ?
  • PHP Manual
  • Map
  • Creates a new map using a callable to determine which pairs to include

Ds\Map::filter

(PECL ds >= 1.0.0)

Ds\Map::filter — Creates a new map using a callable to determine which pairs to include

说明

public Ds\Map::filter ( callable $callback = ? ) : Ds\Map

Creates a new map using a callable to determine which pairs to include.

参数

callback

callback ( mixed $key , mixed $value ) : bool

Optional callable which returns true if the pair should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

返回值

A new map containing all the pairs for which either the callback returned true, or all values that convert to true if a callback was not provided.

范例

Example #1 Ds\Map::filter() example using callback function

<?php
$map = new \Ds\Map(["a", "b", "c", "d", "e"]);

var_dump($map->filter(function($key, $value) {
    return $key % 2 == 0;
}));
?>

以上例程的输出类似于：

object(Ds\Map)#3 (3) {
  [0]=>
  object(Ds\Pair)#2 (2) {
    ["key"]=>
    int(0)
    ["value"]=>
    string(1) "a"
  }
  [1]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    int(2)
    ["value"]=>
    string(1) "c"
  }
  [2]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    int(4)
    ["value"]=>
    string(1) "e"
  }
}

Example #2 Ds\Map::filter() example without a callback function

<?php
$map = new \Ds\Map(["a" => 0, "b" => 1, "c" => true, "d" => false]);

var_dump($map->filter());
?>

以上例程的输出类似于：

object(Ds\Map)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Returns the first pair in the map

  • ? Ds\Map::filter
  • Ds\Map::get ?
  • PHP Manual
  • Map
  • Returns the first pair in the map

Ds\Map::first

(PECL ds >= 1.0.0)

Ds\Map::first — Returns the first pair in the map

说明

public Ds\Map::first ( ) : Ds\Pair

Returns the first pair in the map.

参数

此函数没有参数。

返回值

The first pair in the map.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Map::first() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->first());
?>

以上例程的输出类似于：

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "a"
  ["value"]=>
  int(1)
}


Returns the value for a given key

  • ? Ds\Map::first
  • Ds\Map::hasKey ?
  • PHP Manual
  • Map
  • Returns the value for a given key

Ds\Map::get

(PECL ds >= 1.0.0)

Ds\Map::get — Returns the value for a given key

说明

public Ds\Map::get ( mixed $key , mixed $default = ? ) : mixed

Returns the value for a given key, or an optional default value if the key could not be found.

Note:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Note:

You can also use array syntax to access values by key, eg. $map["key"].

Caution

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

参数

key

The key to look up.

default

The optional default value, returned if the key could not be found.

返回值

The value mapped to the given key, or the default value if provided and the key could not be found in the map.

错误／异常

OutOfBoundsException if the key could not be found and a default value was not provided.

范例

Example #1 Ds\Map::get() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->get("a"));       // 1
var_dump($map->get("d", 10));   // 10 (default used)
?>

以上例程的输出类似于：

int(1)
int(10)

Example #2 Ds\Map::get() example using array syntax

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map["a"])); // 1
?>

以上例程的输出类似于：

int(1)


Determines whether the map contains a given key

  • ? Ds\Map::get
  • Ds\Map::hasValue ?
  • PHP Manual
  • Map
  • Determines whether the map contains a given key

Ds\Map::hasKey

(PECL ds >= 1.0.0)

Ds\Map::hasKey — Determines whether the map contains a given key

说明

public Ds\Map::hasKey ( mixed $key ) : bool

Determines whether the map contains a given key.

参数

key

The key to look for.

返回值

Returns true if the key could found, false otherwise.

范例

Example #1 Ds\Map::hasKey() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->hasKey("a")); // true
var_dump($map->hasKey("e")); // false
?>

以上例程的输出类似于：

bool(true)
bool(false)


Determines whether the map contains a given value

  • ? Ds\Map::hasKey
  • Ds\Map::intersect ?
  • PHP Manual
  • Map
  • Determines whether the map contains a given value

Ds\Map::hasValue

(PECL ds >= 1.0.0)

Ds\Map::hasValue — Determines whether the map contains a given value

说明

public Ds\Map::hasValue ( mixed $value ) : bool

Determines whether the map contains a given value.

参数

value

The value to look for.

返回值

Returns true if the value could found, false otherwise.

范例

Example #1 Ds\Map::hasValue() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->hasValue(1)); // true
var_dump($map->hasValue(4)); // false
?>

以上例程的输出类似于：

bool(true)
bool(false)


Creates a new map by intersecting keys with another map

  • ? Ds\Map::hasValue
  • Ds\Map::isEmpty ?
  • PHP Manual
  • Map
  • Creates a new map by intersecting keys with another map

Ds\Map::intersect

(PECL ds >= 1.0.0)

Ds\Map::intersect — Creates a new map by intersecting keys with another map

说明

public Ds\Map::intersect ( Ds\Map $map ) : Ds\Map

Creates a new map containing the pairs of the current instance whose keys are also present in the given map. In other words, returns a copy of the current instance with all keys removed that are not also in the other map.

A ∩ B = {x : x ∈ A ∧ x ∈ B}

Note:

Values from the current instance will be kept.

参数

map

The other map, containing the keys to intersect with.

返回值

The key intersection of the current instance and another map.

See Also

  • » Intersection on Wikipedia

范例

Example #1 Ds\Map::intersect() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

var_dump($a->intersect($b));
?>

以上例程的输出类似于：

object(Ds\Map)#3 (2) {
  [0]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [1]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}


Returns whether the map is empty

  • ? Ds\Map::intersect
  • Ds\Map::jsonSerialize ?
  • PHP Manual
  • Map
  • Returns whether the map is empty

Ds\Map::isEmpty

(PECL ds >= 1.0.0)

Ds\Map::isEmpty — Returns whether the map is empty

说明

public Ds\Map::isEmpty ( ) : bool

Returns whether the map is empty.

参数

此函数没有参数。

返回值

Returns true if the map is empty, false otherwise.

范例

Example #1 Ds\Map::isEmpty() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • ? Ds\Map::isEmpty
  • Ds\Map::keys ?
  • PHP Manual
  • Map
  • Returns a representation that can be converted to JSON

Ds\Map::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Note:

You should never need to call this directly.


Returns a set of the map's keys

  • ? Ds\Map::jsonSerialize
  • Ds\Map::ksort ?
  • PHP Manual
  • Map
  • Returns a set of the map's keys

Ds\Map::keys

(PECL ds >= 1.0.0)

Ds\Map::keys — Returns a set of the map's keys

说明

public Ds\Map::keys ( ) : Ds\Set

Returns a set containing all the keys of the map, in the same order.

参数

此函数没有参数。

返回值

A Ds\Set containing all the keys of the map.

范例

Example #1 Ds\Map::keys() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->keys());
?>

以上例程的输出类似于：

object(Ds\Set)#2 (3) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
}


Sorts the map in-place by key

  • ? Ds\Map::keys
  • Ds\Map::ksorted ?
  • PHP Manual
  • Map
  • Sorts the map in-place by key

Ds\Map::ksort

(PECL ds >= 1.0.0)

Ds\Map::ksort — Sorts the map in-place by key

说明

public Ds\Map::ksort ( callable $comparator = ? ) : void

Sorts the map in-place by key, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

没有返回值。

范例

Example #1 Ds\Map::ksort() example

<?php
$map = new \Ds\Map(["b" => 2, "c" => 3, "a" => 1]);
$map->ksort();

print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Example #2 Ds\Map::ksort() example using a comparator

<?php
$map = new \Ds\Map([1 => "x", 2 => "y", 0 => "z"]);

// Reverse
$map->ksort(function($a, $b) {
    return $b <=> $a;
});

print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => 2
            [value] => y
        )

    [1] => Ds\Pair Object
        (
            [key] => 1
            [value] => x
        )

    [2] => Ds\Pair Object
        (
            [key] => 0
            [value] => z
        )

)


Returns a copy, sorted by key

  • ? Ds\Map::ksort
  • Ds\Map::last ?
  • PHP Manual
  • Map
  • Returns a copy, sorted by key

Ds\Map::ksorted

(No version information available, might only be in Git)

Ds\Map::ksorted — Returns a copy, sorted by key

说明

public Ds\Map::ksorted ( callable $comparator = ? ) : Ds\Map

Returns a copy sorted by key, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

Returns a copy of the map, sorted by key.

范例

Example #1 Ds\Map::ksorted() example

<?php
$map = new \Ds\Map(["b" => 2, "c" => 3, "a" => 1]);

print_r($map->ksorted());
?>

以上例程的输出类似于：

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Example #2 Ds\Map::ksorted() example using a comparator

<?php
$map = new \Ds\Map([1 => "x", 2 => "y", 0 => "z"]);

// Reverse
$sorted = $map->ksorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

以上例程的输出类似于：

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => 2
            [value] => y
        )

    [1] => Ds\Pair Object
        (
            [key] => 1
            [value] => x
        )

    [2] => Ds\Pair Object
        (
            [key] => 0
            [value] => z
        )

)


Returns the last pair of the map

  • ? Ds\Map::ksorted
  • Ds\Map::map ?
  • PHP Manual
  • Map
  • Returns the last pair of the map

Ds\Map::last

(PECL ds >= 1.0.0)

Ds\Map::last — Returns the last pair of the map

说明

public Ds\Map::last ( ) : Ds\Pair

Returns the last pair of the map.

参数

此函数没有参数。

返回值

The last pair of the map.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Map::last() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->last());
?>

以上例程的输出类似于：

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "c"
  ["value"]=>
  int(3)
}


Returns the result of applying a callback to each value

  • ? Ds\Map::last
  • Ds\Map::merge ?
  • PHP Manual
  • Map
  • Returns the result of applying a callback to each value

Ds\Map::map

(PECL ds >= 1.0.0)

Ds\Map::map — Returns the result of applying a callback to each value

说明

public Ds\Map::map ( callable $callback ) : Ds\Map

Returns the result of applying a callback function to each value of the map.

参数

callback

callback ( mixed $key , mixed $value ) : mixed

A callable to apply to each value in the map.

The callable should return what the key will be mapped to in the resulting map.

返回值

The result of applying a callback to each value in the map.

Note:

The keys and values of the current instance won't be affected.

范例

Example #1 Ds\Map::map() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->map(function($key, $value) { return $value * 2; }));
print_r($map);
?>

以上例程的输出类似于：

(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 4
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 6
        )

)
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)


Returns the result of adding all given associations

  • ? Ds\Map::map
  • Ds\Map::pairs ?
  • PHP Manual
  • Map
  • Returns the result of adding all given associations

Ds\Map::merge

(PECL ds >= 1.0.0)

Ds\Map::merge — Returns the result of adding all given associations

说明

public Ds\Map::merge ( mixed $values ) : Ds\Map

Returns the result of associating all keys of a given traversable object or array with their corresponding values, combined with the current instance.

Note:

Values of the current instance will be overwritten by those provided where keys are equal.

参数

values

A traversable object or an array.

返回值

The result of associating all keys of a given traversable object or array with their corresponding values, combined with the current instance.

Note:

The current instance won't be affected.

范例

Example #1 Ds\Map::merge() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->merge(["a" => 10, "e" => 50]));
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 10
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [3] => Ds\Pair Object
        (
            [key] => e
            [value] => 50
        )

)


Returns a sequence containing all the pairs of the map

  • ? Ds\Map::merge
  • Ds\Map::put ?
  • PHP Manual
  • Map
  • Returns a sequence containing all the pairs of the map

Ds\Map::pairs

(PECL ds >= 1.0.0)

Ds\Map::pairs — Returns a sequence containing all the pairs of the map

说明

public Ds\Map::pairs ( ) : Ds\Sequence

Returns a Ds\Sequence containing all the pairs of the map.

参数

此函数没有参数。

返回值

Ds\Sequence containing all the pairs of the map.

范例

Example #1 Ds\Map::pairs() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->pairs());
?>

以上例程的输出类似于：

object(Ds\Map)#8 (3) {
  [0]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
  [1]=>
  object(Ds\Pair)#6 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [2]=>
  object(Ds\Pair)#7 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}
p


Associates a key with a value

  • ? Ds\Map::pairs
  • Ds\Map::putAll ?
  • PHP Manual
  • Map
  • Associates a key with a value

Ds\Map::put

(PECL ds >= 1.0.0)

Ds\Map::put — Associates a key with a value

说明

public Ds\Map::put ( mixed $key , mixed $value ) : void

Associates a key with a value, overwriting a previous association if one exists.

Note:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Note:

You can also use array syntax to associate values by key, eg. $map["key"] = $value.

Caution

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

参数

key

The key to associate the value with.

value

The value to be associated with the key.

返回值

没有返回值。

范例

Example #1 Ds\Map::put() example

<?php
$map = new \Ds\Map();

$map->put("a", 1);
$map->put("b", 2);
$map->put("c", 3);

print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Example #2 Ds\Map::put() example using objects as keys

<?php
class HashableObject implements \Ds\Hashable
{
    /**
     * An arbitrary value to use as the hash value. Does not define equality.
     */
    private $value;

    public function __construct($value)
    {
        $this->value = $value;
    }

    public function hash()
    {
        return $this->value;
    }

    public function equals($obj): bool
    {
        return $this->value === $obj->value;
    }
}

$map = new \Ds\Map();

$obj = new \ArrayIterator([]);

// Using the same instance multiple times will overwrite the previous value.
$map->put($obj, 1);
$map->put($obj, 2);

// Using multiple instances of the same object will create new associations.
$map->put(new \stdClass(), 3);
$map->put(new \stdClass(), 4);

// Using multiple instances of equal hashable objects will overwrite previous values.
$map->put(new \HashableObject(1), 5);
$map->put(new \HashableObject(1), 6);
$map->put(new \HashableObject(2), 7);
$map->put(new \HashableObject(2), 8);

var_dump($map);
?>

以上例程的输出类似于：

object(Ds\Map)#1 (5) {
  [0]=>
  object(Ds\Pair)#7 (2) {
    ["key"]=>
    object(ArrayIterator)#2 (1) {
      ["storage":"ArrayIterator":private]=>
      array(0) {
      }
    }
    ["value"]=>
    int(2)
  }
  [1]=>
  object(Ds\Pair)#8 (2) {
    ["key"]=>
    object(stdClass)#3 (0) {
    }
    ["value"]=>
    int(3)
  }
  [2]=>
  object(Ds\Pair)#9 (2) {
    ["key"]=>
    object(stdClass)#4 (0) {
    }
    ["value"]=>
    int(4)
  }
  [3]=>
  object(Ds\Pair)#10 (2) {
    ["key"]=>
    object(HashableObject)#5 (1) {
      ["value":"HashableObject":private]=>
      int(1)
    }
    ["value"]=>
    int(6)
  }
  [4]=>
  object(Ds\Pair)#11 (2) {
    ["key"]=>
    object(HashableObject)#6 (1) {
      ["value":"HashableObject":private]=>
      int(2)
    }
    ["value"]=>
    int(8)
  }
}


Associates all key-value pairs of a traversable object or array

  • ? Ds\Map::put
  • Ds\Map::reduce ?
  • PHP Manual
  • Map
  • Associates all key-value pairs of a traversable object or array

Ds\Map::putAll

(PECL ds >= 1.0.2)

Ds\Map::putAll — Associates all key-value pairs of a traversable object or array

说明

public Ds\Map::putAll ( mixed $pairs ) : void

Associates all key-value pairs of a traversable object or array.

Note:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

参数

pairs

traversable object or array.

返回值

没有返回值。

范例

Example #1 Ds\Map::putAll() example

<?php
$map = new \Ds\Map();

$map->putAll([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)


Reduces the map to a single value using a callback function

  • ? Ds\Map::putAll
  • Ds\Map::remove ?
  • PHP Manual
  • Map
  • Reduces the map to a single value using a callback function

Ds\Map::reduce

(PECL ds >= 1.0.0)

Ds\Map::reduce — Reduces the map to a single value using a callback function

说明

public Ds\Map::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the map to a single value using a callback function.

参数

callback
callback ( mixed $carry , mixed $key , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

key

The key of the current iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

返回值

The return value of the final callback.

范例

Example #1 Ds\Map::reduce() with initial value example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

$callback = function($carry, $key, $value) {
    return $carry * $value;
};

var_dump($map->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

以上例程的输出类似于：

int(30)

Example #2 Ds\Map::reduce() without an initial value example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->reduce(function($carry, $key, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

以上例程的输出类似于：

int(21)


Removes and returns a value by key

  • ? Ds\Map::reduce
  • Ds\Map::reverse ?
  • PHP Manual
  • Map
  • Removes and returns a value by key

Ds\Map::remove

(PECL ds >= 1.0.0)

Ds\Map::remove — Removes and returns a value by key

说明

public Ds\Map::remove ( mixed $key , mixed $default = ? ) : mixed

Removes and returns a value by key, or return an optional default value if the key could not be found.

Note:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Note:

You can also use array syntax to access values by key, eg. $map["key"].

Caution

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

参数

key

The key to remove.

default

The optional default value, returned if the key could not be found.

返回值

The value that was removed, or the default value if provided and the key could not be found in the map.

错误／异常

OutOfBoundsException if the key could not be found and a default value was not provided.

范例

Example #1 Ds\Map::remove() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->remove("a"));      //  1
var_dump($map->remove("e", 10));  // 10 (default used)
?>

以上例程的输出类似于：

int(1)
int(10)


Reverses the map in-place

  • ? Ds\Map::remove
  • Ds\Map::reversed ?
  • PHP Manual
  • Map
  • Reverses the map in-place

Ds\Map::reverse

(PECL ds >= 1.0.0)

Ds\Map::reverse — Reverses the map in-place

说明

public Ds\Map::reverse ( ) : void

Reverses the map in-place.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Map::reverse() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$map->reverse();

print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

)


Returns a reversed copy

  • ? Ds\Map::reverse
  • Ds\Map::skip ?
  • PHP Manual
  • Map
  • Returns a reversed copy

Ds\Map::reversed

(PECL ds >= 1.0.0)

Ds\Map::reversed — Returns a reversed copy

说明

public Ds\Map::reversed ( ) : Ds\Map

Returns a reversed copy of the map.

参数

此函数没有参数。

返回值

A reversed copy of the map.

Note:

The current instance is not affected.

范例

Example #1 Ds\Map::reversed() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->reversed());
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

)


Returns the pair at a given positional index

  • ? Ds\Map::reversed
  • Ds\Map::slice ?
  • PHP Manual
  • Map
  • Returns the pair at a given positional index

Ds\Map::skip

(PECL ds >= 1.0.0)

Ds\Map::skip — Returns the pair at a given positional index

说明

public Ds\Map::skip ( int $position ) : Ds\Pair

Returns the pair at a given zero-based position.

参数

position

The zero-based positional index to return.

返回值

Returns the Ds\Pair at the given position.

错误／异常

OutOfRangeException if the position is not valid.

范例

Example #1 Ds\Map::skip() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->skip(1));
?>

以上例程的输出类似于：

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "b"
  ["value"]=>
  int(2)
}


Returns a subset of the map defined by a starting index and length

  • ? Ds\Map::skip
  • Ds\Map::sort ?
  • PHP Manual
  • Map
  • Returns a subset of the map defined by a starting index and length

Ds\Map::slice

(PECL ds >= 1.0.0)

Ds\Map::slice — Returns a subset of the map defined by a starting index and length

说明

public Ds\Map::slice ( int $index , int $length = ? ) : Ds\Map

Returns a subset of the map defined by a starting index and length.

参数

index

The index at which the range starts.

If positive, the range will start at that index in the map. If negative, the range will start that far from the end.

length

If a length is given and is positive, the resulting map will have up to that many pairs in it. If a length is given and is negative, the range will stop that many pairs from the end. If the length results in an overflow, only pairs up to the end of the map will be included. If a length is not provided, the resulting map will contain all pairs between the index and the end of the map.

返回值

A subset of the map defined by a starting index and length.

范例

Example #1 Ds\Map::slice() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3, "d" => 4, "e" => 5]);

// Slice from 2 onwards
print_r($map->slice(2)->toArray());

// Slice from 1, for a length of 3
print_r($map->slice(1, 3)->toArray());

// Slice from 1 onwards
print_r($map->slice(1)->toArray());

// Slice from 2 from the end onwards
print_r($map->slice(-2)->toArray());

// Slice from 1 to 1 from the end
print_r($map->slice(1, -1)->toArray());
?>

以上例程的输出类似于：

Array
(
    [c] => 3
    [d] => 4
    [e] => 5
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
    [e] => 5
)
Array
(
    [d] => 4
    [e] => 5
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
)


Sorts the map in-place by value

  • ? Ds\Map::slice
  • Ds\Map::sorted ?
  • PHP Manual
  • Map
  • Sorts the map in-place by value

Ds\Map::sort

(PECL ds >= 1.0.0)

Ds\Map::sort — Sorts the map in-place by value

说明

public Ds\Map::sort ( callable $comparator = ? ) : void

Sorts the map in-place by value, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

没有返回值。

范例

Example #1 Ds\Map::sort() example

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);
$map->sort();

print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

)

Example #2 Ds\Map::sort() example using a comparator

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

$map->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($map);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

)


Returns a copy, sorted by value

  • ? Ds\Map::sort
  • Ds\Map::sum ?
  • PHP Manual
  • Map
  • Returns a copy, sorted by value

Ds\Map::sorted

(PECL ds >= 1.0.0)

Ds\Map::sorted — Returns a copy, sorted by value

说明

public Ds\Map::sorted ( callable $comparator = ? ) : Ds\Map

Returns a copy, sorted by value using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

Returns a copy of the map, sorted by value.

范例

Example #1 Ds\Map::sort() example

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

print_r($map->sorted());
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

)

Example #2 Ds\Map::sort() example using a comparator

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

// Reverse
$sorted = $map->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

)


Returns the sum of all values in the map

  • ? Ds\Map::sorted
  • Ds\Map::toArray ?
  • PHP Manual
  • Map
  • Returns the sum of all values in the map

Ds\Map::sum

(No version information available, might only be in Git)

Ds\Map::sum — Returns the sum of all values in the map

说明

public Ds\Map::sum ( ) : int|float

Returns the sum of all values in the map.

Note:

Arrays and objects are considered equal to zero when calculating the sum.

参数

此函数没有参数。

返回值

The sum of all the values in the map as either a float or int depending on the values in the map.

范例

Example #1 Ds\Map::sum() integer example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->sum());
?>

以上例程的输出类似于：

int(6)

Example #2 Ds\Map::sum() float example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2.5, "c" => 3]);
var_dump($map->sum());
?>

以上例程的输出类似于：

float(6.5)


Converts the map to an array

  • ? Ds\Map::sum
  • Ds\Map::union ?
  • PHP Manual
  • Map
  • Converts the map to an array

Ds\Map::toArray

(PECL ds >= 1.0.0)

Ds\Map::toArray — Converts the map to an array

说明

public Ds\Map::toArray ( ) : array

Converts the map to an array.

Caution

Maps where non-scalar keys are can't be converted to an array.

Caution

An array will treat all numeric keys as integers, eg. "1" and 1 as keys in the map will only result in 1 being included in the array.

Note:

Casting to an array is not supported yet.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the map.

范例

Example #1 Ds\Map::toArray() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

var_dump($map->toArray());
?>

以上例程的输出类似于：

array(3) {
  ["a"]=>
  int(1)
  ["b"]=>
  int(2)
  ["c"]=>
  int(3)
}


Creates a new map using values from the current instance and another map

  • ? Ds\Map::toArray
  • Ds\Map::values ?
  • PHP Manual
  • Map
  • Creates a new map using values from the current instance and another map

Ds\Map::union

(PECL ds >= 1.0.0)

Ds\Map::union — Creates a new map using values from the current instance and another map

说明

public Ds\Map::union ( Ds\Map $map ) : Ds\Map

Creates a new map that contains the pairs of the current instance as well as the pairs of another map.

A ∪ B = {x: x ∈ A ∨ x ∈ B}

Note:

Values of the current instance will be overwritten by those provided where keys are equal.

参数

map

The other map, to combine with the current instance.

返回值

A new map containing all the pairs of the current instance as well as another map.

See Also

  • » Union on Wikipedia

范例

Example #1 Ds\Map::union() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 3, "c" => 4, "d" => 5]);

print_r($a->union($b));
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 4
        )

    [3] => Ds\Pair Object
        (
            [key] => d
            [value] => 5
        )

)


Returns a sequence of the map's values

  • ? Ds\Map::union
  • Ds\Map::xor ?
  • PHP Manual
  • Map
  • Returns a sequence of the map's values

Ds\Map::values

(PECL ds >= 1.0.0)

Ds\Map::values — Returns a sequence of the map's values

说明

public Ds\Map::values ( ) : Ds\Sequence

Returns a sequence containing all the values of the map, in the same order.

参数

此函数没有参数。

返回值

A Ds\Sequence containing all the values of the map.

范例

Example #1 Ds\Map::values() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->values());
?>

以上例程的输出类似于：

object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Creates a new map using keys of either the current instance or of another map, but not of both

  • ? Ds\Map::values
  • Pair ?
  • PHP Manual
  • Map
  • Creates a new map using keys of either the current instance or of another map, but not of both

Ds\Map::xor

(PECL ds >= 1.0.0)

Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both

说明

public Ds\Map::xor ( Ds\Map $map ) : Ds\Map

Creates a new map containing keys of the current instance as well as another map, but not of both.

A ? B = {x : x ∈ (A \ B) ∪ (B \ A)}

参数

map

The other map.

返回值

A new map containing keys in the current instance as well as another map, but not in both.

See Also

  • » Symmetric Difference on Wikipedia

范例

Example #1 Ds\Map::xor() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

print_r($a->xor($b));
?>

以上例程的输出类似于：

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => d
            [value] => 6
        )

)


The Pair class

(No version information available, might only be in Git)

简介

A pair is used by Ds\Map to pair keys with values.

类摘要

Ds\Pair implements JsonSerializable {
/* 方法 */
public __construct ( mixed $key = ? , mixed $value = ? )
public clear ( ) : void
public copy ( ) : Ds\Pair
public isEmpty ( ) : bool
public toArray ( ) : array
}

Table of Contents

  • Ds\Pair::clear — Removes all values
  • Ds\Pair::__construct — Creates a new instance
  • Ds\Pair::copy — Returns a shallow copy of the pair
  • Ds\Pair::isEmpty — Returns whether the pair is empty
  • Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Pair::toArray — Converts the pair to an array


Removes all values

  • ? Pair
  • Ds\Pair::__construct ?
  • PHP Manual
  • Pair
  • Removes all values

Ds\Pair::clear

(No version information available, might only be in Git)

Ds\Pair::clear — Removes all values

说明

public Ds\Pair::clear ( ) : void

Removes all values from the pair.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Pair::clear() example

<?php
$pair = new \Ds\Pair("a", 1);
print_r($pair);

$pair->clear();
print_r($pair);
?>

以上例程的输出类似于：

Ds\Pair Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Pair Object
(
)


Creates a new instance

  • ? Ds\Pair::clear
  • Ds\Pair::copy ?
  • PHP Manual
  • Pair
  • Creates a new instance

Ds\Pair::__construct

(PECL ds >= 1.0.0)

Ds\Pair::__construct — Creates a new instance

说明

public Ds\Pair::__construct ( mixed $key = ? , mixed $value = ? )

Creates a new instance using a given key and value.

参数

key

The key.

value

The value.


Returns a shallow copy of the pair

  • ? Ds\Pair::__construct
  • Ds\Pair::isEmpty ?
  • PHP Manual
  • Pair
  • Returns a shallow copy of the pair

Ds\Pair::copy

(No version information available, might only be in Git)

Ds\Pair::copy — Returns a shallow copy of the pair

说明

public Ds\Pair::copy ( ) : Ds\Pair

Returns a shallow copy of the pair.

参数

此函数没有参数。

返回值

Returns a shallow copy of the pair.

范例

Example #1 Ds\Pair::copy() example

<?php
$a = new \Ds\Pair("a", 1);
$b = $a->copy();

$a->key = "x";

print_r($a);
print_r($b);
?>

以上例程的输出类似于：

Ds\Pair Object
(
    [key] => x
    [value] => 1
)
Ds\Pair Object
(
    [key] => a
    [value] => 1
)


Returns whether the pair is empty

  • ? Ds\Pair::copy
  • Ds\Pair::jsonSerialize ?
  • PHP Manual
  • Pair
  • Returns whether the pair is empty

Ds\Pair::isEmpty

(No version information available, might only be in Git)

Ds\Pair::isEmpty — Returns whether the pair is empty

说明

public Ds\Pair::isEmpty ( ) : bool

Returns whether the pair is empty.

参数

此函数没有参数。

返回值

Returns true if the pair is empty, false otherwise.

范例

Example #1 Ds\Pair::isEmpty() example

<?php
$a = new \Ds\Pair("a", 1);
$b = new \Ds\Pair();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • ? Ds\Pair::isEmpty
  • Ds\Pair::toArray ?
  • PHP Manual
  • Pair
  • Returns a representation that can be converted to JSON

Ds\Pair::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Note:

You should never need to call this directly.


Converts the pair to an array

  • ? Ds\Pair::jsonSerialize
  • Set ?
  • PHP Manual
  • Pair
  • Converts the pair to an array

Ds\Pair::toArray

(PECL ds >= 1.0.0)

Ds\Pair::toArray — Converts the pair to an array

说明

public Ds\Pair::toArray ( ) : array

Converts the pair to an array.

Note:

Casting to an array is not supported yet.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the pair.

范例

Example #1 Ds\Pair::toArray() example

<?php
$pair = new \Ds\Pair("a", 1);

var_dump($pair->toArray());
?>

以上例程的输出类似于：

array(2) {
  ["key"]=>
  string(1) "a"
  ["value"]=>
  int(1)
}


The Set class

(No version information available, might only be in Git)

简介

A Set is a sequence of unique values. This implementation uses the same hash table as Ds\Map, where values are used as keys and the mapped value is ignored.

Strengths

  • Values can be any type, including objects.
  • Supports array syntax (square brackets).
  • Insertion order is preserved.
  • Automatically frees allocated memory when its size drops low enough.
  • add(),
remove() and
contains() are all O(1).

Weaknesses

  • Doesn't support
                push(),
                pop(),
                insert(),
                shift(), or
                unshift().
  • get() is O(n) if there are deleted values in the buffer before the accessed index, O(1) otherwise.

类摘要

Ds\Set implements Ds\Collection , ArrayAccess {
/* Constants */
const int MIN_CAPACITY = 16 ;
/* 方法 */
public add ( mixed ...$values ) : void
public allocate ( int $capacity ) : void
public capacity ( ) : int
public clear ( ) : void
public contains ( mixed ...$values ) : bool
public copy ( ) : Ds\Set
public diff ( Ds\Set $set ) : Ds\Set
public filter ( callable $callback = ? ) : Ds\Set
public first ( ) : mixed
public get ( int $index ) : mixed
public intersect ( Ds\Set $set ) : Ds\Set
public isEmpty ( ) : bool
public join ( string $glue = ? ) : string
public last ( ) : mixed
public merge ( mixed $values ) : Ds\Set
public reduce ( callable $callback , mixed $initial = ? ) : mixed
public remove ( mixed ...$values ) : void
public reverse ( ) : void
public reversed ( ) : Ds\Set
public slice ( int $index , int $length = ? ) : Ds\Set
public sort ( callable $comparator = ? ) : void
public sorted ( callable $comparator = ? ) : Ds\Set
public sum ( ) : int|float
public toArray ( ) : array
public union ( Ds\Set $set ) : Ds\Set
public xor ( Ds\Set $set ) : Ds\Set
}

预定义常量

Ds\Set::MIN_CAPACITY

更新日志

版本 | 说明
PECL ds 1.3.0 | The class now implements ArrayAccess.

Table of Contents

  • Ds\Set::add — Adds values to the set
  • Ds\Set::allocate — Allocates enough memory for a required capacity
  • Ds\Set::capacity — Returns the current capacity
  • Ds\Set::clear — Removes all values
  • Ds\Set::__construct — Creates a new instance
  • Ds\Set::contains — Determines if the set contains all values
  • Ds\Set::copy — Returns a shallow copy of the set
  • Ds\Set::count — Returns the number of values in the set
  • Ds\Set::diff — Creates a new set using values that aren't in another set
  • Ds\Set::filter — Creates a new set using a callable to determine which values to include
  • Ds\Set::first — Returns the first value in the set
  • Ds\Set::get — Returns the value at a given index
  • Ds\Set::intersect — Creates a new set by intersecting values with another set
  • Ds\Set::isEmpty — Returns whether the set is empty
  • Ds\Set::join — Joins all values together as a string
  • Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Set::last — Returns the last value in the set
  • Ds\Set::merge — Returns the result of adding all given values to the set
  • Ds\Set::reduce — Reduces the set to a single value using a callback function
  • Ds\Set::remove — Removes all given values from the set
  • Ds\Set::reverse — Reverses the set in-place
  • Ds\Set::reversed — Returns a reversed copy
  • Ds\Set::slice — Returns a sub-set of a given range
  • Ds\Set::sort — Sorts the set in-place
  • Ds\Set::sorted — Returns a sorted copy
  • Ds\Set::sum — Returns the sum of all values in the set
  • Ds\Set::toArray — Converts the set to an array
  • Ds\Set::union — Creates a new set using values from the current instance and another set
  • Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both


Adds values to the set

  • ? Set
  • Ds\Set::allocate ?
  • PHP Manual
  • Set
  • Adds values to the set

Ds\Set::add

(PECL ds >= 1.0.0)

Ds\Set::add — Adds values to the set

说明

public Ds\Set::add ( mixed ...$values ) : void

Adds all given values to the set that haven't already been added.

Note:

Values of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Caution

All comparisons are strict (type and value).

参数

values

Values to add to the set.

返回值

没有返回值。

范例

Example #1 Ds\Set::add() example using integers

<?php
$set = new \Ds\Set();

$set->add(1);
$set->add(1);
$set->add(2);
$set->add(3);

// Strict comparison would not treat these the same as int(1)
$set->add("1");
$set->add(true);

var_dump($set);
?>

以上例程的输出类似于：

object(Ds\Set)#1 (5) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  string(1) "1"
  [4]=>
  bool(true)
}

Example #2 Ds\Set::add() example using objects

<?php
class HashableObject implements \Ds\Hashable
{
    /**
     * An arbitrary value to use as the hash value. Does not define equality.
     */
    private $value;

    public function __construct($value)
    {
        $this->value = $value;
    }

    public function hash()
    {
        return $this->value;
    }

    public function equals($obj): bool
    {
        return $this->value === $obj->value;
    }
}

$set = new \Ds\Set();

$obj = new \ArrayIterator([]);

// Adding the same instance multiple times will only add the first.
$set->add($obj);
$set->add($obj);

// Adding multiple instances of the same object will add them all.
$set->add(new \stdClass());
$set->add(new \stdClass());

// Adding multiple instances of equal hashable objects will only add the first.
$set->add(new \HashableObject(1));
$set->add(new \HashableObject(1));
$set->add(new \HashableObject(2));
$set->add(new \HashableObject(2));

var_dump($set);
?>

以上例程的输出类似于：

object(Ds\Set)#1 (5) {
  [0]=>
  object(ArrayIterator)#2 (1) {
    ["storage":"ArrayIterator":private]=>
    array(0) {
    }
  }
  [1]=>
  object(stdClass)#3 (0) {
  }
  [2]=>
  object(stdClass)#4 (0) {
  }
  [3]=>
  object(HashableObject)#5 (1) {
    ["value":"HashableObject":private]=>
    int(1)
  }
  [4]=>
  object(HashableObject)#6 (1) {
    ["value":"HashableObject":private]=>
    int(2)
  }
}


Allocates enough memory for a required capacity

  • ? Ds\Set::add
  • Ds\Set::capacity ?
  • PHP Manual
  • Set
  • Allocates enough memory for a required capacity

Ds\Set::allocate

(PECL ds >= 1.0.0)

Ds\Set::allocate — Allocates enough memory for a required capacity

说明

public Ds\Set::allocate ( int $capacity ) : void

Allocates enough memory for a required capacity.

参数

capacity

The number of values for which capacity should be allocated.

Note:

Capacity will stay the same if this value is less than or equal to the current capacity.

Note:

Capacity will always be rounded up to the nearest power of 2.

返回值

没有返回值。

范例

Example #1 Ds\Set::allocate() example

<?php
$set = new \Ds\Set();
var_dump($set->capacity());

$set->allocate(100);
var_dump($set->capacity());
?>

以上例程的输出类似于：

int(16)
int(128)


Returns the current capacity

  • ? Ds\Set::allocate
  • Ds\Set::clear ?
  • PHP Manual
  • Set
  • Returns the current capacity

Ds\Set::capacity

(PECL ds >= 1.0.0)

Ds\Set::capacity — Returns the current capacity

说明

public Ds\Set::capacity ( ) : int

Returns the current capacity.

参数

此函数没有参数。

返回值

The current capacity.

范例

Example #1 Ds\Set::capacity() example

<?php
$set = new \Ds\Set();
var_dump($set->capacity());

$set->push(...range(1, 50));
var_dump($set->capacity());
?>

以上例程的输出类似于：

int(16)
int(64)


Removes all values

  • ? Ds\Set::capacity
  • Ds\Set::__construct ?
  • PHP Manual
  • Set
  • Removes all values

Ds\Set::clear

(PECL ds >= 1.0.0)

Ds\Set::clear — Removes all values

说明

public Ds\Set::clear ( ) : void

Removes all values from the set.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Set::clear() example

<?php
$set = new \Ds\Set([1, 2, 3]);
print_r($set);

$set->clear();
print_r($set);
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Set Object
(
)


Creates a new instance

  • ? Ds\Set::clear
  • Ds\Set::contains ?
  • PHP Manual
  • Set
  • Creates a new instance

Ds\Set::__construct

(PECL ds >= 1.0.0)

Ds\Set::__construct — Creates a new instance

说明

public Ds\Set::__construct ( mixed ...$values )

Creates a new instance, using either a traversable object or an array for the initial values.

参数

values

A traversable object or an array to use for the initial values.

范例

Example #1 Ds\Set::__construct() example

<?php
$set = new \Ds\Set();
var_dump($set);

$set = new \Ds\Set([1, 2, 3]);
var_dump($set);
?>

以上例程的输出类似于：

object(Ds\Set)#1 (0) {
}
object(Ds\Set)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Determines if the set contains all values

  • ? Ds\Set::__construct
  • Ds\Set::copy ?
  • PHP Manual
  • Set
  • Determines if the set contains all values

Ds\Set::contains

(PECL ds >= 1.0.0)

Ds\Set::contains — Determines if the set contains all values

说明

public Ds\Set::contains ( mixed ...$values ) : bool

Determines if the set contains all values.

Note:

Values of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Caution

All comparisons are strict (type and value).

参数

values

Values to check.

返回值

false if any of the provided values are not in the set, true otherwise.

范例

Example #1 Ds\Set::contains() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->contains(1));                // true
var_dump($set->contains(1, 2));             // true
var_dump($set->contains(...[1, 2]));        // true

var_dump($set->contains("1"));              // false
var_dump($set->contains(...[1, 2, 3, 4]));  // false

var_dump($set->contains(...[]));            // true
?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
bool(false)
bool(false)
bool(true)


Returns a shallow copy of the set

  • ? Ds\Set::contains
  • Ds\Set::count ?
  • PHP Manual
  • Set
  • Returns a shallow copy of the set

Ds\Set::copy

(PECL ds >= 1.0.0)

Ds\Set::copy — Returns a shallow copy of the set

说明

public Ds\Set::copy ( ) : Ds\Set

Returns a shallow copy of the set.

参数

此函数没有参数。

返回值

Returns a shallow copy of the set.

范例

Example #1 Ds\Set::copy() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->add(4);

print_r($a);
print_r($b);
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns the number of values in the set

  • ? Ds\Set::copy
  • Ds\Set::diff ?
  • PHP Manual
  • Set
  • Returns the number of values in the set

Ds\Set::count

(PECL ds >= 1.0.0)

Ds\Set::count — Returns the number of values in the set

See Countable::count()


Creates a new set using values that aren't in another set

  • ? Ds\Set::count
  • Ds\Set::filter ?
  • PHP Manual
  • Set
  • Creates a new set using values that aren't in another set

Ds\Set::diff

(PECL ds >= 1.0.0)

Ds\Set::diff — Creates a new set using values that aren't in another set

说明

public Ds\Set::diff ( Ds\Set $set ) : Ds\Set

Creates a new set using values that aren't in another set.

A \ B = {x ∈ A | x ? B}

参数

set

Set containing the values to exclude.

返回值

A new set containing all values that were not in the other set.

See Also

  • » Compliment on Wikipedia

范例

Example #1 Ds\Set::diff() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->diff($b));
?>

以上例程的输出类似于：

object(Ds\Set)#3 (2) {
  [0]=>
  int(1)
  [1]=>
  int(2)
}


Creates a new set using a callable to determine which values to include

  • ? Ds\Set::diff
  • Ds\Set::first ?
  • PHP Manual
  • Set
  • Creates a new set using a callable to determine which values to include

Ds\Set::filter

(PECL ds >= 1.0.0)

Ds\Set::filter — Creates a new set using a callable to determine which values to include

说明

public Ds\Set::filter ( callable $callback = ? ) : Ds\Set

Creates a new set using a callable to determine which values to include.

参数

callback

callback ( mixed $value ) : bool

Optional callable which returns true if the value should be included, false otherwise.

If a callback is not provided, only values which are true (see converting to boolean) will be included.

返回值

A new set containing all the values for which either the callback returned true, or all values that convert to true if a callback was not provided.

范例

Example #1 Ds\Set::filter() example using callback function

<?php
$set = new \Ds\Set([1, 2, 3, 4, 5]);

var_dump($set->filter(function($value) {
    return $value % 2 == 0;
}));
?>

以上例程的输出类似于：

object(Ds\Set)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Example #2 Ds\Set::filter() example without a callback function

<?php
$set = new \Ds\Set([0, 1, 'a', true, false]);

var_dump($set->filter());
?>

以上例程的输出类似于：

object(Ds\Set)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}


Returns the first value in the set

  • ? Ds\Set::filter
  • Ds\Set::get ?
  • PHP Manual
  • Set
  • Returns the first value in the set

Ds\Set::first

(PECL ds >= 1.0.0)

Ds\Set::first — Returns the first value in the set

说明

public Ds\Set::first ( ) : mixed

Returns the first value in the set.

参数

此函数没有参数。

返回值

The first value in the set.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Set::first() example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->first());
?>

以上例程的输出类似于：

int(1)


Returns the value at a given index

  • ? Ds\Set::first
  • Ds\Set::intersect ?
  • PHP Manual
  • Set
  • Returns the value at a given index

Ds\Set::get

(PECL ds >= 1.0.0)

Ds\Set::get — Returns the value at a given index

说明

public Ds\Set::get ( int $index ) : mixed

Returns the value at a given index.

参数

index

The index to access, starting at 0.

返回值

The value at the requested index.

错误／异常

OutOfRangeException if the index is not valid.

范例

Example #1 Ds\Set::get() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);

var_dump($set->get(0));
var_dump($set->get(1));
var_dump($set->get(2));
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"

Example #2 Ds\Set::get() example using array syntax

<?php
$set = new \Ds\Set(["a", "b", "c"]);

var_dump($set[0]);
var_dump($set[1]);
var_dump($set[2]);
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Creates a new set by intersecting values with another set

  • ? Ds\Set::get
  • Ds\Set::isEmpty ?
  • PHP Manual
  • Set
  • Creates a new set by intersecting values with another set

Ds\Set::intersect

(PECL ds >= 1.0.0)

Ds\Set::intersect — Creates a new set by intersecting values with another set

说明

public Ds\Set::intersect ( Ds\Set $set ) : Ds\Set

Creates a new set using values common to both the current instance and another set. In other words, returns a copy of the current instance with all values removed that are not in the other set.

A ∩ B = {x : x ∈ A ∧ x ∈ B}

参数

set

The other set.

返回值

The intersection of the current instance and another set.

See Also

  • » Intersection on Wikipedia

范例

Example #1 Ds\Set::intersect() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->intersect($b));
?>

以上例程的输出类似于：

object(Ds\Set)#3 (1) {
  [0]=>
  int(3)
}


Returns whether the set is empty

  • ? Ds\Set::intersect
  • Ds\Set::join ?
  • PHP Manual
  • Set
  • Returns whether the set is empty

Ds\Set::isEmpty

(PECL ds >= 1.0.0)

Ds\Set::isEmpty — Returns whether the set is empty

说明

public Ds\Set::isEmpty ( ) : bool

Returns whether the set is empty.

参数

此函数没有参数。

返回值

Returns true if the set is empty, false otherwise.

范例

Example #1 Ds\Set::isEmpty() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Joins all values together as a string

  • ? Ds\Set::isEmpty
  • Ds\Set::jsonSerialize ?
  • PHP Manual
  • Set
  • Joins all values together as a string

Ds\Set::join

(PECL ds >= 1.0.0)

Ds\Set::join — Joins all values together as a string

说明

public Ds\Set::join ( string $glue = ? ) : string

Joins all values together as a string using an optional separator between each value.

参数

glue

An optional string to separate each value.

返回值

All values of the set joined together as a string.

范例

Example #1 Ds\Set::join() example using a separator string

<?php
$set = new \Ds\Set(["a", "b", "c", 1, 2, 3]);

var_dump($set->join("|"));
?>

以上例程的输出类似于：

string(11) "a|b|c|1|2|3"

Example #2 Ds\Set::join() example without a separator string

<?php
$set = new \Ds\Set(["a", "b", "c", 1, 2, 3]);

var_dump($set->join());
?>

以上例程的输出类似于：

string(11) "abc123"


Returns a representation that can be converted to JSON

  • ? Ds\Set::join
  • Ds\Set::last ?
  • PHP Manual
  • Set
  • Returns a representation that can be converted to JSON

Ds\Set::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Note:

You should never need to call this directly.


Returns the last value in the set

  • ? Ds\Set::jsonSerialize
  • Ds\Set::merge ?
  • PHP Manual
  • Set
  • Returns the last value in the set

Ds\Set::last

(PECL ds >= 1.0.0)

Ds\Set::last — Returns the last value in the set

说明

public Ds\Set::last ( ) : mixed

Returns the last value in the set.

参数

此函数没有参数。

返回值

The last value in the set.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Set::last() example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->last());
?>

以上例程的输出类似于：

int(3)


Returns the result of adding all given values to the set

  • ? Ds\Set::last
  • Ds\Set::reduce ?
  • PHP Manual
  • Set
  • Returns the result of adding all given values to the set

Ds\Set::merge

(PECL ds >= 1.0.3)

Ds\Set::merge — Returns the result of adding all given values to the set

说明

public Ds\Set::merge ( mixed $values ) : Ds\Set

Returns the result of adding all given values to the set.

参数

values

A traversable object or an array.

返回值

The result of adding all given values to the set, effectively the same as adding the values to a copy, then returning that copy.

Note:

The current instance won't be affected.

范例

Example #1 Ds\Set::merge() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->merge([3, 4, 5]));
var_dump($set);
?>

以上例程的输出类似于：

object(Ds\Set)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
}
object(Ds\Set)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Reduces the set to a single value using a callback function

  • ? Ds\Set::merge
  • Ds\Set::remove ?
  • PHP Manual
  • Set
  • Reduces the set to a single value using a callback function

Ds\Set::reduce

(PECL ds >= 1.0.0)

Ds\Set::reduce — Reduces the set to a single value using a callback function

说明

public Ds\Set::reduce ( callable $callback , mixed $initial = ? ) : mixed

Reduces the set to a single value using a callback function.

参数

callback
callback ( mixed $carry , mixed $value ) : mixed
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be null.

返回值

The return value of the final callback.

范例

Example #1 Ds\Set::reduce() with initial value example

<?php
$set = new \Ds\Set([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($set->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

以上例程的输出类似于：

int(30)

Example #2 Ds\Set::reduce() without an initial value example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

以上例程的输出类似于：

int(21)


Removes all given values from the set

  • ? Ds\Set::reduce
  • Ds\Set::reverse ?
  • PHP Manual
  • Set
  • Removes all given values from the set

Ds\Set::remove

(PECL ds >= 1.0.0)

Ds\Set::remove — Removes all given values from the set

说明

public Ds\Set::remove ( mixed ...$values ) : void

Removes all given values from the set, ignoring any that are not in the set.

参数

values

The values to remove.

返回值

没有返回值。

范例

Example #1 Ds\Set::remove() example

<?php
$set = new \Ds\Set([1, 2, 3, 4, 5]);

$set->remove(1);            // Remove 1
$set->remove(1, 2);         // Can't find 1, but remove 2
$set->remove(...[3, 4]);    // Remove 3 and 4

var_dump($set);
?>

以上例程的输出类似于：

object(Ds\Set)#1 (1) {
  [0]=>
  int(5)
}


Reverses the set in-place

  • ? Ds\Set::remove
  • Ds\Set::reversed ?
  • PHP Manual
  • Set
  • Reverses the set in-place

Ds\Set::reverse

(PECL ds >= 1.0.0)

Ds\Set::reverse — Reverses the set in-place

说明

public Ds\Set::reverse ( ) : void

Reverses the set in-place.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Set::reverse() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);
$set->reverse();

print_r($set);
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => c
    [1] => b
    [2] => a
)


Returns a reversed copy

  • ? Ds\Set::reverse
  • Ds\Set::slice ?
  • PHP Manual
  • Set
  • Returns a reversed copy

Ds\Set::reversed

(PECL ds >= 1.0.0)

Ds\Set::reversed — Returns a reversed copy

说明

public Ds\Set::reversed ( ) : Ds\Set

Returns a reversed copy of the set.

参数

此函数没有参数。

返回值

A reversed copy of the set.

Note:

The current instance is not affected.

范例

Example #1 Ds\Set::reversed() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);

print_r($set->reversed());
print_r($set);
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Set Object
(
    [0] => a
    [1] => b
    [2] => c
)


Returns a sub-set of a given range

  • ? Ds\Set::reversed
  • Ds\Set::sort ?
  • PHP Manual
  • Set
  • Returns a sub-set of a given range

Ds\Set::slice

(PECL ds >= 1.0.0)

Ds\Set::slice — Returns a sub-set of a given range

说明

public Ds\Set::slice ( int $index , int $length = ? ) : Ds\Set

Creates a sub-set of a given range.

参数

index

The index at which the sub-set starts.

If positive, the set will start at that index in the set. If negative, the set will start that far from the end.

length

If a length is given and is positive, the resulting set will have up to that many values in it. If the length results in an overflow, only values up to the end of the set will be included. If a length is given and is negative, the set will stop that many values from the end. If a length is not provided, the resulting set will contain all values between the index and the end of the set.

返回值

A sub-set of the given range.

范例

Example #1 Ds\Set::slice() example

<?php
$set = new \Ds\Set(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($set->slice(2));

// Slice from 1, for a length of 3
print_r($set->slice(1, 3));

// Slice from 1 onwards
print_r($set->slice(1));

// Slice from 2 from the end onwards
print_r($set->slice(-2));

// Slice from 1 to 1 from the end
print_r($set->slice(1, -1));
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Set Object
(
    [0] => d
    [1] => e
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
)


Sorts the set in-place

  • ? Ds\Set::slice
  • Ds\Set::sorted ?
  • PHP Manual
  • Set
  • Sorts the set in-place

Ds\Set::sort

(PECL ds >= 1.0.0)

Ds\Set::sort — Sorts the set in-place

说明

public Ds\Set::sort ( callable $comparator = ? ) : void

Sorts the set in-place, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

没有返回值。

范例

Example #1 Ds\Set::sort() example

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);
$set->sort();

print_r($set);
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Example #2 Ds\Set::sort() example using a comparator

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

$set->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($set);
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns a sorted copy

  • ? Ds\Set::sort
  • Ds\Set::sum ?
  • PHP Manual
  • Set
  • Returns a sorted copy

Ds\Set::sorted

(PECL ds >= 1.0.0)

Ds\Set::sorted — Returns a sorted copy

说明

public Ds\Set::sorted ( callable $comparator = ? ) : Ds\Set

Returns a sorted copy, using an optional comparator function.

参数

comparator

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to int of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

Returns a sorted copy of the set.

范例

Example #1 Ds\Set::sorted() example

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

print_r($set->sorted());
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Example #2 Ds\Set::sorted() example using a comparator

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

$sorted = $set->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

以上例程的输出类似于：

Ds\Set Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)


Returns the sum of all values in the set

  • ? Ds\Set::sorted
  • Ds\Set::toArray ?
  • PHP Manual
  • Set
  • Returns the sum of all values in the set

Ds\Set::sum

(PECL ds >= 1.0.0)

Ds\Set::sum — Returns the sum of all values in the set

说明

public Ds\Set::sum ( ) : int|float

Returns the sum of all values in the set.

Note:

Arrays and objects are considered equal to zero when calculating the sum.

参数

此函数没有参数。

返回值

The sum of all the values in the set as either a float or int depending on the values in the set.

范例

Example #1 Ds\Set::sum() integer example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->sum());
?>

以上例程的输出类似于：

int(6)

Example #2 Ds\Set::sum() float example

<?php
$set = new \Ds\Set([1, 2.5, 3]);
var_dump($set->sum());
?>

以上例程的输出类似于：

float(6.5)


Converts the set to an array

  • ? Ds\Set::sum
  • Ds\Set::union ?
  • PHP Manual
  • Set
  • Converts the set to an array

Ds\Set::toArray

(PECL ds >= 1.0.0)

Ds\Set::toArray — Converts the set to an array

说明

public Ds\Set::toArray ( ) : array

Converts the set to an array.

Note:

Casting to an array is not supported yet.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the set.

范例

Example #1 Ds\Set::toArray() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->toArray());
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Creates a new set using values from the current instance and another set

  • ? Ds\Set::toArray
  • Ds\Set::xor ?
  • PHP Manual
  • Set
  • Creates a new set using values from the current instance and another set

Ds\Set::union

(PECL ds >= 1.0.0)

Ds\Set::union — Creates a new set using values from the current instance and another set

说明

public Ds\Set::union ( Ds\Set $set ) : Ds\Set

Creates a new set that contains the values of the current instance as well as the values of another set.

A ∪ B = {x: x ∈ A ∨ x ∈ B}

参数

set

The other set, to combine with the current instance.

返回值

A new set containing all the values of the current instance as well as another set.

See Also

  • » Union on Wikipedia

范例

Example #1 Ds\Set::union() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->union($b));
?>

以上例程的输出类似于：

object(Ds\Set)#3 (5) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
}


Creates a new set using values in either the current instance or in another set, but not in both

  • ? Ds\Set::union
  • Stack ?
  • PHP Manual
  • Set
  • Creates a new set using values in either the current instance or in another set, but not in both

Ds\Set::xor

(PECL ds >= 1.0.0)

Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both

说明

public Ds\Set::xor ( Ds\Set $set ) : Ds\Set

Creates a new set containing values in the current instance as well as another set, but not in both.

A ? B = {x : x ∈ (A \ B) ∪ (B \ A)}

参数

set

The other set.

返回值

A new set containing values in the current instance as well as another set, but not in both.

See Also

  • » Symmetric Difference on Wikipedia

范例

Example #1 Ds\Set::xor() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->xor($b));
?>

以上例程的输出类似于：

object(Ds\Set)#3 (4) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(4)
  [3]=>
  int(5)
}


The Stack class

(No version information available, might only be in Git)

简介

A Stack is a "last in, first out" or "LIFO" collection that only allows access to the value at the top of the structure and iterates in that order, destructively.

Uses a Ds\Vector internally.

类摘要

Ds\Stack implements Ds\Collection , ArrayAccess {
/* 方法 */
public allocate ( int $capacity ) : void
public capacity ( ) : int
public clear ( ) : void
public copy ( ) : Ds\Stack
public isEmpty ( ) : bool
public peek ( ) : mixed
public pop ( ) : mixed
public push ( mixed ...$values ) : void
public toArray ( ) : array
}

更新日志

版本 | 说明
PECL ds 1.3.0 | The class now implements ArrayAccess.

Table of Contents

  • Ds\Stack::allocate — Allocates enough memory for a required capacity
  • Ds\Stack::capacity — Returns the current capacity
  • Ds\Stack::clear — Removes all values
  • Ds\Stack::__construct — Creates a new instance
  • Ds\Stack::copy — Returns a shallow copy of the stack
  • Ds\Stack::count — Returns the number of values in the stack
  • Ds\Stack::isEmpty — Returns whether the stack is empty
  • Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Stack::peek — Returns the value at the top of the stack
  • Ds\Stack::pop — Removes and returns the value at the top of the stack
  • Ds\Stack::push — Pushes values onto the stack
  • Ds\Stack::toArray — Converts the stack to an array


Allocates enough memory for a required capacity

  • ? Stack
  • Ds\Stack::capacity ?
  • PHP Manual
  • Stack
  • Allocates enough memory for a required capacity

Ds\Stack::allocate

(PECL ds >= 1.0.0)

Ds\Stack::allocate — Allocates enough memory for a required capacity

说明

public Ds\Stack::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

参数

capacity

The number of values for which capacity should be allocated.

Note:

Capacity will stay the same if this value is less than or equal to the current capacity.

返回值

没有返回值。


Returns the current capacity

  • ? Ds\Stack::allocate
  • Ds\Stack::clear ?
  • PHP Manual
  • Stack
  • Returns the current capacity

Ds\Stack::capacity

(PECL ds >= 1.0.0)

Ds\Stack::capacity — Returns the current capacity

说明

public Ds\Stack::capacity ( ) : int

Returns the current capacity.

参数

此函数没有参数。

返回值

The current capacity.


Removes all values

  • ? Ds\Stack::capacity
  • Ds\Stack::__construct ?
  • PHP Manual
  • Stack
  • Removes all values

Ds\Stack::clear

(PECL ds >= 1.0.0)

Ds\Stack::clear — Removes all values

说明

public Ds\Stack::clear ( ) : void

Removes all values from the stack.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Stack::clear() example

<?php
$stack = new \Ds\Stack([1, 2, 3]);
print_r($stack);

$stack->clear();
print_r($stack);
?>

以上例程的输出类似于：

Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)
Ds\Stack Object
(
)


Creates a new instance

  • ? Ds\Stack::clear
  • Ds\Stack::copy ?
  • PHP Manual
  • Stack
  • Creates a new instance

Ds\Stack::__construct

(PECL ds >= 1.0.0)

Ds\Stack::__construct — Creates a new instance

说明

public Ds\Stack::__construct ( mixed $values = ? )

Creates a new instance, using either a traversable object or an array for the initial values.

参数

values

A traversable object or an array to use for the initial values.

范例

Example #1 Ds\Stack::__construct() example

<?php
$stack = new \Ds\Stack();
print_r($stack);

$stack = new \Ds\Stack([1, 2, 3]);
print_r($stack);
?>

以上例程的输出类似于：

Ds\Stack Object
(
)
Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)


Returns a shallow copy of the stack

  • ? Ds\Stack::__construct
  • Ds\Stack::count ?
  • PHP Manual
  • Stack
  • Returns a shallow copy of the stack

Ds\Stack::copy

(PECL ds >= 1.0.0)

Ds\Stack::copy — Returns a shallow copy of the stack

说明

public Ds\Stack::copy ( ) : Ds\Stack

Returns a shallow copy of the stack.

参数

此函数没有参数。

返回值

Returns a shallow copy of the stack.

范例

Example #1 Ds\Stack::copy() example

<?php
$a = new \Ds\Stack([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

以上例程的输出类似于：

Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)
Ds\Stack Object
(
    [0] => 4
    [1] => 3
    [2] => 2
    [3] => 1
)


Returns the number of values in the stack

  • ? Ds\Stack::copy
  • Ds\Stack::isEmpty ?
  • PHP Manual
  • Stack
  • Returns the number of values in the stack

Ds\Stack::count

(PECL ds >= 1.0.0)

Ds\Stack::count — Returns the number of values in the stack

See Countable::count()


Returns whether the stack is empty

  • ? Ds\Stack::count
  • Ds\Stack::jsonSerialize ?
  • PHP Manual
  • Stack
  • Returns whether the stack is empty

Ds\Stack::isEmpty

(PECL ds >= 1.0.0)

Ds\Stack::isEmpty — Returns whether the stack is empty

说明

public Ds\Stack::isEmpty ( ) : bool

Returns whether the stack is empty.

参数

此函数没有参数。

返回值

Returns true if the stack is empty, false otherwise.

范例

Example #1 Ds\Stack::isEmpty() example

<?php
$a = new \Ds\Stack([1, 2, 3]);
$b = new \Ds\Stack();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • ? Ds\Stack::isEmpty
  • Ds\Stack::peek ?
  • PHP Manual
  • Stack
  • Returns a representation that can be converted to JSON

Ds\Stack::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Note:

You should never need to call this directly.


Returns the value at the top of the stack

  • ? Ds\Stack::jsonSerialize
  • Ds\Stack::pop ?
  • PHP Manual
  • Stack
  • Returns the value at the top of the stack

Ds\Stack::peek

(PECL ds >= 1.0.0)

Ds\Stack::peek — Returns the value at the top of the stack

说明

public Ds\Stack::peek ( ) : mixed

Returns the value at the top of the stack, but does not remove it.

参数

此函数没有参数。

返回值

The value at the top of the stack.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Stack::peek() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c");

var_dump($stack->peek());
?>

以上例程的输出类似于：

string(1) "c"


Removes and returns the value at the top of the stack

  • ? Ds\Stack::peek
  • Ds\Stack::push ?
  • PHP Manual
  • Stack
  • Removes and returns the value at the top of the stack

Ds\Stack::pop

(PECL ds >= 1.0.0)

Ds\Stack::pop — Removes and returns the value at the top of the stack

说明

public Ds\Stack::pop ( ) : mixed

Removes and returns the value at the top of the stack.

参数

此函数没有参数。

返回值

The removed value which was at the top of the stack.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Stack::pop() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c");

var_dump($stack->pop());
var_dump($stack->pop());
var_dump($stack->pop());
?>

以上例程的输出类似于：

string(1) "c"
string(1) "b"
string(1) "a"


Pushes values onto the stack

  • ? Ds\Stack::pop
  • Ds\Stack::toArray ?
  • PHP Manual
  • Stack
  • Pushes values onto the stack

Ds\Stack::push

(PECL ds >= 1.0.0)

Ds\Stack::push — Pushes values onto the stack

说明

public Ds\Stack::push ( mixed ...$values ) : void

Pushes values onto the stack.

参数

values

The values to push onto the stack.

返回值

没有返回值。

范例

Example #1 Ds\Stack::push() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c", "d");
$stack->push(...["e", "f"]);

print_r($stack);
?>

以上例程的输出类似于：

Ds\Stack Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Converts the stack to an array

  • ? Ds\Stack::push
  • Queue ?
  • PHP Manual
  • Stack
  • Converts the stack to an array

Ds\Stack::toArray

(PECL ds >= 1.0.0)

Ds\Stack::toArray — Converts the stack to an array

说明

public Ds\Stack::toArray ( ) : array

Converts the stack to an array.

Note:

Casting to an array is not supported yet.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the stack.

范例

Example #1 Ds\Stack::toArray() example

<?php
$stack = new \Ds\Stack([1, 2, 3]);

var_dump($stack->toArray());
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  int(3)
  [1]=>
  int(2)
  [2]=>
  int(1)
}


The Queue class

(No version information available, might only be in Git)

简介

A Queue is a "first in, first out" or "FIFO" collection that only allows access to the value at the front of the queue and iterates in that order, destructively.

类摘要

Ds\Queue implements Ds\Collection , ArrayAccess {
/* Constants */
const int MIN_CAPACITY = 8 ;
/* 方法 */
public allocate ( int $capacity ) : void
public capacity ( ) : int
public clear ( ) : void
public copy ( ) : Ds\Queue
public isEmpty ( ) : bool
public peek ( ) : mixed
public pop ( ) : mixed
public push ( mixed ...$values ) : void
public toArray ( ) : array
}

预定义常量

Ds\Queue::MIN_CAPACITY

更新日志

版本 | 说明
PECL ds 1.3.0 | The class now implements ArrayAccess.

Table of Contents

  • Ds\Queue::allocate — Allocates enough memory for a required capacity
  • Ds\Queue::capacity — Returns the current capacity
  • Ds\Queue::clear — Removes all values
  • Ds\Queue::__construct — Creates a new instance
  • Ds\Queue::copy — Returns a shallow copy of the queue
  • Ds\Queue::count — Returns the number of values in the queue
  • Ds\Queue::isEmpty — Returns whether the queue is empty
  • Ds\Queue::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\Queue::peek — Returns the value at the front of the queue
  • Ds\Queue::pop — Removes and returns the value at the front of the queue
  • Ds\Queue::push — Pushes values into the queue
  • Ds\Queue::toArray — Converts the queue to an array


Allocates enough memory for a required capacity

  • ? Queue
  • Ds\Queue::capacity ?
  • PHP Manual
  • Queue
  • Allocates enough memory for a required capacity

Ds\Queue::allocate

(PECL ds >= 1.0.0)

Ds\Queue::allocate — Allocates enough memory for a required capacity

说明

public Ds\Queue::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Note:

Capacity will always be rounded up to the nearest power of 2.

参数

capacity

The number of values for which capacity should be allocated.

Note:

Capacity will stay the same if this value is less than or equal to the current capacity.

Note:

Capacity will always be rounded up to the nearest power of 2.

返回值

没有返回值。

范例

Example #1 Ds\Queue::allocate() example

<?php
$queue = new \Ds\Queue();
var_dump($queue->capacity());

$queue->allocate(100);
var_dump($queue->capacity());
?>

以上例程的输出类似于：

int(8)
int(128)


Returns the current capacity

  • ? Ds\Queue::allocate
  • Ds\Queue::clear ?
  • PHP Manual
  • Queue
  • Returns the current capacity

Ds\Queue::capacity

(PECL ds >= 1.0.0)

Ds\Queue::capacity — Returns the current capacity

说明

public Ds\Queue::capacity ( ) : int

Returns the current capacity.

参数

此函数没有参数。

返回值

The current capacity.

范例

Example #1 Ds\Queue::capacity() example

<?php
$queue = new \Ds\Queue();
var_dump($queue->capacity());

$queue->push(...range(1, 50));
var_dump($queue->capacity());
?>

以上例程的输出类似于：

int(8)
int(64)


Removes all values

  • ? Ds\Queue::capacity
  • Ds\Queue::__construct ?
  • PHP Manual
  • Queue
  • Removes all values

Ds\Queue::clear

(PECL ds >= 1.0.0)

Ds\Queue::clear — Removes all values

说明

public Ds\Queue::clear ( ) : void

Removes all values from the queue.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\Queue::clear() example

<?php
$queue = new \Ds\Queue([1, 2, 3]);
print_r($queue);

$queue->clear();
print_r($queue);
?>

以上例程的输出类似于：

Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Queue Object
(
)


Creates a new instance

  • ? Ds\Queue::clear
  • Ds\Queue::copy ?
  • PHP Manual
  • Queue
  • Creates a new instance

Ds\Queue::__construct

(PECL ds >= 1.0.0)

Ds\Queue::__construct — Creates a new instance

说明

public Ds\Queue::__construct ( mixed $values = ? )

Creates a new instance, using either a traversable object or an array for the initial values.

参数

values

A traversable object or an array to use for the initial values.

范例

Example #1 Ds\Queue::__construct() example

<?php
$queue = new \Ds\Queue();
var_dump($queue);

$queue = new \Ds\Queue([1, 2, 3]);
var_dump($queue);
?>

以上例程的输出类似于：

object(Ds\Queue)#2 (0) {
}
object(Ds\Queue)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


Returns a shallow copy of the queue

  • ? Ds\Queue::__construct
  • Ds\Queue::count ?
  • PHP Manual
  • Queue
  • Returns a shallow copy of the queue

Ds\Queue::copy

(PECL ds >= 1.0.0)

Ds\Queue::copy — Returns a shallow copy of the queue

说明

public Ds\Queue::copy ( ) : Ds\Queue

Returns a shallow copy of the queue.

参数

此函数没有参数。

返回值

Returns a shallow copy of the queue.

范例

Example #1 Ds\Queue::copy() example

<?php
$a = new \Ds\Queue([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

以上例程的输出类似于：

Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)


Returns the number of values in the queue

  • ? Ds\Queue::copy
  • Ds\Queue::isEmpty ?
  • PHP Manual
  • Queue
  • Returns the number of values in the queue

Ds\Queue::count

(PECL ds >= 1.0.0)

Ds\Queue::count — Returns the number of values in the queue

See Countable::count()


Returns whether the queue is empty

  • ? Ds\Queue::count
  • Ds\Queue::jsonSerialize ?
  • PHP Manual
  • Queue
  • Returns whether the queue is empty

Ds\Queue::isEmpty

(PECL ds >= 1.0.0)

Ds\Queue::isEmpty — Returns whether the queue is empty

说明

public Ds\Queue::isEmpty ( ) : bool

Returns whether the queue is empty.

参数

此函数没有参数。

返回值

Returns true if the queue is empty, false otherwise.

范例

Example #1 Ds\Queue::isEmpty() example

<?php
$a = new \Ds\Queue([1, 2, 3]);
$b = new \Ds\Queue();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • ? Ds\Queue::isEmpty
  • Ds\Queue::peek ?
  • PHP Manual
  • Queue
  • Returns a representation that can be converted to JSON

Ds\Queue::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Queue::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Note:

You should never need to call this directly.


Returns the value at the front of the queue

  • ? Ds\Queue::jsonSerialize
  • Ds\Queue::pop ?
  • PHP Manual
  • Queue
  • Returns the value at the front of the queue

Ds\Queue::peek

(PECL ds >= 1.0.0)

Ds\Queue::peek — Returns the value at the front of the queue

说明

public Ds\Queue::peek ( ) : mixed

Returns the value at the front of the queue, but does not remove it.

参数

此函数没有参数。

返回值

The value at the front of the queue.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Queue::peek() example

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c");

var_dump($queue->peek());
?>

以上例程的输出类似于：

string(1) "a"


Removes and returns the value at the front of the queue

  • ? Ds\Queue::peek
  • Ds\Queue::push ?
  • PHP Manual
  • Queue
  • Removes and returns the value at the front of the queue

Ds\Queue::pop

(PECL ds >= 1.0.0)

Ds\Queue::pop — Removes and returns the value at the front of the queue

说明

public Ds\Queue::pop ( ) : mixed

Removes and returns the value at the front of the queue.

参数

此函数没有参数。

返回值

The removed value which was at the front of the queue.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\Queue::pop() example

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c");

var_dump($queue->pop());
var_dump($queue->pop());
var_dump($queue->pop());
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Pushes values into the queue

  • ? Ds\Queue::pop
  • Ds\Queue::toArray ?
  • PHP Manual
  • Queue
  • Pushes values into the queue

Ds\Queue::push

(PECL ds >= 1.0.0)

Ds\Queue::push — Pushes values into the queue

说明

public Ds\Queue::push ( mixed ...$values ) : void

Pushes values into the queue.

参数

values

The values to push into the queue.

返回值

没有返回值。

范例

Example #1 Ds\Queue::push() example

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c", "d");
$queue->push(...["e", "f"]);

print_r($queue);
?>

以上例程的输出类似于：

Ds\Queue Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)


Converts the queue to an array

  • ? Ds\Queue::push
  • PriorityQueue ?
  • PHP Manual
  • Queue
  • Converts the queue to an array

Ds\Queue::toArray

(PECL ds >= 1.0.0)

Ds\Queue::toArray — Converts the queue to an array

说明

public Ds\Queue::toArray ( ) : array

Converts the queue to an array.

Note:

Casting to an array is not supported yet.

Note:

This method is not destructive.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the queue.

范例

Example #1 Ds\Queue::toArray() example

<?php
$queue = new \Ds\Queue([1, 2, 3]);

var_dump($queue->toArray());
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}


The PriorityQueue class

(No version information available, might only be in Git)

简介

A PriorityQueue is very similar to a Queue. Values are pushed into the queue with an assigned priority, and the value with the highest priority will always be at the front of the queue.

Implemented using a max heap.

Note:

"First in, first out" ordering is preserved for values with the same priority.

Note:

Iterating over a PriorityQueue is destructive, equivalent to successive pop operations until the queue is empty.

类摘要

Ds\PriorityQueue implements Ds\Collection {
/* Constants */
const int MIN_CAPACITY = 8 ;
/* 方法 */
public allocate ( int $capacity ) : void
public capacity ( ) : int
public clear ( ) : void
public copy ( ) : Ds\PriorityQueue
public isEmpty ( ) : bool
public peek ( ) : mixed
public pop ( ) : mixed
public push ( mixed $value , int $priority ) : void
public toArray ( ) : array
}

预定义常量

Ds\PriorityQueue::MIN_CAPACITY

Table of Contents

  • Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity
  • Ds\PriorityQueue::capacity — Returns the current capacity
  • Ds\PriorityQueue::clear — Removes all values
  • Ds\PriorityQueue::__construct — Creates a new instance
  • Ds\PriorityQueue::copy — Returns a shallow copy of the queue
  • Ds\PriorityQueue::count — Returns the number of values in the queue
  • Ds\PriorityQueue::isEmpty — Returns whether the queue is empty
  • Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON
  • Ds\PriorityQueue::peek — Returns the value at the front of the queue
  • Ds\PriorityQueue::pop — Removes and returns the value with the highest priority
  • Ds\PriorityQueue::push — Pushes values into the queue
  • Ds\PriorityQueue::toArray — Converts the queue to an array


Allocates enough memory for a required capacity

  • ? PriorityQueue
  • Ds\PriorityQueue::capacity ?
  • PHP Manual
  • PriorityQueue
  • Allocates enough memory for a required capacity

Ds\PriorityQueue::allocate

(PECL ds >= 1.0.0)

Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity

说明

public Ds\PriorityQueue::allocate ( int $capacity ) : void

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

参数

capacity

The number of values for which capacity should be allocated.

Note:

Capacity will stay the same if this value is less than or equal to the current capacity.

Note:

Capacity will always be rounded up to the nearest power of 2.

返回值

没有返回值。

范例

Example #1 Ds\PriorityQueue::allocate() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue->capacity());

$queue->allocate(100);
var_dump($queue->capacity());
?>

以上例程的输出类似于：

int(8)
int(128)


Returns the current capacity

  • ? Ds\PriorityQueue::allocate
  • Ds\PriorityQueue::clear ?
  • PHP Manual
  • PriorityQueue
  • Returns the current capacity

Ds\PriorityQueue::capacity

(PECL ds >= 1.0.0)

Ds\PriorityQueue::capacity — Returns the current capacity

说明

public Ds\PriorityQueue::capacity ( ) : int

Returns the current capacity.

参数

此函数没有参数。

返回值

The current capacity.

范例

Example #1 Ds\PriorityQueue::capacity() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue->capacity());
?>

以上例程的输出类似于：

int(8)


Removes all values

  • ? Ds\PriorityQueue::capacity
  • Ds\PriorityQueue::__construct ?
  • PHP Manual
  • PriorityQueue
  • Removes all values

Ds\PriorityQueue::clear

(PECL ds >= 1.0.0)

Ds\PriorityQueue::clear — Removes all values

说明

public Ds\PriorityQueue::clear ( ) : void

Removes all values from the queue.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Ds\PriorityQueue::clear() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

$queue->clear();
print_r($queue);
?>

以上例程的输出类似于：

Ds\PriorityQueue Object
(
)


Creates a new instance

  • ? Ds\PriorityQueue::clear
  • Ds\PriorityQueue::copy ?
  • PHP Manual
  • PriorityQueue
  • Creates a new instance

Ds\PriorityQueue::__construct

(PECL ds >= 1.0.0)

Ds\PriorityQueue::__construct — Creates a new instance

说明

public Ds\PriorityQueue::__construct ( )

Creates a new instance.

范例

Example #1 Ds\PriorityQueue::__construct() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue);
?>

以上例程的输出类似于：

object(Ds\PriorityQueue)#1 (0) {
}


Returns a shallow copy of the queue

  • ? Ds\PriorityQueue::__construct
  • Ds\PriorityQueue::count ?
  • PHP Manual
  • PriorityQueue
  • Returns a shallow copy of the queue

Ds\PriorityQueue::copy

(PECL ds >= 1.0.0)

Ds\PriorityQueue::copy — Returns a shallow copy of the queue

说明

public Ds\PriorityQueue::copy ( ) : Ds\PriorityQueue

Returns a shallow copy of the queue.

参数

此函数没有参数。

返回值

Returns a shallow copy of the queue.

范例

Example #1 Ds\PriorityQueue::copy() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->copy());
?>

以上例程的输出类似于：

Ds\PriorityQueue Object
(
    [0] => b
    [1] => c
    [2] => a
)


Returns the number of values in the queue

  • ? Ds\PriorityQueue::copy
  • Ds\PriorityQueue::isEmpty ?
  • PHP Manual
  • PriorityQueue
  • Returns the number of values in the queue

Ds\PriorityQueue::count

(PECL ds >= 1.0.0)

Ds\PriorityQueue::count — Returns the number of values in the queue

See Countable::count()


Returns whether the queue is empty

  • ? Ds\PriorityQueue::count
  • Ds\PriorityQueue::jsonSerialize ?
  • PHP Manual
  • PriorityQueue
  • Returns whether the queue is empty

Ds\PriorityQueue::isEmpty

(PECL ds >= 1.0.0)

Ds\PriorityQueue::isEmpty — Returns whether the queue is empty

说明

public Ds\PriorityQueue::isEmpty ( ) : bool

Returns whether the queue is empty.

参数

此函数没有参数。

返回值

Returns true if the queue is empty, false otherwise.

范例

Example #1 Ds\PriorityQueue::isEmpty() example

<?php
$a = new \Ds\PriorityQueue();
$b = new \Ds\PriorityQueue();

$a->push("a",  5);
$a->push("b", 15);
$a->push("c", 10);

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

以上例程的输出类似于：

bool(false)
bool(true)


Returns a representation that can be converted to JSON

  • ? Ds\PriorityQueue::isEmpty
  • Ds\PriorityQueue::peek ?
  • PHP Manual
  • PriorityQueue
  • Returns a representation that can be converted to JSON

Ds\PriorityQueue::jsonSerialize

(PECL ds >= 1.0.0)

Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON

See JsonSerializable::jsonSerialize()

Note:

You should never need to call this directly.


Returns the value at the front of the queue

  • ? Ds\PriorityQueue::jsonSerialize
  • Ds\PriorityQueue::pop ?
  • PHP Manual
  • PriorityQueue
  • Returns the value at the front of the queue

Ds\PriorityQueue::peek

(PECL ds >= 1.0.0)

Ds\PriorityQueue::peek — Returns the value at the front of the queue

说明

public Ds\PriorityQueue::peek ( ) : mixed

Returns the value at the front of the queue, but does not remove it.

参数

此函数没有参数。

返回值

The value at the front of the queue.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\PriorityQueue::peek() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

var_dump($queue->peek());
?>

以上例程的输出类似于：

string(1) "b"


Removes and returns the value with the highest priority

  • ? Ds\PriorityQueue::peek
  • Ds\PriorityQueue::push ?
  • PHP Manual
  • PriorityQueue
  • Removes and returns the value with the highest priority

Ds\PriorityQueue::pop

(PECL ds >= 1.0.0)

Ds\PriorityQueue::pop — Removes and returns the value with the highest priority

说明

public Ds\PriorityQueue::pop ( ) : mixed

Removes and returns the value at the front of the queue, ie. the value with the highest priority.

Note:

Values with equal priority fall back to FIFO (first in first out).

参数

此函数没有参数。

返回值

The removed value which was at the front of the queue.

错误／异常

UnderflowException if empty.

范例

Example #1 Ds\PriorityQueue::pop() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->pop());
print_r($queue->pop());
print_r($queue->pop());
?>

以上例程的输出类似于：

string(1) "a"
string(1) "b"
string(1) "c"


Pushes values into the queue

  • ? Ds\PriorityQueue::pop
  • Ds\PriorityQueue::toArray ?
  • PHP Manual
  • PriorityQueue
  • Pushes values into the queue

Ds\PriorityQueue::push

(PECL ds >= 1.0.0)

Ds\PriorityQueue::push — Pushes values into the queue

说明

public Ds\PriorityQueue::push ( mixed $value , int $priority ) : void

Pushes a value with a given priority into the queue.

参数

value

The value to push into the queue.

priority

The priority associated with the value.

返回值

没有返回值。

范例

Example #1 Ds\PriorityQueue::push() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->pop());
print_r($queue->pop());
print_r($queue->pop());
?>

以上例程的输出类似于：

string(1) "b"
string(1) "c"
string(1) "a"


Converts the queue to an array

  • ? Ds\PriorityQueue::push
  • 其它服务 ?
  • PHP Manual
  • PriorityQueue
  • Converts the queue to an array

Ds\PriorityQueue::toArray

(PECL ds >= 1.0.0)

Ds\PriorityQueue::toArray — Converts the queue to an array

说明

public Ds\PriorityQueue::toArray ( ) : array

Converts the queue to an array.

Note:

This method is not destructive.

Note:

Casting to an array is not supported yet.

参数

此函数没有参数。

返回值

An array containing all the values in the same order as the queue.

范例

Example #1 Ds\PriorityQueue::toArray() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

var_dump($queue->toArray());
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  string(1) "b"
  [1]=>
  string(1) "c"
  [2]=>
  string(1) "a"
}


其它服务

  • cURL — Client URL 库
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • cURL 函数
    • CURLFile — CURLFile 类
  • Event
    • 简介
    • 安装／配置
    • 范例
    • Event flags
    • About event persistence
    • Event callbacks
    • Constructing signal events
    • Event — The Event class
    • EventBase — The EventBase class
    • EventBuffer — The EventBuffer class
    • EventBufferEvent — The EventBufferEvent class
    • About buffer event callbacks
    • EventConfig — The EventConfig class
    • EventDnsBase — The EventDnsBase class
    • EventHttp — The EventHttp class
    • EventHttpConnection — The EventHttpConnection class
    • EventHttpRequest — The EventHttpRequest class
    • EventListener — The EventListener class
    • EventSslContext — The EventSslContext class
    • EventUtil — The EventUtil class
  • FTP
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • FTP 函数
  • Gearman
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • GearmanClient — The GearmanClient class
    • GearmanJob — The GearmanJob class
    • GearmanTask — The GearmanTask class
    • GearmanWorker — The GearmanWorker class
    • GearmanException — The GearmanException class
  • LDAP — Lightweight Directory Access Protocol
    • 简介
    • 安装／配置
    • 预定义常量
    • Using the PHP LDAP calls
    • LDAP controls
    • 范例
    • LDAP 函数
  • Memcache
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Memcache — Memcache类
    • Memcache 函数
  • Memcached
    • 简介
    • 安装／配置
    • 预定义常量
    • 超时时间
    • 回调
    • Sessions支持
    • Memcached — Memcached类
  • mqseries
    • 简介
    • 安装／配置
    • 预定义常量
    • mqseries 函数
  • 网络
    • 简介
    • 安装／配置
    • 预定义常量
    • 网络 函数
  • RRD — RRDtool
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • RRD 函数
    • RRDCreator — The RRDCreator class
    • RRDGraph — The RRDGraph class
    • RRDUpdater — The RRDUpdater class
  • ScoutAPM
    • 简介
    • 安装／配置
    • 预定义常量
    • Scoutapm 函数
  • SNMP
    • 简介
    • 安装／配置
    • 预定义常量
    • SNMP 函数
    • SNMP — The SNMP class
    • SNMPException — The SNMPException class
  • Sockets
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Socket Errors
    • Socket 函数
  • SSH2 — Secure Shell2
    • 简介
    • 安装／配置
    • 预定义常量
    • SSH2 函数
  • Stomp — Stomp Client
    • 简介
    • 安装／配置
    • 范例
    • Stomp 函数
    • Stomp — The Stomp class
    • StompFrame — The StompFrame class
    • StompException — The StompException class
  • SVM — 支持向量机
    • 简介
    • 安装／配置
    • 范例
    • SVM — The SVM class
    • SVMModel — The SVMModel class
  • SVN — Subversion
    • 简介
    • 安装／配置
    • 预定义常量
    • SVN 函数
  • TCP — TCP Wrappers
    • 简介
    • 安装／配置
    • 预定义常量
    • TCP 函数
  • Varnish
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • VarnishAdmin — The VarnishAdmin class
    • VarnishStat — The VarnishStat class
    • VarnishLog — The VarnishLog class
  • YAZ
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • YAZ 函数
  • 0MQ消息系统 — ZMQ
    • 简介
    • 安装／配置
    • ZMQ — The ZMQ class
    • ZMQContext — The ZMQContext class
    • ZMQSocket — The ZMQSocket class
    • ZMQPoll — The ZMQPoll class
    • ZMQDevice — The ZMQDevice class
  • ZooKeeper
    • 简介
    • 安装／配置
    • 预定义常量
    • ZooKeeper 函数
    • Zookeeper — The Zookeeper class
    • ZookeeperConfig — The ZookeeperConfig class
    • ZookeeperException — The ZookeeperException class
    • ZookeeperAuthenticationException — The ZookeeperAuthenticationException class
    • ZookeeperConnectionException — The ZookeeperConnectionException class
    • ZookeeperMarshallingException — The ZookeeperMarshallingException class
    • ZookeeperNoNodeException — The ZookeeperNoNodeException class
    • ZookeeperOperationTimeoutException — The ZookeeperOperationTimeoutException class
    • ZookeeperSessionException — The ZookeeperSessionException class


Client URL 库

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • curl 基础例子
  • cURL 函数
    • curl_close — 关闭 cURL 会话
    • curl_copy_handle — 复制一个cURL句柄和它的所有选项
    • curl_errno — 返回最后一次的错误代码
    • curl_error — 返回当前会话最后一次错误的字符串
    • curl_escape — 使用 URL 编码给定的字符串
    • curl_exec — 执行 cURL 会话
    • curl_file_create — 创建一个 CURLFile 对象
    • curl_getinfo — 获取一个cURL连接资源句柄的信息
    • curl_init — 初始化 cURL 会话
    • curl_multi_add_handle — 向curl批处理会话中添加单独的curl句柄
    • curl_multi_close — 关闭一组cURL句柄
    • curl_multi_errno — 返回上一次 curl 批处理的错误码
    • curl_multi_exec — 运行当前 cURL 句柄的子连接
    • curl_multi_getcontent — 如果设置了CURLOPT_RETURNTRANSFER，则返回获取的输出的文本流
    • curl_multi_info_read — 获取当前解析的cURL的相关传输信息
    • curl_multi_init — 返回一个新cURL批处理句柄
    • curl_multi_remove_handle — 移除cURL批处理句柄资源中的某个句柄资源
    • curl_multi_select — 等待所有cURL批处理中的活动连接
    • curl_multi_setopt — 为 cURL 并行处理设置一个选项
    • curl_multi_strerror — 返回字符串描述的错误代码
    • curl_pause — 暂停和取消暂停一个连接。
    • curl_reset — 重置一个 libcurl 会话句柄的所有的选项
    • curl_setopt_array — 为 cURL 传输会话批量设置选项
    • curl_setopt — 设置 cURL 传输选项
    • curl_share_close — 关闭 cURL 共享句柄
    • curl_share_errno — 返回共享 curl 句柄的最后一次错误号
    • curl_share_init — 初始化一个 cURL 共享句柄。
    • curl_share_setopt — 为 cURL 共享句柄设置选项。
    • curl_share_strerror — 返回错误号对应的错误消息
    • curl_strerror — 返回错误代码的字符串描述
    • curl_unescape — 解码给定的 URL 编码的字符串
    • curl_version — 获取 cURL 版本信息
  • CURLFile — CURLFile 类
    • CURLFile::__construct — 创建 CURLFile 对象
    • CURLFile::getFilename — 获取被上传文件的 文件名
    • CURLFile::getMimeType — 获取被上传文件的 MIME 类型
    • CURLFile::getPostFilename — 获取 POST 请求时使用的 文件名
    • CURLFile::setMimeType — 设置被上传文件的 MIME 类型
    • CURLFile::setPostFilename — 设置 POST 请求时使用的文件名


简介

PHP 支持 Daniel Stenberg 创建的 libcurl 库，能够连接通讯各种服务器、使用各种协议。libcurl 目前支持的协议有 http、https、ftp、gopher、telnet、dict、file、ldap。 libcurl 同时支持 HTTPS 证书、HTTP POST、HTTP PUT、 FTP 上传(也能通过 PHP 的 FTP 扩展完成)、HTTP 基于表单的上传、代理、cookies、用户名+密码的认证。


需求

需要安装» libcurl包才能使用 PHP 的 cURL 函数。PHP 需要使用 7.10.5 或更高版本的 libcurl。


安装

要 PHP 支持 cURL，必须在编译 PHP 时加上 --with-curl[=DIR] 选项，DIR 为包含 lib 和 include 的目录路径。在 include 目录中必须有一个名为 curl，包含了 easy.h 和 curl.h 的文件夹。lib 文件夹里应该有一个名为 libcurl.a 的文件。对于 PHP 5.5.0 之前版本，你可以配置 --with-curlwrappers 使 cURL 使用 URL 流。

Note: Win32 用户注意
要在 Windows 环境下使用这个模块，libeay32.dll 和 ssleay32.dll 库文件必须放到 PATH 环境变量包含的目录下。OpenSSL 1.1 下则为 libcrypto-*.dll 和 libssl-*.dll 文件。同样的，libssh2.dll 文件也需要放到 PATH 环境变量包含的目录下。 不需要用 cURL 网站上的 libcurl.dll 库。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

cURL 配置选项
名字 | 默认 | 可修改范围 | 更新日志
curl.cainfo | NULL | PHP_INI_SYSTEM | 自 PHP 5.3.7. 起有效
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

curl.cainfo string

CURLOPT_CAINFO 选项的一个默认值。这个值必须是一个绝对路径。


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

这个扩展定义了2种资源：cURL 句柄和 cURL 批处理句柄。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

curl_setopt()、curl_multi_setopt()、 curl_getinfo() 文档中常量的描述和使用。

CURLOPT_AUTOREFERER (integer)
Available since PHP 5.1.0
CURLOPT_COOKIESESSION (integer)
Available since PHP 5.1.0
CURLOPT_DNS_USE_GLOBAL_CACHE (integer)
CURLOPT_DNS_CACHE_TIMEOUT (integer)
CURLOPT_FTP_SSL (integer)
Available since PHP 5.2.0
CURLFTP_CREATE_DIR (integer)
Available since PHP 7.0.7 and cURL 7.19.3
CURLFTP_CREATE_DIR_NONE (integer)
Available since PHP 7.0.7 and cURL 7.19.3
CURLFTP_CREATE_DIR_RETRY (integer)
Available since PHP 7.0.7 and cURL 7.19.3
CURLFTPSSL_TRY (integer)
Available since PHP 5.2.0
CURLFTPSSL_ALL (integer)
Available since PHP 5.2.0
CURLFTPSSL_CONTROL (integer)
Available since PHP 5.2.0
CURLFTPSSL_NONE (integer)
Available since PHP 5.2.0
CURLOPT_PRIVATE (integer)
Available since PHP 5.2.4
CURLOPT_FTPSSLAUTH (integer)
Available since PHP 5.1.0
CURLOPT_PORT (integer)
CURLOPT_FILE (integer)
CURLOPT_INFILE (integer)
CURLOPT_INFILESIZE (integer)
CURLOPT_URL (integer)
CURLOPT_PROXY (integer)
CURLOPT_VERBOSE (integer)
CURLOPT_HEADER (integer)
CURLOPT_HTTPHEADER (integer)
CURLOPT_NOPROGRESS (integer)
CURLOPT_NOBODY (integer)
CURLOPT_FAILONERROR (integer)
CURLOPT_UPLOAD (integer)
CURLOPT_POST (integer)
CURLOPT_FTPLISTONLY (integer)
CURLOPT_FTPAPPEND (integer)
CURLOPT_FTP_CREATE_MISSING_DIRS (integer)
CURLOPT_NETRC (integer)
CURLOPT_FOLLOWLOCATION (integer)
This constant is not available when open_basedir is enabled.
CURLOPT_FTPASCII (integer)
CURLOPT_PUT (integer)
CURLOPT_MUTE (integer)
CURLOPT_USERPWD (integer)
CURLOPT_PROXYUSERPWD (integer)
CURLOPT_RANGE (integer)
CURLOPT_TIMEOUT (integer)
CURLOPT_TIMEOUT_MS (integer)
CURLOPT_TCP_NODELAY (integer)
Available since PHP 5.2.1
CURLOPT_POSTFIELDS (integer)
CURLOPT_PROGRESSFUNCTION (integer)
Available since PHP 5.3.0
CURLOPT_REFERER (integer)
CURLOPT_USERAGENT (integer)
CURLOPT_FTPPORT (integer)
CURLOPT_FTP_USE_EPSV (integer)
CURLOPT_LOW_SPEED_LIMIT (integer)
CURLOPT_LOW_SPEED_TIME (integer)
CURLOPT_RESUME_FROM (integer)
CURLOPT_COOKIE (integer)
CURLOPT_COOKIELIST (integer)
Available since PHP 5.5.0 and cURL 7.14.1
CURLOPT_SSLCERT (integer)
CURLOPT_SSLCERTPASSWD (integer)
CURLOPT_WRITEHEADER (integer)
CURLOPT_SSL_VERIFYHOST (integer)
CURLOPT_COOKIEFILE (integer)
CURLOPT_SSLVERSION (integer)
CURL_SSLVERSION_DEFAULT (integer)
CURL_SSLVERSION_TLSv1 (integer)
CURL_SSLVERSION_SSLv2 (integer)
CURL_SSLVERSION_SSLv3 (integer)
CURL_SSLVERSION_TLSv1_0 (integer)
Available since PHP 5.5.19 and 5.6.3
CURL_SSLVERSION_TLSv1_1 (integer)
Available since PHP 5.5.19 and 5.6.3
CURL_SSLVERSION_TLSv1_2 (integer)
Available since PHP 5.5.19 and 5.6.3
CURLOPT_TIMECONDITION (integer)
CURLOPT_TIMEVALUE (integer)
CURLOPT_CUSTOMREQUEST (integer)
CURLOPT_STDERR (integer)
CURLOPT_TRANSFERTEXT (integer)
CURLOPT_RETURNTRANSFER (integer)
CURLOPT_QUOTE (integer)
CURLOPT_POSTQUOTE (integer)
CURLOPT_INTERFACE (integer)
CURLOPT_KRB4LEVEL (integer)
CURLOPT_HTTPPROXYTUNNEL (integer)
CURLOPT_FILETIME (integer)
CURLOPT_WRITEFUNCTION (integer)
CURLOPT_READFUNCTION (integer)
CURLOPT_PASSWDFUNCTION (integer)
CURLOPT_HEADERFUNCTION (integer)
CURLOPT_MAXREDIRS (integer)
CURLOPT_MAXCONNECTS (integer)
CURLOPT_CLOSEPOLICY (integer)
Removed in PHP 5.6.0.
CURLOPT_FRESH_CONNECT (integer)
CURLOPT_FORBID_REUSE (integer)
CURLOPT_RANDOM_FILE (integer)
CURLOPT_EGDSOCKET (integer)
CURLOPT_CONNECTTIMEOUT (integer)
CURLOPT_CONNECTTIMEOUT_MS (integer)
CURLOPT_SSL_VERIFYPEER (integer)
CURLOPT_CAINFO (integer)
CURLOPT_CAPATH (integer)
CURLOPT_COOKIEJAR (integer)
CURLOPT_SSL_CIPHER_LIST (integer)
CURLOPT_BINARYTRANSFER (integer)
CURLOPT_NOSIGNAL (integer)
CURLOPT_PROXYTYPE (integer)
Available as of cURL 7.10.
CURLOPT_BUFFERSIZE (integer)
CURLOPT_HTTPGET (integer)
CURLOPT_HTTP_VERSION (integer)
CURLOPT_SSLKEY (integer)
CURLOPT_SSLKEYTYPE (integer)
CURLOPT_SSLKEYPASSWD (integer)
CURLOPT_SSLENGINE (integer)
CURLOPT_SSLENGINE_DEFAULT (integer)
CURLOPT_SSLCERTTYPE (integer)
CURLOPT_CRLF (integer)
CURLOPT_ENCODING (integer)
CURLOPT_PROXYPORT (integer)
CURLOPT_UNRESTRICTED_AUTH (integer)
CURLOPT_FTP_USE_EPRT (integer)
CURLOPT_HTTP200ALIASES (integer)
CURLOPT_HTTPAUTH (integer)
CURLAUTH_BASIC (integer)
CURLAUTH_DIGEST (integer)
CURLAUTH_GSSNEGOTIATE (integer)
CURLAUTH_NEGOTIATE (integer)
Available since PHP 7.0.7 and cURL 7.38.0.
CURLAUTH_NTLM (integer)
CURLAUTH_NTLM_WB (integer)
Available since PHP 7.0.7 and cURL 7.22.0
CURLAUTH_ANY (integer)
CURLAUTH_ANYSAFE (integer)
CURLOPT_PROXYAUTH (integer)
CURLOPT_MAX_RECV_SPEED_LARGE (integer)
Available since PHP 5.4.0 and cURL 7.15.5
CURLOPT_MAX_SEND_SPEED_LARGE (integer)
Available since PHP 5.4.0 and cURL 7.15.5
CURLOPT_HEADEROPT (integer)
Available since PHP 7.0.7 and cURL 7.37.0
CURLOPT_PROXYHEADER (integer)
Available since PHP 7.0.7 and cURL 7.37.0
CURLCLOSEPOLICY_LEAST_RECENTLY_USED (integer)
Removed in PHP 5.6.0.
CURLCLOSEPOLICY_LEAST_TRAFFIC (integer)
Removed in PHP 5.6.0.
CURLCLOSEPOLICY_SLOWEST (integer)
Removed in PHP 5.6.0.
CURLCLOSEPOLICY_CALLBACK (integer)
Removed in PHP 5.6.0.
CURLCLOSEPOLICY_OLDEST (integer)
Removed in PHP 5.6.0.
CURLINFO_PRIVATE (integer)
Available since PHP 5.2.4
CURLINFO_EFFECTIVE_URL (integer)
CURLINFO_HTTP_CODE (integer)
As of PHP 5.5.0 and cURL 7.10.8, this is a legacy alias of CURLINFO_RESPONSE_CODE
CURLINFO_RESPONSE_CODE (integer)
Available since PHP 5.5.0 and cURL 7.10.8
CURLINFO_HEADER_OUT (integer)
Available since PHP 5.1.3
CURLINFO_HEADER_SIZE (integer)
CURLINFO_REQUEST_SIZE (integer)
CURLINFO_TOTAL_TIME (integer)
CURLINFO_NAMELOOKUP_TIME (integer)
CURLINFO_CONNECT_TIME (integer)
CURLINFO_PRETRANSFER_TIME (integer)
CURLINFO_SIZE_UPLOAD (integer)
CURLINFO_SIZE_DOWNLOAD (integer)
CURLINFO_SPEED_DOWNLOAD (integer)
CURLINFO_SPEED_UPLOAD (integer)
CURLINFO_FILETIME (integer)
CURLINFO_SSL_VERIFYRESULT (integer)
CURLINFO_CONTENT_LENGTH_DOWNLOAD (integer)
CURLINFO_CONTENT_LENGTH_UPLOAD (integer)
CURLINFO_STARTTRANSFER_TIME (integer)
CURLINFO_CONTENT_TYPE (integer)
CURLINFO_REDIRECT_TIME (integer)
CURLINFO_REDIRECT_COUNT (integer)
CURLINFO_REDIRECT_URL (string)
Available since PHP 5.3.7
CURLINFO_PRIMARY_IP (string)
Available since PHP 5.4.7
CURLINFO_PRIMARY_PORT (integer)
Available since PHP 5.4.7
CURLINFO_LOCAL_IP (string)
Available since PHP 5.4.7
CURLINFO_LOCAL_PORT (integer)
Available since PHP 5.4.7
CURL_PUSH_OK (integer)
Available since PHP 7.1.0 and cURL 7.44.0
CURL_PUSH_DENY (integer)
Available since PHP 7.1.0 and cURL 7.44.0
CURL_REDIR_POST_301 (integer)
Available since PHP 7.0.7 and cURL 7.18.2
CURL_REDIR_POST_302 (integer)
Available since PHP 7.0.7 and cURL 7.18.2
CURL_REDIR_POST_303 (integer)
Available since PHP 7.0.7 and cURL 7.25.1
CURL_REDIR_POST_ALL (integer)
Available since PHP 7.0.7 and cURL 7.18.2
CURL_TIMECOND_IFMODSINCE (integer)
CURL_TIMECOND_IFUNMODSINCE (integer)
CURL_TIMECOND_LASTMOD (integer)
CURL_VERSION_ALTSVC (integer)
Available since PHP 7.3.6 and cURL 7.64.1
CURL_VERSION_ASYNCHDNS (integer)
Available since PHP 7.3.0 and cURL 7.10.7
CURL_VERSION_BROTLI (integer)
Available since PHP 7.3.0 and cURL 7.57.0
CURL_VERSION_CONV (integer)
Available since PHP 7.3.0 and cURL 7.15.4
CURL_VERSION_CURLDEBUG (integer)
Available since PHP 7.3.6 and cURL 7.19.6
CURL_VERSION_DEBUG (integer)
Available since PHP 7.3.0 and cURL 7.10.6
CURL_VERSION_GSSAPI (integer)
Available since PHP 7.3.0 and cURL 7.38.0
CURL_VERSION_GSSNEGOTIATE (integer)
Available since PHP 7.3.0 and cURL 7.10.6 (deprecated since 7.38.0)
CURL_VERSION_IDN (integer)
Available since PHP 7.3.0 and cURL 7.12.0
CURL_VERSION_MULTI_SSL (integer)
Available since PHP 7.3.0 and cURL 7.56.0
CURL_VERSION_NTLM (integer)
Available since PHP 7.3.0 and cURL 7.10.6
CURL_VERSION_NTLM_WB (integer)
Available since PHP 7.3.0 and cURL 7.22.0
CURL_VERSION_IPV6 (integer)
CURL_VERSION_KERBEROS4 (integer)
CURL_VERSION_KERBEROS5 (integer)
Available since PHP 7.0.7 and cURL 7.40.0
CURL_VERSION_HTTP2 (integer)
Available since PHP 5.5.24 and 5.6.8 and cURL 7.33.0
CURL_VERSION_PSL (integer)
Available since PHP 7.3.6 and cURL 7.47.0
CURL_VERSION_SPNEGO (integer)
Available since PHP 7.3.0 and cURL 7.10.8
CURL_VERSION_SSPI (integer)
Available since PHP 7.3.0 and cURL 7.13.2
CURL_VERSION_SSL (integer)
CURL_VERSION_TLSAUTH_SRP (integer)
Available since PHP 7.3.0 and cURL 7.21.4
CURL_VERSION_UNIX_SOCKETS (integer)
Available since PHP 7.0.7 and cURL 7.40.0
CURL_VERSION_LIBZ (integer)
CURLVERSION_NOW (integer)
CURLE_OK (integer)
CURLE_UNSUPPORTED_PROTOCOL (integer)
CURLE_FAILED_INIT (integer)
CURLE_URL_MALFORMAT (integer)
CURLE_URL_MALFORMAT_USER (integer)
CURLE_COULDNT_RESOLVE_PROXY (integer)
CURLE_COULDNT_RESOLVE_HOST (integer)
CURLE_COULDNT_CONNECT (integer)
CURLE_FTP_WEIRD_SERVER_REPLY (integer)
CURLE_FTP_ACCESS_DENIED (integer)
CURLE_FTP_USER_PASSWORD_INCORRECT (integer)
CURLE_FTP_WEIRD_PASS_REPLY (integer)
CURLE_FTP_WEIRD_USER_REPLY (integer)
CURLE_FTP_WEIRD_PASV_REPLY (integer)
CURLE_FTP_WEIRD_227_FORMAT (integer)
CURLE_FTP_CANT_GET_HOST (integer)
CURLE_FTP_CANT_RECONNECT (integer)
CURLE_FTP_COULDNT_SET_BINARY (integer)
CURLE_PARTIAL_FILE (integer)
CURLE_FTP_COULDNT_RETR_FILE (integer)
CURLE_FTP_WRITE_ERROR (integer)
CURLE_FTP_QUOTE_ERROR (integer)
CURLE_HTTP_NOT_FOUND (integer)
CURLE_WRITE_ERROR (integer)
CURLE_MALFORMAT_USER (integer)
CURLE_FTP_COULDNT_STOR_FILE (integer)
CURLE_READ_ERROR (integer)
CURLE_OUT_OF_MEMORY (integer)
CURLE_OPERATION_TIMEOUTED (integer)
CURLE_FTP_COULDNT_SET_ASCII (integer)
CURLE_FTP_PORT_FAILED (integer)
CURLE_FTP_COULDNT_USE_REST (integer)
CURLE_FTP_COULDNT_GET_SIZE (integer)
CURLE_HTTP_RANGE_ERROR (integer)
CURLE_HTTP_POST_ERROR (integer)
CURLE_SSL_CONNECT_ERROR (integer)
CURLE_FTP_BAD_DOWNLOAD_RESUME (integer)
CURLE_FILE_COULDNT_READ_FILE (integer)
CURLE_LDAP_CANNOT_BIND (integer)
CURLE_LDAP_SEARCH_FAILED (integer)
CURLE_LIBRARY_NOT_FOUND (integer)
CURLE_FUNCTION_NOT_FOUND (integer)
CURLE_ABORTED_BY_CALLBACK (integer)
CURLE_BAD_FUNCTION_ARGUMENT (integer)
CURLE_BAD_CALLING_ORDER (integer)
CURLE_HTTP_PORT_FAILED (integer)
CURLE_BAD_PASSWORD_ENTERED (integer)
CURLE_TOO_MANY_REDIRECTS (integer)
CURLE_UNKNOWN_TELNET_OPTION (integer)
CURLE_TELNET_OPTION_SYNTAX (integer)
CURLE_OBSOLETE (integer)
CURLE_SSL_PEER_CERTIFICATE (integer)
CURLE_GOT_NOTHING (integer)
CURLE_SSL_ENGINE_NOTFOUND (integer)
CURLE_SSL_ENGINE_SETFAILED (integer)
CURLE_SEND_ERROR (integer)
CURLE_RECV_ERROR (integer)
CURLE_SHARE_IN_USE (integer)
CURLE_SSL_CERTPROBLEM (integer)
CURLE_SSL_CIPHER (integer)
CURLE_SSL_CACERT (integer)
CURLE_BAD_CONTENT_ENCODING (integer)
CURLE_LDAP_INVALID_URL (integer)
CURLE_FILESIZE_EXCEEDED (integer)
CURLE_FTP_SSL_FAILED (integer)
CURLE_SSH (integer)
Available since PHP 5.3.0 and cURL 7.16.1.
CURLFTPAUTH_DEFAULT (integer)
Available since PHP 5.1.0
CURLFTPAUTH_SSL (integer)
Available since PHP 5.1.0
CURLFTPAUTH_TLS (integer)
Available since PHP 5.1.0
CURLPROXY_HTTP (integer)
Available since cURL 7.10.
CURLPROXY_HTTP_1_0 (integer)
Available since PHP 7.0.7 and cURL 7.19.3
CURLPROXY_SOCKS4 (integer)
Available since PHP 5.2.10 and cURL 7.10.
CURLPROXY_SOCKS5 (integer)
Available since cURL 7.10.
CURL_NETRC_OPTIONAL (integer)
CURL_NETRC_IGNORED (integer)
CURL_NETRC_REQUIRED (integer)
CURL_HTTP_VERSION_NONE (integer)
CURL_HTTP_VERSION_1_0 (integer)
CURL_HTTP_VERSION_1_1 (integer)
CURL_HTTP_VERSION_2 (integer)
Available since PHP 7.0.7 and cURL 7.43.0
CURL_HTTP_VERSION_2_0 (integer)
Available since PHP 5.5.24 and 5.6.8 and cURL 7.33.0
CURL_HTTP_VERSION_2TLS (integer)
Available since PHP 7.0.7 and cURL 7.47.0
CURL_HTTP_VERSION_2_PRIOR_KNOWLEDGE (integer)
Available since PHP 7.0.7 and cURL 7.49.0
CURLM_CALL_MULTI_PERFORM (integer)
CURLM_OK (integer)
CURLM_BAD_HANDLE (integer)
CURLM_BAD_EASY_HANDLE (integer)
CURLM_OUT_OF_MEMORY (integer)
CURLM_INTERNAL_ERROR (integer)
CURLMSG_DONE (integer)
CURLOPT_KEYPASSWD (integer)
CURLOPT_SSH_AUTH_TYPES (integer)
CURLOPT_SSH_HOST_PUBLIC_KEY_MD5 (integer)
CURLOPT_SSH_PRIVATE_KEYFILE (integer)
CURLOPT_SSH_PUBLIC_KEYFILE (integer)
CURLOPT_SSL_OPTIONS (integer)
Available since PHP 5.5.0 and cURL 7.25.0
CURLSSLOPT_ALLOW_BEAST (integer)
Available since PHP 5.5.0 and cURL 7.25.0
CURLSSLOPT_NO_REVOKE (integer)
Available since PHP 7.0.7 and cURL 7.44.0
CURLOPT_USERNAME (integer)
Available since PHP 5.5.0 and cURL 7.19.1
CURLOPT_SASL_IR (integer)
Available since PHP 7.0.7 and cURL 7.31.0
CURLOPT_DNS_INTERFACE (integer)
Available since PHP 7.0.7 and cURL 7.33.0
CURLOPT_DNS_LOCAL_IP4 (integer)
Available since PHP 7.0.7 and cURL 7.33.0
CURLOPT_DNS_LOCAL_IP6 (integer)
Available since PHP 7.0.7 and cURL 7.33.0
CURLOPT_XOAUTH2_BEARER (integer)
Available since PHP 7.0.7 and cURL 7.33.0
CURLOPT_LOGIN_OPTIONS (integer)
Available since PHP 7.0.7 and cURL 7.34.0
CURLOPT_EXPECT_100_TIMEOUT_MS (integer)
Available since PHP 7.0.7 and cURL 7.36.0
CURLOPT_SSL_ENABLE_ALPN (integer)
Available since PHP 7.0.7 and cURL 7.36.0
CURLOPT_SSL_ENABLE_NPN (integer)
Available since PHP 7.0.7 and cURL 7.36.0
CURLOPT_PINNEDPUBLICKEY (integer)
Available since PHP 7.0.7 and cURL 7.39.0
CURLOPT_UNIX_SOCKET_PATH (integer)
Available since PHP 7.0.7 and cURL 7.40.0
CURLOPT_SSL_VERIFYSTATUS (integer)
Available since PHP 7.0.7 and cURL 7.41.0
CURLOPT_PATH_AS_IS (integer)
Available since PHP 7.0.7 and cURL 7.42.0
CURLOPT_SSL_FALSESTART (integer)
Available since PHP 7.0.7 and cURL 7.42.0
CURLOPT_PIPEWAIT (integer)
Available since PHP 7.0.7 and cURL 7.43.0
CURLOPT_PROXY_SERVICE_NAME (integer)
Available since PHP 7.0.7 and cURL 7.43.0
CURLOPT_SERVICE_NAME (integer)
Available since PHP 7.0.7 and cURL 7.43.0
CURLOPT_DEFAULT_PROTOCOL (integer)
Available since PHP 7.0.7 and cURL 7.45.0
CURLOPT_STREAM_WEIGHT (integer)
Available since PHP 7.0.7 and cURL 7.46.0
CURLOPT_TFTP_NO_OPTIONS (integer)
Available since PHP 7.0.7 and cURL 7.48.0
CURLOPT_CONNECT_TO (integer)
Available since PHP 7.0.7 and cURL 7.49.0
CURLOPT_TCP_FASTOPEN (integer)
Available since PHP 7.0.7 and cURL 7.49.0
CURLOPT_TCP_KEEPALIVE (integer)
Available since PHP 5.5.0 and cURL 7.25.0
CURLOPT_TCP_KEEPIDLE (integer)
Available since PHP 5.5.0 and cURL 7.25.0
CURLOPT_TCP_KEEPINTVL (integer)
Available since PHP 5.5.0 and cURL 7.25.0
CURLMOPT_PIPELINING (integer)
Available since PHP 5.5.0 and cURL 7.16.0.
CURLMOPT_MAXCONNECTS (integer)
Available since PHP 5.5.0 and cURL 7.16.3.
CURLMOPT_CHUNK_LENGTH_PENALTY_SIZE (integer)
Available since PHP 7.0.7 and cURL 7.30.0
CURLMOPT_CONTENT_LENGTH_PENALTY_SIZE (integer)
Available since PHP 7.0.7 and cURL 7.30.0
CURLMOPT_MAX_HOST_CONNECTIONS (integer)
Available since PHP 7.0.7 and cURL 7.30.0
CURLMOPT_MAX_PIPELINE_LENGTH (integer)
Available since PHP 7.0.7 and cURL 7.30.0
CURLMOPT_MAX_TOTAL_CONNECTIONS (integer)
Available since PHP 7.0.7 and cURL 7.30.0
CURLMOPT_PUSHFUNCTION (integer)
Available since PHP 7.1.0 and cURL 7.44.0
CURLSSH_AUTH_AGENT (integer)
Available since PHP 7.0.7 and cURL 7.28.0
CURLSSH_AUTH_ANY (integer)
CURLSSH_AUTH_DEFAULT (integer)
CURLSSH_AUTH_HOST (integer)
CURLSSH_AUTH_KEYBOARD (integer)
CURLSSH_AUTH_NONE (integer)
CURLSSH_AUTH_PASSWORD (integer)
CURLSSH_AUTH_PUBLICKEY (integer)
CURL_WRAPPERS_ENABLED (integer)
Defined if PHP was configured with --with-curlwrappers. Moved to PECL in PHP 5.5.0.
CURLPAUSE_ALL (integer)
Available since PHP 5.5.0 and cURL 7.18.0.
CURLPAUSE_CONT (integer)
Available since PHP 5.5.0 and cURL 7.18.0.
CURLPAUSE_RECV (integer)
Available since PHP 5.5.0 and cURL 7.18.0.
CURLPAUSE_RECV_CONT (integer)
Available since PHP 5.5.0 and cURL 7.18.0.
CURLPAUSE_SEND (integer)
Available since PHP 5.5.0 and cURL 7.18.0.
CURLPAUSE_SEND_CONT (integer)
Available since PHP 5.5.0 and cURL 7.18.0.
CURLPIPE_NOTHING (integer)
Available since PHP 7.0.0 and cURL 7.43.0.
CURLPIPE_HTTP1 (integer)
Available since PHP 7.0.0 and cURL 7.43.0.
CURLPIPE_MULTIPLEX (integer)
Available since PHP 7.0.0 and cURL 7.43.0.
CURLPROXY_SOCKS4A (integer)
Available since PHP 5.5.23 and PHP 5.6.7 and cURL 7.18.0.
CURLPROXY_SOCKS5_HOSTNAME (integer)
Available since PHP 5.5.23 and PHP 5.6.7 and cURL 7.18.0.
CURLHEADER_SEPARATE (integer)
Available since PHP 7.0.7 and cURL 7.37.0.
CURLHEADER_UNIFIED (integer)
Available since PHP 7.0.7 and cURL 7.37.0.
CURLPROTO_SMB (integer)
Available since PHP 7.0.7 and cURL 7.40.0.
CURLPROTO_SMBS (integer)
Available since PHP 7.0.7 and cURL 7.40.0.
CURLOPT_REQUEST_TARGET (integer)
Available since PHP 7.3.0 and cURL 7.55.0.
CURLAUTH_GSSAPI (integer)
Available since PHP 7.3.0 and cURL 7.54.1
CURLE_WEIRD_SERVER_REPLY (integer)
Available since PHP 7.3.0 and cURL 7.51.0
CURLINFO_CONTENT_LENGTH_DOWNLOAD_T (integer)
Available since PHP 7.3.0 and cURL 7.55.0
CURLINFO_CONTENT_LENGTH_UPLOAD_T (integer)
Available since PHP 7.3.0 and cURL 7.55.0
CURLINFO_HTTP_VERSION (integer)
Available since PHP 7.3.0 and cURL 7.50.0
CURLINFO_PROTOCOL (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLINFO_PROXY_SSL_VERIFYRESULT (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLINFO_SCHEME (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLINFO_SIZE_DOWNLOAD_T (integer)
Available since PHP 7.3.0 and cURL 7.50.0
CURLINFO_SIZE_UPLOAD_T (integer)
Available since PHP 7.3.0 and cURL 7.50.0
CURLINFO_SPEED_DOWNLOAD_T (integer)
Available since PHP 7.3.0 and cURL 7.50.0
CURLINFO_SPEED_UPLOAD_T (integer)
Available since PHP 7.3.0 and cURL 7.50.0
CURL_MAX_READ_SIZE (integer)
Available since PHP 7.3.0 and cURL 7.53.0
CURLOPT_ABSTRACT_UNIX_SOCKET (integer)
Available since PHP 7.3.0 and cURL 7.53.0
CURLOPT_KEEP_SENDING_ON_ERROR (integer)
Available since PHP 7.3.0 and cURL 7.51.0
CURLOPT_PRE_PROXY (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_CAINFO (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_CAPATH (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_CRLFILE (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_KEYPASSWD (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_PINNEDPUBLICKEY (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSLCERT (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSLCERTTYPE (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSL_CIPHER_LIST (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSLKEY (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSLKEYTYPE (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSL_OPTIONS (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSL_VERIFYHOST (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSL_VERIFYPEER (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_SSLVERSION (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_TLSAUTH_PASSWORD (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_TLSAUTH_TYPE (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_PROXY_TLSAUTH_USERNAME (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLOPT_SOCKS5_AUTH (integer)
Available since PHP 7.3.0 and cURL 7.55.0
CURLOPT_SUPPRESS_CONNECT_HEADERS (integer)
Available since PHP 7.3.0 and cURL 7.54.0
CURLPROXY_HTTPS (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURL_SSLVERSION_MAX_DEFAULT (integer)
Available since PHP 7.3.0 and cURL 7.54.0
CURL_SSLVERSION_MAX_NONE (integer)
Available since PHP 7.3.0 and cURL 7.54.0
CURL_SSLVERSION_MAX_TLSv1_0 (integer)
Available since PHP 7.3.0 and cURL 7.54.0
CURL_SSLVERSION_MAX_TLSv1_1 (integer)
Available since PHP 7.3.0 and cURL 7.54.0
CURL_SSLVERSION_MAX_TLSv1_2 (integer)
Available since PHP 7.3.0 and cURL 7.54.0
CURL_SSLVERSION_MAX_TLSv1_3 (integer)
Available since PHP 7.3.0 and cURL 7.54.0
CURL_SSLVERSION_TLSv1_3 (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURL_VERSION_HTTPS_PROXY (integer)
Available since PHP 7.3.0 and cURL 7.52.0
CURLAUTH_BEARER (integer)
Available since PHP 7.3.0 and cURL 7.61.0.
CURLINFO_APPCONNECT_TIME_T (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLINFO_CONNECT_TIME_T (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLINFO_FILETIME_T (integer)
Available since PHP 7.3.0 and cURL 7.59.0
CURLINFO_NAMELOOKUP_TIME_T (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLINFO_PRETRANSFER_TIME_T (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLINFO_REDIRECT_TIME_T (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLINFO_STARTTRANSFER_TIME_T (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLINFO_TOTAL_TIME_T (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURL_LOCK_DATA_CONNECT (integer)
Available since PHP 7.3.0 and cURL 7.10.0
CURL_LOCK_DATA_PSL (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLOPT_DISALLOW_USERNAME_IN_URL (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLOPT_DNS_SHUFFLE_ADDRESSES (integer)
Available since PHP 7.3.0 and cURL 7.60.0
CURLOPT_HAPPY_EYEBALLS_TIMEOUT_MS (integer)
Available since PHP 7.3.0 and cURL 7.59.0
CURLOPT_HAPROXYPROTOCOL (integer)
Available since PHP 7.3.0 and cURL 7.60.0
CURLOPT_PROXY_TLS13_CIPHERS (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLOPT_SSH_COMPRESSION (integer)
Available since PHP 7.3.0 and cURL 7.56.0
CURLOPT_TIMEVALUE_LARGE (integer)
Available since PHP 7.3.0 and cURL 7.59.0
CURLOPT_TLS13_CIPHERS (integer)
Available since PHP 7.3.0 and cURL 7.61.0
CURLSSH_AUTH_GSSAPI (integer)
Available since PHP 7.3.0 and cURL 7.58.0
CURLOPT_HTTP09_ALLOWED (integer)
Available since PHP 7.3.15 and 7.4.3, respectively, and cURL 7.64.0


  • ? 预定义常量
  • curl 基础例子 ?
  • PHP Manual
  • cURL
  • 范例

范例

Table of Contents

  • curl 基础例子


curl 基础例子

只要你编译完的PHP设置了支持 cURL 扩展，你就可以开始使用cURL函数了。使用 cURL 函数的基本思想是先使用 curl_init() 初始化 cURL会话，接着可以通过 curl_setopt() 设置需要的全部选项，然后使用 curl_exec() 来执行会话，当执行完会话后使用 curl_close() 关闭会话。这是一个使用 cURL 函数获取 example.com 主页保存到文件的例子：

Example #1 使用 PHP cURL 模块获取 example.com 的主页

<?php

$ch = curl_init("http://www.example.com/");
$fp = fopen("example_homepage.txt", "w");

curl_setopt($ch, CURLOPT_FILE, $fp);
curl_setopt($ch, CURLOPT_HEADER, 0);

curl_exec($ch);
if(curl_error($ch)) {
    fwrite($fp, curl_error($ch));
}
curl_close($ch);
fclose($fp);
?>


cURL 函数

Table of Contents

  • curl_close — 关闭 cURL 会话
  • curl_copy_handle — 复制一个cURL句柄和它的所有选项
  • curl_errno — 返回最后一次的错误代码
  • curl_error — 返回当前会话最后一次错误的字符串
  • curl_escape — 使用 URL 编码给定的字符串
  • curl_exec — 执行 cURL 会话
  • curl_file_create — 创建一个 CURLFile 对象
  • curl_getinfo — 获取一个cURL连接资源句柄的信息
  • curl_init — 初始化 cURL 会话
  • curl_multi_add_handle — 向curl批处理会话中添加单独的curl句柄
  • curl_multi_close — 关闭一组cURL句柄
  • curl_multi_errno — 返回上一次 curl 批处理的错误码
  • curl_multi_exec — 运行当前 cURL 句柄的子连接
  • curl_multi_getcontent — 如果设置了CURLOPT_RETURNTRANSFER，则返回获取的输出的文本流
  • curl_multi_info_read — 获取当前解析的cURL的相关传输信息
  • curl_multi_init — 返回一个新cURL批处理句柄
  • curl_multi_remove_handle — 移除cURL批处理句柄资源中的某个句柄资源
  • curl_multi_select — 等待所有cURL批处理中的活动连接
  • curl_multi_setopt — 为 cURL 并行处理设置一个选项
  • curl_multi_strerror — 返回字符串描述的错误代码
  • curl_pause — 暂停和取消暂停一个连接。
  • curl_reset — 重置一个 libcurl 会话句柄的所有的选项
  • curl_setopt_array — 为 cURL 传输会话批量设置选项
  • curl_setopt — 设置 cURL 传输选项
  • curl_share_close — 关闭 cURL 共享句柄
  • curl_share_errno — 返回共享 curl 句柄的最后一次错误号
  • curl_share_init — 初始化一个 cURL 共享句柄。
  • curl_share_setopt — 为 cURL 共享句柄设置选项。
  • curl_share_strerror — 返回错误号对应的错误消息
  • curl_strerror — 返回错误代码的字符串描述
  • curl_unescape — 解码给定的 URL 编码的字符串
  • curl_version — 获取 cURL 版本信息


关闭 cURL 会话

  • ? cURL 函数
  • curl_copy_handle ?
  • PHP Manual
  • cURL 函数
  • 关闭 cURL 会话

curl_close

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_close — 关闭 cURL 会话

说明

curl_close ( resource $ch ) : void

关闭 cURL 会话并且释放所有资源。cURL 句柄 ch 也会被删除。

参数

handle

由 curl_init() 返回的 cURL 句柄。

返回值

没有返回值。

范例

Example #1 初始化新的 cURL 会话，并获取一张网页

<?php
// 创建一个新cURL资源
$ch = curl_init();

// 设置URL和相应的选项
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// 抓取URL并把它传递给浏览器
curl_exec($ch);

// 关闭cURL资源，并且释放系统资源
curl_close($ch);
?>

参见

  • curl_init() - 初始化 cURL 会话
  • curl_multi_close() - 关闭一组cURL句柄


复制一个cURL句柄和它的所有选项

  • ? curl_close
  • curl_errno ?
  • PHP Manual
  • cURL 函数
  • 复制一个cURL句柄和它的所有选项

curl_copy_handle

(PHP 5, PHP 7, PHP 8)

curl_copy_handle — 复制一个cURL句柄和它的所有选项

说明

curl_copy_handle ( resource $ch ) : resource

复制一个cURL句柄并保持相同的选项。

参数

handle

由 curl_init() 返回的 cURL 句柄。

返回值

返回一个新的cURL句柄。

范例

Example #1 复制一个cURL句柄

<?php
// 创建一个新的cURL资源
$ch = curl_init();

// 设置URL和相应的选项
curl_setopt($ch, CURLOPT_URL, 'http://www.example.com/');
curl_setopt($ch, CURLOPT_HEADER, 0);

// 复制句柄
$ch2 = curl_copy_handle($ch);

// 抓取URL (http://www.example.com/) 并把它传递给浏览器
curl_exec($ch2);

// 关闭cURL资源，并且释放系统资源
curl_close($ch2);
curl_close($ch);
?>


返回最后一次的错误代码

  • ? curl_copy_handle
  • curl_error ?
  • PHP Manual
  • cURL 函数
  • 返回最后一次的错误代码

curl_errno

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

curl_errno — 返回最后一次的错误代码

说明

curl_errno ( resource $ch ) : int

返回最后一次 cURL 操作的错误代码。

参数

handle

由 curl_init() 返回的 cURL 句柄。

返回值

返回错误代码或在没有错误发生时返回 0 (零)。

范例

Example #1 curl_errno() 例子

<?php
// 创建 cURL 句柄，指向不存在的位置
$ch = curl_init('http://404.php.net/');

// 执行
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_exec($ch);

// 检查是否有错误发生
if(curl_errno($ch))
{
    echo 'Curl error: ' . curl_error($ch);
}

// 关闭句柄
curl_close($ch);
?>

参见

  • curl_error() - 返回当前会话最后一次错误的字符串
  • » Curl 错误代码


返回当前会话最后一次错误的字符串

  • ? curl_errno
  • curl_escape ?
  • PHP Manual
  • cURL 函数
  • 返回当前会话最后一次错误的字符串

curl_error

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

curl_error — 返回当前会话最后一次错误的字符串

说明

curl_error ( resource $ch ) : string

返回最近一次 cURL 操作的文本错误详情。

参数

handle

由 curl_init() 返回的 cURL 句柄。

返回值

返回错误信息，或者如果没有任何错误发生就返回 '' (空字符串)。

范例

Example #1 curl_error() 例子

<?php
// 创建 cURL 句柄，指向一个不存在的位置
$ch = curl_init('http://404.php.net/');
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);

if(curl_exec($ch) === false)
{
    echo 'Curl error: ' . curl_error($ch);
}
else
{
    echo '操作完成没有任何错误';
}

// 关闭句柄
curl_close($ch);
?>

参见

  • curl_errno() - 返回最后一次的错误代码
  • » Curl 错误代码


使用 URL 编码给定的字符串

  • ? curl_error
  • curl_exec ?
  • PHP Manual
  • cURL 函数
  • 使用 URL 编码给定的字符串

curl_escape

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_escape — 使用 URL 编码给定的字符串

说明

curl_escape ( resource $ch , string $str ) : string

该函数使用 URL 根据» RFC 3986编码给定的字符串。

参数

handle

由 curl_init() 返回的 cURL 句柄。

str

需要编码的字符串

返回值

返回编码后的字符串 或者在失败时返回 false。

范例

Example #1 curl_escape() 示例

<?php
// 创建一个 curl 句柄
$ch = curl_init();

// 把编码后的字符串当做一个 GET 参数
$location = curl_escape($ch, 'Hofbr?uhaus / München');
// 结果： Hofbr%C3%A4uhaus%20%2F%20M%C3%BCnchen

// 用编码好的字符串组装一个 URL
$url = "http://example.com/add_location.php?location={$location}";
// 结果： http://example.com/add_location.php?location=Hofbr%C3%A4uhaus%20%2F%20M%C3%BCnchen

// 发送 HTTP 请求并关闭句柄
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_exec($ch);
curl_close($ch);
?>

参见

  • curl_unescape() - 解码给定的 URL 编码的字符串
  • urlencode() - 编码 URL 字符串
  • rawurlencode() - 按照 RFC 3986 对 URL 进行编码
  • » RFC 3986


执行 cURL 会话

  • ? curl_escape
  • curl_file_create ?
  • PHP Manual
  • cURL 函数
  • 执行 cURL 会话

curl_exec

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_exec — 执行 cURL 会话

说明

curl_exec ( resource $ch ) : mixed

执行给定的 cURL 会话。

这个函数应该在初始化一个 cURL 会话并且全部的选项都被设置后被调用。

参数

handle

由 curl_init() 返回的 cURL 句柄。

返回值

成功时返回 true， 或者在失败时返回 false。 然而，如果 设置了 CURLOPT_RETURNTRANSFER 选项，函数执行成功时会返回执行的结果，失败时返回 false 。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

Note:

注意：响应代码是错误码时（例如404 Not found）也不会被当作失败。这种情况可以使用 curl_getinfo() 来检查。

范例

Example #1 获取网页

<?php
// 创建新的 cURL 资源
$ch = curl_init();

// 设置 URL 和相应的选项
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// 抓取 URL 并把它传递给浏览器
curl_exec($ch);

// 关闭 cURL 资源，并且释放系统资源
curl_close($ch);
?>

参见

  • curl_multi_exec() - 运行当前 cURL 句柄的子连接


创建一个 CURLFile 对象

  • ? curl_exec
  • curl_getinfo ?
  • PHP Manual
  • cURL 函数
  • 创建一个 CURLFile 对象

curl_file_create

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_file_create — 创建一个 CURLFile 对象

说明

此函数是该函数的别名： CURLFile::__construct()


获取一个cURL连接资源句柄的信息

  • ? curl_file_create
  • curl_init ?
  • PHP Manual
  • cURL 函数
  • 获取一个cURL连接资源句柄的信息

curl_getinfo

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

curl_getinfo — 获取一个cURL连接资源句柄的信息

说明

curl_getinfo ( resource $ch , int $opt = 0 ) : mixed

获取最后一次传输的相关信息。

参数

handle

由 curl_init() 返回的 cURL 句柄。

opt

这个参数可能是以下常量之一:

  • CURLINFO_EFFECTIVE_URL - 最后一个有效的URL地址
  • CURLINFO_HTTP_CODE - 最后一个收到的HTTP代码
  • CURLINFO_FILETIME - 远程获取文档的时间，如果无法获取，则返回值为"-1"
  • CURLINFO_TOTAL_TIME - 最后一次传输所消耗的时间
  • CURLINFO_NAMELOOKUP_TIME - 名称解析所消耗的时间
  • CURLINFO_CONNECT_TIME - 建立连接所消耗的时间
  • CURLINFO_PRETRANSFER_TIME - 从建立连接到准备传输所使用的时间
  • CURLINFO_STARTTRANSFER_TIME - 从建立连接到传输开始所使用的时间
  • CURLINFO_REDIRECT_TIME - 在事务传输开始前重定向所使用的时间
  • CURLINFO_SIZE_UPLOAD - 以字节为单位返回上传数据量的总值
  • CURLINFO_SIZE_DOWNLOAD - 以字节为单位返回下载数据量的总值
  • CURLINFO_SPEED_DOWNLOAD - 平均下载速度
  • CURLINFO_SPEED_UPLOAD - 平均上传速度
  • CURLINFO_HEADER_SIZE - header部分的大小
  • CURLINFO_HEADER_OUT - 发送请求的字符串
  • CURLINFO_REQUEST_SIZE - 在HTTP请求中有问题的请求的大小
  • CURLINFO_SSL_VERIFYRESULT - 通过设置CURLOPT_SSL_VERIFYPEER返回的SSL证书验证请求的结果
  • CURLINFO_CONTENT_LENGTH_DOWNLOAD - 从Content-Length: field中读取的下载内容长度
  • CURLINFO_CONTENT_LENGTH_UPLOAD - 上传内容大小的说明
  • CURLINFO_CONTENT_TYPE - 下载内容的Content-Type:值，NULL表示服务器没有发送有效的Content-Type: header

返回值

如果 opt 被设置，以字符串形式返回它的值。否则，返回返回一个包含下列元素的关联数组(它们分别对应于 opt):

  • "url"
  • "content_type"
  • "http_code"
  • "header_size"
  • "request_size"
  • "filetime"
  • "ssl_verify_result"
  • "redirect_count"
  • "total_time"
  • "namelookup_time"
  • "connect_time"
  • "pretransfer_time"
  • "size_upload"
  • "size_download"
  • "speed_download"
  • "speed_upload"
  • "download_content_length"
  • "upload_content_length"
  • "starttransfer_time"
  • "redirect_time"

更新日志

版本 | 说明
5.1.3 | 引入CURLINFO_HEADER_OUT.

范例

Example #1 curl_getinfo() example

<?php
// 创建一个cURL句柄
$ch = curl_init('http://www.yahoo.com/');

// 执行
curl_exec($ch);

// 检查是否有错误发生
if(!curl_errno($ch))
{
 $info = curl_getinfo($ch);

 echo 'Took ' . $info['total_time'] . ' seconds to send a request to ' . $info['url'];
}

// Close handle
curl_close($ch);
?>

注释

Note:

Information gathered by this function is kept if the handle is re-used. This means that unless a statistic is overridden internally by this function, the previous info is returned.


初始化 cURL 会话

  • ? curl_getinfo
  • curl_multi_add_handle ?
  • PHP Manual
  • cURL 函数
  • 初始化 cURL 会话

curl_init

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_init — 初始化 cURL 会话

说明

curl_init ( string $url = null ) : resource

初始化新的会话，返回 cURL 句柄，供curl_setopt()、 curl_exec() 和 curl_close() 函数使用。

参数

url

如果提供了该参数，CURLOPT_URL 选项将会被设置成这个值。你也可以使用curl_setopt()函数手动地设置这个值。

Note:

如果设置了 open_basedir，file 协议会被 cURL 禁用。

返回值

如果成功，返回 cURL 句柄，出错返回 false。

范例

Example #1 初始化新的 cURL 会话并获取一个网页

<?php
// 创建一个新cURL资源
$ch = curl_init();

// 设置URL和相应的选项
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// 抓取URL并把它传递给浏览器
curl_exec($ch);

// 关闭cURL资源，并且释放系统资源
curl_close($ch);
?>

参见

  • curl_close() - 关闭 cURL 会话
  • curl_multi_init() - 返回一个新cURL批处理句柄


向curl批处理会话中添加单独的curl句柄

  • ? curl_init
  • curl_multi_close ?
  • PHP Manual
  • cURL 函数
  • 向curl批处理会话中添加单独的curl句柄

curl_multi_add_handle

(PHP 5, PHP 7, PHP 8)

curl_multi_add_handle — 向curl批处理会话中添加单独的curl句柄

说明

curl_multi_add_handle ( resource $mh , resource $ch ) : int

增加 ch 句柄到批处理会话mh

参数

multi_handle

由 curl_multi_init() 返回的 cURL 多个句柄。

handle

由 curl_init() 返回的 cURL 句柄。

返回值

成功时返回0，失败时返回CURLM_XXX之一的错误码。

范例

Example #1 curl_multi_add_handle() example

这个范例将会创建2个cURL句柄，把它们加到批处理句柄，然后并行地运行它们。

<?php
// 创建一对cURL资源
$ch1 = curl_init();
$ch2 = curl_init();

// 设置URL和相应的选项
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

// 创建批处理cURL句柄
$mh = curl_multi_init();

// 增加2个句柄
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$running=null;
// 执行批处理句柄
do {
    curl_multi_exec($mh,$running);
} while($running > 0);

// 关闭全部句柄
curl_multi_remove_handle($mh, $ch1);
curl_multi_remove_handle($mh, $ch2);
curl_multi_close($mh);
?>

参见

  • curl_multi_remove_handle() - 移除cURL批处理句柄资源中的某个句柄资源
  • curl_multi_init() - 返回一个新cURL批处理句柄
  • curl_init() - 初始化 cURL 会话


关闭一组cURL句柄

  • ? curl_multi_add_handle
  • curl_multi_errno ?
  • PHP Manual
  • cURL 函数
  • 关闭一组cURL句柄

curl_multi_close

(PHP 5, PHP 7, PHP 8)

curl_multi_close — 关闭一组cURL句柄

说明

curl_multi_close ( resource $mh ) : void

关闭一组cURL句柄。

参数

multi_handle

由 curl_multi_init() 返回的 cURL 多个句柄。

返回值

没有返回值。

范例

Example #1 curl_multi_close() example

这个范例将会创建2个cURL句柄，把它们加到批处理句柄，然后并行地运行它们。

<?php
// 创建一对cURL资源
$ch1 = curl_init();
$ch2 = curl_init();

// 设置URL和相应的选项
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

// 创建批处理cURL句柄
$mh = curl_multi_init();

// 增加2个句柄
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$running=null;
// 执行批处理句柄
do {
    curl_multi_exec($mh,$running);
} while ($running > 0);

// 关闭全部句柄
curl_multi_remove_handle($mh, $ch1);
curl_multi_remove_handle($mh, $ch2);
curl_multi_close($mh);

?>

参见

  • curl_multi_init() - 返回一个新cURL批处理句柄
  • curl_close() - 关闭 cURL 会话


返回上一次 curl 批处理的错误码

  • ? curl_multi_close
  • curl_multi_exec ?
  • PHP Manual
  • cURL 函数
  • 返回上一次 curl 批处理的错误码

curl_multi_errno

(PHP 7 >= 7.1.0, PHP 8)

curl_multi_errno — 返回上一次 curl 批处理的错误码

说明

curl_multi_errno ( resource $mh ) : int

返回一个整型数字，为上次 curl 批处理错误码。

参数

multi_handle

由 curl_multi_init() 返回的 cURL 多个句柄。

返回值

返回整型数字，包含上次 curl 批处理的错误码， 或者在失败时返回 false

参见

  • curl_errno() - 返回最后一次的错误代码


运行当前 cURL 句柄的子连接

  • ? curl_multi_errno
  • curl_multi_getcontent ?
  • PHP Manual
  • cURL 函数
  • 运行当前 cURL 句柄的子连接

curl_multi_exec

(PHP 5, PHP 7, PHP 8)

curl_multi_exec — 运行当前 cURL 句柄的子连接

说明

curl_multi_exec ( resource $mh , int &$still_running ) : int

处理在栈中的每一个句柄。无论该句柄需要读取或写入数据都可调用此方法。

参数

multi_handle

由 curl_multi_init() 返回的 cURL 多个句柄。

still_running

一个用来判断操作是否仍在执行的标识的引用。

返回值

一个定义于 cURL 预定义常量中的 cURL 代码。

Note:

该函数仅返回关于整个批处理栈相关的错误。即使返回 CURLM_OK 时单个传输仍可能有问题。

范例

Example #1 curl_multi_exec() example

这个范例将会创建 2 个 cURL 句柄，把它们加到批处理句柄，然后并行地运行它们。

<?php
// 创建一对cURL资源
$ch1 = curl_init();
$ch2 = curl_init();

// 设置URL和相应的选项
curl_setopt($ch1, CURLOPT_URL, "http://lxr.php.net/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

// 创建批处理cURL句柄
$mh = curl_multi_init();

// 增加2个句柄
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$active = null;
// 执行批处理句柄
do {
    $mrc = curl_multi_exec($mh, $active);
} while ($mrc == CURLM_CALL_MULTI_PERFORM);

while ($active && $mrc == CURLM_OK) {
    if (curl_multi_select($mh) != -1) {
        do {
            $mrc = curl_multi_exec($mh, $active);
        } while ($mrc == CURLM_CALL_MULTI_PERFORM);
    }
}

// 关闭全部句柄
curl_multi_remove_handle($mh, $ch1);
curl_multi_remove_handle($mh, $ch2);
curl_multi_close($mh);

?>

参见

  • curl_multi_init() - 返回一个新cURL批处理句柄
  • curl_multi_select() - 等待所有cURL批处理中的活动连接
  • curl_exec() - 执行 cURL 会话


如果设置了CURLOPT_RETURNTRANSFER，则返回获取的输出的文本流

  • ? curl_multi_exec
  • curl_multi_info_read ?
  • PHP Manual
  • cURL 函数
  • 如果设置了CURLOPT_RETURNTRANSFER，则返回获取的输出的文本流

curl_multi_getcontent

(PHP 5, PHP 7, PHP 8)

curl_multi_getcontent — 如果设置了CURLOPT_RETURNTRANSFER，则返回获取的输出的文本流

说明

curl_multi_getcontent ( resource $ch ) : string

如果CURLOPT_RETURNTRANSFER作为一个选项被设置到一个具体的句柄，那么这个函数将会以字符串的形式返回那个cURL句柄获取的内容。

参数

handle

由 curl_init() 返回的 cURL 句柄。

返回值

如果设置了CURLOPT_RETURNTRANSFER，则返回获取的输出的文本流。

参见

  • curl_multi_init() - 返回一个新cURL批处理句柄


获取当前解析的cURL的相关传输信息

  • ? curl_multi_getcontent
  • curl_multi_init ?
  • PHP Manual
  • cURL 函数
  • 获取当前解析的cURL的相关传输信息

curl_multi_info_read

(PHP 5, PHP 7, PHP 8)

curl_multi_info_read — 获取当前解析的cURL的相关传输信息

说明

curl_multi_info_read ( resource $mh , int &$msgs_in_queue = null ) : array

查询批处理句柄是否单独的传输线程中有消息或信息返回。消息可能包含诸如从单独的传输线程返回的错误码或者只是传输线程有没有完成之类的报告。

重复调用这个函数，它每次都会返回一个新的结果，直到这时没有更多信息返回时，false 被当作一个信号返回。通过msgs_in_queue返回的整数指出将会包含当这次函数被调用后，还剩余的消息数。

Warning

返回的资源指向的数据调用curl_multi_remove_handle()后将不会存在。

参数

multi_handle

由 curl_multi_init() 返回的 cURL 多个句柄。

msgs_in_queue

仍在队列中的消息数量。

返回值

成功时返回相关信息的数组，失败时返回false。

返回数组的内容
Key: | Value:
msg | CURLMSG_DONE常量。其他返回值当前不可用。
result | CURLE_*常量之一。如果一切操作没有问题，将会返回CURLE_OK常量。
handle | cURL资源类型表明它有关的句柄。

范例

Example #1 一个curl_multi_info_read()范例

<?php

$urls = array(
   "http://www.cnn.com/",
   "http://www.bbc.co.uk/",
   "http://www.yahoo.com/"
);

$mh = curl_multi_init();

foreach ($urls as $i => $url) {
    $conn[$i] = curl_init($url);
    curl_setopt($conn[$i], CURLOPT_RETURNTRANSFER, 1);
    curl_multi_add_handle($mh, $conn[$i]);
}

do {
    $status = curl_multi_exec($mh, $active);
    $info = curl_multi_info_read($mh);
    if (false !== $info) {
        var_dump($info);
    }
} while ($status === CURLM_CALL_MULTI_PERFORM || $active);

foreach ($urls as $i => $url) {
    $res[$i] = curl_multi_getcontent($conn[$i]);
    curl_close($conn[$i]);
}

var_dump(curl_multi_info_read($mh));

?>

以上例程的输出类似于：

array(3) {
  ["msg"]=>
  int(1)
  ["result"]=>
  int(0)
  ["handle"]=>
  resource(5) of type (curl)
}
array(3) {
  ["msg"]=>
  int(1)
  ["result"]=>
  int(0)
  ["handle"]=>
  resource(7) of type (curl)
}
array(3) {
  ["msg"]=>
  int(1)
  ["result"]=>
  int(0)
  ["handle"]=>
  resource(6) of type (curl)
}
bool(false)

更新日志

版本 | 说明
5.2.0 | msgs_in_queue被加入。

参见

  • curl_multi_init() - 返回一个新cURL批处理句柄


返回一个新cURL批处理句柄

  • ? curl_multi_info_read
  • curl_multi_remove_handle ?
  • PHP Manual
  • cURL 函数
  • 返回一个新cURL批处理句柄

curl_multi_init

(PHP 5, PHP 7, PHP 8)

curl_multi_init — 返回一个新cURL批处理句柄

说明

curl_multi_init ( ) : resource

允许并行地处理批处理cURL句柄。

参数

此函数没有参数。

返回值

成功时返回一个cURL批处理句柄，失败时返回false。

范例

Example #1 curl_multi_init() example

这个范例将会创建2个cURL句柄，把它们加到批处理句柄，然后并行地运行它们。

<?php
// 创建一对cURL资源
$ch1 = curl_init();
$ch2 = curl_init();

// 设置URL和相应的选项
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

// 创建批处理cURL句柄
$mh = curl_multi_init();

// 增加2个句柄
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$running=null;
// 执行批处理句柄
do {
    usleep(10000);
    curl_multi_exec($mh,$running);
} while ($running > 0);

// 关闭全部句柄
curl_multi_remove_handle($mh, $ch1);
curl_multi_remove_handle($mh, $ch2);
curl_multi_close($mh);

?>

参见

  • curl_init() - 初始化 cURL 会话
  • curl_multi_close() - 关闭一组cURL句柄


移除cURL批处理句柄资源中的某个句柄资源

  • ? curl_multi_init
  • curl_multi_select ?
  • PHP Manual
  • cURL 函数
  • 移除cURL批处理句柄资源中的某个句柄资源

curl_multi_remove_handle

(PHP 5, PHP 7, PHP 8)

curl_multi_remove_handle — 移除cURL批处理句柄资源中的某个句柄资源

说明

curl_multi_remove_handle ( resource $mh , resource $ch ) : int

从给定的批处理句柄mh中移除ch句柄。当ch句柄被移除以后，仍然可以合法地用curl_exec()执行这个句柄。如果要移除的句柄正在被使用，则这个句柄涉及的所有传输任务会被中止。

参数

multi_handle

由 curl_multi_init() 返回的 cURL 多个句柄。

handle

由 curl_init() 返回的 cURL 句柄。

返回值

成功时返回0，失败时返回CURLM_XXX中的一个。

参见

  • curl_init() - 初始化 cURL 会话
  • curl_multi_init() - 返回一个新cURL批处理句柄
  • curl_multi_add_handle() - 向curl批处理会话中添加单独的curl句柄


等待所有cURL批处理中的活动连接

  • ? curl_multi_remove_handle
  • curl_multi_setopt ?
  • PHP Manual
  • cURL 函数
  • 等待所有cURL批处理中的活动连接

curl_multi_select

(PHP 5, PHP 7, PHP 8)

curl_multi_select — 等待所有cURL批处理中的活动连接

说明

curl_multi_select ( resource $mh , float $timeout = 1.0 ) : int

阻塞直到cURL批处理连接中有活动连接。

参数

multi_handle

由 curl_multi_init() 返回的 cURL 多个句柄。

timeout

以秒为单位，等待响应的时间。

返回值

成功时返回描述符集合中描述符的数量。失败时，select失败时返回-1，否则返回超时(从底层的select系统调用).

参见

  • curl_multi_init() - 返回一个新cURL批处理句柄


为 cURL 并行处理设置一个选项

  • ? curl_multi_select
  • curl_multi_strerror ?
  • PHP Manual
  • cURL 函数
  • 为 cURL 并行处理设置一个选项

curl_multi_setopt

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_multi_setopt — 为 cURL 并行处理设置一个选项

说明

curl_multi_setopt ( resource $mh , int $option , mixed $value ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

mh

option

常量 CURLMOPT_* 之一。

value

将要设置给 option 的值。

在 option 参数为下列值时 value 需要为 int 类型：

Option 的值 | 将 value 设为
CURLMOPT_PIPELINING | 传入 1 来启用或 0 来禁用。 在并行处理时启用管道模式 将会尽可能地使用管线化的 HTTP （译注：HTTP长连接）来 传输，这意味着如果你提交第二个请求，这个请求将会使用 已经存在的链接，第二个请求将会被送入同一个链接的"管 道"中。
CURLMOPT_MAXCONNECTS | 传入一个数字来指定 libcurl 可以同时缓存的活跃链接的数量。默认值为 10。当缓存写满时， lincurl 将关闭较早创建的链接来创建新的链接。

返回值

成功时返回 true， 或者在失败时返回 false。


返回字符串描述的错误代码

  • ? curl_multi_setopt
  • curl_pause ?
  • PHP Manual
  • cURL 函数
  • 返回字符串描述的错误代码

curl_multi_strerror

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_multi_strerror — 返回字符串描述的错误代码

说明

curl_multi_strerror ( int $errornum ) : string

返回一个用以描述所给 CURLM 错误代码所对应的错误信息。

参数

errornum

» CURLM 错误代码中的常量之一。

返回值

返回可用错误代码所对应的错误信息，否则返回 null 。

范例

Example #1 curl_multi_strerror() 函数的范例：

<?php
// Create cURL handles
$ch1 = curl_init("http://example.com"/);
$ch2 = curl_init("http://php.net/");

// Create a cURL multi handle
$mh = curl_multi_init();

// Add the handles to the multi handle
curl_multi_add_handle($mh, $ch1);
curl_multi_add_handle($mh, $ch2);

// Execute the multi handle
do {
    $status = curl_multi_exec($mh, $active);
    // Check for errors
    if($status > 0) {
        // Display error message
        echo "ERROR!\n " . curl_multi_strerror($status);
    }
} while ($status === CURLM_CALL_MULTI_PERFORM || $active);
?>

参见

  • curl_strerror() - 返回错误代码的字符串描述
  • » cURL error codes


暂停和取消暂停一个连接。

  • ? curl_multi_strerror
  • curl_reset ?
  • PHP Manual
  • cURL 函数
  • 暂停和取消暂停一个连接。

curl_pause

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_pause — 暂停和取消暂停一个连接。

说明

curl_pause ( resource $ch , int $bitmask ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

handle

由 curl_init() 返回的 cURL 句柄。

bitmask

CURLPAUSE_* 常量之一。

返回值

返回一个错误代码 (如果没有错误则返回CURLE_OK常量)。


重置一个 libcurl 会话句柄的所有的选项

  • ? curl_pause
  • curl_setopt_array ?
  • PHP Manual
  • cURL 函数
  • 重置一个 libcurl 会话句柄的所有的选项

curl_reset

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_reset — 重置一个 libcurl 会话句柄的所有的选项

说明

curl_reset ( resource $ch ) : void

该函数将给定的 cURL 句柄所有选项重新设置为默认值。

参数

handle

由 curl_init() 返回的 cURL 句柄。

返回值

没有返回值。

范例

Example #1 curl_reset() 示例

<?php
// 创建一个url 句柄
$ch = curl_init();

// 设置 CURLOPT_USERAGENT 选项
curl_setopt($ch, CURLOPT_USERAGENT, "My test user-agent");

// 重置所有的预先设置的选项
curl_reset($ch);

// 发送 HTTP 请求
curl_setopt($ch, CURLOPT_URL, 'http://example.com/');
curl_exec($ch); // 预先设置的 user-agent 不会被发送，它已经被 curl_reset 重置掉了

// 关闭句柄
curl_close($ch);
?>

注释

Note:

curl_reset() also resets the URL given as the curl_init() parameter.

参见

  • curl_setopt() - 设置 cURL 传输选项


为 cURL 传输会话批量设置选项

  • ? curl_reset
  • curl_setopt ?
  • PHP Manual
  • cURL 函数
  • 为 cURL 传输会话批量设置选项

curl_setopt_array

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

curl_setopt_array — 为 cURL 传输会话批量设置选项

说明

curl_setopt_array ( resource $ch , array $options ) : bool

为 cURL 传输会话批量设置选项。这个函数对于需要设置大量的 cURL 选项是非常有用的，不需要重复地调用 curl_setopt()。

参数

handle

由 curl_init() 返回的 cURL 句柄。

options

一个 array 用来确定将被设置的选项及其值。数组的键值必须是一个有效的curl_setopt()常量或者是它们对等的整数值。

返回值

如果全部的选项都被成功设置，返回true。如果一个选项不能被成功设置，马上返回false，忽略其后的任何在options数组中的选项。

范例

Example #1 初始化新的 cURL 会话并抓取 web 页面

<?php
// 创建一个新 cURL 资源
$ch = curl_init();

// 设置 URL 和相应的选项
$options = array(CURLOPT_URL => 'http://www.example.com/',
                 CURLOPT_HEADER => false
                );

curl_setopt_array($ch, $options);

// 抓取 URL 并把它传递给浏览器
curl_exec($ch);

// 关闭 cURL 资源，并且释放系统资源
curl_close($ch);
?>

早于PHP 5.1.3这个函数可以做如下模拟：

Example #2 我们对curl_setopt_array()的等价实现

<?php
if (!function_exists('curl_setopt_array')) {
   function curl_setopt_array(&$ch, $curl_options)
   {
       foreach ($curl_options as $option => $value) {
           if (!curl_setopt($ch, $option, $value)) {
               return false;
           }
       }
       return true;
   }
}
?>

注释

Note:

就curl_setopt()来说，传递一个数组到CURLOPT_POST将会把数据以multipart/form-data的方式编码，然而传递一个URL-encoded字符串将会以application/x-www-form-urlencoded的方式对数据进行编码。

参见

  • curl_setopt() - 设置 cURL 传输选项


设置 cURL 传输选项

  • ? curl_setopt_array
  • curl_share_close ?
  • PHP Manual
  • cURL 函数
  • 设置 cURL 传输选项

curl_setopt

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_setopt — 设置 cURL 传输选项

说明

curl_setopt ( resource $ch , int $option , mixed $value ) : bool

为 cURL 会话句柄设置选项。

参数

handle

由 curl_init() 返回的 cURL 句柄。

option

需要设置的CURLOPT_XXX选项。

value

将设置在option选项上的值。

以下 option 参数的 value应该被设置成 bool 类型：

选项 | 将 value 设置为 | 备注
CURLOPT_AUTOREFERER | true 时将根据 Location: 重定向时，自动设置 header 中的Referer:信息。
CURLOPT_BINARYTRANSFER | 设为 true ，将在启用 CURLOPT_RETURNTRANSFER 时，返回原生的（Raw）输出。 | 从 PHP 5.1.3 开始，此选项不再有效果：使用 CURLOPT_RETURNTRANSFER 后总是会返回原生的（Raw）内容。
CURLOPT_COOKIESESSION | 设为 true 时将开启新的一次 cookie 会话。它将强制 libcurl 忽略之前会话时存的其他 cookie。 libcurl 在默认状况下无论是否为会话，都会储存、加载所有 cookie。会话 cookie 是指没有过期时间，只存活在会话之中。
CURLOPT_CERTINFO | true 将在安全传输时输出 SSL 证书信息到 STDERR。 | 在 cURL 7.19.1 中添加。 PHP 5.3.2 后有效。 需要开启 CURLOPT_VERBOSE 才有效。
CURLOPT_CONNECT_ONLY | true 将让库执行所有需要的代理、验证、连接过程，但不传输数据。此选项用于 HTTP、SMTP 和 POP3。 | 在 7.15.2 中添加。 PHP 5.5.0 起有效。
CURLOPT_CRLF | 启用时将Unix的换行符转换成回车换行符。
CURLOPT_DNS_USE_GLOBAL_CACHE | true 会启用一个全局的DNS缓存。此选项非线程安全的，默认已开启。
CURLOPT_FAILONERROR | 当 HTTP 状态码大于等于 400，true 将将显示错误详情。 默认情况下将返回页面，忽略 HTTP 代码。
CURLOPT_SSL_FALSESTART | true 开启 TLS False Start （一种 TLS 握手优化方式） | cURL 7.42.0 中添加。自 PHP 7.0.7 起有效。
CURLOPT_FILETIME | true 时，会尝试获取远程文档中的修改时间信息。 信息可通过curl_getinfo()函数的CURLINFO_FILETIME 选项获取。
CURLOPT_FOLLOWLOCATION | true 时将会根据服务器返回 HTTP 头中的 "Location: " 重定向。（注意：这是递归的，"Location: " 发送几次就重定向几次，除非设置了 CURLOPT_MAXREDIRS，限制最大重定向次数。）。
CURLOPT_FORBID_REUSE | true 在完成交互以后强制明确的断开连接，不能在连接池中重用。
CURLOPT_FRESH_CONNECT | true 强制获取一个新的连接，而不是缓存中的连接。
CURLOPT_FTP_USE_EPRT | true 时，当 FTP 下载时，使用 EPRT (和 LPRT)命令。 设置为 false 时禁用 EPRT 和 LPRT，仅仅使用PORT 命令。
CURLOPT_FTP_USE_EPSV | true 时，在FTP传输过程中，回到 PASV 模式前，先尝试 EPSV 命令。设置为 false 时禁用 EPSV。
CURLOPT_FTP_CREATE_MISSING_DIRS | true 时，当 ftp 操作不存在的目录时将创建它。
CURLOPT_FTPAPPEND | true 为追加写入文件，而不是覆盖。
CURLOPT_TCP_NODELAY | true 时禁用 TCP 的 Nagle 算法，就是减少网络上的小包数量。 | PHP 5.2.1 有效，编译时需要 libcurl 7.11.2 及以上。
CURLOPT_FTPASCII | CURLOPT_TRANSFERTEXT 的别名。
CURLOPT_FTPLISTONLY | true 时只列出 FTP 目录的名字。
CURLOPT_HEADER | 启用时会将头文件的信息作为数据流输出。
CURLINFO_HEADER_OUT | true 时追踪句柄的请求字符串。 | 从 PHP 5.1.3 开始可用。CURLINFO_ 的前缀是有意的(intentional)。
CURLOPT_HTTPGET | true 时会设置 HTTP 的 method 为 GET，由于默认是 GET，所以只有 method 被修改时才需要这个选项。
CURLOPT_HTTPPROXYTUNNEL | true 会通过指定的 HTTP 代理来传输。
CURLOPT_MUTE | true 时将完全静默，无论是何 cURL 函数。 | 在 cURL 7.15.5 中移出（可以使用 CURLOPT_RETURNTRANSFER 作为代替）
CURLOPT_NETRC | true 时，在连接建立时，访问~/.netrc文件获取用户名和密码来连接远程站点。
CURLOPT_NOBODY | true 时将不输出 BODY 部分。同时 Mehtod 变成了 HEAD。修改为 false 时不会变成 GET。
CURLOPT_NOPROGRESS

true 时关闭 cURL 的传输进度。

Note:

PHP 默认自动设置此选项为 true，只有为了调试才需要改变设置。

CURLOPT_NOSIGNAL | true 时忽略所有的 cURL 传递给 PHP 进行的信号。在 SAPI 多线程传输时此项被默认启用，所以超时选项仍能使用。 | cURL 7.10时被加入。
CURLOPT_PATH_AS_IS | true 不处理 dot dot sequences （即 ../ ） | cURL 7.42.0 时被加入。 PHP 7.0.7 起有效。
CURLOPT_PIPEWAIT | true 则等待 pipelining/multiplexing。 | cURL 7.43.0 时被加入。 PHP 7.0.7 起有效。
CURLOPT_POST | true 时会发送 POST 请求，类型为：application/x-www-form-urlencoded，是 HTML 表单提交时最常见的一种。
CURLOPT_PUT | true 时允许 HTTP 发送文件。要被 PUT 的文件必须在 CURLOPT_INFILE和CURLOPT_INFILESIZE 中设置。
CURLOPT_RETURNTRANSFER | true 将curl_exec()获取的信息以字符串返回，而不是直接输出。
CURLOPT_SAFE_UPLOAD | true 禁用 @ 前缀在 CURLOPT_POSTFIELDS 中发送文件。 意味着 @ 可以在字段中安全得使用了。 可使用 CURLFile 作为上传的代替。 | PHP 5.5.0 中添加，默认值 false。 PHP 5.6.0 改默认值为 true。. PHP 7 删除了此选项， 必须使用 CURLFile interface 来上传文件。
CURLOPT_SASL_IR | true 开启，收到首包(first packet)后发送初始的响应(initial response)。 | cURL 7.31.10 中添加，自 PHP 7.0.7 起有效。
CURLOPT_SSL_ENABLE_ALPN | false 禁用 SSL 握手中的 ALPN (如果 SSL 后端的 libcurl 内建支持) 用于协商到 http2。 | cURL 7.36.0 中增加， PHP 7.0.7 起有效。
CURLOPT_SSL_ENABLE_NPN | false 禁用 SSL 握手中的 NPN(如果 SSL 后端的 libcurl 内建支持)，用于协商到 http2。 | cURL 7.36.0 中增加， PHP 7.0.7 起有效。
CURLOPT_SSL_VERIFYPEER | false 禁止 cURL 验证对等证书（peer's certificate）。要验证的交换证书可以在 CURLOPT_CAINFO 选项中设置，或在 CURLOPT_CAPATH中设置证书目录。 | 自cURL 7.10开始默认为 true。从 cURL 7.10开始默认绑定安装。
CURLOPT_SSL_VERIFYSTATUS | true 验证证书状态。 | cURL 7.41.0 中添加， PHP 7.0.7 起有效。
CURLOPT_TCP_FASTOPEN | true 开启 TCP Fast Open。 | cURL 7.49.0 中添加， PHP 7.0.7 起有效。
CURLOPT_TFTP_NO_OPTIONS | true 不发送 TFTP 的 options 请求。 | 自 cURL 7.48.0 添加， PHP 7.0.7 起有效。
CURLOPT_TRANSFERTEXT | true 对 FTP 传输使用 ASCII 模式。对于LDAP，它检索纯文本信息而非 HTML。在 Windows 系统上，系统不会把 STDOUT 设置成二进制 模式。
CURLOPT_UNRESTRICTED_AUTH | true 在使用CURLOPT_FOLLOWLOCATION重定向 header 中的多个 location 时继续发送用户名和密码信息，哪怕主机名已改变。
CURLOPT_UPLOAD | true 准备上传。
CURLOPT_VERBOSE | true 会输出所有的信息，写入到STDERR，或在CURLOPT_STDERR中指定的文件。

以下 option的value应该被设置成 integer：

选项 | 设置value为 | 备注
CURLOPT_BUFFERSIZE | 每次读入的缓冲的尺寸。当然不保证每次都会完全填满这个尺寸。 | 在cURL 7.10中被加入。
CURLOPT_CLOSEPOLICY CURLCLOSEPOLICY_* 中的一个。

Note:

此选项已被废弃，它不会被实现，永远不会有效果啦。

PHP 5.6.0 中移除。
CURLOPT_CONNECTTIMEOUT | 在尝试连接时等待的秒数。设置为0，则无限等待。
CURLOPT_CONNECTTIMEOUT_MS | 尝试连接等待的时间，以毫秒为单位。设置为0，则无限等待。 如果 libcurl 编译时使用系统标准的名称解析器（ standard system name resolver），那部分的连接仍旧使用以秒计的超时解决方案，最小超时时间还是一秒钟。 | 在 cURL 7.16.2 中被加入。从 PHP 5.2.3 开始可用。
CURLOPT_DNS_CACHE_TIMEOUT | 设置在内存中缓存 DNS 的时间，默认为120秒（两分钟）。
CURLOPT_EXPECT_100_TIMEOUT_MS | 超时预计： 100毫秒内的 continue 响应 默认为 1000 毫秒。 | cURL 7.36.0 中添加，自 PHP 7.0.7 有效。
CURLOPT_FTPSSLAUTH | FTP验证方式（启用的时候）：CURLFTPAUTH_SSL (首先尝试SSL)，CURLFTPAUTH_TLS (首先尝试TLS)或CURLFTPAUTH_DEFAULT (让cURL 自个儿决定)。 | 在 cURL 7.12.2 中被加入。
CURLOPT_HEADEROPT | How to deal with headers. One of the following constants: CURLHEADER_UNIFIED: the headers specified in CURLOPT_HTTPHEADER will be used in requests both to servers and proxies. With this option enabled, CURLOPT_PROXYHEADER will not have any effect. CURLHEADER_SEPARATE: makes CURLOPT_HTTPHEADER headers only get sent to a server and not to a proxy. Proxy headers must be set with CURLOPT_PROXYHEADER to get used. Note that if a non-CONNECT request is sent to a proxy, libcurl will send both server headers and proxy headers. When doing CONNECT, libcurl will send CURLOPT_PROXYHEADER headers only to the proxy and then CURLOPT_HTTPHEADER headers only to the server. Defaults to CURLHEADER_SEPARATE as of cURL 7.42.1, and CURLHEADER_UNIFIED before. | Added in cURL 7.37.0. Available since PHP 7.0.7.
CURLOPT_HTTP_VERSION | CURL_HTTP_VERSION_NONE (默认值，让 cURL 自己判断使用哪个版本)，CURL_HTTP_VERSION_1_0 (强制使用 HTTP/1.0)或CURL_HTTP_VERSION_1_1 (强制使用 HTTP/1.1)。
CURLOPT_HTTPAUTH

使用的 HTTP 验证方法。选项有： CURLAUTH_BASIC、 CURLAUTH_DIGEST、 CURLAUTH_GSSNEGOTIATE、 CURLAUTH_NTLM、 CURLAUTH_ANY和 CURLAUTH_ANYSAFE。

可以使用 | 位域(OR)操作符结合多个值，cURL 会让服务器选择受支持的方法，并选择最好的那个。

CURLAUTH_ANY是 CURLAUTH_BASIC | CURLAUTH_DIGEST | CURLAUTH_GSSNEGOTIATE | CURLAUTH_NTLM 的别名。

CURLAUTH_ANYSAFE 是 CURLAUTH_DIGEST | CURLAUTH_GSSNEGOTIATE | CURLAUTH_NTLM 的别名。

CURLOPT_INFILESIZE | 希望传给远程站点的文件尺寸，字节(byte)为单位。 注意无法用这个选项阻止 libcurl 发送更多的数据，确切发送什么取决于 CURLOPT_READFUNCTION。
CURLOPT_LOW_SPEED_LIMIT | 传输速度，每秒字节（bytes）数，根据CURLOPT_LOW_SPEED_TIME秒数统计是否因太慢而取消传输。
CURLOPT_LOW_SPEED_TIME | 当传输速度小于CURLOPT_LOW_SPEED_LIMIT时(bytes/sec)，PHP会判断是否因太慢而取消传输。
CURLOPT_MAXCONNECTS | 允许的最大连接数量。达到限制时，会通过CURLOPT_CLOSEPOLICY决定应该关闭哪些连接。
CURLOPT_MAXREDIRS | 指定最多的 HTTP 重定向次数，这个选项是和CURLOPT_FOLLOWLOCATION一起使用的。
CURLOPT_PORT | 用来指定连接端口。
CURLOPT_POSTREDIR | 位掩码， 1 (301 永久重定向), 2 (302 Found) 和 4 (303 See Other) 设置 CURLOPT_FOLLOWLOCATION 时，什么情况下需要再次 HTTP POST 到重定向网址。 | cURL 7.19.1 中添加，PHP 5.3.2 开始可用。
CURLOPT_PROTOCOLS

CURLPROTO_*的位掩码。 启用时，会限制 libcurl 在传输过程中可使用哪些协议。 这将允许你在编译libcurl时支持众多协议，但是限制只用允许的子集。默认 libcurl 将使用所有支持的协议。 参见CURLOPT_REDIR_PROTOCOLS。

可用的协议选项为： CURLPROTO_HTTP、 CURLPROTO_HTTPS、 CURLPROTO_FTP、 CURLPROTO_FTPS、 CURLPROTO_SCP、 CURLPROTO_SFTP、 CURLPROTO_TELNET、 CURLPROTO_LDAP、 CURLPROTO_LDAPS、 CURLPROTO_DICT、 CURLPROTO_FILE、 CURLPROTO_TFTP、 CURLPROTO_ALL。

在 cURL 7.19.4 中被加入。
CURLOPT_PROXYAUTH | HTTP 代理连接的验证方式。使用在CURLOPT_HTTPAUTH中的位掩码。 当前仅仅支持 CURLAUTH_BASIC和CURLAUTH_NTLM。 | 在 cURL 7.10.7 中被加入。
CURLOPT_PROXYPORT | 代理服务器的端口。端口也可以在CURLOPT_PROXY中设置。
CURLOPT_PROXYTYPE | 可以是 CURLPROXY_HTTP (默认值) CURLPROXY_SOCKS4、 CURLPROXY_SOCKS5、 CURLPROXY_SOCKS4A 或 CURLPROXY_SOCKS5_HOSTNAME。 | 在 cURL 7.10 中被加入。
CURLOPT_REDIR_PROTOCOLS | CURLPROTO_* 值的位掩码。如果被启用，位掩码会限制 libcurl 在 CURLOPT_FOLLOWLOCATION开启时，使用的协议。 默认允许除 FILE 和 SCP 外所有协议。 这和 7.19.4 前的版本无条件支持所有支持的协议不同。关于协议常量，请参照CURLOPT_PROTOCOLS。 | 在 cURL 7.19.4 中被加入。
CURLOPT_RESUME_FROM | 在恢复传输时，传递字节为单位的偏移量（用来断点续传）。
CURLOPT_SSL_OPTIONS | Set SSL behavior options, which is a bitmask of any of the following constants: CURLSSLOPT_ALLOW_BEAST: do not attempt to use any workarounds for a security flaw in the SSL3 and TLS1.0 protocols. CURLSSLOPT_NO_REVOKE: disable certificate revocation checks for those SSL backends where such behavior is present. | Added in cURL 7.25.0. Available since PHP 7.0.7.
CURLOPT_SSL_VERIFYHOST | 设置为 1 是检查服务器SSL证书中是否存在一个公用名(common name)。译者注：公用名(Common Name)一般来讲就是填写你将要申请SSL证书的域名 (domain)或子域名(sub domain)。 设置成 2，会检查公用名是否存在，并且是否与提供的主机名匹配。 0 为不检查名称。 在生产环境中，这个值应该是 2（默认值）。 | 值 1 的支持在 cURL 7.28.1 中被删除了。
CURLOPT_SSLVERSION CURL_SSLVERSION_DEFAULT (0), CURL_SSLVERSION_TLSv1 (1), CURL_SSLVERSION_SSLv2 (2), CURL_SSLVERSION_SSLv3 (3), CURL_SSLVERSION_TLSv1_0 (4), CURL_SSLVERSION_TLSv1_1 (5) ， CURL_SSLVERSION_TLSv1_2 (6) 中的其中一个。

Note:

你最好别设置这个值，让它使用默认值。 设置为 2 或 3 比较危险，在 SSLv2 和 SSLv3 中有弱点存在。

CURLOPT_STREAM_WEIGHT | 设置 stream weight 数值 ( 1 和 256 之间的数字). | cURL 7.46.0 中添加，自 PHP 7.0.7 起有效。
CURLOPT_TIMECONDITION | 设置如何对待 CURLOPT_TIMEVALUE。 使用 CURL_TIMECOND_IFMODSINCE，仅在页面 CURLOPT_TIMEVALUE 之后修改，才返回页面。没有修改则返回 "304 Not Modified" 头，假设设置了 CURLOPT_HEADER 为 true。CURL_TIMECOND_IFUNMODSINCE则起相反的效果。 默认为 CURL_TIMECOND_IFMODSINCE。
CURLOPT_TIMEOUT | 允许 cURL 函数执行的最长秒数。
CURLOPT_TIMEOUT_MS | 设置cURL允许执行的最长毫秒数。 如果 libcurl 编译时使用系统标准的名称解析器（ standard system name resolver），那部分的连接仍旧使用以秒计的超时解决方案，最小超时时间还是一秒钟。 | 在 cURL 7.16.2 中被加入。从 PHP 5.2.3 起可使用。
CURLOPT_TIMEVALUE | 秒数，从 1970年1月1日开始。这个时间会被 CURLOPT_TIMECONDITION使。默认使用CURL_TIMECOND_IFMODSINCE。
CURLOPT_MAX_RECV_SPEED_LARGE | 如果下载速度超过了此速度(以每秒字节数来统计) ，即传输过程中累计的平均数，传输就会降速到这个参数的值。默认不限速。 | cURL 7.15.5 中添加， PHP 5.4.0 有效。
CURLOPT_MAX_SEND_SPEED_LARGE | 如果上传的速度超过了此速度(以每秒字节数来统计)，即传输过程中累计的平均数 ，传输就会降速到这个参数的值。默认不限速。 | cURL 7.15.5 中添加， PHP 5.4.0 有效。
CURLOPT_SSH_AUTH_TYPES | A bitmask consisting of one or more of CURLSSH_AUTH_PUBLICKEY, CURLSSH_AUTH_PASSWORD, CURLSSH_AUTH_HOST, CURLSSH_AUTH_KEYBOARD. Set to CURLSSH_AUTH_ANY to let libcurl pick one. | cURL 7.16.1 中添加。
CURLOPT_IPRESOLVE | 允许程序选择想要解析的 IP 地址类别。只有在地址有多种 ip 类别的时候才能用，可以的值有： CURL_IPRESOLVE_WHATEVER、 CURL_IPRESOLVE_V4、 CURL_IPRESOLVE_V6，默认是 CURL_IPRESOLVE_WHATEVER。 | cURL 7.10.8 中添加。
CURLOPT_FTP_FILEMETHOD | 告诉 curl 使用哪种方式来获取 FTP(s) 服务器上的文件。可能的值有： CURLFTPMETHOD_MULTICWD、 CURLFTPMETHOD_NOCWD 和 CURLFTPMETHOD_SINGLECWD。 | cURL 7.15.1 中添加， PHP 5.3.0 起有效。

对于下面的这些option，value应该被设置成 string：

选项 | 设置的value | 备注
CURLOPT_CAINFO | 一个保存着1个或多个用来让服务端验证的证书的文件名。这个参数仅仅在和CURLOPT_SSL_VERIFYPEER一起使用时才有意义。 . | 可能需要绝对路径。
CURLOPT_CAPATH | 一个保存着多个CA证书的目录。这个选项是和CURLOPT_SSL_VERIFYPEER一起使用的。
CURLOPT_COOKIE | 设定 HTTP 请求中"Cookie: "部分的内容。多个 cookie 用分号分隔，分号后带一个空格(例如， "fruit=apple; colour=red")。
CURLOPT_COOKIEFILE | 包含 cookie 数据的文件名，cookie 文件的格式可以是 Netscape 格式，或者只是纯 HTTP 头部风格，存入文件。如果文件名是空的，不会加载 cookie，但 cookie 的处理仍旧启用。
CURLOPT_COOKIEJAR | 连接结束后，比如，调用 curl_close 后，保存 cookie 信息的文件。
CURLOPT_CUSTOMREQUEST

HTTP 请求时，使用自定义的 Method 来代替"GET"或"HEAD"。对 "DELETE" 或者其他更隐蔽的 HTTP 请求有用。 有效值如 "GET"，"POST"，"CONNECT"等等；也就是说，不要在这里输入整行 HTTP 请求。例如输入"GET /index.html HTTP/1.0\r\n\r\n"是不正确的。

Note:

不确定服务器支持这个自定义方法则不要使用它。

CURLOPT_DEFAULT_PROTOCOL

URL不带协议的时候，使用的默认协议。

cURL 7.45.0 中添加，自 PHP 7.0.7 起有效。
CURLOPT_DNS_INTERFACE

Set the name of the network interface that the DNS resolver should bind to. This must be an interface name (not an address).

Added in cURL 7.33.0. Available since PHP 7.0.7.
CURLOPT_DNS_LOCAL_IP4

Set the local IPv4 address that the resolver should bind to. The argument should contain a single numerical IPv4 address as a string.

Added in cURL 7.33.0. Available since PHP 7.0.7.
CURLOPT_DNS_LOCAL_IP6

Set the local IPv6 address that the resolver should bind to. The argument should contain a single numerical IPv6 address as a string.

Added in cURL 7.33.0. Available since PHP 7.0.7.
CURLOPT_EGDSOCKET | 类似CURLOPT_RANDOM_FILE，除了一个Entropy Gathering Daemon套接字。
CURLOPT_ENCODING | HTTP请求头中"Accept-Encoding: "的值。 这使得能够解码响应的内容。 支持的编码有"identity"，"deflate"和"gzip"。如果为空字符串""，会发送所有支持的编码类型。 | 在 cURL 7.10 中被加入。
CURLOPT_FTPPORT | 这个值将被用来获取供FTP"PORT"指令所需要的IP地址。 "PORT" 指令告诉远程服务器连接到我们指定的IP地址。这个字符串可以是纯文本的IP地址、主机名、一个网络接口名（UNIX下）或者只是一个'-'来使用默认的 IP 地址。
CURLOPT_INTERFACE | 发送的网络接口（interface），可以是一个接口名、IP 地址或者是一个主机名。
CURLOPT_KEYPASSWD | 使用 CURLOPT_SSLKEY 或 CURLOPT_SSH_PRIVATE_KEYFILE 私钥时候的密码。 | 在 cURL 7.16.1 中添加。
CURLOPT_KRB4LEVEL | KRB4 (Kerberos 4) 安全级别。下面的任何值都是有效的(从低到高的顺序)："clear"、"safe"、"confidential"、"private".。如果字符串以上这些，将使用"private"。 这个选项设置为 null 时将禁用 KRB4 安全认证。目前 KRB4 安全认证只能用于 FTP 传输。
CURLOPT_LOGIN_OPTIONS | Can be used to set protocol specific login options, such as the preferred authentication mechanism via "AUTH=NTLM" or "AUTH=*", and should be used in conjunction with the CURLOPT_USERNAME option. | Added in cURL 7.34.0. Available since PHP 7.0.7.
CURLOPT_PINNEDPUBLICKEY | Set the pinned public key. The string can be the file name of your pinned public key. The file format expected is "PEM" or "DER". The string can also be any number of base64 encoded sha256 hashes preceded by "sha256//" and separated by ";". | Added in cURL 7.39.0. Available since PHP 7.0.7.
CURLOPT_POSTFIELDS | 全部数据使用HTTP协议中的 "POST" 操作来发送。 要发送文件，在文件名前面加上@前缀并使用完整路径。 文件类型可在文件名后以 ';type=mimetype' 的格式指定。 这个参数可以是 urlencoded 后的字符串，类似'para1=val1&para2=val2&...'，也可以使用一个以字段名为键值，字段数据为值的数组。 如果value是一个数组，Content-Type头将会被设置成multipart/form-data。 从 PHP 5.2.0 开始，使用 @ 前缀传递文件时，value 必须是个数组。 从 PHP 5.5.0 开始, @ 前缀已被废弃，文件可通过 CURLFile 发送。 设置 CURLOPT_SAFE_UPLOAD 为 true 可禁用 @ 前缀发送文件，以增加安全性。
CURLOPT_PRIVATE | Any data that should be associated with this cURL handle. This data can subsequently be retrieved with the CURLINFO_PRIVATE option of curl_getinfo(). cURL does nothing with this data. When using a cURL multi handle, this private data is typically a unique key to identify a standard cURL handle. | Added in cURL 7.10.3.
CURLOPT_PROXY | HTTP 代理通道。
CURLOPT_PROXY_SERVICE_NAME | 代理验证服务的名称。 | cURL 7.34.0 中添加，PHP 7.0.7 起有效。
CURLOPT_PROXYUSERPWD | 一个用来连接到代理的"[username]:[password]"格式的字符串。
CURLOPT_RANDOM_FILE | 一个被用来生成 SSL 随机数种子的文件名。
CURLOPT_RANGE | 以"X-Y"的形式，其中X和Y都是可选项获取数据的范围，以字节计。HTTP传输线程也支持几个这样的重复项中间用逗号分隔如"X-Y,N-M"。
CURLOPT_REFERER | 在HTTP请求头中"Referer: "的内容。
CURLOPT_SERVICE_NAME | 验证服务的名称 | cURL 7.43.0 起添加，自 PHP 7.0.7 有效。
CURLOPT_SSH_HOST_PUBLIC_KEY_MD5 | 包含 32 位长的 16 进制数值。这个字符串应该是远程主机公钥（public key） 的 MD5 校验值。在不匹配的时候 libcurl 会拒绝连接。 此选项仅用于 SCP 和 SFTP 的传输。 | cURL 7.17.1 中添加。
CURLOPT_SSH_PUBLIC_KEYFILE | The file name for your public key. If not used, libcurl defaults to $HOME/.ssh/id_dsa.pub if the HOME environment variable is set, and just "id_dsa.pub" in the current directory if HOME is not set. | Added in cURL 7.16.1.
CURLOPT_SSH_PRIVATE_KEYFILE | The file name for your private key. If not used, libcurl defaults to $HOME/.ssh/id_dsa if the HOME environment variable is set, and just "id_dsa" in the current directory if HOME is not set. If the file is password-protected, set the password with CURLOPT_KEYPASSWD. | Added in cURL 7.16.1.
CURLOPT_SSL_CIPHER_LIST | 一个SSL的加密算法列表。例如RC4-SHA和TLSv1都是可用的加密列表。
CURLOPT_SSLCERT | 一个包含 PEM 格式证书的文件名。
CURLOPT_SSLCERTPASSWD | 使用CURLOPT_SSLCERT证书需要的密码。
CURLOPT_SSLCERTTYPE | 证书的类型。支持的格式有"PEM" (默认值), "DER"和"ENG"。 | 在 cURL 7.9.3中 被加入。
CURLOPT_SSLENGINE | 用来在CURLOPT_SSLKEY中指定的SSL私钥的加密引擎变量。
CURLOPT_SSLENGINE_DEFAULT | 用来做非对称加密操作的变量。
CURLOPT_SSLKEY | 包含 SSL 私钥的文件名。
CURLOPT_SSLKEYPASSWD

在 CURLOPT_SSLKEY中指定了的SSL私钥的密码。

Note:

由于这个选项包含了敏感的密码信息，记得保证这个PHP脚本的安全。

CURLOPT_SSLKEYTYPE | CURLOPT_SSLKEY中规定的私钥的加密类型，支持的密钥类型为"PEM"(默认值)、"DER"和"ENG"。
CURLOPT_UNIX_SOCKET_PATH | 使用 Unix 套接字作为连接，并用指定的 string 作为路径。 | cURL 7.40.0 中添加， PHP 7.0.7 起有效。
CURLOPT_URL | 需要获取的 URL 地址，也可以在curl_init() 初始化会话的时候。
CURLOPT_USERAGENT | 在HTTP请求中包含一个"User-Agent: "头的字符串。
CURLOPT_USERNAME | 验证中使用的用户名。 | cURL 7.19.1 中添加，PHP 5.5.0 起有效。
CURLOPT_USERPWD | 传递一个连接中需要的用户名和密码，格式为："[username]:[password]"。
CURLOPT_XOAUTH2_BEARER | 指定 OAuth 2.0 access token。 | cURL 7.33.0 中添加，自 PHP 7.0.7 添加。

以下option，value应该被设置成数组：

选项 | 可选value值 | 备注
CURLOPT_CONNECT_TO | 连接到指定的主机和端口，替换 URL 中的主机和端口。接受指定字符串格式的数组： HOST:PORT:CONNECT-TO-HOST:CONNECT-TO-PORT。 | cURL 7.49.0 中添加， PHP 7.0.7 起有效。
CURLOPT_HTTP200ALIASES | HTTP 200 响应码数组，数组中的响应码被认为是正确的响应，而非错误。 | 在 cURL 7.10.3 中被加入。
CURLOPT_HTTPHEADER | 设置 HTTP 头字段的数组。格式： array('Content-type: text/plain', 'Content-length: 100')
CURLOPT_POSTQUOTE | 在 FTP 请求执行完成后，在服务器上执行的一组array格式的 FTP 命令。
CURLOPT_PROXYHEADER | 传给代理的自定义 HTTP 头。 | cURL 7.37.0 中添加，自 PHP 7.0.7 添加。
CURLOPT_QUOTE | 一组先于 FTP 请求的在服务器上执行的FTP命令。
CURLOPT_RESOLVE | 提供自定义地址，指定了主机和端口。 包含主机、端口和 ip 地址的字符串，组成 array 的，每个元素以冒号分隔。格式： array("example.com:80:127.0.0.1") | 在 cURL 7.21.3 中添加，自 PHP 5.5.0 起可用。

以下 option，value应该被设置成流资源 （例如使用fopen()）：

选项 | 可选value值
CURLOPT_FILE | 设置输出文件，默认为STDOUT (浏览器)。
CURLOPT_INFILE | 上传文件时需要读取的文件。
CURLOPT_STDERR | 错误输出的地址，取代默认的STDERR。
CURLOPT_WRITEHEADER | 设置 header 部分内容的写入的文件地址。

以下option 的 value应该是有效的函数或者闭包：

选项 | value值
CURLOPT_HEADERFUNCTION | 设置一个回调函数，这个函数有两个参数，第一个是cURL的资源句柄，第二个是输出的 header 数据。header数据的输出必须依赖这个函数，返回已写入的数据大小。
CURLOPT_PASSWDFUNCTION | 设置一个回调函数，有三个参数，第一个是cURL的资源句柄，第二个是一个密码提示符，第三个参数是密码长度允许的最大值。返回密码的值。
CURLOPT_PROGRESSFUNCTION

设置一个回调函数，有五个参数，第一个是cURL的资源句柄，第二个是预计要下载的总字节（bytes）数。第三个是目前下载的字节数，第四个是预计传输中总上传字节数，第五个是目前上传的字节数。

Note:

只有设置 CURLOPT_NOPROGRESS 选项为 false 时才会调用这个回调函数。

返回非零值将中断传输。 传输将设置 CURLE_ABORTED_BY_CALLBACK 错误。

CURLOPT_READFUNCTION | 回调函数名。该函数应接受三个参数。第一个是 cURL resource；第二个是通过选项 CURLOPT_INFILE 传给 cURL 的 stream resource；第三个参数是最大可以读取的数据的数量。回 调函数必须返回一个字符串，长度小于或等于请求的数据量（第三个参数）。一般从传入的 stream resource 读取。返回空字符串作为 EOF（文件结束） 信号。
CURLOPT_WRITEFUNCTION | 回调函数名。该函数应接受两个参数。第一个是 cURL resource；第二个是要写入的数据字符串。数 据必须在函数中被保存。 函数必须准确返回写入数据的字节数，否则传输会被一个错误所中 断。

其他值：

Option | 设置 value 为
CURLOPT_SHARE | curl_share_init() 返回的结果。 使 cURL 可以处理共享句柄里的数据。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.0.7 | 引入 CURL_HTTP_VERSION_2、 CURL_HTTP_VERSION_2_PRIOR_KNOWLEDGE、 CURL_HTTP_VERSION_2TLS、 CURL_REDIR_POST_301、 CURL_REDIR_POST_302、 CURL_REDIR_POST_303、 CURL_REDIR_POST_ALL、 CURL_VERSION_KERBEROS5、 CURL_VERSION_PSL、 CURL_VERSION_UNIX_SOCKETS、 CURLAUTH_NEGOTIATE、 CURLAUTH_NTLM_WB、 CURLFTP_CREATE_DIR、 CURLFTP_CREATE_DIR_NONE、 CURLFTP_CREATE_DIR_RETRY、 CURLHEADER_SEPARATE、 CURLHEADER_UNIFIED、 CURLMOPT_CHUNK_LENGTH_PENALTY_SIZE、 CURLMOPT_CONTENT_LENGTH_PENALTY_SIZE、 CURLMOPT_MAX_HOST_CONNECTIONS、 CURLMOPT_MAX_PIPELINE_LENGTH、 CURLMOPT_MAX_TOTAL_CONNECTIONS、 CURLOPT_CONNECT_TO、 CURLOPT_DEFAULT_PROTOCOL、 CURLOPT_DNS_INTERFACE、 CURLOPT_DNS_LOCAL_IP4、 CURLOPT_DNS_LOCAL_IP6、 CURLOPT_EXPECT_100_TIMEOUT_MS、 CURLOPT_HEADEROPT、 CURLOPT_LOGIN_OPTIONS、 CURLOPT_PATH_AS_IS、 CURLOPT_PINNEDPUBLICKEY、 CURLOPT_PIPEWAIT、 CURLOPT_PROXY_SERVICE_NAME、 CURLOPT_PROXYHEADER、 CURLOPT_SASL_IR、 CURLOPT_SERVICE_NAME、 CURLOPT_SSL_ENABLE_ALPN、 CURLOPT_SSL_ENABLE_NPN、 CURLOPT_SSL_FALSESTART、 CURLOPT_SSL_VERIFYSTATUS、 CURLOPT_STREAM_WEIGHT、 CURLOPT_TCP_FASTOPEN、 CURLOPT_TFTP_NO_OPTIONS、 CURLOPT_UNIX_SOCKET_PATH、 CURLOPT_XOAUTH2_BEARER、 CURLPROTO_SMB、 CURLPROTO_SMBS、 CURLPROXY_HTTP_1_0、 CURLSSH_AUTH_AGENT 和 CURLSSLOPT_NO_REVOKE。

范例

Example #1 初始化一个新的cURL会话并获取一个网页

<?php
// 创建一个新cURL资源
$ch = curl_init();

// 设置URL和相应的选项
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, false);

// 抓取URL并把它传递给浏览器
curl_exec($ch);

//关闭cURL资源，并且释放系统资源
curl_close($ch);
?>

Example #2 上传文件 (PHP 5.5.0 后被废弃)

<?php

/* http://localhost/upload.php:
print_r($_POST);
print_r($_FILES);
*/

$ch = curl_init();

$data = array('name' => 'Foo', 'file' => '@/home/user/test.png');

curl_setopt($ch, CURLOPT_URL, 'http://localhost/upload.php');
curl_setopt($ch, CURLOPT_POST, 1);
curl_setopt($ch, CURLOPT_SAFE_UPLOAD, false); //  PHP 5.6.0 后必须开启
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

curl_exec($ch);
?>

以上例程会输出：

Array
(
    [name] => Foo
)
Array
(
    [file] => Array
        (
            [name] => test.png
            [type] => image/png
            [tmp_name] => /tmp/phpcpjNeQ
            [error] => 0
            [size] => 279
        )

)

注释

Note:

传递一个数组到CURLOPT_POSTFIELDS，cURL会把数据编码成 multipart/form-data，而然传递一个URL-encoded字符串时，数据会被编码成 application/x-www-form-urlencoded。

参见

  • curl_setopt_array() - 为 cURL 传输会话批量设置选项


关闭 cURL 共享句柄

  • ? curl_setopt
  • curl_share_errno ?
  • PHP Manual
  • cURL 函数
  • 关闭 cURL 共享句柄

curl_share_close

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_share_close — 关闭 cURL 共享句柄

说明

curl_share_close ( resource $sh ) : void

关闭一个 cURL 共享句柄并且释放所有的资源。

参数

sh

由curl_share_init()创建的 cURL 共享句柄。

返回值

没有返回值。

范例

Example #1 curl_share_setopt() 函数范例：

以下范例将会创建一个 cURL 共享句柄，并且往其中添加两个 cURL 句柄，最后共享这两个 cURL 句柄的 cookie 数据运行。

<?php
// Create cURL share handle and set it to share cookie data
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// Initialize the first cURL handle and assign the share handle to it
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// Execute the first cURL handle
curl_exec($ch1);

// Initialize the second cURL handle and assign the share handle to it
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// Execute the second cURL handle
//  all cookies from $ch1 handle are shared with $ch2 handle
curl_exec($ch2);

// Close the cURL share handle
curl_share_close($sh);

// Close the cURL handles
curl_close($ch1);
curl_close($ch2);
?>

参见

  • curl_share_init() - 初始化一个 cURL 共享句柄。


返回共享 curl 句柄的最后一次错误号

  • ? curl_share_close
  • curl_share_init ?
  • PHP Manual
  • cURL 函数
  • 返回共享 curl 句柄的最后一次错误号

curl_share_errno

(PHP 7 >= 7.1.0, PHP 8)

curl_share_errno — 返回共享 curl 句柄的最后一次错误号

说明

curl_share_errno ( resource $sh ) : int

返回一个整数，表示共享 curl 句柄的最后一次错误号

参数

sh

由 curl_share_init() 函数创建的共享 cURL 句柄。

返回值

返回一个整数，表示共享 curl 句柄的最后一次错误号， 或者在失败时返回 false。

参见

  • curl_errno() - 返回最后一次的错误代码


初始化一个 cURL 共享句柄。

  • ? curl_share_errno
  • curl_share_setopt ?
  • PHP Manual
  • cURL 函数
  • 初始化一个 cURL 共享句柄。

curl_share_init

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_share_init — 初始化一个 cURL 共享句柄。

说明

curl_share_init ( ) : resource

运行在 cURL 句柄之间共享数据。

参数

此函数没有参数。

返回值

返回类型为"cURL 共享句柄"的资源。

范例

Example #1 curl_share_init() 函数的范例：

以下范例将会创建一个 cURL 共享句柄，并且往其中添加两个 cURL 句柄，最后用共享的 cookie 数据运行它们。

<?php
// 创建 cURL 共享句柄，并设置共享 cookie 数据
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// 初始化第一个 cURL 句柄，并将它设置到共享句柄
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// 执行第一个 cURL 句柄
curl_exec($ch1);

// 初始化第二个 cURL 句柄，并将它设置到共享句柄
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// 执行第二个 cURL 句柄
//  all cookies from $ch1 handle are shared with $ch2 handle
curl_exec($ch2);

// 关闭 cURL 共享句柄
curl_share_close($sh);

// 关闭 cURL 共享句柄
curl_close($ch1);
curl_close($ch2);
?>

参见

  • curl_share_setopt() - 为 cURL 共享句柄设置选项。
  • curl_share_close() - 关闭 cURL 共享句柄


为 cURL 共享句柄设置选项。

  • ? curl_share_init
  • curl_share_strerror ?
  • PHP Manual
  • cURL 函数
  • 为 cURL 共享句柄设置选项。

curl_share_setopt

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_share_setopt — 为 cURL 共享句柄设置选项。

说明

curl_share_setopt ( resource $sh , int $option , string $value ) : bool

为给定的 cURL 共享句柄设置一个选项。

参数

sh

一个由curl_share_init()函数返回的 cURL 共享句柄。

option

Option | Description
CURLSHOPT_SHARE | 指定要共享的数据类型。
CURLSHOPT_UNSHARE | 指定不再共享的数据类型。

value

Value | Description
CURL_LOCK_DATA_COOKIE | 共享 cookie 数据。
CURL_LOCK_DATA_DNS | 共享 DNS 缓存。注意，当你使用 cURL 多句柄时，默认所有添加在同一个多句柄的句柄都将会共享 DNS 缓存。
CURL_LOCK_DATA_SSL_SESSION | 共享 SSL 的 session ID, 在重连同样的服务器时减少 SSL 握手时间。注意，SSL 的 session ID 在同一个的句柄中默认是重复使用的。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 curl_share_setopt() 函数的范例：

以下范例将会创建一个 cURL 共享句柄，并且往其中添加两个 cURL 句柄，最后共享这两个 cURL 句柄的 cookie 数据运行。

<?php
// Create cURL share handle and set it to share cookie data
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// Initialize the first cURL handle and assign the share handle to it
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// Execute the first cURL handle
curl_exec($ch1);

// Initialize the second cURL handle and assign the share handle to it
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// Execute the second cURL handle
//  all cookies from $ch1 handle are shared with $ch2 handle
curl_exec($ch2);

// Close the cURL share handle
curl_share_close($sh);

// Close the cURL handles
curl_close($ch1);
curl_close($ch2);
?>


返回错误号对应的错误消息

  • ? curl_share_setopt
  • curl_strerror ?
  • PHP Manual
  • cURL 函数
  • 返回错误号对应的错误消息

curl_share_strerror

(PHP 7 >= 7.1.0, PHP 8)

curl_share_strerror — 返回错误号对应的错误消息

说明

curl_share_strerror ( int $errornum ) : string

返回错误号对应的错误消息。

参数

errornum

» cURL error codes 常量。

返回值

返回错误消息。如果传入了无效的错误号，返回 null。

参见

  • curl_share_errno() - 返回共享 curl 句柄的最后一次错误号
  • curl_strerror() - 返回错误代码的字符串描述


返回错误代码的字符串描述

  • ? curl_share_strerror
  • curl_unescape ?
  • PHP Manual
  • cURL 函数
  • 返回错误代码的字符串描述

curl_strerror

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_strerror — 返回错误代码的字符串描述

说明

curl_strerror ( int $errornum ) : string

返回文本错误信息，解释了指定的错误代码。

参数

errornum

» cURL 错误代码中的常量之一。

返回值

返回错误信息描述，无效的错误代码返回 null 。

范例

Example #1 curl_errno() 函数的范例：

<?php
// 以错拼的 URL 协议创建 curl 句柄
$ch = curl_init("htp://example.com/");

// 发送请求
curl_exec($ch);

// 检测错误，显示错误信息
if($errno = curl_errno($ch)) {
    $error_message = curl_strerror($errno);
    echo "cURL error ({$errno}):\n {$error_message}";
}

// 关闭句柄
curl_close($ch);
?>

以上例程会输出：

cURL error (1):
 Unsupported protocol

参见

  • curl_errno() - 返回最后一次的错误代码
  • curl_error() - 返回当前会话最后一次错误的字符串
  • » Curl error codes


解码给定的 URL 编码的字符串

  • ? curl_strerror
  • curl_version ?
  • PHP Manual
  • cURL 函数
  • 解码给定的 URL 编码的字符串

curl_unescape

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

curl_unescape — 解码给定的 URL 编码的字符串

说明

curl_unescape ( resource $ch , string $str ) : string

该函数解码给定的 URL 编码的字符串。

参数

handle

由 curl_init() 返回的 cURL 句柄。

str

需要解码的 URL 编码字符串

返回值

返回解码后的字符串 或者在失败时返回 false。

范例

Example #1 curl_escape() 示例

<?php
// 创建一个 curl 句柄
$ch = curl_init('http://example.com/redirect.php');

// 发送 HTTP 请求并且遵循重定向
curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);
curl_exec($ch);

// 获取最后的有效 URL
$effective_url = curl_getinfo($ch, CURLINFO_EFFECTIVE_URL);
// 结果： "http://example.com/show_location.php?loc=M%C3%BCnchen"

// 解码这个 URL
$effective_url_decoded = curl_unescape($ch, $effective_url);
// "http://example.com/show_location.php?loc=München"

// 关闭句柄
curl_close($ch);
?>

注释

Note:

curl_unescape() 不会将加号 (+) 解码成空格。而 urldecode() 会。

参见

  • curl_escape() - 使用 URL 编码给定的字符串
  • urlencode() - 编码 URL 字符串
  • urldecode() - 解码已编码的 URL 字符串
  • rawurlencode() - 按照 RFC 3986 对 URL 进行编码
  • rawurldecode() - 对已编码的 URL 字符串进行解码


获取 cURL 版本信息

  • ? curl_unescape
  • CURLFile ?
  • PHP Manual
  • cURL 函数
  • 获取 cURL 版本信息

curl_version

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

curl_version — 获取 cURL 版本信息

说明

curl_version ( int $age = CURLVERSION_NOW ) : array

返回关于 cURL 版本的信息。

参数

age

返回值

返回关联数组，包含如下元素：

键 | 值描述
version_number | cURL 24 位版本号
version | cURL 版本号，字符串形式
ssl_version_number | OpenSSL 24 位版本号
ssl_version | OpenSSL 版本号，字符串形式
libz_version | zlib 版本号，字符串形式
host | 关于编译cURL主机的信息
age |
features | 一个CURL_VERSION_XXX常量的位掩码
protocols | 数组，包含 cURL 支持的协议名称

范例

Example #1 curl_version() 例子

这个范例将会检查当前 cURL 版本使用curl_version()返回的 'features' 位掩码中哪些特性是可用的。

<?php
// 获取cURL版本数组
$version = curl_version();

// 在cURL编译版本中使用位域来检查某些特性
$bitfields = Array(
            'CURL_VERSION_IPV6',
            'CURL_VERSION_KERBEROS4',
            'CURL_VERSION_SSL',
            'CURL_VERSION_LIBZ'
            );

foreach($bitfields as $feature)
{
    echo $feature . ($version['features'] & constant($feature) ? ' matches' : ' does not match');
    echo PHP_EOL;
}
?>


CURLFile 类

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

简介

CURLFile 应该与选项 CURLOPT_POSTFIELDS 一同使用用于上传文件。

类摘要

CURLFile {
/* 属性 */
public $name ;
public $mime ;
public $postname ;
/* 方法 */
public __construct ( string $filename , string $mimetype = ? , string $postname = ? )
public getFilename ( ) : string
public getMimeType ( ) : string
public getPostFilename ( ) : string
public setMimeType ( string $mime ) : void
public setPostFilename ( string $postname ) : void
}

属性

name

待上传文件的名称

mime

文件的 MIME type（默认是application/octet-stream）。

postname

上传数据中的文件名称（默认为属性 name ）。

参见

  • curl_setopt()

Table of Contents

  • CURLFile::__construct — 创建 CURLFile 对象
  • CURLFile::getFilename — 获取被上传文件的 文件名
  • CURLFile::getMimeType — 获取被上传文件的 MIME 类型
  • CURLFile::getPostFilename — 获取 POST 请求时使用的 文件名
  • CURLFile::setMimeType — 设置被上传文件的 MIME 类型
  • CURLFile::setPostFilename — 设置 POST 请求时使用的文件名


创建 CURLFile 对象

  • ? CURLFile
  • CURLFile::getFilename ?
  • PHP Manual
  • CURLFile
  • 创建 CURLFile 对象

CURLFile::__construct

curl_file_create

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::__construct -- curl_file_create — 创建 CURLFile 对象

说明

面向对象风格

public CURLFile::__construct ( string $filename , string $mimetype = ? , string $postname = ? )

过程化风格

curl_file_create ( string $filename , string $mimetype = ? , string $postname = ? ) : CURLFile

创建 CURLFile 对象，使用 CURLOPT_POSTFIELDS 选项上传文件。

参数

filename

被上传文件的 路径。

mimetype

被上传文件的 MIME 类型。

postname

上传数据里面的文件名。

返回值

返回 CURLFile 对象。

范例

Example #1 CURLFile::__construct() 示例

面向对象风格

<?php
/* http://example.com/upload.php:
<?php var_dump($_FILES); ?>
*/

// Create a cURL handle
$ch = curl_init('http://example.com/upload.php');

// Create a CURLFile object
$cfile = new CURLFile('cats.jpg','image/jpeg','test_name');

// Assign POST data
$data = array('test_file' => $cfile);
curl_setopt($ch, CURLOPT_POST,1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

// Execute the handle
curl_exec($ch);
?>

过程化风格

<?php
/* http://example.com/upload.php:
<?php var_dump($_FILES); ?>
*/

// Create a cURL handle
$ch = curl_init('http://example.com/upload.php');

// Create a CURLFile object
$cfile = curl_file_create('cats.jpg','image/jpeg','test_name');

// Assign POST data
$data = array('test_file' => $cfile);
curl_setopt($ch, CURLOPT_POST,1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

// Execute the handle
curl_exec($ch);
?>

以上例程会输出：

array(1) {
  ["test_file"]=>
  array(5) {
    ["name"]=>
    string(9) "test_name"
    ["type"]=>
    string(10) "image/jpeg"
    ["tmp_name"]=>
    string(14) "/tmp/phpPC9Kbx"
    ["error"]=>
    int(0)
    ["size"]=>
    int(46334)
  }
}

参见

  • curl_setopt() - 设置 cURL 传输选项


获取被上传文件的 文件名

  • ? CURLFile::__construct
  • CURLFile::getMimeType ?
  • PHP Manual
  • CURLFile
  • 获取被上传文件的 文件名

CURLFile::getFilename

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::getFilename — 获取被上传文件的 文件名

说明

public CURLFile::getFilename ( ) : string

参数

此函数没有参数。

返回值

返回被上传文件的 文件名。


获取被上传文件的 MIME 类型

  • ? CURLFile::getFilename
  • CURLFile::getPostFilename ?
  • PHP Manual
  • CURLFile
  • 获取被上传文件的 MIME 类型

CURLFile::getMimeType

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::getMimeType — 获取被上传文件的 MIME 类型

说明

public CURLFile::getMimeType ( ) : string

参数

此函数没有参数。

返回值

返回被上传文件的 MIME 类型。


获取 POST 请求时使用的 文件名

  • ? CURLFile::getMimeType
  • CURLFile::setMimeType ?
  • PHP Manual
  • CURLFile
  • 获取 POST 请求时使用的 文件名

CURLFile::getPostFilename

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::getPostFilename — 获取 POST 请求时使用的 文件名

说明

public CURLFile::getPostFilename ( ) : string

参数

此函数没有参数。

返回值

返回 POST 请求时使用的 文件名。


设置被上传文件的 MIME 类型

  • ? CURLFile::getPostFilename
  • CURLFile::setPostFilename ?
  • PHP Manual
  • CURLFile
  • 设置被上传文件的 MIME 类型

CURLFile::setMimeType

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::setMimeType — 设置被上传文件的 MIME 类型

说明

public CURLFile::setMimeType ( string $mime ) : void

参数

mime

POST 数据中的 MIME 类型。

返回值

没有返回值。


设置 POST 请求时使用的文件名

  • ? CURLFile::setMimeType
  • Event ?
  • PHP Manual
  • CURLFile
  • 设置 POST 请求时使用的文件名

CURLFile::setPostFilename

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

CURLFile::setPostFilename — 设置 POST 请求时使用的文件名

说明

public CURLFile::setPostFilename ( string $postname ) : void

参数

postname

POST 数据里使用的文件名。

返回值

没有返回值。


Event

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 范例
  • Event flags
  • About event persistence
  • Event callbacks
  • Constructing signal events
  • Event — The Event class
    • Event::add — Makes event pending
    • Event::addSignal — Makes signal event pending
    • Event::addTimer — Makes timer event pending
    • Event::__construct — Constructs Event object
    • Event::del — Makes event non-pending
    • Event::delSignal — Makes signal event non-pending
    • Event::delTimer — Makes timer event non-pending
    • Event::free — Make event non-pending and free resources allocated for this event
    • Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent
    • Event::pending — Detects whether event is pending or scheduled
    • Event::set — Re-configures event
    • Event::setPriority — Set event priority
    • Event::setTimer — Re-configures timer event
    • Event::signal — Constructs signal event object
    • Event::timer — Constructs timer event object
  • EventBase — The EventBase class
    • EventBase::__construct — Constructs EventBase object
    • EventBase::dispatch — Dispatch pending events
    • EventBase::exit — Stop dispatching events
    • EventBase::free — Free resources allocated for this event base
    • EventBase::getFeatures — Returns bitmask of features supported
    • EventBase::getMethod — Returns event method in use
    • EventBase::getTimeOfDayCached — Returns the current event base time
    • EventBase::gotExit — Checks if the event loop was told to exit
    • EventBase::gotStop — Checks if the event loop was told to exit
    • EventBase::loop — Dispatch pending events
    • EventBase::priorityInit — Sets number of priorities per event base
    • EventBase::reInit — Re-initialize event base(after a fork)
    • EventBase::stop — Tells event_base to stop dispatching events
  • EventBuffer — The EventBuffer class
    • EventBuffer::add — Append data to the end of an event buffer
    • EventBuffer::addBuffer — Move all data from a buffer provided to the current instance of EventBuffer
    • EventBuffer::appendFrom — Moves the specified number of bytes from a source buffer to the end of the current buffer
    • EventBuffer::__construct — Constructs EventBuffer object
    • EventBuffer::copyout — Copies out specified number of bytes from the front of the buffer
    • EventBuffer::drain — Removes specified number of bytes from the front of the buffer without copying it anywhere
    • EventBuffer::enableLocking — 说明
    • EventBuffer::expand — Reserves space in buffer
    • EventBuffer::freeze — Prevent calls that modify an event buffer from succeeding
    • EventBuffer::lock — Acquires a lock on buffer
    • EventBuffer::prepend — Prepend data to the front of the buffer
    • EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer
    • EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string
    • EventBuffer::read — Read data from an evbuffer and drain the bytes read
    • EventBuffer::readFrom — Read data from a file onto the end of the buffer
    • EventBuffer::readLine — Extracts a line from the front of the buffer
    • EventBuffer::search — Scans the buffer for an occurrence of a string
    • EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line
    • EventBuffer::substr — Substracts a portion of the buffer data
    • EventBuffer::unfreeze — Re-enable calls that modify an event buffer
    • EventBuffer::unlock — Releases lock acquired by EventBuffer::lock
    • EventBuffer::write — Write contents of the buffer to a file or socket
  • EventBufferEvent — The EventBufferEvent class
    • EventBufferEvent::close — Closes file descriptor associated with the current buffer event
    • EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket
    • EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving
    • EventBufferEvent::__construct — Constructs EventBufferEvent object
    • EventBufferEvent::createPair — Creates two buffer events connected to each other
    • EventBufferEvent::disable — Disable events read, write, or both on a buffer event
    • EventBufferEvent::enable — Enable events read, write, or both on a buffer event
    • EventBufferEvent::free — Free a buffer event
    • EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt
    • EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event
    • EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event
    • EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event
    • EventBufferEvent::read — Read buffer's data
    • EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf
    • EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks
    • EventBufferEvent::setPriority — Assign a priority to a bufferevent
    • EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event
    • EventBufferEvent::setWatermark — Adjusts read and/or write watermarks
    • EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event
    • EventBufferEvent::sslFilter — Create a new SSL buffer event to send its data over another buffer event
    • EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher
    • EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection
    • EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection
    • EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection
    • EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation
    • EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket
    • EventBufferEvent::write — Adds data to a buffer event's output buffer
    • EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer
  • About buffer event callbacks
  • EventConfig — The EventConfig class
    • EventConfig::avoidMethod — Tells libevent to avoid specific event method
    • EventConfig::__construct — Constructs EventConfig object
    • EventConfig::requireFeatures — Enters a required event method feature that the application demands
    • EventConfig::setMaxDispatchInterval — Prevents priority inversion
  • EventDnsBase — The EventDnsBase class
    • EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base
    • EventDnsBase::addSearch — Adds a domain to the list of search domains
    • EventDnsBase::clearSearch — Removes all current search suffixes
    • EventDnsBase::__construct — Constructs EventDnsBase object
    • EventDnsBase::countNameservers — Gets the number of configured nameservers
    • EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file
    • EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file
    • EventDnsBase::setOption — Set the value of a configuration option
    • EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches
  • EventHttp — The EventHttp class
    • EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource
    • EventHttp::addServerAlias — Adds a server alias to the HTTP server object
    • EventHttp::bind — Binds an HTTP server on the specified address and port
    • EventHttp::__construct — Constructs EventHttp object(the HTTP server)
    • EventHttp::removeServerAlias — Removes server alias
    • EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
    • EventHttp::setCallback — Sets a callback for specified URI
    • EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks
    • EventHttp::setMaxBodySize — Sets maximum request body size
    • EventHttp::setMaxHeadersSize — Sets maximum HTTP header size
    • EventHttp::setTimeout — Sets the timeout for an HTTP request
  • EventHttpConnection — The EventHttpConnection class
    • EventHttpConnection::__construct — Constructs EventHttpConnection object
    • EventHttpConnection::getBase — Returns event base associated with the connection
    • EventHttpConnection::getPeer — Gets the remote address and port associated with the connection
    • EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection
    • EventHttpConnection::setCloseCallback — Set callback for connection close
    • EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made
    • EventHttpConnection::setLocalPort — Sets the local port from which connections are made
    • EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection
    • EventHttpConnection::setMaxHeadersSize — Sets maximum header size
    • EventHttpConnection::setRetries — Sets the retry limit for the connection
    • EventHttpConnection::setTimeout — Sets the timeout for the connection
  • EventHttpRequest — The EventHttpRequest class
    • EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request
    • EventHttpRequest::cancel — Cancels a pending HTTP request
    • EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request
    • EventHttpRequest::closeConnection — Closes associated HTTP connection
    • EventHttpRequest::__construct — Constructs EventHttpRequest object
    • EventHttpRequest::findHeader — Finds the value belonging a header
    • EventHttpRequest::free — Frees the object and removes associated events
    • EventHttpRequest::getBufferEvent — Returns EventBufferEvent object
    • EventHttpRequest::getCommand — Returns the request command(method)
    • EventHttpRequest::getConnection — Returns EventHttpConnection object
    • EventHttpRequest::getHost — Returns the request host
    • EventHttpRequest::getInputBuffer — Returns the input buffer
    • EventHttpRequest::getInputHeaders — Returns associative array of the input headers
    • EventHttpRequest::getOutputBuffer — Returns the output buffer of the request
    • EventHttpRequest::getOutputHeaders — Returns associative array of the output headers
    • EventHttpRequest::getResponseCode — Returns the response code
    • EventHttpRequest::getUri — Returns the request URI
    • EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request
    • EventHttpRequest::sendError — Send an HTML error message to the client
    • EventHttpRequest::sendReply — Send an HTML reply to the client
    • EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply
    • EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate
    • EventHttpRequest::sendReplyStart — Initiate a chunked reply
  • EventListener — The EventListener class
    • EventListener::__construct — Creates new connection listener associated with an event base
    • EventListener::disable — Disables an event connect listener object
    • EventListener::enable — Enables an event connect listener object
    • EventListener::getBase — Returns event base associated with the event listener
    • EventListener::getSocketName — Retreives the current address to which the listener's socket is bound
    • EventListener::setCallback — The setCallback purpose
    • EventListener::setErrorCallback — Set event listener's error callback
  • EventSslContext — The EventSslContext class
    • EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes
  • EventUtil — The EventUtil class
    • EventUtil::__construct — The abstract constructor
    • EventUtil::getLastSocketErrno — Returns the most recent socket error number
    • EventUtil::getLastSocketError — Returns the most recent socket error
    • EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream
    • EventUtil::getSocketName — Retreives the current address to which the socket is bound
    • EventUtil::setSocketOption — Sets socket options
    • EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()


简介

This is an extension to efficiently schedule I/O, time and signal based events using the best I/O notification mechanism available for specific platform. This is a port of libevent to the PHP infrastructure.

Note:

Note, Windows support introduced in event-1.9.0 .

Version 1.0.0 introduces new object-oriented API (breaking backwards compatibility), and support of libevent 2+ including HTTP, DNS, OpenSSL and the event listener.

Note:

Note, event-1.0.0 and greater is not compatible with previous versions.


需求

This extension requires » libevent library. Most modern distributions provide packages for libevent.

OpenSSL features require » OpenSSL library.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/event .


范例

Example #1 Simple HTTP client

<?php
// Read callback
function readcb($bev, $base) {
    //$input = $bev->input; //$bev->getInput();

    //$pos = $input->search("TTP");
    $pos = $bev->input->search("TTP");

    while (($n = $bev->input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

// Event callback
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

if ($argc != 3) {
    echo <<<EOS
Trivial HTTP 0.x client
Syntax: php {$argv[0]} [hostname] [resource]
Example: php {$argv[0]} www.google.com /

EOS;
    exit();
}

$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // We'll use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb"
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

//$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

$output = $bev->output; //$bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

if (!$bev->connectHost($dns_base, $argv[1], 80, EventUtil::AF_UNSPEC)) {
    exit("Can't connect to host {$argv[1]}\n");
}

$base->dispatch();
?>

以上例程的输出类似于：

Connected.
HTTP/1.1 301 Moved Permanently
Date: Fri, 01 Mar 2013 18:47:48 GMT
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=gb2312
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Age: 133438
Expires: Sat, 30 Mar 2013 05:39:28 GMT
Connection: close

<HTML><HEAD><meta http-equiv="content-type" content="text/html;CHARSET=gb2312">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.co.uk/">here</A>.
</BODY></HTML>
Closing
Done

Example #2 HTTP client using asynchronous DNS resolver

<?php
/*
 * 1. Connect to 127.0.0.1 at port 80
 * by means of EventBufferEvent::connect().
 *
 * 2. Request /index.cphp via HTTP/1.0
 * using the output buffer.
 *
 * 3. Asyncronously read the response and print it to stdout.
 */

// Read callback
function readcb($bev, $base) {
    $input = $bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

// Event callback
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

echo "step 1\n";
$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

echo "step 2\n";
$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

echo "step 3\n";
// Send request
$output = $bev->getOutput();
if (!$output->add(
    "GET /index.cphp HTTP/1.0\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* Connect to the host syncronously.
We know the IP, and don't need to resolve DNS. */
if (!$bev->connect("127.0.0.1:80")) {
    exit("Can't connect to host\n");
}

// Dispatch pending events
$base->dispatch();
?>

Example #3 Echo server

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php listener.php 9881
 *
 * 2) In another terminal window open up connection, e.g.:
 *
 * $ nc 127.0.0.1 9881
 *
 * 3) start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        $this->bev->free();
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer

        // Variant #1
        $bev->output->addBuffer($bev->input);

        /* Variant #2 */
        /*
        $input    = $bev->getInput();
        $output = $bev->getOutput();
        $output->addBuffer($input);
        */
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            //$bev->free();
            $this->__destruct();
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($port) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        // Variant #1
        /*
        $this->socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
        if (!socket_bind($this->socket, '0.0.0.0', $port)) {
            echo "Unable to bind socket\n";
            exit(1);
        }
        $this->listener = new EventListener($this->base,
            array($this, "acceptConnCallback"), $this->base,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, $this->socket);
         */

        // Variant #2
         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "0.0.0.0:$port");

        if (!$this->listener) {
            echo "Couldn't create listener";
            exit(1);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

$port = 9808;

if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$l = new MyListener($port);
$l->dispatch();
?>

Example #4 SSL echo server

<?php
/*
 * SSL echo server
 *
 * To test:
 * 1) Run:
 * $ php examples/ssl-echo-server/server.php 9998
 *
 * 2) in another terminal window run:
 * $ socat - SSL:127.0.0.1:9998,verify=1,cafile=examples/ssl-echo-server/cert.pem
 */

class MySslEchoServer {
    public $port,
        $base,
        $bev,
        $listener,
        $ctx;

    function __construct ($port, $host = "127.0.0.1") {
        $this->port = $port;
        $this->ctx = $this->init_ssl();
        if (!$this->ctx) {
            exit("Failed creating SSL context\n");
        }

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        $this->listener = new EventListener($this->base,
            array($this, "ssl_accept_cb"), $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, "$host:$port");
        if (!$this->listener) {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }
    function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev.
    function ssl_read_cb($bev, $ctx) {
        $in = $bev->input; //$bev->getInput();

        printf("Received %zu bytes\n", $in->length);
        printf("----- data ----\n");
        printf("%ld:\t%s\n", (int) $in->length, $in->pullup(-1));

        $bev->writeBuffer($in);
    }

    // This callback is invoked when some even occurs on the event listener,
    // e.g. connection closed, or an error occurred
    function ssl_event_cb($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            // Fetch errors from the SSL error stack
            while ($err = $bev->sslError()) {
                fprintf(STDERR, "Bufferevent error %s.\n", $err);
            }
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
        }
    }

    // This callback is invoked when a client accepts new connection
    function ssl_accept_cb($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it.
        $this->bev = EventBufferEvent::sslSocket($this->base, $fd, $this->ctx,
            EventBufferEvent::SSL_ACCEPTING, EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->bev) {
            echo "Failed creating ssl buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->bev->enable(Event::READ);
        $this->bev->setCallbacks(array($this, "ssl_read_cb"), NULL,
            array($this, "ssl_event_cb"), NULL);
    }

    // This callback is invoked when we failed to setup new connection for a client
    function accept_error_cb($listener, $ctx) {
        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $this->base->exit(NULL);
    }

    // Initialize SSL structures, create an EventSslContext
    // Optionally create self-signed certificates
    function init_ssl() {
        // We *must* have entropy. Otherwise there's no point to crypto.
        if (!EventUtil::sslRandPoll()) {
            exit("EventUtil::sslRandPoll failed\n");
        }

        $local_cert = __DIR__."/cert.pem";
        $local_pk   = __DIR__."/privkey.pem";

        if (!file_exists($local_cert) || !file_exists($local_pk)) {
            echo "Couldn't read $local_cert or $local_pk file.  To generate a key\n",
                "and self-signed certificate, run:\n",
                "  openssl genrsa -out $local_pk 2048\n",
                "  openssl req -new -key $local_pk -out cert.req\n",
                "  openssl x509 -req -days 365 -in cert.req -signkey $local_pk -out $local_cert\n";

            return FALSE;
        }

        $ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array (
             EventSslContext::OPT_LOCAL_CERT  => $local_cert,
             EventSslContext::OPT_LOCAL_PK    => $local_pk,
             //EventSslContext::OPT_PASSPHRASE  => "echo server",
             EventSslContext::OPT_VERIFY_PEER => true,
             EventSslContext::OPT_ALLOW_SELF_SIGNED => false,
        ));

        return $ctx;
    }
}

// Allow to override the port
$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port\n");
}

$l = new MySslEchoServer($port);
$l->dispatch();
?>

Example #5 Signal handler

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base;

    function __construct($base) {
        $this->base = $base;
    }

    function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        event_base_loopexit($c->base);
    }
}

$base = event_base_new();
$c    = new MyEventSignal($base);
$no   = SIGTERM;
$ev   = evsignal_new($base, $no, array($c,'eventSighandler'), $c);

evsignal_add($ev);

event_base_loop($base);
?>

Example #6 Use libevent's loop to process requests of `eio' extension

<?php
// Callback for eio_nop()
function my_nop_cb($d, $r) {
    echo "step 6\n";
}

$dir = "/tmp/abc-eio-temp";
if (file_exists($dir)) {
    rmdir($dir);
}

echo "step 1\n";

$base = new EventBase();

echo "step 2\n";

eio_init();

eio_mkdir($dir, 0750, EIO_PRI_DEFAULT, "my_nop_cb");

$event = new Event($base, eio_get_event_stream(),
    Event::READ | Event::PERSIST, function ($fd, $events, $base) {
    echo "step 5\n";

    while (eio_nreqs()) {
        eio_poll();
    }

    $base->stop();
}, $base);

echo "step 3\n";

$event->add();

echo "step 4\n";

$base->dispatch();

echo "Done\n";
?>

Example #7 Miscellaneous

<?php
/* {{{ Config & supported stuff */
echo "Supported methods:\n";
foreach (Event::getSupportedMethods() as $m) {
    echo $m, PHP_EOL;
}

// Avoiding "select" method
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

// Create event_base associated with the config
$base = new EventBase($cfg);
echo "Event method used: ", $base->getMethod(), PHP_EOL;

echo "Features:\n";
$features = $base->getFeatures();
($features & EventConfig::FEATURE_ET) and print("ET - edge-triggered IO\n");
($features & EventConfig::FEATURE_O1) and print("O1 - O(1) operation for adding/deletting events\n");
($features & EventConfig::FEATURE_FDS) and print("FDS - arbitrary file descriptor types, and not just sockets\n");

// Require FDS feature
if ($cfg->requireFeatures(EventConfig::FEATURE_FDS)) {
    echo "FDS feature is now requried\n";

    $base = new EventBase($cfg);
    ($base->getFeatures() & EventConfig::FEATURE_FDS)
        and print("FDS - arbitrary file descriptor types, and not just sockets\n");
}
/* }}} */

/* {{{ Base */
$base = new EventBase();
$event = new Event($base, STDIN, Event::READ | Event::PERSIST, function ($fd, $events, $arg) {
    static $max_iterations = 0;

    if (++$max_iterations >= 5) {
        /* exit after 5 iterations with timeout of 2.33 seconds */
        echo "Stopping...\n";
        $arg[0]->exit(2.33);
    }

    echo fgets($fd);
}, array (&$base));

$event->add();
$base->loop();
/* Base }}} */
?>

Example #8 Simple HTTP server

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * $ nc -t 127.0.0.1 8010
 * GET /dump HTTP/1.0
 * Content-Type: text/plain
 * Content-Encoding: UTF-8
 * Connection: close
 * (press Enter)
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 * (press Enter)
 *
 * $ nc -t 127.0.0.1 8010
 * GET /unknown HTTP/1.0
 * Connection: close
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

以上例程的输出类似于：

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close
(press Enter)

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

Example #9 Simple HTTPS server

<?php
/*
 * Simple HTTPS server.
 *
 * 1) Run the server: `php examples/https.php 9999`
 * 2) Test it: `php examples/ssl-connection.php 9999`
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 200;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    $buf = $req->getInputBuffer();
    echo "\n >> Reading input buffer (", $buf->length, ") ...\n";
    while ($s = $buf->read(1024)) {
        echo $s;
    }
    echo "\nNo more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_400($req) {
    $req->sendError(400);
}

function _init_ssl() {
    $local_cert = __DIR__."/ssl-echo-server/cert.pem";
    $local_pk   = __DIR__."/ssl-echo-server/privkey.pem";

    $ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array (
        EventSslContext::OPT_LOCAL_CERT  => $local_cert,
        EventSslContext::OPT_LOCAL_PK    => $local_pk,
        //EventSslContext::OPT_PASSPHRASE  => "test",
        EventSslContext::OPT_ALLOW_SELF_SIGNED => true,
    ));

    return $ctx;
}

$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}
$ip = '0.0.0.0';

$base = new EventBase();
$ctx  = _init_ssl();
$http = new EventHttp($base, $ctx);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setCallback("/err400", "_http_400");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind($ip, $port);
$base->dispatch();

Example #10 OpenSSL connection

<?php
/*
 * Sample OpenSSL client.
 *
 * Usage:
 * 1) Launch a server, e.g.:
 * $ php examples/https.php 9999
 *
 * 2) Launch the client in another terminal:
 * $ php examples/ssl-connection.php 9999
 */

function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

function _init_ssl() {
    $ctx = new EventSslContext(EventSslContext::SSLv3_CLIENT_METHOD, array ());

    return $ctx;
}

// Allow to override the port
$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port\n");
}
$host = '127.0.0.1';

$ctx = _init_ssl();
if (!$ctx) {
    trigger_error("Failed creating SSL context", E_USER_ERROR);
}

$base = new EventBase();
if (!$base) {
    trigger_error("Failed to initialize event base", E_USER_ERROR);
}

$conn = new EventHttpConnection($base, NULL, $host, $port, $ctx);
$conn->setTimeout(50);

$req = new EventHttpRequest("_request_handler", $base);
$req->addHeader("Host", $host, EventHttpRequest::OUTPUT_HEADER);
$buf = $req->getOutputBuffer();
$buf->add("<html>HTML TEST</html>");
//$req->addHeader("Content-Length", $buf->length, EventHttpRequest::OUTPUT_HEADER);
//$req->addHeader("Connection", "close", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_POST, "/dump");

$base->dispatch();
echo "END\n";
?>

Example #11 EventHttpConnection::makeRequest() example

<?php
function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

以上例程的输出类似于：

_request_handler
Success: 200
Body:
PHP, date:
2013-03-13T20:27:52+05:00

Example #12 Connection listener based on a UNIX domain socket

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php unix-domain-listener.php [path-to-socket]
 *
 * 2) In another terminal window open up connection
 * to the socket, e.g.:
 *
 * $ socat - GOPEN:/tmp/1.sock
 *
 * 3) Start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        if ($this->bev) {
            $this->bev->free();
        }
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer
        $bev->output->addBuffer($bev->input);
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
            $bev = NULL;
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($sock_path) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        if (file_exists($sock_path)) {
            unlink($sock_path);
        }

         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "unix:$sock_path");

        if (!$this->listener) {
            trigger_error("Couldn't create listener", E_USER_ERROR);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

if ($argc <= 1) {
    exit("Socket path is not provided\n");
}
$sock_path = $argv[1];

$l = new MyListener($sock_path);
$l->dispatch();
?>

Example #13 Simple SMTP server

<?php
 /*
 * Author: Andrew Rose <hello at andrewrose dot co dot uk>
 *
 * Usage:
 * 1) Prepare cert.pem certificate and privkey.pem private key files.
 * 2) Launch the server script
 * 3) Open TLS connection, e.g.:
 *      $ openssl s_client -connect localhost:25 -starttls smtp -crlf
 * 4) Start testing the commands listed in `cmd` method below.
 */

class Handler {
    public $domainName = FALSE;
    public $connections = [];
    public $buffers = [];
    public $maxRead = 256000;

    public function __construct() {
        $this->ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, [
            EventSslContext::OPT_LOCAL_CERT  => 'cert.pem',
            EventSslContext::OPT_LOCAL_PK    => 'privkey.pem',
            //EventSslContext::OPT_PASSPHRASE  => '',
            EventSslContext::OPT_VERIFY_PEER => false, // change to true with authentic cert
            EventSslContext::OPT_ALLOW_SELF_SIGNED => true // change to false with authentic cert
        ]);

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        if (!$this->listener = new EventListener($this->base,
            [$this, 'ev_accept'],
            $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1,
            '0.0.0.0:25'))
        {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback([$this, 'ev_error']);
        $this->base->dispatch();
    }

    public function ev_accept($listener, $fd, $address, $ctx) {
        static $id = 0;
        $id += 1;

        $this->connections[$id]['clientData'] = '';
        $this->connections[$id]['cnx'] = new EventBufferEvent($this->base, $fd,
            EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->connections[$id]['cnx']) {
            echo "Failed creating buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL,
            [$this, 'ev_error'], $id);
        $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);

        $this->ev_write($id, '220 '.$this->domainName." wazzzap?\r\n");
    }

    function ev_error($listener, $ctx) {
        $errno = EventUtil::getLastSocketErrno();

        fprintf(STDERR, "Got an error %d (%s) on the listener. Shutting down.\n",
            $errno, EventUtil::getLastSocketError());

        if ($errno != 0) {
            $this->base->exit(NULL);
            exit();
        }
    }

    public function ev_close($id) {
        $this->connections[$id]['cnx']->disable(Event::READ | Event::WRITE);
        unset($this->connections[$id]);
    }

    protected function ev_write($id, $string) {
        echo 'S('.$id.'): '.$string;
        $this->connections[$id]['cnx']->write($string);
    }

    public function ev_read($buffer, $id) {
        while($buffer->input->length > 0) {
            $this->connections[$id]['clientData'] .= $buffer->input->read($this->maxRead);
            $clientDataLen = strlen($this->connections[$id]['clientData']);

            if($this->connections[$id]['clientData'][$clientDataLen-1] == "\n"
                && $this->connections[$id]['clientData'][$clientDataLen-2] == "\r")
            {
                // remove the trailing \r\n
                $line = substr($this->connections[$id]['clientData'], 0,
                    strlen($this->connections[$id]['clientData']) - 2);

                $this->connections[$id]['clientData'] = '';
                $this->cmd($buffer, $id, $line);
            }
        }
    }

    protected function cmd($buffer, $id, $line) {
        switch ($line) {
            case strncmp('EHLO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK ehlo\r\n");
                break;

            case strncmp('HELO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK helo\r\n");
                break;

            case strncmp('QUIT', $line, 3):
                $this->ev_write($id, "250 OK quit\r\n");
                $this->ev_close($id);
                break;

            case strncmp('STARTTLS', $line, 3):
                $this->ev_write($id, "220 Ready to start TLS\r\n");
                $this->connections[$id]['cnx'] = EventBufferEvent::sslFilter($this->base,
                    $this->connections[$id]['cnx'], $this->ctx,
                    EventBufferEvent::SSL_ACCEPTING,
                    EventBufferEvent::OPT_CLOSE_ON_FREE);
                $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL, [$this, 'ev_error'], $id);
                $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);
                break;

            default:
                echo 'unknown command: '.$line."\n";
                break;
        }
    }
}

new Handler();


Event flags

Event::READ This flag indicates an event that becomes active when the provided file descriptor (usually a stream resource, or socket) is ready for reading.

Event::WRITE flag indicates an event that becomes active when the provided file descriptor (usually a stream resource, or socket) is ready for writing.

Event::SIGNAL used to implement signal detection. See "Constructing signal events" below.

Event::TIMEOUT indicates an event that becomes active after a timeout elapses. The Event::TIMEOUT flag is ignored when constructing an event: one can either set a timeout when event is added , or not. It is set in the $what argument to the callback function when a timeout has occurred.

See also » Fast portable non-blocking network programming with Libevent, Working with events, Event flags


About event persistence

By default, whenever a pending event becomes active (because its file descriptor is ready to read or write, or because its timeout expires), it becomes non-pending right before its callback is executed. Thus, to make the event pending again one may call Event::add() on it again from inside the callback function.

If the Event::PERSIST flag is set on an event, however, the event is persistent . This means that event remains pending even when its callback is activated. Event::del() method can be called to make it non-pending.

The timeout on a persistent event resets whenever the event's callback runs. Thus, if one has an event with flags Event::READ | Event::PERSIST and a timeout of five seconds, the event will become active:

  1. Whenever the socket or file descriptor is ready for reading.

  2. Whenever five seconds have passed since the event last became active.

See also » Fast portable non-blocking network programming with Libevent, About Event Persistence


Event callbacks

If a callback is registered for an event, it will be called when the event becomes active. To associate a callback with event one can pass a callable to either Event::__construct() , or Event::set() , or one of the factory methods like Event::timer() .

An event callback should match the following prototype:

callback ( mixed $fd = null , int $what = ? , mixed $arg = null ) : void

fd

The file descriptor, stream resource or socket associated with the event. For signal event fd is equal to the signal number.

what

Bit mask of all events triggered.

arg

User custom data.

Event::timer() expects the callback to match the following prototype:

callback ( mixed $arg = null ) : void

arg

User custom data.

Event::signal() expects the callback to match the following prototype:

callback ( int $signum = ? , mixed $arg = null ) : void

signum

The number of the triggered signal(e.g. SIGTERM ).

arg

User custom data.


Constructing signal events

Event can also watch for POSIX-style signals. To construct a handler for a signal, use Event::__construct() constructor with Event::SIGNAL flag, or Event::signal() factory method.

Example #1 Handling SIGTERM signal

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base, $ev;

    public function __construct($base) {
        $this->base = $base;
        $this->ev = Event::signal($base, SIGTERM, array($this, 'eventSighandler'));
        $this->ev->add();
    }

    public function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        $this->base->exit();
    }
}

$base = new EventBase();
$c    = new MyEventSignal($base);

$base->loop();
?>

Note that signal callbacks are run in the event loop after the signal occurs, so it is safe for them to call functions that you are not supposed to call from a regular POSIX signal handler.

See also » Fast portable non-blocking network programming with Libevent, Constructing Signal Events .


The Event class

(PECL event >= 1.2.6-beta)

简介

Event class represents and event firing on a file descriptor being ready to read from or write to; a file descriptor becoming ready to read from or write to(edge-triggered I/O only); a timeout expiring; a signal occuring; a user-triggered event.

Every event is associated with EventBase . However, event will never fire until it is added (via Event::add() ). An added event remains in pending state until the registered event occurs, thus turning it to active state. To handle events user may register a callback which is called when event becomes active. If event is configured persistent , it remains pending. If it is not persistent, it stops being pending when it's callback runs. Event::del() method deletes event, thus making it non-pending. By means of Event::add() method it could be added again.

类摘要

final Event {
/* Constants */
const int ET = 32 ;
const int PERSIST = 16 ;
const int READ = 2 ;
const int WRITE = 4 ;
const int SIGNAL = 8 ;
const int TIMEOUT = 1 ;
/* 属性 */
public readonly bool $pending ;
/* 方法 */
public add ( float $timeout = ? ) : bool
public addSignal ( float $timeout = ? ) : bool
public addTimer ( float $timeout = ? ) : bool
public __construct ( EventBase $base , mixed $fd , int $what , callable $cb , mixed $arg = NULL )
public del ( ) : bool
public delSignal ( ) : bool
public delTimer ( ) : bool
public free ( ) : void
public static getSupportedMethods ( ) : array
public pending ( int $flags ) : bool
public set ( EventBase $base , mixed $fd , int $what = ? , callable $cb = ? , mixed $arg = ? ) : bool
public setPriority ( int $priority ) : bool
public setTimer ( EventBase $base , callable $cb , mixed $arg = ? ) : bool
public static signal ( EventBase $base , int $signum , callable $cb , mixed $arg = ? ) : Event
public static timer ( EventBase $base , callable $cb , mixed $arg = ? ) : Event
}

属性

pending

Whether event is pending. See About event persistence .

预定义常量

Event::ET

Indicates that the event should be edge-triggered, if the underlying event base backend supports edge-triggered events. This affects the semantics of Event::READ and Event::WRITE .

Event::PERSIST

Indicates that the event is persistent. See About event persistence .

Event::READ

This flag indicates an event that becomes active when the provided file descriptor(usually a stream resource, or socket) is ready for reading.

Event::WRITE

This flag indicates an event that becomes active when the provided file descriptor(usually a stream resource, or socket) is ready for reading.

Event::SIGNAL

Used to implement signal detection. See "Constructing signal events" below.

Event::TIMEOUT

This flag indicates an event that becomes active after a timeout elapses.

The Event::TIMEOUT flag is ignored when constructing an event: one can either set a timeout when event is added , or not. It is set in the $what argument to the callback function when a timeout has occurred.

Table of Contents

  • Event::add — Makes event pending
  • Event::addSignal — Makes signal event pending
  • Event::addTimer — Makes timer event pending
  • Event::__construct — Constructs Event object
  • Event::del — Makes event non-pending
  • Event::delSignal — Makes signal event non-pending
  • Event::delTimer — Makes timer event non-pending
  • Event::free — Make event non-pending and free resources allocated for this event
  • Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent
  • Event::pending — Detects whether event is pending or scheduled
  • Event::set — Re-configures event
  • Event::setPriority — Set event priority
  • Event::setTimer — Re-configures timer event
  • Event::signal — Constructs signal event object
  • Event::timer — Constructs timer event object


Makes event pending

  • ? Event
  • Event::addSignal ?
  • PHP Manual
  • Event
  • Makes event pending

Event::add

(PECL event >= 1.2.6-beta)

Event::add — Makes event pending

说明

public Event::add ( float $timeout = ? ) : bool

Marks event pending. Non-pending event will never occur, and the event callback will never be called. In conjuction with Event::del() an event could be re-scheduled by user at any time.

If Event::add() is called on an already pending event, libevent will leave it pending and re-schedule it with the given timeout(if specified). If in this case timeout is not specified, Event::add() has no effect.

参数

timeout

Timeout in seconds.

返回值

Returns true on success. Otherwise false

参见

  • Event::addSignal() - Makes signal event pending
  • Event::addTimer() - Makes timer event pending
  • Event::del() - Makes event non-pending


Makes signal event pending

  • ? Event::add
  • Event::addTimer ?
  • PHP Manual
  • Event
  • Makes signal event pending

Event::addSignal

(PECL event >= 1.2.6-beta)

Event::addSignal — Makes signal event pending

说明

public Event::addSignal ( float $timeout = ? ) : bool

Event::addSignal() is an alias of Event::add()

范例

Example #1 Event::addSignal() example

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base, $ev;

    public function __construct($base) {
        $this->base = $base;
        $this->ev = Event::signal($base, SIGTERM, array($this, 'eventSighandler'));
        $this->ev->addSignal();
    }

    public function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        $this->base->exit();
    }
}

$base = new EventBase();
$c    = new MyEventSignal($base);

$base->loop();
?>

以上例程的输出类似于：

Caught signal 15

参见

  • Event::add() - Makes event pending
  • Event::del() - Makes event non-pending
  • Event::delSignal() - Makes signal event non-pending
  • Event::signal() - Constructs signal event object


Makes timer event pending

  • ? Event::addSignal
  • Event::__construct ?
  • PHP Manual
  • Event
  • Makes timer event pending

Event::addTimer

(PECL event >= 1.2.6-beta)

Event::addTimer — Makes timer event pending

说明

public Event::addTimer ( float $timeout = ? ) : bool

Event::addTimer() is an alias of Event::add()

返回值

范例

Example #1 Event::addTimer() example

<?php
$base = new EventBase();
$n = 2;
$e = Event::timer($base, function($n) use (&$e) {
    echo "$n seconds elapsed\n";
    $e->delTimer();
}, $n);
$e->addTimer($n);
$base->loop();
?>

以上例程的输出类似于：

2 seconds elapsed

参见

  • Event::add() - Makes event pending
  • Event::del() - Makes event non-pending
  • Event::delTimer() - Makes timer event non-pending


Constructs Event object

  • ? Event::addTimer
  • Event::del ?
  • PHP Manual
  • Event
  • Constructs Event object

Event::__construct

(PECL event >= 1.2.6-beta)

Event::__construct — Constructs Event object

说明

public Event::__construct ( EventBase $base , mixed $fd , int $what , callable $cb , mixed $arg = NULL )

Constructs Event object.

参数

base

The event base to associate with.

fd

stream resource, socket resource, or numeric file descriptor. For timer events pass -1 . For signal events pass the signal number, e.g. SIGHUP .

what

Event flags. See Event flags .

cb

The event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

返回值

Returns Event object.

参见

  • Event::signal() - Constructs signal event object
  • Event::timer() - Constructs timer event object


Makes event non-pending

  • ? Event::__construct
  • Event::delSignal ?
  • PHP Manual
  • Event
  • Makes event non-pending

Event::del

(PECL event >= 1.2.6-beta)

Event::del — Makes event non-pending

说明

public Event::del ( ) : bool

Removes an event from the set of monitored events, i.e. makes it non-pending.

参数

此函数没有参数。

返回值

Returns true on success. Otherwise false

参见

  • Event::add() - Makes event pending


Makes signal event non-pending

  • ? Event::del
  • Event::delTimer ?
  • PHP Manual
  • Event
  • Makes signal event non-pending

Event::delSignal

(PECL event >= 1.2.6-beta)

Event::delSignal — Makes signal event non-pending

说明

public Event::delSignal ( ) : bool

Event::delSignal() is an alias of Event::del()

参见

  • Event::del() - Makes event non-pending


Makes timer event non-pending

  • ? Event::delSignal
  • Event::free ?
  • PHP Manual
  • Event
  • Makes timer event non-pending

Event::delTimer

(PECL event >= 1.2.6-beta)

Event::delTimer — Makes timer event non-pending

说明

public Event::delTimer ( ) : bool

Event::delTimer() is an alias of Event::del() .

参见

  • Event::del() - Makes event non-pending


Make event non-pending and free resources allocated for this event

  • ? Event::delTimer
  • Event::getSupportedMethods ?
  • PHP Manual
  • Event
  • Make event non-pending and free resources allocated for this event

Event::free

(PECL event >= 1.2.6-beta)

Event::free — Make event non-pending and free resources allocated for this event

说明

public Event::free ( ) : void

Removes event from the list of events monitored by libevent, and free resources allocated for the event.

Warning

The Event::free() method currently doesn't destruct the object itself. To destruct the object completely call unset() , or assign null.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • Event::__construct() - Constructs Event object


Returns array with of the names of the methods supported in this version of Libevent

  • ? Event::free
  • Event::pending ?
  • PHP Manual
  • Event
  • Returns array with of the names of the methods supported in this version of Libevent

Event::getSupportedMethods

(PECL event >= 1.2.6-beta)

Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent

说明

public static Event::getSupportedMethods ( ) : array

Returns array with of the names of the methods(backends) supported in this version of Libevent.

参数

此函数没有参数。

返回值

Returns array.

参见

  • EventConfig


Detects whether event is pending or scheduled

  • ? Event::getSupportedMethods
  • Event::set ?
  • PHP Manual
  • Event
  • Detects whether event is pending or scheduled

Event::pending

(PECL event >= 1.2.6-beta)

Event::pending — Detects whether event is pending or scheduled

说明

public Event::pending ( int $flags ) : bool

Detects whether event is pending or scheduled

参数

flags

One of, or a composition of the following constants: Event::READ , Event::WRITE , Event::TIMEOUT , Event::SIGNAL .

返回值

Returns true if event is pending or scheduled. Otherwise false.


Re-configures event

  • ? Event::pending
  • Event::setPriority ?
  • PHP Manual
  • Event
  • Re-configures event

Event::set

(PECL event >= 1.2.6-beta)

Event::set — Re-configures event

说明

public Event::set ( EventBase $base , mixed $fd , int $what = ? , callable $cb = ? , mixed $arg = ? ) : bool

Re-configures event. Note, this function doesn't invoke obsolete libevent's event_set. It calls event_assign instead.

参数

base

The event base to associate the event with.

fd

Stream resource, socket resource, or numeric file descriptor. For timer events pass -1 . For signal events pass the signal number, e.g. SIGHUP .

what

See Event flags .

cb

The event callback. See Event callbacks .

arg

Custom data associated with the event. It will be passed to the callback when the event becomes active.

返回值

Returns true on success. Otherwise false.


Set event priority

  • ? Event::set
  • Event::setTimer ?
  • PHP Manual
  • Event
  • Set event priority

Event::setPriority

(PECL event >= 1.2.6-beta)

Event::setPriority — Set event priority

说明

public Event::setPriority ( int $priority ) : bool

Set event priority.

参数

priority

The event priority.

返回值

Returns true on success. Otherwise false.


Re-configures timer event

  • ? Event::setPriority
  • Event::signal ?
  • PHP Manual
  • Event
  • Re-configures timer event

Event::setTimer

(PECL event >= 1.2.6-beta)

Event::setTimer — Re-configures timer event

说明

public Event::setTimer ( EventBase $base , callable $cb , mixed $arg = ? ) : bool

Re-configures timer event. Note, this function doesn't invoke obsolete libevent's event_set . It calls event_assign instead.

参数

base

The event base to associate with.

cb

The timer event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

返回值

Returns true on success. Otherwise false.

参见

  • Event::__construct() - Constructs Event object
  • Event::timer() - Constructs timer event object


Constructs signal event object

  • ? Event::setTimer
  • Event::timer ?
  • PHP Manual
  • Event
  • Constructs signal event object

Event::signal

(PECL event >= 1.2.6-beta)

Event::signal — Constructs signal event object

说明

public static Event::signal ( EventBase $base , int $signum , callable $cb , mixed $arg = ? ) : Event

Constructs signal event object. This is a straightforward method to create a signal event. Note, the generic Event::__construct() method can contruct signal event objects too.

参数

base

The associated event base object.

signum

The signal number.

cb

The signal event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

返回值

Returns Event object on success. Otherwise false.

参见

  • Constructing signal events


Constructs timer event object

  • ? Event::signal
  • EventBase ?
  • PHP Manual
  • Event
  • Constructs timer event object

Event::timer

(PECL event >= 1.2.6-beta)

Event::timer — Constructs timer event object

说明

public static Event::timer ( EventBase $base , callable $cb , mixed $arg = ? ) : Event

Constructs timer event object. This is a straightforward method to create a timer event. Note, the generic Event::__construct() method can contruct signal event objects too.

参数

base

The associated event base object.

cb

The signal event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

返回值

Returns Event object on success. Otherwise false.


The EventBase class

(PECL event >= 1.2.6-beta)

简介

EventBase class represents libevent's event base structure. It holds a set of events and can poll to determine which events are active.

Each event base has a method , or a backend that it uses to determine which events are ready. The recognized methods are: select , poll , epoll , kqueue , devpoll , evport and win32 .

To configure event base to use, or avoid specific backend EventConfig class can be used.

Warning

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

类摘要

final EventBase {
/* Constants */
const int LOOP_ONCE = 1 ;
const int LOOP_NONBLOCK = 2 ;
const int NOLOCK = 1 ;
const int STARTUP_IOCP = 4 ;
const int NO_CACHE_TIME = 8 ;
const int EPOLL_USE_CHANGELIST = 16 ;
/* 方法 */
public __construct ( EventConfig $cfg = ? )
public dispatch ( ) : void
public exit ( float $timeout = ? ) : bool
public free ( ) : void
public getFeatures ( ) : int
public getMethod ( ) : string
public getTimeOfDayCached ( ) : float
public gotExit ( ) : bool
public gotStop ( ) : bool
public loop ( int $flags = ? ) : bool
public priorityInit ( int $n_priorities ) : bool
public reInit ( ) : bool
public stop ( ) : bool
}

预定义常量

EventBase::LOOP_ONCE

Flag used with EventBase::loop() method which means: "block until libevent has an active event, then exit once all active events have had their callbacks run".

EventBase::LOOP_NONBLOCK

Flag used with EventBase::loop() method which means: "do not block: see which events are ready now, run the callbacks of the highest-priority ones, then exit".

EventBase::NOLOCK

Configuration flag. Do not allocate a lock for the event base, even if we have locking set up".

EventBase::STARTUP_IOCP

Windows-only configuration flag. Enables the IOCP dispatcher at startup.

EventBase::NO_CACHE_TIME

Configuration flag. Instead of checking the current time every time the event loop is ready to run timeout callbacks, check after each timeout callback.

EventBase::EPOLL_USE_CHANGELIST

If we are using the epoll backend, this flag says that it is safe to use Libevent's internal change-list code to batch up adds and deletes in order to try to do as few syscalls as possible.

Setting this flag can make code run faster, but it may trigger a Linux bug: it is not safe to use this flag if one has any fds cloned by dup(), or its variants. Doing so will produce strange and hard-to-diagnose bugs.

This flag can also be activated by settnig the EVENT_EPOLL_USE_CHANGELIST environment variable.

This flag has no effect if one winds up using a backend other than epoll .

Table of Contents

  • EventBase::__construct — Constructs EventBase object
  • EventBase::dispatch — Dispatch pending events
  • EventBase::exit — Stop dispatching events
  • EventBase::free — Free resources allocated for this event base
  • EventBase::getFeatures — Returns bitmask of features supported
  • EventBase::getMethod — Returns event method in use
  • EventBase::getTimeOfDayCached — Returns the current event base time
  • EventBase::gotExit — Checks if the event loop was told to exit
  • EventBase::gotStop — Checks if the event loop was told to exit
  • EventBase::loop — Dispatch pending events
  • EventBase::priorityInit — Sets number of priorities per event base
  • EventBase::reInit — Re-initialize event base(after a fork)
  • EventBase::stop — Tells event_base to stop dispatching events


Constructs EventBase object

  • ? EventBase
  • EventBase::dispatch ?
  • PHP Manual
  • EventBase
  • Constructs EventBase object

EventBase::__construct

(PECL event >= 1.2.6-beta)

EventBase::__construct — Constructs EventBase object

说明

public EventBase::__construct ( EventConfig $cfg = ? )

Constructs EventBase object

参数

cfg

Optional EventConfig object.

返回值

Returns EventBase object.

参见

  • EventConfig


Dispatch pending events

  • ? EventBase::__construct
  • EventBase::exit ?
  • PHP Manual
  • EventBase
  • Dispatch pending events

EventBase::dispatch

(PECL event >= 1.2.6-beta)

EventBase::dispatch — Dispatch pending events

说明

public EventBase::dispatch ( ) : void

Wait for events to become active, and run their callbacks. The same as EventBase::loop() with no flags set.

Warning

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

参数

此函数没有参数。

返回值

Returns true on success. Otherwise false.

参见

  • EventBase::loop() - Dispatch pending events


Stop dispatching events

  • ? EventBase::dispatch
  • EventBase::free ?
  • PHP Manual
  • EventBase
  • Stop dispatching events

EventBase::exit

(PECL event >= 1.2.6-beta)

EventBase::exit — Stop dispatching events

说明

public EventBase::exit ( float $timeout = ? ) : bool

Tells event base to stop optionally after given number of seconds.

参数

timeout

Optional number of seconds after which the event base should stop dispatching events.

返回值

Returns true on success. Otherwise false.

参见

  • EventBase::stop() - Tells event_base to stop dispatching events


Free resources allocated for this event base

  • ? EventBase::exit
  • EventBase::getFeatures ?
  • PHP Manual
  • EventBase
  • Free resources allocated for this event base

EventBase::free

(PECL event >= 1.10.0)

EventBase::free — Free resources allocated for this event base

说明

public EventBase::free ( ) : void

Deallocates resources allocated by libevent for the EventBase object.

Warning

The EventBase::free() method doesn't destruct the object itself. To destruct the object completely call unset() , or assign null.

This method does not deallocate or detach any of the events that are currently associated with the EventBase object, or close any of their sockets - beware.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EventBase::__construct() - Constructs EventBase object


Returns bitmask of features supported

  • ? EventBase::free
  • EventBase::getMethod ?
  • PHP Manual
  • EventBase
  • Returns bitmask of features supported

EventBase::getFeatures

(PECL event >= 1.2.6-beta)

EventBase::getFeatures — Returns bitmask of features supported

说明

public EventBase::getFeatures ( ) : int

Returns bitmask of features supported.

参数

此函数没有参数。

返回值

Returns integer representing a bitmask of supported features. See EventConfig::FEATURE_* constants .

范例

Example #1 EventBase::getFeatures() example

<?php
// Avoiding "select" method
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

$base = new EventBase($cfg);

echo "Features:\n";
$features = $base->getFeatures();
($features & EventConfig::FEATURE_ET) and print("ET - edge-triggered IO\n");
($features & EventConfig::FEATURE_O1) and print("O1 - O(1) operation for adding/deletting events\n");
($features & EventConfig::FEATURE_FDS) and print("FDS - arbitrary file descriptor types, and not just sockets\n");
?>

参见

  • EventBase::getMethod() - Returns event method in use
  • EventConfig


Returns event method in use

  • ? EventBase::getFeatures
  • EventBase::getTimeOfDayCached ?
  • PHP Manual
  • EventBase
  • Returns event method in use

EventBase::getMethod

(PECL event >= 1.2.6-beta)

EventBase::getMethod — Returns event method in use

说明

public EventBase::getMethod ( ) : string

参数

此函数没有参数。

返回值

String representing used event method(backend).

范例

Example #1 EventBase::getMethod() example

<?php
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

// Create event_base associated with the config
$base = new EventBase($cfg);
echo "Event method used: ", $base->getMethod(), PHP_EOL;

?>

以上例程的输出类似于：

`select' method avoided
Event method used: epoll

参见

  • EventBase::getFeatures() - Returns bitmask of features supported


Returns the current event base time

  • ? EventBase::getMethod
  • EventBase::gotExit ?
  • PHP Manual
  • EventBase
  • Returns the current event base time

EventBase::getTimeOfDayCached

(PECL event >= 1.2.6-beta)

EventBase::getTimeOfDayCached — Returns the current event base time

说明

public EventBase::getTimeOfDayCached ( ) : float

On success returns the current time(as returned by gettimeofday() ), looking at the cached value in base if possible, and calling gettimeofday() or clock_gettime() as appropriate if there is no cached time.

参数

此函数没有参数。

返回值

Returns the current event base time. On failure returns null.


Checks if the event loop was told to exit

  • ? EventBase::getTimeOfDayCached
  • EventBase::gotStop ?
  • PHP Manual
  • EventBase
  • Checks if the event loop was told to exit

EventBase::gotExit

(PECL event >= 1.2.6-beta)

EventBase::gotExit — Checks if the event loop was told to exit

说明

public EventBase::gotExit ( ) : bool

Checks if the event loop was told to exit by EventBase::exit() .

参数

此函数没有参数。

返回值

Returns true, event loop was told to exit by EventBase::exit() . Otherwise false.

参见

  • EventBase::exit() - Stop dispatching events
  • EventBase::stop() - Tells event_base to stop dispatching events
  • EventBase::gotStop() - Checks if the event loop was told to exit


Checks if the event loop was told to exit

  • ? EventBase::gotExit
  • EventBase::loop ?
  • PHP Manual
  • EventBase
  • Checks if the event loop was told to exit

EventBase::gotStop

(PECL event >= 1.2.6-beta)

EventBase::gotStop — Checks if the event loop was told to exit

说明

public EventBase::gotStop ( ) : bool

Checks if the event loop was told to exit by EventBase::stop() .

参数

此函数没有参数。

返回值

Returns true, event loop was told to stop by EventBase::stop() . Otherwise false.

参见

  • EventBase::exit() - Stop dispatching events
  • EventBase::stop() - Tells event_base to stop dispatching events
  • EventBase::gotExit() - Checks if the event loop was told to exit


Dispatch pending events

  • ? EventBase::gotStop
  • EventBase::priorityInit ?
  • PHP Manual
  • EventBase
  • Dispatch pending events

EventBase::loop

(PECL event >= 1.2.6-beta)

EventBase::loop — Dispatch pending events

说明

public EventBase::loop ( int $flags = ? ) : bool

Wait for events to become active, and run their callbacks.

Warning

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

参数

flags

Optional flags. One of EventBase::LOOP_* constants. See EventBase constants .

返回值

Returns true on success. Otherwise false.

参见

  • EventBase::dispatch() - Dispatch pending events


Sets number of priorities per event base

  • ? EventBase::loop
  • EventBase::reInit ?
  • PHP Manual
  • EventBase
  • Sets number of priorities per event base

EventBase::priorityInit

(PECL event >= 1.2.6-beta)

EventBase::priorityInit — Sets number of priorities per event base

说明

public EventBase::priorityInit ( int $n_priorities ) : bool

Sets number of priorities per event base.

参数

n_priorities

The number of priorities per event base.

返回值

Returns true on success, otherwise false.

参见

  • Event::setPriority() - Set event priority


Re-initialize event base(after a fork)

  • ? EventBase::priorityInit
  • EventBase::stop ?
  • PHP Manual
  • EventBase
  • Re-initialize event base(after a fork)

EventBase::reInit

(PECL event >= 1.2.6-beta)

EventBase::reInit — Re-initialize event base(after a fork)

说明

public EventBase::reInit ( ) : bool

Re-initialize event base. Should be called after a fork.

参数

此函数没有参数。

返回值

Returns true on success. Otherwise false.


Tells event_base to stop dispatching events

  • ? EventBase::reInit
  • EventBuffer ?
  • PHP Manual
  • EventBase
  • Tells event_base to stop dispatching events

EventBase::stop

(PECL event >= 1.2.6-beta)

EventBase::stop — Tells event_base to stop dispatching events

说明

public EventBase::stop ( ) : bool

Tells event_base to stop dispatching events

参数

此函数没有参数。

返回值

Returns true on success. Otherwise false.

参见

  • EventBase::exit() - Stop dispatching events
  • EventBase::gotStop() - Checks if the event loop was told to exit


The EventBuffer class

(PECL event >= 1.5.0)

简介

EventBuffer represents Libevent's "evbuffer", an utility functionality for buffered I/O.

Event buffers are meant to be generally useful for doing the "buffer" part of buffered network I/O.

类摘要

EventBuffer {
/* Constants */
const int EOL_ANY = 0 ;
const int EOL_CRLF = 1 ;
const int EOL_CRLF_STRICT = 2 ;
const int EOL_LF = 3 ;
const int PTR_SET = 0 ;
const int PTR_ADD = 1 ;
/* 属性 */
public readonly int $length ;
public readonly int $contiguous_space ;
/* 方法 */
public add ( string $data ) : bool
public addBuffer ( EventBuffer $buf ) : bool
public appendFrom ( EventBuffer $buf , int $len ) : int
public __construct ( )
public copyout ( string &$data , int $max_bytes ) : int
public drain ( int $len ) : bool
public enableLocking ( ) : void
public expand ( int $len ) : bool
public freeze ( bool $at_front ) : bool
public lock ( ) : void
public prepend ( string $data ) : bool
public prependBuffer ( EventBuffer $buf ) : bool
public pullup ( int $size ) : string
public read ( int $max_bytes ) : string
public read ( mixed $fd , int $howmuch ) : int
public readLine ( int $eol_style ) : string
public search ( string $what , int $start = -1 , int $end = -1 ) : mixed
public searchEol ( int $start = -1 , int $eol_style = EventBuffer::EOL_ANY ) : mixed
public substr ( int $start , int $length = ? ) : string
public unfreeze ( bool $at_front ) : bool
public unlock ( ) : bool
public write ( mixed $fd , int $howmuch = ? ) : int
}

属性

length

The number of bytes stored in an event buffer.

contiguous_space

The number of bytes stored contiguously at the front of the buffer. The bytes in a buffer may be stored in multiple separate chunks of memory; the property returns the number of bytes currently stored in the first chunk.

预定义常量

EventBuffer::EOL_ANY

The end of line is any sequence of any number of carriage return and linefeed characters. This format is not very useful; it exists mainly for backward compatibility.

EventBuffer::EOL_CRLF

The end of the line is an optional carriage return, followed by a linefeed. (In other words, it is either a "\r\n" or a "\n" .) This format is useful in parsing text-based Internet protocols, since the standards generally prescribe a "\r\n" line-terminator, but nonconformant clients sometimes say just "\n" .

EventBuffer::EOL_CRLF_STRICT

The end of a line is a single carriage return, followed by a single linefeed. (This is also known as "\r\n" . The ASCII values are 0x0D 0x0A ).

EventBuffer::EOL_LF

The end of a line is a single linefeed character. (This is also known as "\n" . It is ASCII value is 0x0A .)

EventBuffer::PTR_SET

Flag used as argument of EventBuffer::setPosition() method. If this flag specified, the position pointer is moved to an absolute position within the buffer.

EventBuffer::PTR_ADD

The same as EventBuffer::PTR_SET , except this flag causes EventBuffer::setPosition() method to move position forward up to the specified number of bytes(instead of setting absolute position).

Table of Contents

  • EventBuffer::add — Append data to the end of an event buffer
  • EventBuffer::addBuffer — Move all data from a buffer provided to the current instance of EventBuffer
  • EventBuffer::appendFrom — Moves the specified number of bytes from a source buffer to the end of the current buffer
  • EventBuffer::__construct — Constructs EventBuffer object
  • EventBuffer::copyout — Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain — Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::enableLocking — 说明
  • EventBuffer::expand — Reserves space in buffer
  • EventBuffer::freeze — Prevent calls that modify an event buffer from succeeding
  • EventBuffer::lock — Acquires a lock on buffer
  • EventBuffer::prepend — Prepend data to the front of the buffer
  • EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer
  • EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::read — Read data from an evbuffer and drain the bytes read
  • EventBuffer::readFrom — Read data from a file onto the end of the buffer
  • EventBuffer::readLine — Extracts a line from the front of the buffer
  • EventBuffer::search — Scans the buffer for an occurrence of a string
  • EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line
  • EventBuffer::substr — Substracts a portion of the buffer data
  • EventBuffer::unfreeze — Re-enable calls that modify an event buffer
  • EventBuffer::unlock — Releases lock acquired by EventBuffer::lock
  • EventBuffer::write — Write contents of the buffer to a file or socket


Append data to the end of an event buffer

  • ? EventBuffer
  • EventBuffer::addBuffer ?
  • PHP Manual
  • EventBuffer
  • Append data to the end of an event buffer

EventBuffer::add

(PECL event >= 1.2.6-beta)

EventBuffer::add — Append data to the end of an event buffer

说明

public EventBuffer::add ( string $data ) : bool

Append data to the end of an event buffer.

参数

data

String to be appended to the end of the buffer.

返回值

Returns true on success. Otherwise false.

参见

  • EventBuffer::addBuffer() - Move all data from a buffer provided to the current instance of EventBuffer


Move all data from a buffer provided to the current instance of EventBuffer

  • ? EventBuffer::add
  • EventBuffer::appendFrom ?
  • PHP Manual
  • EventBuffer
  • Move all data from a buffer provided to the current instance of EventBuffer

EventBuffer::addBuffer

(PECL event >= 1.2.6-beta)

EventBuffer::addBuffer — Move all data from a buffer provided to the current instance of EventBuffer

说明

public EventBuffer::addBuffer ( EventBuffer $buf ) : bool

Move all data from the buffer provided in buf parameter to the end of current EventBuffer . This is a destructive add. The data from one buffer moves into the other buffer. However, no unnecessary memory copies occur.

参数

buf

The source EventBuffer object.

返回值

Returns true on success. Otherwise false.

参见

  • EventBuffer::add() - Append data to the end of an event buffer


Moves the specified number of bytes from a source buffer to the end of the current buffer

  • ? EventBuffer::addBuffer
  • EventBuffer::__construct ?
  • PHP Manual
  • EventBuffer
  • Moves the specified number of bytes from a source buffer to the end of the current buffer

EventBuffer::appendFrom

(PECL event >= 1.6.0)

EventBuffer::appendFrom — Moves the specified number of bytes from a source buffer to the end of the current buffer

说明

public EventBuffer::appendFrom ( EventBuffer $buf , int $len ) : int

Moves the specified number of bytes from a source buffer to the end of the current buffer. If there are fewer number of bytes, it moves all the bytes available from the source buffer.

参数

buf

Source buffer.

len

返回值

Returns the number of bytes read.

更新日志

版本 | 说明
PECL event 1.6.0 | Renamed EventBuffer::appendFrom()(the old method name) to EventBuffer::appendFrom().

参见

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read


Constructs EventBuffer object

  • ? EventBuffer::appendFrom
  • EventBuffer::copyout ?
  • PHP Manual
  • EventBuffer
  • Constructs EventBuffer object

EventBuffer::__construct

(PECL event >= 1.2.6-beta)

EventBuffer::__construct — Constructs EventBuffer object

说明

public EventBuffer::__construct ( )

Constructs EventBuffer object

参数

此函数没有参数。

返回值

Returns EventBuffer object.


Copies out specified number of bytes from the front of the buffer

  • ? EventBuffer::__construct
  • EventBuffer::drain ?
  • PHP Manual
  • EventBuffer
  • Copies out specified number of bytes from the front of the buffer

EventBuffer::copyout

(PECL event >= 1.2.6-beta)

EventBuffer::copyout — Copies out specified number of bytes from the front of the buffer

说明

public EventBuffer::copyout ( string &$data , int $max_bytes ) : int

Behaves just like EventBuffer::read() , but does not drain any data from the buffer. I.e. it copies the first max_bytes bytes from the front of the buffer into data . If there are fewer than max_bytes bytes available, the function copies all the bytes there are.

参数

data

Output string.

max_bytes

The number of bytes to copy.

返回值

Returns the number of bytes copied, or -1 on failure.

参见

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer


Removes specified number of bytes from the front of the buffer without copying it anywhere

  • ? EventBuffer::copyout
  • EventBuffer::enableLocking ?
  • PHP Manual
  • EventBuffer
  • Removes specified number of bytes from the front of the buffer without copying it anywhere

EventBuffer::drain

(PECL event >= 1.2.6-beta)

EventBuffer::drain — Removes specified number of bytes from the front of the buffer without copying it anywhere

说明

public EventBuffer::drain ( int $len ) : bool

Behaves as EventBuffer::read() , except that it does not copy the data: it just removes it from the front of the buffer.

参数

len

The number of bytes to remove from the buffer.

返回值

Returns true on success. Otherwise false.

参见

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer


说明

  • ? EventBuffer::drain
  • EventBuffer::expand ?
  • PHP Manual
  • EventBuffer
  • 说明

EventBuffer::enableLocking

(PECL event >= 1.2.6-beta)

EventBuffer::enableLocking —

说明

public EventBuffer::enableLocking ( ) : void

Enable locking on an EventBuffer so that it can safely be used by multiple threads at the same time. When locking is enabled, the lock will be held when callbacks are invoked. This could result in deadlock if you aren't careful. Plan accordingly!

参数

此函数没有参数。

返回值

没有返回值。

参见

  • » Evbuffers and Thread-safety


Reserves space in buffer

  • ? EventBuffer::enableLocking
  • EventBuffer::freeze ?
  • PHP Manual
  • EventBuffer
  • Reserves space in buffer

EventBuffer::expand

(PECL event >= 1.2.6-beta)

EventBuffer::expand — Reserves space in buffer

说明

public EventBuffer::expand ( int $len ) : bool

Alters the last chunk of memory in the buffer, or adds a new chunk, such that the buffer is now large enough to contain len bytes without any further allocations.

参数

len

The number of bytes to reserve for the buffer

返回值

Returns true on success. Otherwise false.


Prevent calls that modify an event buffer from succeeding

  • ? EventBuffer::expand
  • EventBuffer::lock ?
  • PHP Manual
  • EventBuffer
  • Prevent calls that modify an event buffer from succeeding

EventBuffer::freeze

(PECL event >= 1.2.6-beta)

EventBuffer::freeze — Prevent calls that modify an event buffer from succeeding

说明

public EventBuffer::freeze ( bool $at_front ) : bool

Prevent calls that modify an event buffer from succeeding

参数

at_front

Whether to disable changes to the front or end of the buffer.

返回值

Returns true on success. Otherwise false.

参见

  • EventBuffer::unfreeze() - Re-enable calls that modify an event buffer


Acquires a lock on buffer

  • ? EventBuffer::freeze
  • EventBuffer::prepend ?
  • PHP Manual
  • EventBuffer
  • Acquires a lock on buffer

EventBuffer::lock

(PECL event >= 1.2.6-beta)

EventBuffer::lock — Acquires a lock on buffer

说明

public EventBuffer::lock ( ) : void

Acquires a lock on buffer. Can be used in pair with EventBuffer::unlock() to make a set of operations atomic, i.e. thread-safe. Note, it is not needed to lock buffers for individual operations. When locking is enabled(see EventBuffer::enableLocking() ), individual operations on event buffers are already atomic.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EventBuffer::unlock() - Releases lock acquired by EventBuffer::lock


Prepend data to the front of the buffer

  • ? EventBuffer::lock
  • EventBuffer::prependBuffer ?
  • PHP Manual
  • EventBuffer
  • Prepend data to the front of the buffer

EventBuffer::prepend

(PECL event >= 1.2.6-beta)

EventBuffer::prepend — Prepend data to the front of the buffer

说明

public EventBuffer::prepend ( string $data ) : bool

Prepend data to the front of the buffer.

参数

data

String to be prepended to the front of the buffer.

返回值

Returns true on success. Otherwise false.

参见

  • EventBuffer::prependBuffer() - Moves all data from source buffer to the front of current buffer
  • EventBuffer::add() - Append data to the end of an event buffer
  • EventBuffer::addBuffer() - Move all data from a buffer provided to the current instance of EventBuffer


Moves all data from source buffer to the front of current buffer

  • ? EventBuffer::prepend
  • EventBuffer::pullup ?
  • PHP Manual
  • EventBuffer
  • Moves all data from source buffer to the front of current buffer

EventBuffer::prependBuffer

(PECL event >= 1.2.6-beta)

EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer

说明

public EventBuffer::prependBuffer ( EventBuffer $buf ) : bool

Behaves as EventBuffer::addBuffer() , except that it moves data to the front of the buffer.

参数

buf

Source buffer.

返回值

Returns true on success. Otherwise false.

参见

  • EventBuffer::add() - Append data to the end of an event buffer
  • EventBuffer::addBuffer() - Move all data from a buffer provided to the current instance of EventBuffer
  • EventBuffer::prepend() - Prepend data to the front of the buffer


Linearizes data within buffer and returns it's contents as a string

  • ? EventBuffer::prependBuffer
  • EventBuffer::read ?
  • PHP Manual
  • EventBuffer
  • Linearizes data within buffer and returns it's contents as a string

EventBuffer::pullup

(PECL event >= 1.2.6-beta)

EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string

说明

public EventBuffer::pullup ( int $size ) : string

"Linearizes" the first size bytes of the buffer, copying or moving them as needed to ensure that they are all contiguous and occupying the same chunk of memory. If size is negative, the function linearizes the entire buffer.

Warning

Calling EventBuffer::pullup() with a large size can be quite slow, since it potentially needs to copy the entire buffer's contents.

参数

size

The number of bytes required to be contiguous within the buffer.

返回值

If size is greater than the number of bytes in the buffer, the function returns null. Otherwise, EventBuffer::pullup() returns string.

参见

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer


Read data from an evbuffer and drain the bytes read

  • ? EventBuffer::pullup
  • EventBuffer::readFrom ?
  • PHP Manual
  • EventBuffer
  • Read data from an evbuffer and drain the bytes read

EventBuffer::read

(PECL event >= 1.6.0)

EventBuffer::read — Read data from an evbuffer and drain the bytes read

说明

public EventBuffer::read ( int $max_bytes ) : string

Read the first max_bytes from the buffer and drain the bytes read. If more max_bytes are requested than are available in the buffer, it only extracts as many bytes as available.

参数

max_bytes

Maxmimum number of bytes to read from the buffer.

返回值

Returns string read, or false on failure.

更新日志

版本 | 说明
PECL event 1.6.0 | Renamed EventBuffer::read()(the old method name) to EventBuffer::read(). EventBuffer::read() now takes only max_bytes argument; returns string instead of integer.

参见

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer


Read data from a file onto the end of the buffer

  • ? EventBuffer::read
  • EventBuffer::readLine ?
  • PHP Manual
  • EventBuffer
  • Read data from a file onto the end of the buffer

EventBuffer::readFrom

(PECL event >= 1.7.0)

EventBuffer::readFrom — Read data from a file onto the end of the buffer

说明

public EventBuffer::read ( mixed $fd , int $howmuch ) : int

Read data from the file specified by fd onto the end of the buffer.

参数

fd

Socket resource, stream, or numeric file descriptor.

howmuch

Maxmimum number of bytes to read.

返回值

Returns the number of bytes read, or false on failure.

参见

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer


Extracts a line from the front of the buffer

  • ? EventBuffer::readFrom
  • EventBuffer::search ?
  • PHP Manual
  • EventBuffer
  • Extracts a line from the front of the buffer

EventBuffer::readLine

(PECL event >= 1.2.6-beta)

EventBuffer::readLine — Extracts a line from the front of the buffer

说明

public EventBuffer::readLine ( int $eol_style ) : string

Extracts a line from the front of the buffer and returns it in a newly allocated string. If there is not a whole line to read, the function returns null. The line terminator is not included in the copied string.

参数

eol_style

One of EventBuffer:EOL_* constants .

返回值

On success returns the line read from the buffer, otherwise null.

参见

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer


Scans the buffer for an occurrence of a string

  • ? EventBuffer::readLine
  • EventBuffer::searchEol ?
  • PHP Manual
  • EventBuffer
  • Scans the buffer for an occurrence of a string

EventBuffer::search

(PECL event >= 1.2.6-beta)

EventBuffer::search — Scans the buffer for an occurrence of a string

说明

public EventBuffer::search ( string $what , int $start = -1 , int $end = -1 ) : mixed

Scans the buffer for an occurrence of the string what . It returns numeric position of the string, or false if the string was not found.

If the start argument is provided, it points to the position at which the search should begin; otherwise, the search is performed from the start of the string. If end argument provided, the search is performed between start and end buffer positions.

参数

what

String to search.

start

Start search position.

end

End search position.

返回值

Returns numeric position of the first occurance of the string in the buffer, or false if string is not found.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 EventBuffer::search() example

<?php
// Count total occurances of 'str' in 'buf'
function count_instances($buf, $str) {
    $total = 0;
    $p     = 0;
    $i     = 0;

    while (1) {
        $p = $buf->search($str, $p);
        if ($p === FALSE) {
            break;
        }
        ++$total;
        ++$p;
    }

    return $total;
}

$buf = new EventBuffer();
$buf->add("Some string within a string inside another string");
var_dump(count_instances($buf, "str"));
?>

以上例程的输出类似于：

int(3)

参见

  • EventBuffer::searchEol() - Scans the buffer for an occurrence of an end of line


Scans the buffer for an occurrence of an end of line

  • ? EventBuffer::search
  • EventBuffer::substr ?
  • PHP Manual
  • EventBuffer
  • Scans the buffer for an occurrence of an end of line

EventBuffer::searchEol

(PECL event >= 1.5.0)

EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line

说明

public EventBuffer::searchEol ( int $start = -1 , int $eol_style = EventBuffer::EOL_ANY ) : mixed

Scans the buffer for an occurrence of an end of line specified by eol_style parameter . It returns numeric position of the string, or false if the string was not found.

If the start argument is provided, it represents the position at which the search should begin; otherwise, the search is performed from the start of the string. If end argument provided, the search is performed between start and end buffer positions.

参数

start

Start search position.

eol_style

One of EventBuffer:EOL_* constants .

返回值

Returns numeric position of the first occurance of end-of-line symbol in the buffer, or false if not found.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

参见

  • EventBuffer::search() - Scans the buffer for an occurrence of a string


Substracts a portion of the buffer data

  • ? EventBuffer::searchEol
  • EventBuffer::unfreeze ?
  • PHP Manual
  • EventBuffer
  • Substracts a portion of the buffer data

EventBuffer::substr

(PECL event >= 1.6.0)

EventBuffer::substr — Substracts a portion of the buffer data

说明

public EventBuffer::substr ( int $start , int $length = ? ) : string

Substracts up to length bytes of the buffer data beginning at start position.

参数

start

The start position of data to be substracted.

length

Maximum number of bytes to substract.

返回值

Returns the data substracted as a string on success, or false on failure.

参见

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read


Re-enable calls that modify an event buffer

  • ? EventBuffer::substr
  • EventBuffer::unlock ?
  • PHP Manual
  • EventBuffer
  • Re-enable calls that modify an event buffer

EventBuffer::unfreeze

(PECL event >= 1.2.6-beta)

EventBuffer::unfreeze — Re-enable calls that modify an event buffer

说明

public EventBuffer::unfreeze ( bool $at_front ) : bool

Re-enable calls that modify an event buffer.

参数

at_front

Whether to enable events at the front or at the end of the buffer.

返回值

Returns true on success. Otherwise false.

参见

  • EventBuffer::freeze() - Prevent calls that modify an event buffer from succeeding


Releases lock acquired by EventBuffer::lock

  • ? EventBuffer::unfreeze
  • EventBuffer::write ?
  • PHP Manual
  • EventBuffer
  • Releases lock acquired by EventBuffer::lock

EventBuffer::unlock

(PECL event >= 1.2.6-beta)

EventBuffer::unlock — Releases lock acquired by EventBuffer::lock

说明

public EventBuffer::unlock ( ) : bool

Releases lock acquired by EventBuffer::lock() .

参数

此函数没有参数。

返回值

Returns true on success. Otherwise false.

参见

  • EventBuffer::lock() - Acquires a lock on buffer


Write contents of the buffer to a file or socket

  • ? EventBuffer::unlock
  • EventBufferEvent ?
  • PHP Manual
  • EventBuffer
  • Write contents of the buffer to a file or socket

EventBuffer::write

(PECL event >= 1.6.0)

EventBuffer::write — Write contents of the buffer to a file or socket

说明

public EventBuffer::write ( mixed $fd , int $howmuch = ? ) : int

Write contents of the buffer to a file descriptor. The buffer will be drained after the bytes have been successfully written.

参数

fd

Socket resource, stream or numeric file descriptor associated normally associated with a socket.

howmuch

The maximum number of bytes to write.

返回值

Returns the number of bytes written, or false on error.

参见

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read


The EventBufferEvent class

(PECL event >= 1.2.6-beta)

简介

Represents Libevent's buffer event.

Usually an application wants to perform some amount of data buffering in addition to just responding to events. When we want to write data, for example, the usual pattern looks like:

  1. Decide that we want to write some data to a connection; put that data in a buffer.

  2. Wait for the connection to become writable

  3. Write as much of the data as we can

  4. Remember how much we wrote, and if we still have more data to write, wait for the connection to become writable again.

This buffered I/O pattern is common enough that Libevent provides a generic mechanism for it. A "buffer event" consists of an underlying transport (like a socket), a read buffer, and a write buffer. Instead of regular events, which give callbacks when the underlying transport is ready to be read or written, a buffer event invokes its user-supplied callbacks when it has read or written enough data.

类摘要

final EventBufferEvent {
/* Constants */
const int READING = 1 ;
const int WRITING = 2 ;
const int EOF = 16 ;
const int ERROR = 32 ;
const int TIMEOUT = 64 ;
const int CONNECTED = 128 ;
const int OPT_CLOSE_ON_FREE = 1 ;
const int OPT_THREADSAFE = 2 ;
const int OPT_DEFER_CALLBACKS = 4 ;
const int OPT_UNLOCK_CALLBACKS = 8 ;
const int SSL_OPEN = 0 ;
const int SSL_CONNECTING = 1 ;
const int SSL_ACCEPTING = 2 ;
/* 属性 */
public int $fd ;
public int $priority ;
public readonly EventBuffer $input ;
public readonly EventBuffer $output ;
/* 方法 */
public close ( ) : void
public connect ( string $addr ) : bool
public connectHost ( EventDnsBase $dns_base , string $hostname , int $port , int $family = EventUtil::AF_UNSPEC ) : bool
public __construct ( EventBase $base , mixed $socket = null , int $options = 0 , callable $readcb = null , callable $writecb = null , callable $eventcb = null )
public static createPair ( EventBase $base , int $options = 0 ) : array
public disable ( int $events ) : bool
public enable ( int $events ) : bool
public free ( ) : void
public getDnsErrorString ( ) : string
public getEnabled ( ) : int
public getInput ( ) : EventBuffer
public getOutput ( ) : EventBuffer
public read ( int $size ) : string
public readBuffer ( EventBuffer $buf ) : bool
public setCallbacks ( callable $readcb , callable $writecb , callable $eventcb , string $arg = ? ) : void
public setPriority ( int $priority ) : bool
public setTimeouts ( float $timeout_read , float $timeout_write ) : bool
public setWatermark ( int $events , int $lowmark , int $highmark ) : void
public sslError ( ) : string
public static sslFilter ( EventBase $base , EventBufferEvent $underlying , EventSslContext $ctx , int $state , int $options = 0 ) : EventBufferEvent
public sslGetCipherInfo ( ) : string
public sslGetCipherName ( ) : string
public sslGetCipherVersion ( ) : string
public sslGetProtocol ( ) : string
public sslRenegotiate ( ) : void
public static sslSocket ( EventBase $base , mixed $socket , EventSslContext $ctx , int $state , int $options = ? ) : EventBufferEvent
public write ( string $data ) : bool
public writeBuffer ( EventBuffer $buf ) : bool
}

属性

fd

Numeric file descriptor associated with the buffer event. Normally represents a bound socket. Equals to null, if there is no file descriptor(socket) associated with the buffer event.

priority

The priority of the events used to implement the buffer event.

input

Underlying input buffer object( EventBuffer )

output

Underlying output buffer object( EventBuffer )

预定义常量

EventBufferEvent::READING

An event occurred during a read operation on the bufferevent. See the other flags for which event it was.

EventBufferEvent::WRITING

An event occurred during a write operation on the bufferevent. See the other flags for which event it was.

EventBufferEvent::EOF

Got an end-of-file indication on the buffer event.

EventBufferEvent::ERROR

An error occurred during a bufferevent operation. For more information on what the error was, call EventUtil::getLastSocketErrno() and/or EventUtil::getLastSocketError() .

EventBufferEvent::TIMEOUT

EventBufferEvent::CONNECTED

Finished a requested connection on the bufferevent.

EventBufferEvent::OPT_CLOSE_ON_FREE

When the buffer event is freed, close the underlying transport. This will close an underlying socket, free an underlying buffer event, etc.

EventBufferEvent::OPT_THREADSAFE

Automatically allocate locks for the bufferevent, so that it's safe to use from multiple threads.

EventBufferEvent::OPT_DEFER_CALLBACKS

When this flag is set, the bufferevent defers all of its callbacks. See » Fast portable non-blocking network programming with Libevent, Deferred callbacks .

EventBufferEvent::OPT_UNLOCK_CALLBACKS

By default, when the bufferevent is set up to be threadsafe, the buffer event's locks are held whenever the any user-provided callback is invoked. Setting this option makes Libevent release the buffer event's lock when it's invoking the callbacks.

EventBufferEvent::SSL_OPEN

The SSL handshake is done

EventBufferEvent::SSL_CONNECTING

SSL is currently performing negotiation as a client

EventBufferEvent::SSL_ACCEPTING

SSL is currently performing negotiation as a server

Table of Contents

  • EventBufferEvent::close — Closes file descriptor associated with the current buffer event
  • EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket
  • EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving
  • EventBufferEvent::__construct — Constructs EventBufferEvent object
  • EventBufferEvent::createPair — Creates two buffer events connected to each other
  • EventBufferEvent::disable — Disable events read, write, or both on a buffer event
  • EventBufferEvent::enable — Enable events read, write, or both on a buffer event
  • EventBufferEvent::free — Free a buffer event
  • EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt
  • EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event
  • EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event
  • EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event
  • EventBufferEvent::read — Read buffer's data
  • EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf
  • EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks
  • EventBufferEvent::setPriority — Assign a priority to a bufferevent
  • EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event
  • EventBufferEvent::setWatermark — Adjusts read and/or write watermarks
  • EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event
  • EventBufferEvent::sslFilter — Create a new SSL buffer event to send its data over another buffer event
  • EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher
  • EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection
  • EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection
  • EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection
  • EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation
  • EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket
  • EventBufferEvent::write — Adds data to a buffer event's output buffer
  • EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer


Closes file descriptor associated with the current buffer event

  • ? EventBufferEvent
  • EventBufferEvent::connect ?
  • PHP Manual
  • EventBufferEvent
  • Closes file descriptor associated with the current buffer event

EventBufferEvent::close

(PECL event >= 1.10.0)

EventBufferEvent::close — Closes file descriptor associated with the current buffer event

说明

public EventBufferEvent::close ( ) : void

Closes file descriptor associated with the current buffer event.

This method may be used in cases when the EventBufferEvent::OPT_CLOSE_ON_FREE option is not appropriate.

参数

此函数没有参数。

返回值

没有返回值。


Connect buffer event's file descriptor to given address or UNIX socket

  • ? EventBufferEvent::close
  • EventBufferEvent::connectHost ?
  • PHP Manual
  • EventBufferEvent
  • Connect buffer event's file descriptor to given address or UNIX socket

EventBufferEvent::connect

(PECL event >= 1.2.6-beta)

EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket

说明

public EventBufferEvent::connect ( string $addr ) : bool

Connect buffer event's file descriptor to given address(optionally with port), or a UNIX domain socket.

If socket is not assigned to the buffer event, this function allocates a new socket and makes it non-blocking internally.

To resolve DNS names(asyncronously), use EventBufferEvent::connectHost() method.

参数

addr

Should contain an IP address with optional port number, or a path to UNIX domain socket. Recognized formats are:

[IPv6Address]:port
[IPv6Address]
IPv6Address
IPv4Address:port
IPv4Address
unix:path
Note, 'unix:' prefix is currently not case sensitive.

返回值

Returns true on success. Otherwise false.

范例

Example #1 EventBufferEvent::connect() example

<?php
/*
 * 1. Connect to 127.0.0.1 at port 80
 * by means of EventBufferEvent::connect().
 *
 * 2. Request /index.cphp via HTTP/1.0
 * using the output buffer.
 *
 * 3. Asyncronously read the response and print it to stdout.
 */

/* Read callback */
function readcb($bev, $base) {
    $input = $bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

/* Event callback */
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

echo "step 1\n";
$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

echo "step 2\n";
$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

echo "step 3\n";
/* Send request */
$output = $bev->getOutput();
if (!$output->add(
    "GET /index.cphp HTTP/1.0\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* Connect to the host syncronously.
 * We know the IP, and don't need to resolve DNS. */
if (!$bev->connect("127.0.0.1:80")) {
    exit("Can't connect to host\n");
}

/* Dispatch pending events */
$base->dispatch();

以上例程的输出类似于：

step 1
step 2
step 3
Connected.
HTTP/1.1 200 OK
Server: nginx/1.2.6
Date: Sat, 09 Mar 2013 10:06:58 GMT
Content-Type: text/html; CHARSET=gb2312
Connection: close
X-Powered-By: PHP/5.4.11--pl2-gentoo

sdfsdfsf
Closing
Done

Example #2 Connect to UNIX domain socket which presumably is served by a server, read response from the server and output it to the console

<?php
class MyUnixSocketClient {
    private $base, $bev;

    function __construct($base, $sock_path) {
        $this->base = $base;
        $this->bev = new EventBufferEvent($base, NULL, EventBufferEvent::OPT_CLOSE_ON_FREE,
            array ($this, "read_cb"), NULL, array ($this, "event_cb"));

        if (!$this->bev->connect("unix:$sock_path")) {
            trigger_error("Failed to connect to socket `$sock_path'", E_USER_ERROR);
        }

        $this->bev->enable(Event::READ);
    }

    function __destruct() {
        if ($this->bev) {
            $this->bev->free();
            $this->bev = NULL;
        }
    }

    function dispatch() {
        $this->base->dispatch();
    }

    function read_cb($bev, $unused) {
        $in = $bev->input;

        printf("Received %ld bytes\n", $in->length);
        printf("----- data ----\n");
        printf("%ld:\t%s\n", (int) $in->length, $in->pullup(-1));

        $this->bev->free();
        $this->bev = NULL;
        $this->base->exit(NULL);
    }

    function event_cb($bev, $events, $unused) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
            $bev = NULL;
        } elseif ($events & EventBufferEvent::CONNECTED) {
            $bev->output->add("test\n");
        }
    }
}

if ($argc <= 1) {
    exit("Socket path is not provided\n");
}
$sock_path = $argv[1];

$base = new EventBase();
$cl = new MyUnixSocketClient($base, $sock_path);
$cl->dispatch();
?>

以上例程的输出类似于：

Received 5 bytes
----- data ----
5:  test

参见

  • EventBufferEvent::connectHost() - Connects to a hostname with optionally asyncronous DNS resolving


Connects to a hostname with optionally asyncronous DNS resolving

  • ? EventBufferEvent::connect
  • EventBufferEvent::__construct ?
  • PHP Manual
  • EventBufferEvent
  • Connects to a hostname with optionally asyncronous DNS resolving

EventBufferEvent::connectHost

(PECL event >= 1.2.6-beta)

EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving

说明

public EventBufferEvent::connectHost ( EventDnsBase $dns_base , string $hostname , int $port , int $family = EventUtil::AF_UNSPEC ) : bool

Resolves the DNS name hostname, looking for addresses of type family ( EventUtil::AF_* constants). If the name resolution fails, it invokes the event callback with an error event. If it succeeds, it launches a connection attempt just as EventBufferEvent::connect() would.

dns_base is optional. May be null, or an object created with EventDnsBase::__construct() . For asyncronous hostname resolving pass a valid event dns base resource. Otherwise the hostname resolving will block.

Note:

EventDnsBase is available only if Event configured --with-event-extra ( event_extra library, libevent protocol-specific functionality support including HTTP, DNS, and RPC ).

Note:

EventBufferEvent::connectHost() requires libevent-2.0.3-alpha or greater.

参数

dns_base

Object of EventDnsBase in case if DNS is to be resolved asyncronously. Otherwise null.

hostname

Hostname to connect to. Recognized formats are:

www.example.com (hostname)
 1.2.3.4 (ipv4address)
 ::1 (ipv6address)
[::1] ([ipv6address])

port

Port number

family

Address family. EventUtil::AF_UNSPEC , EventUtil::AF_INET , or EventUtil::AF_INET6 . See EventUtil constants .

返回值

Returns true on success. Otherwise false.

范例

Example #1 EventBufferEvent::connectHost() example

<?php
/* Read callback */
function readcb($bev, $base) {
    //$input = $bev->input; //$bev->getInput();

    //$pos = $input->search("TTP");
    $pos = $bev->input->search("TTP");

    while (($n = $bev->input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

/* Event callback */
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // We'll use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb", $base
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

//$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

$output = $bev->output; //$bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

if (!$bev->connectHost($dns_base, $argv[1], 80, EventUtil::AF_UNSPEC)) {
    exit("Can't connect to host {$argv[1]}\n");
}

$base->dispatch();
?>

以上例程的输出类似于：

Connected.
HTTP/1.0 301 Moved Permanently
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=gb2312
Date: Sat, 09 Mar 2013 12:21:19 GMT
Expires: Mon, 08 Apr 2013 12:21:19 GMT
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN

<HTML><HEAD><meta http-equiv="content-type" content="text/html;CHARSET=gb2312">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.co.uk/">here</A>.
</BODY></HTML>
Closing
Done

参见

  • EventBufferEvent::connect() - Connect buffer event's file descriptor to given address or UNIX socket


Constructs EventBufferEvent object

  • ? EventBufferEvent::connectHost
  • EventBufferEvent::createPair ?
  • PHP Manual
  • EventBufferEvent
  • Constructs EventBufferEvent object

EventBufferEvent::__construct

(PECL event >= 1.2.6-beta)

EventBufferEvent::__construct — Constructs EventBufferEvent object

说明

public EventBufferEvent::__construct ( EventBase $base , mixed $socket = null , int $options = 0 , callable $readcb = null , callable $writecb = null , callable $eventcb = null )

Create a buffer event on a socket, stream or a file descriptor. Passing null to socket means that the socket should be created later, e.g. by means of EventBufferEvent::connect() .

参数

base

Event base that should be associated with the new buffer event.

socket

May be created as a stream(not necessarily by means of sockets extension)

options

One of EventBufferEvent::OPT_* constants , or 0 .

readcb

Read event callback. See About buffer event callbacks .

writecb

Write event callback. See About buffer event callbacks .

eventcb

Status-change event callback. See About buffer event callbacks .

arg

A variable that will be passed to all the callbacks.

返回值

Returns buffer event resource optionally associated with socket resource. */

参见

  • EventBufferEvent::sslFilter() - Create a new SSL buffer event to send its data over another buffer event
  • EventBufferEvent::sslSocket() - Creates a new SSL buffer event to send its data over an SSL on a socket


Creates two buffer events connected to each other

  • ? EventBufferEvent::__construct
  • EventBufferEvent::disable ?
  • PHP Manual
  • EventBufferEvent
  • Creates two buffer events connected to each other

EventBufferEvent::createPair

(PECL event >= 1.2.6-beta)

EventBufferEvent::createPair — Creates two buffer events connected to each other

说明

public static EventBufferEvent::createPair ( EventBase $base , int $options = 0 ) : array

Returns array of two EventBufferEvent objects connected to each other. All the usual options are supported, except for EventBufferEvent::OPT_CLOSE_ON_FREE , which has no effect, and EventBufferEvent::OPT_DEFER_CALLBACKS , which is always on.

参数

base

Associated event base

options

EventBufferEvent::OPT_* constants combined with bitwise OR operator.

返回值

Returns array of two EventBufferEvent objects connected to each other.

更新日志

版本 | 说明
PECL event 1.9.0 | Method made static.


Disable events read, write, or both on a buffer event

  • ? EventBufferEvent::createPair
  • EventBufferEvent::enable ?
  • PHP Manual
  • EventBufferEvent
  • Disable events read, write, or both on a buffer event

EventBufferEvent::disable

(PECL event >= 1.2.6-beta)

EventBufferEvent::disable — Disable events read, write, or both on a buffer event

说明

public EventBufferEvent::disable ( int $events ) : bool

Disable events Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

参数

events

返回值

Returns true on success. Otherwise false.

参见

  • EventBufferEvent::enable() - Enable events read, write, or both on a buffer event


Enable events read, write, or both on a buffer event

  • ? EventBufferEvent::disable
  • EventBufferEvent::free ?
  • PHP Manual
  • EventBufferEvent
  • Enable events read, write, or both on a buffer event

EventBufferEvent::enable

(PECL event >= 1.2.6-beta)

EventBufferEvent::enable — Enable events read, write, or both on a buffer event

说明

public EventBufferEvent::enable ( int $events ) : bool

Enable events Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

参数

events

Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

返回值

Returns true on success. Otherwise false.

参见

  • EventBufferEvent::disable() - Disable events read, write, or both on a buffer event


Free a buffer event

  • ? EventBufferEvent::enable
  • EventBufferEvent::getDnsErrorString ?
  • PHP Manual
  • EventBufferEvent
  • Free a buffer event

EventBufferEvent::free

(PECL event >= 1.2.6-beta)

EventBufferEvent::free — Free a buffer event

说明

public EventBufferEvent::free ( ) : void

Free resources allocated by buffer event.

Usually there is no need to call this method, since normally it is done within internal object destructors. However, sometimes we have a long-time script allocating lots of instances, or a script with a heavy memory usage, where we need to free resources as soon as possible. In such cases EventBufferEvent::free() may be used to protect the script against running up to the memory_limit .

参数

此函数没有参数。

返回值

没有返回值。


Returns string describing the last failed DNS lookup attempt

  • ? EventBufferEvent::free
  • EventBufferEvent::getEnabled ?
  • PHP Manual
  • EventBufferEvent
  • Returns string describing the last failed DNS lookup attempt

EventBufferEvent::getDnsErrorString

(PECL event >= 1.2.6-beta)

EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt

说明

public EventBufferEvent::getDnsErrorString ( ) : string

Returns string describing the last failed DNS lookup attempt made by EventBufferEvent::connectHost() , or an empty string, if there is no DNS error detected.

参数

此函数没有参数。

返回值

Returns a string describing DNS lookup error, or an empty string for no error.

参见

  • EventBufferEvent::connectHost() - Connects to a hostname with optionally asyncronous DNS resolving


Returns bitmask of events currently enabled on the buffer event

  • ? EventBufferEvent::getDnsErrorString
  • EventBufferEvent::getInput ?
  • PHP Manual
  • EventBufferEvent
  • Returns bitmask of events currently enabled on the buffer event

EventBufferEvent::getEnabled

(PECL event >= 1.2.6-beta)

EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event

说明

public EventBufferEvent::getEnabled ( ) : int

Returns bitmask of events currently enabled on the buffer event

参数

此函数没有参数。

返回值

Returns integer representing a bitmask of events currently enabled on the buffer event

参见

  • EventBufferEvent::enable() - Enable events read, write, or both on a buffer event
  • EventBufferEvent::disable() - Disable events read, write, or both on a buffer event


Returns underlying input buffer associated with current buffer event

  • ? EventBufferEvent::getEnabled
  • EventBufferEvent::getOutput ?
  • PHP Manual
  • EventBufferEvent
  • Returns underlying input buffer associated with current buffer event

EventBufferEvent::getInput

(PECL event >= 1.2.6-beta)

EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event

说明

public EventBufferEvent::getInput ( ) : EventBuffer

Returns underlying input buffer associated with current buffer event. An input buffer is a storage for data to read.

Note, there is also input property of EventBufferEvent class.

参数

此函数没有参数。

返回值

Returns instance of EventBuffer input buffer associated with current buffer event.

范例

Example #1 Buffer event's read callback

<?php
function readcb($bev, $base) {
    $input = $bev->input; //$bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}
?>

参见

  • EventBufferEvent::getOutput() - Returns underlying output buffer associated with current buffer event


Returns underlying output buffer associated with current buffer event

  • ? EventBufferEvent::getInput
  • EventBufferEvent::read ?
  • PHP Manual
  • EventBufferEvent
  • Returns underlying output buffer associated with current buffer event

EventBufferEvent::getOutput

(PECL event >= 1.2.6-beta)

EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event

说明

public EventBufferEvent::getOutput ( ) : EventBuffer

Returns underlying output buffer associated with current buffer event. An output buffer is a storage for data to be written.

Note, there is also output property of EventBufferEvent class.

参数

此函数没有参数。

返回值

Returns instance of EventBuffer output buffer associated with current buffer event.

范例

Example #1 EventBufferEvent::getOutput() example

<?php
$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // Use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb", $base
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

$bev->enable(Event::READ | Event::WRITE);

$output = $bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* ... */
?>

参见

  • EventBufferEvent::getInput() - Returns underlying input buffer associated with current buffer event


Read buffer's data

  • ? EventBufferEvent::getOutput
  • EventBufferEvent::readBuffer ?
  • PHP Manual
  • EventBufferEvent
  • Read buffer's data

EventBufferEvent::read

(PECL event >= 1.2.6-beta)

EventBufferEvent::read — Read buffer's data

说明

public EventBufferEvent::read ( int $size ) : string

Removes up to size bytes from the input buffer. Returns a string of data read from the input buffer.

参数

size

Maximum number of bytes to read

返回值

Returns string of data read from the input buffer.

参见

  • EventBufferEvent::readBuffer() - Drains the entire contents of the input buffer and places them into buf


Drains the entire contents of the input buffer and places them into buf

  • ? EventBufferEvent::read
  • EventBufferEvent::setCallbacks ?
  • PHP Manual
  • EventBufferEvent
  • Drains the entire contents of the input buffer and places them into buf

EventBufferEvent::readBuffer

(PECL event >= 1.2.6-beta)

EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf

说明

public EventBufferEvent::readBuffer ( EventBuffer $buf ) : bool

Drains the entire contents of the input buffer and places them into buf .

参数

buf

Target buffer

返回值

Returns true on success; Otherwise false.

参见

  • EventBufferEvent::read() - Read buffer's data


Assigns read, write and event(status) callbacks

  • ? EventBufferEvent::readBuffer
  • EventBufferEvent::setPriority ?
  • PHP Manual
  • EventBufferEvent
  • Assigns read, write and event(status) callbacks

EventBufferEvent::setCallbacks

(PECL event >= 1.2.6-beta)

EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks

说明

public EventBufferEvent::setCallbacks ( callable $readcb , callable $writecb , callable $eventcb , string $arg = ? ) : void

Assigns read, write and event(status) callbacks.

参数

readcb

Read event callback. See About buffer event callbacks .

writecb

Write event callback. See About buffer event callbacks .

eventcb

Status-change event callback. See About buffer event callbacks .

arg

A variable that will be passed to all the callbacks.

返回值

没有返回值。

参见

  • EventBufferEvent::__construct() - Constructs EventBufferEvent object


Assign a priority to a bufferevent

  • ? EventBufferEvent::setCallbacks
  • EventBufferEvent::setTimeouts ?
  • PHP Manual
  • EventBufferEvent
  • Assign a priority to a bufferevent

EventBufferEvent::setPriority

(PECL event >= 1.2.6-beta)

EventBufferEvent::setPriority — Assign a priority to a bufferevent

说明

public EventBufferEvent::setPriority ( int $priority ) : bool

Assign a priority to a bufferevent

Warning

Only supported for socket buffer events

参数

priority

Priority value.

返回值

Returns true on success. Otherwise false.


Set the read and write timeout for a buffer event

  • ? EventBufferEvent::setPriority
  • EventBufferEvent::setWatermark ?
  • PHP Manual
  • EventBufferEvent
  • Set the read and write timeout for a buffer event

EventBufferEvent::setTimeouts

(PECL event >= 1.2.6-beta)

EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event

说明

public EventBufferEvent::setTimeouts ( float $timeout_read , float $timeout_write ) : bool

Set the read and write timeout for a buffer event

参数

timeout_read

Read timeout

timeout_write

Write timeout

返回值

Returns true on success. Otherwise false.


Adjusts read and/or write watermarks

  • ? EventBufferEvent::setTimeouts
  • EventBufferEvent::sslError ?
  • PHP Manual
  • EventBufferEvent
  • Adjusts read and/or write watermarks

EventBufferEvent::setWatermark

(PECL event >= 1.2.6-beta)

EventBufferEvent::setWatermark — Adjusts read and/or write watermarks

说明

public EventBufferEvent::setWatermark ( int $events , int $lowmark , int $highmark ) : void

Adjusts the read watermarks, the write watermarks , or both, of a single buffer event.

A buffer event watermark is an edge, a value specifying number of bytes to be read or written before callback is invoked. By default every read/write event triggers a callback invokation. See » Fast portable non-blocking network programming with Libevent: Callbacks and watermarks

参数

events

Bitmask of Event::READ , Event::WRITE , or both.

lowmark

Minimum watermark value.

highmark

Maximum watermark value. 0 means "unlimited".

返回值

没有返回值。


Returns most recent OpenSSL error reported on the buffer event

  • ? EventBufferEvent::setWatermark
  • EventBufferEvent::sslFilter ?
  • PHP Manual
  • EventBufferEvent
  • Returns most recent OpenSSL error reported on the buffer event

EventBufferEvent::sslError

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event

说明

public EventBufferEvent::sslError ( ) : string

Returns most recent OpenSSL error reported on the buffer event.

Note:

This function is available only if Event is compiled with OpenSSL support.

参数

此函数没有参数。

返回值

Returns OpenSSL error string reported on the buffer event, or false, if there is no more error to return.

范例

Example #1 EventBufferEvent::sslError() example

<?php
// This callback is invoked when some even occurs on the event listener,
// e.g. connection closed, or an error occured
function ssl_event_cb($bev, $events, $ctx) {
    if ($events & EventBufferEvent::ERROR) {
        // Fetch errors from the SSL error stack
        while ($err = $bev->sslError()) {
            fprintf(STDERR, "Bufferevent error %s.\n", $err);
        }
    }

    if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
        $bev->free();
    }
}
?>

参见

  • EventBufferEvent::sslRenegotiate() - Tells a bufferevent to begin SSL renegotiation


Create a new SSL buffer event to send its data over another buffer event

  • ? EventBufferEvent::sslError
  • EventBufferEvent::sslGetCipherInfo ?
  • PHP Manual
  • EventBufferEvent
  • Create a new SSL buffer event to send its data over another buffer event

EventBufferEvent::sslFilter

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslFilter — Create a new SSL buffer event to send its data over another buffer event

说明

public static EventBufferEvent::sslFilter ( EventBase $base , EventBufferEvent $underlying , EventSslContext $ctx , int $state , int $options = 0 ) : EventBufferEvent

Create a new SSL buffer event to send its data over another buffer event

Note:

This function is available only if Event is compiled with OpenSSL support.

参数

base

Associated event base.

underlying

A socket buffer event to use for this SSL.

ctx

Object of EventSslContext class.

state

The current state of SSL connection: EventBufferEvent::SSL_OPEN , EventBufferEvent::SSL_ACCEPTING or EventBufferEvent::SSL_CONNECTING .

options

One or more buffer event options.

返回值

Returns a new SSL EventBufferEvent object.

范例

Example #1 Simple SMTP server

<?php
 /*
 * Author: Andrew Rose <hello at andrewrose dot co dot uk>
 *
 * Usage:
 * 1) Prepare cert.pem certificate and privkey.pem private key files.
 * 2) Launch the server script
 * 3) Open TLS connection, e.g.:
 *      $ openssl s_client -connect localhost:25 -starttls smtp -crlf
 * 4) Start testing the commands listed in `cmd` method below.
 */

class Handler {
    public $domainName = FALSE;
    public $connections = [];
    public $buffers = [];
    public $maxRead = 256000;

    public function __construct() {
        $this->ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, [
            EventSslContext::OPT_LOCAL_CERT  => 'cert.pem',
            EventSslContext::OPT_LOCAL_PK    => 'privkey.pem',
            //EventSslContext::OPT_PASSPHRASE  => '',
            EventSslContext::OPT_VERIFY_PEER => false, // change to true with authentic cert
            EventSslContext::OPT_ALLOW_SELF_SIGNED => true // change to false with authentic cert
        ]);

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        if (!$this->listener = new EventListener($this->base,
            [$this, 'ev_accept'],
            $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1,
            '0.0.0.0:25'))
        {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback([$this, 'ev_error']);
        $this->base->dispatch();
    }

    public function ev_accept($listener, $fd, $address, $ctx) {
        static $id = 0;
        $id += 1;

        $this->connections[$id]['clientData'] = '';
        $this->connections[$id]['cnx'] = new EventBufferEvent($this->base, $fd,
            EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->connections[$id]['cnx']) {
            echo "Failed creating buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL,
            [$this, 'ev_error'], $id);
        $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);

        $this->ev_write($id, '220 '.$this->domainName." wazzzap?\r\n");
    }

    function ev_error($listener, $ctx) {
        $errno = EventUtil::getLastSocketErrno();

        fprintf(STDERR, "Got an error %d (%s) on the listener. Shutting down.\n",
            $errno, EventUtil::getLastSocketError());

        if ($errno != 0) {
            $this->base->exit(NULL);
            exit();
        }
    }

    public function ev_close($id) {
        $this->connections[$id]['cnx']->disable(Event::READ | Event::WRITE);
        unset($this->connections[$id]);
    }

    protected function ev_write($id, $string) {
        echo 'S('.$id.'): '.$string;
        $this->connections[$id]['cnx']->write($string);
    }

    public function ev_read($buffer, $id) {
        while($buffer->input->length > 0) {
            $this->connections[$id]['clientData'] .= $buffer->input->read($this->maxRead);
            $clientDataLen = strlen($this->connections[$id]['clientData']);

            if($this->connections[$id]['clientData'][$clientDataLen-1] == "\n"
                && $this->connections[$id]['clientData'][$clientDataLen-2] == "\r")
            {
                // remove the trailing \r\n
                $line = substr($this->connections[$id]['clientData'], 0,
                    strlen($this->connections[$id]['clientData']) - 2);

                $this->connections[$id]['clientData'] = '';
                $this->cmd($buffer, $id, $line);
            }
        }
    }

    protected function cmd($buffer, $id, $line) {
        switch ($line) {
            case strncmp('EHLO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK ehlo\r\n");
                break;

            case strncmp('HELO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK helo\r\n");
                break;

            case strncmp('QUIT', $line, 3):
                $this->ev_write($id, "250 OK quit\r\n");
                $this->ev_close($id);
                break;

            case strncmp('STARTTLS', $line, 3):
                $this->ev_write($id, "220 Ready to start TLS\r\n");
                $this->connections[$id]['cnx'] = EventBufferEvent::sslFilter($this->base,
                    $this->connections[$id]['cnx'], $this->ctx,
                    EventBufferEvent::SSL_ACCEPTING,
                    EventBufferEvent::OPT_CLOSE_ON_FREE);
                $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL, [$this, 'ev_error'], $id);
                $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);
                break;

            default:
                echo 'unknown command: '.$line."\n";
                break;
        }
    }
}

new Handler();

参见

  • EventBufferEvent::sslSocket() - Creates a new SSL buffer event to send its data over an SSL on a socket


Returns a textual description of the cipher

  • ? EventBufferEvent::sslFilter
  • EventBufferEvent::sslGetCipherName ?
  • PHP Manual
  • EventBufferEvent
  • Returns a textual description of the cipher

EventBufferEvent::sslGetCipherInfo

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher

说明

public EventBufferEvent::sslGetCipherInfo ( ) : string

Retrieves description of the current cipher by means of the SSL_CIPHER_description SSL API function (see SSL_CIPHER_get_name(3) man page).

Note:

This function is available only if Event is compiled with OpenSSL support.

参数

此函数没有参数。

返回值

Returns a textual description of the cipher on success, or false on error.


Returns the current cipher name of the SSL connection

  • ? EventBufferEvent::sslGetCipherInfo
  • EventBufferEvent::sslGetCipherVersion ?
  • PHP Manual
  • EventBufferEvent
  • Returns the current cipher name of the SSL connection

EventBufferEvent::sslGetCipherName

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection

说明

public EventBufferEvent::sslGetCipherName ( ) : string

Retrieves name of cipher used by current SSL connection.

Note:

This function is available only if Event is compiled with OpenSSL support.

参数

此函数没有参数。

返回值

Returns the current cipher name of the SSL connection, or false on error.


Returns version of cipher used by current SSL connection

  • ? EventBufferEvent::sslGetCipherName
  • EventBufferEvent::sslGetProtocol ?
  • PHP Manual
  • EventBufferEvent
  • Returns version of cipher used by current SSL connection

EventBufferEvent::sslGetCipherVersion

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection

说明

public EventBufferEvent::sslGetCipherVersion ( ) : string

Retrieves version of cipher used by current SSL connection.

Note:

This function is available only if Event is compiled with OpenSSL support.

参数

此函数没有参数。

返回值

Returns the current cipher version of the SSL connection, or false on error.


Returns the name of the protocol used for current SSL connection

  • ? EventBufferEvent::sslGetCipherVersion
  • EventBufferEvent::sslRenegotiate ?
  • PHP Manual
  • EventBufferEvent
  • Returns the name of the protocol used for current SSL connection

EventBufferEvent::sslGetProtocol

(PECL event >= 1.10.0)

EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection

说明

public EventBufferEvent::sslGetProtocol ( ) : string

Returns the name of the protocol used for current SSL connection.

Note:

This function is available only if Event is compiled with OpenSSL support.

参数

此函数没有参数。

返回值

Returns the name of the protocol used for current SSL connection.


Tells a bufferevent to begin SSL renegotiation

  • ? EventBufferEvent::sslGetProtocol
  • EventBufferEvent::sslSocket ?
  • PHP Manual
  • EventBufferEvent
  • Tells a bufferevent to begin SSL renegotiation

EventBufferEvent::sslRenegotiate

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation

说明

public EventBufferEvent::sslRenegotiate ( ) : void

Tells a bufferevent to begin SSL renegotiation.

Warning

Calling this function tells the SSL to renegotiate, and the buffer event to invoke appropriate callbacks. This is an advanced topic; this should be generally avoided unless one really knows what he/she does, especially since many SSL versions have had known security issues related to renegotiation.

参数

此函数没有参数。

返回值

没有返回值。


Creates a new SSL buffer event to send its data over an SSL on a socket

  • ? EventBufferEvent::sslRenegotiate
  • EventBufferEvent::write ?
  • PHP Manual
  • EventBufferEvent
  • Creates a new SSL buffer event to send its data over an SSL on a socket

EventBufferEvent::sslSocket

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket

说明

public static EventBufferEvent::sslSocket ( EventBase $base , mixed $socket , EventSslContext $ctx , int $state , int $options = ? ) : EventBufferEvent

Creates a new SSL buffer event to send its data over an SSL on a socket.

参数

base

Associated event base.

socket

Socket to use for this SSL. Can be stream or socket resource, numeric file descriptor, or null. If socket is null, it is assumed that the file descriptor for the socket will be assigned later, for instance, by means of EventBufferEvent::connectHost() method.

ctx

Object of EventSslContext class.

state

The current state of SSL connection: EventBufferEvent::SSL_OPEN , EventBufferEvent::SSL_ACCEPTING or EventBufferEvent::SSL_CONNECTING .

options

The buffer event options.

返回值

Returns EventBufferEvent object.

参见

  • EventBufferEvent::sslFilter() - Create a new SSL buffer event to send its data over another buffer event


Adds data to a buffer event's output buffer

  • ? EventBufferEvent::sslSocket
  • EventBufferEvent::writeBuffer ?
  • PHP Manual
  • EventBufferEvent
  • Adds data to a buffer event's output buffer

EventBufferEvent::write

(PECL event >= 1.2.6-beta)

EventBufferEvent::write — Adds data to a buffer event's output buffer

说明

public EventBufferEvent::write ( string $data ) : bool

Adds data to a buffer event's output buffer

参数

data

Data to be added to the underlying buffer.

返回值

Returns true on success. Otherwise false.

参见

  • EventBufferEvent::writeBuffer() - Adds contents of the entire buffer to a buffer event's output buffer


Adds contents of the entire buffer to a buffer event's output buffer

  • ? EventBufferEvent::write
  • About buffer event callbacks ?
  • PHP Manual
  • EventBufferEvent
  • Adds contents of the entire buffer to a buffer event's output buffer

EventBufferEvent::writeBuffer

(PECL event >= 1.2.6-beta)

EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer

说明

public EventBufferEvent::writeBuffer ( EventBuffer $buf ) : bool

Adds contents of the entire buffer to a buffer event's output buffer

参数

buf

Source EventBuffer object.

返回值

Returns true on success. Otherwise false.

参见

  • EventBufferEvent::write() - Adds data to a buffer event's output buffer


About buffer event callbacks

An object of EventBufferEvent class represents a buffer event . The asynchronous nature of I/O performed by Libevent implies that a socket(or other kind of file descriptor) is not always available. Event invokes corresponding callbacks when the resource becomes available for reading or writing, or when some event occurs(e.g. error, "end of line" etc.).

Read and write callbacks should match the following prototype:

callback ( EventBufferEvent $bev = null , mixed $arg = null ) : void

bev

Associated EventBufferEvent object.

arg

Custom variable attached to all callbacks via EventBufferEvent::__construct() , or EventBufferEvent::setCallbacks() .

Event callback should match the following prototype:

callback ( EventBufferEvent $bev = null , int $events = 0 , mixed $arg = null ) : void

bev

Associated EventBufferEvent object.

events

Bit mask of events: EventBufferEvent::READING , EventBufferEvent::WRITING , EventBufferEvent::EOL , EventBufferEvent::ERROR and EventBufferEvent::TIMEOUT . See EventBufferEvent constants

arg

Custom variable attached to all callbacks via EventBufferEvent::__construct() , or EventBufferEvent::setCallbacks() .


The EventConfig class

(PECL event >= 1.2.6-beta)

简介

Represents configuration structure which could be used in construction of the EventBase .

类摘要

final EventConfig {
/* Constants */
const int FEATURE_ET = 1 ;
const int FEATURE_O1 = 2 ;
const int FEATURE_FDS = 4 ;
/* 方法 */
public avoidMethod ( string $method ) : bool
public __construct ( )
public requireFeatures ( int $feature ) : bool
public setMaxDispatchInterval ( int $max_interval , int $max_callbacks , int $min_priority ) : void
}

预定义常量

EventConfig::FEATURE_ET

Requires a backend method that supports edge-triggered I/O.

EventConfig::FEATURE_O1

Requires a backend method where adding or deleting a single event, or having a single event become active, is an O(1) operation.

EventConfig::FEATURE_FDS

Requires a backend method that can support arbitrary file descriptor types, and not just sockets.

Table of Contents

  • EventConfig::avoidMethod — Tells libevent to avoid specific event method
  • EventConfig::__construct — Constructs EventConfig object
  • EventConfig::requireFeatures — Enters a required event method feature that the application demands
  • EventConfig::setMaxDispatchInterval — Prevents priority inversion


Tells libevent to avoid specific event method

  • ? EventConfig
  • EventConfig::__construct ?
  • PHP Manual
  • EventConfig
  • Tells libevent to avoid specific event method

EventConfig::avoidMethod

(PECL event >= 1.2.6-beta)

EventConfig::avoidMethod — Tells libevent to avoid specific event method

说明

public EventConfig::avoidMethod ( string $method ) : bool

Tells libevent to avoid specific event method(backend). See » Creating an event base .

参数

method

The backend method to avoid. See EventConfig constants .

返回值

Returns true on success, otherwise false.

范例

Example #1 EventConfig::avoidMethod() example

<?php
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}
?>

参见

  • EventBase::__construct() - Constructs EventBase object


Constructs EventConfig object

  • ? EventConfig::avoidMethod
  • EventConfig::requireFeatures ?
  • PHP Manual
  • EventConfig
  • Constructs EventConfig object

EventConfig::__construct

(PECL event >= 1.2.6-beta)

EventConfig::__construct — Constructs EventConfig object

说明

public EventConfig::__construct ( )

Constructs EventConfig object which could be passed to EventBase::__construct() constructor.

参数

此函数没有参数。

返回值

Returns EventConfig object.

范例

Example #1 EventConfig::__construct() example

<?php
// Avoiding "select" method
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

// Create event_base associated with the config
$base = new EventBase($cfg);

/* Now $base is configured to avoid select backend(method) */
?>

参见

  • EventBase::__construct() - Constructs EventBase object


Enters a required event method feature that the application demands

  • ? EventConfig::__construct
  • EventConfig::setMaxDispatchInterval ?
  • PHP Manual
  • EventConfig
  • Enters a required event method feature that the application demands

EventConfig::requireFeatures

(PECL event >= 1.2.6-beta)

EventConfig::requireFeatures — Enters a required event method feature that the application demands

说明

public EventConfig::requireFeatures ( int $feature ) : bool

Enters a required event method feature that the application demands

参数

feature

Bitmask of required features. See EventConfig::FEATURE_* constants

返回值

范例

Example #1 EventConfig::requireFeatures() example

<?php
$cfg = new EventConfig();

// Create event_base associated with the config
$base = new EventBase($cfg);

// Require FDS feature
if ($cfg->requireFeatures(EventConfig::FEATURE_FDS)) {
    echo "FDS feature is now requried\n";

    $base = new EventBase($cfg);
    ($base->getFeatures() & EventConfig::FEATURE_FDS)
        and print("FDS - arbitrary file descriptor types, and not just sockets\n");
}
?>

以上例程的输出类似于：

FDS feature is now requried
FDS - arbitrary file descriptor types, and not just sockets

参见

  • EventBase::getFeatures() - Returns bitmask of features supported


Prevents priority inversion

  • ? EventConfig::requireFeatures
  • EventDnsBase ?
  • PHP Manual
  • EventConfig
  • Prevents priority inversion

EventConfig::setMaxDispatchInterval

(No version information available, might only be in Git)

EventConfig::setMaxDispatchInterval — Prevents priority inversion

说明

public EventConfig::setMaxDispatchInterval ( int $max_interval , int $max_callbacks , int $min_priority ) : void

Prevents priority inversion by limiting how many low-priority event callbacks can be invoked before checking for more high-priority events.

Note:

Available since libevent 2.1.0-alpha .

参数

max_interval

An interval after which Libevent should stop running callbacks and check for more events, or 0 , if there should be no such interval.

max_callbacks

A number of callbacks after which Libevent should stop running callbacks and check for more events, or -1 , if there should be no such limit.

min_priority

A priority below which max_interval and max_callbacks should not be enforced. If this is set to 0 , they are enforced for events of every priority; if it's set to 1 , they're enforced for events of priority 1 and above, and so on.

返回值

Returns true on success, otherwise false.


The EventDnsBase class

(PECL event >= 1.2.6-beta)

简介

Represents Libevent's DNS base structure. Used to resolve DNS asyncronously, parse configuration files like resolv.conf etc.

类摘要

final EventDnsBase {
/* Constants */
const int OPTION_SEARCH = 1 ;
const int OPTION_NAMESERVERS = 2 ;
const int OPTION_MISC = 4 ;
const int OPTION_HOSTSFILE = 8 ;
const int OPTIONS_ALL = 15 ;
/* 方法 */
public addNameserverIp ( string $ip ) : bool
public addSearch ( string $domain ) : void
public clearSearch ( ) : void
public __construct ( EventBase $base , bool $initialize )
public countNameservers ( ) : int
public loadHosts ( string $hosts ) : bool
public parseResolvConf ( int $flags , string $filename ) : bool
public setOption ( string $option , string $value ) : bool
public setSearchNdots ( int $ndots ) : bool
}

预定义常量

EventDnsBase::OPTION_SEARCH

Tells to read the domain and search fields from the resolv.conf file and the ndots option, and use them to decide which domains(if any) to search for hostnames that aren't fully-qualified.

EventDnsBase::OPTION_NAMESERVERS

Tells to learn the nameservers from the resolv.conf file.

EventDnsBase::OPTION_MISC

EventDnsBase::OPTION_HOSTSFILE

Tells to read a list of hosts from /etc/hosts as part of loading the resolv.conf file.

EventDnsBase::OPTIONS_ALL

Tells to learn as much as it can from the resolv.conf file.

Table of Contents

  • EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base
  • EventDnsBase::addSearch — Adds a domain to the list of search domains
  • EventDnsBase::clearSearch — Removes all current search suffixes
  • EventDnsBase::__construct — Constructs EventDnsBase object
  • EventDnsBase::countNameservers — Gets the number of configured nameservers
  • EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file
  • EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file
  • EventDnsBase::setOption — Set the value of a configuration option
  • EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches


Adds a nameserver to the DNS base

  • ? EventDnsBase
  • EventDnsBase::addSearch ?
  • PHP Manual
  • EventDnsBase
  • Adds a nameserver to the DNS base

EventDnsBase::addNameserverIp

(PECL event >= 1.2.6-beta)

EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base

说明

public EventDnsBase::addNameserverIp ( string $ip ) : bool

Adds a nameserver to the evdns_base.

参数

ip

The nameserver string, either as an IPv4 address, an IPv6 address, an IPv4 address with a port ( IPv4:Port ), or an IPv6 address with a port ( [IPv6]:Port ).

返回值

Returns true on success. Otherwise false.


Adds a domain to the list of search domains

  • ? EventDnsBase::addNameserverIp
  • EventDnsBase::clearSearch ?
  • PHP Manual
  • EventDnsBase
  • Adds a domain to the list of search domains

EventDnsBase::addSearch

(PECL event >= 1.2.6-beta)

EventDnsBase::addSearch — Adds a domain to the list of search domains

说明

public EventDnsBase::addSearch ( string $domain ) : void

Adds a domain to the list of search domains

参数

domain

Search domain.

返回值

没有返回值。


Removes all current search suffixes

  • ? EventDnsBase::addSearch
  • EventDnsBase::__construct ?
  • PHP Manual
  • EventDnsBase
  • Removes all current search suffixes

EventDnsBase::clearSearch

(PECL event >= 1.2.6-beta)

EventDnsBase::clearSearch — Removes all current search suffixes

说明

public EventDnsBase::clearSearch ( ) : void

Removes all current search suffixes from the DNS base; the EventDnsBase::addSearch() function adds a suffix.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EventDnsBase::addSearch() - Adds a domain to the list of search domains


Constructs EventDnsBase object

  • ? EventDnsBase::clearSearch
  • EventDnsBase::countNameservers ?
  • PHP Manual
  • EventDnsBase
  • Constructs EventDnsBase object

EventDnsBase::__construct

(PECL event >= 1.2.6-beta)

EventDnsBase::__construct — Constructs EventDnsBase object

说明

public EventDnsBase::__construct ( EventBase $base , bool $initialize )

Constructs EventDnsBase object.

参数

base

Event base.

initialize

If the initialize argument is true, it tries to configure the DNS base sensibly given your operating system's default. Otherwise, it leaves the event DNS base empty, with no nameservers or options configured. In the latter case DNS base should be configured manually, e.g. with EventDnsBase::parseResolvConf() .

返回值

Returns EventDnsBase object.


Gets the number of configured nameservers

  • ? EventDnsBase::__construct
  • EventDnsBase::loadHosts ?
  • PHP Manual
  • EventDnsBase
  • Gets the number of configured nameservers

EventDnsBase::countNameservers

(PECL event >= 1.2.6-beta)

EventDnsBase::countNameservers — Gets the number of configured nameservers

说明

public EventDnsBase::countNameservers ( ) : int

Gets the number of configured nameservers

参数

此函数没有参数。

返回值

Returns the number of configured nameservers(not necessarily the number of running nameservers). This is useful for double-checking whether our calls to the various nameserver configuration functions have been successful.


Loads a hosts file (in the same format as /etc/hosts) from hosts file

  • ? EventDnsBase::countNameservers
  • EventDnsBase::parseResolvConf ?
  • PHP Manual
  • EventDnsBase
  • Loads a hosts file (in the same format as /etc/hosts) from hosts file

EventDnsBase::loadHosts

(PECL event >= 1.2.6-beta)

EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file

说明

public EventDnsBase::loadHosts ( string $hosts ) : bool

Loads a hosts file (in the same format as /etc/hosts ) from hosts file.

参数

hosts

Path to the hosts' file.

返回值

Returns true on success. Otherwise false.


Scans the resolv.conf-formatted file

  • ? EventDnsBase::loadHosts
  • EventDnsBase::setOption ?
  • PHP Manual
  • EventDnsBase
  • Scans the resolv.conf-formatted file

EventDnsBase::parseResolvConf

(PECL event >= 1.2.6-beta)

EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file

说明

public EventDnsBase::parseResolvConf ( int $flags , string $filename ) : bool

Scans the resolv.conf-formatted file stored in filename, and read in all the options from it that are listed in flags

参数

flags

Determines what information is parsed from the resolv.conf file. See the man page for resolv.conf for the format of this file.

The following directives are not parsed from the file: sortlist, rotate, no-check-names, inet6, debug .

If this function encounters an error, the possible return values are:

  • 1 = failed to open file
  • 2 = failed to stat file
  • 3 = file too large
  • 4 = out of memory
  • 5 = short read from file
  • 6 = no nameservers listed in the file

filename

Path to resolv.conf file.

返回值

Returns true on success. Otherwise false.


Set the value of a configuration option

  • ? EventDnsBase::parseResolvConf
  • EventDnsBase::setSearchNdots ?
  • PHP Manual
  • EventDnsBase
  • Set the value of a configuration option

EventDnsBase::setOption

(PECL event >= 1.2.6-beta)

EventDnsBase::setOption — Set the value of a configuration option

说明

public EventDnsBase::setOption ( string $option , string $value ) : bool

Set the value of a configuration option.

参数

option

The currently available configuration options are: "ndots" , "timeout" , "max-timeouts" , "max-inflight" , and "attempts" .

value

Option value.

返回值

Returns true on success. Otherwise false.


Set the 'ndots' parameter for searches

  • ? EventDnsBase::setOption
  • EventHttp ?
  • PHP Manual
  • EventDnsBase
  • Set the 'ndots' parameter for searches

EventDnsBase::setSearchNdots

(PECL event >= 1.2.6-beta)

EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches

说明

public EventDnsBase::setSearchNdots ( int $ndots ) : bool

Set the 'ndots' parameter for searches. Sets the number of dots which, when found in a name, causes the first query to be without any search domain.

参数

ndots

The number of dots.

返回值

Returns true on success. Otherwise false.


The EventHttp class

(PECL event >= 1.4.0-beta)

简介

Represents HTTP server.

类摘要

final EventHttp {
/* 方法 */
public accept ( mixed $socket ) : bool
public addServerAlias ( string $alias ) : bool
public bind ( string $address , int $port ) : void
public __construct ( EventBase $base , EventSslContext $ctx = null )
public removeServerAlias ( string $alias ) : bool
public setAllowedMethods ( int $methods ) : void
public setCallback ( string $path , string $cb , string $arg = ? ) : void
public setDefaultCallback ( string $cb , string $arg = ? ) : void
public setMaxBodySize ( int $value ) : void
public setMaxHeadersSize ( int $value ) : void
public setTimeout ( int $value ) : void
}

Table of Contents

  • EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource
  • EventHttp::addServerAlias — Adds a server alias to the HTTP server object
  • EventHttp::bind — Binds an HTTP server on the specified address and port
  • EventHttp::__construct — Constructs EventHttp object(the HTTP server)
  • EventHttp::removeServerAlias — Removes server alias
  • EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
  • EventHttp::setCallback — Sets a callback for specified URI
  • EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks
  • EventHttp::setMaxBodySize — Sets maximum request body size
  • EventHttp::setMaxHeadersSize — Sets maximum HTTP header size
  • EventHttp::setTimeout — Sets the timeout for an HTTP request


Makes an HTTP server accept connections on the specified socket stream or resource

  • ? EventHttp
  • EventHttp::addServerAlias ?
  • PHP Manual
  • EventHttp
  • Makes an HTTP server accept connections on the specified socket stream or resource

EventHttp::accept

(PECL event >= 1.2.6-beta)

EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource

说明

public EventHttp::accept ( mixed $socket ) : bool

Makes an HTTP server accept connections on the specified socket stream or resource. The socket should be ready to accept connections.

Can be called multiple times to accept connections on different sockets.

Note:

To bind a socket, listen , and accept connections on the socket in s single call use EventHttp::bind() . EventHttp::accept() is needed only if one already has a socket ready to accept connections.

参数

socket

Socket resource, stream or numeric file descriptor representing a socket ready to accept connections.

返回值

Returns true on success. Otherwise false.

范例

Example #1 EventHttp::accept() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$addresses = array (
     8091 => "127.0.0.1",
     8092 => "127.0.0.2",
);
$i = 0;

$socket = array();

foreach ($addresses as $port => $ip) {
    echo $ip, " ", $port, PHP_EOL;
    $socket[$i] = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
    if (!socket_bind($socket[$i], $ip, $port)) {
        exit("socket_bind failed\n");
    }
    socket_listen($socket[$i], 0);
    socket_set_nonblock($socket[$i]);

    if (!$http->accept($socket[$i])) {
        echo "Accept failed\n";
        exit(1);
    }

    ++$i;
}

$http->setCallback("/some-page", function() {
 echo "(some-page)\n";
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$http->setDefaultCallback(function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$signal = Event::signal($base, SIGINT, function () use ($base) {
    echo "Caught SIGINT. Stopping...\n";
    $base->stop();
});
$signal->add();

$base->dispatch();
echo "END\n";
// We didn't close sockets, since Libevent already sets
// CLOSE_ON_FREE and CLOSE_ON_EXEC flags on the file
// descriptor associated with the sockets.
?>

以上例程的输出类似于：

Client:
$ nc 127.0.0.1 8091
GET /about HTTP/1.0
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

Server:
127.0.0.1 8091
127.0.0.2 8092
URI: /about
OK

参见

  • EventHttp::bind() - Binds an HTTP server on the specified address and port


Adds a server alias to the HTTP server object

  • ? EventHttp::accept
  • EventHttp::bind ?
  • PHP Manual
  • EventHttp
  • Adds a server alias to the HTTP server object

EventHttp::addServerAlias

(PECL event >= 1.4.0-beta)

EventHttp::addServerAlias — Adds a server alias to the HTTP server object

说明

public EventHttp::addServerAlias ( string $alias ) : bool

Adds a server alias to the HTTP server object.

参数

alias

The alias to add.

返回值

Returns true on success. Otherwise false.

范例

Example #1 EventHttp::addServerAlias() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};

if (!$http->addServerAlias("local.net")) {
    exit("Failed to add server alias\n");
}

$http->setCallback("/about", function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
});
$base->dispatch();
?>

参见

  • EventHttp::removeServerAlias() - Removes server alias


Binds an HTTP server on the specified address and port

  • ? EventHttp::addServerAlias
  • EventHttp::__construct ?
  • PHP Manual
  • EventHttp
  • Binds an HTTP server on the specified address and port

EventHttp::bind

(PECL event >= 1.2.6-beta)

EventHttp::bind — Binds an HTTP server on the specified address and port

说明

public EventHttp::bind ( string $address , int $port ) : void

Binds an HTTP server on the specified address and port.

Can be called multiple times to bind the same HTTP server to multiple different ports.

参数

address

A string containing the IP address to listen(2) on.

port

The port number to listen on.

返回值

Returns true on success. Otherwise false.

范例

Example #1 EventHttp::bind() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};
if (!$http->bind("127.0.0.1", 8089)) {
    exit("bind(2) failed\n");
};

$http->setCallback("/about", function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$base->dispatch();
?>

以上例程的输出类似于：

Client:

$ nc 127.0.0.1 8088
GET /about HTTP/1.0
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

$ nc 127.0.0.1 8089
GET /unknown HTTP/1.0
Connection: close

HTTP/1.1 404 Not Found
Content-Type: text/html
Date: Wed, 13 Mar 2013 04:14:41 GMT
Content-Length: 149
Connection: close

<html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The requested URL /unknown was not found on this server.</p></body></html>

Server:
URI: /about
OK

参见

  • EventHttp::accept() - Makes an HTTP server accept connections on the specified socket stream or resource


Constructs EventHttp object(the HTTP server)

  • ? EventHttp::bind
  • EventHttp::removeServerAlias ?
  • PHP Manual
  • EventHttp
  • Constructs EventHttp object(the HTTP server)

EventHttp::__construct

(PECL event >= 1.2.6-beta)

EventHttp::__construct — Constructs EventHttp object(the HTTP server)

说明

public EventHttp::__construct ( EventBase $base , EventSslContext $ctx = null )

Constructs the HTTP server object.

参数

base

Associated event base.

ctx

EventSslContext class object. Turns plain HTTP server into HTTPS server. It means that if ctx is configured correctly, then the underlying buffer events will be based on OpenSSL sockets. Thus, all traffic will pass through the SSL or TLS.

Note:

This parameter is available only if Event is compiled with OpenSSL support and only with Libevent 2.1.0-alpha and higher.

返回值

Returns EventHttp object.

更新日志

版本 | 说明
PECL event 1.9.0 | OpenSSL support (ctx) added.

范例

Example #1 Simple HTTP server

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * $ nc -t 127.0.0.1 8010
 * GET /dump HTTP/1.0
 * Content-Type: text/plain
 * Content-Encoding: UTF-8
 * Connection: close
 * (press Enter)
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 * (press Enter)
 *
 * $ nc -t 127.0.0.1 8010
 * GET /unknown HTTP/1.0
 * Connection: close
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

以上例程的输出类似于：

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close
(press Enter)

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close


Removes server alias

  • ? EventHttp::__construct
  • EventHttp::setAllowedMethods ?
  • PHP Manual
  • EventHttp
  • Removes server alias

EventHttp::removeServerAlias

(PECL event >= 1.4.0-beta)

EventHttp::removeServerAlias — Removes server alias

说明

public EventHttp::removeServerAlias ( string $alias ) : bool

Removes server alias added with EventHttp::addServerAlias()

参数

alias

The alias to remove.

返回值

Returns true on success. Otherwise false.

参见

  • EventHttp::addServerAlias() - Adds a server alias to the HTTP server object


Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

  • ? EventHttp::removeServerAlias
  • EventHttp::setCallback ?
  • PHP Manual
  • EventHttp
  • Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

EventHttp::setAllowedMethods

(PECL event >= 1.4.0-beta)

EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

说明

public EventHttp::setAllowedMethods ( int $methods ) : void

Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

If not supported they will generate a "405 Method not allowed" response.

By default this includes the following methods: GET , POST , HEAD , PUT , DELETE . See EventHttpRequest::CMD_* constants.

参数

methods

A bit mask of EventHttpRequest::CMD_* constants .

返回值

没有返回值。


Sets a callback for specified URI

  • ? EventHttp::setAllowedMethods
  • EventHttp::setDefaultCallback ?
  • PHP Manual
  • EventHttp
  • Sets a callback for specified URI

EventHttp::setCallback

(PECL event >= 1.4.0-beta)

EventHttp::setCallback — Sets a callback for specified URI

说明

public EventHttp::setCallback ( string $path , string $cb , string $arg = ? ) : void

Sets a callback for specified URI.

参数

path

The path for which to invoke the callback.

cb

The callback callable that gets invoked on requested path . It should match the following prototype:

callback ( EventHttpRequest $req = NULL , mixed $arg = NULL ) : void

req

EventHttpRequest object.

arg

Custom data.

arg

Custom data.

返回值

Returns true on success. Otherwise false.

范例

Example #1 EventHttp::setCallback() example

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

以上例程的输出类似于：

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

参见

  • EventHttp::setDefaultCallback() - Sets default callback to handle requests that are not caught by specific callbacks


Sets default callback to handle requests that are not caught by specific callbacks

  • ? EventHttp::setCallback
  • EventHttp::setMaxBodySize ?
  • PHP Manual
  • EventHttp
  • Sets default callback to handle requests that are not caught by specific callbacks

EventHttp::setDefaultCallback

(PECL event >= 1.4.0-beta)

EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks

说明

public EventHttp::setDefaultCallback ( string $cb , string $arg = ? ) : void

Sets default callback to handle requests that are not caught by specific callbacks

参数

cb

The callback callable . It should match the following prototype:

callback ( EventHttpRequest $req = NULL , mixed $arg = NULL ) : void

req

EventHttpRequest object.

arg

Custom data.

arg

User custom data passed to the callback.

返回值

Returns true on success. Otherwise false.

范例

Example #1 EventHttp::setDefaultCallback() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};

$http->setDefaultCallback(function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
});

$base->dispatch();
?>

参见

  • EventHttp::setCallback() - Sets a callback for specified URI


Sets maximum request body size

  • ? EventHttp::setDefaultCallback
  • EventHttp::setMaxHeadersSize ?
  • PHP Manual
  • EventHttp
  • Sets maximum request body size

EventHttp::setMaxBodySize

(PECL event >= 1.4.0-beta)

EventHttp::setMaxBodySize — Sets maximum request body size

说明

public EventHttp::setMaxBodySize ( int $value ) : void

Sets maximum request body size.

参数

value

The body size in bytes.

返回值

没有返回值。

参见

  • EventHttp::setMaxHeadersSize() - Sets maximum HTTP header size


Sets maximum HTTP header size

  • ? EventHttp::setMaxBodySize
  • EventHttp::setTimeout ?
  • PHP Manual
  • EventHttp
  • Sets maximum HTTP header size

EventHttp::setMaxHeadersSize

(PECL event >= 1.4.0-beta)

EventHttp::setMaxHeadersSize — Sets maximum HTTP header size

说明

public EventHttp::setMaxHeadersSize ( int $value ) : void

Sets maximum HTTP header size.

参数

value

The header size in bytes.

返回值

没有返回值。

参见

  • EventHttp::setMaxHeadersSize()


Sets the timeout for an HTTP request

  • ? EventHttp::setMaxHeadersSize
  • EventHttpConnection ?
  • PHP Manual
  • EventHttp
  • Sets the timeout for an HTTP request

EventHttp::setTimeout

(PECL event >= 1.4.0-beta)

EventHttp::setTimeout — Sets the timeout for an HTTP request

说明

public EventHttp::setTimeout ( int $value ) : void

Sets the timeout for an HTTP request.

参数

value

The timeout in seconds.

返回值

没有返回值。


The EventHttpConnection class

(PECL event >= 1.4.0-beta)

简介

Represents an HTTP connection.

类摘要

EventHttpConnection {
/* 方法 */
public __construct ( EventBase $base , EventDnsBase $dns_base , string $address , int $port , EventSslContext $ctx = null )
public getBase ( ) : EventBase
public getPeer ( string &$address , int &$port ) : void
public makeRequest ( EventHttpRequest $req , int $type , string $uri ) : bool
public setCloseCallback ( callable $callback , mixed $data = ? ) : void
public setLocalAddress ( string $address ) : void
public setLocalPort ( int $port ) : void
public setMaxBodySize ( string $max_size ) : void
public setMaxHeadersSize ( string $max_size ) : void
public setRetries ( int $retries ) : void
public setTimeout ( int $timeout ) : void
}

Table of Contents

  • EventHttpConnection::__construct — Constructs EventHttpConnection object
  • EventHttpConnection::getBase — Returns event base associated with the connection
  • EventHttpConnection::getPeer — Gets the remote address and port associated with the connection
  • EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection
  • EventHttpConnection::setCloseCallback — Set callback for connection close
  • EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made
  • EventHttpConnection::setLocalPort — Sets the local port from which connections are made
  • EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection
  • EventHttpConnection::setMaxHeadersSize — Sets maximum header size
  • EventHttpConnection::setRetries — Sets the retry limit for the connection
  • EventHttpConnection::setTimeout — Sets the timeout for the connection


Constructs EventHttpConnection object

  • ? EventHttpConnection
  • EventHttpConnection::getBase ?
  • PHP Manual
  • EventHttpConnection
  • Constructs EventHttpConnection object

EventHttpConnection::__construct

(PECL event >= 1.2.6-beta)

EventHttpConnection::__construct — Constructs EventHttpConnection object

说明

public EventHttpConnection::__construct ( EventBase $base , EventDnsBase $dns_base , string $address , int $port , EventSslContext $ctx = null )

Constructs EventHttpConnection object.

参数

base

Associated event base.

dns_base

If dns_base is null, hostname resolution will block.

address

The address to connect to.

port

The port to connect to.

ctx

EventSslContext class object. Enables OpenSSL.

Note:

This parameter is available only if Event is compiled with OpenSSL support and only with Libevent 2.1.0-alpha and higher.

返回值

Returns EventHttpConnection object.

更新日志

版本 | 说明
PECL event 1.9.0 | OpenSSL support (ctx) added.


Returns event base associated with the connection

  • ? EventHttpConnection::__construct
  • EventHttpConnection::getPeer ?
  • PHP Manual
  • EventHttpConnection
  • Returns event base associated with the connection

EventHttpConnection::getBase

(PECL event >= 1.2.6-beta)

EventHttpConnection::getBase — Returns event base associated with the connection

说明

public EventHttpConnection::getBase ( ) : EventBase

Returns event base associated with the connection.

参数

此函数没有参数。

返回值

On success returns EventBase object associated with the connection. Otherwise false.


Gets the remote address and port associated with the connection

  • ? EventHttpConnection::getBase
  • EventHttpConnection::makeRequest ?
  • PHP Manual
  • EventHttpConnection
  • Gets the remote address and port associated with the connection

EventHttpConnection::getPeer

(PECL event >= 1.2.6-beta)

EventHttpConnection::getPeer — Gets the remote address and port associated with the connection

说明

public EventHttpConnection::getPeer ( string &$address , int &$port ) : void

Gets the remote address and port associated with the connection

参数

address

Address of the peer.

port

Port of the peer.

返回值

没有返回值。


Makes an HTTP request over the specified connection

  • ? EventHttpConnection::getPeer
  • EventHttpConnection::setCloseCallback ?
  • PHP Manual
  • EventHttpConnection
  • Makes an HTTP request over the specified connection

EventHttpConnection::makeRequest

(PECL event >= 1.4.0-beta)

EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection

说明

public EventHttpConnection::makeRequest ( EventHttpRequest $req , int $type , string $uri ) : bool

Makes an HTTP request over the specified connection. type is one of EventHttpRequest::CMD_* constants.

参数

req

The connection object over which to send the request.

type

One of EventHttpRequest::CMD_* constants .

uri

The URI associated with the request.

返回值

Returns true on success. Otherwise false.

范例

Example #1 EventHttpConnection::makeRequest() example

<?php
function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

以上例程的输出类似于：

_request_handler
Success: 200
Body:
PHP, date:
2013-03-13T20:27:52+05:00

参见

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Set callback for connection close

  • ? EventHttpConnection::makeRequest
  • EventHttpConnection::setLocalAddress ?
  • PHP Manual
  • EventHttpConnection
  • Set callback for connection close

EventHttpConnection::setCloseCallback

(PECL event >= 1.8.0)

EventHttpConnection::setCloseCallback — Set callback for connection close

说明

public EventHttpConnection::setCloseCallback ( callable $callback , mixed $data = ? ) : void

Sets callback for connection close.

参数

callback

Callback which is called when connection is closed. Should match the following prototype:

callback ( EventHttpConnection $conn = null , mixed $arg = null ) : void

返回值

没有返回值。

范例

Example #1 EventHttpConnection::setCloseCallback() example

<?php
/*
 * Setting up close-connection callback
 *
 * The script handles closed connections using HTTP API.
 *
 * Usage:
 * 1) Launch the server:
 * $ php examples/http_closecb.php 4242
 *
 * 2) Launch a client in another terminal. Telnet-like
 * session should look like the following:
 *
 * $ nc -t 127.0.0.1 4242
 * GET / HTTP/1.0
 * Connection: close
 *
 * The server will output something similar to the following:
 *
 * HTTP/1.0 200 OK
 * Content-Type: multipart/x-mixed-replace;boundary=boundarydonotcross
 * Connection: close
 *
 * <html>
 *
 * 3) Terminate the client connection abruptly,
 * i.e. kill the process, or just press Ctrl-C.
 *
 * 4) Check if the server called _close_callback.
 * The script should output "_close_callback" string to standard output.
 *
 * 5) Check if the server's process has no orphaned connections,
 * e.g. with `lsof` utility.
 */

function _close_callback($conn)
{
    echo __FUNCTION__, PHP_EOL;
}

function _http_default($req, $dummy)
{
    $conn = $req->getConnection();
    $conn->setCloseCallback('_close_callback', NULL);

    /*
    By enabling Event::READ we protect the server against unclosed conections.
    This is a peculiarity of Libevent. The library disables Event::READ events
     on this connection, and the server is not notified about terminated
    connections.

    So each time client terminates connection abruptly, we get an orphaned
    connection. For instance, the following is a part of `lsof -p $PID | grep TCP`
    command after client has terminated connection:

    57-php     15057 ruslan  6u  unix 0xffff8802fb59c780   0t0  125187 socket
    58:php     15057 ruslan  7u  IPv4             125189   0t0     TCP *:4242 (LISTEN)
    59:php     15057 ruslan  8u  IPv4             124342   0t0     TCP localhost:4242->localhost:37375 (CLOSE_WAIT)

    where $PID is our process ID.

    The following block of code fixes such kind of orphaned connections.
     */
    $bev = $req->getBufferEvent();
    $bev->enable(Event::READ);
    // We have to free it explicitly. See
EventHttpRequest::getConnection()
$bev->free(); // we have to free it explicitly

    $req->addHeader(
        'Content-Type',
        'multipart/x-mixed-replace;boundary=boundarydonotcross',
        EventHttpRequest::OUTPUT_HEADER
    );

    $buf = new EventBuffer();
    $buf->add('<html>');

    $req->sendReply(200, "OK");
    $req->sendReplyChunk($buf);
}

$port = 4242;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);

$http->setDefaultCallback("_http_default", NULL);
$http->bind("0.0.0.0", $port);
$base->loop();

?>


Sets the IP address from which HTTP connections are made

  • ? EventHttpConnection::setCloseCallback
  • EventHttpConnection::setLocalPort ?
  • PHP Manual
  • EventHttpConnection
  • Sets the IP address from which HTTP connections are made

EventHttpConnection::setLocalAddress

(PECL event >= 1.2.6-beta)

EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made

说明

public EventHttpConnection::setLocalAddress ( string $address ) : void

Sets the IP address from which http connections are made.

参数

address

The IP address from which HTTP connections are made.

返回值

没有返回值。

参见

  • EventHttpConnection::setLocalPort() - Sets the local port from which connections are made


Sets the local port from which connections are made

  • ? EventHttpConnection::setLocalAddress
  • EventHttpConnection::setMaxBodySize ?
  • PHP Manual
  • EventHttpConnection
  • Sets the local port from which connections are made

EventHttpConnection::setLocalPort

(PECL event >= 1.2.6-beta)

EventHttpConnection::setLocalPort — Sets the local port from which connections are made

说明

public EventHttpConnection::setLocalPort ( int $port ) : void

Sets the local port from which connections are made.

参数

port

The port number.

返回值

参见

  • EventHttpConnection::setLocalAddress() - Sets the IP address from which HTTP connections are made


Sets maximum body size for the connection

  • ? EventHttpConnection::setLocalPort
  • EventHttpConnection::setMaxHeadersSize ?
  • PHP Manual
  • EventHttpConnection
  • Sets maximum body size for the connection

EventHttpConnection::setMaxBodySize

(PECL event >= 1.2.6-beta)

EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection

说明

public EventHttpConnection::setMaxBodySize ( string $max_size ) : void

Sets maximum body size for the connection.

参数

max_size

The maximum body size in bytes.

返回值

没有返回值。

参见

  • EventHttpConnection::setMaxHeadersSize() - Sets maximum header size


Sets maximum header size

  • ? EventHttpConnection::setMaxBodySize
  • EventHttpConnection::setRetries ?
  • PHP Manual
  • EventHttpConnection
  • Sets maximum header size

EventHttpConnection::setMaxHeadersSize

(PECL event >= 1.2.6-beta)

EventHttpConnection::setMaxHeadersSize — Sets maximum header size

说明

public EventHttpConnection::setMaxHeadersSize ( string $max_size ) : void

Sets maximum header size for the connection.

参数

max_size

The maximum header size in bytes.

返回值

没有返回值。

参见

  • EventHttpConnection::setMaxBodySize() - Sets maximum body size for the connection


Sets the retry limit for the connection

  • ? EventHttpConnection::setMaxHeadersSize
  • EventHttpConnection::setTimeout ?
  • PHP Manual
  • EventHttpConnection
  • Sets the retry limit for the connection

EventHttpConnection::setRetries

(PECL event >= 1.2.6-beta)

EventHttpConnection::setRetries — Sets the retry limit for the connection

说明

public EventHttpConnection::setRetries ( int $retries ) : void

Sets the retry limit for the connection

参数

retries

The retry limit. -1 means infinity.

返回值

没有返回值。


Sets the timeout for the connection

  • ? EventHttpConnection::setRetries
  • EventHttpRequest ?
  • PHP Manual
  • EventHttpConnection
  • Sets the timeout for the connection

EventHttpConnection::setTimeout

(PECL event >= 1.2.6-beta)

EventHttpConnection::setTimeout — Sets the timeout for the connection

说明

public EventHttpConnection::setTimeout ( int $timeout ) : void

Sets the timeout for the connection

参数

timeout

Timeout in seconds.

返回值

没有返回值。


The EventHttpRequest class

(PECL event >= 1.4.0-beta)

简介

Represents an HTTP request.

类摘要

EventHttpRequest {
/* Constants */
const int CMD_GET = 1 ;
const int CMD_POST = 2 ;
const int CMD_HEAD = 4 ;
const int CMD_PUT = 8 ;
const int CMD_DELETE = 16 ;
const int CMD_OPTIONS = 32 ;
const int CMD_TRACE = 64 ;
const int CMD_CONNECT = 128 ;
const int CMD_PATCH = 256 ;
const int INPUT_HEADER = 1 ;
const int OUTPUT_HEADER = 2 ;
/* 方法 */
public addHeader ( string $key , string $value , int $type ) : bool
public cancel ( ) : void
public clearHeaders ( ) : void
public closeConnection ( ) : void
public __construct ( callable $callback , mixed $data = null )
public findHeader ( string $key , string $type ) : void
public free ( ) : void
public closeConnection ( ) : EventBufferEvent
public getCommand ( ) : void
public closeConnection ( ) : EventHttpConnection
public getHost ( ) : string
public getInputBuffer ( ) : EventBuffer
public getInputHeaders ( ) : array
public getOutputBuffer ( ) : EventBuffer
public getOutputHeaders ( ) : void
public getResponseCode ( ) : int
public getUri ( ) : string
public removeHeader ( string $key , string $type ) : void
public sendError ( int $error , string $reason = null ) : void
public sendReply ( int $code , string $reason , EventBuffer $buf = ? ) : void
public sendReplyChunk ( EventBuffer $buf ) : void
public sendReplyEnd ( ) : void
public sendReplyStart ( int $code , string $reason ) : void
}

预定义常量

EventHttpRequest::CMD_GET

GET method(command)

EventHttpRequest::CMD_POST

POST method(command)

EventHttpRequest::CMD_HEAD

HEAD method(command)

EventHttpRequest::CMD_PUT

PUT method(command)

EventHttpRequest::CMD_DELETE

DELETE command(method)

EventHttpRequest::CMD_OPTIONS

OPTIONS method(command)

EventHttpRequest::CMD_TRACE

TRACE method(command)

EventHttpRequest::CMD_CONNECT

CONNECT method(command)

EventHttpRequest::CMD_PATCH

PATCH method(command)

EventHttpRequest::INPUT_HEADER

Request input header type.

EventHttpRequest::OUTPUT_HEADER

Request output header type.

Table of Contents

  • EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request
  • EventHttpRequest::cancel — Cancels a pending HTTP request
  • EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request
  • EventHttpRequest::closeConnection — Closes associated HTTP connection
  • EventHttpRequest::__construct — Constructs EventHttpRequest object
  • EventHttpRequest::findHeader — Finds the value belonging a header
  • EventHttpRequest::free — Frees the object and removes associated events
  • EventHttpRequest::getBufferEvent — Returns EventBufferEvent object
  • EventHttpRequest::getCommand — Returns the request command(method)
  • EventHttpRequest::getConnection — Returns EventHttpConnection object
  • EventHttpRequest::getHost — Returns the request host
  • EventHttpRequest::getInputBuffer — Returns the input buffer
  • EventHttpRequest::getInputHeaders — Returns associative array of the input headers
  • EventHttpRequest::getOutputBuffer — Returns the output buffer of the request
  • EventHttpRequest::getOutputHeaders — Returns associative array of the output headers
  • EventHttpRequest::getResponseCode — Returns the response code
  • EventHttpRequest::getUri — Returns the request URI
  • EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request
  • EventHttpRequest::sendError — Send an HTML error message to the client
  • EventHttpRequest::sendReply — Send an HTML reply to the client
  • EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply
  • EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate
  • EventHttpRequest::sendReplyStart — Initiate a chunked reply


Adds an HTTP header to the headers of the request

  • ? EventHttpRequest
  • EventHttpRequest::cancel ?
  • PHP Manual
  • EventHttpRequest
  • Adds an HTTP header to the headers of the request

EventHttpRequest::addHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request

说明

public EventHttpRequest::addHeader ( string $key , string $value , int $type ) : bool

Adds an HTTP header to the headers of the request.

参数

key

Header name.

value

Header value.

type

One of EventHttpRequest::*_HEADER constants .

返回值

Returns true on success. Otherwise false.

参见

  • EventHttpRequest::removeHeader() - Removes an HTTP header from the headers of the request


Cancels a pending HTTP request

  • ? EventHttpRequest::addHeader
  • EventHttpRequest::clearHeaders ?
  • PHP Manual
  • EventHttpRequest
  • Cancels a pending HTTP request

EventHttpRequest::cancel

(PECL event >= 1.4.0-beta)

EventHttpRequest::cancel — Cancels a pending HTTP request

说明

public EventHttpRequest::cancel ( ) : void

Cancels a pending HTTP request.

Cancels an ongoing HTTP request. The callback associated with this request is not executed and the request object is freed. If the request is currently being processed, e.g. it is ongoing, the corresponding EventHttpConnection object is going to get reset.

A request cannot be canceled if its callback has executed already. A request may be canceled reentrantly from its chunked callback.

参数

此函数没有参数。

返回值

没有返回值。


Removes all output headers from the header list of the request

  • ? EventHttpRequest::cancel
  • EventHttpRequest::closeConnection ?
  • PHP Manual
  • EventHttpRequest
  • Removes all output headers from the header list of the request

EventHttpRequest::clearHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request

说明

public EventHttpRequest::clearHeaders ( ) : void

Removes all output headers from the header list of the request.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Closes associated HTTP connection

  • ? EventHttpRequest::clearHeaders
  • EventHttpRequest::__construct ?
  • PHP Manual
  • EventHttpRequest
  • Closes associated HTTP connection

EventHttpRequest::closeConnection

(PECL event >= 1.8.0)

EventHttpRequest::closeConnection — Closes associated HTTP connection

说明

public EventHttpRequest::closeConnection ( ) : void

Closes HTTP connection associated with the request.

参数

此函数没有参数。

返回值

没有返回值。


Constructs EventHttpRequest object

  • ? EventHttpRequest::closeConnection
  • EventHttpRequest::findHeader ?
  • PHP Manual
  • EventHttpRequest
  • Constructs EventHttpRequest object

EventHttpRequest::__construct

(PECL event >= 1.4.0-beta)

EventHttpRequest::__construct — Constructs EventHttpRequest object

说明

public EventHttpRequest::__construct ( callable $callback , mixed $data = null )

Constructs EventHttpRequest object.

参数

callback

Gets invoked on requesting path. Should match the following prototype:

callback ( EventHttpRequest $req = null , mixed $arg = null ) : void
data

User custom data passed to the callback.

返回值

Returns EventHttpRequest object.

范例

Example #1 EventHttpRequest::__construct() example

<?php

function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

参见

  • EventHttpRequest::cancel() - Cancels a pending HTTP request
  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Finds the value belonging a header

  • ? EventHttpRequest::__construct
  • EventHttpRequest::free ?
  • PHP Manual
  • EventHttpRequest
  • Finds the value belonging a header

EventHttpRequest::findHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::findHeader — Finds the value belonging a header

说明

public EventHttpRequest::findHeader ( string $key , string $type ) : void

Finds the value belonging a header.

参数

key

The header name.

type

One of EventHttpRequest::*_HEADER constants .

返回值

Returns null if header not found.

参见

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Frees the object and removes associated events

  • ? EventHttpRequest::findHeader
  • EventHttpRequest::getBufferEvent ?
  • PHP Manual
  • EventHttpRequest
  • Frees the object and removes associated events

EventHttpRequest::free

(PECL event >= 1.4.0-beta)

EventHttpRequest::free — Frees the object and removes associated events

说明

public EventHttpRequest::free ( ) : void

Frees the object and removes associated events.

参数

此函数没有参数。

返回值

没有返回值。


Returns EventBufferEvent object

  • ? EventHttpRequest::free
  • EventHttpRequest::getCommand ?
  • PHP Manual
  • EventHttpRequest
  • Returns EventBufferEvent object

EventHttpRequest::getBufferEvent

(PECL event >= 1.8.0)

EventHttpRequest::getBufferEvent — Returns EventBufferEvent object

说明

public EventHttpRequest::closeConnection ( ) : EventBufferEvent

Returns EventBufferEvent object which represents buffer event that the connection is using.

Warning

The reference counter of the returned object will be incremented by one to protect internal structures against premature destruction when the method is called from a user callback. So the EventBufferEvent object should be freed explicitly with EventBufferEvent::free() method. Otherwise memory will leak.

参数

此函数没有参数。

返回值

Returns EventBufferEvent object.

参见

  • EventHttpRequest::getConnection() - Returns EventHttpConnection object


Returns the request command(method)

  • ? EventHttpRequest::getBufferEvent
  • EventHttpRequest::getConnection ?
  • PHP Manual
  • EventHttpRequest
  • Returns the request command(method)

EventHttpRequest::getCommand

(PECL event >= 1.4.0-beta)

EventHttpRequest::getCommand — Returns the request command(method)

说明

public EventHttpRequest::getCommand ( ) : void

Returns the request command, one of EventHttpRequest::CMD_* constants.

参数

此函数没有参数。

返回值

Returns the request command, one of EventHttpRequest::CMD_* constants.


Returns EventHttpConnection object

  • ? EventHttpRequest::getCommand
  • EventHttpRequest::getHost ?
  • PHP Manual
  • EventHttpRequest
  • Returns EventHttpConnection object

EventHttpRequest::getConnection

(PECL event >= 1.8.0)

EventHttpRequest::getConnection — Returns EventHttpConnection object

说明

public EventHttpRequest::closeConnection ( ) : EventHttpConnection

Returns EventHttpConnection object which represents HTTP connection associated with the request.

Warning

Libevent API allows HTTP request objects to be not bound to any HTTP connection. Therefore we can't unambiguously associate EventHttpRequest with EventHttpConnection . Thus, we construct EventHttpConnection object on-the-fly. Having no information about the event base, DNS base and connection-close callback, we just leave these fields unset.

EventHttpRequest::getConnection() method is usually useful when we need to set up a callback on connection close. See EventHttpConnection::setCloseCallback() .

参数

此函数没有参数。

返回值

Returns EventHttpConnection object.

参见

  • EventHttpConnection::setCloseCallback() - Set callback for connection close
  • EventHttpRequest::getBufferEvent() - Returns EventBufferEvent object


Returns the request host

  • ? EventHttpRequest::getConnection
  • EventHttpRequest::getInputBuffer ?
  • PHP Manual
  • EventHttpRequest
  • Returns the request host

EventHttpRequest::getHost

(PECL event >= 1.4.0-beta)

EventHttpRequest::getHost — Returns the request host

说明

public EventHttpRequest::getHost ( ) : string

Returns the request host.

参数

此函数没有参数。

返回值

Returns the request host.

参见

  • EventHttpRequest::getUri() - Returns the request URI
  • EventHttpRequest::getCommand() - Returns the request command(method)


Returns the input buffer

  • ? EventHttpRequest::getHost
  • EventHttpRequest::getInputHeaders ?
  • PHP Manual
  • EventHttpRequest
  • Returns the input buffer

EventHttpRequest::getInputBuffer

(PECL event >= 1.4.0-beta)

EventHttpRequest::getInputBuffer — Returns the input buffer

说明

public EventHttpRequest::getInputBuffer ( ) : EventBuffer

Returns the input buffer.

参数

此函数没有参数。

返回值

Returns the input buffer.

参见

  • EventHttpRequest::getOutputBuffer() - Returns the output buffer of the request


Returns associative array of the input headers

  • ? EventHttpRequest::getInputBuffer
  • EventHttpRequest::getOutputBuffer ?
  • PHP Manual
  • EventHttpRequest
  • Returns associative array of the input headers

EventHttpRequest::getInputHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::getInputHeaders — Returns associative array of the input headers

说明

public EventHttpRequest::getInputHeaders ( ) : array

Returns associative array of the input headers.

参数

此函数没有参数。

返回值

Returns associative array of the input headers.

参见

  • EventHttpRequest::getOutputHeaders() - Returns associative array of the output headers


Returns the output buffer of the request

  • ? EventHttpRequest::getInputHeaders
  • EventHttpRequest::getOutputHeaders ?
  • PHP Manual
  • EventHttpRequest
  • Returns the output buffer of the request

EventHttpRequest::getOutputBuffer

(PECL event >= 1.4.0-beta)

EventHttpRequest::getOutputBuffer — Returns the output buffer of the request

说明

public EventHttpRequest::getOutputBuffer ( ) : EventBuffer

Returns the output buffer of the request.

参数

此函数没有参数。

返回值

Returns the output buffer of the request.

参见

  • EventHttpRequest::getInputBuffer() - Returns the input buffer


Returns associative array of the output headers

  • ? EventHttpRequest::getOutputBuffer
  • EventHttpRequest::getResponseCode ?
  • PHP Manual
  • EventHttpRequest
  • Returns associative array of the output headers

EventHttpRequest::getOutputHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::getOutputHeaders — Returns associative array of the output headers

说明

public EventHttpRequest::getOutputHeaders ( ) : void

Returns associative array of the output headers.

参数

此函数没有参数。

返回值

参见

  • EventHttpRequest::getInputHeaders() - Returns associative array of the input headers


Returns the response code

  • ? EventHttpRequest::getOutputHeaders
  • EventHttpRequest::getUri ?
  • PHP Manual
  • EventHttpRequest
  • Returns the response code

EventHttpRequest::getResponseCode

(PECL event >= 1.4.0-beta)

EventHttpRequest::getResponseCode — Returns the response code

说明

public EventHttpRequest::getResponseCode ( ) : int

Returns the response code.

参数

此函数没有参数。

返回值

Returns the response code of the request.

参见

  • EventHttpRequest::getCommand() - Returns the request command(method)
  • EventHttpRequest::getHost() - Returns the request host
  • EventHttpRequest::getUri() - Returns the request URI


Returns the request URI

  • ? EventHttpRequest::getResponseCode
  • EventHttpRequest::removeHeader ?
  • PHP Manual
  • EventHttpRequest
  • Returns the request URI

EventHttpRequest::getUri

(PECL event >= 1.4.0-beta)

EventHttpRequest::getUri — Returns the request URI

说明

public EventHttpRequest::getUri ( ) : string

Returns the request URI

参数

此函数没有参数。

返回值

Returns the request URI

参见

  • EventHttpRequest::getCommand() - Returns the request command(method)
  • EventHttpRequest::getHost() - Returns the request host
  • EventHttpRequest::getResponseCode() - Returns the response code


Removes an HTTP header from the headers of the request

  • ? EventHttpRequest::getUri
  • EventHttpRequest::sendError ?
  • PHP Manual
  • EventHttpRequest
  • Removes an HTTP header from the headers of the request

EventHttpRequest::removeHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request

说明

public EventHttpRequest::removeHeader ( string $key , string $type ) : void

Removes an HTTP header from the headers of the request.

参数

key

The header name.

type

type is one of EventHttpRequest::*_HEADER constants.

返回值

Removes an HTTP header from the headers of the request.

参见

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request


Send an HTML error message to the client

  • ? EventHttpRequest::removeHeader
  • EventHttpRequest::sendReply ?
  • PHP Manual
  • EventHttpRequest
  • Send an HTML error message to the client

EventHttpRequest::sendError

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendError — Send an HTML error message to the client

说明

public EventHttpRequest::sendError ( int $error , string $reason = null ) : void

Send an HTML error message to the client.

参数

error

The HTTP error code.

reason

A brief explanation ofthe error. If null, the standard meaning of the error code will be used.

返回值

没有返回值。

范例

Example #1 EventHttpRequest::sendError() example

<?php
function _http_400($req) {
    $req->sendError(400);
}

$base = new EventBase();
$http = new EventHttp($base);

$http->setCallback("/err400", "_http_400");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

参见

  • EventHttpRequest::sendReply() - Send an HTML reply to the client


Send an HTML reply to the client

  • ? EventHttpRequest::sendError
  • EventHttpRequest::sendReplyChunk ?
  • PHP Manual
  • EventHttpRequest
  • Send an HTML reply to the client

EventHttpRequest::sendReply

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReply — Send an HTML reply to the client

说明

public EventHttpRequest::sendReply ( int $code , string $reason , EventBuffer $buf = ? ) : void

Send an HTML reply to the client. The body of the reply consists of data in optional buf parameter.

参数

code

The HTTP response code to send.

reason

A brief message to send with the response code.

buf

The body of the response.

返回值

没有返回值。

参见

  • EventHttpRequest::sendError() - Send an HTML error message to the client
  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply


Send another data chunk as part of an ongoing chunked reply

  • ? EventHttpRequest::sendReply
  • EventHttpRequest::sendReplyEnd ?
  • PHP Manual
  • EventHttpRequest
  • Send another data chunk as part of an ongoing chunked reply

EventHttpRequest::sendReplyChunk

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply

说明

public EventHttpRequest::sendReplyChunk ( EventBuffer $buf ) : void

Send another data chunk as part of an ongoing chunked reply. After calling this method buf will be empty.

参数

buf

The data chunk to send as part of the reply.

返回值

没有返回值。

参见

  • EventHttpRequest::sendReplyStart() - Initiate a chunked reply
  • EventHttpRequest::sendReplyEnd() - Complete a chunked reply, freeing the request as appropriate


Complete a chunked reply, freeing the request as appropriate

  • ? EventHttpRequest::sendReplyChunk
  • EventHttpRequest::sendReplyStart ?
  • PHP Manual
  • EventHttpRequest
  • Complete a chunked reply, freeing the request as appropriate

EventHttpRequest::sendReplyEnd

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate

说明

public EventHttpRequest::sendReplyEnd ( ) : void

Complete a chunked reply, freeing the request as appropriate.

参数

此函数没有参数。

返回值

没有返回值。

参见

  • EventHttpRequest::sendReplyStart() - Initiate a chunked reply
  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply


Initiate a chunked reply

  • ? EventHttpRequest::sendReplyEnd
  • EventListener ?
  • PHP Manual
  • EventHttpRequest
  • Initiate a chunked reply

EventHttpRequest::sendReplyStart

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyStart — Initiate a chunked reply

说明

public EventHttpRequest::sendReplyStart ( int $code , string $reason ) : void

Initiate a reply that uses Transfer-Encoding chunked .

This allows the caller to stream the reply back to the client and is useful when either not all of the reply data is immediately available or when sending very large replies.

The caller needs to supply data chunks with EventHttpRequest::sendReplyChunk() and complete the reply by calling EventHttpRequest::sendReplyEnd() .

参数

code

The HTTP response code to send.

reason

A brief message to send with the response code.

返回值

没有返回值。

参见

  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply
  • EventHttpRequest::sendReplyEnd() - Complete a chunked reply, freeing the request as appropriate


The EventListener class

(PECL event >= 1.5.0)

简介

Represents a connection listener.

类摘要

final EventListener {
/* Constants */
const int OPT_LEAVE_SOCKETS_BLOCKING = 1 ;
const int OPT_CLOSE_ON_FREE = 2 ;
const int OPT_CLOSE_ON_EXEC = 4 ;
const int OPT_REUSEABLE = 8 ;
const int OPT_THREADSAFE = 16 ;
/* 属性 */
public readonly int $fd ;
/* 方法 */
public __construct ( EventBase $base , callable $cb , mixed $data , int $flags , int $backlog , mixed $target )
public disable ( ) : bool
public enable ( ) : bool
public getBase ( ) : void
public static getSocketName ( string &$address , mixed &$port = ? ) : bool
public setCallback ( callable $cb , mixed $arg = null ) : void
public setErrorCallback ( string $cb ) : void
}

属性

fd

Numeric file descriptor of the underlying socket. (Added in event-1.6.0 .)

预定义常量

EventListener::OPT_LEAVE_SOCKETS_BLOCKING

By default Libevent turns underlying file descriptors, or sockets, to non-blocking mode. This flag tells Libevent to leave them in blocking mode.

EventListener::OPT_CLOSE_ON_FREE

If this option is set, the connection listener closes its underlying socket when the EventListener object is freed.

EventListener::OPT_CLOSE_ON_EXEC

If this option is set, the connection listener sets the close-on-exec flag on the underlying listener socket. See platform documentation for fcntl and FD_CLOEXEC for more information.

EventListener::OPT_REUSEABLE

By default on some platforms, once a listener socket is closed, no other socket can bind to the same port until a while has passed. Setting this option makes Libevent mark the socket as reusable, so that once it is closed, another socket can be opened to listen on the same port.

EventListener::OPT_THREADSAFE

Allocate locks for the listener, so that it's safe to use it from multiple threads.

Table of Contents

  • EventListener::__construct — Creates new connection listener associated with an event base
  • EventListener::disable — Disables an event connect listener object
  • EventListener::enable — Enables an event connect listener object
  • EventListener::getBase — Returns event base associated with the event listener
  • EventListener::getSocketName — Retreives the current address to which the listener's socket is bound
  • EventListener::setCallback — The setCallback purpose
  • EventListener::setErrorCallback — Set event listener's error callback


Creates new connection listener associated with an event base

  • ? EventListener
  • EventListener::disable ?
  • PHP Manual
  • EventListener
  • Creates new connection listener associated with an event base

EventListener::__construct

(PECL event >= 1.2.6-beta)

EventListener::__construct — Creates new connection listener associated with an event base

说明

public EventListener::__construct ( EventBase $base , callable $cb , mixed $data , int $flags , int $backlog , mixed $target )

Creates new connection listener associated with an event base.

参数

base

Associated event base.

cb

A callable that will be invoked when new connection received.

data

Custom user data attached to cb .

flags

Bit mask of EventListener::OPT_* constants. See EventListener constants .

backlog

Controls the maximum number of pending connections that the network stack should allow to wait in a not-yet-accepted state at any time; see documentation for your system's listen function for more details. If backlog is negative, Libevent tries to pick a good value for the backlog ; if it is zero, Event assumes that listen is already called on the socket( target )

target

May be string, socket resource, or a stream associated with a socket. In case if target is a string, the string will be parsed as network address. It will be interpreted as a UNIX domain socket path, if prefixed with 'unix:' , e.g. 'unix:/tmp/my.sock' .

返回值

Returns EventListener object representing the event connection listener.

更新日志

版本 | 说明
PECL event 1.5.0 | UNIX domain sockets' support added.

范例

Example #1 EventListener::__construct() example

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php listener.php 9881
 *
 * 2) In another terminal window open up connection, e.g.:
 *
 * $ nc 127.0.0.1 9881
 *
 * 3) start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        $this->bev->free();
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer

        // Variant #1
        $bev->output->addBuffer($bev->input);

        /* Variant #2 */
        /*
        $input    = $bev->getInput();
        $output = $bev->getOutput();
        $output->addBuffer($input);
        */
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            //$bev->free();
            $this->__destruct();
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($port) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        // Variant #1
        /*
        $this->socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
        if (!socket_bind($this->socket, '0.0.0.0', $port)) {
            echo "Unable to bind socket\n";
            exit(1);
        }
        $this->listener = new EventListener($this->base,
            array($this, "acceptConnCallback"), $this->base,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, $this->socket);
         */

        // Variant #2
         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "0.0.0.0:$port");

        if (!$this->listener) {
            echo "Couldn't create listener";
            exit(1);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

$port = 9808;

if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$l = new MyListener($port);
$l->dispatch();
?>


Disables an event connect listener object

  • ? EventListener::__construct
  • EventListener::enable ?
  • PHP Manual
  • EventListener
  • Disables an event connect listener object

EventListener::disable

(PECL event >= 1.2.6-beta)

EventListener::disable — Disables an event connect listener object

说明

public EventListener::disable ( ) : bool

Disables an event connect listener object

参数

此函数没有参数。

返回值

Returns true on success. Otherwise false.

参见

  • EventListener::enable() - Enables an event connect listener object


Enables an event connect listener object

  • ? EventListener::disable
  • EventListener::getBase ?
  • PHP Manual
  • EventListener
  • Enables an event connect listener object

EventListener::enable

(PECL event >= 1.2.6-beta)

EventListener::enable — Enables an event connect listener object

说明

public EventListener::enable ( ) : bool

Enables an event connect listener object

参数

此函数没有参数。

返回值

Returns true on success. Otherwise false.

参见

  • EventListener::disable() - Disables an event connect listener object


Returns event base associated with the event listener

  • ? EventListener::enable
  • EventListener::getSocketName ?
  • PHP Manual
  • EventListener
  • Returns event base associated with the event listener

EventListener::getBase

(PECL event >= 1.2.6-beta)

EventListener::getBase — Returns event base associated with the event listener

说明

public EventListener::getBase ( ) : void

Returns event base associated with the event listener.

参数

此函数没有参数。

返回值

Returns event base associated with the event listener.


Retreives the current address to which the listener's socket is bound

  • ? EventListener::getBase
  • EventListener::setCallback ?
  • PHP Manual
  • EventListener
  • Retreives the current address to which the listener's socket is bound

EventListener::getSocketName

(PECL event >= 1.5.0)

EventListener::getSocketName — Retreives the current address to which the listener's socket is bound

说明

public static EventListener::getSocketName ( string &$address , mixed &$port = ? ) : bool

Retreives the current address to which the listener's socket is bound.

参数

address

Output parameter. IP-address depending on the socket address family.

port

Output parameter. The port the socket is bound to.

返回值

Returns true on success. Otherwise false.


The setCallback purpose

  • ? EventListener::getSocketName
  • EventListener::setErrorCallback ?
  • PHP Manual
  • EventListener
  • The setCallback purpose

EventListener::setCallback

(PECL event >= 1.2.6-beta)

EventListener::setCallback — The setCallback purpose

说明

public EventListener::setCallback ( callable $cb , mixed $arg = null ) : void

Adjust event connect listener's callback and optionally the callback argument.

参数

cb

The new callback for new connections. Ignored if null.

Should match the following prototype:

callback ( EventListener $listener = null , mixed $fd = null , array $address = null , mixed $arg = null ) : void

listener

The EventListener object.

fd

The file descriptor or a resource associated with the listener.

address

Array of two elements: IP address and the server port.

arg

User custom data attached to the callback.

arg

Custom user data attached to the callback. Ignored if null.

返回值

没有返回值。


Set event listener's error callback

  • ? EventListener::setCallback
  • EventSslContext ?
  • PHP Manual
  • EventListener
  • Set event listener's error callback

EventListener::setErrorCallback

(PECL event >= 1.2.6-beta)

EventListener::setErrorCallback — Set event listener's error callback

说明

public EventListener::setErrorCallback ( string $cb ) : void

Set event listener's error callback

参数

cb

The error callback. Should match the following prototype:

callback ( EventListener $listener = null , mixed $data = null ) : void

listener

The EventListener object.

data

User custom data attached to the callback.

返回值

参见

  • EventListener::setCallback() - The setCallback purpose


The EventSslContext class

(PECL event >= 1.2.6-beta)

简介

Represents SSL_CTX structure. Provides methods and properties to configure the SSL context.

类摘要

final EventSslContext {
/* Constants */
const int SSLv2_CLIENT_METHOD = 1 ;
const int SSLv3_CLIENT_METHOD = 2 ;
const int SSLv23_CLIENT_METHOD = 3 ;
const int TLS_CLIENT_METHOD = 4 ;
const int SSLv2_SERVER_METHOD = 5 ;
const int SSLv3_SERVER_METHOD = 6 ;
const int SSLv23_SERVER_METHOD = 7 ;
const int TLS_SERVER_METHOD = 8 ;
const int OPT_LOCAL_CERT = 1 ;
const int OPT_LOCAL_PK = 2 ;
const int OPT_PASSPHRASE = 3 ;
const int OPT_CA_FILE = 4 ;
const int OPT_CA_PATH = 5 ;
const int OPT_ALLOW_SELF_SIGNED = 6 ;
const int OPT_VERIFY_PEER = 7 ;
const int OPT_VERIFY_DEPTH = 8 ;
const int OPT_CIPHERS = 9 ;
/* 属性 */
public string $local_cert ;
public string $local_pk ;
/* 方法 */
public __construct ( string $method , string $options )
}

属性

local_cert

Path to local certificate file on filesystem. It must be a PEM-encoded file which contains certificate. It can optionally contain the certificate chain of issuers.

local_pk

Path to local private key file

预定义常量

EventSslContext::SSLv2_CLIENT_METHOD

SSLv2 client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv3_CLIENT_METHOD

SSLv3 client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv23_CLIENT_METHOD

SSLv23 client method. See SSL_CTX_new(3) man page.

EventSslContext::TLS_CLIENT_METHOD

TLS client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv2_SERVER_METHOD

SSLv2 server method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv3_SERVER_METHOD

SSLv3 server method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv23_SERVER_METHOD

SSLv23 server method. See SSL_CTX_new(3) man page.

EventSslContext::TLS_SERVER_METHOD

TLS server method. See SSL_CTX_new(3) man page.

EventSslContext::OPT_LOCAL_CERT

Key for an item of the options' array used in EventSslContext::__construct() . The option points to path of local certificate.

EventSslContext::OPT_LOCAL_PK

Key for an item of the options' array used in EventSslContext::__construct() . The option points to path of the private key.

EventSslContext::OPT_PASSPHRASE

Key for an item of the options' array used in EventSslContext::__construct() . Represents passphrase of the certificate.

EventSslContext::OPT_CA_FILE

Key for an item of the options' array used in EventSslContext::__construct() . Represents path of the certificate authority file.

EventSslContext::OPT_CA_PATH

Key for an item of the options' array used in EventSslContext::__construct() . Represents path where the certificate authority file should be searched for.

EventSslContext::OPT_ALLOW_SELF_SIGNED

Key for an item of the options' array used in EventSslContext::__construct() . Represents option that allows self-signed certificates.

EventSslContext::OPT_VERIFY_PEER

Key for an item of the options' array used in EventSslContext::__construct() . Represents option that tells Event to verify peer.

EventSslContext::OPT_VERIFY_DEPTH

Key for an item of the options' array used in EventSslContext::__construct() . Represents maximum depth for the certificate chain verification that shall be allowed for the SSL context.

EventSslContext::OPT_CIPHERS

Key for an item of the options' array used in EventSslContext::__construct() . Represents the cipher list for the SSL context.

Table of Contents

  • EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes


Constructs an OpenSSL context for use with Event classes

  • ? EventSslContext
  • EventUtil ?
  • PHP Manual
  • EventSslContext
  • Constructs an OpenSSL context for use with Event classes

EventSslContext::__construct

(PECL event >= 1.2.6-beta)

EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes

说明

public EventSslContext::__construct ( string $method , string $options )

Creates SSL context holding pointer to SSL_CTX (see the system manual).

参数

method

One of EventSslContext::*_METHOD constants .

options

Associative array of SSL context options One of EventSslContext::OPT_* constants .

返回值

Returns EventSslContext object.

范例

Example #1 EventSslContext::__construct() example

<?php
$ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array(
     EventSslContext::OPT_LOCAL_CERT        => $local_cert,
     EventSslContext::OPT_LOCAL_PK          => $local_pk,
     EventSslContext::OPT_PASSPHRASE        => "echo server",
     EventSslContext::OPT_VERIFY_PEER       => true,
     EventSslContext::OPT_ALLOW_SELF_SIGNED => false,
));
?>


The EventUtil class

(PECL event >= 1.5.0)

简介

EventUtil is a singleton with supplimentary methods and constants.

类摘要

final EventUtil {
/* Constants */
const int AF_INET = 2 ;
const int AF_INET6 = 10 ;
const int AF_UNSPEC = 0 ;
const int LIBEVENT_VERSION_NUMBER = 33559808 ;
const int SO_DEBUG = 1 ;
const int SO_REUSEADDR = 2 ;
const int SO_KEEPALIVE = 9 ;
const int SO_DONTROUTE = 5 ;
const int SO_LINGER = 13 ;
const int SO_BROADCAST = 6 ;
const int SO_OOBINLINE = 10 ;
const int SO_SNDBUF = 7 ;
const int SO_RCVBUF = 8 ;
const int SO_SNDLOWAT = 19 ;
const int SO_RCVLOWAT = 18 ;
const int SO_SNDTIMEO = 21 ;
const int SO_RCVTIMEO = 20 ;
const int SO_TYPE = 3 ;
const int SO_ERROR = 4 ;
const int SOL_SOCKET = 1 ;
const int SOL_TCP = 6 ;
const int SOL_UDP = 17 ;
const int IPPROTO_IP = 0 ;
const int IPPROTO_IPV6 = 41 ;
/* 方法 */
abstract public __construct ( )
public static getLastSocketErrno ( mixed $socket = null ) : int
public static getLastSocketError ( mixed $socket = ? ) : string
public static getSocketFd ( mixed $socket ) : int
public static getSocketName ( mixed $socket , string &$address , mixed &$port = ? ) : bool
public static setSocketOption ( mixed $socket , int $level , int $optname , mixed $optval ) : bool
public static sslRandPoll ( ) : void
}

预定义常量

EventUtil::AF_INET

IPv4 address family

EventUtil::AF_INET6

IPv6 address family

EventUtil::AF_UNSPEC

Unspecified IP address family

EventUtil::SO_DEBUG

Socket option. Enable socket debugging. Only allowed for processes with the CAP_NET_ADMIN capability or an effective user ID of 0 . (Added in event-1.6.0.)

EventUtil::SO_REUSEADDR

Socket option. Indicates that the rules used in validating addresses supplied in a bind(2) call should allow reuse of local addresses. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_KEEPALIVE

Socket option. Enable sending of keep-alive messages on connection-oriented sockets. Expects an integer boolean flag. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_DONTROUTE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_LINGER

Socket option. When enabled, a close(2) or shutdown(2) will not return until all queued messages for the socket have been successfully sent or the linger timeout has been reached. Otherwise, the call returns immediately and the closing is done in the background. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_BROADCAST

Socket option. Reports whether transmission of broadcast messages is supported. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_OOBINLINE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDBUF

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVBUF

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDLOWAT

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVLOWAT

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDTIMEO

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVTIMEO

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_TYPE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_ERROR

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_SOCKET

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_TCP

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_UDP

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::IPPROTO_IP

See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::IPPROTO_IPV6

See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::LIBEVENT_VERSION_NUMBER

Libevent' version number at the time when Event extension had been compiled with the library.

Table of Contents

  • EventUtil::__construct — The abstract constructor
  • EventUtil::getLastSocketErrno — Returns the most recent socket error number
  • EventUtil::getLastSocketError — Returns the most recent socket error
  • EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream
  • EventUtil::getSocketName — Retreives the current address to which the socket is bound
  • EventUtil::setSocketOption — Sets socket options
  • EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()


The abstract constructor

  • ? EventUtil
  • EventUtil::getLastSocketErrno ?
  • PHP Manual
  • EventUtil
  • The abstract constructor

EventUtil::__construct

(PECL event >= 1.2.6-beta)

EventUtil::__construct — The abstract constructor

说明

abstract public EventUtil::__construct ( )

EventUtil is a singleton. Therefore the constructor is abstract, and it is impossible to create objects based on this class.

参数

此函数没有参数。

返回值

没有返回值。


Returns the most recent socket error number

  • ? EventUtil::__construct
  • EventUtil::getLastSocketError ?
  • PHP Manual
  • EventUtil
  • Returns the most recent socket error number

EventUtil::getLastSocketErrno

(PECL event >= 1.2.6-beta)

EventUtil::getLastSocketErrno — Returns the most recent socket error number

说明

public static EventUtil::getLastSocketErrno ( mixed $socket = null ) : int

Returns the most recent socket error number( errno ).

参数

socket

Socket resource, stream or a file descriptor of a socket.

返回值

Returns the most recent socket error number( errno ).

参见

  • EventUtil::getLastSocketError() - Returns the most recent socket error


Returns the most recent socket error

  • ? EventUtil::getLastSocketErrno
  • EventUtil::getSocketFd ?
  • PHP Manual
  • EventUtil
  • Returns the most recent socket error

EventUtil::getLastSocketError

(PECL event >= 1.2.6-beta)

EventUtil::getLastSocketError — Returns the most recent socket error

说明

public static EventUtil::getLastSocketError ( mixed $socket = ? ) : string

Returns the most recent socket error.

参数

socket

Socket resource, stream or a file descriptor of a socket.

返回值

Returns the most recent socket error.

参见

  • EventUtil::getLastSocketErrno() - Returns the most recent socket error number


Returns numeric file descriptor of a socket, or stream

  • ? EventUtil::getLastSocketError
  • EventUtil::getSocketName ?
  • PHP Manual
  • EventUtil
  • Returns numeric file descriptor of a socket, or stream

EventUtil::getSocketFd

(PECL event >= 1.7.0)

EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream

说明

public static EventUtil::getSocketFd ( mixed $socket ) : int

Returns numeric file descriptor of a socket or stream specified by socket argument just like the Event extension does it internally for all methods accepting socket resource or stream.

参数

socket

Socket resource or stream.

返回值

Returns numeric file descriptor of a socket, or stream. EventUtil::getSocketFd() returns false in case if it is whether failed to recognize the type of the underlying file, or detected that the file descriptor associated with socket is not valid.


Retreives the current address to which the socket is bound

  • ? EventUtil::getSocketFd
  • EventUtil::setSocketOption ?
  • PHP Manual
  • EventUtil
  • Retreives the current address to which the socket is bound

EventUtil::getSocketName

(PECL event >= 1.5.0)

EventUtil::getSocketName — Retreives the current address to which the socket is bound

说明

public static EventUtil::getSocketName ( mixed $socket , string &$address , mixed &$port = ? ) : bool

Retreives the current address to which the socket is bound.

参数

socket

Socket resource, stream or a file descriptor of a socket.

address

Output parameter. IP-address, or the UNIX domain socket path depending on the socket address family.

port

Output parameter. The port the socket is bound to. Has no meaning for UNIX domain sockets.

返回值

Returns true on success. Otherwise false.


Sets socket options

  • ? EventUtil::getSocketName
  • EventUtil::sslRandPoll ?
  • PHP Manual
  • EventUtil
  • Sets socket options

EventUtil::setSocketOption

(PECL event >= 1.6.0)

EventUtil::setSocketOption — Sets socket options

说明

public static EventUtil::setSocketOption ( mixed $socket , int $level , int $optname , mixed $optval ) : bool

Sets socket options.

参数

socket

Socket resource, stream, or numeric file descriptor associated with the socket.

level

One of EventUtil::SOL_* constants. Specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of EventUtil::SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function. See EventUtil constants .

optname

Option name(type). Has the same meaning as corresponding parameter of socket_get_option() function. See EventUtil constants .

optval

Accepts the same values as optval parameter of the socket_get_option() function.

返回值

Returns true on success. Otherwise false.

参见

  • socket_get_option() - Gets socket options for the socket
  • socket_set_option() - Sets socket options for the socket


Generates entropy by means of OpenSSL's RAND_poll()

  • ? EventUtil::setSocketOption
  • FTP ?
  • PHP Manual
  • EventUtil
  • Generates entropy by means of OpenSSL's RAND_poll()

EventUtil::sslRandPoll

(PECL event >= 1.2.6-beta)

EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()

说明

public static EventUtil::sslRandPoll ( ) : void

Generates entropy by means of OpenSSL's RAND_poll() (see the system manual).

参数

此函数没有参数。

返回值

没有返回值。


FTP

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • 基本用法
  • FTP 函数
    • ftp_alloc — 为要上传的文件分配空间
    • ftp_append — 将文件内容追加到 FTP 服务器上的指定文件
    • ftp_cdup — 切换到当前目录的父目录
    • ftp_chdir — 在 FTP 服务器上改变当前目录
    • ftp_chmod — 设置 FTP 服务器上的文件权限
    • ftp_close — 关闭一个 FTP 连接
    • ftp_connect — 建立一个新的 FTP 连接
    • ftp_delete — 删除 FTP 服务器上的一个文件
    • ftp_exec — 在 FTP 服务器运行指定的命令
    • ftp_fget — 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中
    • ftp_fput — 上传一个已经打开的文件到 FTP 服务器
    • ftp_get_option — 返回当前 FTP 连接的各种不同的选项设置
    • ftp_get — 从 FTP 服务器上下载一个文件
    • ftp_login — 登录 FTP 服务器
    • ftp_mdtm — 返回指定文件的最后修改时间
    • ftp_mkdir — 建立新目录
    • ftp_mlsd — 返回指定目录中的文件列表
    • ftp_nb_continue — 连续获取／发送文件（以不分块的方式 non-blocking）
    • ftp_nb_fget — 从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）
    • ftp_nb_fput — 将文件存储到 FTP 服务器 （非阻塞）
    • ftp_nb_get — 从 FTP 服务器上获取文件并写入本地文件（non-blocking）
    • ftp_nb_put — 存储一个文件至 FTP 服务器（non-blocking）
    • ftp_nlist — 返回给定目录的文件列表
    • ftp_pasv — 返回当前 FTP 被动模式是否打开
    • ftp_put — 上传文件到 FTP 服务器
    • ftp_pwd — 返回当前目录名
    • ftp_quit — ftp_close 的 别名
    • ftp_raw — 向 FTP 服务器发送命令
    • ftp_rawlist — 返回指定目录下文件的详细列表
    • ftp_rename — 更改 FTP 服务器上的文件或目录名
    • ftp_rmdir — 删除目录
    • ftp_set_option — 设置各种 FTP 运行时选项
    • ftp_site — 向服务器发送 SITE 命令
    • ftp_size — 返回指定文件的大小
    • ftp_ssl_connect — 打开 SSL-FTP 连接
    • ftp_systype — 返回远程 FTP 服务器的操作系统类型


简介

本扩展中的函数实现了通过 FTP 协议访问文件服务器的客户端。 FTP 协议在 » http://www.faqs.org/rfcs/rfc959 中定义。 本扩展提供了对于 FTP 服务器完整的访问及控制功能。 如果只是简单的从 FTP 服务器读取或向服务器写入一个文件， 请考虑使用 ftp:// 包装器 和 文件系统函数， 会更加的简单。


安装

要使用这些 FTP 相关函数，在编译的时候请添加 --enable-ftp 选项。

PHP 5 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。

从 PHP 7.0.0 开始的 Windows 版本，默认以动态的方式载入该扩展，使用前需要在 php.ini 中开启该扩展。


资源类型

本扩展使用一种资源类型，就是由 ftp_connect() 或 ftp_ssl_connect() 函数返回的连接标示符。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

FTP_ASCII (int)

FTP_AUTOSEEK (int)

更多信息请参考 ftp_set_option()。

FTP_AUTORESUME (int)

自动确定 GET 和 PUT 请求的恢复位置和开始位置（仅在启用 FTP_AUTOSEEK 的情况下有效）

FTP_FAILED (int)

异步传输失败

FTP_FINISHED (int)

异步传输完成

FTP_MOREDATA (int)

异步传输正处于活动状态

FTP_TEXT (int)

FTP_ASCII 的别名。

FTP_BINARY (int)

FTP_IMAGE (int)

FTP_BINARY 的别名。

FTP_TIMEOUT_SEC (int)

更多信息请参考 ftp_set_option()。

FTP_USEPASVADDRESS (bool)

更多信息请参考 ftp_set_option()。自 PHP 5.6.0 版本起可用。


  • ? 预定义常量
  • 基本用法 ?
  • PHP Manual
  • FTP
  • 范例

范例

Table of Contents

  • 基本用法


基本用法

Example #1 FTP 例程

<?php
// 建立基础连接
$conn_id = ftp_connect($ftp_server);

// 使用用户名和口令登录
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// 检查是否成功
if ((!$conn_id) || (!$login_result)) {
    echo "FTP connection has failed!";
    echo "Attempted to connect to $ftp_server for user $ftp_user_name";
    exit;
} else {
    echo "Connected to $ftp_server, for user $ftp_user_name";
}

// 上传文件
$upload = ftp_put($conn_id, $destination_file, $source_file, FTP_BINARY);

// 检查上传结果
if (!$upload) {
    echo "FTP upload has failed!";
} else {
    echo "Uploaded $source_file to $ftp_server as $destination_file";
}

// 关闭 FTP 流
ftp_close($conn_id);
?>


FTP 函数

Table of Contents

  • ftp_alloc — 为要上传的文件分配空间
  • ftp_append — 将文件内容追加到 FTP 服务器上的指定文件
  • ftp_cdup — 切换到当前目录的父目录
  • ftp_chdir — 在 FTP 服务器上改变当前目录
  • ftp_chmod — 设置 FTP 服务器上的文件权限
  • ftp_close — 关闭一个 FTP 连接
  • ftp_connect — 建立一个新的 FTP 连接
  • ftp_delete — 删除 FTP 服务器上的一个文件
  • ftp_exec — 在 FTP 服务器运行指定的命令
  • ftp_fget — 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中
  • ftp_fput — 上传一个已经打开的文件到 FTP 服务器
  • ftp_get_option — 返回当前 FTP 连接的各种不同的选项设置
  • ftp_get — 从 FTP 服务器上下载一个文件
  • ftp_login — 登录 FTP 服务器
  • ftp_mdtm — 返回指定文件的最后修改时间
  • ftp_mkdir — 建立新目录
  • ftp_mlsd — 返回指定目录中的文件列表
  • ftp_nb_continue — 连续获取／发送文件（以不分块的方式 non-blocking）
  • ftp_nb_fget — 从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）
  • ftp_nb_fput — 将文件存储到 FTP 服务器 （非阻塞）
  • ftp_nb_get — 从 FTP 服务器上获取文件并写入本地文件（non-blocking）
  • ftp_nb_put — 存储一个文件至 FTP 服务器（non-blocking）
  • ftp_nlist — 返回给定目录的文件列表
  • ftp_pasv — 返回当前 FTP 被动模式是否打开
  • ftp_put — 上传文件到 FTP 服务器
  • ftp_pwd — 返回当前目录名
  • ftp_quit — ftp_close 的 别名
  • ftp_raw — 向 FTP 服务器发送命令
  • ftp_rawlist — 返回指定目录下文件的详细列表
  • ftp_rename — 更改 FTP 服务器上的文件或目录名
  • ftp_rmdir — 删除目录
  • ftp_set_option — 设置各种 FTP 运行时选项
  • ftp_site — 向服务器发送 SITE 命令
  • ftp_size — 返回指定文件的大小
  • ftp_ssl_connect — 打开 SSL-FTP 连接
  • ftp_systype — 返回远程 FTP 服务器的操作系统类型


为要上传的文件分配空间

  • ? FTP 函数
  • ftp_append ?
  • PHP Manual
  • FTP 函数
  • 为要上传的文件分配空间

ftp_alloc

(PHP 5, PHP 7, PHP 8)

ftp_alloc — 为要上传的文件分配空间

说明

ftp_alloc ( resource $ftp_stream , int $filesize , string &$result = ? ) : bool

向远程 FTP 服务器发送 ALLO 命令， 来为要上传的文件分配空间。

Note:

很多 FTP 服务器不支持ALLO 命令。 如果服务器不支持此命令，将会返回错误码（false）， 返回成功码（true）表示预分配空间不是必需的， 客户端可以继续操作了。 因此，请仅对需要强制预分配空间服务器使用此函数。

参数

ftp_stream

FTP 连接标示符。

filesize

要分配的空间，以字节为单位。

result

如果提供此参数，那么服务器的响应 会以文本方式设置到 result 中。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_alloc() 函数例程

<?php

$file = "/home/user/myfile";

// 连接服务器
$conn_id = ftp_connect('ftp.example.com');
$login_result = ftp_login($conn_id, 'anonymous', 'user@example.com');

if (ftp_alloc($conn_id, filesize($file), $result)) {
  echo "Space successfully allocated on server.  Sending $file.\n";
  ftp_put($conn_id, '/incomming/myfile', $file, FTP_BINARY);
} else {
  echo "Unable to allocate space on server.  Server said: $result\n";
}

ftp_close($conn_id);

?>

参见

  • ftp_put() - 上传文件到 FTP 服务器
  • ftp_fput() - 上传一个已经打开的文件到 FTP 服务器


将文件内容追加到 FTP 服务器上的指定文件

  • ? ftp_alloc
  • ftp_cdup ?
  • PHP Manual
  • FTP 函数
  • 将文件内容追加到 FTP 服务器上的指定文件

ftp_append

(PHP 7 >= 7.2.0, PHP 8)

ftp_append — 将文件内容追加到 FTP 服务器上的指定文件

说明

ftp_append ( resource $ftp , string $remote_filename , string $local_filename , int $mode = FTP_BINARY ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

ftp

remote_filename

local_filename

mode

返回值

成功时返回 true， 或者在失败时返回 false。


切换到当前目录的父目录

  • ? ftp_append
  • ftp_chdir ?
  • PHP Manual
  • FTP 函数
  • 切换到当前目录的父目录

ftp_cdup

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_cdup — 切换到当前目录的父目录

说明

ftp_cdup ( resource $ftp_stream ) : bool

切换目录至当前目录的父目录 (上级目录)。

参数

ftp_stream

FTP 连接的标识符。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_cdup() 例子

<?php
// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// change the current directory to html
ftp_chdir($conn_id, 'html');

echo ftp_pwd($conn_id); // /html

// return to the parent directory
if (ftp_cdup($conn_id)) {
  echo "cdup successful\n";
} else {
  echo "cdup not successful\n";
}

echo ftp_pwd($conn_id); // /

ftp_close($conn_id);
?>

参见

  • ftp_chdir() - 在 FTP 服务器上改变当前目录
  • ftp_pwd() - 返回当前目录名


在 FTP 服务器上改变当前目录

  • ? ftp_cdup
  • ftp_chmod ?
  • PHP Manual
  • FTP 函数
  • 在 FTP 服务器上改变当前目录

ftp_chdir

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_chdir — 在 FTP 服务器上改变当前目录

说明

ftp_chdir ( resource $ftp_stream , string $directory ) : bool

将当前目录切换为指定的目录。

参数

ftp_stream

FTP 连接的标识符。

directory

目标目录。

返回值

成功时返回 true， 或者在失败时返回 false。如果切换目录失败，PHP 还会发出一条警告。

范例

Example #1 ftp_chdir() 例子

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// check connection
if ((!$conn_id) || (!$login_result)) {
    die("FTP connection has failed !");
}

echo "Current directory: " . ftp_pwd($conn_id) . "\n";

// try to change the directory to somedir
if (ftp_chdir($conn_id, "somedir")) {
    echo "Current directory is now: " . ftp_pwd($conn_id) . "\n";
} else {
    echo "Couldn't change directory\n";
}

// close the connection
ftp_close($conn_id);
?>

参见

  • ftp_cdup() - 切换到当前目录的父目录
  • ftp_pwd() - 返回当前目录名


设置 FTP 服务器上的文件权限

  • ? ftp_chdir
  • ftp_close ?
  • PHP Manual
  • FTP 函数
  • 设置 FTP 服务器上的文件权限

ftp_chmod

(PHP 5, PHP 7, PHP 8)

ftp_chmod — 设置 FTP 服务器上的文件权限

说明

ftp_chmod ( resource $ftp_stream , int $mode , string $filename ) : int

将服务器上的文件权限设置为 mode 指定的值。

参数

ftp_stream

FTP 连接标示符。

mode

要设置的权限值， 八进制 值。

filename

远程文件名称。

返回值

操作成功返回文件新的权限，操作失败返回 false 。

范例

Example #1 ftp_chmod() 函数例程

<?php
$file = 'public_html/index.php';

// 建立基础连接
$conn_id = ftp_connect($ftp_server);

// 使用用户名和密码登录
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// 尝试设置 $file 的权限为 644
if (ftp_chmod($conn_id, 0644, $file) !== false) {
 echo "$file chmoded successfully to 644\n";
} else {
 echo "could not chmod $file\n";
}

// 关闭连接
ftp_close($conn_id);
?>

参见

  • chmod() - 改变文件模式


关闭一个 FTP 连接

  • ? ftp_chmod
  • ftp_connect ?
  • PHP Manual
  • FTP 函数
  • 关闭一个 FTP 连接

ftp_close

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ftp_close — 关闭一个 FTP 连接

说明

ftp_close ( resource $ftp_stream ) : bool

ftp_close() 关闭给出的连接标识符并释放资源。

Note:

调用本函数后，将不能再使用 FTP 连接，必须用 ftp_connect() 建立一个新连接。

参数

ftp_stream

FTP 连接的标识符。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_close() 例子

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// print the current directory
echo ftp_pwd($conn_id); // /

// close this connection
ftp_close($conn_id);
?>

参见

  • ftp_connect() - 建立一个新的 FTP 连接


建立一个新的 FTP 连接

  • ? ftp_close
  • ftp_delete ?
  • PHP Manual
  • FTP 函数
  • 建立一个新的 FTP 连接

ftp_connect

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_connect — 建立一个新的 FTP 连接

说明

ftp_connect ( string $host , int $port = 21 , int $timeout = 90 ) : resource

ftp_connect() 将会建立一个 FTP 连接到指定的服务器 host。

参数

host

要连接的服务器地址。此参数后面不应以斜线结尾，前面也不需要用 ftp:// 开头。

port

为要连接到的 FTP 器的端口号，如果没有设置或者为 0，则会使用默认的端口 21 来连接。

timeout

用来设置网络传输的超时时间限制。如果此选项留空，则默认的值为 90 秒。超时时间可以在任何时候通过函数 ftp_set_option() 及 ftp_get_option() 来改变和获取。

返回值

如果成功返回一个 FTP 连接资源句柄，发生错误则返回 false。

范例

Example #1 ftp_connect() 示例

<?php

$ftp_server = "ftp.example.com";

// set up a connection or die
$conn_id = ftp_connect($ftp_server) or die("Couldn't connect to $ftp_server");

?>

参见

  • ftp_close() - 关闭一个 FTP 连接
  • ftp_ssl_connect() - 打开 SSL-FTP 连接


删除 FTP 服务器上的一个文件

  • ? ftp_connect
  • ftp_exec ?
  • PHP Manual
  • FTP 函数
  • 删除 FTP 服务器上的一个文件

ftp_delete

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_delete — 删除 FTP 服务器上的一个文件

说明

ftp_delete ( resource $ftp_stream , string $path ) : bool

ftp_delete() 函数用来删除 FTP 服务器上的一个由参数 path 指定的的文件。

参数

ftp_stream

FTP 连接的链接标识符。

path

要删除的文件。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_delete() 例子

<?php
$file = 'public_html/old.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to delete $file
if (ftp_delete($conn_id, $file)) {
 echo "$file deleted successful\n";
} else {
 echo "could not delete $file\n";
}

// close the connection
ftp_close($conn_id);
?>


在 FTP 服务器运行指定的命令

  • ? ftp_delete
  • ftp_fget ?
  • PHP Manual
  • FTP 函数
  • 在 FTP 服务器运行指定的命令

ftp_exec

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

ftp_exec — 在 FTP 服务器运行指定的命令

说明

ftp_exec ( resource $ftp_stream , string $command ) : bool

发送一个 SITE EXEC command 请求到 FTP 服务器。

参数

ftp_stream

FTP 连接资源句柄。

command

要执行的命令。

返回值

如果执行成功（服务器发送响应代码 200）则返回 true；否则返回 false。

范例

Example #1 ftp_exec() 示例

<?php

// variable initialization
$command = 'ls -al >files.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// execute command
if (ftp_exec($conn_id, $command)) {
    echo "$command executed successfully\n";
} else {
    echo "could not execute $command\n";
}

// close the connection
ftp_close($conn_id);

?>

参见

  • ftp_raw() - 向 FTP 服务器发送命令


从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中

  • ? ftp_exec
  • ftp_fput ?
  • PHP Manual
  • FTP 函数
  • 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中

ftp_fget

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_fget — 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中

说明

ftp_fget ( resource $ftp_stream , resource $handle , string $remote_file , int $mode , int $resumepos = 0 ) : bool

ftp_fget() 函数用来下载由 remote_file 指定的文件，并写入到本地已经被打开的一个文件中。

参数

ftp_stream

FTP 连接的链接标识符。

handle

本地已经打开的文件的句柄。

remote_file

远程文件的路径。

mode

传送模式参数， 必须是 (文本模式) FTP_ASCII 或 (二进制模式) FTP_BINARY 中的一个。

resumepos

远程文件开始下载的位置。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_fget() 例子

<?php

// path to remote file
$remote_file = 'somefile.txt';
$local_file = 'localfile.txt';

// open some file to write to
$handle = fopen($local_file, 'w');

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to download $remote_file and save it to $handle
if (ftp_fget($conn_id, $handle, $remote_file, FTP_ASCII, 0)) {
 echo "successfully written to $local_file\n";
} else {
 echo "There was a problem while downloading $remote_file to $local_file\n";
}

// close the connection and the file handler
ftp_close($conn_id);
fclose($handle);
?>

更新日志

版本 | 说明
4.3.0 | 增加了resumepos 的支持。

参见

  • ftp_get() - 从 FTP 服务器上下载一个文件
  • ftp_nb_get() - 从 FTP 服务器上获取文件并写入本地文件（non-blocking）
  • ftp_nb_fget() - 从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）


上传一个已经打开的文件到 FTP 服务器

  • ? ftp_fget
  • ftp_get_option ?
  • PHP Manual
  • FTP 函数
  • 上传一个已经打开的文件到 FTP 服务器

ftp_fput

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_fput — 上传一个已经打开的文件到 FTP 服务器

说明

ftp_fput ( resource $ftp_stream , string $remote_file , resource $handle , int $mode , int $startpos = 0 ) : bool

ftp_fput() 函数用来上传一个在已经打开的文件中的数据到 FTP 服务器。

参数

ftp_stream

FTP 连接的链接标识符。

remote_file

远程文件路径。

handle

打开的本地文件句柄，读取到文件末尾。

mode

传输模式只能为 (文本模式) FTP_ASCII 或 (二进制模式) FTP_BINARY 其中的一个。

startpos

远程文件上传的开始位置。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_fput() 例子

<?php

// open some file for reading
$file = 'somefile.txt';
$fp = fopen($file, 'r');

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to upload $file
if (ftp_fput($conn_id, $file, $fp, FTP_ASCII)) {
    echo "Successfully uploaded $file\n";
} else {
    echo "There was a problem while uploading $file\n";
}

// close the connection and the file handler
ftp_close($conn_id);
fclose($fp);

?>

更新日志

版本 | 说明
4.3.0 | 添加了 startpos 的支持。

参见

  • ftp_put() - 上传文件到 FTP 服务器
  • ftp_nb_fput() - 将文件存储到 FTP 服务器 （非阻塞）
  • ftp_nb_put() - 存储一个文件至 FTP 服务器（non-blocking）


返回当前 FTP 连接的各种不同的选项设置

  • ? ftp_fput
  • ftp_get ?
  • PHP Manual
  • FTP 函数
  • 返回当前 FTP 连接的各种不同的选项设置

ftp_get_option

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ftp_get_option — 返回当前 FTP 连接的各种不同的选项设置

说明

ftp_get_option ( resource $ftp_stream , int $option ) : mixed

此函数会返回连接句柄为 ftp_stream，指定键值 option 的值。

参数

ftp_stream

FTP 连接资源句柄。

option

截止到目前，支持的选项有：

支持的运行时 FTP 选项
FTP_TIMEOUT_SEC | 返回当前设定的网络操作的超时时间。
FTP_AUTOSEEK | 此选项打开时返回 true，否则返回 false。

返回值

如果成功则返回选项的值，否则，如果给定的参数 option 选项不被支持则返回 false，同时会抛出一条警告（warning）信息。

范例

Example #1 ftp_get_option() 示例

<?php
// Get the timeout of the given FTP stream
$timeout = ftp_get_option($conn_id, FTP_TIMEOUT_SEC);
?>

参见

  • ftp_set_option() - 设置各种 FTP 运行时选项


从 FTP 服务器上下载一个文件

  • ? ftp_get_option
  • ftp_login ?
  • PHP Manual
  • FTP 函数
  • 从 FTP 服务器上下载一个文件

ftp_get

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_get — 从 FTP 服务器上下载一个文件

说明

ftp_get ( resource $ftp_stream , string $local_file , string $remote_file , int $mode , int $resumepos = 0 ) : bool

ftp_get() 函数用来下载 FTP 服务器上指定的文件并保存为本地文件。

参数

ftp_stream

FTP 连接的链接标识符。

local_file

文件本地的路径（如果文件已经存在，则会被覆盖）。

remote_file

文件的远程路径。

mode

传送模式。只能为 (文本模式) FTP_ASCII 或 (二进制模式) FTP_BINARY 中的其中一个。

resumepos

从远程文件的这个位置继续下载。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_get() 例子

<?php

// define some variables
$local_file = 'local.zip';
$server_file = 'server.zip';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to download $server_file and save to $local_file
if (ftp_get($conn_id, $local_file, $server_file, FTP_BINARY)) {
    echo "Successfully written to $local_file\n";
} else {
    echo "There was a problem\n";
}

// close the connection
ftp_close($conn_id);

?>

更新日志

版本 | 说明
4.3.0 | 增加了 resumepos。

参见

  • ftp_pasv() - 返回当前 FTP 被动模式是否打开
  • ftp_fget() - 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中
  • ftp_nb_get() - 从 FTP 服务器上获取文件并写入本地文件（non-blocking）
  • ftp_nb_fget() - 从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）


登录 FTP 服务器

  • ? ftp_get
  • ftp_mdtm ?
  • PHP Manual
  • FTP 函数
  • 登录 FTP 服务器

ftp_login

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_login — 登录 FTP 服务器

说明

ftp_login ( resource $ftp_stream , string $username , string $password ) : bool

使用用户名和密码登录入给定的 FTP 连接。

参数

ftp_stream

FTP 连接的链接标识符。

username

用户名（USER）。

password

密码（PASS）。

返回值

成功时返回 true， 或者在失败时返回 false。 如果登录失败，PHP 会抛出一个警告。

范例

Example #1 ftp_login() 例子

<?php

$ftp_server = "ftp.example.com";
$ftp_user = "foo";
$ftp_pass = "bar";

// 设置一个连接或失败时退出
$conn_id = ftp_connect($ftp_server) or die("Couldn't connect to $ftp_server");

// 尝试登录
if (@ftp_login($conn_id, $ftp_user, $ftp_pass)) {
    echo "Connected as $ftp_user@$ftp_server\n";
} else {
    echo "Couldn't connect as $ftp_user\n";
}

// 关闭连接
ftp_close($conn_id);
?>


返回指定文件的最后修改时间

  • ? ftp_login
  • ftp_mkdir ?
  • PHP Manual
  • FTP 函数
  • 返回指定文件的最后修改时间

ftp_mdtm

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_mdtm — 返回指定文件的最后修改时间

说明

ftp_mdtm ( resource $ftp_stream , string $remote_file ) : int

ftp_mdtm() 获取远程文件的最后修改时间。

Note:

某些 FTP 服务器可能会不支持这个特性！

Note:

ftp_mdtm() 不适用于检查目录。

参数

ftp_stream

FTP 连接句柄。

remote_file

要检查的远程文件。

返回值

返回指定文件的最后修改时间，以 UNIX 时间戳的方式返回。如果发生错误，或文件不存在则返回 -1。

范例

Example #1 ftp_mdtm() 示例

<?php

$file = 'somefile.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

//  get the last modified time
$buff = ftp_mdtm($conn_id, $file);

if ($buff != -1) {
    // somefile.txt was last modified on: March 26 2003 14:16:41.
    echo "$file was last modified on : " . date("F d Y H:i:s.", $buff);
} else {
    echo "Couldn't get mdtime";
}

// close the connection
ftp_close($conn_id);

?>


建立新目录

  • ? ftp_mdtm
  • ftp_mlsd ?
  • PHP Manual
  • FTP 函数
  • 建立新目录

ftp_mkdir

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_mkdir — 建立新目录

说明

ftp_mkdir ( resource $ftp_stream , string $directory ) : string

在 FTP 服务器上，创建指定的目录 directory。

参数

ftp_stream

FTP 连接句柄。

directory

要创建的目录名。

返回值

如果成功返回新建的目录名，发生错误时返回 false。

范例

Example #1 ftp_mkdir() example

<?php

$dir = 'www';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to create the directory $dir
if (ftp_mkdir($conn_id, $dir)) {
 echo "successfully created $dir\n";
} else {
 echo "There was a problem while creating $dir\n";
}

// close the connection
ftp_close($conn_id);
?>

参见

  • ftp_rmdir() - 删除目录


返回指定目录中的文件列表

  • ? ftp_mkdir
  • ftp_nb_continue ?
  • PHP Manual
  • FTP 函数
  • 返回指定目录中的文件列表

ftp_mlsd

(PHP 7 >= 7.2.0, PHP 8)

ftp_mlsd — 返回指定目录中的文件列表

说明

ftp_mlsd ( resource $ftp , string $directory ) : array|false

参数

ftp

FTP 连接的链接标识符。

directory

要列出的目录。

返回值

如果成功，则返回一个由目录中所有文件信息（数组）所组成的数组； 如果错误，则返回 false 。

范例

Example #1 ftp_mlsd() 示例

<?php

// 简单基本连接
$conn_id = ftp_connect($ftp_server);

// 使用用户名和密码进行登录
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// 获取当前目录的内容
$contents = ftp_mlsd($conn_id, ".");

// 输出 $contents
var_dump($contents);

?>

以上例程的输出类似于：

array(5) {
  [0]=>
  array(8) {
    ["name"]=>
    string(1) "."
    ["modify"]=>
    string(14) "20171212154511"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(4) "cdir"
    ["unique"]=>
    string(11) "811U5740002"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
  [1]=>
  array(8) {
    ["name"]=>
    string(2) ".."
    ["modify"]=>
    string(14) "20171212154511"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(4) "pdir"
    ["unique"]=>
    string(11) "811U5740002"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
  [2]=>
  array(8) {
    ["name"]=>
    string(11) "public_html"
    ["modify"]=>
    string(14) "20171211171525"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(3) "dir"
    ["unique"]=>
    string(11) "811U5740525"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
  [3]=>
  array(8) {
    ["name"]=>
    string(10) "public_ftp"
    ["modify"]=>
    string(14) "20171211174536"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(3) "dir"
    ["unique"]=>
    string(11) "811U57405EE"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
  [4]=>
  array(8) {
    ["name"]=>
    string(3) "www"
    ["modify"]=>
    string(14) "www"
    ["perm"]=>
    string(7) "flcdmpe"
    ["type"]=>
    string(3) "dir"
    ["unique"]=>
    string(11) "811U5740780"
    ["UNIX.group"]=>
    string(2) "33"
    ["UNIX.mode"]=>
    string(4) "0755"
    ["UNIX.owner"]=>
    string(2) "33"
  }
}

参见

  • ftp_rawlist() - 返回指定目录下文件的详细列表
  • ftp_nlist() - 返回给定目录的文件列表


连续获取／发送文件（以不分块的方式 non-blocking）

  • ? ftp_mlsd
  • ftp_nb_fget ?
  • PHP Manual
  • FTP 函数
  • 连续获取／发送文件（以不分块的方式 non-blocking）

ftp_nb_continue

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_continue — 连续获取／发送文件（以不分块的方式 non-blocking）

说明

ftp_nb_continue ( resource $ftp_stream ) : int

以不分块的方式，连续获取/发送文件。

参数

ftp_stream

FTP 连接句柄。

返回值

返回 FTP_FAILED 或 FTP_FINISHED 或 FTP_MOREDATA.

范例

Example #1 ftp_nb_continue() 示例

<?php

// Initiate the download
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}
?>


从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）

  • ? ftp_nb_continue
  • ftp_nb_fput ?
  • PHP Manual
  • FTP 函数
  • 从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）

ftp_nb_fget

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_fget — 从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）

说明

ftp_nb_fget ( resource $ftp_stream , resource $handle , string $remote_file , int $mode = FTP_IMAGE , int $resumepos = 0 ) : int

ftp_nb_fget() 从远程 FTP 服务器获取一个文件

本函数和 ftp_fget() 函数的区别是 本函数是异步方式获取文件的， 所以在下载文件的过程中你的程序还可以执行其他操作。

参数

ftp_stream

FTP 连接标示符。

handle

用来存储数据的一个已经打开的文件句柄。

remote_file

远程文件路径。

mode

传输模式，必须是 FTP_ASCII 或者 FTP_BINARY。

resumepos

远程文件开始下载的位置（即从远程文件的哪个字节开始下载）。

返回值

返回 FTP_FAILED 或 FTP_FINISHED 或 FTP_MOREDATA。

更新日志

版本 | 说明
7.3.0 | 参数 mode 变为可选参数。 在之前的版本中，这是一个必填参数。

范例

Example #1 ftp_nb_fget() 函数例程

<?php

// 打开要写入的文件
$file = 'index.php';
$fp = fopen($file, 'w');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// 初始化下载
$ret = ftp_nb_fget($conn_id, $fp, $file, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // 其他要做的工作
   echo ".";

   // 继续下载...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}

// 关闭文件句柄
fclose($fp);
?>

参见

  • ftp_nb_get() - 从 FTP 服务器上获取文件并写入本地文件（non-blocking）
  • ftp_nb_continue() - 连续获取／发送文件（以不分块的方式 non-blocking）
  • ftp_fget() - 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中
  • ftp_get() - 从 FTP 服务器上下载一个文件


将文件存储到 FTP 服务器 （非阻塞）

  • ? ftp_nb_fget
  • ftp_nb_get ?
  • PHP Manual
  • FTP 函数
  • 将文件存储到 FTP 服务器 （非阻塞）

ftp_nb_fput

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_fput — 将文件存储到 FTP 服务器 （非阻塞）

说明

ftp_nb_fput ( resource $ftp_stream , string $remote_file , resource $handle , int $mode = FTP_IMAGE , int $startpos = 0 ) : int

ftp_nb_fput() 把已打开的文件内容存储到远程 FTP 服务器

本函数和 ftp_fput() 函数的区别是 本函数是异步上传文件。 所以在文件上传过程中，你的程序还可以执行其他操作。

参数

ftp_stream

FTP 连接标示符。

remote_file

远程文件路径。

handle

已经打开的本地文件指针，当读取到文件末尾时结束。

mode

传输模式。必须是 FTP_ASCII 或 FTP_BINARY。

startpos

要将文件存储到远程文件的开始位置（即从远程文件的哪个字节位置开始存储）。

返回值

返回 FTP_FAILED 或 FTP_FINISHED 或 FTP_MOREDATA。

更新日志

版本 | 说明
7.3.0 | 参数 mode 变为可选参数。 在之前的版本中，这是一个必填参数。

范例

Example #1 ftp_nb_fput() 函数例程

<?php

$file = 'index.php';

$fp = fopen($file, 'r');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// 初始化上传
$ret = ftp_nb_fput($conn_id, $file, $fp, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // 任何其他需要做的操作
   echo ".";

   // 继续上传...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error uploading the file...";
   exit(1);
}

fclose($fp);
?>

参见

  • ftp_nb_put() - 存储一个文件至 FTP 服务器（non-blocking）
  • ftp_nb_continue() - 连续获取／发送文件（以不分块的方式 non-blocking）
  • ftp_put() - 上传文件到 FTP 服务器
  • ftp_fput() - 上传一个已经打开的文件到 FTP 服务器


从 FTP 服务器上获取文件并写入本地文件（non-blocking）

  • ? ftp_nb_fput
  • ftp_nb_put ?
  • PHP Manual
  • FTP 函数
  • 从 FTP 服务器上获取文件并写入本地文件（non-blocking）

ftp_nb_get

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_get — 从 FTP 服务器上获取文件并写入本地文件（non-blocking）

说明

ftp_nb_get ( resource $ftp_stream , string $local_file , string $remote_file , int $mode = FTP_BINARY , int $resumepos = 0 ) : int

ftp_nb_get() 在 FTP 服务器上获取指定的远程文件，并保存到本地。

和 ftp_get() 不同之处，在于此函数是通过异步的方式来获取文件，这意味着，你的程序可以在下载文件的同时，同步进行其它操作。

参数

ftp_stream

FTP 连接句柄。

local_file

保存到的本地文件路径（如果文件已存在会被覆盖）。

remote_file

远程文件路径。

mode

指定传输模式。必须是 FTP_ASCII 或 FTP_BINARY。

resumepos

开始下载文件的起始位置。

返回值

返回 FTP_FAILED 或 FTP_FINISHED 或 FTP_MOREDATA。

更新日志

版本 | 说明
7.3.0 | mode 参数变为可选，之前是强制性的。

范例

Example #1 ftp_nb_get() 示例

<?php

// 初始化
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // 可以同步干其它事
   echo ".";

   // 继续下载...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "下载文件出错...";
   exit(1);
}
?>

Example #2 通过 ftp_nb_get() 恢复下载一个文件

<?php

// 初始化
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY,
                      filesize("test"));
// OR: $ret = ftp_nb_get($my_connection, "test", "README",
//                           FTP_BINARY, FTP_AUTORESUME);
while ($ret == FTP_MOREDATA) {

   // 做你爱做的事
   echo ".";

   // 继续下载Ing...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "下载文件出错...";
   exit(1);
}
?>

Example #3 使用 ftp_nb_get() 从指定位置恢复下载文件

<?php

// 禁止 Autoseek
ftp_set_option($my_connection, FTP_AUTOSEEK, false);

// 初始化
$ret = ftp_nb_get($my_connection, "newfile", "README", FTP_BINARY, 100);
while ($ret == FTP_MOREDATA) {

   /* ... */

   // 继续下载...
   $ret = ftp_nb_continue($my_connection);
}
?>

在上面的示例中，newfile 会比 FTP 服务器上的 README 文件小 100 bytes，因为开始下载的时候设置了偏移量为 100。如果我们不禁止 FTP_AUTOSEEK，则 newfile 文件前面的 100 bytes 会变成 '\0'。

参见

  • ftp_nb_fget() - 从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）
  • ftp_nb_continue() - 连续获取／发送文件（以不分块的方式 non-blocking）
  • ftp_fget() - 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中
  • ftp_get() - 从 FTP 服务器上下载一个文件


存储一个文件至 FTP 服务器（non-blocking）

  • ? ftp_nb_get
  • ftp_nlist ?
  • PHP Manual
  • FTP 函数
  • 存储一个文件至 FTP 服务器（non-blocking）

ftp_nb_put

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_nb_put — 存储一个文件至 FTP 服务器（non-blocking）

说明

ftp_nb_put ( resource $ftp_stream , string $remote_file , string $local_file , int $mode = FTP_BINARY , int $startpos = 0 ) : int

ftp_nb_put() 函数用来把本地文件 local_file 存储到 FTP 服务器上由 remote_file 参数指定的路径。

与函数 ftp_put() 不同的是，此函数上传文件的时候采用的是异步传输模式，也就意味着在文件传送的过程中，你的程序可以继续干其它的事情。

参数

ftp_stream

FTP 连接的链接标识符。

remote_file

远程文件路径。

local_file

本地文件路径。

mode

传输模式选择，可选参数为 FTP_ASCII（文本模式）或 FTP_BINARY（二进制模式）。

startpos

指定传输开始的位置，用来续传支持。

返回值

返回 FTP_FAILED 或 FTP_FINISHED 或 FTP_MOREDATA。

更新日志

版本 | 说明
7.3.0 | mode 参数为可选，之前版本中为必填。

范例

Example #1 ftp_nb_put() 示例

<?php

// 初始化
$ret = ftp_nb_put($my_connection, "test.remote", "test.local", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // 可以同时干其它事
   echo ".";

   // 继续上传...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "上传过程中发生错误...";
   exit(1);
}
?>

Example #2 使用 ftp_nb_put() 来续传文件

<?php

// 初始化
$ret = ftp_nb_put($my_connection, "test.remote", "test.local",
                      FTP_BINARY, ftp_size("test.remote"));
// 另一种写法: $ret = ftp_nb_put($my_connection, "test.remote", "test.local",
//                           FTP_BINARY, FTP_AUTORESUME);

while ($ret == FTP_MOREDATA) {

   // 可以同时干其它事情
   echo ".";

   // 继续上传...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "上传过程中发生错误...";
   exit(1);
}
?>

参见

  • ftp_nb_fput() - 将文件存储到 FTP 服务器 （非阻塞）
  • ftp_nb_continue() - 连续获取／发送文件（以不分块的方式 non-blocking）
  • ftp_put() - 上传文件到 FTP 服务器
  • ftp_fput() - 上传一个已经打开的文件到 FTP 服务器


返回给定目录的文件列表

  • ? ftp_nb_put
  • ftp_pasv ?
  • PHP Manual
  • FTP 函数
  • 返回给定目录的文件列表

ftp_nlist

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_nlist — 返回给定目录的文件列表

说明

ftp_nlist ( resource $ftp_stream , string $directory ) : array

参数

ftp_stream

FTP 连接资源。

directory

指定要列表的目录。本参数接受带参数的形式，例如： ftp_nlist($conn_id, "-la /you/dir"); 注意此参数不对传入值做处理，在目录或者文件名包括空格或特殊的情况下，可能会存在问题。

返回值

如果成功则返回给定目录下的文件名组成的数组，否则返回 false。

范例

Example #1 ftp_nlist() 例子

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// check connection
if ((!$conn_id) || (!$login_result)) {
    die("FTP connection has failed !");
}

// get contents of the root directory
$contents = ftp_nlist($conn_id, "/");

// output $contents
var_dump($contents);

?>

以上例程的输出类似于：

array(3) {
  [0]=>
  string(11) "public_html"
  [1]=>
  string(10) "public_ftp"
  [2]=>
  string(3) "www"

参见

  • ftp_rawlist() - 返回指定目录下文件的详细列表
  • ftp_mlsd() - 返回指定目录中的文件列表


返回当前 FTP 被动模式是否打开

  • ? ftp_nlist
  • ftp_put ?
  • PHP Manual
  • FTP 函数
  • 返回当前 FTP 被动模式是否打开

ftp_pasv

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_pasv — 返回当前 FTP 被动模式是否打开

说明

ftp_pasv ( resource $ftp_stream , bool $pasv ) : bool

在被动模式打开的情况下，数据的传送由客户机启动，而不是由服务器开始。

请注意 ftp_pasv() 只能在 FTP 登录成功后方可调用，否则会失败。

参数

ftp_stream

FTP 连接资源。

pasv

如果参数 pasv 为 true，打开被动模式传输 (PASV MODE) ，否则则关闭被动传输模式。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_pasv() 实例

<?php
$file = 'somefile.txt';
$remote_file = 'readme.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// turn passive mode on
ftp_pasv($conn_id, true);

// upload a file
if (ftp_put($conn_id, $remote_file, $file, FTP_ASCII)) {
 echo "successfully uploaded $file\n";
} else {
 echo "There was a problem while uploading $file\n";
}

// close the connection
ftp_close($conn_id);
?>


上传文件到 FTP 服务器

  • ? ftp_pasv
  • ftp_pwd ?
  • PHP Manual
  • FTP 函数
  • 上传文件到 FTP 服务器

ftp_put

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_put — 上传文件到 FTP 服务器

说明

ftp_put ( resource $ftp_stream , string $remote_file , string $local_file , int $mode = FTP_BINARY , int $startpos = 0 ) : bool

ftp_put() 函数用来上传指定的本地文件到 FTP 服务器。

参数

ftp_stream

FTP 连接资源。

remote_file

远程文件路径。

local_file

本地文件路径。

mode

传送模式，只能为 FTP_ASCII（文本模式）或 FTP_BINARY（二进制模式）。

startpos

指定开始上传的位置，一般用来文件续传。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.3.0 | mode 参数为可选，之前版本中为必选。

范例

Example #1 ftp_put() 实例

<?php
$file = 'somefile.txt';
$remote_file = 'readme.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// upload a file
if (ftp_put($conn_id, $remote_file, $file, FTP_ASCII)) {
 echo "successfully uploaded $file\n";
} else {
 echo "There was a problem while uploading $file\n";
}

// close the connection
ftp_close($conn_id);
?>

参见

  • ftp_pasv() - 返回当前 FTP 被动模式是否打开
  • ftp_fput() - 上传一个已经打开的文件到 FTP 服务器
  • ftp_nb_fput() - 将文件存储到 FTP 服务器 （非阻塞）
  • ftp_nb_put() - 存储一个文件至 FTP 服务器（non-blocking）


返回当前目录名

  • ? ftp_put
  • ftp_quit ?
  • PHP Manual
  • FTP 函数
  • 返回当前目录名

ftp_pwd

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_pwd — 返回当前目录名

说明

ftp_pwd ( resource $ftp_stream ) : string

参数

ftp_stream

FTP 连接资源。

返回值

返回当前目录名称，发生错误则返回 false。

范例

Example #1 ftp_pwd() 例子

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// change directory to public_html
ftp_chdir($conn_id, 'public_html');

// print current directory
echo ftp_pwd($conn_id); // /public_html

// close the connection
ftp_close($conn_id);
?>

参见

  • ftp_chdir() - 在 FTP 服务器上改变当前目录
  • ftp_cdup() - 切换到当前目录的父目录


ftp_close 的 别名

  • ? ftp_pwd
  • ftp_raw ?
  • PHP Manual
  • FTP 函数
  • ftp_close 的 别名

ftp_quit

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_quit — ftp_close() 的 别名

说明

此函数是该函数的别名： ftp_close()


向 FTP 服务器发送命令

  • ? ftp_quit
  • ftp_rawlist ?
  • PHP Manual
  • FTP 函数
  • 向 FTP 服务器发送命令

ftp_raw

(PHP 5, PHP 7, PHP 8)

ftp_raw — 向 FTP 服务器发送命令

说明

ftp_raw ( resource $ftp_stream , string $command ) : array

向 FTP 服务器发送任意 command。

参数

ftp_stream

FTP 连接标示符。

command

要执行的命令。

返回值

将服务器的响应以字符串数组的形式返回。 对于响应内容既不做解析处理， 也不检测命令是否执行成功。

范例

Example #1 使用 ftp_raw() 登录远程 FTP 服务器

<?php
$fp = ftp_connect("ftp.example.com");

/* 等同于
   ftp_login($fp, "joeblow", "secret"); */
ftp_raw($fp, "USER joeblow");
ftp_raw($fp, "PASS secret");
?>

参见

  • ftp_exec() - 在 FTP 服务器运行指定的命令


返回指定目录下文件的详细列表

  • ? ftp_raw
  • ftp_rename ?
  • PHP Manual
  • FTP 函数
  • 返回指定目录下文件的详细列表

ftp_rawlist

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_rawlist — 返回指定目录下文件的详细列表

说明

ftp_rawlist ( resource $ftp_stream , string $directory , bool $recursive = false ) : array

ftp_rawlist() 函数将执行 FTP LIST 命令，并把结果做为一个数组返回。

参数

ftp_stream

FTP 连接资源。

directory

要操作的目录路径，可以包括 LIST 参数。

recursive

如果此参数为 true，实际执行的命令将会为 LIST -R。

返回值

返回一个数组，数组的每个元素为返回文本的每一行，输出结构不会被解析。使用函数 ftp_systype() 可以用来判断 FTP 服务器的类型，从而可以用来判断返回列表的类型。

The output is not parsed in any way. The system type identifier returned by ftp_systype() can be used to determine how the results should be interpreted.

范例

Example #1 ftp_rawlist() 示例

<?php

// 初始化连接
$conn_id = ftp_connect($ftp_server);

// 使用用户名和密码登录
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// 获取 / 路径下的文件列表
$buff = ftp_rawlist($conn_id, '/');

// 关闭连接
ftp_close($conn_id);

// 输出
var_dump($buff);
?>

以上例程的输出类似于：

array(3) {
  [0]=>
  string(65) "drwxr-x---   3 vincent  vincent      4096 Jul 12 12:16 public_ftp"
  [1]=>
  string(66) "drwxr-x---  15 vincent  vincent      4096 Nov  3 21:31 public_html"
  [2]=>
  string(73) "lrwxrwxrwx   1 vincent  vincent        11 Jul 12 12:16 www -> public_html"
}

参见

  • ftp_nlist() - 返回给定目录的文件列表
  • ftp_mlsd() - 返回指定目录中的文件列表


更改 FTP 服务器上的文件或目录名

  • ? ftp_rawlist
  • ftp_rmdir ?
  • PHP Manual
  • FTP 函数
  • 更改 FTP 服务器上的文件或目录名

ftp_rename

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_rename — 更改 FTP 服务器上的文件或目录名

说明

ftp_rename ( resource $ftp_stream , string $oldname , string $newname ) : bool

ftp_rename() 将 FTP 服务器上的一个文件或目录改名。

参数

ftp_stream

FTP 连接的标识符。

oldname

原来的文件／目录名。

newname

新名字。

返回值

成功时返回 true， 或者在失败时返回 false。 失败时（比如试图重命名一个不存在的文件）将会抛出一个 E_WARNING 错误信息。

范例

Example #1 ftp_rename() 例子

<?php
$old_file = 'somefile.txt.bak';
$new_file = 'somefile.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to rename $old_file to $new_file
if (ftp_rename($conn_id, $old_file, $new_file)) {
    echo "successfully renamed $old_file to $new_file\n";
} else {
    echo "There was a problem while renaming $old_file to $new_file\n";
}

// close the connection
ftp_close($conn_id);
?>


删除目录

  • ? ftp_rename
  • ftp_set_option ?
  • PHP Manual
  • FTP 函数
  • 删除目录

ftp_rmdir

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_rmdir — 删除目录

说明

ftp_rmdir ( resource $ftp , string $directory ) : bool

删除 FTP 服务器上 directory 参数指定的目录。

参数

ftp

FTP 连接的链接标识符。

directory

要删除的目录。必须是一个空目录的绝对路径或相对路径。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ftp_rmdir() 示例

<?php
$dir = 'www/';

// 简单基本连接
$conn_id = ftp_connect($ftp_server);

// 使用用户名和密码进行登录
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// 尝试删除 $dir 目录
if (ftp_rmdir($conn_id, $dir)) {
    echo "Successfully deleted $dir\n";
} else {
    echo "There was a problem while deleting $dir\n";
}

ftp_close($conn_id);

?>

参见

  • ftp_mkdir() - 建立新目录


设置各种 FTP 运行时选项

  • ? ftp_rmdir
  • ftp_site ?
  • PHP Manual
  • FTP 函数
  • 设置各种 FTP 运行时选项

ftp_set_option

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ftp_set_option — 设置各种 FTP 运行时选项

说明

ftp_set_option ( resource $ftp_stream , int $option , mixed $value ) : bool

本函数控制指定 FTP 流的各种运行时选项。

参数

ftp_stream

FTP 连接的标识符。

option

目前支持以下选项：

所支持的 FTP 运行时选项
FTP_TIMEOUT_SEC | 改变网络传输的超时时间。参数 value 必须为整数且大于 0。默认的超时时间为 90 秒。
FTP_AUTOSEEK | 当此选项打开时，带 resumepos 或 startpos 参数的GET 或 PUT 请求 将先检索到文件中指定的位置。此选项默认是打开的。
FTP_USEPASVADDRESS | 当此选项禁用时，PHP 会忽略掉 FTP 服务器通过 PASV 命令返回的 IP 地址，直接使用在 ftp_connect() 中指定的地址。value 参数必须是布尔型。

value

本参数取决于要修改哪个 option。

返回值

如果选项能够被设置，返回 true，否则返回 false。如果参数 option 不被支持或者给定的参数 value 的值与参数 option 不匹配，则会同时返回一条警告信息。

范例

Example #1 ftp_set_option() 例子

<?php
// 设置网络传输超时时间为 10 秒
ftp_set_option($conn_id, FTP_TIMEOUT_SEC, 10);
?>

参见

  • ftp_get_option() - 返回当前 FTP 连接的各种不同的选项设置


向服务器发送 SITE 命令

  • ? ftp_set_option
  • ftp_size ?
  • PHP Manual
  • FTP 函数
  • 向服务器发送 SITE 命令

ftp_site

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_site — 向服务器发送 SITE 命令

说明

ftp_site ( resource $ftp_stream , string $command ) : bool

ftp_site() 函数向 FTP 服务器发送指定的命令。

SITE 命令是非标准化的，不同的服务器不尽相同。主要用于处理文件权限以及组成员等事情。

参数

ftp_stream

FTP 连接资源。

command

SITE 命令。注意本参数没有经过处理，在文件名有存在空格或其它特殊字符的情况下可能会有问题。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 向一个 FTP 服务器发送一条 SITE 命令

<?php
// 连接 FTP 服务器
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('无法连接到 ftp.example.com');

// 使用用户 user 和密码 pass 登录服务器
if (!ftp_login($conn, 'user', 'pass')) die('登录失败到 ftp.example.com');

// Issue: "SITE CHMOD 0600 /home/user/privatefile" command to ftp server
if (ftp_site($conn, 'CHMOD 0600 /home/user/privatefile')) {
   echo "命令执行成功。\n";
} else {
   die('命令执行失败。');
}
?>

参见

  • ftp_raw() - 向 FTP 服务器发送命令


返回指定文件的大小

  • ? ftp_site
  • ftp_ssl_connect ?
  • PHP Manual
  • FTP 函数
  • 返回指定文件的大小

ftp_size

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_size — 返回指定文件的大小

说明

ftp_size ( resource $ftp , string $filename ) : int

ftp_size() 函数返回指定文件的大小（以字节为单位）。

Note:

不是所有服务器都支持该功能。

参数

ftp

FTP 连接的链接标识符。

filename

远程文件。

返回值

成功时返回文件大小，错误返回 -1 。

范例

Example #1 ftp_size() 示例

<?php

$file = 'somefile.txt';

// 简单基本连接
$conn_id = ftp_connect($ftp_server);

// 使用用户名和密码进行登录
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// 获取 $file 文件大小
$res = ftp_size($conn_id, $file);

if ($res != -1) {
    echo "size of $file is $res bytes";
} else {
    echo "couldn't get the size";
}

// 关闭连接
ftp_close($conn_id);

?>

参见

  • ftp_rawlist() - 返回指定目录下文件的详细列表


打开 SSL-FTP 连接

  • ? ftp_size
  • ftp_systype ?
  • PHP Manual
  • FTP 函数
  • 打开 SSL-FTP 连接

ftp_ssl_connect

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

ftp_ssl_connect — 打开 SSL-FTP 连接

说明

ftp_ssl_connect ( string $host , int $port = 21 , int $timeout = 90 ) : resource

ftp_ssl_connect() 显式的打开一个到 host 的安全 FTP 连接（SSL-FTP）。 即使服务器未配置 SSL-FTP，或者服务器的证书无效，ftp_ssl_connect() 函数也会成功的建立到服务器的连接。直到调用 ftp_login() 函数的时候， 客户端才会发送对应的 AUTH FTP 命令，此时，如果服务器未配置 SSL-FTP 或者整数无效， ftp_login() 函数会失败。

Note: 为何本函数有可能不存在？

只有 PHP 构建时同时包含了 ftp 模块 和 OpenSSL 模块时， ftp_ssl_connect() 函数才可用。 也就是说，在 Windows 平台上，官方发布的 PHP 构建中本函数不可用。 如果需要在 Windows 平台使用本函数，需要自行编译 PHP。

Note:

ftp_ssl_connect() 不是用来连接 sFTP 服务的。 要在 PHP 中使用 sFTP，请参见 ssh2_sftp()。

参数

host

FTP 服务器地址。 此参数末尾不可以有斜线，开头也不可以有 ftp://。

port

要连接的端口。如果省略此参数或设置为 0，将使用 FTP 默认端口 21。

timeout

此参数设置所有后续网络操作的超时时长。 如果省略，默认值为 90 秒。 可以使用 ftp_set_option() 和 ftp_get_option() 函数随时读取或设置超时时长。

返回值

操作成功返回 SSL-FTP 流，操作失败返回 false 。

更新日志

版本 | 说明
5.2.2 | 以前版本中，如果无法使用 SSL 连接，将会返回一个非 SSL 的连接， 在 5.2.2 版本中修改为返回 false

范例

Example #1 ftp_ssl_connect() 函数例程

<?php

// 建立基础 SSL 连接
$conn_id = ftp_ssl_connect($ftp_server);

// 使用用户名和密码登录
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

if (!$login_result) {
    // 在这种情况下，PHP 会发生 E_WARNING 级别的告警消息
    die("can't login");
}

echo ftp_pwd($conn_id); // /

// 关闭 ssl 连接
ftp_close($conn_id);
?>

参见

  • ftp_connect() - 建立一个新的 FTP 连接


返回远程 FTP 服务器的操作系统类型

  • ? ftp_ssl_connect
  • Gearman ?
  • PHP Manual
  • FTP 函数
  • 返回远程 FTP 服务器的操作系统类型

ftp_systype

(PHP 4, PHP 5, PHP 7, PHP 8)

ftp_systype — 返回远程 FTP 服务器的操作系统类型

说明

ftp_systype ( resource $ftp_stream ) : string

返回远程 FTP 服务器的操作系统类型。

参数

ftp_stream

FTP 连接资源。

返回值

返回远程服务器类型，发生错误则返回 false。

范例

Example #1 ftp_systype() 示例

<?php
// 建立 ftp 连接
$ftp = ftp_connect('ftp.example.com');
ftp_login($ftp, 'user', 'password');

// 获取操作系统类型
if ($type = ftp_systype($ftp)) {
    echo "Example.com 的操作系统为 $type\n";
} else {
    echo "无法获取操作系统类型";
}
?>

以上例程的输出类似于：

Example.com 的操作系统为 UNIX


Gearman

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic usage
    • Basic Gearman client and worker, background
    • Basic Gearman client and worker, submitting tasks
  • GearmanClient — The GearmanClient class
    • GearmanClient::addOptions — Add client options
    • GearmanClient::addServer — Add a job server to the client
    • GearmanClient::addServers — Add a list of job servers to the client
    • GearmanClient::addTask — Add a task to be run in parallel
    • GearmanClient::addTaskBackground — Add a background task to be run in parallel
    • GearmanClient::addTaskHigh — Add a high priority task to run in parallel
    • GearmanClient::addTaskHighBackground — Add a high priority background task to be run in parallel
    • GearmanClient::addTaskLow — Add a low priority task to run in parallel
    • GearmanClient::addTaskLowBackground — Add a low priority background task to be run in parallel
    • GearmanClient::addTaskStatus — Add a task to get status
    • GearmanClient::clearCallbacks — Clear all task callback functions
    • GearmanClient::clone — Create a copy of a GearmanClient object
    • GearmanClient::__construct — Create a GearmanClient instance
    • GearmanClient::context — Get the application context
    • GearmanClient::data — Get the application data (deprecated)
    • GearmanClient::do — Run a single task and return a result [deprecated]
    • GearmanClient::doBackground — Run a task in the background
    • GearmanClient::doHigh — Run a single high priority task
    • GearmanClient::doHighBackground — Run a high priority task in the background
    • GearmanClient::doJobHandle — Get the job handle for the running task
    • GearmanClient::doLow — Run a single low priority task
    • GearmanClient::doLowBackground — Run a low priority task in the background
    • GearmanClient::doNormal — Run a single task and return a result
    • GearmanClient::doStatus — Get the status for the running task
    • GearmanClient::echo — Send data to all job servers to see if they echo it back [deprecated]
    • GearmanClient::error — Returns an error string for the last error encountered
    • GearmanClient::getErrno — Get an errno value
    • GearmanClient::jobStatus — Get the status of a background job
    • GearmanClient::ping — Send data to all job servers to see if they echo it back
    • GearmanClient::removeOptions — Remove client options
    • GearmanClient::returnCode — Get the last Gearman return code
    • GearmanClient::runTasks — Run a list of tasks in parallel
    • GearmanClient::setClientCallback — Callback function when there is a data packet for a task (deprecated)
    • GearmanClient::setCompleteCallback — Set a function to be called on task completion
    • GearmanClient::setContext — Set application context
    • GearmanClient::setCreatedCallback — Set a callback for when a task is queued
    • GearmanClient::setData — Set application data (deprecated)
    • GearmanClient::setDataCallback — Callback function when there is a data packet for a task
    • GearmanClient::setExceptionCallback — Set a callback for worker exceptions
    • GearmanClient::setFailCallback — Set callback for job failure
    • GearmanClient::setOptions — Set client options
    • GearmanClient::setStatusCallback — Set a callback for collecting task status
    • GearmanClient::setTimeout — Set socket I/O activity timeout
    • GearmanClient::setWarningCallback — Set a callback for worker warnings
    • GearmanClient::setWorkloadCallback — Set a callback for accepting incremental data updates
    • GearmanClient::timeout — Get current socket I/O activity timeout value
    • GearmanClient::wait — Wait for I/O activity on all connections in a client
  • GearmanJob — The GearmanJob class
    • GearmanJob::complete — Send the result and complete status (deprecated)
    • GearmanJob::__construct — Create a GearmanJob instance
    • GearmanJob::data — Send data for a running job (deprecated)
    • GearmanJob::exception — Send exception for running job (deprecated)
    • GearmanJob::fail — Send fail status (deprecated)
    • GearmanJob::functionName — Get function name
    • GearmanJob::handle — Get the job handle
    • GearmanJob::returnCode — Get last return code
    • GearmanJob::sendComplete — Send the result and complete status
    • GearmanJob::sendData — Send data for a running job
    • GearmanJob::sendException — Send exception for running job (exception)
    • GearmanJob::sendFail — Send fail status
    • GearmanJob::sendStatus — Send status
    • GearmanJob::sendWarning — Send a warning
    • GearmanJob::setReturn — Set a return value
    • GearmanJob::status — Send status (deprecated)
    • GearmanJob::unique — Get the unique identifier
    • GearmanJob::warning — Send a warning (deprecated)
    • GearmanJob::workload — Get workload
    • GearmanJob::workloadSize — Get size of work load
  • GearmanTask — The GearmanTask class
    • GearmanTask::__construct — Create a GearmanTask instance
    • GearmanTask::create — Create a task (deprecated)
    • GearmanTask::data — Get data returned for a task
    • GearmanTask::dataSize — Get the size of returned data
    • GearmanTask::function — Get associated function name (deprecated)
    • GearmanTask::functionName — Get associated function name
    • GearmanTask::isKnown — Determine if task is known
    • GearmanTask::isRunning — Test whether the task is currently running
    • GearmanTask::jobHandle — Get the job handle
    • GearmanTask::recvData — Read work or result data into a buffer for a task
    • GearmanTask::returnCode — Get the last return code
    • GearmanTask::sendData — Send data for a task (deprecated)
    • GearmanTask::sendWorkload — Send data for a task
    • GearmanTask::taskDenominator — Get completion percentage denominator
    • GearmanTask::taskNumerator — Get completion percentage numerator
    • GearmanTask::unique — Get the unique identifier for a task
    • GearmanTask::uuid — Get the unique identifier for a task (deprecated)
  • GearmanWorker — The GearmanWorker class
    • GearmanWorker::addFunction — Register and add callback function
    • GearmanWorker::addOptions — Add worker options
    • GearmanWorker::addServer — Add a job server
    • GearmanWorker::addServers — Add job servers
    • GearmanWorker::clone — Create a copy of the worker
    • GearmanWorker::__construct — Create a GearmanWorker instance
    • GearmanWorker::echo — Test job server response
    • GearmanWorker::error — Get the last error encountered
    • GearmanWorker::getErrno — Get errno
    • GearmanWorker::options — Get worker options
    • GearmanWorker::register — Register a function with the job server
    • GearmanWorker::removeOptions — Remove worker options
    • GearmanWorker::returnCode — Get last Gearman return code
    • GearmanWorker::setId — Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers
    • GearmanWorker::setOptions — Set worker options
    • GearmanWorker::setTimeout — Set socket I/O activity timeout
    • GearmanWorker::timeout — Get socket I/O activity timeout
    • GearmanWorker::unregister — Unregister a function name with the job servers
    • GearmanWorker::unregisterAll — Unregister all function names with the job servers
    • GearmanWorker::wait — Wait for activity from one of the job servers
    • GearmanWorker::work — Wait for and perform jobs
  • GearmanException — The GearmanException class


简介

» Gearman is a generic application framework for farming out work to multiple machines or processes. It allows applications to complete tasks in parallel, to load balance processing, and to call functions between languages. The framework can be used in a variety of applications, from high-availability web sites to the transport of database replication events.

This extension provides classes for writing Gearman clients and workers.


需求

This extension requires the » libgearman, » libevent and » uuid libraries, and a running Gearman server.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/gearman


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Return values. Always check GearmanClient::error() or GearmanWorker() for a string error, as it may contain more details:

GEARMAN_SUCCESS (int)
Whatever action was taken was successful.
GEARMAN_IO_WAIT (int)
When in non-blocking mode, an event is hit that would have blocked.
GEARMAN_ERRNO (int)
A system error. Check GearmanClient::errno() or GearmanWorker::errno() for the system error code that was returned.
GEARMAN_NO_ACTIVE_FDS (int)
GearmanClient::wait() or GearmanWorker() was called with no connections.
GEARMAN_UNEXPECTED_PACKET (int)
Indicates something going very wrong in gearmand. Applies only to GearmanWorker.
GEARMAN_GETADDRINFO (int)
DNS resolution failed (invalid host, port, etc).
GEARMAN_NO_SERVERS (int)
Did not call GearmanClient::addServer() before submitting jobs or tasks.
GEARMAN_LOST_CONNECTION (int)
Lost a connection during a request.
GEARMAN_MEMORY_ALLOCATION_FAILURE (int)
Memory allocation failed (ran out of memory).
GEARMAN_SERVER_ERROR (int)
Something went wrong in the Gearman server and it could not handle the request gracefully.
GEARMAN_WORK_DATA (int)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Sent to update the client with data from a running job. A worker uses this when it needs to send updates, send partial results, or flush data during long running jobs.
GEARMAN_WORK_WARNING (int)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Updates the client with a warning. The behavior is just like GEARMAN_WORK_DATA, but should be treated as a warning instead of normal response data.
GEARMAN_WORK_STATUS (int)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Sent to update the status of a long running job. Use GearmanClient::doStatus() to obtain the percentage complete of the task.
GEARMAN_WORK_EXCEPTION (int)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Indicates that a job failed with a given exception.
GEARMAN_WORK_FAIL (int)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Indicates that the job failed.
GEARMAN_COULD_NOT_CONNECT (int)
Failed to connect to servers.
GEARMAN_INVALID_FUNCTION_NAME (int)
Trying to register a function name of NULL or using the callback interface without specifying callbacks.
GEARMAN_INVALID_WORKER_FUNCTION (int)
Trying to register a function with a NULL callback function.
GEARMAN_NO_REGISTERED_FUNCTIONS (int)
When a worker gets a job for a function it did not register.
GEARMAN_NO_JOBS (int)
For a non-blocking worker, when GearmanWorker::work() does not have any active jobs.
GEARMAN_ECHO_DATA_CORRUPTION (int)
After GearmanClient::echo() or GearmanWorker::echo() the data returned doesn't match the data sent.
GEARMAN_NEED_WORKLOAD_FN (int)
When the client opted to stream the workload of a task, but did not specify a workload callback function.
GEARMAN_PAUSE (int)
For the non-blocking client task interface, can be returned from the task callback to "pause" the call and return from GearmanClient::runTasks(). Call GearmanClient::runTasks() again to continue.
GEARMAN_UNKNOWN_STATE (int)
Internal client/worker state error.
GEARMAN_SEND_BUFFER_TOO_SMALL (int)
Internal error: trying to flush more data in one atomic chunk than is possible due to hard-coded buffer sizes.
GEARMAN_TIMEOUT (int)
Hit the timeout limit set by the client/worker.

GearmanClient options:

GEARMAN_CLIENT_GENERATE_UNIQUE (int)
Generate a unique id (UUID) for each task.
GEARMAN_CLIENT_NON_BLOCKING (int)
Run the cient in a non-blocking mode.
GEARMAN_CLIENT_UNBUFFERED_RESULT (int)
Allow the client to read data in chunks rather than have the library buffer the entire data result and pass that back.
GEARMAN_CLIENT_FREE_TASKS (int)
Automatically free task objects once they are complete. This is the default setting in this extension to prevent memory leaks.

GearmanWorker options:

GEARMAN_WORKER_NON_BLOCKING (int)
Run the worker in non-blocking mode.
GEARMAN_WORKER_GRAB_UNIQ (int)
Return the client assigned unique ID in addition to the job handle.

Base Gearman configuration:

GEARMAN_DEFAULT_TCP_HOST (string)
GEARMAN_DEFAULT_TCP_PORT (int)
GEARMAN_DEFAULT_SOCKET_TIMEOUT (int)
GEARMAN_DEFAULT_SOCKET_SEND_SIZE (int)
GEARMAN_DEFAULT_SOCKET_RECV_SIZE (int)
GEARMAN_MAX_ERROR_SIZE (int)
GEARMAN_PACKET_HEADER_SIZE (int)
GEARMAN_JOB_HANDLE_SIZE (int)
GEARMAN_OPTION_SIZE (int)
GEARMAN_UNIQUE_SIZE (int)
GEARMAN_MAX_COMMAND_ARGS (int)
GEARMAN_ARGS_BUFFER_SIZE (int)
GEARMAN_SEND_BUFFER_SIZE (int)
GEARMAN_RECV_BUFFER_SIZE (int)
GEARMAN_WORKER_WAIT_TIMEOUT (int)


范例

Table of Contents

  • Basic usage
  • Basic Gearman client and worker, background
  • Basic Gearman client and worker, submitting tasks


Basic usage

Example #1 Basic Gearman client and worker

This example shows a very simple client and worker. The client sends a string to the job server, and the worker reverses the string and sends it back. The job is performed synchronously.

<?php

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Send reverse job
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");

  # Check for various return packets and errors.
  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Data: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      echo "Success: $result\n";
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x, $workload_size);
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

# A much simpler and less verbose version of the above function would be:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

以上例程的输出类似于：

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:36
Workload: Hello! (6)
Sending status: 1/6 complete
Sending status: 2/6 complete
Sending status: 3/6 complete
Sending status: 4/6 complete
Sending status: 5/6 complete
Sending status: 6/6 complete
Result: !olleH

% php reverse_client.php
Starting
Sending job
Status: 1/6 complete
Status: 2/6 complete
Status: 3/6 complete
Status: 4/6 complete
Status: 5/6 complete
Status: 6/6 complete
Success: !olleH


Basic Gearman client and worker, background

Example #1 Basic Gearman client and worker, background

This example shows a very simple client and worker. The client sends a string to the job server as a background job, and the worker reverses the string. Note that since the work is performed asynchronously, the client does not wait for the job to complete and exits (and hence the client never receives the results).

<?php

# create our client object
$gmclient= new GearmanClient();

# add the default server (localhost)
$gmclient->addServer();

# run reverse client in the background
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

echo "done!\n";

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x, $workload_size);
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

# A much simpler and less verbose version of the above function would be:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

以上例程的输出类似于：

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:41
Workload: this is a test (14)
1/14 complete
2/14 complete
3/14 complete
4/14 complete
5/14 complete
6/14 complete
7/14 complete
8/14 complete
9/14 complete
10/14 complete
11/14 complete
12/14 complete
13/14 complete
14/14 complete
Result: tset a si siht

% php reverse_client_bg.php
done!


Basic Gearman client and worker, submitting tasks

Example #1 Basic Gearman client and worker, submitting tasks

In this example, the basic reverse client extended to run two tasks in parallel. The reverse worker is unchanged except to add sending of data back during processing.

<?php

# create the gearman client
$gmc= new GearmanClient();

# add the default server (localhost)
$gmc->addServer();

# register some callbacks
$gmc->setCreatedCallback("reverse_created");
$gmc->setDataCallback("reverse_data");
$gmc->setStatusCallback("reverse_status");
$gmc->setCompleteCallback("reverse_complete");
$gmc->setFailCallback("reverse_fail");

# set some arbitrary application data
$data['foo'] = 'bar';

# add two tasks
$task= $gmc->addTask("reverse", "foo", $data);
$task2= $gmc->addTaskLow("reverse", "bar", NULL);

# run the tasks in parallel (assuming multiple workers)
if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}

echo "DONE\n";

function reverse_created($task)
{
    echo "CREATED: " . $task->jobHandle() . "\n";
}

function reverse_status($task)
{
    echo "STATUS: " . $task->jobHandle() . " - " . $task->taskNumerator() .
         "/" . $task->taskDenominator() . "\n";
}

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->jobHandle() . ", " . $task->data() . "\n";
}

function reverse_fail($task)
{
    echo "FAILED: " . $task->jobHandle() . "\n";
}

function reverse_data($task)
{
    echo "DATA: " . $task->data() . "\n";
}

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

# A much simpler and less verbose version of the above function would be:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

以上例程的输出类似于：

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:45
Workload: foo (3)
1/3 complete
2/3 complete
3/3 complete
Result: oof
Received job: H:foo.local:44
Workload: bar (3)
1/3 complete
2/3 complete
3/3 complete
Result: rab

% php reverse_client_task.php
CREATED: H:foo.local:44
CREATED: H:foo.local:45
STATUS: H:foo.local:45 - 1/3
DATA: f
STATUS: H:foo.local:45 - 2/3
DATA: o
STATUS: H:foo.local:45 - 3/3
DATA: o
COMPLETE: H:foo.local:45, oof
STATUS: H:foo.local:44 - 1/3
DATA: b
STATUS: H:foo.local:44 - 2/3
DATA: a
STATUS: H:foo.local:44 - 3/3
DATA: r
COMPLETE: H:foo.local:44, rab
DONE


The GearmanClient class

(PECL gearman >= 0.5.0)

简介

Represents a class for connecting to a Gearman job server and making requests to perform some function on provided data. The function performed must be one registered by a Gearman worker and the data passed is opaque to the job server.

类摘要

GearmanClient {
/* 方法 */
public addOptions ( int $options ) : bool
public addServer ( string $host = 127.0.0.1 , int $port = 4730 ) : bool
public addServers ( string $servers = 127.0.0.1:4730 ) : bool
public addTask ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskHigh ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskHighBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskLow ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskLowBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask
public addTaskStatus ( string $job_handle , string &$context = ? ) : GearmanTask
public clearCallbacks ( ) : bool
public clone ( ) : GearmanClient
public __construct ( )
public context ( ) : string
public data ( ) : string
public do ( string $function_name , string $workload , string $unique = ? ) : string
public doBackground ( string $function_name , string $workload , string $unique = ? ) : string
public doHigh ( string $function_name , string $workload , string $unique = ? ) : string
public doHighBackground ( string $function_name , string $workload , string $unique = ? ) : string
public doJobHandle ( ) : string
public doLow ( string $function_name , string $workload , string $unique = ? ) : string
public doLowBackground ( string $function_name , string $workload , string $unique = ? ) : string
public doNormal ( string $function_name , string $workload , string $unique = ? ) : string
public doStatus ( ) : array
public echo ( string $workload ) : bool
public error ( ) : string
public getErrno ( ) : int
public jobStatus ( string $job_handle ) : array
public ping ( string $workload ) : bool
public removeOptions ( int $options ) : bool
public returnCode ( ) : int
public runTasks ( ) : bool
public setClientCallback ( callable $callback ) : void
public setCompleteCallback ( callable $callback ) : bool
public setContext ( string $context ) : bool
public setCreatedCallback ( string $callback ) : bool
public setData ( string $data ) : bool
public setDataCallback ( callable $callback ) : bool
public setExceptionCallback ( callable $callback ) : bool
public setFailCallback ( callable $callback ) : bool
public setOptions ( int $options ) : bool
public setStatusCallback ( callable $callback ) : bool
public setTimeout ( int $timeout ) : bool
public setWarningCallback ( callable $callback ) : bool
public setWorkloadCallback ( callable $callback ) : bool
public timeout ( ) : int
public wait ( ) : bool
}

Table of Contents

  • GearmanClient::addOptions — Add client options
  • GearmanClient::addServer — Add a job server to the client
  • GearmanClient::addServers — Add a list of job servers to the client
  • GearmanClient::addTask — Add a task to be run in parallel
  • GearmanClient::addTaskBackground — Add a background task to be run in parallel
  • GearmanClient::addTaskHigh — Add a high priority task to run in parallel
  • GearmanClient::addTaskHighBackground — Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLow — Add a low priority task to run in parallel
  • GearmanClient::addTaskLowBackground — Add a low priority background task to be run in parallel
  • GearmanClient::addTaskStatus — Add a task to get status
  • GearmanClient::clearCallbacks — Clear all task callback functions
  • GearmanClient::clone — Create a copy of a GearmanClient object
  • GearmanClient::__construct — Create a GearmanClient instance
  • GearmanClient::context — Get the application context
  • GearmanClient::data — Get the application data (deprecated)
  • GearmanClient::do — Run a single task and return a result [deprecated]
  • GearmanClient::doBackground — Run a task in the background
  • GearmanClient::doHigh — Run a single high priority task
  • GearmanClient::doHighBackground — Run a high priority task in the background
  • GearmanClient::doJobHandle — Get the job handle for the running task
  • GearmanClient::doLow — Run a single low priority task
  • GearmanClient::doLowBackground — Run a low priority task in the background
  • GearmanClient::doNormal — Run a single task and return a result
  • GearmanClient::doStatus — Get the status for the running task
  • GearmanClient::echo — Send data to all job servers to see if they echo it back [deprecated]
  • GearmanClient::error — Returns an error string for the last error encountered
  • GearmanClient::getErrno — Get an errno value
  • GearmanClient::jobStatus — Get the status of a background job
  • GearmanClient::ping — Send data to all job servers to see if they echo it back
  • GearmanClient::removeOptions — Remove client options
  • GearmanClient::returnCode — Get the last Gearman return code
  • GearmanClient::runTasks — Run a list of tasks in parallel
  • GearmanClient::setClientCallback — Callback function when there is a data packet for a task (deprecated)
  • GearmanClient::setCompleteCallback — Set a function to be called on task completion
  • GearmanClient::setContext — Set application context
  • GearmanClient::setCreatedCallback — Set a callback for when a task is queued
  • GearmanClient::setData — Set application data (deprecated)
  • GearmanClient::setDataCallback — Callback function when there is a data packet for a task
  • GearmanClient::setExceptionCallback — Set a callback for worker exceptions
  • GearmanClient::setFailCallback — Set callback for job failure
  • GearmanClient::setOptions — Set client options
  • GearmanClient::setStatusCallback — Set a callback for collecting task status
  • GearmanClient::setTimeout — Set socket I/O activity timeout
  • GearmanClient::setWarningCallback — Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback — Set a callback for accepting incremental data updates
  • GearmanClient::timeout — Get current socket I/O activity timeout value
  • GearmanClient::wait — Wait for I/O activity on all connections in a client


Add client options

  • ? GearmanClient
  • GearmanClient::addServer ?
  • PHP Manual
  • GearmanClient
  • Add client options

GearmanClient::addOptions

(PECL gearman >= 0.6.0)

GearmanClient::addOptions — Add client options

说明

public GearmanClient::addOptions ( int $options ) : bool

Adds one or more options to those already set.

参数

options

The options to add. One of the following constants, or a combination of them using the bitwise OR operator (|): GEARMAN_CLIENT_GENERATE_UNIQUE, GEARMAN_CLIENT_NON_BLOCKING, GEARMAN_CLIENT_UNBUFFERED_RESULT or GEARMAN_CLIENT_FREE_TASKS.

返回值

Always returns true.


Add a job server to the client

  • ? GearmanClient::addOptions
  • GearmanClient::addServers ?
  • PHP Manual
  • GearmanClient
  • Add a job server to the client

GearmanClient::addServer

(PECL gearman >= 0.5.0)

GearmanClient::addServer — Add a job server to the client

说明

public GearmanClient::addServer ( string $host = 127.0.0.1 , int $port = 4730 ) : bool

Adds a job server to a list of servers that can be used to run a task. No socket I/O happens here; the server is simply added to the list.

参数

host

任务服务器主机名。

port

任务服务器端口号。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Adding two job servers

<?php

# Create our client object.
$gmclient= new GearmanClient();

# Add two job servers, the first on the default 4730 port
$gmclient->addServer("10.0.0.1");
$gmclient->addServer("10.0.0.2", 7003);

?>

参见

  • GearmanClient::addServers() - Add a list of job servers to the client


Add a list of job servers to the client

  • ? GearmanClient::addServer
  • GearmanClient::addTask ?
  • PHP Manual
  • GearmanClient
  • Add a list of job servers to the client

GearmanClient::addServers

(PECL gearman >= 0.5.0)

GearmanClient::addServers — Add a list of job servers to the client

说明

public GearmanClient::addServers ( string $servers = 127.0.0.1:4730 ) : bool

Adds a list of job servers that can be used to run a task. No socket I/O happens here; the servers are simply added to the full list of servers.

参数

servers

A comma-separated list of servers, each server specified in the format 'host:port'.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Add two job servers

<?php

# Create our client object.
$gmclient= new GearmanClient();

# Add multiple job servers, the first on the default 4730 port
$gmclient->addServers("10.0.0.1,10.0.0.2:7003");

?>

参见

  • GearmanClient::addServer() - Add a job server to the client


Add a task to be run in parallel

  • ? GearmanClient::addServers
  • GearmanClient::addTaskBackground ?
  • PHP Manual
  • GearmanClient
  • Add a task to be run in parallel

GearmanClient::addTask

(PECL gearman >= 0.5.0)

GearmanClient::addTask — Add a task to be run in parallel

说明

public GearmanClient::addTask ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Adds a task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Note that enough workers need to be available for the tasks to all run in parallel.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

context

与任务关联的应用程序上下文。

unique

用于标识特定任务的唯一性 ID。

返回值

A GearmanTask object or false if the task could not be added.

范例

Example #1 Basic submission of two tasks

<?php

# Create our gearman client
$gmclient= new GearmanClient();

# add the default job server
$gmclient->addServer();

# set a function to be called when the work is complete
$gmclient->setCompleteCallback("complete");

# add a task to perform the "reverse" function on the string "Hello World!"
$gmclient->addTask("reverse", "Hello World!", null, "1");

# add another task to perform the "reverse" function on the string "!dlroW olleH"
$gmclient->addTask("reverse", "!dlroW olleH", null, "2");

# run the tasks
$gmclient->runTasks();

function complete($task)
{
  print "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

以上例程的输出类似于：

COMPLETE: 2, Hello World!
COMPLETE: 1, !dlroW olleH

Example #2 Basic submission of two tasks with passing application context

<?php

$client = new GearmanClient();
$client->addServer();

# set a function to be called when the work is complete
$client->setCompleteCallback("reverse_complete");

# Add some tasks for a placeholder of where to put the results
$results = array();
$client->addTask("reverse", "Hello World!", &$results, "t1");
$client->addTask("reverse", "!dlroW olleH", &$results, "t2");

$client->runTasks();

# The results should now be filled in from the callbacks
foreach ($results as $id => $result)
   echo $id . ": " . $result['handle'] . ", " . $result['data'] . "\n";

function reverse_complete($task, $results)
{
   $results[$task->unique()] = array("handle"=>$task->jobHandle(), "data"=>$task->data());
}

?>

以上例程的输出类似于：

t2: H.foo:21, Hello World!
t1: H:foo:22, !dlroW olleH

参见

  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel


Add a background task to be run in parallel

  • ? GearmanClient::addTask
  • GearmanClient::addTaskHigh ?
  • PHP Manual
  • GearmanClient
  • Add a background task to be run in parallel

GearmanClient::addTaskBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskBackground — Add a background task to be run in parallel

说明

public GearmanClient::addTaskBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Adds a background task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

context

与任务关联的应用程序上下文。

unique

用于标识特定任务的唯一性 ID。

返回值

A GearmanTask object or false if the task could not be added.

范例

Example #1 Two tasks, one background and one not

This example illustrates the difference between running a background task and a normal task. The client adds two tasks to execute the same function, but one is added with addTaskBackground(). A callback is set so that progress of the job can be tracked. A simple worker with an artificial delay reports on the job progress and the client picks this up through the callback. Two workers are run for this example. Note that the background task does not show in the client output.

<?php

# The client script

# create our gearman client
$gmc= new GearmanClient();

# add the default job server
$gmc->addServer();

# set a couple of callbacks so we can track progress
$gmc->setCompleteCallback("reverse_complete");
$gmc->setStatusCallback("reverse_status");

# add a task for the "reverse" function
$task= $gmc->addTask("reverse", "Hello World!", null, "1");

# add another task, but this one to run in the background
$task= $gmc->addTaskBackground("reverse", "!dlroW olleH", null, "2");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}

echo "DONE\n";

function reverse_status($task)
{
    echo "STATUS: " . $task->unique() . ", " . $task->jobHandle() . " - " . $task->taskNumerator() .
         "/" . $task->taskDenominator() . "\n";
}

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>
<?php

# The worker script

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

?>

Worker output for two workers running:

Received job: H:foo.local:65
Workload: !dlroW olleH (12)
1/12 complete
Received job: H:foo.local:66
Workload: Hello World! (12)
Sending status: 1/12 complete
Sending status: 2/12 complete
Sending status: 2/12 complete
Sending status: 3/12 complete
Sending status: 3/12 complete
Sending status: 4/12 complete
Sending status: 4/12 complete
Sending status: 5/12 complete
Sending status: 5/12 complete
Sending status: 6/12 complete
Sending status: 6/12 complete
Sending status: 7/12 complete
Sending status: 7/12 complete
Sending status: 8/12 complete
Sending status: 8/12 complete
Sending status: 9/12 complete
Sending status: 9/12 complete
Sending status: 10/12 complete
Sending status: 10/12 complete
Sending status: 11/12 complete
Sending status: 11/12 complete
Sending status: 12/12 complete
Sending status: 12/12 complete
Result: !dlroW olleH
Result: Hello World!

Client output:

STATUS: 1, H:foo.local:66 - 1/12
STATUS: 1, H:foo.local:66 - 2/12
STATUS: 1, H:foo.local:66 - 3/12
STATUS: 1, H:foo.local:66 - 4/12
STATUS: 1, H:foo.local:66 - 5/12
STATUS: 1, H:foo.local:66 - 6/12
STATUS: 1, H:foo.local:66 - 7/12
STATUS: 1, H:foo.local:66 - 8/12
STATUS: 1, H:foo.local:66 - 9/12
STATUS: 1, H:foo.local:66 - 10/12
STATUS: 1, H:foo.local:66 - 11/12
STATUS: 1, H:foo.local:66 - 12/12
COMPLETE: 1, !dlroW olleH
DONE

参见

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel


Add a high priority task to run in parallel

  • ? GearmanClient::addTaskBackground
  • GearmanClient::addTaskHighBackground ?
  • PHP Manual
  • GearmanClient
  • Add a high priority task to run in parallel

GearmanClient::addTaskHigh

(PECL gearman >= 0.5.0)

GearmanClient::addTaskHigh — Add a high priority task to run in parallel

说明

public GearmanClient::addTaskHigh ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Adds a high priority task to be run in parallel with other tasks. Call this method for all the high priority tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Tasks with a high priority will be selected from the queue before those of normal or low priority.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

context

与任务关联的应用程序上下文。

unique

用于标识特定任务的唯一性 ID。

返回值

A GearmanTask object or false if the task could not be added.

范例

Example #1 A high priority task along with two normal tasks

A high priority task is included among two other tasks. A single worker is available, so that tasks are run one at a time, with the high priority task run first.

<?php

# create the gearman client
$gmc= new GearmanClient();

# add the default job server
$gmc->addServer();

# set the callback for when the job is complete
$gmc->setCompleteCallback("reverse_complete");

# add tasks, one of which is high priority
$task= $gmc->addTask("reverse", "Hello World!", null, "1");
$task= $gmc->addTaskHigh("reverse", "!dlroW olleH", null, "2");
$task= $gmc->addTask("reverse", "Hello World!", null, "3");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}
echo "DONE\n";

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

以上例程的输出类似于：

COMPLETE: 2, Hello World!
COMPLETE: 3, !dlroW olleH
COMPLETE: 1, !dlroW olleH
DONE

参见

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel


Add a high priority background task to be run in parallel

  • ? GearmanClient::addTaskHigh
  • GearmanClient::addTaskLow ?
  • PHP Manual
  • GearmanClient
  • Add a high priority background task to be run in parallel

GearmanClient::addTaskHighBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskHighBackground — Add a high priority background task to be run in parallel

说明

public GearmanClient::addTaskHighBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Adds a high priority background task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Tasks with a high priority will be selected from the queue before those of normal or low priority.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

context

与任务关联的应用程序上下文。

unique

用于标识特定任务的唯一性 ID。

返回值

A GearmanTask object or false if the task could not be added.

参见

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel


Add a low priority task to run in parallel

  • ? GearmanClient::addTaskHighBackground
  • GearmanClient::addTaskLowBackground ?
  • PHP Manual
  • GearmanClient
  • Add a low priority task to run in parallel

GearmanClient::addTaskLow

(PECL gearman >= 0.5.0)

GearmanClient::addTaskLow — Add a low priority task to run in parallel

说明

public GearmanClient::addTaskLow ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Adds a low priority background task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Tasks with a low priority will be selected from the queue after those of normal or low priority.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

context

与任务关联的应用程序上下文。

unique

用于标识特定任务的唯一性 ID。

返回值

A GearmanTask object or false if the task could not be added.

范例

Example #1 A low priority task along with two normal tasks

A low priority task is included among two other tasks. A single worker is available, so that tasks are run one at a time, with the low priority task run last.

<?php

# create the gearman client
$gmc= new GearmanClient();

# add the default job server
$gmc->addServer();

# set the callback for when the job is complete
$gmc->setCompleteCallback("reverse_complete");

# add tasks, one of which is low priority
$task= $gmc->addTask("reverse", "Hello World!", null, "1");
$task= $gmc->addTaskLow("reverse", "!dlroW olleH", null, "2");
$task= $gmc->addTask("reverse", "Hello World!", null, "3");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}
echo "DONE\n";

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

以上例程的输出类似于：

COMPLETE: 3, !dlroW olleH
COMPLETE: 1, !dlroW olleH
COMPLETE: 2, Hello World!
DONE

参见

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel


Add a low priority background task to be run in parallel

  • ? GearmanClient::addTaskLow
  • GearmanClient::addTaskStatus ?
  • PHP Manual
  • GearmanClient
  • Add a low priority background task to be run in parallel

GearmanClient::addTaskLowBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskLowBackground — Add a low priority background task to be run in parallel

说明

public GearmanClient::addTaskLowBackground ( string $function_name , string $workload , mixed &$context = ? , string $unique = ? ) : GearmanTask

Adds a low priority background task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Tasks with a low priority will be selected from the queue after those of normal or high priority.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

context

与任务关联的应用程序上下文。

unique

用于标识特定任务的唯一性 ID。

返回值

A GearmanTask object or false if the task could not be added.

参见

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel


Add a task to get status

  • ? GearmanClient::addTaskLowBackground
  • GearmanClient::clearCallbacks ?
  • PHP Manual
  • GearmanClient
  • Add a task to get status

GearmanClient::addTaskStatus

(PECL gearman >= 0.5.0)

GearmanClient::addTaskStatus — Add a task to get status

说明

public GearmanClient::addTaskStatus ( string $job_handle , string &$context = ? ) : GearmanTask

Used to request status information from the Gearman server, which will call the specified status callback (set using GearmanClient::setStatusCallback()).

参数

job_handle

The job handle for the task to get status for

context

Data to be passed to the status callback, generally a reference to an array or object

返回值

A GearmanTask object.

范例

Example #1 Monitor completion of multiple background tasks

An artificial delay is introduced in the worker in this example to simulate a long running process. There is only one worker running for this example.

<?php

/* create our object */
$gmclient= new GearmanClient();

/* add the default server */
$gmclient->addServer();

/* start some background jobs and save the handles */
$handles = array();
$handles[0] = $gmclient->doBackground("reverse", "Hello World!");
$handles[1] = $gmclient->doBackground("reverse", "!dlroW olleH");

$gmclient->setStatusCallback("reverse_status");

/* Poll the server to see when those background jobs finish; */
/* a better method would be to use event callbacks */
do
{
   /* Use the context variable to track how many tasks have completed */
   $done = 0;
   $gmclient->addTaskStatus($handles[0], &$done);
   $gmclient->addTaskStatus($handles[1], &$done);
   $gmclient->runTasks();
   echo "Done: $done\n";
   sleep(1);
}
while ($done != 2);

function reverse_status($task, $done)
{
   if (!$task->isKnown())
      $done++;
}

?>

以上例程的输出类似于：

Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 2

参见

  • GearmanClient::setStatusCallback() - Set a callback for collecting task status


Clear all task callback functions

  • ? GearmanClient::addTaskStatus
  • GearmanClient::clone ?
  • PHP Manual
  • GearmanClient
  • Clear all task callback functions

GearmanClient::clearCallbacks

(PECL gearman >= 0.5.0)

GearmanClient::clearCallbacks — Clear all task callback functions

说明

public GearmanClient::clearCallbacks ( ) : bool

Clears all the task callback functions that have previously been set.

参数

此函数没有参数。

返回值

Always returns true.

参见

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Create a copy of a GearmanClient object

  • ? GearmanClient::clearCallbacks
  • GearmanClient::__construct ?
  • PHP Manual
  • GearmanClient
  • Create a copy of a GearmanClient object

GearmanClient::clone

(PECL gearman >= 0.5.0)

GearmanClient::clone — Create a copy of a GearmanClient object

说明

public GearmanClient::clone ( ) : GearmanClient

Creates a copy of a GearmanClient object.

参数

此函数没有参数。

返回值

A GearmanClient on success, false on failure.


Create a GearmanClient instance

  • ? GearmanClient::clone
  • GearmanClient::context ?
  • PHP Manual
  • GearmanClient
  • Create a GearmanClient instance

GearmanClient::__construct

(PECL gearman >= 0.5.0)

GearmanClient::__construct — Create a GearmanClient instance

说明

public GearmanClient::__construct ( )

Creates a GearmanClient instance representing a client that connects to the job server and submits tasks to complete.

参数

此函数没有参数。

返回值

A GearmanClient object.

参见

  • GearmanClient::clone() - Create a copy of a GearmanClient object


Get the application context

  • ? GearmanClient::__construct
  • GearmanClient::data ?
  • PHP Manual
  • GearmanClient
  • Get the application context

GearmanClient::context

(PECL gearman >= 0.6.0)

GearmanClient::context — Get the application context

说明

public GearmanClient::context ( ) : string

Get the application context previously set with GearmanClient::setContext().

参数

此函数没有参数。

返回值

The same context data structure set with GearmanClient::setContext()

参见

  • GearmanClient::setContext() - Set application context


Get the application data (deprecated)

  • ? GearmanClient::context
  • GearmanClient::do ?
  • PHP Manual
  • GearmanClient
  • Get the application data (deprecated)

GearmanClient::data

(PECL gearman <= 0.5.0)

GearmanClient::data — Get the application data (deprecated)

说明

public GearmanClient::data ( ) : string

Get the application data previously set with GearmanClient::setData().

Note:

This method was replaced by GearmanClient::setContext() in the 0.6.0 release of the Gearman extension.

参数

此函数没有参数。

返回值

The same string data set with GearmanClient::setData()

参见

  • GearmanClient::setData() - Set application data (deprecated)


Run a single task and return a result [deprecated]

  • ? GearmanClient::data
  • GearmanClient::doBackground ?
  • PHP Manual
  • GearmanClient
  • Run a single task and return a result [deprecated]

GearmanClient::do

(PECL gearman >= 0.5.0)

GearmanClient::do — Run a single task and return a result [deprecated]

说明

public GearmanClient::do ( string $function_name , string $workload , string $unique = ? ) : string

The GearmanClient::do() method is deprecated as of pecl/gearman 1.0.0. Use GearmanClient::doNormal().

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

unique

用于标识特定任务的唯一性 ID。

返回值

A string representing the results of running a task.

范例

Example #1 Simple job submission with immediate return

<?php

# Client code

echo "Starting\n";

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

$result = $gmclient->doNormal("reverse", "Hello!");

echo "Success: $result\n";

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

以上例程的输出类似于：

Starting
Sending job
Success: !olleH

Example #2 Submitting a job and retrieving incremental status

A job is submitted and the script loops to retrieve status information. The worker has an artificial delay which results in a long running job and sends status and data as processing occurs. Each subsequent call to GearmanClient::do() produces status information on the running job.

<?php

# Client code

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Send reverse job
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");
  # Check for various return packets and errors.

  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Data: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      echo "Error: " . $gmclient->error() . "\n";
      echo "Errno: " . $gmclient->getErrno() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Success: $result\n";

?>
<?php

# Worker code

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " + $x + 1 . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

?>

以上例程的输出类似于：

Worker output:

Starting
Waiting for job...
Received job: H:foo.local:106
Workload: Hello! (6)
1/6 complete
2/6 complete
3/6 complete
4/6 complete
5/6 complete
6/6 complete
Result: !olleH

Client output:

Starting
Sending job
Status: 1/6 complete
Data: H
Status: 2/6 complete
Data: e
Status: 3/6 complete
Data: l
Status: 4/6 complete
Data: l
Status: 5/6 complete
Data: o
Status: 6/6 complete
Data: !
Success: !olleH

参见

  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background


Run a task in the background

  • ? GearmanClient::do
  • GearmanClient::doHigh ?
  • PHP Manual
  • GearmanClient
  • Run a task in the background

GearmanClient::doBackground

(PECL gearman >= 0.5.0)

GearmanClient::doBackground — Run a task in the background

说明

public GearmanClient::doBackground ( string $function_name , string $workload , string $unique = ? ) : string

Runs a task in the background, returning a job handle which can be used to get the status of the running task.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

unique

用于标识特定任务的唯一性 ID。

返回值

The job handle for the submitted task.

范例

Example #1 Submit and monitor a background job

The worker in this example has an artificial delay introduced to mimic a long running job. The client script periodically checks the status of the running job.

<?php

/* create our object */
$gmclient= new GearmanClient();

/* add the default server */
$gmclient->addServer();

/* run reverse client */
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

$done = false;
do
{
   sleep(3);
   $stat = $gmclient->jobStatus($job_handle);
   if (!$stat[0]) // the job is known so it is not done
      $done = true;
   echo "Running: " . ($stat[1] ? "true" : "false") . ", numerator: " . $stat[2] . ", denominator: " . $stat[3] . "\n";
}
while(!$done);

echo "done!\n";

?>

以上例程的输出类似于：

Running: true, numerator: 3, denominator: 14
Running: true, numerator: 6, denominator: 14
Running: true, numerator: 9, denominator: 14
Running: true, numerator: 12, denominator: 14
Running: false, numerator: 0, denominator: 0
done!

参见

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background


Run a single high priority task

  • ? GearmanClient::doBackground
  • GearmanClient::doHighBackground ?
  • PHP Manual
  • GearmanClient
  • Run a single high priority task

GearmanClient::doHigh

(PECL gearman >= 0.5.0)

GearmanClient::doHigh — Run a single high priority task

说明

public GearmanClient::doHigh ( string $function_name , string $workload , string $unique = ? ) : string

Runs a single high priority task and returns a string representation of the result. It is up to the GearmanClient and GearmanWorker to agree on the format of the result. High priority tasks will get precedence over normal and low priority tasks in the job queue.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

unique

用于标识特定任务的唯一性 ID。

返回值

A string representing the results of running a task.

参见

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background


Run a high priority task in the background

  • ? GearmanClient::doHigh
  • GearmanClient::doJobHandle ?
  • PHP Manual
  • GearmanClient
  • Run a high priority task in the background

GearmanClient::doHighBackground

(PECL gearman >= 0.5.0)

GearmanClient::doHighBackground — Run a high priority task in the background

说明

public GearmanClient::doHighBackground ( string $function_name , string $workload , string $unique = ? ) : string

Runs a high priority task in the background, returning a job handle which can be used to get the status of the running task. High priority tasks take precedence over normal and low priority tasks in the job queue.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

unique

用于标识特定任务的唯一性 ID。

返回值

The job handle for the submitted task.

参见

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background


Get the job handle for the running task

  • ? GearmanClient::doHighBackground
  • GearmanClient::doLow ?
  • PHP Manual
  • GearmanClient
  • Get the job handle for the running task

GearmanClient::doJobHandle

(PECL gearman >= 0.5.0)

GearmanClient::doJobHandle — Get the job handle for the running task

说明

public GearmanClient::doJobHandle ( ) : string

Gets that job handle for a running task. This should be used between repeated GearmanClient::doNormal() calls. The job handle can then be used to get information on the task.

参数

此函数没有参数。

返回值

The job handle for the running task.

参见

  • GearmanClient::jobStatus() - Get the status of a background job


Run a single low priority task

  • ? GearmanClient::doJobHandle
  • GearmanClient::doLowBackground ?
  • PHP Manual
  • GearmanClient
  • Run a single low priority task

GearmanClient::doLow

(PECL gearman >= 0.5.0)

GearmanClient::doLow — Run a single low priority task

说明

public GearmanClient::doLow ( string $function_name , string $workload , string $unique = ? ) : string

Runs a single low priority task and returns a string representation of the result. It is up to the GearmanClient and GearmanWorker to agree on the format of the result. Normal and high priority tasks will get precedence over low priority tasks in the job queue.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

unique

用于标识特定任务的唯一性 ID。

返回值

A string representing the results of running a task.

参见

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background


Run a low priority task in the background

  • ? GearmanClient::doLow
  • GearmanClient::doNormal ?
  • PHP Manual
  • GearmanClient
  • Run a low priority task in the background

GearmanClient::doLowBackground

(PECL gearman >= 0.5.0)

GearmanClient::doLowBackground — Run a low priority task in the background

说明

public GearmanClient::doLowBackground ( string $function_name , string $workload , string $unique = ? ) : string

Runs a low priority task in the background, returning a job handle which can be used to get the status of the running task. Normal and high priority tasks take precedence over low priority tasks in the job queue.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

unique

用于标识特定任务的唯一性 ID。

返回值

The job handle for the submitted task.

参见

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background


Run a single task and return a result

  • ? GearmanClient::doLowBackground
  • GearmanClient::doStatus ?
  • PHP Manual
  • GearmanClient
  • Run a single task and return a result

GearmanClient::doNormal

(No version information available, might only be in Git)

GearmanClient::doNormal — Run a single task and return a result

说明

public GearmanClient::doNormal ( string $function_name , string $workload , string $unique = ? ) : string

Runs a single task and returns a string representation of the result. It is up to the GearmanClient and GearmanWorker to agree on the format of the result.

参数

function_name

由程序自动执行的已注册函数。

workload

被处理的序列化数据。

unique

用于标识特定任务的唯一性 ID。

返回值

A string representing the results of running a task.

范例

Example #1 Simple job submission with immediate return

<?php

?>
<?php

# Client code

echo "Starting\n";

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

$result = $gmclient->doNormal("reverse", "Hello!");

echo "Success: $result\n";

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

以上例程的输出类似于：

Starting
Sending job
Success: !olleH

Example #2 Submitting a job and retrieving incremental status

A job is submitted and the script loops to retrieve status information. The worker has an artificial delay which results in a long running job and sends status and data as processing occurs. Each subsequent call to GearmanClient::doNormal() produces status information on the running job.

<?php

# Client code

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Send reverse job
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");
  # Check for various return packets and errors.

  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Data: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      echo "Error: " . $gmclient->error() . "\n";
      echo "Errno: " . $gmclient->getErrno() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Success: $result\n";

?>
<?php

# Worker code

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " + $x + 1 . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

?>

以上例程的输出类似于：

Worker output:

Starting
Waiting for job...
Received job: H:foo.local:106
Workload: Hello! (6)
1/6 complete
2/6 complete
3/6 complete
4/6 complete
5/6 complete
6/6 complete
Result: !olleH

Client output:

Starting
Sending job
Status: 1/6 complete
Data: H
Status: 2/6 complete
Data: e
Status: 3/6 complete
Data: l
Status: 4/6 complete
Data: l
Status: 5/6 complete
Data: o
Status: 6/6 complete
Data: !
Success: !olleH

参见

  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background


Get the status for the running task

  • ? GearmanClient::doNormal
  • GearmanClient::echo ?
  • PHP Manual
  • GearmanClient
  • Get the status for the running task

GearmanClient::doStatus

(PECL gearman >= 0.5.0)

GearmanClient::doStatus — Get the status for the running task

说明

public GearmanClient::doStatus ( ) : array

Returns the status for the running task. This should be used between repeated GearmanClient::doNormal() calls.

参数

此函数没有参数。

返回值

An array representing the percentage completion given as a fraction, with the first element the numerator and the second element the denomintor.

范例

Example #1 Get the status of a long running job

The worker in this example has an artificial delay added during processing of the string to be reversed. After each delay it calls GearmanJob::status() which the client then picks up.

<?php

echo "Starting\n";

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Send reverse job
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");

  # Check for various return packets and errors.
  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      break;
    case GEARMAN_WORK_STATUS:
      # get the current job status
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Success: $result\n";

?>

以上例程的输出类似于：

Starting
Sending job
Status: 1/6 complete
Status: 2/6 complete
Status: 3/6 complete
Status: 4/6 complete
Status: 5/6 complete
Status: 6/6 complete
Success: !olleH

参见

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanJob::status() - Send status (deprecated)


Send data to all job servers to see if they echo it back [deprecated]

  • ? GearmanClient::doStatus
  • GearmanClient::error ?
  • PHP Manual
  • GearmanClient
  • Send data to all job servers to see if they echo it back [deprecated]

GearmanClient::echo

(PECL gearman >= 0.5.0)

GearmanClient::echo — Send data to all job servers to see if they echo it back [deprecated]

说明

public GearmanClient::echo ( string $workload ) : bool

The GearmanClient::echo() method is deprecated as of pecl/gearman 1.0.0. Use GearmanClient::ping().

参数

workload

Some arbitrary serialized data to be echo back

返回值

成功时返回 true， 或者在失败时返回 false。


Returns an error string for the last error encountered

  • ? GearmanClient::echo
  • GearmanClient::getErrno ?
  • PHP Manual
  • GearmanClient
  • Returns an error string for the last error encountered

GearmanClient::error

(PECL gearman >= 0.5.0)

GearmanClient::error — Returns an error string for the last error encountered

说明

public GearmanClient::error ( ) : string

Returns an error string for the last error encountered.

参数

此函数没有参数。

返回值

A human readable error string.

参见

  • GearmanClient::getErrno() - Get an errno value


Get an errno value

  • ? GearmanClient::error
  • GearmanClient::jobStatus ?
  • PHP Manual
  • GearmanClient
  • Get an errno value

GearmanClient::getErrno

(PECL gearman >= 0.5.0)

GearmanClient::getErrno — Get an errno value

说明

public GearmanClient::getErrno ( ) : int

Value of errno in the case of a GEARMAN_ERRNO return value.

参数

此函数没有参数。

返回值

A valid Gearman errno.

参见

  • GearmanClient::error() - Returns an error string for the last error encountered


Get the status of a background job

  • ? GearmanClient::getErrno
  • GearmanClient::ping ?
  • PHP Manual
  • GearmanClient
  • Get the status of a background job

GearmanClient::jobStatus

gearman_job_status

(PECL gearman >= 0.5.0)

GearmanClient::jobStatus -- gearman_job_status — Get the status of a background job

说明

面向对象风格 (method):

public GearmanClient::jobStatus ( string $job_handle ) : array

Gets the status for a background job given a job handle. The status information will specify whether the job is known, whether the job is currently running, and the percentage completion.

参数

job_handle

由 Gearman 服务器指派的工作句柄。

返回值

An array containing status information for the job corresponding to the supplied job handle. The first array element is a boolean indicating whether the job is even known, the second is a boolean indicating whether the job is still running, and the third and fourth elements correspond to the numerator and denominator of the fractional completion percentage, respectively.

范例

Example #1 Monitor the status of a long running background job

<?php

/* create our object */
$gmclient= new GearmanClient();

/* add the default server */
$gmclient->addServer();

/* run reverse client */
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

$done = false;
do
{
   sleep(3);
   $stat = $gmclient->jobStatus($job_handle);
   if (!$stat[0]) // the job is known so it is not done
      $done = true;
   echo "Running: " . ($stat[1] ? "true" : "false") . ", numerator: " . $stat[2] . ", denomintor: " . $stat[3] . "\n";
}
while(!$done);

echo "done!\n";

?>

以上例程的输出类似于：

Running: true, numerator: 3, denomintor: 14
Running: true, numerator: 6, denomintor: 14
Running: true, numerator: 9, denomintor: 14
Running: true, numerator: 12, denomintor: 14
Running: false, numerator: 0, denomintor: 0
done!

参见

  • GearmanClient::doStatus() - Get the status for the running task


Send data to all job servers to see if they echo it back

  • ? GearmanClient::jobStatus
  • GearmanClient::removeOptions ?
  • PHP Manual
  • GearmanClient
  • Send data to all job servers to see if they echo it back

GearmanClient::ping

(No version information available, might only be in Git)

GearmanClient::ping — Send data to all job servers to see if they echo it back

说明

public GearmanClient::ping ( string $workload ) : bool

Sends some arbitrary data to all job servers to see if they echo it back. The data sent is not used or processed in any other way. Primarily used for testing and debugging.

参数

workload

Some arbitrary serialized data to be echo back

返回值

成功时返回 true， 或者在失败时返回 false。


Remove client options

  • ? GearmanClient::ping
  • GearmanClient::returnCode ?
  • PHP Manual
  • GearmanClient
  • Remove client options

GearmanClient::removeOptions

(PECL gearman >= 0.6.0)

GearmanClient::removeOptions — Remove client options

说明

public GearmanClient::removeOptions ( int $options ) : bool

Removes (unsets) one or more options.

参数

options

The options to be removed (unset)

返回值

Always returns true.


Get the last Gearman return code

  • ? GearmanClient::removeOptions
  • GearmanClient::runTasks ?
  • PHP Manual
  • GearmanClient
  • Get the last Gearman return code

GearmanClient::returnCode

(PECL gearman >= 0.5.0)

GearmanClient::returnCode — Get the last Gearman return code

说明

public GearmanClient::returnCode ( ) : int

Returns the last Gearman return code.

参数

此函数没有参数。

返回值

A valid Gearman return code.


Run a list of tasks in parallel

  • ? GearmanClient::returnCode
  • GearmanClient::setClientCallback ?
  • PHP Manual
  • GearmanClient
  • Run a list of tasks in parallel

GearmanClient::runTasks

(PECL gearman >= 0.5.0)

GearmanClient::runTasks — Run a list of tasks in parallel

说明

public GearmanClient::runTasks ( ) : bool

For a set of tasks previously added with GearmanClient::addTask(), GearmanClient::addTaskHigh(), GearmanClient::addTaskLow(), GearmanClient::addTaskBackground(), GearmanClient::addTaskHighBackground(), or GearmanClient::addTaskLowBackground(), this call starts running the tasks in parallel.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::addTask() - Add a task to be run in parallel


Callback function when there is a data packet for a task (deprecated)

  • ? GearmanClient::runTasks
  • GearmanClient::setCompleteCallback ?
  • PHP Manual
  • GearmanClient
  • Callback function when there is a data packet for a task (deprecated)

GearmanClient::setClientCallback

(PECL gearman <= 0.5.0)

GearmanClient::setClientCallback — Callback function when there is a data packet for a task (deprecated)

说明

public GearmanClient::setClientCallback ( callable $callback ) : void

Sets the callback function for accepting data packets for a task. The callback function should take a single argument, a GearmanTask object.

Note:

This method has been replaced by GearmanClient::setDataCallback() in the 0.6.0 release of the Gearman extension.

参数

callback

A function or method to call

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Set a function to be called on task completion

  • ? GearmanClient::setClientCallback
  • GearmanClient::setContext ?
  • PHP Manual
  • GearmanClient
  • Set a function to be called on task completion

GearmanClient::setCompleteCallback

(PECL gearman >= 0.5.0)

GearmanClient::setCompleteCallback — Set a function to be called on task completion

说明

public GearmanClient::setCompleteCallback ( callable $callback ) : bool

Use to set a function to be called when a GearmanTask is completed, or when GearmanJob::sendComplete() is invoked by a worker (whichever happens first).

This callback executes only when executing a GearmanTask using GearmanClient::runTasks(). It is not used for individual jobs.

参数

callback

A function to be called

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Set application context

  • ? GearmanClient::setCompleteCallback
  • GearmanClient::setCreatedCallback ?
  • PHP Manual
  • GearmanClient
  • Set application context

GearmanClient::setContext

(PECL gearman >= 0.6.0)

GearmanClient::setContext — Set application context

说明

public GearmanClient::setContext ( string $context ) : bool

Sets an arbitrary string to provide application context that can later be retrieved by GearmanClient::context().

参数

context

Arbitrary context data

返回值

Always returns true.

参见

  • GearmanClient::context() - Get the application context


Set a callback for when a task is queued

  • ? GearmanClient::setContext
  • GearmanClient::setData ?
  • PHP Manual
  • GearmanClient
  • Set a callback for when a task is queued

GearmanClient::setCreatedCallback

(PECL gearman >= 0.5.0)

GearmanClient::setCreatedCallback — Set a callback for when a task is queued

说明

public GearmanClient::setCreatedCallback ( string $callback ) : bool

Sets a function to be called when a task is received and queued by the Gearman job server. The callback should accept a single argument, a GearmanTask object.

参数

callback

A function to call

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Set application data (deprecated)

  • ? GearmanClient::setCreatedCallback
  • GearmanClient::setDataCallback ?
  • PHP Manual
  • GearmanClient
  • Set application data (deprecated)

GearmanClient::setData

(PECL gearman <= 0.5.0)

GearmanClient::setData — Set application data (deprecated)

说明

public GearmanClient::setData ( string $data ) : bool

Sets some arbitrary application data that can later be retrieved by GearmanClient::data().

Note:

This method has been replaced by GearmanCient::setContext() in the 0.6.0 release of the Gearman extension.

参数

data

返回值

Always returns true.

参见

  • GearmanClient::data() - Get the application data (deprecated)


Callback function when there is a data packet for a task

  • ? GearmanClient::setData
  • GearmanClient::setExceptionCallback ?
  • PHP Manual
  • GearmanClient
  • Callback function when there is a data packet for a task

GearmanClient::setDataCallback

(PECL gearman >= 0.6.0)

GearmanClient::setDataCallback — Callback function when there is a data packet for a task

说明

public GearmanClient::setDataCallback ( callable $callback ) : bool

Sets the callback function for accepting data packets for a task. The callback function should take a single argument, a GearmanTask object.

参数

callback

A function or method to call

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Set a callback for worker exceptions

  • ? GearmanClient::setDataCallback
  • GearmanClient::setFailCallback ?
  • PHP Manual
  • GearmanClient
  • Set a callback for worker exceptions

GearmanClient::setExceptionCallback

(PECL gearman >= 0.5.0)

GearmanClient::setExceptionCallback — Set a callback for worker exceptions

说明

public GearmanClient::setExceptionCallback ( callable $callback ) : bool

Specifies a function to call when a worker for a task sends an exception.

参数

callback

Function to call when the worker throws an exception

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Set callback for job failure

  • ? GearmanClient::setExceptionCallback
  • GearmanClient::setOptions ?
  • PHP Manual
  • GearmanClient
  • Set callback for job failure

GearmanClient::setFailCallback

(PECL gearman >= 0.5.0)

GearmanClient::setFailCallback — Set callback for job failure

说明

public GearmanClient::setFailCallback ( callable $callback ) : bool

Sets the callback function to be used when a task does not complete successfully. The function should accept a single argument, a GearmanTask object.

参数

callback

A function to call

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Set client options

  • ? GearmanClient::setFailCallback
  • GearmanClient::setStatusCallback ?
  • PHP Manual
  • GearmanClient
  • Set client options

GearmanClient::setOptions

(PECL gearman >= 0.5.0)

GearmanClient::setOptions — Set client options

说明

public GearmanClient::setOptions ( int $options ) : bool

Sets one or more client options.

参数

options

The options to be set

返回值

Always returns true.


Set a callback for collecting task status

  • ? GearmanClient::setOptions
  • GearmanClient::setTimeout ?
  • PHP Manual
  • GearmanClient
  • Set a callback for collecting task status

GearmanClient::setStatusCallback

(PECL gearman >= 0.5.0)

GearmanClient::setStatusCallback — Set a callback for collecting task status

说明

public GearmanClient::setStatusCallback ( callable $callback ) : bool

Sets a callback function used for getting updated status information from a worker. The function should accept a single argument, a GearmanTask object.

参数

callback

A function to call

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Set socket I/O activity timeout

  • ? GearmanClient::setStatusCallback
  • GearmanClient::setWarningCallback ?
  • PHP Manual
  • GearmanClient
  • Set socket I/O activity timeout

GearmanClient::setTimeout

(PECL gearman >= 0.6.0)

GearmanClient::setTimeout — Set socket I/O activity timeout

说明

public GearmanClient::setTimeout ( int $timeout ) : bool

Sets the timeout for socket I/O activity.

参数

timeout

An interval of time in milliseconds

返回值

Always returns true.


Set a callback for worker warnings

  • ? GearmanClient::setTimeout
  • GearmanClient::setWorkloadCallback ?
  • PHP Manual
  • GearmanClient
  • Set a callback for worker warnings

GearmanClient::setWarningCallback

(PECL gearman >= 0.5.0)

GearmanClient::setWarningCallback — Set a callback for worker warnings

说明

public GearmanClient::setWarningCallback ( callable $callback ) : bool

Sets a function to be called when a worker sends a warning. The callback should accept a single argument, a GearmanTask object.

参数

callback

A function to call

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates


Set a callback for accepting incremental data updates

  • ? GearmanClient::setWarningCallback
  • GearmanClient::timeout ?
  • PHP Manual
  • GearmanClient
  • Set a callback for accepting incremental data updates

GearmanClient::setWorkloadCallback

(PECL gearman >= 0.5.0)

GearmanClient::setWorkloadCallback — Set a callback for accepting incremental data updates

说明

public GearmanClient::setWorkloadCallback ( callable $callback ) : bool

Sets a function to be called when a worker needs to send back data prior to job completion. A worker can do this when it needs to send updates, send partial results, or flush data during long running jobs. The callback should accept a single argument, a GearmanTask object.

参数

callback

A function to call

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings


Get current socket I/O activity timeout value

  • ? GearmanClient::setWorkloadCallback
  • GearmanClient::wait ?
  • PHP Manual
  • GearmanClient
  • Get current socket I/O activity timeout value

GearmanClient::timeout

(PECL gearman >= 0.6.0)

GearmanClient::timeout — Get current socket I/O activity timeout value

说明

public GearmanClient::timeout ( ) : int

Returns the timeout in milliseconds to wait for I/O activity.

参数

此函数没有参数。

返回值

Timeout in milliseconds to wait for I/O activity. A negative value means an infinite timeout.

参见

  • GearmanClient::setTimeout() - Set socket I/O activity timeout


Wait for I/O activity on all connections in a client

  • ? GearmanClient::timeout
  • GearmanJob ?
  • PHP Manual
  • GearmanClient
  • Wait for I/O activity on all connections in a client

GearmanClient::wait

(PECL gearman >= 0.6.0)

GearmanClient::wait — Wait for I/O activity on all connections in a client

说明

public GearmanClient::wait ( ) : bool

This waits for activity from any one of the connected servers.

参数

此函数没有参数。

返回值

true on success false on an error.

参见

  • GearmanWorker::wait() - Wait for activity from one of the job servers


The GearmanJob class

(PECL gearman >= 0.5.0)

简介

类摘要

GearmanJob {
/* 方法 */
public complete ( string $result ) : bool
public __construct ( )
public data ( string $data ) : bool
public exception ( string $exception ) : bool
public fail ( ) : bool
public functionName ( ) : string
public handle ( ) : string
public returnCode ( ) : int
public sendComplete ( string $result ) : bool
public sendData ( string $data ) : bool
public sendException ( string $exception ) : bool
public sendFail ( ) : bool
public sendStatus ( int $numerator , int $denominator ) : bool
public sendWarning ( string $warning ) : bool
public setReturn ( int $gearman_return_t ) : bool
public status ( int $numerator , int $denominator ) : bool
public unique ( ) : string
public warning ( string $warning ) : bool
public workload ( ) : string
public workloadSize ( ) : int
}

Table of Contents

  • GearmanJob::complete — Send the result and complete status (deprecated)
  • GearmanJob::__construct — Create a GearmanJob instance
  • GearmanJob::data — Send data for a running job (deprecated)
  • GearmanJob::exception — Send exception for running job (deprecated)
  • GearmanJob::fail — Send fail status (deprecated)
  • GearmanJob::functionName — Get function name
  • GearmanJob::handle — Get the job handle
  • GearmanJob::returnCode — Get last return code
  • GearmanJob::sendComplete — Send the result and complete status
  • GearmanJob::sendData — Send data for a running job
  • GearmanJob::sendException — Send exception for running job (exception)
  • GearmanJob::sendFail — Send fail status
  • GearmanJob::sendStatus — Send status
  • GearmanJob::sendWarning — Send a warning
  • GearmanJob::setReturn — Set a return value
  • GearmanJob::status — Send status (deprecated)
  • GearmanJob::unique — Get the unique identifier
  • GearmanJob::warning — Send a warning (deprecated)
  • GearmanJob::workload — Get workload
  • GearmanJob::workloadSize — Get size of work load


Send the result and complete status (deprecated)

  • ? GearmanJob
  • GearmanJob::__construct ?
  • PHP Manual
  • GearmanJob
  • Send the result and complete status (deprecated)

GearmanJob::complete

(PECL gearman <= 0.5.0)

GearmanJob::complete — Send the result and complete status (deprecated)

说明

public GearmanJob::complete ( string $result ) : bool

Sends result data and the complete status update for this job.

Note:

This method has been replaced by GearmanJob::sendComplete() in the 0.6.0 release of the Gearman extension.

参数

result

Serialized result data.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::sendFail() - Send fail status
  • GearmanJob::setReturn() - Set a return value


Create a GearmanJob instance

  • ? GearmanJob::complete
  • GearmanJob::data ?
  • PHP Manual
  • GearmanJob
  • Create a GearmanJob instance

GearmanJob::__construct

(PECL gearman >= 0.5.0)

GearmanJob::__construct — Create a GearmanJob instance

说明

public GearmanJob::__construct ( )

Creates a GearmanJob instance representing a job the worker is to complete.

参数

此函数没有参数。

返回值

A GearmanJob object.


Send data for a running job (deprecated)

  • ? GearmanJob::__construct
  • GearmanJob::exception ?
  • PHP Manual
  • GearmanJob
  • Send data for a running job (deprecated)

GearmanJob::data

(PECL gearman <= 0.5.0)

GearmanJob::data — Send data for a running job (deprecated)

说明

public GearmanJob::data ( string $data ) : bool

Sends data to the job server (and any listening clients) for this job.

Note:

This method has been replaced by GearmanJob::sendData() in the 0.6.0 release of the Gearman extension.

参数

data

Arbitrary serialized data.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::workload() - Get workload
  • GearmanTask::data() - Get data returned for a task


Send exception for running job (deprecated)

  • ? GearmanJob::data
  • GearmanJob::fail ?
  • PHP Manual
  • GearmanJob
  • Send exception for running job (deprecated)

GearmanJob::exception

(PECL gearman <= 0.5.0)

GearmanJob::exception — Send exception for running job (deprecated)

说明

public GearmanJob::exception ( string $exception ) : bool

Sends the supplied exception when this job is running.

Note:

This method has been replaced by GearmanJob::sendException() in the 0.6.0 release of the Gearman extension.

参数

exception

An exception description.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::setReturn() - Set a return value
  • GearmanJob::sendStatus() - Send status
  • GearmanJob::sendWarning() - Send a warning


Send fail status (deprecated)

  • ? GearmanJob::exception
  • GearmanJob::functionName ?
  • PHP Manual
  • GearmanJob
  • Send fail status (deprecated)

GearmanJob::fail

(PECL gearman <= 0.5.0)

GearmanJob::fail — Send fail status (deprecated)

说明

public GearmanJob::fail ( ) : bool

Sends failure status for this job, indicating that the job failed in a known way (as opposed to failing due to a thrown exception).

Note:

This method has been replaced by GearmanJob::sendFail() in the 0.6.0 release of the Gearman extension.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::sendException() - Send exception for running job (exception)
  • GearmanJob::setReturn() - Set a return value
  • GearmanJob::sendStatus() - Send status
  • GearmanJob::sendWarning() - Send a warning


Get function name

  • ? GearmanJob::fail
  • GearmanJob::handle ?
  • PHP Manual
  • GearmanJob
  • Get function name

GearmanJob::functionName

(PECL gearman >= 0.5.0)

GearmanJob::functionName — Get function name

说明

public GearmanJob::functionName ( ) : string

Returns the function name for this job. This is the function the work will execute to perform the job.

参数

此函数没有参数。

返回值

The name of a function.

参见

  • GearmanTask::function() - Get associated function name (deprecated)


Get the job handle

  • ? GearmanJob::functionName
  • GearmanJob::returnCode ?
  • PHP Manual
  • GearmanJob
  • Get the job handle

GearmanJob::handle

(PECL gearman >= 0.5.0)

GearmanJob::handle — Get the job handle

说明

public GearmanJob::handle ( ) : string

Returns the opaque job handle assigned by the job server.

参数

此函数没有参数。

返回值

An opaque job handle.

参见

  • GearmanTask::jobHandle() - Get the job handle


Get last return code

  • ? GearmanJob::handle
  • GearmanJob::sendComplete ?
  • PHP Manual
  • GearmanJob
  • Get last return code

GearmanJob::returnCode

(PECL gearman >= 0.5.0)

GearmanJob::returnCode — Get last return code

说明

public GearmanJob::returnCode ( ) : int

Returns the last return code issued by the job server.

参数

此函数没有参数。

返回值

A valid Gearman return code.

参见

  • GearmanTask::returnCode() - Get the last return code


Send the result and complete status

  • ? GearmanJob::returnCode
  • GearmanJob::sendData ?
  • PHP Manual
  • GearmanJob
  • Send the result and complete status

GearmanJob::sendComplete

(PECL gearman >= 0.6.0)

GearmanJob::sendComplete — Send the result and complete status

说明

public GearmanJob::sendComplete ( string $result ) : bool

Sends result data and the complete status update for this job.

参数

result

Serialized result data.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::sendFail() - Send fail status
  • GearmanJob::setReturn() - Set a return value


Send data for a running job

  • ? GearmanJob::sendComplete
  • GearmanJob::sendException ?
  • PHP Manual
  • GearmanJob
  • Send data for a running job

GearmanJob::sendData

(PECL gearman >= 0.6.0)

GearmanJob::sendData — Send data for a running job

说明

public GearmanJob::sendData ( string $data ) : bool

Sends data to the job server (and any listening clients) for this job.

参数

data

Arbitrary serialized data.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::workload() - Get workload
  • GearmanTask::data() - Get data returned for a task


Send exception for running job (exception)

  • ? GearmanJob::sendData
  • GearmanJob::sendFail ?
  • PHP Manual
  • GearmanJob
  • Send exception for running job (exception)

GearmanJob::sendException

(PECL gearman >= 0.6.0)

GearmanJob::sendException — Send exception for running job (exception)

说明

public GearmanJob::sendException ( string $exception ) : bool

Sends the supplied exception when this job is running.

参数

exception

An exception description.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::setReturn() - Set a return value
  • GearmanJob::sendStatus() - Send status
  • GearmanJob::sendWarning() - Send a warning


Send fail status

  • ? GearmanJob::sendException
  • GearmanJob::sendStatus ?
  • PHP Manual
  • GearmanJob
  • Send fail status

GearmanJob::sendFail

(PECL gearman >= 0.6.0)

GearmanJob::sendFail — Send fail status

说明

public GearmanJob::sendFail ( ) : bool

Sends failure status for this job, indicating that the job failed in a known way (as opposed to failing due to a thrown exception).

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::sendException() - Send exception for running job (exception)
  • GearmanJob::setReturn() - Set a return value
  • GearmanJob::sendStatus() - Send status
  • GearmanJob::sendWarning() - Send a warning


Send status

  • ? GearmanJob::sendFail
  • GearmanJob::sendWarning ?
  • PHP Manual
  • GearmanJob
  • Send status

GearmanJob::sendStatus

(PECL gearman >= 0.6.0)

GearmanJob::sendStatus — Send status

说明

public GearmanJob::sendStatus ( int $numerator , int $denominator ) : bool

Sends status information to the job server and any listening clients. Use this to specify what percentage of the job has been completed.

参数

numerator

The numerator of the precentage completed expressed as a fraction.

denominator

The denominator of the precentage completed expressed as a fraction.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::jobStatus() - Get the status of a background job
  • GearmanTask::taskDenominator() - Get completion percentage denominator
  • GearmanTask::taskNumerator() - Get completion percentage numerator


Send a warning

  • ? GearmanJob::sendStatus
  • GearmanJob::setReturn ?
  • PHP Manual
  • GearmanJob
  • Send a warning

GearmanJob::sendWarning

(PECL gearman >= 0.6.0)

GearmanJob::sendWarning — Send a warning

说明

public GearmanJob::sendWarning ( string $warning ) : bool

Sends a warning for this job while it is running.

参数

warning

A warning message.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::sendComplete() - Send the result and complete status
  • GearmanJob::sendException() - Send exception for running job (exception)
  • GearmanJob::sendFail() - Send fail status


Set a return value

  • ? GearmanJob::sendWarning
  • GearmanJob::status ?
  • PHP Manual
  • GearmanJob
  • Set a return value

GearmanJob::setReturn

(PECL gearman >= 0.5.0)

GearmanJob::setReturn — Set a return value

说明

public GearmanJob::setReturn ( int $gearman_return_t ) : bool

Sets the return value for this job, indicates how the job completed.

参数

gearman_return_t

A valid Gearman return value.

返回值

Description...


Send status (deprecated)

  • ? GearmanJob::setReturn
  • GearmanJob::unique ?
  • PHP Manual
  • GearmanJob
  • Send status (deprecated)

GearmanJob::status

(PECL gearman <= 0.5.0)

GearmanJob::status — Send status (deprecated)

说明

public GearmanJob::status ( int $numerator , int $denominator ) : bool

Sends status information to the job server and any listening clients. Use this to specify what percentage of the job has been completed.

Note:

This method has been replaced by GearmanJob::sendStatus() in the 0.6.0 release of the Gearman extenstion.

参数

numerator

The numerator of the precentage completed expressed as a fraction.

denominator

The denominator of the precentage completed expressed as a fraction.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanClient::jobStatus() - Get the status of a background job
  • GearmanTask::taskDenominator() - Get completion percentage denominator
  • GearmanTask::taskNumerator() - Get completion percentage numerator


Get the unique identifier

  • ? GearmanJob::status
  • GearmanJob::warning ?
  • PHP Manual
  • GearmanJob
  • Get the unique identifier

GearmanJob::unique

(PECL gearman >= 0.5.0)

GearmanJob::unique — Get the unique identifier

说明

public GearmanJob::unique ( ) : string

Returns the unique identifier for this job. The identifier is assigned by the client.

参数

此函数没有参数。

返回值

An opaque unique identifier.

参见

  • GearmanClient::do() - Run a single task and return a result [deprecated]
  • GearmanTask::uuid() - Get the unique identifier for a task (deprecated)


Send a warning (deprecated)

  • ? GearmanJob::unique
  • GearmanJob::workload ?
  • PHP Manual
  • GearmanJob
  • Send a warning (deprecated)

GearmanJob::warning

(PECL gearman <= 0.5.0)

GearmanJob::warning — Send a warning (deprecated)

说明

public GearmanJob::warning ( string $warning ) : bool

Sends a warning for this job while it is running.

Note:

This method has been replaced by GearmanJob::sendWarning() in the 0.6.0 release of the Gearman extension.

参数

warning

A warning messages.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • GearmanJob::sendComplete() - Send the result and complete status
  • GearmanJob::sendException() - Send exception for running job (exception)
  • GearmanJob::sendFail() - Send fail status


Get workload

  • ? GearmanJob::warning
  • GearmanJob::workloadSize ?
  • PHP Manual
  • GearmanJob
  • Get workload

GearmanJob::workload

(PECL gearman >= 0.5.0)

GearmanJob::workload — Get workload

说明

public GearmanJob::workload ( ) : string

Returns the workload for the job. This is serialized data that is to be processed by the worker.

参数

此函数没有参数。

返回值

Serialized data.

参见

  • GearmanClient::do() - Run a single task and return a result [deprecated]
  • GearmanJob::workloadSize() - Get size of work load


Get size of work load

  • ? GearmanJob::workload
  • GearmanTask ?
  • PHP Manual
  • GearmanJob
  • Get size of work load

GearmanJob::workloadSize

(PECL gearman >= 0.5.0)

GearmanJob::workloadSize — Get size of work load

说明

public GearmanJob::workloadSize ( ) : int

Returns the size of the job's work load (the data the worker is to process) in bytes.

参数

此函数没有参数。

返回值

The size in bytes.

参见

  • GearmanJob::workload() - Get workload


The GearmanTask class

(PECL gearman >= 0.5.0)

简介

类摘要

GearmanTask {
/* 方法 */
public __construct ( )
public create ( ) : GearmanTask|false
public data ( ) : string
public dataSize ( ) : int
public function ( ) : string
public functionName ( ) : string
public isKnown ( ) : bool
public isRunning ( ) : bool
public jobHandle ( ) : string
public recvData ( int $data_len ) : array
public returnCode ( ) : int
public sendData ( string $data ) : int
public sendWorkload ( string $data ) : int
public taskDenominator ( ) : int
public taskNumerator ( ) : int
public unique ( ) : string
public uuid ( ) : string
}

Table of Contents

  • GearmanTask::__construct — Create a GearmanTask instance
  • GearmanTask::create — Create a task (deprecated)
  • GearmanTask::data — Get data returned for a task
  • GearmanTask::dataSize — Get the size of returned data
  • GearmanTask::function — Get associated function name (deprecated)
  • GearmanTask::functionName — Get associated function name
  • GearmanTask::isKnown — Determine if task is known
  • GearmanTask::isRunning — Test whether the task is currently running
  • GearmanTask::jobHandle — Get the job handle
  • GearmanTask::recvData — Read work or result data into a buffer for a task
  • GearmanTask::returnCode — Get the last return code
  • GearmanTask::sendData — Send data for a task (deprecated)
  • GearmanTask::sendWorkload — Send data for a task
  • GearmanTask::taskDenominator — Get completion percentage denominator
  • GearmanTask::taskNumerator — Get completion percentage numerator
  • GearmanTask::unique — Get the unique identifier for a task
  • GearmanTask::uuid — Get the unique identifier for a task (deprecated)


Create a GearmanTask instance

  • ? GearmanTask
  • GearmanTask::create ?
  • PHP Manual
  • GearmanTask
  • Create a GearmanTask instance

GearmanTask::__construct

(PECL gearman >= 0.5.0)

GearmanTask::__construct — Create a GearmanTask instance

说明

public GearmanTask::__construct ( )

Creates a GearmanTask instance representing a task to be submitted to a job server.

参数

此函数没有参数。

返回值

A GearmanTask object.


Create a task (deprecated)

  • ? GearmanTask::__construct
  • GearmanTask::data ?
  • PHP Manual
  • GearmanTask
  • Create a task (deprecated)

GearmanTask::create

(PECL gearman <= 0.5.0)

GearmanTask::create — Create a task (deprecated)

说明

public GearmanTask::create ( ) : GearmanTask|false

Returns a new GearmanTask object.

Note:

This method was removed in the 0.6.0 version of the Gearman extension.

参数

此函数没有参数。

返回值

A GearmanTask oject 或者在失败时返回 false.


Get data returned for a task

  • ? GearmanTask::create
  • GearmanTask::dataSize ?
  • PHP Manual
  • GearmanTask
  • Get data returned for a task

GearmanTask::data

(PECL gearman >= 0.5.0)

GearmanTask::data — Get data returned for a task

说明

public GearmanTask::data ( ) : string

Returns data being returned for a task by a worker.

参数

此函数没有参数。

返回值

The serialized data, or false if no data is present.

参见

  • GearmanTask::dataSize() - Get the size of returned data


Get the size of returned data

  • ? GearmanTask::data
  • GearmanTask::function ?
  • PHP Manual
  • GearmanTask
  • Get the size of returned data

GearmanTask::dataSize

(PECL gearman >= 0.5.0)

GearmanTask::dataSize — Get the size of returned data

说明

public GearmanTask::dataSize ( ) : int

Returns the size of the data being returned for a task.

参数

此函数没有参数。

返回值

The data size, or false if there is no data.

参见

  • GearmanTask::data() - Get data returned for a task


Get associated function name (deprecated)

  • ? GearmanTask::dataSize
  • GearmanTask::functionName ?
  • PHP Manual
  • GearmanTask
  • Get associated function name (deprecated)

GearmanTask::function

(PECL gearman <= 0.5.0)

GearmanTask::function — Get associated function name (deprecated)

说明

public GearmanTask::function ( ) : string

Returns the name of the function this task is associated with, i.e., the function the Gearman worker calls.

Note:

This method has been replaced by GearmanTask::functionName() in the 0.6.0 release of the Gearman extension.

参数

此函数没有参数。

返回值

A function name.


Get associated function name

  • ? GearmanTask::function
  • GearmanTask::isKnown ?
  • PHP Manual
  • GearmanTask
  • Get associated function name

GearmanTask::functionName

(PECL gearman >= 0.6.0)

GearmanTask::functionName — Get associated function name

说明

public GearmanTask::functionName ( ) : string

Returns the name of the function this task is associated with, i.e., the function the Gearman worker calls.

参数

此函数没有参数。

返回值

A function name.


Determine if task is known

  • ? GearmanTask::functionName
  • GearmanTask::isRunning ?
  • PHP Manual
  • GearmanTask
  • Determine if task is known

GearmanTask::isKnown

(PECL gearman >= 0.5.0)

GearmanTask::isKnown — Determine if task is known

说明

public GearmanTask::isKnown ( ) : bool

Gets the status information for whether or not this task is known to the job server.

参数

此函数没有参数。

返回值

true if the task is known, false otherwise.


Test whether the task is currently running

  • ? GearmanTask::isKnown
  • GearmanTask::jobHandle ?
  • PHP Manual
  • GearmanTask
  • Test whether the task is currently running

GearmanTask::isRunning

(PECL gearman >= 0.5.0)

GearmanTask::isRunning — Test whether the task is currently running

说明

public GearmanTask::isRunning ( ) : bool

Indicates whether or not this task is currently running.

参数

此函数没有参数。

返回值

true if the task is running, false otherwise.


Get the job handle

  • ? GearmanTask::isRunning
  • GearmanTask::recvData ?
  • PHP Manual
  • GearmanTask
  • Get the job handle

GearmanTask::jobHandle

gearman_job_handle

(PECL gearman >= 0.5.0)

GearmanTask::jobHandle -- gearman_job_handle — Get the job handle

说明

public GearmanTask::jobHandle ( ) : string

Returns the job handle for this task.

参数

此函数没有参数。

返回值

The opaque job handle.

参见

  • GearmanClient::doJobHandle() - Get the job handle for the running task


Read work or result data into a buffer for a task

  • ? GearmanTask::jobHandle
  • GearmanTask::returnCode ?
  • PHP Manual
  • GearmanTask
  • Read work or result data into a buffer for a task

GearmanTask::recvData

(PECL gearman >= 0.5.0)

GearmanTask::recvData — Read work or result data into a buffer for a task

说明

public GearmanTask::recvData ( int $data_len ) : array

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

data_len

Length of data to be read.

返回值

An array whose first element is the length of data read and the second is the data buffer. Returns false if the read failed.

参见

  • GearmanTask::sendData() - Send data for a task (deprecated)


Get the last return code

  • ? GearmanTask::recvData
  • GearmanTask::sendData ?
  • PHP Manual
  • GearmanTask
  • Get the last return code

GearmanTask::returnCode

(PECL gearman >= 0.5.0)

GearmanTask::returnCode — Get the last return code

说明

public GearmanTask::returnCode ( ) : int

Returns the last Gearman return code for this task.

参数

此函数没有参数。

返回值

A valid Gearman return code.

参见

  • GearmanClient::returnCode() - Get the last Gearman return code


Send data for a task (deprecated)

  • ? GearmanTask::returnCode
  • GearmanTask::sendWorkload ?
  • PHP Manual
  • GearmanTask
  • Send data for a task (deprecated)

GearmanTask::sendData

(PECL gearman <= 0.5.0)

GearmanTask::sendData — Send data for a task (deprecated)

说明

public GearmanTask::sendData ( string $data ) : int

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

data

Data to send to the worker.

返回值

The length of data sent, or false if the send failed.

参见

  • GearmanTask::recvData() - Read work or result data into a buffer for a task


Send data for a task

  • ? GearmanTask::sendData
  • GearmanTask::taskDenominator ?
  • PHP Manual
  • GearmanTask
  • Send data for a task

GearmanTask::sendWorkload

(PECL gearman >= 0.6.0)

GearmanTask::sendWorkload — Send data for a task

说明

public GearmanTask::sendWorkload ( string $data ) : int

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

data

Data to send to the worker.

返回值

The length of data sent, or false if the send failed.

参见

  • GearmanTask::recvData() - Read work or result data into a buffer for a task


Get completion percentage denominator

  • ? GearmanTask::sendWorkload
  • GearmanTask::taskNumerator ?
  • PHP Manual
  • GearmanTask
  • Get completion percentage denominator

GearmanTask::taskDenominator

(PECL gearman >= 0.5.0)

GearmanTask::taskDenominator — Get completion percentage denominator

说明

public GearmanTask::taskDenominator ( ) : int

Returns the denominator of the percentage of the task that is complete expressed as a fraction.

参数

此函数没有参数。

返回值

A number between 0 and 100, or false if cannot be determined.

参见

  • GearmanTask::taskNumerator() - Get completion percentage numerator


Get completion percentage numerator

  • ? GearmanTask::taskDenominator
  • GearmanTask::unique ?
  • PHP Manual
  • GearmanTask
  • Get completion percentage numerator

GearmanTask::taskNumerator

(PECL gearman >= 0.5.0)

GearmanTask::taskNumerator — Get completion percentage numerator

说明

public GearmanTask::taskNumerator ( ) : int

Returns the numerator of the percentage of the task that is complete expressed as a fraction.

参数

此函数没有参数。

返回值

A number between 0 and 100, or false if cannot be determined.

参见

  • GearmanTask::taskDenominator() - Get completion percentage denominator


Get the unique identifier for a task

  • ? GearmanTask::taskNumerator
  • GearmanTask::uuid ?
  • PHP Manual
  • GearmanTask
  • Get the unique identifier for a task

GearmanTask::unique

(PECL gearman >= 0.6.0)

GearmanTask::unique — Get the unique identifier for a task

说明

public GearmanTask::unique ( ) : string

Returns the unique identifier for this task. This is assigned by the GearmanClient, as opposed to the job handle which is set by the Gearman job server.

参数

此函数没有参数。

返回值

The unique identifier, or false if no identifier is assigned.

参见

  • GearmanClient::do() - Run a single task and return a result [deprecated]
  • GearmanClient::addTask() - Add a task to be run in parallel


Get the unique identifier for a task (deprecated)

  • ? GearmanTask::unique
  • GearmanWorker ?
  • PHP Manual
  • GearmanTask
  • Get the unique identifier for a task (deprecated)

GearmanTask::uuid

(PECL gearman <= 0.5.0)

GearmanTask::uuid — Get the unique identifier for a task (deprecated)

说明

public GearmanTask::uuid ( ) : string

Returns the unique identifier for this task. This is assigned by the GearmanClient, as opposed to the job handle which is set by the Gearman job server.

Note:

This method has been replaced by GearmanTask::unique() in the 0.6.0 release of the Gearman extension.

参数

此函数没有参数。

返回值

The unique identifier, or false if no identifier is assigned.

参见

  • GearmanClient::do() - Run a single task and return a result [deprecated]
  • GearmanClient::addTask() - Add a task to be run in parallel


The GearmanWorker class

(PECL gearman >= 0.5.0)

简介

类摘要

GearmanWorker {
/* 方法 */
public addFunction ( string $function_name , callable $function , mixed &$context = ? , int $timeout = ? ) : bool
public addOptions ( int $option ) : bool
public addServer ( string $host = 127.0.0.1 , int $port = 4730 ) : bool
public addServers ( string $servers = 127.0.0.1:4730 ) : bool
public clone ( ) : void
public __construct ( )
public echo ( string $workload ) : bool
public error ( ) : string
public getErrno ( ) : int
public options ( ) : int
public register ( string $function_name , int $timeout = ? ) : bool
public removeOptions ( int $option ) : bool
public returnCode ( ) : int
public setId ( string $id ) : bool
public setOptions ( int $option ) : bool
public setTimeout ( int $timeout ) : bool
public timeout ( ) : int
public unregister ( string $function_name ) : bool
public unregisterAll ( ) : bool
public wait ( ) : bool
public work ( ) : bool
}

Table of Contents

  • GearmanWorker::addFunction — Register and add callback function
  • GearmanWorker::addOptions — Add worker options
  • GearmanWorker::addServer — Add a job server
  • GearmanWorker::addServers — Add job servers
  • GearmanWorker::clone — Create a copy of the worker
  • GearmanWorker::__construct — Create a GearmanWorker instance
  • GearmanWorker::echo — Test job server response
  • GearmanWorker::error — Get the last error encountered
  • GearmanWorker::getErrno — Get errno
  • GearmanWorker::options — Get worker options
  • GearmanWorker::register — Register a function with the job server
  • GearmanWorker::removeOptions — Remove worker options
  • GearmanWorker::returnCode — Get last Gearman return code
  • GearmanWorker::setId — Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers
  • GearmanWorker::setOptions — Set worker options
  • GearmanWorker::setTimeout — Set socket I/O activity timeout
  • GearmanWorker::timeout — Get socket I/O activity timeout
  • GearmanWorker::unregister — Unregister a function name with the job servers
  • GearmanWorker::unregisterAll — Unregister all function names with the job servers
  • GearmanWorker::wait — Wait for activity from one of the job servers
  • GearmanWorker::work — Wait for and perform jobs


Register and add callback function

  • ? GearmanWorker
  • GearmanWorker::addOptions ?
  • PHP Manual
  • GearmanWorker
  • Register and add callback function

GearmanWorker::addFunction

(PECL gearman >= 0.5.0)

GearmanWorker::addFunction — Register and add callback function

说明

public GearmanWorker::addFunction ( string $function_name , callable $function , mixed &$context = ? , int $timeout = ? ) : bool

Registers a function name with the job server and specifies a callback corresponding to that function. Optionally specify extra application context data to be used when the callback is called and a timeout.

参数

function_name

The name of a function to register with the job server

function

A callback that gets called when a job for the registered function name is submitted

context

A reference to arbitrary application context data that can be modified by the worker function

timeout

An interval of time in seconds

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Simple worker making use of extra application context data

<?php

# get a gearman worker
$worker= new GearmanWorker();

# add the default server (localhost)
$worker->addServer();

# define a variable to hold application data
$count= 0;

# add the "reverse" function
$worker->addFunction("reverse", "reverse_cb", $count);

# start the worker
while ($worker->work());

function reverse_cb($job, &$count)
{
  $count++;
  return "$count: " . strrev($job->workload());
}

?>

Running a client that submits two jobs for the reverse function would have output similar to the following:

1: olleh
2: dlrow

参见

  • GearmanClient::do() - Run a single task and return a result [deprecated]


Add worker options

  • ? GearmanWorker::addFunction
  • GearmanWorker::addServer ?
  • PHP Manual
  • GearmanWorker
  • Add worker options

GearmanWorker::addOptions

(PECL gearman >= 0.6.0)

GearmanWorker::addOptions — Add worker options

说明

public GearmanWorker::addOptions ( int $option ) : bool

Adds one or more options to the options previously set.

参数

option

The options to be added

返回值

Always returns true.

参见

  • GearmanWorker::options() - Get worker options
  • GearmanClient::setOptions() - Set client options
  • GearmanClient::removeOptions() - Remove client options


Add a job server

  • ? GearmanWorker::addOptions
  • GearmanWorker::addServers ?
  • PHP Manual
  • GearmanWorker
  • Add a job server

GearmanWorker::addServer

(PECL gearman >= 0.5.0)

GearmanWorker::addServer — Add a job server

说明

public GearmanWorker::addServer ( string $host = 127.0.0.1 , int $port = 4730 ) : bool

Adds a job server to this worker. This goes into a list of servers than can be used to run jobs. No socket I/O happens here.

参数

host

任务服务器主机名。

port

任务服务器端口号。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Add alternate Gearman servers

<?php
$worker= new GearmanWorker();
$worker->addServer("10.0.0.1");
$worker->addServer("10.0.0.2", 7003);
?>

参见

  • GearmanWorker::addServers() - Add job servers


Add job servers

  • ? GearmanWorker::addServer
  • GearmanWorker::clone ?
  • PHP Manual
  • GearmanWorker
  • Add job servers

GearmanWorker::addServers

(PECL gearman >= 0.5.0)

GearmanWorker::addServers — Add job servers

说明

public GearmanWorker::addServers ( string $servers = 127.0.0.1:4730 ) : bool

Adds one or more job servers to this worker. These go into a list of servers that can be used to run jobs. No socket I/O happens here.

参数

servers

A comma separated list of job servers in the format host:port. If no port is specified, it defaults to 4730.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Add two job servers

<?php

$worker= new GearmanWorker();
$worker->addServers("10.0.0.1,10.0.0.2:7003");

?>

参见

  • GearmanWorker::addServer() - Add a job server


Create a copy of the worker

  • ? GearmanWorker::addServers
  • GearmanWorker::__construct ?
  • PHP Manual
  • GearmanWorker
  • Create a copy of the worker

GearmanWorker::clone

(PECL gearman >= 0.5.0)

GearmanWorker::clone — Create a copy of the worker

说明

public GearmanWorker::clone ( ) : void

Creates a copy of the worker.

参数

此函数没有参数。

返回值

A GearmanWorker object


Create a GearmanWorker instance

  • ? GearmanWorker::clone
  • GearmanWorker::echo ?
  • PHP Manual
  • GearmanWorker
  • Create a GearmanWorker instance

GearmanWorker::__construct

(PECL gearman >= 0.5.0)

GearmanWorker::__construct — Create a GearmanWorker instance

说明

public GearmanWorker::__construct ( )

Creates a GearmanWorker instance representing a worker that connects to the job server and accepts tasks to run.

参数

此函数没有参数。

返回值

A GearmanWorker object

参见

  • GearmanWorker::clone() - Create a copy of the worker


Test job server response

  • ? GearmanWorker::__construct
  • GearmanWorker::error ?
  • PHP Manual
  • GearmanWorker
  • Test job server response

GearmanWorker::echo

(PECL gearman >= 0.6.0)

GearmanWorker::echo — Test job server response

说明

public GearmanWorker::echo ( string $workload ) : bool

Sends data to all job servers to see if they echo it back. This is a test function to see if job servers are responding properly.

参数

workload

Arbitrary serialized data

返回值

Standard Gearman return value.

参见

  • GearmanClient::echo() - Send data to all job servers to see if they echo it back [deprecated]


Get the last error encountered

  • ? GearmanWorker::echo
  • GearmanWorker::getErrno ?
  • PHP Manual
  • GearmanWorker
  • Get the last error encountered

GearmanWorker::error

(PECL gearman >= 0.5.0)

GearmanWorker::error — Get the last error encountered

说明

public GearmanWorker::error ( ) : string

Returns an error string for the last error encountered.

参数

此函数没有参数。

返回值

An error string.

参见

  • GearmanWorker::getErrno() - Get errno


Get errno

  • ? GearmanWorker::error
  • GearmanWorker::options ?
  • PHP Manual
  • GearmanWorker
  • Get errno

GearmanWorker::getErrno

(PECL gearman >= 0.5.0)

GearmanWorker::getErrno — Get errno

说明

public GearmanWorker::getErrno ( ) : int

Returns the value of errno in the case of a GEARMAN_ERRNO return value.

参数

此函数没有参数。

返回值

A valid errno.

参见

  • GearmanWorker::error() - Get the last error encountered


Get worker options

  • ? GearmanWorker::getErrno
  • GearmanWorker::register ?
  • PHP Manual
  • GearmanWorker
  • Get worker options

GearmanWorker::options

(PECL gearman >= 0.6.0)

GearmanWorker::options — Get worker options

说明

public GearmanWorker::options ( ) : int

Gets the options previously set for the worker.

参数

此函数没有参数。

返回值

The options currently set for the worker.

参见

  • GearmanWorker::setOptions() - Set worker options


Register a function with the job server

  • ? GearmanWorker::options
  • GearmanWorker::removeOptions ?
  • PHP Manual
  • GearmanWorker
  • Register a function with the job server

GearmanWorker::register

(PECL gearman >= 0.6.0)

GearmanWorker::register — Register a function with the job server

说明

public GearmanWorker::register ( string $function_name , int $timeout = ? ) : bool

Registers a function name with the job server with an optional timeout. The timeout specifies how many seconds the server will wait before marking a job as failed. If the timeout is set to zero, there is no timeout.

参数

function_name

The name of a function to register with the job server

timeout

An interval of time in seconds

返回值

A standard Gearman return value.

参见

  • GearmanWorker::unregister() - Unregister a function name with the job servers
  • GearmanWorker::unregisterAll() - Unregister all function names with the job servers


Remove worker options

  • ? GearmanWorker::register
  • GearmanWorker::returnCode ?
  • PHP Manual
  • GearmanWorker
  • Remove worker options

GearmanWorker::removeOptions

(PECL gearman >= 0.6.0)

GearmanWorker::removeOptions — Remove worker options

说明

public GearmanWorker::removeOptions ( int $option ) : bool

Removes (unsets) one or more worker options.

参数

option

The options to be removed (unset)

返回值

Always returns true.

参见

  • GearmanWorker::options() - Get worker options
  • GearmanWorker::setOptions() - Set worker options
  • GearmanWorker::addOptions() - Add worker options


Get last Gearman return code

  • ? GearmanWorker::removeOptions
  • GearmanWorker::setId ?
  • PHP Manual
  • GearmanWorker
  • Get last Gearman return code

GearmanWorker::returnCode

(PECL gearman >= 0.5.0)

GearmanWorker::returnCode — Get last Gearman return code

说明

public GearmanWorker::returnCode ( ) : int

Returns the last Gearman return code.

参数

此函数没有参数。

返回值

A valid Gearman return code.

参见

  • GearmanWorker::error() - Get the last error encountered
  • GearmanWorker::getErrno() - Get errno


Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers

  • ? GearmanWorker::returnCode
  • GearmanWorker::setOptions ?
  • PHP Manual
  • GearmanWorker
  • Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers

GearmanWorker::setId

(No version information available, might only be in Git)

GearmanWorker::setId — Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers

说明

public GearmanWorker::setId ( string $id ) : bool

Assigns the worker an identifier.

参数

id

A string identifier.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 GearmanWorker::setId() example

Set an identifier for a simple worker.

<?php
$worker= new GearmanWorker();
$worker->setId('test');
?>

以上例程的输出类似于：

Run the following command:
gearadmin --workers

Output:
30 ::3a3a:3361:3361:3a33%976303667 - : test


Set worker options

  • ? GearmanWorker::setId
  • GearmanWorker::setTimeout ?
  • PHP Manual
  • GearmanWorker
  • Set worker options

GearmanWorker::setOptions

(PECL gearman >= 0.5.0)

GearmanWorker::setOptions — Set worker options

说明

public GearmanWorker::setOptions ( int $option ) : bool

Sets one or more options to the supplied value.

参数

option

The options to be set

返回值

Always returns true.

参见

  • GearmanWorker::options() - Get worker options
  • GearmanWorker::addOptions() - Add worker options
  • GearmanWorker::removeOptions() - Remove worker options
  • GearmanClient::setOptions() - Set client options


Set socket I/O activity timeout

  • ? GearmanWorker::setOptions
  • GearmanWorker::timeout ?
  • PHP Manual
  • GearmanWorker
  • Set socket I/O activity timeout

GearmanWorker::setTimeout

(PECL gearman >= 0.6.0)

GearmanWorker::setTimeout — Set socket I/O activity timeout

说明

public GearmanWorker::setTimeout ( int $timeout ) : bool

Sets the interval of time to wait for socket I/O activity.

参数

timeout

An interval of time in milliseconds. A negative value indicates an infinite timeout.

返回值

Always returns true.

范例

Example #1 A simple worker with a 5 second timeout

<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server.
$gmworker->addFunction("reverse", "reverse_fn");

# Set the timeout to 5 seconds
$gmworker->setTimeout(5000);

echo "Waiting for job...\n";
while(@$gmworker->work() || $gmworker->returnCode() == GEARMAN_TIMEOUT)
{
  if ($gmworker->returnCode() == GEARMAN_TIMEOUT)
  {
    # Normally one would want to do something useful here ...
    echo "Timeout. Waiting for next job...\n";
    continue;
  }

  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

echo "Done\n";

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

Running the worker with no submitted jobs will generate output that looks like the following:

Starting
Waiting for job...
Timeout. Waiting for next job...
Timeout. Waiting for next job...
Timeout. Waiting for next job...

参见

  • GearmanWorker::timeout() - Get socket I/O activity timeout


Get socket I/O activity timeout

  • ? GearmanWorker::setTimeout
  • GearmanWorker::unregister ?
  • PHP Manual
  • GearmanWorker
  • Get socket I/O activity timeout

GearmanWorker::timeout

(PECL gearman >= 0.6.0)

GearmanWorker::timeout — Get socket I/O activity timeout

说明

public GearmanWorker::timeout ( ) : int

Returns the current time to wait, in milliseconds, for socket I/O activity.

参数

此函数没有参数。

返回值

A time period is milliseconds. A negative value indicates an infinite timeout.

参见

  • GearmanWorker::setTimeout() - Set socket I/O activity timeout


Unregister a function name with the job servers

  • ? GearmanWorker::timeout
  • GearmanWorker::unregisterAll ?
  • PHP Manual
  • GearmanWorker
  • Unregister a function name with the job servers

GearmanWorker::unregister

(PECL gearman >= 0.6.0)

GearmanWorker::unregister — Unregister a function name with the job servers

说明

public GearmanWorker::unregister ( string $function_name ) : bool

Unregisters a function name with the job servers ensuring that no more jobs (for that function) are sent to this worker.

参数

function_name

The name of a function to register with the job server

返回值

A standard Gearman return value.

参见

  • GearmanWorker::register() - Register a function with the job server
  • GearmanWorker::unregisterAll() - Unregister all function names with the job servers


Unregister all function names with the job servers

  • ? GearmanWorker::unregister
  • GearmanWorker::wait ?
  • PHP Manual
  • GearmanWorker
  • Unregister all function names with the job servers

GearmanWorker::unregisterAll

(PECL gearman >= 0.6.0)

GearmanWorker::unregisterAll — Unregister all function names with the job servers

说明

public GearmanWorker::unregisterAll ( ) : bool

Unregisters all previously registered functions, ensuring that no more jobs are sent to this worker.

参数

此函数没有参数。

返回值

A standard Gearman return value.

参见

  • GearmanWorker::register() - Register a function with the job server
  • GearmanWorker::unregister() - Unregister a function name with the job servers


Wait for activity from one of the job servers

  • ? GearmanWorker::unregisterAll
  • GearmanWorker::work ?
  • PHP Manual
  • GearmanWorker
  • Wait for activity from one of the job servers

GearmanWorker::wait

(PECL gearman >= 0.6.0)

GearmanWorker::wait — Wait for activity from one of the job servers

说明

public GearmanWorker::wait ( ) : bool

Causes the worker to wait for activity from one of the Gearman job servers when operating in non-blocking I/O mode. On failure, issues a E_WARNING with the last Gearman error encountered.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Running worker in non-blocking mode

<?php

echo "Starting\n";

# Create our worker object
$worker= new GearmanWorker();

# Make the worker non-blocking
$worker->addOptions(GEARMAN_WORKER_NON_BLOCKING);

# Add the default server (localhost, port 4730)
$worker->addServer();

# Add our reverse function
$worker->addFunction('reverse', 'reverse_fn');

# Try to grab a job
while (@$worker->work() ||
       $worker->returnCode() == GEARMAN_IO_WAIT ||
       $worker->returnCode() == GEARMAN_NO_JOBS)
{
  if ($worker->returnCode() == GEARMAN_SUCCESS)
    continue;

  echo "Waiting for next job...\n";
  if (!@$worker->wait())
  {
    if ($worker->returnCode() == GEARMAN_NO_ACTIVE_FDS)
    {
      # We are not connected to any servers, so wait a bit before
      # trying to reconnect.
      sleep(5);
      continue;
    }
    break;
  }
}

echo "Worker Error: " . $worker->error() . "\n";

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

参见

  • GearmanWorker::work() - Wait for and perform jobs


Wait for and perform jobs

  • ? GearmanWorker::wait
  • GearmanException ?
  • PHP Manual
  • GearmanWorker
  • Wait for and perform jobs

GearmanWorker::work

(PECL gearman >= 0.5.0)

GearmanWorker::work — Wait for and perform jobs

说明

public GearmanWorker::work ( ) : bool

Waits for a job to be assigned and then calls the appropriate callback function. Issues an E_WARNING with the last Gearman error if the return code is not one of GEARMAN_SUCCESS, GEARMAN_IO_WAIT, or GEARMAN_WORK_FAIL.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 GearmanWorker::work() example

<?php

# create the worker
$worker = new GearmanWorker();

# add the default job server (localhost)
$worker->addServer();

# add the reverse function
$worker->addFunction("reverse", "my_reverse_function");

# start te worker listening for job submissions
while ($worker->work());

function my_reverse_function($job)
{
  return strrev($job->workload());
}

?>

参见

  • GearmanWorker::addFunction() - Register and add callback function


The GearmanException class

(PECL gearman >= 0.5.0)

简介

类摘要

GearmanException extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Lightweight Directory Access Protocol

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Using the PHP LDAP calls
  • LDAP controls
  • 范例
    • Basic usage
    • LDAP Controls
  • LDAP 函数
    • ldap_8859_to_t61 — Translate 8859 characters to t61 characters
    • ldap_add_ext — Add entries to LDAP directory
    • ldap_add — Add entries to LDAP directory
    • ldap_bind_ext — Bind to LDAP directory
    • ldap_bind — 绑定 LDAP 目录
    • ldap_close — 别名 ldap_unbind
    • ldap_compare — Compare value of attribute found in entry specified with DN
    • ldap_connect — Connect to an LDAP server
    • ldap_control_paged_result_response — Retrieve the LDAP pagination cookie
    • ldap_control_paged_result — Send LDAP pagination control
    • ldap_count_entries — Count the number of entries in a search
    • ldap_delete_ext — Delete an entry from a directory
    • ldap_delete — Delete an entry from a directory
    • ldap_dn2ufn — Convert DN to User Friendly Naming format
    • ldap_err2str — Convert LDAP error number into string error message
    • ldap_errno — Return the LDAP error number of the last LDAP command
    • ldap_error — Return the LDAP error message of the last LDAP command
    • ldap_escape — Escape a string for use in an LDAP filter or DN
    • ldap_exop_passwd — PASSWD extended operation helper
    • ldap_exop_refresh — Refresh extended operation helper
    • ldap_exop_whoami — WHOAMI extended operation helper
    • ldap_exop — Performs an extended operation
    • ldap_explode_dn — Splits DN into its component parts
    • ldap_first_attribute — Return first attribute
    • ldap_first_entry — Return first result id
    • ldap_first_reference — Return first reference
    • ldap_free_result — Free result memory
    • ldap_get_attributes — Get attributes from a search result entry
    • ldap_get_dn — Get the DN of a result entry
    • ldap_get_entries — Get all result entries
    • ldap_get_option — Get the current value for given option
    • ldap_get_values_len — Get all binary values from a result entry
    • ldap_get_values — Get all values from a result entry
    • ldap_list — Single-level search
    • ldap_mod_add_ext — Add attribute values to current attributes
    • ldap_mod_add — Add attribute values to current attributes
    • ldap_mod_del_ext — Delete attribute values from current attributes
    • ldap_mod_del — Delete attribute values from current attributes
    • ldap_mod_replace_ext — Replace attribute values with new ones
    • ldap_mod_replace — Replace attribute values with new ones
    • ldap_modify_batch — Batch and execute modifications on an LDAP entry
    • ldap_modify — 别名 ldap_mod_replace
    • ldap_next_attribute — Get the next attribute in result
    • ldap_next_entry — Get next result entry
    • ldap_next_reference — Get next reference
    • ldap_parse_exop — Parse result object from an LDAP extended operation
    • ldap_parse_reference — Extract information from reference entry
    • ldap_parse_result — Extract information from result
    • ldap_read — Read an entry
    • ldap_rename_ext — Modify the name of an entry
    • ldap_rename — Modify the name of an entry
    • ldap_sasl_bind — Bind to LDAP directory using SASL
    • ldap_search — Search LDAP tree
    • ldap_set_option — Set the value of the given option
    • ldap_set_rebind_proc — Set a callback function to do re-binds on referral chasing
    • ldap_sort — Sort LDAP result entries on the client side
    • ldap_start_tls — Start TLS
    • ldap_t61_to_8859 — Translate t61 characters to 8859 characters
    • ldap_unbind — Unbind from LDAP directory


简介

LDAP is the Lightweight Directory Access Protocol, and is a protocol used to access "Directory Servers". The Directory is a special kind of database that holds information in a tree structure.

The concept is similar to your hard disk directory structure, except that in this context, the root directory is "The world" and the first level subdirectories are "countries". Lower levels of the directory structure contain entries for companies, organisations or places, while yet lower still we find directory entries for people, and perhaps equipment or documents.

To refer to a file in a subdirectory on your hard disk, you might use something like:

   /usr/local/myapp/docs

The forwards slash marks each division in the reference, and the sequence is read from left to right.

The equivalent to the fully qualified file reference in LDAP is the "distinguished name", referred to simply as "dn". An example dn might be:

   cn=John Smith,ou=Accounts,o=My Company,c=US

The comma marks each division in the reference, and the sequence is read from right to left. You would read this dn as:

   country = US
   organization = My Company
   organizationalUnit = Accounts
   commonName = John Smith

In the same way as there are no hard rules about how you organise the directory structure of a hard disk, a directory server manager can set up any structure that is meaningful for the purpose. However, there are some conventions that are used. The message is that you can not write code to access a directory server unless you know something about its structure, any more than you can use a database without some knowledge of what is available.

Lots of information about LDAP can be found at

  • » Mozilla

  • » OpenLDAP Project

  • Internet Engineering Taskforce RFCs » 4510 through » 4519.

The Netscape SDK contains a helpful » Programmer's Guide in HTML format.


需求

You will need to get and compile LDAP client libraries from either » OpenLDAP or » Bind9.net in order to compile PHP with LDAP support. For PHP 5.6 or newer you will need OpenLDAP 2.4 or newer.


安装

LDAP support in PHP is not enabled by default. You will need to use the --with-ldap[=DIR] configuration option when compiling PHP to enable LDAP support. DIR is the LDAP base install directory. To enable SASL support, be sure --with-ldap-sasl[=DIR] is used, and that sasl.h exists on the system.

Note: Note to Win32 Users

为了使此扩展生效， DLL 文件必须能在 Windows 系统的 PATH 指示的路径下找到。如何操作的信息，请参见题为"如何在 Windows 中将 PHP 目录加到 PATH 中"的FAQ。虽然将 DLL 文件从 PHP 文件夹复制到 Windows 系统目录也行，但不建议这样做。 此扩展需要下列文件在 PATH 路径中： libeay32.dll and ssleay32.dll, or, as of OpenSSL 1.1 libcrypto-*.dll and libssl-*.dll

In order to use Oracle LDAP libraries, proper Oracle environment has to be set.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

LDAP configuration options
名字 | 默认 | 可修改范围 | 更新日志
ldap.max_links | "-1" | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

ldap.max_links int

The maximum number of LDAP connections per process.


资源类型

Most LDAP functions operate on or return resources (e.g. ldap_connect() returns a positive LDAP link identifier required by most LDAP functions).


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

LDAP_DEREF_NEVER (int)
Alias dereferencing rule - Never.
LDAP_DEREF_SEARCHING (int)
Alias dereferencing rule - Searching.
LDAP_DEREF_FINDING (int)
Alias dereferencing rule - Finding.
LDAP_DEREF_ALWAYS (int)
Alias dereferencing rule - Always.
LDAP_OPT_DEREF (int)
Specifies alternative rules for following aliases at the server.
LDAP_OPT_SIZELIMIT (int)

Specifies the maximum number of entries that can be returned on a search operation.

Note: The actual size limit for operations is also bounded by the server's configured maximum number of return entries. The lesser of these two settings is the actual size limit.

LDAP_OPT_TIMELIMIT (int)
Specifies the number of seconds to wait for search results.

Note: The actual time limit for operations is also bounded by the server's configured maximum time. The lesser of these two settings is the actual time limit.

LDAP_OPT_NETWORK_TIMEOUT (int)
Option for ldap_set_option() to allow setting network timeout. (Available as of PHP 5.3.0)
LDAP_OPT_PROTOCOL_VERSION (int)
Specifies the LDAP protocol to be used (V2 or V3).
LDAP_OPT_ERROR_NUMBER (int)
Latest session error number.
LDAP_OPT_REFERRALS (int)
Specifies whether to automatically follow referrals returned by the LDAP server.
LDAP_OPT_RESTART (int)
Determines whether or not the connection should be implicitly restarted.
LDAP_OPT_HOST_NAME (int)
Sets/gets a space-separated of hosts when trying to connect.
LDAP_OPT_ERROR_STRING (int)
Alias of LDAP_OPT_DIAGNOSTIC_MESSAGE.
LDAP_OPT_DIAGNOSTIC_MESSAGE (int)
Gets the latest session error message.
LDAP_OPT_MATCHED_DN (int)
Sets/gets the matched DN associated with the connection.
LDAP_OPT_SERVER_CONTROLS (int)
Specifies a default list of server controls to be sent with each request.
LDAP_OPT_CLIENT_CONTROLS (int)
Specifies a default list of client controls to be processed with each request.
LDAP_OPT_DEBUG_LEVEL (int)
Specifies a bitwise level for debug traces.
LDAP_OPT_X_KEEPALIVE_IDLE (int)
Specifies the number of seconds a connection needs to remain idle before TCP starts sending keepalive probes.
LDAP_OPT_X_KEEPALIVE_PROBES (int)
Specifies the maximum number of keepalive probes TCP should send before dropping the connection.
LDAP_OPT_X_KEEPALIVE_INTERVAL (int)
Specifies the interval in seconds between individual keepalive probes.
LDAP_OPT_X_TLS_CACERTDIR (string)
Specifies the path of the directory containing CA certificates.
LDAP_OPT_X_TLS_CACERTFILE (string)
Specifies the full-path of the CA certificate file.
LDAP_OPT_X_TLS_CERTFILE (string)
Specifies the full-path of the certificate file.
LDAP_OPT_X_TLS_CIPHER_SUITE (string)
Specifies the allowed cipher suite.
LDAP_OPT_X_TLS_CRLCHECK (int)
Specifies the CRL evaluation strategy. This must be one of: LDAP_OPT_X_TLS_CRL_NONE,LDAP_OPT_X_TLS_CRL_PEER, LDAP_OPT_X_TLS_CRL_ALL.

Note: This option is only valid for OpenSSL.

LDAP_OPT_X_TLS_CRLFILE (string)
Specifies the full-path of the CRL file.

Note: This option is only valid for GnuTLS.

LDAP_OPT_X_TLS_DHFILE (string)
Specifies the full-path of the file containing the parameters for Diffie-Hellman ephemeral key exchange.

Note: This option is ignored by GnuTLS and Mozilla NSS.

LDAP_OPT_X_TLS_KEYFILE (string)
Specifies the full-path of the certificate key file.
LDAP_OPT_X_TLS_PROTOCOL_MIN (int)
Specifies the minimum protocol version. This can be one of: LDAP_OPT_X_TLS_PROTOCOL_SSL2,LDAP_OPT_X_TLS_PROTOCOL_SSL3, LDAP_OPT_X_TLS_PROTOCOL_TLS1_0, LDAP_OPT_X_TLS_PROTOCOL_TLS1_1, LDAP_OPT_X_TLS_PROTOCOL_TLS1_2
LDAP_OPT_X_TLS_RANDOM_FILE (string)
Sets/gets the random file when one of the system default ones are not available.
LDAP_OPT_X_TLS_REQUIRE_CERT (int)
Specifies the certificate checking checking strategy. This must be one of: LDAP_OPT_X_TLS_NEVER,LDAP_OPT_X_TLS_HARD, LDAP_OPT_X_TLS_DEMAND, LDAP_OPT_X_TLS_ALLOW, LDAP_OPT_X_TLS_TRY. (Available as of PHP 7.0.0)
GSLC_SSL_NO_AUTH (int)
SSL Authentication Mode - No authentication required. (Only for Oracle LDAP)
GSLC_SSL_ONEWAY_AUTH (int)
SSL Authentication Mode - Only server authentication required. (Only for Oracle LDAP)
GSLC_SSL_TWOWAY_AUTH (int)
SSL Authentication Mode - Both server and client authentication required. (Only for Oracle LDAP)
LDAP_EXOP_START_TLS (string)
Extended Operation constant - Start TLS (» RFC 4511).
LDAP_EXOP_MODIFY_PASSWD (string)
Extended Operation constant - Modify password (» RFC 3062).
LDAP_EXOP_REFRESH (string)
Extended Operation Constant - Refresh (» RFC 2589).
LDAP_EXOP_WHO_AM_I (string)
Extended Operation Constant - WHOAMI (» RFC 4532).
LDAP_EXOP_TURN (string)
Extended Operation Constant - Turn (» RFC 4531).
LDAP_CONTROL_MANAGEDSAIT (string)
Control Constant - Manage DSA IT (» RFC 3296). Available as of PHP 7.3.0.
LDAP_CONTROL_PROXY_AUTHZ (string)
Control Constant - Proxied Authorization (» RFC 4370). Available as of PHP 7.3.0.
LDAP_CONTROL_SUBENTRIES (string)
Control Constant - Subentries (» RFC 3672). Available as of PHP 7.3.0.
LDAP_CONTROL_VALUESRETURNFILTER (string)
Control Constant - Filter returned values (» RFC 3876). Available as of PHP 7.3.0.
LDAP_CONTROL_ASSERT (string)
Control Constant - Assertion (» RFC 4528). Available as of PHP 7.3.0.
LDAP_CONTROL_PRE_READ (string)
Control Constant - Pre read (» RFC 4527). Available as of PHP 7.3.0.
LDAP_CONTROL_POST_READ (string)
Control Constant - Post read (» RFC 4527). Available as of PHP 7.3.0.
LDAP_CONTROL_SORTREQUEST (string)
Control Constant - Sort request (» RFC 2891). Available as of PHP 7.3.0.
LDAP_CONTROL_SORTRESPONSE (string)
Control Constant - Sort response (» RFC 2891). Available as of PHP 7.3.0.
LDAP_CONTROL_PAGEDRESULTS (string)
Control Constant - Paged results (» RFC 2696). Available as of PHP 7.3.0.
LDAP_CONTROL_AUTHZID_REQUEST (string)
Control Constant - Authorization Identity Request (» RFC 3829). Available as of PHP 7.3.0.
LDAP_CONTROL_AUTHZID_RESPONSE (string)
Control Constant - Authorization Identity Response (» RFC 3829). Available as of PHP 7.3.0.
LDAP_CONTROL_SYNC (string)
Control Constant - Content Synchronization Operation (» RFC 4533). Available as of PHP 7.3.0.
LDAP_CONTROL_SYNC_STATE (string)
Control Constant - Content Synchronization Operation State (» RFC 4533). Available as of PHP 7.3.0.
LDAP_CONTROL_SYNC_DONE (string)
Control Constant - Content Synchronization Operation Done (» RFC 4533). Available as of PHP 7.3.0.
LDAP_CONTROL_DONTUSECOPY (string)
Control Constant - Don't Use Copy (» RFC 6171). Available as of PHP 7.3.0.
LDAP_CONTROL_PASSWORDPOLICYREQUEST (string)
Control Constant - Password Policy Request. Available as of PHP 7.3.0.
LDAP_CONTROL_PASSWORDPOLICYRESPONSE (string)
Control Constant - Password Policy Response. Available as of PHP 7.3.0.
LDAP_CONTROL_X_INCREMENTAL_VALUES (string)
Control Constant - Active Directory Incremental Values. Available as of PHP 7.3.0.
LDAP_CONTROL_X_DOMAIN_SCOPE (string)
Control Constant - Active Directory Domain Scope. Available as of PHP 7.3.0.
LDAP_CONTROL_X_PERMISSIVE_MODIFY (string)
Control Constant - Active Directory Permissive Modify. Available as of PHP 7.3.0.
LDAP_CONTROL_X_SEARCH_OPTIONS (string)
Control Constant - Active Directory Search Options. Available as of PHP 7.3.0.
LDAP_CONTROL_X_TREE_DELETE (string)
Control Constant - Active Directory Tree Delete. Available as of PHP 7.3.0.
LDAP_CONTROL_X_EXTENDED_DN (string)
Control Constant - Active Directory Extended DN. Available as of PHP 7.3.0.
LDAP_CONTROL_VLVREQUEST (string)
Control Constant - Virtual List View Request. Available as of PHP 7.3.0.
LDAP_CONTROL_VLVRESPONSE (string)
Control Constant - Virtual List View Response. Available as of PHP 7.3.0.


Using the PHP LDAP calls

Before you can use the LDAP calls you will need to know...

  • The name or address of the directory server you will use

  • The "base dn" of the server (the part of the world directory that is held on this server, which could be "o=My Company,c=US")

  • Whether you need a password to access the server (many servers will provide read access for an "anonymous bind" but require a password for anything else)

The typical sequence of LDAP calls you will make in an application will follow this pattern:

  ldap_connect()    // establish connection to server
     |
  ldap_bind()       // anonymous or authenticated "login"
     |
  do something like search or update the directory
  and display the results
     |
  ldap_close()      // "logout"


LDAP controls

Controls are special objects which may be sent alongside an LDAP request to alter LDAP server behavior while performing the request. There may also be controls sent by the server alongside the response to provide more information, usually to answer a control object from the request.

Note:

Not all controls are supported by all LDAP servers. To know which controls are supported by a server, you need to query the root DSE by reading an empty dn with the filter (objectClass=*).

Example #1 Testing support for paged result control

<?php

// $ds is a valid link identifier for a directory server

$result = ldap_read($ds, '', '(objectClass=*)', ['supportedControl']);
if (!in_array(LDAP_CONTROL_PAGEDRESULTS, ldap_get_entries($ds, $result)[0]['supportedcontrol'])) {
  die("This server does not support paged result control");
}

?>

As of PHP 7.3, you can send controls with your request in all request functions using the serverctrls parameter. When a ext version of a function exists, you should use it if you want to get access to the full response object and be able to parse response controls from it using ldap_parse_result().

serverctrls must be an array containing an array for each control to send, containing the following keys:

oid (string)
The OID of the control. You should use constants starting with LDAP_CONTROL_ for this. See LDAP Constants.
iscritical (bool)
If a control is noted as critical, the request will fail if the control is not supported by the server, or if it fails to be applied. Note that some controls should always be marked as critical as noted in the RFC introducing them. Defaults to false.
value (mixed)
If applicable, the value of the control. Read below for more information.

Most control values are sent to the server BER-encoded. You may either BER-encode the value yourself, or you can instead pass an array with the correct keys so that the encoding is done for you. Supported controls to be passed as an array are:

  • LDAP_CONTROL_PAGEDRESULTS Expected keys are [size] and [cookie]

  • LDAP_CONTROL_ASSERT Expected key is filter

  • LDAP_CONTROL_VALUESRETURNFILTER Expected key is filter

  • LDAP_CONTROL_PRE_READ Expected key is attrs

  • LDAP_CONTROL_POST_READ Expected key is attrs

  • LDAP_CONTROL_SORTREQUEST Expects an array of arrays with keys attr, [oid], [reverse].

  • LDAP_CONTROL_VLVREQUEST Expected keys are before, after, attrvalue|(offset, count), [context]

The following controls do not need any value:

  • LDAP_CONTROL_PASSWORDPOLICYREQUEST

  • LDAP_CONTROL_MANAGEDSAIT

  • LDAP_CONTROL_DONTUSECOPY

The control LDAP_CONTROL_PROXY_AUTHZ is a special case as its value is not expected to be BER-encoded, so you can directly use a string for its value.

When controls are parsed by ldap_parse_result(), values are turned into an array if supported. This is supported for:

  • LDAP_CONTROL_PASSWORDPOLICYRESPONSE Keys are expire, grace, [error]

  • LDAP_CONTROL_PAGEDRESULTS Keys are size, cookie

  • LDAP_CONTROL_PRE_READ Keys are dn and LDAP attributes names

  • LDAP_CONTROL_POST_READ Keys are dn and LDAP attributes names

  • LDAP_CONTROL_SORTRESPONSE Keys are errcode, [attribute]

  • LDAP_CONTROL_VLVRESPONSE Keys are target, count, errcode, context


  • ? LDAP controls
  • Basic usage ?
  • PHP Manual
  • LDAP
  • 范例

范例

Table of Contents

  • Basic usage
  • LDAP Controls


Basic usage

Retrieve information for all entries where the surname starts with "S" from a directory server, displaying an extract with name and email address.

Example #1 LDAP search example

<?php
// basic sequence with LDAP is connect, bind, search, interpret search
// result, close connection

echo "<h3>LDAP query test</h3>";
echo "Connecting ...";
$ds=ldap_connect("localhost");  // must be a valid LDAP server!
echo "connect result is " . $ds . "<br />";

if ($ds) {
    echo "Binding ...";
    $r=ldap_bind($ds);     // this is an "anonymous" bind, typically
                           // read-only access
    echo "Bind result is " . $r . "<br />";

    echo "Searching for (sn=S*) ...";
    // Search surname entry
    $sr=ldap_search($ds, "o=My Company, c=US", "sn=S*");
    echo "Search result is " . $sr . "<br />";

    echo "Number of entries returned is " . ldap_count_entries($ds, $sr) . "<br />";

    echo "Getting entries ...<p>";
    $info = ldap_get_entries($ds, $sr);
    echo "Data for " . $info["count"] . " items returned:<p>";

    for ($i=0; $i<$info["count"]; $i++) {
        echo "dn is: " . $info[$i]["dn"] . "<br />";
        echo "first cn entry is: " . $info[$i]["cn"][0] . "<br />";
        echo "first email entry is: " . $info[$i]["mail"][0] . "<br /><hr />";
    }

    echo "Closing connection";
    ldap_close($ds);

} else {
    echo "<h4>Unable to connect to LDAP server</h4>";
}
?>


LDAP Controls

Here are some examples of using LDAP Controls with PHP >= 7.3.0.

Example #1 Bind with ppolicy information

<?php

$user   = 'cn=admin,dc=example,dc=com';
$passwd = 'adminpassword';

$ds = ldap_connect('ldap://localhost');

if ($ds) {
    $r = ldap_bind_ext($ds, $user, $passwd, [['oid' => LDAP_CONTROL_PASSWORDPOLICYREQUEST]]);

    if (ldap_parse_result($ds, $r, $errcode, $matcheddn, $errmsg, $referrals, $ctrls)) {
        if ($errcode != 0) {
            die("Error: $errmsg ($errcode)");
        }
        if (isset($ctrls[LDAP_CONTROL_PASSWORDPOLICYRESPONSE])) {
            $value = $ctrls[LDAP_CONTROL_PASSWORDPOLICYRESPONSE]['value'];
            echo "Expires in: ".$value['expire']." seconds\n";
            echo "Number of auth left: ".$value['grace']."\n";
            if (isset($value['error'])) {
                echo "Ppolicy error code: ".$value['error'];
            }
        }
    }
} else {
    die("Unable to connect to LDAP server");
}
?>

Example #2 Modify description only if it's not empty

<?php
// $link is an LDAP connection

$result = ldap_mod_replace_ext(
    $link,
    'o=test,dc=example,dc=com',
    ['description' => 'New description'],
    [
        [
            'oid'         => LDAP_CONTROL_ASSERT,
            'iscritical'  => TRUE,
            'value'       => ['filter' => '(!(description=*))']
        ]
    ]
);

// Then use ldap_parse_result
?>

Example #3 Read some values before deletion

<?php
// $link is an LDAP connection

$result = ldap_delete_ext(
    $link,
    'o=test,dc=example,dc=com',
    [
        [
            'oid'         => LDAP_CONTROL_PRE_READ,
            'iscritical'  => TRUE,
            'value'       => ['attrs' => ['o', 'description']]
        ]
    ]
);

// Then use ldap_parse_result
?>

Example #4 Delete a reference

<?php
// $link is an LDAP connection

// Without the control it would delete the referenced node
// Make sure to set the control as critical to avoid that
$result = ldap_delete_ext(
    $link,
    'cn=reference,dc=example,dc=com',
    [['oid' => LDAP_CONTROL_MANAGEDSAIT, 'iscritical' => TRUE]]
);

// Then use ldap_parse_result
?>

Example #5 Use pagination for a search

<?php
// $link is an LDAP connection

$cookie = '';

do {
    $result = ldap_search(
        $link, 'dc=example,dc=base', '(cn=*)', ['cn'], 0, 0, 0, LDAP_DEREF_NEVER,
        [['oid' => LDAP_CONTROL_PAGEDRESULTS, 'value' => ['size' => 2, 'cookie' => $cookie]]]
    );
    ldap_parse_result($link, $result, $errcode , $matcheddn , $errmsg , $referrals, $controls);
    // To keep the example short errors are not tested
    $entries = ldap_get_entries($link, $result);
    foreach ($entries as $entry) {
        echo "cn: ".$entry['cn'][0]."\n";
    }
    if (isset($controls[LDAP_CONTROL_PAGEDRESULTS]['value']['cookie'])) {
        // You need to pass the cookie from the last call to the next one
        $cookie = $controls[LDAP_CONTROL_PAGEDRESULTS]['value']['cookie'];
    } else {
        $cookie = '';
    }
    // Empty cookie means last page
} while (!empty($cookie));
?>


LDAP 函数

Table of Contents

  • ldap_8859_to_t61 — Translate 8859 characters to t61 characters
  • ldap_add_ext — Add entries to LDAP directory
  • ldap_add — Add entries to LDAP directory
  • ldap_bind_ext — Bind to LDAP directory
  • ldap_bind — 绑定 LDAP 目录
  • ldap_close — 别名 ldap_unbind
  • ldap_compare — Compare value of attribute found in entry specified with DN
  • ldap_connect — Connect to an LDAP server
  • ldap_control_paged_result_response — Retrieve the LDAP pagination cookie
  • ldap_control_paged_result — Send LDAP pagination control
  • ldap_count_entries — Count the number of entries in a search
  • ldap_delete_ext — Delete an entry from a directory
  • ldap_delete — Delete an entry from a directory
  • ldap_dn2ufn — Convert DN to User Friendly Naming format
  • ldap_err2str — Convert LDAP error number into string error message
  • ldap_errno — Return the LDAP error number of the last LDAP command
  • ldap_error — Return the LDAP error message of the last LDAP command
  • ldap_escape — Escape a string for use in an LDAP filter or DN
  • ldap_exop_passwd — PASSWD extended operation helper
  • ldap_exop_refresh — Refresh extended operation helper
  • ldap_exop_whoami — WHOAMI extended operation helper
  • ldap_exop — Performs an extended operation
  • ldap_explode_dn — Splits DN into its component parts
  • ldap_first_attribute — Return first attribute
  • ldap_first_entry — Return first result id
  • ldap_first_reference — Return first reference
  • ldap_free_result — Free result memory
  • ldap_get_attributes — Get attributes from a search result entry
  • ldap_get_dn — Get the DN of a result entry
  • ldap_get_entries — Get all result entries
  • ldap_get_option — Get the current value for given option
  • ldap_get_values_len — Get all binary values from a result entry
  • ldap_get_values — Get all values from a result entry
  • ldap_list — Single-level search
  • ldap_mod_add_ext — Add attribute values to current attributes
  • ldap_mod_add — Add attribute values to current attributes
  • ldap_mod_del_ext — Delete attribute values from current attributes
  • ldap_mod_del — Delete attribute values from current attributes
  • ldap_mod_replace_ext — Replace attribute values with new ones
  • ldap_mod_replace — Replace attribute values with new ones
  • ldap_modify_batch — Batch and execute modifications on an LDAP entry
  • ldap_modify — 别名 ldap_mod_replace
  • ldap_next_attribute — Get the next attribute in result
  • ldap_next_entry — Get next result entry
  • ldap_next_reference — Get next reference
  • ldap_parse_exop — Parse result object from an LDAP extended operation
  • ldap_parse_reference — Extract information from reference entry
  • ldap_parse_result — Extract information from result
  • ldap_read — Read an entry
  • ldap_rename_ext — Modify the name of an entry
  • ldap_rename — Modify the name of an entry
  • ldap_sasl_bind — Bind to LDAP directory using SASL
  • ldap_search — Search LDAP tree
  • ldap_set_option — Set the value of the given option
  • ldap_set_rebind_proc — Set a callback function to do re-binds on referral chasing
  • ldap_sort — Sort LDAP result entries on the client side
  • ldap_start_tls — Start TLS
  • ldap_t61_to_8859 — Translate t61 characters to 8859 characters
  • ldap_unbind — Unbind from LDAP directory


Translate 8859 characters to t61 characters

  • ? LDAP 函数
  • ldap_add_ext ?
  • PHP Manual
  • LDAP 函数
  • Translate 8859 characters to t61 characters

ldap_8859_to_t61

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

ldap_8859_to_t61 — Translate 8859 characters to t61 characters

说明

ldap_8859_to_t61 ( string $value ) : string|false

Translate ISO-8859 characters to t61 characters.

This function is useful if you have to talk to a legacy LDAPv2 server.

参数

value

The text to be translated.

返回值

Return the t61 translation of value, 或者在失败时返回 false.

参见

  • ldap_t61_to_8859() - Translate t61 characters to 8859 characters


Add entries to LDAP directory

  • ? ldap_8859_to_t61
  • ldap_add ?
  • PHP Manual
  • LDAP 函数
  • Add entries to LDAP directory

ldap_add_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_add_ext — Add entries to LDAP directory

说明

ldap_add_ext ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : resource|false

Does the same thing as ldap_add() but returns the LDAP result resource to be parsed with ldap_parse_result().

参数

See ldap_add()

返回值

Returns an LDAP result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].

注释

Note: 此函数可安全用于二进制对象。

参见

  • ldap_add() - Add entries to LDAP directory
  • ldap_parse_result() - Extract information from result


Add entries to LDAP directory

  • ? ldap_add_ext
  • ldap_bind_ext ?
  • PHP Manual
  • LDAP 函数
  • Add entries to LDAP directory

ldap_add

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_add — Add entries to LDAP directory

说明

ldap_add ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : bool

Add entries in the LDAP directory.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

An array that specifies the information about the entry. The values in the entries are indexed by individual attributes. In case of multiple values for an attribute, they are indexed using integers starting with 0.

<?php
$entry["attribute1"] = "value";
$entry["attribute2"][0] = "value1";
$entry["attribute2"][1] = "value2";
?>

controls

Array of LDAP Controls to send with the request.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

范例

Example #1 Complete example with authenticated bind

<?php
$ds = ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {
    // bind with appropriate dn to give update access
    $r = ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");

    // prepare data
    $info["cn"] = "John Jones";
    $info["sn"] = "Jones";
    $info["objectclass"] = "person";

    // add data to directory
    $r = ldap_add($ds, "cn=John Jones, o=My Company, c=US", $info);

    ldap_close($ds);
} else {
    echo "Unable to connect to LDAP server";
}
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • ldap_add_ext() - Add entries to LDAP directory
  • ldap_delete() - Delete an entry from a directory


Bind to LDAP directory

  • ? ldap_add
  • ldap_bind ?
  • PHP Manual
  • LDAP 函数
  • Bind to LDAP directory

ldap_bind_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_bind_ext — Bind to LDAP directory

说明

ldap_bind_ext ( resource $ldap , string|null $dn = null , string|null $password = null , array|null $controls = null ) : resource|false

Does the same thing as ldap_bind() but returns the LDAP result resource to be parsed with ldap_parse_result().

参数

See ldap_bind()

返回值

Returns an LDAP result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].

参见

  • ldap_bind() - 绑定 LDAP 目录
  • ldap_parse_result() - Extract information from result


绑定 LDAP 目录

  • ? ldap_bind_ext
  • ldap_close ?
  • PHP Manual
  • LDAP 函数
  • 绑定 LDAP 目录

ldap_bind

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_bind — 绑定 LDAP 目录

说明

ldap_bind ( resource $link_identifier , string $bind_rdn = null , string $bind_password = null ) : bool

使用指定的 RDN 和密码绑定到 LDAP 目录。

参数

link_identifier

通过 ldap_connect() 连接之后返回的 LDAP 连接标识。

bind_rdn

bind_password

如果没有指定 bind_rdn 和 bind_password ，将会以匿名身份绑定。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 使用 LDAP Bind

<?php

// using ldap bind
$ldaprdn  = 'uname';     // ldap rdn or dn
$ldappass = 'password';  // associated password

// connect to ldap server
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // binding to ldap server
    $ldapbind = ldap_bind($ldapconn, $ldaprdn, $ldappass);

    // verify binding
    if ($ldapbind) {
        echo "LDAP bind successful...";
    } else {
        echo "LDAP bind failed...";
    }

}

?>

Example #2 Using LDAP Bind Anonymously

<?php

//using ldap bind anonymously

// connect to ldap server
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // binding anonymously
    $ldapbind = ldap_bind($ldapconn);

    if ($ldapbind) {
        echo "LDAP bind anonymous successful...";
    } else {
        echo "LDAP bind anonymous failed...";
    }

}

?>

参见

  • ldap_unbind() - Unbind from LDAP directory


别名 ldap_unbind

  • ? ldap_bind
  • ldap_compare ?
  • PHP Manual
  • LDAP 函数
  • 别名 ldap_unbind

ldap_close

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_close — 别名 ldap_unbind()

说明

此函数是该函数的别名： ldap_unbind().


Compare value of attribute found in entry specified with DN

  • ? ldap_close
  • ldap_connect ?
  • PHP Manual
  • LDAP 函数
  • Compare value of attribute found in entry specified with DN

ldap_compare

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

ldap_compare — Compare value of attribute found in entry specified with DN

说明

ldap_compare ( resource $ldap , string $dn , string $attribute , string $value , array|null $controls = null ) : bool|int

Compare value of attribute with value of same attribute in an LDAP directory entry.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

attribute

The attribute name.

value

The compared value.

controls

Array of LDAP Controls to send with the request.

返回值

Returns true if value matches otherwise returns false. Returns -1 on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

范例

The following example demonstrates how to check whether or not given password matches the one defined in DN specified entry.

Example #1 Complete example of password check

<?php

$ds=ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {

    // bind
    if (ldap_bind($ds)) {

        // prepare data
        $dn = "cn=Matti Meikku, ou=My Unit, o=My Company, c=FI";
        $value = "secretpassword";
        $attr = "password";

        // compare value
        $r=ldap_compare($ds, $dn, $attr, $value);

        if ($r === -1) {
            echo "Error: " . ldap_error($ds);
        } elseif ($r === true) {
            echo "Password correct.";
        } elseif ($r === false) {
            echo "Wrong guess! Password incorrect.";
        }

    } else {
        echo "Unable to bind to LDAP server.";
    }

    ldap_close($ds);

} else {
    echo "Unable to connect to LDAP server.";
}
?>

注释

Warning

ldap_compare() can NOT be used to compare BINARY values!


Connect to an LDAP server

  • ? ldap_compare
  • ldap_control_paged_result_response ?
  • PHP Manual
  • LDAP 函数
  • Connect to an LDAP server

ldap_connect

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_connect — Connect to an LDAP server

说明

ldap_connect ( string|null $uri = null ) : resource|false
Warning

The following signature is still supported for backwards compatibility (except for using named parameters), but is considered deprecated and should not be used anymore!

ldap_connect ( string $host = null , int $port = 389 ) : resource|false

Creates an LDAP link identifier and checks whether the given uri is plausible.

Note: This function does not open a connection. It checks whether the given parameters are plausible and can be used to open a connection as soon as one is needed.

参数

uri

A full LDAP URI of the form ldap://hostname:port or ldaps://hostname:port for SSL encryption.

You can also provide multiple LDAP-URIs separated by a space as one string

Note that hostname:port is not a supported LDAP URI as the schema is missing.

host

The hostname to connect to.

port

The port to connect to.

返回值

Returns a positive LDAP link identifier when the provided LDAP URI seems plausible. It's a syntactic check of the provided parameter but the server(s) will not be contacted! If the syntactic check fails it returns false. ldap_connect() will otherwise return a resource as it does not actually connect but just initializes the connecting parameters. The actual connect happens with the next calls to ldap_* funcs, usually with ldap_bind().

If no argument is specified then the link identifier of the already opened link will be returned.

范例

Example #1 Example of connecting to LDAP server.

<?php

// LDAP variables
$ldapuri = "ldap://ldap.example.com:389";  // your ldap-uri

// Connecting to LDAP
$ldapconn = ldap_connect($ldapuri)
          or die("That LDAP-URI was not parseable");

?>

Example #2 Example of connecting securely to LDAP server.

<?php

// make sure your host is the correct one
// that you issued your secure certificate to
$ldaphost = "ldaps://ldap.example.com/";

// Connecting to LDAP
$ldapconn = ldap_connect($ldaphost)
          or die("That LDAP-URI was not parseable");

?>

参见

  • ldap_bind() - 绑定 LDAP 目录


Retrieve the LDAP pagination cookie

  • ? ldap_connect
  • ldap_control_paged_result ?
  • PHP Manual
  • LDAP 函数
  • Retrieve the LDAP pagination cookie

ldap_control_paged_result_response

(PHP 5 >= 5.4.0, PHP 7)

ldap_control_paged_result_response — Retrieve the LDAP pagination cookie

Warning

This function has been DEPRECATED as of PHP 7.4.0, and REMOVED as of PHP 8.0.0. Instead the controls parameter of ldap_search() should be used. See also LDAP Controls for details.

说明

ldap_control_paged_result_response ( resource $link , resource $result , string &$cookie = ? , int &$estimated = ? ) : bool

Retrieve the pagination information send by the server.

参数

link

An LDAP link identifier, returned by ldap_connect().

result

cookie

An opaque structure sent by the server.

estimated

The estimated number of entries to retrieve.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.4.0 | This function has been deprecated.

参见

  • ldap_control_paged_result() - Send LDAP pagination control
  • » RFC2696 : LDAP Control Extension for Simple Paged Results Manipulation


Send LDAP pagination control

  • ? ldap_control_paged_result_response
  • ldap_count_entries ?
  • PHP Manual
  • LDAP 函数
  • Send LDAP pagination control

ldap_control_paged_result

(PHP 5 >= 5.4.0, PHP 7)

ldap_control_paged_result — Send LDAP pagination control

Warning

This function has been DEPRECATED as of PHP 7.4.0, and REMOVED as of PHP 8.0.0. Instead the controls parameter of ldap_search() should be used. See also LDAP Controls for details.

说明

ldap_control_paged_result ( resource $link , int $pagesize , bool $iscritical = false , string $cookie = "" ) : bool

Enable LDAP pagination by sending the pagination control (page size, cookie...).

参数

link

An LDAP link identifier, returned by ldap_connect().

pagesize

The number of entries by page.

iscritical

Indicates whether the pagination is critical or not. If true and if the server doesn't support pagination, the search will return no result.

cookie

An opaque structure sent by the server (ldap_control_paged_result_response()).

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.4.0 | This function has been deprecated.

范例

The example below show the retrieval of the first page of a search paginated with one entry by page.

Example #1 LDAP pagination

<?php
     // $ds is a valid link identifier (see ldap_connect)
     ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3);

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     // enable pagination with a page size of 1.
     ldap_control_paged_result($ds, 1);

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     $info = ldap_get_entries($ds, $sr);

     echo $info['count'] . ' entries returned' . PHP_EOL;

The example below show the retrieval of all the result paginated with 100 entries by page.

Example #2 LDAP pagination

<?php
     // $ds is a valid link identifier (see ldap_connect)
     ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3);

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     // enable pagination with a page size of 100.
     $pageSize = 100;

     $cookie = '';
     do {
         ldap_control_paged_result($ds, $pageSize, true, $cookie);

         $result  = ldap_search($ds, $dn, $filter, $justthese);
         $entries = ldap_get_entries($ds, $result);

         foreach ($entries as $e) {
             echo $e['dn'] . PHP_EOL;
         }

         ldap_control_paged_result_response($ds, $result, $cookie);

     } while($cookie !== null && $cookie != '');

注释

Note:

Pagination control is a LDAPv3 protocol feature.

参见

  • ldap_control_paged_result_response() - Retrieve the LDAP pagination cookie
  • » RFC2696 : LDAP Control Extension for Simple Paged Results Manipulation


Count the number of entries in a search

  • ? ldap_control_paged_result
  • ldap_delete_ext ?
  • PHP Manual
  • LDAP 函数
  • Count the number of entries in a search

ldap_count_entries

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_count_entries — Count the number of entries in a search

说明

ldap_count_entries ( resource $ldap , resource $result ) : int

Returns the number of entries stored in the result of previous search operations.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

result

The internal LDAP result.

返回值

Returns number of entries in the result or false on error.

范例

Example #1 ldap-count-entries() example

Retrieve number of entries in the result.

// $ds is a valid link identifier (see ldap_connect)

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     var_dump(ldap_count_entries($ds, $sr));

以上例程的输出类似于：

     int(1)


Delete an entry from a directory

  • ? ldap_count_entries
  • ldap_delete ?
  • PHP Manual
  • LDAP 函数
  • Delete an entry from a directory

ldap_delete_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_delete_ext — Delete an entry from a directory

说明

ldap_delete_ext ( resource $ldap , string $dn , array|null $controls = null ) : resource|false

Does the same thing as ldap_delete() but returns the LDAP result resource to be parsed with ldap_parse_result().

参数

See ldap_delete()

返回值

Returns an LDAP result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].

参见

  • ldap_delete() - Delete an entry from a directory
  • ldap_parse_result() - Extract information from result


Delete an entry from a directory

  • ? ldap_delete_ext
  • ldap_dn2ufn ?
  • PHP Manual
  • LDAP 函数
  • Delete an entry from a directory

ldap_delete

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_delete — Delete an entry from a directory

说明

ldap_delete ( resource $ldap , string $dn , array|null $controls = null ) : bool

Deletes a particular entry in LDAP directory.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

controls

Array of LDAP Controls to send with the request.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

参见

  • ldap_delete_ext() - Delete an entry from a directory
  • ldap_add() - Add entries to LDAP directory


Convert DN to User Friendly Naming format

  • ? ldap_delete
  • ldap_err2str ?
  • PHP Manual
  • LDAP 函数
  • Convert DN to User Friendly Naming format

ldap_dn2ufn

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_dn2ufn — Convert DN to User Friendly Naming format

说明

ldap_dn2ufn ( string $dn ) : string|false

Turns the specified dn, into a more user-friendly form, stripping off type names.

参数

dn

The distinguished name of an LDAP entity.

返回值

Returns the user friendly name, 或者在失败时返回 false.


Convert LDAP error number into string error message

  • ? ldap_dn2ufn
  • ldap_errno ?
  • PHP Manual
  • LDAP 函数
  • Convert LDAP error number into string error message

ldap_err2str

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_err2str — Convert LDAP error number into string error message

说明

ldap_err2str ( int $errno ) : string

Returns the string error message explaining the error number errno. While LDAP errno numbers are standardized, different libraries return different or even localized textual error messages. Never check for a specific error message text, but always use an error number to check.

参数

errno

The error number.

返回值

Returns the error message, as a string.

范例

Example #1 Enumerating all LDAP error messages

<?php
  for ($i=0; $i<100; $i++) {
    printf("Error $i: %s<br />\n", ldap_err2str($i));
  }
?>

参见

  • ldap_errno() - Return the LDAP error number of the last LDAP command
  • ldap_error() - Return the LDAP error message of the last LDAP command


Return the LDAP error number of the last LDAP command

  • ? ldap_err2str
  • ldap_error ?
  • PHP Manual
  • LDAP 函数
  • Return the LDAP error number of the last LDAP command

ldap_errno

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_errno — Return the LDAP error number of the last LDAP command

说明

ldap_errno ( resource $ldap ) : int

Returns the standardized error number returned by the last LDAP command. This number can be converted into a textual error message using ldap_err2str().

参数

ldap

An LDAP link identifier, returned by ldap_connect().

返回值

Return the LDAP error number of the last LDAP command for this link.

范例

Unless you lower your warning level in your php.ini sufficiently or prefix your LDAP commands with @ (at) characters to suppress warning output, the errors generated will also show up in your HTML output.

Example #1 Generating and catching an error

<?php
// This example contains an error, which we will catch.
$ld = ldap_connect("localhost");
$bind = ldap_bind($ld);
// syntax error in filter expression (errno 87),
// must be "objectclass=*" to work.
$res =  @ldap_search($ld, "o=Myorg, c=DE", "objectclass");
if (!$res) {
    echo "LDAP-Errno: " . ldap_errno($ld) . "<br />\n";
    echo "LDAP-Error: " . ldap_error($ld) . "<br />\n";
    die("Argh!<br />\n");
}
$info = ldap_get_entries($ld, $res);
echo $info["count"] . " matching entries.<br />\n";
?>

参见

  • ldap_err2str() - Convert LDAP error number into string error message
  • ldap_error() - Return the LDAP error message of the last LDAP command


Return the LDAP error message of the last LDAP command

  • ? ldap_errno
  • ldap_escape ?
  • PHP Manual
  • LDAP 函数
  • Return the LDAP error message of the last LDAP command

ldap_error

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_error — Return the LDAP error message of the last LDAP command

说明

ldap_error ( resource $ldap ) : string

Returns the string error message explaining the error generated by the last LDAP command for the given ldap. While LDAP errno numbers are standardized, different libraries return different or even localized textual error messages. Never check for a specific error message text, but always use an error number to check.

Unless you lower your warning level in your php.ini sufficiently or prefix your LDAP commands with @ (at) characters to suppress warning output, the errors generated will also show up in your HTML output.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

返回值

Returns string error message.

参见

  • ldap_err2str() - Convert LDAP error number into string error message
  • ldap_errno() - Return the LDAP error number of the last LDAP command


Escape a string for use in an LDAP filter or DN

  • ? ldap_error
  • ldap_exop_passwd ?
  • PHP Manual
  • LDAP 函数
  • Escape a string for use in an LDAP filter or DN

ldap_escape

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

ldap_escape — Escape a string for use in an LDAP filter or DN

说明

ldap_escape ( string $value , string $ignore = "" , int $flags = 0 ) : string

Escapes value for use in the context implied by flags.

参数

value

The value to escape.

ignore

Characters to ignore when escaping.

flags

The context the escaped string will be used in: LDAP_ESCAPE_FILTER for filters to be used with ldap_search(), or LDAP_ESCAPE_DN for DNs. If neither flag is passed, all chars are escaped.

返回值

Returns the escaped string.

范例

When building an LDAP filter, you should use ldap_escape with LDAP_ESCAPE_FILTER flag.

Example #1 Searching for an email address

<?php
// $ds is a valid link identifier for a directory server

// $mail is an email address provided by the user in a form

$base   = "o=My Company, c=US";
$filter = "(mail=".ldap_escape($mail, "", LDAP_ESCAPE_FILTER).")";

$sr = ldap_search($ds, $base, $filter, array("sn", "givenname", "mail"));

$info = ldap_get_entries($ds, $sr);

echo $info["count"]." entries returned\n";
?>


PASSWD extended operation helper

  • ? ldap_escape
  • ldap_exop_refresh ?
  • PHP Manual
  • LDAP 函数
  • PASSWD extended operation helper

ldap_exop_passwd

(PHP 7 >= 7.2.0, PHP 8)

ldap_exop_passwd — PASSWD extended operation helper

说明

ldap_exop_passwd ( resource $ldap , string $user = "" , string $old_password = "" , string $new_password = "" , array &$controls = null ) : string|bool

Performs a PASSWD extended operation.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

user

dn of the user to change the password of.

old_password

The old password of this user. May be ommited depending of server configuration.

new_password

The new password for this user. May be omitted or empty to have a generated password.

controls

If provided, a password policy request control is send with the request and this is filled with an array of LDAP Controls returned with the request.

返回值

Returns the generated password if new_password is empty or omitted. Otherwise returns true on success and false on failure.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

范例

Example #1 PASSWD extended operation

<?php
$ds = ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {
    // bind with appropriate dn to give update access
    $bind = ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");
    if (!$bind) {
      echo "Unable to bind to LDAP server";
      exit;
    }

    // use PASSWD EXOP to change the user password for a generated one
    $genpw = ldap_exop_passwd($ds, "cn=root, o=My Company, c=US", "secret");
    if ($genpw) {
      // use the generated password to bind
      $bind = ldap_bind($ds, "cn=root, o=My Company, c=US", $genpw);
    }

    // set the password back to "secret"
    ldap_exop_passwd($ds, "cn=root, o=My Company, c=US", $genpw, "secret");

    ldap_close($ds);
} else {
    echo "Unable to connect to LDAP server";
}
?>

参见

  • ldap_exop() - Performs an extended operation
  • ldap_parse_exop() - Parse result object from an LDAP extended operation


Refresh extended operation helper

  • ? ldap_exop_passwd
  • ldap_exop_whoami ?
  • PHP Manual
  • LDAP 函数
  • Refresh extended operation helper

ldap_exop_refresh

(PHP 7 >= 7.3.0, PHP 8)

ldap_exop_refresh — Refresh extended operation helper

说明

ldap_exop_refresh ( resource $ldap , string $dn , int $ttl ) : int|false

Performs a Refresh extended operation and returns the data.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

dn of the entry to refresh.

ttl

Time in seconds (between 1 and 31557600) that the client requests that the entry exists in the directory before being automatically removed.

返回值

From RFC: The responseTtl field is the time in seconds which the server chooses to have as the time-to-live field for that entry. It must not be any smaller than that which the client requested, and it may be larger. However, to allow servers to maintain a relatively accurate directory, and to prevent clients from abusing the dynamic extensions, servers are permitted to shorten a client-requested time-to-live value, down to a minimum of 86400 seconds (one day). false will be returned on error.

参见

  • ldap_exop() - Performs an extended operation


WHOAMI extended operation helper

  • ? ldap_exop_refresh
  • ldap_exop ?
  • PHP Manual
  • LDAP 函数
  • WHOAMI extended operation helper

ldap_exop_whoami

(PHP 7 >= 7.2.0, PHP 8)

ldap_exop_whoami — WHOAMI extended operation helper

说明

ldap_exop_whoami ( resource $ldap ) : string|false

Performs a WHOAMI extended operation and returns the data.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

返回值

The data returned by the server, or false on error.

参见

  • ldap_exop() - Performs an extended operation


Performs an extended operation

  • ? ldap_exop_whoami
  • ldap_explode_dn ?
  • PHP Manual
  • LDAP 函数
  • Performs an extended operation

ldap_exop

(PHP 7 >= 7.2.0, PHP 8)

ldap_exop — Performs an extended operation

说明

ldap_exop ( resource $link , string $reqoid , string $reqdata = null , array $serverctrls = null , string &$retdata = ? , string &$retoid = ? ) : mixed

Performs an extended operation on the specified link with reqoid the OID of the operation and reqdata the data.

参数

link

An LDAP link identifier, returned by ldap_connect().

reqoid

The extended operation request OID. You may use one of LDAP_EXOP_START_TLS, LDAP_EXOP_MODIFY_PASSWD, LDAP_EXOP_REFRESH, LDAP_EXOP_WHO_AM_I, LDAP_EXOP_TURN, or a string with the OID of the operation you want to send.

reqdata

The extended operation request data. May be NULL for some operations like LDAP_EXOP_WHO_AM_I, may also need to be BER encoded.

serverctrls

Array of LDAP Controls to send with the request.

retdata

Will be filled with the extended operation response data if provided. If not provided you may use ldap_parse_exop on the result object later to get this data.

retoid

Will be filled with the response OID if provided, usually equal to the request OID.

返回值

When used with retdata, returns true on success or false on error. When used without retdata, returns a result identifier or false on error.

更新日志

版本 | 说明
7.3 | Support for serverctrls added

范例

Example #1 Whoami extended operation

<?php
$ds = ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {
    // bind with appropriate dn to give update access
    $bind = ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");
    if (!$bind) {
      echo "Unable to bind to LDAP server";
      exit;
    }

    // Call WHOAMI EXOP
    $r = ldap_exop($ds, LDAP_EXOP_WHO_AM_I);

    // Parse the result object
    ldap_parse_exop($ds, $r, $retdata);
    // Output: string(31) "dn:cn=root, o=My Company, c=US"
    var_dump($retdata);

    // Same thing using $retdata parameter
    $success = ldap_exop($ds, LDAP_EXOP_WHO_AM_I, NULL, NULL, $retdata, $retoid);
    if ($success) {
      var_dump($retdata);
    }

    ldap_close($ds);
} else {
    echo "Unable to connect to LDAP server";
}
?>

参见

  • ldap_parse_result() - Extract information from result
  • ldap_parse_exop() - Parse result object from an LDAP extended operation
  • ldap_exop_whoami() - WHOAMI extended operation helper
  • ldap_exop_refresh() - Refresh extended operation helper
  • ldap_exop_passwd() - PASSWD extended operation helper


Splits DN into its component parts

  • ? ldap_exop
  • ldap_first_attribute ?
  • PHP Manual
  • LDAP 函数
  • Splits DN into its component parts

ldap_explode_dn

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_explode_dn — Splits DN into its component parts

说明

ldap_explode_dn ( string $dn , int $with_attrib ) : array|false

Splits the DN returned by ldap_get_dn() and breaks it up into its component parts. Each part is known as Relative Distinguished Name, or RDN.

参数

dn

The distinguished name of an LDAP entity.

with_attrib

Used to request if the RDNs are returned with only values or their attributes as well. To get RDNs with the attributes (i.e. in attribute=value format) set with_attrib to 0 and to get only values set it to 1.

返回值

Returns an array of all DN components, 或者在失败时返回 false. The first element in the array has count key and represents the number of returned values, next elements are numerically indexed DN components.


Return first attribute

  • ? ldap_explode_dn
  • ldap_first_entry ?
  • PHP Manual
  • LDAP 函数
  • Return first attribute

ldap_first_attribute

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_first_attribute — Return first attribute

说明

ldap_first_attribute ( resource $ldap , resource $entry ) : string|false

Gets the first attribute in the given entry. Remaining attributes are retrieved by calling ldap_next_attribute() successively.

Similar to reading entries, attributes are also read one by one from a particular entry.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

entry

ber_identifier

ber_identifier is the identifier to internal memory location pointer. It is passed by reference. The same ber_identifier is passed to ldap_next_attribute() , which modifies that pointer.

Note:

This parameter is no longer used as this is now handled automatically by PHP. For backwards compatibility PHP will not throw an error if this parameter is passed.

返回值

Returns the first attribute in the entry on success and false on error.

参见

  • ldap_next_attribute() - Get the next attribute in result
  • ldap_get_attributes() - Get attributes from a search result entry


Return first result id

  • ? ldap_first_attribute
  • ldap_first_reference ?
  • PHP Manual
  • LDAP 函数
  • Return first result id

ldap_first_entry

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_first_entry — Return first result id

说明

ldap_first_entry ( resource $ldap , resource $result ) : resource|false

Returns the entry identifier for first entry in the result. This entry identifier is then supplied to ldap_next_entry() routine to get successive entries from the result.

Entries in the LDAP result are read sequentially using the ldap_first_entry() and ldap_next_entry() functions.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

result

返回值

Returns the result entry identifier for the first entry on success and false on error.

参见

  • ldap_get_entries() - Get all result entries


Return first reference

  • ? ldap_first_entry
  • ldap_free_result ?
  • PHP Manual
  • LDAP 函数
  • Return first reference

ldap_first_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_first_reference — Return first reference

说明

ldap_first_reference ( resource $ldap , resource $result ) : resource|false
Warning

本函数还未编写文档，仅有参数列表。


Free result memory

  • ? ldap_first_reference
  • ldap_get_attributes ?
  • PHP Manual
  • LDAP 函数
  • Free result memory

ldap_free_result

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_free_result — Free result memory

说明

ldap_free_result ( resource $ldap ) : bool

Frees up the memory allocated internally to store the result. All result memory will be automatically freed when the script terminates.

Typically all the memory allocated for the LDAP result gets freed at the end of the script. In case the script is making successive searches which return large result sets, ldap_free_result() could be called to keep the runtime memory usage by the script low.

参数

ldap

返回值

成功时返回 true， 或者在失败时返回 false。


Get attributes from a search result entry

  • ? ldap_free_result
  • ldap_get_dn ?
  • PHP Manual
  • LDAP 函数
  • Get attributes from a search result entry

ldap_get_attributes

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_attributes — Get attributes from a search result entry

说明

ldap_get_attributes ( resource $ldap , resource $entry ) : array

Reads attributes and values from an entry in the search result.

Having located a specific entry in the directory, you can find out what information is held for that entry by using this call. You would use this call for an application which "browses" directory entries and/or where you do not know the structure of the directory entries. In many applications you will be searching for a specific attribute such as an email address or a surname, and won't care what other data is held.

return_value["count"] = number of attributes in the entry
return_value[0] = first attribute
return_value[n] = nth attribute

return_value["attribute"]["count"] = number of values for attribute
return_value["attribute"][0] = first value of the attribute
return_value["attribute"][i] = (i+1)th value of the attribute

参数

ldap

An LDAP link identifier, returned by ldap_connect().

entry

返回值

Returns a complete entry information in a multi-dimensional array on success and false on error.

范例

Example #1 Show the list of attributes held for a particular directory entry

<?php
// $ds is the link identifier for the directory

// $sr is a valid search result from a prior call to
// one of the ldap directory search calls

$entry = ldap_first_entry($ds, $sr);

$attrs = ldap_get_attributes($ds, $entry);

echo $attrs["count"] . " attributes held for this entry:<p>";

for ($i=0; $i < $attrs["count"]; $i++) {
    echo $attrs[$i] . "<br />";
}
?>

参见

  • ldap_first_attribute() - Return first attribute
  • ldap_next_attribute() - Get the next attribute in result


Get the DN of a result entry

  • ? ldap_get_attributes
  • ldap_get_entries ?
  • PHP Manual
  • LDAP 函数
  • Get the DN of a result entry

ldap_get_dn

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_dn — Get the DN of a result entry

说明

ldap_get_dn ( resource $ldap , resource $entry ) : string|false

Finds out the DN of an entry in the result.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

entry

返回值

Returns the DN of the result entry and false on error.


Get all result entries

  • ? ldap_get_dn
  • ldap_get_option ?
  • PHP Manual
  • LDAP 函数
  • Get all result entries

ldap_get_entries

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_entries — Get all result entries

说明

ldap_get_entries ( resource $ldap , resource $result ) : array|false

Reads multiple entries from the given result, and then reading the attributes and multiple values.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

result

返回值

Returns a complete result information in a multi-dimensional array on success and false on error.

The structure of the array is as follows. The attribute index is converted to lowercase. (Attributes are case-insensitive for directory servers, but not when used as array indices.)

return_value["count"] = number of entries in the result
return_value[0] : refers to the details of first entry

return_value[i]["dn"] =  DN of the ith entry in the result

return_value[i]["count"] = number of attributes in ith entry
return_value[i][j] = NAME of the jth attribute in the ith entry in the result

return_value[i]["attribute"]["count"] = number of values for
                                        attribute in ith entry
return_value[i]["attribute"][j] = jth value of attribute in ith entry

参见

  • ldap_first_entry() - Return first result id
  • ldap_next_entry() - Get next result entry


Get the current value for given option

  • ? ldap_get_entries
  • ldap_get_values_len ?
  • PHP Manual
  • LDAP 函数
  • Get the current value for given option

ldap_get_option

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ldap_get_option — Get the current value for given option

说明

ldap_get_option ( resource $ldap , int $option , array|string|int &$value = null ) : bool

Sets value to the value of the specified option.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

option

The parameter option can be one of:

Option | Type | since
LDAP_OPT_DEREF | int
LDAP_OPT_SIZELIMIT | int
LDAP_OPT_TIMELIMIT | int
LDAP_OPT_NETWORK_TIMEOUT | int
LDAP_OPT_PROTOCOL_VERSION | int
LDAP_OPT_ERROR_NUMBER | int
LDAP_OPT_DIAGNOSTIC_MESSAGE | int
LDAP_OPT_REFERRALS | int
LDAP_OPT_RESTART | int
LDAP_OPT_HOST_NAME | string
LDAP_OPT_ERROR_STRING | string
LDAP_OPT_MATCHED_DN | string
LDAP_OPT_SERVER_CONTROLS | array
LDAP_OPT_CLIENT_CONTROLS | array
LDAP_OPT_X_KEEPALIVE_IDLE | int | 7.1
LDAP_OPT_X_KEEPALIVE_PROBES | int | 7.1
LDAP_OPT_X_KEEPALIVE_INTERVAL | int | 7.1
LDAP_OPT_X_TLS_CACERTDIR | string | 7.1
LDAP_OPT_X_TLS_CACERTFILE | string | 7.1
LDAP_OPT_X_TLS_CERTFILE | string | 7.1
LDAP_OPT_X_TLS_CIPHER_SUITE | string | 7.1
LDAP_OPT_X_TLS_CRLCHECK | int | 7.1
LDAP_OPT_X_TLS_CRL_NONE | int | 7.1
LDAP_OPT_X_TLS_CRL_PEER | int | 7.1
LDAP_OPT_X_TLS_CRL_ALL | int | 7.1
LDAP_OPT_X_TLS_CRLFILE | string | 7.1
LDAP_OPT_X_TLS_DHFILE | string | 7.1
LDAP_OPT_X_TLS_KEYFILE | string | 7.1
LDAP_OPT_X_TLS_PACKAGE | string | 7.1
LDAP_OPT_X_TLS_PROTOCOL_MIN | int | 7.1
LDAP_OPT_X_TLS_RANDOM_FILE | string | 7.1
LDAP_OPT_X_TLS_REQUIRE_CERT | int

value

This will be set to the option value.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Check protocol version

<?php
// $ds is a valid link identifier for a directory server
if (ldap_get_option($ds, LDAP_OPT_PROTOCOL_VERSION, $version)) {
    echo "Using protocol version $version\n";
} else {
    echo "Unable to determine protocol version\n";
}
?>

注释

Note:

This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

参见

  • ldap_set_option() - Set the value of the given option


Get all binary values from a result entry

  • ? ldap_get_option
  • ldap_get_values ?
  • PHP Manual
  • LDAP 函数
  • Get all binary values from a result entry

ldap_get_values_len

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_values_len — Get all binary values from a result entry

说明

ldap_get_values_len ( resource $ldap , resource $entry , string $attribute ) : array|false

Reads all the values of the attribute in the entry in the result.

This function is used exactly like ldap_get_values() except that it handles binary data and not string data.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

entry

attribute

返回值

Returns an array of values for the attribute on success and false on error. Individual values are accessed by integer index in the array. The first index is 0. The number of values can be found by indexing "count" in the resultant array.

参见

  • ldap_get_values() - Get all values from a result entry


Get all values from a result entry

  • ? ldap_get_values_len
  • ldap_list ?
  • PHP Manual
  • LDAP 函数
  • Get all values from a result entry

ldap_get_values

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_get_values — Get all values from a result entry

说明

ldap_get_values ( resource $ldap , resource $entry , string $attribute ) : array|false

Reads all the values of the attribute in the entry in the result.

This call needs a entry, so needs to be preceded by one of the ldap search calls and one of the calls to get an individual entry.

You application will either be hard coded to look for certain attributes (such as "surname" or "mail") or you will have to use the ldap_get_attributes() call to work out what attributes exist for a given entry.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

entry

attribute

返回值

Returns an array of values for the attribute on success and false on error. The number of values can be found by indexing "count" in the resultant array. Individual values are accessed by integer index in the array. The first index is 0.

LDAP allows more than one entry for an attribute, so it can, for example, store a number of email addresses for one person's directory entry all labeled with the attribute "mail"

    return_value["count"] = number of values for attribute
    return_value[0] = first value of attribute
    return_value[i] = ith value of attribute

范例

Example #1 List all values of the "mail" attribute for a directory entry

<?php
// $ds is a valid link identifier for a directory server

// $sr is a valid search result from a prior call to
//     one of the ldap directory search calls

// $entry is a valid entry identifier from a prior call to
//        one of the calls that returns a directory entry

$values = ldap_get_values($ds, $entry, "mail");

echo $values["count"] . " email addresses for this entry.<br />";

for ($i=0; $i < $values["count"]; $i++) {
    echo $values[$i] . "<br />";
}
?>

参见

  • ldap_get_values_len() - Get all binary values from a result entry


Single-level search

  • ? ldap_get_values
  • ldap_mod_add_ext ?
  • PHP Manual
  • LDAP 函数
  • Single-level search

ldap_list

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_list — Single-level search

说明

ldap_list ( resource|array $ldap , array|string $base , array|string $filter , array $attributes = [] , int $attributes_only = 0 , int $sizelimit = -1 , int $timelimit = -1 , int $deref = LDAP_DEREF_NEVER , array|null $controls = null ) : resource|array|false

Performs the search for a specified filter on the directory with the scope LDAP_SCOPE_ONELEVEL.

LDAP_SCOPE_ONELEVEL means that the search should only return information that is at the level immediately below the base given in the call. (Equivalent to typing "ls" and getting a list of files and folders in the current working directory.)

参数

ldap

An LDAP link identifier, returned by ldap_connect().

base

The base DN for the directory.

filter

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attributes_only

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Note:

This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Note:

This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

controls

Array of LDAP Controls to send with the request.

返回值

Returns a search result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

范例

Example #1 Produce a list of all organizational units of an organization

<?php
// $ds is a valid link identifier for a directory server

$basedn = "o=My Company, c=US";
$justthese = array("ou");

$sr = ldap_list($ds, $basedn, "ou=*", $justthese);

$info = ldap_get_entries($ds, $sr);

for ($i=0; $i < $info["count"]; $i++) {
    echo $info[$i]["ou"][0];
}
?>

参见

  • ldap_search() - Search LDAP tree


Add attribute values to current attributes

  • ? ldap_list
  • ldap_mod_add ?
  • PHP Manual
  • LDAP 函数
  • Add attribute values to current attributes

ldap_mod_add_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_mod_add_ext — Add attribute values to current attributes

说明

ldap_mod_add_ext ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : resource|false

Does the same thing as ldap_mod_add() but returns the LDAP result resource to be parsed with ldap_parse_result().

参数

See ldap_mod_add()

返回值

Returns an LDAP result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

参见

  • ldap_mod_add() - Add attribute values to current attributes
  • ldap_parse_result() - Extract information from result


Add attribute values to current attributes

  • ? ldap_mod_add_ext
  • ldap_mod_del_ext ?
  • PHP Manual
  • LDAP 函数
  • Add attribute values to current attributes

ldap_mod_add

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_mod_add — Add attribute values to current attributes

说明

ldap_mod_add ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : bool

Adds one or more attribute values to the specified dn. To add a whole new object see ldap_add() function.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

An associative array listing the attirbute values to add. If an attribute was not existing yet it will be added. If an attribute is existing you can only add values to it if it supports multiple values.

controls

Array of LDAP Controls to send with the request.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

注释

Note: 此函数可安全用于二进制对象。

参见

  • ldap_mod_add_ext() - Add attribute values to current attributes
  • ldap_mod_del() - Delete attribute values from current attributes
  • ldap_mod_replace() - Replace attribute values with new ones
  • ldap_modify_batch() - Batch and execute modifications on an LDAP entry


Delete attribute values from current attributes

  • ? ldap_mod_add
  • ldap_mod_del ?
  • PHP Manual
  • LDAP 函数
  • Delete attribute values from current attributes

ldap_mod_del_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_mod_del_ext — Delete attribute values from current attributes

说明

ldap_mod_del_ext ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : resource|false

Does the same thing as ldap_mod_del() but returns the LDAP result resource to be parsed with ldap_parse_result().

参数

See ldap_mod_del()

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

返回值

Returns an LDAP result identifier or false on error.

参见

  • ldap_mod_del() - Delete attribute values from current attributes
  • ldap_parse_result() - Extract information from result


Delete attribute values from current attributes

  • ? ldap_mod_del_ext
  • ldap_mod_replace_ext ?
  • PHP Manual
  • LDAP 函数
  • Delete attribute values from current attributes

ldap_mod_del

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_mod_del — Delete attribute values from current attributes

说明

ldap_mod_del ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : bool

Removes one or more attribute values from the specified dn. Object deletions are done by the ldap_delete() function.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

controls

Array of LDAP Controls to send with the request.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

参见

  • ldap_mod_del_ext() - Delete attribute values from current attributes
  • ldap_mod_add() - Add attribute values to current attributes
  • ldap_mod_replace() - Replace attribute values with new ones
  • ldap_modify_batch() - Batch and execute modifications on an LDAP entry


Replace attribute values with new ones

  • ? ldap_mod_del
  • ldap_mod_replace ?
  • PHP Manual
  • LDAP 函数
  • Replace attribute values with new ones

ldap_mod_replace_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_mod_replace_ext — Replace attribute values with new ones

说明

ldap_mod_replace_ext ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : resource|false

Does the same thing as ldap_mod_replace() but returns the LDAP result resource to be parsed with ldap_parse_result().

参数

See ldap_mod_replace()

返回值

Returns an LDAP result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

参见

  • ldap_mod_replace() - Replace attribute values with new ones
  • ldap_parse_result() - Extract information from result


Replace attribute values with new ones

  • ? ldap_mod_replace_ext
  • ldap_modify_batch ?
  • PHP Manual
  • LDAP 函数
  • Replace attribute values with new ones

ldap_mod_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_mod_replace — Replace attribute values with new ones

说明

ldap_mod_replace ( resource $ldap , string $dn , array $entry , array|null $controls = null ) : bool

Replaces one or more attributes from the specified dn. It may also add or remove attributes.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

An associative array listing the attributes to replace. Sending an empty array as value will remove the attribute, while sending an attribute not existing yet on this entry will add it.

controls

Array of LDAP Controls to send with the request.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

注释

Note: 此函数可安全用于二进制对象。

参见

  • ldap_mod_replace_ext() - Replace attribute values with new ones
  • ldap_mod_del() - Delete attribute values from current attributes
  • ldap_mod_add() - Add attribute values to current attributes
  • ldap_modify_batch() - Batch and execute modifications on an LDAP entry


Batch and execute modifications on an LDAP entry

  • ? ldap_mod_replace
  • ldap_modify ?
  • PHP Manual
  • LDAP 函数
  • Batch and execute modifications on an LDAP entry

ldap_modify_batch

(PHP 5.4 >= 5.4.26, PHP 5.5 >= 5.5.10, PHP 5.6 >= 5.6.0, PHP 7, PHP 8)

ldap_modify_batch — Batch and execute modifications on an LDAP entry

说明

ldap_modify_batch ( resource $ldap , string $dn , array $modifications_info , array|null $controls = null ) : bool

Modifies an existing entry in the LDAP directory. Allows detailed specification of the modifications to perform.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

modifications_info

An array that specifies the modifications to make. Each entry in this array is an associative array with two or three keys: attrib maps to the name of the attribute to modify, modtype maps to the type of modification to perform, and (depending on the type of modification) values maps to an array of attribute values relevant to the modification.

Possible values for modtype include:

LDAP_MODIFY_BATCH_ADD

Each value specified through values is added (as an additional value) to the attribute named by attrib.

LDAP_MODIFY_BATCH_REMOVE

Each value specified through values is removed from the attribute named by attrib. Any value of the attribute not contained in the values array will remain untouched.

LDAP_MODIFY_BATCH_REMOVE_ALL

All values are removed from the attribute named by attrib. A values entry must not be provided.

LDAP_MODIFY_BATCH_REPLACE

All current values of the attribute named by attrib are replaced with the values specified through values.

Note that any value for attrib must be a string, any value for values must be an array of strings, and any value for modtype must be one of the LDAP_MODIFY_BATCH_* constants listed above.

controls

Array of LDAP Controls to send with the request.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

范例

Example #1 Add a telephone number to a contact

<?php
$dn = "cn=John Smith,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "telephoneNumber",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => ["+1 555 555 1717"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Example #2 Rename a user

<?php
$dn = "cn=John Smith,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "sn",
        "modtype" => LDAP_MODIFY_BATCH_REPLACE,
        "values"  => ["Smith-Jones"],
    ],
    [
        "attrib"  => "givenName",
        "modtype" => LDAP_MODIFY_BATCH_REPLACE,
        "values"  => ["Jack"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
ldap_rename($connection, $dn, "cn=Jack Smith-Jones", NULL, TRUE);
?>

Example #3 Add two e-mail addresses to a user

<?php
$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "mail",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => [
            "jack.smith@example.com",
            "jack.smith-jones@example.com",
        ],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Example #4 Change a user's password

<?php
$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "userPassword",
        "modtype" => LDAP_MODIFY_BATCH_REMOVE,
        "values"  => ["Tr0ub4dor&3"],
    ],
    [
        "attrib"  => "userPassword",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => ["correct horse battery staple"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Example #5 Change a user's password (Active Directory)

<?php
function adifyPw($pw)
{
    return iconv("UTF-8", "UTF-16LE", '"' . $pw . '"');
}

$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=ad,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "unicodePwd",
        "modtype" => LDAP_MODIFY_BATCH_REMOVE,
        "values"  => [adifyPw("Tr0ub4dor&3")],
    ],
    [
        "attrib"  => "unicodePwd",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => [adifyPw("correct horse battery staple")],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);


别名 ldap_mod_replace

  • ? ldap_modify_batch
  • ldap_next_attribute ?
  • PHP Manual
  • LDAP 函数
  • 别名 ldap_mod_replace

ldap_modify

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_modify — 别名 ldap_mod_replace()

说明

此函数是该函数的别名： ldap_mod_replace().

参见

  • ldap_rename() - Modify the name of an entry


Get the next attribute in result

  • ? ldap_modify
  • ldap_next_entry ?
  • PHP Manual
  • LDAP 函数
  • Get the next attribute in result

ldap_next_attribute

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_next_attribute — Get the next attribute in result

说明

ldap_next_attribute ( resource $ldap , resource $entry ) : string|false

Retrieves the attributes in an entry. The first call to ldap_next_attribute() is made with the entry returned from ldap_first_attribute().

参数

ldap

An LDAP link identifier, returned by ldap_connect().

entry

ber_identifier

The internal state of the pointer is maintained by this parameter.

Note:

This parameter is no longer used as this is now handled automatically by PHP. For backwards compatibility PHP will not throw an error if this parameter is passed.

返回值

Returns the next attribute in an entry on success and false on error.

参见

  • ldap_get_attributes() - Get attributes from a search result entry


Get next result entry

  • ? ldap_next_attribute
  • ldap_next_reference ?
  • PHP Manual
  • LDAP 函数
  • Get next result entry

ldap_next_entry

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_next_entry — Get next result entry

说明

ldap_next_entry ( resource $ldap , resource $result ) : resource|false

Retrieve the entries stored in the result. Successive calls to the ldap_next_entry() return entries one by one till there are no more entries. The first call to ldap_next_entry() is made after the call to ldap_first_entry() with the result as returned from the ldap_first_entry().

参数

ldap

An LDAP link identifier, returned by ldap_connect().

result

返回值

Returns entry identifier for the next entry in the result whose entries are being read starting with ldap_first_entry(). If there are no more entries in the result then it returns false.

参见

  • ldap_get_entries() - Get all result entries


Get next reference

  • ? ldap_next_entry
  • ldap_parse_exop ?
  • PHP Manual
  • LDAP 函数
  • Get next reference

ldap_next_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_next_reference — Get next reference

说明

ldap_next_reference ( resource $ldap , resource $entry ) : resource|false
Warning

本函数还未编写文档，仅有参数列表。


Parse result object from an LDAP extended operation

  • ? ldap_next_reference
  • ldap_parse_reference ?
  • PHP Manual
  • LDAP 函数
  • Parse result object from an LDAP extended operation

ldap_parse_exop

(PHP 7 >= 7.2.0, PHP 8)

ldap_parse_exop — Parse result object from an LDAP extended operation

说明

ldap_parse_exop ( resource $ldap , resource $result , string &$response_data = null , string &$response_oid = null ) : bool

Parse LDAP extended operation data from result object result

参数

ldap

An LDAP link identifier, returned by ldap_connect().

result

An LDAP result resource, returned by ldap_exop().

response_data

Will be filled by the response data.

response_oid

Will be filled by the response OID.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ldap_exop() - Performs an extended operation


Extract information from reference entry

  • ? ldap_parse_exop
  • ldap_parse_result ?
  • PHP Manual
  • LDAP 函数
  • Extract information from reference entry

ldap_parse_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_parse_reference — Extract information from reference entry

说明

ldap_parse_reference ( resource $ldap , resource $entry , array &$referrals ) : bool
Warning

本函数还未编写文档，仅有参数列表。


Extract information from result

  • ? ldap_parse_reference
  • ldap_read ?
  • PHP Manual
  • LDAP 函数
  • Extract information from result

ldap_parse_result

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_parse_result — Extract information from result

说明

ldap_parse_result ( resource $ldap , resource $result , int &$error_code , string &$matched_dn = null , string &$error_message = null , array &$referrals = null , array &$controls = null ) : bool

Parses an LDAP search result.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

result_identifier

An LDAP result resource, returned by ldap_list() or ldap_search().

error_code

A reference to a variable that will be set to the LDAP error code in the result, or 0 if no error occurred.

matched_dn

A reference to a variable that will be set to a matched DN if one was recognised within the request, otherwise it will be set to null.

error_message

A reference to a variable that will be set to the LDAP error message in the result, or an empty string if no error occurred.

referrals

A reference to a variable that will be set to an array set to all of the referral strings in the result, or an empty array if no referrals were returned.

controls

An array of LDAP Controls which have been sent with the response.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.3 | Support for controls added

范例

Example #1 ldap_parse_result() example

<?php
$result = ldap_search($link, "cn=userref,dc=my-domain,dc=com", "(cn=user*)");
$errcode = $dn = $errmsg = $refs =  null;
if (ldap_parse_result($link, $result, $errcode, $dn, $errmsg, $refs)) {
    // do something with $errcode, $dn, $errmsg and $refs
}
?>


Read an entry

  • ? ldap_parse_result
  • ldap_rename_ext ?
  • PHP Manual
  • LDAP 函数
  • Read an entry

ldap_read

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_read — Read an entry

说明

ldap_read ( resource|array $ldap , array|string $base , array|string $filter , array $attributes = [] , int $attributes_only = 0 , int $sizelimit = -1 , int $timelimit = -1 , int $deref = LDAP_DEREF_NEVER , array|null $controls = null ) : resource|array|false

Performs the search for a specified filter on the directory with the scope LDAP_SCOPE_BASE. So it is equivalent to reading an entry from the directory.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

base

The base DN for the directory.

filter

An empty filter is not allowed. If you want to retrieve absolutely all information for this entry, use a filter of objectClass=*. If you know which entry types are used on the directory server, you might use an appropriate filter such as objectClass=inetOrgPerson.

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attributes_only

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Note:

This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Note:

This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

controls

Array of LDAP Controls to send with the request.

返回值

Returns a search result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
4.0.5 | Parallel searches support was added. See ldap_search() for details.
7.3 | Support for controls added


Modify the name of an entry

  • ? ldap_read
  • ldap_rename ?
  • PHP Manual
  • LDAP 函数
  • Modify the name of an entry

ldap_rename_ext

(PHP 7 >= 7.3.0, PHP 8)

ldap_rename_ext — Modify the name of an entry

说明

ldap_rename_ext ( resource $ldap , string $dn , string $new_rdn , string $new_parent , bool $delete_old_rdn , array|null $controls = null ) : resource|false

Does the same thing as ldap_rename() but returns the LDAP result resource to be parsed with ldap_parse_result().

参数

See ldap_rename()

返回值

Returns an LDAP result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

参见

  • ldap_rename() - Modify the name of an entry
  • ldap_parse_result() - Extract information from result


Modify the name of an entry

  • ? ldap_rename_ext
  • ldap_sasl_bind ?
  • PHP Manual
  • LDAP 函数
  • Modify the name of an entry

ldap_rename

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

ldap_rename — Modify the name of an entry

说明

ldap_rename ( resource $ldap , string $dn , string $new_rdn , string $new_parent , bool $delete_old_rdn , array|null $controls = null ) : bool

The entry specified by dn is renamed/moved.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

new_rdn

The new RDN.

new_parent

The new parent/superior entry.

delete_old_rdn

If true the old RDN value(s) is removed, else the old RDN value(s) is retained as non-distinguished values of the entry.

controls

Array of LDAP Controls to send with the request.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

注释

Note:

This function currently only works with LDAPv3. You may have to use ldap_set_option() prior to binding to use LDAPv3. This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

参见

  • ldap_rename_ext() - Modify the name of an entry
  • ldap_modify() - 别名 ldap_mod_replace


Bind to LDAP directory using SASL

  • ? ldap_rename
  • ldap_search ?
  • PHP Manual
  • LDAP 函数
  • Bind to LDAP directory using SASL

ldap_sasl_bind

(PHP 5, PHP 7, PHP 8)

ldap_sasl_bind — Bind to LDAP directory using SASL

说明

ldap_sasl_bind ( resource $ldap , string|null $dn = null , string|null $password = null , string|null $mech = null , string|null $realm = null , string|null $authc_id = null , string|null $authz_id = null , string|null $props = null ) : bool
Warning

本函数还未编写文档，仅有参数列表。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | dn, password, mech, realm, authc_id, authz_id and props are nullable now.

注释

Note: Requirement
ldap_sasl_bind() requires SASL support (sasl.h). Be sure --with-ldap-sasl is used when configuring PHP otherwise this function will be undefined.


Search LDAP tree

  • ? ldap_sasl_bind
  • ldap_set_option ?
  • PHP Manual
  • LDAP 函数
  • Search LDAP tree

ldap_search

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_search — Search LDAP tree

说明

ldap_search ( resource|array $ldap , array|string $base , array|string $filter , array $attributes = [] , int $attributes_only = 0 , int $sizelimit = -1 , int $timelimit = -1 , int $deref = LDAP_DEREF_NEVER , array|null $controls = null ) : resource|array|false

Performs the search for a specified filter on the directory with the scope of LDAP_SCOPE_SUBTREE. This is equivalent to searching the entire directory.

From 4.0.5 on it's also possible to do parallel searches. To do this you use an array of link identifiers, rather than a single identifier, as the first argument. If you don't want the same base DN and the same filter for all the searches, you can also use an array of base DNs and/or an array of filters. Those arrays must be of the same size as the link identifier array since the first entries of the arrays are used for one search, the second entries are used for another, and so on. When doing parallel searches an array of search result identifiers is returned, except in case of error, then the entry corresponding to the search will be false. This is very much like the value normally returned, except that a result identifier is always returned when a search was made. There are some rare cases where the normal search returns false while the parallel search returns an identifier.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

base

The base DN for the directory.

filter

The search filter can be simple or advanced, using boolean operators in the format described in the LDAP documentation (see the » Netscape Directory SDK or » RFC4515 for full information on filters).

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attributes_only

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Note:

This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Note:

This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

controls

Array of LDAP Controls to send with the request.

返回值

Returns a search result identifier or false on error.

更新日志

版本 | 说明
8.0.0 | controls is nullable now; previously, it defaulted to [].
7.3 | Support for controls added

范例

The example below retrieves the organizational unit, surname, given name and email address for all people in "My Company" where the surname or given name contains the substring $person. This example uses a boolean filter to tell the server to look for information in more than one attribute.

Example #1 LDAP search

<?php
// $ds is a valid link identifier for a directory server

// $person is all or part of a person's name, eg "Jo"

$dn = "o=My Company, c=US";
$filter="(|(sn=$person*)(givenname=$person*))";
$justthese = array("ou", "sn", "givenname", "mail");

$sr=ldap_search($ds, $dn, $filter, $justthese);

$info = ldap_get_entries($ds, $sr);

echo $info["count"]." entries returned\n";
?>


Set the value of the given option

  • ? ldap_search
  • ldap_set_rebind_proc ?
  • PHP Manual
  • LDAP 函数
  • Set the value of the given option

ldap_set_option

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ldap_set_option — Set the value of the given option

说明

ldap_set_option ( resource|null $ldap , int $option , array|string|int|bool $value ) : bool

Sets the value of the specified option to be value.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

option

The parameter option can be one of:

Option | Type | Available since
LDAP_OPT_DEREF | int
LDAP_OPT_SIZELIMIT | int
LDAP_OPT_TIMELIMIT | int
LDAP_OPT_NETWORK_TIMEOUT | int
LDAP_OPT_PROTOCOL_VERSION | int
LDAP_OPT_ERROR_NUMBER | int
LDAP_OPT_REFERRALS | bool
LDAP_OPT_RESTART | bool
LDAP_OPT_HOST_NAME | string
LDAP_OPT_ERROR_STRING | string
LDAP_OPT_DIAGNOSTIC_MESSAGE | string
LDAP_OPT_MATCHED_DN | string
LDAP_OPT_SERVER_CONTROLS | array
LDAP_OPT_CLIENT_CONTROLS | array
LDAP_OPT_X_KEEPALIVE_IDLE | int | PHP 7.1.0
LDAP_OPT_X_KEEPALIVE_PROBES | int | PHP 7.1.0
LDAP_OPT_X_KEEPALIVE_INTERVAL | int | PHP 7.1.0
LDAP_OPT_X_TLS_CACERTDIR | string | PHP 7.1.0
LDAP_OPT_X_TLS_CACERTFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_CERTFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_CIPHER_SUITE | string | PHP 7.1.0
LDAP_OPT_X_TLS_CRLCHECK | int | PHP 7.1.0
LDAP_OPT_X_TLS_CRLFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_DHFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_KEYFILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_PROTOCOL_MIN | int | PHP 7.1.0
LDAP_OPT_X_TLS_RANDOM_FILE | string | PHP 7.1.0
LDAP_OPT_X_TLS_REQUIRE_CERT | int | PHP 7.0.5

LDAP_OPT_SERVER_CONTROLS and LDAP_OPT_CLIENT_CONTROLS require a list of controls, this means that the value must be an array of controls. A control consists of an oid identifying the control, an optional value, and an optional flag for criticality. In PHP a control is given by an array containing an element with the key oid and string value, and two optional elements. The optional elements are key value with string value and key iscritical with boolean value. iscritical defaults to false if not supplied. See » draft-ietf-ldapext-ldap-c-api-xx.txt for details. See also the second example below.

value

The new value for the specified option.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Set protocol version

<?php
// $ds is a valid link identifier for a directory server
if (ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3)) {
    echo "Using LDAPv3";
} else {
    echo "Failed to set protocol version to 3";
}
?>

Example #2 Set server controls

<?php
// $ds is a valid link identifier for a directory server
// control with no value
$ctrl1 = array("oid" => "1.2.752.58.10.1", "iscritical" => true);
// iscritical defaults to FALSE
$ctrl2 = array("oid" => "1.2.752.58.1.10", "value" => "magic");
// try to set both controls
if (!ldap_set_option($ds, LDAP_OPT_SERVER_CONTROLS, array($ctrl1, $ctrl2))) {
    echo "Failed to set server controls";
}
?>

注释

Note:

This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

参见

  • ldap_get_option() - Get the current value for given option


Set a callback function to do re-binds on referral chasing

  • ? ldap_set_option
  • ldap_sort ?
  • PHP Manual
  • LDAP 函数
  • Set a callback function to do re-binds on referral chasing

ldap_set_rebind_proc

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ldap_set_rebind_proc — Set a callback function to do re-binds on referral chasing

说明

ldap_set_rebind_proc ( resource $ldap , callable|null $callback ) : bool
Warning

本函数还未编写文档，仅有参数列表。

更新日志

版本 | 说明
8.0.0 | callback is nullable now.


Sort LDAP result entries on the client side

  • ? ldap_set_rebind_proc
  • ldap_start_tls ?
  • PHP Manual
  • LDAP 函数
  • Sort LDAP result entries on the client side

ldap_sort

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ldap_sort — Sort LDAP result entries on the client side

说明

ldap_sort ( resource $link , resource $result , string $sortfilter ) : bool

Sort the result of a LDAP search, returned by ldap_search().

As this function sorts the returned values on the client side it is possible that you might not get the expected results in case you reach the sizelimit either of the server or defined within ldap_search().

Warning

本特性已自 PHP 7.0.0 起废弃。强烈建议不要使用本特性。

参数

link

An LDAP link identifier, returned by ldap_connect().

result

An search result identifier, returned by ldap_search().

sortfilter

The attribute to use as a key in the sort.

范例

Sorting the result of a search.

Example #1 LDAP sort

<?php
     // $ds is a valid link identifier (see ldap_connect)

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     // Sort
     ldap_sort($ds, $sr, 'sn');

     // Retrieving the data
     $info = ldap_get_entries($ds, $sr);


Start TLS

  • ? ldap_sort
  • ldap_t61_to_8859 ?
  • PHP Manual
  • LDAP 函数
  • Start TLS

ldap_start_tls

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

ldap_start_tls — Start TLS

说明

ldap_start_tls ( resource $ldap ) : bool
Warning

本函数还未编写文档，仅有参数列表。


Translate t61 characters to 8859 characters

  • ? ldap_start_tls
  • ldap_unbind ?
  • PHP Manual
  • LDAP 函数
  • Translate t61 characters to 8859 characters

ldap_t61_to_8859

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

ldap_t61_to_8859 — Translate t61 characters to 8859 characters

说明

ldap_t61_to_8859 ( string $value ) : string|false
Warning

本函数还未编写文档，仅有参数列表。


Unbind from LDAP directory

  • ? ldap_t61_to_8859
  • Memcache ?
  • PHP Manual
  • LDAP 函数
  • Unbind from LDAP directory

ldap_unbind

(PHP 4, PHP 5, PHP 7, PHP 8)

ldap_unbind — Unbind from LDAP directory

说明

ldap_unbind ( resource $ldap ) : bool

Unbinds from the LDAP directory.

参数

ldap

An LDAP link identifier, returned by ldap_connect().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ldap_bind() - 绑定 LDAP 目录


Memcache

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Memcache — Memcache类
    • Memcache::add — 增加一个条目到缓存服务器
    • Memcache::addServer — 向连接池中添加一个memcache服务器
    • Memcache::close — 关闭memcache连接
    • Memcache::connect — 打开一个memcached服务端连接
    • Memcache::decrement — 减小元素的值
    • Memcache::delete — 从服务端删除一个元素
    • Memcache::flush — 清洗（删除）已经存储的所有的元素
    • Memcache::get — 从服务端检回一个元素
    • Memcache::getExtendedStats — 缓存服务器池中所有服务器统计信息
    • Memcache::getServerStatus — 用于获取一个服务器的在线/离线状态
    • Memcache::getStats — 获取服务器统计信息
    • Memcache::getVersion — 返回服务器版本信息
    • Memcache::increment — 增加一个元素的值
    • Memcache::pconnect — 打开一个到服务器的持久化连接
    • Memcache::replace — 替换已经存在的元素的值
    • Memcache::set — Store data at the server
    • Memcache::setCompressThreshold — 开启大值自动压缩
    • Memcache::setServerParams — 运行时修改服务器参数和状态
  • Memcache 函数
    • memcache_debug — 转换调试输出的开/关


简介

Memcache模块提供了于memcached方便的面向过程及面向对象的接口，memcached是为了降低动态web应用 从数据库加载数据而产生的一种常驻进程缓存产品。

Memcache模块同时提供了一个session 处理器 (memcache).

更多关于memcached的信息请参见» http://www.memcached.org/.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Memcache
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

此模块使用了函数 » zlib 来支持数据压缩，因此安装此模块需要安装 Zlib 模块。

PHP 4.3.3 及以后版本需要使用 memcache 扩展。


安装

此 » PECL 扩展未与 PHP 捆绑。 安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/memcache.

Note:

可以关闭memcache session处理器的支持。使用pecl install进行安装时，在静态编译到php中时使用选项 --disable-memcache-session可以关闭memcache的session 支持（默认时开启的）。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Memcache配置选项
名字 | 默认 | 可修改范围 | 更新日志
memcache.allow_failover | "1" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.max_failover_attempts | "20" | PHP_INI_ALL | Available since memcache 2.1.0.
memcache.chunk_size | "8192" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.default_port | "11211" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.hash_strategy | "standard" | PHP_INI_ALL | Available since memcache 2.2.0.
memcache.hash_function | "crc32" | PHP_INI_ALL | Available since memcache 2.2.0.
session.save_handler | "files" | PHP_INI_ALL | Supported since memcache 2.1.2
session.save_path | "" | PHP_INI_ALL | Supported since memcache 2.1.2
memcache.protocol | ascii | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.redundancy | 1 | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.session_redundancy | 2 | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.compress_threshold | 20000 | >PHP_INI_ALL | Supported since memcache 3.0.3
memcache.lock_timeout | 15 | >PHP_INI_ALL | Supported since memcache 3.0.4
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

memcache.allow_failover bool

是否在发生错误时（对用户）透明的转移到其他服务器。

memcache.max_failover_attempts int

定义在写入和获取数据时最多尝试的服务器次数（即：故障转移最大尝试数），仅和 memcache.allow_failover结合使用。

memcache.chunk_size int

数据传输块大小，这个值越小网络I/O次数越多，如果发现莫名的速度降低， 可以尝试将此值调至32768。

memcache.default_port string

在尝试连接memcache的时候如果没有单独指定端口默认使用的TCP端口号。

memcache.hash_strategy string

控制key到服务器的映射（分布式）策略。值 consistent允许服务器增减而不会（大量）导致健的重新映射 （译注：参见http://tech.idv2.com/2008/07/24/memcached-004/），设置为 standard则使用余数方式进行key的映射。

memcache.hash_function string

控制在key-server映射时使用哪个hash函数crc32 标明使用标准CRC32进行hash，fnv则说明使用FNV-1a。

session.save_handler string

当值为memcache时标记使用memcache作为session处理器。

session.save_path string

定义一个逗号分割的用于session存储的服务器url列表，例如： "tcp://host1:11211, tcp://host2:11211".

每个url可以包含参数，这些参数于方法Memcache::addServer()的参数相同。比如： "tcp://host1:11211?persistent=1&weight=1&timeout=1&retry_interval=15"

memcache.protocol string

memcache.redundancy int

memcache.session_redundancy int

memcache.compress_threshold int

memcache.lock_timeout int


  • ? 运行时配置
  • 预定义常量 ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

在memcache 模块中只有一个资源类型 - 它就是到一个缓存服务器连接的链接标识符。


预定义常量

Memcache 常量
常量名 | 描述
MEMCACHE_COMPRESSED (integer) | 用于在 Memcache::set(), Memcache::add() 和 Memcache::replace()几个方法中指定是否对写入数据压缩。
MEMCACHE_HAVE_SESSION (integer) | 1代表当前Memcache session处理器可用，其他为0


  • ? 预定义常量
  • ?
  • PHP Manual
  • Memcache
  • 范例

范例

Table of Contents


  • ? 范例
  • Memcache ?
  • PHP Manual
  • 范例

Example #1 memcache扩展概览示例

在这个例子中，一个对象被保存到缓存中，又被取回。对象和其他非标量类型在存储 之前会先被序列化，因此它不可以用来存储资源类型（连接标记及其他）。（译注：请注意隐式的 资源类型存储，比如要保存的对象自身不是资源，但其中某个属性却是资源）

<?php

$memcache = new Memcache;
$memcache->connect('localhost', 11211) or die ("Could not connect");

$version = $memcache->getVersion();
echo "服务端版本信息: ".$version."<br/>\n";

$tmp_object = new stdClass;
$tmp_object->str_attr = 'test';
$tmp_object->int_attr = 123;

$memcache->set('key', $tmp_object, false, 10) or die ("Failed to save data at the server");
echo "将数据保存到缓存中（数据10秒后失效）<br/>\n";

$get_result = $memcache->get('key');
echo "从缓存中取到的数据:<br/>\n";

var_dump($get_result);

?>

Example #2 使用memcache的session处理器

<?php

$session_save_path = "tcp://$host:$port?persistent=1&weight=2&timeout=2&retry_interval=10,  ,tcp://$host:$port  ";
ini_set('session.save_handler', 'memcache');
ini_set('session.save_path', $session_save_path);

?>


Memcache类

(PECL memcache >= 0.2.0)

简介

表示连接到一个服务器组的连接。

类摘要

Memcache {
add ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool
addServer ( string $host , int $port = 11211 , bool $persistent = ? , int $weight = ? , int $timeout = ? , int $retry_interval = ? , bool $status = ? , callback $failure_callback = ? , int $timeoutms = ? ) : bool
close ( ) : bool
connect ( string $host , int $port = ? , int $timeout = ? ) : bool
decrement ( string $key , int $value = 1 ) : int
delete ( string $key , int $timeout = 0 ) : bool
flush ( ) : bool
get ( string $key , int &$flags = ? ) : string
getExtendedStats ( string $type = ? , int $slabid = ? , int $limit = 100 ) : array
getServerStatus ( string $host , int $port = 11211 ) : int
getStats ( string $type = ? , int $slabid = ? , int $limit = 100 ) : array
getVersion ( ) : string
increment ( string $key , int $value = 1 ) : int
pconnect ( string $host , int $port = ? , int $timeout = ? ) : mixed
replace ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool
set ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool
setCompressThreshold ( int $threshold , float $min_savings = ? ) : bool
setServerParams ( string $host , int $port = 11211 , int $timeout = ? , int $retry_interval = false , bool $status = ? , callback $failure_callback = ? ) : bool
}

Table of Contents

  • Memcache::add — 增加一个条目到缓存服务器
  • Memcache::addServer — 向连接池中添加一个memcache服务器
  • Memcache::close — 关闭memcache连接
  • Memcache::connect — 打开一个memcached服务端连接
  • Memcache::decrement — 减小元素的值
  • Memcache::delete — 从服务端删除一个元素
  • Memcache::flush — 清洗（删除）已经存储的所有的元素
  • Memcache::get — 从服务端检回一个元素
  • Memcache::getExtendedStats — 缓存服务器池中所有服务器统计信息
  • Memcache::getServerStatus — 用于获取一个服务器的在线/离线状态
  • Memcache::getStats — 获取服务器统计信息
  • Memcache::getVersion — 返回服务器版本信息
  • Memcache::increment — 增加一个元素的值
  • Memcache::pconnect — 打开一个到服务器的持久化连接
  • Memcache::replace — 替换已经存在的元素的值
  • Memcache::set — Store data at the server
  • Memcache::setCompressThreshold — 开启大值自动压缩
  • Memcache::setServerParams — 运行时修改服务器参数和状态


增加一个条目到缓存服务器

  • ? Memcache
  • Memcache::addServer ?
  • PHP Manual
  • Memcache
  • 增加一个条目到缓存服务器

Memcache::add

(PECL memcache >= 0.2.0)

Memcache::add — 增加一个条目到缓存服务器

说明

Memcache::add ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool

Memcache::add()方法在缓存服务器之前不存在key时， 以key作为key存储一个变量var到缓存服务器。 同样可以使用函数memcache_add()。

参数

key

将要分配给变量的key。

var

将要被存储的变量。字符串和整型被以原文存储，其他类型序列化后存储。

flag

使用MEMCACHE_COMPRESSED标记对数据进行压缩(使用zlib)。

expire

当前写入缓存的数据的失效时间。如果此值设置为0表明此数据永不过期。你可以设置一个UNIX时间戳或 以秒为单位的整数（从当前算起的时间差）来说明此数据的过期时间，但是在后一种设置方式中，不能超过 2592000秒（30天）。

返回值

成功时返回 true， 或者在失败时返回 false。 如果这个key已经存在返回false。 Memcache::add()方法的其他行为类似 Memcache::set()。

范例

Example #1 Memcache::add()示例

<?php

$memcache_obj = memcache_connect("localhost", 11211);

/* 面向过程编程 API */
memcache_add($memcache_obj, 'var_key', 'test variable', false, 30);

/* 面向对象编程 API */
$memcache_obj->add('var_key', 'test variable', false, 30);

?>

参见

  • Memcache::set() - Store data at the server
  • Memcache::replace() - 替换已经存在的元素的值


向连接池中添加一个memcache服务器

  • ? Memcache::add
  • Memcache::close ?
  • PHP Manual
  • Memcache
  • 向连接池中添加一个memcache服务器

Memcache::addServer

(PECL memcache >= 2.0.0)

Memcache::addServer — 向连接池中添加一个memcache服务器

说明

Memcache::addServer ( string $host , int $port = 11211 , bool $persistent = ? , int $weight = ? , int $timeout = ? , int $retry_interval = ? , bool $status = ? , callback $failure_callback = ? , int $timeoutms = ? ) : bool

Memcache::addServer()增加一个服务器到连接池中。通过Memcache::addServer() 打开的连接将会在脚本执行结束后自动关闭，也可以使用Memcache::close()进行手动关闭。 您也可以使用memcache_add_server()来添加服务器。

当使用这个方法的时候(与Memcache::connect()和Memcache::pconnect()相反) 网络连接并不会立刻建立，而是直到真正使用的时候才建立。 因此在加入大量服务器到连接池中时也是没有开销的，因为它们可能并不会被使用。

故障转移可能在方法的任何一个层次发生，通常只要其他服务器可用用户就不会感受到。任何的socket或memcache服务器级别的错误 （比如内存溢出）都可能导致故障转移。而一般的客户端错误比如使用Memcache::add尝试增加一个已经存在的key则不会导致故障转移。

Note:

这个方法在2.0.0版本加入Memcache。

参数

host

要连接的memcached服务端监听的主机位置。这个参数通常指定其他类型的传输比如Unix域套接字使用 unix:///path/to/memcached.sock，这种情况下参数port 必须设置为0。

port

要连接的memcached服务端监听的端口。当使用UNIX域套接字连接时设置为0。

persistent

控制是否使用持久化连接。默认true。

weight

为此服务器创建的桶的数量，用来控制此服务器被选中的权重，单个服务器被选中的概率是相对于所有服务器weight总和而言的。

timeout

连接持续（超时）时间（单位秒），默认值1秒，修改此值之前请三思，过长的连接持续时间可能会导致失去所有的缓存优势。

retry_interval

服务器连接失败时重试的间隔时间，默认值15秒。如果此参数设置为-1表示不重试。此参数和persistent参数在扩展以 dl()函数动态加载的时候无效。

每个失败的连接结构有自己的超时时间，并且在它失效之前选择后端服务请求时该结构会被跳过。一旦一个连接失效， 它将会被成功重新连接或被标记为失败连接以在下一个retry_interval秒重连。 典型的影响是每个web服务子进程在服务于一个页面时将会每retry_interval秒 尝试重新连接一次。

status

控制此服务器是否可以被标记为在线状态。设置此参数值为false并且retry_interval参数 设置为-1时允许将失败的服务器保留在一个池中以免影响key的分配算法。对于这个服务器的请求会进行故障转移或者立即失败， 这受限于memcache.allow_failover参数的设置。该参数默认true，表明允许进行故障转移。

failure_callback

允许用户指定一个运行时发生错误后的回调函数。回调函数会在故障转移之前运行。回调函数会接受到两个参数，分别是失败主机的 主机名和端口号。

timeoutms

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::addServer() 示例

<?php

/* OO API */

$memcache = new Memcache;
$memcache->addServer('memcache_host', 11211);
$memcache->addServer('memcache_host2', 11211);

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_add_server($memcache_obj, 'memcache_host2', 11211);

?>

参见

  • Memcache::connect() - 打开一个memcached服务端连接
  • Memcache::pconnect() - 打开一个到服务器的持久化连接
  • Memcache::close() - 关闭memcache连接
  • Memcache::setServerParams() - 运行时修改服务器参数和状态
  • Memcache::getServerStatus() - 用于获取一个服务器的在线/离线状态


关闭memcache连接

  • ? Memcache::addServer
  • Memcache::connect ?
  • PHP Manual
  • Memcache
  • 关闭memcache连接

Memcache::close

(PECL memcache >= 0.4.0)

Memcache::close — 关闭memcache连接

说明

Memcache::close ( ) : bool

Memcache::close()关闭到memcached服务端的连接。这个函数不会关闭持久化连接， 持久化连接仅仅会在web服务器关机/重启时关闭。与之对应的，你也可以使用memcache_close()函数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::close()示例

<?php

/* 面向过程 API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/*
do something here ..
*/
memcache_close($memcache_obj);

/* 面向对象 API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/*
do something here ..
*/
$memcache_obj->close();

?>

参见

  • Memcache::connect() - 打开一个memcached服务端连接
  • Memcache::pconnect() - 打开一个到服务器的持久化连接


打开一个memcached服务端连接

  • ? Memcache::close
  • Memcache::decrement ?
  • PHP Manual
  • Memcache
  • 打开一个memcached服务端连接

Memcache::connect

(PECL memcache >= 0.2.0)

Memcache::connect — 打开一个memcached服务端连接

说明

Memcache::connect ( string $host , int $port = ? , int $timeout = ? ) : bool

Memcache::connect()建立一个到memcached服务端的连接。 使用方法
Memcache::connect()打开的连接在脚本执行结束后会自动关闭。当然，你也可以使用方法
Memcache::close()来主动关闭。
同时你也可以使用memcache_connect()函数来获取一个连接。

参数

host

memcached服务端监听主机地址。这个参数也可以指定为其他传输方式比如unix:///path/to/memcached.sock 来使用Unix域socket，在这种方式下，port参数必须设置为0。

port

memcached服务端监听端口。当使用Unix域socket的时候要设置此参数为0。

timeout

连接持续（超时）时间，单位秒。默认值1秒，修改此值之前请三思，过长的连接持续时间可能会导致失去所有的缓存优势。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::connect() example

<?php

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);

/* OO API */

$memcache = new Memcache;
$memcache->connect('memcache_host', 11211);

?>

参见

  • Memcache::pconnect() - 打开一个到服务器的持久化连接
  • Memcache::close() - 关闭memcache连接


减小元素的值

  • ? Memcache::connect
  • Memcache::delete ?
  • PHP Manual
  • Memcache
  • 减小元素的值

Memcache::decrement

(PECL memcache >= 0.2.0)

Memcache::decrement — 减小元素的值

说明

Memcache::decrement ( string $key , int $value = 1 ) : int

Memcache::decrement()方法将元素的值减小value。 类似于 Memcache::increment()方法，首先将元素当前值转换成数值然后减去value。

Note:

新的元素的值不会小于0。

Note:

不要将Memcache::decrement()方法用于压缩存储的元素，那样作会导致 Memcache::get()方法获取值会失败。

Memcache::decrement()在元素不存在时不能创建它。 同样可以使用memcache_decrement()函数来完成相同的工作。

参数

key

要减小值的元素的key。

value

value参数指要将指定元素的值减小多少。

返回值

成功的时候返回元素的新值 或者在失败时返回 false

范例

Example #1 Memcache::decrement() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/* 将test_item对应的值减小2 */
$new_value = memcache_decrement($memcache_obj, 'test_item', 2);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/* decrement item by 3 */
$new_value = $memcache_obj->decrement('test_item', 3);
?>

参见

  • Memcache::increment() - 增加一个元素的值
  • Memcache::replace() - 替换已经存在的元素的值


从服务端删除一个元素

  • ? Memcache::decrement
  • Memcache::flush ?
  • PHP Manual
  • Memcache
  • 从服务端删除一个元素

Memcache::delete

(PECL memcache >= 0.2.0)

Memcache::delete — 从服务端删除一个元素

说明

Memcache::delete ( string $key , int $timeout = 0 ) : bool

Memcache::delete()函数通过key删除一个元素。 如果参数timeout指定，该元素会在timeout秒后失效。 同样也可以使用memcache_delete()函数完成同样功能。

参数

key

要删除的元素的key。

timeout

删除该元素的执行时间。如果值为0,则该元素立即删除，如果值为30,元素会在30秒内被删除。

更新日志

版本 | 说明
Unknown | It's not recommended to use the timeout parameter. The behavior differs between memcached versions, but setting to 0 is safe. Other values for this deprecated feature may cause the memcache delete to fail.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::delete() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);

/* 10秒后key_to_delete对应的值会被从服务端删除 */
memcache_delete($memcache_obj, 'key_to_delete', 10);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);

$memcache_obj->delete('key_to_delete', 10);

?>

参见

  • Memcache::set() - Store data at the server
  • Memcache::replace() - 替换已经存在的元素的值


清洗（删除）已经存储的所有的元素

  • ? Memcache::delete
  • Memcache::get ?
  • PHP Manual
  • Memcache
  • 清洗（删除）已经存储的所有的元素

Memcache::flush

(PECL memcache >= 1.0.0)

Memcache::flush — 清洗（删除）已经存储的所有的元素

说明

Memcache::flush ( ) : bool

Memcache::flush()立即使所有已经存在的元素失效。方法Memcache::flush() 并不会真正的释放任何资源，而是仅仅标记所有元素都失效了，因此已经被使用的内存会被新的元素复写。 同样你也可以使用函数memcache_flush()完成相同功能。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::flush()示例

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);

memcache_flush($memcache_obj);

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);

$memcache_obj->flush();

?>


从服务端检回一个元素

  • ? Memcache::flush
  • Memcache::getExtendedStats ?
  • PHP Manual
  • Memcache
  • 从服务端检回一个元素

Memcache::get

(PECL memcache >= 0.2.0)

Memcache::get — 从服务端检回一个元素

说明

Memcache::get ( string $key , int &$flags = ? ) : string
Memcache::get ( array $keys , array &$flags = ? ) : array

如果服务端之前有以key作为key存储的元素，Memcache::get()方法此时返回之前存储的值。

你可以给Memcache::get()方法传递一个数组（多个key）来获取一个数组的元素值，返回的数组仅仅包含从 服务端查找到的key-value对。

参数

key

要获取值的key或key数组。

flags

如果给定这个参数（以引用方式传递），该参数会被写入一些key对应的信息。这些标记和Memcache::set()方法中的同名参数 意义相同。用int值的低位保留了pecl/memcache的内部用法（比如：用来说明压缩和序列化状态）。（译注：最后一位表明是否序列化，倒数第二位表明是否经过压缩， 比如：如果此值为1表示经过序列化，但未经过压缩，2表明压缩而未序列化，3表明压缩并且序列化，0表明未经过压缩和序列化，具体算法可查找linux文件权限算法相关资料）

返回值

返回key对应的存储元素的字符串值或者在失败或key未找到的时候返回false。

范例

Example #1 Memcache::get() 示例

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
$var = memcache_get($memcache_obj, 'some_key');

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
$var = $memcache_obj->get('some_key');

/*
你同样可以使用数组key作为参数，如果某个元素没有在服务端发现，结果数组中将不会包含这些key。
*/

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
$var = memcache_get($memcache_obj, Array('some_key', 'another_key'));

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
$var = $memcache_obj->get(Array('some_key', 'second_key'));

?>


缓存服务器池中所有服务器统计信息

  • ? Memcache::get
  • Memcache::getServerStatus ?
  • PHP Manual
  • Memcache
  • 缓存服务器池中所有服务器统计信息

Memcache::getExtendedStats

(PECL memcache >= 2.0.0)

Memcache::getExtendedStats — 缓存服务器池中所有服务器统计信息

说明

Memcache::getExtendedStats ( string $type = ? , int $slabid = ? , int $limit = 100 ) : array

Memcache::getExtendedStats() 返回一个二维关联数据的服务器统计信息。数组的key由host:port方式 组成，无效的服务器返回的统计信息被设置为false，同样的，你可以使用函数memcache_get_extended_stats()。

Note:

这个函数在Memcache2.0.0版本加入。

Note:

(译注)获取Memcache内所有数据方法：首先使用getExtendedStats('slabs')获取到每个服务器上活动slabs分块的id， 然后 使用getExtendedStats('cachedump', $slabid, $limit)来获取每个slab里面缓存的项，其中$slabid是slab分块id， $limit指 期望获取其中的多少条记录。

参数

type

期望抓取的统计信息类型，可以使用的值有{reset, malloc, maps, cachedump, slabs, items, sizes}。 通过memcached协议指定这些附加参数是为了方便memcache开发者(检查其中的变动)。

slabid

用于与参数type联合从指定slab分块拷贝数据，cachedump命令会完全占用服务器通常用于 比较严格的调试。

limit

用于和参数type联合来设置cachedump时从服务端获取的实体条数。

返回值

返回一个二维关联数组的服务器统计信息或者在失败时返回false。

范例

Example #1 Memcache::getExtendedStats() 示例

<?php
    $memcache_obj = new Memcache;
    $memcache_obj->addServer('memcache_host', 11211);
    $memcache_obj->addServer('failed_host', 11211);

    $stats = $memcache_obj->getExtendedStats();
    print_r($stats);
?>

以上例程会输出：

Array
(
    [memcache_host:11211] => Array
        (
            [pid] => 3756
            [uptime] => 603011
            [time] => 1133810435
            [version] => 1.1.12
            [rusage_user] => 0.451931
            [rusage_system] => 0.634903
            [curr_items] => 2483
            [total_items] => 3079
            [bytes] => 2718136
            [curr_connections] => 2
            [total_connections] => 807
            [connection_structures] => 13
            [cmd_get] => 9748
            [cmd_set] => 3096
            [get_hits] => 5976
            [get_misses] => 3772
            [bytes_read] => 3448968
            [bytes_written] => 2318883
            [limit_maxbytes] => 33554432
        )

    [failed_host:11211] => false
)

参见

  • Memcache::getVersion() - 返回服务器版本信息
  • Memcache::getStats() - 获取服务器统计信息


用于获取一个服务器的在线/离线状态

  • ? Memcache::getExtendedStats
  • Memcache::getStats ?
  • PHP Manual
  • Memcache
  • 用于获取一个服务器的在线/离线状态

Memcache::getServerStatus

(PECL memcache >= 2.1.0)

Memcache::getServerStatus — 用于获取一个服务器的在线/离线状态

说明

Memcache::getServerStatus ( string $host , int $port = 11211 ) : int

Memcache::getServerStatus()返回一个服务器的在线/离线状态，你也同样可以使用 函数memcache_get_server_status()。

Note:

这个函数在memcache2.1.0版本加入。

参数

host

主机监听地址。

port

主机监听端口，默认11211.

返回值

返回一个服务器的状态，0表示服务器离线，非0表示在线。

范例

Example #1 Memcache::getServerStatus() 示例

<?php

/* OO API */
$memcache = new Memcache;
$memcache->addServer('memcache_host', 11211);
echo $memcache->getServerStatus('memcache_host', 11211);

/* procedural API */
$memcache = memcache_connect('memcache_host', 11211);
echo memcache_get_server_status($memcache, 'memcache_host', 11211);

?>

参见

  • Memcache::addServer() - 向连接池中添加一个memcache服务器
  • Memcache::setServerParams() - 运行时修改服务器参数和状态


获取服务器统计信息

  • ? Memcache::getServerStatus
  • Memcache::getVersion ?
  • PHP Manual
  • Memcache
  • 获取服务器统计信息

Memcache::getStats

(PECL memcache >= 0.2.0)

Memcache::getStats — 获取服务器统计信息

说明

Memcache::getStats ( string $type = ? , int $slabid = ? , int $limit = 100 ) : array

Memcache::getStats()返回一个关联数据的服务器统计信息。数组key是统计信息名， 值就是统计信息的值。同样你可以使用函数memcache_get_stats()。

参数

type

期望抓取的统计信息类型，可以使用的值有{reset, malloc, maps, cachedump, slabs, items, sizes}。 通过memcached协议指定这些附加参数是为了方便memcache开发者(检查其中的变动)。

slabid

用于与参数type联合从指定slab分块拷贝数据，cachedump命令会完全占用服务器通常用于 比较严格的调试。

limit

用于和参数type联合来设置cachedump时从服务端获取的实体条数。

返回值

返回关联数组表示的服务器统计信息 或者在失败时返回 false

参见

  • Memcache::getVersion() - 返回服务器版本信息
  • Memcache::getExtendedStats() - 缓存服务器池中所有服务器统计信息


返回服务器版本信息

  • ? Memcache::getStats
  • Memcache::increment ?
  • PHP Manual
  • Memcache
  • 返回服务器版本信息

Memcache::getVersion

(PECL memcache >= 0.2.0)

Memcache::getVersion — 返回服务器版本信息

说明

Memcache::getVersion ( ) : string

Memcache::getVersion()返回一个字符串表示的服务端版本号。 同样你也可以使用函数memcache_get_version()。

返回值

返回服务端版本号 或者在失败时返回 false

范例

Example #1 Memcache::getVersion() 示例

<?php

/* OO API */
$memcache = new Memcache;
$memcache->connect('memcache_host', 11211);
echo $memcache->getVersion();

/* procedural API */
$memcache = memcache_connect('memcache_host', 11211);
echo memcache_get_version($memcache);

?>

参见

  • Memcache::getExtendedStats() - 缓存服务器池中所有服务器统计信息
  • Memcache::getStats() - 获取服务器统计信息


增加一个元素的值

  • ? Memcache::getVersion
  • Memcache::pconnect ?
  • PHP Manual
  • Memcache
  • 增加一个元素的值

Memcache::increment

(PECL memcache >= 0.2.0)

Memcache::increment — 增加一个元素的值

说明

Memcache::increment ( string $key , int $value = 1 ) : int

Memcache::increment()将指定元素的值增加value。如果指定的key 对应的元素不是数值类型并且不能被转换为数值， 会将此值修改为value. Memcache::increment() 不会在key对应元素不存在时创建元素。

Note:

不要在经过压缩存储的元素上使用Memcache::increment()，因为这样作会导致后续对Memcache::get()的调用失败。

同样你也可以使用函数memcache_increment()。

参数

key

将要增加值的元素的key。

value

参数value表明要将指定元素值增加多少。

返回值

成功时返回新的元素值 或者在失败时返回 false

范例

Example #1 Memcache::increment()示例

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/* increment counter by 2 */
$current_value = memcache_increment($memcache_obj, 'counter', 2);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/* increment counter by 3 */
$current_value = $memcache_obj->increment('counter', 3);

?>

参见

  • Memcache::decrement() - 减小元素的值
  • Memcache::replace() - 替换已经存在的元素的值


打开一个到服务器的持久化连接

  • ? Memcache::increment
  • Memcache::replace ?
  • PHP Manual
  • Memcache
  • 打开一个到服务器的持久化连接

Memcache::pconnect

(PECL memcache >= 0.4.0)

Memcache::pconnect — 打开一个到服务器的持久化连接

说明

Memcache::pconnect ( string $host , int $port = ? , int $timeout = ? ) : mixed

Memcache::pconnect()和
Memcache::connect()非常类似，不同点在于这里建立的连接是持久化的。
这个连接不会在脚本执行结束后或者Memcache::close()被调用后关闭。
同样你也可以使用函数memcache_pconnect()。

参数

host

服务端监听的主机地址。这个参数还可以指定为其他传输方式比如unix:///path/to/memcached.sock 来使用Unix域套接字，使用这种方式port参数必须设置为0。

port

服务端监听的端口号。使用Unix域套接字的时候需要将这个参数设置为0。

timeout

连接持续（超时）时间，单位秒。默认值1秒，修改此值之前请三思，过长的连接持续时间可能会导致失去所有的缓存优势。

返回值

返回一个 Memcache 对象 或者在失败时返回 false.

范例

Example #1 Memcache::pconnect()示例

<?php

/* procedural API */
$memcache_obj = memcache_pconnect('memcache_host', 11211);

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->pconnect('memcache_host', 11211);

?>

参见

  • Memcache::connect() - 打开一个memcached服务端连接


替换已经存在的元素的值

  • ? Memcache::pconnect
  • Memcache::set ?
  • PHP Manual
  • Memcache
  • 替换已经存在的元素的值

Memcache::replace

(PECL memcache >= 0.2.0)

Memcache::replace — 替换已经存在的元素的值

说明

Memcache::replace ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool

Memcache::replace()通过key来查找元素并替换其值。当key
对应的元素不存在时，Memcache::replace()返回false。其他方面Memcache::replace()
的行为和Memcache::set()一样。
同样你也可以使用函数memcache_replace()。

参数

key

期望替换值的元素的key。

var

将要存储的新的值，字符串和数值直接存储，其他类型序列化后存储。

flag

使用MEMCACHE_COMPRESSED指定对值进行压缩(使用zlib)。

expire

当前写入缓存的数据的失效时间。如果此值设置为0表明此数据永不过期。你可以设置一个UNIX时间戳或 以秒为单位的整数（从当前算起的时间差）来说明此数据的过期时间，但是在后一种设置方式中，不能超过 2592000秒（30天）。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::replace()示例

<?php

$memcache_obj = memcache_connect('memcache_host', 11211);

/* procedural API */
memcache_replace($memcache_obj, "test_key", "some variable", false, 30);

/* OO API */
$memcache_obj->replace("test_key", "some variable", false, 30);

?>

参见

  • Memcache::set() - Store data at the server
  • Memcache::add() - 增加一个条目到缓存服务器


Store data at the server

  • ? Memcache::replace
  • Memcache::setCompressThreshold ?
  • PHP Manual
  • Memcache
  • Store data at the server

Memcache::set

(PECL memcache >= 0.2.0)

Memcache::set — Store data at the server

说明

Memcache::set ( string $key , mixed $var , int $flag = ? , int $expire = ? ) : bool

Memcache::set()向key存储一个元素值为 var。参数expire是以秒为单位的失效时间， 如果设置为0表明该元素永不过期（但是它可能会因为为了给其他项分配空间而被删除）。如果你希望存储的元素 经过压缩（使用zlib），你可以设置flag的值为MEMCACHE_COMPRESSED。

Note:

谨记：资源类型变量（比如文件或连接）不能被存储在缓存中，因为它们在序列化状态不能被完整描述。

同样你也可以使用函数memcache_set()。

参数

key

要设置值的key。

var

要存储的值，字符串和数值直接存储，其他类型序列化后存储。

flag

使用MEMCACHE_COMPRESSED指定对值进行压缩(使用zlib)。

expire

当前写入缓存的数据的失效时间。如果此值设置为0表明此数据永不过期。你可以设置一个UNIX时间戳或 以秒为单位的整数（从当前算起的时间差）来说明此数据的过期时间，但是在后一种设置方式中，不能超过 2592000秒（30天）。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::set() 示例

<?php
/* procedural API */

/* connect to memcached server */
$memcache_obj = memcache_connect('memcache_host', 11211);

/*
设置'var_key'对应存储的值
flag参数使用0,值没有经过压缩
失效时间为30秒
*/
memcache_set($memcache_obj, 'var_key', 'some variable', 0, 30);

echo memcache_get($memcache_obj, 'var_key');

?>

Example #2 Memcache::set() 示例

<?php
/* OO API */

$memcache_obj = new Memcache;

/* connect to memcached server */
$memcache_obj->connect('memcache_host', 11211);

/*
设置'var_key'对应值，使用即时压缩
失效时间为50秒
*/
$memcache_obj->set('var_key', 'some really big variable', MEMCACHE_COMPRESSED, 50);

echo $memcache_obj->get('var_key');

?>

参见

  • Memcache::add() - 增加一个条目到缓存服务器
  • Memcache::replace() - 替换已经存在的元素的值


开启大值自动压缩

  • ? Memcache::set
  • Memcache::setServerParams ?
  • PHP Manual
  • Memcache
  • 开启大值自动压缩

Memcache::setCompressThreshold

(PECL memcache >= 2.0.0)

Memcache::setCompressThreshold — 开启大值自动压缩

说明

Memcache::setCompressThreshold ( int $threshold , float $min_savings = ? ) : bool

Memcache::setCompressThreshold()开启对于大值的自动压缩。 同样你也可以使用函数memcache_set_compress_threshold()。

Note:

此函数在memcache2.0.0加入。

参数

threshold

控制多大值进行自动压缩的阈值。

min_saving

指定经过压缩实际存储的值的压缩率，支持的值必须在0和1之间。默认值是0.2表示20%压缩率。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::setCompressThreshold() 示例

<?php

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->addServer('memcache_host', 11211);
$memcache_obj->setCompressThreshold(20000, 0.2);

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_set_compress_threshold($memcache_obj, 20000, 0.2);

?>


运行时修改服务器参数和状态

  • ? Memcache::setCompressThreshold
  • Memcache 函数 ?
  • PHP Manual
  • Memcache
  • 运行时修改服务器参数和状态

Memcache::setServerParams

(PECL memcache >= 2.1.0)

Memcache::setServerParams — 运行时修改服务器参数和状态

说明

Memcache::setServerParams ( string $host , int $port = 11211 , int $timeout = ? , int $retry_interval = false , bool $status = ? , callback $failure_callback = ? ) : bool

Memcache::setServerParams()用于运行时修改服务器参数。 同样你可以使用函数memcache_set_server_params()。

Note:

在memcache2.1.0加入。

参数

host

服务端监听地址。

port

服务端监听端口。

timeout

连接持续（超时）时间（单位秒），默认值1秒，修改此值之前请三思，过长的连接持续时间可能会导致失去所有的缓存优势。

retry_interval

服务器连接失败时重试的间隔时间，默认值15秒。如果此参数设置为-1表示不重试。此参数和persistent参数在扩展以 dl()函数动态加载的时候无效。

status

控制此服务器是否可以被标记为在线状态。设置此参数值为false并且retry_interval参数 设置为-1时允许将失败的服务器保留在一个池中以免影响key的分配算法。对于这个服务器的请求会进行故障转移或者立即失败， 这受限于memcache.allow_failover参数的设置。该参数默认true，表明允许进行故障转移。

failure_callback

允许用户指定一个运行时发生错误后的回调函数。回调函数会在故障转移之前运行。回调函数会接受到两个参数，分别是失败主机的 主机名和端口号。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcache::setServerParams() 示例

<?php

function _callback_memcache_failure($host, $port) {
    print "memcache '$host:$port' failed";
}

/* OO API */

$memcache = new Memcache;

// 增加一台离线服务器
$memcache->addServer('memcache_host', 11211, false, 1, 1, -1, false);

// 使该服务器变为在线状态
$memcache->setServerParams('memcache_host', 11211, 1, 15, true, '_callback_memcache_failure');

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_set_server_params($memcache_obj, 'memcache_host', 11211, 1, 15, true, '_callback_memcache_failure');

?>

参见

  • Memcache::addServer() - 向连接池中添加一个memcache服务器
  • Memcache::getServerStatus() - 用于获取一个服务器的在线/离线状态


  • ? Memcache::setServerParams
  • memcache_debug ?
  • PHP Manual
  • Memcache
  • Memcache 函数

Memcache 函数

Table of Contents

  • memcache_debug — 转换调试输出的开/关


转换调试输出的开/关

  • ? Memcache 函数
  • Memcached ?
  • PHP Manual
  • Memcache 函数
  • 转换调试输出的开/关

memcache_debug

(PECL memcache >= 0.2.0)

memcache_debug — 转换调试输出的开/关

说明

memcache_debug ( bool $on_off ) : bool

memcache_debug()在参数 on_off设置为true时打开调试输出，在值为 false时关闭调试输出。

Note:

memcache_debug()仅仅在PHP以--enable-debug方式编译时可以访问，并且 总是返回true，其他情况下此函数不会产生任何影响并总是返回false。

参数

on_off

true表明打开调试输出。 false表明关闭调试输出。

返回值

当PHP以--enalbe-debug选项构建时返回true其他情况下返回false。


Memcached

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 超时时间
  • 回调
    • 结果回调
    • 通读缓存回调
  • Sessions支持
  • Memcached — Memcached类
    • Memcached::add — 向一个新的key下面增加一个元素
    • Memcached::addByKey — 在指定服务器上的一个新的key下增加一个元素
    • Memcached::addServer — 向服务器池中增加一个服务器
    • Memcached::addServers — 向服务器池中增加多台服务器
    • Memcached::append — 向已存在元素后追加数据
    • Memcached::appendByKey — 向指定服务器上已存在元素后追加数据
    • Memcached::cas — 比较并交换值
    • Memcached::casByKey — 在指定服务器上比较并交换值
    • Memcached::__construct — 创建一个Memcached实例
    • Memcached::decrement — 减小数值元素的值
    • Memcached::decrementByKey — Decrement numeric item's value, stored on a specific server
    • Memcached::delete — 删除一个元素
    • Memcached::deleteByKey — 从指定的服务器删除一个元素
    • Memcached::deleteMulti — Delete multiple items
    • Memcached::deleteMultiByKey — Delete multiple items from a specific server
    • Memcached::fetch — 抓取下一个结果
    • Memcached::fetchAll — 抓取所有剩余的结果
    • Memcached::flush — 作废缓存中的所有元素
    • Memcached::get — 检索一个元素
    • Memcached::getAllKeys — Gets the keys stored on all the servers
    • Memcached::getByKey — 从特定的服务器检索元素
    • Memcached::getDelayed — 请求多个元素
    • Memcached::getDelayedByKey — 从指定的服务器上请求多个元素
    • Memcached::getMulti — 检索多个元素
    • Memcached::getMultiByKey — 从特定服务器检索多个元素
    • Memcached::getOption — 获取Memcached的选项值
    • Memcached::getResultCode — 返回最后一次操作的结果代码
    • Memcached::getResultMessage — 返回最后一次操作的结果描述消息
    • Memcached::getServerByKey — 获取一个key所映射的服务器信息
    • Memcached::getServerList — 获取服务器池中的服务器列表
    • Memcached::getStats — 获取服务器池的统计信息
    • Memcached::getVersion — 获取服务器池中所有服务器的版本信息
    • Memcached::increment — 增加数值元素的值
    • Memcached::incrementByKey — Increment numeric item's value, stored on a specific server
    • Memcached::isPersistent — Check if a persitent connection to memcache is being used
    • Memcached::isPristine — Check if the instance was recently created
    • Memcached::prepend — 向一个已存在的元素前面追加数据
    • Memcached::prependByKey — Prepend data to an existing item on a specific server
    • Memcached::quit — 关闭所有打开的链接。
    • Memcached::replace — 替换已存在key下的元素
    • Memcached::replaceByKey — Replace the item under an existing key on a specific server
    • Memcached::resetServerList — Clears all servers from the server list
    • Memcached::set — 存储一个元素
    • Memcached::setByKey — 将元素存储到指定的服务器上
    • Memcached::setMulti — 存储多个元素
    • Memcached::setMultiByKey — Store multiple items on a specific server
    • Memcached::setOption — 设置一个memcached选项
    • Memcached::setOptions — Set Memcached options
    • Memcached::setSaslAuthData — Set the credentials to use for authentication
    • Memcached::touch — Set a new expiration on an item
    • Memcached::touchByKey — Set a new expiration on an item on a specific server


简介

» memcached是一个高性能分布式的内存对象缓存系统， 通常被用于降低数据库加载压力以提高动态web应用的响应速度。

此扩展使用了libmemcached库提供的api与memcached服务端进行交互。它同样提供了一个session处理器（memcached）。 它同时提供了一个session处理器（memcached）。

关于libmemcached的更多信息可以在» http://libmemcached.org/libMemcached.html查看。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Memcached
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

这个扩展需要» libmemcached客户端库（版本大于等于 1.0.0）。链接memcached服务器时使用SASL认证，需要libmemcached 必须开启SASL选项。

Memcached从0.2.0开始，要求PHP版本大于等于5.2.0。


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/memcached.

如果libmemcached被安装在一个非标准路径，使用--with-libmemcached-dir=DIR 来指定路径，DIR就是libmemcached安装时的prefix参数。这个路径需要包含文件include/libmemcached/memcached.h。

如果要支持压缩就需要zlib。对于非标准安装的zlib库，使用--with-zlib-dir=DIR 来指定zlib安装路径，DIR就是zib安装时的prefix参数。

session处理器的支持默认是开启的。如果要关闭它，使用选项--disable-memcached-session。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Memcached配置选项
名字 | 默认 | 可修改范围 | 更新日志
memcached.sess_locking | 1 | PHP_INI_ALL |
memcached.sess_consistent_hash | 0 | PHP_INI_ALL |
memcached.sess_binary | 0 | PHP_INI_ALL |
memcached.sess_lock_wait | 150000 | PHP_INI_ALL |
memcached.sess_prefix | memc.sess.key. | PHP_INI_ALL |
memcached.sess_number_of_replicas | 0 | PHP_INI_ALL |
memcached.sess_randomize_replica_read | 0 | PHP_INI_ALL |
memcached.sess_remove_failed | 0 | PHP_INI_ALL |
memcached.compression_type | fastlz | PHP_INI_ALL |
memcached.compression_factor | 1.3 | PHP_INI_ALL |
memcached.compression_threshold | 2000 | PHP_INI_ALL |
memcached.serializer | php | PHP_INI_ALL |
memcached.use_sasl | 0 | PHP_INI_SYSTEM |

这是配置指令的简短说明。

memcached.sess_locking integer

开启session支持。有效值: On, Off, 默认值 On.

memcached.sess_consistent_hash integer

Memcached 是否使用一致性哈希保存session。如果为On，session数据保存则使用一致性哈希模式。 使用一致性哈希，可以保证你在增加或删除memcached服务器节点的时候不会导致session大规模的失效。 默认此项是关闭的。

memcached.sess_binary integer

Memcached session是否使用二进制模式。如果Libmemcached 开启二进制模式。默认值是 Off.

memcached.sess_lock_wait integer

Session 自旋锁等待时间（微秒）。请小心设置此值。值的类型是整数，当此值被设置为0的时候，lock wait的时间将会使用系统默认值，Memcached扩展中默认值是150000。

memcached.sess_prefix string

设置memcached session key的前缀。session前缀最长为219字节长的字符串。默认值是"memc.sess.key."。

memcached.sess_number_of_replicas integer

使用memcached写session多少个副本。

memcached.sess_randomize_replica_read integer

Memcached session 是否随机复制读。默认值0

memcached.sess_remove_failed integer

是否允许自动剔除出故障的memcached服务器。默认值0

memcached.compression_type string

设置memcached的压缩类型，允许的值为fastlz, zlib。默认值是fastlz（快速无损压缩，性能不错）。

memcached.compression_factor float

压缩因子. 保存时压缩因子超过设置的极限才会将数据压缩存储。存储压缩条件： plain_len > comp_len * factor。默认是1.3 （节省23%的空间）。

memcached.compression_threshold integer

压缩阈值。不压缩的序列化值低于此阈值。默认值是2000字节。

memcached.serializer string

设置缓存对象的默认序列化程序。有效值： php, igbinary, json, json_array.

json

标准的PHP JSON编码。此序列化程序快速而且是压缩后的数据，但是处理UTF-8编码数据时会不完全实现序列化。请查看JSON扩展。

json_array

json序列化，但是反序列化的时候返回数组。

php

PHP标准序列化

igbinary

二进制序列化

如果二进制序列化可用，则优先使用二进制序列化，否则使用php标准序列化。

memcached.use_sasl integer

链接memcached服务器时启用SASL认证。有效值On, Off。默认值是Off。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Memcached::OPT_COMPRESSION

开启或关闭压缩功能。当开启的时候，item的值超过某个阈值（当前是100bytes）时，会首先对值进行压缩然后存储，并 在获取该值时进行解压缩然后返回，使得压缩对应用层透明。

类型: boolean, 默认: true.

Memcached::OPT_SERIALIZER

指定对于非标量值进行序列化的序列化工具。可用的值有Memcached::SERIALIZER_PHP 和Memcached::SERIALIZER_IGBINARY。后者仅在memcached配置时开启 --enable-memcached-igbinary选项并且 igbinary扩展被加载时才有效。

类型: integer, 默认: Memcached::SERIALIZER_PHP.

Memcached::SERIALIZER_PHP

默认的PHP序列化工具（即serialize方法）。

Memcached::SERIALIZER_IGBINARY

» igbinary序列化工具。它将php的数据结构 存储为紧密的二进制形式，在时间和空间上都有所改进。

Memcached::SERIALIZER_JSON

JSON序列化，需要 PHP 5.2.10以上。

Memcached::OPT_PREFIX_KEY

可以用于为key创建"域"。这个值将会被作为每个key的前缀，它不能长于128个字符， 并且将会缩短最大可允许的key的长度。这个前缀仅仅用于被存储的元素的key，而不会用于服务器key。

类型: string, 默认: "".

Memcached::OPT_HASH

指定存储元素key使用的hash算法。可用的值是Memcached::HASH_*系列的常量。 每种hash算法都有它的优势和劣势，在你不了解或不确定哪种算法对你更有利时，请使用默认值。

类型: integer, 默认: Memcached::HASH_DEFAULT

Memcached::HASH_DEFAULT

默认的(Jenkins one-at-a-time)元素key hash算法

Memcached::HASH_MD5

md5元素key hash算法。

Memcached::HASH_CRC

CRC元素key hash算法。

Memcached::HASH_FNV1_64

FNV1_64元素key hash算法。

Memcached::HASH_FNV1A_64

FNV1_64A元素key hash算法。

Memcached::HASH_FNV1_32

FNV1_32元素key hash算法。

Memcached::HASH_FNV1A_32

FNV1_32A元素key hash算法。

Memcached::HASH_HSIEH

Hsieh元素key hash算法。

Memcached::HASH_MURMUR

Murmur元素key hash算法。

Memcached::OPT_DISTRIBUTION

指定元素key分布到各个服务器的方法。当前支持的方法有余数分步法合一致性hash算法两种。一致性hash算法提供 了更好的分配策略并且在添加服务器到集群时可以最小化缓存丢失。

类型: integer, 默认: Memcached::DISTRIBUTION_MODULA.

Memcached::DISTRIBUTION_MODULA

余数分布算法。

Memcached::DISTRIBUTION_CONSISTENT

一致性分布算法(基于libketama).

Memcached::OPT_LIBKETAMA_COMPATIBLE

开启或关闭兼容的libketama类行为。当开启此选项后，元素key的hash算法将会被设置为md5并且分布算法将会 采用带有权重的一致性hash分布。这一点非常有用因为其他基于libketama的客户端（比如python，urby）在同样 的服务端配置下可以透明的访问key。

Note:

如果你要使用一致性hash算法强烈建议开启此选项，并且这个选项可能在未来的发布版中被设置为默认开启。

类型: boolean, 默认: false.

Memcached::OPT_BUFFER_WRITES

开启或关闭I/O缓存。开启I/O缓存会导致存储命令不实际发送而是存储到缓冲区中。任意的检索数据操作都会导致 缓存中的数据被发送到远程服务端。退出连接或关闭连接也会导致缓存数据被发送到远程服务端。

类型: boolean, 默认: false.

Memcached::OPT_BINARY_PROTOCOL

开启使用二进制协议。请注意这个选项不能在一个打开的连接上进行切换。

类型: boolean, 默认: false.

Memcached::OPT_NO_BLOCK

开启或关闭异步I/O。这将使得存储函数传输速度最大化。

类型: boolean, 默认: false.

Memcached::OPT_TCP_NODELAY

开启或关闭已连接socket的无延迟特性（在某些幻境可能会带来速度上的提升）。

类型: boolean, 默认: false.

Memcached::OPT_SOCKET_SEND_SIZE

socket发送缓冲的最大值。

类型: integer, 默认: 根据不同的平台/内核配置不同

Memcached::OPT_SOCKET_RECV_SIZE

socket接收缓冲的最大值。

类型: integer, 默认: 根据不同的平台/内核配置不同

Memcached::OPT_CONNECT_TIMEOUT

在非阻塞模式下这里设置的值就是socket连接的超时时间，单位是毫秒。

类型: integer, 默认: 1000.

Memcached::OPT_RETRY_TIMEOUT

等待失败的连接重试的时间，单位秒。

类型: integer, 默认: 0.

Memcached::OPT_SEND_TIMEOUT

socket发送超时时间，单位微秒。在这种情况下您不能使用非阻塞I/O，这将使得您仍然有数据会发送超时。

类型: integer, 默认: 0.

Memcached::OPT_RECV_TIMEOUT

socket读取超时时间，单位微秒。在这种情况下您不能使用非阻塞I/O，这将使得您仍然有数据会读取超时。

类型: integer, 默认: 0.

Memcached::OPT_POLL_TIMEOUT

poll连接超时时间，单位毫秒。

类型: integer, 默认: 1000.

Memcached::OPT_CACHE_LOOKUPS

开启或禁用DNS查找缓存。

类型: boolean, 默认: false.

Memcached::OPT_SERVER_FAILURE_LIMIT

指定一个服务器连接的失败重试次数限制。在达到此数量的失败重连后此服务器将被从服务器池中移除。

类型: integer, 默认: 0.

Memcached::HAVE_IGBINARY

指示是否支持igbinary的序列化。

类型: boolean.

Memcached::HAVE_JSON

指示是否支持json的序列化。

类型: boolean.

Memcached::GET_PRESERVE_ORDER

一个用于Memcached::getMulti()和 Memcached::getMultiByKey()的标记用以确保返回的key和请求的key顺序保持一致。 不存在的key将会得到一个NULL值。

Memcached::RES_SUCCESS

操作成功。

Memcached::RES_FAILURE

某种方式的操作失败。

Memcached::RES_HOST_LOOKUP_FAILURE

DNS查找失败。

Memcached::RES_UNKNOWN_READ_FAILURE

读取网络数据失败。

Memcached::RES_PROTOCOL_ERROR

错误的memcached协议命令。

Memcached::RES_CLIENT_ERROR

客户端错误。

Memcached::RES_SERVER_ERROR

服务端错误。

Memcached::RES_WRITE_FAILURE

向网络写数据失败。

Memcached::RES_DATA_EXISTS

比较并交换值操作失败（cas方法）：尝试向服务端存储数据时由于自此连接最后一次取此key对应数据之后被改变导致失败。

Memcached::RES_NOTSTORED

元素没有被存储，但并不是因为一个错误。这通常表明add（元素已存在）或replace（元素不存在）方式存储数据失败或者元素已经在一个删除序列中（延时删除）。

Memcached::RES_NOTFOUND

元素未找到（通过get或cas操作时）。

Memcached::RES_PARTIAL_READ

局部网络数据读错误。

Memcached::RES_SOME_ERRORS

在多key获取的时候发生错误。

Memcached::RES_NO_SERVERS

服务器池空。

Memcached::RES_END

结果集到结尾了。

Memcached::RES_ERRNO

系统错误。

Memcached::RES_BUFFERED

操作被缓存。

Memcached::RES_TIMEOUT

操作超时。

Memcached::RES_BAD_KEY_PROVIDED

提供了无效的key。

Memcached::RES_CONNECTION_SOCKET_CREATE_FAILURE

创建网络socket失败。

Memcached::RES_PAYLOAD_FAILURE

不能压缩/解压缩或序列化/反序列化值。


超时时间

一些存储命令在发送时会包含一个失效值（与一个元素或一个客户端操作请求相关）到服务端。所有这类用法，实际发送的值可以 是一个Unix时间戳（自1970年1月1日起至失效时间的整型秒数），或者是一个从现在算起的以秒为单位的数字。对于后一种情况，这个 秒数不能超过60×60×24×30（30天时间的秒数）;如果失效的值大于这个值， 服务端会将其作为一个真实的Unix时间戳来处理而不是 自当前时间的偏移。

如果失效值被设置为0（默认），此元素永不过期（但是它可能由于服务端为了给其他新的元素分配空间而被删除）。


  • ? 超时时间
  • 结果回调 ?
  • PHP Manual
  • Memcached
  • 回调

回调

Table of Contents

  • 结果回调
  • 通读缓存回调


结果回调

Result callbacks方式在通过Memcached::getDelayed()或 Memcached::getDelayedBykey()方法获取元素后，为结果集中每个元素调用一次。 回调函数可以接收到一个Memcached对象合一个数组描述的元素信息，此回调函数不需要返回任何信息。

Example #1 结果回调示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$items = array(
    'key1' => 'value1',
    'key2' => 'value2',
    'key3' => 'value3'
);
$m->setMulti($items);
$m->getDelayed(array('key1', 'key3'), true, 'result_cb');

function result_cb($memc, $item)
{
    var_dump($item);
}
?>

以上例程的输出类似于：

array(3) {
  ["key"]=>
  string(4) "key1"
  ["value"]=>
  string(6) "value1"
  ["cas"]=>
  float(49)
}
array(3) {
  ["key"]=>
  string(4) "key3"
  ["value"]=>
  string(6) "value3"
  ["cas"]=>
  float(50)
}


通读缓存回调

通读缓存回调在一个元素没有从服务端检索到的时候被调用。这个回调函数会接收到Memcached对象，请求的key以及 一个引用方式传递的值变量等三个参数。此回调函数负责通过返回true或false来决定在key没有值时设置一个默认值。 如果回调返回true，Memcached会存储"传出参数"(引用传递的值变量)存储的值到memcached服务端并将其返回到原来 的调用函数中。仅仅Memcached::get()和Memcached::getByKey() 支持这类回调，因为Memcache协议不支持在请求多个key时提供未检索到key的信息。

Example #1 通读回调示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$profile_info = $m->get('user:'.$user_id, 'user_info_cb');

function user_info_cb($memc, $key, &$value)
{
    $user_id = substr($key, 5);
    /* 从数据库读取个人信息 */
    /* ... */
    $value = $profile_info;
    return true;
}
?>


Sessions支持

memcached提供了一个自定义的session处理器可以被用于存储用户session数据到memcached服务端。 一个完全独立的memcached实例将会在内部使用，因此如果需要您可以设置一个不同的服务器池。session的 key被存储在前缀memc.sess.key.之下，因此, 如果你对session和通常的缓存使用了 同样的服务器池，请注意这一点。 译注：另外一个session和通常缓存分离的原因是当通常的缓存占满了memcached服务端后，可能会导致你的session被 从缓存中踢除，导致用户莫名的掉线。

session.save_handler string

设置为memcached开启memcached的session处理器。

session.save_path string

定义一个逗号分隔的hostname:port样式的session缓存服务器池，例如： "sess1:11211, sess2:11211".


Memcached类

(PECL memcached >= 0.1.0)

简介

表征到memcached服务集群的连接。

类摘要

Memcached {
__construct ( string $persistent_id = ? )
public add ( string $key , mixed $value , int $expiration = ? ) : bool
public addByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool
public addServer ( string $host , int $port , int $weight = 0 ) : bool
public addServers ( array $servers ) : bool
public append ( string $key , string $value ) : bool
public appendByKey ( string $server_key , string $key , string $value ) : bool
public cas ( float $cas_token , string $key , mixed $value , int $expiration = ? ) : bool
public casByKey ( float $cas_token , string $server_key , string $key , mixed $value , int $expiration = ? ) : bool
public decrement ( string $key , int $offset = 1 ) : int
public decrementByKey ( string $server_key , string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int|false
public delete ( string $key , int $time = 0 ) : bool
public deleteByKey ( string $server_key , string $key , int $time = 0 ) : bool
public deleteMulti ( array $keys , int $time = 0 ) : array
public deleteMultiByKey ( string $server_key , array $keys , int $time = 0 ) : bool
public fetch ( ) : array
public fetchAll ( ) : array
public flush ( int $delay = 0 ) : bool
public get ( string $key , callback $cache_cb = ? , float &$cas_token = ? ) : mixed
public getAllKeys ( ) : array|false
public getByKey ( string $server_key , string $key , callback $cache_cb = ? , float &$cas_token = ? ) : mixed
public getDelayed ( array $keys , bool $with_cas = ? , callback $value_cb = ? ) : bool
public getDelayedByKey ( string $server_key , array $keys , bool $with_cas = ? , callback $value_cb = ? ) : bool
public getMulti ( array $keys , int $flags = ? ) : mixed
public getMultiByKey ( string $server_key , array $keys , string &$cas_tokens = ? , int $flags = ? ) : array
public getOption ( int $option ) : mixed
public getResultCode ( ) : int
public getResultMessage ( ) : string
public getServerByKey ( string $server_key ) : array
public getServerList ( ) : array
public getStats ( ) : array
public getVersion ( ) : array
public increment ( string $key , int $offset = 1 ) : int
public incrementByKey ( string $server_key , string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int|false
public isPersistent ( ) : bool
public isPristine ( ) : bool
public prepend ( string $key , string $value ) : bool
public prependByKey ( string $server_key , string $key , string $value ) : bool
public quit ( ) : bool
public replace ( string $key , mixed $value , int $expiration = ? ) : bool
public replaceByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool
public resetServerList ( ) : bool
public set ( string $key , mixed $value , int $expiration = ? ) : bool
public setByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool
public setMulti ( array $items , int $expiration = ? ) : bool
public setMultiByKey ( string $server_key , array $items , int $expiration = ? ) : bool
public setOption ( int $option , mixed $value ) : bool
public setOptions ( array $options ) : bool
public setSaslAuthData ( string $username , string $password ) : void
public touch ( string $key , int $expiration ) : bool
public touchByKey ( string $server_key , string $key , int $expiration ) : bool
}

Table of Contents

  • Memcached::add — 向一个新的key下面增加一个元素
  • Memcached::addByKey — 在指定服务器上的一个新的key下增加一个元素
  • Memcached::addServer — 向服务器池中增加一个服务器
  • Memcached::addServers — 向服务器池中增加多台服务器
  • Memcached::append — 向已存在元素后追加数据
  • Memcached::appendByKey — 向指定服务器上已存在元素后追加数据
  • Memcached::cas — 比较并交换值
  • Memcached::casByKey — 在指定服务器上比较并交换值
  • Memcached::__construct — 创建一个Memcached实例
  • Memcached::decrement — 减小数值元素的值
  • Memcached::decrementByKey — Decrement numeric item's value, stored on a specific server
  • Memcached::delete — 删除一个元素
  • Memcached::deleteByKey — 从指定的服务器删除一个元素
  • Memcached::deleteMulti — Delete multiple items
  • Memcached::deleteMultiByKey — Delete multiple items from a specific server
  • Memcached::fetch — 抓取下一个结果
  • Memcached::fetchAll — 抓取所有剩余的结果
  • Memcached::flush — 作废缓存中的所有元素
  • Memcached::get — 检索一个元素
  • Memcached::getAllKeys — Gets the keys stored on all the servers
  • Memcached::getByKey — 从特定的服务器检索元素
  • Memcached::getDelayed — 请求多个元素
  • Memcached::getDelayedByKey — 从指定的服务器上请求多个元素
  • Memcached::getMulti — 检索多个元素
  • Memcached::getMultiByKey — 从特定服务器检索多个元素
  • Memcached::getOption — 获取Memcached的选项值
  • Memcached::getResultCode — 返回最后一次操作的结果代码
  • Memcached::getResultMessage — 返回最后一次操作的结果描述消息
  • Memcached::getServerByKey — 获取一个key所映射的服务器信息
  • Memcached::getServerList — 获取服务器池中的服务器列表
  • Memcached::getStats — 获取服务器池的统计信息
  • Memcached::getVersion — 获取服务器池中所有服务器的版本信息
  • Memcached::increment — 增加数值元素的值
  • Memcached::incrementByKey — Increment numeric item's value, stored on a specific server
  • Memcached::isPersistent — Check if a persitent connection to memcache is being used
  • Memcached::isPristine — Check if the instance was recently created
  • Memcached::prepend — 向一个已存在的元素前面追加数据
  • Memcached::prependByKey — Prepend data to an existing item on a specific server
  • Memcached::quit — 关闭所有打开的链接。
  • Memcached::replace — 替换已存在key下的元素
  • Memcached::replaceByKey — Replace the item under an existing key on a specific server
  • Memcached::resetServerList — Clears all servers from the server list
  • Memcached::set — 存储一个元素
  • Memcached::setByKey — 将元素存储到指定的服务器上
  • Memcached::setMulti — 存储多个元素
  • Memcached::setMultiByKey — Store multiple items on a specific server
  • Memcached::setOption — 设置一个memcached选项
  • Memcached::setOptions — Set Memcached options
  • Memcached::setSaslAuthData — Set the credentials to use for authentication
  • Memcached::touch — Set a new expiration on an item
  • Memcached::touchByKey — Set a new expiration on an item on a specific server


向一个新的key下面增加一个元素

  • ? Memcached
  • Memcached::addByKey ?
  • PHP Manual
  • Memcached
  • 向一个新的key下面增加一个元素

Memcached::add

(PECL memcached >= 0.1.0)

Memcached::add — 向一个新的key下面增加一个元素

说明

public Memcached::add ( string $key , mixed $value , int $expiration = ? ) : bool

Memcached::add()与Memcached::set()类似，但是如果 key已经在服务端存在，此操作会失败。

参数

key

用于存储值的键名。

value

存储的值。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如果key已经存在，Memcached::getResultCode()方法将会返回Memcached::RES_NOTSTORED。

参见

  • Memcached::addByKey() - 在指定服务器上的一个新的key下增加一个元素
  • Memcached::set() - 存储一个元素
  • Memcached::replace() - 替换已存在key下的元素


在指定服务器上的一个新的key下增加一个元素

  • ? Memcached::add
  • Memcached::addServer ?
  • PHP Manual
  • Memcached
  • 在指定服务器上的一个新的key下增加一个元素

Memcached::addByKey

(PECL memcached >= 0.1.0)

Memcached::addByKey — 在指定服务器上的一个新的key下增加一个元素

说明

public Memcached::addByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool

Memcached::addByKey()在功能上等同于Memcached::add()， 不过这种方式可以自由的指定server_key用于将key 映射到特定的服务器。这在你需要将一些相关联的key保存在一个特定的服务器时非常有用。(译注: $server_key也是一个普通的key, *ByKey系列接口的工作过程是: 首先, 对$server_key进行hash, 得到$server_key应该存储的服务器, 然后将相应的操作在 $server_key所在的服务器上进行.)

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

用于存储值的键名。

value

存储的值。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如果key已经存在，Memcached::getResultCode()方法将会返回Memcached::RES_NOTSTORED。

参见

  • Memcached::add() - 向一个新的key下面增加一个元素
  • Memcached::set() - 存储一个元素
  • Memcached::replace() - 替换已存在key下的元素


向服务器池中增加一个服务器

  • ? Memcached::addByKey
  • Memcached::addServers ?
  • PHP Manual
  • Memcached
  • 向服务器池中增加一个服务器

Memcached::addServer

(PECL memcached >= 0.1.0)

Memcached::addServer — 向服务器池中增加一个服务器

说明

public Memcached::addServer ( string $host , int $port , int $weight = 0 ) : bool

Memcached::addServer()增加指定服务器到服务器池中。此时不会建立与服务端的连接，
但是，如果你使用一致性key分布选项（Memcached::DISTRIBUTION_CONSISTENT或
Memcached::OPT_LIBKETAMA_COMPATIBLE），一些内部的数据结构将会被更新。
因此，如果你需要增加多台服务器，更好的方式是使用Memcached::addServers()
以确保这种更新只发生一次。

同一台服务器可以在服务器池中多次出现，因为这里没有做重复检测。但这是不推荐的做法，对于期望提高某台服务器 权重的需求，请使用weight参数。

参数

host

memcached服务端主机名。如果主机名无效，相关的数据操作的返回代码将被设置为Memcached::RES_HOST_LOOKUP_FAILURE。

port

memcached服务端端口号，通常是11211。

weight

此服务器相对于服务器池中所有服务器的权重。此参数用来控制服务器在操作时被选种的概率。这个仅用于一致性 分布选项，并且这个值通常是由服务端分配的内存来设置的。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcached::addServer() example

<?php
$m = new Memcached();

/* Add 2 servers, so that the second one
   is twice as likely to be selected. */
$m->addServer('mem1.domain.com', 11211, 33);
$m->addServer('mem2.domain.com', 11211, 67);
?>

参见

  • Memcached::addServers() - 向服务器池中增加多台服务器


向服务器池中增加多台服务器

  • ? Memcached::addServer
  • Memcached::append ?
  • PHP Manual
  • Memcached
  • 向服务器池中增加多台服务器

Memcached::addServers

(PECL memcached >= 0.1.1)

Memcached::addServers — 向服务器池中增加多台服务器

说明

public Memcached::addServers ( array $servers ) : bool

Memcached::addServers()向服务器池中增加servers参数指定的服务器。 servers中的每一条都是一个包含主机名，端口以及可选的权重等服务器参数。此时并不会与这些服务端建立 连接。

同一台服务器可以在服务器池中多次出现，因为这里没有做重复检测。但这是不推荐的做法，对于期望提高某台服务器 权重的需求，请使用weight参数。

参数

array

将要增加到池中的服务器列表数组。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Memcached::addServers()示例

<?php
$m = new Memcached();

$servers = array(
    array('mem1.domain.com', 11211, 33),
    array('mem2.domain.com', 11211, 67)
);
$m->addServers($servers);
?>

参见

  • Memcached::addServer() - 向服务器池中增加一个服务器


向已存在元素后追加数据

  • ? Memcached::addServers
  • Memcached::appendByKey ?
  • PHP Manual
  • Memcached
  • 向已存在元素后追加数据

Memcached::append

(PECL memcached >= 0.1.0)

Memcached::append — 向已存在元素后追加数据

说明

public Memcached::append ( string $key , string $value ) : bool

Memcached::append()向已经存在的元素后追加value参数对应的字符串值。 value被强制转换成字符串类型主要是因为对于mix类型的追加没有很好的定义。

Note:

如果Memcached::OPT_COMPRESSION常量开启，这个操作会失败，并引发一个警告，因为向压缩数据 后追加数据可能会导致解压不了。

参数

key

用于存储值的键名。

value

将要追加的值。

返回值

成功时返回 true， 或者在失败时返回 false。 如果key不存在，Memcached::getResultCode()将返回Memcached::RES_NOTSTORED。

范例

Example #1 Memcached::append()示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$m->setOption(Memcached::OPT_COMPRESSION, false);

$m->set('foo', 'abc');
$m->append('foo', 'def');
var_dump($m->get('foo'));
?>

以上例程会输出：

string(6) "abcdef"

参见

  • Memcached::appendByKey() - 向指定服务器上已存在元素后追加数据
  • Memcached::prepend() - 向一个已存在的元素前面追加数据


向指定服务器上已存在元素后追加数据

  • ? Memcached::append
  • Memcached::cas ?
  • PHP Manual
  • Memcached
  • 向指定服务器上已存在元素后追加数据

Memcached::appendByKey

(PECL memcached >= 0.1.0)

Memcached::appendByKey — 向指定服务器上已存在元素后追加数据

说明

public Memcached::appendByKey ( string $server_key , string $key , string $value ) : bool

除了可以使用server_key自由的将key映射到指定服务器外， Memcached::appendByKey()在功能上等同于Memcached::append()。 (译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

用于存储值的键名。

value

要追加的字符串。

返回值

成功时返回 true， 或者在失败时返回 false。 如果key不存在，Memcached::getResultCode()将返回 Memcached::RES_NOTSTORED。

参见

  • Memcached::append() - 向已存在元素后追加数据
  • Memcached::prepend() - 向一个已存在的元素前面追加数据


比较并交换值

  • ? Memcached::appendByKey
  • Memcached::casByKey ?
  • PHP Manual
  • Memcached
  • 比较并交换值

Memcached::cas

(PECL memcached >= 0.1.0)

Memcached::cas — 比较并交换值

说明

public Memcached::cas ( float $cas_token , string $key , mixed $value , int $expiration = ? ) : bool

Memcached::cas()执行一个"检查并设置"的操作，因此，它仅在当前客户端最后一次取值后，该key 对应的值没有被其他客户端修改的情况下， 才能够将值写入。检查是通过cas_token参数进行的， 这个参数是Memcach指定给已经存在的元素的一个唯一的64位值， 怎样获取这个值请查看Memcached::get*() 系列方法的文档。注意：这个值作为double类型是因为PHP的整型空间限制。

译注：这是Memcached扩展比Memcache扩展一个非常重要的优势， 在这样一个系统级（Memcache自身提供）的冲突检测机制（乐观锁）下， 我们才能保证高并发下的数据安全。

参数

cas_token

与已存在元素关联的唯一的值，由Memcache生成。

key

用于存储值的键名。

value

存储的值。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如果在元素尝试存储时发现在本客户端最后一次获取后被其他客户端修改，Memcached::getResultCode() 将返回Memcached::RES_DATA_EXISTS。

范例

Example #1 Memcached::cas() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

do {
    /* 获取ip列表以及它的标记 */
    $ips = $m->get('ip_block', null, $cas);
    /* 如果列表不存在， 创建并进行一个原子添加（如果其他客户端已经添加， 这里就返回false）*/
    if ($m->getResultCode() == Memcached::RES_NOTFOUND) {
        $ips = array($_SERVER['REMOTE_ADDR']);
        $m->add('ip_block', $ips);
    /* 其他情况下，添加ip到列表中， 并以cas方式去存储， 这样当其他客户端修改过， 则返回false */
    } else {
        $ips[] = $_SERVER['REMOTE_ADDR'];
        $m->cas($cas, 'ip_block', $ips);
    }
} while ($m->getResultCode() != Memcached::RES_SUCCESS);

?>

参见

  • Memcached::casByKey() - 在指定服务器上比较并交换值


在指定服务器上比较并交换值

  • ? Memcached::cas
  • Memcached::__construct ?
  • PHP Manual
  • Memcached
  • 在指定服务器上比较并交换值

Memcached::casByKey

(PECL memcached >= 0.1.0)

Memcached::casByKey — 在指定服务器上比较并交换值

说明

public Memcached::casByKey ( float $cas_token , string $server_key , string $key , mixed $value , int $expiration = ? ) : bool

除了可以使用server_key将key自由的映射到指定服务器外， Memcached::casByKey()和Memcached::cas()在功能上是等同的。 这通常用于你需要保持一批相关的key在一个中心服务器上的情况。(译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)

参数

cas_token

与已存在元素关联的唯一的值，由Memcache生成。

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

用于存储值的键名。

value

存储的值。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如果在元素尝试存储时发现在本客户端最后一次获取后被其他客户端修改，Memcached::getResultCode() 将返回Memcached::RES_DATA_EXISTS。

参见

  • Memcached::cas() - 比较并交换值


创建一个Memcached实例

  • ? Memcached::casByKey
  • Memcached::decrement ?
  • PHP Manual
  • Memcached
  • 创建一个Memcached实例

Memcached::__construct

(PECL memcached >= 0.1.0)

Memcached::__construct — 创建一个Memcached实例

说明

Memcached::__construct ( string $persistent_id = ? )

创建一个代表到Memcached服务端连接的Memcached实例。

参数

persistent_id

默认情况下，Memcached实例在请求结束后会被销毁。但可以在创建时通过persistent_id为每个实例指定唯一的ID， 在请求间共享实例。所有通过相同的persistent_id值创建的实例共享同一个连接。

返回值

一个Memcached对象。

范例

Example #1 创建一个Memcached对象

<?php
/* 创建一个普通的对象 */
$m1 = new Memcached();
echo get_class($m);

/* 创建持久化对象 */
$m2 = new Memcached('story_pool');
$m3 = new Memcached('story_pool');

/* 现在$m2和$m3共享相同的连接 */
?>


减小数值元素的值

  • ? Memcached::__construct
  • Memcached::decrementByKey ?
  • PHP Manual
  • Memcached
  • 减小数值元素的值

Memcached::decrement

(PECL memcached >= 0.1.0)

Memcached::decrement — 减小数值元素的值

说明

public Memcached::decrement ( string $key , int $offset = 1 ) : int

Memcached::decrement()减小一个数值元素的值，减小多少由参数offset决定。 如果元素的值不是数值，以0值对待。如果减小后的值小于0,则新的值被设置为0.如果元素不存在，Memcached::decrement() 失败。

参数

key

将要减小值的元素的key。

offset

要将减小指定元素的值减小多少。

返回值

成功时返回元素新的值， 或者在失败时返回 false。 如果key不存在，Memcached::getResultCode()返回Memcached::RES_NOTFOUND。

范例

Example #1 Memcached::decrement() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('counter', 5);
$m->decrement('counter');
var_dump($m->get('counter'));

$m->decrement('counter', 10);
var_dump($m->get('counter'));
?>

以上例程会输出：

int(4)
int(0)

参见

  • Memcached::increment() - 增加数值元素的值


Decrement numeric item's value, stored on a specific server

  • ? Memcached::decrement
  • Memcached::delete ?
  • PHP Manual
  • Memcached
  • Decrement numeric item's value, stored on a specific server

Memcached::decrementByKey

(PECL memcached >= 2.0.0)

Memcached::decrementByKey — Decrement numeric item's value, stored on a specific server

说明

public Memcached::decrementByKey ( string $server_key , string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int|false

Memcached::decrementByKey() decrements a numeric item's value by the specified offset. If the item's value is not numeric, an error will result. If the operation would decrease the value below 0, the new value will be 0. Memcached::decrementByKey() will set the item to the initial_value parameter if the key doesn't exist.

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

The key of the item to decrement.

offset

The amount by which to decrement the item's value.

initial_value

The value to set the item to if it doesn't currently exist.

expiry

The expiry time to set on the item.

返回值

Returns item's new value on success 或者在失败时返回 false.

参见

  • Memcached::decrement() - 减小数值元素的值
  • Memcached::increment() - 增加数值元素的值
  • Memcached::incrementByKey() - Increment numeric item's value, stored on a specific server


删除一个元素

  • ? Memcached::decrementByKey
  • Memcached::deleteByKey ?
  • PHP Manual
  • Memcached
  • 删除一个元素

Memcached::delete

(PECL memcached >= 0.1.0)

Memcached::delete — 删除一个元素

说明

public Memcached::delete ( string $key , int $time = 0 ) : bool

Memcached::delete()从服务端删除key对应的元素. 参数time是一个秒为单位的时间(或一个UNIX时间戳表明直到那个时间), 用来表明 客户端希望服务端在这段时间拒绝对这个key的add和replace命令. 由于这个时间段的存在, 元素被放入一个删除队列, 表明它不可以通过get命令获取到值, 但是同时 add和replace命令也会失败(无论如何set命令都会成功). 在这段时间过去后, 元素最终被从服务端内存删除.time参数默认0(表明元素会被立即删除并且之后对这个 key的存储命令也会成功).

参数

key

要删除的key

time

服务端等待删除该元素的总时间(或一个Unix时间戳表明的实际删除时间).

返回值

成功时返回 true， 或者在失败时返回 false。 如果key不存在, Memcached::getResultCode()将会返回Memcached::RES_NOTFOUND.

范例

Example #1 Memcached::delete() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->delete('key1');
?>

参见

  • Memcached::deleteByKey() - 从指定的服务器删除一个元素


从指定的服务器删除一个元素

  • ? Memcached::delete
  • Memcached::deleteMulti ?
  • PHP Manual
  • Memcached
  • 从指定的服务器删除一个元素

Memcached::deleteByKey

(PECL memcached >= 0.1.0)

Memcached::deleteByKey — 从指定的服务器删除一个元素

说明

public Memcached::deleteByKey ( string $server_key , string $key , int $time = 0 ) : bool

Memcached::deleteByKey()除了可以通过server_key参数自由的指定key 所映射的服务器外， 在功能上等同于Memcached::delete()。(译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

要删除的key。

time

服务端等待删除该元素的总时间(或一个Unix时间戳表明的实际删除时间).

返回值

成功时返回 true， 或者在失败时返回 false。 如果key不存在，Memcached::getResultCode()返回Memcached::RES_NOTFOUND。

参见

  • Memcached::delete() - 删除一个元素


Delete multiple items

  • ? Memcached::deleteByKey
  • Memcached::deleteMultiByKey ?
  • PHP Manual
  • Memcached
  • Delete multiple items

Memcached::deleteMulti

(PECL memcached >= 2.0.0)

Memcached::deleteMulti — Delete multiple items

说明

public Memcached::deleteMulti ( array $keys , int $time = 0 ) : array

Memcached::deleteMulti() deletes the array of keys from the server. The time parameter is the amount of time in seconds (or Unix time until which) the client wishes the server to refuse add and replace commands for these keys. For this amount of time, the item is put into a delete queue, which means that it won't be possible to retrieve it by the get command, but add and replace command with these keys will also fail (the set command will succeed, however). After the time passes, the item is finally deleted from server memory. The parameter time defaults to 0 (which means that the item will be deleted immediately and further storage commands with these keys will succeed).

参数

keys

The keys to be deleted.

time

The amount of time the server will wait to delete the items.

返回值

Returns array indexed by keys and where values are indicating whether operation succeeded or not. The Memcached::getResultCode() will return Memcached::RES_NOTFOUND if the key does not exist.

参见

  • Memcached::delete() - 删除一个元素
  • Memcached::deleteByKey() - 从指定的服务器删除一个元素
  • Memcached::deleteMultiByKey() - Delete multiple items from a specific server


Delete multiple items from a specific server

  • ? Memcached::deleteMulti
  • Memcached::fetch ?
  • PHP Manual
  • Memcached
  • Delete multiple items from a specific server

Memcached::deleteMultiByKey

(PECL memcached >= 2.0.0)

Memcached::deleteMultiByKey — Delete multiple items from a specific server

说明

public Memcached::deleteMultiByKey ( string $server_key , array $keys , int $time = 0 ) : bool

Memcached::deleteMultiByKey() is functionally equivalent to Memcached::deleteMulti(), except that the free-form server_key can be used to map the keys to a specific server.

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

keys

The keys to be deleted.

time

The amount of time the server will wait to delete the items.

返回值

成功时返回 true， 或者在失败时返回 false。 The Memcached::getResultCode() will return Memcached::RES_NOTFOUND if the key does not exist.

参见

  • Memcached::delete() - 删除一个元素
  • Memcached::deleteByKey() - 从指定的服务器删除一个元素
  • Memcached::deleteMulti() - Delete multiple items


抓取下一个结果

  • ? Memcached::deleteMultiByKey
  • Memcached::fetchAll ?
  • PHP Manual
  • Memcached
  • 抓取下一个结果

Memcached::fetch

(PECL memcached >= 0.1.0)

Memcached::fetch — 抓取下一个结果

说明

public Memcached::fetch ( ) : array

Memcached::fetch()从最后一次请求中抓取下一个结果。

参数

此函数没有参数。

返回值

返回下一个结果或其他情况下返回false。 如果结果集已经抓取完毕，Memcached::getResultCode()将返回Memcached::RES_END。

范例

Example #1 Memcached::fetch() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'a simple string');
$m->set('array', array(11, 12));

//延迟的获取int和array这两个key的值
$m->getDelayed(array('int', 'array'), true);
//循环抓取上面的延迟抓取得到的结果
while ($result = $m->fetch()) {
    var_dump($result);
}
?>

以上例程的输出类似于：

array(3) {
  ["key"]=>
  string(3) "int"
  "value"]=>
  int(99)
  ["cas"]=>
  float(2363)
}
array(3) {
  ["key"]=>
  string(5) "array"
  ["value"]=>
  array(2) {
    [0]=>
    int(11)
    [1]=>
    int(12)
  }
  ["cas"]=>
  float(2365)
}

参见

  • Memcached::fetchAll() - 抓取所有剩余的结果
  • Memcached::getDelayed() - 请求多个元素


抓取所有剩余的结果

  • ? Memcached::fetch
  • Memcached::flush ?
  • PHP Manual
  • Memcached
  • 抓取所有剩余的结果

Memcached::fetchAll

(PECL memcached >= 0.1.0)

Memcached::fetchAll — 抓取所有剩余的结果

说明

public Memcached::fetchAll ( ) : array

Memcached::fetchAll()抓取最后一次请求的结果集中剩余的所有结果。需要注意的是fetchAll和fetch的返回不同， 因为fetchAll抓取的是结果集中剩余所有元素， 所以比fetch的结果多一个维度。

参数

此函数没有参数。

返回值

返回结果集 或者在失败时返回 false. 如需要则使用 Memcached::getResultCode()。

范例

Example #1 Memcached::getDelayed() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'a simple string');
$m->set('array', array(11, 12));

//延迟抓取int和array两个key的值
$m->getDelayed(array('int', 'array'), true);
//抓取上面delay抓取的所有结果
var_dump($m->fetchAll());
?>

以上例程会输出：

array(2) {
  [0]=>
  array(3) {
    ["key"]=>
    string(3) "int"
    ["value"]=>
    int(99)
    ["cas"]=>
    float(2363)
  }
  [1]=>
  array(3) {
    ["key"]=>
    string(5) "array"
    ["value"]=>
    array(2) {
      [0]=>
      int(11)
      [1]=>
      int(12)
    }
    ["cas"]=>
    float(2365)
  }
}

参见

  • Memcached::fetch() - 抓取下一个结果
  • Memcached::getDelayed() - 请求多个元素


作废缓存中的所有元素

  • ? Memcached::fetchAll
  • Memcached::get ?
  • PHP Manual
  • Memcached
  • 作废缓存中的所有元素

Memcached::flush

(PECL memcached >= 0.1.0)

Memcached::flush — 作废缓存中的所有元素

说明

public Memcached::flush ( int $delay = 0 ) : bool

Memcached::flush()立即（默认）或者在delay延迟后作废所有缓存中已经存在的元素。 在作废之后检索命令将不会有任何返回（除非在执行Memcached::flush()作废之后，该key下被重新存储过）。flush不会 真正的释放已有元素的内存， 而是逐渐的存入新元素重用那些内存。

参数

delay

在作废所有元素之前等待的时间（单位秒）。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

范例

Example #1 Memcached::flush() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

/* 10秒内清除所有元素 */
$m->flush(10);
?>


检索一个元素

  • ? Memcached::flush
  • Memcached::getAllKeys ?
  • PHP Manual
  • Memcached
  • 检索一个元素

Memcached::get

(PECL memcached >= 0.1.0)

Memcached::get — 检索一个元素

说明

public Memcached::get ( string $key , callback $cache_cb = ? , float &$cas_token = ? ) : mixed

Memcached::get()返回之前存储在key下的元素。如果元素被找到，并且提供 了cas_token参数， 这个参数（译注：这个参数在函数定义中是引用参数，用来传出元素的版本标记，原理 可以查阅乐观锁资料）将会包含该元素的CAS标记值。关于CAS标记值的使用，请查看Memcached::cas()的说明。 另外，可以通过cache_cb参数设置Read-through caching callback。

参数

key

要检索的元素的key。

cache_cb

通读缓存回掉函数或null.

cas_token

检索的元素的CAS标记值。

返回值

返回存储在服务端的元素的值或者在其他情况下返回false。 如果key不存在，Memcached::getResultCode()返回Memcached::RES_NOTFOUND。

范例

Example #1 Memcached::get() 示例 #1

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('foo', 100);
var_dump($m->get('foo'));
?>

以上例程会输出：

int(100)

Example #2 Memcached::get() 示例 #2

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

if (!($ip = $m->get('ip_block'))) {
    if ($m->getResultCode() == Memcached::RES_NOTFOUND) {
        $ip = array();
        $m->set('ip_block', $ip);
    } else {
        /* log error */
        /* ...       */
    }
}
?>

参见

  • Memcached::getByKey() - 从特定的服务器检索元素
  • Memcached::getMulti() - 检索多个元素
  • Memcached::getDelayed() - 请求多个元素


Gets the keys stored on all the servers

  • ? Memcached::get
  • Memcached::getByKey ?
  • PHP Manual
  • Memcached
  • Gets the keys stored on all the servers

Memcached::getAllKeys

(PECL memcached >= 2.0.0)

Memcached::getAllKeys — Gets the keys stored on all the servers

说明

public Memcached::getAllKeys ( ) : array|false

Memcached::getAllKeys() queries each memcache server and retrieves an array of all keys stored on them at that point in time. This is not an atomic operation, so it isn't a truly consistent snapshot of the keys at point in time. As memcache doesn't guarantee to return all keys you also cannot assume that all keys have been returned.

参数

此函数没有参数。

返回值

Returns the keys stored on all the servers on success 或者在失败时返回 false.


从特定的服务器检索元素

  • ? Memcached::getAllKeys
  • Memcached::getDelayed ?
  • PHP Manual
  • Memcached
  • 从特定的服务器检索元素

Memcached::getByKey

(PECL memcached >= 0.1.0)

Memcached::getByKey — 从特定的服务器检索元素

说明

public Memcached::getByKey ( string $server_key , string $key , callback $cache_cb = ? , float &$cas_token = ? ) : mixed

Memcached::getByKey()除了可以通过server_key参数自由的指定key 所映射的服务器外， 在功能上等同于Memcached::get()。(译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

要抓取的元素的key。

cache_cb

通读缓存回掉函数或null.

cas_token

检索的元素的CAS标记值。

返回值

返回存储在服务端的元素的值或者在其他情况下返回false。 如果key不存在，Memcached::getResultCode()返回Memcached::RES_NOTFOUND。

参见

  • Memcached::get() - 检索一个元素
  • Memcached::getMulti() - 检索多个元素
  • Memcached::getDelayed() - 请求多个元素


请求多个元素

  • ? Memcached::getByKey
  • Memcached::getDelayedByKey ?
  • PHP Manual
  • Memcached
  • 请求多个元素

Memcached::getDelayed

(PECL memcached >= 0.1.0)

Memcached::getDelayed — 请求多个元素

说明

public Memcached::getDelayed ( array $keys , bool $with_cas = ? , callback $value_cb = ? ) : bool

Memcached::getDelayed()向Memcached服务端发出一个检索keys指定的多个
key对应元素的请求。这个方法不会等待响应而是立即返回。当你需要收集元素值时， 调用Memcached::fetch()或
Memcached::fetchAll()。如果with_cas设置为true，会同时请求每个元素的CAS标记。

可以通过参数value_cb指定一个result callback来替代明确的抓取结果（fetch或fetchAll为明确抓取方式）。

参数

keys

要请求的key的数组。

with_cas

是否同时请求CAS标记。

value_cb

结果回掉函数或null。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

范例

Example #1 Memcached::getDelayed() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'a simple string');
$m->set('array', array(11, 12));

$m->getDelayed(array('int', 'array'), true);
var_dump($m->fetchAll());
?>

以上例程会输出：

array(2) {
  [0]=>
  array(3) {
    ["key"]=>
    string(3) "int"
    ["value"]=>
    int(99)
    ["cas"]=>
    float(2363)
  }
  [1]=>
  array(3) {
    ["key"]=>
    string(5) "array"
    ["value"]=>
    array(2) {
      [0]=>
      int(11)
      [1]=>
      int(12)
    }
    ["cas"]=>
    float(2365)
  }
}

参见

  • Memcached::getDelayedByKey() - 从指定的服务器上请求多个元素
  • Memcached::fetch() - 抓取下一个结果
  • Memcached::fetchAll() - 抓取所有剩余的结果


从指定的服务器上请求多个元素

  • ? Memcached::getDelayed
  • Memcached::getMulti ?
  • PHP Manual
  • Memcached
  • 从指定的服务器上请求多个元素

Memcached::getDelayedByKey

(PECL memcached >= 0.1.0)

Memcached::getDelayedByKey — 从指定的服务器上请求多个元素

说明

public Memcached::getDelayedByKey ( string $server_key , array $keys , bool $with_cas = ? , callback $value_cb = ? ) : bool

Memcached::getDelayedByKey()除了可以通过server_key参数自由的指定key 所映射的服务器外， 在功能上等同于Memcached::getDelayed()。(译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

keys

要请求的key的数组。

with_cas

是否同时请求CAS标记。

value_cb

结果回掉函数或null。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

参见

  • Memcached::getDelayed() - 请求多个元素
  • Memcached::fetch() - 抓取下一个结果
  • Memcached::fetchAll() - 抓取所有剩余的结果


检索多个元素

  • ? Memcached::getDelayedByKey
  • Memcached::getMultiByKey ?
  • PHP Manual
  • Memcached
  • 检索多个元素

Memcached::getMulti

(PECL memcached >= 0.1.0)

Memcached::getMulti — 检索多个元素

说明

public Memcached::getMulti ( array $keys , int $flags = ? ) : mixed

Memcached::getMulti() 与 Memcached::get() 类似，但是这个方法用来检索 keys 数组指定的多个 key 对应的元素。

Note:

在 v3.0 之前，使用的第二个参数是 &cas_tokens。 它会填充进元素的 CAS token 值。 在本扩展里，&cas_tokens 参数在 v3.0 中已经移除。 它被新的附加选项（flag） Memcached::GET_EXTENDED 代替，需要在 flags 值里使用。

flags参数可以用做指定Memcached::getMulti()的附加选项。
当前，仅可以指定为Memcached::GET_PRESERVE_ORDER以保证返回的key的顺序和请求时一致。
Memcached::GET_EXTENDED 可以确保同时返回了 CAS token 信息。

参数

keys

要检索的key的数组。

flags

Get 操作的附加选项。

返回值

返回检索到的元素的数组 或者在失败时返回 false. 如需要则使用 Memcached::getResultCode()。

范例

Example #1 Memcached::getMulti() 的 Memcached v3 示例

<?php
// 扩展版本 v3 有效

$m = new Memcached();
$m->addServer('localhost', 11211);

$items = array(
    'key1' => 'value1',
    'key2' => 'value2',
    'key3' => 'value3'
);
$m->setMulti($items);
$result = $m->getMulti(array('key1', 'key3', 'badkey'));
var_dump($result);
?>

以上例程的输出类似于：

array(2) {
  ["key1"]=>
  string(6) "value1"
  ["key3"]=>
  string(6) "value3"
}

Example #2 Memcached::getMulti() 的 Memcached v1 和 v2 示例

<?php
// 仅在扩展版本 v1 和 v2 中有效

$m = new Memcached();
$m->addServer('localhost', 11211);

$items = array(
    'key1' => 'value1',
    'key2' => 'value2',
    'key3' => 'value3'
);
$m->setMulti($items);
$result = $m->getMulti(array('key1', 'key3', 'badkey'), $cas);
var_dump($result, $cas);
?>

以上例程的输出类似于：

array(2) {
  ["key1"]=>
  string(6) "value1"
  ["key3"]=>
  string(6) "value3"
}
array(2) {
  ["key1"]=>
  float(2360)
  ["key3"]=>
  float(2362)
}

Example #3 Memcached::GET_PRESERVE_ORDER 的 Memcached v3 示例

<?php
//  v3 扩展有效

$m = new Memcached();
$m->addServer('localhost', 11211);

$data = array(
    'foo' => 'foo-data',
    'bar' => 'bar-data',
    'baz' => 'baz-data',
    'lol' => 'lol-data',
    'kek' => 'kek-data',
);

$m->setMulti($data, 3600);

$keys = array_keys($data);
$keys[] = 'zoo';
$got = $m->getMulti($keys, Memcached::GET_PRESERVE_ORDER);

foreach ($got as $k => $v) {
    echo "$k $v\n";
}
?>

以上例程的输出类似于：

foo foo-data
bar bar-data
baz baz-data
lol lol-data
kek kek-data
zoo

Example #4 Memcached::GET_PRESERVE_ORDER 的 Memcached v1 和 v2 示例

<?php
// 在扩展版本 v1 和 v2  中有效

$m = new Memcached();
$m->addServer('localhost', 11211);

$data = array(
    'foo' => 'foo-data',
    'bar' => 'bar-data',
    'baz' => 'baz-data',
    'lol' => 'lol-data',
    'kek' => 'kek-data',
);

$m->setMulti($data, 3600);

$null = null;
$keys = array_keys($data);
$keys[] = 'zoo';
$got = $m->getMulti($keys, $null, Memcached::GET_PRESERVE_ORDER);

foreach ($got as $k => $v) {
    echo "$k $v\n";
}
?>

以上例程的输出类似于：

foo foo-data
bar bar-data
baz baz-data
lol lol-data
kek kek-data
zoo

更新日志

版本 | 说明
3.0.0 | 移出参数 &cas_tokens。 添加 Memcached::GET_EXTENDED，当需要获取 CAS token 信息时，传入 flag 中。

参见

  • Memcached::getMultiByKey() - 从特定服务器检索多个元素
  • Memcached::get() - 检索一个元素
  • Memcached::getDelayed() - 请求多个元素


从特定服务器检索多个元素

  • ? Memcached::getMulti
  • Memcached::getOption ?
  • PHP Manual
  • Memcached
  • 从特定服务器检索多个元素

Memcached::getMultiByKey

(PECL memcached >= 0.1.0)

Memcached::getMultiByKey — 从特定服务器检索多个元素

说明

public Memcached::getMultiByKey ( string $server_key , array $keys , string &$cas_tokens = ? , int $flags = ? ) : array

Memcached::getMultiByKey()除了可以通过server_key参数自由的指定key 所映射的服务器外， 在功能上等同于Memcached::getMulti()。(译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

keys

要检索的key的数组。

cas_tokens

用来存储检索到的元素的CAS标记。

flags

get操作的附加选项。

返回值

返回检索到的元素的数组 或者在失败时返回 false. 如需要则使用 Memcached::getResultCode()。

参见

  • Memcached::getMulti() - 检索多个元素
  • Memcached::get() - 检索一个元素
  • Memcached::getDelayed() - 请求多个元素


获取Memcached的选项值

  • ? Memcached::getMultiByKey
  • Memcached::getResultCode ?
  • PHP Manual
  • Memcached
  • 获取Memcached的选项值

Memcached::getOption

(PECL memcached >= 0.1.0)

Memcached::getOption — 获取Memcached的选项值

说明

public Memcached::getOption ( int $option ) : mixed

这个方法返回option指定的Memcached选项的值。一些选项是和libmemcached中相对应的， 也有一些特殊的选项仅仅是扩展自身的。关于选项的更多信息请查看Memcached Constants。

参数

option

Memcached::OPT_*系列常量中的一个。

返回值

返回请求的选项的值，或者在发生错误时返回FALSE。

范例

Example #1 获取Memcached选项

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_COMPRESSION));
var_dump($m->getOption(Memcached::OPT_POLL_TIMEOUT));
?>

以上例程的输出类似于：

bool(true)
int(1000)

参见

  • Memcached::setOption() - 设置一个memcached选项
  • Memcached Constants


返回最后一次操作的结果代码

  • ? Memcached::getOption
  • Memcached::getResultMessage ?
  • PHP Manual
  • Memcached
  • 返回最后一次操作的结果代码

Memcached::getResultCode

(PECL memcached >= 0.1.0)

Memcached::getResultCode — 返回最后一次操作的结果代码

说明

public Memcached::getResultCode ( ) : int

Memcached::getResultCode()返回Memcached::RES_*系列常量中的一个来表明最后一次执行Memcached方法的结果。

参数

此函数没有参数。

返回值

最后一次Memcached操作的结果代码。

范例

Example #1 Memcached::getResultCode() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->add('foo', 'bar');
if ($m->getResultCode() == Memcached::RES_NOTSTORED) {
    /* ... */
}
?>


返回最后一次操作的结果描述消息

  • ? Memcached::getResultCode
  • Memcached::getServerByKey ?
  • PHP Manual
  • Memcached
  • 返回最后一次操作的结果描述消息

Memcached::getResultMessage

(PECL memcached >= 1.0.0)

Memcached::getResultMessage — 返回最后一次操作的结果描述消息

说明

public Memcached::getResultMessage ( ) : string

Memcached::getResultMessage()返回一个字符串来描述最后一次Memcached方法执行的结果。

参数

此函数没有参数。

返回值

最后一次Memcached操作结果的描述消息。

范例

Example #1 Memcached::getResultMessage() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->add('foo', 'bar'); // first time should succeed
$m->add('foo', 'bar');
echo $m->getResultMessage(),"\n";
?>

以上例程会输出：

NOT STORED


获取一个key所映射的服务器信息

  • ? Memcached::getResultMessage
  • Memcached::getServerList ?
  • PHP Manual
  • Memcached
  • 获取一个key所映射的服务器信息

Memcached::getServerByKey

(PECL memcached >= 0.1.0)

Memcached::getServerByKey — 获取一个key所映射的服务器信息

说明

public Memcached::getServerByKey ( string $server_key ) : array

Memcached::getServerByKey()返回server_key所映射的服务器,
Memcached::*ByKey()系列方法的中的server_key参数, 实际上就是用来获取
操作的服务器的.(译注: 可以这样理解, *ByKey系列函数首先调用Memcached::getServerByKey()获取服务器,
然后在此服务器上进行操作.)

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

范例

Example #1 Memcached::getServerByKey() 示例

<?php
$m = new Memcached();
$m->addServers(array(
    array('mem1.domain.com', 11211, 40),
    array('mem2.domain.com', 11211, 40),
    array('mem3.domain.com', 11211, 20),
));

$m->setOption(Memcached::OPT_LIBKETAMA_COMPATIBLE, true);

var_dump($m->getServerByKey('user'));
var_dump($m->getServerByKey('log'));
var_dump($m->getServerByKey('ip'));
?>

以上例程的输出类似于：

array(3) {
  ["host"]=>
  string(15) "mem3.domain.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(20)
}
array(3) {
  ["host"]=>
  string(15) "mem2.domain.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(40)
}
array(3) {
  ["host"]=>
  string(15) "mem2.domain.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(40)
}


获取服务器池中的服务器列表

  • ? Memcached::getServerByKey
  • Memcached::getStats ?
  • PHP Manual
  • Memcached
  • 获取服务器池中的服务器列表

Memcached::getServerList

(PECL memcached >= 0.1.0)

Memcached::getServerList — 获取服务器池中的服务器列表

说明

public Memcached::getServerList ( ) : array

Memcached::getServerList()返回服务器池中所有服务器列表.

参数

此函数没有参数。

返回值

服务器池中所有服务器列表.

范例

Example #1 Memcached::getServerList() 示例

<?php
$m = new Memcached();
$m->addServers(array(
    array('mem1.domain.com', 11211, 20),
    array('mem2.domain.com', 11311, 80),
));
var_dump($m->getServerList());
?>

以上例程会输出：

array(2) {
  [0]=>
  array(3) {
    ["host"]=>
    string(15) "mem1.domain.com"
    ["port"]=>
    int(11211)
    ["weight"]=>
    int(20)
  }
  [1]=>
  array(3) {
    ["host"]=>
    string(15) "mem2.domain.com"
    ["port"]=>
    int(11311)
    ["weight"]=>
    int(80)
  }
}


获取服务器池的统计信息

  • ? Memcached::getServerList
  • Memcached::getVersion ?
  • PHP Manual
  • Memcached
  • 获取服务器池的统计信息

Memcached::getStats

(PECL memcached >= 0.1.0)

Memcached::getStats — 获取服务器池的统计信息

说明

public Memcached::getStats ( ) : array

Memcached::getStats()返回一个包含所有可用memcache服务器状态的数组. 返回的统计信息的详细描述参见» memcache protocol。 （译注：经实验，服务器池中有不可用服务器时，返回false）

参数

此函数没有参数。

返回值

服务器统计信息数组， 每个服务器一项。

范例

Example #1 Memcached::getStats() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

print_r($m->getStats());
?>

以上例程的输出类似于：

Array
(
    [localhost:11211] => Array
        (
            [pid] => 4933
            [uptime] => 786123
            [threads] => 1
            [time] => 1233868010
            [pointer_size] => 32
            [rusage_user_seconds] => 0
            [rusage_user_microseconds] => 140000
            [rusage_system_seconds] => 23
            [rusage_system_microseconds] => 210000
            [curr_items] => 145
            [total_items] => 2374
            [limit_maxbytes] => 67108864
            [curr_connections] => 2
            [total_connections] => 151
            [connection_structures] => 3
            [bytes] => 20345
            [cmd_get] => 213343
            [cmd_set] => 2381
            [get_hits] => 204223
            [get_misses] => 9120
            [evictions] => 0
            [bytes_read] => 9092476
            [bytes_written] => 15420512
            [version] => 1.2.6
        )

)


获取服务器池中所有服务器的版本信息

  • ? Memcached::getStats
  • Memcached::increment ?
  • PHP Manual
  • Memcached
  • 获取服务器池中所有服务器的版本信息

Memcached::getVersion

(PECL memcached >= 0.1.5)

Memcached::getVersion — 获取服务器池中所有服务器的版本信息

说明

public Memcached::getVersion ( ) : array

Memcached::getVersion()返回一个包含所有可用memcached服务器版本信息的数组。 （译注：经实验，服务器池中有不可用服务器时，返回false）

参数

此函数没有参数。

返回值

服务器版本信息的数组，每个服务器占一项。

范例

Example #1 Memcached::getVersion() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

print_r($m->getVersion());
?>

以上例程的输出类似于：

Array
(
    [localhost:11211] => 1.2.6
)


增加数值元素的值

  • ? Memcached::getVersion
  • Memcached::incrementByKey ?
  • PHP Manual
  • Memcached
  • 增加数值元素的值

Memcached::increment

(PECL memcached >= 0.1.0)

Memcached::increment — 增加数值元素的值

说明

public Memcached::increment ( string $key , int $offset = 1 ) : int

Memcached::increment() 将一个数值元素增加参数 offset 指定的大小。如果元素的值不是数值类型，将返回错误。如果元素不存在， Memcached::increment() 会将元素设置成 initial_value 指定的值。

参数

key

要增加值的元素的 key。

offset

要将元素的值增加的大小。

initial_value

如果元素不存在，要设置的默认值。

expiry

设置元素值的过期时间。

返回值

成功时返回元素的新值 或者在失败时返回 false。

范例

Example #1 Memcached::increment() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('counter', 0);
$m->increment('counter');
$n = $m->increment('counter', 10);
var_dump($n);

$m->set('counter', 'abc');
$n = $m->increment('counter');
// ^ will fail due to item value not being numeric
var_dump($n);
?>

以上例程会输出：

int(11)
bool(false)

参见

  • Memcached::decrement() - 减小数值元素的值
  • Memcached::decrementByKey() - Decrement numeric item's value, stored on a specific server
  • Memcached::incrementByKey() - Increment numeric item's value, stored on a specific server


Increment numeric item's value, stored on a specific server

  • ? Memcached::increment
  • Memcached::isPersistent ?
  • PHP Manual
  • Memcached
  • Increment numeric item's value, stored on a specific server

Memcached::incrementByKey

(PECL memcached >= 2.0.0)

Memcached::incrementByKey — Increment numeric item's value, stored on a specific server

说明

public Memcached::incrementByKey ( string $server_key , string $key , int $offset = 1 , int $initial_value = 0 , int $expiry = 0 ) : int|false

Memcached::incrementByKey() increments a numeric item's value by the specified offset. If the item's value is not numeric, an error will result. Memcached::incrementByKey() will set the item to the initial_value parameter if the key doesn't exist.

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

The key of the item to increment.

offset

The amount by which to increment the item's value.

initial_value

The value to set the item to if it doesn't currently exist.

expiry

The expiry time to set on the item.

返回值

Returns new item's value on success 或者在失败时返回 false.

参见

  • Memcached::decrement() - 减小数值元素的值
  • Memcached::decrementByKey() - Decrement numeric item's value, stored on a specific server
  • Memcached::increment() - 增加数值元素的值


Check if a persitent connection to memcache is being used

  • ? Memcached::incrementByKey
  • Memcached::isPristine ?
  • PHP Manual
  • Memcached
  • Check if a persitent connection to memcache is being used

Memcached::isPersistent

(PECL memcached >= 2.0.0)

Memcached::isPersistent — Check if a persitent connection to memcache is being used

说明

public Memcached::isPersistent ( ) : bool

Memcached::isPersistent() checks if the connections to the memcache servers are persistent connections.

参数

此函数没有参数。

返回值

Returns true if Memcache instance uses a persistent connection, false otherwise.

参见

  • Memcached::isPristine() - Check if the instance was recently created


Check if the instance was recently created

  • ? Memcached::isPersistent
  • Memcached::prepend ?
  • PHP Manual
  • Memcached
  • Check if the instance was recently created

Memcached::isPristine

(PECL memcached >= 2.0.0)

Memcached::isPristine — Check if the instance was recently created

说明

public Memcached::isPristine ( ) : bool

Memcached::isPristine() checks if the Memcache instance was recently created.

参数

此函数没有参数。

返回值

Returns the true if instance is recently created, false otherwise.

参见

  • Memcached::isPersistent() - Check if a persitent connection to memcache is being used


向一个已存在的元素前面追加数据

  • ? Memcached::isPristine
  • Memcached::prependByKey ?
  • PHP Manual
  • Memcached
  • 向一个已存在的元素前面追加数据

Memcached::prepend

(PECL memcached >= 0.1.0)

Memcached::prepend — 向一个已存在的元素前面追加数据

说明

public Memcached::prepend ( string $key , string $value ) : bool

Memcached::prepend()向已存在元素的字符串值前追加value。 value被强制转换成字符串类型主要是因为对于mix类型的追加没有很好的定义。

Note:

如果Memcached::OPT_COMPRESSION常量开启，这个操作会失败，并引发一个警告，因为向压缩数据 后追加数据可能会导致解压不了。

参数

key

要向前追加数据的元素的key。

value

要追加的字符串。

返回值

成功时返回 true， 或者在失败时返回 false。 如果key不存在，Memcached::getResultCode()返回Memcached::RES_NOTSTORED。

范例

Example #1 Memcached::prepend() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$m->setOption(Memcached::OPT_COMPRESSION, false);

$m->set('foo', 'abc');
$m->prepend('foo', 'def');
var_dump($m->get('foo'));
?>

以上例程会输出：

string(6) "defabc"

参见

  • Memcached::prependByKey() - Prepend data to an existing item on a specific server
  • Memcached::append() - 向已存在元素后追加数据


Prepend data to an existing item on a specific server

  • ? Memcached::prepend
  • Memcached::quit ?
  • PHP Manual
  • Memcached
  • Prepend data to an existing item on a specific server

Memcached::prependByKey

(PECL memcached >= 0.1.0)

Memcached::prependByKey — Prepend data to an existing item on a specific server

说明

public Memcached::prependByKey ( string $server_key , string $key , string $value ) : bool

除了可以使用server_key自由的将key映射到指定服务器外， Memcached::prependByKey()在功能上等同于Memcached::prepend()。 (译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

要向前追加数据的元素的key。

value

要追加的字符串。

返回值

成功时返回 true， 或者在失败时返回 false。 如果key不存在，Memcached::getResultCode()返回Memcached::RES_NOTSTORED。

参见

  • Memcached::prepend() - 向一个已存在的元素前面追加数据
  • Memcached::append() - 向已存在元素后追加数据


关闭所有打开的链接。

  • ? Memcached::prependByKey
  • Memcached::replace ?
  • PHP Manual
  • Memcached
  • 关闭所有打开的链接。

Memcached::quit

(PECL memcached >= 2.0.0)

Memcached::quit — 关闭所有打开的链接。

说明

public Memcached::quit ( ) : bool

Memcached::quit() 关闭所有memcache服务器的链接。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


替换已存在key下的元素

  • ? Memcached::quit
  • Memcached::replaceByKey ?
  • PHP Manual
  • Memcached
  • 替换已存在key下的元素

Memcached::replace

(PECL memcached >= 0.1.0)

Memcached::replace — 替换已存在key下的元素

说明

public Memcached::replace ( string $key , mixed $value , int $expiration = ? ) : bool

Memcached::replace()和Memcached::set()类似，但是如果 服务端不存在key， 操作将失败。

参数

key

用于存储值的键名。

value

存储的值。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如果key不存在，Memcached::getResultCode()返回Memcached::RES_NOTSTORED。

参见

  • Memcached::replaceByKey() - Replace the item under an existing key on a specific server
  • Memcached::set() - 存储一个元素
  • Memcached::add() - 向一个新的key下面增加一个元素


Replace the item under an existing key on a specific server

  • ? Memcached::replace
  • Memcached::resetServerList ?
  • PHP Manual
  • Memcached
  • Replace the item under an existing key on a specific server

Memcached::replaceByKey

(PECL memcached >= 0.1.0)

Memcached::replaceByKey — Replace the item under an existing key on a specific server

说明

public Memcached::replaceByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool

除了可以使用server_key自由的将key映射到指定服务器外， Memcached::replaceByKey()在功能上等同于Memcached::replace()。 (译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)。

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

用于存储值的键名。

value

存储的值。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如果key不存在，Memcached::getResultCode()返回Memcached::RES_NOTSTORED。

参见

  • Memcached::replace() - 替换已存在key下的元素
  • Memcached::set() - 存储一个元素
  • Memcached::add() - 向一个新的key下面增加一个元素


Clears all servers from the server list

  • ? Memcached::replaceByKey
  • Memcached::set ?
  • PHP Manual
  • Memcached
  • Clears all servers from the server list

Memcached::resetServerList

(PECL memcached >= 2.0.0)

Memcached::resetServerList — Clears all servers from the server list

说明

public Memcached::resetServerList ( ) : bool

Memcached::resetserverlist() removes all memcache servers from the known server list, resetting it back to empty.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • Memcached::addServer() - 向服务器池中增加一个服务器
  • Memcached::addServers() - 向服务器池中增加多台服务器


存储一个元素

  • ? Memcached::resetServerList
  • Memcached::setByKey ?
  • PHP Manual
  • Memcached
  • 存储一个元素

Memcached::set

(PECL memcached >= 0.1.0)

Memcached::set — 存储一个元素

说明

public Memcached::set ( string $key , mixed $value , int $expiration = ? ) : bool

Memcached::set()将value 存储在一个memcached服务器上的key下。expiration参数 用于控制值的过期时间。

值可以是任何有效的非资源型php类型， 因为资源类型不能被序列化存储。如果Memcached::OPT_COMPRESSION 选项开启， 序列化的值同样会被压缩存储。

参数

key

用于存储值的键名。

value

存储的值。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

范例

Example #1 Memcached::set() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'a simple string');
$m->set('array', array(11, 12));
/* 'object'这个key将在5分钟后过期 */
$m->set('object', new stdclass, time() + 300);

var_dump($m->get('int'));
var_dump($m->get('string'));
var_dump($m->get('array'));
var_dump($m->get('object'));
?>

以上例程的输出类似于：

int(99)
string(15) "a simple string"
array(2) {
  [0]=>
  int(11)
  [1]=>
  int(12)
}
object(stdClass)#1 (0) {
}

参见

  • Memcached::setByKey() - 将元素存储到指定的服务器上
  • Memcached::add() - 向一个新的key下面增加一个元素
  • Memcached::replace() - 替换已存在key下的元素


将元素存储到指定的服务器上

  • ? Memcached::set
  • Memcached::setMulti ?
  • PHP Manual
  • Memcached
  • 将元素存储到指定的服务器上

Memcached::setByKey

(PECL memcached >= 0.1.0)

Memcached::setByKey — 将元素存储到指定的服务器上

说明

public Memcached::setByKey ( string $server_key , string $key , mixed $value , int $expiration = ? ) : bool

除了可以使用server_key自由的将key映射到指定服务器外， Memcached::setByKey()在功能上等同于Memcached::set()。 (译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)。

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

用于存储值的键名。

value

存储的值。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

范例

Example #1 Memcached::setByKey() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

/* 保证block-ip系列key的存储在同一台服务器上。*/
$m->setByKey('api-cache', 'block-ip:169.254.253.252', 1);
$m->setByKey('api-cache', 'block-ip:169.127.127.202', 1);
?>

参见

  • Memcached::set() - 存储一个元素


存储多个元素

  • ? Memcached::setByKey
  • Memcached::setMultiByKey ?
  • PHP Manual
  • Memcached
  • 存储多个元素

Memcached::setMulti

(PECL memcached >= 0.1.0)

Memcached::setMulti — 存储多个元素

说明

public Memcached::setMulti ( array $items , int $expiration = ? ) : bool

Memcached::setMulti()类似于Memcached::set()， 但是使用了 参数items指定多个元素来替代单独的key/value设置以便于对多个元素的操作。expiration 参数指定的时候一次应用到所有的元素上。

参数

items

存放在服务器上的键／值对数组。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

范例

Example #1 Memcached::setMulti() 示例

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$items = array(
    'key1' => 'value1',
    'key2' => 'value2',
    'key3' => 'value3'
);
$m->setMulti($items, time() + 300);
?>

参见

  • Memcached::setMultiByKey() - Store multiple items on a specific server
  • Memcached::set() - 存储一个元素


Store multiple items on a specific server

  • ? Memcached::setMulti
  • Memcached::setOption ?
  • PHP Manual
  • Memcached
  • Store multiple items on a specific server

Memcached::setMultiByKey

(PECL memcached >= 0.1.0)

Memcached::setMultiByKey — Store multiple items on a specific server

说明

public Memcached::setMultiByKey ( string $server_key , array $items , int $expiration = ? ) : bool

除了可以使用server_key自由的将key映射到指定服务器外， Memcached::setMultiByKey()在功能上等同于Memcached::setMulti()。 (译注: 关于*ByKey系列方法及$server_key的工作原理请参照addByKey方法文档)。

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

items

存放在服务器上的键／值对数组。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

参见

  • Memcached::setMulti() - 存储多个元素
  • Memcached::set() - 存储一个元素


设置一个memcached选项

  • ? Memcached::setMultiByKey
  • Memcached::setOptions ?
  • PHP Manual
  • Memcached
  • 设置一个memcached选项

Memcached::setOption

(PECL memcached >= 0.1.0)

Memcached::setOption — 设置一个memcached选项

说明

public Memcached::setOption ( int $option , mixed $value ) : bool

这个方法用来设置Memcached option的值。一些选项和libmemcached中定义的类似， 还有一些则是 扩展所特有的。关于选项的更多信息请参阅Memcached Constants。

下面的选项列表需要通过特定的常量指定值。

  • Memcached::OPT_HASH需要Memcached::HASH_*系列常量值。

  • Memcached::OPT_DISTRIBUTION需要Memcached::DISTRIBUTION_*系列常量值。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 设置一个memcached选项值

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);
$m->setOption(Memcached::OPT_HASH, Memcached::HASH_MURMUR);
$m->setOption(Memcached::OPT_PREFIX_KEY, "widgets");
echo "Prefix key is now: ", $m->getOption(Memcached::OPT_PREFIX_KEY), "\n";
?>

以上例程会输出：

bool(true)
Prefix key is now: widgets

参见

  • Memcached::getOption() - 获取Memcached的选项值


Set Memcached options

  • ? Memcached::setOption
  • Memcached::setSaslAuthData ?
  • PHP Manual
  • Memcached
  • Set Memcached options

Memcached::setOptions

(PECL memcached >= 2.0.0)

Memcached::setOptions — Set Memcached options

说明

public Memcached::setOptions ( array $options ) : bool

Memcached::setOptions() is a variation of the Memcached::setOption() that takes an array of options to be set.

参数

options

An associative array of options where the key is the option to set and the value is the new value for the option.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Setting Memcached options

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);

$m->setOptions(array(Memcached::OPT_HASH => Memcached::HASH_MURMUR, Memcached::OPT_PREFIX_KEY => "widgets"));

var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);
echo "Prefix key is now: ", $m->getOption(Memcached::OPT_PREFIX_KEY), "\n";
?>

以上例程会输出：

bool(true)
bool(false)
Prefix key is now: widgets

参见

  • Memcached::getOption() - 获取Memcached的选项值
  • Memcached::setOption() - 设置一个memcached选项
  • Memcached Constants


Set the credentials to use for authentication

  • ? Memcached::setOptions
  • Memcached::touch ?
  • PHP Manual
  • Memcached
  • Set the credentials to use for authentication

Memcached::setSaslAuthData

(PECL memcached >= 2.0.0)

Memcached::setSaslAuthData — Set the credentials to use for authentication

说明

public Memcached::setSaslAuthData ( string $username , string $password ) : void

Memcached::setSaslAuthData() sets the username and password that should be used for SASL authentication with the memcache servers.

This method is only available when the memcached extension is built with SASL support. Please refer to Memcached setup for how to do this.

参数

username

The username to use for authentication.

password

The password to use for authentication.

返回值

没有返回值。


Set a new expiration on an item

  • ? Memcached::setSaslAuthData
  • Memcached::touchByKey ?
  • PHP Manual
  • Memcached
  • Set a new expiration on an item

Memcached::touch

(PECL memcached >= 2.0.0)

Memcached::touch — Set a new expiration on an item

说明

public Memcached::touch ( string $key , int $expiration ) : bool

Memcached::touch() sets a new expiration value on the given key.

参数

key

用于存储值的键名。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

参见

  • Memcached::touchByKey() - Set a new expiration on an item on a specific server


Set a new expiration on an item on a specific server

  • ? Memcached::touch
  • mqseries ?
  • PHP Manual
  • Memcached
  • Set a new expiration on an item on a specific server

Memcached::touchByKey

(PECL memcached >= 2.0.0)

Memcached::touchByKey — Set a new expiration on an item on a specific server

说明

public Memcached::touchByKey ( string $server_key , string $key , int $expiration ) : bool

Memcached::touchByKey() is functionally equivalent to Memcached::touch(), except that the free-form server_key can be used to map the key to a specific server.

参数

server_key

本键名用于识别储存和读取值的服务器。没有将实际的键名散列到具体的项目，而是在决定与哪一个 memcached 服务器通信时将其散列为服务器键名。这使得关联的项目在单一的服务上被组合起来以提高多重操作的效率。

key

用于存储值的键名。

expiration

到期时间，默认为 0。 更多信息请参见到期时间。

返回值

成功时返回 true， 或者在失败时返回 false。 如需要则使用 Memcached::getResultCode()。

参见

  • Memcached::touch() - Set a new expiration on an item


mqseries

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • mqseries 函数
    • mqseries_back — MQSeries MQBACK
    • mqseries_begin — MQseries MQBEGIN
    • mqseries_close — MQSeries MQCLOSE
    • mqseries_cmit — MQSeries MQCMIT
    • mqseries_conn — MQSeries MQCONN
    • mqseries_connx — MQSeries MQCONNX
    • mqseries_disc — MQSeries MQDISC
    • mqseries_get — MQSeries MQGET
    • mqseries_inq — MQSeries MQINQ
    • mqseries_open — MQSeries MQOPEN
    • mqseries_put1 — MQSeries MQPUT1
    • mqseries_put — MQSeries MQPUT
    • mqseries_set — MQSeries MQSET
    • mqseries_strerror — Returns the error message corresponding to a result code (MQRC)


简介

This extension aims to provide an interface for communicating with IBMs WebSphere MQ series Queue managers.

The interface mimics the C-API client interface of WebSphere MQ Series as close as possible. Using the same naming conventions and possibilities of the C-API. In order to understand the workings of this extension some level of understanding the C-API is required.

For MQ-options, MQ-structures, MQ-results etc. please read the WebSphere MQ Application Programming Guide and WebSphere MQ Application Programming Reference.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • mqseries
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

A working IBM WebSphere MQ installation. If building the extension the SDK for IBM WebSphere MQ is also required.

Note: Be aware that when running against a IBM WebSphere MQ Client installation some methods are not available. This is not a problem of the extension but just the way the WebSphere MQ Client Interface works.

Installation requirements on non windows platforms

Build the extension and put it in the PHP extension directory.

Installation requirements on Windows

No additional requirements.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/mqseries.

Note: The official name of this extension is mqseries.

There are two ways to connect to a queue manager. These depend on the way the extension is compiled and linked.

  • First one and also the default one is using the mqic libraries. Compiling and linking the extension against these IBM WebSphere MQSeries libraries allows the extension to connect to the Queue manager using the client interface. Remote connections are possible this way.

  • The other way is to compile and link against the mqm libraries. Using these libraries it is possible to make use of the transaction management of a queue manager.

Currently selecting the libraries to use is done by changing the config.m4 file.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

There are no extra configuration parameters.


资源类型

This extension defines a connection and object_handle resources.

The mqseries_conn() and mqseries_connx() define the connectionn handles.

The mqseries_open() defines the object handle.


预定义常量

For each WebSphere MQ Constant there is a mqseries counterpart.

For definitions and usage see the WebSphere MQ Application Programming Guide and WebSphere MQ Application Programming Reference red books.

The name of the mqseries counterpart is made by appending the WebSphere MQ constant with MQSERIES_, for example the CompletionCode constants are:

mqseries constants
PHP Constant | MQ Constant
MQSERIES_MQCC_OK | MQCC_OK
MQSERIES_MQCC_WARNING | MQCC_WARNING
MQSERIES_MQCC_FAILED | MQCC_FAILED
MQSERIES_MQCC_UNKNOWN | MQCC_UNKNOWN


mqseries 函数

Table of Contents

  • mqseries_back — MQSeries MQBACK
  • mqseries_begin — MQseries MQBEGIN
  • mqseries_close — MQSeries MQCLOSE
  • mqseries_cmit — MQSeries MQCMIT
  • mqseries_conn — MQSeries MQCONN
  • mqseries_connx — MQSeries MQCONNX
  • mqseries_disc — MQSeries MQDISC
  • mqseries_get — MQSeries MQGET
  • mqseries_inq — MQSeries MQINQ
  • mqseries_open — MQSeries MQOPEN
  • mqseries_put1 — MQSeries MQPUT1
  • mqseries_put — MQSeries MQPUT
  • mqseries_set — MQSeries MQSET
  • mqseries_strerror — Returns the error message corresponding to a result code (MQRC)


MQSeries MQBACK

  • ? mqseries 函数
  • mqseries_begin ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQBACK

mqseries_back

(PECL mqseries >= 0.10.0)

mqseries_back — MQSeries MQBACK

说明

mqseries_back ( resource $hconn , resource &$compCode , resource &$reason ) : void

The mqseries_back() (MQBACK) call indicates to the queue manager that all the message gets and puts that have occurred since the last syncpoint are to be backed out. Messages put as part of a unit of work are deleted; messages retrieved as part of a unit of work are reinstated on the queue.

Using mqseries_back() only works in conjunction with mqseries_begin() and only function when connecting directly to a Queueu manager. Not via the mqclient interface.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_back() example

<?php
    mqseries_back($conn, $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

注释

Note:

mqseries_back() will not function when using MQSeries Client to connect to a Queueu Manager.

参见

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_begin() - MQseries MQBEGIN


MQseries MQBEGIN

  • ? mqseries_back
  • mqseries_close ?
  • PHP Manual
  • mqseries 函数
  • MQseries MQBEGIN

mqseries_begin

(PECL mqseries >= 0.10.0)

mqseries_begin — MQseries MQBEGIN

说明

mqseries_begin ( resource $hconn , array $beginOptions , resource &$compCode , resource &$reason ) : void

The mqseries_begin() (MQBEGIN) call begins a unit of work that is coordinated by the queue manager, and that may involve external resource managers.

Using mqseries_begin() starts the unit of work. Either mqseries_back() or mqseries_cmit() ends the unit of work.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_begin() example

<?php
    $mqbo = array();
    mqseries_begin( $conn,
                    $mqbo,
                    $comp_code,
                    $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        /* reason code 2121 is a warning for more information see MQSeries reference manual.*/
        if ($reason !== 2121) {
            printf("CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        }
    }
?>

注释

Note:

mqseries_begin() will not function when using MQSeries Client to connect to a Queueu Manager.

参见

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_back() - MQSeries MQBACK
  • mqseries_cmit() - MQSeries MQCMIT


MQSeries MQCLOSE

  • ? mqseries_begin
  • mqseries_cmit ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQCLOSE

mqseries_close

(PECL mqseries >= 0.10.0)

mqseries_close — MQSeries MQCLOSE

说明

mqseries_close ( resource $hconn , resource $hobj , int $options , resource &$compCode , resource &$reason ) : void

The mqseries_close() (MQCLOSE) call relinquishes access to an object, and is the inverse of the mqseries_open() (MQOPEN) call.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

options

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_close() example

<?php
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("close CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

参见

  • mqseries_open() - MQSeries MQOPEN
  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX


MQSeries MQCMIT

  • ? mqseries_close
  • mqseries_conn ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQCMIT

mqseries_cmit

(PECL mqseries >= 0.10.0)

mqseries_cmit — MQSeries MQCMIT

说明

mqseries_cmit ( resource $hconn , resource &$compCode , resource &$reason ) : void

The mqseries_cmit() (MQCMIT) call indicates to the queue manager that the application has reached a syncpoint, and that all of the message gets and puts that have occurred since the last syncpoint are to be made permanent. Messages put as part of a unit of work are made available to other applications; messages retrieved as part of a unit of work are deleted.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_cmit() example

<?php
    mqseries_cmit($conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("cmit CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

注释

Note:

mqseries_back() will not function when using MQSeries Client to connect to a Queueu Manager.

参见

  • mqseries_begin() - MQseries MQBEGIN
  • mqseries_back() - MQSeries MQBACK
  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX


MQSeries MQCONN

  • ? mqseries_cmit
  • mqseries_connx ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQCONN

mqseries_conn

(PECL mqseries >= 0.10.0)

mqseries_conn — MQSeries MQCONN

说明

mqseries_conn ( string $qManagerName , resource &$hconn , resource &$compCode , resource &$reason ) : void

The mqseries_conn() (MQCONN) call connects an application program to a queue manager. It provides a queue manager connection handle, which is used by the application on subsequent message queuing calls.

参数

qManagerName

Name of queue manager.

Name of the queue manager the application wishes to connect.

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_conn() example

<?php
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("conn CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

参见

  • mqseries_disc() - MQSeries MQDISC


MQSeries MQCONNX

  • ? mqseries_conn
  • mqseries_disc ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQCONNX

mqseries_connx

(PECL mqseries >= 0.10.0)

mqseries_connx — MQSeries MQCONNX

说明

mqseries_connx ( string $qManagerName , array &$connOptions , resource &$hconn , resource &$compCode , resource &$reason ) : void

The mqseries_connx() (MQCONNX) call connects an application program to a queue manager. It provides a queue manager connection handle, which is used by the application on subsequent MQ calls.

The mqseries_connx() call is like the mqseries_conn() (MQCONN) call, except that MQCONNX allows options to be specified to control the way that the call works.

参数

qManagerName

Name of queue manager.

Name of the queue manager the application wishes to connect.

connOps

Options that control the action of function

See also the MQCNO structure.

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_connx() example

<?php
    $mqcno = array(
        'Version' => MQSERIES_MQCNO_VERSION_2,
        'Options' => MQSERIES_MQCNO_STANDARD_BINDING,
        'MQCD' => array('ChannelName' => 'MQNX9420.CLIENT',
        'ConnectionName' => 'localhost',
        'TransportType' => MQSERIES_MQXPT_TCP)
    );

    mqseries_connx('MQNX9420', $mqcno, $conn, $comp_code,$reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("Connx CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }

?>

Example #2 mqseries_connx() example using SSL connection & OCSP Responder URL

<?php
    $mqcno = array(
        'Version' => 4, //MQCNO_VERSION_4
        'Options' => MQSERIES_MQCNO_STANDARD_BINDING,
        'MQCD' => array(
            'Version' => 7, //MQCD_VERSION_7
            'ConnectionName' => 'localhost',
            'TransportType' => MQSERIES_MQXPT_TCP,
            'ChannelName' => 'CONNECTIONCHANNEL',
            'SSLCipherSpec' => 'NULL_SHA'
        ),
        'MQSCO' => array(
            'KeyRepository' => '/var/mqm/qmgrs/QUEUEMGR/ssl/key', //Local path where the SSL key repository can be found
            'MQAIR' => array(
                'Version' => 2, //MQAIR_VERSION_2
                'AuthInfoType' => 2, //MQAIT_OCSP
                'OCSPResponderURL' => 'http://dummy.OCSP.responder'
            )
        )
    );

    mqseries_connx('QUEUEMGR', $mqcno, $conn, $comp_code,$reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("Connx CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }

?>

参见

  • mqseries_disc() - MQSeries MQDISC


MQSeries MQDISC

  • ? mqseries_connx
  • mqseries_get ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQDISC

mqseries_disc

(PECL mqseries >= 0.10.0)

mqseries_disc — MQSeries MQDISC

说明

mqseries_disc ( resource $hconn , resource &$compCode , resource &$reason ) : void

The mqseries_disc() (MQDISC) call breaks the connection between the queue manager and the application program, and is the inverse of the mqseries_conn() (MQCONN) or mqseries_connx() (MQCONNX) call.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_disc() example

<?php
    mqseries_disc($conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("disc CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

参见

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX


MQSeries MQGET

  • ? mqseries_disc
  • mqseries_inq ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQGET

mqseries_get

(PECL mqseries >= 0.10.0)

mqseries_get — MQSeries MQGET

说明

mqseries_get ( resource $hConn , resource $hObj , array &$md , array &$gmo , int &$bufferLength , string &$msg , int &$data_length , resource &$compCode , resource &$reason ) : void

The mqseries_get() (MQGET) call retrieves a message from a local queue that has been opened using the mqseries_open() (MQOPEN) call

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

md

Message descriptor (MQMD).

gmo

Get message options (MQGMO).

bufferLength

Expected length of the result buffer

msg

Buffer holding the message that was retrieved from the object.

data_length

Actual buffer length

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_get() example

<?php
// open connection to the queue manager
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
// $conn now hold the reference to the connection to the queue manager.

// open the connection to the testq queue
    mqseries_open(
                $conn,
                array('ObjectName' => 'TESTQ'),
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
// $obj now holds the reference to the object (TESTQ)

// setup empty message descriptor.
    $mdg = array();
// setup get message options
    $gmo = array('Options' => MQSERIES_MQGMO_FAIL_IF_QUIESCING | MQSERIES_MQGMO_WAIT, 'WaitInterval' => 3000);

// get the message from the queue
    mqseries_get($conn, $obj, $mdg, $gmo, 255, $msg, $data_length, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("GET CompCode:%d Reason:%d Text:%s<br>", $comp_code, $reason, mqseries_strerror($reason));
    }

// close the object reference $obj
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);

// disconnect from the queue manager.
    mqseries_disc($conn, $comp_code, $reason);

?>

参见

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_put() - MQSeries MQPUT


MQSeries MQINQ

  • ? mqseries_get
  • mqseries_open ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQINQ

mqseries_inq

(PECL mqseries >= 0.10.0)

mqseries_inq — MQSeries MQINQ

说明

mqseries_inq ( resource $hconn , resource $hobj , int $selectorCount , array $selectors , int $intAttrCount , resource &$intAttr , int $charAttrLength , resource &$charAttr , resource &$compCode , resource &$reason ) : void

The mqseries_inq() (MQINQ) call returns an array of integers and a set of character strings containing the attributes of an object.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

selectorCount

Count of selectors.

selectors

Array of attribute selectors.

intAttrLength

Count of integer attributes.

intAttr

Array of integer attributes.

charAttrLength

Length of character attributes buffer.

charAttr

Character attributes.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_inq() example

<?php
    $int_attr = array();
    $char_attr = "";

    mqseries_inq($conn, $obj, 1, array(MQSERIES_MQCA_Q_MGR_NAME), 0, $int_attr, 48, $char_attr, $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("INQ CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    } else {
        echo "INQ QManager name result ".$char_attr."<br>\n";
    }
?>

参见

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN


MQSeries MQOPEN

  • ? mqseries_inq
  • mqseries_put1 ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQOPEN

mqseries_open

(PECL mqseries >= 0.10.0)

mqseries_open — MQSeries MQOPEN

说明

mqseries_open ( resource $hconn , array &$objDesc , int $option , resource &$hobj , resource &$compCode , resource &$reason ) : void

The mqseries_open() (MQOPEN) call establishes access to an object.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

objDesc

Object descriptor. (MQOD)

options

Options that control the action of the function.

hObj

Object handle.

This handle represents the object to be used.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_open() example

<?php
    $mqods = array('ObjectName' => 'TESTQ');
    mqseries_open(
                $conn,
                $mqods,
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("open CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

参见

  • mqseries_close() - MQSeries MQCLOSE


MQSeries MQPUT1

  • ? mqseries_open
  • mqseries_put ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQPUT1

mqseries_put1

(PECL mqseries >= 0.10.0)

mqseries_put1 — MQSeries MQPUT1

说明

mqseries_put1 ( resource $hconn , resource &$objDesc , resource &$msgDesc , resource &$pmo , string $buffer , resource &$compCode , resource &$reason ) : void

The mqseries_put1() (MQPUT1) call puts one message on a queue. The queue need not be open.

You can use both the mqseries_put() and mqseries_put1() calls to put messages on a queue; which call to use depends on the circumstances. Use the mqseries_put() (MQPUT) call to place multiple messages on the same queue. Use the mqseries_put1() (MQPUT1) call to put only one message on a queue. This call encapsulates the MQOPEN, MQPUT, and MQCLOSE calls into a single call, minimizing the number of calls that must be issued.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

objDesc

Object descriptor. (MQOD)

This is a structure which identifies the queue to which the message is added.

msgDesc

Message descriptor (MQMD).

pmo

Put message options (MQPMO).

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

参见

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_get() - MQSeries MQGET


MQSeries MQPUT

  • ? mqseries_put1
  • mqseries_set ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQPUT

mqseries_put

(PECL mqseries >= 0.10.0)

mqseries_put — MQSeries MQPUT

说明

mqseries_put ( resource $hConn , resource $hObj , array &$md , array &$pmo , string $message , resource &$compCode , resource &$reason ) : void

The mqseries_put() (MQPUT) call puts a message on a queue or distribution list. The queue or distribution list must already be open.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

md

Message descriptor (MQMD).

pmo

Put message options (MQPMO).

message

The actual message to put onto the queue.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

范例

Example #1 mqseries_put() example

<?php
// open connection to the queue manager
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
// $conn now hold the reference to the connection to the queue manager.

// open the connectio to the testq queueu
    mqseries_open(
                $conn,
                array('ObjectName' => 'TESTQ'),
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
// $obj now holds the reference to the object (TESTQ)

// setup the message descriptor array. Check MQSeries reference manuals.
    $md = array(
                'Version' => MQSERIES_MQMD_VERSION_1,
                'Expiry' => MQSERIES_MQEI_UNLIMITED,
                'Report' => MQSERIES_MQRO_NONE,
                'MsgType' => MQSERIES_MQMT_DATAGRAM,
                'Format' => MQSERIES_MQFMT_STRING,
                'Priority' => 1,
                'Persistence' => MQSERIES_MQPER_PERSISTENT);

// setup the put message options.
    $pmo = array('Options' => MQSERIES_MQPMO_NEW_MSG_ID|MQSERIES_MQPMO_SYNCPOINT);

// put the message 'Ping' on the queueu.
    mqseries_put($conn, $obj, $md, $pmo, 'Ping', $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("put CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }

// close the object reference $obj
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);

// disconnect from the queue manager.
    mqseries_disc($conn, $comp_code, $reason);

?>

参见

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_get() - MQSeries MQGET


MQSeries MQSET

  • ? mqseries_put
  • mqseries_strerror ?
  • PHP Manual
  • mqseries 函数
  • MQSeries MQSET

mqseries_set

(PECL mqseries >= 0.10.0)

mqseries_set — MQSeries MQSET

说明

mqseries_set ( resource $hConn , resource $hObj , int $selectorCount , array $selectors , int $intAttrCount , array $intAttrs , int $charAttrLength , array $charAttrs , resource &$compCode , resource &$reason ) : void

The mqseries_set() (MQSET) call is used to change the attributes of an object represented by a handle. The object must be a queue.

参数

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

selectorCount

Count of selectors.

selectors

Array of attribute selectors.

intAttrCount

Count of integer attributes.

intAttrs

Array of integer attributes.

charAttrLength

Length of character attributes buffer.

charAttrs

Character attributes.

compCode

Completion code.

reason

Reason code qualifying the compCode.

返回值

没有返回值。

参见

  • mqseries_inq() - MQSeries MQINQ


Returns the error message corresponding to a result code (MQRC)

  • ? mqseries_set
  • 网络 ?
  • PHP Manual
  • mqseries 函数
  • Returns the error message corresponding to a result code (MQRC)

mqseries_strerror

(PECL mqseries >= 0.10.0)

mqseries_strerror — Returns the error message corresponding to a result code (MQRC)

说明

mqseries_strerror ( int $reason ) : string

mqseries_strerror() returns the message that correspond to the reason result code.

参数

reason

Reason code qualifying the compCode.

返回值

string representation of the reason code message.

范例

Example #1 mqseries_strerror() example

<?php
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("open CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

以上例程会输出：

Connx CompCode:2 Reason:2059 Text:Queue manager not available for connection.


网络

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 网络 函数
    • checkdnsrr — 给指定的主机（域名）或者IP地址做DNS通信检查
    • closelog — 关闭系统日志链接
    • dns_check_record — 别名 checkdnsrr
    • dns_get_mx — 别名 getmxrr
    • dns_get_record — 获取指定主机的DNS记录
    • fsockopen — 打开一个网络连接或者一个Unix套接字连接
    • gethostbyaddr — 获取指定的IP地址对应的主机名
    • gethostbyname — 返回主机名对应的 IPv4地址。
    • gethostbynamel — 获取互联网主机名对应的 IPv4 地址列表
    • gethostname — 获取主机名
    • getmxrr — 获取互联网主机名对应的 MX 记录
    • getprotobyname — Get protocol number associated with protocol name
    • getprotobynumber — Get protocol name associated with protocol number
    • getservbyname — 获取互联网服务协议对应的端口
    • getservbyport — Get Internet service which corresponds to port and protocol
    • header_register_callback — 调用一个 header 函数
    • header_remove — 删除之前设置的 HTTP 头
    • header — 发送原生 HTTP 头
    • headers_list — 返回已发送的 HTTP 响应头（或准备发送的）
    • headers_sent — 检测 HTTP 头是否已经发送
    • http_response_code — 获取/设置响应的 HTTP 状态码
    • inet_ntop — Converts a packed internet address to a human readable representation
    • inet_pton — Converts a human readable IP address to its packed in_addr representation
    • ip2long — 将 IPV4 的字符串互联网协议转换成长整型数字
    • long2ip — 将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）
    • openlog — Open connection to system logger
    • pfsockopen — 打开一个持久的网络连接或者Unix套接字连接。
    • setcookie — 发送 Cookie
    • setrawcookie — 发送未经 URL 编码的 cookie
    • socket_get_status — 别名 stream_get_meta_data
    • socket_set_blocking — 别名 stream_set_blocking
    • socket_set_timeout — 别名 stream_set_timeout
    • syslog — Generate a system log message


  • ? 网络
  • 安装／配置 ?
  • PHP Manual
  • 网络
  • 简介

简介

提供一系列联网函数。


需求

Functions checkdnsrr(), getmxrr() and dns_get_record() requires Bind on Linux.


资源类型

This extension defines a file pointer resource returned by fsockopen() and pfsockopen().


预定义常量

下列常量作为 PHP 核心的一部分总是可用的。

openlog() Options
Constant | Description
LOG_CONS | if there is an error while sending data to the system logger, write directly to the system console
LOG_NDELAY | open the connection to the logger immediately
LOG_ODELAY | (default) delay opening the connection until the first message is logged
LOG_NOWAIT |
LOG_PERROR | print log message also to standard error
LOG_PID | include PID with each message
openlog() Facilities
Constant | Description
LOG_AUTH | security/authorization messages (use LOG_AUTHPRIV instead in systems where that constant is defined)
LOG_AUTHPRIV | security/authorization messages (private)
LOG_CRON | clock daemon (cron and at)
LOG_DAEMON | other system daemons
LOG_KERN | kernel messages
LOG_LOCAL0 ... LOG_LOCAL7 | reserved for local use, these are not available in Windows
LOG_LPR | line printer subsystem
LOG_MAIL | mail subsystem
LOG_NEWS | USENET news subsystem
LOG_SYSLOG | messages generated internally by syslogd
LOG_USER | generic user-level messages
LOG_UUCP | UUCP subsystem
syslog() Priorities (in descending order)
Constant | Description
LOG_EMERG | system is unusable
LOG_ALERT | action must be taken immediately
LOG_CRIT | critical conditions
LOG_ERR | error conditions
LOG_WARNING | warning conditions
LOG_NOTICE | normal, but significant, condition
LOG_INFO | informational message
LOG_DEBUG | debug-level message
dns_get_record() Options
Constant | Description
DNS_A | IPv4 Address Resource
DNS_CAA | Certification Authority Authorization Resource (available as of PHP 7.0.16 and 7.1.2)
DNS_MX | Mail Exchanger Resource
DNS_CNAME | Alias (Canonical Name) Resource
DNS_NS | Authoritative Name Server Resource
DNS_PTR | Pointer Resource
DNS_HINFO | Host Info Resource (See IANA's » Operating System Names for the meaning of these values)
DNS_SOA | Start of Authority Resource
DNS_TXT | Text Resource
DNS_ANY | Any Resource Record. On most systems this returns all resource records, however it should not be counted upon for critical uses. Try DNS_ALL instead.
DNS_AAAA | IPv6 Address Resource
DNS_ALL | Iteratively query the name server for each available record type.


网络 函数

Table of Contents

  • checkdnsrr — 给指定的主机（域名）或者IP地址做DNS通信检查
  • closelog — 关闭系统日志链接
  • dns_check_record — 别名 checkdnsrr
  • dns_get_mx — 别名 getmxrr
  • dns_get_record — 获取指定主机的DNS记录
  • fsockopen — 打开一个网络连接或者一个Unix套接字连接
  • gethostbyaddr — 获取指定的IP地址对应的主机名
  • gethostbyname — 返回主机名对应的 IPv4地址。
  • gethostbynamel — 获取互联网主机名对应的 IPv4 地址列表
  • gethostname — 获取主机名
  • getmxrr — 获取互联网主机名对应的 MX 记录
  • getprotobyname — Get protocol number associated with protocol name
  • getprotobynumber — Get protocol name associated with protocol number
  • getservbyname — 获取互联网服务协议对应的端口
  • getservbyport — Get Internet service which corresponds to port and protocol
  • header_register_callback — 调用一个 header 函数
  • header_remove — 删除之前设置的 HTTP 头
  • header — 发送原生 HTTP 头
  • headers_list — 返回已发送的 HTTP 响应头（或准备发送的）
  • headers_sent — 检测 HTTP 头是否已经发送
  • http_response_code — 获取/设置响应的 HTTP 状态码
  • inet_ntop — Converts a packed internet address to a human readable representation
  • inet_pton — Converts a human readable IP address to its packed in_addr representation
  • ip2long — 将 IPV4 的字符串互联网协议转换成长整型数字
  • long2ip — 将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）
  • openlog — Open connection to system logger
  • pfsockopen — 打开一个持久的网络连接或者Unix套接字连接。
  • setcookie — 发送 Cookie
  • setrawcookie — 发送未经 URL 编码的 cookie
  • socket_get_status — 别名 stream_get_meta_data
  • socket_set_blocking — 别名 stream_set_blocking
  • socket_set_timeout — 别名 stream_set_timeout
  • syslog — Generate a system log message


给指定的主机（域名）或者IP地址做DNS通信检查

  • ? 网络 函数
  • closelog ?
  • PHP Manual
  • 网络 函数
  • 给指定的主机（域名）或者IP地址做DNS通信检查

checkdnsrr

(PHP 4, PHP 5, PHP 7, PHP 8)

checkdnsrr — 给指定的主机（域名）或者IP地址做DNS通信检查

说明

checkdnsrr ( string $host , string $type = "MX" ) : bool

根据不同记录（type）类型查询主机（host）相应的DNS记录。

参数

host

主机（host）可以是一个IP地址也可以是域名。

type

解析记录类型（type）可能是下面这些类型中的任何一个：A，MX，NS，SOA，PTR，CNAME，AAAA，A6， SRV，NAPTR，TXT 或者 ANY。

返回值

如果记录能找到，就返回true；如果查找不到该DNS记录或者发生了错误，就返回false。

更新日志

版本 | 说明
5.3.0 | 这个函数在Windows平台上也可以使用了。
5.2.4 | 增加了TXT的记录类型。
5.0.0 | 增加了AAAA的记录类型。

注释

Note:

出于对低版本在windows平台上的兼容性，可以试试» PEAR扩展包里面提供的 » Net_DNS类。

参见

  • dns_get_record() - 获取指定主机的DNS记录
  • getmxrr() - 获取互联网主机名对应的 MX 记录
  • gethostbyaddr() - 获取指定的IP地址对应的主机名
  • gethostbyname() - 返回主机名对应的 IPv4地址。
  • gethostbynamel() - 获取互联网主机名对应的 IPv4 地址列表
  • the named(8) manual page


关闭系统日志链接

  • ? checkdnsrr
  • dns_check_record ?
  • PHP Manual
  • 网络 函数
  • 关闭系统日志链接

closelog

(PHP 4, PHP 5, PHP 7, PHP 8)

closelog — 关闭系统日志链接

说明

closelog ( ) : bool

closelog() 关闭用于通信的描述符并写入系统日志。closelog()是可选的。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • syslog() - Generate a system log message
  • openlog() - Open connection to system logger


别名 checkdnsrr

  • ? closelog
  • dns_get_mx ?
  • PHP Manual
  • 网络 函数
  • 别名 checkdnsrr

dns_check_record

(PHP 5, PHP 7, PHP 8)

dns_check_record — 别名 checkdnsrr()

说明

此函数是该函数的别名： checkdnsrr()。


别名 getmxrr

  • ? dns_check_record
  • dns_get_record ?
  • PHP Manual
  • 网络 函数
  • 别名 getmxrr

dns_get_mx

(PHP 5, PHP 7, PHP 8)

dns_get_mx — 别名 getmxrr()

说明

此函数是该函数的别名： getmxrr()。


获取指定主机的DNS记录

  • ? dns_get_mx
  • fsockopen ?
  • PHP Manual
  • 网络 函数
  • 获取指定主机的DNS记录

dns_get_record

(PHP 5, PHP 7, PHP 8)

dns_get_record — 获取指定主机的DNS记录

说明

dns_get_record ( string $hostname , int $type = DNS_ANY , array &$authns = ? , array &$addtl = ? , bool &$raw = false ) : array

获取指定主机（hostname）的DNS记录。

参数

hostname

主机名（hostname）应该是一个DNS解析生效的域名，例如"www.example.com"。主机名也可以是通过对逆向解析域做DNS逆向域名解析而得到，但是在大多数情况下gethostbyaddr()更加适合做逆向域名解析。

Note:

每个DNS标准，邮件地址必须是user.host这样的格式（例如hostmaster.example.com而不是hostmaster@example.com），在使用mail()这个函数之前请检查这个值，有必要的话还需要修改。

type

默认情况下，dns_get_record()将会搜索所有与hostname相关的记录，可以通过设置type来限定查询。type的值可以是下面的其中的任何一个： DNS_A，DNS_CNAME，DNS_HINFO，DNS_MX，DNS_NS，DNS_PTR，DNS_SOA，DNS_TXT，DNS_AAAA，DNS_SRV，DNS_NAPTR，DNS_A6，DNS_ALL或者DNS_ANY。

Note:

由于dns在各个平台上表现有些不一样，DNS_ANY不会总是返回所有的记录，DNS_ALL虽然慢一些，但是会得到所有的记录，所以使用DNS_ALL更加可靠些。

authns

以引用方式传递，如果写了该参数，那么将会得到该解析记录的DNS服务器（Authoritative Name Servers）的信息。

addtl

以引用方式传递，如果填写了该参数，将会得到其他所有的DNS解析记录。

raw

在原生模式下，在进行额外的查询的时候之前我们只执行请求的DNS类型，而不是循环查询所有的类型。

返回值

这个函数返回一个关联数组，如果失败则 或者在失败时返回 false。每个关联数组都至少包含了以下的这些键。 at minimum the following keys:

Basic DNS attributes
Attribute | Meaning
host | The record in the DNS namespace to which the rest of the associated data refers.
class | dns_get_record() only returns Internet class records and as such this parameter will always return IN.
type | String containing the record type. Additional attributes will also be contained in the resulting array dependant on the value of type. See table below.
ttl | "Time To Live" remaining for this record. This will not equal the record's original ttl, but will rather equal the original ttl minus whatever length of time has passed since the authoritative name server was queried.

Other keys in associative arrays dependant on 'type'
Type | Extra Columns
A | ip: An IPv4 addresses in dotted decimal notation.
MX | pri: Priority of mail exchanger. Lower numbers indicate greater priority. target: FQDN of the mail exchanger. See also dns_get_mx().
CNAME | target: FQDN of location in DNS namespace to which the record is aliased.
NS | target: FQDN of the name server which is authoritative for this hostname.
PTR | target: Location within the DNS namespace to which this record points.
TXT | txt: Arbitrary string data associated with this record.
HINFO | cpu: IANA number designating the CPU of the machine referenced by this record. os: IANA number designating the Operating System on the machine referenced by this record. See IANA's » Operating System Names for the meaning of these values.
SOA | mname: FQDN of the machine from which the resource records originated. rname: Email address of the administrative contain for this domain. serial: Serial # of this revision of the requested domain. refresh: Refresh interval (seconds) secondary name servers should use when updating remote copies of this domain. retry: Length of time (seconds) to wait after a failed refresh before making a second attempt. expire: Maximum length of time (seconds) a secondary DNS server should retain remote copies of the zone data without a successful refresh before discarding. minimum-ttl: Minimum length of time (seconds) a client can continue to use a DNS resolution before it should request a new resolution from the server. Can be overridden by individual resource records.
AAAA | ipv6: IPv6 address
A6(PHP >= 5.1.0) | masklen: Length (in bits) to inherit from the target specified by chain. ipv6: Address for this specific record to merge with chain. chain: Parent record to merge with ipv6 data.
SRV | pri: (Priority) lowest priorities should be used first. weight: Ranking to weight which of commonly prioritized targets should be chosen at random. target and port: hostname and port where the requested service can be found. For additional information see: » RFC 2782
NAPTR | order and pref: Equivalent to pri and weight above. flags, services, regex, and replacement: Parameters as defined by » RFC 2915.

更新日志

版本 | 说明
5.4.0 | 增加了参数raw。
5.3.0 | 可以是在windows平台上使用这个函数了。
5.3.0 | 在此版本之前，如果给参数authns传入值，则必须同时传入addtl的值。

范例

Example #1 使用 dns_get_record()函数

<?php
$result = dns_get_record("php.net");
print_r($result);
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)

Example #2 使用dns_get_record()配合DNS_ANY的例子

由于我们经常会想获取一个邮件服务器的对应的IP地址的MX记录是否已经生效。在使用dns_get_record()函数之后，addtl能够返回一个相关的数组记录，authns参数则会返回授权服务器的列表信息。

<?php
/* Request "ANY" record for php.net,
   and create $authns and $addtl arrays
   containing list of name servers and
   any additional records which go with
   them */
$result = dns_get_record("php.net", DNS_ANY, $authns, $addtl);
echo "Result = ";
print_r($result);
echo "Auth NS = ";
print_r($authns);
echo "Additional = ";
print_r($addtl);
?>

以上例程的输出类似于：

Result = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)
Auth NS = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [1] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [2] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [3] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

)
Additional = Array
(
    [0] => Array
        (
            [host] => pair2.php.net
            [type] => A
            [ip] => 216.92.131.5
            [class] => IN
            [ttl] => 6766
        )

    [1] => Array
        (
            [host] => remote1.easydns.com
            [type] => A
            [ip] => 64.39.29.212
            [class] => IN
            [ttl] => 100384
        )

    [2] => Array
        (
            [host] => remote2.easydns.com
            [type] => A
            [ip] => 212.100.224.80
            [class] => IN
            [ttl] => 81241
        )

    [3] => Array
        (
            [host] => ns1.easydns.com
            [type] => A
            [ip] => 216.220.40.243
            [class] => IN
            [ttl] => 81241
        )

    [4] => Array
        (
            [host] => ns2.easydns.com
            [type] => A
            [ip] => 216.220.40.244
            [class] => IN
            [ttl] => 81241
        )

)

注释

Note:

For compatibility with versions before PHP 5.3.0 on some operating systems, try the » PEAR class » Net_DNS.

参见

  • dns_get_mx() - 别名 getmxrr
  • dns_check_record() - 别名 checkdnsrr


打开一个网络连接或者一个Unix套接字连接

  • ? dns_get_record
  • gethostbyaddr ?
  • PHP Manual
  • 网络 函数
  • 打开一个网络连接或者一个Unix套接字连接

fsockopen

(PHP 4, PHP 5, PHP 7, PHP 8)

fsockopen — 打开一个网络连接或者一个Unix套接字连接

说明

fsockopen ( string $hostname , int $port = -1 , int &$errno = ? , string &$errstr = ? , float $timeout = ini_get("default_socket_timeout") ) : resource

初始化一个套接字连接到指定主机（hostname）。

PHP支持以下的套接字传输器类型列表 所支持的套接字传输器（Socket Transports）列表。也可以通过stream_get_transports()来获取套接字传输器支持类型。

默认情况下将以阻塞模式开启套接字连接。当然你可以通过stream_set_blocking()将它转换到非阻塞模式。

stream_socket_client()与之非常相似，而且提供了更加丰富的参数设置，包括非阻塞模式和提供上下文的的设置。

参数

hostname

如果安装了OpenSSL，那么你也许应该在你的主机名地址前面添加访问协议ssl://或者是tls://，从而可以使用基于TCP/IP协议的SSL或者TLS的客户端连接到远程主机。

port

端口号。如果对该参数传一个-1，则表示不使用端口，例如unix://。

errno

如果传入了该参数，holds the system level error number that occurred in the system-level connect() call。

如果errno的返回值为0，而且这个函数的返回值为false，那么这表明该错误发生在套接字连接（connect()）调用之前，导致连接失败的原因最大的可能是初始化套接字的时候发生了错误。

errstr

错误信息将以字符串的信息返回。

timeout

设置连接的时限，单位为秒。

Note:

注意：如果你要对建立在套接字基础上的读写操作设置操作时间设置连接时限，请使用stream_set_timeout()，fsockopen()的连接时限（timeout）的参数仅仅在套接字连接的时候生效。

返回值

fsockopen()将返回一个文件句柄，之后可以被其他文件类函数调用（例如：fgets()，fgetss()，fwrite()，fclose()还有feof()）。如果调用失败，将返回false。

错误／异常

如果主机（hostname）不可访问，将会抛出一个警告级别（E_WARNING）的错误提示。

更新日志

版本 | 说明
4.3.0 | 在win32系统上增加了对时限设置（timeout）参数的支持。
4.3.0 | 在TCP/IP协议的基础上增加了SSL和TLS。

范例

Example #1 fsockopen()的例子

<?php
$fp = fsockopen("www.example.com", 80, $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br />\n";
} else {
    $out = "GET / HTTP/1.1\r\n";
    $out .= "Host: www.example.com\r\n";
    $out .= "Connection: Close\r\n\r\n";
    fwrite($fp, $out);
    while (!feof($fp)) {
        echo fgets($fp, 128);
    }
    fclose($fp);
}
?>

Example #2 使用UDP连接

下面这个例子展示了怎么样在自己的机器上通过UDP套接字连接（端口号13）来检索日期和时间。

<?php
$fp = fsockopen("udp://127.0.0.1", 13, $errno, $errstr);
if (!$fp) {
    echo "ERROR: $errno - $errstr<br />\n";
} else {
    fwrite($fp, "\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

注释

Note:

因为环境的不同，某些情况下在Unix套接字连接或者自定义的连接设置连接时限（timeout）可能不会生效。

Warning

UDP套接字有些时候在即使远程主机未知的情况，也能打开，并且不发生任何错误。只有当你通过该套接字进行读写的时候才会发现错误。之所以会这样，是因为UDP是一个"非连接状态"的协议，那么这就意味着当前操作系统直到它（套接字）真正需要发送和接受数据的时候才会去尝试为其去建立连接。

Note: 当指定数值型的 IPv6 地址（例如 fe80::1）时必须用方括号将 IP 围起来——例如， tcp://[fe80::1]:80。

参见

  • pfsockopen() - 打开一个持久的网络连接或者Unix套接字连接。
  • stream_socket_client() - Open Internet or Unix domain socket connection
  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式
  • stream_set_timeout() - Set timeout period on a stream
  • fgets() - 从文件指针中读取一行
  • fgetss() - 从文件指针中读取一行并过滤掉 HTML 标记
  • fwrite() - 写入文件（可安全用于二进制文件）
  • fclose() - 关闭一个已打开的文件指针
  • feof() - 测试文件指针是否到了文件结束的位置
  • socket_connect() - 开启一个套接字连接
  • The Curl extension


获取指定的IP地址对应的主机名

  • ? fsockopen
  • gethostbyname ?
  • PHP Manual
  • 网络 函数
  • 获取指定的IP地址对应的主机名

gethostbyaddr

(PHP 4, PHP 5, PHP 7, PHP 8)

gethostbyaddr — 获取指定的IP地址对应的主机名

说明

gethostbyaddr ( string $ip_address ) : string

返回指定的IP地址（ip_address）对应的主机名。

参数

ip_address

主机的IP地址。

返回值

成功则返回主机名；失败则原样输出（输出IP地址）；如果输入的格式不正常，则返回false。

范例

Example #1 一个使用 gethostbyaddr() 的简单例子

<?php
$hostname = gethostbyaddr($_SERVER['REMOTE_ADDR']);

echo $hostname;
?>

参见

  • gethostbyname() - 返回主机名对应的 IPv4地址。
  • gethostbynamel() - 获取互联网主机名对应的 IPv4 地址列表


返回主机名对应的 IPv4地址。

  • ? gethostbyaddr
  • gethostbynamel ?
  • PHP Manual
  • 网络 函数
  • 返回主机名对应的 IPv4地址。

gethostbyname

(PHP 4, PHP 5, PHP 7, PHP 8)

gethostbyname — 返回主机名对应的 IPv4地址。

说明

gethostbyname ( string $hostname ) : string

返回主机名 hostname 对应的 IPv4 互联网地址。

参数

hostname

主机名

返回值

成功时返回 IPv4 地址，失败时原封不动返回 hostname 字符串。

范例

Example #1 简单的 gethostbyname() 例子

<?php
$ip = gethostbyname('www.example.com');

echo $ip;
?>

参见

  • gethostbyaddr() - 获取指定的IP地址对应的主机名
  • gethostbynamel() - 获取互联网主机名对应的 IPv4 地址列表
  • inet_pton() - Converts a human readable IP address to its packed in_addr representation
  • inet_ntop() - Converts a packed internet address to a human readable representation


获取互联网主机名对应的 IPv4 地址列表

  • ? gethostbyname
  • gethostname ?
  • PHP Manual
  • 网络 函数
  • 获取互联网主机名对应的 IPv4 地址列表

gethostbynamel

(PHP 4, PHP 5, PHP 7, PHP 8)

gethostbynamel — 获取互联网主机名对应的 IPv4 地址列表

说明

gethostbynamel ( string $hostname ) : array

返回互联网主机名 hostname 解析出来的 IPv4 地址列表。

参数

hostname

主机名。

返回值

返回 IPv4 地址数组， 或在 hostname 无法解析时返回 false。

范例

Example #1 gethostbynamel() 例子

<?php
$hosts = gethostbynamel('www.example.com');
print_r($hosts);
?>

以上例程会输出：

Array
(
    [0] => 192.0.34.166
)

参见

  • gethostbyname() - 返回主机名对应的 IPv4地址。
  • gethostbyaddr() - 获取指定的IP地址对应的主机名
  • checkdnsrr() - 给指定的主机（域名）或者IP地址做DNS通信检查
  • getmxrr() - 获取互联网主机名对应的 MX 记录
  • Linux 手册页 named(8)


获取主机名

  • ? gethostbynamel
  • getmxrr ?
  • PHP Manual
  • 网络 函数
  • 获取主机名

gethostname

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

gethostname — 获取主机名

说明

gethostname ( ) : string

gethostname() 可以获取本地机器的标准主机名。

返回值

成功时返回主机名称字符串，失败时返回 false。

范例

Example #1 简单的 gethostname() 例子

<?php
echo gethostname(); // may output e.g,: sandie

// Or, an option that also works before PHP 5.3
echo php_uname('n'); // may output e.g,: sandie
?>

参见

  • gethostbyname() - 返回主机名对应的 IPv4地址。
  • gethostbyaddr() - 获取指定的IP地址对应的主机名
  • php_uname() - 返回运行 PHP 的系统的有关信息


获取互联网主机名对应的 MX 记录

  • ? gethostname
  • getprotobyname ?
  • PHP Manual
  • 网络 函数
  • 获取互联网主机名对应的 MX 记录

getmxrr

(PHP 4, PHP 5, PHP 7, PHP 8)

getmxrr — 获取互联网主机名对应的 MX 记录

说明

getmxrr ( string $hostname , array &$mxhosts , array &$weight = ? ) : bool

搜索 hostname对应的 MX DNS 记录。

参数

hostname

互联网主机名。

mxhosts

找到的 MX 记录列表存放于 mxhosts 数组。

weight

提供了 weight 数组后，它会用找到的权重信息填充数组。

返回值

找到记录返回 true，没找到或者出错时返回 false。

更新日志

版本 | 说明
5.3.0 | Windows 平台上也能用这个函数了。

注释

Note:

本函数不应使用于地址验证。 仅在 MX 记录在 DNS 中找到时才会返回，然而根据 » RFC 2821， 没有 MX 记录时， hostname 本身就是 MX 主机，优先级为 0。

Note:

在兼容 Windows 实现之前的版本， 可以使用 » PEAR class 的 » Net_DNS。

参见

  • checkdnsrr() - 给指定的主机（域名）或者IP地址做DNS通信检查
  • dns_get_record() - 获取指定主机的DNS记录
  • gethostbyname() - 返回主机名对应的 IPv4地址。
  • gethostbynamel() - 获取互联网主机名对应的 IPv4 地址列表
  • gethostbyaddr() - 获取指定的IP地址对应的主机名
  • Linux 手册页面 named(8)


Get protocol number associated with protocol name

  • ? getmxrr
  • getprotobynumber ?
  • PHP Manual
  • 网络 函数
  • Get protocol number associated with protocol name

getprotobyname

(PHP 4, PHP 5, PHP 7, PHP 8)

getprotobyname — Get protocol number associated with protocol name

说明

getprotobyname ( string $protocol ) : int|false

getprotobyname() returns the protocol number associated with the protocol protocol as per /etc/protocols.

参数

protocol

The protocol name.

返回值

Returns the protocol number, 或者在失败时返回 false.

范例

Example #1 getprotobyname() example

<?php
$protocol = 'tcp';
$get_prot = getprotobyname($protocol);
if ($get_prot === FALSE) {
    echo 'Invalid Protocol';
} else {
    echo 'Protocol #' . $get_prot;
}
?>

参见

  • getprotobynumber() - Get protocol name associated with protocol number


Get protocol name associated with protocol number

  • ? getprotobyname
  • getservbyname ?
  • PHP Manual
  • 网络 函数
  • Get protocol name associated with protocol number

getprotobynumber

(PHP 4, PHP 5, PHP 7, PHP 8)

getprotobynumber — Get protocol name associated with protocol number

说明

getprotobynumber ( int $protocol ) : string|false

getprotobynumber() returns the protocol name associated with protocol protocol as per /etc/protocols.

参数

protocol

The protocol number.

返回值

Returns the protocol name as a string, 或者在失败时返回 false.

参见

  • getprotobyname() - Get protocol number associated with protocol name


获取互联网服务协议对应的端口

  • ? getprotobynumber
  • getservbyport ?
  • PHP Manual
  • 网络 函数
  • 获取互联网服务协议对应的端口

getservbyname

(PHP 4, PHP 5, PHP 7, PHP 8)

getservbyname — 获取互联网服务协议对应的端口

说明

getservbyname ( string $service , string $protocol ) : int

getservbyname() 返回互联网服务 service 指定的协议 protocol 中对应的端口， 依据 /etc/services。

参数

service

互联网服务名称的字符串。

protocol

protocol 既可以是 "tcp" 也可以是 "udp" (小写)。

返回值

返回端口号，如果 service 或 protocol 未找到返回 false。

范例

Example #1 getservbyname() 例子

<?php
$services = array('http', 'ftp', 'ssh', 'telnet', 'imap',
'smtp', 'nicname', 'gopher', 'finger', 'pop3', 'www');

foreach ($services as $service) {
    $port = getservbyname($service, 'tcp');
    echo $service . ": " . $port . "<br />\n";
}
?>

参见

  • getservbyport() - Get Internet service which corresponds to port and protocol
  • » http://www.iana.org/assignments/port-numbers 端口号的完整列表


Get Internet service which corresponds to port and protocol

  • ? getservbyname
  • header_register_callback ?
  • PHP Manual
  • 网络 函数
  • Get Internet service which corresponds to port and protocol

getservbyport

(PHP 4, PHP 5, PHP 7, PHP 8)

getservbyport — Get Internet service which corresponds to port and protocol

说明

getservbyport ( int $port , string $protocol ) : string|false

getservbyport() returns the Internet service associated with port for the specified protocol as per /etc/services.

参数

port

The port number.

protocol

protocol is either "tcp" or "udp" (in lowercase).

返回值

Returns the Internet service name as a string, 或者在失败时返回 false.

参见

  • getservbyname() - 获取互联网服务协议对应的端口


调用一个 header 函数

  • ? getservbyport
  • header_remove ?
  • PHP Manual
  • 网络 函数
  • 调用一个 header 函数

header_register_callback

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

header_register_callback — 调用一个 header 函数

说明

header_register_callback ( callable $callback ) : bool

注册一个函数，在 PHP 开始发送输出时调用。

PHP 准备好所有响应头，在发送内容之前执行 callback，创建了一个发送响应头的操作窗口。

参数

callback

在头发送前调用函数。 它没有参数，返回的值也会被忽略。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 header_register_callback() 例子

<?php

header('Content-Type: text/plain');
header('X-Test: foo');

function foo() {
 foreach (headers_list() as $header) {
   if (strpos($header, 'X-Powered-By:') !== false) {
     header_remove('X-Powered-By');
   }
   header_remove('X-Test');
 }
}

$result = header_register_callback('foo');
echo "a";
?>

以上例程的输出类似于：

Content-Type: text/plain

a

注释

header_register_callback() 是在头即将发送前执行的， 所以本函数的任意内容输出都会打断输出过程。

Note:

数据头只会在SAPI支持时得到处理和输出。

参见

  • headers_list() - 返回已发送的 HTTP 响应头（或准备发送的）
  • header_remove() - 删除之前设置的 HTTP 头
  • header() - 发送原生 HTTP 头


删除之前设置的 HTTP 头

  • ? header_register_callback
  • header ?
  • PHP Manual
  • 网络 函数
  • 删除之前设置的 HTTP 头

header_remove

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

header_remove — 删除之前设置的 HTTP 头

说明

header_remove ( string $name = ? ) : void

删除之前用 header() 设置的 HTTP 头。

参数

name

要移除的头名称。

Note: 参数不分大小写。

返回值

没有返回值。

范例

Example #1 取消指定的头

<?php
header("X-Foo: Bar");
header("X-Bar: Baz");
header_remove("X-Foo");
?>

以上例程的输出类似于：

X-Bar: Baz

Example #2 取消之前全部指定的头

<?php
header("X-Foo: Bar");
header("X-Bar: Baz");
header_remove();
?>

以上例程的输出类似于：

注释

Caution

    本函数会删除所有 PHP 设置的头，
    包括 Cookie、Session 和 X-Powered-By。

Note:

 数据头只会在SAPI支持时得到处理和输出。

参见

  • header() - 发送原生 HTTP 头
    •

  • headers_sent() - 检测 HTTP 头是否已经发送
    •


发送原生 HTTP 头

  • ? header_remove
  • headers_list ?
  • PHP Manual
  • 网络 函数
  • 发送原生 HTTP 头

header

(PHP 4, PHP 5, PHP 7, PHP 8)

header — 发送原生 HTTP 头

说明

header ( string $string , bool $replace = true , int $http_response_code = ? ) : void

header() 用于发送原生的 HTTP 头。关于 HTTP 头的更多信息请参考 » HTTP/1.1 specification。

请注意 header() 必须在任何实际输出之前调用，不管是普通的 HTML 标签，还是文件或 PHP 输出的空行，空格。这是个常见的错误，在通过include，require，或者其访问其他文件里面的函数的时候，如果在header()被调用之前，其中有空格或者空行。 同样的问题也存在于单独的 PHP/HTML 文件中。

<html>
<?php
/* This will give an error. Note the output
 * above, which is before the header() call */
header('Location: http://www.example.com/');
exit;
?>

参数

string

头字符串。

有两种特别的头。第一种以"HTTP/"开头的 (case is not significant)，将会被用来计算出将要发送的HTTP状态码。 例如在 Apache 服务器上用 PHP 脚本来处理不存在文件的请求（使用 ErrorDocument 指令）， 就会希望脚本响应了正确的状态码。

<?php
header("HTTP/1.0 404 Not Found");
?>

第二种特殊情况是"Location:"的头信息。它不仅把报文发送给浏览器，而且还将返回给浏览器一个 REDIRECT（302）的状态码，除非状态码已经事先被设置为了201或者3xx。

<?php
header("Location: http://www.example.com/"); /* Redirect browser */

/* Make sure that code below does not get executed when we redirect. */
exit;
?>

replace

可选参数 replace 表明是否用后面的头替换前面相同类型的头。 默认情况下会替换。如果传入 false，就可以强制使相同的头信息并存。例如：

<?php
header('WWW-Authenticate: Negotiate');
header('WWW-Authenticate: NTLM', false);
?>

http_response_code

强制指定HTTP响应的值。注意，这个参数只有在报文字符串（string）不为空的情况下才有效。

返回值

没有返回值。

范例

Example #1 下载对话框

如果你想提醒用户去保存你发送的数据，例如保存一个生成的PDF文件。你可以使用» Content-Disposition的报文信息来提供一个推荐的文件名，并且强制浏览器显示一个文件下载的对话框。

<?php
// We'll be outputting a PDF
header('Content-type: application/pdf');

// It will be called downloaded.pdf
header('Content-Disposition: attachment; filename="downloaded.pdf"');

// The PDF source is in original.pdf
readfile('original.pdf');
?>

Example #2 缓存指令

PHP脚本总是会生成一些动态内容，而这些内容是不应该被缓存的，不管是客户端浏览器还是在服务器端和客户端浏览器之间的任何代理。我们可以像这样来强制设置浏览器和各个代理层不缓存数据：

<?php
header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1
header("Expires: Sat, 26 Jul 1997 05:00:00 GMT"); // Date in the past
?>

Note:

也许你会遇到这样的情况，那就是即使你没使用上面这段代码，你的页面也没有被缓存。大多数情况是因为用户可以自己设置他们的浏览器从而改变浏览器默认的缓存行为。一旦发送了上面这段报文信息，那么你就应该重写那些可能用到缓存了的代码。

此外，在启用session的情况下，session_cache_limiter()和session.cache_limiter的配置可以用来自动地生成正确的缓存相关的头信息。

注释

Note:

数据头只会在SAPI支持时得到处理和输出。

Note:

你所有需要输出到浏览器的数据将会一直缓存在服务器端，直到你发送他们，这将造成比较大的资源开销。你可以是用输出缓冲来避开这个问题。你可以通过在脚本里使用ob_start()和ob_end_flush()或者直接在你的php.ini文件里设置output_buffering，也可以直接在服务器的配置文件里设置。

Note:

HTTP状态信息的报文永远都是最新被发送到客户端的，而不管header()是否是在最先发送的。报文状态码可能会被重写，当调用header()来设定新的状态码，除非HTTP报文已经被发送了。

Note:

在IE 4.01和IE 5.5里有bug，要解决就升级浏览器吧，想必也没人用那么远古的神器了吧。

Note:

HTTP/1.1需要一个绝对的网络资源地址（URI）来作为一个参数供» Location:使用，在其中必须包含了协议，主机地址还有完整的路径，但是一些客户端可以接受相对的网络资源地址。你可以在一个相对的网路资源地址的基础上使用$_SERVER['HTTP_HOST']，$_SERVER['PHP_SELF']和dirname()来组装一个绝对的网路资源地址。

<?php
/* Redirect to a different page in the current directory that was requested */
$host  = $_SERVER['HTTP_HOST'];
$uri   = rtrim(dirname($_SERVER['PHP_SELF']), '/\\');
$extra = 'mypage.php';
header("Location: http://$host$uri/$extra");
exit;
?>

Note:

在执行Location header跳转的时候，Session ID无法通传递的，即使session.use_trans_sid是激活状态的。只能通过手动传递using SID的值来实现。

参见

  • headers_sent() - 检测 HTTP 头是否已经发送
  • setcookie() - 发送 Cookie
  • http_response_code() - 获取/设置响应的 HTTP 状态码
  • The section on HTTP authentication


返回已发送的 HTTP 响应头（或准备发送的）

  • ? header
  • headers_sent ?
  • PHP Manual
  • 网络 函数
  • 返回已发送的 HTTP 响应头（或准备发送的）

headers_list

(PHP 5, PHP 7, PHP 8)

headers_list — 返回已发送的 HTTP 响应头（或准备发送的）

说明

headers_list ( ) : array

headers_list() 会返回准备发送给浏览器/客户端的 HTTP 头列表。 检测这些头是否已经发送，使用 headers_sent()。

返回值

返回数字索引的头数组。

范例

Example #1 使用 headers_list() 的例子

<?php

/* setcookie() 会自己添加一个响应头 */
setcookie('foo', 'bar');

/* 添加自定义的响应头
 大多数客户端会主动忽略 */
header("X-Sample-Test: foo");

/* 响应中指定内容为明文 text */
header('Content-type: text/plain');

/* 所以会发送什么头呢？ */
var_dump(headers_list());

?>

以上例程会输出：

array(4) {
  [0]=>
  string(23) "X-Powered-By: PHP/5.1.3"
  [1]=>
  string(19) "Set-Cookie: foo=bar"
  [2]=>
  string(18) "X-Sample-Test: foo"
  [3]=>
  string(24) "Content-type: text/plain"
}

注释

Note:

数据头只会在SAPI支持时得到处理和输出。

参见

  • headers_sent() - 检测 HTTP 头是否已经发送
  • header() - 发送原生 HTTP 头
  • setcookie() - 发送 Cookie
  • apache_response_headers() - 获得全部 HTTP 响应头信息
  • http_response_code() - 获取/设置响应的 HTTP 状态码


检测 HTTP 头是否已经发送

  • ? headers_list
  • http_response_code ?
  • PHP Manual
  • 网络 函数
  • 检测 HTTP 头是否已经发送

headers_sent

(PHP 4, PHP 5, PHP 7, PHP 8)

headers_sent — 检测 HTTP 头是否已经发送

说明

headers_sent ( string &$file = ? , int &$line = ? ) : bool

检测 HTTP 头是否已经发送。

HTTP 头已经发送时，就无法通过 header() 添加更多头字段。 使用此函数起码可以防止 HTTP 头出错。另一个解决方案是用 输出缓冲。

参数

file

若设置了可选参数 file and line， headers_sent() 会把 PHP 文件名放在 file 变量里， 输出开始的行号放在 line 变量里。

line

输出开始的行号。

返回值

HTTP 头未发送时，headers_sent() 返回 false，否则返回 true。

范例

Example #1 使用 headers_sent() 的例子

<?php

// 没有 HTTP 头就发送一个
if (!headers_sent()) {
    header('Location: http://www.example.com/');
    exit;
}

// 使用 file 和 line 参数选项的例子
// 注意 $filename 和 $linenum 用于下文中使用
// 所以不要提前为它们赋值
if (!headers_sent($filename, $linenum)) {
    header('Location: http://www.example.com/');
    exit;

// 很有可能在这里触发错误
} else {

    echo "Headers already sent in $filename on line $linenum\n" .
          "Cannot redirect, for now please click this <a " .
          "href=\"http://www.example.com\">link</a> instead\n";
    exit;
}

?>

注释

Note:

数据头只会在SAPI支持时得到处理和输出。

参见

  • ob_start() - 打开输出控制缓冲
  • trigger_error() - 产生一个用户级别的 error/warning/notice 信息
  • headers_list() - 返回已发送的 HTTP 响应头（或准备发送的）
  • header() - 发送原生 HTTP 头 中有更多相关细节的讨论。


获取/设置响应的 HTTP 状态码

  • ? headers_sent
  • inet_ntop ?
  • PHP Manual
  • 网络 函数
  • 获取/设置响应的 HTTP 状态码

http_response_code

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

http_response_code — 获取/设置响应的 HTTP 状态码

说明

http_response_code ( int $response_code = ? ) : mixed

获取或者设置响应的 HTTP 状态码。

参数

response_code

可选的 response_code 会设置响应的状态码。

返回值

如果提供了 response_code，将返回先前的状态码。 如果未提供 response_code，会返回当前的状态码。 在 Web 服务器环境里，这些状态码的默认值都是 200。

如果在非 Web 服务器环境里调用（比如 CLI 应用里）， 不提供 response_code 就会返回 false 。 在非 Web 服务器环境里，提供 response_code 会返回 true （仅仅在先前没有设置过状态码的时候）。

范例

Example #1 Web 服务器环境内使用 http_response_code()

<?php

// 获取当前状态码，并设置新的状态码
var_dump(http_response_code(404));

//获取新的状态码
var_dump(http_response_code());
?>

以上例程会输出：

int(200)
int(404)

Example #2 在 CLI 环境内使用 http_response_code()

<?php

// 获取当前默认的响应状态码
var_dump(http_response_code());

// 设置状态码
var_dump(http_response_code(201));

// 获取新的状态码
var_dump(http_response_code());
?>

以上例程会输出：

bool(false)
bool(true)
int(201)

参见

  • header() - 发送原生 HTTP 头
  • headers_list() - 返回已发送的 HTTP 响应头（或准备发送的）


Converts a packed internet address to a human readable representation

  • ? http_response_code
  • inet_pton ?
  • PHP Manual
  • 网络 函数
  • Converts a packed internet address to a human readable representation

inet_ntop

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

inet_ntop — Converts a packed internet address to a human readable representation

说明

inet_ntop ( string $ip ) : string|false

This function converts a 32bit IPv4, or 128bit IPv6 address (if PHP was built with IPv6 support enabled) into an address family appropriate string representation.

参数

ip

A 32bit IPv4, or 128bit IPv6 address.

返回值

Returns a string representation of the address 或者在失败时返回 false.

范例

Example #1 inet_ntop() Example

<?php
$packed = chr(127) . chr(0) . chr(0) . chr(1);
$expanded = inet_ntop($packed);

/* Outputs: 127.0.0.1 */
echo $expanded;

$packed = str_repeat(chr(0), 15) . chr(1);
$expanded = inet_ntop($packed);

/* Outputs: ::1 */
echo $expanded;
?>

参见

  • long2ip() - 将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）
  • ip2long() - 将 IPV4 的字符串互联网协议转换成长整型数字
  • inet_pton() - Converts a human readable IP address to its packed in_addr representation


Converts a human readable IP address to its packed in_addr representation

  • ? inet_ntop
  • ip2long ?
  • PHP Manual
  • 网络 函数
  • Converts a human readable IP address to its packed in_addr representation

inet_pton

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

inet_pton — Converts a human readable IP address to its packed in_addr representation

说明

inet_pton ( string $ip ) : string|false

This function converts a human readable IPv4 or IPv6 address (if PHP was built with IPv6 support enabled) into an address family appropriate 32bit or 128bit binary structure.

参数

ip

A human readable IPv4 or IPv6 address.

返回值

Returns the in_addr representation of the given ip, or false if a syntactically invalid ip is given (for example, an IPv4 address without dots or an IPv6 address without colons).

范例

Example #1 inet_pton() Example

<?php
$in_addr = inet_pton('127.0.0.1');

$in6_addr = inet_pton('::1');
?>

参见

  • ip2long() - 将 IPV4 的字符串互联网协议转换成长整型数字
  • long2ip() - 将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）
  • inet_ntop() - Converts a packed internet address to a human readable representation


将 IPV4 的字符串互联网协议转换成长整型数字

  • ? inet_pton
  • long2ip ?
  • PHP Manual
  • 网络 函数
  • 将 IPV4 的字符串互联网协议转换成长整型数字

ip2long

(PHP 4, PHP 5, PHP 7, PHP 8)

ip2long — 将 IPV4 的字符串互联网协议转换成长整型数字

说明

ip2long ( string $ip_address ) : int

函数 ip2long() 返回 IPV4 网络地址的长整型格式，从标准网络地址格式(点字符串)转化得到。

ip2long() 还可以与非完整IP进行工作。 阅读 » http://publibn.boulder.ibm.com/doc_link/en_US/a_doc_lib/libs/commtrf2/inet_addr.htm 获得更多信息。

参数

ip_address

一个标准格式的地址。

返回值

返回IP地址转换后的数字 或 false 如果 ip_address 是无效的。

更新日志

版本 | 说明
5.5.0 | Prior to this version, on Windows ip2long() would sometimes return a valid number even if passed a value which was not an (IPv4) Internet Protocol dotted address.
5.2.10 | 再此之前的版本, ip2long() 有时会返回即使这不是一个IPV4的标准地址的数字地址。

范例

Example #1 ip2long() 例子

<?php
$ip = gethostbyname('www.example.com');
$out = "The following URLs are equivalent:<br />\n";
$out .= 'http://www.example.com/, http://' . $ip . '/, and http://' . sprintf("%u", ip2long($ip)) . "/<br />\n";
echo $out;
?>

Example #2 显示IP地址

第二个例子说明打印一个转换后的地址使用 printf() 在PHP4和PHP5的功能:

<?php
$ip   = gethostbyname('www.example.com');
$long = ip2long($ip);

if ($long == -1 || $long === FALSE) {
    echo 'Invalid IP, please try again';
} else {
    echo $ip   . "\n";           // 192.0.34.166
    echo $long . "\n";           // -1073732954
    printf("%u\n", ip2long($ip)); // 3221234342
}
?>

注释

Note:

因为PHP的 integer 类型是有符号，并且有许多的IP地址讲导致在32位系统的情况下为负数， 你需要使用 "%u" 进行转换通过 sprintf() 或 printf() 得到的字符串来表示无符号的IP地址。

Note:

ip2long() 将返回 false 在IP是 255.255.255.255 的情况，版本为 PHP 5 <= 5.0.2. 在修复后 PHP 5.0.3 会返回 -1 (与PHP4相同).

参见

  • long2ip() - 将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）
  • sprintf() - Return a formatted string


将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）

  • ? ip2long
  • openlog ?
  • PHP Manual
  • 网络 函数
  • 将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）

long2ip

(PHP 4, PHP 5, PHP 7, PHP 8)

long2ip — 将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）

说明

long2ip ( int $proper_address ) : string

long2ip() 函数通过长整型的表达形式转化生成带点格式的互联网地址（例如：aaa.bbb.ccc.ddd ）。

参数

proper_address

合格的地址，长整型的表达形式。

返回值

返回字符串的互联网 IP 地址。

更新日志

版本 | 说明
7.1.0 | 参数 proper_address 的类型从 string 改成 integer。

注释

Note:

在 32 位架构中，从 string 转换 integer 整型形式的 ip 地址将有可能导致错误的结果，因为结果数字超出了 PHP_INT_MAX 限制。

参见

  • ip2long() - 将 IPV4 的字符串互联网协议转换成长整型数字


Open connection to system logger

  • ? long2ip
  • pfsockopen ?
  • PHP Manual
  • 网络 函数
  • Open connection to system logger

openlog

(PHP 4, PHP 5, PHP 7, PHP 8)

openlog — Open connection to system logger

说明

openlog ( string $prefix , int $flags , int $facility ) : bool

openlog() opens a connection to the system logger for a program.

The use of openlog() is optional. It will automatically be called by syslog() if necessary, in which case prefix will default to false.

参数

prefix

The string prefix is added to each message.

flags

The flags argument is used to indicate what logging options will be used when generating a log message.

openlog() Options
Constant | Description
LOG_CONS | if there is an error while sending data to the system logger, write directly to the system console
LOG_NDELAY | open the connection to the logger immediately
LOG_ODELAY | (default) delay opening the connection until the first message is logged
LOG_PERROR | print log message also to standard error
LOG_PID | include PID with each message
You can use one or more of these options. When using multiple options you need to OR them, i.e. to open the connection immediately, write to the console and include the PID in each message, you will use: LOG_CONS | LOG_NDELAY | LOG_PID

facility

The facility argument is used to specify what type of program is logging the message. This allows you to specify (in your machine's syslog configuration) how messages coming from different facilities will be handled.

openlog() Facilities
Constant | Description
LOG_AUTH | security/authorization messages (use LOG_AUTHPRIV instead in systems where that constant is defined)
LOG_AUTHPRIV | security/authorization messages (private)
LOG_CRON | clock daemon (cron and at)
LOG_DAEMON | other system daemons
LOG_KERN | kernel messages
LOG_LOCAL0 ... LOG_LOCAL7 | reserved for local use, these are not available in Windows
LOG_LPR | line printer subsystem
LOG_MAIL | mail subsystem
LOG_NEWS | USENET news subsystem
LOG_SYSLOG | messages generated internally by syslogd
LOG_USER | generic user-level messages
LOG_UUCP | UUCP subsystem

Note:

LOG_USER is the only valid log type under Windows operating systems

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • syslog() - Generate a system log message
  • closelog() - 关闭系统日志链接


打开一个持久的网络连接或者Unix套接字连接。

  • ? openlog
  • setcookie ?
  • PHP Manual
  • 网络 函数
  • 打开一个持久的网络连接或者Unix套接字连接。

pfsockopen

(PHP 4, PHP 5, PHP 7, PHP 8)

pfsockopen — 打开一个持久的网络连接或者Unix套接字连接。

说明

pfsockopen ( string $hostname , int $port = -1 , int &$errno = ? , string &$errstr = ? , float $timeout = ini_get("default_socket_timeout") ) : resource

这个函数的作用与fsockopen()完全一样的，不同的地方在于当在脚本执行完后，连接一直不会关闭。可以说它是fsockopen()的长连接版本。

参数

对于其参数的信息，请参考fsockopen()的文档。

参见

  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接


发送 Cookie

  • ? pfsockopen
  • setrawcookie ?
  • PHP Manual
  • 网络 函数
  • 发送 Cookie

setcookie

(PHP 4, PHP 5, PHP 7, PHP 8)

setcookie — 发送 Cookie

说明

setcookie ( string $name , string $value = "" , int $expires = 0 , string $path = "" , string $domain = "" , bool $secure = false , bool $httponly = false ) : bool

PHP 7.3.0 起有效的签名：

setcookie ( string $name , string $value = "" , array $options = [] ) : bool

setcookie() 定义了 Cookie，会和剩下的 HTTP 头一起发送给客户端。 和其他 HTTP 头一样，必须在脚本产生任意输出之前发送 Cookie（由于协议的限制）。 请在产生任何输出之前（包括 <html> 和 <head> 或者空格）调用本函数。

一旦设置 Cookie 后，下次打开页面时可以使用 $_COOKIE 读取。 Cookie 值同样也存在于 $_REQUEST。

参数

» RFC 6265 提供了 setcookie() 每个参数的参考标准。

name

Cookie 名称。

value

Cookie 值。 这个值储存于用户的电脑里，请勿储存敏感信息。 比如 name 是 'cookiename'， 可通过 $_COOKIE['cookiename'] 获取它的值。

expires

Cookie 的过期时间。 这是个 Unix 时间戳，即 Unix 纪元以来（格林威治时间 1970 年 1 月 1 日 00:00:00）的秒数。 也就是说，基本可以用 time() 函数的结果加上希望过期的秒数。 或者也可以用 mktime()。 time()+60*60*24*30 就是设置 Cookie 30 天后过期。 如果设置成零，或者忽略参数， Cookie 会在会话结束时过期（也就是关掉浏览器时）。

Note:

你可能注意到了，expires 使用 Unix 时间戳而非 Wdy, DD-Mon-YYYY HH:MM:SS GMT 这样的日期格式，是因为 PHP 内部作了转换。

path

Cookie 有效的服务器路径。 设置成 '/' 时，Cookie 对整个域名 domain 有效。 如果设置成 '/foo/'， Cookie 仅仅对 domain 中 /foo/ 目录及其子目录有效（比如 /foo/bar/）。 默认值是设置 Cookie 时的当前目录。

domain

Cookie 的有效域名/子域名。 设置成子域名（例如 'www.example.com'），会使 Cookie 对这个子域名和它的三级域名有效（例如 w2.www.example.com）。 要让 Cookie 对整个域名有效（包括它的全部子域名），只要设置成域名就可以了（这个例子里是 'example.com'）。

旧版浏览器仍然在使用废弃的 » RFC 2109， 需要一个前置的点 . 来匹配所有子域名。

secure

设置这个 Cookie 是否仅仅通过安全的 HTTPS 连接传给客户端。 设置成 true 时，只有安全连接存在时才会设置 Cookie。 如果是在服务器端处理这个需求，程序员需要仅仅在安全连接上发送此类 Cookie （通过 $_SERVER["HTTPS"] 判断）。

httponly

设置成 true，Cookie 仅可通过 HTTP 协议访问。 这意思就是 Cookie 无法通过类似 JavaScript 这样的脚本语言访问。 要有效减少 XSS 攻击时的身份窃取行为，可建议用此设置（虽然不是所有浏览器都支持），不过这个说法经常有争议。 true 或 false

options

An associative array which may have any of the keys expires, path, domain, secure, httponly and samesite. If any other key is present an error of level E_WARNING is generated. The values have the same meaning as described for the parameters with the same name. The value of the samesite element should be either None, Lax or Strict. If any of the allowed options are not given, their default values are the same as the default values of the explicit parameters. If the samesite element is omitted, no SameSite cookie attribute is set.

返回值

如果在调用本函数以前就产生了输出，setcookie() 会调用失败并返回 false。 如果 setcookie() 成功运行，返回 true。当然，它的意思并非用户是否已接受 Cookie。

范例

发送 Cookie 的几个例子：

Example #1 setcookie() 发送例子

<?php
$value = 'something from somewhere';

setcookie("TestCookie", $value);
setcookie("TestCookie", $value, time()+3600);  /* 1 小时过期  */
setcookie("TestCookie", $value, time()+3600, "/~rasmus/", "example.com", 1);
?>

注意：在发送 Cookie 时，值的部分会被自动 urlencode 编码。收到 Cookie 时，会自动解码，并赋值到可变的 Cookie 名称上。 如果不想被编码，可以使用 setrawcookie() 代替。 在脚本里查看我们的测试 Cookie 的内容，使用下面的一个例子：

<?php
// 打印一个单独的 Cookie
echo $_COOKIE["TestCookie"];

//  debug/test 查看所有 Cookie 的另一种方式
print_r($_COOKIE);
?>

Example #2 setcookie() 删除例子

要删除一个 Cookie，应该设置过期时间为过去，以触发浏览器的删除机制。 下面的例子展示了如何删除上个例子里的 Cookie：

<?php
// 设置过期时间为一个小时前
setcookie("TestCookie", "", time() - 3600);
setcookie("TestCookie", "", time() - 3600, "/~rasmus/", "example.com", 1);
?>

Example #3 setcookie() 和数组

通过带 array 标记的 Cookie 名称，也可以把 Cookie 设置成数组。 如果有数组元素，可以把它放进 Cookie 里； 脚本接收到时，Cookie 名称里的值会是一个数组：

<?php
// 设置 Cookie
setcookie("cookie[three]", "cookiethree");
setcookie("cookie[two]", "cookietwo");
setcookie("cookie[one]", "cookieone");

// 网页刷新后，打印出以下内容
if (isset($_COOKIE['cookie'])) {
    foreach ($_COOKIE['cookie'] as $name => $value) {
        $name = htmlspecialchars($name);
        $value = htmlspecialchars($value);
        echo "$name : $value <br />\n";
    }
}
?>

以上例程会输出：

three : cookiethree
two : cookietwo
one : cookieone

Note: Using separator characters such as [ and ] as part of the cookie name is not compliant to RFC 6265, section 4, but supposed to be supported by user agents according to RFC 6265, section 5.

更新日志

版本 | 说明
7.3.0 | An alternative signature supporting an options array has been added. This signature supports also setting of the SameSite cookie attribute.

注释

Note:

要在调用本函数前输出内容，可以使用输出缓冲：让输出的内容在服务器里缓冲起来， 直至真正发送给浏览器。 可在脚本里调用 ob_start() 和 ob_end_flush()， 或设置 output_buffering php.ini 或服务器配置文件里的配置指令。

注意避坑：

  • 在页面（ Cookie 可见的页面）下次刷新前，Cookie 不会生效。 测试 Cookie 是否已经成功设置，需要在下次页面加载时、Cookie 过期前检测。 过期时间是通过 expires 参数设置的。 直接调用 print_r($_COOKIE); 调试检测 Cookie 是个很好的方式。
  • 为同一个参数再次设置 Cookie 前，必须先把它删掉。 如果参数的值是空 string 或 false，并且其他参数和上次调用 setcookie 仍旧一样， 则指定的名称会被远程客户端删除。 内部的实现是：将值设置成 'deleted'，并且过期时间是一年前。
  • 因为设置值成 false 会导致 Cookie 被删除，所以要避免使用布尔值。 代替方式：0 是 false，1 是 true。
  • Cookie 名称可以设置成数组名称，PHP 脚本里会是数组， 但用户系统里储存的是单独分开的 Cookie。 可以考虑使用 explode() 为一个 Cookie 设置多个名称和值。 不建议将 serialize() 用于此处，因为它会导致安全漏洞。

多次调用 setcookie() 会按调用顺序执行。

参见

  • header() - 发送原生 HTTP 头
  • setrawcookie() - 发送未经 URL 编码的 cookie
  • Cookie 章节
  • » RFC 6265
  • » RFC 2109


发送未经 URL 编码的 cookie

  • ? setcookie
  • socket_get_status ?
  • PHP Manual
  • 网络 函数
  • 发送未经 URL 编码的 cookie

setrawcookie

(PHP 5, PHP 7, PHP 8)

setrawcookie — 发送未经 URL 编码的 cookie

说明

setrawcookie ( string $name , string $value = ? , int $expire = 0 , string $path = ? , string $domain = ? , bool $secure = false , bool $httponly = false ) : bool

setrawcookie() 和 setcookie() 非常相似，唯一不同之处是发送到浏览器的 cookie 值没有自动经过 URL 编码（urlencode）。

参数

相关参数的信息参见 setcookie() 的文档。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.5.0 | 发送给客户端的 Set-Cookie 头现在会加上 Max-Age 属性。
5.2.0 | 增加了 httponly 参数。

参见

  • setcookie() - 发送 Cookie


别名 stream_get_meta_data

  • ? setrawcookie
  • socket_set_blocking ?
  • PHP Manual
  • 网络 函数
  • 别名 stream_get_meta_data

socket_get_status

(PHP 4, PHP 5, PHP 7, PHP 8)

socket_get_status — 别名 stream_get_meta_data()

说明

此函数是该函数的别名： stream_get_meta_data()。


别名 stream_set_blocking

  • ? socket_get_status
  • socket_set_timeout ?
  • PHP Manual
  • 网络 函数
  • 别名 stream_set_blocking

socket_set_blocking

(PHP 4, PHP 5, PHP 7, PHP 8)

socket_set_blocking — 别名 stream_set_blocking()

说明

此函数是该函数的别名： stream_set_blocking()。


别名 stream_set_timeout

  • ? socket_set_blocking
  • syslog ?
  • PHP Manual
  • 网络 函数
  • 别名 stream_set_timeout

socket_set_timeout

(PHP 4, PHP 5, PHP 7, PHP 8)

socket_set_timeout — 别名 stream_set_timeout()

说明

此函数是该函数的别名： stream_set_timeout()。


Generate a system log message

  • ? socket_set_timeout
  • RRD ?
  • PHP Manual
  • 网络 函数
  • Generate a system log message

syslog

(PHP 4, PHP 5, PHP 7, PHP 8)

syslog — Generate a system log message

说明

syslog ( int $priority , string $message ) : bool

syslog() generates a log message that will be distributed by the system logger.

For information on setting up a user defined log handler, see the syslog.conf (5) Unix manual page. More information on the syslog facilities and option can be found in the man pages for syslog (3) on Unix machines.

参数

priority

priority is a combination of the facility and the level. Possible values are:

syslog() Priorities (in descending order)
Constant | Description
LOG_EMERG | system is unusable
LOG_ALERT | action must be taken immediately
LOG_CRIT | critical conditions
LOG_ERR | error conditions
LOG_WARNING | warning conditions
LOG_NOTICE | normal, but significant, condition
LOG_INFO | informational message
LOG_DEBUG | debug-level message

message

The message to send, except that the two characters %m will be replaced by the error message string (strerror) corresponding to the present value of errno.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Using syslog()

<?php
// open syslog, include the process ID and also send
// the log to standard error, and use a user defined
// logging mechanism
openlog("myScriptLog", LOG_PID | LOG_PERROR, LOG_LOCAL0);

// some code

if (authorized_client()) {
    // do something
} else {
    // unauthorized client!
    // log the attempt
    $access = date("Y/m/d H:i:s");
    syslog(LOG_WARNING, "Unauthorized client: $access {$_SERVER['REMOTE_ADDR']} ({$_SERVER['HTTP_USER_AGENT']})");
}

closelog();
?>

注释

On Windows NT, the syslog service is emulated using the Event Log.

Note:

Use of LOG_LOCAL0 through LOG_LOCAL7 for the facility parameter of openlog() is not available in Windows.

参见

  • openlog() - Open connection to system logger
  • closelog() - 关闭系统日志链接


RRDtool

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Procedural PECL/rrd example
    • OOP PECL/rrd example
  • RRD 函数
    • rrd_create — Creates rrd database file
    • rrd_error — Gets latest error message
    • rrd_fetch — Fetch the data for graph as array
    • rrd_first — Gets the timestamp of the first sample from rrd file
    • rrd_graph — Creates image from a data
    • rrd_info — Gets information about rrd file
    • rrd_last — Gets unix timestamp of the last sample
    • rrd_lastupdate — Gets information about last updated data
    • rrd_restore — Restores the RRD file from XML dump
    • rrd_tune — Tunes some RRD database file header options
    • rrd_update — Updates the RRD database
    • rrd_version — Gets information about underlying rrdtool library
    • rrd_xport — Exports the information about RRD database
    • rrdc_disconnect — Close any outstanding connection to rrd caching daemon
  • RRDCreator — The RRDCreator class
    • RRDCreator::addArchive — Adds RRA - archive of data values for each data source
    • RRDCreator::addDataSource — Adds data source definition for RRD database
    • RRDCreator::__construct — Creates new RRDCreator instance
    • RRDCreator::save — Saves the RRD database to a file
  • RRDGraph — The RRDGraph class
    • RRDGraph::__construct — Creates new RRDGraph instance
    • RRDGraph::save — Saves the result of query into image
    • RRDGraph::saveVerbose — Saves the RRD database query into image and returns the verbose information about generated graph
    • RRDGraph::setOptions — Sets the options for rrd graph export
  • RRDUpdater — The RRDUpdater class
    • RRDUpdater::__construct — Creates new RRDUpdater instance
    • RRDUpdater::update — Update the RRD database file


简介

The PECL/rrd extension provides bindings to the RRDtool C library. RRDtool is the open source industry standard, high performance data logging and graphing system for time series data.

The RRDtool homepage is » http://www.mrtg.org/rrdtool/.


需求

You need to install librrd first to be able to use PECL/rrd. Most common option is using of librrd-dev package from your favourite linux distro. PECL/rrd is tested with librrd 1.4.3, older or newer versions might or might not work for you. PECL/rrd installation is tested with PHP 5.3.2 or newer.

Warning

Librrd and hence extension itself aren't mostly thread safe. There are many global and shared states in librrd. It can be dangerous use this extension in multi threaded environments like Apache2 mpm worker. If there are many parallel requests, one request can change some global librrd state of other runnig requests.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/rrd.


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • RRD
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

Table of Contents

  • Procedural PECL/rrd example
  • OOP PECL/rrd example


Procedural PECL/rrd example

Example #1 Procedural usage of rrd

<?php
$rrdFile = dirname(__FILE__) . "/speed.rrd";

//create rrd file
rrd_create($rrdFile,
 array(
  "--start",920804400,
  "DS:speed:COUNTER:600:U:U",
  "RRA:AVERAGE:0.5:1:24",
  "RRA:AVERAGE:0.5:6:10"
  )
);

//update rrd file
rrd_update($rrdFile,
 array(
  "920804700:12345",
  "920805000:12357"
  )
);

//graph output
rrd_graph(dirname(__FILE__) . "/speed.png",
 array(
  "--start", "920804400",
  "--end", "920808000",
  "--vertical-label", "m/s",
  "DEF:myspeed=$rrdFile:speed:AVERAGE",
  "CDEF:realspeed=myspeed,1000,*",
  "LINE2:realspeed#FF0000"
 )
);
?>


OOP PECL/rrd example

Example #1 OO usage of rrd

<?php
$rrdFile = dirname(__FILE__) . "/speed.rrd";
$outputPngFile = dirname(__FILE__) . "/speed.png";

$creator = new RRDCreator($rrdFile, "now -10d", 500);
$creator->addDataSource("speed:COUNTER:600:U:U");
$creator->addArchive("AVERAGE:0.5:1:24");
$creator->addArchive("AVERAGE:0.5:6:10");
$creator->save();

$updater = new RRDUpdater($rrdFile);
$updater->update(array("speed" => "12345"), "920804700");
$updater->update(array("speed" => "12357"), "920805000");

$graphObj = new RRDGraph($outputPngFile);
$graphObj->setOptions(
    array(
        "--start" => "920804400",
        "--end" => 920808000,
        "--vertical-label" => "m/s",
        "DEF:myspeed=$rrdFile:speed:AVERAGE",
        "CDEF:realspeed=myspeed,1000,*",
        "LINE2:realspeed#FF0000"
    )
);
$graphObj->save();
?>


RRD 函数

Table of Contents

  • rrd_create — Creates rrd database file
  • rrd_error — Gets latest error message
  • rrd_fetch — Fetch the data for graph as array
  • rrd_first — Gets the timestamp of the first sample from rrd file
  • rrd_graph — Creates image from a data
  • rrd_info — Gets information about rrd file
  • rrd_last — Gets unix timestamp of the last sample
  • rrd_lastupdate — Gets information about last updated data
  • rrd_restore — Restores the RRD file from XML dump
  • rrd_tune — Tunes some RRD database file header options
  • rrd_update — Updates the RRD database
  • rrd_version — Gets information about underlying rrdtool library
  • rrd_xport — Exports the information about RRD database
  • rrdc_disconnect — Close any outstanding connection to rrd caching daemon


Creates rrd database file

  • ? RRD 函数
  • rrd_error ?
  • PHP Manual
  • RRD 函数
  • Creates rrd database file

rrd_create

(PECL rrd >= 0.9.0)

rrd_create — Creates rrd database file

说明

rrd_create ( string $filename , array $options ) : bool

Creates the rdd database file.

参数

filename

Filename for newly created rrd file.

options

Options for rrd create - list of strings. See man page of rrd create for whole list of options.

返回值

成功时返回 true， 或者在失败时返回 false。


Gets latest error message

  • ? rrd_create
  • rrd_fetch ?
  • PHP Manual
  • RRD 函数
  • Gets latest error message

rrd_error

(PECL rrd >= 0.9.0)

rrd_error — Gets latest error message

说明

rrd_error ( ) : string

Returns latest global rrd error message.

参数

此函数没有参数。

返回值

Latest error message.


Fetch the data for graph as array

  • ? rrd_error
  • rrd_first ?
  • PHP Manual
  • RRD 函数
  • Fetch the data for graph as array

rrd_fetch

(PECL rrd >= 0.9.0)

rrd_fetch — Fetch the data for graph as array

说明

rrd_fetch ( string $filename , array $options ) : array

Gets data for graph output from RRD database file as array. This function has same result as rrd_graph(), but fetched data are returned as array, no image file is created.

参数

filename

RRD database file name.

options

Array of options for resolution specification.

返回值

Returns information about retrieved graph data.


Gets the timestamp of the first sample from rrd file

  • ? rrd_fetch
  • rrd_graph ?
  • PHP Manual
  • RRD 函数
  • Gets the timestamp of the first sample from rrd file

rrd_first

(PECL rrd >= 0.9.0)

rrd_first — Gets the timestamp of the first sample from rrd file

说明

rrd_first ( string $file , int $raaindex = 0 ) : int

Returns the first data sample from the specified RRA of the RRD file.

参数

file

RRD database file name.

raaindex

The index number of the RRA that is to be examined. Default value is 0.

返回值

Integer number of unix timestamp, false if some error occurs.


Creates image from a data

  • ? rrd_first
  • rrd_info ?
  • PHP Manual
  • RRD 函数
  • Creates image from a data

rrd_graph

(PECL rrd >= 0.9.0)

rrd_graph — Creates image from a data

说明

rrd_graph ( string $filename , array $options ) : array

Creates image for a particular data from RRD file.

参数

filename

The filename to output the graph to. This will generally end in either .png, .svg or .eps, depending on the format you want to output.

options

Options for generating image. See man page of rrd graph for all possible options. All options (data definitions, variable defintions, etc.) are allowed.

返回值

Array with information about generated image is returned, false when error occurs.


Gets information about rrd file

  • ? rrd_graph
  • rrd_last ?
  • PHP Manual
  • RRD 函数
  • Gets information about rrd file

rrd_info

(PECL rrd >= 0.9.0)

rrd_info — Gets information about rrd file

说明

rrd_info ( string $filename ) : array

Returns information about particular RRD database file.

参数

file

RRD database file name.

返回值

Array with information about requsted RRD file, false when error occurs.


Gets unix timestamp of the last sample

  • ? rrd_info
  • rrd_lastupdate ?
  • PHP Manual
  • RRD 函数
  • Gets unix timestamp of the last sample

rrd_last

(PECL rrd >= 0.9.0)

rrd_last — Gets unix timestamp of the last sample

说明

rrd_last ( string $filename ) : int

Returns the UNIX timestamp of the most recent update of the RRD database.

参数

filename

RRD database file name.

返回值

Integer as unix timestamp of the most recent data from the RRD database.


Gets information about last updated data

  • ? rrd_last
  • rrd_restore ?
  • PHP Manual
  • RRD 函数
  • Gets information about last updated data

rrd_lastupdate

(PECL rrd >= 0.9.0)

rrd_lastupdate — Gets information about last updated data

说明

rrd_lastupdate ( string $filename ) : array

Gets array of the UNIX timestamp and the values stored for each date in the most recent update of the RRD database file.

参数

file

RRD database file name.

返回值

Array of information about last update, false when error occurs.


Restores the RRD file from XML dump

  • ? rrd_lastupdate
  • rrd_tune ?
  • PHP Manual
  • RRD 函数
  • Restores the RRD file from XML dump

rrd_restore

(PECL rrd >= 0.9.0)

rrd_restore — Restores the RRD file from XML dump

说明

rrd_restore ( string $xml_file , string $rrd_file , array $options = ? ) : bool

Restores the RRD file from the XML dump.

参数

xml_file

XML filename with the dump of the original RRD database file.

rrd_file

Restored RRD database file name.

options

Array of options for restoring. See man page for rrd restore.

返回值

Returns true on success, false otherwise.


Tunes some RRD database file header options

  • ? rrd_restore
  • rrd_update ?
  • PHP Manual
  • RRD 函数
  • Tunes some RRD database file header options

rrd_tune

(PECL rrd >= 0.9.0)

rrd_tune — Tunes some RRD database file header options

说明

rrd_tune ( string $filename , array $options ) : bool

Change some options in the RRD dabase header file. E.g. renames the source for the data etc.

参数

filename

RRD database file name.

options

Options with RRD database file properties which will be changed. See rrd tune man page for details.

返回值

Returns true on success, false otherwise.


Updates the RRD database

  • ? rrd_tune
  • rrd_version ?
  • PHP Manual
  • RRD 函数
  • Updates the RRD database

rrd_update

(PECL rrd >= 0.9.0)

rrd_update — Updates the RRD database

说明

rrd_update ( string $filename , array $options ) : bool

Updates the RRD database file. The input data is time interpolated according to the properties of the RRD database file.

参数

filename

RRD database file name. This database will be updated.

options

Options for updating the RRD database. This is list of strings. See man page of rrd update for whole list of options.

返回值

Returns true on success, false when error occurs.


Gets information about underlying rrdtool library

  • ? rrd_update
  • rrd_xport ?
  • PHP Manual
  • RRD 函数
  • Gets information about underlying rrdtool library

rrd_version

(PECL rrd >= 1.0.0)

rrd_version — Gets information about underlying rrdtool library

说明

rrd_version ( ) : string

Returns information about underlying rrdtool library.

参数

此函数没有参数。

返回值

String with rrdtool version number e.g. "1.4.3".


Exports the information about RRD database

  • ? rrd_version
  • rrdc_disconnect ?
  • PHP Manual
  • RRD 函数
  • Exports the information about RRD database

rrd_xport

(PECL rrd >= 0.9.0)

rrd_xport — Exports the information about RRD database

说明

rrd_xport ( array $options ) : array

Exports the information about RRD database file. This data can be converted to XML file via user space PHP script and then restored back as RRD database file.

参数

options

Array of options for the export, see rrd xport man page.

返回值

Array with information about RRD database file, false when error occurs.


Close any outstanding connection to rrd caching daemon

  • ? rrd_xport
  • RRDCreator ?
  • PHP Manual
  • RRD 函数
  • Close any outstanding connection to rrd caching daemon

rrdc_disconnect

(PECL rrd >= 1.1.2)

rrdc_disconnect — Close any outstanding connection to rrd caching daemon

说明

rrdc_disconnect ( ) : void

Close any outstanding connection to rrd caching daemon.

This function is automatically called when the whole PHP process is terminated. It depends on used SAPI. For example, it's called automatically at the end of command line script.

It's up user whether he wants to call this function at the end of every request or otherwise.

参数

此函数没有参数。

返回值

没有返回值。


The RRDCreator class

(PECL rrd >= 0.9.0)

简介

Class for creation of RRD database file.

类摘要

RRDCreator {
/* 方法 */
public addArchive ( string $description ) : void
public addDataSource ( string $description ) : void
public __construct ( string $path , string $startTime = ? , int $step = 0 )
public save ( ) : bool
}

Table of Contents

  • RRDCreator::addArchive — Adds RRA - archive of data values for each data source
  • RRDCreator::addDataSource — Adds data source definition for RRD database
  • RRDCreator::__construct — Creates new RRDCreator instance
  • RRDCreator::save — Saves the RRD database to a file


Adds RRA - archive of data values for each data source

  • ? RRDCreator
  • RRDCreator::addDataSource ?
  • PHP Manual
  • RRDCreator
  • Adds RRA - archive of data values for each data source

RRDCreator::addArchive

(PECL rrd >= 0.9.0)

RRDCreator::addArchive — Adds RRA - archive of data values for each data source

说明

public RRDCreator::addArchive ( string $description ) : void

Adds RRA definition by description of archive. Archive consists of a number of data values or statistics for each of the defined data-sources (DS). Data sources are defined by method RRDCreator::addDataSource(). You need call this method for each requested archive.

参数

description

Definition of archive - RRA. This has same format as RRA definition in rrd create command. See man page of rrd create for more details.

返回值

没有返回值。


Adds data source definition for RRD database

  • ? RRDCreator::addArchive
  • RRDCreator::__construct ?
  • PHP Manual
  • RRDCreator
  • Adds data source definition for RRD database

RRDCreator::addDataSource

(PECL rrd >= 0.9.0)

RRDCreator::addDataSource — Adds data source definition for RRD database

说明

public RRDCreator::addDataSource ( string $description ) : void

RRD can accept input from several data sources (DS), e.g incoming and outgoing traffic. This method adds data source by description. You need call this method for each data source.

参数

description

Definition of data source - DS. This has same format as DS definition in rrd create command. See man page of rrd create for more details.

返回值

没有返回值。


Creates new RRDCreator instance

  • ? RRDCreator::addDataSource
  • RRDCreator::save ?
  • PHP Manual
  • RRDCreator
  • Creates new RRDCreator instance

RRDCreator::__construct

(PECL rrd >= 0.9.0)

RRDCreator::__construct — Creates new RRDCreator instance

说明

public RRDCreator::__construct ( string $path , string $startTime = ? , int $step = 0 )

Creates new RRDCreator instance.

参数

path

Path for newly created RRD database file.

startTime

Time for the first value in RRD database. Parameter supports all formats which are supported by rrd create call.

intstep

Base interval in seconds with which data will be fed into the RRD database.

返回值

没有返回值。


Saves the RRD database to a file

  • ? RRDCreator::__construct
  • RRDGraph ?
  • PHP Manual
  • RRDCreator
  • Saves the RRD database to a file

RRDCreator::save

(PECL rrd >= 0.9.0)

RRDCreator::save — Saves the RRD database to a file

说明

public RRDCreator::save ( ) : bool

Saves the RRD database into file, which name is defined by RRDCreator::__construct().

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


The RRDGraph class

(PECL rrd >= 0.9.0)

简介

Class for exporting data from RRD database to image file.

类摘要

RRDGraph {
/* 方法 */
public __construct ( string $path )
public save ( ) : array
public saveVerbose ( ) : array
public setOptions ( array $options ) : void
}

Table of Contents

  • RRDGraph::__construct — Creates new RRDGraph instance
  • RRDGraph::save — Saves the result of query into image
  • RRDGraph::saveVerbose — Saves the RRD database query into image and returns the verbose information about generated graph
  • RRDGraph::setOptions — Sets the options for rrd graph export


Creates new RRDGraph instance

  • ? RRDGraph
  • RRDGraph::save ?
  • PHP Manual
  • RRDGraph
  • Creates new RRDGraph instance

RRDGraph::__construct

(PECL rrd >= 0.9.0)

RRDGraph::__construct — Creates new RRDGraph instance

说明

public RRDGraph::__construct ( string $path )

Creates new RRDGraph instance. This instance is responsible for rendering the result of RRD database query into image.

参数

path

Full path for the newly created image.

返回值

没有返回值。


Saves the result of query into image

  • ? RRDGraph::__construct
  • RRDGraph::saveVerbose ?
  • PHP Manual
  • RRDGraph
  • Saves the result of query into image

RRDGraph::save

(PECL rrd >= 0.9.0)

RRDGraph::save — Saves the result of query into image

说明

public RRDGraph::save ( ) : array

Saves the result of RRD database query into image defined by RRDGraph::__construct().

参数

此函数没有参数。

返回值

Array with information about generated image is returned, false if error occurs.


Saves the RRD database query into image and returns the verbose information about generated graph

  • ? RRDGraph::save
  • RRDGraph::setOptions ?
  • PHP Manual
  • RRDGraph
  • Saves the RRD database query into image and returns the verbose information about generated graph

RRDGraph::saveVerbose

(PECL rrd >= 0.9.0)

RRDGraph::saveVerbose — Saves the RRD database query into image and returns the verbose information about generated graph

说明

public RRDGraph::saveVerbose ( ) : array

Saves the RRD database query into image file defined by method RRDGraph::__construct() and returns the verbose information about generated graph, if "-" is used as image filename, image data are also returned in result array.

参数

此函数没有参数。

返回值

Array with detailed information about generated image is returned, optionally with image data, false if error occurs.


Sets the options for rrd graph export

  • ? RRDGraph::saveVerbose
  • RRDUpdater ?
  • PHP Manual
  • RRDGraph
  • Sets the options for rrd graph export

RRDGraph::setOptions

(PECL rrd >= 0.9.0)

RRDGraph::setOptions — Sets the options for rrd graph export

说明

public RRDGraph::setOptions ( array $options ) : void

参数

options

List of options for the image generation from the RRD database file. It can be list of strings or list of strings with keys for better readability. Read the rrd graph man pages for list of available options.

返回值

没有返回值。

范例

Example #1 RRDGraph::setOptions() example

<?php
$graphObj->setOptions(array(
    "--start" => "920804400",
    "--end" => 920808000,
    "--vertical-label" => "m/s",
    "DEF:myspeed=$rrdFile:speed:AVERAGE",
    "CDEF:realspeed=myspeed,1000,*",
    "LINE2:realspeed#FF0000"
));
?>

Example #2 Set multiple color options

<?php
$graphObj->setOptions(array(
    "--start" => "920804400",
    "--end" => 920808000,
    "--vertical-label" => "m/s",
    "--color=BACK#00000000",
    "--color=GRID#00000000",
    "--color=MGRID#00000000",
    "DEF:myspeed=$rrdFile:speed:AVERAGE",
    "CDEF:realspeed=myspeed,1000,*",
    "LINE2:realspeed#FF0000"
));
?>

Don't use key value syntax for same rrd option. It looks more readable, but it doesn't work.

<?php
$graphObj->setOptions(array(
    "--color" => "BACK#00000000",
    "--color" => "GRID#00000000",
    "--color" => "MGRID#00000000"
));
?>

In nature of php it's same as

<?php
$graphObj->setOptions(array(
    "--color" => "MGRID#00000000"
));
?>


The RRDUpdater class

(PECL rrd >= 0.9.0)

简介

Class for updating RDD database file.

类摘要

RRDUpdater {
/* 方法 */
public __construct ( string $path )
public update ( array $values , string $time = time() ) : bool
}

Table of Contents

  • RRDUpdater::__construct — Creates new RRDUpdater instance
  • RRDUpdater::update — Update the RRD database file


Creates new RRDUpdater instance

  • ? RRDUpdater
  • RRDUpdater::update ?
  • PHP Manual
  • RRDUpdater
  • Creates new RRDUpdater instance

RRDUpdater::__construct

(PECL rrd >= 0.9.0)

RRDUpdater::__construct — Creates new RRDUpdater instance

说明

public RRDUpdater::__construct ( string $path )

Creates new RRDUpdater instance. This instance is responsible for updating the RRD database file.

参数

path

Filesystem path for RRD database file, which will be updated.

返回值

没有返回值。


Update the RRD database file

  • ? RRDUpdater::__construct
  • ScoutAPM ?
  • PHP Manual
  • RRDUpdater
  • Update the RRD database file

RRDUpdater::update

(PECL rrd >= 0.9.0)

RRDUpdater::update — Update the RRD database file

说明

public RRDUpdater::update ( array $values , string $time = time() ) : bool

Updates the RRD file defined via RRDUpdater::__construct(). The file is updated with a specific values.

参数

values

Data for update. Key is data source name.

time

Time value for updating the RRD with a particulat data. Default value is current time.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Throws a Exception on error.

范例

Example #1 RRDUpdater::update() examples

<?php
$updator = new RRDUpdater("speed.rrd");
//updates the data source "speed" with value "12411"
//for time defined by timestamp "920807700"
$updator->update(array("speed" => "12411"), "920807700");
?>


ScoutAPM

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • Scoutapm 函数
    • scoutapm_get_calls — Returns a list of instrumented calls that have occurred
    • scoutapm_list_instrumented_functions — List functions scoutapm will instrument.


简介

Note: 此扩展在 Windows 平台上不可用。

ScoutAPM's extension for PHP provides additional capabilities to application monitoring over just using the base PHP userland library.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • ScoutAPM
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

  • PHP >= 7.1.0
  • Windows is not currently supported


安装

This extension is available on PECL. Run:

$ sudo pecl install scoutapm
You may need to add Scout to your php.ini, for example:
extension=scoutapm.so


  • ? 运行时配置
  • Scoutapm 函数 ?
  • PHP Manual
  • ScoutAPM
  • 预定义常量

预定义常量

此扩展没有定义常量。


Scoutapm 函数

Table of Contents

  • scoutapm_get_calls — Returns a list of instrumented calls that have occurred
  • scoutapm_list_instrumented_functions — List functions scoutapm will instrument.


Returns a list of instrumented calls that have occurred

  • ? Scoutapm 函数
  • scoutapm_list_instrumented_functions ?
  • PHP Manual
  • Scoutapm 函数
  • Returns a list of instrumented calls that have occurred

scoutapm_get_calls

(PECL scoutapm >= 1.0.0)

scoutapm_get_calls — Returns a list of instrumented calls that have occurred

说明

scoutapm_get_calls ( ) : array

Returns a list of any instrumented function calls since scoutapm_get_calls() was last called. The list is cleared each time the function is called.

参数

此函数没有参数。

返回值

scoutapm_get_calls() returns an array containing a list of all recorded calls to instrumented function calls.

范例

Example #1 Fetch instrumented calls

<?php

file_get_contents('a.txt');
file_get_contents('b.txt');

print_r(scoutapm_get_calls());
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [function] => file_get_contents
            [entered] => 1576839727.7934
            [exited] => 1576839727.7935
            [time_taken] => 2.7894973754883E-5
            [argv] => Array
                (
                    [0] => a.txt
                )

        )

    [1] => Array
        (
            [function] => file_get_contents
            [entered] => 1576839727.7935
            [exited] => 1576839727.7935
            [time_taken] => 7.8678131103516E-6
            [argv] => Array
                (
                    [0] => b.txt
                )

        )

)


List functions scoutapm will instrument.

  • ? scoutapm_get_calls
  • SNMP ?
  • PHP Manual
  • Scoutapm 函数
  • List functions scoutapm will instrument.

scoutapm_list_instrumented_functions

(PECL scoutapm >= 1.0.2)

scoutapm_list_instrumented_functions — List functions scoutapm will instrument.

说明

scoutapm_list_instrumented_functions ( ) : array

Returns a list of the functions the extension will instrument.

参数

此函数没有参数。

返回值

scoutapm_list_instrumented_functions() returns an array containing a list of all functions that the scoutapm extension is able to instrument in the current installation.

范例

Example #1 Fetch the list of functions scoutapm will instrument

<?php
print_r(scoutapm_list_instrumented_functions());
?>

以上例程的输出类似于：

Array
(
    [0] => file_get_contents
    [1] => file_put_contents
    [2] => fopen
    [3] => fread
    [4] => fwrite
    [5] => pdo->exec
    [6] => pdo->query
    [7] => pdo->prepare
    [8] => pdostatement->execute
)


SNMP

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • SNMP 函数
    • snmp_get_quick_print — 返回 UCD 库中 quick_print 设置的当前值
    • snmp_get_valueretrieval — Return the method how the SNMP values will be returned
    • snmp_read_mib — Reads and parses a MIB file into the active MIB tree
    • snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer
    • snmp_set_oid_numeric_print — Set the OID output format
    • snmp_set_oid_output_format — Set the OID output format
    • snmp_set_quick_print — 设置 UCD SNMP 库中 quick_print 的值
    • snmp_set_valueretrieval — Specify the method how the SNMP values will be returned
    • snmp2_get — Fetch an SNMP object
    • snmp2_getnext — Fetch the SNMP object which follows the given object id
    • snmp2_real_walk — Return all objects including their respective object ID within the specified one
    • snmp2_set — Set the value of an SNMP object
    • snmp2_walk — Fetch all the SNMP objects from an agent
    • snmp3_get — Fetch an SNMP object
    • snmp3_getnext — Fetch the SNMP object which follows the given object id
    • snmp3_real_walk — Return all objects including their respective object ID within the specified one
    • snmp3_set — Set the value of an SNMP object
    • snmp3_walk — Fetch all the SNMP objects from an agent
    • snmpget — 获取一个 SNMP 对象
    • snmpgetnext — Fetch the SNMP object which follows the given object id
    • snmprealwalk — 返回指定的所有对象，包括它们各自的对象 ID
    • snmpset — 设置一个 SNMP 对象
    • snmpwalk — 从代理返回所有的 SNMP 对象
    • snmpwalkoid — 查询关于网络实体的信息树
  • SNMP — The SNMP class
    • SNMP::close — Close SNMP session
    • SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent
    • SNMP::get — Fetch an SNMP object
    • SNMP::getErrno — Get last error code
    • SNMP::getError — Get last error message
    • SNMP::getnext — Fetch an SNMP object which follows the given object id
    • SNMP::set — Set the value of an SNMP object
    • SNMP::setSecurity — Configures security-related SNMPv3 session parameters
    • SNMP::walk — Fetch SNMP object subtree
  • SNMPException — The SNMPException class


简介

The SNMP extension provides a very simple and easily usable toolset for managing remote devices via the Simple Network Management Protocol.

As it is a wrapper around the underlying Net-SNMP library, all basic concepts are the same and the PHP functions change their behaviour depending on the Net-SNMP configuration files and environment variables.

More information about Net-SNMP can be found at » http://www.net-snmp.org/


需求

In order to use the SNMP functions requires installation of the » Net-SNMP package. SNMPv3 functions available only when » OpenSSL package is installed too.

Net-SNMP version 5.3+ is required for Unix installations and Net-SNMP version 5.4+ for Windows.


安装

重要提示：为了使用 UCD SNMP 包，需要在编译之前将 NO_ZEROLENGTH_COMMUNITY 定义为 1。 在配置 UCD SNMP 之后，编辑 config.h 或 acconfig.h，查找 NO_ZEROLENGTH_COMMUNITY，将 #define 所在行的注释去掉。修改后应该类似这样：

#define NO_ZEROLENGTH_COMMUNITY 1
然后使用 --with-snmp[=DIR] 选项编译 PHP。

如果在组合 SNMP 命令时看到奇怪的字段错误，那就是因为没有遵从上述说明。如果不想重新编译 UCD SNMP，可以使用 --enable-ucd-snmp-hack 开关编译 PHP 以绕开上述错误。

Windows 版本在目录 mibs 中包含了支持 SNMP 的文件。此目录应该移到 DRIVE:\usr\mibs，其中 DRIVE 是安装 PHP 所在的盘符，例如 c:\usr\mibs。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

For the snmp_set_oid_output_format()
SNMP_OID_OUTPUT_SUFFIX (int)
SNMP_OID_OUTPUT_MODULE (int)
SNMP_OID_OUTPUT_FULL (int)
SNMP_OID_OUTPUT_NUMERIC (int)
SNMP_OID_OUTPUT_UCD (int)
SNMP_OID_OUTPUT_NONE (int)
For the snmp_set_valueretrieval()
SNMP_VALUE_LIBRARY (int)
SNMP_VALUE_PLAIN (int)
SNMP_VALUE_OBJECT (int)
SNMP types as returned if SNMP_VALUE_OBJECT was used with snmp_set_valueretrieval()
SNMP_BIT_STR (int)
SNMP_OCTET_STR (int)
SNMP_OPAQUE (int)
SNMP_NULL (int)
SNMP_OBJECT_ID (int)
SNMP_IPADDRESS (int)
SNMP_COUNTER (int)
SNMP_UNSIGNED (int)
SNMP_TIMETICKS (int)
SNMP_UINTEGER (int)
SNMP_INTEGER (int)
SNMP_COUNTER64 (int)


SNMP 函数

Table of Contents

  • snmp_get_quick_print — 返回 UCD 库中 quick_print 设置的当前值
  • snmp_get_valueretrieval — Return the method how the SNMP values will be returned
  • snmp_read_mib — Reads and parses a MIB file into the active MIB tree
  • snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer
  • snmp_set_oid_numeric_print — Set the OID output format
  • snmp_set_oid_output_format — Set the OID output format
  • snmp_set_quick_print — 设置 UCD SNMP 库中 quick_print 的值
  • snmp_set_valueretrieval — Specify the method how the SNMP values will be returned
  • snmp2_get — Fetch an SNMP object
  • snmp2_getnext — Fetch the SNMP object which follows the given object id
  • snmp2_real_walk — Return all objects including their respective object ID within the specified one
  • snmp2_set — Set the value of an SNMP object
  • snmp2_walk — Fetch all the SNMP objects from an agent
  • snmp3_get — Fetch an SNMP object
  • snmp3_getnext — Fetch the SNMP object which follows the given object id
  • snmp3_real_walk — Return all objects including their respective object ID within the specified one
  • snmp3_set — Set the value of an SNMP object
  • snmp3_walk — Fetch all the SNMP objects from an agent
  • snmpget — 获取一个 SNMP 对象
  • snmpgetnext — Fetch the SNMP object which follows the given object id
  • snmprealwalk — 返回指定的所有对象，包括它们各自的对象 ID
  • snmpset — 设置一个 SNMP 对象
  • snmpwalk — 从代理返回所有的 SNMP 对象
  • snmpwalkoid — 查询关于网络实体的信息树


返回 UCD 库中 quick_print 设置的当前值

  • ? SNMP 函数
  • snmp_get_valueretrieval ?
  • PHP Manual
  • SNMP 函数
  • 返回 UCD 库中 quick_print 设置的当前值

snmp_get_quick_print

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp_get_quick_print — 返回 UCD 库中 quick_print 设置的当前值

说明

snmp_get_quick_print ( ) : bool

返回保存在 UCD 库中 quick_print 的当前值。默认情况下 quick_print 为 off。

Example #1 snmp_get_quick_print() 示例

<?php
  $quickprint = snmp_get_quick_print();
?>

如果 quick_print 为 off，上边的函数调用将返回 false，而如果 quick_print 为 on，则返回 true。

snmp_get_quick_print() 仅在使用了 UCD SNMP 库时才可用。当使用 Windows SNMP 库时，此函数不可用。

参见 snmp_set_quick_print() 查看 quick_print 的详细说明。


Return the method how the SNMP values will be returned

  • ? snmp_get_quick_print
  • snmp_read_mib ?
  • PHP Manual
  • SNMP 函数
  • Return the method how the SNMP values will be returned

snmp_get_valueretrieval

(PHP 4 >= 4.3.3, PHP 5, PHP 7, PHP 8)

snmp_get_valueretrieval — Return the method how the SNMP values will be returned

说明

snmp_get_valueretrieval ( ) : int

返回值

OR-ed combitantion of constants ( SNMP_VALUE_LIBRARY or SNMP_VALUE_PLAIN ) with possible SNMP_VALUE_OBJECT set.

范例

Example #1 Using snmp_get_valueretrieval

<?php
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 if (snmp_get_valueretrieval() & SNMP_VALUE_OBJECT) {
   echo $ret->value;
 } else {
   echo $ret;
 }
?>

参见

  • snmp_set_valueretrieval() - Specify the method how the SNMP values will be returned
  • 预定义常量


Reads and parses a MIB file into the active MIB tree

  • ? snmp_get_valueretrieval
  • snmp_set_enum_print ?
  • PHP Manual
  • SNMP 函数
  • Reads and parses a MIB file into the active MIB tree

snmp_read_mib

(PHP 5, PHP 7, PHP 8)

snmp_read_mib — Reads and parses a MIB file into the active MIB tree

说明

snmp_read_mib ( string $filename ) : bool

This function is used to load additional, e.g. vendor specific, MIBs so that human readable OIDs like VENDOR-MIB::foo.1 instead of error prone numeric OIDs can be used.

The order in which the MIBs are loaded does matter as the underlying Net-SNMP libary will print warnings if referenced objects cannot be resolved.

参数

filename

The filename of the MIB.

范例

Example #1 Using snmp_read_mib()

<?php
 print_r( snmprealwalk('localhost', 'public', '.1.3.6.1.2.1.2.3.4.5') );

 snmp_read_mib('./FOO-BAR-MIB.txt');
 print_r( snmprealwalk('localhost', 'public', 'FOO-BAR-MIB::someTable' );
?>

The above example is made up but the results would look like:

Array
(
    [iso.3.6.1.2.1.2.3.4.5.0] => Gauge32: 6
)
Array
(
    [FOO-BAR-MIB::someTable.0] => Gauge32: 6
)


Return all values that are enums with their enum value instead of the raw integer

  • ? snmp_read_mib
  • snmp_set_oid_numeric_print ?
  • PHP Manual
  • SNMP 函数
  • Return all values that are enums with their enum value instead of the raw integer

snmp_set_enum_print

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer

说明

snmp_set_enum_print ( bool $enable ) : bool

This function toggles if snmpwalk/snmpget etc. should automatically lookup enum values in the MIB and return them together with their human readable string.

参数

enable

As the value is interpreted as boolean by the Net-SNMP library, it can only be "0" or "1".

范例

Example #1 Using snmp_set_enum_print()

<?php
 snmp_set_enum_print(0);
 echo snmpget('localhost', 'public', 'IF-MIB::ifOperStatus.3') . "\n";
 snmp_set_enum_print(1);
 echo snmpget('localhost', 'public', 'IF-MIB::ifOperStatus.3') . "\n";
?>

The above would return

 INTEGER: up(1)
 INTEGER: 1


Set the OID output format

  • ? snmp_set_enum_print
  • snmp_set_oid_output_format ?
  • PHP Manual
  • SNMP 函数
  • Set the OID output format

snmp_set_oid_numeric_print

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

snmp_set_oid_numeric_print — Set the OID output format

说明

snmp_set_oid_numeric_print ( int $format ) : bool

此函数是该函数的别名： snmp_set_oid_output_format().

参见

  • snmp_set_oid_output_format() - Set the OID output format


Set the OID output format

  • ? snmp_set_oid_numeric_print
  • snmp_set_quick_print ?
  • PHP Manual
  • SNMP 函数
  • Set the OID output format

snmp_set_oid_output_format

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

snmp_set_oid_output_format — Set the OID output format

说明

snmp_set_oid_output_format ( int $format ) : bool

snmp_set_oid_output_format() sets the output format to be full or numeric.

参数

format
OID .1.3.6.1.2.1.1.3.0 representation for various format values
SNMP_OID_OUTPUT_FULL | .iso.org.dod.internet.mgmt.mib-2.system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NUMERIC | .1.3.6.1.2.1.1.3.0

Begining from PHP 5.4.0 four additional constants available:

SNMP_OID_OUTPUT_MODULE | DISMAN-EVENT-MIB::sysUpTimeInstance
SNMP_OID_OUTPUT_SUFFIX | sysUpTimeInstance
SNMP_OID_OUTPUT_UCD | system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NONE | Undefined

返回值

没有返回值。

范例

Example #1 Using snmprealwalk()

<?php

 snmp_read_mib("/usr/share/mibs/netsnmp/NET-SNMP-TC");

 // default or SNMP_OID_OUTPUT_MODULE in PHP >= 5.3.6
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );

 snmp_set_oid_output_format(SNMP_OID_OUTPUT_NUMERIC);
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );

 snmp_set_oid_output_format(SNMP_OID_OUTPUT_FULL);
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );
?>

The above would output:

 Array
 (
    [RFC1213-MIB::sysObjectID.0] => OID: NET-SNMP-TC::linux
 )
 Array
 (
    [.1.3.6.1.2.1.1.2.0] => OID: .1.3.6.1.4.1.8072.3.2.10
 )
 Array
 (
    [.iso.org.dod.internet.mgmt.mib-2.system.sysObjectID.0] => OID: .iso.org.dod.internet.private.enterprises.netSnmp.netSnmpEnumerations.netSnmpAgentOIDs.linux
 )


设置 UCD SNMP 库中 quick_print 的值

  • ? snmp_set_oid_output_format
  • snmp_set_valueretrieval ?
  • PHP Manual
  • SNMP 函数
  • 设置 UCD SNMP 库中 quick_print 的值

snmp_set_quick_print

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp_set_quick_print — 设置 UCD SNMP 库中 quick_print 的值

说明

snmp_set_quick_print ( bool $quick_print ) : void

设置 UCD SNMP 库中 quick_print 的值。当此值被设置（1），SNMP 库将返回'快速打印'值。这意味着将只打印值。当 quick_print 被禁用时（此为默认情况），UCD SNMP 库将打印出额外信息，包括值的类型（如 IpAddress 或 OID）。此外，如果 quick_print 是禁用的，UCD SNMP 库将为所有字符串额外打印出三个或更少字符的十六进制值。

当需要使用返回的信息而不是显示它时，经常会用到设置 quick_print。

<?php
snmp_set_quick_print(0);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a< br />\n";
snmp_set_quick_print(1);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a<br />\n";
?>

第一个打印出来的值可能时：'Timeticks: (0) 0:00:00.00'，然而当设置了 quick_print 之后，只是打印 '0:00:00.00'。

默认情况下 UCD SNMP 库返回冗余的值，而 quick_print 则用来只返回值。

现时，字符串依然返回额外的引号，这将会在后续发行版中更正。

snmp_set_quick_print() 仅在使用了 UCD SNMP 库时才可用。当使用 Windows SNMP 库时，此函数不可用。


Specify the method how the SNMP values will be returned

  • ? snmp_set_quick_print
  • snmp2_get ?
  • PHP Manual
  • SNMP 函数
  • Specify the method how the SNMP values will be returned

snmp_set_valueretrieval

(PHP 4 >= 4.3.3, PHP 5, PHP 7, PHP 8)

snmp_set_valueretrieval — Specify the method how the SNMP values will be returned

说明

snmp_set_valueretrieval ( int $method ) : bool

参数

method
types
SNMP_VALUE_LIBRARY | The return values will be as returned by the Net-SNMP library.
SNMP_VALUE_PLAIN | The return values will be the plain value without the SNMP type hint.
SNMP_VALUE_OBJECT | The return values will be objects with the properties "value" and "type", where the latter is one of the SNMP_OCTET_STR, SNMP_COUNTER etc. constants. The way "value" is returned is based on which one of constants SNMP_VALUE_LIBRARY, SNMP_VALUE_PLAIN is set.

范例

Example #1 Using snmp_set_valueretrieval()

<?php
 snmp_set_valueretrieval(SNMP_VALUE_LIBRARY);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // $ret = "STRING: lo"

 snmp_set_valueretrieval(SNMP_VALUE_PLAIN);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // $ret = "lo";

 snmp_set_valueretrieval(SNMP_VALUE_OBJECT);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => lo
 // )

 // PHP 5.4+ examples
 snmp_set_valueretrieval(SNMP_VALUE_OBJECT | SNMP_VALUE_PLAIN);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => lo
 // )

 snmp_set_valueretrieval(SNMP_VALUE_OBJECT | SNMP_VALUE_LIBRARY);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => STRING: lo
 // )

?>

参见

  • snmp_get_valueretrieval() - Return the method how the SNMP values will be returned
  • 预定义常量


Fetch an SNMP object

  • ? snmp_set_valueretrieval
  • snmp2_getnext ?
  • PHP Manual
  • SNMP 函数
  • Fetch an SNMP object

snmp2_get

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

snmp2_get — Fetch an SNMP object

说明

snmp2_get ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmp2_get() function is used to read the value of an SNMP object specified by the object_id.

参数

hostname

The SNMP agent.

community

The read community.

object_id

The SNMP object.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns SNMP object value on success or false on error.

范例

Example #1 Using snmp2_get()

<?php
$syscontact = snmp2_get("127.0.0.1", "public", "system.SysContact.0");
?>

参见

  • snmp2_set() - Set the value of an SNMP object


Fetch the SNMP object which follows the given object id

  • ? snmp2_get
  • snmp2_real_walk ?
  • PHP Manual
  • SNMP 函数
  • Fetch the SNMP object which follows the given object id

snmp2_getnext

(PHP >= 5.2.0, PHP 7, PHP 8)

snmp2_getnext — Fetch the SNMP object which follows the given object id

说明

snmp2_getnext ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmp2_get_next() function is used to read the value of the SNMP object that follows the specified object_id.

参数

hostname

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns SNMP object value on success or false on error. In case of an error, an E_WARNING message is shown.

范例

Example #1 Using snmp2_get_next()

<?php
$nameOfSecondInterface = snmp2_get_next('localhost', 'public', 'IF-MIB::ifName.1';
?>

参见

  • snmp2_get() - Fetch an SNMP object
  • snmp2_walk() - Fetch all the SNMP objects from an agent


Return all objects including their respective object ID within the specified one

  • ? snmp2_getnext
  • snmp2_set ?
  • PHP Manual
  • SNMP 函数
  • Return all objects including their respective object ID within the specified one

snmp2_real_walk

(PHP >= 5.2.0, PHP 7, PHP 8)

snmp2_real_walk — Return all objects including their respective object ID within the specified one

说明

snmp2_real_walk ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

The snmp2_real_walk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

参数

hostname

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns an associative array of the SNMP object ids and their values on success or false on error. In case of an error, an E_WARNING message is shown.

范例

Example #1 Using snmp2_real_walk()

<?php
 print_r(snmp2_real_walk("localhost", "public", "IF-MIB::ifName"));
?>

The above will output something like:

    Array
      (
      [IF-MIB::ifName.1] => STRING: lo
      [IF-MIB::ifName.2] => STRING: eth0
      [IF-MIB::ifName.3] => STRING: eth2
      [IF-MIB::ifName.4] => STRING: sit0
      [IF-MIB::ifName.5] => STRING: sixxs
    )

参见

  • snmp2_walk() - Fetch all the SNMP objects from an agent


Set the value of an SNMP object

  • ? snmp2_real_walk
  • snmp2_walk ?
  • PHP Manual
  • SNMP 函数
  • Set the value of an SNMP object

snmp2_set

(PHP >= 5.2.0, PHP 7, PHP 8)

snmp2_set — Set the value of an SNMP object

说明

snmp2_set ( string $hostname , string $community , array|string $object_id , array|string $type , array|string $value , int $timeout = -1 , int $retries = -1 ) : array|bool

snmp2_set() is used to set the value of an SNMP object specified by the object_id.

参数

hostname

The hostname of the SNMP agent (server).

community

The write community.

object_id

The SNMP object id.

type

MIB 定义了各个对象 id 的类型。必须是下面列出的单个字符之一。

类型
= MIB类型
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

如果在编译 SNMP 库时定义了 OPAQUE_SPECIAL_TYPES，那么下列值是合法的：

types
U | unsigned int64
I | signed int64
F | float
D | double

这些值大都会使用与 ASN.1 相符的类型。's'，'x'，'d' 以及 'b' 都是指定一个八字节字符串值的方式。并且 'u' 无符号类型也可用于处理 Gauge32 值。

如果 MIB 文件是用 "snmp_read_mib" 或者通过在 libsnmp config 中指定而加载入 MIB 树时， '=' 可以被用作为所有对象的 type 参数，因为 type 可以被自动从 MIB 中读取。

注意有两种方式可以设定 BITS 类型的变量，例如 "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • 使用 "b" 类型以及一个位数的列表。不推荐使用此方法，因为 GET 查询对同一个 OID 将会返回例如 0xF8。
  • 使用 "x" 类型以及一个十六进制数但是不需要通常的 "0x" 前缀。

更多细节见范例部分。

value

The new value.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

成功时返回 true， 或者在失败时返回 false。

If the SNMP host rejects the data type, an E_WARNING message like "Warning: Error in packet. Reason: (badValue) The value given has the wrong type or length." is shown. If an unknown or invalid OID is specified the warning probably reads "Could not add variable".

范例

Example #1 Using snmp2_set()

<?php
  snmp2_set("localhost", "public", "IF-MIB::ifAlias.3", "s", "foo");
?>

Example #2 Using snmp2_set() for setting BITS SNMP object id

<?php
  snmp2_set("localhost", "public", 'FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  snmp2_set("localhost", "public", 'FOO-MIB::bar.42', 'x', 'F0');
?>

参见

  • snmp2_get() - Fetch an SNMP object


Fetch all the SNMP objects from an agent

  • ? snmp2_set
  • snmp3_get ?
  • PHP Manual
  • SNMP 函数
  • Fetch all the SNMP objects from an agent

snmp2_walk

(PHP >= 5.2.0, PHP 7, PHP 8)

snmp2_walk — Fetch all the SNMP objects from an agent

说明

snmp2_walk ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

snmp2_walk() function is used to read all the values from an SNMP agent specified by the hostname.

参数

hostname

The SNMP agent (server).

community

The read community.

object_id

If null, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns an array of SNMP object values starting from the object_id as root or false on error.

范例

Example #1 snmp2_walk() Example

<?php
$a = snmp2_walk("127.0.0.1", "public", "");

foreach ($a as $val) {
    echo "$val\n";
}

?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

参见

  • snmp2_real_walk() - Return all objects including their respective object ID within the specified one


Fetch an SNMP object

  • ? snmp2_walk
  • snmp3_getnext ?
  • PHP Manual
  • SNMP 函数
  • Fetch an SNMP object

snmp3_get

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp3_get — Fetch an SNMP object

说明

snmp3_get ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmp3_get() function is used to read the value of an SNMP object specified by the object_id.

参数

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns SNMP object value on success or false on error.

范例

Example #1 Using snmp3_get()

<?php
$nameOfSecondInterface = snmp3_get('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName.2');
?>

参见

  • snmp3_set() - Set the value of an SNMP object


Fetch the SNMP object which follows the given object id

  • ? snmp3_get
  • snmp3_real_walk ?
  • PHP Manual
  • SNMP 函数
  • Fetch the SNMP object which follows the given object id

snmp3_getnext

(PHP 5, PHP 7, PHP 8)

snmp3_getnext — Fetch the SNMP object which follows the given object id

说明

snmp3_getnext ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmp3_getnext() function is used to read the value of the SNMP object that follows the specified object_id.

参数

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns SNMP object value on success or false on error. In case of an error, an E_WARNING message is shown.

范例

Example #1 Using snmp3_getnext()

<?php
$nameOfSecondInterface = snmp3_getnext('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName.1');
?>

参见

  • snmp3_get() - Fetch an SNMP object
  • snmp3_walk() - Fetch all the SNMP objects from an agent


Return all objects including their respective object ID within the specified one

  • ? snmp3_getnext
  • snmp3_set ?
  • PHP Manual
  • SNMP 函数
  • Return all objects including their respective object ID within the specified one

snmp3_real_walk

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp3_real_walk — Return all objects including their respective object ID within the specified one

说明

snmp3_real_walk ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

The snmp3_real_walk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

参数

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns an associative array of the SNMP object ids and their values on success or false on error. In case of an error, an E_WARNING message is shown.

范例

Example #1 Using snmp3_real_walk()

<?php
 var_export(snmp3_real_walk('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName'));
?>

The above will output something like:

array (
  'IF-MIB::ifName.1' => 'STRING: lo',
  'IF-MIB::ifName.2' => 'STRING: eth0',
  'IF-MIB::ifName.3' => 'STRING: eth2',
  'IF-MIB::ifName.4' => 'STRING: sit0',
  'IF-MIB::ifName.5' => 'STRING: sixxs',
)

参见

  • snmpwalk() - 从代理返回所有的 SNMP 对象


Set the value of an SNMP object

  • ? snmp3_real_walk
  • snmp3_walk ?
  • PHP Manual
  • SNMP 函数
  • Set the value of an SNMP object

snmp3_set

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp3_set — Set the value of an SNMP object

说明

snmp3_set ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , array|string $type , array|string $value , int $timeout = -1 , int $retries = -1 ) : array|bool

snmp3_set() is used to set the value of an SNMP object specified by the object_id.

Even if the security level does not use an auth or priv protocol/password valid values have to be specified.

参数

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

The SNMP object id.

type

MIB 定义了各个对象 id 的类型。必须是下面列出的单个字符之一。

类型
= MIB类型
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

如果在编译 SNMP 库时定义了 OPAQUE_SPECIAL_TYPES，那么下列值是合法的：

types
U | unsigned int64
I | signed int64
F | float
D | double

这些值大都会使用与 ASN.1 相符的类型。's'，'x'，'d' 以及 'b' 都是指定一个八字节字符串值的方式。并且 'u' 无符号类型也可用于处理 Gauge32 值。

如果 MIB 文件是用 "snmp_read_mib" 或者通过在 libsnmp config 中指定而加载入 MIB 树时， '=' 可以被用作为所有对象的 type 参数，因为 type 可以被自动从 MIB 中读取。

注意有两种方式可以设定 BITS 类型的变量，例如 "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • 使用 "b" 类型以及一个位数的列表。不推荐使用此方法，因为 GET 查询对同一个 OID 将会返回例如 0xF8。
  • 使用 "x" 类型以及一个十六进制数但是不需要通常的 "0x" 前缀。

更多细节见范例部分。

value

The new value

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

成功时返回 true， 或者在失败时返回 false。

If the SNMP host rejects the data type, an E_WARNING message like "Warning: Error in packet. Reason: (badValue) The value given has the wrong type or length." is shown. If an unknown or invalid OID is specified the warning probably reads "Could not add variable".

范例

Example #1 Using snmp3_set()

<?php
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifAlias.3', 's', "foo");
?>

Example #2 Using snmp3_set() for setting BITS SNMP object id

<?php
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'FOO-MIB::bar.42', 'x', 'F0');
?>


Fetch all the SNMP objects from an agent

  • ? snmp3_set
  • snmpget ?
  • PHP Manual
  • SNMP 函数
  • Fetch all the SNMP objects from an agent

snmp3_walk

(PHP 4, PHP 5, PHP 7, PHP 8)

snmp3_walk — Fetch all the SNMP objects from an agent

说明

snmp3_walk ( string $hostname , string $security_name , string $security_level , string $auth_protocol , string $auth_passphrase , string $privacy_protocol , string $privacy_passphrase , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : array|bool

snmp3_walk() function is used to read all the values from an SNMP agent specified by the hostname.

Even if the security level does not use an auth or priv protocol/password valid values have to be specified.

参数

hostname

The hostname of the SNMP agent (server).

security_name

the security name, usually some kind of username

security_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

privacy_protocol

the privacy protocol (DES or AES)

privacy_passphrase

the privacy pass phrase

object_id

If null, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns an array of SNMP object values starting from the object_id as root or false on error.

范例

Example #1 snmp3_walk() Example

<?php
$ret = snmp3_walk('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName');
var_export($ret);
?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost:

array (
  0 => 'STRING: lo',
  1 => 'STRING: eth0',
  2 => 'STRING: eth2',
  3 => 'STRING: sit0',
  4 => 'STRING: sixxs',
)

参见

  • snmp3_real_walk() - Return all objects including their respective object ID within the specified one


获取一个 SNMP 对象

  • ? snmp3_walk
  • snmpgetnext ?
  • PHP Manual
  • SNMP 函数
  • 获取一个 SNMP 对象

snmpget

(PHP 4, PHP 5, PHP 7, PHP 8)

snmpget — 获取一个 SNMP 对象

说明

snmpget ( string $hostname , string $community , string $object_id , int $timeout = ? , int $retries = ? ) : string

成功则返回 SNMP 的对象值，失败则返回 false。

函数 snmpget() 用于读取由 object_id 指定的 SNMP 对象值。hostname 指定 SNMP 代理，而 community 参数指定具有读权限的域的名字。

<?php
$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0");
?>


Fetch the SNMP object which follows the given object id

  • ? snmpget
  • snmprealwalk ?
  • PHP Manual
  • SNMP 函数
  • Fetch the SNMP object which follows the given object id

snmpgetnext

(PHP 5, PHP 7, PHP 8)

snmpgetnext — Fetch the SNMP object which follows the given object id

说明

snmpgetnext ( string $hostname , string $community , array|string $object_id , int $timeout = -1 , int $retries = -1 ) : stdClass|array|string|bool

The snmpgetnext() function is used to read the value of the SNMP object that follows the specified object_id.

参数

hostname

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns SNMP object value on success or false on error. In case of an error, an E_WARNING message is shown.

范例

Example #1 Using snmpgetnext()

<?php
$nameOfSecondInterface = snmpgetnetxt('localhost', 'public', 'IF-MIB::ifName.1';
?>

参见

  • snmpget() - 获取一个 SNMP 对象
  • snmpwalk() - 从代理返回所有的 SNMP 对象


返回指定的所有对象，包括它们各自的对象 ID

  • ? snmpgetnext
  • snmpset ?
  • PHP Manual
  • SNMP 函数
  • 返回指定的所有对象，包括它们各自的对象 ID

snmprealwalk

(PHP 4, PHP 5, PHP 7, PHP 8)

snmprealwalk — 返回指定的所有对象，包括它们各自的对象 ID

说明

snmprealwalk ( string $host , string $community , string $object_id , int $timeout = 1000000 , int $retries = 5 ) : array

The snmprealwalk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

参数

host

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

返回值

Returns an associative array of the SNMP object ids and their values on success or false on error. In case of an error, an E_WARNING message is shown.

范例

Example #1 Using snmprealwalk()

<?php
 print_r(snmprealwalk("localhost", "public", "IF-MIB::ifName"));
?>

The above will output something like:

    Array
      (
      [IF-MIB::ifName.1] => STRING: lo
      [IF-MIB::ifName.2] => STRING: eth0
      [IF-MIB::ifName.3] => STRING: eth2
      [IF-MIB::ifName.4] => STRING: sit0
      [IF-MIB::ifName.5] => STRING: sixxs
    )

参见

  • snmpwalk() - 从代理返回所有的 SNMP 对象


设置一个 SNMP 对象

  • ? snmprealwalk
  • snmpwalk ?
  • PHP Manual
  • SNMP 函数
  • 设置一个 SNMP 对象

snmpset

(PHP 4, PHP 5, PHP 7, PHP 8)

snmpset — 设置一个 SNMP 对象

说明

snmpset ( string $hostname , string $community , string $object_id , string $type , mixed $value , int $timeout = ? , int $retries = ? ) : bool

设置指定的 SNMP 对象的值，成功返回 true，错误则返回 false。

函数 snmpset() 用于设置由 object_id 指定的 SNMP 对象的值。hostname 指定 SNMP 代理，而 community 参数指定具有读权限的域。


从代理返回所有的 SNMP 对象

  • ? snmpset
  • snmpwalkoid ?
  • PHP Manual
  • SNMP 函数
  • 从代理返回所有的 SNMP 对象

snmpwalk

(PHP 4, PHP 5, PHP 7, PHP 8)

snmpwalk — 从代理返回所有的 SNMP 对象

说明

snmpwalk ( string $hostname , string $community , string $object_id , int $timeout = ? , int $retries = ? ) : array

返回由 object_id 作为根的 SNMP 对象值所组成的数组，错误则返回 false。

snmpwalk() 函数是用来读取所有由 hostname 指定的 SNMP 代理的值。Community 指定该代理中具有读权限的域。一个为 null 的 object_id 将被看作 SNMP 对象树的根，而在此树下的所有对象将作为一个数组被返回。如果指定了 object_id，则返回所有在 object_id 下的 SNMP 对象。

<?php
$a = snmpwalk("127.0.0.1", "public", "");
?>

上边的函数调用将从运行于本机的 SNMP 代理那里返回所有的 SNMP 对象。可使用循环遍历这些值。

<?php
foreach ($a as $val) {
    echo "$val\n";
}
?>


查询关于网络实体的信息树

  • ? snmpwalk
  • SNMP ?
  • PHP Manual
  • SNMP 函数
  • 查询关于网络实体的信息树

snmpwalkoid

(PHP 4, PHP 5, PHP 7, PHP 8)

snmpwalkoid — 查询关于网络实体的信息树

说明

snmpwalkoid ( string $hostname , string $community , string $object_id , int $timeout = ? , int $retries = ? ) : array

返回一个包含对象 id 及它们各自对象值的关联数组，这些对象以 object_id 作为根，错误则返回 false。

snmpwalkoid() 用于从 hostname 所指定的 SNMP 代理那里读取所有对象 id 及它们各自的值。community 指定对于该代理有读权限的域。一个为 null 的 object_id 将被看作 SNMP 对象树的根，而在此树下的所有对象将作为一个数组被返回。如果指定了 object_id，则返回所有在 object_id 下的 SNMP 对象。

snmpwalkoid() 和 snmpwalk() 的同时存在出于历史原因。提供两个函数是为了向后兼容。

<?php
$a = snmpwalkoid("127.0.0.1", "public", "");
?>

上边的函数调用将从运行于本机的 SNMP 代理那里返回所有的 SNMP 对象。可使用循环遍历这些值。

<?php
for (reset($a); $i = key($a); next($a)) {
    echo "$i: $a[$i]<br />\n";
}
?>


The SNMP class

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

简介

Represents SNMP session.

类摘要

SNMP {
/* 属性 */
public int $max_oids ;
public int $valueretrieval ;
public bool $quick_print ;
public bool $enum_print ;
public int $oid_output_format ;
public bool $oid_increasing_check ;
public int $exceptions_enabled ;
public array $info ;
/* 方法 */
public __construct ( int $version , string $hostname , string $community , int $timeout = -1 , int $retries = -1 )
public close ( ) : bool
public get ( array|string $objectId , bool $preserveKeys = false ) : array|bool
public getErrno ( ) : int
public getError ( ) : string
public getnext ( array|string $objectId ) : array|bool
public set ( array|string $objectId , array|string $type , array|string $value ) : array|bool
public setSecurity
 ( string $securityLevel
, string $authProtocol = ""
, string $authPassphrase = ""
, string $privacyProtocol = ""
, string $privacyPassphrase = ""
, string $contextName = ""
, string $contextEngineId = ""
) : bool
public walk ( array|string $objectId , bool $suffixAsKey = false , int $maxRepetitions = -1 , int $nonRepeaters = -1 ) : array|bool
/* 常量 */
const int ERRNO_NOERROR = 0 ;
const int ERRNO_GENERIC = 2 ;
const int ERRNO_TIMEOUT = 4 ;
const int ERRNO_ERROR_IN_REPLY = 8 ;
const int ERRNO_OID_NOT_INCREASING = 16 ;
const int ERRNO_OID_PARSING_ERROR = 32 ;
const int ERRNO_MULTIPLE_SET_QUERIES = 64 ;
const int ERRNO_ANY = 126 ;
const int VERSION_1 = 0 ;
const int VERSION_2C = 1 ;
const int VERSION_2c = 1 ;
const int VERSION_3 = 3 ;
}

属性

max_oids

Maximum OID per GET/SET/GETBULK request

valueretrieval

Controls the method how the SNMP values will be returned

SNMP_VALUE_LIBRARY | The return values will be as returned by the Net-SNMP library.
SNMP_VALUE_PLAIN | The return values will be the plain value without the SNMP type hint.
SNMP_VALUE_OBJECT | The return values will be objects with the properties "value" and "type", where the latter is one of the SNMP_OCTET_STR, SNMP_COUNTER etc. constants. The way "value" is returned is based on which one of SNMP_VALUE_LIBRARY, SNMP_VALUE_PLAIN is set
quick_print

Value of quick_print within the NET-SNMP library

Sets the value of quick_print within the NET-SNMP library. When this is set (1), the SNMP library will return 'quick printed' values. This means that just the value will be printed. When quick_print is not enabled (default) the NET-SNMP library prints extra information including the type of the value (i.e. IpAddress or OID). Additionally, if quick_print is not enabled, the library prints additional hex values for all strings of three characters or less.

enum_print

Controls the way enum values are printed

Parameter toggles if walk/get etc. should automatically lookup enum values in the MIB and return them together with their human readable string.

oid_output_format

Controls OID output format

OID .1.3.6.1.2.1.1.3.0 representation for various oid_output_format values
SNMP_OID_OUTPUT_FULL | .iso.org.dod.internet.mgmt.mib-2.system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NUMERIC | .1.3.6.1.2.1.1.3.0
SNMP_OID_OUTPUT_MODULE | DISMAN-EVENT-MIB::sysUpTimeInstance
SNMP_OID_OUTPUT_SUFFIX | sysUpTimeInstance
SNMP_OID_OUTPUT_UCD | system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NONE | Undefined
oid_increasing_check

Controls disabling check for increasing OID while walking OID tree

Some SNMP agents are known for returning OIDs out of order but can complete the walk anyway. Other agents return OIDs that are out of order and can cause SNMP::walk() to loop indefinitely until memory limit will be reached. PHP SNMP library by default performs OID increasing check and stops walking on OID tree when it detects possible loop with issuing warning about non-increasing OID faced. Set oid_increasing_check to false to disable this check.

exceptions_enabled

Controls which failures will raise SNMPException instead of warning. Use bitwise OR'ed SNMP::ERRNO_* constants. By default all SNMP exceptions are disabled.

info

Read-only property with remote agent configuration: hostname, port, default timeout, default retries count

预定义常量

SNMP Error Types

SNMP::ERRNO_NOERROR

No SNMP-specific error occurred.

SNMP::ERRNO_GENERIC

A generic SNMP error occurred.

SNMP::ERRNO_TIMEOUT

Request to SNMP agent timed out.

SNMP::ERRNO_ERROR_IN_REPLY

SNMP agent returned an error in reply.

SNMP::ERRNO_OID_NOT_INCREASING

SNMP agent faced OID cycling reporning non-increasing OID while executing (BULK)WALK command. This indicates bogus remote SNMP agent.

SNMP::ERRNO_OID_PARSING_ERROR

Library failed while parsing OID (and/or type for SET command). No queries has been made.

SNMP::ERRNO_MULTIPLE_SET_QUERIES

Library will use multiple queries for SET operation requested. That means that operation will be performed in a non-transaction manner and second or subsequent chunks may fail if a type or value failure will be faced.

SNMP::ERRNO_ANY

All SNMP::ERRNO_* codes bitwise OR'ed.

SNMP Protocol Versions

SNMP::VERSION_1

SNMP::VERSION_2C, SNMP::VERSION_2c

SNMP::VERSION_3

Table of Contents

  • SNMP::close — Close SNMP session
  • SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent
  • SNMP::get — Fetch an SNMP object
  • SNMP::getErrno — Get last error code
  • SNMP::getError — Get last error message
  • SNMP::getnext — Fetch an SNMP object which follows the given object id
  • SNMP::set — Set the value of an SNMP object
  • SNMP::setSecurity — Configures security-related SNMPv3 session parameters
  • SNMP::walk — Fetch SNMP object subtree


Close SNMP session

  • ? SNMP
  • SNMP::__construct ?
  • PHP Manual
  • SNMP
  • Close SNMP session

SNMP::close

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::close — Close SNMP session

说明

public SNMP::close ( ) : bool

Frees previously allocated SNMP session object.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SNMP::close() example

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  # ...
  # get, walk, etc goes here
  # ...
  $session->close();
?>

参见

  • SNMP::__construct() - Creates SNMP instance representing session to remote SNMP agent


Creates SNMP instance representing session to remote SNMP agent

  • ? SNMP::close
  • SNMP::get ?
  • PHP Manual
  • SNMP
  • Creates SNMP instance representing session to remote SNMP agent

SNMP::__construct

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent

说明

public SNMP::__construct ( int $version , string $hostname , string $community , int $timeout = -1 , int $retries = -1 )

The function description goes here.

参数

version

SNMP protocol version:
SNMP::VERSION_1,
SNMP::VERSION_2C,
SNMP::VERSION_3.

hostname

The SNMP agent. hostname may be suffixed with optional SNMP agent port after colon. IPv6 addresses must be enclosed in square brackets if used with port. If FQDN is used for hostname it will be resolved by php-snmp library, not by Net-SNMP engine. Usage of IPv6 addresses when specifying FQDN may be forced by enclosing FQDN into square brackets. Here it is some examples:

IPv4 with default port | 127.0.0.1
IPv6 with default port | ::1 or [::1]
IPv4 with specific port | 127.0.0.1:1161
IPv6 with specific port | [::1]:1161
FQDN with default port | host.domain
FQDN with specific port | host.domain:1161
FQDN with default port, force usage of IPv6 address | [host.domain]
FQDN with specific port, force usage of IPv6 address | [host.domain]:1161

community

The purpuse of community is SNMP version specific:

SNMP::VERSION_1 | SNMP community
SNMP::VERSION_2C | SNMP community
SNMP::VERSION_3 | SNMPv3 securityName
timeout

The number of microseconds until the first timeout.

retries

The number of retries in case timeout occurs.

返回值

Returns SNMP object representing remote SNMP agent.

错误／异常

SNMP::__construct() throws an exception when parameters count or types are wrong or unknown SNMP protocol version specified.

范例

Example #1 Fetching sysLocation

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $sysdescr = $session->get("sysDescr.0");
  echo "$sysdescr\n";
?>

以上例程的输出类似于：

STRING: Test server

参见

  • SNMP::close() - Close SNMP session


Fetch an SNMP object

  • ? SNMP::__construct
  • SNMP::getErrno ?
  • PHP Manual
  • SNMP
  • Fetch an SNMP object

SNMP::get

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::get — Fetch an SNMP object

说明

public SNMP::get ( array|string $objectId , bool $preserveKeys = false ) : array|bool

Fetch an SNMP object specified in objectId using GET query.

参数

If objectId is a string, then SNMP::get() will return SNMP object as string. If objectId is a array, all requested SNMP objects will be returned as associative array of the SNMP object ids and their values.

objectId

The SNMP object (OID) or objects

preserveKeys

When objectId is a array and preserveKeys set to true keys in results will be taken exactly as in objectId, otherwise SNMP::oid_output_format property is used to determinate the form of keys.

返回值

Returns SNMP objects requested as string or array depending on objectId type or false on error.

错误／异常

本方法默认不抛出任何异常。如果要在某些库出错时抛出 SNMPException 异常，用户需要将 SNMP 类参数 exceptions_enabled 设定为相应的值。更多细节见 SNMP::$exceptions_enabled 的解释。

范例

Example #1 Single SNMP object

Single SNMP object may be requested in two ways: as string resulting string return value or as single-element array with associative array as output.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $sysdescr = $session->get("sysDescr.0");
  echo "$sysdescr\n";
  $sysdescr = $session->get(array("sysDescr.0"));
  print_r($sysdescr);
?>

以上例程的输出类似于：

STRING: Test server
Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
)

Example #2 Multiple SNMP objects

$session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $results = $session->get(array("sysDescr.0", "sysName.0"));
  print_r($results);
  $session->close();

以上例程的输出类似于：

Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
    [SNMPv2-MIB::sysName.0] => STRING: myhost.nodomain
)

参见

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Get last error message


Get last error code

  • ? SNMP::get
  • SNMP::getError ?
  • PHP Manual
  • SNMP
  • Get last error code

SNMP::getErrno

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::getErrno — Get last error code

说明

public SNMP::getErrno ( ) : int

Returns error code from last SNMP request.

返回值

Returns one of SNMP error code values described in constants chapter.

范例

Example #1 SNMP::getErrno() example

<?php
$session = new SNMP(SNMP::VERSION_2c, '127.0.0.1', 'boguscommunity');
var_dump(@$session->get('.1.3.6.1.2.1.1.1.0'));
var_dump($session->getErrno() == SNMP::ERRNO_TIMEOUT);
?>

以上例程会输出：

bool(false)
bool(true)

参见

  • SNMP::getError() - Get last error message


Get last error message

  • ? SNMP::getErrno
  • SNMP::getnext ?
  • PHP Manual
  • SNMP
  • Get last error message

SNMP::getError

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::getError — Get last error message

说明

public SNMP::getError ( ) : string

Returns string with error from last SNMP request.

返回值

String describing error from last SNMP request.

范例

Example #1 SNMP::getError() example

<?php
$session = new SNMP(SNMP::VERSION_2c, '127.0.0.1', 'boguscommunity');
var_dump(@$session->get('.1.3.6.1.2.1.1.1.0'));
var_dump($session->getError());
?>

以上例程会输出：

bool(false)
string(26) "No response from 127.0.0.1"

参见

  • SNMP::getErrno() - Get last error code


Fetch an SNMP object which follows the given object id

  • ? SNMP::getError
  • SNMP::set ?
  • PHP Manual
  • SNMP
  • Fetch an SNMP object which follows the given object id

SNMP::getnext

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::getnext — Fetch an SNMP object which follows the given object id

说明

public SNMP::getnext ( array|string $objectId ) : array|bool

Fetch an SNMP object that follows specified objectId.

参数

If objectId is a string, then SNMP::getnext() will return SNMP object as string. If objectId is a array, all requested SNMP objects will be returned as associative array of the SNMP object ids and their values.

objectId

The SNMP object (OID) or objects

返回值

Returns SNMP objects requested as string or array depending on objectId type or false on error.

错误／异常

本方法默认不抛出任何异常。如果要在某些库出错时抛出 SNMPException 异常，用户需要将 SNMP 类参数 exceptions_enabled 设定为相应的值。更多细节见 SNMP::$exceptions_enabled 的解释。

范例

Example #1 Single SNMP object

Single SNMP object may be requested in two ways: as string resulting string return value or as single-element array with associative array as output.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $nsysdescr = $session->getnext("sysDescr.0");
  echo "$nsysdescr\n";
  $nsysdescr = $session->getnext(array("sysDescr.0"));
  print_r($nsysdescr);
?>

以上例程的输出类似于：

OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
Array
(
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
)

Example #2 Miltiple SNMP objects

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $results = $session->getnext(array("sysDescr.0", "sysName.0"));
  print_r($results);
  $session->close();
?>

以上例程的输出类似于：

Array
(
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
    [SNMPv2-MIB::sysLocation.0] => STRING: Nowhere
)

参见

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Get last error message


Set the value of an SNMP object

  • ? SNMP::getnext
  • SNMP::setSecurity ?
  • PHP Manual
  • SNMP
  • Set the value of an SNMP object

SNMP::set

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::set — Set the value of an SNMP object

说明

public SNMP::set ( array|string $objectId , array|string $type , array|string $value ) : array|bool

Requests remote SNMP agent setting the value of one or more SNMP objects specified by the objectId.

参数

If objectId is string, both type and value must be string too. If objectId is array value must be equal-sized array containing corresponding values, type may be either string (it's value will be used for all objectId-value pairs) or equal-sized array with per-OID value. When any other parameters' combinations are used, a number of E_WARNING messages may be shown with detailed description.

objectId

The SNMP object id

When count of OIDs in object_id array is greater than max_oids object property set method will have to use multiple queries to perform requested value updates. In this case type and value checks are made per-chunk so second or subsequent requests may fail due to wrong type or value for OID requested. To mark this a warning is raised when count of OIDs in object_id array is greater than max_oids.

type

MIB 定义了各个对象 id 的类型。必须是下面列出的单个字符之一。

类型
= MIB类型
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

如果在编译 SNMP 库时定义了 OPAQUE_SPECIAL_TYPES，那么下列值是合法的：

types
U | unsigned int64
I | signed int64
F | float
D | double

这些值大都会使用与 ASN.1 相符的类型。's'，'x'，'d' 以及 'b' 都是指定一个八字节字符串值的方式。并且 'u' 无符号类型也可用于处理 Gauge32 值。

如果 MIB 文件是用 "snmp_read_mib" 或者通过在 libsnmp config 中指定而加载入 MIB 树时， '=' 可以被用作为所有对象的 type 参数，因为 type 可以被自动从 MIB 中读取。

注意有两种方式可以设定 BITS 类型的变量，例如 "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • 使用 "b" 类型以及一个位数的列表。不推荐使用此方法，因为 GET 查询对同一个 OID 将会返回例如 0xF8。
  • 使用 "x" 类型以及一个十六进制数但是不需要通常的 "0x" 前缀。

更多细节见范例部分。

value

The new value.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

本方法默认不抛出任何异常。如果要在某些库出错时抛出 SNMPException 异常，用户需要将 SNMP 类参数 exceptions_enabled 设定为相应的值。更多细节见 SNMP::$exceptions_enabled 的解释。

范例

Example #1 Set single SNMP object id

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set('SNMPv2-MIB::sysContact.0', 's', "Nobody");
?>

Example #2 Set multiple values using single SNMP::set() call

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set(array('SNMPv2-MIB::sysContact.0', 'SNMPv2-MIB::sysLocation.0'), array('s', 's'), array("Nobody", "Nowhere"));
// or
  $session->set(array('SNMPv2-MIB::sysContact.0', 'SNMPv2-MIB::sysLocation.0'), 's', array("Nobody", "Nowhere"));
?>

Example #3 Using SNMP::set() for setting BITS SNMP object id

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set('FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  $session->set('FOO-MIB::bar.42', 'x', 'F0');
?>

参见

  • SNMP::get() - Fetch an SNMP object


Configures security-related SNMPv3 session parameters

  • ? SNMP::set
  • SNMP::walk ?
  • PHP Manual
  • SNMP
  • Configures security-related SNMPv3 session parameters

SNMP::setSecurity

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::setSecurity — Configures security-related SNMPv3 session parameters

说明

public SNMP::setSecurity
 ( string $securityLevel
, string $authProtocol = ""
, string $authPassphrase = ""
, string $privacyProtocol = ""
, string $privacyPassphrase = ""
, string $contextName = ""
, string $contextEngineId = ""
) : bool

setSecurity configures security-related session parameters used in SNMP protocol version 3

参数

securityLevel

the security level (noAuthNoPriv|authNoPriv|authPriv)

authProtocol

the authentication protocol (MD5 or SHA)

authPassphrase

the authentication pass phrase

privacyProtocol

the privacy protocol (DES or AES)

privacyPassphrase

the privacy pass phrase

contextName

the context name

contextEngineId

the context EngineID

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SNMP::setSecurity() example

<?php
  $session = new SNMP(SNMP::VERSION_3, $hostname, $rwuser, $timeout, $retries);
  $session->setSecurity('authPriv', 'MD5', $auth_pass, 'AES', $priv_pass, '', 'aeeeff');
?>

参见

  • SNMP::__construct() - Creates SNMP instance representing session to remote SNMP agent


Fetch SNMP object subtree

  • ? SNMP::setSecurity
  • SNMPException ?
  • PHP Manual
  • SNMP
  • Fetch SNMP object subtree

SNMP::walk

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SNMP::walk — Fetch SNMP object subtree

说明

public SNMP::walk ( array|string $objectId , bool $suffixAsKey = false , int $maxRepetitions = -1 , int $nonRepeaters = -1 ) : array|bool

SNMP::walk() is used to read SNMP subtree rooted at specified objectId.

参数

objectId

Root of subtree to be fetched

suffixAsKey

By default full OID notation is used for keys in output array. If set to true subtree prefix will be removed from keys leaving only suffix of object_id.

nonRepeaters

This specifies the number of supplied variables that should not be iterated over. The default is to use this value from SNMP object.

maxRepetitions

This specifies the maximum number of iterations over the repeating variables. The default is to use this value from SNMP object.

返回值

Returns an associative array of the SNMP object ids and their values on success or false on error. When a SNMP error occures SNMP::getErrno() and SNMP::getError() can be used for retrieving error number (specific to SNMP extension, see class constants) and error message respectively.

错误／异常

本方法默认不抛出任何异常。如果要在某些库出错时抛出 SNMPException 异常，用户需要将 SNMP 类参数 exceptions_enabled 设定为相应的值。更多细节见 SNMP::$exceptions_enabled 的解释。

范例

Example #1 SNMP::walk() example

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $fulltree = $session->walk(".");
  print_r($fulltree);
  $session->close();
?>

以上例程的输出类似于：

Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
    [DISMAN-EVENT-MIB::sysUpTimeInstance] => Timeticks: (1150681750) 133 days, 4:20:17.50
    [SNMPv2-MIB::sysContact.0] => STRING: Nobody
    [SNMPv2-MIB::sysName.0] => STRING: server.localdomain
    ...
)

Example #2 suffixAsKey example

suffixAsKey may be used when merging multiple SNMP subtrees into one. This example maps interface names to their type.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $session->valueretrieval = SNMP_VALUE_PLAIN;
  $ifDescr = $session->walk(".1.3.6.1.2.1.2.2.1.2", TRUE);
  $session->valueretrieval = SNMP_VALUE_LIBRARY;
  $ifType = $session->walk(".1.3.6.1.2.1.2.2.1.3", TRUE);
  print_r($ifDescr);
  print_r($ifType);
  $result = array();
  foreach($ifDescr as $i => $n) {
    $result[$n] = $ifType[$i];
  }
  print_r($result);
?>

以上例程的输出类似于：

Array
(
    [1] => igb0
    [2] => igb1
    [3] => ipfw0
    [4] => lo0
    [5] => lagg0
)
Array
(
    [1] => INTEGER: ieee8023adLag(161)
    [2] => INTEGER: ieee8023adLag(161)
    [3] => INTEGER: ethernetCsmacd(6)
    [4] => INTEGER: softwareLoopback(24)
    [5] => INTEGER: ethernetCsmacd(6)
)
Array
(
    [igb0] => INTEGER: ieee8023adLag(161)
    [igb1] => INTEGER: ieee8023adLag(161)
    [ipfw0] => INTEGER: ethernetCsmacd(6)
    [lo0] => INTEGER: softwareLoopback(24)
    [lagg0] => INTEGER: ethernetCsmacd(6)
)

参见

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Get last error message


The SNMPException class

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

简介

Represents an error raised by SNMP. You should not throw a SNMPException from your own code. See Exceptions for more information about Exceptions in PHP.

类摘要

SNMPException extends RuntimeException {
/* 属性 */
protected string $code ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

code

SNMPlibrary error code. Use Exception::getCode() to access it.


Sockets

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Socket Errors
  • Socket 函数
    • socket_accept — Accepts a connection on a socket
    • socket_addrinfo_bind — Create and bind to a socket from a given addrinfo
    • socket_addrinfo_connect — Create and connect to a socket from a given addrinfo
    • socket_addrinfo_explain — Get information about addrinfo
    • socket_addrinfo_lookup — Get array with contents of getaddrinfo about the given hostname
    • socket_bind — 给套接字绑定名字
    • socket_clear_error — 清除套接字或者最后的错误代码上的错误
    • socket_close — 关闭套接字资源
    • socket_cmsg_space — Calculate message buffer size
    • socket_connect — 开启一个套接字连接
    • socket_create_listen — Opens a socket on port to accept connections
    • socket_create_pair — Creates a pair of indistinguishable sockets and stores them in an array
    • socket_create — 创建一个套接字（通讯节点）
    • socket_export_stream — Export a socket into a stream that encapsulates a socket
    • socket_get_option — Gets socket options for the socket
    • socket_getopt — 别名 socket_get_option
    • socket_getpeername — Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
    • socket_getsockname — Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
    • socket_import_stream — Import a stream
    • socket_last_error — Returns the last error on the socket
    • socket_listen — Listens for a connection on a socket
    • socket_read — Reads a maximum of length bytes from a socket
    • socket_recv — 从已连接的socket接收数据
    • socket_recvfrom — Receives data from a socket whether or not it is connection-oriented
    • socket_recvmsg — Read a message
    • socket_select — Runs the select() system call on the given arrays of sockets with a specified timeout
    • socket_send — Sends data to a connected socket
    • socket_sendmsg — Send a message
    • socket_sendto — Sends a message to a socket, whether it is connected or not
    • socket_set_block — Sets blocking mode on a socket
    • socket_set_nonblock — Sets nonblocking mode for file descriptor fd
    • socket_set_option — Sets socket options for the socket
    • socket_setopt — 别名 socket_set_option
    • socket_shutdown — Shuts down a socket for receiving, sending, or both
    • socket_strerror — Return a string describing a socket error
    • socket_write — Write to a socket
    • socket_wsaprotocol_info_export — Exports the WSAPROTOCOL_INFO Structure
    • socket_wsaprotocol_info_import — Imports a Socket from another Process
    • socket_wsaprotocol_info_release — Releases an exported WSAPROTOCOL_INFO Structure


简介

Socket扩展是基于流行的BSD sockets，实现了和socket通讯功能的底层接口，它可以和客户端一样当做一个socket服务器。

想了解更通用的客户端socket接口，请看
stream_socket_client(),
stream_socket_server(),
fsockopen(), 和
pfsockopen()。

使用这些函数时请注意，虽然他们中有很多和C函数同名的，但声明却很可能不同。未避免混淆，请仔细阅读函数描述。

不熟悉socket编程的可以在Unix手册上找到很多有用的信息，网上也有很多C socket编程方面的教程，简单修改一下就可以应用于PHP socket编程。» Unix Socket FAQ是一个不错的入门。


安装

这里描述的socket函数只是PHP扩展的一部分，编译PHP时必须在配置中添加--enable-sockets配置项来启用。

Note: 在 PHP 5.0.0 开始加入了对 IPv6 的支持。


资源类型

socket_accept(),
socket_create_listen() 和
socket_create() 返回socket资源类型。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

AF_UNIX (integer)
AF_INET (integer)
AF_INET6 (integer)
只有在编译时加入 IPv6 支持的时候才有效。
SOCK_STREAM (integer)
SOCK_DGRAM (integer)
SOCK_RAW (integer)
SOCK_SEQPACKET (integer)
SOCK_RDM (integer)
MSG_OOB (integer)
MSG_WAITALL (integer)
MSG_PEEK (integer)
MSG_DONTROUTE (integer)
MSG_EOR (integer)
在 Windows 平台上无效。
MSG_EOF (integer)
在 Windows 平台上无效。
SO_DEBUG (integer)
SO_REUSEADDR (integer)
SO_REUSEPORT (integer)
该常量在PHP5.4.10及以上版本，并且支持SO_REUSEPORTsocket选项的平台上可用。包括Mac OS X和FreeBSD，不包括Linux和Windows。
SO_KEEPALIVE (integer)
SO_DONTROUTE (integer)
SO_LINGER (integer)
SO_BROADCAST (integer)
SO_OOBINLINE (integer)
SO_SNDBUF (integer)
SO_RCVBUF (integer)
SO_SNDLOWAT (integer)
SO_RCVLOWAT (integer)
SO_SNDTIMEO (integer)
SO_RCVTIMEO (integer)
SO_TYPE (integer)
SO_ERROR (integer)
TCP_NODELAY (integer)
Used to disable Nagle TCP algorithm. Added in PHP 5.2.7.
SOL_SOCKET (integer)
PHP_NORMAL_READ (integer)
PHP_BINARY_READ (integer)
SOL_TCP (integer)
SOL_UDP (integer)

以下常量在Windows和类UNIX平台上被定义。每个常量只有在平台上有该常量值的时候才会被定义。

SOCKET_EINTR (integer)
中断系统调用。
SOCKET_EBADF (integer)
坏文件编号。
SOCKET_EACCES (integer)
拒绝访问。
SOCKET_EFAULT (integer)
错误的地址。
SOCKET_EINVAL (integer)
无效的参数。
SOCKET_EMFILE (integer)
打开的文件太多。
SOCKET_ENAMETOOLONG (integer)
文件名过长。
SOCKET_ENOTEMPTY (integer)
目录不为空。
SOCKET_ELOOP (integer)
Too many symbolic links encountered.
SOCKET_EWOULDBLOCK (integer)
操作将阻塞。
SOCKET_EREMOTE (integer)
对象是远程。
SOCKET_EUSERS (integer)
太多用户。
SOCKET_ENOTSOCK (integer)
非socket套接字操作。
SOCKET_EDESTADDRREQ (integer)
需要目的地址。
SOCKET_EMSGSIZE (integer)
消息太长。
SOCKET_EPROTOTYPE (integer)
socket协议类型错误。
SOCKET_EPROTONOSUPPORT (integer)
不支持的协议。
SOCKET_ESOCKTNOSUPPORT (integer)
不支持的socket类型。
SOCKET_EOPNOTSUPP (integer)
传输断点不支持的操作。
SOCKET_EPFNOSUPPORT (integer)
不支持的协议族。
SOCKET_EAFNOSUPPORT (integer)
协议不支持的地址族。
SOCKET_EADDRNOTAVAIL (integer)
不能分配请求的地址。
SOCKET_ENETDOWN (integer)
网络出现故障。
SOCKET_ENETUNREACH (integer)
网络不可达。
SOCKET_ENETRESET (integer)
复位，网络掉线。
SOCKET_ECONNABORTED (integer)
软件导致连接中止。
SOCKET_ECONNRESET (integer)
对方重置连接。
SOCKET_ENOBUFS (integer)
无可用的缓存区空间。
SOCKET_EISCONN (integer)
传输端点已经连接。
SOCKET_ENOTCONN (integer)
传输端点未连接。
SOCKET_ESHUTDOWN (integer)
传输端点关闭，无法发送。
SOCKET_ETIMEDOUT (integer)
连接超时。
SOCKET_ECONNREFUSED (integer)
连接被拒绝。
SOCKET_EHOSTDOWN (integer)
主机已关闭。
SOCKET_EHOSTUNREACH (integer)
没有路由到主机。
SOCKET_EALREADY (integer)
操作已在进行中。
SOCKET_EINPROGRESS (integer)
操作正在进行中。

以下常量只能在windows中定义。

SOCKET_ENOPROTOOPT (integer)
SOCKET_EADDRINUSE (integer)
SOCKET_ETOOMYREFS (integer)
SOCKET_EPROCLIM (integer)
SOCKET_EDUOT (integer)
SOCKET_ESTALE (integer)
SOCKET_EDISCON (integer)
SOCKET_SYSNOTREADY (integer)
SOCKET_VERNOTSUPPORTED (integer)
SOCKET_NOTINITIALISED (integer)
SOCKET_HOST_NOT_FOUND (integer)
SOCKET_TRY_AGAIN (integer)
SOCKET_NO_RECOVERY (integer)
SOCKET_NO_DATA (integer)
SOCKET_NO_ADDRESS (integer)

以下常量仅适用于类UNIX。 每个常量只有在该平台上此值可用时被定义。

SOCKET_EPERM (integer)
操作不允许。
SOCKET_ENOENT (integer)
文件或目录不存在。
SOCKET_EIO (integer)
I/O错误。
SOCKET_ENXIO (integer)
未找到设备或地址。
SOCKET_E2BIG (integer)
参数列表太长。
SOCKET_EAGAIN (integer)
请重试。
SOCKET_ENOMEM (integer)
内存不足。
SOCKET_ENOTBLK (integer)
需要块设备。
SOCKET_EBUSY (integer)
设备或资源忙。
SOCKET_EEXIST (integer)
文件存在。
SOCKET_EXDEV (integer)
跨设备链路。
SOCKET_ENODEV (integer)
设备不存在。
SOCKET_ENOTDIR (integer)
非目录。
SOCKET_EISDIR (integer)
是目录。
SOCKET_ENFILE (integer)
文件表溢出。
SOCKET_ENOTTY (integer)
不是打字机。
SOCKET_ENOSPC (integer)
设备上没有剩余空间。
SOCKET_ESPIPE (integer)
非法查找。
SOCKET_EROFS (integer)
文件系统只读。
SOCKET_EMLINK (integer)
链路太多。
SOCKET_EPIPE (integer)
管道断开。
SOCKET_ENOLCK (integer)
无可用的记录锁。
SOCKET_ENOSYS (integer)
函数未实现。
SOCKET_ENOMSG (integer)
无需要类型的消息。
SOCKET_EIDRM (integer)
标识符被删除。
SOCKET_ECHRNG (integer)
通道数超出范围。
SOCKET_EL2NSYNC (integer)
2级未同步。
SOCKET_EL3HLT (integer)
3级停止。
SOCKET_EL3RST (integer)
3级重置。
SOCKET_ELNRNG (integer)
链接数超出范围。
SOCKET_EUNATCH (integer)
协议驱动没有安装。
SOCKET_ENOCSI (integer)
没有可用的CSI结构。
SOCKET_EL2HLT (integer)
2级停止。
SOCKET_EBADE (integer)
无效的交换。
SOCKET_EBADR (integer)
无效的请求描述符。
SOCKET_EXFULL (integer)
交换满了。
SOCKET_ENOANO (integer)
无阳极。
SOCKET_EBADRQC (integer)
无效的请求代码。
SOCKET_EBADSLT (integer)
无效的插槽。
SOCKET_ENOSTR (integer)
设备不是流。
SOCKET_ENODATA (integer)
无可用的数据。
SOCKET_ETIME (integer)
计时器过期。
SOCKET_ENOSR (integer)
流资源不够用。
SOCKET_ENONET (integer)
机器不在网络上。
SOCKET_ENOLINK (integer)
链接已被切断。
SOCKET_EADV (integer)
通知错误。
SOCKET_ESRMNT (integer)
Srmount错误。
SOCKET_ECOMM (integer)
发送时通信错误。
SOCKET_EPROTO (integer)
协议错误。
SOCKET_EMULTIHOP (integer)
多跳尝试。
SOCKET_EBADMSG (integer)
不是一个数据消息。
SOCKET_ENOTUNIQ (integer)
名称在网络上不唯一。
SOCKET_EBADFD (integer)
文件描述符处于错误状态。
SOCKET_EREMCHG (integer)
远程地址改变。
SOCKET_ERESTART (integer)
中断的系统调用应该被重新启动。
SOCKET_ESTRPIPE (integer)
流管道错误。
SOCKET_EPROTOOPT (integer)
协议不可用。
SOCKET_ADDRINUSE (integer)
地址已经被占用。
SOCKET_ETOOMANYREFS (integer)
过多的引用：无法接合。
SOCKET_EISNAM (integer)
是一个已命名类型的文件。
SOCKET_EREMOTEIO (integer)
远程I/O错误。
SOCKET_EDQUOT (integer)
超过配额。
SOCKET_ENOMEDIUM (integer)
未找到媒体。
SOCKET_EMEDIUMTYPE (integer)
错误的媒体类型。


范例

Example #1 Socket举例：简单的TCP/IP服务器

这个例子展示了一个简单的对讲服务器。改变地址和端口以满足你的设置和执行。 你可以使用类似于这样的命令：telnet 192.168.1.53 10000连接到服务器，（这里是你设置的地址和端口）。 你输入任何东西都会在服务器端输出来，然后回显给你。断开连接，请输入'quit'。

#!/usr/local/bin/php -q
<?php
error_reporting(E_ALL);

/* Allow the script to hang around waiting for connections. */
set_time_limit(0);

/* Turn on implicit output flushing so we see what we're getting
 * as it comes in. */
ob_implicit_flush();

$address = '192.168.1.53';
$port = 10000;

if (($sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP)) === false) {
    echo "socket_create() failed: reason: " . socket_strerror(socket_last_error()) . "\n";
}

if (socket_bind($sock, $address, $port) === false) {
    echo "socket_bind() failed: reason: " . socket_strerror(socket_last_error($sock)) . "\n";
}

if (socket_listen($sock, 5) === false) {
    echo "socket_listen() failed: reason: " . socket_strerror(socket_last_error($sock)) . "\n";
}

do {
    if (($msgsock = socket_accept($sock)) === false) {
        echo "socket_accept() failed: reason: " . socket_strerror(socket_last_error($sock)) . "\n";
        break;
    }
    /* Send instructions. */
    $msg = "\nWelcome to the PHP Test Server. \n" .
        "To quit, type 'quit'. To shut down the server type 'shutdown'.\n";
    socket_write($msgsock, $msg, strlen($msg));

    do {
        if (false === ($buf = socket_read($msgsock, 2048, PHP_NORMAL_READ))) {
            echo "socket_read() failed: reason: " . socket_strerror(socket_last_error($msgsock)) . "\n";
            break 2;
        }
        if (!$buf = trim($buf)) {
            continue;
        }
        if ($buf == 'quit') {
            break;
        }
        if ($buf == 'shutdown') {
            socket_close($msgsock);
            break 2;
        }
        $talkback = "PHP: You said '$buf'.\n";
        socket_write($msgsock, $talkback, strlen($talkback));
        echo "$buf\n";
    } while (true);
    socket_close($msgsock);
} while (true);

socket_close($sock);
?>

Example #2 Socket举例：简单的TCP/IP客户端

这个例子展示了一个简单的，一次性的HTTP客户端。 它只是连接到一个页面，提交一个HEAD请求，输出回复，然后退出。

<?php
error_reporting(E_ALL);

echo "<h2>TCP/IP Connection</h2>\n";

/* Get the port for the WWW service. */
$service_port = getservbyname('www', 'tcp');

/* Get the IP address for the target host. */
$address = gethostbyname('www.example.com');

/* Create a TCP/IP socket. */
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === false) {
    echo "socket_create() failed: reason: " . socket_strerror(socket_last_error()) . "\n";
} else {
    echo "OK.\n";
}

echo "Attempting to connect to '$address' on port '$service_port'...";
$result = socket_connect($socket, $address, $service_port);
if ($result === false) {
    echo "socket_connect() failed.\nReason: ($result) " . socket_strerror(socket_last_error($socket)) . "\n";
} else {
    echo "OK.\n";
}

$in = "HEAD / HTTP/1.1\r\n";
$in .= "Host: www.example.com\r\n";
$in .= "Connection: Close\r\n\r\n";
$out = '';

echo "Sending HTTP HEAD request...";
socket_write($socket, $in, strlen($in));
echo "OK.\n";

echo "Reading response:\n\n";
while ($out = socket_read($socket, 2048)) {
    echo $out;
}

echo "Closing socket...";
socket_close($socket);
echo "OK.\n\n";
?>


Socket Errors

Socket扩展编写的目的是提供一个面向功能强大的BSD Socket的可用的接口。它能确保这些函数在Win32和Unix平台上都能很好的工作。 在特定条件下，大部分socket函数如果发生错误都会发出一个 E_WARNING信息描述错误内容。有时可能并不会如开发者所愿。例如，因为连接突然中断， socket_read()函数可能会突然发出一个 E_WARNING。 通常会使用@操作符来压制异常，然后在程序中用socket_last_error()来捕获错误代码。 你可以调用socket_strerror()函数通过错误代码获取错误描述。查看函数描述获取更多信息。

Note:

Socket扩展发出的E_WARNING信息都是英文的，但获取到的错误描述会根据当前的locale展示。 (LC_MESSAGES):

Warning - socket_bind() unable to bind address [98]: Die Adresse wird bereits verwendet


Socket 函数

Table of Contents

  • socket_accept — Accepts a connection on a socket
  • socket_addrinfo_bind — Create and bind to a socket from a given addrinfo
  • socket_addrinfo_connect — Create and connect to a socket from a given addrinfo
  • socket_addrinfo_explain — Get information about addrinfo
  • socket_addrinfo_lookup — Get array with contents of getaddrinfo about the given hostname
  • socket_bind — 给套接字绑定名字
  • socket_clear_error — 清除套接字或者最后的错误代码上的错误
  • socket_close — 关闭套接字资源
  • socket_cmsg_space — Calculate message buffer size
  • socket_connect — 开启一个套接字连接
  • socket_create_listen — Opens a socket on port to accept connections
  • socket_create_pair — Creates a pair of indistinguishable sockets and stores them in an array
  • socket_create — 创建一个套接字（通讯节点）
  • socket_export_stream — Export a socket into a stream that encapsulates a socket
  • socket_get_option — Gets socket options for the socket
  • socket_getopt — 别名 socket_get_option
  • socket_getpeername — Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
  • socket_getsockname — Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
  • socket_import_stream — Import a stream
  • socket_last_error — Returns the last error on the socket
  • socket_listen — Listens for a connection on a socket
  • socket_read — Reads a maximum of length bytes from a socket
  • socket_recv — 从已连接的socket接收数据
  • socket_recvfrom — Receives data from a socket whether or not it is connection-oriented
  • socket_recvmsg — Read a message
  • socket_select — Runs the select() system call on the given arrays of sockets with a specified timeout
  • socket_send — Sends data to a connected socket
  • socket_sendmsg — Send a message
  • socket_sendto — Sends a message to a socket, whether it is connected or not
  • socket_set_block — Sets blocking mode on a socket
  • socket_set_nonblock — Sets nonblocking mode for file descriptor fd
  • socket_set_option — Sets socket options for the socket
  • socket_setopt — 别名 socket_set_option
  • socket_shutdown — Shuts down a socket for receiving, sending, or both
  • socket_strerror — Return a string describing a socket error
  • socket_write — Write to a socket
  • socket_wsaprotocol_info_export — Exports the WSAPROTOCOL_INFO Structure
  • socket_wsaprotocol_info_import — Imports a Socket from another Process
  • socket_wsaprotocol_info_release — Releases an exported WSAPROTOCOL_INFO Structure


Accepts a connection on a socket

  • ? Socket 函数
  • socket_addrinfo_bind ?
  • PHP Manual
  • Socket 函数
  • Accepts a connection on a socket

socket_accept

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_accept — Accepts a connection on a socket

说明

socket_accept ( Socket $socket ) : Socket|false

After the socket socket has been created using socket_create(), bound to a name with socket_bind(), and told to listen for connections with socket_listen(), this function will accept incoming connections on that socket. Once a successful connection is made, a new Socket instance is returned, which may be used for communication. If there are multiple connections queued on the socket, the first will be used. If there are no pending connections, socket_accept() will block until a connection becomes present. If socket has been made non-blocking using socket_set_blocking() or socket_set_nonblock(), false will be returned.

The Socket instance returned by socket_accept() may not be used to accept new connections. The original listening socket socket, however, remains open and may be reused.

参数

socket

A Socket instance created with socket_create().

返回值

Returns a new Socket instance on success, or false on error. The actual error code can be retrieved by calling socket_last_error(). This error code may be passed to socket_strerror() to get a textual explanation of the error.

更新日志

版本 | 说明
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.

参见

  • socket_connect() - 开启一个套接字连接
  • socket_listen() - Listens for a connection on a socket
  • socket_create() - 创建一个套接字（通讯节点）
  • socket_bind() - 给套接字绑定名字
  • socket_strerror() - Return a string describing a socket error


Create and bind to a socket from a given addrinfo

  • ? socket_accept
  • socket_addrinfo_connect ?
  • PHP Manual
  • Socket 函数
  • Create and bind to a socket from a given addrinfo

socket_addrinfo_bind

(PHP 7 >= 7.2.0, PHP 8)

socket_addrinfo_bind — Create and bind to a socket from a given addrinfo

说明

socket_addrinfo_bind ( AddressInfo $address ) : Socket|false

Create a Socket instance, and bind it to the provided AddressInfo. The return value of this function may be used with socket_listen().

参数

address

AddressInfo instance created from socket_addrinfo_lookup().

返回值

Returns a Socket instance on success or false on failure.

更新日志

版本 | 说明
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.
8.0.0 | address is an AddressInfo instance now; previously, it was a resource.

参见

  • socket_addrinfo_connect() - Create and connect to a socket from a given addrinfo
  • socket_addrinfo_explain() - Get information about addrinfo
  • socket_addrinfo_lookup() - Get array with contents of getaddrinfo about the given hostname
  • socket_listen() - Listens for a connection on a socket


Create and connect to a socket from a given addrinfo

  • ? socket_addrinfo_bind
  • socket_addrinfo_explain ?
  • PHP Manual
  • Socket 函数
  • Create and connect to a socket from a given addrinfo

socket_addrinfo_connect

(PHP 7 >= 7.2.0, PHP 8)

socket_addrinfo_connect — Create and connect to a socket from a given addrinfo

说明

socket_addrinfo_connect ( AddressInfo $address ) : Socket|false

Create a Socket instance, and connect it to the provided AddressInfo instance. The return value of this function may be used with the rest of the socket functions.

参数

address

AddressInfo instance created from socket_addrinfo_lookup()

返回值

Returns a Socket instance on success or false on failure.

更新日志

版本 | 说明
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.
8.0.0 | address is an AddressInfo instance now; previously, it was a resource.

参见

  • socket_addrinfo_bind() - Create and bind to a socket from a given addrinfo
  • socket_addrinfo_explain() - Get information about addrinfo
  • socket_addrinfo_lookup() - Get array with contents of getaddrinfo about the given hostname


Get information about addrinfo

  • ? socket_addrinfo_connect
  • socket_addrinfo_lookup ?
  • PHP Manual
  • Socket 函数
  • Get information about addrinfo

socket_addrinfo_explain

(PHP 7 >= 7.2.0, PHP 8)

socket_addrinfo_explain — Get information about addrinfo

说明

socket_addrinfo_explain ( AddressInfo $address ) : array

socket_addrinfo_explain() exposed the underlying addrinfo structure.

参数

address

AddressInfo instance created from socket_addrinfo_lookup()

返回值

Returns an array containing the fields in the addrinfo structure.

更新日志

版本 | 说明
8.0.0 | address is an AddressInfo instance now; previously, it was a resource.

参见

  • socket_addrinfo_bind() - Create and bind to a socket from a given addrinfo
  • socket_addrinfo_connect() - Create and connect to a socket from a given addrinfo
  • socket_addrinfo_lookup() - Get array with contents of getaddrinfo about the given hostname


Get array with contents of getaddrinfo about the given hostname

  • ? socket_addrinfo_explain
  • socket_bind ?
  • PHP Manual
  • Socket 函数
  • Get array with contents of getaddrinfo about the given hostname

socket_addrinfo_lookup

(PHP 7 >= 7.2.0, PHP 8)

socket_addrinfo_lookup — Get array with contents of getaddrinfo about the given hostname

说明

socket_addrinfo_lookup ( string $host , string|null $service = null , array $hints = [] ) : array|false

Lookup different ways we can connect to host. The returned array contains a set of AddressInfo instances that we can bind to using socket_addrinfo_bind().

参数

host

Hostname to search.

service

The service to connect to. If service is a name, it is translated to the corresponding port number.

hints

Hints provide criteria for selecting addresses returned. You may specify the hints as defined by getadrinfo.

返回值

Returns an array of AddressInfo instances that can be used with the other socket_addrinfo functions. On failure, false is returned.

更新日志

版本 | 说明
8.0.0 | On success, this function returns a array of AddressInfo instances now; previously, an array of resources was returned.
8.0.0 | service is nullable now.

参见

  • socket_addrinfo_bind() - Create and bind to a socket from a given addrinfo
  • socket_addrinfo_connect() - Create and connect to a socket from a given addrinfo
  • socket_addrinfo_explain() - Get information about addrinfo


给套接字绑定名字

  • ? socket_addrinfo_lookup
  • socket_clear_error ?
  • PHP Manual
  • Socket 函数
  • 给套接字绑定名字

socket_bind

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_bind — 给套接字绑定名字

说明

socket_bind ( resource $socket , string $address , int $port = 0 ) : bool

绑定 address 到 socket。 该操作必须是在使用 socket_connect() 或者 socket_listen() 建立一个连接之前。

参数

socket

用 socket_create() 创建的一个有效的套接字资源。

address

如果套接字是 AF_INET 族，那么 address 必须是一个四点分法的 IP 地址（例如 127.0.0.1 ）。

如果套接字是 AF_UNIX 族，那么 address 是 Unix 套接字一部分（例如 /tmp/my.sock ）。

port （可选）

参数 port 仅仅用于 AF_INET 套接字连接的时候，并且指定连接中需要监听的端口号。

返回值

成功时返回 true， 或者在失败时返回 false。

错误代码会传入 socket_last_error() ，如果将此参数传入 socket_strerror() 则可以得到错误的文字说明。

范例

Example #1 使用 socket_bind() 来设置套接字资源地址

<?php
// Create a new socket
$sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

// An example list of IP addresses owned by the computer
$sourceips['kevin']    = '127.0.0.1';
$sourceips['madcoder'] = '127.0.0.2';

// Bind the source address
socket_bind($sock, $sourceips['madcoder']);

// Connect to destination address
socket_connect($sock, '127.0.0.1', 80);

// Write
$request = 'GET / HTTP/1.1' . "\r\n" .
           'Host: example.com' . "\r\n\r\n";
socket_write($sock, $request);

// Close
socket_close($sock);

?>

注释

Note:

该函数必须在 socket_connect() 之前使用。

Note:

Windows 9x/ME 兼容性注意点: 如果尝试绑定套接字资源到一个错误的地址，而这个地址不是本机的地址，那么 socket_last_error() 可能会返回一个无效的错误代码。

参见

  • socket_connect() - 开启一个套接字连接
  • socket_listen() - Listens for a connection on a socket
  • socket_create() - 创建一个套接字（通讯节点）
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


清除套接字或者最后的错误代码上的错误

  • ? socket_bind
  • socket_close ?
  • PHP Manual
  • Socket 函数
  • 清除套接字或者最后的错误代码上的错误

socket_clear_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

socket_clear_error — 清除套接字或者最后的错误代码上的错误

说明

socket_clear_error ( resource $socket = ? ) : void

这个函数清除给定的套接字上的错误代码或是最后一个全局的套接字如果套接字没有指定的话

这个函数允许明确的重置错误代码值 不论是一个套接字或者最后全局错误代码的扩展， 这对在检测应用的一部分是否有错误发生是十分有用的

参数

socket

用socket_create()创建的有效的套接字资源。

返回值

没有返回值。

参见

  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


关闭套接字资源

  • ? socket_clear_error
  • socket_cmsg_space ?
  • PHP Manual
  • Socket 函数
  • 关闭套接字资源

socket_close

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_close — 关闭套接字资源

说明

socket_close ( resource $socket ) : void

socket_close() 会关闭掉给定的 socket 资源。 这个函数只针对套接字资源有效，不能用在其他类型的资源类型上。

参数

socket

由 socket_create() 或者是 socket_accept() 创建的有效的套接字资源。

返回值

没有返回值。

参见

  • socket_bind() - 给套接字绑定名字
  • socket_listen() - Listens for a connection on a socket
  • socket_create() - 创建一个套接字（通讯节点）
  • socket_strerror() - Return a string describing a socket error


Calculate message buffer size

  • ? socket_close
  • socket_connect ?
  • PHP Manual
  • Socket 函数
  • Calculate message buffer size

socket_cmsg_space

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

socket_cmsg_space — Calculate message buffer size

说明

socket_cmsg_space ( int $level , int $type , int $num = 0 ) : int|null

Calculates the size of the buffer that should be allocated for receiving the ancillary data.

Warning

本函数还未编写文档，仅有参数列表。

参数

level

type

返回值

参见

  • socket_recvmsg() - Read a message
  • socket_sendmsg() - Send a message


开启一个套接字连接

  • ? socket_cmsg_space
  • socket_create_listen ?
  • PHP Manual
  • Socket 函数
  • 开启一个套接字连接

socket_connect

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_connect — 开启一个套接字连接

说明

socket_connect ( Socket $socket , string $address , int|null $port = null ) : bool

使用 Socket 实例 socket 发起到 address 的连接，该实例必须要求是用 socket_create() 创建的 Socket 有效的套接字资源实例。

参数

socket

由 socket_create() 创建的 Socket 实例。

address

如果参数 socket 是 AF_INET，那么参数 address 则可以是一个点分四组表示法（例如 127.0.0.1 ） 的 IPv4 地址；如果支持 IPv6 并且 socket 是 AF_INET6，那么 address 也可以是有效的 IPv6 地址（例如 ::1）；如果套接字类型为 AF_UNIX ，那么 address 也可以是一个 Unix 套接字。

port

参数 port 仅仅用于 AF_INET 和 AF_INET6 套接字连接的时候，并且是在此情况下是需要强制说明连接对应的远程服务器上的端口号。

返回值

成功时返回 true， 或者在失败时返回 false。 错误代码会传入 socket_last_error() ，如果将此参数传入 socket_strerror() 则可以得到错误的文字说明。

Note:

If the socket is non-blocking then this function returns false with an error Operation now in progress.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.
8.0.0 | port 允许为空。

参见

  • socket_bind() - 给套接字绑定名字
  • socket_listen() - Listens for a connection on a socket
  • socket_create() - 创建一个套接字（通讯节点）
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


Opens a socket on port to accept connections

  • ? socket_connect
  • socket_create_pair ?
  • PHP Manual
  • Socket 函数
  • Opens a socket on port to accept connections

socket_create_listen

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_create_listen — Opens a socket on port to accept connections

说明

socket_create_listen ( int $port , int $backlog = 128 ) : Socket|false

socket_create_listen() creates a new Socket instance of type AF_INET listening on all local interfaces on the given port waiting for new connections.

This function is meant to ease the task of creating a new socket which only listens to accept new connections.

参数

port

The port on which to listen on all interfaces.

backlog

The backlog parameter defines the maximum length the queue of pending connections may grow to. SOMAXCONN may be passed as backlog parameter, see socket_listen() for more information.

返回值

socket_create_listen() returns a new Socket instance on success or false on error. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

注释

Note:

If you want to create a socket which only listens on a certain interface you need to use socket_create(), socket_bind() and socket_listen().

更新日志

版本 | 说明
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.

参见

  • socket_create() - 创建一个套接字（通讯节点）
  • socket_create_pair() - Creates a pair of indistinguishable sockets and stores them in an array
  • socket_bind() - 给套接字绑定名字
  • socket_listen() - Listens for a connection on a socket
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


Creates a pair of indistinguishable sockets and stores them in an array

  • ? socket_create_listen
  • socket_create ?
  • PHP Manual
  • Socket 函数
  • Creates a pair of indistinguishable sockets and stores them in an array

socket_create_pair

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_create_pair — Creates a pair of indistinguishable sockets and stores them in an array

说明

socket_create_pair ( int $domain , int $type , int $protocol , array &$pair ) : bool

socket_create_pair() creates two connected and indistinguishable sockets, and stores them in pair. This function is commonly used in IPC (InterProcess Communication).

参数

domain

The domain parameter specifies the protocol family to be used by the socket. See socket_create() for the full list.

type

The type parameter selects the type of communication to be used by the socket. See socket_create() for the full list.

protocol

The protocol parameter sets the specific protocol within the specified domain to be used when communicating on the returned socket. The proper value can be retrieved by name by using getprotobyname(). If the desired protocol is TCP, or UDP the corresponding constants SOL_TCP, and SOL_UDP can also be used.

See socket_create() for the full list of supported protocols.

pair

Reference to an array in which the two Socket instances will be inserted.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | pair is a reference to an array of Socket instances now; previously, it was a reference to an array of resources.

范例

Example #1 socket_create_pair() example

<?php
$sockets = array();

/* On Windows we need to use AF_INET */
$domain = (strtoupper(substr(PHP_OS, 0, 3)) == 'WIN' ? AF_INET : AF_UNIX);

/* Setup socket pair */
if (socket_create_pair($domain, SOCK_STREAM, 0, $sockets) === false) {
    echo "socket_create_pair failed. Reason: ".socket_strerror(socket_last_error());
}
/* Send and Receive Data */
if (socket_write($sockets[0], "ABCdef123\n", strlen("ABCdef123\n")) === false) {
    echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($sockets[0]));
}
if (($data = socket_read($sockets[1], strlen("ABCdef123\n"), PHP_BINARY_READ)) === false) {
    echo "socket_read() failed. Reason: ".socket_strerror(socket_last_error($sockets[1]));
}
var_dump($data);

/* Close sockets */
socket_close($sockets[0]);
socket_close($sockets[1]);
?>

Example #2 socket_create_pair() IPC example

<?php
$ary = array();
$strone = 'Message From Parent.';
$strtwo = 'Message From Child.';

if (socket_create_pair(AF_UNIX, SOCK_STREAM, 0, $ary) === false) {
    echo "socket_create_pair() failed. Reason: ".socket_strerror(socket_last_error());
}
$pid = pcntl_fork();
if ($pid == -1) {
    echo 'Could not fork Process.';
} elseif ($pid) {
    /*parent*/
    socket_close($ary[0]);
    if (socket_write($ary[1], $strone, strlen($strone)) === false) {
        echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($ary[1]));
    }
    if (socket_read($ary[1], strlen($strtwo), PHP_BINARY_READ) == $strtwo) {
        echo "Received $strtwo\n";
    }
    socket_close($ary[1]);
} else {
    /*child*/
    socket_close($ary[1]);
    if (socket_write($ary[0], $strtwo, strlen($strtwo)) === false) {
        echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($ary[0]));
    }
    if (socket_read($ary[0], strlen($strone), PHP_BINARY_READ) == $strone) {
        echo "Received $strone\n";
    }
    socket_close($ary[0]);
}
?>

参见

  • socket_create() - 创建一个套接字（通讯节点）
  • socket_create_listen() - Opens a socket on port to accept connections
  • socket_bind() - 给套接字绑定名字
  • socket_listen() - Listens for a connection on a socket
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


创建一个套接字（通讯节点）

  • ? socket_create_pair
  • socket_export_stream ?
  • PHP Manual
  • Socket 函数
  • 创建一个套接字（通讯节点）

socket_create

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_create — 创建一个套接字（通讯节点）

说明

socket_create ( int $domain , int $type , int $protocol ) : resource

创建并返回一个套接字，也称作一个通讯节点。一个典型的网络连接由 2 个套接字构成，一个运行在客户端，另一个运行在服务器端。

参数

domain

domain 参数指定哪个协议用在当前套接字上。

可用的地址/协议
Domain | 描述
AF_INET | IPv4 网络协议。TCP 和 UDP 都可使用此协议。
AF_INET6 | IPv6 网络协议。TCP 和 UDP 都可使用此协议。
AF_UNIX | 本地通讯协议。具有高性能和低成本的 IPC（进程间通讯）。
type

type 参数用于选择套接字使用的类型。

可用的套接字类型
类型 | 描述
SOCK_STREAM | 提供一个顺序化的、可靠的、全双工的、基于连接的字节流。支持数据传送流量控制机制。TCP 协议即基于这种流式套接字。
SOCK_DGRAM | 提供数据报文的支持。(无连接，不可靠、固定最大长度).UDP协议即基于这种数据报文套接字。
SOCK_SEQPACKET | 提供一个顺序化的、可靠的、全双工的、面向连接的、固定最大长度的数据通信；数据端通过接收每一个数据段来读取整个数据包。
SOCK_RAW | 提供读取原始的网络协议。这种特殊的套接字可用于手工构建任意类型的协议。一般使用这个套接字来实现 ICMP 请求（例如 ping）。
SOCK_RDM | 提供一个可靠的数据层，但不保证到达顺序。一般的操作系统都未实现此功能。
protocol

protocol 参数，是设置指定 domain 套接字下的具体协议。这个值可以使用 getprotobyname() 函数进行读取。如果所需的协议是 TCP 或 UDP，可以直接使用常量 SOL_TCP 和 SOL_UDP 。

常见协议
名称 | 描述
icmp | Internet Control Message Protocol 主要用于网关和主机报告错误的数据通信。例如"ping"命令（在目前大部分的操作系统中）就是使用 ICMP 协议实现的。
udp | User Datagram Protocol 是一个无连接的、不可靠的、具有固定最大长度的报文协议。由于这些特性，UDP 协议拥有最小的协议开销。
tcp | Transmission Control Protocol 是一个可靠的、基于连接的、面向数据流的全双工协议。TCP 能够保障所有的数据包是按照其发送顺序而接收的。如果任意数据包在通讯时丢失，TCP 将自动重发数据包直到目标主机应答已接收。因为可靠性和性能的原因，TCP 在数据传输层使用 8bit 字节边界。因此，TCP 应用程序必须允许传送部分报文的可能。

返回值

socket_create() 正确时返回一个套接字，失败时返回 false。要读取错误代码，可以调用 socket_last_error()。这个错误代码可以通过 socket_strerror() 读取文字的错误说明。

更新日志

版本 | 说明
5.0.0 | 增加 AF_INET6 支持。

错误／异常

如果使用一个无效的 domain 或 type，socket_create() 会使用 AF_INET 和 SOCK_STREAM 替代无效参数，同时会发出 E_WARNING 警告信息。

参见

  • socket_accept() - Accepts a connection on a socket
  • socket_bind() - 给套接字绑定名字
  • socket_connect() - 开启一个套接字连接
  • socket_listen() - Listens for a connection on a socket
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


Export a socket into a stream that encapsulates a socket

  • ? socket_create
  • socket_get_option ?
  • PHP Manual
  • Socket 函数
  • Export a socket into a stream that encapsulates a socket

socket_export_stream

(PHP 7 >= 7.0.7, PHP 8)

socket_export_stream — Export a socket into a stream that encapsulates a socket

说明

socket_export_stream ( Socket $socket ) : resource|false

Warning

本函数还未编写文档，仅有参数列表。

参数

socket

返回值

Return resource 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.


Gets socket options for the socket

  • ? socket_export_stream
  • socket_getopt ?
  • PHP Manual
  • Socket 函数
  • Gets socket options for the socket

socket_get_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

socket_get_option — Gets socket options for the socket

说明

socket_get_option ( Socket $socket , int $level , int $option ) : array|int|false

The socket_get_option() function retrieves the value for the option specified by the option parameter for the specified socket.

参数

socket

A Socket instance created with socket_create() or socket_accept().

level

The level parameter specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function.

option
Available Socket Options
Option | Description | Type
SO_DEBUG | Reports whether debugging information is being recorded. | int
SO_BROADCAST | Reports whether transmission of broadcast messages is supported. | int
SO_REUSEADDR | Reports whether local addresses can be reused. | int
SO_REUSEPORT | Reports whether local ports can be reused. | int
SO_KEEPALIVE | Reports whether connections are kept active with periodic transmission of messages. If the connected socket fails to respond to these messages, the connection is broken and processes writing to that socket are notified with a SIGPIPE signal. | int
SO_LINGER

Reports whether the socket lingers on socket_close() if data is present. By default, when the socket is closed, it attempts to send all unsent data. In the case of a connection-oriented socket, socket_close() will wait for its peer to acknowledge the data.

If l_onoff is non-zero and l_linger is zero, all the unsent data will be discarded and RST (reset) is sent to the peer in the case of a connection-oriented socket.

On the other hand, if l_onoff is non-zero and l_linger is non-zero, socket_close() will block until all the data is sent or the time specified in l_linger elapses. If the socket is non-blocking, socket_close() will fail and return an error.

array. The array will contain two keys: l_onoff and l_linger.
SO_OOBINLINE | Reports whether the socket leaves out-of-band data inline. | int
SO_SNDBUF | Reports the size of the send buffer. | int
SO_RCVBUF | Reports the size of the receive buffer. | int
SO_ERROR | Reports information about error status and clears it. | int (cannot be set by socket_set_option())
SO_TYPE | Reports the socket type (e.g. SOCK_STREAM). | int (cannot be set by socket_set_option())
SO_DONTROUTE | Reports whether outgoing messages bypass the standard routing facilities. | int
SO_RCVLOWAT | Reports the minimum number of bytes to process for socket input operations. | int
SO_RCVTIMEO | Reports the timeout value for input operations. | array. The array will contain two keys: sec which is the seconds part on the timeout value and usec which is the microsecond part of the timeout value.
SO_SNDTIMEO | Reports the timeout value specifying the amount of time that an output function blocks because flow control prevents data from being sent. | array. The array will contain two keys: sec which is the seconds part on the timeout value and usec which is the microsecond part of the timeout value.
SO_SNDLOWAT | Reports the minimum number of bytes to process for socket output operations. | int
TCP_NODELAY | Reports whether the Nagle TCP algorithm is disabled. | int
MCAST_JOIN_GROUP | Joins a multicast group. (added in PHP 5.4) | array with keys "group", specifying a string with an IPv4 or IPv6 multicast address and "interface", specifying either an interface number (type int) or a string with the interface name, like "eth0". 0 can be specified to indicate the interface should be selected using routing rules. (can only be used in socket_set_option())
MCAST_LEAVE_GROUP | Leaves a multicast group. (added in PHP 5.4) | array. See MCAST_JOIN_GROUP for more information. (can only be used in socket_set_option())
MCAST_BLOCK_SOURCE | Blocks packets arriving from a specific source to a specific multicast group, which must have been previously joined. (added in PHP 5.4) | array with the same keys as MCAST_JOIN_GROUP, plus one extra key, source, which maps to a string specifying an IPv4 or IPv6 address of the source to be blocked. (can only be used in socket_set_option())
MCAST_UNBLOCK_SOURCE | Unblocks (start receiving again) packets arriving from a specific source address to a specific multicast group, which must have been previously joined. (added in PHP 5.4) | array with the same format as MCAST_BLOCK_SOURCE. (can only be used in socket_set_option())
MCAST_JOIN_SOURCE_GROUP | Receive packets destined to a specific multicast group whose source address matches a specific value. (added in PHP 5.4) | array with the same format as MCAST_BLOCK_SOURCE. (can only be used in socket_set_option())
MCAST_LEAVE_SOURCE_GROUP | Stop receiving packets destined to a specific multicast group whose source address matches a specific value. (added in PHP 5.4) | array with the same format as MCAST_BLOCK_SOURCE. (can only be used in socket_set_option())
IP_MULTICAST_IF | The outgoing interface for IPv4 multicast packets. (added in PHP 5.4) | Either int specifying the interface number or a string with an interface name, like eth0. The value 0 can be used to indicate the routing table is to used in the interface selection. The function socket_get_option() returns an interface index. Note that, unlike the C API, this option does NOT take an IP address. This eliminates the interface difference between IP_MULTICAST_IF and IPV6_MULTICAST_IF.
IPV6_MULTICAST_IF | The outgoing interface for IPv6 multicast packets. (added in PHP 5.4) | The same as IP_MULTICAST_IF.
IP_MULTICAST_LOOP | The multicast loopback policy for IPv4 packets, which determines whether multicast packets sent by this socket also reach receivers in the same host that have joined the same multicast group on the outgoing interface used by this socket. This is the case by default. (added in PHP 5.4) | int (either 0 or 1). For socket_set_option() any value will be accepted and will be converted to a boolean following the usual PHP rules.
IPV6_MULTICAST_LOOP | Analogous to IP_MULTICAST_LOOP, but for IPv6. (added in PHP 5.4) | int. See IP_MULTICAST_LOOP.
IP_MULTICAST_TTL | The time-to-live of outgoing IPv4 multicast packets. This should be a value between 0 (don't leave the interface) and 255. The default value is 1 (only the local network is reached). (added in PHP 5.4) | int between 0 and 255.
IPV6_MULTICAST_HOPS | Analogous to IP_MULTICAST_TTL, but for IPv6 packets. The value -1 is also accepted, meaning the route default should be used. (added in PHP 5.4) | int between -1 and 255.

返回值

Returns the value of the given option, or false on errors.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

范例

Example #1 socket_get_option() example

<?php
$socket = socket_create_listen(1223);

$linger = array('l_linger' => 1, 'l_onoff' => 1);
socket_set_option($socket, SOL_SOCKET, SO_LINGER, $linger);

var_dump(socket_get_option($socket, SOL_SOCKET, SO_REUSEADDR));
?>

参见

  • socket_create_listen() - Opens a socket on port to accept connections
  • socket_set_option() - Sets socket options for the socket


别名 socket_get_option

  • ? socket_get_option
  • socket_getpeername ?
  • PHP Manual
  • Socket 函数
  • 别名 socket_get_option

socket_getopt

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_getopt — 别名 socket_get_option()

说明

此函数是该函数的别名： socket_get_option().


Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type

  • ? socket_getopt
  • socket_getsockname ?
  • PHP Manual
  • Socket 函数
  • Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type

socket_getpeername

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_getpeername — Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type

说明

socket_getpeername ( Socket $socket , string &$address , int &$port = null ) : bool

Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type.

参数

socket

A Socket instance created with socket_create() or socket_accept().

address

If the given socket is of type AF_INET or AF_INET6, socket_getpeername() will return the peers (remote) IP address in appropriate notation (e.g. 127.0.0.1 or fe80::1) in the address parameter and, if the optional port parameter is present, also the associated port.

If the given socket is of type AF_UNIX, socket_getpeername() will return the Unix filesystem path (e.g. /var/run/daemon.sock) in the address parameter.

port

If given, this will hold the port associated to address.

返回值

成功时返回 true， 或者在失败时返回 false。 socket_getpeername() may also return false if the socket type is not any of AF_INET, AF_INET6, or AF_UNIX, in which case the last socket error code is not updated.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

注释

Note:

socket_getpeername() should not be used with AF_UNIX sockets created with socket_accept(). Only sockets created with socket_connect() or a primary server socket following a call to socket_bind() will return meaningful values.

Note:

For having socket_getpeername() to return a meaningful value, the socket it is applied upon must of course be one for which the concept of "peer" makes sense.

参见

  • socket_getsockname() - Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type

  • ? socket_getpeername
  • socket_import_stream ?
  • PHP Manual
  • Socket 函数
  • Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type

socket_getsockname

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_getsockname — Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type

说明

socket_getsockname ( Socket $socket , string &$address , int &$port = null ) : bool

Note: socket_getsockname() should not be used with AF_UNIX sockets created with socket_connect(). Only sockets created with socket_accept() or a primary server socket following a call to socket_bind() will return meaningful values.

参数

socket

A Socket instance created with socket_create() or socket_accept().

address

If the given socket is of type AF_INET or AF_INET6, socket_getsockname() will return the local IP address in appropriate notation (e.g. 127.0.0.1 or fe80::1) in the address parameter and, if the optional port parameter is present, also the associated port.

If the given socket is of type AF_UNIX, socket_getsockname() will return the Unix filesystem path (e.g. /var/run/daemon.sock) in the address parameter.

port

If provided, this will hold the associated port.

返回值

成功时返回 true， 或者在失败时返回 false。 socket_getsockname() may also return false if the socket type is not any of AF_INET, AF_INET6, or AF_UNIX, in which case the last socket error code is not updated.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

参见

  • socket_getpeername() - Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


Import a stream

  • ? socket_getsockname
  • socket_last_error ?
  • PHP Manual
  • Socket 函数
  • Import a stream

socket_import_stream

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

socket_import_stream — Import a stream

说明

socket_import_stream ( resource $stream ) : Socket|false

Imports a stream that encapsulates a socket into a socket extension resource.

参数

stream

The stream resource to import.

返回值

Returns false on failure.

更新日志

版本 | 说明
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.

范例

Example #1 socket_import_stream() example

<?php
$stream = stream_socket_server("udp://0.0.0.0:58380", $errno, $errstr, STREAM_SERVER_BIND);
$sock   = socket_import_stream($stream);
?>

参见

  • stream_socket_server() - Create an Internet or Unix domain server socket


Returns the last error on the socket

  • ? socket_import_stream
  • socket_listen ?
  • PHP Manual
  • Socket 函数
  • Returns the last error on the socket

socket_last_error

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_last_error — Returns the last error on the socket

说明

socket_last_error ( Socket|null $socket = null ) : int

If a Socket instance is passed to this function, the last error which occurred on this particular socket is returned. If socket is null, the error code of the last failed socket function is returned. The latter is particularly helpful for functions like socket_create() which don't return a socket on failure and socket_select() which can fail for reasons not directly tied to a particular socket. The error code is suitable to be fed to socket_strerror() which returns a string describing the given error code.

If no error had occurred, or the error had been cleared with socket_clear_error(), the function returns 0.

参数

socket

A Socket instance created with socket_create().

返回值

This function returns a socket error code.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.
8.0.0 | socket is nullable now.

范例

Example #1 socket_last_error() example

<?php
$socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if ($socket === false) {
    $errorcode = socket_last_error();
    $errormsg = socket_strerror($errorcode);

    die("Couldn't create socket: [$errorcode] $errormsg");
}
?>

注释

Note:

socket_last_error() does not clear the error code, use socket_clear_error() for this purpose.


Listens for a connection on a socket

  • ? socket_last_error
  • socket_read ?
  • PHP Manual
  • Socket 函数
  • Listens for a connection on a socket

socket_listen

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_listen — Listens for a connection on a socket

说明

socket_listen ( Socket $socket , int $backlog = 0 ) : bool

After the socket socket has been created using socket_create() and bound to a name with socket_bind(), it may be told to listen for incoming connections on socket.

socket_listen() is applicable only to sockets of type SOCK_STREAM or SOCK_SEQPACKET.

参数

socket

A Socket instance created with socket_create() or socket_addrinfo_bind()

backlog

A maximum of backlog incoming connections will be queued for processing. If a connection request arrives with the queue full the client may receive an error with an indication of ECONNREFUSED, or, if the underlying protocol supports retransmission, the request may be ignored so that retries may succeed.

Note:

The maximum number passed to the backlog parameter highly depends on the underlying platform. On Linux, it is silently truncated to SOMAXCONN. On win32, if passed SOMAXCONN, the underlying service provider responsible for the socket will set the backlog to a maximum reasonable value. There is no standard provision to find out the actual backlog value on this platform.

返回值

成功时返回 true， 或者在失败时返回 false。 The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

参见

  • socket_accept() - Accepts a connection on a socket
  • socket_bind() - 给套接字绑定名字
  • socket_connect() - 开启一个套接字连接
  • socket_create() - 创建一个套接字（通讯节点）
  • socket_strerror() - Return a string describing a socket error
  • socket_addrinfo_bind() - Create and bind to a socket from a given addrinfo


Reads a maximum of length bytes from a socket

  • ? socket_listen
  • socket_recv ?
  • PHP Manual
  • Socket 函数
  • Reads a maximum of length bytes from a socket

socket_read

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_read — Reads a maximum of length bytes from a socket

说明

socket_read ( Socket $socket , int $length , int $mode = PHP_BINARY_READ ) : string|false

The function socket_read() reads from the Socket instance socket created by the socket_create() or socket_accept() functions.

参数

socket

A Socket instance created with socket_create() or socket_accept().

length

The maximum number of bytes read is specified by the length parameter. Otherwise you can use \r, \n, or \0 to end reading (depending on the mode parameter, see below).

mode

Optional mode parameter is a named constant:

  • PHP_BINARY_READ (Default) - use the system recv() function. Safe for reading binary data.
  • PHP_NORMAL_READ - reading stops at \n or \r.

返回值

socket_read() returns the data as a string on success, or false on error (including if the remote host has closed the connection). The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual representation of the error.

Note:

socket_read() returns a zero length string ("") when there is no more data to read.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

参见

  • socket_accept() - Accepts a connection on a socket
  • socket_bind() - 给套接字绑定名字
  • socket_connect() - 开启一个套接字连接
  • socket_listen() - Listens for a connection on a socket
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error
  • socket_write() - Write to a socket


从已连接的socket接收数据

  • ? socket_read
  • socket_recvfrom ?
  • PHP Manual
  • Socket 函数
  • 从已连接的socket接收数据

socket_recv

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_recv — 从已连接的socket接收数据

说明

socket_recv ( resource $socket , string &$buf , int $len , int $flags ) : int

函数 socket_recv() 从 socket 中接受长度为 len 字节的数据，并保存在 buf 中。 socket_recv() 用于从已连接的socket中接收数据。除此之外，可以设定一个或多个 flags 来控制函数的具体行为。

buf 以引用形式传递，因此必须是一个以声明的有效的变量。从 socket 中接收到的数据将会保存在 buf 中。

参数

socket

参数 socket 必须是一个由 socket_create() 创建的socket资源。

buf

从socket中获取的数据将被保存在由 buf 制定的变量中。 如果有错误发生，如链接被重置，数据不可用等等， buf 将被设为 null。

len

长度最多为 len 字节的数据将被接收。

flags

flags 的值可以为下列任意flag的组合。使用按位或运算符(|)来 组合不同的flag。

可用的 flags 值
Flag | 描述
MSG_OOB | 处理超出边界的数据
MSG_PEEK | 从接受队列的起始位置接收数据，但不将他们从接受队列中移除。
MSG_WAITALL | 在接收到至少 len 字节的数据之前，造成一个阻塞，并暂停脚本运行（block）。但是， 如果接收到中断信号，或远程服务器断开连接，该函数将返回少于 len 字节的数据。
MSG_DONTWAIT | 如果制定了该flag，函数将不会造成阻塞，即使在全局设置中指定了阻塞设置。

返回值

socket_recv() 返回一个数字，表示接收到的字节数。如果发生了错误，则返回 false 错误码可使用 socket_last_error() 接收。也可使用函数 socket_strerror() 来取得关于错误的文字描述。

范例

Example #1 socket_recv() 范例

该范例简单地使用 socket_recv() 重写了 范例 中的 第一个例子。

<?php
error_reporting(E_ALL);

echo "<h2>TCP/IP Connection</h2>\n";

/* Get the port for the WWW service. */
$service_port = getservbyname('www', 'tcp');

/* Get the IP address for the target host. */
$address = gethostbyname('www.example.com');

/* Create a TCP/IP socket. */
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === false) {
    echo "socket_create() failed: reason: " . socket_strerror(socket_last_error()) . "\n";
} else {
    echo "OK.\n";
}

echo "Attempting to connect to '$address' on port '$service_port'...";
$result = socket_connect($socket, $address, $service_port);
if ($result === false) {
    echo "socket_connect() failed.\nReason: ($result) " . socket_strerror(socket_last_error($socket)) . "\n";
} else {
    echo "OK.\n";
}

$in = "HEAD / HTTP/1.1\r\n";
$in .= "Host: www.example.com\r\n";
$in .= "Connection: Close\r\n\r\n";
$out = '';

echo "Sending HTTP HEAD request...";
socket_write($socket, $in, strlen($in));
echo "OK.\n";

echo "Reading response:\n\n";
$buf = 'This is my buffer.';
if (false !== ($bytes = socket_recv($socket, $buf, 2048, MSG_WAITALL))) {
    echo "Read $bytes bytes from socket_recv(). Closing socket...";
} else {
    echo "socket_recv() failed; reason: " . socket_strerror(socket_last_error($socket)) . "\n";
}
socket_close($socket);

echo $buf . "\n";
echo "OK.\n\n";
?>

The above example will produce something like:

<h2>TCP/IP Connection</h2>
OK.
Attempting to connect to '208.77.188.166' on port '80'...OK.
Sending HTTP HEAD request...OK.
Reading response:

Read 123 bytes from socket_recv(). Closing socket...HTTP/1.1 200 OK
Date: Mon, 14 Sep 2009 08:56:36 GMT
Server: Apache/2.2.3 (Red Hat)
Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT
ETag: "b80f4-1b6-80bfd280"
Accept-Ranges: bytes
Content-Length: 438
Connection: close
Content-Type: text/html; CHARSET=gb2312

OK.


Receives data from a socket whether or not it is connection-oriented

  • ? socket_recv
  • socket_recvmsg ?
  • PHP Manual
  • Socket 函数
  • Receives data from a socket whether or not it is connection-oriented

socket_recvfrom

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_recvfrom — Receives data from a socket whether or not it is connection-oriented

说明

socket_recvfrom ( Socket $socket , string &$data , int $length , int $flags , string &$address , int &$port = null ) : int|false

The socket_recvfrom() function receives length bytes of data in data from address on port port (if the socket is not of type AF_UNIX) using socket. socket_recvfrom() can be used to gather data from both connected and unconnected sockets. Additionally, one or more flags can be specified to modify the behaviour of the function.

The address and port must be passed by reference. If the socket is not connection-oriented, address will be set to the internet protocol address of the remote host or the path to the UNIX socket. If the socket is connection-oriented, address is null. Additionally, the port will contain the port of the remote host in the case of an unconnected AF_INET or AF_INET6 socket.

Note: 此函数可安全用于二进制对象。

参数

socket

The socket must be a Socket instance previously created by socket_create().

data

The data received will be fetched to the variable specified with data.

length

Up to length bytes will be fetched from remote host.

flags

The value of flags can be any combination of the following flags, joined with the binary OR (|) operator.

Possible values for flags
Flag | Description
MSG_OOB | Process out-of-band data.
MSG_PEEK | Receive data from the beginning of the receive queue without removing it from the queue.
MSG_WAITALL | Block until at least length are received. However, if a signal is caught or the remote host disconnects, the function may return less data.
MSG_DONTWAIT | With this flag set, the function returns even if it would normally have blocked.
address

If the socket is of the type AF_UNIX type, address is the path to the file. Else, for unconnected sockets, address is the IP address of, the remote host, or null if the socket is connection-oriented.

port

This argument only applies to AF_INET and AF_INET6 sockets, and specifies the remote port from which the data is received. If the socket is connection-oriented, port will be null.

返回值

socket_recvfrom() returns the number of bytes received, or false if there was an error. The actual error code can be retrieved by calling socket_last_error(). This error code may be passed to socket_strerror() to get a textual explanation of the error.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

范例

Example #1 socket_recvfrom() example

<?php
error_reporting(E_ALL | E_STRICT);

$socket = socket_create(AF_INET, SOCK_DGRAM, SOL_UDP);
socket_bind($socket, '127.0.0.1', 1223);

$from = '';
$port = 0;
socket_recvfrom($socket, $buf, 12, 0, $from, $port);

echo "Received $buf from remote address $from and remote port $port" . PHP_EOL;
?>

This example will initiate a UDP socket on port 1223 of 127.0.0.1 and print at most 12 characters received from a remote host.

参见

  • socket_recv() - 从已连接的socket接收数据
  • socket_send() - Sends data to a connected socket
  • socket_sendto() - Sends a message to a socket, whether it is connected or not
  • socket_create() - 创建一个套接字（通讯节点）


Read a message

  • ? socket_recvfrom
  • socket_select ?
  • PHP Manual
  • Socket 函数
  • Read a message

socket_recvmsg

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

socket_recvmsg — Read a message

说明

socket_recvmsg ( Socket $socket , array &$message , int $flags = 0 ) : int|false

Warning

本函数还未编写文档，仅有参数列表。

参数

socket

message

flags

返回值

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

参见

  • socket_sendmsg() - Send a message
  • socket_cmsg_space() - Calculate message buffer size


Runs the select() system call on the given arrays of sockets with a specified timeout

  • ? socket_recvmsg
  • socket_send ?
  • PHP Manual
  • Socket 函数
  • Runs the select() system call on the given arrays of sockets with a specified timeout

socket_select

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_select — Runs the select() system call on the given arrays of sockets with a specified timeout

说明

socket_select ( array|null &$read , array|null &$write , array|null &$except , int|null $seconds , int $microseconds = 0 ) : int|false

socket_select() accepts arrays of sockets and waits for them to change status. Those coming with BSD sockets background will recognize that those socket arrays are in fact the so-called file descriptor sets. Three independent arrays of sockets are watched.

参数

read

The sockets listed in the read array will be watched to see if characters become available for reading (more precisely, to see if a read will not block - in particular, a socket is also ready on end-of-file, in which case a socket_read() will return a zero length string).

write

The sockets listed in the write array will be watched to see if a write will not block.

except

The sockets listed in the except array will be watched for exceptions.

seconds

The seconds and microseconds together form the timeout parameter. The timeout is an upper bound on the amount of time elapsed before socket_select() return. seconds may be zero , causing socket_select() to return immediately. This is useful for polling. If seconds is null (no timeout), socket_select() can block indefinitely.

microseconds

Warning

On exit, the arrays are modified to indicate which socket actually changed status.

You do not need to pass every array to socket_select(). You can leave it out and use an empty array or null instead. Also do not forget that those arrays are passed by reference and will be modified after socket_select() returns.

Note:

Due a limitation in the current Zend Engine it is not possible to pass a constant modifier like null directly as a parameter to a function which expects this parameter to be passed by reference. Instead use a temporary variable or an expression with the leftmost member being a temporary variable:

Example #1 Using null with socket_select()

<?php
$e = NULL;
socket_select($r, $w, $e, 0);
?>

返回值

On success socket_select() returns the number of sockets contained in the modified arrays, which may be zero if the timeout expires before anything interesting happens.On error false is returned. The error code can be retrieved with socket_last_error().

Note:

Be sure to use the === operator when checking for an error. Since the socket_select() may return 0 the comparison with == would evaluate to true:

Example #2 Understanding socket_select()'s result

<?php
$e = NULL;
if (false === socket_select($r, $w, $e, 0)) {
    echo "socket_select() failed, reason: " .
        socket_strerror(socket_last_error()) . "\n";
}
?>

范例

Example #3 socket_select() example

<?php
/* Prepare the read array */
$read   = array($socket1, $socket2);
$write  = NULL;
$except = NULL;
$num_changed_sockets = socket_select($read, $write, $except, 0);

if ($num_changed_sockets === false) {
    /* Error handling */
} else if ($num_changed_sockets > 0) {
    /* At least at one of the sockets something interesting happened */
}
?>

注释

Note:

Be aware that some socket implementations need to be handled very carefully. A few basic rules:

  • You should always try to use socket_select() without timeout. Your program should have nothing to do if there is no data available. Code that depends on timeouts is not usually portable and difficult to debug.
  • No socket must be added to any set if you do not intend to check its result after the socket_select() call, and respond appropriately. After socket_select() returns, all sockets in all arrays must be checked. Any socket that is available for writing must be written to, and any socket available for reading must be read from.
  • If you read/write to a socket returns in the arrays be aware that they do not necessarily read/write the full amount of data you have requested. Be prepared to even only be able to read/write a single byte.
  • It's common to most socket implementations that the only exception caught with the except array is out-of-bound data received on a socket.

参见

  • socket_read() - Reads a maximum of length bytes from a socket
  • socket_write() - Write to a socket
  • socket_last_error() - Returns the last error on the socket
  • socket_strerror() - Return a string describing a socket error


Sends data to a connected socket

  • ? socket_select
  • socket_sendmsg ?
  • PHP Manual
  • Socket 函数
  • Sends data to a connected socket

socket_send

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_send — Sends data to a connected socket

说明

socket_send ( Socket $socket , string $data , int $length , int $flags ) : int|false

The function socket_send() sends length bytes to the socket socket from data.

参数

socket

A Socket instance created with socket_create() or socket_accept().

data

A buffer containing the data that will be sent to the remote host.

length

The number of bytes that will be sent to the remote host from data.

flags

The value of flags can be any combination of the following flags, joined with the binary OR (|) operator.

Possible values for flags
MSG_OOB | Send OOB (out-of-band) data.
MSG_EOR | Indicate a record mark. The sent data completes the record.
MSG_EOF | Close the sender side of the socket and include an appropriate notification of this at the end of the sent data. The sent data completes the transaction.
MSG_DONTROUTE | Bypass routing, use direct interface.

返回值

socket_send() returns the number of bytes sent, or false on error.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

参见

  • socket_sendto() - Sends a message to a socket, whether it is connected or not


Send a message

  • ? socket_send
  • socket_sendto ?
  • PHP Manual
  • Socket 函数
  • Send a message

socket_sendmsg

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

socket_sendmsg — Send a message

说明

socket_sendmsg ( Socket $socket , array $message , int $flags = 0 ) : int|false

Warning

本函数还未编写文档，仅有参数列表。

参数

socket

message

flags

返回值

Returns the number of bytes sent, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

参见

  • socket_recvmsg() - Read a message
  • socket_cmsg_space() - Calculate message buffer size


Sends a message to a socket, whether it is connected or not

  • ? socket_sendmsg
  • socket_set_block ?
  • PHP Manual
  • Socket 函数
  • Sends a message to a socket, whether it is connected or not

socket_sendto

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_sendto — Sends a message to a socket, whether it is connected or not

说明

socket_sendto ( Socket $socket , string $data , int $length , int $flags , string $address , int|null $port = null ) : int|false

The function socket_sendto() sends length bytes from data through the socket socket to the port at the address address.

参数

socket

A Socket instance created using socket_create().

data

The sent data will be taken from buffer data.

length

length bytes from data will be sent.

flags

The value of flags can be any combination of the following flags, joined with the binary OR (|) operator.

Possible values for flags
MSG_OOB | Send OOB (out-of-band) data.
MSG_EOR | Indicate a record mark. The sent data completes the record.
MSG_EOF | Close the sender side of the socket and include an appropriate notification of this at the end of the sent data. The sent data completes the transaction.
MSG_DONTROUTE | Bypass routing, use direct interface.

address

IP address of the remote host.

port

port is the remote port number at which the data will be sent.

返回值

socket_sendto() returns the number of bytes sent to the remote host, or false if an error occurred.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.
8.0.0 | port is nullable now.

范例

Example #1 socket_sendto() Example

<?php
    $sock = socket_create(AF_INET, SOCK_DGRAM, SOL_UDP);

    $msg = "Ping !";
    $len = strlen($msg);

    socket_sendto($sock, $msg, $len, 0, '127.0.0.1', 1223);
    socket_close($sock);
?>

参见

  • socket_send() - Sends data to a connected socket


Sets blocking mode on a socket

  • ? socket_sendto
  • socket_set_nonblock ?
  • PHP Manual
  • Socket 函数
  • Sets blocking mode on a socket

socket_set_block

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

socket_set_block — Sets blocking mode on a socket

说明

socket_set_block ( Socket $socket ) : bool

The socket_set_block() function removes the O_NONBLOCK flag on the socket specified by the socket parameter.

When an operation (e.g. receive, send, connect, accept, ...) is performed on a blocking socket, the script will pause its execution until it receives a signal or it can perform the operation.

参数

socket

A Socket instance created with socket_create() or socket_accept().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

范例

Example #1 socket_set_block() example

<?php
$socket = socket_create_listen(1223);
socket_set_block($socket);

socket_accept($socket);
?>

This example creates a listening socket on all interfaces on port 1223 and sets the socket to O_BLOCK mode. socket_accept() will hang until there is a connection to accept.

参见

  • socket_set_nonblock() - Sets nonblocking mode for file descriptor fd
  • socket_set_option() - Sets socket options for the socket


Sets nonblocking mode for file descriptor fd

  • ? socket_set_block
  • socket_set_option ?
  • PHP Manual
  • Socket 函数
  • Sets nonblocking mode for file descriptor fd

socket_set_nonblock

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_set_nonblock — Sets nonblocking mode for file descriptor fd

说明

socket_set_nonblock ( Socket $socket ) : bool

The socket_set_nonblock() function sets the O_NONBLOCK flag on the socket specified by the socket parameter.

When an operation (e.g. receive, send, connect, accept, ...) is performed on a non-blocking socket, the script will not pause its execution until it receives a signal or it can perform the operation. Rather, if the operation would result in a block, the called function will fail.

参数

socket

A Socket instance created with socket_create() or socket_accept().

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

范例

Example #1 socket_set_nonblock() example

<?php
$socket = socket_create_listen(1223);
socket_set_nonblock($socket);

socket_accept($socket);
?>

This example creates a listening socket on all interfaces on port 1223 and sets the socket to O_NONBLOCK mode. socket_accept() will immediately fail unless there is a pending connection exactly at this moment.

参见

  • socket_set_block() - Sets blocking mode on a socket
  • socket_set_option() - Sets socket options for the socket
  • stream_set_blocking() - 为资源流设置阻塞或者阻塞模式


Sets socket options for the socket

  • ? socket_set_nonblock
  • socket_setopt ?
  • PHP Manual
  • Socket 函数
  • Sets socket options for the socket

socket_set_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

socket_set_option — Sets socket options for the socket

说明

socket_set_option ( Socket $socket , int $level , int $option , array|string|int $value ) : bool

The socket_set_option() function sets the option specified by the option parameter, at the specified protocol level, to the value pointed to by the value parameter for the socket.

参数

socket

A Socket instance created with socket_create() or socket_accept().

level

The level parameter specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function.

option

The available socket options are the same as those for the socket_get_option() function.

value

The option value.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

范例

Example #1 socket_set_option() example

<?php
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!is_resource($socket)) {
    echo 'Unable to create socket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

if (!socket_set_option($socket, SOL_SOCKET, SO_REUSEADDR, 1)) {
    echo 'Unable to set option on socket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

if (!socket_bind($socket, '127.0.0.1', 1223)) {
    echo 'Unable to bind socket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

$rval = socket_get_option($socket, SOL_SOCKET, SO_REUSEADDR);

if ($rval === false) {
    echo 'Unable to get socket option: '. socket_strerror(socket_last_error()) . PHP_EOL;
} else if ($rval !== 0) {
    echo 'SO_REUSEADDR is set on socket !' . PHP_EOL;
}
?>

参见

  • socket_create() - 创建一个套接字（通讯节点）
  • socket_bind() - 给套接字绑定名字
  • socket_strerror() - Return a string describing a socket error
  • socket_last_error() - Returns the last error on the socket
  • socket_get_option() - Gets socket options for the socket


别名 socket_set_option

  • ? socket_set_option
  • socket_shutdown ?
  • PHP Manual
  • Socket 函数
  • 别名 socket_set_option

socket_setopt

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_setopt — 别名 socket_set_option()

说明

此函数是该函数的别名： socket_set_option().


Shuts down a socket for receiving, sending, or both

  • ? socket_setopt
  • socket_strerror ?
  • PHP Manual
  • Socket 函数
  • Shuts down a socket for receiving, sending, or both

socket_shutdown

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_shutdown — Shuts down a socket for receiving, sending, or both

说明

socket_shutdown ( Socket $socket , int $mode = 2 ) : bool

The socket_shutdown() function allows you to stop incoming, outgoing or all data (the default) from being sent through the socket

Note:

The associated buffer, or buffers, may or may not be emptied.

参数

socket

A Socket instance created with socket_create().

mode

The value of mode can be one of the following:

possible values for mode
0 | Shutdown socket reading
1 | Shutdown socket writing
2 | Shutdown socket reading and writing

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.


Return a string describing a socket error

  • ? socket_shutdown
  • socket_write ?
  • PHP Manual
  • Socket 函数
  • Return a string describing a socket error

socket_strerror

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_strerror — Return a string describing a socket error

说明

socket_strerror ( int $error_code ) : string

socket_strerror() takes as its error_code parameter a socket error code as returned by socket_last_error() and returns the corresponding explanatory text.

Note:

Although the error messages generated by the socket extension are in English, the system messages retrieved with this function will appear depending on the current locale (LC_MESSAGES).

参数

error_code

A valid socket error number, likely produced by socket_last_error().

返回值

Returns the error message associated with the error_code parameter.

范例

Example #1 socket_strerror() example

<?php
if (false == ($socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP))) {
   echo "socket_create() failed: reason: " . socket_strerror(socket_last_error()) . "\n";
}

if (false == (@socket_bind($socket, '127.0.0.1', 80))) {
   echo "socket_bind() failed: reason: " . socket_strerror(socket_last_error($socket)) . "\n";
}
?>

The expected output from the above example (assuming the script is not run with root privileges):

socket_bind() failed: reason: Permission denied

参见

  • socket_accept() - Accepts a connection on a socket
  • socket_bind() - 给套接字绑定名字
  • socket_connect() - 开启一个套接字连接
  • socket_listen() - Listens for a connection on a socket
  • socket_create() - 创建一个套接字（通讯节点）


Write to a socket

  • ? socket_strerror
  • socket_wsaprotocol_info_export ?
  • PHP Manual
  • Socket 函数
  • Write to a socket

socket_write

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

socket_write — Write to a socket

说明

socket_write ( Socket $socket , string $data , int|null $length = null ) : int|false

The function socket_write() writes to the socket from the given data.

参数

socket

data

The buffer to be written.

length

The optional parameter length can specify an alternate length of bytes written to the socket. If this length is greater than the buffer length, it is silently truncated to the length of the buffer.

返回值

Returns the number of bytes successfully written to the socket 或者在失败时返回 false. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

Note:

It is perfectly valid for socket_write() to return zero which means no bytes have been written. Be sure to use the === operator to check for false in case of an error.

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.
8.0.0 | length is nullable now.

注释

Note:

socket_write() does not necessarily write all bytes from the given buffer. It's valid that, depending on the network buffers etc., only a certain amount of data, even one byte, is written though your buffer is greater. You have to watch out so you don't unintentionally forget to transmit the rest of your data.

参见

  • socket_accept() - Accepts a connection on a socket
  • socket_bind() - 给套接字绑定名字
  • socket_connect() - 开启一个套接字连接
  • socket_listen() - Listens for a connection on a socket
  • socket_read() - Reads a maximum of length bytes from a socket
  • socket_strerror() - Return a string describing a socket error


Exports the WSAPROTOCOL_INFO Structure

  • ? socket_write
  • socket_wsaprotocol_info_import ?
  • PHP Manual
  • Socket 函数
  • Exports the WSAPROTOCOL_INFO Structure

socket_wsaprotocol_info_export

(PHP 7 >= 7.3.0, PHP 8)

socket_wsaprotocol_info_export — Exports the WSAPROTOCOL_INFO Structure

说明

socket_wsaprotocol_info_export ( Socket $socket , int $process_id ) : string|false

Exports the WSAPROTOCOL_INFO structure into shared memory and returns an identifier to be used with socket_wsaprotocol_info_import(). The exported ID is only valid for the given process_id.

Note: This function is available only on Windows.

参数

socket

A Socket instance.

process_id

The ID of the process which will import the socket.

返回值

Returns an identifier to be used for the import, 或者在失败时返回 false

更新日志

版本 | 说明
8.0.0 | socket is a Socket instance now; previously, it was a resource.

参见

  • socket_wsaprotocol_info_import() - Imports a Socket from another Process
  • socket_wsaprotocol_info_release() - Releases an exported WSAPROTOCOL_INFO Structure


Imports a Socket from another Process

  • ? socket_wsaprotocol_info_export
  • socket_wsaprotocol_info_release ?
  • PHP Manual
  • Socket 函数
  • Imports a Socket from another Process

socket_wsaprotocol_info_import

(PHP 7 >= 7.3.0, PHP 8)

socket_wsaprotocol_info_import — Imports a Socket from another Process

说明

socket_wsaprotocol_info_import ( string $info_id ) : Socket|false

Imports a socket which has formerly been exported from another process.

Note: This function is available only on Windows.

参数

info_id

The ID which has been returned by a former call to socket_wsaprotocol_info_export().

返回值

Returns a Socket instance on success, 或者在失败时返回 false

更新日志

版本 | 说明
8.0.0 | On success, this function returns a Socket instance now; previously, a resource was returned.

参见

  • socket_wsaprotocol_info_export() - Exports the WSAPROTOCOL_INFO Structure


Releases an exported WSAPROTOCOL_INFO Structure

  • ? socket_wsaprotocol_info_import
  • SSH2 ?
  • PHP Manual
  • Socket 函数
  • Releases an exported WSAPROTOCOL_INFO Structure

socket_wsaprotocol_info_release

(PHP 7 >= 7.3.0, PHP 8)

socket_wsaprotocol_info_release — Releases an exported WSAPROTOCOL_INFO Structure

说明

socket_wsaprotocol_info_release ( string $info_id ) : bool

Releases the shared memory corresponding to the given info_id.

Note: This function is available only on Windows.

参数

info_id

The ID which has been returned by a former call to socket_wsaprotocol_info_export().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • socket_wsaprotocol_info_export() - Exports the WSAPROTOCOL_INFO Structure


Secure Shell2

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • SSH2 函数
    • ssh2_auth_agent — Authenticate over SSH using the ssh agent
    • ssh2_auth_hostbased_file — Authenticate using a public hostkey
    • ssh2_auth_none — Authenticate as "none"
    • ssh2_auth_password — Authenticate over SSH using a plain password
    • ssh2_auth_pubkey_file — Authenticate using a public key
    • ssh2_connect — Connect to an SSH server
    • ssh2_disconnect — Close a connection to a remote SSH server
    • ssh2_exec — Execute a command on a remote server
    • ssh2_fetch_stream — Fetch an extended data stream
    • ssh2_fingerprint — Retrieve fingerprint of remote server
    • ssh2_forward_accept — Accept a connection created by a listener
    • ssh2_forward_listen — Bind a port on the remote server and listen for connections
    • ssh2_methods_negotiated — Return list of negotiated methods
    • ssh2_poll — Poll the channels/listeners/streams for events
    • ssh2_publickey_add — Add an authorized publickey
    • ssh2_publickey_init — Initialize Publickey subsystem
    • ssh2_publickey_list — List currently authorized publickeys
    • ssh2_publickey_remove — Remove an authorized publickey
    • ssh2_scp_recv — Request a file via SCP
    • ssh2_scp_send — Send a file via SCP
    • ssh2_sftp_chmod — Changes file mode
    • ssh2_sftp_lstat — Stat a symbolic link
    • ssh2_sftp_mkdir — Create a directory
    • ssh2_sftp_readlink — Return the target of a symbolic link
    • ssh2_sftp_realpath — Resolve the realpath of a provided path string
    • ssh2_sftp_rename — Rename a remote file
    • ssh2_sftp_rmdir — Remove a directory
    • ssh2_sftp_stat — Stat a file on a remote filesystem
    • ssh2_sftp_symlink — Create a symlink
    • ssh2_sftp_unlink — Delete a file
    • ssh2_sftp — Initialize SFTP subsystem
    • ssh2_shell — Request an interactive shell
    • ssh2_tunnel — Open a tunnel through a remote server


简介

Bindings to the » libssh2 library which provide access to resources (shell, remote exec, tunneling, file transfer) on a remote machine using a secure cryptographic transport.


需求

The » OpenSSL and » libssh2 libraries are required. Ensure that the development libraries are installed, where a typical package name might be openssl-dev.

Version 1.2 or newer of the libssh2 library is required, although it's possible newer releases of pecl/ssh2 may require newer versions (see the release notes).

The ssh2_auth_agent() function will only be available with libssh >= 1.2.3.

support for stream_set_timeout() to channel streams will only be available with libssh >= 1.2.9.

Libssh2 comes in two flavours: gcrypt or openssl. Some linux distributions build libssh2 with the gcrypt library, some use openssl. Libssh2 has some issues when compiled with gcrypt, please use openssl.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ssh2.

此扩展在 Windows 平台的二进制扩展 (DLL 文件) PECL 可以在 PECL 官方网站上下载。


资源类型

This extension defines the following resource types:

  • SSH2 Session
  • SSH2 Listener
  • SSH2 SFTP
  • SSH2 Publickey Subsystem (as of ssh2 0.10)


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SSH2_FINGERPRINT_MD5 (int)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as an MD5 hash.
SSH2_FINGERPRINT_SHA1 (int)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as an SHA1 hash.
SSH2_FINGERPRINT_HEX (int)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as a string of hexits.
SSH2_FINGERPRINT_RAW (int)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as a raw string of 8-bit characters.
SSH2_TERM_UNIT_CHARS (int)
Flag to ssh2_shell() specifying that width and height are provided as character sizes.
SSH2_TERM_UNIT_PIXELS (int)
Flag to ssh2_shell() specifying that width and height are provided in pixel units.
SSH2_DEFAULT_TERM_WIDTH (int)
Default terminal width requested by ssh2_shell().
SSH2_DEFAULT_TERM_HEIGHT (int)
Default terminal height requested by ssh2_shell().
SSH2_DEFAULT_TERM_UNIT (int)
Default terminal units requested by ssh2_shell().
SSH2_STREAM_STDIO (int)
Flag to ssh2_fetch_stream() requesting STDIO subchannel.
SSH2_STREAM_STDERR (int)
Flag to ssh2_fetch_stream() requesting STDERR subchannel.
SSH2_DEFAULT_TERMINAL (string)
Default terminal type (e.g. vt102, ansi, xterm, vanilla) requested by ssh2_shell().
SSH2_POLLIN (int)
SSH2_POLLEXT (int)
SSH2_POLLOUT (int)
SSH2_POLLERR (int)
SSH2_POLLHUP (int)
SSH2_POLLNVAL (int)
SSH2_POLL_SESSION_CLOSED (int)
SSH2_POLL_CHANNEL_CLOSED (int)
SSH2_POLL_LISTENER_CLOSED (int)


SSH2 函数

Table of Contents

  • ssh2_auth_agent — Authenticate over SSH using the ssh agent
  • ssh2_auth_hostbased_file — Authenticate using a public hostkey
  • ssh2_auth_none — Authenticate as "none"
  • ssh2_auth_password — Authenticate over SSH using a plain password
  • ssh2_auth_pubkey_file — Authenticate using a public key
  • ssh2_connect — Connect to an SSH server
  • ssh2_disconnect — Close a connection to a remote SSH server
  • ssh2_exec — Execute a command on a remote server
  • ssh2_fetch_stream — Fetch an extended data stream
  • ssh2_fingerprint — Retrieve fingerprint of remote server
  • ssh2_forward_accept — Accept a connection created by a listener
  • ssh2_forward_listen — Bind a port on the remote server and listen for connections
  • ssh2_methods_negotiated — Return list of negotiated methods
  • ssh2_poll — Poll the channels/listeners/streams for events
  • ssh2_publickey_add — Add an authorized publickey
  • ssh2_publickey_init — Initialize Publickey subsystem
  • ssh2_publickey_list — List currently authorized publickeys
  • ssh2_publickey_remove — Remove an authorized publickey
  • ssh2_scp_recv — Request a file via SCP
  • ssh2_scp_send — Send a file via SCP
  • ssh2_sftp_chmod — Changes file mode
  • ssh2_sftp_lstat — Stat a symbolic link
  • ssh2_sftp_mkdir — Create a directory
  • ssh2_sftp_readlink — Return the target of a symbolic link
  • ssh2_sftp_realpath — Resolve the realpath of a provided path string
  • ssh2_sftp_rename — Rename a remote file
  • ssh2_sftp_rmdir — Remove a directory
  • ssh2_sftp_stat — Stat a file on a remote filesystem
  • ssh2_sftp_symlink — Create a symlink
  • ssh2_sftp_unlink — Delete a file
  • ssh2_sftp — Initialize SFTP subsystem
  • ssh2_shell — Request an interactive shell
  • ssh2_tunnel — Open a tunnel through a remote server


Authenticate over SSH using the ssh agent

  • ? SSH2 函数
  • ssh2_auth_hostbased_file ?
  • PHP Manual
  • SSH2 函数
  • Authenticate over SSH using the ssh agent

ssh2_auth_agent

(PECL ssh2 >= 0.12)

ssh2_auth_agent — Authenticate over SSH using the ssh agent

说明

ssh2_auth_agent ( resource $session , string $username ) : bool

Authenticate over SSH using the ssh agent

Note: The ssh2_auth_agent() function will only be available when the ssh2 extension is compiled with libssh >= 1.2.3.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Authenticating with a ssh agent

<?php
$connection = ssh2_connect('shell.example.com', 22);

if (ssh2_auth_agent($connection, 'username')) {
  echo "Authentication Successful!\n";
} else {
  die('Authentication Failed...');
}
?>


Authenticate using a public hostkey

  • ? ssh2_auth_agent
  • ssh2_auth_none ?
  • PHP Manual
  • SSH2 函数
  • Authenticate using a public hostkey

ssh2_auth_hostbased_file

(PECL ssh2 >= 0.9.0)

ssh2_auth_hostbased_file — Authenticate using a public hostkey

说明

ssh2_auth_hostbased_file ( resource $session , string $username , string $hostname , string $pubkeyfile , string $privkeyfile , string $passphrase = ? , string $local_username = ? ) : bool

Authenticate using a public hostkey read from a file.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

hostname

pubkeyfile

privkeyfile

passphrase

If privkeyfile is encrypted (which it should be), the passphrase must be provided.

local_username

If local_username is omitted, then the value for username will be used for it.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Authentication using a public hostkey

<?php
$connection = ssh2_connect('shell.example.com', 22, array('hostkey'=>'ssh-rsa'));

if (ssh2_auth_hostbased_file($connection, 'remoteusername', 'myhost.example.com',
                             '/usr/local/etc/hostkey_rsa.pub',
                             '/usr/local/etc/hostkey_rsa', 'secret',
                             'localusername')) {
  echo "Public Key Hostbased Authentication Successful\n";
} else {
  die('Public Key Hostbased Authentication Failed');
}
?>

注释

Note:

ssh2_auth_hostbased_file() requires libssh2 >= 0.7 and PHP/SSH2 >= 0.7


Authenticate as "none"

  • ? ssh2_auth_hostbased_file
  • ssh2_auth_password ?
  • PHP Manual
  • SSH2 函数
  • Authenticate as "none"

ssh2_auth_none

(PECL ssh2 >= 0.9.0)

ssh2_auth_none — Authenticate as "none"

说明

ssh2_auth_none ( resource $session , string $username ) : mixed

Attempt "none" authentication which usually will (and should) fail. As part of the failure, this function will return an array of accepted authentication methods.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

返回值

Returns true if the server does accept "none" as an authentication method, or an array of accepted authentication methods on failure.

范例

Example #1 Retrieving a list of authentication methods

<?php
$connection = ssh2_connect('shell.example.com', 22);

$auth_methods = ssh2_auth_none($connection, 'user');

if (in_array('password', $auth_methods)) {
  echo "Server supports password based authentication\n";
}
?>


Authenticate over SSH using a plain password

  • ? ssh2_auth_none
  • ssh2_auth_pubkey_file ?
  • PHP Manual
  • SSH2 函数
  • Authenticate over SSH using a plain password

ssh2_auth_password

(PECL ssh2 >= 0.9.0)

ssh2_auth_password — Authenticate over SSH using a plain password

说明

ssh2_auth_password ( resource $session , string $username , string $password ) : bool

Authenticate over SSH using a plain password. Since version 0.12 this function also supports keyboard_interactive method.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

password

Password for username

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Authenticating with a password

<?php
$connection = ssh2_connect('shell.example.com', 22);

if (ssh2_auth_password($connection, 'username', 'secret')) {
  echo "Authentication Successful!\n";
} else {
  die('Authentication Failed...');
}
?>


Authenticate using a public key

  • ? ssh2_auth_password
  • ssh2_connect ?
  • PHP Manual
  • SSH2 函数
  • Authenticate using a public key

ssh2_auth_pubkey_file

(PECL ssh2 >= 0.9.0)

ssh2_auth_pubkey_file — Authenticate using a public key

说明

ssh2_auth_pubkey_file ( resource $session , string $username , string $pubkeyfile , string $privkeyfile , string $passphrase = ? ) : bool

Authenticate using a public key read from a file.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

pubkeyfile

The public key file needs to be in OpenSSH's format. It should look something like:

ssh-rsa AAAAB3NzaC1yc2EAAA....NX6sqSnHA8= rsa-key-20121110

privkeyfile

passphrase

If privkeyfile is encrypted (which it should be), the passphrase must be provided.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Authentication using a public key

<?php
$connection = ssh2_connect('shell.example.com', 22, array('hostkey'=>'ssh-rsa'));

if (ssh2_auth_pubkey_file($connection, 'username',
                          '/home/username/.ssh/id_rsa.pub',
                          '/home/username/.ssh/id_rsa', 'secret')) {
  echo "Public Key Authentication Successful\n";
} else {
  die('Public Key Authentication Failed');
}
?>

注释

Note:

The underlying libssh library doesn't support partial auths very cleanly That is, if you need to supply both a public key and a password it will appear as if this function has failed. In this particular case a failure from this call may just mean that auth hasn't been completed yet. You would need to ignore this failure and continue on and call ssh2_auth_password() in order to complete authentication.


Connect to an SSH server

  • ? ssh2_auth_pubkey_file
  • ssh2_disconnect ?
  • PHP Manual
  • SSH2 函数
  • Connect to an SSH server

ssh2_connect

(PECL ssh2 >= 0.9.0)

ssh2_connect — Connect to an SSH server

说明

ssh2_connect ( string $host , int $port = 22 , array $methods = ? , array $callbacks = ? ) : resource

Establish a connection to a remote SSH server.

Once connected, the client should verify the server's hostkey using ssh2_fingerprint(), then authenticate using either password or public key.

参数

host

port

methods

methods may be an associative array with up to four parameters as described below.

methods may be an associative array with any or all of the following parameters.
Index | Meaning | Supported Values*
kex | List of key exchange methods to advertise, comma separated in order of preference. | diffie-hellman-group1-sha1, diffie-hellman-group14-sha1, and diffie-hellman-group-exchange-sha1
hostkey | List of hostkey methods to advertise, comma separated in order of preference. | ssh-rsa and ssh-dss
client_to_server | Associative array containing crypt, compression, and message authentication code (MAC) method preferences for messages sent from client to server.
server_to_client | Associative array containing crypt, compression, and message authentication code (MAC) method preferences for messages sent from server to client.

* - Supported Values are dependent on methods supported by underlying library. See » libssh2 documentation for additional information.

client_to_server and server_to_client may be an associative array with any or all of the following parameters.
Index | Meaning | Supported Values*
crypt | List of crypto methods to advertise, comma separated in order of preference. | rijndael-cbc@lysator.liu.se, aes256-cbc, aes192-cbc, aes128-cbc, 3des-cbc, blowfish-cbc, cast128-cbc, arcfour, and none**
comp | List of compression methods to advertise, comma separated in order of preference. | zlib and none
mac | List of MAC methods to advertise, comma separated in order of preference. | hmac-sha1, hmac-sha1-96, hmac-ripemd160, hmac-ripemd160@openssh.com, and none**

Note: Crypt and MAC method "none"

For security reasons, none is disabled by the underlying » libssh2 library unless explicitly enabled during build time by using the appropriate ./configure options. See documentation for the underlying library for more information.

callbacks

callbacks may be an associative array with any or all of the following parameters.

Callbacks parameters
Index | Meaning | Prototype
ignore | Name of function to call when an SSH2_MSG_IGNORE packet is received | void ignore_cb($message)
debug | Name of function to call when an SSH2_MSG_DEBUG packet is received | void debug_cb($message, $language, $always_display)
macerror | Name of function to call when a packet is received but the message authentication code failed. If the callback returns true, the mismatch will be ignored, otherwise the connection will be terminated. | bool macerror_cb($packet)
disconnect | Name of function to call when an SSH2_MSG_DISCONNECT packet is received | void disconnect_cb($reason, $message, $language)

返回值

Returns a resource on success, or false on error.

范例

Example #1 ssh2_connect() example

Open a connection forcing 3des-cbc when sending packets, any strength aes cipher when receiving packets, no compression in either direction, and Group1 key exchange.

<?php
/* Notify the user if the server terminates the connection */
function my_ssh_disconnect($reason, $message, $language) {
  printf("Server disconnected with reason code [%d] and message: %s\n",
         $reason, $message);
}

$methods = array(
  'kex' => 'diffie-hellman-group1-sha1',
  'client_to_server' => array(
    'crypt' => '3des-cbc',
    'comp' => 'none'),
  'server_to_client' => array(
    'crypt' => 'aes256-cbc,aes192-cbc,aes128-cbc',
    'comp' => 'none'));

$callbacks = array('disconnect' => 'my_ssh_disconnect');

$connection = ssh2_connect('shell.example.com', 22, $methods, $callbacks);
if (!$connection) die('Connection failed');
?>

参见

  • ssh2_fingerprint() - Retrieve fingerprint of remote server
  • ssh2_auth_none() - Authenticate as "none"
  • ssh2_auth_password() - Authenticate over SSH using a plain password
  • ssh2_auth_pubkey_file() - Authenticate using a public key
  • ssh2_disconnect() - Close a connection to a remote SSH server


Close a connection to a remote SSH server

  • ? ssh2_connect
  • ssh2_exec ?
  • PHP Manual
  • SSH2 函数
  • Close a connection to a remote SSH server

ssh2_disconnect

(PECL ssh2 >= 1.0)

ssh2_disconnect — Close a connection to a remote SSH server

说明

ssh2_disconnect ( resource $session ) : bool

Close a connection to a remote SSH server.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ssh2_connect() - Connect to an SSH server


Execute a command on a remote server

  • ? ssh2_disconnect
  • ssh2_fetch_stream ?
  • PHP Manual
  • SSH2 函数
  • Execute a command on a remote server

ssh2_exec

(PECL ssh2 >= 0.9.0)

ssh2_exec — Execute a command on a remote server

说明

ssh2_exec ( resource $session , string $command , string $pty = ? , array $env = ? , int $width = 80 , int $height = 25 , int $width_height_type = SSH2_TERM_UNIT_CHARS ) : resource|false

Execute a command at the remote end and allocate a channel for it.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

command

pty

env

env may be passed as an associative array of name/value pairs to set in the target environment.

width

Width of the virtual terminal.

height

Height of the virtual terminal.

width_height_type

width_height_type should be one of SSH2_TERM_UNIT_CHARS or SSH2_TERM_UNIT_PIXELS.

返回值

Returns a stream on success 或者在失败时返回 false.

范例

Example #1 Executing a command

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stream = ssh2_exec($connection, '/usr/local/bin/php -i');
?>

参见

  • ssh2_connect() - Connect to an SSH server
  • ssh2_shell() - Request an interactive shell
  • ssh2_tunnel() - Open a tunnel through a remote server


Fetch an extended data stream

  • ? ssh2_exec
  • ssh2_fingerprint ?
  • PHP Manual
  • SSH2 函数
  • Fetch an extended data stream

ssh2_fetch_stream

(PECL ssh2 >= 0.9.0)

ssh2_fetch_stream — Fetch an extended data stream

说明

ssh2_fetch_stream ( resource $channel , int $streamid ) : resource

Fetches an alternate substream associated with an SSH2 channel stream. The SSH2 protocol currently defines only one substream, STDERR, which has a substream ID of SSH2_STREAM_STDERR (defined as 1).

参数

channel

streamid

An SSH2 channel stream.

返回值

Returns the requested stream resource.

范例

Example #1 Opening a shell and retrieving the stderr stream associated with it

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stdio_stream = ssh2_shell($connection);
$stderr_stream = ssh2_fetch_stream($stdio_stream, SSH2_STREAM_STDERR);
?>

参见

  • ssh2_shell() - Request an interactive shell
  • ssh2_exec() - Execute a command on a remote server
  • ssh2_connect() - Connect to an SSH server


Retrieve fingerprint of remote server

  • ? ssh2_fetch_stream
  • ssh2_forward_accept ?
  • PHP Manual
  • SSH2 函数
  • Retrieve fingerprint of remote server

ssh2_fingerprint

(PECL ssh2 >= 0.9.0)

ssh2_fingerprint — Retrieve fingerprint of remote server

说明

ssh2_fingerprint ( resource $session , int $flags = SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX ) : string

Returns a server hostkey hash from an active session.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

flags

flags may be either of SSH2_FINGERPRINT_MD5 or SSH2_FINGERPRINT_SHA1 logically ORed with SSH2_FINGERPRINT_HEX or SSH2_FINGERPRINT_RAW.

返回值

Returns the hostkey hash as a string.

范例

Example #1 Checking the fingerprint against a known value

<?php
$known_host = '6F89C2F0A719B30CC38ABDF90755F2E4';

$connection = ssh2_connect('shell.example.com', 22);

$fingerprint = ssh2_fingerprint($connection,
               SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX);

if ($fingerprint != $known_host) {
  die("HOSTKEY MISMATCH!\n" .
      "Possible Man-In-The-Middle Attack?");
}
?>


Accept a connection created by a listener

  • ? ssh2_fingerprint
  • ssh2_forward_listen ?
  • PHP Manual
  • SSH2 函数
  • Accept a connection created by a listener

ssh2_forward_accept

(PECL ssh2 >= 0.9.0)

ssh2_forward_accept — Accept a connection created by a listener

说明

ssh2_forward_accept ( resource $listener ) : resource|false

Accepts a connection created by a listener.

Warning

本函数还未编写文档，仅有参数列表。

参数

desc

An SSH2 Listener resource, obtained from a call to ssh2_forward_listen().

返回值

Returns a stream resource, 或者在失败时返回 false.


Bind a port on the remote server and listen for connections

  • ? ssh2_forward_accept
  • ssh2_methods_negotiated ?
  • PHP Manual
  • SSH2 函数
  • Bind a port on the remote server and listen for connections

ssh2_forward_listen

(PECL ssh2 >= 0.9.0)

ssh2_forward_listen — Bind a port on the remote server and listen for connections

说明

ssh2_forward_listen ( resource $session , int $port , string $host = ? , int $max_connections = 16 ) : resource|false

Binds a port on the remote server and listen for connections.

Warning

本函数还未编写文档，仅有参数列表。

参数

session

An SSH Session resource, obtained from a call to ssh2_connect().

port

The port of the remote server.

host

max_connections

返回值

Returns an SSH2 Listener, 或者在失败时返回 false.

参见

  • ssh2_forward_accept() - Accept a connection created by a listener


Return list of negotiated methods

  • ? ssh2_forward_listen
  • ssh2_poll ?
  • PHP Manual
  • SSH2 函数
  • Return list of negotiated methods

ssh2_methods_negotiated

(PECL ssh2 >= 0.9.0)

ssh2_methods_negotiated — Return list of negotiated methods

说明

ssh2_methods_negotiated ( resource $session ) : array

Returns list of negotiated methods.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

返回值

范例

Example #1 Determining what methods were negotiated

<?php
$connection = ssh2_connect('shell.example.com', 22);
$methods = ssh2_methods_negotiated($connection);

echo "Encryption keys were negotiated using: {$methods['kex']}\n";
echo "Server identified using an {$methods['hostkey']} with ";
echo "fingerprint: " . ssh2_fingerprint($connection) . "\n";

echo "Client to Server packets will use methods:\n";
echo "\tCrypt: {$methods['client_to_server']['crypt']}\n";
echo "\tComp: {$methods['client_to_server']['comp']}\n";
echo "\tMAC: {$methods['client_to_server']['mac']}\n";

echo "Server to Client packets will use methods:\n";
echo "\tCrypt: {$methods['server_to_client']['crypt']}\n";
echo "\tComp: {$methods['server_to_client']['comp']}\n";
echo "\tMAC: {$methods['server_to_client']['mac']}\n";

?>

参见

  • ssh2_connect() - Connect to an SSH server


Poll the channels/listeners/streams for events

  • ? ssh2_methods_negotiated
  • ssh2_publickey_add ?
  • PHP Manual
  • SSH2 函数
  • Poll the channels/listeners/streams for events

ssh2_poll

(PECL ssh2 >= 0.9.0)

ssh2_poll — Poll the channels/listeners/streams for events

说明

ssh2_poll ( array &$desc , int $timeout = 30 ) : int

Polls the channels/listeners/streams for events, and returns the number of descriptors which returned non-zero revents.

Warning

本函数还未编写文档，仅有参数列表。

参数

desc

An indexed array of subarrays with the keys 'resource' and 'events'. The value of the resource is a (channel) stream or an SSH2 Listener resource. The value of the event are SSH2_POLL* flags bitwise ORed together. Each subarray will be populated with an 'revents' element on return, whose values are SSH2_POLL* flags bitwise ORed together of the events that occurred.

timeout

The timeout in seconds.

返回值

Returns the number of descriptors which returned non-zero revents.


Add an authorized publickey

  • ? ssh2_poll
  • ssh2_publickey_init ?
  • PHP Manual
  • SSH2 函数
  • Add an authorized publickey

ssh2_publickey_add

(PECL ssh2 >= 0.10)

ssh2_publickey_add — Add an authorized publickey

说明

ssh2_publickey_add ( resource $pkey , string $algoname , string $blob , bool $overwrite = false , array $attributes = ? ) : bool

Note: 公钥子系统用于管理服务器到已被认证的客户端的公钥。要用公钥认证方法来认证远程系统，应使用 ssh2_auth_pubkey_file() 函数。

参数

pkey

Publickey Subsystem resource created by ssh2_publickey_init().

algoname

Publickey algorithm (e.g.): ssh-dss, ssh-rsa

blob

Publickey blob as raw binary data

overwrite

If the specified key already exists, should it be overwritten?

attributes

Associative array of attributes to assign to this public key. Refer to ietf-secsh-publickey-subsystem for a list of supported attributes. To mark an attribute as mandatory, precede its name with an asterisk. If the server is unable to support an attribute marked mandatory, it will abort the add process.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Adding a publickey with ssh2_publickey_add()

<?php
$ssh2 = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($ssh2, 'jdoe', 'password');
$pkey = ssh2_publickey_init($ssh2);

$keyblob = base64_decode('
AAAAB3NzaC1yc2EAAAABIwAAAIEA5HVt6VqSGd5PTrLRdjNONxXH1tVFGn0
Bd26BF0aCP9qyJRlvdJ3j4WBeX4ZmrveGrjMgkseSYc4xZ26sDHwfL351xj
zaLpipu\BGRrw17mWVBhuCExo476ri5tQFzbTc54VEHYckxQ16CjSTibI5X
69GmnYC9PNqEYq/1TP+HF10=');

ssh2_publickey_add($pkey, 'ssh-rsa', $keyblob, false, array('comment'=>"John's Key"));
?>

参见

  • ssh2_publickey_init() - Initialize Publickey subsystem
  • ssh2_publickey_remove() - Remove an authorized publickey
  • ssh2_publickey_list() - List currently authorized publickeys


Initialize Publickey subsystem

  • ? ssh2_publickey_add
  • ssh2_publickey_list ?
  • PHP Manual
  • SSH2 函数
  • Initialize Publickey subsystem

ssh2_publickey_init

(PECL ssh2 >= 0.10)

ssh2_publickey_init — Initialize Publickey subsystem

说明

ssh2_publickey_init ( resource $session ) : resource|false

Request the Publickey subsystem from an already connected SSH2 server.

The publickey subsystem allows an already connected and authenticated client to manage the list of authorized public keys stored on the target server in an implementation agnostic manner. If the remote server does not support the publickey subsystem, the ssh2_publickey_init() function will return false.

参数

session

返回值

Returns an SSH2 Publickey Subsystem resource for use with all other ssh2_publickey_*() methods 或者在失败时返回 false.

注释

Note: 公钥子系统用于管理服务器到已被认证的客户端的公钥。要用公钥认证方法来认证远程系统，应使用 ssh2_auth_pubkey_file() 函数。

参见

  • ssh2_publickey_add() - Add an authorized publickey
  • ssh2_publickey_remove() - Remove an authorized publickey
  • ssh2_publickey_list() - List currently authorized publickeys


List currently authorized publickeys

  • ? ssh2_publickey_init
  • ssh2_publickey_remove ?
  • PHP Manual
  • SSH2 函数
  • List currently authorized publickeys

ssh2_publickey_list

(PECL ssh2 >= 0.10)

ssh2_publickey_list — List currently authorized publickeys

说明

ssh2_publickey_list ( resource $pkey ) : array

List currently authorized publickeys.

参数

pkey

Publickey Subsystem resource

返回值

Returns a numerically indexed array of keys, each of which is an associative array containing: name, blob, and attrs elements.

Publickey elements
Array Key | Meaning
name | Name of algorithm used by this publickey, for example: ssh-dss or ssh-rsa.
blob | Publickey blob as raw binary data.
attrs | Attributes assigned to this publickey. The most common attribute, and the only one supported by publickey version 1 servers, is comment, which may be any freeform string.

范例

Example #1 Listing authorized keys with ssh2_publickey_list()

<?php
$ssh2 = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($ssh2, 'jdoe', 'secret');
$pkey = ssh2_publickey_init($ssh2);

$list = ssh2_publickey_list($pkey);

foreach($list as $key) {
  echo "Key: {$key['name']}\n";
  echo "Blob: " . chunk_split(base64_encode($key['blob']), 40, "\n") . "\n";
  echo "Comment: {$key['attrs']['comment']}\n\n";
}
?>

以上例程会输出：

Key: ssh-rsa
Blob: AAAAB3NzaC1yc2EAAAABIwAAAIEA5HVt6VqSGd5P
TrLRdjNONxXH1tVFGn0Bd26BF0aCP9qyJRlvdJ3j
4WBeX4ZmrveGrjMgkseSYc4xZ26sDHwfL351xjza
Lpipu\BGRrw17mWVBhuCExo476ri5tQFzbTc54VE
HYckxQ16CjSTibI5X69GmnYC9PNqEYq/1TP+HF10
Comment: John's Key

Key: ssh-rsa
Blob: AAAAB3NzaHVt6VqSGd5C1yc2EAAAABIwA232dnJA
AIEA5HVt6VqSGd5PTrLRdjNONxX/1TP+HF1HVt6V
qSGd50H1tVFGn0BB3NzaC1yc2EAd26BF0aCP9qyJ
RlvdJ3j4WBeX4ZmrveGrjMgkseSYc4xZ26HVt6Vq
SGd5sDHwfL351xjzaLpipu\BGB3NzaC1yc2EA/1T
Comment: Alice's Key

注释

Note: 公钥子系统用于管理服务器到已被认证的客户端的公钥。要用公钥认证方法来认证远程系统，应使用 ssh2_auth_pubkey_file() 函数。

参见

  • ssh2_publickey_init() - Initialize Publickey subsystem
  • ssh2_publickey_add() - Add an authorized publickey
  • ssh2_publickey_remove() - Remove an authorized publickey


Remove an authorized publickey

  • ? ssh2_publickey_list
  • ssh2_scp_recv ?
  • PHP Manual
  • SSH2 函数
  • Remove an authorized publickey

ssh2_publickey_remove

(PECL ssh2 >= 0.10)

ssh2_publickey_remove — Remove an authorized publickey

说明

ssh2_publickey_remove ( resource $pkey , string $algoname , string $blob ) : bool

Removes an authorized publickey.

参数

pkey

Publickey Subsystem Resource

algoname

Publickey algorithm (e.g.): ssh-dss, ssh-rsa

blob

Publickey blob as raw binary data

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note: 公钥子系统用于管理服务器到已被认证的客户端的公钥。要用公钥认证方法来认证远程系统，应使用 ssh2_auth_pubkey_file() 函数。

参见

  • ssh2_publickey_init() - Initialize Publickey subsystem
  • ssh2_publickey_add() - Add an authorized publickey
  • ssh2_publickey_list() - List currently authorized publickeys


Request a file via SCP

  • ? ssh2_publickey_remove
  • ssh2_scp_send ?
  • PHP Manual
  • SSH2 函数
  • Request a file via SCP

ssh2_scp_recv

(PECL ssh2 >= 0.9.0)

ssh2_scp_recv — Request a file via SCP

说明

ssh2_scp_recv ( resource $session , string $remote_file , string $local_file ) : bool

Copy a file from the remote server to the local filesystem using the SCP protocol.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

remote_file

Path to the remote file.

local_file

Path to the local file.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Downloading a file via SCP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

ssh2_scp_recv($connection, '/remote/filename', '/local/filename');
?>

参见

  • ssh2_scp_send() - Send a file via SCP
  • copy() - 拷贝文件


Send a file via SCP

  • ? ssh2_scp_recv
  • ssh2_sftp_chmod ?
  • PHP Manual
  • SSH2 函数
  • Send a file via SCP

ssh2_scp_send

(PECL ssh2 >= 0.9.0)

ssh2_scp_send — Send a file via SCP

说明

ssh2_scp_send ( resource $session , string $local_file , string $remote_file , int $create_mode = 0644 ) : bool

Copy a file from the local filesystem to the remote server using the SCP protocol.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

local_file

Path to the local file.

remote_file

Path to the remote file.

create_mode

The file will be created with the mode specified by create_mode.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Uploading a file via SCP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

ssh2_scp_send($connection, '/local/filename', '/remote/filename', 0644);
?>

参见

  • ssh2_scp_recv() - Request a file via SCP
  • copy() - 拷贝文件


Changes file mode

  • ? ssh2_scp_send
  • ssh2_sftp_lstat ?
  • PHP Manual
  • SSH2 函数
  • Changes file mode

ssh2_sftp_chmod

(PECL ssh2 >= 0.12)

ssh2_sftp_chmod — Changes file mode

说明

ssh2_sftp_chmod ( resource $sftp , string $filename , int $mode ) : bool

Attempts to change the mode of the specified file to that given in mode.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

Path to the file.

mode

Permissions on the file. See the chmod() for more details on this parameter.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Changing the mode of a file on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_chmod($sftp, '/somedir/somefile', 0755);
?>

参见

  • chmod() - 改变文件模式
  • ssh2_sftp() - Initialize SFTP subsystem
  • ssh2_connect() - Connect to an SSH server


Stat a symbolic link

  • ? ssh2_sftp_chmod
  • ssh2_sftp_mkdir ?
  • PHP Manual
  • SSH2 函数
  • Stat a symbolic link

ssh2_sftp_lstat

(PECL ssh2 >= 0.9.0)

ssh2_sftp_lstat — Stat a symbolic link

说明

ssh2_sftp_lstat ( resource $sftp , string $path ) : array

Stats a symbolic link on the remote filesystem without following the link.

This function is similar to using the lstat() function with the ssh2.sftp:// wrapper in PHP 5 and returns the same values.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

path

Path to the remote symbolic link.

返回值

See the documentation for stat() for details on the values which may be returned.

范例

Example #1 Stating a symbolic link via SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);
$statinfo = ssh2_sftp_lstat($sftp, '/path/to/symlink');

$filesize = $statinfo['size'];
$group = $statinfo['gid'];
$owner = $statinfo['uid'];
$atime = $statinfo['atime'];
$mtime = $statinfo['mtime'];
$mode = $statinfo['mode'];
?>

参见

  • ssh2_sftp_stat() - Stat a file on a remote filesystem
  • lstat() - 给出一个文件或符号连接的信息
  • stat() - 给出文件的信息


Create a directory

  • ? ssh2_sftp_lstat
  • ssh2_sftp_readlink ?
  • PHP Manual
  • SSH2 函数
  • Create a directory

ssh2_sftp_mkdir

(PECL ssh2 >= 0.9.0)

ssh2_sftp_mkdir — Create a directory

说明

ssh2_sftp_mkdir ( resource $sftp , string $dirname , int $mode = 0777 , bool $recursive = false ) : bool

Creates a directory on the remote file server with permissions set to mode.

This function is similar to using mkdir() with the ssh2.sftp:// wrapper.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

dirname

Path of the new directory.

mode

Permissions on the new directory. The actual mode is affected by the current umask.

recursive

If recursive is true any parent directories required for dirname will be automatically created as well.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Creating a directory on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_mkdir($sftp, '/home/username/newdir');
/* Or:  mkdir("ssh2.sftp://$sftp/home/username/newdir"); */
?>

参见

  • mkdir() - 新建目录
  • ssh2_sftp_rmdir() - Remove a directory


Return the target of a symbolic link

  • ? ssh2_sftp_mkdir
  • ssh2_sftp_realpath ?
  • PHP Manual
  • SSH2 函数
  • Return the target of a symbolic link

ssh2_sftp_readlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_readlink — Return the target of a symbolic link

说明

ssh2_sftp_readlink ( resource $sftp , string $link ) : string

Returns the target of a symbolic link.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

link

Path of the symbolic link.

返回值

Returns the target of the symbolic link.

范例

Example #1 Reading a symbolic link

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

$target = ssh2_sftp_readlink($sftp, '/tmp/mysql.sock');
/* $target is now (e.g.): '/var/run/mysql.sock' */
?>

参见

  • readlink() - 返回符号连接指向的目标
  • ssh2_sftp_symlink() - Create a symlink


Resolve the realpath of a provided path string

  • ? ssh2_sftp_readlink
  • ssh2_sftp_rename ?
  • PHP Manual
  • SSH2 函数
  • Resolve the realpath of a provided path string

ssh2_sftp_realpath

(PECL ssh2 >= 0.9.0)

ssh2_sftp_realpath — Resolve the realpath of a provided path string

说明

ssh2_sftp_realpath ( resource $sftp , string $filename ) : string

Translates filename into the effective real path on the remote filesystem.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

返回值

Returns the real path as a string.

范例

Example #1 Resolving a pathname

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

$realpath = ssh2_sftp_realpath($sftp, '/home/username/../../../..//./usr/../etc/passwd');
/* $realpath is now: '/etc/passwd' */
?>

参见

  • realpath() - 返回规范化的绝对路径名
  • ssh2_sftp_symlink() - Create a symlink
  • ssh2_sftp_readlink() - Return the target of a symbolic link


Rename a remote file

  • ? ssh2_sftp_realpath
  • ssh2_sftp_rmdir ?
  • PHP Manual
  • SSH2 函数
  • Rename a remote file

ssh2_sftp_rename

(PECL ssh2 >= 0.9.0)

ssh2_sftp_rename — Rename a remote file

说明

ssh2_sftp_rename ( resource $sftp , string $from , string $to ) : bool

Renames a file on the remote filesystem.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

from

The current file that is being renamed.

to

The new file name that replaces from.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Renaming a file via sftp

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_rename($sftp, '/home/username/oldname', '/home/username/newname');
?>

参见

  • rename() - 重命名一个文件或目录


Remove a directory

  • ? ssh2_sftp_rename
  • ssh2_sftp_stat ?
  • PHP Manual
  • SSH2 函数
  • Remove a directory

ssh2_sftp_rmdir

(PECL ssh2 >= 0.9.0)

ssh2_sftp_rmdir — Remove a directory

说明

ssh2_sftp_rmdir ( resource $sftp , string $dirname ) : bool

Removes a directory from the remote file server.

This function is similar to using rmdir() with the ssh2.sftp:// wrapper.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

dirname

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Removing a directory on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_rmdir($sftp, '/home/username/deltodel');
/* Or:  rmdir("ssh2.sftp://$sftp/home/username/dirtodel"); */
?>

参见

  • rmdir() - 删除目录
  • ssh2_sftp_mkdir() - Create a directory


Stat a file on a remote filesystem

  • ? ssh2_sftp_rmdir
  • ssh2_sftp_symlink ?
  • PHP Manual
  • SSH2 函数
  • Stat a file on a remote filesystem

ssh2_sftp_stat

(PECL ssh2 >= 0.9.0)

ssh2_sftp_stat — Stat a file on a remote filesystem

说明

ssh2_sftp_stat ( resource $sftp , string $path ) : array

Stats a file on the remote filesystem following any symbolic links.

This function is similar to using the stat() function with the ssh2.sftp:// wrapper in PHP 5 and returns the same values.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

path

返回值

See the documentation for stat() for details on the values which may be returned.

范例

Example #1 Stating a file via SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);
$statinfo = ssh2_sftp_stat($sftp, '/path/to/file');

$filesize = $statinfo['size'];
$group = $statinfo['gid'];
$owner = $statinfo['uid'];
$atime = $statinfo['atime'];
$mtime = $statinfo['mtime'];
$mode = $statinfo['mode'];
?>

参见

  • ssh2_sftp_lstat() - Stat a symbolic link
  • lstat() - 给出一个文件或符号连接的信息
  • stat() - 给出文件的信息


Create a symlink

  • ? ssh2_sftp_stat
  • ssh2_sftp_unlink ?
  • PHP Manual
  • SSH2 函数
  • Create a symlink

ssh2_sftp_symlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_symlink — Create a symlink

说明

ssh2_sftp_symlink ( resource $sftp , string $target , string $link ) : bool

Creates a symbolic link named link on the remote filesystem pointing to target.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

target

Target of the symbolic link.

link

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Creating a symbolic link

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_symlink($sftp, '/var/run/mysql.sock', '/tmp/mysql.sock');
?>

参见

  • ssh2_sftp_readlink() - Return the target of a symbolic link
  • symlink() - 建立符号连接


Delete a file

  • ? ssh2_sftp_symlink
  • ssh2_sftp ?
  • PHP Manual
  • SSH2 函数
  • Delete a file

ssh2_sftp_unlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_unlink — Delete a file

说明

ssh2_sftp_unlink ( resource $sftp , string $filename ) : bool

Deletes a file on the remote filesystem.

参数

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Deleting a file

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_unlink($sftp, '/home/username/stale_file');
?>

参见

  • unlink() - 删除文件


Initialize SFTP subsystem

  • ? ssh2_sftp_unlink
  • ssh2_shell ?
  • PHP Manual
  • SSH2 函数
  • Initialize SFTP subsystem

ssh2_sftp

(PECL ssh2 >= 0.9.0)

ssh2_sftp — Initialize SFTP subsystem

说明

ssh2_sftp ( resource $session ) : resource|false

Request the SFTP subsystem from an already connected SSH2 server.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

返回值

This method returns an SSH2 SFTP resource for use with all other ssh2_sftp_*() methods and the ssh2.sftp:// fopen wrapper, 或者在失败时返回 false.

范例

Example #1 Opening a file via SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);

$stream = fopen('ssh2.sftp://' . intval($sftp) . '/path/to/file', 'r');
?>

参见

  • ssh2_scp_recv() - Request a file via SCP
  • ssh2_scp_send() - Send a file via SCP


Request an interactive shell

  • ? ssh2_sftp
  • ssh2_tunnel ?
  • PHP Manual
  • SSH2 函数
  • Request an interactive shell

ssh2_shell

(PECL ssh2 >= 0.9.0)

ssh2_shell — Request an interactive shell

说明

ssh2_shell ( resource $session , string $term_type = "vanilla" , array|null $env = null , int $width = 80 , int $height = 25 , int $width_height_type = SSH2_TERM_UNIT_CHARS ) : resource|false

Open a shell at the remote end and allocate a stream for it.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

term_type

term_type should correspond to one of the entries in the target system's /etc/termcap file.

env

env may be passed as an associative array of name/value pairs to set in the target environment.

width

Width of the virtual terminal.

height

Height of the virtual terminal.

width_height_type

width_height_type should be one of SSH2_TERM_UNIT_CHARS or SSH2_TERM_UNIT_PIXELS.

返回值

Returns a stream 资源(resource) on success, 或者在失败时返回 false.

范例

Example #1 Requesting an interactive shell

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stream = ssh2_shell($connection, 'vt102', null, 80, 24, SSH2_TERM_UNIT_CHARS);
?>

参见

  • ssh2_exec() - Execute a command on a remote server
  • ssh2_tunnel() - Open a tunnel through a remote server
  • ssh2_fetch_stream() - Fetch an extended data stream


Open a tunnel through a remote server

  • ? ssh2_shell
  • Stomp ?
  • PHP Manual
  • SSH2 函数
  • Open a tunnel through a remote server

ssh2_tunnel

(PECL ssh2 >= 0.9.0)

ssh2_tunnel — Open a tunnel through a remote server

说明

ssh2_tunnel ( resource $session , string $host , int $port ) : resource

Open a socket stream to an arbitrary host/port by way of the currently connected SSH server.

参数

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

host

port

返回值

范例

Example #1 Opening a tunnel to an arbitrary host

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_pubkey_file($connection, 'username', 'id_dsa.pub', 'id_dsa');

$tunnel = ssh2_tunnel($connection, '10.0.0.101', 12345);
?>

参见

  • ssh2_connect() - Connect to an SSH server
  • fsockopen() - 打开一个网络连接或者一个Unix套接字连接


Stomp Client

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 范例
  • Stomp 函数
    • stomp_connect_error — Returns a string description of the last connect error
    • stomp_version — Gets the current stomp extension version
  • Stomp — The Stomp class
    • Stomp::abort — Rolls back a transaction in progress
    • Stomp::ack — Acknowledges consumption of a message
    • Stomp::begin — Starts a transaction
    • Stomp::commit — Commits a transaction in progress
    • Stomp::__construct — 打开一个连接
    • Stomp::__destruct — Closes stomp connection
    • Stomp::error — Gets the last stomp error
    • Stomp::getReadTimeout — Gets read timeout
    • Stomp::getSessionId — Gets the current stomp session ID
    • Stomp::hasFrame — Indicates whether or not there is a frame ready to read
    • Stomp::readFrame — Reads the next frame
    • Stomp::send — Sends a message
    • Stomp::setReadTimeout — Sets read timeout
    • Stomp::subscribe — Registers to listen to a given destination
    • Stomp::unsubscribe — Removes an existing subscription
  • StompFrame — The StompFrame class
    • StompFrame::__construct — Constructor
  • StompException — The StompException class
    • StompException::getDetails — Get exception details


简介

This extension allows php applications to communicate with any Stomp compliant Message Brokers through easy object oriented and procedural interfaces. » Stomp official site


需求

PECL/stomp requires PHP 5.2.2 or newer.

The » OpenSSL package >= 0.9.6 and the openssl extension may also be required to use stomp over SSL.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/stomp


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Stomp 配置选项
名字 | 默认 | 可修改范围 | 更新日志
stomp.default_broker | tcp://localhost:61613 | PHP_INI_ALL |
stomp.default_connection_timeout_sec | 2 | PHP_INI_ALL |
stomp.default_connection_timeout_usec | 0 | PHP_INI_ALL |
stomp.default_read_timeout_sec | 2 | PHP_INI_ALL |
stomp.default_read_timeout_usec | 0 | PHP_INI_ALL |

这是配置指令的简短说明。

stomp.default_broker string

The default broker URI to use when connecting to the message broker if no other URI is specified.

stomp.default_connection_timeout_sec int

The seconds part of the default connection timeout.

stomp.default_connection_timeout_usec int

The microseconds part of the default connection timeout.

stomp.default_read_timeout_sec int

The seconds part of the default reading timeout.

stomp.default_read_timeout_usec int

The microseconds part of the default reading timeout.


资源类型

There is only one resource type used in the stomp extension - it's the link identifier for a stomp connection.


范例

Example #1 面向对象风格

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* send a message to the queue 'foo' */
$stomp->send($queue, $msg);

/* subscribe to messages from the queue 'foo' */
$stomp->subscribe($queue);

/* read a frame */
$frame = $stomp->readFrame();

if ($frame->body === $msg) {
    var_dump($frame);

    /* acknowledge that the frame was received */
    $stomp->ack($frame);
}

/* close connection */
unset($stomp);

?>

以上例程的输出类似于：

object(StompFrame)#2 (3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["headers"]=>
  array(5) {
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:2:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257226805828"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
  ["body"]=>
  string(3) "bar"
}

Example #2 过程化风格

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* begin a transaction */
stomp_begin($link, 't1');

/* send a message to the queue 'foo' */
stomp_send($link, $queue, $msg, array('transaction' => 't1'));

/* commit a transaction */
stomp_commit($link, 't1');

/* subscribe to messages from the queue 'foo' */
stomp_subscribe($link, $queue);

/* read a frame */
$frame = stomp_read_frame($link);

if ($frame['body'] === $msg) {
    var_dump($frame);

    /* acknowledge that the frame was received */
    stomp_ack($link, $frame['headers']['message-id']);
}

/* close connection */
stomp_close($link);

?>

以上例程的输出类似于：

array(3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["body"]=>
  string(3) "bar"
  ["headers"]=>
  array(6) {
    ["transaction"]=>
    string(2) "t1"
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:3:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257227037059"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
}


Stomp 函数

Table of Contents

  • stomp_connect_error — Returns a string description of the last connect error
  • stomp_version — Gets the current stomp extension version


Returns a string description of the last connect error

  • ? Stomp 函数
  • stomp_version ?
  • PHP Manual
  • Stomp 函数
  • Returns a string description of the last connect error

stomp_connect_error

(PECL stomp >= 0.3.0)

stomp_connect_error — Returns a string description of the last connect error

说明

stomp_connect_error ( ) : string

Returns a string description of the last connect error.

参数

此函数没有参数。

返回值

A string that describes the error, or null if no error occurred.

范例

Example #1 stomp_connect_error() example

<?php
$link = stomp_connect('http://localhost:61613');

if(!$link) {
    die('Connection failed: ' . stomp_connect_error());
}
?>

以上例程的输出类似于：

Connection failed: Invalid Broker URI scheme


Gets the current stomp extension version

  • ? stomp_connect_error
  • Stomp ?
  • PHP Manual
  • Stomp 函数
  • Gets the current stomp extension version

stomp_version

(PECL stomp >= 0.1.0)

stomp_version — Gets the current stomp extension version

说明

stomp_version ( ) : string

Returns a string containing the version of the current stomp extension.

参数

此函数没有参数。

返回值

It returns the current stomp extension version

范例

Example #1 stomp_version() example

<?php

var_dump(stomp_version());

?>

以上例程的输出类似于：

string(5) "0.2.0"


The Stomp class

(PECL stomp >= 0.1.0)

简介

Represents a connection between PHP and a Stomp compliant Message Broker.

类摘要

Stomp {
/* 方法 */
public abort ( string $transaction_id , array $headers = ? ) : bool
public ack ( mixed $msg , array $headers = ? ) : bool
public begin ( string $transaction_id , array $headers = ? ) : bool
public commit ( string $transaction_id , array $headers = ? ) : bool
public __construct ( string $broker = ini_get("stomp.default_broker_uri") , string $username = ? , string $password = ? , array $headers = ? )
public __destruct ( ) : bool
public error ( ) : string
public getReadTimeout ( ) : array
public getSessionId ( ) : string|false
public hasFrame ( ) : bool
public readFrame ( string $class_name = "stompFrame" ) : stompframe
public send ( string $destination , mixed $msg , array $headers = ? ) : bool
public setReadTimeout ( int $seconds , int $microseconds = ? ) : void
public subscribe ( string $destination , array $headers = ? ) : bool
public unsubscribe ( string $destination , array $headers = ? ) : bool
}

Table of Contents

  • Stomp::abort — Rolls back a transaction in progress
  • Stomp::ack — Acknowledges consumption of a message
  • Stomp::begin — Starts a transaction
  • Stomp::commit — Commits a transaction in progress
  • Stomp::__construct — 打开一个连接
  • Stomp::__destruct — Closes stomp connection
  • Stomp::error — Gets the last stomp error
  • Stomp::getReadTimeout — Gets read timeout
  • Stomp::getSessionId — Gets the current stomp session ID
  • Stomp::hasFrame — Indicates whether or not there is a frame ready to read
  • Stomp::readFrame — Reads the next frame
  • Stomp::send — Sends a message
  • Stomp::setReadTimeout — Sets read timeout
  • Stomp::subscribe — Registers to listen to a given destination
  • Stomp::unsubscribe — Removes an existing subscription


Rolls back a transaction in progress

  • ? Stomp
  • Stomp::ack ?
  • PHP Manual
  • Stomp
  • Rolls back a transaction in progress

Stomp::abort

stomp_abort

(PECL stomp >= 0.1.0)

Stomp::abort -- stomp_abort — Rolls back a transaction in progress

说明

面向对象风格 (method):

public Stomp::abort ( string $transaction_id , array $headers = ? ) : bool

过程化风格:

stomp_abort ( resource $link , string $transaction_id , array $headers = ? ) : bool

Rolls back a transaction in progress.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

transaction_id

The transaction to abort.

headers

关联数组包含附加的头信息（例如： receipt）。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Tip

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

范例

Example #1 面向对象风格

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* begin a transaction */
$stomp->begin('t1');

/* send a message to the queue */
$stomp->send('/queue/foo', 'bar', array('transaction' => 't1'));

/* rollback */
$stomp->abort('t1');

/* close connection */
unset($stomp);
?>

Example #2 过程化风格

<?php

/* connection */
$link = stomp_connect('tcp://localhost:61613');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* begin a transaction */
stomp_begin($link, 't1');

/* send a message to the queue 'foo' */
stomp_send($link, '/queue/foo', 'bar', array('transaction' => 't1'));

/* rollback */
stomp_abort($link, 't1');

/* close connection */
stomp_close($link);

?>


Acknowledges consumption of a message

  • ? Stomp::abort
  • Stomp::begin ?
  • PHP Manual
  • Stomp
  • Acknowledges consumption of a message

Stomp::ack

stomp_ack

(PECL stomp >= 0.1.0)

Stomp::ack -- stomp_ack — Acknowledges consumption of a message

说明

面向对象风格 (method):

public Stomp::ack ( mixed $msg , array $headers = ? ) : bool

过程化风格:

stomp_ack ( resource $link , mixed $msg , array $headers = ? ) : bool

Acknowledges consumption of a message from a subscription using client acknowledgment.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

msg

The message/messageId to be acknowledged.

headers

关联数组包含附加的头信息（例如： receipt）。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

A transaction header may be specified, indicating that the message acknowledgment should be part of the named transaction.

Tip

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

范例

Example #1 面向对象风格

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* send a message to the queue 'foo' */
$stomp->send($queue, $msg);

/* subscribe to messages from the queue 'foo' */
$stomp->subscribe($queue);

/* read a frame */
$frame = $stomp->readFrame();

if ($frame->body === $msg) {
    /* acknowledge that the frame was received */
    $stomp->ack($frame);
}

/* remove the subscription */
$stomp->unsubscribe($queue);

/* close connection */
unset($stomp);

?>

Example #2 过程化风格

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* begin a transaction */
stomp_begin($link, 't1');

/* send a message to the queue 'foo' */
stomp_send($link, $queue, $msg, array('transaction' => 't1'));

/* commit a transaction */
stomp_commit($link, 't1');

/* subscribe to messages from the queue 'foo' */
stomp_subscribe($link, $queue);

/* read a frame */
$frame = stomp_read_frame($link);

if ($frame['body'] === $msg) {
    /* acknowledge that the frame was received */
    stomp_ack($link, $frame['headers']['message-id']);
}

/* remove the subscription */
stomp_unsubscribe($link, $queue);

/* close connection */
stomp_close($link);

?>


Starts a transaction

  • ? Stomp::ack
  • Stomp::commit ?
  • PHP Manual
  • Stomp
  • Starts a transaction

Stomp::begin

stomp_begin

(PECL stomp >= 0.1.0)

Stomp::begin -- stomp_begin — Starts a transaction

说明

面向对象风格 (method):

public Stomp::begin ( string $transaction_id , array $headers = ? ) : bool

过程化风格:

stomp_begin ( resource $link , string $transaction_id , array $headers = ? ) : bool

Starts a transaction.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

transaction_id

The transaction id.

headers

关联数组包含附加的头信息（例如： receipt）。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Tip

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

范例

See stomp_commit() or stomp_abort().


Commits a transaction in progress

  • ? Stomp::begin
  • Stomp::__construct ?
  • PHP Manual
  • Stomp
  • Commits a transaction in progress

Stomp::commit

stomp_commit

(PECL stomp >= 0.1.0)

Stomp::commit -- stomp_commit — Commits a transaction in progress

说明

面向对象风格 (method):

public Stomp::commit ( string $transaction_id , array $headers = ? ) : bool

过程化风格:

stomp_commit ( resource $link , string $transaction_id , array $headers = ? ) : bool

Commits a transaction in progress.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

transaction_id

The transaction id.

headers

关联数组包含附加的头信息（例如： receipt）。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Tip

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

范例

Example #1 面向对象风格

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* begin a transaction */
$stomp->begin('t1');

/* send a message to the queue */
$stomp->send('/queue/foo', 'bar', array('transaction' => 't1'));

/* commit */
$stomp->commit('t1');

/* close connection */
unset($stomp);

?>

Example #2 过程化风格

<?php

/* connection */
$link = stomp_connect('tcp://localhost:61613');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* begin a transaction */
stomp_begin($link, 't1');

/* send a message to the queue 'foo' */
stomp_send($link, '/queue/foo', 'bar', array('transaction' => 't1'));

/* commit */
stomp_commit($link, 't1');

/* close connection */
stomp_close($link);

?>


打开一个连接

  • ? Stomp::commit
  • Stomp::__destruct ?
  • PHP Manual
  • Stomp
  • 打开一个连接

Stomp::__construct

stomp_connect

(PECL stomp >= 0.1.0)

Stomp::__construct -- stomp_connect — 打开一个连接

说明

面向对象风格 (constructor):

public Stomp::__construct ( string $broker = ini_get("stomp.default_broker_uri") , string $username = ? , string $password = ? , array $headers = ? )

过程化风格:

stomp_connect ( string $broker = ini_get("stomp.default_broker_uri") , string $username = ? , string $password = ? , array $headers = ? ) : resource

打开一个到兼容stomp通讯协议的消息代理服务器的连接.

参数

broker

代理服务器的统一资源标识符（URI）。

username

用户名.

password

密码.

headers

关联数组包含附加的头信息（例如： receipt）。

返回值

Note:

A transaction header may be specified, indicating that the message acknowledgment should be part of the named transaction.

更新日志

版本 | 说明
1.0.1 | 增加了headers 参数

范例

Example #1 面向对象风格

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* close connection */
unset($stomp);

?>

Example #2 过程化风格

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* close connection */
stomp_close($link);

?>


Closes stomp connection

  • ? Stomp::__construct
  • Stomp::error ?
  • PHP Manual
  • Stomp
  • Closes stomp connection

Stomp::__destruct

stomp_close

(PECL stomp >= 0.1.0)

Stomp::__destruct -- stomp_close — Closes stomp connection

说明

面向对象风格 (destructor):

public Stomp::__destruct ( ) : bool

过程化风格:

stomp_close ( resource $link ) : bool

Closes a previously opened connection.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

See stomp_connect().


Gets the last stomp error

  • ? Stomp::__destruct
  • Stomp::getReadTimeout ?
  • PHP Manual
  • Stomp
  • Gets the last stomp error

Stomp::error

stomp_error

(PECL stomp >= 0.1.0)

Stomp::error -- stomp_error — Gets the last stomp error

说明

面向对象风格 (method):

public Stomp::error ( ) : string

过程化风格:

stomp_error ( resource $link ) : string

Gets the last stomp error.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

返回值

Returns an error string or false if no error occurred.

范例

Example #1 面向对象风格

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->error());

if (!$stomp->abort('unknown-transaction', array('receipt' => 'foo'))) {
    var_dump($stomp->error());
}

/* close connection */
unset($stomp);

?>

以上例程的输出类似于：

bool(false)
string(43) "Invalid transaction id: unknown-transaction"

Example #2 过程化风格

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_error($link));

if (!stomp_abort($link, 'unknown-transaction', array('receipt' => 'foo'))) {
    var_dump(stomp_error($link));
}

/* close connection */
stomp_close($link);

?>

以上例程的输出类似于：

bool(false)
string(43) "Invalid transaction id: unknown-transaction"


Gets read timeout

  • ? Stomp::error
  • Stomp::getSessionId ?
  • PHP Manual
  • Stomp
  • Gets read timeout

Stomp::getReadTimeout

stomp_get_read_timeout

(PECL stomp >= 0.3.0)

Stomp::getReadTimeout -- stomp_get_read_timeout — Gets read timeout

说明

面向对象风格 (method):

public Stomp::getReadTimeout ( ) : array

过程化风格:

stomp_get_read_timeout ( resource $link ) : array

Gets read timeout

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

返回值

Returns an array with 2 elements: sec and usec.

范例

Example #1 面向对象风格

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->getReadTimeout());

/* close connection */
unset($stomp);

?>

以上例程的输出类似于：

array(2) {
  ["sec"]=>
  int(2)
  ["usec"]=>
  int(0)
}

Example #2 过程化风格

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_get_read_timeout($link));

/* close connection */
stomp_close($link);

?>

以上例程的输出类似于：

array(2) {
  ["sec"]=>
  int(2)
  ["usec"]=>
  int(0)
}


Gets the current stomp session ID

  • ? Stomp::getReadTimeout
  • Stomp::hasFrame ?
  • PHP Manual
  • Stomp
  • Gets the current stomp session ID

Stomp::getSessionId

stomp_get_session_id

(PECL stomp >= 0.1.0)

Stomp::getSessionId -- stomp_get_session_id — Gets the current stomp session ID

说明

面向对象风格 (method):

public Stomp::getSessionId ( ) : string|false

过程化风格:

stomp_get_session_id ( resource $link ) : string|false

Gets the current stomp session ID.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

返回值

string session id on success 或者在失败时返回 false.

范例

Example #1 面向对象风格

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->getSessionId());

/* close connection */
unset($stomp);

?>

以上例程的输出类似于：

string(35) "ID:php.net-52873-1257291895530-4:14"

Example #2 过程化风格

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_get_session_id($link));

/* close connection */
stomp_close($link);

?>

以上例程的输出类似于：

string(35) "ID:php.net-52873-1257291895530-4:14"


Indicates whether or not there is a frame ready to read

  • ? Stomp::getSessionId
  • Stomp::readFrame ?
  • PHP Manual
  • Stomp
  • Indicates whether or not there is a frame ready to read

Stomp::hasFrame

stomp_has_frame

(PECL stomp >= 0.1.0)

Stomp::hasFrame -- stomp_has_frame — Indicates whether or not there is a frame ready to read

说明

面向对象风格 (method):

public Stomp::hasFrame ( ) : bool

过程化风格:

stomp_has_frame ( resource $link ) : bool

Indicates whether or not there is a frame ready to read.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

返回值

Returns true if a frame is ready to read, or false otherwise.


Reads the next frame

  • ? Stomp::hasFrame
  • Stomp::send ?
  • PHP Manual
  • Stomp
  • Reads the next frame

Stomp::readFrame

stomp_read_frame

(PECL stomp >= 0.1.0)

Stomp::readFrame -- stomp_read_frame — Reads the next frame

说明

面向对象风格 (method):

public Stomp::readFrame ( string $class_name = "stompFrame" ) : stompframe

过程化风格:

stomp_read_frame ( resource $link ) : array

Reads the next frame. It is possible to instantiate an object of a specific class, and pass parameters to that class's constructor.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

class_name

The name of the class to instantiate. If not specified, a stompFrame object is returned.

返回值

Note:

A transaction header may be specified, indicating that the message acknowledgment should be part of the named transaction.

更新日志

版本 | 说明
Stomp 0.4.0 | class_name parameter was added.

范例

Example #1 面向对象风格

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* subscribe to messages from the queue 'foo' */
$stomp->subscribe('/queue/foo');

/* read a frame */
var_dump($stomp->readFrame());

/* close connection */
unset($stomp);

?>

以上例程的输出类似于：

object(StompFrame)#2 (3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["headers"]=>
  array(5) {
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:2:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257226805828"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
  ["body"]=>
  string(3) "bar"
}

Example #2 过程化风格

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* subscribe to messages from the queue 'foo' */
stomp_subscribe($link, '/queue/foo');

/* read a frame */
$frame = stomp_read_frame($link);

/* close connection */
stomp_close($link);

?>

以上例程的输出类似于：

array(3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["body"]=>
  string(3) "bar"
  ["headers"]=>
  array(6) {
    ["transaction"]=>
    string(2) "t1"
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:3:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257227037059"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
}


Sends a message

  • ? Stomp::readFrame
  • Stomp::setReadTimeout ?
  • PHP Manual
  • Stomp
  • Sends a message

Stomp::send

stomp_send

(PECL stomp >= 0.1.0)

Stomp::send -- stomp_send — Sends a message

说明

面向对象风格 (method):

public Stomp::send ( string $destination , mixed $msg , array $headers = ? ) : bool

过程化风格:

stomp_send ( resource $link , string $destination , mixed $msg , array $headers = ? ) : bool

Sends a message to the Message Broker.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

destination

Where to send the message

msg

Message to send.

headers

关联数组包含附加的头信息（例如： receipt）。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

A transaction header may be specified, indicating that the message acknowledgment should be part of the named transaction.

Tip

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

范例

See stomp_ack().


Sets read timeout

  • ? Stomp::send
  • Stomp::subscribe ?
  • PHP Manual
  • Stomp
  • Sets read timeout

Stomp::setReadTimeout

stomp_set_read_timeout

(PECL stomp >= 0.3.0)

Stomp::setReadTimeout -- stomp_set_read_timeout — Sets read timeout

说明

面向对象风格 (method):

public Stomp::setReadTimeout ( int $seconds , int $microseconds = ? ) : void

过程化风格:

stomp_set_read_timeout ( resource $link , int $seconds , int $microseconds = ? ) : void

Sets read timeout.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

seconds

The seconds part of the timeout to be set.

microseconds

The microseconds part of the timeout to be set.

范例

Example #1 面向对象风格

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

$stomp->setReadTimeout(10);

/* close connection */
unset($stomp);

?>

Example #2 过程化风格

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

stomp_set_read_timeout($link, 10);

/* close connection */
stomp_close($link);

?>


Registers to listen to a given destination

  • ? Stomp::setReadTimeout
  • Stomp::unsubscribe ?
  • PHP Manual
  • Stomp
  • Registers to listen to a given destination

Stomp::subscribe

stomp_subscribe

(PECL stomp >= 0.1.0)

Stomp::subscribe -- stomp_subscribe — Registers to listen to a given destination

说明

面向对象风格 (method):

public Stomp::subscribe ( string $destination , array $headers = ? ) : bool

过程化风格:

stomp_subscribe ( resource $link , string $destination , array $headers = ? ) : bool

Registers to listen to a given destination.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

destination

Destination to subscribe to.

headers

关联数组包含附加的头信息（例如： receipt）。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Tip

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

范例

See stomp_ack().


Removes an existing subscription

  • ? Stomp::subscribe
  • StompFrame ?
  • PHP Manual
  • Stomp
  • Removes an existing subscription

Stomp::unsubscribe

stomp_unsubscribe

(PECL stomp >= 0.1.0)

Stomp::unsubscribe -- stomp_unsubscribe — Removes an existing subscription

说明

面向对象风格 (method):

public Stomp::unsubscribe ( string $destination , array $headers = ? ) : bool

过程化风格:

stomp_unsubscribe ( resource $link , string $destination , array $headers = ? ) : bool

Removes an existing subscription.

参数

link

仅对过程化样式：由 stomp_connect() 返回的 stomp 连接标识符。

destination

Subscription to remove.

headers

关联数组包含附加的头信息（例如： receipt）。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Tip

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

范例

See stomp_ack().


The StompFrame class

(PECL stomp >= 0.1.0)

简介

Represents a message which was sent or received from a Stomp compliant Message Broker.

类摘要

StompFrame {
/* 属性 */
public $command ;
public $headers ;
public $body ;
/* 方法 */
__construct ( string $command = ? , array $headers = ? , string $body = ? )
}

属性

command

Frame command.

headers

Frame headers (array).

body

Frame body.

Table of Contents

  • StompFrame::__construct — Constructor


Constructor

  • ? StompFrame
  • StompException ?
  • PHP Manual
  • StompFrame
  • Constructor

StompFrame::__construct

(PECL stomp >= 0.1.0)

StompFrame::__construct — Constructor

说明

StompFrame::__construct ( string $command = ? , array $headers = ? , string $body = ? )

Constructor.

参数

command

Frame command

headers

Frame headers (array).

body

Frame body.


The StompException class

(PECL stomp >= 0.1.0)

简介

Represents an error raised by the stomp extension. See Exceptions for more information about Exceptions in PHP.

类摘要

StompException extends Exception {
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
/* 方法 */
public getDetails ( ) : string
}

Table of Contents

  • StompException::getDetails — Get exception details


Get exception details

  • ? StompException
  • SVM ?
  • PHP Manual
  • StompException
  • Get exception details

StompException::getDetails

(PECL stomp >= 0.1.0)

StompException::getDetails — Get exception details

说明

public StompException::getDetails ( ) : string

Get exception details.

返回值

string containing the error details.


支持向量机

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 范例
  • SVM — The SVM class
    • SVM::__construct — Construct a new SVM object
    • SVM::crossvalidate — Test training params on subsets of the training data
    • SVM::getOptions — Return the current training parameters
    • SVM::setOptions — Set training parameters
    • SVM::train — Create a SVMModel based on training data
  • SVMModel — The SVMModel class
    • SVMModel::checkProbabilityModel — Returns true if the model has probability information
    • SVMModel::__construct — Construct a new SVMModel
    • SVMModel::getLabels — Get the labels the model was trained on
    • SVMModel::getNrClass — Returns the number of classes the model was trained with
    • SVMModel::getSvmType — Get the SVM type the model was trained with
    • SVMModel::getSvrProbability — Get the sigma value for regression types
    • SVMModel::load — Load a saved SVM Model
    • SVMModel::predict_probability — Return class probabilities for previous unseen data
    • SVMModel::predict — Predict a value for previously unseen data
    • SVMModel::save — Save a model to a file


简介

LibSVM 是SVM分类和回归问题的有效解决方案。这里的以php接口封装的svm扩展是为了在php脚本中更方便的应用。


需求

Libsvm itself is required, and is available through some package management - libsvm-devel for RPM based system or libsvm-dev for Debian based ones. Alternatively it is available direct from the website. If installing from the » official website then some steps will need to be taken as the package does not install automatically. For example, assuming the latest version is 3.1:

wget http://www.csie.ntu.edu.tw/~cjlin/cgi-bin/libsvm.cgi?+http://www.csie.ntu.edu.tw/~cjlin/libsvm+tar.gz
tar xvzf libsvm-3.1.tar.gz
cd libsvm-3.1
make lib
cp libsvm.so.1 /usr/lib
ln -s libsvm.so.1 libsvm.so
ldconfig
ldconfig --print | grep libsvm

This last step should show libsvm is installed.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/svm


范例

The basic process is to define parameters, supply training data to generate a model on, then make predictions based on the model. There are a default set of parameters that should get some results with most any input, so we'll start by looking at the data.

Data is supplied in either a file, a stream, or as an array. If supplied in a file or a stream, it must contain one line per training example, which must be formatted as an integer class (usually 1 and -1) followed by a series of feature/value pairs, in increasing feature order. The features are integers, the values floats, usually scaled 0-1. For example:

-1 1:0.43 3:0.12 9284:0.2

In a document classification problem, say a spam checker, each line would represent a document. There would be two classes, -1 for spam, 1 for ham. Each feature would represent some word, and the value would represent that importance of that word to the document (perhaps the frequency count, with the total scaled to unit length). Features that were 0 (e.g. the word did not appear in the document at all) would simply not be included.

In array mode, the data must be passed as an array of arrays. Each sub-array must have the class as the first element, then key => value sets for the feature values pairs.

This data is passed to the SVM class's train function, which will return an SVM model is successful.

Once a model has been generated, it can be used to make predictions about previously unseen data. This can be passed as an array to the model's predict function, in the same format as before, but without the label. The response will be the class.

Models can be saved and restored as required, using the save and load functions, which both take a file location.

Example #1 Train from array

<?php
$data = array(
    array(-1, 1 => 0.43, 3 => 0.12, 9284 => 0.2),
    array(1, 1 => 0.22, 5 => 0.01, 94 => 0.11),
);

$svm = new SVM();
$model = $svm->train($data);

$data = array(1 => 0.43, 3 => 0.12, 9284 => 0.2);
$result = $model->predict($data);
var_dump($result);
$model->save('model.svm');
?>

以上例程的输出类似于：

int(-1)

Example #2 Train from a file

<?php
$svm = new SVM();
$model = $svm->train("traindata.txt");
?>


The SVM class

(PECL svm >= 0.1.0)

简介

类摘要

SVM {
/* Constants */
const int C_SVC = 0 ;
const int NU_SVC = 1 ;
const int ONE_CLASS = 2 ;
const int EPSILON_SVR = 3 ;
const int NU_SVR = 4 ;
const int KERNEL_LINEAR = 0 ;
const int KERNEL_POLY = 1 ;
const int KERNEL_RBF = 2 ;
const int KERNEL_SIGMOID = 3 ;
const int KERNEL_PRECOMPUTED = 4 ;
const int OPT_TYPE = 101 ;
const int OPT_KERNEL_TYPE = 102 ;
const int OPT_DEGREE = 103 ;
const int OPT_SHRINKING = 104 ;
const int OPT_PROPABILITY = 105 ;
const int OPT_GAMMA = 201 ;
const int OPT_NU = 202 ;
const int OPT_EPS = 203 ;
const int OPT_P = 204 ;
const int OPT_COEF_ZERO = 205 ;
const int OPT_C = 206 ;
const int OPT_CACHE_SIZE = 207 ;
/* Methods */
public __construct ( )
public svm::crossvalidate ( array $problem , int $number_of_folds ) : float
public getOptions ( ) : array
public setOptions ( array $params ) : bool
public svm::train ( array $problem , array $weights = ? ) : SVMModel
}

预定义常量

SVM Constants

SVM::C_SVC

The basic C_SVC SVM type. The default, and a good starting point

SVM::NU_SVC

The NU_SVC type uses a different, more flexible, error weighting

SVM::ONE_CLASS

One class SVM type. Train just on a single class, using outliers as negative examples

SVM::EPSILON_SVR

A SVM type for regression (predicting a value rather than just a class)

SVM::NU_SVR

A NU style SVM regression type

SVM::KERNEL_LINEAR

A very simple kernel, can work well on large document classification problems

SVM::KERNEL_POLY

A polynomial kernel

SVM::KERNEL_RBF

The common Gaussian RBD kernel. Handles non-linear problems well and is a good default for classification

SVM::KERNEL_SIGMOID

A kernel based on the sigmoid function. Using this makes the SVM very similar to a two layer sigmoid based neural network

SVM::KERNEL_PRECOMPUTED

A precomputed kernel - currently unsupported.

SVM::OPT_TYPE

The options key for the SVM type

SVM::OPT_KERNEL_TYPE

The options key for the kernel type

SVM::OPT_DEGREE

SVM::OPT_SHRINKING

Training parameter, boolean, for whether to use the shrinking heuristics

SVM::OPT_PROBABILITY

Training parameter, boolean, for whether to collect and use probability estimates

SVM::OPT_GAMMA

Algorithm parameter for Poly, RBF and Sigmoid kernel types.

SVM::OPT_NU

The option key for the nu parameter, only used in the NU_ SVM types

SVM::OPT_EPS

The option key for the Epsilon parameter, used in epsilon regression

SVM::OPT_P

Training parameter used by Episilon SVR regression

SVM::OPT_COEF_ZERO

Algorithm parameter for poly and sigmoid kernels

SVM::OPT_C

The option for the cost parameter that controls tradeoff between errors and generality - effectively the penalty for misclassifying training examples.

SVM::OPT_CACHE_SIZE

Memory cache size, in MB

Table of Contents

  • SVM::__construct — Construct a new SVM object
  • SVM::crossvalidate — Test training params on subsets of the training data
  • SVM::getOptions — Return the current training parameters
  • SVM::setOptions — Set training parameters
  • SVM::train — Create a SVMModel based on training data


Construct a new SVM object

  • ? SVM
  • SVM::crossvalidate ?
  • PHP Manual
  • SVM
  • Construct a new SVM object

SVM::__construct

(PECL svm >= 0.1.0)

SVM::__construct — Construct a new SVM object

说明

public SVM::__construct ( )

Constructs a new SVM object ready to accept training data.

参数

此函数没有参数。

返回值

Throws SVMException if the libsvm library could not be loaded


Test training params on subsets of the training data

  • ? SVM::__construct
  • SVM::getOptions ?
  • PHP Manual
  • SVM
  • Test training params on subsets of the training data

SVM::crossvalidate

(PECL svm >= 0.1.0)

SVM::crossvalidate — Test training params on subsets of the training data

说明

public svm::crossvalidate ( array $problem , int $number_of_folds ) : float

Crossvalidate can be used to test the effectiveness of the current parameter set on a subset of the training data. Given a problem set and a n "folds", it separates the problem set into n subsets, and the repeatedly trains on one subset and tests on another. While the accuracy will generally be lower than a SVM trained on the enter data set, the accuracy score returned should be relatively useful, so it can be used to test different training parameters.

参数

problem

The problem data. This can either be in the form of an array, the URL of an SVMLight formatted file, or a stream to an opened SVMLight formatted datasource.

number_of_folds

The number of sets the data should be divided into and cross tested. A higher number means smaller training sets and less reliability. 5 is a good number to start with.

返回值

The correct percentage, expressed as a floating point number from 0-1. In the case of NU_SVC or EPSILON_SVR kernels the mean squared error will returned instead.

参见

  • SVM::train() - Create a SVMModel based on training data


Return the current training parameters

  • ? SVM::crossvalidate
  • SVM::setOptions ?
  • PHP Manual
  • SVM
  • Return the current training parameters

SVM::getOptions

(PECL svm >= 0.1.0)

SVM::getOptions — Return the current training parameters

说明

public SVM::getOptions ( ) : array

Retrieve an array containing the training parameters. The parameters will be keyed on the predefined SVM constants.

参数

此函数没有参数。

返回值

Returns an array of configuration settings.


Set training parameters

  • ? SVM::getOptions
  • SVM::train ?
  • PHP Manual
  • SVM
  • Set training parameters

SVM::setOptions

(PECL svm >= 0.1.0)

SVM::setOptions — Set training parameters

说明

public SVM::setOptions ( array $params ) : bool

Set one or more training parameters.

参数

params

An array of training parameters, keyed on the SVM constants.

返回值

Return true on success, throws SVMException on error.


Create a SVMModel based on training data

  • ? SVM::setOptions
  • SVMModel ?
  • PHP Manual
  • SVM
  • Create a SVMModel based on training data

SVM::train

(PECL svm >= 0.1.0)

SVM::train — Create a SVMModel based on training data

说明

public svm::train ( array $problem , array $weights = ? ) : SVMModel

Train a support vector machine based on the supplied training data.

参数

problem

The problem can be provided in three different ways. An array, where the data should start with the class label (usually 1 or -1) then followed by a sparse data set of dimension => data pairs. A URL to a file containing a SVM Light formatted problem, with the each line being a new training example, the start of each line containing the class (1, -1) then a series of tab separated data values shows as key:value. A opened stream pointing to a data source formatted as in the file above.

weights

Weights are an optional set of weighting parameters for the different classes, to help account for unbalanced training sets. For example, if the classes were 1 and -1, and -1 had significantly more example than one, the weight for -1 could be 0.5. Weights should be in the range 0-1.

返回值

Returns an SVMModel that can be used to classify previously unseen data. Throws SVMException on error


The SVMModel class

(PECL svm >= 0.1.0)

简介

The SVMModel is the end result of the training process. It can be used to classify previously unseen data.

类摘要

SVMModel {
/* Methods */
public checkProbabilityModel ( ) : bool
public __construct ( string $filename = ? )
public getLabels ( ) : array
public getNrClass ( ) : int
public getSvmType ( ) : int
public getSvrProbability ( ) : float
public load ( string $filename ) : bool
public predict_probability ( array $data ) : float
public predict ( array $data ) : float
public save ( string $filename ) : bool
}

Table of Contents

  • SVMModel::checkProbabilityModel — Returns true if the model has probability information
  • SVMModel::__construct — Construct a new SVMModel
  • SVMModel::getLabels — Get the labels the model was trained on
  • SVMModel::getNrClass — Returns the number of classes the model was trained with
  • SVMModel::getSvmType — Get the SVM type the model was trained with
  • SVMModel::getSvrProbability — Get the sigma value for regression types
  • SVMModel::load — Load a saved SVM Model
  • SVMModel::predict_probability — Return class probabilities for previous unseen data
  • SVMModel::predict — Predict a value for previously unseen data
  • SVMModel::save — Save a model to a file


Returns true if the model has probability information

  • ? SVMModel
  • SVMModel::__construct ?
  • PHP Manual
  • SVMModel
  • Returns true if the model has probability information

SVMModel::checkProbabilityModel

(PECL svm >= 0.1.5)

SVMModel::checkProbabilityModel — Returns true if the model has probability information

说明

public SVMModel::checkProbabilityModel ( ) : bool

Returns true if the model contains probability information.

参数

此函数没有参数。

返回值

Return a boolean value


Construct a new SVMModel

  • ? SVMModel::checkProbabilityModel
  • SVMModel::getLabels ?
  • PHP Manual
  • SVMModel
  • Construct a new SVMModel

SVMModel::__construct

(PECL svm >= 0.1.0)

SVMModel::__construct — Construct a new SVMModel

说明

public SVMModel::__construct ( string $filename = ? )

Build a new SVMModel. Models will usually be created from the SVM::train function, but then saved models may be restored directly.

参数

filename

The filename for the saved model file this model should load.

返回值

Throws SVMException on error

参见

  • SVMModel::load() - Load a saved SVM Model


Get the labels the model was trained on

  • ? SVMModel::__construct
  • SVMModel::getNrClass ?
  • PHP Manual
  • SVMModel
  • Get the labels the model was trained on

SVMModel::getLabels

(PECL svm >= 0.1.5)

SVMModel::getLabels — Get the labels the model was trained on

说明

public SVMModel::getLabels ( ) : array

Return an array of labels that the model was trained on. For regression and one class models an empty array is returned.

参数

此函数没有参数。

返回值

Return an array of labels

参见

  • SVMModel::getNrClass() - Returns the number of classes the model was trained with


Returns the number of classes the model was trained with

  • ? SVMModel::getLabels
  • SVMModel::getSvmType ?
  • PHP Manual
  • SVMModel
  • Returns the number of classes the model was trained with

SVMModel::getNrClass

(PECL svm >= 0.1.5)

SVMModel::getNrClass — Returns the number of classes the model was trained with

说明

public SVMModel::getNrClass ( ) : int

Returns the number of classes the model was trained with, will return 2 for one class and regression models.

参数

此函数没有参数。

返回值

Return an integer number of classes


Get the SVM type the model was trained with

  • ? SVMModel::getNrClass
  • SVMModel::getSvrProbability ?
  • PHP Manual
  • SVMModel
  • Get the SVM type the model was trained with

SVMModel::getSvmType

(PECL svm >= 0.1.5)

SVMModel::getSvmType — Get the SVM type the model was trained with

说明

public SVMModel::getSvmType ( ) : int

Returns an integer value representing the type of the SVM model used, e.g SVM::C_SVC.

参数

此函数没有参数。

返回值

Return an integer SVM type


Get the sigma value for regression types

  • ? SVMModel::getSvmType
  • SVMModel::load ?
  • PHP Manual
  • SVMModel
  • Get the sigma value for regression types

SVMModel::getSvrProbability

(PECL svm >= 0.1.5)

SVMModel::getSvrProbability — Get the sigma value for regression types

说明

public SVMModel::getSvrProbability ( ) : float

For regression models, returns a sigma value. If there is no probability information or the model is not SVR, 0 is returned.

参数

此函数没有参数。

返回值

Returns a sigma value


Load a saved SVM Model

  • ? SVMModel::getSvrProbability
  • SVMModel::predict_probability ?
  • PHP Manual
  • SVMModel
  • Load a saved SVM Model

SVMModel::load

(PECL svm >= 0.1.00.1.0)

SVMModel::load — Load a saved SVM Model

说明

public SVMModel::load ( string $filename ) : bool

Load a model file ready for classification or regression.

参数

filename

The filename of the model.

返回值

Throws SVMException on error. Returns true on success.

参见

  • SVMModel::save() - Save a model to a file


Return class probabilities for previous unseen data

  • ? SVMModel::load
  • SVMModel::predict ?
  • PHP Manual
  • SVMModel
  • Return class probabilities for previous unseen data

SVMModel::predict_probability

(PECL svm >= 0.1.4)

SVMModel::predict_probability — Return class probabilities for previous unseen data

说明

public SVMModel::predict_probability ( array $data ) : float

This function accepts an array of data and attempts to predict the class, as with the predict function. Additionally, however, this function returns an array of probabilities, one per class in the model, which represent the estimated chance of the data supplied being a member of that class. Requires that the model to be used has been trained with the probability parameter set to true.

参数

data

The array to be classified. This should be a series of key => value pairs in increasing key order, but not necessarily continuous.

probabilities

The supplied value will be filled with the probabilities. This will be either null, in the case of a model without probability information, or an array where the index is the class name and the value the predicted probability.

返回值

Float the predicted value. This will be a class label in the case of classification, a real value in the case of regression. Throws SVMException on error

参见

  • SVM::predict()


Predict a value for previously unseen data

  • ? SVMModel::predict_probability
  • SVMModel::save ?
  • PHP Manual
  • SVMModel
  • Predict a value for previously unseen data

SVMModel::predict

(PECL svm >= 0.1.0)

SVMModel::predict — Predict a value for previously unseen data

说明

public SVMModel::predict ( array $data ) : float

This function accepts an array of data and attempts to predict the class or regression value based on the model extracted from previously trained data.

参数

data

The array to be classified. This should be a series of key => value pairs in increasing key order, but not necessarily continuous.

返回值

Float the predicted value. This will be a class label in the case of classification, a real value in the case of regression. Throws SVMException on error

参见

  • SVM::train() - Create a SVMModel based on training data


Save a model to a file

  • ? SVMModel::predict
  • SVN ?
  • PHP Manual
  • SVMModel
  • Save a model to a file

SVMModel::save

(PECL svm >= 0.1.0)

SVMModel::save — Save a model to a file

说明

public SVMModel::save ( string $filename ) : bool

Save the model data to a file, for later use.

参数

filename

The file to save the model to.

返回值

Throws SVMException on error. Returns true on success.

参见

  • SVMModel::load() - Load a saved SVM Model


Subversion

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • SVN 函数
    • svn_add — 计划在工作目录添加项
    • svn_auth_get_parameter — Retrieves authentication parameter
    • svn_auth_set_parameter — Sets an authentication parameter
    • svn_blame — Get the SVN blame for a file
    • svn_cat — Returns the contents of a file in a repository
    • svn_checkout — Checks out a working copy from the repository
    • svn_cleanup — Recursively cleanup a working copy directory, finishing incomplete operations and removing locks
    • svn_client_version — Returns the version of the SVN client libraries
    • svn_commit — 将修改的本地文件副本发送至版本库
    • svn_delete — Delete items from a working copy or repository
    • svn_diff — Recursively diffs two paths
    • svn_export — Export the contents of a SVN directory
    • svn_fs_abort_txn — Abort a transaction, returns true if everything is okay, false otherwise
    • svn_fs_apply_text — Creates and returns a stream that will be used to replace
    • svn_fs_begin_txn2 — Create a new transaction
    • svn_fs_change_node_prop — Return true if everything is ok, false otherwise
    • svn_fs_check_path — Determines what kind of item lives at path in a given repository fsroot
    • svn_fs_contents_changed — Return true if content is different, false otherwise
    • svn_fs_copy — Copies a file or a directory, returns true if all is ok, false otherwise
    • svn_fs_delete — Deletes a file or a directory, return true if all is ok, false otherwise
    • svn_fs_dir_entries — Enumerates the directory entries under path; returns a hash of dir names to file type
    • svn_fs_file_contents — Returns a stream to access the contents of a file from a given version of the fs
    • svn_fs_file_length — Returns the length of a file from a given version of the fs
    • svn_fs_is_dir — Return true if the path points to a directory, false otherwise
    • svn_fs_is_file — Return true if the path points to a file, false otherwise
    • svn_fs_make_dir — Creates a new empty directory, returns true if all is ok, false otherwise
    • svn_fs_make_file — Creates a new empty file, returns true if all is ok, false otherwise
    • svn_fs_node_created_rev — Returns the revision in which path under fsroot was created
    • svn_fs_node_prop — Returns the value of a property for a node
    • svn_fs_props_changed — Return true if props are different, false otherwise
    • svn_fs_revision_prop — Fetches the value of a named property
    • svn_fs_revision_root — Get a handle on a specific version of the repository root
    • svn_fs_txn_root — Creates and returns a transaction root
    • svn_fs_youngest_rev — Returns the number of the youngest revision in the filesystem
    • svn_import — Imports an unversioned path into a repository
    • svn_log — Returns the commit log messages of a repository URL
    • svn_ls — Returns list of directory contents in repository URL, optionally at revision number
    • svn_mkdir — Creates a directory in a working copy or repository
    • svn_repos_create — Create a new subversion repository at path
    • svn_repos_fs_begin_txn_for_commit — Create a new transaction
    • svn_repos_fs_commit_txn — Commits a transaction and returns the new revision
    • svn_repos_fs — Gets a handle on the filesystem for a repository
    • svn_repos_hotcopy — Make a hot-copy of the repos at repospath; copy it to destpath
    • svn_repos_open — Open a shared lock on a repository
    • svn_repos_recover — Run recovery procedures on the repository located at path
    • svn_revert — Revert changes to the working copy
    • svn_status — Returns the status of working copy files and directories
    • svn_update — Update working copy


简介

This extension implements PHP bindings for » Subversion (SVN), a version control system, allowing PHP scripts to communicate with SVN repositories and working copies without direct command line calls to the svn executable.

Warning

此扩展是实验性 的。 此扩展的表象，包括其函数名称以及其他此扩展的相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本扩展风险自担。


需求

The Subversion binaries are not necessary to use this extension. However, when compiling the extension, libsvn (the Subversion headers) must be available.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/svn

If ./configure is having trouble finding the SVN files (for example, Subversion was installed with a different prefix directory), use ./configure --with-svn=$USR_PATH to specify the directory where the include/subversion-1/ folder is located.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。

Warning

If the extension is compiled against libsvn 1.3, functions that work with working copies will fail when used on working copies created by Subversion 1.4.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SVN_REVISION_HEAD (int)
Magic number (-1) specifying the HEAD revision
Constants usable with svn_auth_set_parameter()
SVN_AUTH_PARAM_DEFAULT_USERNAME (string)
Property for default username to use when performing basic authentication
SVN_AUTH_PARAM_DEFAULT_PASSWORD (string)
Property for default password to use when performing basic authentication
SVN_AUTH_PARAM_NON_INTERACTIVE (string)
SVN_AUTH_PARAM_DONT_STORE_PASSWORDS (string)
SVN_AUTH_PARAM_NO_AUTH_CACHE (string)
SVN_AUTH_PARAM_SSL_SERVER_FAILURES (string)
SVN_AUTH_PARAM_SSL_SERVER_CERT_INFO (string)
SVN_AUTH_PARAM_CONFIG (string)
SVN_AUTH_PARAM_SERVER_GROUP (string)
SVN_AUTH_PARAM_CONFIG_DIR (string)
PHP_SVN_AUTH_PARAM_IGNORE_SSL_VERIFY_ERRORS (string)
Custom property for ignoring SSL cert verification errors
Filesystem constants
SVN_FS_CONFIG_FS_TYPE (string)
Configuration key that determines filesystem type
SVN_FS_TYPE_BDB (string)
Filesystem is Berkeley-DB implementation
SVN_FS_TYPE_FSFS (string)
Filesystem is native-filesystem implementation
Reserved property constants
SVN_PROP_REVISION_DATE (string)
svn:date
SVN_PROP_REVISION_ORIG_DATE (string)
svn:original-date
SVN_PROP_REVISION_AUTHOR (string)
svn:author
SVN_PROP_REVISION_LOG (string)
svn:log
Working copy status constants
SVN_WC_STATUS_NONE (int)
Status does not exist
SVN_WC_STATUS_UNVERSIONED (int)
Item is not versioned in working copy
SVN_WC_STATUS_NORMAL (int)
Item exists, nothing else is happening
SVN_WC_STATUS_ADDED (int)
Item is scheduled for addition
SVN_WC_STATUS_MISSING (int)
Item is versioned but missing from the working copy
SVN_WC_STATUS_DELETED (int)
Item is scheduled for deletion
SVN_WC_STATUS_REPLACED (int)
Item was deleted and then re-added
SVN_WC_STATUS_MODIFIED (int)
Item (text or properties) was modified
SVN_WC_STATUS_MERGED (int)
Item's local modifications were merged with repository modifications
SVN_WC_STATUS_CONFLICTED (int)
Item's local modifications conflicted with repository modifications
SVN_WC_STATUS_IGNORED (int)
Item is unversioned but configured to be ignored
SVN_WC_STATUS_OBSTRUCTED (int)
Unversioned item is in the way of a versioned resource
SVN_WC_STATUS_EXTERNAL (int)
Unversioned path that is populated using svn:externals
SVN_WC_STATUS_INCOMPLETE (int)
Directory does not contain complete entries list
Node type constants
SVN_NODE_NONE (int)
Absent
SVN_NODE_FILE (int)
File
SVN_NODE_DIR (int)
Directory
SVN_NODE_UNKNOWN (int)
Something Subversion cannot identify


SVN 函数

Table of Contents

  • svn_add — 计划在工作目录添加项
  • svn_auth_get_parameter — Retrieves authentication parameter
  • svn_auth_set_parameter — Sets an authentication parameter
  • svn_blame — Get the SVN blame for a file
  • svn_cat — Returns the contents of a file in a repository
  • svn_checkout — Checks out a working copy from the repository
  • svn_cleanup — Recursively cleanup a working copy directory, finishing incomplete operations and removing locks
  • svn_client_version — Returns the version of the SVN client libraries
  • svn_commit — 将修改的本地文件副本发送至版本库
  • svn_delete — Delete items from a working copy or repository
  • svn_diff — Recursively diffs two paths
  • svn_export — Export the contents of a SVN directory
  • svn_fs_abort_txn — Abort a transaction, returns true if everything is okay, false otherwise
  • svn_fs_apply_text — Creates and returns a stream that will be used to replace
  • svn_fs_begin_txn2 — Create a new transaction
  • svn_fs_change_node_prop — Return true if everything is ok, false otherwise
  • svn_fs_check_path — Determines what kind of item lives at path in a given repository fsroot
  • svn_fs_contents_changed — Return true if content is different, false otherwise
  • svn_fs_copy — Copies a file or a directory, returns true if all is ok, false otherwise
  • svn_fs_delete — Deletes a file or a directory, return true if all is ok, false otherwise
  • svn_fs_dir_entries — Enumerates the directory entries under path; returns a hash of dir names to file type
  • svn_fs_file_contents — Returns a stream to access the contents of a file from a given version of the fs
  • svn_fs_file_length — Returns the length of a file from a given version of the fs
  • svn_fs_is_dir — Return true if the path points to a directory, false otherwise
  • svn_fs_is_file — Return true if the path points to a file, false otherwise
  • svn_fs_make_dir — Creates a new empty directory, returns true if all is ok, false otherwise
  • svn_fs_make_file — Creates a new empty file, returns true if all is ok, false otherwise
  • svn_fs_node_created_rev — Returns the revision in which path under fsroot was created
  • svn_fs_node_prop — Returns the value of a property for a node
  • svn_fs_props_changed — Return true if props are different, false otherwise
  • svn_fs_revision_prop — Fetches the value of a named property
  • svn_fs_revision_root — Get a handle on a specific version of the repository root
  • svn_fs_txn_root — Creates and returns a transaction root
  • svn_fs_youngest_rev — Returns the number of the youngest revision in the filesystem
  • svn_import — Imports an unversioned path into a repository
  • svn_log — Returns the commit log messages of a repository URL
  • svn_ls — Returns list of directory contents in repository URL, optionally at revision number
  • svn_mkdir — Creates a directory in a working copy or repository
  • svn_repos_create — Create a new subversion repository at path
  • svn_repos_fs_begin_txn_for_commit — Create a new transaction
  • svn_repos_fs_commit_txn — Commits a transaction and returns the new revision
  • svn_repos_fs — Gets a handle on the filesystem for a repository
  • svn_repos_hotcopy — Make a hot-copy of the repos at repospath; copy it to destpath
  • svn_repos_open — Open a shared lock on a repository
  • svn_repos_recover — Run recovery procedures on the repository located at path
  • svn_revert — Revert changes to the working copy
  • svn_status — Returns the status of working copy files and directories
  • svn_update — Update working copy


计划在工作目录添加项

  • ? SVN 函数
  • svn_auth_get_parameter ?
  • PHP Manual
  • SVN 函数
  • 计划在工作目录添加项

svn_add

(PECL svn >= 0.1.0)

svn_add — 计划在工作目录添加项

说明

svn_add ( string $path , bool $recursive = true , bool $force = false ) : bool

添加文件, 目录或者链接在路径 到工作目录。将在下一次执行svn_commit() 时把工作副本添加到项目中。

参数

path

添加项的路径。

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

recursive

如果添加项为目录是否递归目录下所有文件。 默认为 true

force

If true, Subversion will recurse into already versioned directories in order to add unversioned files that may be hiding in those directories. Default is false

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 svn_add() 例子

在工作目录使用命令 svn status 返回值:

$ svn status
?      foobar.txt

...代码:

<?php
svn_add('foobar.txt');
?>

...计划 foobar.txt 文件添加到版本库。

参见

  • » SVN documentation on svn add


Retrieves authentication parameter

  • ? svn_add
  • svn_auth_set_parameter ?
  • PHP Manual
  • SVN 函数
  • Retrieves authentication parameter

svn_auth_get_parameter

(PECL svn >= 0.1.0)

svn_auth_get_parameter — Retrieves authentication parameter

说明

svn_auth_get_parameter ( string $key ) : string

Retrieves authentication parameter at key. For a list of valid keys and their meanings, consult the authentication constants list.

参数

key

String key name. Use the authentication constants defined by this extension to specify a key.

返回值

Returns the string value of the parameter at key; returns null if parameter does not exist.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • svn_auth_set_parameter() - Sets an authentication parameter
  • Authentication constants


Sets an authentication parameter

  • ? svn_auth_get_parameter
  • svn_blame ?
  • PHP Manual
  • SVN 函数
  • Sets an authentication parameter

svn_auth_set_parameter

(PECL svn >= 0.1.0)

svn_auth_set_parameter — Sets an authentication parameter

说明

svn_auth_set_parameter ( string $key , string $value ) : void

Sets authentication parameter at key to value. For a list of valid keys and their meanings, consult the authentication constants list.

参数

key

String key name. Use the authentication constants defined by this extension to specify a key.

value

String value to set to parameter at key. Format of value varies with the parameter.

返回值

没有返回值。

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Default authentication example

This example configures SVN so that the default username to use is 'Bob' and the default password is 'abc123':

<?php
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, 'Bob');
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_PASSWORD, 'abc123');
?>

参见

  • svn_auth_get_parameter() - Retrieves authentication parameter
  • Authentication constants


Get the SVN blame for a file

  • ? svn_auth_set_parameter
  • svn_cat ?
  • PHP Manual
  • SVN 函数
  • Get the SVN blame for a file

svn_blame

(PECL svn >= 0.3.0)

svn_blame — Get the SVN blame for a file

说明

svn_blame ( string $repository_url , int $revision_no = SVN_REVISION_HEAD ) : array

Get the SVN blame of a file from a repository URL.

参数

repository_url

The repository URL.

revision_no

The revision number.

返回值

An array of SVN blame information separated by line which includes the revision number, line number, line of code, author, and date.

范例

Example #1 svn_blame() example

<?php
$svnurl = 'http://svn.example.org/svnroot/foo/trunk/index.php';

print_r( svn_blame($svnurl) );

?>

以上例程的输出类似于：

Array
(
    [0] = Array
          (
           [rev] = 1
           [line_no] = 1
           [line] = Hello World
           [author] = joesmith
           [date] = 2007-07-02T05:51:26.628396Z
          )
    [1] = Array
          ...

参见

  • svn_diff() - Recursively diffs two paths
  • svn_logs()
  • svn_status() - Returns the status of working copy files and directories


Returns the contents of a file in a repository

  • ? svn_blame
  • svn_checkout ?
  • PHP Manual
  • SVN 函数
  • Returns the contents of a file in a repository

svn_cat

(PECL svn >= 0.1.0)

svn_cat — Returns the contents of a file in a repository

说明

svn_cat ( string $repos_url , int $revision_no = ? ) : string

Returns the contents of the URL repos_url to a file in the repository, optionally at revision number revision_no.

参数

repos_url

String URL path to item in a repository.

revision_no

Integer revision number of item to retrieve, default is the HEAD revision.

返回值

Returns the string contents of the item from the repository on success, and false on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Basic example

This example retrieves the contents of a file at revision 28:

<?php
$contents = svn_cat('http://www.example.com/svnroot/calc/gui.c', 28)
?>

参见

  • svn_list()
  • » SVN documentation on svn cat


Checks out a working copy from the repository

  • ? svn_cat
  • svn_cleanup ?
  • PHP Manual
  • SVN 函数
  • Checks out a working copy from the repository

svn_checkout

(PECL svn >= 0.1.0)

svn_checkout — Checks out a working copy from the repository

说明

svn_checkout ( string $repos , string $targetpath , int $revision = ? , int $flags = 0 ) : bool

Checks out a working copy from the repository at repos to targetpath at revision revision.

参数

repos

String URL path to directory in repository to check out.

targetpath

String local path to directory to check out in to

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

revision

Integer revision number of repository to check out. Default is HEAD, the most recent revision.

flags

Any combination of SVN_NON_RECURSIVE and SVN_IGNORE_EXTERNALS.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Basic example

This example demonstrates how to check out a directory from a repository to a directory named calc:

<?php
svn_checkout('http://www.example.com/svnroot/calc/trunk', dirname(__FILE__) . '/calc');
?>

The dirname(__FILE__) call is necessary in order to convert the calc relative path into an absolute one. If calc exists, you can also use realpath() to retrieve an absolute path.

参见

  • svn_add() - 计划在工作目录添加项
  • svn_commit() - 将修改的本地文件副本发送至版本库
  • svn_status() - Returns the status of working copy files and directories
  • svn_update() - Update working copy
  • » SVN documentation on svn checkout


Recursively cleanup a working copy directory, finishing incomplete operations and removing locks

  • ? svn_checkout
  • svn_client_version ?
  • PHP Manual
  • SVN 函数
  • Recursively cleanup a working copy directory, finishing incomplete operations and removing locks

svn_cleanup

(PECL svn >= 0.1.0)

svn_cleanup — Recursively cleanup a working copy directory, finishing incomplete operations and removing locks

说明

svn_cleanup ( string $workingdir ) : bool

Recursively cleanup working copy directory workingdir, finishing any incomplete operations and removing working copy locks. Use when a working copy is in limbo and needs to be usable again.

参数

workingdir

String path to local working directory to cleanup

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Basic example

This example demonstrates clean up of a working copy in a directory named help-me:

<?php
svn_cleanup(realpath('help-me'));
?>

The realpath() call is necessary due to SVN's quirky handling of relative paths.

参见

  • update()
  • » SVN documentation on svn cleanup


Returns the version of the SVN client libraries

  • ? svn_cleanup
  • svn_commit ?
  • PHP Manual
  • SVN 函数
  • Returns the version of the SVN client libraries

svn_client_version

(PECL svn >= 0.1.0)

svn_client_version — Returns the version of the SVN client libraries

说明

svn_client_version ( ) : string

Returns the version of the SVN client libraries

返回值

String version number, usually in form of x.y.z.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Basic example

<?php
echo svn_client_version();
?>

以上例程的输出类似于：

1.3.1


将修改的本地文件副本发送至版本库

  • ? svn_client_version
  • svn_delete ?
  • PHP Manual
  • SVN 函数
  • 将修改的本地文件副本发送至版本库

svn_commit

(PECL svn >= 0.1.0)

svn_commit — 将修改的本地文件副本发送至版本库

说明

svn_commit ( string $log , array $targets , bool $recursive = true ) : array

提交本地文件副本的改变使用参数 targets ，使用 log 参数作为提交日志，targets 参数默认使用递归，recursive 参数设置为 false 将不使用递归。

Note: 此方法没有指定任何认证参数，用户名和密码必须使用 svn_auth_set_parameter()

参数

log

长文本的提交日志

targets

本地文件路径数组

Warning

此参数必须是一个数组，一个单一字符串是不被接收的。

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

recursive

布尔类型，是否禁用 targets 递归。默认值为 true

返回值

返回数组信息如下:

array(
    0 => 提交版本号
    1 => ISO 8601 格式的提交时间
    2 => 提交者
)

失败返回 false

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 基本示例

这个例子是将一个计算程序目录提交到一个版本库，使用用户名为 Bob 以及密码为 abc123 (提倡可以使用强密码)

<?php
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, 'Bob');
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_PASSWORD, 'abc123');
var_dump(svn_commit('Log message of Bob\'s commit', array(realpath('calculator'))));
?>

以上例程会输出：

array(
  0 => 1415,
  1 => '2007-05-26T01:44:28.453125Z',
  2 => 'Bob'
)

参见

  • svn_auth_set_parameter() - Sets an authentication parameter
  • » 参见 svn 官方文档


Delete items from a working copy or repository

  • ? svn_commit
  • svn_diff ?
  • PHP Manual
  • SVN 函数
  • Delete items from a working copy or repository

svn_delete

(PECL svn >= 0.4.0)

svn_delete — Delete items from a working copy or repository

说明

svn_delete ( string $path , bool $force = false ) : bool

Deletes the file, directory or symbolic link at path from the working directory. The item will be deleted from the repository the next time you call svn_commit() on the working copy.

参数

path

Path of item to delete.

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

force

If true, the file will be deleted even if it has local modifications. Otherwise, local modifications will result in a failure. Default is false

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参见

  • » SVN documentation on svn delete


Recursively diffs two paths

  • ? svn_delete
  • svn_export ?
  • PHP Manual
  • SVN 函数
  • Recursively diffs two paths

svn_diff

(PECL svn >= 0.1.0)

svn_diff — Recursively diffs two paths

说明

svn_diff ( string $path1 , int $rev1 , string $path2 , int $rev2 ) : array

Recursively diffs two paths, path1 and path2.

Note:

This is not a general-purpose diff utility. Only local files that are versioned may be diffed: other files will fail.

参数

path1

First path to diff. This can be a URL to a file/directory in an SVN repository or a local file/directory path.

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

Warning

If a local file path has only backslashes and no forward slashes, this extension will fail to find the path. Always replace all backslashes with forward slashes when using this function.

rev1

First path's revision number. Use SVN_REVISION_HEAD to specify the most recent revision.

path2

Second path to diff. See path1 for description.

rev2

Second path's revision number. See rev1 for description.

返回值

Returns an array-list consisting of two streams: the first is the diff output and the second contains error stream output. The streams can be read using fread(). Returns false or null on error.

The diff output will, by default, be in the form of Subversion's custom unified diff format, but an » external diff engine may be used depending on Subversion's configuration.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Basic example

This example demonstrates the basic usage of this function, and the retrieval of contents from the stream:

<?php
list($diff, $errors) = svn_diff(
    'http://www.example.com/svnroot/trunk/foo', SVN_REVISION_HEAD,
    'http://www.example.com/svnroot/branches/dev/foo', SVN_REVISION_HEAD
);
if (!$diff) exit;
$contents = '';
while (!feof($diff)) {
  $contents .= fread($diff, 8192);
}
fclose($diff);
fclose($errors);
var_dump($contents);
?>

以上例程会输出：

Index: http://www.example.com/svnroot/trunk/foo
===================================================================
--- http://www.example.com/svnroot/trunk/foo        (.../foo) (revision 23)
+++ http://www.example.com/svnroot/branches/dev/foo (.../foo) (revision 27)
 // further diff output

Example #2 Diffing two revisions of a repository path

This example implements a wrapper function that allows a user to easily diff two revisions of the same item using an external repository path (the default syntax is somewhat verbose):

<?php
function svn_diff_same_item($path, $rev1, $rev2) {
    return svn_diff($path, $rev1, $path, $rev2);
}
?>

Example #3 Portably diffing two local files

This example implements a wrapper function that portably diffs two local files, compensating for the realpath() fix and the backslashes bug:

<?php
function svn_diff_local($path1, $rev1, $path2, $rev2) {
    $path1 = str_replace('\\', '/', realpath($path1));
    $path2 = str_replace('\\', '/', realpath($path2));
    return svn_diff($path1, $rev1, $path2, $rev2);
}
?>

参见

  • » SVN documentation on svn diff


Export the contents of a SVN directory

  • ? svn_diff
  • svn_fs_abort_txn ?
  • PHP Manual
  • SVN 函数
  • Export the contents of a SVN directory

svn_export

(PECL svn >= 0.3.0)

svn_export — Export the contents of a SVN directory

说明

svn_export ( string $frompath , string $topath , bool $working_copy = true , int $revision_no = -1 ) : bool

Export the contents of either a working copy or repository into a 'clean' directory.

参数

frompath

The path to the current repository.

topath

The path to the new repository.

working_copy

If true, it will export uncommitted files from the working copy.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 svn_export() example

<?php
$working_dir     = '../';
$new_working_dir = '/home/user/devel/foo/trunk';

svn_export($working_dir, $new_working_dir);
?>

参见

  • svn_import() - Imports an unversioned path into a repository


Abort a transaction, returns true if everything is okay, false otherwise

  • ? svn_export
  • svn_fs_apply_text ?
  • PHP Manual
  • SVN 函数
  • Abort a transaction, returns true if everything is okay, false otherwise

svn_fs_abort_txn

(PECL svn >= 0.2.0)

svn_fs_abort_txn — Abort a transaction, returns true if everything is okay, false otherwise

说明

svn_fs_abort_txn ( resource $txn ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Abort a transaction, returns true if everything is okay, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Creates and returns a stream that will be used to replace

  • ? svn_fs_abort_txn
  • svn_fs_begin_txn2 ?
  • PHP Manual
  • SVN 函数
  • Creates and returns a stream that will be used to replace

svn_fs_apply_text

(PECL svn >= 0.2.0)

svn_fs_apply_text — Creates and returns a stream that will be used to replace

说明

svn_fs_apply_text ( resource $root , string $path ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Creates and returns a stream that will be used to replace

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Create a new transaction

  • ? svn_fs_apply_text
  • svn_fs_change_node_prop ?
  • PHP Manual
  • SVN 函数
  • Create a new transaction

svn_fs_begin_txn2

(PECL svn >= 0.2.0)

svn_fs_begin_txn2 — Create a new transaction

说明

svn_fs_begin_txn2 ( resource $repos , int $rev ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Create a new transaction

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Return true if everything is ok, false otherwise

  • ? svn_fs_begin_txn2
  • svn_fs_check_path ?
  • PHP Manual
  • SVN 函数
  • Return true if everything is ok, false otherwise

svn_fs_change_node_prop

(PECL svn >= 0.2.0)

svn_fs_change_node_prop — Return true if everything is ok, false otherwise

说明

svn_fs_change_node_prop ( resource $root , string $path , string $name , string $value ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Return true if everything is ok, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Determines what kind of item lives at path in a given repository fsroot

  • ? svn_fs_change_node_prop
  • svn_fs_contents_changed ?
  • PHP Manual
  • SVN 函数
  • Determines what kind of item lives at path in a given repository fsroot

svn_fs_check_path

(PECL svn >= 0.1.0)

svn_fs_check_path — Determines what kind of item lives at path in a given repository fsroot

说明

svn_fs_check_path ( resource $fsroot , string $path ) : int
Warning

本函数还未编写文档，仅有参数列表。

Determines what kind of item lives at path in a given repository fsroot

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Return true if content is different, false otherwise

  • ? svn_fs_check_path
  • svn_fs_copy ?
  • PHP Manual
  • SVN 函数
  • Return true if content is different, false otherwise

svn_fs_contents_changed

(PECL svn >= 0.2.0)

svn_fs_contents_changed — Return true if content is different, false otherwise

说明

svn_fs_contents_changed ( resource $root1 , string $path1 , resource $root2 , string $path2 ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Return true if content is different, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Copies a file or a directory, returns true if all is ok, false otherwise

  • ? svn_fs_contents_changed
  • svn_fs_delete ?
  • PHP Manual
  • SVN 函数
  • Copies a file or a directory, returns true if all is ok, false otherwise

svn_fs_copy

(PECL svn >= 0.2.0)

svn_fs_copy — Copies a file or a directory, returns true if all is ok, false otherwise

说明

svn_fs_copy ( resource $from_root , string $from_path , resource $to_root , string $to_path ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Copies a file or a directory, returns true if all is ok, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Deletes a file or a directory, return true if all is ok, false otherwise

  • ? svn_fs_copy
  • svn_fs_dir_entries ?
  • PHP Manual
  • SVN 函数
  • Deletes a file or a directory, return true if all is ok, false otherwise

svn_fs_delete

(PECL svn >= 0.2.0)

svn_fs_delete — Deletes a file or a directory, return true if all is ok, false otherwise

说明

svn_fs_delete ( resource $root , string $path ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Deletes a file or a directory, return true if all is ok, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Enumerates the directory entries under path; returns a hash of dir names to file type

  • ? svn_fs_delete
  • svn_fs_file_contents ?
  • PHP Manual
  • SVN 函数
  • Enumerates the directory entries under path; returns a hash of dir names to file type

svn_fs_dir_entries

(PECL svn >= 0.1.0)

svn_fs_dir_entries — Enumerates the directory entries under path; returns a hash of dir names to file type

说明

svn_fs_dir_entries ( resource $fsroot , string $path ) : array
Warning

本函数还未编写文档，仅有参数列表。

Enumerates the directory entries under path; returns a hash of dir names to file type

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Returns a stream to access the contents of a file from a given version of the fs

  • ? svn_fs_dir_entries
  • svn_fs_file_length ?
  • PHP Manual
  • SVN 函数
  • Returns a stream to access the contents of a file from a given version of the fs

svn_fs_file_contents

(PECL svn >= 0.1.0)

svn_fs_file_contents — Returns a stream to access the contents of a file from a given version of the fs

说明

svn_fs_file_contents ( resource $fsroot , string $path ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Returns a stream to access the contents of a file from a given version of the fs

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Returns the length of a file from a given version of the fs

  • ? svn_fs_file_contents
  • svn_fs_is_dir ?
  • PHP Manual
  • SVN 函数
  • Returns the length of a file from a given version of the fs

svn_fs_file_length

(PECL svn >= 0.1.0)

svn_fs_file_length — Returns the length of a file from a given version of the fs

说明

svn_fs_file_length ( resource $fsroot , string $path ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the length of a file from a given version of the fs

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Return true if the path points to a directory, false otherwise

  • ? svn_fs_file_length
  • svn_fs_is_file ?
  • PHP Manual
  • SVN 函数
  • Return true if the path points to a directory, false otherwise

svn_fs_is_dir

(PECL svn >= 0.2.0)

svn_fs_is_dir — Return true if the path points to a directory, false otherwise

说明

svn_fs_is_dir ( resource $root , string $path ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Return true if the path points to a directory, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Return true if the path points to a file, false otherwise

  • ? svn_fs_is_dir
  • svn_fs_make_dir ?
  • PHP Manual
  • SVN 函数
  • Return true if the path points to a file, false otherwise

svn_fs_is_file

(PECL svn >= 0.2.0)

svn_fs_is_file — Return true if the path points to a file, false otherwise

说明

svn_fs_is_file ( resource $root , string $path ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Return true if the path points to a file, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Creates a new empty directory, returns true if all is ok, false otherwise

  • ? svn_fs_is_file
  • svn_fs_make_file ?
  • PHP Manual
  • SVN 函数
  • Creates a new empty directory, returns true if all is ok, false otherwise

svn_fs_make_dir

(PECL svn >= 0.2.0)

svn_fs_make_dir — Creates a new empty directory, returns true if all is ok, false otherwise

说明

svn_fs_make_dir ( resource $root , string $path ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Creates a new empty directory, returns true if all is ok, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Creates a new empty file, returns true if all is ok, false otherwise

  • ? svn_fs_make_dir
  • svn_fs_node_created_rev ?
  • PHP Manual
  • SVN 函数
  • Creates a new empty file, returns true if all is ok, false otherwise

svn_fs_make_file

(PECL svn >= 0.2.0)

svn_fs_make_file — Creates a new empty file, returns true if all is ok, false otherwise

说明

svn_fs_make_file ( resource $root , string $path ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Creates a new empty file, returns true if all is ok, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Returns the revision in which path under fsroot was created

  • ? svn_fs_make_file
  • svn_fs_node_prop ?
  • PHP Manual
  • SVN 函数
  • Returns the revision in which path under fsroot was created

svn_fs_node_created_rev

(PECL svn >= 0.1.0)

svn_fs_node_created_rev — Returns the revision in which path under fsroot was created

说明

svn_fs_node_created_rev ( resource $fsroot , string $path ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the revision in which path under fsroot was created

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Returns the value of a property for a node

  • ? svn_fs_node_created_rev
  • svn_fs_props_changed ?
  • PHP Manual
  • SVN 函数
  • Returns the value of a property for a node

svn_fs_node_prop

(PECL svn >= 0.1.0)

svn_fs_node_prop — Returns the value of a property for a node

说明

svn_fs_node_prop ( resource $fsroot , string $path , string $propname ) : string
Warning

本函数还未编写文档，仅有参数列表。

Returns the value of a property for a node

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Return true if props are different, false otherwise

  • ? svn_fs_node_prop
  • svn_fs_revision_prop ?
  • PHP Manual
  • SVN 函数
  • Return true if props are different, false otherwise

svn_fs_props_changed

(PECL svn >= 0.2.0)

svn_fs_props_changed — Return true if props are different, false otherwise

说明

svn_fs_props_changed ( resource $root1 , string $path1 , resource $root2 , string $path2 ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Return true if props are different, false otherwise

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Fetches the value of a named property

  • ? svn_fs_props_changed
  • svn_fs_revision_root ?
  • PHP Manual
  • SVN 函数
  • Fetches the value of a named property

svn_fs_revision_prop

(PECL svn >= 0.1.0)

svn_fs_revision_prop — Fetches the value of a named property

说明

svn_fs_revision_prop ( resource $fs , int $revnum , string $propname ) : string
Warning

本函数还未编写文档，仅有参数列表。

Fetches the value of a named property

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Get a handle on a specific version of the repository root

  • ? svn_fs_revision_prop
  • svn_fs_txn_root ?
  • PHP Manual
  • SVN 函数
  • Get a handle on a specific version of the repository root

svn_fs_revision_root

(PECL svn >= 0.1.0)

svn_fs_revision_root — Get a handle on a specific version of the repository root

说明

svn_fs_revision_root ( resource $fs , int $revnum ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Get a handle on a specific version of the repository root

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Creates and returns a transaction root

  • ? svn_fs_revision_root
  • svn_fs_youngest_rev ?
  • PHP Manual
  • SVN 函数
  • Creates and returns a transaction root

svn_fs_txn_root

(PECL svn >= 0.2.0)

svn_fs_txn_root — Creates and returns a transaction root

说明

svn_fs_txn_root ( resource $txn ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Creates and returns a transaction root

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Returns the number of the youngest revision in the filesystem

  • ? svn_fs_txn_root
  • svn_import ?
  • PHP Manual
  • SVN 函数
  • Returns the number of the youngest revision in the filesystem

svn_fs_youngest_rev

(PECL svn >= 0.1.0)

svn_fs_youngest_rev — Returns the number of the youngest revision in the filesystem

说明

svn_fs_youngest_rev ( resource $fs ) : int
Warning

本函数还未编写文档，仅有参数列表。

Returns the number of the youngest revision in the filesystem

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Imports an unversioned path into a repository

  • ? svn_fs_youngest_rev
  • svn_log ?
  • PHP Manual
  • SVN 函数
  • Imports an unversioned path into a repository

svn_import

(PECL svn >= 0.2.0)

svn_import — Imports an unversioned path into a repository

说明

svn_import ( string $path , string $url , bool $nonrecursive ) : bool

Commits unversioned path into repository at url. If path is a directory and nonrecursive is false, the directory will be imported recursively.

参数

path

Path of file or directory to import.

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

url

Repository URL to import into.

nonrecursive

Whether or not to refrain from recursively processing directories.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Basic example

This example demonstrates a basic use-case of this function. To import a directory named new-files into the repository at http://www.example.com/svnroot/incoming/abc, use:

<?php
svn_import(realpath('new-files'), 'http://www.example.com/svnroot/incoming/abc', false);
?>

参见

  • svn_add() - 计划在工作目录添加项
  • » SVN documentation for svn import


Returns the commit log messages of a repository URL

  • ? svn_import
  • svn_ls ?
  • PHP Manual
  • SVN 函数
  • Returns the commit log messages of a repository URL

svn_log

(PECL svn >= 0.1.0)

svn_log — Returns the commit log messages of a repository URL

说明

svn_log ( string $repos_url , int $start_revision = ? , int $end_revision = ? , int $limit = 0 , int $flags = SVN_DISCOVER_CHANGED_PATHS | SVN_STOP_ON_COPY ) : array

svn_log() returns the complete history of the item at the repository URL repos_url, or the history of a specific revision if start_revision is set. This function is equivalent to svn log --verbose -r $start_revision $repos_url.

参数

repos_url

Repository URL of the item to retrieve log history from.

start_revision

Revision number of the first log to retrieve. Use SVN_REVISION_HEAD to retrieve the log from the most recent revision.

end_revision

Revision number of the last log to retrieve. Defaults to start_revision if specified or to SVN_REVISION_INITIAL otherwise.

limit

Number of logs to retrieve.

flags

Any combination of SVN_OMIT_MESSAGES, SVN_DISCOVER_CHANGED_PATHS and SVN_STOP_ON_COPY.

返回值

On success, this function returns an array file listing in the format of:

[0] => Array, ordered most recent (highest) revision first
(
    [rev] => integer revision number
    [author] => string author name
    [msg] => string log message
    [date] => string date formatted per ISO 8601, i.e. date('c')
    [paths] => Array, describing changed files
        (
            [0] => Array
                (
                    [action] => string letter signifying change
                    [path] =>  absolute repository path of changed file
                )
            [1] => ...
        )
)
[1] => ...

Note:

The output will always be a numerically indexed array of arrays, even when there are none or only one log message(s).

The value of action is a subset of the » status output in the first column, where possible values are:

Actions
Letter | Description
M | Item/props was modified
A | Item was added
D | Item was deleted
R | Item was replaced

If no changes were made to the item, an empty array is returned.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 svn_log() example

<?php
print_r( svn_log('http://www.example.com/', 23) );
?>

以上例程的输出类似于：

Array
(
    [0] => Array
    (
        [rev] => 23
        [author] => 'joe'
        [msg] => 'Add cheese and salami to our sandwich.'
        [date] => '2007-04-06T16:00:27-04:00'
        [paths] => Array
            (
                [0] => Array
                    (
                        [action] => 'M'
                        [path] =>  '/sandwich.txt'
                    )
            )
    )
)

参见

  • » SVN documentation on svn log


Returns list of directory contents in repository URL, optionally at revision number

  • ? svn_log
  • svn_mkdir ?
  • PHP Manual
  • SVN 函数
  • Returns list of directory contents in repository URL, optionally at revision number

svn_ls

(PECL svn >= 0.1.0)

svn_ls — Returns list of directory contents in repository URL, optionally at revision number

说明

svn_ls ( string $repos_url , int $revision_no = SVN_REVISION_HEAD , bool $recurse = false , bool $peg = false ) : array

This function queries the repository URL and returns a list of files and directories, optionally from a specific revision. This is equivalent to svn list $repos_url[@$revision_no]

Note:

This function does not work with working copies. repos_url must be a repository URL.

参数

url

URL of the repository, eg. http://www.example.com/svnroot. To access a local Subversion repository via filesystem, use the file URI scheme, eg. file:///home/user/svn-repos

revision

Integer revision number to retrieve listing of. When omitted, the HEAD revision is used.

recurse

Enables recursion.

返回值

On success, this function returns an array file listing in the format of:

[0] => Array
    (
        [created_rev] => integer revision number of last edit
        [last_author] => string author name of last edit
        [size] => integer byte file size of file
        [time] => string date of last edit in form 'M d H:i'
                  or 'M d Y', depending on how old the file is
        [time_t] => integer unix timestamp of last edit
        [name] => name of file/directory
        [type] => type, can be 'file' or 'dir'
    )
[1] => ...

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 svn_ls() example

<?php
print_r( svn_ls('http://www.example.com/svnroot/') );
?>

以上例程的输出类似于：

Array
(
    [0] => Array
        (
            [created_rev] => 20
            [last_author] => Joe
            [size] => 0
            [time] => Apr 02 09:28
            [time_t] => 1175520529
            [name] => tags
            [type] => dir
        )
    [1] => Array
        (
            [created_rev] => 23
            [last_author] => Bob
            [size] => 0
            [time] => Apr 02 15:15
            [time_t] => 1175541322
            [name] => trunk
            [type] => dir
        )
)

参见

  • » SVN documentation on svn list


Creates a directory in a working copy or repository

  • ? svn_ls
  • svn_repos_create ?
  • PHP Manual
  • SVN 函数
  • Creates a directory in a working copy or repository

svn_mkdir

(PECL svn >= 0.4.0)

svn_mkdir — Creates a directory in a working copy or repository

说明

svn_mkdir ( string $path , string $log_message = ? ) : bool

Creates a directory in a working copy or repository.

参数

path

The path to the working copy or repository.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • svn_add() - 计划在工作目录添加项
  • svn_copy()


Create a new subversion repository at path

  • ? svn_mkdir
  • svn_repos_fs_begin_txn_for_commit ?
  • PHP Manual
  • SVN 函数
  • Create a new subversion repository at path

svn_repos_create

(PECL svn >= 0.1.0)

svn_repos_create — Create a new subversion repository at path

说明

svn_repos_create ( string $path , array $config = ? , array $fsconfig = ? ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Create a new subversion repository at path

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Create a new transaction

  • ? svn_repos_create
  • svn_repos_fs_commit_txn ?
  • PHP Manual
  • SVN 函数
  • Create a new transaction

svn_repos_fs_begin_txn_for_commit

(PECL svn >= 0.2.0)

svn_repos_fs_begin_txn_for_commit — Create a new transaction

说明

svn_repos_fs_begin_txn_for_commit ( resource $repos , int $rev , string $author , string $log_msg ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Create a new transaction

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Commits a transaction and returns the new revision

  • ? svn_repos_fs_begin_txn_for_commit
  • svn_repos_fs ?
  • PHP Manual
  • SVN 函数
  • Commits a transaction and returns the new revision

svn_repos_fs_commit_txn

(PECL svn >= 0.2.0)

svn_repos_fs_commit_txn — Commits a transaction and returns the new revision

说明

svn_repos_fs_commit_txn ( resource $txn ) : int
Warning

本函数还未编写文档，仅有参数列表。

Commits a transaction and returns the new revision

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Gets a handle on the filesystem for a repository

  • ? svn_repos_fs_commit_txn
  • svn_repos_hotcopy ?
  • PHP Manual
  • SVN 函数
  • Gets a handle on the filesystem for a repository

svn_repos_fs

(PECL svn >= 0.1.0)

svn_repos_fs — Gets a handle on the filesystem for a repository

说明

svn_repos_fs ( resource $repos ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Gets a handle on the filesystem for a repository

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Make a hot-copy of the repos at repospath; copy it to destpath

  • ? svn_repos_fs
  • svn_repos_open ?
  • PHP Manual
  • SVN 函数
  • Make a hot-copy of the repos at repospath; copy it to destpath

svn_repos_hotcopy

(PECL svn >= 0.1.0)

svn_repos_hotcopy — Make a hot-copy of the repos at repospath; copy it to destpath

说明

svn_repos_hotcopy ( string $repospath , string $destpath , bool $cleanlogs ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Make a hot-copy of the repos at repospath; copy it to destpath

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Open a shared lock on a repository

  • ? svn_repos_hotcopy
  • svn_repos_recover ?
  • PHP Manual
  • SVN 函数
  • Open a shared lock on a repository

svn_repos_open

(PECL svn >= 0.1.0)

svn_repos_open — Open a shared lock on a repository

说明

svn_repos_open ( string $path ) : resource
Warning

本函数还未编写文档，仅有参数列表。

Open a shared lock on a repository.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Run recovery procedures on the repository located at path

  • ? svn_repos_open
  • svn_revert ?
  • PHP Manual
  • SVN 函数
  • Run recovery procedures on the repository located at path

svn_repos_recover

(PECL svn >= 0.1.0)

svn_repos_recover — Run recovery procedures on the repository located at path

说明

svn_repos_recover ( string $path ) : bool
Warning

本函数还未编写文档，仅有参数列表。

Run recovery procedures on the repository located at path.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。


Revert changes to the working copy

  • ? svn_repos_recover
  • svn_status ?
  • PHP Manual
  • SVN 函数
  • Revert changes to the working copy

svn_revert

(PECL svn >= 0.3.0)

svn_revert — Revert changes to the working copy

说明

svn_revert ( string $path , bool $recursive = false ) : bool

Revert any local changes to the path in a working copy.

参数

path

The path to the working repository.

recursive

Optionally make recursive changes.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • svn_delete() - Delete items from a working copy or repository
  • svn_export() - Export the contents of a SVN directory


Returns the status of working copy files and directories

  • ? svn_revert
  • svn_update ?
  • PHP Manual
  • SVN 函数
  • Returns the status of working copy files and directories

svn_status

(PECL svn >= 0.1.0)

svn_status — Returns the status of working copy files and directories

说明

svn_status ( string $path , int $flags = 0 ) : array

Returns the status of working copy files and directories, giving modifications, additions, deletions and other changes to items in the working copy.

参数

path

Local path to file or directory to retrieve status of.

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

flags

Any combination of Svn::NON_RECURSIVE, Svn::ALL (regardless of modification status), Svn::SHOW_UPDATES (entries will be added for items that are out-of-date), Svn::NO_IGNORE (disregard svn:ignore properties when scanning for new files) and Svn::IGNORE_EXTERNALS.

返回值

Returns a numerically indexed array of associative arrays detailing the status of items in the repository:

Array (
    [0] => Array (
        // information on item
    )
    [1] => ...
)

The information on the item is an associative array that can contain the following keys:

path
String path to file/directory of this entry on local filesystem.
text_status
Status of item's text. 参见 状态常量列表 获得可能的值.
repos_text_status
Status of item's text in repository. Only accurate if update was set to true. 参见 状态常量列表 获得可能的值.
prop_status
Status of item's properties. 参见 状态常量列表 获得可能的值.
repos_prop_status
Status of item's property in repository. Only accurate if update was set to true. 参见 状态常量列表 获得可能的值.
locked
Whether or not the item is locked. (Only set if true.)
copied
Whether or not the item was copied (scheduled for addition with history). (Only set if true.)
switched
Whether or not the item was switched using the switch command. (Only set if true)

These keys are only set if the item is versioned:

name
Base name of item in repository.
url
URL of item in repository.
repos
Base URL of repository.
revision
Integer revision of item in working copy.
kind
Type of item, i.e. file or directory. 参见 类型常量列表 获取可能的值.
schedule
Scheduled action for item, i.e. addition or deletion. Constants for these magic numbers are not available, they can be emulated by using:
<?php
if (!defined('svn_wc_schedule_normal')) {
    define('svn_wc_schedule_normal',  0); // nothing special
    define('svn_wc_schedule_add',     1); // item will be added
    define('svn_wc_schedule_delete',  2); // item will be deleted
    define('svn_wc_schedule_replace', 3); // item will be added and deleted
}
?>
deleted
Whether or not the item was deleted, but parent revision lags behind. (Only set if true.)
absent
Whether or not the item is absent, that is, Subversion knows that there should be something there but there isn't. (Only set if true.)
incomplete
Whether or not the entries file for a directory is incomplete. (Only set if true.)
cmt_date
Integer Unix timestamp of last commit date. (Unaffected by update.)
cmt_rev
Integer revision of last commit. (Unaffected by update.)
cmt_author
String author of last commit. (Unaffected by update.)
prop_time
Integer Unix timestamp of last up-to-date time for properties
text_time
Integer Unix timestamp of last up-to-date time for text

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Basic example

This example demonstrates a basic, theoretical usage of this function.

<?php
print_r(svn_status(realpath('wc')));
?>

以上例程的输出类似于：

Array (
    [0] => Array (
        [path] => /home/bob/wc/sandwich.txt
        [text_status] => 8 // item was modified
        [repos_text_status] => 1 // no information available, use update
        [prop_status] => 3 // no changes
        [repos_prop_status] => 1 // no information available, use update
        [name] => sandwich.txt
        [url] => http://www.example.com/svnroot/deli/trunk/sandwich.txt
        [repos] => http://www.example.com/svnroot/
        [revision] => 123
        [kind] => 1 // file
        [schedule] => 0 // no special actions scheduled
        [cmt_date] => 1165543135
        [cmt_rev] => 120
        [cmt_author] => Alice
        [prop_time] => 1180201728
        [text_time] => 1180201729
    )
)

参见

  • svn_update() - Update working copy
  • svn_log() - Returns the commit log messages of a repository URL
  • » SVN documentation for svn status


Update working copy

  • ? svn_status
  • TCP ?
  • PHP Manual
  • SVN 函数
  • Update working copy

svn_update

(PECL svn >= 0.1.0)

svn_update — Update working copy

说明

svn_update ( string $path , int $revno = SVN_REVISION_HEAD , bool $recurse = true ) : int

Update working copy at path to revision revno. If recurse is true, directories will be recursively updated.

参数

path

Path to local working copy.

Note: 相对路径将会以PHP执行文件所在目录作为当前工作目录进行解析。如果希望依据脚本所在目录解析, 使用realpath() 或 dirname(__FILE__)。

revno

Revision number to update to, default is SVN_REVISION_HEAD.

recurse

Whether or not to recursively update directories.

返回值

Returns new revision number on success, returns false on failure.

注释

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

范例

Example #1 Basic example

This example demonstrates basic usage of this function:

<?php
echo svn_update(realpath('working-copy'));
?>

以上例程的输出类似于：

234

参见

  • svn_checkout() - Checks out a working copy from the repository
  • svn_commit() - 将修改的本地文件副本发送至版本库
  • » SVN documentation for svn update


TCP Wrappers

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • TCP 函数
    • tcpwrap_check — Performs a tcpwrap check


简介

The TCP wrappers provides a classical Unix mechanism which has been designed to check if the remote client is able to connect from the given IP address.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/tcpwrap.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


  • ? 资源类型
  • TCP 函数 ?
  • PHP Manual
  • TCP
  • 预定义常量

预定义常量

此扩展没有定义常量。


TCP 函数

Table of Contents

  • tcpwrap_check — Performs a tcpwrap check


Performs a tcpwrap check

  • ? TCP 函数
  • Varnish ?
  • PHP Manual
  • TCP 函数
  • Performs a tcpwrap check

tcpwrap_check

(PECL tcpwrap >= 0.1.0)

tcpwrap_check — Performs a tcpwrap check

说明

tcpwrap_check ( string $daemon , string $address , string $user = ? , bool $nodns = false ) : bool

This function consults the /etc/hosts.allow and /etc/hosts.deny files to check if access to service daemon should be granted or denied for a client.

参数

daemon

The service name.

address

The client remote address. Can be either an IP address or a domain name.

user

An optional user name.

nodns

If address looks like domain name then DNS is used to resolve it to IP address; set nodns to true to avoid this.

返回值

This function returns true if access should be granted, false otherwise.

范例

Example #1 Deny all connections from localhost

If your /etc/hosts.deny file contains:

php: 127.0.0.1

And your code looks like:

<?php
if (!tcpwrap_check('php', $_SERVER['REMOTE_ADDR'])) {
  die('You are not welcome here');
}
?>

参见

For more details please consult hosts_access(3) man page.


Varnish

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic VarnishAdmin usage
    • Basic VarnishStat usage
    • Basic VarnishLog usage
  • VarnishAdmin — The VarnishAdmin class
    • VarnishAdmin::auth — Authenticate on a varnish instance
    • VarnishAdmin::ban — Ban URLs using a VCL expression
    • VarnishAdmin::banUrl — Ban an URL using a VCL expression
    • VarnishAdmin::clearPanic — Clear varnish instance panic messages
    • VarnishAdmin::connect — Connect to a varnish instance administration interface
    • VarnishAdmin::__construct — VarnishAdmin constructor
    • VarnishAdmin::disconnect — Disconnect from a varnish instance administration interface
    • VarnishAdmin::getPanic — Get the last panic message on a varnish instance
    • VarnishAdmin::getParams — Fetch current varnish instance configuration parameters
    • VarnishAdmin::isRunning — Check if the varnish slave process is currently running
    • VarnishAdmin::setCompat — Set the class compat configuration param
    • VarnishAdmin::setHost — Set the class host configuration param
    • VarnishAdmin::setIdent — Set the class ident configuration param
    • VarnishAdmin::setParam — Set configuration param on the current varnish instance
    • VarnishAdmin::setPort — Set the class port configuration param
    • VarnishAdmin::setSecret — Set the class secret configuration param
    • VarnishAdmin::setTimeout — Set the class timeout configuration param
    • VarnishAdmin::start — Start varnish worker process
    • VarnishAdmin::stop — Stop varnish worker process
  • VarnishStat — The VarnishStat class
    • VarnishStat::__construct — VarnishStat constructor
    • VarnishStat::getSnapshot — Get the current varnish instance statistics snapshot
  • VarnishLog — The VarnishLog class
    • VarnishLog::__construct — Varnishlog constructor
    • VarnishLog::getLine — Get next log line
    • VarnishLog::getTagName — Get the log tag string representation by its index


简介

Varnish Cache is an open source, state of the art web application accelerator. The extension makes it possible to interact with a running varnish instance through TCP socket or shared memory.


需求

To use this extension, you will need Varnish Cache of the version >=3.0 installed, available on the » Varnish Cache homepage


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/varnish.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/varnish/.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

VARNISH_STATUS_SYNTAX (int)
VARNISH_STATUS_UNKNOWN (int)
VARNISH_STATUS_UNIMPL (int)
VARNISH_STATUS_TOOFEW (int)
VARNISH_STATUS_TOOMANY (int)
VARNISH_STATUS_PARAM (int)
VARNISH_STATUS_AUTH (int)
VARNISH_STATUS_OK (int)
VARNISH_STATUS_CANT (int)
VARNISH_STATUS_COMMS (int)
VARNISH_STATUS_CLOSE (int)
VARNISH_CONFIG_IDENT (string)
VARNISH_CONFIG_HOST (string)
VARNISH_CONFIG_PORT (string)
VARNISH_CONFIG_TIMEOUT (string)
VARNISH_CONFIG_SECRET (string)
VARNISH_CONFIG_COMPAT (string)
VARNISH_COMPAT_2 (int)
VARNISH_COMPAT_3 (int)


范例

Table of Contents

  • Basic VarnishAdmin usage
  • Basic VarnishStat usage
  • Basic VarnishLog usage


Basic VarnishAdmin usage

The example illustrates a simple usage of the ban functionality

Example #1 Ban an URL

<?php

$args = array(
    VARNISH_CONFIG_HOST    => "::1",
    VARNISH_CONFIG_PORT    => 6082,
    VARNISH_CONFIG_SECRET  => "5174826b-8595-4958-aa7a-0609632ad7ca",
    VARNISH_CONFIG_TIMEOUT => 300,
);

$va = new VarnishAdmin($args);

try {
    if(!$va->connect()) {
        throw new VarnishException("Connection failed\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

try {
    if(!$va->auth()) {
        throw new VarnishException("Auth failed\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

try {
    $status = $va->ban('req.url ~ "^/$"');
    if (VARNISH_STATUS_OK != $status) {
        throw new VarnishException("Ban method returned $status status\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

exit(0);

?>


Basic VarnishStat usage

The example illustrates getting varnish statistic snapshot from shared memory

Example #1 Get statistic snapshot

<?php

$vs = new VarnishStat;

try {
    $data = $vs->getSnapshot();
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

exit(0);
?>


Basic VarnishLog usage

The example illustrates reading varnish log lines from shared memory

Example #1 Read varnish shared memory log

<?php

$vl = new VarnishLog;
while(1) {
    $line = $vl->getLine();
    printf("%s %d %s", VarnishLog::getTagName($line['tag'], $line['id'],
    $line['data']);
}

exit(0);
?>


The VarnishAdmin class

(PECL varnish >= 0.3)

简介

类摘要

VarnishAdmin {
/* 方法 */
public auth ( ) : bool
public ban ( string $vcl_regex ) : int
public banUrl ( string $vcl_regex ) : int
public clearPanic ( ) : int
public connect ( ) : bool
public __construct ( array $args = ? )
public disconnect ( ) : bool
public getPanic ( ) : string
public getParams ( ) : array
public isRunning ( ) : bool
public setCompat ( int $compat ) : void
public setHost ( string $host ) : void
public setIdent ( string $ident ) : void
public setParam ( string $name , string|int $value ) : int
public setPort ( int $port ) : void
public setSecret ( string $secret ) : void
public setTimeout ( int $timeout ) : void
public start ( ) : int
public stop ( ) : int
}

Table of Contents

  • VarnishAdmin::auth — Authenticate on a varnish instance
  • VarnishAdmin::ban — Ban URLs using a VCL expression
  • VarnishAdmin::banUrl — Ban an URL using a VCL expression
  • VarnishAdmin::clearPanic — Clear varnish instance panic messages
  • VarnishAdmin::connect — Connect to a varnish instance administration interface
  • VarnishAdmin::__construct — VarnishAdmin constructor
  • VarnishAdmin::disconnect — Disconnect from a varnish instance administration interface
  • VarnishAdmin::getPanic — Get the last panic message on a varnish instance
  • VarnishAdmin::getParams — Fetch current varnish instance configuration parameters
  • VarnishAdmin::isRunning — Check if the varnish slave process is currently running
  • VarnishAdmin::setCompat — Set the class compat configuration param
  • VarnishAdmin::setHost — Set the class host configuration param
  • VarnishAdmin::setIdent — Set the class ident configuration param
  • VarnishAdmin::setParam — Set configuration param on the current varnish instance
  • VarnishAdmin::setPort — Set the class port configuration param
  • VarnishAdmin::setSecret — Set the class secret configuration param
  • VarnishAdmin::setTimeout — Set the class timeout configuration param
  • VarnishAdmin::start — Start varnish worker process
  • VarnishAdmin::stop — Stop varnish worker process


Authenticate on a varnish instance

  • ? VarnishAdmin
  • VarnishAdmin::ban ?
  • PHP Manual
  • VarnishAdmin
  • Authenticate on a varnish instance

VarnishAdmin::auth

(PECL varnish >= 0.3)

VarnishAdmin::auth — Authenticate on a varnish instance

说明

public VarnishAdmin::auth ( ) : bool

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Ban URLs using a VCL expression

  • ? VarnishAdmin::auth
  • VarnishAdmin::banUrl ?
  • PHP Manual
  • VarnishAdmin
  • Ban URLs using a VCL expression

VarnishAdmin::ban

(PECL varnish >= 0.3)

VarnishAdmin::ban — Ban URLs using a VCL expression

说明

public VarnishAdmin::ban ( string $vcl_regex ) : int

参数

vcl_regex

Varnish VCL expression. It's based on the varnish ban command.

返回值

Returns the varnish command status.


Ban an URL using a VCL expression

  • ? VarnishAdmin::ban
  • VarnishAdmin::clearPanic ?
  • PHP Manual
  • VarnishAdmin
  • Ban an URL using a VCL expression

VarnishAdmin::banUrl

(PECL varnish >= 0.3)

VarnishAdmin::banUrl — Ban an URL using a VCL expression

说明

public VarnishAdmin::banUrl ( string $vcl_regex ) : int

参数

vcl_regex

URL regular expression in PCRE compatible syntax. It's based on the ban.url varnish command.

返回值

Returns the varnish command status.


Clear varnish instance panic messages

  • ? VarnishAdmin::banUrl
  • VarnishAdmin::connect ?
  • PHP Manual
  • VarnishAdmin
  • Clear varnish instance panic messages

VarnishAdmin::clearPanic

(PECL varnish >= 0.4)

VarnishAdmin::clearPanic — Clear varnish instance panic messages

说明

public VarnishAdmin::clearPanic ( ) : int

参数

此函数没有参数。

返回值

Returns the varnish command status.


Connect to a varnish instance administration interface

  • ? VarnishAdmin::clearPanic
  • VarnishAdmin::__construct ?
  • PHP Manual
  • VarnishAdmin
  • Connect to a varnish instance administration interface

VarnishAdmin::connect

(PECL varnish >= 0.3)

VarnishAdmin::connect — Connect to a varnish instance administration interface

说明

public VarnishAdmin::connect ( ) : bool

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


VarnishAdmin constructor

  • ? VarnishAdmin::connect
  • VarnishAdmin::disconnect ?
  • PHP Manual
  • VarnishAdmin
  • VarnishAdmin constructor

VarnishAdmin::__construct

(PECL varnish >= 0.3)

VarnishAdmin::__construct — VarnishAdmin constructor

说明

public VarnishAdmin::__construct ( array $args = ? )

参数

args

Configuration arguments. The possible keys are:

VARNISH_CONFIG_IDENT - local varnish instance ident
VARNISH_CONFIG_HOST - varnish instance ip
VARNISH_CONFIG_PORT - varnish instance port
VARNISH_CONFIG_SECRET - varnish instance secret
VARNISH_CONFIG_TIMEOUT - connection read timeout
VARNISH_CONFIG_COMPAT - varnish major version compatibility

返回值

范例

Example #1 VarnishAdmin::__construct() example

<?php
    $args = array(
        VARNISH_CONFIG_HOST => "::1",
        VARNISH_CONFIG_PORT => 6082,
        VARNISH_CONFIG_SECRET => "5174826b-8595-4958-aa7a-0609632ad7ca",
        VARNISH_CONFIG_TIMEOUT => 300,
    );
    $va = new VarnishAdmin($args);
?>


Disconnect from a varnish instance administration interface

  • ? VarnishAdmin::__construct
  • VarnishAdmin::getPanic ?
  • PHP Manual
  • VarnishAdmin
  • Disconnect from a varnish instance administration interface

VarnishAdmin::disconnect

(PECL varnish >= 1.0.0)

VarnishAdmin::disconnect — Disconnect from a varnish instance administration interface

说明

public VarnishAdmin::disconnect ( ) : bool

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Get the last panic message on a varnish instance

  • ? VarnishAdmin::disconnect
  • VarnishAdmin::getParams ?
  • PHP Manual
  • VarnishAdmin
  • Get the last panic message on a varnish instance

VarnishAdmin::getPanic

(PECL varnish >= 0.4)

VarnishAdmin::getPanic — Get the last panic message on a varnish instance

说明

public VarnishAdmin::getPanic ( ) : string

参数

此函数没有参数。

返回值

Returns the last panic message on the current varnish instance.


Fetch current varnish instance configuration parameters

  • ? VarnishAdmin::getPanic
  • VarnishAdmin::isRunning ?
  • PHP Manual
  • VarnishAdmin
  • Fetch current varnish instance configuration parameters

VarnishAdmin::getParams

(PECL varnish >= 0.4)

VarnishAdmin::getParams — Fetch current varnish instance configuration parameters

说明

public VarnishAdmin::getParams ( ) : array

参数

此函数没有参数。

返回值

Returns an array with the varnish configuration parameters.


Check if the varnish slave process is currently running

  • ? VarnishAdmin::getParams
  • VarnishAdmin::setCompat ?
  • PHP Manual
  • VarnishAdmin
  • Check if the varnish slave process is currently running

VarnishAdmin::isRunning

(PECL varnish >= 0.3)

VarnishAdmin::isRunning — Check if the varnish slave process is currently running

说明

public VarnishAdmin::isRunning ( ) : bool

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Set the class compat configuration param

  • ? VarnishAdmin::isRunning
  • VarnishAdmin::setHost ?
  • PHP Manual
  • VarnishAdmin
  • Set the class compat configuration param

VarnishAdmin::setCompat

(PECL varnish >= 0.9.2)

VarnishAdmin::setCompat — Set the class compat configuration param

说明

public VarnishAdmin::setCompat ( int $compat ) : void

参数

compat

Varnish compatibility option.

返回值


Set the class host configuration param

  • ? VarnishAdmin::setCompat
  • VarnishAdmin::setIdent ?
  • PHP Manual
  • VarnishAdmin
  • Set the class host configuration param

VarnishAdmin::setHost

(PECL varnish >= 0.8)

VarnishAdmin::setHost — Set the class host configuration param

说明

public VarnishAdmin::setHost ( string $host ) : void

参数

host

Connection host configuration parameter.

返回值


Set the class ident configuration param

  • ? VarnishAdmin::setHost
  • VarnishAdmin::setParam ?
  • PHP Manual
  • VarnishAdmin
  • Set the class ident configuration param

VarnishAdmin::setIdent

(PECL varnish >= 0.8)

VarnishAdmin::setIdent — Set the class ident configuration param

说明

public VarnishAdmin::setIdent ( string $ident ) : void

参数

ident

Connection ident configuration parameter.

返回值


Set configuration param on the current varnish instance

  • ? VarnishAdmin::setIdent
  • VarnishAdmin::setPort ?
  • PHP Manual
  • VarnishAdmin
  • Set configuration param on the current varnish instance

VarnishAdmin::setParam

(PECL varnish >= 0.4)

VarnishAdmin::setParam — Set configuration param on the current varnish instance

说明

public VarnishAdmin::setParam ( string $name , string|int $value ) : int

参数

name

Varnish configuration param name.

value

Varnish configuration param value.

返回值

Returns the varnish command status.


Set the class port configuration param

  • ? VarnishAdmin::setParam
  • VarnishAdmin::setSecret ?
  • PHP Manual
  • VarnishAdmin
  • Set the class port configuration param

VarnishAdmin::setPort

(PECL varnish >= 0.8)

VarnishAdmin::setPort — Set the class port configuration param

说明

public VarnishAdmin::setPort ( int $port ) : void

参数

port

Connection port configuration parameter.

返回值


Set the class secret configuration param

  • ? VarnishAdmin::setPort
  • VarnishAdmin::setTimeout ?
  • PHP Manual
  • VarnishAdmin
  • Set the class secret configuration param

VarnishAdmin::setSecret

(PECL varnish >= 0.8)

VarnishAdmin::setSecret — Set the class secret configuration param

说明

public VarnishAdmin::setSecret ( string $secret ) : void

参数

secret

Connection secret configuration parameter.

返回值


Set the class timeout configuration param

  • ? VarnishAdmin::setSecret
  • VarnishAdmin::start ?
  • PHP Manual
  • VarnishAdmin
  • Set the class timeout configuration param

VarnishAdmin::setTimeout

(PECL varnish >= 0.8)

VarnishAdmin::setTimeout — Set the class timeout configuration param

说明

public VarnishAdmin::setTimeout ( int $timeout ) : void

参数

timeout

Connection timeout configuration parameter.

返回值


Start varnish worker process

  • ? VarnishAdmin::setTimeout
  • VarnishAdmin::stop ?
  • PHP Manual
  • VarnishAdmin
  • Start varnish worker process

VarnishAdmin::start

(PECL varnish >= 0.3)

VarnishAdmin::start — Start varnish worker process

说明

public VarnishAdmin::start ( ) : int

参数

此函数没有参数。

返回值

Returns the varnish command status.


Stop varnish worker process

  • ? VarnishAdmin::start
  • VarnishStat ?
  • PHP Manual
  • VarnishAdmin
  • Stop varnish worker process

VarnishAdmin::stop

(PECL varnish >= 0.3)

VarnishAdmin::stop — Stop varnish worker process

说明

public VarnishAdmin::stop ( ) : int

参数

此函数没有参数。

返回值

Returns the varnish command status.


The VarnishStat class

(PECL varnish >= 0.3)

简介

类摘要

VarnishStat {
/* 方法 */
public __construct ( array $args = ? )
public getSnapshot ( ) : array
}

Table of Contents

  • VarnishStat::__construct — VarnishStat constructor
  • VarnishStat::getSnapshot — Get the current varnish instance statistics snapshot


VarnishStat constructor

  • ? VarnishStat
  • VarnishStat::getSnapshot ?
  • PHP Manual
  • VarnishStat
  • VarnishStat constructor

VarnishStat::__construct

(PECL varnish >= 0.3)

VarnishStat::__construct — VarnishStat constructor

说明

public VarnishStat::__construct ( array $args = ? )

参数

args

Configuration arguments. The possible keys are:

VARNISH_CONFIG_IDENT - local varnish instance ident path

返回值


Get the current varnish instance statistics snapshot

  • ? VarnishStat::__construct
  • VarnishLog ?
  • PHP Manual
  • VarnishStat
  • Get the current varnish instance statistics snapshot

VarnishStat::getSnapshot

(PECL varnish >= 0.3)

VarnishStat::getSnapshot — Get the current varnish instance statistics snapshot

说明

public VarnishStat::getSnapshot ( ) : array

参数

此函数没有参数。

返回值

Array with the varnish statistic snapshot. The array keys are identical to that in the varnishstat tool.


The VarnishLog class

(PECL varnish >= 0.6)

简介

类摘要

VarnishLog {
/* Constants */
const int TAG_Debug = 0 ;
const int TAG_Error = 1 ;
const int TAG_CLI = 2 ;
const int TAG_StatSess = 3 ;
const int TAG_ReqEnd = 4 ;
const int TAG_SessionOpen = 5 ;
const int TAG_SessionClose = 6 ;
const int TAG_BackendOpen = 7 ;
const int TAG_BackendXID = 8 ;
const int TAG_BackendReuse = 9 ;
const int TAG_BackendClose = 10 ;
const int TAG_HttpGarbage = 11 ;
const int TAG_Backend = 12 ;
const int TAG_Length = 13 ;
const int TAG_FetchError = 14 ;
const int TAG_RxRequest = 15 ;
const int TAG_RxResponse = 16 ;
const int TAG_RxStatus = 17 ;
const int TAG_RxURL = 18 ;
const int TAG_RxProtocol = 19 ;
const int TAG_RxHeader = 20 ;
const int TAG_TxRequest = 21 ;
const int TAG_TxResponse = 22 ;
const int TAG_TxStatus = 23 ;
const int TAG_TxURL = 24 ;
const int TAG_TxProtocol = 25 ;
const int TAG_TxHeader = 26 ;
const int TAG_ObjRequest = 27 ;
const int TAG_ObjResponse = 28 ;
const int TAG_ObjStatus = 29 ;
const int TAG_ObjURL = 30 ;
const int TAG_ObjProtocol = 31 ;
const int TAG_ObjHeader = 32 ;
const int TAG_LostHeader = 33 ;
const int TAG_TTL = 34 ;
const int TAG_Fetch_Body = 35 ;
const int TAG_VCL_acl = 36 ;
const int TAG_VCL_call = 37 ;
const int TAG_VCL_trace = 38 ;
const int TAG_VCL_return = 39 ;
const int TAG_VCL_error = 40 ;
const int TAG_ReqStart = 41 ;
const int TAG_Hit = 42 ;
const int TAG_HitPass = 43 ;
const int TAG_ExpBan = 44 ;
const int TAG_ExpKill = 45 ;
const int TAG_WorkThread = 46 ;
const int TAG_ESI_xmlerror = 47 ;
const int TAG_Hash = 48 ;
const int TAG_Backend_health = 49 ;
const int TAG_VCL_Log = 50 ;
const int TAG_Gzip = 51 ;
/* 方法 */
public __construct ( array $args = ? )
public getLine ( ) : array
public static getTagName ( int $index ) : string
}

预定义常量

VarnishLog::TAG_Debug

VarnishLog::TAG_Error

VarnishLog::TAG_CLI

VarnishLog::TAG_StatSess

VarnishLog::TAG_ReqEnd

VarnishLog::TAG_SessionOpen

VarnishLog::TAG_SessionClose

VarnishLog::TAG_BackendOpen

VarnishLog::TAG_BackendXID

VarnishLog::TAG_BackendReuse

VarnishLog::TAG_BackendClose

VarnishLog::TAG_HttpGarbage

VarnishLog::TAG_Backend

VarnishLog::TAG_Length

VarnishLog::TAG_FetchError

VarnishLog::TAG_RxRequest

VarnishLog::TAG_RxResponse

VarnishLog::TAG_RxStatus

VarnishLog::TAG_RxURL

VarnishLog::TAG_RxProtocol

VarnishLog::TAG_RxHeader

VarnishLog::TAG_TxRequest

VarnishLog::TAG_TxResponse

VarnishLog::TAG_TxStatus

VarnishLog::TAG_TxURL

VarnishLog::TAG_TxProtocol

VarnishLog::TAG_TxHeader

VarnishLog::TAG_ObjRequest

VarnishLog::TAG_ObjResponse

VarnishLog::TAG_ObjStatus

VarnishLog::TAG_ObjURL

VarnishLog::TAG_ObjProtocol

VarnishLog::TAG_ObjHeader

VarnishLog::TAG_LostHeader

VarnishLog::TAG_TTL

VarnishLog::TAG_Fetch_Body

VarnishLog::TAG_VCL_acl

VarnishLog::TAG_VCL_call

VarnishLog::TAG_VCL_trace

VarnishLog::TAG_VCL_return

VarnishLog::TAG_VCL_error

VarnishLog::TAG_ReqStart

VarnishLog::TAG_Hit

VarnishLog::TAG_HitPass

VarnishLog::TAG_ExpBan

VarnishLog::TAG_ExpKill

VarnishLog::TAG_WorkThread

VarnishLog::TAG_ESI_xmlerror

VarnishLog::TAG_Hash

VarnishLog::TAG_Backend_health

VarnishLog::TAG_VCL_Log

VarnishLog::TAG_Gzip

Table of Contents

  • VarnishLog::__construct — Varnishlog constructor
  • VarnishLog::getLine — Get next log line
  • VarnishLog::getTagName — Get the log tag string representation by its index


Varnishlog constructor

  • ? VarnishLog
  • VarnishLog::getLine ?
  • PHP Manual
  • VarnishLog
  • Varnishlog constructor

VarnishLog::__construct

(PECL varnish >= 0.6)

VarnishLog::__construct — Varnishlog constructor

说明

public VarnishLog::__construct ( array $args = ? )

参数

args

Configuration arguments. The possible keys are:

VARNISH_CONFIG_IDENT - local varnish instance ident path

返回值


Get next log line

  • ? VarnishLog::__construct
  • VarnishLog::getTagName ?
  • PHP Manual
  • VarnishLog
  • Get next log line

VarnishLog::getLine

(PECL varnish >= 0.6)

VarnishLog::getLine — Get next log line

说明

public VarnishLog::getLine ( ) : array

参数

此函数没有参数。

返回值

Returns an array with the log line data.


Get the log tag string representation by its index

  • ? VarnishLog::getLine
  • YAZ ?
  • PHP Manual
  • VarnishLog
  • Get the log tag string representation by its index

VarnishLog::getTagName

(PECL varnish >= 0.6)

VarnishLog::getTagName — Get the log tag string representation by its index

说明

public static VarnishLog::getTagName ( int $index ) : string

参数

index

Log tag index.

返回值

Returns the log tag name as string.


YAZ

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • YAZ 函数
    • yaz_addinfo — Returns additional error information
    • yaz_ccl_conf — Configure CCL parser
    • yaz_ccl_parse — Invoke CCL Parser
    • yaz_close — Close YAZ connection
    • yaz_connect — Prepares for a connection to a Z39.50 server
    • yaz_database — Specifies the databases within a session
    • yaz_element — Specifies Element-Set Name for retrieval
    • yaz_errno — Returns error number
    • yaz_error — Returns error description
    • yaz_es_result — Inspects Extended Services Result
    • yaz_es — Prepares for an Extended Service Request
    • yaz_get_option — Returns value of option for connection
    • yaz_hits — Returns number of hits for last search
    • yaz_itemorder — Prepares for Z39.50 Item Order with an ILL-Request package
    • yaz_present — Prepares for retrieval (Z39.50 present)
    • yaz_range — Specifies a range of records to retrieve
    • yaz_record — Returns a record
    • yaz_scan_result — Returns Scan Response result
    • yaz_scan — Prepares for a scan
    • yaz_schema — Specifies schema for retrieval
    • yaz_search — Prepares for a search
    • yaz_set_option — Sets one or more options for connection
    • yaz_sort — Sets sorting criteria
    • yaz_syntax — Specifies the preferred record syntax for retrieval
    • yaz_wait — Wait for Z39.50 requests to complete


简介

This extension offers a PHP interface to the YAZ toolkit that implements the » Z39.50 Protocol for Information Retrieval. With this extension you can easily implement a Z39.50 origin (client) that searches or scans Z39.50 targets (servers) in parallel.

The module hides most of the complexity of Z39.50 so it should be fairly easy to use. It supports persistent stateless connections very similar to those offered by the various RDB APIs that are available for PHP. This means that sessions are stateless but shared among users, thus saving the connect and initialize phase steps in most cases.

YAZ is available at » http://www.indexdata.dk/yaz/. You can find news information, example scripts, etc. for this extension at » http://www.indexdata.dk/phpyaz/.

Note:

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。5.0.0.


需求

Obtain YAZ (ANSI/NISO Z39.50 support) and install it. YAZ can be fetched in source or in various prebuilt packages from the » YAZ archive. Systems such as Debian GNU/Linux, Suse Linux, FreeBSD also has YAZ as part of their distribution.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/yaz

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。

Note: Information specific to Windows users

php_yaz.dll depends on yaz.dll. The yaz.dll is part of the Win32 ZIP from the PHP site. It is also part of the Windows YAZ install available from the » YAZ WIN32 area.

On windows, don't forget to add the PHP directory to the PATH, so that the yaz.dll file can be found by the system.

Warning

IMAP，recode，和 YAZ 扩展不能同时使用，因为它们共享了相同 的内部符号。注意：Yaz 2.0 及以上版本不存在此问题。


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • YAZ
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

PHP/YAZ keeps track of connections with targets (Z-Associations). A resource represents a connection to a target.

The script below demonstrates the parallel searching feature of the API. When invoked with no arguments it prints a query form; else (arguments are supplied) it searches the targets as given in array host.

Example #1 Parallel searching using Yaz

<?php
$host=$_REQUEST[host];
$query=$_REQUEST[query];
$num_hosts = count($host);
if (empty($query) || count($host) == 0) {
    echo '<form method="get">
    <input type="checkbox"
    name="host[]" value="bagel.indexdata.dk/gils" />
        GILS test
    <input type="checkbox"
    name="host[]" value="localhost:9999/Default" />
        local test
    <input type="checkbox" checked="checked"
    name="host[]" value="z3950.loc.gov:7090/voyager" />
        Library of Congress
    <br />
    RPN Query:
    <input type="text" size="30" name="query" />
    <input type="submit" name="action" value="Search" />
    </form>
    ';
} else {
    echo 'You searched for ' . htmlspecialchars($query) . '<br />';
    for ($i = 0; $i < $num_hosts; $i++) {
        $id[] = yaz_connect($host[$i]);
        yaz_syntax($id[$i], "usmarc");
        yaz_range($id[$i], 1, 10);
        yaz_search($id[$i], "rpn", $query);
    }
    yaz_wait();
    for ($i = 0; $i < $num_hosts; $i++) {
        echo '<hr />' . $host[$i] . ':';
        $error = yaz_error($id[$i]);
        if (!empty($error)) {
            echo "Error: $error";
        } else {
            $hits = yaz_hits($id[$i]);
            echo "Result Count $hits";
        }
        echo '<dl>';
        for ($p = 1; $p <= 10; $p++) {
            $rec = yaz_record($id[$i], $p, "string");
            if (empty($rec)) continue;
            echo "<dt><b>$p</b></dt><dd>";
            echo nl2br($rec);
            echo "</dd>";
        }
        echo '</dl>';
    }
}
?>


YAZ 函数

Table of Contents

  • yaz_addinfo — Returns additional error information
  • yaz_ccl_conf — Configure CCL parser
  • yaz_ccl_parse — Invoke CCL Parser
  • yaz_close — Close YAZ connection
  • yaz_connect — Prepares for a connection to a Z39.50 server
  • yaz_database — Specifies the databases within a session
  • yaz_element — Specifies Element-Set Name for retrieval
  • yaz_errno — Returns error number
  • yaz_error — Returns error description
  • yaz_es_result — Inspects Extended Services Result
  • yaz_es — Prepares for an Extended Service Request
  • yaz_get_option — Returns value of option for connection
  • yaz_hits — Returns number of hits for last search
  • yaz_itemorder — Prepares for Z39.50 Item Order with an ILL-Request package
  • yaz_present — Prepares for retrieval (Z39.50 present)
  • yaz_range — Specifies a range of records to retrieve
  • yaz_record — Returns a record
  • yaz_scan_result — Returns Scan Response result
  • yaz_scan — Prepares for a scan
  • yaz_schema — Specifies schema for retrieval
  • yaz_search — Prepares for a search
  • yaz_set_option — Sets one or more options for connection
  • yaz_sort — Sets sorting criteria
  • yaz_syntax — Specifies the preferred record syntax for retrieval
  • yaz_wait — Wait for Z39.50 requests to complete


Returns additional error information

  • ? YAZ 函数
  • yaz_ccl_conf ?
  • PHP Manual
  • YAZ 函数
  • Returns additional error information

yaz_addinfo

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_addinfo — Returns additional error information

说明

yaz_addinfo ( resource $id ) : string

Returns additional error information for the last request on the server.

With some servers, this function may return the same string as yaz_error().

参数

id

The connection resource returned by yaz_connect().

返回值

A string containing additional error information or an empty string if the last operation was successful or if no additional information was provided by the server.

参见

  • yaz_error() - Returns error description
  • yaz_errno() - Returns error number


Configure CCL parser

  • ? yaz_addinfo
  • yaz_ccl_parse ?
  • PHP Manual
  • YAZ 函数
  • Configure CCL parser

yaz_ccl_conf

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_ccl_conf — Configure CCL parser

说明

yaz_ccl_conf ( resource $id , array $config ) : void

This function configures the CCL query parser for a server with definitions of access points (CCL qualifiers) and their mapping to RPN.

To map a specific CCL query to RPN afterwards call the yaz_ccl_parse() function.

参数

id

The connection resource returned by yaz_connect().

config

An array of configuration. Each key of the array is the name of a CCL field and the corresponding value holds a string that specifies a mapping to RPN.

The mapping is a sequence of attribute-type, attribute-value pairs. Attribute-type and attribute-value is separated by an equal sign (=). Each pair is separated by white space.

Additional information can be found on the » CCL page.

返回值

没有返回值。

范例

In the example below, the CCL parser is configured to support three CCL fields: ti, au and isbn. Each field is mapped to their BIB-1 equivalent. It is assumed that variable $id is the connection ID.

Example #1 CCL configuration

<?php
$fields = array(
  "ti" => "1=4",
  "au"   => "1=1",
  "isbn" => "1=7"
);
yaz_ccl_conf($id, $fields);
?>

参见

  • yaz_ccl_parse() - Invoke CCL Parser


Invoke CCL Parser

  • ? yaz_ccl_conf
  • yaz_close ?
  • PHP Manual
  • YAZ 函数
  • Invoke CCL Parser

yaz_ccl_parse

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_ccl_parse — Invoke CCL Parser

说明

yaz_ccl_parse ( resource $id , string $query , array &$result ) : bool

This function invokes a CCL parser. It converts a given CCL FIND query to an RPN query which may be passed to the yaz_search() function to perform a search.

To define a set of valid CCL fields call yaz_ccl_conf() prior to this function.

参数

id

The connection resource returned by yaz_connect().

query

The CCL FIND query.

result

If the function was executed successfully, this will be an array containing the valid RPN query under the key rpn.

Upon failure, three indexes are set in this array to indicate the cause of failure:

  • errorcode - the CCL error code (integer)

  • errorstring - the CCL error string

  • errorpos - approximate position in query of failure (integer is character position)

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 CCL Parsing

We will try to search using CCL. In the example below, $ccl is a CCL query.

<?php

yaz_ccl_conf($id, $fields);  // see example for yaz_ccl_conf
if (!yaz_ccl_parse($id, $ccl, &$cclresult)) {
    echo 'Error: ' . $cclresult["errorstring"];
} else {
    $rpn = $cclresult["rpn"];
    yaz_search($id, "rpn", $rpn);
}
?>


Close YAZ connection

  • ? yaz_ccl_parse
  • yaz_connect ?
  • PHP Manual
  • YAZ 函数
  • Close YAZ connection

yaz_close

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_close — Close YAZ connection

说明

yaz_close ( resource $id ) : bool

Closes the connection given by parameter id.

Note:

This function will only close a non-persistent connection opened by setting the persistent option to false with yaz_connect().

参数

id

The connection resource returned by yaz_connect().

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • yaz_connect() - Prepares for a connection to a Z39.50 server


Prepares for a connection to a Z39.50 server

  • ? yaz_close
  • yaz_database ?
  • PHP Manual
  • YAZ 函数
  • Prepares for a connection to a Z39.50 server

yaz_connect

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_connect — Prepares for a connection to a Z39.50 server

说明

yaz_connect ( string $zurl , mixed $options = ? ) : mixed

This function returns a connection resource on success, zero on failure.

yaz_connect() prepares for a connection to a Z39.50 server. This function is non-blocking and does not attempt to establish a connection - it merely prepares a connect to be performed later when yaz_wait() is called.

Note:

The » YAZ proxy is a freely available Z39.50 proxy.

参数

zurl

A string that takes the form host[:port][/database]. If port is omitted, port 210 is used. If database is omitted Default is used.

options

If given as a string, it is treated as the Z39.50 V2 authentication string (OpenAuth).

If given as an array, the contents of the array serves as options.

user

Username for authentication.

group

Group for authentication.

password

Password for authentication.

cookie

Cookie for session (YAZ proxy).

proxy

Proxy for connection (YAZ proxy).

persistent

A boolean. If true the connection is persistent; If false the connection is not persistent. By default connections are persistent.

Note:

If you open a persistent connection, you won't be able to close it later with yaz_close().

piggyback

A boolean. If true piggyback is enabled for searches; If false piggyback is disabled. By default piggyback is enabled.

Enabling piggyback is more efficient and usually saves a network-round-trip for first time fetches of records. However, a few Z39.50 servers do not support piggyback or they ignore element set names. For those, piggyback should be disabled.

charset

A string that specifies character set to be used in Z39.50 language and character set negotiation. Use strings such as: ISO-8859-1, UTF-8, UTF-16.

Most Z39.50 servers do not support this feature (and thus, this is ignored). Many servers use the ISO-8859-1 encoding for queries and messages. MARC21/USMARC records are not affected by this setting.

preferredMessageSize

An integer that specifies the maximum byte size of all records to be returned by a target during retrieval. See the » Z39.50 standard for more information.

Note:

This option is supported in PECL YAZ 1.0.5 or later.

maximumRecordSize

An integer that specifies the maximum byte size of a single record to be returned by a target during retrieval. This entity is referred to as Exceptional-record-size in the » Z39.50 standard.

Note:

This option is supported in PECL YAZ 1.0.5 or later.

返回值

A connection resource on success, false on error.

更新日志

版本 | 说明
4.1.0 | The parameter options was added.

参见

  • yaz_close() - Close YAZ connection


Specifies the databases within a session

  • ? yaz_connect
  • yaz_element ?
  • PHP Manual
  • YAZ 函数
  • Specifies the databases within a session

yaz_database

(PHP 4 >= 4.0.6, PECL yaz >= 0.9.0)

yaz_database — Specifies the databases within a session

说明

yaz_database ( resource $id , string $databases ) : bool

This function allows you to change databases within a session by specifying one or more databases to be used in search, retrieval, etc. - overriding databases specified in call to yaz_connect().

参数

id

The connection resource returned by yaz_connect().

databases

A string containing one or more databases. Multiple databases are separated by a plus sign +.

返回值

成功时返回 true， 或者在失败时返回 false。


Specifies Element-Set Name for retrieval

  • ? yaz_database
  • yaz_errno ?
  • PHP Manual
  • YAZ 函数
  • Specifies Element-Set Name for retrieval

yaz_element

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_element — Specifies Element-Set Name for retrieval

说明

yaz_element ( resource $id , string $elementset ) : bool

This function sets the element set name for retrieval.

Call this function before yaz_search() or yaz_present() to specify the element set name for records to be retrieved.

Note:

If this function appears to have no effect, see the description of the piggybacking option in yaz_connect().

参数

id

The connection resource returned by yaz_connect().

elementset

Most servers support F (for full records) and B (for brief records).

返回值

成功时返回 true， 或者在失败时返回 false。


Returns error number

  • ? yaz_element
  • yaz_error ?
  • PHP Manual
  • YAZ 函数
  • Returns error number

yaz_errno

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_errno — Returns error number

说明

yaz_errno ( resource $id ) : int

Returns an error number for the server (last request) identified by id.

yaz_errno() should be called after network activity for each server - (after yaz_wait() returns) to determine the success or failure of the last operation (e.g. search).

参数

id

The connection resource returned by yaz_connect().

返回值

Returns an error code. The error code is either a Z39.50 diagnostic code (usually a Bib-1 diagnostic) or a client side error code which is generated by PHP/YAZ itself, such as "Connect failed", "Init Rejected", etc.

参见

  • yaz_error() - Returns error description
  • yaz_addinfo() - Returns additional error information


Returns error description

  • ? yaz_errno
  • yaz_es_result ?
  • PHP Manual
  • YAZ 函数
  • Returns error description

yaz_error

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_error — Returns error description

说明

yaz_error ( resource $id ) : string

yaz_error() returns an English text message corresponding to the last error number as returned by yaz_errno().

参数

id

The connection resource returned by yaz_connect().

返回值

Returns an error text message for server (last request), identified by parameter id. An empty string is returned if the last operation was successful.

参见

  • yaz_errno() - Returns error number
  • yaz_addinfo() - Returns additional error information


Inspects Extended Services Result

  • ? yaz_error
  • yaz_es ?
  • PHP Manual
  • YAZ 函数
  • Inspects Extended Services Result

yaz_es_result

(PHP 4 >= 4.2.0, PECL yaz >= 0.9.0)

yaz_es_result — Inspects Extended Services Result

说明

yaz_es_result ( resource $id ) : array

This function inspects the last returned Extended Service result from a server. An Extended Service is initiated by either yaz_item_order() or yaz_es().

参数

id

The connection resource returned by yaz_connect().

返回值

Returns array with element targetReference for the reference for the extended service operation (generated and returned from the server).

参见

  • yaz_es() - Prepares for an Extended Service Request


Prepares for an Extended Service Request

  • ? yaz_es_result
  • yaz_get_option ?
  • PHP Manual
  • YAZ 函数
  • Prepares for an Extended Service Request

yaz_es

(PECL yaz >= 0.9.0)

yaz_es — Prepares for an Extended Service Request

说明

yaz_es ( resource $id , string $type , array $args ) : void

This function prepares for an Extended Service Request. Extended Services is family of various Z39.50 facilities, such as Record Update, Item Order, Database administration etc.

Note:

Many Z39.50 Servers do not support Extended Services.

The yaz_es() creates an Extended Service Request packages and puts it into a queue of operations. Use yaz_wait() to send the request(s) to the server. After completion of yaz_wait() the result of the Extended Service operation should be expected with a call to yaz_es_result().

参数

id

The connection resource returned by yaz_connect().

type

A string which represents the type of the Extended Service: itemorder (Item Order), create (Create Database), drop (Drop Database), commit (Commit Operation), update (Update Record), xmlupdate (XML Update). Each type is specified in the following section.

args

An array with extended service options plus package specific options. The options are identical to those offered in the C API of ZOOM C. Refer to the ZOOM » Extended Services.

返回值

没有返回值。

范例

Example #1 Record Update

<?php
$con = yaz_connect("myhost/database");
$args = array (
    "record" => "<gils><title>some title</title></gils>",
    "syntax" => "xml",
    "action" => "specialUpdate"
);
yaz_es($con, "update", $args);
yaz_wait();
$result = yaz_es_result($id);
?>

参见

  • yaz_es_result() - Inspects Extended Services Result


Returns value of option for connection

  • ? yaz_es
  • yaz_hits ?
  • PHP Manual
  • YAZ 函数
  • Returns value of option for connection

yaz_get_option

(PECL yaz >= 0.9.0)

yaz_get_option — Returns value of option for connection

说明

yaz_get_option ( resource $id , string $name ) : string

Returns the value of the option specified with name.

参数

id

The connection resource returned by yaz_connect().

name

The option name.

返回值

Returns the value of the specified option or an empty string if the option wasn't set.

参见

  • The description of yaz_set_option() - Sets one or more options for connection for available options


Returns number of hits for last search

  • ? yaz_get_option
  • yaz_itemorder ?
  • PHP Manual
  • YAZ 函数
  • Returns number of hits for last search

yaz_hits

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_hits — Returns number of hits for last search

说明

yaz_hits ( resource $id , array &$searchresult = ? ) : int

yaz_hits() returns the number of hits for the last search.

参数

id

The connection resource returned by yaz_connect().

searchresult

Result array for detailed search result information.

返回值

Returns the number of hits for the last search or 0 if no search was performed.

The search result array (if supplied) holds information that is returned by a Z39.50 server in the SearchResult-1 format part of a search response. The SearchResult-1 format can be used to obtain information about hit counts for various parts of the query (subquery). In particular, it is possible to obtain hit counts for the individual search terms in a query. Information for first subquery is in $array[0], second subquery in $array[1], and so forth.

searchresult members
Element | Description
id | Sub query ID2 (string)
count | Result count / hits (integer)
subquery.term | Sub query term (string)
interpretation.term | Interpretated sub query term (string)
recommendation.term | Recommended sub query term (string)

Note:

The SearchResult facility requires PECL YAZ 1.0.5 or later and YAZ 2.1.9 or later.

Note:

Very few Z39.50 implementations support the SearchResult facility.


Prepares for Z39.50 Item Order with an ILL-Request package

  • ? yaz_hits
  • yaz_present ?
  • PHP Manual
  • YAZ 函数
  • Prepares for Z39.50 Item Order with an ILL-Request package

yaz_itemorder

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_itemorder — Prepares for Z39.50 Item Order with an ILL-Request package

说明

yaz_itemorder ( resource $id , array $args ) : void

This function prepares for an Extended Services request using the Profile for the Use of Z39.50 Item Order Extended Service to Transport ILL (Profile/1). See » this and the » specification.

参数

id

The connection resource returned by yaz_connect().

args

Must be an associative array with information about the Item Order request to be sent. The key of the hash is the name of the corresponding ASN.1 tag path. For example, the ISBN below the Item-ID has the key item-id,ISBN.

The ILL-Request parameters are:

protocol-version-num
transaction-id,initial-requester-id,person-or-institution-symbol,person
transaction-id,initial-requester-id,person-or-institution-symbol,institution
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-person
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-institution
transaction-id,transaction-group-qualifier
transaction-id,transaction-qualifier
transaction-id,sub-transaction-qualifier
service-date-time,this,date
service-date-time,this,time
service-date-time,original,date
service-date-time,original,time
requester-id,person-or-institution-symbol,person
requester-id,person-or-institution-symbol,institution
requester-id,name-of-person-or-institution,name-of-person
requester-id,name-of-person-or-institution,name-of-institution
responder-id,person-or-institution-symbol,person
responder-id,person-or-institution-symbol,institution
responder-id,name-of-person-or-institution,name-of-person
responder-id,name-of-person-or-institution,name-of-institution
transaction-type
delivery-address,postal-address,name-of-person-or-institution,name-of-person
delivery-address,postal-address,name-of-person-or-institution,name-of-institution
delivery-address,postal-address,extended-postal-delivery-address
delivery-address,postal-address,street-and-number
delivery-address,postal-address,post-office-box
delivery-address,postal-address,city
delivery-address,postal-address,region
delivery-address,postal-address,country
delivery-address,postal-address,postal-code
delivery-address,electronic-address,telecom-service-identifier
delivery-address,electronic-address,telecom-service-addreess
billing-address,postal-address,name-of-person-or-institution,name-of-person
billing-address,postal-address,name-of-person-or-institution,name-of-institution
billing-address,postal-address,extended-postal-delivery-address
billing-address,postal-address,street-and-number
billing-address,postal-address,post-office-box
billing-address,postal-address,city
billing-address,postal-address,region
billing-address,postal-address,country
billing-address,postal-address,postal-code
billing-address,electronic-address,telecom-service-identifier
billing-address,electronic-address,telecom-service-addreess
ill-service-type
requester-optional-messages,can-send-RECEIVED
requester-optional-messages,can-send-RETURNED
requester-optional-messages,requester-SHIPPED
requester-optional-messages,requester-CHECKED-IN
search-type,level-of-service
search-type,need-before-date
search-type,expiry-date
search-type,expiry-flag
place-on-hold
client-id,client-name
client-id,client-status
client-id,client-identifier
item-id,item-type
item-id,call-number
item-id,author
item-id,title
item-id,sub-title
item-id,sponsoring-body
item-id,place-of-publication
item-id,publisher
item-id,series-title-number
item-id,volume-issue
item-id,edition
item-id,publication-date
item-id,publication-date-of-component
item-id,author-of-article
item-id,title-of-article
item-id,pagination
item-id,ISBN
item-id,ISSN
item-id,additional-no-letters
item-id,verification-reference-source
copyright-complicance
retry-flag
forward-flag
requester-note
forward-note

There are also a few parameters that are part of the Extended Services Request package and the ItemOrder package:

package-name
user-id
contact-name
contact-phone
contact-email
itemorder-item

返回值

没有返回值。


Prepares for retrieval (Z39.50 present)

  • ? yaz_itemorder
  • yaz_range ?
  • PHP Manual
  • YAZ 函数
  • Prepares for retrieval (Z39.50 present)

yaz_present

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_present — Prepares for retrieval (Z39.50 present)

说明

yaz_present ( resource $id ) : bool

This function prepares for retrieval of records after a successful search.

The yaz_range() function should be called prior to this function to specify the range of records to be retrieved.

参数

id

The connection resource returned by yaz_connect().

返回值

成功时返回 true， 或者在失败时返回 false。


Specifies a range of records to retrieve

  • ? yaz_present
  • yaz_record ?
  • PHP Manual
  • YAZ 函数
  • Specifies a range of records to retrieve

yaz_range

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_range — Specifies a range of records to retrieve

说明

yaz_range ( resource $id , int $start , int $number ) : void

Specifies a range of records to retrieve.

This function should be called before yaz_search() or yaz_present().

参数

id

The connection resource returned by yaz_connect().

start

Specifies the position of the first record to be retrieved. The records numbers goes from 1 to yaz_hits().

number

Specifies the number of records to be retrieved.

返回值

没有返回值。


Returns a record

  • ? yaz_range
  • yaz_scan_result ?
  • PHP Manual
  • YAZ 函数
  • Returns a record

yaz_record

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_record — Returns a record

说明

yaz_record ( resource $id , int $pos , string $type ) : string

The yaz_record() function inspects a record in the current result set at the position specified by parameter pos.

参数

id

The connection resource returned by yaz_connect().

pos

The record position. Records positions in a result set are numbered 1, 2, ... $hits where $hits is the count returned by yaz_hits().

type

The type specifies the form of the returned record.

Note:

It is the application which is responsible for actually ensuring that the records are returned from the Z39.50/SRW server in the proper format. The type given only specifies a conversion to take place on the client side (in PHP/YAZ).

Besides conversion of the transfer record to a string/array, PHP/YAZ it is also possible to perform a character set conversion of the record. Especially for USMARC/MARC21 that is recommended since these are typically returned in the character set MARC-8 that is not supported by browsers, etc. To specify a conversion, add ; charset=from, to where from is the original character set of the record and to is the resulting character set (as seen by PHP).

string

The record is returned as a string for simple display. In this mode, all MARC records are converted to a line-by-line format since ISO2709 is hardly readable. XML records and SUTRS are returned in their original format. GRS-1 are returned in a (ugly) line-by-line format.

This format is suitable if records are to be displayed in a quick way - for debugging - or because it is not feasible to perform proper display.

xml

The record is returned as an XML string if possible. In this mode, all MARC records are converted to » MARCXML. XML records and SUTRS are returned in their original format. GRS-1 is not supported.

This format is similar to string except that MARC records are converted to MARCXML

This format is suitable if records are processed by an XML parser or XSLT processor afterwards.

raw

The record is returned as a string in its original form. This type is suitable for MARC, XML and SUTRS. It does not work for GRS-1.

MARC records are returned as a ISO2709 string. XML and SUTRS are returned as strings.

syntax

The syntax of the record is returned as a string, i.e. USmarc, GRS-1, XML, etc.

database

The name of database associated with record at the position is returned as a string.

array

The record is returned as an array that reflects the GRS-1 structure. This type is suitable for MARC and GRS-1. XML, SUTRS are not supported and if the actual record is XML or SUTRS an empty string will be returned.

The array returned consists of a list corresponding to each leaf/internal node of GRS-1. Each list item consists a sub list with first element path and data (if data is available).

The path which is a string holds a list of each tree component (of the structured GRS-1 record) from root to leaf. Each component is a tag type, tag value pair of the form (type, value

String tags normally has a corresponding tag type 3. MARC can also be returned as an array (they are converted to GRS-1 internally).

返回值

Returns the record at position pos or an empty string if no record exists at the given position.

If no database record exists at the given position an empty string is returned.

范例

Example #1 Array for GRS-1 record

Consider this GRS-1 record:

(4,52)Robert M. Pirsig
(4,70)
      (4,90)
            (2,7)Transworld Publishers, ltd.
This record has two nodes at root level. First element at root level is (4,52) [tag type 4, tag value 52], and has data Robert M. Pirsig. Second element at root level (4,70) has a subtree with a single element (4,90). (4,90) has yet another sub tree (2,7) with data Transworld Publishers, ltd..

If this record is present at position $p, then

<?php

$ar = yaz_record($id, $p, "array");
print_r($ar);

?>
will output:
Array
(
    [0] => Array
        (
            [0] => (4,52)
            [1] => Robert M. Pirsig
        )
    [1] => Array
        (
            [0] => (4,70)
        )
    [2] => Array
        (
            [0] => (4,70)(4,90)
        )
    [3] => Array
        (
            [0] => (4,70)(4,90)(2,7)
            [1] => Transworld Publishers, ltd.
        )
)

Example #2 Working with MARCXML

The following PHP snippet returns a MARC21/USMARC record as MARCXML. The original record is returned in marc-8 (unknown to most XML parsers), so we convert it to UTF-8 (which all XML parsers must support).

<?php
$rec = yaz_record($id, $p, "xml; charset=marc-8,utf-8");
?>

The record $rec can be processed with the Sablotron XSLT processor as follows:

<?php

$xslfile = 'display.xsl';
$processor = xslt_create();
$parms = array('/_xml' => $rec);
$res = xslt_process($processor, 'arg:/_xml', $xslfile, NULL, $parms);
xslt_free($processor);
$res = preg_replace("'</?html[^>]*>'", '', $res);
echo $res;

?>

For PHP 5 the XSL extension must be used instead of Sablotron XSLT.


Returns Scan Response result

  • ? yaz_record
  • yaz_scan ?
  • PHP Manual
  • YAZ 函数
  • Returns Scan Response result

yaz_scan_result

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_scan_result — Returns Scan Response result

说明

yaz_scan_result ( resource $id , array &$result = ? ) : array

yaz_scan_result() returns terms and associated information as received from the server in the last performed yaz_scan().

参数

id

The connection resource returned by yaz_connect().

result

If given, this array will be modified to hold additional information taken from the Scan Response:

  • number - Number of entries returned

  • stepsize - Step size

  • position - Position of term

  • status - Scan status

返回值

Returns an array (0..n-1) where n is the number of terms returned. Each value is a pair where the first item is the term, and the second item is the result-count.


Prepares for a scan

  • ? yaz_scan_result
  • yaz_schema ?
  • PHP Manual
  • YAZ 函数
  • Prepares for a scan

yaz_scan

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_scan — Prepares for a scan

说明

yaz_scan ( resource $id , string $type , string $startterm , array $flags = ? ) : void

This function prepares for a Z39.50 Scan Request on the specified connection.

To actually transfer the Scan Request to the server and receive the Scan Response, yaz_wait() must be called. Upon completion of yaz_wait() call yaz_error() and yaz_scan_result() to handle the response.

参数

id

The connection resource returned by yaz_connect().

type

Currently only type rpn is supported.

startterm

Starting term point for the scan.

The form in which the starting term is specified is given by parameter type.

The syntax this parameter is similar to the RPN query as described in yaz_search(). It consists of zero or more @attr-operator specifications, then followed by exactly one token.

flags

This optional parameter specifies additional information to control the behaviour of the scan request. Three indexes are currently read from the flags array: number (number of terms requested), position (preferred position of term) and stepSize (preferred step size).

返回值

没有返回值。

范例

Example #1 PHP function that scans titles

<?php
function scan_titles($id, $startterm)
{
  yaz_scan($id, "rpn", "@attr 1=4 " . $startterm);
  yaz_wait();
  $errno = yaz_errno($id);
  if ($errno == 0) {
    $ar = yaz_scan_result($id, $options);
    echo 'Scan ok; ';
    foreach ($options as $key => $val) {
      echo "$key = $val &nbsp;";
    }
    echo '<br /><table>';
    while (list($key, list($k, $term, $tcount)) = each($ar)) {
      if (empty($k)) continue;
      echo "<tr><td>$term</td><td>$tcount</td></tr>";
    }
    echo '</table>';
  } else {
    echo "Scan failed. Error: " . yaz_error($id) . "<br />";
  }
}
?>


Specifies schema for retrieval

  • ? yaz_scan
  • yaz_search ?
  • PHP Manual
  • YAZ 函数
  • Specifies schema for retrieval

yaz_schema

(PHP 4 >= 4.2.0, PECL yaz >= 0.9.0)

yaz_schema — Specifies schema for retrieval

说明

yaz_schema ( resource $id , string $schema ) : void

yaz_schema() specifies the schema for retrieval.

This function should be called before yaz_search() or yaz_present().

参数

id

The connection resource returned by yaz_connect().

schema

Must be specified as an OID (Object Identifier) in a raw dot-notation (like 1.2.840.10003.13.4) or as one of the known registered schemas: GILS-schema, Holdings, Zthes, ...

返回值

没有返回值。


Prepares for a search

  • ? yaz_schema
  • yaz_set_option ?
  • PHP Manual
  • YAZ 函数
  • Prepares for a search

yaz_search

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_search — Prepares for a search

说明

yaz_search ( resource $id , string $type , string $query ) : bool

yaz_search() prepares for a search on the given connection.

Like yaz_connect() this function is non-blocking and only prepares for a search to be executed later when yaz_wait() is called.

参数

id

The connection resource returned by yaz_connect().

type

This parameter represents the query type - only "rpn" is supported now in which case the third argument specifies a Type-1 query in prefix query notation.

query

The RPN query is a textual representation of the Type-1 query as defined by the Z39.50 standard. However, in the text representation as used by YAZ a prefix notation is used, that is the operator precedes the operands. The query string is a sequence of tokens where white space is ignored unless surrounded by double quotes. Tokens beginning with an at-character (@) are considered operators, otherwise they are treated as search terms.

RPN Operators
Construct | Description
@and query1 query2 | intersection of query1 and query2
@or query1 query2 | union of query1 and query2
@not query1 query2 | query1 and not query2
@set name | result set reference
@attrset set query | specifies attribute-set for query. This construction is only allowed once - in the beginning of the whole query
@attr [set] type=value query | applies attribute to query. The type and value are integers specifying the attribute-type and attribute-value respectively. The set, if given, specifies the attribute-set.

You can find information about attributes at the » Z39.50 Maintenance Agency site.

Note:

If you would like to use a more friendly notation, use the CCL parser - functions yaz_ccl_conf() and yaz_ccl_parse().

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Query Examples

You can search for simple terms, like this:

computer
which matches documents where "computer" occur. No attributes are specified.

The query

"knuth donald"
matches documents where "knuth donald" occur (provided that the server supports phrase search).

This query applies two attributes for the same phrase.

@attr 1=1003 @attr 4=1 "knuth donald"
First attribute is type 1 (Bib-1 use), attribute value is 1003 (Author). Second attribute has is type 4 (structure), value 1 (phrase), so this should match documents where Donald Knuth is author.

The query

@and @or a b @not @or c d e
would in infix notation look like (a or b) and ((c or d) not e).

Another, more complex, one:

@attrset gils @and @attr 1=4 art @attr 1=2000 company
The query as a whole uses the GILS attributeset. The query matches documents where art occur in the title (GILS,BIB-1) and in which company occur as Distributor (GILS).


Sets one or more options for connection

  • ? yaz_search
  • yaz_sort ?
  • PHP Manual
  • YAZ 函数
  • Sets one or more options for connection

yaz_set_option

(PECL yaz >= 0.9.0)

yaz_set_option — Sets one or more options for connection

说明

yaz_set_option ( resource $id , string $name , string $value ) : void
yaz_set_option ( resource $id , array $options ) : void

Sets one or more options on the given connection.

参数

id

The connection resource returned by yaz_connect().

name or options

May be either a string or an array.

If given as a string, this will be the name of the option to set. You'll need to give it's value.

If given as an array, this will be an associative array (option name => option value).

PHP/YAZ Connection Options
Name | Description
implementationName | implementation name of server
implementationVersion | implementation version of server
implementationId | implementation ID of server
schema | schema for retrieval. By default, no schema is used. Setting this option is equivalent to using function yaz_schema()
preferredRecordSyntax | record syntax for retrieval. By default, no syntax is used. Setting this option is equivalent to using function yaz_syntax()
start | offset for first record to be retrieved via yaz_search() or yaz_present(). First record is numbered has a start value of 0. Second record has start value 1. Setting this option in combination with option count has the same effect as calling yaz_range() except that records are numbered from 1 in yaz_range()
count | maximum number of records to be retrieved via yaz_search() or yaz_present().
elementSetName | element-set-name for retrieval. Setting this option is equivalent to calling yaz_element().
value

The new value of the option. Use this only if the previous argument is a string.

返回值

没有返回值。


Sets sorting criteria

  • ? yaz_set_option
  • yaz_syntax ?
  • PHP Manual
  • YAZ 函数
  • Sets sorting criteria

yaz_sort

(PHP 4 >= 4.0.7, PECL yaz >= 0.9.0)

yaz_sort — Sets sorting criteria

说明

yaz_sort ( resource $id , string $criteria ) : void

This function sets sorting criteria and enables Z39.50 Sort.

Call this function before yaz_search(). Using this function alone does not have any effect. When used in conjunction with yaz_search(), a Z39.50 Sort will be sent after a search response has been received and before any records are retrieved with Z39.50 Present (yaz_present().

参数

id

The connection resource returned by yaz_connect().

criteria

A string that takes the form field1 flags1 field2 flags2 where field1 specifies the primary attributes for sort, field2 seconds, etc..

The field specifies either a numerical attribute combinations consisting of type=value pairs separated by comma (e.g. 1=4,2=1) ; or the field may specify a plain string criteria (e.g. title. The flags is a sequence of the following characters which may not be separated by any white space.

Sort Flags
a

Sort ascending

d

Sort descending

i

Case insensitive sorting

s

Case sensitive sorting

返回值

没有返回值。

范例

Example #1 Sort Criterias

To sort on Bib1 attribute title, case insensitive, and ascending you would use the following sort criteria:

1=4 ia

If the secondary sorting criteria should be author, case sensitive and ascending you would use:

1=4 ia 1=1003 sa


Specifies the preferred record syntax for retrieval

  • ? yaz_sort
  • yaz_wait ?
  • PHP Manual
  • YAZ 函数
  • Specifies the preferred record syntax for retrieval

yaz_syntax

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_syntax — Specifies the preferred record syntax for retrieval

说明

yaz_syntax ( resource $id , string $syntax ) : void

yaz_syntax() specifies the preferred record syntax for retrieval

This function should be called before yaz_search() or yaz_present().

参数

id

The connection resource returned by yaz_connect().

syntax

The syntax must be specified as an OID (Object Identifier) in a raw dot-notation (like 1.2.840.10003.5.10) or as one of the known registered record syntaxes (sutrs, usmarc, grs1, xml, etc.).

返回值

没有返回值。


Wait for Z39.50 requests to complete

  • ? yaz_syntax
  • 0MQ消息系统 ?
  • PHP Manual
  • YAZ 函数
  • Wait for Z39.50 requests to complete

yaz_wait

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_wait — Wait for Z39.50 requests to complete

说明

yaz_wait ( array &$options = ? ) : mixed

This function carries out networked (blocked) activity for outstanding
requests which have been prepared by the functions
yaz_connect(), yaz_search(),
yaz_present(), yaz_scan() and
yaz_itemorder().

yaz_wait() returns when all servers have either completed all requests or aborted (in case of errors).

参数

options

An associative array of options:

timeout

Sets timeout in seconds. If a server has not responded within the timeout it is considered dead and yaz_wait() returns. The default value for timeout is 15 seconds.

event

A boolean.

返回值

成功时返回 true， 或者在失败时返回 false。 In event mode, returns resource 或者在失败时返回 false.


ZMQ

  • 简介
  • 安装／配置
    • 需求
  • ZMQ — The ZMQ class
    • ZMQ::__construct — ZMQ constructor
  • ZMQContext — The ZMQContext class
    • ZMQContext::__construct — Construct a new ZMQContext object
    • ZMQContext::getOpt — Get context option
    • ZMQContext::getSocket — Create a new socket
    • ZMQContext::isPersistent — Whether the context is persistent
    • ZMQContext::setOpt — Set a socket option
  • ZMQSocket — The ZMQSocket class
    • ZMQSocket::bind — Bind the socket
    • ZMQSocket::connect — Connect the socket
    • ZMQSocket::__construct — Construct a new ZMQSocket
    • ZMQSocket::disconnect — Disconnect a socket
    • ZMQSocket::getEndpoints — Get list of endpoints
    • ZMQSocket::getPersistentId — Get the persistent id
    • ZMQSocket::getSocketType — Get the socket type
    • ZMQSocket::getSockOpt — Get socket option
    • ZMQSocket::isPersistent — Whether the socket is persistent
    • ZMQSocket::recv — Receives a message
    • ZMQSocket::recvMulti — Receives a multipart message
    • ZMQSocket::send — Sends a message
    • ZMQSocket::sendmulti — Sends a multipart message
    • ZMQSocket::setSockOpt — Set a socket option
    • ZMQSocket::unbind — Unbind the socket
  • ZMQPoll — The ZMQPoll class
    • ZMQPoll::add — Add item to the poll set
    • ZMQPoll::clear — Clear the poll set
    • ZMQPoll::count — Count items in the poll set
    • ZMQPoll::getLastErrors — Get poll errors
    • ZMQPoll::poll — Poll the items
    • ZMQPoll::remove — Remove item from poll set
  • ZMQDevice — The ZMQDevice class
    • ZMQDevice::__construct — Construct a new device
    • ZMQDevice::getIdleTimeout — Get the idle timeout
    • ZMQDevice::getTimerTimeout — Get the timer timeout
    • ZMQDevice::run — Run the new device
    • ZMQDevice::setIdleCallback — Set the idle callback function
    • ZMQDevice::setIdleTimeout — Set the idle timeout
    • ZMQDevice::setTimerCallback — Set the timer callback function
    • ZMQDevice::setTimerTimeout — Set the timer timeout


简介

"?MQ 是一个能让你快速设计、开发基于消息应用的函数库。"——0MQ官网

关于 0MQ 的更多信息，请参考 » http://zeromq.org/。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • 0MQ消息系统
  • 安装／配置

安装／配置

Table of Contents

  • 需求


需求

ZMQ扩展需要 0MQ 2.0.7及以上版本。 0MQ 可以在这里下载 » http://zeromq.org/area:download。

安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/zmq


The ZMQ class

(PECL zmq >= 0.5.0)

简介

类摘要

ZMQ {
/* Constants */
const int SOCKET_PAIR ;
const int SOCKET_PUB ;
const int SOCKET_SUB ;
const int SOCKET_REQ ;
const int SOCKET_REP ;
const int SOCKET_XREQ ;
const int SOCKET_XREP ;
const int SOCKET_PUSH ;
const int SOCKET_PULL ;
const int SOCKET_ROUTER ;
const int SOCKET_DEALER ;
const int SOCKET_XPUB ;
const int SOCKET_XSUB ;
const int SOCKET_STREAM ;
const int SOCKOPT_HWM ;
const int SOCKOPT_SNDHWM ;
const int SOCKOPT_RCVHWM ;
const int SOCKOPT_AFFINITY ;
const int SOCKOPT_IDENTITY ;
const int SOCKOPT_SUBSCRIBE ;
const int SOCKOPT_UNSUBSCRIBE ;
const int SOCKOPT_RATE ;
const int SOCKOPT_RECOVERY_IVL ;
const int SOCKOPT_RECONNECT_IVL ;
const int SOCKOPT_RECONNECT_IVL_MAX ;
const int SOCKOPT_MCAST_LOOP ;
const int SOCKOPT_SNDBUF ;
const int SOCKOPT_RCVBUF ;
const int SOCKOPT_RCVMORE ;
const int SOCKOPT_TYPE ;
const int SOCKOPT_LINGER ;
const int SOCKOPT_BACKLOG ;
const int SOCKOPT_MAXMSGSIZE ;
const int SOCKOPT_SNDTIMEO ;
const int SOCKOPT_RCVTIMEO ;
const int SOCKOPT_IPV4ONLY ;
const int SOCKOPT_LAST_ENDPOINT ;
const int SOCKOPT_TCP_KEEPALIVE_IDLE ;
const int SOCKOPT_TCP_KEEPALIVE_CNT ;
const int SOCKOPT_TCP_KEEPALIVE_INTVL ;
const int SOCKOPT_TCP_ACCEPT_FILTER ;
const int SOCKOPT_TCP_ACCEPT_FILTER ;
const int SOCKOPT_DELAY_ATTACH_ON_CONNECT ;
const int SOCKOPT_XPUB_VERBOSE ;
const int SOCKOPT_ROUTER_RAW ;
const int SOCKOPT_IPV6 ;
const int CTXOPT_MAX_SOCKETS ;
const int POLL_IN ;
const int POLL_OUT ;
const int MODE_NOBLOCK ;
const int MODE_DONTWAIT ;
const int MODE_SNDMORE ;
const int ERR_INTERNAL ;
const int ERR_EAGAIN ;
const int ERR_ENOTSUP ;
const int ERR_EFSM ;
const int ERR_ETERM ;
/* Methods */
private __construct ( )
}

预定义常量

ZMQ Constant Types

ZMQ::SOCKET_PAIR

Exclusive pair pattern

ZMQ::SOCKET_PUB

Publisher socket

ZMQ::SOCKET_SUB

Subscriber socket

ZMQ::SOCKET_REQ

Request socket

ZMQ::SOCKET_REP

Reply socket

ZMQ::SOCKET_XREQ

Alias for SOCKET_DEALER

ZMQ::SOCKET_XREP

Alias for SOCKET_ROUTER

ZMQ::SOCKET_PUSH

Pipeline upstream push socket

ZMQ::SOCKET_PULL

Pipeline downstream pull socket

ZMQ::SOCKET_ROUTER

Extended REP socket that can route replies to requesters

ZMQ::SOCKET_DEALER

Extended REQ socket that load balances to all connected peers

ZMQ::SOCKET_XPUB

Similar to SOCKET_PUB, except you can receive subscriptions as messages. The subscription message is 0 (unsubscribe) or 1 (subscribe) followed by the topic.

ZMQ::SOCKET_XSUB

Similar to SOCKET_SUB, except you can send subscriptions as messages. See SOCKET_XPUB for format.

ZMQ::SOCKET_STREAM

Used to send and receive TCP data from a non-?MQ peer. Available if compiled against ZeroMQ 4.x or higher (Value: int).

ZMQ::SOCKOPT_HWM

The high water mark for inbound and outbound messages is a hard limit on the maximum number of outstanding messages ?MQ shall queue in memory for any single peer that the specified socket is communicating with. Setting this option on a socket will only affect connections made after the option has been set. On ZeroMQ 3.x this is a wrapper for setting both SNDHWM and RCVHWM. (Value: int).

ZMQ::SOCKOPT_SNDHWM

The ZMQ_SNDHWM option shall set the high water mark for outbound messages on the specified socket. Available if compiled against ZeroMQ 3.x or higher (Value: int).

ZMQ::SOCKOPT_RCVHWM

The SOCKOPT_RCVHWM option shall set the high water mark for inbound messages on the specified socket. Available if compiled against ZeroMQ 3.x or higher (Value: int).

ZMQ::SOCKOPT_AFFINITY

Set I/O thread affinity (Value: int)

ZMQ::SOCKOPT_IDENTITY

Set socket identity (Value: string)

ZMQ::SOCKOPT_SUBSCRIBE

Establish message filter. Valid for subscriber socket (Value: string)

ZMQ::SOCKOPT_UNSUBSCRIBE

Remove message filter. Valid for subscriber socket (Value: string)

ZMQ::SOCKOPT_RATE

Set rate for multicast sockets (pgm) (Value: int >= 0)

ZMQ::SOCKOPT_RECOVERY_IVL

Set multicast recovery interval (Value: int >= 0)

ZMQ::SOCKOPT_RECONNECT_IVL

Set the initial reconnection interval (Value: int >= 0)

ZMQ::SOCKOPT_RECONNECT_IVL_MAX

Set the max reconnection interval (Value: int >= 0)

ZMQ::SOCKOPT_MCAST_LOOP

Control multicast loopback (Value: int >= 0)

ZMQ::SOCKOPT_SNDBUF

Set kernel transmit buffer size (Value: int >= 0)

ZMQ::SOCKOPT_RCVBUF

Set kernel receive buffer size (Value: int >= 0)

ZMQ::SOCKOPT_RCVMORE

Receive multi-part messages (Value: int)

ZMQ::SOCKOPT_TYPE

Get the socket type. Valid for getSockOpt (Value: int)

ZMQ::SOCKOPT_LINGER

The linger value of the socket. Specifies how long the socket blocks trying flush messages after it has been closed (Value: int)

ZMQ::SOCKOPT_BACKLOG

The SOCKOPT_BACKLOG option shall set the maximum length of the queue of outstanding peer connections for the specified socket; this only applies to connection-oriented transports. (Value: int)

ZMQ::SOCKOPT_MAXMSGSIZE

Limits the maximum size of the inbound message. Value -1 means no limit. Available if compiled against ZeroMQ 3.x or higher (Value: int)

ZMQ::SOCKOPT_SNDTIMEO

Sets the timeout for send operation on the socket. Value -1 means no limit. Available if compiled against ZeroMQ 3.x or higher (Value: int)

ZMQ::SOCKOPT_RCVTIMEO

Sets the timeout for receive operation on the socket. Value -1 means no limit. Available if compiled against ZeroMQ 3.x or higher (Value: int)

ZMQ::SOCKOPT_IPV4ONLY

Disable IPV6 support if 1. Available if compiled against ZeroMQ 3.x (Value: int)

ZMQ::SOCKOPT_LAST_ENDPOINT

Retrieve the last connected endpoint - for use with * wildcard ports. Available if compiled against ZeroMQ 3.x or higher (Value: string)

ZMQ::SOCKOPT_TCP_KEEPALIVE_IDLE

Idle time for TCP keepalive. Available if compiled against ZeroMQ 3.x or higher (Value: int)

ZMQ::SOCKOPT_TCP_KEEPALIVE_CNT

Count time for TCP keepalive. Available if compiled against ZeroMQ 3.x or higher (Value: int)

ZMQ::SOCKOPT_TCP_KEEPALIVE_INTVL

Interval for TCP keepalive. Available if compiled against ZeroMQ 3.x or higher (Value: int)

ZMQ::SOCKOPT_DELAY_ATTACH_ON_CONNECT

Set a CIDR string to match against incoming TCP connections. Available if compiled against ZeroMQ 3.x or higher (Value: string)

ZMQ::SOCKOPT_TCP_ACCEPT_FILTER

Set a CIDR string to match against incoming TCP connections. Available if compiled against ZeroMQ 3.x or higher (Value: string)

ZMQ::SOCKOPT_XPUB_VERBOSE

Set the XPUB to receive an application message on each instance of a subscription. Available if compiled against ZeroMQ 3.x or higher (Value: string)

ZMQ::SOCKOPT_ROUTER_RAW

Sets the raw mode on the ROUTER, when set to 1. In raw mode when using tcp:// transport the socket will read and write without ZeroMQ framing. Available if compiled against ZeroMQ 4.0 or higher (Value: string)

ZMQ::SOCKOPT_IPV6

Enable IPV6. Available if compiled against ZeroMQ 4.0 or higher (Value: string)

ZMQ::CTXOPT_MAX_SOCKETS

The socket limit for this context. Available if compiled against ZeroMQ 3.x or higher (Value: int)

ZMQ::POLL_IN

Poll for incoming data

ZMQ::POLL_OUT

Poll for outgoing data

ZMQ::MODE_NOBLOCK

Non-blocking operation. Deprecated, use ZMQ::MODE_DONTWAIT instead

ZMQ::MODE_DONTWAIT

Non-blocking operation

ZMQ::MODE_SNDMORE

Send multi-part message

ZMQ::DEVICE_FORWARDER

Forwarder device

ZMQ::DEVICE_QUEUE

Queue device

ZMQ::DEVICE_STREAMER

Streamer device

ZMQ::ERR_INTERNAL

ZMQ extension internal error

ZMQ::ERR_EAGAIN

Implies that the operation would block when ZMQ::MODE_DONTWAIT is used

ZMQ::ERR_ENOTSUP

The operation is not supported by the socket type

ZMQ::ERR_EFSM

The operation can not be executed because the socket is not in correct state

ZMQ::ERR_ETERM

The context has been terminated

Table of Contents

  • ZMQ::__construct — ZMQ constructor


ZMQ constructor

  • ? ZMQ
  • ZMQContext ?
  • PHP Manual
  • ZMQ
  • ZMQ constructor

ZMQ::__construct

(PECL zmq >= 0.5.0)

ZMQ::__construct — ZMQ constructor

说明

private ZMQ::__construct ( )

Private constructor to prevent direct initialization. This class holds the constants for ZMQ extension.

参数

此函数没有参数。

返回值


The ZMQContext class

(PECL zmq >= 0.5.0)

简介

类摘要

ZMQContext {
/* Methods */
public __construct ( int $io_threads = 1 , bool $is_persistent = true )
public getOpt ( string $key ) : mixed
public getSocket ( int $type , string $persistent_id = null , callable $on_new_socket = null ) : ZMQSocket
public isPersistent ( ) : bool
public setOpt ( int $key , mixed $value ) : ZMQContext
}

Table of Contents

  • ZMQContext::__construct — Construct a new ZMQContext object
  • ZMQContext::getOpt — Get context option
  • ZMQContext::getSocket — Create a new socket
  • ZMQContext::isPersistent — Whether the context is persistent
  • ZMQContext::setOpt — Set a socket option


Construct a new ZMQContext object

  • ? ZMQContext
  • ZMQContext::getOpt ?
  • PHP Manual
  • ZMQContext
  • Construct a new ZMQContext object

ZMQContext::__construct

(PECL zmq >= 0.5.0)

ZMQContext::__construct — Construct a new ZMQContext object

说明

public ZMQContext::__construct ( int $io_threads = 1 , bool $is_persistent = true )

Constructs a new ZMQ context. The context is used to initialize sockets. A persistent context is required to initialize persistent sockets.

参数

io_threads

Number of io-threads in the context.

is_persistent

Whether the context is persistent. Persistent context is stored over multiple requests and is a requirement for persistent sockets.

范例

Example #1 A ZMQContext() example

Construct a new context and allocate request socket from it

<?php
/* Allocate a new context */
$context = new ZMQContext();

/* Create a new socket */
$socket = $context->getSocket(ZMQ::SOCKET_REQ, 'my sock');

/* Connect the socket */
$socket->connect("tcp://example.com:1234");

/* Send a request */
$socket->send("Hello there");

/* Receive back the response */
$message = $socket->recv();
?>

返回值

Throws ZMQContextException if context initialization fails.


Get context option

  • ? ZMQContext::__construct
  • ZMQContext::getSocket ?
  • PHP Manual
  • ZMQContext
  • Get context option

ZMQContext::getOpt

(PECL zmq >= 1.0.4)

ZMQContext::getOpt — Get context option

说明

public ZMQContext::getOpt ( string $key ) : mixed

Returns the value of a context option.

参数

key

An integer representing the option. See the ZMQ::CTXOPT_* constants.

返回值

Returns either a string or an int depending on key. Throws ZMQContextException on error.


Create a new socket

  • ? ZMQContext::getOpt
  • ZMQContext::isPersistent ?
  • PHP Manual
  • ZMQContext
  • Create a new socket

ZMQContext::getSocket

(PECL zmq >= 0.5.0)

ZMQContext::getSocket — Create a new socket

说明

public ZMQContext::getSocket ( int $type , string $persistent_id = null , callable $on_new_socket = null ) : ZMQSocket

Shortcut for creating new sockets from the context. If the context is not persistent the persistent_id parameter is ignored and the socket falls back to being non-persistent. The on_new_socket is called only when a new underlying socket structure is created.

参数

type

ZMQ::SOCKET_* constant to specify socket type.

persistent_id

If persistent_id is specified the socket will be persisted over multiple requests.

on_new_socket

Callback function, which is executed when a new socket structure is created. This function does not get invoked if the underlying persistent connection is re-used. The callback takes ZMQSocket and persistent_id as two arguments.

范例

Example #1 A ZMQContext() example

Basic usage

<?php
/* Allocate a new context */
$context = new ZMQContext();

/* Create a new socket */
$socket = $context->getSocket(ZMQ::SOCKET_REQ, 'my sock');

/* Connect the socket */
$socket->connect("tcp://example.com:1234");

/* Send a request */
$socket->send("Hello there");

/* Receive back the response */
$message = $socket->recv();
echo "Received message: {$message}\n";
?>

返回值

Returns a ZMQSocket object on success. Throws ZMQSocketException on error.


Whether the context is persistent

  • ? ZMQContext::getSocket
  • ZMQContext::setOpt ?
  • PHP Manual
  • ZMQContext
  • Whether the context is persistent

ZMQContext::isPersistent

(PECL zmq >= 0.5.0)

ZMQContext::isPersistent — Whether the context is persistent

说明

public ZMQContext::isPersistent ( ) : bool

Whether the context is persistent. Persistent context is needed for persistent connections as each socket is allocated from a context.

参数

此函数没有参数。

返回值

Returns true if the context is persistent and false if the context is non-persistent.


Set a socket option

  • ? ZMQContext::isPersistent
  • ZMQSocket ?
  • PHP Manual
  • ZMQContext
  • Set a socket option

ZMQContext::setOpt

(PECL zmq >= 1.0.4)

ZMQContext::setOpt — Set a socket option

说明

public ZMQContext::setOpt ( int $key , mixed $value ) : ZMQContext

Sets a ZMQ context option. The type of the value depends on the key. See ZMQ Constant Types for more information.

参数

key

One of the ZMQ::CTXOPT_* constants.

value

The value of the parameter.

返回值

Returns the current object. Throws ZMQContextException on error.


The ZMQSocket class

(PECL zmq >= 0.5.0)

简介

类摘要

ZMQSocket {
/* Methods */
public bind ( string $dsn , bool $force = false ) : ZMQSocket
public connect ( string $dsn , bool $force = false ) : ZMQSocket
public __construct ( ZMQContext $context , int $type , string $persistent_id = null , callable $on_new_socket = null )
public disconnect ( string $dsn ) : ZMQSocket
public getEndpoints ( ) : array
public getPersistentId ( ) : string
public getSocketType ( ) : int
public getSockOpt ( string $key ) : mixed
public isPersistent ( ) : bool
public recv ( int $mode = 0 ) : string
public recvMulti ( int $mode = 0 ) : array
public send ( string $message , int $mode = 0 ) : ZMQSocket
public sendmulti ( array $message , int $mode = 0 ) : ZMQSocket
public setSockOpt ( int $key , mixed $value ) : ZMQSocket
public unbind ( string $dsn ) : ZMQSocket
}

Table of Contents

  • ZMQSocket::bind — Bind the socket
  • ZMQSocket::connect — Connect the socket
  • ZMQSocket::__construct — Construct a new ZMQSocket
  • ZMQSocket::disconnect — Disconnect a socket
  • ZMQSocket::getEndpoints — Get list of endpoints
  • ZMQSocket::getPersistentId — Get the persistent id
  • ZMQSocket::getSocketType — Get the socket type
  • ZMQSocket::getSockOpt — Get socket option
  • ZMQSocket::isPersistent — Whether the socket is persistent
  • ZMQSocket::recv — Receives a message
  • ZMQSocket::recvMulti — Receives a multipart message
  • ZMQSocket::send — Sends a message
  • ZMQSocket::sendmulti — Sends a multipart message
  • ZMQSocket::setSockOpt — Set a socket option
  • ZMQSocket::unbind — Unbind the socket


Bind the socket

  • ? ZMQSocket
  • ZMQSocket::connect ?
  • PHP Manual
  • ZMQSocket
  • Bind the socket

ZMQSocket::bind

(PECL zmq >= 0.5.0)

ZMQSocket::bind — Bind the socket

说明

public ZMQSocket::bind ( string $dsn , bool $force = false ) : ZMQSocket

Bind the socket to an endpoint. The endpoint is defined in format transport://address where transport is one of the following: inproc, ipc, tcp, pgm or epgm.

参数

dsn

The bind dsn, for example transport://address.

force

Tries to bind even if the socket has already been bound to the given endpoint.

返回值

Returns the current object. Throws ZMQSocketException on error.


Connect the socket

  • ? ZMQSocket::bind
  • ZMQSocket::__construct ?
  • PHP Manual
  • ZMQSocket
  • Connect the socket

ZMQSocket::connect

(PECL zmq >= 0.5.0)

ZMQSocket::connect — Connect the socket

说明

public ZMQSocket::connect ( string $dsn , bool $force = false ) : ZMQSocket

Connect the socket to a remote endpoint. The endpoint is defined in format transport://address where transport is one of the following: inproc, ipc, tcp, pgm or epgm.

参数

dsn

The connect dsn, for example transport://address.

force

Tries to connect even if the socket has already been connected to given endpoint.

范例

Example #1 A ZMQContext() example

Construct a new context and allocate request socket from it

<?php
/* Server hostname */
$dsn = "tcp://127.0.0.1:5555";

/* Create a socket */
$socket = new ZMQSocket(new ZMQContext(), ZMQ::SOCKET_REQ, 'my socket');

/* Get list of connected endpoints */
$endpoints = $socket->getEndpoints();

/* Check if the socket is connected */
if (!in_array($dsn, $endpoints['connect'])) {
    echo "<p>Connecting to $dsn</p>";
    $socket->connect($dsn);
} else {
    echo "<p>Already connected to $dsn</p>";
}

/* Send and receive */
$socket->send("Hello!");
$message = $socket->recv();

echo "<p>Server said: {$message}</p>";
?>

返回值

Returns the current object. Throws ZMQSocketException on error.


Construct a new ZMQSocket

  • ? ZMQSocket::connect
  • ZMQSocket::disconnect ?
  • PHP Manual
  • ZMQSocket
  • Construct a new ZMQSocket

ZMQSocket::__construct

(PECL zmq >= 0.5.0)

ZMQSocket::__construct — Construct a new ZMQSocket

说明

public ZMQSocket::__construct ( ZMQContext $context , int $type , string $persistent_id = null , callable $on_new_socket = null )

Constructs a ZMQSocket object. persistent_id parameter can be used to allocated a persistent socket. A persistent socket has to be allocated from a persistent context and it stays connected over multiple requests. The persistent_id parameter can be used to recall the same socket over multiple requests. The on_new_socket is called only when a new underlying socket structure is created.

参数

context

ZMQContext object.

type

The socket type. See ZMQ::SOCKET_* constants.

persistent_id

If persistent_id is specified the socket will be persisted over multiple requests. If context is not persistent the socket falls back to non-persistent mode.

on_new_socket

Callback function, which is executed when a new socket structure is created. This function does not get invoked if the underlying persistent connection is re-used.

范例

Example #1 A ZMQSocket() example

Using callback the bind/connect socket

<?php

/*
  The socket is persistent so this function is called only on the
  first request to the script.
*/
function on_new_socket_cb(ZMQSocket $socket, $persistent_id = null)
{
    if ($persistent_id === 'server') {
        $socket->bind("tcp://localhost:12122");
    } else {
        $socket->connect("tcp://localhost:12122");
    }
}

/* Allocate a new context */
$context = new ZMQContext();

/* Create a new socket */
$socket = $context->getSocket(ZMQ::SOCKET_REP, 'server', 'on_new_socket_cb');

$message = $socket->recv();
echo "Received message: {$message}\n";
?>

The callback signature

Note:

function on_new_socket_cb(ZMQSocket $socket, string $persistent_id = null);

返回值

Throws ZMQSocketException on error.


Disconnect a socket

  • ? ZMQSocket::__construct
  • ZMQSocket::getEndpoints ?
  • PHP Manual
  • ZMQSocket
  • Disconnect a socket

ZMQSocket::disconnect

(PECL zmq >= 1.0.4)

ZMQSocket::disconnect — Disconnect a socket

说明

public ZMQSocket::disconnect ( string $dsn ) : ZMQSocket

Disconnect the socket from a previously connected remote endpoint. The endpoint is defined in format transport://address where transport is one of the following: inproc, ipc, tcp, pgm or epgm.

参数

dsn

The connect dsn, for example transport://address.

返回值

Returns the current object. Throws ZMQSocketException on error.


Get list of endpoints

  • ? ZMQSocket::disconnect
  • ZMQSocket::getPersistentId ?
  • PHP Manual
  • ZMQSocket
  • Get list of endpoints

ZMQSocket::getEndpoints

(PECL zmq >= 0.5.0)

ZMQSocket::getEndpoints — Get list of endpoints

说明

public ZMQSocket::getEndpoints ( ) : array

Returns a list of endpoints where the socket is connected or bound to.

参数

此函数没有参数。

返回值

Returns an array containing elements 'bind' and 'connect'.


Get the persistent id

  • ? ZMQSocket::getEndpoints
  • ZMQSocket::getSocketType ?
  • PHP Manual
  • ZMQSocket
  • Get the persistent id

ZMQSocket::getPersistentId

(PECL zmq >= 0.5.0)

ZMQSocket::getPersistentId — Get the persistent id

说明

public ZMQSocket::getPersistentId ( ) : string

Returns the persistent id of the socket.

参数

此函数没有参数。

返回值

Returns the persistent id string assigned of the object and null if socket is not persistent.


Get the socket type

  • ? ZMQSocket::getPersistentId
  • ZMQSocket::getSockOpt ?
  • PHP Manual
  • ZMQSocket
  • Get the socket type

ZMQSocket::getSocketType

(PECL zmq >= 0.5.0)

ZMQSocket::getSocketType — Get the socket type

说明

public ZMQSocket::getSocketType ( ) : int

Gets the socket type.

参数

此函数没有参数。

返回值

Returns an integer representing the socket type. The integer can be compared against ZMQ::SOCKET_* constants.


Get socket option

  • ? ZMQSocket::getSocketType
  • ZMQSocket::isPersistent ?
  • PHP Manual
  • ZMQSocket
  • Get socket option

ZMQSocket::getSockOpt

(PECL zmq >= 0.5.0)

ZMQSocket::getSockOpt — Get socket option

说明

public ZMQSocket::getSockOpt ( string $key ) : mixed

Returns the value of a socket option.

参数

key

An integer representing the option. See the ZMQ::SOCKOPT_* constants.

返回值

Returns either a string or an int depending on key. Throws ZMQSocketException on error.


Whether the socket is persistent

  • ? ZMQSocket::getSockOpt
  • ZMQSocket::recv ?
  • PHP Manual
  • ZMQSocket
  • Whether the socket is persistent

ZMQSocket::isPersistent

(PECL zmq >= 0.5.0)

ZMQSocket::isPersistent — Whether the socket is persistent

说明

public ZMQSocket::isPersistent ( ) : bool

Check whether the socket is persistent.

参数

此函数没有参数。

返回值

Returns a bool based on whether the socket is persistent or not.


Receives a message

  • ? ZMQSocket::isPersistent
  • ZMQSocket::recvMulti ?
  • PHP Manual
  • ZMQSocket
  • Receives a message

ZMQSocket::recv

(PECL zmq >= 0.5.0)

ZMQSocket::recv — Receives a message

说明

public ZMQSocket::recv ( int $mode = 0 ) : string

Receive a message from a socket. By default receiving will block until a message is available unless ZMQ::MODE_DONTWAIT flag is used. ZMQ::SOCKOPT_RCVMORE socket option can be used for receiving multi-part messages. See ZMQSocket::setSockOpt() for more information.

参数

mode

Pass mode flags to receive multipart messages or non-blocking operation. See ZMQ::MODE_* constants.

范例

Example #1 A send/recv example

Non-blocking send / receive

<?php

/* Create new queue object, there needs to be a server at the other end */
$queue = new ZMQSocket(new ZMQContext(), ZMQ::SOCKET_REQ);
$queue->connect("tcp://127.0.0.1:5555");

/* Assign socket 1 to the queue, send and receive */
$retries = 5;
$sending = true;

/* Start a loop */
do {
    try {
        /* Try to send / receive */
        if ($sending) {
            echo "Sending message\n";
            $queue->send("This is a message", ZMQ::MODE_DONTWAIT);
            $sending = false;
        } else {
            echo "Got response: " . $queue->recv(ZMQ::MODE_DONTWAIT) . "\n";
            break;
        }
    } catch (ZMQSocketException $e) {
        /* EAGAIN means that the operation would have blocked, retry */
        if ($e->getCode() === ZMQ::ERR_EAGAIN) {
            echo " - Got EAGAIN, retrying ($retries)\n";
        } else {
            die(" - Error: " . $e->getMessage());
        }
    }
    /* Sleep a bit between operations */
    usleep(5);
} while (--$retries);
?>

以上例程的输出类似于：

Sending message
 - Unable to execute operation, retrying (4)
Got response: This is a message

返回值

Returns the message. Throws ZMQSocketException in error. If ZMQ::MODE_DONTWAIT is used and the operation would block bool false shall be returned.


Receives a multipart message

  • ? ZMQSocket::recv
  • ZMQSocket::send ?
  • PHP Manual
  • ZMQSocket
  • Receives a multipart message

ZMQSocket::recvMulti

(PECL zmq >= 0.8.0)

ZMQSocket::recvMulti — Receives a multipart message

说明

public ZMQSocket::recvMulti ( int $mode = 0 ) : array

Receive an array multipart message from a socket. By default receiving will block until a message is available unless ZMQ::MODE_NOBLOCK flag is used.

参数

mode

Pass mode flags to receive multipart messages or non-blocking operation. See ZMQ::MODE_* constants.

返回值

Returns the array of message parts. Throws ZMQSocketException in error. If ZMQ::MODE_NOBLOCK is used and the operation would block bool false shall be returned.


Sends a message

  • ? ZMQSocket::recvMulti
  • ZMQSocket::sendmulti ?
  • PHP Manual
  • ZMQSocket
  • Sends a message

ZMQSocket::send

(PECL zmq >= 0.5.0)

ZMQSocket::send — Sends a message

说明

public ZMQSocket::send ( string $message , int $mode = 0 ) : ZMQSocket

Send a message using the socket. The operation can block unless ZMQ::MODE_NOBLOCK is used.

参数

message

The message to send.

mode

Pass mode flags to receive multipart messages or non-blocking operation. See ZMQ::MODE_* constants.

返回值

Returns the current object. Throws ZMQSocketException on error. If ZMQ::MODE_NOBLOCK is used and the operation would block bool false shall be returned.


Sends a multipart message

  • ? ZMQSocket::send
  • ZMQSocket::setSockOpt ?
  • PHP Manual
  • ZMQSocket
  • Sends a multipart message

ZMQSocket::sendmulti

(PECL zmq >= 0.8.0)

ZMQSocket::sendmulti — Sends a multipart message

说明

public ZMQSocket::sendmulti ( array $message , int $mode = 0 ) : ZMQSocket

Send a multipart message using the socket. The operation can block unless ZMQ::MODE_NOBLOCK is used.

参数

message

The message to send - an array of strings

mode

Pass mode flags to receive multipart messages or non-blocking operation. See ZMQ::MODE_* constants.

返回值

Returns the current object. Throws ZMQSocketException on error. If ZMQ::MODE_NOBLOCK is used and the operation would block bool false shall be returned.


Set a socket option

  • ? ZMQSocket::sendmulti
  • ZMQSocket::unbind ?
  • PHP Manual
  • ZMQSocket
  • Set a socket option

ZMQSocket::setSockOpt

(PECL zmq >= 0.5.0)

ZMQSocket::setSockOpt — Set a socket option

说明

public ZMQSocket::setSockOpt ( int $key , mixed $value ) : ZMQSocket

Sets a ZMQ socket option. The type of the value depends on the key. See ZMQ Constant Types for more information.

参数

key

One of the ZMQ::SOCKOPT_* constants.

value

The value of the parameter.

返回值

Returns the current object. Throws ZMQSocketException on error.


Unbind the socket

  • ? ZMQSocket::setSockOpt
  • ZMQPoll ?
  • PHP Manual
  • ZMQSocket
  • Unbind the socket

ZMQSocket::unbind

(PECL zmq >= 1.0.4)

ZMQSocket::unbind — Unbind the socket

说明

public ZMQSocket::unbind ( string $dsn ) : ZMQSocket

Unbind the socket from an endpoint. The endpoint is defined in format transport://address where transport is one of the following: inproc, ipc, tcp, pgm or epgm.

参数

dsn

The previously bound dsn, for example transport://address.

返回值

Returns the current object. Throws ZMQSocketException on error.


The ZMQPoll class

(PECL zmq >= 0.5.0)

简介

类摘要

ZMQPoll {
/* Methods */
public add ( mixed $entry , int $type ) : string
public clear ( ) : ZMQPoll
public count ( ) : int
public getLastErrors ( ) : array
public poll ( array &$readable , array &$writable , int $timeout = -1 ) : int
public remove ( mixed $item ) : bool
}

Table of Contents

  • ZMQPoll::add — Add item to the poll set
  • ZMQPoll::clear — Clear the poll set
  • ZMQPoll::count — Count items in the poll set
  • ZMQPoll::getLastErrors — Get poll errors
  • ZMQPoll::poll — Poll the items
  • ZMQPoll::remove — Remove item from poll set


Add item to the poll set

  • ? ZMQPoll
  • ZMQPoll::clear ?
  • PHP Manual
  • ZMQPoll
  • Add item to the poll set

ZMQPoll::add

(PECL zmq >= 0.5.0)

ZMQPoll::add — Add item to the poll set

说明

public ZMQPoll::add ( mixed $entry , int $type ) : string

Adds a new item to the poll set and returns the internal id of the added item. The item can be removed from the poll set using the returned string id.

参数

entry

ZMQSocket object or a PHP stream resource

type

Defines what activity the socket is polled for. See ZMQ::POLL_IN and ZMQ::POLL_OUT constants.

返回值

Returns a string id of the added item which can be later used to remove the item. Throws ZMQPollException on error.


Clear the poll set

  • ? ZMQPoll::add
  • ZMQPoll::count ?
  • PHP Manual
  • ZMQPoll
  • Clear the poll set

ZMQPoll::clear

(PECL zmq >= 0.5.0)

ZMQPoll::clear — Clear the poll set

说明

public ZMQPoll::clear ( ) : ZMQPoll

Clears all elements from the poll set.

参数

此函数没有参数。

返回值

Returns the current object.


Count items in the poll set

  • ? ZMQPoll::clear
  • ZMQPoll::getLastErrors ?
  • PHP Manual
  • ZMQPoll
  • Count items in the poll set

ZMQPoll::count

(PECL zmq >= 0.5.0)

ZMQPoll::count — Count items in the poll set

说明

public ZMQPoll::count ( ) : int

Count the items in the poll set.

参数

此函数没有参数。

返回值

Returns an int representing the amount of items in the poll set.


Get poll errors

  • ? ZMQPoll::count
  • ZMQPoll::poll ?
  • PHP Manual
  • ZMQPoll
  • Get poll errors

ZMQPoll::getLastErrors

(PECL zmq >= 0.5.0)

ZMQPoll::getLastErrors — Get poll errors

说明

public ZMQPoll::getLastErrors ( ) : array

Returns the ids of the objects that had errors in the last poll.

参数

此函数没有参数。

返回值

Returns an array containing ids for the items that had errors in the last poll. Empty array is returned if there were no errors.


Poll the items

  • ? ZMQPoll::getLastErrors
  • ZMQPoll::remove ?
  • PHP Manual
  • ZMQPoll
  • Poll the items

ZMQPoll::poll

(PECL zmq >= 0.5.0)

ZMQPoll::poll — Poll the items

说明

public ZMQPoll::poll ( array &$readable , array &$writable , int $timeout = -1 ) : int

Polls the items in the current poll set. The readable and writable items are returned in the readable and writable parameters. ZMQPoll::getLastErrors() can be used to check if there were errors.

参数

readable

Array where readable ZMQSockets/PHP streams are returned. The array will be cleared at the beginning of the operation.

writable

Array where writable ZMQSockets/PHP streams are returned. The array will be cleared at the beginning of the operation.

timeout

Timeout for the operation. -1 means that poll waits until at least one item has activity. Please note that starting from version 1.0.0 the poll timeout is defined in milliseconds, rather than microseconds.

范例

Example #1 A ZMQPoll() example

Create a simple poll server

<?php

/* Create socket, request-reply pattern (reply socket) */
$context = new ZMQContext();
$server  = $context->getSocket(ZMQ::SOCKET_REP);

/* Bind to port 5555 on 127.0.0.1 */
$server->bind("tcp://127.0.0.1:5555");

/* Create new pollset for incoming/outgoing message */
$poll = new ZMQPoll();

/* Add the object and listen for poll in/out */
$id = $poll->add($server, ZMQ::POLL_IN | ZMQ::POLL_OUT);
echo "Added object with id " . $id . "\n";

/* Initialise readable and writable arrays */
$readable = array();
$writable = array();

while (true) {
   /* Amount of events retrieved */
   $events = 0;

   try {
       /* Poll until there is something to do */
       $events = $poll->poll($readable, $writable, -1);
       $errors = $poll->getLastErrors();

       if (count($errors) > 0) {
           foreach ($errors as $error) {
               echo "Error polling object " . $error . "\n";
           }
       }
   } catch (ZMQPollException $e) {
       echo "poll failed: " . $e->getMessage() . "\n";
   }

   if ($events > 0) {
       /* Loop through readable objects and recv messages */
       foreach ($readable as $r) {
           try {
               echo "Received message: " . $r->recv() . "\n";
           } catch (ZMQException $e) {
               echo "recv failed: " . $e->getMessage() . "\n";
           }
       }

       /* Loop through writable and send back messages */
       foreach ($writable as $w) {
           try {
               $w->send("Got it!");
           } catch (ZMQException $e) {
               echo "send failed: " . $e->getMessage() . "\n";
           }
       }
   }
}
?>

返回值

Returns an integer representing amount of items with activity. Throws ZMQPollException on error.


Remove item from poll set

  • ? ZMQPoll::poll
  • ZMQDevice ?
  • PHP Manual
  • ZMQPoll
  • Remove item from poll set

ZMQPoll::remove

(PECL zmq >= 0.5.0)

ZMQPoll::remove — Remove item from poll set

说明

public ZMQPoll::remove ( mixed $item ) : bool

Remove item from the poll set. The item parameter can be ZMQSocket object, a stream resource or the id returned from ZMQPoll::add() method.

参数

item

The ZMQSocket object, PHP stream or string id of the item.

返回值

Returns true if the item was removed and false if the object with given id does not exist in the poll set.


The ZMQDevice class

(PECL zmq >= 0.5.0)

简介

类摘要

ZMQDevice {
/* Methods */
public __construct ( ZMQSocket $frontend , ZMQSocket $backend , ZMQSocket $listener = ? )
public getIdleTimeout ( ) : ZMQDevice
public getTimerTimeout ( ) : ZMQDevice
public run ( ) : void
public setIdleCallback ( callable $cb_func , int $timeout , mixed $user_data = ? ) : ZMQDevice
public setIdleTimeout ( int $timeout ) : ZMQDevice
public setTimerCallback ( callable $cb_func , int $timeout , mixed $user_data = ? ) : ZMQDevice
public setTimerTimeout ( int $timeout ) : ZMQDevice
}

Table of Contents

  • ZMQDevice::__construct — Construct a new device
  • ZMQDevice::getIdleTimeout — Get the idle timeout
  • ZMQDevice::getTimerTimeout — Get the timer timeout
  • ZMQDevice::run — Run the new device
  • ZMQDevice::setIdleCallback — Set the idle callback function
  • ZMQDevice::setIdleTimeout — Set the idle timeout
  • ZMQDevice::setTimerCallback — Set the timer callback function
  • ZMQDevice::setTimerTimeout — Set the timer timeout


Construct a new device

  • ? ZMQDevice
  • ZMQDevice::getIdleTimeout ?
  • PHP Manual
  • ZMQDevice
  • Construct a new device

ZMQDevice::__construct

(PECL zmq >= 0.5.0)

ZMQDevice::__construct — Construct a new device

说明

public ZMQDevice::__construct ( ZMQSocket $frontend , ZMQSocket $backend , ZMQSocket $listener = ? )

"?MQ devices can do intermediation of addresses, services, queues, or any other abstraction you care to define above the message and socket layers." -- zguide

参数

frontend

Frontend parameter for the devices. Usually where there messages are coming.

backend

Backend parameter for the devices. Usually where there messages going to.

listener

Listener socket, which receives a copy of all messages going both directions. The type of this socket should be SUB, PULL or DEALER.

返回值

Call to this method will prepare the device. Usually devices are very long running processes so running this method from interactive script is not recommended. This method throw ZMQDeviceException if the device cannot be started.


Get the idle timeout

  • ? ZMQDevice::__construct
  • ZMQDevice::getTimerTimeout ?
  • PHP Manual
  • ZMQDevice
  • Get the idle timeout

ZMQDevice::getIdleTimeout

(No version information available, might only be in Git)

ZMQDevice::getIdleTimeout — Get the idle timeout

说明

public ZMQDevice::getIdleTimeout ( ) : ZMQDevice

Gets the idle callback timeout value. Added in ZMQ extension version 1.1.0.

返回值

This method returns the idle callback timeout value.


Get the timer timeout

  • ? ZMQDevice::getIdleTimeout
  • ZMQDevice::run ?
  • PHP Manual
  • ZMQDevice
  • Get the timer timeout

ZMQDevice::getTimerTimeout

(No version information available, might only be in Git)

ZMQDevice::getTimerTimeout — Get the timer timeout

说明

public ZMQDevice::getTimerTimeout ( ) : ZMQDevice

Gets the timer callback timeout value. Added in ZMQ extension version 1.1.0.

返回值

This method returns the timer timeout value.


Run the new device

  • ? ZMQDevice::getTimerTimeout
  • ZMQDevice::setIdleCallback ?
  • PHP Manual
  • ZMQDevice
  • Run the new device

ZMQDevice::run

(No version information available, might only be in Git)

ZMQDevice::run — Run the new device

说明

public ZMQDevice::run ( ) : void

Runs the device.

参数

此函数没有参数。

返回值

Call to this method will block until the device is running. It is not recommended that devices are used from interactive scripts. On failure this method will throw ZMQDeviceException.


Set the idle callback function

  • ? ZMQDevice::run
  • ZMQDevice::setIdleTimeout ?
  • PHP Manual
  • ZMQDevice
  • Set the idle callback function

ZMQDevice::setIdleCallback

(No version information available, might only be in Git)

ZMQDevice::setIdleCallback — Set the idle callback function

说明

public ZMQDevice::setIdleCallback ( callable $cb_func , int $timeout , mixed $user_data = ? ) : ZMQDevice

Sets the idle callback function. If idle timeout is defined the idle callback function shall be called if the internal poll loop times out without events. If the callback function returns false or a value that evaluates to false the device is stopped. The callback function signature is callback (mixed $user_data).

参数

cb_func

Callback function to invoke when the device is idle. Returning false or a value that evaluates to false from this function will cause the device to stop.

timeout

How often to invoke the idle callback in milliseconds. The idle callback is invoked periodically when there is no activity on the device. The timeout value guarantees that there is at least this amount of milliseconds between invocations of the callback function.

user_data

Additional data to pass to the callback function.

返回值

On success this method returns the current object.


Set the idle timeout

  • ? ZMQDevice::setIdleCallback
  • ZMQDevice::setTimerCallback ?
  • PHP Manual
  • ZMQDevice
  • Set the idle timeout

ZMQDevice::setIdleTimeout

(No version information available, might only be in Git)

ZMQDevice::setIdleTimeout — Set the idle timeout

说明

public ZMQDevice::setIdleTimeout ( int $timeout ) : ZMQDevice

Sets the idle callback timeout value. The idle callback is invoked periodically when the device is idle.

参数

timeout

The idle callback timeout value.

返回值

On success this method returns the current object.


Set the timer callback function

  • ? ZMQDevice::setIdleTimeout
  • ZMQDevice::setTimerTimeout ?
  • PHP Manual
  • ZMQDevice
  • Set the timer callback function

ZMQDevice::setTimerCallback

(No version information available, might only be in Git)

ZMQDevice::setTimerCallback — Set the timer callback function

说明

public ZMQDevice::setTimerCallback ( callable $cb_func , int $timeout , mixed $user_data = ? ) : ZMQDevice

Sets the timer callback function. The timer callback will be invoked after timeout has passed. The difference between idle and timer callbacks are that idle callback is invoked only when the device is idle. The callback function signature is callback (mixed $user_data). Added in ZMQ extension version 1.1.0.

参数

cb_func

Callback function to invoke when the device is idle. Returning false or a value that evaluates to false from this function will cause the device to stop.

timeout

How often to invoke the idle callback in milliseconds. The idle callback is invoked periodically when there is no activity on the device. The timeout value guarantees that there is at least this amount of milliseconds between invocations of the callback function.

user_data

Additional data to pass to the callback function.

返回值

On success this method returns the current object.


Set the timer timeout

  • ? ZMQDevice::setTimerCallback
  • ZooKeeper ?
  • PHP Manual
  • ZMQDevice
  • Set the timer timeout

ZMQDevice::setTimerTimeout

(No version information available, might only be in Git)

ZMQDevice::setTimerTimeout — Set the timer timeout

说明

public ZMQDevice::setTimerTimeout ( int $timeout ) : ZMQDevice

Sets the timer callback timeout value. The timer callback is invoked periodically if it's set. Added in ZMQ extension version 1.1.0.

参数

timeout

The timer callback timeout value.

返回值

On success this method returns the current object.


ZooKeeper

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • ZooKeeper 函数
    • zookeeper_dispatch — Calls callbacks for pending operations
  • Zookeeper — The Zookeeper class
    • Zookeeper::addAuth — Specify application credentials
    • Zookeeper::close — Close the zookeeper handle and free up any resources
    • Zookeeper::connect — Create a handle to used communicate with zookeeper
    • Zookeeper::__construct — Create a handle to used communicate with zookeeper
    • Zookeeper::create — Create a node synchronously
    • Zookeeper::delete — Delete a node in zookeeper synchronously
    • Zookeeper::exists — Checks the existence of a node in zookeeper synchronously
    • Zookeeper::get — Gets the data associated with a node synchronously
    • Zookeeper::getAcl — Gets the acl associated with a node synchronously
    • Zookeeper::getChildren — Lists the children of a node synchronously
    • Zookeeper::getClientId — Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
    • Zookeeper::getConfig — Get instance of ZookeeperConfig
    • Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect
    • Zookeeper::getState — Get the state of the zookeeper connection
    • Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered
    • Zookeeper::set — Sets the data associated with a node
    • Zookeeper::setAcl — Sets the acl associated with a node synchronously
    • Zookeeper::setDebugLevel — Sets the debugging level for the library
    • Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization
    • Zookeeper::setLogStream — Sets the stream to be used by the library for logging
    • Zookeeper::setWatcher — Set a watcher function
  • ZookeeperConfig — The ZookeeperConfig class
    • ZookeeperConfig::add — Add servers to the ensemble
    • ZookeeperConfig::get — Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
    • ZookeeperConfig::remove — Remove servers from the ensemble
    • ZookeeperConfig::set — Change ZK cluster ensemble membership and roles of ensemble peers
  • ZookeeperException — The ZookeeperException class
  • ZookeeperAuthenticationException — The ZookeeperAuthenticationException class
  • ZookeeperConnectionException — The ZookeeperConnectionException class
  • ZookeeperMarshallingException — The ZookeeperMarshallingException class
  • ZookeeperNoNodeException — The ZookeeperNoNodeException class
  • ZookeeperOperationTimeoutException — The ZookeeperOperationTimeoutException class
  • ZookeeperSessionException — The ZookeeperSessionException class


简介

This extension uses libzookeeper library to provide API for communicating with ZooKeeper service.

ZooKeeper is an Apache project that enables centralized service for maintaining configuration information, naming, providing distributed synchronization, and providing group services.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • ZooKeeper
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

This extension requires » ZooKeeper C Binding (version 3.4.1 or greater). For more information, see » ZooKeeper Programmer's Guide.

This extension requires PHP version 5.2.0 or higher. Since 0.6.0, it requires PHP version 7.0.0 or higher.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/zookeeper.

To enable zookeeper support, configure with --with-libzookeeper-dir=DIR. DIR is the install prefix of ZooKeeper C Binding, which must contain the include/zookeeper/zookeeper.h

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Zookeeper 配置选项
名字 | 默认 | 可修改范围 | Changelog
zookeeper.recv_timeout | 10000 | PHP_INI_ALL |
zookeeper.session_lock | 1 | PHP_INI_SYSTEM |
zookeeper.sess_lock_wait | 150000 | PHP_INI_ALL |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

zookeeper.recv_timeout int

Default the timeout for any ZooKeeper session.

zookeeper.session_lock int

Enable PHP session locking.

zookeeper.sess_lock_wait int

PHP Session spin lock retry wait time in microseconds. Be carefull when setting this value. Valid values are integers, where 0 is interpreted as the default value. Negative values result in a reduces locking to a try lock.


  • ? 资源类型
  • ZooKeeper 函数 ?
  • PHP Manual
  • ZooKeeper
  • 预定义常量

预定义常量

此扩展没有定义常量。


ZooKeeper 函数

Table of Contents

  • zookeeper_dispatch — Calls callbacks for pending operations


Calls callbacks for pending operations

  • ? ZooKeeper 函数
  • Zookeeper ?
  • PHP Manual
  • ZooKeeper 函数
  • Calls callbacks for pending operations

zookeeper_dispatch

(PECL zookeeper >= 0.4.0)

zookeeper_dispatch — Calls callbacks for pending operations

说明

zookeeper_dispatch ( ) : void

The zookeeper_dispatch() function calls the callbacks passwd by operations like Zookeeper::get() or Zookeeper::exists().

Caution

Since version 0.4.0, this function must be called manually to achieve asynchronous operations. If you want that to be done automatically, you also can declare ticks at the beginning of your program.

After PHP 7.1, you can ignore this function. This extension uses EG(vm_interrupt) to implement async dispatch.

错误／异常

This method emits PHP warning when callback could not be invoked.

范例

Example #1 zookeeper_dispatch() example #1

Dispatch callbacks manually.

<?php
$client = new Zookeeper();
$client->connect('localhost:2181');
$client->get('/zookeeper', function() {
    echo "Callback was called".PHP_EOL;
});
while(true) {
    sleep(1);
    zookeeper_dispatch();
}
?>

Example #2 zookeeper_dispatch() example #2

Declare ticks.

<?php
declare(ticks=1);

$client = new Zookeeper();
$client->connect('localhost:2181');
$client->get('/zookeeper', function() {
    echo "Callback was called".PHP_EOL;
});
while(true) {
    sleep(1);
}
?>

参见

  • Zookeeper::addAuth() - Specify application credentials
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::exists() - Checks the existence of a node in zookeeper synchronously
  • Zookeeper::get() - Gets the data associated with a node synchronously
  • Zookeeper::getChildren() - Lists the children of a node synchronously
  • Zookeeper::setWatcher() - Set a watcher function


The Zookeeper class

(PECL zookeeper >= 0.1.0)

简介

Represents ZooKeeper session.

类摘要

Zookeeper {
/* 方法 */
public __construct ( string $host = '' , callable $watcher_cb = null , int $recv_timeout = 10000 )
public addAuth ( string $scheme , string $cert , callable $completion_cb = null ) : bool
public close ( ) : void
public connect ( string $host , callable $watcher_cb = null , int $recv_timeout = 10000 ) : void
public create ( string $path , string $value , array $acls , int $flags = null ) : string
public delete ( string $path , int $version = -1 ) : bool
public exists ( string $path , callable $watcher_cb = null ) : array
public get ( string $path , callable $watcher_cb = null , array &$stat = null , int $max_size = 0 ) : string
public getAcl ( string $path ) : array
public getChildren ( string $path , callable $watcher_cb = null ) : array
public getClientId ( ) : int
public getConfig ( ) : ZookeeperConfig
public getRecvTimeout ( ) : int
public getState ( ) : int
public isRecoverable ( ) : bool
public set ( string $path , string $value , int $version = -1 , array &$stat = null ) : bool
public setAcl ( string $path , int $version , array $acl ) : bool
public static setDebugLevel ( int $logLevel ) : bool
public static setDeterministicConnOrder ( bool $yesOrNo ) : bool
public setLogStream ( resource $stream ) : bool
public setWatcher ( callable $watcher_cb ) : bool
/* 常量 */
const int PERM_READ = 1 ;
const int PERM_WRITE = 2 ;
const int PERM_CREATE = 4 ;
const int PERM_DELETE = 8 ;
const int PERM_ADMIN = 16 ;
const int PERM_ALL = 31 ;
const int EPHEMERAL = 1 ;
const int SEQUENCE = 2 ;
const int LOG_LEVEL_ERROR = 1 ;
const int LOG_LEVEL_WARN = 2 ;
const int LOG_LEVEL_INFO = 3 ;
const int LOG_LEVEL_DEBUG = 4 ;
const int EXPIRED_SESSION_STATE = -112 ;
const int AUTH_FAILED_STATE = -113 ;
const int CONNECTING_STATE = 1 ;
const int ASSOCIATING_STATE = 2 ;
const int CONNECTED_STATE = 3 ;
const int READONLY_STATE = 5 ;
const int NOTCONNECTED_STATE = 999 ;
const int CREATED_EVENT = 1 ;
const int DELETED_EVENT = 2 ;
const int CHANGED_EVENT = 3 ;
const int CHILD_EVENT = 4 ;
const int SESSION_EVENT = -1 ;
const int NOTWATCHING_EVENT = -2 ;
const int SYSTEMERROR = -1 ;
const int RUNTIMEINCONSISTENCY = -2 ;
const int DATAINCONSISTENCY = -3 ;
const int CONNECTIONLOSS = -4 ;
const int MARSHALLINGERROR = -5 ;
const int UNIMPLEMENTED = -6 ;
const int OPERATIONTIMEOUT = -7 ;
const int BADARGUMENTS = -8 ;
const int INVALIDSTATE = -9 ;
const int NEWCONFIGNOQUORUM = -13 ;
const int RECONFIGINPROGRESS = -14 ;
const int OK = 0 ;
const int APIERROR = -100 ;
const int NONODE = -101 ;
const int NOAUTH = -102 ;
const int BADVERSION = -103 ;
const int NOCHILDRENFOREPHEMERALS = -108 ;
const int NODEEXISTS = -110 ;
const int NOTEMPTY = -111 ;
const int SESSIONEXPIRED = -112 ;
const int INVALIDCALLBACK = -113 ;
const int INVALIDACL = -114 ;
const int AUTHFAILED = -115 ;
const int CLOSING = -116 ;
const int NOTHING = -117 ;
const int SESSIONMOVED = -118 ;
const int NOTREADONLY = -119 ;
const int EPHEMERALONLOCALSESSION = -120 ;
const int NOWATCHER = -121 ;
const int RECONFIGDISABLED = -122 ;
}

预定义常量

ZooKeeper Permissions

Zookeeper::PERM_READ

Can read nodes value and list its children

Zookeeper::PERM_WRITE

Can set the nodes value

Zookeeper::PERM_CREATE

Can create children

Zookeeper::PERM_DELETE

Can delete children

Zookeeper::PERM_ADMIN

Can execute set_acl()

Zookeeper::PERM_ALL

All of the above flags ORd together

ZooKeeper Create Flags

Zookeeper::EPHEMERAL

If Zookeeper::EPHEMERAL flag is set, the node will automatically get removed if the client session goes away.

Zookeeper::SEQUENCE

If the Zookeeper::SEQUENCE flag is set, a unique monotonically increasing sequence number is appended to the path name. The sequence number is always fixed length of 10 digits, 0 padded.

ZooKeeper Log Levels

Zookeeper::LOG_LEVEL_ERROR

Outputs only error mesages

Zookeeper::LOG_LEVEL_WARN

Outputs errors/warnings

Zookeeper::LOG_LEVEL_INFO

Outputs big action messages besides errors/warnings

Zookeeper::LOG_LEVEL_DEBUG

Outputs all

ZooKeeper States

Zookeeper::EXPIRED_SESSION_STATE

Connected but session expired

Zookeeper::AUTH_FAILED_STATE

Connected but auth failed

Zookeeper::CONNECTING_STATE

Connecting

Zookeeper::ASSOCIATING_STATE

Associating

Zookeeper::CONNECTED_STATE

Connected

Zookeeper::READONLY_STATE

TODO: help us improve this extension.

Zookeeper::NOTCONNECTED_STATE

Connection failed

ZooKeeper Watch Types

Zookeeper::CREATED_EVENT

A node has been created

This is only generated by watches on non-existent nodes. These watches are set using Zookeeper::exists.

Zookeeper::DELETED_EVENT

A node has been deleted

This is only generated by watches on nodes. These watches are set using Zookeeper::exists and Zookeeper::get.

Zookeeper::CHANGED_EVENT

A node has changed

This is only generated by watches on nodes. These watches are set using Zookeeper::exists and Zookeeper::get.

Zookeeper::CHILD_EVENT

A change as occurred in the list of children

This is only generated by watches on the child list of a node. These watches are set using Zookeeper::getChildren.

Zookeeper::SESSION_EVENT

A session has been lost

This is generated when a client loses contact or reconnects with a server.

Zookeeper::NOTWATCHING_EVENT

A watch has been removed

This is generated when the server for some reason, probably a resource constraint, will no longer watch a node for a client.

ZooKeeper System and Server-side Errors

Zookeeper::SYSTEMERROR

This is never thrown by the server, it shouldn't be used other than to indicate a range. Specifically error codes greater than this value, but lesser than Zookeeper::APIERROR, are system errors.

Zookeeper::RUNTIMEINCONSISTENCY

A runtime inconsistency was found.

Zookeeper::DATAINCONSISTENCY

A data inconsistency was found.

Zookeeper::CONNECTIONLOSS

Connection to the server has been lost.

Zookeeper::MARSHALLINGERROR

Error while marshalling or unmarshalling data.

Zookeeper::UNIMPLEMENTED

Operation is unimplemented.

Zookeeper::OPERATIONTIMEOUT

Operation timeout.

Zookeeper::BADARGUMENTS

Invalid arguments.

Zookeeper::INVALIDSTATE

Invliad zhandle state.

Zookeeper::NEWCONFIGNOQUORUM

No quorum of new config is connected and up-to-date with the leader of last committed config - try invoking reconfiguration after new servers are connected and synced.

Available as of ZooKeeper 3.5.0

Zookeeper::RECONFIGINPROGRESS

Reconfiguration requested while another reconfiguration is currently in progress. This is currently not supported. Please retry.

Available as of ZooKeeper 3.5.0

ZooKeeper API Errors

Zookeeper::OK

Everything is OK.

Zookeeper::APIERROR

This is never thrown by the server, it shouldn't be used other than to indicate a range. Specifically error codes greater than this value are API errors (while values less than this indicate a Zookeeper::SYSTEMERROR).

Zookeeper::NONODE

Node does not exist.

Zookeeper::NOAUTH

Not authenticated.

Zookeeper::BADVERSION

Version conflict.

Zookeeper::NOCHILDRENFOREPHEMERALS

Ephemeral nodes may not have children.

Zookeeper::NODEEXISTS

The node already exists.

Zookeeper::NOTEMPTY

The node has children.

Zookeeper::SESSIONEXPIRED

The session has been expired by the server.

Zookeeper::INVALIDCALLBACK

Invalid callback specified.

Zookeeper::INVALIDACL

Invalid ACL specified.

Zookeeper::AUTHFAILED

Client authentication failed.

Zookeeper::CLOSING

ZooKeeper is closing.

Zookeeper::NOTHING

(not error) No server responses to process.

Zookeeper::SESSIONMOVED

Session moved to another server, so operation is ignored.

Zookeeper::NOTREADONLY

State-changing request is passed to read-only server.

Zookeeper::EPHEMERALONLOCALSESSION

Attempt to create ephemeral node on a local session.

Zookeeper::NOWATCHER

The watcher couldn't be found.

Zookeeper::RECONFIGDISABLED

Attempts to perform a reconfiguration operation when reconfiguration feature is disabled.

Table of Contents

  • Zookeeper::addAuth — Specify application credentials
  • Zookeeper::close — Close the zookeeper handle and free up any resources
  • Zookeeper::connect — Create a handle to used communicate with zookeeper
  • Zookeeper::__construct — Create a handle to used communicate with zookeeper
  • Zookeeper::create — Create a node synchronously
  • Zookeeper::delete — Delete a node in zookeeper synchronously
  • Zookeeper::exists — Checks the existence of a node in zookeeper synchronously
  • Zookeeper::get — Gets the data associated with a node synchronously
  • Zookeeper::getAcl — Gets the acl associated with a node synchronously
  • Zookeeper::getChildren — Lists the children of a node synchronously
  • Zookeeper::getClientId — Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • Zookeeper::getConfig — Get instance of ZookeeperConfig
  • Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect
  • Zookeeper::getState — Get the state of the zookeeper connection
  • Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered
  • Zookeeper::set — Sets the data associated with a node
  • Zookeeper::setAcl — Sets the acl associated with a node synchronously
  • Zookeeper::setDebugLevel — Sets the debugging level for the library
  • Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization
  • Zookeeper::setLogStream — Sets the stream to be used by the library for logging
  • Zookeeper::setWatcher — Set a watcher function


Specify application credentials

  • ? Zookeeper
  • Zookeeper::close ?
  • PHP Manual
  • Zookeeper
  • Specify application credentials

Zookeeper::addAuth

(PECL zookeeper >= 0.1.0)

Zookeeper::addAuth — Specify application credentials

说明

public Zookeeper::addAuth ( string $scheme , string $cert , callable $completion_cb = null ) : bool

The application calls this function to specify its credentials for purposes of authentication. The server will use the security provider specified by the scheme parameter to authenticate the client connection. If the authentication request has failed: - the server connection is dropped. - the watcher is called with the ZOO_AUTH_FAILED_STATE value as the state parameter.

参数

scheme

The id of authentication scheme. Natively supported: "digest" password-based authentication

cert

Application credentials. The actual value depends on the scheme.

completion_cb

The routine to invoke when the request completes. One of the following result codes may be passed into the completion callback: - ZOK operation completed successfully - ZAUTHFAILED authentication failed

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::addAuth() example

Add auth before requesting node value.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$zookeeper->set($path, $value);

$zookeeper->addAuth('digest', 'user0:passwd0');
$r = $zookeeper->get($path);
if ($r)
  echo $r;
else
  echo 'ERR';
?>

以上例程会输出：

nodevalue

参见

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::setAcl() - Sets the acl associated with a node synchronously
  • Zookeeper::getAcl() - Gets the acl associated with a node synchronously
  • ZooKeeper States
  • ZookeeperException


Close the zookeeper handle and free up any resources

  • ? Zookeeper::addAuth
  • Zookeeper::connect ?
  • PHP Manual
  • Zookeeper
  • Close the zookeeper handle and free up any resources

Zookeeper::close

(PECL zookeeper >= 0.5.0)

Zookeeper::close — Close the zookeeper handle and free up any resources

说明

public Zookeeper::close ( ) : void

错误／异常

This method emits ZookeeperException and it's derivatives when closing an uninitialized instance.

参见

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Create a handle to used communicate with zookeeper

  • ? Zookeeper::close
  • Zookeeper::__construct ?
  • PHP Manual
  • Zookeeper
  • Create a handle to used communicate with zookeeper

Zookeeper::connect

(PECL zookeeper >= 0.2.0)

Zookeeper::connect — Create a handle to used communicate with zookeeper

说明

public Zookeeper::connect ( string $host , callable $watcher_cb = null , int $recv_timeout = 10000 ) : void

This method creates a new handle and a zookeeper session that corresponds to that handle. Session establishment is asynchronous, meaning that the session should not be considered established until (and unless) an event of state ZOO_CONNECTED_STATE is received.

参数

host

Comma separated host:port pairs, each corresponding to a zk server. e.g. "127.0.0.1:3000,127.0.0.1:3001,127.0.0.1:3002"

watcher_cb

The global watcher callback function. When notifications are triggered this function will be invoked.

recv_timeout

The timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE).

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or could not init instance.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Create a handle to used communicate with zookeeper

  • ? Zookeeper::connect
  • Zookeeper::create ?
  • PHP Manual
  • Zookeeper
  • Create a handle to used communicate with zookeeper

Zookeeper::__construct

(PECL zookeeper >= 0.1.0)

Zookeeper::__construct — Create a handle to used communicate with zookeeper

说明

public Zookeeper::__construct ( string $host = '' , callable $watcher_cb = null , int $recv_timeout = 10000 )

This method creates a new handle and a zookeeper session that corresponds to that handle. Session establishment is asynchronous, meaning that the session should not be considered established until (and unless) an event of state ZOO_CONNECTED_STATE is received.

参数

host

comma separated host:port pairs, each corresponding to a zk server. e.g. "127.0.0.1:3000,127.0.0.1:3001,127.0.0.1:3002"

watcher_cb

the global watcher callback function. When notifications are triggered this function will be invoked.

recv_timeout

the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE).

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or could not init instance.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Create a node synchronously

  • ? Zookeeper::__construct
  • Zookeeper::delete ?
  • PHP Manual
  • Zookeeper
  • Create a node synchronously

Zookeeper::create

(PECL zookeeper >= 0.1.0)

Zookeeper::create — Create a node synchronously

说明

public Zookeeper::create ( string $path , string $value , array $acls , int $flags = null ) : string

This method will create a node in ZooKeeper. A node can only be created if it does not already exists. The Create Flags affect the creation of nodes. If ZOO_EPHEMERAL flag is set, the node will automatically get removed if the client session goes away. If the ZOO_SEQUENCE flag is set, a unique monotonically increasing sequence number is appended to the path name.

参数

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

value

The data to be stored in the node.

acls

The initial ACL of the node. The ACL must not be null or empty.

flags

this parameter can be set to 0 for normal create or an OR of the Create Flags

返回值

Returns the path of the new node (this might be different than the supplied path because of the ZOO_SEQUENCE flag) on success, and false on failure.

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to create node.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::create() example

Create a new node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$realPath = $zookeeper->create($path, null, $aclArray);
if ($realPath)
  echo $realPath;
else
  echo 'ERR';
?>

以上例程会输出：

/path/to/newnode

参见

  • Zookeeper::delete() - Delete a node in zookeeper synchronously
  • Zookeeper::getChildren() - Lists the children of a node synchronously
  • ZooKeeper Permissions
  • ZookeeperException


Delete a node in zookeeper synchronously

  • ? Zookeeper::create
  • Zookeeper::exists ?
  • PHP Manual
  • Zookeeper
  • Delete a node in zookeeper synchronously

Zookeeper::delete

(PECL zookeeper >= 0.2.0)

Zookeeper::delete — Delete a node in zookeeper synchronously

说明

public Zookeeper::delete ( string $path , int $version = -1 ) : bool

参数

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to delete node.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::delete() example

Delete a existing node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$r = $zookeeper->delete($path);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>

以上例程会输出：

SUCCESS

参见

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::getChildren() - Lists the children of a node synchronously
  • ZookeeperException


Checks the existence of a node in zookeeper synchronously

  • ? Zookeeper::delete
  • Zookeeper::get ?
  • PHP Manual
  • Zookeeper
  • Checks the existence of a node in zookeeper synchronously

Zookeeper::exists

(PECL zookeeper >= 0.1.0)

Zookeeper::exists — Checks the existence of a node in zookeeper synchronously

说明

public Zookeeper::exists ( string $path , callable $watcher_cb = null ) : array

参数

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

watcher_cb

if nonzero, a watch will be set at the server to notify the client if the node changes. The watch will be set even if the node does not

返回值

Returns the value of stat for the path if the given node exists, otherwise false.

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to check the existence of a node.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::exists() example

Check the existence of a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$r = $zookeeper->exists($path);
if ($r)
  echo 'EXISTS';
else
  echo 'N/A or ERR';
?>

以上例程会输出：

EXISTS

参见

  • Zookeeper::get() - Gets the data associated with a node synchronously
  • ZookeeperException


Gets the data associated with a node synchronously

  • ? Zookeeper::exists
  • Zookeeper::getAcl ?
  • PHP Manual
  • Zookeeper
  • Gets the data associated with a node synchronously

Zookeeper::get

(PECL zookeeper >= 0.1.0)

Zookeeper::get — Gets the data associated with a node synchronously

说明

public Zookeeper::get ( string $path , callable $watcher_cb = null , array &$stat = null , int $max_size = 0 ) : string

参数

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

watcher_cb

If nonzero, a watch will be set at the server to notify the client if the node changes.

stat

If not NULL, will hold the value of stat for the path on return.

max_size

Max size of the data. If 0 is used, this method will return the whole data.

返回值

Returns the data on success, and false on failure.

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to get value from node.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::get() example

Get value from node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$zookeeper->set($path, $value);

$r = $zookeeper->get($path);
if ($r)
  echo $r;
else
  echo 'ERR';
?>

以上例程会输出：

nodevalue

Example #2 Zookeeper::get() stat example

Get node stat info.

<?php
$zookeeper = new Zookeeper('localhost:2181');
$path = '/path/to/node';
$stat = [];
$zookeeper->get($path, null, $stat);
var_dump($stat);
?>

以上例程会输出：

array(11) {
  ["czxid"]=>
  float(0)
  ["mzxid"]=>
  float(0)
  ["ctime"]=>
  float(0)
  ["mtime"]=>
  float(0)
  ["version"]=>
  int(0)
  ["cversion"]=>
  int(-2)
  ["aversion"]=>
  int(0)
  ["ephemeralOwner"]=>
  float(0)
  ["dataLength"]=>
  int(0)
  ["numChildren"]=>
  int(2)
  ["pzxid"]=>
  float(0)
}

参见

  • Zookeeper::set() - Sets the data associated with a node
  • ZookeeperException


Gets the acl associated with a node synchronously

  • ? Zookeeper::get
  • Zookeeper::getChildren ?
  • PHP Manual
  • Zookeeper
  • Gets the acl associated with a node synchronously

Zookeeper::getAcl

(PECL zookeeper >= 0.1.0)

Zookeeper::getAcl — Gets the acl associated with a node synchronously

说明

public Zookeeper::getAcl ( string $path ) : array

参数

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

返回值

Return acl array on success and false on failure.

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to get ACL of a node.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::getAcl() example

Get ACL of a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$zookeeper->setAcl($path, $aclArray);

$r = $zookeeper->getAcl($path);
if ($r)
  var_dump($r);
else
  echo 'ERR';
?>

以上例程会输出：

array(1) {
  [0]=>
  array(3) {
    ["perms"]=>
    int(31)
    ["scheme"]=>
    string(5) "world"
    ["id"]=>
    string(6) "anyone"
  }
}

参见

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::setAcl() - Sets the acl associated with a node synchronously
  • ZooKeeper Permissions
  • ZookeeperException


Lists the children of a node synchronously

  • ? Zookeeper::getAcl
  • Zookeeper::getClientId ?
  • PHP Manual
  • Zookeeper
  • Lists the children of a node synchronously

Zookeeper::getChildren

(PECL zookeeper >= 0.1.0)

Zookeeper::getChildren — Lists the children of a node synchronously

说明

public Zookeeper::getChildren ( string $path , callable $watcher_cb = null ) : array

参数

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

watcher_cb

If nonzero, a watch will be set at the server to notify the client if the node changes.

返回值

Returns an array with children paths on success, and false on failure.

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to list children of a node.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::getChildren() example

Lists children of a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/zookeeper';
$r = $zookeeper->getchildren($path);
if ($r)
  var_dump($r);
else
  echo 'ERR';
?>

以上例程会输出：

array(1) {
  [0]=>
  string(6) "config"
}

参见

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::delete() - Delete a node in zookeeper synchronously
  • ZookeeperException


Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)

  • ? Zookeeper::getChildren
  • Zookeeper::getConfig ?
  • PHP Manual
  • Zookeeper
  • Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)

Zookeeper::getClientId

(PECL zookeeper >= 0.1.0)

Zookeeper::getClientId — Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)

说明

public Zookeeper::getClientId ( ) : int

返回值

Returns the client session id on success, and false on failure.

错误／异常

This method emits PHP error/warning when it could not get client session id.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • Zookeeper::getState() - Get the state of the zookeeper connection
  • ZooKeeper States
  • ZookeeperException


Get instance of ZookeeperConfig

  • ? Zookeeper::getClientId
  • Zookeeper::getRecvTimeout ?
  • PHP Manual
  • Zookeeper
  • Get instance of ZookeeperConfig

Zookeeper::getConfig

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

Zookeeper::getConfig — Get instance of ZookeeperConfig

说明

public Zookeeper::getConfig ( ) : ZookeeperConfig

返回值

Returns instance of ZookeeperConfig.

参见

  • ZookeeperConfig


Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect

  • ? Zookeeper::getConfig
  • Zookeeper::getState ?
  • PHP Manual
  • Zookeeper
  • Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect

Zookeeper::getRecvTimeout

(PECL zookeeper >= 0.1.0)

Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect

说明

public Zookeeper::getRecvTimeout ( ) : int

返回值

Returns the timeout for this session on success, and false on failure.

错误／异常

This method emits PHP error/warning when operation fails.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Get the state of the zookeeper connection

  • ? Zookeeper::getRecvTimeout
  • Zookeeper::isRecoverable ?
  • PHP Manual
  • Zookeeper
  • Get the state of the zookeeper connection

Zookeeper::getState

(PECL zookeeper >= 0.1.0)

Zookeeper::getState — Get the state of the zookeeper connection

说明

public Zookeeper::getState ( ) : int

返回值

Returns the state of zookeeper connection on success, and false on failure.

错误／异常

This method emits PHP error/warning when it fails to get state of zookeeper connection.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • Zookeeper::getClientId() - Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • ZooKeeper States
  • ZookeeperException


Checks if the current zookeeper connection state can be recovered

  • ? Zookeeper::getState
  • Zookeeper::set ?
  • PHP Manual
  • Zookeeper
  • Checks if the current zookeeper connection state can be recovered

Zookeeper::isRecoverable

(PECL zookeeper >= 0.1.0)

Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered

说明

public Zookeeper::isRecoverable ( ) : bool

The application must close the handle and try to reconnect.

返回值

Returns true/false on success, and false on failure.

错误／异常

This method emits PHP error/warning when operation fails.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • Zookeeper::getClientId() - Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • ZooKeeper States
  • ZookeeperException


Sets the data associated with a node

  • ? Zookeeper::isRecoverable
  • Zookeeper::setAcl ?
  • PHP Manual
  • Zookeeper
  • Sets the data associated with a node

Zookeeper::set

(PECL zookeeper >= 0.1.0)

Zookeeper::set — Sets the data associated with a node

说明

public Zookeeper::set ( string $path , string $value , int $version = -1 , array &$stat = null ) : bool

参数

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

value

The data to be stored in the node.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to save value to node.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::set() example

Save value to node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$r = $zookeeper->set($path, $value);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>

以上例程会输出：

SUCCESS

参见

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::get() - Gets the data associated with a node synchronously
  • ZookeeperException


Sets the acl associated with a node synchronously

  • ? Zookeeper::set
  • Zookeeper::setDebugLevel ?
  • PHP Manual
  • Zookeeper
  • Sets the acl associated with a node synchronously

Zookeeper::setAcl

(PECL zookeeper >= 0.1.0)

Zookeeper::setAcl — Sets the acl associated with a node synchronously

说明

public Zookeeper::setAcl ( string $path , int $version , array $acl ) : bool

参数

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

version

The expected version of the path.

acl

The acl to be set on the path.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to set ACL for a node.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::setAcl() example

Set ACL for a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$zookeeper->setAcl($path, $aclArray);

$r = $zookeeper->getAcl($path);
if ($r)
  var_dump($r);
else
  echo 'ERR';
?>

以上例程会输出：

array(1) {
  [0]=>
  array(3) {
    ["perms"]=>
    int(31)
    ["scheme"]=>
    string(5) "world"
    ["id"]=>
    string(6) "anyone"
  }
}

参见

  • Zookeeper::create() - Create a node synchronously
  • Zookeeper::getAcl() - Gets the acl associated with a node synchronously
  • ZooKeeper Permissions
  • ZookeeperException


Sets the debugging level for the library

  • ? Zookeeper::setAcl
  • Zookeeper::setDeterministicConnOrder ?
  • PHP Manual
  • Zookeeper
  • Sets the debugging level for the library

Zookeeper::setDebugLevel

(PECL zookeeper >= 0.1.0)

Zookeeper::setDebugLevel — Sets the debugging level for the library

说明

public static Zookeeper::setDebugLevel ( int $logLevel ) : bool

参数

logLevel

ZooKeeper log level constants.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to set debug level.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

范例

Example #1 Zookeeper::setDebugLevel() example

Set debugl level.

<?php
$r = Zookeeper::setDebugLevel(Zookeeper::LOG_LEVEL_WARN);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>
?>

以上例程会输出：

SUCCESS

参见

  • ZooKeeper Log Levels
  • ZookeeperException


Enable/disable quorum endpoint order randomization

  • ? Zookeeper::setDebugLevel
  • Zookeeper::setLogStream ?
  • PHP Manual
  • Zookeeper
  • Enable/disable quorum endpoint order randomization

Zookeeper::setDeterministicConnOrder

(PECL zookeeper >= 0.1.0)

Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization

说明

public static Zookeeper::setDeterministicConnOrder ( bool $yesOrNo ) : bool

If passed a true value, will make the client connect to quorum peers in the order as specified in the zookeeper_init() call. A false value causes zookeeper_init() to permute the peer endpoints which is good for more even client connection distribution among the quorum peers. ZooKeeper C Client uses false by default.

参数

yesOrNo

Disable/enable quorum endpoint order randomization.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper
  • ZookeeperException


Sets the stream to be used by the library for logging

  • ? Zookeeper::setDeterministicConnOrder
  • Zookeeper::setWatcher ?
  • PHP Manual
  • Zookeeper
  • Sets the stream to be used by the library for logging

Zookeeper::setLogStream

(PECL zookeeper >= 0.1.0)

Zookeeper::setLogStream — Sets the stream to be used by the library for logging

说明

public Zookeeper::setLogStream ( resource $stream ) : bool

The zookeeper library uses stderr as its default log stream. Application must make sure the stream is writable. Passing in NULL resets the stream to its default value (stderr).

参数

stream

The stream to be used by the library for logging.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::setDebugLevel() - Sets the debugging level for the library
  • ZookeeperException


Set a watcher function

  • ? Zookeeper::setLogStream
  • ZookeeperConfig ?
  • PHP Manual
  • Zookeeper
  • Set a watcher function

Zookeeper::setWatcher

(PECL zookeeper >= 0.1.0)

Zookeeper::setWatcher — Set a watcher function

说明

public Zookeeper::setWatcher ( callable $watcher_cb ) : bool

参数

watcher_cb

A watch will be set at the server to notify the client if the node changes.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

This method emits PHP error/warning when parameters count or types are wrong or fail to set watcher.

Caution

Since version 0.3.0, this method emits ZookeeperException and it's derivatives.

参见

  • Zookeeper::exists() - Checks the existence of a node in zookeeper synchronously
  • Zookeeper::get() - Gets the data associated with a node synchronously
  • ZookeeperException


The ZookeeperConfig class

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

简介

The ZooKeeper Config handling class.

类摘要

ZookeeperConfig {
/* 方法 */
public add ( string $members , int $version = -1 , array &$stat = null ) : void
public get ( callable $watcher_cb = null , array &$stat = null ) : string
public remove ( string $id_list , int $version = -1 , array &$stat = null ) : void
public set ( string $members , int $version = -1 , array &$stat = null ) : void
}

Table of Contents

  • ZookeeperConfig::add — Add servers to the ensemble
  • ZookeeperConfig::get — Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
  • ZookeeperConfig::remove — Remove servers from the ensemble
  • ZookeeperConfig::set — Change ZK cluster ensemble membership and roles of ensemble peers


Add servers to the ensemble

  • ? ZookeeperConfig
  • ZookeeperConfig::get ?
  • PHP Manual
  • ZookeeperConfig
  • Add servers to the ensemble

ZookeeperConfig::add

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

ZookeeperConfig::add — Add servers to the ensemble

说明

public ZookeeperConfig::add ( string $members , int $version = -1 , array &$stat = null ) : void

参数

members

Comma separated list of servers to be added to the ensemble. Each has a configuration line for a server to be added (as would appear in a configuration file), only for maj. quorums.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

错误／异常

This method emits ZookeeperException and it's derivatives when parameters count or types are wrong or fail to save value to node.

范例

Example #1 ZookeeperConfig::add() example

Add members.

<?php
$client = new Zookeeper();
$client->connect('localhost:2181');
$client->addAuth('digest', 'timandes:timandes');
$zkConfig = $client->getConfig();
$zkConfig->set("server.1=localhost:2888:3888:participant;0.0.0.0:2181");
$zkConfig->add("server.2=localhost:2889:3889:participant;0.0.0.0:2182");
$r = $zkConfig->get();
if ($r)
  echo $r;
else
  echo 'ERR';
?>

以上例程会输出：

server.1=localhost:2888:3888:participant;0.0.0.0:2181
server.2=localhost:2889:3889:participant;0.0.0.0:2182
version=0xca01e881a2

参见

  • ZookeeperConfig::get() - Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
  • ZookeeperConfig::set() - Change ZK cluster ensemble membership and roles of ensemble peers
  • ZookeeperConfig::remove() - Remove servers from the ensemble
  • ZookeeperException


Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously

  • ? ZookeeperConfig::add
  • ZookeeperConfig::remove ?
  • PHP Manual
  • ZookeeperConfig
  • Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously

ZookeeperConfig::get

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

ZookeeperConfig::get — Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously

说明

public ZookeeperConfig::get ( callable $watcher_cb = null , array &$stat = null ) : string

参数

watcher_cb

If nonzero, a watch will be set at the server to notify the client if the node changes.

stat

If not NULL, will hold the value of stat for the path on return.

返回值

Returns the configuration string on success, and false on failure.

错误／异常

This method emits ZookeeperException and it's derivatives when parameters count or types are wrong or fail to get configuration.

范例

Example #1 ZookeeperConfig::get() example

Get configuration.

<?php
$zk = new Zookeeper();
$zk->connect('localhost:2181');
$zk->addAuth('digest', 'timandes:timandes');
$zkConfig = $zk->getConfig();
$r = $zkConfig->get();
if ($r)
  echo $r;
else
  echo 'ERR';
?>

以上例程会输出：

server.1=localhost:2888:3888:participant;0.0.0.0:2181
version=0xca01e881a2

参见

  • ZookeeperConfig::set() - Change ZK cluster ensemble membership and roles of ensemble peers
  • ZookeeperConfig::add() - Add servers to the ensemble
  • ZookeeperConfig::remove() - Remove servers from the ensemble
  • ZookeeperException


Remove servers from the ensemble

  • ? ZookeeperConfig::get
  • ZookeeperConfig::set ?
  • PHP Manual
  • ZookeeperConfig
  • Remove servers from the ensemble

ZookeeperConfig::remove

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

ZookeeperConfig::remove — Remove servers from the ensemble

说明

public ZookeeperConfig::remove ( string $id_list , int $version = -1 , array &$stat = null ) : void

参数

id_list

Comma separated list of server IDs to be removed from the ensemble. Each has an id of a server to be removed, only for maj. quorums.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

错误／异常

This method emits ZookeeperException and it's derivatives when parameters count or types are wrong or fail to save value to node.

范例

Example #1 ZookeeperConfig::remove() example

Remove members.

<?php
$client = new Zookeeper();
$client->connect('localhost:2181');
$client->addAuth('digest', 'timandes:timandes');
$zkConfig = $client->getConfig();
$zkConfig->set("server.1=localhost:2888:3888:participant;0.0.0.0:2181,server.2=localhost:2889:3889:participant;0.0.0.0:2182");
$zkConfig->remove("2");
echo $zkConfig->get();
if ($r)
  echo $r;
else
  echo 'ERR';
?>

以上例程会输出：

server.1=localhost:2888:3888:participant;0.0.0.0:2181
version=0xca01e881a2

参见

  • ZookeeperConfig::get() - Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
  • ZookeeperConfig::add() - Add servers to the ensemble
  • ZookeeperConfig::set() - Change ZK cluster ensemble membership and roles of ensemble peers
  • ZookeeperException


Change ZK cluster ensemble membership and roles of ensemble peers

  • ? ZookeeperConfig::remove
  • ZookeeperException ?
  • PHP Manual
  • ZookeeperConfig
  • Change ZK cluster ensemble membership and roles of ensemble peers

ZookeeperConfig::set

(PECL zookeeper >= 0.6.0, ZooKeeper >= 3.5.0)

ZookeeperConfig::set — Change ZK cluster ensemble membership and roles of ensemble peers

说明

public ZookeeperConfig::set ( string $members , int $version = -1 , array &$stat = null ) : void

参数

members

Comma separated list of new membership (e.g., contents of a membership configuration file) - for use only with a non-incremental reconfiguration.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

错误／异常

This method emits ZookeeperException and it's derivatives when parameters count or types are wrong or fail to save value to node.

范例

Example #1 ZookeeperConfig::set() example

Reconfig.

<?php
$client = new Zookeeper();
$client->connect('localhost:2181');
$client->addAuth('digest', 'timandes:timandes');
$zkConfig = $client->getConfig();
$zkConfig->set("server.1=localhost:2888:3888:participant;0.0.0.0:2181");
?>

参见

  • ZookeeperConfig::get() - Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
  • ZookeeperConfig::add() - Add servers to the ensemble
  • ZookeeperConfig::remove() - Remove servers from the ensemble
  • ZookeeperException


The ZookeeperException class

(PECL zookeeper >= 0.3.0)

简介

The ZooKeeper exception handling class.

类摘要

ZookeeperException extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The ZookeeperAuthenticationException class

(PECL zookeeper >= 0.3.0)

简介

The ZooKeeper authentication exception handling class.

类摘要

ZookeeperAuthenticationException extends ZookeeperException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The ZookeeperConnectionException class

(PECL zookeeper >= 0.3.0)

简介

The ZooKeeper connection exception handling class.

类摘要

ZookeeperConnectionException extends ZookeeperException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The ZookeeperMarshallingException class

(PECL zookeeper >= 0.3.0)

简介

The ZooKeeper exception (while marshalling or unmarshalling data) handling class.

类摘要

ZookeeperMarshallingException extends ZookeeperException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The ZookeeperNoNodeException class

(PECL zookeeper >= 0.3.0)

简介

The ZooKeeper exception (when node does not exist) handling class.

类摘要

ZookeeperNoNodeException extends ZookeeperException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The ZookeeperOperationTimeoutException class

(PECL zookeeper >= 0.3.0)

简介

The ZooKeeper operation timeout exception handling class.

类摘要

ZookeeperOperationTimeoutException extends ZookeeperException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The ZookeeperSessionException class

(PECL zookeeper >= 0.3.0)

简介

The ZooKeeper session exception handling class.

类摘要

ZookeeperSessionException extends ZookeeperException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


搜索引擎扩展

  • Solr — Apache Solr
    • 简介
    • 安装／配置
    • 预定义常量
    • Solr 函数
    • 范例
    • SolrUtils — The SolrUtils class
    • SolrInputDocument — The SolrInputDocument class
    • SolrDocument — The SolrDocument class
    • SolrDocumentField — The SolrDocumentField class
    • SolrObject — The SolrObject class
    • SolrClient — The SolrClient class
    • SolrResponse — The SolrResponse class
    • SolrQueryResponse — The SolrQueryResponse class
    • SolrUpdateResponse — The SolrUpdateResponse class
    • SolrPingResponse — The SolrPingResponse class
    • SolrGenericResponse — The SolrGenericResponse class
    • SolrParams — The SolrParams class
    • SolrModifiableParams — The SolrModifiableParams class
    • SolrQuery — The SolrQuery class
    • SolrDisMaxQuery — The SolrDisMaxQuery class
    • SolrCollapseFunction — The SolrCollapseFunction class
    • SolrException — The SolrException class
    • SolrClientException — The SolrClientException class
    • SolrServerException — The SolrServerException class
    • SolrIllegalArgumentException — The SolrIllegalArgumentException class
    • SolrIllegalOperationException — The SolrIllegalOperationException class
    • SolrMissingMandatoryParameterException — The SolrMissingMandatoryParameterException class
  • Sphinx — Sphinx 客户端
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • SphinxClient — SphinxClient 类


Apache Solr

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Solr 函数
    • solr_get_version — 返回当前Solr扩展的版本
  • 范例
  • SolrUtils — The SolrUtils class
    • SolrUtils::digestXmlResponse — Parses an response XML string into a SolrObject
    • SolrUtils::escapeQueryChars — Escapes a lucene query string
    • SolrUtils::getSolrVersion — Returns the current version of the Solr extension
    • SolrUtils::queryPhrase — Prepares a phrase from an unescaped lucene string
  • SolrInputDocument — The SolrInputDocument class
    • SolrInputDocument::addChildDocument — Adds a child document for block indexing
    • SolrInputDocument::addChildDocuments — Adds an array of child documents
    • SolrInputDocument::addField — Adds a field to the document
    • SolrInputDocument::clear — Resets the input document
    • SolrInputDocument::__clone — Creates a copy of a SolrDocument
    • SolrInputDocument::__construct — Constructor
    • SolrInputDocument::deleteField — Removes a field from the document
    • SolrInputDocument::__destruct — Destructor
    • SolrInputDocument::fieldExists — Checks if a field exists
    • SolrInputDocument::getBoost — Retrieves the current boost value for the document
    • SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)
    • SolrInputDocument::getChildDocumentsCount — Returns the number of child documents
    • SolrInputDocument::getField — Retrieves a field by name
    • SolrInputDocument::getFieldBoost — Retrieves the boost value for a particular field
    • SolrInputDocument::getFieldCount — Returns the number of fields in the document
    • SolrInputDocument::getFieldNames — Returns an array containing all the fields in the document
    • SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents
    • SolrInputDocument::merge — Merges one input document into another
    • SolrInputDocument::reset — This is an alias of SolrInputDocument::clear
    • SolrInputDocument::setBoost — Sets the boost value for this document
    • SolrInputDocument::setFieldBoost — Sets the index-time boost value for a field
    • SolrInputDocument::sort — Sorts the fields within the document
    • SolrInputDocument::toArray — Returns an array representation of the input document
  • SolrDocument — The SolrDocument class
    • SolrDocument::addField — Adds a field to the document
    • SolrDocument::clear — Drops all the fields in the document
    • SolrDocument::__clone — Creates a copy of a SolrDocument object
    • SolrDocument::__construct — Constructor
    • SolrDocument::current — Retrieves the current field
    • SolrDocument::deleteField — Removes a field from the document
    • SolrDocument::__destruct — Destructor
    • SolrDocument::fieldExists — Checks if a field exists in the document
    • SolrDocument::__get — Access the field as a property
    • SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)
    • SolrDocument::getChildDocumentsCount — Returns the number of child documents
    • SolrDocument::getField — Retrieves a field by name
    • SolrDocument::getFieldCount — Returns the number of fields in this document
    • SolrDocument::getFieldNames — Returns an array of fields names in the document
    • SolrDocument::getInputDocument — Returns a SolrInputDocument equivalent of the object
    • SolrDocument::hasChildDocuments — Checks whether the document has any child documents
    • SolrDocument::__isset — Checks if a field exists
    • SolrDocument::key — Retrieves the current key
    • SolrDocument::merge — Merges source to the current SolrDocument
    • SolrDocument::next — Moves the internal pointer to the next field
    • SolrDocument::offsetExists — Checks if a particular field exists
    • SolrDocument::offsetGet — Retrieves a field
    • SolrDocument::offsetSet — Adds a field to the document
    • SolrDocument::offsetUnset — Removes a field
    • SolrDocument::reset — This is an alias to SolrDocument::clear()
    • SolrDocument::rewind — Resets the internal pointer to the beginning
    • SolrDocument::serialize — Used for custom serialization
    • SolrDocument::__set — Adds another field to the document
    • SolrDocument::sort — Sorts the fields in the document
    • SolrDocument::toArray — Returns an array representation of the document
    • SolrDocument::unserialize — Custom serialization of SolrDocument objects
    • SolrDocument::__unset — Removes a field from the document
    • SolrDocument::valid — Checks if the current position internally is still valid
  • SolrDocumentField — The SolrDocumentField class
    • SolrDocumentField::__construct — Constructor
    • SolrDocumentField::__destruct — Destructor
  • SolrObject — The SolrObject class
    • SolrObject::__construct — Creates Solr object
    • SolrObject::__destruct — Destructor
    • SolrObject::getPropertyNames — Returns an array of all the names of the properties
    • SolrObject::offsetExists — Checks if the property exists
    • SolrObject::offsetGet — Used to retrieve a property
    • SolrObject::offsetSet — Sets the value for a property
    • SolrObject::offsetUnset — Unsets the value for the property
  • SolrClient — The SolrClient class
    • SolrClient::addDocument — Adds a document to the index
    • SolrClient::addDocuments — Adds a collection of SolrInputDocument instances to the index
    • SolrClient::commit — Finalizes all add/deletes made to the index
    • SolrClient::__construct — Constructor for the SolrClient object
    • SolrClient::deleteById — Delete by Id
    • SolrClient::deleteByIds — Deletes by Ids
    • SolrClient::deleteByQueries — Removes all documents matching any of the queries
    • SolrClient::deleteByQuery — Deletes all documents matching the given query
    • SolrClient::__destruct — Destructor for SolrClient
    • SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG)
    • SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)
    • SolrClient::getDebug — Returns the debug data for the last connection attempt
    • SolrClient::getOptions — Returns the client options set internally
    • SolrClient::optimize — Defragments the index
    • SolrClient::ping — Checks if Solr server is still up
    • SolrClient::query — Sends a query to the server
    • SolrClient::request — Sends a raw update request
    • SolrClient::rollback — Rollbacks all add/deletes made to the index since the last commit
    • SolrClient::setResponseWriter — Sets the response writer used to prepare the response from Solr
    • SolrClient::setServlet — Changes the specified servlet type to a new value
    • SolrClient::system — Retrieve Solr Server information
    • SolrClient::threads — Checks the threads status
  • SolrResponse — The SolrResponse class
    • SolrResponse::getDigestedResponse — Returns the XML response as serialized PHP data
    • SolrResponse::getHttpStatus — Returns the HTTP status of the response
    • SolrResponse::getHttpStatusMessage — Returns more details on the HTTP status
    • SolrResponse::getRawRequest — Returns the raw request sent to the Solr server
    • SolrResponse::getRawRequestHeaders — Returns the raw request headers sent to the Solr server
    • SolrResponse::getRawResponse — Returns the raw response from the server
    • SolrResponse::getRawResponseHeaders — Returns the raw response headers from the server
    • SolrResponse::getRequestUrl — Returns the full URL the request was sent to
    • SolrResponse::getResponse — Returns a SolrObject representing the XML response from the server
    • SolrResponse::setParseMode — Sets the parse mode
    • SolrResponse::success — Was the request a success
  • SolrQueryResponse — The SolrQueryResponse class
    • SolrQueryResponse::__construct — Constructor
    • SolrQueryResponse::__destruct — Destructor
  • SolrUpdateResponse — The SolrUpdateResponse class
    • SolrUpdateResponse::__construct — Constructor
    • SolrUpdateResponse::__destruct — Destructor
  • SolrPingResponse — The SolrPingResponse class
    • SolrPingResponse::__construct — Constructor
    • SolrPingResponse::__destruct — Destructor
    • SolrPingResponse::getResponse — Returns the response from the server
  • SolrGenericResponse — The SolrGenericResponse class
    • SolrGenericResponse::__construct — Constructor
    • SolrGenericResponse::__destruct — Destructor
  • SolrParams — The SolrParams class
    • SolrParams::add — This is an alias for SolrParams::addParam
    • SolrParams::addParam — Adds a parameter to the object
    • SolrParams::get — This is an alias for SolrParams::getParam
    • SolrParams::getParam — Returns a parameter value
    • SolrParams::getParams — Returns an array of non URL-encoded parameters
    • SolrParams::getPreparedParams — Returns an array of URL-encoded parameters
    • SolrParams::serialize — Used for custom serialization
    • SolrParams::set — An alias of SolrParams::setParam
    • SolrParams::setParam — Sets the parameter to the specified value
    • SolrParams::toString — Returns all the name-value pair parameters in the object
    • SolrParams::unserialize — Used for custom serialization
  • SolrModifiableParams — The SolrModifiableParams class
    • SolrModifiableParams::__construct — Constructor
    • SolrModifiableParams::__destruct — Destructor
  • SolrQuery — The SolrQuery class
    • SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group
    • SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter)
    • SolrQuery::addFacetDateField — Maps to facet.date
    • SolrQuery::addFacetDateOther — Adds another facet.date.other parameter
    • SolrQuery::addFacetField — Adds another field to the facet
    • SolrQuery::addFacetQuery — Adds a facet query
    • SolrQuery::addField — Specifies which fields to return in the result
    • SolrQuery::addFilterQuery — Specifies a filter query
    • SolrQuery::addGroupField — Add a field to be used to group results
    • SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter)
    • SolrQuery::addGroupQuery — Allows grouping of documents that match the given query
    • SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter)
    • SolrQuery::addHighlightField — Maps to hl.fl
    • SolrQuery::addMltField — Sets a field to use for similarity
    • SolrQuery::addMltQueryField — Maps to mlt.qf
    • SolrQuery::addSortField — Used to control how the results should be sorted
    • SolrQuery::addStatsFacet — Requests a return of sub results for values within the given facet
    • SolrQuery::addStatsField — Maps to stats.field parameter
    • SolrQuery::collapse — Collapses the result set to a single document per group
    • SolrQuery::__construct — Constructor
    • SolrQuery::__destruct — Destructor
    • SolrQuery::getExpand — Returns true if group expanding is enabled
    • SolrQuery::getExpandFilterQueries — Returns the expand filter queries
    • SolrQuery::getExpandQuery — Returns the expand query expand.q parameter
    • SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)
    • SolrQuery::getExpandSortFields — Returns an array of fields
    • SolrQuery::getFacet — Returns the value of the facet parameter
    • SolrQuery::getFacetDateEnd — Returns the value for the facet.date.end parameter
    • SolrQuery::getFacetDateFields — Returns all the facet.date fields
    • SolrQuery::getFacetDateGap — Returns the value of the facet.date.gap parameter
    • SolrQuery::getFacetDateHardEnd — Returns the value of the facet.date.hardend parameter
    • SolrQuery::getFacetDateOther — Returns the value for the facet.date.other parameter
    • SolrQuery::getFacetDateStart — Returns the lower bound for the first date range for all date faceting on this field
    • SolrQuery::getFacetFields — Returns all the facet fields
    • SolrQuery::getFacetLimit — Returns the maximum number of constraint counts that should be returned for the facet fields
    • SolrQuery::getFacetMethod — Returns the value of the facet.method parameter
    • SolrQuery::getFacetMinCount — Returns the minimum counts for facet fields should be included in the response
    • SolrQuery::getFacetMissing — Returns the current state of the facet.missing parameter
    • SolrQuery::getFacetOffset — Returns an offset into the list of constraints to be used for pagination
    • SolrQuery::getFacetPrefix — Returns the facet prefix
    • SolrQuery::getFacetQueries — Returns all the facet queries
    • SolrQuery::getFacetSort — Returns the facet sort type
    • SolrQuery::getFields — Returns the list of fields that will be returned in the response
    • SolrQuery::getFilterQueries — Returns an array of filter queries
    • SolrQuery::getGroup — Returns true if grouping is enabled
    • SolrQuery::getGroupCachePercent — Returns group cache percent value
    • SolrQuery::getGroupFacet — Returns the group.facet parameter value
    • SolrQuery::getGroupFields — Returns group fields (group.field parameter values)
    • SolrQuery::getGroupFormat — Returns the group.format value
    • SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)
    • SolrQuery::getGroupLimit — Returns the group.limit value
    • SolrQuery::getGroupMain — Returns the group.main value
    • SolrQuery::getGroupNGroups — Returns the group.ngroups value
    • SolrQuery::getGroupOffset — Returns the group.offset value
    • SolrQuery::getGroupQueries — Returns all the group.query parameter values
    • SolrQuery::getGroupSortFields — Returns the group.sort value
    • SolrQuery::getGroupTruncate — Returns the group.truncate value
    • SolrQuery::getHighlight — Returns the state of the hl parameter
    • SolrQuery::getHighlightAlternateField — Returns the highlight field to use as backup or default
    • SolrQuery::getHighlightFields — Returns all the fields that Solr should generate highlighted snippets for
    • SolrQuery::getHighlightFormatter — Returns the formatter for the highlighted output
    • SolrQuery::getHighlightFragmenter — Returns the text snippet generator for highlighted text
    • SolrQuery::getHighlightFragsize — Returns the number of characters of fragments to consider for highlighting
    • SolrQuery::getHighlightHighlightMultiTerm — Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries
    • SolrQuery::getHighlightMaxAlternateFieldLength — Returns the maximum number of characters of the field to return
    • SolrQuery::getHighlightMaxAnalyzedChars — Returns the maximum number of characters into a document to look for suitable snippets
    • SolrQuery::getHighlightMergeContiguous — Returns whether or not the collapse contiguous fragments into a single fragment
    • SolrQuery::getHighlightRegexMaxAnalyzedChars — Returns the maximum number of characters from a field when using the regex fragmenter
    • SolrQuery::getHighlightRegexPattern — Returns the regular expression for fragmenting
    • SolrQuery::getHighlightRegexSlop — Returns the deviation factor from the ideal fragment size
    • SolrQuery::getHighlightRequireFieldMatch — Returns if a field will only be highlighted if the query matched in this particular field
    • SolrQuery::getHighlightSimplePost — Returns the text which appears after a highlighted term
    • SolrQuery::getHighlightSimplePre — Returns the text which appears before a highlighted term
    • SolrQuery::getHighlightSnippets — Returns the maximum number of highlighted snippets to generate per field
    • SolrQuery::getHighlightUsePhraseHighlighter — Returns the state of the hl.usePhraseHighlighter parameter
    • SolrQuery::getMlt — Returns whether or not MoreLikeThis results should be enabled
    • SolrQuery::getMltBoost — Returns whether or not the query will be boosted by the interesting term relevance
    • SolrQuery::getMltCount — Returns the number of similar documents to return for each result
    • SolrQuery::getMltFields — Returns all the fields to use for similarity
    • SolrQuery::getMltMaxNumQueryTerms — Returns the maximum number of query terms that will be included in any generated query
    • SolrQuery::getMltMaxNumTokens — Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support
    • SolrQuery::getMltMaxWordLength — Returns the maximum word length above which words will be ignored
    • SolrQuery::getMltMinDocFrequency — Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs
    • SolrQuery::getMltMinTermFrequency — Returns the frequency below which terms will be ignored in the source document
    • SolrQuery::getMltMinWordLength — Returns the minimum word length below which words will be ignored
    • SolrQuery::getMltQueryFields — Returns the query fields and their boosts
    • SolrQuery::getQuery — Returns the main query
    • SolrQuery::getRows — Returns the maximum number of documents
    • SolrQuery::getSortFields — Returns all the sort fields
    • SolrQuery::getStart — Returns the offset in the complete result set
    • SolrQuery::getStats — Returns whether or not stats is enabled
    • SolrQuery::getStatsFacets — Returns all the stats facets that were set
    • SolrQuery::getStatsFields — Returns all the statistics fields
    • SolrQuery::getTerms — Returns whether or not the TermsComponent is enabled
    • SolrQuery::getTermsField — Returns the field from which the terms are retrieved
    • SolrQuery::getTermsIncludeLowerBound — Returns whether or not to include the lower bound in the result set
    • SolrQuery::getTermsIncludeUpperBound — Returns whether or not to include the upper bound term in the result set
    • SolrQuery::getTermsLimit — Returns the maximum number of terms Solr should return
    • SolrQuery::getTermsLowerBound — Returns the term to start at
    • SolrQuery::getTermsMaxCount — Returns the maximum document frequency
    • SolrQuery::getTermsMinCount — Returns the minimum document frequency to return in order to be included
    • SolrQuery::getTermsPrefix — Returns the term prefix
    • SolrQuery::getTermsReturnRaw — Whether or not to return raw characters
    • SolrQuery::getTermsSort — Returns an integer indicating how terms are sorted
    • SolrQuery::getTermsUpperBound — Returns the term to stop at
    • SolrQuery::getTimeAllowed — Returns the time in milliseconds allowed for the query to finish
    • SolrQuery::removeExpandFilterQuery — Removes an expand filter query
    • SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter
    • SolrQuery::removeFacetDateField — Removes one of the facet date fields
    • SolrQuery::removeFacetDateOther — Removes one of the facet.date.other parameters
    • SolrQuery::removeFacetField — Removes one of the facet.date parameters
    • SolrQuery::removeFacetQuery — Removes one of the facet.query parameters
    • SolrQuery::removeField — Removes a field from the list of fields
    • SolrQuery::removeFilterQuery — Removes a filter query
    • SolrQuery::removeHighlightField — Removes one of the fields used for highlighting
    • SolrQuery::removeMltField — Removes one of the moreLikeThis fields
    • SolrQuery::removeMltQueryField — Removes one of the moreLikeThis query fields
    • SolrQuery::removeSortField — Removes one of the sort fields
    • SolrQuery::removeStatsFacet — Removes one of the stats.facet parameters
    • SolrQuery::removeStatsField — Removes one of the stats.field parameters
    • SolrQuery::setEchoHandler — Toggles the echoHandler parameter
    • SolrQuery::setEchoParams — Determines what kind of parameters to include in the response
    • SolrQuery::setExpand — Enables/Disables the Expand Component
    • SolrQuery::setExpandQuery — Sets the expand.q parameter
    • SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5
    • SolrQuery::setExplainOther — Sets the explainOther common query parameter
    • SolrQuery::setFacet — Maps to the facet parameter. Enables or disables facetting
    • SolrQuery::setFacetDateEnd — Maps to facet.date.end
    • SolrQuery::setFacetDateGap — Maps to facet.date.gap
    • SolrQuery::setFacetDateHardEnd — Maps to facet.date.hardend
    • SolrQuery::setFacetDateStart — Maps to facet.date.start
    • SolrQuery::setFacetEnumCacheMinDefaultFrequency — Sets the minimum document frequency used for determining term count
    • SolrQuery::setFacetLimit — Maps to facet.limit
    • SolrQuery::setFacetMethod — Specifies the type of algorithm to use when faceting a field
    • SolrQuery::setFacetMinCount — Maps to facet.mincount
    • SolrQuery::setFacetMissing — Maps to facet.missing
    • SolrQuery::setFacetOffset — Sets the offset into the list of constraints to allow for pagination
    • SolrQuery::setFacetPrefix — Specifies a string prefix with which to limits the terms on which to facet
    • SolrQuery::setFacetSort — Determines the ordering of the facet field constraints
    • SolrQuery::setGroup — Enable/Disable result grouping (group parameter)
    • SolrQuery::setGroupCachePercent — Enables caching for result grouping
    • SolrQuery::setGroupFacet — Sets group.facet parameter
    • SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter)
    • SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1
    • SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
    • SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results
    • SolrQuery::setGroupOffset — Sets the group.offset parameter
    • SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query
    • SolrQuery::setHighlight — Enables or disables highlighting
    • SolrQuery::setHighlightAlternateField — Specifies the backup field to use
    • SolrQuery::setHighlightFormatter — Specify a formatter for the highlight output
    • SolrQuery::setHighlightFragmenter — Sets a text snippet generator for highlighted text
    • SolrQuery::setHighlightFragsize — The size of fragments to consider for highlighting
    • SolrQuery::setHighlightHighlightMultiTerm — Use SpanScorer to highlight phrase terms
    • SolrQuery::setHighlightMaxAlternateFieldLength — Sets the maximum number of characters of the field to return
    • SolrQuery::setHighlightMaxAnalyzedChars — Specifies the number of characters into a document to look for suitable snippets
    • SolrQuery::setHighlightMergeContiguous — Whether or not to collapse contiguous fragments into a single fragment
    • SolrQuery::setHighlightRegexMaxAnalyzedChars — Specify the maximum number of characters to analyze
    • SolrQuery::setHighlightRegexPattern — Specify the regular expression for fragmenting
    • SolrQuery::setHighlightRegexSlop — Sets the factor by which the regex fragmenter can stray from the ideal fragment size
    • SolrQuery::setHighlightRequireFieldMatch — Require field matching during highlighting
    • SolrQuery::setHighlightSimplePost — Sets the text which appears after a highlighted term
    • SolrQuery::setHighlightSimplePre — Sets the text which appears before a highlighted term
    • SolrQuery::setHighlightSnippets — Sets the maximum number of highlighted snippets to generate per field
    • SolrQuery::setHighlightUsePhraseHighlighter — Whether to highlight phrase terms only when they appear within the query phrase
    • SolrQuery::setMlt — Enables or disables moreLikeThis
    • SolrQuery::setMltBoost — Set if the query will be boosted by the interesting term relevance
    • SolrQuery::setMltCount — Set the number of similar documents to return for each result
    • SolrQuery::setMltMaxNumQueryTerms — Sets the maximum number of query terms included
    • SolrQuery::setMltMaxNumTokens — Specifies the maximum number of tokens to parse
    • SolrQuery::setMltMaxWordLength — Sets the maximum word length
    • SolrQuery::setMltMinDocFrequency — Sets the mltMinDoc frequency
    • SolrQuery::setMltMinTermFrequency — Sets the frequency below which terms will be ignored in the source docs
    • SolrQuery::setMltMinWordLength — Sets the minimum word length
    • SolrQuery::setOmitHeader — Exclude the header from the returned results
    • SolrQuery::setQuery — Sets the search query
    • SolrQuery::setRows — Specifies the maximum number of rows to return in the result
    • SolrQuery::setShowDebugInfo — Flag to show debug information
    • SolrQuery::setStart — Specifies the number of rows to skip
    • SolrQuery::setStats — Enables or disables the Stats component
    • SolrQuery::setTerms — Enables or disables the TermsComponent
    • SolrQuery::setTermsField — Sets the name of the field to get the Terms from
    • SolrQuery::setTermsIncludeLowerBound — Include the lower bound term in the result set
    • SolrQuery::setTermsIncludeUpperBound — Include the upper bound term in the result set
    • SolrQuery::setTermsLimit — Sets the maximum number of terms to return
    • SolrQuery::setTermsLowerBound — Specifies the Term to start from
    • SolrQuery::setTermsMaxCount — Sets the maximum document frequency
    • SolrQuery::setTermsMinCount — Sets the minimum document frequency
    • SolrQuery::setTermsPrefix — Restrict matches to terms that start with the prefix
    • SolrQuery::setTermsReturnRaw — Return the raw characters of the indexed term
    • SolrQuery::setTermsSort — Specifies how to sort the returned terms
    • SolrQuery::setTermsUpperBound — Sets the term to stop at
    • SolrQuery::setTimeAllowed — The time allowed for search to finish
  • SolrDisMaxQuery — The SolrDisMaxQuery class
    • SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)
    • SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)
    • SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)
    • SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)
    • SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)
    • SolrDisMaxQuery::__construct — Class Constructor
    • SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)
    • SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)
    • SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)
    • SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)
    • SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)
    • SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)
    • SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter)
    • SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)
    • SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)
    • SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)
    • SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)
    • SolrDisMaxQuery::setQueryPhraseSlop — Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
    • SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)
    • SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)
    • SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)
    • SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)
    • SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser
    • SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax
  • SolrCollapseFunction — The SolrCollapseFunction class
    • SolrCollapseFunction::__construct — Constructor
    • SolrCollapseFunction::getField — Returns the field that is being collapsed on
    • SolrCollapseFunction::getHint — Returns collapse hint
    • SolrCollapseFunction::getMax — Returns max parameter
    • SolrCollapseFunction::getMin — Returns min parameter
    • SolrCollapseFunction::getNullPolicy — Returns null policy
    • SolrCollapseFunction::getSize — Returns size parameter
    • SolrCollapseFunction::setField — Sets the field to collapse on
    • SolrCollapseFunction::setHint — Sets collapse hint
    • SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query
    • SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::setNullPolicy — Sets the NULL Policy
    • SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function
  • SolrException — The SolrException class
    • SolrException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrClientException — The SolrClientException class
    • SolrClientException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrServerException — The SolrServerException class
    • SolrServerException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrIllegalArgumentException — The SolrIllegalArgumentException class
    • SolrIllegalArgumentException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrIllegalOperationException — The SolrIllegalOperationException class
    • SolrIllegalOperationException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrMissingMandatoryParameterException — The SolrMissingMandatoryParameterException class


简介

The Solr extension allows you to communicate effectively with the Apache Solr Server in PHP.

The Solr extension is an extremely fast, light-weight, feature-rich library that allows PHP developers to communicate effectively with Solr server instances.

Versions 1.x of The PECL Extension supports Apache Solr Server 1.3-3.x

Versions 2.x of The PECL Extension supports Apache Solr Server 4.0+

There are built-in tools to add documents and make updates to the solr server.

It also contains tools that allows you to build advanced queries to the server when searching for documents.


需求

PHP version 5.2.11 or later is required.

The libxml and curl extensions must also be enabled for the Apache Solr extension to be available.

libxml2 2.6.31 or later is required.

libcurl 7.18.0 or later is also required.

The above library versions are required and attempting to hack the code to make it compile is strongly discouraged. It will fail, possibly with errors that could be hard to debug


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/solr.

For help and support, please visit the extension google group. » Apache Solr PHP Extension

此扩展在 Windows 平台的二进制扩展 (DLL 文件) PECL 可以在 PECL 官方网站上下载。

Note:

The solr module can be compiled in debug mode by passing the --enable-solr-debug flag to configure

When building manually, be sure to include curl and libxml support within the build.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SOLR_MAJOR_VERSION (int)
SOLR_MINOR_VERSION (int)
SOLR_PATCH_VERSION (int)
SOLR_EXTENSION_VERSION (string)


  • ? 预定义常量
  • solr_get_version ?
  • PHP Manual
  • Solr
  • Solr 函数

Solr 函数

Table of Contents

  • solr_get_version — 返回当前Solr扩展的版本


返回当前Solr扩展的版本

  • ? Solr 函数
  • 范例 ?
  • PHP Manual
  • Solr 函数
  • 返回当前Solr扩展的版本

solr_get_version

(PECL solr >= 0.9.1)

solr_get_version — 返回当前Solr扩展的版本

说明

solr_get_version ( ) : string

函数已字符串形式返回扩展的当前版本。

参数

此函数没有参数。

返回值

获取成功则返回版本号，否则返回 false 。

错误／异常

此函数不抛出异常

范例

Example #1 solr_get_version() example

<?php

$solr_version = solr_get_version();

print $solr_version;

?>

以上例程的输出类似于：

0.9.6

参见

  • SolrUtils::getSolrVersion() - Returns the current version of the Solr extension


范例

Examples of how to use the Apache Solr extension in PHP

Example #1 Contents of the BootStrap file

<?php

/* Domain name of the Solr server */
define('SOLR_SERVER_HOSTNAME', 'solr.example.com');

/* Whether or not to run in secure mode */
define('SOLR_SECURE', true);

/* HTTP Port to connection */
define('SOLR_SERVER_PORT', ((SOLR_SECURE) ? 8443 : 8983));

/* HTTP Basic Authentication Username */
define('SOLR_SERVER_USERNAME', 'admin');

/* HTTP Basic Authentication password */
define('SOLR_SERVER_PASSWORD', 'changeit');

/* HTTP connection timeout */
/* This is maximum time in seconds allowed for the http data transfer operation. Default value is 30 seconds */
define('SOLR_SERVER_TIMEOUT', 10);

/* File name to a PEM-formatted private key + private certificate (concatenated in that order) */
define('SOLR_SSL_CERT', 'certs/combo.pem');

/* File name to a PEM-formatted private certificate only */
define('SOLR_SSL_CERT_ONLY', 'certs/solr.crt');

/* File name to a PEM-formatted private key */
define('SOLR_SSL_KEY', 'certs/solr.key');

/* Password for PEM-formatted private key file */
define('SOLR_SSL_KEYPASSWORD', 'StrongAndSecurePassword');

/* Name of file holding one or more CA certificates to verify peer with*/
define('SOLR_SSL_CAINFO', 'certs/cacert.crt');

/* Name of directory holding multiple CA certificates to verify peer with */
define('SOLR_SSL_CAPATH', 'certs/');

?>

Example #2 Adding a document to the index

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$updateResponse = $client->addDocument($doc);

print_r($updateResponse->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 446
        )

)

Example #3 Merging one document into another document

<?php

include "bootstrap.php";

$doc = new SolrDocument();

$second_doc = new SolrDocument();

$doc->addField('id', 1123);

$doc->features = "PHP Client Side";
$doc->features = "Fast development cycles";

$doc['cat'] = 'Software';
$doc['cat'] = 'Custom Search';
$doc->cat   = 'Information Technology';

$second_doc->addField('cat', 'Lucene Search');

$second_doc->merge($doc, true);

print_r($second_doc->toArray());

?>

以上例程的输出类似于：

Array
(
    [document_boost] => 0
    [field_count] => 3
    [fields] => Array
        (
            [0] => SolrDocumentField Object
                (
                    [name] => cat
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => Software
                            [1] => Custom Search
                            [2] => Information Technology
                        )

                )

            [1] => SolrDocumentField Object
                (
                    [name] => id
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => 1123
                        )

                )

            [2] => SolrDocumentField Object
                (
                    [name] => features
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => PHP Client Side
                            [1] => Fast development cycles
                        )

                )

        )

)

Example #4 Searching for documents - SolrObject responses

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery('lucene');

$query->setStart(0);

$query->setRows(50);

$query->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response);

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [wt] => xml
                    [rows] => 50
                    [start] => 0
                    [indent] => on
                    [q] => lucene
                    [fl] => cat,features,id,timestamp
                    [version] => 2.2
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 3
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => Software
                                    [1] => Lucene
                                )

                            [id] => 334456
                        )

                    [1] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => Software
                                    [1] => Lucene
                                )

                            [id] => 334455
                        )

                    [2] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => software
                                    [1] => search
                                )

                            [features] => Array
                                (
                                    [0] => Advanced Full-Text Search Capabilities using Lucene
                                    [1] => Optimized for High Volume Web Traffic
                                    [2] => Standards Based Open Interfaces - XML and HTTP
                                    [3] => Comprehensive HTML Administration Interfaces
                                    [4] => Scalability - Efficient Replication to other Solr Search Servers
                                    [5] => Flexible and Adaptable with XML configuration and Schema
                                    [6] => Good unicode support: héllo (hello with an accent over the e)
                                )

                            [id] => SOLR1000
                            [timestamp] => 2009-09-04T20:38:55.906
                        )

                )

        )

)

Example #5 Searching for documents - SolrDocument responses

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery('lucene');

$query->setStart(0);

$query->setRows(50);

$query->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$query_response = $client->query($query);

$query_response->setParseMode(SolrQueryResponse::PARSE_SOLR_DOC);

$response = $query_response->getResponse();

print_r($response);

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [wt] => xml
                    [rows] => 50
                    [start] => 0
                    [indent] => on
                    [q] => lucene
                    [fl] => cat,features,id,timestamp
                    [version] => 2.2
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 3
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 19740
                        )

                    [1] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 25485
                        )

                    [2] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 25052
                        )

                )

        )

)

Example #6 Simple TermsComponent example - basic

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setTerms(true);

$query->setTermsField('cat');

$updateResponse = $client->query($query);

print_r($updateResponse->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 2
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [electronics] => 14
                    [Lucene] => 4
                    [Software] => 4
                    [memory] => 3
                    [card] => 2
                    [connector] => 2
                    [drive] => 2
                    [graphics] => 2
                    [hard] => 2
                    [monitor] => 2
                )

        )

)

Example #7 Simple TermsComponent example - using a prefix

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setTerms(true);

/* Return only terms starting with $prefix */
$prefix = 'c';

$query->setTermsField('cat')->setTermsPrefix($prefix);

$updateResponse = $client->query($query);

print_r($updateResponse->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [card] => 2
                    [connector] => 2
                    [camera] => 1
                    [copier] => 1
                )

        )

)

Example #8 Simple TermsComponent example - specifying a minimum frequency

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setTerms(true);

/* Return only terms starting with $prefix */
$prefix = 'c';

/* Return only terms with a frequency of 2 or greater */
$min_frequency = 2;

$query->setTermsField('cat')->setTermsPrefix($prefix)->setTermsMinCount($min_frequency);

$updateResponse = $client->query($query);

print_r($updateResponse->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 0
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [card] => 2
                    [connector] => 2
                )

        )

)

Example #9 Simple Facet Example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2);

$updateResponse = $client->query($query);

$response_array = $updateResponse->getResponse();

$facet_data = $response_array->facet_counts->facet_fields;

print_r($facet_data);

?>

以上例程的输出类似于：

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
            [1] => 3
            [184] => 3
            [2] => 3
            [3200] => 3
            [400] => 3
            [500] => 3
            [ddr] => 3
            [i] => 3
            [ipod] => 3
            [memori] => 3
            [pc] => 3
            [pin] => 3
            [pod] => 3
            [sdram] => 3
            [system] => 3
            [unbuff] => 3
            [canon] => 2
            [corsair] => 2
            [drive] => 2
            [hard] => 2
            [mb] => 2
            [n] => 2
            [power] => 2
            [retail] => 2
            [video] => 2
            [x] => 2
        )

)

Example #10 Simple Facet Example - with optional field override for mincount

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2)->setFacetMinCount(4, 'name');

$updateResponse = $client->query($query);

$response_array = $updateResponse->getResponse();

$facet_data = $response_array->facet_counts->facet_fields;

print_r($facet_data);

?>

以上例程的输出类似于：

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
        )

)

Example #11 Facet Date Example

<?php

include "bootstrap.php";

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetDateField('manufacturedate_dt');

$query->setFacetDateStart('2006-02-13T00:00:00Z');

$query->setFacetDateEnd('2012-02-13T00:00:00Z');

$query->setFacetDateGap('+1YEAR');

$query->setFacetDateHardEnd(1);

$query->addFacetDateOther('before');

$updateResponse = $client->query($query);

$response_array = $updateResponse->getResponse();

$facet_data = $response_array->facet_counts->facet_dates;

print_r($facet_data);

?>

以上例程的输出类似于：

SolrObject Object
(
    [manufacturedate_dt] => SolrObject Object
        (
            [2006-02-13T00:00:00Z] => 9
            [2007-02-13T00:00:00Z] => 0
            [2008-02-13T00:00:00Z] => 0
            [2009-02-13T00:00:00Z] => 0
            [2010-02-13T00:00:00Z] => 0
            [2011-02-13T00:00:00Z] => 0
            [gap] => +1YEAR
            [start] => 2006-02-13T00:00:00Z
            [end] => 2012-02-13T00:00:00Z
            [before] => 2
        )

)

Example #12 Connecting to SSL-Enabled Server

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'timeout'  => SOLR_SERVER_TIMEOUT,
    'secure'   => SOLR_SECURE,
    'ssl_cert' => SOLR_SSL_CERT_ONLY,
    'ssl_key'  => SOLR_SSL_KEY,
    'ssl_keypassword' => SOLR_SSL_KEYPASSWORD,
    'ssl_cainfo' => SOLR_SSL_CAINFO,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2)->setFacetMinCount(4, 'name');

$updateResponse = $client->query($query);

$response_array = $updateResponse->getResponse();

$facet_data = $response_array->facet_counts->facet_fields;

print_r($facet_data);

?>

以上例程的输出类似于：

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
        )

)

Example #13 Collapsing a SolrQuery

<?php
include "bootstrap.php";

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
        'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$collapseFunction = new SolrCollapseFunction('manu_id_s');

$collapseFunction
->setSize(2)
->setNullPolicy(SolrCollapseFunction::NULLPOLICY_IGNORE);

$query
->collapse($collapseFunction)
->setRows(4);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);
?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [q] => *:*
                    [indent] => on
                    [fq] => {!collapse field=manu_id_s size=2 nullPolicy=ignore}
                    [rows] => 4
                    [version] => 2.2
                    [wt] => xml
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 14
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SP2514N
                            [name] => Array
                                (
                                    [0] => Samsung SpinPoint P120 SP2514N - hard drive - 250 GB - ATA-133
                                )

                            [manu] => Array
                                (
                                    [0] => Samsung Electronics Co. Ltd.
                                )

                            [manu_id_s] => samsung
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => 7200RPM, 8MB cache, IDE Ultra ATA-133
                                    [1] => NoiseGuard, SilentSeek technology, Fluid Dynamic Bearing (FDB) motor
                                )

                            [price] => Array
                                (
                                    [0] => 92
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [store] => Array
                                (
                                    [0] => 35.0752,-97.032
                                )

                            [_version_] => 1510294336412057600
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                    [2] => SolrObject Object
                        (
                            [id] => F8V7067-APL-KIT
                            [name] => Array
                                (
                                    [0] => Belkin Mobile Power Cord for iPod w/ Dock
                                )

                            [manu] => Array
                                (
                                    [0] => Belkin
                                )

                            [manu_id_s] => belkin
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => connector
                                )

                            [features] => Array
                                (
                                    [0] => car power adapter, white
                                )

                            [weight] => Array
                                (
                                    [0] => 4
                                )

                            [price] => Array
                                (
                                    [0] => 19.95
                                )

                            [popularity] => Array
                                (
                                    [0] => 1
                                )

                            [inStock] => Array
                                (
                                    [0] =>
                                )

                            [store] => Array
                                (
                                    [0] => 45.18014,-93.87741
                                )

                            [manufacturedate_dt] => 2005-08-01T16:30:25Z
                            [_version_] => 1510294336458194944
                        )

                    [3] => SolrObject Object
                        (
                            [id] => MA147LL/A
                            [name] => Array
                                (
                                    [0] => Apple 60 GB iPod with Video Playback Black
                                )

                            [manu] => Array
                                (
                                    [0] => Apple Computer Inc.
                                )

                            [manu_id_s] => apple
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => music
                                )

                            [features] => Array
                                (
                                    [0] => iTunes, Podcasts, Audiobooks
                                    [1] => Stores up to 15,000 songs, 25,000 photos, or 150 hours of video
                                    [2] => 2.5-inch, 320x240 color TFT LCD display with LED backlight
                                    [3] => Up to 20 hours of battery life
                                    [4] => Plays AAC, MP3, WAV, AIFF, Audible, Apple Lossless, H.264 video
                                    [5] => Notes, Calendar, Phone book, Hold button, Date display, Photo wallet, Built-in games, JPEG photo playback, Upgradeable firmware, USB 2.0 compatibility, Playback speed control, Rechargeable capability, Battery level indication
                                )

                            [includes] => Array
                                (
                                    [0] => earbud headphones, USB cable
                                )

                            [weight] => Array
                                (
                                    [0] => 5.5
                                )

                            [price] => Array
                                (
                                    [0] => 399
                                )

                            [popularity] => Array
                                (
                                    [0] => 10
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 37.7752,-100.0232
                                )

                            [manufacturedate_dt] => 2005-10-12T08:00:00Z
                            [_version_] => 1510294336562003968
                        )

                )

        )

)

Example #14 Solr Real Time Get (RTG) example SolrClient::getById()

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getById('GB18030TEST');
print_r($response->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [doc] => SolrObject Object
        (
            [id] => GB18030TEST
            [name] => Array
                (
                    [0] => Test with some GB18030 encoded characters
                )

            [features] => Array
                (
                    [0] => No accents here
                    [1] => 这是一个功能
                    [2] => This is a feature (translated)
                    [3] => 这份文件是很有光泽
                    [4] => This document is very shiny (translated)
                )

            [price] => Array
                (
                    [0] => 0
                )

            [inStock] => Array
                (
                    [0] => 1
                )

            [_version_] => 1510294336239042560
        )

)


The SolrUtils class

(PECL solr >= 0.9.2)

简介

Contains utility methods for retrieving the current extension version and preparing query phrases.

Also contains method for escaping query strings and parsing XML responses.

类摘要

abstract SolrUtils {
/* 方法 */
public static digestXmlResponse ( string $xmlresponse , int $parse_mode = 0 ) : SolrObject
public static escapeQueryChars ( string $str ) : string|false
public static getSolrVersion ( ) : string
public static queryPhrase ( string $str ) : string
}

Table of Contents

  • SolrUtils::digestXmlResponse — Parses an response XML string into a SolrObject
  • SolrUtils::escapeQueryChars — Escapes a lucene query string
  • SolrUtils::getSolrVersion — Returns the current version of the Solr extension
  • SolrUtils::queryPhrase — Prepares a phrase from an unescaped lucene string


Parses an response XML string into a SolrObject

  • ? SolrUtils
  • SolrUtils::escapeQueryChars ?
  • PHP Manual
  • SolrUtils
  • Parses an response XML string into a SolrObject

SolrUtils::digestXmlResponse

(PECL solr >= 0.9.2)

SolrUtils::digestXmlResponse — Parses an response XML string into a SolrObject

说明

public static SolrUtils::digestXmlResponse ( string $xmlresponse , int $parse_mode = 0 ) : SolrObject

This method parses an response XML string from the Apache Solr server into a SolrObject. It throws a SolrException if there was an error.

参数

xmlresponse

The XML response string from the Solr server.

parse_mode

Use SolrResponse::PARSE_SOLR_OBJ or SolrResponse::PARSE_SOLR_DOC

返回值

Returns the SolrObject representing the XML response.

If the parse_mode parameter is set to SolrResponse::PARSE_SOLR_OBJ Solr documents will be parses as SolrObject instances.

If it is set to SolrResponse::PARSE_SOLR_DOC, they will be parsed as SolrDocument instances.


Escapes a lucene query string

  • ? SolrUtils::digestXmlResponse
  • SolrUtils::getSolrVersion ?
  • PHP Manual
  • SolrUtils
  • Escapes a lucene query string

SolrUtils::escapeQueryChars

(PECL solr >= 0.9.2)

SolrUtils::escapeQueryChars — Escapes a lucene query string

说明

public static SolrUtils::escapeQueryChars ( string $str ) : string|false

Lucene supports escaping special characters that are part of the query syntax.

The current list special characters are:

+ - && || ! ( ) { } [ ] ^ " ~ * ? : \ /

These characters are part of the query syntax and must be escaped

参数

str

This is the query string to be escaped.

返回值

Returns the escaped string 或者在失败时返回 false.


Returns the current version of the Solr extension

  • ? SolrUtils::escapeQueryChars
  • SolrUtils::queryPhrase ?
  • PHP Manual
  • SolrUtils
  • Returns the current version of the Solr extension

SolrUtils::getSolrVersion

(PECL solr >= 0.9.2)

SolrUtils::getSolrVersion — Returns the current version of the Solr extension

说明

public static SolrUtils::getSolrVersion ( ) : string

Returns the current Solr version.

参数

此函数没有参数。

返回值

The current version of the Apache Solr extension.


Prepares a phrase from an unescaped lucene string

  • ? SolrUtils::getSolrVersion
  • SolrInputDocument ?
  • PHP Manual
  • SolrUtils
  • Prepares a phrase from an unescaped lucene string

SolrUtils::queryPhrase

(PECL solr >= 0.9.2)

SolrUtils::queryPhrase — Prepares a phrase from an unescaped lucene string

说明

public static SolrUtils::queryPhrase ( string $str ) : string

Prepares a phrase from an unescaped lucene string.

参数

str

The lucene phrase.

返回值

Returns the phrase contained in double quotes.


The SolrInputDocument class

(PECL solr >= 0.9.2)

简介

This class represents a Solr document that is about to be submitted to the Solr index.

类摘要

final SolrInputDocument {
/* 常量 */
const int SORT_DEFAULT = 1 ;
const int SORT_ASC = 1 ;
const int SORT_DESC = 2 ;
const int SORT_FIELD_NAME = 1 ;
const int SORT_FIELD_VALUE_COUNT = 2 ;
const int SORT_FIELD_BOOST_VALUE = 4 ;
/* 方法 */
public addChildDocument ( SolrInputDocument $child ) : void
public addChildDocuments ( array &$docs ) : void
public addField ( string $fieldName , string $fieldValue , float $fieldBoostValue = 0.0 ) : bool
public clear ( ) : bool
public __clone ( ) : void
public __construct ( )
public deleteField ( string $fieldName ) : bool
public __destruct ( ) : void
public fieldExists ( string $fieldName ) : bool
public getBoost ( ) : float
public getChildDocuments ( ) : array
public getChildDocumentsCount ( ) : int
public getField ( string $fieldName ) : SolrDocumentField
public getFieldBoost ( string $fieldName ) : float
public getFieldCount ( ) : int|false
public getFieldNames ( ) : array
public hasChildDocuments ( ) : bool
public merge ( SolrInputDocument $sourceDoc , bool $overwrite = true ) : bool
public reset ( ) : bool
public setBoost ( float $documentBoostValue ) : bool
public setFieldBoost ( string $fieldName , float $fieldBoostValue ) : bool
public sort ( int $sortOrderBy , int $sortDirection = SolrInputDocument::SORT_ASC ) : bool
public toArray ( ) : array
}

预定义常量

SolrInputDocument Class Constants

SolrInputDocument::SORT_DEFAULT

Sorts the fields in ascending order.

SolrInputDocument::SORT_ASC

Sorts the fields in ascending order.

SolrInputDocument::SORT_DESC

Sorts the fields in descending order.

SolrInputDocument::SORT_FIELD_NAME

Sorts the fields by name

SolrInputDocument::SORT_FIELD_VALUE_COUNT

Sorts the fields by number of values.

SolrInputDocument::SORT_FIELD_BOOST_VALUE

Sorts the fields by boost value.

Table of Contents

  • SolrInputDocument::addChildDocument — Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments — Adds an array of child documents
  • SolrInputDocument::addField — Adds a field to the document
  • SolrInputDocument::clear — Resets the input document
  • SolrInputDocument::__clone — Creates a copy of a SolrDocument
  • SolrInputDocument::__construct — Constructor
  • SolrInputDocument::deleteField — Removes a field from the document
  • SolrInputDocument::__destruct — Destructor
  • SolrInputDocument::fieldExists — Checks if a field exists
  • SolrInputDocument::getBoost — Retrieves the current boost value for the document
  • SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount — Returns the number of child documents
  • SolrInputDocument::getField — Retrieves a field by name
  • SolrInputDocument::getFieldBoost — Retrieves the boost value for a particular field
  • SolrInputDocument::getFieldCount — Returns the number of fields in the document
  • SolrInputDocument::getFieldNames — Returns an array containing all the fields in the document
  • SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents
  • SolrInputDocument::merge — Merges one input document into another
  • SolrInputDocument::reset — This is an alias of SolrInputDocument::clear
  • SolrInputDocument::setBoost — Sets the boost value for this document
  • SolrInputDocument::setFieldBoost — Sets the index-time boost value for a field
  • SolrInputDocument::sort — Sorts the fields within the document
  • SolrInputDocument::toArray — Returns an array representation of the input document


Adds a child document for block indexing

  • ? SolrInputDocument
  • SolrInputDocument::addChildDocuments ?
  • PHP Manual
  • SolrInputDocument
  • Adds a child document for block indexing

SolrInputDocument::addChildDocument

(PECL solr >= 2.3.0)

SolrInputDocument::addChildDocument — Adds a child document for block indexing

说明

public SolrInputDocument::addChildDocument ( SolrInputDocument $child ) : void

Adds a child document to construct a document block with nested documents.

参数

child

A SolrInputDocument object.

错误／异常

Throws SolrIllegalArgumentException on failure.

Throws SolrException on internal failure.

返回值

范例

Example #1 SolrInputDocument::addChildDocument() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_STORE_PATH,
);

$client = new SolrClient($options);

$product = new SolrInputDocument();

$product->addField('id', 'P-BLACK');
$product->addField('cat', 'tshirt');
$product->addField('cat', 'polo');
$product->addField('content_type', 'product');

$small = new SolrInputDocument();
$small->addField('id', 'TS-BLK-S');
$small->addField('content_type', 'sku');
$small->addField('size', 'S');
$small->addField('inventory', 100);

$medium = new SolrInputDocument();
$medium->addField('id', 'TS-BLK-M');
$medium->addField('content_type', 'sku');
$medium->addField('size', 'M');
$medium->addField('inventory', 200);

$large = new SolrInputDocument();
$large->addField('id', 'TS-BLK-L');
$large->addField('content_type', 'sku');
$large->addField('size', 'L');
$large->addField('inventory', 300);

// add child documents
$product->addChildDocument($small);
$product->addChildDocument($medium);
$product->addChildDocument($large);

// add product document block to the index
$updateResponse = $client->addDocument(
        $product,
        true, // overwrite if the document exists
        10000 // commit within 10 seconds
);

print_r($updateResponse->getResponse());

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 5
        )
)

参见

  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents


Adds an array of child documents

  • ? SolrInputDocument::addChildDocument
  • SolrInputDocument::addField ?
  • PHP Manual
  • SolrInputDocument
  • Adds an array of child documents

SolrInputDocument::addChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::addChildDocuments — Adds an array of child documents

说明

public SolrInputDocument::addChildDocuments ( array &$docs ) : void

Adds an array of child documents to the current input document.

参数

docs

An array of SolrInputDocument objects.

错误／异常

Throws SolrIllegalArgumentException on failure.

Throws SolrException on internal failure.

返回值

范例

Example #1 SolrInputDocument::addChildDocuments() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_STORE_PATH,
);

$client = new SolrClient($options);

$product = new SolrInputDocument();

$product->addField('id', 'P-BLACK');
$product->addField('cat', 'tshirt');
$product->addField('cat', 'polo');
$product->addField('content_type', 'product');

$small = new SolrInputDocument();
$small->addField('id', 'TS-BLK-S');
$small->addField('content_type', 'sku');
$small->addField('size', 'S');
$small->addField('inventory', 100);

$medium = new SolrInputDocument();
$medium->addField('id', 'TS-BLK-M');
$medium->addField('content_type', 'sku');
$medium->addField('size', 'M');
$medium->addField('inventory', 200);

$large = new SolrInputDocument();
$large->addField('id', 'TS-BLK-L');
$large->addField('content_type', 'sku');
$large->addField('size', 'L');
$large->addField('inventory', 300);

// add child documents
$skus = [$small, $medium, $large];
$product->addChildDocuments($skus);

// add the product document block to the index
$updateResponse = $client->addDocument(
        $product,
        true, // overwrite if the document exists
        10000 // commit within 10 seconds
);

print_r($updateResponse->getResponse());

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 5
        )
)

参见

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents


Adds a field to the document

  • ? SolrInputDocument::addChildDocuments
  • SolrInputDocument::clear ?
  • PHP Manual
  • SolrInputDocument
  • Adds a field to the document

SolrInputDocument::addField

(PECL solr >= 0.9.2)

SolrInputDocument::addField — Adds a field to the document

说明

public SolrInputDocument::addField ( string $fieldName , string $fieldValue , float $fieldBoostValue = 0.0 ) : bool

For multi-value fields, if a valid boost value is specified, the specified value will be multiplied by the current boost value for this field.

参数

fieldName

The name of the field

fieldValue

The value for the field.

fieldBoostValue

The index time boost for the field. Though this cannot be negative, you can still pass values less than 1.0 but they must be greater than zero.

返回值

成功时返回 true， 或者在失败时返回 false。


Resets the input document

  • ? SolrInputDocument::addField
  • SolrInputDocument::__clone ?
  • PHP Manual
  • SolrInputDocument
  • Resets the input document

SolrInputDocument::clear

(PECL solr >= 0.9.2)

SolrInputDocument::clear — Resets the input document

说明

public SolrInputDocument::clear ( ) : bool

Resets the document by dropping all the fields and resets the document boost to zero.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Creates a copy of a SolrDocument

  • ? SolrInputDocument::clear
  • SolrInputDocument::__construct ?
  • PHP Manual
  • SolrInputDocument
  • Creates a copy of a SolrDocument

SolrInputDocument::__clone

(PECL solr >= 0.9.2)

SolrInputDocument::__clone — Creates a copy of a SolrDocument

说明

public SolrInputDocument::__clone ( ) : void

Should not be called directly. It is used to create a deep copy of a SolrInputDocument.

参数

此函数没有参数。

返回值

Creates a new SolrInputDocument instance.


Constructor

  • ? SolrInputDocument::__clone
  • SolrInputDocument::deleteField ?
  • PHP Manual
  • SolrInputDocument
  • Constructor

SolrInputDocument::__construct

(PECL solr >= 0.9.2)

SolrInputDocument::__construct — Constructor

说明

public SolrInputDocument::__construct ( )

Constructor.

参数

此函数没有参数。

返回值

None.


Removes a field from the document

  • ? SolrInputDocument::__construct
  • SolrInputDocument::__destruct ?
  • PHP Manual
  • SolrInputDocument
  • Removes a field from the document

SolrInputDocument::deleteField

(PECL solr >= 0.9.2)

SolrInputDocument::deleteField — Removes a field from the document

说明

public SolrInputDocument::deleteField ( string $fieldName ) : bool

Removes a field from the document.

参数

fieldName

The name of the field.

返回值

成功时返回 true， 或者在失败时返回 false。


Destructor

  • ? SolrInputDocument::deleteField
  • SolrInputDocument::fieldExists ?
  • PHP Manual
  • SolrInputDocument
  • Destructor

SolrInputDocument::__destruct

(PECL solr >= 0.9.2)

SolrInputDocument::__destruct — Destructor

说明

public SolrInputDocument::__destruct ( ) : void

Destructor

参数

此函数没有参数。

返回值

None.


Checks if a field exists

  • ? SolrInputDocument::__destruct
  • SolrInputDocument::getBoost ?
  • PHP Manual
  • SolrInputDocument
  • Checks if a field exists

SolrInputDocument::fieldExists

(PECL solr >= 0.9.2)

SolrInputDocument::fieldExists — Checks if a field exists

说明

public SolrInputDocument::fieldExists ( string $fieldName ) : bool

Checks if a field exists

参数

fieldName

Name of the field.

返回值

Returns true if the field was found and false if it was not found.


Retrieves the current boost value for the document

  • ? SolrInputDocument::fieldExists
  • SolrInputDocument::getChildDocuments ?
  • PHP Manual
  • SolrInputDocument
  • Retrieves the current boost value for the document

SolrInputDocument::getBoost

(PECL solr >= 0.9.2)

SolrInputDocument::getBoost — Retrieves the current boost value for the document

说明

public SolrInputDocument::getBoost ( ) : float

Retrieves the current boost value for the document.

参数

此函数没有参数。

返回值

Returns the boost value on success and false on failure.


Returns an array of child documents (SolrInputDocument)

  • ? SolrInputDocument::getBoost
  • SolrInputDocument::getChildDocumentsCount ?
  • PHP Manual
  • SolrInputDocument
  • Returns an array of child documents (SolrInputDocument)

SolrInputDocument::getChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)

说明

public SolrInputDocument::getChildDocuments ( ) : array

Returns an array of child documents (SolrInputDocument)

参数

此函数没有参数。

返回值

参见

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents


Returns the number of child documents

  • ? SolrInputDocument::getChildDocuments
  • SolrInputDocument::getField ?
  • PHP Manual
  • SolrInputDocument
  • Returns the number of child documents

SolrInputDocument::getChildDocumentsCount

(PECL solr >= 2.3.0)

SolrInputDocument::getChildDocumentsCount — Returns the number of child documents

说明

public SolrInputDocument::getChildDocumentsCount ( ) : int

Returns the number of child documents

参数

此函数没有参数。

返回值

参见

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)


Retrieves a field by name

  • ? SolrInputDocument::getChildDocumentsCount
  • SolrInputDocument::getFieldBoost ?
  • PHP Manual
  • SolrInputDocument
  • Retrieves a field by name

SolrInputDocument::getField

(PECL solr >= 0.9.2)

SolrInputDocument::getField — Retrieves a field by name

说明

public SolrInputDocument::getField ( string $fieldName ) : SolrDocumentField

Retrieves a field in the document.

参数

fieldName

The name of the field.

返回值

Returns a SolrDocumentField object on success and false on failure.


Retrieves the boost value for a particular field

  • ? SolrInputDocument::getField
  • SolrInputDocument::getFieldCount ?
  • PHP Manual
  • SolrInputDocument
  • Retrieves the boost value for a particular field

SolrInputDocument::getFieldBoost

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldBoost — Retrieves the boost value for a particular field

说明

public SolrInputDocument::getFieldBoost ( string $fieldName ) : float

Retrieves the boost value for a particular field.

参数

fieldName

The name of the field.

返回值

Returns the boost value for the field or false if there was an error.


Returns the number of fields in the document

  • ? SolrInputDocument::getFieldBoost
  • SolrInputDocument::getFieldNames ?
  • PHP Manual
  • SolrInputDocument
  • Returns the number of fields in the document

SolrInputDocument::getFieldCount

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldCount — Returns the number of fields in the document

说明

public SolrInputDocument::getFieldCount ( ) : int|false

Returns the number of fields in the document.

参数

此函数没有参数。

返回值

Returns an integer on success 或者在失败时返回 false.


Returns an array containing all the fields in the document

  • ? SolrInputDocument::getFieldCount
  • SolrInputDocument::hasChildDocuments ?
  • PHP Manual
  • SolrInputDocument
  • Returns an array containing all the fields in the document

SolrInputDocument::getFieldNames

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldNames — Returns an array containing all the fields in the document

说明

public SolrInputDocument::getFieldNames ( ) : array

Returns an array containing all the fields in the document.

参数

此函数没有参数。

返回值

Returns an array on success and false on failure.


Returns true if the document has any child documents

  • ? SolrInputDocument::getFieldNames
  • SolrInputDocument::merge ?
  • PHP Manual
  • SolrInputDocument
  • Returns true if the document has any child documents

SolrInputDocument::hasChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents

说明

public SolrInputDocument::hasChildDocuments ( ) : bool

Checks whether the document has any child documents

参数

此函数没有参数。

返回值

参见

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents


Merges one input document into another

  • ? SolrInputDocument::hasChildDocuments
  • SolrInputDocument::reset ?
  • PHP Manual
  • SolrInputDocument
  • Merges one input document into another

SolrInputDocument::merge

(PECL solr >= 0.9.2)

SolrInputDocument::merge — Merges one input document into another

说明

public SolrInputDocument::merge ( SolrInputDocument $sourceDoc , bool $overwrite = true ) : bool

Merges one input document into another.

参数

sourceDoc

The source document.

overwrite

If this is true it will replace matching fields in the destination document.

返回值

成功时返回 true， 或者在失败时返回 false。 In the future, this will be modified to return the number of fields in the new document.


This is an alias of SolrInputDocument::clear

  • ? SolrInputDocument::merge
  • SolrInputDocument::setBoost ?
  • PHP Manual
  • SolrInputDocument
  • This is an alias of SolrInputDocument::clear

SolrInputDocument::reset

(PECL solr >= 0.9.2)

SolrInputDocument::reset — This is an alias of SolrInputDocument::clear

说明

public SolrInputDocument::reset ( ) : bool

This is an alias of SolrInputDocument::clear

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Sets the boost value for this document

  • ? SolrInputDocument::reset
  • SolrInputDocument::setFieldBoost ?
  • PHP Manual
  • SolrInputDocument
  • Sets the boost value for this document

SolrInputDocument::setBoost

(PECL solr >= 0.9.2)

SolrInputDocument::setBoost — Sets the boost value for this document

说明

public SolrInputDocument::setBoost ( float $documentBoostValue ) : bool

Sets the boost value for this document.

参数

documentBoostValue

The index-time boost value for this document.

返回值

成功时返回 true， 或者在失败时返回 false。


Sets the index-time boost value for a field

  • ? SolrInputDocument::setBoost
  • SolrInputDocument::sort ?
  • PHP Manual
  • SolrInputDocument
  • Sets the index-time boost value for a field

SolrInputDocument::setFieldBoost

(PECL solr >= 0.9.2)

SolrInputDocument::setFieldBoost — Sets the index-time boost value for a field

说明

public SolrInputDocument::setFieldBoost ( string $fieldName , float $fieldBoostValue ) : bool

Sets the index-time boost value for a field. This replaces the current boost value for this field.

参数

fieldName

The name of the field.

fieldBoostValue

The index time boost value.


Sorts the fields within the document

  • ? SolrInputDocument::setFieldBoost
  • SolrInputDocument::toArray ?
  • PHP Manual
  • SolrInputDocument
  • Sorts the fields within the document

SolrInputDocument::sort

(PECL solr >= 0.9.2)

SolrInputDocument::sort — Sorts the fields within the document

说明

public SolrInputDocument::sort ( int $sortOrderBy , int $sortDirection = SolrInputDocument::SORT_ASC ) : bool

The fields are rearranged according to the specified criteria and sort direction

   Fields can be sorted by boost values, field names and number of values.

   The $order_by parameter must be one of :

   * SolrInputDocument::SORT_FIELD_NAME
   * SolrInputDocument::SORT_FIELD_BOOST_VALUE
   * SolrInputDocument::SORT_FIELD_VALUE_COUNT

   The sort direction can be one of :

   * SolrInputDocument::SORT_DEFAULT
   * SolrInputDocument::SORT_ASC
   * SolrInputDocument::SORT_DESC

参数

sortOrderBy

The sort criteria

sortDirection

The sort direction

返回值

成功时返回 true， 或者在失败时返回 false。


Returns an array representation of the input document

  • ? SolrInputDocument::sort
  • SolrDocument ?
  • PHP Manual
  • SolrInputDocument
  • Returns an array representation of the input document

SolrInputDocument::toArray

(PECL solr >= 0.9.2)

SolrInputDocument::toArray — Returns an array representation of the input document

说明

public SolrInputDocument::toArray ( ) : array

Returns an array representation of the input document.

参数

此函数没有参数。

返回值

Returns an array containing the fields. It returns false on failure.


The SolrDocument class

(PECL solr >= 0.9.2)

简介

Represents a Solr document retrieved from a query response.

类摘要

final SolrDocument implements ArrayAccess , Iterator , Serializable {
/* 常量 */
const int SORT_DEFAULT = 1 ;
const int SORT_ASC = 1 ;
const int SORT_DESC = 2 ;
const int SORT_FIELD_NAME = 1 ;
const int SORT_FIELD_VALUE_COUNT = 2 ;
const int SORT_FIELD_BOOST_VALUE = 4 ;
/* 方法 */
public addField ( string $fieldName , string $fieldValue ) : bool
public clear ( ) : bool
public __clone ( ) : void
public __construct ( )
public current ( ) : SolrDocumentField
public deleteField ( string $fieldName ) : bool
public __destruct ( ) : void
public fieldExists ( string $fieldName ) : bool
public __get ( string $fieldName ) : SolrDocumentField
public getChildDocuments ( ) : array
public getChildDocumentsCount ( ) : int
public getField ( string $fieldName ) : SolrDocumentField
public getFieldCount ( ) : int
public getFieldNames ( ) : array
public getInputDocument ( ) : SolrInputDocument
public hasChildDocuments ( ) : bool
public __isset ( string $fieldName ) : bool
public key ( ) : string
public merge ( SolrDocument $sourceDoc , bool $overwrite = true ) : bool
public next ( ) : void
public offsetExists ( string $fieldName ) : bool
public offsetGet ( string $fieldName ) : SolrDocumentField
public offsetSet ( string $fieldName , string $fieldValue ) : void
public offsetUnset ( string $fieldName ) : void
public reset ( ) : bool
public rewind ( ) : void
public serialize ( ) : string
public __set ( string $fieldName , string $fieldValue ) : bool
public sort ( int $sortOrderBy , int $sortDirection = SolrDocument::SORT_ASC ) : bool
public toArray ( ) : array
public unserialize ( string $serialized ) : void
public __unset ( string $fieldName ) : bool
public valid ( ) : bool
}

预定义常量

SolrDocument::SORT_DEFAULT

Default mode for sorting fields within the document.

SolrDocument::SORT_ASC

Sorts the fields in ascending order

SolrDocument::SORT_DESC

Sorts the fields in descending order

SolrDocument::SORT_FIELD_NAME

Sorts the fields by field name.

SolrDocument::SORT_FIELD_VALUE_COUNT

Sorts the fields by number of values in each field.

SolrDocument::SORT_FIELD_BOOST_VALUE

Sorts the fields by thier boost values.

Table of Contents

  • SolrDocument::addField — Adds a field to the document
  • SolrDocument::clear — Drops all the fields in the document
  • SolrDocument::__clone — Creates a copy of a SolrDocument object
  • SolrDocument::__construct — Constructor
  • SolrDocument::current — Retrieves the current field
  • SolrDocument::deleteField — Removes a field from the document
  • SolrDocument::__destruct — Destructor
  • SolrDocument::fieldExists — Checks if a field exists in the document
  • SolrDocument::__get — Access the field as a property
  • SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)
  • SolrDocument::getChildDocumentsCount — Returns the number of child documents
  • SolrDocument::getField — Retrieves a field by name
  • SolrDocument::getFieldCount — Returns the number of fields in this document
  • SolrDocument::getFieldNames — Returns an array of fields names in the document
  • SolrDocument::getInputDocument — Returns a SolrInputDocument equivalent of the object
  • SolrDocument::hasChildDocuments — Checks whether the document has any child documents
  • SolrDocument::__isset — Checks if a field exists
  • SolrDocument::key — Retrieves the current key
  • SolrDocument::merge — Merges source to the current SolrDocument
  • SolrDocument::next — Moves the internal pointer to the next field
  • SolrDocument::offsetExists — Checks if a particular field exists
  • SolrDocument::offsetGet — Retrieves a field
  • SolrDocument::offsetSet — Adds a field to the document
  • SolrDocument::offsetUnset — Removes a field
  • SolrDocument::reset — This is an alias to SolrDocument::clear()
  • SolrDocument::rewind — Resets the internal pointer to the beginning
  • SolrDocument::serialize — Used for custom serialization
  • SolrDocument::__set — Adds another field to the document
  • SolrDocument::sort — Sorts the fields in the document
  • SolrDocument::toArray — Returns an array representation of the document
  • SolrDocument::unserialize — Custom serialization of SolrDocument objects
  • SolrDocument::__unset — Removes a field from the document
  • SolrDocument::valid — Checks if the current position internally is still valid


Adds a field to the document

  • ? SolrDocument
  • SolrDocument::clear ?
  • PHP Manual
  • SolrDocument
  • Adds a field to the document

SolrDocument::addField

(PECL solr >= 0.9.2)

SolrDocument::addField — Adds a field to the document

说明

public SolrDocument::addField ( string $fieldName , string $fieldValue ) : bool

This method adds a field to the SolrDocument instance.

参数

fieldName

The name of the field

fieldValue

The value of the field.

返回值

成功时返回 true， 或者在失败时返回 false。


Drops all the fields in the document

  • ? SolrDocument::addField
  • SolrDocument::__clone ?
  • PHP Manual
  • SolrDocument
  • Drops all the fields in the document

SolrDocument::clear

(PECL solr >= 0.9.2)

SolrDocument::clear — Drops all the fields in the document

说明

public SolrDocument::clear ( ) : bool

Resets the current object. Discards all the fields and resets the document boost to zero.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Creates a copy of a SolrDocument object

  • ? SolrDocument::clear
  • SolrDocument::__construct ?
  • PHP Manual
  • SolrDocument
  • Creates a copy of a SolrDocument object

SolrDocument::__clone

(PECL solr >= 0.9.2)

SolrDocument::__clone — Creates a copy of a SolrDocument object

说明

public SolrDocument::__clone ( ) : void

Creates a copy of a SolrDocument object. Not to be called directly.

参数

此函数没有参数。

返回值

None.


Constructor

  • ? SolrDocument::__clone
  • SolrDocument::current ?
  • PHP Manual
  • SolrDocument
  • Constructor

SolrDocument::__construct

(PECL solr >= 0.9.2)

SolrDocument::__construct — Constructor

说明

public SolrDocument::__construct ( )

Constructor for SolrDocument

参数

此函数没有参数。

返回值


Retrieves the current field

  • ? SolrDocument::__construct
  • SolrDocument::deleteField ?
  • PHP Manual
  • SolrDocument
  • Retrieves the current field

SolrDocument::current

(PECL solr >= 0.9.2)

SolrDocument::current — Retrieves the current field

说明

public SolrDocument::current ( ) : SolrDocumentField

Retrieves the current field

参数

此函数没有参数。

返回值

Returns the field


Removes a field from the document

  • ? SolrDocument::current
  • SolrDocument::__destruct ?
  • PHP Manual
  • SolrDocument
  • Removes a field from the document

SolrDocument::deleteField

(PECL solr >= 0.9.2)

SolrDocument::deleteField — Removes a field from the document

说明

public SolrDocument::deleteField ( string $fieldName ) : bool

Removes a field from the document.

参数

fieldName

Name of the field

返回值

成功时返回 true， 或者在失败时返回 false。


Destructor

  • ? SolrDocument::deleteField
  • SolrDocument::fieldExists ?
  • PHP Manual
  • SolrDocument
  • Destructor

SolrDocument::__destruct

(PECL solr >= 0.9.2)

SolrDocument::__destruct — Destructor

说明

public SolrDocument::__destruct ( ) : void

Destructor for SolrDocument.

参数

此函数没有参数。

返回值


Checks if a field exists in the document

  • ? SolrDocument::__destruct
  • SolrDocument::__get ?
  • PHP Manual
  • SolrDocument
  • Checks if a field exists in the document

SolrDocument::fieldExists

(PECL solr >= 0.9.2)

SolrDocument::fieldExists — Checks if a field exists in the document

说明

public SolrDocument::fieldExists ( string $fieldName ) : bool

Checks if the requested field as a valid fieldname in the document.

参数

fieldName

The name of the field.

返回值

Returns true if the field is present and false if it does not.


Access the field as a property

  • ? SolrDocument::fieldExists
  • SolrDocument::getChildDocuments ?
  • PHP Manual
  • SolrDocument
  • Access the field as a property

SolrDocument::__get

(PECL solr >= 0.9.2)

SolrDocument::__get — Access the field as a property

说明

public SolrDocument::__get ( string $fieldName ) : SolrDocumentField

Magic method for accessing the field as a property.

参数

fieldName

The name of the field.

返回值

Returns a SolrDocumentField instance.


Returns an array of child documents (SolrDocument)

  • ? SolrDocument::__get
  • SolrDocument::getChildDocumentsCount ?
  • PHP Manual
  • SolrDocument
  • Returns an array of child documents (SolrDocument)

SolrDocument::getChildDocuments

(PECL solr >= 2.3.0)

SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)

说明

public SolrDocument::getChildDocuments ( ) : array

Returns an array of child documents (SolrDocument)

参数

此函数没有参数。

返回值

参见

  • SolrDocument::hasChildDocuments() - Checks whether the document has any child documents
  • SolrDocument::getChildDocumentsCount() - Returns the number of child documents


Returns the number of child documents

  • ? SolrDocument::getChildDocuments
  • SolrDocument::getField ?
  • PHP Manual
  • SolrDocument
  • Returns the number of child documents

SolrDocument::getChildDocumentsCount

(PECL solr >= 2.3.0)

SolrDocument::getChildDocumentsCount — Returns the number of child documents

说明

public SolrDocument::getChildDocumentsCount ( ) : int

Returns the number of child documents

参数

此函数没有参数。

返回值

参见

  • SolrDocument::hasChildDocuments() - Checks whether the document has any child documents
  • SolrDocument::getChildDocuments() - Returns an array of child documents (SolrDocument)


Retrieves a field by name

  • ? SolrDocument::getChildDocumentsCount
  • SolrDocument::getFieldCount ?
  • PHP Manual
  • SolrDocument
  • Retrieves a field by name

SolrDocument::getField

(PECL solr >= 0.9.2)

SolrDocument::getField — Retrieves a field by name

说明

public SolrDocument::getField ( string $fieldName ) : SolrDocumentField

Retrieves a field by name.

参数

fieldName

Name of the field.

返回值

Returns a SolrDocumentField on success and false on failure.


Returns the number of fields in this document

  • ? SolrDocument::getField
  • SolrDocument::getFieldNames ?
  • PHP Manual
  • SolrDocument
  • Returns the number of fields in this document

SolrDocument::getFieldCount

(PECL solr >= 0.9.2)

SolrDocument::getFieldCount — Returns the number of fields in this document

说明

public SolrDocument::getFieldCount ( ) : int

Returns the number of fields in this document. Multi-value fields are only counted once.

参数

此函数没有参数。

返回值

Returns an integer on success and false on failure.


Returns an array of fields names in the document

  • ? SolrDocument::getFieldCount
  • SolrDocument::getInputDocument ?
  • PHP Manual
  • SolrDocument
  • Returns an array of fields names in the document

SolrDocument::getFieldNames

(PECL solr >= 0.9.2)

SolrDocument::getFieldNames — Returns an array of fields names in the document

说明

public SolrDocument::getFieldNames ( ) : array

Returns an array of fields names in the document.

参数

此函数没有参数。

返回值

Returns an array containing the names of the fields in this document.


Returns a SolrInputDocument equivalent of the object

  • ? SolrDocument::getFieldNames
  • SolrDocument::hasChildDocuments ?
  • PHP Manual
  • SolrDocument
  • Returns a SolrInputDocument equivalent of the object

SolrDocument::getInputDocument

(PECL solr >= 0.9.2)

SolrDocument::getInputDocument — Returns a SolrInputDocument equivalent of the object

说明

public SolrDocument::getInputDocument ( ) : SolrInputDocument

Returns a SolrInputDocument equivalent of the object. This is useful if one wishes to resubmit/update a document retrieved from a query.

参数

此函数没有参数。

返回值

Returns a SolrInputDocument on success and null on failure.


Checks whether the document has any child documents

  • ? SolrDocument::getInputDocument
  • SolrDocument::__isset ?
  • PHP Manual
  • SolrDocument
  • Checks whether the document has any child documents

SolrDocument::hasChildDocuments

(PECL solr >= 2.3.0)

SolrDocument::hasChildDocuments — Checks whether the document has any child documents

说明

public SolrDocument::hasChildDocuments ( ) : bool

Checks whether the document has any child documents

参数

此函数没有参数。

返回值

参见

  • SolrDocument::getChildDocuments() - Returns an array of child documents (SolrDocument)
  • SolrDocument::getChildDocumentsCount() - Returns the number of child documents


Checks if a field exists

  • ? SolrDocument::hasChildDocuments
  • SolrDocument::key ?
  • PHP Manual
  • SolrDocument
  • Checks if a field exists

SolrDocument::__isset

(PECL solr >= 0.9.2)

SolrDocument::__isset — Checks if a field exists

说明

public SolrDocument::__isset ( string $fieldName ) : bool

Checks if a field exists

参数

fieldName

Name of the field.

返回值

成功时返回 true， 或者在失败时返回 false。


Retrieves the current key

  • ? SolrDocument::__isset
  • SolrDocument::merge ?
  • PHP Manual
  • SolrDocument
  • Retrieves the current key

SolrDocument::key

(PECL solr >= 0.9.2)

SolrDocument::key — Retrieves the current key

说明

public SolrDocument::key ( ) : string

Retrieves the current key.

参数

此函数没有参数。

返回值

Returns the current key.


Merges source to the current SolrDocument

  • ? SolrDocument::key
  • SolrDocument::next ?
  • PHP Manual
  • SolrDocument
  • Merges source to the current SolrDocument

SolrDocument::merge

(PECL solr >= 0.9.2)

SolrDocument::merge — Merges source to the current SolrDocument

说明

public SolrDocument::merge ( SolrDocument $sourceDoc , bool $overwrite = true ) : bool

Merges source to the current SolrDocument.

参数

sourceDoc

The source document.

overwrite

If this is true then fields with the same name in the destination document will be overwritten.

返回值

成功时返回 true， 或者在失败时返回 false。


Moves the internal pointer to the next field

  • ? SolrDocument::merge
  • SolrDocument::offsetExists ?
  • PHP Manual
  • SolrDocument
  • Moves the internal pointer to the next field

SolrDocument::next

(PECL solr >= 0.9.2)

SolrDocument::next — Moves the internal pointer to the next field

说明

public SolrDocument::next ( ) : void

Moves the internal pointer to the next field.

参数

此函数没有参数。

返回值

This method has no return value.


Checks if a particular field exists

  • ? SolrDocument::next
  • SolrDocument::offsetGet ?
  • PHP Manual
  • SolrDocument
  • Checks if a particular field exists

SolrDocument::offsetExists

(PECL solr >= 0.9.2)

SolrDocument::offsetExists — Checks if a particular field exists

说明

public SolrDocument::offsetExists ( string $fieldName ) : bool

Checks if a particular field exists. This is used when the object is treated as an array.

参数

fieldName

The name of the field.

返回值

成功时返回 true， 或者在失败时返回 false。


Retrieves a field

  • ? SolrDocument::offsetExists
  • SolrDocument::offsetSet ?
  • PHP Manual
  • SolrDocument
  • Retrieves a field

SolrDocument::offsetGet

(PECL solr >= 0.9.2)

SolrDocument::offsetGet — Retrieves a field

说明

public SolrDocument::offsetGet ( string $fieldName ) : SolrDocumentField

This is used to retrieve the field when the object is treated as an array.

参数

fieldName

The name of the field.

返回值

Returns a SolrDocumentField object.


Adds a field to the document

  • ? SolrDocument::offsetGet
  • SolrDocument::offsetUnset ?
  • PHP Manual
  • SolrDocument
  • Adds a field to the document

SolrDocument::offsetSet

(PECL solr >= 0.9.2)

SolrDocument::offsetSet — Adds a field to the document

说明

public SolrDocument::offsetSet ( string $fieldName , string $fieldValue ) : void

Used when the object is treated as an array to add a field to the document.

参数

fieldName

The name of the field.

fieldValue

The value for this field.

返回值

成功时返回 true， 或者在失败时返回 false。


Removes a field

  • ? SolrDocument::offsetSet
  • SolrDocument::reset ?
  • PHP Manual
  • SolrDocument
  • Removes a field

SolrDocument::offsetUnset

(PECL solr >= 0.9.2)

SolrDocument::offsetUnset — Removes a field

说明

public SolrDocument::offsetUnset ( string $fieldName ) : void

Removes a field from the document.

参数

fieldName

The name of the field.

返回值

No return value.


This is an alias to SolrDocument::clear()

  • ? SolrDocument::offsetUnset
  • SolrDocument::rewind ?
  • PHP Manual
  • SolrDocument
  • This is an alias to SolrDocument::clear()

SolrDocument::reset

(PECL solr >= 0.9.2)

SolrDocument::reset — This is an alias to SolrDocument::clear()

说明

public SolrDocument::reset ( ) : bool

This is an alias to SolrDocument::clear()

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Resets the internal pointer to the beginning

  • ? SolrDocument::reset
  • SolrDocument::serialize ?
  • PHP Manual
  • SolrDocument
  • Resets the internal pointer to the beginning

SolrDocument::rewind

(PECL solr >= 0.9.2)

SolrDocument::rewind — Resets the internal pointer to the beginning

说明

public SolrDocument::rewind ( ) : void

Resets the internal pointer to the beginning.

参数

此函数没有参数。

返回值

This method has no return value.


Used for custom serialization

  • ? SolrDocument::rewind
  • SolrDocument::__set ?
  • PHP Manual
  • SolrDocument
  • Used for custom serialization

SolrDocument::serialize

(PECL solr >= 0.9.2)

SolrDocument::serialize — Used for custom serialization

说明

public SolrDocument::serialize ( ) : string

Used for custom serialization.

参数

此函数没有参数。

返回值

Returns a string representing the serialized Solr document.


Adds another field to the document

  • ? SolrDocument::serialize
  • SolrDocument::sort ?
  • PHP Manual
  • SolrDocument
  • Adds another field to the document

SolrDocument::__set

(PECL solr >= 0.9.2)

SolrDocument::__set — Adds another field to the document

说明

public SolrDocument::__set ( string $fieldName , string $fieldValue ) : bool

Adds another field to the document. Used to set the fields as new properties.

参数

fieldName

Name of the field.

fieldValue

Field value.

返回值

成功时返回 true， 或者在失败时返回 false。


Sorts the fields in the document

  • ? SolrDocument::__set
  • SolrDocument::toArray ?
  • PHP Manual
  • SolrDocument
  • Sorts the fields in the document

SolrDocument::sort

(PECL solr >= 0.9.2)

SolrDocument::sort — Sorts the fields in the document

说明

public SolrDocument::sort ( int $sortOrderBy , int $sortDirection = SolrDocument::SORT_ASC ) : bool

The fields are rearranged according to the specified criteria and sort direction

   Fields can be sorted by boost values, field names and number of values.

   The sortOrderBy parameter must be one of :

   * SolrDocument::SORT_FIELD_NAME
   * SolrDocument::SORT_FIELD_BOOST_VALUE
   * SolrDocument::SORT_FIELD_VALUE_COUNT

   The sortDirection can be one of :

   * SolrDocument::SORT_DEFAULT
   * SolrDocument::SORT_ASC
   * SolrDocument::SORT_DESC

   The default way is to sort in ascending order.

参数

sortOrderBy

The sort criteria.

sortDirection

The sort direction.

返回值

成功时返回 true， 或者在失败时返回 false。


Returns an array representation of the document

  • ? SolrDocument::sort
  • SolrDocument::unserialize ?
  • PHP Manual
  • SolrDocument
  • Returns an array representation of the document

SolrDocument::toArray

(PECL solr >= 0.9.2)

SolrDocument::toArray — Returns an array representation of the document

说明

public SolrDocument::toArray ( ) : array

Returns an array representation of the document.

参数

此函数没有参数。

返回值

Returns an array representation of the document.

范例

Example #1 SolrDocument::toArray() example

<?php

$doc = new SolrDocument();

$doc->addField('id', 1123);

$doc->features = "PHP Client Side";
$doc->features = "Fast development cycles";

$doc['cat'] = 'Software';
$doc['cat'] = 'Custom Search';
$doc->cat   = 'Information Technology';

print_r($doc->toArray());

?>

以上例程的输出类似于：

Array
(
    [document_boost] => 0
    [field_count] => 3
    [fields] => Array
        (
            [0] => SolrDocumentField Object
                (
                    [name] => id
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => 1123
                        )

                )

            [1] => SolrDocumentField Object
                (
                    [name] => features
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => PHP Client Side
                            [1] => Fast development cycles
                        )

                )

            [2] => SolrDocumentField Object
                (
                    [name] => cat
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => Software
                            [1] => Custom Search
                            [2] => Information Technology
                        )

                )

        )

)


Custom serialization of SolrDocument objects

  • ? SolrDocument::toArray
  • SolrDocument::__unset ?
  • PHP Manual
  • SolrDocument
  • Custom serialization of SolrDocument objects

SolrDocument::unserialize

(PECL solr >= 0.9.2)

SolrDocument::unserialize — Custom serialization of SolrDocument objects

说明

public SolrDocument::unserialize ( string $serialized ) : void

Custom serialization of SolrDocument objects

参数

serialized

An XML representation of the document.

返回值

None.


Removes a field from the document

  • ? SolrDocument::unserialize
  • SolrDocument::valid ?
  • PHP Manual
  • SolrDocument
  • Removes a field from the document

SolrDocument::__unset

(PECL solr >= 0.9.2)

SolrDocument::__unset — Removes a field from the document

说明

public SolrDocument::__unset ( string $fieldName ) : bool

Removes a field from the document when the field is access as an object property.

参数

fieldName

The name of the field.

返回值

成功时返回 true， 或者在失败时返回 false。


Checks if the current position internally is still valid

  • ? SolrDocument::__unset
  • SolrDocumentField ?
  • PHP Manual
  • SolrDocument
  • Checks if the current position internally is still valid

SolrDocument::valid

(PECL solr >= 0.9.2)

SolrDocument::valid — Checks if the current position internally is still valid

说明

public SolrDocument::valid ( ) : bool

Checks if the current position internally is still valid. It is used during foreach operations.

参数

此函数没有参数。

返回值

Returns true on success and false if the current position is no longer valid.


The SolrDocumentField class

(PECL solr >= 0.9.2)

简介

This represents a field in a Solr document. All its properties are read-only.

类摘要

final SolrDocumentField {
/* 属性 */
public readonly string $name ;
public readonly float $boost ;
public readonly array $values ;
/* 方法 */
public __construct ( )
public __destruct ( ) : void
}

属性

name

The name of the field.

boost

The boost value for the field

values

An array of values for this field

Table of Contents

  • SolrDocumentField::__construct — Constructor
  • SolrDocumentField::__destruct — Destructor


Constructor

  • ? SolrDocumentField
  • SolrDocumentField::__destruct ?
  • PHP Manual
  • SolrDocumentField
  • Constructor

SolrDocumentField::__construct

(PECL solr >= 0.9.2)

SolrDocumentField::__construct — Constructor

说明

public SolrDocumentField::__construct ( )

Constructor.

参数

此函数没有参数。

返回值

None.


Destructor

  • ? SolrDocumentField::__construct
  • SolrObject ?
  • PHP Manual
  • SolrDocumentField
  • Destructor

SolrDocumentField::__destruct

(PECL solr >= 0.9.2)

SolrDocumentField::__destruct — Destructor

说明

public SolrDocumentField::__destruct ( ) : void

Destructor.

参数

此函数没有参数。

返回值

None.


The SolrObject class

(PECL solr >= 0.9.2)

简介

This is an object whose properties can also by accessed using the array syntax. All its properties are read-only.

类摘要

final SolrObject implements ArrayAccess {
/* 方法 */
public __construct ( )
public __destruct ( ) : void
public getPropertyNames ( ) : array
public offsetExists ( string $property_name ) : bool
public offsetGet ( string $property_name ) : mixed
public offsetSet ( string $property_name , string $property_value ) : void
public offsetUnset ( string $property_name ) : void
}

Table of Contents

  • SolrObject::__construct — Creates Solr object
  • SolrObject::__destruct — Destructor
  • SolrObject::getPropertyNames — Returns an array of all the names of the properties
  • SolrObject::offsetExists — Checks if the property exists
  • SolrObject::offsetGet — Used to retrieve a property
  • SolrObject::offsetSet — Sets the value for a property
  • SolrObject::offsetUnset — Unsets the value for the property


Creates Solr object

  • ? SolrObject
  • SolrObject::__destruct ?
  • PHP Manual
  • SolrObject
  • Creates Solr object

SolrObject::__construct

(PECL solr >= 0.9.2)

SolrObject::__construct — Creates Solr object

说明

public SolrObject::__construct ( )

Creates Solr object.

参数

此函数没有参数。

返回值

None

范例

Example #1 SolrObject::__construct() example

<?php
/* ... */
?>

以上例程的输出类似于：

...

参见

  • Classname::Method()


Destructor

  • ? SolrObject::__construct
  • SolrObject::getPropertyNames ?
  • PHP Manual
  • SolrObject
  • Destructor

SolrObject::__destruct

(PECL solr >= 0.9.2)

SolrObject::__destruct — Destructor

说明

public SolrObject::__destruct ( ) : void

The destructor

参数

此函数没有参数。

返回值

None.


Returns an array of all the names of the properties

  • ? SolrObject::__destruct
  • SolrObject::offsetExists ?
  • PHP Manual
  • SolrObject
  • Returns an array of all the names of the properties

SolrObject::getPropertyNames

(PECL solr >= 0.9.2)

SolrObject::getPropertyNames — Returns an array of all the names of the properties

说明

public SolrObject::getPropertyNames ( ) : array

Returns an array of all the names of the properties

参数

此函数没有参数。

返回值

Returns an array.


Checks if the property exists

  • ? SolrObject::getPropertyNames
  • SolrObject::offsetGet ?
  • PHP Manual
  • SolrObject
  • Checks if the property exists

SolrObject::offsetExists

(PECL solr >= 0.9.2)

SolrObject::offsetExists — Checks if the property exists

说明

public SolrObject::offsetExists ( string $property_name ) : bool

Checks if the property exists. This is used when the object is treated as an array.

参数

property_name

The name of the property.

返回值

成功时返回 true， 或者在失败时返回 false。


Used to retrieve a property

  • ? SolrObject::offsetExists
  • SolrObject::offsetSet ?
  • PHP Manual
  • SolrObject
  • Used to retrieve a property

SolrObject::offsetGet

(PECL solr >= 0.9.2)

SolrObject::offsetGet — Used to retrieve a property

说明

public SolrObject::offsetGet ( string $property_name ) : mixed

Used to get the value of a property. This is used when the object is treated as an array.

参数

property_name

Name of the property.

返回值

Returns the property value.


Sets the value for a property

  • ? SolrObject::offsetGet
  • SolrObject::offsetUnset ?
  • PHP Manual
  • SolrObject
  • Sets the value for a property

SolrObject::offsetSet

(PECL solr >= 0.9.2)

SolrObject::offsetSet — Sets the value for a property

说明

public SolrObject::offsetSet ( string $property_name , string $property_value ) : void

Sets the value for a property. This is used when the object is treated as an array. This object is read-only. This should never be attempted.

参数

property_name

The name of the property.

property_value

The new value.

返回值

None.


Unsets the value for the property

  • ? SolrObject::offsetSet
  • SolrClient ?
  • PHP Manual
  • SolrObject
  • Unsets the value for the property

SolrObject::offsetUnset

(PECL solr >= 0.9.2)

SolrObject::offsetUnset — Unsets the value for the property

说明

public SolrObject::offsetUnset ( string $property_name ) : void

Unsets the value for the property. This is used when the object is treated as an array. This object is read-only. This should never be attempted.

参数

property_name

The name of the property.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SolrObject::offsetUnset() example

<?php
/* ... */
?>

以上例程的输出类似于：

...

参见

  • Classname::Method()


The SolrClient class

(PECL solr >= 0.9.2)

简介

Used to send requests to a Solr server. Currently, cloning and serialization of SolrClient instances is not supported.

类摘要

final SolrClient {
/* 常量 */
const int SEARCH_SERVLET_TYPE = 1 ;
const int UPDATE_SERVLET_TYPE = 2 ;
const int THREADS_SERVLET_TYPE = 4 ;
const int PING_SERVLET_TYPE = 8 ;
const int TERMS_SERVLET_TYPE = 16 ;
const int SYSTEM_SERVLET_TYPE = 32 ;
const string DEFAULT_SEARCH_SERVLET = select ;
const string DEFAULT_UPDATE_SERVLET = update ;
const string DEFAULT_THREADS_SERVLET = admin/threads ;
const string DEFAULT_PING_SERVLET = admin/ping ;
const string DEFAULT_TERMS_SERVLET = terms ;
const string DEFAULT_SYSTEM_SERVLET = admin/system ;
/* 方法 */
public addDocument ( SolrInputDocument $doc , bool $overwrite = true , int $commitWithin = 0 ) : SolrUpdateResponse
public addDocuments ( array $docs , bool $overwrite = true , int $commitWithin = 0 ) : void
public commit ( bool $softCommit = false , bool $waitSearcher = true , bool $expungeDeletes = false ) : SolrUpdateResponse
public __construct ( array $clientOptions )
public deleteById ( string $id ) : SolrUpdateResponse
public deleteByIds ( array $ids ) : SolrUpdateResponse
public deleteByQueries ( array $queries ) : SolrUpdateResponse
public deleteByQuery ( string $query ) : SolrUpdateResponse
public __destruct ( ) : void
public getById ( string $id ) : SolrQueryResponse
public getByIds ( array $ids ) : SolrQueryResponse
public getDebug ( ) : string
public getOptions ( ) : array
public optimize ( int $maxSegments = 1 , bool $softCommit = true , bool $waitSearcher = true ) : SolrUpdateResponse
public ping ( ) : SolrPingResponse
public query ( SolrParams $query ) : SolrQueryResponse
public request ( string $raw_request ) : SolrUpdateResponse
public rollback ( ) : SolrUpdateResponse
public setResponseWriter ( string $responseWriter ) : void
public setServlet ( int $type , string $value ) : bool
public system ( ) : void
public threads ( ) : void
}

预定义常量

SolrClient::SEARCH_SERVLET_TYPE

Used when updating the search servlet.

SolrClient::UPDATE_SERVLET_TYPE

Used when updating the update servlet.

SolrClient::THREADS_SERVLET_TYPE

Used when updating the threads servlet.

SolrClient::PING_SERVLET_TYPE

Used when updating the ping servlet.

SolrClient::TERMS_SERVLET_TYPE

Used when updating the terms servlet.

SolrClient::SYSTEM_SERVLET_TYPE

Used when retrieving system information from the system servlet.

SolrClient::DEFAULT_SEARCH_SERVLET

This is the initial value for the search servlet.

SolrClient::DEFAULT_UPDATE_SERVLET

This is the initial value for the update servlet.

SolrClient::DEFAULT_THREADS_SERVLET

This is the initial value for the threads servlet.

SolrClient::DEFAULT_PING_SERVLET

This is the initial value for the ping servlet.

SolrClient::DEFAULT_TERMS_SERVLET

This is the initial value for the terms servlet used for the TermsComponent

SolrClient::DEFAULT_SYSTEM_SERVLET

This is the initial value for the system servlet used to obtain Solr Server information

Table of Contents

  • SolrClient::addDocument — Adds a document to the index
  • SolrClient::addDocuments — Adds a collection of SolrInputDocument instances to the index
  • SolrClient::commit — Finalizes all add/deletes made to the index
  • SolrClient::__construct — Constructor for the SolrClient object
  • SolrClient::deleteById — Delete by Id
  • SolrClient::deleteByIds — Deletes by Ids
  • SolrClient::deleteByQueries — Removes all documents matching any of the queries
  • SolrClient::deleteByQuery — Deletes all documents matching the given query
  • SolrClient::__destruct — Destructor for SolrClient
  • SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG)
  • SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)
  • SolrClient::getDebug — Returns the debug data for the last connection attempt
  • SolrClient::getOptions — Returns the client options set internally
  • SolrClient::optimize — Defragments the index
  • SolrClient::ping — Checks if Solr server is still up
  • SolrClient::query — Sends a query to the server
  • SolrClient::request — Sends a raw update request
  • SolrClient::rollback — Rollbacks all add/deletes made to the index since the last commit
  • SolrClient::setResponseWriter — Sets the response writer used to prepare the response from Solr
  • SolrClient::setServlet — Changes the specified servlet type to a new value
  • SolrClient::system — Retrieve Solr Server information
  • SolrClient::threads — Checks the threads status


Adds a document to the index

  • ? SolrClient
  • SolrClient::addDocuments ?
  • PHP Manual
  • SolrClient
  • Adds a document to the index

SolrClient::addDocument

(PECL solr >= 0.9.2)

SolrClient::addDocument — Adds a document to the index

说明

public SolrClient::addDocument ( SolrInputDocument $doc , bool $overwrite = true , int $commitWithin = 0 ) : SolrUpdateResponse

This method adds a document to the index.

参数

doc

The SolrInputDocument instance.

overwrite

Whether to overwrite existing document or not. If false there will be duplicates (several documents with the same ID).

Warning

PECL Solr < 2.0 $allowDups was used instead of $overwrite, which does the same functionality with exact opposite bool flag.

$allowDups = false is the same as $overwrite = true

commitWithin

Number of milliseconds within which to auto commit this document. Available since Solr 1.4 . Default (0) means disabled.

When this value specified, it leaves the control of when to do the commit to Solr itself, optimizing number of commits to a minimum while still fulfilling the update latency requirements, and Solr will automatically do a commit when the oldest add in the buffer is due.

返回值

Returns a SolrUpdateResponse object or throws an Exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

范例

Example #1 SolrClient::addDocument() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$updateResponse = $client->addDocument($doc);

// you will have to commit changes to be written if you didn't use $commitWithin
$client->commit();

print_r($updateResponse->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

)

Example #2 SolrClient::addDocument() example 2

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

// No need to call commit() because $commitWithin is passed, so Solr Server will auto commit within 10 seconds
$updateResponse = $client->addDocument($doc, false, 10000);

print_r($updateResponse->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

)

参见

  • SolrClient::addDocuments() - Adds a collection of SolrInputDocument instances to the index
  • SolrClient::commit() - Finalizes all add/deletes made to the index


Adds a collection of SolrInputDocument instances to the index

  • ? SolrClient::addDocument
  • SolrClient::commit ?
  • PHP Manual
  • SolrClient
  • Adds a collection of SolrInputDocument instances to the index

SolrClient::addDocuments

(PECL solr >= 0.9.2)

SolrClient::addDocuments — Adds a collection of SolrInputDocument instances to the index

说明

public SolrClient::addDocuments ( array $docs , bool $overwrite = true , int $commitWithin = 0 ) : void

Adds a collection of documents to the index.

参数

docs

An array containing the collection of SolrInputDocument instances. This array must be an actual variable.

overwrite

Whether to overwrite existing documents or not. If false there will be duplicates (several documents with the same ID).

Warning

PECL Solr < 2.0 $allowDups was used instead of $overwrite, which does the same functionality with exact opposite bool flag.

$allowDups = false is the same as $overwrite = true

commitWithin

Number of milliseconds within which to auto commit this document. Available since Solr 1.4 . Default (0) means disabled.

When this value specified, it leaves the control of when to do the commit to Solr itself, optimizing number of commits to a minimum while still fulfilling the update latency requirements, and Solr will automatically do a commit when the oldest add in the buffer is due.

返回值

Returns a SolrUpdateResponse object or throws an exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

范例

Example #1 SolrClient::addDocuments() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$doc2 = clone $doc;

$doc2->deleteField('id');
$doc2->addField('id', 334456);

$docs = array($doc, $doc2);

$updateResponse = $client->addDocuments($docs);

// no changes will be written to disk unless $commitWithin is passed or SolrClient::commit is called

print_r($updateResponse->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 2
        )

)

参见

  • SolrClient::addDocument() - Adds a document to the index
  • SolrClient::commit() - Finalizes all add/deletes made to the index


Finalizes all add/deletes made to the index

  • ? SolrClient::addDocuments
  • SolrClient::__construct ?
  • PHP Manual
  • SolrClient
  • Finalizes all add/deletes made to the index

SolrClient::commit

(PECL solr >= 0.9.2)

SolrClient::commit — Finalizes all add/deletes made to the index

说明

public SolrClient::commit ( bool $softCommit = false , bool $waitSearcher = true , bool $expungeDeletes = false ) : SolrUpdateResponse

This method finalizes all add/deletes made to the index.

参数

softCommit

This will refresh the 'view' of the index in a more performant manner, but without "on-disk" guarantees. (Solr4.0+)

A soft commit is much faster since it only makes index changes visible and does not fsync index files or write a new index descriptor. If the JVM crashes or there is a loss of power, changes that occurred after the last hard commit will be lost. Search collections that have near-real-time requirements (that want index changes to be quickly visible to searches) will want to soft commit often but hard commit less frequently.

waitSearcher

block until a new searcher is opened and registered as the main query searcher, making the changes visible.

expungeDeletes

Merge segments with deletes away. (Solr1.4+)

返回值

Returns a SolrUpdateResponse object on success or throws an exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

更新日志

版本 | 说明
PECL solr 1.1.0, 2.0.0 | $maxSegments removed
PECL solr 2.0.0b | API Changed: SolrClient::commit ([ int $maxSegments = 0 [, bool $softCommit = false [, bool $waitSearcher = true[, bool $expungeDeletes = false ]]] )
PECL solr 0.9.2 | Signature: SolrClient::commit ([ int $maxSegments = 1 [, bool $waitFlush = true [, bool $waitSearcher = true ]]] ). $waitFlush: Block until index changes are flushed to disk.

注释

Warning

PECL Solr >= 2.0 only supports Solr Server >= 4.0

参见

  • SolrClient::optimize() - Defragments the index
  • SolrClient::rollback() - Rollbacks all add/deletes made to the index since the last commit


Constructor for the SolrClient object

  • ? SolrClient::commit
  • SolrClient::deleteById ?
  • PHP Manual
  • SolrClient
  • Constructor for the SolrClient object

SolrClient::__construct

(PECL solr >= 0.9.2)

SolrClient::__construct — Constructor for the SolrClient object

说明

public SolrClient::__construct ( array $clientOptions )

Constructor for the SolrClient object

参数

clientOptions

This is an array containing one of the following keys :

- secure          (Boolean value indicating whether or not to connect in secure mode)
 - hostname        (The hostname for the Solr server)
 - port            (The port number)
 - path            (The path to solr)
 - wt              (The name of the response writer e.g. xml, json)
 - login           (The username used for HTTP Authentication, if any)
 - password        (The HTTP Authentication password)
 - proxy_host      (The hostname for the proxy server, if any)
 - proxy_port      (The proxy port)
 - proxy_login     (The proxy username)
 - proxy_password  (The proxy password)
 - timeout         (This is maximum time in seconds allowed for the http data transfer operation. Default is 30 seconds)
 - ssl_cert        (File name to a PEM-formatted file containing the private key + private certificate (concatenated in that order) )
 - ssl_key         (File name to a PEM-formatted private key file only)
 - ssl_keypassword (Password for private key)
 - ssl_cainfo      (Name of file holding one or more CA certificates to verify peer with)
 - ssl_capath      (Name of directory holding multiple CA certificates to verify peer with )

 Please note the if the ssl_cert file only contains the private certificate, you have to specify a separate ssl_key file

 The ssl_keypassword option is required if the ssl_cert or ssl_key options are set.

错误／异常

Throws SolrIllegalArgumentException on failure.

范例

Example #1 SolrClient::__construct() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_PATH_TO_SOLR,
    'wt'       => 'xml',
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$updateResponse = $client->addDocument($doc);

?>

以上例程的输出类似于：

参见

  • SolrClient::getOptions() - Returns the client options set internally


Delete by Id

  • ? SolrClient::__construct
  • SolrClient::deleteByIds ?
  • PHP Manual
  • SolrClient
  • Delete by Id

SolrClient::deleteById

(PECL solr >= 0.9.2)

SolrClient::deleteById — Delete by Id

说明

public SolrClient::deleteById ( string $id ) : SolrUpdateResponse

Deletes the document with the specified ID. Where ID is the value of the uniqueKey field declared in the schema

参数

id

The value of the uniqueKey field declared in the schema

返回值

Returns a SolrUpdateResponse on success and throws an exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

参见

  • SolrClient::deleteByIds() - Deletes by Ids
  • SolrClient::deleteByQuery() - Deletes all documents matching the given query
  • SolrClient::deleteByQueries() - Removes all documents matching any of the queries


Deletes by Ids

  • ? SolrClient::deleteById
  • SolrClient::deleteByQueries ?
  • PHP Manual
  • SolrClient
  • Deletes by Ids

SolrClient::deleteByIds

(PECL solr >= 0.9.2)

SolrClient::deleteByIds — Deletes by Ids

说明

public SolrClient::deleteByIds ( array $ids ) : SolrUpdateResponse

Deletes a collection of documents with the specified set of ids.

参数

ids

An array of IDs representing the uniqueKey field declared in the schema for each document to be deleted. This must be an actual php variable.

返回值

Returns a SolrUpdateResponse on success and throws an exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

参见

  • SolrClient::deleteById() - Delete by Id
  • SolrClient::deleteByQuery() - Deletes all documents matching the given query
  • SolrClient::deleteByQueries() - Removes all documents matching any of the queries


Removes all documents matching any of the queries

  • ? SolrClient::deleteByIds
  • SolrClient::deleteByQuery ?
  • PHP Manual
  • SolrClient
  • Removes all documents matching any of the queries

SolrClient::deleteByQueries

(PECL solr >= 0.9.2)

SolrClient::deleteByQueries — Removes all documents matching any of the queries

说明

public SolrClient::deleteByQueries ( array $queries ) : SolrUpdateResponse

Removes all documents matching any of the queries

参数

queries

The array of queries. This must be an actual php variable.

返回值

Returns a SolrUpdateResponse on success and throws a SolrClientException on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

参见

  • SolrClient::deleteById() - Delete by Id
  • SolrClient::deleteByIds() - Deletes by Ids
  • SolrClient::deleteByQuery() - Deletes all documents matching the given query


Deletes all documents matching the given query

  • ? SolrClient::deleteByQueries
  • SolrClient::__destruct ?
  • PHP Manual
  • SolrClient
  • Deletes all documents matching the given query

SolrClient::deleteByQuery

(PECL solr >= 0.9.2)

SolrClient::deleteByQuery — Deletes all documents matching the given query

说明

public SolrClient::deleteByQuery ( string $query ) : SolrUpdateResponse

Deletes all documents matching the given query.

参数

query

The query

返回值

Returns a SolrUpdateResponse on success and throws an exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

范例

Example #1 SolrQuery::deleteByQuery() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

//This will erase the entire index
$client->deleteByQuery("*:*");
$client->commit();

?>

参见

  • SolrClient::deleteById() - Delete by Id
  • SolrClient::deleteByIds() - Deletes by Ids
  • SolrClient::deleteByQueries() - Removes all documents matching any of the queries


Destructor for SolrClient

  • ? SolrClient::deleteByQuery
  • SolrClient::getById ?
  • PHP Manual
  • SolrClient
  • Destructor for SolrClient

SolrClient::__destruct

(PECL solr >= 0.9.2)

SolrClient::__destruct — Destructor for SolrClient

说明

public SolrClient::__destruct ( ) : void

Destructor

参数

此函数没有参数。

返回值

Destructor for SolrClient

参见

  • SolrClient::__construct() - Constructor for the SolrClient object


Get Document By Id. Utilizes Solr Realtime Get (RTG)

  • ? SolrClient::__destruct
  • SolrClient::getByIds ?
  • PHP Manual
  • SolrClient
  • Get Document By Id. Utilizes Solr Realtime Get (RTG)

SolrClient::getById

(PECL solr >= 2.2.0)

SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG)

说明

public SolrClient::getById ( string $id ) : SolrQueryResponse

Get Document By Id. Utilizes Solr Realtime Get (RTG).

参数

id

Document ID

返回值

SolrQueryResponse

范例

Example #1 SolrClient::getById() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getById('GB18030TEST');
print_r($response->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [doc] => SolrObject Object
        (
            [id] => GB18030TEST
            [name] => Array
                (
                    [0] => Test with some GB18030 encoded characters
                )

            [features] => Array
                (
                    [0] => No accents here
                    [1] => 这是一个功能
                    [2] => This is a feature (translated)
                    [3] => 这份文件是很有光泽
                    [4] => This document is very shiny (translated)
                )

            [price] => Array
                (
                    [0] => 0
                )

            [inStock] => Array
                (
                    [0] => 1
                )

            [_version_] => 1510294336239042560
        )

)

参见

  • SolrClient::getByIds() - Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)


Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)

  • ? SolrClient::getById
  • SolrClient::getDebug ?
  • PHP Manual
  • SolrClient
  • Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)

SolrClient::getByIds

(PECL solr >= 2.2.0)

SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)

说明

public SolrClient::getByIds ( array $ids ) : SolrQueryResponse

Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).

参数

ids

Document ids

返回值

SolrQueryResponse

范例

Example #1 SolrClient::getByIds() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getByIds(['GB18030TEST', '6H500F0']);

print_r($response->getResponse());

?>

以上例程的输出类似于：

SolrObject Object
(
    [response] => SolrObject Object
        (
            [numFound] => 2
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => GB18030TEST
                            [name] => Array
                                (
                                    [0] => Test with some GB18030 encoded characters
                                )

                            [features] => Array
                                (
                                    [0] => No accents here
                                    [1] => 这是一个功能
                                    [2] => This is a feature (translated)
                                    [3] => 这份文件是很有光泽
                                    [4] => This document is very shiny (translated)
                                )

                            [price] => Array
                                (
                                    [0] => 0
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [_version_] => 1510294336239042560
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                )

        )

)

参见

  • SolrClient::getById() - Get Document By Id. Utilizes Solr Realtime Get (RTG)


Returns the debug data for the last connection attempt

  • ? SolrClient::getByIds
  • SolrClient::getOptions ?
  • PHP Manual
  • SolrClient
  • Returns the debug data for the last connection attempt

SolrClient::getDebug

(PECL solr >= 0.9.7)

SolrClient::getDebug — Returns the debug data for the last connection attempt

说明

public SolrClient::getDebug ( ) : string

Returns the debug data for the last connection attempt

参数

此函数没有参数。

返回值

Returns a string on success and null if there is nothing to return.


Returns the client options set internally

  • ? SolrClient::getDebug
  • SolrClient::optimize ?
  • PHP Manual
  • SolrClient
  • Returns the client options set internally

SolrClient::getOptions

(PECL solr >= 0.9.6)

SolrClient::getOptions — Returns the client options set internally

说明

public SolrClient::getOptions ( ) : array

Returns the client options set internally. Very useful for debugging. The values returned are readonly and can only be set when the object is instantiated.

参数

此函数没有参数。

返回值

Returns an array containing all the options for the SolrClient object set internally.

参见

  • SolrClient::__construct() - Constructor for the SolrClient object


Defragments the index

  • ? SolrClient::getOptions
  • SolrClient::ping ?
  • PHP Manual
  • SolrClient
  • Defragments the index

SolrClient::optimize

(PECL solr >= 0.9.2)

SolrClient::optimize — Defragments the index

说明

public SolrClient::optimize ( int $maxSegments = 1 , bool $softCommit = true , bool $waitSearcher = true ) : SolrUpdateResponse

Defragments the index for faster search performance.

参数

maxSegments

Optimizes down to at most this number of segments. Since Solr 1.3

softCommit

This will refresh the 'view' of the index in a more performant manner, but without "on-disk" guarantees. (Solr4.0+)

waitSearcher

Block until a new searcher is opened and registered as the main query searcher, making the changes visible.

返回值

Returns a SolrUpdateResponse on success or throws an exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

注释

Warning

PECL Solr >= 2.0 only supports Solr Server >= 4.0

Prior to PECL Solr 2.0 this method used to accept these arguments "int $maxSegments, bool $waitFlush, bool $waitSearcher".

参见

  • SolrClient::commit() - Finalizes all add/deletes made to the index
  • SolrClient::rollback() - Rollbacks all add/deletes made to the index since the last commit


Checks if Solr server is still up

  • ? SolrClient::optimize
  • SolrClient::query ?
  • PHP Manual
  • SolrClient
  • Checks if Solr server is still up

SolrClient::ping

(PECL solr >= 0.9.2)

SolrClient::ping — Checks if Solr server is still up

说明

public SolrClient::ping ( ) : SolrPingResponse

Checks if the Solr server is still alive. Sends a HEAD request to the Apache Solr server.

参数

此函数没有参数。

返回值

Returns a SolrPingResponse object on success and throws an exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to satisfy the request.

范例

Example #1 SolrClient::ping() example

<?php
$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$pingresponse = $client->ping();

?>

以上例程的输出类似于：


Sends a query to the server

  • ? SolrClient::ping
  • SolrClient::request ?
  • PHP Manual
  • SolrClient
  • Sends a query to the server

SolrClient::query

(PECL solr >= 0.9.2)

SolrClient::query — Sends a query to the server

说明

public SolrClient::query ( SolrParams $query ) : SolrQueryResponse

Sends a query to the server.

参数

query

A SolrParams object. It is recommended to use SolrQuery for advanced queries.

返回值

Returns a SolrQueryResponse object on success and throws an exception on failure.

错误／异常

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to satisfy the query.

范例

Example #1 SolrClient::query() example

<?php

$options = array
(
    'hostname' => 'localhost',
    'login'    => 'username',
    'password' => 'password',
    'port'     => '8983',
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery('lucene');

$query->setStart(0);

$query->setRows(50);

$query->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response);

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 3
            [params] => SolrObject Object
                (
                    [fl] => cat,features,id,timestamp
                    [indent] => on
                    [start] => 0
                    [q] => lucene
                    [wt] => xml
                    [version] => 2.2
                    [rows] => 50
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 1
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SOLR1000
                            [cat] => Array
                                (
                                    [0] => software
                                    [1] => search
                                )

                            [features] => Array
                                (
                                    [0] => Advanced Full-Text Search Capabilities using Lucene
                                    [1] => Optimized for High Volume Web Traffic
                                    [2] => Standards Based Open Interfaces - XML and HTTP
                                    [3] => Comprehensive HTML Administration Interfaces
                                    [4] => Scalability - Efficient Replication to other Solr Search Servers
                                    [5] => Flexible and Adaptable with XML configuration and Schema
                                    [6] => Good unicode support: héllo (hello with an accent over the e)
                                )

                        )

                )

        )

)


Sends a raw update request

  • ? SolrClient::query
  • SolrClient::rollback ?
  • PHP Manual
  • SolrClient
  • Sends a raw update request

SolrClient::request

(PECL solr >= 0.9.2)

SolrClient::request — Sends a raw update request

说明

public SolrClient::request ( string $raw_request ) : SolrUpdateResponse

Sends a raw XML update request to the server

参数

raw_request

An XML string with the raw request to the server.

返回值

Returns a SolrUpdateResponse on success. Throws an exception on failure.

错误／异常

Throws SolrIllegalArgumentException if raw_request was an empty string

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to satisfy the query.

范例

Example #1 SolrClient::request() example

<?php
$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$update_response = $client->request("<commit/>");

$response = $update_response->getResponse();

print_r($response);
?>

以上例程的输出类似于：

...


Rollbacks all add/deletes made to the index since the last commit

  • ? SolrClient::request
  • SolrClient::setResponseWriter ?
  • PHP Manual
  • SolrClient
  • Rollbacks all add/deletes made to the index since the last commit

SolrClient::rollback

(PECL solr >= 0.9.2)

SolrClient::rollback — Rollbacks all add/deletes made to the index since the last commit

说明

public SolrClient::rollback ( ) : SolrUpdateResponse

Rollbacks all add/deletes made to the index since the last commit. It neither calls any event listeners nor creates a new searcher.

参数

此函数没有参数。

返回值

Returns a SolrUpdateResponse on success or throws a SolrClientException on failure.

参见

  • SolrClient::commit() - Finalizes all add/deletes made to the index
  • SolrClient::optimize() - Defragments the index


Sets the response writer used to prepare the response from Solr

  • ? SolrClient::rollback
  • SolrClient::setServlet ?
  • PHP Manual
  • SolrClient
  • Sets the response writer used to prepare the response from Solr

SolrClient::setResponseWriter

(PECL solr >= 0.9.11)

SolrClient::setResponseWriter — Sets the response writer used to prepare the response from Solr

说明

public SolrClient::setResponseWriter ( string $responseWriter ) : void

Sets the response writer used to prepare the response from Solr

参数

responseWriter

One of the following:

  • json
  • phps
  • xml

返回值

没有返回值。

范例

Example #1 SolrClient::setResponseWriter() example

<?php

// This is my custom class for objects
class SolrClass
{
   public $_properties = array();

   public function __get($property_name) {

      if (property_exists($this, $property_name)) {

          return $this->$property_name;

      } else if (isset($_properties[$property_name])) {

          return $_properties[$property_name];
      }

      return null;
   }
}

$options = array
(
  'hostname' => 'localhost',
  'port' => 8983,
  'path' => '/solr/core1'
);

$client = new SolrClient($options);

$client->setResponseWriter("json");

//$response = $client->ping();

$query = new SolrQuery();

$query->setQuery("*:*");

$query->set("objectClassName", "SolrClass");

$query->set("objectPropertiesStorageMode", 1); // 0 for independent properties, 1 for combined

try
{

$response = $client->query($query);

$resp = $response->getResponse();

print_r($response);

print_r($resp);

} catch (Exception $e) {

print_r($e);

}

?>


Changes the specified servlet type to a new value

  • ? SolrClient::setResponseWriter
  • SolrClient::system ?
  • PHP Manual
  • SolrClient
  • Changes the specified servlet type to a new value

SolrClient::setServlet

(PECL solr >= 0.9.2)

SolrClient::setServlet — Changes the specified servlet type to a new value

说明

public SolrClient::setServlet ( int $type , string $value ) : bool

Changes the specified servlet type to a new value

参数

type

One of the following :

- SolrClient::SEARCH_SERVLET_TYPE
 - SolrClient::UPDATE_SERVLET_TYPE
 - SolrClient::THREADS_SERVLET_TYPE
 - SolrClient::PING_SERVLET_TYPE
 - SolrClient::TERMS_SERVLET_TYPE

value

The new value for the servlet

返回值

成功时返回 true， 或者在失败时返回 false。


Retrieve Solr Server information

  • ? SolrClient::setServlet
  • SolrClient::threads ?
  • PHP Manual
  • SolrClient
  • Retrieve Solr Server information

SolrClient::system

(PECL solr >= 2.0.0)

SolrClient::system — Retrieve Solr Server information

说明

public SolrClient::system ( ) : void

Retrieve Solr Server information

参数

此函数没有参数。

返回值

Returns a SolrGenericResponse object on success.

错误／异常

Emits SolrClientException if the client failed, or there was a connection issue.

Emits SolrServerException if the Solr Server failed to satisfy the query.


Checks the threads status

  • ? SolrClient::system
  • SolrResponse ?
  • PHP Manual
  • SolrClient
  • Checks the threads status

SolrClient::threads

(PECL solr >= 0.9.2)

SolrClient::threads — Checks the threads status

说明

public SolrClient::threads ( ) : void

Checks the threads status

参数

此函数没有参数。

返回值

Returns a SolrGenericResponse object.

错误／异常

Throws SolrClientException if the client failed, or there was a connection issue.

throws SolrServerException if the Solr Server failed to process the request.


The SolrResponse class

(PECL solr >= 0.9.2)

简介

Represents a response from the Solr server.

类摘要

abstract SolrResponse {
/* 常量 */
const int PARSE_SOLR_OBJ = 0 ;
const int PARSE_SOLR_DOC = 1 ;
/* 属性 */
protected int $http_status ;
protected int $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* 方法 */
public getDigestedResponse ( ) : string
public getHttpStatus ( ) : int
public getHttpStatusMessage ( ) : string
public getRawRequest ( ) : string
public getRawRequestHeaders ( ) : string
public getRawResponse ( ) : string
public getRawResponseHeaders ( ) : string
public getRequestUrl ( ) : string
public getResponse ( ) : SolrObject
public setParseMode ( int $parser_mode = 0 ) : bool
public success ( ) : bool
}

属性

http_status

The http status of the response.

parser_mode

Whether to parse the solr documents as SolrObject or SolrDocument instances.

success

Was there an error during the request

http_status_message

Detailed message on http status

http_request_url

The request URL

http_raw_request_headers

A string of raw headers sent during the request.

http_raw_request

The raw request sent to the server

http_raw_response_headers

Response headers from the Solr server.

http_raw_response

The response message from the server.

http_digested_response

The response in PHP serialized format.

预定义常量

SolrResponse Class Constants

SolrResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

Table of Contents

  • SolrResponse::getDigestedResponse — Returns the XML response as serialized PHP data
  • SolrResponse::getHttpStatus — Returns the HTTP status of the response
  • SolrResponse::getHttpStatusMessage — Returns more details on the HTTP status
  • SolrResponse::getRawRequest — Returns the raw request sent to the Solr server
  • SolrResponse::getRawRequestHeaders — Returns the raw request headers sent to the Solr server
  • SolrResponse::getRawResponse — Returns the raw response from the server
  • SolrResponse::getRawResponseHeaders — Returns the raw response headers from the server
  • SolrResponse::getRequestUrl — Returns the full URL the request was sent to
  • SolrResponse::getResponse — Returns a SolrObject representing the XML response from the server
  • SolrResponse::setParseMode — Sets the parse mode
  • SolrResponse::success — Was the request a success


Returns the XML response as serialized PHP data

  • ? SolrResponse
  • SolrResponse::getHttpStatus ?
  • PHP Manual
  • SolrResponse
  • Returns the XML response as serialized PHP data

SolrResponse::getDigestedResponse

(PECL solr >= 0.9.2)

SolrResponse::getDigestedResponse — Returns the XML response as serialized PHP data

说明

public SolrResponse::getDigestedResponse ( ) : string

Returns the XML response as serialized PHP data

参数

此函数没有参数。

返回值

Returns the XML response as serialized PHP data


Returns the HTTP status of the response

  • ? SolrResponse::getDigestedResponse
  • SolrResponse::getHttpStatusMessage ?
  • PHP Manual
  • SolrResponse
  • Returns the HTTP status of the response

SolrResponse::getHttpStatus

(PECL solr >= 0.9.2)

SolrResponse::getHttpStatus — Returns the HTTP status of the response

说明

public SolrResponse::getHttpStatus ( ) : int

Returns the HTTP status of the response.

参数

此函数没有参数。

返回值

Returns the HTTP status of the response.


Returns more details on the HTTP status

  • ? SolrResponse::getHttpStatus
  • SolrResponse::getRawRequest ?
  • PHP Manual
  • SolrResponse
  • Returns more details on the HTTP status

SolrResponse::getHttpStatusMessage

(PECL solr >= 0.9.2)

SolrResponse::getHttpStatusMessage — Returns more details on the HTTP status

说明

public SolrResponse::getHttpStatusMessage ( ) : string

Returns more details on the HTTP status.

参数

此函数没有参数。

返回值

Returns more details on the HTTP status


Returns the raw request sent to the Solr server

  • ? SolrResponse::getHttpStatusMessage
  • SolrResponse::getRawRequestHeaders ?
  • PHP Manual
  • SolrResponse
  • Returns the raw request sent to the Solr server

SolrResponse::getRawRequest

(PECL solr >= 0.9.2)

SolrResponse::getRawRequest — Returns the raw request sent to the Solr server

说明

public SolrResponse::getRawRequest ( ) : string

Returns the raw request sent to the Solr server.

参数

此函数没有参数。

返回值

Returns the raw request sent to the Solr server


Returns the raw request headers sent to the Solr server

  • ? SolrResponse::getRawRequest
  • SolrResponse::getRawResponse ?
  • PHP Manual
  • SolrResponse
  • Returns the raw request headers sent to the Solr server

SolrResponse::getRawRequestHeaders

(PECL solr >= 0.9.2)

SolrResponse::getRawRequestHeaders — Returns the raw request headers sent to the Solr server

说明

public SolrResponse::getRawRequestHeaders ( ) : string

Returns the raw request headers sent to the Solr server.

参数

此函数没有参数。

返回值

Returns the raw request headers sent to the Solr server


Returns the raw response from the server

  • ? SolrResponse::getRawRequestHeaders
  • SolrResponse::getRawResponseHeaders ?
  • PHP Manual
  • SolrResponse
  • Returns the raw response from the server

SolrResponse::getRawResponse

(PECL solr >= 0.9.2)

SolrResponse::getRawResponse — Returns the raw response from the server

说明

public SolrResponse::getRawResponse ( ) : string

Returns the raw response from the server.

参数

此函数没有参数。

返回值

Returns the raw response from the server.


Returns the raw response headers from the server

  • ? SolrResponse::getRawResponse
  • SolrResponse::getRequestUrl ?
  • PHP Manual
  • SolrResponse
  • Returns the raw response headers from the server

SolrResponse::getRawResponseHeaders

(PECL solr >= 0.9.2)

SolrResponse::getRawResponseHeaders — Returns the raw response headers from the server

说明

public SolrResponse::getRawResponseHeaders ( ) : string

Returns the raw response headers from the server.

参数

此函数没有参数。

返回值

Returns the raw response headers from the server.


Returns the full URL the request was sent to

  • ? SolrResponse::getRawResponseHeaders
  • SolrResponse::getResponse ?
  • PHP Manual
  • SolrResponse
  • Returns the full URL the request was sent to

SolrResponse::getRequestUrl

(PECL solr >= 0.9.2)

SolrResponse::getRequestUrl — Returns the full URL the request was sent to

说明

public SolrResponse::getRequestUrl ( ) : string

Returns the full URL the request was sent to.

参数

此函数没有参数。

返回值

Returns the full URL the request was sent to


Returns a SolrObject representing the XML response from the server

  • ? SolrResponse::getRequestUrl
  • SolrResponse::setParseMode ?
  • PHP Manual
  • SolrResponse
  • Returns a SolrObject representing the XML response from the server

SolrResponse::getResponse

(PECL solr >= 0.9.2)

SolrResponse::getResponse — Returns a SolrObject representing the XML response from the server

说明

public SolrResponse::getResponse ( ) : SolrObject

Returns a SolrObject representing the XML response from the server.

参数

此函数没有参数。

返回值

Returns a SolrObject representing the XML response from the server


Sets the parse mode

  • ? SolrResponse::getResponse
  • SolrResponse::success ?
  • PHP Manual
  • SolrResponse
  • Sets the parse mode

SolrResponse::setParseMode

(PECL solr >= 0.9.2)

SolrResponse::setParseMode — Sets the parse mode

说明

public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool

Sets the parse mode.

参数

parser_mode

SolrResponse::PARSE_SOLR_DOC parses documents in SolrDocument instances. SolrResponse::PARSE_SOLR_OBJ parses document into SolrObjects.

返回值

成功时返回 true， 或者在失败时返回 false。


Was the request a success

  • ? SolrResponse::setParseMode
  • SolrQueryResponse ?
  • PHP Manual
  • SolrResponse
  • Was the request a success

SolrResponse::success

(PECL solr >= 0.9.2)

SolrResponse::success — Was the request a success

说明

public SolrResponse::success ( ) : bool

Used to check if the request to the server was successful.

参数

此函数没有参数。

返回值

Returns true if it was successful and false if it was not.


The SolrQueryResponse class

(PECL solr >= 0.9.2)

简介

Represents a response to a query request.

类摘要

final SolrQueryResponse extends SolrResponse {
/* 常量 */
const int PARSE_SOLR_OBJ = 0 ;
const int PARSE_SOLR_DOC = 1 ;
/* 继承的属性 */
const int SolrResponse::PARSE_SOLR_OBJ = 0 ;
const int SolrResponse::PARSE_SOLR_DOC = 1 ;
protected int $http_status ;
protected int $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* 方法 */
public __construct ( )
public __destruct ( ) : void
/* 继承的方法 */
public SolrResponse::getDigestedResponse ( ) : string
public SolrResponse::getHttpStatus ( ) : int
public SolrResponse::getHttpStatusMessage ( ) : string
public SolrResponse::getRawRequest ( ) : string
public SolrResponse::getRawRequestHeaders ( ) : string
public SolrResponse::getRawResponse ( ) : string
public SolrResponse::getRawResponseHeaders ( ) : string
public SolrResponse::getRequestUrl ( ) : string
public SolrResponse::getResponse ( ) : SolrObject
public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool
public SolrResponse::success ( ) : bool
}

预定义常量

SolrQueryResponse Class constants

SolrQueryResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrQueryResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

Table of Contents

  • SolrQueryResponse::__construct — Constructor
  • SolrQueryResponse::__destruct — Destructor


Constructor

  • ? SolrQueryResponse
  • SolrQueryResponse::__destruct ?
  • PHP Manual
  • SolrQueryResponse
  • Constructor

SolrQueryResponse::__construct

(PECL solr >= 0.9.2)

SolrQueryResponse::__construct — Constructor

说明

public SolrQueryResponse::__construct ( )

Constructor

参数

此函数没有参数。

返回值

None


Destructor

  • ? SolrQueryResponse::__construct
  • SolrUpdateResponse ?
  • PHP Manual
  • SolrQueryResponse
  • Destructor

SolrQueryResponse::__destruct

(PECL solr >= 0.9.2)

SolrQueryResponse::__destruct — Destructor

说明

public SolrQueryResponse::__destruct ( ) : void

Destructor.

参数

此函数没有参数。

返回值

None


The SolrUpdateResponse class

(PECL solr >= 0.9.2)

简介

Represents a response to an update request.

类摘要

final SolrUpdateResponse extends SolrResponse {
/* 常量 */
const int PARSE_SOLR_OBJ = 0 ;
const int PARSE_SOLR_DOC = 1 ;
/* 继承的属性 */
const int SolrResponse::PARSE_SOLR_OBJ = 0 ;
const int SolrResponse::PARSE_SOLR_DOC = 1 ;
protected int $http_status ;
protected int $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* 方法 */
public __construct ( )
public __destruct ( ) : void
/* 继承的方法 */
public SolrResponse::getDigestedResponse ( ) : string
public SolrResponse::getHttpStatus ( ) : int
public SolrResponse::getHttpStatusMessage ( ) : string
public SolrResponse::getRawRequest ( ) : string
public SolrResponse::getRawRequestHeaders ( ) : string
public SolrResponse::getRawResponse ( ) : string
public SolrResponse::getRawResponseHeaders ( ) : string
public SolrResponse::getRequestUrl ( ) : string
public SolrResponse::getResponse ( ) : SolrObject
public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool
public SolrResponse::success ( ) : bool
}

预定义常量

SolrUpdateResponse Class Constants

SolrUpdateResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrUpdateResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

Table of Contents

  • SolrUpdateResponse::__construct — Constructor
  • SolrUpdateResponse::__destruct — Destructor


Constructor

  • ? SolrUpdateResponse
  • SolrUpdateResponse::__destruct ?
  • PHP Manual
  • SolrUpdateResponse
  • Constructor

SolrUpdateResponse::__construct

(PECL solr >= 0.9.2)

SolrUpdateResponse::__construct — Constructor

说明

public SolrUpdateResponse::__construct ( )

Constructor

参数

此函数没有参数。

返回值

None


Destructor

  • ? SolrUpdateResponse::__construct
  • SolrPingResponse ?
  • PHP Manual
  • SolrUpdateResponse
  • Destructor

SolrUpdateResponse::__destruct

(PECL solr >= 0.9.2)

SolrUpdateResponse::__destruct — Destructor

说明

public SolrUpdateResponse::__destruct ( ) : void

Destructor

参数

此函数没有参数。

返回值

None


The SolrPingResponse class

(PECL solr >= 0.9.2)

简介

Represents a response to a ping request to the server

类摘要

final SolrPingResponse extends SolrResponse {
/* 常量 */
const int PARSE_SOLR_OBJ = 0 ;
const int PARSE_SOLR_DOC = 1 ;
/* 属性 */
/* 方法 */
public __construct ( )
public __destruct ( ) : void
public getResponse ( ) : string
/* 继承的方法 */
public SolrResponse::getDigestedResponse ( ) : string
public SolrResponse::getHttpStatus ( ) : int
public SolrResponse::getHttpStatusMessage ( ) : string
public SolrResponse::getRawRequest ( ) : string
public SolrResponse::getRawRequestHeaders ( ) : string
public SolrResponse::getRawResponse ( ) : string
public SolrResponse::getRawResponseHeaders ( ) : string
public SolrResponse::getRequestUrl ( ) : string
public SolrResponse::getResponse ( ) : SolrObject
public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool
public SolrResponse::success ( ) : bool
}

属性

http_status

The http status of the response.

parser_mode

Whether to parse the solr documents as SolrObject or SolrDocument instances.

success

Was there an error during the request

http_status_message

Detailed message on http status

http_request_url

The request URL

http_raw_request_headers

A string of raw headers sent during the request

http_raw_request

The raw request sent to the server

http_raw_response_headers

Response headers from the Solr server

http_raw_response

The response message from the server

http_digested_response

The response in PHP serialized format.

预定义常量

SolrPingResponse Class Constants

SolrPingResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrPingResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

Table of Contents

  • SolrPingResponse::__construct — Constructor
  • SolrPingResponse::__destruct — Destructor
  • SolrPingResponse::getResponse — Returns the response from the server


Constructor

  • ? SolrPingResponse
  • SolrPingResponse::__destruct ?
  • PHP Manual
  • SolrPingResponse
  • Constructor

SolrPingResponse::__construct

(PECL solr >= 0.9.2)

SolrPingResponse::__construct — Constructor

说明

public SolrPingResponse::__construct ( )

Constructor

参数

此函数没有参数。

返回值

None


Destructor

  • ? SolrPingResponse::__construct
  • SolrPingResponse::getResponse ?
  • PHP Manual
  • SolrPingResponse
  • Destructor

SolrPingResponse::__destruct

(PECL solr >= 0.9.2)

SolrPingResponse::__destruct — Destructor

说明

public SolrPingResponse::__destruct ( ) : void

Destructor

参数

此函数没有参数。

返回值

None


Returns the response from the server

  • ? SolrPingResponse::__destruct
  • SolrGenericResponse ?
  • PHP Manual
  • SolrPingResponse
  • Returns the response from the server

SolrPingResponse::getResponse

(PECL solr >= 0.9.2)

SolrPingResponse::getResponse — Returns the response from the server

说明

public SolrPingResponse::getResponse ( ) : string

Returns the response from the server. This should be empty because the request as a HEAD request.

参数

此函数没有参数。

返回值

Returns an empty string.


The SolrGenericResponse class

(PECL solr >= 0.9.2)

简介

Represents a response from the solr server.

类摘要

final SolrGenericResponse extends SolrResponse {
/* 常量 */
const int PARSE_SOLR_OBJ = 0 ;
const int PARSE_SOLR_DOC = 1 ;
/* 继承的属性 */
const int SolrResponse::PARSE_SOLR_OBJ = 0 ;
const int SolrResponse::PARSE_SOLR_DOC = 1 ;
protected int $http_status ;
protected int $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* 方法 */
public __construct ( )
public __destruct ( ) : void
/* 继承的方法 */
public SolrResponse::getDigestedResponse ( ) : string
public SolrResponse::getHttpStatus ( ) : int
public SolrResponse::getHttpStatusMessage ( ) : string
public SolrResponse::getRawRequest ( ) : string
public SolrResponse::getRawRequestHeaders ( ) : string
public SolrResponse::getRawResponse ( ) : string
public SolrResponse::getRawResponseHeaders ( ) : string
public SolrResponse::getRequestUrl ( ) : string
public SolrResponse::getResponse ( ) : SolrObject
public SolrResponse::setParseMode ( int $parser_mode = 0 ) : bool
public SolrResponse::success ( ) : bool
}

预定义常量

SolrGenericResponse Class constants

SolrGenericResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrGenericResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

Table of Contents

  • SolrGenericResponse::__construct — Constructor
  • SolrGenericResponse::__destruct — Destructor


Constructor

  • ? SolrGenericResponse
  • SolrGenericResponse::__destruct ?
  • PHP Manual
  • SolrGenericResponse
  • Constructor

SolrGenericResponse::__construct

(PECL solr >= 0.9.2)

SolrGenericResponse::__construct — Constructor

说明

public SolrGenericResponse::__construct ( )

Constructor

参数

此函数没有参数。

返回值

None


Destructor

  • ? SolrGenericResponse::__construct
  • SolrParams ?
  • PHP Manual
  • SolrGenericResponse
  • Destructor

SolrGenericResponse::__destruct

(PECL solr >= 0.9.2)

SolrGenericResponse::__destruct — Destructor

说明

public SolrGenericResponse::__destruct ( ) : void

Destructor.

参数

此函数没有参数。

返回值

None


The SolrParams class

(PECL solr >= 0.9.2)

简介

Represents a collection of name-value pairs sent to the Solr server during a request.

类摘要

abstract SolrParams implements Serializable {
/* 方法 */
final public add ( string $name , string $value ) : SolrParams
public addParam ( string $name , string $value ) : SolrParams
final public get ( string $param_name ) : mixed
final public getParam ( string $param_name = ? ) : mixed
final public getParams ( ) : array
final public getPreparedParams ( ) : array
final public serialize ( ) : string
final public set ( string $name , string $value ) : void
public setParam ( string $name , string $value ) : SolrParams
final public toString ( bool $url_encode = false ) : string
final public unserialize ( string $serialized ) : void
}

Table of Contents

  • SolrParams::add — This is an alias for SolrParams::addParam
  • SolrParams::addParam — Adds a parameter to the object
  • SolrParams::get — This is an alias for SolrParams::getParam
  • SolrParams::getParam — Returns a parameter value
  • SolrParams::getParams — Returns an array of non URL-encoded parameters
  • SolrParams::getPreparedParams — Returns an array of URL-encoded parameters
  • SolrParams::serialize — Used for custom serialization
  • SolrParams::set — An alias of SolrParams::setParam
  • SolrParams::setParam — Sets the parameter to the specified value
  • SolrParams::toString — Returns all the name-value pair parameters in the object
  • SolrParams::unserialize — Used for custom serialization


This is an alias for SolrParams::addParam

  • ? SolrParams
  • SolrParams::addParam ?
  • PHP Manual
  • SolrParams
  • This is an alias for SolrParams::addParam

SolrParams::add

(PECL solr >= 0.9.2)

SolrParams::add — This is an alias for SolrParams::addParam

说明

final public SolrParams::add ( string $name , string $value ) : SolrParams

This is an alias for SolrParams::addParam

参数

name

The name of the parameter

value

The value of the parameter

返回值

Returns a SolrParams instance on success


Adds a parameter to the object

  • ? SolrParams::add
  • SolrParams::get ?
  • PHP Manual
  • SolrParams
  • Adds a parameter to the object

SolrParams::addParam

(PECL solr >= 0.9.2)

SolrParams::addParam — Adds a parameter to the object

说明

public SolrParams::addParam ( string $name , string $value ) : SolrParams

Adds a parameter to the object. This is used for parameters that can be specified multiple times.

参数

name

Name of parameter

value

Value of parameter

返回值

Returns a SolrParam object on success and false on failure.


This is an alias for SolrParams::getParam

  • ? SolrParams::addParam
  • SolrParams::getParam ?
  • PHP Manual
  • SolrParams
  • This is an alias for SolrParams::getParam

SolrParams::get

(PECL solr >= 0.9.2)

SolrParams::get — This is an alias for SolrParams::getParam

说明

final public SolrParams::get ( string $param_name ) : mixed

This is an alias for SolrParams::getParam

参数

param_name

Then name of the parameter

返回值

Returns an array or string depending on the type of parameter


Returns a parameter value

  • ? SolrParams::get
  • SolrParams::getParams ?
  • PHP Manual
  • SolrParams
  • Returns a parameter value

SolrParams::getParam

(PECL solr >= 0.9.2)

SolrParams::getParam — Returns a parameter value

说明

final public SolrParams::getParam ( string $param_name = ? ) : mixed

Returns a parameter with name param_name

参数

param_name

The name of the parameter

返回值

Returns a string or an array depending on the type of the parameter


Returns an array of non URL-encoded parameters

  • ? SolrParams::getParam
  • SolrParams::getPreparedParams ?
  • PHP Manual
  • SolrParams
  • Returns an array of non URL-encoded parameters

SolrParams::getParams

(PECL solr >= 0.9.2)

SolrParams::getParams — Returns an array of non URL-encoded parameters

说明

final public SolrParams::getParams ( ) : array

Returns an array of non URL-encoded parameters

参数

此函数没有参数。

返回值

Returns an array of non URL-encoded parameters


Returns an array of URL-encoded parameters

  • ? SolrParams::getParams
  • SolrParams::serialize ?
  • PHP Manual
  • SolrParams
  • Returns an array of URL-encoded parameters

SolrParams::getPreparedParams

(PECL solr >= 0.9.2)

SolrParams::getPreparedParams — Returns an array of URL-encoded parameters

说明

final public SolrParams::getPreparedParams ( ) : array

Returns an array on URL-encoded parameters

参数

此函数没有参数。

返回值

Returns an array on URL-encoded parameters


Used for custom serialization

  • ? SolrParams::getPreparedParams
  • SolrParams::set ?
  • PHP Manual
  • SolrParams
  • Used for custom serialization

SolrParams::serialize

(PECL solr >= 0.9.2)

SolrParams::serialize — Used for custom serialization

说明

final public SolrParams::serialize ( ) : string

Used for custom serialization

参数

此函数没有参数。

返回值

Used for custom serialization


An alias of SolrParams::setParam

  • ? SolrParams::serialize
  • SolrParams::setParam ?
  • PHP Manual
  • SolrParams
  • An alias of SolrParams::setParam

SolrParams::set

(PECL solr >= 0.9.2)

SolrParams::set — An alias of SolrParams::setParam

说明

final public SolrParams::set ( string $name , string $value ) : void

An alias of SolrParams::setParam

参数

name

Then name of the parameter

value

The parameter value

返回值

Returns an instance of the SolrParams object on success


Sets the parameter to the specified value

  • ? SolrParams::set
  • SolrParams::toString ?
  • PHP Manual
  • SolrParams
  • Sets the parameter to the specified value

SolrParams::setParam

(PECL solr >= 0.9.2)

SolrParams::setParam — Sets the parameter to the specified value

说明

public SolrParams::setParam ( string $name , string $value ) : SolrParams

Sets the query parameter to the specified value. This is used for parameters that can only be specified once. Subsequent calls with the same parameter name will override the existing value

参数

name

Name of the parameter

value

Value of the parameter

返回值

Returns a SolrParam object on success and false on value.

范例

Example #1 SolrParams::setParam() example

<?php

$param = new SolrParams();

$param->setParam('q', 'solr')->setParam('rows', 2);

?>

以上例程的输出类似于：


Returns all the name-value pair parameters in the object

  • ? SolrParams::setParam
  • SolrParams::unserialize ?
  • PHP Manual
  • SolrParams
  • Returns all the name-value pair parameters in the object

SolrParams::toString

(PECL solr >= 0.9.2)

SolrParams::toString — Returns all the name-value pair parameters in the object

说明

final public SolrParams::toString ( bool $url_encode = false ) : string

Returns all the name-value pair parameters in the object

参数

url_encode

Whether to return URL-encoded values

返回值

Returns a string on success and false on failure.


Used for custom serialization

  • ? SolrParams::toString
  • SolrModifiableParams ?
  • PHP Manual
  • SolrParams
  • Used for custom serialization

SolrParams::unserialize

(PECL solr >= 0.9.2)

SolrParams::unserialize — Used for custom serialization

说明

final public SolrParams::unserialize ( string $serialized ) : void

Used for custom serialization

参数

serialized

The serialized representation of the object

返回值

None


The SolrModifiableParams class

(PECL solr >= 0.9.2)

简介

Represents a collection of name-value pairs sent to the Solr server during a request.

类摘要

SolrModifiableParams extends SolrParams implements Serializable {
/* 方法 */
public __construct ( )
public __destruct ( ) : void
/* 继承的方法 */
final public SolrParams::add ( string $name , string $value ) : SolrParams
public SolrParams::addParam ( string $name , string $value ) : SolrParams
final public SolrParams::get ( string $param_name ) : mixed
final public SolrParams::getParam ( string $param_name = ? ) : mixed
final public SolrParams::getParams ( ) : array
final public SolrParams::getPreparedParams ( ) : array
final public SolrParams::serialize ( ) : string
final public SolrParams::set ( string $name , string $value ) : void
public SolrParams::setParam ( string $name , string $value ) : SolrParams
final public SolrParams::toString ( bool $url_encode = false ) : string
final public SolrParams::unserialize ( string $serialized ) : void
}

Table of Contents

  • SolrModifiableParams::__construct — Constructor
  • SolrModifiableParams::__destruct — Destructor


Constructor

  • ? SolrModifiableParams
  • SolrModifiableParams::__destruct ?
  • PHP Manual
  • SolrModifiableParams
  • Constructor

SolrModifiableParams::__construct

(PECL solr >= 0.9.2)

SolrModifiableParams::__construct — Constructor

说明

public SolrModifiableParams::__construct ( )

Constructor

参数

此函数没有参数。

返回值

None


Destructor

  • ? SolrModifiableParams::__construct
  • SolrQuery ?
  • PHP Manual
  • SolrModifiableParams
  • Destructor

SolrModifiableParams::__destruct

(PECL solr >= 0.9.2)

SolrModifiableParams::__destruct — Destructor

说明

public SolrModifiableParams::__destruct ( ) : void

Destructor

参数

此函数没有参数。

返回值

None


The SolrQuery class

(PECL solr >= 0.9.2)

简介

Represents a collection of name-value pairs sent to the Solr server during a request.

类摘要

SolrQuery extends SolrModifiableParams implements Serializable {
/* 常量 */
const int ORDER_ASC = 0 ;
const int ORDER_DESC = 1 ;
const int FACET_SORT_INDEX = 0 ;
const int FACET_SORT_COUNT = 1 ;
const int TERMS_SORT_INDEX = 0 ;
const int TERMS_SORT_COUNT = 1 ;
/* 属性 */
/* 方法 */
public addExpandFilterQuery ( string $fq ) : SolrQuery
public addExpandSortField ( string $field , string $order = ? ) : SolrQuery
public addFacetDateField ( string $dateField ) : SolrQuery
public addFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery
public addFacetField ( string $field ) : SolrQuery
public addFacetQuery ( string $facetQuery ) : SolrQuery
public addField ( string $field ) : SolrQuery
public addFilterQuery ( string $fq ) : SolrQuery
public addGroupField ( string $value ) : SolrQuery
public addGroupFunction ( string $value ) : SolrQuery
public addGroupQuery ( string $value ) : SolrQuery
public addGroupSortField ( string $field , int $order = ? ) : SolrQuery
public addHighlightField ( string $field ) : SolrQuery
public addMltField ( string $field ) : SolrQuery
public addMltQueryField ( string $field , float $boost ) : SolrQuery
public addSortField ( string $field , int $order = SolrQuery::ORDER_DESC ) : SolrQuery
public addStatsFacet ( string $field ) : SolrQuery
public addStatsField ( string $field ) : SolrQuery
public collapse ( SolrCollapseFunction $collapseFunction ) : SolrQuery
public __construct ( string $q = ? )
public __destruct ( ) : void
public getExpand ( ) : bool
public getExpandFilterQueries ( ) : array
public getExpandQuery ( ) : array
public getExpandRows ( ) : int
public getExpandSortFields ( ) : array
public getFacet ( ) : bool
public getFacetDateEnd ( string $field_override = ? ) : string
public getFacetDateFields ( ) : array
public getFacetDateGap ( string $field_override = ? ) : string
public getFacetDateHardEnd ( string $field_override = ? ) : string
public getFacetDateOther ( string $field_override = ? ) : array
public getFacetDateStart ( string $field_override = ? ) : string
public getFacetFields ( ) : array
public getFacetLimit ( string $field_override = ? ) : int
public getFacetMethod ( string $field_override = ? ) : string
public getFacetMinCount ( string $field_override = ? ) : int
public getFacetMissing ( string $field_override = ? ) : bool
public getFacetOffset ( string $field_override = ? ) : int
public getFacetPrefix ( string $field_override = ? ) : string
public getFacetQueries ( ) : array
public getFacetSort ( string $field_override = ? ) : int
public getFields ( ) : array
public getFilterQueries ( ) : array
public getGroup ( ) : bool
public getGroupCachePercent ( ) : int
public getGroupFacet ( ) : bool
public getGroupFields ( ) : array
public getGroupFormat ( ) : string
public getGroupFunctions ( ) : array
public getGroupLimit ( ) : int
public getGroupMain ( ) : bool
public getGroupNGroups ( ) : bool
public getGroupOffset ( ) : int
public getGroupQueries ( ) : array
public getGroupSortFields ( ) : array
public getGroupTruncate ( ) : bool
public getHighlight ( ) : bool
public getHighlightAlternateField ( string $field_override = ? ) : string
public getHighlightFields ( ) : array
public getHighlightFormatter ( string $field_override = ? ) : string
public getHighlightFragmenter ( string $field_override = ? ) : string
public getHighlightFragsize ( string $field_override = ? ) : int
public getHighlightHighlightMultiTerm ( ) : bool
public getHighlightMaxAlternateFieldLength ( string $field_override = ? ) : int
public getHighlightMaxAnalyzedChars ( ) : int
public getHighlightMergeContiguous ( string $field_override = ? ) : bool
public getHighlightRegexMaxAnalyzedChars ( ) : int
public getHighlightRegexPattern ( ) : string
public getHighlightRegexSlop ( ) : float
public getHighlightRequireFieldMatch ( ) : bool
public getHighlightSimplePost ( string $field_override = ? ) : string
public getHighlightSimplePre ( string $field_override = ? ) : string
public getHighlightSnippets ( string $field_override = ? ) : int
public getHighlightUsePhraseHighlighter ( ) : bool
public getMlt ( ) : bool
public getMltBoost ( ) : bool
public getMltCount ( ) : int
public getMltFields ( ) : array
public getMltMaxNumQueryTerms ( ) : int
public getMltMaxNumTokens ( ) : int
public getMltMaxWordLength ( ) : int
public getMltMinDocFrequency ( ) : int
public getMltMinTermFrequency ( ) : int
public getMltMinWordLength ( ) : int
public getMltQueryFields ( ) : array
public getQuery ( ) : string
public getRows ( ) : int
public getSortFields ( ) : array
public getStart ( ) : int
public getStats ( ) : bool
public getStatsFacets ( ) : array
public getStatsFields ( ) : array
public getTerms ( ) : bool
public getTermsField ( ) : string
public getTermsIncludeLowerBound ( ) : bool
public getTermsIncludeUpperBound ( ) : bool
public getTermsLimit ( ) : int
public getTermsLowerBound ( ) : string
public getTermsMaxCount ( ) : int
public getTermsMinCount ( ) : int
public getTermsPrefix ( ) : string
public getTermsReturnRaw ( ) : bool
public getTermsSort ( ) : int
public getTermsUpperBound ( ) : string
public getTimeAllowed ( ) : int
public removeExpandFilterQuery ( string $fq ) : SolrQuery
public removeExpandSortField ( string $field ) : SolrQuery
public removeFacetDateField ( string $field ) : SolrQuery
public removeFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery
public removeFacetField ( string $field ) : SolrQuery
public removeFacetQuery ( string $value ) : SolrQuery
public removeField ( string $field ) : SolrQuery
public removeFilterQuery ( string $fq ) : SolrQuery
public removeHighlightField ( string $field ) : SolrQuery
public removeMltField ( string $field ) : SolrQuery
public removeMltQueryField ( string $queryField ) : SolrQuery
public removeSortField ( string $field ) : SolrQuery
public removeStatsFacet ( string $value ) : SolrQuery
public removeStatsField ( string $field ) : SolrQuery
public setEchoHandler ( bool $flag ) : SolrQuery
public setEchoParams ( string $type ) : SolrQuery
public setExpand ( bool $value ) : SolrQuery
public setExpandQuery ( string $q ) : SolrQuery
public setExpandRows ( int $value ) : SolrQuery
public setExplainOther ( string $query ) : SolrQuery
public setFacet ( bool $flag ) : SolrQuery
public setFacetDateEnd ( string $value , string $field_override = ? ) : SolrQuery
public setFacetDateGap ( string $value , string $field_override = ? ) : SolrQuery
public setFacetDateHardEnd ( bool $value , string $field_override = ? ) : SolrQuery
public setFacetDateStart ( string $value , string $field_override = ? ) : SolrQuery
public setFacetEnumCacheMinDefaultFrequency ( int $frequency , string $field_override = ? ) : SolrQuery
public setFacetLimit ( int $limit , string $field_override = ? ) : SolrQuery
public setFacetMethod ( string $method , string $field_override = ? ) : SolrQuery
public setFacetMinCount ( int $mincount , string $field_override = ? ) : SolrQuery
public setFacetMissing ( bool $flag , string $field_override = ? ) : SolrQuery
public setFacetOffset ( int $offset , string $field_override = ? ) : SolrQuery
public setFacetPrefix ( string $prefix , string $field_override = ? ) : SolrQuery
public setFacetSort ( int $facetSort , string $field_override = ? ) : SolrQuery
public setGroup ( bool $value ) : SolrQuery
public setGroupCachePercent ( int $percent ) : SolrQuery
public setGroupFacet ( bool $value ) : SolrQuery
public setGroupFormat ( string $value ) : SolrQuery
public setGroupLimit ( int $value ) : SolrQuery
public setGroupMain ( string $value ) : SolrQuery
public setGroupNGroups ( bool $value ) : SolrQuery
public setGroupOffset ( int $value ) : SolrQuery
public setGroupTruncate ( bool $value ) : SolrQuery
public setHighlight ( bool $flag ) : SolrQuery
public setHighlightAlternateField ( string $field , string $field_override = ? ) : SolrQuery
public setHighlightFormatter ( string $formatter , string $field_override = ? ) : SolrQuery
public setHighlightFragmenter ( string $fragmenter , string $field_override = ? ) : SolrQuery
public setHighlightFragsize ( int $size , string $field_override = ? ) : SolrQuery
public setHighlightHighlightMultiTerm ( bool $flag ) : SolrQuery
public setHighlightMaxAlternateFieldLength ( int $fieldLength , string $field_override = ? ) : SolrQuery
public setHighlightMaxAnalyzedChars ( int $value ) : SolrQuery
public setHighlightMergeContiguous ( bool $flag , string $field_override = ? ) : SolrQuery
public setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars ) : SolrQuery
public setHighlightRegexPattern ( string $value ) : SolrQuery
public setHighlightRegexSlop ( float $factor ) : SolrQuery
public setHighlightRequireFieldMatch ( bool $flag ) : SolrQuery
public setHighlightSimplePost ( string $simplePost , string $field_override = ? ) : SolrQuery
public setHighlightSimplePre ( string $simplePre , string $field_override = ? ) : SolrQuery
public setHighlightSnippets ( int $value , string $field_override = ? ) : SolrQuery
public setHighlightUsePhraseHighlighter ( bool $flag ) : SolrQuery
public setMlt ( bool $flag ) : SolrQuery
public setMltBoost ( bool $flag ) : SolrQuery
public setMltCount ( int $count ) : SolrQuery
public setMltMaxNumQueryTerms ( int $value ) : SolrQuery
public setMltMaxNumTokens ( int $value ) : SolrQuery
public setMltMaxWordLength ( int $maxWordLength ) : SolrQuery
public setMltMinDocFrequency ( int $minDocFrequency ) : SolrQuery
public setMltMinTermFrequency ( int $minTermFrequency ) : SolrQuery
public setMltMinWordLength ( int $minWordLength ) : SolrQuery
public setOmitHeader ( bool $flag ) : SolrQuery
public setQuery ( string $query ) : SolrQuery
public setRows ( int $rows ) : SolrQuery
public setShowDebugInfo ( bool $flag ) : SolrQuery
public setStart ( int $start ) : SolrQuery
public setStats ( bool $flag ) : SolrQuery
public setTerms ( bool $flag ) : SolrQuery
public setTermsField ( string $fieldname ) : SolrQuery
public setTermsIncludeLowerBound ( bool $flag ) : SolrQuery
public setTermsIncludeUpperBound ( bool $flag ) : SolrQuery
public setTermsLimit ( int $limit ) : SolrQuery
public setTermsLowerBound ( string $lowerBound ) : SolrQuery
public setTermsMaxCount ( int $frequency ) : SolrQuery
public setTermsMinCount ( int $frequency ) : SolrQuery
public setTermsPrefix ( string $prefix ) : SolrQuery
public setTermsReturnRaw ( bool $flag ) : SolrQuery
public setTermsSort ( int $sortType ) : SolrQuery
public setTermsUpperBound ( string $upperBound ) : SolrQuery
public setTimeAllowed ( int $timeAllowed ) : SolrQuery
/* 继承的方法 */
public SolrModifiableParams::__construct ( )
public SolrModifiableParams::__destruct ( ) : void
}

预定义常量

SolrQuery::ORDER_ASC

Used to specify that the sorting should be in acending order

SolrQuery::ORDER_DESC

Used to specify that the sorting should be in descending order

SolrQuery::FACET_SORT_INDEX

Used to specify that the facet should sort by index

SolrQuery::FACET_SORT_COUNT

Used to specify that the facet should sort by count

SolrQuery::TERMS_SORT_INDEX

Used in the TermsComponent

SolrQuery::TERMS_SORT_COUNT

Used in the TermsComponent

Table of Contents

  • SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::addFacetDateField — Maps to facet.date
  • SolrQuery::addFacetDateOther — Adds another facet.date.other parameter
  • SolrQuery::addFacetField — Adds another field to the facet
  • SolrQuery::addFacetQuery — Adds a facet query
  • SolrQuery::addField — Specifies which fields to return in the result
  • SolrQuery::addFilterQuery — Specifies a filter query
  • SolrQuery::addGroupField — Add a field to be used to group results
  • SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery — Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter)
  • SolrQuery::addHighlightField — Maps to hl.fl
  • SolrQuery::addMltField — Sets a field to use for similarity
  • SolrQuery::addMltQueryField — Maps to mlt.qf
  • SolrQuery::addSortField — Used to control how the results should be sorted
  • SolrQuery::addStatsFacet — Requests a return of sub results for values within the given facet
  • SolrQuery::addStatsField — Maps to stats.field parameter
  • SolrQuery::collapse — Collapses the result set to a single document per group
  • SolrQuery::__construct — Constructor
  • SolrQuery::__destruct — Destructor
  • SolrQuery::getExpand — Returns true if group expanding is enabled
  • SolrQuery::getExpandFilterQueries — Returns the expand filter queries
  • SolrQuery::getExpandQuery — Returns the expand query expand.q parameter
  • SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)
  • SolrQuery::getExpandSortFields — Returns an array of fields
  • SolrQuery::getFacet — Returns the value of the facet parameter
  • SolrQuery::getFacetDateEnd — Returns the value for the facet.date.end parameter
  • SolrQuery::getFacetDateFields — Returns all the facet.date fields
  • SolrQuery::getFacetDateGap — Returns the value of the facet.date.gap parameter
  • SolrQuery::getFacetDateHardEnd — Returns the value of the facet.date.hardend parameter
  • SolrQuery::getFacetDateOther — Returns the value for the facet.date.other parameter
  • SolrQuery::getFacetDateStart — Returns the lower bound for the first date range for all date faceting on this field
  • SolrQuery::getFacetFields — Returns all the facet fields
  • SolrQuery::getFacetLimit — Returns the maximum number of constraint counts that should be returned for the facet fields
  • SolrQuery::getFacetMethod — Returns the value of the facet.method parameter
  • SolrQuery::getFacetMinCount — Returns the minimum counts for facet fields should be included in the response
  • SolrQuery::getFacetMissing — Returns the current state of the facet.missing parameter
  • SolrQuery::getFacetOffset — Returns an offset into the list of constraints to be used for pagination
  • SolrQuery::getFacetPrefix — Returns the facet prefix
  • SolrQuery::getFacetQueries — Returns all the facet queries
  • SolrQuery::getFacetSort — Returns the facet sort type
  • SolrQuery::getFields — Returns the list of fields that will be returned in the response
  • SolrQuery::getFilterQueries — Returns an array of filter queries
  • SolrQuery::getGroup — Returns true if grouping is enabled
  • SolrQuery::getGroupCachePercent — Returns group cache percent value
  • SolrQuery::getGroupFacet — Returns the group.facet parameter value
  • SolrQuery::getGroupFields — Returns group fields (group.field parameter values)
  • SolrQuery::getGroupFormat — Returns the group.format value
  • SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)
  • SolrQuery::getGroupLimit — Returns the group.limit value
  • SolrQuery::getGroupMain — Returns the group.main value
  • SolrQuery::getGroupNGroups — Returns the group.ngroups value
  • SolrQuery::getGroupOffset — Returns the group.offset value
  • SolrQuery::getGroupQueries — Returns all the group.query parameter values
  • SolrQuery::getGroupSortFields — Returns the group.sort value
  • SolrQuery::getGroupTruncate — Returns the group.truncate value
  • SolrQuery::getHighlight — Returns the state of the hl parameter
  • SolrQuery::getHighlightAlternateField — Returns the highlight field to use as backup or default
  • SolrQuery::getHighlightFields — Returns all the fields that Solr should generate highlighted snippets for
  • SolrQuery::getHighlightFormatter — Returns the formatter for the highlighted output
  • SolrQuery::getHighlightFragmenter — Returns the text snippet generator for highlighted text
  • SolrQuery::getHighlightFragsize — Returns the number of characters of fragments to consider for highlighting
  • SolrQuery::getHighlightHighlightMultiTerm — Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries
  • SolrQuery::getHighlightMaxAlternateFieldLength — Returns the maximum number of characters of the field to return
  • SolrQuery::getHighlightMaxAnalyzedChars — Returns the maximum number of characters into a document to look for suitable snippets
  • SolrQuery::getHighlightMergeContiguous — Returns whether or not the collapse contiguous fragments into a single fragment
  • SolrQuery::getHighlightRegexMaxAnalyzedChars — Returns the maximum number of characters from a field when using the regex fragmenter
  • SolrQuery::getHighlightRegexPattern — Returns the regular expression for fragmenting
  • SolrQuery::getHighlightRegexSlop — Returns the deviation factor from the ideal fragment size
  • SolrQuery::getHighlightRequireFieldMatch — Returns if a field will only be highlighted if the query matched in this particular field
  • SolrQuery::getHighlightSimplePost — Returns the text which appears after a highlighted term
  • SolrQuery::getHighlightSimplePre — Returns the text which appears before a highlighted term
  • SolrQuery::getHighlightSnippets — Returns the maximum number of highlighted snippets to generate per field
  • SolrQuery::getHighlightUsePhraseHighlighter — Returns the state of the hl.usePhraseHighlighter parameter
  • SolrQuery::getMlt — Returns whether or not MoreLikeThis results should be enabled
  • SolrQuery::getMltBoost — Returns whether or not the query will be boosted by the interesting term relevance
  • SolrQuery::getMltCount — Returns the number of similar documents to return for each result
  • SolrQuery::getMltFields — Returns all the fields to use for similarity
  • SolrQuery::getMltMaxNumQueryTerms — Returns the maximum number of query terms that will be included in any generated query
  • SolrQuery::getMltMaxNumTokens — Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support
  • SolrQuery::getMltMaxWordLength — Returns the maximum word length above which words will be ignored
  • SolrQuery::getMltMinDocFrequency — Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs
  • SolrQuery::getMltMinTermFrequency — Returns the frequency below which terms will be ignored in the source document
  • SolrQuery::getMltMinWordLength — Returns the minimum word length below which words will be ignored
  • SolrQuery::getMltQueryFields — Returns the query fields and their boosts
  • SolrQuery::getQuery — Returns the main query
  • SolrQuery::getRows — Returns the maximum number of documents
  • SolrQuery::getSortFields — Returns all the sort fields
  • SolrQuery::getStart — Returns the offset in the complete result set
  • SolrQuery::getStats — Returns whether or not stats is enabled
  • SolrQuery::getStatsFacets — Returns all the stats facets that were set
  • SolrQuery::getStatsFields — Returns all the statistics fields
  • SolrQuery::getTerms — Returns whether or not the TermsComponent is enabled
  • SolrQuery::getTermsField — Returns the field from which the terms are retrieved
  • SolrQuery::getTermsIncludeLowerBound — Returns whether or not to include the lower bound in the result set
  • SolrQuery::getTermsIncludeUpperBound — Returns whether or not to include the upper bound term in the result set
  • SolrQuery::getTermsLimit — Returns the maximum number of terms Solr should return
  • SolrQuery::getTermsLowerBound — Returns the term to start at
  • SolrQuery::getTermsMaxCount — Returns the maximum document frequency
  • SolrQuery::getTermsMinCount — Returns the minimum document frequency to return in order to be included
  • SolrQuery::getTermsPrefix — Returns the term prefix
  • SolrQuery::getTermsReturnRaw — Whether or not to return raw characters
  • SolrQuery::getTermsSort — Returns an integer indicating how terms are sorted
  • SolrQuery::getTermsUpperBound — Returns the term to stop at
  • SolrQuery::getTimeAllowed — Returns the time in milliseconds allowed for the query to finish
  • SolrQuery::removeExpandFilterQuery — Removes an expand filter query
  • SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter
  • SolrQuery::removeFacetDateField — Removes one of the facet date fields
  • SolrQuery::removeFacetDateOther — Removes one of the facet.date.other parameters
  • SolrQuery::removeFacetField — Removes one of the facet.date parameters
  • SolrQuery::removeFacetQuery — Removes one of the facet.query parameters
  • SolrQuery::removeField — Removes a field from the list of fields
  • SolrQuery::removeFilterQuery — Removes a filter query
  • SolrQuery::removeHighlightField — Removes one of the fields used for highlighting
  • SolrQuery::removeMltField — Removes one of the moreLikeThis fields
  • SolrQuery::removeMltQueryField — Removes one of the moreLikeThis query fields
  • SolrQuery::removeSortField — Removes one of the sort fields
  • SolrQuery::removeStatsFacet — Removes one of the stats.facet parameters
  • SolrQuery::removeStatsField — Removes one of the stats.field parameters
  • SolrQuery::setEchoHandler — Toggles the echoHandler parameter
  • SolrQuery::setEchoParams — Determines what kind of parameters to include in the response
  • SolrQuery::setExpand — Enables/Disables the Expand Component
  • SolrQuery::setExpandQuery — Sets the expand.q parameter
  • SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExplainOther — Sets the explainOther common query parameter
  • SolrQuery::setFacet — Maps to the facet parameter. Enables or disables facetting
  • SolrQuery::setFacetDateEnd — Maps to facet.date.end
  • SolrQuery::setFacetDateGap — Maps to facet.date.gap
  • SolrQuery::setFacetDateHardEnd — Maps to facet.date.hardend
  • SolrQuery::setFacetDateStart — Maps to facet.date.start
  • SolrQuery::setFacetEnumCacheMinDefaultFrequency — Sets the minimum document frequency used for determining term count
  • SolrQuery::setFacetLimit — Maps to facet.limit
  • SolrQuery::setFacetMethod — Specifies the type of algorithm to use when faceting a field
  • SolrQuery::setFacetMinCount — Maps to facet.mincount
  • SolrQuery::setFacetMissing — Maps to facet.missing
  • SolrQuery::setFacetOffset — Sets the offset into the list of constraints to allow for pagination
  • SolrQuery::setFacetPrefix — Specifies a string prefix with which to limits the terms on which to facet
  • SolrQuery::setFacetSort — Determines the ordering of the facet field constraints
  • SolrQuery::setGroup — Enable/Disable result grouping (group parameter)
  • SolrQuery::setGroupCachePercent — Enables caching for result grouping
  • SolrQuery::setGroupFacet — Sets group.facet parameter
  • SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupOffset — Sets the group.offset parameter
  • SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setHighlight — Enables or disables highlighting
  • SolrQuery::setHighlightAlternateField — Specifies the backup field to use
  • SolrQuery::setHighlightFormatter — Specify a formatter for the highlight output
  • SolrQuery::setHighlightFragmenter — Sets a text snippet generator for highlighted text
  • SolrQuery::setHighlightFragsize — The size of fragments to consider for highlighting
  • SolrQuery::setHighlightHighlightMultiTerm — Use SpanScorer to highlight phrase terms
  • SolrQuery::setHighlightMaxAlternateFieldLength — Sets the maximum number of characters of the field to return
  • SolrQuery::setHighlightMaxAnalyzedChars — Specifies the number of characters into a document to look for suitable snippets
  • SolrQuery::setHighlightMergeContiguous — Whether or not to collapse contiguous fragments into a single fragment
  • SolrQuery::setHighlightRegexMaxAnalyzedChars — Specify the maximum number of characters to analyze
  • SolrQuery::setHighlightRegexPattern — Specify the regular expression for fragmenting
  • SolrQuery::setHighlightRegexSlop — Sets the factor by which the regex fragmenter can stray from the ideal fragment size
  • SolrQuery::setHighlightRequireFieldMatch — Require field matching during highlighting
  • SolrQuery::setHighlightSimplePost — Sets the text which appears after a highlighted term
  • SolrQuery::setHighlightSimplePre — Sets the text which appears before a highlighted term
  • SolrQuery::setHighlightSnippets — Sets the maximum number of highlighted snippets to generate per field
  • SolrQuery::setHighlightUsePhraseHighlighter — Whether to highlight phrase terms only when they appear within the query phrase
  • SolrQuery::setMlt — Enables or disables moreLikeThis
  • SolrQuery::setMltBoost — Set if the query will be boosted by the interesting term relevance
  • SolrQuery::setMltCount — Set the number of similar documents to return for each result
  • SolrQuery::setMltMaxNumQueryTerms — Sets the maximum number of query terms included
  • SolrQuery::setMltMaxNumTokens — Specifies the maximum number of tokens to parse
  • SolrQuery::setMltMaxWordLength — Sets the maximum word length
  • SolrQuery::setMltMinDocFrequency — Sets the mltMinDoc frequency
  • SolrQuery::setMltMinTermFrequency — Sets the frequency below which terms will be ignored in the source docs
  • SolrQuery::setMltMinWordLength — Sets the minimum word length
  • SolrQuery::setOmitHeader — Exclude the header from the returned results
  • SolrQuery::setQuery — Sets the search query
  • SolrQuery::setRows — Specifies the maximum number of rows to return in the result
  • SolrQuery::setShowDebugInfo — Flag to show debug information
  • SolrQuery::setStart — Specifies the number of rows to skip
  • SolrQuery::setStats — Enables or disables the Stats component
  • SolrQuery::setTerms — Enables or disables the TermsComponent
  • SolrQuery::setTermsField — Sets the name of the field to get the Terms from
  • SolrQuery::setTermsIncludeLowerBound — Include the lower bound term in the result set
  • SolrQuery::setTermsIncludeUpperBound — Include the upper bound term in the result set
  • SolrQuery::setTermsLimit — Sets the maximum number of terms to return
  • SolrQuery::setTermsLowerBound — Specifies the Term to start from
  • SolrQuery::setTermsMaxCount — Sets the maximum document frequency
  • SolrQuery::setTermsMinCount — Sets the minimum document frequency
  • SolrQuery::setTermsPrefix — Restrict matches to terms that start with the prefix
  • SolrQuery::setTermsReturnRaw — Return the raw characters of the indexed term
  • SolrQuery::setTermsSort — Specifies how to sort the returned terms
  • SolrQuery::setTermsUpperBound — Sets the term to stop at
  • SolrQuery::setTimeAllowed — The time allowed for search to finish


Overrides main filter query, determines which documents to include in the main group

  • ? SolrQuery
  • SolrQuery::addExpandSortField ?
  • PHP Manual
  • SolrQuery
  • Overrides main filter query, determines which documents to include in the main group

SolrQuery::addExpandFilterQuery

(PECL solr >= 2.2.0)

SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group

说明

public SolrQuery::addExpandFilterQuery ( string $fq ) : SolrQuery

Overrides main filter query, determines which documents to include in the main group.

参数

fq

返回值

SolrQuery

参见

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Orders the documents within the expanded groups (expand.sort parameter)

  • ? SolrQuery::addExpandFilterQuery
  • SolrQuery::addFacetDateField ?
  • PHP Manual
  • SolrQuery
  • Orders the documents within the expanded groups (expand.sort parameter)

SolrQuery::addExpandSortField

(PECL solr >= 2.2.0)

SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter)

说明

public SolrQuery::addExpandSortField ( string $field , string $order = ? ) : SolrQuery

Orders the documents within the expanded groups (expand.sort parameter).

参数

field

field name

order

Order ASC/DESC, utilizes SolrQuery::ORDER_* constants.

Default: SolrQuery::ORDER_DESC

返回值

SolrQuery

参见

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Maps to facet.date

  • ? SolrQuery::addExpandSortField
  • SolrQuery::addFacetDateOther ?
  • PHP Manual
  • SolrQuery
  • Maps to facet.date

SolrQuery::addFacetDateField

(PECL solr >= 0.9.2)

SolrQuery::addFacetDateField — Maps to facet.date

说明

public SolrQuery::addFacetDateField ( string $dateField ) : SolrQuery

This method allows you to specify a field which should be treated as a facet.

It can be used multiple times with different field names to indicate multiple facet fields

参数

dateField

The name of the date field.

返回值

Returns a SolrQuery object.


Adds another facet.date.other parameter

  • ? SolrQuery::addFacetDateField
  • SolrQuery::addFacetField ?
  • PHP Manual
  • SolrQuery
  • Adds another facet.date.other parameter

SolrQuery::addFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::addFacetDateOther — Adds another facet.date.other parameter

说明

public SolrQuery::addFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery

Sets the facet.date.other parameter. Accepts an optional field override

参数

value

The value to use.

field_override

The field name for the override.

返回值

Returns the current SolrQuery object, if the return value is used.


Adds another field to the facet

  • ? SolrQuery::addFacetDateOther
  • SolrQuery::addFacetQuery ?
  • PHP Manual
  • SolrQuery
  • Adds another field to the facet

SolrQuery::addFacetField

(PECL solr >= 0.9.2)

SolrQuery::addFacetField — Adds another field to the facet

说明

public SolrQuery::addFacetField ( string $field ) : SolrQuery

Adds another field to the facet

参数

field

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.

范例

Example #1 SolrQuery::addFacetField() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery($query);

$query->addField('price')->addField('color');

$query->setFacet(true);

$query->addFacetField('price')->addFacetField('color');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response['facet_counts']['facet_fields']);

?>

以上例程的输出类似于：

SolrObject Object
(
    [color] => SolrObject Object
        (
            [blue] => 20
            [green] => 100
        )

)


Adds a facet query

  • ? SolrQuery::addFacetField
  • SolrQuery::addField ?
  • PHP Manual
  • SolrQuery
  • Adds a facet query

SolrQuery::addFacetQuery

(PECL solr >= 0.9.2)

SolrQuery::addFacetQuery — Adds a facet query

说明

public SolrQuery::addFacetQuery ( string $facetQuery ) : SolrQuery

Adds a facet query

参数

facetQuery

The facet query

返回值

Returns the current SolrQuery object, if the return value is used.

范例

Example #1 SolrQuery::addFacetField() example

<?php

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetQuery('price:[* TO 500]')->addFacetQuery('price:[500 TO *]');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response->facet_counts->facet_queries);

?>

以上例程的输出类似于：

SolrObject Object
(
    [price:[* TO 500]] => 14
    [price:[500 TO *]] => 2
)


Specifies which fields to return in the result

  • ? SolrQuery::addFacetQuery
  • SolrQuery::addFilterQuery ?
  • PHP Manual
  • SolrQuery
  • Specifies which fields to return in the result

SolrQuery::addField

(PECL solr >= 0.9.2)

SolrQuery::addField — Specifies which fields to return in the result

说明

public SolrQuery::addField ( string $field ) : SolrQuery

This method is used to used to specify a set of fields to return, thereby restricting the amount of data returned in the response.

It should be called multiple time, once for each field name.

参数

field

The name of the field

返回值

Returns the current SolrQuery object


Specifies a filter query

  • ? SolrQuery::addField
  • SolrQuery::addGroupField ?
  • PHP Manual
  • SolrQuery
  • Specifies a filter query

SolrQuery::addFilterQuery

(PECL solr >= 0.9.2)

SolrQuery::addFilterQuery — Specifies a filter query

说明

public SolrQuery::addFilterQuery ( string $fq ) : SolrQuery

Specifies a filter query

参数

fq

The filter query

返回值

Returns the current SolrQuery object.

范例

Example #1 SolrQuery::addFilterQuery() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery('*:*');

$query->addFilterQuery('color:blue,green');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response['facet_counts']['facet_fields']);

?>

以上例程的输出类似于：

 &fq=color:blue,green


Add a field to be used to group results

  • ? SolrQuery::addFilterQuery
  • SolrQuery::addGroupFunction ?
  • PHP Manual
  • SolrQuery
  • Add a field to be used to group results

SolrQuery::addGroupField

(PECL solr >= 2.2.0)

SolrQuery::addGroupField — Add a field to be used to group results

说明

public SolrQuery::addGroupField ( string $value ) : SolrQuery

The name of the field by which to group results. The field must be single-valued, and either be indexed or a field type that has a value source and works in a function query, such as ExternalFileField. It must also be a string-based field, such as StrField or TextField Uses group.field parameter

参数

value

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Allows grouping results based on the unique values of a function query (group.func parameter)

  • ? SolrQuery::addGroupField
  • SolrQuery::addGroupQuery ?
  • PHP Manual
  • SolrQuery
  • Allows grouping results based on the unique values of a function query (group.func parameter)

SolrQuery::addGroupFunction

(PECL solr >= 2.2.0)

SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter)

说明

public SolrQuery::addGroupFunction ( string $value ) : SolrQuery

Adds a group function (group.func parameter) Allows grouping results based on the unique values of a function query.

参数

value

返回值

SolrQuery

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Allows grouping of documents that match the given query

  • ? SolrQuery::addGroupFunction
  • SolrQuery::addGroupSortField ?
  • PHP Manual
  • SolrQuery
  • Allows grouping of documents that match the given query

SolrQuery::addGroupQuery

(PECL solr >= 2.2.0)

SolrQuery::addGroupQuery — Allows grouping of documents that match the given query

说明

public SolrQuery::addGroupQuery ( string $value ) : SolrQuery

Allows grouping of documents that match the given query. Adds query to the group.query parameter

参数

value

返回值

SolrQuery

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Add a group sort field (group.sort parameter)

  • ? SolrQuery::addGroupQuery
  • SolrQuery::addHighlightField ?
  • PHP Manual
  • SolrQuery
  • Add a group sort field (group.sort parameter)

SolrQuery::addGroupSortField

(PECL solr >= 2.2.0)

SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter)

说明

public SolrQuery::addGroupSortField ( string $field , int $order = ? ) : SolrQuery

Allow sorting group documents, using group sort field (group.sort parameter).

参数

field

Field name

order

Order ASC/DESC, utilizes SolrQuery::ORDER_* constants

返回值

范例

Example #1 SolrQuery::addGroupSortField() example

<?php

$solrQuery = new SolrQuery('*:*');
$solrQuery
    ->setGroup(true)
    ->addGroupSortField('price', SolrQuery::ORDER_ASC);

echo $solrQuery;
?>

以上例程的输出类似于：

q=*:*&group=true&group.sort=price asc

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Maps to hl.fl

  • ? SolrQuery::addGroupSortField
  • SolrQuery::addMltField ?
  • PHP Manual
  • SolrQuery
  • Maps to hl.fl

SolrQuery::addHighlightField

(PECL solr >= 0.9.2)

SolrQuery::addHighlightField — Maps to hl.fl

说明

public SolrQuery::addHighlightField ( string $field ) : SolrQuery

Maps to hl.fl. This is used to specify that highlighted snippets should be generated for a particular field

参数

field

Name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Sets a field to use for similarity

  • ? SolrQuery::addHighlightField
  • SolrQuery::addMltQueryField ?
  • PHP Manual
  • SolrQuery
  • Sets a field to use for similarity

SolrQuery::addMltField

(PECL solr >= 0.9.2)

SolrQuery::addMltField — Sets a field to use for similarity

说明

public SolrQuery::addMltField ( string $field ) : SolrQuery

Maps to mlt.fl. It specifies that a field should be used for similarity.

参数

field

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to mlt.qf

  • ? SolrQuery::addMltField
  • SolrQuery::addSortField ?
  • PHP Manual
  • SolrQuery
  • Maps to mlt.qf

SolrQuery::addMltQueryField

(PECL solr >= 0.9.2)

SolrQuery::addMltQueryField — Maps to mlt.qf

说明

public SolrQuery::addMltQueryField ( string $field , float $boost ) : SolrQuery

Maps to mlt.qf. It is used to specify query fields and their boosts

参数

field

The name of the field

boost

Its boost value

返回值

Returns the current SolrQuery object, if the return value is used.


Used to control how the results should be sorted

  • ? SolrQuery::addMltQueryField
  • SolrQuery::addStatsFacet ?
  • PHP Manual
  • SolrQuery
  • Used to control how the results should be sorted

SolrQuery::addSortField

(PECL solr >= 0.9.2)

SolrQuery::addSortField — Used to control how the results should be sorted

说明

public SolrQuery::addSortField ( string $field , int $order = SolrQuery::ORDER_DESC ) : SolrQuery

Used to control how the results should be sorted.

参数

field

The name of the field

order

The sort direction. This should be either SolrQuery::ORDER_ASC or SolrQuery::ORDER_DESC.

返回值

Returns the current SolrQuery object.


Requests a return of sub results for values within the given facet

  • ? SolrQuery::addSortField
  • SolrQuery::addStatsField ?
  • PHP Manual
  • SolrQuery
  • Requests a return of sub results for values within the given facet

SolrQuery::addStatsFacet

(PECL solr >= 0.9.2)

SolrQuery::addStatsFacet — Requests a return of sub results for values within the given facet

说明

public SolrQuery::addStatsFacet ( string $field ) : SolrQuery

Requests a return of sub results for values within the given facet. Maps to the stats.facet field

参数

field

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to stats.field parameter

  • ? SolrQuery::addStatsFacet
  • SolrQuery::collapse ?
  • PHP Manual
  • SolrQuery
  • Maps to stats.field parameter

SolrQuery::addStatsField

(PECL solr >= 0.9.2)

SolrQuery::addStatsField — Maps to stats.field parameter

说明

public SolrQuery::addStatsField ( string $field ) : SolrQuery

Maps to stats.field parameter This methods adds another stats.field parameter.

参数

field

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Collapses the result set to a single document per group

  • ? SolrQuery::addStatsField
  • SolrQuery::__construct ?
  • PHP Manual
  • SolrQuery
  • Collapses the result set to a single document per group

SolrQuery::collapse

(No version information available, might only be in Git)

SolrQuery::collapse — Collapses the result set to a single document per group

说明

public SolrQuery::collapse ( SolrCollapseFunction $collapseFunction ) : SolrQuery

Collapses the result set to a single document per group before it forwards the result set to the rest of the search components.

So all downstream components (faceting, highlighting, etc...) will work with the collapsed result set.

参数

collapseFunction

返回值

Returns the current SolrQuery object

范例

Example #1 SolrQuery::collapse() example

<?php

include "bootstrap.php";

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
        'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$collapseFunction = new SolrCollapseFunction('manu_id_s');

$collapseFunction
->setSize(2)
->setNullPolicy(SolrCollapseFunction::NULLPOLICY_IGNORE);

$query
->collapse($collapseFunction)
->setRows(4);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);

?>

以上例程的输出类似于：

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [q] => *:*
                    [indent] => on
                    [fq] => {!collapse field=manu_id_s size=2 nullPolicy=ignore}
                    [rows] => 4
                    [version] => 2.2
                    [wt] => xml
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 14
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SP2514N
                            [name] => Array
                                (
                                    [0] => Samsung SpinPoint P120 SP2514N - hard drive - 250 GB - ATA-133
                                )

                            [manu] => Array
                                (
                                    [0] => Samsung Electronics Co. Ltd.
                                )

                            [manu_id_s] => samsung
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => 7200RPM, 8MB cache, IDE Ultra ATA-133
                                    [1] => NoiseGuard, SilentSeek technology, Fluid Dynamic Bearing (FDB) motor
                                )

                            [price] => Array
                                (
                                    [0] => 92
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [store] => Array
                                (
                                    [0] => 35.0752,-97.032
                                )

                            [_version_] => 1510294336412057600
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                    [2] => SolrObject Object
                        (
                            [id] => F8V7067-APL-KIT
                            [name] => Array
                                (
                                    [0] => Belkin Mobile Power Cord for iPod w/ Dock
                                )

                            [manu] => Array
                                (
                                    [0] => Belkin
                                )

                            [manu_id_s] => belkin
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => connector
                                )

                            [features] => Array
                                (
                                    [0] => car power adapter, white
                                )

                            [weight] => Array
                                (
                                    [0] => 4
                                )

                            [price] => Array
                                (
                                    [0] => 19.95
                                )

                            [popularity] => Array
                                (
                                    [0] => 1
                                )

                            [inStock] => Array
                                (
                                    [0] =>
                                )

                            [store] => Array
                                (
                                    [0] => 45.18014,-93.87741
                                )

                            [manufacturedate_dt] => 2005-08-01T16:30:25Z
                            [_version_] => 1510294336458194944
                        )

                    [3] => SolrObject Object
                        (
                            [id] => MA147LL/A
                            [name] => Array
                                (
                                    [0] => Apple 60 GB iPod with Video Playback Black
                                )

                            [manu] => Array
                                (
                                    [0] => Apple Computer Inc.
                                )

                            [manu_id_s] => apple
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => music
                                )

                            [features] => Array
                                (
                                    [0] => iTunes, Podcasts, Audiobooks
                                    [1] => Stores up to 15,000 songs, 25,000 photos, or 150 hours of video
                                    [2] => 2.5-inch, 320x240 color TFT LCD display with LED backlight
                                    [3] => Up to 20 hours of battery life
                                    [4] => Plays AAC, MP3, WAV, AIFF, Audible, Apple Lossless, H.264 video
                                    [5] => Notes, Calendar, Phone book, Hold button, Date display, Photo wallet, Built-in games, JPEG photo playback, Upgradeable firmware, USB 2.0 compatibility, Playback speed control, Rechargeable capability, Battery level indication
                                )

                            [includes] => Array
                                (
                                    [0] => earbud headphones, USB cable
                                )

                            [weight] => Array
                                (
                                    [0] => 5.5
                                )

                            [price] => Array
                                (
                                    [0] => 399
                                )

                            [popularity] => Array
                                (
                                    [0] => 10
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 37.7752,-100.0232
                                )

                            [manufacturedate_dt] => 2005-10-12T08:00:00Z
                            [_version_] => 1510294336562003968
                        )

                )

        )

)


Constructor

  • ? SolrQuery::collapse
  • SolrQuery::__destruct ?
  • PHP Manual
  • SolrQuery
  • Constructor

SolrQuery::__construct

(PECL solr >= 0.9.2)

SolrQuery::__construct — Constructor

说明

public SolrQuery::__construct ( string $q = ? )

Constructor.

参数

q

Optional search query

返回值

None

错误／异常

Emits SolrIllegalArgumentException in case of an invalid parameter was passed.

更新日志

版本 | 说明
PECL solr 2.0.0 | If q was invalid, then a SolrIllegalArgumentException is now thrown. Previously an error was emitted.


Destructor

  • ? SolrQuery::__construct
  • SolrQuery::getExpand ?
  • PHP Manual
  • SolrQuery
  • Destructor

SolrQuery::__destruct

(PECL solr >= 0.9.2)

SolrQuery::__destruct — Destructor

说明

public SolrQuery::__destruct ( ) : void

Destructor

参数

此函数没有参数。

返回值

None.


Returns true if group expanding is enabled

  • ? SolrQuery::__destruct
  • SolrQuery::getExpandFilterQueries ?
  • PHP Manual
  • SolrQuery
  • Returns true if group expanding is enabled

SolrQuery::getExpand

(PECL solr >= 2.2.0)

SolrQuery::getExpand — Returns true if group expanding is enabled

说明

public SolrQuery::getExpand ( ) : bool

Returns true if group expanding is enabled


Returns the expand filter queries

  • ? SolrQuery::getExpand
  • SolrQuery::getExpandQuery ?
  • PHP Manual
  • SolrQuery
  • Returns the expand filter queries

SolrQuery::getExpandFilterQueries

(PECL solr >= 2.2.0)

SolrQuery::getExpandFilterQueries — Returns the expand filter queries

说明

public SolrQuery::getExpandFilterQueries ( ) : array

Returns the expand filter queries


Returns the expand query expand.q parameter

  • ? SolrQuery::getExpandFilterQueries
  • SolrQuery::getExpandRows ?
  • PHP Manual
  • SolrQuery
  • Returns the expand query expand.q parameter

SolrQuery::getExpandQuery

(PECL solr >= 2.2.0)

SolrQuery::getExpandQuery — Returns the expand query expand.q parameter

说明

public SolrQuery::getExpandQuery ( ) : array

Returns the expand query expand.q parameter


Returns The number of rows to display in each group (expand.rows)

  • ? SolrQuery::getExpandQuery
  • SolrQuery::getExpandSortFields ?
  • PHP Manual
  • SolrQuery
  • Returns The number of rows to display in each group (expand.rows)

SolrQuery::getExpandRows

(PECL solr >= 2.2.0)

SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)

说明

public SolrQuery::getExpandRows ( ) : int

Returns The number of rows to display in each group (expand.rows)


Returns an array of fields

  • ? SolrQuery::getExpandRows
  • SolrQuery::getFacet ?
  • PHP Manual
  • SolrQuery
  • Returns an array of fields

SolrQuery::getExpandSortFields

(PECL solr >= 2.2.0)

SolrQuery::getExpandSortFields — Returns an array of fields

说明

public SolrQuery::getExpandSortFields ( ) : array

Returns an array of fields


Returns the value of the facet parameter

  • ? SolrQuery::getExpandSortFields
  • SolrQuery::getFacetDateEnd ?
  • PHP Manual
  • SolrQuery
  • Returns the value of the facet parameter

SolrQuery::getFacet

(PECL solr >= 0.9.2)

SolrQuery::getFacet — Returns the value of the facet parameter

说明

public SolrQuery::getFacet ( ) : bool

Returns the value of the facet parameter.

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set


Returns the value for the facet.date.end parameter

  • ? SolrQuery::getFacet
  • SolrQuery::getFacetDateFields ?
  • PHP Manual
  • SolrQuery
  • Returns the value for the facet.date.end parameter

SolrQuery::getFacetDateEnd

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateEnd — Returns the value for the facet.date.end parameter

说明

public SolrQuery::getFacetDateEnd ( string $field_override = ? ) : string

Returns the value for the facet.date.end parameter. This method accepts an optional field override

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set


Returns all the facet.date fields

  • ? SolrQuery::getFacetDateEnd
  • SolrQuery::getFacetDateGap ?
  • PHP Manual
  • SolrQuery
  • Returns all the facet.date fields

SolrQuery::getFacetDateFields

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateFields — Returns all the facet.date fields

说明

public SolrQuery::getFacetDateFields ( ) : array

Returns all the facet.date fields

参数

此函数没有参数。

返回值

Returns all the facet.date fields as an array or null if none was set


Returns the value of the facet.date.gap parameter

  • ? SolrQuery::getFacetDateFields
  • SolrQuery::getFacetDateHardEnd ?
  • PHP Manual
  • SolrQuery
  • Returns the value of the facet.date.gap parameter

SolrQuery::getFacetDateGap

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateGap — Returns the value of the facet.date.gap parameter

说明

public SolrQuery::getFacetDateGap ( string $field_override = ? ) : string

Returns the value of the facet.date.gap parameter. It accepts an optional field override

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set


Returns the value of the facet.date.hardend parameter

  • ? SolrQuery::getFacetDateGap
  • SolrQuery::getFacetDateOther ?
  • PHP Manual
  • SolrQuery
  • Returns the value of the facet.date.hardend parameter

SolrQuery::getFacetDateHardEnd

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateHardEnd — Returns the value of the facet.date.hardend parameter

说明

public SolrQuery::getFacetDateHardEnd ( string $field_override = ? ) : string

Returns the value of the facet.date.hardend parameter. Accepts an optional field override

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set


Returns the value for the facet.date.other parameter

  • ? SolrQuery::getFacetDateHardEnd
  • SolrQuery::getFacetDateStart ?
  • PHP Manual
  • SolrQuery
  • Returns the value for the facet.date.other parameter

SolrQuery::getFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateOther — Returns the value for the facet.date.other parameter

说明

public SolrQuery::getFacetDateOther ( string $field_override = ? ) : array

Returns the value for the facet.date.other parameter. This method accepts an optional field override.

参数

field_override

The name of the field

返回值

Returns an array on success and null if not set.


Returns the lower bound for the first date range for all date faceting on this field

  • ? SolrQuery::getFacetDateOther
  • SolrQuery::getFacetFields ?
  • PHP Manual
  • SolrQuery
  • Returns the lower bound for the first date range for all date faceting on this field

SolrQuery::getFacetDateStart

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateStart — Returns the lower bound for the first date range for all date faceting on this field

说明

public SolrQuery::getFacetDateStart ( string $field_override = ? ) : string

Returns the lower bound for the first date range for all date faceting on this field. Accepts an optional field override

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set


Returns all the facet fields

  • ? SolrQuery::getFacetDateStart
  • SolrQuery::getFacetLimit ?
  • PHP Manual
  • SolrQuery
  • Returns all the facet fields

SolrQuery::getFacetFields

(PECL solr >= 0.9.2)

SolrQuery::getFacetFields — Returns all the facet fields

说明

public SolrQuery::getFacetFields ( ) : array

Returns all the facet fields

参数

此函数没有参数。

返回值

Returns an array of all the fields and null if none was set


Returns the maximum number of constraint counts that should be returned for the facet fields

  • ? SolrQuery::getFacetFields
  • SolrQuery::getFacetMethod ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of constraint counts that should be returned for the facet fields

SolrQuery::getFacetLimit

(PECL solr >= 0.9.2)

SolrQuery::getFacetLimit — Returns the maximum number of constraint counts that should be returned for the facet fields

说明

public SolrQuery::getFacetLimit ( string $field_override = ? ) : int

Returns the maximum number of constraint counts that should be returned for the facet fields. This method accepts an optional field override

参数

field_override

The name of the field to override for

返回值

Returns an integer on success and null if not set


Returns the value of the facet.method parameter

  • ? SolrQuery::getFacetLimit
  • SolrQuery::getFacetMinCount ?
  • PHP Manual
  • SolrQuery
  • Returns the value of the facet.method parameter

SolrQuery::getFacetMethod

(PECL solr >= 0.9.2)

SolrQuery::getFacetMethod — Returns the value of the facet.method parameter

说明

public SolrQuery::getFacetMethod ( string $field_override = ? ) : string

Returns the value of the facet.method parameter. This accepts an optional field override.

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set


Returns the minimum counts for facet fields should be included in the response

  • ? SolrQuery::getFacetMethod
  • SolrQuery::getFacetMissing ?
  • PHP Manual
  • SolrQuery
  • Returns the minimum counts for facet fields should be included in the response

SolrQuery::getFacetMinCount

(PECL solr >= 0.9.2)

SolrQuery::getFacetMinCount — Returns the minimum counts for facet fields should be included in the response

说明

public SolrQuery::getFacetMinCount ( string $field_override = ? ) : int

Returns the minimum counts for facet fields should be included in the response. It accepts an optional field override

参数

field_override

The name of the field

返回值

Returns an integer on success and null if not set


Returns the current state of the facet.missing parameter

  • ? SolrQuery::getFacetMinCount
  • SolrQuery::getFacetOffset ?
  • PHP Manual
  • SolrQuery
  • Returns the current state of the facet.missing parameter

SolrQuery::getFacetMissing

(PECL solr >= 0.9.2)

SolrQuery::getFacetMissing — Returns the current state of the facet.missing parameter

说明

public SolrQuery::getFacetMissing ( string $field_override = ? ) : bool

Returns the current state of the facet.missing parameter. This accepts an optional field override

参数

field_override

The name of the field

返回值

Returns a boolean on success and null if not set


Returns an offset into the list of constraints to be used for pagination

  • ? SolrQuery::getFacetMissing
  • SolrQuery::getFacetPrefix ?
  • PHP Manual
  • SolrQuery
  • Returns an offset into the list of constraints to be used for pagination

SolrQuery::getFacetOffset

(PECL solr >= 0.9.2)

SolrQuery::getFacetOffset — Returns an offset into the list of constraints to be used for pagination

说明

public SolrQuery::getFacetOffset ( string $field_override = ? ) : int

Returns an offset into the list of constraints to be used for pagination. Accepts an optional field override

参数

field_override

The name of the field to override for.

返回值

Returns an integer on success and null if not set


Returns the facet prefix

  • ? SolrQuery::getFacetOffset
  • SolrQuery::getFacetQueries ?
  • PHP Manual
  • SolrQuery
  • Returns the facet prefix

SolrQuery::getFacetPrefix

(PECL solr >= 0.9.2)

SolrQuery::getFacetPrefix — Returns the facet prefix

说明

public SolrQuery::getFacetPrefix ( string $field_override = ? ) : string

Returns the facet prefix

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set.


Returns all the facet queries

  • ? SolrQuery::getFacetPrefix
  • SolrQuery::getFacetSort ?
  • PHP Manual
  • SolrQuery
  • Returns all the facet queries

SolrQuery::getFacetQueries

(PECL solr >= 0.9.2)

SolrQuery::getFacetQueries — Returns all the facet queries

说明

public SolrQuery::getFacetQueries ( ) : array

Returns all the facet queries

参数

此函数没有参数。

返回值

Returns an array on success and null if not set.


Returns the facet sort type

  • ? SolrQuery::getFacetQueries
  • SolrQuery::getFields ?
  • PHP Manual
  • SolrQuery
  • Returns the facet sort type

SolrQuery::getFacetSort

(PECL solr >= 0.9.2)

SolrQuery::getFacetSort — Returns the facet sort type

说明

public SolrQuery::getFacetSort ( string $field_override = ? ) : int

Returns an integer (SolrQuery::FACET_SORT_INDEX or SolrQuery::FACET_SORT_COUNT)

参数

field_override

The name of the field

返回值

Returns an integer (SolrQuery::FACET_SORT_INDEX or SolrQuery::FACET_SORT_COUNT) on success or null if not set.


Returns the list of fields that will be returned in the response

  • ? SolrQuery::getFacetSort
  • SolrQuery::getFilterQueries ?
  • PHP Manual
  • SolrQuery
  • Returns the list of fields that will be returned in the response

SolrQuery::getFields

(PECL solr >= 0.9.2)

SolrQuery::getFields — Returns the list of fields that will be returned in the response

说明

public SolrQuery::getFields ( ) : array

Returns the list of fields that will be returned in the response

参数

此函数没有参数。

返回值

Returns an array on success and null if not set.


Returns an array of filter queries

  • ? SolrQuery::getFields
  • SolrQuery::getGroup ?
  • PHP Manual
  • SolrQuery
  • Returns an array of filter queries

SolrQuery::getFilterQueries

(PECL solr >= 0.9.2)

SolrQuery::getFilterQueries — Returns an array of filter queries

说明

public SolrQuery::getFilterQueries ( ) : array

Returns an array of filter queries. These are queries that can be used to restrict the super set of documents that can be returned, without influencing score

参数

此函数没有参数。

返回值

Returns an array on success and null if not set.


Returns true if grouping is enabled

  • ? SolrQuery::getFilterQueries
  • SolrQuery::getGroupCachePercent ?
  • PHP Manual
  • SolrQuery
  • Returns true if grouping is enabled

SolrQuery::getGroup

(PECL solr >= 2.2.0)

SolrQuery::getGroup — Returns true if grouping is enabled

说明

public SolrQuery::getGroup ( ) : bool

Returns true if grouping is enabled

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)


Returns group cache percent value

  • ? SolrQuery::getGroup
  • SolrQuery::getGroupFacet ?
  • PHP Manual
  • SolrQuery
  • Returns group cache percent value

SolrQuery::getGroupCachePercent

(PECL solr >= 2.2.0)

SolrQuery::getGroupCachePercent — Returns group cache percent value

说明

public SolrQuery::getGroupCachePercent ( ) : int

Returns group cache percent value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Returns the group.facet parameter value

  • ? SolrQuery::getGroupCachePercent
  • SolrQuery::getGroupFields ?
  • PHP Manual
  • SolrQuery
  • Returns the group.facet parameter value

SolrQuery::getGroupFacet

(PECL solr >= 2.2.0)

SolrQuery::getGroupFacet — Returns the group.facet parameter value

说明

public SolrQuery::getGroupFacet ( ) : bool

Returns the group.facet parameter value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroupFacet() - Sets group.facet parameter


Returns group fields (group.field parameter values)

  • ? SolrQuery::getGroupFacet
  • SolrQuery::getGroupFormat ?
  • PHP Manual
  • SolrQuery
  • Returns group fields (group.field parameter values)

SolrQuery::getGroupFields

(PECL solr >= 2.2.0)

SolrQuery::getGroupFields — Returns group fields (group.field parameter values)

说明

public SolrQuery::getGroupFields ( ) : array

Returns group fields (group.field parameter values)

参数

此函数没有参数。

返回值

参见

  • SolrQuery::addGroupField() - Add a field to be used to group results


Returns the group.format value

  • ? SolrQuery::getGroupFields
  • SolrQuery::getGroupFunctions ?
  • PHP Manual
  • SolrQuery
  • Returns the group.format value

SolrQuery::getGroupFormat

(PECL solr >= 2.2.0)

SolrQuery::getGroupFormat — Returns the group.format value

说明

public SolrQuery::getGroupFormat ( ) : string

Returns the group.format value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)


Returns group functions (group.func parameter values)

  • ? SolrQuery::getGroupFormat
  • SolrQuery::getGroupLimit ?
  • PHP Manual
  • SolrQuery
  • Returns group functions (group.func parameter values)

SolrQuery::getGroupFunctions

(PECL solr >= 2.2.0)

SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)

说明

public SolrQuery::getGroupFunctions ( ) : array

Returns group functions (group.func parameter values)

参数

此函数没有参数。

返回值

参见

  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)


Returns the group.limit value

  • ? SolrQuery::getGroupFunctions
  • SolrQuery::getGroupMain ?
  • PHP Manual
  • SolrQuery
  • Returns the group.limit value

SolrQuery::getGroupLimit

(PECL solr >= 2.2.0)

SolrQuery::getGroupLimit — Returns the group.limit value

说明

public SolrQuery::getGroupLimit ( ) : int

Returns the group.limit value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1


Returns the group.main value

  • ? SolrQuery::getGroupLimit
  • SolrQuery::getGroupNGroups ?
  • PHP Manual
  • SolrQuery
  • Returns the group.main value

SolrQuery::getGroupMain

(PECL solr >= 2.2.0)

SolrQuery::getGroupMain — Returns the group.main value

说明

public SolrQuery::getGroupMain ( ) : bool

Returns the group.main value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple


Returns the group.ngroups value

  • ? SolrQuery::getGroupMain
  • SolrQuery::getGroupOffset ?
  • PHP Manual
  • SolrQuery
  • Returns the group.ngroups value

SolrQuery::getGroupNGroups

(PECL solr >= 2.2.0)

SolrQuery::getGroupNGroups — Returns the group.ngroups value

说明

public SolrQuery::getGroupNGroups ( ) : bool

Returns the group.ngroups value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results


Returns the group.offset value

  • ? SolrQuery::getGroupNGroups
  • SolrQuery::getGroupQueries ?
  • PHP Manual
  • SolrQuery
  • Returns the group.offset value

SolrQuery::getGroupOffset

(PECL solr >= 2.2.0)

SolrQuery::getGroupOffset — Returns the group.offset value

说明

public SolrQuery::getGroupOffset ( ) : int

Returns the group.offset value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroupOffset() - Sets the group.offset parameter


Returns all the group.query parameter values

  • ? SolrQuery::getGroupOffset
  • SolrQuery::getGroupSortFields ?
  • PHP Manual
  • SolrQuery
  • Returns all the group.query parameter values

SolrQuery::getGroupQueries

(PECL solr >= 2.2.0)

SolrQuery::getGroupQueries — Returns all the group.query parameter values

说明

public SolrQuery::getGroupQueries ( ) : array

Returns all the group.query parameter values

参数

此函数没有参数。

返回值

array

参见

  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query


Returns the group.sort value

  • ? SolrQuery::getGroupQueries
  • SolrQuery::getGroupTruncate ?
  • PHP Manual
  • SolrQuery
  • Returns the group.sort value

SolrQuery::getGroupSortFields

(PECL solr >= 2.2.0)

SolrQuery::getGroupSortFields — Returns the group.sort value

说明

public SolrQuery::getGroupSortFields ( ) : array

Returns the group.sort value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)


Returns the group.truncate value

  • ? SolrQuery::getGroupSortFields
  • SolrQuery::getHighlight ?
  • PHP Manual
  • SolrQuery
  • Returns the group.truncate value

SolrQuery::getGroupTruncate

(PECL solr >= 2.2.0)

SolrQuery::getGroupTruncate — Returns the group.truncate value

说明

public SolrQuery::getGroupTruncate ( ) : bool

Returns the group.truncate value

参数

此函数没有参数。

返回值

参见

  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query


Returns the state of the hl parameter

  • ? SolrQuery::getGroupTruncate
  • SolrQuery::getHighlightAlternateField ?
  • PHP Manual
  • SolrQuery
  • Returns the state of the hl parameter

SolrQuery::getHighlight

(PECL solr >= 0.9.2)

SolrQuery::getHighlight — Returns the state of the hl parameter

说明

public SolrQuery::getHighlight ( ) : bool

Returns a boolean indicating whether or not to enable highlighted snippets to be generated in the query response.

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns the highlight field to use as backup or default

  • ? SolrQuery::getHighlight
  • SolrQuery::getHighlightFields ?
  • PHP Manual
  • SolrQuery
  • Returns the highlight field to use as backup or default

SolrQuery::getHighlightAlternateField

(PECL solr >= 0.9.2)

SolrQuery::getHighlightAlternateField — Returns the highlight field to use as backup or default

说明

public SolrQuery::getHighlightAlternateField ( string $field_override = ? ) : string

Returns the highlight field to use as backup or default. It accepts an optional override.

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set.


Returns all the fields that Solr should generate highlighted snippets for

  • ? SolrQuery::getHighlightAlternateField
  • SolrQuery::getHighlightFormatter ?
  • PHP Manual
  • SolrQuery
  • Returns all the fields that Solr should generate highlighted snippets for

SolrQuery::getHighlightFields

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFields — Returns all the fields that Solr should generate highlighted snippets for

说明

public SolrQuery::getHighlightFields ( ) : array

Returns all the fields that Solr should generate highlighted snippets for

参数

此函数没有参数。

返回值

Returns an array on success and null if not set.


Returns the formatter for the highlighted output

  • ? SolrQuery::getHighlightFields
  • SolrQuery::getHighlightFragmenter ?
  • PHP Manual
  • SolrQuery
  • Returns the formatter for the highlighted output

SolrQuery::getHighlightFormatter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFormatter — Returns the formatter for the highlighted output

说明

public SolrQuery::getHighlightFormatter ( string $field_override = ? ) : string

Returns the formatter for the highlighted output

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set.


Returns the text snippet generator for highlighted text

  • ? SolrQuery::getHighlightFormatter
  • SolrQuery::getHighlightFragsize ?
  • PHP Manual
  • SolrQuery
  • Returns the text snippet generator for highlighted text

SolrQuery::getHighlightFragmenter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFragmenter — Returns the text snippet generator for highlighted text

说明

public SolrQuery::getHighlightFragmenter ( string $field_override = ? ) : string

Returns the text snippet generator for highlighted text. Accepts an optional field override.

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set.


Returns the number of characters of fragments to consider for highlighting

  • ? SolrQuery::getHighlightFragmenter
  • SolrQuery::getHighlightHighlightMultiTerm ?
  • PHP Manual
  • SolrQuery
  • Returns the number of characters of fragments to consider for highlighting

SolrQuery::getHighlightFragsize

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFragsize — Returns the number of characters of fragments to consider for highlighting

说明

public SolrQuery::getHighlightFragsize ( string $field_override = ? ) : int

Returns the number of characters of fragments to consider for highlighting. Zero implies no fragmenting. The entire field should be used.

参数

field_override

The name of the field

返回值

Returns an integer on success or null if not set.


Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries

  • ? SolrQuery::getHighlightFragsize
  • SolrQuery::getHighlightMaxAlternateFieldLength ?
  • PHP Manual
  • SolrQuery
  • Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries

SolrQuery::getHighlightHighlightMultiTerm

(PECL solr >= 0.9.2)

SolrQuery::getHighlightHighlightMultiTerm — Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries

说明

public SolrQuery::getHighlightHighlightMultiTerm ( ) : bool

Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns the maximum number of characters of the field to return

  • ? SolrQuery::getHighlightHighlightMultiTerm
  • SolrQuery::getHighlightMaxAnalyzedChars ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of characters of the field to return

SolrQuery::getHighlightMaxAlternateFieldLength

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMaxAlternateFieldLength — Returns the maximum number of characters of the field to return

说明

public SolrQuery::getHighlightMaxAlternateFieldLength ( string $field_override = ? ) : int

Returns the maximum number of characters of the field to return

参数

field_override

The name of the field

返回值

Returns an integer on success and null if not set.


Returns the maximum number of characters into a document to look for suitable snippets

  • ? SolrQuery::getHighlightMaxAlternateFieldLength
  • SolrQuery::getHighlightMergeContiguous ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of characters into a document to look for suitable snippets

SolrQuery::getHighlightMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMaxAnalyzedChars — Returns the maximum number of characters into a document to look for suitable snippets

说明

public SolrQuery::getHighlightMaxAnalyzedChars ( ) : int

Returns the maximum number of characters into a document to look for suitable snippets

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns whether or not the collapse contiguous fragments into a single fragment

  • ? SolrQuery::getHighlightMaxAnalyzedChars
  • SolrQuery::getHighlightRegexMaxAnalyzedChars ?
  • PHP Manual
  • SolrQuery
  • Returns whether or not the collapse contiguous fragments into a single fragment

SolrQuery::getHighlightMergeContiguous

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMergeContiguous — Returns whether or not the collapse contiguous fragments into a single fragment

说明

public SolrQuery::getHighlightMergeContiguous ( string $field_override = ? ) : bool

Returns whether or not the collapse contiguous fragments into a single fragment. Accepts an optional field override.

参数

field_override

The name of the field

返回值

Returns a boolean on success and null if not set.


Returns the maximum number of characters from a field when using the regex fragmenter

  • ? SolrQuery::getHighlightMergeContiguous
  • SolrQuery::getHighlightRegexPattern ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of characters from a field when using the regex fragmenter

SolrQuery::getHighlightRegexMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexMaxAnalyzedChars — Returns the maximum number of characters from a field when using the regex fragmenter

说明

public SolrQuery::getHighlightRegexMaxAnalyzedChars ( ) : int

Returns the maximum number of characters from a field when using the regex fragmenter

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the regular expression for fragmenting

  • ? SolrQuery::getHighlightRegexMaxAnalyzedChars
  • SolrQuery::getHighlightRegexSlop ?
  • PHP Manual
  • SolrQuery
  • Returns the regular expression for fragmenting

SolrQuery::getHighlightRegexPattern

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexPattern — Returns the regular expression for fragmenting

说明

public SolrQuery::getHighlightRegexPattern ( ) : string

Returns the regular expression used for fragmenting

参数

此函数没有参数。

返回值

Returns a string on success and null if not set.


Returns the deviation factor from the ideal fragment size

  • ? SolrQuery::getHighlightRegexPattern
  • SolrQuery::getHighlightRequireFieldMatch ?
  • PHP Manual
  • SolrQuery
  • Returns the deviation factor from the ideal fragment size

SolrQuery::getHighlightRegexSlop

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexSlop — Returns the deviation factor from the ideal fragment size

说明

public SolrQuery::getHighlightRegexSlop ( ) : float

Returns the factor by which the regex fragmenter can deviate from the ideal fragment size to accomodate the regular expression

参数

此函数没有参数。

返回值

Returns a double on success and null if not set.


Returns if a field will only be highlighted if the query matched in this particular field

  • ? SolrQuery::getHighlightRegexSlop
  • SolrQuery::getHighlightSimplePost ?
  • PHP Manual
  • SolrQuery
  • Returns if a field will only be highlighted if the query matched in this particular field

SolrQuery::getHighlightRequireFieldMatch

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRequireFieldMatch — Returns if a field will only be highlighted if the query matched in this particular field

说明

public SolrQuery::getHighlightRequireFieldMatch ( ) : bool

Returns if a field will only be highlighted if the query matched in this particular field.

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns the text which appears after a highlighted term

  • ? SolrQuery::getHighlightRequireFieldMatch
  • SolrQuery::getHighlightSimplePre ?
  • PHP Manual
  • SolrQuery
  • Returns the text which appears after a highlighted term

SolrQuery::getHighlightSimplePost

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSimplePost — Returns the text which appears after a highlighted term

说明

public SolrQuery::getHighlightSimplePost ( string $field_override = ? ) : string

Returns the text which appears after a highlighted term. Accepts an optional field override

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set.


Returns the text which appears before a highlighted term

  • ? SolrQuery::getHighlightSimplePost
  • SolrQuery::getHighlightSnippets ?
  • PHP Manual
  • SolrQuery
  • Returns the text which appears before a highlighted term

SolrQuery::getHighlightSimplePre

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSimplePre — Returns the text which appears before a highlighted term

说明

public SolrQuery::getHighlightSimplePre ( string $field_override = ? ) : string

Returns the text which appears before a highlighted term. Accepts an optional field override

参数

field_override

The name of the field

返回值

Returns a string on success and null if not set.


Returns the maximum number of highlighted snippets to generate per field

  • ? SolrQuery::getHighlightSimplePre
  • SolrQuery::getHighlightUsePhraseHighlighter ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of highlighted snippets to generate per field

SolrQuery::getHighlightSnippets

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSnippets — Returns the maximum number of highlighted snippets to generate per field

说明

public SolrQuery::getHighlightSnippets ( string $field_override = ? ) : int

Returns the maximum number of highlighted snippets to generate per field. Accepts an optional field override

参数

field_override

The name of the field

返回值

Returns an integer on success and null if not set.


Returns the state of the hl.usePhraseHighlighter parameter

  • ? SolrQuery::getHighlightSnippets
  • SolrQuery::getMlt ?
  • PHP Manual
  • SolrQuery
  • Returns the state of the hl.usePhraseHighlighter parameter

SolrQuery::getHighlightUsePhraseHighlighter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightUsePhraseHighlighter — Returns the state of the hl.usePhraseHighlighter parameter

说明

public SolrQuery::getHighlightUsePhraseHighlighter ( ) : bool

Returns whether or not to use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document.

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns whether or not MoreLikeThis results should be enabled

  • ? SolrQuery::getHighlightUsePhraseHighlighter
  • SolrQuery::getMltBoost ?
  • PHP Manual
  • SolrQuery
  • Returns whether or not MoreLikeThis results should be enabled

SolrQuery::getMlt

(PECL solr >= 0.9.2)

SolrQuery::getMlt — Returns whether or not MoreLikeThis results should be enabled

说明

public SolrQuery::getMlt ( ) : bool

Returns whether or not MoreLikeThis results should be enabled

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns whether or not the query will be boosted by the interesting term relevance

  • ? SolrQuery::getMlt
  • SolrQuery::getMltCount ?
  • PHP Manual
  • SolrQuery
  • Returns whether or not the query will be boosted by the interesting term relevance

SolrQuery::getMltBoost

(PECL solr >= 0.9.2)

SolrQuery::getMltBoost — Returns whether or not the query will be boosted by the interesting term relevance

说明

public SolrQuery::getMltBoost ( ) : bool

Returns whether or not the query will be boosted by the interesting term relevance

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns the number of similar documents to return for each result

  • ? SolrQuery::getMltBoost
  • SolrQuery::getMltFields ?
  • PHP Manual
  • SolrQuery
  • Returns the number of similar documents to return for each result

SolrQuery::getMltCount

(PECL solr >= 0.9.2)

SolrQuery::getMltCount — Returns the number of similar documents to return for each result

说明

public SolrQuery::getMltCount ( ) : int

Returns the number of similar documents to return for each result

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns all the fields to use for similarity

  • ? SolrQuery::getMltCount
  • SolrQuery::getMltMaxNumQueryTerms ?
  • PHP Manual
  • SolrQuery
  • Returns all the fields to use for similarity

SolrQuery::getMltFields

(PECL solr >= 0.9.2)

SolrQuery::getMltFields — Returns all the fields to use for similarity

说明

public SolrQuery::getMltFields ( ) : array

Returns all the fields to use for similarity

参数

此函数没有参数。

返回值

Returns an array on success and null if not set.


Returns the maximum number of query terms that will be included in any generated query

  • ? SolrQuery::getMltFields
  • SolrQuery::getMltMaxNumTokens ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of query terms that will be included in any generated query

SolrQuery::getMltMaxNumQueryTerms

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxNumQueryTerms — Returns the maximum number of query terms that will be included in any generated query

说明

public SolrQuery::getMltMaxNumQueryTerms ( ) : int

Returns the maximum number of query terms that will be included in any generated query

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support

  • ? SolrQuery::getMltMaxNumQueryTerms
  • SolrQuery::getMltMaxWordLength ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support

SolrQuery::getMltMaxNumTokens

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxNumTokens — Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support

说明

public SolrQuery::getMltMaxNumTokens ( ) : int

Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the maximum word length above which words will be ignored

  • ? SolrQuery::getMltMaxNumTokens
  • SolrQuery::getMltMinDocFrequency ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum word length above which words will be ignored

SolrQuery::getMltMaxWordLength

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxWordLength — Returns the maximum word length above which words will be ignored

说明

public SolrQuery::getMltMaxWordLength ( ) : int

Returns the maximum word length above which words will be ignored

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs

  • ? SolrQuery::getMltMaxWordLength
  • SolrQuery::getMltMinTermFrequency ?
  • PHP Manual
  • SolrQuery
  • Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs

SolrQuery::getMltMinDocFrequency

(PECL solr >= 0.9.2)

SolrQuery::getMltMinDocFrequency — Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs

说明

public SolrQuery::getMltMinDocFrequency ( ) : int

Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the frequency below which terms will be ignored in the source document

  • ? SolrQuery::getMltMinDocFrequency
  • SolrQuery::getMltMinWordLength ?
  • PHP Manual
  • SolrQuery
  • Returns the frequency below which terms will be ignored in the source document

SolrQuery::getMltMinTermFrequency

(PECL solr >= 0.9.2)

SolrQuery::getMltMinTermFrequency — Returns the frequency below which terms will be ignored in the source document

说明

public SolrQuery::getMltMinTermFrequency ( ) : int

Returns the frequency below which terms will be ignored in the source document

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the minimum word length below which words will be ignored

  • ? SolrQuery::getMltMinTermFrequency
  • SolrQuery::getMltQueryFields ?
  • PHP Manual
  • SolrQuery
  • Returns the minimum word length below which words will be ignored

SolrQuery::getMltMinWordLength

(PECL solr >= 0.9.2)

SolrQuery::getMltMinWordLength — Returns the minimum word length below which words will be ignored

说明

public SolrQuery::getMltMinWordLength ( ) : int

Returns the minimum word length below which words will be ignored

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the query fields and their boosts

  • ? SolrQuery::getMltMinWordLength
  • SolrQuery::getQuery ?
  • PHP Manual
  • SolrQuery
  • Returns the query fields and their boosts

SolrQuery::getMltQueryFields

(PECL solr >= 0.9.2)

SolrQuery::getMltQueryFields — Returns the query fields and their boosts

说明

public SolrQuery::getMltQueryFields ( ) : array

Returns the query fields and their boosts

参数

此函数没有参数。

返回值

Returns an array on success and null if not set.


Returns the main query

  • ? SolrQuery::getMltQueryFields
  • SolrQuery::getRows ?
  • PHP Manual
  • SolrQuery
  • Returns the main query

SolrQuery::getQuery

(PECL solr >= 0.9.2)

SolrQuery::getQuery — Returns the main query

说明

public SolrQuery::getQuery ( ) : string

Returns the main search query

参数

此函数没有参数。

返回值

Returns a string on success and null if not set.


Returns the maximum number of documents

  • ? SolrQuery::getQuery
  • SolrQuery::getSortFields ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of documents

SolrQuery::getRows

(PECL solr >= 0.9.2)

SolrQuery::getRows — Returns the maximum number of documents

说明

public SolrQuery::getRows ( ) : int

Returns the maximum number of documents from the complete result set to return to the client for every request

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns all the sort fields

  • ? SolrQuery::getRows
  • SolrQuery::getStart ?
  • PHP Manual
  • SolrQuery
  • Returns all the sort fields

SolrQuery::getSortFields

(PECL solr >= 0.9.2)

SolrQuery::getSortFields — Returns all the sort fields

说明

public SolrQuery::getSortFields ( ) : array

Returns all the sort fields

参数

此函数没有参数。

返回值

Returns an array on success and null if none of the parameters was set.


Returns the offset in the complete result set

  • ? SolrQuery::getSortFields
  • SolrQuery::getStats ?
  • PHP Manual
  • SolrQuery
  • Returns the offset in the complete result set

SolrQuery::getStart

(PECL solr >= 0.9.2)

SolrQuery::getStart — Returns the offset in the complete result set

说明

public SolrQuery::getStart ( ) : int

Returns the offset in the complete result set for the queries where the set of returned documents should begin.

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns whether or not stats is enabled

  • ? SolrQuery::getStart
  • SolrQuery::getStatsFacets ?
  • PHP Manual
  • SolrQuery
  • Returns whether or not stats is enabled

SolrQuery::getStats

(PECL solr >= 0.9.2)

SolrQuery::getStats — Returns whether or not stats is enabled

说明

public SolrQuery::getStats ( ) : bool

Returns whether or not stats is enabled

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns all the stats facets that were set

  • ? SolrQuery::getStats
  • SolrQuery::getStatsFields ?
  • PHP Manual
  • SolrQuery
  • Returns all the stats facets that were set

SolrQuery::getStatsFacets

(PECL solr >= 0.9.2)

SolrQuery::getStatsFacets — Returns all the stats facets that were set

说明

public SolrQuery::getStatsFacets ( ) : array

Returns all the stats facets that were set

参数

此函数没有参数。

返回值

Returns an array on success and null if not set.


Returns all the statistics fields

  • ? SolrQuery::getStatsFacets
  • SolrQuery::getTerms ?
  • PHP Manual
  • SolrQuery
  • Returns all the statistics fields

SolrQuery::getStatsFields

(PECL solr >= 0.9.2)

SolrQuery::getStatsFields — Returns all the statistics fields

说明

public SolrQuery::getStatsFields ( ) : array

Returns all the statistics fields

参数

此函数没有参数。

返回值

Returns an array on success and null if not set.


Returns whether or not the TermsComponent is enabled

  • ? SolrQuery::getStatsFields
  • SolrQuery::getTermsField ?
  • PHP Manual
  • SolrQuery
  • Returns whether or not the TermsComponent is enabled

SolrQuery::getTerms

(PECL solr >= 0.9.2)

SolrQuery::getTerms — Returns whether or not the TermsComponent is enabled

说明

public SolrQuery::getTerms ( ) : bool

Returns whether or not the TermsComponent is enabled

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns the field from which the terms are retrieved

  • ? SolrQuery::getTerms
  • SolrQuery::getTermsIncludeLowerBound ?
  • PHP Manual
  • SolrQuery
  • Returns the field from which the terms are retrieved

SolrQuery::getTermsField

(PECL solr >= 0.9.2)

SolrQuery::getTermsField — Returns the field from which the terms are retrieved

说明

public SolrQuery::getTermsField ( ) : string

Returns the field from which the terms are retrieved

参数

此函数没有参数。

返回值

Returns a string on success and null if not set.


Returns whether or not to include the lower bound in the result set

  • ? SolrQuery::getTermsField
  • SolrQuery::getTermsIncludeUpperBound ?
  • PHP Manual
  • SolrQuery
  • Returns whether or not to include the lower bound in the result set

SolrQuery::getTermsIncludeLowerBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsIncludeLowerBound — Returns whether or not to include the lower bound in the result set

说明

public SolrQuery::getTermsIncludeLowerBound ( ) : bool

Returns whether or not to include the lower bound in the result set

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns whether or not to include the upper bound term in the result set

  • ? SolrQuery::getTermsIncludeLowerBound
  • SolrQuery::getTermsLimit ?
  • PHP Manual
  • SolrQuery
  • Returns whether or not to include the upper bound term in the result set

SolrQuery::getTermsIncludeUpperBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsIncludeUpperBound — Returns whether or not to include the upper bound term in the result set

说明

public SolrQuery::getTermsIncludeUpperBound ( ) : bool

Returns whether or not to include the upper bound term in the result set

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns the maximum number of terms Solr should return

  • ? SolrQuery::getTermsIncludeUpperBound
  • SolrQuery::getTermsLowerBound ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum number of terms Solr should return

SolrQuery::getTermsLimit

(PECL solr >= 0.9.2)

SolrQuery::getTermsLimit — Returns the maximum number of terms Solr should return

说明

public SolrQuery::getTermsLimit ( ) : int

Returns the maximum number of terms Solr should return

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the term to start at

  • ? SolrQuery::getTermsLimit
  • SolrQuery::getTermsMaxCount ?
  • PHP Manual
  • SolrQuery
  • Returns the term to start at

SolrQuery::getTermsLowerBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsLowerBound — Returns the term to start at

说明

public SolrQuery::getTermsLowerBound ( ) : string

Returns the term to start at

参数

此函数没有参数。

返回值

Returns a string on success and null if not set.


Returns the maximum document frequency

  • ? SolrQuery::getTermsLowerBound
  • SolrQuery::getTermsMinCount ?
  • PHP Manual
  • SolrQuery
  • Returns the maximum document frequency

SolrQuery::getTermsMaxCount

(PECL solr >= 0.9.2)

SolrQuery::getTermsMaxCount — Returns the maximum document frequency

说明

public SolrQuery::getTermsMaxCount ( ) : int

Returns the maximum document frequency

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the minimum document frequency to return in order to be included

  • ? SolrQuery::getTermsMaxCount
  • SolrQuery::getTermsPrefix ?
  • PHP Manual
  • SolrQuery
  • Returns the minimum document frequency to return in order to be included

SolrQuery::getTermsMinCount

(PECL solr >= 0.9.2)

SolrQuery::getTermsMinCount — Returns the minimum document frequency to return in order to be included

说明

public SolrQuery::getTermsMinCount ( ) : int

Returns the minimum document frequency to return in order to be included

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the term prefix

  • ? SolrQuery::getTermsMinCount
  • SolrQuery::getTermsReturnRaw ?
  • PHP Manual
  • SolrQuery
  • Returns the term prefix

SolrQuery::getTermsPrefix

(PECL solr >= 0.9.2)

SolrQuery::getTermsPrefix — Returns the term prefix

说明

public SolrQuery::getTermsPrefix ( ) : string

Returns the prefix to which matching terms must be restricted. This will restrict matches to only terms that start with the prefix

参数

此函数没有参数。

返回值

Returns a string on success and null if not set.


Whether or not to return raw characters

  • ? SolrQuery::getTermsPrefix
  • SolrQuery::getTermsSort ?
  • PHP Manual
  • SolrQuery
  • Whether or not to return raw characters

SolrQuery::getTermsReturnRaw

(PECL solr >= 0.9.2)

SolrQuery::getTermsReturnRaw — Whether or not to return raw characters

说明

public SolrQuery::getTermsReturnRaw ( ) : bool

Returns a boolean indicating whether or not to return the raw characters of the indexed term, regardless of if it is human readable

参数

此函数没有参数。

返回值

Returns a boolean on success and null if not set.


Returns an integer indicating how terms are sorted

  • ? SolrQuery::getTermsReturnRaw
  • SolrQuery::getTermsUpperBound ?
  • PHP Manual
  • SolrQuery
  • Returns an integer indicating how terms are sorted

SolrQuery::getTermsSort

(PECL solr >= 0.9.2)

SolrQuery::getTermsSort — Returns an integer indicating how terms are sorted

说明

public SolrQuery::getTermsSort ( ) : int

SolrQuery::TERMS_SORT_INDEX indicates that the terms are returned by index order. SolrQuery::TERMS_SORT_COUNT implies that the terms are sorted by term frequency (highest count first)

参数

此函数没有参数。

返回值

Returns an integer on success and null if not set.


Returns the term to stop at

  • ? SolrQuery::getTermsSort
  • SolrQuery::getTimeAllowed ?
  • PHP Manual
  • SolrQuery
  • Returns the term to stop at

SolrQuery::getTermsUpperBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsUpperBound — Returns the term to stop at

说明

public SolrQuery::getTermsUpperBound ( ) : string

Returns the term to stop at

参数

此函数没有参数。

返回值

Returns a string on success and null if not set.


Returns the time in milliseconds allowed for the query to finish

  • ? SolrQuery::getTermsUpperBound
  • SolrQuery::removeExpandFilterQuery ?
  • PHP Manual
  • SolrQuery
  • Returns the time in milliseconds allowed for the query to finish

SolrQuery::getTimeAllowed

(PECL solr >= 0.9.2)

SolrQuery::getTimeAllowed — Returns the time in milliseconds allowed for the query to finish

说明

public SolrQuery::getTimeAllowed ( ) : int

Returns the time in milliseconds allowed for the query to finish.

参数

此函数没有参数。

返回值

Returns and integer on success and null if it is not set.


Removes an expand filter query

  • ? SolrQuery::getTimeAllowed
  • SolrQuery::removeExpandSortField ?
  • PHP Manual
  • SolrQuery
  • Removes an expand filter query

SolrQuery::removeExpandFilterQuery

(PECL solr >= 2.2.0)

SolrQuery::removeExpandFilterQuery — Removes an expand filter query

说明

public SolrQuery::removeExpandFilterQuery ( string $fq ) : SolrQuery

Removes an expand filter query.

参数

fq

返回值

SolrQuery

参见

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group


Removes an expand sort field from the expand.sort parameter

  • ? SolrQuery::removeExpandFilterQuery
  • SolrQuery::removeFacetDateField ?
  • PHP Manual
  • SolrQuery
  • Removes an expand sort field from the expand.sort parameter

SolrQuery::removeExpandSortField

(PECL solr >= 2.2.0)

SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter

说明

public SolrQuery::removeExpandSortField ( string $field ) : SolrQuery

Removes an expand sort field from the expand.sort parameter.

参数

field

field name

返回值

SolrQuery

参见

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Removes one of the facet date fields

  • ? SolrQuery::removeExpandSortField
  • SolrQuery::removeFacetDateOther ?
  • PHP Manual
  • SolrQuery
  • Removes one of the facet date fields

SolrQuery::removeFacetDateField

(PECL solr >= 0.9.2)

SolrQuery::removeFacetDateField — Removes one of the facet date fields

说明

public SolrQuery::removeFacetDateField ( string $field ) : SolrQuery

The name of the field

参数

field

The name of the date field to remove

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the facet.date.other parameters

  • ? SolrQuery::removeFacetDateField
  • SolrQuery::removeFacetField ?
  • PHP Manual
  • SolrQuery
  • Removes one of the facet.date.other parameters

SolrQuery::removeFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::removeFacetDateOther — Removes one of the facet.date.other parameters

说明

public SolrQuery::removeFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery

Removes one of the facet.date.other parameters

参数

value

The value

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the facet.date parameters

  • ? SolrQuery::removeFacetDateOther
  • SolrQuery::removeFacetQuery ?
  • PHP Manual
  • SolrQuery
  • Removes one of the facet.date parameters

SolrQuery::removeFacetField

(PECL solr >= 0.9.2)

SolrQuery::removeFacetField — Removes one of the facet.date parameters

说明

public SolrQuery::removeFacetField ( string $field ) : SolrQuery

Removes one of the facet.date parameters

参数

field

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the facet.query parameters

  • ? SolrQuery::removeFacetField
  • SolrQuery::removeField ?
  • PHP Manual
  • SolrQuery
  • Removes one of the facet.query parameters

SolrQuery::removeFacetQuery

(PECL solr >= 0.9.2)

SolrQuery::removeFacetQuery — Removes one of the facet.query parameters

说明

public SolrQuery::removeFacetQuery ( string $value ) : SolrQuery

Removes one of the facet.query parameters.

参数

value

The value

返回值

Returns the current SolrQuery object, if the return value is used.


Removes a field from the list of fields

  • ? SolrQuery::removeFacetQuery
  • SolrQuery::removeFilterQuery ?
  • PHP Manual
  • SolrQuery
  • Removes a field from the list of fields

SolrQuery::removeField

(PECL solr >= 0.9.2)

SolrQuery::removeField — Removes a field from the list of fields

说明

public SolrQuery::removeField ( string $field ) : SolrQuery

Removes a field from the list of fields

参数

field

Name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Removes a filter query

  • ? SolrQuery::removeField
  • SolrQuery::removeHighlightField ?
  • PHP Manual
  • SolrQuery
  • Removes a filter query

SolrQuery::removeFilterQuery

(PECL solr >= 0.9.2)

SolrQuery::removeFilterQuery — Removes a filter query

说明

public SolrQuery::removeFilterQuery ( string $fq ) : SolrQuery

Removes a filter query.

参数

fq

The filter query to remove

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the fields used for highlighting

  • ? SolrQuery::removeFilterQuery
  • SolrQuery::removeMltField ?
  • PHP Manual
  • SolrQuery
  • Removes one of the fields used for highlighting

SolrQuery::removeHighlightField

(PECL solr >= 0.9.2)

SolrQuery::removeHighlightField — Removes one of the fields used for highlighting

说明

public SolrQuery::removeHighlightField ( string $field ) : SolrQuery

Removes one of the fields used for highlighting.

参数

field

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the moreLikeThis fields

  • ? SolrQuery::removeHighlightField
  • SolrQuery::removeMltQueryField ?
  • PHP Manual
  • SolrQuery
  • Removes one of the moreLikeThis fields

SolrQuery::removeMltField

(PECL solr >= 0.9.2)

SolrQuery::removeMltField — Removes one of the moreLikeThis fields

说明

public SolrQuery::removeMltField ( string $field ) : SolrQuery

Removes one of the moreLikeThis fields.

参数

field

Name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the moreLikeThis query fields

  • ? SolrQuery::removeMltField
  • SolrQuery::removeSortField ?
  • PHP Manual
  • SolrQuery
  • Removes one of the moreLikeThis query fields

SolrQuery::removeMltQueryField

(PECL solr >= 0.9.2)

SolrQuery::removeMltQueryField — Removes one of the moreLikeThis query fields

说明

public SolrQuery::removeMltQueryField ( string $queryField ) : SolrQuery

Removes one of the moreLikeThis query fields.

参数

queryField

The query field

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the sort fields

  • ? SolrQuery::removeMltQueryField
  • SolrQuery::removeStatsFacet ?
  • PHP Manual
  • SolrQuery
  • Removes one of the sort fields

SolrQuery::removeSortField

(PECL solr >= 0.9.2)

SolrQuery::removeSortField — Removes one of the sort fields

说明

public SolrQuery::removeSortField ( string $field ) : SolrQuery

Removes one of the sort fields

参数

field

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the stats.facet parameters

  • ? SolrQuery::removeSortField
  • SolrQuery::removeStatsField ?
  • PHP Manual
  • SolrQuery
  • Removes one of the stats.facet parameters

SolrQuery::removeStatsFacet

(PECL solr >= 0.9.2)

SolrQuery::removeStatsFacet — Removes one of the stats.facet parameters

说明

public SolrQuery::removeStatsFacet ( string $value ) : SolrQuery

Removes one of the stats.facet parameters

参数

value

The value

返回值

Returns the current SolrQuery object, if the return value is used.


Removes one of the stats.field parameters

  • ? SolrQuery::removeStatsFacet
  • SolrQuery::setEchoHandler ?
  • PHP Manual
  • SolrQuery
  • Removes one of the stats.field parameters

SolrQuery::removeStatsField

(PECL solr >= 0.9.2)

SolrQuery::removeStatsField — Removes one of the stats.field parameters

说明

public SolrQuery::removeStatsField ( string $field ) : SolrQuery

Removes one of the stats.field parameters

参数

field

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Toggles the echoHandler parameter

  • ? SolrQuery::removeStatsField
  • SolrQuery::setEchoParams ?
  • PHP Manual
  • SolrQuery
  • Toggles the echoHandler parameter

SolrQuery::setEchoHandler

(PECL solr >= 0.9.2)

SolrQuery::setEchoHandler — Toggles the echoHandler parameter

说明

public SolrQuery::setEchoHandler ( bool $flag ) : SolrQuery

If set to true, Solr places the name of the handle used in the response to the client for debugging purposes.

参数

flag

true or false

返回值

Returns the current SolrQuery object, if the return value is used.


Determines what kind of parameters to include in the response

  • ? SolrQuery::setEchoHandler
  • SolrQuery::setExpand ?
  • PHP Manual
  • SolrQuery
  • Determines what kind of parameters to include in the response

SolrQuery::setEchoParams

(PECL solr >= 0.9.2)

SolrQuery::setEchoParams — Determines what kind of parameters to include in the response

说明

public SolrQuery::setEchoParams ( string $type ) : SolrQuery

Instructs Solr what kinds of Request parameters should be included in the response for debugging purposes, legal values include:

- none - don't include any request parameters for debugging
- explicit - include the parameters explicitly specified by the client in the request
- all - include all parameters involved in this request, either specified explicitly by the client, or implicit because of the request handler configuration.

参数

type

The type of parameters to include

返回值

Returns the current SolrQuery object, if the return value is used.


Enables/Disables the Expand Component

  • ? SolrQuery::setEchoParams
  • SolrQuery::setExpandQuery ?
  • PHP Manual
  • SolrQuery
  • Enables/Disables the Expand Component

SolrQuery::setExpand

(PECL solr >= 2.2.0)

SolrQuery::setExpand — Enables/Disables the Expand Component

说明

public SolrQuery::setExpand ( bool $value ) : SolrQuery

Enables/Disables the Expand Component.

参数

value

Bool flag

返回值

SolrQuery

范例

Example #1 SolrQuery::setExpand() example

<?php

$query = new SolrQuery('lucene');

$query
    ->setExpand(true)
    ->setExpandRows(50)
    ->setExpandQuery('text:product')
    ->addExpandFilterQuery('manu:apple')
    ->addExpandFilterQuery('inStock:true')
    ->addExpandSortField('score', SolrQuery::ORDER_DESC)
    ->addExpandSortField('title', SolrQuery::ORDER_ASC);

echo $query.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&expand=true&expand.rows=50&expand.q=text:product&expand.fq=manu:apple&expand.fq=inStock:true&expand.sort=score desc,title asc

参见

  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Sets the expand.q parameter

  • ? SolrQuery::setExpand
  • SolrQuery::setExpandRows ?
  • PHP Manual
  • SolrQuery
  • Sets the expand.q parameter

SolrQuery::setExpandQuery

(PECL solr >= 2.2.0)

SolrQuery::setExpandQuery — Sets the expand.q parameter

说明

public SolrQuery::setExpandQuery ( string $q ) : SolrQuery

Sets the expand.q parameter.

Overrides the main q parameter, determines which documents to include in the main group.

参数

q

返回值

SolrQuery

参见

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Sets the number of rows to display in each group (expand.rows). Server Default 5

  • ? SolrQuery::setExpandQuery
  • SolrQuery::setExplainOther ?
  • PHP Manual
  • SolrQuery
  • Sets the number of rows to display in each group (expand.rows). Server Default 5

SolrQuery::setExpandRows

(PECL solr >= 2.2.0)

SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5

说明

public SolrQuery::setExpandRows ( int $value ) : SolrQuery

Sets the number of rows to display in each group (expand.rows). Server Default 5

参数

value

返回值

SolrQuery

参见

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter)
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query


Sets the explainOther common query parameter

  • ? SolrQuery::setExpandRows
  • SolrQuery::setFacet ?
  • PHP Manual
  • SolrQuery
  • Sets the explainOther common query parameter

SolrQuery::setExplainOther

(PECL solr >= 0.9.2)

SolrQuery::setExplainOther — Sets the explainOther common query parameter

说明

public SolrQuery::setExplainOther ( string $query ) : SolrQuery

Sets the explainOther common query parameter

参数

query

The Lucene query to identify a set of documents

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to the facet parameter. Enables or disables facetting

  • ? SolrQuery::setExplainOther
  • SolrQuery::setFacetDateEnd ?
  • PHP Manual
  • SolrQuery
  • Maps to the facet parameter. Enables or disables facetting

SolrQuery::setFacet

(PECL solr >= 0.9.2)

SolrQuery::setFacet — Maps to the facet parameter. Enables or disables facetting

说明

public SolrQuery::setFacet ( bool $flag ) : SolrQuery

Enables or disables faceting.

参数

value

true enables faceting and false disables it.

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to facet.date.end

  • ? SolrQuery::setFacet
  • SolrQuery::setFacetDateGap ?
  • PHP Manual
  • SolrQuery
  • Maps to facet.date.end

SolrQuery::setFacetDateEnd

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateEnd — Maps to facet.date.end

说明

public SolrQuery::setFacetDateEnd ( string $value , string $field_override = ? ) : SolrQuery

Maps to facet.date.end

参数

value

See facet.date.end

field_override

Name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to facet.date.gap

  • ? SolrQuery::setFacetDateEnd
  • SolrQuery::setFacetDateHardEnd ?
  • PHP Manual
  • SolrQuery
  • Maps to facet.date.gap

SolrQuery::setFacetDateGap

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateGap — Maps to facet.date.gap

说明

public SolrQuery::setFacetDateGap ( string $value , string $field_override = ? ) : SolrQuery

Maps to facet.date.gap

参数

value

See facet.date.gap

field_override

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to facet.date.hardend

  • ? SolrQuery::setFacetDateGap
  • SolrQuery::setFacetDateStart ?
  • PHP Manual
  • SolrQuery
  • Maps to facet.date.hardend

SolrQuery::setFacetDateHardEnd

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateHardEnd — Maps to facet.date.hardend

说明

public SolrQuery::setFacetDateHardEnd ( bool $value , string $field_override = ? ) : SolrQuery

Maps to facet.date.hardend

参数

value

See facet.date.hardend

field_override

The name of the field

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to facet.date.start

  • ? SolrQuery::setFacetDateHardEnd
  • SolrQuery::setFacetEnumCacheMinDefaultFrequency ?
  • PHP Manual
  • SolrQuery
  • Maps to facet.date.start

SolrQuery::setFacetDateStart

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateStart — Maps to facet.date.start

说明

public SolrQuery::setFacetDateStart ( string $value , string $field_override = ? ) : SolrQuery

Maps to facet.date.start

参数

value

See facet.date.start

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the minimum document frequency used for determining term count

  • ? SolrQuery::setFacetDateStart
  • SolrQuery::setFacetLimit ?
  • PHP Manual
  • SolrQuery
  • Sets the minimum document frequency used for determining term count

SolrQuery::setFacetEnumCacheMinDefaultFrequency

(PECL solr >= 0.9.2)

SolrQuery::setFacetEnumCacheMinDefaultFrequency — Sets the minimum document frequency used for determining term count

说明

public SolrQuery::setFacetEnumCacheMinDefaultFrequency ( int $frequency , string $field_override = ? ) : SolrQuery

Sets the minimum document frequency used for determining term count

参数

value

The minimum frequency

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to facet.limit

  • ? SolrQuery::setFacetEnumCacheMinDefaultFrequency
  • SolrQuery::setFacetMethod ?
  • PHP Manual
  • SolrQuery
  • Maps to facet.limit

SolrQuery::setFacetLimit

(PECL solr >= 0.9.2)

SolrQuery::setFacetLimit — Maps to facet.limit

说明

public SolrQuery::setFacetLimit ( int $limit , string $field_override = ? ) : SolrQuery

Maps to facet.limit. Sets the maximum number of constraint counts that should be returned for the facet fields.

参数

limit

The maximum number of constraint counts

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Specifies the type of algorithm to use when faceting a field

  • ? SolrQuery::setFacetLimit
  • SolrQuery::setFacetMinCount ?
  • PHP Manual
  • SolrQuery
  • Specifies the type of algorithm to use when faceting a field

SolrQuery::setFacetMethod

(PECL solr >= 0.9.2)

SolrQuery::setFacetMethod — Specifies the type of algorithm to use when faceting a field

说明

public SolrQuery::setFacetMethod ( string $method , string $field_override = ? ) : SolrQuery

Specifies the type of algorithm to use when faceting a field. This method accepts optional field override.

参数

method

The method to use.

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to facet.mincount

  • ? SolrQuery::setFacetMethod
  • SolrQuery::setFacetMissing ?
  • PHP Manual
  • SolrQuery
  • Maps to facet.mincount

SolrQuery::setFacetMinCount

(PECL solr >= 0.9.2)

SolrQuery::setFacetMinCount — Maps to facet.mincount

说明

public SolrQuery::setFacetMinCount ( int $mincount , string $field_override = ? ) : SolrQuery

Sets the minimum counts for facet fields that should be included in the response

参数

mincount

The minimum count

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Maps to facet.missing

  • ? SolrQuery::setFacetMinCount
  • SolrQuery::setFacetOffset ?
  • PHP Manual
  • SolrQuery
  • Maps to facet.missing

SolrQuery::setFacetMissing

(PECL solr >= 0.9.2)

SolrQuery::setFacetMissing — Maps to facet.missing

说明

public SolrQuery::setFacetMissing ( bool $flag , string $field_override = ? ) : SolrQuery

Used to indicate that in addition to the Term-based constraints of a facet field, a count of all matching results which have no value for the field should be computed

参数

flag

true turns this feature on. false disables it.

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the offset into the list of constraints to allow for pagination

  • ? SolrQuery::setFacetMissing
  • SolrQuery::setFacetPrefix ?
  • PHP Manual
  • SolrQuery
  • Sets the offset into the list of constraints to allow for pagination

SolrQuery::setFacetOffset

(PECL solr >= 0.9.2)

SolrQuery::setFacetOffset — Sets the offset into the list of constraints to allow for pagination

说明

public SolrQuery::setFacetOffset ( int $offset , string $field_override = ? ) : SolrQuery

Sets the offset into the list of constraints to allow for pagination.

参数

offset

The offset

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Specifies a string prefix with which to limits the terms on which to facet

  • ? SolrQuery::setFacetOffset
  • SolrQuery::setFacetSort ?
  • PHP Manual
  • SolrQuery
  • Specifies a string prefix with which to limits the terms on which to facet

SolrQuery::setFacetPrefix

(PECL solr >= 0.9.2)

SolrQuery::setFacetPrefix — Specifies a string prefix with which to limits the terms on which to facet

说明

public SolrQuery::setFacetPrefix ( string $prefix , string $field_override = ? ) : SolrQuery

Specifies a string prefix with which to limits the terms on which to facet.

参数

prefix

The prefix string

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Determines the ordering of the facet field constraints

  • ? SolrQuery::setFacetPrefix
  • SolrQuery::setGroup ?
  • PHP Manual
  • SolrQuery
  • Determines the ordering of the facet field constraints

SolrQuery::setFacetSort

(PECL solr >= 0.9.2)

SolrQuery::setFacetSort — Determines the ordering of the facet field constraints

说明

public SolrQuery::setFacetSort ( int $facetSort , string $field_override = ? ) : SolrQuery

Determines the ordering of the facet field constraints

参数

facetSort

Use SolrQuery::FACET_SORT_INDEX for sorting by index order or SolrQuery::FACET_SORT_COUNT for sorting by count.

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Enable/Disable result grouping (group parameter)

  • ? SolrQuery::setFacetSort
  • SolrQuery::setGroupCachePercent ?
  • PHP Manual
  • SolrQuery
  • Enable/Disable result grouping (group parameter)

SolrQuery::setGroup

(PECL solr >= 2.2.0)

SolrQuery::setGroup — Enable/Disable result grouping (group parameter)

说明

public SolrQuery::setGroup ( bool $value ) : SolrQuery

Enable/Disable result grouping (group parameter)

参数

value

返回值

参见

  • SolrQuery::getGroup() - Returns true if grouping is enabled
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Enables caching for result grouping

  • ? SolrQuery::setGroup
  • SolrQuery::setGroupFacet ?
  • PHP Manual
  • SolrQuery
  • Enables caching for result grouping

SolrQuery::setGroupCachePercent

(PECL solr >= 2.2.0)

SolrQuery::setGroupCachePercent — Enables caching for result grouping

说明

public SolrQuery::setGroupCachePercent ( int $percent ) : SolrQuery

Setting this parameter to a number greater than 0 enables caching for result grouping. Result Grouping executes two searches; this option caches the second search. The server default value is 0. Testing has shown that group caching only improves search time with Boolean, wildcard, and fuzzy queries. For simple queries like term or "match all" queries, group caching degrades performance. group.cache.percent parameter

参数

percent

返回值

错误／异常

Emits SolrIllegalArgumentException in case of an invalid parameter was passed.

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)


Sets group.facet parameter

  • ? SolrQuery::setGroupCachePercent
  • SolrQuery::setGroupFormat ?
  • PHP Manual
  • SolrQuery
  • Sets group.facet parameter

SolrQuery::setGroupFacet

(PECL solr >= 2.2.0)

SolrQuery::setGroupFacet — Sets group.facet parameter

说明

public SolrQuery::setGroupFacet ( bool $value ) : SolrQuery

Determines whether to compute grouped facets for the field facets specified in facet.field parameters. Grouped facets are computed based on the first specified group.

参数

value

返回值

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Sets the group format, result structure (group.format parameter)

  • ? SolrQuery::setGroupFacet
  • SolrQuery::setGroupLimit ?
  • PHP Manual
  • SolrQuery
  • Sets the group format, result structure (group.format parameter)

SolrQuery::setGroupFormat

(PECL solr >= 2.2.0)

SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter)

说明

public SolrQuery::setGroupFormat ( string $value ) : SolrQuery

Sets the group.format parameter. If this parameter is set to simple, the grouped documents are presented in a single flat list, and the start and rows parameters affect the numbers of documents instead of groups. Accepts: grouped/simple

参数

value

返回值

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Specifies the number of results to return for each group. The server default value is 1

  • ? SolrQuery::setGroupFormat
  • SolrQuery::setGroupMain ?
  • PHP Manual
  • SolrQuery
  • Specifies the number of results to return for each group. The server default value is 1

SolrQuery::setGroupLimit

(PECL solr >= 2.2.0)

SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1

说明

public SolrQuery::setGroupLimit ( int $value ) : SolrQuery

Specifies the number of results to return for each group. The server default value is 1.

参数

value

返回值

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple

  • ? SolrQuery::setGroupLimit
  • SolrQuery::setGroupNGroups ?
  • PHP Manual
  • SolrQuery
  • If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple

SolrQuery::setGroupMain

(PECL solr >= 2.2.0)

SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple

说明

public SolrQuery::setGroupMain ( string $value ) : SolrQuery

If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.

参数

value

返回值

参见

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupMain()
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


If true, Solr includes the number of groups that have matched the query in the results

  • ? SolrQuery::setGroupMain
  • SolrQuery::setGroupOffset ?
  • PHP Manual
  • SolrQuery
  • If true, Solr includes the number of groups that have matched the query in the results

SolrQuery::setGroupNGroups

(PECL solr >= 2.2.0)

SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results

说明

public SolrQuery::setGroupNGroups ( bool $value ) : SolrQuery

If true, Solr includes the number of groups that have matched the query in the results.

参数

value

返回值

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Sets the group.offset parameter

  • ? SolrQuery::setGroupNGroups
  • SolrQuery::setGroupTruncate ?
  • PHP Manual
  • SolrQuery
  • Sets the group.offset parameter

SolrQuery::setGroupOffset

(PECL solr >= 2.2.0)

SolrQuery::setGroupOffset — Sets the group.offset parameter

说明

public SolrQuery::setGroupOffset ( int $value ) : SolrQuery

Sets the group.offset parameter.

参数

value

返回值

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


If true, facet counts are based on the most relevant document of each group matching the query

  • ? SolrQuery::setGroupOffset
  • SolrQuery::setHighlight ?
  • PHP Manual
  • SolrQuery
  • If true, facet counts are based on the most relevant document of each group matching the query

SolrQuery::setGroupTruncate

(PECL solr >= 2.2.0)

SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query

说明

public SolrQuery::setGroupTruncate ( bool $value ) : SolrQuery

If true, facet counts are based on the most relevant document of each group matching the query. The server default value is false. group.truncate parameter

参数

value

返回值

参见

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter)
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter)
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter)
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping


Enables or disables highlighting

  • ? SolrQuery::setGroupTruncate
  • SolrQuery::setHighlightAlternateField ?
  • PHP Manual
  • SolrQuery
  • Enables or disables highlighting

SolrQuery::setHighlight

(PECL solr >= 0.9.2)

SolrQuery::setHighlight — Enables or disables highlighting

说明

public SolrQuery::setHighlight ( bool $flag ) : SolrQuery

Setting it to true enables highlighted snippets to be generated in the query response.

Setting it to false disables highlighting

参数

flag

Enable or disable highlighting

返回值

Returns the current SolrQuery object, if the return value is used.


Specifies the backup field to use

  • ? SolrQuery::setHighlight
  • SolrQuery::setHighlightFormatter ?
  • PHP Manual
  • SolrQuery
  • Specifies the backup field to use

SolrQuery::setHighlightAlternateField

(PECL solr >= 0.9.2)

SolrQuery::setHighlightAlternateField — Specifies the backup field to use

说明

public SolrQuery::setHighlightAlternateField ( string $field , string $field_override = ? ) : SolrQuery

If a snippet cannot be generated because there were no matching terms, one can specify a field to use as the backup or default summary

参数

field

The name of the backup field

field_override

The name of the field we are overriding this setting for.

返回值

Returns the current SolrQuery object, if the return value is used.


Specify a formatter for the highlight output

  • ? SolrQuery::setHighlightAlternateField
  • SolrQuery::setHighlightFragmenter ?
  • PHP Manual
  • SolrQuery
  • Specify a formatter for the highlight output

SolrQuery::setHighlightFormatter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFormatter — Specify a formatter for the highlight output

说明

public SolrQuery::setHighlightFormatter ( string $formatter , string $field_override = ? ) : SolrQuery

Specify a formatter for the highlight output.

参数

formatter

Currently the only legal value is "simple"

field_override

The name of the field.


Sets a text snippet generator for highlighted text

  • ? SolrQuery::setHighlightFormatter
  • SolrQuery::setHighlightFragsize ?
  • PHP Manual
  • SolrQuery
  • Sets a text snippet generator for highlighted text

SolrQuery::setHighlightFragmenter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFragmenter — Sets a text snippet generator for highlighted text

说明

public SolrQuery::setHighlightFragmenter ( string $fragmenter , string $field_override = ? ) : SolrQuery

Specify a text snippet generator for highlighted text.

参数

fragmenter

The standard fragmenter is gap. Another option is regex, which tries to create fragments that resembles a certain regular expression

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


The size of fragments to consider for highlighting

  • ? SolrQuery::setHighlightFragmenter
  • SolrQuery::setHighlightHighlightMultiTerm ?
  • PHP Manual
  • SolrQuery
  • The size of fragments to consider for highlighting

SolrQuery::setHighlightFragsize

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFragsize — The size of fragments to consider for highlighting

说明

public SolrQuery::setHighlightFragsize ( int $size , string $field_override = ? ) : SolrQuery

Sets the size, in characters, of fragments to consider for highlighting. "0" indicates that the whole field value should be used (no fragmenting).

参数

size

The size, in characters, of fragments to consider for highlighting

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Use SpanScorer to highlight phrase terms

  • ? SolrQuery::setHighlightFragsize
  • SolrQuery::setHighlightMaxAlternateFieldLength ?
  • PHP Manual
  • SolrQuery
  • Use SpanScorer to highlight phrase terms

SolrQuery::setHighlightHighlightMultiTerm

(PECL solr >= 0.9.2)

SolrQuery::setHighlightHighlightMultiTerm — Use SpanScorer to highlight phrase terms

说明

public SolrQuery::setHighlightHighlightMultiTerm ( bool $flag ) : SolrQuery

Use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document.

参数

flag

Whether or not to use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document.

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the maximum number of characters of the field to return

  • ? SolrQuery::setHighlightHighlightMultiTerm
  • SolrQuery::setHighlightMaxAnalyzedChars ?
  • PHP Manual
  • SolrQuery
  • Sets the maximum number of characters of the field to return

SolrQuery::setHighlightMaxAlternateFieldLength

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMaxAlternateFieldLength — Sets the maximum number of characters of the field to return

说明

public SolrQuery::setHighlightMaxAlternateFieldLength ( int $fieldLength , string $field_override = ? ) : SolrQuery

If SolrQuery::setHighlightAlternateField() was passed the value true, this parameter specifies the maximum number of characters of the field to return

Any value less than or equal to 0 means unlimited.

参数

fieldLength

The length of the field

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Specifies the number of characters into a document to look for suitable snippets

  • ? SolrQuery::setHighlightMaxAlternateFieldLength
  • SolrQuery::setHighlightMergeContiguous ?
  • PHP Manual
  • SolrQuery
  • Specifies the number of characters into a document to look for suitable snippets

SolrQuery::setHighlightMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMaxAnalyzedChars — Specifies the number of characters into a document to look for suitable snippets

说明

public SolrQuery::setHighlightMaxAnalyzedChars ( int $value ) : SolrQuery

Specifies the number of characters into a document to look for suitable snippets

参数

value

The number of characters into a document to look for suitable snippets

返回值

Returns the current SolrQuery object, if the return value is used.


Whether or not to collapse contiguous fragments into a single fragment

  • ? SolrQuery::setHighlightMaxAnalyzedChars
  • SolrQuery::setHighlightRegexMaxAnalyzedChars ?
  • PHP Manual
  • SolrQuery
  • Whether or not to collapse contiguous fragments into a single fragment

SolrQuery::setHighlightMergeContiguous

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMergeContiguous — Whether or not to collapse contiguous fragments into a single fragment

说明

public SolrQuery::setHighlightMergeContiguous ( bool $flag , string $field_override = ? ) : SolrQuery

Whether or not to collapse contiguous fragments into a single fragment

参数

value

Whether or not to collapse contiguous fragments into a single fragment

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Specify the maximum number of characters to analyze

  • ? SolrQuery::setHighlightMergeContiguous
  • SolrQuery::setHighlightRegexPattern ?
  • PHP Manual
  • SolrQuery
  • Specify the maximum number of characters to analyze

SolrQuery::setHighlightRegexMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexMaxAnalyzedChars — Specify the maximum number of characters to analyze

说明

public SolrQuery::setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars ) : SolrQuery

Specify the maximum number of characters to analyze from a field when using the regex fragmenter

参数

maxAnalyzedChars

The maximum number of characters to analyze from a field when using the regex fragmenter

返回值

Returns the current SolrQuery object, if the return value is used.


Specify the regular expression for fragmenting

  • ? SolrQuery::setHighlightRegexMaxAnalyzedChars
  • SolrQuery::setHighlightRegexSlop ?
  • PHP Manual
  • SolrQuery
  • Specify the regular expression for fragmenting

SolrQuery::setHighlightRegexPattern

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexPattern — Specify the regular expression for fragmenting

说明

public SolrQuery::setHighlightRegexPattern ( string $value ) : SolrQuery

Specifies the regular expression for fragmenting. This could be used to extract sentences

参数

value

The regular expression for fragmenting. This could be used to extract sentences

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the factor by which the regex fragmenter can stray from the ideal fragment size

  • ? SolrQuery::setHighlightRegexPattern
  • SolrQuery::setHighlightRequireFieldMatch ?
  • PHP Manual
  • SolrQuery
  • Sets the factor by which the regex fragmenter can stray from the ideal fragment size

SolrQuery::setHighlightRegexSlop

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexSlop — Sets the factor by which the regex fragmenter can stray from the ideal fragment size

说明

public SolrQuery::setHighlightRegexSlop ( float $factor ) : SolrQuery

The factor by which the regex fragmenter can stray from the ideal fragment size ( specfied by SolrQuery::setHighlightFragsize )to accommodate the regular expression

参数

factor

The factor by which the regex fragmenter can stray from the ideal fragment size

返回值

Returns the current SolrQuery object, if the return value is used.


Require field matching during highlighting

  • ? SolrQuery::setHighlightRegexSlop
  • SolrQuery::setHighlightSimplePost ?
  • PHP Manual
  • SolrQuery
  • Require field matching during highlighting

SolrQuery::setHighlightRequireFieldMatch

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRequireFieldMatch — Require field matching during highlighting

说明

public SolrQuery::setHighlightRequireFieldMatch ( bool $flag ) : SolrQuery

If true, then a field will only be highlighted if the query matched in this particular field.

This will only work if SolrQuery::setHighlightUsePhraseHighlighter() was set to true

参数

flag

true or false

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the text which appears after a highlighted term

  • ? SolrQuery::setHighlightRequireFieldMatch
  • SolrQuery::setHighlightSimplePre ?
  • PHP Manual
  • SolrQuery
  • Sets the text which appears after a highlighted term

SolrQuery::setHighlightSimplePost

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSimplePost — Sets the text which appears after a highlighted term

说明

public SolrQuery::setHighlightSimplePost ( string $simplePost , string $field_override = ? ) : SolrQuery

Sets the text which appears before a highlighted term

参数

simplePost

Sets the text which appears after a highlighted term

The default is </em>

field_override

The name of the field.


Sets the text which appears before a highlighted term

  • ? SolrQuery::setHighlightSimplePost
  • SolrQuery::setHighlightSnippets ?
  • PHP Manual
  • SolrQuery
  • Sets the text which appears before a highlighted term

SolrQuery::setHighlightSimplePre

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSimplePre — Sets the text which appears before a highlighted term

说明

public SolrQuery::setHighlightSimplePre ( string $simplePre , string $field_override = ? ) : SolrQuery

Sets the text which appears before a highlighted term

The default is <em>

参数

simplePre

The text which appears before a highlighted term

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the maximum number of highlighted snippets to generate per field

  • ? SolrQuery::setHighlightSimplePre
  • SolrQuery::setHighlightUsePhraseHighlighter ?
  • PHP Manual
  • SolrQuery
  • Sets the maximum number of highlighted snippets to generate per field

SolrQuery::setHighlightSnippets

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSnippets — Sets the maximum number of highlighted snippets to generate per field

说明

public SolrQuery::setHighlightSnippets ( int $value , string $field_override = ? ) : SolrQuery

Sets the maximum number of highlighted snippets to generate per field

参数

value

The maximum number of highlighted snippets to generate per field

field_override

The name of the field.

返回值

Returns the current SolrQuery object, if the return value is used.


Whether to highlight phrase terms only when they appear within the query phrase

  • ? SolrQuery::setHighlightSnippets
  • SolrQuery::setMlt ?
  • PHP Manual
  • SolrQuery
  • Whether to highlight phrase terms only when they appear within the query phrase

SolrQuery::setHighlightUsePhraseHighlighter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightUsePhraseHighlighter — Whether to highlight phrase terms only when they appear within the query phrase

说明

public SolrQuery::setHighlightUsePhraseHighlighter ( bool $flag ) : SolrQuery

Sets whether or not to use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document

参数

value

Whether or not to use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document

返回值

Returns the current SolrQuery object, if the return value is used.


Enables or disables moreLikeThis

  • ? SolrQuery::setHighlightUsePhraseHighlighter
  • SolrQuery::setMltBoost ?
  • PHP Manual
  • SolrQuery
  • Enables or disables moreLikeThis

SolrQuery::setMlt

(PECL solr >= 0.9.2)

SolrQuery::setMlt — Enables or disables moreLikeThis

说明

public SolrQuery::setMlt ( bool $flag ) : SolrQuery

Enables or disables moreLikeThis

参数

flag

true enables it and false turns it off.

返回值

Returns the current SolrQuery object, if the return value is used.


Set if the query will be boosted by the interesting term relevance

  • ? SolrQuery::setMlt
  • SolrQuery::setMltCount ?
  • PHP Manual
  • SolrQuery
  • Set if the query will be boosted by the interesting term relevance

SolrQuery::setMltBoost

(PECL solr >= 0.9.2)

SolrQuery::setMltBoost — Set if the query will be boosted by the interesting term relevance

说明

public SolrQuery::setMltBoost ( bool $flag ) : SolrQuery

Set if the query will be boosted by the interesting term relevance

参数

value

Sets to true or false

返回值

Returns the current SolrQuery object, if the return value is used.


Set the number of similar documents to return for each result

  • ? SolrQuery::setMltBoost
  • SolrQuery::setMltMaxNumQueryTerms ?
  • PHP Manual
  • SolrQuery
  • Set the number of similar documents to return for each result

SolrQuery::setMltCount

(PECL solr >= 0.9.2)

SolrQuery::setMltCount — Set the number of similar documents to return for each result

说明

public SolrQuery::setMltCount ( int $count ) : SolrQuery

Set the number of similar documents to return for each result

参数

count

The number of similar documents to return for each result

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the maximum number of query terms included

  • ? SolrQuery::setMltCount
  • SolrQuery::setMltMaxNumTokens ?
  • PHP Manual
  • SolrQuery
  • Sets the maximum number of query terms included

SolrQuery::setMltMaxNumQueryTerms

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxNumQueryTerms — Sets the maximum number of query terms included

说明

public SolrQuery::setMltMaxNumQueryTerms ( int $value ) : SolrQuery

Sets the maximum number of query terms that will be included in any generated query.

参数

value

The maximum number of query terms that will be included in any generated query

返回值

Returns the current SolrQuery object, if the return value is used.


Specifies the maximum number of tokens to parse

  • ? SolrQuery::setMltMaxNumQueryTerms
  • SolrQuery::setMltMaxWordLength ?
  • PHP Manual
  • SolrQuery
  • Specifies the maximum number of tokens to parse

SolrQuery::setMltMaxNumTokens

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxNumTokens — Specifies the maximum number of tokens to parse

说明

public SolrQuery::setMltMaxNumTokens ( int $value ) : SolrQuery

Specifies the maximum number of tokens to parse in each example doc field that is not stored with TermVector support.

参数

value

The maximum number of tokens to parse

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the maximum word length

  • ? SolrQuery::setMltMaxNumTokens
  • SolrQuery::setMltMinDocFrequency ?
  • PHP Manual
  • SolrQuery
  • Sets the maximum word length

SolrQuery::setMltMaxWordLength

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxWordLength — Sets the maximum word length

说明

public SolrQuery::setMltMaxWordLength ( int $maxWordLength ) : SolrQuery

Sets the maximum word length above which words will be ignored.

参数

maxWordLength

The maximum word length above which words will be ignored

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the mltMinDoc frequency

  • ? SolrQuery::setMltMaxWordLength
  • SolrQuery::setMltMinTermFrequency ?
  • PHP Manual
  • SolrQuery
  • Sets the mltMinDoc frequency

SolrQuery::setMltMinDocFrequency

(PECL solr >= 0.9.2)

SolrQuery::setMltMinDocFrequency — Sets the mltMinDoc frequency

说明

public SolrQuery::setMltMinDocFrequency ( int $minDocFrequency ) : SolrQuery

The frequency at which words will be ignored which do not occur in at least this many docs.

参数

minDocFrequency

Sets the frequency at which words will be ignored which do not occur in at least this many docs.

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the frequency below which terms will be ignored in the source docs

  • ? SolrQuery::setMltMinDocFrequency
  • SolrQuery::setMltMinWordLength ?
  • PHP Manual
  • SolrQuery
  • Sets the frequency below which terms will be ignored in the source docs

SolrQuery::setMltMinTermFrequency

(PECL solr >= 0.9.2)

SolrQuery::setMltMinTermFrequency — Sets the frequency below which terms will be ignored in the source docs

说明

public SolrQuery::setMltMinTermFrequency ( int $minTermFrequency ) : SolrQuery

Sets the frequency below which terms will be ignored in the source docs

参数

minTermFrequency

The frequency below which terms will be ignored in the source docs

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the minimum word length

  • ? SolrQuery::setMltMinTermFrequency
  • SolrQuery::setOmitHeader ?
  • PHP Manual
  • SolrQuery
  • Sets the minimum word length

SolrQuery::setMltMinWordLength

(PECL solr >= 0.9.2)

SolrQuery::setMltMinWordLength — Sets the minimum word length

说明

public SolrQuery::setMltMinWordLength ( int $minWordLength ) : SolrQuery

Sets the minimum word length below which words will be ignored.

参数

minWordLength

The minimum word length below which words will be ignored

返回值

Returns the current SolrQuery object, if the return value is used.


Exclude the header from the returned results

  • ? SolrQuery::setMltMinWordLength
  • SolrQuery::setQuery ?
  • PHP Manual
  • SolrQuery
  • Exclude the header from the returned results

SolrQuery::setOmitHeader

(PECL solr >= 0.9.2)

SolrQuery::setOmitHeader — Exclude the header from the returned results

说明

public SolrQuery::setOmitHeader ( bool $flag ) : SolrQuery

Exclude the header from the returned results.

参数

flag

true excludes the header from the result.

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the search query

  • ? SolrQuery::setOmitHeader
  • SolrQuery::setRows ?
  • PHP Manual
  • SolrQuery
  • Sets the search query

SolrQuery::setQuery

(PECL solr >= 0.9.2)

SolrQuery::setQuery — Sets the search query

说明

public SolrQuery::setQuery ( string $query ) : SolrQuery

Sets the search query.

参数

query

The search query

返回值

Returns the current SolrQuery object


Specifies the maximum number of rows to return in the result

  • ? SolrQuery::setQuery
  • SolrQuery::setShowDebugInfo ?
  • PHP Manual
  • SolrQuery
  • Specifies the maximum number of rows to return in the result

SolrQuery::setRows

(PECL solr >= 0.9.2)

SolrQuery::setRows — Specifies the maximum number of rows to return in the result

说明

public SolrQuery::setRows ( int $rows ) : SolrQuery

Specifies the maximum number of rows to return in the result

参数

rows

The maximum number of rows to return

返回值

Returns the current SolrQuery object.


Flag to show debug information

  • ? SolrQuery::setRows
  • SolrQuery::setStart ?
  • PHP Manual
  • SolrQuery
  • Flag to show debug information

SolrQuery::setShowDebugInfo

(PECL solr >= 0.9.2)

SolrQuery::setShowDebugInfo — Flag to show debug information

说明

public SolrQuery::setShowDebugInfo ( bool $flag ) : SolrQuery

Whether to show debug info

参数

flag

Whether to show debug info. true or false

返回值

Returns the current SolrQuery object, if the return value is used.


Specifies the number of rows to skip

  • ? SolrQuery::setShowDebugInfo
  • SolrQuery::setStats ?
  • PHP Manual
  • SolrQuery
  • Specifies the number of rows to skip

SolrQuery::setStart

(PECL solr >= 0.9.2)

SolrQuery::setStart — Specifies the number of rows to skip

说明

public SolrQuery::setStart ( int $start ) : SolrQuery

Specifies the number of rows to skip. Useful in pagination of results.

参数

start

The number of rows to skip.

返回值

Returns the current SolrQuery object.


Enables or disables the Stats component

  • ? SolrQuery::setStart
  • SolrQuery::setTerms ?
  • PHP Manual
  • SolrQuery
  • Enables or disables the Stats component

SolrQuery::setStats

(PECL solr >= 0.9.2)

SolrQuery::setStats — Enables or disables the Stats component

说明

public SolrQuery::setStats ( bool $flag ) : SolrQuery

Enables or disables the Stats component.

参数

flag

true turns on the stats component and false disables it.

返回值

Returns the current SolrQuery object, if the return value is used.


Enables or disables the TermsComponent

  • ? SolrQuery::setStats
  • SolrQuery::setTermsField ?
  • PHP Manual
  • SolrQuery
  • Enables or disables the TermsComponent

SolrQuery::setTerms

(PECL solr >= 0.9.2)

SolrQuery::setTerms — Enables or disables the TermsComponent

说明

public SolrQuery::setTerms ( bool $flag ) : SolrQuery

Enables or disables the TermsComponent

参数

flag

true enables it. false turns it off

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the name of the field to get the Terms from

  • ? SolrQuery::setTerms
  • SolrQuery::setTermsIncludeLowerBound ?
  • PHP Manual
  • SolrQuery
  • Sets the name of the field to get the Terms from

SolrQuery::setTermsField

(PECL solr >= 0.9.2)

SolrQuery::setTermsField — Sets the name of the field to get the Terms from

说明

public SolrQuery::setTermsField ( string $fieldname ) : SolrQuery

Sets the name of the field to get the terms from

参数

fieldname

The field name

返回值

Returns the current SolrQuery object, if the return value is used.


Include the lower bound term in the result set

  • ? SolrQuery::setTermsField
  • SolrQuery::setTermsIncludeUpperBound ?
  • PHP Manual
  • SolrQuery
  • Include the lower bound term in the result set

SolrQuery::setTermsIncludeLowerBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsIncludeLowerBound — Include the lower bound term in the result set

说明

public SolrQuery::setTermsIncludeLowerBound ( bool $flag ) : SolrQuery

Include the lower bound term in the result set.

参数

flag

Include the lower bound term in the result set

返回值

Returns the current SolrQuery object, if the return value is used.


Include the upper bound term in the result set

  • ? SolrQuery::setTermsIncludeLowerBound
  • SolrQuery::setTermsLimit ?
  • PHP Manual
  • SolrQuery
  • Include the upper bound term in the result set

SolrQuery::setTermsIncludeUpperBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsIncludeUpperBound — Include the upper bound term in the result set

说明

public SolrQuery::setTermsIncludeUpperBound ( bool $flag ) : SolrQuery

Include the upper bound term in the result set.

参数

flag

true or false

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the maximum number of terms to return

  • ? SolrQuery::setTermsIncludeUpperBound
  • SolrQuery::setTermsLowerBound ?
  • PHP Manual
  • SolrQuery
  • Sets the maximum number of terms to return

SolrQuery::setTermsLimit

(PECL solr >= 0.9.2)

SolrQuery::setTermsLimit — Sets the maximum number of terms to return

说明

public SolrQuery::setTermsLimit ( int $limit ) : SolrQuery

Sets the maximum number of terms to return

参数

limit

The maximum number of terms to return. All the terms will be returned if the limit is negative.

返回值

Returns the current SolrQuery object, if the return value is used.


Specifies the Term to start from

  • ? SolrQuery::setTermsLimit
  • SolrQuery::setTermsMaxCount ?
  • PHP Manual
  • SolrQuery
  • Specifies the Term to start from

SolrQuery::setTermsLowerBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsLowerBound — Specifies the Term to start from

说明

public SolrQuery::setTermsLowerBound ( string $lowerBound ) : SolrQuery

Specifies the Term to start from

参数

lowerBound

The lower bound Term

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the maximum document frequency

  • ? SolrQuery::setTermsLowerBound
  • SolrQuery::setTermsMinCount ?
  • PHP Manual
  • SolrQuery
  • Sets the maximum document frequency

SolrQuery::setTermsMaxCount

(PECL solr >= 0.9.2)

SolrQuery::setTermsMaxCount — Sets the maximum document frequency

说明

public SolrQuery::setTermsMaxCount ( int $frequency ) : SolrQuery

Sets the maximum document frequency.

参数

frequency

The maximum document frequency.

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the minimum document frequency

  • ? SolrQuery::setTermsMaxCount
  • SolrQuery::setTermsPrefix ?
  • PHP Manual
  • SolrQuery
  • Sets the minimum document frequency

SolrQuery::setTermsMinCount

(PECL solr >= 0.9.2)

SolrQuery::setTermsMinCount — Sets the minimum document frequency

说明

public SolrQuery::setTermsMinCount ( int $frequency ) : SolrQuery

Sets the minimum doc frequency to return in order to be included

参数

frequency

The minimum frequency

返回值

Returns the current SolrQuery object, if the return value is used.


Restrict matches to terms that start with the prefix

  • ? SolrQuery::setTermsMinCount
  • SolrQuery::setTermsReturnRaw ?
  • PHP Manual
  • SolrQuery
  • Restrict matches to terms that start with the prefix

SolrQuery::setTermsPrefix

(PECL solr >= 0.9.2)

SolrQuery::setTermsPrefix — Restrict matches to terms that start with the prefix

说明

public SolrQuery::setTermsPrefix ( string $prefix ) : SolrQuery

Restrict matches to terms that start with the prefix

参数

prefix

Restrict matches to terms that start with the prefix

返回值

Returns the current SolrQuery object, if the return value is used.


Return the raw characters of the indexed term

  • ? SolrQuery::setTermsPrefix
  • SolrQuery::setTermsSort ?
  • PHP Manual
  • SolrQuery
  • Return the raw characters of the indexed term

SolrQuery::setTermsReturnRaw

(PECL solr >= 0.9.2)

SolrQuery::setTermsReturnRaw — Return the raw characters of the indexed term

说明

public SolrQuery::setTermsReturnRaw ( bool $flag ) : SolrQuery

If true, return the raw characters of the indexed term, regardless of if it is human readable

参数

value

true or false

返回值

Returns the current SolrQuery object, if the return value is used.


Specifies how to sort the returned terms

  • ? SolrQuery::setTermsReturnRaw
  • SolrQuery::setTermsUpperBound ?
  • PHP Manual
  • SolrQuery
  • Specifies how to sort the returned terms

SolrQuery::setTermsSort

(PECL solr >= 0.9.2)

SolrQuery::setTermsSort — Specifies how to sort the returned terms

说明

public SolrQuery::setTermsSort ( int $sortType ) : SolrQuery

If SolrQuery::TERMS_SORT_COUNT, sorts the terms by the term frequency (highest count first). If SolrQuery::TERMS_SORT_INDEX, returns the terms in index order

参数

sortType

SolrQuery::TERMS_SORT_INDEX or SolrQuery::TERMS_SORT_COUNT

返回值

Returns the current SolrQuery object, if the return value is used.


Sets the term to stop at

  • ? SolrQuery::setTermsSort
  • SolrQuery::setTimeAllowed ?
  • PHP Manual
  • SolrQuery
  • Sets the term to stop at

SolrQuery::setTermsUpperBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsUpperBound — Sets the term to stop at

说明

public SolrQuery::setTermsUpperBound ( string $upperBound ) : SolrQuery

Sets the term to stop at

参数

upperBound

The term to stop at

返回值

Returns the current SolrQuery object, if the return value is used.


The time allowed for search to finish

  • ? SolrQuery::setTermsUpperBound
  • SolrDisMaxQuery ?
  • PHP Manual
  • SolrQuery
  • The time allowed for search to finish

SolrQuery::setTimeAllowed

(PECL solr >= 0.9.2)

SolrQuery::setTimeAllowed — The time allowed for search to finish

说明

public SolrQuery::setTimeAllowed ( int $timeAllowed ) : SolrQuery

The time allowed for a search to finish. This value only applies to the search and not to requests in general. Time is in milliseconds. Values less than or equal to zero implies no time restriction. Partial results may be returned, if there are any.

参数

timeAllowed

The time allowed for a search to finish.

返回值

Returns the current SolrQuery object, if the return value is used.


The SolrDisMaxQuery class

(No version information available, might only be in Git)

简介

类摘要

SolrDisMaxQuery extends SolrQuery implements Serializable {
/* 继承的属性 */
const int SolrQuery::ORDER_ASC = 0 ;
const int SolrQuery::ORDER_DESC = 1 ;
const int SolrQuery::FACET_SORT_INDEX = 0 ;
const int SolrQuery::FACET_SORT_COUNT = 1 ;
const int SolrQuery::TERMS_SORT_INDEX = 0 ;
const int SolrQuery::TERMS_SORT_COUNT = 1 ;
/* 方法 */
public addBigramPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery
public addBoostQuery ( string $field , string $value , string $boost = ? ) : SolrDisMaxQuery
public addPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery
public addQueryField ( string $field , string $boost = ? ) : SolrDisMaxQuery
public addTrigramPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery
public addUserField ( string $field ) : SolrDisMaxQuery
public __construct ( string $q = ? )
public removeBigramPhraseField ( string $field ) : SolrDisMaxQuery
public removeBoostQuery ( string $field ) : SolrDisMaxQuery
public removePhraseField ( string $field ) : SolrDisMaxQuery
public removeQueryField ( string $field ) : SolrDisMaxQuery
public removeTrigramPhraseField ( string $field ) : SolrDisMaxQuery
public removeUserField ( string $field ) : SolrDisMaxQuery
public setBigramPhraseFields ( string $fields ) : SolrDisMaxQuery
public setBigramPhraseSlop ( string $slop ) : SolrDisMaxQuery
public setBoostFunction ( string $function ) : SolrDisMaxQuery
public setBoostQuery ( string $q ) : SolrDisMaxQuery
public setMinimumMatch ( string $value ) : SolrDisMaxQuery
public setPhraseFields ( string $fields ) : SolrDisMaxQuery
public setPhraseSlop ( string $slop ) : SolrDisMaxQuery
public setQueryAlt ( string $q ) : SolrDisMaxQuery
public setQueryPhraseSlop ( string $slop ) : SolrDisMaxQuery
public setTieBreaker ( string $tieBreaker ) : SolrDisMaxQuery
public setTrigramPhraseFields ( string $fields ) : SolrDisMaxQuery
public setTrigramPhraseSlop ( string $slop ) : SolrDisMaxQuery
public setUserFields ( string $fields ) : SolrDisMaxQuery
public useDisMaxQueryParser ( ) : SolrDisMaxQuery
public useEDisMaxQueryParser ( ) : SolrDisMaxQuery
/* 继承的方法 */
public SolrQuery::addExpandFilterQuery ( string $fq ) : SolrQuery
public SolrQuery::addExpandSortField ( string $field , string $order = ? ) : SolrQuery
public SolrQuery::addFacetDateField ( string $dateField ) : SolrQuery
public SolrQuery::addFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::addFacetField ( string $field ) : SolrQuery
public SolrQuery::addFacetQuery ( string $facetQuery ) : SolrQuery
public SolrQuery::addField ( string $field ) : SolrQuery
public SolrQuery::addFilterQuery ( string $fq ) : SolrQuery
public SolrQuery::addGroupField ( string $value ) : SolrQuery
public SolrQuery::addGroupFunction ( string $value ) : SolrQuery
public SolrQuery::addGroupQuery ( string $value ) : SolrQuery
public SolrQuery::addGroupSortField ( string $field , int $order = ? ) : SolrQuery
public SolrQuery::addHighlightField ( string $field ) : SolrQuery
public SolrQuery::addMltField ( string $field ) : SolrQuery
public SolrQuery::addMltQueryField ( string $field , float $boost ) : SolrQuery
public SolrQuery::addSortField ( string $field , int $order = SolrQuery::ORDER_DESC ) : SolrQuery
public SolrQuery::addStatsFacet ( string $field ) : SolrQuery
public SolrQuery::addStatsField ( string $field ) : SolrQuery
public SolrQuery::collapse ( SolrCollapseFunction $collapseFunction ) : SolrQuery
public SolrQuery::__construct ( string $q = ? )
public SolrQuery::__destruct ( ) : void
public SolrQuery::getExpand ( ) : bool
public SolrQuery::getExpandFilterQueries ( ) : array
public SolrQuery::getExpandQuery ( ) : array
public SolrQuery::getExpandRows ( ) : int
public SolrQuery::getExpandSortFields ( ) : array
public SolrQuery::getFacet ( ) : bool
public SolrQuery::getFacetDateEnd ( string $field_override = ? ) : string
public SolrQuery::getFacetDateFields ( ) : array
public SolrQuery::getFacetDateGap ( string $field_override = ? ) : string
public SolrQuery::getFacetDateHardEnd ( string $field_override = ? ) : string
public SolrQuery::getFacetDateOther ( string $field_override = ? ) : array
public SolrQuery::getFacetDateStart ( string $field_override = ? ) : string
public SolrQuery::getFacetFields ( ) : array
public SolrQuery::getFacetLimit ( string $field_override = ? ) : int
public SolrQuery::getFacetMethod ( string $field_override = ? ) : string
public SolrQuery::getFacetMinCount ( string $field_override = ? ) : int
public SolrQuery::getFacetMissing ( string $field_override = ? ) : bool
public SolrQuery::getFacetOffset ( string $field_override = ? ) : int
public SolrQuery::getFacetPrefix ( string $field_override = ? ) : string
public SolrQuery::getFacetQueries ( ) : array
public SolrQuery::getFacetSort ( string $field_override = ? ) : int
public SolrQuery::getFields ( ) : array
public SolrQuery::getFilterQueries ( ) : array
public SolrQuery::getGroup ( ) : bool
public SolrQuery::getGroupCachePercent ( ) : int
public SolrQuery::getGroupFacet ( ) : bool
public SolrQuery::getGroupFields ( ) : array
public SolrQuery::getGroupFormat ( ) : string
public SolrQuery::getGroupFunctions ( ) : array
public SolrQuery::getGroupLimit ( ) : int
public SolrQuery::getGroupMain ( ) : bool
public SolrQuery::getGroupNGroups ( ) : bool
public SolrQuery::getGroupOffset ( ) : int
public SolrQuery::getGroupQueries ( ) : array
public SolrQuery::getGroupSortFields ( ) : array
public SolrQuery::getGroupTruncate ( ) : bool
public SolrQuery::getHighlight ( ) : bool
public SolrQuery::getHighlightAlternateField ( string $field_override = ? ) : string
public SolrQuery::getHighlightFields ( ) : array
public SolrQuery::getHighlightFormatter ( string $field_override = ? ) : string
public SolrQuery::getHighlightFragmenter ( string $field_override = ? ) : string
public SolrQuery::getHighlightFragsize ( string $field_override = ? ) : int
public SolrQuery::getHighlightHighlightMultiTerm ( ) : bool
public SolrQuery::getHighlightMaxAlternateFieldLength ( string $field_override = ? ) : int
public SolrQuery::getHighlightMaxAnalyzedChars ( ) : int
public SolrQuery::getHighlightMergeContiguous ( string $field_override = ? ) : bool
public SolrQuery::getHighlightRegexMaxAnalyzedChars ( ) : int
public SolrQuery::getHighlightRegexPattern ( ) : string
public SolrQuery::getHighlightRegexSlop ( ) : float
public SolrQuery::getHighlightRequireFieldMatch ( ) : bool
public SolrQuery::getHighlightSimplePost ( string $field_override = ? ) : string
public SolrQuery::getHighlightSimplePre ( string $field_override = ? ) : string
public SolrQuery::getHighlightSnippets ( string $field_override = ? ) : int
public SolrQuery::getHighlightUsePhraseHighlighter ( ) : bool
public SolrQuery::getMlt ( ) : bool
public SolrQuery::getMltBoost ( ) : bool
public SolrQuery::getMltCount ( ) : int
public SolrQuery::getMltFields ( ) : array
public SolrQuery::getMltMaxNumQueryTerms ( ) : int
public SolrQuery::getMltMaxNumTokens ( ) : int
public SolrQuery::getMltMaxWordLength ( ) : int
public SolrQuery::getMltMinDocFrequency ( ) : int
public SolrQuery::getMltMinTermFrequency ( ) : int
public SolrQuery::getMltMinWordLength ( ) : int
public SolrQuery::getMltQueryFields ( ) : array
public SolrQuery::getQuery ( ) : string
public SolrQuery::getRows ( ) : int
public SolrQuery::getSortFields ( ) : array
public SolrQuery::getStart ( ) : int
public SolrQuery::getStats ( ) : bool
public SolrQuery::getStatsFacets ( ) : array
public SolrQuery::getStatsFields ( ) : array
public SolrQuery::getTerms ( ) : bool
public SolrQuery::getTermsField ( ) : string
public SolrQuery::getTermsIncludeLowerBound ( ) : bool
public SolrQuery::getTermsIncludeUpperBound ( ) : bool
public SolrQuery::getTermsLimit ( ) : int
public SolrQuery::getTermsLowerBound ( ) : string
public SolrQuery::getTermsMaxCount ( ) : int
public SolrQuery::getTermsMinCount ( ) : int
public SolrQuery::getTermsPrefix ( ) : string
public SolrQuery::getTermsReturnRaw ( ) : bool
public SolrQuery::getTermsSort ( ) : int
public SolrQuery::getTermsUpperBound ( ) : string
public SolrQuery::getTimeAllowed ( ) : int
public SolrQuery::removeExpandFilterQuery ( string $fq ) : SolrQuery
public SolrQuery::removeExpandSortField ( string $field ) : SolrQuery
public SolrQuery::removeFacetDateField ( string $field ) : SolrQuery
public SolrQuery::removeFacetDateOther ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::removeFacetField ( string $field ) : SolrQuery
public SolrQuery::removeFacetQuery ( string $value ) : SolrQuery
public SolrQuery::removeField ( string $field ) : SolrQuery
public SolrQuery::removeFilterQuery ( string $fq ) : SolrQuery
public SolrQuery::removeHighlightField ( string $field ) : SolrQuery
public SolrQuery::removeMltField ( string $field ) : SolrQuery
public SolrQuery::removeMltQueryField ( string $queryField ) : SolrQuery
public SolrQuery::removeSortField ( string $field ) : SolrQuery
public SolrQuery::removeStatsFacet ( string $value ) : SolrQuery
public SolrQuery::removeStatsField ( string $field ) : SolrQuery
public SolrQuery::setEchoHandler ( bool $flag ) : SolrQuery
public SolrQuery::setEchoParams ( string $type ) : SolrQuery
public SolrQuery::setExpand ( bool $value ) : SolrQuery
public SolrQuery::setExpandQuery ( string $q ) : SolrQuery
public SolrQuery::setExpandRows ( int $value ) : SolrQuery
public SolrQuery::setExplainOther ( string $query ) : SolrQuery
public SolrQuery::setFacet ( bool $flag ) : SolrQuery
public SolrQuery::setFacetDateEnd ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetDateGap ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetDateHardEnd ( bool $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetDateStart ( string $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetEnumCacheMinDefaultFrequency ( int $frequency , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetLimit ( int $limit , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetMethod ( string $method , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetMinCount ( int $mincount , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetMissing ( bool $flag , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetOffset ( int $offset , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetPrefix ( string $prefix , string $field_override = ? ) : SolrQuery
public SolrQuery::setFacetSort ( int $facetSort , string $field_override = ? ) : SolrQuery
public SolrQuery::setGroup ( bool $value ) : SolrQuery
public SolrQuery::setGroupCachePercent ( int $percent ) : SolrQuery
public SolrQuery::setGroupFacet ( bool $value ) : SolrQuery
public SolrQuery::setGroupFormat ( string $value ) : SolrQuery
public SolrQuery::setGroupLimit ( int $value ) : SolrQuery
public SolrQuery::setGroupMain ( string $value ) : SolrQuery
public SolrQuery::setGroupNGroups ( bool $value ) : SolrQuery
public SolrQuery::setGroupOffset ( int $value ) : SolrQuery
public SolrQuery::setGroupTruncate ( bool $value ) : SolrQuery
public SolrQuery::setHighlight ( bool $flag ) : SolrQuery
public SolrQuery::setHighlightAlternateField ( string $field , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightFormatter ( string $formatter , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightFragmenter ( string $fragmenter , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightFragsize ( int $size , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightHighlightMultiTerm ( bool $flag ) : SolrQuery
public SolrQuery::setHighlightMaxAlternateFieldLength ( int $fieldLength , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightMaxAnalyzedChars ( int $value ) : SolrQuery
public SolrQuery::setHighlightMergeContiguous ( bool $flag , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars ) : SolrQuery
public SolrQuery::setHighlightRegexPattern ( string $value ) : SolrQuery
public SolrQuery::setHighlightRegexSlop ( float $factor ) : SolrQuery
public SolrQuery::setHighlightRequireFieldMatch ( bool $flag ) : SolrQuery
public SolrQuery::setHighlightSimplePost ( string $simplePost , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightSimplePre ( string $simplePre , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightSnippets ( int $value , string $field_override = ? ) : SolrQuery
public SolrQuery::setHighlightUsePhraseHighlighter ( bool $flag ) : SolrQuery
public SolrQuery::setMlt ( bool $flag ) : SolrQuery
public SolrQuery::setMltBoost ( bool $flag ) : SolrQuery
public SolrQuery::setMltCount ( int $count ) : SolrQuery
public SolrQuery::setMltMaxNumQueryTerms ( int $value ) : SolrQuery
public SolrQuery::setMltMaxNumTokens ( int $value ) : SolrQuery
public SolrQuery::setMltMaxWordLength ( int $maxWordLength ) : SolrQuery
public SolrQuery::setMltMinDocFrequency ( int $minDocFrequency ) : SolrQuery
public SolrQuery::setMltMinTermFrequency ( int $minTermFrequency ) : SolrQuery
public SolrQuery::setMltMinWordLength ( int $minWordLength ) : SolrQuery
public SolrQuery::setOmitHeader ( bool $flag ) : SolrQuery
public SolrQuery::setQuery ( string $query ) : SolrQuery
public SolrQuery::setRows ( int $rows ) : SolrQuery
public SolrQuery::setShowDebugInfo ( bool $flag ) : SolrQuery
public SolrQuery::setStart ( int $start ) : SolrQuery
public SolrQuery::setStats ( bool $flag ) : SolrQuery
public SolrQuery::setTerms ( bool $flag ) : SolrQuery
public SolrQuery::setTermsField ( string $fieldname ) : SolrQuery
public SolrQuery::setTermsIncludeLowerBound ( bool $flag ) : SolrQuery
public SolrQuery::setTermsIncludeUpperBound ( bool $flag ) : SolrQuery
public SolrQuery::setTermsLimit ( int $limit ) : SolrQuery
public SolrQuery::setTermsLowerBound ( string $lowerBound ) : SolrQuery
public SolrQuery::setTermsMaxCount ( int $frequency ) : SolrQuery
public SolrQuery::setTermsMinCount ( int $frequency ) : SolrQuery
public SolrQuery::setTermsPrefix ( string $prefix ) : SolrQuery
public SolrQuery::setTermsReturnRaw ( bool $flag ) : SolrQuery
public SolrQuery::setTermsSort ( int $sortType ) : SolrQuery
public SolrQuery::setTermsUpperBound ( string $upperBound ) : SolrQuery
public SolrQuery::setTimeAllowed ( int $timeAllowed ) : SolrQuery
}

预定义常量

SolrDisMaxQuery::ORDER_ASC

Used to specify that the sorting should be in acending order (Duplicated for easier migration)

SolrDisMaxQuery::ORDER_DESC

Used to specify that the sorting should be in descending order (Duplicated for easier migration)

SolrDisMaxQuery::FACET_SORT_INDEX

Used to specify that the facet should sort by index (Duplicated for easier migration)

SolrDisMaxQuery::FACET_SORT_COUNT

Used to specify that the facet should sort by count (Duplicated for easier migration)

SolrDisMaxQuery::TERMS_SORT_INDEX

Used in the TermsComponent (Duplicated for easier migration)

SolrDisMaxQuery::TERMS_SORT_COUNT

Used in the TermsComponent (Duplicated for easier migration)

Table of Contents

  • SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)
  • SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)
  • SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)
  • SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::__construct — Class Constructor
  • SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)
  • SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)
  • SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)
  • SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)
  • SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter)
  • SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)
  • SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)
  • SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)
  • SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)
  • SolrDisMaxQuery::setQueryPhraseSlop — Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
  • SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)
  • SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)
  • SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser
  • SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax


Adds a Phrase Bigram Field (pf2 parameter)

  • ? SolrDisMaxQuery
  • SolrDisMaxQuery::addBoostQuery ?
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a Phrase Bigram Field (pf2 parameter)

SolrDisMaxQuery::addBigramPhraseField

(No version information available, might only be in Git)

SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)

说明

public SolrDisMaxQuery::addBigramPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery

Adds a Phrase Bigram Field (pf2 parameter) output format: field~slop^boost OR field^boost Slop is optional

参数

field

boost

slop

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::addBigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBigramPhraseField('cat', 2, 5.1)
    ->addBigramPhraseField('feature', 4.5)
;
echo $dismaxQuery;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5

参见

  • SolrDisMaxQuery::removeBigramPhraseField() - Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::setBigramPhraseFields() - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)


Adds a boost query field with value and optional boost (bq parameter)

  • ? SolrDisMaxQuery::addBigramPhraseField
  • SolrDisMaxQuery::addPhraseField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a boost query field with value and optional boost (bq parameter)

SolrDisMaxQuery::addBoostQuery

(No version information available, might only be in Git)

SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)

说明

public SolrDisMaxQuery::addBoostQuery ( string $field , string $value , string $boost = ? ) : SolrDisMaxQuery

Adds a Boost Query field with value [and boost] (bq parameter)

参数

field

value

boost

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::addBoostQuery() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBoostQuery('cat', 'clothing', 2)
    ->addBoostQuery('cat', 'electronics', 5.1)
;
echo $dismaxQuery.PHP_EOL;
?>

以上例程的输出类似于：

q=lucene&defType=edismax&bq=cat:clothing^2 cat:electronics^5.1

参见

  • SolrDisMaxQuery::removeBoostQuery() - Removes a boost query partial by field name (bq)
  • SolrDisMaxQuery::setBoostQuery() - Directly Sets Boost Query Parameter (bq)


Adds a Phrase Field (pf parameter)

  • ? SolrDisMaxQuery::addBoostQuery
  • SolrDisMaxQuery::addQueryField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a Phrase Field (pf parameter)

SolrDisMaxQuery::addPhraseField

(No version information available, might only be in Git)

SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)

说明

public SolrDisMaxQuery::addPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery

Adds a Phrase Field (pf parameter)

参数

field

field name

boost

slop

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::addPhraseField() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addPhraseField('cat', 3, 1)
    ->addPhraseField('third', 4, 2)
    ->addPhraseField('source', 55)
;
echo $dismaxQuery;
?>

以上例程的输出类似于：

q=lucene&defType=edismax&pf=cat~1^3 third~2^4 source^55

参见

  • SolrDisMaxQuery::removePhraseField() - Removes a Phrase Field (pf parameter)
  • SolrDisMaxQuery::setPhraseFields() - Sets Phrase Fields and their boosts (and slops) using pf2 parameter


Add a query field with optional boost (qf parameter)

  • ? SolrDisMaxQuery::addPhraseField
  • SolrDisMaxQuery::addTrigramPhraseField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Add a query field with optional boost (qf parameter)

SolrDisMaxQuery::addQueryField

(No version information available, might only be in Git)

SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)

说明

public SolrDisMaxQuery::addQueryField ( string $field , string $boost = ? ) : SolrDisMaxQuery

Add a query field with optional boost (qf parameter)

参数

field

field name

boost

Boost value. Boosts documents with matching terms.

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::addQueryField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addQueryField("location", 4)
    ->addQueryField("price")
    ->addQueryField("sku")
    ->addQueryField("title",3.4)
;
echo $dismaxQuery;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&qf=location^4 price sku title^3.4

参见

  • SolrDisMaxQuery::removeQueryField() - Removes a Query Field (qf parameter)


Adds a Trigram Phrase Field (pf3 parameter)

  • ? SolrDisMaxQuery::addQueryField
  • SolrDisMaxQuery::addUserField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a Trigram Phrase Field (pf3 parameter)

SolrDisMaxQuery::addTrigramPhraseField

(No version information available, might only be in Git)

SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)

说明

public SolrDisMaxQuery::addTrigramPhraseField ( string $field , string $boost , string $slop = ? ) : SolrDisMaxQuery

Adds a Trigram Phrase Field (pf3 parameter)

参数

field

Field Name

boost

Field Boost

slop

Field Slop

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::addTrigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addTrigramPhraseField('cat', 2, 5.1)
->addTrigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;

?>

以上例程会输出：

q=lucene&defType=%s&pf3=cat~5.1^2 feature^4.5

参见

  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)


Adds a field to User Fields Parameter (uf)

  • ? SolrDisMaxQuery::addTrigramPhraseField
  • SolrDisMaxQuery::__construct ?
  • PHP Manual
  • SolrDisMaxQuery
  • Adds a field to User Fields Parameter (uf)

SolrDisMaxQuery::addUserField

(No version information available, might only be in Git)

SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)

说明

public SolrDisMaxQuery::addUserField ( string $field ) : SolrDisMaxQuery

Adds a field to The User Fields Parameter (uf)

参数

field

Field Name

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::addUserField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addUserField('cat')
->addUserField('text')
->addUserField('*_dt');

echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&uf=cat text *_dt

参见

  • SolrDisMaxQuery::removeUserField() - Removes a field from The User Fields Parameter (uf)
  • SolrDisMaxQuery::setUserFields() - Sets User Fields parameter (uf)


Class Constructor

  • ? SolrDisMaxQuery::addUserField
  • SolrDisMaxQuery::removeBigramPhraseField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Class Constructor

SolrDisMaxQuery::__construct

(No version information available, might only be in Git)

SolrDisMaxQuery::__construct — Class Constructor

说明

public SolrDisMaxQuery::__construct ( string $q = ? )

Class constructor initializes the object and sets the q parameter if passed

参数

q

Search Query (q parameter)

返回值

错误／异常

Emits SolrIllegalArgumentException in case of an invalid parameter was passed.

范例

Example #1 SolrDisMaxQuery::__construct() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
echo $dismaxQuery;

?>

以上例程会输出：

q=lucene&defType=edismax

参见


Removes phrase bigram field (pf2 parameter)

  • ? SolrDisMaxQuery::__construct
  • SolrDisMaxQuery::removeBoostQuery ?
  • PHP Manual
  • SolrDisMaxQuery
  • Removes phrase bigram field (pf2 parameter)

SolrDisMaxQuery::removeBigramPhraseField

(No version information available, might only be in Git)

SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)

说明

public SolrDisMaxQuery::removeBigramPhraseField ( string $field ) : SolrDisMaxQuery

Removes a Bigram Phrase Field (pf2 parameter) that was previously added using SolrDisMaxQuery::addBigramPhraseField()

参数

field

The Field Name

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::removeBigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBigramPhraseField('cat', 2, 5.1)
    ->addBigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;

// remove cat from pf2
$dismaxQuery
    ->removeBigramPhraseField('cat');
echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5
q=lucene&defType=edismax&pf2=feature^4.5

参见

  • SolrDisMaxQuery::addBigramPhraseField() - Adds a Phrase Bigram Field (pf2 parameter)
  • SolrDisMaxQuery::setBigramPhraseFields() - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)


Removes a boost query partial by field name (bq)

  • ? SolrDisMaxQuery::removeBigramPhraseField
  • SolrDisMaxQuery::removePhraseField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a boost query partial by field name (bq)

SolrDisMaxQuery::removeBoostQuery

(No version information available, might only be in Git)

SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)

说明

public SolrDisMaxQuery::removeBoostQuery ( string $field ) : SolrDisMaxQuery

Removes a boost query partial from the existing query, only if SolrDisMaxQuery::addBoostQuery() was used.

参数

field

Field Name

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::removeBoostQuery() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBoostQuery('cat', 'electronics', 5.1)
    ->addBoostQuery('cat', 'hard drive')
;
echo $dismaxQuery.PHP_EOL;
// now remove a query part with field 'cat'
$dismaxQuery
->removeBoostQuery('cat');
echo $dismaxQuery . PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&bq=cat:electronics^5.1 cat:hard drive
q=lucene&defType=edismax&bq=cat:hard drive

参见

  • SolrDisMaxQuery::addBoostQuery() - Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::setBoostQuery() - Directly Sets Boost Query Parameter (bq)


Removes a Phrase Field (pf parameter)

  • ? SolrDisMaxQuery::removeBoostQuery
  • SolrDisMaxQuery::removeQueryField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a Phrase Field (pf parameter)

SolrDisMaxQuery::removePhraseField

(No version information available, might only be in Git)

SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)

说明

public SolrDisMaxQuery::removePhraseField ( string $field ) : SolrDisMaxQuery

Removes a Phrase Field (pf parameter) that was previously added using SolrDisMaxQuery::addPhraseField

参数

field

Field Name

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::removePhraseField() example

<?php
$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
    ->addPhraseField('first', 3, 1)
    ->addPhraseField('second', 4, 1)
    ->addPhraseField('cat', 55);
echo $dismaxQuery . PHP_EOL;
echo $dismaxQuery->removePhraseField('second');
?>

以上例程的输出类似于：

q=lucene&defType=edismax&pf=first~1^3 second~1^4 cat^55
q=lucene&defType=edismax&pf=first~1^3 cat^55

参见

  • SolrDisMaxQuery::addPhraseField() - Adds a Phrase Field (pf parameter)
  • SolrDisMaxQuery::setPhraseFields() - Sets Phrase Fields and their boosts (and slops) using pf2 parameter


Removes a Query Field (qf parameter)

  • ? SolrDisMaxQuery::removePhraseField
  • SolrDisMaxQuery::removeTrigramPhraseField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a Query Field (qf parameter)

SolrDisMaxQuery::removeQueryField

(No version information available, might only be in Git)

SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)

说明

public SolrDisMaxQuery::removeQueryField ( string $field ) : SolrDisMaxQuery

Removes a Query Field (qf parameter) from the field list added by SolrDisMaxQuery::addQueryField()

qf: When building DisjunctionMaxQueries from the user's query it specifies the fields to search in, and boosts for those fields.

参数

field

Field Name

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::removeQueryField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
    ->addQueryField('first', 3)
    ->addQueryField('second', 0.2)
    ->addQueryField('cat');
echo $dismaxQuery . PHP_EOL;
// remove field 'second'
echo $dismaxQuery->removeQueryField('second');
?>

以上例程的输出类似于：

q=lucene&defType=edismax&qf=first^3 second^0.2 cat
q=lucene&defType=edismax&qf=first^3 cat

参见

  • SolrDisMaxQuery::addQueryField() - Add a query field with optional boost (qf parameter)


Removes a Trigram Phrase Field (pf3 parameter)

  • ? SolrDisMaxQuery::removeQueryField
  • SolrDisMaxQuery::removeUserField ?
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a Trigram Phrase Field (pf3 parameter)

SolrDisMaxQuery::removeTrigramPhraseField

(No version information available, might only be in Git)

SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)

说明

public SolrDisMaxQuery::removeTrigramPhraseField ( string $field ) : SolrDisMaxQuery

Removes a Trigram Phrase Field (pf3 parameter)

参数

field

Field Name

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::removeTrigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addTrigramPhraseField('cat', 2, 5.1)
->addTrigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;
// reverse
$dismaxQuery
->removeTrigramPhraseField('cat');
echo $dismaxQuery.PHP_EOL;

?>

以上例程会输出：

q=lucene&defType=%s&pf3=cat~5.1^2 feature^4.5
q=lucene&defType=%s&pf3=feature^4.5

参见

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)


Removes a field from The User Fields Parameter (uf)

  • ? SolrDisMaxQuery::removeTrigramPhraseField
  • SolrDisMaxQuery::setBigramPhraseFields ?
  • PHP Manual
  • SolrDisMaxQuery
  • Removes a field from The User Fields Parameter (uf)

SolrDisMaxQuery::removeUserField

(No version information available, might only be in Git)

SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)

说明

public SolrDisMaxQuery::removeUserField ( string $field ) : SolrDisMaxQuery

Removes a field from The User Fields Parameter (uf)

Warning

本函数还未编写文档，仅有参数列表。

参数

field

Field Name

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::removeUserField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addUserField('cat')
->addUserField('text')
->addUserField('*_dt')
;
echo $dismaxQuery.PHP_EOL;

// remove field named 'text'
$dismaxQuery
->removeUserField('text');
echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=%s&uf=cat text *_dt
q=lucene&defType=%s&uf=cat *_dt

参见

  • SolrDisMaxQuery::addUserField() - Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::setUserFields() - Sets User Fields parameter (uf)


Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter

  • ? SolrDisMaxQuery::removeUserField
  • SolrDisMaxQuery::setBigramPhraseSlop ?
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter

SolrDisMaxQuery::setBigramPhraseFields

(No version information available, might only be in Git)

SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter

说明

public SolrDisMaxQuery::setBigramPhraseFields ( string $fields ) : SolrDisMaxQuery

Sets Bigram Phrase Fields (pf2) and their boosts (and slops)

参数

fields

Fields boosts (slops)

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setBigramPhraseFields() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery->setBigramPhraseFields("cat~5.1^2 feature^4.5");
echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5

参见

  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)
  • SolrDisMaxQuery::addBigramPhraseFields()
  • SolrDisMaxQuery::removeBigramPhraseField() - Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)


Sets Bigram Phrase Slop (ps2 parameter)

  • ? SolrDisMaxQuery::setBigramPhraseFields
  • SolrDisMaxQuery::setBoostFunction ?
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Bigram Phrase Slop (ps2 parameter)

SolrDisMaxQuery::setBigramPhraseSlop

(No version information available, might only be in Git)

SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)

说明

public SolrDisMaxQuery::setBigramPhraseSlop ( string $slop ) : SolrDisMaxQuery

Sets Bigram Phrase Slop (ps2 parameter). A default slop for Bigram phrase fields.

参数

slop

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setBigramPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$dismaxQuery->setBigramPhraseSlop(5);
echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&ps2=5

参见


Sets a Boost Function (bf parameter)

  • ? SolrDisMaxQuery::setBigramPhraseSlop
  • SolrDisMaxQuery::setBoostQuery ?
  • PHP Manual
  • SolrDisMaxQuery
  • Sets a Boost Function (bf parameter)

SolrDisMaxQuery::setBoostFunction

(No version information available, might only be in Git)

SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter)

说明

public SolrDisMaxQuery::setBoostFunction ( string $function ) : SolrDisMaxQuery

Sets Boost Function (bf parameter).

Functions (with optional boosts) that will be included in the user's query to influence the score. Any function supported natively by Solr can be used, along with a boost value. e.g.:

recip(rord(myfield),1,2,3)^1.5

参数

function

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setBoostFunction() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$boostRecentDocsFunction = "recip(ms(NOW,mydatefield),3.16e-11,1,1)";
$dismaxQuery->setBoostFunction($boostRecentDocsFunction);

echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&bf=recip(ms(NOW,mydatefield),3.16e-11,1,1)

参见


Directly Sets Boost Query Parameter (bq)

  • ? SolrDisMaxQuery::setBoostFunction
  • SolrDisMaxQuery::setMinimumMatch ?
  • PHP Manual
  • SolrDisMaxQuery
  • Directly Sets Boost Query Parameter (bq)

SolrDisMaxQuery::setBoostQuery

(No version information available, might only be in Git)

SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)

说明

public SolrDisMaxQuery::setBoostQuery ( string $q ) : SolrDisMaxQuery

Sets Boost Query Parameter (bq)

参数

q

query

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setBoostQuery() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");

$dismaxQuery->setBoostQuery('cat:electronics manu:local^2');
echo $dismaxQuery.PHP_EOL;
?>

以上例程的输出类似于：

q=lucene&defType=edismax&bq=cat:electronics manu:local^2

参见

  • SolrDisMaxQuery::addBoostQuery() - Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::removeBoostQuery() - Removes a boost query partial by field name (bq)


Set Minimum "Should" Match (mm)

  • ? SolrDisMaxQuery::setBoostQuery
  • SolrDisMaxQuery::setPhraseFields ?
  • PHP Manual
  • SolrDisMaxQuery
  • Set Minimum "Should" Match (mm)

SolrDisMaxQuery::setMinimumMatch

(No version information available, might only be in Git)

SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)

说明

public SolrDisMaxQuery::setMinimumMatch ( string $value ) : SolrDisMaxQuery

Set Minimum "Should" Match parameter (mm). If the default query operator is AND then mm=100%, if the default query operator (q.op) is OR, then mm=0%.

参数

value

Minimum match value/expression

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setMinimumMatch() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
// 75% of the query clauses must match
$dismaxQuery->setMinimumMatch("75%");
echo $dismaxQuery . PHP_EOL;

?>

以上例程会输出：

q=lucene&defType=edismax&mm=75%


Sets Phrase Fields and their boosts (and slops) using pf2 parameter

  • ? SolrDisMaxQuery::setMinimumMatch
  • SolrDisMaxQuery::setPhraseSlop ?
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Phrase Fields and their boosts (and slops) using pf2 parameter

SolrDisMaxQuery::setPhraseFields

(No version information available, might only be in Git)

SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter

说明

public SolrDisMaxQuery::setPhraseFields ( string $fields ) : SolrDisMaxQuery

Sets Phrase Fields (pf) and their boosts (and slops)

参数

fields

Fields, boosts [, slops]

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setPhraseFields() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery->setPhraseFields("cat~5.1^2 feature^4.5");
echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&pf=cat~5.1^2 feature^4.5

参见

  • SolrDisMaxQuery::addPhraseFields()
  • SolrDisMaxQuery::removePhraseField() - Removes a Phrase Field (pf parameter)


Sets the default slop on phrase queries (ps parameter)

  • ? SolrDisMaxQuery::setPhraseFields
  • SolrDisMaxQuery::setQueryAlt ?
  • PHP Manual
  • SolrDisMaxQuery
  • Sets the default slop on phrase queries (ps parameter)

SolrDisMaxQuery::setPhraseSlop

(No version information available, might only be in Git)

SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)

说明

public SolrDisMaxQuery::setPhraseSlop ( string $slop ) : SolrDisMaxQuery

Sets the default amount of slop on phrase queries built with "pf", "pf2" and/or "pf3" fields (affects boosting). "ps" parameter

参数

slop

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$dismaxQuery->setPhraseSlop(4);
echo $dismaxQuery.PHP_EOL;

?>

以上例程会输出：

q=lucene&defType=edismax&ps=4

参见


Set Query Alternate (q.alt parameter)

  • ? SolrDisMaxQuery::setPhraseSlop
  • SolrDisMaxQuery::setQueryPhraseSlop ?
  • PHP Manual
  • SolrDisMaxQuery
  • Set Query Alternate (q.alt parameter)

SolrDisMaxQuery::setQueryAlt

(No version information available, might only be in Git)

SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)

说明

public SolrDisMaxQuery::setQueryAlt ( string $q ) : SolrDisMaxQuery

Set Query Alternate (q.alt parameter)

When the main q parameter is not specified or is blank. The q.alt parameter is used

参数

q

Query String

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setQueryAlt() example

<?php

$dismaxQuery = new DisMaxQuery();
$dismaxQuery->setQueryAlt('*:*');

?>

以上例程的输出类似于：

defType=edismax&q.alt=*:*&q=


Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)

  • ? SolrDisMaxQuery::setQueryAlt
  • SolrDisMaxQuery::setTieBreaker ?
  • PHP Manual
  • SolrDisMaxQuery
  • Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)

SolrDisMaxQuery::setQueryPhraseSlop

(No version information available, might only be in Git)

SolrDisMaxQuery::setQueryPhraseSlop — Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)

说明

public SolrDisMaxQuery::setQueryPhraseSlop ( string $slop ) : SolrDisMaxQuery

The Query Phrase Slop is the amount of slop permitted on phrase queries explicitly included in the user's query string with the qf parameter.

slop refers to the number of positions one token needs to be moved in relation to another token in order to match a phrase specified in a query.

参数

slop

Amount of slop

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setQueryPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->setQueryPhraseSlop(3);
echo $dismaxQuery;
?>

以上例程的输出类似于：

defType=edismax&qs=3


Sets Tie Breaker parameter (tie parameter)

  • ? SolrDisMaxQuery::setQueryPhraseSlop
  • SolrDisMaxQuery::setTrigramPhraseFields ?
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Tie Breaker parameter (tie parameter)

SolrDisMaxQuery::setTieBreaker

(No version information available, might only be in Git)

SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)

说明

public SolrDisMaxQuery::setTieBreaker ( string $tieBreaker ) : SolrDisMaxQuery

Sets Tie Breaker parameter (tie parameter)

参数

tieBreaker

The tie parameter specifies a float value (which should be something much less than 1) to use as tiebreaker in DisMax queries.

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setTieBreaker() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->setTieBreaker(0.1);

echo $dismaxQuery;

?>

以上例程会输出：

defType=edismax&tie=0.1


Directly Sets Trigram Phrase Fields (pf3 parameter)

  • ? SolrDisMaxQuery::setTieBreaker
  • SolrDisMaxQuery::setTrigramPhraseSlop ?
  • PHP Manual
  • SolrDisMaxQuery
  • Directly Sets Trigram Phrase Fields (pf3 parameter)

SolrDisMaxQuery::setTrigramPhraseFields

(No version information available, might only be in Git)

SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)

说明

public SolrDisMaxQuery::setTrigramPhraseFields ( string $fields ) : SolrDisMaxQuery

Directly Sets Trigram Phrase Fields (pf3 parameter)

参数

fields

Trigram Phrase Fields

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setTrigramPhraseFields() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setTrigramPhraseFields('cat~5.1^2 feature^4.5');
echo $dismaxQuery.PHP_EOL;

?>

以上例程会输出：

q=lucene&defType=edismax&pf3=cat~5.1^2 feature^4.5

参见

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)


Sets Trigram Phrase Slop (ps3 parameter)

  • ? SolrDisMaxQuery::setTrigramPhraseFields
  • SolrDisMaxQuery::setUserFields ?
  • PHP Manual
  • SolrDisMaxQuery
  • Sets Trigram Phrase Slop (ps3 parameter)

SolrDisMaxQuery::setTrigramPhraseSlop

(No version information available, might only be in Git)

SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)

说明

public SolrDisMaxQuery::setTrigramPhraseSlop ( string $slop ) : SolrDisMaxQuery

Sets Trigram Phrase Slop (ps3 parameter)

参数

slop

Phrase slop

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setTrigramPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setTrigramPhraseSlop(2);
echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&ps3=2

参见

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)


Sets User Fields parameter (uf)

  • ? SolrDisMaxQuery::setTrigramPhraseSlop
  • SolrDisMaxQuery::useDisMaxQueryParser ?
  • PHP Manual
  • SolrDisMaxQuery
  • Sets User Fields parameter (uf)

SolrDisMaxQuery::setUserFields

(No version information available, might only be in Git)

SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)

说明

public SolrDisMaxQuery::setUserFields ( string $fields ) : SolrDisMaxQuery

Sets User Fields parameter (uf)

User Fields: Specifies which schema fields the end user shall be allowed to query.

参数

fields

Fields names separated by space

This parameter supports wildcards.

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::setUserFields() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setUserFields('field1 field2 *_txt');
echo $dismaxQuery.PHP_EOL;

?>

以上例程的输出类似于：

q=lucene&defType=edismax&uf=field1 field2 *_txt

参见

  • SolrDisMaxQuery::addUserField() - Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::removeUserField() - Removes a field from The User Fields Parameter (uf)


Switch QueryParser to be DisMax Query Parser

  • ? SolrDisMaxQuery::setUserFields
  • SolrDisMaxQuery::useEDisMaxQueryParser ?
  • PHP Manual
  • SolrDisMaxQuery
  • Switch QueryParser to be DisMax Query Parser

SolrDisMaxQuery::useDisMaxQueryParser

(No version information available, might only be in Git)

SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser

说明

public SolrDisMaxQuery::useDisMaxQueryParser ( ) : SolrDisMaxQuery

Switch QueryParser to be DisMax Query Parser

参数

此函数没有参数。

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::useDisMaxQueryParser() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->useDisMaxQueryParser();
echo $dismaxQuery;
?>

以上例程的输出类似于：

defType=dismax

参见

  • SolrDisMaxQuery::useDisMaxQueryParser()


Switch QueryParser to be EDisMax

  • ? SolrDisMaxQuery::useDisMaxQueryParser
  • SolrCollapseFunction ?
  • PHP Manual
  • SolrDisMaxQuery
  • Switch QueryParser to be EDisMax

SolrDisMaxQuery::useEDisMaxQueryParser

(No version information available, might only be in Git)

SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax

说明

public SolrDisMaxQuery::useEDisMaxQueryParser ( ) : SolrDisMaxQuery

Switch QueryParser to be EDisMax. By default the query builder uses edismax, if it was switched using SolrDisMaxQuery::useDisMaxQueryParser(), it can be switched back using this method.

参数

此函数没有参数。

返回值

SolrDisMaxQuery

范例

Example #1 SolrDisMaxQuery::useEDisMaxQueryParser() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->useEDisMaxQueryParser();
echo $dismaxQuery;

?>

以上例程的输出类似于：

defType=edismax

参见


The SolrCollapseFunction class

(PECL solr >= 2.2.0)

简介

类摘要

SolrCollapseFunction {
/* Constants */
const string NULLPOLICY_IGNORE = ignore ;
const string NULLPOLICY_EXPAND = expand ;
const string NULLPOLICY_COLLAPSE = collapse ;
/* 方法 */
public __construct ( string $field = ? )
public getField ( ) : string
public getHint ( ) : string
public getMax ( ) : string
public getMin ( ) : string
public getNullPolicy ( ) : string
public getSize ( ) : int
public setField ( string $fieldName ) : SolrCollapseFunction
public setHint ( string $hint ) : SolrCollapseFunction
public setMax ( string $max ) : SolrCollapseFunction
public setMin ( string $min ) : SolrCollapseFunction
public setNullPolicy ( string $nullPolicy ) : SolrCollapseFunction
public setSize ( int $size ) : SolrCollapseFunction
public __toString ( ) : string
}

预定义常量

SolrCollapseFunction::NULLPOLICY_IGNORE

SolrCollapseFunction::NULLPOLICY_EXPAND

SolrCollapseFunction::NULLPOLICY_COLLAPSE

Table of Contents

  • SolrCollapseFunction::__construct — Constructor
  • SolrCollapseFunction::getField — Returns the field that is being collapsed on
  • SolrCollapseFunction::getHint — Returns collapse hint
  • SolrCollapseFunction::getMax — Returns max parameter
  • SolrCollapseFunction::getMin — Returns min parameter
  • SolrCollapseFunction::getNullPolicy — Returns null policy
  • SolrCollapseFunction::getSize — Returns size parameter
  • SolrCollapseFunction::setField — Sets the field to collapse on
  • SolrCollapseFunction::setHint — Sets collapse hint
  • SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query
  • SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only
  • SolrCollapseFunction::setNullPolicy — Sets the NULL Policy
  • SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only
  • SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function


Constructor

  • ? SolrCollapseFunction
  • SolrCollapseFunction::getField ?
  • PHP Manual
  • SolrCollapseFunction
  • Constructor

SolrCollapseFunction::__construct

(PECL solr >= 2.2.0)

SolrCollapseFunction::__construct — Constructor

说明

public SolrCollapseFunction::__construct ( string $field = ? )

Collapse Function constructor

参数

field

The field name to collapse on.

In order to collapse a result. The field type must be a single valued String, Int or Float.

范例

Example #1 SolrCollapseFunction::__construct() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$func = new SolrCollapseFunction('field_name');

$func->setMax('sum(cscore(),field(some_other_field))');
$func->setSize(100);
$func->setNullPolicy(SolrCollapseFunction::NULLPOLICY_EXPAND);

$query->collapse($func);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);

?>

参见

  • SolrQuery::collapse() - Collapses the result set to a single document per group


Returns the field that is being collapsed on

  • ? SolrCollapseFunction::__construct
  • SolrCollapseFunction::getHint ?
  • PHP Manual
  • SolrCollapseFunction
  • Returns the field that is being collapsed on

SolrCollapseFunction::getField

(PECL solr >= 2.2.0)

SolrCollapseFunction::getField — Returns the field that is being collapsed on

说明

public SolrCollapseFunction::getField ( ) : string

Returns the field that is being collapsed on.

参数

此函数没有参数。

返回值

参见

  • SolrCollapseFunction::setField() - Sets the field to collapse on


Returns collapse hint

  • ? SolrCollapseFunction::getField
  • SolrCollapseFunction::getMax ?
  • PHP Manual
  • SolrCollapseFunction
  • Returns collapse hint

SolrCollapseFunction::getHint

(PECL solr >= 2.2.0)

SolrCollapseFunction::getHint — Returns collapse hint

说明

public SolrCollapseFunction::getHint ( ) : string

Returns collapse hint

参数

此函数没有参数。

返回值

参见

  • SolrCollapseFunction::setHint() - Sets collapse hint


Returns max parameter

  • ? SolrCollapseFunction::getHint
  • SolrCollapseFunction::getMin ?
  • PHP Manual
  • SolrCollapseFunction
  • Returns max parameter

SolrCollapseFunction::getMax

(PECL solr >= 2.2.0)

SolrCollapseFunction::getMax — Returns max parameter

说明

public SolrCollapseFunction::getMax ( ) : string

Returns max parameter

参数

此函数没有参数。

返回值

参见

  • SolrCollapseFunction::setMax() - Selects the group heads by the max value of a numeric field or function query


Returns min parameter

  • ? SolrCollapseFunction::getMax
  • SolrCollapseFunction::getNullPolicy ?
  • PHP Manual
  • SolrCollapseFunction
  • Returns min parameter

SolrCollapseFunction::getMin

(PECL solr >= 2.2.0)

SolrCollapseFunction::getMin — Returns min parameter

说明

public SolrCollapseFunction::getMin ( ) : string

Returns min parameter

参数

此函数没有参数。

返回值

参见

  • SolrCollapseFunction::setMin() - Sets the initial size of the collapse data structures when collapsing on a numeric field only


Returns null policy

  • ? SolrCollapseFunction::getMin
  • SolrCollapseFunction::getSize ?
  • PHP Manual
  • SolrCollapseFunction
  • Returns null policy

SolrCollapseFunction::getNullPolicy

(PECL solr >= 2.2.0)

SolrCollapseFunction::getNullPolicy — Returns null policy

说明

public SolrCollapseFunction::getNullPolicy ( ) : string

Returns null policy used or null

参数

此函数没有参数。

返回值

参见

  • SolrCollapseFunction::setNullPolicy() - Sets the NULL Policy


Returns size parameter

  • ? SolrCollapseFunction::getNullPolicy
  • SolrCollapseFunction::setField ?
  • PHP Manual
  • SolrCollapseFunction
  • Returns size parameter

SolrCollapseFunction::getSize

(PECL solr >= 2.2.0)

SolrCollapseFunction::getSize — Returns size parameter

说明

public SolrCollapseFunction::getSize ( ) : int

Gets the initial size of the collapse data structures when collapsing on a numeric field only

参数

此函数没有参数。

返回值

参见

  • SolrCollapseFunction::setSize() - Sets the initial size of the collapse data structures when collapsing on a numeric field only


Sets the field to collapse on

  • ? SolrCollapseFunction::getSize
  • SolrCollapseFunction::setHint ?
  • PHP Manual
  • SolrCollapseFunction
  • Sets the field to collapse on

SolrCollapseFunction::setField

(PECL solr >= 2.2.0)

SolrCollapseFunction::setField — Sets the field to collapse on

说明

public SolrCollapseFunction::setField ( string $fieldName ) : SolrCollapseFunction

The field name to collapse on. In order to collapse a result. The field type must be a single valued String, Int or Float.

参数

fieldName

返回值

SolrCollapseFunction


Sets collapse hint

  • ? SolrCollapseFunction::setField
  • SolrCollapseFunction::setMax ?
  • PHP Manual
  • SolrCollapseFunction
  • Sets collapse hint

SolrCollapseFunction::setHint

(PECL solr >= 2.2.0)

SolrCollapseFunction::setHint — Sets collapse hint

说明

public SolrCollapseFunction::setHint ( string $hint ) : SolrCollapseFunction

Sets collapse hint

参数

hint

Currently there is only one hint available "top_fc", which stands for top level FieldCache

返回值

SolrCollapseFunction

范例

Example #1 SolrCollapseFunction::setHint() example

<?php

/* ... */

?>

以上例程的输出类似于：

...


Selects the group heads by the max value of a numeric field or function query

  • ? SolrCollapseFunction::setHint
  • SolrCollapseFunction::setMin ?
  • PHP Manual
  • SolrCollapseFunction
  • Selects the group heads by the max value of a numeric field or function query

SolrCollapseFunction::setMax

(PECL solr >= 2.2.0)

SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query

说明

public SolrCollapseFunction::setMax ( string $max ) : SolrCollapseFunction

Selects the group heads by the max value of a numeric field or function query.

参数

max

返回值

SolrCollapseFunction

范例

Example #1 SolrCollapseFunction::setMax() example

<?php

$func = new SolrCollapseFunction('field_name');

$func->setMax('sum(cscore(),field(some_field))');

$query = new SolrQuery('*:*');

$query->collapse($func);

?>


Sets the initial size of the collapse data structures when collapsing on a numeric field only

  • ? SolrCollapseFunction::setMax
  • SolrCollapseFunction::setNullPolicy ?
  • PHP Manual
  • SolrCollapseFunction
  • Sets the initial size of the collapse data structures when collapsing on a numeric field only

SolrCollapseFunction::setMin

(PECL solr >= 2.2.0)

SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only

说明

public SolrCollapseFunction::setMin ( string $min ) : SolrCollapseFunction

Sets the initial size of the collapse data structures when collapsing on a numeric field only

参数

min

返回值

SolrCollapseFunction


Sets the NULL Policy

  • ? SolrCollapseFunction::setMin
  • SolrCollapseFunction::setSize ?
  • PHP Manual
  • SolrCollapseFunction
  • Sets the NULL Policy

SolrCollapseFunction::setNullPolicy

(PECL solr >= 2.2.0)

SolrCollapseFunction::setNullPolicy — Sets the NULL Policy

说明

public SolrCollapseFunction::setNullPolicy ( string $nullPolicy ) : SolrCollapseFunction

Sets the NULL Policy. One of the 3 policies defined as class constants shall be passed. Accepts ignore, expand, or collapse policies.

参数

nullPolicy

返回值

SolrCollapseFunction


Sets the initial size of the collapse data structures when collapsing on a numeric field only

  • ? SolrCollapseFunction::setNullPolicy
  • SolrCollapseFunction::__toString ?
  • PHP Manual
  • SolrCollapseFunction
  • Sets the initial size of the collapse data structures when collapsing on a numeric field only

SolrCollapseFunction::setSize

(PECL solr >= 2.2.0)

SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only

说明

public SolrCollapseFunction::setSize ( int $size ) : SolrCollapseFunction

Sets the initial size of the collapse data structures when collapsing on a numeric field only.

参数

size

返回值

SolrCollapseFunction


Returns a string representing the constructed collapse function

  • ? SolrCollapseFunction::setSize
  • SolrException ?
  • PHP Manual
  • SolrCollapseFunction
  • Returns a string representing the constructed collapse function

SolrCollapseFunction::__toString

(PECL solr >= 2.2.0)

SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function

说明

public SolrCollapseFunction::__toString ( ) : string

Returns a string representing the constructed collapse function

参数

此函数没有参数。

返回值


The SolrException class

(PECL solr >= 0.9.2)

简介

This is the base class for all exception thrown by the Solr extension classes.

类摘要

SolrException extends Exception {
/* 属性 */
protected int $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
public getInternalInfo ( ) : array
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

sourceline

The line in c-space source file where exception was generated

sourcefile

The c-space source file where exception was generated

zif_name

The c-space function where exception was generated

Table of Contents

  • SolrException::getInternalInfo — Returns internal information where the Exception was thrown


Returns internal information where the Exception was thrown

  • ? SolrException
  • SolrClientException ?
  • PHP Manual
  • SolrException
  • Returns internal information where the Exception was thrown

SolrException::getInternalInfo

(PECL solr >= 0.9.2)

SolrException::getInternalInfo — Returns internal information where the Exception was thrown

说明

public SolrException::getInternalInfo ( ) : array

Returns internal information where the Exception was thrown.

参数

此函数没有参数。

返回值

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.


The SolrClientException class

(PECL solr >= 0.9.2)

简介

An exception thrown when there is an error while making a request to the server from the client.

类摘要

SolrClientException extends SolrException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected int $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* 方法 */
public getInternalInfo ( ) : array
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}

Table of Contents

  • SolrClientException::getInternalInfo — Returns internal information where the Exception was thrown


Returns internal information where the Exception was thrown

  • ? SolrClientException
  • SolrServerException ?
  • PHP Manual
  • SolrClientException
  • Returns internal information where the Exception was thrown

SolrClientException::getInternalInfo

(PECL solr >= 0.9.2)

SolrClientException::getInternalInfo — Returns internal information where the Exception was thrown

说明

public SolrClientException::getInternalInfo ( ) : array

Returns internal information where the Exception was thrown.

参数

此函数没有参数。

返回值

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.


The SolrServerException class

(PECL Solr >= 1.1.0, >=2.0.0)

简介

An exception thrown when there is an error produced by the Solr Server itself.

类摘要

SolrServerException extends SolrException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected int $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* 方法 */
public getInternalInfo ( ) : array
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}

Table of Contents

  • SolrServerException::getInternalInfo — Returns internal information where the Exception was thrown


Returns internal information where the Exception was thrown

  • ? SolrServerException
  • SolrIllegalArgumentException ?
  • PHP Manual
  • SolrServerException
  • Returns internal information where the Exception was thrown

SolrServerException::getInternalInfo

(PECL solr >= 1.1.0, >=2.0.0)

SolrServerException::getInternalInfo — Returns internal information where the Exception was thrown

说明

public SolrServerException::getInternalInfo ( ) : array

Returns internal information where the Exception was thrown.

参数

此函数没有参数。

返回值

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.


The SolrIllegalArgumentException class

(PECL solr >= 0.9.2)

简介

This object is thrown when an illegal or invalid argument is passed to a method.

类摘要

SolrIllegalArgumentException extends SolrException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected int $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* 方法 */
public getInternalInfo ( ) : array
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}

Table of Contents

  • SolrIllegalArgumentException::getInternalInfo — Returns internal information where the Exception was thrown


Returns internal information where the Exception was thrown

  • ? SolrIllegalArgumentException
  • SolrIllegalOperationException ?
  • PHP Manual
  • SolrIllegalArgumentException
  • Returns internal information where the Exception was thrown

SolrIllegalArgumentException::getInternalInfo

(PECL solr >= 0.9.2)

SolrIllegalArgumentException::getInternalInfo — Returns internal information where the Exception was thrown

说明

public SolrIllegalArgumentException::getInternalInfo ( ) : array

Returns internal information where the Exception was thrown.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.


The SolrIllegalOperationException class

(PECL solr >= 0.9.2)

简介

This object is thrown when an illegal or unsupported operation is performed on an object.

类摘要

SolrIllegalOperationException extends SolrException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected int $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* 方法 */
public getInternalInfo ( ) : array
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}

Table of Contents

  • SolrIllegalOperationException::getInternalInfo — Returns internal information where the Exception was thrown


Returns internal information where the Exception was thrown

  • ? SolrIllegalOperationException
  • SolrMissingMandatoryParameterException ?
  • PHP Manual
  • SolrIllegalOperationException
  • Returns internal information where the Exception was thrown

SolrIllegalOperationException::getInternalInfo

(PECL solr >= 0.9.2)

SolrIllegalOperationException::getInternalInfo — Returns internal information where the Exception was thrown

说明

public SolrIllegalOperationException::getInternalInfo ( ) : array

Returns internal information where the Exception was thrown.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.


The SolrMissingMandatoryParameterException class

(No version information available, might only be in Git)

简介

类摘要

SolrMissingMandatoryParameterException extends SolrException {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected int $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
public SolrException::getInternalInfo ( ) : array
}


Sphinx 客户端

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • SphinxClient — SphinxClient 类
    • SphinxClient::addQuery — Add query to multi-query batch
    • SphinxClient::buildExcerpts — Build text snippets
    • SphinxClient::buildKeywords — Extract keywords from query
    • SphinxClient::close — 关闭先前打开的持久连接
    • SphinxClient::__construct — Create a new SphinxClient object
    • SphinxClient::escapeString — Escape special characters
    • SphinxClient::getLastError — Get the last error message
    • SphinxClient::getLastWarning — Get the last warning
    • SphinxClient::open — 建立到搜索服务端的持久连接
    • SphinxClient::query — 执行搜索查询
    • SphinxClient::resetFilters — Clear all filters
    • SphinxClient::resetGroupBy — Clear all group-by settings
    • SphinxClient::runQueries — Run a batch of search queries
    • SphinxClient::setArrayResult — 控制搜索结果集的返回格式
    • SphinxClient::setConnectTimeout — Set connection timeout
    • SphinxClient::setFieldWeights — Set field weights
    • SphinxClient::setFilter — 增加整数值过滤器
    • SphinxClient::setFilterFloatRange — Add new float range filter
    • SphinxClient::setFilterRange — Add new integer range filter
    • SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations
    • SphinxClient::setGroupBy — Set grouping attribute
    • SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations
    • SphinxClient::setIDRange — Set a range of accepted document IDs
    • SphinxClient::setIndexWeights — Set per-index weights
    • SphinxClient::setLimits — 设置返回结果集偏移量和数目
    • SphinxClient::setMatchMode — 设置全文查询的匹配模式
    • SphinxClient::setMaxQueryTime — Set maximum query time
    • SphinxClient::setOverride — Sets temporary per-document attribute value overrides
    • SphinxClient::setRankingMode — Set ranking mode
    • SphinxClient::setRetries — Set retry count and delay
    • SphinxClient::setSelect — Set select clause
    • SphinxClient::setServer — 设置searchd的主机名和TCP端口
    • SphinxClient::setSortMode — Set matches sorting mode
    • SphinxClient::status — Queries searchd status
    • SphinxClient::updateAttributes — Update document attributes


简介

该扩展提供了针对Sphinx搜索客户端开发库的绑定. Sphinx是一个独立的搜索引擎系统，其目的是为其他相关程序和应用提供快速的、规模可扩展的全文搜索功能. Sphinx有着良好的设计，可以很方便的与SQL数据库结合，并使用脚本语言调用. SPhinx 以及 其客户端库 可以从 » 官方站点获取，中文用户也可以从» Coreseek获取支持中文的版本和服务。


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

PECL/sphinx requires PHP 5.2.2 or newer.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/sphinx.

如果 ./configure 不能正确找到 libsphinxclient 文件 (例如, 他被安装在用户自己定义的目录中), 使用 ./configure --with-sphinx=$PREFIX来制定libsphinxclient的具体位置（$PREFIX是libsphinxclient的安装位置）.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SEARCHD_OK (int)
SEARCHD_ERROR (int)
SEARCHD_RETRY (int)
SEARCHD_WARNING (int)
SPH_MATCH_ALL (int)
SPH_MATCH_ANY (int)
SPH_MATCH_PHRASE (int)
SPH_MATCH_BOOLEAN (int)
SPH_MATCH_EXTENDED (int)
SPH_MATCH_FULLSCAN (int)
SPH_MATCH_EXTENDED2 (int)
SPH_RANK_PROXIMITY_BM25 (int)
SPH_RANK_BM25 (int)
SPH_RANK_NONE (int)
SPH_RANK_WORDCOUNT (int)
SPH_SORT_RELEVANCE (int)
SPH_SORT_ATTR_DESC (int)
SPH_SORT_ATTR_ASC (int)
SPH_SORT_TIME_SEGMENTS (int)
SPH_SORT_EXTENDED (int)
SPH_SORT_EXPR (int)
SPH_FILTER_VALUES (int)
SPH_FILTER_RANGE (int)
SPH_FILTER_FLOATRANGE (int)
SPH_ATTR_INTEGER (int)
SPH_ATTR_TIMESTAMP (int)
SPH_ATTR_ORDINAL (int)
SPH_ATTR_BOOL (int)
SPH_ATTR_FLOAT (int)
SPH_ATTR_MULTI (int)
SPH_GROUPBY_DAY (int)
SPH_GROUPBY_WEEK (int)
SPH_GROUPBY_MONTH (int)
SPH_GROUPBY_YEAR (int)
SPH_GROUPBY_ATTR (int)
SPH_GROUPBY_ATTRPAIR (int)


范例

Example #1 基本使用范例

<?php

$s = new SphinxClient;
$s->setServer("localhost", 6712);
$s->setMatchMode(SPH_MATCH_ANY);
$s->setMaxQueryTime(3);

$result = $s->query("test");

var_dump($result);

?>

以上例程的输出类似于：

array(10) {
  ["error"]=>
  string(0) ""
  ["warning"]=>
  string(0) ""
  ["status"]=>
  int(0)
  ["fields"]=>
  array(3) {
    [0]=>
    string(7) "subject"
    [1]=>
    string(4) "body"
    [2]=>
    string(6) "author"
  }
  ["attrs"]=>
  array(0) {
  }
  ["matches"]=>
  array(1) {
    [3]=>
    array(2) {
      ["weight"]=>
      int(1)
      ["attrs"]=>
      array(0) {
      }
    }
  }
  ["total"]=>
  int(1)
  ["total_found"]=>
  int(1)
  ["time"]=>
  float(0)
  ["words"]=>
  array(1) {
    ["to"]=>
    array(2) {
      ["docs"]=>
      int(1)
      ["hits"]=>
      int(1)
    }
  }
}


SphinxClient 类

(PECL sphinx >= 0.1.0)

简介

SphinxClient 为 Sphinx 提供了面向对象的接口.

类摘要

SphinxClient {
/* 方法 */
public addQuery ( string $query , string $index = "*" , string $comment = "" ) : int
public buildExcerpts ( array $docs , string $index , string $words , array $opts = ? ) : array|false
public buildKeywords ( string $query , string $index , bool $hits ) : array
public close ( ) : bool
public __construct ( )
public escapeString ( string $string ) : string
public getLastError ( ) : string
public getLastWarning ( ) : string
public open ( ) : bool
public query ( string $query , string $index = "*" , string $comment = "" ) : array
public resetFilters ( ) : void
public resetGroupBy ( ) : void
public runQueries ( ) : array
public setArrayResult ( bool $array_result = false ) : bool
public setConnectTimeout ( float $timeout ) : bool
public setFieldWeights ( array $weights ) : bool
public setFilter ( string $attribute , array $values , bool $exclude = false ) : bool
public setFilterFloatRange ( string $attribute , float $min , float $max , bool $exclude = false ) : bool
public setFilterRange ( string $attribute , int $min , int $max , bool $exclude = false ) : bool
public setGeoAnchor ( string $attrlat , string $attrlong , float $latitude , float $longitude ) : bool
public setGroupBy ( string $attribute , int $func , string $groupsort = "@group desc" ) : bool
public setGroupDistinct ( string $attribute ) : bool
public setIDRange ( int $min , int $max ) : bool
public setIndexWeights ( array $weights ) : bool
public setLimits ( int $offset , int $limit , int $max_matches = 0 , int $cutoff = 0 ) : bool
public setMatchMode ( int $mode ) : bool
public setMaxQueryTime ( int $qtime ) : bool
public setOverride ( string $attribute , int $type , array $values ) : bool
public setRankingMode ( int $ranker ) : bool
public setRetries ( int $count , int $delay = 0 ) : bool
public setSelect ( string $clause ) : bool
public setServer ( string $server , int $port ) : bool
public setSortMode ( int $mode , string $sortby = ? ) : bool
public status ( ) : array
public updateAttributes ( string $index , array $attributes , array $values , bool $mva = false ) : int
}

Table of Contents

  • SphinxClient::addQuery — Add query to multi-query batch
  • SphinxClient::buildExcerpts — Build text snippets
  • SphinxClient::buildKeywords — Extract keywords from query
  • SphinxClient::close — 关闭先前打开的持久连接
  • SphinxClient::__construct — Create a new SphinxClient object
  • SphinxClient::escapeString — Escape special characters
  • SphinxClient::getLastError — Get the last error message
  • SphinxClient::getLastWarning — Get the last warning
  • SphinxClient::open — 建立到搜索服务端的持久连接
  • SphinxClient::query — 执行搜索查询
  • SphinxClient::resetFilters — Clear all filters
  • SphinxClient::resetGroupBy — Clear all group-by settings
  • SphinxClient::runQueries — Run a batch of search queries
  • SphinxClient::setArrayResult — 控制搜索结果集的返回格式
  • SphinxClient::setConnectTimeout — Set connection timeout
  • SphinxClient::setFieldWeights — Set field weights
  • SphinxClient::setFilter — 增加整数值过滤器
  • SphinxClient::setFilterFloatRange — Add new float range filter
  • SphinxClient::setFilterRange — Add new integer range filter
  • SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations
  • SphinxClient::setGroupBy — Set grouping attribute
  • SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations
  • SphinxClient::setIDRange — Set a range of accepted document IDs
  • SphinxClient::setIndexWeights — Set per-index weights
  • SphinxClient::setLimits — 设置返回结果集偏移量和数目
  • SphinxClient::setMatchMode — 设置全文查询的匹配模式
  • SphinxClient::setMaxQueryTime — Set maximum query time
  • SphinxClient::setOverride — Sets temporary per-document attribute value overrides
  • SphinxClient::setRankingMode — Set ranking mode
  • SphinxClient::setRetries — Set retry count and delay
  • SphinxClient::setSelect — Set select clause
  • SphinxClient::setServer — 设置searchd的主机名和TCP端口
  • SphinxClient::setSortMode — Set matches sorting mode
  • SphinxClient::status — Queries searchd status
  • SphinxClient::updateAttributes — Update document attributes


Add query to multi-query batch

  • ? SphinxClient
  • SphinxClient::buildExcerpts ?
  • PHP Manual
  • SphinxClient
  • Add query to multi-query batch

SphinxClient::addQuery

(PECL sphinx >= 0.1.0)

SphinxClient::addQuery — Add query to multi-query batch

说明

public SphinxClient::addQuery ( string $query , string $index = "*" , string $comment = "" ) : int

Adds query with the current settings to multi-query batch. This method doesn't affect current settings (sorting, filtering, grouping etc.) in any way.

参数

query

Query string.

index

An index name (or names).

comment

返回值

Returns an index in an array of results that will be returned by SphinxClient::runQueries call or false on error.

参见

  • SphinxClient::runQueries
  • SphinxClient::query


Build text snippets

  • ? SphinxClient::addQuery
  • SphinxClient::buildKeywords ?
  • PHP Manual
  • SphinxClient
  • Build text snippets

SphinxClient::buildExcerpts

(PECL sphinx >= 0.1.0)

SphinxClient::buildExcerpts — Build text snippets

说明

public SphinxClient::buildExcerpts ( array $docs , string $index , string $words , array $opts = ? ) : array|false

Connects to searchd, requests it to generate excerpts (snippets) from the given documents, and returns the results.

参数

docs

Array of strings with documents' contents.

index

Index name.

words

Keywords to highlight.

opts

Associative array of additional highlighting options (see below).

Highlighting options
Option | Description
"before_match" | A string to insert before a keyword match. Default is "<b>".
"after_match" | A string to insert after a keyword match. Default is "</b>".
"chunk_separator" | A string to insert between snippet chunks (passages). Default is " ... ".
"limit" | Maximum snippet size, in symbols (codepoints). Integer, default is 256.
"around" | How much words to pick around each matching keywords block. Integer, default is 5.
"exact_phrase" | Whether to highlight exact query phrase matches only instead of individual keywords. Boolean, default is false.
"single_passage" | Whether to extract single best passage only. Boolean, default is false.

返回值

Returns array of snippets on success 或者在失败时返回 false.


Extract keywords from query

  • ? SphinxClient::buildExcerpts
  • SphinxClient::close ?
  • PHP Manual
  • SphinxClient
  • Extract keywords from query

SphinxClient::buildKeywords

(PECL sphinx >= 0.1.0)

SphinxClient::buildKeywords — Extract keywords from query

说明

public SphinxClient::buildKeywords ( string $query , string $index , bool $hits ) : array

Extracts keywords from query using tokenizer settings for the given index, optionally with per-keyword occurrence statistics.

参数

query

A query to extract keywords from.

index

An index to get tokenizing settings and keyword occurrence statistics from.

hits

A boolean flag to enable/disable keyword statistics generation.

返回值

Returns an array of associative arrays with per-keyword information.


关闭先前打开的持久连接

  • ? SphinxClient::buildKeywords
  • SphinxClient::__construct ?
  • PHP Manual
  • SphinxClient
  • 关闭先前打开的持久连接

SphinxClient::close

(PECL sphinx >= 1.0.3)

SphinxClient::close — 关闭先前打开的持久连接

说明

public SphinxClient::close ( ) : bool

关闭先前打开的持久连接.

参数

此函数没有参数。

更新日志

PECL/sphinx 版本 | 说明
1.0.3 | 新增函数 SphinxClient::close(), 仅在编译时使用 libsphinxclient >= 0.9.9 有效.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::open


Create a new SphinxClient object

  • ? SphinxClient::close
  • SphinxClient::escapeString ?
  • PHP Manual
  • SphinxClient
  • Create a new SphinxClient object

SphinxClient::__construct

(PECL sphinx >= 0.1.0)

SphinxClient::__construct — Create a new SphinxClient object

说明

public SphinxClient::__construct ( )

Creates a new SphinxClient object.

参数

此函数没有参数。


Escape special characters

  • ? SphinxClient::__construct
  • SphinxClient::getLastError ?
  • PHP Manual
  • SphinxClient
  • Escape special characters

SphinxClient::escapeString

(PECL sphinx >= 0.1.0)

SphinxClient::escapeString — Escape special characters

说明

public SphinxClient::escapeString ( string $string ) : string

Escapes characters that are treated as special operators by the query language parser.

参数

string

String to escape.

返回值

Returns escaped string.


Get the last error message

  • ? SphinxClient::escapeString
  • SphinxClient::getLastWarning ?
  • PHP Manual
  • SphinxClient
  • Get the last error message

SphinxClient::getLastError

(PECL sphinx >= 0.1.0)

SphinxClient::getLastError — Get the last error message

说明

public SphinxClient::getLastError ( ) : string

Returns string with the last error message. If there were no errors during the previous API call, empty string is returned. This method doesn't reset the error message, so you can safely call it several times.

参数

此函数没有参数。

返回值

Returns the last error message or an empty string if there were no errors.

参见

  • SphinxClient::getLastWarning


Get the last warning

  • ? SphinxClient::getLastError
  • SphinxClient::open ?
  • PHP Manual
  • SphinxClient
  • Get the last warning

SphinxClient::getLastWarning

(PECL sphinx >= 0.1.0)

SphinxClient::getLastWarning — Get the last warning

说明

public SphinxClient::getLastWarning ( ) : string

Returns last warning message. If there were no warnings during the previous API call, empty string is returned. This method doesn't reset the warning, so you can safely call it several times.

参数

此函数没有参数。

返回值

Returns the last warning message or an empty string if there were no warnings.

参见

  • SphinxClient::getLastError


建立到搜索服务端的持久连接

  • ? SphinxClient::getLastWarning
  • SphinxClient::query ?
  • PHP Manual
  • SphinxClient
  • 建立到搜索服务端的持久连接

SphinxClient::open

(PECL sphinx >= 1.0.3)

SphinxClient::open — 建立到搜索服务端的持久连接

说明

public SphinxClient::open ( ) : bool

建立到搜索服务端的持久连接.

参数

此函数没有参数。

更新日志

PECL/sphinx 版本 | 说明
1.0.3 | 新增函数 SphinxClient::open(), 仅在编译时使用 libsphinxclient >= 0.9.9 有效.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::close


执行搜索查询

  • ? SphinxClient::open
  • SphinxClient::resetFilters ?
  • PHP Manual
  • SphinxClient
  • 执行搜索查询

SphinxClient::query

(PECL sphinx >= 0.1.0)

SphinxClient::query — 执行搜索查询

说明

public SphinxClient::query ( string $query , string $index = "*" , string $comment = "" ) : array

连接到searchd服务器，根据服务器的当前设置执行给定的查询，取得并返回结果集.

参数

query

查询字符串.

index

索引名称 (可以为多个，使用逗号分割，或者为"*"表示全部索引).

comment

发送到searchd的查询日志的注释内容

返回值

如果搜索成功, SphinxClient::query() 返回的结果集列表包含找到的全部匹配项中的一部分，以及与查询相关的统计数据. 结果集是哈希结构，包含如下键和值:

返回数据结构
键 | 值说明
"matches" | 存储文档ID以及其对应的另一个包含文档权重和属性值的hash表
"total" | 此查询在服务器检索所得的匹配文档总数（即服务器端结果集的大小，且与相关设置有关）
"total_found" | （服务器上找到和处理了的）索引中匹配文档的总数
"words" | 将查询关键字（关键字已经过大小写转换，取词干和其他处理）映射到一个包含关于关键字的统计数据（"docs"——在多少文档中出现，"hits"——共出现了多少次）的小hash表上。
"error" | searchd报告的错误信息
"warning" | searchd报告的警告信息

参见

  • SphinxClient::runQueries
  • SphinxClient::addQuery


Clear all filters

  • ? SphinxClient::query
  • SphinxClient::resetGroupBy ?
  • PHP Manual
  • SphinxClient
  • Clear all filters

SphinxClient::resetFilters

(PECL sphinx >= 0.1.0)

SphinxClient::resetFilters — Clear all filters

说明

public SphinxClient::resetFilters ( ) : void

Clears all currently set filters. This call is normally required when using multi-queries. You might want to set different filters for different queries in the batch. To do that, you should call SphinxClient::resetFilters() and add new filters using the respective calls.

返回值

没有返回值。

参见

  • SphinxClient::resetGroupBy


Clear all group-by settings

  • ? SphinxClient::resetFilters
  • SphinxClient::runQueries ?
  • PHP Manual
  • SphinxClient
  • Clear all group-by settings

SphinxClient::resetGroupBy

(PECL sphinx >= 0.1.0)

SphinxClient::resetGroupBy — Clear all group-by settings

说明

public SphinxClient::resetGroupBy ( ) : void

Clears all currently group-by settings, and disables group-by. This call is normally required only when using multi-queries.

返回值

没有返回值。

参见

  • SphinxClient::resetGroupBy


Run a batch of search queries

  • ? SphinxClient::resetGroupBy
  • SphinxClient::setArrayResult ?
  • PHP Manual
  • SphinxClient
  • Run a batch of search queries

SphinxClient::runQueries

(PECL sphinx >= 0.1.0)

SphinxClient::runQueries — Run a batch of search queries

说明

public SphinxClient::runQueries ( ) : array

Connects to searchd, runs a batch of all queries added using SphinxClient::addQuery, obtains and returns the result sets.

返回值

Returns false on failure and array of result sets on success.

参见

  • SphinxClient::addQuery
  • SphinxClient::query


控制搜索结果集的返回格式

  • ? SphinxClient::runQueries
  • SphinxClient::setConnectTimeout ?
  • PHP Manual
  • SphinxClient
  • 控制搜索结果集的返回格式

SphinxClient::setArrayResult

(PECL sphinx >= 0.1.0)

SphinxClient::setArrayResult — 控制搜索结果集的返回格式

说明

public SphinxClient::setArrayResult ( bool $array_result = false ) : bool

控制搜索结果集的返回格式（匹配项按数组返回还是按hash返回）.

参数

array_result

如果 array_result 设置为 false, 匹配项以PHP hash格式返回，文档ID为键，其他信息（权重、属性）为值。如果 array_result 设置为 true, 匹配项以普通数组返回，包括匹配项的全部信息（含文档ID）.

返回值

总是返回 true.


Set connection timeout

  • ? SphinxClient::setArrayResult
  • SphinxClient::setFieldWeights ?
  • PHP Manual
  • SphinxClient
  • Set connection timeout

SphinxClient::setConnectTimeout

(PECL sphinx >= 0.1.0)

SphinxClient::setConnectTimeout — Set connection timeout

说明

public SphinxClient::setConnectTimeout ( float $timeout ) : bool

Sets connection timeout (in seconds) for searchd connection.

参数

timeout

Timeout in seconds.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setMaxQueryTime


Set field weights

  • ? SphinxClient::setConnectTimeout
  • SphinxClient::setFilter ?
  • PHP Manual
  • SphinxClient
  • Set field weights

SphinxClient::setFieldWeights

(PECL sphinx >= 0.1.0)

SphinxClient::setFieldWeights — Set field weights

说明

public SphinxClient::setFieldWeights ( array $weights ) : bool

Binds per-field weights by name.

Match ranking can be affected by per-field weights. See » Sphinx documentation for an explanation on how phrase proximity ranking is affected. This call lets you specify non-default weights for full-text fields.

The weights must be positive 32-bit integers, so be careful not to hit 32-bit integer maximum. The final weight is a 32-bit integer too. Default weight value is 1. Unknown field names are silently ignored.

参数

weights

Associative array of field names and field weights.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setIndexWeights


增加整数值过滤器

  • ? SphinxClient::setFieldWeights
  • SphinxClient::setFilterFloatRange ?
  • PHP Manual
  • SphinxClient
  • 增加整数值过滤器

SphinxClient::setFilter

(PECL sphinx >= 0.1.0)

SphinxClient::setFilter — 增加整数值过滤器

说明

public SphinxClient::setFilter ( string $attribute , array $values , bool $exclude = false ) : bool

在已有的过滤器列表中添加新的过滤器.

参数

attribute

属性名称.

values

整数值数组.

exclude

如果设置为 true, 则匹配该过滤规则的文档会被排除在结果之外.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilterRange
  • SphinxClient::resetFilters


Add new float range filter

  • ? SphinxClient::setFilter
  • SphinxClient::setFilterRange ?
  • PHP Manual
  • SphinxClient
  • Add new float range filter

SphinxClient::setFilterFloatRange

(PECL sphinx >= 0.1.0)

SphinxClient::setFilterFloatRange — Add new float range filter

说明

public SphinxClient::setFilterFloatRange ( string $attribute , float $min , float $max , bool $exclude = false ) : bool

Adds new float range filter to the existing list of filters. Only those documents which have attribute value stored in the index between min and max (including values that are exactly equal to min or max) will be matched (or rejected, if exclude is true).

参数

attribute

An attribute name.

min

Minimum value.

max

Maximum value.

exclude

If set to true, matching documents are excluded from the result set.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setFilterRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters


Add new integer range filter

  • ? SphinxClient::setFilterFloatRange
  • SphinxClient::setGeoAnchor ?
  • PHP Manual
  • SphinxClient
  • Add new integer range filter

SphinxClient::setFilterRange

(PECL sphinx >= 0.1.0)

SphinxClient::setFilterRange — Add new integer range filter

说明

public SphinxClient::setFilterRange ( string $attribute , int $min , int $max , bool $exclude = false ) : bool

Adds new integer range filter to the existing list of filters. Only those documents which have attribute value stored in the index between min and max (including values that are exactly equal to min or max) will be matched (or rejected, if exclude is true).

参数

attribute

An attribute name.

min

Minimum value.

max

Maximum value.

exclude

If set to true, matching documents are excluded from the result set.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters


Set anchor point for a geosphere distance calculations

  • ? SphinxClient::setFilterRange
  • SphinxClient::setGroupBy ?
  • PHP Manual
  • SphinxClient
  • Set anchor point for a geosphere distance calculations

SphinxClient::setGeoAnchor

(PECL sphinx >= 0.1.0)

SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations

说明

public SphinxClient::setGeoAnchor ( string $attrlat , string $attrlong , float $latitude , float $longitude ) : bool

Sets anchor point for a geosphere distance (geodistance) calculations and enables them.

Once an anchor point is set, you can use magic "@geodist" attribute name in your filters and/or sorting expressions.

参数

attrlat

Name of a latitude attribute.

attrlong

Name of a longitude attribute.

latitude

Anchor latitude in radians.

longitude

Anchor longitude in radians.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilterRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters


Set grouping attribute

  • ? SphinxClient::setGeoAnchor
  • SphinxClient::setGroupDistinct ?
  • PHP Manual
  • SphinxClient
  • Set grouping attribute

SphinxClient::setGroupBy

(PECL sphinx >= 0.1.0)

SphinxClient::setGroupBy — Set grouping attribute

说明

public SphinxClient::setGroupBy ( string $attribute , int $func , string $groupsort = "@group desc" ) : bool

Sets grouping attribute, function, and group sorting mode, and enables grouping.

Grouping feature is very similar to GROUP BY clause in SQL. Results produced by this function call are going to be the same as produced by the following pseudo code: SELECT ... GROUP BY $func($attribute) ORDER BY $groupsort.

参数

attribute

A string containing group-by attribute name.

func

Constant, which sets a function applied to the attribute value in order to compute group-by key.

groupsort

An optional clause controlling how the groups are sorted.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::resetGroupBy
  • SphinxClient::setSortMode
  • SphinxClient::setGroupDistinct


Set attribute name for per-group distinct values count calculations

  • ? SphinxClient::setGroupBy
  • SphinxClient::setIDRange ?
  • PHP Manual
  • SphinxClient
  • Set attribute name for per-group distinct values count calculations

SphinxClient::setGroupDistinct

(PECL sphinx >= 0.1.0)

SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations

说明

public SphinxClient::setGroupDistinct ( string $attribute ) : bool

Sets attribute name for per-group distinct values count calculations. Only available for grouping queries. For each group, all values of attribute will be stored, then the amount of distinct values will be calculated and returned to the client. This feature is similar to COUNT(DISTINCT) clause in SQL.

参数

attribute

A string containing group-by attribute name.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setSortMode
  • SphinxClient::setGroupBy
  • SphinxClient::resetGroupBy


Set a range of accepted document IDs

  • ? SphinxClient::setGroupDistinct
  • SphinxClient::setIndexWeights ?
  • PHP Manual
  • SphinxClient
  • Set a range of accepted document IDs

SphinxClient::setIDRange

(PECL sphinx >= 0.1.0)

SphinxClient::setIDRange — Set a range of accepted document IDs

说明

public SphinxClient::setIDRange ( int $min , int $max ) : bool

Sets an accepted range of document IDs. Default range is from 0 to 0, i.e. no limit. Only those records that have document ID between min and max (including IDs exactly equal to min or max) will be matched.

参数

min

Minimum ID value.

max

Maximum ID value.

返回值

成功时返回 true， 或者在失败时返回 false。


Set per-index weights

  • ? SphinxClient::setIDRange
  • SphinxClient::setLimits ?
  • PHP Manual
  • SphinxClient
  • Set per-index weights

SphinxClient::setIndexWeights

(PECL sphinx >= 0.1.0)

SphinxClient::setIndexWeights — Set per-index weights

说明

public SphinxClient::setIndexWeights ( array $weights ) : bool

Sets per-index weights and enables weighted summing of match weights across different indexes.

参数

weights

An associative array mapping string index names to integer weights. Default is empty array, i.e. weighting summing is disabled.

返回值

成功时返回 true， 或者在失败时返回 false。


设置返回结果集偏移量和数目

  • ? SphinxClient::setIndexWeights
  • SphinxClient::setMatchMode ?
  • PHP Manual
  • SphinxClient
  • 设置返回结果集偏移量和数目

SphinxClient::setLimits

(PECL sphinx >= 0.1.0)

SphinxClient::setLimits — 设置返回结果集偏移量和数目

说明

public SphinxClient::setLimits ( int $offset , int $limit , int $max_matches = 0 , int $cutoff = 0 ) : bool

给服务器端结果集设置一个偏移量 offset 从那个偏移量起向客户端返回的匹配项数目限制(limit) . 并且可以在服务器端设定当前查询的结果集大小 (max_matches) ，另有一个阈值 (cutoff)，当找到的匹配项达到这个阀值时就停止搜索。

参数

offset

结果集的偏移量.

limit

返回的匹配项数目.

max_matches

设置控制搜索过程中searchd在内存中所保持的匹配项数目.

cutoff

该设置是为高级性能优化而提供的. 它告诉searchd 在找到并处理 cutoff 个匹配后就强制停止.

返回值

成功时返回 true， 或者在失败时返回 false。


设置全文查询的匹配模式

  • ? SphinxClient::setLimits
  • SphinxClient::setMaxQueryTime ?
  • PHP Manual
  • SphinxClient
  • 设置全文查询的匹配模式

SphinxClient::setMatchMode

(PECL sphinx >= 0.1.0)

SphinxClient::setMatchMode — 设置全文查询的匹配模式

说明

public SphinxClient::setMatchMode ( int $mode ) : bool

设置全文查询的匹配模式. mode 是以下列出的常量之一.

匹配模式
Constant | Description
SPH_MATCH_ALL | 匹配所有查询词（默认模式）.
SPH_MATCH_ANY | 匹配查询词中的任意一个.
SPH_MATCH_PHRASE | 将整个查询看作一个词组，要求按顺序完整匹配.
SPH_MATCH_BOOLEAN | 将查询看作一个布尔表达式.
SPH_MATCH_EXTENDED | 将查询看作一个Sphinx内部查询语言的表达式.
SPH_MATCH_FULLSCAN | 使用完全扫描，忽略查询词汇.
SPH_MATCH_EXTENDED2 | 类似 SPH_MATCH_EXTENDED ，并支持评分和权重.

参数

mode

匹配模式.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setRankingMode
  • SphinxClient::setSortMode


Set maximum query time

  • ? SphinxClient::setMatchMode
  • SphinxClient::setOverride ?
  • PHP Manual
  • SphinxClient
  • Set maximum query time

SphinxClient::setMaxQueryTime

(PECL sphinx >= 0.1.0)

SphinxClient::setMaxQueryTime — Set maximum query time

说明

public SphinxClient::setMaxQueryTime ( int $qtime ) : bool

Sets maximum search query time.

参数

qtime

Maximum query time, in milliseconds. It must be a non-negative integer. Default value is 0, i.e. no limit.

返回值

成功时返回 true， 或者在失败时返回 false。


Sets temporary per-document attribute value overrides

  • ? SphinxClient::setMaxQueryTime
  • SphinxClient::setRankingMode ?
  • PHP Manual
  • SphinxClient
  • Sets temporary per-document attribute value overrides

SphinxClient::setOverride

(PECL sphinx >= 1.0.3)

SphinxClient::setOverride — Sets temporary per-document attribute value overrides

说明

public SphinxClient::setOverride ( string $attribute , int $type , array $values ) : bool

Sets temporary (per-query) per-document attribute value overrides. Override feature lets you "temporary" update attribute values for some documents within a single query, leaving all other queries unaffected. This might be useful for personalized data

参数

attribute

An attribute name.

type

An attribute type. Only supports scalar attributes.

values

Array of attribute values that maps document IDs to overridden attribute values.

更新日志

PECL/sphinx 版本 | 说明
PECL sphinx 1.0.3 | Added SphinxClient::setOverride(), available only if compiled with libsphinxclient >= 0.9.9.

返回值

成功时返回 true， 或者在失败时返回 false。


Set ranking mode

  • ? SphinxClient::setOverride
  • SphinxClient::setRetries ?
  • PHP Manual
  • SphinxClient
  • Set ranking mode

SphinxClient::setRankingMode

(PECL sphinx >= 0.1.0)

SphinxClient::setRankingMode — Set ranking mode

说明

public SphinxClient::setRankingMode ( int $ranker ) : bool

Sets ranking mode. Only available in SPH_MATCH_EXTENDED2 matching mode.

Ranking modes
Constant | Description
SPH_RANK_PROXIMITY_BM25 | Default ranking mode which uses both proximity and BM25 ranking.
SPH_RANK_BM25 | Statistical ranking mode which uses BM25 ranking only (similar to most of other full-text engines). This mode is faster, but may result in worse quality on queries which contain more than 1 keyword.
SPH_RANK_NONE | Disables ranking. This mode is the fastest. It is essentially equivalent to boolean searching, a weight of 1 is assigned to all matches.

参数

ranker

Ranking mode.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setMatchMode


Set retry count and delay

  • ? SphinxClient::setRankingMode
  • SphinxClient::setSelect ?
  • PHP Manual
  • SphinxClient
  • Set retry count and delay

SphinxClient::setRetries

(PECL sphinx >= 0.1.0)

SphinxClient::setRetries — Set retry count and delay

说明

public SphinxClient::setRetries ( int $count , int $delay = 0 ) : bool

Sets distributed retry count and delay.

On temporary failures searchd will attempt up to count retries per agent. delay is the delay between the retries, in milliseconds. Retries are disabled by default. Note that this call will not make the API itself retry on temporary failure; it only tells searchd to do so.

参数

count

Number of retries.

delay

Delay between retries, in milliseconds.

返回值

成功时返回 true， 或者在失败时返回 false。


Set select clause

  • ? SphinxClient::setRetries
  • SphinxClient::setServer ?
  • PHP Manual
  • SphinxClient
  • Set select clause

SphinxClient::setSelect

(PECL sphinx >= 1.0.1)

SphinxClient::setSelect — Set select clause

说明

public SphinxClient::setSelect ( string $clause ) : bool

Sets the select clause, listing specific attributes to fetch, and expressions to compute and fetch.

参数

clause

SQL-like clause.

更新日志

PECL/sphinx 版本 | 说明
PECL sphinx 1.0.1 | Added SphinxClient::setSelect(), available only if compiled with libsphinxclient >= 0.9.9.

返回值

成功时返回 true， 或者在失败时返回 false。


设置searchd的主机名和TCP端口

  • ? SphinxClient::setSelect
  • SphinxClient::setSortMode ?
  • PHP Manual
  • SphinxClient
  • 设置searchd的主机名和TCP端口

SphinxClient::setServer

(PECL sphinx >= 0.1.0)

SphinxClient::setServer — 设置searchd的主机名和TCP端口

说明

public SphinxClient::setServer ( string $server , int $port ) : bool

设置searchd的主机名和TCP端口。此后的所有请求都使用新的主机和端口设置。默认的主机和端口分别是"localhost"和3312.

参数

server

IP 或者主机名.

port

端口.

返回值

成功时返回 true， 或者在失败时返回 false。


Set matches sorting mode

  • ? SphinxClient::setServer
  • SphinxClient::status ?
  • PHP Manual
  • SphinxClient
  • Set matches sorting mode

SphinxClient::setSortMode

(PECL sphinx >= 0.1.0)

SphinxClient::setSortMode — Set matches sorting mode

说明

public SphinxClient::setSortMode ( int $mode , string $sortby = ? ) : bool

Sets matches sorting mode. See available modes below.

Sorting modes
Constant | Description
SPH_SORT_RELEVANCE | Sort by relevance in descending order (best matches first).
SPH_SORT_ATTR_DESC | Sort by an attribute in descending order (bigger attribute values first).
SPH_SORT_ATTR_ASC | Sort by an attribute in ascending order (smaller attribute values first).
SPH_SORT_TIME_SEGMENTS | Sort by time segments (last hour/day/week/month) in descending order, and then by relevance in descending order.
SPH_SORT_EXTENDED | Sort by SQL-like combination of columns in ASC/DESC order.
SPH_SORT_EXPR | Sort by an arithmetic expression.

参数

mode

Sorting mode.

sortby

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • SphinxClient::setMatchMode
  • SphinxClient::setSortMode


Queries searchd status

  • ? SphinxClient::setSortMode
  • SphinxClient::updateAttributes ?
  • PHP Manual
  • SphinxClient
  • Queries searchd status

SphinxClient::status

(PECL sphinx >= 1.0.3)

SphinxClient::status — Queries searchd status

说明

public SphinxClient::status ( ) : array

Queries searchd status, and returns an array of status variable name and value pairs.

参数

此函数没有参数。

更新日志

PECL/sphinx 版本 | 说明
PECL sphinx 1.0.3 | Added SphinxClient::status(), available only if compiled with libsphinxclient >= 0.9.9.

返回值

Returns an associative array of search server statistics 或者在失败时返回 false.


Update document attributes

  • ? SphinxClient::status
  • 针对服务器的扩展 ?
  • PHP Manual
  • SphinxClient
  • Update document attributes

SphinxClient::updateAttributes

(PECL sphinx >= 0.1.0)

SphinxClient::updateAttributes — Update document attributes

说明

public SphinxClient::updateAttributes ( string $index , array $attributes , array $values , bool $mva = false ) : int

Instantly updates given attribute values in given documents.

参数

index

Name of the index (or indexes) to be updated.

attributes

Array of attribute names, listing attributes that are updated.

values

Associative array containing document IDs as keys and array of attribute values as values.

返回值

Returns number of actually updated documents (0 or more) on success, or false on failure.


针对服务器的扩展

  • Apache
    • 简介
    • 安装／配置
    • 预定义常量
    • Apache 函数
  • FastCGI 进程管理器
    • 简介
    • 安装／配置
    • FPM 函数


Apache

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Apache 函数
    • apache_child_terminate — 在本次请求结束后终止 apache 子进程
    • apache_get_modules — 获得已加载的Apache模块列表
    • apache_get_version — 获得Apache版本信息
    • apache_getenv — 获取 Apache subprocess_env 变量
    • apache_lookup_uri — 对指定的 URI 执行部分请求并返回所有有关信息
    • apache_note — 取得或设置 apache 请求记录
    • apache_request_headers — 获取全部 HTTP 请求头信息
    • apache_response_headers — 获得全部 HTTP 响应头信息
    • apache_setenv — 设置 Apache 子进程环境变量
    • getallheaders — 获取全部 HTTP 请求头信息
    • virtual — 执行 Apache 子请求


简介

这些函数仅在 PHP 以 Apache 模块运行时有效。

Note: 截至 PHP 4.3.2，和Apache 1的情况下相比，PATH_TRANSLATED 在 Apache 2 的 SAPI 模式下不再隐式设定，相同的值设定在 SCRIPT_FILENAME server 变量。 该变化符合 CGI 协议， PATH_TRANSLATED 应该仅仅存在于 PATH_INFO 定义后的情况。 Apache 2 用户可以在 httpd.conf 里使用 AcceptPathInfo = On 的设定来定义 PATH_INFO。


  • ? 需求
  • 运行时配置 ?
  • PHP Manual
  • 安装／配置
  • 安装

安装

PHP 安装到 Apache 参见 installation chapter。


运行时配置

Apache 的 PHP 模块的行为受 php.ini 的设置影响。在 php.ini 中的设置可以被服务器配置文件或本地的 .htaccess 文件中的 php_flag 设置所覆盖。

Example #1 用 .htaccess 禁用一个目录的 PHP 解析

php_flag engine off

Apache 配置选项
名字 | 默认 | 可修改范围 | 更新日志
engine | "1" | PHP_INI_ALL | 自 PHP 4.0.5 起可用
child_terminate | "0" | PHP_INI_ALL | 自 PHP 4.0.5 起可用
last_modified | "0" | PHP_INI_ALL | 自 PHP 4.0.5 起可用
xbithack | "0" | PHP_INI_ALL | 自 PHP 4.0.5 起可用
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

engine boolean

打开或关闭 PHP 解析。本指令仅在使用 PHP 的 Apache 模块版本时才有用。可以基于目录或者虚拟主机来打开或者关闭 PHP。将 engine off 放到 httpd.conf 文件中适当的位置就可以激活或禁用 PHP。

child_terminate boolean

指定 PHP 脚本在请求结束后是否可以要求终止子进程。参见 apache_child_terminate()。

last_modified boolean

在本次请求中发送一个头信息 Last-Modified:，显示 PHP 脚本最后被修改的日期。

xbithack boolean

不管文件结尾是什么，将文件作为 PHP 以可执行位组来解析。


  • ? 资源类型
  • Apache 函数 ?
  • PHP Manual
  • Apache
  • 预定义常量

预定义常量

此扩展没有定义常量。


Apache 函数

Table of Contents

  • apache_child_terminate — 在本次请求结束后终止 apache 子进程
  • apache_get_modules — 获得已加载的Apache模块列表
  • apache_get_version — 获得Apache版本信息
  • apache_getenv — 获取 Apache subprocess_env 变量
  • apache_lookup_uri — 对指定的 URI 执行部分请求并返回所有有关信息
  • apache_note — 取得或设置 apache 请求记录
  • apache_request_headers — 获取全部 HTTP 请求头信息
  • apache_response_headers — 获得全部 HTTP 响应头信息
  • apache_setenv — 设置 Apache 子进程环境变量
  • getallheaders — 获取全部 HTTP 请求头信息
  • virtual — 执行 Apache 子请求


在本次请求结束后终止 apache 子进程

  • ? Apache 函数
  • apache_get_modules ?
  • PHP Manual
  • Apache 函数
  • 在本次请求结束后终止 apache 子进程

apache_child_terminate

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

apache_child_terminate — 在本次请求结束后终止 apache 子进程

说明

apache_child_terminate ( ) : void

apache_child_terminate() 将把运行当前 PHP 请求的 Apache 子进程注册为终止状态，一旦结束 PHP 代码的运行此进程将终止。可以用在占用大量内存的脚本后面来终止该进程，因为通常内存只在内部释放而不会还给操作系统。

在 Apache 和 FastCGI 网页服务器中运行。

返回值

没有返回值。

注释

Note: 此函数未在 Windows 平台下实现。

参见

  • exit() - 输出一个消息并且退出当前脚本


获得已加载的Apache模块列表

  • ? apache_child_terminate
  • apache_get_version ?
  • PHP Manual
  • Apache 函数
  • 获得已加载的Apache模块列表

apache_get_modules

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

apache_get_modules — 获得已加载的Apache模块列表

说明

apache_get_modules ( ) : array

获得已加载的Apache模块列表。

返回值

包含已加载的Apache模块的数组.

更新日志

版本 | 说明
5.0.0 | 可用于Apache 1或PHP Apache 2 filter API。 在此之前, 只可用于 Apache 2 handler API。

范例

Example #1 apache_get_modules() 示例

<?php
print_r(apache_get_modules());
?>

以上例程的输出类似于：

Array
(
    [0] => core
    [1] => http_core
    [2] => mod_so
    [3] => sapi_apache2
    [4] => mod_mime
    [5] => mod_rewrite
)


获得Apache版本信息

  • ? apache_get_modules
  • apache_getenv ?
  • PHP Manual
  • Apache 函数
  • 获得Apache版本信息

apache_get_version

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

apache_get_version — 获得Apache版本信息

说明

apache_get_version ( ) : string

获得Apache版本信息。

返回值

成功时返回 Apache 版本信息 或者在失败时返回 false.

更新日志

版本 | 说明
4.3.4 | 可用于 Apache 1.
5.0.0 | 可用于 Apache 2 filter API.

范例

Example #1 apache_get_version() example

<?php
$version = apache_get_version();
echo "$version\n";
?>

以上例程的输出类似于：

Apache/1.3.29 (Unix) PHP/4.3.4

参见

  • phpinfo() - 输出关于 PHP 配置的信息


获取 Apache subprocess_env 变量

  • ? apache_get_version
  • apache_lookup_uri ?
  • PHP Manual
  • Apache 函数
  • 获取 Apache subprocess_env 变量

apache_getenv

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

apache_getenv — 获取 Apache subprocess_env 变量

说明

apache_getenv ( string $variable , bool $walk_to_top = false ) : string

获取 variable 指定的环境变量。

此函数需要 Apache 2 否则为 undefined。

参数

variable

Apache 环境变量

walk_to_top

是否获取对Apache各层可用的顶层变量

返回值

成功时返回 Apache 环境变量值，失败时返回 false

范例

Example #1 apache_getenv() example

该示例显示如何取得 Apache 环境变量 SERVER_ADDR的值。

<?php
$ret = apache_getenv("SERVER_ADDR");
echo $ret;
?>

以上例程的输出类似于：

42.24.42.240

参见

  • apache_setenv() - 设置 Apache 子进程环境变量
  • getenv() - 获取一个环境变量的值
  • Superglobals


对指定的 URI 执行部分请求并返回所有有关信息

  • ? apache_getenv
  • apache_note ?
  • PHP Manual
  • Apache 函数
  • 对指定的 URI 执行部分请求并返回所有有关信息

apache_lookup_uri

(PHP 4, PHP 5, PHP 7, PHP 8)

apache_lookup_uri — 对指定的 URI 执行部分请求并返回所有有关信息

说明

apache_lookup_uri ( string $filename ) : object

本函数对一个 URL 执行部分请求。取得所有有关给定资源的重要信息后就停手。

仅在 PHP 以 Apache 模块运行时，才支持此函数。

参数

filename

被请求的文件名（URI）。

返回值

一个有关 URI 信息的 object。此 object 的属性有：

  • status
  • the_request
  • status_line
  • method
  • content_type
  • handler
  • uri
  • filename
  • path_info
  • args
  • boundary
  • no_cache
  • no_local_copy
  • allowed
  • send_bodyct
  • bytes_sent
  • byterange
  • clength
  • unparsed_uri
  • mtime
  • request_time

范例

Example #1 apache_lookup_uri() 例子

<?php
$info = apache_lookup_uri('index.php?var=value');
print_r($info);

if (file_exists($info->filename)) {
    echo 'file exists!';
}
?>

以上例程的输出类似于：

stdClass Object
(
    [status] => 200
    [the_request] => GET /dir/file.php HTTP/1.1
    [method] => GET
    [mtime] => 0
    [clength] => 0
    [chunked] => 0
    [content_type] => application/x-httpd-php
    [no_cache] => 0
    [no_local_copy] => 1
    [unparsed_uri] => /dir/index.php?var=value
    [uri] => /dir/index.php
    [filename] => /home/htdocs/dir/index.php
    [args] => var=value
    [allowed] => 0
    [sent_bodyct] => 0
    [bytes_sent] => 0
    [request_time] => 1074282764
)
file exists!


取得或设置 apache 请求记录

  • ? apache_lookup_uri
  • apache_request_headers ?
  • PHP Manual
  • Apache 函数
  • 取得或设置 apache 请求记录

apache_note

(PHP 4, PHP 5, PHP 7, PHP 8)

apache_note — 取得或设置 apache 请求记录

说明

apache_note ( string $note_name , string $note_value = "" ) : string

这个函数是 Apache table_get 和 table_set 的包装。 它编辑了请求中存在的 notes 表。 这个表的目的是允许 Apache 模块进行通讯。

apache_note() 的主要用途是在同一个请求中，从一个模块传递信息到另一个模块。

参数

note_name

note 名。

note_value

note 值。

返回值

如果只有一个参数调用，则返回记录 note_name 的当前值。如果用两个参数调用，则将记录 note_name 的值设为 note_value 并返回记录 note_name 的前一个值。如果未能获取记录，则返回 false。

范例

Example #1 Passing information between PHP and Perl

<?php

apache_note('name', 'Fredrik Ekengren');

// Call perl script
virtual("/perl/some_script.pl");

$result = apache_note("resultdata");
?>
# Get Apache request object
my $r = Apache->request()->main();

# Get passed data
my $name = $r->notes('name');

# some processing

# Pass result back to PHP
$r->notes('resultdata', $result);

Example #2 Logging values in access.log

<?php

apache_note('sessionID', session_id());

?>
# "%{sessionID}n" can be used in the LogFormat directive

参见

  • virtual() - 执行 Apache 子请求


获取全部 HTTP 请求头信息

  • ? apache_note
  • apache_response_headers ?
  • PHP Manual
  • Apache 函数
  • 获取全部 HTTP 请求头信息

apache_request_headers

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

apache_request_headers — 获取全部 HTTP 请求头信息

说明

apache_request_headers ( ) : array

获取当前请求的所有请求头信息。 可在 Apache、FastCGI、CLI、FPM 模式下运行。

返回值

包含当前请求所有头信息的数组，失败返回 false。

更新日志

版本 | 说明
7.3.0 | 此函数可用于 FPM SAPI 模式。

范例

Example #1 apache_request_headers() 示例

<?php
$headers = apache_request_headers();

foreach ($headers as $header => $value) {
    echo "$header: $value <br />\n";
}
?>

以上例程的输出类似于：

Accept: */*
Accept-Language: en-us
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0
Host: www.example.com
Connection: Keep-Alive

注释

Note:

你也可以试图从环境变量中读取普通CGI变量，PHP以Apache模块方式运行时有可能无法获得。使用phpinfo()获得可读取的变量列表。 环境变量.

参见

  • apache_response_headers() - 获得全部 HTTP 响应头信息


获得全部 HTTP 响应头信息

  • ? apache_request_headers
  • apache_setenv ?
  • PHP Manual
  • Apache 函数
  • 获得全部 HTTP 响应头信息

apache_response_headers

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

apache_response_headers — 获得全部 HTTP 响应头信息

说明

apache_response_headers ( ) : array|false

获得全部 HTTP 响应头信息。 可在 Apache、FastCGI、CLI、FPM 模式下运行。

返回值

成功时返回包含全部 Apache 响应头信息的数组， 或者在失败时返回 false.

范例

Example #1 apache_response_headers() 示例

<?php
print_r(apache_response_headers());
?>

以上例程的输出类似于：

Array
(
    [Accept-Ranges] => bytes
    [X-Powered-By] => PHP/4.3.8
)

参见

  • apache_request_headers() - 获取全部 HTTP 请求头信息
  • headers_sent() - 检测 HTTP 头是否已经发送
  • headers_list() - 返回已发送的 HTTP 响应头（或准备发送的）


设置 Apache 子进程环境变量

  • ? apache_response_headers
  • getallheaders ?
  • PHP Manual
  • Apache 函数
  • 设置 Apache 子进程环境变量

apache_setenv

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

apache_setenv — 设置 Apache 子进程环境变量

说明

apache_setenv ( string $variable , string $value , bool $walk_to_top = false ) : bool

apache_setenv() 设置由variable指定的 Apache 环境变量值。

Note:

当设置了某 Apache 环境变量, 相应的 $_SERVER 变量不会改变。

参数

variable

将被设置的环境变量。

value

新 variable 值。

walk_to_top

是否将所设置的顶层变量应用到所有 Apache 层。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 使用 apache_setenv() 设置一个 Apache 环境变量

<?php
apache_setenv("EXAMPLE_VAR", "Example Value");
?>

注释

Note:

apache_setenv() 可与 apache_getenv() 配合使用，以在不同页面间传递变量，或将 PHP 脚本中已设置变量传入 Server Side Includes (.shtml)页面。

参见

  • apache_getenv() - 获取 Apache subprocess_env 变量


获取全部 HTTP 请求头信息

  • ? apache_setenv
  • virtual ?
  • PHP Manual
  • Apache 函数
  • 获取全部 HTTP 请求头信息

getallheaders

(PHP 4, PHP 5, PHP 7, PHP 8)

getallheaders — 获取全部 HTTP 请求头信息

说明

getallheaders ( ) : array

获取当前请求的所有请求头信息。

此函数是 apache_request_headers()的别名。 请阅读 apache_request_headers() 文档获得更多信息。

返回值

包含当前请求所有头信息的数组，失败返回 false 。

更新日志

版本 | 说明
5.5.7 | 此函数可用于 CLI server。
5.4.0 | 此函数可用于 FastCGI。 此前仅在PHP以 Apache 模块方式运行时支持。
4.3.0 | 4.3.0 | 被改名而成为 apache_request_headers() 的别名。因为此函数仅适用于 Apache 。

范例

Example #1 getallheaders() 示例

<?php

foreach (getallheaders() as $name => $value) {
    echo "$name: $value\n";
}

?>

参见

  • apache_response_headers() - 获得全部 HTTP 响应头信息


执行 Apache 子请求

  • ? getallheaders
  • FastCGI 进程管理器 ?
  • PHP Manual
  • Apache 函数
  • 执行 Apache 子请求

virtual

(PHP 4, PHP 5, PHP 7, PHP 8)

virtual — 执行 Apache 子请求

说明

virtual ( string $filename ) : bool

virtual() 是一个 Apache 特有函数， 类似于 mod_include 中的 <!--#include virtual...-->。 它执行一个 Apache 子请求。可用于包含一个 CGI 脚本或 .shtml 文件，或任何其它可通过 Apache 解析的请求。注意对一个 CGI 脚本，该脚本 生成合法的 CGI 头，至少必须 生成Content-Type 头。

为运行子请求，所有缓冲将中止并刷新至浏览器，包括头信息。

仅在 PHP 以 Apache 模块运行时，才支持此函数。

参数

filename

virtual命令将执行的文件

返回值

成功执行 virtual 命令，或失败时返回 false 。

范例

示例请看 apache_note() 。

注释

Warning

查询字符串可被传递至被包含文件，但是 $_GET 是拷贝于父文件，仅有 $_SERVER['QUERY_STRING'] 将填充传递入的查询字符串。 且此查询字符串只在使用 Apache 2 时被填充。 此请求文件将不会显示在 Apache 访问日志中。

Note:

在被请求文件中设置的环境变量在原请求文件中不可见。

参见

  • apache_note() - 取得或设置 apache 请求记录


FastCGI 进程管理器

  • 简介
  • 安装／配置
  • FPM 函数
    • fastcgi_finish_request — 冲刷(flush)所有响应的数据给客户端


简介

FPM (FastCGI 进程管理器) 是一个可选的 PHP FastCGI 实现并且附加了一些（主要是）对高负载网站很有用的特性。

这个 SAPI 在 PHP 5.3.3 以后已经被绑定。


安装／配置

安装与配置 FPM 的信息可以在 PHP 手册的 installation and configuration section中被找到。


  • ? 安装／配置
  • fastcgi_finish_request ?
  • PHP Manual
  • FastCGI 进程管理器
  • FPM 函数

FPM 函数

Table of Contents

  • fastcgi_finish_request — 冲刷(flush)所有响应的数据给客户端


冲刷(flush)所有响应的数据给客户端

  • ? FPM 函数
  • Session 扩展 ?
  • PHP Manual
  • FPM 函数
  • 冲刷(flush)所有响应的数据给客户端

fastcgi_finish_request

(PHP 5 >= 5.3.3, PHP 7, PHP 8)

fastcgi_finish_request — 冲刷(flush)所有响应的数据给客户端

说明

fastcgi_finish_request ( ) : bool

此函数冲刷(flush)所有响应的数据给客户端并结束请求。 这使得客户端结束连接后，需要大量时间运行的任务能够继续运行。

返回值

成功时返回 true， 或者在失败时返回 false。


Session 扩展

  • Sessions — Session Handling
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Session 上传进度
    • 会话和安全
    • Session 函数
    • SessionHandler — The SessionHandler class
    • SessionHandlerInterface — The SessionHandlerInterface class


Session Handling

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • 基本用法
    • 传送会话ID
    • 自定义会话管理器
  • Session 上传进度
  • 会话和安全
    • 会话管理基础
    • 和会话安全相关的配置项
  • Session 函数
    • session_abort — Discard session array changes and finish session
    • session_cache_expire — 返回当前缓存的到期时间
    • session_cache_limiter — 读取/设置缓存限制器
    • session_commit — session_write_close 的别名
    • session_create_id — Create new session id
    • session_decode — 解码会话数据
    • session_destroy — 销毁一个会话中的全部数据
    • session_encode — 将当前会话数据编码为一个字符串
    • session_gc — Perform session data garbage collection
    • session_get_cookie_params — 获取会话 cookie 参数
    • session_id — 获取/设置当前会话 ID
    • session_is_registered — 检查变量是否在会话中已经注册
    • session_module_name — 获取/设置会话模块名称
    • session_name — 读取/设置会话名称
    • session_regenerate_id — 使用新生成的会话 ID 更新现有会话 ID
    • session_register_shutdown — 关闭会话
    • session_reset — Re-initialize session array with original values
    • session_save_path — 读取/设置当前会话的保存路径
    • session_set_cookie_params — 设置会话 cookie 参数
    • session_set_save_handler — 设置用户自定义会话存储函数
    • session_start — 启动新会话或者重用现有会话
    • session_status — 返回当前会话状态
    • session_unregister — Unregister a global variable from the current session
    • session_unset — 释放所有的会话变量
    • session_write_close — Write session data and end session
  • SessionHandler — The SessionHandler class
    • SessionHandler::close — Close the session
    • SessionHandler::create_sid — Return a new session ID
    • SessionHandler::destroy — Destroy a session
    • SessionHandler::gc — Cleanup old sessions
    • SessionHandler::open — Initialize session
    • SessionHandler::read — Read session data
    • SessionHandler::write — Write session data
  • SessionHandlerInterface — The SessionHandlerInterface class
    • SessionHandlerInterface::close — Close the session
    • SessionHandlerInterface::destroy — Destroy a session
    • SessionHandlerInterface::gc — Cleanup old sessions
    • SessionHandlerInterface::open — Initialize session
    • SessionHandlerInterface::read — Read session data
    • SessionHandlerInterface::write — Write session data


简介

会话支持在 PHP 中是在并发访问时由一个方法来保存某些数据.从而使你能够构建更多的定制程序 从而提高你的 web 网站的吸引力.

一个访问者访问你的 web 网站将被分配一个唯一的 id, 就是所谓的会话 id. 这个 id 可以存储在用户端的一个 cookie 中，也可以通过 URL 进行传递.

会话支持允许你将请求中的数据保存在超全局数组$_SESSION中. 当一个访问者访问你的网站，PHP 将自动检查(如果 session.auto_start 被设置为 1）或者在你要求下检查(明确通过 session_start() 或者隐式通过 session_register()) 当前会话 id 是否是先前发送的请求创建. 如果是这种情况， 那么先前保存的环境将被重建.

Caution

如果你打开了 session.auto_start 那么 将对象放入会话的唯一方法是使用 auto_prepend_file 来加载定义这个对象的类，其中，在加载的定义的类时，你不得不使用 serialize() 你得对象，并且事后 unserialize() 它.

$_SESSION (和所有已注册得变量) 将被 PHP 使用内置的序列化方法在请求完成时 进行序列化.序列化方法可以通过 session.serialize_handler 这个 PHP 配置选项中来设置一个指定的方法.注册的变量未定义将被标记为未定义.在并发访问时,这些变量不会被会话模块 定义除非用户后来定义了它们.

Warning

因为会话数据是被序列化的，resource 变量不能被存储在会话中.

序列化句柄 (php 和 php_binary) 会受到 register_globals 的限制. 而且，数字索引或者字符串索引包含的特殊字符(| 和 !) 不能被使用. 使用这些字符将脚本执行关闭时的最后出现错误. php_serialize 没有这样的限制.php_serialize 从 PHP 5.5.4 以后可用.

Note:

请注意当会话工作时，会话的记录并没有被创建 直到一个变量已经被使用 session_register() 注册或者被添加一个新元素到 $_SESSION 全局数组中. 这点一直有效，无论是否使用 session_start() 函数 来开始会话.

Note:

在 PHP 5.2.2 有一个没有在文档中说明的特性是用文件存储时，即使是 在 open_basedir 被启用，并且 "/tmp" 没有被添加到 允许路径列表中，也能将会话存储到 "/tmp" 目录. 这个特性在 PHP 5.3.0 时已经从 PHP 中被移除了.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Sessions
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

构建此扩展不需要其他扩展。

Note:

你可以选择使用由 Ralf S. Engelschall 开发的 Shared Memory Allocation 来作为会话存储. 你需要到 » mm 然后安装它. 这个可选功能在 Windows 平台不可用.注意 mm 的这个会话存储模块无法保证并发访问时相同会话间正确的互锁. 它可能更多地是适用与存储会话到文件的使用在基于文件系统(比如 Solaris/Linux 的tmpfs， 或者 BSD 上的/dev/md) 的共享内存，因为他们能够正确互锁. 因为会话数据是存储在内存从而当web 服务器重启时数据将被删除.


安装

会话的支持在 PHP 默认为激活。如果不想在 PHP 中加入会话支持，应在配置时指定 --disable-session 选项。要为会话存储使用共享内存分配（mm），配置 PHP 时指定 --with-mm[=DIR] 。

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。

Note:

默认情况下，所有与特定会话相关的数据都被存储在由 INI 选项 session.save_path 指定的目录下的一个文件中。对每个会话会建立一个文件（不论是否有数据与该会话相关）。这是由于每打开一个会话即建立一个文件，不论是否有数据写入到该文件中。注意由于和文件系统协同工作的限制，此行为有个副作用，有可能造成用户定制的会话处理器（例如用数据库）丢失了未存储数据的会话。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

会话配置选项
名字 | 默认 | 可修改范围 | 更新日志
session.save_path | "" | PHP_INI_ALL |
session.name | "PHPSESSID" | PHP_INI_ALL |
session.save_handler | "files" | PHP_INI_ALL |
session.auto_start | "0" | PHP_INI_PERDIR |
session.gc_probability | "1" | PHP_INI_ALL |
session.gc_divisor | "100" | PHP_INI_ALL |
session.gc_maxlifetime | "1440" | PHP_INI_ALL |
session.serialize_handler | "php" | PHP_INI_ALL |
session.cookie_lifetime | "0" | PHP_INI_ALL |
session.cookie_path | "/" | PHP_INI_ALL |
session.cookie_domain | "" | PHP_INI_ALL |
session.cookie_secure | "" | PHP_INI_ALL |
session.cookie_httponly | "" | PHP_INI_ALL | 自 PHP 5.2.0 起有效
session.cookie_samesite | "" | PHP_INI_ALL | 自 PHP 7.3.0 起有效
session.use_strict_mode | "0" | PHP_INI_ALL | 自 PHP 5.5.2 起有效
session.use_cookies | "1" | PHP_INI_ALL |
session.use_only_cookies | "1" | PHP_INI_ALL |
session.referer_check | "" | PHP_INI_ALL |
session.cache_limiter | "nocache" | PHP_INI_ALL |
session.cache_expire | "180" | PHP_INI_ALL |
session.use_trans_sid | "0" | PHP_INI_ALL |
session.trans_sid_tags | "a=href,area=href,frame=src,form=" | PHP_INI_ALL | 自 PHP 7.1.0 起有效。
session.trans_sid_hosts | $_SERVER['HTTP_HOST'] | PHP_INI_ALL | 自 PHP 7.1.0 起有效。
session.sid_length | "32" | PHP_INI_ALL | 自 PHP 7.1.0 起有效。
session.sid_bits_per_character | "4" | PHP_INI_ALL | 自 PHP 7.1.0 起有效。
session.upload_progress.enabled | "1" | PHP_INI_PERDIR |
session.upload_progress.cleanup | "1" | PHP_INI_PERDIR |
session.upload_progress.prefix | "upload_progress_" | PHP_INI_PERDIR |
session.upload_progress.name | "PHP_SESSION_UPLOAD_PROGRESS" | PHP_INI_PERDIR |
session.upload_progress.freq | "1%" | PHP_INI_PERDIR |
session.upload_progress.min_freq | "1" | PHP_INI_PERDIR |
session.lazy_write | "1" | PHP_INI_ALL |
session.hash_function | "0" | PHP_INI_ALL | 自 PHP 7.1.0 起移除。
session.hash_bits_per_character | "4" | PHP_INI_ALL | 自 PHP 7.1.0 起移除。
session.entropy_file | "" | PHP_INI_ALL | 自 PHP 7.1.0 起移除。
session.entropy_length | "0" | PHP_INI_ALL | 自 PHP 7.1.0 起移除。
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

会话管理系统支持许多配置选项，可以在自己的 php.ini 文件中设定。这里只是个简短的概览。

session.save_handler string
session.save_handler defines the name of the handler which is used for storing and retrieving data associated with a session. Defaults to files. Note that individual extensions may register their own save_handlers; registered handlers can be obtained on a per-installation basis by referring to phpinfo(). See also session_set_save_handler().
session.save_path string
session.save_path 定义了传递给存储处理器的参数。如果选择了默认的 files 文件处理器，则此值是创建文件的路径。默认为 /tmp。参见 session_save_path()。

此指令还有一个可选的 N 参数来决定会话文件分布的目录深度。例如，设定为 '5;/tmp' 将使创建的会话文件和路径类似于 /tmp/4/b/1/e/3/sess_4b1e384ad74619bd212e236e52a5a174If。要使用 N 参数，必须在使用前先创建好这些目录。在 ext/session 目录下有个小的 shell 脚本名叫 mod_files.sh，windows 版本是 mod_files.bat 可以用来做这件事。此外注意如果使用了 N 参数并且大于 0，那么将不会执行自动垃圾回收，更多信息见 php.ini。另外如果用了 N 参数，要确保将 session.save_path 的值用双引号 "quotes" 括起来，因为分隔符分号（ ;）在 php.ini 中也是注释符号。

文件储存模块默认使用 mode 600 创建文件。通过 修改可选参数 MODE 来改变这种默认行为： N;MODE;/path ，其中 MODE 是 mode 的八进制表示。 MODE 设置不影响进程的掩码(umask)。

Warning

如果将此设定为一个全局可读的目录，例如 /tmp（默认值），服务器上的其他用户有可能通过该目录的文件列表破解会话。

Caution

使用以上描述的可选目录层级参数 N 时请注意，对于绝大多数站点，大于1或者2的值会不太合适——因为这需要创建大量的目录：例如，值设置为 3 需要在文件系统上创建 64^3 个目录，将浪费很多空间和 inode。

仅仅在绝对肯定站点足够大时，才可以设置 N 大于2。

session.name string
session.name 指定会话名以用做 cookie 的名字。只能由字母数字组成，默认为 PHPSESSID。参见 session_name()。
session.auto_start bool
session.auto_start 指定会话模块是否在请求开始时自动启动一个会话。默认为 0（不启动）。
session.serialize_handler string
session.serialize_handler 定义用来序列化／反序列化的处理器名字。 当前支持 PHP 序列化格式 (名为 php_serialize)、 PHP PHP 内部格式 (名为 php 及 php_binary) 和 WDDX (名为 wddx)。 如果 PHP 编译时加入了 WDDX 支持，则只能用 WDDX。 自 PHP 5.5.4 起可以使用 php_serialize。 php_serialize 在内部简单地直接使用 serialize/unserialize 函数，并且不会有 php 和 php_binary 所具有的限制。 使用较旧的序列化处理器导致 $_SESSION 的索引既不能是数字也不能包含特殊字符(| and !) 。 使用 php_serialize 避免脚本退出时，数字及特殊字符索引导致出错。 默认使用 php。
session.gc_probability int
session.gc_probability 与 session.gc_divisor 合起来用来管理 gc（garbage collection 垃圾回收）进程启动的概率。默认为 1。详见 session.gc_divisor。
session.gc_divisor int
session.gc_divisor 与 session.gc_probability 合起来定义了在每个会话初始化时启动 gc（garbage collection 垃圾回收）进程的概率。此概率用 gc_probability/gc_divisor 计算得来。例如 1/100 意味着在每个请求中有 1% 的概率启动 gc 进程。session.gc_divisor 默认为 100。
session.gc_maxlifetime int
session.gc_maxlifetime 指定过了多少秒之后数据就会被视为"垃圾"并被清除。 垃圾搜集可能会在 session 启动的时候开始（ 取决于session.gc_probability 和 session.gc_divisor）。

Note:

如果不同的脚本具有不同的 session.gc_maxlifetime 数值但是共享了同一个地方存储会话数据，则具有最小数值的脚本会清理数据。此情况下，与 session.save_path 一起使用本指令。

session.referer_check string
session.referer_check 包含有用来检查每个 HTTP Referer 的子串。如果客户端发送了 Referer 信息但是在其中并未找到该子串，则嵌入的会话 ID 会被标记为无效。默认为空字符串。
session.entropy_file string
session.entropy_file 给出了一个到外部资源（文件）的路径，该资源将在会话 ID 创建进程中被用作附加的熵值资源。例如在许多 Unix 系统下都可以用 /dev/random 或 /dev/urandom。 在 Windows 上自 PHP 5.3.3 起加入了此功能。 设置 session.entropy_length 为非零的值将使 PHP 使用 Windows Random API 作为熵值源。

Note: PHP 7.1.0 中移除。 自 PHP 5.4.0 起，默认情况下， session.entropy_file 在 /dev/urandom 或 /dev/arandom 可用的时候使用它们。 在 PHP 5.3.0 中此指令默认留空。

session.entropy_length int
session.entropy_length 指定了从上面的文件中读取的字节数。默认为 0（禁用）。 PHP 7.1.0 中移除。
session.use_strict_mode bool
session.use_strict_mode specifies whether the module will use strict session id mode. If this mode is enabled, the module does not accept uninitialized session IDs. If an uninitialized session ID is sent from the browser, a new session ID is sent to the browser. Applications are protected from session fixation via session adoption with strict mode. Defaults to 0 (disabled).

Note: Enabling session.use_strict_mode is mandatory for general session security. All sites are advised to enable this. See session_create_id() example code for more details.

Warning

If a custom session handler registered via session_set_save_handler() does not implement SessionUpdateTimestampHandlerInterface::validateId(), nor supplies the validate_sid callback, respectively, strict session ID mode is effectively disabled, regardless of the value of this directive. Particularly note that SessionHandler does not implement SessionHandler::validateId().

session.use_cookies bool
session.use_cookies 指定是否在客户端用 cookie 来存放会话 ID。默认为 1（启用）。
session.use_only_cookies bool
session.use_only_cookies 指定是否在客户端仅仅使用 cookie 来存放会话 ID。。启用此设定可以防止有关通过 URL 传递会话 ID 的攻击。自PHP 5.3.0开始，默认值为1（启用）
session.cookie_lifetime int
session.cookie_lifetime 以秒数指定了发送到浏览器的 cookie 的生命周期。值为 0 表示"直到关闭浏览器"。默认为 0。参见 session_get_cookie_params() 和 session_set_cookie_params()。

Note:

The expiration timestamp is set relative to the server time, which is not necessarily the same as the time in the client's browser.

session.cookie_path string
session.cookie_path 指定了要设定会话 cookie 的路径。默认为 /。参见 session_get_cookie_params() 和 session_set_cookie_params()。
session.cookie_domain string
session.cookie_domain 指定了要设定会话 cookie 的域名。默认为无，表示根据 cookie 规范产生 cookie 的主机名。参见 session_get_cookie_params() 和 session_set_cookie_params()。
session.cookie_secure bool
session.cookie_secure 指定是否仅通过安全连接发送 cookie。默认为 off。此设定是 PHP 4.0.4 添加的。参见 session_get_cookie_params() 和 session_set_cookie_params()。
session.cookie_httponly bool
Marks the cookie as accessible only through the HTTP protocol. This means that the cookie won't be accessible by scripting languages, such as JavaScript. This setting can effectively help to reduce identity theft through XSS attacks (although it is not supported by all browsers).
session.cookie_samesite string
Allows servers to assert that a cookie ought not to be sent along with cross-site requests. This assertion allows user agents to mitigate the risk of cross-origin information leakage, and provides some protection against cross-site request forgery attacks. Note that this is not supported by all browsers. An empty value means that no SameSite cookie attribute will be set. Lax and Strict mean that the cookie will not be sent cross-domain for POST requests; Lax will sent the cookie for cross-domain GET requests, while Strict will not.
session.cache_limiter string
session.cache_limiter 指定会话页面所使用的缓冲控制方法（ none/nocache/ private/ private_no_expire/public）。默认为 nocache。参见 session_cache_limiter() 文档查看各个值的含义。
session.cache_expire int
session.cache_expire 以分钟数指定缓冲的会话页面的存活期，此设定对 nocache 缓冲控制方法无效。默认为 180。参见 session_cache_expire()。
session.use_trans_sid bool
session.use_trans_sid 指定是否启用透明 SID 支持。默认为 0（禁用）。

Note: 基于 URL 的会话管理比基于 cookie 的会话管理有更多安全风险。例如用户有可能通过 email 将一个包含有效的会话 ID 的 URL 发给他的朋友，或者用户总是有可能在收藏夹中存有一个包含会话 ID 的 URL 来以同样的会话 ID 去访问站点。 自 PHP 7.1.0 开始，透明 SID 开始使用完整的 URL 绝对路径，例如 https://php.net/。 在此之前 PHP 只会使用相对路径。使用 session.trans_sid_hosts 定义重写的目标 host。

session.trans_sid_tags string
session.trans_sid_tags specifies which HTML tags are rewritten to include session id when transparent sid support is enabled. Defaults to a=href,area=href,frame=src,input=src,form= form is special tag. <input hidden="session_id" name="session_name"> is added as form variable.

Note: Before PHP 7.1.0, url_rewriter.tags was used for this purpose. Since PHP 7.1.0, fieldset is no longer considered as special tag.

session.trans_sid_hosts string
session.trans_sid_hosts specifies which hosts are rewritten to include session id when transparent sid support is enabled. Defaults to $_SERVER['HTTP_HOST'] Multiple hosts can be specified by ",", no space is allowed between hosts. e.g. php.net,wiki.php.net,bugs.php.net
session.sid_length int
session.sid_length allows you to specify the length of session ID string. Session ID length can be between 22 to 256. The default is 32. If you need compatibility you may specify 32, 40, etc. Longer session ID is harder to guess. At least 32 chars are recommended.
Tip

Compatibility Note: Use 32 instead of
session.hash_function=0 (MD5) and
session.hash_bits_per_character=4,
session.hash_function=1 (SHA1) and
session.hash_bits_per_character=6. Use 26 instead of
session.hash_function=0 (MD5) and
session.hash_bits_per_character=5. Use 22 instead of
session.hash_function=0 (MD5) and
session.hash_bits_per_character=6. You must
configure INI values to have at least 128 bits in session ID. Do
not forget to set an appropriate value for
session.sid_bits_per_character, otherwise you
will have weaker session ID.

Note: This setting is introduced in PHP 7.1.0.

session.sid_bits_per_character int
session.sid_per_character allows you to specify the number of bits in encoded session ID character. The possible values are '4' (0-9, a-f), '5' (0-9, a-v), and '6' (0-9, a-z, A-Z, "-", ","). The default is 4. The more bits results in stronger session ID. 5 is recommended value for most environments.

Note: This setting is introduced in PHP 7.1.0.

session.hash_function mixed
session.hash_function 允许用户指定生成会话 ID 的散列算法。'0' 表示 MD5（128 位），'1' 表示 SHA-1（160 位）。

Since PHP 5.3.0 it is also possible to specify any of the algorithms provided by the hash extension (if it is available), like sha512 or whirlpool. A complete list of supported algorithms can be obtained with the hash_algos() function.

Note:

这是 PHP 5 引进的。

session.hash_bits_per_character int
session.hash_bits_per_character 允许用户定义将二进制散列数据转换为可读的格式时每个字符存放多少个比特。可能值为 '4'（0-9，a-f），'5'（0-9，a-v），以及 '6'（0-9，a-z，A-Z，"-"，","）。

Note:

这是 PHP 5 引进的。

session.upload_progress.enabled boolean
Enables upload progress tracking, populating the $_SESSION variable. Defaults to 1, enabled.
session.upload_progress.cleanup boolean
Cleanup the progress information as soon as all POST data has been read (i.e. upload completed). Defaults to 1, enabled.

Note: It is highly recommended to keep this feature enabled.

session.upload_progress.prefix string
A prefix used for the upload progress key in the $_SESSION. This key will be concatenated with the value of $_POST[ini_get("session.upload_progress.name")] to provide a unique index. Defaults to "upload_progress_".
session.upload_progress.name string
The name of the key to be used in $_SESSION storing the progress information. See also session.upload_progress.prefix. If $_POST[ini_get("session.upload_progress.name")] is not passed or available, upload progressing will not be recorded. Defaults to "PHP_SESSION_UPLOAD_PROGRESS".
session.upload_progress.freq mixed
Defines how often the upload progress information should be updated. This can be defined in bytes (i.e. "update progress information after every 100 bytes"), or in percentages (i.e. "update progress information after receiving every 1% of the whole filesize"). Defaults to "1%".
session.upload_progress.min_freq int
The minimum delay between updates, in seconds. Defaults to "1" (one second).
session.lazy_write bool
session.lazy_write, when set to 1, means that session data is only rewritten if it changes. Defaults to 1, enabled.

Upload progress will not be registered unless session.upload_progress.enabled is enabled, and the $_POST[ini_get("session.upload_progress.name")] variable is set. See Session Upload Progress for mor details on this functionality.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SID (string)
包含着会话名以及会话 ID 的常量，格式为 "name=ID"，或者如果会话 ID 已经在适当的会话 cookie 中设定时则为空字符串。 这和 session_id() 返回的是同一个 ID。
PHP_SESSION_DISABLED (int)
自 PHP 5.4.0 起。如果会话已禁用则返回 session_status() 的值。
PHP_SESSION_NONE (int)
自 PHP 5.4.0 起。在会话已启用但是没有会话的时候返回 session_status() 的值。
PHP_SESSION_ACTIVE (int)
自 PHP 5.4.0 起。在一个会话已启用并存在时返回 session_status() 的值。


  • ? 预定义常量
  • 基本用法 ?
  • PHP Manual
  • Sessions
  • 范例

范例

Table of Contents

  • 基本用法
  • 传送会话ID
  • 自定义会话管理器


基本用法

通过为每个独立用户分配唯一的会话 ID，可以实现针对不同用户分别存储数据的功能。 会话通常被用来在多个页面请求之间保存及共享信息。 一般来说，会话 ID 通过 cookie 的方式发送到浏览器，并且在服务器端也是通过会话 ID 来取回会话中的数据。 如果请求中不包含会话 ID 信息，那么 PHP 就会创建一个新的会话，并为新创建的会话分配新的 ID。

会话的工作流程很简单。当开始一个会话时，PHP 会尝试从请求中查找会话 ID （通常通过会话 cookie）， 如果请求中不包含会话 ID 信息，PHP 就会创建一个新的会话。 会话开始之后，PHP 就会将会话中的数据设置到 $_SESSION 变量中。 当 PHP 停止的时候，它会自动读取 $_SESSION 中的内容，并将其进行序列化， 然后发送给会话保存管理器来进行保存。

默认情况下，PHP 使用内置的文件会话保存管理器（files）来完成会话的保存。 也可以通过配置项 session.save_handler 来修改所要采用的会话保存管理器。 对于文件会话保存管理器，会将会话数据保存到配置项 session.save_path 所指定的位置。

可以通过调用函数 session_start() 来手动开始一个会话。 如果配置项 session.auto_start 设置为1， 那么请求开始的时候，会话会自动开始。

PHP 脚本执行完毕之后，会话会自动关闭。 同时，也可以通过调用函数 session_write_close() 来手动关闭会话。

Example #1 在 $_SESSION 中注册变量。

<?php
session_start();
if (!isset($_SESSION['count'])) {
  $_SESSION['count'] = 0;
} else {
  $_SESSION['count']++;
}
?>

Example #2 从 $_SESSION 中反注册变量。

<?php
session_start();
unset($_SESSION['count']);
?>

Caution

千万不要使用 unset($_SESSION) 来复位超级变量 $_SESSION， 因为这样会导致无法继续在 $_SESSION 中注册会话变量。

Warning

由于无法将一个引用恢复到另外一个变量， 所以不可以将引用保存到会话变量中。

Note:

无论是通过调用函数 session_start() 手动开启会话， 还是使用配置项 session.auto_start 自动开启会话， 对于基于文件的会话数据保存（PHP 的默认行为）而言， 在会话开始的时候都会给会话数据文件加锁， 直到 PHP 脚本执行完毕或者显式调用 session_write_close() 来保存会话数据。 在此期间，其他脚本不可以访问同一个会话数据文件。

对于大量使用 Ajax 或者并发请求的网站而言，这可能是一个严重的问题。 解决这个问题最简单的做法是如果修改了会话中的变量， 那么应该尽快调用 session_write_close() 来保存会话数据并释放文件锁。 还有一种选择就是使用支持并发操作的会话保存管理器来替代文件会话保存管理器。


传送会话ID

有两种方式用来传送会话 ID：

  • Cookies
  • URL 参数

会话模块支持这两种方式。 Cookie 方式相对好一些，但是用户可能在浏览器中关闭 Cookie，所以 第二种方案就是把会话 ID 直接并入到 URL 中，以保证会话 ID 的传送。

无需开发人员干预，PHP 就可以自动处理 URL 传送会话 ID 的场景。 如果启用了 session.use_trans_sid 选项， PHP 将会自动在相对 URI 中包含会话 ID。

Note:

arg_separator.output php.ini 配置指令允许你自定义会话 ID 参数分隔符。 可以设定为 & 来保持和 XHTML 的一致性。

会话开始之后，可以使用 SID 常量。 如果客户端未提供会话 cookie，该常量的展开形式为 session_name=session_id， 反之，该常量为空字符串。因此，可以直接在 URL 中包含此常量的展开字符串而无需考虑会话 ID 的实际传送方式。

下例演示了如何在会话中注册变量以及如何使用 SID 常量正确的链接到另一页面。

Example #1 某单一用户的点击数

<?php

session_start();

if (empty($_SESSION['count'])) {
   $_SESSION['count'] = 1;
} else {
   $_SESSION['count']++;
}
?>

<p>
Hello visitor, you have seen this page <?php echo $_SESSION['count']; ?> times.
</p>

<p>
To continue, <a href="nextpage.php?<?php echo htmlspecialchars(SID); ?>">click
here</a>.
</p>

可以使用 htmlspecialchars() 来打印 SID 常量的展开字符串以避免 XSS 相关的攻击。

如果使用 --enable-trans-sid 参数编译的 PHP， 上例中打印 SID 常量部分就可以省略。

Note:

非相对 URL 将被视为指向外部站点的链接， 从安全角度考虑，外站的链接 URL 中将 不包含 SID 常量，以避免将 SID 泄露到外部服务器的风险。


自定义会话管理器

如果需要在数据库中或者以其他方式存储会话数据， 需要使用 session_set_save_handler() 函数来创建一系列用户级存储函数。 PHP 5.4.0 之后，你可以使用 SessionHandlerInterface 类 或者通过继承 SessionHandler 类来扩展内置的管理器， 从而达到自定义会话保存机制的目的。

函数 session_set_save_handler() 的参数即为在会话生命周期内要调用的一组回调函数： open， read， write 以及 close。 还有一些回调函数被用来完成垃圾清理：destroy 用来删除会话， gc 用来进行周期性的垃圾收集。

因此，会话保存管理器对于 PHP 而言是必需的。 默认情况下会使用内置的文件会话保存管理器。 可以通过 session_set_save_handler() 函数来设置自定义会话保存管理器。 一些 PHP 扩展也提供了内置的会话管理器，例如：sqlite， memcache 以及 memcached， 可以通过配置项 session.save_handler 来使用它们。

会话开始的时候，PHP 会调用 open 管理器，然后再调用 read 回调函数来读取内容，该回调函数返回已经经过编码的字符串。 然后 PHP 会将这个字符串解码，并且产生一个数组对象，然后保存至 $_SESSION 超级全局变量。

当 PHP 关闭的时候（或者调用了 session_write_close() 之后）， PHP 会对 $_SESSION 中的数据进行编码， 然后和会话 ID 一起传送给 write 回调函数。 write 回调函数调用完毕之后，PHP 内部将调用 close 回调函数。

销毁会话时，PHP 会调用 destroy 回调函数。

根据会话生命周期时间的设置，PHP 会不时地调用 gc 回调函数。 该函数会从持久化存储中删除超时的会话数据。 超时是指会话最后一次访问时间距离当前时间超过了 $lifetime 所指定的值。


Session 上传进度

Note: 此特性自 PHP 5.4.0 后可用。

当 session.upload_progress.enabled INI 选项开启时，PHP 能够在每一个文件上传时监测上传进度。 这个信息对上传请求自身并没有什么帮助，但在文件上传时应用可以发送一个POST请求到终端（例如通过XHR）来检查这个状态

当一个上传在处理中，同时POST一个与INI中设置的session.upload_progress.name同名变量时，上传进度可以在$_SESSION中获得。 当PHP检测到这种POST请求时，它会在$_SESSION中添加一组数据, 索引是 session.upload_progress.prefix 与 session.upload_progress.name连接在一起的值。 通常这些键值可以通过读取INI设置来获得，例如

<?php
$key = ini_get("session.upload_progress.prefix") . ini_get("session.upload_progress.name");
var_dump($_SESSION[$key]);
?>

通过将$_SESSION[$key]["cancel_upload"]设置为true，还可以取消一个正在处理中的文件上传。 当在同一个请求中上传多个文件，它仅会取消当前正在处理的文件上传和未处理的文件上传，但是不会移除那些已经完成的上传。 当一个上传请求被这么取消时，$_FILES中的error将会被设置为 UPLOAD_ERR_EXTENSION。

session.upload_progress.freq 和 session.upload_progress.min_freq INI选项控制了上传进度信息应该多久被重新计算一次。 通过合理设置这两个选项的值，这个功能的开销几乎可以忽略不计。

Example #1 样例信息

一个上传进度数组的结构的例子

<form action="upload.php" method="POST" enctype="multipart/form-data">
 <input type="hidden" name="<?php echo ini_get("session.upload_progress.name"); ?>" value="123" />
 <input type="file" name="file1" />
 <input type="file" name="file2" />
 <input type="submit" />
</form>

在session中存放的数据看上去是这样子的：

<?php
$_SESSION["upload_progress_123"] = array(
 "start_time" => 1234567890,   // The request time
 "content_length" => 57343257, // POST content length
 "bytes_processed" => 453489,  // Amount of bytes received and processed
 "done" => false,              // true when the POST handler has finished, successfully or not
 "files" => array(
  0 => array(
   "field_name" => "file1",       // Name of the <input/> field
   // The following 3 elements equals those in $_FILES
   "name" => "foo.avi",
   "tmp_name" => "/tmp/phpxxxxxx",
   "error" => 0,
   "done" => true,                // True when the POST handler has finished handling this file
   "start_time" => 1234567890,    // When this file has started to be processed
   "bytes_processed" => 57343250, // Amount of bytes received and processed for this file
  ),
  // An other file, not finished uploading, in the same request
  1 => array(
   "field_name" => "file2",
   "name" => "bar.avi",
   "tmp_name" => NULL,
   "error" => 0,
   "done" => false,
   "start_time" => 1234567899,
   "bytes_processed" => 54554,
  ),
 )
);

Warning

为了使这个正常工作，web服务器的请求缓冲区需要禁用，否则 PHP可能仅当文件完全上传完成时才能收到文件上传请求。 已知会缓冲这种大请求的程序有Nginx。

Caution

这个进度信息是在任意脚本被执行前写入session的，因此通过 ini_set()或session_name()修改session名将会导致一个没有上传进度信息的session。


会话和安全

Table of Contents

  • 会话管理基础
  • 和会话安全相关的配置项

外部链接：» 会话固定

HTTP 会话管理是 web 应用安全的核心内容， 要采用尽可能的手段来确保会话安全。 开发人员应该合理的启用或使用可接受的设置。


会话管理基础

会话安全

会话模块无法保证你存储在会话中的信息只能被创建会话的用户本人可见。 你需要采取额外的手段来保护会话中的机密信息， 至于采取何种方式来保护机密信息， 取决于你在会话中存储的数据的机密程度。

评估会话中存储的数据的重要性， 以及为此增加额外的保护机制， 通常需要付出一定的代价，同时会降低便利性。 例如，如果你需要保护用户免受社会工程学攻击， 你需要启用 session.use_only_cookies 选项。 这就要求用户在使用过程中，必须把浏览器设置为接受 cookie， 否则就无法正常使用会话功能了。

有很多种方式都可以导致会话 ID 被泄露给第三方。 例如，JavaScript 注入，URL 中包含会话 ID，数据包侦听， 或者直接访问你的物理设备等。 如果会话 ID 被泄漏给第三方， 那么他们就可以访问这个会话 ID 可以访问的全部资源。 首先，如果在 URL 中包含了会话 ID， 并且访问了外部的站点， 那么你的会话 ID 可能在外部站点的访问日志中被记录（referrer 请求头）。 另外，攻击者也可以监听你的网络通信，如果通信未加密， 那么会话 ID 将会在网络中以明文的形式进行传输。 针对这种情况的解决方案就是在服务端配置 SSL/TLS， 另外，使用 HSTS 可以达到更高的安全性。

Note: 即使使用 HTTPS 协议，也无法百分百保证机密数据不被泄漏。 例如，CRIME 和 BEAST 漏洞可以使得攻击者读取到你的数据。 另外，出于网络通信审计目的，很多网络中都存在 HTTPS MITM 代理， 可以读取 HTTPS 协议下的通信数据。 那么攻击者也可以搭建类似的代理服务器，用来窃取 HTTPS 协议下的通信数据。

严格会话管理

目前，默认情况下，PHP 是以自适应的方式来管理会话的， 这种方式使用起来很灵活，但是同样也带来了一定的风险。

从 PHP 5.5.2 开始，新增加了一个配置项： session.use_strict_mode。 当启用这个配置项，并且你所用的会话存储处理器支持的话，未经初始化的会话 ID 会被拒绝， 并为其生成一个全新的会话，这可以避免攻击者使用一个已知的会话 ID 来进行攻击。 例如，攻击者可以通过邮件给受害者发送一个包含会话 ID 的链接： http://example.com/page.php?PHPSESSID=123456789。 如果启用了 session.use_trans_sid 配置项， 那么受害者将会使用攻击者所提供的会话 ID 开始一个新的会话。 如果启用了 session.use_strict_mode 选项，就可以降低风险。

Warning

用户自定义的会话存储器也可以通过实现会话 ID 验证来支持严格会话模式。 建议用户在实现自己的会话存储器的时候， 一定要对会话 ID 的合法性进行验证。

在浏览器一侧，可以为用来保存会话 ID 的 cookie 设置域，路径， 仅允许 HTTP 访问，必须使用 HTTPS 访问等安全属性。 如果使用的是 PHP 7.3. 版本，还可以对 cookie 设置 SameSite 属性。 攻击者可以利用浏览器的这些特性来设置永久可用的会话 ID。 仅仅设置 session.use_only_cookies 配置项 无法解决这个问题。而 session.use_strict_mode 配置项 可以降低这种风险。设置 session.use_strict_mode=On， 来拒绝未经初始化的会话 ID。

Note: 虽然使用 session.use_strict_mode 配置项 可以降低灵活会话管理方式所带来的风险， 攻击者还是通过利用 JavaScript 注入等手段， 强制用户使用由攻击者创建的并且经过了正常的初始化的会话 ID。 如何降低这种风向，可以参考本手册的建议部分。 如果你已经启用了 session.use_strict_mode 配置项， 同时使用基于时间戳的会话管理， 并且通过设置 session_regenerate_id() 配置项 来重新生成会话 ID， 那么，攻击者生成的会话 ID 就可以被删除掉了。 当发生对过期会话访问的时候， 你应该保存活跃会话的所有数据， 以备后续分析使用。 然后让用户退出当前的会话，并且重新登录。 防止攻击者继续使用"偷"来的会话。

Warning

对过期会话数据的访问并不总是意味着正在遭受攻击。 不稳定的网络状况，或者不正确的会话删除行为， 都会导致合法的用户产生访问过期会话数据的情况。

从 PHP 7.1.0 开始，增加了 session_create_id() 函数。 这个函数允许开发者在会话 ID 中增加用户 ID 作为前缀， 以确保用户访问到正确对应的会话数据。 要使用这个函数， 请确保启用了 session.use_strict_mode 配置项， 否则恶意用户可能会伪造其他用户的会话 ID。

Note: 对于 PHP 7.1.0 之前的用户，应该使用 CSPRNG（例如 /dev/urandom） 或者 random_bytes() 函数以及哈希函数 来产生新的会话 ID。 session_create_id() 函数本身包含碰撞检测的能力， 并且根据 INI 文件中和会话相关的配置项来生成会话 ID。 所以，建议使用 session_create_id() 函数来生成会话 ID。

重新生成会话 ID

虽然 session.use_strict_mode 配置项可以降低风险，但是还不够。为了确保会话安全，开发者还需要使用 session_regenerate_id() 函数。

会话 ID 重生机制可以有效的降低会话被窃取的风险， 所以，必须周期性的调用 session_regenerate_id() 函数 来重新生成会话 ID， 例如，对于机密内容，每隔 15 分钟就重新生成会话 ID。 这样一来，即使会话 ID 被窃取， 那么攻击者所得到的会话 ID 也会很快的过期， 如果他们进一步访问，就会产生对过期会话数据访问的错误。

当用户成功通过认证之后，必须为其重新生成会话 ID。 并且，必须在向 $_SESSION 中保存用户认证信息之前 调用 session_regenerate_id() 函数（ 从 PHP 7.0.0 开始， session_regenerate_id() 函数 会自动将重生之前的会话数据保存到新生成的会话）。 请确保只有新的会话包含用户认证信息。

开发者不可过分依赖 session.gc_maxlifetime 配置项。 因为攻击者可以在受害者的会话过期之前访问系统， 并且维持这个会话的活动，以保证这个会话不会过期。

实际上，你需要自己实现基于时间戳的会话数据管理机制。

Warning

虽然会话管理器可以透明的管理时间戳，但是这个特性尚未完整的实现。 在 GC 发生之前，旧的会话数据还得保存， 同时，开发者还得保证过期的会话数据已经被移除。 但是，开发者又不能立即移除活跃会话中的数据。 所以，不要同时在活跃会话上调用 session_regenerate_id(true); 和 session_destroy() 函数。 这听起来有点儿自相矛盾，但是事实上必须得这么做。

默认情况下，session_regenerate_id() 函数 不会删除旧的会话， 所以即使重生了会话 ID，旧的会话可能还是可用的。 开发者需要使用时间戳等机制， 来确保旧的会话数据不会再次被访问。

Warning

删除活跃会话可能会带来非预期的一些影响。 例如，在网络状态不稳定，或者有并发请求到达 Web 服务器的情况下， 立即删除活跃会话可能导致个别请求会话失效的问题。

立即删除活跃会话也无法检测可能存在的恶意访问。

作为替代方案， 你要在 $_SESSION 中设置一个很短的过期时间， 然后根据这个时间戳来判断后续的访问是被允许的还是被禁止的。

在调用 session_regenerate_id() 函数之后， 不能立即禁止对旧的会话数据的访问，应该再一小段之间之后再禁止访问。 例如，在稳定的网络条件下，可以设置为几秒钟， 在不稳定的网络条件下，可以设置为几分钟。

如果用户访问了旧的会话数据（已经过期的）， 那么应该禁止访问。 建议从会话中移除这个用户的认证信息，因为这看起来像是在遭受攻击。

如果攻击者设置了不可删除的 cookie，那么使用 session.use_only_cookies 和 session_regenerate_id() 会导致正常用户遭受拒绝服务的问题。 如果发生这种情况，请让用户删除 cookie 并且警告用户他可能面临一些安全问题。 攻击者可以通过恶意的 Web 应用、浏览器插件以及对安全性较差的物理设备进行攻击 来伪造恶意的 cookie。

Warning

请勿误解这里的拒绝服务攻击风险所指的含义。 通常来讲，要保护会话 ID 的安全，use_strict_mode=On 是必须要做的。 建议所有的站点都启用 use_strict_mode=On。

只有当账号处于被攻击的时候，才会发生拒绝服务的问题。 通常都是由于应用中被注入了恶意的 JavaScript 才会导致这个问题。

会话中数据的删除

过期的会话中的数据应该是被删除的，并且不可访问。 现在的会话模块尚未很好的支持这种特性。

应该尽可能快的删除过期会话中的数据。 但是，活跃会话一定不要立即删除。 为了能够同时满足这两点要求， 你需要自己来实现基于时间戳的会话数据管理机制。

在 $_SESSION 中设置会话过期时间戳，并且对其进行管理， 以便能够阻止对于过期会话的访问。 当发生对于过期会话的访问时，建议从相关用户的所有会话中删除认证信息， 并且要求用户重新认证。 对于过期会话数据的访问可能是一种攻击行为， 为了保护会话数据，你需要追踪每个用户的活跃会话。

Note: 当用户处于不稳定的网络，或者 web 应用存在并发的请求的时候， 也可能发生对于过期会话数据的访问。 服务器尝试为用户设置新的会话 ID， 但是很可能由于网络原因，导致 Set-Cookie 的数据包无法到达用户的浏览器。 当通过 session_regenerate_id() 函数 为一个连接生成新的会话 ID 之后，其他的并发连接可能尚未得到这个新的会话 ID。 因此，不能立即阻止对于过期会话数据的访问，而是要延迟一个很小的时间段， 这就是为什么我们需要实现基于时间戳的会话管理。

简而言之，不要在调用 session_regenerate_id() 或者 session_destroy() 函数的时候立即删除旧的会话数据， 而是要通过一个时间戳来控制后续对于这个旧会话数据的访问。 从会话存储中删除数据的工作交给 session_gc() 函数来完成吧。

会话和锁定

默认情况下，为了保证会话数据在多个请求之间的一致性， 对于会话数据的访问是加锁进行的。

但是，这种锁定机制也会导致被攻击者利用，来进行对于用户的拒绝服务攻击。 为了降低这种风险，请在访问会话数据的时候，尽可能的缩短锁定的时间。 当某个请求不需要更新会话数据的时候，使用只读模式访问会话数据。 也就是说，在调用 session_start() 函数的时候， 使用 'read_and_close' 选项：session_start(['read_and_close'=>1]);。 另外，如果需要更新会话数据，那么在更新完毕之后， 马上调用 session_commit() 函数来释放对于会话数据的锁。

当会话不活跃的时候，当前的会话模块不会检测对于 $_SESSION 的修改。 你需要自己来保证 在会话处于不活跃状态的时候，不要去修改它。

活跃会话

开发者需要自己来追踪每个用户的活跃会话， 要知道每个用户创建了多少活跃会话，每个活跃会话来自那个 IP 地址， 活跃了多长时间等。 PHP 不会自动完成这项工作，需要开发者来完成。

有很多种方式可以做到追踪用户的活跃会话。 你可以通过在数据库中存储会话信息来跟踪用户会话。 由于会话是可以被垃圾收集器收集掉的， 所以你也需要处理被收集掉的会话数据， 以保证数据库中的数据和真实的活跃会话数据的一致性。

一种很简单的方式就是使用"使用用户 ID 作为会话 ID 前缀"，并且保存必要的信息到 $_SESSION 中。 大部分的数据库产品对于字符串前缀查询（译注：也即右模糊查询，可以利用索引）都有很好的性能表现。 为了实现这种方式，可以使用 session_regenerate_id() 和 session_create_id() 函数。

Warning

永远不要使用机密数据作为会话 ID 前缀！ 如果用户 ID 属于机密数据，那么可以考虑使用 hash_hmac() 函数对其进行摘要后再使用。

Warning

必须启用 session.use_strict_mode 配置项。 请确保已经启用， 否则活跃会话数据库可能会被入侵。

要能够检测对于过期会话数据的访问， 基于时间戳的会话数据管理机制是必不可少的。 当检测到对于过期会话数据的访问时，你应该从相关用户的活跃会话中删除认证信息， 避免攻击者持续使用盗取的会话。

会话和自动登录

开发者不应该通过使用长生命周期的会话 ID 来实现自动登录功能， 因为这种方式提高了会话被窃取的风险。 开发者应该自己实现自动登录的机制。

在使用 setcookie() 的时候，传入安全的一次性摘要结果作为自动登录信息。 建议使用比 SHA-2 更高强度的摘要算法（例如 SHA-256） 对 random_bytes() 随机生成的数据 （也可以读取 /dev/urandom 设备）进行摘要作为自动登录的信息。

在用户访问的时候，如果发现用户尚未认证， 那么就去检查请求中是否包含了有效的一次性登录信息。 如果包含有效的一次性登录信息，那么就去认证用户，并且重新生成新的一次性登录信息。 自动登录的关键信息一定是只能使用一次，永远不要重复使用一次性登录信息。

自动登录信息是长生命周期的认证信息， 所以必须要尽可能的妥善保护。 可以对于自动登录信息对应的 cookie 设置路径、仅允许 HTTP 访问、仅允许安全访问 等属性来加以保护，并且仅在必需的时候才传送这个 cookie。

开发者也要提供禁用自动登录的机制， 以及删除不再需要的自动登录数据的能力。

CSRF（跨站请求伪造）

会话和认证无法避免跨站请求伪造攻击。 开发者需要自己来实现保护应用不受 CSRF 攻击的功能。

output_add_rewrite_var() 函数可以用来 保护应用免受 CSRF 攻击。更多信息请参考文档。

Note: PHP 7.2.0 之前的版本，这个函数和会话 ID 使用了同样的输出缓冲以及 INI 设置项， 所以不建议在 PHP 7.2.0 之前使用 output_add_rewrite_var() 函数。

大部分 Web 应用框架都提供了 CSRF 保护的特性。 详细信息请参考你所用的 Web 框架的文档。

从 PHP 7.3 开始，对于会话 cookie 增加了 SameSite 属性， 这个属性可以有效的降低 CSRF 攻击的风险。


和会话安全相关的配置项

通过使用 INI 文件中和会话安全相关的配置项，来提高会话的安全性。 有一些重要的配置项没有默认值， 所以你需要自行设置。

  • session.cookie_lifetime=0

    0 表示特殊含义，它告知浏览器不要持久化存储 cookie 数据。 也即，关闭浏览器的时候，会话 ID cookie 会被立即删除。 如果将此项设置为非 0 的值， 可能会导致会话 ID 被其他用户使用。 大部分应用应该把此项设置为 "0"。

    如果应用中有自动登录的功能， 请自行实现一种更加安全的方式， 而不要使用长生命周期的会话 ID 来完成自动登录。 至于如何实现安全的自动登录功能，请参考本文档前面的内容。

  • session.use_cookies=On

    session.use_only_cookies=On

    虽然 HTTP cookie 存在一些问题， 但是它确实是实现会话 ID 管理的优选方案。 尽可能的仅使用 cookie 来进行会话 ID 管理， 而且大部分应用也确实是只使用 cookie 来记录会话 ID 的。

    如果 session.use_only_cookies=Off， 会话模块会在基于 cookie 的会话 ID 初始化之前 使用 GET/POST/URL 请求中的会话 ID（如果存在的话）。

  • session.use_strict_mode=On

    虽然启用 session.use_strict_mode 是必不可少的，但是默认情况下，这个配置项是未启用的。

    此设置防止会话模块使用未初始化的会话 ID。 也就是说， 会话模块仅接受由它自己创建的有效的会话 ID， 而拒绝由用户自己提供的会话 ID。

    攻击者可以自行设置 cookie 或者使用 JavaScript 注入的方式 来设置会话 ID 进行攻击。 启用 session.use_strict_mode 配置项 可以阻止使用未经会话模块初始化的会话 ID。

    Note:

    攻击者可以使用自己的设备产生会话 ID，也可以使用受害者的会话 ID。 攻击者也可以通过一些后续操作保证会话活跃。 因此，启用 session.use_strict_mode 配置项 可以降低这种风险。

  • session.cookie_httponly=On

    禁止 JavaScript 访问会话 cookie。 此设置项可以保护 cookie 不被 JavaScript 窃取。

    虽然可以使用会话 ID 来作为防范跨站请求伪造（CSRF）的关键数据， 但是不建议你这么做。例如，攻击者可以把 HTML 源代码保存下来并且发送给其他用户。 为了安全起见，开发者不应该在 web 页面中显示会话 ID。 几乎所有的应用都应该对会话 ID cookie 设置 httponly 为 On。

    Note:

    类似会话 ID，CSRF 保护串号也应该定期的更新。

  • session.cookie_secure=On

    仅允许在 HTTPS 协议下访问会话 ID cookie。 如果你的 web 站点仅支持 HTTPS，那么必须将此配置项设置为 On。

    对于仅支持 HTTPS 的 web 站点建议考虑使用强制安全传输技术（HSTS）。

  • session.cookie_samesite="Lax" 或者 session.cookie_samesite="Strict"

    自 PHP 7.3 开始，可以为会话 cookie 设置 "SameSite" 属性。 这个属性可以有效的降低 CSRF 攻击的风险。

    Lax 和 Strict 之间的区别是， 对于来自其他站点的并且携带了会话 cookie 的 GET 请求的处理方式不同。 设置为 Lax 会允许来自其他站点并且携带了会话 cookie 的请求， 设置为 Strict 则不会允许这种请求访问本站的会话数据。

  • session.gc_maxlifetime=[选择一个尽可能小的时间段]

    session.gc_maxlifetime 来设置删除过期会话数据的时间周期。 来的删除， 你需要自己来实现一套基于时间戳的会话数据生命周期管理机制。

    最好使用 session_gc() 函数来进行会话数据垃圾收集。 如果你是 UNIX 的操作系统， 最好使用类似 cron 这样的定时任务来执行 session_gc() 函数。

    GC 的运行时机并不是精准的，带有一定的或然性， 所以这个设置项并不能确保 旧的会话数据被删除。某些会话存储处理模块不使用此设置项。 更多的信息请参考会话存储模块的完整文档。 虽然开发人员不能完全依赖这个设置，但是还是建议将其设置的尽可能的小。 调整 session.gc_probability 和 session.gc_divisor 配置项 可以使得过期的会话数据在适当的周期内被删除。 如果需要使用自动登录的功能， 请使用其他更加安全的方式自行实现， 而不要通过使用长生命周期的会话 ID 来实现。

    Note:

    如果会话存储器将会话数据存储到 memcached 或者 mecache 这种自带超时机制的存储中， 就不依赖这个配置项来进行过期会话数据的垃圾收集。 更多信息请参考对应的会话存储器文档。

  • session.use_trans_sid=Off

    如果你有需要，可以使用会话 ID 透传机制。 但是，禁用会话 ID 透传机制可以 避免会话 ID 被注入以及泄漏， 有效的提高会话安全性。

    Note:

    会话 ID 可能在浏览器书签或者保存下来的 HTML 源代码中被泄漏。

  • session.trans_sid_tags=[限制标签]

    （PHP 7.1.0 及以上）一般情况下，默认值就可以， 你无需重写不需要的标签。 之前版本的 PHP 请使用 url_rewriter.tags 配置项。

  • session.trans_sid_hosts=[限制的主机名]

    （PHP 7.1.0 及以上）这个配置项设定允许进行会话 ID 透传的主机白名单。 请勿在其中加入你不信任的主机。 如果此配置项为空， 则仅允许 $_SERVER['HTTP_HOST'] 的站点进行会话 ID 透传。

  • session.referer_check=[原始 URL]

    当启用 session.use_trans_sid 配置项的时候， 这个设置可以降低会话 ID 注入的风险。 如果你的站点是 http://example.com/， 那么就把此项设置为 http://example.com/。 需要注意的是，如果使用了 HTTPS 协议， 那么浏览器在发起请求的时候不会包含 referrer 请求头。 建议启用此配置项，虽然它并不是可靠的安全措施。

  • session.cache_limiter=nocache

    确保对于已经认证的会话，其 HTTP 内容不会被浏览器缓存。 应该仅针对公开内容允许缓存， 否则将会面临内容泄露的风险。 即使 HTTP 内容不包含敏感数据， 也可以把它设置为"private"。 注意，"private"可能会导致客户端缓存私有数据。 仅在 HTTP 内容中不包含任何私有数据的时候，可以使用"public"。

  • session.sid_length="48"

    （PHP 7.1.0 及更高版本）更长的会话 ID 可以得到更高的安全强度。 建议开发者将会话 ID 的长度设置为不低于 32 个字符。 当 session.sid_bits_per_character="5" 时， 会话 ID 至少需要 26 个字符。

  • session.sid_bits_per_character="6"

    （PHP 7.1.0 及更高版本） 即使会话 ID 的长度设定不变， 更高的会话 ID 比特位设置也会产生安全性更高的会话 ID。

  • session.hash_function="sha256"

    （PHP 7.1.0 及更高版本）高强度的哈希算法可以生成更高安全性的会话 ID。 虽然说，即使是采用 MD5 哈希算法，要想生成完全一致的哈希结果都是不太现实的， 但是还是建议开发者使用 SHA-2 或者更高强度的哈希算法。 比如，可以考虑使用 sha384 和 sha512 哈希算法。 请确保 entropy 配置项的设置可以满足你所用的哈希算法对种子长度要求。


Session 函数

Table of Contents

  • session_abort — Discard session array changes and finish session
  • session_cache_expire — 返回当前缓存的到期时间
  • session_cache_limiter — 读取/设置缓存限制器
  • session_commit — session_write_close 的别名
  • session_create_id — Create new session id
  • session_decode — 解码会话数据
  • session_destroy — 销毁一个会话中的全部数据
  • session_encode — 将当前会话数据编码为一个字符串
  • session_gc — Perform session data garbage collection
  • session_get_cookie_params — 获取会话 cookie 参数
  • session_id — 获取/设置当前会话 ID
  • session_is_registered — 检查变量是否在会话中已经注册
  • session_module_name — 获取/设置会话模块名称
  • session_name — 读取/设置会话名称
  • session_regenerate_id — 使用新生成的会话 ID 更新现有会话 ID
  • session_register_shutdown — 关闭会话
  • session_reset — Re-initialize session array with original values
  • session_save_path — 读取/设置当前会话的保存路径
  • session_set_cookie_params — 设置会话 cookie 参数
  • session_set_save_handler — 设置用户自定义会话存储函数
  • session_start — 启动新会话或者重用现有会话
  • session_status — 返回当前会话状态
  • session_unregister — Unregister a global variable from the current session
  • session_unset — 释放所有的会话变量
  • session_write_close — Write session data and end session


Discard session array changes and finish session

  • ? Session 函数
  • session_cache_expire ?
  • PHP Manual
  • Session 函数
  • Discard session array changes and finish session

session_abort

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

session_abort — Discard session array changes and finish session

说明

session_abort ( ) : bool

session_abort() finishes session without saving data. Thus the original values in session data are kept.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.2.0 | The return type of this function is bool now. Formerly, it has been void.

参见

  • $_SESSION
  • The session.auto_start configuration directive
  • session_start() - 启动新会话或者重用现有会话
  • session_reset() - Re-initialize session array with original values
  • session_commit() - session_write_close 的别名


返回当前缓存的到期时间

  • ? session_abort
  • session_cache_limiter ?
  • PHP Manual
  • Session 函数
  • 返回当前缓存的到期时间

session_cache_expire

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

session_cache_expire — 返回当前缓存的到期时间

说明

session_cache_expire ( string $new_cache_expire = ? ) : int

session_cache_expire() 返回 session.cache_expire 的设定值。

请求开始的时候，缓存到期时间会被重置为 180，并且保存在 session.cache_expire 配置项中。 因此，针对每个请求，需要在 session_start() 函数调用之前 调用 session_cache_expire() 来设置缓存到期时间。

参数

new_cache_expire

如果给定 new_cache_expire ，就使用 new_cache_expire 的值设置当前缓存到期时间。

Note: 仅在 session.cache_limiter 的设置值 不是 nocache 的时候， 才可以设置 new_cache_expire 参数。

返回值

返回 session.cache_expire 的当前设置值， 以分钟为单位，默认值是 180 （分钟）。

范例

Example #1 session_cache_expire() 示例

<?php

/* 设置缓存限制为 "private" */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

/* 设置缓存过期时间为 30 分钟 */
session_cache_expire(30);
$cache_expire = session_cache_expire();

/* 开始会话 */

session_start();

echo "The cache limiter is now set to $cache_limiter<br />";
echo "The cached session pages expire after $cache_expire minutes";
?>

参见

  • session.cache_expire
  • session.cache_limiter
  • session_cache_limiter() - 读取/设置缓存限制器


读取/设置缓存限制器

  • ? session_cache_expire
  • session_commit ?
  • PHP Manual
  • Session 函数
  • 读取/设置缓存限制器

session_cache_limiter

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

session_cache_limiter — 读取/设置缓存限制器

说明

session_cache_limiter ( string $cache_limiter = ? ) : string

session_cache_limiter() 返回当前缓存限制器的名称。

缓存限制器定义了向客户端发送的 HTTP 响应头中的缓存控制策略。 客户端或者代理服务器通过检测这个响应头信息来 确定对于页面内容的缓存规则。 设置缓存限制器为 nocache 会进制客户端或者代理服务器缓存内容， public 表示允许客户端或代理服务器缓存内容， private 表示允许客户端缓存， 但是不允许代理服务器缓存内容。

在 private 模式下， 包括 Mozilla 在内的一些浏览器可能无法正确处理 Expire 响应头， 通过使用 private_no_expire 模式可以解决这个问题：在这种模式下， 不会向客户端发送 Expire 响应头。

设置为 '' 可以关闭 自动发送缓存策略响应头的功能。

请求开始的时候，缓存限制器会被重置为默认值，并且存储在 session.cache_limiter 配置项中。 因此，如果要设置缓存限制器，对于每个请求， 都需要在调用 session_start() 函数之前， 调用 session_cache_limiter() 函数来进行设置。

参数

cache_limiter

如果指定了 cache_limiter 参数， 将使用指定值作为缓存限制器的值。

可选的值
值 发送的响应头
public
Expires：（根据 session.cache_expire 的设定计算得出）
Cache-Control： public, max-age=（根据 session.cache_expire 的设定计算得出）
Last-Modified：（会话最后保存时间）
private_no_expire
Cache-Control: private, max-age=（根据 session.cache_expire 的设定计算得出）, pre-check=（根据 session.cache_expire 的设定计算得出）
Last-Modified: （会话最后保存时间）
private
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: private, max-age=（根据 session.cache_expire 的设定计算得出）, pre-check=（根据 session.cache_expire 的设定计算得出）
Last-Modified: （会话最后保存时间）
nocache
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache

返回值

返回当前所用的缓存限制器名称。

范例

Example #1 session_cache_limiter() 示例

<?php

/* 设置缓存限制器为 'private' */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

echo "The cache limiter is now set to $cache_limiter<br />";
?>

参见

  • session.cache_limiter


session_write_close 的别名

  • ? session_cache_limiter
  • session_create_id ?
  • PHP Manual
  • Session 函数
  • session_write_close 的别名

session_commit

(PHP 4 >= 4.4.0, PHP 5, PHP 7, PHP 8)

session_commit — session_write_close() 的别名

说明

此函数是该函数的别名：session_write_close()。


Create new session id

  • ? session_commit
  • session_decode ?
  • PHP Manual
  • Session 函数
  • Create new session id

session_create_id

(PHP 7 >= 7.1.0, PHP 8)

session_create_id — Create new session id

说明

session_create_id ( string $prefix = "" ) : string|false

session_create_id() is used to create new session id for the current session. It returns collision free session id.

If session is not active, collision check is omitted.

Session ID is created according to php.ini settings.

It is important to use the same user ID of your web server for GC task script. Otherwise, you may have permission problems especially with files save handler.

参数

prefix

If prefix is specified, new session id is prefixed by prefix. Not all characters are allowed within the session id. Characters in the range a-z A-Z 0-9 , (comma) and - (minus) are allowed.

返回值

session_create_id() returns new collision free session id for the current session. If it is used without active session, it omits collision check. On failure, false is returned.

范例

Example #1 session_create_id() example with session_regenerate_id()

<?php
// My session start function support timestamp management
function my_session_start() {
    session_start();
    // Do not allow to use too old session ID
    if (!empty($_SESSION['deleted_time']) && $_SESSION['deleted_time'] < time() - 180) {
        session_destroy();
        session_start();
    }
}

// My session regenerate id function
function my_session_regenerate_id() {
    // Call session_create_id() while session is active to
    // make sure collision free.
    if (session_status() != PHP_SESSION_ACTIVE) {
        session_start();
    }
    // WARNING: Never use confidential strings for prefix!
    $newid = session_create_id('myprefix-');
    // Set deleted timestamp. Session data must not be deleted immediately for reasons.
    $_SESSION['deleted_time'] = time();
    // Finish session
    session_commit();
    // Make sure to accept user defined session ID
    // NOTE: You must enable use_strict_mode for normal operations.
    ini_set('session.use_strict_mode', 0);
    // Set new custom session ID
    session_id($newid);
    // Start with custom session ID
    session_start();
}

// Make sure use_strict_mode is enabled.
// use_strict_mode is mandatory for security reasons.
ini_set('session.use_strict_mode', 1);
my_session_start();

// Session ID must be regenerated when
//  - User logged in
//  - User logged out
//  - Certain period has passed
my_session_regenerate_id();

// Write useful codes
?>

参见

  • session_regenerate_id() - 使用新生成的会话 ID 更新现有会话 ID
  • session_start() - 启动新会话或者重用现有会话
  • session.use_strict_mode
  • SessionHandler::create_sid() - Return a new session ID


解码会话数据

  • ? session_create_id
  • session_destroy ?
  • PHP Manual
  • Session 函数
  • 解码会话数据

session_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

session_decode — 解码会话数据

说明

session_decode ( string $data ) : bool

session_decode() 对 $data 参数中的已经序列化的会话数据进行解码， 并且使用解码后的数据填充 $_SESSION 超级全局变量。

请注意，这里的反序列化方法不同于 unserialize() 函数。 序列化方法是 PHP 内置的，并且可以通过 session.serialize_handler 配置项进行修改。

参数

data

编码后的数据

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • session_encode() - 将当前会话数据编码为一个字符串
  • session.serialize_handler


销毁一个会话中的全部数据

  • ? session_decode
  • session_encode ?
  • PHP Manual
  • Session 函数
  • 销毁一个会话中的全部数据

session_destroy

(PHP 4, PHP 5, PHP 7, PHP 8)

session_destroy — 销毁一个会话中的全部数据

说明

session_destroy ( ) : bool

session_destroy() 销毁当前会话中的全部数据， 但是不会重置当前会话所关联的全局变量， 也不会重置会话 cookie。 如果需要再次使用会话变量， 必须重新调用 session_start() 函数。

Note: 通常情况下，在你的代码中不必调用 session_destroy() 函数， 可以直接清除 $_SESSION 数组中的数据来实现会话数据清理。

为了彻底销毁会话，必须同时重置会话 ID。 如果是通过 cookie 方式传送会话 ID 的，那么同时也需要 调用 setcookie() 函数来 删除客户端的会话 cookie。

当启用了 session.use_strict_mode 配置项的时候，你不需要删除过期会话 ID 对应的 cookie， 因为会话模块已经不再接受携带过期会话 ID 的 cookie 了， 然后它会生成一个新的会话 ID cookie。 建议所有的站点都启用 session.use_strict_mode 配置项。

Warning

过早的删除会话中的数据可能会导致不可预期的结果。 例如，当存在从 JavaScript 或者 URL 链接过来的并发请求的时候， 某一个请求删除了会话中的数据，会导致其他的并发请求无法使用会话数据。

虽然当前的会话处理模块不会接受为空的会话 ID， 但是由于客户端（浏览器）的处理方式， 立即删除会话中的数据可能会导致生成为空的会话 cookie， 进而导致客户端生成很多不必要的会话 ID cookie。

为了避免这种情况的发生，你需要在 $_SESSION 中设置一个时间戳， 在这个时间戳之后的对于会话的访问都将被拒绝。 或者，确保你的应用中不存在并发请求。 这个规则同样适用于 session_regenerate_id()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 销毁会话数据以及 $_SESSION

<?php
// 初始化会话。
// 如果要使用会话，别忘了现在就调用：
session_start();

// 重置会话中的所有变量
$_SESSION = array();

// 如果要清理的更彻底，那么同时删除会话 cookie
// 注意：这样不但销毁了会话中的数据，还同时销毁了会话本身
if (ini_get("session.use_cookies")) {
    $params = session_get_cookie_params();
    setcookie(session_name(), '', time() - 42000,
        $params["path"], $params["domain"],
        $params["secure"], $params["httponly"]
    );
}

// 最后，销毁会话
session_destroy();
?>

注释

Note:

对于旧版本中不使用 $_SESSION 的代码， 仅能使用 session_unset() 来完成会话销毁工作。

参见

  • session.use_strict_mode
  • session_reset() - Re-initialize session array with original values
  • session_regenerate_id() - 使用新生成的会话 ID 更新现有会话 ID
  • unset() - 释放给定的变量
  • setcookie() - 发送 Cookie


将当前会话数据编码为一个字符串

  • ? session_destroy
  • session_gc ?
  • PHP Manual
  • Session 函数
  • 将当前会话数据编码为一个字符串

session_encode

(PHP 4, PHP 5, PHP 7, PHP 8)

session_encode — 将当前会话数据编码为一个字符串

说明

session_encode ( ) : string

session_encode() 返回一个序列化后的字符串，包含被编码的、储存于 $_SESSION 超全局变量中的当前会话数据。

请注意，序列方法 和 serialize() 是不一样的。 该序列方法是内置于 PHP 的，能够通过设置 session.serialize_handler 来设置。

返回值

返回当前会话编码后的内容。

注释

Warning

在调用 session_decode() 之前必须先调用 session_start()。

参见

  • session_decode() - 解码会话数据
  • session.serialize_handler


Perform session data garbage collection

  • ? session_encode
  • session_get_cookie_params ?
  • PHP Manual
  • Session 函数
  • Perform session data garbage collection

session_gc

(PHP 7 >= 7.1.0, PHP 8)

session_gc — Perform session data garbage collection

说明

session_gc ( ) : int|false

session_gc() is used to perform session data GC(garbage collection). PHP does probability based session GC by default.

Probability based GC works somewhat but it has few problems. 1) Low traffic sites' session data may not be deleted within the preferred duration. 2) High traffic sites' GC may be too frequent GC. 3) GC is performed on the user's request and the user will experience a GC delay.

Therefore, it is recommended to execute GC periodically for production systems using, e.g., "cron" for UNIX-like systems. Make sure to disable probability based GC by setting session.gc_probability to 0.

返回值

session_gc() returns number of deleted session data for success, false for failure.

Old save handlers do not return number of deleted session data, but only success/failure flag. If this is the case, number of deleted session data became 1 regardless of actually deleted data.

范例

Example #1 session_gc() example for task managers like cron

<?php
// Note: This script should be executed by the same user of web server process.

// Need active session to initialize session data storage access.
session_start();

// Executes GC immediately
session_gc();

// Clean up session ID created by session_gc()
session_destroy();
?>

Example #2 session_gc() example for user accessible script

<?php
// Note: session_gc() is recommended to be used by task manager script, but
// it may be used as follows.

// Used for last GC time check
$gc_time = '/tmp/php_session_last_gc';
$gc_period = 1800;

session_start();
// Execute GC only when GC period elapsed.
// i.e. Calling session_gc() every request is waste of resources.
if (file_exists($gc_time)) {
    if (filemtime($gc_time) < time() - $gc_period) {
        session_gc();
        touch($gc_time);
    }
} else {
    touch($gc_time);
}
?>

参见

  • session_start() - 启动新会话或者重用现有会话
  • session_destroy() - 销毁一个会话中的全部数据
  • session.gc_probability


获取会话 cookie 参数

  • ? session_gc
  • session_id ?
  • PHP Manual
  • Session 函数
  • 获取会话 cookie 参数

session_get_cookie_params

(PHP 4, PHP 5, PHP 7, PHP 8)

session_get_cookie_params — 获取会话 cookie 参数

说明

session_get_cookie_params ( ) : array

获取会话 cookie 的参数。

返回值

返回一个包含当前会话 cookie 信息的数组：

  • "lifetime" - cookie 的生命周期，以秒为单位。
  • "path" - cookie 的访问路径。
  • "domain" - cookie 的域。
  • "secure" - 仅在使用安全连接时发送 cookie。
  • "httponly" - 只能通过 http 协议访问 cookie

更新日志

版本 | 说明
5.2.0 | 在返回数组中加入 "httponly"。
4.0.4 | 在返回数组中加入 "secure"。

参见

  • session.cookie_lifetime
  • session.cookie_path
  • session.cookie_domain
  • session.cookie_secure
  • session.cookie_httponly
  • session_set_cookie_params() - 设置会话 cookie 参数


获取/设置当前会话 ID

  • ? session_get_cookie_params
  • session_is_registered ?
  • PHP Manual
  • Session 函数
  • 获取/设置当前会话 ID

session_id

(PHP 4, PHP 5, PHP 7, PHP 8)

session_id — 获取/设置当前会话 ID

说明

session_id ( string $id = ? ) : string

session_id() 可以用来获取/设置 当前会话 ID。

为了能够将会话 ID 很方便的附加到 URL 之后， 你可以使用常量 SID 获取以字符串格式表达的会话名称和 ID。 请参考 会话处理。

参数

id

如果指定了 id 参数的值， 则使用指定值作为会话 ID。 必须在调用 session_start() 函数之前调用 session_id() 函数。 不同的会话管理器对于会话 ID 中可以使用的字符有不同的限制。 例如文件会话管理器仅允许会话 ID 中使用以下字符：a-z A-Z 0-9 , （逗号）和 - （减号）

Note: 如果使用 cookie 方式传送会话 ID，并且指定了 id 参数， 在调用 session_start() 之后都会向客户端发送新的 cookie， 无论当前的会话 ID 和新指定的会话 ID 是否相同。

返回值

session_id() 返回当前会话ID。 如果当前没有会话，则返回空字符串（""）。

参见

  • session_regenerate_id() - 使用新生成的会话 ID 更新现有会话 ID
  • session_start() - 启动新会话或者重用现有会话
  • session_set_save_handler() - 设置用户自定义会话存储函数
  • session.save_handler


检查变量是否在会话中已经注册

  • ? session_id
  • session_module_name ?
  • PHP Manual
  • Session 函数
  • 检查变量是否在会话中已经注册

session_is_registered

(No version information available, might only be in Git)

session_is_registered — 检查变量是否在会话中已经注册

说明

session_is_registered ( string $name ) : bool

检查变量是否已经在会话中注册。

Warning

本函数已自 PHP 5.3.0 起废弃并将自 PHP 5.4.0 起移除。

参数

name

变量名称。

返回值

session_is_registered() 返回 true 则表示 name 变量已经在当前会话中注册使用，否则返回 false 。

注释

Note:

如果使用 $_SESSION (或 $HTTP_SESSION_VARS for PHP 4.0.6 or less),可以使用 isset() 检查变量是否在 $_SESSION 中注册使用。

Caution

如果使用 $_SESSION
(或 $HTTP_SESSION_VARS), 则不要使用
session_register(),
session_is_registered() 和
session_unregister().


获取/设置会话模块名称

  • ? session_is_registered
  • session_name ?
  • PHP Manual
  • Session 函数
  • 获取/设置会话模块名称

session_module_name

(PHP 4, PHP 5, PHP 7, PHP 8)

session_module_name — 获取/设置会话模块名称

说明

session_module_name ( string $module = ? ) : string

session_module_name() 获取或设置会话模块名称，也被称做：session.save_handler。

参数

module

如果指定 module 参数，则使用 指定值作为会话模块。 禁止传入 "user" 作为此参数的值， 请使用 set_set_save_handler() 来设置用户自定义的会话处理器。

返回值

返回当前所用的会话模块名称。

更新日志

版本 | 说明
7.2.0 | 不允许设置模块名称为 "user"。 在之前的版本中，如果设置为 "user"，那么会被静默的忽略到。


读取/设置会话名称

  • ? session_module_name
  • session_regenerate_id ?
  • PHP Manual
  • Session 函数
  • 读取/设置会话名称

session_name

(PHP 4, PHP 5, PHP 7, PHP 8)

session_name — 读取/设置会话名称

说明

session_name ( string $name = ? ) : string

session_name() 函数返回当前会话名称。 如果指定 name 参数， session_name() 函数会更新会话名称， 并返回 原来的 会话名称。

如果使用 name 指定了新字符串作为会话 cookie 的名字， session_name() 函数会修改 HTTP 响应中的 cookie （如果启用了 session.transid，还会输出会话 cookie 的内容）。 一旦在 HTTP 响应中发送了 cookie 的内容之后， 调用 session_name() 函数会产生错误。 所以，一定要在调用 session_start() 函数之前 调用此函数。

请求开始的时候，会话名称会被重置并且存储到 session.name 配置项。 因此，要想设置会话名称，那么对于每个请求，都需要在 调用 session_start() 函数 之前调用 session_name() 函数。

参数

name

用在 cookie 或者 URL 中的会话名称， 例如：PHPSESSID。 只能使用字母和数字作为会话名称，建议尽可能的短一些， 并且是望文知意的名字（对于启用了 cookie 警告的用户来说，方便其判断是否要允许此 cookie）。 如果指定了 name 参数， 那么当前会话也会使用指定值作为名称。

Warning

会话名称至少需要一个字母，不能全部都使用数字， 否则，每次都会生成一个新的会话 ID。

返回值

返回当前会话名称。如果指定 name 参数，那么此函数会更新会话名称，并且 返回 原来的 会话名称。

范例

Example #1 session_name() 示例

<?php

/* 设置会话名称为 WebsiteID */

$previous_name = session_name("WebsiteID");

echo "The previous session name was $previous_name<br />";
?>

更新日志

版本 | 说明
7.2.0 | session_name() 函数会检查会话状态， 之前的版本仅仅检查 cookie 状态。 所以，旧版本的 PHP 允许你在调用 session_start() 函数之后再调用 session_name() 函数， 新版本的 PHP 不再允许这样做了。

参见

  • session.name 配置指示


使用新生成的会话 ID 更新现有会话 ID

  • ? session_name
  • session_register_shutdown ?
  • PHP Manual
  • Session 函数
  • 使用新生成的会话 ID 更新现有会话 ID

session_regenerate_id

(PHP 4 >= 4.3.2, PHP 5, PHP 7, PHP 8)

session_regenerate_id — 使用新生成的会话 ID 更新现有会话 ID

说明

session_regenerate_id ( bool $delete_old_session = false ) : bool

session_regenerate_id() 在不修改当前会话中数据的前提下使用新的 ID 替换原有会话 ID。

如果启用了 session.use_trans_sid 选项， 那么必须在调用 session_regenerate_id() 函数之后开始进行输出工作， 否则会导致使用原有的会话 ID。

Warning

当前的 session_regenerate_id 并没有很好的处理在诸如移动数据网络和 WiFi 网络不稳定的场景。 因此，调用 session_regenerate_id 函数 可能会导致会话丢失。

你不应该直接销毁旧的会话所关联的数据， 而是应该使用时间戳机制来控制对于已经失效的会话 ID 的访问。 否则，可能会在并发访问的场景下导致会话数据不一致、 会话丢失等情况，甚至可能引发客户端（浏览器）创建很多无用的会话 ID。 但是，另外一方面来讲，立即删除会话中的数据 可以防止会话劫持攻击。

参数

delete_old_session

是否删除原 ID 所关联的会话存储文件。 如果你需要避免会话并发访问冲突，那么不应该立即删除会话中的数据。 如果你需要防止会话劫持攻击，那么可以立即删除会话数据。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 A session_regenerate_id() 示例

<?php
// 注意：下列不是完整的代码，只是一个示例

session_start();

// 检查会话被销毁的时间戳
if (isset($_SESSION['destroyed'])
    && $_SESSION['destroyed'] < time() - 300) {
    // 通常不会发生这种情况。如果发生，那么可能是由于不稳定的网络状况或者被攻击导致的
    // 移除用户会话中的认证信息
    remove_all_authentication_flag_from_active_sessions($_SESSION['userid']);
    throw(new DestroyedSessionAccessException);
}

$old_sessionid = session_id();

// 设置会话销毁时间戳
$_SESSION['destroyed'] = time(); // 从 PHP 7.0.0 开始, session_regenerate_id() 会自动保存会话数据

// 如果直接调用 session_regenerate_id() 函数可能会导致会话丢失的情况，
// 参见下面的例程
session_regenerate_id();

// 新创建的会话不需要时间戳
unset($_SESSION['destroyed']);

$new_sessionid = session_id();

echo "Old Session: $old_sessionid<br />";
echo "New Session: $new_sessionid<br />";

print_r($_SESSION);
?>

当前的会话模块未能很好的处理在网络不稳定的时候导致会话丢失的场景。 你需要自行管理会话 ID 避免调用 session_regenerate_id 导致会话丢失。

Example #2 Avoiding lost session by session_regenerate_id()

<?php
// 注意：下列不是完整的代码，只是一个示例
// my_session_start() 和 my_session_regenerate_id()
// 函数可以避免在网络不稳定的情况下导致会话丢失的问题。
// 并且还可以避免用户会话被攻击者利用

function my_session_start() {
    session_start();
    if (isset($_SESSION['destroyed'])) {
       if ($_SESSION['destroyed'] < time()-300) {
           // 通常不会发生这种情况。如果发生，那么可能是由于不稳定的网络状况或者被攻击导致的
           // 移除用户会话中的认证信息
           remove_all_authentication_flag_from_active_sessions($_SESSION['userid']);
           throw(new DestroyedSessionAccessException);
       }
       if (isset($_SESSION['new_session_id'])) {
           // 尚未完全过期，可能是由于网络不稳定引起的。
           // 尝试再次设置正确的会话 ID cookie。
           // 注意：如果你需要移除认证标记，那么不要尝试再次设置会话 ID。
           session_commit();
           session_id($_SESSION['new_session_id']);
           // 现在有了新的会话 ID 了。
           session_start();
           return;
       }
   }
}

function my_session_regenerate_id() {
    // 如果由于不稳定的网络导致没有创建会话 ID，
    // 那么就创建一个
    $new_session_id = session_create_id();
    $_SESSION['new_session_id'] = $new_session_id;

    // 设置销毁时间戳
    $_SESSION['destroyed'] = time();

    // 保存并关闭会话
    session_commit();

    // 使用新的会话 ID 开始会话
    session_id($new_session_id);
    ini_set('session.use_strict_mode', 0);
    session_start();
    ini_set('session.use_strict_mode', 1);

    // 新的会话不需要这 2 个数据了
    unset($_SESSION['destroyed']);
    unset($_SESSION['new_session_id']);
}
?>

参见

  • session_id() - 获取/设置当前会话 ID
  • session_create_id() - Create new session id
  • session_start() - 启动新会话或者重用现有会话
  • session_destroy() - 销毁一个会话中的全部数据
  • session_reset() - Re-initialize session array with original values
  • session_name() - 读取/设置会话名称


关闭会话

  • ? session_regenerate_id
  • session_reset ?
  • PHP Manual
  • Session 函数
  • 关闭会话

session_register_shutdown

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

session_register_shutdown — 关闭会话

说明

session_register_shutdown ( ) : void

将 session_write_close() 函数注册为关闭会话的函数。

参数

此函数没有参数。

返回值

没有返回值。

错误／异常

如果函数调用失败，触发 E_WARNING 级别的错误。


Re-initialize session array with original values

  • ? session_register_shutdown
  • session_save_path ?
  • PHP Manual
  • Session 函数
  • Re-initialize session array with original values

session_reset

(PHP 5 >= 5.6.0, PHP 7, PHP 8)

session_reset — Re-initialize session array with original values

说明

session_reset ( ) : bool

session_reset() reinitializes a session with original values stored in session storage. This function requires an active session and discards changes in $_SESSION.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.2.0 | The return type of this function is bool now. Formerly, it has been void.

参见

  • $_SESSION
  • The session.auto_start configuration directive
  • session_start() - 启动新会话或者重用现有会话
  • session_abort() - Discard session array changes and finish session
  • session_commit() - session_write_close 的别名


读取/设置当前会话的保存路径

  • ? session_reset
  • session_set_cookie_params ?
  • PHP Manual
  • Session 函数
  • 读取/设置当前会话的保存路径

session_save_path

(PHP 4, PHP 5, PHP 7, PHP 8)

session_save_path — 读取/设置当前会话的保存路径

说明

session_save_path ( string $path = ? ) : string

session_save_path() 返回当前会话的保存路径。

参数

path

指定会话数据保存的路径。 必须在调用 session_start() 函数之前调用 session_save_path() 函数。

Note:

在某些操作系统上，建议使用可以高效处理 大量小尺寸文件的文件系统上的路径来保存会话数据。 例如，在 Linux 平台上，对于会话数据保存的工作而言，reiserfs 文件系统会比 ext2fs 文件系统能够提供更好的性能。

返回值

返回保存会话数据的路径。

参见

  • session.save_path 配置指示。


设置会话 cookie 参数

  • ? session_save_path
  • session_set_save_handler ?
  • PHP Manual
  • Session 函数
  • 设置会话 cookie 参数

session_set_cookie_params

(PHP 4, PHP 5, PHP 7, PHP 8)

session_set_cookie_params — 设置会话 cookie 参数

说明

session_set_cookie_params ( int $lifetime , string $path = ? , string $domain = ? , bool $secure = false , bool $httponly = false ) : bool
session_set_cookie_params ( array $options ) : bool

Cookie 参数可以在 php.ini 文件中定义，本函数仅在当前脚本执行过程中有效。 因此，如果要通过函数修改 cookie 参数，需要对每个请求都要 在调用 session_start() 函数之前调用 session_set_cookie_params() 函数。

本函数会修改运行期 ini 设置值， 可以通过 ini_get() 函数获取这些值。

参数

lifetime

Cookie 的 生命周期，以秒为单位。

path

此 cookie 的有效 路径。 on the domain where 设置为"/"表示对于本域上所有的路径此 cookie 都可用。

domain

Cookie 的作用 域。 例如："www.php.net"。 如果要让 cookie 在所有的子域中都可用，此参数必须以点（.）开头，例如：".php.net"。

secure

设置为 true 表示 cookie 仅在使用 安全 链接时可用。

httponly

设置为 true 表示 PHP 发送 cookie 的时候会使用 httponly 标记。

options

此参数为一个键值对关联 array，可能包含的键有： lifetime，path，domain, secure，httponly 以及 samesite。 这些键对应的值和上面所述的一样。 samesite 键对应的值可以是 Lax 或者 Strict。 如果可以接受的键在传入的数组中不存在， 那么会采用这些键对应的默认值作为运行时的值。 如果不提供 samesite 键， 那么就设置 SameSite cookie 属性。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.3.0 | 增加 options 参数， 可以通过传入一个关联数组对各个选项进行设置。 同时，通过使用这个参数还可以对 SameSite cookie 进行设置。
7.2.0 | 成功时返回 true， 或者在失败时返回 false。 之前版本中是返回 void 的。
5.2.0 | 加入 httponly 参数。

参见

  • session.cookie_lifetime
  • session.cookie_path
  • session.cookie_domain
  • session.cookie_secure
  • session.cookie_httponly
  • session.cookie_samesite
  • session_get_cookie_params() - 获取会话 cookie 参数


设置用户自定义会话存储函数

  • ? session_set_cookie_params
  • session_start ?
  • PHP Manual
  • Session 函数
  • 设置用户自定义会话存储函数

session_set_save_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

session_set_save_handler — 设置用户自定义会话存储函数

说明

session_set_save_handler ( callable $open , callable $close , callable $read , callable $write , callable $destroy , callable $gc , callable $create_sid = ? , callable $validate_sid = ? , callable $update_timestamp = ? ) : bool

自 PHP 5.4 开始，可以使用下面的方式来注册自定义会话存储函数：

session_set_save_handler ( object $sessionhandler , bool $register_shutdown = true ) : bool

session_set_save_handler() 设置用户自定义 会话存储函数。 如果想使用 PHP 内置的会话存储机制之外的方式， 可以使用本函数。 例如，可以自定义会话存储函数来将会话数据存储到数据库。

参数

本函数有 2 种原型：

sessionhandler

实现了 SessionHandlerInterface， SessionIdInterface 和/或 SessionUpdateTimestampHandlerInterface 接口的对象， 例如 SessionHandler。 自 PHP 5.4 之后可以使用。

register_shutdown

将函数 session_write_close() 注册为 register_shutdown_function() 函数。

或者
open(string $savePath, string $sessionName)

open 回调函数类似于类的构造函数， 在会话打开的时候会被调用。 这是自动开始会话或者通过调用 session_start() 手动开始会话 之后第一个被调用的回调函数。 此回调函数操作成功返回 true，反之返回 false。

close()

close 回调函数类似于类的析构函数。 在 write 回调函数调用之后调用。 当调用 session_write_close() 函数之后，也会调用 close 回调函数。 此回调函数操作成功返回 true，反之返回 false。

read(string $sessionId)

如果会话中有数据，read 回调函数必须返回将会话数据编码（序列化）后的字符串。 如果会话中没有数据，read 回调函数返回空字符串。

在自动开始会话或者通过调用 session_start() 函数手动开始会话之后，PHP 内部调用 read 回调函数来获取会话数据。 在调用 read 之前，PHP 会调用 open 回调函数。

read 回调返回的序列化之后的字符串格式必须与 write 回调函数保存数据时的格式完全一致。 PHP 会自动反序列化返回的字符串并填充 $_SESSION 超级全局变量。 虽然数据看起来和 serialize() 函数很相似， 但是需要提醒的是，它们是不同的。 请参考： session.serialize_handler。

write(string $sessionId, string $data)

在会话保存数据时会调用 write 回调函数。 此回调函数接收当前会话 ID 以及 $_SESSION 中数据序列化之后的字符串作为参数。 序列化会话数据的过程由 PHP 根据 session.serialize_handler 设定值来完成。

序列化后的数据将和会话 ID 关联在一起进行保存。 当调用 read 回调函数获取数据时，所返回的数据必须要和 传入 write 回调函数的数据完全保持一致。

PHP 会在脚本执行完毕或调用 session_write_close() 函数之后调用此回调函数。 注意，在调用完此回调函数之后，PHP 内部会调用 close 回调函数。

Note:

PHP 会在输出流写入完毕并且关闭之后 才调用 write 回调函数， 所以在 write 回调函数中的调试信息不会输出到浏览器中。 如果需要在 write 回调函数中使用调试输出， 建议将调试输出写入到文件。

destroy($sessionId)

当调用 session_destroy() 函数， 或者调用 session_regenerate_id() 函数并且设置 destroy 参数为 true 时， 会调用此回调函数。此回调函数操作成功返回 true，反之返回 false。

gc($lifetime)

为了清理会话中的旧数据，PHP 会不时的调用垃圾收集回调函数。 调用周期由 session.gc_probability 和 session.gc_divisor 参数控制。 传入到此回调函数的 lifetime 参数由 session.gc_maxlifetime 设置。 此回调函数操作成功返回 true，反之返回 false。

create_sid()

当需要新的会话 ID 时被调用的回调函数。 回调函数被调用时无传入参数， 其返回值应该是一个字符串格式的、有效的会话 ID。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.0.0 | 新增可选参数 validate_sid 和 update_timestamp。
5.5.1 | 新增可选参数 create_sid。
5.4.0 | 新增用来实现自定义会话处理器的接口 SessionHandlerInterface； 新增 PHP 内部会话处理器类：SessionHandler。

范例

Example #1 自定义会话管理器： 完整代码请参见 SessionHandlerInterface。

下列代码适用于 PHP 5.4.0 及以上版本。 这里仅列出了调用方式，完整代码请参见 SessionHandlerInterface。

这里使用了 session_set_save_handler() 函数的 OOP 原型 并且使用第二个参数来注册 shutdown 函数。 当将对象注册为会话保存管理器时，建议使用这种方式。

<?php
class MySessionHandler implements SessionHandlerInterface
{
    // 在这里实现接口
}

$handler = new MySessionHandler();
session_set_save_handler($handler, true);
session_start();

// 现在可以使用 $_SESSION 保存以及获取数据了

Example #2 使用对象自定义会话保存管理器

下列代码适用于 PHP 5.4.0 之前的版本。

下例演示了基于文件的会话数据存储， 和 PHP 默认的 files 存储器很相似。 通过对此示例代码进行扩展， 你可以很方便的实现使用数据库保存会话数据的功能。

针对于 PHP 5.4.0 之前的版本， 通过调用 register_shutdown_function() 函数 来注册 session_write_close() 回调函数。 这也是我们建议的方式。

<?php
class FileSessionHandler
{
    private $savePath;

    function open($savePath, $sessionName)
    {
        $this->savePath = $savePath;
        if (!is_dir($this->savePath)) {
            mkdir($this->savePath, 0777);
        }

        return true;
    }

    function close()
    {
        return true;
    }

    function read($id)
    {
        return (string)@file_get_contents("$this->savePath/sess_$id");
    }

    function write($id, $data)
    {
        return file_put_contents("$this->savePath/sess_$id", $data) === false ? false : true;
    }

    function destroy($id)
    {
        $file = "$this->savePath/sess_$id";
        if (file_exists($file)) {
            unlink($file);
        }

        return true;
    }

    function gc($maxlifetime)
    {
        foreach (glob("$this->savePath/sess_*") as $file) {
            if (filemtime($file) + $maxlifetime < time() && file_exists($file)) {
                unlink($file);
            }
        }

        return true;
    }
}

$handler = new FileSessionHandler();
session_set_save_handler(
    array($handler, 'open'),
    array($handler, 'close'),
    array($handler, 'read'),
    array($handler, 'write'),
    array($handler, 'destroy'),
    array($handler, 'gc')
    );

// 下面这行代码可以防止使用对象作为会话保存管理器时可能引发的非预期行为
register_shutdown_function('session_write_close');

session_start();
// 现在可以使用 $_SESSION 保存以及获取数据了

注释

Warning

在脚本执行完毕之后，PHP 内部会清除对象， 所以有可能不调用 write 和 close 回调函数。 这样可能会引发非预期的行为，所以当使用对象作为会话保存管理器时， 需要通过注册 shutdown 回调函数来规避风险。 通常，你可以通过调用 register_shutdown_function() 函数 来注册 'session_write_close' 回调函数。

在 PHP 5.4.0 中，可以调用 session_register_shutdown() 函数来注册 shutdown 回调函数。 如果你使用 session_set_save_handler() 的 OOP 原型， 那么仅需设置 "register shutdown" 为 true 即可。

Warning

在 PHP 5.0.5 中，在对象销毁之后才会调用 write 和 close 回调函数， 所以，在这两个回调函数中不可以使用对象，也不可以抛出异常。 如果在函数中抛出异常，PHP 既不会捕获它，也不会跟踪它， 这样会导致程序异常终止。 但是对象析构函数可以使用会话。

可以在析构函数中调用 session_write_close() 函数来解决这个问题。 但是注册 shutdown 回调函数才是更加可靠的做法。

Warning

如果会话在脚本结束后关闭，对于某些 SAPI 而言，当前工作目录可能已经被改变。 可以调用 session_write_close() 函数在脚本执行结束之前关闭会话。

参见

  • session.save_handler 配置指示
  • session.serialize_handler 配置指示
  • register_shutdown_function() - 注册一个会在php中止时执行的函数
  • session_register_shutdown() - 关闭会话 PHP 5.4.0+
  • 完整的实现请参考 » save_handler.inc。


启动新会话或者重用现有会话

  • ? session_set_save_handler
  • session_status ?
  • PHP Manual
  • Session 函数
  • 启动新会话或者重用现有会话

session_start

(PHP 4, PHP 5, PHP 7, PHP 8)

session_start — 启动新会话或者重用现有会话

说明

session_start ( array $options = array() ) : bool

session_start() 会创建新会话或者重用现有会话。 如果通过 GET 或者 POST 方式，或者使用 cookie 提交了会话 ID， 则会重用现有会话。

当会话自动开始或者通过 session_start() 手动开始的时候， PHP 内部会调用会话管理器的 open 和 read 回调函数。 会话管理器可能是 PHP 默认的， 也可能是扩展提供的（SQLite 或者 Memcached 扩展）， 也可能是通过 session_set_save_handler() 设定的用户自定义会话管理器。 通过 read 回调函数返回的现有会话数据（使用特殊的序列化格式存储）， PHP 会自动反序列化数据并且填充 $_SESSION 超级全局变量。

要想使用命名会话，请在调用 session_start() 函数 之前调用 session_name() 函数。

如果启用了 session.use_trans_sid 选项， session_start() 函数会注册一个内部输出管理器， 该输出管理器完成 URL 重写的工作。

如果用户联合使用 ob_start() 和 ob_gzhandler 函数， 那么函数的调用顺序会影响输出结果。 例如，必须在开始会话之前调用 ob_gzhandler 函数完成注册。

参数

options

此参数是一个关联数组，如果提供，那么会用其中的项目覆盖 会话配置指示 中的配置项。此数组中的键无需包含 session. 前缀。

除了常规的会话配置指示项， 还可以在此数组中包含 read_and_close 选项。如果将此选项的值设置为 true， 那么会话文件会在读取完毕之后马上关闭， 因此，可以在会话数据没有变动的时候，避免不必要的文件锁。

返回值

成功开始会话返回 true ，反之返回 false

更新日志

版本 | 说明
7.1.0 | 当 session_start() 执行失败， 无法开始一个会话的时候，会返回 false， 并且不会初始化超级变量 $_SESSION。
7.0.0 | 新加 options 参数。
5.3.0 | 如果函数调用失败返回 false， 之前版本返回了 true。

范例

基本的会话示例

Example #1 page1.php

<?php
// page1.php

session_start();

echo 'Welcome to page #1';

$_SESSION['favcolor'] = 'green';
$_SESSION['animal']   = 'cat';
$_SESSION['time']     = time();

// 如果使用 cookie 方式传送会话 ID
echo '<br /><a href="page2.php">page 2</a>';

// 如果不是使用 cookie 方式传送会话 ID，则使用 URL 改写的方式传送会话 ID
echo '<br /><a href="page2.php?' . SID . '">page 2</a>';
?>

请求 page1.php 页面之后， 第二个页面 page2.php 会包含会话数据。 请查阅 会话参考 获取更多关于 会话 ID 传送的信息， 在该参考页面中有关于常量 SID 的详细说明。

Example #2 page2.php

<?php
// page2.php

session_start();

echo 'Welcome to page #2<br />';

echo $_SESSION['favcolor']; // green
echo $_SESSION['animal'];   // cat
echo date('Y m d H:i:s', $_SESSION['time']);

// 类似 page1.php 中的代码，你可能需要在这里处理使用 SID 的场景
echo '<br /><a href="page1.php">page 1</a>';
?>

调用 session_start() 的时候指定选项

Example #3 覆盖 Cookie 超时时间设定

<?php
// 设置 cookie 的有效时间为 1 天
session_start([
    'cookie_lifetime' => 86400,
]);
?>

Example #4 读取会话之后立即关闭会话存储文件

<?php
// 如果确定不修改会话中的数据，
// 我们可以在会话文件读取完毕之后立即关闭它
// 来避免由于给会话文件加锁导致其他页面阻塞
session_start([
    'cookie_lifetime' => 86400,
    'read_and_close'  => true,
]);

注释

Note:

要使用基于 cookie 的会话， 必须在输出开始之前调用 session_start() 函数。

Note:

建议使用 zlib.output_compression 来替代 ob_gzhandler()。

Note:

根据配置不同，本函数会发送几个 HTTP 响应头。 参考 session_cache_limiter() 来自定义 HTTP 响应头。

参见

  • $_SESSION
  • session.auto_start 配置指示
  • session_id() - 获取/设置当前会话 ID


返回当前会话状态

  • ? session_start
  • session_unregister ?
  • PHP Manual
  • Session 函数
  • 返回当前会话状态

session_status

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

session_status — 返回当前会话状态

说明

session_status ( ) : int

session_status() 被用于返回当前会话状态。

返回值

  • PHP_SESSION_DISABLED 会话是被禁用的。
  • PHP_SESSION_NONE 会话是启用的，但不存在当前会话。
  • PHP_SESSION_ACTIVE 会话是启用的，而且存在当前会话。

参见

  • session_start() - 启动新会话或者重用现有会话


Unregister a global variable from the current session

  • ? session_status
  • session_unset ?
  • PHP Manual
  • Session 函数
  • Unregister a global variable from the current session

session_unregister

(No version information available, might only be in Git)

session_unregister — Unregister a global variable from the current session

说明

session_unregister ( string $name ) : bool

session_unregister() unregisters the global variable named name from the current session.

Warning

本函数已自 PHP 5.3.0 起废弃并将自 PHP 5.4.0 起移除。

参数

name

The variable name.

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

If $_SESSION is used, use unset() to unregister a session variable. Do not unset() $_SESSION itself as this will disable the special function of the $_SESSION superglobal.

Caution

This function does not unset the corresponding global variable for name, it only prevents the variable from being saved as part of the session. You must call unset() to remove the corresponding global variable.

Caution

If you are using $_SESSION (or
$HTTP_SESSION_VARS), do not use
session_register(),
session_is_registered() and
session_unregister().


释放所有的会话变量

  • ? session_unregister
  • session_write_close ?
  • PHP Manual
  • Session 函数
  • 释放所有的会话变量

session_unset

(PHP 4, PHP 5, PHP 7, PHP 8)

session_unset — 释放所有的会话变量

说明

session_unset ( ) : void

session_unset() 会释放当前会话注册的所有会话变量。

返回值

没有返回值。

注释

Note:

如果使用的是 $_SESSION (或者PHP 4.0.6或更早版本的 $HTTP_SESSION_VARS ) ，请使用 unset() 去 注销会话变量，即 unset ($_SESSION['varname']);.

Caution

请不要使用unset($_SESSION)来释放整个$_SESSION， 因为它将会禁用通过全局$_SESSION去注册会话变量


Write session data and end session

  • ? session_unset
  • SessionHandler ?
  • PHP Manual
  • Session 函数
  • Write session data and end session

session_write_close

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

session_write_close — Write session data and end session

说明

session_write_close ( ) : bool

End the current session and store session data.

Session data is usually stored after your script terminated without the need to call session_write_close(), but as session data is locked to prevent concurrent writes only one script may operate on a session at any time. When using framesets together with sessions you will experience the frames loading one by one due to this locking. You can reduce the time needed to load all the frames by ending the session as soon as all changes to session variables are done.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.2.0 | The return type of this function is bool now. Formerly, it has been void.

参见

  • The session_register_shutdown() - 关闭会话


The SessionHandler class

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

简介

SessionHandler is a special class that can be used to expose the current internal PHP session save handler by inheritance. There are seven methods which wrap the seven internal session save handler callbacks (open, close, read, write, destroy, gc and create_sid). By default, this class will wrap whatever internal save handler is set as defined by the session.save_handler configuration directive which is usually files by default. Other internal session save handlers are provided by PHP extensions such as SQLite (as sqlite), Memcache (as memcache), and Memcached (as memcached).

When a plain instance of SessionHandler is set as the save handler using session_set_save_handler() it will wrap the current save handlers. A class extending from SessionHandler allows you to override the methods or intercept or filter them by calls the parent class methods which ultimately wrap the internal PHP session handlers.

This allows you, for example, to intercept the read and write methods to encrypt/decrypt the session data and then pass the result to and from the parent class. Alternatively one might chose to entirely override a method like the garbage collection callback gc.

Because the SessionHandler wraps the current internal save handler methods, the above example of encryption can be applied to any internal save handler without having to know the internals of the handlers.

To use this class, first set the save handler you wish to expose using session.save_handler and then pass an instance of SessionHandler or one extending it to session_set_save_handler().

Please note the callback methods of this class are designed to be called internally by PHP and are not meant to be called from user-space code. The return values are equally processed internally by PHP. For more information on the session workflow, please refer session_set_save_handler().

类摘要

SessionHandler implements SessionHandlerInterface , SessionIdInterface {
/* 方法 */
public close ( ) : bool
public create_sid ( ) : string
public destroy ( string $id ) : bool
public gc ( int $max_lifetime ) : int|bool
public open ( string $path , string $name ) : bool
public read ( string $id ) : string
public write ( string $id , string $data ) : bool
}
Warning

This class is designed to expose the current internal PHP session save handler, if you want to write your own custom save handlers, please implement the SessionHandlerInterface interface instead of extending from SessionHandler.

更新日志

版本 | 说明
5.5.1 | Added SessionHandler::create_sid().

Example #1 Using SessionHandler to add encryption to internal PHP save handlers.

<?php

 /**
  * decrypt AES 256
  *
  * @param data $edata
  * @param string $password
  * @return decrypted data
  */
function decrypt($edata, $password) {
    $data = base64_decode($edata);
    $salt = substr($data, 0, 16);
    $ct = substr($data, 16);

    $rounds = 3; // depends on key length
    $data00 = $password.$salt;
    $hash = array();
    $hash[0] = hash('sha256', $data00, true);
    $result = $hash[0];
    for ($i = 1; $i < $rounds; $i++) {
        $hash[$i] = hash('sha256', $hash[$i - 1].$data00, true);
        $result .= $hash[$i];
    }
    $key = substr($result, 0, 32);
    $iv  = substr($result, 32,16);

    return openssl_decrypt($ct, 'AES-256-CBC', $key, true, $iv);
  }

/**
 * crypt AES 256
 *
 * @param data $data
 * @param string $password
 * @return base64 encrypted data
 */
function encrypt($data, $password) {
    // Set a random salt
    $salt = openssl_random_pseudo_bytes(16);

    $salted = '';
    $dx = '';
    // Salt the key(32) and iv(16) = 48
    while (strlen($salted) < 48) {
      $dx = hash('sha256', $dx.$password.$salt, true);
      $salted .= $dx;
    }

    $key = substr($salted, 0, 32);
    $iv  = substr($salted, 32,16);

    $encrypted_data = openssl_encrypt($data, 'AES-256-CBC', $key, true, $iv);
    return base64_encode($salt . $encrypted_data);
}

class EncryptedSessionHandler extends SessionHandler
{
    private $key;

    public function __construct($key)
    {
        $this->key = $key;
    }

    public function read($id)
    {
        $data = parent::read($id);

        if (!$data) {
            return "";
        } else {
            return decrypt($data, $this->key);
        }
    }

    public function write($id, $data)
    {
        $data = encrypt($data, $this->key);

        return parent::write($id, $data);
    }
}

// we'll intercept the native 'files' handler, but will equally work
// with other internal native handlers like 'sqlite', 'memcache' or 'memcached'
// which are provided by PHP extensions.
ini_set('session.save_handler', 'files');

$key = 'secret_string';
$handler = new EncryptedSessionHandler($key);
session_set_save_handler($handler, true);
session_start();

// proceed to set and retrieve values by key from $_SESSION

Note:

Since this class' methods are designed to be called internally by PHP as part of the normal session workflow, child class calls to parent methods (i.e. the actual internal native handlers) will return false unless the session has actually been started (either automatically, or by explicit session_start(). This is important to consider when writing unit tests where the class methods might be invoked manually.

Table of Contents

  • SessionHandler::close — Close the session
  • SessionHandler::create_sid — Return a new session ID
  • SessionHandler::destroy — Destroy a session
  • SessionHandler::gc — Cleanup old sessions
  • SessionHandler::open — Initialize session
  • SessionHandler::read — Read session data
  • SessionHandler::write — Write session data


Close the session

  • ? SessionHandler
  • SessionHandler::create_sid ?
  • PHP Manual
  • SessionHandler
  • Close the session

SessionHandler::close

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::close — Close the session

说明

public SessionHandler::close ( ) : bool

Closes the current session. This method is automatically executed internally by PHP when closing the session, or explicitly via session_write_close() (which first calls the SessionHandler::write()).

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was activated by session_set_save_handler().

If this class is extended by inheritiance, calling the parent close method will invoke the wrapper for this method and therefore invoke the associated internal callback. This allows the method to be overridden and or intercepted.

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::close().

参数

此函数没有参数。

返回值

会话存储的返回值（通常成功返回 0，失败返回 1）。


Return a new session ID

  • ? SessionHandler::close
  • SessionHandler::destroy ?
  • PHP Manual
  • SessionHandler
  • Return a new session ID

SessionHandler::create_sid

(PHP 5 >= 5.5.1, PHP 7, PHP 8)

SessionHandler::create_sid — Return a new session ID

说明

public SessionHandler::create_sid ( ) : string

Generates and returns a new session ID.

返回值

A session ID valid for the default session handler.

参见

  • session_id() - 获取/设置当前会话 ID
  • session_create_id() - Create new session id


Destroy a session

  • ? SessionHandler::create_sid
  • SessionHandler::gc ?
  • PHP Manual
  • SessionHandler
  • Destroy a session

SessionHandler::destroy

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::destroy — Destroy a session

说明

public SessionHandler::destroy ( string $id ) : bool

Destroys a session. Called internally by PHP with session_regenerate_id() (assuming the $destroy is set to true, by session_destroy() or when session_decode() fails.

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent destroy method will invoke the wrapper for this method and therefore invoke the associated internal callback. This allows this method to be overridden and or intercepted and filtered.

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::destroy().

参数

id

The session ID being destroyed.

返回值

会话存储的返回值（通常成功返回 0，失败返回 1）。


Cleanup old sessions

  • ? SessionHandler::destroy
  • SessionHandler::open ?
  • PHP Manual
  • SessionHandler
  • Cleanup old sessions

SessionHandler::gc

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::gc — Cleanup old sessions

说明

public SessionHandler::gc ( int $max_lifetime ) : int|bool

Cleans up expired sessions. Called randomly by PHP internally when a session starts or when session_start() is invoked. The frequency this is called is based on the session.gc_divisor and session.gc_probability configuration directives.

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent gc method will invoke the wrapper for this method and therefore invoke the associated internal callback. This allows this method to be overridden and or intercepted and filtered.

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::gc().

参数

max_lifetime

Sessions that have not updated for the last max_lifetime seconds will be removed.

返回值

Returns the number of deleted sessions on success, 或者在失败时返回 false. Note this value is returned internally to PHP for processing.

更新日志

版本 | 说明
7.1.0 | Prior to this version, the function returned true on success.


Initialize session

  • ? SessionHandler::gc
  • SessionHandler::read ?
  • PHP Manual
  • SessionHandler
  • Initialize session

SessionHandler::open

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::open — Initialize session

说明

public SessionHandler::open ( string $path , string $name ) : bool

Create new session, or re-initialize existing session. Called internally by PHP when a session starts either automatically or when session_start() is invoked.

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent open method will invoke the wrapper for this method and therefore invoke the associated internal callback. This allows this method to be overridden and or intercepted and filtered.

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::open().

参数

path

The path where to store/retrieve the session.

name

The session name.

返回值

会话存储的返回值（通常成功返回 0，失败返回 1）。

参见

  • The session.auto-start configuration directive.


Read session data

  • ? SessionHandler::open
  • SessionHandler::write ?
  • PHP Manual
  • SessionHandler
  • Read session data

SessionHandler::read

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::read — Read session data

说明

public SessionHandler::read ( string $id ) : string

Reads the session data from the session storage, and returns the result back to PHP for internal processing. This method is called automatically by PHP when a session is started (either automatically or explicitly with session_start() and is preceded by an internal call to the SessionHandler::open().

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritance, calling the parent read method will invoke the wrapper for this method and therefore invoke the associated internal callback. This allows the method to be overridden and or intercepted and filtered (for example, decrypting $data value returned by the parent read method).

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::read().

参数

id

The session id to read data for.

返回值

Returns an encoded string of the read data. If nothing was read, it must return an empty string. Note this value is returned internally to PHP for processing.

参见

  • The session.serialize_handler configuration directive.


Write session data

  • ? SessionHandler::read
  • SessionHandlerInterface ?
  • PHP Manual
  • SessionHandler
  • Write session data

SessionHandler::write

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandler::write — Write session data

说明

public SessionHandler::write ( string $id , string $data ) : bool

Writes the session data to the session storage. Called by normal PHP shutdown, by session_write_close(), or when session_register_shutdown() fails. PHP will call SessionHandler::close() immediately after this method returns.

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent write method will invoke the wrapper for this method and therefore invoke the associated internal callback. This allows this method to be overridden and or intercepted and filtered (for example, encrypting the $data value before sending it to the parent write method).

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::write().

参数

id

The session id.

data

The encoded session data. This data is the result of the PHP internally encoding the $_SESSION superglobal to a serialized string and passing it as this parameter. Please note sessions use an alternative serialization method.

返回值

会话存储的返回值（通常成功返回 0，失败返回 1）。

参见

  • The session.serialize_handler configuration directive.


The SessionHandlerInterface class

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

简介

SessionHandlerInterface is an interface which defines the minimal prototype for creating a custom session handler. In order to pass a custom session handler to session_set_save_handler() using its OOP invocation, the class can implement this interface.

Please note the callback methods of this class are designed to be called internally by PHP and are not meant to be called from user-space code.

类摘要

SessionHandlerInterface {
/* 方法 */
abstract public close ( ) : bool
abstract public destroy ( string $id ) : bool
abstract public gc ( int $max_lifetime ) : int|bool
abstract public open ( string $path , string $name ) : bool
abstract public read ( string $id ) : string
abstract public write ( string $id , string $data ) : bool
}

Example #1 Example using SessionHandlerInterface

The following example provides file based session storage similar to the PHP sessions default save handler files. This example could easily be extended to cover database storage using your favorite PHP supported database engine.

Note we use the OOP prototype with session_set_save_handler() and register the shutdown function using the function's parameter flag. This is generally advised when registering objects as session save handlers.

Caution

For brevity, this example omits input validation. However, the $id parameters are actually user supplied values which require proper validation/sanitization to avoid vulnerabilities, such as path traversal issues. So do not use this example unmodified in production environments.

<?php
class MySessionHandler implements SessionHandlerInterface
{
    private $savePath;

    public function open($savePath, $sessionName)
    {
        $this->savePath = $savePath;
        if (!is_dir($this->savePath)) {
            mkdir($this->savePath, 0777);
        }

        return true;
    }

    public function close()
    {
        return true;
    }

    public function read($id)
    {
        return (string)@file_get_contents("$this->savePath/sess_$id");
    }

    public function write($id, $data)
    {
        return file_put_contents("$this->savePath/sess_$id", $data) === false ? false : true;
    }

    public function destroy($id)
    {
        $file = "$this->savePath/sess_$id";
        if (file_exists($file)) {
            unlink($file);
        }

        return true;
    }

    public function gc($maxlifetime)
    {
        foreach (glob("$this->savePath/sess_*") as $file) {
            if (filemtime($file) + $maxlifetime < time() && file_exists($file)) {
                unlink($file);
            }
        }

        return true;
    }
}

$handler = new MySessionHandler();
session_set_save_handler($handler, true);
session_start();

// proceed to set and retrieve values by key from $_SESSION

Table of Contents

  • SessionHandlerInterface::close — Close the session
  • SessionHandlerInterface::destroy — Destroy a session
  • SessionHandlerInterface::gc — Cleanup old sessions
  • SessionHandlerInterface::open — Initialize session
  • SessionHandlerInterface::read — Read session data
  • SessionHandlerInterface::write — Write session data


Close the session

  • ? SessionHandlerInterface
  • SessionHandlerInterface::destroy ?
  • PHP Manual
  • SessionHandlerInterface
  • Close the session

SessionHandlerInterface::close

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::close — Close the session

说明

abstract public SessionHandlerInterface::close ( ) : bool

Closes the current session. This function is automatically executed when closing the session, or explicitly via session_write_close().

参数

此函数没有参数。

返回值

会话存储的返回值（通常成功返回 0，失败返回 1）。


Destroy a session

  • ? SessionHandlerInterface::close
  • SessionHandlerInterface::gc ?
  • PHP Manual
  • SessionHandlerInterface
  • Destroy a session

SessionHandlerInterface::destroy

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::destroy — Destroy a session

说明

abstract public SessionHandlerInterface::destroy ( string $id ) : bool

Destroys a session. Called by session_regenerate_id() (with $destroy = true), session_destroy() and when session_decode() fails.

参数

id

The session ID being destroyed.

返回值

会话存储的返回值（通常成功返回 0，失败返回 1）。


Cleanup old sessions

  • ? SessionHandlerInterface::destroy
  • SessionHandlerInterface::open ?
  • PHP Manual
  • SessionHandlerInterface
  • Cleanup old sessions

SessionHandlerInterface::gc

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::gc — Cleanup old sessions

说明

abstract public SessionHandlerInterface::gc ( int $max_lifetime ) : int|bool

Cleans up expired sessions. Called by session_start(), based on session.gc_divisor, session.gc_probability and session.gc_maxlifetime settings.

参数

max_lifetime

Sessions that have not updated for the last max_lifetime seconds will be removed.

返回值

Returns the number of deleted sessions on success, 或者在失败时返回 false. Note this value is returned internally to PHP for processing.

更新日志

版本 | 说明
7.1.0 | Prior to this version, the function returned true on success.


Initialize session

  • ? SessionHandlerInterface::gc
  • SessionHandlerInterface::read ?
  • PHP Manual
  • SessionHandlerInterface
  • Initialize session

SessionHandlerInterface::open

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::open — Initialize session

说明

abstract public SessionHandlerInterface::open ( string $path , string $name ) : bool

Re-initialize existing session, or creates a new one. Called when a session starts or when session_start() is invoked.

参数

path

The path where to store/retrieve the session.

name

The session name.

返回值

会话存储的返回值（通常成功返回 0，失败返回 1）。

参见

  • session_name() - 读取/设置会话名称
  • The session.auto-start configuration directive.


Read session data

  • ? SessionHandlerInterface::open
  • SessionHandlerInterface::write ?
  • PHP Manual
  • SessionHandlerInterface
  • Read session data

SessionHandlerInterface::read

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::read — Read session data

说明

abstract public SessionHandlerInterface::read ( string $id ) : string

Reads the session data from the session storage, and returns the results. Called right after the session starts or when session_start() is called. Please note that before this method is called SessionHandlerInterface::open() is invoked.

This method is called by PHP itself when the session is started. This method should retrieve the session data from storage by the session ID provided. The string returned by this method must be in the same serialized format as when originally passed to the SessionHandlerInterface::write() If the record was not found, return an empty string.

The data returned by this method will be decoded internally by PHP using the unserialization method specified in session.serialize_handler. The resulting data will be used to populate the $_SESSION superglobal.

Note that the serialization scheme is not the same as unserialize() and can be accessed by session_decode().

参数

id

The session id.

返回值

Returns an encoded string of the read data. If nothing was read, it must return an empty string. Note this value is returned internally to PHP for processing.

参见

  • The session.serialize_handler configuration directive.


Write session data

  • ? SessionHandlerInterface::read
  • 文本处理 ?
  • PHP Manual
  • SessionHandlerInterface
  • Write session data

SessionHandlerInterface::write

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

SessionHandlerInterface::write — Write session data

说明

abstract public SessionHandlerInterface::write ( string $id , string $data ) : bool

Writes the session data to the session storage. Called by session_write_close(), when session_register_shutdown() fails, or during a normal shutdown. Note: SessionHandlerInterface::close() is called immediately after this function.

PHP will call this method when the session is ready to be saved and closed. It encodes the session data from the $_SESSION superglobal to a serialized string and passes this along with the session ID to this method for storage. The serialization method used is specified in the session.serialize_handler setting.

Note this method is normally called by PHP after the output buffers have been closed unless explicitly called by session_write_close()

参数

id

The session id.

data

The encoded session data. This data is the result of the PHP internally encoding the $_SESSION superglobal to a serialized string and passing it as this parameter. Please note sessions use an alternative serialization method.

返回值

会话存储的返回值（通常成功返回 0，失败返回 1）。

参见

  • The session.serialize_handler configuration directive.


文本处理

  • CommonMark
    • 简介
    • 安装／配置
    • CommonMark\Node\Document — Document concrete CommonMark\Node
    • CommonMark\Node\Heading — Heading concrete CommonMark\Node
    • CommonMark\Node\Paragraph — Paragraph concrete CommonMark\Node
    • CommonMark\Node\BlockQuote — BlockQuote concrete CommonMark\Node
    • CommonMark\Node\BulletList — BulletList concrete CommonMark\Node
    • CommonMark\Node\OrderedList — OrderedList concrete CommonMark\Node
    • CommonMark\Node\Item — Item concrete CommonMark\Node
    • CommonMark\Node\Text — Text concrete CommonMark\Node
    • CommonMark\Node\Text\Strong — Strong concrete CommonMark\Node
    • CommonMark\Node\Text\Emphasis — Emphasis concrete CommonMark\Node
    • CommonMark\Node\ThematicBreak — ThematicBreak concrete CommonMark\Node
    • CommonMark\Node\SoftBreak — SoftBreak concrete CommonMark\Node
    • CommonMark\Node\LineBreak — LineBreak concrete CommonMark\Node
    • CommonMark\Node\Code — Code concrete CommonMark\Node
    • CommonMark\Node\CodeBlock — CodeBlock concrete CommonMark\Node
    • CommonMark\Node\HTMLBlock — HTMLBlock concrete CommonMark\Node
    • CommonMark\Node\HTMLInline — HTMLInline concrete CommonMark\Node
    • CommonMark\Node\Image — Image concrete CommonMark\Node
    • CommonMark\Node\Link — Link concrete CommonMark\Node
    • CommonMark\Node\CustomBlock — CustomBlock concrete CommonMark\Node
    • CommonMark\Node\CustomInline — CustomInline concrete CommonMark\Node
    • CommonMark\Node — Abstract CommonMark\Node
    • CommonMark\Interfaces\IVisitor — The CommonMark\Interfaces\IVisitor interface
    • CommonMark\Interfaces\IVisitable — The CommonMark\Interfaces\IVisitable interface
    • CommonMark\Parser — The CommonMark\Parser class
    • CommonMark\CQL — The CommonMark\CQL class
    • CommonMark 函数
  • Parle — Parsing and lexing
    • 简介
    • 安装／配置
    • 预定义常量
    • Pattern matching — Parle pattern matching
    • 范例
    • Parle\Lexer — The Parle\Lexer class
    • Parle\RLexer — The Parle\RLexer class
    • Parle\Parser — The Parle\Parser class
    • Parle\RParser — The Parle\RParser class
    • Parle\Stack — The Parle\Stack class
    • Parle\Token — The Parle\Token class
    • Parle\ErrorInfo — The Parle\ErrorInfo class
    • Parle\LexerException — The Parle\LexerException class
    • Parle\ParserException — The Parle\ParserException class
  • PCRE — 正则表达式(兼容 Perl)
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • PCRE模式
    • PCRE 函数
  • POSIX Regex — Regular Expression (POSIX Extended)
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • POSIX 正则表达式函数
  • ssdeep — ssdeep Fuzzy Hashing
    • 简介
    • 安装／配置
    • 预定义常量
    • ssdeep 函数
  • 字符串
    • 简介
    • 安装／配置
    • 预定义常量
    • 字符串 函数
    • 更新日志


CommonMark

  • 简介
  • 安装／配置
    • 需求
    • 安装
  • CommonMark\Node\Document — Document concrete CommonMark\Node
  • CommonMark\Node\Heading — Heading concrete CommonMark\Node
    • CommonMark\Node\Heading::__construct — Heading Construction
  • CommonMark\Node\Paragraph — Paragraph concrete CommonMark\Node
  • CommonMark\Node\BlockQuote — BlockQuote concrete CommonMark\Node
  • CommonMark\Node\BulletList — BulletList concrete CommonMark\Node
    • CommonMark\Node\BulletList::__construct — BulletList Construction
  • CommonMark\Node\OrderedList — OrderedList concrete CommonMark\Node
    • CommonMark\Node\OrderedList::__construct — OrderedList Construction
  • CommonMark\Node\Item — Item concrete CommonMark\Node
  • CommonMark\Node\Text — Text concrete CommonMark\Node
    • CommonMark\Node\Text::__construct — Text Construction
  • CommonMark\Node\Text\Strong — Strong concrete CommonMark\Node
  • CommonMark\Node\Text\Emphasis — Emphasis concrete CommonMark\Node
  • CommonMark\Node\ThematicBreak — ThematicBreak concrete CommonMark\Node
  • CommonMark\Node\SoftBreak — SoftBreak concrete CommonMark\Node
  • CommonMark\Node\LineBreak — LineBreak concrete CommonMark\Node
  • CommonMark\Node\Code — Code concrete CommonMark\Node
  • CommonMark\Node\CodeBlock — CodeBlock concrete CommonMark\Node
    • CommonMark\Node\CodeBlock::__construct — CodeBlock Construction
  • CommonMark\Node\HTMLBlock — HTMLBlock concrete CommonMark\Node
  • CommonMark\Node\HTMLInline — HTMLInline concrete CommonMark\Node
  • CommonMark\Node\Image — Image concrete CommonMark\Node
    • CommonMark\Node\Image::__construct — Image Construction
  • CommonMark\Node\Link — Link concrete CommonMark\Node
    • CommonMark\Node\Link::__construct — Link Construction
  • CommonMark\Node\CustomBlock — CustomBlock concrete CommonMark\Node
  • CommonMark\Node\CustomInline — CustomInline concrete CommonMark\Node
  • CommonMark\Node — Abstract CommonMark\Node
    • CommonMark\Node::appendChild — AST Manipulation
    • CommonMark\Node::prependChild — AST Manipulation
    • CommonMark\Node::insertAfter — AST Manipulation
    • CommonMark\Node::insertBefore — AST Manipulation
    • CommonMark\Node::replace — AST Manipulation
    • CommonMark\Node::unlink — AST Manipulation
    • CommonMark\Node::accept — Visitation
  • CommonMark\Interfaces\IVisitor — The CommonMark\Interfaces\IVisitor interface
    • CommonMark\Interfaces\IVisitor::enter — Visitation
    • CommonMark\Interfaces\IVisitor::leave — Visitation
  • CommonMark\Interfaces\IVisitable — The CommonMark\Interfaces\IVisitable interface
    • CommonMark\Interfaces\IVisitable::accept — Visitation
  • CommonMark\Parser — The CommonMark\Parser class
    • CommonMark\Parser::__construct — Parsing
    • CommonMark\Parser::parse — Parsing
    • CommonMark\Parser::finish — Parsing
  • CommonMark\CQL — The CommonMark\CQL class
    • CommonMark\CQL::__construct — CQL Construction
    • CommonMark\CQL::__invoke — CQL Execution
  • CommonMark 函数
    • CommonMark\Parse — Parsing
    • CommonMark\Render — Rendering
    • CommonMark\Render\HTML — Rendering
    • CommonMark\Render\Latex — Rendering
    • CommonMark\Render\Man — Rendering
    • CommonMark\Render\XML — Rendering


简介

This extension provides access to the reference implementation of CommonMark, a rationalized version of Markdown syntax with a specification.

Parsing:

The CommonMark extension provides a simple parsing API:

CommonMark\Parse ( string $content , int $options = ? ) : CommonMark\Node

Rendering:

The CommonMark extension provides simple rendering API that supports multiple formats:

CommonMark\Render ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string
CommonMark\Render\HTML ( CommonMark\Node $node , int $options = ? ) : string
CommonMark\Render\XML ( CommonMark\Node $node , int $options = ? ) : string
CommonMark\Render\Man ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string
CommonMark\Render\Latex ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string

AST:

The CommonMark extension implements visitation for CommonMark\Node objects:

public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void

CQL:

The CommonMark extension provides an interface to CQL, CommonMark Query Language:

public CommonMark\CQL::__construct ( string $query )


  • ? 简介
  • 需求 ?
  • PHP Manual
  • CommonMark
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装


需求

The CommonMark extension requires the (C) reference implementation of » cmark.


安装

The CommonMark extension releases are hosted by PECL and source is hosted on » github, the easiest route to installation is the normal PECL route: » https://pecl.php.net/package/cmark.

Windows users can download prebuilt release binaries from the » PECL website.

Caution

Windows users need to take the additional step of adding cmark.dll (distributed with Windows releases) to their PATH.


Document concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Document extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Heading concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Heading extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 属性 */
public int $level ;
/* Constructor */
public __construct ( )
public __construct ( int $level )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Node\Heading::__construct — Heading Construction


Heading Construction

  • ? CommonMark\Node\Heading
  • CommonMark\Node\Paragraph ?
  • PHP Manual
  • CommonMark\Node\Heading
  • Heading Construction

CommonMark\Node\Heading::__construct

(cmark >= 1.0.0)

CommonMark\Node\Heading::__construct — Heading Construction

说明

public CommonMark\Node\Heading::__construct ( )
public CommonMark\Node\Heading::__construct ( int $level )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。


Paragraph concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Paragraph extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


BlockQuote concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\BlockQuote extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


BulletList concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\BulletList extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 属性 */
public bool $tight ;
public int $delimiter ;
/* Constructor */
public __construct ( )
public __construct ( int $tight )
public __construct ( int $tight , int $delimiter )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Node\BulletList::__construct — BulletList Construction


BulletList Construction

  • ? CommonMark\Node\BulletList
  • CommonMark\Node\OrderedList ?
  • PHP Manual
  • CommonMark\Node\BulletList
  • BulletList Construction

CommonMark\Node\BulletList::__construct

(cmark >= 1.0.0)

CommonMark\Node\BulletList::__construct — BulletList Construction

说明

public CommonMark\Node\BulletList::__construct ( )
public CommonMark\Node\BulletList::__construct ( int $tight )
public CommonMark\Node\BulletList::__construct ( int $tight , int $delimiter )

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。


OrderedList concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\OrderedList extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 属性 */
public bool $tight ;
public int $delimiter ;
public int $start ;
/* Constructor */
public __construct ( )
public __construct ( int $tight )
public __construct ( int $tight , int $delimiter )
public __construct ( int $tight , int $delimiter , int $start )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Node\OrderedList::__construct — OrderedList Construction


OrderedList Construction

  • ? CommonMark\Node\OrderedList
  • CommonMark\Node\Item ?
  • PHP Manual
  • CommonMark\Node\OrderedList
  • OrderedList Construction

CommonMark\Node\OrderedList::__construct

(cmark >= 1.0.0)

CommonMark\Node\OrderedList::__construct — OrderedList Construction

说明

public CommonMark\Node\OrderedList::__construct ( )
public CommonMark\Node\OrderedList::__construct ( int $tight )
public CommonMark\Node\OrderedList::__construct ( int $tight , int $delimiter )
public CommonMark\Node\OrderedList::__construct ( int $tight , int $delimiter , int $start )

Warning

本函数还未编写文档，仅有参数列表。

参数

tight

delimiter

start


Item concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Item extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Text concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Text extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 属性 */
public string|null $literal ;
/* Constructor */
public __construct ( )
public __construct ( string $literal )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Node\Text::__construct — Text Construction


Text Construction

  • ? CommonMark\Node\Text
  • CommonMark\Node\Text\Strong ?
  • PHP Manual
  • CommonMark\Node\Text
  • Text Construction

CommonMark\Node\Text::__construct

(cmark >= 1.0.0)

CommonMark\Node\Text::__construct — Text Construction

说明

public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )

Warning

本函数还未编写文档，仅有参数列表。

参数

literal


Strong concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Text\Strong extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Emphasis concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Text\Emphasis extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


ThematicBreak concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\ThematicBreak extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


SoftBreak concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\SoftBreak extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


LineBreak concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\LineBreak extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Code concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Code extends CommonMark\Node\Text implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
public string|null $literal ;
/* Constructor */
public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


CodeBlock concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\CodeBlock extends CommonMark\Node\Text implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
public string|null $literal ;
/* 属性 */
public string|null $fence ;
/* Constructor */
public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )
public __construct ( string $fence , string $literal )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Node\CodeBlock::__construct — CodeBlock Construction


CodeBlock Construction

  • ? CommonMark\Node\CodeBlock
  • CommonMark\Node\HTMLBlock ?
  • PHP Manual
  • CommonMark\Node\CodeBlock
  • CodeBlock Construction

CommonMark\Node\CodeBlock::__construct

(cmark >= 1.0.0)

CommonMark\Node\CodeBlock::__construct — CodeBlock Construction

说明

public CommonMark\Node\CodeBlock::__construct ( string $fence , string $literal )

Warning

本函数还未编写文档，仅有参数列表。

参数

fence

literal


HTMLBlock concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\HTMLBlock extends CommonMark\Node\Text implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
public string|null $literal ;
/* Constructor */
public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


HTMLInline concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\HTMLInline extends CommonMark\Node\Text implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
public string|null $literal ;
/* Constructor */
public CommonMark\Node\Text::__construct ( )
public CommonMark\Node\Text::__construct ( string $literal )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Image concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Image extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 属性 */
public string|null $url ;
public string|null $title ;
/* Constructor */
public __construct ( )
public __construct ( string $url )
public __construct ( string $url , string $title )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Node\Image::__construct — Image Construction


Image Construction

  • ? CommonMark\Node\Image
  • CommonMark\Node\Link ?
  • PHP Manual
  • CommonMark\Node\Image
  • Image Construction

CommonMark\Node\Image::__construct

(cmark >= 1.0.0)

CommonMark\Node\Image::__construct — Image Construction

说明

public CommonMark\Node\Image::__construct ( )
public CommonMark\Node\Image::__construct ( string $url )
public CommonMark\Node\Image::__construct ( string $url , string $title )

Warning

本函数还未编写文档，仅有参数列表。

参数

url

title


Link concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\Link extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 属性 */
public string|null $url ;
public string|null $title ;
/* Constructor */
public __construct ( )
public __construct ( string $url )
public __construct ( string $url , string $title )
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Node\Link::__construct — Link Construction


Link Construction

  • ? CommonMark\Node\Link
  • CommonMark\Node\CustomBlock ?
  • PHP Manual
  • CommonMark\Node\Link
  • Link Construction

CommonMark\Node\Link::__construct

(cmark >= 1.0.0)

CommonMark\Node\Link::__construct — Link Construction

说明

public CommonMark\Node\Link::__construct ( )
public CommonMark\Node\Link::__construct ( string $url )
public CommonMark\Node\Link::__construct ( string $url , string $title )

Warning

本函数还未编写文档，仅有参数列表。

参数

url

title


CustomBlock concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\CustomBlock extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 属性 */
public string|null $onEnter ;
public string|null $onLeave ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


CustomInline concrete CommonMark\Node

(cmark >= 1.0.0)

类摘要

final CommonMark\Node\CustomInline extends CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 继承的属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 属性 */
public string|null $onEnter ;
public string|null $onLeave ;
/* 继承的方法 */
public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node
public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node
public CommonMark\Node::unlink ( ) : void
public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}


Abstract CommonMark\Node

(cmark >= 1.0.0)

简介

Represents an Abstract Node, this final abstract is not for direct use by the programmer.

类摘要

final abstract CommonMark\Node implements CommonMark\Interfaces\IVisitable , Traversable {
/* 属性 */
public readonly Node|null $parent ;
public readonly Node|null $previous ;
public readonly Node|null $next ;
public readonly Node|null $lastChild ;
public readonly Node|null $firstChild ;
public readonly int $startLine ;
public readonly int $endLine ;
public readonly int $startColumn ;
public readonly int $endColumn ;
/* 方法 */
public appendChild ( CommonMark\Node $child ) : CommonMark\Node
public prependChild ( CommonMark\Node $child ) : CommonMark\Node
public insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node
public insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node
public replace ( CommonMark\Node $target ) : CommonMark\Node
public unlink ( ) : void
public accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Node::appendChild — AST Manipulation
  • CommonMark\Node::prependChild — AST Manipulation
  • CommonMark\Node::insertAfter — AST Manipulation
  • CommonMark\Node::insertBefore — AST Manipulation
  • CommonMark\Node::replace — AST Manipulation
  • CommonMark\Node::unlink — AST Manipulation
  • CommonMark\Node::accept — Visitation


AST Manipulation

  • ? CommonMark\Node
  • CommonMark\Node::prependChild ?
  • PHP Manual
  • CommonMark\Node
  • AST Manipulation

CommonMark\Node::appendChild

(cmark >= 1.0.0)

CommonMark\Node::appendChild — AST Manipulation

说明

public CommonMark\Node::appendChild ( CommonMark\Node $child ) : CommonMark\Node

Warning

本函数还未编写文档，仅有参数列表。

参数

child

返回值


AST Manipulation

  • ? CommonMark\Node::appendChild
  • CommonMark\Node::insertAfter ?
  • PHP Manual
  • CommonMark\Node
  • AST Manipulation

CommonMark\Node::prependChild

(cmark >= 1.0.0)

CommonMark\Node::prependChild — AST Manipulation

说明

public CommonMark\Node::prependChild ( CommonMark\Node $child ) : CommonMark\Node

Warning

本函数还未编写文档，仅有参数列表。

参数

child

返回值


AST Manipulation

  • ? CommonMark\Node::prependChild
  • CommonMark\Node::insertBefore ?
  • PHP Manual
  • CommonMark\Node
  • AST Manipulation

CommonMark\Node::insertAfter

(cmark >= 1.0.0)

CommonMark\Node::insertAfter — AST Manipulation

说明

public CommonMark\Node::insertAfter ( CommonMark\Node $sibling ) : CommonMark\Node

Warning

本函数还未编写文档，仅有参数列表。

参数

sibling

返回值


AST Manipulation

  • ? CommonMark\Node::insertAfter
  • CommonMark\Node::replace ?
  • PHP Manual
  • CommonMark\Node
  • AST Manipulation

CommonMark\Node::insertBefore

(cmark >= 1.0.0)

CommonMark\Node::insertBefore — AST Manipulation

说明

public CommonMark\Node::insertBefore ( CommonMark\Node $sibling ) : CommonMark\Node

Warning

本函数还未编写文档，仅有参数列表。

参数

sibling

返回值


AST Manipulation

  • ? CommonMark\Node::insertBefore
  • CommonMark\Node::unlink ?
  • PHP Manual
  • CommonMark\Node
  • AST Manipulation

CommonMark\Node::replace

(cmark >= 1.0.0)

CommonMark\Node::replace — AST Manipulation

说明

public CommonMark\Node::replace ( CommonMark\Node $target ) : CommonMark\Node

Warning

本函数还未编写文档，仅有参数列表。

参数

target

返回值


AST Manipulation

  • ? CommonMark\Node::replace
  • CommonMark\Node::accept ?
  • PHP Manual
  • CommonMark\Node
  • AST Manipulation

CommonMark\Node::unlink

(cmark >= 1.0.0)

CommonMark\Node::unlink — AST Manipulation

说明

public CommonMark\Node::unlink ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Visitation

  • ? CommonMark\Node::unlink
  • CommonMark\Interfaces\IVisitor ?
  • PHP Manual
  • CommonMark\Node
  • Visitation

CommonMark\Node::accept

(cmark >= 1.0.0)

CommonMark\Node::accept — Visitation

说明

public CommonMark\Node::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void

参数

visitor

An object implementing CommonMark\Interfaces\IVisitor

参见

  • CommonMark\Interfaces\IVisitor::enter
  • CommonMark\Interfaces\IVisitor::leave


The CommonMark\Interfaces\IVisitor interface

(cmark >= 1.0.0)

简介

类摘要

final CommonMark\Interfaces\IVisitor {
/* Constants */
const int Done ;
const int Enter ;
const int Leave ;
/* 方法 */
abstract public enter ( IVisitable $visitable ) : int|IVisitable|null
abstract public leave ( IVisitable $visitable ) : int|IVisitable|null
}

Table of Contents

  • CommonMark\Interfaces\IVisitor::enter — Visitation
  • CommonMark\Interfaces\IVisitor::leave — Visitation


Visitation

  • ? CommonMark\Interfaces\IVisitor
  • CommonMark\Interfaces\IVisitor::leave ?
  • PHP Manual
  • CommonMark\Interfaces\IVisitor
  • Visitation

CommonMark\Interfaces\IVisitor::enter

(cmark >= 1.0.0)

CommonMark\Interfaces\IVisitor::enter — Visitation

说明

abstract public CommonMark\Interfaces\IVisitor::enter ( IVisitable $visitable ) : int|IVisitable|null

参数

visitable

The current CommonMark\Interfaces\IVisitable being entered

返回值

Returning CommonMark\Interfaces\IVisitor::Done will cause the backing iterator to exit.

Returning CommonMark\Interfaces\IVisitor::Enter will reset the backing iterator at entering the current IVisitable

Returning CommonMark\Interfaces\IVisitor::Leave will reset the backing iterator at exiting the current IVisitable

Returning an IVisitable will reset the backing iterator at entering the given IVisitable

Returning nothing will allow the backing iterator to continue

参见

  • CommonMark\Interfaces\IVisitable::accept


Visitation

  • ? CommonMark\Interfaces\IVisitor::enter
  • CommonMark\Interfaces\IVisitable ?
  • PHP Manual
  • CommonMark\Interfaces\IVisitor
  • Visitation

CommonMark\Interfaces\IVisitor::leave

(cmark >= 1.0.0)

CommonMark\Interfaces\IVisitor::leave — Visitation

说明

abstract public CommonMark\Interfaces\IVisitor::leave ( IVisitable $visitable ) : int|IVisitable|null

参数

visitable

The current CommonMark\Interfaces\IVisitable being exited

返回值

Returning CommonMark\Interfaces\IVisitor::Done will cause the backing iterator to exit.

Returning CommonMark\Interfaces\IVisitor::Enter will reset the backing iterator at entering the current IVisitable

Returning CommonMark\Interfaces\IVisitor::Leave will reset the backing iterator at exiting the current IVisitable

Returning an IVisitable will reset the backing iterator at exiting the given IVisitable

Returning nothing will allow the backing iterator to continue

参见

  • CommonMark\Interfaces\IVisitable::accept


The CommonMark\Interfaces\IVisitable interface

(cmark >= 1.0.0)

简介

类摘要

final CommonMark\Interfaces\IVisitable {
abstract public accept ( CommonMark\Interfaces\IVisitor $visitor ) : void
}

Table of Contents

  • CommonMark\Interfaces\IVisitable::accept — Visitation


Visitation

  • ? CommonMark\Interfaces\IVisitable
  • CommonMark\Parser ?
  • PHP Manual
  • CommonMark\Interfaces\IVisitable
  • Visitation

CommonMark\Interfaces\IVisitable::accept

(cmark >= 1.0.0)

CommonMark\Interfaces\IVisitable::accept — Visitation

说明

abstract public CommonMark\Interfaces\IVisitable::accept ( CommonMark\Interfaces\IVisitor $visitor ) : void

参数

visitor

An object implementing CommonMark\Interfaces\IVisitor

参见

  • CommonMark\Interfaces\IVisitor::enter
  • CommonMark\Interfaces\IVisitor::leave


The CommonMark\Parser class

(cmark >= 1.0.0)

简介

Provides an incremental parser as an alternative to the simple Parsing API function

类摘要

final CommonMark\Parser {
/* Constructor */
public __construct ( int $options = ? )
/* 方法 */
public parse ( string $buffer ) : void
public finish ( ) : CommonMark\Node
}

Table of Contents

  • CommonMark\Parser::__construct — Parsing
  • CommonMark\Parser::parse — Parsing
  • CommonMark\Parser::finish — Parsing


Parsing

  • ? CommonMark\Parser
  • CommonMark\Parser::parse ?
  • PHP Manual
  • CommonMark\Parser
  • Parsing

CommonMark\Parser::__construct

(cmark >= 1.0.0)

CommonMark\Parser::__construct — Parsing

说明

public CommonMark\Parser::__construct ( int $options = ? )

Warning

本函数还未编写文档，仅有参数列表。

参数

options

A mask of:

CommonMark\Parser\Normal (int)
CommonMark\Parser\Normalize (int)
CommonMark\Parser\ValidateUTF8 (int)
CommonMark\Parser\Smart (int)


Parsing

  • ? CommonMark\Parser::__construct
  • CommonMark\Parser::finish ?
  • PHP Manual
  • CommonMark\Parser
  • Parsing

CommonMark\Parser::parse

(cmark >= 1.0.0)

CommonMark\Parser::parse — Parsing

说明

public CommonMark\Parser::parse ( string $buffer ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

buffer

返回值


Parsing

  • ? CommonMark\Parser::parse
  • CommonMark\CQL ?
  • PHP Manual
  • CommonMark\Parser
  • Parsing

CommonMark\Parser::finish

(cmark >= 1.0.0)

CommonMark\Parser::finish — Parsing

说明

public CommonMark\Parser::finish ( ) : CommonMark\Node

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


The CommonMark\CQL class

(cmark >= 1.1.0)

简介

CommonMark Query Language is a DSL for describing how to travel through a CommonMark Node tree implemented as a parser and compiler for a small set of instructions, and a virtual machine for executing those instructions.

Paths:

In it's most simplistic form, a CQL query combines the following paths and / to describe how to travel through a tree:

  • firstChild
  • lastChild
  • previous
  • next
  • parent
For example, /firstChild/lastChild would travel to the last child node of the first child node.

Loops

CQL can be instructed to loop, for example through the children of, or siblings to a particular node, by using the path children, or siblings. For example, /firstChild/children will travel to all the children of the first child node.

Subqueries

CQL can be instructed how to travel by using a subquery like [/firstChild]. For example, /firstChild/children[/firstChild] will travel to the first child node of all the children of the first child node.

Loop Constraints

While looping, CQL can be instructed to constrict the travelled path to nodes of particular type. For example /children(BlockQuote) will travel to the children of a node where the type is BlockQuote. The following types are recognized (case insensitively):

  • BlockQuote
  • List
  • Item
  • CodeBlock
  • HtmlBlock
  • CustomBlock
  • Paragraph
  • Heading
  • ThematicBreak
  • Text
  • SoftBreak
  • LineBreak
  • Code
  • HtmlInline
  • CustomInline
  • Emphasis
  • Strong
  • Link
  • Image
Types may be used as a union, for example /children(BlockQuote|List) will travel to the children of a node where the type is BlockQuote or List. Types, or unions of types, may be also negated. For example /children(~BlockQuote) will travel to the children of a node where the type is not BlockQuote, and /children(~BlockQuote|Paragraph) will travel to the children of a node where the type is not BlockQuote or Paragraph

Path Constraints

CQL can be instructed to create a loop to travel to a node of a particular type, at a particular path. For example, /firstChild(BlockQuote) will travel to the first child node where the type is BlockQuote. Note that like other loops for children and siblings, this kind of path can only be followed by a subquery.

Implementation Notes

While CQL has been implemented as part of the PHP CommonMark extension, it stands separately from PHP and does not use PHP's virtual machine or internal representation of values.

类摘要

CommonMark\CQL {
/* Constructor */
public __construct ( string $query )
/* 方法 */
public __invoke ( CommonMark\Node $root , callable $handler )
}

Table of Contents

  • CommonMark\CQL::__construct — CQL Construction
  • CommonMark\CQL::__invoke — CQL Execution


CQL Construction

  • ? CommonMark\CQL
  • CommonMark\CQL::__invoke ?
  • PHP Manual
  • CommonMark\CQL
  • CQL Construction

CommonMark\CQL::__construct

(cmark >= 1.1.0)

CommonMark\CQL::__construct — CQL Construction

说明

public CommonMark\CQL::__construct ( string $query )

参数

query

a CQL string


CQL Execution

  • ? CommonMark\CQL::__construct
  • CommonMark 函数 ?
  • PHP Manual
  • CommonMark\CQL
  • CQL Execution

CommonMark\CQL::__invoke

(cmark >= 1.1.0)

CommonMark\CQL::__invoke — CQL Execution

说明

public CommonMark\CQL::__invoke ( CommonMark\Node $root , callable $handler )

Shall invoke the current CQL function on the given root, executing the given handler on entry to a CommonMark\Node

参数

root

the root node of a tree

handler

should have the prototype:

handler ( CommonMark\Node $root , CommonMark\Node $entering ) : bool|null
  • Should handler fail to return (void), or return null, CQL will continue executing
  • Should the handler return a truthy value, CQL will continue executing.
  • Should the handler return a falsy value, CQL will stop executing


CommonMark 函数

Table of Contents

  • CommonMark\Parse — Parsing
  • CommonMark\Render — Rendering
  • CommonMark\Render\HTML — Rendering
  • CommonMark\Render\Latex — Rendering
  • CommonMark\Render\Man — Rendering
  • CommonMark\Render\XML — Rendering


Parsing

  • ? CommonMark 函数
  • CommonMark\Render ?
  • PHP Manual
  • CommonMark 函数
  • Parsing

CommonMark\Parse

(cmark >= 1.0.0)

CommonMark\Parse — Parsing

说明

CommonMark\Parse ( string $content , int $options = ? ) : CommonMark\Node

Shall parse content

参数

content

markdown string

options

A mask of:

CommonMark\Parser\Normal (int)
CommonMark\Parser\Normalize (int)
CommonMark\Parser\ValidateUTF8 (int)
CommonMark\Parser\Smart (int)

返回值

Shall return root CommonMark\Node


Rendering

  • ? CommonMark\Parse
  • CommonMark\Render\HTML ?
  • PHP Manual
  • CommonMark 函数
  • Rendering

CommonMark\Render

(cmark >= 1.0.0)

CommonMark\Render — Rendering

说明

CommonMark\Render ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

node

options

A mask of:

CommonMark\Render\Normal (int)
CommonMark\Render\SourcePos (int)
CommonMark\Render\HardBreaks (int)
CommonMark\Render\Safe (int)
CommonMark\Render\NoBreaks (int)
width

返回值


Rendering

  • ? CommonMark\Render
  • CommonMark\Render\Latex ?
  • PHP Manual
  • CommonMark 函数
  • Rendering

CommonMark\Render\HTML

(cmark >= 1.0.0)

CommonMark\Render\HTML — Rendering

说明

CommonMark\Render\HTML ( CommonMark\Node $node , int $options = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

node

options

A mask of:

CommonMark\Render\Normal (int)
CommonMark\Render\SourcePos (int)
CommonMark\Render\HardBreaks (int)
CommonMark\Render\Safe (int)
CommonMark\Render\NoBreaks (int)

返回值


Rendering

  • ? CommonMark\Render\HTML
  • CommonMark\Render\Man ?
  • PHP Manual
  • CommonMark 函数
  • Rendering

CommonMark\Render\Latex

(cmark >= 1.0.0)

CommonMark\Render\Latex — Rendering

说明

CommonMark\Render\Latex ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

node

options

A mask of:

CommonMark\Render\Normal (int)
CommonMark\Render\SourcePos (int)
CommonMark\Render\HardBreaks (int)
CommonMark\Render\Safe (int)
CommonMark\Render\NoBreaks (int)
width

返回值


Rendering

  • ? CommonMark\Render\Latex
  • CommonMark\Render\XML ?
  • PHP Manual
  • CommonMark 函数
  • Rendering

CommonMark\Render\Man

(cmark >= 1.0.0)

CommonMark\Render\Man — Rendering

说明

CommonMark\Render\Man ( CommonMark\Node $node , int $options = ? , int $width = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

node

options

A mask of:

CommonMark\Render\Normal (int)
CommonMark\Render\SourcePos (int)
CommonMark\Render\HardBreaks (int)
CommonMark\Render\Safe (int)
CommonMark\Render\NoBreaks (int)
width

返回值


Rendering

  • ? CommonMark\Render\Man
  • Parle ?
  • PHP Manual
  • CommonMark 函数
  • Rendering

CommonMark\Render\XML

(cmark >= 1.0.0)

CommonMark\Render\XML — Rendering

说明

CommonMark\Render\XML ( CommonMark\Node $node , int $options = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

node

options

A mask of:

CommonMark\Render\Normal (int)
CommonMark\Render\SourcePos (int)
CommonMark\Render\HardBreaks (int)
CommonMark\Render\Safe (int)
CommonMark\Render\NoBreaks (int)

返回值


Parsing and lexing

  • 简介
  • 安装／配置
    • 需求
    • 安装
  • 预定义常量
  • Pattern matching — Parle pattern matching
    • Character representations
    • Character classes
    • Unicode character classes
    • Alternation and repetition
    • Anchors
    • Grouping
  • 范例
    • Lexer examples
    • Parser examples
  • Parle\Lexer — The Parle\Lexer class
    • Parle\Lexer::advance — Process next lexer rule
    • Parle\Lexer::build — Finalize the lexer rule set
    • Parle\Lexer::callout — Define token callback
    • Parle\Lexer::consume — Pass the data for processing
    • Parle\Lexer::dump — Dump the state machine
    • Parle\Lexer::getToken — Retrieve the current token
    • Parle\Lexer::insertMacro — Insert regex macro
    • Parle\Lexer::push — Add a lexer rule
    • Parle\Lexer::reset — Reset lexer
  • Parle\RLexer — The Parle\RLexer class
    • Parle\RLexer::advance — Process next lexer rule
    • Parle\RLexer::build — Finalize the lexer rule set
    • Parle\RLexer::callout — Define token callback
    • Parle\RLexer::consume — Pass the data for processing
    • Parle\RLexer::dump — Dump the state machine
    • Parle\RLexer::getToken — Retrieve the current token
    • Parle\RLexer::insertMacro — Insert regex macro
    • Parle\RLexer::push — Add a lexer rule
    • Parle\RLexer::pushState — Push a new start state
    • Parle\RLexer::reset — Reset lexer
  • Parle\Parser — The Parle\Parser class
    • Parle\Parser::advance — Process next parser rule
    • Parle\Parser::build — Finalize the grammar rules
    • Parle\Parser::consume — Consume the data for processing
    • Parle\Parser::dump — Dump the grammar
    • Parle\Parser::errorInfo — Retrieve the error information
    • Parle\Parser::left — Declare a token with left-associativity
    • Parle\Parser::nonassoc — Declare a token with no associativity
    • Parle\Parser::precedence — Declare a precedence rule
    • Parle\Parser::push — Add a grammar rule
    • Parle\Parser::reset — Reset parser state
    • Parle\Parser::right — Declare a token with right-associativity
    • Parle\Parser::sigil — Retrieve a matching part of a rule
    • Parle\Parser::token — Declare a token
    • Parle\Parser::tokenId — Get token id
    • Parle\Parser::trace — Trace the parser operation
    • Parle\Parser::validate — Validate input
  • Parle\RParser — The Parle\RParser class
    • Parle\RParser::advance — Process next parser rule
    • Parle\RParser::build — Finalize the grammar rules
    • Parle\RParser::consume — Consume the data for processing
    • Parle\RParser::dump — Dump the grammar
    • Parle\RParser::errorInfo — Retrieve the error information
    • Parle\RParser::left — Declare a token with left-associativity
    • Parle\RParser::nonassoc — Declare a token with no associativity
    • Parle\RParser::precedence — Declare a precedence rule
    • Parle\RParser::push — Add a grammar rule
    • Parle\RParser::reset — Reset parser state
    • Parle\RParser::right — Declare a token with right-associativity
    • Parle\RParser::sigil — Retrieve a matching part of a rule
    • Parle\RParser::token — Declare a token
    • Parle\RParser::tokenId — Get token id
    • Parle\RParser::trace — Trace the parser operation
    • Parle\RParser::validate — Validate input
  • Parle\Stack — The Parle\Stack class
    • Parle\Stack::pop — Pop an item from the stack
    • Parle\Stack::push — Push an item into the stack
  • Parle\Token — The Parle\Token class
  • Parle\ErrorInfo — The Parle\ErrorInfo class
  • Parle\LexerException — The Parle\LexerException class
  • Parle\ParserException — The Parle\ParserException class


简介

The parle extension provides general purpose lexing and parsing facilities. The implementation is based on » Ben Hanson's libraries and requires a » C++14 capable compiler. The lexer is based on the regex matching, the parser is LALR(1). Lexers and parsers are generated on the fly and can be used immediately after they've been finalized. Parle deals with parsing and lexing, the appropriate data structures representation and processing are the implementer's task. Serialization and code generation are not supported by the extension, yet.

Lexer analysis is a process of splitting a character sequence into a list of lexemes. The lexeme list can be then used for the syntax analysis against a formal grammar. These operations are also known as lexing and parsing. This documentation doesn't aim to provide an exhaustive information on lexing and parsing. Good information in this regard is available on the numerous resources on the net. Several usage examples are included, to show the functionality. The extension is useful for PHP programmers both willing to learn or to utilize parsing and lexing. State machines and grammar parsing don't have to be implemented manually, these complex tasks are taken away by parle. Thanks to that, the development can be focused on the actual problem solving.

The common use case for parle is, when a data format is too complex to be handled by the regex matching with PCRE. The practical application is herewith wide. Be it a specific data format, a behavior modification of existing functions, even an own programming language and beyond. The helper methods such as Parle\Lexer::dump() to inspect the generated state machine, or Parle\Parser::dump() to inspect the generated grammar, are useful. The method Parle\Parser::trace() can also be used to track the parsing operation.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Parle
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装


需求

PHP 7.0 or above is supported. A C++14 capable compiler is required. A successful extension build was produced with at least clang 5.0, GCC 5.0 and Visual Studio 2015.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/parle.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/parle/.

Available configure options
Option | Description
--enable-parle | Enable parle extension.
--enable-parle-utf32 | Enable internal UTF-32 support. Available since parle 0.7.2.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

Parle\INTERNAL_UTF32 bool
Flag whether the internal UTF-32 support is compiled in. Available since parle 0.7.2.


Parle pattern matching

Table of Contents

  • Character representations
  • Character classes
  • Unicode character classes
  • Alternation and repetition
  • Anchors
  • Grouping

Parle supports regex matching similar to flex. Also supported are the following POSIX character sets: [:alnum:], [:alpha:], [:blank:], [:cntrl:], [:digit:], [:graph:], [:lower:], [:print:], [:punct:], [:space:], [:upper:] and [:xdigit:].

The Unicode character classes are currently not enabled by default, pass --enable-parle-utf32 to make them available. A particular encoding can be mapped with a correctly constructed regex. For example, to match the EURO symbol encoded in UTF-8, the regular expression [\xe2][\x82][\xac] can be used. The pattern for an UTF-8 encoded string could be [ -\x7f]{+}[\x80-\xbf]{+}[\xc2-\xdf]{+}[\xe0-\xef]{+}[\xf0-\xff]+.


Character representations

Character representations
Sequence | Description
\a | Alert (bell).
\b | Backspace.
\e | ESC character, \x1b.
\n | Newline.
\r | Carriage return.
\f | Form feed, \x0c.
\t | Horizontal tab, \x09.
\v | Vertical tab, \x0b.
\oct | Character specified by a three-digit octal code.
\xhex | Character specified by a hex code.
\cchar | Named control character.


Character classes

Character classes
Sequence | Description
[...] | A single character listed or contained within a listed range. Ranges can be combined with the {+} and {-} operators. For example [a-z]{+}[0-9] is the same as [0-9a-z] and [a-z]{-}[aeiou] is the same as [b-df-hj-np-tv-z].
[^...] | A single character not listed and not contained within a listed range.
. | Any character, default [^\n].
\d | Digit character, [0-9].
\D | Non-digit character, [^0-9].
\s | White space character, [ \t\n\r\f\v].
\S | Non-white space character, [^ \t\n\r\f\v].
\w | Word caracter, [a-zA-Z0-9_].
\W | Non-word caracter, [^a-zA-Z0-9_].


Unicode character classes

Unicode character classes
Sequence | Description
\p{C} | Other.
\p{Cc} | Other, control.
\p{Cf} | Other, format.
\p{Co} | Other, private use.
\p{Cs} | Other, surrogate.
\p{L} | Letter.
\p{LC} | Letter, cased.
\p{Ll} | Letter, lowercase.
\p{Lm} | Letter, modifier.
\p{Lo} | Letter, other.
\p{Lt} | Letter, titlecase.
\p{Lu} | Letter, uppercase.
\p{M} | Mark.
\p{Mc} | Mark, space combining.
\p{Me} | Mark, enclosing.
\p{Mn} | Mark, nonspacing.
\p{N} | Number.
\p{Nd} | Number, decimal digit.
\p{Nl} | Number, letter.
\p{No} | Number, other.
\p{P} | Punctuation.
\p{Pc} | Punctiation, connector.
\p{Pd} | Punctuation, dash.
\p{Pe} | Punctuation, close.
\p{Pf} | Punctuation, final quote.
\p{Pi} | Punctuation, initial quote.
\p{Po} | Punctuation, other.
\p{Ps} | Punctuation, open.
\p{S} | Symbol.
\p{Sc} | Symbol, currency.
\p{Sk} | Symbol, modifier.
\p{Sm} | Symbol, math.
\p{So} | Symbol, other.
\p{Z} | Separator.
\p{Zl} | Separator, line.
\p{Zp} | Separator, paragraph.
\p{Zs} | Separator, space.

These character clasess are only available, if the option --enable-parle-utf32 was passed at the compilation time.


Alternation and repetition

Alternation and repetition
Sequence | Greedy | Description
...|... | - | Try subpatterns in alternation.
* | yes | Match 0 or more times.
+ | yes | Match 1 or more times.
? | yes | Match 0 or 1 times.
{n} | no | Match exactly n times.
{n,} | yes | Match at least n times.
{n,m} | yes | Match at least n times but no more than m times.
*? | no | Match 0 or more times.
+? | no | Match 1 or more times.
?? | no | Match 0 or 1 times.
{n,}? | no | Match at least n times.
{n,m}? | no | Match at least n times but no more than m times.
{MACRO} | - | Include the regex MACRO in the current regex.


Anchors

Anchors
Sequence | Description
^ | Start of string or after a newline.
$ | End of string or before a newline.


Grouping

Grouping
Sequence | Description
(...) Group a regular expression to override default operator precedence.
(?r-s:pattern) Apply option r and omit option s while interpreting pattern. Options may be zero or more of the characters i, s, or x.
Options
Option | Description
i | Case insensitive.
-i | Case sensitive.
s | Alters the meaning of '.' to match any character whatsoever.
-s | "lters the meaning of '.' to match any character except '\n'.
x | Ignores comments and whitespace in patterns. Whitespace is ignored unless it is backslash-escaped, contained within ""s, or appears inside a character range.
These options can be applied globally at the rules level by passing a combination of the bit flags to the lexer.
(?# comment ) | Omit everything within (). The first ) character encountered ends the pattern. It is not possible for the comment to contain a ) character. The comment may span lines.


  • ? Grouping
  • Lexer examples ?
  • PHP Manual
  • Parle
  • 范例

范例

Table of Contents

  • Lexer examples
  • Parser examples


Lexer examples

Example #1 Tokenize comma separated integer list

<?php

use Parle\Token;
use Parle\Lexer;
use Parle\LexerException;

/* name => id */
$token = array(
        "COMMA" => 1,
        "CRLF" => 2,
        "DECIMAL" => 3,
);
/* id => name */
$tokenIdToName = array_flip($token);

$lex = new Lexer;
$lex->push("[\x2c]", $token["COMMA"]);
$lex->push("[\r][\n]", $token["CRLF"]);
$lex->push("[\d]+", $token["DECIMAL"]);
$lex->build();

$in = "0,1,2\r\n3,42,5\r\n6,77,8\r\n";

$lex->consume($in);

do {
        $lex->advance();
        $tok = $lex->getToken();

        if (Token::UNKNOWN == $tok->id) {
                throw new LexerException("Unknown token '{$tok->value}' at offset {$lex->marker}.");
        }

        echo "TOKEN: ", $tokenIdToName[$tok->id], PHP_EOL;
} while (Token::EOI != $tok->id);

Example #2 Tokenize assign statement

<?php

use Parle\{Token, Lexer};

$lex = new Lexer;

$lex->push("\$[a-zA-Z_][a-zA-Z0-9_]*", 1);
$lex->push("=", 2);
$lex->push("\d+", 3);
$lex->push(";", 4);

$lex->build();

$lex->consume('$x = 42; $y = 24;');

do {
    $lex->advance();
    $tok = $lex->getToken();
    var_dump($tok);
} while (Token::EOI != $tok->id);


Parser examples

Example #1 Simple calculator

<?php

use Parle\{Parser, ParserException, Lexer, Token};

$p = new Parser;
$p->token("INTEGER");
$p->left("'+' '-' '*' '/'");

$p->push("start", "exp");
$prod_add = $p->push("exp", "exp '+' exp");
$prod_sub = $p->push("exp", "exp '-' exp");
$prod_mul = $p->push("exp", "exp '*' exp");
$prod_div = $p->push("exp", "exp '/' exp");
$p->push("exp", "INTEGER"); /* Production index unused. */

$p->build();

$lex = new Lexer;
$lex->push("[+]", $p->tokenId("'+'"));
$lex->push("[-]", $p->tokenId("'-'"));
$lex->push("[*]", $p->tokenId("'*'"));
$lex->push("[/]", $p->tokenId("'/'"));
$lex->push("\\d+", $p->tokenId("INTEGER"));
$lex->push("\\s+", Token::SKIP);

$lex->build();

$exp = array(
    "1 + 1",
    "33 / 10",
    "100 * 45",
    "17 - 45",
);

foreach ($exp as $in) {
    if (!$p->validate($in, $lex)) {
        throw new ParserException("Failed to validate input");
    }

    $p->consume($in, $lex);

    while (Parser::ACTION_ERROR != $p->action && Parser::ACTION_ACCEPT != $p->action) {
        switch ($p->action) {
            case Parser::ACTION_ERROR:
                throw new ParserException("Parser error");
                break;
            case Parser::ACTION_SHIFT:
            case Parser::ACTION_GOTO:
            case Parser::ACTION_ACCEPT:
                break;
            case Parser::ACTION_REDUCE:
                switch ($p->reduceId) {
                    case $prod_add:
                        $l = $p->sigil(0);
                        $r = $p->sigil(2);
                        echo "$l + $r = " . ($l + $r) . "\n";
                        break;
                    case $prod_sub:
                        $l = $p->sigil(0);
                        $r = $p->sigil(2);
                        echo "$l - $r = " . ($l - $r) . "\n";
                        break;
                    case $prod_mul:
                        $l = $p->sigil(0);
                        $r = $p->sigil(2);
                        echo "$l * $r = " . ($l * $r) . "\n";
                        break;
                    case $prod_div:
                        $l = $p->sigil(0);
                        $r = $p->sigil(2);
                    echo "$l / $r = " . ($l / $r) . "\n";
                        break;
            }
            break;
        }
        $p->advance();
    }
}

Example #2 Parse words out from a sentence

<?php

use Parle\{Lexer, Token, Parser, ParserException};

$p = new Parser;
$p->token("WORD");
$p->push("START", "SENTENCE");
$p->push("SENTENCE", "WORDS");
$prod_word_0 = $p->push("WORDS", "WORDS WORD");
$prod_word_1 = $p->push("WORDS", "WORD");
$p->build();

$lex = new Lexer;
$lex->push("[^\s]{-}[\.,\:\;\?]+", $p->tokenId("WORD"));
$lex->push("[\s\.,\:\;\?]+", Token::SKIP);
$lex->build();

$in = "Dis-moi où est ton papa?";
$p->consume($in, $lex);
do {
    switch ($p->action) {
    case Parser::ACTION_ERROR:
        throw new ParserException("Error");
        break;
    case Parser::ACTION_SHIFT:
    case Parser::ACTION_GOTO:
        /* var_dump($p->trace());*/
        break;
    case Parser::ACTION_REDUCE:
        $rid = $p->reduceId();
        if ($rid == $prod_word_1) {
            var_dump($p->sigil(0));
        } if ($rid == $prod_word_0) {
            var_dump($p->sigil(1));
        }
        break;
    }
    $p->advance();
} while (Parser::ACTION_ACCEPT != $p->action);


The Parle\Lexer class

(PECL parle >= 0.5.1)

简介

Single state lexer class. Lexemes can be defined on the fly. If the particular lexer instance is meant to be used with Parle\Parser, the token IDs need to be taken from there. Otherwise, arbitrary token IDs can be supplied. This lexer can give a certain performance advantage over Parle\RLexer, if no multiple states are required. Note, that Parle\RParser is not compatible with this lexer.

类摘要

Parle\Lexer {
/* Constants */
const int ICASE = 1 ;
const int DOT_NOT_LF = 2 ;
const int DOT_NOT_CRLF = 4 ;
const int SKIP_WS = 8 ;
const int MATCH_ZERO_LEN = 16 ;
/* 属性 */
public bool $bol = false ;
public int $flags = 0 ;
public int $state = 0 ;
public int $marker = 0 ;
public int $cursor = 0 ;
/* 方法 */
public advance ( ) : void
public build ( ) : void
public callout ( int $id , callable $callback ) : void
public consume ( string $data ) : void
public dump ( ) : void
public getToken ( ) : Parle\Token
public insertMacro ( string $name , string $regex ) : void
public push ( string $regex , int $id ) : void
public reset ( int $pos ) : void
}

预定义常量

Parle\Lexer::ICASE

Parle\Lexer::DOT_NOT_LF

Parle\Lexer::DOT_NOT_CRLF

Parle\Lexer::SKIP_WS

Parle\Lexer::MATCH_ZERO_LEN

属性

bol

Start of input flag.

flags

Lexer flags.

state

Current lexer state, readonly.

marker

Position of the latest token match, readonly.

cursor

Current input offset, readonly.

Table of Contents

  • Parle\Lexer::advance — Process next lexer rule
  • Parle\Lexer::build — Finalize the lexer rule set
  • Parle\Lexer::callout — Define token callback
  • Parle\Lexer::consume — Pass the data for processing
  • Parle\Lexer::dump — Dump the state machine
  • Parle\Lexer::getToken — Retrieve the current token
  • Parle\Lexer::insertMacro — Insert regex macro
  • Parle\Lexer::push — Add a lexer rule
  • Parle\Lexer::reset — Reset lexer


Process next lexer rule

  • ? Parle\Lexer
  • Parle\Lexer::build ?
  • PHP Manual
  • Parle\Lexer
  • Process next lexer rule

Parle\Lexer::advance

(PECL parle >= 0.5.1)

Parle\Lexer::advance — Process next lexer rule

说明

public Parle\Lexer::advance ( ) : void

Processes the next rule and prepares the resulting token data.

参数

此函数没有参数。

返回值

没有返回值。


Finalize the lexer rule set

  • ? Parle\Lexer::advance
  • Parle\Lexer::callout ?
  • PHP Manual
  • Parle\Lexer
  • Finalize the lexer rule set

Parle\Lexer::build

(PECL parle >= 0.5.1)

Parle\Lexer::build — Finalize the lexer rule set

说明

public Parle\Lexer::build ( ) : void

Rules, previously added with Parle\Lexer::push() are finalized. This method call has to be done after all the necessary rules was pushed. The rule set becomes read only. The lexing can begin.

参数

此函数没有参数。

返回值

没有返回值。


Define token callback

  • ? Parle\Lexer::build
  • Parle\Lexer::consume ?
  • PHP Manual
  • Parle\Lexer
  • Define token callback

Parle\Lexer::callout

(PECL parle >= 0.7.2)

Parle\Lexer::callout — Define token callback

说明

public Parle\Lexer::callout ( int $id , callable $callback ) : void

Define a callback to be invoked once lexer encounters a particular token.

参数

id

Token id.

callback

Callable to be invoked. The callable doesn't receive any arguments and its return value is ignored.

返回值

没有返回值。


Pass the data for processing

  • ? Parle\Lexer::callout
  • Parle\Lexer::dump ?
  • PHP Manual
  • Parle\Lexer
  • Pass the data for processing

Parle\Lexer::consume

(PECL parle >= 0.5.1)

Parle\Lexer::consume — Pass the data for processing

说明

public Parle\Lexer::consume ( string $data ) : void

Consume the data for lexing.

参数

data

Data to be lexed.

返回值

没有返回值。


Dump the state machine

  • ? Parle\Lexer::consume
  • Parle\Lexer::getToken ?
  • PHP Manual
  • Parle\Lexer
  • Dump the state machine

Parle\Lexer::dump

(PECL parle >= 0.5.1)

Parle\Lexer::dump — Dump the state machine

说明

public Parle\Lexer::dump ( ) : void

Dump the current state machine to stdout.

参数

此函数没有参数。

返回值

没有返回值。


Retrieve the current token

  • ? Parle\Lexer::dump
  • Parle\Lexer::insertMacro ?
  • PHP Manual
  • Parle\Lexer
  • Retrieve the current token

Parle\Lexer::getToken

(PECL parle >= 0.5.1)

Parle\Lexer::getToken — Retrieve the current token

说明

public Parle\Lexer::getToken ( ) : Parle\Token

Retrieve the current token.

参数

此函数没有参数。

返回值

Returns an instance of Parle\Token.


Insert regex macro

  • ? Parle\Lexer::getToken
  • Parle\Lexer::push ?
  • PHP Manual
  • Parle\Lexer
  • Insert regex macro

Parle\Lexer::insertMacro

(PECL parle >= 0.5.1)

Parle\Lexer::insertMacro — Insert regex macro

说明

public Parle\Lexer::insertMacro ( string $name , string $regex ) : void

Insert a regex macro, that can be later used as a shortcut and included in other regular expressions.

参数

name

Name of the macros.

regex

Regular expression.

返回值

没有返回值。


Add a lexer rule

  • ? Parle\Lexer::insertMacro
  • Parle\Lexer::reset ?
  • PHP Manual
  • Parle\Lexer
  • Add a lexer rule

Parle\Lexer::push

(PECL parle >= 0.5.1)

Parle\Lexer::push — Add a lexer rule

说明

public Parle\Lexer::push ( string $regex , int $id ) : void

Push a pattern for lexeme recognition.

参数

regex

Regular expression used for token matching.

id

Token id. If the lexer instance is meant to be used standalone, this can be an arbitrary number. If the lexer instance is going to be passed to the parser, it has to be an id returned by Parle\Parser::tokenid().

返回值

没有返回值。


Reset lexer

  • ? Parle\Lexer::push
  • Parle\RLexer ?
  • PHP Manual
  • Parle\Lexer
  • Reset lexer

Parle\Lexer::reset

(PECL parle >= 0.7.1)

Parle\Lexer::reset — Reset lexer

说明

public Parle\Lexer::reset ( int $pos ) : void

Reset lexing optionally supplying the desired offset.

参数

pos

Reset position.

返回值

没有返回值。


The Parle\RLexer class

(PECL parle >= 0.5.1)

简介

Multistate lexer class. Lexemes can be defined on the fly. If the particular lexer instance is meant to be used with Parle\RParser, the token IDs need to be taken from there. Otherwise, arbitrary token IDs can be supplied. Note, that Parle\Parser is not compatible with this lexer.

类摘要

Parle\RLexer {
/* Constants */
const int ICASE = 1 ;
const int DOT_NOT_LF = 2 ;
const int DOT_NOT_CRLF = 4 ;
const int SKIP_WS = 8 ;
const int MATCH_ZERO_LEN = 16 ;
/* 属性 */
public bool $bol = false ;
public int $flags = 0 ;
public int $state = 0 ;
public int $marker = 0 ;
public int $cursor = 0 ;
/* 方法 */
public advance ( ) : void
public build ( ) : void
public callout ( int $id , callable $callback ) : void
public consume ( string $data ) : void
public dump ( ) : void
public getToken ( ) : Parle\Token
public insertMacro ( string $name , string $regex ) : void
public push ( string $regex , int $id ) : void
public push ( string $state , string $regex , int $id , string $newState ) : void
public push ( string $state , string $regex , string $newState ) : void
public pushState ( string $state ) : int
public reset ( int $pos ) : void
}

预定义常量

Parle\RLexer::ICASE

Parle\RLexer::DOT_NOT_LF

Parle\RLexer::DOT_NOT_CRLF

Parle\RLexer::SKIP_WS

Parle\RLexer::MATCH_ZERO_LEN

属性

bol

Start of input flag.

flags

Lexer flags.

state

Current lexer state, readonly.

marker

Position of the latest token match, readonly.

cursor

Current input offset, readonly.

Table of Contents

  • Parle\RLexer::advance — Process next lexer rule
  • Parle\RLexer::build — Finalize the lexer rule set
  • Parle\RLexer::callout — Define token callback
  • Parle\RLexer::consume — Pass the data for processing
  • Parle\RLexer::dump — Dump the state machine
  • Parle\RLexer::getToken — Retrieve the current token
  • Parle\RLexer::insertMacro — Insert regex macro
  • Parle\RLexer::push — Add a lexer rule
  • Parle\RLexer::pushState — Push a new start state
  • Parle\RLexer::reset — Reset lexer


Process next lexer rule

  • ? Parle\RLexer
  • Parle\RLexer::build ?
  • PHP Manual
  • Parle\RLexer
  • Process next lexer rule

Parle\RLexer::advance

(PECL parle >= 0.5.1)

Parle\RLexer::advance — Process next lexer rule

说明

public Parle\RLexer::advance ( ) : void

Processes the next rule and prepares the resulting token data.

参数

此函数没有参数。

返回值

没有返回值。


Finalize the lexer rule set

  • ? Parle\RLexer::advance
  • Parle\RLexer::callout ?
  • PHP Manual
  • Parle\RLexer
  • Finalize the lexer rule set

Parle\RLexer::build

(PECL parle >= 0.5.1)

Parle\RLexer::build — Finalize the lexer rule set

说明

public Parle\RLexer::build ( ) : void

Rules, previously added with Parle\RLexer::push() are finalized. This method call has to be done after all the necessary rules was pushed. The rule set becomes read only. The lexing can begin.

参数

此函数没有参数。

返回值

没有返回值。


Define token callback

  • ? Parle\RLexer::build
  • Parle\RLexer::consume ?
  • PHP Manual
  • Parle\RLexer
  • Define token callback

Parle\RLexer::callout

(PECL parle >= 0.7.2)

Parle\RLexer::callout — Define token callback

说明

public Parle\RLexer::callout ( int $id , callable $callback ) : void

Define a callback to be invoked once lexer encounters a particular token.

参数

id

Token id.

callback

Callable to be invoked. The callable doesn't receive any arguments and its return value is ignored.

返回值

没有返回值。


Pass the data for processing

  • ? Parle\RLexer::callout
  • Parle\RLexer::dump ?
  • PHP Manual
  • Parle\RLexer
  • Pass the data for processing

Parle\RLexer::consume

(PECL parle >= 0.5.1)

Parle\RLexer::consume — Pass the data for processing

说明

public Parle\RLexer::consume ( string $data ) : void

Consume the data for lexing.

参数

data

Data to be lexed.

返回值

没有返回值。


Dump the state machine

  • ? Parle\RLexer::consume
  • Parle\RLexer::getToken ?
  • PHP Manual
  • Parle\RLexer
  • Dump the state machine

Parle\RLexer::dump

(PECL parle >= 0.5.1)

Parle\RLexer::dump — Dump the state machine

说明

public Parle\RLexer::dump ( ) : void

Dump the current state machine to stdout.

参数

此函数没有参数。

返回值

没有返回值。


Retrieve the current token

  • ? Parle\RLexer::dump
  • Parle\RLexer::insertMacro ?
  • PHP Manual
  • Parle\RLexer
  • Retrieve the current token

Parle\RLexer::getToken

(PECL parle >= 0.5.1)

Parle\RLexer::getToken — Retrieve the current token

说明

public Parle\RLexer::getToken ( ) : Parle\Token

Retrive the current token.

参数

此函数没有参数。

返回值

Returns an instance of Parle\Token.


Insert regex macro

  • ? Parle\RLexer::getToken
  • Parle\RLexer::push ?
  • PHP Manual
  • Parle\RLexer
  • Insert regex macro

Parle\RLexer::insertMacro

(PECL parle >= 0.5.1)

Parle\RLexer::insertMacro — Insert regex macro

说明

public Parle\RLexer::insertMacro ( string $name , string $regex ) : void

Insert a regex macro, that can be later used as a shortcut and included in other regular expressions.

参数

name

Name of the macros.

regex

Regular expression.

返回值

没有返回值。


Add a lexer rule

  • ? Parle\RLexer::insertMacro
  • Parle\RLexer::pushState ?
  • PHP Manual
  • Parle\RLexer
  • Add a lexer rule

Parle\RLexer::push

(PECL parle >= 0.5.1)

Parle\RLexer::push — Add a lexer rule

说明

public Parle\RLexer::push ( string $regex , int $id ) : void
public Parle\RLexer::push ( string $state , string $regex , int $id , string $newState ) : void
public Parle\RLexer::push ( string $state , string $regex , string $newState ) : void

Push a pattern for lexeme recognition.

A 'start state' and 'exit state' can be specified by using a suitable signature.

参数

regex

Regular expression used for token matching.

id

Token id. If the lexer instance is meant to be used standalone, this can be an arbitrary number. If the lexer instance is going to be passed to the parser, it has to be an id returned by Parle\RParser::tokenid().

state

State name. If '*' is used as start state, then the rule is applied to all lexer states.

newState

New state name, after the rule was applied.

If '.' is specified as the exit state, then the lexer state is unchanged when that rule matches. An exit state with '>' before the name means push. Use the signature without id for either continuation or to start matching, when a continuation or recursion is required.

If '<' is specified as exit state, it means pop. In that case, the signature containing the id can be used to identify the match. Note that even in the case an id is specified, the rule will finish first when all the previous pushes popped.

返回值

没有返回值。


Push a new start state

  • ? Parle\RLexer::push
  • Parle\RLexer::reset ?
  • PHP Manual
  • Parle\RLexer
  • Push a new start state

Parle\RLexer::pushState

(PECL parle >= 0.5.1)

Parle\RLexer::pushState — Push a new start state

说明

public Parle\RLexer::pushState ( string $state ) : int

This lexer type can have more than one state machine. This allows you to lex different tokens depending on context, thus allowing simple parsing to take place. Once a state pushed, it can be used with a suitable Parle\RLexer::push() signature variant.

参数

state

Name of the state.

返回值


Reset lexer

  • ? Parle\RLexer::pushState
  • Parle\Parser ?
  • PHP Manual
  • Parle\RLexer
  • Reset lexer

Parle\RLexer::reset

(PECL parle >= 0.7.1)

Parle\RLexer::reset — Reset lexer

说明

public Parle\RLexer::reset ( int $pos ) : void

Reset lexing optionally supplying the desired offset.

参数

pos

Reset position.

返回值

没有返回值。


The Parle\Parser class

(PECL parle >= 0.5.1)

简介

Parser class. Rules can be defined on the fly. Once finalized, a Parle\Lexer instance is required to deliver the token stream.

类摘要

Parle\Parser {
/* Constants */
const int ACTION_ERROR = 0 ;
const int ACTION_SHIFT = 1 ;
const int ACTION_REDUCE = 2 ;
const int ACTION_GOTO = 3 ;
const int ACTION_ACCEPT = 4 ;
const int ERROR_SYNTAX = 0 ;
const int ERROR_NON_ASSOCIATIVE = 1 ;
const int ERROR_UNKNOWN_TOKEN = 2 ;
/* 属性 */
public int $action = 0 ;
public int $reduceId = 0 ;
/* 方法 */
public advance ( ) : void
public build ( ) : void
public consume ( string $data , Parle\Lexer $lexer ) : void
public dump ( ) : void
public errorInfo ( ) : Parle\ErrorInfo
public left ( string $tok ) : void
public nonassoc ( string $tok ) : void
public precedence ( string $tok ) : void
public push ( string $name , string $rule ) : int
public reset ( int $tokenId = ? ) : void
public right ( string $tok ) : void
public sigil ( int $idx ) : string
public token ( string $tok ) : void
public tokenId ( string $tok ) : int
public trace ( ) : string
public validate ( string $data , Parle\Lexer $lexer ) : bool
}

预定义常量

Parle\Parser::ACTION_ERROR

Parle\Parser::ACTION_SHIFT

Parle\Parser::ACTION_REDUCE

Parle\Parser::ACTION_GOTO

Parle\Parser::ACTION_ACCEPT

Parle\Parser::ERROR_SYNTAX

Parle\Parser::ERROR_NON_ASSOCIATIVE

Parle\Parser::ERROR_UNKNOWN_TOKEN

属性

action

Current parser action that matches one of the action class constants, readonly.

reduceId

Grammar rule id just processed in the reduce action. The value corresponds either to a token or to a production id. Readonly.

Table of Contents

  • Parle\Parser::advance — Process next parser rule
  • Parle\Parser::build — Finalize the grammar rules
  • Parle\Parser::consume — Consume the data for processing
  • Parle\Parser::dump — Dump the grammar
  • Parle\Parser::errorInfo — Retrieve the error information
  • Parle\Parser::left — Declare a token with left-associativity
  • Parle\Parser::nonassoc — Declare a token with no associativity
  • Parle\Parser::precedence — Declare a precedence rule
  • Parle\Parser::push — Add a grammar rule
  • Parle\Parser::reset — Reset parser state
  • Parle\Parser::right — Declare a token with right-associativity
  • Parle\Parser::sigil — Retrieve a matching part of a rule
  • Parle\Parser::token — Declare a token
  • Parle\Parser::tokenId — Get token id
  • Parle\Parser::trace — Trace the parser operation
  • Parle\Parser::validate — Validate input


Process next parser rule

  • ? Parle\Parser
  • Parle\Parser::build ?
  • PHP Manual
  • Parle\Parser
  • Process next parser rule

Parle\Parser::advance

(PECL parle >= 0.5.1)

Parle\Parser::advance — Process next parser rule

说明

public Parle\Parser::advance ( ) : void

Process next parser rule.

参数

此函数没有参数。

返回值

没有返回值。


Finalize the grammar rules

  • ? Parle\Parser::advance
  • Parle\Parser::consume ?
  • PHP Manual
  • Parle\Parser
  • Finalize the grammar rules

Parle\Parser::build

(PECL parle >= 0.5.1)

Parle\Parser::build — Finalize the grammar rules

说明

public Parle\Parser::build ( ) : void

Any tokens and grammar rules previously added are finalized. The rule set becomes readonly and the parser is ready to start.

参数

此函数没有参数。

返回值

没有返回值。


Consume the data for processing

  • ? Parle\Parser::build
  • Parle\Parser::dump ?
  • PHP Manual
  • Parle\Parser
  • Consume the data for processing

Parle\Parser::consume

(PECL parle >= 0.5.1)

Parle\Parser::consume — Consume the data for processing

说明

public Parle\Parser::consume ( string $data , Parle\Lexer $lexer ) : void

Consume the data for parsing.

参数

data

Data to be parsed.

lexer

A lexer object containing the lexing rules prepared for the particular grammar.

返回值

没有返回值。


Dump the grammar

  • ? Parle\Parser::consume
  • Parle\Parser::errorInfo ?
  • PHP Manual
  • Parle\Parser
  • Dump the grammar

Parle\Parser::dump

(PECL parle >= 0.5.1)

Parle\Parser::dump — Dump the grammar

说明

public Parle\Parser::dump ( ) : void

Dump the current grammar to stdout.

参数

此函数没有参数。

返回值

没有返回值。


Retrieve the error information

  • ? Parle\Parser::dump
  • Parle\Parser::left ?
  • PHP Manual
  • Parle\Parser
  • Retrieve the error information

Parle\Parser::errorInfo

(PECL parle >= 0.5.1)

Parle\Parser::errorInfo — Retrieve the error information

说明

public Parle\Parser::errorInfo ( ) : Parle\ErrorInfo

Retrieve the error information in case Parle\Parser::action() returned the error action.

参数

此函数没有参数。

返回值

Returns an instance of Parle\ErrorInfo.


Declare a token with left-associativity

  • ? Parle\Parser::errorInfo
  • Parle\Parser::nonassoc ?
  • PHP Manual
  • Parle\Parser
  • Declare a token with left-associativity

Parle\Parser::left

(PECL parle >= 0.5.1)

Parle\Parser::left — Declare a token with left-associativity

说明

public Parle\Parser::left ( string $tok ) : void

Declare a terminal with left associativity.

参数

tok

Token name.

返回值

没有返回值。


Declare a token with no associativity

  • ? Parle\Parser::left
  • Parle\Parser::precedence ?
  • PHP Manual
  • Parle\Parser
  • Declare a token with no associativity

Parle\Parser::nonassoc

(PECL parle >= 0.5.1)

Parle\Parser::nonassoc — Declare a token with no associativity

说明

public Parle\Parser::nonassoc ( string $tok ) : void

Declare a terminal, that cannot appear more than once in the row.

参数

tok

Token name.

返回值

没有返回值。


Declare a precedence rule

  • ? Parle\Parser::nonassoc
  • Parle\Parser::push ?
  • PHP Manual
  • Parle\Parser
  • Declare a precedence rule

Parle\Parser::precedence

(PECL parle >= 0.5.1)

Parle\Parser::precedence — Declare a precedence rule

说明

public Parle\Parser::precedence ( string $tok ) : void

Declares a precedence rule for a fictitious terminal symbol. This rule can be later used in the specific grammar rules.

参数

tok

Token name.

返回值

没有返回值。


Add a grammar rule

  • ? Parle\Parser::precedence
  • Parle\Parser::reset ?
  • PHP Manual
  • Parle\Parser
  • Add a grammar rule

Parle\Parser::push

(PECL parle >= 0.5.1)

Parle\Parser::push — Add a grammar rule

说明

public Parle\Parser::push ( string $name , string $rule ) : int

Push a grammar rule. The production id returned can be used later in the parsing process to identify the rule matched.

参数

name

Rule name.

rule

The rule to be added. The syntax is Bison compatible.

返回值

Returns int representing the rule index.


Reset parser state

  • ? Parle\Parser::push
  • Parle\Parser::right ?
  • PHP Manual
  • Parle\Parser
  • Reset parser state

Parle\Parser::reset

(PECL parle >= 0.7.1)

Parle\Parser::reset — Reset parser state

说明

public Parle\Parser::reset ( int $tokenId = ? ) : void

Reset parser state using the given token id.

参数

tokenId

Token id.

返回值

没有返回值。


Declare a token with right-associativity

  • ? Parle\Parser::reset
  • Parle\Parser::sigil ?
  • PHP Manual
  • Parle\Parser
  • Declare a token with right-associativity

Parle\Parser::right

(PECL parle >= 0.5.1)

Parle\Parser::right — Declare a token with right-associativity

说明

public Parle\Parser::right ( string $tok ) : void

Declare a terminal with right associativity.

参数

tok

Token name.

返回值

没有返回值。


Retrieve a matching part of a rule

  • ? Parle\Parser::right
  • Parle\Parser::token ?
  • PHP Manual
  • Parle\Parser
  • Retrieve a matching part of a rule

Parle\Parser::sigil

(PECL parle >= 0.5.1)

Parle\Parser::sigil — Retrieve a matching part of a rule

说明

public Parle\Parser::sigil ( int $idx ) : string

Retrieve a part of the match by a rule. This method is equivalent to the pseudo variable functionality in Bison.

参数

idx

Match index, zero based.

返回值

Returns a string with the matched part.


Declare a token

  • ? Parle\Parser::sigil
  • Parle\Parser::tokenId ?
  • PHP Manual
  • Parle\Parser
  • Declare a token

Parle\Parser::token

(PECL parle >= 0.5.1)

Parle\Parser::token — Declare a token

说明

public Parle\Parser::token ( string $tok ) : void

Declare a terminal to be used in the grammar.

参数

tok

Token name.

返回值

没有返回值。


Get token id

  • ? Parle\Parser::token
  • Parle\Parser::trace ?
  • PHP Manual
  • Parle\Parser
  • Get token id

Parle\Parser::tokenId

(PECL parle >= 0.5.1)

Parle\Parser::tokenId — Get token id

说明

public Parle\Parser::tokenId ( string $tok ) : int

Retrieve the id of the named token.

参数

tok

Name of the token as used in Parle\Parser::token().

返回值

Returns int representing the token id.


Trace the parser operation

  • ? Parle\Parser::tokenId
  • Parle\Parser::validate ?
  • PHP Manual
  • Parle\Parser
  • Trace the parser operation

Parle\Parser::trace

(PECL parle >= 0.5.1)

Parle\Parser::trace — Trace the parser operation

说明

public Parle\Parser::trace ( ) : string

Retrieve the current parser operation description. This can be especially useful for studying the parser and to optimize the grammar.

参数

此函数没有参数。

返回值

Returns a string with the trace information.


Validate input

  • ? Parle\Parser::trace
  • Parle\RParser ?
  • PHP Manual
  • Parle\Parser
  • Validate input

Parle\Parser::validate

(PECL parle >= 0.5.1)

Parle\Parser::validate — Validate input

说明

public Parle\Parser::validate ( string $data , Parle\Lexer $lexer ) : bool

Validate an input string. The string is parsed internally, thus this method is useful for the quick input validation.

参数

data

String to be validated.

lexer

A lexer object containing the lexing rules prepared for the particular grammar.

返回值

Returns bool witnessing whether the input chimes or not with the defined rules.


The Parle\RParser class

(PECL parle >= 0.7.0)

简介

Parser class. Rules can be defined on the fly. Once finalized, a Parle\RLexer instance is required to deliver the token stream.

类摘要

Parle\RParser {
/* Constants */
const int ACTION_ERROR = 0 ;
const int ACTION_SHIFT = 1 ;
const int ACTION_REDUCE = 2 ;
const int ACTION_GOTO = 3 ;
const int ACTION_ACCEPT = 4 ;
const int ERROR_SYNTAX = 0 ;
const int ERROR_NON_ASSOCIATIVE = 1 ;
const int ERROR_UNKNOWN_TOKEN = 2 ;
/* 属性 */
public int $action = 0 ;
public int $reduceId = 0 ;
/* 方法 */
public advance ( ) : void
public build ( ) : void
public consume ( string $data , Parle\RLexer $rlexer ) : void
public dump ( ) : void
public errorInfo ( ) : Parle\ErrorInfo
public left ( string $tok ) : void
public nonassoc ( string $tok ) : void
public precedence ( string $tok ) : void
public push ( string $name , string $rule ) : int
public reset ( int $tokenId = ? ) : void
public right ( string $tok ) : void
public sigil ( int $idx = ? ) : string
public token ( string $tok ) : void
public tokenId ( string $tok ) : int
public trace ( ) : string
public validate ( string $data , Parle\RLexer $lexer ) : bool
}

预定义常量

Parle\RParser::ACTION_ERROR

Parle\RParser::ACTION_SHIFT

Parle\RParser::ACTION_REDUCE

Parle\RParser::ACTION_GOTO

Parle\RParser::ACTION_ACCEPT

Parle\RParser::ERROR_SYNTAX

Parle\RParser::ERROR_NON_ASSOCIATIVE

Parle\RParser::ERROR_UNKNOWN_TOKEN

属性

action

Current parser action that matches one of the action class constants, readonly.

reduceId

Grammar rule id just processed in the reduce action. The value corresponds either to a token or to a production id. Readonly.

Table of Contents

  • Parle\RParser::advance — Process next parser rule
  • Parle\RParser::build — Finalize the grammar rules
  • Parle\RParser::consume — Consume the data for processing
  • Parle\RParser::dump — Dump the grammar
  • Parle\RParser::errorInfo — Retrieve the error information
  • Parle\RParser::left — Declare a token with left-associativity
  • Parle\RParser::nonassoc — Declare a token with no associativity
  • Parle\RParser::precedence — Declare a precedence rule
  • Parle\RParser::push — Add a grammar rule
  • Parle\RParser::reset — Reset parser state
  • Parle\RParser::right — Declare a token with right-associativity
  • Parle\RParser::sigil — Retrieve a matching part of a rule
  • Parle\RParser::token — Declare a token
  • Parle\RParser::tokenId — Get token id
  • Parle\RParser::trace — Trace the parser operation
  • Parle\RParser::validate — Validate input


Process next parser rule

  • ? Parle\RParser
  • Parle\RParser::build ?
  • PHP Manual
  • Parle\RParser
  • Process next parser rule

Parle\RParser::advance

(PECL parle >= 0.7.0)

Parle\RParser::advance — Process next parser rule

说明

public Parle\RParser::advance ( ) : void

Prosess next parser rule.

参数

此函数没有参数。

返回值

没有返回值。


Finalize the grammar rules

  • ? Parle\RParser::advance
  • Parle\RParser::consume ?
  • PHP Manual
  • Parle\RParser
  • Finalize the grammar rules

Parle\RParser::build

(PECL parle >= 0.7.0)

Parle\RParser::build — Finalize the grammar rules

说明

public Parle\RParser::build ( ) : void

Any tokens and grammar rules previously added are finalized. The rule set becomes readonly and the parser is ready to start.

参数

此函数没有参数。

返回值

没有返回值。


Consume the data for processing

  • ? Parle\RParser::build
  • Parle\RParser::dump ?
  • PHP Manual
  • Parle\RParser
  • Consume the data for processing

Parle\RParser::consume

(PECL parle >= 0.7.0)

Parle\RParser::consume — Consume the data for processing

说明

public Parle\RParser::consume ( string $data , Parle\RLexer $rlexer ) : void

Consume the data for parsing.

参数

data

Data to be parsed.

lexer

A lexer object containing the lexing rules prepared for the particular grammar.

返回值

没有返回值。


Dump the grammar

  • ? Parle\RParser::consume
  • Parle\RParser::errorInfo ?
  • PHP Manual
  • Parle\RParser
  • Dump the grammar

Parle\RParser::dump

(PECL parle >= 0.7.0)

Parle\RParser::dump — Dump the grammar

说明

public Parle\RParser::dump ( ) : void

Dump the current grammar to stdout.

参数

此函数没有参数。

返回值

没有返回值。


Retrieve the error information

  • ? Parle\RParser::dump
  • Parle\RParser::left ?
  • PHP Manual
  • Parle\RParser
  • Retrieve the error information

Parle\RParser::errorInfo

(PECL parle >= 0.7.0)

Parle\RParser::errorInfo — Retrieve the error information

说明

public Parle\RParser::errorInfo ( ) : Parle\ErrorInfo

Retrieve the error information in case Parle\RParser::action() returned the error action.

参数

此函数没有参数。

返回值

Returns an instance of Parle\ErrorInfo.


Declare a token with left-associativity

  • ? Parle\RParser::errorInfo
  • Parle\RParser::nonassoc ?
  • PHP Manual
  • Parle\RParser
  • Declare a token with left-associativity

Parle\RParser::left

(PECL parle >= 0.7.0)

Parle\RParser::left — Declare a token with left-associativity

说明

public Parle\RParser::left ( string $tok ) : void

Declare a terminal with left associativity.

参数

tok

Token name.

返回值

没有返回值。


Declare a token with no associativity

  • ? Parle\RParser::left
  • Parle\RParser::precedence ?
  • PHP Manual
  • Parle\RParser
  • Declare a token with no associativity

Parle\RParser::nonassoc

(PECL parle >= 0.7.0)

Parle\RParser::nonassoc — Declare a token with no associativity

说明

public Parle\RParser::nonassoc ( string $tok ) : void

Declare a terminal, that cannot appear more than once in the row.

参数

tok

Token name.

返回值

没有返回值。


Declare a precedence rule

  • ? Parle\RParser::nonassoc
  • Parle\RParser::push ?
  • PHP Manual
  • Parle\RParser
  • Declare a precedence rule

Parle\RParser::precedence

(PECL parle >= 0.7.0)

Parle\RParser::precedence — Declare a precedence rule

说明

public Parle\RParser::precedence ( string $tok ) : void

Declares a precedence rule for a fictious terminal symbol. This rule can be later used in the specific grammar rules.

参数

tok

Token name.

返回值

没有返回值。


Add a grammar rule

  • ? Parle\RParser::precedence
  • Parle\RParser::reset ?
  • PHP Manual
  • Parle\RParser
  • Add a grammar rule

Parle\RParser::push

(PECL parle >= 0.7.0)

Parle\RParser::push — Add a grammar rule

说明

public Parle\RParser::push ( string $name , string $rule ) : int

Push a grammar rule. The production id returned can be used later in the parsing process to identify the rule matched.

参数

name

Rule name.

rule

The rule to be added. The syntax is Bison compatible.

返回值

Returns int representing the rule index.


Reset parser state

  • ? Parle\RParser::push
  • Parle\RParser::right ?
  • PHP Manual
  • Parle\RParser
  • Reset parser state

Parle\RParser::reset

(PECL parle >= 0.7.1)

Parle\RParser::reset — Reset parser state

说明

public Parle\RParser::reset ( int $tokenId = ? ) : void

Reset parser state using the given token id.

参数

tokenId

Token id.

返回值

没有返回值。


Declare a token with right-associativity

  • ? Parle\RParser::reset
  • Parle\RParser::sigil ?
  • PHP Manual
  • Parle\RParser
  • Declare a token with right-associativity

Parle\RParser::right

(PECL parle >= 0.7.0)

Parle\RParser::right — Declare a token with right-associativity

说明

public Parle\RParser::right ( string $tok ) : void

Declare a terminal with right associativity.

参数

tok

Token name.

返回值

没有返回值。


Retrieve a matching part of a rule

  • ? Parle\RParser::right
  • Parle\RParser::token ?
  • PHP Manual
  • Parle\RParser
  • Retrieve a matching part of a rule

Parle\RParser::sigil

(PECL parle >= 0.7.0)

Parle\RParser::sigil — Retrieve a matching part of a rule

说明

public Parle\RParser::sigil ( int $idx = ? ) : string

Retrieve a part of the match by a rule. This method is equivalent to the pseudo variable functionality in Bison.

参数

idx

Match index, zero based.

返回值

Returns a string with the matched part.


Declare a token

  • ? Parle\RParser::sigil
  • Parle\RParser::tokenId ?
  • PHP Manual
  • Parle\RParser
  • Declare a token

Parle\RParser::token

(PECL parle >= 0.7.0)

Parle\RParser::token — Declare a token

说明

public Parle\RParser::token ( string $tok ) : void

Declare a terminal to be used in the grammar.

参数

tok

Token name.

返回值

没有返回值。


Get token id

  • ? Parle\RParser::token
  • Parle\RParser::trace ?
  • PHP Manual
  • Parle\RParser
  • Get token id

Parle\RParser::tokenId

(PECL parle >= 0.7.0)

Parle\RParser::tokenId — Get token id

说明

public Parle\RParser::tokenId ( string $tok ) : int

Retrieve the id of the named token.

参数

tok

Name of the token as used in Parle\RParser::token().

返回值

Returns int representing the token id.


Trace the parser operation

  • ? Parle\RParser::tokenId
  • Parle\RParser::validate ?
  • PHP Manual
  • Parle\RParser
  • Trace the parser operation

Parle\RParser::trace

(PECL parle >= 0.7.0)

Parle\RParser::trace — Trace the parser operation

说明

public Parle\RParser::trace ( ) : string

Retrieve the current parser operation description. This can be especially useful to study the parser and to optimize the grammar.

参数

此函数没有参数。

返回值

Returns a string with the trace information.


Validate input

  • ? Parle\RParser::trace
  • Parle\Stack ?
  • PHP Manual
  • Parle\RParser
  • Validate input

Parle\RParser::validate

(PECL parle >= 0.7.0)

Parle\RParser::validate — Validate input

说明

public Parle\RParser::validate ( string $data , Parle\RLexer $lexer ) : bool

Validate an input string. The string is parsed internally, thus this method is useful for the quick input validation.

参数

data

String to be validated.

lexer

A lexer object containing the lexing rules prepared for the particular grammar.

返回值

Returns bool whitnessing whether the input chimes or not with the defined rules.


The Parle\Stack class

(PECL parle >= 0.7.0)

简介

Parle\Stack is a LIFO stack. The elements are inserted and removed only from one end.

类摘要

Parle\Stack {
/* 属性 */
public bool $empty = true ;
public int $size = 0 ;
public mixed $top ;
/* 方法 */
public pop ( ) : void
public push ( mixed $item ) : void
}

属性

empty

Whether the stack is empty, readonly.

size

Stack size, readonly.

top

Element on the top of the stack.

Table of Contents

  • Parle\Stack::pop — Pop an item from the stack
  • Parle\Stack::push — Push an item into the stack


Pop an item from the stack

  • ? Parle\Stack
  • Parle\Stack::push ?
  • PHP Manual
  • Parle\Stack
  • Pop an item from the stack

Parle\Stack::pop

(PECL parle >= 0.5.1)

Parle\Stack::pop — Pop an item from the stack

说明

public Parle\Stack::pop ( ) : void

参数

此函数没有参数。

返回值

没有返回值。


Push an item into the stack

  • ? Parle\Stack::pop
  • Parle\Token ?
  • PHP Manual
  • Parle\Stack
  • Push an item into the stack

Parle\Stack::push

(PECL parle >= 0.5.1)

Parle\Stack::push — Push an item into the stack

说明

public Parle\Stack::push ( mixed $item ) : void

参数

item

Variable to be pushed.

返回值

没有返回值。


The Parle\Token class

(PECL parle >= 0.5.2)

简介

This class represents a token. Lexer returns instances of this class.

类摘要

Parle\Token {
/* Constants */
const int EOI = 0 ;
const int UNKNOWN = -1 ;
const int SKIP = -2 ;
/* 属性 */
public int $id ;
public string $value ;
/* 方法 */
}

属性

id

Token id.

value

Token value.

预定义常量

Parle\Token::EOI

End of input token id.

Parle\Token::UNKNOWN

Unknown token id.

Parle\Token::SKIP

Skip token id.


The Parle\ErrorInfo class

(PECL parle >= 0.5.2)

简介

The class represents detailed error information as supplied by Parle\Parser::errorInfo()

类摘要

Parle\ErrorInfo {
/* 属性 */
public int $id ;
public int $position ;
public mixed $token ;
/* 方法 */
}

属性

id

Error id.

position

Position in the input, where the error occurred.

token

If applicable - the Parle\Token related to the error, otherwise null.


The Parle\LexerException class

(PECL parle >= 0.5.1)

简介

类摘要

Parle\LexerException extends Exception implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


The Parle\ParserException class

(PECL parle >= 0.5.1)

简介

类摘要

Parle\ParserException extends Exception implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


正则表达式(兼容 Perl)

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • PCRE模式
    • PCRE 正则语法 — 模式语法
    • 正则表达式模式中可用的模式修饰符 — 模式修饰符
    • 与 perl 的不同之处
    • 与 POSIX 正则表达式的不同
  • PCRE 函数
    • preg_filter — 执行一个正则表达式搜索和替换
    • preg_grep — 返回匹配模式的数组条目
    • preg_last_error_msg — Returns the error message of the last PCRE regex execution
    • preg_last_error — 返回最后一个PCRE正则执行产生的错误代码
    • preg_match_all — 执行一个全局正则表达式匹配
    • preg_match — 执行匹配正则表达式
    • preg_quote — 转义正则表达式字符
    • preg_replace_callback_array — Perform a regular expression search and replace using callbacks
    • preg_replace_callback — 执行一个正则表达式搜索并且使用一个回调进行替换
    • preg_replace — 执行一个正则表达式的搜索和替换
    • preg_split — 通过一个正则表达式分隔字符串


简介

这些函数中使用的模式语法非常类似 perl。表达式必须用分隔符闭合，比如一个正斜杠(/)。 分隔符可以使任意非字母数字，除反斜杠(\)和空字节之外的非空白 ascii 字符。 如果分隔符 在表达式中使用，需要使用反斜线进行转义。自php 4.0.4开始，可以使用 perl 样式的()、 {}、 [] 以及 <> 作为分隔符。 更详细的解释参见模式语法。

结束分隔符后面可以紧跟模式修饰符来影响匹配效果。 参见模式修饰符。

PHP也支持使用 POSIX 扩展正则表达式函数 的 POSIX 扩展语法的正则表达式。

Note:

这个扩展维护了一个已编译正则表达式的全局线程化缓存(最大4096)。

Warning

你应该知道一些 PCRE 的限制。阅读» http://www.pcre.org/pcre.txt 获取更详细信息。

PCRE 库是一个实现了与 perl 5 在语法和语义上略有差异(详见下文)的正则表达式模式匹配功能的函数集。 当前的实现对应于 perl 5.005。


安装

PCRE 是 PHP 核心扩展，所以总是启用的。 默认情况下，该扩展使用内置的 PCRE library。或者，也可以通过指定 configure 选项 --with-pcre-regex=DIR 设置外部 PCRE library 目录，DIR 是 PCRE 的 include 和 library 文件位置。 PHP 5.6/7.0 推荐使用 PCRE 8.10 或更高版本。

PHP 7.0.0 起 PCRE 默认支持 JIT（just-in-time）编译技术，PHP 7.0.12 起可以通过 --without-pcre-jit 禁用 PCRE 的 JIT 功能。

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。

Note:

PHP 5.3.0 的之前版本，可通过 --without-pcre-regex 配置选项禁用此扩展。

PCRE 是一个活跃的项目，作为它的一个演变，PHP功能依赖于它。 php 文档的某些部分 可能会过期, 因为它可能不包括 PCRE 提供的一些新功能. 关于修正的清单，请查阅 » PCRE library changelog， 下面是绑定的 PCRE 库的历史记录：

绑定 PCRE 库升级历史
PHP 版本 | Updated PCRE 版本 | Notes
7.0.3 / 5.6.18 / 5.5.32 | 8.38 | 参见 CVE-2015-8383、 CVE-2015-8386、 CVE-2015-8387、 CVE-2015-8389、 CVE-2015-8390、 CVE-2015-8391、 CVE-2015-8393、 CVE-2015-8394
7.0.0 / 5.6.9 / 5.5.26 / 5.4.41 | 8.37 | See CVE-2015-2325, CVE-2015-2326
5.6.0 / 5.5.10 | 8.34 |
5.5.0 / 5.4.14 / 5.3.24 | 8.32 |
5.4.9 / 5.3.19 | 8.31 |
5.3.7 | 8.12 |
5.3.6 | 8.11 |
5.3.4 | 8.10 |
5.3.3 / 5.2.14 | 8.02 |
5.3.2 | 8.00 |
5.3.0 / 5.2.13 | 7.9 |
5.2.7 | 7.8 |
5.2.6 | 7.6 |
5.2.5 | 7.3 |
5.2.4 | 7.2 |
5.2.2 | 7.0 |
5.2.0 | 6.7 |
5.1.3 | 6.6 |
5.1.0 | 6.2 |
5.0.5 | 5.0 |
5.0.0 | 4.5 |
4.4.7 | 7.7 |


运行时配置

这些函数的行为受 php.ini 中的设置影响。

PCRE配置选项
名字 | 默认 | 可修改范围 | 更新日志
pcre.backtrack_limit | "100000" | PHP_INI_ALL | php 5.2.0 起可用。
pcre.recursion_limit | "100000" | PHP_INI_ALL | php 5.2.0 起可用。
pcre.jit | "1" | PHP_INI_ALL | PHP 7.0.0 起可用
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

pcre.backtrack_limit int

PCRE的回溯限制.

pcre.recursion_limit int

PCRE的递归限制. 请注意, 如果 讲这个值设置为一个很大的数字, 你可能会消耗掉 所有的进程可用堆栈, 最终导致php崩溃(直到达到系统限制的堆栈大小).

pcre.jit bool

是否使用 PCRE 的 JIT 编译.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

PREG 常量
常量 | 描述 | 自哪个版本起
PREG_PATTERN_ORDER | 结果按照"规则"排序，仅用于 preg_match_all()， 即 $matches[0] 是完整规则的匹配结果， $matches[1] 是第一个子组匹配的结果，等等。 | since
PREG_SET_ORDER | 结果按照"集合"排序，仅用于preg_match_all()， 即 $matches[0] 保存第一次匹配结果的所有结果(包含子组)信息, $matches[1] 保存第二次的结果信息，等等。 |
PREG_OFFSET_CAPTURE | 查看 PREG_SPLIT_OFFSET_CAPTURE 的描述。 | 4.3.0
PREG_SPLIT_NO_EMPTY | 这个标记告诉 preg_split() 仅返回非空部分。 |
PREG_SPLIT_DELIM_CAPTURE | 这个标记告诉 preg_split() 同时捕获括号表达式匹配到的内容。 | 4.0.5
PREG_SPLIT_OFFSET_CAPTURE | 如果设置了这个标记，每次出现的匹配子串的偏移量也会被返回。注意，这会改变返回数组中的值， 每个元素都是由匹配子串作为第 0 个元素，它相对目标字符串的偏移量作为第 1 个元素的数组。这个 标记只能用于 preg_split()。 | 4.3.0
PREG_UNMATCHED_AS_NULL | This flag tells preg_match() and preg_match_all() to include unmatched subpatterns in $matches as null values. Without this flag, unmatched subpatterns are reported as empty strings, as if they were empty matches. Setting this flag allows to distinguish between these two cases. | 7.2.0
PREG_NO_ERROR | 没有匹配错误时调用 preg_last_error() 返回。 | 5.2.0
PREG_INTERNAL_ERROR | 如果有 PCRE 内部错误时调用 preg_last_error() 返回。 | 5.2.0
PREG_BACKTRACK_LIMIT_ERROR | 如果调用回溯限制超出， 调用preg_last_error()时返回。 | 5.2.0
PREG_RECURSION_LIMIT_ERROR | 如果递归限制超出， 调用preg_last_error()时返回。 | 5.2.0
PREG_BAD_UTF8_ERROR | 如果最后一个错误时由于异常的utf-8数据(仅在运行在 UTF-8 模式正则表达式下可用)。 导致的，调用preg_last_error()返回。 | 5.2.0
PREG_BAD_UTF8_OFFSET_ERROR | 如果偏移量与合法的 UTF-8 代码不匹配(仅在运行在 UTF-8 模式 正则表达式下可用)。 调用 preg_last_error() 返回。 | 5.3.0
PREG_JIT_STACKLIMIT_ERROR | 当 PCRE 函数因 JIT 栈空间限制而失败，preg_last_error() 就会返回此常量。 | 7.0.0
PCRE_VERSION | PCRE版本号和发布日期(比如： "7.0 18-Dec-2006")。 | 5.2.4


范例

Example #1 合法模式示例

  • /<\/\w+>/
  • |(\d{3})-\d+|Sm
  • /^(?i)php[34]/
  • {^\s+(\s+)?$}

Example #2 非法模式示例

  • /href='(.*)' - 缺失结束分隔符
  • /\w+\s*\w+/J - 未知模式修饰符"J"
  • 1-\d3-\d3-\d4| - 缺失开始分隔符


PCRE模式

Table of Contents

  • PCRE 正则语法
  • 正则表达式模式中可用的模式修饰符
  • 与 perl 的不同之处
  • 与 POSIX 正则表达式的不同


模式语法

Table of Contents

  • 简介
  • 分隔符
  • 元字符
  • 转义序列(反斜线)
  • Unicode字符属性
  • 锚
  • 句点
  • 字符类(方括号)
  • 可选路径(|)
  • 内部选项设置
  • 子组(子模式)
  • 重复/量词
  • 后向引用
  • 断言
  • 一次性子组
  • 条件子组
  • 注释
  • 递归模式
  • 性能


简介

下面描述的是 PCRE 支持的正则表达式语法和语义。正则表达式在 perl 的文档 和另外一些书籍中也有讨论, 其中一些会有丰富的示例。O'Reilly(ISBN 1-56592-257-3) 出版的 Jeffrey Friedl 的《精通正则表达式》一书非常详细的讨论了这些内容。 这里的描述仅作为一个参考手册。

正则表达式是一个从左到右匹配目标字符串的模式。大多数字符自身就代表一个匹配 它们自身的模式。 作为一个简单的例子，模式 The quick brown fox 匹配目标字符串中与其相同的部分。


分隔符

当使用 PCRE 函数的时候，模式需要由分隔符闭合包裹。分隔符可以使任意非字母数字、非反斜线、非空白字符。

经常使用的分隔符是正斜线(/)、hash符号(#) 以及取反符号(~)。下面的例子都是使用合法分隔符的模式。

/foo bar/
#^[^0-9]$#
+php+
%[a-zA-Z0-9_-]%

如果分隔符需要在模式内进行匹配，它必须使用反斜线进行转义。如果分隔符经常在 模式内出现， 一个更好的选择就是是用其他分隔符来提高可读性。

/http:\/\//
#http://#
需要将一个字符串放入模式中使用时，可以用 preg_quote() 函数对其进行 转义，它的第二个参数(可选)可以用于指定需要被转义的分隔符。

除了上面提到的分隔符，也可以使用括号样式的分隔符，左括号和右括号分别作为开始和结束 分隔符。

{this is a pattern}

可以在结束分隔符后面增加模式修饰符。 下面的例子是一个大小写不敏感的匹配：

#[a-z]#i


元字符

正则表达式的威力源于它可以在模式中拥有选择和重复的能力。 一些字符被赋予 特殊的涵义，使其不再单纯的代表自己，模式中的这种有特殊涵义的编码字符 称为 元字符。

共有两种不同的元字符：一种是可以在模式中方括号外任何地方使用的，另外一种 是需要在方括号内使用的。 在方括号外使用的元字符如下：

\
一般用于转义字符
^
断言目标的开始位置(或在多行模式下是行首)
$
断言目标的结束位置(或在多行模式下是行尾)
.
匹配除换行符外的任何字符(默认)
[
开始字符类定义
]
结束字符类定义
|
开始一个可选分支
(
子组的开始标记
)
子组的结束标记
?
作为量词，表示 0 次或 1 次匹配。位于量词后面用于改变量词的贪婪特性。 (查阅量词)
*
量词，0 次或多次匹配
+
量词，1 次或多次匹配
{
自定义量词开始标记
}
自定义量词结束标记
模式中方括号内的部分称为"字符类"。 在一个字符类中仅有以下可用元字符：
\
转义字符
^
仅在作为第一个字符(方括号内)时，表明字符类取反
-
标记字符范围
下面部分描述每个元字符的用法。


转义序列(反斜线)

反斜线有多种用法。首先，如果紧接着是一个非字母数字字符，表明取消 该字符所代表的特殊涵义。这种将反斜线作为转义字符的用法在字符类 内部和外部都可用。

比如，如果你希望匹配一个 "*" 字符，就需要在模式中写为 "\*"。 这适用于一个字符在不进行转义会有特殊含义的情况下。 但是， 对于非数字字母的字符，总是在需要其进行原文匹配的时候在它前面增加一个反斜线， 来声明它代表自己，这是安全的。如果要匹配一个反斜线，那么在模式中使用 "\\"。

Note:

反斜线在单引号字符串和双引号字符串 中都有特殊含义，因此要匹配一个反斜线， 模式中必须写为 "\\\\"。 译注： "/\\/"， 首先它作为字符串，反斜线会进行转义， 那么转义后的结果是/\/，这个才是正则表达式引擎拿到的模式， 而正则表达式引擎也认为 \ 是转义标记，它会将分隔符 / 进行转义， 从而得到的是一个错误，因此，需要 4 个反斜线才可以匹配一个反斜线。

如果一个模式被使用 PCRE_EXTENDED 选项编译， 模式中的空白字符(除了字符类中的)和未转义的#到行末的所有字符都会被忽略。 要在这种情况下使用空白字符或者#，就需要对其进行转义。

反斜线的第二种用途提供了一种对非打印字符进行可见编码的控制手段。 除了二进制的 0 会终结一个模式外，并不会严格的限制非打印字符(自身)的出现， 但是当一个模式以文本编辑器的方式编辑准备的时候， 使用下面的转义序列相比使用二进制字符会更加容易。

\a
响铃字符(十六进制 07)
\cx
"control-x"，x 是任意字符
\e
转义 (十六进制 1B)
\f
换页 (十六进制 0C)
\n
换行 (十六进制 0A)
\p{xx}
一个符合 xx 属性的字符，详细查看unicode properties 属性
\P{xx}
一个不符合xx属性的字符，详细查看unicode properties 属性
\r
回车 (十六进制 0D)
\t
水平制表符 (十六进制 09)
\xhh
hh十六进制编码的字符，详细查看unicode properties 属性
\ddd
ddd八进制编码的字符，或者后向引用

\cx的确切效果如下： 如果x是一个小写字母，它被转换为大写。接着， 将字符的第6位(十六进制 40，右数第一个位为第0位)取反。 比如\cz成为十六进制的1A，\c{成为十六进制3B， \c;成为十六进制7B。

在"\x"后面，读取两个十六进制数(字母可以是大写或小写)。 在UTF-8模式， "\x{...}"允许使用， 花括号内的内容是十六进制有效数字。 它将给出的十六进制数字解释为 UTF-8 字符代码。原来的十六进制转义序列， \xhh， 匹配一个双字节的UTF-8字符，如果它的值大于127

在"\0"之后， 读取两个八进制数。所有情况下，如果数少于2个，则直接使用。 序列 "\0\x\07" 指定了两个二进制 0 紧跟着一个 BEL 字符。 请确保初始的 0 之后的两个数字是合法的八进制数。

处理一个反斜线紧跟着的不是0的数字的情况比较复杂。在字符类外部， PCRE 读取它并以十进制读取紧随其后的数字。 如果数值小于 10， 或者之前捕获到了该数字能够代表的左括号(子组)， 整个数字序列被认为是后向引用。后向引用如何工作在后面描述， 接下来就会讨论括号子组。

在一个字符类里面，或者十进制数大于 9 并且没有那么多的子组被捕获， PCRE 重新读取反斜线后的第三个 8 进制数字，并且从最低的 8 位生成单字节值。 任何的后续数字都代表它们自身。例如：

\040
空格的另外一种用法
\40
当提供了少于40个子组时也认为是空格。
\7
始终是后向引用
\11
可能是后向引用，也可能是制表符
\011
总是一个制表符
\0113
一个制表符紧跟着一个3(因为每次最多只读取3个8进制位
\113
八进制113代表的字符
\377
8进制377是10进制255， 因此代表一个全1的字符
\81
一个后向引用或者一个二进制 0 紧跟着两个数字 8 和 1(因为8不是8进制有效数字)

注意，八进制值的 100 或者更大的值必须没有前置的0引导， 因为每次最多读取3个8进制位.

所有序列定义的单字节值都可以在字符类内部或外部使用。另外，在字符类中, 序列 "\b" 解释为退格字符。字符类外它又有不同的意义(下面有描述)

反斜线的第三种用法是用来描述特定的字符类：

\d
任意十进制数字
\D
任意非十进制数字
\h
任意水平空白字符(since PHP 5.2.4)
\H
任意非水平空白字符(since PHP 5.2.4)
\s
任意空白字符
\S
任意非空白字符
\v
任意垂直空白字符(since PHP 5.2.4)
\V
任意非垂直空白字符(since PHP 5.2.4)
\w
任意单词字符
\W
任意非单词字符

上面每一对转义序列都代表了完整字符集中两个不相交的部分， 任意字符一定会匹配其中一个，同时一定不会匹配另外一个。

单词字符指的是任意字母、数字、下划线。 也就是说任意可以组成perl单词的字符。 字母和数字的定义通过PCRE字符表控制，可以通过指定地域设置使其匹配改变。比如， 在法国 (fr) 地域设置中，一些超过 128 的字符代码被用于重音字母， 它们可以实用 \w 匹配。

这些字符类序列在字符类内部或外部都可以出现。 他们每次匹配所代表的字符类型中的一个字符。 如果当前匹配点位于目标字符串末尾， 它们中的所有字符都匹配失败， 因为没有字符让它们匹配了。

反斜线的第四种用法是一些简单的断言。 一个断言指定一个必须在特定位置匹配的条件， 它们不会从目标字符串中消耗任何字符。 接下来我们会讨论使用子组的更加复杂的断言。 反斜线断言包括：

\b
单词边界
\B
非单词边界
\A
目标的开始位置(独立于多行模式)
\Z
目标的结束位置或结束处的换行符(独立于多行模式)
\z
目标的结束位置(独立于多行模式)
\G
在目标中首次匹配位置

这些断言不能出现在字符类中(但是注意， "\b"在字符类中有不同的意义， 表示的是退格(backspace)字符)

一个单词边界表示的是在目标字符串中， 当前字符和前一个字符不同时匹配\w或\W(一个比配\w, 一个匹配\W)， 或者作为字符串开始或结尾字符的时候当前字符匹配\w。

\A， \Z， \z断言不同于传统的^和$(详见下文)， 因为他们永远匹配目标字符串的开始和结尾，而不会受模式修饰符的限制。 它们不受PCRE_MULTILINE，PCRE_DOLLAR_ENDONLY选项的影响。 \Z 和 \z 之间的不同在于当字符串结束字符时换行符时 \Z 会将其看做字符串结尾匹配, 而 \z 只匹配字符串结尾。

\G 断言在指定了$offset 参数的preg_match() 调用中， 仅在当前匹配位置在匹配开始点的时候才是成功的。 当 $offset 的值不为 0 的时候， 它与 \A 是不同的。 译注：另外一点与 \A 的不同之处在于使用 preg_match_all() 时， 每次匹配 \G 只是断言是否是匹配结果的开始位置， 而 \A 断言的则是匹配结果的开始位置是否在目标字符串开始位置。

自 PHP 4.3.3开始， \Q 和 \E 可以用于在模式中忽略正则表达式元字符。比如： \w+\Q.$.\E$ 会匹配一个或多个单词字符，紧接着一个点号，一个$，一个点号， 最后锚向字符串末尾。

自 PHP 5.2.4 开始。 \K 可以用于重置匹配。 比如， foot\Kbar 匹配"footbar"。 但是得到的匹配结果是 "bar"。但是， \K 的使用不会干预到子组内的内容， 比如 (foot)\Kbar 匹配 "footbar"，第一个子组内的结果仍然会是 "foo"。译注： \K 放在子组和子组外面的效果是一样的。


Unicode字符属性

自从 PHP 4.4.0 和 5.1.0， 三个额外的转义序列在选用 UTF-8模式时用于匹配通用字符类型。他们是：

\p{xx}
一个有属性 xx 的字符
\P{xx}
一个没有属性 xx 的字符
\X
一个扩展的 Unicode 字符

上面 xx 代表的属性名用于限制 Unicode 通常的类别属性。 每个字符都有一个这样的确定的属性，通过两个缩写的字母指定。 为了与 perl 兼容， 可以在左花括号 { 后面增加 ^ 表示取反。比如： \p{^Lu} 就等同于 \P{Lu}。

如果通过 \p 或 \P 仅指定了一个字母，它包含所有以这个字母开头的属性。 在这种情况下，花括号的转义序列是可选的。

\p{L}
\pL

支持的Unicode属性
Property | Matches | Notes
C | Other |
Cc | Control |
Cf | Format |
Cn | Unassigned |
Co | Private use |
Cs | Surrogate |
L | Letter | Includes the following properties: Ll, Lm, Lo, Lt and Lu.
Ll | Lower case letter |
Lm | Modifier letter |
Lo | Other letter |
Lt | Title case letter |
Lu | Upper case letter |
M | Mark |
Mc | Spacing mark |
Me | Enclosing mark |
Mn | Non-spacing mark |
N | Number |
Nd | Decimal number |
Nl | Letter number |
No | Other number |
P | Punctuation |
Pc | Connector punctuation |
Pd | Dash punctuation |
Pe | Close punctuation |
Pf | Final punctuation |
Pi | Initial punctuation |
Po | Other punctuation |
Ps | Open punctuation |
S | Symbol |
Sc | Currency symbol |
Sk | Modifier symbol |
Sm | Mathematical symbol |
So | Other symbol |
Z | Separator |
Zl | Line separator |
Zp | Paragraph separator |
Zs | Space separator |

InMusicalSymbols 等扩展属性在 PCRE 中不支持

指定大小写不敏感匹配对这些转义序列不会产生影响，比如， \p{Lu} 始终匹配大写字母。

Unicode 字符集在具体文字中定义。使用文字名可以匹配这些字符集中的一个字符。例如：

  • \p{Greek}
  • \P{Han}

不在确定文字中的则被集中到 Common。当前的文字列表中有：

支持的文字
Arabic | Armenian | Avestan | Balinese | Bamum
Batak | Bengali | Bopomofo | Brahmi | Braille
Buginese | Buhid | Canadian_Aboriginal | Carian | Chakma
Cham | Cherokee | Common | Coptic | Cuneiform
Cypriot | Cyrillic | Deseret | Devanagari | Egyptian_Hieroglyphs
Ethiopic | Georgian | Glagolitic | Gothic | Greek
Gujarati | Gurmukhi | Han | Hangul | Hanunoo
Hebrew | Hiragana | Imperial_Aramaic | Inherited | Inscriptional_Pahlavi
Inscriptional_Parthian | Javanese | Kaithi | Kannada | Katakana
Kayah_Li | Kharoshthi | Khmer | Lao | Latin
Lepcha | Limbu | Linear_B | Lisu | Lycian
Lydian | Malayalam | Mandaic | Meetei_Mayek | Meroitic_Cursive
Meroitic_Hieroglyphs | Miao | Mongolian | Myanmar | New_Tai_Lue
Nko | Ogham | Old_Italic | Old_Persian | Old_South_Arabian
Old_Turkic | Ol_Chiki | Oriya | Osmanya | Phags_Pa
Phoenician | Rejang | Runic | Samaritan | Saurashtra
Sharada | Shavian | Sinhala | Sora_Sompeng | Sundanese
Syloti_Nagri | Syriac | Tagalog | Tagbanwa | Tai_Le
Tai_Tham | Tai_Viet | Takri | Tamil | Telugu
Thaana | Thai | Tibetan | Tifinagh | Ugaritic
Vai | Yi |  |  |

\X 转义匹配任意数量的 Unicode 字符。 \X 等价于 (?>\PM\pM*)

也就是说，它匹配一个没有 "mark" 属性的字符，紧接着任意多个由 "mark" 属性的字符。 并将这个序列认为是一个原子组(详见下文)。 典型的有 "mark" 属性的字符是影响到前面的字符的重音符。

用 Unicode 属性来匹配字符并不快， 因为 PCRE 需要去搜索一个包含超过 15000 字符的数据结构。 这就是为什么在 PCRE中 要使用传统的转义序列\d、 \w 而不使用 Unicode 属性的原因。


锚

在一个字符类外面，在默认匹配模式下， ^ 是一个断言当前匹配点位于目标字符串开始处的断言。在一个字符类内部， ^ 表明这个字符类中描述的字符取反(详见下文)。

^ 并不一定要是模式的第一个字符， 但是如果处于某个可选分支时， 它应该是该分支的首字符。如果所有选择分支都以 ^ 开头，这就是说， 如果模式限制为只匹配目标的开头， 它被称为是一个 "紧固" 模式。(同样也有其他方式可以构造出紧固模式)

$ 是用于断言当前匹配点位于目标字符串末尾， 或当目标字符串以换行符结尾时当前匹配点位于该换行符位置(默认情况)。 $ 不一定要作为模式的最后一个字符，但是如果它在某个可选分支中时， 就应该位于该分支的末尾。 $ 在字符类中没有特殊的意义。

$ 的意义可以通过在编译或匹配时设置 PCRE_DOLLAR_ENDONLY 改变为只匹配字符串末尾。 这不会影响 \Z 断言的行为。

^ 和 $ 字符的意义在 PCRE_MULTILINE 选项被设置时会发生变化。 当在这种情况下时， 它们匹配每一个换行符后面的和前面的字符，另外， 也会匹配目标字符串的开始和结束。比如, 模式 /^abc$/ 在多行模式下会成功匹配目标字符串 "def\nabc"， 而正常情况下不会。因此，由于所有的可选分支都以 ^ 开始， 在单行模式下这成为紧固模式，然而在多行模式下，这是非紧固的。 PCRE_DOLLAR_ENDONLY 选项在PCRE_MULTILINE 设置后失效。

注意： \A、\Z、 \z 等转义序列可以在任何模式下用于匹配目标字符串的开始和结束位置。 并且如果模式的所有分支都以 \A 开始，它同样是紧固的， 而与 PCRE_MULTILINE 是否设置无关。


句点

在字符类外部，模式中的句点匹配目标字符串中的任意字符，包括非打印字符， 但是(默认)不包括换行符。如果 PCRE_DOTALL 被设置，句点就会匹配换行符。 句点的处理和^、$的处理没有关联，它们唯一的关系是它们都涉及到了换行符。 句点在字符类中没有任何意义。

\C可以被用于匹配单字节， 也就是说在UTF-8模式下，句点可以匹配多字节字符。


字符类(方括号)

左方括号开始一个字符类的描述，并以方中括号结束。 单独的一个右方括号没有特殊含义。如果一个右方括号需要作为一个字符类中的成员, 那么可以将它写在字符类的首字符处(如果使用了^取反， 那么是第二个)或者使用转义符。

一个字符类在目标字符串中匹配一个单独的字符； 该字符必须是字符类中定义的字符集合的其中一个, 除非使用了 ^ 对字符类取反。 如果^需要作为一个字符类的成员，确保它不是该字符类的首字符， 或者对其进行转义即可。

例如，字符类[aeiou]匹配所有的小写元音字母， 而[^aeiou]匹配所有非元音字母的字符。注意： ^只是一个通过枚举指定那些不存在字符类之中的字符的便利符号。而不是断言， 它仍然会从目标字符串中消耗一个字符，并且如果当前匹配点在目标字符串末尾， 匹配将会失败。

当大小写无关匹配被设置后，任意字符类都同时代表大小写两种版本，因此对于例子， 一个大小写不敏感的[aeiou]同时匹配"A"和"a"， 并且大小写不敏感的[^aeiou]同时不匹配 "A"。

换行符在字符类中没有任何特殊涵义， 与 PCRE_DOTALL 或 PCRE_MULTILINE 选项都无关。 一个字符类比如 [^a] 始终会匹配换行符。

在字符类中，一个中划线(减号 -)可以用于指定从一个字符到另一个字符的范围。 比如，[d-m]匹配d到m之间的所有字符，这个集合时闭合的。 如果中划线自身要在一个字符类中描述， 它必须被转移或者出现在一个不会被解释为一个范围的位置， 典型的比如字符类开始或结束位置。

在一个字符范围描述后面不能使用右中括号。 比如一个模式 [W-]46] 被解释为一个包含 W 和 - 的字符类，后面紧跟字符串 "46]"， 因此它可以匹配 "W46]" 或 "-46]"。然而， 如果中括号是经过转义的， 它将会被解释为范围的终点， 因此 [W-\]46] 就会被解释为一个单独的包含 W 至 ] 范围内所有字符以及 4、6 的字符类。 8 进制或 16 进制描述的中括号同样可以用于作为范围的终点。

范围操作以 ASCII 整理排序。它们可以用于为字符指定数值，比如 [\000-\037]。 如果在大小写不敏感匹配模式下使用一个包含字母的范围， 则同时匹配它的大小写形式。 比如 [W-c] 在不区分大小写匹配时等价于 [][\^_`wxyzabc]，并且， 如果使用了 "fr"(法国) 的地域设置字符表时， [\xc8-xcb] 将会在所有模式下匹配重音E字符。

字符类\d、\D、 \s、\S、\w 和 \W 也可以出现在一个字符类中， 用以将其匹配的字符类加入到新的自定义字符类中。比如， [\dABCDEF] 匹配任意合法的 16 进制数。用 ^ 可以很方便的制定严格的字符类， 比如 [^\W_] 匹配任何字母或数字，但不匹配下划线。

所有非字母数字字符除了\、-、 ^(在起始位置)以及结束的]在字符类中都是非特殊字符， 没有转义也不会有危害。模式结束符在表达式中总是特殊字符，必须进行转义。

Perl 支持 POSIX 字符类符号。这种字符类使用[:和:]闭合。 PCRE 同样支持这些字符类， 比如，[01[:alpha:]%]匹配 "0"、"1"、任意字母或"%"。 支持的字符类如下：

Character classes
alnum | 字母和数字
alpha | 字母
ascii | 0 - 127的ascii字符
blank | 空格和水平制表符
cntrl | 控制字符
digit | 十进制数(same as \d)
graph | 打印字符, 不包括空格
lower | 小写字母
print | 打印字符,包含空格
punct | 打印字符, 不包括字母和数字
space | 空白字符 (比\s多垂直制表符)
upper | 大写字母
word | 单词字符(same as \w)
xdigit | 十六进制数字
空白字符有HT(9)、 LF(10)、VT(11)、 FF(12)、CR(13)、space(32)。 注意， 这个列表包含了垂直制表符。这使得space不同于\s， 因为它不包含垂直制表符(为了向 perl 兼容)

[:word:]是一个 perl扩展，[:blank:]是一个从 Perl5.8 中来的 GNU 扩展。 另外一个 perl 扩展是取反，通过前置一个^。 比如， [12[:^digit:]] 匹配"1", "2" 或任何非数字字符

在 UTF-8 模式，大于 128 的字符值不会匹配任何 POSIX 字符类。


可选路径(|)

竖线字符用于分离模式中的可选路径。 比如模式gilbert|Sullivan匹配 "gilbert" 或者 "sullivan"。 竖线可以在模式中出现任意多个，并且允许有空的可选路径(匹配空字符串)。 匹配的处理从左到右尝试每一个可选路径，并且使用第一个成功匹配的。 如果可选路径在子组(下面定义)中， 则"成功匹配"表示同时匹配了子模式中的分支以及主模式中的其他部分。


内部选项设置

PCRE_CASELESS, PCRE_MULTILINE, PCRE_DOTALL, PCRE_UNGREEDY, PCRE_EXTRA, PCRE_EXTENDED and PCRE_DUPNAMES 等模式修饰符设置可以在模式内部通过一个 perl 选项字符序列来设置， 语法为:(?修饰符)，可用的修饰符有：

Internal option letters
i | for PCRE_CASELESS
m | for PCRE_MULTILINE
s | for PCRE_DOTALL
x | for PCRE_EXTENDED
U | for PCRE_UNGREEDY
X | for PCRE_EXTRA
J | for PCRE_INFO_JCHANGED

比如，(?im) 设置表明多行大小写不敏感匹配。同样可以用它来取消这些设置， 比如 (?im-sx) 设置了 PCRE_CASELESS，PCRE_MULTILINE， 但是同时取消了 PCRE_DOTALL 和 PCRE_EXTENDED。 如果一个字母即出现在 - 之前, 也出现在 - 之后，这个选项被取消设置。

当一个选项在模式的最上级(也就是说不在子组中)时， 这个改变会影响模式中剩余部分。比如 /ab(?i)c/ 仅仅匹配 "abc" 和 "abC"。 这个形式在 PCRE 4.0(PHP 4.3.3) 中被改变。在此之前的版本中， /ab(?i)c/ 行为和 /abc/i 完全一致。

如果一个选项在子组中设置，产生的影响是不同的。这是 perl 5.005 中行为的一个变种。 一个选项在子组内部设置，仅仅改变子组中剩余的部分， 因此 (a(?i)b)c 仅仅匹配 "abc" 和 "aBc" (假设没有使用 PCRE_CASELESS 选项)。 这就意味着选项在模式的不同位置可以造成不同的影响。 在同一个子模式中， 一个分支的选项设置回穿透到后面剩余的其他分支中去。 比如 (a(?i)b|c) 匹配"ab"， "aB"， "c" 和 "C"。 尽管在匹配 "C" 时第一个分支会在选项被设定前就被丢弃。 这是因为选项的设定是在编译期确定的，否则可能会带来非常怪异的行为。

PCRE 专用选项 PCRE_UNGREEDY 和 PCRE_EXTRA 可以和 perl 兼容选项以同样的方式来改变， 分别使用字母 U 和 X. (?X) 标记设定有些特殊，它必须出现在任何其他特性之前， 最好放在最开头的位置。


子组(子模式)

子组通过圆括号分隔界定，并且它们可以嵌套。 将一个模式中的一部分标记为子组(子模式)主要是来做两件事情：

  1. 将可选分支局部化。比如，模式cat(arcat|erpillar|)匹配 "cat"， "cataract"， "caterpillar" 中的一个，如果没有圆括号的话，它匹配的则是 "cataract"， "erpillar" 以及空字符串。

  2. 将子组设定为捕获子组(向上面定义的). 当整个模式匹配后， 目标字符串中匹配子组的部分将会通过 pcre_exec()() 的 ovector 参数回传给调用者。 左括号从左至右出现的次序就是对应子组的下标(从 1 开始)， 可以通过这些下标数字来获取捕获子模式匹配结果。

比如，如果字符串 "the red king" 使用模式((red|white) (king|queen)) 进行匹配， 模式匹配到的结果是 array("red king"， "red king", "red", "king") 的形式， 其中第 0 个元素是整个模式匹配的结果，后面的三个元素依次为三个子组匹配的结果。 它们的下表分别为 1， 2， 3。

事实上，圆括号履行的两种功能并不总是有用的。 经常我们会有一种需求需要使用子组进行分组， 但又不需要(单独的)捕获它们。 在子组定义的左括号后面紧跟字符串 "?:" 会使得该子组不被单独捕获， 并且不会对其后子组序号的计算产生影响。比如, 如果字符串 "the white queen" 匹配模式 the ((?:red|white) (king|queen))，匹配到的子串是 "white queen" 和 "queen"， 他们的下标分别是 1 和 2。捕获子组的最大序号为 65535。然而，有可能我们并不能编译这么长的 正则表达式，这取决于 libpcre 的配置。

为了方便简写，如果需要在非捕获子组开始位置设置选项， 选项字母可以位于 ? 和 : 之间，比如：

(?i:saturday|sunday)
(?:(?i)saturday|sunday)

上面两种写法实际上是相同的模式。因为可选分支会从左到右尝试每个分支， 并且选项没有在子模式结束前被重置， 并且由于选项的设置会穿透对后面的其他分支产生影响，因此， 上面的模式都会匹配 "SUNDAY" 以及 "Saturday"。

在 PHP 4.3.3 中，可以对子组使用 (?P<name>pattern) 的语法进行命名。 这个子模式将会在匹配结果中同时以其名称和顺序(数字下标)出现， PHP 5.2.2中又增加了两种味子组命名的语法： (?<name>pattern) 和 (?'name'pattern)。

有时需要多个匹配可以在一个正则表达式中选用子组。 为了让多个子组可以共用一个后向引用数字的问题， (?| 语法允许复制数字。 考虑下面的正则表达式匹配Sunday：

(?:(Sat)ur|(Sun))day

这里当后向引用 1 空时Sun 存储在后向引用 2 中. 当后向引用 2 不存在的时候 Sat 存储在后向引用 1中。 使用 (?|修改模式来修复这个问题：

(?|(Sat)ur|(Sun))day

使用这个模式， Sun和Sat都会被存储到后向引用1中。


重复/量词

重复次数是通过量词指定的，可以紧跟在下面元素之后：

  • 单独的字符, 可以是经过转义的
  • 元字符。
  • 字符类
  • 后向引用(参加下一部分)
  • 子组(除非它是一个断言)

一般的重复量词指定了一个最小数值和一个最大数值的匹配次数， 通过花括号包裹两个数字，两个数字之间用逗号隔开的语法定义。 两个数值都必须小于 65536， 并且第一个数字必须小于等于第二个。 比如： z{2,4} 匹配 "zz"， "zzz"， "zzzz"。 单个的右花括号不是特殊字符。 如果第二个数字被省略，但是逗号仍然存在，就代表没有上限； 如果第二个数字和逗号都被省略，那么这个量词就限定的是一个确定次数的匹配。 比如 [aeiou]{3,} 匹配至少三个连续的元音字母，但是同时也可以匹配更多， 而 \d{8} 则只能匹配 8 个数字。 左花括号出现在不允许使用量词的位置或者与量词语法不匹配时， 被认为是一个普通字符，对它自身进行原文匹配。 比如，{,6}就不是一个量词， 会按照原文匹配四个字符 "{,6}"。

量词 {0} 是被授权的，它会导致的行为是认为前面的项和量词不存在。

为了方便(以及历史的兼容性)，最常用的三个量词都有单字符缩写。

单字符量词
* | 等价于 {0,}
+ | 等价于 {1,}
? | 等价于 {0,1}

可以通过一个不匹配任何字符的子模式后面紧跟一个匹配 0 或多个字符的量词来构造一个没有上限的无限循环。 比如：(a?)*

早期版本的 perl 和 pcre 对于这种模式会在编译期得到一个错误。然而， 由于这在某些情况下是有用的，因此现在也接受这种模式了， 但是如果任何子模式的重复确实匹配不到任何字符，循环会被强制跳出。

默认情况下，量词都是"贪婪"的，也就是说， 它们会在不导致模式匹配失败的前提下，尽可能多的匹配字符(直到最大允许的匹配次数)。 这种问题的典型示例就是尝试匹配C语言的注释。 出现在 /* 和 */ 之间的所有内容都被认为是注释， 在注释中间， 可以允许出现单独的 * 和 /。 对C注释匹配的一个尝试是使用模式 /\*.*\*/， 假设将此模式应用在字符串 "/* first comment*/ not comment /*second comment*/" 它会匹配到错误的结果，也就是整个字符串， 这是因为量词的贪婪性导致的，它会尝试尽可能多的匹配字符。

然而，如果一个量词紧跟着一个 ?(问号) 标记，它就会成为懒惰(非贪婪)模式， 它不再尽可能多的匹配，而是尽可能少的匹配。 因此模式 /\*.*?\*/ 在 C 的注释匹配上将会正确的执行。 各个量词自身的意义并不会改变，而是由于加入了 ? 使其首选的匹配次数发生改变。 不要将 ? 的这个用法和它作为量词的用法混淆。因为它又两种用法， 因此有时它会出现量词，比如 \d??\d 会更倾向于匹配一个数字， 但同时如果为了达到整个模式匹配的目的，它也可以接受两个数字的匹配。译注： 以模式 \w\d??\d\w 为例，对于字符串 "a33a"，虽然 \d?? 是非贪婪的， 但由于如果使用贪婪会导致整个模式不匹配，所以， 最终它选择的仍然是匹配到一个数字。

如果 PCRE_UNGREEDY 选项被设置(一个在 perl 中不可用的选项)， 那么量词默认情况下就是非贪婪的了。但是， 单个的量词可以通过紧跟一个 ? 来使其成为贪婪的。换句话说， PCRE_UNGREEDY 这个选项逆转了贪婪的默认行为。

量词后面紧跟一个 "+" 是"占有"性。它会吃掉尽可能多的字符， 并且不关注后面的其他模式，比如 .*abc 匹配 "aabc"， 但是 .*+abc 不会匹配， 因为 .*+ 会吃掉整个字符串，从而导致后面剩余的模式得不到匹配。 自PHP 4.3.3 起， 可以使用占有符 (+) 修饰量词来达到提升速度的目的。

当一个子组受最小数量大于 1 或有一个最大数量限制的量词修饰时， 按照最小或最大的数量的比例需要更多的存储用于编译模式。

如果一个模式以 .* 或 .{0,} 开始并且 PCRE_DOTALL 选项开启(等价于 perl 的/s)， 也就是允许.匹配换行符，那么模式会隐式的紧固，因为不管怎么样， 接下来都会对目标字符串中的每个字符位置进行尝试，因此在第一次之后， 在任何位置都不会有一个对所有匹配重试的点。 PCRE 会想对待 \A 一样处理这个模式。 在我们已知目标字符串没有包含换行符的情况下， 当模式以 .* 开始的时候我们为了获得这个优化，值得设置 PCRE_DOTALL， 或者选择使用 ^ 明确指明锚定。

译注：这里的优化指模式不匹配之后，不会回头再来查找下一个位置， 比如没有设置 PCRE_DOTALL，并且目标字符串第一个字符时换行符， 那么模式尝试第一个字符，发现不匹配， 会重新用模式从第二个字符位置开始进行尝试。 而使用了PCRE_DOTALL后， 是肯定匹配的....同理，当使用了 ^ 或者 /A的限定是，模式一旦不匹配，都可以直接退出， 而不用在目标字符串下一个位置再一次开始整个模式的匹配。

当一个捕获子组时重复的时，捕获到的该子组的结果是最后一次迭代捕获的值。比如， (tweedle[dume]{3}\s*)+匹配字符串 "tweedledum tweedledee"， 得到的的子组捕获结果是 "tweedledee"。然而，如果是嵌套的捕获子组， 相应的捕获值可能会被设置到之前的迭代中。比如，/(a|(b))+/ 匹配字符串 "aba"， 第二个捕获子组得到的结果会是 "b"。译注：不理解然而之后的部分，以例子说明， b 是第二个子组最后一次捕获到的结果，所以， 第二个子组最后结果是 b， 这是符合"然而"之前描述的规则的。


后向引用

在一个字符类外面， 反斜线紧跟一个大于 0 (可能还有一位数)的数字就是一个到模式中之前出现的某个捕获组的后向引用。

如果紧跟反斜线的数字小于 10， 它总是一个后向引用， 并且如果在模式中没有这么多的捕获组会引发一个错误。 换一种说法， 被引用的括号不能少于被引用的小于 10 的数量。 查看上面的"反斜线"部分查看具体的数字处理方式。

一个后向引用会直接匹配被引用捕获组在目标字符串中实际捕获到的内容， 而不是匹配子组模式的内容。因此，模式(sens|respons)e and \1ibility将会匹配 "sense and sensibility" 和 "response and responsibility"， 而不会匹配 "sense and responsibility"。 如果在后向引用时被强制进行了大小写敏感匹配, 比如 ((?i)rah)\s+\1 匹配 "rah rah"和"RAH RAH"，但是不会匹配 "RAH rah"， 即使原始捕获子组自身是不区分大小写的。 译注： 这里其实要考虑的是后向引用期望得到的内容是和那个被引用的捕获子组得到的内容是完全一致的(当然， 我们可以通过在后向引用之前设定内部选项使其不区分大小写，或者增加模式修饰符， 同样可以达到不区分大小写的目的，但是, 这种做法实际上是从外部对其行为进行了控制。)

可能会有超过一个的后向引用引用相同的子组。 一个子组可能并不会真正的用于特定的匹配，此时， 任何对这个子组的后向引用也都会失败。 比如， 模式 (a|(bc))\2 总是在匹配 "a" 开头而不是 "bc" 开头的字符串时失败。 因为可能会有多达 99 个后向引用， 所有紧跟反斜线后的数字都可能是一个潜在的后向引用计数。 如果模式在后向引用之后紧接着还是一个数值字符， 那么必须使用一些分隔符用于终结后向引用语法。 如果 PCRE_EXTENDED 选项被设置了， 可以使用空格来做。其他情况下可以使用一个空的注释。

如果一个后向引用出现在它所引用的子组内部， 它的匹配就会失败。比如， (a\1) 就不会得到任何匹配。然而这种引用可以用于内部的子模式重复。比如， 模式 (a|b\1)+ 会匹配任意数量的 "a" 组成的字符串以及 "aba"， "ababba" 等等(译注： 因为子组内部有一个可选路径，可选路径中有一条路能够完成匹配，在匹配完成后， 后向引用就能够引用到内容了)。在每次子模式的迭代过程中， 后向引用匹配上一次迭代时这个子组匹配到的字符串。为了做这种工作， 模式必须满足这样一个条件，模式在第一次迭代的时候， 必须能够保证不需要匹配后向引用。 这种条件可以像上面的例子用可选路径来实现，也可以通过使用最小值为 0 的量词修饰后向引用的方式来完成。

在 PHP 5.2.2之后， \g 转义序列可以用于子模式的绝对和相对引用。 这个转义序列必须紧跟一个无符号数字或一个负数， 可以选择性的使用括号对数字进行包裹。 序列\1， \g1，\g{1} 之间是同义词关系。 这种用法可以消除使用反斜线紧跟数值描述反向引用时候产生的歧义。 这种转义序列有利于区分后向引用和八进制数字字符， 也使得后向引用后面紧跟一个原文匹配数字变的更明了，比如 \g{2}1。

\g 转义序列紧跟一个负数代表一个相对的后向引用。比如： (foo)(bar)\g{-1} 可以匹配字符串 "foobarbar"， (foo)(bar)\g{-2} 可以匹配 "foobarfoo"。 这在长的模式中作为一个可选方案， 用来保持对之前一个特定子组的引用的子组序号的追踪。

后向引用也支持使用子组名称的语法方式描述, 比如 (?P=name) 或者 PHP 5.2.2 开始可以实用\k<name> 或 \k'name'。 另外在 PHP 5.2.4 中加入了对\k{name} 和 \g{name} 的支持。


断言

一个断言就是一个对当前匹配位置之前或之后的字符的测试， 它不会实际消耗任何字符。简单的断言代码有\b、\B、 \A、 \Z、\z、 ^、$ 等等。 更加复杂的断言以子组的方式编码。 它有两种类型： 前瞻断言(从当前位置向前测试)和后瞻断言(从当前位置向后测试)。

一个断言子组的匹配还是通过普通方式进行的， 不同在于它不会导致当前的匹配点发生改变。 前瞻断言中的正面断言(断言此匹配为真)以 "(?=" 开始，消极断言以 "(?!" 开头。比如， \w+(?=;) 匹配一个单词紧跟着一个分号但是匹配结果不会包含分号， foo(?!bar) 匹配所有后面没有紧跟 "bar" 的 "foo" 字符串。 注意一个类似的模式 (?!foo)bar， 它不能用于查找之前出现所有不是 "foo" 的 "bar" 匹配， 它会查找到任意的 "bar" 出现的情况， 因为 (?!foo) 这个断言在接下来三个字符时 "bar" 的时候是永远都 true 的。 前瞻断言需要达到的就是这样的效果。

后瞻断言中的正面断言以"(?<="开始, 消极断言以"(?<!"开始。比如， (?<!foo)bar 用于查找任何前面不是 "foo" 的 "bar"。 后瞻断言的内容被严格限制为只能用于匹配定长字符串。但是，如果有多个可选分支， 它们不需要拥有相同的长度。比如 (?<=bullock|donkey) 是允许的， 但是 (?<!dogs?|cats?) 将会引发一个编译期的错误。在最上级分支可以匹配不同长度的字符串是允许的。 相比较于 perl 5.005 而言，它会要求多个分支使用相同长度的字符串匹配。 (?<=ab(c|de)) 这样的断言是不允许的， 因为它单个的顶级分支可以匹配两个不同的长度， 但是它可以接受使用两个顶级分支的写法 (?<=abc|abde) 这样的断言实现， 对于每个可选分支，暂时将当前位置移动到尝试匹配的当前位置之前的固定宽度处。 如果在当前没有足够的字符就视为匹配失败。后瞻断言与一次性子组结合使用可以用来匹配字符串结尾； 一个例子就是在一次性子组上给出字符串结尾。

多个断言(任意顺序)可以同时出现。 比如 (?<=\d{3})(?<!999)foo 匹配前面有三个数字但不是 "999" 的字符串 "foo"。注意， 每个断言独立应用到对目标字符串该点的匹配。 首先它会检查前面的三位都是数字， 然后检查这三位不是 "999"。 这个模式不能匹配 "foo" 前面有三位数字然后紧跟 3 位非 999 共 6 个字符的字符串，比如， 它不匹配 "123abcfoo"。 匹配 "123abcfoo" 这个字符串的模式可以是(?<=\d{3}...)(?<!999)foo。

这种情况下，第一个断言查看(当前匹配点)前面的 6 个字符，检查前三个是数字， 然后第二个断言检查(当前匹配点)前三个字符不是 "999"。

断言可以以任意复杂度嵌套。 比如 (?<=(?<!foo)bar)baz 匹配前面有 "bar" 但是 "bar" 前面没有 "foo" 的 "baz"。 另外一个模式 (?<=\d{3}...(?<!999))foo 则匹配前面有三个数字字符紧跟 3 个不是 999 的任意字符的 "foo"。

断言子组时非捕获子组，并且不能用量词修饰， 因为对同一件事做多次断言是没有意义的.如果所有的断言都包含一个捕获子组， 那么为了在整个模式中捕获子组计数的目的，它们都会被计算在内。然而， 子字符串的捕获仅可以用于正面断言，因为对于消极的断言是没有意义的。

将断言计算在内，可以拥有的最大子组数量是 200 个。


一次性子组

对于同时有最大值和最小值量词限制的重复项， 在匹配失败后， 紧接着会以另外一个重复次数重新评估是否能使模式匹配。 当模式的作者明确知道执行上没有问题时， 通过改变匹配的行为或者使其更早的匹配失败以阻止这种行为是很有用的。

考虑一个例子，模式 \d+foo 应用到目标行 123456bar 时：

在匹配了 6 个数字后匹配 "foo" 时失败，通常的行为时匹配器尝试使 \d+ 只匹配 5 个数字， 只匹配 4 个数字，在最终失败之前依次进行尝试。 一次性子组提供了一种特殊的意义， 当模式的一部分得到匹配后，不再对其进行重新评估， 因此匹配器在第一次匹配 "foo" 失败后就能立刻失败。语法符号是另外一种特殊的括号， 以 (?> 开始，比如 (?>\d+)bar。

这种括号对模式的一部分提供了"锁定"，当它包含一个匹配之后， 会阻止未来模式失败后对它内部的后向回溯。后向回溯在这里失效， 其他工作照常进行。

换一种说法，如果在目标字符串中当前匹配点是锚点， 这种类型的子组匹配的字符串等同于一个独立的模式匹配。

一次性子组不是捕获子组。如上面的例子，简单而言， 就是尽其所能吃掉尽可能多的匹配字符。因此， 尽管 \d+ 和 \d+? 都会调整要匹配的数字的个数以便模式的其他部分匹配， (?>\d+) 却仅能匹配整个数字序列。

这个(语法)结构可以包含任意复杂度的字符， 也可以嵌套。

一次性子组可以和后瞻断言结合使用来指定在目标字符串末尾的有效匹配。 考虑当一个简单的模式比如abcd$应用到一个不匹配的长字符串上。 由于匹配时从左到右处理的， PCRE会从目标中查找每一个 "a" 然后查看是否紧接着会匹配模式的剩余部分。 如果模式是^.*abcd$， 那么初始的 .* 将首先匹配整个字符串，但是当它失败后(因为紧接着不是 "a")， 它会回溯所有的匹配，依次吐出最后 1 个字符，倒数第 2 个字符等等。 从右向左查找整个字符串中的 "a"， 因此，我们不能很好的退出。然而， 如果模式写作 ^(?>.*)(?<=abcd) 那么它就不会回溯 .* 这一部分， 它仅仅用于匹配整个字符串。后瞻断言对字符串末尾的后四个字符做了一个测试。 如果它失败，匹配立即失败。对于长字符串， 这个模式将会带来显著的处理时间上的性能提升。

当一个模式中包含一个子组自己可以无限重复并且内部有无限重复元素时， 使用一次性子组是避免一些失败匹配消耗大量时间的唯一途径。 模式 (\D+|<\d+>)*[!?] 匹配一个不限制数目的非数字字符或由 <> 闭合的数字字符紧跟着 ! 或 ?。 当它匹配的时候，运行时快速的。然而， 如果它应用到 "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" 上将会在报告错误之前消耗很多时间。 这是因为字符串可以用于两种重复规则，并且需要为两种重复规则都分配进行尝试。 (示例的结尾使用 [!?] 而不是单个的字符， 是因为 PCRE 和 perl 都会对模式最后是一个单独字符时的快速报错有优化。 它们会记录最后需要匹配的单个字符，当它们没有出现在字符串中时快速报错。) 如果模式修改为 ((?>\D+)|<\d+>)*[!?] 就会快速得到报错。(译注： 对于这里给出的模式，当目标字符串更长的时候，消耗时间会迅速增加，慎用。)


条件子组

可以使匹配器根据一个断言的结果， 或者之前的一个捕获子组是否匹配来条件式的匹配一个子组或者在两个可选子组中选择。 条件子组的两种语法如下：

(?(condition)yes-pattern)
(?(condition)yes-pattern|no-pattern)

如果条件满足，使用 yes-pattern，其他情况使用 no-pattern(如果指定了)。 如果有超过 2 个的可选子组，会产生给一个编译期错误。

条件一共有两种。如果在(condition)的括号内是数字组成的文本， 条件在该数字代表的(之前的)子组得到匹配时满足(即使用 yes-pattern)。 考虑下面的模式， 为了使其易于阅读其中增加了一些空白字符(查看PCRE_EXTENDED 选项)并且将其分为三个部分： ( \( )? [^()]+ (?(1) \) )

模式的第一部分匹配一个可选的左括号，并且如果该字符出现， 设置其为第一个子组的捕获子串。第二部分匹配一个或多个非括号字符。 第三部分是一个条件子组，它会测试第一个子组是否匹配，如果匹配到了， 也就是说目标字符串以左括号开始，条件为true， 那么使用 yes-pattern 也就是这里需要匹配一个右括号。其他情况下， 既然 no-pattern 没有出现，这个子组就不匹配任何东西。换句话说， 这个模式匹配一个没有括号的或者闭合括号包裹的字符序列。

如果条件式字符串 (R)，它在得到对模式或子模式的递归调用时满足。 在"最上级"， 条件总是false。

如果条件不是数字序列或(R)，它就必须是一个断言。这里的断言可以使任意的，积极， 消极，正向，后向都是可以的。考虑这个模式， 同样为了方便阅读， 增加了一些空白字符，并且在第二行有两个可选路径。

(?(?=[^a-z]*[a-z])
\d{2}-[a-z]{3}-\d{2}  |  \d{2}-\d{2}-\d{2} )

条件式一个正向积极断言，匹配一个可选的非小写字母字符序列紧接着一个小写字母。 换一种说法，它测试目标中至少出现一个小写字母，如果小写字母发现， 目标匹配第一个可选分支，其他情况下它匹配第二个分支。 这个模式匹配两种格式的字符串：dd-aaa-dd 或 dd-dd-dd。aaa 代表小写字母， dd 是数字。


注释

字符序列(?#标记开始一个注释直到遇到一个右括号。不允许嵌套括号。 注释中的字符不会作为模式的一部分参与匹配。

如果设置了 PCRE_EXTENDED 选项， 一个字符类外部的未转义的 # 字符就代表本行剩余部分为注释。


递归模式

考虑匹配圆括号内字符串的问题，允许无限嵌套括号。如果不使用递归， 最好的方式是使用一个模式匹配固定深度的嵌套。它不能处理任意深度的嵌套。 perl 5.6 提供了一个实验性的功能允许正则表达式递归。 特殊项 (?R) 提供了递归的这种特殊用法。 这个PCRE模式解决了圆括号问题(假设 PCRE_EXTENDED 选项被设置了， 因此空白字符被忽略)： \( ( (?>[^()]+) | (?R) )* \)。

首先，它匹配一个左括号。 然后它匹配任意数量的非括号字符序列或一个模式自身的递归匹配(比如， 一个正确的括号子串)，最终，匹配一个右括号。

这个例子模式包含无限重复的嵌套，因此使用了一次性子组匹配非括号字符， 这在模式应用到模式不匹配的字符串时非常重要。比如， 当它应用到 (aaaaaaaaaaaaaaaaaaaaaaaaaaaaa() 时就会很快的产生"不匹配"结果。 然而，如果不使用一次性子组，这个匹配将会运行很长时间， 因为有很多途径让 + 和 * 重复限定分隔目标字符串， 并且在报告失败之前需要测试所有路径。

所有捕获子组最终被设置的捕获值都是从递归最外层子模式捕获的值。 如果上面的模式匹配 (ab(cd)ef)，捕获子组最终被设置的值为 "ef"， 即顶级得到的最后一个值。如果增加了额外的括号，\( ( ( (?>[^()]+) | (?R) )* ) \)，捕获到的字符串就是顶层括号的匹配内容 "ab(cd)ef"。 如果在模式中有超过 15 个捕获括号， PCRE 在递归期间就会使用 pcre_malloc 分配额外的内存来存储数据， 随后通过 pcre_free 释放他们。如果没有内存可被分配，它就仅保存前 15 个捕获括号， 在递归内部无法给出内存不够用的错误。

从 PHP 4.3.3 开始, (?1)、(?2) 等可以用于递归子组。这同样可以用于命名子组： (?P>name) 或 (?P&name)。

如果递归子组语法在它提到的子组括号外部使用(无论是子组数字序号还是子组名称)， 这个操作就相当于程序设计语言中的子程序。 前面一些有一个例子指出模式 (sens|respons)e and \1ibility 匹配 "sense and responsibility" 和 "response and responsibility"，但是不匹配 "sense and responsibility"。如果用模式 (sens|respons)e and (?1)ibility 替代， 它会像匹配那两个字符串一样匹配 "sense and responsibility"。 这种引用方式意义是紧接着匹配引用的子模式。(译注: 后向引用只匹配引用的子组之前匹配的结果, 这里的递归语法引用是拿引用的子模式重新匹配。)

目标字符串的最大长度是 int 型变量可以存储的最大正整数。然而， PCRE 使用递归处理子组和无限重复。 这就是说对于某些模式可用的栈空间可能会受目标字符串限制。


性能

模式中一些项可能比其他一些更加高效。 比如使用 [aeiou] 这样的字符类会比可选路径 (a|e|i|o|u) 高效。 一般而言， 用尽可能简单的构造描述需求是最高效的。 Jeffrey Friedl 书(精通正则表达式)中包含了很多关于正则表达式性能的讨论。

当一个模式以 .* 开始并且设置了 PCRE_DOTALL 选项时，模式通过PCRE隐式锚定， 因为它可以匹配字符串的开始。然而，如果 PCRE_DOTALL 没有设置， PCRE 不能做这个优化，因为.元字符不能匹配换行符，如果目标字符串包含换行符， 模式可能会从一个换行符后面开始匹配，而不是最开始位置。 比如，模式 (.*) second 匹配目标字符串 "first\nand second"(\n 是一个换行符)第一个捕获子组结果是 "and"。为了这样做， PCRE 尝试从目标字符串中每个换行符后开始匹配。

如果你使用模式匹配没有换行符的目标字符串， 可以通过设置 PCRE_DOTALL 或以 ^.* 开始的模式明确指示锚定以获取最佳性能。 这样节省了 PCRE 沿目标字符串扫描查找换行符重新开始的时间。

小心模式中的无限重复嵌套。这在应用到不匹配字符串时可能会导致运行时间很长。 考虑模式片段 (a+)*。

这个模式可以有 33 种方式匹配 "aaaa"， 并且这个数字会随着字符串的长度的增加迅速增加. (*重复可以匹配0,1,2,3,4次, 并且除了0外每种情况+都有不同次数的匹配对应)。 当模式的剩余部分导致整个匹配失败的时候， PCRE原则上回尝试每种可能的变化， 这将会非常耗时。

对于一些简单的情况的优化是像 (a+)*b 这样紧接着使用原文字符串.。 在着手正式匹配工作之前，PCRE 检查目标字符串后面是否有 "b" 字符， 如果没有就立即失败。然而当紧接着没有原文字符的时候这个优化是不可用的。 你可以比较观察 (a+)*\d 和上面模式的行为差异。 前者在应用到整行的 "a" 组成的字符串时几乎是立即报告失败， 而后者在目标字符串长于 20 个字符时，时间消耗就相当可观。


模式修饰符

下面列出了当前可用的 PCRE 修饰符。括号中提到的名字是 PCRE 内部这些修饰符的名称。 模式修饰符中的空格，换行符会被忽略，其他字符会导致错误。

i (PCRE_CASELESS)
如果设置了这个修饰符，模式中的字母会进行大小写不敏感匹配。
m (PCRE_MULTILINE)
默认情况下，PCRE 认为目标字符串是由单行字符组成的(然而实际上它可能会包含多行)， "行首"元字符 (^) 仅匹配字符串的开始位置， 而"行末"元字符 ($) 仅匹配字符串末尾， 或者最后的换行符(除非设置了 D 修饰符)。这个行为和 perl 相同。 当这个修饰符设置之后，"行首"和"行末"就会匹配目标字符串中任意换行符之前或之后，另外， 还分别匹配目标字符串的最开始和最末尾位置。这等同于 perl 的 /m 修饰符。如果目标字符串 中没有 "\n" 字符，或者模式中没有出现 ^ 或 $，设置这个修饰符不产生任何影响。
s (PCRE_DOTALL)
如果设置了这个修饰符，模式中的点号元字符匹配所有字符，包含换行符。如果没有这个 修饰符，点号不匹配换行符。这个修饰符等同于 perl 中的/s修饰符。 一个取反字符类比如 [^a] 总是匹配换行符，而不依赖于这个修饰符的设置。
x (PCRE_EXTENDED)
如果设置了这个修饰符，模式中的没有经过转义的或不在字符类中的空白数据字符总会被忽略， 并且位于一个未转义的字符类外部的#字符和下一个换行符之间的字符也被忽略。 这个修饰符 等同于 perl 中的 /x 修饰符，使被编译模式中可以包含注释。 注意：这仅用于数据字符。 空白字符 还是不能在模式的特殊字符序列中出现，比如序列 (?( 引入了一个条件子组(译注: 这种语法定义的 特殊字符序列中如果出现空白字符会导致编译错误。 比如(?(就会导致错误)。
e (PREG_REPLACE_EVAL)
Warning

This feature was DEPRECATED in PHP 5.5.0, and REMOVED as of PHP 7.0.0.

如果设置了这个被弃用的修饰符， preg_replace() 在进行了对替换字符串的 后向引用替换之后, 将替换后的字符串作为php 代码评估执行(eval 函数方式)，并使用执行结果 作为实际参与替换的字符串。单引号、双引号、反斜线(\)和 NULL 字符在 后向引用替换时会被用反斜线转义.
Caution

The addslashes() function is run on each matched backreference before the substitution takes place. As such, when the backreference is used as a quoted string, escaped characters will be converted to literals. However, characters which are escaped, which would normally not be converted, will retain their slashes. This makes use of this modifier very complicated.

Caution

请确保 replacement 参数由合法 php 代码字符串组成，否则 php 将会 在preg_replace() 调用的行上产生一个解释错误。

Caution

不建议使用此修饰符，它很容易产生安全漏洞：

<?php
$html = $_POST['html'];

// uppercase headings
$html = preg_replace(
    '(<h([1-6])>(.*?)</h\1>)e',
    '"<h$1>" . strtoupper("$2") . "</h$1>"',
    $html
);

以上示例代码能够被这样的字符串利用： <h1>{${eval($_GET[php_code])}}</h1>。 这能让攻击者执行他们想要的 PHP 代码，几乎完全渗透进服务器。

为了阻止此类远程代码执行攻击，可以使用 preg_replace_callback() 替代：

<?php
$html = $_POST['html'];

// uppercase headings
$html = preg_replace_callback(
    '(<h([1-6])>(.*?)</h\1>)',
    function ($m) {
        return "<h$m[1]>" . strtoupper($m[2]) . "</h$m[1]>";
    },
    $html
);

Note:

仅 preg_replace() 使用此修饰符，其他 PCRE 函数忽略此修饰符。

A (PCRE_ANCHORED)
如果设置了这个修饰符，模式被强制为"锚定"模式，也就是说约束匹配使其仅从 目标字符串的开始位置搜索。这个效果同样可以使用适当的模式构造出来，并且 这也是 perl 种实现这种模式的唯一途径。
D (PCRE_DOLLAR_ENDONLY)
如果这个修饰符被设置，模式中的元字符美元符号仅仅匹配目标字符串的末尾。如果这个修饰符 没有设置，当字符串以一个换行符结尾时， 美元符号还会匹配该换行符(但不会匹配之前的任何换行符)。 如果设置了修饰符m，这个修饰符被忽略. 在 perl 中没有与此修饰符等同的修饰符。
S
当一个模式需要多次使用的时候，为了得到匹配速度的提升，值得花费一些时间 对其进行一些额外的分析。如果设置了这个修饰符，这个额外的分析就会执行。当前， 这种对一个模式的分析仅仅适用于非锚定模式的匹配(即没有单独的固定开始字符)。
U (PCRE_UNGREEDY)
这个修饰符逆转了量词的"贪婪"模式。 使量词默认为非贪婪的，通过量词后紧跟? 的方式可以使其成为贪婪的。这和 perl 是不兼容的。 它同样可以使用 模式内修饰符设置 (?U)进行设置， 或者在量词后以问号标记其非贪婪(比如.*?)。

Note:

在非贪婪模式，通常不能匹配超过 pcre.backtrack_limit 的字符。

X (PCRE_EXTRA)
这个修饰符打开了 PCRE 与 perl 不兼容的附件功能。模式中的任意反斜线后就 ingen 一个 没有特殊含义的字符都会导致一个错误，以此保留这些字符以保证向后兼容性。 默认情况下，在 perl 中，反斜线紧跟一个没有特殊含义的字符被认为是该字符的原文。 当前没有其他特性由这个修饰符控制。
J (PCRE_INFO_JCHANGED)
内部选项设置(?J)修改本地的PCRE_DUPNAMES选项。允许子组重名， (译注：只能通过内部选项设置，外部的 /J 设置会产生错误。)
u (PCRE_UTF8)
此修正符打开一个与 perl 不兼容的附加功能。 模式和目标字符串都被认为是 utf-8 的。 无效的目标字符串会导致 preg_* 函数什么都匹配不到； 无效的模式字符串会导致 E_WARNING 级别的错误。 PHP 5.3.4 后，5字节和6字节的 UTF-8 字符序列被考虑为无效（resp. PCRE 7.3 2007-08-28）。 以前就被认为是无效的 UTF-8。


与 perl 的不同之处

这里讨论的不同之处是与 perl 5.005相比的。

  1. 尽管可以使用字符类编译 pcre 进行替代，但仍然默认使用 c 库函数 isspace() 判定一个字符是否是空白字符。通常 isspace() 匹配空格、换页符、换行符、 回车符、水平制表符和垂直制表符。 Perl5 不再将垂直制表符包括到空白字符集中。 \v 这个转义实际上在很长时间都没有得到 perl 文档的承认。然而，这个字符自身 被认为是一个空白字符至少是在 5.002 以上。 在 5.004 和 5.005 它不和 \s 匹配。
  2. PCRE 不允许前瞻断言的量词修饰，perl 允许这样做，但是这并不是你想象的那样。 例如，(?!a){3}并不意味着接下来 3 个字符不是 a，而是断言下一个字符不是 a 并进行了 3 次断言.
  3. 捕获子组发生在消极前瞻断言中时被计算在内，但是在偏移向量中并没有设置它们的条目。 Perl 从断言失败之前匹配得到的这些模式匹配结果中设置了它的数值变量(因此是成功的)， 但这也仅在消极前瞻断言只有一个分支的时候。
  4. 尽管目标字符串中支持二进制 0 字符，但是它们在模式字符串中是不允许的，因为它们是通过普通的 c 字符串传递的，而 c 字符串是以 0 字符结束的。转义序列"\x00"可以在模式中表示二进制 0 字符。
  5. 不支持下面的 perl 转义序列：\l、\u、 \L、 \U。 实际上这些都是通过 perl 一般的字符串处理来实现 的，而不是模式匹配引擎的一部分。
  6. 不支持 perl 的 \G 断言，因为它与单模式匹配没有关系。
  7. 很显然，PCRE不支持(?{code}) 和 (??{code})的结构，但是它支持递归模式。
  8. 在 perl 5.005_2 中档设置为捕获字符串的模式中有部分重复的时候会有一些古怪的现象发生， 比如: /^(a(b)?)+$/ 捕获 aba 的时候， $2 会被设置为 b，然而，如果把模式修改为/^(aa(bb)?)+$/， 用aabbaa去匹配，$2讲不会得到匹配结果。 如果将模式修改为 /^(aa(b(b))?)+$/， $2 和 $3 又都能 得到匹配结果。在 perl 5.004 中 $2 在这几种情况下都能够得到匹配结果，并且 pcre 也是这样。如果 未来 perl 修改为一致那就不同了。pcre 可能接下来会修改.
  9. 还有一个没有解决的差异是 perl 5.005_02中，模式 /^(a)?(?(1)a|b)+$/ 会匹配字符串 "a"， 而 pcre 中不会，然而，perl 和 pcre 中 /^(a)?a/ 匹配 "a" 都会得到相同的结果，$1 都未被设置。

  10. PCRE 提供了一些对 perl 正则表达式的扩展：

    1. 虽然后瞻断言要求必须匹配固定长度的字符串，然而后瞻断言的每个可选分支 还是可以使用不同长度的字符串的，而perl 5.005 中要求它们必须拥有同样 的长度。
    2. 如果设置了 PCRE_DOLLAR_ENDONLY 并且没有设置 PCRE_MULTILINE， 元字符 $ 仅仅匹配字符串的末尾(而不是某个换行符之前)。
    3. 如果设置了 PCRE_EXTRA， 反斜线后紧跟一个没有特殊含义的字符讲会导致错误。
    4. 如果设置了 PCRE_UNGREEDY， 贪婪量词修饰被逆转，也就是说，默认它们都是非贪婪的了，但如果紧跟一个问号它们就会变成 贪婪的。(译注：既完全将贪婪模式逆转。)


与 POSIX 正则表达式的不同

自 PHP 5.3.0起， POSIX 正则表达式扩展被废弃。在 POSIX 正则和 PCRE 正则之间有一些不同，本页列出了在转向PCRE 时最显著的需要知道的不同点。

  1. PCRE 函数需要模式以分隔符闭合。
  2. 不像POSIX，PCRE 扩展没有专门用于大小写不敏感匹配的函数。取而代之的是，支持使用i (PCRE_CASELESS) 模式修饰符完成同样的工作。 其他模式修饰符同样可用于改变匹配策略。
  3. POSIX 函数从最左面开始寻找最长的匹配，但是 PCRE 在第一个合法匹配后停止。如果字符串 不匹配这没有什么区别，但是如果匹配，两者在结果和速度上都会有差别。 为了说明这个不同, 考虑下面的例子(来自Jeffrey Friedl 的《精通正则表达式》一书)。 使用模式 one(self)?(selfsufficient)? 在字符串oneselfsufficient 上匹配，PCRE 会匹配到oneself，但是使用 POSIX，结果将是整个字符串 oneselfsufficient。 两个子串都匹配原始字符串，但是 POSIX 将 最长的作为结果。

函数对照表
POSIX | PCRE
ereg_replace() | preg_replace()
ereg() | preg_match()
eregi_replace() | preg_replace()
eregi() | preg_match()
split() | preg_split()
spliti() | preg_split()
sql_regcase() | 无对等函数


PCRE 函数

Table of Contents

  • preg_filter — 执行一个正则表达式搜索和替换
  • preg_grep — 返回匹配模式的数组条目
  • preg_last_error_msg — Returns the error message of the last PCRE regex execution
  • preg_last_error — 返回最后一个PCRE正则执行产生的错误代码
  • preg_match_all — 执行一个全局正则表达式匹配
  • preg_match — 执行匹配正则表达式
  • preg_quote — 转义正则表达式字符
  • preg_replace_callback_array — Perform a regular expression search and replace using callbacks
  • preg_replace_callback — 执行一个正则表达式搜索并且使用一个回调进行替换
  • preg_replace — 执行一个正则表达式的搜索和替换
  • preg_split — 通过一个正则表达式分隔字符串


执行一个正则表达式搜索和替换

  • ? PCRE 函数
  • preg_grep ?
  • PHP Manual
  • PCRE 函数
  • 执行一个正则表达式搜索和替换

preg_filter

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

preg_filter — 执行一个正则表达式搜索和替换

说明

preg_filter ( mixed $pattern , mixed $replacement , mixed $subject , int $limit = -1 , int &$count = ? ) : mixed

preg_filter()等价于preg_replace() 除了它仅仅返回(可能经过转化)与目标匹配的结果. 这个函数怎样工作的更详细信息请阅读 preg_replace()文档.

返回值

如果subject是一个数组，返回一个数组， 其他情况返回一个字符串。

如果没有找到匹配或者发生了错误，当subject是数组 时返回一个空数组，其他情况返回null。

范例

Example #1 比较preg_filter() 和preg_replace()的示例

<?php
$subject = array('1', 'a', '2', 'b', '3', 'A', 'B', '4');
$pattern = array('/\d/', '/[a-z]/', '/[1a]/');
$replace = array('A:$0', 'B:$0', 'C:$0');

echo "preg_filter returns\n";
print_r(preg_filter($pattern, $replace, $subject));

echo "preg_replace returns\n";
print_r(preg_replace($pattern, $replace, $subject));
?>

以上例程会输出：

preg_filter returns
Array
(
    [0] => A:C:1
    [1] => B:C:a
    [2] => A:2
    [3] => B:b
    [4] => A:3
    [7] => A:4
)
preg_replace returns
Array
(
    [0] => A:C:1
    [1] => B:C:a
    [2] => A:2
    [3] => B:b
    [4] => A:3
    [5] => A
    [6] => B
    [7] => A:4
)

参见

  • PCRE 模式
  • preg_quote() - 转义正则表达式字符
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • preg_replace_callback() - 执行一个正则表达式搜索并且使用一个回调进行替换
  • preg_grep() - 返回匹配模式的数组条目
  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码


返回匹配模式的数组条目

  • ? preg_filter
  • preg_last_error_msg ?
  • PHP Manual
  • PCRE 函数
  • 返回匹配模式的数组条目

preg_grep

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_grep — 返回匹配模式的数组条目

说明

preg_grep ( string $pattern , array $input , int $flags = 0 ) : array

返回给定数组input中与模式pattern 匹配的元素组成的数组.

参数

pattern

要搜索的模式, 字符串形式.

input

输入数组.

flags

如果设置为PREG_GREP_INVERT, 这个函数返回输入数组中与 给定模式pattern 不匹配的元素组成的数组.

返回值

返回使用input中key做索引的数组.

范例

Example #1 preg_grep() 示例

<?php
// 返回所有包含浮点数的元素
$fl_array = preg_grep("/^(\d+)?\.\d+$/", $array);
?>

参见

  • PCRE 模式
  • preg_quote() - 转义正则表达式字符
  • preg_match_all() - 执行一个全局正则表达式匹配
  • preg_filter() - 执行一个正则表达式搜索和替换
  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码


Returns the error message of the last PCRE regex execution

  • ? preg_grep
  • preg_last_error ?
  • PHP Manual
  • PCRE 函数
  • Returns the error message of the last PCRE regex execution

preg_last_error_msg

(PHP 8)

preg_last_error_msg — Returns the error message of the last PCRE regex execution

说明

preg_last_error_msg ( ) : string

Returns the error message of the last PCRE regex execution.

参数

此函数没有参数。

返回值

Returns the error message on success, or "No error" if no error has occurred.

范例

Example #1 preg_last_error_msg() example

<?php

preg_match('/(?:\D+|<\d+>)*[!?]/', 'foobar foobar foobar');

if (preg_last_error() !== PREG_NO_ERROR) {
    echo preg_last_error_msg();
}

?>

以上例程会输出：

Backtrack limit exhausted

参见

  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码


返回最后一个PCRE正则执行产生的错误代码

  • ? preg_last_error_msg
  • preg_match_all ?
  • PHP Manual
  • PCRE 函数
  • 返回最后一个PCRE正则执行产生的错误代码

preg_last_error

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

preg_last_error — 返回最后一个PCRE正则执行产生的错误代码

说明

preg_last_error ( ) : int

返回最后一次PCRE正则执行的错误代码。

Example #1 preg_last_error() 示例

<?php

preg_match('/(?:\D+|<\d+>)*[!?]/', 'foobar foobar foobar');

if (preg_last_error() == PREG_BACKTRACK_LIMIT_ERROR) {
    print 'Backtrack limit was exhausted!';
}

?>

以上例程会输出：

Backtrack limit was exhausted!

返回值

返回下面常量中的一个(查看它们自身的解释):

  • PREG_NO_ERROR
  • PREG_INTERNAL_ERROR
  • PREG_BACKTRACK_LIMIT_ERROR （参见 pcre.backtrack_limit）
  • PREG_RECURSION_LIMIT_ERROR （参见 pcre.recursion_limit）
  • PREG_BAD_UTF8_ERROR
  • PREG_BAD_UTF8_OFFSET_ERROR （自 PHP 5.3.0 起）
  • PREG_JIT_STACKLIMIT_ERROR (自 PHP 7.0.0 起)


执行一个全局正则表达式匹配

  • ? preg_last_error
  • preg_match ?
  • PHP Manual
  • PCRE 函数
  • 执行一个全局正则表达式匹配

preg_match_all

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_match_all — 执行一个全局正则表达式匹配

说明

preg_match_all ( string $pattern , string $subject , array &$matches = ? , int $flags = PREG_PATTERN_ORDER , int $offset = 0 ) : int

搜索subject中所有匹配pattern给定正则表达式 的匹配结果并且将它们以flag指定顺序输出到matches中.

在第一个匹配找到后, 子序列继续从最后一次匹配位置搜索.

参数

pattern

要搜索的模式，字符串形式。

subject

输入字符串。

matches

多维数组，作为输出参数输出所有匹配结果, 数组排序通过flags指定。

flags

可以结合下面标记使用(注意不能同时使用PREG_PATTERN_ORDER和 PREG_SET_ORDER)：

PREG_PATTERN_ORDER

结果排序为$matches[0]保存完整模式的所有匹配, $matches[1] 保存第一个子组的所有匹配，以此类推。

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>example: </b><div align=left>this is a test</div>",
    $out, PREG_PATTERN_ORDER);
echo $out[0][0] . ", " . $out[0][1] . "\n";
echo $out[1][0] . ", " . $out[1][1] . "\n";
?>

以上例程会输出：

<b>example: </b>, <div align=left>this is a test</div>
example: , this is a test

因此, $out[0]是包含匹配完整模式的字符串的数组， $out[1]是包含闭合标签内的字符串的数组。

如果正则表达式包含了带名称的子组，$matches 额外包含了带名称子组的键。

如果正则表达式里，子组名称重名了，则仅最右侧的子组储存在 $matches[NAME] 中。

<?php
preg_match_all(
    '/(?J)(?<match>foo)|(?<match>bar)/',
    'foo bar',
    $matches,
    PREG_PATTERN_ORDER
);
print_r($matches['match']);
?>

以上例程会输出：

Array
(
    [0] =>
    [1] => bar
)

PREG_SET_ORDER

结果排序为$matches[0]包含第一次匹配得到的所有匹配(包含子组)， $matches[1]是包含第二次匹配到的所有匹配(包含子组)的数组，以此类推。

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>example: </b><div align=\"left\">this is a test</div>",
    $out, PREG_SET_ORDER);
echo $out[0][0] . ", " . $out[0][1] . "\n";
echo $out[1][0] . ", " . $out[1][1] . "\n";
?>

以上例程会输出：

<b>example: </b>, example:
<div align="left">this is a test</div>, this is a test

PREG_OFFSET_CAPTURE

如果这个标记被传递，每个发现的匹配返回时会增加它相对目标字符串的字节偏移量。 注意这会改变matches中的每一个匹配结果字符串元素，使其 成为一个第0个元素为匹配结果字符串，第1个元素为 匹配结果字符串在subject中的偏移量。

<?php
preg_match_all('/(foo)(bar)(baz)/', 'foobarbaz', $matches, PREG_OFFSET_CAPTURE);
print_r($matches);
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [0] => Array
                (
                    [0] => foobarbaz
                    [1] => 0
                )

        )

    [1] => Array
        (
            [0] => Array
                (
                    [0] => foo
                    [1] => 0
                )

        )

    [2] => Array
        (
            [0] => Array
                (
                    [0] => bar
                    [1] => 3
                )

        )

    [3] => Array
        (
            [0] => Array
                (
                    [0] => baz
                    [1] => 6
                )

        )

)

PREG_UNMATCHED_AS_NULL

传入此标记，未匹配的子组报告为 null；否则会是空 string。

如果没有给定排序标记，假定设置为PREG_PATTERN_ORDER。

offset

通常， 查找时从目标字符串的开始位置开始。可选参数offset用于 从目标字符串中指定位置开始搜索(单位是字节)。

Note:

使用 offset 参数不同于传递 substr($subject, $offset) 的 结果到 preg_match_all() 作为目标字符串，因为 pattern 可以包含断言比如^， $ 或者 (?<=x) 。 示例查看 preg_match()。

返回值

返回完整匹配次数（可能是0），或者如果发生错误返回false。

更新日志

版本 | 说明
7.2.0 | 现在 $flags 参数可以支持 PREG_UNMATCHED_AS_NULL。

范例

Example #1 查找所有文本中的电话号码。

<?php
preg_match_all("/\(?  (\d{3})?  \)?  (?(1)  [\-\s] ) \d{3}-\d{4}/x",
                "Call 555-1212 or 1-800-555-1212", $phones);
?>

Example #2 查找匹配的HTML标签（贪婪）

<?php
//\\2是一个后向引用的示例. 这会告诉pcre它必须匹配正则表达式中第二个圆括号(这里是([\w]+))
//匹配到的结果. 这里使用两个反斜线是因为这里使用了双引号.
$html = "<b>bold text</b><a href=howdy.html>click me</a>";

preg_match_all("/(<([\w]+)[^>]*>)(.*?)(<\/\\2>)/", $html, $matches, PREG_SET_ORDER);

foreach ($matches as $val) {
    echo "matched: " . $val[0] . "\n";
    echo "part 1: " . $val[1] . "\n";
    echo "part 2: " . $val[2] . "\n";
    echo "part 3: " . $val[3] . "\n";
    echo "part 4: " . $val[4] . "\n\n";
}
?>

以上例程会输出：

matched: <b>bold text</b>
part 1: <b>
part 2: b
part 3: bold text
part 4: </b>

matched: <a href=howdy.html>click me</a>
part 1: <a href=howdy.html>
part 2: a
part 3: click me
part 4: </a>

Example #3 使用子命名组

<?php

$str = <<<FOO
a: 1
b: 2
c: 3
FOO;

preg_match_all('/(?P<name>\w+): (?P<digit>\d+)/', $str, $matches);

/* 下面代码在php 5.2.2(pcre 7.0)或更高版本下工作, 不过, 为了向后兼容
 * 推荐使用上面的方式. */
// preg_match_all('/(?<name>\w+): (?<digit>\d+)/', $str, $matches);

print_r($matches);

?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [0] => a: 1
            [1] => b: 2
            [2] => c: 3
        )

    [name] => Array
        (
            [0] => a
            [1] => b
            [2] => c
        )

    [1] => Array
        (
            [0] => a
            [1] => b
            [2] => c
        )

    [digit] => Array
        (
            [0] => 1
            [1] => 2
            [2] => 3
        )

    [2] => Array
        (
            [0] => 1
            [1] => 2
            [2] => 3
        )

)

参见

  • PCRE 匹配
  • preg_quote() - 转义正则表达式字符
  • preg_match() - 执行匹配正则表达式
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • preg_split() - 通过一个正则表达式分隔字符串
  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码


执行匹配正则表达式

  • ? preg_match_all
  • preg_quote ?
  • PHP Manual
  • PCRE 函数
  • 执行匹配正则表达式

preg_match

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_match — 执行匹配正则表达式

说明

preg_match ( string $pattern , string $subject , array &$matches = ? , int $flags = 0 , int $offset = 0 ) : int

搜索subject与pattern给定的正则表达式的一个匹配.

参数

pattern

要搜索的模式，字符串类型。

subject

输入字符串。

matches

如果提供了参数matches，它将被填充为搜索结果。 $matches[0]将包含完整模式匹配到的文本， $matches[1] 将包含第一个捕获子组匹配到的文本，以此类推。

flags

flags 可以被设置为以下标记值的组合：

PREG_OFFSET_CAPTURE

如果传递了这个标记，对于每一个出现的匹配返回时会附加字符串偏移量(相对于目标字符串的字节数)。 注意：这会改变填充到matches参数的数组，使其每个元素成为一个由 第0个元素是匹配到的字符串，第1个元素是该匹配字符串 在目标字符串subject中的偏移量。

<?php
preg_match('/(foo)(bar)(baz)/', 'foobarbaz', $matches, PREG_OFFSET_CAPTURE);
print_r($matches);
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [0] => foobarbaz
            [1] => 0
        )

    [1] => Array
        (
            [0] => foo
            [1] => 0
        )

    [2] => Array
        (
            [0] => bar
            [1] => 3
        )

    [3] => Array
        (
            [0] => baz
            [1] => 6
        )

)

PREG_UNMATCHED_AS_NULL

使用该标记，未匹配的子组会报告为 null；未使用时，报告为空的 string。

<?php
preg_match('/(a)(b)*(c)/', 'ac', $matches);
var_dump($matches);
preg_match('/(a)(b)*(c)/', 'ac', $matches, PREG_UNMATCHED_AS_NULL);
var_dump($matches);
?>

以上例程会输出：

array(4) {
  [0]=>
  string(2) "ac"
  [1]=>
  string(1) "a"
  [2]=>
  string(0) ""
  [3]=>
  string(1) "c"
}
array(4) {
  [0]=>
  string(2) "ac"
  [1]=>
  string(1) "a"
  [2]=>
  NULL
  [3]=>
  string(1) "c"
}

offset

通常，搜索从目标字符串的开始位置开始。可选参数 offset 用于 指定从目标字符串的某个位置开始搜索(单位是字节)。

Note:

使用offset参数不同于向preg_match() 传递按照位置通过substr($subject, $offset)截取目标字符串结果， 因为pattern可以包含断言比如^， $ 或者(?<=x)。 比较：

<?php
$subject = "abcdef";
$pattern = '/^def/';
preg_match($pattern, $subject, $matches, PREG_OFFSET_CAPTURE, 3);
print_r($matches);
?>

以上例程会输出：

Array
(
)

当这个示例使用截取后传递时

<?php
$subject = "abcdef";
$pattern = '/^def/';
preg_match($pattern, substr($subject,3), $matches, PREG_OFFSET_CAPTURE);
print_r($matches);
?>

将会产生匹配

Array
(
    [0] => Array
        (
            [0] => def
            [1] => 0
        )

)

要避免使用 substr()，可以用 \G 断言而不是 ^ 锚，或者 A 修改器，它们都能和 offset 参数一起运行。

返回值

preg_match()返回 pattern 的匹配次数。 它的值将是0次（不匹配）或1次，因为preg_match()在第一次匹配后 将会停止搜索。preg_match_all()不同于此，它会一直搜索subject 直到到达结尾。 如果发生错误preg_match()返回 false。

更新日志

版本 | 说明
7.2.0 | 现在 $flags 参数支持 PREG_UNMATCHED_AS_NULL。

范例

Example #1 查找文本字符串"php"

<?php
//模式分隔符后的"i"标记这是一个大小写不敏感的搜索
if (preg_match("/php/i", "PHP is the web scripting language of choice.")) {
    echo "A match was found.";
} else {
    echo "A match was not found.";
}
?>

Example #2 查找单词"word"

<?php
/* 模式中的\b标记一个单词边界，所以只有独立的单词"web"会被匹配，而不会匹配
 * 单词的部分内容比如"webbing" 或 "cobweb" */
if (preg_match("/\bweb\b/i", "PHP is the web scripting language of choice.")) {
    echo "A match was found.";
} else {
    echo "A match was not found.";
}

if (preg_match("/\bweb\b/i", "PHP is the website scripting language of choice.")) {
    echo "A match was found.";
} else {
    echo "A match was not found.";
}
?>

Example #3 获取URL中的域名

<?php
//从URL中获取主机名称
preg_match('@^(?:http://)?([^/]+)@i',
    "http://www.php.net/index.html", $matches);
$host = $matches[1];

//获取主机名称的后面两部分
preg_match('/[^.]+\.[^.]+$/', $host, $matches);
echo "domain name is: {$matches[0]}\n";
?>

以上例程会输出：

domain name is: php.net

Example #4 使用命名子组

<?php

$str = 'foobar: 2008';

preg_match('/(?P<name>\w+): (?P<digit>\d+)/', $str, $matches);

/* 下面例子在php 5.2.2(pcre 7.0)或更新版本下工作, 然而, 为了后向兼容, 上面的方式是推荐写法. */
// preg_match('/(?<name>\w+): (?<digit>\d+)/', $str, $matches);

print_r($matches);

?>

以上例程会输出：

Array
(
    [0] => foobar: 2008
    [name] => foobar
    [1] => foobar
    [digit] => 2008
    [2] => 2008
)

注释

Tip

如果你仅仅想要检查某个字符串是否包含另外一个字符串，不要使用preg_match()。 使用 strpos() 会更快。

参见

  • PCRE 模式
  • preg_quote() - 转义正则表达式字符
  • preg_match_all() - 执行一个全局正则表达式匹配
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • preg_split() - 通过一个正则表达式分隔字符串
  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码


转义正则表达式字符

  • ? preg_match
  • preg_replace_callback_array ?
  • PHP Manual
  • PCRE 函数
  • 转义正则表达式字符

preg_quote

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_quote — 转义正则表达式字符

说明

preg_quote ( string $str , string $delimiter = null ) : string

preg_quote()需要参数 str 并向其中 每个正则表达式语法中的字符前增加一个反斜线。 这通常用于你有一些运行时字符串 需要作为正则表达式进行匹配的时候。

正则表达式特殊字符有： . \ + * ? [ ^ ] $ ( ) { } = ! < > | : - #

注意 / 不是正则表达式特殊字符。

Note:

注意：preg_quote() 的应用场景不是用于 preg_replace() 的 $replacement 字符串参数。

参数

str

输入字符串

delimiter

如果指定了可选参数 delimiter，它也会被转义。这通常用于 转义PCRE函数使用的分隔符。 / 是最常见的分隔符。

返回值

返回转义后的字符串。

更新日志

版本 | 说明
7.3.0 | 字符 # 被增加为需要转义的。

范例

Example #1 preg_quote()示例

<?php
$keywords = '$40 for a g3/400';
$keywords = preg_quote($keywords, '/');
echo $keywords; // 返回 \$40 for a g3\/400
?>

Example #2 将文本中的单词替换为斜体

<?php
//在这个例子中，preg_quote($word) 用于保持星号原文涵义，使其不使用正则表达式中的特殊语义。

$textbody = "This book is *very* difficult to find.";
$word = "*very*";
$textbody = preg_replace ("/" . preg_quote($word, '/') . "/",
                          "<i>" . $word . "</i>",
                          $textbody);
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • PCRE 模式
  • escapeshellcmd() - shell 元字符转义


Perform a regular expression search and replace using callbacks

  • ? preg_quote
  • preg_replace_callback ?
  • PHP Manual
  • PCRE 函数
  • Perform a regular expression search and replace using callbacks

preg_replace_callback_array

(PHP 7, PHP 8)

preg_replace_callback_array — Perform a regular expression search and replace using callbacks

说明

preg_replace_callback_array ( array $pattern , string|array $subject , int $limit = -1 , int &$count = null , int $flags = 0 ) : string|array|null

The behavior of this function is similar to preg_replace_callback(), except that callbacks are executed on a per-pattern basis.

参数

pattern

An associative array mapping patterns (keys) to callables (values).

subject

The string or an array with strings to search and replace.

limit

The maximum possible replacements for each pattern in each subject string. Defaults to -1 (no limit).

count

If specified, this variable will be filled with the number of replacements done.

flags

flags can be a combination of the PREG_OFFSET_CAPTURE and PREG_UNMATCHED_AS_NULL flags, which influence the format of the matches array. See the description in preg_match() for more details.

返回值

preg_replace_callback_array() returns an array if the subject parameter is an array, or a string otherwise. On errors the return value is null

If matches are found, the new subject will be returned, otherwise subject will be returned unchanged.

更新日志

版本 | 说明
7.4.0 | The flags parameter was added.

范例

Example #1 preg_replace_callback_array() example

<?php
$subject = 'Aaaaaa Bbb';

preg_replace_callback_array(
    [
        '~[a]+~i' => function ($match) {
            echo strlen($match[0]), ' matches for "a" found', PHP_EOL;
        },
        '~[b]+~i' => function ($match) {
            echo strlen($match[0]), ' matches for "b" found', PHP_EOL;
        }
    ],
    $subject
);
?>

以上例程会输出：

6 matches for "a" found
3 matches for "b" found

参见

  • PCRE Patterns
  • preg_replace_callback() - 执行一个正则表达式搜索并且使用一个回调进行替换
  • preg_quote() - 转义正则表达式字符
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码
  • Anonymous functions


执行一个正则表达式搜索并且使用一个回调进行替换

  • ? preg_replace_callback_array
  • preg_replace ?
  • PHP Manual
  • PCRE 函数
  • 执行一个正则表达式搜索并且使用一个回调进行替换

preg_replace_callback

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

preg_replace_callback — 执行一个正则表达式搜索并且使用一个回调进行替换

说明

preg_replace_callback ( string|array $pattern , callable $callback , string|array $subject , int $limit = -1 , int &$count = null , int $flags = 0 ) : string|array|null

这个函数的行为除了可以指定一个 callback 替代 replacement 进行替换字符串的计算，其他方面等同于 preg_replace()。

参数

pattern

要搜索的模式，可以是字符串或一个字符串数组。

callback

一个回调函数，在每次需要替换时调用，调用时函数得到的参数是从 subject 中匹配到的结果。回调函数返回真正参与替换的字符串。这是该回调函数的签名：

handler ( array $matches ) : string

经常会需要 callback 函数而仅用于 preg_replace_callback() 一个地方的调用。在这种情况下，你可以使用 匿名函数 来定义一个匿名函数作为 preg_replace_callback() 调用时的回调。 这样做你可以保留所有调用信息在同一个位置并且不会因为一个不在任何其他地方使用的回调函数名称而污染函数名称空间。

Example #1 preg_replace_callback() 和 匿名函数

<?php
/* 一个unix样式的命令行过滤器，用于将段落开始部分的大写字母转换为小写。 */
$fp = fopen("php://stdin", "r") or die("can't read stdin");
while (!feof($fp)) {
    $line = fgets($fp);
    $line = preg_replace_callback(
        '|<p>\s*\w|',
        function ($matches) {
            return strtolower($matches[0]);
        },
        $line
    );
    echo $line;
}
fclose($fp);
?>

subject

要搜索替换的目标字符串或字符串数组。

limit

对于每个模式用于每个 subject 字符串的最大可替换次数。 默认是 -1（无限制）。

count

如果指定，这个变量将被填充为替换执行的次数。

flags

flags 可以是 PREG_OFFSET_CAPTURE 和 PREG_UNMATCHED_AS_NULL 标志的组合， 这会影响匹配到的结果的格式。 相关详情请参阅 preg_match() 中的描述。

返回值

如果 subject 是一个数组， preg_replace_callback() 返回一个数组，其他情况返回字符串。错误发生时返回 null。

如果查找到了匹配，返回替换后的目标字符串（或字符串数组），其他情况 subject 将会无变化返回。

更新日志

版本 | 说明
7.4.0 | 新增 flags 参数。

范例

Example #2 preg_replace_callback()示例

<?php
// 将文本中的年份增加一年.
$text = "April fools day is 04/01/2002\n";
$text.= "Last christmas was 12/24/2001\n";
// 回调函数
function next_year($matches)
{
  // 通常: $matches[0]是完成的匹配
  // $matches[1]是第一个捕获子组的匹配
  // 以此类推
  return $matches[1].($matches[2]+1);
}
echo preg_replace_callback(
            "|(\d{2}/\d{2}/)(\d{4})|",
            "next_year",
            $text);

?>

以上例程会输出：

April fools day is 04/01/2003
Last christmas was 12/24/2002

Example #3 preg_replace_callback() 使用递归构造处理 BB 码的封装

<?php
$input = "plain [indent] deep [indent] deeper [/indent] deep [/indent] plain";

function parseTagsRecursive($input)
{
     /* 译注: 对此正则表达式分段分析
     * 首尾两个#是正则分隔符
     * \[indent] 匹配一个原文的[indent]
     * ((?:[^[]|\[(?!/?indent])|(?R))+)分析:
     *   (?:[^[]|\[(?!/?indent])分析:
     *  首先它是一个非捕获子组
     *   两个可选路径, 一个是非[字符, 另一个是[字符但后面紧跟着不是/indent或indent.
     *   (?R) 正则表达式递归
     *     \[/indent] 匹配结束的[/indent]
     * /

    $regex = '#\[indent]((?:[^[]|\[(?!/?indent])|(?R))+)\[/indent]#';

    if (is_array($input)) {
        $input = '<div style="margin-left: 10px">'.$input[1].'</div>';
    }

    return preg_replace_callback($regex, 'parseTagsRecursive', $input);
}

$output = parseTagsRecursive($input);

echo $output;
?>

参见

  • PCRE 模式
  • preg_replace_callback_array() - Perform a regular expression search and replace using callbacks
  • preg_quote() - 转义正则表达式字符
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码
  • 匿名函数


执行一个正则表达式的搜索和替换

  • ? preg_replace_callback
  • preg_split ?
  • PHP Manual
  • PCRE 函数
  • 执行一个正则表达式的搜索和替换

preg_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_replace — 执行一个正则表达式的搜索和替换

说明

preg_replace ( mixed $pattern , mixed $replacement , mixed $subject , int $limit = -1 , int &$count = ? ) : mixed

搜索 subject 中匹配 pattern 的部分，以 replacement 进行替换。

参数

pattern

要搜索的模式。可以使一个字符串或字符串数组。

可以使用一些 PCRE 修饰符。

replacement

用于替换的字符串或字符串数组。如果这个参数是一个字符串，并且 pattern 是一个数组，那么所有的模式都使用这个字符串进行替换。如果 pattern 和 replacement 都是数组，每个 pattern 使用 replacement 中对应的元素进行替换。如果 replacement 中的元素比 pattern 中的少，多出来的 pattern 使用空字符串进行替换。

replacement 中可以包含后向引用 \\n 或 $n，语法上首选后者。 每个这样的引用将被匹配到的第 n 个捕获子组捕获到的文本替换。 n 可以是0-99，\\0 和 $0 代表完整的模式匹配文本。捕获子组的序号计数方式为：代表捕获子组的左括号从左到右， 从1开始数。如果要在 replacement 中使用反斜线，必须使用 4 个("\\\\"，译注：因为这首先是 PHP 的字符串，经过转义后，是两个，再经过正则表达式引擎后才被认为是一个原文反斜线)。

当在替换模式下工作并且后向引用后面紧跟着需要是另外一个数字 (比如：在一个匹配模式后紧接着增加一个原文数字)，不能使用 \\1 这样的语法来描述后向引用。比如，\\11将会使preg_replace() 不能理解你希望的是一个 \\1 后向引用紧跟一个原文 1，还是一个 \\11 后向引用后面不跟任何东西。 这种情况下解决方案是使用 ${1}1。这创建了一个独立的 $1 后向引用, 一个独立的原文 1。

当使用被弃用的 e 修饰符时, 这个函数会转义一些字符 (即：'、"、 \ 和 NULL) 然后进行后向引用替换。当这些完成后请确保后向引用解析完后没有单引号或双引号引起的语法错误 (比如： 'strlen(\'$1\')+strlen("$2")')。确保符合 PHP 的 字符串语法，并且符合 eval 语法。因为在完成替换后，引擎会将结果字符串作为 PHP 代码使用 eval 方式进行评估并将返回值作为最终参与替换的字符串。

subject

要进行搜索和替换的字符串或字符串数组。

如果 subject 是一个数组，搜索和替换回在 subject 的每一个元素上进行, 并且返回值也会是一个数组。

limit

每个模式在每个 subject 上进行替换的最大次数。默认是 -1(无限)。

count

如果指定，将会被填充为完成的替换次数。

返回值

如果 subject 是一个数组，preg_replace() 返回一个数组，其他情况下返回一个字符串。

如果匹配被查找到，替换后的 subject 被返回，其他情况下返回没有改变的 subject。如果发生错误，返回 null 。

错误／异常

PHP 5.5.0 起， 传入 "\e" 修饰符的时候，会产生一个 E_DEPRECATED 错误； PHP 7.0.0 起，会产生 E_WARNING 错误，同时 "\e" 也无法起效。

范例

Example #1 使用后向引用紧跟数值原文

<?php
$string = 'April 15, 2003';
$pattern = '/(\w+) (\d+), (\d+)/i';
$replacement = '${1}1,$3';
echo preg_replace($pattern, $replacement, $string);
?>

以上例程会输出：

April1,2003

Example #2 preg_replace() 中使用基于索引的数组

<?php
$string = 'The quick brown fox jumps over the lazy dog.';
$patterns = array();
$patterns[0] = '/quick/';
$patterns[1] = '/brown/';
$patterns[2] = '/fox/';
$replacements = array();
$replacements[2] = 'bear';
$replacements[1] = 'black';
$replacements[0] = 'slow';
echo preg_replace($patterns, $replacements, $string);
?>

以上例程会输出：

The bear black slow jumps over the lazy dog.

对模式和替换内容按 key 进行排序我们可以得到期望的结果。

<?php
ksort($patterns);
ksort($replacements);
echo preg_replace($patterns, $replacements, $string);
?>

以上例程会输出：

The slow black bear jumps over the lazy dog.

Example #3 替换一些值

<?php
$patterns = array ('/(19|20)(\d{2})-(\d{1,2})-(\d{1,2})/',
                   '/^\s*{(\w+)}\s*=/');
$replace = array ('\3/\4/\1\2', '$\1 =');
echo preg_replace($patterns, $replace, '{startDate} = 1999-5-27');
?>

以上例程会输出：

$startDate = 5/27/1999

Example #4 剥离空白字符

这个例子剥离多余的空白字符

<?php
$str = 'foo   o';
$str = preg_replace('/\s\s+/', ' ', $str);
// 将会改变为'foo o'
echo $str;
?>

Example #5 使用参数 count

<?php
$count = 0;

echo preg_replace(array('/\d/', '/\s/'), '*', 'xp 4 to', -1 , $count);
echo $count; //3
?>

以上例程会输出：

xp***to
3

注释

Note:

当使用数组形式的pattern和replacement时, 将会按照key在数组中出现的顺序进行处理. 这不一定和数组的索引顺序一致. 如果你期望使用索引对等方式用replacement对pattern 进行替换, 你可以在调用preg_replace()之前对两个数组各进行一次ksort()排序.

参见

  • PCRE 模式
  • preg_quote() - 转义正则表达式字符
  • preg_filter() - 执行一个正则表达式搜索和替换
  • preg_match() - 执行匹配正则表达式
  • preg_replace_callback() - 执行一个正则表达式搜索并且使用一个回调进行替换
  • preg_split() - 通过一个正则表达式分隔字符串
  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码


通过一个正则表达式分隔字符串

  • ? preg_replace
  • POSIX Regex ?
  • PHP Manual
  • PCRE 函数
  • 通过一个正则表达式分隔字符串

preg_split

(PHP 4, PHP 5, PHP 7, PHP 8)

preg_split — 通过一个正则表达式分隔字符串

说明

preg_split ( string $pattern , string $subject , int $limit = -1 , int $flags = 0 ) : array

通过一个正则表达式分隔给定字符串.

参数

pattern

用于搜索的模式，字符串形式。

subject

输入字符串

limit

如果指定，将限制分隔得到的子串最多只有limit个，返回的最后一个 子串将包含所有剩余部分。limit值为-1， 0或null时都代表"不限制"。

flags

flags 可以是任何下面标记的组合(以位或运算 | 组合)：

PREG_SPLIT_NO_EMPTY
如果这个标记被设置， preg_split() 将仅返回分隔后的非空部分。
PREG_SPLIT_DELIM_CAPTURE
如果这个标记设置了，用于分隔的模式中的括号表达式将被捕获并返回。
PREG_SPLIT_OFFSET_CAPTURE

如果这个标记被设置, 对于每一个出现的匹配返回时将会附加字符串偏移量. 注意：这将会改变返回数组中的每一个元素, 使其每个元素成为一个由第0 个元素为分隔后的子串，第1个元素为该子串在subject 中的偏移量组成的数组。

返回值

返回一个使用 pattern 边界分隔 subject 后得到 的子串组成的数组， 或者在失败时返回 false。

范例

Example #1 preg_split()示例：获取搜索字符串的部分

<?php
//使用逗号或空格(包含" ", \r, \t, \n, \f)分隔短语
$keywords = preg_split("/[\s,]+/", "hypertext language, programming");
print_r($keywords);
?>

以上例程会输出：

Array
(
    [0] => hypertext
    [1] => language
    [2] => programming
)

Example #2 将一个字符串分隔为组成它的字符

<?php
$str = 'string';
$chars = preg_split('//', $str, -1, PREG_SPLIT_NO_EMPTY);
print_r($chars);
?>

以上例程会输出：

Array
(
    [0] => s
    [1] => t
    [2] => r
    [3] => i
    [4] => n
    [5] => g
)

Example #3 分隔一个字符串并获取每部分的偏移量

<?php
$str = 'hypertext language programming';
$chars = preg_split('/ /', $str, -1, PREG_SPLIT_OFFSET_CAPTURE);
print_r($chars);
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [0] => hypertext
            [1] => 0
        )

    [1] => Array
        (
            [0] => language
            [1] => 10
        )

    [2] => Array
        (
            [0] => programming
            [1] => 19
        )

)

注释

Tip

如果你不需要正则表达式功能，可以有更快(并且更简单)的选择比如 explode() 或 str_split()。

Tip

如果没有成功匹配，将会返回一个数组，包含了单个元素，即输入的字符串。

参见

  • PCRE 模式
  • preg_quote() - 转义正则表达式字符
  • implode() - 将一个一维数组的值转化为字符串
  • preg_match() - 执行匹配正则表达式
  • preg_match_all() - 执行一个全局正则表达式匹配
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • preg_last_error() - 返回最后一个PCRE正则执行产生的错误代码


Regular Expression (POSIX Extended)

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • POSIX 正则表达式函数
    • ereg_replace — 正则表达式替换
    • ereg — 正则表达式匹配
    • eregi_replace — 不区分大小写的正则表达式替换
    • eregi — 不区分大小写的正则表达式匹配
    • split — 用正则表达式将字符串分割到数组中
    • spliti — 用正则表达式不区分大小写将字符串分割到数组中
    • sql_regcase — 产生用于不区分大小的匹配的正则表达式


简介

Tip

PHP also supports regular expressions using a Perl-compatible syntax using the PCRE functions. Those functions support non-greedy matching, assertions, conditional subpatterns, and a number of other features not supported by the POSIX-extended regular expression syntax.

Warning

These regular expression functions are not binary-safe. The PCRE functions are.

Note:

从PHP5.3.0开始本扩展不再建议使用，所有调用本扩展中函数都将提示E_DEPRECATED 错误。

Regular expressions are used for complex string manipulation. PHP uses the POSIX extended regular expressions as defined by POSIX 1003.2. For a full description of POSIX regular expressions see the » regex man pages included in the regex directory in the PHP distribution. It's in manpage format, so you'll want to do something along the lines of man /usr/local/src/regex/regex.7 in order to read it.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • POSIX Regex
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

Warning

除非知道自己在做什么，否则不要改变 TYPE。

要激活 regexp 的支持在配置 PHP 时加上 --with-regex[=TYPE]。TYPE 可以是 system，apache 或 php 之一。默认使用 php。

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • POSIX Regex
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

Example #1 正则表达式例子

<?php
// $string 中任意位置找到 "abc" 就返回 true。
ereg("abc", $string);

// $string 中起始位置找到 "abc" 就返回 true。
ereg("^abc", $string);

// $string 末尾找到 "abc" 就返回 true。
ereg("abc$", $string);

// 客户浏览器是 Netscape 2、 3 或 MSIE 3 就返回 true。
eregi("(ozilla.[23]|MSIE.3)", $_SERVER["HTTP_USER_AGENT"]);

// 三个空格分割单词为 $regs[1]、 $regs[2]、 $regs[3]。
ereg("([[:alnum:]]+) ([[:alnum:]]+) ([[:alnum:]]+)", $string, $regs);

// $string 头部加一个 <br /> 标签。
$string = ereg_replace("^", "<br />", $string);

// $string 尾部添加一个 <br /> 标签。
$string = ereg_replace("$", "<br />", $string);

// 删除 $string 里的换行符。
$string = ereg_replace("\n", "", $string);
?>


POSIX 正则表达式函数

参见

Warning

This feature was DEPRECATED in PHP 5.3.0, and REMOVED in PHP 7.0.0.

Alternatives to this feature include:

  • PCRE （支持完整的正则表达式）
  • fnmatch() （支持 shell 风格通配符的匹配）

Table of Contents

  • ereg_replace — 正则表达式替换
  • ereg — 正则表达式匹配
  • eregi_replace — 不区分大小写的正则表达式替换
  • eregi — 不区分大小写的正则表达式匹配
  • split — 用正则表达式将字符串分割到数组中
  • spliti — 用正则表达式不区分大小写将字符串分割到数组中
  • sql_regcase — 产生用于不区分大小的匹配的正则表达式


正则表达式替换

  • ? POSIX 正则表达式函数
  • ereg ?
  • PHP Manual
  • POSIX 正则表达式函数
  • 正则表达式替换

ereg_replace

(PHP 4, PHP 5)

ereg_replace — 正则表达式替换

说明

ereg_replace ( string $pattern , string $replacement , string $string ) : string

本函数在 string 中扫描与 pattern 匹配的部分，并将其替换为 replacement。

返回替换后的字符串。（如果没有可供替换的匹配项则会返回原字符串。）

如果 pattern 包含有括号内的子串，则 replacement 可以包含形如 \\digit 的子串，这些子串将被替换为数字表示的的第几个括号内的子串；\\0 则包含了字符串的整个内容。最多可以用九个子串。括号可以嵌套，此情形下以左圆括号来计算顺序。

如果未在 string 中找到匹配项，则 string 将原样返回。

例如，下面的代码片断输出 "This was a test" 三次：

Example #1 ereg_replace() 例子

<?php
$string = "This is a test";
echo str_replace(" is", " was", $string);
echo ereg_replace("( )is", "\\1was", $string);
echo ereg_replace("(( )is)", "\\2was", $string);
?>

要注意的一点是如果在 replacement 参数中使用了整数值，则可能得不到所期望的结果。这是因为 ereg_replace() 将把数字作为字符的序列值来解释并应用之。例如：

Example #2 ereg_replace() 例子

<?php
/* 不能产生出期望的结果 */
$num = 4;
$string = "This string has four words.";
$string = ereg_replace('four', $num, $string);
echo $string;   /* Output: 'This string has   words.' */

/* 本例工作正常 */
$num = '4';
$string = "This string has four words.";
$string = ereg_replace('four', $num, $string);
echo $string;   /* Output: 'This string has 4 words.' */
?>

Example #3 将 URL 替换为超连接

<?php
$text = ereg_replace("[[:alpha:]]+://[^<>[:space:]]+[[:alnum:]/]",
                     "<a href=\"\\0\">\\0</a>", $text);
?>

Tip

preg_replace() 函数使用了 Perl 兼容正则表达式语法，通常是比 ereg_replace() 更快的替代方案。

参见 ereg()，eregi()，eregi_replace()，str_replace() 和 preg_match()。


正则表达式匹配

  • ? ereg_replace
  • eregi_replace ?
  • PHP Manual
  • POSIX 正则表达式函数
  • 正则表达式匹配

ereg

(PHP 4, PHP 5)

ereg — 正则表达式匹配

说明

ereg ( string $pattern , string $string , array &$regs = ? ) : int

Note:

使用 Perl 兼容正则表达式语法的 preg_match() 函数通常是比 ereg() 更快的替代方案。

以区分大小写的方式在 string 中寻找与给定的正则表达式 pattern 所匹配的子串。

如果找到与 pattern 中圆括号内的子模式相匹配的子串并且函数调用给出了第三个参数 regs，则匹配项将被存入 regs 数组中。$regs[1] 包含第一个左圆括号开始的子串，$regs[2] 包含第二个子串，以此类推。$regs[0] 包含整个匹配的字符串。

Note: 直到 PHP 4.1.0 为止，$regs 将被填充为正好十个单元，即使实际匹配的子串少于十个。这并不影响 ereg() 匹配更多子串的能力。如果没有找到匹配，则 $regs 不会被 ereg() 更改。

如果在 string 中找到 pattern 模式的匹配则返回 所匹配字符串的长度，如果没有找到匹配或出错则返回 false。如果没有传递入可选参数 regs 或者所匹配的字符串长度为 0，则本函数返回 1。

以下代码片断接受 ISO 格式的日期（YYYY-MM-DD）然后以 DD.MM.YYYY 格式显示：

Example #1 ereg() 例子

<?php
if (ereg ("([0-9]{4})-([0-9]{1,2})-([0-9]{1,2})", $date, $regs)) {
    echo "$regs[3].$regs[2].$regs[1]";
} else {
    echo "Invalid date format: $date";
}
?>

参见 eregi()，ereg_replace()，eregi_replace()，preg_match()，strpos() 和 strstr()。


不区分大小写的正则表达式替换

  • ? ereg
  • eregi ?
  • PHP Manual
  • POSIX 正则表达式函数
  • 不区分大小写的正则表达式替换

eregi_replace

(PHP 4, PHP 5)

eregi_replace — 不区分大小写的正则表达式替换

说明

eregi_replace ( string $pattern , string $replacement , string $string ) : string

本函数和 ereg_replace() 完全相同，只除了在匹配字母字符时忽略大小写的区别。

Example #1 高亮搜索结果

<?php
$pattern = '(>[^<]*)('. quotemeta($_GET['search']) .')';
$replacement = '\\1<span class="search">\\2</span>';
$body = eregi_replace($pattern, $replacement, $body);
?>

参见 ereg()，eregi() 和 ereg_replace()。


不区分大小写的正则表达式匹配

  • ? eregi_replace
  • split ?
  • PHP Manual
  • POSIX 正则表达式函数
  • 不区分大小写的正则表达式匹配

eregi

(PHP 4, PHP 5)

eregi — 不区分大小写的正则表达式匹配

说明

eregi ( string $pattern , string $string , array &$regs = ? ) : int

本函数和 ereg() 完全相同，只除了在匹配字母字符时忽略大小写的区别。

Example #1 eregi() 例子

<?php
$string = 'XYZ';
   if (eregi('z', $string)) {
    echo "'$string' contains a 'z' or 'Z'!";
}
?>

参见 ereg()，ereg_replace()，eregi_replace()，stripos() 和 stristr()。


用正则表达式将字符串分割到数组中

  • ? eregi
  • spliti ?
  • PHP Manual
  • POSIX 正则表达式函数
  • 用正则表达式将字符串分割到数组中

split

(PHP 4, PHP 5)

split — 用正则表达式将字符串分割到数组中

说明

split ( string $pattern , string $string , int $limit = ? ) : array
Tip

preg_split() 函数使用了 Perl 兼容正则表达式语法，通常是比 split() 更快的替代方案。如果不需要正则表达式的威力，则使用 explode() 更快，这样就不会招致正则表达式引擎的浪费。

本函数返回一个字符串数组，每个单元为 string 经区分大小写的正则表达式 pattern 作为边界分割出的子串。如果设定了 limit，则返回的数组最多包含 limit 个单元，而其中最后一个单元包含了 string 中剩余的所有部分。如果出错，则 split() 返回 false。

将 /etc/passwd 中的前四个字段分割出来：

Example #1 split() 例子

<?php
list($user, $pass, $uid, $gid, $extra) =
    split (":", $passwd_line, 5);
?>

如果字符串中有 n 个与 pattern 匹配的项目，则返回的数组将包含 n+1 个单元。例如，如果没有找到 pattern，则会返回一个只有一个单元的数组。当然，如果 string 为空也是这样。

解析可能用斜线，点，或横线分割的日期：

Example #2 split() 例子

<?php
// 分隔符可以是斜线，点，或横线
$date = "04/30/1973";
list($month, $day, $year) = split ('[/.-]', $date);
echo "Month: $month; Day: $day; Year: $year<br />\n";
?>

想仿效 Perl 中类似的 @chars = split('', $str) 行为，请参考 preg_split() 或 str_split() 函数中的例子。

注意 pattern 是一个正则表达式。如果想要用的分割字符是正则表达式中的特殊字符，要先将其转义。如果觉得 split()（或其它任何 regex 函数）行为古怪的话，请阅读包含在 PHP 发行包中 regex/ 子目录下的 regex.7 文件。该文件是手册页面格式，可以用类似 man /usr/local/src/regex/regex.7 的命令来阅读。

参见 preg_split()，spliti()，str_split()，explode()，implode()，chunk_split() 和 wordwrap()。


用正则表达式不区分大小写将字符串分割到数组中

  • ? split
  • sql_regcase ?
  • PHP Manual
  • POSIX 正则表达式函数
  • 用正则表达式不区分大小写将字符串分割到数组中

spliti

(PHP 4 >= 4.0.1, PHP 5)

spliti — 用正则表达式不区分大小写将字符串分割到数组中

说明

spliti ( string $pattern , string $string , int $limit = -1 ) : array

用正则表达式将一个 string 分割成数组。

本函数和 split() 相同，只除了在匹配字母字符时忽略大小写的区别。

Warning

自 PHP 5.3.0 起，已经废弃此函数。强烈建议不要应用此函数。

参数

pattern

大小写不敏感的正则表达式。

If you want to split on any of the characters which are considered special by regular expressions, you'll need to escape them first. If you think spliti() (or any other regex function, for that matter) is doing something weird, please read the file regex.7, included in the regex/ subdirectory of the PHP distribution. It's in manpage format, so you'll want to do something along the lines of man /usr/local/src/regex/regex.7 in order to read it.

string

输入的字符。

limit

如果设置了 limit，返回的数组最多会包含 limit 个元素，最后一个元素包含了剩下的全部 string。

返回值

Returns an array of strings, each of which is a substring of string formed by splitting it on boundaries formed by the case insensitive regular expression pattern.

If there are n occurrences of pattern, the returned array will contain n+1 items. For example, if there is no occurrence of pattern, an array with only one element will be returned. Of course, this is also true if string is empty. If an error occurs, spliti() returns false.

范例

本例用 'a' 做分隔符来分割一个字符串：

Example #1 spliti() 例子

<?php
$string = "aBBBaCCCADDDaEEEaGGGA";
$chunks = spliti ("a", $string, 5);
print_r($chunks);
?>

以上例程会输出：

Array
(
  [0] =>
  [1] => BBB
  [2] => CCC
  [3] => DDD
  [4] => EEEaGGGA
)

注释

参见

  • preg_split() - 通过一个正则表达式分隔字符串
  • split() - 用正则表达式将字符串分割到数组中
  • explode() - 使用一个字符串分割另一个字符串
  • implode() - 将一个一维数组的值转化为字符串


产生用于不区分大小的匹配的正则表达式

  • ? spliti
  • ssdeep ?
  • PHP Manual
  • POSIX 正则表达式函数
  • 产生用于不区分大小的匹配的正则表达式

sql_regcase

(PHP 4, PHP 5)

sql_regcase — 产生用于不区分大小的匹配的正则表达式

说明

sql_regcase ( string $string ) : string

产生用于不区分大小的匹配的正则表达式

Warning

自 PHP 5.3.0 起，已经废弃此函数。强烈建议不要应用此函数。

参数

string

输入的字符。

返回值

返回与 string 相匹配的正则表达式，不论大小写字母。返回的表达式是将 string 中的每个字母字符转换为方括号表达式，该方括号表达式包含了该字母的大小写形式。其它字符保留不变。

范例

Example #1 sql_regcase() 例子

<?php
echo sql_regcase("Foo - bar.");
?>

以上例程会输出：

[Ff][Oo][Oo] - [Bb][Aa][Rr].

可以用于在仅支持区分大小写正则表达式的产品中完成不区分大小写的模式匹配。

注释


ssdeep Fuzzy Hashing

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • ssdeep 函数
    • ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures
    • ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file
    • ssdeep_fuzzy_hash — Create a fuzzy hash from a string


简介

ssdeep is a utility for creating and comparing fuzzy hashes or » context-triggered piecewise hashing.

Fuzzy hashing can match signatures which have "...sequences of identical bytes in the same order, although bytes in between these sequences may be different in both content and length". (» ssdeep project page)

This extension provides functions for creating and comparing fuzzy hashes.


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

This extension requires the » ssdeep library.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ssdeep.


  • ? 资源类型
  • ssdeep 函数 ?
  • PHP Manual
  • ssdeep
  • 预定义常量

预定义常量

此扩展没有定义常量。


ssdeep 函数

Table of Contents

  • ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures
  • ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file
  • ssdeep_fuzzy_hash — Create a fuzzy hash from a string


Calculates the match score between two fuzzy hash signatures

  • ? ssdeep 函数
  • ssdeep_fuzzy_hash_filename ?
  • PHP Manual
  • ssdeep 函数
  • Calculates the match score between two fuzzy hash signatures

ssdeep_fuzzy_compare

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures

说明

ssdeep_fuzzy_compare ( string $signature1 , string $signature2 ) : int

Calculates the match score between signature1 and signature2 using » context-triggered piecewise hashing, and returns the match score.

参数

signature1

The first fuzzy hash signature string.

signature2

The second fuzzy hash signature string.

返回值

Returns an integer from 0 to 100 on success, false otherwise.


Create a fuzzy hash from a file

  • ? ssdeep_fuzzy_compare
  • ssdeep_fuzzy_hash ?
  • PHP Manual
  • ssdeep 函数
  • Create a fuzzy hash from a file

ssdeep_fuzzy_hash_filename

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file

说明

ssdeep_fuzzy_hash_filename ( string $file_name ) : string

ssdeep_fuzzy_hash_filename() calculates the hash of the file specified by file_name using » context-triggered piecewise hashing, and returns that hash.

参数

file_name

The filename of the file to hash.

返回值

Returns a string on success, false otherwise.


Create a fuzzy hash from a string

  • ? ssdeep_fuzzy_hash_filename
  • 字符串 ?
  • PHP Manual
  • ssdeep 函数
  • Create a fuzzy hash from a string

ssdeep_fuzzy_hash

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_hash — Create a fuzzy hash from a string

说明

ssdeep_fuzzy_hash ( string $to_hash ) : string

ssdeep_fuzzy_hash() calculates the hash of to_hash using » context-triggered piecewise hashing, and returns that hash.

参数

to_hash

The input string.

返回值

Returns a string on success, false otherwise.


字符串

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 字符串 函数
    • addcslashes — 以 C 语言风格使用反斜线转义字符串中的字符
    • addslashes — 使用反斜线引用字符串
    • bin2hex — 函数把包含数据的二进制字符串转换为十六进制值
    • chop — rtrim 的别名
    • chr — 返回指定的字符
    • chunk_split — 将字符串分割成小块
    • convert_cyr_string — 将字符由一种 Cyrillic 字符转换成另一种
    • convert_uudecode — 解码一个 uuencode 编码的字符串
    • convert_uuencode — 使用 uuencode 编码一个字符串
    • count_chars — 返回字符串所用字符的信息
    • crc32 — 计算一个字符串的 crc32 多项式
    • crypt — 单向字符串散列
    • echo — 输出一个或多个字符串
    • explode — 使用一个字符串分割另一个字符串
    • fprintf — 将格式化后的字符串写入到流
    • get_html_translation_table — 返回使用 htmlspecialchars 和 htmlentities 后的转换表
    • hebrev — 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew）
    • hebrevc — 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew），并且转换换行符
    • hex2bin — 转换十六进制字符串为二进制字符串
    • html_entity_decode — Convert HTML entities to their corresponding characters
    • htmlentities — 将字符转换为 HTML 转义字符
    • htmlspecialchars_decode — 将特殊的 HTML 实体转换回普通字符
    • htmlspecialchars — 将特殊字符转换为 HTML 实体
    • implode — 将一个一维数组的值转化为字符串
    • join — 别名 implode
    • lcfirst — 使一个字符串的第一个字符小写
    • levenshtein — 计算两个字符串之间的编辑距离
    • localeconv — Get numeric formatting information
    • ltrim — 删除字符串开头的空白字符（或其他字符）
    • md5_file — 计算指定文件的 MD5 散列值
    • md5 — 计算字符串的 MD5 散列值
    • metaphone — Calculate the metaphone key of a string
    • money_format — 将数字格式化成货币字符串
    • nl_langinfo — Query language and locale information
    • nl2br — 在字符串所有新行之前插入 HTML 换行标记
    • number_format — 以千位分隔符方式格式化一个数字
    • ord — 转换字符串第一个字节为 0-255 之间的值
    • parse_str — 将字符串解析成多个变量
    • print — 输出字符串
    • printf — 输出格式化字符串
    • quoted_printable_decode — 将 quoted-printable 字符串转换为 8-bit 字符串
    • quoted_printable_encode — 将 8-bit 字符串转换成 quoted-printable 字符串
    • quotemeta — 转义元字符集
    • rtrim — 删除字符串末端的空白字符（或者其他字符）
    • setlocale — 设置地区信息
    • sha1_file — 计算文件的 sha1 散列值
    • sha1 — 计算字符串的 sha1 散列值
    • similar_text — 计算两个字符串的相似度
    • soundex — Calculate the soundex key of a string
    • sprintf — Return a formatted string
    • sscanf — 根据指定格式解析输入的字符
    • str_contains — Determine if a string contains a given substring
    • str_ends_with — Checks if a string ends with a given substring
    • str_getcsv — 解析 CSV 字符串为一个数组
    • str_ireplace — str_replace 的忽略大小写版本
    • str_pad — 使用另一个字符串填充字符串为指定长度
    • str_repeat — 重复一个字符串
    • str_replace — 子字符串替换
    • str_rot13 — 对字符串执行 ROT13 转换
    • str_shuffle — 随机打乱一个字符串
    • str_split — 将字符串转换为数组
    • str_starts_with — Checks if a string starts with a given substring
    • str_word_count — 返回字符串中单词的使用情况
    • strcasecmp — 二进制安全比较字符串（不区分大小写）
    • strchr — 别名 strstr
    • strcmp — 二进制安全字符串比较
    • strcoll — 基于区域设置的字符串比较
    • strcspn — 获取不匹配遮罩的起始子字符串的长度
    • strip_tags — 从字符串中去除 HTML 和 PHP 标记
    • stripcslashes — 反引用一个使用 addcslashes 转义的字符串
    • stripos — 查找字符串首次出现的位置（不区分大小写）
    • stripslashes — 反引用一个引用字符串
    • stristr — strstr 函数的忽略大小写版本
    • strlen — 获取字符串长度
    • strnatcasecmp — 使用“自然顺序”算法比较字符串（不区分大小写）
    • strnatcmp — 使用自然排序算法比较字符串
    • strncasecmp — 二进制安全比较字符串开头的若干个字符（不区分大小写）
    • strncmp — 二进制安全比较字符串开头的若干个字符
    • strpbrk — 在字符串中查找一组字符的任何一个字符
    • strpos — 查找字符串首次出现的位置
    • strrchr — 查找指定字符在字符串中的最后一次出现
    • strrev — 反转字符串
    • strripos — 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
    • strrpos — 计算指定字符串在目标字符串中最后一次出现的位置
    • strspn — 计算字符串中全部字符都存在于指定字符集合中的第一段子串的长度。
    • strstr — 查找字符串的首次出现
    • strtok — 标记分割字符串
    • strtolower — 将字符串转化为小写
    • strtoupper — 将字符串转化为大写
    • strtr — 转换指定字符
    • substr_compare — 二进制安全比较字符串（从偏移位置比较指定长度）
    • substr_count — 计算字串出现的次数
    • substr_replace — 替换字符串的子串
    • substr — 返回字符串的子串
    • trim — 去除字符串首尾处的空白字符（或者其他字符）
    • ucfirst — 将字符串的首字母转换为大写
    • ucwords — 将字符串中每个单词的首字母转换为大写
    • vfprintf — 将格式化字符串写入流
    • vprintf — 输出格式化字符串
    • vsprintf — 返回格式化字符串
    • wordwrap — 打断字符串为指定数量的字串
  • 更新日志


简介

这些都是以各种方式处理字符串的函数。还有一些专门的章节位于正则表达式和 URL 处理部分。

关于字符串的运转机制，特别是关于单引号、双引号、转义序列的信息，参见本手册的字符串条目，其位于手册中的类型章节。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

CRYPT_SALT_LENGTH integer
CRYPT_STD_DES integer
CRYPT_EXT_DES integer
CRYPT_MD5 integer
CRYPT_BLOWFISH integer
HTML_SPECIALCHARS (integer)
HTML_ENTITIES (integer)
ENT_COMPAT (integer)
ENT_QUOTES (integer)
ENT_NOQUOTES (integer)
ENT_IGNORE (integer)
ENT_SUBSTITUTE (integer)
ENT_DISALLOWED (integer)
ENT_HTML401 (integer)
ENT_XML1 (integer)
ENT_XHTML (integer)
ENT_HTML5 (integer)
CHAR_MAX (integer)
LC_CTYPE (integer)
LC_NUMERIC (integer)
LC_TIME (integer)
LC_COLLATE (integer)
LC_MONETARY (integer)
LC_ALL (integer)
LC_MESSAGES (integer)
STR_PAD_LEFT (integer)
STR_PAD_RIGHT (integer)
STR_PAD_BOTH (integer)


字符串 函数

参见

更多强大的字符串处理函数，参见 Perl 兼容正则表达式函数。 需要处理多字节字符集，参见 多字节字符函数。

Table of Contents

  • addcslashes — 以 C 语言风格使用反斜线转义字符串中的字符
  • addslashes — 使用反斜线引用字符串
  • bin2hex — 函数把包含数据的二进制字符串转换为十六进制值
  • chop — rtrim 的别名
  • chr — 返回指定的字符
  • chunk_split — 将字符串分割成小块
  • convert_cyr_string — 将字符由一种 Cyrillic 字符转换成另一种
  • convert_uudecode — 解码一个 uuencode 编码的字符串
  • convert_uuencode — 使用 uuencode 编码一个字符串
  • count_chars — 返回字符串所用字符的信息
  • crc32 — 计算一个字符串的 crc32 多项式
  • crypt — 单向字符串散列
  • echo — 输出一个或多个字符串
  • explode — 使用一个字符串分割另一个字符串
  • fprintf — 将格式化后的字符串写入到流
  • get_html_translation_table — 返回使用 htmlspecialchars 和 htmlentities 后的转换表
  • hebrev — 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew）
  • hebrevc — 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew），并且转换换行符
  • hex2bin — 转换十六进制字符串为二进制字符串
  • html_entity_decode — Convert HTML entities to their corresponding characters
  • htmlentities — 将字符转换为 HTML 转义字符
  • htmlspecialchars_decode — 将特殊的 HTML 实体转换回普通字符
  • htmlspecialchars — 将特殊字符转换为 HTML 实体
  • implode — 将一个一维数组的值转化为字符串
  • join — 别名 implode
  • lcfirst — 使一个字符串的第一个字符小写
  • levenshtein — 计算两个字符串之间的编辑距离
  • localeconv — Get numeric formatting information
  • ltrim — 删除字符串开头的空白字符（或其他字符）
  • md5_file — 计算指定文件的 MD5 散列值
  • md5 — 计算字符串的 MD5 散列值
  • metaphone — Calculate the metaphone key of a string
  • money_format — 将数字格式化成货币字符串
  • nl_langinfo — Query language and locale information
  • nl2br — 在字符串所有新行之前插入 HTML 换行标记
  • number_format — 以千位分隔符方式格式化一个数字
  • ord — 转换字符串第一个字节为 0-255 之间的值
  • parse_str — 将字符串解析成多个变量
  • print — 输出字符串
  • printf — 输出格式化字符串
  • quoted_printable_decode — 将 quoted-printable 字符串转换为 8-bit 字符串
  • quoted_printable_encode — 将 8-bit 字符串转换成 quoted-printable 字符串
  • quotemeta — 转义元字符集
  • rtrim — 删除字符串末端的空白字符（或者其他字符）
  • setlocale — 设置地区信息
  • sha1_file — 计算文件的 sha1 散列值
  • sha1 — 计算字符串的 sha1 散列值
  • similar_text — 计算两个字符串的相似度
  • soundex — Calculate the soundex key of a string
  • sprintf — Return a formatted string
  • sscanf — 根据指定格式解析输入的字符
  • str_contains — Determine if a string contains a given substring
  • str_ends_with — Checks if a string ends with a given substring
  • str_getcsv — 解析 CSV 字符串为一个数组
  • str_ireplace — str_replace 的忽略大小写版本
  • str_pad — 使用另一个字符串填充字符串为指定长度
  • str_repeat — 重复一个字符串
  • str_replace — 子字符串替换
  • str_rot13 — 对字符串执行 ROT13 转换
  • str_shuffle — 随机打乱一个字符串
  • str_split — 将字符串转换为数组
  • str_starts_with — Checks if a string starts with a given substring
  • str_word_count — 返回字符串中单词的使用情况
  • strcasecmp — 二进制安全比较字符串（不区分大小写）
  • strchr — 别名 strstr
  • strcmp — 二进制安全字符串比较
  • strcoll — 基于区域设置的字符串比较
  • strcspn — 获取不匹配遮罩的起始子字符串的长度
  • strip_tags — 从字符串中去除 HTML 和 PHP 标记
  • stripcslashes — 反引用一个使用 addcslashes 转义的字符串
  • stripos — 查找字符串首次出现的位置（不区分大小写）
  • stripslashes — 反引用一个引用字符串
  • stristr — strstr 函数的忽略大小写版本
  • strlen — 获取字符串长度
  • strnatcasecmp — 使用“自然顺序”算法比较字符串（不区分大小写）
  • strnatcmp — 使用自然排序算法比较字符串
  • strncasecmp — 二进制安全比较字符串开头的若干个字符（不区分大小写）
  • strncmp — 二进制安全比较字符串开头的若干个字符
  • strpbrk — 在字符串中查找一组字符的任何一个字符
  • strpos — 查找字符串首次出现的位置
  • strrchr — 查找指定字符在字符串中的最后一次出现
  • strrev — 反转字符串
  • strripos — 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
  • strrpos — 计算指定字符串在目标字符串中最后一次出现的位置
  • strspn — 计算字符串中全部字符都存在于指定字符集合中的第一段子串的长度。
  • strstr — 查找字符串的首次出现
  • strtok — 标记分割字符串
  • strtolower — 将字符串转化为小写
  • strtoupper — 将字符串转化为大写
  • strtr — 转换指定字符
  • substr_compare — 二进制安全比较字符串（从偏移位置比较指定长度）
  • substr_count — 计算字串出现的次数
  • substr_replace — 替换字符串的子串
  • substr — 返回字符串的子串
  • trim — 去除字符串首尾处的空白字符（或者其他字符）
  • ucfirst — 将字符串的首字母转换为大写
  • ucwords — 将字符串中每个单词的首字母转换为大写
  • vfprintf — 将格式化字符串写入流
  • vprintf — 输出格式化字符串
  • vsprintf — 返回格式化字符串
  • wordwrap — 打断字符串为指定数量的字串


以 C 语言风格使用反斜线转义字符串中的字符

  • ? 字符串 函数
  • addslashes ?
  • PHP Manual
  • 字符串 函数
  • 以 C 语言风格使用反斜线转义字符串中的字符

addcslashes

(PHP 4, PHP 5, PHP 7, PHP 8)

addcslashes — 以 C 语言风格使用反斜线转义字符串中的字符

说明

addcslashes ( string $str , string $charlist ) : string

返回字符串，该字符串在属于参数 charlist 列表中的字符前都加上了反斜线。

参数

str

要转义的字符。

charlist

如果 charlist 中包含有 \n，\r 等字符，将以 C 语言风格转换，而其它非字母数字且 ASCII 码低于 32 以及高于 126 的字符均转换成使用八进制表示。

当定义 charlist 参数中的字符序列时，需要确实知道介于自己设置的开始及结束范围之内的都是些什么字符。

<?php
echo addcslashes('foo[ ]', 'A..z');
// 输出：\f\o\o\[ \]
// 所有大小写字母均被转义
// ... 但 [\]^_` 以及分隔符、换行符、回车符等也一并被转义了。
?>
另外，如果设置范围中的结束字符 ASCII 码高于开始字符，则不会创建范围，只是将开始字符、结束字符以及其间的字符逐个转义。可使用 ord() 函数获取字符的 ASCII 码值。
<?php
echo addcslashes("zoo['.']", 'z..A');
// 输出：\zoo['\.']
?>

当选择对字符 0，a，b，f，n，r，t 和 v 进行转义时需要小心，它们将被转换成 \0，\a，\b，\f，\n，\r，\t 和 \v。在 PHP 中，只有 \0（NULL），\r（回车符），\n（换行符）和 \t（制表符）是预定义的转义序列， 而在 C 语言中，上述的所有转换后的字符都是预定义的转义序列。

返回值

返回转义后的字符。

更新日志

版本 | 说明
5.2.5 | The escape sequences \v and \f were added.

范例

charlist 参数，如"\0..\37"，将转义所有 ASCII 码介于 0 和 31 之间的字符。

Example #1 addcslashes() 例子

<?php
$escaped = addcslashes($not_escaped, "\0..\37!@\177..\377");
?>

参见

  • stripcslashes() - 反引用一个使用 addcslashes 转义的字符串
  • stripslashes() - 反引用一个引用字符串
  • addslashes() - 使用反斜线引用字符串
  • htmlspecialchars() - 将特殊字符转换为 HTML 实体
  • quotemeta() - 转义元字符集


使用反斜线引用字符串

  • ? addcslashes
  • bin2hex ?
  • PHP Manual
  • 字符串 函数
  • 使用反斜线引用字符串

addslashes

(PHP 4, PHP 5, PHP 7, PHP 8)

addslashes — 使用反斜线引用字符串

说明

addslashes ( string $str ) : string

返回字符串，该字符串为了数据库查询语句等的需要在某些字符前加上了反斜线。这些字符是单引号（'）、双引号（"）、反斜线（\）与 NUL（null 字符）。

一个使用 addslashes() 的例子是当你要往数据库中输入数据时。 例如，将名字 O'reilly 插入到数据库中，这就需要对其进行转义。 强烈建议使用 DBMS 指定的转义函数 （比如 MySQL 是 mysqli_real_escape_string()，PostgreSQL 是 pg_escape_string()），但是如果你使用的 DBMS 没有一个转义函数，并且使用 \ 来转义特殊字符，你可以使用这个函数。 仅仅是为了获取插入数据库的数据，额外的 \ 并不会插入。 当 PHP 指令 magic_quotes_sybase 被设置成 on 时，意味着插入 ' 时将使用 ' 进行转义。

PHP 5.4 之前 PHP 指令 magic_quotes_gpc 默认是 on， 实际上所有的 GET、POST 和 COOKIE 数据都用被 addslashes() 了。 不要对已经被 magic_quotes_gpc 转义过的字符串使用 addslashes()，因为这样会导致双层转义。 遇到这种情况时可以使用函数 get_magic_quotes_gpc() 进行检测。

参数

str

要转义的字符。

返回值

返回转义后的字符。

范例

Example #1 一个 addslashes() 例子

<?php
$str = "Is your name O'reilly?";

// 输出： Is your name O\'reilly?
echo addslashes($str);
?>

参见

  • stripcslashes() - 反引用一个使用 addcslashes 转义的字符串
  • stripslashes() - 反引用一个引用字符串
  • addcslashes() - 以 C 语言风格使用反斜线转义字符串中的字符
  • htmlspecialchars() - 将特殊字符转换为 HTML 实体
  • quotemeta() - 转义元字符集
  • get_magic_quotes_gpc() - 获取当前 magic_quotes_gpc 的配置选项设置


函数把包含数据的二进制字符串转换为十六进制值

  • ? addslashes
  • chop ?
  • PHP Manual
  • 字符串 函数
  • 函数把包含数据的二进制字符串转换为十六进制值

bin2hex

(PHP 4, PHP 5, PHP 7, PHP 8)

bin2hex — 函数把包含数据的二进制字符串转换为十六进制值

说明

bin2hex ( string $str ) : string

把二进制的参数 str 转换为的十六进制的字符串。转换使用字节方式，高四位字节优先。

参数

str

二进制字符串。

返回值

返回指定字符串十六进制的表示。

参见

  • hex2bin() - 转换十六进制字符串为二进制字符串
  • pack() - 将数据打包成二进制字符串


rtrim 的别名

  • ? bin2hex
  • chr ?
  • PHP Manual
  • 字符串 函数
  • rtrim 的别名

chop

(PHP 4, PHP 5, PHP 7, PHP 8)

chop — rtrim() 的别名

说明

此函数是该函数的别名：rtrim()。

注释

Note:

chop() 与 Perl 的 chop() 函数有所不同，它会删除字符串的最后一个字符。


返回指定的字符

  • ? chop
  • chunk_split ?
  • PHP Manual
  • 字符串 函数
  • 返回指定的字符

chr

(PHP 4, PHP 5, PHP 7, PHP 8)

chr — 返回指定的字符

说明

chr ( int $ascii ) : string

返回相对应于 ascii 所指定的单个字符。

此函数与 ord() 是互补的。

参数

ascii

Ascii 码。

返回值

返回规定的字符。

范例

Example #1 chr() 例子

<?php
$str = "The string ends in escape: ";
$str .= chr(27); /* 在 $str 后边增加换码符 */

/* 通常这样更有用 */

$str = sprintf("The string ends in escape: %c", 27);
?>

参见

  • sprintf() - Return a formatted string 如何使用格式字符串 %c。
  • ord()
  • 可以在此处找到 ASCII 码表：» https://www.man7.org/linux/man-pages/man7/ascii.7.html。


将字符串分割成小块

  • ? chr
  • convert_cyr_string ?
  • PHP Manual
  • 字符串 函数
  • 将字符串分割成小块

chunk_split

(PHP 4, PHP 5, PHP 7, PHP 8)

chunk_split — 将字符串分割成小块

说明

chunk_split ( string $body , int $chunklen = 76 , string $end = "\r\n" ) : string

使用此函数将字符串分割成小块非常有用。例如将 base64_encode() 的输出转换成符合 RFC 2045 语义的字符串。它会在每 chunklen 个字符后边插入 end。

参数

body

要分割的字符。

chunklen

分割的尺寸。

end

行尾序列符号。

返回值

返回分割后的字符。

范例

Example #1 chunk_split() 例子

<?php
// 使用 RFC 2045 语义格式化 $data
$new_string = chunk_split(base64_encode($data));
?>

参见

  • str_split() - 将字符串转换为数组
  • explode() - 使用一个字符串分割另一个字符串
  • split() - 用正则表达式将字符串分割到数组中
  • wordwrap() - 打断字符串为指定数量的字串
  • » RFC 2045


将字符由一种 Cyrillic 字符转换成另一种

  • ? chunk_split
  • convert_uudecode ?
  • PHP Manual
  • 字符串 函数
  • 将字符由一种 Cyrillic 字符转换成另一种

convert_cyr_string

(PHP 4, PHP 5, PHP 7)

convert_cyr_string — 将字符由一种 Cyrillic 字符转换成另一种

说明

convert_cyr_string ( string $str , string $from , string $to ) : string

此函数将给定的字符串从一种 Cyrillic 字符转换成另一种，返回转换之后的字符串。

参数

str

要转换的字符。

from

单个字符，代表源 Cyrillic 字符集。

to

单个字符，代表了目标 Cyrillic 字符集。

支持的类型有：

  • k - koi8-r
  • w - windows-1251
  • i - iso8859-5
  • a - x-cp866
  • d - x-cp866
  • m - x-mac-cyrillic

返回值

返回转换后的字符串。

注释

Note: 此函数可安全用于二进制对象。


解码一个 uuencode 编码的字符串

  • ? convert_cyr_string
  • convert_uuencode ?
  • PHP Manual
  • 字符串 函数
  • 解码一个 uuencode 编码的字符串

convert_uudecode

(PHP 5, PHP 7, PHP 8)

convert_uudecode — 解码一个 uuencode 编码的字符串

说明

convert_uudecode ( string $data ) : string

convert_uudecode() 解码一个 uuencode 编码的字符串。

参数

data

uuencode 编码后的数据

返回值

返回解码后的字符串数据， 或者在失败时返回 false.。

范例

Example #1 convert_uudecode() 例子

<?php
/* 你猜会输出啥？:) */
echo convert_uudecode("+22!L;W9E(%!(4\"$`\n`");
?>

参见

  • convert_uuencode() - 使用 uuencode 编码一个字符串


使用 uuencode 编码一个字符串

  • ? convert_uudecode
  • count_chars ?
  • PHP Manual
  • 字符串 函数
  • 使用 uuencode 编码一个字符串

convert_uuencode

(PHP 5, PHP 7, PHP 8)

convert_uuencode — 使用 uuencode 编码一个字符串

说明

convert_uuencode ( string $data ) : string

convert_uuencode() 使用 uuencode 算法对一个字符串进行编码。

uuencode 算法会将所有（含二进制数据）字符串转化为可输出的字符， 并且可以被安全的应用于网络传输。使用 uuencode 编码后的数据 将会比源数据大35%左右

参数

data

需要被编码的数据。

返回值

返回 uuencode 编码后的数据 或者在失败时返回 false。

范例

Example #1 convert_uuencode() 例子

<?php
$some_string = "test\ntext text\r\n";

echo convert_uuencode($some_string);
?>

参见

  • convert_uudecode() - 解码一个 uuencode 编码的字符串
  • base64_encode() - 使用 MIME base64 对数据进行编码


返回字符串所用字符的信息

  • ? convert_uuencode
  • crc32 ?
  • PHP Manual
  • 字符串 函数
  • 返回字符串所用字符的信息

count_chars

(PHP 4, PHP 5, PHP 7, PHP 8)

count_chars — 返回字符串所用字符的信息

说明

count_chars ( string $string , int $mode = 0 ) : mixed

统计 string 中每个字节值（0..255）出现的次数，使用多种模式返回结果。

参数

string

需要统计的字符串。

mode

参见返回的值。

返回值

根据不同的 mode，count_chars() 返回下列不同的结果：

  • 0 - 以所有的每个字节值作为键名，出现次数作为值的数组。
  • 1 - 与 0 相同，但只列出出现次数大于零的字节值。
  • 2 - 与 0 相同，但只列出出现次数等于零的字节值。
  • 3 - 返回由所有使用了的字节值组成的字符串。
  • 4 - 返回由所有未使用的字节值组成的字符串。

范例

Example #1 count_chars() 示例

<?php
$data = "Two Ts and one F.";

foreach (count_chars($data, 1) as $i => $val) {
   echo "There were $val instance(s) of \"" , chr($i) , "\" in the string.\n";
}
?>

以上例程会输出：

There were 4 instance(s) of " " in the string.
There were 1 instance(s) of "." in the string.
There were 1 instance(s) of "F" in the string.
There were 2 instance(s) of "T" in the string.
There were 1 instance(s) of "a" in the string.
There were 1 instance(s) of "d" in the string.
There were 1 instance(s) of "e" in the string.
There were 2 instance(s) of "n" in the string.
There were 2 instance(s) of "o" in the string.
There were 1 instance(s) of "s" in the string.
There were 1 instance(s) of "w" in the string.

参见

  • strpos() - 查找字符串首次出现的位置
  • substr_count() - 计算字串出现的次数


计算一个字符串的 crc32 多项式

  • ? count_chars
  • crypt ?
  • PHP Manual
  • 字符串 函数
  • 计算一个字符串的 crc32 多项式

crc32

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

crc32 — 计算一个字符串的 crc32 多项式

说明

crc32 ( string $str ) : int

生成 str 的 32 位循环冗余校验码多项式。这通常用于检查传输的数据是否完整。

Warning

由于 PHP 的整数是带符号的，所以在 32 位系统上许多 crc32 校验码将返回负整数。 尽管在 64 位上所有 crc32() 的结果将都是正整数。

因此你需要使用 sprintf() 或 printf() 的"%u"格式符来获取表示无符号 crc32 校验码的字符串。

For a hexadecimal representation of the checksum you can either use the "%x" formatter of sprintf() or printf() or the dechex() conversion functions, both of these also take care of converting the crc32() result to an unsigned integer.

Having 64bit installations also return negative integers for higher result values was considered but would break the hexadecimal conversion as negatives would get an extra 0xFFFFFFFF######## offset then. As hexadecimal representation seems to be the most common use case we decided to not break this even if it breaks direct decimal comparisons in about 50% of the cases when moving from 32 to 64bits.

In retrospect having the function return an integer maybe wasn't the best idea and returning a hex string representation right away (as e.g. md5() does) might have been a better plan to begin with.

For a more portable solution you may also consider the generic hash(). hash("crc32b", $str) will return the same string as dechex(crc32($str)).

参数

str

要校验的数据。

返回值

返回 str crc32 校验的整数。

范例

Example #1 显示一个 crc32 校验码

示例中的第二行演示了如何使用 printf() 函数转换校验码：

<?php
$checksum = crc32("The quick brown fox jumped over the lazy dog.");
printf("%u\n", $checksum);
?>

参见

  • hash() - 生成哈希值 （消息摘要）
  • md5() - 计算字符串的 MD5 散列值
  • sha1() - 计算字符串的 sha1 散列值


单向字符串散列

  • ? crc32
  • echo ?
  • PHP Manual
  • 字符串 函数
  • 单向字符串散列

crypt

(PHP 4, PHP 5, PHP 7, PHP 8)

crypt — 单向字符串散列

说明

crypt ( string $str , string $salt = ? ) : string

crypt() 返回一个基于标准 UNIX DES 算法或系统上其他可用的替代算法的散列字符串。

salt 参数是可选的。然而，如果没有salt的话，crypt()创建出来的会是弱密码。 php 5.6及之后的版本会在没有它的情况下抛出一个 E_NOTICE 级别的错误。为了更好的安全性，请确保指定一个足够强度的盐值。

password_hash()使用了一个强的哈希算法，来产生足够强的盐值，并且会自动进行合适的轮次。password_hash()是crypt()的一个简单封装，并且完全与现有的密码哈希兼容。推荐使用password_hash()。

有些系统支持不止一种散列类型。实际上，有时候，基于 MD5 的算法被用来替代基于标准 DES 的算法。这种散列类型由盐值参数触发。在 5.3 之前，PHP 在安装时根据系统的 crypt() 决定可用的算法。如果没有提供盐值，PHP 将自动生成一个 2 个字符（DES）或者 12 个字符（MD5）的盐值 ，这取决于 MD5 crypt() 的可用性。PHP 设置了一个名为 CRYPT_SALT_LENGTH 的常量，用来表示可用散列允许的最长可用盐值。

基于标准 DES 算法的 crypt() 在输出内容的开始位置返回两个字符的盐值。它也只使用 str 的开始 8 个字符，所以更长的以相同 8 个字符开始的字符串也将生成相同的结果（当使用了相同的盐值时）。

在 crypt() 函数支持多重散列的系统上，下面的常量根据相应的类型是否可用被设置为 0 或 1：

  • CRYPT_STD_DES - 基于标准 DES 算法的散列使用 "./0-9A-Za-z" 字符中的两个字符作为盐值。在盐值中使用非法的字符将导致 crypt() 失败。
  • CRYPT_EXT_DES - 扩展的基于 DES 算法的散列。其盐值为 9 个字符的字符串，由 1 个下划线后面跟着 4 字节循环次数和 4 字节盐值组成。它们被编码成可打印字符，每个字符 6 位，有效位最少的优先。0 到 63 被编码为 "./0-9A-Za-z"。在盐值中使用非法的字符将导致 crypt() 失败。
  • CRYPT_MD5 - MD5 散列使用一个以 $1$ 开始的 12 字符的字符串盐值。
  • CRYPT_BLOWFISH - Blowfish 算法使用如下盐值："$2a$"，一个两位 cost 参数，"$" 以及 64 位由 "./0-9A-Za-z" 中的字符组合而成的字符串。在盐值中使用此范围之外的字符将导致 crypt() 返回一个空字符串。两位 cost 参数是循环次数以 2 为底的对数，它的范围是 04-31，超出这个范围将导致 crypt() 失败。 PHP 5.3.7 之前只支持 "$2a$" 作为盐值的前缀，PHP 5.3.7 开始引入了新的前缀来修正一个在Blowfish实现上的安全风险。可以参考» this document来了解关于这个修复的更多信息。总而言之，开发者如果仅针对 PHP 5.3.7及之后版本进行开发，那应该使用 "$2y$" 而非 "$2a$"
  • CRYPT_SHA256 - SHA-256 算法使用一个以 $5$ 开头的 16 字符字符串盐值进行散列。如果盐值字符串以 "rounds=<N>$" 开头，N 的数字值将被用来指定散列循环的执行次数，这点很像 Blowfish 算法的 cost 参数。默认的循环次数是 5000，最小是 1000，最大是 999,999,999。超出这个范围的 N 将会被转换为最接近的值。
  • CRYPT_SHA512 - SHA-512 算法使用一个以 $6$ 开头的 16 字符字符串盐值进行散列。如果盐值字符串以 "rounds=<N>$" 开头，N 的数字值将被用来指定散列循环的执行次数，这点很像 Blowfish 算法的 cost 参数。默认的循环次数是 5000，最小是 1000，最大是 999,999,999。超出这个范围的 N 将会被转换为最接近的值。

Note:

从 PHP 5.3.0 起，PHP 包含了它自己的实现，并将在系统缺乏相应算法支持的时候使用它自己的实现。

参数

str

待散列的字符串。

Caution

使用 CRYPT_BLOWFISH 算法将导致str被裁剪为一个最长72个字符的字符串。

salt

可选的盐值字符串。如果没有提供，算法行为将由不同的算法实现决定，并可能导致不可预料的结束。

返回值

返回散列后的字符串或一个少于 13 字符的字符串，从而保证在失败时与盐值区分开来。

Warning

当校验密码时，应该使用一个不容易被时间攻击的字符串比较函数来比较crypt()的输出与之前已知的哈希。出于这个目的，PHP5.6开始提供了hash_equals()。

更新日志

版本 | 说明
5.6.5 | When the failure string "*0" is given as the salt, "*1" will now be returned for consistency with other crypt implementations. Prior to this version, PHP 5.6 would incorrectly return a DES hash.
5.6.0 | Raise E_NOTICE security warning if salt is omitted.
5.5.21 | When the failure string "*0" is given as the salt, "*1" will now be returned for consistency with other crypt implementations. Prior to this version, PHP 5.5 (and earlier branches) would incorrectly return a DES hash.
5.3.7 | Added $2x$ and $2y$ Blowfish modes to deal with potential high-bit attacks.
5.3.2 | 基于 Ulrich Drepper 的» 实现，新增基于 SHA-256 算法和 SHA-512 算法的 crypt。
5.3.2 | 修正了 Blowfish 算法由于非法循环导致的问题，返回"失败"字符串（"*0" 或 "*1"）而不是转而使用 DES 算法。
5.3.0 | PHP 现在包含了它自己的 MD5 Crypt 实现，包括标准 DES 算法，扩展的 DES 算法以及 Blowfish 算法。如果系统缺乏相应的实现，那么 PHP 将使用它自己的实现。

范例

Example #1 crypt() 范例

<?php
$hashed_password = crypt('mypassword'); // 自动生成盐值

/* 你应当使用 crypt() 得到的完整结果作为盐值进行密码校验，以此来避免使用不同散列算法导致的问题。（如上所述，基于标准 DES 算法的密码散列使用 2 字符盐值，但是基于 MD5 算法的散列使用 12 个字符盐值。）*/
if (hash_equals($hashed_password, crypt($user_input, $hashed_password))) {
   echo "Password verified!";
}
?>

Example #2 利用 htpasswd 进行 crypt() 加密

<?php
// 设置密码
$password = 'mypassword';

// 获取散列值，使用自动盐值
$hash = crypt($password);
?>

Example #3 以不同散列类型使用 crypt()

<?php
if (CRYPT_STD_DES == 1) {
    echo 'Standard DES: ' . crypt('rasmuslerdorf', 'rl') . "\n";
}

if (CRYPT_EXT_DES == 1) {
    echo 'Extended DES: ' . crypt('rasmuslerdorf', '_J9..rasm') . "\n";
}

if (CRYPT_MD5 == 1) {
    echo 'MD5:          ' . crypt('rasmuslerdorf', '$1$rasmusle$') . "\n";
}

if (CRYPT_BLOWFISH == 1) {
    echo 'Blowfish:     ' . crypt('rasmuslerdorf', '$2a$07$usesomesillystringforsalt$') . "\n";
}

if (CRYPT_SHA256 == 1) {
    echo 'SHA-256:      ' . crypt('rasmuslerdorf', '$5$rounds=5000$usesomesillystringforsalt$') . "\n";
}

if (CRYPT_SHA512 == 1) {
    echo 'SHA-512:      ' . crypt('rasmuslerdorf', '$6$rounds=5000$usesomesillystringforsalt$') . "\n";
}
?>

以上例程的输出类似于：

Standard DES: rl.3StKT.4T8M
Extended DES: _J9..rasmBYk8r9AiWNc
MD5:          $1$rasmusle$rISCgZzpwk3UhDidwXvin0
Blowfish:     $2a$07$usesomesillystringfore2uDLvp1Ii2e./U9C8sBjqp8I90dH6hi
SHA-256:      $5$rounds=5000$usesomesillystri$KqJWpanXZHKq2BOB43TSaYhEWsQ1Lr5QNyPCDH/Tp.6
SHA-512:      $6$rounds=5000$usesomesillystri$D4IrlXatmP7rx3P3InaxBeoomnAihCKRVQP22JZ6EY47Wc6BkroIuUUBOov1i.S5KPgErtP/EN5mcO.ChWQW21

注释

Note: 由于 crypt() 使用的是单向算法，因此不存在 decrypt 函数。

参见

  • hash_equals() - 可防止时序攻击的字符串比较
  • password_hash() - 创建密码的散列（hash）
  • md5() - 计算字符串的 MD5 散列值
  • Mcrypt 扩展
  • 更多关于 crypt 函数的信息，请阅读 Unix man 页面


输出一个或多个字符串

  • ? crypt
  • explode ?
  • PHP Manual
  • 字符串 函数
  • 输出一个或多个字符串

echo

(PHP 4, PHP 5, PHP 7, PHP 8)

echo — 输出一个或多个字符串

说明

echo ( string $arg1 , string $... = ? ) : void

输出所有参数。不会换行。

echo 不是一个函数（它是一个语言结构）， 因此你不一定要使用小括号来指明参数，单引号，双引号都可以。 echo （不像其他语言构造）不表现得像一个函数， 所以不能总是使用一个函数的上下文。 另外，如果你想给echo 传递多个参数， 那么就不能使用小括号。

echo 也有一个快捷用法，你可以在打开标记前直接用一个等号。在 PHP 5.4.0 之前，必须在php.ini 里面启用 short_open_tag 才有效。

I have <?=$foo?> foo.

和 print 最主要的不同之处是， echo 接受参数列表，并且没有返回值。

参数

arg1

要输出的参数

...

返回值

没有返回值。

范例

Example #1 echo 例子

<?php
echo "Hello World";

// Strings can either be passed individually as multiple arguments or
// concatenated together and passed as a single argument
echo 'This ', 'string ', 'was ', 'made ', 'with multiple parameters.', chr(10);
echo 'This ' . 'string ' . 'was ' . 'made ' . 'with concatenation.' . "\n";

// Because echo does not behave like a function, the following code is invalid.
($some_var) ? echo 'true' : echo 'false';

// However, the following examples will work:
($some_var) ? print 'true' : print 'false'; // print is also a construct, but
                                            // it behaves like a function, so
                                            // it may be used in this context.
echo $some_var ? 'true': 'false'; // changing the statement around
?>

注释

Note: 因为是一个语言构造器而不是一个函数，不能被 可变函数 调用。

Tip

相对 echo 中拼接字符串而言，传递多个参数比较好，考虑到了 PHP 中连接运算符（"."）的优先级。 传入多个参数，不需要圆括号保证优先级：

<?php
echo "Sum: ", 1 + 2;
echo "Hello ", isset($name) ? $name : "John Doe", "!";

如果拼接字符串，连接运算符（"."）相对于加号优先级相同，比三元运算符优先级更高。为了正确，必须使用圆括号：

<?php
echo 'Sum: ' . (1 + 2);
echo 'Hello ' . (isset($name) ? $name : 'John Doe') . '!';

参见

  • print - 输出字符串
  • printf() - 输出格式化字符串
  • flush() - 刷新输出缓冲
  • Heredoc 语法


使用一个字符串分割另一个字符串

  • ? echo
  • fprintf ?
  • PHP Manual
  • 字符串 函数
  • 使用一个字符串分割另一个字符串

explode

(PHP 4, PHP 5, PHP 7, PHP 8)

explode — 使用一个字符串分割另一个字符串

说明

explode ( string $delimiter , string $string , int $limit = ? ) : array

此函数返回由字符串组成的数组，每个元素都是 string 的一个子串，它们被字符串 delimiter 作为边界点分割出来。

参数

delimiter

边界上的分隔字符。

string

输入的字符串。

limit

如果设置了 limit 参数并且是正数，则返回的数组包含最多 limit 个元素，而最后那个元素将包含 string 的剩余部分。

如果 limit 参数是负数，则返回除了最后的 -limit 个元素外的所有元素。

如果 limit 是 0，则会被当做 1。

由于历史原因，虽然 implode() 可以接收两种参数顺序，但是 explode() 不行。你必须保证 separator 参数在 string 参数之前才行。

返回值

此函数返回由字符串组成的 array，每个元素都是 string 的一个子串，它们被字符串 delimiter 作为边界点分割出来。

如果 delimiter 为空字符串（""），explode() 将返回 false。 如果 delimiter 所包含的值在 string 中找不到，并且使用了负数的 limit ， 那么会返回空的 array， 否则返回包含 string 单个元素的数组。

更新日志

版本 | 说明
5.1.0 | 支持负数的 limit
4.0.1 | 增加了参数 limit

范例

Example #1 explode() 例子

<?php
// 示例 1
$pizza  = "piece1 piece2 piece3 piece4 piece5 piece6";
$pieces = explode(" ", $pizza);
echo $pieces[0]; // piece1
echo $pieces[1]; // piece2

// 示例 2
$data = "foo:*:1023:1000::/home/foo:/bin/sh";
list($user, $pass, $uid, $gid, $gecos, $home, $shell) = explode(":", $data);
echo $user; // foo
echo $pass; // *

?>

Example #2 explode() return examples

<?php
/* A string that doesn't contain the delimiter will simply return a one-length array of the original string. */
$input1 = "hello";
$input2 = "hello,there";
var_dump( explode( ',', $input1 ) );
var_dump( explode( ',', $input2 ) );

?>

以上例程会输出：

array(1)
(
    [0] => string(5) "hello"
)
array(2)
(
    [0] => string(5) "hello"
    [1] => string(5) "there"
)

Example #3 limit 参数的例子

<?php
$str = 'one|two|three|four';

// 正数的 limit
print_r(explode('|', $str, 2));

// 负数的 limit（自 PHP 5.1 起）
print_r(explode('|', $str, -1));
?>

以上例程会输出：

Array
(
    [0] => one
    [1] => two|three|four
)
Array
(
    [0] => one
    [1] => two
    [2] => three
)

注释

Note: 此函数可安全用于二进制对象。

参见

  • preg_split() - 通过一个正则表达式分隔字符串
  • str_split() - 将字符串转换为数组
  • mb_split() - 使用正则表达式分割多字节字符串
  • str_word_count() - 返回字符串中单词的使用情况
  • strtok() - 标记分割字符串
  • implode() - 将一个一维数组的值转化为字符串


将格式化后的字符串写入到流

  • ? explode
  • get_html_translation_table ?
  • PHP Manual
  • 字符串 函数
  • 将格式化后的字符串写入到流

fprintf

(PHP 5, PHP 7, PHP 8)

fprintf — 将格式化后的字符串写入到流

说明

fprintf ( resource $handle , string $format , mixed $... = ? ) : int

写入一个根据 format 格式化后的字符串到 由 handle 句柄打开的流中。

参数

handle

文件系统指针，是典型地由 fopen() 创建的 resource(资源)。

format

The format string is composed of zero or more directives: ordinary characters (excluding %) that are copied directly to the result and conversion specifications, each of which results in fetching its own parameter.

A conversion specification follows this prototype: %[argnum$][flags][width][.precision]specifier.

Argnum

An integer followed by a dollar sign $, to specify which number argument to treat in the conversion.

Flags
Flag | 说明
- Left-justify within the given field width; Right justification is the default
+ Prefix positive numbers with a plus sign +; Default only negative are prefixed with a negative sign.
(space) | Pads the result with spaces. This is the default.
0 | Only left-pads numbers with zeros. With s specifiers this can also right-pad with zeros.
'(char) | Pads the result with the character (char).

Width

An integer that says how many characters (minimum) this conversion should result in.

Precision

A period . followed by an integer who's meaning depends on the specifier:

  • For e, E, f and F specifiers: this is the number of digits to be printed after the decimal point (by default, this is 6).
  • For g and G specifiers: this is the maximum number of significant digits to be printed.
  • For s specifier: it acts as a cutoff point, setting a maximum character limit to the string.

Note: If the period is specified without an explicit value for precision, 0 is assumed.

Note: Attempting to use a position specifier greater than PHP_INT_MAX will generate warnings.

Specifiers
Specifier | 说明
% A literal percent character. No argument is required.
b | The argument is treated as an integer and presented as a binary number.
c | The argument is treated as an integer and presented as the character with that ASCII.
d | The argument is treated as an integer and presented as a (signed) decimal number.
e | The argument is treated as scientific notation (e.g. 1.2e+2). The precision specifier stands for the number of digits after the decimal point since PHP 5.2.1. In earlier versions, it was taken as number of significant digits (one less).
E | Like the e specifier but uses uppercase letter (e.g. 1.2E+2).
f | The argument is treated as a float and presented as a floating-point number (locale aware).
F | The argument is treated as a float and presented as a floating-point number (non-locale aware). Available as of PHP 5.0.3.
g

General format.

Let P equal the precision if nonzero, 6 if the precision is omitted, or 1 if the precision is zero. Then, if a conversion with style E would have an exponent of X:

If P > X ≥ ?4, the conversion is with style f and precision P ? (X + 1). Otherwise, the conversion is with style e and precision P ? 1.

G | Like the g specifier but uses E and f.
h | Like the g specifier but uses F. Available as of PHP 8.0.0.
H | Like the g specifier but uses E and F. Available as of PHP 8.0.0.
o | The argument is treated as an integer and presented as an octal number.
s | The argument is treated and presented as a string.
u | The argument is treated as an integer and presented as an unsigned decimal number.
x | The argument is treated as an integer and presented as a hexadecimal number (with lowercase letters).
X | The argument is treated as an integer and presented as a hexadecimal number (with uppercase letters).

Warning

The c type specifier ignores padding and width

Warning

Attempting to use a combination of the string and width specifiers with character sets that require more than one byte per character may result in unexpected results

Variables will be co-erced to a suitable type for the specifier:

Type Handling
Type | Specifiers
string | s
integer | d, u, c, o, x, X, b
double | g, G, e, E, f, F

...

返回值

返回写入的字符串长度。

范例

Example #1 fprintf(): zero-padded integers

<?php
if (!($fp = fopen('date.txt', 'w'))) {
    return;
}

fprintf($fp, "%04d-%02d-%02d", $year, $month, $day);
// will write the formatted ISO date to date.txt
?>

Example #2 fprintf(): formatting currency

<?php
if (!($fp = fopen('currency.txt', 'w'))) {
    return;
}

$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
// echo $money will output "123.1";
$len = fprintf($fp, '%01.2f', $money);
// will write "123.10" to currency.txt

echo "wrote $len bytes to currency.txt";
// use the return value of fprintf to determine how many bytes we wrote
?>

参见

  • printf() - 输出格式化字符串
  • sprintf() - Return a formatted string
  • vprintf() - 输出格式化字符串
  • vsprintf() - 返回格式化字符串
  • vfprintf() - 将格式化字符串写入流
  • sscanf() - 根据指定格式解析输入的字符
  • fscanf() - 从文件中格式化输入
  • number_format() - 以千位分隔符方式格式化一个数字
  • date() - 格式化一个本地时间／日期


返回使用 htmlspecialchars 和 htmlentities 后的转换表

  • ? fprintf
  • hebrev ?
  • PHP Manual
  • 字符串 函数
  • 返回使用 htmlspecialchars 和 htmlentities 后的转换表

get_html_translation_table

(PHP 4, PHP 5, PHP 7, PHP 8)

get_html_translation_table — 返回使用 htmlspecialchars() 和 htmlentities() 后的转换表

说明

get_html_translation_table ( int $table = HTML_SPECIALCHARS , int $flags = ENT_COMPAT | ENT_HTML401 , string $encoding = 'UTF-8' ) : array

get_html_translation_table() 将返回 htmlspecialchars() 和 htmlentities() 处理后的转换表。

Note:

特殊字符可以使用多种转换方式。 例如： " 可以被转换成 &quot;, &#34; 或者 &#x22. get_html_translation_table() 返回其中最常用的。

参数

table

有两个新的常量 (HTML_ENTITIES, HTML_SPECIALCHARS) 允许你指定你想要的表。

flags

A bitmask of one or more of the following flags, which specify which quotes the table will contain as well as which document type the table is for. The default is ENT_COMPAT | ENT_HTML401.

Available flags constants
Constant Name | Description
ENT_COMPAT | Table will contain entities for double-quotes, but not for single-quotes.
ENT_QUOTES | Table will contain entities for both double and single quotes.
ENT_NOQUOTES | Table will neither contain entities for single quotes nor for double quotes.
ENT_HTML401 | Table for HTML 4.01.
ENT_XML1 | Table for XML 1.
ENT_XHTML | Table for XHTML.
ENT_HTML5 | Table for HTML 5.

encoding

Encoding to use. If omitted, the default value for this argument is ISO-8859-1 in versions of PHP prior to 5.4.0, and UTF-8 from PHP 5.4.0 onwards.

支持以下字符集：

支持的字符集列表
字符集 | 别名 | 描述
ISO-8859-1 | ISO8859-1 | 西欧，Latin-1
ISO-8859-5 | ISO8859-5 | Little used cyrillic charset (Latin/Cyrillic).
ISO-8859-15 | ISO8859-15 | 西欧，Latin-9。增加欧元符号，法语和芬兰语字母在 Latin-1(ISO-8859-1) 中缺失。
UTF-8 | ASCII 兼容的多字节 8 位 Unicode。
cp866 | ibm866, 866 | DOS 特有的西里尔编码。本字符集在 4.3.2 版本中得到支持。
cp1251 | Windows-1251, win-1251, 1251 | Windows 特有的西里尔编码。本字符集在 4.3.2 版本中得到支持。
cp1252 | Windows-1252, 1252 | Windows 特有的西欧编码。
KOI8-R | koi8-ru, koi8r | 俄语。本字符集在 4.3.2 版本中得到支持。
BIG5 | 950 | 繁体中文，主要用于中国台湾省。
GB2312 | 936 | 简体中文，中国国家标准字符集。
BIG5-HKSCS | 繁体中文，附带香港扩展的 Big5 字符集。
Shift_JIS | SJIS, 932 | 日语
EUC-JP | EUCJP | 日语
MacRoman | Mac OS 使用的字符串。
'' An empty string activates detection from script encoding (Zend multibyte), default_charset and current locale (see nl_langinfo() and setlocale()), in this order. Not recommended.

Note: 其他字符集没有认可。将会使用默认编码并抛出异常。

返回值

将转换表作为一个数组返回。

更新日志

版本 | 说明
5.4.0 | The default value for the encoding parameter was changed to UTF-8.
5.4.0 | The constants ENT_HTML401, ENT_XML1, ENT_XHTML and ENT_HTML5 were added.
5.3.4 | The encoding parameter was added.

范例

Example #1 Translation Table Example

<?php
var_dump(get_html_translation_table(HTML_ENTITIES, ENT_QUOTES | ENT_HTML5));
?>

以上例程的输出类似于：

array(1510) {
  ["
"]=>
  string(9) "&NewLine;"
  ["!"]=>
  string(6) "&excl;"
  ["""]=>
  string(6) "&quot;"
  ["#"]=>
  string(5) "&num;"
  ["$"]=>
  string(8) "&dollar;"
  ["%"]=>
  string(8) "&percnt;"
  ["&"]=>
  string(5) "&amp;"
  ["'"]=>
  string(6) "&apos;"
  // ...
}

参见

  • htmlspecialchars() - 将特殊字符转换为 HTML 实体
  • htmlentities() - 将字符转换为 HTML 转义字符
  • html_entity_decode() - Convert HTML entities to their corresponding characters


将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew）

  • ? get_html_translation_table
  • hebrevc ?
  • PHP Manual
  • 字符串 函数
  • 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew）

hebrev

(PHP 4, PHP 5, PHP 7, PHP 8)

hebrev — 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew）

说明

hebrev ( string $hebrew_text , int $max_chars_per_line = 0 ) : string

将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew）

函数将会尝试避免破坏单词。

参数

hebrew_text

逻辑顺序希伯来文字符串。

max_chars_per_line

可选参数，表示每行可返回的最多字符数。

返回值

返回视觉顺序字符串。

参见

  • hebrevc() - 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew），并且转换换行符


将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew），并且转换换行符

  • ? hebrev
  • hex2bin ?
  • PHP Manual
  • 字符串 函数
  • 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew），并且转换换行符

hebrevc

(PHP 4, PHP 5, PHP 7)

hebrevc — 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew），并且转换换行符

说明

hebrevc ( string $hebrew_text , int $max_chars_per_line = 0 ) : string

本函数与hebrev() 一样，唯一的区别是 本函数会额外将换行符(\n)转换为"<br>\n"。

函数将会尝试避免破坏单词。

参数

hebrew_text

逻辑顺序希伯来文字符串。

max_chars_per_line

可选参数，表示每行可返回的最多字符数。

返回值

返回视觉顺序字符串。

参见

  • hebrev() - 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew）


转换十六进制字符串为二进制字符串

  • ? hebrevc
  • html_entity_decode ?
  • PHP Manual
  • 字符串 函数
  • 转换十六进制字符串为二进制字符串

hex2bin

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

hex2bin — 转换十六进制字符串为二进制字符串

说明

hex2bin ( string $data ) : string

转换十六进制字符串为二进制字符串。

Caution

这个函数不是 转换十六进制数字为二进制数字。这种转换可以使用base_convert() 函数。

参数

data

十六进制表示的数据

返回值

返回给定数据的二进制表示 或者在失败时返回 false。

错误／异常

如果输入的十六进制字符串是奇数长数或者无效的十六进制字符串将会抛出 E_WARNING 级别的错误。

更新日志

版本 | 说明
5.5.1 | 如果输入的字符串是无效的十六进制字符串则抛出一个警告，
5.4.4 | 如果输入的字符串有多余将抛出异常。 PHP 5.4.0 起字符串将被静默地接受，但是最后的字节会被截断。

范例

Example #1 hex2bin() 例子

<?php
$hex = hex2bin("6578616d706c65206865782064617461");
var_dump($hex);
?>

以上例程的输出类似于：

string(16) "example hex data"

参见

  • bin2hex() - 函数把包含数据的二进制字符串转换为十六进制值
  • unpack() - Unpack data from binary string


Convert HTML entities to their corresponding characters

  • ? hex2bin
  • htmlentities ?
  • PHP Manual
  • 字符串 函数
  • Convert HTML entities to their corresponding characters

html_entity_decode

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

html_entity_decode — Convert HTML entities to their corresponding characters

说明

html_entity_decode ( string $string , int $flags = ENT_COMPAT , string|null $encoding = null ) : string

html_entity_decode() is the opposite of htmlentities() in that it converts HTML entities in the string to their corresponding characters.

More precisely, this function decodes all the entities (including all numeric entities) that a) are necessarily valid for the chosen document type — i.e., for XML, this function does not decode named entities that might be defined in some DTD — and b) whose character or characters are in the coded character set associated with the chosen encoding and are permitted in the chosen document type. All other entities are left as is.

参数

string

The input string.

flags

A bitmask of one or more of the following flags, which specify how to handle quotes and which document type to use. The default is ENT_COMPAT | ENT_HTML401.

Available flags constants
Constant Name | Description
ENT_COMPAT | Will convert double-quotes and leave single-quotes alone.
ENT_QUOTES | Will convert both double and single quotes.
ENT_NOQUOTES | Will leave both double and single quotes unconverted.
ENT_HTML401 | Handle code as HTML 4.01.
ENT_XML1 | Handle code as XML 1.
ENT_XHTML | Handle code as XHTML.
ENT_HTML5 | Handle code as HTML 5.

encoding

An optional argument defining the encoding used when converting characters.

If omitted, encoding defaults to the value of the default_charset configuration option.

Although this argument is technically optional, you are highly encouraged to specify the correct value for your code if the default_charset configuration option may be set incorrectly for the given input.

支持以下字符集：

支持的字符集列表
字符集 | 别名 | 描述
ISO-8859-1 | ISO8859-1 | 西欧，Latin-1
ISO-8859-5 | ISO8859-5 | Little used cyrillic charset (Latin/Cyrillic).
ISO-8859-15 | ISO8859-15 | 西欧，Latin-9。增加欧元符号，法语和芬兰语字母在 Latin-1(ISO-8859-1) 中缺失。
UTF-8 | ASCII 兼容的多字节 8 位 Unicode。
cp866 | ibm866, 866 | DOS 特有的西里尔编码。本字符集在 4.3.2 版本中得到支持。
cp1251 | Windows-1251, win-1251, 1251 | Windows 特有的西里尔编码。本字符集在 4.3.2 版本中得到支持。
cp1252 | Windows-1252, 1252 | Windows 特有的西欧编码。
KOI8-R | koi8-ru, koi8r | 俄语。本字符集在 4.3.2 版本中得到支持。
BIG5 | 950 | 繁体中文，主要用于中国台湾省。
GB2312 | 936 | 简体中文，中国国家标准字符集。
BIG5-HKSCS | 繁体中文，附带香港扩展的 Big5 字符集。
Shift_JIS | SJIS, 932 | 日语
EUC-JP | EUCJP | 日语
MacRoman | Mac OS 使用的字符串。
'' An empty string activates detection from script encoding (Zend multibyte), default_charset and current locale (see nl_langinfo() and setlocale()), in this order. Not recommended.

Note: 其他字符集没有认可。将会使用默认编码并抛出异常。

返回值

Returns the decoded string.

更新日志

版本 | 说明
8.0.0 | encoding is nullable now.

范例

Example #1 Decoding HTML entities

<?php
$orig = "I'll \"walk\" the <b>dog</b> now";

$a = htmlentities($orig);

$b = html_entity_decode($a);

echo $a; // I'll &quot;walk&quot; the &lt;b&gt;dog&lt;/b&gt; now

echo $b; // I'll "walk" the <b>dog</b> now
?>

注释

Note:

You might wonder why trim(html_entity_decode('&nbsp;')); doesn't reduce the string to an empty string, that's because the '&nbsp;' entity is not ASCII code 32 (which is stripped by trim()) but ASCII code 160 (0xa0) in the default ISO 8859-1 encoding.

参见

  • htmlentities() - 将字符转换为 HTML 转义字符
  • htmlspecialchars() - 将特殊字符转换为 HTML 实体
  • get_html_translation_table() - 返回使用 htmlspecialchars 和 htmlentities 后的转换表
  • urldecode() - 解码已编码的 URL 字符串


将字符转换为 HTML 转义字符

  • ? html_entity_decode
  • htmlspecialchars_decode ?
  • PHP Manual
  • 字符串 函数
  • 将字符转换为 HTML 转义字符

htmlentities

(PHP 4, PHP 5, PHP 7, PHP 8)

htmlentities — 将字符转换为 HTML 转义字符

说明

htmlentities ( string $string , int $flags = ENT_COMPAT | ENT_HTML401 , string $encoding = ini_get("default_charset") , bool $double_encode = true ) : string

本函数各方面都和 htmlspecialchars() 一样， 除了 htmlentities() 会转换所有具有 HTML 实体的字符。

如果要解码（反向操作），可以使用 html_entity_decode()。

参数

string

输入字符。

flags

以下一组位掩码标记，用于设置如何处理引号、无效代码序列、使用文档的类型。 默认是 ENT_COMPAT | ENT_HTML401。

有效 flags 标记常量
常量名 | 描述
ENT_COMPAT | 会转换双引号，不转换单引号。
ENT_QUOTES | 既转换双引号也转换单引号。
ENT_NOQUOTES | 单/双引号都不转换
ENT_IGNORE | 静默丢弃无效的代码单元序列，而不是返回空字符串。 不建议使用此标记， 因为它» 可能有安全影响。
ENT_SUBSTITUTE | 替换无效的代码单元序列为 Unicode 代替符（Replacement Character）， U+FFFD (UTF-8) 或者 &#xFFFD; (其他)，而不是返回空字符串。
ENT_DISALLOWED | 为文档的无效代码点替换为 Unicode 代替符（Replacement Character）： U+FFFD (UTF-8)，或 &#xFFFD;（其他），而不是把它们留在原处。 比如以下情况下就很有用：要保证 XML 文档嵌入额外内容时格式合法。
ENT_HTML401 | 以 HTML 4.01 处理代码。
ENT_XML1 | 以 XML 1 处理代码。
ENT_XHTML | 以 XHTML 处理代码。
ENT_HTML5 | 以 HTML 5 处理代码。

encoding

An optional argument defining the encoding used when converting characters.

If omitted, encoding defaults to the value of the default_charset configuration option.

Although this argument is technically optional, you are highly encouraged to specify the correct value for your code if the default_charset configuration option may be set incorrectly for the given input.

支持以下字符集：

支持的字符集列表
字符集 | 别名 | 描述
ISO-8859-1 | ISO8859-1 | 西欧，Latin-1
ISO-8859-5 | ISO8859-5 | Little used cyrillic charset (Latin/Cyrillic).
ISO-8859-15 | ISO8859-15 | 西欧，Latin-9。增加欧元符号，法语和芬兰语字母在 Latin-1(ISO-8859-1) 中缺失。
UTF-8 | ASCII 兼容的多字节 8 位 Unicode。
cp866 | ibm866, 866 | DOS 特有的西里尔编码。本字符集在 4.3.2 版本中得到支持。
cp1251 | Windows-1251, win-1251, 1251 | Windows 特有的西里尔编码。本字符集在 4.3.2 版本中得到支持。
cp1252 | Windows-1252, 1252 | Windows 特有的西欧编码。
KOI8-R | koi8-ru, koi8r | 俄语。本字符集在 4.3.2 版本中得到支持。
BIG5 | 950 | 繁体中文，主要用于中国台湾省。
GB2312 | 936 | 简体中文，中国国家标准字符集。
BIG5-HKSCS | 繁体中文，附带香港扩展的 Big5 字符集。
Shift_JIS | SJIS, 932 | 日语
EUC-JP | EUCJP | 日语
MacRoman | Mac OS 使用的字符串。
'' An empty string activates detection from script encoding (Zend multibyte), default_charset and current locale (see nl_langinfo() and setlocale()), in this order. Not recommended.

Note: 其他字符集没有认可。将会使用默认编码并抛出异常。

double_encode

关闭 double_encode 时，PHP 不会转换现有的 HTML 实体， 默认是全部转换。

返回值

返回编码后的字符。

如果指定的编码 encoding 里， string 包含了无效的代码单元序列， 没有设置 ENT_IGNORE 或者 ENT_SUBSTITUTE 标记的情况下，会返回空字符串。

更新日志

版本 | 说明
5.6.0 | The default value for the encoding parameter was changed to be the value of the default_charset configuration option.
5.4.0 | encoding 参数的默认值改成 UTF-8。
5.4.0 | 增加常量 ENT_SUBSTITUTE、 ENT_DISALLOWED、 ENT_HTML401、 ENT_XML1、 ENT_XHTML、 ENT_HTML5。
5.3.0 | 增加常量 ENT_IGNORE。
5.2.3 | 增加参数 double_encode。

范例

Example #1 htmlentities() 例子

<?php
$str = "A 'quote' is <b>bold</b>";

// 输出: A 'quote' is &lt;b&gt;bold&lt;/b&gt;
echo htmlentities($str);

// 输出: A &#039;quote&#039; is &lt;b&gt;bold&lt;/b&gt;
echo htmlentities($str, ENT_QUOTES);
?>

Example #2 ENT_IGNORE 用法示例

<?php
$str = "\x8F!!!";

// 输出空 string
echo htmlentities($str, ENT_QUOTES, "UTF-8");

// 输出 "!!!"
echo htmlentities($str, ENT_QUOTES | ENT_IGNORE, "UTF-8");
?>

参见

  • html_entity_decode() - Convert HTML entities to their corresponding characters
  • get_html_translation_table() - 返回使用 htmlspecialchars 和 htmlentities 后的转换表
  • htmlspecialchars() - 将特殊字符转换为 HTML 实体
  • nl2br() - 在字符串所有新行之前插入 HTML 换行标记
  • urlencode() - 编码 URL 字符串


将特殊的 HTML 实体转换回普通字符

  • ? htmlentities
  • htmlspecialchars ?
  • PHP Manual
  • 字符串 函数
  • 将特殊的 HTML 实体转换回普通字符

htmlspecialchars_decode

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

htmlspecialchars_decode — 将特殊的 HTML 实体转换回普通字符

说明

htmlspecialchars_decode ( string $string , int $flags = ENT_COMPAT | ENT_HTML401 ) : string

此函数的作用和 htmlspecialchars() 刚好相反。它将特殊的HTML实体转换回普通字符。

被转换的实体有： &amp;， &quot; （没有设置ENT_NOQUOTES 时）, &#039; （设置了 ENT_QUOTES 时）， &lt; 以及&gt;。

参数

string

要解码的字符串

flags

用下列标记中的一个或多个作为一个位掩码，来指定如何处理引号和使用哪种文档类型。默认为 ENT_COMPAT | ENT_HTML401。

有效的 flags 常量
常量名 | 说明
ENT_COMPAT | 转换双引号，不转换单引号。
ENT_QUOTES | 单引号和双引号都转换。
ENT_NOQUOTES | 单引号和双引号都不转换。
ENT_HTML401 | 作为HTML 4.01编码处理。
ENT_XML1 | 作为XML 1编码处理。
ENT_XHTML | 作为XHTML编码处理。
ENT_HTML5 | 作为HTML 5编码处理。

返回值

返回解码后的字符串。

更新日志

版本 | 说明
5.4.0 | 增加了 ENT_HTML401、ENT_XML1、 ENT_XHTML 和 ENT_HTML5 等常量。

范例

Example #1 一个 htmlspecialchars_decode() 的例子

<?php
$str = "<p>this -&gt; &quot;</p>\n";

echo htmlspecialchars_decode($str);

// 注意，这里的引号不会被转换
echo htmlspecialchars_decode($str, ENT_NOQUOTES);
?>

以上例程会输出：

<p>this -> "</p>
<p>this -> &quot;</p>

参见

  • htmlspecialchars() - 将特殊字符转换为 HTML 实体
  • html_entity_decode() - Convert HTML entities to their corresponding characters
  • get_html_translation_table() - 返回使用 htmlspecialchars 和 htmlentities 后的转换表


将特殊字符转换为 HTML 实体

  • ? htmlspecialchars_decode
  • implode ?
  • PHP Manual
  • 字符串 函数
  • 将特殊字符转换为 HTML 实体

htmlspecialchars

(PHP 4, PHP 5, PHP 7, PHP 8)

htmlspecialchars — 将特殊字符转换为 HTML 实体

说明

htmlspecialchars ( string $string , int $flags = ENT_COMPAT | ENT_HTML401 , string $encoding = ini_get("default_charset") , bool $double_encode = true ) : string

某类字符在 HTML 中有特殊用处，如需保持原意，需要用 HTML 实体来表达。 本函数会返回字符转义后的表达。 如需转换子字符串中所有关联的名称实体，使用 htmlentities() 代替本函数。

如果传入字符的字符编码和最终的文档是一致的，则用函数处理的输入适合绝大多数 HTML 文档环境。 然而，如果输入的字符编码和最终包含字符的文档是不一样的， 想要保留字符（以数字或名称实体的形式），本函数以及 htmlentities() （仅编码名称实体对应的子字符串）可能不够用。 这种情况可以使用 mb_encode_numericentity() 代替。

执行转换
字符 | 替换后
& (& 符号) | &amp;
" (双引号) | &quot;，除非设置了 ENT_NOQUOTES
' (单引号) | 设置了 ENT_QUOTES 后， &#039; (如果是 ENT_HTML401) ，或者 &apos; (如果是 ENT_XML1、 ENT_XHTML 或 ENT_HTML5)。
< (小于) | &lt;
> (大于) | &gt;

参数

string

待转换的 string。

flags

位掩码，由以下某个或多个标记组成，设置转义处理细节、无效单元序列、文档类型。 默认是 ENT_COMPAT | ENT_HTML401。

有效的 flags 常量
常量名称 | 描述
ENT_COMPAT | 会转换双引号，不转换单引号。
ENT_QUOTES | 既转换双引号也转换单引号。
ENT_NOQUOTES | 单/双引号都不转换
ENT_IGNORE | 静默丢弃无效的代码单元序列，而不是返回空字符串。 不建议使用此标记， 因为它» 可能有安全影响。
ENT_SUBSTITUTE | 替换无效的代码单元序列为 Unicode 代替符（Replacement Character）， U+FFFD (UTF-8) 或者 &#xFFFD; (其他)，而不是返回空字符串。
ENT_DISALLOWED | 为文档的无效代码点替换为 Unicode 代替符（Replacement Character）： U+FFFD (UTF-8)，或 &#xFFFD;（其他），而不是把它们留在原处。 比如以下情况下就很有用：要保证 XML 文档嵌入额外内容时格式合法。
ENT_HTML401 | 以 HTML 4.01 处理代码。
ENT_XML1 | 以 XML 1 处理代码。
ENT_XHTML | 以 XHTML 处理代码。
ENT_HTML5 | 以 HTML 5 处理代码。

encoding

An optional argument defining the encoding used when converting characters.

If omitted, encoding defaults to the value of the default_charset configuration option.

Although this argument is technically optional, you are highly encouraged to specify the correct value for your code if the default_charset configuration option may be set incorrectly for the given input.

本函数使用效果上，如果 string 对以下字符编码是有效的， ISO-8859-1、 ISO-8859-15、 UTF-8、 cp866、 cp1251、 cp1252、 KOI8-R 将具有相同的效果。 也就是说，在这些编码里， 受 htmlspecialchars() 影响的字符会占据相同的位置。

支持以下字符集：

支持的字符集列表
字符集 | 别名 | 描述
ISO-8859-1 | ISO8859-1 | 西欧，Latin-1
ISO-8859-5 | ISO8859-5 | Little used cyrillic charset (Latin/Cyrillic).
ISO-8859-15 | ISO8859-15 | 西欧，Latin-9。增加欧元符号，法语和芬兰语字母在 Latin-1(ISO-8859-1) 中缺失。
UTF-8 | ASCII 兼容的多字节 8 位 Unicode。
cp866 | ibm866, 866 | DOS 特有的西里尔编码。本字符集在 4.3.2 版本中得到支持。
cp1251 | Windows-1251, win-1251, 1251 | Windows 特有的西里尔编码。本字符集在 4.3.2 版本中得到支持。
cp1252 | Windows-1252, 1252 | Windows 特有的西欧编码。
KOI8-R | koi8-ru, koi8r | 俄语。本字符集在 4.3.2 版本中得到支持。
BIG5 | 950 | 繁体中文，主要用于中国台湾省。
GB2312 | 936 | 简体中文，中国国家标准字符集。
BIG5-HKSCS | 繁体中文，附带香港扩展的 Big5 字符集。
Shift_JIS | SJIS, 932 | 日语
EUC-JP | EUCJP | 日语
MacRoman | Mac OS 使用的字符串。
'' An empty string activates detection from script encoding (Zend multibyte), default_charset and current locale (see nl_langinfo() and setlocale()), in this order. Not recommended.

Note: 其他字符集没有认可。将会使用默认编码并抛出异常。

double_encode

关闭 double_encode 时，PHP 不会转换现有的 HTML 实体， 默认是全部转换。

返回值

转换后的 string。

如果指定的编码 encoding 里， string 包含了无效的代码单元序列， 没有设置 ENT_IGNORE 或者 ENT_SUBSTITUTE 标记的情况下，会返回空字符串。

更新日志

版本 | 说明
5.6.0 | The default value for the encoding parameter was changed to be the value of the default_charset configuration option.
5.4.0 | encoding 参数的默认值改成 UTF-8。
5.4.0 | 增加常量 ENT_SUBSTITUTE、 ENT_DISALLOWED、 ENT_HTML401、 ENT_XML1、 ENT_XHTML、 ENT_HTML5。
5.3.0 | 增加常量 ENT_IGNORE。
5.2.3 | 增加参数 double_encode。

范例

Example #1 htmlspecialchars() 例子

<?php
$new = htmlspecialchars("<a href='test'>Test</a>", ENT_QUOTES);
echo $new; // &lt;a href=&#039;test&#039;&gt;Test&lt;/a&gt;
?>

注释

Note:

注意，本函数不会转换以上列表以外的实体。 完整转换请参见 htmlentities()。

Note:

如果 flags 的设置模糊易混淆，将遵循以下规则：

  • 当 ENT_COMPAT、ENT_QUOTES、ENT_NOQUOTES 都没设置， 默认就是 ENT_NOQUOTES。
  • 如果设置不止一个 ENT_COMPAT、 ENT_QUOTES、 ENT_NOQUOTES ，优先级最高的是 ENT_QUOTES， 其次是 ENT_COMPAT。
  • 当 ENT_HTML401、 ENT_HTML5、 ENT_XHTML、 ENT_XML1 都没设置，默认是 ENT_HTML401。
  • 如果设置不止一个 ENT_HTML401、 ENT_HTML5、 ENT_XHTML、 ENT_XML1， 优先级最高的是 ENT_HTML5 其次是 ENT_XHTML、ENT_XML1 和 ENT_HTML401。
  • 如果设置不止一个 ENT_DISALLOWED、 ENT_IGNORE、 ENT_SUBSTITUTE，优先级最高的是 ENT_IGNORE， 其次是 ENT_SUBSTITUTE。

参见

  • get_html_translation_table() - 返回使用 htmlspecialchars 和 htmlentities 后的转换表
  • htmlspecialchars_decode() - 将特殊的 HTML 实体转换回普通字符
  • strip_tags() - 从字符串中去除 HTML 和 PHP 标记
  • htmlentities() - 将字符转换为 HTML 转义字符
  • nl2br() - 在字符串所有新行之前插入 HTML 换行标记


将一个一维数组的值转化为字符串

  • ? htmlspecialchars
  • join ?
  • PHP Manual
  • 字符串 函数
  • 将一个一维数组的值转化为字符串

implode

(PHP 4, PHP 5, PHP 7, PHP 8)

implode — 将一个一维数组的值转化为字符串

说明

implode ( string $glue , array $pieces ) : string
implode ( array $pieces ) : string

用 glue 将一维数组的值连接为一个字符串。

Note:

因为历史原因，implode() 可以接收两种参数顺序，但是为了和 explode() 内的顺序保持一致，不按文档的方式已被废弃。

参数

glue

默认为空的字符串。

pieces

你想要转换的数组。

返回值

返回一个字符串，其内容为由 glue 分割开的数组的值。

更新日志

版本 | 说明
7.4.0 | 把参数 glue 放到 pieces 的后面已被废弃（就是不按文档中的顺序传递参数）。

范例

Example #1 implode() 例子

<?php

$array = array('lastname', 'email', 'phone');
$comma_separated = implode(",", $array);

echo $comma_separated; // lastname,email,phone

// Empty string when using an empty array:
var_dump(implode('hello', array())); // string(0) ""

?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • explode() - 使用一个字符串分割另一个字符串
  • preg_split() - 通过一个正则表达式分隔字符串
  • http_build_query() - 生成 URL-encode 之后的请求字符串


别名 implode

  • ? implode
  • lcfirst ?
  • PHP Manual
  • 字符串 函数
  • 别名 implode

join

(PHP 4, PHP 5, PHP 7, PHP 8)

join — 别名 implode()

说明

此函数是该函数的别名： implode().


使一个字符串的第一个字符小写

  • ? join
  • levenshtein ?
  • PHP Manual
  • 字符串 函数
  • 使一个字符串的第一个字符小写

lcfirst

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

lcfirst — 使一个字符串的第一个字符小写

说明

lcfirst ( string $str ) : string

返回第一个字母小写的 str ，如果是字母的话。

需要注意的是"字母"是由当前语言区域决定的。比如，在默认的"C"区域像日耳曼语系中的元音变音a (?) 将不会被转换。

参数

str

输入的字符串。

返回值

返回转换后的字符串。

范例

Example #1 lcfirst() 例子：

<?php
$foo = 'HelloWorld';
$foo = lcfirst($foo);             // helloWorld

$bar = 'HELLO WORLD!';
$bar = lcfirst($bar);             // hELLO WORLD!
$bar = lcfirst(strtoupper($bar)); // hELLO WORLD!
?>

参见

  • ucfirst() - 将字符串的首字母转换为大写
  • strtolower() - 将字符串转化为小写
  • strtoupper() - 将字符串转化为大写
  • ucwords() - 将字符串中每个单词的首字母转换为大写


计算两个字符串之间的编辑距离

  • ? lcfirst
  • localeconv ?
  • PHP Manual
  • 字符串 函数
  • 计算两个字符串之间的编辑距离

levenshtein

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

levenshtein — 计算两个字符串之间的编辑距离

说明

levenshtein ( string $str1 , string $str2 ) : int
levenshtein ( string $str1 , string $str2 , int $cost_ins , int $cost_rep , int $cost_del ) : int

编辑距离，是指两个字串之间，通过替换、插入、删除等操作将字符串str1转换成str2所需要操作的最少字符数量。 该算法的复杂度是 O(m*n)，其中 n 和 m 分别是str1 和str2的长度 （当和算法复杂度为O(max(n,m)**3)的similar_text()相比时，此函数还是相当不错的，尽管仍然很耗时。）。

在最简单的形式中，该函数只以两个字符串作为参数，并计算通过插入、替换和删除等操作将str1转换成str2所需要的操作次数。

第二种变体将采用三个额外的参数来定义插入、替换和删除操作的次数。此变体比第一种更加通用和适应，但效率不高。

参数

str1

求编辑距离中的其中一个字符串

str2

求编辑距离中的另一个字符串

cost_ins

定义插入次数

cost_rep

定义替换次数

cost_del

定义删除次数

返回值

此函数返回两个字符串参数之间的编辑距离，如果其中一个字符串参数长度大于限制的255个字符时，返回-1。

范例

Example #1 levenshtein() 例子：

<?php
// 输入拼写错误的单词
$input = 'carrrot';

// 要检查的单词数组
$words  = array('apple','pineapple','banana','orange',
                'radish','carrot','pea','bean','potato');

// 目前没有找到最短距离
$shortest = -1;

// 遍历单词来找到最接近的
foreach ($words as $word) {

    // 计算输入单词与当前单词的距离
    $lev = levenshtein($input, $word);

    // 检查完全的匹配
    if ($lev == 0) {

        // 最接近的单词是这个（完全匹配）
        $closest = $word;
        $shortest = 0;

        // 退出循环；我们已经找到一个完全的匹配
        break;
    }

    // 如果此次距离比上次找到的要短
    // 或者还没找到接近的单词
    if ($lev <= $shortest || $shortest < 0) {
        // 设置最接近的匹配以及它的最短距离
        $closest  = $word;
        $shortest = $lev;
    }
}

echo "Input word: $input\n";
if ($shortest == 0) {
    echo "Exact match found: $closest\n";
} else {
    echo "Did you mean: $closest?\n";
}

?>

以上例程会输出：

Input word: carrrot
Did you mean: carrot?

参见

  • soundex() - Calculate the soundex key of a string
  • similar_text() - 计算两个字符串的相似度
  • metaphone() - Calculate the metaphone key of a string


Get numeric formatting information

  • ? levenshtein
  • ltrim ?
  • PHP Manual
  • 字符串 函数
  • Get numeric formatting information

localeconv

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

localeconv — Get numeric formatting information

说明

localeconv ( ) : array

Returns an associative array containing localized numeric and monetary formatting information.

返回值

localeconv() returns data based upon the current locale as set by setlocale(). The associative array that is returned contains the following fields:

Array element | Description
decimal_point | Decimal point character
thousands_sep | Thousands separator
grouping | Array containing numeric groupings
int_curr_symbol | International currency symbol (i.e. USD)
currency_symbol | Local currency symbol (i.e. $)
mon_decimal_point | Monetary decimal point character
mon_thousands_sep | Monetary thousands separator
mon_grouping | Array containing monetary groupings
positive_sign | Sign for positive values
negative_sign | Sign for negative values
int_frac_digits | International fractional digits
frac_digits | Local fractional digits
p_cs_precedes | true if currency_symbol precedes a positive value, false if it succeeds one
p_sep_by_space | true if a space separates currency_symbol from a positive value, false otherwise
n_cs_precedes | true if currency_symbol precedes a negative value, false if it succeeds one
n_sep_by_space | true if a space separates currency_symbol from a negative value, false otherwise
p_sign_posn
  • 0 - Parentheses surround the quantity and currency_symbol
  • 1 - The sign string precedes the quantity and currency_symbol
  • 2 - The sign string succeeds the quantity and currency_symbol
  • 3 - The sign string immediately precedes the currency_symbol
  • 4 - The sign string immediately succeeds the currency_symbol
n_sign_posn
  • 0 - Parentheses surround the quantity and currency_symbol
  • 1 - The sign string precedes the quantity and currency_symbol
  • 2 - The sign string succeeds the quantity and currency_symbol
  • 3 - The sign string immediately precedes the currency_symbol
  • 4 - The sign string immediately succeeds the currency_symbol

The p_sign_posn, and n_sign_posn contain a string of formatting options. Each number representing one of the above listed conditions.

The grouping fields contain arrays that define the way numbers should be grouped. For example, the monetary grouping field for the nl_NL locale (in UTF-8 mode with the euro sign), would contain a 2 item array with the values 3 and 3. The higher the index in the array, the farther left the grouping is. If an array element is equal to CHAR_MAX, no further grouping is done. If an array element is equal to 0, the previous element should be used.

范例

Example #1 localeconv() example

<?php
if (false !== setlocale(LC_ALL, 'nl_NL.UTF-8@euro')) {
    $locale_info = localeconv();
    print_r($locale_info);
}
?>

以上例程会输出：

Array
(
    [decimal_point] => .
    [thousands_sep] =>
    [int_curr_symbol] => EUR
    [currency_symbol] => �
    [mon_decimal_point] => ,
    [mon_thousands_sep] =>
    [positive_sign] =>
    [negative_sign] => -
    [int_frac_digits] => 2
    [frac_digits] => 2
    [p_cs_precedes] => 1
    [p_sep_by_space] => 1
    [n_cs_precedes] => 1
    [n_sep_by_space] => 1
    [p_sign_posn] => 1
    [n_sign_posn] => 2
    [grouping] => Array
        (
        )

    [mon_grouping] => Array
        (
            [0] => 3
            [1] => 3
        )

)

参见

  • setlocale() - 设置地区信息


删除字符串开头的空白字符（或其他字符）

  • ? localeconv
  • md5_file ?
  • PHP Manual
  • 字符串 函数
  • 删除字符串开头的空白字符（或其他字符）

ltrim

(PHP 4, PHP 5, PHP 7, PHP 8)

ltrim — 删除字符串开头的空白字符（或其他字符）

说明

ltrim ( string $str , string $character_mask = ? ) : string

删除字符串开头的空白字符（或其他字符）

参数

str

输入的字符串。

character_mask

通过参数 character_mask，你也可以指定想要删除的字符，简单地列出你想要删除的所有字符即可。使用..，可以指定字符的范围。

返回值

该函数返回一个删除了 str 最左边的空白字符的字符串。 如果不使用第二个参数， ltrim() 仅删除以下字符：

  • " " (ASCII 32 (0x20))，普通空白字符。
  • "\t" (ASCII 9 (0x09))， 制表符.
  • "\n" (ASCII 10 (0x0A))，换行符。
  • "\r" (ASCII 13 (0x0D))，回车符。
  • "\0" (ASCII 0 (0x00))， NUL空字节符。
  • "\x0B" (ASCII 11 (0x0B))，垂直制表符。

范例

Example #1 ltrim()的使用范例

<?php

$text = "\t\tThese are a few words :) ...  ";
$binary = "\x09Example string\x0A";
$hello  = "Hello World";
var_dump($text, $binary, $hello);

print "\n";

$trimmed = ltrim($text);
var_dump($trimmed);

$trimmed = ltrim($text, " \t.");
var_dump($trimmed);

$trimmed = ltrim($hello, "Hdle");
var_dump($trimmed);

// 删除 $binary 开头的 ASCII 控制字符
// (从 0 到 31，包括 0 和 31)
$clean = ltrim($binary, "\x00..\x1F");
var_dump($clean);

?>

以上例程会输出：

string(32) "        These are a few words :) ...  "
string(16) "    Example string
"
string(11) "Hello World"

string(30) "These are a few words :) ...  "
string(30) "These are a few words :) ...  "
string(7) "o World"
string(15) "Example string
"

参见

  • trim() - 去除字符串首尾处的空白字符（或者其他字符）
  • rtrim() - 删除字符串末端的空白字符（或者其他字符）


计算指定文件的 MD5 散列值

  • ? ltrim
  • md5 ?
  • PHP Manual
  • 字符串 函数
  • 计算指定文件的 MD5 散列值

md5_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

md5_file — 计算指定文件的 MD5 散列值

说明

md5_file ( string $filename , bool $raw_output = false ) : string

使用 » RSA 数据安全公司的 MD5 报文算法计算 filename 文件的 MD5 散列值并返回。该散列值为 32 字符的十六进制数字。

参数

filename

文件名

raw_output

如果被设置为 true，那么报文摘要将以原始的 16 位二进制格式返回。

返回值

成功返回字符串，否则返回 false。

更新日志

版本 | 说明
5.1.0 | 函数改用流 API。这意味着能够配合封装器使用该函数，比如 md5_file('http://example.com/..')。

范例

Example #1 md5_file() 使用范例

<?php
$file = 'php-5.3.0alpha2-Win32-VC9-x64.zip';

echo 'MD5 file hash of ' . $file . ': ' . md5_file($file);
?>

参见

  • md5() - 计算字符串的 MD5 散列值
  • sha1_file() - 计算文件的 sha1 散列值
  • crc32() - 计算一个字符串的 crc32 多项式


计算字符串的 MD5 散列值

  • ? md5_file
  • metaphone ?
  • PHP Manual
  • 字符串 函数
  • 计算字符串的 MD5 散列值

md5

(PHP 4, PHP 5, PHP 7, PHP 8)

md5 — 计算字符串的 MD5 散列值

Warning

由于此函数依赖的算法已不足够复杂,不推荐使用此函数对明文密码加密。详细内容参见 这里。

说明

md5 ( string $str , bool $raw_output = false ) : string

使用 » RSA 数据安全公司的 MD5 报文算法计算 str 的 MD5 散列值。

参数

str

原始字符串。

raw_output

如果可选的 raw_output 被设置为 true，那么 MD5 报文摘要将以16字节长度的原始二进制格式返回。

返回值

以 32 字符十六进制数字形式返回散列值。

范例

Example #1 md5() 范例

<?php
$str = 'apple';

if (md5($str) === '1f3870be274f6c49b3e31a0c6728957f') {
    echo "Would you like a green or red apple?";
}
?>

参见

  • md5_file() - 计算指定文件的 MD5 散列值
  • sha1_file() - 计算文件的 sha1 散列值
  • crc32() - 计算一个字符串的 crc32 多项式
  • sha1() - 计算字符串的 sha1 散列值
  • hash() - 生成哈希值 （消息摘要）
  • crypt() - 单向字符串散列
  • password_hash() - 创建密码的散列（hash）


Calculate the metaphone key of a string

  • ? md5
  • money_format ?
  • PHP Manual
  • 字符串 函数
  • Calculate the metaphone key of a string

metaphone

(PHP 4, PHP 5, PHP 7, PHP 8)

metaphone — Calculate the metaphone key of a string

说明

metaphone ( string $string , int $max_phonemes = 0 ) : string

Calculates the metaphone key of string.

Similar to soundex() metaphone creates the same key for similar sounding words. It's more accurate than soundex() as it knows the basic rules of English pronunciation. The metaphone generated keys are of variable length.

Metaphone was developed by Lawrence Philips <lphilips at verity dot com>. It is described in ["Practical Algorithms for Programmers", Binstock & Rex, Addison Wesley, 1995].

参数

string

The input string.

max_phonemes

This parameter restricts the returned metaphone key to max_phonemes characters in length. However, the resulting phonemes are always transcribed completely, so the resulting string length may be slightly longer than max_phonemes. The default value of 0 means no restriction.

返回值

Returns the metaphone key as a string.

更新日志

版本 | 说明
8.0.0 | The function returned false on failure.

范例

Example #1 metaphone() basic example

<?php
var_dump(metaphone('programming'));
var_dump(metaphone('programmer'));
?>

以上例程会输出：

string(7) "PRKRMNK"
string(6) "PRKRMR"

Example #2 Using the max_phonemes parameter

<?php
var_dump(metaphone('programming', 5));
var_dump(metaphone('programmer', 5));
?>

以上例程会输出：

string(5) "PRKRM"
string(5) "PRKRM"

Example #3 Using the max_phonemes parameter

In this example, metaphone() is advised to produce a string of five characters, but that would require to split the final phoneme ('x' is supposed to be transcribed to 'KS'), so the function returns a string with six characters.

<?php
var_dump(metaphone('Asterix', 5));
?>

以上例程会输出：

string(6) "ASTRKS"


将数字格式化成货币字符串

  • ? metaphone
  • nl_langinfo ?
  • PHP Manual
  • 字符串 函数
  • 将数字格式化成货币字符串

money_format

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

money_format — 将数字格式化成货币字符串

说明

money_format ( string $format , float $number ) : string

money_format() 返回格式化好的 number 版本。 此函数包装了 C 函数库中的 strfmon()，不同之处是：此实现每次只能转化一个数字。

参数

format

格式字符串由以下几部分组成：

  • 单个 % 字符

  • 可选的标记（flags）

  • 可选的字段宽度

  • 可选的，左侧精度

  • 可选的，右侧精度

  • 必选的，单个转化字符

标记(Flags)

可选多个标记，分别是：

=f

字符：=，并紧跟一个字符（单字节） f，用于数字填充。默认的填充字符是空格。

^

禁用分组字符（比如金额中的逗号。在本地区域设置 locale 中定义）。

+ or (

正负数字的格式。使用 +，将使用区域设置（locale）中相当于 + 和 - 的符号。 如果使用 (，负数将被圆括号围绕。不设置的话，默认为 +。

!

不输出货币符号（比如 ￥）。

-

有这个符号的时候，将使字段左对齐（填充到右边），默认是相反的，是右对齐的（填充到左边）。

字段宽度

w

十进制数值字符串的宽度。字段将右对齐，除非使用了 - 标记。默认值 0。

左侧精度

#n

小数字符（比如小数点）前的最大位数 (n)。 常用于同一列中的格式对齐。 如果位数小于 n 则使用填充字符填满。 如果实际位数大于 n，此设置将被忽略。

如果没用 ^ 标识禁用分组，分组分隔符会在添加填充字符之前插入（如果有的话）。 分组分隔符不会应用到填充字符里，哪怕填充字符是个数字。

为了保证对齐，出现在之前或者之后的字符，都会填充必要的空格，保证正负情况下长度都一样。

右侧精度

.p

小数点后的一段数字 (p)。 如果 p 的值是 0（零），小数点右侧的数值将被删除。 如果不使用这个标记，默认展现取决于当前的区域设置。 小数点后指定位数的数字，四舍五入格式化。

转化字符

i

根据国际化区域设置中的货币格式，格式化数值。（比如，locale 是 USA：USD 1,234.56）。

n

根据国际化区域设置中国家的货币格式，格式化数值。（比如，locale 是 de_DE：EU1.234,56）。

%

返回字符 %。

number

需要格式化的数字。

返回值

返回格式化后的字符。格式字符串前后的字符将原封不动返回。 传入的 number 如果不是数字，将返回 null 并且产生 E_WARNING。

注释

Note:

具有 strfmon 的系统才有 money_format() 函数。 例如 Windows 不具备，所以 Windows 系统上 money_format() 未定义。

Note:

locale 设置中， LC_MONETARY 会影响此函数的行为。 在使用函数前，首先要用 setlocale() 来设置合适的区域设置（locale）。

范例

Example #1 money_format() 例子

使用不同的 locale 和格式字符串，来说明此函数的用法。

<?php

$number = 1234.56;

// 让我们打印 en_US locale 的国际化格式
setlocale(LC_MONETARY, 'en_US');
echo money_format('%i', $number) . "\n";
// USD 1,234.56

// 意大利国家的格式，带两位浮点小数`
setlocale(LC_MONETARY, 'it_IT');
echo money_format('%.2n', $number) . "\n";
// Eu 1.234,56

// 负数的使用
$number = -1234.5672;

// 美国国家的格式，使用圆括号 () 标记负数。
// 左侧精度使用十位
setlocale(LC_MONETARY, 'en_US');
echo money_format('%(#10n', $number) . "\n";
// ($        1,234.57)

// 相似的格式，添加了右侧两位小数点的精度，同时用 * 来填充
echo money_format('%=*(#10.2n', $number) . "\n";
// ($********1,234.57)

// 让我们左对齐，14位宽，左侧八位，右侧两位，不带分组字符
// de_DE 的国际化格式
setlocale(LC_MONETARY, 'de_DE');
echo money_format('%=*^-14#8.2i', 1234.56) . "\n";
// Eu 1234,56****

// 让我们在格式字符串前后，添加一些简介
setlocale(LC_MONETARY, 'en_GB');
$fmt = 'The final value is %i (after a 10%% discount)';
echo money_format($fmt, 1234.56) . "\n";
// The final value is  GBP 1,234.56 (after a 10% discount)

?>

参见

  • setlocale() - 设置地区信息
  • sscanf() - 根据指定格式解析输入的字符
  • sprintf() - Return a formatted string
  • printf() - 输出格式化字符串
  • number_format() - 以千位分隔符方式格式化一个数字


Query language and locale information

  • ? money_format
  • nl2br ?
  • PHP Manual
  • 字符串 函数
  • Query language and locale information

nl_langinfo

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

nl_langinfo — Query language and locale information

说明

nl_langinfo ( int $item ) : string|false

nl_langinfo() is used to access individual elements of the locale categories. Unlike localeconv(), which returns all of the elements, nl_langinfo() allows you to select any specific element.

参数

item

item may be an integer value of the element or the constant name of the element. The following is a list of constant names for item that may be used and their description. Some of these constants may not be defined or hold no value for certain locales.

nl_langinfo Constants
Constant | Description
LC_TIME Category Constants
ABDAY_(1-7) | Abbreviated name of n-th day of the week.
DAY_(1-7) | Name of the n-th day of the week (DAY_1 = Sunday).
ABMON_(1-12) | Abbreviated name of the n-th month of the year.
MON_(1-12) | Name of the n-th month of the year.
AM_STR | String for Ante meridian.
PM_STR | String for Post meridian.
D_T_FMT | String that can be used as the format string for strftime() to represent time and date.
D_FMT | String that can be used as the format string for strftime() to represent date.
T_FMT | String that can be used as the format string for strftime() to represent time.
T_FMT_AMPM | String that can be used as the format string for strftime() to represent time in 12-hour format with ante/post meridian.
ERA | Alternate era.
ERA_YEAR | Year in alternate era format.
ERA_D_T_FMT | Date and time in alternate era format (string can be used in strftime()).
ERA_D_FMT | Date in alternate era format (string can be used in strftime()).
ERA_T_FMT | Time in alternate era format (string can be used in strftime()).
LC_MONETARY Category Constants
INT_CURR_SYMBOL | International currency symbol.
CURRENCY_SYMBOL | Local currency symbol.
CRNCYSTR | Same value as CURRENCY_SYMBOL.
MON_DECIMAL_POINT | Decimal point character.
MON_THOUSANDS_SEP | Thousands separator (groups of three digits).
MON_GROUPING | Like "grouping" element.
POSITIVE_SIGN | Sign for positive values.
NEGATIVE_SIGN | Sign for negative values.
INT_FRAC_DIGITS | International fractional digits.
FRAC_DIGITS | Local fractional digits.
P_CS_PRECEDES | Returns 1 if CURRENCY_SYMBOL precedes a positive value.
P_SEP_BY_SPACE | Returns 1 if a space separates CURRENCY_SYMBOL from a positive value.
N_CS_PRECEDES | Returns 1 if CURRENCY_SYMBOL precedes a negative value.
N_SEP_BY_SPACE | Returns 1 if a space separates CURRENCY_SYMBOL from a negative value.
P_SIGN_POSN
  • Returns 0 if parentheses surround the quantity and CURRENCY_SYMBOL.
  • Returns 1 if the sign string precedes the quantity and CURRENCY_SYMBOL.
  • Returns 2 if the sign string follows the quantity and CURRENCY_SYMBOL.
  • Returns 3 if the sign string immediately precedes the CURRENCY_SYMBOL.
  • Returns 4 if the sign string immediately follows the CURRENCY_SYMBOL.
N_SIGN_POSN
LC_NUMERIC Category Constants
DECIMAL_POINT | Decimal point character.
RADIXCHAR | Same value as DECIMAL_POINT.
THOUSANDS_SEP | Separator character for thousands (groups of three digits).
THOUSEP | Same value as THOUSANDS_SEP.
GROUPING
LC_MESSAGES Category Constants
YESEXPR | Regex string for matching "yes" input.
NOEXPR | Regex string for matching "no" input.
YESSTR | Output string for "yes".
NOSTR | Output string for "no".
LC_CTYPE Category Constants
CODESET | Return a string with the name of the character encoding.

返回值

Returns the element as a string, or false if item is not valid.

注释

Note: 此函数未在 Windows 平台下实现。

参见

  • setlocale() - 设置地区信息
  • localeconv() - Get numeric formatting information


在字符串所有新行之前插入 HTML 换行标记

  • ? nl_langinfo
  • number_format ?
  • PHP Manual
  • 字符串 函数
  • 在字符串所有新行之前插入 HTML 换行标记

nl2br

(PHP 4, PHP 5, PHP 7, PHP 8)

nl2br — 在字符串所有新行之前插入 HTML 换行标记

说明

nl2br ( string $string , bool $is_xhtml = true ) : string

在字符串 string 所有新行之前插入 '<br />' 或 '<br>'，并返回。

参数

string

输入字符串。

is_xhtml

是否使用 XHTML 兼容换行符。

返回值

返回调整后的字符串。

范例

Example #1 nl2br() 使用范例

<?php
echo nl2br("foo isn't\n bar");
?>

以上例程会输出：

foo isn't<br />
 bar

Example #2 使用 is_xhtml 生成合法的 HTML 标记

<?php
echo nl2br("Welcome\r\nThis is my HTML document", false);
?>

以上例程会输出：

Welcome<br>
This is my HTML document

Example #3 各种换行分隔符

<?php
$string = "This\r\nis\n\ra\nstring\r";
echo nl2br($string);
?>

以上例程会输出：

This<br />
is<br />
a<br />
string<br />

更新日志

版本 | 说明
5.3.0 | 新增可选的 is_xhtml 参数。在此之前，总是插入 '<br />'。

参见

  • htmlspecialchars() - 将特殊字符转换为 HTML 实体
  • htmlentities() - 将字符转换为 HTML 转义字符
  • wordwrap() - 打断字符串为指定数量的字串
  • str_replace() - 子字符串替换


以千位分隔符方式格式化一个数字

  • ? nl2br
  • ord ?
  • PHP Manual
  • 字符串 函数
  • 以千位分隔符方式格式化一个数字

number_format

(PHP 4, PHP 5, PHP 7, PHP 8)

number_format — 以千位分隔符方式格式化一个数字

说明

number_format ( float $number , int $decimals = 0 ) : string
number_format ( float $number , int $decimals = 0 , string $dec_point = "." , string $thousands_sep = "," ) : string

本函数可以接受1个、2个或者4个参数（注意：不能是3个）:

如果只提供第一个参数，number的小数部分会被去掉 并且每个千位分隔符都是英文小写逗号","

如果提供两个参数，number将保留小数点后的位数到你设定的值，其余同楼上

如果提供了四个参数，number 将保留decimals个长度的小数部分, 小数点被替换为dec_point，千位分隔符替换为thousands_sep

参数

number

你要格式化的数字

decimals

要保留的小数位数

dec_point

指定小数点显示的字符

thousands_sep

指定千位分隔符显示的字符

返回值

格式化以后的 number.

更新日志

版本 | 说明
5.4.0 | This function now supports multiple bytes in dec_point and thousands_sep. Only the first byte of each separator was used in older versions.

范例

Example #1 number_format() Example

For instance, French notation usually use two decimals, comma (',') as decimal separator, and space (' ') as thousand separator. The following example demonstrates various way to format a number:

<?php

$number = 1234.56;

// english notation (default)
$english_format_number = number_format($number);
// 1,235

// French notation
$nombre_format_francais = number_format($number, 2, ',', ' ');
// 1 234,56

$number = 1234.5678;

// english notation without thousands separator
$english_format_number = number_format($number, 2, '.', '');
// 1234.57

?>

更新日志

版本 | 说明
7.2.0 | number_format() 现在无法返回 -0，之前可能返回 -0，因为 number 可能会是 -0.01。

参见

  • money_format() - 将数字格式化成货币字符串
  • sprintf() - Return a formatted string
  • printf() - 输出格式化字符串
  • sscanf() - 根据指定格式解析输入的字符


转换字符串第一个字节为 0-255 之间的值

  • ? number_format
  • parse_str ?
  • PHP Manual
  • 字符串 函数
  • 转换字符串第一个字节为 0-255 之间的值

ord

(PHP 4, PHP 5, PHP 7, PHP 8)

ord — 转换字符串第一个字节为 0-255 之间的值

说明

ord ( string $string ) : int

解析 string 二进制值第一个字节为 0 到 255 范围的无符号整型类型。

如果字符串是 ASCII、 ISO-8859、Windows 1252之类单字节编码，就等于返回该字符在字符集编码表中的位置。 但请注意，本函数不会去检测字符串的编码，尤其是不会识别类似 UTF-8 或 UTF-16 这种多字节字符的 Unicode 代码点（code point）。

该函数是 chr() 的互补函数。

参数

string

一个字符。

返回值

返回 0 - 255 的整型值。

范例

Example #1 ord() 范例

<?php
$str = "\n";
if (ord($str) == 10) {
    echo "The first character of \$str is a line feed.\n";
}
?>

Example #2 检查 UTF-8 字符串的每一个字节

<?php
declare(encoding='UTF-8');
$str = "??";
for ( $pos=0; $pos < strlen($str); $pos ++ ) {
 $byte = substr($str, $pos);
 echo 'Byte ' . $pos . ' of $str has value ' . ord($byte) . PHP_EOL;
}
?>

以上例程会输出：

Byte 0 of $str has value 240
Byte 1 of $str has value 159
Byte 2 of $str has value 144
Byte 3 of $str has value 152

参见

  • chr() - 返回指定的字符
  • » ASCII 码表


将字符串解析成多个变量

  • ? ord
  • print ?
  • PHP Manual
  • 字符串 函数
  • 将字符串解析成多个变量

parse_str

(PHP 4, PHP 5, PHP 7, PHP 8)

parse_str — 将字符串解析成多个变量

说明

parse_str ( string $string , array &$result ) : void

如果 string 是 URL 传递入的查询字符串（query string），则将它解析为变量并设置到当前作用域（如果提供了 result 则会设置到该数组里 ）。

参数

string

输入的字符串。

result

如果设置了第二个变量 result， 变量将会以数组元素的形式存入到这个数组，作为替代。

Warning

极度不建议 在没有 result 参数的情况下使用此函数， 并且在 PHP 7.2 中将废弃不设置参数的行为。

返回值

没有返回值。

更新日志

版本 | 说明
8.0.0 | result 是必须项。
7.2.0 | 不带第二个参数的情况下使用 parse_str() 会产生 E_DEPRECATED 警告。

范例

Example #1 parse_str() 的使用

<?php
$str = "first=value&arr[]=foo+bar&arr[]=baz";

// 推荐用法
parse_str($str, $output);
echo $output['first'];  // value
echo $output['arr'][0]; // foo bar
echo $output['arr'][1]; // baz

// 不建议这么用
parse_str($str);
echo $first;  // value
echo $arr[0]; // foo bar
echo $arr[1]; // baz
?>

由于 PHP 的变量名不能带「点」和「空格」，所以它们会被转化成下划线。 用本函数带 result 参数，也会应用同样规则到数组的键名。

Example #2 parse_str() 名称改写

<?php
parse_str("My Value=Something");
echo $My_Value; // Something

parse_str("My Value=Something", $output);
echo $output['My_Value']; // Something
?>

注释

Note:

所有创建的变量(或者在设置第二个参数的情况下，返回数组里的值)， 都已经 urldecode() 了。

Note:

要获取当前的 QUERY_STRING，可以使用 $_SERVER['QUERY_STRING'] 变量。 所以你可能想要阅读 来自 PHP 之外的变量这个章节。

Note:

本函数受 magic_quotes_gpc 设置的影响， 和 $_GET、 $_POST 在 PHP 中填充变量相似， parse_str() 也使用了同样的机制。

参见

  • parse_url() - 解析 URL，返回其组成部分
  • pathinfo() - 返回文件路径的信息
  • http_build_query() - 生成 URL-encode 之后的请求字符串
  • urldecode() - 解码已编码的 URL 字符串


输出字符串

  • ? parse_str
  • printf ?
  • PHP Manual
  • 字符串 函数
  • 输出字符串

print

(PHP 4, PHP 5, PHP 7, PHP 8)

print — 输出字符串

说明

print ( string $arg ) : int

输出 arg。

print 实际上不是函数（而是语言结构），所以可以不用圆括号包围参数列表。

和 echo 最主要的区别： print 仅支持一个参数，并总是返回 1。

参数

arg

输入数据。

返回值

总是返回 1。

范例

Example #1 print 范例

<?php
print("Hello World");

print "print() also works without parentheses.";

print "This spans
multiple lines. The newlines will be
output as well";

print "This spans\nmultiple lines. The newlines will be\noutput as well.";

print "escaping characters is done \"Like this\".";

// 可以在打印语句中使用变量
$foo = "foobar";
$bar = "barbaz";

print "foo is $foo"; // foo is foobar

// 也可以使用数组
$bar = array("value" => "foo");

print "this is {$bar['value']} !"; // this is foo !

// 使用单引号将打印变量名，而不是变量的值
print 'foo is $foo'; // foo is $foo

// 如果没有使用任何其他字符，可以仅打印变量
print $foo;          // foobar

print <<<END
This uses the "here document" syntax to output
multiple lines with $variable interpolation. Note
that the here document terminator must appear on a
line with just a semicolon no extra whitespace!
END;
?>

注释

Note: 因为是一个语言构造器而不是一个函数，不能被 可变函数 调用。

参见

  • echo - 输出一个或多个字符串
  • printf() - 输出格式化字符串
  • flush() - 刷新输出缓冲
  • Heredoc syntax


输出格式化字符串

  • ? print
  • quoted_printable_decode ?
  • PHP Manual
  • 字符串 函数
  • 输出格式化字符串

printf

(PHP 4, PHP 5, PHP 7, PHP 8)

printf — 输出格式化字符串

说明

printf ( string $format , mixed $args = ? , mixed $... = ? ) : int

依据 format 格式参数产生输出。

参数

format

format 描述信息，请参见 sprintf()。

args

...

返回值

返回输出字符串的长度。

参见

  • print - 输出字符串
  • sprintf() - Return a formatted string
  • vprintf() - 输出格式化字符串
  • sscanf() - 根据指定格式解析输入的字符
  • fscanf() - 从文件中格式化输入
  • flush() - 刷新输出缓冲


将 quoted-printable 字符串转换为 8-bit 字符串

  • ? printf
  • quoted_printable_encode ?
  • PHP Manual
  • 字符串 函数
  • 将 quoted-printable 字符串转换为 8-bit 字符串

quoted_printable_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

quoted_printable_decode — 将 quoted-printable 字符串转换为 8-bit 字符串

说明

quoted_printable_decode ( string $str ) : string

该函数返回 quoted-printable 解码之后的 8-bit 字符串 (参考 » RFC2045 的6.7章节，而不是 » RFC2821 的4.5.2章节，so additional periods are not stripped from the beginning of line)

该函数与 imap_qprint() 函数十分相似，但是该函数不需要依赖 IMAP 模块。

参数

str

输入的字符串。

返回值

返回的 8-bit 二进制字符串。

参见

  • quoted_printable_encode() - 将 8-bit 字符串转换成 quoted-printable 字符串


将 8-bit 字符串转换成 quoted-printable 字符串

  • ? quoted_printable_decode
  • quotemeta ?
  • PHP Manual
  • 字符串 函数
  • 将 8-bit 字符串转换成 quoted-printable 字符串

quoted_printable_encode

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

quoted_printable_encode — 将 8-bit 字符串转换成 quoted-printable 字符串

说明

quoted_printable_encode ( string $str ) : string

返回 quoted-printable 格式的字符，该格式由 » RFC2045 6.7.章节里制定。

该函数与 imap_8bit() 函数十分相似，不同的是该函数不需要 IMAP 模块就能运行。

参数

str

输入的字符串。

返回值

返回编码之后的字符串。

参见

  • quoted_printable_decode() - 将 quoted-printable 字符串转换为 8-bit 字符串
  • iconv_mime_encode() - Composes a MIME header field


转义元字符集

  • ? quoted_printable_encode
  • rtrim ?
  • PHP Manual
  • 字符串 函数
  • 转义元字符集

quotemeta

(PHP 4, PHP 5, PHP 7, PHP 8)

quotemeta — 转义元字符集

说明

quotemeta ( string $str ) : string

返回 在下面这些特殊字符前加 反斜线(\) 转义后的字符串。 这些特殊字符包含：

. \ + * ? [ ^ ] ( $ )

参数

str

输入字符串

返回值

返回 元字符集被转义后的 字符串，如果输入字符串str为空， 则返回 false。

注释

Note: 此函数可安全用于二进制对象。

参见

  • addslashes() - 使用反斜线引用字符串
  • addcslashes() - 以 C 语言风格使用反斜线转义字符串中的字符
  • htmlentities() - 将字符转换为 HTML 转义字符
  • htmlspecialchars() - 将特殊字符转换为 HTML 实体
  • nl2br() - 在字符串所有新行之前插入 HTML 换行标记
  • stripslashes() - 反引用一个引用字符串
  • stripcslashes() - 反引用一个使用 addcslashes 转义的字符串
  • ereg() - 正则表达式匹配
  • preg_quote() - 转义正则表达式字符


删除字符串末端的空白字符（或者其他字符）

  • ? quotemeta
  • setlocale ?
  • PHP Manual
  • 字符串 函数
  • 删除字符串末端的空白字符（或者其他字符）

rtrim

(PHP 4, PHP 5, PHP 7, PHP 8)

rtrim — 删除字符串末端的空白字符（或者其他字符）

说明

rtrim ( string $str , string $character_mask = ? ) : string

该函数删除 str 末端的空白字符（或者其他字符）并返回。

不使用第二个参数，rtrim() 仅删除以下字符：

  • " " (ASCII 32 (0x20))，普通空白符。
  • "\t" (ASCII 9 (0x09))，制表符。
  • "\n" (ASCII 10 (0x0A))，换行符。
  • "\r" (ASCII 13 (0x0D))，回车符。
  • "\0" (ASCII 0 (0x00))，NUL 空字节符。
  • "\x0B" (ASCII 11 (0x0B))，垂直制表符。

参数

str

输入字符串。

character_mask

通过指定 character_mask，可以指定想要删除的字符列表。简单地列出你想要删除的全部字符。使用 .. 格式，可以指定一个范围。

返回值

返回改变后的字符串。

范例

Example #1 rtrim() 使用范例

<?php

$text = "\t\tThese are a few words :) ...  ";
$binary = "\x09Example string\x0A";
$hello  = "Hello World";
var_dump($text, $binary, $hello);

print "\n";

$trimmed = rtrim($text);
var_dump($trimmed);

$trimmed = rtrim($text, " \t.");
var_dump($trimmed);

$trimmed = rtrim($hello, "Hdle");
var_dump($trimmed);

// 删除 $binary 末端的 ASCII 码控制字符
// (包括 0 - 31)
$clean = rtrim($binary, "\x00..\x1F");
var_dump($clean);

?>

以上例程会输出：

string(32) "        These are a few words :) ...  "
string(16) "    Example string
"
string(11) "Hello World"

string(30) "        These are a few words :) ..."
string(26) "        These are a few words :)"
string(9) "Hello Wor"
string(15) "    Example string"

参见

  • trim() - 去除字符串首尾处的空白字符（或者其他字符）
  • ltrim() - 删除字符串开头的空白字符（或其他字符）


设置地区信息

  • ? rtrim
  • sha1_file ?
  • PHP Manual
  • 字符串 函数
  • 设置地区信息

setlocale

(PHP 4, PHP 5, PHP 7, PHP 8)

setlocale — 设置地区信息

说明

setlocale ( int $category , string $locale , string $... = ? ) : string
setlocale ( int $category , array $locale ) : string

设置地区信息。

参数

category

category 命名常量指定的受区域设置的功能类别:

  • LC_ALL 所有的设置
  • LC_COLLATE 字符串比较, 详见 strcoll()
  • LC_CTYPE 字符串的分类与转换, 参见例子 strtoupper()
  • LC_MONETARY 等同 localeconv()
  • LC_NUMERIC 对于小数点的分隔 (另请参见 localeconv())
  • LC_TIME 时间与格式 strftime()
  • LC_MESSAGES 系统响应 (如果PHP使用libintl编译)

locale

If locale is null or the empty string "", the locale names will be set from the values of environment variables with the same names as the above categories, or from "LANG".

If locale is "0", the locale setting is not affected, only the current setting is returned.

If locale is an array or followed by additional parameters then each array element or parameter is tried to be set as new locale until success. This is useful if a locale is known under different names on different systems or for providing a fallback for a possibly not available locale.

...

(可使用字符串或数组参数进行尝试直到设置成功。)

Note:

在Windows中，setlocale(LC_ALL, '')要从系统中的区域/语言设置(通过控制面板访问) 。

返回值

Returns the new current locale, or false if the locale functionality is not implemented on your platform, the specified locale does not exist or the category name is invalid.

An invalid category name also causes a warning message. Category/locale names can be found in » RFC 1766 and » ISO 639. Different systems have different naming schemes for locales.

Note:

The return value of setlocale() depends on the system that PHP is running. It returns exactly what the system setlocale function returns.

更新日志

版本 | 说明
5.3.0 | This function now throws an E_DEPRECATED notice if a string is passed to the category parameter instead of one of the LC_* constants.

范例

Example #1 setlocale() Examples

<?php
/* Set locale to Dutch */
setlocale(LC_ALL, 'nl_NL');

/* Output: vrijdag 22 december 1978 */
echo strftime("%A %e %B %Y", mktime(0, 0, 0, 12, 22, 1978));

/* try different possible locale names for german as of PHP 4.3.0 */
$loc_de = setlocale(LC_ALL, 'de_DE@euro', 'de_DE', 'de', 'ge');
echo "Preferred locale for german on this system is '$loc_de'";
?>

Example #2 setlocale() Examples for Windows

<?php
/* Set locale to Dutch */
setlocale(LC_ALL, 'nld_nld');

/* Output: vrijdag 22 december 1978 */
echo strftime("%A %d %B %Y", mktime(0, 0, 0, 12, 22, 1978));

/* try different possible locale names for german as of PHP 4.3.0 */
$loc_de = setlocale(LC_ALL, 'de_DE@euro', 'de_DE', 'deu_deu');
echo "Preferred locale for german on this system is '$loc_de'";
?>

注释

Warning

The locale information is maintained per process, not per thread. If you are running PHP on a multithreaded server API like IIS or Apache on Windows, you may experience sudden changes in locale settings while a script is running, though the script itself never called setlocale(). This happens due to other scripts running in different threads of the same process at the same time, changing the process-wide locale using setlocale().

Tip

Windows users will find useful information about locale strings at Microsoft's MSDN website. Supported language strings can be found in the » language strings documentation and supported country/region strings in the » country/region strings documentation.


计算文件的 sha1 散列值

  • ? setlocale
  • sha1 ?
  • PHP Manual
  • 字符串 函数
  • 计算文件的 sha1 散列值

sha1_file

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

sha1_file — 计算文件的 sha1 散列值

说明

sha1_file ( string $filename , bool $raw_output = false ) : string

利用 » 美国安全散列算法 1，计算并返回由 filename 指定的文件的 sha1 散列值。该散列值是一个 40 字符长度的十六进制数字。

参数

filename

要散列的文件的文件名。

raw_output

如果被设置为 true，sha1 摘要将以 20 字符长度的原始格式返回。

返回值

成功返回一个字符串，否则返回 false。

范例

Example #1 sha1_file() 范例

<?php
foreach(glob('/home/Kalle/myproject/*.php') as $ent)
{
    if(is_dir($ent))
    {
        continue;
    }

    echo $ent . ' (SHA1: ' . sha1_file($ent) . ')', PHP_EOL;
}
?>

参见

  • sha1() - 计算字符串的 sha1 散列值
  • md5_file() - 计算指定文件的 MD5 散列值
  • crc32() - 计算一个字符串的 crc32 多项式


计算字符串的 sha1 散列值

  • ? sha1_file
  • similar_text ?
  • PHP Manual
  • 字符串 函数
  • 计算字符串的 sha1 散列值

sha1

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

sha1 — 计算字符串的 sha1 散列值

Warning

由于此函数依赖的算法已不足够复杂,不推荐使用此函数对明文密码加密。详细内容参见 这里。

说明

sha1 ( string $str , bool $raw_output = false ) : string

利用» 美国安全散列算法 1 计算字符串的 sha1 散列值。

参数

str

输入字符串。

raw_output

如果可选的 raw_output 参数被设置为 true， 那么 sha1 摘要将以 20 字符长度的原始格式返回， 否则返回值是一个 40 字符长度的十六进制数字。

返回值

返回 sha1 散列值字符串。

范例

Example #1 sha1() 范例

<?php
$str = 'apple';

if (sha1($str) === 'd0be2dc421be4fcd0172e5afceea3970e2f3d940') {
    echo "Would you like a green or red apple?";
}
?>

参见

  • sha1_file() - 计算文件的 sha1 散列值
  • crc32() - 计算一个字符串的 crc32 多项式
  • md5() - 计算字符串的 MD5 散列值
  • hash() - 生成哈希值 （消息摘要）
  • crypt() - 单向字符串散列
  • password_hash() - 创建密码的散列（hash）


计算两个字符串的相似度

  • ? sha1
  • soundex ?
  • PHP Manual
  • 字符串 函数
  • 计算两个字符串的相似度

similar_text

(PHP 4, PHP 5, PHP 7, PHP 8)

similar_text — 计算两个字符串的相似度

说明

similar_text ( string $first , string $second , float &$percent = ? ) : int

两个字符串的相似程度计算依据 Programming Classics: Implementing the World's Best Algorithms by Oliver (ISBN 0-131-00413-1) 的描述进行。注意该实现没有使用 Oliver 虚拟码中的堆栈，但是却进行了递归调用，这个做法可能会导致整个过程变慢或变快。也请注意，该算法的复杂度是 O(N**3)，N 是最长字符串的长度。

参数

first

第一个字符串。

second

第二个字符串。

percent

通过引用方式传递第三个参数，similar_text() 将计算相似程度百分数。

返回值

返回在两个字符串中匹配字符的数目。

参见

  • levenshtein() - 计算两个字符串之间的编辑距离
  • soundex() - Calculate the soundex key of a string


Calculate the soundex key of a string

  • ? similar_text
  • sprintf ?
  • PHP Manual
  • 字符串 函数
  • Calculate the soundex key of a string

soundex

(PHP 4, PHP 5, PHP 7, PHP 8)

soundex — Calculate the soundex key of a string

说明

soundex ( string $string ) : string

Calculates the soundex key of string.

Soundex keys have the property that words pronounced similarly produce the same soundex key, and can thus be used to simplify searches in databases where you know the pronunciation but not the spelling.

This particular soundex function is one described by Donald Knuth in "The Art Of Computer Programming, vol. 3: Sorting And Searching", Addison-Wesley (1973), pp. 391-392.

参数

string

The input string.

返回值

Returns the soundex key as a string with four characters. If at least one letter is contained in string, the returned string starts with a letter. Otherwise "0000" is returned.

更新日志

版本 | 说明
8.0.0 | Prior to this version, calling the function with an empty string returned false for no particular reason.

范例

Example #1 Soundex Examples

<?php
soundex("Euler")       == soundex("Ellery");    // E460
soundex("Gauss")       == soundex("Ghosh");     // G200
soundex("Hilbert")     == soundex("Heilbronn"); // H416
soundex("Knuth")       == soundex("Kant");      // K530
soundex("Lloyd")       == soundex("Ladd");      // L300
soundex("Lukasiewicz") == soundex("Lissajous"); // L222
?>

参见

  • levenshtein() - 计算两个字符串之间的编辑距离
  • metaphone() - Calculate the metaphone key of a string
  • similar_text() - 计算两个字符串的相似度


Return a formatted string

  • ? soundex
  • sscanf ?
  • PHP Manual
  • 字符串 函数
  • Return a formatted string

sprintf

(PHP 4, PHP 5, PHP 7, PHP 8)

sprintf — Return a formatted string

说明

sprintf ( string $format , mixed ...$values ) : string

Returns a string produced according to the formatting string format.

参数

format

The format string is composed of zero or more directives: ordinary characters (excluding %) that are copied directly to the result and conversion specifications, each of which results in fetching its own parameter.

A conversion specification follows this prototype: %[argnum$][flags][width][.precision]specifier.

Argnum

An integer followed by a dollar sign $, to specify which number argument to treat in the conversion.

Flags
Flag | 说明
- Left-justify within the given field width; Right justification is the default
+ Prefix positive numbers with a plus sign +; Default only negative are prefixed with a negative sign.
(space) | Pads the result with spaces. This is the default.
0 | Only left-pads numbers with zeros. With s specifiers this can also right-pad with zeros.
'(char) | Pads the result with the character (char).

Width

An integer that says how many characters (minimum) this conversion should result in.

Precision

A period . followed by an integer who's meaning depends on the specifier:

  • For e, E, f and F specifiers: this is the number of digits to be printed after the decimal point (by default, this is 6).
  • For g and G specifiers: this is the maximum number of significant digits to be printed.
  • For s specifier: it acts as a cutoff point, setting a maximum character limit to the string.

Note: If the period is specified without an explicit value for precision, 0 is assumed.

Note: Attempting to use a position specifier greater than PHP_INT_MAX will generate warnings.

Specifiers
Specifier | 说明
% A literal percent character. No argument is required.
b | The argument is treated as an integer and presented as a binary number.
c | The argument is treated as an integer and presented as the character with that ASCII.
d | The argument is treated as an integer and presented as a (signed) decimal number.
e | The argument is treated as scientific notation (e.g. 1.2e+2). The precision specifier stands for the number of digits after the decimal point since PHP 5.2.1. In earlier versions, it was taken as number of significant digits (one less).
E | Like the e specifier but uses uppercase letter (e.g. 1.2E+2).
f | The argument is treated as a float and presented as a floating-point number (locale aware).
F | The argument is treated as a float and presented as a floating-point number (non-locale aware). Available as of PHP 5.0.3.
g

General format.

Let P equal the precision if nonzero, 6 if the precision is omitted, or 1 if the precision is zero. Then, if a conversion with style E would have an exponent of X:

If P > X ≥ ?4, the conversion is with style f and precision P ? (X + 1). Otherwise, the conversion is with style e and precision P ? 1.

G | Like the g specifier but uses E and f.
h | Like the g specifier but uses F. Available as of PHP 8.0.0.
H | Like the g specifier but uses E and F. Available as of PHP 8.0.0.
o | The argument is treated as an integer and presented as an octal number.
s | The argument is treated and presented as a string.
u | The argument is treated as an integer and presented as an unsigned decimal number.
x | The argument is treated as an integer and presented as a hexadecimal number (with lowercase letters).
X | The argument is treated as an integer and presented as a hexadecimal number (with uppercase letters).

Warning

The c type specifier ignores padding and width

Warning

Attempting to use a combination of the string and width specifiers with character sets that require more than one byte per character may result in unexpected results

Variables will be co-erced to a suitable type for the specifier:

Type Handling
Type | Specifiers
string | s
integer | d, u, c, o, x, X, b
double | g, G, e, E, f, F

values

返回值

Returns a string produced according to the formatting string format.

更新日志

版本 | 说明
8.0.0 | This function no longer returns false on failure.

范例

Example #1 Argument swapping

The format string supports argument numbering/swapping.

<?php
$num = 5;
$location = 'tree';

$format = 'There are %d monkeys in the %s';
echo sprintf($format, $num, $location);
?>

以上例程会输出：

There are 5 monkeys in the tree

However imagine we are creating a format string in a separate file, commonly because we would like to internationalize it and we rewrite it as:

<?php
$format = 'The %s contains %d monkeys';
echo sprintf($format, $num, $location);
?>

We now have a problem. The order of the placeholders in the format string does not match the order of the arguments in the code. We would like to leave the code as is and simply indicate in the format string which arguments the placeholders refer to. We would write the format string like this instead:

<?php
$format = 'The %2$s contains %1$d monkeys';
echo sprintf($format, $num, $location);
?>

An added benefit is that placeholders can be repeated without adding more arguments in the code.

<?php
$format = 'The %2$s contains %1$d monkeys.
           That\'s a nice %2$s full of %1$d monkeys.';
echo sprintf($format, $num, $location);
?>

When using argument swapping, the n$ position specifier must come immediately after the percent sign (%), before any other specifiers, as shown below.

Example #2 Specifying padding character

<?php
echo sprintf("%'.9d\n", 123);
echo sprintf("%'.09d\n", 123);
?>

以上例程会输出：

......123
000000123

Example #3 Position specifier with other specifiers

<?php
$format = 'The %2$s contains %1$04d monkeys';
echo sprintf($format, $num, $location);
?>

以上例程会输出：

The tree contains 0005 monkeys

Example #4 sprintf(): zero-padded integers

<?php
$isodate = sprintf("%04d-%02d-%02d", $year, $month, $day);
?>

Example #5 sprintf(): formatting currency

<?php
$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
echo $money;
echo "\n";
$formatted = sprintf("%01.2f", $money);
echo $formatted;
?>

以上例程会输出：

123.1
123.10

Example #6 sprintf(): scientific notation

<?php
$number = 362525200;

echo sprintf("%.3e", $number);
?>

以上例程会输出：

3.625e+8

参见

  • printf() - 输出格式化字符串
  • fprintf() - 将格式化后的字符串写入到流
  • vprintf() - 输出格式化字符串
  • vsprintf() - 返回格式化字符串
  • vfprintf() - 将格式化字符串写入流
  • sscanf() - 根据指定格式解析输入的字符
  • fscanf() - 从文件中格式化输入
  • number_format() - 以千位分隔符方式格式化一个数字
  • date() - 格式化一个本地时间／日期


根据指定格式解析输入的字符

  • ? sprintf
  • str_contains ?
  • PHP Manual
  • 字符串 函数
  • 根据指定格式解析输入的字符

sscanf

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

sscanf — 根据指定格式解析输入的字符

说明

sscanf ( string $str , string $format , mixed &$... = ? ) : mixed

这个函数 sscanf() 输入类似
printf()。 sscanf()
读取字符串str 然后根据指定格式format解析, 格式的描述文档见 sprintf()。

指定的格式字符串中的任意空白匹配输入字符串的任意空白.也就是说即使是格式字符串中的一个制表符 \t 也能匹配输入 字符串中的一个单一空格字符

参数

str

将要被解析的 字符串.

format

The interpreted format for 解析str的格式, 除了以下不同外，其余的见 sprintf()的描述文档:

  • 函数不区分语言地区
  • F, g, G 和 b 不被支持.
  • D 表示十进制数字.
  • i stands for integer with base detection.
  • n 代表目前已经处理的字符数。
  • s 遇到任意空格字符时停止读取。

...

可以选参数将以引用方式传入，它们的值将被设置为解析匹配的值

返回值

如果仅传入了两个参数给这个函数，解析后将返回一个数组，否则，如果可选参数被传入，这个函数将返回被设置了值的个数

如果format存在的子字符串比 str内可用的多, -1 将被返回.

范例

Example #1 sscanf() 例子

<?php
// getting the serial number
list($serial) = sscanf("SN/2350001", "SN/%d");
// and the date of manufacturing
$mandate = "January 01 2000";
list($month, $day, $year) = sscanf($mandate, "%s %d %d");
echo "Item $serial was manufactured on: $year-" . substr($month, 0, 3) . "-$day\n";
?>

If optional parameters are passed, the function will return the number of assigned values.

Example #2 sscanf() - using optional parameters

<?php
// get author info and generate DocBook entry
$auth = "24\tLewis Carroll";
$n = sscanf($auth, "%d\t%s %s", $id, $first, $last);
echo "<author id='$id'>
    <firstname>$first</firstname>
    <surname>$last</surname>
</author>\n";
?>

参见

  • fscanf() - 从文件中格式化输入
  • printf() - 输出格式化字符串
  • sprintf() - Return a formatted string


Determine if a string contains a given substring

  • ? sscanf
  • str_ends_with ?
  • PHP Manual
  • 字符串 函数
  • Determine if a string contains a given substring

str_contains

(PHP 8)

str_contains — Determine if a string contains a given substring

说明

str_contains ( string $haystack , string $needle ) : bool

Performs a case-sensitive check indicating if needle is contained in haystack.

参数

haystack

The string to search in.

needle

The substring to search for in the haystack.

返回值

Returns true if needle is in haystack, false otherwise.

范例

Example #1 Using the empty string ''

<?php
if (str_contains('abc', '')) {
    echo "Checking the existence of the empty string will always return true";
}
?>

以上例程会输出：

Checking the existence of the empty string will always return true

Example #2 Showing case-sensitivity

<?php
$string = 'The lazy fox jumped over the fence';

if (str_contains($string, 'lazy')) {
    echo "The string 'lazy' was found in the string\n";
}

if (str_contains($string, 'Lazy')) {
    echo 'The string "Lazy" was found in the string';
} else {
    echo '"Lazy" was not found because the case does not match';
}

?>

以上例程会输出：

The string 'lazy' was found in the string
"Lazy" was not found because the case does not match

注释

Note: 此函数可安全用于二进制对象。

参见

  • str_ends_with() - Checks if a string ends with a given substring
  • str_starts_with() - Checks if a string starts with a given substring
  • stripos() - 查找字符串首次出现的位置（不区分大小写）
  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置
  • strripos() - 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
  • strstr() - 查找字符串的首次出现
  • strpbrk() - 在字符串中查找一组字符的任何一个字符
  • substr() - 返回字符串的子串
  • preg_match() - 执行匹配正则表达式


Checks if a string ends with a given substring

  • ? str_contains
  • str_getcsv ?
  • PHP Manual
  • 字符串 函数
  • Checks if a string ends with a given substring

str_ends_with

(PHP 8)

str_ends_with — Checks if a string ends with a given substring

说明

str_ends_with ( string $haystack , string $needle ) : bool

Performs a case-sensitive check indicating if haystack ends with needle.

参数

haystack

The string to search in.

needle

The substring to search for in the haystack.

返回值

Returns true if haystack ends with needle, false otherwise.

范例

Example #1 Using the empty string ''

<?php
if (str_ends_with('abc', '')) {
    echo "All strings end with the empty string";
}
?>

以上例程会输出：

All strings end with the empty string

Example #2 Showing case-sensitivity

<?php
$string = 'The lazy fox jumped over the fence';

if (str_ends_with($string, 'fence')) {
    echo "The string ends with 'fence'\n";
}

if (str_ends_with($string, 'Fence')) {
    echo 'The string ends with "fence"';
} else {
    echo '"fence" was not found because the case does not match';
}

?>

以上例程会输出：

The string ends with 'fence'
"fence" was not found because the case does not match

注释

Note: 此函数可安全用于二进制对象。

参见

  • str_contains() - Determine if a string contains a given substring
  • str_starts_with() - Checks if a string starts with a given substring
  • stripos() - 查找字符串首次出现的位置（不区分大小写）
  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置
  • strripos() - 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
  • strstr() - 查找字符串的首次出现
  • strpbrk() - 在字符串中查找一组字符的任何一个字符
  • substr() - 返回字符串的子串
  • preg_match() - 执行匹配正则表达式


解析 CSV 字符串为一个数组

  • ? str_ends_with
  • str_ireplace ?
  • PHP Manual
  • 字符串 函数
  • 解析 CSV 字符串为一个数组

str_getcsv

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

str_getcsv — 解析 CSV 字符串为一个数组

说明

str_getcsv ( string $input , string $delimiter = "," , string $enclosure = '"' , string $escape = "\\" ) : array

以 CSV 字段格式解析字符串输入，并返回包含读取字段的数组。

参数

input

待解析的字符串。

delimiter

设定字段界定符（仅单个字符）。

enclosure

设定字段包裹字符（仅单个字符）。

escape

设置转义字符（仅单个字符）。默认为反斜线（\）。

返回值

返回一个包含读取到的字段的索引数组。

参见

  • fgetcsv() - 从文件指针中读入一行并解析 CSV 字段


str_replace 的忽略大小写版本

  • ? str_getcsv
  • str_pad ?
  • PHP Manual
  • 字符串 函数
  • str_replace 的忽略大小写版本

str_ireplace

(PHP 5, PHP 7, PHP 8)

str_ireplace — str_replace() 的忽略大小写版本

说明

str_ireplace ( mixed $search , mixed $replace , mixed $subject , int &$count = ? ) : mixed

该函数返回一个字符串或者数组。该字符串或数组是将 subject 中全部的 search 都被 replace 替换（忽略大小写）之后的结果。如果没有一些特殊的替换规则，你应该使用该函数替换带有 i 修正符的 preg_replace() 函数。

参数

如果 search 和 replace 为数组，那么 str_ireplace() 将对 subject 做二者的映射替换。如果 replace 的值的个数少于 search 的个数，多余的替换将使用空字符串来进行。如果 search 是一个数组而 replace 是一个字符串，那么 search 中每个元素的替换将始终使用这个字符串。

如果 search 或 replace 是数组，他们的元素将从头到尾一个个处理。

search

要搜索的值，就像是 needle。可以使用 array 来提供多个 needle。

replace

search 的替换值。一个数组可以被用来指定多重替换。

subject

要被搜索和替换的字符串或数组，就像是 haystack。

如果 subject 是一个数组，替换操作将遍历整个 subject，并且也将返回一个数组。

count

如果被指定，它的值将被设置为替换发生的次数。

返回值

返回替换后的字符串或者数组。

范例

Example #1 str_ireplace() 范例

<?php
$bodytag = str_ireplace("%body%", "black", "<body text=%BODY%>");
echo $bodytag; // <body text=black>
?>

注释

Note: 此函数可安全用于二进制对象。

Caution

Replacement order gotcha

Because str_ireplace() replaces left to right, it might replace a previously inserted value when doing multiple replacements. Example #2 in the str_replace() documentation demonstrates how this may affect you in practice.

参见

  • str_replace() - 子字符串替换
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • strtr() - 转换指定字符


使用另一个字符串填充字符串为指定长度

  • ? str_ireplace
  • str_repeat ?
  • PHP Manual
  • 字符串 函数
  • 使用另一个字符串填充字符串为指定长度

str_pad

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

str_pad — 使用另一个字符串填充字符串为指定长度

说明

str_pad ( string $input , int $pad_length , string $pad_string = " " , int $pad_type = STR_PAD_RIGHT ) : string

该函数返回 input 被从左端、右端或者同时两端被填充到制定长度后的结果。如果可选的 pad_string 参数没有被指定，input 将被空格字符填充，否则它将被 pad_string 填充到指定长度。

参数

input

输入字符串。

pad_length

如果 pad_length 的值是负数，小于或者等于输入字符串的长度，不会发生任何填充，并会返回 input 。

pad_string

Note:

如果填充字符的长度不能被 pad_string 整除，那么 pad_string 可能会被缩短。

pad_type

可选的 pad_type 参数的可能值为 STR_PAD_RIGHT，STR_PAD_LEFT 或 STR_PAD_BOTH。如果没有指定 pad_type，则假定它是 STR_PAD_RIGHT。

返回值

返回填充后的字符串。

范例

Example #1 str_pad() 范例

<?php
$input = "Alien";
echo str_pad($input, 10);                      // 输出 "Alien     "
echo str_pad($input, 10, "-=", STR_PAD_LEFT);  // 输出 "-=-=-Alien"
echo str_pad($input, 10, "_", STR_PAD_BOTH);   // 输出 "__Alien___"
echo str_pad($input,  6, "___");               // 输出 "Alien_"
echo str_pad($input,  3, "*");                 // 输出 "Alien"
?>


重复一个字符串

  • ? str_pad
  • str_replace ?
  • PHP Manual
  • 字符串 函数
  • 重复一个字符串

str_repeat

(PHP 4, PHP 5, PHP 7, PHP 8)

str_repeat — 重复一个字符串

说明

str_repeat ( string $input , int $multiplier ) : string

返回 input 重复 multiplier 次后的结果。

参数

input

待操作的字符串。

multiplier

input 被重复的次数。

multiplier 必须大于等于 0。如果 multiplier 被设置为 0，函数返回空字符串。

返回值

返回重复后的字符串。

范例

Example #1 str_repeat() 范例

<?php
echo str_repeat("-=", 10);
?>

以上例程会输出：

-=-=-=-=-=-=-=-=-=-=

参见

  • for
  • str_pad() - 使用另一个字符串填充字符串为指定长度
  • substr_count() - 计算字串出现的次数


子字符串替换

  • ? str_repeat
  • str_rot13 ?
  • PHP Manual
  • 字符串 函数
  • 子字符串替换

str_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

str_replace — 子字符串替换

说明

str_replace ( mixed $search , mixed $replace , mixed $subject , int &$count = ? ) : mixed

该函数返回一个字符串或者数组。该字符串或数组是将 subject 中全部的 search 都被 replace 替换之后的结果。

如果没有一些特殊的替换需求（比如正则表达式），你应该使用该函数替换 ereg_replace() 和 preg_replace()。

参数

如果 search 和 replace 为数组，那么 str_replace() 将对 subject 做二者的映射替换。如果 replace 的值的个数少于 search 的个数，多余的替换将使用空字符串来进行。如果 search 是一个数组而 replace 是一个字符串，那么 search 中每个元素的替换将始终使用这个字符串。该转换不会改变大小写。

如果 search 和 replace 都是数组，它们的值将会被依次处理。

search

查找的目标值，也就是 needle。一个数组可以指定多个目标。

replace

search 的替换值。一个数组可以被用来指定多重替换。

subject

执行替换的数组或者字符串。也就是 haystack。

如果 subject 是一个数组，替换操作将遍历整个 subject，返回值也将是一个数组。

count

如果被指定，它的值将被设置为替换发生的次数。

返回值

该函数返回替换后的数组或者字符串。

范例

Example #1 str_replace() 基本范例

<?php
// 赋值: <body text='black'>
$bodytag = str_replace("%body%", "black", "<body text='%body%'>");

// 赋值: Hll Wrld f PHP
$vowels = array("a", "e", "i", "o", "u", "A", "E", "I", "O", "U");
$onlyconsonants = str_replace($vowels, "", "Hello World of PHP");

// 赋值: You should eat pizza, beer, and ice cream every day
$phrase  = "You should eat fruits, vegetables, and fiber every day.";
$healthy = array("fruits", "vegetables", "fiber");
$yummy   = array("pizza", "beer", "ice cream");

$newphrase = str_replace($healthy, $yummy, $phrase);

// 赋值: 2
$str = str_replace("ll", "", "good golly miss molly!", $count);
echo $count;
?>

Example #2 可能的 str_replace() 替换范例

<?php
// 替换顺序
$str     = "Line 1\nLine 2\rLine 3\r\nLine 4\n";
$order   = array("\r\n", "\n", "\r");
$replace = '<br />';

// 首先替换 \r\n 字符，因此它们不会被两次转换
$newstr = str_replace($order, $replace, $str);

// 输出 F ，因为 A 被 B 替换，B 又被 C 替换，以此类推...
// 由于从左到右依次替换，最终 E 被 F 替换
$search  = array('A', 'B', 'C', 'D', 'E');
$replace = array('B', 'C', 'D', 'E', 'F');
$subject = 'A';
echo str_replace($search, $replace, $subject);

// 输出: apearpearle pear
// 由于上面提到的原因
$letters = array('a', 'p');
$fruit   = array('apple', 'pear');
$text    = 'a p';
$output  = str_replace($letters, $fruit, $text);
echo $output;
?>

注释

Note: 此函数可安全用于二进制对象。

Caution

了解替换顺序

由于 str_replace() 的替换时从左到右依次进行的，进行多重替换的时候可能会替换掉之前插入的值。参见该文档的范例。

Note:

该函数区分大小写。使用 str_ireplace() 可以进行不区分大小写的替换。

参见

  • str_ireplace() - str_replace 的忽略大小写版本
  • substr_replace() - 替换字符串的子串
  • preg_replace() - 执行一个正则表达式的搜索和替换
  • strtr() - 转换指定字符


对字符串执行 ROT13 转换

  • ? str_replace
  • str_shuffle ?
  • PHP Manual
  • 字符串 函数
  • 对字符串执行 ROT13 转换

str_rot13

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

str_rot13 — 对字符串执行 ROT13 转换

说明

str_rot13 ( string $str ) : string

对 str 参数执行 ROT13 编码并将结果字符串返回。

ROT13 编码简单地使用字母表中后面第 13 个字母替换当前字母，同时忽略非字母表中的字符。编码和解码都使用相同的函数，传递一个编码过的字符串作为参数，将得到原始字符串。

参数

str

输入字符串。

返回值

返回给定字符串的 ROT13 版本。

范例

Example #1 str_rot13() 范例

<?php

echo str_rot13('PHP 4.3.0'); // CUC 4.3.0

?>


随机打乱一个字符串

  • ? str_rot13
  • str_split ?
  • PHP Manual
  • 字符串 函数
  • 随机打乱一个字符串

str_shuffle

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

str_shuffle — 随机打乱一个字符串

说明

str_shuffle ( string $str ) : string

str_shuffle() 函数打乱一个字符串，使用任何一种可能的排序方案。

Caution

本函数并不会生成安全加密的值，不应用于加密用途。若需要安全加密的值，考虑使用 random_int()、random_bytes() 或 openssl_random_pseudo_bytes() 替代。

参数

str

输入字符串。

返回值

返回打乱后的字符串。

更新日志

版本 | 说明
7.1.0 | 内置的随机算法从 libc rand 函数改成了 » 梅森旋转演伪随机数发生算法。

范例

Example #1 str_shuffle() 范例

<?php
$str = 'abcdef';
$shuffled = str_shuffle($str);

// 输出类似于: bfdaec
echo $shuffled;
?>

参见

  • shuffle() - 打乱数组
  • rand() - 产生一个随机整数


将字符串转换为数组

  • ? str_shuffle
  • str_starts_with ?
  • PHP Manual
  • 字符串 函数
  • 将字符串转换为数组

str_split

(PHP 5, PHP 7, PHP 8)

str_split — 将字符串转换为数组

说明

str_split ( string $string , int $split_length = 1 ) : array

将一个字符串转换为数组。

参数

string

输入字符串。

split_length

每一段的长度。

返回值

如果指定了可选的 split_length 参数，返回数组中的每个元素均为一个长度为 split_length 的字符块，否则每个字符块为单个字符。

如果 split_length 小于 1，返回 false。如果 split_length 参数超过了 string 超过了字符串 string 的长度，整个字符串将作为数组仅有的一个元素返回。

范例

Example #1 str_split() 使用范例

<?php

$str = "Hello Friend";

$arr1 = str_split($str);
$arr2 = str_split($str, 3);

print_r($arr1);
print_r($arr2);

?>

以上例程会输出：

Array
(
    [0] => H
    [1] => e
    [2] => l
    [3] => l
    [4] => o
    [5] =>
    [6] => F
    [7] => r
    [8] => i
    [9] => e
    [10] => n
    [11] => d
)

Array
(
    [0] => Hel
    [1] => lo
    [2] => Fri
    [3] => end
)

注释

Note:

在处理多字节字符时，str_split() 会按字节数转换，而非字符数。

参见

  • chunk_split() - 将字符串分割成小块
  • preg_split() - 通过一个正则表达式分隔字符串
  • explode() - 使用一个字符串分割另一个字符串
  • count_chars() - 返回字符串所用字符的信息
  • str_word_count() - 返回字符串中单词的使用情况
  • for


Checks if a string starts with a given substring

  • ? str_split
  • str_word_count ?
  • PHP Manual
  • 字符串 函数
  • Checks if a string starts with a given substring

str_starts_with

(PHP 8)

str_starts_with — Checks if a string starts with a given substring

说明

str_starts_with ( string $haystack , string $needle ) : bool

Performs a case-sensitive check indicating if haystack begins with needle.

参数

haystack

The string to search in.

needle

The substring to search for in the haystack.

返回值

Returns true if haystack begins with needle, false otherwise.

范例

Example #1 Using the empty string ''

<?php
if (str_starts_with('abc', '')) {
    echo "All strings start with the empty string";
}
?>

以上例程会输出：

All strings start with the empty string

Example #2 Showing case-sensitivity

<?php
$string = 'The lazy fox jumped over the fence';

if (str_starts_with($string, 'The')) {
    echo "The string starts with 'The'\n";
}

if (str_starts_with($string, 'the')) {
    echo 'The string starts with "the"';
} else {
    echo '"the" was not found because the case does not match';
}

?>

以上例程会输出：

The string starts with 'The'
"the" was not found because the case does not match

注释

Note: 此函数可安全用于二进制对象。

参见

  • str_contains() - Determine if a string contains a given substring
  • str_ends_with() - Checks if a string ends with a given substring
  • stripos() - 查找字符串首次出现的位置（不区分大小写）
  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置
  • strripos() - 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
  • strstr() - 查找字符串的首次出现
  • strpbrk() - 在字符串中查找一组字符的任何一个字符
  • substr() - 返回字符串的子串
  • preg_match() - 执行匹配正则表达式


返回字符串中单词的使用情况

  • ? str_starts_with
  • strcasecmp ?
  • PHP Manual
  • 字符串 函数
  • 返回字符串中单词的使用情况

str_word_count

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

str_word_count — 返回字符串中单词的使用情况

说明

str_word_count ( string $string , int $format = 0 , string $charlist = ? ) : mixed

统计 string 中单词的数量。如果可选的参数 format 没有被指定，那么返回值是一个代表单词数量的整型数。如果指定了 format 参数，返回值将是一个数组，数组的内容则取决于 format 参数。format 的可能值和相应的输出结果如下所列。

对于这个函数的目的来说，单词的定义是一个与区域设置相关的字符串。这个字符串可以包含字母字符，也可以包含 "'" 和 "-" 字符（但不能以这两个字符开始）。

参数

string

字符串。

format

指定函数的返回值。当前支持的值如下：

  • 0 - 返回单词数量
  • 1 - 返回一个包含 string 中全部单词的数组
  • 2 - 返回关联数组。数组的键是单词在 string 中出现的数值位置，数组的值是这个单词

charlist

附加的字符串列表，其中的字符将被视为单词的一部分。

返回值

返回一个数组或整型数，这取决于 format 参数的选择。

范例

Example #1 str_word_count() 范例

<?php

$str = "Hello fri3nd, you're
       looking          good today!";

print_r(str_word_count($str, 1));
print_r(str_word_count($str, 2));
print_r(str_word_count($str, 1, 'àá??3'));

echo str_word_count($str);

?>

以上例程会输出：

Array
(
    [0] => Hello
    [1] => fri
    [2] => nd
    [3] => you're
    [4] => looking
    [5] => good
    [6] => today
)

Array
(
    [0] => Hello
    [6] => fri
    [10] => nd
    [14] => you're
    [29] => looking
    [46] => good
    [51] => today
)

Array
(
    [0] => Hello
    [1] => fri3nd
    [2] => you're
    [3] => looking
    [4] => good
    [5] => today
)

7

参见

  • explode() - 使用一个字符串分割另一个字符串
  • preg_split() - 通过一个正则表达式分隔字符串
  • split() - 用正则表达式将字符串分割到数组中
  • count_chars() - 返回字符串所用字符的信息
  • substr_count() - 计算字串出现的次数


二进制安全比较字符串（不区分大小写）

  • ? str_word_count
  • strchr ?
  • PHP Manual
  • 字符串 函数
  • 二进制安全比较字符串（不区分大小写）

strcasecmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strcasecmp — 二进制安全比较字符串（不区分大小写）

说明

strcasecmp ( string $str1 , string $str2 ) : int

二进制安全比较字符串（不区分大小写）。

参数

str1

第一个字符串。

str2

第二个字符串。

返回值

如果 str1 小于 str2 返回 < 0； 如果 str1 大于 str2 返回 > 0；如果两者相等，返回 0。

范例

Example #1 strcasecmp() 范例

<?php
$var1 = "Hello";
$var2 = "hello";
if (strcasecmp($var1, $var2) == 0) {
    echo '$var1 is equal to $var2 in a case-insensitive string comparison';
}
?>

参见

  • strcmp() - 二进制安全字符串比较
  • preg_match() - 执行匹配正则表达式
  • substr_compare() - 二进制安全比较字符串（从偏移位置比较指定长度）
  • strncasecmp() - 二进制安全比较字符串开头的若干个字符（不区分大小写）
  • stristr() - strstr 函数的忽略大小写版本
  • substr() - 返回字符串的子串


别名 strstr

  • ? strcasecmp
  • strcmp ?
  • PHP Manual
  • 字符串 函数
  • 别名 strstr

strchr

(PHP 4, PHP 5, PHP 7, PHP 8)

strchr — 别名 strstr()

说明

此函数是该函数的别名： strstr().


二进制安全字符串比较

  • ? strchr
  • strcoll ?
  • PHP Manual
  • 字符串 函数
  • 二进制安全字符串比较

strcmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strcmp — 二进制安全字符串比较

说明

strcmp ( string $str1 , string $str2 ) : int

注意该比较区分大小写。

参数

str1

第一个字符串。

str2

第二个字符串。

返回值

如果 str1 小于 str2 返回 < 0； 如果 str1 大于 str2 返回 > 0；如果两者相等，返回 0。

范例

Example #1 strcmp() 例子

<?php
$var1 = "Hello";
$var2 = "hello";
if (strcmp($var1, $var2) !== 0) {
    echo '$var1 is not equal to $var2 in a case sensitive string comparison';
}
?>

参见

  • strcasecmp() - 二进制安全比较字符串（不区分大小写）
  • preg_match() - 执行匹配正则表达式
  • substr_compare() - 二进制安全比较字符串（从偏移位置比较指定长度）
  • strncmp() - 二进制安全比较字符串开头的若干个字符
  • strstr() - 查找字符串的首次出现
  • substr() - 返回字符串的子串


基于区域设置的字符串比较

  • ? strcmp
  • strcspn ?
  • PHP Manual
  • 字符串 函数
  • 基于区域设置的字符串比较

strcoll

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

strcoll — 基于区域设置的字符串比较

说明

strcoll ( string $str1 , string $str2 ) : int

注意该比较区分大小写。和 strcmp() 不同，该函数不是二进制安全的。

strcoll() 使用当前区域设置进行比较。如果当前区域为 C 或 POSIX，该函数等同于 strcmp()。

参数

str1

第一个字符串。

str2

第二个字符串。

返回值

如果 str1 小于 str2 返回 < 0； 如果 str1 大于 str2 返回 > 0；如果两者相等，返回 0。

更新日志

版本 | 说明
4.2.3 | 函数在 Win32 平台可用。

参见

  • preg_match() - 执行匹配正则表达式
  • strcmp() - 二进制安全字符串比较
  • strcasecmp() - 二进制安全比较字符串（不区分大小写）
  • substr() - 返回字符串的子串
  • stristr() - strstr 函数的忽略大小写版本
  • strncasecmp() - 二进制安全比较字符串开头的若干个字符（不区分大小写）
  • strncmp() - 二进制安全比较字符串开头的若干个字符
  • strstr() - 查找字符串的首次出现
  • setlocale() - 设置地区信息


获取不匹配遮罩的起始子字符串的长度

  • ? strcoll
  • strip_tags ?
  • PHP Manual
  • 字符串 函数
  • 获取不匹配遮罩的起始子字符串的长度

strcspn

(PHP 4, PHP 5, PHP 7, PHP 8)

strcspn — 获取不匹配遮罩的起始子字符串的长度

说明

strcspn ( string $str1 , string $str2 , int $start = ? , int $length = ? ) : int

返回 str1 中，所有字符都不存在于 str2 范围的起始子字符串的长度。

参数

str1

第一个字符串。

str2

第二个字符串。

start

查找的起始位置。

length

查找的长度。

返回值

以整型数返回子串的长度。

范例

Example #1 strcspn() example

<?php
$a = strcspn('abcd',  'apple');
$b = strcspn('abcd',  'banana');
$c = strcspn('hello', 'l');
$d = strcspn('hello', 'world');

var_dump($a);
var_dump($b);
var_dump($c);
var_dump($d);
?>

以上例程会输出：

int(0)
int(0)
int(2)
int(2)

注释

Note: 此函数可安全用于二进制对象。

参见

  • strspn() - 计算字符串中全部字符都存在于指定字符集合中的第一段子串的长度。


从字符串中去除 HTML 和 PHP 标记

  • ? strcspn
  • stripcslashes ?
  • PHP Manual
  • 字符串 函数
  • 从字符串中去除 HTML 和 PHP 标记

strip_tags

(PHP 4, PHP 5, PHP 7, PHP 8)

strip_tags — 从字符串中去除 HTML 和 PHP 标记

说明

strip_tags ( string $str , string $allowable_tags = ? ) : string

该函数尝试返回给定的字符串 str 去除空字符、HTML 和 PHP 标记后的结果。它使用与函数 fgetss() 一样的机制去除标记。

参数

str

输入字符串。

allowable_tags

使用可选的第二个参数指定不被去除的字符列表。

Note:

HTML 注释和 PHP 标签也会被去除。这里是硬编码处理的，所以无法通过 allowable_tags 参数进行改变。

Note:

In PHP 5.3.4 and later, self-closing XHTML tags are ignored and only non-self-closing tags should be used in allowable_tags. For example, to allow both <br> and <br/>, you should use:

<?php
strip_tags($input, '<br>');
?>

返回值

返回处理后的字符串。

更新日志

版本 | 说明
5.3.4 | strip_tags() ignores self-closing XHTML tags in allowable_tags.
5.0.0 | strip_tags() 变为二进制安全的。

范例

Example #1 strip_tags() 范例

<?php
$text = '<p>Test paragraph.</p><!-- Comment --> <a href="#fragment">Other text</a>';
echo strip_tags($text);
echo "\n";

// 允许 <p> 和 <a>
echo strip_tags($text, '<p><a>');
?>

以上例程会输出：

Test paragraph. Other text
<p>Test paragraph.</p> <a href="#fragment">Other text</a>

注释

Warning

由于 strip_tags() 无法实际验证 HTML，不完整或者破损标签将导致更多的数据被删除。

Warning

该函数不会修改 allowable_tags 参数中指定的允许标记的任何属性，包括 style 和 onmouseover 属性，用户可能会在提交的内容中恶意滥用这些属性，从而展示给其他用户。

Note:

输入 HTML 标签名字如果大于 1023 字节(bytes)将会被认为是无效的，无论 allowable_tags 参数是怎样的。

参见

  • htmlspecialchars() - 将特殊字符转换为 HTML 实体


反引用一个使用 addcslashes 转义的字符串

  • ? strip_tags
  • stripos ?
  • PHP Manual
  • 字符串 函数
  • 反引用一个使用 addcslashes 转义的字符串

stripcslashes

(PHP 4, PHP 5, PHP 7, PHP 8)

stripcslashes — 反引用一个使用 addcslashes() 转义的字符串

说明

stripcslashes ( string $str ) : string

返回反转义后的字符串。可识别类似 C 语言的 \n，\r，... 八进制以及十六进制的描述。

参数

str

需要反转义的字符串。

返回值

返回反转义后的字符串。

参见

  • addcslashes() - 以 C 语言风格使用反斜线转义字符串中的字符


查找字符串首次出现的位置（不区分大小写）

  • ? stripcslashes
  • stripslashes ?
  • PHP Manual
  • 字符串 函数
  • 查找字符串首次出现的位置（不区分大小写）

stripos

(PHP 5, PHP 7, PHP 8)

stripos — 查找字符串首次出现的位置（不区分大小写）

说明

stripos ( string $haystack , string $needle , int $offset = 0 ) : int

返回在字符串 haystack 中 needle 首次出现的数字位置。

与 strpos() 不同，stripos() 不区分大小写。

参数

haystack

在该字符串中查找。

needle

注意 needle 可以是一个单字符或者多字符的字符串。

如果 needle 不是一个字符串，那么它将被转换为整型并被视为字符顺序值。

offset

可选的 offset 参数，从字符此数量的开始位置进行搜索。 如果是负数，就从字符末尾此数量的字符数开始统计。

返回值

返回 needle 存在于 haystack 字符串开始的位置(独立于偏移量)。同时注意字符串位置起始于 0，而不是 1。

如果未发现 needle 将返回 false。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
7.1.0 | 开始支持负数的 offset。

范例

Example #1 stripos() 范例

<?php
$findme    = 'a';
$mystring1 = 'xyz';
$mystring2 = 'ABC';

$pos1 = stripos($mystring1, $findme);
$pos2 = stripos($mystring2, $findme);

// 'a' 当然不在 'xyz' 中
if ($pos1 === false) {
    echo "The string '$findme' was not found in the string '$mystring1'";
}

// 注意这里使用的是 ===。简单的 == 不能像我们期望的那样工作，
// 因为 'a' 的位置是 0（第一个字符）。
if ($pos2 !== false) {
    echo "We found '$findme' in '$mystring2' at position $pos2";
}
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • mb_stripos() - 大小写不敏感地查找字符串在另一个字符串中首次出现的位置
  • strpos() - 查找字符串首次出现的位置
  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置
  • strripos() - 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
  • stristr() - strstr 函数的忽略大小写版本
  • substr() - 返回字符串的子串
  • str_ireplace() - str_replace 的忽略大小写版本


反引用一个引用字符串

  • ? stripos
  • stristr ?
  • PHP Manual
  • 字符串 函数
  • 反引用一个引用字符串

stripslashes

(PHP 4, PHP 5, PHP 7, PHP 8)

stripslashes — 反引用一个引用字符串

说明

stripslashes ( string $str ) : string

反引用一个引用字符串。

Note:

如果 magic_quotes_sybase 项开启，反斜线将被去除，但是两个反斜线将会被替换成一个。

一个使用范例是使用 PHP 检测 magic_quotes_gpc 配置项的 开启情况（在 PHP 5.4之 前默认是开启的）并且你不需要将数据插入到一个需要转义的位置（例如数据库）。例如，你只是简单地将表单数据直接输出。

参数

str

输入字符串。

返回值

返回一个去除转义反斜线后的字符串（\' 转换为 ' 等等）。双反斜线（\\）被转换为单个反斜线（\）。

范例

Example #1 stripslashes() 范例

<?php
$str = "Is your name O\'reilly?";

// 输出: Is your name O'reilly?
echo stripslashes($str);
?>

Note:

stripslashes() 是非递归的。如果你想要在多维数组中使用该函数，你需要使用递归函数。

Example #2 对数组使用 stripslashes()

<?php
function stripslashes_deep($value)
{
    $value = is_array($value) ?
                array_map('stripslashes_deep', $value) :
                stripslashes($value);

    return $value;
}

// 范例
$array = array("f\\'oo", "b\\'ar", array("fo\\'o", "b\\'ar"));
$array = stripslashes_deep($array);

// 输出
print_r($array);
?>

以上例程会输出：

Array
(
    [0] => f'oo
    [1] => b'ar
    [2] => Array
        (
            [0] => fo'o
            [1] => b'ar
        )

)

参见

  • addslashes() - 使用反斜线引用字符串
  • get_magic_quotes_gpc() - 获取当前 magic_quotes_gpc 的配置选项设置


strstr 函数的忽略大小写版本

  • ? stripslashes
  • strlen ?
  • PHP Manual
  • 字符串 函数
  • strstr 函数的忽略大小写版本

stristr

(PHP 4, PHP 5, PHP 7, PHP 8)

stristr — strstr() 函数的忽略大小写版本

说明

stristr ( string $haystack , mixed $needle , bool $before_needle = false ) : string

返回 haystack 字符串从 needle 第一次出现的位置开始到结尾的字符串。

参数

haystack

在该字符串中查找。

needle

如果 needle 不是一个字符串，那么它将被转换为整型并被视为字符顺序值。

before_needle

若为 true，strstr() 将返回 needle 在 haystack 中的位置之前的部分(不包括 needle)。

参数 needle 和 haystack 将以不区分大小写的方式对待。

返回值

返回匹配的子字符串。如果 needle 未找到，返回 false。

更新日志

版本 | 说明
5.3.0 | 新增可选的 before_needle 参数。
4.3.0 | stristr() 变为二进制安全的。

范例

Example #1 stristr() 范例

<?php
  $email = 'USER@EXAMPLE.com';
  echo stristr($email, 'e'); // 输出 ER@EXAMPLE.com
  echo stristr($email, 'e', true); // 自 PHP 5.3.0 起，输出 US
?>

Example #2 测试字符串的存在与否

<?php
  $string = 'Hello World!';
  if(stristr($string, 'earth') === FALSE) {
    echo '"earth" not found in string';
  }
// 输出: "earth" not found in string
?>

Example #3 使用非字符串 needle

<?php
  $string = 'APPLE';
  echo stristr($string, 97); // 97 = 小写字母 a
// 输出: APPLE
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • strstr() - 查找字符串的首次出现
  • strrchr() - 查找指定字符在字符串中的最后一次出现
  • stripos() - 查找字符串首次出现的位置（不区分大小写）
  • strpbrk() - 在字符串中查找一组字符的任何一个字符
  • preg_match() - 执行匹配正则表达式


获取字符串长度

  • ? stristr
  • strnatcasecmp ?
  • PHP Manual
  • 字符串 函数
  • 获取字符串长度

strlen

(PHP 4, PHP 5, PHP 7, PHP 8)

strlen — 获取字符串长度

说明

strlen ( string $string ) : int

返回给定的字符串 string 的长度。

参数

string

需要计算长度的字符串。

返回值

成功则返回字符串 string 的长度；如果 string 为空，则返回 0。

更新日志

版本 | 说明
5.3.0 | Prior versions treated arrays as the string Array, thus returning a string length of 5 and emitting an E_NOTICE level error.

范例

Example #1 strlen() 范例

<?php
$str = 'abcdef';
echo strlen($str); // 6

$str = ' ab cd ';
echo strlen($str); // 7
?>

注释

Note:

strlen() returns the number of bytes rather than the number of characters in a string.

Note:

strlen() returns null when executed on arrays, and an E_WARNING level error is emitted.

参见

  • count() - 计算数组中的单元数目，或对象中的属性个数
  • mb_strlen() - 获取字符串的长度


使用“自然顺序”算法比较字符串（不区分大小写）

  • ? strlen
  • strnatcmp ?
  • PHP Manual
  • 字符串 函数
  • 使用“自然顺序”算法比较字符串（不区分大小写）

strnatcasecmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strnatcasecmp — 使用"自然顺序"算法比较字符串（不区分大小写）

说明

strnatcasecmp ( string $str1 , string $str2 ) : int

该函数实现了以人类习惯对数字型字符串进行排序的比较算法。除了不区分大小写，该函数的行为与 strnatcmp() 类似。更多信息，参见：Martin Pool 的» 自然顺序的字符串比较页面。

参数

str1

第一个字符串。

str2

第二个字符串。

返回值

与其他字符串比较函数类似，如果 str1 小于 str2 返回 < 0； 如果 str1 大于 str2 返回 > 0；如果两者相等，返回 0。

参见

  • preg_match() - 执行匹配正则表达式
  • strcmp() - 二进制安全字符串比较
  • strcasecmp() - 二进制安全比较字符串（不区分大小写）
  • substr() - 返回字符串的子串
  • stristr() - strstr 函数的忽略大小写版本
  • strncasecmp() - 二进制安全比较字符串开头的若干个字符（不区分大小写）
  • strncmp() - 二进制安全比较字符串开头的若干个字符
  • strstr() - 查找字符串的首次出现
  • setlocale() - 设置地区信息


使用自然排序算法比较字符串

  • ? strnatcasecmp
  • strncasecmp ?
  • PHP Manual
  • 字符串 函数
  • 使用自然排序算法比较字符串

strnatcmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strnatcmp — 使用自然排序算法比较字符串

说明

strnatcmp ( string $str1 , string $str2 ) : int

该函数实现了以人类习惯对数字型字符串进行排序的比较算法，这就是"自然顺序"。注意该比较区分大小写。

参数

str1

第一个字符串。

str2

第二个字符串。

返回值

与其他字符串比较函数类似，如果 str1 小于 str2 返回 < 0； 如果 str1 大于 str2 返回 > 0；如果两者相等，返回 0。

范例

下面的例子展示了该算法与计算机常规字符串比较算法（ strcmp() 所使用的）的区别：

<?php
$arr1 = $arr2 = array("img12.png", "img10.png", "img2.png", "img1.png");
echo "Standard string comparison\n";
usort($arr1, "strcmp");
print_r($arr1);
echo "\nNatural order string comparison\n";
usort($arr2, "strnatcmp");
print_r($arr2);
?>

以上例程会输出：

Standard string comparison
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Natural order string comparison
Array
(
    [0] => img1.png
    [1] => img2.png
    [2] => img10.png
    [3] => img12.png
)
更多信息，参见：Martin Pool 的» 自然顺序的字符串比较 page.

参见

  • preg_match() - 执行匹配正则表达式
  • strcasecmp() - 二进制安全比较字符串（不区分大小写）
  • substr() - 返回字符串的子串
  • stristr() - strstr 函数的忽略大小写版本
  • strcmp() - 二进制安全字符串比较
  • strncmp() - 二进制安全比较字符串开头的若干个字符
  • strncasecmp() - 二进制安全比较字符串开头的若干个字符（不区分大小写）
  • strnatcasecmp() - 使用“自然顺序”算法比较字符串（不区分大小写）
  • strstr() - 查找字符串的首次出现
  • natsort() - 用“自然排序”算法对数组排序
  • natcasesort() - 用“自然排序”算法对数组进行不区分大小写字母的排序


二进制安全比较字符串开头的若干个字符（不区分大小写）

  • ? strnatcmp
  • strncmp ?
  • PHP Manual
  • 字符串 函数
  • 二进制安全比较字符串开头的若干个字符（不区分大小写）

strncasecmp

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

strncasecmp — 二进制安全比较字符串开头的若干个字符（不区分大小写）

说明

strncasecmp ( string $str1 , string $str2 , int $len ) : int

该函数与 strcasecmp() 类似，不同之处在于你可以指定两个字符串比较时使用的长度（即最大比较长度）。

参数

str1

第一个字符串。

str2

第二个字符串。

len

最大比较长度。

返回值

如果 str1 小于 str2 返回 < 0； 如果 str1 大于 str2 返回 > 0；如果两者相等，返回 0。

参见

  • strncmp() - 二进制安全比较字符串开头的若干个字符
  • preg_match() - 执行匹配正则表达式
  • substr_compare() - 二进制安全比较字符串（从偏移位置比较指定长度）
  • strcasecmp() - 二进制安全比较字符串（不区分大小写）
  • stristr() - strstr 函数的忽略大小写版本
  • substr() - 返回字符串的子串


二进制安全比较字符串开头的若干个字符

  • ? strncasecmp
  • strpbrk ?
  • PHP Manual
  • 字符串 函数
  • 二进制安全比较字符串开头的若干个字符

strncmp

(PHP 4, PHP 5, PHP 7, PHP 8)

strncmp — 二进制安全比较字符串开头的若干个字符

说明

strncmp ( string $str1 , string $str2 , int $len ) : int

该函数与 strcmp() 类似，不同之处在于你可以指定两个字符串比较时使用的长度（即最大比较长度）。

注意该比较区分大小写。

参数

str1

第一个字符串。

str2

第二个字符串。

len

最大比较长度。

返回值

如果 str1 小于 str2 返回 < 0； 如果 str1 大于 str2 返回 > 0；如果两者相等，返回 0。

参见

  • strncasecmp() - 二进制安全比较字符串开头的若干个字符（不区分大小写）
  • preg_match() - 执行匹配正则表达式
  • substr_compare() - 二进制安全比较字符串（从偏移位置比较指定长度）
  • strcmp() - 二进制安全字符串比较
  • strstr() - 查找字符串的首次出现
  • substr() - 返回字符串的子串


在字符串中查找一组字符的任何一个字符

  • ? strncmp
  • strpos ?
  • PHP Manual
  • 字符串 函数
  • 在字符串中查找一组字符的任何一个字符

strpbrk

(PHP 5, PHP 7, PHP 8)

strpbrk — 在字符串中查找一组字符的任何一个字符

说明

strpbrk ( string $haystack , string $char_list ) : string

strpbrk() 函数在 haystack 字符串中查找 char_list 中的字符。

参数

haystack

在此字符串中查找 char_list。

char_list

该参数区分大小写。

返回值

返回一个以找到的字符开始的子字符串。如果没有找到，则返回 false。

范例

Example #1 strpbrk() 范例

<?php

$text = 'This is a Simple text.';

// 输出 "is is a Simple text."，因为 'i' 先被匹配
echo strpbrk($text, 'mi');

// 输出 "Simple text."，因为字符区分大小写
echo strpbrk($text, 'S');
?>

参见

  • strpos() - 查找字符串首次出现的位置
  • strstr() - 查找字符串的首次出现
  • preg_match() - 执行匹配正则表达式


查找字符串首次出现的位置

  • ? strpbrk
  • strrchr ?
  • PHP Manual
  • 字符串 函数
  • 查找字符串首次出现的位置

strpos

(PHP 4, PHP 5, PHP 7, PHP 8)

strpos — 查找字符串首次出现的位置

说明

strpos ( string $haystack , mixed $needle , int $offset = 0 ) : int

返回 needle 在 haystack 中首次出现的数字位置。

参数

haystack

在该字符串中进行查找。

needle

Prior to PHP 8.0.0, if needle is not a string, it is converted to an integer and applied as the ordinal value of a character. This behavior is deprecated as of PHP 7.3.0, and relying on it is highly discouraged. Depending on the intended behavior, the needle should either be explicitly cast to string, or an explicit call to chr() should be performed.

offset

如果提供了此参数，搜索会从字符串该字符数的起始位置开始统计。 如果是负数，搜索会从字符串结尾指定字符数开始。

返回值

返回 needle 存在于 haystack 字符串起始的位置(独立于 offset)。同时注意字符串位置是从0开始，而不是从1开始的。

如果没找到 needle，将返回 false。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
7.1.0 | 开始支持负数的 offset。

范例

Example #1 使用 ===

<?php
$mystring = 'abc';
$findme   = 'a';
$pos = strpos($mystring, $findme);

// 注意这里使用的是 ===。简单的 == 不能像我们期待的那样工作，
// 因为 'a' 是第 0 位置上的（第一个）字符。
if ($pos === false) {
    echo "The string '$findme' was not found in the string '$mystring'";
} else {
    echo "The string '$findme' was found in the string '$mystring'";
    echo " and exists at position $pos";
}
?>

Example #2 使用 !==

<?php
$mystring = 'abc';
$findme   = 'a';
$pos = strpos($mystring, $findme);

// 使用 !== 操作符。使用 != 不能像我们期待的那样工作，
// 因为 'a' 的位置是 0。语句 (0 != false) 的结果是 false。
if ($pos !== false) {
     echo "The string '$findme' was found in the string '$mystring'";
         echo " and exists at position $pos";
} else {
     echo "The string '$findme' was not found in the string '$mystring'";
}
?>

Example #3 使用位置偏移量

<?php
// 忽视位置偏移量之前的字符进行查找
$newstring = 'abcdef abcdef';
$pos = strpos($newstring, 'a', 1); // $pos = 7, 不是 0
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • stripos() - 查找字符串首次出现的位置（不区分大小写）
  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置
  • strripos() - 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
  • strstr() - 查找字符串的首次出现
  • strpbrk() - 在字符串中查找一组字符的任何一个字符
  • substr() - 返回字符串的子串
  • preg_match() - 执行匹配正则表达式


查找指定字符在字符串中的最后一次出现

  • ? strpos
  • strrev ?
  • PHP Manual
  • 字符串 函数
  • 查找指定字符在字符串中的最后一次出现

strrchr

(PHP 4, PHP 5, PHP 7, PHP 8)

strrchr — 查找指定字符在字符串中的最后一次出现

说明

strrchr ( string $haystack , mixed $needle ) : string

该函数返回 haystack 字符串中的一部分，这部分以 needle 的最后出现位置开始，直到 haystack 末尾。

参数

haystack

在该字符串中查找。

needle

如果 needle 包含了不止一个字符，那么仅使用第一个字符。该行为不同于 strstr()。

如果 needle 不是一个字符串，那么将被转化为整型并被视为字符顺序值。

返回值

该函数返回字符串的一部分。如果 needle 未被找到，返回 false。

更新日志

版本 | 说明
4.3.0 | 该函数是二进制安全的。

范例

Example #1 strrchr() 范例

<?php
// 获取 $PATH 中不含磁盘符号的目录
$dir = substr(strrchr($PATH, ":"), 1);

// 获取最后一行内容
$text = "Line 1\nLine 2\nLine 3";
$last = substr(strrchr($text, 10), 1 );
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • strstr() - 查找字符串的首次出现
  • strrpos() - 计算指定字符串在目标字符串中最后一次出现的位置


反转字符串

  • ? strrchr
  • strripos ?
  • PHP Manual
  • 字符串 函数
  • 反转字符串

strrev

(PHP 4, PHP 5, PHP 7, PHP 8)

strrev — 反转字符串

说明

strrev ( string $string ) : string

返回 string 反转后的字符串。

参数

string

待反转的原始字符串。

返回值

返回反转后的字符串。

范例

Example #1 使用 strrev() 反转字符串

<?php
echo strrev("Hello world!"); // 输出 "!dlrow olleH"
?>


计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）

  • ? strrev
  • strrpos ?
  • PHP Manual
  • 字符串 函数
  • 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）

strripos

(PHP 5, PHP 7, PHP 8)

strripos — 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）

说明

strripos ( string $haystack , string $needle , int $offset = 0 ) : int

以不区分大小写的方式查找指定字符串在目标字符串中最后一次出现的位置。与 strrpos() 不同，strripos() 不区分大小写。

参数

haystack

在此字符串中进行查找。

needle

注意 needle 可以是一个单字符或者多字符的字符串。

offset

参数 offset 可以被指定来查找字符串中任意长度的子字符串。

负数偏移量将使得查找从字符串的起始位置开始，到 offset 位置为止。

返回值

返回 needle 相对于 haystack 字符串的位置(和搜索的方向和偏移量无关)。同时注意字符串的起始位置为 0 而非 1。

如果 needle 未被发现，返回 false。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 strripos() 简单范例

<?php
$haystack = 'ababcd';
$needle   = 'aB';

$pos      = strripos($haystack, $needle);

if ($pos === false) {
    echo "Sorry, we did not find ($needle) in ($haystack)";
} else {
    echo "Congratulations!\n";
    echo "We found the last ($needle) in ($haystack) at position ($pos)";
}
?>

以上例程会输出：

   Congratulations!
   We found the last (aB) in (ababcd) at position (2)

参见

  • strpos() - 查找字符串首次出现的位置
  • stripos() - 查找字符串首次出现的位置（不区分大小写）
  • strrchr() - 查找指定字符在字符串中的最后一次出现
  • substr() - 返回字符串的子串
  • stristr() - strstr 函数的忽略大小写版本
  • strstr() - 查找字符串的首次出现


计算指定字符串在目标字符串中最后一次出现的位置

  • ? strripos
  • strspn ?
  • PHP Manual
  • 字符串 函数
  • 计算指定字符串在目标字符串中最后一次出现的位置

strrpos

(PHP 4, PHP 5, PHP 7, PHP 8)

strrpos — 计算指定字符串在目标字符串中最后一次出现的位置

说明

strrpos ( string $haystack , string $needle , int $offset = 0 ) : int

返回字符串 haystack 中 needle 最后一次出现的数字位置。注意 PHP4 中，needle 只能为单个字符。如果 needle 被指定为一个字符串，那么将仅使用第一个字符。

参数

haystack

在此字符串中进行查找。

needle

如果 needle不是一个字符串，它将被转换为整型并被视为字符的顺序值。

offset

或许会查找字符串中任意长度的子字符串。负数值将导致查找在字符串结尾处开始的计数位置处结束。

返回值

返回 needle 存在的位置。如果没有找到，返回 false。 Also note that string positions start at 0, and not 1.

Returns false if the needle was not found.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
5.0.0 | 参数 needle 可以是一个多字符的字符串。
5.0.0 | 引入 offset 参数。

范例

Example #1 检查字串是否存在

很容易将"在位置 0 处找到"和"未发现字符串"这两种情况搞错。这是检测区别的办法：

<?php

$pos = strrpos($mystring, "b");
if ($pos === false) { // 注意: 三个等号
    // 未发现...
}

?>

Example #2 使用偏移位置进行查找

<?php
$foo = "0123456789a123456789b123456789c";

var_dump(strrpos($foo, '7', -5));  // 从尾部第 5 个位置开始查找
                                   // 结果: int(17)

var_dump(strrpos($foo, '7', 20));  // 从第 20 个位置开始查找
                                   // 结果: int(27)

var_dump(strrpos($foo, '7', 28));  // 结果: bool(false)
?>

参见

  • strpos() - 查找字符串首次出现的位置
  • stripos() - 查找字符串首次出现的位置（不区分大小写）
  • strripos() - 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
  • strrchr() - 查找指定字符在字符串中的最后一次出现
  • substr() - 返回字符串的子串


计算字符串中全部字符都存在于指定字符集合中的第一段子串的长度。

  • ? strrpos
  • strstr ?
  • PHP Manual
  • 字符串 函数
  • 计算字符串中全部字符都存在于指定字符集合中的第一段子串的长度。

strspn

(PHP 4, PHP 5, PHP 7, PHP 8)

strspn — 计算字符串中全部字符都存在于指定字符集合中的第一段子串的长度。

说明

strspn ( string $subject , string $mask , int $start = ? , int $length = ? ) : int

返回 subject 中全部字符仅存在于 mask 中的第一组连续字符(子字符串)的长度。

如果省略了 start 和 length 参数，则检查整个 subject 字符串；如果指定了这两个参数，则效果等同于调用 strspn(substr($subject, $start, $length), $mask)（更多信息，参见 substr ）。

代码行：

<?php
$var = strspn("42 is the answer to the 128th question.", "1234567890");
?>
$var 将被指派为 2，因为 '42' 是 subject 中第一段全部字符都存在于 '1234567890' 的连续字符。

参数

subject

待检查的字符串。

mask

检查字符列表。

start

subject 的开始检查位置。

如果 start 被设置并且是非负的，strspn() 将从 subject 的第 start 个位置开始检查。例如，在字符串 'abcdef' 中，第 0 个位置的字符是 'a'，第二个位置的字符是 'c'，等等。

如果 start 被设置并且为负数，strspn() 将从 subject 的尾部倒数第 start 个位置开始检查 subject。

length

subject 中检查的长度。

如果 length 被设置并且为非负数，那么将从起始位置开始，检查 subject 的 length 个长度的字符。

如果 length 被设置并且为负数，那么将从起始位置开始，直到从 subject 尾部开始第 length 个位置，对 subject 进行检查。

返回值

返回 str1 中第一段全部字符都存在于 str2 范围的字符串的长度。

更新日志

版本 | 说明
4.3.0 | 新增 start 和 length 参数。

范例

Example #1 strspn() 范例

<?php
echo strspn("foo", "o", 1, 2); // 打印: 2
?>

以上例程会输出：

int(0)
int(2)
int(1)

注释

Note: 此函数可安全用于二进制对象。

参见

  • strcspn() - 获取不匹配遮罩的起始子字符串的长度


查找字符串的首次出现

  • ? strspn
  • strtok ?
  • PHP Manual
  • 字符串 函数
  • 查找字符串的首次出现

strstr

(PHP 4, PHP 5, PHP 7, PHP 8)

strstr — 查找字符串的首次出现

说明

strstr ( string $haystack , mixed $needle , bool $before_needle = false ) : string

返回 haystack 字符串从 needle 第一次出现的位置开始到 haystack 结尾的字符串。

Note:

该函数区分大小写。如果想要不区分大小写，请使用 stristr()。

Note:

如果你仅仅想确定 needle 是否存在于 haystack 中，请使用速度更快、耗费内存更少的 strpos() 函数。

参数

haystack

输入字符串。

needle

如果 needle 不是一个字符串，那么它将被转化为整型并且作为字符的序号来使用。

before_needle

若为 true，strstr() 将返回 needle 在 haystack 中的位置之前的部分。

返回值

返回字符串的一部分或者 false（如果未发现 needle）。

更新日志

版本 | 说明
5.3.0 | 新增可选的 before_needle 参数。
4.3.0 | strstr() 成为二进制安全的。

范例

Example #1 strstr() 范例

<?php
$email  = 'name@example.com';
$domain = strstr($email, '@');
echo $domain; // 打印 @example.com

$user = strstr($email, '@', true); // 从 PHP 5.3.0 起
echo $user; // 打印 name
?>

参见

  • preg_match() - 执行匹配正则表达式
  • stristr() - strstr 函数的忽略大小写版本
  • strpos() - 查找字符串首次出现的位置
  • strrchr() - 查找指定字符在字符串中的最后一次出现
  • substr() - 返回字符串的子串


标记分割字符串

  • ? strstr
  • strtolower ?
  • PHP Manual
  • 字符串 函数
  • 标记分割字符串

strtok

(PHP 4, PHP 5, PHP 7, PHP 8)

strtok — 标记分割字符串

说明

strtok ( string $string , string $token ) : string|false

可选 token （不支持命名参数）：

strtok ( string $token ) : string|false

strtok() 将字符串 string 分割为若干子字符串，每个子字符串以 token 中的字符分割。这也就意味着，如果有个字符串是 "This is an example string"， 你可以使用空格字符作为 token，将这句话分割成独立的单词。

注意，仅第一次调用 strtok 函数时才使用 string 参数。 随后每次调用 strtok 都将只使用 token 参数，因为它会记住它在当前字符串中的位置。 如果要重新开始分割一个新的字符串，你需要再次使用 string 参数来调用 strtok 函数来对其进行初始化。 注意，可以在 token 参数中使用多个字符。字符串将被 token 参数中任何一个字符分割。

参数

string

被分成若干子字符串的原始字符串。

token

分割 string 时使用的分界字符。

返回值

标记后的字符串，如果没有更多标记可用，则返回 false 。

范例

Example #1 strtok() 示例

<?php
$string = "This is\tan example\nstring";
/* 使用制表符和换行符作为分界符 */
$tok = strtok($string, " \n\t");

while ($tok !== false) {
    echo "Word=$tok<br />";
    $tok = strtok(" \n\t");
}
?>

Example #2 当 strtok() 找不到标记时的反应

<?php
$first_token  = strtok('/something', '/');
$second_token = strtok('/');
var_dump($first_token, $second_token);
?>

以上例程会输出：

    string(9) "something"
    bool(false)

注释

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

参见

  • split() - 用正则表达式将字符串分割到数组中
  • explode() - 使用一个字符串分割另一个字符串


将字符串转化为小写

  • ? strtok
  • strtoupper ?
  • PHP Manual
  • 字符串 函数
  • 将字符串转化为小写

strtolower

(PHP 4, PHP 5, PHP 7, PHP 8)

strtolower — 将字符串转化为小写

说明

strtolower ( string $string ) : string

将 string 中所有的字母字符转换为小写并返回。

注意 "字母" 与当前所在区域有关。例如，在默认的 "C" 区域，字符 umlaut-A（?）就不会被转换。

参数

string

输入字符串。

返回值

返回转换后的小写字符串。

范例

Example #1 strtolower() 范例

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = strtolower($str);
echo $str; // 打印 mary had a little lamb and she loved it so
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • strtoupper() - 将字符串转化为大写
  • ucfirst() - 将字符串的首字母转换为大写
  • ucwords() - 将字符串中每个单词的首字母转换为大写
  • mb_strtolower() - 使字符串小写


将字符串转化为大写

  • ? strtolower
  • strtr ?
  • PHP Manual
  • 字符串 函数
  • 将字符串转化为大写

strtoupper

(PHP 4, PHP 5, PHP 7, PHP 8)

strtoupper — 将字符串转化为大写

说明

strtoupper ( string $string ) : string

将 string 中所有的字母字符转换为大写并返回。

注意 "字母" 与当前所在区域有关。例如，在默认的 "C" 区域，字符 umlaut-a（?）就不会被转换。

参数

string

输入字符串。

返回值

返回转换后的大写字符串。

范例

Example #1 strtoupper() 范例

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = strtoupper($str);
echo $str; // 打印 MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • strtolower() - 将字符串转化为小写
  • ucfirst() - 将字符串的首字母转换为大写
  • ucwords() - 将字符串中每个单词的首字母转换为大写
  • mb_strtoupper() - 使字符串大写


转换指定字符

  • ? strtoupper
  • substr_compare ?
  • PHP Manual
  • 字符串 函数
  • 转换指定字符

strtr

(PHP 4, PHP 5, PHP 7, PHP 8)

strtr — 转换指定字符

说明

strtr ( string $str , string $from , string $to ) : string
strtr ( string $str , array $replace_pairs ) : string

该函数返回 str 的一个副本，并将在 from 中指定的字符转换为 to 中相应的字符。 比如， $from[$n]中每次的出现都会被替换为 $to[$n]，其中 $n 是两个参数都有效的位移(offset)。

如果 from 与 to 长度不相等，那么多余的字符部分将被忽略。 str 的长度将会和返回的值一样。

If given two arguments, the second should be an array in the form array('from' => 'to', ...). The return value is a string where all the occurrences of the array keys have been replaced by the corresponding values. The longest keys will be tried first. Once a substring has been replaced, its new value will not be searched again.

In this case, the keys and the values may have any length, provided that there is no empty key; additionally, the length of the return value may differ from that of str. However, this function will be the most efficient when all the keys have the same size.

参数

str

待转换的字符串。

from

字符串中与将要被转换的目的字符 to 相对应的源字符。

to

字符串中与将要被转换的字符 from 相对应的目的字符。

replace_pairs

参数 replace_pairs 可以用来取代 to 和 from 参数，因为它是以 array('from' => 'to', ...) 格式出现的数组。

返回值

返回转换后的字符串。

如果 replace_pairs 中包含一个空字符串（""）键，那么将返回 false。 If the str is not a scalar then it is not typecasted into a string, instead a warning is raised and null is returned.

范例

Example #1 strtr() 范例

<?php
$addr = strtr($addr, "???", "aao");
?>

The next example shows the behavior of strtr() when called with only two arguments. Note the preference of the replacements ("h" is not picked because there are longer matches) and how replaced text was not searched again.

Example #2 使用两个参数的 strtr() 范例

<?php
$trans = array("hello" => "hi", "hi" => "hello");
echo strtr("hi all, I said hello", $trans);
?>

以上例程会输出：

hello all, I said hi

The two modes of behavior are substantially different. With three arguments, strtr() will replace bytes; with two, it may replace longer substrings.

Example #3 strtr() behavior comparison

<?php
echo strtr("baab", "ab", "01"),"\n";

$trans = array("ab" => "01");
echo strtr("baab", $trans);
?>

以上例程会输出：

1001
ba01

参见

  • str_replace() - 子字符串替换
  • preg_replace() - 执行一个正则表达式的搜索和替换


二进制安全比较字符串（从偏移位置比较指定长度）

  • ? strtr
  • substr_count ?
  • PHP Manual
  • 字符串 函数
  • 二进制安全比较字符串（从偏移位置比较指定长度）

substr_compare

(PHP 5, PHP 7, PHP 8)

substr_compare — 二进制安全比较字符串（从偏移位置比较指定长度）

说明

substr_compare ( string $main_str , string $str , int $offset , int $length = ? , bool $case_insensitivity = false ) : int

substr_compare() 从偏移位置 offset 开始比较 main_str 与 str，比较长度为 length 个字符。

参数

main_str

待比较的第一个字符串。

str

待比较的第二个字符串。

offset

比较开始的位置。如果为负数，则从字符串结尾处开始算起。

length

比较的长度。默认值为 str 的长度与 main_str 的长度减去位置偏移量 offset 后二者中的较大者。

case_insensitivity

如果 case_insensitivity 为 true，比较将不区分大小写。

返回值

如果 main_str 从偏移位置 offset 起的子字符串小于 str，则返回小于 0 的数；如果大于 str，则返回大于 0 的数；如果二者相等，则返回 0。如果 offset 大于等于 main_str 的长度或 length 被设置为小于 1 的值（ PHP 5.5.11 之前的版本），substr_compare() 将打印出一条警告信息并且返回 false。

更新日志

版本 | 说明
7.2.18, 7.3.5 | offset 现在可能等于 main_str。

范例

Example #1 substr_compare() 范例

<?php
echo substr_compare("abcde", "bc", 1, 2); // 0
echo substr_compare("abcde", "de", -2, 2); // 0
echo substr_compare("abcde", "bcg", 1, 2); // 0
echo substr_compare("abcde", "BC", 1, 2, true); // 0
echo substr_compare("abcde", "bc", 1, 3); // 1
echo substr_compare("abcde", "cd", 1, 2); // -1
echo substr_compare("abcde", "abc", 5, 1); // warning
?>

参见

  • strncmp() - 二进制安全比较字符串开头的若干个字符


计算字串出现的次数

  • ? substr_compare
  • substr_replace ?
  • PHP Manual
  • 字符串 函数
  • 计算字串出现的次数

substr_count

(PHP 4, PHP 5, PHP 7, PHP 8)

substr_count — 计算字串出现的次数

说明

substr_count ( string $haystack , string $needle , int $offset = 0 , int $length = ? ) : int

substr_count() 返回子字符串 needle 在字符串 haystack 中出现的次数。注意 needle 区分大小写。

Note:

该函数不会计算重叠字符串！参见下面的例子。

参数

haystack

在此字符串中进行搜索。

needle

要搜索的字符串。

offset

开始计数的偏移位置。如果是负数，就从字符的末尾开始统计。

length

指定偏移位置之后的最大搜索长度。如果偏移量加上这个长度的和大于 haystack 的总长度，则打印警告信息。 负数的长度 length 是从 haystack 的末尾开始统计的。

返回值

该函数返回 整型。

更新日志

版本 | 说明
7.1.0 | 开始支持负数的 offset 和 length。

范例

Example #1 substr_count() 范例

<?php
$text = 'This is a test';
echo strlen($text); // 14

echo substr_count($text, 'is'); // 2

// 字符串被简化为 's is a test'，因此输出 1
echo substr_count($text, 'is', 3);

// 字符串被简化为 's i'，所以输出 0
echo substr_count($text, 'is', 3, 3);

// 因为 5+10 > 14，所以生成警告
echo substr_count($text, 'is', 5, 10);

// 输出 1，因为该函数不计算重叠字符串
$text2 = 'gcdgcdgcd';
echo substr_count($text2, 'gcdgcd');
?>

参见

  • count_chars() - 返回字符串所用字符的信息
  • strpos() - 查找字符串首次出现的位置
  • substr() - 返回字符串的子串
  • strstr() - 查找字符串的首次出现


替换字符串的子串

  • ? substr_count
  • substr ?
  • PHP Manual
  • 字符串 函数
  • 替换字符串的子串

substr_replace

(PHP 4, PHP 5, PHP 7, PHP 8)

substr_replace — 替换字符串的子串

说明

substr_replace ( mixed $string , mixed $replacement , mixed $start , mixed $length = ? ) : mixed

substr_replace() 在字符串 string 的副本中将由 start 和可选的 length 参数限定的子字符串使用 replacement 进行替换。

参数

string

输入字符串。

An array of strings can be provided, in which case the replacements will occur on each string in turn. In this case, the replacement, start and length parameters may be provided either as scalar values to be applied to each input string in turn, or as arrays, in which case the corresponding array element will be used for each input string.

replacement

替换字符串。

start

如果 start 为正数，替换将从 string 的 start 位置开始。

如果 start 为负数，替换将从 string 的倒数第 start 个位置开始。

length

如果设定了这个参数并且为正数，表示 string 中被替换的子字符串的长度。如果设定为负数，它表示待替换的子字符串结尾处距离 string 末端的字符个数。如果没有提供此参数，那么它默认为 strlen( string ) （字符串的长度）。当然，如果 length 为 0，那么这个函数的功能为将 replacement 插入到 string 的 start 位置处。

返回值

返回结果字符串。如果 string 是个数组，那么也将返回一个数组。

更新日志

版本 | 说明
4.3.3 | All parameters now accept arrays.

范例

Example #1 substr_replace() 范例

<?php
$var = 'ABCDEFGH:/MNRPQR/';
echo "Original: $var<hr />\n";

/* 这两个例子使用 "bob" 替换整个 $var。*/
echo substr_replace($var, 'bob', 0) . "<br />\n";
echo substr_replace($var, 'bob', 0, strlen($var)) . "<br />\n";

/* 将 "bob" 插入到 $var 的开头处。*/
echo substr_replace($var, 'bob', 0, 0) . "<br />\n";

/* 下面两个例子使用 "bob" 替换 $var 中的 "MNRPQR"。*/
echo substr_replace($var, 'bob', 10, -1) . "<br />\n";
echo substr_replace($var, 'bob', -7, -1) . "<br />\n";

/* 从 $var 中删除 "MNRPQR"。*/
echo substr_replace($var, '', 10, -1) . "<br />\n";
?>

Example #2 Using substr_replace() to replace multiple strings at once

<?php
$input = array('A: XXX', 'B: XXX', 'C: XXX');

// A simple case: replace XXX in each string with YYY.
echo implode('; ', substr_replace($input, 'YYY', 3, 3))."\n";

// A more complicated case where each replacement is different.
$replace = array('AAA', 'BBB', 'CCC');
echo implode('; ', substr_replace($input, $replace, 3, 3))."\n";

// Replace a different number of characters each time.
$length = array(1, 2, 3);
echo implode('; ', substr_replace($input, $replace, 3, $length))."\n";
?>

以上例程会输出：

A: YYY; B: YYY; C: YYY
A: AAA; B: BBB; C: CCC
A: AAAXX; B: BBBX; C: CCC

注释

Note: 此函数可安全用于二进制对象。

参见

  • str_replace() - 子字符串替换
  • substr() - 返回字符串的子串
  • 字符串访问与修改


返回字符串的子串

  • ? substr_replace
  • trim ?
  • PHP Manual
  • 字符串 函数
  • 返回字符串的子串

substr

(PHP 4, PHP 5, PHP 7, PHP 8)

substr — 返回字符串的子串

说明

substr ( string $string , int $start , int $length = ? ) : string

返回字符串 string 由 start 和 length 参数指定的子字符串。

参数

string

输入字符串。必须至少有一个字符。

start

如果 start 是非负数，返回的字符串将从 string 的 start 位置开始，从 0 开始计算。例如，在字符串 "abcdef" 中，在位置 0 的字符是 "a"，位置 2 的字符串是 "c" 等等。

如果 start 是负数，返回的字符串将从 string 结尾处向前数第 start 个字符开始。

如果 string 的长度小于 start，将返回 false。

Example #1 使用负数 start

<?php
$rest = substr("abcdef", -1);    // 返回 "f"
$rest = substr("abcdef", -2);    // 返回 "ef"
$rest = substr("abcdef", -3, 1); // 返回 "d"
?>

length

如果提供了正数的 length，返回的字符串将从 start 处开始最多包括 length 个字符（取决于 string 的长度）。

如果提供了负数的 length，那么 string 末尾处的 length 个字符将会被省略（若 start 是负数则从字符串尾部算起）。如果 start 不在这段文本中，那么将返回 false。

如果提供了值为 0，false 或 null 的 length，那么将返回一个空字符串。

如果没有提供 length，返回的子字符串将从 start 位置开始直到字符串结尾。

Example #2 使用负数 length

<?php
$rest = substr("abcdef", 0, -1);  // 返回 "abcde"
$rest = substr("abcdef", 2, -1);  // 返回 "cde"
$rest = substr("abcdef", 4, -4);  // 返回 ""
$rest = substr("abcdef", -3, -1); // 返回 "de"
?>

返回值

返回提取的子字符串， 或者在失败时返回 false。

更新日志

版本 | 说明
7.0.0 | 如果 string 的字符串长度与 start 相同时将返回一个空字符串。在之前的版本中，这种情况将返回 false 。
5.2.2 - 5.2.6 | If the start parameter indicates the position of a negative truncation or beyond, false is returned. Other versions get the string from start.

范例

Example #3 substr() 基本用法

<?php
echo substr('abcdef', 1);     // bcdef
echo substr('abcdef', 1, 3);  // bcd
echo substr('abcdef', 0, 4);  // abcd
echo substr('abcdef', 0, 8);  // abcdef
echo substr('abcdef', -1, 1); // f

// 访问字符串中的单个字符
// 也可以使用中括号
$string = 'abcdef';
echo $string[0];                 // a
echo $string[3];                 // d
echo $string[strlen($string)-1]; // f
?>

Example #4 substr() casting behaviour

<?php
class apple {
    public function __toString() {
        return "green";
    }
}

echo "1) ".var_export(substr("pear", 0, 2), true).PHP_EOL;
echo "2) ".var_export(substr(54321, 0, 2), true).PHP_EOL;
echo "3) ".var_export(substr(new apple(), 0, 2), true).PHP_EOL;
echo "4) ".var_export(substr(true, 0, 1), true).PHP_EOL;
echo "5) ".var_export(substr(false, 0, 1), true).PHP_EOL;
echo "6) ".var_export(substr("", 0, 1), true).PHP_EOL;
echo "7) ".var_export(substr(1.2e3, 0, 4), true).PHP_EOL;
?>

以上例程在 PHP 7 中的输出：

1) 'pe'
2) '54'
3) 'gr'
4) '1'
5) false
6) false
7) '1200'

以上例程在 PHP 5 中的输出：

1) 'pe'
2) '54'
3) 'gr'
4) '1'
5) false
6) false
7) '1200'

错误／异常

错误时返回 false。

<?php
var_dump(substr('a', 2)); // bool(false)
?>

参见

  • strrchr() - 查找指定字符在字符串中的最后一次出现
  • substr_replace() - 替换字符串的子串
  • preg_match() - 执行匹配正则表达式
  • trim() - 去除字符串首尾处的空白字符（或者其他字符）
  • mb_substr() - 获取部分字符串
  • wordwrap() - 打断字符串为指定数量的字串
  • 字符串访问和修改


去除字符串首尾处的空白字符（或者其他字符）

  • ? substr
  • ucfirst ?
  • PHP Manual
  • 字符串 函数
  • 去除字符串首尾处的空白字符（或者其他字符）

trim

(PHP 4, PHP 5, PHP 7, PHP 8)

trim — 去除字符串首尾处的空白字符（或者其他字符）

说明

trim ( string $str , string $character_mask = " \t\n\r\0\x0B" ) : string

此函数返回字符串 str 去除首尾空白字符后的结果。如果不指定第二个参数，trim() 将去除这些字符：

  • " " (ASCII 32 (0x20))，普通空格符。
  • "\t" (ASCII 9 (0x09))，制表符。
  • "\n" (ASCII 10 (0x0A))，换行符。
  • "\r" (ASCII 13 (0x0D))，回车符。
  • "\0" (ASCII 0 (0x00))，空字节符。
  • "\x0B" (ASCII 11 (0x0B))，垂直制表符。

参数

str

待处理的字符串。

character_mask

可选参数，过滤字符也可由 character_mask 参数指定。一般要列出所有希望过滤的字符，也可以使用 ".." 列出一个字符范围。

返回值

过滤后的字符串。

范例

Example #1 trim() 使用范例

<?php

$text   = "\t\tThese are a few words :) ...  ";
$binary = "\x09Example string\x0A";
$hello  = "Hello World";
var_dump($text, $binary, $hello);

print "\n";

$trimmed = trim($text);
var_dump($trimmed);

$trimmed = trim($text, " \t.");
var_dump($trimmed);

$trimmed = trim($hello, "Hdle");
var_dump($trimmed);

// 清除 $binary 首位的 ASCII 控制字符
// （包括 0-31）
$clean = trim($binary, "\x00..\x1F");
var_dump($clean);

?>

以上例程会输出：

string(32) "        These are a few words :) ...  "
string(16) "    Example string
"
string(11) "Hello World"

string(28) "These are a few words :) ..."
string(24) "These are a few words :)"
string(5) "o Wor"
string(14) "Example string"

Example #2 使用 trim() 清理数组值

<?php
function trim_value(&$value)
{
    $value = trim($value);
}

$fruit = array('apple','banana ', ' cranberry ');
var_dump($fruit);

array_walk($fruit, 'trim_value');
var_dump($fruit);

?>

以上例程会输出：

array(3) {
  [0]=>
  string(5) "apple"
  [1]=>
  string(7) "banana "
  [2]=>
  string(11) " cranberry "
}
array(3) {
  [0]=>
  string(5) "apple"
  [1]=>
  string(6) "banana"
  [2]=>
  string(9) "cranberry"
}

注释

Note: Possible gotcha: removing middle characters

Because trim() trims characters from the beginning and end of a string, it may be confusing when characters are (or are not) removed from the middle. trim('abc', 'bad') removes both 'a' and 'b' because it trims 'a' thus moving 'b' to the beginning to also be trimmed. So, this is why it "works" whereas trim('abc', 'b') seemingly does not.

参见

  • ltrim() - 删除字符串开头的空白字符（或其他字符）
  • rtrim() - 删除字符串末端的空白字符（或者其他字符）
  • str_replace() - 子字符串替换


将字符串的首字母转换为大写

  • ? trim
  • ucwords ?
  • PHP Manual
  • 字符串 函数
  • 将字符串的首字母转换为大写

ucfirst

(PHP 4, PHP 5, PHP 7, PHP 8)

ucfirst — 将字符串的首字母转换为大写

说明

ucfirst ( string $str ) : string

将 str 的首字符（如果首字符是字母）转换为大写字母，并返回这个字符串。

注意字母的定义取决于当前区域设定。例如，在默认的 "C" 区域，字符 umlaut-a（?）将不会被转换。

参数

str

输入字符串。

返回值

返回结果字符串。

范例

Example #1 ucfirst() 范例

<?php
$foo = 'hello world!';
$foo = ucfirst($foo);             // Hello world!

$bar = 'HELLO WORLD!';
$bar = ucfirst($bar);             // HELLO WORLD!
$bar = ucfirst(strtolower($bar)); // Hello world!
?>

参见

  • lcfirst() - 使一个字符串的第一个字符小写
  • strtolower() - 将字符串转化为小写
  • strtoupper() - 将字符串转化为大写
  • ucwords() - 将字符串中每个单词的首字母转换为大写


将字符串中每个单词的首字母转换为大写

  • ? ucfirst
  • vfprintf ?
  • PHP Manual
  • 字符串 函数
  • 将字符串中每个单词的首字母转换为大写

ucwords

(PHP 4, PHP 5, PHP 7, PHP 8)

ucwords — 将字符串中每个单词的首字母转换为大写

说明

ucwords ( string $str , string $delimiters = " \t\r\n\f\v" ) : string

将 str 中每个单词的首字符（如果首字符是字母）转换为大写字母，并返回这个字符串。

这里单词的定义是紧跟在 delimiters 参数（默认：空格符、制表符、换行符、回车符、水平线以及竖线）之后的子字符串。

参数

str

输入字符串。

delimiters

可选的 delimiters，包含了单词分割字符。

返回值

返回转换后的字符串。

更新日志

版本 | 说明
5.4.32, 5.5.16 | 增加了 delimiters 参数。

范例

Example #1 ucwords() 范例

<?php
$foo = 'hello world!';
$foo = ucwords($foo);             // Hello World!

$bar = 'HELLO WORLD!';
$bar = ucwords($bar);             // HELLO WORLD!
$bar = ucwords(strtolower($bar)); // Hello World!
?>

Example #2 ucwords() 自定义 delimiters 的例子

<?php
$foo = 'hello|world!';
$bar = ucwords($foo);             // Hello|world!

$baz = ucwords($foo, "|");        // Hello|World!
?>

注释

Note: 此函数可安全用于二进制对象。

参见

  • strtoupper() - 将字符串转化为大写
  • strtolower() - 将字符串转化为小写
  • ucfirst() - 将字符串的首字母转换为大写
  • mb_convert_case() - 对字符串进行大小写转换


将格式化字符串写入流

  • ? ucwords
  • vprintf ?
  • PHP Manual
  • 字符串 函数
  • 将格式化字符串写入流

vfprintf

(PHP 5, PHP 7, PHP 8)

vfprintf — 将格式化字符串写入流

说明

vfprintf ( resource $handle , string $format , array $args ) : int

向由 handle 指定的流资源句柄中写入根据 format 格式化后的字符串。

作用与 fprintf() 函数类似，但是接收一个数组参数，而不是一系列可变数量的参数。

参数

handle

format

关于 format 的描述，参见 sprintf()。

args

返回值

返回输出字符串的长度。

范例

Example #1 vfprintf(): 前导 0 的整数

<?php
if (!($fp = fopen('date.txt', 'w')))
    return;

vfprintf($fp, "%04d-%02d-%02d", array($year, $month, $day));
// 将向 date.txt 写入格式化的 ISO 标准日期
?>

参见

  • printf() - 输出格式化字符串
  • sprintf() - Return a formatted string
  • sscanf() - 根据指定格式解析输入的字符
  • fscanf() - 从文件中格式化输入
  • vsprintf() - 返回格式化字符串
  • number_format() - 以千位分隔符方式格式化一个数字


输出格式化字符串

  • ? vfprintf
  • vsprintf ?
  • PHP Manual
  • 字符串 函数
  • 输出格式化字符串

vprintf

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

vprintf — 输出格式化字符串

说明

vprintf ( string $format , array $args ) : int

根据 format （sprintf() 函数文档中有相关描述）参数指定的格式，在一个格式化字符串中显示多个值。

作用与 printf() 函数类似，但是接收一个数组参数，而不是一系列可变数量的参数。

参数

format

关于 format 的描述，参见 sprintf()。

args

返回值

返回输出字符串的长度。

范例

Example #1 vprintf(): 前导 0 的整数

<?php
vprintf("%04d-%02d-%02d", explode('-', '1988-8-1')); // 1988-08-01
?>

参见

  • printf() - 输出格式化字符串
  • sprintf() - Return a formatted string
  • vsprintf() - 返回格式化字符串


返回格式化字符串

  • ? vprintf
  • wordwrap ?
  • PHP Manual
  • 字符串 函数
  • 返回格式化字符串

vsprintf

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

vsprintf — 返回格式化字符串

说明

vsprintf ( string $format , array $args ) : string

作用与 sprintf() 函数类似，但是接收一个数组参数，而不是一系列可变数量的参数。

参数

format

The format string is composed of zero or more directives: ordinary characters (excluding %) that are copied directly to the result and conversion specifications, each of which results in fetching its own parameter.

A conversion specification follows this prototype: %[argnum$][flags][width][.precision]specifier.

Argnum

An integer followed by a dollar sign $, to specify which number argument to treat in the conversion.

Flags
Flag | 说明
- Left-justify within the given field width; Right justification is the default
+ Prefix positive numbers with a plus sign +; Default only negative are prefixed with a negative sign.
(space) | Pads the result with spaces. This is the default.
0 | Only left-pads numbers with zeros. With s specifiers this can also right-pad with zeros.
'(char) | Pads the result with the character (char).

Width

An integer that says how many characters (minimum) this conversion should result in.

Precision

A period . followed by an integer who's meaning depends on the specifier:

  • For e, E, f and F specifiers: this is the number of digits to be printed after the decimal point (by default, this is 6).
  • For g and G specifiers: this is the maximum number of significant digits to be printed.
  • For s specifier: it acts as a cutoff point, setting a maximum character limit to the string.

Note: If the period is specified without an explicit value for precision, 0 is assumed.

Note: Attempting to use a position specifier greater than PHP_INT_MAX will generate warnings.

Specifiers
Specifier | 说明
% A literal percent character. No argument is required.
b | The argument is treated as an integer and presented as a binary number.
c | The argument is treated as an integer and presented as the character with that ASCII.
d | The argument is treated as an integer and presented as a (signed) decimal number.
e | The argument is treated as scientific notation (e.g. 1.2e+2). The precision specifier stands for the number of digits after the decimal point since PHP 5.2.1. In earlier versions, it was taken as number of significant digits (one less).
E | Like the e specifier but uses uppercase letter (e.g. 1.2E+2).
f | The argument is treated as a float and presented as a floating-point number (locale aware).
F | The argument is treated as a float and presented as a floating-point number (non-locale aware). Available as of PHP 5.0.3.
g

General format.

Let P equal the precision if nonzero, 6 if the precision is omitted, or 1 if the precision is zero. Then, if a conversion with style E would have an exponent of X:

If P > X ≥ ?4, the conversion is with style f and precision P ? (X + 1). Otherwise, the conversion is with style e and precision P ? 1.

G | Like the g specifier but uses E and f.
h | Like the g specifier but uses F. Available as of PHP 8.0.0.
H | Like the g specifier but uses E and F. Available as of PHP 8.0.0.
o | The argument is treated as an integer and presented as an octal number.
s | The argument is treated and presented as a string.
u | The argument is treated as an integer and presented as an unsigned decimal number.
x | The argument is treated as an integer and presented as a hexadecimal number (with lowercase letters).
X | The argument is treated as an integer and presented as a hexadecimal number (with uppercase letters).

Warning

The c type specifier ignores padding and width

Warning

Attempting to use a combination of the string and width specifiers with character sets that require more than one byte per character may result in unexpected results

Variables will be co-erced to a suitable type for the specifier:

Type Handling
Type | Specifiers
string | s
integer | d, u, c, o, x, X, b
double | g, G, e, E, f, F

args

返回值

根据 format 参数指定的格式，在一个字符串中返回一系列值， 或者在失败时返回 false。

范例

Example #1 vsprintf(): 前导 0 的整数

<?php
print vsprintf("%04d-%02d-%02d", explode('-', '1988-8-1'));
?>

以上例程会输出：

1988-08-01

参见

  • printf() - 输出格式化字符串
  • sprintf() - Return a formatted string
  • fprintf() - 将格式化后的字符串写入到流
  • vprintf() - 输出格式化字符串
  • vfprintf() - 将格式化字符串写入流
  • sscanf() - 根据指定格式解析输入的字符
  • fscanf() - 从文件中格式化输入
  • number_format() - 以千位分隔符方式格式化一个数字
  • date() - 格式化一个本地时间／日期


打断字符串为指定数量的字串

  • ? vsprintf
  • 更新日志 ?
  • PHP Manual
  • 字符串 函数
  • 打断字符串为指定数量的字串

wordwrap

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

wordwrap — 打断字符串为指定数量的字串

说明

wordwrap ( string $str , int $width = 75 , string $break = "\n" , bool $cut = false ) : string

使用字符串断点将字符串打断为指定数量的字串。

参数

str

输入字符串。

width

列宽度。

break

使用可选的 break 参数打断字符串。

cut

如果 cut 设置为 true，字符串总是在指定的 width 或者之前位置被打断。因此，如果有的单词宽度超过了给定的宽度，它将被分隔开来。（参见第二个范例）。 当它是 false ，函数不会分割单词，哪怕 width 小于单词宽度。

返回值

返回打断后的字符串。

范例

Example #1 wordwrap() 范例

<?php
$text = "The quick brown fox jumped over the lazy dog.";
$newtext = wordwrap($text, 20, "<br />\n");

echo $newtext;
?>

以上例程会输出：

The quick brown fox<br />
jumped over the lazy<br />
dog.

Example #2 wordwrap() 范例

<?php
$text = "A very long woooooooooooord.";
$newtext = wordwrap($text, 8, "\n", true);

echo "$newtext\n";
?>

以上例程会输出：

A very
long
wooooooo
ooooord.

Example #3 wordwrap() 例子

<?php
$text = "A very long woooooooooooooooooord. and something";
$newtext = wordwrap($text, 8, "\n", false);

echo "$newtext\n";
?>

以上例程会输出：

A very
long
woooooooooooooooooord.
and
something

参见

  • nl2br() - 在字符串所有新行之前插入 HTML 换行标记
  • chunk_split() - 将字符串分割成小块


更新日志

对本扩展的类／函数／方法有以下更新。

Version | Function | Description
8.0.0 | html_entity_decode | encoding is nullable now.
 | metaphone | The function returned false on failure.
 | parse_str | result 是必须项。
 | soundex | Prior to this version, calling the function with an empty string returned false for no particular reason.
 | sprintf | This function no longer returns false on failure.
7.4.0 | implode | 把参数 glue 放到 pieces 的后面已被废弃（就是不按文档中的顺序传递参数）。
7.2.18, 7.3.5 | substr_compare | offset 现在可能等于 main_str。
7.2.0 | number_format | number_format 现在无法返回 -0，之前可能返回 -0，因为 number 可能会是 -0.01。
 | parse_str | 不带第二个参数的情况下使用 parse_str 会产生 E_DEPRECATED 警告。
7.1.0 | str_shuffle | 内置的随机算法从 libc rand 函数改成了梅森旋转演伪随机数发生算法。
 | stripos | 开始支持负数的 offset。
 | strpos | 开始支持负数的 offset。
 | substr_count | 开始支持负数的 offset 和 length。
7.0.0 | substr | 如果 string 的字符串长度与 start 相同时将返回一个空字符串。在之前的版本中，这种情况将返回 false 。
5.6.5 | crypt | When the failure string "*0" is given as the salt, "*1" will now be returned for consistency with other crypt implementations. Prior to this version, PHP 5.6 would incorrectly return a DES hash.
5.6.0 | crypt | Raise E_NOTICE security warning if salt is omitted.
 | htmlentities | The default value for the encoding parameter was changed to be the value of the default_charset configuration option.
 | htmlspecialchars | The default value for the encoding parameter was changed to be the value of the default_charset configuration option.
5.5.21 | crypt | When the failure string "*0" is given as the salt, "*1" will now be returned for consistency with other crypt implementations. Prior to this version, PHP 5.5 (and earlier branches) would incorrectly return a DES hash.
5.5.1 | hex2bin | 如果输入的字符串是无效的十六进制字符串则抛出一个警告，
5.4.32, 5.5.16 | ucwords | 增加了 delimiters 参数。
5.4.4 | hex2bin | 如果输入的字符串有多余将抛出异常。 PHP 5.4.0 起字符串将被静默地接受，但是最后的字节会被截断。
5.4.0 | get_html_translation_table | The constants ENT_HTML401, ENT_XML1, ENT_XHTML and ENT_HTML5 were added.
 | get_html_translation_table | The default value for the encoding parameter was changed to UTF-8.
 | htmlentities | encoding 参数的默认值改成 UTF-8。
 | htmlentities | 增加常量 ENT_SUBSTITUTE、 ENT_DISALLOWED、 ENT_HTML401、 ENT_XML1、 ENT_XHTML、 ENT_HTML5。
 | htmlspecialchars | encoding 参数的默认值改成 UTF-8。
 | htmlspecialchars | 增加常量 ENT_SUBSTITUTE、 ENT_DISALLOWED、 ENT_HTML401、 ENT_XML1、 ENT_XHTML、 ENT_HTML5。
 | htmlspecialchars_decode | 增加了 ENT_HTML401、ENT_XML1、 ENT_XHTML 和 ENT_HTML5 等常量。
 | number_format | This function now supports multiple bytes in dec_point and thousands_sep. Only the first byte of each separator was used in older versions.
5.3.7 | crypt | Added $2x$ and $2y$ Blowfish modes to deal with potential high-bit attacks.
5.3.4 | get_html_translation_table | The encoding parameter was added.
 | strip_tags | strip_tags ignores self-closing XHTML tags in allowable_tags.
5.3.2 | crypt | 修正了 Blowfish 算法由于非法循环导致的问题，返回“失败”字符串（“*0” 或 “*1”）而不是转而使用 DES 算法。
 | crypt | 基于 Ulrich Drepper 的实现，新增基于 SHA-256 算法和 SHA-512 算法的 crypt。
5.3.0 | crypt | PHP 现在包含了它自己的 MD5 Crypt 实现，包括标准 DES 算法，扩展的 DES 算法以及 Blowfish 算法。如果系统缺乏相应的实现，那么 PHP 将使用它自己的实现。
 | htmlentities | 增加常量 ENT_IGNORE。
 | htmlspecialchars | 增加常量 ENT_IGNORE。
 | nl2br | 新增可选的 is_xhtml 参数。在此之前，总是插入 '<br />'。
 | setlocale | This function now throws an E_DEPRECATED notice if a string is passed to the category parameter instead of one of the LC_* constants.
 | stristr | 新增可选的 before_needle 参数。
 | strlen | Prior versions treated arrays as the string Array, thus returning a string length of 5 and emitting an E_NOTICE level error.
 | strstr | 新增可选的 before_needle 参数。
5.2.5 | addcslashes | The escape sequences \v and \f were added.
5.2.3 | htmlentities | 增加参数 double_encode。
 | htmlspecialchars | 增加参数 double_encode。
5.2.2 - 5.2.6 | substr | If the start parameter indicates the position of a negative truncation or beyond, false is returned. Other versions get the string from start.
5.1.0 | explode | 支持负数的 limit
 | md5_file | 函数改用流 API。这意味着能够配合封装器使用该函数，比如 md5_file('http://example.com/..')。
5.0.0 | strip_tags | strip_tags 变为二进制安全的。
 | strrpos | 引入 offset 参数。
 | strrpos | 参数 needle 可以是一个多字符的字符串。
4.3.3 | substr_replace | All parameters now accept arrays.
4.3.0 | stristr | stristr 变为二进制安全的。
 | strrchr | 该函数是二进制安全的。
 | strspn | 新增 start 和 length 参数。
 | strstr | strstr 成为二进制安全的。
4.2.3 | strcoll | 函数在 Win32 平台可用。
4.0.1 | explode | 增加了参数 limit


变量与类型相关扩展

  • 数组
    • 简介
    • 安装／配置
    • 预定义常量
    • 对数组进行排序
    • 数组 函数
  • 类/对象 — 类/对象的信息
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • 类/对象 函数
  • Classkit
    • 简介
    • 安装／配置
    • 预定义常量
    • Classkit 函数
  • Ctype — 字符类型检测
    • 简介
    • 安装／配置
    • 预定义常量
    • Ctype 函数
  • Filter — Data Filtering
    • 简介
    • 安装／配置
    • Types of filters
    • 预定义常量
    • 范例
    • 过滤器函数
  • 函数处理
    • 简介
    • 安装／配置
    • 预定义常量
    • 函数处理 函数
  • Quickhash
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • QuickHashIntSet — The QuickHashIntSet class
    • QuickHashIntHash — The QuickHashIntHash class
    • QuickHashStringIntHash — The QuickHashStringIntHash class
    • QuickHashIntStringHash — The QuickHashIntStringHash class
  • 反射
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • 扩展
    • Reflection — Reflection 类
    • ReflectionClass — ReflectionClass 类
    • ReflectionClassConstant — The ReflectionClassConstant class
    • ReflectionZendExtension — ReflectionZendExtension 类
    • ReflectionExtension — ReflectionExtension 类
    • ReflectionFunction — ReflectionFunction 类
    • ReflectionFunctionAbstract — ReflectionFunctionAbstract 类
    • ReflectionMethod — ReflectionMethod 类
    • ReflectionObject — ReflectionObject 类
    • ReflectionParameter — ReflectionParameter 类
    • ReflectionProperty — ReflectionProperty 类
    • ReflectionType — The ReflectionType class
    • ReflectionGenerator — 生成器反射类
    • Reflector — Reflector 接口
    • ReflectionException — ReflectionException 类
  • Variable handling
    • 简介
    • 安装／配置
    • 预定义常量
    • Variable handling 函数


数组

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 对数组进行排序
  • 数组 函数
    • array_change_key_case — 将数组中的所有键名修改为全大写或小写
    • array_chunk — 将一个数组分割成多个
    • array_column — 返回数组中指定的一列
    • array_combine — 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值
    • array_count_values — 统计数组中所有的值
    • array_diff_assoc — 带索引检查计算数组的差集
    • array_diff_key — 使用键名比较计算数组的差集
    • array_diff_uassoc — 用用户提供的回调函数做索引检查来计算数组的差集
    • array_diff_ukey — 用回调函数对键名比较计算数组的差集
    • array_diff — 计算数组的差集
    • array_fill_keys — 使用指定的键和值填充数组
    • array_fill — 用给定的值填充数组
    • array_filter — 使用回调函数过滤数组的元素
    • array_flip — 交换数组中的键和值
    • array_intersect_assoc — 带索引检查计算数组的交集
    • array_intersect_key — 使用键名比较计算数组的交集
    • array_intersect_uassoc — 带索引检查计算数组的交集，用回调函数比较索引
    • array_intersect_ukey — 用回调函数比较键名来计算数组的交集
    • array_intersect — 计算数组的交集
    • array_key_exists — 检查数组里是否有指定的键名或索引
    • array_key_first — 获取指定数组的第一个键值
    • array_key_last — 获取一个数组的最后一个键值
    • array_keys — 返回数组中部分的或所有的键名
    • array_map — 为数组的每个元素应用回调函数
    • array_merge_recursive — 递归地合并一个或多个数组
    • array_merge — 合并一个或多个数组
    • array_multisort — 对多个数组或多维数组进行排序
    • array_pad — 以指定长度将一个值填充进数组
    • array_pop — 弹出数组最后一个单元（出栈）
    • array_product — 计算数组中所有值的乘积
    • array_push — 将一个或多个单元压入数组的末尾（入栈）
    • array_rand — 从数组中随机取出一个或多个随机键
    • array_reduce — 用回调函数迭代地将数组简化为单一的值
    • array_replace_recursive — 使用传递的数组递归替换第一个数组的元素
    • array_replace — 使用传递的数组替换第一个数组的元素
    • array_reverse — 返回单元顺序相反的数组
    • array_search — 在数组中搜索给定的值，如果成功则返回首个相应的键名
    • array_shift — 将数组开头的单元移出数组
    • array_slice — 从数组中取出一段
    • array_splice — 去掉数组中的某一部分并用其它值取代
    • array_sum — 对数组中所有值求和
    • array_udiff_assoc — 带索引检查计算数组的差集，用回调函数比较数据
    • array_udiff_uassoc — 带索引检查计算数组的差集，用回调函数比较数据和索引
    • array_udiff — 用回调函数比较数据来计算数组的差集
    • array_uintersect_assoc — 带索引检查计算数组的交集，用回调函数比较数据
    • array_uintersect_uassoc — 带索引检查计算数组的交集，用单独的回调函数比较数据和索引
    • array_uintersect — 计算数组的交集，用回调函数比较数据
    • array_unique — 移除数组中重复的值
    • array_unshift — 在数组开头插入一个或多个单元
    • array_values — 返回数组中所有的值
    • array_walk_recursive — 对数组中的每个成员递归地应用用户函数
    • array_walk — 使用用户自定义函数对数组中的每个元素做回调处理
    • array — 新建一个数组
    • arsort — 对数组进行逆向排序并保持索引关系
    • asort — 对数组进行排序并保持索引关系
    • compact — 建立一个数组，包括变量名和它们的值
    • count — 计算数组中的单元数目，或对象中的属性个数
    • current — 返回数组中的当前值
    • each — 返回数组中当前的键／值对并将数组指针向前移动一步
    • end — 将数组的内部指针指向最后一个单元
    • extract — 从数组中将变量导入到当前的符号表
    • in_array — 检查数组中是否存在某个值
    • key_exists — 别名 array_key_exists
    • key — 从关联数组中取得键名
    • krsort — 对数组按照键名逆向排序
    • ksort — 对数组按照键名排序
    • list — 把数组中的值赋给一组变量
    • natcasesort — 用“自然排序”算法对数组进行不区分大小写字母的排序
    • natsort — 用“自然排序”算法对数组排序
    • next — 将数组中的内部指针向前移动一位
    • pos — current 的别名
    • prev — 将数组的内部指针倒回一位
    • range — 根据范围创建数组，包含指定的元素
    • reset — 将数组的内部指针指向第一个单元
    • rsort — 对数组逆向排序
    • shuffle — 打乱数组
    • sizeof — count 的别名
    • sort — 对数组排序
    • uasort — 使用用户自定义的比较函数对数组中的值进行排序并保持索引关联
    • uksort — 使用用户自定义的比较函数对数组中的键名进行排序
    • usort — 使用用户自定义的比较函数对数组中的值进行排序


简介

这些函数允许你通过不同的方式来使用和操作数组。数组是存储、管理和操作变量组的必不可少的工具。

PHP 支持简单数组和多维数组，数组可由用户自己创建也可以由其它函数创建。有很多特殊的数据库处理函数可以从数据库查询中返回数组以及一些返回数组的函数。

请参考手册中有关数组的章节来详细了解 PHP 中数组是如何实现及使用的。也可以参考 数组操作符来了解操作数组的一些其它方式。


预定义常量

下列常量作为 PHP 核心的一部分总是可用的。

CASE_LOWER (integer)
CASE_LOWER 用在 array_change_key_case() 中将数组的键名转换成小写字母。这也是 array_change_key_case() 的默认值。
CASE_UPPER (integer)
CASE_UPPER 用在 array_change_key_case() 中将数组的键名转换成大写字母。

排序顺序标识：

SORT_ASC (integer)
SORT_ASC 用在 array_multisort() 函数中，使其升序排列。
SORT_DESC (integer)
SORT_DESC 用在 array_multisort() 函数中，使其降序排列。

排序类型标识：用于各种排序函数

SORT_REGULAR (integer)
SORT_REGULAR 用于对对象进行通常比较。
SORT_NUMERIC (integer)
SORT_NUMERIC 用于对对象进行数值比较。
SORT_STRING (integer)
SORT_STRING 用于对对象进行字符串比较。
SORT_LOCALE_STRING (integer)
SORT_LOCALE_STRING 基于当前区域来对对象进行字符串比较。PHP 4.4.0 和 5.0.2 新加。

COUNT_NORMAL (integer)
COUNT_RECURSIVE (integer)
EXTR_OVERWRITE (integer)
EXTR_SKIP (integer)
EXTR_PREFIX_SAME (integer)
EXTR_PREFIX_ALL (integer)
EXTR_PREFIX_INVALID (integer)
EXTR_PREFIX_IF_EXISTS (integer)
EXTR_IF_EXISTS (integer)
EXTR_REFS (integer)


对数组进行排序

PHP 有一些用来排序数组的函数， 这个文档会把它们列出来。

主要区别有：

  • 有些函数基于 array 的键来排序， 而其他的基于值来排序的：$array['key'] = 'value';。
  • 排序之后键和值之间的关联关系是否能够保持， 是指排序之后数组的键可能 会被重置为数字型的（0,1,2 ...）。
  • 排序的顺序有：字母表顺序， 由低到高（升序）， 由高到低（降序），数字排序，自然排序，随机顺序或者用户自定义排序。
  • 注意：下列的所有排序函数都是直接作用于数组本身， 而不是返回一个新的有序的数组。
  • 以下函数对于数组中相等的元素，它们在排序后的顺序是未定义的。 （也即相等元素之间的顺序是不稳定的）。

排序函数属性
函数名称 | 排序依据 | 数组索引键保持 | 排序的顺序 | 相关函数
array_multisort() | 值 | 键值关联的保持，数字类型的不保持 | 第一个数组或者由选项指定 | array_walk()
asort() | 值 | 是 | 由低到高 | arsort()
arsort() | 值 | 是 | 由高到低 | asort()
krsort() | 键 | 是 | 由高到低 | ksort()
ksort() | 键 | 是 | 由低到高 | asort()
natcasesort() | 值 | 是 | 自然排序，大小写不敏感 | natsort()
natsort() | 值 | 是 | 自然排序 | natcasesort()
rsort() | 值 | 否 | 由高到低 | sort()
shuffle() | 值 | 否 | 随机 | array_rand()
sort() | 值 | 否 | 由低到高 | rsort()
uasort() | 值 | 是 | 由用户定义 | uksort()
uksort() | 键 | 是 | 由用户定义 | uasort()
usort() | 值 | 否 | 由用户定义 | uasort()


数组 函数

参见

参考 is_array(), explode(),
implode(), split(),
preg_split(), and unset().

Table of Contents

  • array_change_key_case — 将数组中的所有键名修改为全大写或小写
  • array_chunk — 将一个数组分割成多个
  • array_column — 返回数组中指定的一列
  • array_combine — 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值
  • array_count_values — 统计数组中所有的值
  • array_diff_assoc — 带索引检查计算数组的差集
  • array_diff_key — 使用键名比较计算数组的差集
  • array_diff_uassoc — 用用户提供的回调函数做索引检查来计算数组的差集
  • array_diff_ukey — 用回调函数对键名比较计算数组的差集
  • array_diff — 计算数组的差集
  • array_fill_keys — 使用指定的键和值填充数组
  • array_fill — 用给定的值填充数组
  • array_filter — 使用回调函数过滤数组的元素
  • array_flip — 交换数组中的键和值
  • array_intersect_assoc — 带索引检查计算数组的交集
  • array_intersect_key — 使用键名比较计算数组的交集
  • array_intersect_uassoc — 带索引检查计算数组的交集，用回调函数比较索引
  • array_intersect_ukey — 用回调函数比较键名来计算数组的交集
  • array_intersect — 计算数组的交集
  • array_key_exists — 检查数组里是否有指定的键名或索引
  • array_key_first — 获取指定数组的第一个键值
  • array_key_last — 获取一个数组的最后一个键值
  • array_keys — 返回数组中部分的或所有的键名
  • array_map — 为数组的每个元素应用回调函数
  • array_merge_recursive — 递归地合并一个或多个数组
  • array_merge — 合并一个或多个数组
  • array_multisort — 对多个数组或多维数组进行排序
  • array_pad — 以指定长度将一个值填充进数组
  • array_pop — 弹出数组最后一个单元（出栈）
  • array_product — 计算数组中所有值的乘积
  • array_push — 将一个或多个单元压入数组的末尾（入栈）
  • array_rand — 从数组中随机取出一个或多个随机键
  • array_reduce — 用回调函数迭代地将数组简化为单一的值
  • array_replace_recursive — 使用传递的数组递归替换第一个数组的元素
  • array_replace — 使用传递的数组替换第一个数组的元素
  • array_reverse — 返回单元顺序相反的数组
  • array_search — 在数组中搜索给定的值，如果成功则返回首个相应的键名
  • array_shift — 将数组开头的单元移出数组
  • array_slice — 从数组中取出一段
  • array_splice — 去掉数组中的某一部分并用其它值取代
  • array_sum — 对数组中所有值求和
  • array_udiff_assoc — 带索引检查计算数组的差集，用回调函数比较数据
  • array_udiff_uassoc — 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_udiff — 用回调函数比较数据来计算数组的差集
  • array_uintersect_assoc — 带索引检查计算数组的交集，用回调函数比较数据
  • array_uintersect_uassoc — 带索引检查计算数组的交集，用单独的回调函数比较数据和索引
  • array_uintersect — 计算数组的交集，用回调函数比较数据
  • array_unique — 移除数组中重复的值
  • array_unshift — 在数组开头插入一个或多个单元
  • array_values — 返回数组中所有的值
  • array_walk_recursive — 对数组中的每个成员递归地应用用户函数
  • array_walk — 使用用户自定义函数对数组中的每个元素做回调处理
  • array — 新建一个数组
  • arsort — 对数组进行逆向排序并保持索引关系
  • asort — 对数组进行排序并保持索引关系
  • compact — 建立一个数组，包括变量名和它们的值
  • count — 计算数组中的单元数目，或对象中的属性个数
  • current — 返回数组中的当前值
  • each — 返回数组中当前的键／值对并将数组指针向前移动一步
  • end — 将数组的内部指针指向最后一个单元
  • extract — 从数组中将变量导入到当前的符号表
  • in_array — 检查数组中是否存在某个值
  • key_exists — 别名 array_key_exists
  • key — 从关联数组中取得键名
  • krsort — 对数组按照键名逆向排序
  • ksort — 对数组按照键名排序
  • list — 把数组中的值赋给一组变量
  • natcasesort — 用“自然排序”算法对数组进行不区分大小写字母的排序
  • natsort — 用“自然排序”算法对数组排序
  • next — 将数组中的内部指针向前移动一位
  • pos — current 的别名
  • prev — 将数组的内部指针倒回一位
  • range — 根据范围创建数组，包含指定的元素
  • reset — 将数组的内部指针指向第一个单元
  • rsort — 对数组逆向排序
  • shuffle — 打乱数组
  • sizeof — count 的别名
  • sort — 对数组排序
  • uasort — 使用用户自定义的比较函数对数组中的值进行排序并保持索引关联
  • uksort — 使用用户自定义的比较函数对数组中的键名进行排序
  • usort — 使用用户自定义的比较函数对数组中的值进行排序


将数组中的所有键名修改为全大写或小写

  • ? 数组 函数
  • array_chunk ?
  • PHP Manual
  • 数组 函数
  • 将数组中的所有键名修改为全大写或小写

array_change_key_case

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

array_change_key_case — 将数组中的所有键名修改为全大写或小写

说明

array_change_key_case ( array $array , int $case = CASE_LOWER ) : array

array_change_key_case() 将 array 数组中的所有键名改为全小写或大写。本函数不改变数字索引。

参数

array

需要操作的数组。

case

可以在这里用两个常量，CASE_UPPER 或 CASE_LOWER（默认值）。

返回值

返回一个键全是小写或者全是大写的数组；如果输入值（array）不是一个数组，那么返回false

错误／异常

如果输入值（array）不是一个数组，就会抛出一个错误警告（E_WARNING）。

范例

Example #1 array_change_key_case()例一

<?php
$input_array = array("FirSt" => 1, "SecOnd" => 4);
print_r(array_change_key_case($input_array, CASE_UPPER));
?>

以上例程会输出：

Array
(
    [FIRST] => 1
    [SECOND] => 4
)

注释

Note:

如果一个数组中的多个键名经过本函数后变成一样的话（例如 "keY" 和 "kEY"），最后一个值将覆盖其它的值。


将一个数组分割成多个

  • ? array_change_key_case
  • array_column ?
  • PHP Manual
  • 数组 函数
  • 将一个数组分割成多个

array_chunk

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

array_chunk — 将一个数组分割成多个

说明

array_chunk ( array $array , int $size , bool $preserve_keys = false ) : array

将一个数组分割成多个数组，其中每个数组的单元数目由 size 决定。最后一个数组的单元数目可能会少于 size 个。

参数

array

需要操作的数组

size

每个数组的单元数目

preserve_keys

设为 true，可以使 PHP 保留输入数组中原来的键名。如果你指定了 false，那每个结果数组将用从零开始的新数字索引。默认值是 false。

返回值

得到的数组是一个多维数组中的单元，其索引从零开始，每一维包含了 size 个元素。

错误／异常

如果 size 小于 1，会抛出一个 E_WARNING 错误并返回 null。

范例

Example #1 array_chunk() 例子

<?php
$input_array = array('a', 'b', 'c', 'd', 'e');
print_r(array_chunk($input_array, 2));
print_r(array_chunk($input_array, 2, true));
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [0] => c
            [1] => d
        )

    [2] => Array
        (
            [0] => e
        )

)
Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [2] => c
            [3] => d
        )

    [2] => Array
        (
            [4] => e
        )

)

参见

  • array_slice() - 从数组中取出一段


返回数组中指定的一列

  • ? array_chunk
  • array_combine ?
  • PHP Manual
  • 数组 函数
  • 返回数组中指定的一列

array_column

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

array_column — 返回数组中指定的一列

说明

array_column ( array $input , mixed $column_key , mixed $index_key = null ) : array

array_column() 返回input数组中键值为column_key的列， 如果指定了可选参数index_key，那么input数组中的这一列的值将作为返回数组中对应值的键。

参数

input

需要取出数组列的多维数组。 如果提供的是包含一组对象的数组，只有 public 属性会被直接取出。 为了也能取出 private 和 protected 属性，类必须实现 __get() 和 __isset() 魔术方法。

column_key

需要返回值的列，它可以是索引数组的列索引，或者是关联数组的列的键，也可以是属性名。 也可以是null，此时将返回整个数组（配合index_key参数来重置数组键的时候，非常管用）

index_key

作为返回数组的索引/键的列，它可以是该列的整数索引，或者字符串键值。

返回值

从多维数组中返回单列数组。

更新日志

版本 | 说明
7.0.0 | input 参数现在可以是包含对象的数组。

范例

Example #1 从结果集中取出first names列

<?php
// Array representing a possible record set returned from a database
$records = array(
    array(
        'id' => 2135,
        'first_name' => 'John',
        'last_name' => 'Doe',
    ),
    array(
        'id' => 3245,
        'first_name' => 'Sally',
        'last_name' => 'Smith',
    ),
    array(
        'id' => 5342,
        'first_name' => 'Jane',
        'last_name' => 'Jones',
    ),
    array(
        'id' => 5623,
        'first_name' => 'Peter',
        'last_name' => 'Doe',
    )
);

$first_names = array_column($records, 'first_name');
print_r($first_names);
?>

以上例程会输出：

Array
(
    [0] => John
    [1] => Sally
    [2] => Jane
    [3] => Peter
)

Example #2 从结果集中总取出last names列，用相应的id作为键值

<?php
// Using the $records array from Example #1
$last_names = array_column($records, 'last_name', 'id');
print_r($last_names);
?>

以上例程会输出：

Array
(
    [2135] => Doe
    [3245] => Smith
    [5342] => Jones
    [5623] => Doe
)

Example #3 username 列是从对象获取 public 的 "username" 属性

<?php

class User
{
    public $username;

    public function __construct(string $username)
    {
        $this->username = $username;
    }
}

$users = [
    new User('user 1'),
    new User('user 2'),
    new User('user 3'),
];

print_r(array_column($users, 'username'));
?>

以上例程会输出：

Array
(
    [0] => user 1
    [1] => user 2
    [2] => user 3
)

Example #4 获取 username 列，从对象通过魔术方法 __get() 获取 private 的 "username" 属性。

<?php

class Person
{
    private $name;

    public function __construct(string $name)
    {
        $this->name = $name;
    }

    public function __get($prop)
    {
        return $this->$prop;
    }

    public function __isset($prop) : bool
    {
        return isset($this->$prop);
    }
}

$people = [
    new Person('Fred'),
    new Person('Jane'),
    new Person('John'),
];

print_r(array_column($people, 'name'));
?>

以上例程会输出：

Array
(
    [0] => Fred
    [1] => Jane
    [2] => John
)
如果不提供__isset()，会返回空数组。

参见

  • » Recommended userland implementation for PHP lower than 5.5


创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值

  • ? array_column
  • array_count_values ?
  • PHP Manual
  • 数组 函数
  • 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值

array_combine

(PHP 5, PHP 7, PHP 8)

array_combine — 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值

说明

array_combine ( array $keys , array $values ) : array

返回一个 array，用来自 keys 数组的值作为键名，来自 values 数组的值作为相应的值。

参数

keys

将被作为新数组的键。非法的值将会被转换为字符串类型（string）。

values

将被作为 Array 的值。

返回值

返回合并的 array，如果两个数组的单元数不同则返回 false。

错误／异常

如果作为keys的数组和作为values的数组的元素个数不一样，将会抛出一个警告错误（E_WARNING）。

更新日志

版本 | 说明
5.4.0 | （修复）早期版本中如果是空数组就报E_WARNING的错并且返回false。

范例

Example #1 一个 array_combine() 简单的例子

<?php
$a = array('green', 'red', 'yellow');
$b = array('avocado', 'apple', 'banana');
$c = array_combine($a, $b);

print_r($c);
?>

以上例程会输出：

Array
(
    [green]  => avocado
    [red]    => apple
    [yellow] => banana
)

参见

  • array_merge() - 合并一个或多个数组
  • array_walk() - 使用用户自定义函数对数组中的每个元素做回调处理
  • array_values() - 返回数组中所有的值


统计数组中所有的值

  • ? array_combine
  • array_diff_assoc ?
  • PHP Manual
  • 数组 函数
  • 统计数组中所有的值

array_count_values

(PHP 4, PHP 5, PHP 7, PHP 8)

array_count_values — 统计数组中所有的值

说明

array_count_values ( array $array ) : array

array_count_values() 返回一个数组： 数组的键是 array 里单元的值； 数组的值是 array 单元的值出现的次数。

参数

input

统计这个数组的值

返回值

返回一个关联数组，用 array 数组中的值作为键名，该值在数组中出现的次数作为值。

错误／异常

对数组里面的每个不是 string 和 integer 类型的元素抛出一个警告错误（E_WARNING）。

范例

Example #1 array_count_values() 例子

<?php
$array = array(1, "hello", 1, "world", "hello");
print_r(array_count_values($array));
?>

以上例程会输出：

Array
(
    [1] => 2
    [hello] => 2
    [world] => 1
)

参见

  • count() - 计算数组中的单元数目，或对象中的属性个数
  • array_unique() - 移除数组中重复的值
  • array_values() - 返回数组中所有的值
  • count_chars() - 返回字符串所用字符的信息


带索引检查计算数组的差集

  • ? array_count_values
  • array_diff_key ?
  • PHP Manual
  • 数组 函数
  • 带索引检查计算数组的差集

array_diff_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

array_diff_assoc — 带索引检查计算数组的差集

说明

array_diff_assoc ( array $array1 , array $array2 , array $... = ? ) : array

array_diff_assoc() 返回一个数组，该数组包括了所有在 array1 中但是不在任何其它参数数组中的值。注意和 array_diff() 不同的是键名也用于比较。

参数

array1

从这个数组进行比较

array2

被比较的数组

...

更多被比较的数组

返回值

Returns an array containing all the values from array1 that are not present in any of the other arrays.

范例

Example #1 array_diff_assoc() 例子

上面的例子中可以看到键值对 "a" => "green" 在两个数组中都有，因此不在本函数的输出中。与此不同，键值对 0 => "red" 出现在输出中是因为第二个参数中的 "red" 的键名是 1。

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result = array_diff_assoc($array1, $array2);
print_r($result);
?>

以上例程会输出：

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

Example #2 array_diff_assoc() example

键值对 key => value 中的两个值仅在 (string) $elem1 === (string) $elem2 时被认为相等。也就是说使用了严格检查，字符串的表达必须相同。

<?php
$array1 = array(0, 1, 2);
$array2 = array("00", "01", "2");
$result = array_diff_assoc($array1, $array2);
print_r($result);
?>

以上例程会输出：

Array
(
    [0] => 0
    [1] => 1
    )

注释

Note: 注意本函数只检查了多维数组中的一维。当然可以用 array_diff_assoc($array1[0], $array2[0]); 检查更深的维度。

Note: 使用更多的键比较相似数组时，确保你传入参数的顺序是正确的。 新的数组应该是在列表里的第一个。

参见

  • array_diff() - 计算数组的差集
  • array_diff_uassoc() - 用用户提供的回调函数做索引检查来计算数组的差集
  • array_udiff_assoc() - 带索引检查计算数组的差集，用回调函数比较数据
  • array_udiff_uassoc() - 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集


使用键名比较计算数组的差集

  • ? array_diff_assoc
  • array_diff_uassoc ?
  • PHP Manual
  • 数组 函数
  • 使用键名比较计算数组的差集

array_diff_key

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_diff_key — 使用键名比较计算数组的差集

说明

array_diff_key ( array $array1 , array $array2 , array $... = ? ) : array

根据 array1 中的键名和 array2 进行比较，返回不同键名的项。 本函数和 array_diff() 相同只除了比较是根据键名而不是值来进行的。

参数

array1

从这个数组进行比较

array2

针对此数组进行比较

...

更多比较数组

返回值

array_diff_key() 返回一个数组，该数组包括了所有出现在 array1 中但是未出现在任何其它参数数组中的键名的值。

范例

Example #1 array_diff_key() 例

在 key => value 对中的两个键名仅在 (string) $key1 === (string) $key2 时被认为相等。换句话说，执行的是严格类型检查，因此字符串的表达必须完全一样。

<?php
$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_diff_key($array1, $array2));
?>

以上例程会输出：

array(2) {
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}

注释

Note:

注意本函数只检查了多维数组中的一维。当然，可以用 array_diff_key($array1[0], $array2[0]); 来检查更深的维度。

参见

  • array_diff() - 计算数组的差集
  • array_udiff() - 用回调函数比较数据来计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_diff_uassoc() - 用用户提供的回调函数做索引检查来计算数组的差集
  • array_udiff_assoc() - 带索引检查计算数组的差集，用回调函数比较数据
  • array_udiff_uassoc() - 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_diff_ukey() - 用回调函数对键名比较计算数组的差集
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_intersect_uassoc() - 带索引检查计算数组的交集，用回调函数比较索引
  • array_intersect_key() - 使用键名比较计算数组的交集
  • array_intersect_ukey() - 用回调函数比较键名来计算数组的交集


用用户提供的回调函数做索引检查来计算数组的差集

  • ? array_diff_key
  • array_diff_ukey ?
  • PHP Manual
  • 数组 函数
  • 用用户提供的回调函数做索引检查来计算数组的差集

array_diff_uassoc

(PHP 5, PHP 7, PHP 8)

array_diff_uassoc — 用用户提供的回调函数做索引检查来计算数组的差集

说明

array_diff_uassoc ( array $array1 , array $array2 , array $... = ? , callable $key_compare_func ) : array

对比了 array1 和 array2 并返回不同之处。 注意和 array_diff() 不同的是键名也用于比较。

和 array_diff_assoc() 不同的是使用了用户自定义的回调函数，而不是内置的函数。

参数

array1

待比较的数组

array2

和这个数组进行比较

...

更多比较的数组

key_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

返回一个 array，该数组包括了所有在 array1 中但是不在任何其它参数数组中的值。

范例

Example #1 array_diff_uassoc() 例子

上面的例子中 "a" => "green" 出现在两个数组中因此不在函数的输出中。但是 0 => "red" 却在输出中，因为第二个参数中的 "red" 的键名是 1。

<?php
function key_compare_func($a, $b)
{
    if ($a === $b) {
        return 0;
    }
    return ($a > $b)? 1:-1;
}

$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result = array_diff_uassoc($array1, $array2, "key_compare_func");
print_r($result);
?>

以上例程会输出：

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

The equality of 2 indices is checked by the user supplied callback function.

注释

Note:

注意本函数只检查了多维数组中的一维。当然可以用 array_diff_uassoc($array1[0], $array2[0], "key_compare_func"); 检查更深的维度。

参见

  • array_diff() - 计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_udiff() - 用回调函数比较数据来计算数组的差集
  • array_udiff_assoc() - 带索引检查计算数组的差集，用回调函数比较数据
  • array_udiff_uassoc() - 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_uintersect() - 计算数组的交集，用回调函数比较数据
  • array_uintersect_assoc() - 带索引检查计算数组的交集，用回调函数比较数据
  • array_uintersect_uassoc() - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引


用回调函数对键名比较计算数组的差集

  • ? array_diff_uassoc
  • array_diff ?
  • PHP Manual
  • 数组 函数
  • 用回调函数对键名比较计算数组的差集

array_diff_ukey

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_diff_ukey — 用回调函数对键名比较计算数组的差集

说明

array_diff_ukey ( array $array1 , array $array2 , array $... = ? , callable $key_compare_func ) : array

array_diff_ukey() 返回一个数组，该数组包括了所有出现在 array1 中但是未出现在任何其它参数数组中的键名的值。注意关联关系保留不变。本函数和 array_diff() 相同只除了比较是根据键名而不是值来进行的。

此比较是通过用户提供的回调函数来进行的。如果认为第一个参数小于，等于，或大于第二个参数时必须分别返回一个小于零，等于零，或大于零的整数。

参数

array1

The array to compare from

array2

An array to compare against

...

More arrays to compare against

key_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

Returns an array containing all the entries from array1 that are not present in any of the other arrays.

范例

Example #1 array_diff_ukey() 例子

<?php
function key_compare_func($key1, $key2)
{
    if ($key1 == $key2)
        return 0;
    else if ($key1 > $key2)
        return 1;
    else
        return -1;
}

$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_diff_ukey($array1, $array2, 'key_compare_func'));
?>

以上例程会输出：

array(2) {
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}

注释

Note:

注意本函数只检查了多维数组中的一维。当然，可以用 array_diff_ukey($array1[0], $array2[0], 'callback_func'); 来检查更深的维度。

参见

  • array_diff() - 计算数组的差集
  • array_udiff() - 用回调函数比较数据来计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_diff_uassoc() - 用用户提供的回调函数做索引检查来计算数组的差集
  • array_udiff_assoc() - 带索引检查计算数组的差集，用回调函数比较数据
  • array_udiff_uassoc() - 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_diff_key() - 使用键名比较计算数组的差集
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_intersect_uassoc() - 带索引检查计算数组的交集，用回调函数比较索引
  • array_intersect_key() - 使用键名比较计算数组的交集
  • array_intersect_ukey() - 用回调函数比较键名来计算数组的交集


计算数组的差集

  • ? array_diff_ukey
  • array_fill_keys ?
  • PHP Manual
  • 数组 函数
  • 计算数组的差集

array_diff

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

array_diff — 计算数组的差集

说明

array_diff ( array $array , array ...$arrays ) : array

对比 array 和其他一个或者多个数组，返回在 array 中但是不在其他 array 里的值。

参数

array

要被对比的数组

arrays

和更多数组进行比较

返回值

返回一个数组，该数组包括了所有在 array 中但是不在任何其它参数数组中的值。注意键名保留不变。 保留数组 array 里的键。

范例

Example #1 array_diff() 例子

<?php
$array1 = array("a" => "green", "red", "blue", "red");
$array2 = array("b" => "green", "yellow", "red");
$result = array_diff($array1, $array2);

print_r($result);
?>

在 $array1 中多次出现的值一样处理，输出结果为：

Array
(
    [1] => blue
)

Example #2 array_diff() example with non-matching types

两个元素只有在 (string) $elem1 === (string) $elem2 相等时视为一致。 也就是字符串转换表达相同。

<?php
// 数组无法转换成字符串时会产生 Notice 警告
$source = [1, 2, 3, 4];
$filter = [3, 4, [5], 6];
$result = array_diff($source, $filter);

// 而这个就可以，因为对象可以转换成字符串
class S {
  private $v;

  public function __construct(string $v) {
    $this->v = $v;
  }

  public function __toString() {
    return $this->v;
  }
}

$source = [new S('a'), new S('b'), new S('c')];
$filter = [new S('b'), new S('c'), new S('d')];

$result = array_diff($source, $filter);

// $result 包含了一个 S('a'); 实例
?>

想要使用函数来比较，可使用 array_udiff()。

注释

Note:

注意本函数只检查了多维数组中的一维。当然可以用 array_diff($array1[0], $array2[0]); 检查更深的维度。

参见

  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_udiff() - 用回调函数比较数据来计算数组的差集
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集


使用指定的键和值填充数组

  • ? array_diff
  • array_fill ?
  • PHP Manual
  • 数组 函数
  • 使用指定的键和值填充数组

array_fill_keys

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

array_fill_keys — 使用指定的键和值填充数组

说明

array_fill_keys ( array $keys , mixed $value ) : array

使用 value 参数的值作为值，使用 keys 数组的值作为键来填充一个数组。

参数

keys

使用该数组的值作为键。非法值将被转换为字符串。

value

填充使用的值。

返回值

返回填充后的数组。

范例

Example #1 array_fill_keys() 范例

<?php
$keys = array('foo', 5, 10, 'bar');
$a = array_fill_keys($keys, 'banana');
print_r($a);
?>

以上例程会输出：

Array
(
    [foo] => banana
    [5] => banana
    [10] => banana
    [bar] => banana
)

参见

  • array_fill() - 用给定的值填充数组
  • array_combine() - 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值


用给定的值填充数组

  • ? array_fill_keys
  • array_filter ?
  • PHP Manual
  • 数组 函数
  • 用给定的值填充数组

array_fill

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

array_fill — 用给定的值填充数组

说明

array_fill ( int $start_index , int $count , mixed $value ) : array

用 value 参数的值填充 count 个元素到数组， 开始键名由 start_index 参数指定。

参数

start_index

返回的数组的第一个索引值。

如果 start_index 是负数， 那么返回的数组的第一个索引将会是 start_index ，而后面索引则从0开始。 (参见 例子)。

count

要插入元素的数量。 必须大于或等于 0。

value

用来填充的值。

返回值

返回填充后的数组。

错误／异常

如果 count 小于零，将会抛出 E_WARNING。

更新日志

版本 | 说明
5.6.0 | count 现在可以是零。 之前 count 必须大于零。

范例

Example #1 array_fill() 例子

<?php
$a = array_fill(5, 6, 'banana');
$b = array_fill(-2, 4, 'pear');
print_r($a);
print_r($b);
?>

以上例程会输出：

Array
(
    [5]  => banana
    [6]  => banana
    [7]  => banana
    [8]  => banana
    [9]  => banana
    [10] => banana
)
Array
(
    [-2] => pear
    [0] => pear
    [1] => pear
    [2] => pear
)

注释

参见手册上 数组 一节里关于负数的键的详细解释。

参见

  • array_fill_keys() - 使用指定的键和值填充数组
  • str_repeat() - 重复一个字符串
  • range() - 根据范围创建数组，包含指定的元素


使用回调函数过滤数组的元素

  • ? array_fill
  • array_flip ?
  • PHP Manual
  • 数组 函数
  • 使用回调函数过滤数组的元素

array_filter

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

array_filter — 使用回调函数过滤数组的元素

说明

array_filter ( array $array , callable|null $callback = null , int $mode = 0 ) : array

遍历 array 数组中的每个值，并将每个值传递给 callback 回调函数。 如果 callback 回调函数返回 true，则将 array 数组中的当前值返回到结果 array 数组中。

返回结果 array 数组的键名（下标）会维持不变，如果 array 参数是索引数组，返回的结果 array 数组键名（下标）可能会不连续。 可以使用 array_values() 函数对数组重新索引。

参数

array

要遍历的数组

callback

使用的回调函数

如果没有提供 callback 回调函数，将删除数组中 array 的所有"空"元素。 有关 PHP 如何判定"空"元素，请参阅 empty() 。

mode

决定哪些参数发送到 callback 回调的标志：

  • ARRAY_FILTER_USE_KEY - 将键名作为 callback 回调的唯一参数，而不是值
  • ARRAY_FILTER_USE_BOTH - 将值和键都作为参数传递给 callback 回调，而不是仅传递值
默认值为 0 ，只传递值作为 callback 回调的唯一参数。

返回值

返回过滤后的数组。

更新日志

版本 | 说明
8.0.0 | callback 回调现在可以为空（nullable）。
5.6.0 | 添加可选的 mode 标志和常量（ ARRAY_FILTER_USE_KEY 和 ARRAY_FILTER_USE_BOTH ）

范例

Example #1 array_filter() 示例

<?php
function odd($var)
{
    // 返回输入整数是否为奇数（单数）
    return $var & 1;
}
function even($var)
{
    // 返回输入整数是否为偶数
    return !($var & 1);
}
$array1 = ['a' => 1, 'b' => 2, 'c' => 3, 'd' => 4, 'e' => 5];
$array2 = [6, 7, 8, 9, 10, 11, 12];
echo "Odd :\n";
print_r(array_filter($array1, "odd"));
echo "Even:\n";
print_r(array_filter($array2, "even"));
?>

以上例程会输出：

Odd :
Array
(
    [a] => 1
    [c] => 3
    [e] => 5
)
Even:
Array
(
    [0] => 6
    [2] => 8
    [4] => 10
    [6] => 12
)

Example #2 array_filter() 不使用 callback 参数时

<?php
$entry = [
    0 => 'foo',
    1 => false,
    2 => -1,
    3 => null,
    4 => '',
    5 => '0',
    6 => 0,
];
print_r(array_filter($entry));
?>

以上例程会输出：

Array
(
    [0] => foo
    [2] => -1
)

Example #3 array_filter() 不使用 mode 参数时

<?php
$arr = ['a' => 1, 'b' => 2, 'c' => 3, 'd' => 4];
var_dump(array_filter($arr, function($k) {
    return $k == 'b';
}, ARRAY_FILTER_USE_KEY));
var_dump(array_filter($arr, function($v, $k) {
    return $k == 'b' || $v == 4;
}, ARRAY_FILTER_USE_BOTH));
?>

以上例程会输出：

array(1) {
  ["b"]=>
  int(2)
}
array(2) {
  ["b"]=>
  int(2)
  ["d"]=>
  int(4)
}

注释

Caution

不应该在回调函数中改变数组（如：添加、删除或销毁"unset"当前数组和里面的元素），否则此函数的行为将不可预测。

参见

  • array_map() - 为数组的每个元素应用回调函数
  • array_reduce() - 用回调函数迭代地将数组简化为单一的值
  • array_walk() - 使用用户自定义函数对数组中的每个元素做回调处理


交换数组中的键和值

  • ? array_filter
  • array_intersect_assoc ?
  • PHP Manual
  • 数组 函数
  • 交换数组中的键和值

array_flip

(PHP 4, PHP 5, PHP 7, PHP 8)

array_flip — 交换数组中的键和值

说明

array_flip ( array $array ) : array

array_flip() 返回一个反转后的 array，例如 array 中的键名变成了值，而 array 中的值成了键名。

注意 array 中的值需要能够作为合法的键名（例如需要是 int 或者 string）。如果类型不对，将出现一个警告，并且有问题的键／值对将不会出现在结果里。

如果同一个值出现多次，则最后一个键名将作为它的值，其它键会被丢弃。

参数

array

要交换键/值对的数组。

返回值

成功时返回交换后的数组，如果失败返回 null。

范例

Example #1 array_flip() 例子

<?php
$input = array("oranges", "apples", "pears");
$flipped = array_flip($input);

print_r($flipped);
?>

以上例程会输出：

Array
(
    [oranges] => 0
    [apples] => 1
    [pears] => 2
)

Example #2 array_flip() 例子 : 冲突

<?php
$input = array("a" => 1, "b" => 1, "c" => 2);
$flipped = array_flip($input);

print_r($flipped);
?>

以上例程会输出：

Array
(
    [1] => b
    [2] => c
)

参见

  • array_values() - 返回数组中所有的值
  • array_keys() - 返回数组中部分的或所有的键名
  • array_reverse() - 返回单元顺序相反的数组


带索引检查计算数组的交集

  • ? array_flip
  • array_intersect_key ?
  • PHP Manual
  • 数组 函数
  • 带索引检查计算数组的交集

array_intersect_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7, PHP 8)

array_intersect_assoc — 带索引检查计算数组的交集

说明

array_intersect_assoc ( array $array1 , array $array2 , array $... = ? ) : array

array_intersect_assoc() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。注意和 array_intersect() 不同的是键名也用于比较。

参数

array1

要检查的主值。

array2

要比较的数组。

...

要对比的数组变量的列表。

返回值

返回数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。

范例

Example #1 array_intersect_assoc() 例子

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "b" => "yellow", "blue", "red");
$result_array = array_intersect_assoc($array1, $array2);
print_r($result_array);
?>

以上例程会输出：

Array
(
    [a] => green
)

上面例子中可以看到只有键值对 "a" => "green" 在两个数组中都存在从而被返回。值 "red" 没有被返回是因为在 $array1 中它的键名是 0 而在 $array2 中 "red" 的键名是 1，键 "b" 没有返回的原因是它的值和其他数组不同。

键值对 key => value 中的两个值仅在 (string) $elem1 === (string) $elem2 时被认为相等。也就是说使用了严格检查，字符串的表达必须相同。

参见

  • array_intersect() - 计算数组的交集
  • array_uintersect_assoc() - 带索引检查计算数组的交集，用回调函数比较数据
  • array_intersect_uassoc() - 带索引检查计算数组的交集，用回调函数比较索引
  • array_uintersect_uassoc() - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引
  • array_diff() - 计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集


使用键名比较计算数组的交集

  • ? array_intersect_assoc
  • array_intersect_uassoc ?
  • PHP Manual
  • 数组 函数
  • 使用键名比较计算数组的交集

array_intersect_key

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_intersect_key — 使用键名比较计算数组的交集

说明

array_intersect_key ( array $array1 , array $array2 , array $... = ? ) : array

array_intersect_key() 返回一个数组，该数组包含了所有出现在 array1 中并同时出现在所有其它参数数组中的键名的值。

参数

array1

The array with master keys to check.

array2

An array to compare keys against.

...

A variable list of arrays to compare.

返回值

Returns an associative array containing all the entries of array1 which have keys that are present in all arguments.

范例

Example #1 array_intersect_key() 例子

<?php
$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_intersect_key($array1, $array2));
?>

以上例程会输出：

array(2) {
  ["blue"]=>
  int(1)
  ["green"]=>
  int(3)
}

上例中可以看到只有 'blue' 和 'green' 两个键名出现在两个数组中，因此被返回。此外注意 'blue' 和 'green' 的值在两个数组中是不同的。但因为只检查键名，因此还是匹配。返回的值只是 array1 中的。

在 key => value 对中的两个键名仅在 (string) $key1 === (string) $key2 时被认为相等。换句话说，执行的是严格类型检查，因此字符串的表达必须完全一样。

参见

  • array_diff() - 计算数组的差集
  • array_udiff() - 用回调函数比较数据来计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_diff_uassoc() - 用用户提供的回调函数做索引检查来计算数组的差集
  • array_udiff_assoc() - 带索引检查计算数组的差集，用回调函数比较数据
  • array_udiff_uassoc() - 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_diff_key() - 使用键名比较计算数组的差集
  • array_diff_ukey() - 用回调函数对键名比较计算数组的差集
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_intersect_uassoc() - 带索引检查计算数组的交集，用回调函数比较索引
  • array_intersect_ukey() - 用回调函数比较键名来计算数组的交集


带索引检查计算数组的交集，用回调函数比较索引

  • ? array_intersect_key
  • array_intersect_ukey ?
  • PHP Manual
  • 数组 函数
  • 带索引检查计算数组的交集，用回调函数比较索引

array_intersect_uassoc

(PHP 5, PHP 7, PHP 8)

array_intersect_uassoc — 带索引检查计算数组的交集，用回调函数比较索引

说明

array_intersect_uassoc ( array $array1 , array $array2 , array $... = ? , callable $key_compare_func ) : array

array_intersect_uassoc() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。注意和 array_intersect() 不同的是键名也用于比较。

参数

array1

Initial array for comparison of the arrays.

array2

First array to compare keys against.

...

Variable list of array arguments to compare values against.

key_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

Returns the values of array1 whose values exist in all of the arguments.

范例

Example #1 array_intersect_uassoc() 例子

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_intersect_uassoc($array1, $array2, "strcasecmp"));
?>

以上例程会输出：

Array
(
    [b] => brown
)

参见

  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_uintersect_assoc() - 带索引检查计算数组的交集，用回调函数比较数据
  • array_uintersect_uassoc() - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引
  • array_intersect_key() - 使用键名比较计算数组的交集
  • array_intersect_ukey() - 用回调函数比较键名来计算数组的交集


用回调函数比较键名来计算数组的交集

  • ? array_intersect_uassoc
  • array_intersect ?
  • PHP Manual
  • 数组 函数
  • 用回调函数比较键名来计算数组的交集

array_intersect_ukey

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_intersect_ukey — 用回调函数比较键名来计算数组的交集

说明

array_intersect_ukey ( array $array1 , array $array2 , array $... = ? , callable $key_compare_func ) : array

array_intersect_ukey() 返回一个数组，该数组包含了所有出现在 array1 中并同时出现在所有其它参数数组中的键名的值。

参数

array1

Initial array for comparison of the arrays.

array2

First array to compare keys against.

...

Variable list of array arguments to compare keys against.

key_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

Returns the values of array1 whose keys exist in all the arguments.

范例

Example #1 array_intersect_ukey() 例子

<?php
function key_compare_func($key1, $key2)
{
    if ($key1 == $key2)
        return 0;
    else if ($key1 > $key2)
        return 1;
    else
        return -1;
}

$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_intersect_ukey($array1, $array2, 'key_compare_func'));
?>

以上例程会输出：

array(2) {
  ["blue"]=>
  int(1)
  ["green"]=>
  int(3)
}

上例中可以看到只有 'blue' 和 'green' 两个键名出现在两个数组中，因此被返回。此外注意 'blue' 和 'green' 的值在两个数组中是不同的。但因为只检查键名，因此还是匹配。返回的值只是 array1 中的。

参见

  • array_diff() - 计算数组的差集
  • array_udiff() - 用回调函数比较数据来计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_diff_uassoc() - 用用户提供的回调函数做索引检查来计算数组的差集
  • array_udiff_assoc() - 带索引检查计算数组的差集，用回调函数比较数据
  • array_udiff_uassoc() - 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_diff_key() - 使用键名比较计算数组的差集
  • array_diff_ukey() - 用回调函数对键名比较计算数组的差集
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_intersect_uassoc() - 带索引检查计算数组的交集，用回调函数比较索引
  • array_intersect_key() - 使用键名比较计算数组的交集


计算数组的交集

  • ? array_intersect_ukey
  • array_key_exists ?
  • PHP Manual
  • 数组 函数
  • 计算数组的交集

array_intersect

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

array_intersect — 计算数组的交集

说明

array_intersect ( array $array1 , array $array2 , array $... = ? ) : array

array_intersect() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。注意键名保留不变。

参数

array1

要检查的数组，作为主值。

array2

要被对比的数组。

...

要对比的数组列表。

返回值

返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。

范例

Example #1 array_intersect() 例子

<?php
$array1 = array("a" => "green", "red", "blue");
$array2 = array("b" => "green", "yellow", "red");
$result = array_intersect($array1, $array2);
print_r($result);
?>

以上例程会输出：

Array
(
    [a] => green
    [0] => red
)

注释

Note: 两个单元仅在 (string) $elem1 === (string) $elem2 时被认为是相同的。也就是说，当字符串的表达是一样的时候。

参见

  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_diff() - 计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集


检查数组里是否有指定的键名或索引

  • ? array_intersect
  • array_key_first ?
  • PHP Manual
  • 数组 函数
  • 检查数组里是否有指定的键名或索引

array_key_exists

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PHP 8)

array_key_exists — 检查数组里是否有指定的键名或索引

说明

array_key_exists ( mixed $key , array $array ) : bool

数组里有键 key 时，array_key_exists() 返回 true。 key 可以是任何能作为数组索引的值。

参数

key

要检查的键。

array

一个数组，包含待检查的键。

返回值

成功时返回 true， 或者在失败时返回 false。

Note:

array_key_exists() 仅仅搜索第一维的键。 多维数组里嵌套的键不会被搜索到。

范例

Example #1 array_key_exists() 例子

<?php
$search_array = array('first' => 1, 'second' => 4);
if (array_key_exists('first', $search_array)) {
    echo "The 'first' element is in the array";
}
?>

Example #2 array_key_exists() 与 isset() 的对比

isset() 对于数组中为 null 的值不会返回 true，而 array_key_exists() 会。

<?php
$search_array = array('first' => null, 'second' => 4);

// returns false
isset($search_array['first']);

// returns true
array_key_exists('first', $search_array);
?>

注释

Note:

由于为了兼容以前版本，如果 object 当做 array 传入 array_key_exists()，同时 key 是对象的属性，也会返回 true。 不要依赖这个特性，保证参数 array 类型是数组（array）。

要检查对象是否有某个属性，应该去用 property_exists()。

参见

  • isset() - 检测变量是否已设置并且非 null
  • array_keys() - 返回数组中部分的或所有的键名
  • in_array() - 检查数组中是否存在某个值
  • property_exists() - 检查对象或类是否具有该属性


获取指定数组的第一个键值

  • ? array_key_exists
  • array_key_last ?
  • PHP Manual
  • 数组 函数
  • 获取指定数组的第一个键值

array_key_first

(PHP 7 >= 7.3.0, PHP 8)

array_key_first — 获取指定数组的第一个键值

说明

array_key_first ( array $array ) : mixed

取得指定数组的 array 第一个键值，不影响到原数组的内部指针。

参数

array

要操作的数组。

返回值

返回 array 的第一个键值（如果不为空），否则返回 null。

范例

Example #1 array_key_first() 基本用法

<?php
$array = ['a' => 1, 'b' => 2, 'c' => 3];

$firstKey = array_key_first($array);

var_dump($firstKey);
?>

以上例程会输出：

string(1) "a"

注释

Tip

在 PHP 7.3.0 之前，有几种方式可以实现该功能。可以使用 array_keys() 函数，但是性能会比较低。也可以使用 reset() 和 key() 函数，但这可能会影响内部数组指针。一个用旧函数实现该功能的方式如下:

<?php
if (!function_exists('array_key_first')) {
    function array_key_first(array $arr) {
        foreach($arr as $key => $unused) {
            return $key;
        }
        return NULL;
    }
}
?>

参见

  • array_key_last() - 获取一个数组的最后一个键值
  • reset() - 将数组的内部指针指向第一个单元


获取一个数组的最后一个键值

  • ? array_key_first
  • array_keys ?
  • PHP Manual
  • 数组 函数
  • 获取一个数组的最后一个键值

array_key_last

(PHP 7 >= 7.3.0, PHP 8)

array_key_last — 获取一个数组的最后一个键值

说明

array_key_last ( array $array ) : mixed

取得指定数组的 array 最后一个键值，不会影响到原数组的内部指针。

参数

array

要操作的数组。

返回值

返回 array 的最后一个键值（如果不为空），否则返回 null。

参见

  • array_key_first() - 获取指定数组的第一个键值
  • end() - 将数组的内部指针指向最后一个单元


返回数组中部分的或所有的键名

  • ? array_key_last
  • array_map ?
  • PHP Manual
  • 数组 函数
  • 返回数组中部分的或所有的键名

array_keys

(PHP 4, PHP 5, PHP 7, PHP 8)

array_keys — 返回数组中部分的或所有的键名

说明

array_keys ( array $array , mixed $search_value = null , bool $strict = false ) : array

array_keys() 返回 input 数组中的数字或者字符串的键名。

如果指定了可选参数 search_value，则只返回该值的键名。否则 input 数组中的所有键名都会被返回。

参数

input

一个数组，包含了要返回的键。

search_value

如果指定了这个参数，只有包含这些值的键才会返回。

strict

判断在搜索的时候是否该使用严格的比较（===）。

返回值

返回 input 里的所有键。

范例

Example #1 array_keys() 例子

<?php
$array = array(0 => 100, "color" => "red");
print_r(array_keys($array));

$array = array("blue", "red", "green", "blue", "blue");
print_r(array_keys($array, "blue"));

$array = array("color" => array("blue", "red", "green"),
               "size"  => array("small", "medium", "large"));
print_r(array_keys($array));
?>

以上例程会输出：

Array
(
    [0] => 0
    [1] => color
)
Array
(
    [0] => 0
    [1] => 3
    [2] => 4
)
Array
(
    [0] => color
    [1] => size
)

参见

  • array_values() - 返回数组中所有的值
  • array_combine() - 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值
  • array_key_exists() - 检查数组里是否有指定的键名或索引
  • array_search() - 在数组中搜索给定的值，如果成功则返回首个相应的键名


为数组的每个元素应用回调函数

  • ? array_keys
  • array_merge_recursive ?
  • PHP Manual
  • 数组 函数
  • 为数组的每个元素应用回调函数

array_map

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

array_map — 为数组的每个元素应用回调函数

说明

array_map ( callable $callback , array $array , array ...$arrays ) : array

array_map()：返回数组，是为 array 每个元素应用 callback函数之后的数组。 array_map() 返回一个 array，数组内容为 array1 的元素按索引顺序为参数调用 callback 后的结果（有更多数组时，还会传入 arrays 的元素）。 callback 函数形参的数量必须匹配 array_map() 实参中数组的数量。

参数

callback

回调函数 callable，应用到每个数组里的每个元素。

多个数组操作合并时，callback 可以设置为 null。 如果只提供了 array 一个数组， array_map() 会返回输入的数组。

array

数组，遍历运行 callback 函数。

arrays

额外的数组列表，每个都遍历运行 callback 函数。

返回值

返回数组，包含 callback 函数处理之后 array (有多个数组时，为 arrays) 对应索引所有元素作为函数的参数。

当仅仅传入一个数组时，返回的数组会保留传入参数的键（key）。 传入多个数组时，返回的数组键是按顺序的 integer。

范例

Example #1 array_map() 例子

<?php
function cube($n)
{
    return ($n * $n * $n);
}

$a = [1, 2, 3, 4, 5];
$b = array_map('cube', $a);
print_r($b);
?>

这使得 $b 成为：

Array
(
    [0] => 1
    [1] => 8
    [2] => 27
    [3] => 64
    [4] => 125
)

Example #2 array_map() 使用匿名函数 (PHP 5.3.0 起)

<?php
$func = function($value) {
    return $value * 2;
};

print_r(array_map($func, range(1, 5)));
?>
Array
(
    [0] => 2
    [1] => 4
    [2] => 6
    [3] => 8
    [4] => 10
)

Example #3 array_map()：使用更多的数组

<?php
function show_Spanish($n, $m)
{
    return "The number {$n} is called {$m} in Spanish";
}

function map_Spanish($n, $m)
{
    return [$n => $m];
}

$a = [1, 2, 3, 4, 5];
$b = ['uno', 'dos', 'tres', 'cuatro', 'cinco'];

$c = array_map('show_Spanish', $a, $b);
print_r($c);

$d = array_map('map_Spanish', $a , $b);
print_r($d);
?>

以上例程会输出：

// printout of $c
Array
(
    [0] => The number 1 is called uno in Spanish
    [1] => The number 2 is called dos in Spanish
    [2] => The number 3 is called tres in Spanish
    [3] => The number 4 is called cuatro in Spanish
    [4] => The number 5 is called cinco in Spanish
)

// printout of $d
Array
(
    [0] => Array
        (
            [1] => uno
        )

    [1] => Array
        (
            [2] => dos
        )

    [2] => Array
        (
            [3] => tres
        )

    [3] => Array
        (
            [4] => cuatro
        )

    [4] => Array
        (
            [5] => cinco
        )

)

传入两个及以上的数组时，它们元素数量将会相同。因为回调函数会并行地处理相互对应的元素。 如果几个数组的元素数量不一致：空元素会扩展短那个数组，直到长度和最长的数组一样。

此函数有个有趣的用法：传入 null 作为回调函数的名称，将创建多维数组（一个数组，内部包含数组。）

Example #4 多个数组的合并操作

<?php
$a = [1, 2, 3, 4, 5];
$b = ['one', 'two', 'three', 'four', 'five'];
$c = ['uno', 'dos', 'tres', 'cuatro', 'cinco'];

$d = array_map(null, $a, $b, $c);
print_r($d);
?>

以上例程会输出：

Array
(
    [0] => Array
        (
            [0] => 1
            [1] => one
            [2] => uno
        )

    [1] => Array
        (
            [0] => 2
            [1] => two
            [2] => dos
        )

    [2] => Array
        (
            [0] => 3
            [1] => three
            [2] => tres
        )

    [3] => Array
        (
            [0] => 4
            [1] => four
            [2] => cuatro
        )

    [4] => Array
        (
            [0] => 5
            [1] => five
            [2] => cinco
        )

)

Example #5 仅有 array1 时，callback 设置为 null

<?php
$array = [1, 2, 3];
var_dump(array_map(null, $array));
?>

以上例程会输出：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

Example #6 array_map() 键（key）是 string

<?php
$arr = array("stringkey" => "value");
function cb1($a) {
    return [$a];
}
function cb2($a, $b) {
    return [$a, $b];
}
var_dump(array_map('cb1', $arr));
var_dump(array_map('cb2', $arr, $arr));
var_dump(array_map(null,  $arr));
var_dump(array_map(null, $arr, $arr));
?>

以上例程会输出：

array(1) {
  ["stringkey"]=>
  array(1) {
    [0]=>
    string(5) "value"
  }
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(5) "value"
    [1]=>
    string(5) "value"
  }
}
array(1) {
  ["stringkey"]=>
  string(5) "value"
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(5) "value"
    [1]=>
    string(5) "value"
  }
}

参见

  • array_filter() - 使用回调函数过滤数组的元素
  • array_reduce() - 用回调函数迭代地将数组简化为单一的值
  • array_walk() - 使用用户自定义函数对数组中的每个元素做回调处理


递归地合并一个或多个数组

  • ? array_map
  • array_merge ?
  • PHP Manual
  • 数组 函数
  • 递归地合并一个或多个数组

array_merge_recursive

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

array_merge_recursive — 递归地合并一个或多个数组

说明

array_merge_recursive ( array $... = ? ) : array

array_merge_recursive() 将一个或多个数组的单元合并起来，一个数组中的值附加在前一个数组的后面。返回作为结果的数组。

如果输入的数组中有相同的字符串键名，则这些值会被合并到一个数组中去，这将递归下去，因此如果一个值本身是一个数组，本函数将按照相应的条目把它合并为另一个数组。需要注意的是，如果数组具有相同的数值键名，后一个值将不会覆盖原来的值，而是附加到后面。

参数

...

数组变量列表，进行递归合并。

返回值

一个结果数组，其中的值合并自附加的参数。如果未传递参数调用，则会返回一个空 array。

更新日志

版本 | 说明
7.4.0 | 允许不传递参数调用，之前的版本中至少需要一个参数。

范例

Example #1 array_merge_recursive() 例子

<?php
$ar1 = array("color" => array("favorite" => "red"), 5);
$ar2 = array(10, "color" => array("favorite" => "green", "blue"));
$result = array_merge_recursive($ar1, $ar2);
print_r($result);
?>

以上例程会输出：

Array
(
    [color] => Array
        (
            [favorite] => Array
                (
                    [0] => red
                    [1] => green
                )

            [0] => blue
        )

    [0] => 5
    [1] => 10
)

参见

  • array_merge() - 合并一个或多个数组
  • array_replace_recursive() - 使用传递的数组递归替换第一个数组的元素


合并一个或多个数组

  • ? array_merge_recursive
  • array_multisort ?
  • PHP Manual
  • 数组 函数
  • 合并一个或多个数组

array_merge

(PHP 4, PHP 5, PHP 7, PHP 8)

array_merge — 合并一个或多个数组

说明

array_merge ( array $... = ? ) : array

将一个或多个数组的单元合并起来，一个数组中的值附加在前一个数组的后面。返回作为结果的数组。

如果输入的数组中有相同的字符串键名，则该键名后面的值将覆盖前一个值。然而，如果数组包含数字键名，后面的值将 不会 覆盖原来的值，而是附加到后面。

如果输入的数组存在以数字作为索引的内容，则这项内容的键名会以连续方式重新索引。

参数

...

要合并的数组。

返回值

返回合并后的结果数组。如果参数为空，则返回空 array。

更新日志

版本 | 说明
7.4.0 | 允许不带参数调用，之前版本至少需要一个参数。

范例

Example #1 array_merge() 示例

<?php
$array1 = array("color" => "red", 2, 4);
$array2 = array("a", "b", "color" => "green", "shape" => "trapezoid", 4);
$result = array_merge($array1, $array2);
print_r($result);
?>

以上例程会输出：

Array
(
    [color] => green
    [0] => 2
    [1] => 4
    [2] => a
    [3] => b
    [shape] => trapezoid
    [4] => 4
)

Example #2 Simple array_merge() 示例

<?php
$array1 = array();
$array2 = array(1 => "data");
$result = array_merge($array1, $array2);
?>

别忘了数字键名将会被重新编号！

Array
(
    [0] => data
)

如果你想完全保留原有数组并只想新的数组附加到后面，可以使用 + 运算符：

<?php
$array1 = array(0 => 'zero_a', 2 => 'two_a', 3 => 'three_a');
$array2 = array(1 => 'one_b', 3 => 'three_b', 4 => 'four_b');
$result = $array1 + $array2;
var_dump($result);
?>

第一个数组的键名将会被保留。在两个数组中存在相同的键名时，第一个数组中的同键名的元素将会被保留，第二个数组中的元素将会被忽略。

array(5) {
  [0]=>
  string(6) "zero_a"
  [2]=>
  string(5) "two_a"
  [3]=>
  string(7) "three_a"
  [1]=>
  string(5) "one_b"
  [4]=>
  string(6) "four_b"
}

Example #3 array_merge() 合并非数组的类型

<?php
$beginning = 'foo';
$end = array(1 => 'bar');
$result = array_merge((array)$beginning, (array)$end);
print_r($result);
?>

以上例程会输出：

    Array
    (
        [0] => foo
        [1] => bar
    )

参见

  • array_merge_recursive() - 递归地合并一个或多个数组
  • array_replace() - 使用传递的数组替换第一个数组的元素
  • array_combine() - 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值
  • 数组操作符


对多个数组或多维数组进行排序

  • ? array_merge
  • array_pad ?
  • PHP Manual
  • 数组 函数
  • 对多个数组或多维数组进行排序

array_multisort

(PHP 4, PHP 5, PHP 7, PHP 8)

array_multisort — 对多个数组或多维数组进行排序

说明

array_multisort ( array &$array1 , mixed $array1_sort_order = SORT_ASC , mixed $array1_sort_flags = SORT_REGULAR , mixed $... = ? ) : bool

array_multisort() 可以用来一次对多个数组进行排序，或者根据某一维或多维对多维数组进行排序。

关联（string）键名保持不变，但数字键名会被重新索引。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array1

要排序的 array。

array1_sort_order

之前 array 参数要排列的顺序。 SORT_ASC 按照上升顺序排序， SORT_DESC 按照下降顺序排序。

此参数可以和 array1_sort_flags 互换，也可以完全删除，默认是 SORT_ASC 。

array1_sort_flags

为 array 参数设定选项：

排序类型标志：

  • SORT_REGULAR - 将项目按照通常方法比较（不修改类型）
  • SORT_NUMERIC - 按照数字大小比较
  • SORT_STRING - 按照字符串比较
  • SORT_LOCALE_STRING - 根据当前的本地化设置，按照字符串比较。 它会使用 locale 信息，可以通过 setlocale() 修改此信息。
  • SORT_NATURAL - 以字符串的"自然排序"，类似 natsort()
  • SORT_FLAG_CASE - 可以组合 (按位或 OR) SORT_STRING 或者 SORT_NATURAL 大小写不敏感的方式排序字符串。

参数可以和 array1_sort_order 交换或者省略，默认情况下是 SORT_REGULAR。

...

可选的选项，可提供更多数组，跟随在 sort order 和 sort flag 之后。 提供的数组和之前的数组要有相同数量的元素。 换言之，排序是按字典顺序排列的。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.4.0 | array1_sort_flags 增加 SORT_NATURAL 和 SORT_FLAG_CASE 选项。
5.3.0 | array1_sort_flags 增加选项 SORT_LOCALE_STRING。

范例

Example #1 多个数组排序

<?php
$ar1 = array(10, 100, 100, 0);
$ar2 = array(1, 3, 2, 4);
array_multisort($ar1, $ar2);

var_dump($ar1);
var_dump($ar2);
?>

这个例子里，排序后，第一个数组会包含 0、 10、 100、 100。 第二个数组会包含 4、1、 2、 3。 第二个数组里的项目对应第一个数组后也进行了排序（100 和 100）。

array(4) {
  [0]=> int(0)
  [1]=> int(10)
  [2]=> int(100)
  [3]=> int(100)
}
array(4) {
  [0]=> int(4)
  [1]=> int(1)
  [2]=> int(2)
  [3]=> int(3)
}

Example #2 排序多维数组

<?php
$ar = array(
       array("10", 11, 100, 100, "a"),
       array(   1,  2, "2",   3,   1)
      );
array_multisort($ar[0], SORT_ASC, SORT_STRING,
                $ar[1], SORT_NUMERIC, SORT_DESC);
var_dump($ar);
?>

本例中在排序后，第一个数组将变成 "10"，100，100，11，"a"（被当作字符串以升序排列）。第二个数组将包含 1, 3, "2", 2, 1（被当作数字以降序排列）。

array(2) {
  [0]=> array(5) {
    [0]=> string(2) "10"
    [1]=> int(100)
    [2]=> int(100)
    [3]=> int(11)
    [4]=> string(1) "a"
  }
  [1]=> array(5) {
    [0]=> int(1)
    [1]=> int(3)
    [2]=> string(1) "2"
    [3]=> int(2)
    [4]=> int(1)
  }
}

Example #3 对数据库结果进行排序

本例中 data 数组中的每个单元表示一个表中的一行。这是典型的数据库记录的数据集合。

例子中的数据如下：

volume | edition
-------+--------
    67 |       2
    86 |       1
    85 |       6
    98 |       2
    86 |       6
    67 |       7

数据全都存放在名为 data 的数组中。这通常是通过循环从数据库取得的结果，例如 mysql_fetch_assoc()。

<?php
$data[] = array('volume' => 67, 'edition' => 2);
$data[] = array('volume' => 86, 'edition' => 1);
$data[] = array('volume' => 85, 'edition' => 6);
$data[] = array('volume' => 98, 'edition' => 2);
$data[] = array('volume' => 86, 'edition' => 6);
$data[] = array('volume' => 67, 'edition' => 7);
?>

本例中将把 volume 降序排列，把 edition 升序排列。

现在有了包含有行的数组，但是 array_multisort() 需要一个包含列的数组，因此用以下代码来取得列，然后排序。

<?php
// 取得列的列表
foreach ($data as $key => $row) {
    $volume[$key]  = $row['volume'];
    $edition[$key] = $row['edition'];
}

// 将数据根据 volume 降序排列，根据 edition 升序排列
// 把 $data 作为最后一个参数，以通用键排序
array_multisort($volume, SORT_DESC, $edition, SORT_ASC, $data);
?>

数据集合现在排好序了，结果如下：

volume | edition
-------+--------
    98 |       2
    86 |       1
    86 |       6
    85 |       6
    67 |       2
    67 |       7

Example #4 不区分大小写字母排序

SORT_STRING 和 SORT_REGULAR 都是区分大小写字母的，大写字母会排在小写字母之前。

要进行不区分大小写的排序，就要按照原数组的小写字母拷贝来排序。

<?php
$array = array('Alpha', 'atomic', 'Beta', 'bank');
$array_lowercase = array_map('strtolower', $array);

array_multisort($array_lowercase, SORT_ASC, SORT_STRING, $array);

print_r($array);
?>

以上例程会输出：

Array
(
    [0] => Alpha
    [1] => atomic
    [2] => bank
    [3] => Beta
)

参见

  • usort() - 使用用户自定义的比较函数对数组中的值进行排序
  • 数组排序函数对比


以指定长度将一个值填充进数组

  • ? array_multisort
  • array_pop ?
  • PHP Manual
  • 数组 函数
  • 以指定长度将一个值填充进数组

array_pad

(PHP 4, PHP 5, PHP 7, PHP 8)

array_pad — 以指定长度将一个值填充进数组

说明

array_pad ( array $array , int $size , mixed $value ) : array

array_pad() 返回 array 的一个拷贝，并用 value 将其填补到 size 指定的长度。如果 size 为正，则填补到数组的右侧，如果为负则从左侧开始填补。如果 size 的绝对值小于或等于 array 数组的长度则没有任何填补。有可能一次最多填补 1048576 个单元。

参数

array

需要被填充的原始数组。

size

新数组的长度。

value

将被填充的值，只有在 array 的现有长度小于 size 的长度时才有效。

返回值

返回 array 用 value 填充到 size 指定的长度之后的一个副本。 如果 size 为正，则填补到数组的右侧，如果为负则从左侧开始填补。 如果 size 的绝对值小于或等于 array 数组的长度则没有任何填补。

范例

Example #1 array_pad() 例子

<?php
$input = array(12, 10, 9);

$result = array_pad($input, 5, 0);
// result is array(12, 10, 9, 0, 0)

$result = array_pad($input, -7, -1);
// result is array(-1, -1, -1, -1, 12, 10, 9)

$result = array_pad($input, 2, "noop");
// not padded
?>

参见

  • array_fill() - 用给定的值填充数组
  • range() - 根据范围创建数组，包含指定的元素


弹出数组最后一个单元（出栈）

  • ? array_pad
  • array_product ?
  • PHP Manual
  • 数组 函数
  • 弹出数组最后一个单元（出栈）

array_pop

(PHP 4, PHP 5, PHP 7, PHP 8)

array_pop — 弹出数组最后一个单元（出栈）

说明

array_pop ( array &$array ) : mixed

array_pop() 弹出并返回 array 数组的最后一个单元，并将数组 array 的长度减一。

Note: 使用此函数后会重置（reset()）array 指针。

参数

array

需要弹出栈的数组。

返回值

返回 array 的最后一个值。如果 array 是空（如果不是一个数组），将会返回 null 。

错误／异常

调用此函数去处理非数组的值，会产生 E_WARNING 级别的错误。

范例

Example #1 array_pop() 例子

<?php
$stack = array("orange", "banana", "apple", "raspberry");
$fruit = array_pop($stack);
print_r($stack);
?>

经过此操作后，$stack 将只有 3 个单元：

Array
(
    [0] => orange
    [1] => banana
    [2] => apple
)

并且 raspberry 将被赋给 $fruit。

参见

  • array_push() - 将一个或多个单元压入数组的末尾（入栈）
  • array_shift() - 将数组开头的单元移出数组
  • array_unshift() - 在数组开头插入一个或多个单元


计算数组中所有值的乘积

  • ? array_pop
  • array_push ?
  • PHP Manual
  • 数组 函数
  • 计算数组中所有值的乘积

array_product

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

array_product — 计算数组中所有值的乘积

说明

array_product ( array $array ) : number

array_product() 以整数或浮点数返回一个数组中所有值的乘积。

参数

array

这个数组。

返回值

以整数或浮点数返回一个数组中所有值的乘积。

更新日志

版本 | 说明
5.3.6 | 空数组现在会产生 1，而之前此函数处理空数组会产生 0。

范例

Example #1 array_product() 例子

<?php

$a = array(2, 4, 6, 8);
echo "product(a) = " . array_product($a) . "\n";
echo "product(array()) = " . array_product(array()) . "\n";

?>

以上例程会输出：

product(a) = 384
product(array()) = 1


将一个或多个单元压入数组的末尾（入栈）

  • ? array_product
  • array_rand ?
  • PHP Manual
  • 数组 函数
  • 将一个或多个单元压入数组的末尾（入栈）

array_push

(PHP 4, PHP 5, PHP 7, PHP 8)

array_push — 将一个或多个单元压入数组的末尾（入栈）

说明

array_push ( array &$array , mixed $value1 , mixed $... = ? ) : int

array_push() 将 array 当成一个栈，并将传入的变量压入 array 的末尾。array 的长度将根据入栈变量的数目增加。和如下效果相同：

<?php
$array[] = $var;
?>
并对每个传入的值重复以上动作。

Note: 如果用 array_push() 来给数组增加一个单元，还不如用 $array[] = ，因为这样没有调用函数的额外负担。

Note: 如果第一个参数不是数组，array_push() 将发出一条警告。这和 $var[] 的行为不同，在 PHP 7.1.0 之前的版本中，后者将会新建一个数组。

参数

array

输入的数组。

value1

要压入 array 末尾的第一个值。

返回值

返回处理之后数组的元素个数。

更新日志

版本 | 说明
7.3.0 | 可以只用一个参数来调用此函数，之前版本中至少需要两个参数。

范例

Example #1 array_push() 例子

<?php
$stack = array("orange", "banana");
array_push($stack, "apple", "raspberry");
print_r($stack);
?>

以上例程会输出：

Array
(
    [0] => orange
    [1] => banana
    [2] => apple
    [3] => raspberry
)

参见

  • array_pop() - 弹出数组最后一个单元（出栈）
  • array_shift() - 将数组开头的单元移出数组
  • array_unshift() - 在数组开头插入一个或多个单元


从数组中随机取出一个或多个随机键

  • ? array_push
  • array_reduce ?
  • PHP Manual
  • 数组 函数
  • 从数组中随机取出一个或多个随机键

array_rand

(PHP 4, PHP 5, PHP 7, PHP 8)

array_rand — 从数组中随机取出一个或多个随机键

说明

array_rand ( array $array , int $num = 1 ) : int|string|array

从数组中取出一个或多个随机的单元，并返回随机条目对应的键（一个或多个）。 它使用了伪随机数产生算法，所以不适合密码学场景。

参数

array

输入的数组。

num

指定要取出的单元数量。

返回值

如果只取出一个，array_rand() 返回随机单元的键名。 否则就返回包含随机键名的数组。 完成后，就可以根据随机的键获取数组的随机值。 如果返回的是包含随机键名的数组，数组单元的顺序按照键名在原数组中的顺序排列。 取出数量如果超过 array 的长度，就会导致 E_WARNING 错误，并返回 NULL。

更新日志

版本 | 说明
7.1.0 | 内部随机化算法已从 libc rand 函数更改为使用 » 梅森旋转算法（Mersenne Twister） 随机数生成器。

范例

Example #1 array_rand() 例子

<?php
$input = array("Neo", "Morpheus", "Trinity", "Cypher", "Tank");
$rand_keys = array_rand($input, 2);
echo $input[$rand_keys[0]] . "\n";
echo $input[$rand_keys[1]] . "\n";
?>

参见

  • shuffle() - 打乱数组


用回调函数迭代地将数组简化为单一的值

  • ? array_rand
  • array_replace_recursive ?
  • PHP Manual
  • 数组 函数
  • 用回调函数迭代地将数组简化为单一的值

array_reduce

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

array_reduce — 用回调函数迭代地将数组简化为单一的值

说明

array_reduce ( array $array , callable $callback , mixed $initial = null ) : mixed

array_reduce() 将回调函数 callback 迭代地作用到 array 数组中的每一个单元中，从而将数组简化为单一的值。

参数

array

输入的 array。

callback
callback ( mixed $carry , mixed $item ) : mixed
carry

携带上次迭代的返回值； 如果本次迭代是第一次，那么这个值是 initial。

item

携带了本次迭代的值。

initial

如果指定了可选参数 initial，该参数将用作处理开始时的初始值，如果数组为空，则会作为最终结果返回。

返回值

返回结果值。

如果数组为空，并且没有指定 initial 参数，array_reduce() 返回 null。

范例

Example #1 array_reduce() 例子

<?php
function sum($carry, $item)
{
    $carry += $item;
    return $carry;
}

function product($carry, $item)
{
    $carry *= $item;
    return $carry;
}

$a = array(1, 2, 3, 4, 5);
$x = array();

var_dump(array_reduce($a, "sum")); // int(15)
var_dump(array_reduce($a, "product", 10)); // int(1200), because: 10*1*2*3*4*5
var_dump(array_reduce($x, "sum", "No data to reduce")); // string(17) "No data to reduce"
?>

参见

  • array_filter() - 使用回调函数过滤数组的元素
  • array_map() - 为数组的每个元素应用回调函数
  • array_unique() - 移除数组中重复的值
  • array_count_values() - 统计数组中所有的值


使用传递的数组递归替换第一个数组的元素

  • ? array_reduce
  • array_replace ?
  • PHP Manual
  • 数组 函数
  • 使用传递的数组递归替换第一个数组的元素

array_replace_recursive

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

array_replace_recursive — 使用传递的数组递归替换第一个数组的元素

说明

array_replace_recursive ( array $array1 , array $... = ? ) : array

array_replace_recursive() 使用后面数组元素的值替换数组 array1 的值。 如果一个键存在于第一个数组同时也存在于第二个数组，它的值将被第二个数组中的值替换。 如果一个键存在于第二个数组，但是不存在于第一个数组，则会在第一个数组中创建这个元素。 如果一个键仅存在于第一个数组，它将保持不变。 如果传递了多个替换数组，它们将被按顺序依次处理，后面的数组将覆盖之前的值。

array_replace_recursive() 是递归的：它将遍历数组并将相同的处理应用到数组的内部值。

如果第一个数组中的值是标量，它的值将被第二个数组中的值替换，它可能是一个标量或者数组。如果第一个数组和第二个数组中的值都是数组，array_replace_recursive() 函数将递归地替换它们各自的值。

参数

array1

替换该数组的值。

...

可选项。包含要提取元素的数组。

返回值

返回一个数组。如果发生错误，将返回 null。

范例

Example #1 array_replace_recursive() 范例

<?php
$base = array('citrus' => array( "orange") , 'berries' => array("blackberry", "raspberry"), );
$replacements = array('citrus' => array('pineapple'), 'berries' => array('blueberry'));

$basket = array_replace_recursive($base, $replacements);
print_r($basket);

$basket = array_replace($base, $replacements);
print_r($basket);
?>

以上例程会输出：

Array
(
    [citrus] => Array
        (
            [0] => pineapple
        )

    [berries] => Array
        (
            [0] => blueberry
            [1] => raspberry
        )

)
Array
(
    [citrus] => Array
        (
            [0] => pineapple
        )

    [berries] => Array
        (
            [0] => blueberry
        )

)

Example #2 array_replace_recursive() 及其递归表现

<?php
$base = array('citrus' => array("orange") , 'berries' => array("blackberry", "raspberry"), 'others' => 'banana' );
$replacements = array('citrus' => 'pineapple', 'berries' => array('blueberry'), 'others' => array('litchis'));
$replacements2 = array('citrus' => array('pineapple'), 'berries' => array('blueberry'), 'others' => 'litchis');

$basket = array_replace_recursive($base, $replacements, $replacements2);
print_r($basket);

?>

以上例程会输出：

Array
(
    [citrus] => Array
        (
            [0] => pineapple
        )

    [berries] => Array
        (
            [0] => blueberry
            [1] => raspberry
        )

    [others] => litchis
)

参见

  • array_replace() - 使用传递的数组替换第一个数组的元素
  • array_merge_recursive() - 递归地合并一个或多个数组


使用传递的数组替换第一个数组的元素

  • ? array_replace_recursive
  • array_reverse ?
  • PHP Manual
  • 数组 函数
  • 使用传递的数组替换第一个数组的元素

array_replace

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

array_replace — 使用传递的数组替换第一个数组的元素

说明

array_replace ( array $array , array $replacements = ? ) : array

array_replace() 函数使用后面数组元素相同 key 的值替换 array 数组的值。如果一个键存在于第一个数组同时也存在于第二个数组，它的值将被第二个数组中的值替换。如果一个键存在于第二个数组，但是不存在于第一个数组，则会在第一个数组中创建这个元素。如果一个键仅存在于第一个数组，它将保持不变。如果传递了多个替换数组，它们将被按顺序依次处理，后面的数组将覆盖之前的值。

array_replace() 是非递归的：它将第一个数组的值进行替换而不管第二个数组中是什么类型。

参数

array

替换该数组的值。

replacements

包含要提取元素的数组。 后面的数组里的值会覆盖前面的值。

返回值

返回一个数组。如果发生错误，将返回 null。

范例

Example #1 array_replace() 范例

<?php
$base = array("orange", "banana", "apple", "raspberry");
$replacements = array(0 => "pineapple", 4 => "cherry");
$replacements2 = array(0 => "grape");

$basket = array_replace($base, $replacements, $replacements2);
print_r($basket);
?>

以上例程会输出：

Array
(
    [0] => grape
    [1] => banana
    [2] => apple
    [3] => raspberry
    [4] => cherry
)

参见

  • array_replace_recursive() - 使用传递的数组递归替换第一个数组的元素
  • array_merge() - 合并一个或多个数组


返回单元顺序相反的数组

  • ? array_replace
  • array_search ?
  • PHP Manual
  • 数组 函数
  • 返回单元顺序相反的数组

array_reverse

(PHP 4, PHP 5, PHP 7, PHP 8)

array_reverse — 返回单元顺序相反的数组

说明

array_reverse ( array $array , bool $preserve_keys = false ) : array

array_reverse() 接受数组 array 作为输入并返回一个单元为相反顺序的新数组。

参数

array

输入的数组。

preserve_keys

如果设置为 true 会保留数字的键。 非数字的键则不受这个设置的影响，总是会被保留。

返回值

返回反转后的数组。

范例

Example #1 array_reverse() 例子

<?php
$input  = array("php", 4.0, array("green", "red"));
$reversed = array_reverse($input);
$preserved = array_reverse($input, true);

print_r($input);
print_r($reversed);
print_r($preserved);
?>

以上例程会输出：

Array
(
    [0] => php
    [1] => 4
    [2] => Array
        (
            [0] => green
            [1] => red
        )

)
Array
(
    [0] => Array
        (
            [0] => green
            [1] => red
        )

    [1] => 4
    [2] => php
)
Array
(
    [2] => Array
        (
            [0] => green
            [1] => red
        )

    [1] => 4
    [0] => php
)

参见

  • array_flip() - 交换数组中的键和值


在数组中搜索给定的值，如果成功则返回首个相应的键名

  • ? array_reverse
  • array_shift ?
  • PHP Manual
  • 数组 函数
  • 在数组中搜索给定的值，如果成功则返回首个相应的键名

array_search

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

array_search — 在数组中搜索给定的值，如果成功则返回首个相应的键名

说明

array_search ( mixed $needle , array $haystack , bool $strict = false ) : mixed

大海捞针，在大海（haystack）中搜索针（ needle 参数）。

参数

needle

搜索的值。

Note:

如果 needle 是字符串，则比较以区分大小写的方式进行。

haystack

这个数组。

strict

如果可选的第三个参数 strict 为 true，则 array_search() 将在 haystack 中检查完全相同的元素。 这意味着同样严格比较 haystack 里 needle 的 类型，并且对象需是同一个实例。

返回值

如果找到了 needle 则返回它的键，否则返回 false。

如果 needle 在 haystack 中出现不止一次，则返回第一个匹配的键。要返回所有匹配值的键，应该用 array_keys() 加上可选参数 search_value 来代替。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
5.3.0 | As with all internal PHP functions as of 5.3.0, array_search() returns null if invalid parameters are passed to it.

范例

Example #1 array_search() 例子

<?php
$array = array(0 => 'blue', 1 => 'red', 2 => 'green', 3 => 'red');

$key = array_search('green', $array); // $key = 2;
$key = array_search('red', $array);   // $key = 1;
?>

参见

  • array_keys() - 返回数组中部分的或所有的键名
  • array_values() - 返回数组中所有的值
  • array_key_exists() - 检查数组里是否有指定的键名或索引
  • in_array() - 检查数组中是否存在某个值


将数组开头的单元移出数组

  • ? array_search
  • array_slice ?
  • PHP Manual
  • 数组 函数
  • 将数组开头的单元移出数组

array_shift

(PHP 4, PHP 5, PHP 7, PHP 8)

array_shift — 将数组开头的单元移出数组

说明

array_shift ( array &$array ) : mixed

array_shift() 将 array 的第一个单元移出并作为结果返回，将 array 的长度减一并将所有其它单元向前移动一位。所有的数字键名将改为从零开始计数，文字键名将不变。

Note: 使用此函数后会重置（reset()）array 指针。

参数

array

输入的数组。

返回值

返回移出的值，如果 array 为 空或不是一个数组则返回 null。

范例

Example #1 array_shift() 例子

<?php
$stack = array("orange", "banana", "apple", "raspberry");
$fruit = array_shift($stack);
print_r($stack);
?>

以上例程会输出：

Array
(
    [0] => banana
    [1] => apple
    [2] => raspberry
)

并且 orange 被赋给了 $fruit。

参见

  • array_unshift() - 在数组开头插入一个或多个单元
  • array_push() - 将一个或多个单元压入数组的末尾（入栈）
  • array_pop() - 弹出数组最后一个单元（出栈）


从数组中取出一段

  • ? array_shift
  • array_splice ?
  • PHP Manual
  • 数组 函数
  • 从数组中取出一段

array_slice

(PHP 4, PHP 5, PHP 7, PHP 8)

array_slice — 从数组中取出一段

说明

array_slice ( array $array , int $offset , int $length = null , bool $preserve_keys = false ) : array

array_slice() 返回根据 offset 和 length 参数所指定的 array 数组中的一段序列。

参数

array

输入的数组。

offset

如果 offset 非负，则序列将从 array 中的此偏移量开始。

如果 offset 为负，则序列将从 array 中距离末端这么远的地方开始。

Note:

参数 offset 标识的是数组中的位置，而不是键。

length

如果给出了 length 并且为正，则序列中将具有这么多的单元。

如果 array 比 length 要短，只会保留有效的数组单元。

如果给出了 length 并且为负，则序列将终止在距离数组末端这么远的地方。

如果省略，则序列将从 offset 开始一直到 array 的末端。

preserve_keys

Note:

注意 array_slice() 默认会重新排序并重置数组的数字索引。你可以通过将 preserve_keys 设为 true 来改变此行为。 无论本参数如何设置，都会保留字符串的键。

返回值

返回其中一段。 如果 offset 参数大于 array 尺寸，就会返回空的 array。

范例

Example #1 array_slice() 例子

<?php
$input = array("a", "b", "c", "d", "e");

$output = array_slice($input, 2);      // returns "c", "d", and "e"
$output = array_slice($input, -2, 1);  // returns "d"
$output = array_slice($input, 0, 3);   // returns "a", "b", and "c"

// note the differences in the array keys
print_r(array_slice($input, 2, -1));
print_r(array_slice($input, 2, -1, true));
?>

以上例程会输出：

Array
(
    [0] => c
    [1] => d
)
Array
(
    [2] => c
    [3] => d
)

Example #2 array_slice() 于索引从 1 开始的 array

<?php
$input = array(1 => "a", "b", "c", "d", "e");
print_r(array_slice($input, 1, 2));
?>

以上例程会输出：

Array
(
    [0] => b
    [1] => c
)

Example #3 array_slice() 与混合类型键的 array

<?php
$ar = array('a'=>'apple', 'b'=>'banana', '42'=>'pear', 'd'=>'orange');
print_r(array_slice($ar, 0, 3));
print_r(array_slice($ar, 0, 3, true));
?>

以上例程会输出：

Array
(
    [a] => apple
    [b] => banana
    [0] => pear
)
Array
(
    [a] => apple
    [b] => banana
    [42] => pear
)

参见

  • array_splice() - 去掉数组中的某一部分并用其它值取代
  • unset() - 释放给定的变量
  • array_chunk() - 将一个数组分割成多个


去掉数组中的某一部分并用其它值取代

  • ? array_slice
  • array_sum ?
  • PHP Manual
  • 数组 函数
  • 去掉数组中的某一部分并用其它值取代

array_splice

(PHP 4, PHP 5, PHP 7, PHP 8)

array_splice — 去掉数组中的某一部分并用其它值取代

说明

array_splice ( array &$input , int $offset , int $length = count($input) , mixed $replacement = array() ) : array

把 input 数组中由 offset 和 length 指定的单元去掉，如果提供了 replacement 参数，则用其中的单元取代。

Note:

input 中的数字键名不被保留。

Note: 如果 replacement 不是数组，会被 类型转换 成数组 (例如： (array) $replacement)。 当传入的 replacement 是个对象或者 null，会导致未知的行为出现。

参数

input

输入的数组。

offset

如果 offset 为正，则从 input 数组中该值指定的偏移量开始移除。

如果 offset 为负，则从 input 末尾倒数该值指定的偏移量开始移除。

length

如果省略 length，则移除数组中从 offset 到结尾的所有部分。

如果指定了 length 并且为正值，则移除这么多单元。

如果指定了 length 并且为负值，则移除部分停止于数组末尾该数量的单元。

如果设置了 length 为零，不会移除单元。

Tip

当给出了 replacement 时要移除从 offset 到数组末尾所有单元时，用 count($input) 作为 length。

replacement

如果给出了 replacement 数组，则被移除的单元被此数组中的单元替代。

如果 offset 和 length 的组合结果是不会移除任何值，则 replacement 数组中的单元将被插入到 offset 指定的位置。

Note:

不保留替换数组 replacement 中的键名。

如果用来替换 replacement 只有一个单元，那么不需要给它加上 array() 或方括号，除非该单元本身就是一个数组、一个对象或者 null。

返回值

返回一个包含有被移除单元的数组。

范例

Example #1 array_splice() 例子

<?php
$input = array("red", "green", "blue", "yellow");
array_splice($input, 2);
var_dump($input);

$input = array("red", "green", "blue", "yellow");
array_splice($input, 1, -1);
var_dump($input);

$input = array("red", "green", "blue", "yellow");
array_splice($input, 1, count($input), "orange");
var_dump($input);

$input = array("red", "green", "blue", "yellow");
array_splice($input, -1, 1, array("black", "maroon"));
var_dump($input);
?>

以上例程会输出：

array(2) {
  [0]=>
  string(3) "red"
  [1]=>
  string(5) "green"
}
array(2) {
  [0]=>
  string(3) "red"
  [1]=>
  string(6) "yellow"
}
array(2) {
  [0]=>
  string(3) "red"
  [1]=>
  string(6) "orange"
}
array(5) {
  [0]=>
  string(3) "red"
  [1]=>
  string(5) "green"
  [2]=>
  string(4) "blue"
  [3]=>
  string(5) "black"
  [4]=>
  string(6) "maroon"
}

Example #2 几个以不同表达式实现相同效果的 array_splice() 例子

以下表达式是相同的：

<?php

// 添加两个新元素到 $input
array_push($input, $x, $y);
array_splice($input, count($input), 0, array($x, $y));

// 移除 $input 中的最后一个元素
array_pop($input);
array_splice($input, -1);

// 移除  $input 中第一个元素
array_shift($input);
array_splice($input, 0, 1);

// 在 $input 的开头插入一个元素
array_unshift($input, $x, $y);
array_splice($input, 0, 0, array($x, $y));

// 在 $input  的索引  $x 处替换值
$input[$x] = $y; // 对于键名和偏移量等值的数组
array_splice($input, $x, 1, $y);
?>

参见

  • array_merge() - 合并一个或多个数组
  • array_slice() - 从数组中取出一段
  • unset() - 释放给定的变量


对数组中所有值求和

  • ? array_splice
  • array_udiff_assoc ?
  • PHP Manual
  • 数组 函数
  • 对数组中所有值求和

array_sum

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

array_sum — 对数组中所有值求和

说明

array_sum ( array $array ) : number

array_sum() 将数组中的所有值相加，并返回结果。

参数

array

输入的数组。

返回值

所有值的和以整数或浮点数的结果返回，array 为空时则返回 0。

范例

Example #1 array_sum() 例子

<?php
$a = array(2, 4, 6, 8);
echo "sum(a) = " . array_sum($a) . "\n";

$b = array("a" => 1.2, "b" => 2.3, "c" => 3.4);
echo "sum(b) = " . array_sum($b) . "\n";
?>

以上例程会输出：

sum(a) = 20
sum(b) = 6.9


带索引检查计算数组的差集，用回调函数比较数据

  • ? array_sum
  • array_udiff_uassoc ?
  • PHP Manual
  • 数组 函数
  • 带索引检查计算数组的差集，用回调函数比较数据

array_udiff_assoc

(PHP 5, PHP 7, PHP 8)

array_udiff_assoc — 带索引检查计算数组的差集，用回调函数比较数据

说明

array_udiff_assoc ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func ) : array

此比较是通过用户提供的回调函数来进行的。如果认为第一个参数小于，等于，或大于第二个参数时必须分别返回一个小于零，等于零，或大于零的整数。

Note: 注意本函数只检查了多维数组中的一维。当然，可以用 array_udiff_assoc($array1[0], $array2[0], "some_comparison_func"); 来检查更深的维度。

参数

array1

第一个数组。

array2

第二个数组。

value_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

array_udiff_assoc() 返回一个数组，该数组包括了所有在 array1 中但是不在任何其它参数数组中的值。注意和 array_diff() 与 array_udiff() 不同的是键名也用于比较。数组数据的比较是用用户提供的回调函数进行的。在此方面和 array_diff_assoc() 的行为正好相反，后者是用内部函数进行比较的。

范例

Example #1 array_udiff_assoc() 例子

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    static function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }
}

$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_assoc($a, $b, array("cr", "comp_func_cr"));
print_r($result);
?>

以上例程会输出：

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

上例中可以看到键值对 "1" => new cr(4) 同时出现在两个数组中因此不在本函数的输出中。

参见

  • array_diff() - 计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_diff_uassoc() - 用用户提供的回调函数做索引检查来计算数组的差集
  • array_udiff() - 用回调函数比较数据来计算数组的差集
  • array_udiff_uassoc() - 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_uintersect() - 计算数组的交集，用回调函数比较数据
  • array_uintersect_assoc() - 带索引检查计算数组的交集，用回调函数比较数据
  • array_uintersect_uassoc() - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引


带索引检查计算数组的差集，用回调函数比较数据和索引

  • ? array_udiff_assoc
  • array_udiff ?
  • PHP Manual
  • 数组 函数
  • 带索引检查计算数组的差集，用回调函数比较数据和索引

array_udiff_uassoc

(PHP 5, PHP 7, PHP 8)

array_udiff_uassoc — 带索引检查计算数组的差集，用回调函数比较数据和索引

说明

array_udiff_uassoc ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func , callable $key_compare_func ) : array

array_udiff_uassoc() 返回一个数组，该数组包括了所有在 array1 中但是不在任何其它参数数组中的值。

注意和 array_diff() 与 array_udiff() 不同的是键名也用于比较。

参数

array1

第一个数组。

array2

第二个数组。

value_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
key_compare_func

对键名（索引）的检查也是由回调函数 key_compare_func 进行的。这和 array_udiff_assoc() 的行为不同，后者是用内部函数比较索引的。

返回值

Returns an array containing all the values from array1 that are not present in any of the other arguments.

范例

Example #1 array_udiff_uassoc() 例子

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    static function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }

    static function comp_func_key($a, $b)
    {
        if ($a === $b) return 0;
        return ($a > $b)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_uassoc($a, $b, array("cr", "comp_func_cr"), array("cr", "comp_func_key"));
print_r($result);
?>

以上例程会输出：

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

在上例中键值对 "1" => new cr(4) 同时出现在两个数组中，因此不在本函数的输出中。要记住必须提供两个回调函数。

注释

Note: 注意本函数只检查了多维数组中的一维。当然，可以用 array_udiff_uassoc($array1[0], $array2[0], "data_compare_func", "key_compare_func"); 来检查更深的维度。

参见

  • array_diff() - 计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_udiff() - 用回调函数比较数据来计算数组的差集
  • array_udiff_assoc() - 带索引检查计算数组的差集，用回调函数比较数据
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_uintersect() - 计算数组的交集，用回调函数比较数据
  • array_uintersect_assoc() - 带索引检查计算数组的交集，用回调函数比较数据
  • array_uintersect_uassoc() - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引


用回调函数比较数据来计算数组的差集

  • ? array_udiff_uassoc
  • array_uintersect_assoc ?
  • PHP Manual
  • 数组 函数
  • 用回调函数比较数据来计算数组的差集

array_udiff

(PHP 5, PHP 7, PHP 8)

array_udiff — 用回调函数比较数据来计算数组的差集

说明

array_udiff ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func ) : array

使用回调函数比较数据，计算数组的不同之处。和 array_diff() 不同的是，前者使用内置函数进行数据比较。

参数

array1

第一个数组。

array2

第二个数组。

value_compare_func

回调对照函数。

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

返回 array1 里没有出现在其他参数里的所有值。

范例

Example #1 array_udiff() 使用 stdClass 对象的例子

<?php
// Arrays to compare
$array1 = array(new stdclass, new stdclass,
                new stdclass, new stdclass,
               );

$array2 = array(
                new stdclass, new stdclass,
               );

// Set some properties for each object
$array1[0]->width = 11; $array1[0]->height = 3;
$array1[1]->width = 7;  $array1[1]->height = 1;
$array1[2]->width = 2;  $array1[2]->height = 9;
$array1[3]->width = 5;  $array1[3]->height = 7;

$array2[0]->width = 7;  $array2[0]->height = 5;
$array2[1]->width = 9;  $array2[1]->height = 2;

function compare_by_area($a, $b) {
    $areaA = $a->width * $a->height;
    $areaB = $b->width * $b->height;

    if ($areaA < $areaB) {
        return -1;
    } elseif ($areaA > $areaB) {
        return 1;
    } else {
        return 0;
    }
}

print_r(array_udiff($array1, $array2, 'compare_by_area'));
?>

以上例程会输出：

Array
(
    [0] => stdClass Object
        (
            [width] => 11
            [height] => 3
        )

    [1] => stdClass Object
        (
            [width] => 7
            [height] => 1
        )

)

Example #2 array_udiff() 使用 DateTime 对象的例子

<?php
class MyCalendar {
    public $free = array();
    public $booked = array();

    public function __construct($week = 'now') {
        $start = new DateTime($week);
        $start->modify('Monday this week midnight');
        $end = clone $start;
        $end->modify('Friday this week midnight');
        $interval = new DateInterval('P1D');
        foreach (new DatePeriod($start, $interval, $end) as $freeTime) {
            $this->free[] = $freeTime;
        }
    }

    public function bookAppointment(DateTime $date, $note) {
        $this->booked[] = array('date' => $date->modify('midnight'), 'note' => $note);
    }

    public function checkAvailability() {
        return array_udiff($this->free, $this->booked, array($this, 'customCompare'));
    }

    public function customCompare($free, $booked) {
        if (is_array($free)) $a = $free['date'];
        else $a = $free;
        if (is_array($booked)) $b = $booked['date'];
        else $b = $booked;
        if ($a == $b) {
            return 0;
        } elseif ($a > $b) {
            return 1;
        } else {
            return -1;
        }
    }
}

// Create a calendar for weekly appointments
$myCalendar = new MyCalendar;

// Book some appointments for this week
$myCalendar->bookAppointment(new DateTime('Monday this week'), "Cleaning GoogleGuy's apartment.");
$myCalendar->bookAppointment(new DateTime('Wednesday this week'), "Going on a snowboarding trip.");
$myCalendar->bookAppointment(new DateTime('Friday this week'), "Fixing buggy code.");

// Check availability of days by comparing $booked dates against $free dates
echo "I'm available on the following days this week...\n\n";
foreach ($myCalendar->checkAvailability() as $free) {
    echo $free->format('l'), "\n";
}
echo "\n\n";
echo "I'm busy on the following days this week...\n\n";
foreach ($myCalendar->booked as $booked) {
    echo $booked['date']->format('l'), ": ", $booked['note'], "\n";
}
?>

以上例程会输出：

I'm available on the following days this week...

Tuesday
Thursday

I'm busy on the following days this week...

Monday: Cleaning GoogleGuy's apartment.
Wednesday: Going on a snowboarding trip.
Friday: Fixing buggy code.

注释

Note: 注意本函数只检查了多维数组中的一维。当然，可以用 array_udiff($array1[0], $array2[0], "data_compare_func"); 来检查更深的维度。

参见

  • array_diff() - 计算数组的差集
  • array_diff_assoc() - 带索引检查计算数组的差集
  • array_diff_uassoc() - 用用户提供的回调函数做索引检查来计算数组的差集
  • array_udiff_assoc() - 带索引检查计算数组的差集，用回调函数比较数据
  • array_udiff_uassoc() - 带索引检查计算数组的差集，用回调函数比较数据和索引
  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_uintersect() - 计算数组的交集，用回调函数比较数据
  • array_uintersect_assoc() - 带索引检查计算数组的交集，用回调函数比较数据
  • array_uintersect_uassoc() - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引


带索引检查计算数组的交集，用回调函数比较数据

  • ? array_udiff
  • array_uintersect_uassoc ?
  • PHP Manual
  • 数组 函数
  • 带索引检查计算数组的交集，用回调函数比较数据

array_uintersect_assoc

(PHP 5, PHP 7, PHP 8)

array_uintersect_assoc — 带索引检查计算数组的交集，用回调函数比较数据

说明

array_uintersect_assoc ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func ) : array

此比较是通过用户提供的回调函数来进行的。如果认为第一个参数小于，等于，或大于第二个参数时必须分别返回一个小于零，等于零，或大于零的整数。

注意和 array_uintersect() 不同的是键名也要比较。数据是用回调函数比较的。

参数

array1

第一个数组。

array2

第二个数组。

value_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。

范例

Example #1 array_uintersect_assoc() 例子

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_uintersect_assoc($array1, $array2, "strcasecmp"));
?>

以上例程会输出：

Array
(
    [a] => green
)

参见

  • array_uintersect() - 计算数组的交集，用回调函数比较数据
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_intersect_uassoc() - 带索引检查计算数组的交集，用回调函数比较索引
  • array_uintersect_uassoc() - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引


带索引检查计算数组的交集，用单独的回调函数比较数据和索引

  • ? array_uintersect_assoc
  • array_uintersect ?
  • PHP Manual
  • 数组 函数
  • 带索引检查计算数组的交集，用单独的回调函数比较数据和索引

array_uintersect_uassoc

(PHP 5, PHP 7, PHP 8)

array_uintersect_uassoc — 带索引检查计算数组的交集，用单独的回调函数比较数据和索引

说明

array_uintersect_uassoc ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func , callable $key_compare_func ) : array

通过额外的索引检查、回调函数比较数据和索引来返回多个数组的交集。

参数

array1

第一个数组。

array2

第二个数组。

value_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
key_compare_func

键名比较的回调函数。

返回值

返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。

范例

Example #1 array_uintersect_uassoc() 例子

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_uintersect_uassoc($array1, $array2, "strcasecmp", "strcasecmp"));
?>

以上例程会输出：

Array
(
    [a] => green
    [b] => brown
)

参见

  • array_uintersect() - 计算数组的交集，用回调函数比较数据
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_intersect_uassoc() - 带索引检查计算数组的交集，用回调函数比较索引
  • array_uintersect_assoc() - 带索引检查计算数组的交集，用回调函数比较数据


计算数组的交集，用回调函数比较数据

  • ? array_uintersect_uassoc
  • array_unique ?
  • PHP Manual
  • 数组 函数
  • 计算数组的交集，用回调函数比较数据

array_uintersect

(PHP 5, PHP 7, PHP 8)

array_uintersect — 计算数组的交集，用回调函数比较数据

说明

array_uintersect ( array $array1 , array $array2 , array $... = ? , callable $value_compare_func ) : array

array_uintersect() 返回一个数组，该数组包含了所有在 array1 中也同时出现在所有其它参数数组中的值。数据比较是用回调函数进行的。 此比较是通过用户提供的回调函数来进行的。如果认为第一个参数小于，等于，或大于第二个参数时必须分别返回一个小于零，等于零，或大于零的整数。

参数

array1

第一个数组。

array2

第二个数组。

value_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

Returns an array containing all the values of array1 that are present in all the arguments.

范例

Example #1 array_uintersect() 例子

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_uintersect($array1, $array2, "strcasecmp"));
?>

以上例程会输出：

Array
(
    [a] => green
    [b] => brown
    [0] => red
)

参见

  • array_intersect() - 计算数组的交集
  • array_intersect_assoc() - 带索引检查计算数组的交集
  • array_uintersect_assoc() - 带索引检查计算数组的交集，用回调函数比较数据
  • array_uintersect_uassoc() - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引


移除数组中重复的值

  • ? array_uintersect
  • array_unshift ?
  • PHP Manual
  • 数组 函数
  • 移除数组中重复的值

array_unique

(PHP 4 >= 4.0.1, PHP 5, PHP 7, PHP 8)

array_unique — 移除数组中重复的值

说明

array_unique ( array $array , int $sort_flags = SORT_STRING ) : array

array_unique() 接受 array 作为输入并返回没有重复值的新数组。

注意键名保留不变。array_unique() 先将值作为字符串排序，然后对每个值只保留第一个遇到的键名，接着忽略所有后面的键名。这并不意味着在未排序的 array 中同一个值的第一个出现的键名会被保留。

Note: 当且仅当 (string) $elem1 === (string) $elem2 时两个单元被认为相同。 例如，字符串表达一样时，会使用首个元素。

参数

array

输入的数组。

sort_flags

第二个可选参数sort_flags 可用于修改排序行为：

排序类型标记：

  • SORT_REGULAR - 按照通常方法比较（不修改类型）
  • SORT_NUMERIC - 按照数字形式比较
  • SORT_STRING - 按照字符串形式比较
  • SORT_LOCALE_STRING - 根据当前的本地化设置，按照字符串比较。

返回值

返回过滤后的数组。

更新日志

版本 | 说明
5.2.10 | 修改回 sort_flags 的默认值为 SORT_STRING。
5.2.9 | 增加可选选项sort_flags，默认值 SORT_REGULAR。 5.2.9 之前，此函数内部使用 SORT_STRING 排序。

范例

Example #1 array_unique() 例子

<?php
$input = array("a" => "green", "red", "b" => "green", "blue", "red");
$result = array_unique($input);
print_r($result);
?>

以上例程会输出：

Array
(
    [a] => green
    [0] => red
    [1] => blue
)

Example #2 array_unique() 和类型

<?php
$input = array(4, "4", "3", 4, 3, "3");
$result = array_unique($input);
var_dump($result);
?>

以上例程会输出：

array(2) {
  [0] => int(4)
  [2] => string(1) "3"
}

参见

  • array_count_values() - 统计数组中所有的值

注释

Note: 注意， array_unique() 不能应用于多维数组。


在数组开头插入一个或多个单元

  • ? array_unique
  • array_values ?
  • PHP Manual
  • 数组 函数
  • 在数组开头插入一个或多个单元

array_unshift

(PHP 4, PHP 5, PHP 7, PHP 8)

array_unshift — 在数组开头插入一个或多个单元

说明

array_unshift ( array &$array , mixed ...$values ) : int

array_unshift() 将传入的单元插入到 array 数组的开头。注意单元是作为整体被插入的，因此传入单元将保持同样的顺序。所有的数值键名将修改为从零开始重新计数，所有的文字键名保持不变。

参数

array

输入的数组。

values

插入的变量。

返回值

返回 array 数组新的单元数目。

更新日志

版本 | 说明
7.3.0 | 现在可以只用一个参数来调用，之前至少需要两个参数。

范例

Example #1 array_unshift() 例子

<?php
$queue = array("orange", "banana");
array_unshift($queue, "apple", "raspberry");
print_r($queue);
?>

以上例程会输出：

Array
(
    [0] => apple
    [1] => raspberry
    [2] => orange
    [3] => banana
)

参见

  • array_shift() - 将数组开头的单元移出数组
  • array_push() - 将一个或多个单元压入数组的末尾（入栈）
  • array_pop() - 弹出数组最后一个单元（出栈）


返回数组中所有的值

  • ? array_unshift
  • array_walk_recursive ?
  • PHP Manual
  • 数组 函数
  • 返回数组中所有的值

array_values

(PHP 4, PHP 5, PHP 7, PHP 8)

array_values — 返回数组中所有的值

说明

array_values ( array $array ) : array

array_values() 返回 input 数组中所有的值并给其建立数字索引。

参数

array

数组。

返回值

返回含所有值的索引数组。

范例

Example #1 array_values() 例子

<?php
$array = array("size" => "XL", "color" => "gold");
print_r(array_values($array));
?>

以上例程会输出：

Array
(
    [0] => XL
    [1] => gold
)

参见

  • array_keys() - 返回数组中部分的或所有的键名
  • array_combine() - 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值


对数组中的每个成员递归地应用用户函数

  • ? array_values
  • array_walk ?
  • PHP Manual
  • 数组 函数
  • 对数组中的每个成员递归地应用用户函数

array_walk_recursive

(PHP 5, PHP 7, PHP 8)

array_walk_recursive — 对数组中的每个成员递归地应用用户函数

说明

array_walk_recursive ( array &$array , callable $callback , mixed $userdata = null ) : bool

将用户自定义函数 callback 应用到 array 数组中的每个单元。本函数会递归到更深层的数组中去。

参数

array

输入的数组。

callback

典型情况下 callback 接受两个参数。array 参数的值作为第一个，键名作为第二个。

Note:

如果 callback 需要直接作用于数组中的值，则给 callback 的第一个参数指定为引用。这样任何对这些单元的改变也将会改变原始数组本身。

userdata

如果提供了可选参数 userdata，将被作为第三个参数传递给 callback。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 array_walk_recursive() 例子

<?php
$sweet = array('a' => 'apple', 'b' => 'banana');
$fruits = array('sweet' => $sweet, 'sour' => 'lemon');

function test_print($item, $key)
{
    echo "$key holds $item\n";
}

array_walk_recursive($fruits, 'test_print');
?>

以上例程会输出：

a holds apple
b holds banana
sour holds lemon

注意上例中的键 'sweet' 并没有显示出来。任何其值为 array 的键都不会被传递到回调函数中去。

参见

  • array_walk() - 使用用户自定义函数对数组中的每个元素做回调处理


使用用户自定义函数对数组中的每个元素做回调处理

  • ? array_walk_recursive
  • array ?
  • PHP Manual
  • 数组 函数
  • 使用用户自定义函数对数组中的每个元素做回调处理

array_walk

(PHP 4, PHP 5, PHP 7, PHP 8)

array_walk — 使用用户自定义函数对数组中的每个元素做回调处理

说明

array_walk ( array &$array , callable $callback , mixed $userdata = null ) : bool

将用户自定义函数 funcname 应用到 array 数组中的每个单元。

array_walk() 不会受到 array 内部数组指针的影响。array_walk() 会遍历整个数组而不管指针的位置。

参数

array

输入的数组。

callback

典型情况下 callback 接受两个参数。array 参数的值作为第一个，键名作为第二个。

Note:

如果 callback 需要直接作用于数组中的值，则给 callback 的第一个参数指定为引用。这样任何对这些单元的改变也将会改变原始数组本身。

Note:

参数数量超过预期，传入内置函数 (例如 strtolower())， 将抛出警告，所以不适合当做 funcname。

只有 array 的值才可以被改变，用户不应在回调函数中改变该数组本身的结构。例如增加/删除单元，unset 单元等等。如果 array_walk() 作用的数组改变了，则此函数的的行为未经定义，且不可预期。

userdata

如果提供了可选参数 userdata，将被作为第三个参数传递给 callback funcname。

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

如果 callback 函数需要的参数比给出的多，则每次 array_walk() 调用 callback 时都会产生一个 E_WARNING 级的错误。

范例

Example #1 array_walk() 例子

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");

function test_alter(&$item1, $key, $prefix)
{
    $item1 = "$prefix: $item1";
}

function test_print($item2, $key)
{
    echo "$key. $item2<br />\n";
}

echo "Before ...:\n";
array_walk($fruits, 'test_print');

array_walk($fruits, 'test_alter', 'fruit');
echo "... and after:\n";

array_walk($fruits, 'test_print');
?>

以上例程会输出：

Before ...:
d. lemon
a. orange
b. banana
c. apple
... and after:
d. fruit: lemon
a. fruit: orange
b. fruit: banana
c. fruit: apple

参见

  • array_walk_recursive() - 对数组中的每个成员递归地应用用户函数
  • iterator_apply() - 为迭代器中每个元素调用一个用户自定义函数
  • list() - 把数组中的值赋给一组变量
  • each() - 返回数组中当前的键／值对并将数组指针向前移动一步
  • call_user_func_array() - 调用回调函数，并把一个数组参数作为回调函数的参数
  • array_map() - 为数组的每个元素应用回调函数
  • foreach


新建一个数组

  • ? array_walk
  • arsort ?
  • PHP Manual
  • 数组 函数
  • 新建一个数组

array

(PHP 4, PHP 5, PHP 7, PHP 8)

array — 新建一个数组

说明

array ( mixed $... = ? ) : array

创建一个数组。关于数组是什么的信息请阅读数组一节。

参数

...

语法"index => values"，用逗号分开，定义了索引和值。索引可以是字符串或数字。如果省略了索引，会自动产生从 0 开始的整数索引。如果索引是整数，则下一个产生的索引将是目前最大的整数索引 + 1。注意如果定义了两个完全一样的索引，则后面一个会覆盖前一个。

在最后一个定义的数组项目之后加一个逗号虽然不常见，却是合法的语法。

返回值

返回根据参数建立的数组。参数可以用 => 运算符给出索引。关于数组是什么的信息请阅读数组一节。

范例

下面的例子演示了怎样建立一个二维数组，怎样给相应的数组指定键名，以及怎样在普通数组中略过和继续数字索引。

Example #1 array() 例子

<?php
$fruits = array (
    "fruits"  => array("a" => "orange", "b" => "banana", "c" => "apple"),
    "numbers" => array(1, 2, 3, 4, 5, 6),
    "holes"   => array("first", 5 => "second", "third")
);
?>

Example #2 array() 的自动索引

<?php
$array = array(1, 1, 1, 1,  1, 8 => 1,  4 => 1, 19, 3 => 13);
print_r($array);
?>

以上例程会输出：

Array
(
    [0] => 1
    [1] => 1
    [2] => 1
    [3] => 13
    [4] => 1
    [8] => 1
    [9] => 19
)

注意索引 3 被定义了两次，保留了最后的值 13。索引 4 在 索引 8 之后定义，下一个自动生成的索引（值为 19 那个）为 9，因为最大的索引是 8。

本例建立了从 1 开始的数组。

Example #3 从 1 开始索引的 array()

<?php
$firstquarter = array(1 => 'January', 'February', 'March');
print_r($firstquarter);
?>

以上例程会输出：

Array
(
    [1] => January
    [2] => February
    [3] => March
)

在 Perl 中，可以访问在双引号内的数组的值。但在 PHP 中需要将数组用花括号括起来。

Example #4 访问双引号内的数组

<?php

$foo = array('bar' => 'baz');
echo "Hello {$foo['bar']}!"; // Hello baz!

?>

注释

Note:

array() 是一个语言结构，用于字面上表示数组，不是常规的函数。

参见

  • array_pad() - 以指定长度将一个值填充进数组
  • list() - 把数组中的值赋给一组变量
  • count() - 计算数组中的单元数目，或对象中的属性个数
  • range() - 根据范围创建数组，包含指定的元素
  • foreach
  • The array type


对数组进行逆向排序并保持索引关系

  • ? array
  • asort ?
  • PHP Manual
  • 数组 函数
  • 对数组进行逆向排序并保持索引关系

arsort

(PHP 4, PHP 5, PHP 7, PHP 8)

arsort — 对数组进行逆向排序并保持索引关系

说明

arsort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

本函数对数组进行排序，数组的索引保持和单元的关联。

主要用于对那些单元顺序很重要的结合数组进行排序。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

输入的数组。

sort_flags

可以用可选的参数 sort_flags 改变排序的行为，详情见 sort()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 arsort() 例子

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
arsort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

以上例程会输出：

a = orange
d = lemon
b = banana
c = apple

fruits 被按照字母顺序逆向排序，并且单元的索引关系不变。

参见

  • asort() - 对数组进行排序并保持索引关系
  • 数组排序函数对比


对数组进行排序并保持索引关系

  • ? arsort
  • compact ?
  • PHP Manual
  • 数组 函数
  • 对数组进行排序并保持索引关系

asort

(PHP 4, PHP 5, PHP 7, PHP 8)

asort — 对数组进行排序并保持索引关系

说明

asort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

本函数对数组进行排序，数组的索引保持和单元的关联。主要用于对那些单元顺序很重要的结合数组进行排序。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

输入的数组。

sort_flags

可以用可选的参数 sort_flags 改变排序的行为，详情见 sort()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 asort() 例子

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
asort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

以上例程会输出：

c = apple
b = banana
d = lemon
a = orange

fruits 被按照字母顺序排序，并且单元的索引关系不变。

参见

  • arsort() - 对数组进行逆向排序并保持索引关系
  • 数组排序函数对比


建立一个数组，包括变量名和它们的值

  • ? asort
  • count ?
  • PHP Manual
  • 数组 函数
  • 建立一个数组，包括变量名和它们的值

compact

(PHP 4, PHP 5, PHP 7, PHP 8)

compact — 建立一个数组，包括变量名和它们的值

说明

compact ( mixed $var_name , mixed ...$var_names ) : array

创建一个包含变量与其值的数组。

对每个参数，compact() 在当前的符号表中查找该变量名并将它添加到输出的数组中，变量名成为键名而变量的内容成为该键的值。简单说，它做的事和 extract() 正好相反。返回将所有变量添加进去后的数组。

Note:

在 PHP 7.3 之前版本，未设置的字符串会被静默忽略。

参数

var_name
var_names

compact() 接受可变的参数数目。每个参数可以是一个包括变量名的字符串或者是一个包含变量名的数组，该数组中还可以包含其它单元内容为变量名的数组， compact() 可以递归处理。

返回值

返回输出的数组，包含了添加的所有变量。

错误／异常

如果字符串指向的变量未定义，compact() 会产生 E_NOTICE 级错误。

更新日志

版本 | 说明
7.3.0 | 现在，如果字符串指向的变量未定义，compact() 会产生 E_NOTICE 级错误。 在此之前，此类问题会静默忽略掉。

范例

Example #1 compact() 例子

<?php
$city  = "San Francisco";
$state = "CA";
$event = "SIGGRAPH";

$location_vars = array("city", "state");

$result = compact("event", $location_vars);
print_r($result);
?>

以上例程会输出：

Array
(
    [event] => SIGGRAPH
    [city] => San Francisco
    [state] => CA
)

注释

Note: Gotcha

因为可变变量也许不能在函数内部用于 PHP 的超全局数组，此时不能将超全局数组传递入 compact() 中。

参见

  • extract() - 从数组中将变量导入到当前的符号表


计算数组中的单元数目，或对象中的属性个数

  • ? compact
  • current ?
  • PHP Manual
  • 数组 函数
  • 计算数组中的单元数目，或对象中的属性个数

count

(PHP 4, PHP 5, PHP 7, PHP 8)

count — 计算数组中的单元数目，或对象中的属性个数

说明

count ( mixed $array_or_countable , int $mode = COUNT_NORMAL ) : int

统计出数组里的所有元素的数量，或者对象里的东西。

对于对象，如果安装了 SPL，可以通过实现 Countable 接口对 count()挂钩（hook） 。该接口只有一个方法 Countable::count()，此方法为 count() 函数返回值。

关于 PHP 中如何实现和使用数组可以参考手册中数组章节中的详细描述。

参数

array_or_countable

数组或者 Countable 对象。

mode

如果可选的 mode 参数设为 COUNT_RECURSIVE（或 1），count() 将递归地对数组计数。对计算多维数组的所有单元尤其有用。

Caution

count() 能检测递归来避免无限循环，但每次出现时会产生 E_WARNING 错误 （如果 array 不止一次包含了自身）并返回大于预期的统计数字。

返回值

返回 array_or_countable 中的单元数目。 如果参数既不是数组，也不是实现 Countable 接口的对象，将返回 1。 有个例外：如果 array_or_countable 是 null 则结果是 0。

范例

Example #1 count() 例子

<?php
$a[0] = 1;
$a[1] = 3;
$a[2] = 5;
var_dump(count($a));

$b[0]  = 7;
$b[5]  = 9;
$b[10] = 11;
var_dump(count($b));

var_dump(count(null));

var_dump(count(false));
?>

以上例程会输出：

int(3)
int(3)

Warning: count(): Parameter must be an array or an object that implements Countable in ... on line 12 // PHP 7.2 起
int(0)

Warning: count(): Parameter must be an array or an object that implements Countable in ... on line 14 // PHP 7.2 起
int(1)

Example #2 递归 count() 例子

<?php
$food = array('fruits' => array('orange', 'banana', 'apple'),
              'veggie' => array('carrot', 'collard', 'pea'));

// recursive count
echo count($food, COUNT_RECURSIVE); // output 8

// normal count
echo count($food); // output 2

?>

更新日志

版本 | 说明
7.2.0 | 当无效的 countable 类型传递给 array_or_countable 参数时，count() 会产生警告。

参见

  • is_array() - 检测变量是否是数组
  • isset() - 检测变量是否已设置并且非 null
  • empty() - 检查一个变量是否为空
  • strlen() - 获取字符串长度
  • is_countable() - Verify that the contents of a variable is a countable value


返回数组中的当前值

  • ? count
  • each ?
  • PHP Manual
  • 数组 函数
  • 返回数组中的当前值

current

(PHP 4, PHP 5, PHP 7, PHP 8)

current — 返回数组中的当前值

说明

current ( array|object $array ) : mixed

每个数组中都有一个内部的指针指向它"当前的"单元，初始化时会指向该数组中的第一个值。

参数

array

要操作的数组。

返回值

current() 函数返回当前被内部指针指向的数组单元的值，并不移动指针。如果内部指针指向超出了单元列表的末端，current() 将返回 false。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

更新日志

版本 | 说明
7.0.0 | array 参数始终通过赋值来传递。之前的版本中，默认通过引用来传值。

范例

Example #1 current() 函数使用示例

<?php
$transport = array('foot', 'bike', 'car', 'plane');
$mode = current($transport); // $mode = 'foot';
$mode = next($transport);    // $mode = 'bike';
$mode = current($transport); // $mode = 'bike';
$mode = prev($transport);    // $mode = 'foot';
$mode = end($transport);     // $mode = 'plane';
$mode = current($transport); // $mode = 'plane';

$arr = array();
var_dump(current($arr)); // bool(false)

$arr = array(array());
var_dump(current($arr)); // array(0) { }
?>

注释

Note: 在一个空数组上使用 current() 函数，和在一个内部指针指向单元末端以外的数组上使用此函数，结果是相同的，同样都会返回 bool false。如果希望正确遍历一个包含 false 的数组，请参阅 foreach() 函数。 如果仍然希望使用 current() 来判断数组单元真实的值，应该同时使用 key() 和 current() 来检查当前元素是否为 null。

参见

  • end() - 将数组的内部指针指向最后一个单元
  • key() - 从关联数组中取得键名
  • each() - 返回数组中当前的键／值对并将数组指针向前移动一步
  • prev() - 将数组的内部指针倒回一位
  • reset() - 将数组的内部指针指向第一个单元
  • next() - 将数组中的内部指针向前移动一位


返回数组中当前的键／值对并将数组指针向前移动一步

  • ? current
  • end ?
  • PHP Manual
  • 数组 函数
  • 返回数组中当前的键／值对并将数组指针向前移动一步

each

(PHP 4, PHP 5, PHP 7)

each — 返回数组中当前的键／值对并将数组指针向前移动一步

Warning

本函数已自 PHP 7.2.0 起废弃。强烈建议不要使用本函数。

说明

each ( array &$array ) : array

返回数组中当前的键／值对并将数组指针向前移动一步

在执行 each() 之后，数组指针将停留在数组中的下一个单元或者当碰到数组结尾时停留在最后一个单元。如果要再用 each 遍历数组，必须使用 reset()。

参数

array

输入的数组。

返回值

返回 array 数组中当前指针位置的键／值对并向前移动数组指针。键值对被返回为四个单元的数组，键名为0，1，key和 value。单元 0 和 key 包含有数组单元的键名，1 和 value 包含有数据。

如果内部指针越过了数组的末端，则 each() 返回 false。

范例

Example #1 each() 例子

<?php
$foo = array("bob", "fred", "jussi", "jouni", "egon", "marliese");
$bar = each($foo);
print_r($bar);
?>

$bar 现在包含有如下的键／值对：

Array
(
    [1] => bob
    [value] => bob
    [0] => 0
    [key] => 0
)

<?php
$foo = array("Robert" => "Bob", "Seppo" => "Sepi");
$bar = each($foo);
print_r($bar);
?>

$bar 现在包含有如下的键／值对：

Array
(
    [1] => Bob
    [value] => Bob
    [0] => Robert
    [key] => Robert
)

each() 经常和 list() 结合使用来遍历数组，例如：

Example #2 用 each() 遍历数组

<?php
$fruit = array('a' => 'apple', 'b' => 'banana', 'c' => 'cranberry');

reset($fruit);
while (list($key, $val) = each($fruit)) {
    echo "$key => $val\n";
}
?>

以上例程会输出：

a => apple
b => banana
c => cranberry

Caution

因为将一个数组赋值给另一个数组时会重置原来的数组指针，因此在上边的例子中如果我们在循环内部将 $fruit 赋给了另一个变量的话将会导致无限循环。

Warning

each() will also accept objects, but may return unexpected results. Its therefore not recommended to iterate though object properties with each().

参见

  • key() - 从关联数组中取得键名
  • list() - 把数组中的值赋给一组变量
  • current() - 返回数组中的当前值
  • reset() - 将数组的内部指针指向第一个单元
  • next() - 将数组中的内部指针向前移动一位
  • prev() - 将数组的内部指针倒回一位
  • foreach
  • Object Iteration


将数组的内部指针指向最后一个单元

  • ? each
  • extract ?
  • PHP Manual
  • 数组 函数
  • 将数组的内部指针指向最后一个单元

end

(PHP 4, PHP 5, PHP 7, PHP 8)

end — 将数组的内部指针指向最后一个单元

说明

end ( array &$array ) : mixed

end() 将 array 的内部指针移动到最后一个单元并返回其值。

参数

array

这个数组。 该数组是通过引用传递的，因为它会被这个函数修改。 这意味着你必须传入一个真正的变量，而不是函数返回的数组，因为只有真正的变量才能以引用传递。

返回值

返回最后一个元素的值，或者如果是空数组则返回 false。

范例

Example #1 end() 例子

<?php

$fruits = array('apple', 'banana', 'cranberry');
echo end($fruits); // cranberry

?>

参见

  • current() - 返回数组中的当前值
  • each() - 返回数组中当前的键／值对并将数组指针向前移动一步
  • prev() - 将数组的内部指针倒回一位
  • reset() - 将数组的内部指针指向第一个单元
  • next() - 将数组中的内部指针向前移动一位


从数组中将变量导入到当前的符号表

  • ? end
  • in_array ?
  • PHP Manual
  • 数组 函数
  • 从数组中将变量导入到当前的符号表

extract

(PHP 4, PHP 5, PHP 7, PHP 8)

extract — 从数组中将变量导入到当前的符号表

说明

extract ( array &$array , int $flags = EXTR_OVERWRITE , string $prefix = "" ) : int

本函数用来将变量从数组中导入到当前的符号表中。

检查每个键名看是否可以作为一个合法的变量名，同时也检查和符号表中已有的变量名的冲突。

Warning

不要对不可信的数据使用 extract()，类似用户输入 （例如 $_GET、$_FILES）。

参数

array

一个关联数组。此函数会将键名当作变量名，值作为变量的值。 对每个键／值对都会在当前的符号表中建立变量，并受到 flags 和 prefix 参数的影响。

必须使用关联数组，数字索引的数组将不会产生结果，除非用了 EXTR_PREFIX_ALL 或者 EXTR_PREFIX_INVALID。

flags

对待非法／数字和冲突的键名的方法将根据取出标记 flags 参数决定。可以是以下值之一：

EXTR_OVERWRITE
如果有冲突，覆盖已有的变量。
EXTR_SKIP
如果有冲突，不覆盖已有的变量。
EXTR_PREFIX_SAME
如果有冲突，在变量名前加上前缀 prefix。
EXTR_PREFIX_ALL
给所有变量名加上前缀 prefix。
EXTR_PREFIX_INVALID
仅在非法／数字的变量名前加上前缀 prefix。
EXTR_IF_EXISTS
仅在当前符号表中已有同名变量时，覆盖它们的值。其它的都不处理。 举个例子，以下情况非常有用：定义一些有效变量，然后从 $_REQUEST 中仅导入这些已定义的变量。
EXTR_PREFIX_IF_EXISTS
仅在当前符号表中已有同名变量时，建立附加了前缀的变量名，其它的都不处理。
EXTR_REFS
将变量作为引用提取。这有力地表明了导入的变量仍然引用了 array 参数的值。可以单独使用这个标志或者在 flags 中用 OR 与其它任何标志结合使用。

如果没有指定 flags，则被假定为 EXTR_OVERWRITE。

prefix

注意 prefix 仅在 flags 的值是 EXTR_PREFIX_SAME，EXTR_PREFIX_ALL，EXTR_PREFIX_INVALID 或 EXTR_PREFIX_IF_EXISTS 时需要。 如果附加了前缀后的结果不是合法的变量名，将不会导入到符号表中。前缀和数组键名之间会自动加上一个下划线。

返回值

返回成功导入到符号表中的变量数目。

范例

Example #1 extract() 例子

extract() 的一种可能用法是将 wddx_deserialize() 返回的结合数组中的内容导入到符号表变量中去。

<?php

/* 假定 $var_array 是 wddx_deserialize 返回的数组*/

$size = "large";
$var_array = array("color" => "blue",
                   "size"  => "medium",
                   "shape" => "sphere");
extract($var_array, EXTR_PREFIX_SAME, "wddx");

echo "$color, $size, $shape, $wddx_size\n";

?>

以上例程会输出：

blue, large, sphere, medium

$size 没有被覆盖，因为指定了 EXTR_PREFIX_SAME，这使得 $wddx_size 被建立。如果指定了 EXTR_SKIP，则 $wddx_size 也不会被建立。EXTR_OVERWRITE 将使 $size 的值为"medium"，EXTR_PREFIX_ALL 将建立新变量 $wddx_color，$wddx_size 和 $wddx_shape。

注释

Warning

不要对不能信任的数据使用 extract()，例如用户的输入（$_GET， $_FILES...）。 如果这样做，要确保使用不会覆盖的 flags 值，例如 EXTR_SKIP，并且要留意应该按照 variables_order 在 php.ini 里 定义的顺序来提取。

参见

  • compact() - 建立一个数组，包括变量名和它们的值
  • list() - 把数组中的值赋给一组变量


检查数组中是否存在某个值

  • ? extract
  • key_exists ?
  • PHP Manual
  • 数组 函数
  • 检查数组中是否存在某个值

in_array

(PHP 4, PHP 5, PHP 7, PHP 8)

in_array — 检查数组中是否存在某个值

说明

in_array ( mixed $needle , array $haystack , bool $strict = false ) : bool

大海捞针，在大海（haystack）中搜索针（ needle），如果没有设置 strict 则使用宽松的比较。

参数

needle

待搜索的值。

Note:

如果 needle 是字符串，则比较是区分大小写的。

haystack

待搜索的数组。

strict

如果第三个参数 strict 的值为 true 则 in_array() 函数还会检查 needle 的类型是否和 haystack 中的相同。

返回值

如果找到 needle 则返回 true，否则返回 false。

范例

Example #1 in_array() 例子

<?php
$os = array("Mac", "NT", "Irix", "Linux");
if (in_array("Irix", $os)) {
    echo "Got Irix";
}
if (in_array("mac", $os)) {
    echo "Got mac";
}
?>

第二个条件失败，因为 in_array() 是区分大小写的，所以以上程序显示为：

Got Irix

Example #2 in_array() 严格类型检查例子

<?php
$a = array('1.10', 12.4, 1.13);

if (in_array('12.4', $a, true)) {
    echo "'12.4' found with strict check\n";
}

if (in_array(1.13, $a, true)) {
    echo "1.13 found with strict check\n";
}
?>

以上例程会输出：

1.13 found with strict check

Example #3 in_array() 中用数组作为 needle

<?php
$a = array(array('p', 'h'), array('p', 'r'), 'o');

if (in_array(array('p', 'h'), $a)) {
    echo "'ph' was found\n";
}

if (in_array(array('f', 'i'), $a)) {
    echo "'fi' was found\n";
}

if (in_array('o', $a)) {
    echo "'o' was found\n";
}
?>

以上例程会输出：

  'ph' was found
  'o' was found

参见

  • array_search() - 在数组中搜索给定的值，如果成功则返回首个相应的键名
  • isset() - 检测变量是否已设置并且非 null
  • array_key_exists() - 检查数组里是否有指定的键名或索引


别名 array_key_exists

  • ? in_array
  • key ?
  • PHP Manual
  • 数组 函数
  • 别名 array_key_exists

key_exists

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

key_exists — 别名 array_key_exists()

说明

此函数是该函数的别名： array_key_exists().


从关联数组中取得键名

  • ? key_exists
  • krsort ?
  • PHP Manual
  • 数组 函数
  • 从关联数组中取得键名

key

(PHP 4, PHP 5, PHP 7, PHP 8)

key — 从关联数组中取得键名

说明

key ( array $array ) : mixed

key() 返回数组中当前单元的键名。

参数

array

该数组。

返回值

key() 函数返回数组中内部指针指向的当前单元的键名。 但它不会移动指针。如果内部指针超过了元素列表尾部，或者数组是空的，key() 会返回 null。

更新日志

版本 | 说明
7.0.0 | array 现在总是会传值。 在此之前，它会尽可能传引用，否则就传值。

范例

Example #1 key() 例子

<?php
$array = array(
    'fruit1' => 'apple',
    'fruit2' => 'orange',
    'fruit3' => 'grape',
    'fruit4' => 'apple',
    'fruit5' => 'apple');

// this cycle echoes all associative array
// key where value equals "apple"
while ($fruit_name = current($array)) {
    if ($fruit_name == 'apple') {
        echo key($array).'<br />';
    }
    next($array);
}
?>

以上例程会输出：

fruit1<br />
fruit4<br />
fruit5<br />

参见

  • current() - 返回数组中的当前值
  • next() - 将数组中的内部指针向前移动一位
  • foreach


对数组按照键名逆向排序

  • ? key
  • ksort ?
  • PHP Manual
  • 数组 函数
  • 对数组按照键名逆向排序

krsort

(PHP 4, PHP 5, PHP 7, PHP 8)

krsort — 对数组按照键名逆向排序

说明

krsort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

对数组按照键名逆向排序，保留键名到数据的关联。主要用于结合数组。

参数

array

输入的数组。

sort_flags

可以用可选参数 sort_flags 改变排序的行为，详情见 sort()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 krsort() 例子

<?php
$fruits = array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
krsort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

以上例程会输出：

d = lemon
c = apple
b = banana
a = orange

参见

  • arsort() - 对数组进行逆向排序并保持索引关系
  • ksort() - 对数组按照键名排序
  • 数组排序函数对比


对数组按照键名排序

  • ? krsort
  • list ?
  • PHP Manual
  • 数组 函数
  • 对数组按照键名排序

ksort

(PHP 4, PHP 5, PHP 7, PHP 8)

ksort — 对数组按照键名排序

说明

ksort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

对数组按照键名排序，保留键名到数据的关联。本函数主要用于关联数组。

参数

array

输入的数组。

sort_flags

可以用可选参数 sort_flags 改变排序的行为，详情见 sort()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ksort() 例子

<?php
$fruits = array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
ksort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

以上例程会输出：

a = orange
b = banana
c = apple
d = lemon

参见

  • asort() - 对数组进行排序并保持索引关系
  • 数组排序函数对比


把数组中的值赋给一组变量

  • ? ksort
  • natcasesort ?
  • PHP Manual
  • 数组 函数
  • 把数组中的值赋给一组变量

list

(PHP 4, PHP 5, PHP 7, PHP 8)

list — 把数组中的值赋给一组变量

说明

list ( mixed $var , mixed ...$vars = ? ) : array

像 array() 一样，这不是真正的函数，而是语言结构。 list() 可以在单次操作内就为一组变量赋值。

Note:

在 PHP 7.1.0 之前的版本，list() 仅能用于数字索引的数组，并假定数字索引从 0 开始。

Warning

PHP 5 里，list() 从最右边的参数开始赋值； PHP 7 里，list() 从最左边的参数开始赋值。

如果你用单纯的变量，不用担心这一点。 但是如果你用了具有索引的数组，通常你期望得到的结果和在 list() 中写的一样是从左到右的，但在 PHP 5 里实际上不是， 它是以相反顺序赋值的。

通常而言，不建议依赖于操作的顺序，在未来可能会再次发生修改。

参数

var

一个变量。

vars

更多变量。

返回值

返回指定的数组。

更新日志

版本 | 说明
7.3.0 | 支持在数组解构时传引用。
7.1.0 | 现在可以指定 list() 中的键。 这就可以解构非数字键或者无顺序的数组。
7.0.0 | 赋值操作的顺序发生了变化。
7.0.0 | list() 表达式不再可以完全为空。
7.0.0 | 字符串无法再被拆包（unpack）。

范例

Example #1 list() 例子

<?php

$info = array('coffee', 'brown', 'caffeine');

// 列出所有变量
list($drink, $color, $power) = $info;
echo "$drink is $color and $power makes it special.\n";

// 列出他们的其中一个
list($drink, , $power) = $info;
echo "$drink has $power.\n";

// 或者让我们跳到仅第三个
list( , , $power) = $info;
echo "I need $power!\n";

// list() 不能对字符串起作用
list($bar) = "abcde";
var_dump($bar); // NULL
?>

Example #2 list() 用法的一个例子

<table>
 <tr>
  <th>Employee name</th>
  <th>Salary</th>
 </tr>

<?php

$result = $pdo->query("SELECT id, name, salary FROM employees");
while (list($id, $name, $salary) = $result->fetch(PDO::FETCH_NUM)) {
    echo " <tr>\n" .
          "  <td><a href=\"info.php?id=$id\">$name</a></td>\n" .
          "  <td>$salary</td>\n" .
          " </tr>\n";
}

?>

</table>

Example #3 使用嵌套的 list()

<?php

list($a, list($b, $c)) = array(1, array(2, 3));

var_dump($a, $b, $c);

?>
int(1)
int(2)
int(3)

Example #4 在 list() 中使用数组索引

<?php

$info = array('coffee', 'brown', 'caffeine');

list($a[0], $a[1], $a[2]) = $info;

var_dump($a);

?>

产生如下输出（注意单元顺序和 list() 语法中所写的顺序的比较）：

以上例程在 PHP 7 中的输出：

array(3) {
  [0]=>
  string(6) "coffee"
  [1]=>
  string(5) "brown"
  [2]=>
  string(8) "caffeine"
}

以上例程在 PHP 5 中的输出：

array(3) {
  [2]=>
  string(8) "caffeine"
  [1]=>
  string(5) "brown"
  [0]=>
  string(6) "coffee"
}

Example #5 list() 和索引顺序定义

list() 使用 array 索引的顺序和它何时定义无关。

<?php
$foo = array(2 => 'a', 'foo' => 'b', 0 => 'c');
$foo[1] = 'd';
list($x, $y, $z) = $foo;
var_dump($foo, $x, $y, $z);

得到以下输出（注意比较 list() 所写的元素顺序）：

array(4) {
  [2]=>
  string(1) "a"
  ["foo"]=>
  string(1) "b"
  [0]=>
  string(1) "c"
  [1]=>
  string(1) "d"
}
string(1) "c"
string(1) "d"
string(1) "a"

Example #6 带键的 list()

从 PHP 7.1.0 开始，list() 可以包含显式的键，可赋值到任意表达式。 可以混合使用数字和字符串键。但是不能混合有键和无键不能混用。

<?php
$data = [
    ["id" => 1, "name" => 'Tom'],
    ["id" => 2, "name" => 'Fred'],
];
foreach ($data as ["id" => $id, "name" => $name]) {
    echo "id: $id, name: $name\n";
}
echo PHP_EOL;
list(1 => $second, 3 => $fourth) = [1, 2, 3, 4];
echo "$second, $fourth\n";

以上例程会输出：

id: 1, name: Tom
id: 2, name: Fred

2, 4

参见

  • each() - 返回数组中当前的键／值对并将数组指针向前移动一步
  • array() - 新建一个数组
  • extract() - 从数组中将变量导入到当前的符号表


用“自然排序”算法对数组进行不区分大小写字母的排序

  • ? list
  • natsort ?
  • PHP Manual
  • 数组 函数
  • 用“自然排序”算法对数组进行不区分大小写字母的排序

natcasesort

(PHP 4, PHP 5, PHP 7, PHP 8)

natcasesort — 用"自然排序"算法对数组进行不区分大小写字母的排序

说明

natcasesort ( array &$array ) : bool

natcasesort() 是 natsort() 函数的不区分大小写字母的版本。

本函数实现了一个和人们通常对字母数字字符串进行排序的方法一样的排序算法并保持原有键／值的关联，这被称为"自然排序"。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

输入的数组。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 natcasesort() 例子

<?php
$array1 = $array2 = array('IMG0.png', 'img12.png', 'img10.png', 'img2.png', 'img1.png', 'IMG3.png');

sort($array1);
echo "Standard sorting\n";
print_r($array1);

natcasesort($array2);
echo "\nNatural order sorting (case-insensitive)\n";
print_r($array2);
?>

以上例程会输出：

Standard sorting
Array
(
    [0] => IMG0.png
    [1] => IMG3.png
    [2] => img1.png
    [3] => img10.png
    [4] => img12.png
    [5] => img2.png
)

Natural order sorting (case-insensitive)
Array
(
    [0] => IMG0.png
    [4] => img1.png
    [3] => img2.png
    [5] => IMG3.png
    [2] => img10.png
    [1] => img12.png
)

更多信息见 Martin Pool 的 » Natural Order String Comparison 页面。

参见

  • natsort() - 用“自然排序”算法对数组排序
  • 数组排序函数对比
  • strnatcmp() - 使用自然排序算法比较字符串
  • strnatcasecmp() - 使用“自然顺序”算法比较字符串（不区分大小写）


用“自然排序”算法对数组排序

  • ? natcasesort
  • next ?
  • PHP Manual
  • 数组 函数
  • 用“自然排序”算法对数组排序

natsort

(PHP 4, PHP 5, PHP 7, PHP 8)

natsort — 用"自然排序"算法对数组排序

说明

natsort ( array &$array ) : bool

本函数实现了一个和人们通常对字母数字字符串进行排序的方法一样的排序算法并保持原有键／值的关联，这被称为"自然排序"。本算法和通常的计算机字符串排序算法（用于 sort()）的区别见下面示例。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

输入的 array。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.2.10 | 用零填充的数字字符串 (例如 '00005')现在本质上会忽略掉填充的前道零。

范例

Example #1 natsort() 基本用法的操作示例

<?php
$array1 = $array2 = array("img12.png", "img10.png", "img2.png", "img1.png");

asort($array1);
echo "Standard sorting\n";
print_r($array1);

natsort($array2);
echo "\nNatural order sorting\n";
print_r($array2);
?>

以上例程会输出：

Standard sorting
Array
(
    [3] => img1.png
    [1] => img10.png
    [0] => img12.png
    [2] => img2.png
)

Natural order sorting
Array
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)

For more information see: Martin Pool's » Natural Order String Comparison page.

Example #2 natsort() examples demonstrating potential gotchas

<?php
echo "Negative numbers\n";
$negative = array('-5','3','-2','0','-1000','9','1');
print_r($negative);
natsort($negative);
print_r($negative);

echo "Zero padding\n";
$zeros = array('09', '8', '10', '009', '011', '0');
print_r($zeros);
natsort($zeros);
print_r($zeros);
?>

以上例程会输出：

Negative numbers
Array
(
    [0] => -5
    [1] => 3
    [2] => -2
    [3] => 0
    [4] => -1000
    [5] => 9
    [6] => 1
)
Array
(
    [2] => -2
    [0] => -5
    [4] => -1000
    [3] => 0
    [6] => 1
    [1] => 3
    [5] => 9
)

Zero padding
Array
(
    [0] => 09
    [1] => 8
    [2] => 10
    [3] => 009
    [4] => 011
    [5] => 0
)
Array
(
    [5] => 0
    [1] => 8
    [3] => 009
    [0] => 09
    [2] => 10
    [4] => 011
)

参见

  • natcasesort() - 用“自然排序”算法对数组进行不区分大小写字母的排序
  • 数组排序函数对比
  • strnatcmp() - 使用自然排序算法比较字符串
  • strnatcasecmp() - 使用“自然顺序”算法比较字符串（不区分大小写）


将数组中的内部指针向前移动一位

  • ? natsort
  • pos ?
  • PHP Manual
  • 数组 函数
  • 将数组中的内部指针向前移动一位

next

(PHP 4, PHP 5, PHP 7, PHP 8)

next — 将数组中的内部指针向前移动一位

说明

next ( array &$array ) : mixed

next() 和 current() 的行为类似，只有一点区别，在返回值之前将内部指针向前移动一位。这意味着它返回的是下一个数组单元的值并将数组指针向前移动了一位。

参数

array

受影响的 array 。

返回值

返回数组内部指针指向的下一个单元的值，或当没有更多单元时返回 false。

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

范例

Example #1 next() 及相关函数的用法示例

<?php
$transport = array('foot', 'bike', 'car', 'plane');
$mode = current($transport); // $mode = 'foot';
$mode = next($transport);    // $mode = 'bike';
$mode = next($transport);    // $mode = 'car';
$mode = prev($transport);    // $mode = 'bike';
$mode = end($transport);     // $mode = 'plane';
?>

注释

Note: 你将无法区别包含数组尾以及 boolean false 单元的数组。要正确遍历可能含有空单元或者单元值为 0 的数组，参见 each() 函数。

参见

  • current() - 返回数组中的当前值
  • end() - 将数组的内部指针指向最后一个单元
  • prev() - 将数组的内部指针倒回一位
  • reset() - 将数组的内部指针指向第一个单元
  • each() - 返回数组中当前的键／值对并将数组指针向前移动一步


current 的别名

  • ? next
  • prev ?
  • PHP Manual
  • 数组 函数
  • current 的别名

pos

(PHP 4, PHP 5, PHP 7, PHP 8)

pos — current() 的别名

说明

此函数是该函数的别名：current()。


将数组的内部指针倒回一位

  • ? pos
  • range ?
  • PHP Manual
  • 数组 函数
  • 将数组的内部指针倒回一位

prev

(PHP 4, PHP 5, PHP 7, PHP 8)

prev — 将数组的内部指针倒回一位

说明

prev ( array &$array ) : mixed

将数组的内部指针倒回一位。

prev() 和 next() 的行为类似，只除了它将内部指针倒回一位而不是前移一位。

参数

array

The input array.

返回值

返回数组内部指针指向的前一个单元的值，或当没有更多单元时返回 false。

范例

Example #1 prev() 及相关函数用法示例

<?php
$transport = array('foot', 'bike', 'car', 'plane');
$mode = current($transport); // $mode = 'foot';
$mode = next($transport);    // $mode = 'bike';
$mode = next($transport);    // $mode = 'car';
$mode = prev($transport);    // $mode = 'bike';
$mode = end($transport);     // $mode = 'plane';
?>

注释

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

Note: 你会无法区分包含 boolean false 单元的数组开头。要正确遍历可能含有空单元或者单元值为 0 的数组，参见 each() 函数。

参见

  • current() - 返回数组中的当前值
  • end() - 将数组的内部指针指向最后一个单元
  • next() - 将数组中的内部指针向前移动一位
  • reset() - 将数组的内部指针指向第一个单元
  • each() - 返回数组中当前的键／值对并将数组指针向前移动一步


根据范围创建数组，包含指定的元素

  • ? prev
  • reset ?
  • PHP Manual
  • 数组 函数
  • 根据范围创建数组，包含指定的元素

range

(PHP 4, PHP 5, PHP 7, PHP 8)

range — 根据范围创建数组，包含指定的元素

说明

range ( string|int|float $start , string|int|float $end , int|float $step = 1 ) : array

建立一个包含指定范围单元的数组。

参数

start

序列的第一个值。

end

序列结束于 end 的值。

step

如果设置了步长 step，会被作为单元之间的步进值。step 应该为正值。不设置step 则默认为 1。

返回值

返回的数组中从 start 到 end （含 start 和 end）的单元。

范例

Example #1 range() 例子

<?php
// array(0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12)
foreach (range(0, 12) as $number) {
    echo $number;
}

echo "\n";

//  step 参数
// array(0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100)
foreach (range(0, 100, 10) as $number) {
    echo $number;
}

echo "\n";

// 字符序列的使用
// array('a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i');
foreach (range('a', 'i') as $letter) {
    echo $letter;
}

echo "\n";

// array('c', 'b', 'a');
foreach (range('c', 'a') as $letter) {
    echo $letter;
}
?>

注释

Note:

字符序列值仅限单个字符。 如果长度大于 1，仅仅使用第一个字符。

参见

  • shuffle() - 打乱数组
  • array_fill() - 用给定的值填充数组
  • foreach


将数组的内部指针指向第一个单元

  • ? range
  • rsort ?
  • PHP Manual
  • 数组 函数
  • 将数组的内部指针指向第一个单元

reset

(PHP 4, PHP 5, PHP 7, PHP 8)

reset — 将数组的内部指针指向第一个单元

说明

reset ( array &$array ) : mixed

reset() 将 array 的内部指针倒回到第一个单元并返回第一个数组单元的值。

参数

array

输入的数组。

返回值

返回数组第一个单元的值，如果数组为空则返回 false。

范例

Example #1 reset() 例子

<?php

$array = array('step one', 'step two', 'step three', 'step four');

// by default, the pointer is on the first element
echo current($array) . "<br />\n"; // "step one"

// skip two steps
next($array);
next($array);
echo current($array) . "<br />\n"; // "step three"

// reset pointer, start again on step one
reset($array);
echo current($array) . "<br />\n"; // "step one"

?>

参见

  • current() - 返回数组中的当前值
  • each() - 返回数组中当前的键／值对并将数组指针向前移动一步
  • end() - 将数组的内部指针指向最后一个单元
  • next() - 将数组中的内部指针向前移动一位
  • prev() - 将数组的内部指针倒回一位


对数组逆向排序

  • ? reset
  • shuffle ?
  • PHP Manual
  • 数组 函数
  • 对数组逆向排序

rsort

(PHP 4, PHP 5, PHP 7, PHP 8)

rsort — 对数组逆向排序

说明

rsort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

本函数对数组进行逆向排序（最高到最低）。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

输入的数组。

sort_flags

可以用可选参数 sort_flags 改变排序的行为，详情见 sort()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 rsort() 例

<?php
$fruits = array("lemon", "orange", "banana", "apple");
rsort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

以上例程会输出：

0 = orange
1 = lemon
2 = banana
3 = apple

fruits 被按照字母顺序逆向排序。

注释

Note: 此函数为 array 中的元素赋与新的键名。这将删除原有的键名，而不是仅仅将键名重新排序。

参见

  • arsort() - 对数组进行逆向排序并保持索引关系
  • krsort() - 对数组按照键名逆向排序
  • 数组排序函数对比


打乱数组

  • ? rsort
  • sizeof ?
  • PHP Manual
  • 数组 函数
  • 打乱数组

shuffle

(PHP 4, PHP 5, PHP 7, PHP 8)

shuffle — 打乱数组

说明

shuffle ( array &$array ) : bool

本函数打乱（随机排列单元的顺序）一个数组。 它使用的是伪随机数产生器，并不适合密码学的场合。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

待操作的数组。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
7.1.0 | 内置的随机数产生算法从 libc rand 函数改成 » 梅森旋转伪随机数生成算法。

范例

Example #1 shuffle() 例子

<?php
$numbers = range(1, 20);
shuffle($numbers);
foreach ($numbers as $number) {
    echo "$number ";
}
?>

注释

Note: 此函数为 array 中的元素赋与新的键名。这将删除原有的键名，而不是仅仅将键名重新排序。

参见

  • array_rand() - 从数组中随机取出一个或多个随机键
  • 数组排序函数对比


count 的别名

  • ? shuffle
  • sort ?
  • PHP Manual
  • 数组 函数
  • count 的别名

sizeof

(PHP 4, PHP 5, PHP 7, PHP 8)

sizeof — count() 的别名

说明

此函数是该函数的别名：count()。


对数组排序

  • ? sizeof
  • uasort ?
  • PHP Manual
  • 数组 函数
  • 对数组排序

sort

(PHP 4, PHP 5, PHP 7, PHP 8)

sort — 对数组排序

说明

sort ( array &$array , int $sort_flags = SORT_REGULAR ) : bool

本函数对数组进行排序。 当本函数结束时数组单元将被从最低到最高重新安排。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

要排序的数组。

sort_flags

可选的第二个参数 sort_flags 可以用以下值改变排序的行为：

排序类型标记：

  • SORT_REGULAR - 正常比较单元 详细描述参见 比较运算符 章节
  • SORT_NUMERIC - 单元被作为数字来比较
  • SORT_STRING - 单元被作为字符串来比较
  • SORT_LOCALE_STRING - 根据当前的区域（locale）设置来把单元当作字符串比较，可以用 setlocale() 来改变。
  • SORT_NATURAL - 和 natsort() 类似对每个单元以"自然的顺序"对字符串进行排序。
  • SORT_FLAG_CASE - 能够与 SORT_STRING 或 SORT_NATURAL 合并（OR 位运算），不区分大小写排序字符串。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 sort() 例子

<?php

$fruits = array("lemon", "orange", "banana", "apple");
sort($fruits);
foreach ($fruits as $key => $val) {
    echo "fruits[" . $key . "] = " . $val . "\n";
}

?>

以上例程会输出：

fruits[0] = apple
fruits[1] = banana
fruits[2] = lemon
fruits[3] = orange

fruits 被按照字母顺序排序。

Example #2 使用 sort() 不区分大小写自然排序的例子

<?php

$fruits = array(
    "Orange1", "orange2", "Orange3", "orange20"
);
sort($fruits, SORT_NATURAL | SORT_FLAG_CASE);
foreach ($fruits as $key => $val) {
    echo "fruits[" . $key . "] = " . $val . "\n";
}

?>

以上例程会输出：

fruits[0] = Orange1
fruits[1] = orange2
fruits[2] = Orange3
fruits[3] = orange20

fruits 排序得像 natcasesort() 的结果。

注释

Note: 此函数为 array 中的元素赋与新的键名。这将删除原有的键名，而不是仅仅将键名重新排序。

Note: 和大多数 PHP 排序函数一样，sort() 使用了 » Quicksort 实现的。 The pivot is chosen in the middle of the partition resulting in an optimal time for already sorted arrays. This is however an implementation detail you shouldn't rely on.

Warning

在对含有混合类型值的数组 以 sort_flags 为 SORT_REGULAR 排序时要小心，因为 sort() 可能会产生不可预知的结果。

参见

  • asort() - 对数组进行排序并保持索引关系
  • rsort() - 对数组逆向排序
  • 数组排序函数对比


使用用户自定义的比较函数对数组中的值进行排序并保持索引关联

  • ? sort
  • uksort ?
  • PHP Manual
  • 数组 函数
  • 使用用户自定义的比较函数对数组中的值进行排序并保持索引关联

uasort

(PHP 4, PHP 5, PHP 7, PHP 8)

uasort — 使用用户自定义的比较函数对数组中的值进行排序并保持索引关联

说明

uasort ( array &$array , callable $value_compare_func ) : bool

本函数对数组排序并保持索引和单元之间的关联。

主要用于对那些单元顺序很重要的结合数组进行排序。比较函数是用户自定义的。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

输入的数组。

value_compare_func

用户自定义比较函数的例子请参考 usort() 和 uksort()。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 uasort() 的基本例子

<?php
// Comparison function
function cmp($a, $b) {
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

// Array to be sorted
$array = array('a' => 4, 'b' => 8, 'c' => -1, 'd' => -9, 'e' => 2, 'f' => 5, 'g' => 3, 'h' => -4);
print_r($array);

// Sort and print the resulting array
uasort($array, 'cmp');
print_r($array);
?>

以上例程会输出：

Array
(
    [a] => 4
    [b] => 8
    [c] => -1
    [d] => -9
    [e] => 2
    [f] => 5
    [g] => 3
    [h] => -4
)
Array
(
    [d] => -9
    [h] => -4
    [c] => -1
    [e] => 2
    [g] => 3
    [a] => 4
    [f] => 5
    [b] => 8
)

参见

  • usort() - 使用用户自定义的比较函数对数组中的值进行排序
  • 数组排序函数对比


使用用户自定义的比较函数对数组中的键名进行排序

  • ? uasort
  • usort ?
  • PHP Manual
  • 数组 函数
  • 使用用户自定义的比较函数对数组中的键名进行排序

uksort

(PHP 4, PHP 5, PHP 7, PHP 8)

uksort — 使用用户自定义的比较函数对数组中的键名进行排序

说明

uksort ( array &$array , callable $key_compare_func ) : bool

uksort() 函数将使用用户提供的比较函数对数组中的键名进行排序。如果要排序的数组需要用一种不寻常的标准进行排序，那么应该使用此函数。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

参数

array

输入的数组。

key_compare_func

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 uksort() 例子

<?php
function cmp($a, $b)
{
    $a = preg_replace('@^(a|an|the) @', '', $a);
    $b = preg_replace('@^(a|an|the) @', '', $b);
    return strcasecmp($a, $b);
}

$a = array("John" => 1, "the Earth" => 2, "an apple" => 3, "a banana" => 4);

uksort($a, "cmp");

foreach ($a as $key => $value) {
    echo "$key: $value\n";
}
?>

以上例程会输出：

an apple: 3
a banana: 4
the Earth: 2
John: 1

参见

  • usort() - 使用用户自定义的比较函数对数组中的值进行排序
  • 数组排序函数对比


使用用户自定义的比较函数对数组中的值进行排序

  • ? uksort
  • 类/对象 ?
  • PHP Manual
  • 数组 函数
  • 使用用户自定义的比较函数对数组中的值进行排序

usort

(PHP 4, PHP 5, PHP 7, PHP 8)

usort — 使用用户自定义的比较函数对数组中的值进行排序

说明

usort ( array &$array , callable $value_compare_func ) : bool

本函数将用用户自定义的比较函数对一个数组中的值进行排序。 如果要排序的数组需要用一种不寻常的标准进行排序，那么应该使用此函数。

Note:

如果两个成员完全相同，那么它们在排序数组中的相对顺序是未定义的。

Note: 此函数为 array 中的元素赋与新的键名。这将删除原有的键名，而不是仅仅将键名重新排序。

参数

array

输入的数组

cmp_function

在第一个参数小于，等于或大于第二个参数时，该比较函数必须相应地返回一个小于，等于或大于 0 的整数。

callback ( mixed $a, mixed $b ) : int
Caution

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 usort() 例子

<?php
function cmp($a, $b)
{
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

$a = array(3, 2, 5, 6, 1);

usort($a, "cmp");

foreach ($a as $key => $value) {
    echo "$key: $value\n";
}
?>

以上例程会输出：

0: 1
1: 2
2: 3
3: 5
4: 6

Note:

很明显在这个小例子中用 sort() 函数更合适。

Example #2 使用多维数组的 usort() 例子

<?php
function cmp($a, $b)
{
    return strcmp($a["fruit"], $b["fruit"]);
}

$fruits[0]["fruit"] = "lemons";
$fruits[1]["fruit"] = "apples";
$fruits[2]["fruit"] = "grapes";

usort($fruits, "cmp");

while (list($key, $value) = each($fruits)) {
    echo "$fruits[$key]: " . $value["fruit"] . "\n";
}
?>

当排序多维数组时，$a 和 $b 包含到数组第一个索引的引用。

以上例程会输出：

$fruits[0]: apples
$fruits[1]: grapes
$fruits[2]: lemons

Example #3 usort() example using a member function of an object

<?php
class TestObj {
    var $name;

    function TestObj($name)
    {
        $this->name = $name;
    }

    /* This is the static comparing function: */
    static function cmp_obj($a, $b)
    {
        $al = strtolower($a->name);
        $bl = strtolower($b->name);
        if ($al == $bl) {
            return 0;
        }
        return ($al > $bl) ? +1 : -1;
    }
}

$a[] = new TestObj("c");
$a[] = new TestObj("b");
$a[] = new TestObj("d");

usort($a, array("TestObj", "cmp_obj"));

foreach ($a as $item) {
    echo $item->name . "\n";
}
?>

以上例程会输出：

b
c
d

Example #4 usort() example using a closure to sort a multi-dimensional array

<?php
$array[0] = array('key_a' => 'z', 'key_b' => 'c');
$array[1] = array('key_a' => 'x', 'key_b' => 'b');
$array[2] = array('key_a' => 'y', 'key_b' => 'a');

function build_sorter($key) {
    return function ($a, $b) use ($key) {
        return strnatcmp($a[$key], $b[$key]);
    };
}

usort($array, build_sorter('key_b'));

foreach ($array as $item) {
    echo $item['key_a'] . ', ' . $item['key_b'] . "\n";
}
?>

以上例程会输出：

y, a
x, b
z, c

参见

  • uasort() - 使用用户自定义的比较函数对数组中的值进行排序并保持索引关联
  • 数组排序函数对比


类/对象的信息

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • 类/对象 函数
    • __autoload — 尝试加载未定义的类
    • class_alias — 为一个类创建别名
    • class_exists — 检查类是否已定义
    • get_called_class — 后期静态绑定（"Late Static Binding"）类的名称
    • get_class_methods — 返回由类的方法名组成的数组
    • get_class_vars — 返回由类的默认属性组成的数组
    • get_class — 返回对象的类名
    • get_declared_classes — 返回由已定义类的名字所组成的数组
    • get_declared_interfaces — 返回一个数组包含所有已声明的接口
    • get_declared_traits — 返回所有已定义的 traits 的数组
    • get_object_vars — 返回由对象属性组成的关联数组
    • get_parent_class — 返回对象或类的父类名
    • interface_exists — 检查接口是否已被定义
    • is_a — 如果对象属于该类或该类是此对象的父类则返回 true
    • is_subclass_of — 如果此对象是该类的子类，则返回 true
    • method_exists — 检查类的方法是否存在
    • property_exists — 检查对象或类是否具有该属性
    • trait_exists — 检查指定的 trait 是否存在


简介

这些函数允许你获得类和对象实例的相关信息。 你可以获取对象所属的类名，也可以是它的成员属性和方法。 通过使用这些函数，你不仅可以找到对象和类的关系，也可以是它们的继承关系（例如，对象类继承自哪个类）。

请参见手册中对象一节来查看在 PHP 里，对象和类如何实现和使用的详细描述。


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • 类/对象
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

在这个例子中，我们首先定义了一个基类和该类的扩展。 这个基类描述了普通的蔬菜，关于它是否可食用及其颜色。 子类 Spinach 添加了烹饪的方法和另一个检查是否已烹饪的方法。

Example #1 classes.inc

<?php

// base class with member properties and methods
class Vegetable {

   var $edible;
   var $color;

   function __construct($edible, $color="green")
   {
       $this->edible = $edible;
       $this->color = $color;
   }

   function is_edible()
   {
       return $this->edible;
   }

   function what_color()
   {
       return $this->color;
   }

} // end of class Vegetable

// extends the base class
class Spinach extends Vegetable {

   var $cooked = false;

   function __construct()
   {
       parent::__construct(true, "green");
   }

   function cook_it()
   {
       $this->cooked = true;
   }

   function is_cooked()
   {
       return $this->cooked;
   }

} // end of class Spinach

?>

接下来我们从这些类中实例化了两个对象，并打印了他们的信息，包括了他们类的继承关系。 同时我们也定了一些实用函数，主要为了漂亮地打印出这些变量。

Example #2 test_script.php

<pre>
<?php

include "classes.inc";

// 实用函数

function print_vars($obj)
{
foreach (get_object_vars($obj) as $prop => $val) {
    echo "\t$prop = $val\n";
}
}

function print_methods($obj)
{
$arr = get_class_methods(get_class($obj));
foreach ($arr as $method) {
    echo "\tfunction $method()\n";
}
}

function class_parentage($obj, $class)
{
if (is_subclass_of($GLOBALS[$obj], $class)) {
    echo "Object $obj belongs to class " . get_class($GLOBALS[$obj]);
    echo " a subclass of $class\n";
} else {
    echo "Object $obj does not belong to a subclass of $class\n";
}
}

// 实例化 2 对象

$veggie = new Vegetable(true, "blue");
$leafy = new Spinach();

// 打印这些对象的信息
echo "veggie: CLASS " . get_class($veggie) . "\n";
echo "leafy: CLASS " . get_class($leafy);
echo ", PARENT " . get_parent_class($leafy) . "\n";

// 显示蔬菜的属性
echo "\nveggie: Properties\n";
print_vars($veggie);

// and leafy methods
echo "\nleafy: Methods\n";
print_methods($leafy);

echo "\nParentage:\n";
class_parentage("leafy", "Spinach");
class_parentage("leafy", "Vegetable");
?>
</pre>

一个重要的东西是注意在上面的例子中，对象 $leafy 是 Spinach 的实例（Vegetable 的子类），另外脚本的最后部分会输出以下信息：

   [...]
Parentage:
Object leafy does not belong to a subclass of Spinach
Object leafy belongs to class spinach, a subclass of Vegetable


类/对象 函数

Table of Contents

  • __autoload — 尝试加载未定义的类
  • class_alias — 为一个类创建别名
  • class_exists — 检查类是否已定义
  • get_called_class — 后期静态绑定（"Late Static Binding"）类的名称
  • get_class_methods — 返回由类的方法名组成的数组
  • get_class_vars — 返回由类的默认属性组成的数组
  • get_class — 返回对象的类名
  • get_declared_classes — 返回由已定义类的名字所组成的数组
  • get_declared_interfaces — 返回一个数组包含所有已声明的接口
  • get_declared_traits — 返回所有已定义的 traits 的数组
  • get_object_vars — 返回由对象属性组成的关联数组
  • get_parent_class — 返回对象或类的父类名
  • interface_exists — 检查接口是否已被定义
  • is_a — 如果对象属于该类或该类是此对象的父类则返回 true
  • is_subclass_of — 如果此对象是该类的子类，则返回 true
  • method_exists — 检查类的方法是否存在
  • property_exists — 检查对象或类是否具有该属性
  • trait_exists — 检查指定的 trait 是否存在


尝试加载未定义的类

  • ? 类/对象 函数
  • class_alias ?
  • PHP Manual
  • 类/对象 函数
  • 尝试加载未定义的类

__autoload

(PHP 5, PHP 7)

__autoload — 尝试加载未定义的类

Warning

本函数已自 PHP 7.2.0 起被废弃，并自 PHP 8.0.0 起被移除。 强烈建议不要依赖本函数。

说明

__autoload ( string $class ) : void

你可以通过定义这个函数来启用类的自动加载。

参数

class

待加载的类名。

返回值

没有返回值。

参见

  • spl_autoload_register() - 注册给定的函数作为 __autoload 的实现


为一个类创建别名

  • ? __autoload
  • class_exists ?
  • PHP Manual
  • 类/对象 函数
  • 为一个类创建别名

class_alias

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

class_alias — 为一个类创建别名

说明

class_alias ( string $original , string $alias , bool $autoload = true ) : bool

基于用户定义的类 original 创建别名 alias。 这个别名类和原有的类完全相同。

参数

original

原有的类。

alias

类的别名。

autoload

如果原始类没有加载，是否使用自动加载（autoload）。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 class_alias() 例子

<?php

class foo { }

class_alias('foo', 'bar');

$a = new foo;
$b = new bar;

// the objects are the same
var_dump($a == $b, $a === $b);
var_dump($a instanceof $b);

// the classes are the same
var_dump($a instanceof foo);
var_dump($a instanceof bar);

var_dump($b instanceof foo);
var_dump($b instanceof bar);

?>

以上例程会输出：

bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)
bool(true)

参见

  • get_parent_class() - 返回对象或类的父类名
  • is_subclass_of() - 如果此对象是该类的子类，则返回 true


检查类是否已定义

  • ? class_alias
  • get_called_class ?
  • PHP Manual
  • 类/对象 函数
  • 检查类是否已定义

class_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

class_exists — 检查类是否已定义

说明

class_exists ( string $class_name , bool $autoload = true ) : bool

检查指定的类是否已定义。

参数

class_name

类名。名字的匹配是不分区大小写的。

autoload

是否默认调用 __autoload。

返回值

如果由 class_name 所指的类已经定义，此函数返回 true，否则返回 false。

范例

Example #1 class_exists() 例子

<?php
// 使用前检查类是否存在
if (class_exists('MyClass')) {
    $myclass = new MyClass();
}

?>

Example #2 autoload parameter 例子

<?php
function __autoload($class)
{
    include($class . '.php');

    // Check to see whether the include declared the class
    if (!class_exists($class, false)) {
        trigger_error("Unable to load class: $class", E_USER_WARNING);
    }
}

if (class_exists('MyClass')) {
    $myclass = new MyClass();
}

?>

参见

  • function_exists() - 如果给定的函数已经被定义就返回 true
  • interface_exists() - 检查接口是否已被定义
  • get_declared_classes() - 返回由已定义类的名字所组成的数组


后期静态绑定（"Late Static Binding"）类的名称

  • ? class_exists
  • get_class_methods ?
  • PHP Manual
  • 类/对象 函数
  • 后期静态绑定（"Late Static Binding"）类的名称

get_called_class

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

get_called_class — 后期静态绑定（"Late Static Binding"）类的名称

说明

get_called_class ( ) : string

获取静态方法调用的类名。

返回值

返回类的名称，如果不是在类中调用则返回 false。

范例

Example #1 get_called_class() 的使用

<?php

class foo {
    static public function test() {
        var_dump(get_called_class());
    }
}

class bar extends foo {
}

foo::test();
bar::test();

?>

以上例程会输出：

string(3) "foo"
string(3) "bar"

参见

  • get_parent_class() - 返回对象或类的父类名
  • get_class() - 返回对象的类名
  • is_subclass_of() - 如果此对象是该类的子类，则返回 true


返回由类的方法名组成的数组

  • ? get_called_class
  • get_class_vars ?
  • PHP Manual
  • 类/对象 函数
  • 返回由类的方法名组成的数组

get_class_methods

(PHP 4, PHP 5, PHP 7, PHP 8)

get_class_methods — 返回由类的方法名组成的数组

说明

get_class_methods ( mixed $class_name ) : array

返回由类的方法名组成的数组。

参数

class_name

类名或者对象实例。

返回值

返回由 class_name 指定的类中定义的方法名所组成的数组。如果出错，则返回 null。

范例

Example #1 get_class_methods() 示例

<?php

class myclass {
    // constructor
    function myclass()
    {
        return(true);
    }

    // method 1
    function myfunc1()
    {
        return(true);
    }

    // method 2
    function myfunc2()
    {
        return(true);
    }
}

$class_methods = get_class_methods('myclass');
// or
$class_methods = get_class_methods(new myclass());

foreach ($class_methods as $method_name) {
    echo "$method_name\n";
}

?>

以上例程会输出：

myclass
myfunc1
myfunc2

参见

  • get_class() - 返回对象的类名
  • get_class_vars() - 返回由类的默认属性组成的数组
  • get_object_vars() - 返回由对象属性组成的关联数组


返回由类的默认属性组成的数组

  • ? get_class_methods
  • get_class ?
  • PHP Manual
  • 类/对象 函数
  • 返回由类的默认属性组成的数组

get_class_vars

(PHP 4, PHP 5, PHP 7, PHP 8)

get_class_vars — 返回由类的默认属性组成的数组

说明

get_class_vars ( string $class_name ) : array

返回由类的默认公有属性组成的关联数组。

参数

class_name

类名

返回值

Returns an associative array of declared properties visible from the current scope, with their default value. The resulting array elements are in the form of varname => value. In case of an error, it returns false.

范例

Example #1 get_class_vars() example

<?php

class myclass {

    var $var1; // this has no default value...
    var $var2 = "xyz";
    var $var3 = 100;
    private $var4;

    // constructor
    function __construct() {
        // change some properties
        $this->var1 = "foo";
        $this->var2 = "bar";
        return true;
    }

}

$my_class = new myclass();

$class_vars = get_class_vars(get_class($my_class));

foreach ($class_vars as $name => $value) {
    echo "$name : $value\n";
}

?>

以上例程会输出：

var1 :
var2 : xyz
var3 : 100

Example #2 get_class_vars() and scoping behaviour

<?php
function format($array)
{
    return implode('|', array_keys($array)) . "\r\n";
}

class TestCase
{
    public $a    = 1;
    protected $b = 2;
    private $c   = 3;

    public static function expose()
    {
        echo format(get_class_vars(__CLASS__));
    }
}

TestCase::expose();
echo format(get_class_vars('TestCase'));
?>

以上例程会输出：

// 5.0.0
a| * b| TestCase c
a| * b| TestCase c

// 5.0.1 - 5.0.2
a|b|c
a|b|c

// 5.0.3 +
a|b|c
a

参见

  • get_class_methods() - 返回由类的方法名组成的数组
  • get_object_vars() - 返回由对象属性组成的关联数组


返回对象的类名

  • ? get_class_vars
  • get_declared_classes ?
  • PHP Manual
  • 类/对象 函数
  • 返回对象的类名

get_class

(PHP 4, PHP 5, PHP 7, PHP 8)

get_class — 返回对象的类名

说明

get_class ( object $object = null ) : string

返回对象实例 object 所属类的名字。

参数

object

要测试的对象。如果在类里，此参数可以省略。

返回值

返回对象实例 object 所属类的名字。 如果 object 不是一个对象则返回 false。

如果在一个类里，省略了参数 object， 则返回当前所在类的名称。

如果 object 是命名空间中某个类的实例，则会返回带上命名空间的类名。

错误／异常

如果用其他类型调用 get_class()，而不是一个对象的话，就会产生 E_WARNING 级别的错误。

更新日志

版本 | 说明
5.3.0 起 | object 默认参数现在是 null ，所以，现在传入 null 到 object 参数时，和没传参数的结果一样。

范例

Example #1 使用 get_class()

<?php

class foo {
    function name()
    {
        echo "My name is " , get_class($this) , "\n";
    }
}

// create an object
$bar = new foo();

// external call
echo "Its name is " , get_class($bar) , "\n";

// internal call
$bar->name();

?>

以上例程会输出：

Its name is foo
My name is foo

Example #2 超类中使用 get_class()

<?php

abstract class bar {
    public function __construct()
    {
        var_dump(get_class($this));
        var_dump(get_class());
    }
}

class foo extends bar {
}

new foo;

?>

以上例程会输出：

string(3) "foo"
string(3) "bar"

Example #3 命名空间中的类使用 get_class()

<?php

namespace Foo\Bar;

class Baz {
    public function __construct()
    {

    }
}

$baz = new \Foo\Bar\Baz;

var_dump(get_class($baz));
?>

以上例程会输出：

string(11) "Foo\Bar\Baz"

参见

  • get_called_class() - 后期静态绑定（"Late Static Binding"）类的名称
  • get_parent_class() - 返回对象或类的父类名
  • gettype() - 获取变量的类型
  • is_subclass_of() - 如果此对象是该类的子类，则返回 true


返回由已定义类的名字所组成的数组

  • ? get_class
  • get_declared_interfaces ?
  • PHP Manual
  • 类/对象 函数
  • 返回由已定义类的名字所组成的数组

get_declared_classes

(PHP 4, PHP 5, PHP 7, PHP 8)

get_declared_classes — 返回由已定义类的名字所组成的数组

说明

get_declared_classes ( ) : array

返回由当前脚本中已定义类的名字组成的数组。

返回值

返回由当前脚本中已定义类的名字组成的数组。

Note:

需要注意的是额外类的出现依赖于你已编译到 PHP 中的库。这意味着你不能使用这些类名定义自己的类。在附录的 预定义类 部分有预定义类的列表。

范例

Example #1 get_declared_classes() 例子

<?php
print_r(get_declared_classes());
?>

以上例程的输出类似于：

Array
(
    [0] => stdClass
    [1] => __PHP_Incomplete_Class
    [2] => Directory
)

参见

  • class_exists() - 检查类是否已定义
  • get_declared_interfaces() - 返回一个数组包含所有已声明的接口
  • get_defined_functions() - 返回所有已定义函数的数组


返回一个数组包含所有已声明的接口

  • ? get_declared_classes
  • get_declared_traits ?
  • PHP Manual
  • 类/对象 函数
  • 返回一个数组包含所有已声明的接口

get_declared_interfaces

(PHP 5, PHP 7, PHP 8)

get_declared_interfaces — 返回一个数组包含所有已声明的接口

说明

get_declared_interfaces ( ) : array

返回一个数组包含所有已声明的接口。

返回值

本函数返回一个数组，其内容是当前脚本中所有已声明的接口的名字。

范例

Example #1 get_declared_interfaces() 例子

<?php
print_r(get_declared_interfaces());
?>

以上例程的输出类似于：

Array
(
    [0] => Traversable
    [1] => IteratorAggregate
    [2] => Iterator
    [3] => ArrayAccess
    [4] => reflector
    [5] => RecursiveIterator
    [6] => SeekableIterator
)

参见

  • interface_exists() - 检查接口是否已被定义
  • get_declared_classes() - 返回由已定义类的名字所组成的数组
  • class_implements() - 返回指定的类实现的所有接口。


返回所有已定义的 traits 的数组

  • ? get_declared_interfaces
  • get_object_vars ?
  • PHP Manual
  • 类/对象 函数
  • 返回所有已定义的 traits 的数组

get_declared_traits

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

get_declared_traits — 返回所有已定义的 traits 的数组

说明

get_declared_traits ( ) : array

参数

此函数没有参数。

返回值

返回一个数组，其值包含了所有已定义的 traits 的名称。 在失败的情况下返回 null。

参见

  • class_uses() - Return the traits used by the given class
  • trait_exists() - 检查指定的 trait 是否存在


返回由对象属性组成的关联数组

  • ? get_declared_traits
  • get_parent_class ?
  • PHP Manual
  • 类/对象 函数
  • 返回由对象属性组成的关联数组

get_object_vars

(PHP 4, PHP 5, PHP 7, PHP 8)

get_object_vars — 返回由对象属性组成的关联数组

说明

get_object_vars ( object $obj ) : array

返回由 obj 指定的对象中定义的属性组成的关联数组。

Note:

在 PHP 4.2.0 之前的版本中，如果在 obj 对象实例中声明的变量没有被赋值，则它们将不会在返回的数组中。而在 PHP 4.2.0 之后，这些变量作为键名将被赋予 null 值。

Example #1 使用 get_object_vars()

<?php
class Point2D {
    var $x, $y;
    var $label;

    function Point2D($x, $y)
    {
        $this->x = $x;
        $this->y = $y;
    }

    function setLabel($label)
    {
        $this->label = $label;
    }

    function getPoint()
    {
        return array("x" => $this->x,
                     "y" => $this->y,
                     "label" => $this->label);
    }
}

// "$label" is declared but not defined
$p1 = new Point2D(1.233, 3.445);
print_r(get_object_vars($p1));

$p1->setLabel("point #1");
print_r(get_object_vars($p1));

?>

以上例程会输出：

 Array
 (
     [x] => 1.233
     [y] => 3.445
     [label] =>
 )

 Array
 (
     [x] => 1.233
     [y] => 3.445
     [label] => point #1
 )

参见 get_class_methods() 和 get_class_vars()。

参数

object

An object instance.

返回值

Returns an associative array of defined object accessible non-static properties for the specified object in scope. If a property have not been assigned a value, it will be returned with a null value.

更新日志

版本 | 说明
5.3.0 | This function now returns NULL if the object isn't an object.
prior to 5.3.0 | If the object isn't an object, then get_object_vars() would return false
prior to 4.2.0 | If the variables declared in the class of which the object is an instance, have not been assigned a value, those will not be returned in the array

范例

Example #2 Use of get_object_vars()

<?php

class foo {
    private $a;
    public $b = 1;
    public $c;
    private $d;
    static $e;

    public function test() {
        var_dump(get_object_vars($this));
    }
}

$test = new foo;
var_dump(get_object_vars($test));

$test->test();

?>

以上例程会输出：

array(2) {
  ["b"]=>
  int(1)
  ["c"]=>
  NULL
}
array(4) {
  ["a"]=>
  NULL
  ["b"]=>
  int(1)
  ["c"]=>
  NULL
  ["d"]=>
  NULL
}

参见

  • get_class_methods() - 返回由类的方法名组成的数组
  • get_class_vars() - 返回由类的默认属性组成的数组


返回对象或类的父类名

  • ? get_object_vars
  • interface_exists ?
  • PHP Manual
  • 类/对象 函数
  • 返回对象或类的父类名

get_parent_class

(PHP 4, PHP 5, PHP 7, PHP 8)

get_parent_class — 返回对象或类的父类名

说明

get_parent_class ( mixed $obj = ? ) : string

如果 obj 是对象，则返回对象实例 obj 所属类的父类名。

如果 obj 是字符串，则返回以此字符串为名的类的父类名。此功能是在 PHP 4.0.5 中增加的。

Note:

自 PHP 5 起，如果在对象的方法内调用，则 obj 为可选项。

Example #1 使用 get_parent_class()

<?php

class dad {
    function dad()
    {
    // implements some logic
    }
}

class child extends dad {
    function child()
    {
        echo "I'm " , get_parent_class($this) , "'s son\n";
    }
}

class child2 extends dad {
    function child2()
    {
        echo "I'm " , get_parent_class('child2') , "'s son too\n";
    }
}

$foo = new child();
$bar = new child2();

?>

以上例程会输出：

I'm dad's son
I'm dad's son too

参见 get_class() 和 is_subclass_of()。

参数

object

The tested object or class name

返回值

Returns the name of the parent class of the class of which object is an instance or the name.

Note:

If the object does not have a parent or the class given does not exist false will be returned.

If called without parameter outside object, this function returns false.

更新日志

版本 | 说明
Before 5.1.0 | If called without parameter outside object, this function would have returned null with a warning.
Since 5.0.0 | The object parameter is optional if called from the object's method.
Since 4.0.5 | If object is a string, returns the name of the parent class of the class with that name.

范例

Example #2 Using get_parent_class()

<?php

class dad {
    function dad()
    {
    // implements some logic
    }
}

class child extends dad {
    function child()
    {
        echo "I'm " , get_parent_class($this) , "'s son\n";
    }
}

class child2 extends dad {
    function child2()
    {
        echo "I'm " , get_parent_class('child2') , "'s son too\n";
    }
}

$foo = new child();
$bar = new child2();

?>

以上例程会输出：

I'm dad's son
I'm dad's son too

参见

  • get_class() - 返回对象的类名
  • is_subclass_of() - 如果此对象是该类的子类，则返回 true


检查接口是否已被定义

  • ? get_parent_class
  • is_a ?
  • PHP Manual
  • 类/对象 函数
  • 检查接口是否已被定义

interface_exists

(PHP 5 >= 5.0.2, PHP 7, PHP 8)

interface_exists — 检查接口是否已被定义

说明

interface_exists ( string $interface_name , bool $autoload = true ) : bool

检查接口是否已被定义。

参数

interface_name

接口名。

autoload

默认是否调用 __autoload。

返回值

本函数在由 interface_name 给出的接口已定义时返回 true，否则返回 false。

范例

Example #1 interface_exists() 例子

<?php
// 在尝试使用前先检查接口是否存在
if (interface_exists('MyInterface')) {
    class MyClass implements MyInterface
    {
        // Methods
    }
}

?>

参见

  • get_declared_interfaces() - 返回一个数组包含所有已声明的接口
  • class_implements() - 返回指定的类实现的所有接口。
  • class_exists() - 检查类是否已定义


如果对象属于该类或该类是此对象的父类则返回 true

  • ? interface_exists
  • is_subclass_of ?
  • PHP Manual
  • 类/对象 函数
  • 如果对象属于该类或该类是此对象的父类则返回 true

is_a

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

is_a — 如果对象属于该类或该类是此对象的父类则返回 true

说明

is_a ( mixed $object , string $class_name , bool $allow_string = false ) : bool

如果 object 是该类或该类是此对象的父类。

参数

object

类名或者实例对象。

class_name

类名

allow_string

如果本参数设置为 false，object 就不允许传入字符串类名。 这也会在类不存在时，阻止调用自动加载器（autoloader）。

返回值

如果对象属于该类或该类是此对象的父类时返回 true，否则返回 false。

范例

Example #1 is_a() 例子

<?php
// define a class
class WidgetFactory
{
  var $oink = 'moo';
}

// create a new object
$WF = new WidgetFactory();

if (is_a($WF, 'WidgetFactory')) {
  echo "yes, \$WF is still a WidgetFactory\n";
}
?>

Example #2 在 PHP 5 中使用 instanceof 运算符

<?php
if ($WF instanceof WidgetFactory) {
    echo 'Yes, $WF is a WidgetFactory';
}
?>

参见

  • get_class() - 返回对象的类名
  • get_parent_class() - 返回对象或类的父类名
  • is_subclass_of() - 如果此对象是该类的子类，则返回 true


如果此对象是该类的子类，则返回 true

  • ? is_a
  • method_exists ?
  • PHP Manual
  • 类/对象 函数
  • 如果此对象是该类的子类，则返回 true

is_subclass_of

(PHP 4, PHP 5, PHP 7, PHP 8)

is_subclass_of — 如果此对象是该类的子类，则返回 true

说明

is_subclass_of ( object $object , string $class_name ) : bool

如果对象 object 所属类是类 class_name 的子类，则返回 true，否则返回 false。

Note:

自 PHP 5.0.3 起也可以用一个字符串来指定 object 参数（类名）。

Example #1 is_subclass_of() 例子

<?php
// define a class
class WidgetFactory
{
  var $oink = 'moo';
}

// define a child class
class WidgetFactory_Child extends WidgetFactory
{
  var $oink = 'oink';
}

// create a new object
$WF = new WidgetFactory();
$WFC = new WidgetFactory_Child();

if (is_subclass_of($WFC, 'WidgetFactory')) {
  echo "yes, \$WFC is a subclass of WidgetFactory\n";
} else {
  echo "no, \$WFC is not a subclass of WidgetFactory\n";
}

if (is_subclass_of($WF, 'WidgetFactory')) {
  echo "yes, \$WF is a subclass of WidgetFactory\n";
} else {
  echo "no, \$WF is not a subclass of WidgetFactory\n";
}

// usable only since PHP 5.0.3
if (is_subclass_of('WidgetFactory_Child', 'WidgetFactory')) {
  echo "yes, WidgetFactory_Child is a subclass of WidgetFactory\n";
} else {
  echo "no, WidgetFactory_Child is not a subclass of WidgetFactory\n";
}
?>

以上例程会输出：

yes, $WFC is a subclass of WidgetFactory
no, $WF is not a subclass of WidgetFactory
yes, WidgetFactory_Child is a subclass of WidgetFactory

参见 get_class()、
get_parent_class() 和
is_a()。

参数

object

A class name or an object instance

class_name

The class name

allow_string

If this parameter set to false, string class name as object is not allowed. This also prevents from calling autoloader if the class doesn't exist.

返回值

This function returns true if the object object, belongs to a class which is a subclass of class_name, false otherwise.

范例

Example #2 is_subclass_of() example

<?php
// define a class
class WidgetFactory
{
  var $oink = 'moo';
}

// define a child class
class WidgetFactory_Child extends WidgetFactory
{
  var $oink = 'oink';
}

// create a new object
$WF = new WidgetFactory();
$WFC = new WidgetFactory_Child();

if (is_subclass_of($WFC, 'WidgetFactory')) {
  echo "yes, $WFC is a subclass of WidgetFactory\n";
} else {
  echo "no, $WFC is not a subclass of WidgetFactory\n";
}

if (is_subclass_of($WF, 'WidgetFactory')) {
  echo "yes, $WF is a subclass of WidgetFactory\n";
} else {
  echo "no, $WF is not a subclass of WidgetFactory\n";
}

// usable only since PHP 5.0.3
if (is_subclass_of('WidgetFactory_Child', 'WidgetFactory')) {
  echo "yes, WidgetFactory_Child is a subclass of WidgetFactory\n";
} else {
  echo "no, WidgetFactory_Child is not a subclass of WidgetFactory\n";
}
?>

以上例程会输出：

yes, $WFC is a subclass of WidgetFactory
no, $WF is not a subclass of WidgetFactory
yes, WidgetFactory_Child is a subclass of WidgetFactory

注释

Note:

如果此类不是已知类，使用此函数会使用任何已注册的 autoloader。

参见

  • get_class() - 返回对象的类名
  • get_parent_class() - 返回对象或类的父类名
  • is_a() - 如果对象属于该类或该类是此对象的父类则返回 true
  • class_parents() - 返回指定类的父类。


检查类的方法是否存在

  • ? is_subclass_of
  • property_exists ?
  • PHP Manual
  • 类/对象 函数
  • 检查类的方法是否存在

method_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

method_exists — 检查类的方法是否存在

说明

method_exists ( mixed $object , string $method_name ) : bool

检查类的方法是否存在于指定的 object中。

参数

object

对象示例或者类名。

method_name

方法名。

返回值

如果 method_name 所指的方法在 object 所指的对象类中已定义，则返回 true，否则返回 false。

注释

Note:

如果此类不是已知类，使用此函数会使用任何已注册的 autoloader。

范例

Example #1 method_exists() 例子

<?php
$directory = new Directory('.');
var_dump(method_exists($directory,'read'));
?>

以上例程会输出：

bool(true)

Example #2 Static method_exists() 例子

<?php
var_dump(method_exists('Directory','read'));
?>

以上例程会输出：

bool(true)

参见

  • function_exists() - 如果给定的函数已经被定义就返回 true
  • is_callable() - 检测参数是否为合法的可调用结构
  • class_exists() - 检查类是否已定义


检查对象或类是否具有该属性

  • ? method_exists
  • trait_exists ?
  • PHP Manual
  • 类/对象 函数
  • 检查对象或类是否具有该属性

property_exists

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

property_exists — 检查对象或类是否具有该属性

说明

property_exists ( mixed $class , string $property ) : bool

本函数检查给出的 property 是否存在于指定的类中（以及是否能在当前范围内访问）。

Note:

As opposed with isset(), property_exists() returns true even if the property has the value null.

参数

class

字符串形式的类名或要检查的类的一个对象

property

属性的名字

返回值

如果该属性存在则返回 true，如果不存在则返回 false，出错返回 null。

注释

Note:

如果此类不是已知类，使用此函数会使用任何已注册的 autoloader。

Note:

The property_exists() function cannot detect properties that are magically accessible using the __get magic method.

更新日志

版本 | 说明
5.3.0 | This function checks the existence of a property independent of accessibility.

范例

Example #1 A property_exists() example

<?php

class myClass {
    public $mine;
    private $xpto;
    static protected $test;

    static function test() {
        var_dump(property_exists('myClass', 'xpto')); //true
    }
}

var_dump(property_exists('myClass', 'mine'));   //true
var_dump(property_exists(new myClass, 'mine')); //true
var_dump(property_exists('myClass', 'xpto'));   //true, as of PHP 5.3.0
var_dump(property_exists('myClass', 'bar'));    //false
var_dump(property_exists('myClass', 'test'));   //true, as of PHP 5.3.0
myClass::test();

?>

参见

  • method_exists() - 检查类的方法是否存在


检查指定的 trait 是否存在

  • ? property_exists
  • Classkit ?
  • PHP Manual
  • 类/对象 函数
  • 检查指定的 trait 是否存在

trait_exists

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

trait_exists — 检查指定的 trait 是否存在

说明

trait_exists ( string $traitname , bool $autoload = ? ) : bool

参数

traitname

待检查的 trait 的名称

autoload

如果尚未加载，是否使用自动加载（autoload）。

返回值

如果 trait 存在返回 true，不存在则返回 false。发生错误的时候返回 null。


Classkit

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Classkit 函数
    • classkit_import — Import new class method definitions from a file
    • classkit_method_add — Dynamically adds a new method to a given class
    • classkit_method_copy — Copies a method from class to another
    • classkit_method_redefine — Dynamically changes the code of the given method
    • classkit_method_remove — Dynamically removes the given method
    • classkit_method_rename — Dynamically changes the name of the given method


简介

These functions allow the dynamic manipulation of PHP classes, at runtime.

Note:

This extension has been replaced by runkit, which is not limited to class manipulation but has function manipulation, as well.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Classkit
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

此扩展被认为已无人维护及已消亡。然而，此扩展的源代码还可在 PECL SVN 找到： » https://svn.php.net/viewvc/pecl/classkit.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

CLASSKIT_ACC_PRIVATE (int)
将方法标记为 private
CLASSKIT_ACC_PROTECTED (int)
将方法标记为 protected
CLASSKIT_ACC_PUBLIC (int)
将方法标记为 public


Classkit 函数

Table of Contents

  • classkit_import — Import new class method definitions from a file
  • classkit_method_add — Dynamically adds a new method to a given class
  • classkit_method_copy — Copies a method from class to another
  • classkit_method_redefine — Dynamically changes the code of the given method
  • classkit_method_remove — Dynamically removes the given method
  • classkit_method_rename — Dynamically changes the name of the given method


Import new class method definitions from a file

  • ? Classkit 函数
  • classkit_method_add ?
  • PHP Manual
  • Classkit 函数
  • Import new class method definitions from a file

classkit_import

(PECL classkit >= 0.3)

classkit_import — Import new class method definitions from a file

说明

classkit_import ( string $filename ) : array

Note: 此函数不能用来操作当前正常运行（或运行链上）的方法。

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

filename

The filename of the class method definitions to import

返回值

Associative array of imported methods

范例

Example #1 classkit_import() example

<?php
// file: newclass.php
class Example {
    function foo() {
        return "bar!\n";
    }
}
?>
<?php
// requires newclass.php (see above)
class Example {
    function foo() {
        return "foo!\n";
    }
}

$e = new Example();

// output original
echo $e->foo();

// import replacement method
classkit_import('newclass.php');

// output imported
echo $e->foo();

?>

以上例程会输出：

foo!
bar!

参见

  • classkit_method_add() - Dynamically adds a new method to a given class
  • classkit_method_copy() - Copies a method from class to another


Dynamically adds a new method to a given class

  • ? classkit_import
  • classkit_method_copy ?
  • PHP Manual
  • Classkit 函数
  • Dynamically adds a new method to a given class

classkit_method_add

(PECL classkit >= 0.1)

classkit_method_add — Dynamically adds a new method to a given class

说明

classkit_method_add ( string $classname , string $methodname , string $args , string $code , int $flags = CLASSKIT_ACC_PUBLIC ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

classname

The class to which this method will be added

methodname

The name of the method to add

args

Comma-delimited list of arguments for the newly-created method

code

The code to be evaluated when methodname is called

flags

The type of method to create, can be CLASSKIT_ACC_PUBLIC, CLASSKIT_ACC_PROTECTED or CLASSKIT_ACC_PRIVATE

Note:

This parameter is only used as of PHP 5, because, prior to this, all methods were public.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 classkit_method_add() example

<?php
class Example {
    function foo() {
        echo "foo!\n";
    }
}

// create an Example object
$e = new Example();

// Add a new public method
classkit_method_add(
    'Example',
    'add',
    '$num1, $num2',
    'return $num1 + $num2;',
    CLASSKIT_ACC_PUBLIC
);

// add 12 + 4
echo $e->add(12, 4);
?>

以上例程会输出：

16

参见

  • classkit_method_copy() - Copies a method from class to another
  • classkit_method_redefine() - Dynamically changes the code of the given method
  • classkit_method_remove() - Dynamically removes the given method
  • classkit_method_rename() - Dynamically changes the name of the given method
  • create_function() - Create an anonymous (lambda-style) function


Copies a method from class to another

  • ? classkit_method_add
  • classkit_method_redefine ?
  • PHP Manual
  • Classkit 函数
  • Copies a method from class to another

classkit_method_copy

(PECL classkit >= 0.2)

classkit_method_copy — Copies a method from class to another

说明

classkit_method_copy ( string $dClass , string $dMethod , string $sClass , string $sMethod = ? ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

dClass

Destination class for copied method

dMethod

Destination method name

sClass

Source class of the method to copy

sMethod

Name of the method to copy from the source class. If this parameter is omitted, the value of dMethod is assumed.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 classkit_method_copy() example

<?php
class Foo {
    function example() {
        return "foo!\n";
    }
}

class Bar {
    // initially, no methods
}

// copy the example() method from the Foo class to the Bar class, as baz()
classkit_method_copy('Bar', 'baz', 'Foo', 'example');

// output copied function
echo Bar::baz();
?>

以上例程会输出：

foo!

参见

  • classkit_method_add() - Dynamically adds a new method to a given class
  • classkit_method_redefine() - Dynamically changes the code of the given method
  • classkit_method_remove() - Dynamically removes the given method
  • classkit_method_rename() - Dynamically changes the name of the given method


Dynamically changes the code of the given method

  • ? classkit_method_copy
  • classkit_method_remove ?
  • PHP Manual
  • Classkit 函数
  • Dynamically changes the code of the given method

classkit_method_redefine

(PECL classkit >= 0.1)

classkit_method_redefine — Dynamically changes the code of the given method

说明

classkit_method_redefine ( string $classname , string $methodname , string $args , string $code , int $flags = CLASSKIT_ACC_PUBLIC ) : bool

Note: 此函数不能用来操作当前正常运行（或运行链上）的方法。

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

classname

The class in which to redefine the method

methodname

The name of the method to redefine

args

Comma-delimited list of arguments for the redefined method

code

The new code to be evaluated when methodname is called

flags

The redefined method can be CLASSKIT_ACC_PUBLIC, CLASSKIT_ACC_PROTECTED or CLASSKIT_ACC_PRIVATE

Note:

This parameter is only used as of PHP 5, because, prior to this, all methods were public.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 classkit_method_redefine() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// create an Example object
$e = new Example();

// output Example::foo() (before redefine)
echo "Before: " . $e->foo();

// Redefine the 'foo' method
classkit_method_redefine(
    'Example',
    'foo',
    '',
    'return "bar!\n";',
    CLASSKIT_ACC_PUBLIC
);

// output Example::foo() (after redefine)
echo "After: " . $e->foo();
?>

以上例程会输出：

Before: foo!
After: bar!

参见

  • classkit_method_add() - Dynamically adds a new method to a given class
  • classkit_method_copy() - Copies a method from class to another
  • classkit_method_remove() - Dynamically removes the given method
  • classkit_method_rename() - Dynamically changes the name of the given method


Dynamically removes the given method

  • ? classkit_method_redefine
  • classkit_method_rename ?
  • PHP Manual
  • Classkit 函数
  • Dynamically removes the given method

classkit_method_remove

(PECL classkit >= 0.1)

classkit_method_remove — Dynamically removes the given method

说明

classkit_method_remove ( string $classname , string $methodname ) : bool

Note: 此函数不能用来操作当前正常运行（或运行链上）的方法。

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

classname

The class in which to remove the method

methodname

The name of the method to remove

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 classkit_method_remove() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }

    function bar() {
        return "bar!\n";
    }
}

// Remove the 'foo' method
classkit_method_remove(
    'Example',
    'foo'
);

echo implode(' ', get_class_methods('Example'));

?>

以上例程会输出：

bar

参见

  • classkit_method_add() - Dynamically adds a new method to a given class
  • classkit_method_copy() - Copies a method from class to another
  • classkit_method_redefine() - Dynamically changes the code of the given method
  • classkit_method_rename() - Dynamically changes the name of the given method


Dynamically changes the name of the given method

  • ? classkit_method_remove
  • Ctype ?
  • PHP Manual
  • Classkit 函数
  • Dynamically changes the name of the given method

classkit_method_rename

(PECL classkit >= 0.1)

classkit_method_rename — Dynamically changes the name of the given method

说明

classkit_method_rename ( string $classname , string $methodname , string $newname ) : bool

Note: 此函数不能用来操作当前正常运行（或运行链上）的方法。

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

classname

The class in which to rename the method

methodname

The name of the method to rename

newname

The new name to give to the renamed method

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 classkit_method_rename() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// Rename the 'foo' method to 'bar'
classkit_method_rename(
    'Example',
    'foo',
    'bar'
);

// output renamed function
echo Example::bar();
?>

以上例程会输出：

foo!

参见

  • classkit_method_add() - Dynamically adds a new method to a given class
  • classkit_method_copy() - Copies a method from class to another
  • classkit_method_redefine() - Dynamically changes the code of the given method
  • classkit_method_remove() - Dynamically removes the given method


字符类型检测

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Ctype 函数
    • ctype_alnum — 做字母和数字字符检测
    • ctype_alpha — 做纯字符检测
    • ctype_cntrl — 做控制字符检测
    • ctype_digit — 做纯数字检测
    • ctype_graph — 做可打印字符串检测，空格除外
    • ctype_lower — 做小写字符检测
    • ctype_print — 做可打印字符检测
    • ctype_punct — 检测可打印的字符是不是不包含空白、数字和字母
    • ctype_space — 做空白字符检测
    • ctype_upper — 做大写字母检测
    • ctype_xdigit — 检测字符串是否只包含十六进制字符


简介

该扩展所提供的函数用来检测 在当前的区域设定下（参见 setlocale()），一个字符或者字符串 是否仅包含指定类型的字符。

当使用整数作为参数调用这些函数的时候， 这些函数的行为和 C 语言（ctype.h） 中的对应函数一样。 也就是说，如果传入了小于 256 的整数参数，它会把这个整数当做 ASCII 码值， 来检测对应字符是否符合要求（数值检测的 ASCII 值范围为 0x30-0x39）。 如果传入的参数介于 -128 和 -1 之间（含 -128 和 -1），它会先将其加上 256，然后再进行检测。

当传入参数为字符串的时候，它会对字符串中的每个字符进行检测， 仅当字符串中的每个字符都符合指定条件的情况下才会返回 true。 在 PHP 5.1 之前的版本中，如果传入空字符串总是会返回 true， 从 PHP 5.1 开始，传入空字符串总是会返回 false。

传入除整数和字符串之外的参数 会立即返回 false。

需要提醒的是，如果可以满足需求，请优先考虑使用 ctype 函数， 而不是正则表达式或者对应的 "str_*" 和 "is_*" 函数。 因为 ctype 使用的是原生 C 库，所以会有明显的性能优势。

Note:

这些函数和 Python 中的 "ctypes" 库没有任何关系。 ctype 的名字源自对应的 C 语言中的头文件 ctype.h。

实际上，这个扩展是先于 Python 的 "ctypes" 的， 如果这个命名给你带来困扰，那也不是我们的错误 ...


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

无额外需求，因为标准 C 库中的函数总是可用的。


安装

可以使用 --disable-ctype 配置项来禁用 ctype 扩展。

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。


  • ? 资源类型
  • Ctype 函数 ?
  • PHP Manual
  • Ctype
  • 预定义常量

预定义常量

此扩展没有定义常量。


Ctype 函数

Table of Contents

  • ctype_alnum — 做字母和数字字符检测
  • ctype_alpha — 做纯字符检测
  • ctype_cntrl — 做控制字符检测
  • ctype_digit — 做纯数字检测
  • ctype_graph — 做可打印字符串检测，空格除外
  • ctype_lower — 做小写字符检测
  • ctype_print — 做可打印字符检测
  • ctype_punct — 检测可打印的字符是不是不包含空白、数字和字母
  • ctype_space — 做空白字符检测
  • ctype_upper — 做大写字母检测
  • ctype_xdigit — 检测字符串是否只包含十六进制字符


做字母和数字字符检测

  • ? Ctype 函数
  • ctype_alpha ?
  • PHP Manual
  • Ctype 函数
  • 做字母和数字字符检测

ctype_alnum

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_alnum — 做字母和数字字符检测

说明

ctype_alnum ( string $text ) : bool

检查提供的string,text 是否全部为字母和(或)数字字符。

参数

text

测试字符串。

返回值

如果text中所有的字符全部是字母和(或者)数字，返回 true 否则返回false

范例

Example #1 A ctype_alnum() 示例 (使用默认的区域设置)

<?php
$strings = array('AbCd1zyZ9', 'foo!#$bar');
foreach ($strings as $testcase) {
    if (ctype_alnum($testcase)) {
        echo "The string $testcase consists of all letters or digits.\n";
    } else {
        echo "The string $testcase does not consist of all letters or digits.\n";
    }
}
?>

以上例程会输出：

The string AbCd1zyZ9 consists of all letters or digits.
The string foo!#$bar does not consist of all letters or digits.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_alpha() - 做纯字符检测
  • ctype_digit() - 做纯数字检测
  • setlocale() - 设置地区信息


做纯字符检测

  • ? ctype_alnum
  • ctype_cntrl ?
  • PHP Manual
  • Ctype 函数
  • 做纯字符检测

ctype_alpha

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_alpha — 做纯字符检测

说明

ctype_alpha ( string $text ) : bool

查看提供的string，text里面的所有字符是否只包含字符。 在标准的 C 语言环境下，字母仅仅是指 [A-Za-z] ， ctype_alpha() 等同于 (ctype_upper($text) || ctype_lower($text)) 如果 text 是简单的单个字符串还好，但是在其他语言中有些字母被认为既不是大写也不是小写。

参数

text

被测试的字符串。

返回值

如果在当前语言环境中 text 里的每个字符都是一个字母，那么就返回true，反之则返回false。

范例

Example #1 一个 ctype_alpha() 例子（使用默认的语言环境）

<?php
$strings = array('KjgWZC', 'arf12');
foreach ($strings as $testcase) {
    if (ctype_alpha($testcase)) {
        echo "The string $testcase consists of all letters.\n";
    } else {
        echo "The string $testcase does not consist of all letters.\n";
    }
}
?>

以上例程会输出：

The string KjgWZC consists of all letters.
The string arf12 does not consist of all letters.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_upper() - 做大写字母检测
  • ctype_lower() - 做小写字符检测
  • setlocale() - 设置地区信息


做控制字符检测

  • ? ctype_alpha
  • ctype_digit ?
  • PHP Manual
  • Ctype 函数
  • 做控制字符检测

ctype_cntrl

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_cntrl — 做控制字符检测

说明

ctype_cntrl ( string $text ) : bool

检查提供的 string 和 text 里面的字符是不是都是控制字符。 控制字符就是例如：换行、缩进、空格。

参数

text

需要被测试的字符串。

返回值

如果在当前的语言环境下 text 里面的每个字符都是控制字符，就返回 true ；反之就返回 false 。

范例

Example #1 一个 ctype_cntrl() 例子

<?php
$strings = array('string1' => "\n\r\t", 'string2' => 'arf12');
foreach ($strings as $name => $testcase) {
    if (ctype_cntrl($testcase)) {
        echo "The string '$name' consists of all control characters.\n";
    } else {
        echo "The string '$name' does not consist of all control characters.\n";
    }
}
?>

以上例程会输出：

The string 'string1' consists of all control characters.
The string 'string2' does not consist of all control characters.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_print() - 做可打印字符检测


做纯数字检测

  • ? ctype_cntrl
  • ctype_graph ?
  • PHP Manual
  • Ctype 函数
  • 做纯数字检测

ctype_digit

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_digit — 做纯数字检测

说明

ctype_digit ( string $text ) : bool

检查提供的 string 和 text 里面的字符是不是都是数字。

参数

text

需要被测试的字符串。

返回值

如果 text 字符串是一个十进制数字，就返回 true ；反之就返回 false 。

更新日志

版本 | 说明
5.1.0 | 在 PHP 5.1.0 之前，当 text 是一个空字符串的时候，该函数将返回 true 。

范例

Example #1 一个 ctype_digit() 例子

<?php
$strings = array('1820.20', '10002', 'wsl!12');
foreach ($strings as $testcase) {
    if (ctype_digit($testcase)) {
        echo "The string $testcase consists of all digits.\n";
    } else {
        echo "The string $testcase does not consist of all digits.\n";
    }
}
?>

以上例程会输出：

The string 1820.20 does not consist of all digits.
The string 10002 consists of all digits.
The string wsl!12 does not consist of all digits.

Example #2 一个通过 ctype_digit() 来比对字符和整数的例子。

<?php

$numeric_string = '42';
$integer        = 42;

ctype_digit($numeric_string);  // true
ctype_digit($integer);         // false (ASCII 42 is the * character)

is_numeric($numeric_string);   // true
is_numeric($integer);          // true
?>

注释

Note:

这个函数的参数要求是一个 string 这一点是非常有用的，因此当你传入一个 integer 的参数也许不能得到期望的结果。然后，同样需要注意HTML表单将会返回数字字符串而不是一个整型。 看下手册的 types 章节。

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_alnum() - 做字母和数字字符检测
  • ctype_xdigit() - 检测字符串是否只包含十六进制字符
  • is_numeric() - 检测变量是否为数字或数字字符串
  • is_int() - 检测变量是否是整数
  • is_string() - 检测变量是否是字符串


做可打印字符串检测，空格除外

  • ? ctype_digit
  • ctype_lower ?
  • PHP Manual
  • Ctype 函数
  • 做可打印字符串检测，空格除外

ctype_graph

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_graph — 做可打印字符串检测，空格除外

说明

ctype_graph ( string $text ) : bool

检查提供的 string 和 text 里面的字符输出都是可见的。

参数

text

需要被测试的字符串。

返回值

如果 text 里面的每个字符都是输出可见的（没有空白），就返回 true ；反之就返回 false 。

范例

Example #1 一个 ctype_graph() 例子

<?php
$strings = array('string1' => "asdf\n\r\t", 'string2' => 'arf12', 'string3' => 'LKA#@%.54');
foreach ($strings as $name => $testcase) {
    if (ctype_graph($testcase)) {
        echo "The string '$name' consists of all (visibly) printable characters.\n";
    } else {
        echo "The string '$name' does not consist of all (visibly) printable characters.\n";
    }
}
?>

以上例程会输出：

The string 'string1' does not consist of all (visibly) printable characters.
The string 'string2' consists of all (visibly) printable characters.
The string 'string3' consists of all (visibly) printable characters.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_alnum() - 做字母和数字字符检测
  • ctype_print() - 做可打印字符检测
  • ctype_punct() - 检测可打印的字符是不是不包含空白、数字和字母


做小写字符检测

  • ? ctype_graph
  • ctype_print ?
  • PHP Manual
  • Ctype 函数
  • 做小写字符检测

ctype_lower

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_lower — 做小写字符检测

说明

ctype_lower ( string $text ) : bool

检查提供的 string 和 text 里面的字符是不是都是小写字母。

参数

text

需要被测试的字符串。

返回值

如果在当前的语言环境下 text 里面的每个字符都是小写字母，就返回 true ；反之就返回 false 。

范例

Example #1 一个 ctype_lower() 例子 (使用默认的语言环境)

<?php
$strings = array('aac123', 'qiutoas', 'QASsdks');
foreach ($strings as $testcase) {
    if (ctype_lower($testcase)) {
        echo "The string $testcase consists of all lowercase letters.\n";
    } else {
        echo "The string $testcase does not consist of all lowercase letters.\n";
    }
}
?>

以上例程会输出：

The string aac123 does not consist of all lowercase letters.
The string qiutoas consists of all lowercase letters.
The string QASsdks does not consist of all lowercase letters.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_alpha() - 做纯字符检测
  • ctype_upper() - 做大写字母检测
  • setlocale() - 设置地区信息


做可打印字符检测

  • ? ctype_lower
  • ctype_punct ?
  • PHP Manual
  • Ctype 函数
  • 做可打印字符检测

ctype_print

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_print — 做可打印字符检测

说明

ctype_print ( string $text ) : bool

检查提供的 string 和 text 里面的字符是不是都是可以打印出来。

参数

text

需要被测试的字符串。

返回值

如果在当前的语言环境下 text 里面的每个字符都能被实际输出（包括空白），就返回 true ；如果 text 里面包含控制字符或者那些根本不会有任何输出的字符串，就返回 false 。

范例

Example #1 一个 ctype_print() 例子

<?php
$strings = array('string1' => "asdf\n\r\t", 'string2' => 'arf12', 'string3' => 'LKA#@%.54');
foreach ($strings as $name => $testcase) {
    if (ctype_print($testcase)) {
        echo "The string '$name' consists of all printable characters.\n";
    } else {
        echo "The string '$name' does not consist of all printable characters.\n";
    }
}
?>

以上例程会输出：

The string 'string1' does not consist of all printable characters.
The string 'string2' consists of all printable characters.
The string 'string3' consists of all printable characters.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_cntrl() - 做控制字符检测
  • ctype_graph() - 做可打印字符串检测，空格除外
  • ctype_punct() - 检测可打印的字符是不是不包含空白、数字和字母


检测可打印的字符是不是不包含空白、数字和字母

  • ? ctype_print
  • ctype_space ?
  • PHP Manual
  • Ctype 函数
  • 检测可打印的字符是不是不包含空白、数字和字母

ctype_punct

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_punct — 检测可打印的字符是不是不包含空白、数字和字母

说明

ctype_punct ( string $text ) : bool

检查提供的 string 和 text 里面的字符是不是都是标点符号。

参数

text

需要被测试的字符串。

返回值

如果在 text 里面的每个字符都是能打印的，但不是字母、数字，也不是空白，那么就返回 true ；反之则返回 false 。

范例

Example #1 一个 ctype_punct() 的例子

<?php
$strings = array('ABasdk!@!$#', '!@ # $', '*&$()');
foreach ($strings as $testcase) {
    if (ctype_punct($testcase)) {
        echo "The string $testcase consists of all punctuation.\n";
    } else {
        echo "The string $testcase does not consist of all punctuation.\n";
    }
}
?>

以上例程会输出：

The string ABasdk!@!$# does not consist of all punctuation.
The string !@ # $ does not consist of all punctuation.
The string *&$() consists of all punctuation.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_cntrl() - 做控制字符检测
  • ctype_graph() - 做可打印字符串检测，空格除外


做空白字符检测

  • ? ctype_punct
  • ctype_upper ?
  • PHP Manual
  • Ctype 函数
  • 做空白字符检测

ctype_space

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_space — 做空白字符检测

说明

ctype_space ( string $text ) : bool

检查提供的 string 和 text 里面的字符是否包含空白。

参数

text

需要被测试的字符串。

返回值

如果 text 里面的每个字符最终被实际输出的时候都是某种形式的空白，就返回 true ；否则返回 false 。 除了空白字符，还包括缩进，垂直制表符，换行符，回车和换页字符。

范例

Example #1 一个 ctype_space() 例子

<?php
$strings = array('string1' => "\n\r\t", 'string2' => "\narf12", 'string3' => '\n\r\t');
foreach ($strings as $name => $testcase) {
    if (ctype_space($testcase)) {
        echo "The string '$name' consists of all whitespace characters.\n";
    } else {
        echo "The string '$name' does not consist of all whitespace characters.\n";
    }
}
?>

以上例程会输出：

The string 'string1' consists of all whitespace characters.
The string 'string2' does not consist of all whitespace characters.
The string 'string3' does not consist of all whitespace characters.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_cntrl() - 做控制字符检测
  • ctype_graph() - 做可打印字符串检测，空格除外
  • ctype_punct() - 检测可打印的字符是不是不包含空白、数字和字母


做大写字母检测

  • ? ctype_space
  • ctype_xdigit ?
  • PHP Manual
  • Ctype 函数
  • 做大写字母检测

ctype_upper

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_upper — 做大写字母检测

说明

ctype_upper ( string $text ) : bool

检查 string 和 text 里面的字符是不是都是大写字母。

参数

text

需要被测试的字符串。

返回值

在当前语言环境下，如果 text 里面的每个字符都是大写字母，就返回 true。

范例

Example #1 一个 ctype_upper() 例子 （使用当前默认语言环境）

<?php
$strings = array('AKLWC139', 'LMNSDO', 'akwSKWsm');
foreach ($strings as $testcase) {
    if (ctype_upper($testcase)) {
        echo "The string $testcase consists of all uppercase letters.\n";
    } else {
        echo "The string $testcase does not consist of all uppercase letters.\n";
    }
}
?>

以上例程会输出：

The string AKLWC139 does not consist of all uppercase letters.
The string LMNSDO consists of all uppercase letters.
The string akwSKWsm does not consist of all uppercase letters.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_alpha() - 做纯字符检测
  • ctype_lower() - 做小写字符检测
  • setlocale() - 设置地区信息


检测字符串是否只包含十六进制字符

  • ? ctype_upper
  • Filter ?
  • PHP Manual
  • Ctype 函数
  • 检测字符串是否只包含十六进制字符

ctype_xdigit

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

ctype_xdigit — 检测字符串是否只包含十六进制字符

说明

ctype_xdigit ( string $text ) : bool

检查 string 和 text 里面的字符是不是都是十六进制字符串。

参数

text

需要被测试的字符串。

返回值

如果 text 里面的每个字符都是十六进制字符。也就是只能包含十进制的树枝和 [A-Fa-f] 的字母。否则，返回 false 。

范例

Example #1 一个 ctype_xdigit() 的例子

<?php
$strings = array('AB10BC99', 'AR1012', 'ab12bc99');
foreach ($strings as $testcase) {
    if (ctype_xdigit($testcase)) {
        echo "The string $testcase consists of all hexadecimal digits.\n";
    } else {
        echo "The string $testcase does not consist of all hexadecimal digits.\n";
    }
}
?>

以上例程会输出：

The string AB10BC99 consists of all hexadecimal digits.
The string AR1012 does not consist of all hexadecimal digits.
The string ab12bc99 consists of all hexadecimal digits.

注释

Note:

如果给出一个 -128 到 255 之间(含)的int, 将会被解释为该值对应的ASCII字符 (负值将加上 256 以支持扩展ASCII字符). 其它整数将会被解释为该值对应的十进制字符串.

参见

  • ctype_digit() - 做纯数字检测


Data Filtering

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • Types of filters
    • Validate filters
    • Sanitize filters
    • Other filters
    • Filter flags
  • 预定义常量
  • 范例
    • Validation
    • Sanitization
  • 过滤器函数
    • filter_has_var — 检测是否存在指定类型的变量
    • filter_id — 返回与某个特定名称的过滤器相关联的id
    • filter_input_array — 获取一系列外部变量，并且可以通过过滤器处理它们
    • filter_input — 通过名称获取特定的外部变量，并且可以通过过滤器处理它
    • filter_list — 返回所支持的过滤器列表
    • filter_var_array — 获取多个变量并且过滤它们
    • filter_var — 使用特定的过滤器过滤一个变量


简介

This extension filters data by either validating or sanitizing it. This is especially useful when the data source contains unknown (or foreign) data, like user supplied input. For example, this data may come from an HTML form.

There are two main types of filtering: validation and sanitization.

Validation is used to validate or check if the data meets certain qualifications. For example, passing in FILTER_VALIDATE_EMAIL will determine if the data is a valid email address, but will not change the data itself.

Sanitization will sanitize the data, so it may alter it by removing undesired characters. For example, passing in FILTER_SANITIZE_EMAIL will remove characters that are inappropriate for an email address to contain. That said, it does not validate the data.

Flags are optionally used with both validation and sanitization to tweak behaviour according to need. For example, passing in FILTER_FLAG_PATH_REQUIRED while filtering an URL will require a path (like /foo in http://example.org/foo) to be present.


安装

The filter extension is enabled by default as of PHP 5.2.0. To disable the filter extension, use --disable-filter.

Before PHP 5.2 an experimental PECL extension was used, however, the PECL version is no longer recommended or updated.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Filter Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
filter.default | "unsafe_raw" | PHP_INI_PERDIR | PHP_INI_ALL in filter <= 0.9.4. Available since PHP 5.2.0.
filter.default_flags | NULL | PHP_INI_PERDIR | PHP_INI_ALL in filter <= 0.9.4. Available since PHP 5.2.0.
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

filter.default string

Filter all $_GET, $_POST, $_COOKIE, $_REQUEST and $_SERVER data by this filter. Original data can be accessed through filter_input().

Accepts the name of the filter you like to use by default. See the existing filter list for the list of the filter names.

Note:

Be careful about the default flags for the default filters. You should explicitly set them to the value you want. For example, to configure the default filter to behave exactly like htmlspecialchars() you need to set them default flags to 0 as shown below.

Example #1 Configuring the default filter to act like htmlspecialchars

filter.default = full_special_chars
filter.default_flags = 0

filter.default_flags int

Default flags to apply when the default filter is set. This is set to FILTER_FLAG_NO_ENCODE_QUOTES by default for backwards compatibility reasons. See the flag list for the list of all the flag names.


  • ? 运行时配置
  • Types of filters ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


Types of filters

Table of Contents

  • Validate filters
  • Sanitize filters
  • Other filters
  • Filter flags


Validate filters

Listing of filters for validation
ID | Name | Options | Flags | Description
FILTER_VALIDATE_BOOLEAN | "boolean" | default | FILTER_NULL_ON_FAILURE | Returns true for "1", "true", "on" and "yes". Returns false otherwise. If FILTER_NULL_ON_FAILURE is set, false is returned only for "0", "false", "off", "no", and "", and null is returned for all non-boolean values.
FILTER_VALIDATE_DOMAIN | "validate_domain" | default | FILTER_FLAG_HOSTNAME | Validates whether the domain name label lengths are valid. Validates domain names against RFC 1034, RFC 1035, RFC 952, RFC 1123, RFC 2732, RFC 2181, and RFC 1123. Optional flag FILTER_FLAG_HOSTNAME adds ability to specifically validate hostnames (they must start with an alphanumeric character and contain only alphanumerics or hyphens).
FILTER_VALIDATE_EMAIL | "validate_email" | default | FILTER_FLAG_EMAIL_UNICODE | Validates whether the value is a valid e-mail address. In general, this validates e-mail addresses against the syntax in RFC 822, with the exceptions that comments and whitespace folding and dotless domain names are not supported.
FILTER_VALIDATE_FLOAT | "float" | default, decimal, min_range, max_range | FILTER_FLAG_ALLOW_THOUSAND | Validates value as float, optionally from the specified range, and converts to float on success.
FILTER_VALIDATE_INT | "int" | default, min_range, max_range | FILTER_FLAG_ALLOW_OCTAL, FILTER_FLAG_ALLOW_HEX | Validates value as integer, optionally from the specified range, and converts to int on success.
FILTER_VALIDATE_IP | "validate_ip" | default | FILTER_FLAG_IPV4, FILTER_FLAG_IPV6, FILTER_FLAG_NO_PRIV_RANGE, FILTER_FLAG_NO_RES_RANGE | Validates value as IP address, optionally only IPv4 or IPv6 or not from private or reserved ranges.
FILTER_VALIDATE_MAC | "validate_mac_address" | default |  | Validates value as MAC address.
FILTER_VALIDATE_REGEXP | "validate_regexp" | default, regexp |  | Validates value against regexp, a Perl-compatible regular expression.
FILTER_VALIDATE_URL | "validate_url" | default | FILTER_FLAG_SCHEME_REQUIRED, FILTER_FLAG_HOST_REQUIRED, FILTER_FLAG_PATH_REQUIRED, FILTER_FLAG_QUERY_REQUIRED | Validates value as URL (according to » http://www.faqs.org/rfcs/rfc2396), optionally with required components. Beware a valid URL may not specify the HTTP protocol http:// so further validation may be required to determine the URL uses an expected protocol, e.g. ssh:// or mailto:. Note that the function will only find ASCII URLs to be valid; internationalized domain names (containing non-ASCII characters) will fail.

Note:

As of PHP 5.4.11, the numbers +0 and -0 validate as both integers as well as floats (using FILTER_VALIDATE_FLOAT and FILTER_VALIDATE_INT). Before PHP 5.4.11 they only validated as floats (using FILTER_VALIDATE_FLOAT).

When default is set to option, default's value is used if value is not validated.

更新日志

版本 | 说明
7.4.0 | Added min_range and max_range options for FILTER_VALIDATE_FLOAT.
7.0.0 | Added FILTER_FLAG_HOSTNAME and FILTER_VALIDATE_DOMAIN.
5.5.0 | Added FILTER_VALIDATE_MAC.
5.2.1 | FILTER_VALIDATE_URL now implicitly uses FILTER_FLAG_SCHEME_REQUIRED and FILTER_FLAG_HOST_REQUIRED.


Sanitize filters

List of filters for sanitization
ID | Name | Flags | Description
FILTER_SANITIZE_EMAIL | "email" |  | Remove all characters except letters, digits and !#$%&'*+-=?^_`{|}~@.[].
FILTER_SANITIZE_ENCODED | "encoded" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_STRIP_BACKTICK, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH | URL-encode string, optionally strip or encode special characters.
FILTER_SANITIZE_MAGIC_QUOTES | "magic_quotes" |  | Apply addslashes().
FILTER_SANITIZE_NUMBER_FLOAT | "number_float" | FILTER_FLAG_ALLOW_FRACTION, FILTER_FLAG_ALLOW_THOUSAND, FILTER_FLAG_ALLOW_SCIENTIFIC | Remove all characters except digits, +- and optionally .,eE.
FILTER_SANITIZE_NUMBER_INT | "number_int" |  | Remove all characters except digits, plus and minus sign.
FILTER_SANITIZE_SPECIAL_CHARS | "special_chars" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_STRIP_BACKTICK, FILTER_FLAG_ENCODE_HIGH | HTML-escape '"<>& and characters with ASCII value less than 32, optionally strip or encode other special characters.
FILTER_SANITIZE_FULL_SPECIAL_CHARS | "full_special_chars" | FILTER_FLAG_NO_ENCODE_QUOTES, | Equivalent to calling htmlspecialchars() with ENT_QUOTES set. Encoding quotes can be disabled by setting FILTER_FLAG_NO_ENCODE_QUOTES. Like htmlspecialchars(), this filter is aware of the default_charset and if a sequence of bytes is detected that makes up an invalid character in the current character set then the entire string is rejected resulting in a 0-length string. When using this filter as a default filter, see the warning below about setting the default flags to 0.
FILTER_SANITIZE_STRING | "string" | FILTER_FLAG_NO_ENCODE_QUOTES, FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_STRIP_BACKTICK, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH, FILTER_FLAG_ENCODE_AMP | Strip tags, optionally strip or encode special characters.
FILTER_SANITIZE_STRIPPED | "stripped" |  | Alias of "string" filter.
FILTER_SANITIZE_URL | "url" |  | Remove all characters except letters, digits and $-_.+!*'(),{}|\\^~[]`<>#%";/?:@&=.
FILTER_UNSAFE_RAW | "unsafe_raw" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_STRIP_BACKTICK, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH, FILTER_FLAG_ENCODE_AMP | Do nothing, optionally strip or encode special characters. This filter is also aliased to FILTER_DEFAULT.

Warning

When using one of these filters as a default filter either through your ini file or through your web server's configuration, the default flags is set to FILTER_FLAG_NO_ENCODE_QUOTES. You need to explicitly set filter.default_flags to 0 to have quotes encoded by default. Like this:

Example #1 Configuring the default filter to act like htmlspecialchars

filter.default = full_special_chars
filter.default_flags = 0

更新日志

版本 | 说明
5.2.11/5.3.1 | Slashes (/) are removed by FILTER_SANITIZE_EMAIL. Prior they were retained.


Other filters

List of miscellaneous filters
ID | Name | Options | Flags | Description
FILTER_CALLBACK | "callback" | callable function or method | All flags are ignored | Call user-defined function to filter data.


Filter flags

List of filter flags
ID | Used with | Description
FILTER_FLAG_STRIP_LOW | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_UNSAFE_RAW | Strips characters that have a numerical value <32.
FILTER_FLAG_STRIP_HIGH | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_UNSAFE_RAW | Strips characters that have a numerical value >127.
FILTER_FLAG_STRIP_BACKTICK | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_UNSAFE_RAW | Strips backtick characters.
FILTER_FLAG_ALLOW_FRACTION | FILTER_SANITIZE_NUMBER_FLOAT | Allows a period (.) as a fractional separator in numbers.
FILTER_FLAG_ALLOW_THOUSAND | FILTER_SANITIZE_NUMBER_FLOAT, FILTER_VALIDATE_FLOAT | Allows a comma (,) as a thousands separator in numbers.
FILTER_FLAG_ALLOW_SCIENTIFIC | FILTER_SANITIZE_NUMBER_FLOAT | Allows an e or E for scientific notation in numbers.
FILTER_FLAG_NO_ENCODE_QUOTES | FILTER_SANITIZE_STRING | If this flag is present, single (') and double (") quotes will not be encoded.
FILTER_FLAG_ENCODE_LOW | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Encodes all characters with a numerical value <32.
FILTER_FLAG_ENCODE_HIGH | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Encodes all characters with a numerical value >127.
FILTER_FLAG_ENCODE_AMP | FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Encodes ampersands (&).
FILTER_NULL_ON_FAILURE | FILTER_VALIDATE_BOOLEAN | Returns null for unrecognized boolean values.
FILTER_FLAG_ALLOW_OCTAL | FILTER_VALIDATE_INT | Regards inputs starting with a zero (0) as octal numbers. This only allows the succeeding digits to be 0-7.
FILTER_FLAG_ALLOW_HEX | FILTER_VALIDATE_INT | Regards inputs starting with 0x or 0X as hexadecimal numbers. This only allows succeeding characters to be a-fA-F0-9.
FILTER_FLAG_EMAIL_UNICODE | FILTER_VALIDATE_EMAIL | Allows the local part of the email address to contain Unicode characters.
FILTER_FLAG_IPV4 | FILTER_VALIDATE_IP | Allows the IP address to be in IPv4 format.
FILTER_FLAG_IPV6 | FILTER_VALIDATE_IP | Allows the IP address to be in IPv6 format.
FILTER_FLAG_NO_PRIV_RANGE | FILTER_VALIDATE_IP | Fails validation for the following private IPv4 ranges: 10.0.0.0/8, 172.16.0.0/12 and 192.168.0.0/16. Fails validation for the IPv6 addresses starting with FD or FC.
FILTER_FLAG_NO_RES_RANGE | FILTER_VALIDATE_IP | Fails validation for the following reserved IPv4 ranges: 0.0.0.0/8, 169.254.0.0/16, 127.0.0.0/8 and 240.0.0.0/4. Fails validation for the following reserved IPv6 ranges: ::1/128, ::/128, ::ffff:0:0/96 and fe80::/10.
FILTER_FLAG_SCHEME_REQUIRED | FILTER_VALIDATE_URL | Requires the URL to contain a scheme part.
FILTER_FLAG_HOST_REQUIRED | FILTER_VALIDATE_URL | Requires the URL to contain a host part.
FILTER_FLAG_PATH_REQUIRED | FILTER_VALIDATE_URL | Requires the URL to contain a path part.
FILTER_FLAG_QUERY_REQUIRED | FILTER_VALIDATE_URL | Requires the URL to contain a query string.
FILTER_REQUIRE_SCALAR |  | Requires the value to be scalar.
FILTER_REQUIRE_ARRAY |  | Requires the value to be an array.
FILTER_FORCE_ARRAY |  | If the value is a scalar, it is treated as array with the scalar value as only element.

更新日志

版本 | 说明
7.3.0 | The explicit usage of FILTER_FLAG_SCHEME_REQUIRED and FILTER_FLAG_HOST_REQUIRED has been deprecated.
7.1.0 | FILTER_FLAG_EMAIL_UNICODE has been added.
5.3.2 | FILTER_FLAG_STRIP_BACKTICK has been added.
5.2.10 | FILTER_FLAG_NO_RES_RANGE supports also IPv6 addresses.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

INPUT_POST (integer)
POST 变量。
INPUT_GET (integer)
GET 变量。
INPUT_COOKIE (integer)
COOKIE 变量。
INPUT_ENV (integer)
ENV 变量。
INPUT_SERVER (integer)
SERVER 变量。
INPUT_SESSION (integer)
SESSION 变量。 (暂未实现)
INPUT_REQUEST (integer)
REQUEST 变量。 (暂未实现)
FILTER_FLAG_NONE (integer)
没有标记。
FILTER_REQUIRE_SCALAR (integer)
此标记要求输入的是标量。
FILTER_REQUIRE_ARRAY (integer)
需要输入的是数组。
FILTER_FORCE_ARRAY (integer)
一律返回数组。
FILTER_NULL_ON_FAILURE (integer)
失败时返回 NULL，而非 FALSE。
FILTER_VALIDATE_INT (integer)
标记 "int" 过滤器。
FILTER_VALIDATE_BOOLEAN (integer)
标记 "boolean" 过滤器。
FILTER_VALIDATE_FLOAT (integer)
标记 "float" 过滤器。
FILTER_VALIDATE_REGEXP (integer)
标记 "validate_regexp" 过滤器。
FILTER_VALIDATE_URL (integer)
标记 "validate_url" 过滤器。
FILTER_VALIDATE_EMAIL (integer)
标记 "validate_email" 过滤器。
FILTER_VALIDATE_IP (integer)
标记 "validate_ip" 过滤器。
FILTER_VALIDATE_MAC (integer)
标记 "validate_mac_address" 过滤器。（PHP 5.5.0 起有效）
FILTER_DEFAULT (integer)
标记默认的 "unsafe_raw" 过滤器。 等同于 FILTER_UNSAFE_RAW。
FILTER_UNSAFE_RAW (integer)
标记 "unsafe_raw" 过滤器。
FILTER_SANITIZE_STRING (integer)
标记 "string" 过滤器。
FILTER_SANITIZE_STRIPPED (integer)
标记 "stripped" 过滤器。
FILTER_SANITIZE_ENCODED (integer)
标记 "encoded" 过滤器。
FILTER_SANITIZE_SPECIAL_CHARS (integer)
标记 "special_chars" 过滤器。
FILTER_SANITIZE_EMAIL (integer)
标记 "email" 过滤器。
FILTER_SANITIZE_URL (integer)
标记 "url" 过滤器。
FILTER_SANITIZE_NUMBER_INT (integer)
标记 "number_int" 过滤器。
FILTER_SANITIZE_NUMBER_FLOAT (integer)
标记 "number_float" 过滤器。
FILTER_SANITIZE_MAGIC_QUOTES (integer)
标记 "magic_quotes" 过滤器。
FILTER_CALLBACK (integer)
标记 "callback" 过滤器。
FILTER_FLAG_ALLOW_OCTAL (integer)
"int" 过滤器允许八进制（octal）标记的字符（0[0-7]+）。
FILTER_FLAG_ALLOW_HEX (integer)
"int" 过滤器允许十六进制（Hex）标记的字符（0x[0-9a-fA-F]+）
FILTER_FLAG_STRIP_LOW (integer)
过滤 ASCII 编码值大于 32 的字符 。
FILTER_FLAG_STRIP_HIGH (integer)
过滤 ASCII 编码值大于 127 的字符 。
FILTER_FLAG_ENCODE_LOW (integer)
字符的 ASCII 编码值大于 32。
FILTER_FLAG_ENCODE_HIGH (integer)
字符的 ASCII 编码值大于 127。
FILTER_FLAG_ENCODE_AMP (integer)
为 & 编码。
FILTER_FLAG_NO_ENCODE_QUOTES (integer)
不要为 ' 和 " 编码。
FILTER_FLAG_EMPTY_STRING_NULL (integer)
(目前不能使用。)
FILTER_FLAG_ALLOW_FRACTION (integer)
"number_float" 过滤器允许小数部分。
FILTER_FLAG_ALLOW_THOUSAND (integer)
"number_float" 过滤器允许使用千分位分隔符（,）。
FILTER_FLAG_ALLOW_SCIENTIFIC (integer)
"number_float" 过滤器允许使用科学计数法（e、E）。
FILTER_FLAG_PATH_REQUIRED (integer)
"validate_url" 过滤器，要求带路径部分。
FILTER_FLAG_QUERY_REQUIRED (integer)
"validate_url" 过滤器，要求带 Query 部分。
FILTER_FLAG_IPV4 (integer)
"validate_ip" 过滤器，仅仅允许 IPv4 地址。
FILTER_FLAG_IPV6 (integer)
"validate_ip" 过滤器，仅仅允许 IPv6 地址。
FILTER_FLAG_NO_RES_RANGE (integer)
"validate_ip" 过滤器，禁止保留 IP 地址。
FILTER_FLAG_NO_PRIV_RANGE (integer)
"validate_ip" 过滤器，禁止私有 IP 地址。
FILTER_FLAG_EMAIL_UNICODE (integer)
"validate_email" 过滤器，在邮件地址用户名部分允许 Unicode 字符。 （PHP 7.1.0 起有效）


  • ? 预定义常量
  • Validation ?
  • PHP Manual
  • Filter
  • 范例

范例

Table of Contents

  • Validation
  • Sanitization


Validation

Example #1 Validating email addresses with filter_var()

<?php
$email_a = 'joe@example.com';
$email_b = 'bogus';

if (filter_var($email_a, FILTER_VALIDATE_EMAIL)) {
    echo "Email address '$email_a' is considered valid.\n";
}
if (filter_var($email_b, FILTER_VALIDATE_EMAIL)) {
    echo "Email address '$email_b' is considered valid.\n";
} else {
    echo "Email address '$email_b' is considered invalid.\n";
}
?>

以上例程会输出：

Email address 'joe@example.com' is considered valid.
Email address 'bogus' is considered invalid.

Example #2 Validating IP addresses with filter_var()

<?php
$ip_a = '127.0.0.1';
$ip_b = '42.42';

if (filter_var($ip_a, FILTER_VALIDATE_IP)) {
    echo "IP address '$ip_a' is considered valid.";
}
if (filter_var($ip_b, FILTER_VALIDATE_IP)) {
    echo "IP address '$ip_b' is considered valid.";
}
?>

以上例程会输出：

IP address '127.0.0.1' is considered valid.

Example #3 Passing options to filter_var()

<?php
$int_a = '1';
$int_b = '-1';
$int_c = '4';
$options = array(
    'options' => array(
        'min_range' => 0,
        'max_range' => 3,
    )
);
if (filter_var($int_a, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "Integer A '$int_a' is considered valid (between 0 and 3).\n";
}
if (filter_var($int_b, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "Integer B '$int_b' is considered valid (between 0 and 3).\n";
}
if (filter_var($int_c, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "Integer C '$int_c' is considered valid (between 0 and 3).\n";
}

$options['options']['default'] = 1;
if (($int_c = filter_var($int_c, FILTER_VALIDATE_INT, $options)) !== FALSE) {
    echo "Integer C '$int_c' is considered valid (between 0 and 3).";
}
?>

以上例程会输出：

Integer A '1' is considered valid (between 0 and 3).
Integer C '1' is considered valid (between 0 and 3).


Sanitization

Example #1 Sanitizing and validating email addresses

<?php
$a = 'joe@example.org';
$b = 'bogus - at - example dot org';
$c = '(bogus@example.org)';

$sanitized_a = filter_var($a, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_a, FILTER_VALIDATE_EMAIL)) {
    echo "This (a) sanitized email address is considered valid.\n";
}

$sanitized_b = filter_var($b, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_b, FILTER_VALIDATE_EMAIL)) {
    echo "This sanitized email address is considered valid.";
} else {
    echo "This (b) sanitized email address is considered invalid.\n";
}

$sanitized_c = filter_var($c, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_c, FILTER_VALIDATE_EMAIL)) {
    echo "This (c) sanitized email address is considered valid.\n";
    echo "Before: $c\n";
    echo "After:  $sanitized_c\n";
}
?>

以上例程会输出：

This (a) sanitized email address is considered valid.
This (b) sanitized email address is considered invalid.
This (c) sanitized email address is considered valid.
Before: (bogus@example.org)
After: bogus@example.org

Example #2 Configuring a default filter

filter.default = full_special_chars
filter.default_flags = 0


过滤器函数

Table of Contents

  • filter_has_var — 检测是否存在指定类型的变量
  • filter_id — 返回与某个特定名称的过滤器相关联的id
  • filter_input_array — 获取一系列外部变量，并且可以通过过滤器处理它们
  • filter_input — 通过名称获取特定的外部变量，并且可以通过过滤器处理它
  • filter_list — 返回所支持的过滤器列表
  • filter_var_array — 获取多个变量并且过滤它们
  • filter_var — 使用特定的过滤器过滤一个变量


检测是否存在指定类型的变量

  • ? 过滤器函数
  • filter_id ?
  • PHP Manual
  • 过滤器函数
  • 检测是否存在指定类型的变量

filter_has_var

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_has_var — 检测是否存在指定类型的变量

说明

filter_has_var ( int $type , string $variable_name ) : bool

参数

type

INPUT_GET、 INPUT_POST、 INPUT_COOKIE、 INPUT_SERVER、 INPUT_ENV 里的其中一个。

variable_name

要检查的变量名。

返回值

成功时返回 true， 或者在失败时返回 false。


返回与某个特定名称的过滤器相关联的id

  • ? filter_has_var
  • filter_input_array ?
  • PHP Manual
  • 过滤器函数
  • 返回与某个特定名称的过滤器相关联的id

filter_id

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_id — 返回与某个特定名称的过滤器相关联的id

说明

filter_id ( string $filtername ) : int

参数

filtername

待获取的过滤器名称

返回值

如果获取成功则返回过滤器id，如果过滤器不存在则返回 false 。

参见

  • filter_list() - 返回所支持的过滤器列表


获取一系列外部变量，并且可以通过过滤器处理它们

  • ? filter_id
  • filter_input ?
  • PHP Manual
  • 过滤器函数
  • 获取一系列外部变量，并且可以通过过滤器处理它们

filter_input_array

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_input_array — 获取一系列外部变量，并且可以通过过滤器处理它们

说明

filter_input_array ( int $type , mixed $definition = ? , bool $add_empty = true ) : mixed

这个函数当需要获取很多变量却不想重复调用filter_input()时很有用。

参数

type

INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER, or INPUT_ENV之一。

definition

一个定义参数的数组。一个有效的键必须是一个包含变量名的string，一个有效的值要么是一个filter type，或者是一个array 指明了过滤器、标示和选项。如果值是一个数组，那么它的有效的键可以是 filter， 用于指明 filter type，flags 用于指明任何想要用于过滤器的标示，或者 options 用于指明任何想要用于过滤器的选项。 参考下面的例子来更好的理解这段说明。

这个参数也可以是一个filter constant的整数。那么数组中的所有变量都会被这个过滤器所过滤。

add_empty

在返回值中添加 null 作为不存在的键。

返回值

如果成功的话返回一个所请求的变量的数组，如果失败的话返回 false 。对于数组的值，如果过滤失败则返回 false ，如果variable_name 不存在的话则返回 null 。 如果标示 FILTER_NULL_ON_FAILURE 被使用了，那么当变量不存在时返回 false ，当过滤失败时返回 null 。

范例

Example #1 一个 filter_input_array() 的例子

<?php
error_reporting(E_ALL | E_STRICT);
/* data actually came from POST
$_POST = array(
    'product_id'    => 'libgd<script>',
    'component'     => '10',
    'versions'      => '2.0.33',
    'testscalar'    => array('2', '23', '10', '12'),
    'testarray'     => '2',
);
*/

$args = array(
    'product_id'   => FILTER_SANITIZE_ENCODED,
    'component'    => array('filter'    => FILTER_VALIDATE_INT,
                            'flags'     => FILTER_REQUIRE_ARRAY,
                            'options'   => array('min_range' => 1, 'max_range' => 10)
                           ),
    'versions'     => FILTER_SANITIZE_ENCODED,
    'doesnotexist' => FILTER_VALIDATE_INT,
    'testscalar'   => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_SCALAR,
                           ),
    'testarray'    => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_ARRAY,
                           )

);

$myinputs = filter_input_array(INPUT_POST, $args);

var_dump($myinputs);
echo "\n";
?>

以上例程会输出：

array(6) {
  ["product_id"]=>
  string(17) "libgd%3Cscript%3E"
  ["component"]=>
  array(1) {
    [0]=>
    int(10)
  }
  ["versions"]=>
  string(6) "2.0.33"
  ["doesnotexist"]=>
  NULL
  ["testscalar"]=>
  bool(false)
  ["testarray"]=>
  array(1) {
    [0]=>
    int(2)
  }
}

更新日志

版本 | 说明
5.4.0 | 添加 add_empty 参数.

注释

Note:

在 INPUT_SERVER 数组中并没有 REQUEST_TIME ，因为它是被稍后插入到$_SERVER 中的。

参见

  • filter_input() - 通过名称获取特定的外部变量，并且可以通过过滤器处理它
  • filter_var_array() - 获取多个变量并且过滤它们
  • Types of filters


通过名称获取特定的外部变量，并且可以通过过滤器处理它

  • ? filter_input_array
  • filter_list ?
  • PHP Manual
  • 过滤器函数
  • 通过名称获取特定的外部变量，并且可以通过过滤器处理它

filter_input

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_input — 通过名称获取特定的外部变量，并且可以通过过滤器处理它

说明

filter_input ( int $type , string $variable_name , int $filter = FILTER_DEFAULT , mixed $options = ? ) : mixed

参数

type

INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER或 INPUT_ENV之一。

variable_name

待获取的变量名。

filter

The ID of the filter to apply. The Types of filters manual page lists the available filters.

If omitted, FILTER_DEFAULT will be used, which is equivalent to FILTER_UNSAFE_RAW. This will result in no filtering taking place by default.

options

一个选项的关联数组，或者按位区分的标示。如果过滤器接受选项，可以通过数组的 "flags" 位去提供这些标示。

返回值

如果成功的话返回所请求的变量。如果过滤失败则返回 false ，如果variable_name 不存在的话则返回 null 。 如果标示 FILTER_NULL_ON_FAILURE 被使用了，那么当变量不存在时返回 false ，当过滤失败时返回 null 。

范例

Example #1 一个 filter_input() 的例子

<?php
$search_html = filter_input(INPUT_GET, 'search', FILTER_SANITIZE_SPECIAL_CHARS);
$search_url = filter_input(INPUT_GET, 'search', FILTER_SANITIZE_ENCODED);
echo "You have searched for $search_html.\n";
echo "<a href='?search=$search_url'>Search again.</a>";
?>

以上例程的输出类似于：

You have searched for Me &#38; son.
<a href='?search=Me%20%26%20son'>Search again.</a>

参见

  • filter_var() - 使用特定的过滤器过滤一个变量
  • filter_input_array() - 获取一系列外部变量，并且可以通过过滤器处理它们
  • filter_var_array() - 获取多个变量并且过滤它们
  • Types of filters


返回所支持的过滤器列表

  • ? filter_input
  • filter_var_array ?
  • PHP Manual
  • 过滤器函数
  • 返回所支持的过滤器列表

filter_list

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_list — 返回所支持的过滤器列表

说明

filter_list ( ) : array

返回值

返回一个所支持的过滤器的名称的列表，如果没有这样子的过滤器的话则返回空数组。这个数组的索引不是过滤器id， 你可以通过 filter_id() 去根据名称获取它们。

范例

Example #1 一个 filter_list() 的例子

<?php
print_r(filter_list());
?>

以上例程的输出类似于：

Array
(
    [0] => int
    [1] => boolean
    [2] => float
    [3] => validate_regexp
    [4] => validate_url
    [5] => validate_email
    [6] => validate_ip
    [7] => string
    [8] => stripped
    [9] => encoded
    [10] => special_chars
    [11] => unsafe_raw
    [12] => email
    [13] => url
    [14] => number_int
    [15] => number_float
    [16] => magic_quotes
    [17] => callback
)


获取多个变量并且过滤它们

  • ? filter_list
  • filter_var ?
  • PHP Manual
  • 过滤器函数
  • 获取多个变量并且过滤它们

filter_var_array

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_var_array — 获取多个变量并且过滤它们

说明

filter_var_array ( array $data , mixed $definition = ? , bool $add_empty = true ) : mixed

不需要重复调用 filter_var() 就能获取多个变量。

参数

data

数组，键为字符串，值为待过滤的数据。

definition

一个定义参数的数组。一个有效的键必须是一个包含变量名的string，一个有效的值要么是一个filter type，或者是一个array 指明了过滤器、标示和选项。如果值是一个数组，那么它的有效的键可以是 filter， 用于指明 filter type，flags 用于指明任何想要用于过滤器的标示，或者 options 用于指明任何想要用于过滤器的选项。 参考下面的例子来更好的理解这段说明。

这个参数也可以是一个filter constant的整数。那么数组中的所有值都会被这个过滤器所过滤。

add_empty

在返回值中添加 null 作为不存在的键。

返回值

如果成功则返回一个包含所请求变量的数组，或者当失败时返回 false 。 一个数组的值如果过滤失败则为 false ，或者为 null 如果变量不存在的话。

范例

Example #1 一个 filter_var_array() 的例子

<?php
error_reporting(E_ALL | E_STRICT);
$data = array(
    'product_id'    => 'libgd<script>',
    'component'     => '10',
    'versions'      => '2.0.33',
    'testscalar'    => array('2', '23', '10', '12'),
    'testarray'     => '2',
);

$args = array(
    'product_id'   => FILTER_SANITIZE_ENCODED,
    'component'    => array('filter'    => FILTER_VALIDATE_INT,
                            'flags'     => FILTER_FORCE_ARRAY,
                            'options'   => array('min_range' => 1, 'max_range' => 10)
                           ),
    'versions'     => FILTER_SANITIZE_ENCODED,
    'doesnotexist' => FILTER_VALIDATE_INT,
    'testscalar'   => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_SCALAR,
                           ),
    'testarray'    => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_FORCE_ARRAY,
                           )

);

$myinputs = filter_var_array($data, $args);

var_dump($myinputs);
echo "\n";
?>

以上例程会输出：

array(6) {
  ["product_id"]=>
  string(17) "libgd%3Cscript%3E"
  ["component"]=>
  array(1) {
    [0]=>
    int(10)
  }
  ["versions"]=>
  string(6) "2.0.33"
  ["doesnotexist"]=>
  NULL
  ["testscalar"]=>
  bool(false)
  ["testarray"]=>
  array(1) {
    [0]=>
    int(2)
  }
}

更新日志

版本 | 说明
5.4.0 | 添加 add_empty 参数。

参见

  • filter_input_array() - 获取一系列外部变量，并且可以通过过滤器处理它们
  • filter_var() - 使用特定的过滤器过滤一个变量
  • filter_input() - 通过名称获取特定的外部变量，并且可以通过过滤器处理它
  • Types of filters


使用特定的过滤器过滤一个变量

  • ? filter_var_array
  • 函数处理 ?
  • PHP Manual
  • 过滤器函数
  • 使用特定的过滤器过滤一个变量

filter_var

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

filter_var — 使用特定的过滤器过滤一个变量

说明

filter_var ( mixed $value , int $filter = FILTER_DEFAULT , array|int $options = 0 ) : mixed

参数

value

要过滤的内容。注意：标量值在过滤前，会被转换成字符串。

filter

The ID of the filter to apply. The Types of filters manual page lists the available filters.

If omitted, FILTER_DEFAULT will be used, which is equivalent to FILTER_UNSAFE_RAW. This will result in no filtering taking place by default.

options

一个选项的关联数组，或者按位区分的标示。如果过滤器接受选项，可以通过数组的 "flags" 下标去提供这些标示。 对于回调型的过滤器，应该传入 callable。 这个回调函数必须接受一个参数（即待过滤的值），并且返回一个在过滤/净化后的值。

<?php
// 对于接受选项的过滤器，请使用此格式
$options = array(
    'options' => array(
        'default' => 3, // 过滤器失败时返回的值
        // 可以继续写过滤器接收其它选项
        'min_range' => 0
    ),
    'flags' => FILTER_FLAG_ALLOW_OCTAL,
);
$var = filter_var('0755', FILTER_VALIDATE_INT, $options);
// 对于仅接受标志的过滤器，您可以直接将其传递
$var = filter_var('oops', FILTER_VALIDATE_BOOLEAN, FILTER_NULL_ON_FAILURE);
// 对于仅接受标志的过滤器，您还可以将其作为数组传递
$var = filter_var('oops', FILTER_VALIDATE_BOOLEAN,
                  array('flags' => FILTER_NULL_ON_FAILURE));
// 回调类型过滤器
function foo($value)
{
    // 预期值: Surname, GivenNames
    if (strpos($value, ", ") === false) return false;
    list($surname, $givennames) = explode(", ", $value, 2);
    $empty = (empty($surname) || empty($givennames));
    $notstrings = (!is_string($surname) || !is_string($givennames));
    if ($empty || $notstrings) {
        return false;
    } else {
        return $value;
    }
}
$var = filter_var('Doe, Jane Sue', FILTER_CALLBACK, array('options' => 'foo'));
?>

返回值

返回过滤后的数据，如果过滤失败则返回 false 。

范例

Example #1 一个 filter_var() 的示例

<?php
var_dump(filter_var('bob@example.com', FILTER_VALIDATE_EMAIL));
var_dump(filter_var('http://example.com', FILTER_VALIDATE_URL, FILTER_FLAG_PATH_REQUIRED));
?>

以上例程会输出：

string(15) "bob@example.com"
bool(false)

参见

  • filter_var_array() - 获取多个变量并且过滤它们
  • filter_input() - 通过名称获取特定的外部变量，并且可以通过过滤器处理它
  • filter_input_array() - 获取一系列外部变量，并且可以通过过滤器处理它们
  • Types of filters


函数处理

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 函数处理 函数
    • call_user_func_array — 调用回调函数，并把一个数组参数作为回调函数的参数
    • call_user_func — 把第一个参数作为回调函数调用
    • create_function — Create an anonymous (lambda-style) function
    • forward_static_call_array — Call a static method and pass the arguments as array
    • forward_static_call — Call a static method
    • func_get_arg — 返回参数列表的某一项
    • func_get_args — 返回一个包含函数参数列表的数组
    • func_num_args — Returns the number of arguments passed to the function
    • function_exists — 如果给定的函数已经被定义就返回 true
    • get_defined_functions — 返回所有已定义函数的数组
    • register_shutdown_function — 注册一个会在php中止时执行的函数
    • register_tick_function — Register a function for execution on each tick
    • unregister_tick_function — De-register a function for execution on each tick


  • ? 函数处理
  • 安装／配置 ?
  • PHP Manual
  • 函数处理
  • 简介

简介

这些函数涉及函数的相关操作。


  • ? 资源类型
  • 函数处理 函数 ?
  • PHP Manual
  • 函数处理
  • 预定义常量

预定义常量

此扩展没有定义常量。


函数处理 函数

Table of Contents

  • call_user_func_array — 调用回调函数，并把一个数组参数作为回调函数的参数
  • call_user_func — 把第一个参数作为回调函数调用
  • create_function — Create an anonymous (lambda-style) function
  • forward_static_call_array — Call a static method and pass the arguments as array
  • forward_static_call — Call a static method
  • func_get_arg — 返回参数列表的某一项
  • func_get_args — 返回一个包含函数参数列表的数组
  • func_num_args — Returns the number of arguments passed to the function
  • function_exists — 如果给定的函数已经被定义就返回 true
  • get_defined_functions — 返回所有已定义函数的数组
  • register_shutdown_function — 注册一个会在php中止时执行的函数
  • register_tick_function — Register a function for execution on each tick
  • unregister_tick_function — De-register a function for execution on each tick


调用回调函数，并把一个数组参数作为回调函数的参数

  • ? 函数处理 函数
  • call_user_func ?
  • PHP Manual
  • 函数处理 函数
  • 调用回调函数，并把一个数组参数作为回调函数的参数

call_user_func_array

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

call_user_func_array — 调用回调函数，并把一个数组参数作为回调函数的参数

说明

call_user_func_array ( callable $callback , array $param_arr ) : mixed

把第一个参数作为回调函数（callback）调用，把参数数组作（param_arr）为回调函数的的参数传入。

参数

callback

被调用的回调函数。

param_arr

要被传入回调函数的数组，这个数组得是索引数组。

返回值

返回回调函数的结果。如果出错的话就返回false

更新日志

版本 | 说明
5.3.0 | 对面向对象里面的关键字的解析有所增强。在此之前，使用两个冒号来连接一个类和里面的一个方法，把它作为参数来作为回调函数的话，将会发出一个E_STRICT的警告，因为这个传入的参数被视为静态方法。

范例

Example #1 call_user_func_array()例子

<?php
function foobar($arg, $arg2) {
    echo __FUNCTION__, " got $arg and $arg2\n";
}
class foo {
    function bar($arg, $arg2) {
        echo __METHOD__, " got $arg and $arg2\n";
    }
}

// Call the foobar() function with 2 arguments
call_user_func_array("foobar", array("one", "two"));

// Call the $foo->bar() method with 2 arguments
$foo = new foo;
call_user_func_array(array($foo, "bar"), array("three", "four"));
?>

以上例程的输出类似于：

foobar got one and two
foo::bar got three and four

Example #2 call_user_func_array()使用命名空间的情况

<?php

namespace Foobar;

class Foo {
    static public function test($name) {
        print "Hello {$name}!\n";
    }
}

// As of PHP 5.3.0
call_user_func_array(__NAMESPACE__ .'\Foo::test', array('Hannes'));

// As of PHP 5.3.0
call_user_func_array(array(__NAMESPACE__ .'\Foo', 'test'), array('Philip'));

?>

以上例程的输出类似于：

Hello Hannes!
Hello Philip!

Example #3 把完整的函数作为回调传入call_user_func_array()

<?php

$func = function($arg1, $arg2) {
    return $arg1 * $arg2;
};

var_dump(call_user_func_array($func, array(2, 4))); /* As of PHP 5.3.0 */

?>

以上例程会输出：

int(8)

Example #4 传引用

<?php

function mega(&$a){
    $a = 55;
    echo "function mega \$a=$a\n";
}
$bar = 77;
call_user_func_array('mega',array(&$bar));
echo "global \$bar=$bar\n";

?>

以上例程会输出：

function mega $a=55
global $bar=55

注释

Note:

PHP 5.4之前，如果param_arr里面的参数是引用传值，那么不管原函数默认的各个参数是不是引用传值，都会以引用方式传入到回调函数。虽然以引用传值这种方式来传递参数给回调函数，不会发出不支持的警告，但是不管怎么说，这样做还是不被支持的。并且在PHP 5.4里面被去掉了。而且，这也不适用于内部函数，for which the function signature is honored。如果回调函数默认设置需要接受的参数是引用传递的时候，按值传递，结果将会输出一个警告。call_user_func() 将会返回 false（there is, however, an exception for passed values with reference count = 1, such as in literals, as these can be turned into references without ill effects — but also without writes to that value having any effect —; do not rely in this behavior, though, as the reference count is an implementation detail and the soundness of this behavior is questionable）。

Note:

在函数中注册有多个回调内容时(如使用 call_user_func() 与 call_user_func_array())，如在前一个回调中有未捕获的异常，其后的将不再被调用。

参见

  • call_user_func() - 把第一个参数作为回调函数调用
  • ReflectionFunction::invokeArgs() - Invokes function args
  • ReflectionMethod::invokeArgs() - 带参数执行


把第一个参数作为回调函数调用

  • ? call_user_func_array
  • create_function ?
  • PHP Manual
  • 函数处理 函数
  • 把第一个参数作为回调函数调用

call_user_func

(PHP 4, PHP 5, PHP 7, PHP 8)

call_user_func — 把第一个参数作为回调函数调用

说明

call_user_func ( callable $callback , mixed $parameter = ? , mixed $... = ? ) : mixed

第一个参数 callback 是被调用的回调函数，其余参数是回调函数的参数。

参数

callback

将被调用的回调函数（callable）。

parameter

0个或以上的参数，被传入回调函数。

Note:

请注意，传入call_user_func()的参数不能为引用传递。

Example #1 call_user_func() 的参考例子

<?php
error_reporting(E_ALL);
function increment(&$var)
{
    $var++;
}

$a = 0;
call_user_func('increment', $a);
echo $a."\n";

call_user_func_array('increment', array(&$a)); // You can use this instead before PHP 5.3
echo $a."\n";
?>

以上例程会输出：

0
1

返回值

返回回调函数的返回值。

更新日志

版本 | 说明
5.3.0 | 对面向对象里面的关键字的解析有所增强。在此之前，使用两个冒号来连接一个类和里面的一个方法，把它作为参数来作为回调函数的话，将会发出一个E_STRICT的警告，因为这个传入的参数被视为静态方法。

范例

Example #2 call_user_func() 的例子

<?php
function barber($type)
{
    echo "You wanted a $type haircut, no problem\n";
}
call_user_func('barber', "mushroom");
call_user_func('barber', "shave");
?>

以上例程会输出：

You wanted a mushroom haircut, no problem
You wanted a shave haircut, no problem

Example #3 call_user_func() 命名空间的使用

<?php

namespace Foobar;

class Foo {
    static public function test() {
        print "Hello world!\n";
    }
}

call_user_func(__NAMESPACE__ .'\Foo::test'); // As of PHP 5.3.0
call_user_func(array(__NAMESPACE__ .'\Foo', 'test')); // As of PHP 5.3.0

?>

以上例程会输出：

Hello world!
Hello world!

Example #4 用call_user_func()来调用一个类里面的方法

<?php

class myclass {
    static function say_hello()
    {
        echo "Hello!\n";
    }
}

$classname = "myclass";

call_user_func(array($classname, 'say_hello'));
call_user_func($classname .'::say_hello'); // As of 5.2.3

$myobject = new myclass();

call_user_func(array($myobject, 'say_hello'));

?>

以上例程会输出：

Hello!
Hello!
Hello!

Example #5 把完整的函数作为回调传入call_user_func()

<?php
call_user_func(function($arg) { print "[$arg]\n"; }, 'test'); /* As of PHP 5.3.0 */
?>

以上例程会输出：

[test]

注释

Note:

在函数中注册有多个回调内容时(如使用 call_user_func() 与 call_user_func_array())，如在前一个回调中有未捕获的异常，其后的将不再被调用。

参见

  • call_user_func_array() - 调用回调函数，并把一个数组参数作为回调函数的参数
  • is_callable() - 检测参数是否为合法的可调用结构
  • ReflectionFunction::invoke() - Invokes function
  • ReflectionMethod::invoke() - Invoke


Create an anonymous (lambda-style) function

  • ? call_user_func
  • forward_static_call_array ?
  • PHP Manual
  • 函数处理 函数
  • Create an anonymous (lambda-style) function

create_function

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

create_function — Create an anonymous (lambda-style) function

说明

create_function ( string $args , string $code ) : string

Creates an anonymous function from the parameters passed, and returns a unique name for it.

Caution

This function internally performs an eval() and as such has the same security issues as eval(). Additionally it has bad performance and memory usage characteristics.

If you are using PHP 5.3.0 or newer a native anonymous function should be used instead.

参数

Usually these parameters will be passed as single quote delimited strings. The reason for using single quoted strings, is to protect the variable names from parsing, otherwise, if you use double quotes there will be a need to escape the variable names, e.g. \$avar.

args

The function arguments.

code

The function code.

返回值

Returns a unique function name as a string, or false on error.

范例

Example #1 Creating an anonymous function with create_function()

You can use this function, to (for example) create a function from information gathered at run time:

<?php
$newfunc = create_function('$a,$b', 'return "ln($a) + ln($b) = " . log($a * $b);');
echo "New anonymous function: $newfunc\n";
echo $newfunc(2, M_E) . "\n";
// outputs
// New anonymous function: lambda_1
// ln(2) + ln(2.718281828459) = 1.6931471805599
?>

Or, perhaps to have general handler function that can apply a set of operations to a list of parameters:

Example #2 Making a general processing function with create_function()

<?php
function process($var1, $var2, $farr)
{
    foreach ($farr as $f) {
        echo $f($var1, $var2) . "\n";
    }
}

// create a bunch of math functions
$f1 = 'if ($a >=0) {return "b*a^2 = ".$b*sqrt($a);} else {return false;}';
$f2 = "return \"min(b^2+a, a^2,b) = \".min(\$a*\$a+\$b,\$b*\$b+\$a);";
$f3 = 'if ($a > 0 && $b != 0) {return "ln(a)/b = ".log($a)/$b; } else { return false; }';
$farr = array(
    create_function('$x,$y', 'return "some trig: ".(sin($x) + $x*cos($y));'),
    create_function('$x,$y', 'return "a hypotenuse: ".sqrt($x*$x + $y*$y);'),
    create_function('$a,$b', $f1),
    create_function('$a,$b', $f2),
    create_function('$a,$b', $f3)
    );

echo "\nUsing the first array of anonymous functions\n";
echo "parameters: 2.3445, M_PI\n";
process(2.3445, M_PI, $farr);

// now make a bunch of string processing functions
$garr = array(
    create_function('$b,$a', 'if (strncmp($a, $b, 3) == 0) return "** \"$a\" '.
    'and \"$b\"\n** Look the same to me! (looking at the first 3 chars)";'),
    create_function('$a,$b', '; return "CRCs: " . crc32($a) . ", ".crc32($b);'),
    create_function('$a,$b', '; return "similar(a,b) = " . similar_text($a, $b, &$p) . "($p%)";')
    );
echo "\nUsing the second array of anonymous functions\n";
process("Twas brilling and the slithy toves", "Twas the night", $garr);
?>

以上例程会输出：

Using the first array of anonymous functions
parameters: 2.3445, M_PI
some trig: -1.6291725057799
a hypotenuse: 3.9199852871011
b*a^2 = 4.8103313314525
min(b^2+a, a^2,b) = 8.6382729035898
ln(a)/b = 0.27122299212594

Using the second array of anonymous functions
** "Twas the night" and "Twas brilling and the slithy toves"
** Look the same to me! (looking at the first 3 chars)
CRCs: -725381282, 342550513
similar(a,b) = 11(45.833333333333%)

But perhaps the most common use for of lambda-style (anonymous) functions is to create callback functions, for example when using array_walk() or usort()

Example #3 Using anonymous functions as callback functions

<?php
$av = array("the ", "a ", "that ", "this ");
array_walk($av, create_function('&$v,$k', '$v = $v . "mango";'));
print_r($av);
?>

以上例程会输出：

Array
(
  [0] => the mango
  [1] => a mango
  [2] => that mango
  [3] => this mango
)

an array of strings ordered from shorter to longer

<?php

$sv = array("small", "larger", "a big string", "it is a string thing");
print_r($sv);

?>

以上例程会输出：

Array
(
  [0] => small
  [1] => larger
  [2] => a big string
  [3] => it is a string thing
)

sort it from longer to shorter

<?php

usort($sv, create_function('$a,$b','return strlen($b) - strlen($a);'));
print_r($sv);

?>

以上例程会输出：

Array
(
  [0] => it is a string thing
  [1] => a big string
  [2] => larger
  [3] => small
)

参见

  • Anonymous functions


Call a static method and pass the arguments as array

  • ? create_function
  • forward_static_call ?
  • PHP Manual
  • 函数处理 函数
  • Call a static method and pass the arguments as array

forward_static_call_array

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

forward_static_call_array — Call a static method and pass the arguments as array

说明

forward_static_call_array ( callable $function , array $parameters ) : mixed

Calls a user defined function or method given by the function parameter. This function must be called within a method context, it can't be used outside a class. It uses the late static binding. All arguments of the forwarded method are passed as values, and as an array, similarly to call_user_func_array().

参数

function

The function or method to be called. This parameter may be an array, with the name of the class, and the method, or a string, with a function name.

parameter

One parameter, gathering all the method parameter in one array.

Note:

Note that the parameters for forward_static_call_array() are not passed by reference.

返回值

Returns the function result, or false on error.

范例

Example #1 forward_static_call_array() example

<?php

class A
{
    const NAME = 'A';
    public static function test() {
        $args = func_get_args();
        echo static::NAME, " ".join(',', $args)." \n";
    }
}

class B extends A
{
    const NAME = 'B';

    public static function test() {
        echo self::NAME, "\n";
        forward_static_call_array(array('A', 'test'), array('more', 'args'));
        forward_static_call_array( 'test', array('other', 'args'));
    }
}

B::test('foo');

function test() {
        $args = func_get_args();
        echo "C ".join(',', $args)." \n";
    }

?>

以上例程会输出：

B
B more,args
C other,args

参见

  • forward_static_call() - Call a static method
  • call_user_func() - 把第一个参数作为回调函数调用
  • call_user_func_array() - 调用回调函数，并把一个数组参数作为回调函数的参数
  • is_callable() - 检测参数是否为合法的可调用结构


Call a static method

  • ? forward_static_call_array
  • func_get_arg ?
  • PHP Manual
  • 函数处理 函数
  • Call a static method

forward_static_call

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

forward_static_call — Call a static method

说明

forward_static_call ( callable $function , mixed $parameter = ? , mixed $... = ? ) : mixed

Calls a user defined function or method given by the function parameter, with the following arguments. This function must be called within a method context, it can't be used outside a class. It uses the late static binding.

参数

function

The function or method to be called. This parameter may be an array, with the name of the class, and the method, or a string, with a function name.

parameter

Zero or more parameters to be passed to the function.

返回值

Returns the function result, or false on error.

范例

Example #1 forward_static_call() example

<?php

class A
{
    const NAME = 'A';
    public static function test() {
        $args = func_get_args();
        echo static::NAME, " ".join(',', $args)." \n";
    }
}

class B extends A
{
    const NAME = 'B';

    public static function test() {
        echo self::NAME, "\n";
        forward_static_call(array('A', 'test'), 'more', 'args');
        forward_static_call( 'test', 'other', 'args');
    }
}

B::test('foo');

function test() {
        $args = func_get_args();
        echo "C ".join(',', $args)." \n";
    }

?>

以上例程会输出：

B
B more,args
C other,args

参见

  • forward_static_call_array() - Call a static method and pass the arguments as array
  • call_user_func_array() - 调用回调函数，并把一个数组参数作为回调函数的参数
  • call_user_func() - 把第一个参数作为回调函数调用
  • is_callable() - 检测参数是否为合法的可调用结构


返回参数列表的某一项

  • ? forward_static_call
  • func_get_args ?
  • PHP Manual
  • 函数处理 函数
  • 返回参数列表的某一项

func_get_arg

(PHP 4, PHP 5, PHP 7, PHP 8)

func_get_arg — 返回参数列表的某一项

说明

func_get_arg ( int $arg_num ) : mixed

从用户自定义函数的参数列表中获取某个指定的参数。

该函数可以配合 func_get_args() 和 func_num_args() 一起使用，从而使得用户自定义函数可以接受自定义个数的参数列表。

参数

arg_num

参数的偏移量。函数的参数是从0开始计数的。

返回值

返回指定的参数，错误则返回 false 。

更新日志

版本 | 说明
5.3.0 | 该函数可以在参数列表中使用。
5.3.0 | If this function is called from the outermost scope of a file which has been included by calling include or require from within a function in the calling file, it now generates a warning and returns false. （不知道如何翻译跟好，直接参考例2即可明白）

错误／异常

当在自定义函数的外面调用的该函数的时候会发出一个警告， 或者是当 arg_num 比实际传入的参数的数目大的时候也会发出一个警告。

范例

Example #1 func_get_arg() 例子

<?php
function foo()
{
     $numargs = func_num_args();
     echo "Number of arguments: $numargs<br />\n";
     if ($numargs >= 2) {
         echo "Second argument is: " . func_get_arg(1) . "<br />\n";
     }
}

foo (1, 2, 3);
?>

Example #2 func_get_arg() PHP 5.3 前后对比的例子

test.php
<?php
function foo() {
    include './fga.inc';
}

foo('First arg', 'Second arg');
?>

fga.inc
<?php

$arg = func_get_arg(1);
var_export($arg);

?>

PHP 5.3 版本之前的输出：

'Second arg'

PHP 5.3 和之后的版本的输出:

Warning: func_get_arg():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fga.inc on line 3
false

Example #3 func_get_arg() example of byref and byval arguments

<?php
function byVal($arg) {
    echo 'As passed     : ', var_export(func_get_arg(0)), PHP_EOL;
    $arg = 'baz';
    echo 'After change  : ', var_export(func_get_arg(0)), PHP_EOL;
}

function byRef(&$arg) {
    echo 'As passed     : ', var_export(func_get_arg(0)), PHP_EOL;
    $arg = 'baz';
    echo 'After change  : ', var_export(func_get_arg(0)), PHP_EOL;
}

$arg = 'bar';
byVal($arg);
byRef($arg);
?>

以上例程会输出：

As passed : 'bar'
After change : 'bar'
As passed : 'bar'
After change : 'baz'

注释

Note:

因为函数依赖于当前作用域以确定参数的细节，所以在 5.3.0 以前的版本中不能用作函数的参数。如必须传递此值时，可将结果赋与一个变量，然后用此变量进行传递。

Note:

如果参数以引用方式传递，函数对该参数的任何改变将在函数返回后保留。As of PHP 7 the current values will also be returned if the arguments are passed by value.

Note: This function returns a copy of the passed arguments only, and does not account for default (non-passed) arguments.

参见

  • func_get_args() - 返回一个包含函数参数列表的数组
  • func_num_args() - Returns the number of arguments passed to the function


返回一个包含函数参数列表的数组

  • ? func_get_arg
  • func_num_args ?
  • PHP Manual
  • 函数处理 函数
  • 返回一个包含函数参数列表的数组

func_get_args

(PHP 4, PHP 5, PHP 7, PHP 8)

func_get_args — 返回一个包含函数参数列表的数组

说明

func_get_args ( ) : array

获取函数参数列表的数组。

该函数可以配合 func_get_arg() 和 func_num_args() 一起使用，从而使得用户自定义函数可以接受自定义个数的参数列表。

返回值

返回一个数组，其中每个元素都是目前用户自定义函数的参数列表的相应元素的副本。

更新日志

版本 | 说明
5.3.0 | 该函数可以在参数列表中使用。
5.3.0 | If this function is called from the outermost scope of a file which has been included by calling include or require from within a function in the calling file, it now generates a warning and returns false. （不知道如何翻译跟好，直接参考例2即可明白）

错误／异常

在用户自定义函数外调用则会出现错误警告。

范例

Example #1 func_get_args() 例子

<?php
function foo()
{
    $numargs = func_num_args();
    echo "Number of arguments: $numargs<br />\n";
    if ($numargs >= 2) {
        echo "Second argument is: " . func_get_arg(1) . "<br />\n";
    }
    $arg_list = func_get_args();
    for ($i = 0; $i < $numargs; $i++) {
        echo "Argument $i is: " . $arg_list[$i] . "<br />\n";
    }
}

foo(1, 2, 3);
?>

以上例程会输出：

Number of arguments: 3<br />
Second argument is: 2<br />
Argument 0 is: 1<br />
Argument 1 is: 2<br />
Argument 2 is: 3<br />

Example #2 PHP 5.3 前后使用 func_get_args() 在的对比

test.php
<?php
function foo() {
    include './fga.inc';
}

foo('First arg', 'Second arg');
?>

fga.inc
<?php

$args = func_get_args();
var_export($args);

?>

PHP 5.3 版本之前的输出：

array (
  0 => 'First arg',
  1 => 'Second arg',
)

PHP 5.3 和之后的版本的输出:

Warning: func_get_args():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fga.inc on line 3
false

Example #3 func_get_args() example of byref and byval arguments

<?php
function byVal($arg) {
    echo 'As passed     : ', var_export(func_get_args()), PHP_EOL;
    $arg = 'baz';
    echo 'After change  : ', var_export(func_get_args()), PHP_EOL;
}

function byRef(&$arg) {
    echo 'As passed     : ', var_export(func_get_args()), PHP_EOL;
    $arg = 'baz';
    echo 'After change  : ', var_export(func_get_args()), PHP_EOL;
}

$arg = 'bar';
byVal($arg);
byRef($arg);
?>

以上例程会输出：

As passed : array (
0 => 'bar',
)
After change : array (
0 => 'bar',
)
As passed : array (
0 => 'bar',
)
After change : array (
0 => 'baz',
)

注释

Note:

因为函数依赖于当前作用域以确定参数的细节，所以在 5.3.0 以前的版本中不能用作函数的参数。如必须传递此值时，可将结果赋与一个变量，然后用此变量进行传递。

Note:

如果参数以引用方式传递，函数对该参数的任何改变将在函数返回后保留。As of PHP 7 the current values will also be returned if the arguments are passed by value.

Note: 该函数仅仅是返回传递参数的一个副本，并且不包含没有传入的默认参数。

参见

  • func_get_arg() - 返回参数列表的某一项
  • func_num_args() - Returns the number of arguments passed to the function
  • ReflectionFunctionAbstract::getParameters() - 获取参数


Returns the number of arguments passed to the function

  • ? func_get_args
  • function_exists ?
  • PHP Manual
  • 函数处理 函数
  • Returns the number of arguments passed to the function

func_num_args

(PHP 4, PHP 5, PHP 7, PHP 8)

func_num_args — Returns the number of arguments passed to the function

说明

func_num_args ( ) : int

Gets the number of arguments passed to the function.

This function may be used in conjunction with func_get_arg() and func_get_args() to allow user-defined functions to accept variable-length argument lists.

返回值

Returns the number of arguments passed into the current user-defined function.

更新日志

版本 | 说明
5.3.0 | This function can now be used in parameter lists.
5.3.0 | If this function is called from the outermost scope of a file which has been included by calling include or require from within a function in the calling file, it now generates a warning and returns -1.

错误／异常

Generates a warning if called from outside of a user-defined function.

范例

Example #1 func_num_args() example

<?php
function foo()
{
    $numargs = func_num_args();
    echo "Number of arguments: $numargs\n";
}

foo(1, 2, 3);
?>

以上例程会输出：

Number of arguments: 3

Example #2 func_num_args() example before and after PHP 5.3

test.php
<?php
function foo() {
    include './fna.php';
}

foo('First arg', 'Second arg');
?>

fna.php
<?php

$num_args = func_num_args();
var_export($num_args);

?>

Output previous to PHP 5.3:

2

Output in PHP 5.3 and later will be something similar to:

Warning: func_num_args():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fna.php on line 3
-1

注释

Note:

因为函数依赖于当前作用域以确定参数的细节，所以在 5.3.0 以前的版本中不能用作函数的参数。如必须传递此值时，可将结果赋与一个变量，然后用此变量进行传递。

参见

  • func_get_arg() - 返回参数列表的某一项
  • func_get_args() - 返回一个包含函数参数列表的数组
  • ReflectionFunctionAbstract::getNumberOfParameters() - 获取参数数目


如果给定的函数已经被定义就返回 true

  • ? func_num_args
  • get_defined_functions ?
  • PHP Manual
  • 函数处理 函数
  • 如果给定的函数已经被定义就返回 true

function_exists

(PHP 4, PHP 5, PHP 7, PHP 8)

function_exists — 如果给定的函数已经被定义就返回 true

说明

function_exists ( string $function_name ) : bool

在已经定义的函数列表（包括系统自带的函数和用户自定义的函数）中查找 function_name。

参数

function_name

函数名，必须为一个字符串。

返回值

如果 function_name 存在且的确是一个函数就返回 true ，反之则返回 false 。

Note:

对于语法结构的判断，例如 include_once 和 echo 将会返回 false 。

范例

Example #1 function_exists() 的例子

<?php
if (function_exists('imap_open')) {
    echo "IMAP functions are available.<br />\n";
} else {
    echo "IMAP functions are not available.<br />\n";
}
?>

注释

Note:

当本配置或者编译或编译选项禁用某函数时，该函数名也可能存在（ image 就是一个现成的例子）

参见

  • method_exists() - 检查类的方法是否存在
  • is_callable() - 检测参数是否为合法的可调用结构
  • get_defined_functions() - 返回所有已定义函数的数组
  • class_exists() - 检查类是否已定义
  • extension_loaded() - 检查一个扩展是否已经加载


返回所有已定义函数的数组

  • ? function_exists
  • register_shutdown_function ?
  • PHP Manual
  • 函数处理 函数
  • 返回所有已定义函数的数组

get_defined_functions

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

get_defined_functions — 返回所有已定义函数的数组

说明

get_defined_functions ( bool $exclude_disabled = false ) : array

获取所有已定义函数的数组。

参数

exclude_disabled

禁用的函数是否应该在返回的数据里排除。

返回值

返回数组，包含了所有已定义的函数，包括内置(internal) 和用户定义的函数。 可通过$arr["internal"]来访问系统内置函数， 通过$arr["user"]来访问用户自定义函数 (参见示例)。

更新日志

版本 | 说明
PHP 7.0.15, PHP 7.1.1 | 增加 exclude_disabled 参数。

范例

Example #1 get_defined_functions() 例子

<?php
function myrow($id, $data)
{
    return "<tr><th>$id</th><td>$data</td></tr>\n";
}

$arr = get_defined_functions();

print_r($arr);
?>

以上例程的输出类似于：

Array
(
    [internal] => Array
        (
            [0] => zend_version
            [1] => func_num_args
            [2] => func_get_arg
            [3] => func_get_args
            [4] => strlen
            [5] => strcmp
            [6] => strncmp
            ...
            [750] => bcscale
            [751] => bccomp
        )

    [user] => Array
        (
            [0] => myrow
        )

)

参见

  • function_exists() - 如果给定的函数已经被定义就返回 true
  • get_defined_vars() - 返回由所有已定义变量所组成的数组
  • get_defined_constants() - 返回所有常量的关联数组，键是常量名，值是常量值
  • get_declared_classes() - 返回由已定义类的名字所组成的数组


注册一个会在php中止时执行的函数

  • ? get_defined_functions
  • register_tick_function ?
  • PHP Manual
  • 函数处理 函数
  • 注册一个会在php中止时执行的函数

register_shutdown_function

(PHP 4, PHP 5, PHP 7, PHP 8)

register_shutdown_function — 注册一个会在php中止时执行的函数

说明

register_shutdown_function ( callable $callback , mixed $parameter = ? , mixed $... = ? ) : void

注册一个 callback ，它会在脚本执行完成或者 exit() 后被调用。

可以多次调用 register_shutdown_function() ，这些被注册的回调会按照他们注册时的顺序被依次调用。 如果你在注册的方法内部调用 exit()， 那么所有处理会被中止，并且其他注册的中止回调也不会再被调用。

参数

callback

待注册的中止回调

中止回调是作为请求的一部分被执行的，因此可以在它们中进行输出或者读取输出缓冲区。

parameter

可以通过传入额外的参数来将参数传给中止函数

...

返回值

没有返回值。

错误／异常

如果传入的callback不是可调用的，那么将会产生一个 E_WARNING 级别的错误。

范例

Example #1 register_shutdown_function() 例子

<?php
function shutdown()
{
    // This is our shutdown function, in
    // here we can do any last operations
    // before the script is complete.

    echo 'Script executed with success', PHP_EOL;
}

register_shutdown_function('shutdown');
?>

注释

Note:

在某些web server（如Apache）上，可以在中止函数内对脚本的工作目录进行修改。

Note:

如果进程被信号SIGTERM或SIGKILL杀死，那么中止函数将不会被调用。尽管你无法中断SIGKILL，但你可以通过pcntl_signal() 来捕获SIGTERM，通过在其中调用exit()来进行一个正常的中止。

参见

  • auto_append_file
  • exit() - 输出一个消息并且退出当前脚本
  • 连接处理 章节


Register a function for execution on each tick

  • ? register_shutdown_function
  • unregister_tick_function ?
  • PHP Manual
  • 函数处理 函数
  • Register a function for execution on each tick

register_tick_function

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

register_tick_function — Register a function for execution on each tick

说明

register_tick_function ( callable $function , mixed $arg = ? , mixed $... = ? ) : bool

Registers the given function to be executed when a tick is called.

参数

function

The function name as a string, or an array consisting of an object and a method.

arg

...

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 register_tick_function() example

<?php
declare(ticks=1);

// using a function as the callback
register_tick_function('my_function', true);

// using an object->method
$object = new my_class();
register_tick_function(array(&$object, 'my_method'), true);
?>

更新日志

版本 | 说明
5.3.0 | Ticks are now supported on threaded web server modules.

注释

Warning

register_tick_function() should not be used with threaded web server modules with PHP 5.2 or lower.

参见

  • declare
  • unregister_tick_function() - De-register a function for execution on each tick


De-register a function for execution on each tick

  • ? register_tick_function
  • Quickhash ?
  • PHP Manual
  • 函数处理 函数
  • De-register a function for execution on each tick

unregister_tick_function

(PHP 4 >= 4.0.3, PHP 5, PHP 7, PHP 8)

unregister_tick_function — De-register a function for execution on each tick

说明

unregister_tick_function ( string $function_name ) : void

De-registers the function named by function_name so it is no longer executed when a tick is called.

参数

function_name

The function name, as a string.

返回值

没有返回值。

参见

  • register_tick_function() - Register a function for execution on each tick


Quickhash

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
  • 预定义常量
  • 范例
  • QuickHashIntSet — The QuickHashIntSet class
    • QuickHashIntSet::add — This method adds a new entry to the set
    • QuickHashIntSet::__construct — Creates a new QuickHashIntSet object
    • QuickHashIntSet::delete — This method deletes an entry from the set
    • QuickHashIntSet::exists — This method checks whether a key is part of the set
    • QuickHashIntSet::getSize — Returns the number of elements in the set
    • QuickHashIntSet::loadFromFile — This factory method creates a set from a file
    • QuickHashIntSet::loadFromString — This factory method creates a set from a string
    • QuickHashIntSet::saveToFile — This method stores an in-memory set to disk
    • QuickHashIntSet::saveToString — This method returns a serialized version of the set
  • QuickHashIntHash — The QuickHashIntHash class
    • QuickHashIntHash::add — This method adds a new entry to the hash
    • QuickHashIntHash::__construct — Creates a new QuickHashIntHash object
    • QuickHashIntHash::delete — This method deletes am entry from the hash
    • QuickHashIntHash::exists — This method checks whether a key is part of the hash
    • QuickHashIntHash::get — This method retrieves a value from the hash by its key
    • QuickHashIntHash::getSize — Returns the number of elements in the hash
    • QuickHashIntHash::loadFromFile — This factory method creates a hash from a file
    • QuickHashIntHash::loadFromString — This factory method creates a hash from a string
    • QuickHashIntHash::saveToFile — This method stores an in-memory hash to disk
    • QuickHashIntHash::saveToString — This method returns a serialized version of the hash
    • QuickHashIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashIntHash::update — This method updates an entry in the hash with a new value
  • QuickHashStringIntHash — The QuickHashStringIntHash class
    • QuickHashStringIntHash::add — This method adds a new entry to the hash
    • QuickHashStringIntHash::__construct — Creates a new QuickHashStringIntHash object
    • QuickHashStringIntHash::delete — This method deletes am entry from the hash
    • QuickHashStringIntHash::exists — This method checks whether a key is part of the hash
    • QuickHashStringIntHash::get — This method retrieves a value from the hash by its key
    • QuickHashStringIntHash::getSize — Returns the number of elements in the hash
    • QuickHashStringIntHash::loadFromFile — This factory method creates a hash from a file
    • QuickHashStringIntHash::loadFromString — This factory method creates a hash from a string
    • QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk
    • QuickHashStringIntHash::saveToString — This method returns a serialized version of the hash
    • QuickHashStringIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashStringIntHash::update — This method updates an entry in the hash with a new value
  • QuickHashIntStringHash — The QuickHashIntStringHash class
    • QuickHashIntStringHash::add — This method adds a new entry to the hash
    • QuickHashIntStringHash::__construct — Creates a new QuickHashIntStringHash object
    • QuickHashIntStringHash::delete — This method deletes am entry from the hash
    • QuickHashIntStringHash::exists — This method checks whether a key is part of the hash
    • QuickHashIntStringHash::get — This method retrieves a value from the hash by its key
    • QuickHashIntStringHash::getSize — Returns the number of elements in the hash
    • QuickHashIntStringHash::loadFromFile — This factory method creates a hash from a file
    • QuickHashIntStringHash::loadFromString — This factory method creates a hash from a string
    • QuickHashIntStringHash::saveToFile — This method stores an in-memory hash to disk
    • QuickHashIntStringHash::saveToString — This method returns a serialized version of the hash
    • QuickHashIntStringHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashIntStringHash::update — This method updates an entry in the hash with a new value


简介

The quickhash extension contains a set of specific strongly-typed classes to deal with specific set and hash implementations.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Quickhash
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置


需求

This extension requires no additional libraries.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/quickhash


  • ? 运行时配置
  • 范例 ?
  • PHP Manual
  • Quickhash
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

Example #1 Quickhash Example

<?php
$set = new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES );
$set->add( 1 );
$set->add( 3 );

var_dump( $set->exists( 3 ) );
var_dump( $set->exists( 4 ) );

$set->saveToFile( "/tmp/test-set.set" );

$newSet = QuickHashIntSet::loadFromFile(
    "/tmp/test-set.set"
);

var_dump( $newSet->exists( 3 ) );
var_dump( $newSet->exists( 4 ) );
?>

以上例程的输出类似于：

bool(true)
bool(false)
bool(true)
bool(false)

Example #2 Quickhash ArrayAccess Example

<?php
$hash = new QuickHashIntHash( 64 );

// Adding and updating hash entries.
$hash[3] = 145926;
$hash[3] = 1415926;
$hash[2] = 72;

// Checking if keys exist
var_dump( isset( $hash[3] ) );

// Removing hash entries
unset( $hash[2] );

// Retrieving the value stored for a hash
echo $hash[3], "\n";
?>

以上例程的输出类似于：

bool(true)
1415926

Example #3 Quickhash Iterator Example

<?php
$hash = new QuickHashIntHash( 64 );

// Adding hash entries.
$hash[1] = 145926;
$hash[2] = 1415926;
$hash[3] = 72;
$hash[4] = 712314;
$hash[5] = -4234;

foreach( $hash as $key => $value )
{
    echo $key, ' => ', $value, "\n";
}
?>

以上例程的输出类似于：

5 => -4234
4 => 712314
1 => 145926
2 => 1415926
3 => 72

Example #4 Quickhash String Values Example

<?php
$hash = new QuickHashIntStringHash( 64 );

// Adding hash entries.
$hash[1] = "one million four hundred fifteen thousand nine hundred twenty six";
$hash->add( 2, "one more" );

foreach( $hash as $key => $value )
{
    echo $key, ' => ', $value, "\n";
}
?>

以上例程的输出类似于：

1 => one million four hundred fifteen thousand nine hundred twenty six
2 => one more


The QuickHashIntSet class

(PECL quickhash >= Unknown)

简介

This class wraps around a set containing integer numbers.

Sets can also be iterated over with foreach as the Iterator interface is implemented as well. The order of which elements are returned in is not guaranteed.

类摘要

QuickHashIntSet {
/* Constants */
const int CHECK_FOR_DUPES = 1 ;
const int DO_NOT_USE_ZEND_ALLOC = 2 ;
const int HASHER_NO_HASH = 256 ;
const int HASHER_JENKINS1 = 512 ;
const int HASHER_JENKINS2 = 1024 ;
/* Methods */
public add ( int $key ) : bool
public __construct ( int $size , int $options = ? )
public delete ( int $key ) : bool
public exists ( int $key ) : bool
publicgetSize ( ) : int
public static loadFromFile ( string $filename , int $size = ? , int $options = ? ) : QuickHashIntSet
public static loadFromString ( string $contents , int $size = ? , int $options = ? ) : QuickHashIntSet
public saveToFile ( string $filename ) : void
public saveToString ( ) : string
}

预定义常量

QuickHashIntSet::CHECK_FOR_DUPES

If enabled, adding duplicate elements to a set (through either add() or loadFromFile()) will result in those elements to be dropped from the set. This will take up extra time, so only used when it is required.

QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

QuickHashIntSet::HASHER_NO_HASH

Selects to not use a hashing function, but merely use a modulo to find the bucket list index. This is not faster than normal hashing, and gives more collisions.

QuickHashIntSet::HASHER_JENKINS1

This is the default hashing function to turn the integer hashes into bucket list indexes.

QuickHashIntSet::HASHER_JENKINS2

Selects a variant hashing algorithm.

Table of Contents

  • QuickHashIntSet::add — This method adds a new entry to the set
  • QuickHashIntSet::__construct — Creates a new QuickHashIntSet object
  • QuickHashIntSet::delete — This method deletes an entry from the set
  • QuickHashIntSet::exists — This method checks whether a key is part of the set
  • QuickHashIntSet::getSize — Returns the number of elements in the set
  • QuickHashIntSet::loadFromFile — This factory method creates a set from a file
  • QuickHashIntSet::loadFromString — This factory method creates a set from a string
  • QuickHashIntSet::saveToFile — This method stores an in-memory set to disk
  • QuickHashIntSet::saveToString — This method returns a serialized version of the set


This method adds a new entry to the set

  • ? QuickHashIntSet
  • QuickHashIntSet::__construct ?
  • PHP Manual
  • QuickHashIntSet
  • This method adds a new entry to the set

QuickHashIntSet::add

(PECL quickhash >= Unknown)

QuickHashIntSet::add — This method adds a new entry to the set

说明

public QuickHashIntSet::add ( int $key ) : bool

This method adds a new entry to the set, and returns whether the entry was added. Entries are by default always added unless QuickHashIntSet::CHECK_FOR_DUPES has been passed when the set was created.

参数

key

The key of the entry to add.

返回值

true when the entry was added, and false if the entry was not added.

范例

Example #1 QuickHashIntSet::add() example

<?php
echo "without dupe checking\n";
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );

echo "\nwith dupe checking\n";
$set = new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
?>

以上例程的输出类似于：

without dupe checking
bool(false)
bool(true)
bool(true)
bool(true)

with dupe checking
bool(false)
bool(true)
bool(true)
bool(false)


Creates a new QuickHashIntSet object

  • ? QuickHashIntSet::add
  • QuickHashIntSet::delete ?
  • PHP Manual
  • QuickHashIntSet
  • Creates a new QuickHashIntSet object

QuickHashIntSet::__construct

(PECL quickhash >= Unknown)

QuickHashIntSet::__construct — Creates a new QuickHashIntSet object

说明

public QuickHashIntSet::__construct ( int $size , int $options = ? )

This constructor creates a new QuickHashIntSet. The size is the amount of bucket lists to create. The more lists there are, the less collisions you will have. Options are also supported.

参数

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The options that you can pass in are: QuickHashIntSet::CHECK_FOR_DUPES, which makes sure no duplicate entries are added to the set; QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC to not use PHP's internal memory manager as well as one of QuickHashIntSet::HASHER_NO_HASH, QuickHashIntSet::HASHER_JENKINS1 or QuickHashIntSet::HASHER_JENKINS2. These last three configure which hashing algorithm to use. All options can be combined using bitmasks.

返回值

Returns a new QuickHashIntSet object.

范例

Example #1 QuickHashIntSet::__construct() example

<?php
var_dump( new QuickHashIntSet( 1024 ) );
var_dump( new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntSet(
        1024,
        QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC | QuickHashIntSet::HASHER_JENKINS2
    )
);
?>


This method deletes an entry from the set

  • ? QuickHashIntSet::__construct
  • QuickHashIntSet::exists ?
  • PHP Manual
  • QuickHashIntSet
  • This method deletes an entry from the set

QuickHashIntSet::delete

(PECL quickhash >= Unknown)

QuickHashIntSet::delete — This method deletes an entry from the set

说明

public QuickHashIntSet::delete ( int $key ) : bool

This method deletes an entry from the set, and returns whether the entry was deleted or not. Associated memory structures will not be freed immediately, but rather when the set itself is freed.

参数

key

The key of the entry to delete.

返回值

true when the entry was deleted, and false if the entry was not deleted.

范例

Example #1 QuickHashIntSet::delete() example

<?php
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->delete( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->delete( 4 ) );
?>

以上例程的输出类似于：

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)


This method checks whether a key is part of the set

  • ? QuickHashIntSet::delete
  • QuickHashIntSet::getSize ?
  • PHP Manual
  • QuickHashIntSet
  • This method checks whether a key is part of the set

QuickHashIntSet::exists

(PECL quickhash >= Unknown)

QuickHashIntSet::exists — This method checks whether a key is part of the set

说明

public QuickHashIntSet::exists ( int $key ) : bool

This method checks whether an entry with the provided key exists in the set.

参数

key

The key of the entry to check for whether it exists in the set.

返回值

Returns true when the entry was found, or false when the entry is not found.

范例

Example #1 QuickHashIntSet::exists() example

<?php
//generate 200000 elements
$array = range( 0, 199999 );
$existingEntries = array_rand( array_flip( $array ), 180000 );
$testForEntries = array_rand( array_flip( $array ), 1000 );
$foundCount = 0;

echo "Creating set: ", microtime( true ), "\n";
$set = new QuickHashIntSet( 100000 );
echo "Adding elements: ", microtime( true ), "\n";
foreach( $existingEntries as $key )
{
     $set->add( $key );
}

echo "Doing 1000 tests: ", microtime( true ), "\n";
foreach( $testForEntries as $key )
{
     $foundCount += $set->exists( $key );
}
echo "Done, $foundCount found: ", microtime( true ), "\n";
?>

以上例程的输出类似于：

Creating set: 1263588703.0748
Adding elements: 1263588703.0757
Doing 1000 tests: 1263588703.7851
Done, 898 found: 1263588703.7897


Returns the number of elements in the set

  • ? QuickHashIntSet::exists
  • QuickHashIntSet::loadFromFile ?
  • PHP Manual
  • QuickHashIntSet
  • Returns the number of elements in the set

QuickHashIntSet::getSize

(PECL quickhash >= Unknown)

QuickHashIntSet::getSize — Returns the number of elements in the set

说明

publicQuickHashIntSet::getSize ( ) : int

Returns the number of elements in the set.

参数

key

The key of the entry to add.

返回值

The number of elements in the set.

范例

Example #1 QuickHashIntSet::getSize() example

<?php
$set = new QuickHashIntSet( 8 );
var_dump( $set->add( 2 ) );
var_dump( $set->add( 3 ) );
var_dump( $set->getSize() );
?>

以上例程的输出类似于：

bool(true)
bool(true)
int(2)


This factory method creates a set from a file

  • ? QuickHashIntSet::getSize
  • QuickHashIntSet::loadFromString ?
  • PHP Manual
  • QuickHashIntSet
  • This factory method creates a set from a file

QuickHashIntSet::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntSet::loadFromFile — This factory method creates a set from a file

说明

public static QuickHashIntSet::loadFromFile ( string $filename , int $size = ? , int $options = ? ) : QuickHashIntSet

This factory method creates a new set from a definition file on disk. The file format consists of 32 bit signed integers packed together in the Endianness that the system that the code runs on uses.

参数

filename

The filename of the file to read the set from.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the set, rounded up to the nearest power of two with a maximum limit of 4194304.

返回值

Returns a new QuickHashIntSet.

范例

Example #1 QuickHashIntSet::loadFromFile() example

<?php
$file = dirname( __FILE__ ) . "/simple.set";
$set = QuickHashIntSet::loadFromFile(
    $file,
    QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $set->exists( $key ) ? 'set' : 'unset'
    );
}
?>

以上例程的输出类似于：

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset


This factory method creates a set from a string

  • ? QuickHashIntSet::loadFromFile
  • QuickHashIntSet::saveToFile ?
  • PHP Manual
  • QuickHashIntSet
  • This factory method creates a set from a string

QuickHashIntSet::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntSet::loadFromString — This factory method creates a set from a string

说明

public static QuickHashIntSet::loadFromString ( string $contents , int $size = ? , int $options = ? ) : QuickHashIntSet

This factory method creates a new set from a definition in a string. The file format consists of 32 bit signed integers packed together in the Endianness that the system that the code runs on uses.

参数

contents

The string containing a serialized format of the set.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the set, rounded up to the nearest power of two automatically limited from 64 to 4194304.

返回值

Returns a new QuickHashIntSet.

范例

Example #1 QuickHashIntSet::loadFromString() example

<?php
$contents = file_get_contents( dirname( __FILE__ ) . "/simple.set" );
$set = QuickHashIntSet::loadFromString(
    $contents,
    QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $set->exists( $key ) ? 'set' : 'unset'
    );
}
?>

以上例程的输出类似于：

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset


This method stores an in-memory set to disk

  • ? QuickHashIntSet::loadFromString
  • QuickHashIntSet::saveToString ?
  • PHP Manual
  • QuickHashIntSet
  • This method stores an in-memory set to disk

QuickHashIntSet::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntSet::saveToFile — This method stores an in-memory set to disk

说明

public QuickHashIntSet::saveToFile ( string $filename ) : void

This method stores an existing set to a file on disk, in the same format that loadFromFile() can read.

参数

filename

The filename of the file to store the hash in.

返回值

没有返回值。

范例

Example #1 QuickHashIntSet::saveToFile() example

<?php
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );

$set->saveToFile( '/tmp/test.set' );
?>


This method returns a serialized version of the set

  • ? QuickHashIntSet::saveToFile
  • QuickHashIntHash ?
  • PHP Manual
  • QuickHashIntSet
  • This method returns a serialized version of the set

QuickHashIntSet::saveToString

(PECL quickhash >= Unknown)

QuickHashIntSet::saveToString — This method returns a serialized version of the set

说明

public QuickHashIntSet::saveToString ( ) : string

This method returns a serialized version of the set in the same format that loadFromString() can read.

返回值

This method returns a string containing a serialized format of the set. Each element is stored as a four byte value in the Endianness that the current system uses.

范例

Example #1 QuickHashIntSet::saveToString() example

<?php
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );

var_dump( $set->saveToString() );
?>


The QuickHashIntHash class

(PECL quickhash >= Unknown)

简介

This class wraps around a hash containing integer numbers, where the values are also integer numbers. Hashes are also available as implementation of the ArrayAccess interface.

Hashes can also be iterated over with foreach as the Iterator interface is implemented as well. The order of which elements are returned in is not guaranteed.

类摘要

QuickHashIntHash {
/* Constants */
const int CHECK_FOR_DUPES = 1 ;
const int DO_NOT_USE_ZEND_ALLOC = 2 ;
const int HASHER_NO_HASH = 256 ;
const int HASHER_JENKINS1 = 512 ;
const int HASHER_JENKINS2 = 1024 ;
/* Methods */
public add ( int $key , int $value = ? ) : bool
public __construct ( int $size , int $options = ? )
public delete ( int $key ) : bool
public exists ( int $key ) : bool
public get ( int $key ) : int
public getSize ( ) : int
public static loadFromFile ( string $filename , int $options = ? ) : QuickHashIntHash
public static loadFromString ( string $contents , int $options = ? ) : QuickHashIntHash
public saveToFile ( string $filename ) : void
public saveToString ( ) : string
public set ( int $key , int $value ) : bool
public update ( int $key , int $value ) : bool
}

预定义常量

QuickHashIntHash::CHECK_FOR_DUPES

If enabled, adding duplicate elements to a set (through either add() or loadFromFile()) will result in those elements to be dropped from the set. This will take up extra time, so only used when it is required.

QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

QuickHashIntHash::HASHER_NO_HASH

Selects to not use a hashing function, but merely use a modulo to find the bucket list index. This is not faster than normal hashing, and gives more collisions.

QuickHashIntHash::HASHER_JENKINS1

This is the default hashing function to turn the integer hashes into bucket list indexes.

QuickHashIntHash::HASHER_JENKINS2

Selects a variant hashing algorithm.

Table of Contents

  • QuickHashIntHash::add — This method adds a new entry to the hash
  • QuickHashIntHash::__construct — Creates a new QuickHashIntHash object
  • QuickHashIntHash::delete — This method deletes am entry from the hash
  • QuickHashIntHash::exists — This method checks whether a key is part of the hash
  • QuickHashIntHash::get — This method retrieves a value from the hash by its key
  • QuickHashIntHash::getSize — Returns the number of elements in the hash
  • QuickHashIntHash::loadFromFile — This factory method creates a hash from a file
  • QuickHashIntHash::loadFromString — This factory method creates a hash from a string
  • QuickHashIntHash::saveToFile — This method stores an in-memory hash to disk
  • QuickHashIntHash::saveToString — This method returns a serialized version of the hash
  • QuickHashIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
  • QuickHashIntHash::update — This method updates an entry in the hash with a new value


This method adds a new entry to the hash

  • ? QuickHashIntHash
  • QuickHashIntHash::__construct ?
  • PHP Manual
  • QuickHashIntHash
  • This method adds a new entry to the hash

QuickHashIntHash::add

(PECL quickhash >= Unknown)

QuickHashIntHash::add — This method adds a new entry to the hash

说明

public QuickHashIntHash::add ( int $key , int $value = ? ) : bool

This method adds a new entry to the hash, and returns whether the entry was added. Entries are by default always added unless QuickHashIntHash::CHECK_FOR_DUPES has been passed when the hash was created.

参数

key

The key of the entry to add.

value

The optional value of the entry to add. If no value is specified, 1 will be used.

返回值

true when the entry was added, and false if the entry was not added.

范例

Example #1 QuickHashIntHash::add() example

<?php
echo "without dupe checking\n";
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 22 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 12 ) );

echo "\nwith dupe checking\n";
$hash = new QuickHashIntHash( 1024, QuickHashIntHash::CHECK_FOR_DUPES );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 78 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 9 ) );

echo "\ndefault value\n";
var_dump( $hash->add( 5 ) );
var_dump( $hash->get( 5 ) );
?>

以上例程的输出类似于：

without dupe checking
bool(false)
bool(false)
bool(true)
bool(true)
int(22)
bool(true)

with dupe checking
bool(false)
bool(false)
bool(true)
bool(true)
int(78)
bool(false)

default value
bool(true)
int(1)


Creates a new QuickHashIntHash object

  • ? QuickHashIntHash::add
  • QuickHashIntHash::delete ?
  • PHP Manual
  • QuickHashIntHash
  • Creates a new QuickHashIntHash object

QuickHashIntHash::__construct

(PECL quickhash >= Unknown)

QuickHashIntHash::__construct — Creates a new QuickHashIntHash object

说明

public QuickHashIntHash::__construct ( int $size , int $options = ? )

This constructor creates a new QuickHashIntHash. The size is the amount of bucket lists to create. The more lists there are, the less collisions you will have. Options are also supported.

参数

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 64 to 4194304.

options

The options that you can pass in are: QuickHashIntHash::CHECK_FOR_DUPES, which makes sure no duplicate entries are added to the hash; QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC to not use PHP's internal memory manager as well as one of QuickHashIntHash::HASHER_NO_HASH, QuickHashIntHash::HASHER_JENKINS1 or QuickHashIntHash::HASHER_JENKINS2. These last three configure which hashing algorithm to use. All options can be combined using bitmasks.

返回值

Returns a new QuickHashIntHash object.

范例

Example #1 QuickHashIntHash::__construct() example

<?php
var_dump( new QuickHashIntHash( 1024 ) );
var_dump( new QuickHashIntHash( 1024, QuickHashIntHash::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntHash(
        1024,
        QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC | QuickHashIntHash::HASHER_JENKINS2
    )
);
?>


This method deletes am entry from the hash

  • ? QuickHashIntHash::__construct
  • QuickHashIntHash::exists ?
  • PHP Manual
  • QuickHashIntHash
  • This method deletes am entry from the hash

QuickHashIntHash::delete

(PECL quickhash >= Unknown)

QuickHashIntHash::delete — This method deletes am entry from the hash

说明

public QuickHashIntHash::delete ( int $key ) : bool

This method deletes an entry from the hash, and returns whether the entry was deleted or not. Associated memory structures will not be freed immediately, but rather when the hash itself is freed.

Elements can not be deleted when the hash is used in an iterator. The method will not throw an exception, but simply return false like would happen with any other deletion failure.

参数

key

The key of the entry to delete.

返回值

true when the entry was deleted, and false if the entry was not deleted.

范例

Example #1 QuickHashIntHash::delete() example

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 5 ) );
var_dump( $hash->delete( 4 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->delete( 4 ) );
?>

以上例程的输出类似于：

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)


This method checks whether a key is part of the hash

  • ? QuickHashIntHash::delete
  • QuickHashIntHash::get ?
  • PHP Manual
  • QuickHashIntHash
  • This method checks whether a key is part of the hash

QuickHashIntHash::exists

(PECL quickhash >= Unknown)

QuickHashIntHash::exists — This method checks whether a key is part of the hash

说明

public QuickHashIntHash::exists ( int $key ) : bool

This method checks whether an entry with the provided key exists in the hash.

参数

key

The key of the entry to check for whether it exists in the hash.

返回值

Returns true when the entry was found, or false when the entry is not found.

范例

Example #1 QuickHashIntHash::exists() example

<?php
//generate 200000 elements
$array = range( 0, 199999 );
$existingEntries = array_rand( array_flip( $array ), 180000 );
$testForEntries = array_rand( array_flip( $array ), 1000 );
$foundCount = 0;

echo "Creating hash: ", microtime( true ), "\n";
$hash = new QuickHashIntHash( 100000 );
echo "Adding elements: ", microtime( true ), "\n";
foreach( $existingEntries as $key )
{
     $hash->add( $key, 56 );
}

echo "Doing 1000 tests: ", microtime( true ), "\n";
foreach( $testForEntries as $key )
{
     $foundCount += $hash->exists( $key );
}
echo "Done, $foundCount found: ", microtime( true ), "\n";
?>

以上例程的输出类似于：

Creating hash: 1263588703.0748
Adding elements: 1263588703.0757
Doing 1000 tests: 1263588703.7851
Done, 898 found: 1263588703.7897


This method retrieves a value from the hash by its key

  • ? QuickHashIntHash::exists
  • QuickHashIntHash::getSize ?
  • PHP Manual
  • QuickHashIntHash
  • This method retrieves a value from the hash by its key

QuickHashIntHash::get

(PECL quickhash >= Unknown)

QuickHashIntHash::get — This method retrieves a value from the hash by its key

说明

public QuickHashIntHash::get ( int $key ) : int

This method retrieves a value from the hash by its key.

参数

key

The key of the entry to add.

返回值

The value if the key exists, or null if the key wasn't part of the hash.

范例

Example #1 QuickHashIntHash::get() example

<?php
$hash = new QuickHashIntHash( 8 );
var_dump( $hash->get( 1 ) );

var_dump( $hash->add( 2 ) );
var_dump( $hash->get( 2 ) );

var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->get( 3 ) );
?>

以上例程的输出类似于：

bool(false)
bool(true)
int(1)
bool(true)
int(5)


Returns the number of elements in the hash

  • ? QuickHashIntHash::get
  • QuickHashIntHash::loadFromFile ?
  • PHP Manual
  • QuickHashIntHash
  • Returns the number of elements in the hash

QuickHashIntHash::getSize

(PECL quickhash >= Unknown)

QuickHashIntHash::getSize — Returns the number of elements in the hash

说明

public QuickHashIntHash::getSize ( ) : int

Returns the number of elements in the hash.

参数

key

The key of the entry to add.

返回值

The number of elements in the hash.

范例

Example #1 QuickHashIntHash::getSize() example

<?php
$hash = new QuickHashIntHash( 8 );
var_dump( $hash->add( 2 ) );
var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->getSize() );
?>

以上例程的输出类似于：

bool(true)
bool(true)
int(2)


This factory method creates a hash from a file

  • ? QuickHashIntHash::getSize
  • QuickHashIntHash::loadFromString ?
  • PHP Manual
  • QuickHashIntHash
  • This factory method creates a hash from a file

QuickHashIntHash::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntHash::loadFromFile — This factory method creates a hash from a file

说明

public static QuickHashIntHash::loadFromFile ( string $filename , int $options = ? ) : QuickHashIntHash

This factory method creates a new hash from a definition file on disk. The file format consists of a signature 'QH\0x11\0', the number of elements as a 32 bit signed integer in system Endianness, followed by 32 bit signed integers packed together in the Endianness that the system that the code runs on uses. For each hash element there are two 32 bit signed integers stored. The first of each element is the key, and the second is the value belonging to the key. An example could be:

Example #1 QuickHash IntHash file format

00000000  51 48 11 00 02 00 00 00  01 00 00 00 01 00 00 00  |QH..............|
00000010  03 00 00 00 09 00 00 00                           |........|
00000018

Example #2 QuickHash IntHash file format

header signature ('QH'; key type: 1; value type: 1; filler: \0x00)
00000000  51 48 11 00

number of elements:
00000004  02 00 00 00

data string:
00000000  01 00 00 00 01 00 00 00  03 00 00 00 09 00 00 00

key/value 1 (key = 1, value = 1)
01 00 00 00  01 00 00 00

key/value 2 (key = 3, value = 9)
03 00 00 00  09 00 00 00

参数

filename

The filename of the file to read the hash from.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

返回值

Returns a new QuickHashIntHash.

范例

Example #3 QuickHashIntHash::loadFromFile() example

<?php
$file = dirname( __FILE__ ) . "/simple.hash";
$hash = QuickHashIntHash::loadFromFile(
    $file,
    QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $hash->exists( $key ) ? 'set' : 'unset'
    );
}
?>

以上例程的输出类似于：

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset


This factory method creates a hash from a string

  • ? QuickHashIntHash::loadFromFile
  • QuickHashIntHash::saveToFile ?
  • PHP Manual
  • QuickHashIntHash
  • This factory method creates a hash from a string

QuickHashIntHash::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntHash::loadFromString — This factory method creates a hash from a string

说明

public static QuickHashIntHash::loadFromString ( string $contents , int $options = ? ) : QuickHashIntHash

This factory method creates a new hash from a definition in a string. The file format consists of 32 bit signed integers packed together in the Endianness that the system that the code runs on uses. For each element there are two 32 bit signed integers stored. The first of each element is the key, and the second is the value belonging to the key.

参数

contents

The string containing a serialized format of the hash.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

返回值

Returns a new QuickHashIntHash.

范例

Example #1 QuickHashIntHash::loadFromString() example

<?php
$contents = file_get_contents( dirname( __FILE__ ) . "/simple.hash" );
$hash = QuickHashIntHash::loadFromString(
    $contents,
    QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $hash->exists( $key ) ? 'set' : 'unset'
    );
}
?>

以上例程的输出类似于：

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset


This method stores an in-memory hash to disk

  • ? QuickHashIntHash::loadFromString
  • QuickHashIntHash::saveToString ?
  • PHP Manual
  • QuickHashIntHash
  • This method stores an in-memory hash to disk

QuickHashIntHash::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntHash::saveToFile — This method stores an in-memory hash to disk

说明

public QuickHashIntHash::saveToFile ( string $filename ) : void

This method stores an existing hash to a file on disk, in the same format that loadFromFile() can read.

参数

filename

The filename of the file to store the hash in.

返回值

没有返回值。

范例

Example #1 QuickHashIntHash::saveToFile() example

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 43 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 52 ) );

$hash->saveToFile( '/tmp/test.hash' );
?>


This method returns a serialized version of the hash

  • ? QuickHashIntHash::saveToFile
  • QuickHashIntHash::set ?
  • PHP Manual
  • QuickHashIntHash
  • This method returns a serialized version of the hash

QuickHashIntHash::saveToString

(PECL quickhash >= Unknown)

QuickHashIntHash::saveToString — This method returns a serialized version of the hash

说明

public QuickHashIntHash::saveToString ( ) : string

This method returns a serialized version of the hash in the same format that loadFromString() can read.

返回值

This method returns a string containing a serialized format of the hash. Each element is stored as a four byte value in the Endianness that the current system uses.

范例

Example #1 QuickHashIntHash::saveToString() example

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 34 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 55 ) );

var_dump( $hash->saveToString() );
?>


This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

  • ? QuickHashIntHash::saveToString
  • QuickHashIntHash::update ?
  • PHP Manual
  • QuickHashIntHash
  • This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

QuickHashIntHash::set

(PECL quickhash >= Unknown)

QuickHashIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

说明

public QuickHashIntHash::set ( int $key , int $value ) : bool

This method tries to update an entry with a new value. In case the entry did not yet exist, it will instead add a new entry. It returns whether the entry was added or update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashIntHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

参数

key

The key of the entry to add or update.

value

The new value to set the entry with.

返回值

2 if the entry was found and updated, 1 if the entry was newly added or 0 if there was an error.

范例

Example #1 QuickHashIntHash::set() example

<?php
$hash = new QuickHashIntHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( 46692 ) );
var_dump( $hash->set( 46692, 16091 ) );
var_dump( $hash->get( 46692 ) );

echo "Set->Update\n";
var_dump( $hash->set( 46692, 29906 ) );
var_dump( $hash->get( 46692 ) );
?>

以上例程的输出类似于：

bool(false)
int(2)
int(16091)
Set->Update
int(1)
int(29906)


This method updates an entry in the hash with a new value

  • ? QuickHashIntHash::set
  • QuickHashStringIntHash ?
  • PHP Manual
  • QuickHashIntHash
  • This method updates an entry in the hash with a new value

QuickHashIntHash::update

(PECL quickhash >= Unknown)

QuickHashIntHash::update — This method updates an entry in the hash with a new value

说明

public QuickHashIntHash::update ( int $key , int $value ) : bool

This method updates an entry with a new value, and returns whether the entry was update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashIntHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

参数

key

The key of the entry to add.

value

The new value to update the entry with.

返回值

true when the entry was found and updated, and false if the entry was not part of the hash already.

范例

Example #1 QuickHashIntHash::update() example

<?php
$hash = new QuickHashIntHash( 1024 );

var_dump( $hash->add( 141421, 173205 ) );
var_dump( $hash->update( 141421, 223606 ) );
var_dump( $hash->get( 141421 ) );
?>

以上例程的输出类似于：

bool(true)
bool(true)
int(223606)


The QuickHashStringIntHash class

(No version information available, might only be in Git)

简介

This class wraps around a hash containing strings, where the values are integer numbers. Hashes are also available as implementation of the ArrayAccess interface.

Hashes can also be iterated over with foreach as the Iterator interface is implemented as well. The order of which elements are returned in is not guaranteed.

类摘要

QuickHashStringIntHash {
/* Constants */
const int CHECK_FOR_DUPES = 1 ;
const int DO_NOT_USE_ZEND_ALLOC = 2 ;
/* Methods */
public add ( string $key , int $value ) : bool
public __construct ( int $size , int $options = 0 )
public delete ( string $key ) : bool
public exists ( string $key ) : bool
public get ( string $key ) : mixed
public getSize ( ) : int
public static loadFromFile ( string $filename , int $size = 0 , int $options = 0 ) : QuickHashStringIntHash
public static loadFromString ( string $contents , int $size = 0 , int $options = 0 ) : QuickHashStringIntHash
public saveToFile ( string $filename ) : void
public saveToString ( ) : string
public set ( string $key , int $value ) : int
public update ( string $key , int $value ) : bool
}

预定义常量

QuickHashStringIntHash::CHECK_FOR_DUPES

If enabled, adding duplicate elements to a set (through either add() or loadFromFile()) will result in those elements to be dropped from the set. This will take up extra time, so only used when it is required.

QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

Table of Contents

  • QuickHashStringIntHash::add — This method adds a new entry to the hash
  • QuickHashStringIntHash::__construct — Creates a new QuickHashStringIntHash object
  • QuickHashStringIntHash::delete — This method deletes am entry from the hash
  • QuickHashStringIntHash::exists — This method checks whether a key is part of the hash
  • QuickHashStringIntHash::get — This method retrieves a value from the hash by its key
  • QuickHashStringIntHash::getSize — Returns the number of elements in the hash
  • QuickHashStringIntHash::loadFromFile — This factory method creates a hash from a file
  • QuickHashStringIntHash::loadFromString — This factory method creates a hash from a string
  • QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk
  • QuickHashStringIntHash::saveToString — This method returns a serialized version of the hash
  • QuickHashStringIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
  • QuickHashStringIntHash::update — This method updates an entry in the hash with a new value


This method adds a new entry to the hash

  • ? QuickHashStringIntHash
  • QuickHashStringIntHash::__construct ?
  • PHP Manual
  • QuickHashStringIntHash
  • This method adds a new entry to the hash

QuickHashStringIntHash::add

(No version information available, might only be in Git)

QuickHashStringIntHash::add — This method adds a new entry to the hash

说明

public QuickHashStringIntHash::add ( string $key , int $value ) : bool

This method adds a new entry to the hash, and returns whether the entry was added. Entries are by default always added unless QuickHashStringIntHash::CHECK_FOR_DUPES has been passed when the hash was created.

参数

key

The key of the entry to add.

value

The value of the entry to add.

返回值

true when the entry was added, and false if the entry was not added.

范例

Example #1 QuickHashStringIntHash::add() example

<?php
echo "without dupe checking\n";
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 22 ) );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 12 ) );

echo "\nwith dupe checking\n";
$hash = new QuickHashStringIntHash( 1024, QuickHashStringIntHash::CHECK_FOR_DUPES );
var_dump( $hash );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 78 ) );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 9 ) );
?>

以上例程的输出类似于：

without dupe checking
object(QuickHashStringIntHash)#1 (0) {
}
bool(false)
bool(false)
bool(true)
bool(true)
int(22)
bool(true)

with dupe checking
object(QuickHashStringIntHash)#2 (0) {
}
bool(false)
bool(false)
bool(true)
bool(true)
int(78)
bool(false)


Creates a new QuickHashStringIntHash object

  • ? QuickHashStringIntHash::add
  • QuickHashStringIntHash::delete ?
  • PHP Manual
  • QuickHashStringIntHash
  • Creates a new QuickHashStringIntHash object

QuickHashStringIntHash::__construct

(No version information available, might only be in Git)

QuickHashStringIntHash::__construct — Creates a new QuickHashStringIntHash object

说明

public QuickHashStringIntHash::__construct ( int $size , int $options = 0 )

This constructor creates a new QuickHashStringIntHash. The size is the amount of bucket lists to create. The more lists there are, the less collisions you will have. Options are also supported.

参数

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 64 to 4194304.

options

The options that you can pass in are: QuickHashStringIntHash::CHECK_FOR_DUPES, which makes sure no duplicate entries are added to the hash and QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC to not use PHP's internal memory manager.

返回值

Returns a new QuickHashStringIntHash object.

范例

Example #1 QuickHashStringIntHash::__construct() example

<?php
var_dump( new QuickHashStringIntHash( 1024 ) );
var_dump( new QuickHashStringIntHash( 1024, QuickHashStringIntHash::CHECK_FOR_DUPES ) );
?>


This method deletes am entry from the hash

  • ? QuickHashStringIntHash::__construct
  • QuickHashStringIntHash::exists ?
  • PHP Manual
  • QuickHashStringIntHash
  • This method deletes am entry from the hash

QuickHashStringIntHash::delete

(No version information available, might only be in Git)

QuickHashStringIntHash::delete — This method deletes am entry from the hash

说明

public QuickHashStringIntHash::delete ( string $key ) : bool

This method deletes an entry from the hash, and returns whether the entry was deleted or not. Associated memory structures will not be freed immediately, but rather when the hash itself is freed.

Elements can not be deleted when the hash is used in an iterator. The method will not throw an exception, but simply return false like would happen with any other deletion failure.

参数

key

The key of the entry to delete.

返回值

true when the entry was deleted, and false if the entry was not deleted.

范例

Example #1 QuickHashStringIntHash::delete() example

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->exists( 'four' ) );
var_dump( $hash->add( 'four', 5 ) );
var_dump( $hash->get( 'four' ) );
var_dump( $hash->delete( 'four' ) );
var_dump( $hash->exists( 'four' ) );
var_dump( $hash->get( 'four' ) );
var_dump( $hash->delete( 'four' ) );
?>

以上例程的输出类似于：

bool(false)
bool(true)
int(5)
bool(true)
bool(false)
bool(false)
bool(false)


This method checks whether a key is part of the hash

  • ? QuickHashStringIntHash::delete
  • QuickHashStringIntHash::get ?
  • PHP Manual
  • QuickHashStringIntHash
  • This method checks whether a key is part of the hash

QuickHashStringIntHash::exists

(No version information available, might only be in Git)

QuickHashStringIntHash::exists — This method checks whether a key is part of the hash

说明

public QuickHashStringIntHash::exists ( string $key ) : bool

This method checks whether an entry with the provided key exists in the hash.

参数

key

The key of the entry to check for whether it exists in the hash.

返回值

Returns true when the entry was found, or false when the entry is not found.


This method retrieves a value from the hash by its key

  • ? QuickHashStringIntHash::exists
  • QuickHashStringIntHash::getSize ?
  • PHP Manual
  • QuickHashStringIntHash
  • This method retrieves a value from the hash by its key

QuickHashStringIntHash::get

(No version information available, might only be in Git)

QuickHashStringIntHash::get — This method retrieves a value from the hash by its key

说明

public QuickHashStringIntHash::get ( string $key ) : mixed

This method retrieves a value from the hash by its key.

参数

key

The key of the entry to add.

返回值

The value if the key exists, or null if the key wasn't part of the hash.

范例

Example #1 QuickHashStringIntHash::get() example

<?php
$hash = new QuickHashStringIntHash( 8 );
var_dump( $hash->get( "one" ) );

var_dump( $hash->add( "two", 2 ) );
var_dump( $hash->get( "two" ) );
?>

以上例程的输出类似于：

bool(false)
bool(true)
int(2)


Returns the number of elements in the hash

  • ? QuickHashStringIntHash::get
  • QuickHashStringIntHash::loadFromFile ?
  • PHP Manual
  • QuickHashStringIntHash
  • Returns the number of elements in the hash

QuickHashStringIntHash::getSize

(No version information available, might only be in Git)

QuickHashStringIntHash::getSize — Returns the number of elements in the hash

说明

public QuickHashStringIntHash::getSize ( ) : int

Returns the number of elements in the hash.

参数

key

The key of the entry to add.

返回值

The number of elements in the hash.

范例

Example #1 QuickHashStringIntHash::getSize() example

<?php
$hash = new QuickHashStringIntHash( 8 );
var_dump( $hash->add( "two", 2 ) );
var_dump( $hash->add( "three", 5 ) );
var_dump( $hash->getSize() );
?>

以上例程的输出类似于：

bool(true)
bool(true)
int(2)


This factory method creates a hash from a file

  • ? QuickHashStringIntHash::getSize
  • QuickHashStringIntHash::loadFromString ?
  • PHP Manual
  • QuickHashStringIntHash
  • This factory method creates a hash from a file

QuickHashStringIntHash::loadFromFile

(No version information available, might only be in Git)

QuickHashStringIntHash::loadFromFile — This factory method creates a hash from a file

说明

public static QuickHashStringIntHash::loadFromFile ( string $filename , int $size = 0 , int $options = 0 ) : QuickHashStringIntHash

This factory method creates a new hash from a definition file on disk. The file format consists of a signature 'QH\0x21\0', the number of elements as a 32 bit signed integer in system Endianness, an unsigned 32 bit integer containing the number of element data to follow in characters. This element data contains all the strings. The follows another signed 32 bit integer containing the number of bucket lists. After the header and the strings, the elements follow. They are ordered by bucket list so that the keys don't have to be hashed in order to restore the hash. For each bucket list, the following information is stored (all as 32 bit integers): the bucket list index, the number of elements in that list, and then in pairs of two unsigned 32 bit integers the elements, where the first one is the index into the string list containing the keys, and the second one the value. An example could be:

Example #1 QuickHash StringIntHash file format

00000000  51 48 21 00 02 00 00 00  09 00 00 00 40 00 00 00  |QH!.........@...|
00000010  4f 4e 45 00 4e 49 4e 45  00 07 00 00 00 01 00 00  |ONE.NINE........|
00000020  00 00 00 00 00 01 00 00  00 2f 00 00 00 01 00 00  |........./......|
00000030  00 04 00 00 00 03 00 00  00                       |.........|
00000039

Example #2 QuickHash IntHash file format

header signature ('QH'; key type: 2; value type: 1; filler: \0x00)
00000000  51 48 21 00

number of elements:
00000004  02 00 00 00

length of string values (9 characters):
00000008  09 00 00 00

number of hash bucket lists (this is configured for hashes as argument to the
constructor normally, 64 in this case):
0000000C  40 00 00 00

string values:
00000010  4f 4e 45 00 4e 49 4e 45  00

bucket lists:
  bucket list 1 (with key 7, and 1 element):
    header:
    07 00 00 00 01 00 00 00
    elements (key index: 0 ('ONE'), value = 0):
    00 00 00 00 01 00 00 00
  bucket list 2 (with key 0x2f, and 1 element):
    header:
    2f 00 00 00 01 00 00 00
    elements (key index: 4 ('NINE'), value = 3):
    04 00 00 00 03 00 00 00

参数

filename

The filename of the file to read the hash from.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is read from the file format (unlike the QuickHashIntHash and QuickHashIntStringHash classes, where it is automatically calculated from the number of entries in the hash.)

返回值

Returns a new QuickHashStringIntHash.

范例

Example #3 QuickHashStringIntHash::loadFromFile() example

<?php
$file = dirname( __FILE__ ) . "/simple.hash.string";
$hash = QuickHashStringIntHash::loadFromFile(
    $file,
    QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    $i = 48712 + $key * 1631;
    $k = base_convert( $i, 10, 36 );
    echo $k, ' => ', $hash->get( $k ), "\n";
}
?>

以上例程的输出类似于：

11l4 => 48712
12uf => 50343
143q => 51974
15d1 => 53605
16mc => 55236
17vn => 56867
194y => 58498
1ae9 => 60129
1bnk => 61760
1cwv => 63391
1e66 => 65022
1ffh => 66653
1gos => 68284
1hy3 => 69915
1j7e => 71546
1kgp => 73177


This factory method creates a hash from a string

  • ? QuickHashStringIntHash::loadFromFile
  • QuickHashStringIntHash::saveToFile ?
  • PHP Manual
  • QuickHashStringIntHash
  • This factory method creates a hash from a string

QuickHashStringIntHash::loadFromString

(No version information available, might only be in Git)

QuickHashStringIntHash::loadFromString — This factory method creates a hash from a string

说明

public static QuickHashStringIntHash::loadFromString ( string $contents , int $size = 0 , int $options = 0 ) : QuickHashStringIntHash

This factory method creates a new hash from a definition in a string. The format is the same as the one used in "loadFromFile".

参数

contents

The string containing a serialized format of the hash.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

返回值

Returns a new QuickHashStringIntHash.

范例

Example #1 QuickHashStringIntHash::loadFromString() example

<?php
$contents = file_get_contents( dirname( __FILE__ ) . "/simple.hash.string" );
$hash = QuickHashStringIntHash::loadFromString(
    $contents,
    QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    $i = 48712 + $key * 1631;
    $k = base_convert( $i, 10, 36 );
    echo $k, ' => ', $hash->get( $k ), "\n";
}
?>

以上例程的输出类似于：

11l4 => 48712
12uf => 50343
143q => 51974
15d1 => 53605
16mc => 55236
17vn => 56867
194y => 58498
1ae9 => 60129
1bnk => 61760
1cwv => 63391
1e66 => 65022
1ffh => 66653
1gos => 68284
1hy3 => 69915
1j7e => 71546
1kgp => 73177


This method stores an in-memory hash to disk

  • ? QuickHashStringIntHash::loadFromString
  • QuickHashStringIntHash::saveToString ?
  • PHP Manual
  • QuickHashStringIntHash
  • This method stores an in-memory hash to disk

QuickHashStringIntHash::saveToFile

(No version information available, might only be in Git)

QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk

说明

public QuickHashStringIntHash::saveToFile ( string $filename ) : void

This method stores an existing hash to a file on disk, in the same format that loadFromFile() can read.

参数

filename

The filename of the file to store the hash in.

返回值

没有返回值。

范例

Example #1 QuickHashStringIntHash::saveToFile() example

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->add( "fourty three", 42 ) );
var_dump( $hash->add( "fifty two", 52 ) );

$hash->saveToFile( '/tmp/test.hash.string' );
?>


This method returns a serialized version of the hash

  • ? QuickHashStringIntHash::saveToFile
  • QuickHashStringIntHash::set ?
  • PHP Manual
  • QuickHashStringIntHash
  • This method returns a serialized version of the hash

QuickHashStringIntHash::saveToString

(No version information available, might only be in Git)

QuickHashStringIntHash::saveToString — This method returns a serialized version of the hash

说明

public QuickHashStringIntHash::saveToString ( ) : string

This method returns a serialized version of the hash in the same format that loadFromString() can read.

返回值

This method returns a serialized format of an existing hash, in the same format that loadFromString() can read.

范例

Example #1 QuickHashStringIntHash::saveToString() example

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->add( "fourty three", 42 ) );
var_dump( $hash->add( "fifty two", 52 ) );

var_dump( $hash->saveToString() );
?>


This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

  • ? QuickHashStringIntHash::saveToString
  • QuickHashStringIntHash::update ?
  • PHP Manual
  • QuickHashStringIntHash
  • This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

QuickHashStringIntHash::set

(No version information available, might only be in Git)

QuickHashStringIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

说明

public QuickHashStringIntHash::set ( string $key , int $value ) : int

This method tries to update an entry with a new value. In case the entry did not yet exist, it will instead add a new entry. It returns whether the entry was added or update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashStringIntHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

参数

key

The key of the entry to add or update.

value

The value of the entry to add. If a non-string is passed, it will be converted to a string automatically if possible.

返回值

2 if the entry was found and updated, 1 if the entry was newly added or 0 if there was an error.

范例

Example #1 QuickHashStringIntHash::set() example

<?php
$hash = new QuickHashStringIntHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );
var_dump( $hash->set( "fourty six thousand six hundred ninety two", 16091 ) );
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );

echo "Set->Update\n";
var_dump( $hash->set( "fourty six thousand six hundred ninety two", 29906 ) );
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );
?>

以上例程的输出类似于：

Set->Add
bool(false)
int(2)
int(16091)
Set->Update
int(1)
int(29906)


This method updates an entry in the hash with a new value

  • ? QuickHashStringIntHash::set
  • QuickHashIntStringHash ?
  • PHP Manual
  • QuickHashStringIntHash
  • This method updates an entry in the hash with a new value

QuickHashStringIntHash::update

(No version information available, might only be in Git)

QuickHashStringIntHash::update — This method updates an entry in the hash with a new value

说明

public QuickHashStringIntHash::update ( string $key , int $value ) : bool

This method updates an entry with a new value, and returns whether the entry was update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashStringIntHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

参数

key

The key of the entry to add.

value

The new value for the entry. If a non-string is passed, it will be converted to a string automatically if possible.

返回值

true when the entry was found and updated, and false if the entry was not part of the hash already.

范例

Example #1 QuickHashStringIntHash::update() example

<?php
$hash = new QuickHashStringIntHash( 1024 );

$hash->add( 'six', 314159265 );
$hash->add( "a lot", 314159265 );

echo $hash->get( 'six' ), "\n";
echo $hash->get( 'a lot' ), "\n";

var_dump( $hash->update( 'a lot', 314159266 ) );
var_dump( $hash->update( "a lot plus one", 314159999 ) );

echo $hash->get( 'six' ), "\n";
echo $hash->get( 'a lot' ), "\n";
?>

以上例程的输出类似于：

314159265
314159265
bool(true)
bool(false)
314159265
314159266


The QuickHashIntStringHash class

(PECL quickhash >= Unknown)

简介

This class wraps around a hash containing integer numbers, where the values are strings. Hashes are also available as implementation of the ArrayAccess interface.

Hashes can also be iterated over with foreach as the Iterator interface is implemented as well. The order of which elements are returned in is not guaranteed.

类摘要

QuickHashIntStringHash {
/* Constants */
const int CHECK_FOR_DUPES = 1 ;
const int DO_NOT_USE_ZEND_ALLOC = 2 ;
const int HASHER_NO_HASH = 256 ;
const int HASHER_JENKINS1 = 512 ;
const int HASHER_JENKINS2 = 1024 ;
/* Methods */
public add ( int $key , string $value ) : bool
public __construct ( int $size , int $options = 0 )
public delete ( int $key ) : bool
public exists ( int $key ) : bool
public get ( int $key ) : mixed
public getSize ( ) : int
public static loadFromFile ( string $filename , int $size = 0 , int $options = 0 ) : QuickHashIntStringHash
public static loadFromString ( string $contents , int $size = 0 , int $options = 0 ) : QuickHashIntStringHash
public saveToFile ( string $filename ) : void
public saveToString ( ) : string
public set ( int $key , string $value ) : int
public update ( int $key , string $value ) : bool
}

预定义常量

QuickHashIntStringHash::CHECK_FOR_DUPES

If enabled, adding duplicate elements to a set (through either add() or loadFromFile()) will result in those elements to be dropped from the set. This will take up extra time, so only used when it is required.

QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

QuickHashIntStringHash::HASHER_NO_HASH

Selects to not use a hashing function, but merely use a modulo to find the bucket list index. This is not faster than normal hashing, and gives more collisions.

QuickHashIntStringHash::HASHER_JENKINS1

This is the default hashing function to turn the integer hashes into bucket list indexes.

QuickHashIntStringHash::HASHER_JENKINS2

Selects a variant hashing algorithm.

Table of Contents

  • QuickHashIntStringHash::add — This method adds a new entry to the hash
  • QuickHashIntStringHash::__construct — Creates a new QuickHashIntStringHash object
  • QuickHashIntStringHash::delete — This method deletes am entry from the hash
  • QuickHashIntStringHash::exists — This method checks whether a key is part of the hash
  • QuickHashIntStringHash::get — This method retrieves a value from the hash by its key
  • QuickHashIntStringHash::getSize — Returns the number of elements in the hash
  • QuickHashIntStringHash::loadFromFile — This factory method creates a hash from a file
  • QuickHashIntStringHash::loadFromString — This factory method creates a hash from a string
  • QuickHashIntStringHash::saveToFile — This method stores an in-memory hash to disk
  • QuickHashIntStringHash::saveToString — This method returns a serialized version of the hash
  • QuickHashIntStringHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
  • QuickHashIntStringHash::update — This method updates an entry in the hash with a new value


This method adds a new entry to the hash

  • ? QuickHashIntStringHash
  • QuickHashIntStringHash::__construct ?
  • PHP Manual
  • QuickHashIntStringHash
  • This method adds a new entry to the hash

QuickHashIntStringHash::add

(PECL quickhash >= Unknown)

QuickHashIntStringHash::add — This method adds a new entry to the hash

说明

public QuickHashIntStringHash::add ( int $key , string $value ) : bool

This method adds a new entry to the hash, and returns whether the entry was added. Entries are by default always added unless QuickHashIntStringHash::CHECK_FOR_DUPES has been passed when the hash was created.

参数

key

The key of the entry to add.

value

The value of the entry to add. If a non-string is passed, it will be converted to a string automatically if possible.

返回值

true when the entry was added, and false if the entry was not added.

范例

Example #1 QuickHashIntStringHash::add() example

<?php
echo "without dupe checking\n";
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "twenty two" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "twelve" ) );

echo "\nwith dupe checking\n";
$hash = new QuickHashIntStringHash( 1024, QuickHashIntStringHash::CHECK_FOR_DUPES );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "seventy eight" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "nine" ) );
?>

以上例程的输出类似于：

without dupe checking
bool(false)
bool(false)
bool(true)
bool(true)
string(10) "twenty two"
bool(true)

with dupe checking
bool(false)
bool(false)
bool(true)
bool(true)
string(13) "seventy eight"
bool(false)


Creates a new QuickHashIntStringHash object

  • ? QuickHashIntStringHash::add
  • QuickHashIntStringHash::delete ?
  • PHP Manual
  • QuickHashIntStringHash
  • Creates a new QuickHashIntStringHash object

QuickHashIntStringHash::__construct

(PECL quickhash >= Unknown)

QuickHashIntStringHash::__construct — Creates a new QuickHashIntStringHash object

说明

public QuickHashIntStringHash::__construct ( int $size , int $options = 0 )

This constructor creates a new QuickHashIntStringHash. The size is the amount of bucket lists to create. The more lists there are, the less collisions you will have. Options are also supported.

参数

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 64 to 4194304.

options

The options that you can pass in are: QuickHashIntStringHash::CHECK_FOR_DUPES, which makes sure no duplicate entries are added to the hash; QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC to not use PHP's internal memory manager as well as one of QuickHashIntStringHash::HASHER_NO_HASH, QuickHashIntStringHash::HASHER_JENKINS1 or QuickHashIntStringHash::HASHER_JENKINS2. These last three configure which hashing algorithm to use. All options can be combined using bitmasks.

返回值

Returns a new QuickHashIntStringHash object.

范例

Example #1 QuickHashIntStringHash::__construct() example

<?php
var_dump( new QuickHashIntStringHash( 1024 ) );
var_dump( new QuickHashIntStringHash( 1024, QuickHashIntStringHash::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntStringHash(
        1024,
        QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC | QuickHashIntStringHash::HASHER_JENKINS2
    )
);
?>


This method deletes am entry from the hash

  • ? QuickHashIntStringHash::__construct
  • QuickHashIntStringHash::exists ?
  • PHP Manual
  • QuickHashIntStringHash
  • This method deletes am entry from the hash

QuickHashIntStringHash::delete

(PECL quickhash >= Unknown)

QuickHashIntStringHash::delete — This method deletes am entry from the hash

说明

public QuickHashIntStringHash::delete ( int $key ) : bool

This method deletes an entry from the hash, and returns whether the entry was deleted or not. Associated memory structures will not be freed immediately, but rather when the hash itself is freed.

Elements can not be deleted when the hash is used in an iterator. The method will not throw an exception, but simply return false like would happen with any other deletion failure.

参数

key

The key of the entry to delete.

返回值

true when the entry was deleted, and false if the entry was not deleted.

范例

Example #1 QuickHashIntStringHash::delete() example

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "five" ) );
var_dump( $hash->delete( 4 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->delete( 4 ) );
?>

以上例程的输出类似于：

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)


This method checks whether a key is part of the hash

  • ? QuickHashIntStringHash::delete
  • QuickHashIntStringHash::get ?
  • PHP Manual
  • QuickHashIntStringHash
  • This method checks whether a key is part of the hash

QuickHashIntStringHash::exists

(PECL quickhash >= Unknown)

QuickHashIntStringHash::exists — This method checks whether a key is part of the hash

说明

public QuickHashIntStringHash::exists ( int $key ) : bool

This method checks whether an entry with the provided key exists in the hash.

参数

key

The key of the entry to check for whether it exists in the hash.

返回值

Returns true when the entry was found, or false when the entry is not found.


This method retrieves a value from the hash by its key

  • ? QuickHashIntStringHash::exists
  • QuickHashIntStringHash::getSize ?
  • PHP Manual
  • QuickHashIntStringHash
  • This method retrieves a value from the hash by its key

QuickHashIntStringHash::get

(PECL quickhash >= Unknown)

QuickHashIntStringHash::get — This method retrieves a value from the hash by its key

说明

public QuickHashIntStringHash::get ( int $key ) : mixed

This method retrieves a value from the hash by its key.

参数

key

The key of the entry to add.

返回值

The value if the key exists, or null if the key wasn't part of the hash.

范例

Example #1 QuickHashIntStringHash::get() example

<?php
$hash = new QuickHashIntStringHash( 8 );
var_dump( $hash->get( 1 ) );

var_dump( $hash->add( 2, "two" ) );
var_dump( $hash->get( 2 ) );

var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->get( 3 ) );
?>

以上例程的输出类似于：

bool(false)
bool(true)
string(3) "two"
bool(true)
string(1) "5"


Returns the number of elements in the hash

  • ? QuickHashIntStringHash::get
  • QuickHashIntStringHash::loadFromFile ?
  • PHP Manual
  • QuickHashIntStringHash
  • Returns the number of elements in the hash

QuickHashIntStringHash::getSize

(PECL quickhash >= Unknown)

QuickHashIntStringHash::getSize — Returns the number of elements in the hash

说明

public QuickHashIntStringHash::getSize ( ) : int

Returns the number of elements in the hash.

返回值

The number of elements in the hash.

范例

Example #1 QuickHashIntStringHash::getSize() example

<?php
$hash = new QuickHashIntStringHash( 8 );
var_dump( $hash->add( 2, "two" ) );
var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->getSize() );
?>

以上例程的输出类似于：

bool(true)
bool(true)
int(2)


This factory method creates a hash from a file

  • ? QuickHashIntStringHash::getSize
  • QuickHashIntStringHash::loadFromString ?
  • PHP Manual
  • QuickHashIntStringHash
  • This factory method creates a hash from a file

QuickHashIntStringHash::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntStringHash::loadFromFile — This factory method creates a hash from a file

说明

public static QuickHashIntStringHash::loadFromFile ( string $filename , int $size = 0 , int $options = 0 ) : QuickHashIntStringHash

This factory method creates a new hash from a definition file on disk. The file format consists of a signature 'QH\0x12\0', the number of elements as a 32 bit signed integer in system Endianness, an unsigned 32 bit integer containing the number of element data to follow in characters. This element data contains all the strings. After the header and the strings, the elements follow in pairs of two unsigned 32 bit integers where the first one is the key, and the second one the index in the element data string. An example could be:

Example #1 QuickHash IntString file format

00000000  51 48 12 00 02 00 00 00  09 00 00 00 4f 4e 45 00  |QH..........ONE.|
00000010  4e 49 4e 45 00 01 00 00  00 00 00 00 00 03 00 00  |NINE............|
00000020  00 04 00 00 00                                    |.....|
00000025

Example #2 QuickHash IntString file format

header signature ('QH'; key type: 1; value type: 2; filler: \0x00)
00000000  51 48 12 00

number of elements:
00000004  02 00 00 00

length of string values (9 characters):
00000008  09 00 00 00

string values:
0000000C  4f 4e 45 00 4e 49 4e 45  00

data string:
00000015  01 00 00 00 00 00 00 00  03 00 00 00 04 00 00 00

key/value 1 (key = 1, string index = 0 ("ONE")):
01 00 00 00  00 00 00 00

key/value 2 (key = 3, string index = 4 ("NINE")):
03 00 00 00  04 00 00 00

参数

filename

The filename of the file to read the hash from.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

返回值

Returns a new QuickHashIntStringHash.

范例

Example #3 QuickHashIntStringHash::loadFromFile() example

<?php
$file = dirname( __FILE__ ) . "/simple.string.hash";
$hash = QuickHashIntStringHash::loadFromFile(
    $file,
    QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $hash->exists( $key ) ? 'set' : 'unset'
    );
}
?>

以上例程的输出类似于：

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset


This factory method creates a hash from a string

  • ? QuickHashIntStringHash::loadFromFile
  • QuickHashIntStringHash::saveToFile ?
  • PHP Manual
  • QuickHashIntStringHash
  • This factory method creates a hash from a string

QuickHashIntStringHash::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntStringHash::loadFromString — This factory method creates a hash from a string

说明

public static QuickHashIntStringHash::loadFromString ( string $contents , int $size = 0 , int $options = 0 ) : QuickHashIntStringHash

This factory method creates a new hash from a definition in a string. The format is the same as the one used in "loadFromFile".

参数

contents

The string containing a serialized format of the hash.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

返回值

Returns a new QuickHashIntStringHash.

范例

Example #1 QuickHashIntStringHash::loadFromString() example

<?php
$contents = file_get_contents( dirname( __FILE__ ) . "/simple.hash" );
$hash = QuickHashIntStringHash::loadFromString(
    $contents,
    QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $hash->exists( $key ) ? 'set' : 'unset'
    );
}
?>

以上例程的输出类似于：

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset


This method stores an in-memory hash to disk

  • ? QuickHashIntStringHash::loadFromString
  • QuickHashIntStringHash::saveToString ?
  • PHP Manual
  • QuickHashIntStringHash
  • This method stores an in-memory hash to disk

QuickHashIntStringHash::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntStringHash::saveToFile — This method stores an in-memory hash to disk

说明

public QuickHashIntStringHash::saveToFile ( string $filename ) : void

This method stores an existing hash to a file on disk, in the same format that loadFromFile() can read.

参数

filename

The filename of the file to store the hash in.

返回值

没有返回值。

范例

Example #1 QuickHashIntStringHash::saveToFile() example

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "fourty three" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "fifty two" ) );

$hash->saveToFile( '/tmp/test.string.hash' );
?>


This method returns a serialized version of the hash

  • ? QuickHashIntStringHash::saveToFile
  • QuickHashIntStringHash::set ?
  • PHP Manual
  • QuickHashIntStringHash
  • This method returns a serialized version of the hash

QuickHashIntStringHash::saveToString

(PECL quickhash >= Unknown)

QuickHashIntStringHash::saveToString — This method returns a serialized version of the hash

说明

public QuickHashIntStringHash::saveToString ( ) : string

This method returns a serialized version of the hash in the same format that loadFromString() can read.

返回值

This method returns a string containing a serialized format of the hash. Each element is stored as a four byte value in the Endianness that the current system uses.

范例

Example #1 QuickHashIntStringHash::saveToString() example

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "thirty four" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 5, "fifty five" ) );

var_dump( $hash->saveToString() );
?>


This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

  • ? QuickHashIntStringHash::saveToString
  • QuickHashIntStringHash::update ?
  • PHP Manual
  • QuickHashIntStringHash
  • This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

QuickHashIntStringHash::set

(PECL quickhash >= Unknown)

QuickHashIntStringHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

说明

public QuickHashIntStringHash::set ( int $key , string $value ) : int

This method tries to update an entry with a new value. In case the entry did not yet exist, it will instead add a new entry. It returns whether the entry was added or update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashIntStringHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

参数

key

The key of the entry to add or update.

value

The value of the entry to add. If a non-string is passed, it will be converted to a string automatically if possible.

返回值

2 if the entry was found and updated, 1 if the entry was newly added or 0 if there was an error.

范例

Example #1 QuickHashIntStringHash::set() example

<?php
$hash = new QuickHashIntStringHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( 46692 ) );
var_dump( $hash->set( 46692, "sixteen thousand ninety one" ) );
var_dump( $hash->get( 46692 ) );

echo "Set->Update\n";
var_dump( $hash->set( 46692, "twenty nine thousand nine hundred six" ) );
var_dump( $hash->get( 46692 ) );
?>

以上例程的输出类似于：

Set->Add
bool(false)
int(2)
string(27) "sixteen thousand ninety one"
Set->Update
int(1)
string(37) "twenty nine thousand nine hundred six"


This method updates an entry in the hash with a new value

  • ? QuickHashIntStringHash::set
  • 反射 ?
  • PHP Manual
  • QuickHashIntStringHash
  • This method updates an entry in the hash with a new value

QuickHashIntStringHash::update

(PECL quickhash >= Unknown)

QuickHashIntStringHash::update — This method updates an entry in the hash with a new value

说明

public QuickHashIntStringHash::update ( int $key , string $value ) : bool

This method updates an entry with a new value, and returns whether the entry was update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashIntStringHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

参数

key

The key of the entry to add.

value

The new value for the entry. If a non-string is passed, it will be converted to a string automatically if possible.

返回值

true when the entry was found and updated, and false if the entry was not part of the hash already.

范例

Example #1 QuickHashIntStringHash::update() example

<?php
$hash->add( 161803398, "--" );
$hash->add( 314159265, "a lot" );

echo $hash->get( 161803398 ), "\n";
echo $hash->get( 314159265 ), "\n";

var_dump( $hash->update( 314159265, "a lot plus one" ) );
var_dump( $hash->update( 314159999, "a lot plus one" ) );

echo $hash->get( 161803398 ), "\n";
echo $hash->get( 314159265 ), "\n";
?>

以上例程的输出类似于：

--
a lot
bool(true)
bool(false)
--
a lot plus one


反射

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • 扩展
  • Reflection — Reflection 类
    • Reflection::export — Exports
    • Reflection::getModifierNames — 获取修饰符的名称
  • ReflectionClass — ReflectionClass 类
    • ReflectionClass::__construct — 初始化 ReflectionClass 类
    • ReflectionClass::export — 导出一个类
    • ReflectionClass::getConstant — 获取定义过的一个常量
    • ReflectionClass::getConstants — 获取一组常量
    • ReflectionClass::getConstructor — 获取类的构造函数
    • ReflectionClass::getDefaultProperties — 获取默认属性
    • ReflectionClass::getDocComment — 获取文档注释
    • ReflectionClass::getEndLine — 获取最后一行的行数
    • ReflectionClass::getExtension — 根据已定义的类获取所在扩展的 ReflectionExtension 对象
    • ReflectionClass::getExtensionName — 获取定义的类所在的扩展的名称
    • ReflectionClass::getFileName — 获取定义类的文件名
    • ReflectionClass::getInterfaceNames — 获取接口（interface）名称
    • ReflectionClass::getInterfaces — 获取接口
    • ReflectionClass::getMethod — 获取一个类方法的 ReflectionMethod。
    • ReflectionClass::getMethods — 获取方法的数组
    • ReflectionClass::getModifiers — 获取类的修饰符
    • ReflectionClass::getName — 获取类名
    • ReflectionClass::getNamespaceName — 获取命名空间的名称
    • ReflectionClass::getParentClass — 获取父类
    • ReflectionClass::getProperties — 获取一组属性
    • ReflectionClass::getProperty — 获取类的一个属性的 ReflectionProperty
    • ReflectionClass::getReflectionConstant — Gets a ReflectionClassConstant for a class's constant
    • ReflectionClass::getReflectionConstants — Gets class constants
    • ReflectionClass::getShortName — 获取短名
    • ReflectionClass::getStartLine — 获取起始行号
    • ReflectionClass::getStaticProperties — 获取静态（static）属性
    • ReflectionClass::getStaticPropertyValue — 获取静态（static）属性的值
    • ReflectionClass::getTraitAliases — 返回 trait 别名的一个数组
    • ReflectionClass::getTraitNames — 返回这个类所使用 traits 的名称的数组
    • ReflectionClass::getTraits — 返回这个类所使用的 traits 数组
    • ReflectionClass::hasConstant — 检查常量是否已经定义
    • ReflectionClass::hasMethod — 检查方法是否已定义
    • ReflectionClass::hasProperty — 检查属性是否已定义
    • ReflectionClass::implementsInterface — 接口的实现
    • ReflectionClass::inNamespace — 检查是否位于命名空间中
    • ReflectionClass::isAbstract — 检查类是否是抽象类（abstract）
    • ReflectionClass::isAnonymous — 检查类是否是匿名类
    • ReflectionClass::isCloneable — 返回了一个类是否可复制
    • ReflectionClass::isFinal — 检查类是否声明为 final
    • ReflectionClass::isInstance — 检查类的实例
    • ReflectionClass::isInstantiable — 检查类是否可实例化
    • ReflectionClass::isInterface — 检查类是否是一个接口（interface）
    • ReflectionClass::isInternal — 检查类是否由扩展或核心在内部定义
    • ReflectionClass::isIterable — Check whether this class is iterable
    • ReflectionClass::isIterateable — 检查是否可迭代（iterateable）
    • ReflectionClass::isSubclassOf — 检查是否为一个子类
    • ReflectionClass::isTrait — 返回了是否为一个 trait
    • ReflectionClass::isUserDefined — 检查是否由用户定义的
    • ReflectionClass::newInstance — 从指定的参数创建一个新的类实例
    • ReflectionClass::newInstanceArgs — 从给出的参数创建一个新的类实例。
    • ReflectionClass::newInstanceWithoutConstructor — 创建一个新的类实例而不调用它的构造函数
    • ReflectionClass::setStaticPropertyValue — 设置静态属性的值
    • ReflectionClass::__toString — 返回 ReflectionClass 对象字符串的表示形式。
  • ReflectionClassConstant — The ReflectionClassConstant class
    • ReflectionClassConstant::__construct — Constructs a ReflectionClassConstant
    • ReflectionClassConstant::export — Export
    • ReflectionClassConstant::getDeclaringClass — Gets declaring class
    • ReflectionClassConstant::getDocComment — Gets doc comments
    • ReflectionClassConstant::getModifiers — Gets the class constant modifiers
    • ReflectionClassConstant::getName — Get name of the constant
    • ReflectionClassConstant::getValue — Gets value
    • ReflectionClassConstant::isPrivate — Checks if class constant is private
    • ReflectionClassConstant::isProtected — Checks if class constant is protected
    • ReflectionClassConstant::isPublic — Checks if class constant is public
    • ReflectionClassConstant::__toString — Returns the string representation of the ReflectionClassConstant object
  • ReflectionZendExtension — ReflectionZendExtension 类
    • ReflectionZendExtension::__clone — Clone handler
    • ReflectionZendExtension::__construct — Constructor
    • ReflectionZendExtension::export — Export
    • ReflectionZendExtension::getAuthor — Gets author
    • ReflectionZendExtension::getCopyright — Gets copyright
    • ReflectionZendExtension::getName — Gets name
    • ReflectionZendExtension::getURL — Gets URL
    • ReflectionZendExtension::getVersion — Gets version
    • ReflectionZendExtension::__toString — To string handler
  • ReflectionExtension — ReflectionExtension 类
    • ReflectionExtension::__clone — Clones
    • ReflectionExtension::__construct — Constructs a ReflectionExtension
    • ReflectionExtension::export — Export
    • ReflectionExtension::getClasses — Gets classes
    • ReflectionExtension::getClassNames — 获取类名称
    • ReflectionExtension::getConstants — 获取常量
    • ReflectionExtension::getDependencies — 获取依赖
    • ReflectionExtension::getFunctions — 获取扩展中的函数
    • ReflectionExtension::getINIEntries — 获取ini配置
    • ReflectionExtension::getName — 获取扩展名称
    • ReflectionExtension::getVersion — 获取扩展版本号
    • ReflectionExtension::info — 输出扩展信息
    • ReflectionExtension::isPersistent — 返回扩展是否持久化载入
    • ReflectionExtension::isTemporary — 返回扩展是否是临时载入
    • ReflectionExtension::__toString — To string
  • ReflectionFunction — ReflectionFunction 类
    • ReflectionFunction::__construct — Constructs a ReflectionFunction object
    • ReflectionFunction::export — Exports function
    • ReflectionFunction::getClosure — Returns a dynamically created closure for the function
    • ReflectionFunction::invoke — Invokes function
    • ReflectionFunction::invokeArgs — Invokes function args
    • ReflectionFunction::isDisabled — Checks if function is disabled
    • ReflectionFunction::__toString — To string
  • ReflectionFunctionAbstract — ReflectionFunctionAbstract 类
    • ReflectionFunctionAbstract::__clone — 复制函数
    • ReflectionFunctionAbstract::getClosureScopeClass — Returns the scope associated to the closure
    • ReflectionFunctionAbstract::getClosureThis — 返回本身的匿名函数
    • ReflectionFunctionAbstract::getDocComment — 获取注释内容
    • ReflectionFunctionAbstract::getEndLine — 获取结束行号
    • ReflectionFunctionAbstract::getExtension — 获取扩展信息
    • ReflectionFunctionAbstract::getExtensionName — 获取扩展名称
    • ReflectionFunctionAbstract::getFileName — 获取文件名称
    • ReflectionFunctionAbstract::getName — 获取函数名称
    • ReflectionFunctionAbstract::getNamespaceName — 获取命名空间
    • ReflectionFunctionAbstract::getNumberOfParameters — 获取参数数目
    • ReflectionFunctionAbstract::getNumberOfRequiredParameters — 获取必须输入参数个数
    • ReflectionFunctionAbstract::getParameters — 获取参数
    • ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function
    • ReflectionFunctionAbstract::getShortName — 获取函数短名称
    • ReflectionFunctionAbstract::getStartLine — 获取开始行号
    • ReflectionFunctionAbstract::getStaticVariables — 获取静态变量
    • ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type
    • ReflectionFunctionAbstract::inNamespace — 检查是否处于命名空间
    • ReflectionFunctionAbstract::isClosure — 检查是否是匿名函数
    • ReflectionFunctionAbstract::isDeprecated — 检查是否已经弃用
    • ReflectionFunctionAbstract::isGenerator — 判断函数是否是一个生成器函数
    • ReflectionFunctionAbstract::isInternal — 判断函数是否是内置函数
    • ReflectionFunctionAbstract::isUserDefined — 检查是否是用户定义
    • ReflectionFunctionAbstract::isVariadic — Checks if the function is variadic
    • ReflectionFunctionAbstract::returnsReference — 检查是否返回参考信息
    • ReflectionFunctionAbstract::__toString — 字符串化
  • ReflectionMethod — ReflectionMethod 类
    • ReflectionMethod::__construct — ReflectionMethod 的构造函数
    • ReflectionMethod::export — 输出一个回调方法
    • ReflectionMethod::getClosure — 返回一个动态建立的方法调用接口，译者注：可以使用这个返回值直接调用非公开方法。
    • ReflectionMethod::getDeclaringClass — 获取被反射的方法所在类的反射实例
    • ReflectionMethod::getModifiers — 获取方法的修饰符
    • ReflectionMethod::getPrototype — 返回方法原型 (如果存在)
    • ReflectionMethod::invoke — Invoke
    • ReflectionMethod::invokeArgs — 带参数执行
    • ReflectionMethod::isAbstract — 判断方法是否是抽象方法
    • ReflectionMethod::isConstructor — 判断方法是否是构造方法
    • ReflectionMethod::isDestructor — 判断方法是否是析构方法
    • ReflectionMethod::isFinal — 判断方法是否定义 final
    • ReflectionMethod::isPrivate — 判断方法是否是私有方法
    • ReflectionMethod::isProtected — 判断方法是否是保护方法 (protected)
    • ReflectionMethod::isPublic — 判断方法是否是公开方法
    • ReflectionMethod::isStatic — 判断方法是否是静态方法
    • ReflectionMethod::setAccessible — 设置方法是否访问
    • ReflectionMethod::__toString — 返回反射方法对象的字符串表达
  • ReflectionObject — ReflectionObject 类
    • ReflectionObject::__construct — Constructs a ReflectionObject
    • ReflectionObject::export — Export
  • ReflectionParameter — ReflectionParameter 类
    • ReflectionParameter::allowsNull — Checks if null is allowed
    • ReflectionParameter::canBePassedByValue — Returns whether this parameter can be passed by value
    • ReflectionParameter::__clone — Clone
    • ReflectionParameter::__construct — Construct
    • ReflectionParameter::export — Exports
    • ReflectionParameter::getClass — 获得类型提示类。
    • ReflectionParameter::getDeclaringClass — Gets declaring class
    • ReflectionParameter::getDeclaringFunction — Gets declaring function
    • ReflectionParameter::getDefaultValue — Gets default parameter value
    • ReflectionParameter::getDefaultValueConstantName — Returns the default value's constant name if default value is constant or null
    • ReflectionParameter::getName — Gets parameter name
    • ReflectionParameter::getPosition — Gets parameter position
    • ReflectionParameter::getType — Gets a parameter's type
    • ReflectionParameter::hasType — Checks if parameter has a type
    • ReflectionParameter::isArray — Checks if parameter expects an array
    • ReflectionParameter::isCallable — Returns whether parameter MUST be callable
    • ReflectionParameter::isDefaultValueAvailable — 检查是否有默认值。
    • ReflectionParameter::isDefaultValueConstant — Returns whether the default value of this parameter is a constant
    • ReflectionParameter::isOptional — Checks if optional
    • ReflectionParameter::isPassedByReference — Checks if passed by reference
    • ReflectionParameter::isVariadic — Checks if the parameter is variadic
    • ReflectionParameter::__toString — To string
  • ReflectionProperty — ReflectionProperty 类
    • ReflectionProperty::__clone — Clone
    • ReflectionProperty::__construct — Construct a ReflectionProperty object
    • ReflectionProperty::export — Export
    • ReflectionProperty::getDeclaringClass — Gets declaring class
    • ReflectionProperty::getDefaultValue — Returns the default value declared for a property
    • ReflectionProperty::getDocComment — Gets the property doc comment
    • ReflectionProperty::getModifiers — Gets the property modifiers
    • ReflectionProperty::getName — Gets property name
    • ReflectionProperty::getType — Gets a property's type
    • ReflectionProperty::getValue — Gets value
    • ReflectionProperty::hasDefaultValue — Checks if property has a default value declared
    • ReflectionProperty::hasType — Checks if property has a type
    • ReflectionProperty::isDefault — Checks if property is a default property
    • ReflectionProperty::isInitialized — Checks whether a property is initialized
    • ReflectionProperty::isPrivate — Checks if property is private
    • ReflectionProperty::isProtected — Checks if property is protected
    • ReflectionProperty::isPublic — Checks if property is public
    • ReflectionProperty::isStatic — Checks if property is static
    • ReflectionProperty::setAccessible — Set property accessibility
    • ReflectionProperty::setValue — Set property value
    • ReflectionProperty::__toString — To string
  • ReflectionType — The ReflectionType class
    • ReflectionType::allowsNull — Checks if null is allowed
    • ReflectionType::__toString — To string
  • ReflectionGenerator — 生成器反射类
    • ReflectionGenerator::__construct — Constructs a ReflectionGenerator object
    • ReflectionGenerator::getExecutingFile — Gets the file name of the currently executing generator
    • ReflectionGenerator::getExecutingGenerator — Gets the executing Generator object
    • ReflectionGenerator::getExecutingLine — Gets the currently executing line of the generator
    • ReflectionGenerator::getFunction — Gets the function name of the generator
    • ReflectionGenerator::getThis — Gets the $this value of the generator
    • ReflectionGenerator::getTrace — Gets the trace of the executing generator
  • Reflector — Reflector 接口
    • Reflector::export — Exports
    • Reflector::__toString — 转化成字符串
  • ReflectionException — ReflectionException 类


简介

PHP 5 具有完整的反射 API，添加了对类、接口、函数、方法和扩展进行反向工程的能力。 此外，反射 API 提供了方法来取出函数、类和方法中的文档注释。

请注意部分内部 API 丢失了反射扩展工作所需的代码。 例如，一个内置的 PHP 类可能丢失了反射属性的数据。这些少数的情况被认为是错误，不过， 正因为如此，它们应该被发现和修复。


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • 反射
  • 预定义常量

预定义常量

每个类描述了它自己的常量。


范例

在反射文档中存在很多例子，通常位于每个类的 __construct 文档中。

Example #1 Shell 里的一个反射例子（一个终端）

$ php --rf strlen
$ php --rc finfo
$ php --re json
$ php --ri dom

以上例程的输出类似于：

Function [ <internal:Core> function strlen ] {

  - Parameters [1] {
    Parameter #0 [ <required> $str ]
  }
}

Class [ <internal:fileinfo> class finfo ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [0] {
  }

  - Methods [4] {
    Method [ <internal:fileinfo, ctor> public method finfo ] {

      - Parameters [2] {
        Parameter #0 [ <optional> $options ]
        Parameter #1 [ <optional> $arg ]
      }
    }

    Method [ <internal:fileinfo> public method set_flags ] {

      - Parameters [1] {
        Parameter #0 [ <required> $options ]
      }
    }

    Method [ <internal:fileinfo> public method file ] {

      - Parameters [3] {
        Parameter #0 [ <required> $filename ]
        Parameter #1 [ <optional> $options ]
        Parameter #2 [ <optional> $context ]
      }
    }

    Method [ <internal:fileinfo> public method buffer ] {

      - Parameters [3] {
        Parameter #0 [ <required> $string ]
        Parameter #1 [ <optional> $options ]
        Parameter #2 [ <optional> $context ]
      }
    }
  }
}

Extension [ <persistent> extension #23 json version 1.2.1 ] {

  - Constants [10] {
    Constant [ integer JSON_HEX_TAG ] { 1 }
    Constant [ integer JSON_HEX_AMP ] { 2 }
    Constant [ integer JSON_HEX_APOS ] { 4 }
    Constant [ integer JSON_HEX_QUOT ] { 8 }
    Constant [ integer JSON_FORCE_OBJECT ] { 16 }
    Constant [ integer JSON_ERROR_NONE ] { 0 }
    Constant [ integer JSON_ERROR_DEPTH ] { 1 }
    Constant [ integer JSON_ERROR_STATE_MISMATCH ] { 2 }
    Constant [ integer JSON_ERROR_CTRL_CHAR ] { 3 }
    Constant [ integer JSON_ERROR_SYNTAX ] { 4 }
  }

  - Functions {
    Function [ <internal:json> function json_encode ] {

      - Parameters [2] {
        Parameter #0 [ <required> $value ]
        Parameter #1 [ <optional> $options ]
      }
    }
    Function [ <internal:json> function json_decode ] {

      - Parameters [3] {
        Parameter #0 [ <required> $json ]
        Parameter #1 [ <optional> $assoc ]
        Parameter #2 [ <optional> $depth ]
      }
    }
    Function [ <internal:json> function json_last_error ] {

      - Parameters [0] {
      }
    }
  }
}

dom

DOM/XML => enabled
DOM/XML API Version => 20031129
libxml Version => 2.7.3
HTML Support => enabled
XPath Support => enabled
XPointer Support => enabled
Schema Support => enabled
RelaxNG Support => enabled


扩展

如果你想创建内建类的专门版本（比如说，在创建并导出高亮 HTML 时，以易于访问的成员变量来取代方法或使用实用的方法）， 你可以继续并扩展它们。

Example #1 扩展内置的类

<?php
/**
 * My Reflection_Method class
 */
class My_Reflection_Method extends ReflectionMethod
{
    public $visibility = array();

    public function __construct($o, $m)
    {
        parent::__construct($o, $m);
        $this->visibility = Reflection::getModifierNames($this->getModifiers());
    }
}

/**
 * Demo class #1
 *
 */
class T {
    protected function x() {}
}

/**
 * Demo class #2
 *
 */
class U extends T {
    function x() {}
}

// 输出信息
var_dump(new My_Reflection_Method('U', 'x'));
?>

以上例程的输出类似于：

object(My_Reflection_Method)#1 (3) {
  ["visibility"]=>
  array(1) {
    [0]=>
    string(6) "public"
  }
  ["name"]=>
  string(1) "x"
  ["class"]=>
  string(1) "U"
}
Caution

如果你重写了构造函数，记住在写任何插入的代码之前要先调用父类的构造函数。 不这么做将会导致以下的结果： Fatal error: Internal error: Failed to retrieve the reflection object


Reflection 类

(PHP 5, PHP 7)

简介

反射（reflection）类。

类摘要

Reflection {
/* 方法 */
public static export ( Reflector $reflector , bool $return = false ) : string
public static getModifierNames ( int $modifiers ) : array
}

Table of Contents

  • Reflection::export — Exports
  • Reflection::getModifierNames — 获取修饰符的名称


Exports

  • ? Reflection
  • Reflection::getModifierNames ?
  • PHP Manual
  • Reflection
  • Exports

Reflection::export

(PHP 5, PHP 7)

Reflection::export — Exports

说明

public static Reflection::export ( Reflector $reflector , bool $return = false ) : string

导出一个反射（reflection）。

Warning

本函数还未编写文档，仅有参数列表。

参数

reflector

导出的反射。

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

如果参数 return 设为 true，导出结果将作为 string 返回，否则返回 null。

参见

  • Reflection::getModifierNames() - 获取修饰符的名称


获取修饰符的名称

  • ? Reflection::export
  • ReflectionClass ?
  • PHP Manual
  • Reflection
  • 获取修饰符的名称

Reflection::getModifierNames

(PHP 5, PHP 7)

Reflection::getModifierNames — 获取修饰符的名称

说明

public static Reflection::getModifierNames ( int $modifiers ) : array

获取修饰符的名称。

参数

modifiers

根据标志位域获取修饰符。

返回值

修饰符名称的一个数组。

范例

Example #1 Reflection::getModifierNames() 例子

<?php
class Testing
{
    final public static function foo()
    {
        return;
    }

    public function bar()
    {
        return;
    }
}

$foo = new ReflectionMethod('Testing', 'foo');

echo "Modifiers for method foo():\n";
echo $foo->getModifiers() . "\n";
echo implode(' ', Reflection::getModifierNames($foo->getModifiers())) . "\n";

$bar = new ReflectionMethod('Testing', 'bar');

echo "Modifiers for method bar():\n";
echo $bar->getModifiers() . "\n";
echo implode(' ', Reflection::getModifierNames($bar->getModifiers()));

以上例程的输出类似于：

Modifiers for method foo():
261
final public static
Modifiers for method bar():
65792
public

参见

  • ReflectionClass::getModifiers() - 获取类的修饰符
  • ReflectionClassConstant::getModifiers() - Gets the class constant modifiers
  • ReflectionMethod::getModifiers() - 获取方法的修饰符
  • ReflectionProperty::getModifiers() - Gets the property modifiers


ReflectionClass 类

(PHP 5, PHP 7)

简介

ReflectionClass 类报告了一个类的有关信息。

类摘要

ReflectionClass implements Reflector {
/* 常量 */
const integer IS_IMPLICIT_ABSTRACT = 16 ;
const integer IS_EXPLICIT_ABSTRACT = 32 ;
const integer IS_FINAL = 64 ;
/* 属性 */
public $name ;
/* 方法 */
public __construct ( mixed $argument )
public static export ( mixed $argument , bool $return = false ) : string
public getConstant ( string $name ) : mixed
public getConstants ( ) : array
public getConstructor ( ) : ReflectionMethod
public getDefaultProperties ( ) : array
public getDocComment ( ) : string
public getEndLine ( ) : int
public getExtension ( ) : ReflectionExtension
public getExtensionName ( ) : string
public getFileName ( ) : string
public getInterfaceNames ( ) : array
public getInterfaces ( ) : array
public getMethod ( string $name ) : ReflectionMethod
public getMethods ( int $filter = ? ) : array
public getModifiers ( ) : int
public getName ( ) : string
public getNamespaceName ( ) : string
public getParentClass ( ) : ReflectionClass
public getProperties ( int $filter = ? ) : array
public getProperty ( string $name ) : ReflectionProperty
public getReflectionConstant ( string $name ) : ReflectionClassConstant|false
public getReflectionConstants ( int|null $filter = null ) : array
public getShortName ( ) : string
public getStartLine ( ) : int
public getStaticProperties ( ) : array
public getStaticPropertyValue ( string $name , mixed &$def_value = ? ) : mixed
public getTraitAliases ( ) : array
public getTraitNames ( ) : array
public getTraits ( ) : array
public hasConstant ( string $name ) : bool
public hasMethod ( string $name ) : bool
public hasProperty ( string $name ) : bool
public implementsInterface ( string $interface ) : bool
public inNamespace ( ) : bool
public isAbstract ( ) : bool
public isAnonymous ( ) : bool
public isCloneable ( ) : bool
public isFinal ( ) : bool
public isInstance ( object $object ) : bool
public isInstantiable ( ) : bool
public isInterface ( ) : bool
public isInternal ( ) : bool
public isIterable ( ) : bool
public isIterateable ( ) : bool
public isSubclassOf ( string $class ) : bool
public isTrait ( ) : bool
public isUserDefined ( ) : bool
public newInstance ( mixed $args , mixed $... = ? ) : object
public newInstanceArgs ( array $args = ? ) : object
public newInstanceWithoutConstructor ( ) : object
public setStaticPropertyValue ( string $name , string $value ) : void
public __toString ( ) : string
}

属性

name

类的名称。只读，并在尝试赋值的时候会抛出 ReflectionException。

预定义常量

ReflectionClass 修饰符

ReflectionClass::IS_IMPLICIT_ABSTRACT

指示了类是一个抽象类（abstract）， 因为它有抽象（abstract）方法。

ReflectionClass::IS_EXPLICIT_ABSTRACT

指示了类是一个抽象类（abstract）， 因为它已明确定义。

ReflectionClass::IS_FINAL

指示这是一个 final 类。

Table of Contents

  • ReflectionClass::__construct — 初始化 ReflectionClass 类
  • ReflectionClass::export — 导出一个类
  • ReflectionClass::getConstant — 获取定义过的一个常量
  • ReflectionClass::getConstants — 获取一组常量
  • ReflectionClass::getConstructor — 获取类的构造函数
  • ReflectionClass::getDefaultProperties — 获取默认属性
  • ReflectionClass::getDocComment — 获取文档注释
  • ReflectionClass::getEndLine — 获取最后一行的行数
  • ReflectionClass::getExtension — 根据已定义的类获取所在扩展的 ReflectionExtension 对象
  • ReflectionClass::getExtensionName — 获取定义的类所在的扩展的名称
  • ReflectionClass::getFileName — 获取定义类的文件名
  • ReflectionClass::getInterfaceNames — 获取接口（interface）名称
  • ReflectionClass::getInterfaces — 获取接口
  • ReflectionClass::getMethod — 获取一个类方法的 ReflectionMethod。
  • ReflectionClass::getMethods — 获取方法的数组
  • ReflectionClass::getModifiers — 获取类的修饰符
  • ReflectionClass::getName — 获取类名
  • ReflectionClass::getNamespaceName — 获取命名空间的名称
  • ReflectionClass::getParentClass — 获取父类
  • ReflectionClass::getProperties — 获取一组属性
  • ReflectionClass::getProperty — 获取类的一个属性的 ReflectionProperty
  • ReflectionClass::getReflectionConstant — Gets a ReflectionClassConstant for a class's constant
  • ReflectionClass::getReflectionConstants — Gets class constants
  • ReflectionClass::getShortName — 获取短名
  • ReflectionClass::getStartLine — 获取起始行号
  • ReflectionClass::getStaticProperties — 获取静态（static）属性
  • ReflectionClass::getStaticPropertyValue — 获取静态（static）属性的值
  • ReflectionClass::getTraitAliases — 返回 trait 别名的一个数组
  • ReflectionClass::getTraitNames — 返回这个类所使用 traits 的名称的数组
  • ReflectionClass::getTraits — 返回这个类所使用的 traits 数组
  • ReflectionClass::hasConstant — 检查常量是否已经定义
  • ReflectionClass::hasMethod — 检查方法是否已定义
  • ReflectionClass::hasProperty — 检查属性是否已定义
  • ReflectionClass::implementsInterface — 接口的实现
  • ReflectionClass::inNamespace — 检查是否位于命名空间中
  • ReflectionClass::isAbstract — 检查类是否是抽象类（abstract）
  • ReflectionClass::isAnonymous — 检查类是否是匿名类
  • ReflectionClass::isCloneable — 返回了一个类是否可复制
  • ReflectionClass::isFinal — 检查类是否声明为 final
  • ReflectionClass::isInstance — 检查类的实例
  • ReflectionClass::isInstantiable — 检查类是否可实例化
  • ReflectionClass::isInterface — 检查类是否是一个接口（interface）
  • ReflectionClass::isInternal — 检查类是否由扩展或核心在内部定义
  • ReflectionClass::isIterable — Check whether this class is iterable
  • ReflectionClass::isIterateable — 检查是否可迭代（iterateable）
  • ReflectionClass::isSubclassOf — 检查是否为一个子类
  • ReflectionClass::isTrait — 返回了是否为一个 trait
  • ReflectionClass::isUserDefined — 检查是否由用户定义的
  • ReflectionClass::newInstance — 从指定的参数创建一个新的类实例
  • ReflectionClass::newInstanceArgs — 从给出的参数创建一个新的类实例。
  • ReflectionClass::newInstanceWithoutConstructor — 创建一个新的类实例而不调用它的构造函数
  • ReflectionClass::setStaticPropertyValue — 设置静态属性的值
  • ReflectionClass::__toString — 返回 ReflectionClass 对象字符串的表示形式。


初始化 ReflectionClass 类

  • ? ReflectionClass
  • ReflectionClass::export ?
  • PHP Manual
  • ReflectionClass
  • 初始化 ReflectionClass 类

ReflectionClass::__construct

(PHP 5, PHP 7)

ReflectionClass::__construct — 初始化 ReflectionClass 类

说明

public ReflectionClass::__construct ( mixed $argument )

初始化新的 ReflectionClass 对象。

参数

argument

既可以是包含类名的字符串（string）也可以是对象（object）。

返回值

返回初始化完成后的 ReflectionClass 实例。

错误／异常

如果要反射的 Class 不存在，抛出异常 ReflectionException。

范例

Example #1 ReflectionClass 的基本用法

<?php
Reflection::export(new ReflectionClass('Exception'));
?>

以上例程的输出类似于：

Class [ <internal:Core> class Exception ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [7] {
    Property [ <default> protected $message ]
    Property [ <default> private $string ]
    Property [ <default> protected $code ]
    Property [ <default> protected $file ]
    Property [ <default> protected $line ]
    Property [ <default> private $trace ]
    Property [ <default> private $previous ]
  }

  - Methods [10] {
    Method [ <internal:Core> final private method __clone ] {
    }

    Method [ <internal:Core, ctor> public method __construct ] {

      - Parameters [3] {
        Parameter #0 [ <optional> $message ]
        Parameter #1 [ <optional> $code ]
        Parameter #2 [ <optional> $previous ]
      }
    }

    Method [ <internal:Core> final public method getMessage ] {
    }

    Method [ <internal:Core> final public method getCode ] {
    }

    Method [ <internal:Core> final public method getFile ] {
    }

    Method [ <internal:Core> final public method getLine ] {
    }

    Method [ <internal:Core> final public method getTrace ] {
    }

    Method [ <internal:Core> final public method getPrevious ] {
    }

    Method [ <internal:Core> final public method getTraceAsString ] {
    }

    Method [ <internal:Core> public method __toString ] {
    }
  }
}

参见

  • ReflectionObject::__construct() - Constructs a ReflectionObject
  • Constructors


导出一个类

  • ? ReflectionClass::__construct
  • ReflectionClass::getConstant ?
  • PHP Manual
  • ReflectionClass
  • 导出一个类

ReflectionClass::export

(PHP 5, PHP 7)

ReflectionClass::export — 导出一个类

说明

public static ReflectionClass::export ( mixed $argument , bool $return = false ) : string

导出一个反射后的类。

参数

argument

导出的反射。

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

如果参数 return 设为 true，导出结果将作为 string 返回，否则返回 null。

范例

Example #1 ReflectionClass::export() 的基本用法

<?php
class Apple {
    public $var1;
    public $var2 = 'Orange';

    public function type() {
        return 'Apple';
    }
}
ReflectionClass::export('Apple');
?>

以上例程的输出类似于：

Class [ <user> class Apple ] {
  @@ php shell code 1-8

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [2] {
    Property [ <default> public $var1 ]
    Property [ <default> public $var2 ]
  }

  - Methods [1] {
    Method [ <user> public method type ] {
      @@ php shell code 5 - 7
    }
  }
}

参见

  • ReflectionClass::getName() - 获取类名


获取定义过的一个常量

  • ? ReflectionClass::export
  • ReflectionClass::getConstants ?
  • PHP Manual
  • ReflectionClass
  • 获取定义过的一个常量

ReflectionClass::getConstant

(PHP 5, PHP 7)

ReflectionClass::getConstant — 获取定义过的一个常量

说明

public ReflectionClass::getConstant ( string $name ) : mixed

获取定义过的一个常量。

Warning

本函数还未编写文档，仅有参数列表。

参数

name

常量的名称。

返回值

常量的值。

参见

  • ReflectionClass::getConstants() - 获取一组常量


获取一组常量

  • ? ReflectionClass::getConstant
  • ReflectionClass::getConstructor ?
  • PHP Manual
  • ReflectionClass
  • 获取一组常量

ReflectionClass::getConstants

(PHP 5, PHP 7)

ReflectionClass::getConstants — 获取一组常量

说明

public ReflectionClass::getConstants ( ) : array

获取某个类的全部已定义的常量，不管可见性如何定义。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

常量的数组，常量名是数组的键，常量的值是数组的值。

参见

  • ReflectionClass::getConstant() - 获取定义过的一个常量


获取类的构造函数

  • ? ReflectionClass::getConstants
  • ReflectionClass::getDefaultProperties ?
  • PHP Manual
  • ReflectionClass
  • 获取类的构造函数

ReflectionClass::getConstructor

(PHP 5, PHP 7)

ReflectionClass::getConstructor — 获取类的构造函数

说明

public ReflectionClass::getConstructor ( ) : ReflectionMethod

获取已反射的类的构造函数。

参数

此函数没有参数。

返回值

一个 ReflectionMethod 对象，反射了类的构造函数，或者当类不存在构造函数时返回 null。

范例

Example #1 ReflectionClass::getConstructor() 的基本用法

<?php
$class = new ReflectionClass('ReflectionClass');
$constructor = $class->getConstructor();
var_dump($constructor);
?>

以上例程会输出：

object(ReflectionMethod)#2 (2) {
  ["name"]=>
  string(11) "__construct"
  ["class"]=>
  string(15) "ReflectionClass"
}

参见

  • ReflectionClass::getName() - 获取类名


获取默认属性

  • ? ReflectionClass::getConstructor
  • ReflectionClass::getDocComment ?
  • PHP Manual
  • ReflectionClass
  • 获取默认属性

ReflectionClass::getDefaultProperties

(PHP 5, PHP 7)

ReflectionClass::getDefaultProperties — 获取默认属性

说明

public ReflectionClass::getDefaultProperties ( ) : array

获取类的默认属性（包括了继承的属性）。

Note:

This method only works for static properties when used on internal classes. The default value of a static class property can not be tracked when using this method on user defined classes.

参数

此函数没有参数。

返回值

默认属性的数组，其键是属性的名称，其值是属性的默认值或者在属性没有默认值时是 null。 这个函数不区分静态和非静态属性，也不考虑可见性修饰符。

范例

Example #1 ReflectionClass::getDefaultProperties() 例子

<?php
class Bar {
    protected $inheritedProperty = 'inheritedDefault';
}

class Foo extends Bar {
    public $property = 'propertyDefault';
    private $privateProperty = 'privatePropertyDefault';
    public static $staticProperty = 'staticProperty';
    public $defaultlessProperty;
}

$reflectionClass = new ReflectionClass('Foo');
var_dump($reflectionClass->getDefaultProperties());
?>

以上例程会输出：

array(5) {
   ["staticProperty"]=>
   string(14) "staticProperty"
   ["property"]=>
   string(15) "propertyDefault"
   ["privateProperty"]=>
   string(22) "privatePropertyDefault"
   ["defaultlessProperty"]=>
   NULL
   ["inheritedProperty"]=>
   string(16) "inheritedDefault"
}

参见

  • ReflectionClass::getProperties() - 获取一组属性
  • ReflectionClass::getStaticProperties() - 获取静态（static）属性
  • ReflectionClass::getProperty() - 获取类的一个属性的 ReflectionProperty


获取文档注释

  • ? ReflectionClass::getDefaultProperties
  • ReflectionClass::getEndLine ?
  • PHP Manual
  • ReflectionClass
  • 获取文档注释

ReflectionClass::getDocComment

(PHP 5, PHP 7)

ReflectionClass::getDocComment — 获取文档注释

说明

public ReflectionClass::getDocComment ( ) : string

从一个类中获取文档注释。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

如果存在则返回文档注释，否则返回 false。

范例

Example #1 ReflectionClass::getDocComment() 例子

<?php
/**
* A test class
*
* @param  foo bar
* @return baz
*/
class TestClass { }

$rc = new ReflectionClass('TestClass');
var_dump($rc->getDocComment())
?>

以上例程会输出：

string(55) "/**
* A test class
*
* @param  foo bar
* @return baz
*/"

参见

  • ReflectionClass::getName() - 获取类名


获取最后一行的行数

  • ? ReflectionClass::getDocComment
  • ReflectionClass::getExtension ?
  • PHP Manual
  • ReflectionClass
  • 获取最后一行的行数

ReflectionClass::getEndLine

(PHP 5, PHP 7)

ReflectionClass::getEndLine — 获取最后一行的行数

说明

public ReflectionClass::getEndLine ( ) : int

从用户定义的类获取其最后一行的行数。

参数

此函数没有参数。

返回值

返回用户定义的类最后一行的行数，如果未知则返回 false。

范例

Example #1 ReflectionClass::getEndLine() 例子

<?php
// Test Class
class TestClass { }

$rc = new ReflectionClass('TestClass');

echo $rc->getEndLine();
?>

以上例程会输出：

3

参见

  • ReflectionClass::getStartLine() - 获取起始行号


根据已定义的类获取所在扩展的 ReflectionExtension 对象

  • ? ReflectionClass::getEndLine
  • ReflectionClass::getExtensionName ?
  • PHP Manual
  • ReflectionClass
  • 根据已定义的类获取所在扩展的 ReflectionExtension 对象

ReflectionClass::getExtension

(PHP 5, PHP 7)

ReflectionClass::getExtension — 根据已定义的类获取所在扩展的 ReflectionExtension 对象

说明

public ReflectionClass::getExtension ( ) : ReflectionExtension

获取已定义类的扩展的 ReflectionExtension 对象。

参数

此函数没有参数。

返回值

类所处的扩展的 ReflectionExtension 对象的表示，如果是用户定义的类则返回 null。

范例

Example #1 ReflectionClass::getExtension() 的基本用法

<?php
$class = new ReflectionClass('ReflectionClass');
$extension = $class->getExtension();
var_dump($extension);
?>

以上例程会输出：

object(ReflectionExtension)#2 (1) {
  ["name"]=>
  string(10) "Reflection"
}

参见

  • ReflectionClass::getExtensionName() - 获取定义的类所在的扩展的名称


获取定义的类所在的扩展的名称

  • ? ReflectionClass::getExtension
  • ReflectionClass::getFileName ?
  • PHP Manual
  • ReflectionClass
  • 获取定义的类所在的扩展的名称

ReflectionClass::getExtensionName

(PHP 5, PHP 7)

ReflectionClass::getExtensionName — 获取定义的类所在的扩展的名称

说明

public ReflectionClass::getExtensionName ( ) : string

获取定义的类所在的扩展的名称。

参数

此函数没有参数。

返回值

获取定义的类所在的扩展的名称，如果是用户定义的类，则返回 false。

范例

Example #1 ReflectionClass::getExtensionName() 的基本用法

<?php
$class = new ReflectionClass('ReflectionClass');
$extension = $class->getExtensionName();
var_dump($extension);
?>

以上例程会输出：

string(10) "Reflection"

参见

  • ReflectionClass::getExtension() - 根据已定义的类获取所在扩展的 ReflectionExtension 对象


获取定义类的文件名

  • ? ReflectionClass::getExtensionName
  • ReflectionClass::getInterfaceNames ?
  • PHP Manual
  • ReflectionClass
  • 获取定义类的文件名

ReflectionClass::getFileName

(PHP 5, PHP 7)

ReflectionClass::getFileName — 获取定义类的文件名

说明

public ReflectionClass::getFileName ( ) : string

获取类被定义的文件的文件名。

参数

此函数没有参数。

返回值

返回类所定义的文件名。如果这个类是在 PHP 核心或 PHP 扩展中定义的，则返回 false。

参见

  • ReflectionClass::getExtensionName() - 获取定义的类所在的扩展的名称


获取接口（interface）名称

  • ? ReflectionClass::getFileName
  • ReflectionClass::getInterfaces ?
  • PHP Manual
  • ReflectionClass
  • 获取接口（interface）名称

ReflectionClass::getInterfaceNames

(PHP 5 >= 5.2.0, PHP 7)

ReflectionClass::getInterfaceNames — 获取接口（interface）名称

说明

public ReflectionClass::getInterfaceNames ( ) : array

获取接口（interface）名称。

参数

此函数没有参数。

返回值

一个数值数组，接口（interface）的名称是数组的值。

范例

Example #1 ReflectionClass::getInterfaceNames() 例子

<?php
interface Foo { }

interface Bar { }

class Baz implements Foo, Bar { }

$rc1 = new ReflectionClass("Baz");

print_r($rc1->getInterfaceNames());
?>

以上例程的输出类似于：

Array
(
    [0] => Foo
    [1] => Bar
)

参见

  • ReflectionClass::getInterfaces() - 获取接口


获取接口

  • ? ReflectionClass::getInterfaceNames
  • ReflectionClass::getMethod ?
  • PHP Manual
  • ReflectionClass
  • 获取接口

ReflectionClass::getInterfaces

(PHP 5, PHP 7)

ReflectionClass::getInterfaces — 获取接口

说明

public ReflectionClass::getInterfaces ( ) : array

获取接口。

参数

此函数没有参数。

返回值

接口的关联数组，数组键是接口（interface）的名称，数组的值是 ReflectionClass 对象。

范例

Example #1 ReflectionClass::getInterfaces() 例子

<?php
interface Foo { }

interface Bar { }

class Baz implements Foo, Bar { }

$rc1 = new ReflectionClass("Baz");

print_r($rc1->getInterfaces());
?>

以上例程的输出类似于：

Array
(
    [Foo] => ReflectionClass Object
        (
            [name] => Foo
        )

    [Bar] => ReflectionClass Object
        (
            [name] => Bar
        )

)

参见

  • ReflectionClass::getInterfaceNames() - 获取接口（interface）名称


获取一个类方法的 ReflectionMethod。

  • ? ReflectionClass::getInterfaces
  • ReflectionClass::getMethods ?
  • PHP Manual
  • ReflectionClass
  • 获取一个类方法的 ReflectionMethod。

ReflectionClass::getMethod

(PHP 5, PHP 7)

ReflectionClass::getMethod — 获取一个类方法的 ReflectionMethod。

说明

public ReflectionClass::getMethod ( string $name ) : ReflectionMethod

获取一个类方法的 ReflectionMethod。

参数

name

要反射的方法名称。

返回值

一个 ReflectionMethod。

错误／异常

如果方法不存在则会抛出 ReflectionException 异常。

范例

Example #1 ReflectionClass::getMethod() 的基本用法

<?php
$class = new ReflectionClass('ReflectionClass');
$method = $class->getMethod('getMethod');
var_dump($method);
?>

以上例程会输出：

object(ReflectionMethod)#2 (2) {
  ["name"]=>
  string(9) "getMethod"
  ["class"]=>
  string(15) "ReflectionClass"
}

参见

  • ReflectionClass::getMethods() - 获取方法的数组


获取方法的数组

  • ? ReflectionClass::getMethod
  • ReflectionClass::getModifiers ?
  • PHP Manual
  • ReflectionClass
  • 获取方法的数组

ReflectionClass::getMethods

(PHP 5, PHP 7)

ReflectionClass::getMethods — 获取方法的数组

说明

public ReflectionClass::getMethods ( int $filter = ? ) : array

获取类的方法的一个数组。

参数

filter

过滤结果为仅包含某些属性的方法。默认不过滤。

ReflectionMethod::IS_STATIC、
ReflectionMethod::IS_PUBLIC、
ReflectionMethod::IS_PROTECTED、
ReflectionMethod::IS_PRIVATE、
ReflectionMethod::IS_ABSTRACT、
ReflectionMethod::IS_FINAL 的按位或（OR），就会返回任意满足条件的属性。

Note: 请注意：其他位操作，例如 ~ 无法按预期运行。这个例子也就是说，无法获取所有的非静态方法。

返回值

包含每个方法 ReflectionMethod 对象的数组。

范例

Example #1 ReflectionClass::getMethods() 的基本用法

<?php
class Apple {
    public function firstMethod() { }
    final protected function secondMethod() { }
    private static function thirdMethod() { }
}

$class = new ReflectionClass('Apple');
$methods = $class->getMethods();
var_dump($methods);
?>

以上例程会输出：

array(3) {
  [0]=>
  &object(ReflectionMethod)#2 (2) {
    ["name"]=>
    string(11) "firstMethod"
    ["class"]=>
    string(5) "Apple"
  }
  [1]=>
  &object(ReflectionMethod)#3 (2) {
    ["name"]=>
    string(12) "secondMethod"
    ["class"]=>
    string(5) "Apple"
  }
  [2]=>
  &object(ReflectionMethod)#4 (2) {
    ["name"]=>
    string(11) "thirdMethod"
    ["class"]=>
    string(5) "Apple"
  }
}

Example #2 从 ReflectionClass::getMethods() 中过滤结果

<?php
class Apple {
    public function firstMethod() { }
    final protected function secondMethod() { }
    private static function thirdMethod() { }
}

$class = new ReflectionClass('Apple');
$methods = $class->getMethods(ReflectionMethod::IS_STATIC | ReflectionMethod::IS_FINAL);
var_dump($methods);
?>

以上例程会输出：

array(2) {
  [0]=>
  &object(ReflectionMethod)#2 (2) {
    ["name"]=>
    string(12) "secondMethod"
    ["class"]=>
    string(5) "Apple"
  }
  [1]=>
  &object(ReflectionMethod)#3 (2) {
    ["name"]=>
    string(11) "thirdMethod"
    ["class"]=>
    string(5) "Apple"
  }
}

参见

  • ReflectionClass::getMethod() - 获取一个类方法的 ReflectionMethod。
  • get_class_methods() - 返回由类的方法名组成的数组


获取类的修饰符

  • ? ReflectionClass::getMethods
  • ReflectionClass::getName ?
  • PHP Manual
  • ReflectionClass
  • 获取类的修饰符

ReflectionClass::getModifiers

(PHP 5, PHP 7)

ReflectionClass::getModifiers — 获取类的修饰符

说明

public ReflectionClass::getModifiers ( ) : int

返回这个类访问修饰符的位字段。

参数

此函数没有参数。

返回值

返回 修饰符常量 的位掩码。

参见

  • ReflectionClass::getProperties() - 获取一组属性
  • Reflection::getModifierNames() - 获取修饰符的名称


获取类名

  • ? ReflectionClass::getModifiers
  • ReflectionClass::getNamespaceName ?
  • PHP Manual
  • ReflectionClass
  • 获取类名

ReflectionClass::getName

(PHP 5, PHP 7)

ReflectionClass::getName — 获取类名

说明

public ReflectionClass::getName ( ) : string

获取类的名称。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The class name.

范例

Example #1 ReflectionClass::getName() 例子

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

以上例程会输出：

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

参见

  • ReflectionClass::getNamespaceName() - 获取命名空间的名称


获取命名空间的名称

  • ? ReflectionClass::getName
  • ReflectionClass::getParentClass ?
  • PHP Manual
  • ReflectionClass
  • 获取命名空间的名称

ReflectionClass::getNamespaceName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::getNamespaceName — 获取命名空间的名称

说明

public ReflectionClass::getNamespaceName ( ) : string

获取命名空间（namespace）的名称。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

命名空间的名称。

范例

Example #1 ReflectionClass::getNamespaceName() 例子

<?php
namespace A\B;

class Foo { }

$class = new \ReflectionClass('stdClass');

var_dump($class->inNamespace());
var_dump($class->getName());
var_dump($class->getNamespaceName());
var_dump($class->getShortName());

$class = new \ReflectionClass('A\\B\\Foo');

var_dump($class->inNamespace());
var_dump($class->getName());
var_dump($class->getNamespaceName());
var_dump($class->getShortName());
?>

以上例程会输出：

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

参见

  • ReflectionClass::getParentClass() - 获取父类
  • namespaces


获取父类

  • ? ReflectionClass::getNamespaceName
  • ReflectionClass::getProperties ?
  • PHP Manual
  • ReflectionClass
  • 获取父类

ReflectionClass::getParentClass

(PHP 5, PHP 7)

ReflectionClass::getParentClass — 获取父类

说明

public ReflectionClass::getParentClass ( ) : ReflectionClass

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

一个 ReflectionClass。

参见

  • ReflectionClass::__construct() - 初始化 ReflectionClass 类


获取一组属性

  • ? ReflectionClass::getParentClass
  • ReflectionClass::getProperty ?
  • PHP Manual
  • ReflectionClass
  • 获取一组属性

ReflectionClass::getProperties

(PHP 5, PHP 7)

ReflectionClass::getProperties — 获取一组属性

说明

public ReflectionClass::getProperties ( int $filter = ? ) : array

获取反射过的属性。

参数

filter

可选的过滤器，过滤为所需类型的属性。它使用 ReflectionProperty 常量 来配置，默认获取所有类型的属性。

返回值

ReflectionProperty 对象的数组。

范例

Example #1 ReflectionClass::getProperties() 过滤例子

这个例子延时了可选 filter 参数的用法，例子里实际上忽略了私有属性。

<?php
class Foo {
    public    $foo  = 1;
    protected $bar  = 2;
    private   $baz  = 3;
}

$foo = new Foo();

$reflect = new ReflectionClass($foo);
$props   = $reflect->getProperties(ReflectionProperty::IS_PUBLIC | ReflectionProperty::IS_PROTECTED);

foreach ($props as $prop) {
    print $prop->getName() . "\n";
}

var_dump($props);

?>

以上例程的输出类似于：

foo
bar
array(2) {
  [0]=>
  object(ReflectionProperty)#3 (2) {
    ["name"]=>
    string(3) "foo"
    ["class"]=>
    string(3) "Foo"
  }
  [1]=>
  object(ReflectionProperty)#4 (2) {
    ["name"]=>
    string(3) "bar"
    ["class"]=>
    string(3) "Foo"
  }
}

参见

  • ReflectionClass::getProperty() - 获取类的一个属性的 ReflectionProperty
  • ReflectionProperty
  • ReflectionProperty 修饰符常量


获取类的一个属性的 ReflectionProperty

  • ? ReflectionClass::getProperties
  • ReflectionClass::getReflectionConstant ?
  • PHP Manual
  • ReflectionClass
  • 获取类的一个属性的 ReflectionProperty

ReflectionClass::getProperty

(PHP 5, PHP 7)

ReflectionClass::getProperty — 获取类的一个属性的 ReflectionProperty

说明

public ReflectionClass::getProperty ( string $name ) : ReflectionProperty

获取类的一个属性的 ReflectionProperty。

参数

name

属性名。

返回值

一个 ReflectionProperty。

范例

Example #1 ReflectionClass::getProperty() 的基本用法

<?php
$class = new ReflectionClass('ReflectionClass');
$property = $class->getProperty('name');
var_dump($property);
?>

以上例程会输出：

object(ReflectionProperty)#2 (2) {
  ["name"]=>
  string(4) "name"
  ["class"]=>
  string(15) "ReflectionClass"
}

参见

  • ReflectionClass::getProperties() - 获取一组属性


Gets a ReflectionClassConstant for a class's constant

  • ? ReflectionClass::getProperty
  • ReflectionClass::getReflectionConstants ?
  • PHP Manual
  • ReflectionClass
  • Gets a ReflectionClassConstant for a class's constant

ReflectionClass::getReflectionConstant

(PHP 7 >= 7.1.0)

ReflectionClass::getReflectionConstant — Gets a ReflectionClassConstant for a class's constant

说明

public ReflectionClass::getReflectionConstant ( string $name ) : ReflectionClassConstant|false

Gets a ReflectionClassConstant for a class's property.

参数

name

The class constant name.

返回值

A ReflectionClassConstant, 或者在失败时返回 false.

参见

  • ReflectionClass::getReflectionConstants() - Gets class constants
  • ReflectionClassConstant


Gets class constants

  • ? ReflectionClass::getReflectionConstant
  • ReflectionClass::getShortName ?
  • PHP Manual
  • ReflectionClass
  • Gets class constants

ReflectionClass::getReflectionConstants

(PHP 7 >= 7.1.0)

ReflectionClass::getReflectionConstants — Gets class constants

说明

public ReflectionClass::getReflectionConstants ( int|null $filter = null ) : array

Retrieves reflected constants.

参数

filter

The optional filter, for filtering desired constant visibilities. It's configured using the ReflectionClassConstant constants, and defaults to all constant visibilities.

返回值

An array of ReflectionClassConstant objects.

更新日志

版本 | 说明
8.0.0 | filter has been added.

范例

Example #1 Basic ReflectionClass::getReflectionConstants() example

<?php
class Foo {
    public    const FOO  = 1;
    protected const BAR  = 2;
    private   const BAZ  = 3;
}

$foo = new Foo();

$reflect = new ReflectionClass($foo);
$consts  = $reflect->getReflectionConstants();

foreach ($consts as $const) {
    print $const->getName() . "\n";
}

var_dump($consts);

?>

以上例程的输出类似于：

FOO
BAR
BAZ
array(3) {
  [0]=>
  object(ReflectionClassConstant)#3 (2) {
    ["name"]=>
    string(3) "FOO"
    ["class"]=>
    string(3) "Foo"
  }
  [1]=>
  object(ReflectionClassConstant)#4 (2) {
    ["name"]=>
    string(3) "BAR"
    ["class"]=>
    string(3) "Foo"
  }
  [2]=>
  object(ReflectionClassConstant)#5 (2) {
    ["name"]=>
    string(3) "BAZ"
    ["class"]=>
    string(3) "Foo"
  }
}

参见

  • ReflectionClass::getReflectionConstant() - Gets a ReflectionClassConstant for a class's constant
  • ReflectionClassConstant


获取短名

  • ? ReflectionClass::getReflectionConstants
  • ReflectionClass::getStartLine ?
  • PHP Manual
  • ReflectionClass
  • 获取短名

ReflectionClass::getShortName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::getShortName — 获取短名

说明

public ReflectionClass::getShortName ( ) : string

获取类的短名，就是不含命名空间（namespace）的那一部分。

参数

此函数没有参数。

返回值

类的短名。

范例

Example #1 ReflectionClass::getShortName() 例子

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

以上例程会输出：

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

参见

  • ReflectionClass::getName() - 获取类名


获取起始行号

  • ? ReflectionClass::getShortName
  • ReflectionClass::getStaticProperties ?
  • PHP Manual
  • ReflectionClass
  • 获取起始行号

ReflectionClass::getStartLine

(PHP 5, PHP 7)

ReflectionClass::getStartLine — 获取起始行号

说明

public ReflectionClass::getStartLine ( ) : int

获取起始的行号。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

起始的行号，类型是 integer 的。

参见

  • ReflectionClass::getEndLine() - 获取最后一行的行数


获取静态（static）属性

  • ? ReflectionClass::getStartLine
  • ReflectionClass::getStaticPropertyValue ?
  • PHP Manual
  • ReflectionClass
  • 获取静态（static）属性

ReflectionClass::getStaticProperties

(PHP 5, PHP 7)

ReflectionClass::getStaticProperties — 获取静态（static）属性

说明

public ReflectionClass::getStaticProperties ( ) : array

获取静态（static）属性。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

静态（static）的属性，类型是 array。

参见

  • ReflectionClass::getStaticPropertyValue() - 获取静态（static）属性的值
  • ReflectionClass::setStaticPropertyValue() - 设置静态属性的值


获取静态（static）属性的值

  • ? ReflectionClass::getStaticProperties
  • ReflectionClass::getTraitAliases ?
  • PHP Manual
  • ReflectionClass
  • 获取静态（static）属性的值

ReflectionClass::getStaticPropertyValue

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::getStaticPropertyValue — 获取静态（static）属性的值

说明

public ReflectionClass::getStaticPropertyValue ( string $name , mixed &$def_value = ? ) : mixed

获取这个类里静态（static）属性的值。

参数

name

静态属性的名称，来返回它的值。

def_value

假如类没有定义 name 的 static 属性，将返回一个默认值。 如果属性不存在，并且省略了此参数，将会抛出 ReflectionException 。

返回值

静态属性的值。

范例

Example #1 ReflectionClass::getStaticPropertyValue() 的基本用法

<?php
class Apple {
    public static $color = 'Red';
}

$class = new ReflectionClass('Apple');
var_dump($class->getStaticPropertyValue('color'));
?>

以上例程会输出：

string(3) "Red"

参见

  • ReflectionClass::getStaticProperties() - 获取静态（static）属性
  • ReflectionClass::setStaticPropertyValue() - 设置静态属性的值


返回 trait 别名的一个数组

  • ? ReflectionClass::getStaticPropertyValue
  • ReflectionClass::getTraitNames ?
  • PHP Manual
  • ReflectionClass
  • 返回 trait 别名的一个数组

ReflectionClass::getTraitAliases

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::getTraitAliases — 返回 trait 别名的一个数组

说明

public ReflectionClass::getTraitAliases ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回了一个数组，新的方法名位于键中，原始名称（格式是 "TraitName::original"）位于数组的值中。 出现一个错误的情况下返回 null。


返回这个类所使用 traits 的名称的数组

  • ? ReflectionClass::getTraitAliases
  • ReflectionClass::getTraits ?
  • PHP Manual
  • ReflectionClass
  • 返回这个类所使用 traits 的名称的数组

ReflectionClass::getTraitNames

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::getTraitNames — 返回这个类所使用 traits 的名称的数组

说明

public ReflectionClass::getTraitNames ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回的数组的值包含了 trait 的名称。 出现错误的情况下返回 null。


返回这个类所使用的 traits 数组

  • ? ReflectionClass::getTraitNames
  • ReflectionClass::hasConstant ?
  • PHP Manual
  • ReflectionClass
  • 返回这个类所使用的 traits 数组

ReflectionClass::getTraits

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::getTraits — 返回这个类所使用的 traits 数组

说明

public ReflectionClass::getTraits ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回了一个数组，键是 trait 的名称，值是 trait 实例的 ReflectionClass。 出现错误的情况下返回 null。


检查常量是否已经定义

  • ? ReflectionClass::getTraits
  • ReflectionClass::hasMethod ?
  • PHP Manual
  • ReflectionClass
  • 检查常量是否已经定义

ReflectionClass::hasConstant

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::hasConstant — 检查常量是否已经定义

说明

public ReflectionClass::hasConstant ( string $name ) : bool

检查类中是否已经定义了指定的常量。

参数

name

要被检查的常量名称。

返回值

如果已定义返回 true，否则返回 false。

范例

Example #1 ReflectionClass::hasConstant() 例子

<?php
class Foo {
    const c1 = 1;
}

$class = new ReflectionClass("Foo");

var_dump($class->hasConstant("c1"));
var_dump($class->hasConstant("c2"));
?>

以上例程的输出类似于：

bool(true)
bool(false)

参见

  • ReflectionClass::hasMethod() - 检查方法是否已定义
  • ReflectionClass::hasProperty() - 检查属性是否已定义


检查方法是否已定义

  • ? ReflectionClass::hasConstant
  • ReflectionClass::hasProperty ?
  • PHP Manual
  • ReflectionClass
  • 检查方法是否已定义

ReflectionClass::hasMethod

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::hasMethod — 检查方法是否已定义

说明

public ReflectionClass::hasMethod ( string $name ) : bool

检查一个类中指定的方法是否已定义。

参数

name

要检查的方法的名称。

返回值

如果有这个方法返回 true，否则返回 false。

范例

Example #1 ReflectionClass::hasMethod() 例子

<?php
Class C {
    public function publicFoo() {
        return true;
    }

    protected function protectedFoo() {
        return true;
    }

    private function privateFoo() {
        return true;
    }

    static function staticFoo() {
        return true;
    }
}

$rc = new ReflectionClass("C");

var_dump($rc->hasMethod('publicFoo'));

var_dump($rc->hasMethod('protectedFoo'));

var_dump($rc->hasMethod('privateFoo'));

var_dump($rc->hasMethod('staticFoo'));

// C should not have method bar
var_dump($rc->hasMethod('bar'));

// Method names are case insensitive
var_dump($rc->hasMethod('PUBLICfOO'));
?>

以上例程会输出：

bool(true)
bool(true)
bool(true)
bool(true)
bool(false)
bool(true)

参见

  • ReflectionClass::hasConstant() - 检查常量是否已经定义
  • ReflectionClass::hasProperty() - 检查属性是否已定义


检查属性是否已定义

  • ? ReflectionClass::hasMethod
  • ReflectionClass::implementsInterface ?
  • PHP Manual
  • ReflectionClass
  • 检查属性是否已定义

ReflectionClass::hasProperty

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::hasProperty — 检查属性是否已定义

说明

public ReflectionClass::hasProperty ( string $name ) : bool

检查指定的属性是否已定义。

参数

name

待检查的属性的名称。

返回值

如果有这个属性返回 true，否则返回 false。

范例

Example #1 ReflectionClass::hasProperty() 例子

<?php
class Foo {
    public    $p1;
    protected $p2;
    private   $p3;

}

$obj = new ReflectionObject(new Foo());

var_dump($obj->hasProperty("p1"));
var_dump($obj->hasProperty("p2"));
var_dump($obj->hasProperty("p3"));
var_dump($obj->hasProperty("p4"));
?>

以上例程的输出类似于：

bool(true)
bool(true)
bool(true)
bool(false)

参见

  • ReflectionClass::hasConstant() - 检查常量是否已经定义
  • ReflectionClass::hasMethod() - 检查方法是否已定义


接口的实现

  • ? ReflectionClass::hasProperty
  • ReflectionClass::inNamespace ?
  • PHP Manual
  • ReflectionClass
  • 接口的实现

ReflectionClass::implementsInterface

(PHP 5, PHP 7)

ReflectionClass::implementsInterface — 接口的实现

说明

public ReflectionClass::implementsInterface ( string $interface ) : bool

检查它是否实现了一个接口（interface）。

参数

interface

接口（interface）的名称。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ReflectionClass::isInterface() - 检查类是否是一个接口（interface）
  • ReflectionClass::isSubclassOf() - 检查是否为一个子类
  • interface_exists() - 检查接口是否已被定义
  • Object Interfaces


检查是否位于命名空间中

  • ? ReflectionClass::implementsInterface
  • ReflectionClass::isAbstract ?
  • PHP Manual
  • ReflectionClass
  • 检查是否位于命名空间中

ReflectionClass::inNamespace

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::inNamespace — 检查是否位于命名空间中

说明

public ReflectionClass::inNamespace ( ) : bool

检查这个类是否定义于一个命名空间中里。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::inNamespace() 例子

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

以上例程会输出：

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

参见

  • ReflectionClass::getNamespaceName() - 获取命名空间的名称
  • PHP Namespaces


检查类是否是抽象类（abstract）

  • ? ReflectionClass::inNamespace
  • ReflectionClass::isAnonymous ?
  • PHP Manual
  • ReflectionClass
  • 检查类是否是抽象类（abstract）

ReflectionClass::isAbstract

(PHP 5, PHP 7)

ReflectionClass::isAbstract — 检查类是否是抽象类（abstract）

说明

public ReflectionClass::isAbstract ( ) : bool

检查这个类是否是抽象类（abstract）。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::isAbstract() 例子

<?php
class          TestClass { }
abstract class TestAbstractClass { }

$testClass     = new ReflectionClass('TestClass');
$abstractClass = new ReflectionClass('TestAbstractClass');

var_dump($testClass->isAbstract());
var_dump($abstractClass->isAbstract());
?>

以上例程会输出：

bool(false)
bool(true)

参见

  • ReflectionClass::isInterface() - 检查类是否是一个接口（interface）
  • 类的抽象


检查类是否是匿名类

  • ? ReflectionClass::isAbstract
  • ReflectionClass::isCloneable ?
  • PHP Manual
  • ReflectionClass
  • 检查类是否是匿名类

ReflectionClass::isAnonymous

(PHP 7)

ReflectionClass::isAnonymous — 检查类是否是匿名类

说明

public ReflectionClass::isAnonymous ( ) : bool

检查类是否是匿名类。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::isAnonymous() example

<?php
class TestClass {}
$anonClass = new class {};

$normalClass = new ReflectionClass('TestClass');
$anonClass  = new ReflectionClass($anonClass);

var_dump($normalClass->isAnonymous());
var_dump($anonClass->isAnonymous());

?>

以上例程会输出：

bool(false)
bool(true)

参见

  • ReflectionClass::isFinal() - 检查类是否声明为 final


返回了一个类是否可复制

  • ? ReflectionClass::isAnonymous
  • ReflectionClass::isFinal ?
  • PHP Manual
  • ReflectionClass
  • 返回了一个类是否可复制

ReflectionClass::isCloneable

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::isCloneable — 返回了一个类是否可复制

说明

public ReflectionClass::isCloneable ( ) : bool

返回了这个类是否可复制。

参数

此函数没有参数。

返回值

如果这个类可以复制返回 true，否则返回 false。

范例

Example #1 ReflectionClass::isCloneable() 的基本用法

<?php
class NotCloneable {
    public $var1;

    private function __clone() {
    }
}

class Cloneable {
    public $var1;
}

$notCloneable = new ReflectionClass('NotCloneable');
$cloneable = new ReflectionClass('Cloneable');

var_dump($notCloneable->isCloneable());
var_dump($cloneable->isCloneable());
?>

以上例程会输出：

bool(false)
bool(true)


检查类是否声明为 final

  • ? ReflectionClass::isCloneable
  • ReflectionClass::isInstance ?
  • PHP Manual
  • ReflectionClass
  • 检查类是否声明为 final

ReflectionClass::isFinal

(PHP 5, PHP 7)

ReflectionClass::isFinal — 检查类是否声明为 final

说明

public ReflectionClass::isFinal ( ) : bool

检查类是否声明为 final。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::isFinal() 例子

<?php
class       TestClass { }
final class TestFinalClass { }

$normalClass = new ReflectionClass('TestClass');
$finalClass  = new ReflectionClass('TestFinalClass');

var_dump($normalClass->isFinal());
var_dump($finalClass->isFinal());

?>

以上例程会输出：

bool(false)
bool(true)

参见

  • ReflectionClass::isAbstract() - 检查类是否是抽象类（abstract）
  • Final 关键字


检查类的实例

  • ? ReflectionClass::isFinal
  • ReflectionClass::isInstantiable ?
  • PHP Manual
  • ReflectionClass
  • 检查类的实例

ReflectionClass::isInstance

(PHP 5, PHP 7)

ReflectionClass::isInstance — 检查类的实例

说明

public ReflectionClass::isInstance ( object $object ) : bool

检查对象是否为一个类的实例。

参数

object

待比较的对象。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::isInstance() 相关例子

<?php
// Example usage
$class = new ReflectionClass('Foo');

if ($class->isInstance($arg)) {
    echo "Yes";
}

// Equivalent to
if ($arg instanceof Foo) {
    echo "Yes";
}

// Equivalent to
if (is_a($arg, 'Foo')) {
    echo "Yes";
}
?>

以上例程的输出类似于：

Yes
Yes
Yes

参见

  • ReflectionClass::isInterface() - 检查类是否是一个接口（interface）
  • 类型运算符（instanceof）
  • 对象接口
  • is_a() - 如果对象属于该类或该类是此对象的父类则返回 true


检查类是否可实例化

  • ? ReflectionClass::isInstance
  • ReflectionClass::isInterface ?
  • PHP Manual
  • ReflectionClass
  • 检查类是否可实例化

ReflectionClass::isInstantiable

(PHP 5, PHP 7)

ReflectionClass::isInstantiable — 检查类是否可实例化

说明

public ReflectionClass::isInstantiable ( ) : bool

检查这个类是否可实例化。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::isInstantiable() 例子

<?php
class C { }

interface iface {
    function f1();
}

class ifaceImpl implements iface {
    function f1() {}
}

abstract class abstractClass {
    function f1() { }
    abstract function f2();
}

class D extends abstractClass {
    function f2() { }
}

class privateConstructor {
    private function __construct() { }
}

$classes = array(
    "C",
    "iface",
    "ifaceImpl",
    "abstractClass",
    "D",
    "privateConstructor",
);

foreach($classes  as $class ) {
    $reflectionClass = new ReflectionClass($class);
    echo "Is $class instantiable?  ";
    var_dump($reflectionClass->IsInstantiable());
}

?>

以上例程会输出：

Is C instantiable?  bool(true)
Is iface instantiable?  bool(false)
Is ifaceImpl instantiable?  bool(true)
Is abstractClass instantiable?  bool(false)
Is D instantiable?  bool(true)
Is privateConstructor instantiable?  bool(false)

参见

  • ReflectionClass::isInstance() - 检查类的实例


检查类是否是一个接口（interface）

  • ? ReflectionClass::isInstantiable
  • ReflectionClass::isInternal ?
  • PHP Manual
  • ReflectionClass
  • 检查类是否是一个接口（interface）

ReflectionClass::isInterface

(PHP 5, PHP 7)

ReflectionClass::isInterface — 检查类是否是一个接口（interface）

说明

public ReflectionClass::isInterface ( ) : bool

检查类是否是一个接口（interface）。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::isInterface() 基本用法

<?php
interface SomeInterface {
    public function interfaceMethod();
}

$class = new ReflectionClass('SomeInterface');
var_dump($class->isInterface());
?>

以上例程会输出：

bool(true)

参见

  • ReflectionClass::isInstance() - 检查类的实例


检查类是否由扩展或核心在内部定义

  • ? ReflectionClass::isInterface
  • ReflectionClass::isIterable ?
  • PHP Manual
  • ReflectionClass
  • 检查类是否由扩展或核心在内部定义

ReflectionClass::isInternal

(PHP 5, PHP 7)

ReflectionClass::isInternal — 检查类是否由扩展或核心在内部定义

说明

public ReflectionClass::isInternal ( ) : bool

检查类是否由扩展或核心在内部定义，与用户定义相反。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::isInternal() 的基本用法

<?php
$internalclass = new ReflectionClass('ReflectionClass');

class Apple {}
$userclass = new ReflectionClass('Apple');

var_dump($internalclass->isInternal());
var_dump($userclass->isInternal());
?>

以上例程会输出：

bool(true)
bool(false)

参见

  • ReflectionClass::isUserDefined() - 检查是否由用户定义的


Check whether this class is iterable

  • ? ReflectionClass::isInternal
  • ReflectionClass::isIterateable ?
  • PHP Manual
  • ReflectionClass
  • Check whether this class is iterable

ReflectionClass::isIterable

(PHP 7 >= 7.2.0)

ReflectionClass::isIterable — Check whether this class is iterable

说明

public ReflectionClass::isIterable ( ) : bool

Check whether this class is iterable (i.e. can be used inside foreach).

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Basic ReflectionClass::isIterable() Usage

<?php

class IteratorClass implements Iterator {
    public function __construct() { }
    public function key() { }
    public function current() { }
    function next() { }
    function valid() { }
    function rewind() { }
}
class DerivedClass extends IteratorClass { }
class NonIterator { }

function dump_iterable($class) {
    $reflection = new ReflectionClass($class);
    var_dump($reflection->isIterable());
}

$classes = array("ArrayObject", "IteratorClass", "DerivedClass", "NonIterator");

foreach ($classes as $class) {
    echo "Is $class iterable? ";
    dump_iterable($class);
}
?>

以上例程会输出：

Is ArrayObject iterable? bool(true)
Is IteratorClass iterable? bool(true)
Is DerivedClass iterable? bool(true)
Is NonIterator iterable? bool(false)

参见

  • ReflectionClass::__construct() - 初始化 ReflectionClass 类


检查是否可迭代（iterateable）

  • ? ReflectionClass::isIterable
  • ReflectionClass::isSubclassOf ?
  • PHP Manual
  • ReflectionClass
  • 检查是否可迭代（iterateable）

ReflectionClass::isIterateable

(PHP 5, PHP 7)

ReflectionClass::isIterateable — 检查是否可迭代（iterateable）

说明

public ReflectionClass::isIterateable ( ) : bool

检查一个类是否可迭代（iterateable）。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 ReflectionClass::isIterateable() 例子

<?php

class IteratorClass implements Iterator {
    public function __construct() { }
    public function key() { }
    public function current() { }
    function next() { }
    function valid() { }
    function rewind() { }
}
class DerivedClass extends IteratorClass { }
class NonIterator { }

function dump_iterateable($class) {
    $reflection = new ReflectionClass($class);
    var_dump($reflection->isIterateable());
}

$classes = array("ArrayObject", "IteratorClass", "DerivedClass", "NonIterator");

foreach ($classes as $class) {
    echo "Is $class iterateable? ";
    dump_iterateable($class);
}
?>

以上例程会输出：

Is ArrayObject iterateable? bool(true)
Is IteratorClass iterateable? bool(true)
Is DerivedClass iterateable? bool(true)
Is NonIterator iterateable? bool(false)

参见

  • ReflectionClass::__construct() - 初始化 ReflectionClass 类


检查是否为一个子类

  • ? ReflectionClass::isIterateable
  • ReflectionClass::isTrait ?
  • PHP Manual
  • ReflectionClass
  • 检查是否为一个子类

ReflectionClass::isSubclassOf

(PHP 5, PHP 7)

ReflectionClass::isSubclassOf — 检查是否为一个子类

说明

public ReflectionClass::isSubclassOf ( string $class ) : bool

检查一个类是否为指定类的子类，或者实现了指定的接口。

参数

class

被检查的类名。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ReflectionClass::isInterface() - 检查类是否是一个接口（interface）
  • ReflectionClass::implementsInterface() - 接口的实现
  • is_subclass_of() - 如果此对象是该类的子类，则返回 true
  • get_parent_class() - 返回对象或类的父类名


返回了是否为一个 trait

  • ? ReflectionClass::isSubclassOf
  • ReflectionClass::isUserDefined ?
  • PHP Manual
  • ReflectionClass
  • 返回了是否为一个 trait

ReflectionClass::isTrait

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::isTrait — 返回了是否为一个 trait

说明

public ReflectionClass::isTrait ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

如果是 trait 返回 true，否则返回 false。 在出现错误的情况下，将会返回 null。


检查是否由用户定义的

  • ? ReflectionClass::isTrait
  • ReflectionClass::newInstance ?
  • PHP Manual
  • ReflectionClass
  • 检查是否由用户定义的

ReflectionClass::isUserDefined

(PHP 5, PHP 7)

ReflectionClass::isUserDefined — 检查是否由用户定义的

说明

public ReflectionClass::isUserDefined ( ) : bool

检查一个类是否由用户定义，和内置相对。

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • ReflectionClass::isInternal() - 检查类是否由扩展或核心在内部定义


从指定的参数创建一个新的类实例

  • ? ReflectionClass::isUserDefined
  • ReflectionClass::newInstanceArgs ?
  • PHP Manual
  • ReflectionClass
  • 从指定的参数创建一个新的类实例

ReflectionClass::newInstance

(PHP 5, PHP 7)

ReflectionClass::newInstance — 从指定的参数创建一个新的类实例

说明

public ReflectionClass::newInstance ( mixed $args , mixed $... = ? ) : object

创建类的新的实例。给出的参数将会传递到类的构造函数。

参数

args

接受可变数目的参数，用于传递到类的构造函数，和 call_user_func() 很相似。

返回值

错误／异常

如果类的构造函数不是 public 的将会导致一个 ReflectionException。

当 args 指定了一个或多个参数，而类不具有构造函数时,将导致一个 ReflectionException。

参见

  • ReflectionClass::newInstanceArgs() - 从给出的参数创建一个新的类实例。
  • ReflectionClass::newInstanceWithoutConstructor() - 创建一个新的类实例而不调用它的构造函数


从给出的参数创建一个新的类实例。

  • ? ReflectionClass::newInstance
  • ReflectionClass::newInstanceWithoutConstructor ?
  • PHP Manual
  • ReflectionClass
  • 从给出的参数创建一个新的类实例。

ReflectionClass::newInstanceArgs

(PHP 5 >= 5.1.3, PHP 7)

ReflectionClass::newInstanceArgs — 从给出的参数创建一个新的类实例。

说明

public ReflectionClass::newInstanceArgs ( array $args = ? ) : object

创建一个类的新实例，给出的参数将传递到类的构造函数。

参数

args

这个参数以 array 形式传递到类的构造函数。

返回值

返回类的新实例。

范例

Example #1 ReflectionClass::newInstanceArgs() 的基本用法

<?php
$class = new ReflectionClass('ReflectionFunction');
$instance = $class->newInstanceArgs(array('substr'));
var_dump($instance);
?>

以上例程会输出：

object(ReflectionFunction)#2 (1) {
  ["name"]=>
  string(6) "substr"
}

错误／异常

如果类的构造函数不是 public 的将导致产生一个 ReflectionException。

当 args 指定了一个或多个参数，而类不具有构造函数时,将导致一个 ReflectionException。

参见

  • ReflectionClass::newInstance() - 从指定的参数创建一个新的类实例
  • ReflectionClass::newInstanceWithoutConstructor() - 创建一个新的类实例而不调用它的构造函数


创建一个新的类实例而不调用它的构造函数

  • ? ReflectionClass::newInstanceArgs
  • ReflectionClass::setStaticPropertyValue ?
  • PHP Manual
  • ReflectionClass
  • 创建一个新的类实例而不调用它的构造函数

ReflectionClass::newInstanceWithoutConstructor

(PHP 5 >= 5.4.0, PHP 7)

ReflectionClass::newInstanceWithoutConstructor — 创建一个新的类实例而不调用它的构造函数

说明

public ReflectionClass::newInstanceWithoutConstructor ( ) : object

创建一个新的类的实例而不调用它的构造函数。

参数

返回值

更新日志

版本 | 说明
5.6.0 | All internal classes can now be instantiated except for those declared final.

错误／异常

如果这个类是一个不能不调用构造函数来实例化的内置类，将导致一个 ReflectionException。在 PHP 5.6.0 及更高版本中，此异常仅限于 final 的内置类。

参见

  • ReflectionClass::newInstance() - 从指定的参数创建一个新的类实例
  • ReflectionClass::newInstanceArgs() - 从给出的参数创建一个新的类实例。


设置静态属性的值

  • ? ReflectionClass::newInstanceWithoutConstructor
  • ReflectionClass::__toString ?
  • PHP Manual
  • ReflectionClass
  • 设置静态属性的值

ReflectionClass::setStaticPropertyValue

(PHP 5 >= 5.1.2, PHP 7)

ReflectionClass::setStaticPropertyValue — 设置静态属性的值

说明

public ReflectionClass::setStaticPropertyValue ( string $name , string $value ) : void

设置静态属性的值。

Warning

本函数还未编写文档，仅有参数列表。

参数

name

属性的名称。

value

属性的值。

返回值

没有返回值。

参见

  • ReflectionClass::getStaticPropertyValue() - 获取静态（static）属性的值


返回 ReflectionClass 对象字符串的表示形式。

  • ? ReflectionClass::setStaticPropertyValue
  • ReflectionClassConstant ?
  • PHP Manual
  • ReflectionClass
  • 返回 ReflectionClass 对象字符串的表示形式。

ReflectionClass::__toString

(PHP 5, PHP 7)

ReflectionClass::__toString — 返回 ReflectionClass 对象字符串的表示形式。

说明

public ReflectionClass::__toString ( ) : string

返回 ReflectionClass 对象字符串的表示形式。

参数

此函数没有参数。

返回值

ReflectionClass 实例的一个字符串表示形式。

范例

Example #1 ReflectionClass::__toString() 例子

<?php
$reflectionClass = new ReflectionClass('Exception');
echo $reflectionClass->__toString();
?>

以上例程会输出：

Class [ <internal:Core> class Exception ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [7] {
    Property [ <default> protected $message ]
    Property [ <default> private $string ]
    Property [ <default> protected $code ]
    Property [ <default> protected $file ]
    Property [ <default> protected $line ]
    Property [ <default> private $trace ]
    Property [ <default> private $previous ]
  }

  - Methods [10] {
    Method [ <internal:Core> final private method __clone ] {
    }

    Method [ <internal:Core, ctor> public method __construct ] {

      - Parameters [3] {
        Parameter #0 [ <optional> $message ]
        Parameter #1 [ <optional> $code ]
        Parameter #2 [ <optional> $previous ]
      }
    }

    Method [ <internal:Core> final public method getMessage ] {
    }

    Method [ <internal:Core> final public method getCode ] {
    }

    Method [ <internal:Core> final public method getFile ] {
    }

    Method [ <internal:Core> final public method getLine ] {
    }

    Method [ <internal:Core> final public method getTrace ] {
    }

    Method [ <internal:Core> final public method getPrevious ] {
    }

    Method [ <internal:Core> final public method getTraceAsString ] {
    }

    Method [ <internal:Core> public method __toString ] {
    }
  }
}

参见

  • ReflectionClass::export() - 导出一个类
  • __toString()


The ReflectionClassConstant class

(PHP 7 >= 7.1.0)

简介

The ReflectionClassConstant class reports information about a class constant.

类摘要

ReflectionClassConstant implements Reflector {
/* 常量 */
const int IS_PUBLIC ;
const int IS_PROTECTED ;
const int IS_PRIVATE ;
/* 属性 */
public $name ;
public $class ;
/* 方法 */
public __construct ( object|string $class , string $constant )
public static export ( mixed $class , string $name , bool $return = ? ) : string
public getDeclaringClass ( ) : ReflectionClass
public getDocComment ( ) : string|false
public getModifiers ( ) : int
public getName ( ) : string|false
public getValue ( ) : mixed
public isPrivate ( ) : bool
public isProtected ( ) : bool
public isPublic ( ) : bool
public __toString ( ) : string
}

属性

name

Name of the class constant. Read-only, throws ReflectionException in attempt to write.

class

Name of the class where the class constant is defined. Read-only, throws ReflectionException in attempt to write.

预定义常量

ReflectionClassConstant Modifiers

ReflectionClassConstant::IS_PUBLIC

Indicates public constants.

ReflectionClassConstant::IS_PROTECTED

Indicates protected constants.

ReflectionClassConstant::IS_PRIVATE

Indicates private constants.

Table of Contents

  • ReflectionClassConstant::__construct — Constructs a ReflectionClassConstant
  • ReflectionClassConstant::export — Export
  • ReflectionClassConstant::getDeclaringClass — Gets declaring class
  • ReflectionClassConstant::getDocComment — Gets doc comments
  • ReflectionClassConstant::getModifiers — Gets the class constant modifiers
  • ReflectionClassConstant::getName — Get name of the constant
  • ReflectionClassConstant::getValue — Gets value
  • ReflectionClassConstant::isPrivate — Checks if class constant is private
  • ReflectionClassConstant::isProtected — Checks if class constant is protected
  • ReflectionClassConstant::isPublic — Checks if class constant is public
  • ReflectionClassConstant::__toString — Returns the string representation of the ReflectionClassConstant object


Constructs a ReflectionClassConstant

  • ? ReflectionClassConstant
  • ReflectionClassConstant::export ?
  • PHP Manual
  • ReflectionClassConstant
  • Constructs a ReflectionClassConstant

ReflectionClassConstant::__construct

(PHP 7 >= 7.1.0)

ReflectionClassConstant::__construct — Constructs a ReflectionClassConstant

说明

public ReflectionClassConstant::__construct ( object|string $class , string $constant )

Constructs a new ReflectionClassConstant object.

参数

class

Either a string containing the name of the class to reflect, or an object.

constant

The name of the class constant.

返回值

Returns constructed ReflectionClassConstant instance.

错误／异常

Throws an Exception in case the given class constant does not exist.

参见

  • Constructors


Export

  • ? ReflectionClassConstant::__construct
  • ReflectionClassConstant::getDeclaringClass ?
  • PHP Manual
  • ReflectionClassConstant
  • Export

ReflectionClassConstant::export

(PHP 7 >= 7.1.0)

ReflectionClassConstant::export — Export

Warning

本函数已自 PHP 7.4.0 起废弃。强烈建议不要使用本函数。

说明

public static ReflectionClassConstant::export ( mixed $class , string $name , bool $return = ? ) : string

Exports a reflection.

Warning

本函数还未编写文档，仅有参数列表。

参数

class

导出的反射。

name

The class constant name.

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

参见

  • ReflectionClassConstant::__toString() - Returns the string representation of the ReflectionClassConstant object


Gets declaring class

  • ? ReflectionClassConstant::export
  • ReflectionClassConstant::getDocComment ?
  • PHP Manual
  • ReflectionClassConstant
  • Gets declaring class

ReflectionClassConstant::getDeclaringClass

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getDeclaringClass — Gets declaring class

说明

public ReflectionClassConstant::getDeclaringClass ( ) : ReflectionClass

Gets the declaring class.

参数

此函数没有参数。

返回值

A ReflectionClass object.


Gets doc comments

  • ? ReflectionClassConstant::getDeclaringClass
  • ReflectionClassConstant::getModifiers ?
  • PHP Manual
  • ReflectionClassConstant
  • Gets doc comments

ReflectionClassConstant::getDocComment

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getDocComment — Gets doc comments

说明

public ReflectionClassConstant::getDocComment ( ) : string|false

Gets doc comments from a class constant.

参数

此函数没有参数。

返回值

The doc comment if it exists, otherwise false


Gets the class constant modifiers

  • ? ReflectionClassConstant::getDocComment
  • ReflectionClassConstant::getName ?
  • PHP Manual
  • ReflectionClassConstant
  • Gets the class constant modifiers

ReflectionClassConstant::getModifiers

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getModifiers — Gets the class constant modifiers

说明

public ReflectionClassConstant::getModifiers ( ) : int

Returns a bitfield of the access modifiers for this class constant.

参数

此函数没有参数。

返回值

A numeric representation of the modifiers. The actual meanings of these modifiers are described in the predefined constants.

参见

  • Reflection::getModifierNames() - 获取修饰符的名称


Get name of the constant

  • ? ReflectionClassConstant::getModifiers
  • ReflectionClassConstant::getValue ?
  • PHP Manual
  • ReflectionClassConstant
  • Get name of the constant

ReflectionClassConstant::getName

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getName — Get name of the constant

说明

public ReflectionClassConstant::getName ( ) : string|false

参数

此函数没有参数。

返回值

Returns the constant's name, 或者在失败时返回 false.


Gets value

  • ? ReflectionClassConstant::getName
  • ReflectionClassConstant::isPrivate ?
  • PHP Manual
  • ReflectionClassConstant
  • Gets value

ReflectionClassConstant::getValue

(PHP 7 >= 7.1.0)

ReflectionClassConstant::getValue — Gets value

说明

public ReflectionClassConstant::getValue ( ) : mixed

Gets the class constant's value.

参数

此函数没有参数。

返回值

The value of the class constant.


Checks if class constant is private

  • ? ReflectionClassConstant::getValue
  • ReflectionClassConstant::isProtected ?
  • PHP Manual
  • ReflectionClassConstant
  • Checks if class constant is private

ReflectionClassConstant::isPrivate

(PHP 7 >= 7.1.0)

ReflectionClassConstant::isPrivate — Checks if class constant is private

说明

public ReflectionClassConstant::isPrivate ( ) : bool

Checks if the class constant is private.

参数

此函数没有参数。

返回值

true if the class constant is private, otherwise false

参见

  • ReflectionClassConstant::isPublic() - Checks if class constant is public
  • ReflectionClassConstant::isProtected() - Checks if class constant is protected


Checks if class constant is protected

  • ? ReflectionClassConstant::isPrivate
  • ReflectionClassConstant::isPublic ?
  • PHP Manual
  • ReflectionClassConstant
  • Checks if class constant is protected

ReflectionClassConstant::isProtected

(PHP 7 >= 7.1.0)

ReflectionClassConstant::isProtected — Checks if class constant is protected

说明

public ReflectionClassConstant::isProtected ( ) : bool

Checks if the class constant is protected.

参数

此函数没有参数。

返回值

true if the class constant is protected, otherwise false

参见

  • ReflectionClassConstant::isPublic() - Checks if class constant is public
  • ReflectionClassConstant::isPrivate() - Checks if class constant is private


Checks if class constant is public

  • ? ReflectionClassConstant::isProtected
  • ReflectionClassConstant::__toString ?
  • PHP Manual
  • ReflectionClassConstant
  • Checks if class constant is public

ReflectionClassConstant::isPublic

(PHP 7 >= 7.1.0)

ReflectionClassConstant::isPublic — Checks if class constant is public

说明

public ReflectionClassConstant::isPublic ( ) : bool

Checks if the class constant is public.

参数

此函数没有参数。

返回值

true if the class constant is public, otherwise false

参见

  • ReflectionClassConstant::isPrivate() - Checks if class constant is private
  • ReflectionClassConstant::isProtected() - Checks if class constant is protected


Returns the string representation of the ReflectionClassConstant object

  • ? ReflectionClassConstant::isPublic
  • ReflectionZendExtension ?
  • PHP Manual
  • ReflectionClassConstant
  • Returns the string representation of the ReflectionClassConstant object

ReflectionClassConstant::__toString

(PHP 7 >= 7.1.0)

ReflectionClassConstant::__toString — Returns the string representation of the ReflectionClassConstant object

说明

public ReflectionClassConstant::__toString ( ) : string

Returns the string representation of the ReflectionClassConstant object.

参数

此函数没有参数。

返回值

A string representation of this ReflectionClassConstant instance.

参见

  • ReflectionClassConstant::export() - Export
  • __toString()


ReflectionZendExtension 类

(PHP 5 >= 5.4.0, PHP 7)

简介

类摘要

ReflectionZendExtension implements Reflector {
/* 属性 */
public $name ;
/* 方法 */
final private __clone ( ) : void
public static export ( string $name , bool $return = ? ) : string
public getAuthor ( ) : string
public getCopyright ( ) : string
public getName ( ) : string
public getURL ( ) : string
public getVersion ( ) : string
public __toString ( ) : string
}

属性

name

扩展的名称。只读，并在尝试赋值的时候抛出 ReflectionException。

Table of Contents

  • ReflectionZendExtension::__clone — Clone handler
  • ReflectionZendExtension::__construct — Constructor
  • ReflectionZendExtension::export — Export
  • ReflectionZendExtension::getAuthor — Gets author
  • ReflectionZendExtension::getCopyright — Gets copyright
  • ReflectionZendExtension::getName — Gets name
  • ReflectionZendExtension::getURL — Gets URL
  • ReflectionZendExtension::getVersion — Gets version
  • ReflectionZendExtension::__toString — To string handler


Clone handler

  • ? ReflectionZendExtension
  • ReflectionZendExtension::__construct ?
  • PHP Manual
  • ReflectionZendExtension
  • Clone handler

ReflectionZendExtension::__clone

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::__clone — Clone handler

说明

final private ReflectionZendExtension::__clone ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Constructor

  • ? ReflectionZendExtension::__clone
  • ReflectionZendExtension::export ?
  • PHP Manual
  • ReflectionZendExtension
  • Constructor

ReflectionZendExtension::__construct

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::__construct — Constructor

说明

public ReflectionZendExtension::__construct ( string $name )

Warning

本函数还未编写文档，仅有参数列表。

参数

name

返回值


Export

  • ? ReflectionZendExtension::__construct
  • ReflectionZendExtension::getAuthor ?
  • PHP Manual
  • ReflectionZendExtension
  • Export

ReflectionZendExtension::export

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::export — Export

Warning

本函数已自 PHP 7.4.0 起废弃。强烈建议不要使用本函数。

说明

public static ReflectionZendExtension::export ( string $name , bool $return = ? ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

name

return

返回值

参见

  • ReflectionClassConstant::__toString() - Returns the string representation of the ReflectionClassConstant object


Gets author

  • ? ReflectionZendExtension::export
  • ReflectionZendExtension::getCopyright ?
  • PHP Manual
  • ReflectionZendExtension
  • Gets author

ReflectionZendExtension::getAuthor

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getAuthor — Gets author

说明

public ReflectionZendExtension::getAuthor ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Gets copyright

  • ? ReflectionZendExtension::getAuthor
  • ReflectionZendExtension::getName ?
  • PHP Manual
  • ReflectionZendExtension
  • Gets copyright

ReflectionZendExtension::getCopyright

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getCopyright — Gets copyright

说明

public ReflectionZendExtension::getCopyright ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Gets name

  • ? ReflectionZendExtension::getCopyright
  • ReflectionZendExtension::getURL ?
  • PHP Manual
  • ReflectionZendExtension
  • Gets name

ReflectionZendExtension::getName

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getName — Gets name

说明

public ReflectionZendExtension::getName ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Gets URL

  • ? ReflectionZendExtension::getName
  • ReflectionZendExtension::getVersion ?
  • PHP Manual
  • ReflectionZendExtension
  • Gets URL

ReflectionZendExtension::getURL

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getURL — Gets URL

说明

public ReflectionZendExtension::getURL ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Gets version

  • ? ReflectionZendExtension::getURL
  • ReflectionZendExtension::__toString ?
  • PHP Manual
  • ReflectionZendExtension
  • Gets version

ReflectionZendExtension::getVersion

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::getVersion — Gets version

说明

public ReflectionZendExtension::getVersion ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


To string handler

  • ? ReflectionZendExtension::getVersion
  • ReflectionExtension ?
  • PHP Manual
  • ReflectionZendExtension
  • To string handler

ReflectionZendExtension::__toString

(PHP 5 >= 5.4.0, PHP 7)

ReflectionZendExtension::__toString — To string handler

说明

public ReflectionZendExtension::__toString ( ) : string

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


ReflectionExtension 类

(PHP 5, PHP 7)

简介

ReflectionExtension 报告了一个扩展（extension）的有关信息。

类摘要

ReflectionExtension implements Reflector {
/* 属性 */
public $name ;
/* 方法 */
final private __clone ( ) : void
public __construct ( string $name )
public static export ( string $name , string $return = false ) : string
public getClasses ( ) : array
public getClassNames ( ) : array
public getConstants ( ) : array
public getDependencies ( ) : array
public getFunctions ( ) : array
public getINIEntries ( ) : array
public getName ( ) : string
public getVersion ( ) : string
public info ( ) : void
public isPersistent ( ) : void
public isTemporary ( ) : void
public __toString ( ) : string
}

属性

name

扩展的名称，和 ReflectionExtension::getName() 方法所返回的一样。

Table of Contents

  • ReflectionExtension::__clone — Clones
  • ReflectionExtension::__construct — Constructs a ReflectionExtension
  • ReflectionExtension::export — Export
  • ReflectionExtension::getClasses — Gets classes
  • ReflectionExtension::getClassNames — 获取类名称
  • ReflectionExtension::getConstants — 获取常量
  • ReflectionExtension::getDependencies — 获取依赖
  • ReflectionExtension::getFunctions — 获取扩展中的函数
  • ReflectionExtension::getINIEntries — 获取ini配置
  • ReflectionExtension::getName — 获取扩展名称
  • ReflectionExtension::getVersion — 获取扩展版本号
  • ReflectionExtension::info — 输出扩展信息
  • ReflectionExtension::isPersistent — 返回扩展是否持久化载入
  • ReflectionExtension::isTemporary — 返回扩展是否是临时载入
  • ReflectionExtension::__toString — To string


Clones

  • ? ReflectionExtension
  • ReflectionExtension::__construct ?
  • PHP Manual
  • ReflectionExtension
  • Clones

ReflectionExtension::__clone

(PHP 5, PHP 7)

ReflectionExtension::__clone — Clones

说明

final private ReflectionExtension::__clone ( ) : void

clone方法阻止实例克隆。反射类实例不允许被克隆。

参数

此函数没有参数。

返回值

没有返回值，如果被调用将产生fatal错误。

参见

  • ReflectionExtension::__construct() - Constructs a ReflectionExtension
  • Object cloning


Constructs a ReflectionExtension

  • ? ReflectionExtension::__clone
  • ReflectionExtension::export ?
  • PHP Manual
  • ReflectionExtension
  • Constructs a ReflectionExtension

ReflectionExtension::__construct

(PHP 5, PHP 7)

ReflectionExtension::__construct — Constructs a ReflectionExtension

说明

public ReflectionExtension::__construct ( string $name )

Construct a ReflectionExtension object.

参数

name

扩展的名称。

返回值

A ReflectionExtension object.

范例

Example #1 ReflectionExtension example

<?php
$ext = new ReflectionExtension('Reflection');

printf('Extension: %s (version: %s)', $ext->getName(), $ext->getVersion());
?>

以上例程的输出类似于：

Extension: Reflection (version: $Revision$)

参见

  • ReflectionExtension::info() - 输出扩展信息
  • Constructors


Export

  • ? ReflectionExtension::__construct
  • ReflectionExtension::getClasses ?
  • PHP Manual
  • ReflectionExtension
  • Export

ReflectionExtension::export

(PHP 5, PHP 7)

ReflectionExtension::export — Export

说明

public static ReflectionExtension::export ( string $name , string $return = false ) : string

导出可以被反射的扩展。输出格式同CLI argument --re [extension].

参数

name

导出的反射。

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

如果参数 return 设为 true，导出结果将作为 string 返回，否则返回 null。

参见

  • ReflectionExtension::info() - 输出扩展信息


Gets classes

  • ? ReflectionExtension::export
  • ReflectionExtension::getClassNames ?
  • PHP Manual
  • ReflectionExtension
  • Gets classes

ReflectionExtension::getClasses

(PHP 5, PHP 7)

ReflectionExtension::getClasses — Gets classes

说明

public ReflectionExtension::getClasses ( ) : array

从扩展中获取类列表。

参数

此函数没有参数。

返回值

返回一个ReflectionClass对象数组，包括扩展中所有类。如果扩展中没有类声明，将返回空数组。

范例

Example #1 ReflectionExtension::getClasses() example

<?php
$ext = new ReflectionExtension('XMLWriter');
var_dump($ext->getClasses());
?>

以上例程的输出类似于：

array(1) {
  ["XMLWriter"]=>
  &object(ReflectionClass)#2 (1) {
    ["name"]=>
    string(9) "XMLWriter"
  }
}

参见

  • ReflectionExtension::getClassNames() - 获取类名称


获取类名称

  • ? ReflectionExtension::getClasses
  • ReflectionExtension::getConstants ?
  • PHP Manual
  • ReflectionExtension
  • 获取类名称

ReflectionExtension::getClassNames

(PHP 5, PHP 7)

ReflectionExtension::getClassNames — 获取类名称

说明

public ReflectionExtension::getClassNames ( ) : array

获取扩展中的类名称列表。

参数

此函数没有参数。

返回值

返回类名称数组。如果扩展中没有类声明，将返回空数组。

范例

Example #1 ReflectionExtension::getClassNames() example

<?php
$ext = new ReflectionExtension('XMLWriter');
var_dump($ext->getClassNames());
?>

以上例程的输出类似于：

array(1) {
  [0]=>
  string(9) "XMLWriter"
}

参见

  • ReflectionExtension::getClasses() - Gets classes
  • ReflectionExtension::getName() - 获取扩展名称


获取常量

  • ? ReflectionExtension::getClassNames
  • ReflectionExtension::getDependencies ?
  • PHP Manual
  • ReflectionExtension
  • 获取常量

ReflectionExtension::getConstants

(PHP 5, PHP 7)

ReflectionExtension::getConstants — 获取常量

说明

public ReflectionExtension::getConstants ( ) : array

获取扩展中定义的常量。

参数

此函数没有参数。

返回值

返回一个以常量名称为索引的数组。

范例

Example #1 ReflectionExtension::getConstants() example

<?php
$ext = new ReflectionExtension('DOM');

print_r($ext->getConstants());
?>

以上例程的输出类似于：

Array
(
    [XML_ELEMENT_NODE] => 1
    [XML_ATTRIBUTE_NODE] => 2
    [XML_TEXT_NODE] => 3
    [XML_CDATA_SECTION_NODE] => 4
    [XML_ENTITY_REF_NODE] => 5
    [XML_ENTITY_NODE] => 6
    [XML_PI_NODE] => 7
    [XML_COMMENT_NODE] => 8
    [XML_DOCUMENT_NODE] => 9
    [XML_DOCUMENT_TYPE_NODE] => 10
    [XML_DOCUMENT_FRAG_NODE] => 11
    [XML_NOTATION_NODE] => 12
    [XML_HTML_DOCUMENT_NODE] => 13
    [XML_DTD_NODE] => 14
    [XML_ELEMENT_DECL_NODE] => 15
    [XML_ATTRIBUTE_DECL_NODE] => 16
    [XML_ENTITY_DECL_NODE] => 17
    [XML_NAMESPACE_DECL_NODE] => 18
    [XML_LOCAL_NAMESPACE] => 18
    [XML_ATTRIBUTE_CDATA] => 1
    [XML_ATTRIBUTE_ID] => 2
    [XML_ATTRIBUTE_IDREF] => 3
    [XML_ATTRIBUTE_IDREFS] => 4
    [XML_ATTRIBUTE_ENTITY] => 6
    [XML_ATTRIBUTE_NMTOKEN] => 7
    [XML_ATTRIBUTE_NMTOKENS] => 8
    [XML_ATTRIBUTE_ENUMERATION] => 9
    [XML_ATTRIBUTE_NOTATION] => 10
    [DOM_PHP_ERR] => 0
    [DOM_INDEX_SIZE_ERR] => 1
    [DOMSTRING_SIZE_ERR] => 2
    [DOM_HIERARCHY_REQUEST_ERR] => 3
    [DOM_WRONG_DOCUMENT_ERR] => 4
    [DOM_INVALID_CHARACTER_ERR] => 5
    [DOM_NO_DATA_ALLOWED_ERR] => 6
    [DOM_NO_MODIFICATION_ALLOWED_ERR] => 7
    [DOM_NOT_FOUND_ERR] => 8
    [DOM_NOT_SUPPORTED_ERR] => 9
    [DOM_INUSE_ATTRIBUTE_ERR] => 10
    [DOM_INVALID_STATE_ERR] => 11
    [DOM_SYNTAX_ERR] => 12
    [DOM_INVALID_MODIFICATION_ERR] => 13
    [DOM_NAMESPACE_ERR] => 14
    [DOM_INVALID_ACCESS_ERR] => 15
    [DOM_VALIDATION_ERR] => 16
)

参见

  • ReflectionExtension::getINIEntries() - 获取ini配置


获取依赖

  • ? ReflectionExtension::getConstants
  • ReflectionExtension::getFunctions ?
  • PHP Manual
  • ReflectionExtension
  • 获取依赖

ReflectionExtension::getDependencies

(PHP 5 >= 5.1.3, PHP 7)

ReflectionExtension::getDependencies — 获取依赖

说明

public ReflectionExtension::getDependencies ( ) : array

获取依赖，包括必需的、冲突的、可选的。 Gets dependencies, by listing both required and conflicting dependencies.

参数

此函数没有参数。

返回值

返回一个以依赖的扩展名称为索引的数组，每一项的取值为 Required、Optional 或者 Conflicts。

范例

Example #1 ReflectionExtension::getDependencies() example

<?php
$dom = new ReflectionExtension('dom');

print_r($dom->getDependencies());
?>

以上例程的输出类似于：

Array
(
    [libxml] => Required
    [domxml] => Conflicts
)

参见

  • ReflectionClass::getVersion()


获取扩展中的函数

  • ? ReflectionExtension::getDependencies
  • ReflectionExtension::getINIEntries ?
  • PHP Manual
  • ReflectionExtension
  • 获取扩展中的函数

ReflectionExtension::getFunctions

(PHP 5, PHP 7)

ReflectionExtension::getFunctions — 获取扩展中的函数

说明

public ReflectionExtension::getFunctions ( ) : array

获取扩展中定义的函数。

参数

此函数没有参数。

返回值

返回一个ReflectionFunction对象数组，数组索引为函数名。如果扩展中没有定义函数，将返回空数组。

范例

Example #1 ReflectionExtension::getFunctions() example

<?php
$dom = new ReflectionExtension('SimpleXML');

print_r($dom->getFunctions());
?>

以上例程的输出类似于：

Array
(
    [simplexml_load_file] => ReflectionFunction Object
        (
            [name] => simplexml_load_file
        )

    [simplexml_load_string] => ReflectionFunction Object
        (
            [name] => simplexml_load_string
        )

    [simplexml_import_dom] => ReflectionFunction Object
        (
            [name] => simplexml_import_dom
        )

)

参见

  • ReflectionExtension::getClasses() - Gets classes
  • get_extension_funcs() - 返回模块函数名称的数组


获取ini配置

  • ? ReflectionExtension::getFunctions
  • ReflectionExtension::getName ?
  • PHP Manual
  • ReflectionExtension
  • 获取ini配置

ReflectionExtension::getINIEntries

(PHP 5, PHP 7)

ReflectionExtension::getINIEntries — 获取ini配置

说明

public ReflectionExtension::getINIEntries ( ) : array

获取扩展在ini配置文件中的配置。

参数

此函数没有参数。

返回值

返回一个数组，数组索引是配置名称，值是配置值。

范例

Example #1 ReflectionExtension::getINIEntries() example

<?php
$ext = new ReflectionExtension('mysql');

print_r($ext->getINIEntries());
?>

以上例程的输出类似于：

Array
(
    [mysql.allow_persistent] => 1
    [mysql.max_persistent] => -1
    [mysql.max_links] => -1
    [mysql.default_host] =>
    [mysql.default_user] =>
    [mysql.default_password] =>
    [mysql.default_port] =>
    [mysql.default_socket] =>
    [mysql.connect_timeout] => 60
    [mysql.trace_mode] =>
    [mysql.allow_local_infile] => 1
    [mysql.cache_size] => 2000
)

参见

  • ini_get_all() - 获取所有配置选项
  • ReflectionExtension::getConstants() - 获取常量


获取扩展名称

  • ? ReflectionExtension::getINIEntries
  • ReflectionExtension::getVersion ?
  • PHP Manual
  • ReflectionExtension
  • 获取扩展名称

ReflectionExtension::getName

(PHP 5, PHP 7)

ReflectionExtension::getName — 获取扩展名称

说明

public ReflectionExtension::getName ( ) : string

获取扩展名称。

参数

此函数没有参数。

返回值

扩展名称。

范例

Example #1 ReflectionExtension::getName() example

<?php
$ext = new ReflectionExtension('mysqli');
var_dump($ext->getName());
?>

以上例程的输出类似于：

string(6) "mysqli"

参见

  • ReflectionExtension::getClassNames() - 获取类名称


获取扩展版本号

  • ? ReflectionExtension::getName
  • ReflectionExtension::info ?
  • PHP Manual
  • ReflectionExtension
  • 获取扩展版本号

ReflectionExtension::getVersion

(PHP 5, PHP 7)

ReflectionExtension::getVersion — 获取扩展版本号

说明

public ReflectionExtension::getVersion ( ) : string

获取扩展的版本号。

参数

此函数没有参数。

返回值

扩展的版本号。

范例

Example #1 ReflectionExtension::getVersion() example

<?php
$ext = new ReflectionExtension('mysqli');
var_dump($ext->getVersion());
?>

以上例程的输出类似于：

string(3) "0.1"

参见

  • ReflectionExtension::info() - 输出扩展信息


输出扩展信息

  • ? ReflectionExtension::getVersion
  • ReflectionExtension::isPersistent ?
  • PHP Manual
  • ReflectionExtension
  • 输出扩展信息

ReflectionExtension::info

(PHP 5 >= 5.2.4, PHP 7)

ReflectionExtension::info — 输出扩展信息

说明

public ReflectionExtension::info ( ) : void

输出"phpinfo()"信息中的扩展信息。

参数

此函数没有参数。

返回值

扩展信息。

范例

Example #1 ReflectionExtension::info() example

<?php
$ext = new ReflectionExtension('mysqli');
$ext->info();
?>

以上例程的输出类似于：

mysqli

MysqlI Support => enabled
Client API library version => mysqlnd 5.0.5-dev - 081106 - $Revision$
Active Persistent Links => 0
Inactive Persistent Links => 0
Active Links => 0
Persistent cache => enabled
put_hits => 0
put_misses => 0
get_hits => 0
get_misses => 0
size => 2000
free_items => 2000
references => 2

Directive => Local Value => Master Value
mysqli.max_links => Unlimited => Unlimited
mysqli.max_persistent => Unlimited => Unlimited
mysqli.allow_persistent => On => On
mysqli.default_host => no value => no value
mysqli.default_user => no value => no value
mysqli.default_pw => no value => no value
mysqli.default_port => 3306 => 3306
mysqli.default_socket => no value => no value
mysqli.reconnect => Off => Off
mysqli.allow_local_infile => On => On
mysqli.cache_size => 2000 => 2000

参见

  • ReflectionExtension::getName() - 获取扩展名称
  • phpinfo() - 输出关于 PHP 配置的信息


返回扩展是否持久化载入

  • ? ReflectionExtension::info
  • ReflectionExtension::isTemporary ?
  • PHP Manual
  • ReflectionExtension
  • 返回扩展是否持久化载入

ReflectionExtension::isPersistent

(PHP 5 >= 5.4.0, PHP 7)

ReflectionExtension::isPersistent — 返回扩展是否持久化载入

说明

public ReflectionExtension::isPersistent ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

扩展在extension配置中被载入返回true ，否则返回 false。

参见

  • ReflectionExtension::isTemporary() - 返回扩展是否是临时载入


返回扩展是否是临时载入

  • ? ReflectionExtension::isPersistent
  • ReflectionExtension::__toString ?
  • PHP Manual
  • ReflectionExtension
  • 返回扩展是否是临时载入

ReflectionExtension::isTemporary

(PHP 5 >= 5.4.0, PHP 7)

ReflectionExtension::isTemporary — 返回扩展是否是临时载入

说明

public ReflectionExtension::isTemporary ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

如果扩展被dl()载入则返回true ，否则返回 false 。

参见

  • ReflectionExtension::isPersistent() - 返回扩展是否持久化载入


To string

  • ? ReflectionExtension::isTemporary
  • ReflectionFunction ?
  • PHP Manual
  • ReflectionExtension
  • To string

ReflectionExtension::__toString

(PHP 5, PHP 7)

ReflectionExtension::__toString — To string

说明

public ReflectionExtension::__toString ( ) : string

以string形式返回扩展的反射信息。同ReflectionExtension::export()return参数设置为true。

参数

此函数没有参数。

返回值

返回扩展的反射信息，同ReflectionExtension::export()。

参见

  • ReflectionExtension::__construct() - Constructs a ReflectionExtension
  • ReflectionExtension::export() - Export
  • __toString()


ReflectionFunction 类

(PHP 5, PHP 7)

简介

ReflectionFunction 类报告了一个函数的有关信息。

类摘要

ReflectionFunction extends ReflectionFunctionAbstract implements Reflector {
/* 常量 */
const integer IS_DEPRECATED = 262144 ;
/* 属性 */
public $name ;
/* 方法 */
public static export ( string $name , string $return = ? ) : string
public getClosure ( ) : Closure
public invoke ( mixed ...$args ) : mixed
public invokeArgs ( array $args ) : mixed
public isDisabled ( ) : bool
public __toString ( ) : string
/* 继承的方法 */
final private ReflectionFunctionAbstract::__clone ( ) : void
public ReflectionFunctionAbstract::getClosureScopeClass ( ) : ReflectionClass|null
public ReflectionFunctionAbstract::getClosureThis ( ) : object
public ReflectionFunctionAbstract::getDocComment ( ) : string
public ReflectionFunctionAbstract::getEndLine ( ) : int
public ReflectionFunctionAbstract::getExtension ( ) : ReflectionExtension
public ReflectionFunctionAbstract::getExtensionName ( ) : string
public ReflectionFunctionAbstract::getFileName ( ) : string
public ReflectionFunctionAbstract::getName ( ) : string
public ReflectionFunctionAbstract::getNamespaceName ( ) : string
public ReflectionFunctionAbstract::getNumberOfParameters ( ) : int
public ReflectionFunctionAbstract::getNumberOfRequiredParameters ( ) : int
public ReflectionFunctionAbstract::getParameters ( ) : array
public ReflectionFunctionAbstract::getReturnType ( ) : ReflectionType|null
public ReflectionFunctionAbstract::getShortName ( ) : string
public ReflectionFunctionAbstract::getStartLine ( ) : int
public ReflectionFunctionAbstract::getStaticVariables ( ) : array
public ReflectionFunctionAbstract::hasReturnType ( ) : bool
public ReflectionFunctionAbstract::inNamespace ( ) : bool
public ReflectionFunctionAbstract::isClosure ( ) : bool
public ReflectionFunctionAbstract::isDeprecated ( ) : bool
public ReflectionFunctionAbstract::isGenerator ( ) : bool
public ReflectionFunctionAbstract::isInternal ( ) : bool
public ReflectionFunctionAbstract::isUserDefined ( ) : bool
public ReflectionFunctionAbstract::isVariadic ( ) : bool
public ReflectionFunctionAbstract::returnsReference ( ) : bool
abstract public ReflectionFunctionAbstract::__toString ( ) : void
}

属性

name

函数的名称。只读，并在尝试赋值的时候会抛出 ReflectionException。

预定义常量

ReflectionFunction 修饰符

ReflectionFunction::IS_DEPRECATED

指示了不建议使用的函数。

Table of Contents

  • ReflectionFunction::__construct — Constructs a ReflectionFunction object
  • ReflectionFunction::export — Exports function
  • ReflectionFunction::getClosure — Returns a dynamically created closure for the function
  • ReflectionFunction::invoke — Invokes function
  • ReflectionFunction::invokeArgs — Invokes function args
  • ReflectionFunction::isDisabled — Checks if function is disabled
  • ReflectionFunction::__toString — To string


Constructs a ReflectionFunction object

  • ? ReflectionFunction
  • ReflectionFunction::export ?
  • PHP Manual
  • ReflectionFunction
  • Constructs a ReflectionFunction object

ReflectionFunction::__construct

(PHP 5, PHP 7)

ReflectionFunction::__construct — Constructs a ReflectionFunction object

说明

public ReflectionFunction::__construct ( Closure|string $function )

Constructs a ReflectionFunction object.

参数

function

The name of the function to reflect or a closure.

返回值

没有返回值。

错误／异常

A ReflectionException if the function parameter does not contain a valid function.

范例

Example #1 ReflectionFunction::__construct() example

<?php
/**
 * A simple counter
 *
 * @return    int
 */
function counter1()
{
    static $c = 0;
    return ++$c;
}

/**
 * Another simple counter
 *
 * @return    int
 */
$counter2 = function()
{
    static $d = 0;
    return ++$d;

};

function dumpReflectionFunction($func)
{
    // Print out basic information
    printf(
        "\n\n===> The %s function '%s'\n".
        "     declared in %s\n".
        "     lines %d to %d\n",
        $func->isInternal() ? 'internal' : 'user-defined',
        $func->getName(),
        $func->getFileName(),
        $func->getStartLine(),
        $func->getEndline()
    );

    // Print documentation comment
    printf("---> Documentation:\n %s\n", var_export($func->getDocComment(), 1));

    // Print static variables if existant
    if ($statics = $func->getStaticVariables())
    {
        printf("---> Static variables: %s\n", var_export($statics, 1));
    }
}

// Create an instance of the ReflectionFunction class
dumpReflectionFunction(new ReflectionFunction('counter1'));
dumpReflectionFunction(new ReflectionFunction($counter2));
?>

以上例程的输出类似于：

===> The user-defined function 'counter1'
     declared in Z:\reflectcounter.php
     lines 7 to 11
---> Documentation:
 '/**
 * A simple counter
 *
 * @return    int
 */'
---> Static variables: array (
  'c' => 0,
)

===> The user-defined function '{closure}'
     declared in Z:\reflectcounter.php
     lines 18 to 23
---> Documentation:
 '/**
 * Another simple counter
 *
 * @return    int
 */'
---> Static variables: array (
  'd' => 0,
)

参见

  • ReflectionMethod::__construct() - ReflectionMethod 的构造函数
  • Constructors


Exports function

  • ? ReflectionFunction::__construct
  • ReflectionFunction::getClosure ?
  • PHP Manual
  • ReflectionFunction
  • Exports function

ReflectionFunction::export

(PHP 5, PHP 7)

ReflectionFunction::export — Exports function

Warning

本函数已自 PHP 7.4.0 起废弃。强烈建议不要使用本函数。

说明

public static ReflectionFunction::export ( string $name , string $return = ? ) : string

Exports a Reflected function.

参数

name

导出的反射。

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

如果参数 return 设为 true，导出结果将作为 string 返回，否则返回 null。

参见

  • ReflectionFunction::invoke() - Invokes function
  • ReflectionFunction::__toString() - To string


Returns a dynamically created closure for the function

  • ? ReflectionFunction::export
  • ReflectionFunction::invoke ?
  • PHP Manual
  • ReflectionFunction
  • Returns a dynamically created closure for the function

ReflectionFunction::getClosure

(PHP 5 >= 5.4.0, PHP 7)

ReflectionFunction::getClosure — Returns a dynamically created closure for the function

说明

public ReflectionFunction::getClosure ( ) : Closure

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns Closure. Returns null in case of an error.


Invokes function

  • ? ReflectionFunction::getClosure
  • ReflectionFunction::invokeArgs ?
  • PHP Manual
  • ReflectionFunction
  • Invokes function

ReflectionFunction::invoke

(PHP 5, PHP 7)

ReflectionFunction::invoke — Invokes function

说明

public ReflectionFunction::invoke ( mixed ...$args ) : mixed

Invokes a reflected function.

参数

args

The passed in argument list. It accepts a variable number of arguments which are passed to the function much like call_user_func() is.

返回值

Returns the result of the invoked function call.

范例

Example #1 ReflectionFunction::invoke() example

<?php
function title($title, $name)
{
    return sprintf("%s. %s\r\n", $title, $name);
}

$function = new ReflectionFunction('title');

echo $function->invoke('Dr', 'Phil');
?>

以上例程会输出：

Dr. Phil

注释

Note:

如果函数有参数需为引用，那么它们必须以引用方式传入。

参见

  • ReflectionFunction::export() - Exports function
  • __invoke()
  • call_user_func() - 把第一个参数作为回调函数调用


Invokes function args

  • ? ReflectionFunction::invoke
  • ReflectionFunction::isDisabled ?
  • PHP Manual
  • ReflectionFunction
  • Invokes function args

ReflectionFunction::invokeArgs

(PHP 5 >= 5.1.2, PHP 7)

ReflectionFunction::invokeArgs — Invokes function args

说明

public ReflectionFunction::invokeArgs ( array $args ) : mixed

Invokes the function and pass its arguments as array.

参数

args

The passed arguments to the function as an array, much like call_user_func_array() works.

返回值

Returns the result of the invoked function

范例

Example #1 ReflectionFunction::invokeArgs() example

<?php
function title($title, $name)
{
    return sprintf("%s. %s\r\n", $title, $name);
}

$function = new ReflectionFunction('title');

echo $function->invokeArgs(array('Dr', 'Phil'));
?>

以上例程会输出：

Dr. Phil

Example #2 ReflectionFunction::invokeArgs() with references example

<?php
function get_false_conditions(array $conditions, array &$false_conditions)
{
    foreach ($conditions as $condition) {
        if (!$condition) {
            $false_conditions[] = $condition;
        }
    }
}

$function_ref     = new ReflectionFunction('get_false_conditions');

$conditions       = array(true, false, -1, 0, 1);
$false_conditions = array();

$function_ref->invokeArgs(array($conditions, &$false_conditions));

var_dump($false_conditions);
?>

以上例程会输出：

array(2) {
  [0]=>
  bool(false)
  [1]=>
  int(0)
}

注释

Note:

如果函数有参数需为引用，那么它们必须以引用方式传入。

参见

  • ReflectionFunction::invoke() - Invokes function
  • ReflectionFunctionAbstract::getNumberOfParameters() - 获取参数数目
  • __invoke()
  • call_user_func_array() - 调用回调函数，并把一个数组参数作为回调函数的参数


Checks if function is disabled

  • ? ReflectionFunction::invokeArgs
  • ReflectionFunction::__toString ?
  • PHP Manual
  • ReflectionFunction
  • Checks if function is disabled

ReflectionFunction::isDisabled

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunction::isDisabled — Checks if function is disabled

Warning

本函数已自 PHP 8.0.0 起被废弃。强烈建议不要依赖本函数。

说明

public ReflectionFunction::isDisabled ( ) : bool

Checks if the function is disabled, via the disable_functions directive.

参数

此函数没有参数。

返回值

true if it's disable, otherwise false

参见

  • ReflectionFunctionAbstract::isUserDefined() - 检查是否是用户定义
  • disable_functions directive


To string

  • ? ReflectionFunction::isDisabled
  • ReflectionFunctionAbstract ?
  • PHP Manual
  • ReflectionFunction
  • To string

ReflectionFunction::__toString

(PHP 5, PHP 7)

ReflectionFunction::__toString — To string

说明

public ReflectionFunction::__toString ( ) : string

To string.

参数

此函数没有参数。

返回值

Returns ReflectionFunction::export()-like output for the function.

范例

Example #1 ReflectionFunction::__toString() example

<?php
function title($title, $name)
{
    return sprintf("%s. %s\r\n", $title, $name);
}

echo new ReflectionFunction('title');
?>

以上例程的输出类似于：

Function [ <user> function title ] {
  @@ Command line code 1 - 1

  - Parameters [2] {
    Parameter #0 [ <required> $title ]
    Parameter #1 [ <required> $name ]
  }
}

参见

  • ReflectionFunction::export() - Exports function
  • ReflectionClass::clone()
  • __toString()


ReflectionFunctionAbstract 类

(PHP 5 >= 5.2.0, PHP 7)

简介

ReflectionFunction 的父类，详情请阅读它的描述。

类摘要

ReflectionFunctionAbstract implements Reflector {
/* 属性 */
public $name ;
/* 方法 */
final private __clone ( ) : void
public getClosureScopeClass ( ) : ReflectionClass|null
public getClosureThis ( ) : object
public getDocComment ( ) : string
public getEndLine ( ) : int
public getExtension ( ) : ReflectionExtension
public getExtensionName ( ) : string
public getFileName ( ) : string
public getName ( ) : string
public getNamespaceName ( ) : string
public getNumberOfParameters ( ) : int
public getNumberOfRequiredParameters ( ) : int
public getParameters ( ) : array
public getReturnType ( ) : ReflectionType|null
public getShortName ( ) : string
public getStartLine ( ) : int
public getStaticVariables ( ) : array
public hasReturnType ( ) : bool
public inNamespace ( ) : bool
public isClosure ( ) : bool
public isDeprecated ( ) : bool
public isGenerator ( ) : bool
public isInternal ( ) : bool
public isUserDefined ( ) : bool
public isVariadic ( ) : bool
public returnsReference ( ) : bool
abstract public __toString ( ) : void
}

属性

name

函数的名称。只读，尝试赋值的时候将会抛出 ReflectionException。

Table of Contents

  • ReflectionFunctionAbstract::__clone — 复制函数
  • ReflectionFunctionAbstract::getClosureScopeClass — Returns the scope associated to the closure
  • ReflectionFunctionAbstract::getClosureThis — 返回本身的匿名函数
  • ReflectionFunctionAbstract::getDocComment — 获取注释内容
  • ReflectionFunctionAbstract::getEndLine — 获取结束行号
  • ReflectionFunctionAbstract::getExtension — 获取扩展信息
  • ReflectionFunctionAbstract::getExtensionName — 获取扩展名称
  • ReflectionFunctionAbstract::getFileName — 获取文件名称
  • ReflectionFunctionAbstract::getName — 获取函数名称
  • ReflectionFunctionAbstract::getNamespaceName — 获取命名空间
  • ReflectionFunctionAbstract::getNumberOfParameters — 获取参数数目
  • ReflectionFunctionAbstract::getNumberOfRequiredParameters — 获取必须输入参数个数
  • ReflectionFunctionAbstract::getParameters — 获取参数
  • ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function
  • ReflectionFunctionAbstract::getShortName — 获取函数短名称
  • ReflectionFunctionAbstract::getStartLine — 获取开始行号
  • ReflectionFunctionAbstract::getStaticVariables — 获取静态变量
  • ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type
  • ReflectionFunctionAbstract::inNamespace — 检查是否处于命名空间
  • ReflectionFunctionAbstract::isClosure — 检查是否是匿名函数
  • ReflectionFunctionAbstract::isDeprecated — 检查是否已经弃用
  • ReflectionFunctionAbstract::isGenerator — 判断函数是否是一个生成器函数
  • ReflectionFunctionAbstract::isInternal — 判断函数是否是内置函数
  • ReflectionFunctionAbstract::isUserDefined — 检查是否是用户定义
  • ReflectionFunctionAbstract::isVariadic — Checks if the function is variadic
  • ReflectionFunctionAbstract::returnsReference — 检查是否返回参考信息
  • ReflectionFunctionAbstract::__toString — 字符串化


复制函数

  • ? ReflectionFunctionAbstract
  • ReflectionFunctionAbstract::getClosureScopeClass ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 复制函数

ReflectionFunctionAbstract::__clone

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::__clone — 复制函数

说明

final private ReflectionFunctionAbstract::__clone ( ) : void

复制函数

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

参见

  • Object cloning


Returns the scope associated to the closure

  • ? ReflectionFunctionAbstract::__clone
  • ReflectionFunctionAbstract::getClosureThis ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • Returns the scope associated to the closure

ReflectionFunctionAbstract::getClosureScopeClass

(PHP 5 >= 5.4.0, PHP 7)

ReflectionFunctionAbstract::getClosureScopeClass — Returns the scope associated to the closure

说明

public ReflectionFunctionAbstract::getClosureScopeClass ( ) : ReflectionClass|null

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns the class on success or null on failure.


返回本身的匿名函数

  • ? ReflectionFunctionAbstract::getClosureScopeClass
  • ReflectionFunctionAbstract::getDocComment ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 返回本身的匿名函数

ReflectionFunctionAbstract::getClosureThis

(PHP 5 >= 5.4.0, PHP 7)

ReflectionFunctionAbstract::getClosureThis — 返回本身的匿名函数

说明

public ReflectionFunctionAbstract::getClosureThis ( ) : object

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回 $this 指向，产生错误返回 null


获取注释内容

  • ? ReflectionFunctionAbstract::getClosureThis
  • ReflectionFunctionAbstract::getEndLine ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取注释内容

ReflectionFunctionAbstract::getDocComment

(PHP 5 >= 5.1.0, PHP 7)

ReflectionFunctionAbstract::getDocComment — 获取注释内容

说明

public ReflectionFunctionAbstract::getDocComment ( ) : string

获取函数的注释文本

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

如果存在注释文本返回其内容，否则返回 false

参见

  • ReflectionFunctionAbstract::getStartLine() - 获取开始行号


获取结束行号

  • ? ReflectionFunctionAbstract::getDocComment
  • ReflectionFunctionAbstract::getExtension ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取结束行号

ReflectionFunctionAbstract::getEndLine

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getEndLine — 获取结束行号

说明

public ReflectionFunctionAbstract::getEndLine ( ) : int

获取结束行号

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

获取用户定义函数的结束行号，如果未知返回 false

参见

  • ReflectionFunctionAbstract::getStartLine() - 获取开始行号


获取扩展信息

  • ? ReflectionFunctionAbstract::getEndLine
  • ReflectionFunctionAbstract::getExtensionName ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取扩展信息

ReflectionFunctionAbstract::getExtension

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getExtension — 获取扩展信息

说明

public ReflectionFunctionAbstract::getExtension ( ) : ReflectionExtension

获取函数的扩展信息

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回 ReflectionExtension 对象，包含扩展信息

参见

  • ReflectionFunctionAbstract::getExtensionName() - 获取扩展名称


获取扩展名称

  • ? ReflectionFunctionAbstract::getExtension
  • ReflectionFunctionAbstract::getFileName ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取扩展名称

ReflectionFunctionAbstract::getExtensionName

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getExtensionName — 获取扩展名称

说明

public ReflectionFunctionAbstract::getExtensionName ( ) : string

获取扩展名称

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回扩展名称

参见

  • ReflectionFunctionAbstract::getExtension() - 获取扩展信息


获取文件名称

  • ? ReflectionFunctionAbstract::getExtensionName
  • ReflectionFunctionAbstract::getName ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取文件名称

ReflectionFunctionAbstract::getFileName

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getFileName — 获取文件名称

说明

public ReflectionFunctionAbstract::getFileName ( ) : string

获取函数定义的文件名称

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The file name.

参见

  • ReflectionFunctionAbstract::getNamespaceName() - 获取命名空间


获取函数名称

  • ? ReflectionFunctionAbstract::getFileName
  • ReflectionFunctionAbstract::getNamespaceName ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取函数名称

ReflectionFunctionAbstract::getName

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getName — 获取函数名称

说明

public ReflectionFunctionAbstract::getName ( ) : string

获取函数名称

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回函数名称

参见

  • ReflectionFunctionAbstract::getExtensionName() - 获取扩展名称
  • ReflectionFunctionAbstract::isUserDefined() - 检查是否是用户定义


获取命名空间

  • ? ReflectionFunctionAbstract::getName
  • ReflectionFunctionAbstract::getNumberOfParameters ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取命名空间

ReflectionFunctionAbstract::getNamespaceName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getNamespaceName — 获取命名空间

说明

public ReflectionFunctionAbstract::getNamespaceName ( ) : string

获取类定义所属的命名空间

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回命名空间

参见

  • ReflectionFunctionAbstract::getFileName() - 获取文件名称
  • namespaces


获取参数数目

  • ? ReflectionFunctionAbstract::getNamespaceName
  • ReflectionFunctionAbstract::getNumberOfRequiredParameters ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取参数数目

ReflectionFunctionAbstract::getNumberOfParameters

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getNumberOfParameters — 获取参数数目

说明

public ReflectionFunctionAbstract::getNumberOfParameters ( ) : int

获取函数定义的参数数目，包括可选参数

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

参数的个数

参见

  • ReflectionFunctionAbstract::getNumberOfRequiredParameters() - 获取必须输入参数个数
  • func_num_args() - Returns the number of arguments passed to the function


获取必须输入参数个数

  • ? ReflectionFunctionAbstract::getNumberOfParameters
  • ReflectionFunctionAbstract::getParameters ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取必须输入参数个数

ReflectionFunctionAbstract::getNumberOfRequiredParameters

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getNumberOfRequiredParameters — 获取必须输入参数个数

说明

public ReflectionFunctionAbstract::getNumberOfRequiredParameters ( ) : int

获取函数定义中，必须输入的参数个数

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

必须输入的参数个数

参见

  • ReflectionFunctionAbstract::getNumberOfParameters() - 获取参数数目


获取参数

  • ? ReflectionFunctionAbstract::getNumberOfRequiredParameters
  • ReflectionFunctionAbstract::getReturnType ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取参数

ReflectionFunctionAbstract::getParameters

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getParameters — 获取参数

说明

public ReflectionFunctionAbstract::getParameters ( ) : array

通过 ReflectionParameter 数组返回参数列表

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

一组 ReflectionParameter 对象表示每一参数

参见

  • ReflectionFunctionAbstract::getNumberOfParameters() - 获取参数数目
  • func_get_args() - 返回一个包含函数参数列表的数组


Gets the specified return type of a function

  • ? ReflectionFunctionAbstract::getParameters
  • ReflectionFunctionAbstract::getShortName ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • Gets the specified return type of a function

ReflectionFunctionAbstract::getReturnType

(PHP 7)

ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function

说明

public ReflectionFunctionAbstract::getReturnType ( ) : ReflectionType|null

Gets the specified return type of a reflected function.

参数

此函数没有参数。

返回值

Returns a ReflectionType object if a return type is specified, null otherwise.

范例

Example #1 ReflectionFunctionAbstract::getReturnType() example

<?php

function to_int($param) : int {
    return (int) $param;
}

$reflection1 = new ReflectionFunction('to_int');
echo $reflection1->getReturnType();

以上例程会输出：

int

Example #2 Usage on built-in functions

<?php

$reflection2 = new ReflectionFunction('array_merge');

var_dump($reflection2->getReturnType());

以上例程会输出：

null

This is because many internal functions do not have types specified for their parameters or return values. It is therefore best to avoid using this method on built-in functions.

参见

  • ReflectionFunctionAbstract::hasReturnType() - Checks if the function has a specified return type
  • ReflectionType::__toString() - To string


获取函数短名称

  • ? ReflectionFunctionAbstract::getReturnType
  • ReflectionFunctionAbstract::getStartLine ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取函数短名称

ReflectionFunctionAbstract::getShortName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getShortName — 获取函数短名称

说明

public ReflectionFunctionAbstract::getShortName ( ) : string

获取函数的段名称 (没有命名空间定义)

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

函数短名称

参见

  • ReflectionFunctionAbstract::getNamespaceName() - 获取命名空间
  • namespaces


获取开始行号

  • ? ReflectionFunctionAbstract::getShortName
  • ReflectionFunctionAbstract::getStaticVariables ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取开始行号

ReflectionFunctionAbstract::getStartLine

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getStartLine — 获取开始行号

说明

public ReflectionFunctionAbstract::getStartLine ( ) : int

获取函数定义的开始行号

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

开始行号

参见

  • ReflectionFunctionAbstract::getEndLine() - 获取结束行号


获取静态变量

  • ? ReflectionFunctionAbstract::getStartLine
  • ReflectionFunctionAbstract::hasReturnType ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 获取静态变量

ReflectionFunctionAbstract::getStaticVariables

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::getStaticVariables — 获取静态变量

说明

public ReflectionFunctionAbstract::getStaticVariables ( ) : array

获取静态变量

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回一个静态变量的 array

参见

  • ReflectionFunctionAbstract::getParameters() - 获取参数


Checks if the function has a specified return type

  • ? ReflectionFunctionAbstract::getStaticVariables
  • ReflectionFunctionAbstract::inNamespace ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • Checks if the function has a specified return type

ReflectionFunctionAbstract::hasReturnType

(PHP 7)

ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type

说明

public ReflectionFunctionAbstract::hasReturnType ( ) : bool

Checks whether the reflected function has a return type specified.

参数

此函数没有参数。

返回值

Returns true if the function is a specified return type, otherwise false.

范例

Example #1 ReflectionFunctionAbstract::hasReturnType() example

<?php

function to_int($param) : int {
    return (int) $param;
}

$reflection1 = new ReflectionFunction('to_int');
var_dump($reflection1->hasReturnType());

以上例程会输出：

bool(true)

Example #2 Usage on built-in functions

<?php

$reflection2 = new ReflectionFunction('array_merge');

var_dump($reflection2->hasReturnType());

以上例程会输出：

bool(false)

This is because many internal functions do not have types specified for their parameters or return values. It is therefore best to avoid using this method on built-in functions.

参见

  • ReflectionFunctionAbstract::getReturnType() - Gets the specified return type of a function


检查是否处于命名空间

  • ? ReflectionFunctionAbstract::hasReturnType
  • ReflectionFunctionAbstract::isClosure ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 检查是否处于命名空间

ReflectionFunctionAbstract::inNamespace

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::inNamespace — 检查是否处于命名空间

说明

public ReflectionFunctionAbstract::inNamespace ( ) : bool

检查函数是否在命名空间内定义

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

在命名空间内返回 true，否则返回 false

参见

  • ReflectionFunctionAbstract::getNamespaceName() - 获取命名空间
  • namespaces


检查是否是匿名函数

  • ? ReflectionFunctionAbstract::inNamespace
  • ReflectionFunctionAbstract::isDeprecated ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 检查是否是匿名函数

ReflectionFunctionAbstract::isClosure

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::isClosure — 检查是否是匿名函数

说明

public ReflectionFunctionAbstract::isClosure ( ) : bool

检查是否是匿名函数

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

匿名函数返回 true，否则返回 false

参见

  • ReflectionFunctionAbstract::()


检查是否已经弃用

  • ? ReflectionFunctionAbstract::isClosure
  • ReflectionFunctionAbstract::isGenerator ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 检查是否已经弃用

ReflectionFunctionAbstract::isDeprecated

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::isDeprecated — 检查是否已经弃用

说明

public ReflectionFunctionAbstract::isDeprecated ( ) : bool

检查函数是否已经被弃用

参数

此函数没有参数。

返回值

弃用返回 true，否则返回 false

范例

Example #1 ReflectionFunctionAbstract::isDeprecated() example

<?php
$rf = new ReflectionFunction('ereg');
var_dump($rf->isDeprecated());
?>

以上例程会输出：

bool(true)

参见

  • ReflectionFunctionAbstract::getDocComment() - 获取注释内容


判断函数是否是一个生成器函数

  • ? ReflectionFunctionAbstract::isDeprecated
  • ReflectionFunctionAbstract::isInternal ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 判断函数是否是一个生成器函数

ReflectionFunctionAbstract::isGenerator

(PHP 5 >= 5.5.0, PHP 7)

ReflectionFunctionAbstract::isGenerator — 判断函数是否是一个生成器函数

说明

public ReflectionFunctionAbstract::isGenerator ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

生成器函数返回 true，否则返回 false on failure.


判断函数是否是内置函数

  • ? ReflectionFunctionAbstract::isGenerator
  • ReflectionFunctionAbstract::isUserDefined ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 判断函数是否是内置函数

ReflectionFunctionAbstract::isInternal

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::isInternal — 判断函数是否是内置函数

说明

public ReflectionFunctionAbstract::isInternal ( ) : bool

判断函数是否是内置函数，与用户自定义函数相反

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

内置函数返回 true，否则返回 false

参见

  • ReflectionFunctionAbstract::isUserDefined() - 检查是否是用户定义


检查是否是用户定义

  • ? ReflectionFunctionAbstract::isInternal
  • ReflectionFunctionAbstract::isVariadic ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 检查是否是用户定义

ReflectionFunctionAbstract::isUserDefined

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::isUserDefined — 检查是否是用户定义

说明

public ReflectionFunctionAbstract::isUserDefined ( ) : bool

检查函数是否是用户自定义，也就是说不是 PHP 自己内置函数

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

用户自定义函数返回 true，否则返回 false

参见

  • ReflectionFunctionAbstract::isInternal() - 判断函数是否是内置函数


Checks if the function is variadic

  • ? ReflectionFunctionAbstract::isUserDefined
  • ReflectionFunctionAbstract::returnsReference ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • Checks if the function is variadic

ReflectionFunctionAbstract::isVariadic

(PHP 5 >= 5.6.0, PHP 7)

ReflectionFunctionAbstract::isVariadic — Checks if the function is variadic

说明

public ReflectionFunctionAbstract::isVariadic ( ) : bool

Checks if the function is variadic.

参数

此函数没有参数。

返回值

Returns true if the function is variadic, otherwise false.


检查是否返回参考信息

  • ? ReflectionFunctionAbstract::isVariadic
  • ReflectionFunctionAbstract::__toString ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 检查是否返回参考信息

ReflectionFunctionAbstract::returnsReference

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::returnsReference — 检查是否返回参考信息

说明

public ReflectionFunctionAbstract::returnsReference ( ) : bool

检查是否返回参考信息

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回参考信息返回 true，否则返回 false

参见

  • ReflectionFunctionAbstract::isClosure() - 检查是否是匿名函数


字符串化

  • ? ReflectionFunctionAbstract::returnsReference
  • ReflectionMethod ?
  • PHP Manual
  • ReflectionFunctionAbstract
  • 字符串化

ReflectionFunctionAbstract::__toString

(PHP 5 >= 5.2.0, PHP 7)

ReflectionFunctionAbstract::__toString — 字符串化

说明

abstract public ReflectionFunctionAbstract::__toString ( ) : void

To string.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The string.

参见

  • ReflectionClass::clone()
  • __toString()


ReflectionMethod 类

(PHP 5, PHP 7)

简介

ReflectionMethod 类报告了一个方法的有关信息。

类摘要

ReflectionMethod extends ReflectionFunctionAbstract implements Reflector {
/* 常量 */
const integer IS_STATIC = 1 ;
const integer IS_PUBLIC = 256 ;
const integer IS_PROTECTED = 512 ;
const integer IS_PRIVATE = 1024 ;
const integer IS_ABSTRACT = 2 ;
const integer IS_FINAL = 4 ;
/* 属性 */
public $name ;
public $class ;
/* 方法 */
public __construct ( mixed $class , string $name )
public static export ( string $class , string $name , bool $return = false ) : string
public getClosure ( object $object ) : Closure
public getDeclaringClass ( ) : ReflectionClass
public getModifiers ( ) : int
public getPrototype ( ) : ReflectionMethod
public invoke ( object $object , mixed $parameter = ? , mixed $... = ? ) : mixed
public invokeArgs ( object $object , array $args ) : mixed
public isAbstract ( ) : bool
public isConstructor ( ) : bool
public isDestructor ( ) : bool
public isFinal ( ) : bool
public isPrivate ( ) : bool
public isProtected ( ) : bool
public isPublic ( ) : bool
public isStatic ( ) : bool
public setAccessible ( bool $accessible ) : void
public __toString ( ) : string
/* 继承的方法 */
final private ReflectionFunctionAbstract::__clone ( ) : void
public ReflectionFunctionAbstract::getClosureScopeClass ( ) : ReflectionClass|null
public ReflectionFunctionAbstract::getClosureThis ( ) : object
public ReflectionFunctionAbstract::getDocComment ( ) : string
public ReflectionFunctionAbstract::getEndLine ( ) : int
public ReflectionFunctionAbstract::getExtension ( ) : ReflectionExtension
public ReflectionFunctionAbstract::getExtensionName ( ) : string
public ReflectionFunctionAbstract::getFileName ( ) : string
public ReflectionFunctionAbstract::getName ( ) : string
public ReflectionFunctionAbstract::getNamespaceName ( ) : string
public ReflectionFunctionAbstract::getNumberOfParameters ( ) : int
public ReflectionFunctionAbstract::getNumberOfRequiredParameters ( ) : int
public ReflectionFunctionAbstract::getParameters ( ) : array
public ReflectionFunctionAbstract::getReturnType ( ) : ReflectionType|null
public ReflectionFunctionAbstract::getShortName ( ) : string
public ReflectionFunctionAbstract::getStartLine ( ) : int
public ReflectionFunctionAbstract::getStaticVariables ( ) : array
public ReflectionFunctionAbstract::hasReturnType ( ) : bool
public ReflectionFunctionAbstract::inNamespace ( ) : bool
public ReflectionFunctionAbstract::isClosure ( ) : bool
public ReflectionFunctionAbstract::isDeprecated ( ) : bool
public ReflectionFunctionAbstract::isGenerator ( ) : bool
public ReflectionFunctionAbstract::isInternal ( ) : bool
public ReflectionFunctionAbstract::isUserDefined ( ) : bool
public ReflectionFunctionAbstract::isVariadic ( ) : bool
public ReflectionFunctionAbstract::returnsReference ( ) : bool
abstract public ReflectionFunctionAbstract::__toString ( ) : void
}

属性

name

Method name

class

Class name

预定义常量

ReflectionMethod 修饰符

ReflectionMethod::IS_STATIC

指示一个方法是静态（static）的。

ReflectionMethod::IS_PUBLIC

指示一个方法是 public 的。

ReflectionMethod::IS_PROTECTED

指示一个方法是 protected 的。

ReflectionMethod::IS_PRIVATE

指示一个方法是 private 的。

ReflectionMethod::IS_ABSTRACT

指示一个方法是 abstract 的。

ReflectionMethod::IS_FINAL

指示一个方法是 final 的。

Table of Contents

  • ReflectionMethod::__construct — ReflectionMethod 的构造函数
  • ReflectionMethod::export — 输出一个回调方法
  • ReflectionMethod::getClosure — 返回一个动态建立的方法调用接口，译者注：可以使用这个返回值直接调用非公开方法。
  • ReflectionMethod::getDeclaringClass — 获取被反射的方法所在类的反射实例
  • ReflectionMethod::getModifiers — 获取方法的修饰符
  • ReflectionMethod::getPrototype — 返回方法原型 (如果存在)
  • ReflectionMethod::invoke — Invoke
  • ReflectionMethod::invokeArgs — 带参数执行
  • ReflectionMethod::isAbstract — 判断方法是否是抽象方法
  • ReflectionMethod::isConstructor — 判断方法是否是构造方法
  • ReflectionMethod::isDestructor — 判断方法是否是析构方法
  • ReflectionMethod::isFinal — 判断方法是否定义 final
  • ReflectionMethod::isPrivate — 判断方法是否是私有方法
  • ReflectionMethod::isProtected — 判断方法是否是保护方法 (protected)
  • ReflectionMethod::isPublic — 判断方法是否是公开方法
  • ReflectionMethod::isStatic — 判断方法是否是静态方法
  • ReflectionMethod::setAccessible — 设置方法是否访问
  • ReflectionMethod::__toString — 返回反射方法对象的字符串表达


ReflectionMethod 的构造函数

  • ? ReflectionMethod
  • ReflectionMethod::export ?
  • PHP Manual
  • ReflectionMethod
  • ReflectionMethod 的构造函数

ReflectionMethod::__construct

(PHP 5, PHP 7)

ReflectionMethod::__construct — ReflectionMethod 的构造函数

说明

public ReflectionMethod::__construct ( mixed $class , string $name )
public ReflectionMethod::__construct ( string $class_method )

构造一个新的 ReflectionMethod

参数

class

包含方法的类名称或者这个类的一个实例

name

方法的名称

class_method

类名称和方法名称，之间使用 :: 分隔

返回值

没有返回值。

错误／异常

如果指定的方法不存在，那么抛出一个 ReflectionException

范例

Example #1 ReflectionMethod::__construct() example

<?php
class Counter
{
    private static $c = 0;

    /**
     * Increment counter
     *
     * @final
     * @static
     * @access  public
     * @return  int
     */
    final public static function increment()
    {
        return ++self::$c;
    }
}

// Create an instance of the ReflectionMethod class
$method = new ReflectionMethod('Counter', 'increment');

// Print out basic information
printf(
    "===> The %s%s%s%s%s%s%s method '%s' (which is %s)\n" .
    "     declared in %s\n" .
    "     lines %d to %d\n" .
    "     having the modifiers %d[%s]\n",
        $method->isInternal() ? 'internal' : 'user-defined',
        $method->isAbstract() ? ' abstract' : '',
        $method->isFinal() ? ' final' : '',
        $method->isPublic() ? ' public' : '',
        $method->isPrivate() ? ' private' : '',
        $method->isProtected() ? ' protected' : '',
        $method->isStatic() ? ' static' : '',
        $method->getName(),
        $method->isConstructor() ? 'the constructor' : 'a regular method',
        $method->getFileName(),
        $method->getStartLine(),
        $method->getEndline(),
        $method->getModifiers(),
        implode(' ', Reflection::getModifierNames($method->getModifiers()))
);

// 打印注释文档
printf("---> Documentation:\n %s\n", var_export($method->getDocComment(), 1));

// 打印存在的静态变量
if ($statics= $method->getStaticVariables()) {
    printf("---> Static variables: %s\n", var_export($statics, 1));
}

// 执行方法
printf("---> Invocation results in: ");
var_dump($method->invoke(NULL));
?>

以上例程的输出类似于：

===> The user-defined final public static method 'increment' (which is a regular method)
     declared in /Users/philip/cvs/phpdoc/test.php
     lines 14 to 17
     having the modifiers 261[final public static]
---> Documentation:
 '/**
     * Increment counter
     *
     * @final
     * @static
     * @access  public
     * @return  int
     */'
---> Invocation results in: int(1)

参见

  • ReflectionMethod::export() - 输出一个回调方法
  • Constructors


输出一个回调方法

  • ? ReflectionMethod::__construct
  • ReflectionMethod::getClosure ?
  • PHP Manual
  • ReflectionMethod
  • 输出一个回调方法

ReflectionMethod::export

(PHP 5, PHP 7)

ReflectionMethod::export — 输出一个回调方法

说明

public static ReflectionMethod::export ( string $class , string $name , bool $return = false ) : string

Exports a ReflectionMethod.

Warning

本函数还未编写文档，仅有参数列表。

参数

class

类名称

name

方法名称

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

如果参数 return 设为 true，导出结果将作为 string 返回，否则返回 null。

参见

  • ReflectionMethod::__construct() - ReflectionMethod 的构造函数
  • ReflectionMethod::__toString() - 返回反射方法对象的字符串表达


返回一个动态建立的方法调用接口，译者注：可以使用这个返回值直接调用非公开方法。

  • ? ReflectionMethod::export
  • ReflectionMethod::getDeclaringClass ?
  • PHP Manual
  • ReflectionMethod
  • 返回一个动态建立的方法调用接口，译者注：可以使用这个返回值直接调用非公开方法。

ReflectionMethod::getClosure

(PHP 5 >= 5.4.0, PHP 7)

ReflectionMethod::getClosure — 返回一个动态建立的方法调用接口，译者注：可以使用这个返回值直接调用非公开方法。

说明

public ReflectionMethod::getClosure ( object $object ) : Closure

Warning

本函数还未编写文档，仅有参数列表。

参数

object

不可以使用静态方法，需要其他类型的方法

返回值

返回 Closure 如果产生任何错误返回 null


获取被反射的方法所在类的反射实例

  • ? ReflectionMethod::getClosure
  • ReflectionMethod::getModifiers ?
  • PHP Manual
  • ReflectionMethod
  • 获取被反射的方法所在类的反射实例

ReflectionMethod::getDeclaringClass

(PHP 5, PHP 7)

ReflectionMethod::getDeclaringClass — 获取被反射的方法所在类的反射实例

说明

public ReflectionMethod::getDeclaringClass ( ) : ReflectionClass

获取被反射的方法所在的类的反射实例。

参数

此函数没有参数。

返回值

返回一个类的 ReflectionClass 反射对象，被反射的方法是这个类的一部分。

范例

Example #1 ReflectionMethod::getDeclaringClass() example

<?php
class HelloWorld {

    protected function sayHelloTo($name) {
        return 'Hello ' . $name;
    }

}

$reflectionMethod = new ReflectionMethod(new HelloWorld(), 'sayHelloTo');
var_dump($reflectionMethod->getDeclaringClass());
?>

以上例程会输出：

object(ReflectionClass)#2 (1) {
  ["name"]=>
  string(10) "HelloWorld"
}

参见

  • ReflectionMethod::isAbstract() - 判断方法是否是抽象方法


获取方法的修饰符

  • ? ReflectionMethod::getDeclaringClass
  • ReflectionMethod::getPrototype ?
  • PHP Manual
  • ReflectionMethod
  • 获取方法的修饰符

ReflectionMethod::getModifiers

(PHP 5, PHP 7)

ReflectionMethod::getModifiers — 获取方法的修饰符

说明

public ReflectionMethod::getModifiers ( ) : int

返回一个方法的修饰符，返回值是一个位标

参数

此函数没有参数。

返回值

使用一个数字表示方法修饰符，具体数字的含义可以参考 predefined constants 中的说明。

范例

Example #1 ReflectionMethod::getModifiers() example

<?php
class Testing
{
    final public static function foo()
    {
        return;
    }
    public function bar()
    {
        return;
    }
}

$foo = new ReflectionMethod('Testing', 'foo');

echo "Modifiers for method foo():\n";
echo $foo->getModifiers() . "\n";
echo implode(' ', Reflection::getModifierNames($foo->getModifiers())) . "\n";

$bar = new ReflectionMethod('Testing', 'bar');

echo "Modifiers for method bar():\n";
echo $bar->getModifiers() . "\n";
echo implode(' ', Reflection::getModifierNames($bar->getModifiers()));
?>

以上例程的输出类似于：

Modifiers for method foo():
261
final public static
Modifiers for method bar():
65792
public

参见

  • Reflection::getModifierNames() - 获取修饰符的名称


返回方法原型 (如果存在)

  • ? ReflectionMethod::getModifiers
  • ReflectionMethod::invoke ?
  • PHP Manual
  • ReflectionMethod
  • 返回方法原型 (如果存在)

ReflectionMethod::getPrototype

(PHP 5 >= 5.1.2, PHP 7)

ReflectionMethod::getPrototype — 返回方法原型 (如果存在)

说明

public ReflectionMethod::getPrototype ( ) : ReflectionMethod

返回方法原型

参数

此函数没有参数。

返回值

方法原型的一个 ReflectionMethod 实例

错误／异常

如果方法没有原型，产生一个 ReflectionException

范例

Example #1 ReflectionMethod::getPrototype() example

<?php
class Hello {

    public function sayHelloTo($name) {
        return 'Hello ' . $name;
    }

}
class HelloWorld extends Hello {

    public function sayHelloTo($name) {
        return 'Hello world: ' . $name;
    }

}

$reflectionMethod = new ReflectionMethod('HelloWorld', 'sayHelloTo');
var_dump($reflectionMethod->getPrototype());
?>

以上例程会输出：

object(ReflectionMethod)#2 (2) {
  ["name"]=>
  string(10) "sayHelloTo"
  ["class"]=>
  string(5) "Hello"
}

参见

  • ReflectionMethod::getModifiers() - 获取方法的修饰符


Invoke

  • ? ReflectionMethod::getPrototype
  • ReflectionMethod::invokeArgs ?
  • PHP Manual
  • ReflectionMethod
  • Invoke

ReflectionMethod::invoke

(PHP 5, PHP 7)

ReflectionMethod::invoke — Invoke

说明

public ReflectionMethod::invoke ( object $object , mixed $parameter = ? , mixed $... = ? ) : mixed

执行一个反射的方法。

参数

object

如果执行的方法是静态类，那么这个参数传送 null。

parameter

0，或者传送给方法的参数列表。可以通过这个参数，给方法传送大量的参数。

返回值

返回方法的返回值

错误／异常

如果 object 并没有包含一个可以使用的类实例，那么将产生 一个 ReflectionException。

如果方法调用失败，也会产生一个 ReflectionException。

范例

Example #1 ReflectionMethod::invoke() example

<?php
class HelloWorld {

    public function sayHelloTo($name) {
        return 'Hello ' . $name;
    }

}

$reflectionMethod = new ReflectionMethod('HelloWorld', 'sayHelloTo');
echo $reflectionMethod->invoke(new HelloWorld(), 'Mike');
?>

以上例程会输出：

Hello Mike

注释

Note:

如果函数有参数需为引用，那么它们必须以引用方式传入。

参见

  • ReflectionMethod::invokeArgs() - 带参数执行
  • __invoke()
  • call_user_func() - 把第一个参数作为回调函数调用


带参数执行

  • ? ReflectionMethod::invoke
  • ReflectionMethod::isAbstract ?
  • PHP Manual
  • ReflectionMethod
  • 带参数执行

ReflectionMethod::invokeArgs

(PHP 5 >= 5.1.2, PHP 7)

ReflectionMethod::invokeArgs — 带参数执行

说明

public ReflectionMethod::invokeArgs ( object $object , array $args ) : mixed

使用数组给方法传送参数，并执行他。

参数

object

调用方法的对象，如果是静态对象，设置为 null

args

使用 array 传送的方法参数。

返回值

返回方法返回值

错误／异常

如果 object 指定的实例无法执行方法，那么产生 ReflectionException 异常。

如果方法调用失败，产生 ReflectionException

范例

Example #1 ReflectionMethod::invokeArgs() example

<?php
class HelloWorld {

    public function sayHelloTo($name) {
        return 'Hello ' . $name;
    }

}

$reflectionMethod = new ReflectionMethod('HelloWorld', 'sayHelloTo');
echo $reflectionMethod->invokeArgs(new HelloWorld(), array('Mike'));
?>

以上例程会输出：

Hello Mike

注释

Note:

如果函数有参数需为引用，那么它们必须以引用方式传入。

参见

  • ReflectionMethod::invoke() - Invoke
  • __invoke()
  • call_user_func_array() - 调用回调函数，并把一个数组参数作为回调函数的参数


判断方法是否是抽象方法

  • ? ReflectionMethod::invokeArgs
  • ReflectionMethod::isConstructor ?
  • PHP Manual
  • ReflectionMethod
  • 判断方法是否是抽象方法

ReflectionMethod::isAbstract

(PHP 5, PHP 7)

ReflectionMethod::isAbstract — 判断方法是否是抽象方法

说明

public ReflectionMethod::isAbstract ( ) : bool

判断方法是否是抽象方法

参数

此函数没有参数。

返回值

如果是抽象方法返回 true，否则返回 false

参见

  • ReflectionMethod::getDeclaringClass() - 获取被反射的方法所在类的反射实例


判断方法是否是构造方法

  • ? ReflectionMethod::isAbstract
  • ReflectionMethod::isDestructor ?
  • PHP Manual
  • ReflectionMethod
  • 判断方法是否是构造方法

ReflectionMethod::isConstructor

(PHP 5, PHP 7)

ReflectionMethod::isConstructor — 判断方法是否是构造方法

说明

public ReflectionMethod::isConstructor ( ) : bool

判断方法是否是构造方法

参数

此函数没有参数。

返回值

如果是构造方法返回 true，否则返回 false

参见

  • ReflectionMethod::__construct() - ReflectionMethod 的构造函数
  • ReflectionMethod::isAbstract() - 判断方法是否是抽象方法
  • ReflectionMethod::isDestructor() - 判断方法是否是析构方法


判断方法是否是析构方法

  • ? ReflectionMethod::isConstructor
  • ReflectionMethod::isFinal ?
  • PHP Manual
  • ReflectionMethod
  • 判断方法是否是析构方法

ReflectionMethod::isDestructor

(PHP 5, PHP 7)

ReflectionMethod::isDestructor — 判断方法是否是析构方法

说明

public ReflectionMethod::isDestructor ( ) : bool

判断方法是否是析构方法

参数

此函数没有参数。

返回值

如果是析构方法返回 true，否则返回 false

参见

  • ReflectionMethod::isConstructor() - 判断方法是否是构造方法


判断方法是否定义 final

  • ? ReflectionMethod::isDestructor
  • ReflectionMethod::isPrivate ?
  • PHP Manual
  • ReflectionMethod
  • 判断方法是否定义 final

ReflectionMethod::isFinal

(PHP 5, PHP 7)

ReflectionMethod::isFinal — 判断方法是否定义 final

说明

public ReflectionMethod::isFinal ( ) : bool

判断方法是否定义 final

参数

此函数没有参数。

返回值

如果是 final 返回 true，否则返回 false

参见

  • ReflectionMethod::isStatic() - 判断方法是否是静态方法


判断方法是否是私有方法

  • ? ReflectionMethod::isFinal
  • ReflectionMethod::isProtected ?
  • PHP Manual
  • ReflectionMethod
  • 判断方法是否是私有方法

ReflectionMethod::isPrivate

(PHP 5, PHP 7)

ReflectionMethod::isPrivate — 判断方法是否是私有方法

说明

public ReflectionMethod::isPrivate ( ) : bool

判断方法是否是私有方法

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

私有方法返回 true，否则返回 false

参见

  • ReflectionMethod::isPublic() - 判断方法是否是公开方法


判断方法是否是保护方法 (protected)

  • ? ReflectionMethod::isPrivate
  • ReflectionMethod::isPublic ?
  • PHP Manual
  • ReflectionMethod
  • 判断方法是否是保护方法 (protected)

ReflectionMethod::isProtected

(PHP 5, PHP 7)

ReflectionMethod::isProtected — 判断方法是否是保护方法 (protected)

说明

public ReflectionMethod::isProtected ( ) : bool

判断方法是否是保护方法

参数

此函数没有参数。

返回值

保护方法返回 true，否则返回 false

参见

  • ReflectionMethod::isPrivate() - 判断方法是否是私有方法


判断方法是否是公开方法

  • ? ReflectionMethod::isProtected
  • ReflectionMethod::isStatic ?
  • PHP Manual
  • ReflectionMethod
  • 判断方法是否是公开方法

ReflectionMethod::isPublic

(PHP 5, PHP 7)

ReflectionMethod::isPublic — 判断方法是否是公开方法

说明

public ReflectionMethod::isPublic ( ) : bool

判断方法是否是公开方法

参数

此函数没有参数。

返回值

公开方法返回 true，否则返回 false

参见

  • ReflectionMethod::isPrivate() - 判断方法是否是私有方法


判断方法是否是静态方法

  • ? ReflectionMethod::isPublic
  • ReflectionMethod::setAccessible ?
  • PHP Manual
  • ReflectionMethod
  • 判断方法是否是静态方法

ReflectionMethod::isStatic

(PHP 5, PHP 7)

ReflectionMethod::isStatic — 判断方法是否是静态方法

说明

public ReflectionMethod::isStatic ( ) : bool

判断方法是否是静态方法

参数

此函数没有参数。

返回值

静态方法返回 true，否则返回 false

参见

  • ReflectionMethod::isFinal() - 判断方法是否定义 final


设置方法是否访问

  • ? ReflectionMethod::isStatic
  • ReflectionMethod::__toString ?
  • PHP Manual
  • ReflectionMethod
  • 设置方法是否访问

ReflectionMethod::setAccessible

(PHP 5 >= 5.3.2, PHP 7)

ReflectionMethod::setAccessible — 设置方法是否访问

说明

public ReflectionMethod::setAccessible ( bool $accessible ) : void

设置方法是否可以访问，例如通过设置可以访问能够执行私有方法和保护方法

参数

accessible

可以访问设置 true，否则设置 false

返回值

没有返回值。

参见

  • ReflectionMethod::isPrivate() - 判断方法是否是私有方法
  • ReflectionMethod::isProtected() - 判断方法是否是保护方法 (protected)


返回反射方法对象的字符串表达

  • ? ReflectionMethod::setAccessible
  • ReflectionObject ?
  • PHP Manual
  • ReflectionMethod
  • 返回反射方法对象的字符串表达

ReflectionMethod::__toString

(PHP 5, PHP 7)

ReflectionMethod::__toString — 返回反射方法对象的字符串表达

说明

public ReflectionMethod::__toString ( ) : string

返回反射方法对象的字符串表达

参数

此函数没有参数。

返回值

ReflectionMethod 实例的字符串表达，也就是字符串

范例

Example #1 ReflectionMethod::__toString() example

<?php
class HelloWorld {

    public function sayHelloTo($name) {
        return 'Hello ' . $name;
    }

}

$reflectionMethod = new ReflectionMethod(new HelloWorld(), 'sayHelloTo');
echo $reflectionMethod;
?>

以上例程会输出：

Method [ <user> public method sayHelloTo ] {
  @@ /var/www/examples/reflection.php 16 - 18

  - Parameters [1] {
    Parameter #0 [ <required> $name ]
  }
}

参见

  • ReflectionMethod::export() - 输出一个回调方法
  • __toString()


ReflectionObject 类

(PHP 5, PHP 7)

简介

ReflectionObject 类报告了一个对象（object）的相关信息。

类摘要

ReflectionObject extends ReflectionClass implements Reflector {
/* 常量 */
const integer IS_IMPLICIT_ABSTRACT = 16 ;
const integer IS_EXPLICIT_ABSTRACT = 32 ;
const integer IS_FINAL = 64 ;
/* 属性 */
public $name ;
/* 方法 */
public static export ( string $argument , bool $return = ? ) : string
/* 继承的方法 */
public ReflectionClass::__construct ( mixed $argument )
public static ReflectionClass::export ( mixed $argument , bool $return = false ) : string
public ReflectionClass::getConstant ( string $name ) : mixed
public ReflectionClass::getConstants ( ) : array
public ReflectionClass::getConstructor ( ) : ReflectionMethod
public ReflectionClass::getDefaultProperties ( ) : array
public ReflectionClass::getDocComment ( ) : string
public ReflectionClass::getEndLine ( ) : int
public ReflectionClass::getExtension ( ) : ReflectionExtension
public ReflectionClass::getExtensionName ( ) : string
public ReflectionClass::getFileName ( ) : string
public ReflectionClass::getInterfaceNames ( ) : array
public ReflectionClass::getInterfaces ( ) : array
public ReflectionClass::getMethod ( string $name ) : ReflectionMethod
public ReflectionClass::getMethods ( int $filter = ? ) : array
public ReflectionClass::getModifiers ( ) : int
public ReflectionClass::getName ( ) : string
public ReflectionClass::getNamespaceName ( ) : string
public ReflectionClass::getParentClass ( ) : ReflectionClass
public ReflectionClass::getProperties ( int $filter = ? ) : array
public ReflectionClass::getProperty ( string $name ) : ReflectionProperty
public ReflectionClass::getReflectionConstant ( string $name ) : ReflectionClassConstant|false
public ReflectionClass::getReflectionConstants ( int|null $filter = null ) : array
public ReflectionClass::getShortName ( ) : string
public ReflectionClass::getStartLine ( ) : int
public ReflectionClass::getStaticProperties ( ) : array
public ReflectionClass::getStaticPropertyValue ( string $name , mixed &$def_value = ? ) : mixed
public ReflectionClass::getTraitAliases ( ) : array
public ReflectionClass::getTraitNames ( ) : array
public ReflectionClass::getTraits ( ) : array
public ReflectionClass::hasConstant ( string $name ) : bool
public ReflectionClass::hasMethod ( string $name ) : bool
public ReflectionClass::hasProperty ( string $name ) : bool
public ReflectionClass::implementsInterface ( string $interface ) : bool
public ReflectionClass::inNamespace ( ) : bool
public ReflectionClass::isAbstract ( ) : bool
public ReflectionClass::isAnonymous ( ) : bool
public ReflectionClass::isCloneable ( ) : bool
public ReflectionClass::isFinal ( ) : bool
public ReflectionClass::isInstance ( object $object ) : bool
public ReflectionClass::isInstantiable ( ) : bool
public ReflectionClass::isInterface ( ) : bool
public ReflectionClass::isInternal ( ) : bool
public ReflectionClass::isIterable ( ) : bool
public ReflectionClass::isIterateable ( ) : bool
public ReflectionClass::isSubclassOf ( string $class ) : bool
public ReflectionClass::isTrait ( ) : bool
public ReflectionClass::isUserDefined ( ) : bool
public ReflectionClass::newInstance ( mixed $args , mixed $... = ? ) : object
public ReflectionClass::newInstanceArgs ( array $args = ? ) : object
public ReflectionClass::newInstanceWithoutConstructor ( ) : object
public ReflectionClass::setStaticPropertyValue ( string $name , string $value ) : void
public ReflectionClass::__toString ( ) : string
}

属性

name

对象的类名。只读，在尝试赋值的时候会抛出 ReflectionException。

Table of Contents

  • ReflectionObject::__construct — Constructs a ReflectionObject
  • ReflectionObject::export — Export


Constructs a ReflectionObject

  • ? ReflectionObject
  • ReflectionObject::export ?
  • PHP Manual
  • ReflectionObject
  • Constructs a ReflectionObject

ReflectionObject::__construct

(PHP 5, PHP 7)

ReflectionObject::__construct — Constructs a ReflectionObject

说明

public ReflectionObject::__construct ( object $object )

Constructs a ReflectionObject.

Warning

本函数还未编写文档，仅有参数列表。

参数

object

An object instance.

返回值

没有返回值。

参见

  • ReflectionObject::export() - Export
  • Constructors


Export

  • ? ReflectionObject::__construct
  • ReflectionParameter ?
  • PHP Manual
  • ReflectionObject
  • Export

ReflectionObject::export

(PHP 5, PHP 7)

ReflectionObject::export — Export

说明

public static ReflectionObject::export ( string $argument , bool $return = ? ) : string

Exports a reflection.

Warning

本函数还未编写文档，仅有参数列表。

参数

argument

导出的反射。

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

如果参数 return 设为 true，导出结果将作为 string 返回，否则返回 null。

参见

  • ReflectionObject::__construct() - Constructs a ReflectionObject


ReflectionParameter 类

(PHP 5, PHP 7)

简介

ReflectionParameter 取回了函数或方法参数的相关信息。

要自行检查函数的参数，首先创建一个 ReflectionFunction 或 ReflectionMethod 的实例，然后使用它们的 ReflectionFunctionAbstract::getParameters() 方法来获取参数的数组。

类摘要

ReflectionParameter implements Reflector {
/* 属性 */
public $name ;
/* 方法 */
public allowsNull ( ) : bool
public canBePassedByValue ( ) : bool
final private __clone ( ) : void
public static export ( string $function , string $parameter , bool $return = ? ) : string
public getClass ( ) : ReflectionClass
public getDeclaringClass ( ) : ReflectionClass|null
public getDeclaringFunction ( ) : ReflectionFunctionAbstract
public getDefaultValue ( ) : mixed
public getDefaultValueConstantName ( ) : string|null
public getName ( ) : string
public getPosition ( ) : int
public getType ( ) : ReflectionType|null
public hasType ( ) : bool
public isArray ( ) : bool
public isCallable ( ) : bool
public isDefaultValueAvailable ( ) : bool
public isDefaultValueConstant ( ) : bool
public isOptional ( ) : bool
public isPassedByReference ( ) : bool
public isVariadic ( ) : bool
public __toString ( ) : string
}

属性

name

参数的名称。只读，在尝试赋值的时候会抛出 ReflectionException。

Table of Contents

  • ReflectionParameter::allowsNull — Checks if null is allowed
  • ReflectionParameter::canBePassedByValue — Returns whether this parameter can be passed by value
  • ReflectionParameter::__clone — Clone
  • ReflectionParameter::__construct — Construct
  • ReflectionParameter::export — Exports
  • ReflectionParameter::getClass — 获得类型提示类。
  • ReflectionParameter::getDeclaringClass — Gets declaring class
  • ReflectionParameter::getDeclaringFunction — Gets declaring function
  • ReflectionParameter::getDefaultValue — Gets default parameter value
  • ReflectionParameter::getDefaultValueConstantName — Returns the default value's constant name if default value is constant or null
  • ReflectionParameter::getName — Gets parameter name
  • ReflectionParameter::getPosition — Gets parameter position
  • ReflectionParameter::getType — Gets a parameter's type
  • ReflectionParameter::hasType — Checks if parameter has a type
  • ReflectionParameter::isArray — Checks if parameter expects an array
  • ReflectionParameter::isCallable — Returns whether parameter MUST be callable
  • ReflectionParameter::isDefaultValueAvailable — 检查是否有默认值。
  • ReflectionParameter::isDefaultValueConstant — Returns whether the default value of this parameter is a constant
  • ReflectionParameter::isOptional — Checks if optional
  • ReflectionParameter::isPassedByReference — Checks if passed by reference
  • ReflectionParameter::isVariadic — Checks if the parameter is variadic
  • ReflectionParameter::__toString — To string


Checks if null is allowed

  • ? ReflectionParameter
  • ReflectionParameter::canBePassedByValue ?
  • PHP Manual
  • ReflectionParameter
  • Checks if null is allowed

ReflectionParameter::allowsNull

(PHP 5, PHP 7)

ReflectionParameter::allowsNull — Checks if null is allowed

说明

public ReflectionParameter::allowsNull ( ) : bool

Checks whether the parameter allows null.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if null is allowed, otherwise false

参见

  • ReflectionParameter::isOptional() - Checks if optional


Returns whether this parameter can be passed by value

  • ? ReflectionParameter::allowsNull
  • ReflectionParameter::__clone ?
  • PHP Manual
  • ReflectionParameter
  • Returns whether this parameter can be passed by value

ReflectionParameter::canBePassedByValue

(PHP 5 >= 5.4.0, PHP 7)

ReflectionParameter::canBePassedByValue — Returns whether this parameter can be passed by value

说明

public ReflectionParameter::canBePassedByValue ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns true if the parameter can be passed by value, false otherwise. Returns null in case of an error.


Clone

  • ? ReflectionParameter::canBePassedByValue
  • ReflectionParameter::__construct ?
  • PHP Manual
  • ReflectionParameter
  • Clone

ReflectionParameter::__clone

(PHP 5, PHP 7)

ReflectionParameter::__clone — Clone

说明

final private ReflectionParameter::__clone ( ) : void

Clones.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

参见

  • ReflectionParameter::toString()
  • Object cloning


Construct

  • ? ReflectionParameter::__clone
  • ReflectionParameter::export ?
  • PHP Manual
  • ReflectionParameter
  • Construct

ReflectionParameter::__construct

(PHP 5, PHP 7)

ReflectionParameter::__construct — Construct

说明

public ReflectionParameter::__construct ( string|array|object $function , int|string $param )

Constructs a ReflectionParameter instance.

参数

function

The function to reflect parameters from.

param

Either an int specifying the position of the parameter (starting with zero), or the parameter name as string.

返回值

没有返回值。

范例

Example #1 Using the ReflectionParameter class

<?php
function foo($a, $b, $c) { }
function bar(Exception $a, &$b, $c) { }
function baz(ReflectionFunction $a, $b = 1, $c = null) { }
function abc() { }

$reflect = new ReflectionFunction('foo');

echo $reflect;

foreach ($reflect->getParameters() as $i => $param) {
    printf(
        "-- Parameter #%d: %s {\n".
        "   Class: %s\n".
        "   Allows NULL: %s\n".
        "   Passed to by reference: %s\n".
        "   Is optional?: %s\n".
        "}\n",
        $i, // $param->getPosition() can be used from PHP 5.2.3
        $param->getName(),
        var_export($param->getClass(), 1),
        var_export($param->allowsNull(), 1),
        var_export($param->isPassedByReference(), 1),
        $param->isOptional() ? 'yes' : 'no'
    );
}
?>

以上例程的输出类似于：

Function [ <user> function foo ] {
  @@ /Users/philip/cvs/phpdoc/a 2 - 2

  - Parameters [3] {
    Parameter #0 [ <required> $a ]
    Parameter #1 [ <required> $b ]
    Parameter #2 [ <required> $c ]
  }
}
-- Parameter #0: a {
   Class: NULL
   Allows NULL: true
   Passed to by reference: false
   Is optional?: no
}
-- Parameter #1: b {
   Class: NULL
   Allows NULL: true
   Passed to by reference: false
   Is optional?: no
}
-- Parameter #2: c {
   Class: NULL
   Allows NULL: true
   Passed to by reference: false
   Is optional?: no
}

参见

  • ReflectionFunctionAbstract::getParameters() - 获取参数
  • ReflectionFunction::__construct() - Constructs a ReflectionFunction object
  • ReflectionMethod::__construct() - ReflectionMethod 的构造函数
  • Constructors


Exports

  • ? ReflectionParameter::__construct
  • ReflectionParameter::getClass ?
  • PHP Manual
  • ReflectionParameter
  • Exports

ReflectionParameter::export

(PHP 5, PHP 7)

ReflectionParameter::export — Exports

Warning

本函数已自 PHP 7.4.0 起废弃。强烈建议不要使用本函数。

说明

public static ReflectionParameter::export ( string $function , string $parameter , bool $return = ? ) : string

Exports.

Warning

本函数还未编写文档，仅有参数列表。

参数

function

The function name.

parameter

The parameter name.

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

The exported reflection.

参见

  • ReflectionParameter::__toString() - To string


获得类型提示类。

  • ? ReflectionParameter::export
  • ReflectionParameter::getDeclaringClass ?
  • PHP Manual
  • ReflectionParameter
  • 获得类型提示类。

ReflectionParameter::getClass

(PHP 5, PHP 7)

ReflectionParameter::getClass — 获得类型提示类。

说明

public ReflectionParameter::getClass ( ) : ReflectionClass

获取参数的类型提示类，类型为ReflectionClass对象。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

一个 ReflectionClass 对象。

范例

Example #1 使用 ReflectionParameter 类

<?php
function foo(Exception $a) { }

$functionReflection = new ReflectionFunction('foo');
$parameters = $functionReflection->getParameters();
$aParameter = $parameters[0];

echo $aParameter->getClass()->name;
?>

以上例程会输出：

Exception

参见

  • ReflectionParameter::getDeclaringClass() - Gets declaring class


Gets declaring class

  • ? ReflectionParameter::getClass
  • ReflectionParameter::getDeclaringFunction ?
  • PHP Manual
  • ReflectionParameter
  • Gets declaring class

ReflectionParameter::getDeclaringClass

(PHP 5 >= 5.1.3, PHP 7)

ReflectionParameter::getDeclaringClass — Gets declaring class

说明

public ReflectionParameter::getDeclaringClass ( ) : ReflectionClass|null

Gets the declaring class.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A ReflectionClass object or null if called on function.

范例

Example #1 Getting the class that declared the method

<?php
class Foo
{
    public function bar(\DateTime $datetime)
    {
    }
}

class Baz extends Foo
{
}

$param = new \ReflectionParameter(['Baz', 'bar'], 0);

var_dump($param->getDeclaringClass());

以上例程会输出：

object(ReflectionClass)#2 (1) {
  ["name"]=>
  string(3) "Foo"
}

参见

  • ReflectionParameter::getClass() - 获得类型提示类。


Gets declaring function

  • ? ReflectionParameter::getDeclaringClass
  • ReflectionParameter::getDefaultValue ?
  • PHP Manual
  • ReflectionParameter
  • Gets declaring function

ReflectionParameter::getDeclaringFunction

(PHP 5 >= 5.1.3, PHP 7)

ReflectionParameter::getDeclaringFunction — Gets declaring function

说明

public ReflectionParameter::getDeclaringFunction ( ) : ReflectionFunctionAbstract

Gets the declaring function.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A ReflectionFunction object.

参见

  • ReflectionParameter::getDeclaringClass() - Gets declaring class


Gets default parameter value

  • ? ReflectionParameter::getDeclaringFunction
  • ReflectionParameter::getDefaultValueConstantName ?
  • PHP Manual
  • ReflectionParameter
  • Gets default parameter value

ReflectionParameter::getDefaultValue

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::getDefaultValue — Gets default parameter value

说明

public ReflectionParameter::getDefaultValue ( ) : mixed

Gets the default value of the parameter for any user-defined or internal function or method. If the parameter is not optional a ReflectionException will be thrown.

参数

此函数没有参数。

返回值

The parameters default value.

更新日志

版本 | 说明
8.0.0 | This method now allows getting the default value of parameters of built-in functions and built-in class methods. Previously, a ReflectionException was thrown.

范例

Example #1 Getting default values of function parameters

<?php
function foo($test, $bar = 'baz')
{
    echo $test . $bar;
}

$function = new ReflectionFunction('foo');

foreach ($function->getParameters() as $param) {
    echo 'Name: ' . $param->getName() . PHP_EOL;
    if ($param->isOptional()) {
        echo 'Default value: ' . $param->getDefaultValue() . PHP_EOL;
    }
    echo PHP_EOL;
}
?>

以上例程会输出：

Name: test

Name: bar
Default value: baz

参见

  • ReflectionParameter::isOptional() - Checks if optional
  • ReflectionParameter::isDefaultValueAvailable() - 检查是否有默认值。
  • ReflectionParameter::getDefaultValueConstantName() - Returns the default value's constant name if default value is constant or null
  • ReflectionParameter::isPassedByReference() - Checks if passed by reference


Returns the default value's constant name if default value is constant or null

  • ? ReflectionParameter::getDefaultValue
  • ReflectionParameter::getName ?
  • PHP Manual
  • ReflectionParameter
  • Returns the default value's constant name if default value is constant or null

ReflectionParameter::getDefaultValueConstantName

(PHP 5 >= 5.4.6, PHP 7)

ReflectionParameter::getDefaultValueConstantName — Returns the default value's constant name if default value is constant or null

说明

public ReflectionParameter::getDefaultValueConstantName ( ) : string|null

Returns the default value's constant name of the parameter of any user-defined or internal function or method, if default value is constant or null. If the parameter is not optional a ReflectionException will be thrown.

参数

此函数没有参数。

返回值

Returns string on success or null on failure.

更新日志

版本 | 说明
8.0.0 | This method now allows getting the default values' constant names of built-in functions and built-in class methods. Previously, a ReflectionException was thrown.

范例

Example #1 Getting default values' constant names of function parameters

<?php
function foo($test, $bar = PHP_INT_MIN)
{
    echo $test . $bar;
}

$function = new ReflectionFunction('foo');

foreach ($function->getParameters() as $param) {
    echo 'Name: ' . $param->getName() . PHP_EOL;
    if ($param->isOptional()) {
        echo 'Default value: ' . $param->getDefaultValueConstantName() . PHP_EOL;
    }
    echo PHP_EOL;
}
?>

以上例程会输出：

Name: test

Name: bar
Default value: PHP_INT_MIN

参见

  • ReflectionParameter::isOptional() - Checks if optional
  • ReflectionParameter::isDefaultValueConstant() - Returns whether the default value of this parameter is a constant
  • ReflectionParameter::getDefaultValue() - Gets default parameter value


Gets parameter name

  • ? ReflectionParameter::getDefaultValueConstantName
  • ReflectionParameter::getPosition ?
  • PHP Manual
  • ReflectionParameter
  • Gets parameter name

ReflectionParameter::getName

(PHP 5, PHP 7)

ReflectionParameter::getName — Gets parameter name

说明

public ReflectionParameter::getName ( ) : string

Gets the name of the parameter.

参数

此函数没有参数。

返回值

The name of the reflected parameter.

参见

  • ReflectionParameter::getValue()


Gets parameter position

  • ? ReflectionParameter::getName
  • ReflectionParameter::getType ?
  • PHP Manual
  • ReflectionParameter
  • Gets parameter position

ReflectionParameter::getPosition

(PHP 5 >= 5.1.3, PHP 7)

ReflectionParameter::getPosition — Gets parameter position

说明

public ReflectionParameter::getPosition ( ) : int

Gets the position of the parameter.

参数

此函数没有参数。

返回值

The position of the parameter, left to right, starting at position #0.

参见

  • ReflectionParameter::getName() - Gets parameter name


Gets a parameter's type

  • ? ReflectionParameter::getPosition
  • ReflectionParameter::hasType ?
  • PHP Manual
  • ReflectionParameter
  • Gets a parameter's type

ReflectionParameter::getType

(PHP 7)

ReflectionParameter::getType — Gets a parameter's type

说明

public ReflectionParameter::getType ( ) : ReflectionType|null

Gets the associated type of a parameter.

参数

此函数没有参数。

返回值

Returns a ReflectionType object if a parameter type is specified, null otherwise.

范例

Example #1 ReflectionParameter::getType() Usage as of PHP 7.1.0

As of PHP 7.1.0, ReflectionType::__toString() is deprecated, and ReflectionParameter::getType() may return an instance of ReflectionNamedType. To get the name of the parameter type, ReflectionNamedType() is available in this case.

<?php
function someFunction(int $param, $param2) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();
$reflectionType1 = $reflectionParams[0]->getType();
$reflectionType2 = $reflectionParams[1]->getType();

assert($reflectionType1 instanceof ReflectionNamedType);
echo $reflectionType1->getName(), PHP_EOL;
var_dump($reflectionType2);
?>

以上例程会输出：

int
NULL

Example #2 ReflectionParameter::getType() Usage before PHP 7.1.0

<?php
function someFunction(int $param, $param2) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();
$reflectionType1 = $reflectionParams[0]->getType();
$reflectionType2 = $reflectionParams[1]->getType();

echo $reflectionType1, PHP_EOL;
var_dump($reflectionType2);
?>

以上例程在 PHP 7.0 中的输出：

int
NULL

参见

  • ReflectionParameter::hasType() - Checks if parameter has a type
  • ReflectionType::__toString() - To string


Checks if parameter has a type

  • ? ReflectionParameter::getType
  • ReflectionParameter::isArray ?
  • PHP Manual
  • ReflectionParameter
  • Checks if parameter has a type

ReflectionParameter::hasType

(PHP 7)

ReflectionParameter::hasType — Checks if parameter has a type

说明

public ReflectionParameter::hasType ( ) : bool

Checks if the parameter has a type associated with it.

参数

此函数没有参数。

返回值

true if a type is specified, false otherwise.

范例

Example #1 ReflectionParameter::hasType() example

<?php
function someFunction(string $param, $param2 = null) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();

var_dump($reflectionParams[0]->hasType());
var_dump($reflectionParams[1]->hasType());

以上例程的输出类似于：

bool(true)
bool(false)

参见

  • ReflectionParameter::getType() - Gets a parameter's type


Checks if parameter expects an array

  • ? ReflectionParameter::hasType
  • ReflectionParameter::isCallable ?
  • PHP Manual
  • ReflectionParameter
  • Checks if parameter expects an array

ReflectionParameter::isArray

(PHP 5 >= 5.1.2, PHP 7)

ReflectionParameter::isArray — Checks if parameter expects an array

Warning

本函数已自 PHP 8.0.0 起被废弃。强烈建议不要依赖本函数。

说明

public ReflectionParameter::isArray ( ) : bool

Checks if the parameter expects an array.

参数

此函数没有参数。

返回值

true if an array is expected, false otherwise.

参见

  • ReflectionParameter::isOptional() - Checks if optional


Returns whether parameter MUST be callable

  • ? ReflectionParameter::isArray
  • ReflectionParameter::isDefaultValueAvailable ?
  • PHP Manual
  • ReflectionParameter
  • Returns whether parameter MUST be callable

ReflectionParameter::isCallable

(PHP 5 >= 5.4.0, PHP 7)

ReflectionParameter::isCallable — Returns whether parameter MUST be callable

Warning

本函数已自 PHP 8.0.0 起被废弃。强烈建议不要依赖本函数。

说明

public ReflectionParameter::isCallable ( ) : bool

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

Returns true if the parameter is callable, false if it is not or null on failure.


检查是否有默认值。

  • ? ReflectionParameter::isCallable
  • ReflectionParameter::isDefaultValueConstant ?
  • PHP Manual
  • ReflectionParameter
  • 检查是否有默认值。

ReflectionParameter::isDefaultValueAvailable

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::isDefaultValueAvailable — 检查是否有默认值。

说明

public ReflectionParameter::isDefaultValueAvailable ( ) : bool

检查参数是否有默认值。

参数

此函数没有参数。

返回值

如果有默认值返回，true if a default value is available, 否则返回 false

参见

  • ReflectionParameter::getDefaultValue() - Gets default parameter value
  • ReflectionParameter::getName() - Gets parameter name


Returns whether the default value of this parameter is a constant

  • ? ReflectionParameter::isDefaultValueAvailable
  • ReflectionParameter::isOptional ?
  • PHP Manual
  • ReflectionParameter
  • Returns whether the default value of this parameter is a constant

ReflectionParameter::isDefaultValueConstant

(PHP 5 >= 5.4.6, PHP 7)

ReflectionParameter::isDefaultValueConstant — Returns whether the default value of this parameter is a constant

说明

public ReflectionParameter::isDefaultValueConstant ( ) : bool

Returns whether the default value of this parameter is a constant.

参数

此函数没有参数。

返回值

Returns true if the default value is constant, and false otherwise.

参见

  • ReflectionParameter::getDefaultValueConstantName() - Returns the default value's constant name if default value is constant or null
  • ReflectionParameter::isDefaultValueAvailable() - 检查是否有默认值。


Checks if optional

  • ? ReflectionParameter::isDefaultValueConstant
  • ReflectionParameter::isPassedByReference ?
  • PHP Manual
  • ReflectionParameter
  • Checks if optional

ReflectionParameter::isOptional

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::isOptional — Checks if optional

说明

public ReflectionParameter::isOptional ( ) : bool

Checks if the parameter is optional.

参数

此函数没有参数。

返回值

true if the parameter is optional, otherwise false

参见

  • ReflectionParameter::getName() - Gets parameter name


Checks if passed by reference

  • ? ReflectionParameter::isOptional
  • ReflectionParameter::isVariadic ?
  • PHP Manual
  • ReflectionParameter
  • Checks if passed by reference

ReflectionParameter::isPassedByReference

(PHP 5, PHP 7)

ReflectionParameter::isPassedByReference — Checks if passed by reference

说明

public ReflectionParameter::isPassedByReference ( ) : bool

Checks if the parameter is passed in by reference.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true if the parameter is passed in by reference, otherwise false

参见

  • ReflectionParameter::getName() - Gets parameter name


Checks if the parameter is variadic

  • ? ReflectionParameter::isPassedByReference
  • ReflectionParameter::__toString ?
  • PHP Manual
  • ReflectionParameter
  • Checks if the parameter is variadic

ReflectionParameter::isVariadic

(PHP 5 >= 5.6.0, PHP 7)

ReflectionParameter::isVariadic — Checks if the parameter is variadic

说明

public ReflectionParameter::isVariadic ( ) : bool

Checks if the parameter was declared as a variadic parameter.

参数

此函数没有参数。

返回值

Returns true if the parameter is variadic, otherwise false.


To string

  • ? ReflectionParameter::isVariadic
  • ReflectionProperty ?
  • PHP Manual
  • ReflectionParameter
  • To string

ReflectionParameter::__toString

(PHP 5, PHP 7)

ReflectionParameter::__toString — To string

说明

public ReflectionParameter::__toString ( ) : string

To string.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

参见

  • ReflectionParameter::export() - Exports
  • __toString()


ReflectionProperty 类

(PHP 5, PHP 7)

简介

ReflectionProperty 类报告了类的属性的相关信息。

类摘要

ReflectionProperty implements Reflector {
/* 常量 */
const integer IS_STATIC = 1 ;
const integer IS_PUBLIC = 256 ;
const integer IS_PROTECTED = 512 ;
const integer IS_PRIVATE = 1024 ;
/* 属性 */
public $name ;
public $class ;
/* 方法 */
final private __clone ( ) : void
public static export ( mixed $class , string $name , bool $return = ? ) : string
public getDeclaringClass ( ) : ReflectionClass
public getDefaultValue ( ) : mixed
public getDocComment ( ) : string|false
public getModifiers ( ) : int
public getName ( ) : string
public getType ( ) : ReflectionType|null
public getValue ( object|null $object = null ) : mixed
public hasDefaultValue ( ) : bool
public hasType ( ) : bool
public isDefault ( ) : bool
public isInitialized ( object|null $object = null ) : bool
public isPrivate ( ) : bool
public isProtected ( ) : bool
public isPublic ( ) : bool
public isStatic ( ) : bool
public setAccessible ( bool $accessible ) : void
public setValue ( object $object , mixed $value ) : void
public __toString ( ) : string
}

属性

name

属性的名称。只读，在尝试赋值的时候抛出 ReflectionException。

class

定义的属性所在的类。只读，在尝试赋值的时候抛出 ReflectionException。

预定义常量

ReflectionProperty 修饰符

ReflectionProperty::IS_STATIC

指示了 static 的属性。

ReflectionProperty::IS_PUBLIC

指示了 public 的属性。

ReflectionProperty::IS_PROTECTED

指示了 protected 的属性。

ReflectionProperty::IS_PRIVATE

指示了 private 的属性。

Table of Contents

  • ReflectionProperty::__clone — Clone
  • ReflectionProperty::__construct — Construct a ReflectionProperty object
  • ReflectionProperty::export — Export
  • ReflectionProperty::getDeclaringClass — Gets declaring class
  • ReflectionProperty::getDefaultValue — Returns the default value declared for a property
  • ReflectionProperty::getDocComment — Gets the property doc comment
  • ReflectionProperty::getModifiers — Gets the property modifiers
  • ReflectionProperty::getName — Gets property name
  • ReflectionProperty::getType — Gets a property's type
  • ReflectionProperty::getValue — Gets value
  • ReflectionProperty::hasDefaultValue — Checks if property has a default value declared
  • ReflectionProperty::hasType — Checks if property has a type
  • ReflectionProperty::isDefault — Checks if property is a default property
  • ReflectionProperty::isInitialized — Checks whether a property is initialized
  • ReflectionProperty::isPrivate — Checks if property is private
  • ReflectionProperty::isProtected — Checks if property is protected
  • ReflectionProperty::isPublic — Checks if property is public
  • ReflectionProperty::isStatic — Checks if property is static
  • ReflectionProperty::setAccessible — Set property accessibility
  • ReflectionProperty::setValue — Set property value
  • ReflectionProperty::__toString — To string


Clone

  • ? ReflectionProperty
  • ReflectionProperty::__construct ?
  • PHP Manual
  • ReflectionProperty
  • Clone

ReflectionProperty::__clone

(PHP 5, PHP 7)

ReflectionProperty::__clone — Clone

说明

final private ReflectionProperty::__clone ( ) : void

Clones.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

参见

  • ReflectionProperty::export() - Export
  • Object cloning


Construct a ReflectionProperty object

  • ? ReflectionProperty::__clone
  • ReflectionProperty::export ?
  • PHP Manual
  • ReflectionProperty
  • Construct a ReflectionProperty object

ReflectionProperty::__construct

(PHP 5, PHP 7)

ReflectionProperty::__construct — Construct a ReflectionProperty object

说明

public ReflectionProperty::__construct ( object|string $class , string $property )

Warning

本函数还未编写文档，仅有参数列表。

参数

class

Either a string containing the name of the class to reflect, or an object.

property

The name of the property being reflected.

返回值

没有返回值。

错误／异常

Trying to get or set private or protected class property's values will result in an exception being thrown.

范例

Example #1 ReflectionProperty::__construct() example

<?php
class Str
{
    public $length  = 5;
}

// Create an instance of the ReflectionProperty class
$prop = new ReflectionProperty('Str', 'length');

// Print out basic information
printf(
    "===> The%s%s%s%s property '%s' (which was %s)\n" .
    "     having the modifiers %s\n",
        $prop->isPublic() ? ' public' : '',
        $prop->isPrivate() ? ' private' : '',
        $prop->isProtected() ? ' protected' : '',
        $prop->isStatic() ? ' static' : '',
        $prop->getName(),
        $prop->isDefault() ? 'declared at compile-time' : 'created at run-time',
        var_export(Reflection::getModifierNames($prop->getModifiers()), 1)
);

// Create an instance of Str
$obj= new Str();

// Get current value
printf("---> Value is: ");
var_dump($prop->getValue($obj));

// Change value
$prop->setValue($obj, 10);
printf("---> Setting value to 10, new value is: ");
var_dump($prop->getValue($obj));

// Dump object
var_dump($obj);
?>

以上例程的输出类似于：

===> The public property 'length' (which was declared at compile-time)
     having the modifiers array (
  0 => 'public',
)
---> Value is: int(5)
---> Setting value to 10, new value is: int(10)
object(Str)#2 (1) {
  ["length"]=>
  int(10)
}

Example #2 Getting value from private and protected properties using ReflectionProperty class

<?php

class Foo {
    public $x = 1;
    protected $y = 2;
    private $z = 3;
}

$obj = new Foo;

$prop = new ReflectionProperty('Foo', 'y');
$prop->setAccessible(true); /* As of PHP 5.3.0 */
var_dump($prop->getValue($obj)); // int(2)

$prop = new ReflectionProperty('Foo', 'z');
$prop->setAccessible(true); /* As of PHP 5.3.0 */
var_dump($prop->getValue($obj)); // int(2)

?>

以上例程的输出类似于：

int(2)
int(3)

参见

  • ReflectionProperty::getName() - Gets property name
  • Constructors


Export

  • ? ReflectionProperty::__construct
  • ReflectionProperty::getDeclaringClass ?
  • PHP Manual
  • ReflectionProperty
  • Export

ReflectionProperty::export

(PHP 5, PHP 7)

ReflectionProperty::export — Export

说明

public static ReflectionProperty::export ( mixed $class , string $name , bool $return = ? ) : string

Exports a reflection.

Warning

本函数还未编写文档，仅有参数列表。

参数

argument

导出的反射。

name

The property name.

return

设为 true 时返回导出结果，设为 false（默认值）则忽略返回。

返回值

参见

  • ReflectionProperty::__toString() - To string


Gets declaring class

  • ? ReflectionProperty::export
  • ReflectionProperty::getDefaultValue ?
  • PHP Manual
  • ReflectionProperty
  • Gets declaring class

ReflectionProperty::getDeclaringClass

(PHP 5, PHP 7)

ReflectionProperty::getDeclaringClass — Gets declaring class

说明

public ReflectionProperty::getDeclaringClass ( ) : ReflectionClass

Gets the declaring class.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A ReflectionClass object.

参见

  • ReflectionProperty::getName() - Gets property name


Returns the default value declared for a property

  • ? ReflectionProperty::getDeclaringClass
  • ReflectionProperty::getDocComment ?
  • PHP Manual
  • ReflectionProperty
  • Returns the default value declared for a property

ReflectionProperty::getDefaultValue

(PHP 8)

ReflectionProperty::getDefaultValue — Returns the default value declared for a property

说明

public ReflectionProperty::getDefaultValue ( ) : mixed

Gets the implicit or explicitly declared default value for a property.

参数

此函数没有参数。

返回值

The default value if the property has any default value (including null). If there is no default value, then null is returned. It is not possible to differentiate between a null default value and an unitialized typed property. Use ReflectionClass::hasDefaultValue() to detect the difference.

范例

Example #1 ReflectionClass::getDefaultValue() example

<?php
class Foo {
    public $bar = 1;
    public ?int $baz;
    public int $boing = 0;
}

$ro = new ReflectionClass(Foo::class);
var_dump($ro->getProperty('bar')->getDefaultValue());
var_dump($ro->getProperty('baz')->getDefaultValue());
var_dump($ro->getProperty('boing')->getDefaultValue());
?>

以上例程会输出：

int(1)
NULL
int(0)

参见

  • ReflectionProperty::hasDefaultValue() - Checks if property has a default value declared


Gets the property doc comment

  • ? ReflectionProperty::getDefaultValue
  • ReflectionProperty::getModifiers ?
  • PHP Manual
  • ReflectionProperty
  • Gets the property doc comment

ReflectionProperty::getDocComment

(PHP 5 >= 5.1.0, PHP 7)

ReflectionProperty::getDocComment — Gets the property doc comment

说明

public ReflectionProperty::getDocComment ( ) : string|false

Gets the doc comment for a property.

参数

此函数没有参数。

返回值

The doc comment if it exists, otherwise false.

范例

Example #1 ReflectionProperty::getDocComment() example

<?php
class Str
{
    /**
     * @var int  The length of the string
     */
    public $length = 5;
}

$prop = new ReflectionProperty('Str', 'length');

var_dump($prop->getDocComment());

?>

以上例程的输出类似于：

string(53) "/**
     * @var int  The length of the string
     */"

Example #2 Multiple property declarations

If multiple property declarations are preceeded by a single doc comment, the doc comment refers to the first property only.

<?php
class Foo
{
    /** @var string */
    public $a, $b;
}
$class = new \ReflectionClass('Foo');
foreach ($class->getProperties() as $property) {
    echo $property->getName() . ': ' . var_export($property->getDocComment(), true) . PHP_EOL;
}
?>

以上例程会输出：

a: '/** @var string */'
b: false

参见

  • ReflectionProperty::getModifiers() - Gets the property modifiers
  • ReflectionProperty::getName() - Gets property name
  • ReflectionProperty::getValue() - Gets value


Gets the property modifiers

  • ? ReflectionProperty::getDocComment
  • ReflectionProperty::getName ?
  • PHP Manual
  • ReflectionProperty
  • Gets the property modifiers

ReflectionProperty::getModifiers

(PHP 5, PHP 7)

ReflectionProperty::getModifiers — Gets the property modifiers

说明

public ReflectionProperty::getModifiers ( ) : int

Gets the modifiers.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

A numeric representation of the modifiers.

参见

  • ReflectionProperty::isPrivate() - Checks if property is private
  • Reflection::getModifierNames() - 获取修饰符的名称


Gets property name

  • ? ReflectionProperty::getModifiers
  • ReflectionProperty::getType ?
  • PHP Manual
  • ReflectionProperty
  • Gets property name

ReflectionProperty::getName

(PHP 5, PHP 7)

ReflectionProperty::getName — Gets property name

说明

public ReflectionProperty::getName ( ) : string

Gets the properties name.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

The name of the reflected property.

参见

  • ReflectionProperty::getValue() - Gets value


Gets a property's type

  • ? ReflectionProperty::getName
  • ReflectionProperty::getValue ?
  • PHP Manual
  • ReflectionProperty
  • Gets a property's type

ReflectionProperty::getType

(PHP 7 >= 7.4.0)

ReflectionProperty::getType — Gets a property's type

说明

public ReflectionProperty::getType ( ) : ReflectionType|null

Gets the associated type of a property.

参数

此函数没有参数。

返回值

Returns a ReflectionType if the property has a type, and null otherwise.

范例

Example #1 ReflectionProperty::getType() example

<?php
class User
{
    public string $name;
}

$rp = new ReflectionProperty('User', 'name');
echo $rp->getType()->getName();
?>

以上例程会输出：

string

参见

  • ReflectionProperty::hasType() - Checks if property has a type
  • ReflectionProperty::isInitialized() - Checks whether a property is initialized


Gets value

  • ? ReflectionProperty::getType
  • ReflectionProperty::hasDefaultValue ?
  • PHP Manual
  • ReflectionProperty
  • Gets value

ReflectionProperty::getValue

(PHP 5, PHP 7)

ReflectionProperty::getValue — Gets value

说明

public ReflectionProperty::getValue ( object|null $object = null ) : mixed

Gets the property's value.

参数

object

If the property is non-static an object must be provided to fetch the property from. If you want to fetch the default property without providing an object use ReflectionClass::getDefaultProperties() instead.

返回值

The current value of the property.

错误／异常

Throws a ReflectionException if the property is inaccessible. You can make a protected or private property accessible using ReflectionProperty::setAccessible().

更新日志

版本 | 说明
8.0.0 | object is nullable now.

范例

Example #1 ReflectionProperty::getValue() example

<?php
class Foo {
    public static $staticProperty = 'foobar';

    public $property = 'barfoo';
    protected $privateProperty = 'foofoo';
}

$reflectionClass = new ReflectionClass('Foo');

var_dump($reflectionClass->getProperty('staticProperty')->getValue());
var_dump($reflectionClass->getProperty('property')->getValue(new Foo));

$reflectionProperty = $reflectionClass->getProperty('privateProperty');
$reflectionProperty->setAccessible(true);
var_dump($reflectionProperty->getValue(new Foo));
?>

以上例程会输出：

string(6) "foobar"
string(6) "barfoo"
string(6) "foofoo"

参见

  • ReflectionProperty::setValue() - Set property value
  • ReflectionProperty::setAccessible() - Set property accessibility
  • ReflectionClass::getDefaultProperties() - 获取默认属性
  • ReflectionClass::getStaticPropertyValue() - 获取静态（static）属性的值


Checks if property has a default value declared

  • ? ReflectionProperty::getValue
  • ReflectionProperty::hasType ?
  • PHP Manual
  • ReflectionProperty
  • Checks if property has a default value declared

ReflectionProperty::hasDefaultValue

(PHP 8)

ReflectionProperty::hasDefaultValue — Checks if property has a default value declared

说明

public ReflectionProperty::hasDefaultValue ( ) : bool

Checks whether the property was declared with a default value, including an implicit null default value. Only returns false for typed properties without default value (or dynamic properties).

参数

此函数没有参数。

返回值

If the property has any default value (including null) true is returned; if the property is typed without a default value declared or is a dynamic property, false is returned.

范例

Example #1 ReflectionClass::hasDefaultValue() example

<?php
class Foo {
    public $bar;
    public ?int $baz;
    public ?int $foo = null;
    public int $boing;

    public function __construct()
    {
        $this->ping = '';
    }
}

$ro = new ReflectionObject(new Foo());
var_dump($ro->getProperty('bar')->hasDefaultValue());
var_dump($ro->getProperty('baz')->hasDefaultValue());
var_dump($ro->getProperty('foo')->hasDefaultValue());
var_dump($ro->getProperty('boing')->hasDefaultValue());
var_dump($ro->getProperty('ping')->hasDefaultValue()); // Dynamic property
var_dump($ro->getProperty('pong')->hasDefaultValue()); // Not defined property
?>

以上例程会输出：

bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

Fatal error: Uncaught ReflectionException: Property Foo::$pong does not exist in example.php

参见

  • ReflectionProperty::getDefaultValue() - Returns the default value declared for a property


Checks if property has a type

  • ? ReflectionProperty::hasDefaultValue
  • ReflectionProperty::isDefault ?
  • PHP Manual
  • ReflectionProperty
  • Checks if property has a type

ReflectionProperty::hasType

(PHP 7 >= 7.4.0)

ReflectionProperty::hasType — Checks if property has a type

说明

public ReflectionProperty::hasType ( ) : bool

Checks if the property has a type associated with it.

参数

此函数没有参数。

返回值

true if a type is specified, false otherwise.

范例

Example #1 ReflectionProperty::hasType() example

<?php
class User
{
    public string $name;
}

$rp = new ReflectionProperty('User', 'name');
var_dump($rp->hasType());
?>

以上例程会输出：

bool(true)

参见

  • ReflectionProperty::getType() - Gets a property's type
  • ReflectionProperty::isInitialized() - Checks whether a property is initialized


Checks if property is a default property

  • ? ReflectionProperty::hasType
  • ReflectionProperty::isInitialized ?
  • PHP Manual
  • ReflectionProperty
  • Checks if property is a default property

ReflectionProperty::isDefault

(PHP 5, PHP 7)

ReflectionProperty::isDefault — Checks if property is a default property

说明

public ReflectionProperty::isDefault ( ) : bool

Checks whether the property was declared at compile-time, or whether the property was dynamically declared at run-time.

参数

此函数没有参数。

返回值

true if the property was declared at compile-time, or false if it was created at run-time.

范例

Example #1 ReflectionClass::isDefault() example

<?php
class Foo {
    public $bar;
}

$o = new Foo();
$o->bar = 42;
$o->baz = 42;

$ro = new ReflectionObject($o);
var_dump($ro->getProperty('bar')->isDefault());
var_dump($ro->getProperty('baz')->isDefault());
?>

以上例程会输出：

bool(true)
bool(false)

参见

  • ReflectionProperty::getValue() - Gets value


Checks whether a property is initialized

  • ? ReflectionProperty::isDefault
  • ReflectionProperty::isPrivate ?
  • PHP Manual
  • ReflectionProperty
  • Checks whether a property is initialized

ReflectionProperty::isInitialized

(PHP 7 >= 7.4.0)

ReflectionProperty::isInitialized — Checks whether a property is initialized

说明

public ReflectionProperty::isInitialized ( object|null $object = null ) : bool

Checks whether a property is initialized.

参数

object

If the property is non-static an object must be provided to fetch the property from.

返回值

Returns false for typed properties prior to initialization, and for properties that have been explicitly unset(). For all other properties true will be returned.

错误／异常

Throws a ReflectionException if the property is inaccessible. You can make a protected or private property accessible using ReflectionProperty::setAccessible().

更新日志

版本 | 说明
8.0.0 | object is nullable now.

范例

Example #1 ReflectionProperty::isInitialized() example

<?php
class User
{
    public string $name;
}

$rp = new ReflectionProperty('User', 'name');
$user = new User;
var_dump($rp->isInitialized($user));
$user->name = 'Nikita';
var_dump($rp->isInitialized($user));
?>

以上例程会输出：

bool(false)
bool(true)

参见

  • ReflectionProperty::hasType() - Checks if property has a type


Checks if property is private

  • ? ReflectionProperty::isInitialized
  • ReflectionProperty::isProtected ?
  • PHP Manual
  • ReflectionProperty
  • Checks if property is private

ReflectionProperty::isPrivate

(PHP 5, PHP 7)

ReflectionProperty::isPrivate — Checks if property is private

说明

public ReflectionProperty::isPrivate ( ) : bool

Checks whether the property is private.

参数

此函数没有参数。

返回值

true if the property is private, false otherwise.

参见

  • ReflectionProperty::isPublic() - Checks if property is public
  • ReflectionProperty::isProtected() - Checks if property is protected
  • ReflectionProperty::isStatic() - Checks if property is static


Checks if property is protected

  • ? ReflectionProperty::isPrivate
  • ReflectionProperty::isPublic ?
  • PHP Manual
  • ReflectionProperty
  • Checks if property is protected

ReflectionProperty::isProtected

(PHP 5, PHP 7)

ReflectionProperty::isProtected — Checks if property is protected

说明

public ReflectionProperty::isProtected ( ) : bool

Checks whether the property is protected.

参数

此函数没有参数。

返回值

true if the property is protected, false otherwise.

参见

  • ReflectionProperty::isPublic() - Checks if property is public
  • ReflectionProperty::isPrivate() - Checks if property is private
  • ReflectionProperty::isStatic() - Checks if property is static


Checks if property is public

  • ? ReflectionProperty::isProtected
  • ReflectionProperty::isStatic ?
  • PHP Manual
  • ReflectionProperty
  • Checks if property is public

ReflectionProperty::isPublic

(PHP 5, PHP 7)

ReflectionProperty::isPublic — Checks if property is public

说明

public ReflectionProperty::isPublic ( ) : bool

Checks whether the property is public.

参数

此函数没有参数。

返回值

true if the property is public, false otherwise.

参见

  • ReflectionProperty::isProtected() - Checks if property is protected
  • ReflectionProperty::isPrivate() - Checks if property is private
  • ReflectionProperty::isStatic() - Checks if property is static


Checks if property is static

  • ? ReflectionProperty::isPublic
  • ReflectionProperty::setAccessible ?
  • PHP Manual
  • ReflectionProperty
  • Checks if property is static

ReflectionProperty::isStatic

(PHP 5, PHP 7)

ReflectionProperty::isStatic — Checks if property is static

说明

public ReflectionProperty::isStatic ( ) : bool

Checks whether the property is static.

参数

此函数没有参数。

返回值

true if the property is static, false otherwise.

参见

  • ReflectionProperty::isPublic() - Checks if property is public
  • ReflectionProperty::isProtected() - Checks if property is protected
  • ReflectionProperty::isPrivate() - Checks if property is private


Set property accessibility

  • ? ReflectionProperty::isStatic
  • ReflectionProperty::setValue ?
  • PHP Manual
  • ReflectionProperty
  • Set property accessibility

ReflectionProperty::setAccessible

(PHP 5 >= 5.3.0, PHP 7)

ReflectionProperty::setAccessible — Set property accessibility

说明

public ReflectionProperty::setAccessible ( bool $accessible ) : void

Enables access to a protected or private property via the ReflectionProperty::getValue() and ReflectionProperty::setValue() methods.

参数

accessible

true to allow accessibility, or false.

返回值

没有返回值。

范例

Example #1 Simple Class definition

<?php
class MyClass
{
    private $foo = 'bar';
}

$property = new ReflectionProperty("MyClass", "foo");
$property->setAccessible(true);

$obj = new MyClass();
echo $property->getValue($obj);
echo $obj->foo;
?>

以上例程的输出类似于：

bar
Fatal error: Uncaught Error: Cannot access private property MyClass::$foo in /in/WJqTv:12

参见

  • ReflectionProperty::isPrivate() - Checks if property is private
  • ReflectionProperty::isProtected() - Checks if property is protected


Set property value

  • ? ReflectionProperty::setAccessible
  • ReflectionProperty::__toString ?
  • PHP Manual
  • ReflectionProperty
  • Set property value

ReflectionProperty::setValue

(PHP 5, PHP 7)

ReflectionProperty::setValue — Set property value

说明

public ReflectionProperty::setValue ( object $object , mixed $value ) : void
public ReflectionProperty::setValue ( mixed $value ) : void

Sets (changes) the property's value.

参数

object

If the property is non-static an object must be provided to change the property on. If the property is static this parameter is left out and only value needs to be provided.

value

The new value.

返回值

没有返回值。

错误／异常

Throws a ReflectionException if the property is inaccessible. You can make a protected or private property accessible using ReflectionProperty::setAccessible().

范例

Example #1 ReflectionProperty::setValue() example

<?php
class Foo {
    public static $staticProperty;

    public $property;
    protected $privateProperty;
}

$reflectionClass = new ReflectionClass('Foo');

$reflectionClass->getProperty('staticProperty')->setValue('foo');
var_dump(Foo::$staticProperty);

$foo = new Foo;

$reflectionClass->getProperty('property')->setValue($foo, 'bar');
var_dump($foo->property);

$reflectionProperty = $reflectionClass->getProperty('privateProperty');
$reflectionProperty->setAccessible(true);
$reflectionProperty->setValue($foo, 'foobar');
var_dump($reflectionProperty->getValue($foo));
?>

以上例程会输出：

string(3) "foo"
string(3) "bar"
string(6) "foobar"

参见

  • ReflectionProperty::getValue() - Gets value
  • ReflectionProperty::setAccessible() - Set property accessibility
  • ReflectionClass::setStaticPropertyValue() - 设置静态属性的值


To string

  • ? ReflectionProperty::setValue
  • ReflectionType ?
  • PHP Manual
  • ReflectionProperty
  • To string

ReflectionProperty::__toString

(PHP 5, PHP 7)

ReflectionProperty::__toString — To string

说明

public ReflectionProperty::__toString ( ) : string

To string.

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

参见

  • __toString()


The ReflectionType class

(PHP 7)

简介

ReflectionType 类用于获取函数、类方法的参数或者返回值的类型。

类摘要

ReflectionType {
/* 方法 */
public allowsNull ( ) : bool
public __toString ( ) : string
}

Table of Contents

  • ReflectionType::allowsNull — Checks if null is allowed
  • ReflectionType::__toString — To string


Checks if null is allowed

  • ? ReflectionType
  • ReflectionType::__toString ?
  • PHP Manual
  • ReflectionType
  • Checks if null is allowed

ReflectionType::allowsNull

(PHP 7)

ReflectionType::allowsNull — Checks if null is allowed

说明

public ReflectionType::allowsNull ( ) : bool

Checks whether the parameter allows null.

参数

此函数没有参数。

返回值

true if null is allowed, otherwise false

范例

Example #1 ReflectionType::allowsNull() example

<?php
function someFunction(string $param, StdClass $param2 = null) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();

var_dump($reflectionParams[0]->getType()->allowsNull());
var_dump($reflectionParams[1]->getType()->allowsNull());

以上例程会输出：

bool(false)
bool(true)

参见

  • ReflectionNamedType::isBuiltin()
  • ReflectionType::__toString() - To string
  • ReflectionParameter::getType() - Gets a parameter's type


To string

  • ? ReflectionType::allowsNull
  • ReflectionGenerator ?
  • PHP Manual
  • ReflectionType
  • To string

ReflectionType::__toString

(PHP 7)

ReflectionType::__toString — To string

Warning

本函数已自 PHP 7.1.0 起废弃。强烈建议不要使用本函数。

说明

public ReflectionType::__toString ( ) : string

Gets the parameter type name.

参数

此函数没有参数。

返回值

Returns the type of the parameter.

范例

Example #1 ReflectionType::__toString() example

<?php
function someFunction(string $param) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParam = $reflectionFunc->getParameters()[0];

echo $reflectionParam->getType();

以上例程的输出类似于：

string

更新日志

版本 | 说明
7.1.0 | ReflectionType::__toString() has been deprecated.

参见

  • ReflectionNamedType::getName()
  • ReflectionNamedType::isBuiltin()
  • ReflectionType::allowsNull() - Checks if null is allowed
  • ReflectionUnionType::getTypes()
  • ReflectionParameter::getType() - Gets a parameter's type


生成器反射类

(PHP 7)

简介

ReflectionGenerator类用于获取生成器的信息。

类摘要

ReflectionGenerator {
/* 方法 */
public getExecutingFile ( ) : string
public getExecutingGenerator ( ) : Generator
public getExecutingLine ( ) : int
public getFunction ( ) : ReflectionFunctionAbstract
public getThis ( ) : object|null
public getTrace ( int $options = DEBUG_BACKTRACE_PROVIDE_OBJECT ) : array
}

Table of Contents

  • ReflectionGenerator::__construct — Constructs a ReflectionGenerator object
  • ReflectionGenerator::getExecutingFile — Gets the file name of the currently executing generator
  • ReflectionGenerator::getExecutingGenerator — Gets the executing Generator object
  • ReflectionGenerator::getExecutingLine — Gets the currently executing line of the generator
  • ReflectionGenerator::getFunction — Gets the function name of the generator
  • ReflectionGenerator::getThis — Gets the $this value of the generator
  • ReflectionGenerator::getTrace — Gets the trace of the executing generator


Constructs a ReflectionGenerator object

  • ? ReflectionGenerator
  • ReflectionGenerator::getExecutingFile ?
  • PHP Manual
  • ReflectionGenerator
  • Constructs a ReflectionGenerator object

ReflectionGenerator::__construct

(PHP 7)

ReflectionGenerator::__construct — Constructs a ReflectionGenerator object

说明

public ReflectionGenerator::__construct ( Generator $generator )

Constructs a ReflectionGenerator object.

参数

generator

A generator object.

返回值

没有返回值。

范例

Example #1 ReflectionGenerator::__construct() example

<?php

function gen()
{
    yield 1;
}

$gen = gen();

$reflectionGen = new ReflectionGenerator($gen);

echo <<< output
{$reflectionGen->getFunction()->name}
Line: {$reflectionGen->getExecutingLine()}
File: {$reflectionGen->getExecutingFile()}
output;

以上例程的输出类似于：

gen
Line: 5
File: /path/to/file/example.php

参见

  • ReflectionGenerator::getFunction() - Gets the function name of the generator
  • ReflectionGenerator::getExecutingLine() - Gets the currently executing line of the generator
  • ReflectionGenerator::getExecutingFile() - Gets the file name of the currently executing generator


Gets the file name of the currently executing generator

  • ? ReflectionGenerator::__construct
  • ReflectionGenerator::getExecutingGenerator ?
  • PHP Manual
  • ReflectionGenerator
  • Gets the file name of the currently executing generator

ReflectionGenerator::getExecutingFile

(PHP 7)

ReflectionGenerator::getExecutingFile — Gets the file name of the currently executing generator

说明

public ReflectionGenerator::getExecutingFile ( ) : string

Get the full path and file name of the currently executing generator.

参数

此函数没有参数。

返回值

Returns the full path and file name of the currently executing generator.

范例

Example #1 ReflectionGenerator::getExecutingFile() example

<?php

class GenExample
{
    public function gen()
    {
        yield 1;
    }
}

$gen = (new GenExample)->gen();

$reflectionGen = new ReflectionGenerator($gen);

echo "File: {$reflectionGen->getExecutingFile()}";

以上例程的输出类似于：

File: /path/to/file/example.php

参见

  • ReflectionGenerator::getExecutingLine() - Gets the currently executing line of the generator
  • ReflectionGenerator::getExecutingGenerator() - Gets the executing Generator object


Gets the executing Generator object

  • ? ReflectionGenerator::getExecutingFile
  • ReflectionGenerator::getExecutingLine ?
  • PHP Manual
  • ReflectionGenerator
  • Gets the executing Generator object

ReflectionGenerator::getExecutingGenerator

(PHP 7)

ReflectionGenerator::getExecutingGenerator — Gets the executing Generator object

说明

public ReflectionGenerator::getExecutingGenerator ( ) : Generator

Get the executing Generator object

参数

此函数没有参数。

返回值

Returns the currently executing Generator object.

范例

Example #1 ReflectionGenerator::getExecutingGenerator() example

<?php

class GenExample
{
    public function gen()
    {
        yield 1;
    }
}

$gen = (new GenExample)->gen();

$reflectionGen = new ReflectionGenerator($gen);

$gen2 = $reflectionGen->getExecutingGenerator();

var_dump($gen2 === $gen);
var_dump($gen2->current());

以上例程的输出类似于：

bool(true)
int(1);

参见

  • ReflectionGenerator::getExecutingLine() - Gets the currently executing line of the generator
  • ReflectionGenerator::getExecutingFile() - Gets the file name of the currently executing generator


Gets the currently executing line of the generator

  • ? ReflectionGenerator::getExecutingGenerator
  • ReflectionGenerator::getFunction ?
  • PHP Manual
  • ReflectionGenerator
  • Gets the currently executing line of the generator

ReflectionGenerator::getExecutingLine

(PHP 7)

ReflectionGenerator::getExecutingLine — Gets the currently executing line of the generator

说明

public ReflectionGenerator::getExecutingLine ( ) : int

Get the currently executing line number of the generator.

参数

此函数没有参数。

返回值

Returns the line number of the currently executing statement in the generator.

范例

Example #1 ReflectionGenerator::getExecutingLine() example

<?php

class GenExample
{
    public function gen()
    {
        yield 1;
    }
}

$gen = (new GenExample)->gen();

$reflectionGen = new ReflectionGenerator($gen);

echo "Line: {$reflectionGen->getExecutingLine()}";

以上例程的输出类似于：

Line: 7

参见

  • ReflectionGenerator::getExecutingGenerator() - Gets the executing Generator object
  • ReflectionGenerator::getExecutingFile() - Gets the file name of the currently executing generator


Gets the function name of the generator

  • ? ReflectionGenerator::getExecutingLine
  • ReflectionGenerator::getThis ?
  • PHP Manual
  • ReflectionGenerator
  • Gets the function name of the generator

ReflectionGenerator::getFunction

(PHP 7)

ReflectionGenerator::getFunction — Gets the function name of the generator

说明

public ReflectionGenerator::getFunction ( ) : ReflectionFunctionAbstract

Enables the function name of the generator to be obtained by returning a class derived from ReflectionFunctionAbstract.

参数

此函数没有参数。

返回值

Returns a ReflectionFunctionAbstract class. This will be ReflectionFunction for functions, or ReflectionMethod for methods.

范例

Example #1 ReflectionGenerator::getFunction() example

<?php

function gen()
{
    yield 1;
}

$gen = gen();

$reflectionGen = new ReflectionGenerator($gen);

var_dump($reflectionGen->getFunction());

以上例程的输出类似于：

object(ReflectionFunction)#3 (1) {
  ["name"]=>
  string(3) "gen"
}

参见

  • ReflectionGenerator::getThis() - Gets the $this value of the generator
  • ReflectionGenerator::getTrace() - Gets the trace of the executing generator


Gets the $this value of the generator

  • ? ReflectionGenerator::getFunction
  • ReflectionGenerator::getTrace ?
  • PHP Manual
  • ReflectionGenerator
  • Gets the $this value of the generator

ReflectionGenerator::getThis

(PHP 7)

ReflectionGenerator::getThis — Gets the $this value of the generator

说明

public ReflectionGenerator::getThis ( ) : object|null

Get the $this value that the generator has access to.

参数

此函数没有参数。

返回值

Returns the $this value, or null if the generator was not created in a class context.

范例

Example #1 ReflectionGenerator::getThis() example

<?php

class GenExample
{
    public function gen()
    {
        yield 1;
    }
}

$gen = (new GenExample)->gen();

$reflectionGen = new ReflectionGenerator($gen);

var_dump($reflectionGen->getThis());

以上例程的输出类似于：

object(GenExample)#3 (0) {
}

参见

  • ReflectionGenerator::getFunction() - Gets the function name of the generator
  • ReflectionGenerator::getTrace() - Gets the trace of the executing generator


Gets the trace of the executing generator

  • ? ReflectionGenerator::getThis
  • Reflector ?
  • PHP Manual
  • ReflectionGenerator
  • Gets the trace of the executing generator

ReflectionGenerator::getTrace

(PHP 7)

ReflectionGenerator::getTrace — Gets the trace of the executing generator

说明

public ReflectionGenerator::getTrace ( int $options = DEBUG_BACKTRACE_PROVIDE_OBJECT ) : array

Get the trace of the currently executing generator.

参数

options

The value of options can be any of the following flags.

Available options
Option | Description
DEBUG_BACKTRACE_PROVIDE_OBJECT | Default.
DEBUG_BACKTRACE_IGNORE_ARGS | Don't include the argument information for functions in the stack trace.

返回值

Returns the trace of the currently executing generator.

范例

Example #1 ReflectionGenerator::getTrace() example

<?php
function foo() {
    yield 1;
}

function bar()
{
    yield from foo();
}

function baz()
{
    yield from bar();
}

$gen = baz();
$gen->valid(); // start the generator

var_dump((new ReflectionGenerator($gen))->getTrace());

以上例程的输出类似于：

array(2) {
  [0]=>
  array(4) {
    ["file"]=>
    string(18) "example.php"
    ["line"]=>
    int(8)
    ["function"]=>
    string(3) "foo"
    ["args"]=>
    array(0) {
    }
  }
  [1]=>
  array(4) {
    ["file"]=>
    string(18) "example.php"
    ["line"]=>
    int(12)
    ["function"]=>
    string(3) "bar"
    ["args"]=>
    array(0) {
    }
  }
}

参见

  • ReflectionGenerator::getFunction() - Gets the function name of the generator
  • ReflectionGenerator::getThis() - Gets the $this value of the generator


Reflector 接口

(PHP 5, PHP 7)

简介

Reflector 是一个接口，被所有可导出的反射类所实现（implement）。

类摘要

Reflector {
/* 方法 */
public static export ( ) : string
public __toString ( ) : string
}

Table of Contents

  • Reflector::export — Exports
  • Reflector::__toString — 转化成字符串


Exports

  • ? Reflector
  • Reflector::__toString ?
  • PHP Manual
  • Reflector
  • Exports

Reflector::export

(PHP 5, PHP 7)

Reflector::export — Exports

说明

public static Reflector::export ( ) : string

输出。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

参见

  • Reflection::__toString()


转化成字符串

  • ? Reflector::export
  • ReflectionException ?
  • PHP Manual
  • Reflector
  • 转化成字符串

Reflector::__toString

(PHP 5, PHP 7)

Reflector::__toString — 转化成字符串

说明

public Reflector::__toString ( ) : string

转化成字符串。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

参见

  • ReflectionProperty::export() - Export
  • __toString()


ReflectionException 类

(PHP 5, PHP 7)

简介

ReflectionException 类。

类摘要

ReflectionException extends Exception {
/* 属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


Variable handling

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Variable handling 函数
    • boolval — 获取变量的布尔值
    • debug_zval_dump — Dumps a string representation of an internal zend value to output
    • doubleval — floatval 的别名
    • empty — 检查一个变量是否为空
    • floatval — 获取变量的浮点值
    • get_defined_vars — 返回由所有已定义变量所组成的数组
    • get_resource_id — Returns an integer identifier for the given resource
    • get_resource_type — 返回资源（resource）类型
    • gettype — 获取变量的类型
    • intval — 获取变量的整数值
    • is_array — 检测变量是否是数组
    • is_bool — 检测变量是否是布尔值
    • is_callable — 检测参数是否为合法的可调用结构
    • is_countable — Verify that the contents of a variable is a countable value
    • is_double — is_float 的别名
    • is_float — 检测变量是否是浮点型
    • is_int — 检测变量是否是整数
    • is_integer — is_int 的别名
    • is_iterable — Verify that the contents of a variable is an iterable value
    • is_long — is_int 的别名
    • is_null — 检测变量是否为 null
    • is_numeric — 检测变量是否为数字或数字字符串
    • is_object — 检测变量是否是一个对象
    • is_real — is_float 的别名
    • is_resource — 检测变量是否为资源类型
    • is_scalar — 检测变量是否是一个标量
    • is_string — 检测变量是否是字符串
    • isset — 检测变量是否已设置并且非 null
    • print_r — 以易于理解的格式打印变量。
    • serialize — 产生一个可存储的值的表示
    • settype — 设置变量的类型
    • strval — 获取变量的字符串值
    • unserialize — 从已存储的表示中创建 PHP 的值
    • unset — 释放给定的变量
    • var_dump — 打印变量的相关信息
    • var_export — 输出或返回一个变量的字符串表示


简介

For information on how variables behave, see the Variables entry in the Language Reference section of the manual.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • Variable handling
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


运行时配置

这些函数的行为受 php.ini 中的设置影响。

变量配置选项
名字 | 默认 | 可修改范围 | 更新日志
unserialize_callback_func | NULL | PHP_INI_ALL | 自 PHP 4.2.0 起可用。
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

unserialize_callback_func string

如果解串行器发现有未定义类要被实例化，将会调用 unserialize() 回调函数（用该未定义类名作为参数）。如果指定函数不存在，或者此函数没有包含／实现该未定义类，则显示警告。所以仅在确实需要实现这样的回调函数时才设置该选项。

参见 unserialize() 和 Autoloading Objects.


  • ? 资源类型
  • Variable handling 函数 ?
  • PHP Manual
  • Variable handling
  • 预定义常量

预定义常量

此扩展没有定义常量。


Variable handling 函数

Table of Contents

  • boolval — 获取变量的布尔值
  • debug_zval_dump — Dumps a string representation of an internal zend value to output
  • doubleval — floatval 的别名
  • empty — 检查一个变量是否为空
  • floatval — 获取变量的浮点值
  • get_defined_vars — 返回由所有已定义变量所组成的数组
  • get_resource_id — Returns an integer identifier for the given resource
  • get_resource_type — 返回资源（resource）类型
  • gettype — 获取变量的类型
  • intval — 获取变量的整数值
  • is_array — 检测变量是否是数组
  • is_bool — 检测变量是否是布尔值
  • is_callable — 检测参数是否为合法的可调用结构
  • is_countable — Verify that the contents of a variable is a countable value
  • is_double — is_float 的别名
  • is_float — 检测变量是否是浮点型
  • is_int — 检测变量是否是整数
  • is_integer — is_int 的别名
  • is_iterable — Verify that the contents of a variable is an iterable value
  • is_long — is_int 的别名
  • is_null — 检测变量是否为 null
  • is_numeric — 检测变量是否为数字或数字字符串
  • is_object — 检测变量是否是一个对象
  • is_real — is_float 的别名
  • is_resource — 检测变量是否为资源类型
  • is_scalar — 检测变量是否是一个标量
  • is_string — 检测变量是否是字符串
  • isset — 检测变量是否已设置并且非 null
  • print_r — 以易于理解的格式打印变量。
  • serialize — 产生一个可存储的值的表示
  • settype — 设置变量的类型
  • strval — 获取变量的字符串值
  • unserialize — 从已存储的表示中创建 PHP 的值
  • unset — 释放给定的变量
  • var_dump — 打印变量的相关信息
  • var_export — 输出或返回一个变量的字符串表示


获取变量的布尔值

  • ? Variable handling 函数
  • debug_zval_dump ?
  • PHP Manual
  • Variable handling 函数
  • 获取变量的布尔值

boolval

(PHP 5 >= 5.5.0, PHP 7, PHP 8)

boolval — 获取变量的布尔值

说明

boolval ( mixed $value ) : bool

返回 value 的 bool 值。

参数

value

标量值会被转化成 bool 值。

返回值

value 的 bool 值。

范例

Example #1 boolval() examples

<?php
echo '0:        '.(boolval(0) ? 'true' : 'false')."\n";
echo '42:       '.(boolval(42) ? 'true' : 'false')."\n";
echo '0.0:      '.(boolval(0.0) ? 'true' : 'false')."\n";
echo '4.2:      '.(boolval(4.2) ? 'true' : 'false')."\n";
echo '"":       '.(boolval("") ? 'true' : 'false')."\n";
echo '"string": '.(boolval("string") ? 'true' : 'false')."\n";
echo '"0":      '.(boolval("0") ? 'true' : 'false')."\n";
echo '"1":      '.(boolval("1") ? 'true' : 'false')."\n";
echo '[1, 2]:   '.(boolval([1, 2]) ? 'true' : 'false')."\n";
echo '[]:       '.(boolval([]) ? 'true' : 'false')."\n";
echo 'stdClass: '.(boolval(new stdClass) ? 'true' : 'false')."\n";
?>

以上例程会输出：

0:        false
42:       true
0.0:      false
4.2:      true
"":       false
"string": true
"0":      false
"1":      true
[1, 2]:   true
[]:       false
stdClass: true

参见

  • floatval() - 获取变量的浮点值
  • intval() - 获取变量的整数值
  • strval() - 获取变量的字符串值
  • settype() - 设置变量的类型
  • is_bool() - 检测变量是否是布尔值
  • 类型转换的判别


Dumps a string representation of an internal zend value to output

  • ? boolval
  • doubleval ?
  • PHP Manual
  • Variable handling 函数
  • Dumps a string representation of an internal zend value to output

debug_zval_dump

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

debug_zval_dump — Dumps a string representation of an internal zend value to output

说明

debug_zval_dump ( mixed $value , mixed ...$values ) : void

Dumps a string representation of an internal zend value to output.

参数

value

The variable to dump.

values

Further variables to dump.

返回值

没有返回值。

范例

Example #1 debug_zval_dump() example

<?php
$var1 = 'Hello World';
$var2 = '';

$var2 =& $var1;

debug_zval_dump(&$var1);
?>

以上例程会输出：

&string(11) "Hello World" refcount(3)

Note: Beware the refcount

The refcount value returned by this function is non-obvious in certain circumstances. For example, a developer might expect the above example to indicate a refcount of 2. The third reference is created when actually calling debug_zval_dump().

This behavior is further compounded when a variable is not passed to debug_zval_dump() by reference. To illustrate, consider a slightly modified version of the above example:

<?php
$var1 = 'Hello World';
$var2 = '';

$var2 =& $var1;

debug_zval_dump($var1); // not passed by reference, this time
?>

以上例程会输出：

string(11) "Hello World" refcount(1)

Why refcount(1)? Because a copy of $var1 is being made, when the function is called.

This function becomes even more confusing when a variable with a refcount of 1 is passed (by copy/value):

<?php
$var1 = 'Hello World';

debug_zval_dump($var1);
?>

以上例程会输出：

string(11) "Hello World" refcount(2)

A refcount of 2, here, is extremely non-obvious. Especially considering the above examples. So what's happening?

When a variable has a single reference (as did $var1 before it was used as an argument to debug_zval_dump()), PHP's engine optimizes the manner in which it is passed to a function. Internally, PHP treats $var1 like a reference (in that the refcount is increased for the scope of this function), with the caveat that if the passed reference happens to be written to, a copy is made, but only at the moment of writing. This is known as "copy on write."

So, if debug_zval_dump() happened to write to its sole parameter (and it doesn't), then a copy would be made. Until then, the parameter remains a reference, causing the refcount to be incremented to 2 for the scope of the function call.

参见

  • var_dump() - 打印变量的相关信息
  • debug_backtrace() - 产生一条回溯跟踪(backtrace)
  • References Explained
  • » References Explained (by Derick Rethans)


floatval 的别名

  • ? debug_zval_dump
  • empty ?
  • PHP Manual
  • Variable handling 函数
  • floatval 的别名

doubleval

(PHP 4, PHP 5, PHP 7, PHP 8)

doubleval — floatval() 的别名

描述

此函数是 floatval() 的别名。

Note:

此别名是函数改名之后的遗留问题。在 PHP 旧的版本中由于还没有 floatval() 函数，所以你可能需要用到这个 floatval() 的别名函数。


检查一个变量是否为空

  • ? doubleval
  • floatval ?
  • PHP Manual
  • Variable handling 函数
  • 检查一个变量是否为空

empty

(PHP 4, PHP 5, PHP 7, PHP 8)

empty — 检查一个变量是否为空

说明

empty ( mixed $var ) : bool

判断一个变量是否被认为是空的。当一个变量并不存在，或者它的值等同于false，那么它会被认为不存在。如果变量不存在的话，empty()并不会产生警告。

参数

var

待检查的变量

Note:

在 PHP 5.5 之前，empty() 仅支持变量；任何其他东西将会导致一个解析错误。换言之，下列代码不会生效： empty(trim($name))。 作为替代，应该使用trim($name) == false.

没有警告会产生，哪怕变量并不存在。 这意味着 empty() 本质上与 !isset($var) || $var == false 等价。

返回值

当var存在，并且是一个非空非零的值时返回 false 否则返回 true.

以下的东西被认为是空的：

  • "" (空字符串)
  • 0 (作为整数的0)
  • 0.0 (作为浮点数的0)
  • "0" (作为字符串的0)
  • null
  • false
  • array() (一个空数组)
  • $var; (一个声明了，但是没有值的变量)

更新日志

版本 | 说明
5.5.0 | empty() 现在支持表达式了，而不仅仅是变量。
5.4.0 | 检查非数字的字符串偏移量会返回 true.

范例

Example #1 一个简单的 empty() 与 isset() 的比较。

<?php
$var = 0;

// Evaluates to true because $var is empty
if (empty($var)) {
    echo '$var is either 0, empty, or not set at all';
}

// Evaluates as true because $var is set
if (isset($var)) {
    echo '$var is set even though it is empty';
}
?>

Example #2 在字符串偏移量上使用empty()

PHP 5.4 修改了当传入的是字符串偏移量时， empty() 的行为

<?php
$expected_array_got_string = 'somestring';
var_dump(empty($expected_array_got_string['some_key']));
var_dump(empty($expected_array_got_string[0]));
var_dump(empty($expected_array_got_string['0']));
var_dump(empty($expected_array_got_string[0.5]));
var_dump(empty($expected_array_got_string['0.5']));
var_dump(empty($expected_array_got_string['0 Mostel']));
?>

以上例程在 PHP 5.3 中的输出：

bool(false)
bool(false)
bool(false)
bool(false)
bool(false)
bool(false)

以上例程在 PHP 5.4 中的输出：

bool(true)
bool(false)
bool(false)
bool(false)
bool(true)
bool(true)

注释

Note: 因为是一个语言构造器而不是一个函数，不能被 可变函数 调用。

Note:

当对一个不可见的对象属性使用 empty() 时， __isset() 方法如果存在的话，它将会被调用。

参见

  • isset() - 检测变量是否已设置并且非 null
  • __isset()
  • unset() - 释放给定的变量
  • array_key_exists() - 检查数组里是否有指定的键名或索引
  • count() - 计算数组中的单元数目，或对象中的属性个数
  • strlen() - 获取字符串长度
  • The type comparison tables


获取变量的浮点值

  • ? empty
  • get_defined_vars ?
  • PHP Manual
  • Variable handling 函数
  • 获取变量的浮点值

floatval

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

floatval — 获取变量的浮点值

描述

floatval ( mixed $var ) : float

返回变量 var 的 float 数值。

var 可以是任何标量类型。你不能将 floatval() 用于数组或对象。

<?php
$var = '122.34343The';
$float_value_of_var = floatval ($var);
print $float_value_of_var; // 打印出 122.34343
?>

参见 intval()、strval()、settype() 和 类型戏法。


返回由所有已定义变量所组成的数组

  • ? floatval
  • get_resource_id ?
  • PHP Manual
  • Variable handling 函数
  • 返回由所有已定义变量所组成的数组

get_defined_vars

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

get_defined_vars — 返回由所有已定义变量所组成的数组

描述

get_defined_vars ( ) : array

此函数返回一个包含所有已定义变量列表的多维数组，这些变量包括环境变量、服务器变量和用户定义的变量。

<?php
$b = array(1,1,2,3,5,8);

$arr = get_defined_vars();

// 打印 $b
print_r($arr["b"]);

// 打印 PHP 解释程序的路径（如果 PHP 作为 CGI 使用的话）
// 例如：/usr/local/bin/php
echo $arr["_"];

// 打印命令行参数（如果有的话）
print_r($arr["argv"]);

// 打印所有服务器变量
print_r($arr["_SERVER"]);

// 打印变量数组的所有可用键值
print_r(array_keys(get_defined_vars()));
?>

参见 get_defined_functions() 和 get_defined_constants()。


Returns an integer identifier for the given resource

  • ? get_defined_vars
  • get_resource_type ?
  • PHP Manual
  • Variable handling 函数
  • Returns an integer identifier for the given resource

get_resource_id

(PHP 8)

get_resource_id — Returns an integer identifier for the given resource

说明

get_resource_id ( resource $res ) : int

This function provides a type-safe way for generating the integer identifier for a resource.

参数

res

The evaluated resource handle.

返回值

The int identifier for the given res.

This function is essentially an int cast of res to make it easier to retrieve the resource ID.

范例

Example #1 get_resource_id() example

<?php
$handle = fopen('./storage/logs/lumen.log', 'rt');

echo (int) $handle . "\n\n";

echo get_resource_id($handle);

?>

以上例程会输出：

698

698

参见

  • get_resource_type() - 返回资源（resource）类型


返回资源（resource）类型

  • ? get_resource_id
  • gettype ?
  • PHP Manual
  • Variable handling 函数
  • 返回资源（resource）类型

get_resource_type

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

get_resource_type — 返回资源（resource）类型

描述

get_resource_type ( resource $handle ) : string

此函数返回一个字符串，用于表示传递给它的 resource 的类型。如果参数不是合法的 resource，将产生错误。

<?php
$c = mysql_connect();
echo get_resource_type($c)."\n";
// 打印：mysql link

$fp = fopen("foo","w");
echo get_resource_type($fp)."\n";
// 打印：file

$doc = new_xmldoc("1.0");
echo get_resource_type($doc->doc)."\n";
// 打印：domxml document
?>


获取变量的类型

  • ? get_resource_type
  • intval ?
  • PHP Manual
  • Variable handling 函数
  • 获取变量的类型

gettype

(PHP 4, PHP 5, PHP 7, PHP 8)

gettype — 获取变量的类型

说明

gettype ( mixed $value ) : string

返回 PHP value 变量的类型。 对于类型检查，请使用 is_* 函数。

参数

value

要检查类型的变量。

返回值

返回字符串，可能值为：

  • "boolean"
  • "integer"
  • "double" （由于历史原因，如果是浮点型，则返回 "double"，而不仅仅是 "float"）
  • "string"
  • "array"
  • "object"
  • "resource"
  • "resource (closed)" 自 PHP 7.2.0 起
  • "NULL"
  • "unknown type"

范例

Example #1 gettype() 示例

<?php

$data = array(1, 1., NULL, new stdClass, 'foo');

foreach ($data as $value) {
    echo gettype($value), "\n";
}

?>

以上例程的输出类似于：

integer
double
NULL
object
string

更新日志

版本 | 说明
7.2.0 | 现在，已关闭的资源报告为 'resource (closed)'。 此前，已关闭的资源报告为 'unknown type'。

参见

  • settype() - 设置变量的类型
  • get_class() - 返回对象的类名
  • is_array() - 检测变量是否是数组
  • is_bool() - 检测变量是否是布尔值
  • is_callable() - 检测参数是否为合法的可调用结构
  • is_float() - 检测变量是否是浮点型
  • is_int() - 检测变量是否是整数
  • is_null() - 检测变量是否为 null
  • is_numeric() - 检测变量是否为数字或数字字符串
  • is_object() - 检测变量是否是一个对象
  • is_resource() - 检测变量是否为资源类型
  • is_scalar() - 检测变量是否是一个标量
  • is_string() - 检测变量是否是字符串
  • function_exists() - 如果给定的函数已经被定义就返回 true
  • method_exists() - 检查类的方法是否存在


获取变量的整数值

  • ? gettype
  • is_array ?
  • PHP Manual
  • Variable handling 函数
  • 获取变量的整数值

intval

(PHP 4, PHP 5, PHP 7, PHP 8)

intval — 获取变量的整数值

说明

intval ( mixed $value , int $base = 10 ) : int

通过使用指定的进制 base 转换（默认是十进制），返回变量 value 的 int 数值。 intval() 不能用于 object，否则会产生 E_NOTICE 错误并返回 1。

参数

value

要转换成 integer 的数量值

base

转化所使用的进制

Note:

如果 base 是 0，通过检测 value 的格式来决定使用的进制：

  • 如果字符串包括了 "0x" (或 "0X") 的前缀，使用 16 进制 (hex)；否则，
  • 如果字符串以 "0" 开始，使用 8 进制(octal)；否则，
  • 将使用 10 进制 (decimal)。

返回值

成功时返回 value 的 integer 值，失败时返回 0。 空的 array 返回 0，非空的 array 返回 1。

最大的值取决于操作系统。 32 位系统最大带符号的 integer 范围是 -2147483648 到 2147483647。举例，在这样的系统上，intval('1000000000000') 会返回 2147483647。64 位系统上，最大带符号的 integer 值是 9223372036854775807。

字符串有可能返回 0，虽然取决于字符串最左侧的字符。 使用 整型转换 的共同规则。

范例

Example #1 intval() 例子

下面的例子运行于 32 位系统上。

<?php
echo intval(42);                      // 42
echo intval(4.2);                     // 4
echo intval('42');                    // 42
echo intval('+42');                   // 42
echo intval('-42');                   // -42
echo intval(042);                     // 34
echo intval('042');                   // 42
echo intval(1e10);                    // 1410065408
echo intval('1e10');                  // 1
echo intval(0x1A);                    // 26
echo intval(42000000);                // 42000000
echo intval(420000000000000000000);   // 0
echo intval('420000000000000000000'); // 2147483647
echo intval(42, 8);                   // 42
echo intval('42', 8);                 // 34
echo intval(array());                 // 0
echo intval(array('foo', 'bar'));     // 1
echo intval(false);                   // 0
echo intval(true);                    // 1
?>

注释

Note:

除非 value 是一个字符串，否则 base 不会起作用。

参见

  • boolval() - 获取变量的布尔值
  • floatval() - 获取变量的浮点值
  • strval() - 获取变量的字符串值
  • settype() - 设置变量的类型
  • is_numeric() - 检测变量是否为数字或数字字符串
  • 类型转换的判别
  • BCMath 任意精度数学函数


检测变量是否是数组

  • ? intval
  • is_bool ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否是数组

is_array

(PHP 4, PHP 5, PHP 7, PHP 8)

is_array — 检测变量是否是数组

描述

is_array ( mixed $var ) : bool

如果 var 是 array，则返回 true，否则返回 false。

参见 is_float()、is_int()、is_integer()、is_string() 和 is_object()。


检测变量是否是布尔值

  • ? is_array
  • is_callable ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否是布尔值

is_bool

(PHP 4, PHP 5, PHP 7, PHP 8)

is_bool — 检测变量是否是布尔值

说明

is_bool ( mixed $value ) : bool

检查变量是否为布尔值。

参数

value

要检查的变量。

返回值

如果 value 是布尔值则返回 true，否则返回 false。

范例

Example #1 is_bool() 示例

<?php
$a = false;
$b = 0;

// 因为 $a 是布尔值，所以结果为 true
if (is_bool($a) === true) {
    echo "Yes, this is a boolean";
}

// 因为 $b 不是布尔值，所以结果为 false
if (is_bool($b) === false) {
    echo "No, this is not a boolean";
}
?>

参见

  • is_float() - 检测变量是否是浮点型
  • is_int() - 检测变量是否是整数
  • is_string() - 检测变量是否是字符串
  • is_object() - 检测变量是否是一个对象
  • is_array() - 检测变量是否是数组


检测参数是否为合法的可调用结构

  • ? is_bool
  • is_countable ?
  • PHP Manual
  • Variable handling 函数
  • 检测参数是否为合法的可调用结构

is_callable

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PHP 8)

is_callable — 检测参数是否为合法的可调用结构

说明

is_callable ( callable $name , bool $syntax_only = false , string &$callable_name = ? ) : bool

验证变量的内容能否作为函数调用。 这可以检查包含有效函数名的变量，或者一个数组，包含了正确编码的对象以及函数名。

参数

name

要检查的回调函数。

syntax_only

如果设置为 true，这个函数仅仅验证 name 可能是函数或方法。 它仅仅拒绝非字符，或者未包含能用于回调函数的有效结构。有效的应该包含两个元素，第一个是一个对象或者字符，第二个元素是个字符。

callable_name

接受"可调用的名称"。下面的例子是"someClass::someMethod"。 注意，尽管 someClass::SomeMethod() 的含义是可调用的静态方法，但例子的情况并不是这样的。

返回值

如果 name 可调用则返回 true，否则返回 false。

范例

Example #1 is_callable() 例子

<?php
//  How to check a variable to see if it can be called
//  as a function.

//
//  Simple variable containing a function
//

function someFunction()
{
}

$functionVariable = 'someFunction';

var_dump(is_callable($functionVariable, false, $callable_name));  // bool(true)

echo $callable_name, "\n";  // someFunction

//
//  Array containing a method
//

class someClass {

  function someMethod()
  {
  }

}

$anObject = new someClass();

$methodVariable = array($anObject, 'someMethod');

var_dump(is_callable($methodVariable, true, $callable_name));  //  bool(true)

echo $callable_name, "\n";  //  someClass::someMethod

?>

参见

  • function_exists() - 如果给定的函数已经被定义就返回 true
  • method_exists() - 检查类的方法是否存在


Verify that the contents of a variable is a countable value

  • ? is_callable
  • is_double ?
  • PHP Manual
  • Variable handling 函数
  • Verify that the contents of a variable is a countable value

is_countable

(PHP 7 >= 7.3.0, PHP 8)

is_countable — Verify that the contents of a variable is a countable value

说明

is_countable ( mixed $value ) : bool

Verify that the contents of a variable is an array or an object implementing Countable

参数

value

The value to check

返回值

Returns true if value is countable, false otherwise.

更新日志

版本 | 说明
7.3.0 | is_countable() has been added.

范例

Example #1 is_countable() examples

<?php
var_dump(is_countable([1, 2, 3])); // bool(true)
var_dump(is_countable(new ArrayIterator(['foo', 'bar', 'baz']))); // bool(true)
var_dump(is_countable(new ArrayIterator())); // bool(true)
var_dump(is_countable(new stdClass())); // bool(false)

参见

  • is_array() - 检测变量是否是数组
  • is_object() - 检测变量是否是一个对象
  • is_iterable() - Verify that the contents of a variable is an iterable value
  • is_bool() - 检测变量是否是布尔值


is_float 的别名

  • ? is_countable
  • is_float ?
  • PHP Manual
  • Variable handling 函数
  • is_float 的别名

is_double

(PHP 4, PHP 5, PHP 7, PHP 8)

is_double — is_float() 的别名

描述

此函数是 is_float() 的别名函数。


检测变量是否是浮点型

  • ? is_double
  • is_int ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否是浮点型

is_float

(PHP 4, PHP 5, PHP 7, PHP 8)

is_float — 检测变量是否是浮点型

描述

is_float ( mixed $var ) : bool

如果 var 是 float 则返回 true，否则返回 false。

Note:

若想测试一个变量是否是数字或数字字符串（如表单输入，它们通常为字符串），必须使用 is_numeric()。

参见 is_bool()、is_int()、is_integer()、is_numeric()、is_string()、is_array() 和 is_object()。


检测变量是否是整数

  • ? is_float
  • is_integer ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否是整数

is_int

(PHP 4, PHP 5, PHP 7, PHP 8)

is_int — 检测变量是否是整数

说明

is_int ( mixed $value ) : bool

检测变量的类型是否为整数（integer）。

Note:

若想检测变量是否是数字或数字字符串（如表单输入，它们通常为字符串），则必须使用 is_numeric() 。

参数

value

要检测的变量。

返回值

如果 value 是 int，则返回 true，否则返回 false。

范例

Example #1 is_int() 示例

<?php
$values = array(23, "23", 23.5, "23.5", null, true, false);
foreach ($values as $value) {
    echo "is_int(";
    var_export($value);
    echo ") = ";
    var_dump(is_int($value));
}
?>

以上例程会输出：

is_int(23) = bool(true)
is_int('23') = bool(false)
is_int(23.5) = bool(false)
is_int('23.5') = bool(false)
is_int(NULL) = bool(false)
is_int(true) = bool(false)
is_int(false) = bool(false)

参见

  • is_bool() - 检测变量是否是布尔值
  • is_float() - 检测变量是否是浮点型
  • is_numeric() - 检测变量是否为数字或数字字符串
  • is_string() - 检测变量是否是字符串
  • is_array() - 检测变量是否是数组
  • is_object() - 检测变量是否是一个对象


is_int 的别名

  • ? is_int
  • is_iterable ?
  • PHP Manual
  • Variable handling 函数
  • is_int 的别名

is_integer

(PHP 4, PHP 5, PHP 7, PHP 8)

is_integer — is_int() 的别名

描述

此函数是 is_int() 的别名函数。


Verify that the contents of a variable is an iterable value

  • ? is_integer
  • is_long ?
  • PHP Manual
  • Variable handling 函数
  • Verify that the contents of a variable is an iterable value

is_iterable

(PHP 7 >= 7.1.0, PHP 8)

is_iterable — Verify that the contents of a variable is an iterable value

说明

is_iterable ( mixed $value ) : bool

Verify that the contents of a variable is accepted by the iterable pseudo-type, i.e. that it is either an array or an object implementing Traversable

参数

value

The value to check

返回值

Returns true if value is iterable, false otherwise.

范例

Example #1 is_iterable() examples

<?php

var_dump(is_iterable([1, 2, 3]));  // bool(true)
var_dump(is_iterable(new ArrayIterator([1, 2, 3])));  // bool(true)
var_dump(is_iterable((function () { yield 1; })()));  // bool(true)
var_dump(is_iterable(1));  // bool(false)
var_dump(is_iterable(new stdClass()));  // bool(false)

?>

参见

  • is_array() - 检测变量是否是数组


is_int 的别名

  • ? is_iterable
  • is_null ?
  • PHP Manual
  • Variable handling 函数
  • is_int 的别名

is_long

(PHP 4, PHP 5, PHP 7, PHP 8)

is_long — is_int() 的别名

描述

此函数是 is_int() 的别名函数。


检测变量是否为 null

  • ? is_long
  • is_numeric ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否为 null

is_null

(PHP 4 >= 4.0.4, PHP 5, PHP 7, PHP 8)

is_null — 检测变量是否为 null

描述

is_null ( mixed $var ) : bool

如果 var 是 null 则返回 true，否则返回 false。

查看 null 类型获知变量什么时候被认为是 null，而什么时候不是。

参见 null、is_bool()、is_numeric()、is_float()、is_int()、is_string()、is_object()、is_array()、is_integer() 和 is_real()。


检测变量是否为数字或数字字符串

  • ? is_null
  • is_object ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否为数字或数字字符串

is_numeric

(PHP 4, PHP 5, PHP 7, PHP 8)

is_numeric — 检测变量是否为数字或数字字符串

描述

is_numeric ( mixed $var ) : bool

如果 var 是数字和数字字符串则返回 true，否则返回 false。

参见 is_bool()、is_float()、is_int()、is_string()、is_object()、is_array() 和 is_integer()。


检测变量是否是一个对象

  • ? is_numeric
  • is_real ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否是一个对象

is_object

(PHP 4, PHP 5, PHP 7, PHP 8)

is_object — 检测变量是否是一个对象

描述

is_object ( mixed $var ) : bool

如果 var 是一个 object 则返回 true，否则返回 false。

参见 is_bool()、is_int()、is_integer()、is_float()、is_string() 和 is_array()。


is_float 的别名

  • ? is_object
  • is_resource ?
  • PHP Manual
  • Variable handling 函数
  • is_float 的别名

is_real

(PHP 4, PHP 5, PHP 7, PHP 8)

is_real — is_float() 的别名

描述

此函数是 is_float() 的别名函数。


检测变量是否为资源类型

  • ? is_real
  • is_scalar ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否为资源类型

is_resource

(PHP 4, PHP 5, PHP 7, PHP 8)

is_resource — 检测变量是否为资源类型

描述

is_resource ( mixed $var ) : bool

如果给出的参数 var 是 resource 类型，is_resource() 返回 true，否则返回 false。

查看 resource 类型文档获取更多的信息。


检测变量是否是一个标量

  • ? is_resource
  • is_string ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否是一个标量

is_scalar

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

is_scalar — 检测变量是否是一个标量

说明

is_scalar ( mixed $value ) : bool

检测变量是否为标量

标量变量是指 int、float、string 或 bool 类型的变量。 array、object 和 resource 类型不是标量。

Note:

is_scalar() 不会将 resource 类型值视为标量， 因为当前 resources 是基于整数（integer）的抽象数据类型。 不能依赖该执行细节，因为它可能会改变。

Note:

is_scalar() 不会将 NULL 检测为标量。

参数

value

需要检测的变量。

返回值

如果 value 是标量，则返回 true ，否则返回 false 。

范例

Example #1 is_scalar() 示例

<?php
function show_var($var)
{
    if (is_scalar($var)) {
        echo $var;
    } else {
        var_dump($var);
    }
}
$pi = 3.1416;
$proteins = array("hemoglobin", "cytochrome c oxidase", "ferredoxin");

show_var($pi);
show_var($proteins)

?>

以上例程会输出：

3.1416
array(3) {
  [0]=>
  string(10) "hemoglobin"
  [1]=>
  string(20) "cytochrome c oxidase"
  [2]=>
  string(10) "ferredoxin"
}

参见

  • is_float() - 检测变量是否是浮点型
  • is_int() - 检测变量是否是整数
  • is_numeric() - 检测变量是否为数字或数字字符串
  • is_real() - is_float 的别名
  • is_string() - 检测变量是否是字符串
  • is_bool() - 检测变量是否是布尔值
  • is_object() - 检测变量是否是一个对象
  • is_array() - 检测变量是否是数组


检测变量是否是字符串

  • ? is_scalar
  • isset ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否是字符串

is_string

(PHP 4, PHP 5, PHP 7, PHP 8)

is_string — 检测变量是否是字符串

描述

is_string ( mixed $var ) : bool

如果 var 是 string 则返回 true，否则返回 false。

参见 is_bool()、is_int()、is_integer()、is_float()、is_real()、is_object() 和 is_array()。


检测变量是否已设置并且非 null

  • ? is_string
  • print_r ?
  • PHP Manual
  • Variable handling 函数
  • 检测变量是否已设置并且非 null

isset

(PHP 4, PHP 5, PHP 7, PHP 8)

isset — 检测变量是否已设置并且非 null

说明

isset ( mixed $var , mixed $... = ? ) : bool

检测变量是否设置，并且不是 null。

如果已经使用 unset() 释放了一个变量之后，它将不再是 isset()。若使用 isset() 测试一个被设置成 null 的变量，将返回 false。同时要注意的是 null 字符（"\0"）并不等同于 PHP 的 null 常量。

如果一次传入多个参数，那么 isset() 只有在全部参数都以被设置时返回 true 计算过程从左至右，中途遇到没有设置的变量时就会立即停止。

参数

var

要检查的变量。

...

其他变量。

返回值

如果 var 存在并且值不是 null 则返回 true，否则返回 false。

更新日志

版本 | 说明
5.4.0 | 检查字符的非数字偏移量将会返回 false。

范例

Example #1 isset() 例子

<?php

$var = '';

// 结果为 TRUE，所以后边的文本将被打印出来。
if (isset($var)) {
    echo "This var is set so I will print.";
}

// 在后边的例子中，我们将使用 var_dump 输出 isset() 的返回值。
// the return value of isset().

$a = "test";
$b = "anothertest";

var_dump(isset($a));      // TRUE
var_dump(isset($a, $b)); // TRUE

unset ($a);

var_dump(isset($a));     // FALSE
var_dump(isset($a, $b)); // FALSE

$foo = NULL;
var_dump(isset($foo));   // FALSE

?>

这对于数组中的元素也同样有效：

<?php

$a = array ('test' => 1, 'hello' => NULL, 'pie' => array('a' => 'apple'));

var_dump(isset($a['test']));            // TRUE
var_dump(isset($a['foo']));             // FALSE
var_dump(isset($a['hello']));           // FALSE

// 键 'hello' 的值等于 NULL，所以被认为是未置值的。
// 如果想检测 NULL 键值，可以试试下边的方法。
var_dump(array_key_exists('hello', $a)); // TRUE

// Checking deeper array values
var_dump(isset($a['pie']['a']));        // TRUE
var_dump(isset($a['pie']['b']));        // FALSE
var_dump(isset($a['cake']['a']['b']));  // FALSE

?>

Example #2 在字符串位移中使用 isset()

PHP 5.4 改变了传入字符串位移时 isset() 的行为。

<?php
$expected_array_got_string = 'somestring';
var_dump(isset($expected_array_got_string['some_key']));
var_dump(isset($expected_array_got_string[0]));
var_dump(isset($expected_array_got_string['0']));
var_dump(isset($expected_array_got_string[0.5]));
var_dump(isset($expected_array_got_string['0.5']));
var_dump(isset($expected_array_got_string['0 Mostel']));
?>

以上例程在 PHP 5.3 中的输出：

bool(true)
bool(true)
bool(true)
bool(true)
bool(true)
bool(true)

以上例程在 PHP 5.4 中的输出：

bool(false)
bool(true)
bool(true)
bool(true)
bool(false)
bool(false)

注释

Warning

isset() 只能用于变量，因为传递任何其它参数都将造成解析错误。若想检测常量是否已设置，可使用 defined() 函数。

Note: 因为是一个语言构造器而不是一个函数，不能被 可变函数 调用。

Note:

如果使用 isset() 来检查对象无法访问的属性，如果 __isset() 方法已经定义则会调用这个重载方法。

参见

  • empty() - 检查一个变量是否为空
  • __isset()
  • unset() - 释放给定的变量
  • defined() - 检查某个名称的常量是否存在
  • the type comparison tables
  • array_key_exists() - 检查数组里是否有指定的键名或索引
  • is_null() - 检测变量是否为 null
  • 错误控制 @ 运算符。


以易于理解的格式打印变量。

  • ? isset
  • serialize ?
  • PHP Manual
  • Variable handling 函数
  • 以易于理解的格式打印变量。

print_r

(PHP 4, PHP 5, PHP 7, PHP 8)

print_r — 以易于理解的格式打印变量。

说明

print_r ( mixed $expression , bool $return = false ) : mixed

print_r() 以人类易读的格式显示一个变量的信息。

print_r()、
var_dump()、
var_export()
都会显示对象 protected 和 private 的属性。
Class 的静态属性（static） 则不会显示。

参数

expression

要打印的表达式。

return

想要获取 print_r() 输出的内容，使用 return 参数。 当此参数为 true，print_r() 会直接返回信息，而不是输出。

返回值

如果输入的内容是 string、 integer 或 float，会直接输出值本身。 如果输入的内容是 array，展示的格式会显示数组的键和包含的元素。object 也类似。

当 return 参数设置成 true，本函数会返回 string 格式。否则返回 true。

注释

Note:

当使用了return 参数时，本函数使用其内部输出缓冲，因此不能在 ob_start() 回调函数的内部使用。

范例

Example #1 print_r() 例子

<pre>
<?php
$a = array ('a' => 'apple', 'b' => 'banana', 'c' => array ('x', 'y', 'z'));
print_r ($a);
?>
</pre>

以上例程会输出：

<pre>
Array
(
    [a] => apple
    [b] => banana
    [c] => Array
        (
            [0] => x
            [1] => y
            [2] => z
        )
)
</pre>

Example #2 return 参数的例子

<?php
$b = array ('m' => 'monkey', 'foo' => 'bar', 'x' => array ('x', 'y', 'z'));
$results = print_r($b, true); // $results 包含了 print_r 的输出
?>

参见

  • ob_start() - 打开输出控制缓冲
  • var_dump() - 打印变量的相关信息
  • var_export() - 输出或返回一个变量的字符串表示


产生一个可存储的值的表示

  • ? print_r
  • settype ?
  • PHP Manual
  • Variable handling 函数
  • 产生一个可存储的值的表示

serialize

(PHP 4, PHP 5, PHP 7, PHP 8)

serialize — 产生一个可存储的值的表示

描述

serialize ( mixed $value ) : string

serialize() 返回字符串，此字符串包含了表示 value 的字节流，可以存储于任何地方。

这有利于存储或传递 PHP 的值，同时不丢失其类型和结构。

想要将已序列化的字符串变回 PHP 的值，可使用 unserialize()。serialize() 可处理除了 resource 之外的任何类型。甚至可以 serialize() 那些包含了指向其自身引用的数组。你正 serialize() 的数组／对象中的引用也将被存储。

当序列化对象时，PHP 将试图在序列动作之前调用该对象的成员函数
__sleep()。这样就允许对象在被序列化之前做任何清除操作。类似的，当使用
unserialize() 恢复对象时， 将调用
__wakeup() 成员函数。

Note:

在 PHP 3 中，对象属性将被序列化，但是方法则会丢失。PHP 4 打破了此限制，可以同时存储属性和方法。请参见类与对象中的序列化对象部分获取更多信息。

Example #1 serialize() 示例

<?php
// $session_data 是包含了当前用户 session 信息的多维数组。
// 我们使用 serialize() 在请求结束之前将其存储到数据库中。

$conn = odbc_connect ("webdb", "php", "chicken");
$stmt = odbc_prepare ($conn,
      "UPDATE sessions SET data = ? WHERE id = ?");
$sqldata = array (serialize($session_data), $PHP_AUTH_USER);
if (!odbc_execute ($stmt, &$sqldata)) {
    $stmt = odbc_prepare($conn,
     "INSERT INTO sessions (id, data) VALUES(?, ?)");
    if (!odbc_execute($stmt, &$sqldata)) {
    /* 出错 */
    }
}
?>

参见：unserialize()。


设置变量的类型

  • ? serialize
  • strval ?
  • PHP Manual
  • Variable handling 函数
  • 设置变量的类型

settype

(PHP 4, PHP 5, PHP 7, PHP 8)

settype — 设置变量的类型

说明

settype ( mixed &$var , string $type ) : bool

将变量 var 的类型设置成 type。

参数

var

要转换的变量。

type

type 的可能值为：

  • "boolean" （或为"bool"，从 PHP 4.2.0 起）
  • "integer" （或为"int"，从 PHP 4.2.0 起）
  • "float" （只在 PHP 4.2.0 之后可以使用，对于旧版本中使用的"double"现已停用）
  • "string"
  • "array"
  • "object"
  • "null" （从 PHP 4.2.0 起）

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 settype() 示例

<?php
$foo = "5bar"; // string
$bar = true;   // boolean

settype($foo, "integer"); // $foo 现在是 5   (integer)
settype($bar, "string");  // $bar 现在是 "1" (string)
?>

注释

Note:

Maximum value for "int" is PHP_INT_MAX.

参见

  • gettype() - 获取变量的类型
  • 类型转换
  • 类型戏法


获取变量的字符串值

  • ? settype
  • unserialize ?
  • PHP Manual
  • Variable handling 函数
  • 获取变量的字符串值

strval

(PHP 4, PHP 5, PHP 7, PHP 8)

strval — 获取变量的字符串值

描述

strval ( mixed $var ) : string

返回 var 的 string 值。 参见 string 文档获取更多关于字符串转换的信息。

var 可以是任何标量类型。不能将 strval() 用于数组或对象。

参见 floatval()、intval()、settype() 和类型戏法。


从已存储的表示中创建 PHP 的值

  • ? strval
  • unset ?
  • PHP Manual
  • Variable handling 函数
  • 从已存储的表示中创建 PHP 的值

unserialize

(PHP 4, PHP 5, PHP 7, PHP 8)

unserialize — 从已存储的表示中创建 PHP 的值

说明

unserialize ( string $str ) : mixed

unserialize() 对单一的已序列化的变量进行操作，将其转换回 PHP 的值。

参数

str

序列化后的字符串。

若被反序列化的变量是一个对象，在成功地重新构造对象之后，PHP 会自动地试图去调用 __wakeup() 成员函数（如果存在的话）。

Note: unserialize_callback_func 指令

如果在反序列化的时候需要实例化一个未定义类，则可以设置回调函数以供调用（以免得到的是不完整的 object "__PHP_Incomplete_Class"）。可通过 php.ini、ini_set() 或 .htaccess 定义'unserialize_callback_func'。每次实例化一个未定义类时它都会被调用。若要禁止这个特性，只需置空此设定。

返回值

返回的是转换之后的值，可为 integer、float、string、array 或 object。

如果传递的字符串不可反序列化，则返回 false，并产生一个 E_NOTICE。

更新日志

版本 | 说明
4.2.0 | 添加了 unserialize_callback_func 指令。

范例

Example #1 unserialize() 例子

<?php
// 这里，我们使用 unserialize() 装载来自数据库的 $session_data 数组中的会话数据。
// 此例是描述 serialize() 的那个例子的补充。

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn, "SELECT data FROM sessions WHERE id = ?");
$sqldata = array($_SERVER['PHP_AUTH_USER']);
if (!odbc_execute($stmt, $sqldata) || !odbc_fetch_into($stmt, $tmp)) {
    // 如果执行出错或返回错误，则初始化为空数组
    $session_data = array();
} else {
    // 现在我们需要的是 $tmp[0] 中已序列化的数据。
    $session_data = unserialize($tmp[0]);
    if (!is_array($session_data)) {
        // 出错，初始化为空数组
        $session_data = array();
    }
}
?>

Example #2 unserialize_callback_func 例子

<?php
$serialized_object='O:1:"a":1:{s:5:"value";s:3:"100";}';

// unserialize_callback_func 从 PHP 4.2.0 起可用
ini_set('unserialize_callback_func', 'mycallback'); // 设置您的回调函数

function mycallback($classname)
{
   // 只需包含含有类定义的文件
   // $classname 指出需要的是哪一个类
}
?>

注释

Warning

如果反序列化了 false 的值，或者在过程中发生了错误，都会返回 false。 可以通过 str 和 serialize(false) 进行比较，或者捕捉 E_NOTICE 错误来判断这种特殊情况。

参见

  • serialize() - 产生一个可存储的值的表示
  • 自动加载对象
  • unserialize_callback_func
  • __wakeup()


释放给定的变量

  • ? unserialize
  • var_dump ?
  • PHP Manual
  • Variable handling 函数
  • 释放给定的变量

unset

(PHP 4, PHP 5, PHP 7, PHP 8)

unset — 释放给定的变量

说明

unset ( mixed $var , mixed $... = ? ) : void

unset() 销毁指定的变量。

unset() 在函数中的行为会依赖于想要销毁的变量的类型而有所不同。

如果在函数中 unset() 一个全局变量，则只是局部变量被销毁，而在调用环境中的变量将保持调用 unset() 之前一样的值。

<?php
function destroy_foo() {
    global $foo;
    unset($foo);
}

$foo = 'bar';
destroy_foo();
echo $foo;
?>

以上例程会输出：

bar

如果您想在函数中 unset() 一个全局变量，可使用 $GLOBALS 数组来实现：

<?php
function foo()
{
    unset($GLOBALS['bar']);
}

$bar = "something";
foo();
?>

如果在函数中 unset() 一个通过引用传递的变量，则只是局部变量被销毁，而在调用环境中的变量将保持调用 unset() 之前一样的值。

<?php
function foo(&$bar) {
    unset($bar);
    $bar = "blah";
}

$bar = 'something';
echo "$bar\n";

foo($bar);
echo "$bar\n";
?>

以上例程会输出：

something
something

如果在函数中 unset() 一个静态变量，那么在函数内部此静态变量将被销毁。但是，当再次调用此函数时，此静态变量将被复原为上次被销毁之前的值。

<?php
function foo()
{
    static $bar;
    $bar++;
    echo "Before unset: $bar, ";
    unset($bar);
    $bar = 23;
    echo "after unset: $bar\n";
}

foo();
foo();
foo();
?>

以上例程会输出：

Before unset: 1, after unset: 23
Before unset: 2, after unset: 23
Before unset: 3, after unset: 23

参数

var

要销毁的变量。

...

其他变量......

返回值

没有返回值。

范例

Example #1 unset() 示例

<?php
// 销毁单个变量
unset ($foo);

// 销毁单个数组元素
unset ($bar['quux']);

// 销毁一个以上的变量
unset($foo1, $foo2, $foo3);
?>

Example #2 使用 (unset) 类型强制转换

(unset) 类型强制转换常常和函数 unset() 引起困惑。 为了完整性，(unset) 是作为一个 NULL 类型的强制转换。它不会改变变量的类型。

<?php
$name = 'Felipe';

var_dump((unset) $name);
var_dump($name);
?>

以上例程会输出：

NULL
string(6) "Felipe"

注释

Note: 因为是一个语言构造器而不是一个函数，不能被 可变函数 调用。

Note:

It is possible to unset even object properties visible in current context.

Note:

在 PHP 5 之前无法在对象里销毁 $this。

Note:

在 unset() 一个无法访问的对象属性时，如果定义了 __unset() 则对调用这个重载方法。

参见

  • isset() - 检测变量是否已设置并且非 null
  • empty() - 检查一个变量是否为空
  • __unset()
  • array_splice() - 去掉数组中的某一部分并用其它值取代


打印变量的相关信息

  • ? unset
  • var_export ?
  • PHP Manual
  • Variable handling 函数
  • 打印变量的相关信息

var_dump

(PHP 4, PHP 5, PHP 7, PHP 8)

var_dump — 打印变量的相关信息

说明

var_dump ( mixed $expression , mixed $... = ? ) : void

此函数显示关于一个或多个表达式的结构信息，包括表达式的类型与值。数组将递归展开值，通过缩进显示其结构。

In PHP 5 all public, private and protected properties of objects will be returned in the output.

Tip

和直接将结果输出到浏览器一样，可使用输出控制函数来捕获当前函数的输出，然后(例如)保存到一个 string 中。

参数

expression

你要打印的变量。

返回值

没有返回值。

范例

Example #1 var_dump() 例子

<?php
$a = array(1, 2, array("a", "b", "c"));
var_dump($a);
?>

以上例程会输出：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  array(3) {
    [0]=>
    string(1) "a"
    [1]=>
    string(1) "b"
    [2]=>
    string(1) "c"
  }
}
<?php

$b = 3.1;
$c = true;
var_dump($b, $c);

?>

以上例程会输出：

float(3.1)
bool(true)

参见

  • var_export() - 输出或返回一个变量的字符串表示
  • print_r() - 以易于理解的格式打印变量。


输出或返回一个变量的字符串表示

  • ? var_dump
  • Web 服务 ?
  • PHP Manual
  • Variable handling 函数
  • 输出或返回一个变量的字符串表示

var_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

var_export — 输出或返回一个变量的字符串表示

说明

var_export ( mixed $expression , bool $return = false ) : mixed

var_export() 函数返回关于传递给该函数的变量的结构信息，它和 var_dump() 函数类似，不同的是其返回的表示是合法的 PHP 代码。

参数

expression

想要输出的变量名。

return

此参数为 true 时，var_export() 将返回一个变量，而不是输出它。

返回值

参数 return 为 true 时返回变量，否则返回 null。

注释

Note:

当使用了return 参数时，本函数使用其内部输出缓冲，因此不能在 ob_start() 回调函数的内部使用。

更新日志

版本 | 说明
7.3.0 | Now exports stdClass objects as an array cast to an object ((object) array( ... )), rather than using the nonexistent method stdClass::__setState(). The practical effect is that now stdClass is exportable, and the resulting code will even work on earlier versions of PHP.

范例

Example #1 var_export() 示例

<?php
$a = array (1, 2, array ("a", "b", "c"));
var_export($a);
?>

以上例程会输出：

array (
  0 => 1,
  1 => 2,
  2 =>
  array (
    0 => 'a',
    1 => 'b',
    2 => 'c',
  ),
)
<?php

$b = 3.1;
$v = var_export($b, true);
echo $v;

?>

以上例程会输出：

3.1

Example #2 输出类 stdClass (自 PHP 7.3.0 起)

<?php
$person = new stdClass;
$person->name = 'ElePHPant ElePHPantsdotter';
$person->website = 'https://php.net/elephpant.php';

var_export($person);

以上例程会输出：

(object) array(
   'name' => 'ElePHPant ElePHPantsdotter',
   'website' => 'https://php.net/elephpant.php',
)

Example #3 输出对象 (自 PHP 5.1.0 起)

<?php
class A { public $var; }
$a = new A;
$a->var = 5;
var_export($a);
?>

以上例程会输出：

A::__set_state(array(
   'var' => 5,
))

Example #4 使用 __set_state() (自 PHP 5.1.0 起)

<?php
class A
{
    public $var1;
    public $var2;

    public static function __set_state($an_array)
    {
        $obj = new A;
        $obj->var1 = $an_array['var1'];
        $obj->var2 = $an_array['var2'];
        return $obj;
    }
}

$a = new A;
$a->var1 = 5;
$a->var2 = 'foo';

eval('$b = ' . var_export($a, true) . ';'); // $b = A::__set_state(array(
                                            //    'var1' => 5,
                                            //    'var2' => 'foo',
                                            // ));
var_dump($b);
?>

以上例程会输出：

object(A)#2 (2) {
  ["var1"]=>
  int(5)
  ["var2"]=>
  string(3) "foo"
}

注释

Note:

类型为 resource 的变量无法通过此函数输出。

Note:

var_export() does not handle circular references as it would be close to impossible to generate parsable PHP code for that. If you want to do something with the full representation of an array or object, use serialize().

Warning

When var_export() exports objects, the leading backslash is not included in the class name of namespaced classes for maximum compatibility.

Note:

To be able to evaluate the PHP generated by var_export(), all processed objects must implement the magic __set_state method. The only exception is stdClass, which is exported using an array cast to an object.

参见

  • print_r() - 以易于理解的格式打印变量。
  • serialize() - 产生一个可存储的值的表示
  • var_dump() - 打印变量的相关信息


Web 服务

  • OAuth
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • OAuth 函数
    • OAuth — OAuth 类
    • OAuthProvider — OAuthProvider 类
    • OAuthException — OAuthException 类
  • SOAP
    • 简介
    • 安装／配置
    • 预定义常量
    • SOAP 函数
    • SoapClient — The SoapClient class
    • SoapServer — The SoapServer class
    • SoapFault — The SoapFault class
    • SoapHeader — The SoapHeader class
    • SoapParam — The SoapParam class
    • SoapVar — The SoapVar class
  • Yar — Yet Another RPC Framework
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • Yar_Server — The Yar_Server class
    • Yar_Client — The Yar_Client class
    • Yar_Concurrent_Client — The Yar_Concurrent_Client class
    • Yar_Server_Exception — The Yar_Server_Exception class
    • Yar_Client_Exception — The Yar_Client_Exception class
  • XML-RPC
    • 简介
    • 安装／配置
    • 预定义常量
    • XML-RPC 函数


OAuth

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • FireEagle
  • OAuth 函数
    • oauth_get_sbs — 生成一个签名字符基串
    • oauth_urlencode — 将 URI 编码为 RFC 3986 规范
  • OAuth — OAuth 类
    • OAuth::__construct — 新建一个 OAuth 对象
    • OAuth::__destruct — 析构函数
    • OAuth::disableDebug — 关闭详细的调试
    • OAuth::disableRedirects — 关闭重定向
    • OAuth::disableSSLChecks — 关闭 SSL 检查
    • OAuth::enableDebug — 启用详细调试
    • OAuth::enableRedirects — 启用重定向
    • OAuth::enableSSLChecks — 启用 SSL 检查
    • OAuth::fetch — 获取一个 OAuth 受保护的资源
    • OAuth::generateSignature — 生成一个签名
    • OAuth::getAccessToken — 获取一个访问令牌
    • OAuth::getCAPath — 获取 CA 信息
    • OAuth::getLastResponse — 获取最后一次的响应
    • OAuth::getLastResponseHeaders — 获取最后一次响应的头信息
    • OAuth::getLastResponseInfo — 获取关于最后一次响应的 HTTP 信息
    • OAuth::getRequestHeader — 生成 OAuth 头信息字符串签名
    • OAuth::getRequestToken — 获取一个请求令牌
    • OAuth::setAuthType — 设置授权类型
    • OAuth::setCAPath — 设置 CA 路径和信息
    • OAuth::setNonce — 为后续请求设置现时标志
    • OAuth::setRequestEngine — 设置目标请求引擎
    • OAuth::setRSACertificate — 设置 RSA 证书
    • OAuth::setSSLChecks — 调整特定的SSL请求检查
    • OAuth::setTimestamp — 设置时间戳
    • OAuth::setToken — 设置令牌和 secret
    • OAuth::setVersion — 设置 OAuth 版本
  • OAuthProvider — OAuthProvider 类
    • OAuthProvider::addRequiredParameter — 添加必需的参数
    • OAuthProvider::callconsumerHandler — 调用 consumerNonceHandler 回调函数
    • OAuthProvider::callTimestampNonceHandler — 调用 timestampNonceHandler 回调函数
    • OAuthProvider::calltokenHandler — 调用 tokenNonceHandler 回调函数
    • OAuthProvider::checkOAuthRequest — 检查一个 oauth 请求
    • OAuthProvider::__construct — 新建一个 OAuthProvider 对象
    • OAuthProvider::consumerHandler — 设置 consumerHandler 句柄回调函数
    • OAuthProvider::generateToken — 生成一个随机令牌
    • OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint
    • OAuthProvider::isRequestTokenEndpoint — 设置 isRequestTokenEndpoint
    • OAuthProvider::removeRequiredParameter — 移除一个必需的参数
    • OAuthProvider::reportProblem — 报告问题
    • OAuthProvider::setParam — 设置一个参数
    • OAuthProvider::setRequestTokenPath — 设置请求令牌路径
    • OAuthProvider::timestampNonceHandler — 设置 timestampNonceHandler 句柄回调函数
    • OAuthProvider::tokenHandler — 设置 tokenHandler 句柄回调函数
  • OAuthException — OAuthException 类


简介

此扩展提供 OAuth 消费方和提供方之间的绑定。OAuth 是一种建立在 HTTP 之上的授权协议，用于允许应用程序安全访问数据而无需存储用户名和密码。


需求

PECL/oauth 需要 PHP 5.1 或更高版本，以及 ext/hash 和 ext/pcre 。

如果在构建时选择 PECL/oauth 则可选择性地需要 libcurl 。如果使用 libcurl 配置，则必须构建 HTTPS 支持。


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pear.php.net/package/oauth


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

这些常量牵涉到的大部分问题也都在官方的 OAuth » 问题报告 文档里有描述。但是要注意，这些常量名是特定于 PHP 的，尽管这些命名规则看上去相似。

OAUTH_SIG_METHOD_RSASHA1 (字符串)
OAuth RSA-SHA1 签名方法。
OAUTH_SIG_METHOD_HMACSHA1 (字符串)

OAuth HMAC-SHA1 签名方法。

OAUTH_SIG_METHOD_HMACSHA256 (字符串)
OAuth HMAC-SHA256 签名方法。
OAUTH_AUTH_TYPE_AUTHORIZATION (字符串)

此常量代表把 OAuth 参数放在 Authorization 头部。

OAUTH_AUTH_TYPE_NONE (字符串)

此常量标志着一个 NoAuth OAuth 请求。

OAUTH_AUTH_TYPE_URI (字符串)

此常量表示将 OAuth 参数放在请求中。 URI.

OAUTH_AUTH_TYPE_FORM (字符串)

此常量表示将 OAuth 参数作为 HTTP POST 主体的一部分。

OAUTH_HTTP_METHOD_GET (字符串)

为 OAuth 请求使用 GET 方法。

OAUTH_HTTP_METHOD_POST (字符串)

为 OAuth 请求使用 POST 方法。

OAUTH_HTTP_METHOD_PUT (字符串)

为 OAuth 请求使用 PUT 方法。

OAUTH_HTTP_METHOD_HEAD (字符串)

为 OAuth 请求使用 HEAD 方法。

OAUTH_HTTP_METHOD_DELETE (字符串)
为 OAuth 请求使用 DELETE 方法。
OAUTH_REQENGINE_STREAMS (整型)
使用 OAuth::setRequestEngine() 来设置引擎为 PHP 流，与用 OAUTH_REQENGINE_CURL 的 Curl 截然相反。
OAUTH_REQENGINE_CURL (整型)
使用 OAuth::setRequestEngine() 来设置引擎为 Curl，与用 OAUTH_REQENGINE_STREAMS 的 PHP 流 截然相反。
OAUTH_OK (整型)
一切良好。
OAUTH_BAD_NONCE (整型)
oauth_nonce 值已经用于上一个上一个请求，因此现在不能使用了。
OAUTH_BAD_TIMESTAMP (整型)
oauth_timestamp 值不能被服务提供者接受。这种情况下，响应应该也包含 oauth_acceptable_timestamps 参数。
OAUTH_CONSUMER_KEY_UNKNOWN (整型)
oauth_consumer_key 暂时不能被服务提供者接受。比如，服务提供者限流了使用者。
OAUTH_CONSUMER_KEY_REFUSED (整型)
使用者密钥遭拒绝。
OAUTH_INVALID_SIGNATURE (整型)
oauth_signature 无效，因为和服务提供者的签名计算不匹配。
OAUTH_TOKEN_USED (整型)
oauth_token 已经被消费。此令牌不能再被使用，因为在上一次请求中已经使用过。
OAUTH_TOKEN_EXPIRED (整型)
oauth_token 已经过期。
OAUTH_TOKEN_REVOKED (整型)
oauth_token 已经被撤销，且将决不再接受。
OAUTH_TOKEN_REJECTED (整型)
oauth_token 被服务提供者拒绝。原因未知，也许是因为令牌从未发布、已经消费、过期、或服务提供者忘记了。
OAUTH_VERIFIER_INVALID (整型)
oauth_verifier 不正确。
OAUTH_PARAMETER_ABSENT (整型)
一个必需的参数没有接收到。这种情况下，响应也应该包含 oauth_parameters_absent 参数。
OAUTH_SIGNATURE_METHOD_REJECTED (整型)
oauth_signature_method 不能被服务提供者接受。


  • ? 预定义常量
  • FireEagle ?
  • PHP Manual
  • OAuth
  • 范例

范例

Table of Contents

  • FireEagle


FireEagle

<?php
$req_url = 'https://fireeagle.yahooapis.com/oauth/request_token';
$authurl = 'https://fireeagle.yahoo.net/oauth/authorize';
$acc_url = 'https://fireeagle.yahooapis.com/oauth/access_token';
$api_url = 'https://fireeagle.yahooapis.com/api/0.1';
$conskey = 'your_consumer_key';
$conssec = 'your_consumer_secret';

session_start();

//  当 state=1 则下次请求应该包含一个 oauth_token 。
//  如果没有则返回 0
if(!isset($_GET['oauth_token']) && $_SESSION['state']==1) $_SESSION['state'] = 0;
try {
  $oauth = new OAuth($conskey,$conssec,OAUTH_SIG_METHOD_HMACSHA1,OAUTH_AUTH_TYPE_URI);
  $oauth->enableDebug();
  if(!isset($_GET['oauth_token']) && !$_SESSION['state']) {
    $request_token_info = $oauth->getRequestToken($req_url);
    $_SESSION['secret'] = $request_token_info['oauth_token_secret'];
    $_SESSION['state'] = 1;
    header('Location: '.$authurl.'?oauth_token='.$request_token_info['oauth_token']);
    exit;
  } else if($_SESSION['state']==1) {
    $oauth->setToken($_GET['oauth_token'],$_SESSION['secret']);
    $access_token_info = $oauth->getAccessToken($acc_url);
    $_SESSION['state'] = 2;
    $_SESSION['token'] = $access_token_info['oauth_token'];
    $_SESSION['secret'] = $access_token_info['oauth_token_secret'];
  }
  $oauth->setToken($_SESSION['token'],$_SESSION['secret']);
  $oauth->fetch("$api_url/user.json");
  $json = json_decode($oauth->getLastResponse());
  print_r($json);
} catch(OAuthException $E) {
  print_r($E);
}
?>


OAuth 函数

Table of Contents

  • oauth_get_sbs — 生成一个签名字符基串
  • oauth_urlencode — 将 URI 编码为 RFC 3986 规范


生成一个签名字符基串

  • ? OAuth 函数
  • oauth_urlencode ?
  • PHP Manual
  • OAuth 函数
  • 生成一个签名字符基串

oauth_get_sbs

(PECL OAuth >=0.99.7)

oauth_get_sbs — 生成一个签名字符基串

说明

oauth_get_sbs ( string $http_method , string $uri , array $request_parameters = ? ) : string

根据 pecl/oauth 生成一个签名字符基串。

参数

http_method

HTTP 方法。

uri

将要编码的 URI 。

request_parameters

请求参数的数组。

返回值

返回一个签名字符基串。


将 URI 编码为 RFC 3986 规范

  • ? oauth_get_sbs
  • OAuth ?
  • PHP Manual
  • OAuth 函数
  • 将 URI 编码为 RFC 3986 规范

oauth_urlencode

(PECL OAuth >=0.99.2)

oauth_urlencode — 将 URI 编码为 RFC 3986 规范

说明

oauth_urlencode ( string $uri ) : string

将 URI 编码为 » RFC 3986 规范。

参数

uri

将要编码的 URI 。

返回值

返回一个 » RFC 3986 规范的编码字符串。


OAuth 类

(PECL OAuth >= 0.99.1)

简介

此 OAuth 扩展提供一个简单接口使用 OAuth HTTP 规范与数据提供者互动，以便保护私有资源。

类摘要

OAuth {
/* 属性 */
public $debug ;
public $sslChecks ;
public $debugInfo ;
/* 方法 */
public __construct ( string $consumer_key , string $consumer_secret , string $signature_method = OAUTH_SIG_METHOD_HMACSHA1 , int $auth_type = 0 )
public __destruct ( ) : void
public disableDebug ( ) : bool
public disableRedirects ( ) : bool
public disableSSLChecks ( ) : bool
public enableDebug ( ) : bool
public enableRedirects ( ) : bool
public enableSSLChecks ( ) : bool
public fetch ( string $protected_resource_url , array $extra_parameters = ? , string $http_method = ? , array $http_headers = ? ) : mixed
public generateSignature ( string $http_method , string $url , mixed $extra_parameters = ? ) : string
public getAccessToken ( string $access_token_url , string $auth_session_handle = ? , string $verifier_token = ? ) : array
public getCAPath ( ) : array
public getLastResponse ( ) : string
public getLastResponseHeaders ( ) : string
public getLastResponseInfo ( ) : array
public getRequestHeader ( string $http_method , string $url , mixed $extra_parameters = ? ) : string
public getRequestToken ( string $request_token_url , string $callback_url = ? ) : array
public setAuthType ( int $auth_type ) : mixed
public setCAPath ( string $ca_path = ? , string $ca_info = ? ) : mixed
public setNonce ( string $nonce ) : mixed
public setRequestEngine ( int $reqengine ) : void
public setRSACertificate ( string $cert ) : mixed
public setSSLChecks ( int $sslcheck ) : bool
public setTimestamp ( string $timestamp ) : mixed
public setToken ( string $token , string $token_secret ) : bool
public setVersion ( string $version ) : bool
}

属性

debug

sslChecks

debugInfo

Table of Contents

  • OAuth::__construct — 新建一个 OAuth 对象
  • OAuth::__destruct — 析构函数
  • OAuth::disableDebug — 关闭详细的调试
  • OAuth::disableRedirects — 关闭重定向
  • OAuth::disableSSLChecks — 关闭 SSL 检查
  • OAuth::enableDebug — 启用详细调试
  • OAuth::enableRedirects — 启用重定向
  • OAuth::enableSSLChecks — 启用 SSL 检查
  • OAuth::fetch — 获取一个 OAuth 受保护的资源
  • OAuth::generateSignature — 生成一个签名
  • OAuth::getAccessToken — 获取一个访问令牌
  • OAuth::getCAPath — 获取 CA 信息
  • OAuth::getLastResponse — 获取最后一次的响应
  • OAuth::getLastResponseHeaders — 获取最后一次响应的头信息
  • OAuth::getLastResponseInfo — 获取关于最后一次响应的 HTTP 信息
  • OAuth::getRequestHeader — 生成 OAuth 头信息字符串签名
  • OAuth::getRequestToken — 获取一个请求令牌
  • OAuth::setAuthType — 设置授权类型
  • OAuth::setCAPath — 设置 CA 路径和信息
  • OAuth::setNonce — 为后续请求设置现时标志
  • OAuth::setRequestEngine — 设置目标请求引擎
  • OAuth::setRSACertificate — 设置 RSA 证书
  • OAuth::setSSLChecks — 调整特定的SSL请求检查
  • OAuth::setTimestamp — 设置时间戳
  • OAuth::setToken — 设置令牌和 secret
  • OAuth::setVersion — 设置 OAuth 版本


新建一个 OAuth 对象

  • ? OAuth
  • OAuth::__destruct ?
  • PHP Manual
  • OAuth
  • 新建一个 OAuth 对象

OAuth::__construct

(PECL OAuth >= 0.99.1)

OAuth::__construct — 新建一个 OAuth 对象

说明

public OAuth::__construct ( string $consumer_key , string $consumer_secret , string $signature_method = OAUTH_SIG_METHOD_HMACSHA1 , int $auth_type = 0 )

新建一个 OAuth 对象

参数

consumer_key

由服务提供者提供的 consumer key 。

consumer_secret

由服务提供者提供的 consumer secret 。

signature_method

可选参数，用来定义使用哪种签名方法，默认为 OAUTH_SIG_METHOD_HMACSHA1 （HMAC-SHA1）。

auth_type

可选参数，用来定义如何传递 OAuth 参数给消费方，默认为OAUTH_AUTH_TYPE_AUTHORIZATION （在 Authorization 头部）。


析构函数

  • ? OAuth::__construct
  • OAuth::disableDebug ?
  • PHP Manual
  • OAuth
  • 析构函数

OAuth::__destruct

(PECL OAuth >= 0.99.9)

OAuth::__destruct — 析构函数

说明

public OAuth::__destruct ( ) : void

析构函数。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

参见

  • OAuth::__construct() - 新建一个 OAuth 对象


关闭详细的调试

  • ? OAuth::__destruct
  • OAuth::disableRedirects ?
  • PHP Manual
  • OAuth
  • 关闭详细的调试

OAuth::disableDebug

(PECL OAuth >= 0.99.3)

OAuth::disableDebug — 关闭详细的调试

说明

public OAuth::disableDebug ( ) : bool

关闭详细的请求信息（默认为关闭）。或者，将 调试 属性设置为 false 值来关闭调试。

参数

此函数没有参数。

返回值

true

更新日志

版本 | 说明
0.99.8 | 增加相关 调试 属性。

参见

  • OAuth::enableDebug() - 启用详细调试


关闭重定向

  • ? OAuth::disableDebug
  • OAuth::disableSSLChecks ?
  • PHP Manual
  • OAuth
  • 关闭重定向

OAuth::disableRedirects

(PECL OAuth >= 0.99.9)

OAuth::disableRedirects — 关闭重定向

说明

public OAuth::disableRedirects ( ) : bool

禁用自动跟随其后的重定向，这样，手动重定向请求。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true

参见

  • OAuth::enableRedirects() - 启用重定向


关闭 SSL 检查

  • ? OAuth::disableRedirects
  • OAuth::enableDebug ?
  • PHP Manual
  • OAuth
  • 关闭 SSL 检查

OAuth::disableSSLChecks

(PECL OAuth >= 0.99.5)

OAuth::disableSSLChecks — 关闭 SSL 检查

说明

public OAuth::disableSSLChecks ( ) : bool

关闭通常的 SSL 对等证书和主机检查，但不用于生产环境。或者，设置 sslChecks 成员为 false 来关闭 SSL 检查。

参数

此函数没有参数。

返回值

true

更新日志

版本 | 说明
0.99.8 | 增加了 sslChecks 成员

参见

  • OAuth::enableSSLChecks() - 启用 SSL 检查


启用详细调试

  • ? OAuth::disableSSLChecks
  • OAuth::enableRedirects ?
  • PHP Manual
  • OAuth
  • 启用详细调试

OAuth::enableDebug

(PECL OAuth >= 0.99.3)

OAuth::enableDebug — 启用详细调试

说明

public OAuth::enableDebug ( ) : bool

打开用于调试的详细请求信息，调试信息存储在 debugInfo 成员中。或者，可以设置 debug 成员为一个非 false 值来打开启用调试。

参数

此函数没有参数。

返回值

true

更新日志

版本 | 说明
0.99.8 | 增加了 debug 和 debugInfo 成员

参见

  • OAuth::disableDebug() - 关闭详细的调试


启用重定向

  • ? OAuth::enableDebug
  • OAuth::enableSSLChecks ?
  • PHP Manual
  • OAuth
  • 启用重定向

OAuth::enableRedirects

(PECL OAuth >= 0.99.9)

OAuth::enableRedirects — 启用重定向

说明

public OAuth::enableRedirects ( ) : bool

启用自动重定向，此项默认为启用。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

true

参见

  • OAuth::disableRedirects() - 关闭重定向


启用 SSL 检查

  • ? OAuth::enableRedirects
  • OAuth::fetch ?
  • PHP Manual
  • OAuth
  • 启用 SSL 检查

OAuth::enableSSLChecks

(PECL OAuth >= 0.99.5)

OAuth::enableSSLChecks — 启用 SSL 检查

说明

public OAuth::enableSSLChecks ( ) : bool

启用通常的l SSL 对等证书和主机检查（默认为启用）。或者，可以设置 sslChecks 成员为一个非 false 值来启用 SSL 检查。

参数

此函数没有参数。

返回值

true

更新日志

版本 | 说明
0.99.8 | 增加 sslChecks 成员

参见

  • OAuth::disableSSLChecks() - 关闭 SSL 检查


获取一个 OAuth 受保护的资源

  • ? OAuth::enableSSLChecks
  • OAuth::generateSignature ?
  • PHP Manual
  • OAuth
  • 获取一个 OAuth 受保护的资源

OAuth::fetch

(PECL OAuth >= 0.99.1)

OAuth::fetch — 获取一个 OAuth 受保护的资源

说明

public OAuth::fetch ( string $protected_resource_url , array $extra_parameters = ? , string $http_method = ? , array $http_headers = ? ) : mixed

获取一个资源。

参数

protected_resource_url

OAuth 受保护资源的URL

extra_parameters

和资源请求一起发送的额外参数。

http_method

OAUTH_HTTP_METHOD_* 系列 OAUTH 常量之一，GET、POST、PUT、HEAD 或 DELETE 其中的一个。

HEAD （OAUTH_HTTP_METHOD_HEAD ）可以用于先于请求发现信息（如果 OAuth 证书在 Authorization 头部）。

http_headers

HTTP 客户端头信息（像 User-Agent， Accept 等等这样的）。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
1.0.0 | 以前失败时返回 null，而不是 false。
0.99.5 | 新增 http_method 参数
0.99.8 | 新增 http_headers 参数

范例

Example #1 OAuth::fetch() example

<?php
try {
    $oauth = new OAuth("consumer_key","consumer_secret",OAUTH_SIG_METHOD_HMACSHA1,OAUTH_AUTH_TYPE_AUTHORIZATION);
    $oauth->setToken("access_token","access_token_secret");

    $oauth->fetch("http://photos.example.net/photo?file=vacation.jpg");

    $response_info = $oauth->getLastResponseInfo();
    header("Content-Type: {$response_info["content_type"]}");
    echo $oauth->getLastResponse();
} catch(OAuthException $E) {
    echo "Exception caught!\n";
    echo "Response: ". $E->lastResponse . "\n";
}
?>

参见

  • OAuth::getLastResponse() - 获取最后一次的响应
  • OAuth::getLastResponseInfo() - 获取关于最后一次响应的 HTTP 信息
  • OAuth::setToken() - 设置令牌和 secret


生成一个签名

  • ? OAuth::fetch
  • OAuth::getAccessToken ?
  • PHP Manual
  • OAuth
  • 生成一个签名

OAuth::generateSignature

(No version information available, might only be in Git)

OAuth::generateSignature — 生成一个签名

说明

public OAuth::generateSignature ( string $http_method , string $url , mixed $extra_parameters = ? ) : string

生成一个基于最终 HTTP 方法、URL 和 一个字符串/数组参数的签名。

参数

http_method

用来请求的 HTTP 方法

url

用来请求的 URL

extra_parameters

字符串或数组的附加参数

返回值

一个包含签名的字符串 或者在失败时返回 false


获取一个访问令牌

  • ? OAuth::generateSignature
  • OAuth::getCAPath ?
  • PHP Manual
  • OAuth
  • 获取一个访问令牌

OAuth::getAccessToken

(PECL OAuth >= 0.99.1)

OAuth::getAccessToken — 获取一个访问令牌

说明

public OAuth::getAccessToken ( string $access_token_url , string $auth_session_handle = ? , string $verifier_token = ? ) : array

从服务提供者获取一个访问令牌、secret以及一些附带的响应参数 。

参数

access_token_url

用于访问令牌 API 的 URL。

auth_session_handle

授权会话句柄，此参数在 OAuth 规范核心中没有任何引用， 但可能被大的提供者实现。» 参见 ScalableOAuth 获取更多信息。

verifier_token

对于支持 1.0a 的服务提供者， 当交换请求令牌和访问令牌时，必须传递 verifier_token 。如果 verifier_token 存在于 $_GET 或 $_POST 中，它将被自动传递，且调用者不需要指定一个 verifier_token （通常如果访问令牌在 oauth_callback URL 上被交换 ）。 » 参见 ScalableOAuth 获取更多信息。

返回值

成功则返回一个包含解析过的 OAuth 响应的数组， 失败则返回 false 。

更新日志

版本 | 说明
1.0.0 | 以前失败时返回 null，而不是 false。
0.99.9 | 新增 verifier_token 参数

范例

Example #1 OAuth::getAccessToken() 例子

<?php
try {
    $oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
    $oauth->setToken($request_token,$request_token_secret);
    $access_token_info = $oauth->getAccessToken("https://example.com/oauth/access_token");
    if(!empty($access_token_info)) {
        print_r($access_token_info);
    } else {
        print "Failed fetching access token, response was: " . $oauth->getLastResponse();
    }
} catch(OAuthException $E) {
    echo "Response: ". $E->lastResponse . "\n";
}
?>

以上例程的输出类似于：

Array
(
    [oauth_token] => some_token
    [oauth_token_secret] => some_token_secret
)

参见

  • OAuth::getLastResponse() - 获取最后一次的响应
  • OAuth::getLastResponseInfo() - 获取关于最后一次响应的 HTTP 信息
  • OAuth::setToken() - 设置令牌和 secret


获取 CA 信息

  • ? OAuth::getAccessToken
  • OAuth::getLastResponse ?
  • PHP Manual
  • OAuth
  • 获取 CA 信息

OAuth::getCAPath

(PECL OAuth >= 0.99.8)

OAuth::getCAPath — 获取 CA 信息

说明

public OAuth::getCAPath ( ) : array

获取证书授权的信息，其中包括通过 OAuth::setCaPath() 设置的 ca_path 和 ca_info 。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

返回一个证书授权信息的 数组 ，在返回的关联数组中明确地包含 ca_path 和 ca_info 键。

参见

  • OAuth::setCAPath() - 设置 CA 路径和信息
  • OAuth::getLastResponseInfo() - 获取关于最后一次响应的 HTTP 信息


获取最后一次的响应

  • ? OAuth::getCAPath
  • OAuth::getLastResponseHeaders ?
  • PHP Manual
  • OAuth
  • 获取最后一次的响应

OAuth::getLastResponse

(PECL OAuth >= 0.99.1)

OAuth::getLastResponse — 获取最后一次的响应

说明

public OAuth::getLastResponse ( ) : string

获取最近一次请求的原始响应。

参数

此函数没有参数。

返回值

返回一个最后一次响应的字符串。

参见

  • OAuth::getLastResponseInfo() - 获取关于最后一次响应的 HTTP 信息
  • OAuth::fetch() - 获取一个 OAuth 受保护的资源


获取最后一次响应的头信息

  • ? OAuth::getLastResponse
  • OAuth::getLastResponseInfo ?
  • PHP Manual
  • OAuth
  • 获取最后一次响应的头信息

OAuth::getLastResponseHeaders

(No version information available, might only be in Git)

OAuth::getLastResponseHeaders — 获取最后一次响应的头信息

说明

public OAuth::getLastResponseHeaders ( ) : string

获取最后一次响应的头信息。

参数

此函数没有参数。

返回值

返回一个包含最后一次响应头信息的字符串 或者在失败时返回 false 。


获取关于最后一次响应的 HTTP 信息

  • ? OAuth::getLastResponseHeaders
  • OAuth::getRequestHeader ?
  • PHP Manual
  • OAuth
  • 获取关于最后一次响应的 HTTP 信息

OAuth::getLastResponseInfo

(PECL OAuth >= 0.99.1)

OAuth::getLastResponseInfo — 获取关于最后一次响应的 HTTP 信息

说明

public OAuth::getLastResponseInfo ( ) : array

获取关于最后一次响应的 HTTP 信息。

参数

此函数没有参数。

返回值

返回一个包含最后一次请求响应信息的数组。可以用到来自 curl_getinfo() 的常量。

参见

  • OAuth::fetch() - 获取一个 OAuth 受保护的资源
  • OAuth::getLastResponse() - 获取最后一次的响应


生成 OAuth 头信息字符串签名

  • ? OAuth::getLastResponseInfo
  • OAuth::getRequestToken ?
  • PHP Manual
  • OAuth
  • 生成 OAuth 头信息字符串签名

OAuth::getRequestHeader

(No version information available, might only be in Git)

OAuth::getRequestHeader — 生成 OAuth 头信息字符串签名

说明

public OAuth::getRequestHeader ( string $http_method , string $url , mixed $extra_parameters = ? ) : string

生成基于最终 HTTP 方法、URL 和 一个字符串/数组附加参数的 OAuth 头信息字符串签名。

参数

http_method

请求的 HTTP 方法。

url

请求的 URL 。

extra_parameters

字符串或数组类型的附带参数。

返回值

返回 一个包含生成的请求头信息的字符串 r 或者在失败时返回 false


获取一个请求令牌

  • ? OAuth::getRequestHeader
  • OAuth::setAuthType ?
  • PHP Manual
  • OAuth
  • 获取一个请求令牌

OAuth::getRequestToken

(PECL OAuth >= 0.99.1)

OAuth::getRequestToken — 获取一个请求令牌

说明

public OAuth::getRequestToken ( string $request_token_url , string $callback_url = ? ) : array

从服务提供者那里获取一个请求令牌、secret 、以及一些附带的响应参数。

参数

request_token_url

请求令牌 API 的 URL。

callback_url

OAuth 回调 URL。 如果传递了 callback_url 且为空值，则将其设置为"oob"即到 OAuth 2009.1 咨询的地址。

返回值

成功则返回一个包含解析过了的 OAuth 响应的数组，失败则返回 false 。

更新日志

版本 | 说明
1.0.0 | 以前失败时返回 null，而不是 false。
0.99.9 | 增加 callback_url 参数。

范例

Example #1 OAuth::getRequestToken() 例子

<?php
try {
    $oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
    $request_token_info = $oauth->getRequestToken("https://example.com/oauth/request_token");
    if(!empty($request_token_info)) {
        print_r($request_token_info);
    } else {
        print "Failed fetching request token, response was: " . $oauth->getLastResponse();
    }
} catch(OAuthException $E) {
    echo "Response: ". $E->lastResponse . "\n";
}
?>

以上例程的输出类似于：

Array
(
    [oauth_token] => some_token
    [oauth_token_secret] => some_token_secret
)

参见

  • OAuth::getLastResponse() - 获取最后一次的响应
  • OAuth::getLastResponseInfo() - 获取关于最后一次响应的 HTTP 信息


设置授权类型

  • ? OAuth::getRequestToken
  • OAuth::setCAPath ?
  • PHP Manual
  • OAuth
  • 设置授权类型

OAuth::setAuthType

(PECL OAuth >= 0.99.1)

OAuth::setAuthType — 设置授权类型

说明

public OAuth::setAuthType ( int $auth_type ) : mixed

设置 OAuth 参数应该放在哪里传递。

参数

auth_type

auth_type可能是下列标志之一（在 OAuth 1.0 规范的第 5.2 章节中按优先级降序排列）：

OAUTH_AUTH_TYPE_AUTHORIZATION
在 HTTP Authorization 头部传递 OAuth 参数。
OAUTH_AUTH_TYPE_FORM
将 OAuth 参数附加到 HTTP POST 请求主体中。
OAUTH_AUTH_TYPE_URI
将 OAuth 参数附加到请求的 URI 后面 。
OAUTH_AUTH_TYPE_NONE
无。

返回值

如果参数设置正确则返回 true ，否则返回 false （比如，传递进一个无效的 auth_type ）。

更新日志

版本 | 说明
1.0.0 | 以前失败时返回 null，而不是 false。


设置 CA 路径和信息

  • ? OAuth::setAuthType
  • OAuth::setNonce ?
  • PHP Manual
  • OAuth
  • 设置 CA 路径和信息

OAuth::setCAPath

(PECL OAuth >= 0.99.8)

OAuth::setCAPath — 设置 CA 路径和信息

说明

public OAuth::setCAPath ( string $ca_path = ? , string $ca_info = ? ) : mixed

设置证书授权中心（CA ）的路径和信息。

Warning

本函数还未编写文档，仅有参数列表。

参数

ca_path

要设置的 CA 路径。

ca_info

要设置的 CA 信息。

返回值

成功则返回 true ，如果 ca_path 或 ca_info 其中之一被认为无效则返回 false 。

更新日志

版本 | 说明
1.0.0 | 以前失败时返回 null，而不是 false。

参见

  • OAuth::getCaPath() - 获取 CA 信息


为后续请求设置现时标志

  • ? OAuth::setCAPath
  • OAuth::setRequestEngine ?
  • PHP Manual
  • OAuth
  • 为后续请求设置现时标志

OAuth::setNonce

(PECL OAuth >= 0.99.1)

OAuth::setNonce — 为后续请求设置现时标志

说明

public OAuth::setNonce ( string $nonce ) : mixed

为所有后续请求设置现时标志。

参数

nonce

oauth_nonce 的值。

返回值

成功返回 true ，如果 nonce 被认为无效，则返回 false 。

更新日志

版本 | 说明
1.0.0 | 以前失败时返回 null，而不是 false。

参见

  • OAuth::setToken() - 设置令牌和 secret
  • OAuth::setAuthType() - 设置授权类型
  • OAuth::setVersion() - 设置 OAuth 版本


设置目标请求引擎

  • ? OAuth::setNonce
  • OAuth::setRSACertificate ?
  • PHP Manual
  • OAuth
  • 设置目标请求引擎

OAuth::setRequestEngine

(PECL OAuth >= 1.0.0)

OAuth::setRequestEngine — 设置目标请求引擎

说明

public OAuth::setRequestEngine ( int $reqengine ) : void

设置请求引擎，用于发送 HTTP 请求。

Warning

本函数还未编写文档，仅有参数列表。

参数

reqengine

想要的请求引擎。 设为 OAUTH_REQENGINE_STREAMS 则使用 PHP 流，设为 OAUTH_REQENGINE_CURL 则使用 Curl。

返回值

没有返回值。

错误／异常

如果选择了一个无效的请求引擎，则发出一个 OAuthException 异常。

范例

Example #1 OAuth::setRequestEngine() 例子

<?php
$consumer = new OAuth();

$consumer->setRequestEngine(OAUTH_REQENGINE_STREAMS);
?>

参见

  • Curl
  • PHP 流
  • OAuthException


设置 RSA 证书

  • ? OAuth::setRequestEngine
  • OAuth::setSSLChecks ?
  • PHP Manual
  • OAuth
  • 设置 RSA 证书

OAuth::setRSACertificate

(PECL OAuth >= 1.0.0)

OAuth::setRSACertificate — 设置 RSA 证书

说明

public OAuth::setRSACertificate ( string $cert ) : mixed

设置 RSA 证书。

Warning

本函数还未编写文档，仅有参数列表。

参数

cert

RSA 证书。

返回值

成功则返回 true ，失败返回 false （例如，RSA证书不能被传递）。

更新日志

版本 | 说明
1.0.0 | 以前失败时返回 null，而不是 false。

范例

Example #1 一个 OAuth::setRsaCertificate() 例子

<?php
$consume = new OAuth('1234', '', OAUTH_SIG_METHOD_RSASHA1);

$consume->setRSACertificate(file_get_contents('test.pem'));
?>

参见

  • OAuth::setCaPath() - 设置 CA 路径和信息


调整特定的SSL请求检查

  • ? OAuth::setRSACertificate
  • OAuth::setTimestamp ?
  • PHP Manual
  • OAuth
  • 调整特定的SSL请求检查

OAuth::setSSLChecks

(No version information available, might only be in Git)

OAuth::setSSLChecks — 调整特定的SSL请求检查

说明

public OAuth::setSSLChecks ( int $sslcheck ) : bool

调整特定的SSL请求检查。

Warning

本函数还未编写文档，仅有参数列表。

参数

sslcheck

返回值

成功时返回 true， 或者在失败时返回 false。


设置时间戳

  • ? OAuth::setSSLChecks
  • OAuth::setToken ?
  • PHP Manual
  • OAuth
  • 设置时间戳

OAuth::setTimestamp

(PECL OAuth >= 1.0.0)

OAuth::setTimestamp — 设置时间戳

说明

public OAuth::setTimestamp ( string $timestamp ) : mixed

为后续请求设置时间戳。

Warning

本函数还未编写文档，仅有参数列表。

参数

timestamp

时间戳。

返回值

返回 true ，除非 timestamp 无效，则返回 false 。

更新日志

版本 | 说明
1.0.0 | 以前失败时返回 null，而不是 false。

参见

  • OAuth::setNonce() - 为后续请求设置现时标志


设置令牌和 secret

  • ? OAuth::setTimestamp
  • OAuth::setVersion ?
  • PHP Manual
  • OAuth
  • 设置令牌和 secret

OAuth::setToken

(PECL OAuth >= 0.99.1)

OAuth::setToken — 设置令牌和 secret

说明

public OAuth::setToken ( string $token , string $token_secret ) : bool

为后续请求设置令牌和 secret。

参数

token

OAuth 令牌

token_secret

OAuth 令牌 secret。

返回值

true

范例

Example #1 OAuth::setToken() 例子

<?php
$oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
$oauth->setToken("token","token-secret");
?>


设置 OAuth 版本

  • ? OAuth::setToken
  • OAuthProvider ?
  • PHP Manual
  • OAuth
  • 设置 OAuth 版本

OAuth::setVersion

(PECL OAuth >= 0.99.1)

OAuth::setVersion — 设置 OAuth 版本

说明

public OAuth::setVersion ( string $version ) : bool

为随后请求设置 OAuth 版本

参数

version

OAuth 版本，默认值为 "1.0"

返回值

成功时返回 true， 或者在失败时返回 false。


OAuthProvider 类

(PECL OAuth >= 1.0.0)

简介

管理一个 OAuth 提供者类。

参考一个外部的深入教程 » 写一个 OAuth 提供者服务，用来亲自实践提供服务。也可以参考 OAuth 扩展源代码里的 » OAuth 提供者例子 。

类摘要

OAuthProvider {
/* 方法 */
final public addRequiredParameter ( string $req_params ) : bool
public callconsumerHandler ( ) : void
public callTimestampNonceHandler ( ) : void
public calltokenHandler ( ) : void
public checkOAuthRequest ( string $uri = ? , string $method = ? ) : void
public __construct ( array $params_array = ? )
public consumerHandler ( callable $callback_function ) : void
final public static generateToken ( int $size , bool $strong = false ) : string
public is2LeggedEndpoint ( mixed $params_array ) : void
public isRequestTokenEndpoint ( bool $will_issue_request_token ) : void
final public removeRequiredParameter ( string $req_params ) : bool
final public static reportProblem ( string $oauthexception , bool $send_headers = true ) : string
final public setParam ( string $param_key , mixed $param_val = ? ) : bool
final public setRequestTokenPath ( string $path ) : bool
public timestampNonceHandler ( callable $callback_function ) : void
public tokenHandler ( callable $callback_function ) : void
}

Table of Contents

  • OAuthProvider::addRequiredParameter — 添加必需的参数
  • OAuthProvider::callconsumerHandler — 调用 consumerNonceHandler 回调函数
  • OAuthProvider::callTimestampNonceHandler — 调用 timestampNonceHandler 回调函数
  • OAuthProvider::calltokenHandler — 调用 tokenNonceHandler 回调函数
  • OAuthProvider::checkOAuthRequest — 检查一个 oauth 请求
  • OAuthProvider::__construct — 新建一个 OAuthProvider 对象
  • OAuthProvider::consumerHandler — 设置 consumerHandler 句柄回调函数
  • OAuthProvider::generateToken — 生成一个随机令牌
  • OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint
  • OAuthProvider::isRequestTokenEndpoint — 设置 isRequestTokenEndpoint
  • OAuthProvider::removeRequiredParameter — 移除一个必需的参数
  • OAuthProvider::reportProblem — 报告问题
  • OAuthProvider::setParam — 设置一个参数
  • OAuthProvider::setRequestTokenPath — 设置请求令牌路径
  • OAuthProvider::timestampNonceHandler — 设置 timestampNonceHandler 句柄回调函数
  • OAuthProvider::tokenHandler — 设置 tokenHandler 句柄回调函数


添加必需的参数

  • ? OAuthProvider
  • OAuthProvider::callconsumerHandler ?
  • PHP Manual
  • OAuthProvider
  • 添加必需的参数

OAuthProvider::addRequiredParameter

(PECL OAuth >= 1.0.0)

OAuthProvider::addRequiredParameter — 添加必需的参数

说明

final public OAuthProvider::addRequiredParameter ( string $req_params ) : bool

添加必需的 oauth 提供者参数。

Warning

本函数还未编写文档，仅有参数列表。

参数

req_params

必需的参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • OAuthProvider::removeRequiredParameter() - 移除一个必需的参数


调用 consumerNonceHandler 回调函数

  • ? OAuthProvider::addRequiredParameter
  • OAuthProvider::callTimestampNonceHandler ?
  • PHP Manual
  • OAuthProvider
  • 调用 consumerNonceHandler 回调函数

OAuthProvider::callconsumerHandler

(No version information available, might only be in Git)

OAuthProvider::callconsumerHandler — 调用 consumerNonceHandler 回调函数

说明

public OAuthProvider::callconsumerHandler ( ) : void

调用注册的消费者句柄回调函数，此回调函数通过 OAuthProvider::consumerHandler() 设置。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

错误／异常

如回调函数无法被调用或未被指定，会引发一个 E_ERROR 级别的错误。

参见

  • OAuthProvider::consumerHandler() - 设置 consumerHandler 句柄回调函数


调用 timestampNonceHandler 回调函数

  • ? OAuthProvider::callconsumerHandler
  • OAuthProvider::calltokenHandler ?
  • PHP Manual
  • OAuthProvider
  • 调用 timestampNonceHandler 回调函数

OAuthProvider::callTimestampNonceHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::callTimestampNonceHandler — 调用 timestampNonceHandler 回调函数

说明

public OAuthProvider::callTimestampNonceHandler ( ) : void

调用注册的时间戳句柄回调函数，此回调函数通过 OAuthProvider::timestampNonceHandler() 设置。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

错误／异常

如回调函数无法被调用或未被指定，会引发一个 E_ERROR 级别的错误。

参见

  • OAuthProvider::timestampNonceHandler() - 设置 timestampNonceHandler 句柄回调函数


调用 tokenNonceHandler 回调函数

  • ? OAuthProvider::callTimestampNonceHandler
  • OAuthProvider::checkOAuthRequest ?
  • PHP Manual
  • OAuthProvider
  • 调用 tokenNonceHandler 回调函数

OAuthProvider::calltokenHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::calltokenHandler — 调用 tokenNonceHandler 回调函数

说明

public OAuthProvider::calltokenHandler ( ) : void

调用注册的令牌句柄回调函数，此回调函数通过 OAuthProvider::tokenHandler() 设置。

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

没有返回值。

错误／异常

如回调函数无法被调用或未被指定，会引发一个 E_ERROR 级别的错误。

参见

  • OAuthProvider::tokenHandler() - 设置 tokenHandler 句柄回调函数


检查一个 oauth 请求

  • ? OAuthProvider::calltokenHandler
  • OAuthProvider::__construct ?
  • PHP Manual
  • OAuthProvider
  • 检查一个 oauth 请求

OAuthProvider::checkOAuthRequest

(PECL OAuth >= 1.0.0)

OAuthProvider::checkOAuthRequest — 检查一个 oauth 请求

说明

public OAuthProvider::checkOAuthRequest ( string $uri = ? , string $method = ? ) : void

检查一个 OAuth 请求。

Warning

本函数还未编写文档，仅有参数列表。

参数

uri

可选的 URI 或终点。

method

HTTP 方法。 可选 OAUTH_HTTP_METHOD_* OAuth 常量 其中之一传递。

返回值

没有返回值。

错误／异常

如果不能检测到 HTTP 方法，则发出一个 E_ERROR 级别的错误。

参见

  • OAuthProvider::reportProblem() - 报告问题


新建一个 OAuthProvider 对象

  • ? OAuthProvider::checkOAuthRequest
  • OAuthProvider::consumerHandler ?
  • PHP Manual
  • OAuthProvider
  • 新建一个 OAuthProvider 对象

OAuthProvider::__construct

(PECL OAuth >= 1.0.0)

OAuthProvider::__construct — 新建一个 OAuthProvider 对象

说明

public OAuthProvider::__construct ( array $params_array = ? )

发起一个新的 OAuthProvider 对象。

Warning

本函数还未编写文档，仅有参数列表。

参数

params_array

设置限制 CLI SAPI 的可选参数。

返回值

返回一个 OAuthProvider 对象。

范例

Example #1 OAuthProvider::__construct() 例子

<?php
try {

    $op = new OAuthProvider();

    // 使用用户定义的回调函数
    $op->consumerHandler(array($this, 'lookupConsumer'));
    $op->timestampNonceHandler(array($this, 'timestampNonceChecker'));
    $op->tokenHandler(array($this, 'myTokenHandler'));

    // 忽略 foo_uri 参数
    $op->setParam('foo_uri', NULL);

    // 对于终点不需要令牌
    $op->setRequestTokenPath('/v1/oauth/request_token');

    $op->checkOAuthRequest();

} catch (OAuthException $e) {

    echo OAuthProvider::reportProblem($e);
}
?>

参见

  • OAuthProvider::setParam() - 设置一个参数


设置 consumerHandler 句柄回调函数

  • ? OAuthProvider::__construct
  • OAuthProvider::generateToken ?
  • PHP Manual
  • OAuthProvider
  • 设置 consumerHandler 句柄回调函数

OAuthProvider::consumerHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::consumerHandler — 设置 consumerHandler 句柄回调函数

说明

public OAuthProvider::consumerHandler ( callable $callback_function ) : void

设置消费者句柄回调函数，并将在后面通过 OAuthProvider::callConsumerHandler() 被调用。

Warning

本函数还未编写文档，仅有参数列表。

参数

callback_function

回调类型 函数名。

返回值

没有返回值。

范例

Example #1 OAuthProvider::consumerHandler() 回调的例子

<?php
function lookupConsumer($provider) {

    if ($provider->consumer_key === 'unknown') {
        return OAUTH_CONSUMER_KEY_UNKNOWN;
    } else if($provider->consumer_key == 'blacklisted' || $provider->consumer_key === 'throttled') {
        return OAUTH_CONSUMER_KEY_REFUSED;
    }

    $provider->consumer_secret = "the_consumers_secret";

    return OAUTH_OK;
}
?>

参见

  • OAuthProvider::callConsumerHandler() - 调用 consumerNonceHandler 回调函数


生成一个随机令牌

  • ? OAuthProvider::consumerHandler
  • OAuthProvider::is2LeggedEndpoint ?
  • PHP Manual
  • OAuthProvider
  • 生成一个随机令牌

OAuthProvider::generateToken

(PECL OAuth >= 1.0.0)

OAuthProvider::generateToken — 生成一个随机令牌

说明

final public static OAuthProvider::generateToken ( int $size , bool $strong = false ) : string

生成一个伪随机字节的 字符串 。

参数

size

想要的令牌长度，单位为字节。

strong

设置为 true 则意味着将对熵使用 /dev/random ，否则使用非阻塞的 /dev/urandom。在 Windows 平台将忽略此参数。

返回值

生成的令牌，一个以字节为单位的 字符串 。

错误／异常

如果 strong 参数为 true ， 则当回退到用 rand() 来实现填充剩余的随机字节的时候，将触发一个 E_WARNING 级别的错误（比如，当最初找不到足够的随机数据的时候）。

范例

Example #1 OAuthProvider::generateToken() 例子

<?php
$p = new OAuthProvider();

$t = $p->generateToken(4);

echo strlen($t),  PHP_EOL;
echo bin2hex($t), PHP_EOL;

?>

以上例程的输出类似于：

4
b6a82c27

注释

Note:

当系统没有足够的随机数据可用的时候，此函数将使用 PHP 内部的 rand() 来实现填充剩余的随机字节。

参见

  • openssl_random_pseudo_bytes() - 生成一个伪随机字节串
  • mcrypt_create_iv() - 从随机源创建初始向量


is2LeggedEndpoint

  • ? OAuthProvider::generateToken
  • OAuthProvider::isRequestTokenEndpoint ?
  • PHP Manual
  • OAuthProvider
  • is2LeggedEndpoint

OAuthProvider::is2LeggedEndpoint

(PECL OAuth >= 1.0.0)

OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint

说明

public OAuthProvider::is2LeggedEndpoint ( mixed $params_array ) : void

2-legged 流程，或请求签名。不需要令牌。

Warning

本函数还未编写文档，仅有参数列表。

参数

params_array

返回值

返回一个 OAuthProvider 对象.

范例

Example #1 OAuthProvider::is2LeggedEndpoint() 例子

<?php

$provider = new OAuthProvider();

$provider->is2LeggedEndpoint(true);

?>

参见

  • OAuthProvider::__construct() - 新建一个 OAuthProvider 对象


设置 isRequestTokenEndpoint

  • ? OAuthProvider::is2LeggedEndpoint
  • OAuthProvider::removeRequiredParameter ?
  • PHP Manual
  • OAuthProvider
  • 设置 isRequestTokenEndpoint

OAuthProvider::isRequestTokenEndpoint

(PECL OAuth >= 1.0.0)

OAuthProvider::isRequestTokenEndpoint — 设置 isRequestTokenEndpoint

说明

public OAuthProvider::isRequestTokenEndpoint ( bool $will_issue_request_token ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

will_issue_request_token

设置是否发布一个请求令牌，从而决定 OAuthProvider::tokenHandler() 是否需要被调用。

返回值

没有返回值。

参见

  • OAuthProvider::setRequestTokenPath() - 设置请求令牌路径
  • OAuthProvider::reportProblem() - 报告问题


移除一个必需的参数

  • ? OAuthProvider::isRequestTokenEndpoint
  • OAuthProvider::reportProblem ?
  • PHP Manual
  • OAuthProvider
  • 移除一个必需的参数

OAuthProvider::removeRequiredParameter

(PECL OAuth >= 1.0.0)

OAuthProvider::removeRequiredParameter — 移除一个必需的参数

说明

final public OAuthProvider::removeRequiredParameter ( string $req_params ) : bool

移除一个必需的参数。

Warning

本函数还未编写文档，仅有参数列表。

参数

req_params

要被移除的必需参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • OAuthProvider::setParam() - 设置一个参数
  • OAuthProvider::addRequiredParameter() - 添加必需的参数


报告问题

  • ? OAuthProvider::removeRequiredParameter
  • OAuthProvider::setParam ?
  • PHP Manual
  • OAuthProvider
  • 报告问题

OAuthProvider::reportProblem

(PECL OAuth >= 1.0.0)

OAuthProvider::reportProblem — 报告问题

说明

final public static OAuthProvider::reportProblem ( string $oauthexception , bool $send_headers = true ) : string

将问题作为一个 OAuthException 异常传入，可能出现的问题在 OAuth 常量 章节里已列出。

Warning

本函数还未编写文档，仅有参数列表。

参数

oauthexception

OAuthException 类。

返回值

没有返回值。

参见

  • OAuthProvider::checkOAuthRequest() - 检查一个 oauth 请求
  • OAuthProvider::isRequestTokenEndpoint() - 设置 isRequestTokenEndpoint


设置一个参数

  • ? OAuthProvider::reportProblem
  • OAuthProvider::setRequestTokenPath ?
  • PHP Manual
  • OAuthProvider
  • 设置一个参数

OAuthProvider::setParam

(PECL OAuth >= 1.0.0)

OAuthProvider::setParam — 设置一个参数

说明

final public OAuthProvider::setParam ( string $param_key , mixed $param_val = ? ) : bool

设置一个参数。

Warning

本函数还未编写文档，仅有参数列表。

参数

param_key

参数的 key 。

param_val

参数的值，此为可选项。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • OAuthProvider::addRequiredParameter() - 添加必需的参数


设置请求令牌路径

  • ? OAuthProvider::setParam
  • OAuthProvider::timestampNonceHandler ?
  • PHP Manual
  • OAuthProvider
  • 设置请求令牌路径

OAuthProvider::setRequestTokenPath

(PECL OAuth >= 1.0.0)

OAuthProvider::setRequestTokenPath — 设置请求令牌路径

说明

final public OAuthProvider::setRequestTokenPath ( string $path ) : bool

设置请求令牌路径。

Warning

本函数还未编写文档，仅有参数列表。

参数

path

路径。

返回值

true

参见

  • OAuthProvider::tokenHandler() - 设置 tokenHandler 句柄回调函数


设置 timestampNonceHandler 句柄回调函数

  • ? OAuthProvider::setRequestTokenPath
  • OAuthProvider::tokenHandler ?
  • PHP Manual
  • OAuthProvider
  • 设置 timestampNonceHandler 句柄回调函数

OAuthProvider::timestampNonceHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::timestampNonceHandler — 设置 timestampNonceHandler 句柄回调函数

说明

public OAuthProvider::timestampNonceHandler ( callable $callback_function ) : void

设置时间戳 nonce 句柄回调函数，此函数将在后面被 OAuthProvider::callTimestampNonceHandler() 调用。跟时间戳/nonce相关的错误将被抛给此回调函数。

Warning

本函数还未编写文档，仅有参数列表。

参数

callback_function

回调类型 的函数名。

返回值

没有返回值。

范例

Example #1 OAuthProvider::timestampNonceHandler() 回调的例子

<?php
function timestampNonceChecker($provider) {

    if ($provider->nonce === 'bad') {
        return OAUTH_BAD_NONCE;
    } elseif ($provider->timestamp == '0') {
        return OAUTH_BAD_TIMESTAMP;
    }

    return OAUTH_OK;
}
?>

参见

  • OAuthProvider::callTimestampNonceHandler() - 调用 timestampNonceHandler 回调函数


设置 tokenHandler 句柄回调函数

  • ? OAuthProvider::timestampNonceHandler
  • OAuthException ?
  • PHP Manual
  • OAuthProvider
  • 设置 tokenHandler 句柄回调函数

OAuthProvider::tokenHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::tokenHandler — 设置 tokenHandler 句柄回调函数

说明

public OAuthProvider::tokenHandler ( callable $callback_function ) : void

设置令牌句柄的回调函数，此回调函数将在后面被 OAuthProvider::callTokenHandler() 调用。

Warning

本函数还未编写文档，仅有参数列表。

参数

callback_function

回调类型 的函数名。

返回值

没有返回值。

范例

Example #1 OAuthProvider::tokenHandler() 回调的例子

<?php
function tokenHandler($provider) {

    if ($provider->token === 'rejected') {
        return OAUTH_TOKEN_REJECTED;
    } elseif ($provider->token === 'revoked') {
        return OAUTH_TOKEN_REVOKED;
    }

    $provider->token_secret = "the_tokens_secret";
    return OAUTH_OK;
}
?>

参见

  • OAuthProvider::callTokenHandler() - 调用 tokenNonceHandler 回调函数


OAuthException 类

(PECL OAuth >= 0.99.1)

简介

当使用 OAuth 扩展发生异常错误时，抛出此异常和包含了一些有用的调试信息。

类摘要

OAuthException extends Exception {
/* 属性 */
public $lastResponse ;
public $debugInfo ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

lastResponse

发生异常时的响应，如果有的话

debugInfo


SOAP

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • SOAP 函数
    • is_soap_fault — Checks if a SOAP call has failed
    • use_soap_error_handler — Set whether to use the SOAP error handler
  • SoapClient — The SoapClient class
    • SoapClient::__call — Calls a SOAP function (deprecated)
    • SoapClient::__construct — SoapClient constructor
    • SoapClient::__doRequest — Performs a SOAP request
    • SoapClient::__getCookies — Get list of cookies
    • SoapClient::__getFunctions — Returns list of available SOAP functions
    • SoapClient::__getLastRequest — Returns last SOAP request
    • SoapClient::__getLastRequestHeaders — Returns the SOAP headers from the last request
    • SoapClient::__getLastResponse — Returns last SOAP response
    • SoapClient::__getLastResponseHeaders — Returns the SOAP headers from the last response
    • SoapClient::__getTypes — Returns a list of SOAP types
    • SoapClient::__setCookie — Defines a cookie for SOAP requests
    • SoapClient::__setLocation — Sets the location of the Web service to use
    • SoapClient::__setSoapHeaders — Sets SOAP headers for subsequent calls
    • SoapClient::__soapCall — Calls a SOAP function
  • SoapServer — The SoapServer class
    • SoapServer::addFunction — 添加一个或多个函数来处理SOAP请求
    • SoapServer::addSoapHeader — Add a SOAP header to the response
    • SoapServer::__construct — SoapServer constructor
    • SoapServer::fault — Issue SoapServer fault indicating an error
    • SoapServer::getFunctions — Returns list of defined functions
    • SoapServer::handle — Handles a SOAP request
    • SoapServer::setClass — Sets the class which handles SOAP requests
    • SoapServer::setObject — Sets the object which will be used to handle SOAP requests
    • SoapServer::setPersistence — Sets SoapServer persistence mode
  • SoapFault — The SoapFault class
    • SoapFault::__construct — SoapFault constructor
    • SoapFault::__toString — Obtain a string representation of a SoapFault
  • SoapHeader — The SoapHeader class
    • SoapHeader::__construct — SoapHeader constructor
  • SoapParam — The SoapParam class
    • SoapParam::__construct — SoapParam constructor
  • SoapVar — The SoapVar class
    • SoapVar::__construct — SoapVar constructor


简介

The SOAP extension can be used to write SOAP Servers and Clients. It supports subsets of » SOAP 1.1, » SOAP 1.2 and » WSDL 1.1 specifications.


需求

此扩展需要 libxml PHP 扩展。这表示需要使用 --with-libxml，或在 PHP 7.4 之前的版本中使用 --enable-libxml， 尽管这将隐式完成因为 libxml 是缺省开启的。


安装

To enable SOAP support, configure PHP with --enable-soap.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

SOAP 配置选项
名字 | 默认 | 可修改范围 | 更新日志
soap.wsdl_cache_enabled | 1 | PHP_INI_ALL |
soap.wsdl_cache_dir | /tmp | PHP_INI_ALL |
soap.wsdl_cache_ttl | 86400 | PHP_INI_ALL |
soap.wsdl_cache | 1 | PHP_INI_ALL |
soap.wsdl_cache_limit | 5 | PHP_INI_ALL |

这是配置指令的简短说明。

soap.wsdl_cache_enabled int

Enables or disables the WSDL caching feature.

soap.wsdl_cache_dir string

Sets the directory name where the SOAP extension will put cache files.

soap.wsdl_cache_ttl int

Sets the number of seconds (time to live) that cached files will be used instead of the originals.

soap.wsdl_cache int

If soap.wsdl_cache_enabled is on, this setting determines the type of caching. It can be any of: WSDL_CACHE_NONE (0), WSDL_CACHE_DISK (1), WSDL_CACHE_MEMORY (2) or WSDL_CACHE_BOTH (3). This can also be set via the options array in the SoapClient or SoapServer constructor.

soap.wsdl_cache_limit int

Maximum number of in-memory cached WSDL files. Adding further files into a full memory cache will delete the oldest files from it.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

SOAP constants
Constant | Value | Description
SOAP_1_1 (int) | 1 |
SOAP_1_2 (int) | 2 |
SOAP_PERSISTENCE_SESSION (int) | 1 |
SOAP_PERSISTENCE_REQUEST (int) | 2 |
SOAP_FUNCTIONS_ALL (int) | 999 |
SOAP_ENCODED (int) | 1 |
SOAP_LITERAL (int) | 2 |
SOAP_RPC (int) | 1 |
SOAP_DOCUMENT (int) | 2 |
SOAP_ACTOR_NEXT (int) | 1 |
SOAP_ACTOR_NONE (int) | 2 |
SOAP_ACTOR_UNLIMATERECEIVER (int) | 3 |
SOAP_COMPRESSION_ACCEPT (int) | 32 |
SOAP_COMPRESSION_GZIP (int) | 0 |
SOAP_COMPRESSION_DEFLATE (int) | 16 |
SOAP_AUTHENTICATION_BASIC (int) | 0 |
SOAP_AUTHENTICATION_DIGEST (int) | 1 |
SOAP_SSL_METHOD_TLS (int) | 0 | Since PHP 5.5.0.
SOAP_SSL_METHOD_SSLv2 (int) | 1 | Since PHP 5.5.0.
SOAP_SSL_METHOD_SSLv3 (int) | 2 | Since PHP 5.5.0.
SOAP_SSL_METHOD_SSLv23 (int) | 3 | Since PHP 5.5.0.
UNKNOWN_TYPE (int) | 999998 |
XSD_STRING (int) | 101 |
XSD_BOOLEAN (int) | 102 |
XSD_DECIMAL (int) | 103 |
XSD_FLOAT (int) | 104 |
XSD_DOUBLE (int) | 105 |
XSD_DURATION (int) | 106 |
XSD_DATETIME (int) | 107 |
XSD_TIME (int) | 108 |
XSD_DATE (int) | 109 |
XSD_GYEARMONTH (int) | 110 |
XSD_GYEAR (int) | 111 |
XSD_GMONTHDAY (int) | 112 |
XSD_GDAY (int) | 113 |
XSD_GMONTH (int) | 114 |
XSD_HEXBINARY (int) | 115 |
XSD_BASE64BINARY (int) | 116 |
XSD_ANYURI (int) | 117 |
XSD_QNAME (int) | 118 |
XSD_NOTATION (int) | 119 |
XSD_NORMALIZEDSTRING (int) | 120 |
XSD_TOKEN (int) | 121 |
XSD_LANGUAGE (int) | 122 |
XSD_NMTOKEN (int) | 123 |
XSD_NAME (int) | 124 |
XSD_NCNAME (int) | 125 |
XSD_ID (int) | 126 |
XSD_IDREF (int) | 127 |
XSD_IDREFS (int) | 128 |
XSD_ENTITY (int) | 129 |
XSD_ENTITIES (int) | 130 |
XSD_INTEGER (int) | 131 |
XSD_NONPOSITIVEINTEGER (int) | 132 |
XSD_NEGATIVEINTEGER (int) | 133 |
XSD_LONG (int) | 134 |
XSD_INT (int) | 135 |
XSD_SHORT (int) | 136 |
XSD_BYTE (int) | 137 |
XSD_NONNEGATIVEINTEGER (int) | 138 |
XSD_UNSIGNEDLONG (int) | 139 |
XSD_UNSIGNEDINT (int) | 140 |
XSD_UNSIGNEDSHORT (int) | 141 |
XSD_UNSIGNEDBYTE (int) | 142 |
XSD_POSITIVEINTEGER (int) | 143 |
XSD_NMTOKENS (int) | 144 |
XSD_ANYTYPE (int) | 145 |
XSD_ANYXML (int) | 147 |
APACHE_MAP (int) | 200 |
SOAP_ENC_OBJECT (int) | 301 |
SOAP_ENC_ARRAY (int) | 300 |
XSD_1999_TIMEINSTANT (int) | 401 |
XSD_NAMESPACE (int) | http://www.w3.org/2001/XMLSchema |
XSD_1999_NAMESPACE (int) | http://www.w3.org/1999/XMLSchema |
SOAP_SINGLE_ELEMENT_ARRAYS (int) | 1 |
SOAP_WAIT_ONE_WAY_CALLS (int) | 2 |
SOAP_USE_XSI_ARRAY_TYPE (int) | 4 |
WSDL_CACHE_NONE (int) | 0 |
WSDL_CACHE_DISK (int) | 1 |
WSDL_CACHE_MEMORY (int) | 2 |
WSDL_CACHE_BOTH (int) | 3 |


SOAP 函数

Table of Contents

  • is_soap_fault — Checks if a SOAP call has failed
  • use_soap_error_handler — Set whether to use the SOAP error handler


Checks if a SOAP call has failed

  • ? SOAP 函数
  • use_soap_error_handler ?
  • PHP Manual
  • SOAP 函数
  • Checks if a SOAP call has failed

is_soap_fault

(PHP 5, PHP 7, PHP 8)

is_soap_fault — Checks if a SOAP call has failed

说明

is_soap_fault ( mixed $object ) : bool

This function is useful to check if the SOAP call failed, but without using exceptions. To use it, create a SoapClient object with the exceptions option set to zero or false. In this case, the SOAP method will return a special SoapFault object which encapsulates the fault details (faultcode, faultstring, faultactor and faultdetails).

If exceptions is not set then SOAP call will throw an exception on error. is_soap_fault() checks if the given parameter is a SoapFault object.

参数

object

The object to test.

返回值

This will return true on error, and false otherwise.

范例

Example #1 is_soap_fault() example

<?php
$client = new SoapClient("some.wsdl", array('exceptions' => 0));
$result = $client->SomeFunction();
if (is_soap_fault($result)) {
    trigger_error("SOAP Fault: (faultcode: {$result->faultcode}, faultstring: {$result->faultstring})", E_USER_ERROR);
}
?>

Example #2 SOAP's standard method for error reporting is exceptions

<?php
try {
    $client = new SoapClient("some.wsdl");
    $result = $client->SomeFunction(/* ... */);
} catch (SoapFault $fault) {
    trigger_error("SOAP Fault: (faultcode: {$fault->faultcode}, faultstring: {$fault->faultstring})", E_USER_ERROR);
}
?>

参见

  • SoapClient::__construct() - SoapClient constructor
  • SoapFault::__construct() - SoapFault constructor


Set whether to use the SOAP error handler

  • ? is_soap_fault
  • SoapClient ?
  • PHP Manual
  • SOAP 函数
  • Set whether to use the SOAP error handler

use_soap_error_handler

(PHP 5, PHP 7, PHP 8)

use_soap_error_handler — Set whether to use the SOAP error handler

说明

use_soap_error_handler ( bool $enable = true ) : bool

This function sets whether or not to use the SOAP error handler in the SOAP server. It will return the previous value. If set to true, details of errors in a SoapServer application will be sent to the client as a SOAP fault message. If false, the standard PHP error handler is used. The default is to send error to the client as SOAP fault message.

参数

enable

Set to true to send error details to clients.

返回值

Returns the original value.

参见

  • set_error_handler() - 设置用户自定义的错误处理函数
  • set_exception_handler() - 设置用户自定义的异常处理函数


The SoapClient class

(PHP 5, PHP 7, PHP 8)

简介

The SoapClient class provides a client for » SOAP 1.1, » SOAP 1.2 servers. It can be used in WSDL or non-WSDL mode.

类摘要

SoapClient {
/* 方法 */
public __construct ( string|null $wsdl , array $options = [] )
public __call ( string $name , array $args ) : mixed
public __doRequest ( string $request , string $location , string $action , int $version , bool $oneWay = false ) : string|null
public __getCookies ( ) : array
public __getFunctions ( ) : array|null
public __getLastRequest ( ) : string|null
public __getLastRequestHeaders ( ) : string|null
public __getLastResponse ( ) : string|null
public __getLastResponseHeaders ( ) : string|null
public __getTypes ( ) : array|null
public __setCookie ( string $name , string|null $value = null ) : void
public __setLocation ( string $location = "" ) : string|null
public __setSoapHeaders ( SoapHeader|array|null $headers = null ) : bool
public __soapCall ( string $name , array $args , array|null $options = null , SoapHeader|array|null $inputHeaders = null , array &$outputHeaders = null ) : mixed
}

Table of Contents

  • SoapClient::__call — Calls a SOAP function (deprecated)
  • SoapClient::__construct — SoapClient constructor
  • SoapClient::__doRequest — Performs a SOAP request
  • SoapClient::__getCookies — Get list of cookies
  • SoapClient::__getFunctions — Returns list of available SOAP functions
  • SoapClient::__getLastRequest — Returns last SOAP request
  • SoapClient::__getLastRequestHeaders — Returns the SOAP headers from the last request
  • SoapClient::__getLastResponse — Returns last SOAP response
  • SoapClient::__getLastResponseHeaders — Returns the SOAP headers from the last response
  • SoapClient::__getTypes — Returns a list of SOAP types
  • SoapClient::__setCookie — Defines a cookie for SOAP requests
  • SoapClient::__setLocation — Sets the location of the Web service to use
  • SoapClient::__setSoapHeaders — Sets SOAP headers for subsequent calls
  • SoapClient::__soapCall — Calls a SOAP function


Calls a SOAP function (deprecated)

  • ? SoapClient
  • SoapClient::__construct ?
  • PHP Manual
  • SoapClient
  • Calls a SOAP function (deprecated)

SoapClient::__call

(PHP 5, PHP 7, PHP 8)

SoapClient::__call — Calls a SOAP function (deprecated)

说明

public SoapClient::__call ( string $name , array $args ) : mixed

Calling this method directly is deprecated. Usually, SOAP functions can be called as methods of the SoapClient object; in situations where this is not possible or additional options are needed, use SoapClient::__soapCall().


SoapClient constructor

  • ? SoapClient::__call
  • SoapClient::__doRequest ?
  • PHP Manual
  • SoapClient
  • SoapClient constructor

SoapClient::__construct

(PHP 5, PHP 7, PHP 8)

SoapClient::__construct — SoapClient constructor

说明

public SoapClient::__construct ( string|null $wsdl , array $options = [] )

This constructor creates SoapClient objects in WSDL or non-WSDL mode.

参数

wsdl

URI of the WSDL file or null if working in non-WSDL mode.

Note:

During development, WSDL caching may be disabled by the use of the soap.wsdl_cache_ttl php.ini setting otherwise changes made to the WSDL file will have no effect until soap.wsdl_cache_ttl is expired.

options

An array of options. If working in WSDL mode, this parameter is optional. If working in non-WSDL mode, the location and uri options must be set, where location is the URL of the SOAP server to send the request to, and uri is the target namespace of the SOAP service.

The style and use options only work in non-WSDL mode. In WSDL mode, they come from the WSDL file.

The soap_version option should be one of either SOAP_1_1 or SOAP_1_2 to select SOAP 1.1 or 1.2, respectively. If omitted, 1.1 is used.

For HTTP authentication, the login and password options can be used to supply credentials. For making an HTTP connection through a proxy server, the options proxy_host, proxy_port, proxy_login and proxy_password are also available. For HTTPS client certificate authentication use local_cert and passphrase options. An authentication may be supplied in the authentication option. The authentication method may be either SOAP_AUTHENTICATION_BASIC (default) or SOAP_AUTHENTICATION_DIGEST.

The compression option allows to use compression of HTTP SOAP requests and responses.

The encoding option defines internal character encoding. This option does not change the encoding of SOAP requests (it is always utf-8), but converts strings into it.

The trace option enables tracing of request so faults can be backtraced. This defaults to false

The classmap option can be used to map some WSDL types to PHP classes. This option must be an array with WSDL types as keys and names of PHP classes as values.

Setting the boolean trace option enables use of the
methods
SoapClient->__getLastRequest,

SoapClient->__getLastRequestHeaders,

SoapClient->__getLastResponse and

SoapClient->__getLastResponseHeaders.

The exceptions option is a boolean value defining whether soap errors throw exceptions of type SoapFault.

The connection_timeout option defines a timeout in seconds for the connection to the SOAP service. This option does not define a timeout for services with slow responses. To limit the time to wait for calls to finish the default_socket_timeout setting is available.

The typemap option is an array of type mappings. Type mapping is an array with keys type_name, type_ns (namespace URI), from_xml (callback accepting one string parameter) and to_xml (callback accepting one object parameter).

The cache_wsdl option is one of WSDL_CACHE_NONE, WSDL_CACHE_DISK, WSDL_CACHE_MEMORY or WSDL_CACHE_BOTH.

The user_agent option specifies string to use in User-Agent header.

The stream_context option is a resource for context.

The features option is a bitmask of SOAP_SINGLE_ELEMENT_ARRAYS, SOAP_USE_XSI_ARRAY_TYPE, SOAP_WAIT_ONE_WAY_CALLS.

The keep_alive option is a boolean value defining whether to send the Connection: Keep-Alive header or Connection: close.

The ssl_method option is one of SOAP_SSL_METHOD_TLS, SOAP_SSL_METHOD_SSLv2, SOAP_SSL_METHOD_SSLv3 or SOAP_SSL_METHOD_SSLv23.

错误／异常

SoapClient::__construct() will generate an E_ERROR error if the location and uri options aren't provided in non-WSDL mode.

A SoapFault exception will be thrown if the wsdl URI cannot be loaded.

范例

Example #1 SoapClient::__construct() example

<?php

$client = new SoapClient("some.wsdl");

$client = new SoapClient("some.wsdl", array('soap_version'   => SOAP_1_2));

$client = new SoapClient("some.wsdl", array('login'          => "some_name",
                                            'password'       => "some_password"));

$client = new SoapClient("some.wsdl", array('proxy_host'     => "localhost",
                                            'proxy_port'     => 8080));

$client = new SoapClient("some.wsdl", array('proxy_host'     => "localhost",
                                            'proxy_port'     => 8080,
                                            'proxy_login'    => "some_name",
                                            'proxy_password' => "some_password"));

$client = new SoapClient("some.wsdl", array('local_cert'     => "cert_key.pem"));

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/",
                                     'style'    => SOAP_DOCUMENT,
                                     'use'      => SOAP_LITERAL));

$client = new SoapClient("some.wsdl",
  array('compression' => SOAP_COMPRESSION_ACCEPT | SOAP_COMPRESSION_GZIP));

$client = new SoapClient("some.wsdl", array('encoding'=>'ISO-8859-1'));

class MyBook {
    public $title;
    public $author;
}

$client = new SoapClient("books.wsdl", array('classmap' => array('book' => "MyBook")));

?>


Performs a SOAP request

  • ? SoapClient::__construct
  • SoapClient::__getCookies ?
  • PHP Manual
  • SoapClient
  • Performs a SOAP request

SoapClient::__doRequest

(PHP 5, PHP 7, PHP 8)

SoapClient::__doRequest — Performs a SOAP request

说明

public SoapClient::__doRequest ( string $request , string $location , string $action , int $version , bool $oneWay = false ) : string|null

Performs SOAP request over HTTP.

This method can be overridden in subclasses to implement different transport layers, perform additional XML processing or other purpose.

参数

request

The XML SOAP request.

location

The URL to request.

action

The SOAP action.

version

The SOAP version.

oneWay

If one_way is set to 1, this method returns nothing. Use this where a response is not expected.

返回值

The XML SOAP response.

更新日志

版本 | 说明
8.0.0 | The type of oneWay is bool now; formerly it was int.

范例

Example #1 SoapClient::__doRequest() example

<?php
function Add($x,$y) {
  return $x+$y;
}

class LocalSoapClient extends SoapClient {

  function __construct($wsdl, $options) {
    parent::__construct($wsdl, $options);
    $this->server = new SoapServer($wsdl, $options);
    $this->server->addFunction('Add');
  }

  function __doRequest($request, $location, $action, $version, $one_way = 0) {
    ob_start();
    $this->server->handle($request);
    $response = ob_get_contents();
    ob_end_clean();
    return $response;
  }

}

$x = new LocalSoapClient(NULL,array('location'=>'test://',
                                   'uri'=>'http://testuri.org'));
var_dump($x->Add(3,4));
?>


Get list of cookies

  • ? SoapClient::__doRequest
  • SoapClient::__getFunctions ?
  • PHP Manual
  • SoapClient
  • Get list of cookies

SoapClient::__getCookies

(PHP 5 >= 5.4.30, PHP 7, PHP 8)

SoapClient::__getCookies — Get list of cookies

说明

public SoapClient::__getCookies ( ) : array

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Returns list of available SOAP functions

  • ? SoapClient::__getCookies
  • SoapClient::__getLastRequest ?
  • PHP Manual
  • SoapClient
  • Returns list of available SOAP functions

SoapClient::__getFunctions

(PHP 5, PHP 7, PHP 8)

SoapClient::__getFunctions — Returns list of available SOAP functions

说明

public SoapClient::__getFunctions ( ) : array|null

Returns an array of functions described in the WSDL for the Web service.

Note:

此函数仅在 WSDL 模式下生效。

参数

此函数没有参数。

返回值

The array of SOAP function prototypes, detailing the return type, the function name and type-hinted parameters.

范例

Example #1 SoapClient::__getFunctions() example

<?php
$client = new SoapClient('http://soap.amazon.com/schemas3/AmazonWebServices.wsdl');
var_dump($client->__getFunctions());
?>

以上例程会输出：

array(26) {
  [0]=>
  string(70) "ProductInfo KeywordSearchRequest(KeywordRequest $KeywordSearchRequest)"
  [1]=>
  string(79) "ProductInfo TextStreamSearchRequest(TextStreamRequest $TextStreamSearchRequest)"
  [2]=>
  string(64) "ProductInfo PowerSearchRequest(PowerRequest $PowerSearchRequest)"
...
  [23]=>
  string(107) "ShoppingCart RemoveShoppingCartItemsRequest(RemoveShoppingCartItemsRequest $RemoveShoppingCartItemsRequest)"
  [24]=>
  string(107) "ShoppingCart ModifyShoppingCartItemsRequest(ModifyShoppingCartItemsRequest $ModifyShoppingCartItemsRequest)"
  [25]=>
  string(118) "GetTransactionDetailsResponse GetTransactionDetailsRequest(GetTransactionDetailsRequest $GetTransactionDetailsRequest)"
}

参见

  • SoapClient::__construct() - SoapClient constructor


Returns last SOAP request

  • ? SoapClient::__getFunctions
  • SoapClient::__getLastRequestHeaders ?
  • PHP Manual
  • SoapClient
  • Returns last SOAP request

SoapClient::__getLastRequest

(PHP 5, PHP 7, PHP 8)

SoapClient::__getLastRequest — Returns last SOAP request

说明

public SoapClient::__getLastRequest ( ) : string|null

Returns the XML sent in the last SOAP request.

Note:

This method works only if the SoapClient object was created with the trace option set to true.

参数

此函数没有参数。

返回值

The last SOAP request, as an XML string.

范例

Example #1 SoapClient::__getLastRequest() example

<?php
$client = new SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "REQUEST:\n" . $client->__getLastRequest() . "\n";
?>

参见

  • SoapClient::__getLastRequestHeaders() - Returns the SOAP headers from the last request
  • SoapClient::__getLastResponse() - Returns last SOAP response
  • SoapClient::__getLastResponseHeaders() - Returns the SOAP headers from the last response


Returns the SOAP headers from the last request

  • ? SoapClient::__getLastRequest
  • SoapClient::__getLastResponse ?
  • PHP Manual
  • SoapClient
  • Returns the SOAP headers from the last request

SoapClient::__getLastRequestHeaders

(PHP 5, PHP 7, PHP 8)

SoapClient::__getLastRequestHeaders — Returns the SOAP headers from the last request

说明

public SoapClient::__getLastRequestHeaders ( ) : string|null

Returns the SOAP headers from the last request.

Note:

This function only works if the SoapClient object was created with the trace option set to true.

参数

此函数没有参数。

返回值

The last SOAP request headers.

范例

Example #1 SoapClient::__getLastRequestHeaders() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "REQUEST HEADERS:\n" . $client->__getLastRequestHeaders() . "\n";
?>

参见

  • SoapClient::__getLastResponseHeaders() - Returns the SOAP headers from the last response
  • SoapClient::__getLastRequest() - Returns last SOAP request
  • SoapClient::__getLastResponse() - Returns last SOAP response


Returns last SOAP response

  • ? SoapClient::__getLastRequestHeaders
  • SoapClient::__getLastResponseHeaders ?
  • PHP Manual
  • SoapClient
  • Returns last SOAP response

SoapClient::__getLastResponse

(PHP 5, PHP 7, PHP 8)

SoapClient::__getLastResponse — Returns last SOAP response

说明

public SoapClient::__getLastResponse ( ) : string|null

Returns the XML received in the last SOAP response.

Note:

This method works only if the SoapClient object was created with the trace option set to true.

参数

此函数没有参数。

返回值

The last SOAP response, as an XML string.

范例

Example #1 SoapClient::__getLastResponse() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "Response:\n" . $client->__getLastResponse() . "\n";
?>

参见

  • SoapClient::__getLastResponseHeaders() - Returns the SOAP headers from the last response
  • SoapClient::__getLastRequest() - Returns last SOAP request
  • SoapClient::__getLastRequestHeaders() - Returns the SOAP headers from the last request


Returns the SOAP headers from the last response

  • ? SoapClient::__getLastResponse
  • SoapClient::__getTypes ?
  • PHP Manual
  • SoapClient
  • Returns the SOAP headers from the last response

SoapClient::__getLastResponseHeaders

(PHP 5, PHP 7, PHP 8)

SoapClient::__getLastResponseHeaders — Returns the SOAP headers from the last response

说明

public SoapClient::__getLastResponseHeaders ( ) : string|null

Returns the SOAP headers from the last response.

Note:

This function only works if the SoapClient object was created with the trace option set to true.

参数

此函数没有参数。

返回值

The last SOAP response headers.

范例

Example #1 SoapClient::__getLastResponse() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "RESPONSE HEADERS:\n" . $client->__getLastResponseHeaders() . "\n";
?>

参见

  • SoapClient::__getLastRequestHeaders() - Returns the SOAP headers from the last request
  • SoapClient::__getLastRequest() - Returns last SOAP request
  • SoapClient::__getLastResponse() - Returns last SOAP response


Returns a list of SOAP types

  • ? SoapClient::__getLastResponseHeaders
  • SoapClient::__setCookie ?
  • PHP Manual
  • SoapClient
  • Returns a list of SOAP types

SoapClient::__getTypes

(PHP 5, PHP 7, PHP 8)

SoapClient::__getTypes — Returns a list of SOAP types

说明

public SoapClient::__getTypes ( ) : array|null

Returns an array of types described in the WSDL for the Web service.

Note:

此函数仅在 WSDL 模式下生效。

参数

此函数没有参数。

返回值

The array of SOAP types, detailing all structures and types.

范例

Example #1 SoapClient::__getTypes() example

<?php
$client = new SoapClient('http://soap.amazon.com/schemas3/AmazonWebServices.wsdl');
var_dump($client->__getTypes());
?>

以上例程会输出：

array(88) {
  [0]=>
  string(30) "ProductLine ProductLineArray[]"
  [1]=>
  string(85) "struct ProductLine {
 string Mode;
 string RelevanceRank;
 ProductInfo ProductInfo;
}"
  [2]=>
  string(105) "struct ProductInfo {
 string TotalResults;
 string TotalPages;
 string ListName;
 DetailsArray Details;
}"
...
  [85]=>
  string(32) "ShortSummary ShortSummaryArray[]"
  [86]=>
  string(121) "struct GetTransactionDetailsRequest {
 string tag;
 string devtag;
 string key;
 OrderIdArray OrderIds;
 string locale;
}"
  [87]=>
  string(75) "struct GetTransactionDetailsResponse {
 ShortSummaryArray ShortSummaries;
}"
}

参见

  • SoapClient::__construct() - SoapClient constructor


Defines a cookie for SOAP requests

  • ? SoapClient::__getTypes
  • SoapClient::__setLocation ?
  • PHP Manual
  • SoapClient
  • Defines a cookie for SOAP requests

SoapClient::__setCookie

(PHP 5 >= 5.0.4, PHP 7, PHP 8)

SoapClient::__setCookie — Defines a cookie for SOAP requests

说明

public SoapClient::__setCookie ( string $name , string|null $value = null ) : void

Defines a cookie to be sent along with the SOAP requests.

Note:

Calling this method will affect all following calls to SoapClient methods.

参数

name

The name of the cookie.

value

The value of the cookie. If not specified, the cookie will be deleted.

返回值

没有返回值。

更新日志

版本 | 说明
8.0.0 | value is now nullable.


Sets the location of the Web service to use

  • ? SoapClient::__setCookie
  • SoapClient::__setSoapHeaders ?
  • PHP Manual
  • SoapClient
  • Sets the location of the Web service to use

SoapClient::__setLocation

(PHP 5 >= 5.0.4, PHP 7, PHP 8)

SoapClient::__setLocation — Sets the location of the Web service to use

说明

public SoapClient::__setLocation ( string $location = "" ) : string|null

Sets the endpoint URL that will be touched by following SOAP requests. This is equivalent to specifying the location option when constructing the SoapClient.

Note:

Calling this method is optional. The SoapClient uses the endpoint from the WSDL file by default.

参数

location

The new endpoint URL.

返回值

The old endpoint URL.

范例

Example #1 SoapClient::__setLocation() example

<?php
$client = new SoapClient('http://example.com/webservice.php?wsdl');

$client->__setLocation('http://www.somethirdparty.com');

$old_location = $client->__setLocation(); // unsets the location option

echo $old_location;

?>

以上例程的输出类似于：

http://www.somethirdparty.com

参见

  • SoapClient::__construct() - SoapClient constructor


Sets SOAP headers for subsequent calls

  • ? SoapClient::__setLocation
  • SoapClient::__soapCall ?
  • PHP Manual
  • SoapClient
  • Sets SOAP headers for subsequent calls

SoapClient::__setSoapHeaders

(PHP 5 >= 5.0.5, PHP 7, PHP 8)

SoapClient::__setSoapHeaders — Sets SOAP headers for subsequent calls

说明

public SoapClient::__setSoapHeaders ( SoapHeader|array|null $headers = null ) : bool

Defines headers to be sent along with the SOAP requests.

Note:

Calling this method will replace any previous values.

参数

headers

The headers to be set. It could be SoapHeader object or array of SoapHeader objects. If not specified or set to null, the headers will be deleted.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 SoapClient::__setSoapHeaders() example

<?php

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$header = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hello world');

$client->__setSoapHeaders($header);

$client->__soapCall("echoVoid", null);
?>

Example #2 Set Multiple Headers

<?php

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$headers = array();

$headers[] = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hello world');

$headers[] = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hello world again');

$client->__setSoapHeaders($headers);

$client->__soapCall("echoVoid", null);
?>


Calls a SOAP function

  • ? SoapClient::__setSoapHeaders
  • SoapServer ?
  • PHP Manual
  • SoapClient
  • Calls a SOAP function

SoapClient::__soapCall

(PHP 5, PHP 7, PHP 8)

SoapClient::__soapCall — Calls a SOAP function

说明

public SoapClient::__soapCall ( string $name , array $args , array|null $options = null , SoapHeader|array|null $inputHeaders = null , array &$outputHeaders = null ) : mixed

This is a low level API function that is used to make a SOAP call. Usually, in WSDL mode, SOAP functions can be called as methods of the SoapClient object. This method is useful in non-WSDL mode when soapaction is unknown, uri differs from the default or when sending and/or receiving SOAP Headers.

On error, a call to a SOAP function can cause PHP to throw exceptions or return a SoapFault object if exceptions are disabled. To check if the function call failed to catch the SoapFault exceptions, check the result with is_soap_fault().

参数

name

The name of the SOAP function to call.

args

An array of the arguments to pass to the function. This can be either an ordered or an associative array. Note that most SOAP servers require parameter names to be provided, in which case this must be an associative array.

options

An associative array of options to pass to the client.

The location option is the URL of the remote Web service.

The uri option is the target namespace of the SOAP service.

The soapaction option is the action to call.

inputHeaders

An array of headers to be sent along with the SOAP request.

outputHeaders

If supplied, this array will be filled with the headers from the SOAP response.

返回值

SOAP functions may return one, or multiple values. If only one value is returned by the SOAP function, the return value of __soapCall will be a simple value (e.g. an integer, a string, etc). If multiple values are returned, __soapCall will return an associative array of named output parameters.

On error, if the SoapClient object was constructed with the exceptions option set to false, a SoapFault object will be returned.

范例

Example #1 SoapClient::__soapCall() example

<?php

$client = new SoapClient("some.wsdl");
$client->SomeFunction($a, $b, $c);

$client->__soapCall("SomeFunction", array($a, $b, $c));
$client->__soapCall("SomeFunction", array($a, $b, $c), NULL,
                    new SoapHeader(), $output_headers);

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->SomeFunction($a, $b, $c);
$client->__soapCall("SomeFunction", array($a, $b, $c));
$client->__soapCall("SomeFunction", array($a, $b, $c),
                    array('soapaction' => 'some_action',
                          'uri'        => 'some_uri'));
?>

参见

  • SoapClient::__construct() - SoapClient constructor
  • SoapParam::__construct() - SoapParam constructor
  • SoapVar::__construct() - SoapVar constructor
  • SoapHeader::__construct() - SoapHeader constructor
  • SoapFault::__construct() - SoapFault constructor
  • is_soap_fault() - Checks if a SOAP call has failed


The SoapServer class

(PHP 5, PHP 7, PHP 8)

简介

The SoapServer class provides a server for the » SOAP 1.1 and » SOAP 1.2 protocols. It can be used with or without a WSDL service description.

类摘要

SoapServer {
/* 方法 */
public __construct ( string|null $wsdl , array $options = [] )
public addFunction ( mixed $functions ) : void
public addSoapHeader ( SoapHeader $header ) : void
public fault ( string $code , string $string , string $actor = "" , mixed $details = null , string $name = "" ) : void
public getFunctions ( ) : array
public handle ( string|null $request = null ) : void
public setClass ( string $class , mixed ...$args ) : void
public setObject ( object $object ) : void
public setPersistence ( int $mode ) : void
}

Table of Contents

  • SoapServer::addFunction — 添加一个或多个函数来处理SOAP请求
  • SoapServer::addSoapHeader — Add a SOAP header to the response
  • SoapServer::__construct — SoapServer constructor
  • SoapServer::fault — Issue SoapServer fault indicating an error
  • SoapServer::getFunctions — Returns list of defined functions
  • SoapServer::handle — Handles a SOAP request
  • SoapServer::setClass — Sets the class which handles SOAP requests
  • SoapServer::setObject — Sets the object which will be used to handle SOAP requests
  • SoapServer::setPersistence — Sets SoapServer persistence mode


添加一个或多个函数来处理SOAP请求

  • ? SoapServer
  • SoapServer::addSoapHeader ?
  • PHP Manual
  • SoapServer
  • 添加一个或多个函数来处理SOAP请求

SoapServer::addFunction

(PHP 5, PHP 7, PHP 8)

SoapServer::addFunction — 添加一个或多个函数来处理SOAP请求

说明

public SoapServer::addFunction ( mixed $functions ) : void

为远程客户端导出一个或多个函数

参数

functions

导出一个函数，将函数名作为字符串传递给这个参数。

导出多个函数，将一组函数名作为数组传递。

导出所有函数，传递特殊常量 SOAP_FUNCTIONS_ALL.

Note:

functions 接收的所有输入参数必须同时和WSDL文件中定义的 顺序一样（它们不应该接收任何输出变量作为参数）并且返回一个或多个值。如果要返回多个 值，它们必须返回一组被命名的输出参数作为数组。

返回值

没有返回值。

范例

Example #1 SoapServer::addFunction() example

<?php

function echoString($inputString)
{
    return $inputString;
}

$server->addFunction("echoString");

function echoTwoStrings($inputString1, $inputString2)
{
    return array("outputString1" => $inputString1,
                 "outputString2" => $inputString2);
}
$server->addFunction(array("echoString", "echoTwoStrings"));

$server->addFunction(SOAP_FUNCTIONS_ALL);

?>

参见

  • SoapServer::SoapServer()
  • SoapServer::setClass() - Sets the class which handles SOAP requests


Add a SOAP header to the response

  • ? SoapServer::addFunction
  • SoapServer::__construct ?
  • PHP Manual
  • SoapServer
  • Add a SOAP header to the response

SoapServer::addSoapHeader

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

SoapServer::addSoapHeader — Add a SOAP header to the response

说明

public SoapServer::addSoapHeader ( SoapHeader $header ) : void

Adds a SOAP header to be returned with the response to the current request.

参数

header

The header to be returned.

返回值

没有返回值。


SoapServer constructor

  • ? SoapServer::addSoapHeader
  • SoapServer::fault ?
  • PHP Manual
  • SoapServer
  • SoapServer constructor

SoapServer::__construct

(PHP 5, PHP 7, PHP 8)

SoapServer::__construct — SoapServer constructor

说明

public SoapServer::__construct ( string|null $wsdl , array $options = [] )

This constructor allows the creation of SoapServer objects in WSDL or non-WSDL mode.

参数

wsdl

To use the SoapServer in WSDL mode, pass the URI of a WSDL file. Otherwise, pass null and set the uri option to the target namespace for the server.

options

Allow setting a default SOAP version (soap_version), internal character encoding (encoding), and actor URI (actor).

The classmap option can be used to map some WSDL types to PHP classes. This option must be an array with WSDL types as keys and names of PHP classes as values.

The typemap option is an array of type mappings. Type mapping is an array with keys type_name, type_ns (namespace URI), from_xml (callback accepting one string parameter) and to_xml (callback accepting one object parameter).

The cache_wsdl option is one of WSDL_CACHE_NONE, WSDL_CACHE_DISK, WSDL_CACHE_MEMORY or WSDL_CACHE_BOTH.

There is also a features option which can be set to SOAP_WAIT_ONE_WAY_CALLS, SOAP_SINGLE_ELEMENT_ARRAYS, SOAP_USE_XSI_ARRAY_TYPE.

The send_errors option can be set to false to sent a generic error message ("Internal error") instead of the specific error message sent otherwise.

范例

Example #1 SoapServer::__construct() example

<?php

$server = new SoapServer("some.wsdl");

$server = new SoapServer("some.wsdl", array('soap_version' => SOAP_1_2));

$server = new SoapServer("some.wsdl", array('actor' => "http://example.org/ts-tests/C"));

$server = new SoapServer("some.wsdl", array('encoding'=>'ISO-8859-1'));

$server = new SoapServer(null, array('uri' => "http://test-uri/"));

class MyBook {
    public $title;
    public $author;
}

$server = new SoapServer("books.wsdl", array('classmap' => array('book' => "MyBook")));

?>

参见

  • SoapClient::__construct() - SoapClient constructor


Issue SoapServer fault indicating an error

  • ? SoapServer::__construct
  • SoapServer::getFunctions ?
  • PHP Manual
  • SoapServer
  • Issue SoapServer fault indicating an error

SoapServer::fault

(PHP 5, PHP 7, PHP 8)

SoapServer::fault — Issue SoapServer fault indicating an error

说明

public SoapServer::fault ( string $code , string $string , string $actor = "" , mixed $details = null , string $name = "" ) : void

Sends a response to the client of the current request indicating an error.

Note:

This can only be called when handling a request.

参数

code

The error code to return

string

A brief description of the error

actor

A string identifying the actor that caused the fault.

details

More details of the fault

name

The name of the fault. This can be used to select a name from a WSDL file.

返回值

没有返回值。

参见

  • SoapFault::__construct() - SoapFault constructor


Returns list of defined functions

  • ? SoapServer::fault
  • SoapServer::handle ?
  • PHP Manual
  • SoapServer
  • Returns list of defined functions

SoapServer::getFunctions

(PHP 5, PHP 7, PHP 8)

SoapServer::getFunctions — Returns list of defined functions

说明

public SoapServer::getFunctions ( ) : array

Returns a list of the defined functions in the SoapServer object. This method returns the list of all functions added by SoapServer::addFunction() or SoapServer::setClass().

参数

此函数没有参数。

返回值

An array of the defined functions.

范例

Example #1 SoapServer::getFunctions() example

<?php
$server = new SoapServer(NULL, array("uri" => "http://test-uri"));
$server->addFunction(SOAP_FUNCTIONS_ALL);
if ($_SERVER["REQUEST_METHOD"] == "POST") {
  $server->handle();
} else {
  echo "This SOAP server can handle following functions: ";
  $functions = $server->getFunctions();
  foreach($functions as $func) {
    echo $func . "\n";
  }
}
?>

参见

  • SoapServer::__construct() - SoapServer constructor
  • SoapServer::addFunction() - 添加一个或多个函数来处理SOAP请求
  • SoapServer::setClass() - Sets the class which handles SOAP requests


Handles a SOAP request

  • ? SoapServer::getFunctions
  • SoapServer::setClass ?
  • PHP Manual
  • SoapServer
  • Handles a SOAP request

SoapServer::handle

(PHP 5, PHP 7, PHP 8)

SoapServer::handle — Handles a SOAP request

说明

public SoapServer::handle ( string|null $request = null ) : void

Processes a SOAP request, calls necessary functions, and sends a response back.

参数

request

The SOAP request. If this argument is omitted, the request is assumed to be in the raw POST data of the HTTP request.

返回值

没有返回值。

范例

Example #1 SoapServer::handle() example

<?php
function test($x)
{
    return $x;
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

更新日志

版本 | 说明
8.0.0 | request is now nullable.

参见

  • SoapServer::__construct() - SoapServer constructor


Sets the class which handles SOAP requests

  • ? SoapServer::handle
  • SoapServer::setObject ?
  • PHP Manual
  • SoapServer
  • Sets the class which handles SOAP requests

SoapServer::setClass

(PHP 5, PHP 7, PHP 8)

SoapServer::setClass — Sets the class which handles SOAP requests

说明

public SoapServer::setClass ( string $class , mixed ...$args ) : void

Exports all methods from specified class.

The object can be made persistent across request for a given PHP session with the SoapServer::setPersistence() method.

参数

class

The name of the exported class.

args

These optional parameters will be passed to the default class constructor during object creation.

返回值

没有返回值。

参见

  • SoapServer::__construct() - SoapServer constructor
  • SoapServer::addFunction() - 添加一个或多个函数来处理SOAP请求
  • SoapServer::setPersistence() - Sets SoapServer persistence mode


Sets the object which will be used to handle SOAP requests

  • ? SoapServer::setClass
  • SoapServer::setPersistence ?
  • PHP Manual
  • SoapServer
  • Sets the object which will be used to handle SOAP requests

SoapServer::setObject

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

SoapServer::setObject — Sets the object which will be used to handle SOAP requests

说明

public SoapServer::setObject ( object $object ) : void

This sets a specific object as the handler for SOAP requests, rather than just a class as in SoapServer::setClass().

参数

object

The object to handle the requests.

返回值

没有返回值。

参见

  • SoapServer::setClass() - Sets the class which handles SOAP requests


Sets SoapServer persistence mode

  • ? SoapServer::setObject
  • SoapFault ?
  • PHP Manual
  • SoapServer
  • Sets SoapServer persistence mode

SoapServer::setPersistence

(PHP 5, PHP 7, PHP 8)

SoapServer::setPersistence — Sets SoapServer persistence mode

说明

public SoapServer::setPersistence ( int $mode ) : void

This function allows changing the persistence state of a SoapServer object between requests. This function allows saving data between requests utilizing PHP sessions. This method only has an affect on a SoapServer after it has exported functions utilizing SoapServer::setClass().

Note:

The persistence of SOAP_PERSISTENCE_SESSION makes only objects of the given class persistent, but not the class static data. In this case, use $this->bar instead of self::$bar.

Note:

SOAP_PERSISTENCE_SESSION serializes data on the class object between requests. In order to properly utilize resources (e.g. PDO), __wakeup() and __sleep() magic methods should be utilized.

参数

mode

One of the SOAP_PERSISTENCE_XXX constants.

SOAP_PERSISTENCE_REQUEST - SoapServer data does not persist between requests. This is the default behavior of any SoapServer object after setClass is called.

SOAP_PERSISTENCE_SESSION - SoapServer data persists between requests. This is accomplished by serializing the SoapServer class data into $_SESSION['_bogus_session_name'], because of this session_start() must be called before this persistence mode is set.

返回值

没有返回值。

范例

Example #1 SoapServer::setPersistence() example

<?php
 class MyFirstPersistentSoapServer {
     private $resource; // (Such as PDO, mysqli, etc..)
     public $myvar1;
     public $myvar2;

     public function __construct() {
         $this->__wakeup(); // We're calling our wakeup to handle starting our resource
     }

     public function __wakeup() {
         $this->resource = CodeToStartOurResourceUp();
     }

     public function __sleep() {
         // We make sure to leave out $resource here, so our session data remains persistent
         // Failure to do so will result in the failure during the unserialization of data
         // on the next request; thus, our SoapObject would not be persistent across requests.
         return array('myvar1','myvar2');
     }
 }

 try {
     session_start();
     $server = new SoapServer(null, array('uri' => $_SERVER['REQUEST_URI']));
     $server->setClass('MyFirstPersistentSoapServer');
     // setPersistence MUST be called after setClass, because setClass's
     // behavior sets SESSION_PERSISTENCE_REQUEST upon enacting the method.
     $server->setPersistence(SOAP_PERSISTENCE_SESSION);
     $server->handle();
 } catch(SoapFault $e) {
     error_log("SOAP ERROR: ". $e->getMessage());
 }
?>

参见

  • SoapServer::setClass() - Sets the class which handles SOAP requests


The SoapFault class

(PHP 5, PHP 7, PHP 8)

简介

Represents a SOAP fault.

类摘要

SoapFault extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 方法 */
public __construct ( array|string|null $code , string $string , string|null $actor = null , mixed $details = null , string|null $name = null , mixed $headerFault = null )
public __toString ( ) : string
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

Table of Contents

  • SoapFault::__construct — SoapFault constructor
  • SoapFault::__toString — Obtain a string representation of a SoapFault


SoapFault constructor

  • ? SoapFault
  • SoapFault::__toString ?
  • PHP Manual
  • SoapFault
  • SoapFault constructor

SoapFault::__construct

(PHP 5, PHP 7, PHP 8)

SoapFault::__construct — SoapFault constructor

说明

public SoapFault::__construct ( array|string|null $code , string $string , string|null $actor = null , mixed $details = null , string|null $name = null , mixed $headerFault = null )

This class is used to send SOAP fault responses from the PHP handler. faultcode, faultstring, faultactor and detail are standard elements of a SOAP Fault.

参数

faultcode

The error code of the SoapFault.

faultstring

The error message of the SoapFault.

faultactor

A string identifying the actor that caused the error.

detail

More details about the cause of the error.

faultname

Can be used to select the proper fault encoding from WSDL.

headerfault

Can be used during SOAP header handling to report an error in the response header.

范例

Example #1 Some examples

<?php
function test($x)
{
    return new SoapFault("Server", "Some error message");
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

It is possible to use PHP exception mechanism to throw SOAP Fault.

Example #2 Some examples

<?php
function test($x)
{
    throw new SoapFault("Server", "Some error message");
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

参见

  • SoapServer::fault() - Issue SoapServer fault indicating an error
  • is_soap_fault() - Checks if a SOAP call has failed


Obtain a string representation of a SoapFault

  • ? SoapFault::__construct
  • SoapHeader ?
  • PHP Manual
  • SoapFault
  • Obtain a string representation of a SoapFault

SoapFault::__toString

(PHP 5, PHP 7, PHP 8)

SoapFault::__toString — Obtain a string representation of a SoapFault

说明

public SoapFault::__toString ( ) : string

Returns a string representation of the SoapFault.

参数

此函数没有参数。

返回值

A string describing the SoapFault.


The SoapHeader class

(PHP 5, PHP 7, PHP 8)

简介

Represents a SOAP header.

类摘要

SoapHeader {
/* 方法 */
__construct ( string $namespace , string $name , mixed $data = ? , bool $mustunderstand = ? , string $actor = ? )
}

Table of Contents

  • SoapHeader::__construct — SoapHeader constructor


SoapHeader constructor

  • ? SoapHeader
  • SoapParam ?
  • PHP Manual
  • SoapHeader
  • SoapHeader constructor

SoapHeader::__construct

(PHP 5, PHP 7, PHP 8)

SoapHeader::__construct — SoapHeader constructor

说明

SoapHeader::__construct ( string $namespace , string $name , mixed $data = ? , bool $mustunderstand = ? , string $actor = ? )

Constructs a new SoapHeader object.

参数

namespace

The namespace of the SOAP header element.

name

The name of the SoapHeader object.

data

A SOAP header's content. It can be a PHP value or a SoapVar object.

mustUnderstand

Value of the mustUnderstand attribute of the SOAP header element.

actor

Value of the actor attribute of the SOAP header element.

范例

Example #1 SoapHeader::__construct() example

<?php
$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->__soapCall("echoVoid", null, null,
                new SoapHeader('http://soapinterop.org/echoheader/',
                               'echoMeStringRequest',
                               'hello world'));
?>

参见

  • SoapClient::__soapCall() - Calls a SOAP function
  • SoapVar::__construct() - SoapVar constructor
  • SoapParam::__construct() - SoapParam constructor
  • SoapServer::addSoapHeader() - Add a SOAP header to the response


The SoapParam class

(PHP 5, PHP 7, PHP 8)

简介

Represents parameter to a SOAP call.

类摘要

SoapParam {
/* 方法 */
public __construct ( mixed $data , string $name )
}

Table of Contents

  • SoapParam::__construct — SoapParam constructor


SoapParam constructor

  • ? SoapParam
  • SoapVar ?
  • PHP Manual
  • SoapParam
  • SoapParam constructor

SoapParam::__construct

(PHP 5, PHP 7, PHP 8)

SoapParam::__construct — SoapParam constructor

说明

public SoapParam::__construct ( mixed $data , string $name )

Constructs a new SoapParam object.

参数

data

The data to pass or return. This parameter can be passed directly as PHP value, but in this case it will be named as paramN and the SOAP service may not understand it.

name

The parameter name.

范例

Example #1 SoapParam::__construct() example

<?php
$client = new SoapClient(null,array('location' => "http://localhost/soap.php",
                                    'uri'      => "http://test-uri/"));
$client->SomeFunction(new SoapParam($a, "a"),
                      new SoapParam($b, "b"),
                      new SoapParam($c, "c"));
?>

参见

  • SoapClient::__soapCall() - Calls a SOAP function
  • SoapVar::__construct() - SoapVar constructor


The SoapVar class

(PHP 5, PHP 7, PHP 8)

简介

A class representing a variable or object for use with SOAP services.

类摘要

SoapVar {
/* 方法 */
public __construct ( mixed $data , int|null $encoding , string $typeName = "" , string $typeNamespace = "" , string $nodeName = "" , string $nodeNamespace = "" )
}

Table of Contents

  • SoapVar::__construct — SoapVar constructor


SoapVar constructor

  • ? SoapVar
  • Yar ?
  • PHP Manual
  • SoapVar
  • SoapVar constructor

SoapVar::__construct

(PHP 5, PHP 7, PHP 8)

SoapVar::__construct — SoapVar constructor

说明

public SoapVar::__construct
 ( mixed $data
, int|null $encoding
, string $typeName = ""
, string $typeNamespace = ""
, string $nodeName = ""
, string $nodeNamespace = ""
)

Constructs a new SoapVar object.

参数

data

The data to pass or return.

encoding

The encoding ID, one of the XSD_... constants.

type_name

The type name.

type_namespace

The type namespace.

node_name

The XML node name.

node_namespace

The XML node namespace.

范例

Example #1 SoapVar::__construct() example

<?php
class SOAPStruct {
    function SOAPStruct($s, $i, $f)
    {
        $this->varString = $s;
        $this->varInt = $i;
        $this->varFloat = $f;
    }
}
$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$struct = new SOAPStruct('arg', 34, 325.325);
$soapstruct = new SoapVar($struct, SOAP_ENC_OBJECT, "SOAPStruct", "http://soapinterop.org/xsd");
$client->echoStruct(new SoapParam($soapstruct, "inputStruct"));
?>

参见

  • SoapClient::__soapCall() - Calls a SOAP function
  • SoapParam::__construct() - SoapParam constructor


Yet Another RPC Framework

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • Yar_Server — The Yar_Server class
    • Yar_Server::__construct — 创建一个HTTP RPC Server
    • Yar_Server::handle — 启动HTTP RPC Server
  • Yar_Client — The Yar_Client class
    • Yar_Client::__call — 调用远程服务
    • Yar_Client::__construct — 创建一个客户端实例
    • Yar_Client::setOpt — 设置调用的配置
  • Yar_Concurrent_Client — The Yar_Concurrent_Client class
    • Yar_Concurrent_Client::call — 注册一个并行的服务调用
    • Yar_Concurrent_Client::loop — 发送所有注册的并行调用
  • Yar_Server_Exception — The Yar_Server_Exception class
    • Yar_Server_Exception::getType — 获取异常的原始类型
  • Yar_Client_Exception — The Yar_Client_Exception class
    • Yar_Client_Exception::getType — The getType purpose


简介

Yar 是一个轻量级, 高效的RPC框架, 它提供了一种简单方法来让PHP项目之间可以互相远程调用对方的本地方法. 并且Yar也提供了并行调用的能力. 可以支持同时调用多个远程服务的方法.


需求

如果需要使用Msgpack作为打包协议, 则需要在configure的时候加上--enable-msgpack, 并且要保证Msgpack扩展也安装到PHP内.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/yar.

PECL 扩展的 DLL 当前不可用。参见 在 Windows 上构建章节。


运行时配置

这些函数的行为受 php.ini 中的设置影响。

Yar 配置选项
名字 | 默认 | 可修改范围 | 更新日志
yar.packager | php | PHP_INI_SYSTEM |
yar.debug | Off | PHP_INI_ALL |
yar.connect_timeout | 1000 | PHP_INI_ALL |
yar.timeout | 5000 | PHP_INI_ALL |
yar.expose_info | On | PHP_INI_SYS |

这是配置指令的简短说明。

yar.packager string

设置Yar的打包工具, 可以是PHP(serialize), JSON, Msgpack(这个需要编译的时候指定--enable-msgpack).

yar.debug string

打开的时候, Yar会把请求过程的日志都打印出来(到stderr).

yar.connect_timeout integer

连接超时(毫秒为单位)

yar.timeout integer

处理超时(毫秒为单位)

yar.expose_info bool

如果关闭, 则当通过浏览器访问Server的时候, 不会出现Server Info信息.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

YAR_VERSION (string)
YAR_CLIENT_PROTOCOL_HTTP (integer)
YAR_CLIENT_OPT_PACKAGER (integer)
YAR_CLIENT_OPT_TIMEOUT (integer)
YAR_CLIENT_OPT_CONNECT_TIMEOUT (integer)
YAR_PACKAGER_PHP (string)
YAR_PACKAGER_JSON (string)
YAR_ERR_OKEY (integer)
YAR_ERR_OUTPUT (integer)
YAR_ERR_TRANSPORT (integer)
YAR_ERR_REQUEST (integer)
YAR_ERR_PROTOCOL (integer)
YAR_ERR_PACKAGER (integer)
YAR_ERR_EXCEPTION (integer)


范例

Example #1 Yar Server示例

<?php

/* 假设这个页面的访问路径是: http://example.com/operator.php */

class Operator {

    /**
     * Add two operands
     * @param interge
     * @return interge
     */
    public function add($a, $b) {
        return $this->_add($a, $b);
    }

    /**
     * Sub
     */
    public function sub($a, $b) {
        return $a - $b;
    }

    /**
     * Mul
     */
    public function mul($a, $b) {
        return $a * $b;
    }

    /**
     * Protected methods will not be exposed
     * @param interge
     * @return interge
     */
    protected function _add($a, $b) {
        return $a + $b;
    }
}

$server = new Yar_Server(new Operator());
$server->handle();
?>

Example #2 通过浏览器访问(GET请求)

以上例程的输出类似于：

Yar Server Info

Example #3 Yar Client示例

<?php
$client = new yar_client("http://example.com/operator.php");

/* call directly */
var_dump($client->add(1, 2));

/* call via call */
var_dump($client->call("add", array(3, 2)));

/* __add can not be called */
var_dump($client->_add(1, 2));
?>

以上例程的输出类似于：

int(3)
int(5)
PHP Fatal error:  Uncaught exception 'Yar_Server_Exception' with message 'call to api Operator::_add() failed' in *

Example #4 Yar Concurrent Client示例

<?php
function callback($ret, $callinfo) {
    echo $callinfo['method'] , " result: ", $ret , "\n";
}

/* 注册一个异步调用 */
Yar_Concurrent_Client::call("http://example.com/operator.php", "add", array(1, 2), "callback");
Yar_Concurrent_Client::call("http://example.com/operator.php", "sub", array(2, 1), "callback");
Yar_Concurrent_Client::call("http://example.com/operator.php", "mul", array(2, 2), "callback");

/* 发送所有注册的调用, 等待返回, 返回后Yar会调用callback回掉函数 */
Yar_Concurrent_Client::loop();
?>

以上例程的输出类似于：

mul result: 4
sub result: 1
add result: 3


The Yar_Server class

(No version information available, might only be in Git)

简介

类摘要

Yar_Server {
/* 属性 */
protected $_executor ;
/* 方法 */
final public __construct ( Object $obj )
public handle ( ) : boolean
}

属性

_executor

Table of Contents

  • Yar_Server::__construct — 创建一个HTTP RPC Server
  • Yar_Server::handle — 启动HTTP RPC Server


创建一个HTTP RPC Server

  • ? Yar_Server
  • Yar_Server::handle ?
  • PHP Manual
  • Yar_Server
  • 创建一个HTTP RPC Server

Yar_Server::__construct

(PECL yar >= 1.0.0)

Yar_Server::__construct — 创建一个HTTP RPC Server

说明

final public Yar_Server::__construct ( Object $obj )

创建一个Yar的HTTP RPC服务，参数 $obj 对象的所有公开方法都会被注册为服务函数， 可以被RPC调用。

参数

obj

一个对象实例, 这个对象的所有公开方法都会被注册为服务函数.

返回值

返回一个Yar_Server的实例。

范例

Example #1 Yar_Server::__construct()示例

<?php
class API {
    /**
     * the doc info will be generated automatically into service info page.
     * @params
     * @return
     */
    public function some_method($parameter, $option = "foo") {
         return "some_method";
    }

    protected function client_can_not_see() {
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

以上例程的输出类似于：

参见

  • Yar_Server::handle() - 启动HTTP RPC Server
    •


启动HTTP RPC Server

  • ? Yar_Server::__construct
  • Yar_Client ?
  • PHP Manual
  • Yar_Server
  • 启动HTTP RPC Server

Yar_Server::handle

(PECL yar >= 1.0.0)

Yar_Server::handle — 启动HTTP RPC Server

说明

public Yar_Server::handle ( ) : boolean

启动服务, 开始接受客户端的调用请求.

Note:

来自客户端的调用, 都是通过POST请求发送过来的. 如果一个GET请求访问到这个Server, 那在yar.expose_info开启的情况下, 这个服务的Server Info信息会被展现.

参数

此函数没有参数。

返回值

boolean

范例

Example #1 Yar_Server::handle()示例

<?php
class API {
    /**
     * the doc info will be generated automatically into service info page.
     * @params
     * @return
     */
    public function some_method($parameter, $option = "foo") {
    }

    protected function client_can_not_see() {
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

以上例程的输出类似于：

参见

  • Yar_Server::__construct() - 创建一个HTTP RPC Server
    •


The Yar_Client class

(No version information available, might only be in Git)

简介

类摘要

Yar_Client {
/* 属性 */
protected $_protocol ;
protected $_uri ;
protected $_options ;
protected $_running ;
/* 方法 */
public __call ( string $method , array $parameters ) : void
final public __construct ( string $url )
public setOpt ( number $name , mixed $value ) : boolean
}

属性

_protocol

_uri

_options

_running

Table of Contents

  • Yar_Client::__call — 调用远程服务
  • Yar_Client::__construct — 创建一个客户端实例
  • Yar_Client::setOpt — 设置调用的配置


调用远程服务

  • ? Yar_Client
  • Yar_Client::__construct ?
  • PHP Manual
  • Yar_Client
  • 调用远程服务

Yar_Client::__call

(PECL yar >= 1.0.0)

Yar_Client::__call — 调用远程服务

说明

public Yar_Client::__call ( string $method , array $parameters ) : void

发起一个RPC调用, 并且得到返回值. 如果服务端的远程调用抛出异常, 那么本地也会相应的抛出一个Yar_Server_Exception异常.

参数

method

远程服务的名字.

parameters

调用参数.

返回值

范例

Example #1 Yar_Client::__call() example

<?php

$client = new Yar_Client("http://host/api/");

/* 调用远程服务的some_method服务 */
$result = $client->some_method("parameter");

?>

以上例程的输出类似于：

参见

  • Yar_Client::setOpt() - 设置调用的配置
    •


创建一个客户端实例

  • ? Yar_Client::__call
  • Yar_Client::setOpt ?
  • PHP Manual
  • Yar_Client
  • 创建一个客户端实例

Yar_Client::__construct

(PECL yar >= 1.0.0)

Yar_Client::__construct — 创建一个客户端实例

说明

final public Yar_Client::__construct ( string $url )

创建一个Yar_Client 到一个 Yar_Server的实例.

参数

url

服务端的HTTP URL路径.

返回值

Yar_Client实例.

范例

Example #1 Yar_Client::__construct()示例

<?php
$client = new Yar_Client("http://host/api/");
?>

以上例程的输出类似于：

参见

  • Yar_Client::__call() - 调用远程服务
    •

  • Yar_Client::setOpt() - 设置调用的配置
    •


设置调用的配置

  • ? Yar_Client::__construct
  • Yar_Concurrent_Client ?
  • PHP Manual
  • Yar_Client
  • 设置调用的配置

Yar_Client::setOpt

(PECL yar >= 1.0.0)

Yar_Client::setOpt — 设置调用的配置

说明

public Yar_Client::setOpt ( number $name , mixed $value ) : boolean

设置调用远程服务的一些配置, 比如超时值, 打包类型等.

参数

name

可以是: YAR_OPT_PACKAGER, YAR_OPT_PERSISTENT (需要服务端支持keepalive), YAR_OPT_TIMEOUT, YAR_OPT_CONNECT_TIMEOUT

value

返回值

范例

Example #1 Yar_Client::setOpt()示例

<?php

$cient = new Yar_Client("http://host/api/");

//Set timeout to 1s
$client->SetOpt(YAR_OPT_CONNECT_TIMEOUT, 1000);

//Set packager to JSON
$client->SetOpt(YAR_OPT_PACKAGER, "json");

/* call remote service */
$result = $client->some_method("parameter");
?>

以上例程的输出类似于：

参见

  • Yar_Client::__call() - 调用远程服务
    •


The Yar_Concurrent_Client class

(No version information available, might only be in Git)

简介

类摘要

Yar_Concurrent_Client {
/* 属性 */
static $_callstack ;
static $_callback ;
static $_error_callback ;
/* 方法 */
public static call ( string $uri , string $method , array $parameters = ? , callable $callback = ? , callable $error_callback = ? , array $options = ? ) : int
public static loop ( callable $callback = ? , callable $error_callback = ? ) : boolean
}

属性

_callstack

_callback

_error_callback

Table of Contents

  • Yar_Concurrent_Client::call — 注册一个并行的服务调用
  • Yar_Concurrent_Client::loop — 发送所有注册的并行调用


注册一个并行的服务调用

  • ? Yar_Concurrent_Client
  • Yar_Concurrent_Client::loop ?
  • PHP Manual
  • Yar_Concurrent_Client
  • 注册一个并行的服务调用

Yar_Concurrent_Client::call

(PECL yar >= 1.0.0)

Yar_Concurrent_Client::call — 注册一个并行的服务调用

说明

public static Yar_Concurrent_Client::call ( string $uri , string $method , array $parameters = ? , callable $callback = ? , callable $error_callback = ? , array $options = ? ) : int

注册一个并行的(异步的)远程服务调用, 不过这个调用请求不会被立即发出, 而是会在接下来调用 Yar_Concurrent_Client::loop()的时候才真正的发送出去.

参数

uri

RPC 服务的 URI(http 或 tcp).

method

调用的服务名字(也就是服务方法名).

parameters

调用的参数.

callback

回调函数, 在远程服务的返回到达的时候被Yar调用, 从而可以处理返回内容.

返回值

唯一 ID， 可用于区分到底是那个调用的返回.

范例

Example #1 Yar_Concurrent_Client::call()示例

<?php
function callback($retval, $callinfo) {
     var_dump($retval);
}

function error_callback($type, $error, $callinfo) {
    error_log($error);
}

Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback");
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"));   // if the callback is not specificed,
                                                                               // callback in loop will be used
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_PACKAGER => "json"));
                                                                               //this server accept json packager
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_TIMEOUT=>1));
                                                                               //custom timeout

// 这个时候请求都还没有发出
?>

以上例程的输出类似于：

参见

  • Yar_Concurrent_Client::loop() - 发送所有注册的并行调用
    •

  • Yar_Concurrent_Client::reset()
    •

  • Yar_Server::__construct() - 创建一个HTTP RPC Server
    •

  • Yar_Server::handle() - 启动HTTP RPC Server
    •


发送所有注册的并行调用

  • ? Yar_Concurrent_Client::call
  • Yar_Server_Exception ?
  • PHP Manual
  • Yar_Concurrent_Client
  • 发送所有注册的并行调用

Yar_Concurrent_Client::loop

(PECL yar >= 1.0.0)

Yar_Concurrent_Client::loop — 发送所有注册的并行调用

说明

public static Yar_Concurrent_Client::loop ( callable $callback = ? , callable $error_callback = ? ) : boolean

发送所有的已经通过 Yar_Concurrent_Client::call()注册的并行调用, 并且等待返回.

参数

callback

如果这个回掉函数被设置, 那么Yar在发送出所有的请求之后立即调用一次这个回掉函数(此时还没有任何请求返回), 调用的时候$callinfo参数是NULL.

如果在注册并行调用的时候制定了callback, 那么那个callback有更高的优先级.

error_callback

错误回掉函数, 如果设置了, 那么Yar在出错的时候会调用这个回掉函数.

返回值

范例

Example #1 Yar_Concurrent_Client::loop() example

<?php
function callback($retval, $callinfo) {
     if ($callinfo == NULL) {
        echo "现在, 所有的请求都发出去了, 还没有任何请求返回\n";
     } else {
              echo "这是一个远程调用的返回, 调用的服务名是", $callinfo["method"],
                      ". 调用的sequence是 " , $callinfo["sequence"] , "\n";
        var_dump($retval);
     }
}

function error_callback($type, $error, $callinfo) {
    error_log($error);
}

Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback");
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"));   // if the callback is not specificed,
                                                                               // callback in loop will be used
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_PACKAGER => "json"));
                                                                               //this server accept json packager
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_TIMEOUT=>1));
                                                                               //custom timeout

Yar_Concurrent_Client::loop("callback", "error_callback"); //send the requests,
                                                           //the error_callback is optional
?>

以上例程的输出类似于：

现在, 所有的请求都发出去了, 还没有任何请求返回
这是一个远程调用的返回, 调用的服务名是some_method, 调用的sequence是 4
string(11) "some_method"
这是一个远程调用的返回, 调用的服务名是some_method, 调用的sequence是 1
string(11) "some_method"
这是一个远程调用的返回, 调用的服务名是some_method, 调用的sequence是 2
string(11) "some_method"
这是一个远程调用的返回, 调用的服务名是some_method, 调用的sequence是 3
string(11) "some_method"

参见

  • Yar_Concurrent_Client::call() - 注册一个并行的服务调用
  • Yar_Server::__construct() - 创建一个HTTP RPC Server
  • Yar_Server::handle() - 启动HTTP RPC Server


The Yar_Server_Exception class

(No version information available, might only be in Git)

简介

If service threw exceptions, A Yar_Server_Exception will be threw in client side.

类摘要

Yar_Server_Exception extends Exception {
/* 属性 */
protected $_type ;
/* 方法 */
public getType ( ) : string
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

message

code

file

line

_type

Table of Contents

  • Yar_Server_Exception::getType — 获取异常的原始类型


获取异常的原始类型

  • ? Yar_Server_Exception
  • Yar_Client_Exception ?
  • PHP Manual
  • Yar_Server_Exception
  • 获取异常的原始类型

Yar_Server_Exception::getType

(PECL yar >= 1.0.0)

Yar_Server_Exception::getType — 获取异常的原始类型

说明

public Yar_Server_Exception::getType ( ) : string

当服务端的服务函数抛出异常的时候, 客户端本地会响应的抛出一个Yar_Server_Exception异常. 有一个属性, 标明了服务端异常的类型. 这个方法就是获取这个异常类型.

参数

此函数没有参数。

返回值

string

范例

Example #1 Yar_Server_Exception::getType()示例

//Server.php
<?php
class Custom_Exception extends Exception {};

class API {
    public function throw_exception($name) {
        throw new Custom_Exception($name);
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

//Client.php
<?php
$client = new Yar_Client("http://host/api.php");

try {
    $client->throw_exception("client");
} catch (Yar_Server_Exception $e) {
    var_dump($e->getType());
    var_dump($e->getMessage());
}

以上例程的输出类似于：

string(16) "Custom_Exception"
string(6) "client"

参见


The Yar_Client_Exception class

(No version information available, might only be in Git)

简介

类摘要

Yar_Client_Exception extends Exception {
/* 属性 */
/* 方法 */
public getType ( ) : void
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

message

code

file

line

Table of Contents

  • Yar_Client_Exception::getType — The getType purpose


The getType purpose

  • ? Yar_Client_Exception
  • XML-RPC ?
  • PHP Manual
  • Yar_Client_Exception
  • The getType purpose

Yar_Client_Exception::getType

(PECL yar >= 1.0.0)

Yar_Client_Exception::getType — The getType purpose

说明

public Yar_Client_Exception::getType ( ) : void

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值

范例

Example #1 Yar_Client_Exception::getType() example

<?php

/* ... */

?>

以上例程的输出类似于：

...

参见


XML-RPC

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • XML-RPC 函数
    • xmlrpc_decode_request — 将 XML 译码为 PHP 本身的类型
    • xmlrpc_decode — 将 XML 译码为 PHP 本身的类型
    • xmlrpc_encode_request — 为 PHP 的值生成 XML
    • xmlrpc_encode — 为 PHP 的值生成 XML
    • xmlrpc_get_type — 为 PHP 的值获取 xmlrpc 的类型
    • xmlrpc_is_fault — Determines if an array value represents an XMLRPC fault
    • xmlrpc_parse_method_descriptions — 将 XML 译码成方法描述的列表
    • xmlrpc_server_add_introspection_data — 添加自我描述的文档
    • xmlrpc_server_call_method — 解析 XML 请求同时调用方法
    • xmlrpc_server_create — 创建一个 xmlrpc 服务端
    • xmlrpc_server_destroy — 销毁服务端资源
    • xmlrpc_server_register_introspection_callback — 注册一个 PHP 函数用于生成文档
    • xmlrpc_server_register_method — 注册一个 PHP 函数用于匹配 xmlrpc 方法名
    • xmlrpc_set_type — 为一个 PHP 字符串值设置 xmlrpc 的类型、base64 或日期时间


简介

These functions can be used to write XML-RPC servers and clients. You can find more information about XML-RPC at » http://www.xmlrpc.com/, and more documentation on this extension and its functions at » http://xmlrpc-epi.sourceforge.net/.

Warning

此扩展是实验性 的。 此扩展的表象，包括其函数名称以及其他此扩展的相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本扩展风险自担。


安装

默认情况下在 PHP 中是不能使用 XML-RPC 支持的。你需要使用 --with-xmlrpc[=DIR] 配置选项编译 PHP 才能够使用 XML-RPC 支持。从 PHP 4.1.0 开始附带了此扩展。


资源类型

This extension defines a XML-RPC server resource returned by xmlrpc_server_create().


  • ? 资源类型
  • XML-RPC 函数 ?
  • PHP Manual
  • XML-RPC
  • 预定义常量

预定义常量

此扩展没有定义常量。


XML-RPC 函数

Table of Contents

  • xmlrpc_decode_request — 将 XML 译码为 PHP 本身的类型
  • xmlrpc_decode — 将 XML 译码为 PHP 本身的类型
  • xmlrpc_encode_request — 为 PHP 的值生成 XML
  • xmlrpc_encode — 为 PHP 的值生成 XML
  • xmlrpc_get_type — 为 PHP 的值获取 xmlrpc 的类型
  • xmlrpc_is_fault — Determines if an array value represents an XMLRPC fault
  • xmlrpc_parse_method_descriptions — 将 XML 译码成方法描述的列表
  • xmlrpc_server_add_introspection_data — 添加自我描述的文档
  • xmlrpc_server_call_method — 解析 XML 请求同时调用方法
  • xmlrpc_server_create — 创建一个 xmlrpc 服务端
  • xmlrpc_server_destroy — 销毁服务端资源
  • xmlrpc_server_register_introspection_callback — 注册一个 PHP 函数用于生成文档
  • xmlrpc_server_register_method — 注册一个 PHP 函数用于匹配 xmlrpc 方法名
  • xmlrpc_set_type — 为一个 PHP 字符串值设置 xmlrpc 的类型、base64 或日期时间


将 XML 译码为 PHP 本身的类型

  • ? XML-RPC 函数
  • xmlrpc_decode ?
  • PHP Manual
  • XML-RPC 函数
  • 将 XML 译码为 PHP 本身的类型

xmlrpc_decode_request

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_decode_request — 将 XML 译码为 PHP 本身的类型

说明

xmlrpc_decode_request ( string $xml , string &$method , string $encoding = ? ) : mixed
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


将 XML 译码为 PHP 本身的类型

  • ? xmlrpc_decode_request
  • xmlrpc_encode_request ?
  • PHP Manual
  • XML-RPC 函数
  • 将 XML 译码为 PHP 本身的类型

xmlrpc_decode

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_decode — 将 XML 译码为 PHP 本身的类型

说明

xmlrpc_decode ( string $xml , string $encoding = "iso-8859-1" ) : mixed
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

xml

XML response returned by XMLRPC method.

encoding

Input encoding supported by iconv.

返回值

Returns either an array, or an integer, or a string, or a boolean according to the response returned by the XMLRPC method.

范例

See example by xmlrpc_encode_request().

参见

  • xmlrpc_encode_request() - 为 PHP 的值生成 XML
  • xmlrpc_is_fault() - Determines if an array value represents an XMLRPC fault


为 PHP 的值生成 XML

  • ? xmlrpc_decode
  • xmlrpc_encode ?
  • PHP Manual
  • XML-RPC 函数
  • 为 PHP 的值生成 XML

xmlrpc_encode_request

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_encode_request — 为 PHP 的值生成 XML

说明

xmlrpc_encode_request ( string $method , mixed $params , array $output_options = ? ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

method

Name of the method to call.

params

Method parameters compatible with method signature.

output_options

Array specifying output options may contain (default values are emphasised):

  • output_type: php, xml

  • verbosity: no_white_space, newlines_only, pretty

  • escaping: cdata, non-ascii, non-print, markup (may be a string with one value or an array with multiple values)

  • version: simple, xmlrpc, soap 1.1, auto

  • encoding: iso-8859-1, other character set supported by iconv

返回值

Returns a string containing the XML representation of the request.

范例

Example #1 XMLRPC client functions example

<?php
$request = xmlrpc_encode_request("method", array(1, 2, 3));
$context = stream_context_create(array('http' => array(
    'method' => "POST",
    'header' => "Content-Type: text/xml",
    'content' => $request
)));
$file = file_get_contents("http://www.example.com/xmlrpc", false, $context);
$response = xmlrpc_decode($file);
if ($response && xmlrpc_is_fault($response)) {
    trigger_error("xmlrpc: $response[faultString] ($response[faultCode])");
} else {
    print_r($response);
}
?>

参见

  • stream_context_create() - 创建资源流上下文
  • file_get_contents() - 将整个文件读入一个字符串
  • xmlrpc_decode() - 将 XML 译码为 PHP 本身的类型


为 PHP 的值生成 XML

  • ? xmlrpc_encode_request
  • xmlrpc_get_type ?
  • PHP Manual
  • XML-RPC 函数
  • 为 PHP 的值生成 XML

xmlrpc_encode

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_encode — 为 PHP 的值生成 XML

说明

xmlrpc_encode ( mixed $value ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


为 PHP 的值获取 xmlrpc 的类型

  • ? xmlrpc_encode
  • xmlrpc_is_fault ?
  • PHP Manual
  • XML-RPC 函数
  • 为 PHP 的值获取 xmlrpc 的类型

xmlrpc_get_type

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_get_type — 为 PHP 的值获取 xmlrpc 的类型

说明

xmlrpc_get_type ( mixed $value ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

该函数对于 base64 与日期时间字符串特别有用。

参数

value

PHP value

返回值

Returns the XML-RPC type.

范例

Example #1 XML-RPC type example

<?php
echo xmlrpc_get_type(null) . "\n"; // base64
echo xmlrpc_get_type(false) . "\n"; // boolean
echo xmlrpc_get_type(1) . "\n"; // int
echo xmlrpc_get_type(1.0) . "\n"; // double
echo xmlrpc_get_type("") . "\n"; // string
echo xmlrpc_get_type(array()) . "\n"; // array
echo xmlrpc_get_type(new stdClass) . "\n"; // array
echo xmlrpc_get_type(STDIN) . "\n"; // int
?>

参见

  • xmlrpc_set_type() - 为一个 PHP 字符串值设置 xmlrpc 的类型、base64 或日期时间


Determines if an array value represents an XMLRPC fault

  • ? xmlrpc_get_type
  • xmlrpc_parse_method_descriptions ?
  • PHP Manual
  • XML-RPC 函数
  • Determines if an array value represents an XMLRPC fault

xmlrpc_is_fault

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

xmlrpc_is_fault — Determines if an array value represents an XMLRPC fault

说明

xmlrpc_is_fault ( array $arg ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

arg

Array returned by xmlrpc_decode().

返回值

Returns true if the argument means fault, false otherwise. Fault description is available in $arg["faultString"], fault code is in $arg["faultCode"].

范例

See example by xmlrpc_encode_request().

参见

  • xmlrpc_decode() - 将 XML 译码为 PHP 本身的类型


将 XML 译码成方法描述的列表

  • ? xmlrpc_is_fault
  • xmlrpc_server_add_introspection_data ?
  • PHP Manual
  • XML-RPC 函数
  • 将 XML 译码成方法描述的列表

xmlrpc_parse_method_descriptions

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_parse_method_descriptions — 将 XML 译码成方法描述的列表

说明

xmlrpc_parse_method_descriptions ( string $xml ) : array
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


添加自我描述的文档

  • ? xmlrpc_parse_method_descriptions
  • xmlrpc_server_call_method ?
  • PHP Manual
  • XML-RPC 函数
  • 添加自我描述的文档

xmlrpc_server_add_introspection_data

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_add_introspection_data — 添加自我描述的文档

说明

xmlrpc_server_add_introspection_data ( resource $server , array $desc ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


解析 XML 请求同时调用方法

  • ? xmlrpc_server_add_introspection_data
  • xmlrpc_server_create ?
  • PHP Manual
  • XML-RPC 函数
  • 解析 XML 请求同时调用方法

xmlrpc_server_call_method

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_call_method — 解析 XML 请求同时调用方法

说明

xmlrpc_server_call_method ( resource $server , string $xml , mixed $user_data , array $output_options = ? ) : string
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


创建一个 xmlrpc 服务端

  • ? xmlrpc_server_call_method
  • xmlrpc_server_destroy ?
  • PHP Manual
  • XML-RPC 函数
  • 创建一个 xmlrpc 服务端

xmlrpc_server_create

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_create — 创建一个 xmlrpc 服务端

说明

xmlrpc_server_create ( ) : resource
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


销毁服务端资源

  • ? xmlrpc_server_create
  • xmlrpc_server_register_introspection_callback ?
  • PHP Manual
  • XML-RPC 函数
  • 销毁服务端资源

xmlrpc_server_destroy

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_destroy — 销毁服务端资源

说明

xmlrpc_server_destroy ( resource $server ) : int
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


注册一个 PHP 函数用于生成文档

  • ? xmlrpc_server_destroy
  • xmlrpc_server_register_method ?
  • PHP Manual
  • XML-RPC 函数
  • 注册一个 PHP 函数用于生成文档

xmlrpc_server_register_introspection_callback

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_register_introspection_callback — 注册一个 PHP 函数用于生成文档

说明

xmlrpc_server_register_introspection_callback ( resource $server , string $function ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


注册一个 PHP 函数用于匹配 xmlrpc 方法名

  • ? xmlrpc_server_register_introspection_callback
  • xmlrpc_set_type ?
  • PHP Manual
  • XML-RPC 函数
  • 注册一个 PHP 函数用于匹配 xmlrpc 方法名

xmlrpc_server_register_method

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_register_method — 注册一个 PHP 函数用于匹配 xmlrpc 方法名

说明

xmlrpc_server_register_method ( resource $server , string $method_name , string $function ) : bool
Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

Warning

本函数还未编写文档，仅有参数列表。


为一个 PHP 字符串值设置 xmlrpc 的类型、base64 或日期时间

  • ? xmlrpc_server_register_method
  • Windows 专用扩展 ?
  • PHP Manual
  • XML-RPC 函数
  • 为一个 PHP 字符串值设置 xmlrpc 的类型、base64 或日期时间

xmlrpc_set_type

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_set_type — 为一个 PHP 字符串值设置 xmlrpc 的类型、base64 或日期时间

说明

xmlrpc_set_type ( string &$value , string $type ) : bool

为一个 PHP 字符串值设置 xmlrpc 的类型、base64 或日期时间

Warning

此函数是实验性的。此函数的表象，包括名称及其相关文档都可能在未来的 PHP 发布版本中未通知就被修改。使用本函数风险自担。

参数

value

Value to set the type

type

'base64' or 'datetime'

返回值

成功时返回 true， 或者在失败时返回 false。 If successful, value is converted to an object.

范例

Example #1 A xmlrpc_set_type() example

<?php

$params = date("Ymd\TH:i:s", time());
xmlrpc_set_type($params, 'datetime');
echo xmlrpc_encode($params);

?>

以上例程的输出类似于：

<?xml version="1.0" encoding="utf-8"?>
<params>
<param>
 <value>
  <dateTime.iso8601>20090322T23:43:03</dateTime.iso8601>
 </value>
</param>
</params>

错误／异常

Issues E_WARNING with type unsupported by XMLRPC.


Windows 专用扩展

  • COM — COM and .Net (Windows)
    • 简介
    • 安装／配置
    • 预定义常量
    • Errors and error handling
    • 范例
    • com — The com class
    • dotnet — The dotnet class
    • variant — variant class
    • COMPersistHelper — The COMPersistHelper class
    • com_exception — The com_exception class
    • COM 函数
  • win32service
    • 简介
    • 安装／配置
    • 预定义常量
    • Win32ServiceException — The Win32ServiceException class
    • 范例
    • win32service 函数


COM and .Net (Windows)

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • Errors and error handling
  • 范例
    • For Each
    • Arrays and Array-style COM properties
  • com — The com class
    • com::__construct — com class constructor
  • dotnet — The dotnet class
    • dotnet::__construct — dotnet class constructor
  • variant — variant class
    • variant::__construct — variant class constructor
  • COMPersistHelper — The COMPersistHelper class
    • COMPersistHelper::__construct — Construct a COMPersistHelper object
    • COMPersistHelper::GetCurFileName — Get current filename
    • COMPersistHelper::GetMaxStreamSize — Get maximum stream size
    • COMPersistHelper::InitNew — Initialize object to default state
    • COMPersistHelper::LoadFromFile — Load object from file
    • COMPersistHelper::LoadFromStream — Load object from stream
    • COMPersistHelper::SaveToFile — Save object to file
    • COMPersistHelper::SaveToStream — Save object to stream
  • com_exception — The com_exception class
  • COM 函数
    • com_create_guid — Generate a globally unique identifier (GUID)
    • com_event_sink — Connect events from a COM object to a PHP object
    • com_get_active_object — Returns a handle to an already running instance of a COM object
    • com_load_typelib — 装载一个 Typelib
    • com_message_pump — Process COM messages, sleeping for up to timeoutms milliseconds
    • com_print_typeinfo — Print out a PHP class definition for a dispatchable interface
    • variant_abs — Returns the absolute value of a variant
    • variant_add — "Adds" two variant values together and returns the result
    • variant_and — Performs a bitwise AND operation between two variants
    • variant_cast — Convert a variant into a new variant object of another type
    • variant_cat — Concatenates two variant values together and returns the result
    • variant_cmp — Compares two variants
    • variant_date_from_timestamp — Returns a variant date representation of a Unix timestamp
    • variant_date_to_timestamp — Converts a variant date/time value to Unix timestamp
    • variant_div — Returns the result from dividing two variants
    • variant_eqv — Performs a bitwise equivalence on two variants
    • variant_fix — Returns the integer portion of a variant
    • variant_get_type — Returns the type of a variant object
    • variant_idiv — Converts variants to integers and then returns the result from dividing them
    • variant_imp — Performs a bitwise implication on two variants
    • variant_int — Returns the integer portion of a variant
    • variant_mod — Divides two variants and returns only the remainder
    • variant_mul — Multiplies the values of the two variants
    • variant_neg — Performs logical negation on a variant
    • variant_not — Performs bitwise not negation on a variant
    • variant_or — Performs a logical disjunction on two variants
    • variant_pow — Returns the result of performing the power function with two variants
    • variant_round — Rounds a variant to the specified number of decimal places
    • variant_set_type — Convert a variant into another type "in-place"
    • variant_set — Assigns a new value for a variant object
    • variant_sub — Subtracts the value of the right variant from the left variant value
    • variant_xor — Performs a logical exclusion on two variants


简介

COM is an acronym for Component Object Model; it is an object orientated layer (and associated services) on top of DCE RPC (an open standard) and defines a common calling convention that enables code written in any language to call and interoperate with code written in any other language (provided those languages are COM aware). Not only can the code be written in any language, but it need not even be part of the same executable; the code can be loaded from a DLL, be found in another process running on the same machine, or, with DCOM (Distributed COM), be found in another process on a remote machine, all without your code even needing to know where a component resides.

There is a subset of COM known as OLE Automation which comprises a set of COM interfaces that allow loose binding to COM objects, so that they can be introspected and called at run-time without compile-time knowledge of how the object works. The PHP COM extension utilizes the OLE Automation interfaces to allow you to create and call compatible objects from your scripts. Technically speaking, this should really be called the "OLE Automation Extension for PHP", since not all COM objects are OLE compatible.

Now, why would or should you use COM? COM is one of the main ways to glue applications and components together on the Windows platform; using COM you can launch Microsoft Word, fill in a document template and save the result as a Word document and send it to a visitor of your web site. You can also use COM to perform administrative tasks for your network and to configure your IIS; these are just the most common uses; you can do much more with COM.

Additionally, we support the instantiation and creation of .Net assemblies using the COM interoperability layer provided by Microsoft.


需求

COM functions are only available for the Windows version of PHP.

.Net support requires the .Net runtime.


安装

As of PHP 5.3.15 / 5.4.5, this extension requires php_com_dotnet.dll to be enabled inside of php.ini in order to use these functions. Previous versions of PHP enabled these extensions by default.

You are responsible for installing support for the various COM objects that you intend to use (such as MS Word); we don't and can't bundle all of those with PHP.


运行时配置

这些函数的行为受 php.ini 中的设置影响。

COM 配置选项
名字 | 默认 | 可修改范围 | 更新日志
com.allow_dcom | "0" | PHP_INI_SYSTEM |
com.autoregister_typelib | "0" | PHP_INI_ALL |
com.autoregister_verbose | "0" | PHP_INI_ALL |
com.autoregister_casesensitive | "1" | PHP_INI_ALL |
com.code_page | "" | PHP_INI_ALL |
com.dotnet_version | "" | PHP_INI_SYSTEM | As of PHP 8.0.0
com.typelib_file | "" | PHP_INI_SYSTEM |
有关 PHP_INI_* 样式的更多详情与定义，见 配置可被设定范围。

这是配置指令的简短说明。

com.allow_dcom

如果打开此选项，PHP 将被允许以一个 D-COM（Distributed COM）客户方式操作并允许 PHP 脚本在远程服务器上实例化 COM 对象。

com.autoregister_typelib

When this is turned on, PHP will attempt to register constants from the typelibrary of COM objects that it instantiates, if those objects implement the interfaces required to obtain that information. The case sensitivity of the constants it registers is controlled by the configuration directive.

com.autoregister_verbose

When this is turned on, any problems with loading a typelibrary during object instantiation will be reported using the PHP error mechanism. The default is off, which does not emit any indication if there was an error finding or loading the type library.

com.autoregister_casesensitive

When this is turned on (the default), constants found in auto-loaded type libraries when instatiating COM objects will be registered case sensitively. See com_load_typelib() for more details.

com.code_page

It controls the default character set code-page to use when passing strings to and from COM objects. If set to an empty string, PHP will assume that you want CP_ACP, which is the default system ANSI code page.

If the text in your scripts is encoded using a different encoding/character set by default, setting this directive will save you from having to pass the code page as a parameter to the com class constructor. Please note that by using this directive (as with any PHP configuration directive), your PHP script becomes less portable; you should use the COM constructor parameter whenever possible.

com.dotnet_version

The version of the .NET framework to use for dotnet objects. The value of the setting is the first three parts of the framework's version number, separated by dots, and prefixed with v, e.g. v4.0.30319.

com.typelib_file

When set, this should hold the path to a file that contains a list of typelibraries that should be loaded on startup. Each line of the file will be treated as the type library name and loaded as though you had called com_load_typelib(). The constants will be registered persistently, so that the library only needs to be loaded once. If a type library name ends with the string #cis or #case_insensitive, then the constants from that library will be registered case insensitively.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

CLSCTX_INPROC_SERVER (integer)
CLSCTX_INPROC_HANDLER (integer)
CLSCTX_LOCAL_SERVER (integer)
CLSCTX_REMOTE_SERVER (integer)
CLSCTX_SERVER (integer)
CLSCTX_ALL (integer)
VT_NULL (integer)
VT_EMPTY (integer)
VT_UI1 (integer)
VT_I2 (integer)
VT_I4 (integer)
VT_R4 (integer)
VT_R8 (integer)
VT_BOOL (integer)
VT_ERROR (integer)
VT_CY (integer)
VT_DATE (integer)
VT_BSTR (integer)
VT_DECIMAL (integer)
VT_UNKNOWN (integer)
VT_DISPATCH (integer)
VT_VARIANT (integer)
VT_I1 (integer)
VT_UI2 (integer)
VT_UI4 (integer)
VT_INT (integer)
VT_UINT (integer)
VT_ARRAY (integer)
VT_BYREF (integer)
CP_ACP (integer)
CP_MACCP (integer)
CP_OEMCP (integer)
CP_UTF7 (integer)
CP_UTF8 (integer)
CP_SYMBOL (integer)
CP_THREAD_ACP (integer)
VARCMP_LT (integer)
VARCMP_EQ (integer)
VARCMP_GT (integer)
VARCMP_NULL (integer)
NORM_IGNORECASE (integer)
NORM_IGNORENONSPACE (integer)
NORM_IGNORESYMBOLS (integer)
NORM_IGNOREWIDTH (integer)
NORM_IGNOREKANATYPE (integer)
NORM_IGNOREKASHIDA (integer)
DISP_E_DIVBYZERO (integer)
DISP_E_OVERFLOW (integer)
MK_E_UNAVAILABLE (integer)


Errors and error handling

This extension will throw instances of the class com_exception whenever there is a potentially fatal error reported by COM. All COM exceptions have a well-defined code property that corresponds to the HRESULT return value from the various COM operations. You may use this code to make programmatic decisions on how to handle the exception.


  • ? Errors and error handling
  • For Each ?
  • PHP Manual
  • COM
  • 范例

范例

Table of Contents

  • For Each
  • Arrays and Array-style COM properties


For Each

You may use PHP's own foreach statement to iterate over the contents of a standard COM/OLE IEnumVariant. In layman's terms, this means that you can use foreach in places where you would have used For Each in VB/ASP code.

Example #1 For Each in ASP

<%
Set domainObject = GetObject("WinNT://Domain")
For Each obj in domainObject
  Response.Write obj.Name & "<br />"
Next
%>

Example #2 foreach in PHP

<?php
$domainObject = new COM("WinNT://Domain");
foreach ($domainObject as $obj) {
   echo $obj->Name . "<br />";
}
?>


Arrays and Array-style COM properties

Many COM objects expose their properties as arrays, or using array-style access.

You can:

  • Access multi-dimensional arrays, or COM properties that require multiple parameters using PHP array syntax. You can also write or set properties using this technique.

  • Iterate SafeArrays ("true" arrays) using the foreach control structure. This works because SafeArrays include information about their size. If an array-style property implements IEnumVariant then you can also use foreach for that property too; take a look at For Each for more information on this topic.


The com class

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

简介

The com class allows you to instantiate an OLE compatible COM object and call its methods and access its properties.

类摘要

com extends variant {
/* 方法 */
public __construct ( string $module_name , array|string|null $server_name = null , int $codepage = CP_ACP , string $typelib = "" )
}

Overloaded Methods

The returned object is an overloaded object, which means that PHP does not see any fixed methods as it does with regular classes; instead, any property or method accesses are passed through to COM.

PHP will automatically detect methods that accept parameters by reference, and will automatically convert regular PHP variables to a form that can be passed by reference. This means that you can call the method very naturally; you needn't go to any extra effort in your code.

com examples

Example #1 com example (1)

<?php
// starting word
$word = new com("word.application") or die("Unable to instantiate Word");
echo "Loaded Word, version {$word->Version}\n";

//bring it to front
$word->Visible = 1;

//open an empty document
$word->Documents->Add();

//do some weird stuff
$word->Selection->TypeText("This is a test...");
$word->Documents[1]->SaveAs("Useless test.doc");

//closing word
$word->Quit();

//free the object
$word = null;
?>

Example #2 com example (2)

<?php

$conn = new com("ADODB.Connection") or die("Cannot start ADO");
$conn->Open("Provider=SQLOLEDB; Data Source=localhost;
Initial Catalog=database; User ID=user; Password=password");

$rs = $conn->Execute("SELECT * FROM sometable");    // Recordset

$num_columns = $rs->Fields->Count();
echo $num_columns . "\n";

for ($i=0; $i < $num_columns; $i++) {
    $fld[$i] = $rs->Fields($i);
}

$rowcount = 0;
while (!$rs->EOF) {
    for ($i=0; $i < $num_columns; $i++) {
        echo $fld[$i]->value . "\t";
    }
    echo "\n";
    $rowcount++;            // increments rowcount
    $rs->MoveNext();
}

$rs->Close();
$conn->Close();

$rs = null;
$conn = null;

?>

Table of Contents

  • com::__construct — com class constructor


com class constructor

  • ? com
  • dotnet ?
  • PHP Manual
  • com
  • com class constructor

com::__construct

(PHP 4 > 4.1.0, PHP 5, PHP 7, PHP 8)

com::__construct — com class constructor

说明

public com::__construct ( string $module_name , array|string|null $server_name = null , int $codepage = CP_ACP , string $typelib = "" )

Constructs a new com object.

参数

module_name
Can be a ProgID, Class ID or Moniker that names the component to load. A ProgID is typically the application or DLL name, followed by a period, followed by the object name. e.g: Word.Application. A Class ID is the UUID that uniquely identifies a given class. A Moniker is a special form of naming, similar in concept to a URL scheme, that identifies a resource and specifies how it should be loaded. As an example, you could load up Word and get an object representing a word document by specifying the full path to the word document as the module name, or you can use LDAP: as a moniker to use the ADSI interface to LDAP.
server_name
The name of the DCOM server on which the component should be loaded and run. If null, the object is run using the default for the application. The default is typically to run it on the local machine, although the administrator might have configured the application to launch on a different machine. If you specify a non-null value for server, PHP will refuse to load the object unless the configuration option is set to true.

If server_name is an array, it should contain the following elements (case sensitive!). Note that they are all optional (although you need to specify both Username and Password together); if you omit the Server setting, the default server will be used (as mentioned above), and the instantiation of the object will not be affected by the directive.

DCOM server name
key | type | description
Server | string | The name of the server.
Username | string | The username to connect as.
Password | string | The password for Username.
Domain | string | The domain of server.
Flags | integer | One or more of the following constants, logically OR'd together: CLSCTX_INPROC_SERVER, CLSCTX_INPROC_HANDLER, CLSCTX_LOCAL_SERVER, CLSCTX_REMOTE_SERVER, CLSCTX_SERVER and CLSCTX_ALL. The default value if not specified here is CLSCTX_SERVER if you also omit Server, or CLSCTX_REMOTE_SERVER if you do specify a server. You should consult the Microsoft documentation for CoCreateInstance for more information on the meaning of these constants; you will typically never have to use them.

codepage
Specifies the codepage that is used to convert strings to unicode-strings and vice versa. The conversion is applied whenever a PHP string is passed as a parameter or returned from a method of this COM object. The code page is sticky, which means that it will propagate to objects and variants returned from the object. Possible values are CP_ACP (use system default ANSI code page - the default if this parameter is omitted), CP_MACCP, CP_OEMCP, CP_SYMBOL, CP_THREAD_ACP (use codepage/locale set for the current executing thread), CP_UTF7 and CP_UTF8. You may also use the number for a given codepage; consult the Microsoft documentation for more details on codepages and their numeric values.


The dotnet class

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

简介

The dotnet class allows you to instantiate a class from a .Net assembly and call its methods and access its properties, if the class and the methods and properties are » visible to COM.

Neither instantiating static classes nor calling static methods is supported.

Some .Net classes do not implement IDispatch, so while they can be instantiated, calling methods or accessing properties on these classes is not supported.

Note:

You need to install the .Net runtime on your web server to take advantage of this feature.

Note:

.Net framework 4.0 and later are not supported by the dotnet class. If assemblies have been registered with regasm.exe, the classes can be instantiated as com objects, though.

类摘要

dotnet extends variant {
/* 方法 */
public __construct ( string $assembly_name , string $datatype_name , int $codepage = CP_ACP )
}

Overloaded Methods

The returned object is an overloaded object, which means that PHP does not see any fixed methods as it does with regular classes; instead, any property or method accesses are passed through to COM and from there to DOTNET. In other words, the .Net object is mapped through the COM interoperability layer provided by the .Net runtime.

Once you have created a dotnet object, PHP treats it identically to any other COM object; all the same rules apply.

dotnet examples

Example #1 dotnet example

<?php
$stack = new dotnet("mscorlib", "System.Collections.Stack");
$stack->Push(".Net");
$stack->Push("Hello ");
echo $stack->Pop() . $stack->Pop();
?>

Table of Contents

  • dotnet::__construct — dotnet class constructor


dotnet class constructor

  • ? dotnet
  • variant ?
  • PHP Manual
  • dotnet
  • dotnet class constructor

dotnet::__construct

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

dotnet::__construct — dotnet class constructor

说明

public dotnet::__construct ( string $assembly_name , string $datatype_name , int $codepage = CP_ACP )

Constructs a new dotnet object.

参数

assembly_name
Specifies which assembly should be loaded.
datatype_name
Specifices which class in that assembly to instantiate.
codepage
Codepage to use for unicode string transformations; see the com class for more details on code pages.


variant class

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

简介

The VARIANT is COM's equivalent of the PHP zval; it is a structure that can contain a value with a range of different possible types. The variant class provided by the COM extension allows you to have more control over the way that PHP passes values to and from COM.

类摘要

variant {
/* 方法 */
public __construct ( mixed $value = null , int $type = VT_EMPTY , int $codepage = CP_ACP )
}

variant examples

Example #1 variant example

<?php
$v = new variant(42);
print "The type is " . variant_get_type($v) . "<br/>";
print "The value is " . $v . "<br/>";
?>

Note:

When returning a value or fetching a variant property, the variant is converted to a PHP value only when there is a direct mapping between the types that would not result in a loss of information. In all other cases, the result is returned as an instance of the variant class. You can force PHP to convert or evaluate the variant as a PHP native type by using a casting operator explicitly, or implicitly casting to a string by printing it. You may use the wide range of variant functions to perform arithmetic operations on variants without forcing a conversion or risking a loss of data.

See also variant_get_type().

Table of Contents

  • variant::__construct — variant class constructor


variant class constructor

  • ? variant
  • COMPersistHelper ?
  • PHP Manual
  • variant
  • variant class constructor

variant::__construct

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

variant::__construct — variant class constructor

说明

public variant::__construct ( mixed $value = null , int $type = VT_EMPTY , int $codepage = CP_ACP )

Constructs a new variant object.

参数

value
Initial value. If omitted, or set to null an VT_EMPTY object is created.
type
Specifies the content type of the variant object. Possible values are one of the VT_XXX 预定义常量. PHP can detect parameters passed by reference automatically; they do not even need to be passed as variant objects. Consult the MSDN library for additional information on the VARIANT type.
codepage
Specifies the codepage that is used to convert strings to unicode. See the parameter of the same name in the com class for more information.


The COMPersistHelper class

(PHP 5, PHP 7, PHP 8)

简介

COMPersistHelper improves the interoperability of COM and PHP with regard to the php.ini directive open_basedir, and stream 资源(resource)s.

类摘要

final COMPersistHelper {
/* 方法 */
public __construct ( variant|null $variant = null )
public GetCurFileName ( ) : string|false
public GetMaxStreamSize ( ) : int
public InitNew ( ) : bool
public LoadFromFile ( string $filename , int $flags = 0 ) : bool
public LoadFromStream ( resource $stream ) : bool
public SaveToFile ( string|null $filename , bool $remember = true ) : bool
public SaveToStream ( resource $stream ) : bool
}

Table of Contents

  • COMPersistHelper::__construct — Construct a COMPersistHelper object
  • COMPersistHelper::GetCurFileName — Get current filename
  • COMPersistHelper::GetMaxStreamSize — Get maximum stream size
  • COMPersistHelper::InitNew — Initialize object to default state
  • COMPersistHelper::LoadFromFile — Load object from file
  • COMPersistHelper::LoadFromStream — Load object from stream
  • COMPersistHelper::SaveToFile — Save object to file
  • COMPersistHelper::SaveToStream — Save object to stream


Construct a COMPersistHelper object

  • ? COMPersistHelper
  • COMPersistHelper::GetCurFileName ?
  • PHP Manual
  • COMPersistHelper
  • Construct a COMPersistHelper object

COMPersistHelper::__construct

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::__construct — Construct a COMPersistHelper object

说明

public COMPersistHelper::__construct ( variant|null $variant = null )

Constructs a persistence helper object, usually associated with a variant.

参数

variant
A COM object which implements IDispatch. To be able to successfully call any of COMPersistHelper's methods, the object has to implement IPersistFile, IPersistStream and/or IPersistStreamInit. Passing null as variant is only useful if the object is to be loaded from a stream by calling COMPersistHelper::LoadFromStream().


Get current filename

  • ? COMPersistHelper::__construct
  • COMPersistHelper::GetMaxStreamSize ?
  • PHP Manual
  • COMPersistHelper
  • Get current filename

COMPersistHelper::GetCurFileName

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::GetCurFileName — Get current filename

说明

public COMPersistHelper::GetCurFileName ( ) : string|false

Retrieves the current name of the file associated with the object.

参数

此函数没有参数。

返回值

Returns the current name of the file associated with the object.

错误／异常

A com_exception is thrown if the associated object does not implement the COM interface IPersistFile, or when calling the IPersistFile::GetCurFile() method failed.


Get maximum stream size

  • ? COMPersistHelper::GetCurFileName
  • COMPersistHelper::InitNew ?
  • PHP Manual
  • COMPersistHelper
  • Get maximum stream size

COMPersistHelper::GetMaxStreamSize

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::GetMaxStreamSize — Get maximum stream size

说明

public COMPersistHelper::GetMaxStreamSize ( ) : int

Retrieves the size of the stream (in bytes) needed to save the object.

参数

此函数没有参数。

返回值

Returns the size of the stream (in bytes) needed to save the object.

错误／异常

A com_exception is thrown if the associated object does neither implement the COM interface IPersistStream nor IPersistStreamInit, or when calling the IPersistStream::GetSizeMax() method failed.


Initialize object to default state

  • ? COMPersistHelper::GetMaxStreamSize
  • COMPersistHelper::LoadFromFile ?
  • PHP Manual
  • COMPersistHelper
  • Initialize object to default state

COMPersistHelper::InitNew

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::InitNew — Initialize object to default state

说明

public COMPersistHelper::InitNew ( ) : bool

Initializes an object to a default state.

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

A com_exception is thrown if the associated object does not implement the COM interface IPersistStreamInit, or when calling its IPersistStreamInit::Init() method failed.


Load object from file

  • ? COMPersistHelper::InitNew
  • COMPersistHelper::LoadFromStream ?
  • PHP Manual
  • COMPersistHelper
  • Load object from file

COMPersistHelper::LoadFromFile

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::LoadFromFile — Load object from file

说明

public COMPersistHelper::LoadFromFile ( string $filename , int $flags = 0 ) : bool

Opens the specified file and initializes an object from the file contents.

参数

filename
The name of the file from which to load the object.
flags
The access mode to be used when opening the file. Possible values are taken from the » STGM enumeration. The method can treat this value as a suggestion, adding more restrictive permissions if necessary. If flags is 0, the implementation is supposed to open the file using whatever default permissions are used when a user opens the file.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

A com_exception is thrown if the associated object does not implement the COM interface IPersistFile, or when calling the IPersistFile::Load() method failed.


Load object from stream

  • ? COMPersistHelper::LoadFromFile
  • COMPersistHelper::SaveToFile ?
  • PHP Manual
  • COMPersistHelper
  • Load object from stream

COMPersistHelper::LoadFromStream

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::LoadFromStream — Load object from stream

说明

public COMPersistHelper::LoadFromStream ( resource $stream ) : bool

Initializes an object from the stream where it was saved previously.

参数

stream
The stream 资源(resource) from which to load the object.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

A com_exception is thrown if the associated object does not implement the COM interface IPersistStream, or when calling the IPersistStream::Load() method failed.


Save object to file

  • ? COMPersistHelper::LoadFromStream
  • COMPersistHelper::SaveToStream ?
  • PHP Manual
  • COMPersistHelper
  • Save object to file

COMPersistHelper::SaveToFile

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::SaveToFile — Save object to file

说明

public COMPersistHelper::SaveToFile ( string|null $filename , bool $remember = true ) : bool

Saves a copy of the object to the specified file.

参数

filename
The name of the file to which to save the object.
remember
Indicates whether the filename parameter is to be used as the current working file. If true, filename becomes the current file and the object is supposed to clear its dirty flag after the save. If false, this save operation is a "Save A Copy As ..." operation. In this case, the current file is unchanged and the object is not supposed to clear its dirty flag.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

A com_exception is thrown if the associated object does not implement the COM interface IPersistFile, or when calling the IPersistFile::Save() method failed.

范例

Example #1 Basic COMPersistHelper::saveToFile() Usage

<?php
$word = new COM('Word.Application');
$doc = $word->Documents->Add();
$ph = new COMPersistHelper($doc);
$ph->SaveToFile('C:\\Users\\cmb\\Documents\\my.docx');
$word->Quit();
?>


Save object to stream

  • ? COMPersistHelper::SaveToFile
  • com_exception ?
  • PHP Manual
  • COMPersistHelper
  • Save object to stream

COMPersistHelper::SaveToStream

(PHP 5, PHP 7, PHP 8)

COMPersistHelper::SaveToStream — Save object to stream

说明

public COMPersistHelper::SaveToStream ( resource $stream ) : bool

Saves an object to the specified stream.

参数

stream
The stream 资源(resource) to which to save the object.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

A com_exception is thrown if the associated object does neither implement the COM interface IPersistStream nor IPersistStreamInit, or when calling the IPersistStream::Save() method failed.


The com_exception class

(PHP 5, PHP 7, PHP 8)

简介

类摘要

com_exception extends Exception implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


COM 函数

参见

For further information on COM read the » COM specification. You might find some additional useful information in our FAQ for PHP 和 COM. If you're thinking of using MS Office applications on the server side, you should read the information here: » Considerations for Server-Side Automation of Office.

Table of Contents

  • com_create_guid — Generate a globally unique identifier (GUID)
  • com_event_sink — Connect events from a COM object to a PHP object
  • com_get_active_object — Returns a handle to an already running instance of a COM object
  • com_load_typelib — 装载一个 Typelib
  • com_message_pump — Process COM messages, sleeping for up to timeoutms milliseconds
  • com_print_typeinfo — Print out a PHP class definition for a dispatchable interface
  • variant_abs — Returns the absolute value of a variant
  • variant_add — "Adds" two variant values together and returns the result
  • variant_and — Performs a bitwise AND operation between two variants
  • variant_cast — Convert a variant into a new variant object of another type
  • variant_cat — Concatenates two variant values together and returns the result
  • variant_cmp — Compares two variants
  • variant_date_from_timestamp — Returns a variant date representation of a Unix timestamp
  • variant_date_to_timestamp — Converts a variant date/time value to Unix timestamp
  • variant_div — Returns the result from dividing two variants
  • variant_eqv — Performs a bitwise equivalence on two variants
  • variant_fix — Returns the integer portion of a variant
  • variant_get_type — Returns the type of a variant object
  • variant_idiv — Converts variants to integers and then returns the result from dividing them
  • variant_imp — Performs a bitwise implication on two variants
  • variant_int — Returns the integer portion of a variant
  • variant_mod — Divides two variants and returns only the remainder
  • variant_mul — Multiplies the values of the two variants
  • variant_neg — Performs logical negation on a variant
  • variant_not — Performs bitwise not negation on a variant
  • variant_or — Performs a logical disjunction on two variants
  • variant_pow — Returns the result of performing the power function with two variants
  • variant_round — Rounds a variant to the specified number of decimal places
  • variant_set_type — Convert a variant into another type "in-place"
  • variant_set — Assigns a new value for a variant object
  • variant_sub — Subtracts the value of the right variant from the left variant value
  • variant_xor — Performs a logical exclusion on two variants


Generate a globally unique identifier (GUID)

  • ? COM 函数
  • com_event_sink ?
  • PHP Manual
  • COM 函数
  • Generate a globally unique identifier (GUID)

com_create_guid

(PHP 5, PHP 7, PHP 8)

com_create_guid — Generate a globally unique identifier (GUID)

说明

com_create_guid ( ) : string|false

Generates a Globally Unique Identifier (GUID).

A GUID is generated in the same way as DCE UUID's, except that the Microsoft convention is to enclose a GUID in curly braces.

返回值

Returns the GUID as a string, 或者在失败时返回 false.

参见

  • uuid_create() in the PECL uuid extension


Connect events from a COM object to a PHP object

  • ? com_create_guid
  • com_get_active_object ?
  • PHP Manual
  • COM 函数
  • Connect events from a COM object to a PHP object

com_event_sink

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

com_event_sink — Connect events from a COM object to a PHP object

说明

com_event_sink ( variant $variant , object $sink_object , array|string|null $sink_interface = null ) : bool

Instructs COM to sink events generated by variant into the PHP object sink_object.

Be careful how you use this feature; if you are doing something similar to the example below, then it doesn't really make sense to run it in a web server context.

参数

variant

sink_object

sink_object should be an instance of a class with methods named after those of the desired dispinterface; you may use com_print_typeinfo() to help generate a template class for this purpose.

sink_interface

PHP will attempt to use the default dispinterface type specified by the typelibrary associated with variant, but you may override this choice by setting sink_interface to the name of the dispinterface that you want to use.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | sink_interface is nullable now.

范例

Example #1 COM event sink example

<?php
class IEEventSinker {
    var $terminated = false;

   function ProgressChange($progress, $progressmax) {
      echo "Download progress: $progress / $progressmax\n";
    }

    function DocumentComplete(&$dom, $url) {
      echo "Document $url complete\n";
    }

    function OnQuit() {
      echo "Quit!\n";
      $this->terminated = true;
    }
}
$ie = new COM("InternetExplorer.Application");
$sink = new IEEventSinker();
com_event_sink($ie, $sink, "DWebBrowserEvents2");
$ie->Visible = true;
$ie->Navigate("http://www.example.org");
while(!$sink->terminated) {
  com_message_pump(4000);
}
$ie = null;
?>

注释

Caution

Prior to PHP 8.0.0, calling exit() from any of the event handlers is not supported, and may cause PHP to hang. This can be worked around by throwing an exception from the event handler, catching the exception in the main code, and calling exit() from there.

参见

  • com_print_typeinfo() - Print out a PHP class definition for a dispatchable interface
  • com_message_pump() - Process COM messages, sleeping for up to timeoutms milliseconds


Returns a handle to an already running instance of a COM object

  • ? com_event_sink
  • com_load_typelib ?
  • PHP Manual
  • COM 函数
  • Returns a handle to an already running instance of a COM object

com_get_active_object

(PHP 5, PHP 7, PHP 8)

com_get_active_object — Returns a handle to an already running instance of a COM object

说明

com_get_active_object ( string $prog_id , int|null $codepage = null ) : variant

com_get_active_object() is similar to creating a new instance of a com object, except that it will only return an object to your script if the object is already running. OLE applications use something known as the "Running Object Table" to allow well-known applications to be launched only once; this function exposes the COM library function GetActiveObject() to get a handle on a running instance.

参数

prog_id

prog_id must be either the ProgID or CLSID for the object that you want to access (for example Word.Application).

codepage

Acts in precisely the same way that it does for the com class.

返回值

If the requested object is running, it will be returned to your script just like any other COM object.

错误／异常

There are a variety of reasons why this function might fail, the most common being that the object is not already running. In that situation, the exception error code will be MK_E_UNAVAILABLE; you can use the getCode method of the exception object to check the exception code.

更新日志

版本 | 说明
8.0.0 | codepage is nullable now.

注释

Warning

Using com_get_active_object() in a web server context is not always a smart idea. Most COM/OLE applications are not designed to handle more than one client concurrently, even (or especially!) Microsoft Office. You should read » Considerations for Server-Side Automation of Office for more information on the general issues involved.


装载一个 Typelib

  • ? com_get_active_object
  • com_message_pump ?
  • PHP Manual
  • COM 函数
  • 装载一个 Typelib

com_load_typelib

(PHP 4 >= 4.1.0, PHP 5, PHP 7, PHP 8)

com_load_typelib — 装载一个 Typelib

说明

com_load_typelib ( string $typelib_name , bool $case_insensitive = true ) : bool

Loads a type-library and registers its constants in the engine, as though they were defined using define().

Note that it is much more efficient to use the configuration setting to pre-load and register the constants, although not so flexible.

If you have turned on , then PHP will attempt to automatically register the constants associated with a COM object when you instantiate it. This depends on the interfaces provided by the COM object itself, and may not always be possible.

参数

typelib_name

typelib_name can be one of the following:

  • The filename of a .tlb file or the executable module that contains the type library.

  • The type library GUID, followed by its version number, for example {00000200-0000-0010-8000-00AA006D2EA4},2,0.

  • The type library name, e.g. Microsoft OLE DB ActiveX Data Objects 1.0 Library.

PHP will attempt to resolve the type library in this order, as the process gets more and more expensive as you progress down the list; searching for the type library by name is handled by physically enumerating the registry until we find a match.

case_insensitive

The case_insensitive behaves in the same way as the parameter with the same name in the define() function.

返回值

成功时返回 true， 或者在失败时返回 false。


Process COM messages, sleeping for up to timeoutms milliseconds

  • ? com_load_typelib
  • com_print_typeinfo ?
  • PHP Manual
  • COM 函数
  • Process COM messages, sleeping for up to timeoutms milliseconds

com_message_pump

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

com_message_pump — Process COM messages, sleeping for up to timeoutms milliseconds

说明

com_message_pump ( int $timeout_milliseconds = 0 ) : bool

This function will sleep for up to timeout_milliseconds milliseconds, or until a message arrives in the queue.

The purpose of this function is to route COM calls between apartments and handle various synchronization issues. This allows your script to wait efficiently for events to be triggered, while still handling other events or running other code in the background. You should use it in a loop, as demonstrated by the example in the com_event_sink() function, until you are finished using event bound COM objects.

参数

timeout_milliseconds

The timeout, in milliseconds.

If you do not specify a value for timeout_milliseconds, then 0 will be assumed. A 0 value means that no waiting will be performed; if there are messages pending they will be dispatched as before; if there are no messages pending, the function will return false immediately without sleeping.

返回值

If a message or messages arrives before the timeout, they will be dispatched, and the function will return true. If the timeout occurs and no messages were processed, the return value will be false.


Print out a PHP class definition for a dispatchable interface

  • ? com_message_pump
  • variant_abs ?
  • PHP Manual
  • COM 函数
  • Print out a PHP class definition for a dispatchable interface

com_print_typeinfo

(PHP 4 >= 4.2.0, PHP 5, PHP 7, PHP 8)

com_print_typeinfo — Print out a PHP class definition for a dispatchable interface

说明

com_print_typeinfo ( variant|string $variant , string|null $dispatch_interface = null , bool $display_sink = false ) : bool

The purpose of this function is to help generate a skeleton class for use as an event sink. You may also use it to generate a dump of any COM object, provided that it supports enough of the introspection interfaces, and that you know the name of the interface you want to display.

参数

variant

variant should be either an instance of a COM object, or be the name of a typelibrary (which will be resolved according to the rules set out in com_load_typelib()).

dispatch_interface

The name of an IDispatch descendant interface that you want to display.

display_sink

If set to true, the corresponding sink interface will be displayed instead.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • com_event_sink() - Connect events from a COM object to a PHP object
  • com_load_typelib() - 装载一个 Typelib


Returns the absolute value of a variant

  • ? com_print_typeinfo
  • variant_add ?
  • PHP Manual
  • COM 函数
  • Returns the absolute value of a variant

variant_abs

(PHP 5, PHP 7, PHP 8)

variant_abs — Returns the absolute value of a variant

说明

variant_abs ( mixed $value ) : variant

Returns the absolute value of a variant.

参数

value

The variant.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns the absolute value of value.

错误／异常

Throws a com_exception on failure.

参见

  • abs() - 绝对值


"Adds" two variant values together and returns the result

  • ? variant_abs
  • variant_and ?
  • PHP Manual
  • COM 函数
  • "Adds" two variant values together and returns the result

variant_add

(PHP 5, PHP 7, PHP 8)

variant_add — "Adds" two variant values together and returns the result

说明

variant_add ( mixed $left , mixed $right ) : variant

Adds left to right using the following rules (taken from the MSDN library), which correspond to those of Visual Basic:

Variant Addition Rules
If | Then
Both expressions are of the string type | Concatenation
One expression is a string type and the other a character | Addition
One expression is numeric and the other is a string | Addition
Both expressions are numeric | Addition
Either expression is NULL | NULL is returned
Both expressions are empty | Integer subtype is returned

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns the result.

错误／异常

Throws a com_exception on failure.

参见

  • variant_sub() - Subtracts the value of the right variant from the left variant value


Performs a bitwise AND operation between two variants

  • ? variant_add
  • variant_cast ?
  • PHP Manual
  • COM 函数
  • Performs a bitwise AND operation between two variants

variant_and

(PHP 5, PHP 7, PHP 8)

variant_and — Performs a bitwise AND operation between two variants

说明

variant_and ( mixed $left , mixed $right ) : variant

Performs a bitwise AND operation. Note that this is slightly different from a regular AND operation.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Variant AND Rules
If left is | If right is | then the result is
true | true | true
true | false | false
true | null | null
false | true | false
false | false | false
false | null | false
null | true | null
null | false | false
null | null | null

错误／异常

Throws a com_exception on failure.

参见

  • variant_or() - Performs a logical disjunction on two variants


Convert a variant into a new variant object of another type

  • ? variant_and
  • variant_cat ?
  • PHP Manual
  • COM 函数
  • Convert a variant into a new variant object of another type

variant_cast

(PHP 5, PHP 7, PHP 8)

variant_cast — Convert a variant into a new variant object of another type

说明

variant_cast ( variant $variant , int $type ) : variant

This function makes a copy of variant and then performs a variant cast operation to force the copy to have the type given by type.

This function wraps VariantChangeType() in the COM library; consult MSDN for more information.

参数

variant

The variant.

type

type should be one of the VT_XXX constants.

返回值

Returns a variant of given type.

参见

  • variant_set_type() - Convert a variant into another type "in-place"


Concatenates two variant values together and returns the result

  • ? variant_cast
  • variant_cmp ?
  • PHP Manual
  • COM 函数
  • Concatenates two variant values together and returns the result

variant_cat

(PHP 5, PHP 7, PHP 8)

variant_cat — Concatenates two variant values together and returns the result

说明

variant_cat ( mixed $left , mixed $right ) : variant

Concatenates left with right and returns the result.

This function is notionally equivalent to $left . $right.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns the result of the concatenation.

错误／异常

Throws a com_exception on failure.

参见

  • 字符串运算符 for the string concatenation operator


Compares two variants

  • ? variant_cat
  • variant_date_from_timestamp ?
  • PHP Manual
  • COM 函数
  • Compares two variants

variant_cmp

(PHP 5, PHP 7, PHP 8)

variant_cmp — Compares two variants

说明

variant_cmp ( mixed $left , mixed $right , int $locale_id = LOCALE_SYSTEM_DEFAULT , int $flags = 0 ) : int

Compares left with right.

This function will only compare scalar values, not arrays or variant records.

参数

left

The left operand.

right

The right operand.

locale_id

A valid Locale Identifier to use when comparing strings (this affects string collation).

flags

flags can be one or more of the following values OR'd together, and affects string comparisons:

Variant Comparision Flags
value | meaning
NORM_IGNORECASE | Compare case insensitively
NORM_IGNORENONSPACE | Ignore nonspacing characters
NORM_IGNORESYMBOLS | Ignore symbols
NORM_IGNOREWIDTH | Ignore string width
NORM_IGNOREKANATYPE | Ignore Kana type
NORM_IGNOREKASHIDA | Ignore Arabic kashida characters

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns one of the following:

Variant Comparision Results
value | meaning
VARCMP_LT | left is less than right
VARCMP_EQ | left is equal to right
VARCMP_GT | left is greater than right
VARCMP_NULL | Either left, right or both are null


Returns a variant date representation of a Unix timestamp

  • ? variant_cmp
  • variant_date_to_timestamp ?
  • PHP Manual
  • COM 函数
  • Returns a variant date representation of a Unix timestamp

variant_date_from_timestamp

(PHP 5, PHP 7, PHP 8)

variant_date_from_timestamp — Returns a variant date representation of a Unix timestamp

说明

variant_date_from_timestamp ( int $timestamp ) : variant

Converts timestamp from a unix timestamp value into a variant of type VT_DATE. This allows easier interopability between the unix-ish parts of PHP and COM.

参数

timestamp

A unix timestamp.

返回值

Returns a VT_DATE variant.

参见

  • variant_date_to_timestamp() - Converts a variant date/time value to Unix timestamp
  • mktime() - 取得一个日期的 Unix 时间戳
  • time() - 返回当前的 Unix 时间戳


Converts a variant date/time value to Unix timestamp

  • ? variant_date_from_timestamp
  • variant_div ?
  • PHP Manual
  • COM 函数
  • Converts a variant date/time value to Unix timestamp

variant_date_to_timestamp

(PHP 5, PHP 7, PHP 8)

variant_date_to_timestamp — Converts a variant date/time value to Unix timestamp

说明

variant_date_to_timestamp ( variant $variant ) : int|null

Converts variant from a VT_DATE (or similar) value into a Unix timestamp. This allows easier interopability between the Unix-ish parts of PHP and COM.

参数

variant

The variant.

返回值

Returns a unix timestamp, or null on failure.

参见

  • variant_date_from_timestamp() - Returns a variant date representation of a Unix timestamp
  • date() - 格式化一个本地时间／日期
  • strftime() - 根据区域设置格式化本地时间／日期


Returns the result from dividing two variants

  • ? variant_date_to_timestamp
  • variant_eqv ?
  • PHP Manual
  • COM 函数
  • Returns the result from dividing two variants

variant_div

(PHP 5, PHP 7, PHP 8)

variant_div — Returns the result from dividing two variants

说明

variant_div ( mixed $left , mixed $right ) : variant

Divides left by right and returns the result.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Variant Division Rules
If | Then
Both expressions are of the string, date, character, boolean type | Double is returned
One expression is a string type and the other a character | Division and a double is returned
One expression is numeric and the other is a string | Division and a double is returned.
Both expressions are numeric | Division and a double is returned
Either expression is NULL | NULL is returned
right is empty and left is anything but empty | A com_exception with code DISP_E_DIVBYZERO is thrown
left is empty and right is anything but empty. | 0 as type double is returned
Both expressions are empty | A com_exception with code DISP_E_OVERFLOW is thrown

错误／异常

Throws a com_exception on failure.

参见

  • variant_idiv() - Converts variants to integers and then returns the result from dividing them


Performs a bitwise equivalence on two variants

  • ? variant_div
  • variant_fix ?
  • PHP Manual
  • COM 函数
  • Performs a bitwise equivalence on two variants

variant_eqv

(PHP 5, PHP 7, PHP 8)

variant_eqv — Performs a bitwise equivalence on two variants

说明

variant_eqv ( mixed $left , mixed $right ) : variant

Performs a bitwise equivalence on two variants.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

If each bit in left is equal to the corresponding bit in right then true is returned, otherwise false is returned.

错误／异常

Throws a com_exception on failure.


Returns the integer portion of a variant

  • ? variant_eqv
  • variant_get_type ?
  • PHP Manual
  • COM 函数
  • Returns the integer portion of a variant

variant_fix

(PHP 5, PHP 7, PHP 8)

variant_fix — Returns the integer portion of a variant

说明

variant_fix ( mixed $value ) : variant

Gets the integer portion of a variant.

参数

value

The variant.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

If value is negative, then the first negative integer greater than or equal to the variant is returned, otherwise returns the integer portion of the value of value.

错误／异常

Throws a com_exception on failure.

注释

Warning

This documentation is based on the MSDN documentation; it appears that this function is either the same as variant_int(), or that there is an error in the MSDN documentation.

参见

  • variant_int() - Returns the integer portion of a variant
  • variant_round() - Rounds a variant to the specified number of decimal places
  • floor() - 舍去法取整
  • ceil() - 进一法取整
  • round() - 对浮点数进行四舍五入


Returns the type of a variant object

  • ? variant_fix
  • variant_idiv ?
  • PHP Manual
  • COM 函数
  • Returns the type of a variant object

variant_get_type

(PHP 5, PHP 7, PHP 8)

variant_get_type — Returns the type of a variant object

说明

variant_get_type ( variant $variant ) : int

Returns the type of a variant object.

参数

variant

The variant object.

返回值

This function returns an integer value that indicates the type of variant, which can be an instance of com, dotnet or variant classes. The return value can be compared to one of the VT_XXX constants.

The return value for COM and DOTNET objects will usually be VT_DISPATCH; the only reason this function works for those classes is because COM and DOTNET are descendants of VARIANT.

参见

  • variant_set_type() - Convert a variant into another type "in-place"


Converts variants to integers and then returns the result from dividing them

  • ? variant_get_type
  • variant_imp ?
  • PHP Manual
  • COM 函数
  • Converts variants to integers and then returns the result from dividing them

variant_idiv

(PHP 5, PHP 7, PHP 8)

variant_idiv — Converts variants to integers and then returns the result from dividing them

说明

variant_idiv ( mixed $left , mixed $right ) : variant

Converts left and right to integer values, and then performs integer division.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Variant Integer Division Rules
If | Then
Both expressions are of the string, date, character, boolean type | Division and integer is returned
One expression is a string type and the other a character | Division
One expression is numeric and the other is a string | Division
Both expressions are numeric | Division
Either expression is NULL | NULL is returned
Both expressions are empty | A com_exception with code DISP_E_DIVBYZERO is thrown

错误／异常

Throws a com_exception on failure.

参见

  • variant_div() - Returns the result from dividing two variants


Performs a bitwise implication on two variants

  • ? variant_idiv
  • variant_int ?
  • PHP Manual
  • COM 函数
  • Performs a bitwise implication on two variants

variant_imp

(PHP 5, PHP 7, PHP 8)

variant_imp — Performs a bitwise implication on two variants

说明

variant_imp ( mixed $left , mixed $right ) : variant

Performs a bitwise implication operation.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Variant Implication Table
If left is | If right is | then the result is
true | true | true
true | false | false
true | null | true
false | true | true
false | false | true
false | null | true
null | true | true
null | false | null
null | null | null

错误／异常

Throws a com_exception on failure.


Returns the integer portion of a variant

  • ? variant_imp
  • variant_mod ?
  • PHP Manual
  • COM 函数
  • Returns the integer portion of a variant

variant_int

(PHP 5, PHP 7, PHP 8)

variant_int — Returns the integer portion of a variant

说明

variant_int ( mixed $value ) : variant

Gets the integer portion of a variant.

参数

value

The variant.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

If value is negative, then the first negative integer greater than or equal to the variant is returned, otherwise returns the integer portion of the value of value.

错误／异常

Throws a com_exception on failure.

参见

  • variant_fix() - Returns the integer portion of a variant
  • variant_round() - Rounds a variant to the specified number of decimal places
  • floor() - 舍去法取整
  • ceil() - 进一法取整
  • round() - 对浮点数进行四舍五入


Divides two variants and returns only the remainder

  • ? variant_int
  • variant_mul ?
  • PHP Manual
  • COM 函数
  • Divides two variants and returns only the remainder

variant_mod

(PHP 5, PHP 7, PHP 8)

variant_mod — Divides two variants and returns only the remainder

说明

variant_mod ( mixed $left , mixed $right ) : variant

Divides left by right and returns the remainder.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns the remainder of the division.

错误／异常

Throws a com_exception on failure.

参见

  • variant_div() - Returns the result from dividing two variants
  • variant_idiv() - Converts variants to integers and then returns the result from dividing them


Multiplies the values of the two variants

  • ? variant_mod
  • variant_neg ?
  • PHP Manual
  • COM 函数
  • Multiplies the values of the two variants

variant_mul

(PHP 5, PHP 7, PHP 8)

variant_mul — Multiplies the values of the two variants

说明

variant_mul ( mixed $left , mixed $right ) : variant

Multiplies left by right.

参数

left

The left operand.

right

The right operand.

Boolean values are converted to -1 for false and 0 for true.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Variant Multiplication Rules
If | Then
Both expressions are of the string, date, character, boolean type | Multiplication
One expression is a string type and the other a character | Multiplication
One expression is numeric and the other is a string | Multiplication
Both expressions are numeric | Multiplication
Either expression is NULL | NULL is returned
Both expressions are empty | Empty string is returned

错误／异常

Throws a com_exception on failure.

参见

  • variant_div() - Returns the result from dividing two variants
  • variant_idiv() - Converts variants to integers and then returns the result from dividing them


Performs logical negation on a variant

  • ? variant_mul
  • variant_not ?
  • PHP Manual
  • COM 函数
  • Performs logical negation on a variant

variant_neg

(PHP 5, PHP 7, PHP 8)

variant_neg — Performs logical negation on a variant

说明

variant_neg ( mixed $value ) : variant

Performs logical negation of value.

参数

value

The variant.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns the result of the logical negation.

错误／异常

Throws a com_exception on failure.


Performs bitwise not negation on a variant

  • ? variant_neg
  • variant_or ?
  • PHP Manual
  • COM 函数
  • Performs bitwise not negation on a variant

variant_not

(PHP 5, PHP 7, PHP 8)

variant_not — Performs bitwise not negation on a variant

说明

variant_not ( mixed $value ) : variant

Performs bitwise not negation on value and returns the result.

参数

value

The variant.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns the bitwise not negation. If value is null, the result will also be null.

错误／异常

Throws a com_exception on failure.


Performs a logical disjunction on two variants

  • ? variant_not
  • variant_pow ?
  • PHP Manual
  • COM 函数
  • Performs a logical disjunction on two variants

variant_or

(PHP 5, PHP 7, PHP 8)

variant_or — Performs a logical disjunction on two variants

说明

variant_or ( mixed $left , mixed $right ) : variant

Performs a bitwise OR operation. Note that this is slightly different from a regular OR operation.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Variant OR Rules
If left is | If right is | then the result is
true | true | true
true | false | true
true | null | true
false | true | true
false | false | false
false | null | null
null | true | true
null | false | null
null | null | null

错误／异常

Throws a com_exception on failure.

参见

  • variant_and() - Performs a bitwise AND operation between two variants
  • variant_xor() - Performs a logical exclusion on two variants


Returns the result of performing the power function with two variants

  • ? variant_or
  • variant_round ?
  • PHP Manual
  • COM 函数
  • Returns the result of performing the power function with two variants

variant_pow

(PHP 5, PHP 7, PHP 8)

variant_pow — Returns the result of performing the power function with two variants

说明

variant_pow ( mixed $left , mixed $right ) : variant

Returns the result of left to the power of right.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns the result of left to the power of right.

错误／异常

Throws a com_exception on failure.

参见

  • pow() - 指数表达式


Rounds a variant to the specified number of decimal places

  • ? variant_pow
  • variant_set_type ?
  • PHP Manual
  • COM 函数
  • Rounds a variant to the specified number of decimal places

variant_round

(PHP 5, PHP 7, PHP 8)

variant_round — Rounds a variant to the specified number of decimal places

说明

variant_round ( mixed $value , int $decimals ) : variant|null

Returns the value of value rounded to decimals decimal places.

参数

value

The variant.

decimals

Number of decimal places.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Returns the rounded value, or null on failure.

参见

  • round() - 对浮点数进行四舍五入


Convert a variant into another type "in-place"

  • ? variant_round
  • variant_set ?
  • PHP Manual
  • COM 函数
  • Convert a variant into another type "in-place"

variant_set_type

(PHP 5, PHP 7, PHP 8)

variant_set_type — Convert a variant into another type "in-place"

说明

variant_set_type ( variant $variant , int $type ) : void

This function is similar to variant_cast() except that the variant is modified "in-place"; no new variant is created. The parameters for this function have identical meaning to those of variant_cast().

参数

variant

The variant.

type

返回值

没有返回值。

参见

  • variant_cast() - Convert a variant into a new variant object of another type
  • variant_get_type() - Returns the type of a variant object


Assigns a new value for a variant object

  • ? variant_set_type
  • variant_sub ?
  • PHP Manual
  • COM 函数
  • Assigns a new value for a variant object

variant_set

(PHP 5, PHP 7, PHP 8)

variant_set — Assigns a new value for a variant object

说明

variant_set ( variant $variant , mixed $value ) : void

Converts value to a variant and assigns it to the variant object; no new variant object is created, and the old value of variant is freed/released.

参数

variant

The variant.

value

返回值

没有返回值。


Subtracts the value of the right variant from the left variant value

  • ? variant_set
  • variant_xor ?
  • PHP Manual
  • COM 函数
  • Subtracts the value of the right variant from the left variant value

variant_sub

(PHP 5, PHP 7, PHP 8)

variant_sub — Subtracts the value of the right variant from the left variant value

说明

variant_sub ( mixed $left , mixed $right ) : variant

Subtracts right from left.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Variant Subtraction Rules
If | Then
Both expressions are of the string type | Subtraction
One expression is a string type and the other a character | Subtraction
One expression is numeric and the other is a string | Subtraction.
Both expressions are numeric | Subtraction
Either expression is NULL | NULL is returned
Both expressions are empty | Empty string is returned

错误／异常

Throws a com_exception on failure.

参见

  • variant_add() - "Adds" two variant values together and returns the result


Performs a logical exclusion on two variants

  • ? variant_sub
  • win32service ?
  • PHP Manual
  • COM 函数
  • Performs a logical exclusion on two variants

variant_xor

(PHP 5, PHP 7, PHP 8)

variant_xor — Performs a logical exclusion on two variants

说明

variant_xor ( mixed $left , mixed $right ) : variant

Performs a logical exclusion.

参数

left

The left operand.

right

The right operand.

Note:

对于所有变量运算函数，本函数的参数可以是 PHP 内置的类型（整数，字符串，浮点数，布尔型或者 null），或者是一个 COM，VARIANT 或者 DOTNET 类的实例。PHP 内置类型将会使用和构造variant类相同的规则转换成变量。COM 和 DOTNET 对象的值将会取其默认属性并被当成变量值使用。

变量运算函数是同名函数在 COM 库中的外包；有关此类函数的更多信息参见 MSDN 库。PHP 函数命名有少许区别，例如 PHP 中的 variant_add() 对应于 MSDN 文档中的 VarAdd()。

返回值

Variant XOR Rules
If left is | If right is | then the result is
true | true | false
true | false | true
false | true | true
false | false | false
null | null | null

错误／异常

Throws a com_exception on failure.

参见

  • variant_or() - Performs a logical disjunction on two variants
  • variant_and() - Performs a bitwise AND operation between two variants


win32service

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
    • Security consideration
  • 预定义常量
    • Win32Service Service Type Bitmasks
    • Win32Service Service Status Constants
    • Win32Service Service Control Message Constants
    • Win32Service Service Control Message Accepted Bitmasks
    • Win32Service Service Start Type Constants
    • Win32Service Service Error Control Constants
    • Win32Service Service Flag Constants
    • Win32 Error Codes
    • Win32 Base Priority Classes
    • Win32 Recovery action
    • Win32 Service informations
  • Win32ServiceException — The Win32ServiceException class
  • 范例
  • win32service 函数
    • win32_continue_service — Resumes a paused service
    • win32_create_service — Creates a new service entry in the SCM database
    • win32_delete_service — Deletes a service entry from the SCM database
    • win32_get_last_control_message — Returns the last control message that was sent to this service
    • win32_pause_service — Pauses a service
    • win32_query_service_status — Queries the status of a service
    • win32_send_custom_control — Send a custom control to the service
    • win32_set_service_exit_code — Define or return the exit code for the current running service
    • win32_set_service_exit_mode — Define or return the exit mode for the current running service
    • win32_set_service_status — Update the service status
    • win32_start_service_ctrl_dispatcher — Registers the script with the SCM, so that it can act as the service with the given name
    • win32_start_service — Starts a service
    • win32_stop_service — Stops a service


简介

The win32service extension is a Windows specific extension that allows PHP to communicate with the Service Control Manager to start, stop, register and unregister services, and even allows your PHP scripts to run as a service.


安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型
  • Security consideration


需求

The versions of Windows supported are the same as the Visual C++ redistributable package used to build PHP.


安装

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/win32service


  • ? 运行时配置
  • Security consideration ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


Security consideration

This extension needs administrator privileges for some actions such as create, delete, start, stop, pause and continue. This requirement can cause an elevation of privileges if the service control is available from the web interface or remote control.

You can set the ACL on the service after adding it into SCM to delegate the current administration tasks to an non administrator account or service account. For further instructions, see the » Microsoft Knowledge Base.


预定义常量

Table of Contents

  • Win32Service Service Type Bitmasks
  • Win32Service Service Status Constants
  • Win32Service Service Control Message Constants
  • Win32Service Service Control Message Accepted Bitmasks
  • Win32Service Service Start Type Constants
  • Win32Service Service Error Control Constants
  • Win32Service Service Flag Constants
  • Win32 Error Codes
  • Win32 Base Priority Classes
  • Win32 Recovery action
  • Win32 Service informations

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。


Win32Service Service Type Bitmasks

  • ? 预定义常量
  • Win32Service Service Status Constants ?
  • PHP Manual
  • 预定义常量
  • Win32Service Service Type Bitmasks
Win32Service Service Type Bitmasks
Constant | Value | Description
WIN32_SERVICE_WIN32_OWN_PROCESS | 0x00000010 | The service runs in its own process.
WIN32_SERVICE_INTERACTIVE_PROCESS | 0x00000100 | The service can interact with the desktop. This option is not available on Windows Vista or later.
WIN32_SERVICE_WIN32_OWN_PROCESS_INTERACTIVE | 0x00000110 | The service runs in its own process and can interact with the desktop. This option is not available on Windows Vista or later.


Win32Service Service Status Constants

  • ? Win32Service Service Type Bitmasks
  • Win32Service Service Control Message Constants ?
  • PHP Manual
  • 预定义常量
  • Win32Service Service Status Constants
Win32Service Service Status Constants
Constant | Value | Description
WIN32_SERVICE_CONTINUE_PENDING | 0x00000005 | The service continue is pending.
WIN32_SERVICE_PAUSE_PENDING | 0x00000006 | The service pause is pending.
WIN32_SERVICE_PAUSED | 0x00000007 | The service is paused.
WIN32_SERVICE_RUNNING | 0x00000004 | The service is running.
WIN32_SERVICE_START_PENDING | 0x00000002 | The service is starting.
WIN32_SERVICE_STOP_PENDING | 0x00000003 | The service is stopping.
WIN32_SERVICE_STOPPED | 0x00000001 | The service is not running.


Win32Service Service Control Message Constants

  • ? Win32Service Service Status Constants
  • Win32Service Service Control Message Accepted Bitmasks ?
  • PHP Manual
  • 预定义常量
  • Win32Service Service Control Message Constants
Win32Service Service Control Message Constants
Constant | Value | Description
WIN32_SERVICE_CONTROL_CONTINUE | 0x00000003 | Notifies a paused service that it should resume.
WIN32_SERVICE_CONTROL_DEVICEEVENT | 0x0000000B |
WIN32_SERVICE_CONTROL_HARDWAREPROFILECHANGE | 0x0000000C |
WIN32_SERVICE_CONTROL_INTERROGATE | 0x00000004 | Notifies a service that it should report its current status information to the service control manager.
WIN32_SERVICE_CONTROL_NETBINDADD | 0x00000007 | Notifies a network service that there is a new component for binding.
WIN32_SERVICE_CONTROL_NETBINDDISABLE | 0x0000000A | Notifies a network service that one of its bindings has been disabled.
WIN32_SERVICE_CONTROL_NETBINDENABLE | 0x00000009 | Notifies a network service that a disabled binding has been enabled.
WIN32_SERVICE_CONTROL_NETBINDREMOVE | 0x00000008 | Notifies a network service that a component for binding has been removed.
WIN32_SERVICE_CONTROL_PARAMCHANGE | 0x00000006 | Notifies a service that its startup parameters have changed.
WIN32_SERVICE_CONTROL_PAUSE | 0x00000002 | Notifies a service that it should pause.
WIN32_SERVICE_CONTROL_POWEREVENT | 0x0000000D |
WIN32_SERVICE_CONTROL_PRESHUTDOWN | 0x0000000F | Notifies a service that the system will be shutting down. A service that handles this notification blocks system shutdown until the service stops or the preshutdown time-out interval expires. This value is not supported by Windows Server 2003 and Windows XP/2000.
WIN32_SERVICE_CONTROL_SESSIONCHANGE | 0x0000000E |
WIN32_SERVICE_CONTROL_SHUTDOWN | 0x00000005 | Notifies a service that the system is shutting down so the service can perform cleanup tasks. If a service accepts this control code, it must stop after it performs its cleanup tasks. After the SCM sends this control code, it will not send other control codes to the service.
WIN32_SERVICE_CONTROL_STOP | 0x00000001 | Notifies a service that it should stop.


Win32Service Service Control Message Accepted Bitmasks

  • ? Win32Service Service Control Message Constants
  • Win32Service Service Start Type Constants ?
  • PHP Manual
  • 预定义常量
  • Win32Service Service Control Message Accepted Bitmasks
Win32Service Service Control Message Accepted Bitmasks
Constant | Value | Description
WIN32_SERVICE_ACCEPT_HARDWAREPROFILECHANGE | 0x00000020 | The service is notified when the computer's hardware profile has changed. This enables the system to send WIN32_SERVICE_CONTROL_HARDWAREPROFILECHANGE notifications to the service.
WIN32_SERVICE_ACCEPT_NETBINDCHANGE | 0x00000010 | The service is a network component that can accept changes in its binding without being stopped and restarted. This control code allows the service to receive WIN32_SERVICE_CONTROL_NETBINDADD, WIN32_SERVICE_CONTROL_NETBINDREMOVE, WIN32_SERVICE_CONTROL_NETBINDENABLE, and WIN32_SERVICE_CONTROL_NETBINDDISABLE notifications.
WIN32_SERVICE_ACCEPT_PARAMCHANGE | 0x00000008 | The service can reread its startup parameters without being stopped and restarted. This control code allows the service to receive WIN32_SERVICE_CONTROL_PARAMCHANGE notifications.
WIN32_SERVICE_ACCEPT_PAUSE_CONTINUE | 0x00000002 | The service can be paused and continued. This control code allows the service to receive WIN32_SERVICE_CONTROL_PAUSE and WIN32_SERVICE_CONTROL_CONTINUE notifications.
WIN32_SERVICE_ACCEPT_POWEREVENT | 0x00000040 | The service is notified when the computer's power status has changed. This enables the system to send WIN32_SERVICE_CONTROL_POWEREVENT notifications to the service.
WIN32_SERVICE_ACCEPT_PRESHUTDOWN | 0x00000100 | The service can perform preshutdown tasks. This control code enables the service to receive WIN32_SERVICE_CONTROL_PRESHUTDOWN notifications. This value is not supported by Windows Server 2003 and Windows XP/2000.
WIN32_SERVICE_ACCEPT_SESSIONCHANGE | 0x00000080 | The service is notified when the computer's session status has changed. This enables the system to send WIN32_SERVICE_CONTROL_SESSIONCHANGE notifications to the service. Windows 2000: This value is not supported
WIN32_SERVICE_ACCEPT_SHUTDOWN | 0x00000004 | The service is notified when system shutdown occurs. This control code allows the service to receive WIN32_SERVICE_CONTROL_SHUTDOWN notifications.
WIN32_SERVICE_ACCEPT_STOP | 0x00000001 | The service can be stopped. This control code allows the service to receive WIN32_SERVICE_CONTROL_STOP notifications.
WIN32_SERVICE_ACCEPT_TIMECHANGE | 0x00000200 | The service is notified when the system time has changed. This enables the system to send WIN32_SERVICE_CONTROL_TIMECHANGE notifications to the service. Windows Server 2008, Windows Vista, Windows Server 2003, and Windows XP/2000: This control code is not supported.
WIN32_SERVICE_ACCEPT_TRIGGEREVENT | 0x00000400 | The service is notified when an event for which the service has registered occurs. This enables the system to send WIN32_SERVICE_CONTROL_TRIGGEREVENT notifications to the service. Windows Server 2008, Windows Vista, Windows Server 2003, and Windows XP/2000: This control code is not supported.


Win32Service Service Start Type Constants

  • ? Win32Service Service Control Message Accepted Bitmasks
  • Win32Service Service Error Control Constants ?
  • PHP Manual
  • 预定义常量
  • Win32Service Service Start Type Constants
Win32Service Service Start Type Constants
Constant | Value | Description
WIN32_SERVICE_BOOT_START | 0x00000000 | A device driver started by the system loader. This value is valid only for driver services.
WIN32_SERVICE_SYSTEM_START | 0x00000001 | A device driver started by the IoInitSystem function. This value is valid only for driver services.
WIN32_SERVICE_AUTO_START | 0x00000002 | A service started automatically by the service control manager during system startup.
WIN32_SERVICE_DEMAND_START | 0x00000003 | A service started by the service control manager when a process calls the StartService function.
WIN32_SERVICE_DISABLED | 0x00000004 | A service that cannot be started. Attempts to start the service result in the error code WIN32_ERROR_SERVICE_DISABLED.


Win32Service Service Error Control Constants

  • ? Win32Service Service Start Type Constants
  • Win32Service Service Flag Constants ?
  • PHP Manual
  • 预定义常量
  • Win32Service Service Error Control Constants
Win32Service Service Error Control Constants
Constant | Value | Description
WIN32_SERVICE_ERROR_IGNORE | 0x00000000 | The startup program ignores the error and continues the startup operation.
WIN32_SERVICE_ERROR_NORMAL | 0x00000001 | The startup program logs the error in the event log but continues the startup operation.
WIN32_SERVICE_ERROR_SEVERE | 0x00000002 | The startup program logs the error in the event log. If the last-known-good configuration is being started, the startup operation continues. Otherwise, the system is restarted with the last-known-good configuration.
WIN32_SERVICE_ERROR_CRITICAL | 0x00000003 | The startup program logs the error in the event log, if possible. If the last-known-good configuration is being started, the startup operation fails. Otherwise, the system is restarted with the last-known good configuration.


Win32Service Service Flag Constants

  • ? Win32Service Service Error Control Constants
  • Win32 Error Codes ?
  • PHP Manual
  • 预定义常量
  • Win32Service Service Flag Constants
Win32Service Service Flag Constants
Constant | Value | Description
WIN32_SERVICE_RUNS_IN_SYSTEM_PROCESS | 0x00000001 | The service runs in a system process that must always be running.


Win32 Error Codes

  • ? Win32Service Service Flag Constants
  • Win32 Base Priority Classes ?
  • PHP Manual
  • 预定义常量
  • Win32 Error Codes

Note:

These constants are no longer in use as of Win32Service 1.0.0.

Win32 Error Codes
Constant | Value | Description
WIN32_ERROR_ACCESS_DENIED | 0x00000005 | The handle to the SCM database does not have the appropriate access rights.
WIN32_ERROR_CIRCULAR_DEPENDENCY | 0x00000423 | A circular service dependency was specified.
WIN32_ERROR_DATABASE_DOES_NOT_EXIST | 0x00000429 | The specified database does not exist.
WIN32_ERROR_DEPENDENT_SERVICES_RUNNING | 0x0000041B | The service cannot be stopped because other running services are dependent on it.
WIN32_ERROR_DUPLICATE_SERVICE_NAME | 0x00000436 | The display name already exists in the service control manager database either as a service name or as another display name.
WIN32_ERROR_FAILED_SERVICE_CONTROLLER_CONNECT | 0x00000427 | This error is returned if the program is being run as a console application rather than as a service. If the program will be run as a console application for debugging purposes, structure it such that service-specific code is not called.
WIN32_ERROR_INSUFFICIENT_BUFFER | 0x0000007A | The buffer is too small for the service status structure. Nothing was written to the structure.
WIN32_ERROR_INVALID_DATA | 0x0000000D | The specified service status structure is invalid.
WIN32_ERROR_INVALID_HANDLE | 0x00000006 | The handle to the specified service control manager database is invalid.
WIN32_ERROR_INVALID_LEVEL | 0x0000007C | The InfoLevel parameter contains an unsupported value.
WIN32_ERROR_INVALID_NAME | 0x0000007B | The specified service name is invalid.
WIN32_ERROR_INVALID_PARAMETER | 0x00000057 | A parameter that was specified is invalid.
WIN32_ERROR_INVALID_SERVICE_ACCOUNT | 0x00000421 | The user account name specified in the user parameter does not exist. See win32_create_service().
WIN32_ERROR_INVALID_SERVICE_CONTROL | 0x0000041C | The requested control code is not valid, or it is unacceptable to the service.
WIN32_ERROR_PATH_NOT_FOUND | 0x00000003 | The service binary file could not be found.
WIN32_ERROR_SERVICE_ALREADY_RUNNING | 0x00000420 | An instance of the service is already running.
WIN32_ERROR_SERVICE_CANNOT_ACCEPT_CTRL | 0x00000425 | The requested control code cannot be sent to the service because the state of the service is WIN32_SERVICE_STOPPED, WIN32_SERVICE_START_PENDING, or WIN32_SERVICE_STOP_PENDING.
WIN32_ERROR_SERVICE_DATABASE_LOCKED | 0x0000041F | The database is locked.
WIN32_ERROR_SERVICE_DEPENDENCY_DELETED | 0x00000433 | The service depends on a service that does not exist or has been marked for deletion.
WIN32_ERROR_SERVICE_DEPENDENCY_FAIL | 0x0000042C | The service depends on another service that has failed to start.
WIN32_ERROR_SERVICE_DISABLED | 0x00000422 | The service has been disabled.
WIN32_ERROR_SERVICE_DOES_NOT_EXIST | 0x00000424 | The specified service does not exist as an installed service.
WIN32_ERROR_SERVICE_EXISTS | 0x00000431 | The specified service already exists in this database.
WIN32_ERROR_SERVICE_LOGON_FAILED | 0x0000042D | The service did not start due to a logon failure. This error occurs if the service is configured to run under an account that does not have the "Log on as a service" right.
WIN32_ERROR_SERVICE_MARKED_FOR_DELETE | 0x00000430 | The specified service has already been marked for deletion.
WIN32_ERROR_SERVICE_NO_THREAD | 0x0000041E | A thread could not be created for the service.
WIN32_ERROR_SERVICE_NOT_ACTIVE | 0x00000426 | The service has not been started.
WIN32_ERROR_SERVICE_REQUEST_TIMEOUT | 0x0000041D | The process for the service was started, but it did not call StartServiceCtrlDispatcher, or the thread that called StartServiceCtrlDispatcher may be blocked in a control handler function.
WIN32_ERROR_SHUTDOWN_IN_PROGRESS | 0x0000045B | The system is shutting down; this function cannot be called.
WIN32_ERROR_SERVICE_SPECIFIC_ERROR | 0x0000042A | The service has returned a service-specific error code.
WIN32_NO_ERROR | 0x00000000 | No error.


Win32 Base Priority Classes

  • ? Win32 Error Codes
  • Win32 Recovery action ?
  • PHP Manual
  • 预定义常量
  • Win32 Base Priority Classes
Win32 Base Priority Classes
Constant | Value | Description
WIN32_ABOVE_NORMAL_PRIORITY_CLASS | 0x00008000 | Process that has priority above WIN32_NORMAL_PRIORITY_CLASS but below WIN32_HIGH_PRIORITY_CLASS.
WIN32_BELOW_NORMAL_PRIORITY_CLASS | 0x00004000 | Process that has priority above WIN32_IDLE_PRIORITY_CLASS but below WIN32_NORMAL_PRIORITY_CLASS.
WIN32_HIGH_PRIORITY_CLASS | 0x00000080 | Process that performs time-critical tasks that must be executed immediately. The threads of the process preempt the threads of normal or idle priority class processes. An example is the Task List, which must respond quickly when called by the user, regardless of the load on the operating system. Use extreme care when using the high-priority class, because a high-priority class application can use nearly all available CPU time.
WIN32_IDLE_PRIORITY_CLASS | 0x00000040 | Process whose threads run only when the system is idle. The threads of the process are preempted by the threads of any process running in a higher priority class. An example is a screen saver. The idle-priority class is inherited by child processes.
WIN32_NORMAL_PRIORITY_CLASS | 0x00000020 | Process with no special scheduling needs.
WIN32_REALTIME_PRIORITY_CLASS | 0x00000100 | Process that has the highest possible priority. The threads of the process preempt the threads of all other processes, including operating system processes performing important tasks. For example, a real-time process that executes for more than a very brief interval can cause disk caches not to flush or cause the mouse to be unresponsive.


Win32 Recovery action

  • ? Win32 Base Priority Classes
  • Win32 Service informations ?
  • PHP Manual
  • 预定义常量
  • Win32 Recovery action
Win32 Recovery action
Constant | Value | Description
WIN32_SC_ACTION_NONE | 0x00000000 | No action.
WIN32_SC_ACTION_REBOOT | 0x00000001 | Restart the server.
WIN32_SC_ACTION_RESTART | 0x00000002 | Restart the service.
WIN32_SC_ACTION_RUN_COMMAND | 0x00000003 | Run a command.


Win32 Service informations

  • ? Win32 Recovery action
  • Win32ServiceException ?
  • PHP Manual
  • 预定义常量
  • Win32 Service informations
Win32 Service informations
Constant | Value | Description
WIN32_INFO_SERVICE | "service" |
WIN32_INFO_DISPLAY | "display" |
WIN32_INFO_USER | "user" |
WIN32_INFO_PASSWORD | "password" |
WIN32_INFO_PATH | "path" |
WIN32_INFO_PARAMS | "params" |
WIN32_INFO_DESCRIPTION | "description" |
WIN32_INFO_START_TYPE | "start_type" |
INFO_LOAD_ORDER | "load_order" |
INFO_SVC_TYPE | "svc_type" |
INFO_ERROR_CONTROL | "error_control" |
INFO_DELAYED_START | "delayed_start" |
INFO_BASE_PRIORITY | "base_priority" |
INFO_DEPENDENCIES | "dependencies" |
INFO_RECOVERY_DELAY | "recovery_delay" |
INFO_RECOVERY_ACTION_1 | "recovery_action_1" |
INFO_RECOVERY_ACTION_2 | "recovery_action_2" |
INFO_RECOVERY_ACTION_3 | "recovery_action_3" |
INFO_RECOVERY_RESET_PERIOD | "recovery_reset_period" |
INFO_RECOVERY_ENABLED | "recovery_enabled" |
INFO_RECOVERY_REBOOT_MSG | "recovery_reboot_msg" |
INFO_RECOVERY_COMMAND | "recovery_command" |


The Win32ServiceException class

(PECL win32service >=1.0.0)

简介

The exception replaces the old mechanism where the error value needed to be compared to constants to detect which error was emitted. The Exception code is equal to the value of the error value and the exception message is based on the corresponding constant name.

类摘要

Win32ServiceException extends Exception {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


范例

Example #1 Registering a PHP script to run as a service

<?php
win32_create_service(array(
    'service'     => 'dummyphp',                                           # the name of your service
    'display'     => 'sample dummy PHP service',                           # short description
    'description' => 'This is a dummy Windows service created using PHP.', # long description
    'params'      => '"' . __FILE__ . '"  run',                            # path to the script and parameters
));
?>

Example #2 Unregistering a service

<?php
win32_delete_service('dummyphp');
?>

Example #3 Running as a service

<?php
if ($argv[1] == 'run') {
  win32_start_service_ctrl_dispatcher('dummyphp');

  while (WIN32_SERVICE_CONTROL_STOP != win32_get_last_control_message()) {
    # do your work here.
    # try not to take up more than 30 seconds before going around the loop
    # again
  }
}
?>


win32service 函数

Table of Contents

  • win32_continue_service — Resumes a paused service
  • win32_create_service — Creates a new service entry in the SCM database
  • win32_delete_service — Deletes a service entry from the SCM database
  • win32_get_last_control_message — Returns the last control message that was sent to this service
  • win32_pause_service — Pauses a service
  • win32_query_service_status — Queries the status of a service
  • win32_send_custom_control — Send a custom control to the service
  • win32_set_service_exit_code — Define or return the exit code for the current running service
  • win32_set_service_exit_mode — Define or return the exit mode for the current running service
  • win32_set_service_status — Update the service status
  • win32_start_service_ctrl_dispatcher — Registers the script with the SCM, so that it can act as the service with the given name
  • win32_start_service — Starts a service
  • win32_stop_service — Stops a service


Resumes a paused service

  • ? win32service 函数
  • win32_create_service ?
  • PHP Manual
  • win32service 函数
  • Resumes a paused service

win32_continue_service

(PECL win32service >=0.1.0)

win32_continue_service — Resumes a paused service

说明

win32_continue_service ( string $servicename , string $machine = ? ) : void

Resumes a paused, named service. Requires administrative privileges or an account with appropriate rights set in the service's ACL.

参数

servicename

The short name of the service.

machine

Optional machine name. If omitted, the local machine is used.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

A ValueError is thrown if the value of servicename parameter is empty.

A Win32ServiceException is thrown on error.

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.
PECL win32service 0.3.0 | This function does not longer require an administrator account if ACL is set for another account.

参见

  • win32_start_service() - Starts a service
  • win32_stop_service() - Stops a service
  • win32_pause_service() - Pauses a service
  • win32_send_custom_control() - Send a custom control to the service
  • Win32 Error Codes


Creates a new service entry in the SCM database

  • ? win32_continue_service
  • win32_delete_service ?
  • PHP Manual
  • win32service 函数
  • Creates a new service entry in the SCM database

win32_create_service

(PECL win32service >=0.1.0)

win32_create_service — Creates a new service entry in the SCM database

说明

win32_create_service ( array $details , string $machine = ? ) : void

Attempts to add a service into the SCM database. Administrative privileges are required for this to succeed.

参数

details

An array of service details:

service

The short name of the service. This is the name that you will use to control the service using the net command. The service must be unique (no two services can share the same name), and, ideally, should avoid having spaces in the name.

display

The display name of the service. This is the name that you will see in the Services Applet.

description

The long description of the service. This is the description that you will see in the Services Applet.

user

The name of the user account under which you want the service to run. If omitted, the service will run as the LocalSystem account. If the username is specified, you must also provide a password.

password

The password that corresponds to the user.

path

The full path to the executable module that will be launched when the service is started. If omitted, the path to the current PHP process will be used.

params

Command line parameters to pass to the service when it starts. If you want to run a PHP script as the service, then the first parameter should be the full path to the PHP script that you intend to run. If the script name or path contains spaces, then wrap the full path to the PHP script with ".

load_order

Controls the load_order. This is not yet fully supported.

svc_type

Sets the service type. If omitted, the default value is WIN32_SERVICE_WIN32_OWN_PROCESS. Don't change this unless you know what you're doing.

start_type

Specifies how the service should be started. The default is WIN32_SERVICE_AUTO_START which means the service will be launched when the machine starts up.

error_control

Informs the SCM what it should do when it detects a problem with the service. The default is WIN32_SERVER_ERROR_IGNORE. Changing this value is not yet fully supported.

delayed_start

If delayed_start is set to true, then this will inform the SCM that this service should be started after other auto-start services are started plus a short delay.

Any service can be marked as a delayed auto-start service; however, this setting has no effect unless the service's start_type is WIN32_SERVICE_AUTO_START.

This setting is only applicable on Windows Vista and Windows Server 2008 or greater.

base_priority

To reduce the impact on processor utilisation, it may be necessary to set a base priority lower than normal.

The base_priority can be set to one of the constants define in Win32 Base Priority Classes.

dependencies

To define the dependencies for your service, it may be necessary to set this parameter to the list of the services names in an array.

recovery_delay

This parameter defines the delay between the fail and the execution of recovery action. The value is in milliseconds.

The default value is 60000.

recovery_action_1

The action will be executed on first failure. The default value is WIN32_SC_ACTION_NONE.

The recovery_action_1 can be set to one of the constants defined in Win32 Recovery action.

recovery_action_2

The action will be executed on second failure. The default value is WIN32_SC_ACTION_NONE.

The recovery_action_2 can be set to one of the constants defined in Win32 Recovery action.

recovery_action_3

The action will be executed on next failures. The default value is WIN32_SC_ACTION_NONE.

The recovery_action_3 can be set to one of the constants defined in Win32 Recovery action.

recovery_reset_period

The failure count will be reset after the delay defined in the parameter. The delay is expirement in seconds.

The default value is 86400.

recovery_enabled

Set this parameter at true to enable the recovery settings, false to disable.

The default value is false

recovery_reboot_msg

Set this parameter to define the message saved into the Windows Event Log before the reboot. Used only if one action is set to WIN32_SC_ACTION_REBOOT.

recovery_command

Set this parameter to define the command executed when one action is defined on WIN32_SC_ACTION_RUN_COMMAND.

machine

The optional machine name on which you want to create a service. If omitted, it will use the local machine.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

A ValueError is thrown if the; value of service parameter is empty.

A ValueError is thrown if the; value of path parameter is missing or empty.

A ValueError is thrown if the; value of svc_type parameter is wrong.

A ValueError is thrown if the; value of start_type parameter is wrong.

A ValueError is thrown if the; value of error_control parameter is wrong.

A ValueError is thrown if the; value of base_priority parameter is wrong.

A ValueError is thrown if the; value of recovery_delay parameter is not between 0 and PHP_INT_MAX.

A ValueError is thrown if the; value of recovery_action_1 parameter is wrong.

A ValueError is thrown if the; value of recovery_action_2 parameter is wrong.

A ValueError is thrown if the; value of recovery_action_3 parameter is wrong.

A ValueError is thrown if the; value of recovery_reset_period parameter is not between 0 and PHP_INT_MAX.

A Win32ServiceException is thrown on error.

范例

Example #1 A win32_create_service() example

Create a service with the short name 'dummyphp'.

<?php
$x = win32_create_service(array(
    'service'     => 'dummyphp',                                           // the name of your service
    'display'     => 'sample dummy PHP service',                           // short description
    'description' => 'This is a dummy Windows service created using PHP.', // long description
    'params'      => '"' . __FILE__ . '"  run',                            // path to the script and parameters
));
debug_zval_dump($x);
?>

Example #2 A win32_create_service() example with dependencies

Create a service with the short name 'dummyphp' and dependencies.

<?php
$x = win32_create_service(array(
    'service'      => 'dummyphp',                                           // the name of your service
    'display'      => 'sample dummy PHP service',                           // short description
    'description'  => 'This is a dummy Windows service created using PHP.', // long description
    'params'       => '"' . __FILE__ . '"  run',                            // path to the script and parameters
    'dependencies' => array("Netman"),                                      // The list of the dependencies
));
debug_zval_dump($x);
?>

Example #3 A win32_create_service() example with recovery

Create a service with the short name 'dummyphp' and recovery settings.

<?php
$x = win32_create_service(array(
    'service'               => 'dummyphp',                                           // the name of your service
    'display'               => 'sample dummy PHP service',                           // short description
    'description'           => 'This is a dummy Windows service created using PHP.', // long description
    'params'                => '"' . __FILE__ . '"  run',                            // path to the script and parameters
    'recovery_delay'        => 120000,                                               // Recovery action is executed after 2 minutes
    'recovery_action_1'     => WIN32_SC_ACTION_RESTART,                              // On first failure, restart the service
    'recovery_action_2'     => WIN32_SC_ACTION_RUN_COMMAND,                          // On second failure, execute the commmand
    'recovery_action_3'     => WIN32_SC_ACTION_NONE,                                 // On other failure, do nothing
    'recovery_reset_period' => 86400,                                                // Reset the fail counter after 1 day
    'recovery_enabled'      => true,                                                 // Enable the recovery parameter
    'recovery_reboot_msg'   => null,                                                 // Do not define a reboot message, it's not needed here
    'recovery_command'      => "c:\clean-service.bat",                               // When the action is WIN32_SC_ACTION_RUN_COMMAND, execute this command
));
debug_zval_dump($x);
?>

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.
PECL win32service 0.4.0 | The dependencies, recovery_delay, recovery_action_1, recovery_action_2, recovery_action_3, recovery_reset_period, recovery_enabled, recovery_reboot_msg and recovery_command parameters have been added.

参见

  • win32_delete_service() - Deletes a service entry from the SCM database
  • Win32 Base Priority Classes
  • Win32 Recovery action
  • Win32 Error Codes


Deletes a service entry from the SCM database

  • ? win32_create_service
  • win32_get_last_control_message ?
  • PHP Manual
  • win32service 函数
  • Deletes a service entry from the SCM database

win32_delete_service

(PECL win32service >=0.1.0)

win32_delete_service — Deletes a service entry from the SCM database

说明

win32_delete_service ( string $servicename , string $machine = ? ) : void

Attempts to delete a service from the SCM database. Administrative privileges are required for this to succeed.

This function really just marks the service for deletion. If other processes (such as the Services Applet) are open, then the deletion will be deferred until those applications are closed. If a service is marked for deletion, further attempts to delete it will fail, and attempts to create a new service with that name will also fail.

参数

servicename

The short name of the service.

machine

The optional machine name. If omitted, the local machine will be used.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

A ValueError is thrown if the; value of servicename parameter is empty.

A Win32ServiceException is thrown on error.

范例

Example #1 A win32_delete_service() example

Deletes the dummyphp service.

<?php
win32_delete_service('dummyphp');
?>

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.

参见

  • win32_create_service() - Creates a new service entry in the SCM database
  • Win32 Error Codes


Returns the last control message that was sent to this service

  • ? win32_delete_service
  • win32_pause_service ?
  • PHP Manual
  • win32service 函数
  • Returns the last control message that was sent to this service

win32_get_last_control_message

(PECL win32service >=0.1.0)

win32_get_last_control_message — Returns the last control message that was sent to this service

说明

win32_get_last_control_message ( ) : int

Returns the control code that was last sent to this service process. When running as a service you should periodically check this to determine if your service needs to stop running.

Caution

Since version 0.2.0, this function work only in "cli" SAPI. On other SAPI this function is disabled.

返回值

Returns a control constant which will be one of the Win32Service Service Control Message Constants: WIN32_SERVICE_CONTROL_CONTINUE, WIN32_SERVICE_CONTROL_DEVICEEVENT, WIN32_SERVICE_CONTROL_HARDWAREPROFILECHANGE, WIN32_SERVICE_CONTROL_INTERROGATE, WIN32_SERVICE_CONTROL_NETBINDADD, WIN32_SERVICE_CONTROL_NETBINDDISABLE, WIN32_SERVICE_CONTROL_NETBINDENABLE, WIN32_SERVICE_CONTROL_NETBINDREMOVE, WIN32_SERVICE_CONTROL_PARAMCHANGE, WIN32_SERVICE_CONTROL_PAUSE, WIN32_SERVICE_CONTROL_POWEREVENT, WIN32_SERVICE_CONTROL_PRESHUTDOWN, WIN32_SERVICE_CONTROL_SESSIONCHANGE, WIN32_SERVICE_CONTROL_SHUTDOWN, WIN32_SERVICE_CONTROL_STOP.

If the value is between 128 and 255, the control code is custom.

错误／异常

Prior to version 1.0.0, if the SAPI is not "cli", this function emits an E_ERROR level error.

As of version 1.0.0, will throw a Win32ServiceException if SAPI is not "cli"

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 0.2.0 | This function works only in the "cli" SAPI.

参见

  • win32_start_service_ctrl_dispatcher() - Registers the script with the SCM, so that it can act as the service with the given name
  • win32_set_service_status() - Update the service status
  • win32_set_service_exit_mode() - Define or return the exit mode for the current running service
  • win32_set_service_exit_code() - Define or return the exit code for the current running service
  • Win32Service Service Control Message Constants


Pauses a service

  • ? win32_get_last_control_message
  • win32_query_service_status ?
  • PHP Manual
  • win32service 函数
  • Pauses a service

win32_pause_service

(PECL win32service >=0.1.0)

win32_pause_service — Pauses a service

说明

win32_pause_service ( string $servicename , string $machine = ? ) : void

Pauses a named service. Requires administrative privileges or an account with appropriate rights set in the service's ACL.

参数

servicename

The short name of the service.

machine

Optional machine name. If omitted, the local machine is used.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

A ValueError is thrown if the; value of servicename parameter is empty.

A Win32ServiceException is thrown on error.

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.
PECL win32service 0.3.0 | This function does not longer require an administrator account if ACL is set for another account.

参见

  • win32_start_service() - Starts a service
  • win32_stop_service() - Stops a service
  • win32_continue_service() - Resumes a paused service
  • win32_send_custom_control() - Send a custom control to the service
  • Win32 Error Codes


Queries the status of a service

  • ? win32_pause_service
  • win32_send_custom_control ?
  • PHP Manual
  • win32service 函数
  • Queries the status of a service

win32_query_service_status

(PECL win32service >=0.1.0)

win32_query_service_status — Queries the status of a service

说明

win32_query_service_status ( string $servicename , string $machine = ? ) : array

Queries the current status for a service, returning an array of information.

参数

servicename

The short name of the service.

machine

The optional machine name. If omitted, the local machine will be used.

返回值

Returns an array consisting of the following information on success

Prior version 1.0.0，参数错误时返回 false，或失败时返回一个 Win32 错误码。

ServiceType

The dwServiceType. See Win32Service Service Type Bitmasks.

CurrentState

The dwCurrentState. See Win32Service Service Status Constants.

ControlsAccepted

Which service controls are accepted by the service. See Win32Service Service Control Message Accepted Bitmasks.

Win32ExitCode

If the service exited, the return code from the process. This value is equal to WIN32_ERROR_SERVICE_SPECIFIC_ERROR if the exit mode is not gracefuly. See Win32Service error codes and win32_set_service_exit_mode()

ServiceSpecificExitCode

If the service exited with an error condition, the service specific code that is logged in the event log is visible here. This value is equal to the value defined by win32_set_service_exit_code()

CheckPoint

If the service is shutting down, holds the current check point number. This is used by the SCM as a kind of heart-beat to detect a wedged service process. The value of the check point is best interpreted in conjunction with the WaitHint value.

WaitHint

If the service is shutting down it will set WaitHint to a checkpoint value that will indicate 100% completion. This can be used to implement a progress indicator.

ProcessId

The Windows process identifier. If 0, the process is not running.

ServiceFlags

The dwServiceFlags. See Win32Service Service Service Flag Constants.

错误／异常

A ValueError is thrown if the; value of servicename parameter is empty.

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now array, previously it was mixed.

参见

  • Win32Service Predefined Constants


Send a custom control to the service

  • ? win32_query_service_status
  • win32_set_service_exit_code ?
  • PHP Manual
  • win32service 函数
  • Send a custom control to the service

win32_send_custom_control

(PECL win32service >=0.4.0)

win32_send_custom_control — Send a custom control to the service

说明

win32_send_custom_control ( string $servicename , int $control , string $machine = ? ) : void

See » Microsoft ControlService function for more details

参数

servicename

The short name of the service.

control

The custom contole value between 128 and 255.

machine

Optional machine name. If omitted, the local machine is used.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

Prior to version 1.0.0, if the control value is not between 128 and 255, this function emits an E_ERROR level error.

A ValueError is thrown if the; value of servicename parameter is empty.

A ValueError is thrown if the; value of control parameter is not between 128 and 255.

A Win32ServiceException is thrown on error.

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.

参见

  • win32_start_service() - Starts a service
  • win32_stop_service() - Stops a service
  • win32_pause_service() - Pauses a service
  • win32_continue_service() - Resumes a paused service
  • Win32 Error Codes


Define or return the exit code for the current running service

  • ? win32_send_custom_control
  • win32_set_service_exit_mode ?
  • PHP Manual
  • win32service 函数
  • Define or return the exit code for the current running service

win32_set_service_exit_code

(PECL win32service >=0.4.0)

win32_set_service_exit_code — Define or return the exit code for the current running service

说明

win32_set_service_exit_code ( int $exitCode = 1 ) : int

Change or return the exit code. The exit code is used only if the exit mode is not graceful. If the value is not zero, the recovery configuration can be used after service fail. See » Microsoft system error codes for more details

Caution

This function work only in "cli" SAPI. On other SAPI this function is disabled.

参数

exitCode

The return code used on exit.

返回值

Return the current or old exit code.

错误／异常

Prior to version 1.0.0, if the SAPI is not "cli", this function emits an E_ERROR level error.

As of version 1.0.0, will throw a Win32ServiceException if SAPI is not "cli"

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.

参见

  • win32_start_service_ctrl_dispatcher() - Registers the script with the SCM, so that it can act as the service with the given name
  • win32_set_service_status() - Update the service status
  • win32_set_service_exit_mode() - Define or return the exit mode for the current running service


Define or return the exit mode for the current running service

  • ? win32_set_service_exit_code
  • win32_set_service_status ?
  • PHP Manual
  • win32service 函数
  • Define or return the exit mode for the current running service

win32_set_service_exit_mode

(PECL win32service >=0.4.0)

win32_set_service_exit_mode — Define or return the exit mode for the current running service

说明

win32_set_service_exit_mode ( bool $gracefulMode = true ) : bool

If gracefulMode parameter is provided, the exit mode is changed. When the exit mode is not gracefuly, the exit code used can be set with the win32_set_service_exit_code() function.

Caution

This function work only in "cli" SAPI. On other SAPI this function is disabled.

参数

gracefulMode

true for exit graceful. false for exit with error.

返回值

Return the current or old exit mode.

错误／异常

Prior to version 1.0.0, if the SAPI is not "cli", this function emits an E_ERROR level error.

As of version 1.0.0, will throw a Win32ServiceException if SAPI is not "cli"

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.

参见

  • win32_start_service_ctrl_dispatcher() - Registers the script with the SCM, so that it can act as the service with the given name
  • win32_set_service_status() - Update the service status
  • win32_set_service_exit_code() - Define or return the exit code for the current running service


Update the service status

  • ? win32_set_service_exit_mode
  • win32_start_service_ctrl_dispatcher ?
  • PHP Manual
  • win32service 函数
  • Update the service status

win32_set_service_status

(PECL win32service >=0.1.0)

win32_set_service_status — Update the service status

说明

win32_set_service_status ( int $status , int $checkpoint = 0 ) : void

Informs the SCM of the current status of a running service. This call is only valid for a running service process.

Caution

Since version 0.2.0, this function work only in "cli" SAPI. On other SAPI this function is disabled.

参数

status

The service status code, one of WIN32_SERVICE_RUNNING, WIN32_SERVICE_STOPPED, WIN32_SERVICE_STOP_PENDING, WIN32_SERVICE_START_PENDING, WIN32_SERVICE_CONTINUE_PENDING, WIN32_SERVICE_PAUSE_PENDING, WIN32_SERVICE_PAUSED.

checkpoint

The checkpoint value the service increments periodically to report its progress during a lengthy start, stop, pause, or continue operation. For example, the service should increment this value as it completes each step of its initialization when it is starting up.

The checkpoint is only valid when the status is one of WIN32_SERVICE_STOP_PENDING, WIN32_SERVICE_START_PENDING, WIN32_SERVICE_CONTINUE_PENDING or WIN32_SERVICE_PAUSE_PENDING.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

Prior to version 1.0.0, if the SAPI is not "cli", this function emits an E_ERROR level error.

As of version 1.0.0, will throw a Win32ServiceException if SAPI is not "cli"

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.
PECL win32service 0.2.0 | This function works only in the "cli" SAPI.

参见

  • win32_start_service_ctrl_dispatcher() - Registers the script with the SCM, so that it can act as the service with the given name
  • win32_get_last_control_message() - Returns the last control message that was sent to this service
  • win32_set_service_exit_mode() - Define or return the exit mode for the current running service
  • win32_set_service_exit_code() - Define or return the exit code for the current running service
  • Win32Service Service Status Constants


Registers the script with the SCM, so that it can act as the service with the given name

  • ? win32_set_service_status
  • win32_start_service ?
  • PHP Manual
  • win32service 函数
  • Registers the script with the SCM, so that it can act as the service with the given name

win32_start_service_ctrl_dispatcher

(PECL win32service >=0.1.0)

win32_start_service_ctrl_dispatcher — Registers the script with the SCM, so that it can act as the service with the given name

说明

win32_start_service_ctrl_dispatcher ( string $name , bool $gracefulMode = true ) : void

When launched via the Service Control Manager, a service process is required to "check-in" with it to establish service monitoring and communication facilities. This function performs the check-in by spawning a thread to handle the lower-level communication with the service control manager.

Once started, the service process should do 2 things. The first is to tell the Service Control Manager that the service is running. This is achieved by calling win32_set_service_status() with the WIN32_SERVICE_RUNNING constant. If you need to perform some lengthy process before the service is actually running, then you can use the WIN32_SERVICE_START_PENDING constant. The second is to continue to check-in with the service control manager so that it can determine if it should terminate. This is achieved by periodically calling win32_get_last_control_message() and handling the return code appropriately.

Caution

Since version 0.2.0, this function work only in "cli" SAPI. On other SAPI this function is disabled.

参数

name

The short-name of the service, as registered by win32_create_service().

gracefulMode

true for exit graceful. false for exit with error. See win32_set_service_exit_mode() for more details.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

Prior to version 1.0.0, if the SAPI is not "cli", this function emits an E_ERROR level error.

As of version 1.0.0, will throw a Win32ServiceException if SAPI is not "cli"

范例

Example #1 A win32_start_service_ctrl_dispatcher() example

Check if the service is runnig under the SCM.

<?php
if (!win32_start_service_ctrl_dispatcher('dummyphp')) {
  die("I'm probably not running under the service control manager");
}

win32_set_service_status(WIN32_SERVICE_START_PENDING);

// Some lengthy process to get this service up and running.

win32_set_service_status(WIN32_SERVICE_RUNNING);

while (WIN32_SERVICE_CONTROL_STOP != win32_get_last_control_message()) {
  # do some work here, trying not to take more than around 30 seconds
  # before coming back into the loop again
}
?>

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.
PECL win32service 0.4.0 | The parameter gracefulMode has been added.
PECL win32service 0.2.0 | This function works only in the "cli" SAPI.

参见

  • win32_set_service_status() - Update the service status
  • win32_get_last_control_message() - Returns the last control message that was sent to this service
  • win32_set_service_exit_mode() - Define or return the exit mode for the current running service
  • win32_set_service_exit_code() - Define or return the exit code for the current running service
  • Win32 Error Codes


Starts a service

  • ? win32_start_service_ctrl_dispatcher
  • win32_stop_service ?
  • PHP Manual
  • win32service 函数
  • Starts a service

win32_start_service

(PECL win32service >=0.1.0)

win32_start_service — Starts a service

说明

win32_start_service ( string $servicename , string $machine = ? ) : void

Attempts to start the named service. Requires administrative privileges or an account with appropriate rights set in the service's ACL.

参数

servicename

The short name of the service.

machine

Optional machine name. If omitted, the local machine is used.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

A ValueError is thrown if the value of servicename parameter is empty.

A Win32ServiceException is thrown on error.

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.
PECL win32service 0.3.0 | This function does not longer require an administrator account if ACL is set for another account.

参见

  • win32_stop_service() - Stops a service
  • win32_pause_service() - Pauses a service
  • win32_continue_service() - Resumes a paused service
  • win32_send_custom_control() - Send a custom control to the service
  • Win32 Error Codes


Stops a service

  • ? win32_start_service
  • XML 操作 ?
  • PHP Manual
  • win32service 函数
  • Stops a service

win32_stop_service

(PECL win32service >=0.1.0)

win32_stop_service — Stops a service

说明

win32_stop_service ( string $servicename , string $machine = ? ) : void

Stops a named service. Requires administrative privileges or an account with appropriate rights set in the service's ACL.

参数

servicename

The short name of the service.

machine

Optional machine name. If omitted, the local machine is used.

返回值

没有返回值。

Prior to version 1.0.0, 成功时返回 WIN32_NO_ERROR，参数错误时返回 false，或失败时返回一个 Win32 错误码。

错误／异常

A ValueError is thrown if the value of servicename parameter is empty.

A Win32ServiceException is thrown on error.

更新日志

版本 | 说明
PECL win32service 1.0.0 | Throws a ValueError on invalid data in parameters, previously false was returned.
PECL win32service 1.0.0 | Throws a Win32ServiceException on error, previously a Win32 Error Code was returned.
PECL win32service 1.0.0 | The return type is now void, previously it was mixed.
PECL win32service 0.3.0 | This function does not longer require an administrator account if ACL is set for another account.

参见

  • win32_start_service() - Starts a service
  • win32_pause_service() - Pauses a service
  • win32_continue_service() - Resumes a paused service
  • win32_send_custom_control() - Send a custom control to the service
  • Win32 Error Codes


XML 操作

  • DOM — Document Object Model
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • DOMAttr — The DOMAttr class
    • DOMCdataSection — The DOMCdataSection class
    • DOMCharacterData — The DOMCharacterData class
    • DOMComment — The DOMComment class
    • DOMDocument — The DOMDocument class
    • DOMDocumentFragment — The DOMDocumentFragment class
    • DOMDocumentType — The DOMDocumentType class
    • DOMElement — The DOMElement class
    • DOMEntity — The DOMEntity class
    • DOMEntityReference — The DOMEntityReference class
    • DOMException — The DOMException class
    • DOMImplementation — The DOMImplementation class
    • DOMNamedNodeMap — The DOMNamedNodeMap class
    • DOMNode — The DOMNode class
    • DOMNodeList — The DOMNodeList class
    • DOMNotation — The DOMNotation class
    • DOMProcessingInstruction — The DOMProcessingInstruction class
    • DOMText — The DOMText class
    • DOMXPath — The DOMXPath class
    • DOM 函数
  • libxml
    • 简介
    • 安装／配置
    • 预定义常量
    • libXMLError — The libXMLError class
    • libxml 函数
  • SimpleXML
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • SimpleXMLElement — The SimpleXMLElement class
    • SimpleXMLIterator — The SimpleXMLIterator class
    • SimpleXML 函数
  • WDDX
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • WDDX 函数
  • XMLDiff — XML diff and merge
    • 简介
    • 安装／配置
    • XMLDiff\Base — The XMLDiff\Base class
    • XMLDiff\DOM — The XMLDiff\DOM class
    • XMLDiff\Memory — The XMLDiff\Memory class
    • XMLDiff\File — The XMLDiff\File class
  • XML 解析器
    • 简介
    • 安装／配置
    • 预定义常量
    • 事件处理器
    • Case Folding(大写转换)
    • 错误代码
    • 字符编码
    • 范例
    • XML 解析器函数
  • XMLReader
    • 简介
    • 安装／配置
    • XMLReader — The XMLReader class
  • XMLWriter
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • XMLWriter — The XMLWriter class
  • XSL
    • 简介
    • 安装／配置
    • 预定义常量
    • 范例
    • XSLTProcessor — The XSLTProcessor class


Document Object Model

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
  • DOMAttr — The DOMAttr class
    • DOMAttr::__construct — Creates a new DOMAttr object
    • DOMAttr::isId — Checks if attribute is a defined ID
  • DOMCdataSection — The DOMCdataSection class
    • DOMCdataSection::__construct — Constructs a new DOMCdataSection object
  • DOMCharacterData — The DOMCharacterData class
    • DOMCharacterData::appendData — Append the string to the end of the character data of the node
    • DOMCharacterData::deleteData — Remove a range of characters from the node
    • DOMCharacterData::insertData — Insert a string at the specified 16-bit unit offset
    • DOMCharacterData::replaceData — Replace a substring within the DOMCharacterData node
    • DOMCharacterData::substringData — Extracts a range of data from the node
  • DOMComment — The DOMComment class
    • DOMComment::__construct — Creates a new DOMComment object
  • DOMDocument — The DOMDocument class
    • DOMDocument::__construct — Creates a new DOMDocument object
    • DOMDocument::createAttribute — Create new attribute
    • DOMDocument::createAttributeNS — Create new attribute node with an associated namespace
    • DOMDocument::createCDATASection — Create new cdata node
    • DOMDocument::createComment — Create new comment node
    • DOMDocument::createDocumentFragment — Create new document fragment
    • DOMDocument::createElement — Create new element node
    • DOMDocument::createElementNS — Create new element node with an associated namespace
    • DOMDocument::createEntityReference — Create new entity reference node
    • DOMDocument::createProcessingInstruction — Creates new PI node
    • DOMDocument::createTextNode — Create new text node
    • DOMDocument::getElementById — Searches for an element with a certain id
    • DOMDocument::getElementsByTagName — Searches for all elements with given local tag name
    • DOMDocument::getElementsByTagNameNS — Searches for all elements with given tag name in specified namespace
    • DOMDocument::importNode — Import node into current document
    • DOMDocument::load — Load XML from a file
    • DOMDocument::loadHTML — Load HTML from a string
    • DOMDocument::loadHTMLFile — Load HTML from a file
    • DOMDocument::loadXML — Load XML from a string
    • DOMDocument::normalizeDocument — Normalizes the document
    • DOMDocument::registerNodeClass — Register extended class used to create base node type
    • DOMDocument::relaxNGValidate — Performs relaxNG validation on the document
    • DOMDocument::relaxNGValidateSource — Performs relaxNG validation on the document
    • DOMDocument::save — Dumps the internal XML tree back into a file
    • DOMDocument::saveHTML — Dumps the internal document into a string using HTML formatting
    • DOMDocument::saveHTMLFile — Dumps the internal document into a file using HTML formatting
    • DOMDocument::saveXML — Dumps the internal XML tree back into a string
    • DOMDocument::schemaValidate — Validates a document based on a schema. Only XML Schema 1.0 is supported.
    • DOMDocument::schemaValidateSource — Validates a document based on a schema
    • DOMDocument::validate — Validates the document based on its DTD
    • DOMDocument::xinclude — Substitutes XIncludes in a DOMDocument Object
  • DOMDocumentFragment — The DOMDocumentFragment class
    • DOMDocumentFragment::appendXML — Append raw XML data
  • DOMDocumentType — The DOMDocumentType class
  • DOMElement — The DOMElement class
    • DOMElement::__construct — Creates a new DOMElement object
    • DOMElement::getAttribute — Returns value of attribute
    • DOMElement::getAttributeNode — Returns attribute node
    • DOMElement::getAttributeNodeNS — Returns attribute node
    • DOMElement::getAttributeNS — Returns value of attribute
    • DOMElement::getElementsByTagName — Gets elements by tagname
    • DOMElement::getElementsByTagNameNS — Get elements by namespaceURI and localName
    • DOMElement::hasAttribute — Checks to see if attribute exists
    • DOMElement::hasAttributeNS — Checks to see if attribute exists
    • DOMElement::removeAttribute — Removes attribute
    • DOMElement::removeAttributeNode — Removes attribute
    • DOMElement::removeAttributeNS — Removes attribute
    • DOMElement::setAttribute — Adds new attribute
    • DOMElement::setAttributeNode — Adds new attribute node to element
    • DOMElement::setAttributeNodeNS — Adds new attribute node to element
    • DOMElement::setAttributeNS — Adds new attribute
    • DOMElement::setIdAttribute — Declares the attribute specified by name to be of type ID
    • DOMElement::setIdAttributeNode — Declares the attribute specified by node to be of type ID
    • DOMElement::setIdAttributeNS — Declares the attribute specified by local name and namespace URI to be of type ID
  • DOMEntity — The DOMEntity class
  • DOMEntityReference — The DOMEntityReference class
    • DOMEntityReference::__construct — Creates a new DOMEntityReference object
  • DOMException — The DOMException class
  • DOMImplementation — The DOMImplementation class
    • DOMImplementation::__construct — Creates a new DOMImplementation object
    • DOMImplementation::createDocument — Creates a DOMDocument object of the specified type with its document element
    • DOMImplementation::createDocumentType — Creates an empty DOMDocumentType object
    • DOMImplementation::hasFeature — Test if the DOM implementation implements a specific feature
  • DOMNamedNodeMap — The DOMNamedNodeMap class
    • DOMNamedNodeMap::count — Get number of nodes in the map
    • DOMNamedNodeMap::getNamedItem — Retrieves a node specified by name
    • DOMNamedNodeMap::getNamedItemNS — Retrieves a node specified by local name and namespace URI
    • DOMNamedNodeMap::item — Retrieves a node specified by index
  • DOMNode — The DOMNode class
    • DOMNode::appendChild — Adds new child at the end of the children
    • DOMNode::C14N — Canonicalize nodes to a string
    • DOMNode::C14NFile — Canonicalize nodes to a file
    • DOMNode::cloneNode — Clones a node
    • DOMNode::getLineNo — Get line number for a node
    • DOMNode::getNodePath — Get an XPath for a node
    • DOMNode::hasAttributes — Checks if node has attributes
    • DOMNode::hasChildNodes — Checks if node has children
    • DOMNode::insertBefore — Adds a new child before a reference node
    • DOMNode::isDefaultNamespace — Checks if the specified namespaceURI is the default namespace or not
    • DOMNode::isSameNode — Indicates if two nodes are the same node
    • DOMNode::isSupported — Checks if feature is supported for specified version
    • DOMNode::lookupNamespaceUri — Gets the namespace URI of the node based on the prefix
    • DOMNode::lookupPrefix — Gets the namespace prefix of the node based on the namespace URI
    • DOMNode::normalize — Normalizes the node
    • DOMNode::removeChild — Removes child from list of children
    • DOMNode::replaceChild — Replaces a child
  • DOMNodeList — The DOMNodeList class
    • DOMNodeList::count — Get number of nodes in the list
    • DOMNodeList::item — Retrieves a node specified by index
  • DOMNotation — The DOMNotation class
  • DOMProcessingInstruction — The DOMProcessingInstruction class
    • DOMProcessingInstruction::__construct — Creates a new DOMProcessingInstruction object
  • DOMText — The DOMText class
    • DOMText::__construct — Creates a new DOMText object
    • DOMText::isElementContentWhitespace — Returns whether this text node contains whitespace in element content
    • DOMText::isWhitespaceInElementContent — Indicates whether this text node contains whitespace
    • DOMText::splitText — Breaks this node into two nodes at the specified offset
  • DOMXPath — The DOMXPath class
    • DOMXPath::__construct — Creates a new DOMXPath object
    • DOMXPath::evaluate — Evaluates the given XPath expression and returns a typed result if possible
    • DOMXPath::query — Evaluates the given XPath expression
    • DOMXPath::registerNamespace — Registers the namespace with the DOMXPath object
    • DOMXPath::registerPhpFunctions — Register PHP functions as XPath functions
  • DOM 函数
    • dom_import_simplexml — Gets a DOMElement object from a SimpleXMLElement object


简介

The DOM extension allows you to operate on XML documents through the DOM API with PHP.

Note:

此 DOM 扩展采用 UTF-8 编码。在 ISO-8859-1 编码下，使用 utf8_encode() 和 utf8_decode() 来处理，其它编码下使用 iconv 函数处理。


  • ? 需求
  • 运行时配置 ?
  • PHP Manual
  • 安装／配置
  • 安装

安装

此扩展默认为启用，编译时可通过下列选项禁用： --disable-dom


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

XML constants
Constant | Value | Description
XML_ELEMENT_NODE (int) | 1 | Node is a DOMElement
XML_ATTRIBUTE_NODE (int) | 2 | Node is a DOMAttr
XML_TEXT_NODE (int) | 3 | Node is a DOMText
XML_CDATA_SECTION_NODE (int) | 4 | Node is a DOMCharacterData
XML_ENTITY_REF_NODE (int) | 5 | Node is a DOMEntityReference
XML_ENTITY_NODE (int) | 6 | Node is a DOMEntity
XML_PI_NODE (int) | 7 | Node is a DOMProcessingInstruction
XML_COMMENT_NODE (int) | 8 | Node is a DOMComment
XML_DOCUMENT_NODE (int) | 9 | Node is a DOMDocument
XML_DOCUMENT_TYPE_NODE (int) | 10 | Node is a DOMDocumentType
XML_DOCUMENT_FRAG_NODE (int) | 11 | Node is a DOMDocumentFragment
XML_NOTATION_NODE (int) | 12 | Node is a DOMNotation
XML_HTML_DOCUMENT_NODE (int) | 13 |
XML_DTD_NODE (int) | 14 |
XML_ELEMENT_DECL_NODE (int) | 15 |
XML_ATTRIBUTE_DECL_NODE (int) | 16 |
XML_ENTITY_DECL_NODE (int) | 17 |
XML_NAMESPACE_DECL_NODE (int) | 18 |
XML_ATTRIBUTE_CDATA (int) | 1 |
XML_ATTRIBUTE_ID (int) | 2 |
XML_ATTRIBUTE_IDREF (int) | 3 |
XML_ATTRIBUTE_IDREFS (int) | 4 |
XML_ATTRIBUTE_ENTITY (int) | 5 |
XML_ATTRIBUTE_NMTOKEN (int) | 7 |
XML_ATTRIBUTE_NMTOKENS (int) | 8 |
XML_ATTRIBUTE_ENUMERATION (int) | 9 |
XML_ATTRIBUTE_NOTATION (int) | 10 |
DOMException constants
Constant | Value | Description
DOM_PHP_ERR (int) | 0 | Error code not part of the DOM specification. Meant for PHP errors.
DOM_INDEX_SIZE_ERR (int) | 1 | If index or size is negative, or greater than the allowed value.
DOMSTRING_SIZE_ERR (int) | 2 | If the specified range of text does not fit into a DOMString.
DOM_HIERARCHY_REQUEST_ERR (int) | 3 | If any node is inserted somewhere it doesn't belong
DOM_WRONG_DOCUMENT_ERR (int) | 4 | If a node is used in a different document than the one that created it.
DOM_INVALID_CHARACTER_ERR (int) | 5 | If an invalid or illegal character is specified, such as in a name.
DOM_NO_DATA_ALLOWED_ERR (int) | 6 | If data is specified for a node which does not support data.
DOM_NO_MODIFICATION_ALLOWED_ERR (int) | 7 | If an attempt is made to modify an object where modifications are not allowed.
DOM_NOT_FOUND_ERR (int) | 8 | If an attempt is made to reference a node in a context where it does not exist.
DOM_NOT_SUPPORTED_ERR (int) | 9 | If the implementation does not support the requested type of object or operation.
DOM_INUSE_ATTRIBUTE_ERR (int) | 10 | If an attempt is made to add an attribute that is already in use elsewhere.
DOM_INVALID_STATE_ERR (int) | 11 | If an attempt is made to use an object that is not, or is no longer, usable.
DOM_SYNTAX_ERR (int) | 12 | If an invalid or illegal string is specified.
DOM_INVALID_MODIFICATION_ERR (int) | 13 | If an attempt is made to modify the type of the underlying object.
DOM_NAMESPACE_ERR (int) | 14 | If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
DOM_INVALID_ACCESS_ERR (int) | 15 | If a parameter or an operation is not supported by the underlying object.
DOM_VALIDATION_ERR (int) | 16 | If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done.


范例

Many examples in this reference require an XML file. We will use book.xml that contains the following:

Example #1 book.xml

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
 "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
]>
<book id="listing">
 <title>My lists</title>
 <chapter id="books">
  <title>My books</title>
  <para>
   <informaltable>
    <tgroup cols="4">
     <thead>
      <row>
       <entry>Title</entry>
       <entry>Author</entry>
       <entry>Language</entry>
       <entry>ISBN</entry>
      </row>
     </thead>
     <tbody>
      <row>
       <entry>The Grapes of Wrath</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>0140186409</entry>
      </row>
      <row>
       <entry>The Pearl</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>014017737X</entry>
      </row>
      <row>
       <entry>Samarcande</entry>
       <entry>Amine Maalouf</entry>
       <entry>fr</entry>
       <entry>2253051209</entry>
      </row>
      <!-- TODO: I have a lot of remaining books to add.. -->
     </tbody>
    </tgroup>
   </informaltable>
  </para>
 </chapter>
</book>


The DOMAttr class

(PHP 5, PHP 7)

简介

DOMAttr represents an attribute in the DOMElement object.

类摘要

DOMAttr extends DOMNode {
/* 属性 */
public readonly string $name ;
public readonly DOMElement $ownerElement ;
public readonly bool $schemaTypeInfo ;
public readonly bool $specified ;
public string $value ;
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public __construct ( string $name , string $value = "" )
public isId ( ) : bool
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

name

The name of the attribute

ownerElement

The element which contains the attribute

schemaTypeInfo

Not implemented yet, always is null

specified

Not implemented yet, always is null

value

The value of the attribute

参见

  • » W3C specification of Attr

Table of Contents

  • DOMAttr::__construct — Creates a new DOMAttr object
  • DOMAttr::isId — Checks if attribute is a defined ID


Creates a new DOMAttr object

  • ? DOMAttr
  • DOMAttr::isId ?
  • PHP Manual
  • DOMAttr
  • Creates a new DOMAttr object

DOMAttr::__construct

(PHP 5, PHP 7)

DOMAttr::__construct — Creates a new DOMAttr object

说明

public DOMAttr::__construct ( string $name , string $value = "" )

Creates a new DOMAttr object. This object is read only. It may be appended to a document, but additional nodes may not be appended to this node until the node is associated with a document. To create a writable node, use DOMDocument::createAttribute.

参数

name

The tag name of the attribute.

value

The value of the attribute.

范例

Example #1 Creating a new DOMAttr object

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$attr = $element->setAttributeNode(new DOMAttr('attr', 'attrvalue'));
echo $dom->saveXML();

?>

以上例程会输出：

<?xml version="1.0" encoding="utf-8"?>
<root attr="attrvalue" />

参见

  • DOMDocument::createAttribute() - Create new attribute


Checks if attribute is a defined ID

  • ? DOMAttr::__construct
  • DOMCdataSection ?
  • PHP Manual
  • DOMAttr
  • Checks if attribute is a defined ID

DOMAttr::isId

(PHP 5, PHP 7)

DOMAttr::isId — Checks if attribute is a defined ID

说明

public DOMAttr::isId ( ) : bool

This function checks if the attribute is a defined ID.

According to the DOM standard this requires a DTD which defines the attribute ID to be of type ID. You need to validate your document with DOMDocument::validate or DOMDocument::validateOnParse before using this function.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 DOMAttr::isId() Example

<?php

$doc = new DomDocument;

// We need to validate our document before referring to the id
$doc->validateOnParse = true;
$doc->Load('book.xml');

// We retrieve the attribute named id of the chapter element
$attr = $doc->getElementsByTagName('chapter')->item(0)->getAttributeNode('id');

var_dump($attr->isId()); // bool(true)

?>


The DOMCdataSection class

(PHP 5, PHP 7)

简介

The DOMCdataSection inherits from DOMText for textural representation of CData constructs.

类摘要

DOMCdataSection extends DOMText {
/* 继承的属性 */
public readonly string $wholeText ;
public string $data ;
public readonly int $length ;
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* Methods */
public __construct ( string $data )
/* Inherited methods */
public DOMText::isElementContentWhitespace ( ) : bool
public DOMText::isWhitespaceInElementContent ( ) : bool
public DOMText::splitText ( int $offset ) : DOMText|false
public DOMCharacterData::appendData ( string $data ) : bool
public DOMCharacterData::deleteData ( int $offset , int $count ) : bool
public DOMCharacterData::insertData ( int $offset , string $data ) : bool
public DOMCharacterData::replaceData ( int $offset , int $count , string $data ) : bool
public DOMCharacterData::substringData ( int $offset , int $count ) : string|false
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

Table of Contents

  • DOMCdataSection::__construct — Constructs a new DOMCdataSection object


Constructs a new DOMCdataSection object

  • ? DOMCdataSection
  • DOMCharacterData ?
  • PHP Manual
  • DOMCdataSection
  • Constructs a new DOMCdataSection object

DOMCdataSection::__construct

(PHP 5, PHP 7)

DOMCdataSection::__construct — Constructs a new DOMCdataSection object

说明

public DOMCdataSection::__construct ( string $data )

Constructs a new CDATA node. This works like the DOMText class.

参数

data

The value of the CDATA node. If not supplied, an empty CDATA node is created.

范例

Example #1 Creating a new DOMCdataSection object

<?php

$dom = new DOMDocument('1.0', 'utf-8');
$element = $dom->appendChild(new DOMElement('root'));
$text = $element->appendChild(new DOMCdataSection('root value'));
echo $dom->saveXML();

?>

以上例程会输出：

<?xml version="1.0" encoding="utf-8"?>
<root><![CDATA[root value]]></root>

参见

  • DOMText::__construct() - Creates a new DOMText object
  • DOMDocument::createTextNode() - Create new text node


The DOMCharacterData class

(PHP 5, PHP 7)

简介

Represents nodes with character data. No nodes directly correspond to this class, but other nodes do inherit from it.

类摘要

DOMCharacterData extends DOMNode {
/* 属性 */
public string $data ;
public readonly int $length ;
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public appendData ( string $data ) : bool
public deleteData ( int $offset , int $count ) : bool
public insertData ( int $offset , string $data ) : bool
public replaceData ( int $offset , int $count , string $data ) : bool
public substringData ( int $offset , int $count ) : string|false
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

data

The contents of the node.

length

The length of the contents.

参见

  • » W3C specification of CharacterData

Table of Contents

  • DOMCharacterData::appendData — Append the string to the end of the character data of the node
  • DOMCharacterData::deleteData — Remove a range of characters from the node
  • DOMCharacterData::insertData — Insert a string at the specified 16-bit unit offset
  • DOMCharacterData::replaceData — Replace a substring within the DOMCharacterData node
  • DOMCharacterData::substringData — Extracts a range of data from the node


Append the string to the end of the character data of the node

  • ? DOMCharacterData
  • DOMCharacterData::deleteData ?
  • PHP Manual
  • DOMCharacterData
  • Append the string to the end of the character data of the node

DOMCharacterData::appendData

(PHP 5, PHP 7)

DOMCharacterData::appendData — Append the string to the end of the character data of the node

说明

public DOMCharacterData::appendData ( string $data ) : bool

Append the string data to the end of the character data of the node.

参数

data

The string to append.

返回值

没有返回值。

参见

  • DOMCharacterData::deleteData() - Remove a range of characters from the node
  • DOMCharacterData::insertData() - Insert a string at the specified 16-bit unit offset
  • DOMCharacterData::replaceData() - Replace a substring within the DOMCharacterData node
  • DOMCharacterData::substringData() - Extracts a range of data from the node


Remove a range of characters from the node

  • ? DOMCharacterData::appendData
  • DOMCharacterData::insertData ?
  • PHP Manual
  • DOMCharacterData
  • Remove a range of characters from the node

DOMCharacterData::deleteData

(PHP 5, PHP 7)

DOMCharacterData::deleteData — Remove a range of characters from the node

说明

public DOMCharacterData::deleteData ( int $offset , int $count ) : bool

Deletes count characters starting from position offset.

参数

offset

The offset from which to start removing.

count

The number of characters to delete. If the sum of offset and count exceeds the length, then all characters to the end of the data are deleted.

返回值

没有返回值。

错误／异常

DOM_INDEX_SIZE_ERR

Raised if offset is negative or greater than the number of 16-bit units in data, or if count is negative.

参见

  • DOMCharacterData::appendData() - Append the string to the end of the character data of the node
  • DOMCharacterData::insertData() - Insert a string at the specified 16-bit unit offset
  • DOMCharacterData::replaceData() - Replace a substring within the DOMCharacterData node
  • DOMCharacterData::substringData() - Extracts a range of data from the node


Insert a string at the specified 16-bit unit offset

  • ? DOMCharacterData::deleteData
  • DOMCharacterData::replaceData ?
  • PHP Manual
  • DOMCharacterData
  • Insert a string at the specified 16-bit unit offset

DOMCharacterData::insertData

(PHP 5, PHP 7)

DOMCharacterData::insertData — Insert a string at the specified 16-bit unit offset

说明

public DOMCharacterData::insertData ( int $offset , string $data ) : bool

Inserts string data at position offset.

参数

offset

The character offset at which to insert.

data

The string to insert.

返回值

没有返回值。

错误／异常

DOM_INDEX_SIZE_ERR

Raised if offset is negative or greater than the number of 16-bit units in data.

参见

  • DOMCharacterData::appendData() - Append the string to the end of the character data of the node
  • DOMCharacterData::deleteData() - Remove a range of characters from the node
  • DOMCharacterData::replaceData() - Replace a substring within the DOMCharacterData node
  • DOMCharacterData::substringData() - Extracts a range of data from the node


Replace a substring within the DOMCharacterData node

  • ? DOMCharacterData::insertData
  • DOMCharacterData::substringData ?
  • PHP Manual
  • DOMCharacterData
  • Replace a substring within the DOMCharacterData node

DOMCharacterData::replaceData

(PHP 5, PHP 7)

DOMCharacterData::replaceData — Replace a substring within the DOMCharacterData node

说明

public DOMCharacterData::replaceData ( int $offset , int $count , string $data ) : bool

Replace count characters starting from position offset with data.

参数

offset

The offset from which to start replacing.

count

The number of characters to replace. If the sum of offset and count exceeds the length, then all characters to the end of the data are replaced.

data

The string with which the range must be replaced.

返回值

没有返回值。

错误／异常

DOM_INDEX_SIZE_ERR

Raised if offset is negative or greater than the number of 16-bit units in data, or if count is negative.

参见

  • DOMCharacterData::appendData() - Append the string to the end of the character data of the node
  • DOMCharacterData::deleteData() - Remove a range of characters from the node
  • DOMCharacterData::insertData() - Insert a string at the specified 16-bit unit offset
  • DOMCharacterData::substringData() - Extracts a range of data from the node


Extracts a range of data from the node

  • ? DOMCharacterData::replaceData
  • DOMComment ?
  • PHP Manual
  • DOMCharacterData
  • Extracts a range of data from the node

DOMCharacterData::substringData

(PHP 5, PHP 7)

DOMCharacterData::substringData — Extracts a range of data from the node

说明

public DOMCharacterData::substringData ( int $offset , int $count ) : string|false

Returns the specified substring.

参数

offset

Start offset of substring to extract.

count

The number of characters to extract.

返回值

The specified substring. If the sum of offset and count exceeds the length, then all 16-bit units to the end of the data are returned.

错误／异常

DOM_INDEX_SIZE_ERR

Raised if offset is negative or greater than the number of 16-bit units in data, or if count is negative.

参见

  • DOMCharacterData::appendData() - Append the string to the end of the character data of the node
  • DOMCharacterData::deleteData() - Remove a range of characters from the node
  • DOMCharacterData::insertData() - Insert a string at the specified 16-bit unit offset
  • DOMCharacterData::replaceData() - Replace a substring within the DOMCharacterData node


The DOMComment class

(PHP 5, PHP 7)

简介

Represents comment nodes, characters delimited by <!-- and -->.

类摘要

DOMComment extends DOMCharacterData {
/* 继承的属性 */
public string $data ;
public readonly int $length ;
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public __construct ( string $data = "" )
/* 继承的方法 */
public DOMCharacterData::appendData ( string $data ) : bool
public DOMCharacterData::deleteData ( int $offset , int $count ) : bool
public DOMCharacterData::insertData ( int $offset , string $data ) : bool
public DOMCharacterData::replaceData ( int $offset , int $count , string $data ) : bool
public DOMCharacterData::substringData ( int $offset , int $count ) : string|false
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

参见

  • » W3C specification of Comment

Table of Contents

  • DOMComment::__construct — Creates a new DOMComment object


Creates a new DOMComment object

  • ? DOMComment
  • DOMDocument ?
  • PHP Manual
  • DOMComment
  • Creates a new DOMComment object

DOMComment::__construct

(PHP 5, PHP 7)

DOMComment::__construct — Creates a new DOMComment object

说明

public DOMComment::__construct ( string $data = "" )

Creates a new DOMComment object. This object is read only. It may be appended to a document, but additional nodes may not be appended to this node until the node is associated with a document. To create a writeable node, use DOMDocument::createComment.

参数

data

The value of the comment.

范例

Example #1 Creating a new DOMComment

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$comment = $element->appendChild(new DOMComment('root comment'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?><root><!--root comment--></root> */

?>

参见

  • DOMDocument::createComment() - Create new comment node


The DOMDocument class

(PHP 5, PHP 7)

简介

Represents an entire HTML or XML document; serves as the root of the document tree.

类摘要

DOMDocument extends DOMNode {
/* 属性 */
public readonly string $actualEncoding ;
public readonly DOMConfiguration $config ;
public readonly DOMDocumentType $doctype ;
public readonly DOMElement $documentElement ;
public string|null $documentURI ;
public string $encoding ;
public bool $formatOutput ;
public readonly DOMImplementation $implementation ;
public bool $preserveWhiteSpace = true ;
public bool $recover ;
public bool $resolveExternals ;
public bool $standalone ;
public bool $strictErrorChecking = true ;
public bool $substituteEntities ;
public bool $validateOnParse = false ;
public string $version ;
public readonly string|null $xmlEncoding ;
public bool $xmlStandalone ;
public string $xmlVersion ;
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public __construct ( string $version = "1.0" , string $encoding = "" )
public createAttribute ( string $localName ) : DOMAttr|false
public createAttributeNS ( string|null $namespace , string $qualifiedName ) : DOMAttr|false
public createCDATASection ( string $data ) : DOMCdataSection|false
public createComment ( string $data ) : DOMComment|false
public createDocumentFragment ( ) : DOMDocumentFragment|false
public createElement ( string $localName , string $value = "" ) : DOMElement|false
public createElementNS ( string|null $namespace , string $qualifiedName , string $value = "" ) : DOMElement|false
public createEntityReference ( string $name ) : DOMEntityReference|false
public createProcessingInstruction ( string $target , string $data = "" ) : DOMProcessingInstruction|false
public createTextNode ( string $data ) : DOMText|false
public getElementById ( string $elementId ) : DOMElement|null
public getElementsByTagName ( string $qualifiedName ) : DOMNodeList
public getElementsByTagNameNS ( string $namespace , string $localName ) : DOMNodeList
public importNode ( DOMNode $node , bool $deep = false ) : DOMNode|false
public load ( string $filename , int $options = 0 ) : DOMDocument|bool
public loadHTML ( string $source , int $options = 0 ) : DOMDocument|bool
public loadHTMLFile ( string $filename , int $options = 0 ) : DOMDocument|bool
public loadXML ( string $source , int $options = 0 ) : DOMDocument|bool
public normalizeDocument ( ) : void
public registerNodeClass ( string $baseClass , string|null $extendedClass ) : bool
public relaxNGValidate ( string $filename ) : bool
public relaxNGValidateSource ( string $source ) : bool
public save ( string $filename , int $options = 0 ) : int|false
public saveHTML ( DOMNode|null $node = null ) : string|false
public saveHTMLFile ( string $filename ) : int|false
public saveXML ( DOMNode|null $node = null , int $options = 0 ) : string|false
public schemaValidate ( string $filename , int $flags = 0 ) : bool
public schemaValidateSource ( string $source , int $flags = 0 ) : bool
public validate ( ) : bool
public xinclude ( int $options = 0 ) : int|false
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

actualEncoding

Deprecated. Actual encoding of the document, is a readonly equivalent to encoding.

config

Deprecated. Configuration used when DOMDocument::normalizeDocument() is invoked.

doctype

The Document Type Declaration associated with this document.

documentElement

This is a convenience attribute that allows direct access to the child node that is the document element of the document.

documentURI

The location of the document or null if undefined.

encoding

Encoding of the document, as specified by the XML declaration. This attribute is not present in the final DOM Level 3 specification, but is the only way of manipulating XML document encoding in this implementation.

formatOutput

Nicely formats output with indentation and extra space. This has no effect if the document was loaded with preserveWhitespace enabled.

implementation

The DOMImplementation object that handles this document.

preserveWhiteSpace

Do not remove redundant white space. Default to true. Setting this to false has the same effect as passing LIBXML_NOBLANKS as option to DOMDocument::load() etc.

recover

Proprietary. Enables recovery mode, i.e. trying to parse non-well formed documents. This attribute is not part of the DOM specification and is specific to libxml.

resolveExternals

Set it to true to load external entities from a doctype declaration. This is useful for including character entities in your XML document.

standalone

Deprecated. Whether or not the document is standalone, as specified by the XML declaration, corresponds to xmlStandalone.

strictErrorChecking

Throws DOMException on errors. Default to true.

substituteEntities

Proprietary. Whether or not to substitute entities. This attribute is not part of the DOM specification and is specific to libxml.

Caution

Enabling entity substitution may facilitate XML External Entity (XXE) attacks.

validateOnParse

Loads and validates against the DTD. Default to false.

version

Deprecated. Version of XML, corresponds to xmlVersion.

xmlEncoding

An attribute specifying, as part of the XML declaration, the encoding of this document. This is null when unspecified or when it is not known, such as when the Document was created in memory.

xmlStandalone

An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

xmlVersion

An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0".

注释

Note:

此 DOM 扩展采用 UTF-8 编码。在 ISO-8859-1 编码下，使用 utf8_encode() 和 utf8_decode() 来处理，其它编码下使用 iconv 函数处理。

Note:

When using json_encode() on a DOMDocument object the result will be that of encoding an empty object.

参见

  • » W3C specification for Document

Table of Contents

  • DOMDocument::__construct — Creates a new DOMDocument object
  • DOMDocument::createAttribute — Create new attribute
  • DOMDocument::createAttributeNS — Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection — Create new cdata node
  • DOMDocument::createComment — Create new comment node
  • DOMDocument::createDocumentFragment — Create new document fragment
  • DOMDocument::createElement — Create new element node
  • DOMDocument::createElementNS — Create new element node with an associated namespace
  • DOMDocument::createEntityReference — Create new entity reference node
  • DOMDocument::createProcessingInstruction — Creates new PI node
  • DOMDocument::createTextNode — Create new text node
  • DOMDocument::getElementById — Searches for an element with a certain id
  • DOMDocument::getElementsByTagName — Searches for all elements with given local tag name
  • DOMDocument::getElementsByTagNameNS — Searches for all elements with given tag name in specified namespace
  • DOMDocument::importNode — Import node into current document
  • DOMDocument::load — Load XML from a file
  • DOMDocument::loadHTML — Load HTML from a string
  • DOMDocument::loadHTMLFile — Load HTML from a file
  • DOMDocument::loadXML — Load XML from a string
  • DOMDocument::normalizeDocument — Normalizes the document
  • DOMDocument::registerNodeClass — Register extended class used to create base node type
  • DOMDocument::relaxNGValidate — Performs relaxNG validation on the document
  • DOMDocument::relaxNGValidateSource — Performs relaxNG validation on the document
  • DOMDocument::save — Dumps the internal XML tree back into a file
  • DOMDocument::saveHTML — Dumps the internal document into a string using HTML formatting
  • DOMDocument::saveHTMLFile — Dumps the internal document into a file using HTML formatting
  • DOMDocument::saveXML — Dumps the internal XML tree back into a string
  • DOMDocument::schemaValidate — Validates a document based on a schema. Only XML Schema 1.0 is supported.
  • DOMDocument::schemaValidateSource — Validates a document based on a schema
  • DOMDocument::validate — Validates the document based on its DTD
  • DOMDocument::xinclude — Substitutes XIncludes in a DOMDocument Object


Creates a new DOMDocument object

  • ? DOMDocument
  • DOMDocument::createAttribute ?
  • PHP Manual
  • DOMDocument
  • Creates a new DOMDocument object

DOMDocument::__construct

(PHP 5, PHP 7)

DOMDocument::__construct — Creates a new DOMDocument object

说明

public DOMDocument::__construct
 ( string $version = "1.0"
, string $encoding = ""
)

Creates a new DOMDocument object.

参数

version

The version number of the document as part of the XML declaration.

encoding

The encoding of the document as part of the XML declaration.

范例

Example #1 Creating a new DOMDocument

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');

echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?> */

?>

参见

  • DOMImplementation::createDocument() - Creates a DOMDocument object of the specified type with its document element


Create new attribute

  • ? DOMDocument::__construct
  • DOMDocument::createAttributeNS ?
  • PHP Manual
  • DOMDocument
  • Create new attribute

DOMDocument::createAttribute

(PHP 5, PHP 7)

DOMDocument::createAttribute — Create new attribute

说明

public DOMDocument::createAttribute ( string $localName ) : DOMAttr|false

This function creates a new instance of class DOMAttr. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

localName

The name of the attribute.

返回值

The new DOMAttr or false if an error occurred.

错误／异常

DOM_INVALID_CHARACTER_ERR

Raised if localName contains an invalid character.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Creates new PI node
  • DOMDocument::createTextNode() - Create new text node


Create new attribute node with an associated namespace

  • ? DOMDocument::createAttribute
  • DOMDocument::createCDATASection ?
  • PHP Manual
  • DOMDocument
  • Create new attribute node with an associated namespace

DOMDocument::createAttributeNS

(PHP 5, PHP 7)

DOMDocument::createAttributeNS — Create new attribute node with an associated namespace

说明

public DOMDocument::createAttributeNS ( string|null $namespace , string $qualifiedName ) : DOMAttr|false

This function creates a new instance of class DOMAttr. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

namespace

The URI of the namespace.

qualifiedName

The tag name and prefix of the attribute, as prefix:tagname.

返回值

The new DOMAttr or false if an error occurred.

错误／异常

DOM_INVALID_CHARACTER_ERR

Raised if qualifiedName contains an invalid character.

DOM_NAMESPACE_ERR

Raised if qualifiedName is a malformed qualified name, or if qualifiedName has a prefix and namespace is null.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Creates new PI node
  • DOMDocument::createTextNode() - Create new text node


Create new cdata node

  • ? DOMDocument::createAttributeNS
  • DOMDocument::createComment ?
  • PHP Manual
  • DOMDocument
  • Create new cdata node

DOMDocument::createCDATASection

(PHP 5, PHP 7)

DOMDocument::createCDATASection — Create new cdata node

说明

public DOMDocument::createCDATASection ( string $data ) : DOMCdataSection|false

This function creates a new instance of class DOMCDATASection. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

data

The content of the cdata.

返回值

The new DOMCDATASection or false if an error occurred.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Creates new PI node
  • DOMDocument::createTextNode() - Create new text node


Create new comment node

  • ? DOMDocument::createCDATASection
  • DOMDocument::createDocumentFragment ?
  • PHP Manual
  • DOMDocument
  • Create new comment node

DOMDocument::createComment

(PHP 5, PHP 7)

DOMDocument::createComment — Create new comment node

说明

public DOMDocument::createComment ( string $data ) : DOMComment|false

This function creates a new instance of class DOMComment. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

data

The content of the comment.

返回值

The new DOMComment or false if an error occurred.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Creates new PI node
  • DOMDocument::createTextNode() - Create new text node


Create new document fragment

  • ? DOMDocument::createComment
  • DOMDocument::createElement ?
  • PHP Manual
  • DOMDocument
  • Create new document fragment

DOMDocument::createDocumentFragment

(PHP 5, PHP 7)

DOMDocument::createDocumentFragment — Create new document fragment

说明

public DOMDocument::createDocumentFragment ( ) : DOMDocumentFragment|false

This function creates a new instance of class DOMDocumentFragment. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

返回值

The new DOMDocumentFragment or false if an error occurred.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Creates new PI node
  • DOMDocument::createTextNode() - Create new text node


Create new element node

  • ? DOMDocument::createDocumentFragment
  • DOMDocument::createElementNS ?
  • PHP Manual
  • DOMDocument
  • Create new element node

DOMDocument::createElement

(PHP 5, PHP 7)

DOMDocument::createElement — Create new element node

说明

public DOMDocument::createElement ( string $localName , string $value = "" ) : DOMElement|false

This function creates a new instance of class DOMElement. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

localName

The tag name of the element.

value

The value of the element. By default, an empty element will be created. The value can also be set later with DOMElement::$nodeValue.

The value is used verbatim except that the < and > entity references will escaped. Note that & has to be manually escaped; otherwise it is regarded as starting an entity reference. Also " won't be escaped.

返回值

Returns a new instance of class DOMElement or false if an error occurred.

错误／异常

DOM_INVALID_CHARACTER_ERR

Raised if localName contains an invalid character.

范例

Example #1 Creating a new element and inserting it as root

<?php

$dom = new DOMDocument('1.0', 'utf-8');

$element = $dom->createElement('test', 'This is the root element!');

// We insert the new element as root (child of the document)
$dom->appendChild($element);

echo $dom->saveXML();
?>

以上例程会输出：

<?xml version="1.0" encoding="utf-8"?>
<test>This is the root element!</test>

Example #2 Passing text containing an unescaped & as value

<?php
$dom = new DOMDocument('1.0', 'utf-8');
$element = $dom->createElement('foo', 'me & you');
$dom->appendChild($element);
echo $dom->saveXML();
?>

以上例程的输出类似于：

Warning: DOMDocument::createElement(): unterminated entity reference             you in /in/BjTCg on line 4
<?xml version="1.0" encoding="utf-8"?>
<foo/>

注释

Note:

The value will not be escaped. Use DOMDocument::createTextNode() to create a text node with escaping support.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Creates new PI node
  • DOMDocument::createTextNode() - Create new text node


Create new element node with an associated namespace

  • ? DOMDocument::createElement
  • DOMDocument::createEntityReference ?
  • PHP Manual
  • DOMDocument
  • Create new element node with an associated namespace

DOMDocument::createElementNS

(PHP 5, PHP 7)

DOMDocument::createElementNS — Create new element node with an associated namespace

说明

public DOMDocument::createElementNS ( string|null $namespace , string $qualifiedName , string $value = "" ) : DOMElement|false

This function creates a new element node with an associated namespace. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

namespace

The URI of the namespace.

qualifiedName

The qualified name of the element, as prefix:tagname.

value

The value of the element. By default, an empty element will be created. You can also set the value later with DOMElement::$nodeValue.

返回值

The new DOMElement or false if an error occurred.

错误／异常

DOM_INVALID_CHARACTER_ERR

Raised if qualifiedName contains an invalid character.

DOM_NAMESPACE_ERR

Raised if qualifiedName is a maformed qualified name.

范例

Example #1 Creating a new element and inserting it as root

<?php

$dom = new DOMDocument('1.0', 'utf-8');

$element = $dom->createElementNS('http://www.example.com/XFoo', 'xfoo:test', 'This is the root element!');

// We insert the new element as root (child of the document)
$dom->appendChild($element);

echo $dom->saveXML();
?>

以上例程会输出：

<?xml version="1.0" encoding="utf-8"?>
<xfoo:test xmlns:xfoo="http://www.example.com/XFoo">This is the root element!</xfoo:test>

Example #2 A namespace prefix example

<?php
$doc  = new DOMDocument('1.0', 'utf-8');
$doc->formatOutput = true;
$root = $doc->createElementNS('http://www.w3.org/2005/Atom', 'element');
$doc->appendChild($root);
$root->setAttributeNS('http://www.w3.org/2000/xmlns/' ,'xmlns:g', 'http://base.google.com/ns/1.0');
$item = $doc->createElementNS('http://base.google.com/ns/1.0', 'g:item_type', 'house');
$root->appendChild($item);

echo $doc->saveXML(), "\n";

echo $item->namespaceURI, "\n"; // Outputs: http://base.google.com/ns/1.0
echo $item->prefix, "\n";       // Outputs: g
echo $item->localName, "\n";    // Outputs: item_type
?>

以上例程会输出：

<?xml version="1.0" encoding="utf-8"?>
<element xmlns="http://www.w3.org/2005/Atom" xmlns:g="http://base.google.com/ns/1.0">
  <g:item_type>house</g:item_type>
</element>

http://base.google.com/ns/1.0
g
item_type

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Creates new PI node
  • DOMDocument::createTextNode() - Create new text node


Create new entity reference node

  • ? DOMDocument::createElementNS
  • DOMDocument::createProcessingInstruction ?
  • PHP Manual
  • DOMDocument
  • Create new entity reference node

DOMDocument::createEntityReference

(PHP 5, PHP 7)

DOMDocument::createEntityReference — Create new entity reference node

说明

public DOMDocument::createEntityReference ( string $name ) : DOMEntityReference|false

This function creates a new instance of class DOMEntityReference. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

name

The content of the entity reference, e.g. the entity reference minus the leading & and the trailing ; characters.

返回值

The new DOMEntityReference or false if an error occurred.

错误／异常

DOM_INVALID_CHARACTER_ERR

Raised if name contains an invalid character.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createProcessingInstruction() - Creates new PI node
  • DOMDocument::createTextNode() - Create new text node


Creates new PI node

  • ? DOMDocument::createEntityReference
  • DOMDocument::createTextNode ?
  • PHP Manual
  • DOMDocument
  • Creates new PI node

DOMDocument::createProcessingInstruction

(PHP 5, PHP 7)

DOMDocument::createProcessingInstruction — Creates new PI node

说明

public DOMDocument::createProcessingInstruction ( string $target , string $data = "" ) : DOMProcessingInstruction|false

This function creates a new instance of class DOMProcessingInstruction. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

target

The target of the processing instruction.

data

The content of the processing instruction.

返回值

The new DOMProcessingInstruction or false if an error occurred.

错误／异常

DOM_INVALID_CHARACTER_ERR

Raised if target contains an invalid character.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createTextNode() - Create new text node


Create new text node

  • ? DOMDocument::createProcessingInstruction
  • DOMDocument::getElementById ?
  • PHP Manual
  • DOMDocument
  • Create new text node

DOMDocument::createTextNode

(PHP 5, PHP 7)

DOMDocument::createTextNode — Create new text node

说明

public DOMDocument::createTextNode ( string $data ) : DOMText|false

This function creates a new instance of class DOMText. 此节点出现在文档中，除非是用诸如 DOMNode->appendChild() 等函数来将其插入。

参数

data

The content of the text.

返回值

The new DOMText or false if an error occurred.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMDocument::createAttribute() - Create new attribute
  • DOMDocument::createAttributeNS() - Create new attribute node with an associated namespace
  • DOMDocument::createCDATASection() - Create new cdata node
  • DOMDocument::createComment() - Create new comment node
  • DOMDocument::createDocumentFragment() - Create new document fragment
  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace
  • DOMDocument::createEntityReference() - Create new entity reference node
  • DOMDocument::createProcessingInstruction() - Creates new PI node


Searches for an element with a certain id

  • ? DOMDocument::createTextNode
  • DOMDocument::getElementsByTagName ?
  • PHP Manual
  • DOMDocument
  • Searches for an element with a certain id

DOMDocument::getElementById

(PHP 5, PHP 7)

DOMDocument::getElementById — Searches for an element with a certain id

说明

public DOMDocument::getElementById ( string $elementId ) : DOMElement|null

This function is similar to DOMDocument::getElementsByTagName but searches for an element with a given id.

For this function to work, you will need either to set some ID attributes with DOMElement::setIdAttribute or a DTD which defines an attribute to be of type ID. In the later case, you will need to validate your document with DOMDocument::validate or DOMDocument::$validateOnParse before using this function.

参数

elementId

The unique id value for an element.

返回值

Returns the DOMElement or null if the element is not found.

范例

Example #1 DOMDocument::getElementById() Example

以下范例使用了 book.xml，其内容如下：

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE books [
  <!ELEMENT books   (book+)>
  <!ELEMENT book    (title, author+, xhtml:blurb?)>
  <!ELEMENT title   (#PCDATA)>
  <!ELEMENT blurb   (#PCDATA)>
  <!ELEMENT author  (#PCDATA)>
  <!ATTLIST books   xmlns        CDATA  #IMPLIED>
  <!ATTLIST books   xmlns:xhtml  CDATA  #IMPLIED>
  <!ATTLIST book    id           ID     #IMPLIED>
  <!ATTLIST author  email        CDATA  #IMPLIED>
]>
<?xml-stylesheet type="text/xsl" href="style.xsl"?>
<books xmlns="http://books.php/" xmlns:xhtml="http://www.w3.org/1999/xhtml">
  <book id="php-basics">
    <title>PHP Basics</title>
    <author email="jim.smith@basics.php">Jim Smith</author>
    <author email="jane.smith@basics.php">Jane Smith</author>
    <xhtml:blurb><![CDATA[
<p><em>PHP Basics</em> provides an introduction to PHP.</p>
]]></xhtml:blurb>
  </book>
  <book id="php-advanced">
    <title>PHP Advanced Programming</title>
    <author email="jon.doe@advanced.php">Jon Doe</author>
  </book>
</books>
<?php

$doc = new DomDocument;

// We need to validate our document before referring to the id
$doc->validateOnParse = true;
$doc->Load('book.xml');

echo "The element whose id is 'php-basics' is: " . $doc->getElementById('php-basics')->tagName . "\n";

?>

以上例程会输出：

The element whose id is 'php-basics' is: book

参见

  • DOMDocument::getElementsByTagName() - Searches for all elements with given local tag name


Searches for all elements with given local tag name

  • ? DOMDocument::getElementById
  • DOMDocument::getElementsByTagNameNS ?
  • PHP Manual
  • DOMDocument
  • Searches for all elements with given local tag name

DOMDocument::getElementsByTagName

(PHP 5, PHP 7)

DOMDocument::getElementsByTagName — Searches for all elements with given local tag name

说明

public DOMDocument::getElementsByTagName ( string $qualifiedName ) : DOMNodeList

This function returns a new instance of class DOMNodeList containing all the elements with a given local tag name.

参数

qualifiedName

The local name (without namespace) of the tag to match on. The special value * matches all tags.

返回值

A new DOMNodeList object containing all the matched elements.

范例

Example #1 Basic Usage Example

<?php
$xml = <<< XML
<?xml version="1.0" encoding="utf-8"?>
<books>
 <book>Patterns of Enterprise Application Architecture</book>
 <book>Design Patterns: Elements of Reusable Software Design</book>
 <book>Clean Code</book>
</books>
XML;

$dom = new DOMDocument;
$dom->loadXML($xml);
$books = $dom->getElementsByTagName('book');
foreach ($books as $book) {
    echo $book->nodeValue, PHP_EOL;
}
?>

以上例程会输出：

Patterns of Enterprise Application Architecture
Design Patterns: Elements of Reusable Software Design
Clean Code

参见

  • DOMDocument::getElementsByTagNameNS() - Searches for all elements with given tag name in specified namespace


Searches for all elements with given tag name in specified namespace

  • ? DOMDocument::getElementsByTagName
  • DOMDocument::importNode ?
  • PHP Manual
  • DOMDocument
  • Searches for all elements with given tag name in specified namespace

DOMDocument::getElementsByTagNameNS

(PHP 5, PHP 7)

DOMDocument::getElementsByTagNameNS — Searches for all elements with given tag name in specified namespace

说明

public DOMDocument::getElementsByTagNameNS ( string $namespace , string $localName ) : DOMNodeList

Returns a DOMNodeList of all elements with a given local name and a namespace URI.

参数

namespace

The namespace URI of the elements to match on. The special value * matches all namespaces.

localName

The local name of the elements to match on. The special value * matches all local names.

返回值

A new DOMNodeList object containing all the matched elements.

范例

Example #1 Get all the XInclude elements

<?php

$xml = <<<EOD
<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
<title>Books of the other guy..</title>
<para>
 <xi:include href="book.xml">
  <xi:fallback>
   <error>xinclude: book.xml not found</error>
  </xi:fallback>
 </xi:include>
 <include>
  This is another namespace
 </include>
</para>
</chapter>
EOD;
$dom = new DOMDocument;

// load the XML string defined above
$dom->loadXML($xml);

foreach ($dom->getElementsByTagNameNS('http://www.w3.org/2001/XInclude', '*') as $element) {
    echo 'local name: ', $element->localName, ', prefix: ', $element->prefix, "\n";
}
?>

以上例程会输出：

local name: include, prefix: xi
local name: fallback, prefix: xi

参见

  • DOMDocument::getElementsByTagName() - Searches for all elements with given local tag name


Import node into current document

  • ? DOMDocument::getElementsByTagNameNS
  • DOMDocument::load ?
  • PHP Manual
  • DOMDocument
  • Import node into current document

DOMDocument::importNode

(PHP 5, PHP 7)

DOMDocument::importNode — Import node into current document

说明

public DOMDocument::importNode ( DOMNode $node , bool $deep = false ) : DOMNode|false

This function returns a copy of the node to import and associates it with the current document.

参数

node

The node to import.

deep

If set to true, this method will recursively import the subtree under the node.

Note:

To copy the nodes attributes deep needs to be set to true

返回值

The copied node or false, if it cannot be copied.

错误／异常

DOMException is thrown if node cannot be imported.

范例

Example #1 DOMDocument::importNode() example

Copying nodes between documents.

<?php

$orgdoc = new DOMDocument;
$orgdoc->loadXML("<root><element><child>text in child</child></element></root>");

// The node we want to import to a new document
$node = $orgdoc->getElementsByTagName("element")->item(0);

// Create a new document
$newdoc = new DOMDocument;
$newdoc->formatOutput = true;

// Add some markup
$newdoc->loadXML("<root><someelement>text in some element</someelement></root>");

echo "The 'new document' before copying nodes into it:\n";
echo $newdoc->saveXML();

// Import the node, and all its children, to the document
$node = $newdoc->importNode($node, true);
// And then append it to the "<root>" node
$newdoc->documentElement->appendChild($node);

echo "\nThe 'new document' after copying the nodes into it:\n";
echo $newdoc->saveXML();
?>

以上例程会输出：

The 'new document' before copying nodes into it:
<?xml version="1.0"?>
<root>
  <someelement>text in some element</someelement>
</root>

The 'new document' after copying the nodes into it:
<?xml version="1.0"?>
<root>
  <someelement>text in some element</someelement>
  <element>
    <child>text in child</child>
  </element>
</root>


Load XML from a file

  • ? DOMDocument::importNode
  • DOMDocument::loadHTML ?
  • PHP Manual
  • DOMDocument
  • Load XML from a file

DOMDocument::load

(PHP 5, PHP 7)

DOMDocument::load — Load XML from a file

说明

public DOMDocument::load ( string $filename , int $options = 0 ) : DOMDocument|bool

Loads an XML document from a file.

Warning

Unix style paths with forward slashes can cause significant performance degradation on Windows systems; be sure to call realpath() in such a case.

参数

filename

The path to the XML document.

options

Bitwise OR of the libxml option constants.

返回值

成功时返回 true， 或者在失败时返回 false。 If called statically, returns a DOMDocument 或者在失败时返回 false.

错误／异常

If an empty string is passed as the filename or an empty file is named, a warning will be generated. This warning is not generated by libxml and cannot be handled using libxml's error handling functions.

此方法可以被静态调用,但会抛出一个 E_STRICT 错误。

范例

Example #1 Creating a Document

<?php
$doc = new DOMDocument();
$doc->load('book.xml');
echo $doc->saveXML();
?>

参见

  • DOMDocument::loadXML() - Load XML from a string
  • DOMDocument::save() - Dumps the internal XML tree back into a file
  • DOMDocument::saveXML() - Dumps the internal XML tree back into a string


Load HTML from a string

  • ? DOMDocument::load
  • DOMDocument::loadHTMLFile ?
  • PHP Manual
  • DOMDocument
  • Load HTML from a string

DOMDocument::loadHTML

(PHP 5, PHP 7)

DOMDocument::loadHTML — Load HTML from a string

说明

public DOMDocument::loadHTML ( string $source , int $options = 0 ) : DOMDocument|bool

The function parses the HTML contained in the string source. Unlike loading XML, HTML does not have to be well-formed to load. This function may also be called statically to load and create a DOMDocument object. The static invocation may be used when no DOMDocument properties need to be set prior to loading.

参数

source

The HTML string.

options

Since PHP 5.4.0 and Libxml 2.6.0, you may also use the options parameter to specify additional Libxml parameters.

返回值

成功时返回 true， 或者在失败时返回 false。 If called statically, returns a DOMDocument 或者在失败时返回 false.

错误／异常

If an empty string is passed as the source, a warning will be generated. This warning is not generated by libxml and cannot be handled using libxml's error handling functions.

此方法可以被静态调用,但会抛出一个 E_STRICT 错误。

尽管非正确格式化的 HTML 仍应该被成功调入，但此函数会在遇到错误标记时产生 E_WARNING 错误。libxml 错误处理函数可以用来处理这类错误。

范例

Example #1 Creating a Document

<?php
$doc = new DOMDocument();
$doc->loadHTML("<html><body>Test<br></body></html>");
echo $doc->saveHTML();
?>

参见

  • DOMDocument::loadHTMLFile() - Load HTML from a file
  • DOMDocument::saveHTML() - Dumps the internal document into a string using HTML formatting
  • DOMDocument::saveHTMLFile() - Dumps the internal document into a file using HTML formatting


Load HTML from a file

  • ? DOMDocument::loadHTML
  • DOMDocument::loadXML ?
  • PHP Manual
  • DOMDocument
  • Load HTML from a file

DOMDocument::loadHTMLFile

(PHP 5, PHP 7)

DOMDocument::loadHTMLFile — Load HTML from a file

说明

public DOMDocument::loadHTMLFile ( string $filename , int $options = 0 ) : DOMDocument|bool

The function parses the HTML document in the file named filename. Unlike loading XML, HTML does not have to be well-formed to load.

参数

filename

The path to the HTML file.

options

Since PHP 5.4.0 and Libxml 2.6.0, you may also use the options parameter to specify additional Libxml parameters.

返回值

成功时返回 true， 或者在失败时返回 false。 If called statically, returns a DOMDocument 或者在失败时返回 false.

错误／异常

If an empty string is passed as the filename or an empty file is named, a warning will be generated. This warning is not generated by libxml and cannot be handled using libxml's error handling functions.

此方法可以被静态调用,但会抛出一个 E_STRICT 错误。

尽管非正确格式化的 HTML 仍应该被成功调入，但此函数会在遇到错误标记时产生 E_WARNING 错误。libxml 错误处理函数可以用来处理这类错误。

范例

Example #1 Creating a Document

<?php
$doc = new DOMDocument();
$doc->loadHTMLFile("filename.html");
echo $doc->saveHTML();
?>

参见

  • DOMDocument::loadHTML() - Load HTML from a string
  • DOMDocument::saveHTML() - Dumps the internal document into a string using HTML formatting
  • DOMDocument::saveHTMLFile() - Dumps the internal document into a file using HTML formatting


Load XML from a string

  • ? DOMDocument::loadHTMLFile
  • DOMDocument::normalizeDocument ?
  • PHP Manual
  • DOMDocument
  • Load XML from a string

DOMDocument::loadXML

(PHP 5, PHP 7)

DOMDocument::loadXML — Load XML from a string

说明

public DOMDocument::loadXML ( string $source , int $options = 0 ) : DOMDocument|bool

Loads an XML document from a string.

参数

source

The string containing the XML.

options

Bitwise OR of the libxml option constants.

返回值

成功时返回 true， 或者在失败时返回 false。 If called statically, returns a DOMDocument 或者在失败时返回 false.

错误／异常

If an empty string is passed as the source, a warning will be generated. This warning is not generated by libxml and cannot be handled using libxml's error handling functions.

此方法可以被静态调用,但会抛出一个 E_STRICT 错误。

范例

Example #1 Creating a Document

<?php
$doc = new DOMDocument();
$doc->loadXML('<root><node/></root>');
echo $doc->saveXML();
?>

Example #2 Static invocation of loadXML

<?php
// Issues an E_STRICT error
$doc = DOMDocument::loadXML('<root><node/></root>');
echo $doc->saveXML();
?>

参见

  • DOMDocument::load() - Load XML from a file
  • DOMDocument::save() - Dumps the internal XML tree back into a file
  • DOMDocument::saveXML() - Dumps the internal XML tree back into a string


Normalizes the document

  • ? DOMDocument::loadXML
  • DOMDocument::registerNodeClass ?
  • PHP Manual
  • DOMDocument
  • Normalizes the document

DOMDocument::normalizeDocument

(PHP 5, PHP 7)

DOMDocument::normalizeDocument — Normalizes the document

说明

public DOMDocument::normalizeDocument ( ) : void

This method acts as if you saved and then loaded the document, putting the document in a "normal" form.

返回值

没有返回值。

参见

  • » The DOM Specification
  • DOMNode::normalize() - Normalizes the node


Register extended class used to create base node type

  • ? DOMDocument::normalizeDocument
  • DOMDocument::relaxNGValidate ?
  • PHP Manual
  • DOMDocument
  • Register extended class used to create base node type

DOMDocument::registerNodeClass

(PHP 5 >= 5.2.0, PHP 7)

DOMDocument::registerNodeClass — Register extended class used to create base node type

说明

public DOMDocument::registerNodeClass ( string $baseClass , string|null $extendedClass ) : bool

This method allows you to register your own extended DOM class to be used afterward by the PHP DOM extension.

This method is not part of the DOM standard.

参数

baseClass

The DOM class that you want to extend. You can find a list of these classes in the chapter introduction.

extendedClass

Your extended class name. If null is provided, any previously registered class extending baseClass will be removed.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Adding a new method to DOMElement to ease our code

<?php

class myElement extends DOMElement {
   function appendElement($name) {
      return $this->appendChild(new myElement($name));
   }
}

class myDocument extends DOMDocument {
   function setRoot($name) {
      return $this->appendChild(new myElement($name));
   }
}

$doc = new myDocument();
$doc->registerNodeClass('DOMElement', 'myElement');

// From now on, adding an element to another costs only one method call !
$root = $doc->setRoot('root');
$child = $root->appendElement('child');
$child->setAttribute('foo', 'bar');

echo $doc->saveXML();

?>

以上例程会输出：

<?xml version="1.0"?>
<root><child foo="bar"/></root>

Example #2 Retrieving elements as custom class

<?php
class myElement extends DOMElement {
    public function __toString() {
        return $this->nodeValue;
    }
}

$doc = new DOMDocument;
$doc->loadXML("<root><element><child>text in child</child></element></root>");
$doc->registerNodeClass("DOMElement", "myElement");

$element = $doc->getElementsByTagName("child")->item(0);
var_dump(get_class($element));

// And take advantage of the __toString method..
echo $element;
?>

以上例程会输出：

string(9) "myElement"
text in child

Example #3 Retrieving owner document

When instantiating a custom DOMDocument the ownerDocument property will refer to the instantiated class, meaning there is no need (and in fact not possible) to use DOMDocument::registerNodeClass() with DOMDocument

<?php
class myDOMDocument extends DOMDocument {
}

class myOtherDOMDocument extends DOMDocument {
}

// Create myDOMDocument with some XML
$doc = new myDOMDocument;
$doc->loadXML("<root><element><child>text in child</child></element></root>");

$child = $doc->getElementsByTagName("child")->item(0);

// The current owner of the node is myDOMDocument
var_dump(get_class($child->ownerDocument));

// Import a node from myDOMDocument
$newdoc = new myOtherDOMDocument;
$child = $newdoc->importNode($child);

// The new owner of the node has changed to myOtherDOMDocument
var_dump(get_class($child->ownerDocument));
?>

以上例程会输出：

string(13) "myDOMDocument"
string(18) "myOtherDOMDocument"

Example #4 Custom objects are transient

Caution

Objects of the registered node classes are transient, i.e. they are destroyed when they are no longer referenced from PHP code, and recreated when being retrieved again. That implies that custom property values will be lost after recreation.

<?php
class MyDOMElement extends DOMElement
{
    public $myProp = 'default value';
}

$doc = new DOMDocument();
$doc->registerNodeClass('DOMElement', 'MyDOMElement');

$node = $doc->createElement('a');
$node->myProp = 'modified value';
$doc->appendChild($node);

echo $doc->childNodes[0]->myProp, PHP_EOL;
unset($node);
echo $doc->childNodes[0]->myProp, PHP_EOL;
?>

以上例程会输出：

modified value
default value


Performs relaxNG validation on the document

  • ? DOMDocument::registerNodeClass
  • DOMDocument::relaxNGValidateSource ?
  • PHP Manual
  • DOMDocument
  • Performs relaxNG validation on the document

DOMDocument::relaxNGValidate

(PHP 5, PHP 7)

DOMDocument::relaxNGValidate — Performs relaxNG validation on the document

说明

public DOMDocument::relaxNGValidate ( string $filename ) : bool

Performs » relaxNG validation on the document based on the given RNG schema.

参数

filename

The RNG file.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • DOMDocument::relaxNGValidateSource() - Performs relaxNG validation on the document
  • DOMDocument::schemaValidate() - Validates a document based on a schema. Only XML Schema 1.0 is supported.
  • DOMDocument::schemaValidateSource() - Validates a document based on a schema
  • DOMDocument::validate() - Validates the document based on its DTD


Performs relaxNG validation on the document

  • ? DOMDocument::relaxNGValidate
  • DOMDocument::save ?
  • PHP Manual
  • DOMDocument
  • Performs relaxNG validation on the document

DOMDocument::relaxNGValidateSource

(PHP 5, PHP 7)

DOMDocument::relaxNGValidateSource — Performs relaxNG validation on the document

说明

public DOMDocument::relaxNGValidateSource ( string $source ) : bool

Performs » relaxNG validation on the document based on the given RNG source.

参数

source

A string containing the RNG schema.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • DOMDocument::relaxNGValidate() - Performs relaxNG validation on the document
  • DOMDocument::schemaValidate() - Validates a document based on a schema. Only XML Schema 1.0 is supported.
  • DOMDocument::schemaValidateSource() - Validates a document based on a schema
  • DOMDocument::validate() - Validates the document based on its DTD


Dumps the internal XML tree back into a file

  • ? DOMDocument::relaxNGValidateSource
  • DOMDocument::saveHTML ?
  • PHP Manual
  • DOMDocument
  • Dumps the internal XML tree back into a file

DOMDocument::save

(PHP 5, PHP 7)

DOMDocument::save — Dumps the internal XML tree back into a file

说明

public DOMDocument::save ( string $filename , int $options = 0 ) : int|false

Creates an XML document from the DOM representation. This function is usually called after building a new dom document from scratch as in the example below.

参数

filename

The path to the saved XML document.

options

Additional Options. Currently only LIBXML_NOEMPTYTAG is supported.

返回值

Returns the number of bytes written or false if an error occurred.

范例

Example #1 Saving a DOM tree into a file

<?php

$doc = new DOMDocument('1.0');
// we want a nice output
$doc->formatOutput = true;

$root = $doc->createElement('book');
$root = $doc->appendChild($root);

$title = $doc->createElement('title');
$title = $root->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo 'Wrote: ' . $doc->save("/tmp/test.xml") . ' bytes'; // Wrote: 72 bytes

?>

参见

  • DOMDocument::saveXML() - Dumps the internal XML tree back into a string
  • DOMDocument::load() - Load XML from a file
  • DOMDocument::loadXML() - Load XML from a string


Dumps the internal document into a string using HTML formatting

  • ? DOMDocument::save
  • DOMDocument::saveHTMLFile ?
  • PHP Manual
  • DOMDocument
  • Dumps the internal document into a string using HTML formatting

DOMDocument::saveHTML

(PHP 5, PHP 7)

DOMDocument::saveHTML — Dumps the internal document into a string using HTML formatting

说明

public DOMDocument::saveHTML ( DOMNode|null $node = null ) : string|false

Creates an HTML document from the DOM representation. This function is usually called after building a new dom document from scratch as in the example below.

参数

node

Optional parameter to output a subset of the document.

返回值

Returns the HTML, or false if an error occurred.

范例

Example #1 Saving a HTML tree into a string

<?php

$doc = new DOMDocument('1.0');

$root = $doc->createElement('html');
$root = $doc->appendChild($root);

$head = $doc->createElement('head');
$head = $root->appendChild($head);

$title = $doc->createElement('title');
$title = $head->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo $doc->saveHTML();

?>

参见

  • DOMDocument::saveHTMLFile() - Dumps the internal document into a file using HTML formatting
  • DOMDocument::loadHTML() - Load HTML from a string
  • DOMDocument::loadHTMLFile() - Load HTML from a file


Dumps the internal document into a file using HTML formatting

  • ? DOMDocument::saveHTML
  • DOMDocument::saveXML ?
  • PHP Manual
  • DOMDocument
  • Dumps the internal document into a file using HTML formatting

DOMDocument::saveHTMLFile

(PHP 5, PHP 7)

DOMDocument::saveHTMLFile — Dumps the internal document into a file using HTML formatting

说明

public DOMDocument::saveHTMLFile ( string $filename ) : int|false

Creates an HTML document from the DOM representation. This function is usually called after building a new dom document from scratch as in the example below.

参数

filename

The path to the saved HTML document.

返回值

Returns the number of bytes written or false if an error occurred.

范例

Example #1 Saving a HTML tree into a file

<?php

$doc = new DOMDocument('1.0');
// we want a nice output
$doc->formatOutput = true;

$root = $doc->createElement('html');
$root = $doc->appendChild($root);

$head = $doc->createElement('head');
$head = $root->appendChild($head);

$title = $doc->createElement('title');
$title = $head->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo 'Wrote: ' . $doc->saveHTMLFile("/tmp/test.html") . ' bytes'; // Wrote: 129 bytes

?>

参见

  • DOMDocument::saveHTML() - Dumps the internal document into a string using HTML formatting
  • DOMDocument::loadHTML() - Load HTML from a string
  • DOMDocument::loadHTMLFile() - Load HTML from a file


Dumps the internal XML tree back into a string

  • ? DOMDocument::saveHTMLFile
  • DOMDocument::schemaValidate ?
  • PHP Manual
  • DOMDocument
  • Dumps the internal XML tree back into a string

DOMDocument::saveXML

(PHP 5, PHP 7)

DOMDocument::saveXML — Dumps the internal XML tree back into a string

说明

public DOMDocument::saveXML ( DOMNode|null $node = null , int $options = 0 ) : string|false

Creates an XML document from the DOM representation. This function is usually called after building a new dom document from scratch as in the example below.

参数

node

Use this parameter to output only a specific node without XML declaration rather than the entire document.

options

Additional Options. Currently only LIBXML_NOEMPTYTAG is supported.

返回值

Returns the XML, or false if an error occurred.

错误／异常

DOM_WRONG_DOCUMENT_ERR

Raised if node is from another document.

范例

Example #1 Saving a DOM tree into a string

<?php

$doc = new DOMDocument('1.0');
// we want a nice output
$doc->formatOutput = true;

$root = $doc->createElement('book');
$root = $doc->appendChild($root);

$title = $doc->createElement('title');
$title = $root->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo "Saving all the document:\n";
echo $doc->saveXML() . "\n";

echo "Saving only the title part:\n";
echo $doc->saveXML($title);

?>

以上例程会输出：

Saving all the document:
<?xml version="1.0"?>
<book>
  <title>This is the title</title>
</book>

Saving only the title part:
<title>This is the title</title>

参见

  • DOMDocument::save() - Dumps the internal XML tree back into a file
  • DOMDocument::load() - Load XML from a file
  • DOMDocument::loadXML() - Load XML from a string


Validates a document based on a schema. Only XML Schema 1.0 is supported.

  • ? DOMDocument::saveXML
  • DOMDocument::schemaValidateSource ?
  • PHP Manual
  • DOMDocument
  • Validates a document based on a schema. Only XML Schema 1.0 is supported.

DOMDocument::schemaValidate

(PHP 5, PHP 7)

DOMDocument::schemaValidate — Validates a document based on a schema. Only XML Schema 1.0 is supported.

说明

public DOMDocument::schemaValidate ( string $filename , int $flags = 0 ) : bool

Validates a document based on the given schema file.

参数

filename

The path to the schema.

flags

A bitmask of Libxml schema validation flags. Currently the only supported value is LIBXML_SCHEMA_CREATE. Available since PHP 5.5.2 and Libxml 2.6.14.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.5.2 | Added the flags parameter

参见

  • DOMDocument::schemaValidateSource() - Validates a document based on a schema
  • DOMDocument::relaxNGValidate() - Performs relaxNG validation on the document
  • DOMDocument::relaxNGValidateSource() - Performs relaxNG validation on the document
  • DOMDocument::validate() - Validates the document based on its DTD


Validates a document based on a schema

  • ? DOMDocument::schemaValidate
  • DOMDocument::validate ?
  • PHP Manual
  • DOMDocument
  • Validates a document based on a schema

DOMDocument::schemaValidateSource

(PHP 5, PHP 7)

DOMDocument::schemaValidateSource — Validates a document based on a schema

说明

public DOMDocument::schemaValidateSource ( string $source , int $flags = 0 ) : bool

Validates a document based on a schema defined in the given string.

参数

source

A string containing the schema.

flags

A bitmask of Libxml schema validation flags. Currently the only supported value is LIBXML_SCHEMA_CREATE. Available since PHP 5.5.2 and Libxml 2.6.14.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
5.5.2 | Added the flags parameter

参见

  • DOMDocument::schemaValidate() - Validates a document based on a schema. Only XML Schema 1.0 is supported.
  • DOMDocument::relaxNGValidate() - Performs relaxNG validation on the document
  • DOMDocument::relaxNGValidateSource() - Performs relaxNG validation on the document
  • DOMDocument::validate() - Validates the document based on its DTD


Validates the document based on its DTD

  • ? DOMDocument::schemaValidateSource
  • DOMDocument::xinclude ?
  • PHP Manual
  • DOMDocument
  • Validates the document based on its DTD

DOMDocument::validate

(PHP 5, PHP 7)

DOMDocument::validate — Validates the document based on its DTD

说明

public DOMDocument::validate ( ) : bool

Validates the document based on its DTD.

You can also use the validateOnParse property of DOMDocument to make a DTD validation.

返回值

成功时返回 true， 或者在失败时返回 false。 If the document has no DTD attached, this method will return false.

范例

Example #1 Example of DTD validation

<?php
$dom = new DOMDocument;
$dom->load('book.xml');
if ($dom->validate()) {
    echo "This document is valid!\n";
}
?>

You can also validate your XML file while loading it:

<?php
$dom = new DOMDocument;
$dom->validateOnParse = true;
$dom->load('book.xml');
?>

参见

  • DOMDocument::schemaValidate() - Validates a document based on a schema. Only XML Schema 1.0 is supported.
  • DOMDocument::schemaValidateSource() - Validates a document based on a schema
  • DOMDocument::relaxNGValidate() - Performs relaxNG validation on the document
  • DOMDocument::relaxNGValidateSource() - Performs relaxNG validation on the document


Substitutes XIncludes in a DOMDocument Object

  • ? DOMDocument::validate
  • DOMDocumentFragment ?
  • PHP Manual
  • DOMDocument
  • Substitutes XIncludes in a DOMDocument Object

DOMDocument::xinclude

(PHP 5, PHP 7)

DOMDocument::xinclude — Substitutes XIncludes in a DOMDocument Object

说明

public DOMDocument::xinclude ( int $options = 0 ) : int|false

This method substitutes » XIncludes in a DOMDocument object.

Note:

Due to libxml2 automatically resolving entities, this method will produce unexpected results if the included XML file have an attached DTD.

参数

options

libxml parameters. Available since PHP 5.1.0 and Libxml 2.6.7.

返回值

Returns the number of XIncludes in the document, -1 if some processing failed, or false if there were no substitutions.

范例

Example #1 DOMDocument::xinclude() example

<?php

$xml = <<<EOD
<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
 <title>Books of the other guy..</title>
 <para>
  <xi:include href="book.xml">
   <xi:fallback>
    <error>xinclude: book.xml not found</error>
   </xi:fallback>
  </xi:include>
 </para>
</chapter>
EOD;

$dom = new DOMDocument;

// let's have a nice output
$dom->preserveWhiteSpace = false;
$dom->formatOutput = true;

// load the XML string defined above
$dom->loadXML($xml);

// substitute xincludes
$dom->xinclude();

echo $dom->saveXML();

?>

以上例程的输出类似于：

<?xml version="1.0"?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
  <title>Books of the other guy..</title>
  <para>
    <row xml:base="/home/didou/book.xml">
       <entry>The Grapes of Wrath</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>0140186409</entry>
      </row>
    <row xml:base="/home/didou/book.xml">
       <entry>The Pearl</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>014017737X</entry>
      </row>
    <row xml:base="/home/didou/book.xml">
       <entry>Samarcande</entry>
       <entry>Amine Maalouf</entry>
       <entry>fr</entry>
       <entry>2253051209</entry>
      </row>
  </para>
</chapter>


The DOMDocumentFragment class

(PHP 5, PHP 7)

类摘要

DOMDocumentFragment extends DOMNode {
/* 属性 */
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public appendXML ( string $data ) : bool
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

Table of Contents

  • DOMDocumentFragment::appendXML — Append raw XML data


Append raw XML data

  • ? DOMDocumentFragment
  • DOMDocumentType ?
  • PHP Manual
  • DOMDocumentFragment
  • Append raw XML data

DOMDocumentFragment::appendXML

(PHP 5 >= 5.1.0, PHP 7)

DOMDocumentFragment::appendXML — Append raw XML data

说明

public DOMDocumentFragment::appendXML ( string $data ) : bool

Appends raw XML data to a DOMDocumentFragment.

This method is not part of the DOM standard. It was created as a simpler approach for appending an XML DocumentFragment in a DOMDocument.

If you want to stick to the standards, you will have to create a temporary DOMDocument with a dummy root and then loop through the child nodes of the root of your XML data to append them.

参数

data

XML to append.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Appending XML data to your document

<?php
$doc = new DOMDocument();
$doc->loadXML("<root/>");
$f = $doc->createDocumentFragment();
$f->appendXML("<foo>text</foo><bar>text2</bar>");
$doc->documentElement->appendChild($f);
echo $doc->saveXML();
?>

以上例程会输出：

<?xml version="1.0"?>
<root><foo>text</foo><bar>text2</bar></root>


The DOMDocumentType class

(PHP 5, PHP 7)

简介

Each DOMDocument has a doctype attribute whose value is either null or a DOMDocumentType object.

类摘要

DOMDocumentType extends DOMNode {
/* 属性 */
public readonly string $publicId ;
public readonly string $systemId ;
public readonly string $name ;
public readonly DOMNamedNodeMap $entities ;
public readonly DOMNamedNodeMap $notations ;
public readonly string $internalSubset ;
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

publicId

The public identifier of the external subset.

systemId

The system identifier of the external subset. This may be an absolute URI or not.

name

The name of DTD; i.e., the name immediately following the DOCTYPE keyword.

entities

A DOMNamedNodeMap containing the general entities, both external and internal, declared in the DTD.

notations

A DOMNamedNodeMap containing the notations declared in the DTD.

internalSubset

The internal subset as a string, or null if there is none. This does not contain the delimiting square brackets.


The DOMElement class

(PHP 5, PHP 7)

类摘要

DOMElement extends DOMNode {
/* 属性 */
public readonly bool $schemaTypeInfo ;
public readonly string $tagName ;
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public __construct ( string $qualifiedName , string|null $value = null , string $namespace = "" )
public getAttribute ( string $qualifiedName ) : string
public getAttributeNode ( string $qualifiedName ) : DOMAttr|DOMNamespaceNode|false
public getAttributeNodeNS ( string|null $namespace , string $localName ) : DOMAttr|DOMNamespaceNode|null
public getAttributeNS ( string|null $namespace , string $localName ) : string
public getElementsByTagName ( string $qualifiedName ) : DOMNodeList
public getElementsByTagNameNS ( string $namespace , string $localName ) : DOMNodeList
public hasAttribute ( string $qualifiedName ) : bool
public hasAttributeNS ( string|null $namespace , string $localName ) : bool
public removeAttribute ( string $qualifiedName ) : bool
public removeAttributeNode ( DOMAttr $attr ) : DOMAttr|false
public removeAttributeNS ( string|null $namespace , string $localName ) : void
public setAttribute ( string $qualifiedName , string $value ) : DOMAttr|bool
public setAttributeNode ( DOMAttr $attr ) : DOMAttr|null|false
public setAttributeNodeNS ( DOMAttr $attr ) : DOMAttr|null|false
public setAttributeNS ( string|null $namespace , string $qualifiedName , string $value ) : void
public setIdAttribute ( string $qualifiedName , bool $isId ) : void
public setIdAttributeNode ( DOMAttr $attr , bool $isId ) : void
public setIdAttributeNS ( string $namespace , string $qualifiedName , bool $isId ) : void
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

schemaTypeInfo

Not implemented yet, always return null

tagName

The element name

注释

Note:

此 DOM 扩展采用 UTF-8 编码。在 ISO-8859-1 编码下，使用 utf8_encode() 和 utf8_decode() 来处理，其它编码下使用 iconv 函数处理。

Table of Contents

  • DOMElement::__construct — Creates a new DOMElement object
  • DOMElement::getAttribute — Returns value of attribute
  • DOMElement::getAttributeNode — Returns attribute node
  • DOMElement::getAttributeNodeNS — Returns attribute node
  • DOMElement::getAttributeNS — Returns value of attribute
  • DOMElement::getElementsByTagName — Gets elements by tagname
  • DOMElement::getElementsByTagNameNS — Get elements by namespaceURI and localName
  • DOMElement::hasAttribute — Checks to see if attribute exists
  • DOMElement::hasAttributeNS — Checks to see if attribute exists
  • DOMElement::removeAttribute — Removes attribute
  • DOMElement::removeAttributeNode — Removes attribute
  • DOMElement::removeAttributeNS — Removes attribute
  • DOMElement::setAttribute — Adds new attribute
  • DOMElement::setAttributeNode — Adds new attribute node to element
  • DOMElement::setAttributeNodeNS — Adds new attribute node to element
  • DOMElement::setAttributeNS — Adds new attribute
  • DOMElement::setIdAttribute — Declares the attribute specified by name to be of type ID
  • DOMElement::setIdAttributeNode — Declares the attribute specified by node to be of type ID
  • DOMElement::setIdAttributeNS — Declares the attribute specified by local name and namespace URI to be of type ID


Creates a new DOMElement object

  • ? DOMElement
  • DOMElement::getAttribute ?
  • PHP Manual
  • DOMElement
  • Creates a new DOMElement object

DOMElement::__construct

(PHP 5, PHP 7)

DOMElement::__construct — Creates a new DOMElement object

说明

public DOMElement::__construct ( string $qualifiedName , string|null $value = null , string $namespace = "" )

Creates a new DOMElement object. This object is read only. It may be appended to a document, but additional nodes may not be appended to this node until the node is associated with a document. To create a writeable node, use DOMDocument::createElement or DOMDocument::createElementNS.

参数

qualifiedName

The tag name of the element. When also passing in namespaceURI, the element name may take a prefix to be associated with the URI.

value

The value of the element.

namespace

A namespace URI to create the element within a specific namespace.

范例

Example #1 Creating a new DOMElement

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$element_ns = new DOMElement('pr:node1', 'thisvalue', 'http://xyz');
$element->appendChild($element_ns);
echo $dom->saveXML(); /* <?xml version="1.0" encoding="utf-8"?>
<root><pr:node1 xmlns:pr="http://xyz">thisvalue</pr:node1></root> */

?>

参见

  • DOMDocument::createElement() - Create new element node
  • DOMDocument::createElementNS() - Create new element node with an associated namespace


Returns value of attribute

  • ? DOMElement::__construct
  • DOMElement::getAttributeNode ?
  • PHP Manual
  • DOMElement
  • Returns value of attribute

DOMElement::getAttribute

(PHP 5, PHP 7)

DOMElement::getAttribute — Returns value of attribute

说明

public DOMElement::getAttribute ( string $qualifiedName ) : string

Gets the value of the attribute with name qualifiedName for the current node.

参数

qualifiedName

The name of the attribute.

返回值

The value of the attribute, or an empty string if no attribute with the given qualifiedName is found.

参见

  • DOMElement::hasAttribute() - Checks to see if attribute exists
  • DOMElement::setAttribute() - Adds new attribute
  • DOMElement::removeAttribute() - Removes attribute


Returns attribute node

  • ? DOMElement::getAttribute
  • DOMElement::getAttributeNodeNS ?
  • PHP Manual
  • DOMElement
  • Returns attribute node

DOMElement::getAttributeNode

(PHP 5, PHP 7)

DOMElement::getAttributeNode — Returns attribute node

说明

public DOMElement::getAttributeNode ( string $qualifiedName ) : DOMAttr|DOMNamespaceNode|false

Returns the attribute node with name qualifiedName for the current element.

参数

qualifiedName

The name of the attribute.

返回值

The attribute node. Note that for XML namespace declarations (xmlns and xmlns:* attributes) an instance of DOMNameSpaceNode is returned instead of a DOMAttr.

参见

  • DOMElement::hasAttribute() - Checks to see if attribute exists
  • DOMElement::setAttributeNode() - Adds new attribute node to element
  • DOMElement::removeAttributeNode() - Removes attribute


Returns attribute node

  • ? DOMElement::getAttributeNode
  • DOMElement::getAttributeNS ?
  • PHP Manual
  • DOMElement
  • Returns attribute node

DOMElement::getAttributeNodeNS

(PHP 5, PHP 7)

DOMElement::getAttributeNodeNS — Returns attribute node

说明

public DOMElement::getAttributeNodeNS ( string|null $namespace , string $localName ) : DOMAttr|DOMNamespaceNode|null

Returns the attribute node in namespace namespace with local name localName for the current node.

参数

namespace

The namespace URI.

localName

The local name.

返回值

The attribute node. Note that for XML namespace declarations (xmlns and xmlns:* attributes) an instance of DOMNameSpaceNode is returned instead of a DOMAttr object.

参见

  • DOMElement::hasAttributeNS() - Checks to see if attribute exists
  • DOMElement::setAttributeNodeNS() - Adds new attribute node to element
  • DOMElement::removeAttributeNode() - Removes attribute


Returns value of attribute

  • ? DOMElement::getAttributeNodeNS
  • DOMElement::getElementsByTagName ?
  • PHP Manual
  • DOMElement
  • Returns value of attribute

DOMElement::getAttributeNS

(PHP 5, PHP 7)

DOMElement::getAttributeNS — Returns value of attribute

说明

public DOMElement::getAttributeNS ( string|null $namespace , string $localName ) : string

Gets the value of the attribute in namespace namespace with local name localName for the current node.

参数

namespace

The namespace URI.

localName

The local name.

返回值

The value of the attribute, or an empty string if no attribute with the given localName and namespace is found.

参见

  • DOMElement::hasAttributeNS() - Checks to see if attribute exists
  • DOMElement::setAttributeNS() - Adds new attribute
  • DOMElement::removeAttributeNS() - Removes attribute


Gets elements by tagname

  • ? DOMElement::getAttributeNS
  • DOMElement::getElementsByTagNameNS ?
  • PHP Manual
  • DOMElement
  • Gets elements by tagname

DOMElement::getElementsByTagName

(PHP 5, PHP 7)

DOMElement::getElementsByTagName — Gets elements by tagname

说明

public DOMElement::getElementsByTagName ( string $qualifiedName ) : DOMNodeList

This function returns a new instance of the class DOMNodeList of all descendant elements with a given tag qualifiedName, in the order in which they are encountered in a preorder traversal of this element tree.

参数

qualifiedName

The tag name. Use * to return all elements within the element tree.

返回值

This function returns a new instance of the class DOMNodeList of all matched elements.

参见

  • DOMElement::getElementsByTagNameNS() - Get elements by namespaceURI and localName


Get elements by namespaceURI and localName

  • ? DOMElement::getElementsByTagName
  • DOMElement::hasAttribute ?
  • PHP Manual
  • DOMElement
  • Get elements by namespaceURI and localName

DOMElement::getElementsByTagNameNS

(PHP 5, PHP 7)

DOMElement::getElementsByTagNameNS — Get elements by namespaceURI and localName

说明

public DOMElement::getElementsByTagNameNS ( string $namespace , string $localName ) : DOMNodeList

This function fetch all the descendant elements with a given localName and namespace.

参数

namespace

The namespace URI.

localName

The local name. Use * to return all elements within the element tree.

返回值

This function returns a new instance of the class DOMNodeList of all matched elements in the order in which they are encountered in a preorder traversal of this element tree.

参见

  • DOMElement::getElementsByTagName() - Gets elements by tagname


Checks to see if attribute exists

  • ? DOMElement::getElementsByTagNameNS
  • DOMElement::hasAttributeNS ?
  • PHP Manual
  • DOMElement
  • Checks to see if attribute exists

DOMElement::hasAttribute

(PHP 5, PHP 7)

DOMElement::hasAttribute — Checks to see if attribute exists

说明

public DOMElement::hasAttribute ( string $qualifiedName ) : bool

Indicates whether attribute named qualifiedName exists as a member of the element.

参数

qualifiedName

The attribute name.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • DOMElement::hasAttributeNS() - Checks to see if attribute exists
  • DOMElement::getAttribute() - Returns value of attribute
  • DOMElement::setAttribute() - Adds new attribute
  • DOMElement::removeAttribute() - Removes attribute


Checks to see if attribute exists

  • ? DOMElement::hasAttribute
  • DOMElement::removeAttribute ?
  • PHP Manual
  • DOMElement
  • Checks to see if attribute exists

DOMElement::hasAttributeNS

(PHP 5, PHP 7)

DOMElement::hasAttributeNS — Checks to see if attribute exists

说明

public DOMElement::hasAttributeNS ( string|null $namespace , string $localName ) : bool

Indicates whether attribute in namespace namespace named localName exists as a member of the element.

参数

namespace

The namespace URI.

localName

The local name.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • DOMElement::hasAttribute() - Checks to see if attribute exists
  • DOMElement::getAttributeNS() - Returns value of attribute
  • DOMElement::setAttributeNS() - Adds new attribute
  • DOMElement::removeAttributeNS() - Removes attribute


Removes attribute

  • ? DOMElement::hasAttributeNS
  • DOMElement::removeAttributeNode ?
  • PHP Manual
  • DOMElement
  • Removes attribute

DOMElement::removeAttribute

(PHP 5, PHP 7)

DOMElement::removeAttribute — Removes attribute

说明

public DOMElement::removeAttribute ( string $qualifiedName ) : bool

Removes attribute named qualifiedName from the element.

参数

qualifiedName

The name of the attribute.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

参见

  • DOMElement::hasAttribute() - Checks to see if attribute exists
  • DOMElement::getAttribute() - Returns value of attribute
  • DOMElement::setAttribute() - Adds new attribute


Removes attribute

  • ? DOMElement::removeAttribute
  • DOMElement::removeAttributeNS ?
  • PHP Manual
  • DOMElement
  • Removes attribute

DOMElement::removeAttributeNode

(PHP 5, PHP 7)

DOMElement::removeAttributeNode — Removes attribute

说明

public DOMElement::removeAttributeNode ( DOMAttr $attr ) : DOMAttr|false

Removes attribute attr from the element.

参数

attr

The attribute node.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NOT_FOUND_ERROR

Raised if attr is not an attribute of the element.

参见

  • DOMElement::hasAttribute() - Checks to see if attribute exists
  • DOMElement::getAttributeNode() - Returns attribute node
  • DOMElement::setAttributeNode() - Adds new attribute node to element


Removes attribute

  • ? DOMElement::removeAttributeNode
  • DOMElement::setAttribute ?
  • PHP Manual
  • DOMElement
  • Removes attribute

DOMElement::removeAttributeNS

(PHP 5, PHP 7)

DOMElement::removeAttributeNS — Removes attribute

说明

public DOMElement::removeAttributeNS ( string|null $namespace , string $localName ) : void

Removes attribute localName in namespace namespace from the element.

参数

namespace

The namespace URI.

localName

The local name.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

参见

  • DOMElement::hasAttributeNS() - Checks to see if attribute exists
  • DOMElement::getAttributeNS() - Returns value of attribute
  • DOMElement::setAttributeNS() - Adds new attribute


Adds new attribute

  • ? DOMElement::removeAttributeNS
  • DOMElement::setAttributeNode ?
  • PHP Manual
  • DOMElement
  • Adds new attribute

DOMElement::setAttribute

(PHP 5, PHP 7)

DOMElement::setAttribute — Adds new attribute

说明

public DOMElement::setAttribute ( string $qualifiedName , string $value ) : DOMAttr|bool

Sets an attribute with name qualifiedName to the given value. If the attribute does not exist, it will be created.

参数

qualifiedName

The name of the attribute.

value

The value of the attribute.

返回值

The new DOMAttr or false if an error occurred.

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

范例

Example #1 Setting an attribute

<?php
$doc = new DOMDocument("1.0");
$node = $doc->createElement("para");
$newnode = $doc->appendChild($node);
$newnode->setAttribute("align", "left");
?>

参见

  • DOMElement::hasAttribute() - Checks to see if attribute exists
  • DOMElement::getAttribute() - Returns value of attribute
  • DOMElement::removeAttribute() - Removes attribute


Adds new attribute node to element

  • ? DOMElement::setAttribute
  • DOMElement::setAttributeNodeNS ?
  • PHP Manual
  • DOMElement
  • Adds new attribute node to element

DOMElement::setAttributeNode

(PHP 5, PHP 7)

DOMElement::setAttributeNode — Adds new attribute node to element

说明

public DOMElement::setAttributeNode ( DOMAttr $attr ) : DOMAttr|null|false

Adds new attribute node attr to element.

参数

attr

The attribute node.

返回值

Returns old node if the attribute has been replaced or null.

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

参见

  • DOMElement::hasAttribute() - Checks to see if attribute exists
  • DOMElement::getAttributeNode() - Returns attribute node
  • DOMElement::removeAttributeNode() - Removes attribute


Adds new attribute node to element

  • ? DOMElement::setAttributeNode
  • DOMElement::setAttributeNS ?
  • PHP Manual
  • DOMElement
  • Adds new attribute node to element

DOMElement::setAttributeNodeNS

(PHP 5, PHP 7)

DOMElement::setAttributeNodeNS — Adds new attribute node to element

说明

public DOMElement::setAttributeNodeNS ( DOMAttr $attr ) : DOMAttr|null|false

Adds new attribute node attr to element.

参数

attr

The attribute node.

返回值

Returns the old node if the attribute has been replaced.

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

参见

  • DOMElement::hasAttributeNS() - Checks to see if attribute exists
  • DOMElement::getAttributeNodeNS() - Returns attribute node
  • DOMElement::removeAttributeNode() - Removes attribute


Adds new attribute

  • ? DOMElement::setAttributeNodeNS
  • DOMElement::setIdAttribute ?
  • PHP Manual
  • DOMElement
  • Adds new attribute

DOMElement::setAttributeNS

(PHP 5, PHP 7)

DOMElement::setAttributeNS — Adds new attribute

说明

public DOMElement::setAttributeNS ( string|null $namespace , string $qualifiedName , string $value ) : void

Sets an attribute with namespace namespace and name name to the given value. If the attribute does not exist, it will be created.

参数

namespace

The namespace URI.

qualifiedName

The qualified name of the attribute, as prefix:tagname.

value

The value of the attribute.

返回值

没有返回值。

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NAMESPACE_ERR

Raised if qualifiedName is a malformed qualified name, or if qualifiedName has a prefix and namespace is null.

参见

  • DOMElement::hasAttributeNS() - Checks to see if attribute exists
  • DOMElement::getAttributeNS() - Returns value of attribute
  • DOMElement::removeAttributeNS() - Removes attribute


Declares the attribute specified by name to be of type ID

  • ? DOMElement::setAttributeNS
  • DOMElement::setIdAttributeNode ?
  • PHP Manual
  • DOMElement
  • Declares the attribute specified by name to be of type ID

DOMElement::setIdAttribute

(PHP 5, PHP 7)

DOMElement::setIdAttribute — Declares the attribute specified by name to be of type ID

说明

public DOMElement::setIdAttribute ( string $qualifiedName , bool $isId ) : void

Declares the attribute qualifiedName to be of type ID.

参数

qualifiedName

The name of the attribute.

isId

Set it to true if you want qualifiedName to be of type ID, false otherwise.

返回值

没有返回值。

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NOT_FOUND

Raised if qualifiedName is not an attribute of this element.

参见

  • DOMDocument::getElementById() - Searches for an element with a certain id
  • DOMElement::setIdAttributeNode() - Declares the attribute specified by node to be of type ID
  • DOMElement::setIdAttributeNS() - Declares the attribute specified by local name and namespace URI to be of type ID


Declares the attribute specified by node to be of type ID

  • ? DOMElement::setIdAttribute
  • DOMElement::setIdAttributeNS ?
  • PHP Manual
  • DOMElement
  • Declares the attribute specified by node to be of type ID

DOMElement::setIdAttributeNode

(PHP 5, PHP 7)

DOMElement::setIdAttributeNode — Declares the attribute specified by node to be of type ID

说明

public DOMElement::setIdAttributeNode ( DOMAttr $attr , bool $isId ) : void

Declares the attribute specified by attr to be of type ID.

参数

attr

The attribute node.

isId

Set it to true if you want name to be of type ID, false otherwise.

返回值

没有返回值。

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NOT_FOUND

Raised if name is not an attribute of this element.

参见

  • DOMDocument::getElementById() - Searches for an element with a certain id
  • DOMElement::setIdAttribute() - Declares the attribute specified by name to be of type ID
  • DOMElement::setIdAttributeNS() - Declares the attribute specified by local name and namespace URI to be of type ID


Declares the attribute specified by local name and namespace URI to be of type ID

  • ? DOMElement::setIdAttributeNode
  • DOMEntity ?
  • PHP Manual
  • DOMElement
  • Declares the attribute specified by local name and namespace URI to be of type ID

DOMElement::setIdAttributeNS

(PHP 5, PHP 7)

DOMElement::setIdAttributeNS — Declares the attribute specified by local name and namespace URI to be of type ID

说明

public DOMElement::setIdAttributeNS ( string $namespace , string $qualifiedName , bool $isId ) : void

Declares the attribute specified by qualifiedName and namespace to be of type ID.

参数

namespace

The namespace URI of the attribute.

qualifiedName

The local name of the attribute, as prefix:tagname.

isId

Set it to true if you want name to be of type ID, false otherwise.

返回值

没有返回值。

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NOT_FOUND

Raised if name is not an attribute of this element.

参见

  • DOMDocument::getElementById() - Searches for an element with a certain id
  • DOMElement::setIdAttribute() - Declares the attribute specified by name to be of type ID
  • DOMElement::setIdAttributeNode() - Declares the attribute specified by node to be of type ID


The DOMEntity class

(PHP 5, PHP 7)

简介

This interface represents a known entity, either parsed or unparsed, in an XML document.

类摘要

DOMEntity extends DOMNode {
/* 属性 */
public readonly string $publicId ;
public readonly string $systemId ;
public readonly string $notationName ;
public string $actualEncoding ;
public readonly string $encoding ;
public readonly string $version ;
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

publicId

The public identifier associated with the entity if specified, and null otherwise.

systemId

The system identifier associated with the entity if specified, and null otherwise. This may be an absolute URI or not.

notationName

For unparsed entities, the name of the notation for the entity. For parsed entities, this is null.

actualEncoding

An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity. This is null if it an entity from the internal subset or if it is not known.

encoding

An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity. This is null otherwise.

version

An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity. This is null otherwise.


The DOMEntityReference class

(PHP 5, PHP 7)

类摘要

DOMEntityReference extends DOMNode {
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public __construct ( string $name )
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

Table of Contents

  • DOMEntityReference::__construct — Creates a new DOMEntityReference object


Creates a new DOMEntityReference object

  • ? DOMEntityReference
  • DOMException ?
  • PHP Manual
  • DOMEntityReference
  • Creates a new DOMEntityReference object

DOMEntityReference::__construct

(PHP 5, PHP 7)

DOMEntityReference::__construct — Creates a new DOMEntityReference object

说明

public DOMEntityReference::__construct ( string $name )

Creates a new DOMEntityReference object.

参数

name

The name of the entity reference.

范例

Example #1 Creating a new DOMEntityReference

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$entity = $element->appendChild(new DOMEntityReference('nbsp'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?><root>&nbsp;</root> */

?>

参见

  • DOMDocument::createEntityReference() - Create new entity reference node


The DOMException class

(PHP 5, PHP 7)

简介

DOM operations raise exceptions under particular circumstances, i.e., when an operation is impossible to perform for logical reasons.

See also 异常.

类摘要

DOMException extends Exception {
/* 属性 */
public readonly int $code ;
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}

属性

code

An integer indicating the type of error generated


The DOMImplementation class

(PHP 5, PHP 7)

简介

The DOMImplementation class provides a number of methods for performing operations that are independent of any particular instance of the document object model.

类摘要

DOMImplementation {
/* 属性 */
/* 方法 */
__construct ( )
public createDocument ( string $namespace = "" , string $qualifiedName = "" , DOMDocumentType|null $doctype = null ) : DOMDocument|false
public createDocumentType ( string $qualifiedName , string $publicId = "" , string $systemId = "" ) : DOMDocumentType|false
public hasFeature ( string $feature , string $version ) : bool
}

Table of Contents

  • DOMImplementation::__construct — Creates a new DOMImplementation object
  • DOMImplementation::createDocument — Creates a DOMDocument object of the specified type with its document element
  • DOMImplementation::createDocumentType — Creates an empty DOMDocumentType object
  • DOMImplementation::hasFeature — Test if the DOM implementation implements a specific feature


Creates a new DOMImplementation object

  • ? DOMImplementation
  • DOMImplementation::createDocument ?
  • PHP Manual
  • DOMImplementation
  • Creates a new DOMImplementation object

DOMImplementation::__construct

(PHP 5, PHP 7)

DOMImplementation::__construct — Creates a new DOMImplementation object

说明

DOMImplementation::__construct ( )

Creates a new DOMImplementation object.


Creates a DOMDocument object of the specified type with its document element

  • ? DOMImplementation::__construct
  • DOMImplementation::createDocumentType ?
  • PHP Manual
  • DOMImplementation
  • Creates a DOMDocument object of the specified type with its document element

DOMImplementation::createDocument

(PHP 5, PHP 7)

DOMImplementation::createDocument — Creates a DOMDocument object of the specified type with its document element

说明

public DOMImplementation::createDocument
 ( string $namespace = ""
, string $qualifiedName = ""
, DOMDocumentType|null $doctype = null
) : DOMDocument|false

Creates a DOMDocument object of the specified type with its document element.

参数

namespace

The namespace URI of the document element to create.

qualifiedName

The qualified name of the document element to create.

doctype

The type of document to create or null.

返回值

A new DOMDocument object. If namespace, qualifiedName, and doctype are null, the returned DOMDocument is empty with no document element

错误／异常

DOM_WRONG_DOCUMENT_ERR

Raised if doctype has already been used with a different document or was created from a different implementation.

DOM_NAMESPACE_ERR

Raised if there is an error with the namespace, as determined by namespace and qualifiedName.

此方法可以被静态调用,但会抛出一个 E_STRICT 错误。

更新日志

版本 | 说明
8.0.0 | doctype is now nullable.

参见

  • DOMDocument::__construct() - Creates a new DOMDocument object
  • DOMImplementation::createDocumentType() - Creates an empty DOMDocumentType object


Creates an empty DOMDocumentType object

  • ? DOMImplementation::createDocument
  • DOMImplementation::hasFeature ?
  • PHP Manual
  • DOMImplementation
  • Creates an empty DOMDocumentType object

DOMImplementation::createDocumentType

(PHP 5, PHP 7)

DOMImplementation::createDocumentType — Creates an empty DOMDocumentType object

说明

public DOMImplementation::createDocumentType ( string $qualifiedName , string $publicId = "" , string $systemId = "" ) : DOMDocumentType|false

Creates an empty DOMDocumentType object. Entity declarations and notations are not made available. Entity reference expansions and default attribute additions do not occur.

参数

qualifiedName

The qualified name of the document type to create.

publicId

The external subset public identifier.

systemId

The external subset system identifier.

返回值

A new DOMDocumentType node with its ownerDocument set to null.

错误／异常

DOM_NAMESPACE_ERR

Raised if there is an error with the namespace, as determined by qualifiedName.

此方法可以被静态调用,但会抛出一个 E_STRICT 错误。

范例

Example #1 Creating a document with an attached DTD

<?php

// Creates an instance of the DOMImplementation class
$imp = new DOMImplementation;

// Creates a DOMDocumentType instance
$dtd = $imp->createDocumentType('graph', '', 'graph.dtd');

// Creates a DOMDocument instance
$dom = $imp->createDocument("", "", $dtd);

// Set other properties
$dom->encoding = 'UTF-8';
$dom->standalone = false;

// Create an empty element
$element = $dom->createElement('graph');

// Append the element
$dom->appendChild($element);

// Retrieve and print the document
echo $dom->saveXML();

?>

以上例程会输出：

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE graph SYSTEM "graph.dtd">
<graph/>

参见

  • DOMImplementation::createDocument() - Creates a DOMDocument object of the specified type with its document element


Test if the DOM implementation implements a specific feature

  • ? DOMImplementation::createDocumentType
  • DOMNamedNodeMap ?
  • PHP Manual
  • DOMImplementation
  • Test if the DOM implementation implements a specific feature

DOMImplementation::hasFeature

(PHP 5, PHP 7)

DOMImplementation::hasFeature — Test if the DOM implementation implements a specific feature

说明

public DOMImplementation::hasFeature ( string $feature , string $version ) : bool

Test if the DOM implementation implements a specific feature.

You can find a list of all features in the » Conformance section of the DOM specification.

参数

feature

The feature to test.

version

The version number of the feature to test. In level 2, this can be either 2.0 or 1.0.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

此方法可以被静态调用,但会抛出一个 E_STRICT 错误。

范例

Example #1 Testing your DOM Implementation

<?php

$features = array(
  'Core'           => 'Core module',
  'XML'            => 'XML module',
  'HTML'           => 'HTML module',
  'Views'          => 'Views module',
  'Stylesheets'    => 'Style Sheets module',
  'CSS'            => 'CSS module',
  'CSS2'           => 'CSS2 module',
  'Events'         => 'Events module',
  'UIEvents'       => 'User interface Events module',
  'MouseEvents'    => 'Mouse Events module',
  'MutationEvents' => 'Mutation Events module',
  'HTMLEvents'     => 'HTML Events module',
  'Range'          => 'Range module',
  'Traversal'      => 'Traversal module'
);

foreach ($features as $key => $name) {
  if (DOMImplementation::hasFeature($key, '2.0')) {
    echo "Has feature $name\n";
  } else {
    echo "Missing feature $name\n";
  }
}

?>

参见

  • DOMNode::isSupported() - Checks if feature is supported for specified version


The DOMNamedNodeMap class

(PHP 5, PHP 7)

类摘要

DOMNamedNodeMap implements Traversable , Countable {
/* 属性 */
public readonly int $length ;
/* 方法 */
public count ( ) : int|false
public getNamedItem ( string $qualifiedName ) : DOMNode|null
public getNamedItemNS ( string|null $namespace , string $localName ) : DOMNode|null
public item ( int $index ) : DOMNode|null
}

属性

length

The number of nodes in the map. The range of valid child node indices is 0 to length - 1 inclusive.

Table of Contents

  • DOMNamedNodeMap::count — Get number of nodes in the map
  • DOMNamedNodeMap::getNamedItem — Retrieves a node specified by name
  • DOMNamedNodeMap::getNamedItemNS — Retrieves a node specified by local name and namespace URI
  • DOMNamedNodeMap::item — Retrieves a node specified by index


Get number of nodes in the map

  • ? DOMNamedNodeMap
  • DOMNamedNodeMap::getNamedItem ?
  • PHP Manual
  • DOMNamedNodeMap
  • Get number of nodes in the map

DOMNamedNodeMap::count

(PHP 7 >= 7.2.0)

DOMNamedNodeMap::count — Get number of nodes in the map

说明

public DOMNamedNodeMap::count ( ) : int|false

Gets the number of nodes in the map.

参数

此函数没有参数。

返回值

Returns the number of nodes in the map, which is identical to the length property.


Retrieves a node specified by name

  • ? DOMNamedNodeMap::count
  • DOMNamedNodeMap::getNamedItemNS ?
  • PHP Manual
  • DOMNamedNodeMap
  • Retrieves a node specified by name

DOMNamedNodeMap::getNamedItem

(PHP 5, PHP 7)

DOMNamedNodeMap::getNamedItem — Retrieves a node specified by name

说明

public DOMNamedNodeMap::getNamedItem ( string $qualifiedName ) : DOMNode|null

Retrieves a node specified by its nodeName.

参数

qualifiedName

The nodeName of the node to retrieve.

返回值

A node (of any type) with the specified nodeName, or null if no node is found.

参见

  • DOMNamedNodeMap::getNamedItemNS() - Retrieves a node specified by local name and namespace URI


Retrieves a node specified by local name and namespace URI

  • ? DOMNamedNodeMap::getNamedItem
  • DOMNamedNodeMap::item ?
  • PHP Manual
  • DOMNamedNodeMap
  • Retrieves a node specified by local name and namespace URI

DOMNamedNodeMap::getNamedItemNS

(PHP 5, PHP 7)

DOMNamedNodeMap::getNamedItemNS — Retrieves a node specified by local name and namespace URI

说明

public DOMNamedNodeMap::getNamedItemNS ( string|null $namespace , string $localName ) : DOMNode|null

Retrieves a node specified by localName and namespace.

参数

namespace

The namespace URI of the node to retrieve.

localName

The local name of the node to retrieve.

返回值

A node (of any type) with the specified local name and namespace URI, or null if no node is found.

参见

  • DOMNamedNodeMap::getNamedItem() - Retrieves a node specified by name


Retrieves a node specified by index

  • ? DOMNamedNodeMap::getNamedItemNS
  • DOMNode ?
  • PHP Manual
  • DOMNamedNodeMap
  • Retrieves a node specified by index

DOMNamedNodeMap::item

(PHP 5, PHP 7)

DOMNamedNodeMap::item — Retrieves a node specified by index

说明

public DOMNamedNodeMap::item ( int $index ) : DOMNode|null

Retrieves a node specified by index within the DOMNamedNodeMap object.

参数

index

Index into this map.

返回值

The node at the indexth position in the map, or null if that is not a valid index (greater than or equal to the number of nodes in this map).


The DOMNode class

(PHP 5, PHP 7)

类摘要

DOMNode {
/* 属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public appendChild ( DOMNode $node ) : DOMNode|false
public C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public cloneNode ( bool $deep = false ) : DOMNode|false
public getLineNo ( ) : int
public getNodePath ( ) : string|null
public hasAttributes ( ) : bool
public hasChildNodes ( ) : bool
public insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public isDefaultNamespace ( string $namespace ) : bool
public isSameNode ( DOMNode $otherNode ) : bool
public isSupported ( string $feature , string $version ) : bool
public lookupNamespaceUri ( string $prefix ) : string
public lookupPrefix ( string $namespace ) : string|null
public normalize ( ) : void
public removeChild ( DOMNode $child ) : DOMNode|false
public replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

nodeName

Returns the most accurate name for the current node type

nodeValue

The value of this node, depending on its type. Contrary to the W3C specification, the node value of DOMElement nodes is equal to DOMNode::textContent instead of null.

nodeType

Gets the type of the node. One of the predefined XML_xxx_NODE constants

parentNode

The parent of this node. If there is no such node, this returns null.

childNodes

A DOMNodeList that contains all children of this node. If there are no children, this is an empty DOMNodeList.

firstChild

The first child of this node. If there is no such node, this returns null.

lastChild

The last child of this node. If there is no such node, this returns null.

previousSibling

The node immediately preceding this node. If there is no such node, this returns null.

nextSibling

The node immediately following this node. If there is no such node, this returns null.

attributes

A DOMNamedNodeMap containing the attributes of this node (if it is a DOMElement) or null otherwise.

ownerDocument

The DOMDocument object associated with this node, or null if this node is a DOMDOcument

namespaceURI

The namespace URI of this node, or null if it is unspecified.

prefix

The namespace prefix of this node, or null if it is unspecified.

localName

Returns the local part of the qualified name of this node.

baseURI

The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI.

textContent

The text content of this node and its descendants.

注释

Note:

此 DOM 扩展采用 UTF-8 编码。在 ISO-8859-1 编码下，使用 utf8_encode() 和 utf8_decode() 来处理，其它编码下使用 iconv 函数处理。

更新日志

版本 | 说明
5.6.1 | The textContent property has been made writable (formerly it has been readonly).

参见

  • » W3C specification of Node

Table of Contents

  • DOMNode::appendChild — Adds new child at the end of the children
  • DOMNode::C14N — Canonicalize nodes to a string
  • DOMNode::C14NFile — Canonicalize nodes to a file
  • DOMNode::cloneNode — Clones a node
  • DOMNode::getLineNo — Get line number for a node
  • DOMNode::getNodePath — Get an XPath for a node
  • DOMNode::hasAttributes — Checks if node has attributes
  • DOMNode::hasChildNodes — Checks if node has children
  • DOMNode::insertBefore — Adds a new child before a reference node
  • DOMNode::isDefaultNamespace — Checks if the specified namespaceURI is the default namespace or not
  • DOMNode::isSameNode — Indicates if two nodes are the same node
  • DOMNode::isSupported — Checks if feature is supported for specified version
  • DOMNode::lookupNamespaceUri — Gets the namespace URI of the node based on the prefix
  • DOMNode::lookupPrefix — Gets the namespace prefix of the node based on the namespace URI
  • DOMNode::normalize — Normalizes the node
  • DOMNode::removeChild — Removes child from list of children
  • DOMNode::replaceChild — Replaces a child


Adds new child at the end of the children

  • ? DOMNode
  • DOMNode::C14N ?
  • PHP Manual
  • DOMNode
  • Adds new child at the end of the children

DOMNode::appendChild

(PHP 5, PHP 7)

DOMNode::appendChild — Adds new child at the end of the children

说明

public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false

This function appends a child to an existing list of children or creates a new list of children. The child can be created with e.g. DOMDocument::createElement(), DOMDocument::createTextNode() etc. or simply by using any other node.

When using an existing node it will be moved.

参数

node

The appended child.

返回值

The node added.

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if this node is readonly or if the previous parent of the node being inserted is readonly.

DOM_HIERARCHY_REQUEST_ERR

Raised if this node is of a type that does not allow children of the type of the node node, or if the node to append is one of this node's ancestors or this node itself.

DOM_WRONG_DOCUMENT_ERR

Raised if node was created from a different document than the one that created this node.

范例

The following example will add a new element node to a fresh document.

Example #1 Adding a child

<?php

$doc = new DOMDocument;

$node = $doc->createElement("para");
$newnode = $doc->appendChild($node);

echo $doc->saveXML();
?>

Example #2 Nested children

<?php

$doc = new DOMDocument;

$headNode = $doc->createElement("head");
$doc->appendChild($headNode);

$titleNode = $doc->createElement("title");
$headNode->appendChild($titleNode);

echo $doc->saveXML();
?>

参见

  • DOMNode::insertBefore() - Adds a new child before a reference node
  • DOMNode::removeChild() - Removes child from list of children
  • DOMNode::replaceChild() - Replaces a child


Canonicalize nodes to a string

  • ? DOMNode::appendChild
  • DOMNode::C14NFile ?
  • PHP Manual
  • DOMNode
  • Canonicalize nodes to a string

DOMNode::C14N

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::C14N — Canonicalize nodes to a string

说明

public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false

Canonicalize nodes to a string

参数

exclusive

Enable exclusive parsing of only the nodes matched by the provided xpath or namespace prefixes.

withComments

Retain comments in output.

xpath

An array of xpaths to filter the nodes by.

nsPrefixes

An array of namespace prefixes to filter the nodes by.

返回值

Returns canonicalized nodes as a string 或者在失败时返回 false

参见

  • DOMNode::C14NFile() - Canonicalize nodes to a file


Canonicalize nodes to a file

  • ? DOMNode::C14N
  • DOMNode::cloneNode ?
  • PHP Manual
  • DOMNode
  • Canonicalize nodes to a file

DOMNode::C14NFile

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::C14NFile — Canonicalize nodes to a file

说明

public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false

Canonicalize nodes to a file.

参数

uri

Path to write the output to.

exclusive

Enable exclusive parsing of only the nodes matched by the provided xpath or namespace prefixes.

withComments

Retain comments in output.

xpath

An array of xpaths to filter the nodes by.

nsPrefixes

An array of namespace prefixes to filter the nodes by.

返回值

Number of bytes written 或者在失败时返回 false

参见

  • DOMNode::C14N() - Canonicalize nodes to a string


Clones a node

  • ? DOMNode::C14NFile
  • DOMNode::getLineNo ?
  • PHP Manual
  • DOMNode
  • Clones a node

DOMNode::cloneNode

(PHP 5, PHP 7)

DOMNode::cloneNode — Clones a node

说明

public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false

Creates a copy of the node.

参数

deep

Indicates whether to copy all descendant nodes. This parameter is defaulted to false.

返回值

The cloned node.


Get line number for a node

  • ? DOMNode::cloneNode
  • DOMNode::getNodePath ?
  • PHP Manual
  • DOMNode
  • Get line number for a node

DOMNode::getLineNo

(PHP 5 >= 5.3.0, PHP 7)

DOMNode::getLineNo — Get line number for a node

说明

public DOMNode::getLineNo ( ) : int

Gets line number for where the node is defined.

参数

此函数没有参数。

返回值

Always returns the line number where the node was defined in.

范例

Example #1 DOMNode::getLineNo() example

<?php
// XML dump for below example
$xml = <<<XML
<?xml version="1.0" encoding="utf-8"?>
<root>
    <node />
</root>
XML;

// Create a new DOMDocument instance
$dom = new DOMDocument;

// Load the XML
$dom->loadXML($xml);

// Print where the line where the 'node' element was defined in
printf('The <node> tag is defined on line %d', $dom->getElementsByTagName('node')->item(0)->getLineNo());
?>

以上例程会输出：

The <node> tag is defined in line 3


Get an XPath for a node

  • ? DOMNode::getLineNo
  • DOMNode::hasAttributes ?
  • PHP Manual
  • DOMNode
  • Get an XPath for a node

DOMNode::getNodePath

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::getNodePath — Get an XPath for a node

说明

public DOMNode::getNodePath ( ) : string|null

Gets an XPath location path for the node.

参数

此函数没有参数。

返回值

Returns a string containing the XPath, or null in case of an error.

范例

Example #1 DOMNode::getNodePath() example

<?php
// Create a new DOMDocument instance
$dom = new DOMDocument;

// Load the XML
$dom->loadXML('
<fruits>
 <apples>
  <apple>braeburn</apple>
  <apple>granny smith</apple>
 </apples>
 <pears>
  <pear>conference</pear>
 </pears>
</fruits>
');

// Print XPath for each element
foreach ($dom->getElementsByTagName('*') as $node) {
    echo $node->getNodePath() . "\n";
}
?>

以上例程会输出：

/fruits
/fruits/apples
/fruits/apples/apple[1]
/fruits/apples/apple[2]
/fruits/pears
/fruits/pears/pear

参见

  • DOMXPath


Checks if node has attributes

  • ? DOMNode::getNodePath
  • DOMNode::hasChildNodes ?
  • PHP Manual
  • DOMNode
  • Checks if node has attributes

DOMNode::hasAttributes

(PHP 5, PHP 7)

DOMNode::hasAttributes — Checks if node has attributes

说明

public DOMNode::hasAttributes ( ) : bool

This method checks if the node has attributes. The tested node has to be an XML_ELEMENT_NODE.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • DOMNode::hasChildNodes() - Checks if node has children


Checks if node has children

  • ? DOMNode::hasAttributes
  • DOMNode::insertBefore ?
  • PHP Manual
  • DOMNode
  • Checks if node has children

DOMNode::hasChildNodes

(PHP 5, PHP 7)

DOMNode::hasChildNodes — Checks if node has children

说明

public DOMNode::hasChildNodes ( ) : bool

This function checks if the node has children.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • DOMNode::hasAttributes() - Checks if node has attributes


Adds a new child before a reference node

  • ? DOMNode::hasChildNodes
  • DOMNode::isDefaultNamespace ?
  • PHP Manual
  • DOMNode
  • Adds a new child before a reference node

DOMNode::insertBefore

(PHP 5, PHP 7)

DOMNode::insertBefore — Adds a new child before a reference node

说明

public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false

This function inserts a new node right before the reference node. If you plan to do further modifications on the appended child you must use the returned node.

When using an existing node it will be moved.

参数

node

The new node.

child

The reference node. If not supplied, node is appended to the children.

返回值

The inserted node.

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if this node is readonly or if the previous parent of the node being inserted is readonly.

DOM_HIERARCHY_REQUEST_ERR

Raised if this node is of a type that does not allow children of the type of the node node, or if the node to append is one of this node's ancestors or this node itself.

DOM_WRONG_DOCUMENT_ERR

Raised if node was created from a different document than the one that created this node.

DOM_NOT_FOUND

Raised if child is not a child of this node.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children


Checks if the specified namespaceURI is the default namespace or not

  • ? DOMNode::insertBefore
  • DOMNode::isSameNode ?
  • PHP Manual
  • DOMNode
  • Checks if the specified namespaceURI is the default namespace or not

DOMNode::isDefaultNamespace

(PHP 5, PHP 7)

DOMNode::isDefaultNamespace — Checks if the specified namespaceURI is the default namespace or not

说明

public DOMNode::isDefaultNamespace ( string $namespace ) : bool

Tells whether namespace is the default namespace.

参数

namespace

The namespace URI to look for.

返回值

Return true if namespace is the default namespace, false otherwise.


Indicates if two nodes are the same node

  • ? DOMNode::isDefaultNamespace
  • DOMNode::isSupported ?
  • PHP Manual
  • DOMNode
  • Indicates if two nodes are the same node

DOMNode::isSameNode

(PHP 5, PHP 7)

DOMNode::isSameNode — Indicates if two nodes are the same node

说明

public DOMNode::isSameNode ( DOMNode $otherNode ) : bool

This function indicates if two nodes are the same node. The comparison is not based on content

参数

otherNode

The compared node.

返回值

成功时返回 true， 或者在失败时返回 false。


Checks if feature is supported for specified version

  • ? DOMNode::isSameNode
  • DOMNode::lookupNamespaceUri ?
  • PHP Manual
  • DOMNode
  • Checks if feature is supported for specified version

DOMNode::isSupported

(PHP 5, PHP 7)

DOMNode::isSupported — Checks if feature is supported for specified version

说明

public DOMNode::isSupported ( string $feature , string $version ) : bool

Checks if the asked feature is supported for the specified version.

参数

feature

The feature to test. See the example of DOMImplementation::hasFeature() for a list of features.

version

The version number of the feature to test.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • DOMImplementation::hasFeature() - Test if the DOM implementation implements a specific feature


Gets the namespace URI of the node based on the prefix

  • ? DOMNode::isSupported
  • DOMNode::lookupPrefix ?
  • PHP Manual
  • DOMNode
  • Gets the namespace URI of the node based on the prefix

DOMNode::lookupNamespaceUri

(PHP 5, PHP 7)

DOMNode::lookupNamespaceUri — Gets the namespace URI of the node based on the prefix

说明

public DOMNode::lookupNamespaceUri ( string $prefix ) : string

Gets the namespace URI of the node based on the prefix.

参数

prefix

The prefix of the namespace.

返回值

The namespace URI of the node.

参见

  • DOMNode::lookupPrefix() - Gets the namespace prefix of the node based on the namespace URI


Gets the namespace prefix of the node based on the namespace URI

  • ? DOMNode::lookupNamespaceUri
  • DOMNode::normalize ?
  • PHP Manual
  • DOMNode
  • Gets the namespace prefix of the node based on the namespace URI

DOMNode::lookupPrefix

(PHP 5, PHP 7)

DOMNode::lookupPrefix — Gets the namespace prefix of the node based on the namespace URI

说明

public DOMNode::lookupPrefix ( string $namespace ) : string|null

Gets the namespace prefix of the node based on the namespace URI.

参数

namespace

The namespace URI.

返回值

The prefix of the namespace.

参见

  • DOMNode::lookupNamespaceUri() - Gets the namespace URI of the node based on the prefix


Normalizes the node

  • ? DOMNode::lookupPrefix
  • DOMNode::removeChild ?
  • PHP Manual
  • DOMNode
  • Normalizes the node

DOMNode::normalize

(PHP 5, PHP 7)

DOMNode::normalize — Normalizes the node

说明

public DOMNode::normalize ( ) : void

Remove empty text nodes and merge adjacent text nodes in this node and all its children.

返回值

没有返回值。

参见

  • » The DOM Specification
  • DOMDocument::normalizeDocument() - Normalizes the document


Removes child from list of children

  • ? DOMNode::normalize
  • DOMNode::replaceChild ?
  • PHP Manual
  • DOMNode
  • Removes child from list of children

DOMNode::removeChild

(PHP 5, PHP 7)

DOMNode::removeChild — Removes child from list of children

说明

public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false

This functions removes a child from a list of children.

参数

child

The removed child.

返回值

If the child could be removed the function returns the old child.

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if this node is readonly.

DOM_NOT_FOUND

Raised if child is not a child of this node.

范例

The following example will delete the chapter element of our XML document.

Example #1 Removing a child

<?php

$doc = new DOMDocument;
$doc->load('book.xml');

$book = $doc->documentElement;

// we retrieve the chapter and remove it from the book
$chapter = $book->getElementsByTagName('chapter')->item(0);
$oldchapter = $book->removeChild($chapter);

echo $doc->saveXML();
?>

以上例程会输出：

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
          "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
<book id="listing">
 <title>My lists</title>

</book>

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMNode::replaceChild() - Replaces a child


Replaces a child

  • ? DOMNode::removeChild
  • DOMNodeList ?
  • PHP Manual
  • DOMNode
  • Replaces a child

DOMNode::replaceChild

(PHP 5, PHP 7)

DOMNode::replaceChild — Replaces a child

说明

public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false

This function replaces the child child with the passed new node. If the node is already a child it will not be added a second time. If the replacement succeeds the old node is returned.

参数

node

The new node. It must be a member of the target document, i.e. created by one of the DOMDocument->createXXX() methods or imported in the document by DOMDocument::importNode.

child

The old node.

返回值

The old node or false if an error occur.

错误／异常

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if this node is readonly or if the previous parent of the node being inserted is readonly.

DOM_HIERARCHY_REQUEST_ERR

Raised if this node is of a type that does not allow children of the type of the node node, or if the node to put in is one of this node's ancestors or this node itself.

DOM_WRONG_DOCUMENT_ERR

Raised if node was created from a different document than the one that created this node.

DOM_NOT_FOUND

Raised if child is not a child of this node.

参见

  • DOMNode::appendChild() - Adds new child at the end of the children
  • DOMNode::removeChild() - Removes child from list of children


The DOMNodeList class

(PHP 5, PHP 7)

类摘要

DOMNodeList implements Traversable , Countable {
/* 属性 */
public readonly int $length ;
/* 方法 */
public count ( ) : int|false
public item ( int $index ) : DOMNode|null
}

属性

length

The number of nodes in the list. The range of valid child node indices is 0 to length - 1 inclusive.

更新日志

版本 | 说明
7.2.0 | The Countable interface is implemented and returns the value of the length property.

参见

  • » W3C specification of NodeList

Table of Contents

  • DOMNodeList::count — Get number of nodes in the list
  • DOMNodeList::item — Retrieves a node specified by index


Get number of nodes in the list

  • ? DOMNodeList
  • DOMNodeList::item ?
  • PHP Manual
  • DOMNodeList
  • Get number of nodes in the list

DOMNodeList::count

(PHP 7 >= 7.2.0)

DOMNodeList::count — Get number of nodes in the list

说明

public DOMNodeList::count ( ) : int|false

Gets the number of nodes in the list.

参数

此函数没有参数。

返回值

Returns the number of nodes in the list, which is identical to the length property.


Retrieves a node specified by index

  • ? DOMNodeList::count
  • DOMNotation ?
  • PHP Manual
  • DOMNodeList
  • Retrieves a node specified by index

DOMNodeList::item

(PHP 5, PHP 7)

DOMNodeList::item — Retrieves a node specified by index

说明

public DOMNodeList::item ( int $index ) : DOMNode|null

Retrieves a node specified by index within the DOMNodeList object.

Tip

If you need to know the number of nodes in the collection, use the length property of the DOMNodeList object.

参数

index

Index of the node into the collection.

返回值

The node at the indexth position in the DOMNodeList, or null if that is not a valid index.

范例

Example #1 Traversing all the entries of the table

<?php

$doc = new DOMDocument;
$doc->load('book.xml');

$items = $doc->getElementsByTagName('entry');

for ($i = 0; $i < $items->length; $i++) {
    echo $items->item($i)->nodeValue . "\n";
}

?>

Alternatively, you can use foreach, which is a much more convenient way:

<?php

foreach ($items as $item) {
    echo $item->nodeValue . "\n";
}

?>

以上例程会输出：

Title
Author
Language
ISBN
The Grapes of Wrath
John Steinbeck
en
0140186409
The Pearl
John Steinbeck
en
014017737X
Samarcande
Amine Maalouf
fr
2253051209


The DOMNotation class

(PHP 5, PHP 7)

类摘要

DOMNotation extends DOMNode {
/* 属性 */
public readonly string $publicId ;
public readonly string $systemId ;
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

publicId

systemId


The DOMProcessingInstruction class

(PHP 5, PHP 7)

类摘要

DOMProcessingInstruction extends DOMNode {
/* 属性 */
public readonly string $target ;
public string $data ;
/* 继承的属性 */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public __construct ( string $name , string $value = "" )
/* 继承的方法 */
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

target

data

Table of Contents

  • DOMProcessingInstruction::__construct — Creates a new DOMProcessingInstruction object


Creates a new DOMProcessingInstruction object

  • ? DOMProcessingInstruction
  • DOMText ?
  • PHP Manual
  • DOMProcessingInstruction
  • Creates a new DOMProcessingInstruction object

DOMProcessingInstruction::__construct

(PHP 5, PHP 7)

DOMProcessingInstruction::__construct — Creates a new DOMProcessingInstruction object

说明

public DOMProcessingInstruction::__construct ( string $name , string $value = "" )

Creates a new DOMProcessingInstruction object. This object is read only. It may be appended to a document, but additional nodes may not be appended to this node until the node is associated with a document. To create a writeable node, use DOMDocument::createProcessingInstruction.

参数

name

The tag name of the processing instruction.

value

The value of the processing instruction.

范例

Example #1 Creating a new DOMProcessingInstruction object

<?php

$dom = new DOMDocument('1.0', 'UTF-8');
$html = $dom->appendChild(new DOMElement('html'));
$body = $html->appendChild(new DOMElement('body'));
$pinode = new DOMProcessingInstruction('php', 'echo "Hello World"; ');
$body->appendChild($pinode);
echo $dom->saveXML();

?>

以上例程会输出：

<?xml version="1.0" encoding="UTF-8"?>
<html><body><?php echo "Hello World"; ?></body></html>

参见

  • DOMDocument::createProcessingInstruction() - Creates new PI node


The DOMText class

(PHP 5, PHP 7)

简介

The DOMText class inherits from DOMCharacterData and represents the textual content of a DOMElement or DOMAttr.

类摘要

DOMText extends DOMCharacterData {
/* 属性 */
public readonly string $wholeText ;
/* 继承的属性 */
public string $data ;
public readonly int $length ;
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode|null $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode|null $firstChild ;
public readonly DOMNode|null $lastChild ;
public readonly DOMNode|null $previousSibling ;
public readonly DOMNode|null $nextSibling ;
public readonly DOMNamedNodeMap|null $attributes ;
public readonly DOMDocument|null $ownerDocument ;
public readonly string|null $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string|null $baseURI ;
public string $textContent ;
/* 方法 */
public __construct ( string $data = "" )
public isElementContentWhitespace ( ) : bool
public isWhitespaceInElementContent ( ) : bool
public splitText ( int $offset ) : DOMText|false
/* 继承的方法 */
public DOMCharacterData::appendData ( string $data ) : bool
public DOMCharacterData::deleteData ( int $offset , int $count ) : bool
public DOMCharacterData::insertData ( int $offset , string $data ) : bool
public DOMCharacterData::replaceData ( int $offset , int $count , string $data ) : bool
public DOMCharacterData::substringData ( int $offset , int $count ) : string|false
public DOMNode::appendChild ( DOMNode $node ) : DOMNode|false
public DOMNode::C14N ( bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : string|false
public DOMNode::C14NFile ( string $uri , bool $exclusive = false , bool $withComments = false , array|null $xpath = null , array|null $nsPrefixes = null ) : int|false
public DOMNode::cloneNode ( bool $deep = false ) : DOMNode|false
public DOMNode::getLineNo ( ) : int
public DOMNode::getNodePath ( ) : string|null
public DOMNode::hasAttributes ( ) : bool
public DOMNode::hasChildNodes ( ) : bool
public DOMNode::insertBefore ( DOMNode $node , DOMNode|null $child = null ) : DOMNode|false
public DOMNode::isDefaultNamespace ( string $namespace ) : bool
public DOMNode::isSameNode ( DOMNode $otherNode ) : bool
public DOMNode::isSupported ( string $feature , string $version ) : bool
public DOMNode::lookupNamespaceUri ( string $prefix ) : string
public DOMNode::lookupPrefix ( string $namespace ) : string|null
public DOMNode::normalize ( ) : void
public DOMNode::removeChild ( DOMNode $child ) : DOMNode|false
public DOMNode::replaceChild ( DOMNode $node , DOMNode $child ) : DOMNode|false
}

属性

wholeText

Holds all the text of logically-adjacent (not separated by Element, Comment or Processing Instruction) Text nodes.

Table of Contents

  • DOMText::__construct — Creates a new DOMText object
  • DOMText::isElementContentWhitespace — Returns whether this text node contains whitespace in element content
  • DOMText::isWhitespaceInElementContent — Indicates whether this text node contains whitespace
  • DOMText::splitText — Breaks this node into two nodes at the specified offset


Creates a new DOMText object

  • ? DOMText
  • DOMText::isElementContentWhitespace ?
  • PHP Manual
  • DOMText
  • Creates a new DOMText object

DOMText::__construct

(PHP 5, PHP 7)

DOMText::__construct — Creates a new DOMText object

说明

public DOMText::__construct ( string $data = "" )

Creates a new DOMText object.

参数

data

The value of the text node. If not supplied an empty text node is created.

范例

Example #1 Creating a new DOMText

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$text = $element->appendChild(new DOMText('root value'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?><root>root value</root> */

?>

参见

  • DOMDocument::createTextNode() - Create new text node


Returns whether this text node contains whitespace in element content

  • ? DOMText::__construct
  • DOMText::isWhitespaceInElementContent ?
  • PHP Manual
  • DOMText
  • Returns whether this text node contains whitespace in element content

DOMText::isElementContentWhitespace

(No version information available, might only be in Git)

DOMText::isElementContentWhitespace — Returns whether this text node contains whitespace in element content

说明

public DOMText::isElementContentWhitespace ( ) : bool

参数

此函数没有参数。

返回值

成功时返回 true， 或者在失败时返回 false。


Indicates whether this text node contains whitespace

  • ? DOMText::isElementContentWhitespace
  • DOMText::splitText ?
  • PHP Manual
  • DOMText
  • Indicates whether this text node contains whitespace

DOMText::isWhitespaceInElementContent

(PHP 5, PHP 7)

DOMText::isWhitespaceInElementContent — Indicates whether this text node contains whitespace

说明

public DOMText::isWhitespaceInElementContent ( ) : bool

Indicates whether this text node contains only whitespace or it is empty. The text node is determined to contain whitespace in element content during the load of the document.

返回值

Returns true if node contains zero or more whitespace characters and nothing else. Returns false otherwise.


Breaks this node into two nodes at the specified offset

  • ? DOMText::isWhitespaceInElementContent
  • DOMXPath ?
  • PHP Manual
  • DOMText
  • Breaks this node into two nodes at the specified offset

DOMText::splitText

(PHP 5, PHP 7)

DOMText::splitText — Breaks this node into two nodes at the specified offset

说明

public DOMText::splitText ( int $offset ) : DOMText|false

Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.

After being split, this node will contain all the content up to the offset. If the original node had a parent node, the new node is inserted as the next sibling of the original node. When the offset is equal to the length of this node, the new node has no data.

参数

offset

The offset at which to split, starting from 0.

返回值

The new node of the same type, which contains all the content at and after the offset.


The DOMXPath class

(PHP 5, PHP 7)

简介

Supports XPath 1.0

类摘要

DOMXPath {
/* 属性 */
public DOMDocument $document ;
/* 方法 */
public __construct ( DOMDocument $document , bool $registerNodeNS = true )
public evaluate ( string $expression , DOMNode|null $contextNode = null , bool $registerNodeNS = true ) : mixed
public query ( string $expression , DOMNode|null $contextNode = null , bool $registerNodeNS = true ) : mixed
public registerNamespace ( string $prefix , string $namespace ) : bool
public registerPhpFunctions ( string|array|null $restrict = null ) : void
}

属性

document

Table of Contents

  • DOMXPath::__construct — Creates a new DOMXPath object
  • DOMXPath::evaluate — Evaluates the given XPath expression and returns a typed result if possible
  • DOMXPath::query — Evaluates the given XPath expression
  • DOMXPath::registerNamespace — Registers the namespace with the DOMXPath object
  • DOMXPath::registerPhpFunctions — Register PHP functions as XPath functions


Creates a new DOMXPath object

  • ? DOMXPath
  • DOMXPath::evaluate ?
  • PHP Manual
  • DOMXPath
  • Creates a new DOMXPath object

DOMXPath::__construct

(PHP 5, PHP 7)

DOMXPath::__construct — Creates a new DOMXPath object

说明

public DOMXPath::__construct ( DOMDocument $document , bool $registerNodeNS = true )

Creates a new DOMXPath object.

参数

document

The DOMDocument associated with the DOMXPath.


Evaluates the given XPath expression and returns a typed result if possible

  • ? DOMXPath::__construct
  • DOMXPath::query ?
  • PHP Manual
  • DOMXPath
  • Evaluates the given XPath expression and returns a typed result if possible

DOMXPath::evaluate

(PHP 5 >= 5.1.0, PHP 7)

DOMXPath::evaluate — Evaluates the given XPath expression and returns a typed result if possible

说明

public DOMXPath::evaluate ( string $expression , DOMNode|null $contextNode = null , bool $registerNodeNS = true ) : mixed

Executes the given XPath expression and returns a typed result if possible.

参数

expression

The XPath expression to execute.

contextNode

The optional contextNode can be specified for doing relative XPath queries. By default, the queries are relative to the root element.

registerNodeNS

The optional registerNodeNS can be specified to disable automatic registration of the context node.

返回值

Returns a typed result if possible or a DOMNodeList containing all nodes matching the given XPath expression.

If the expression is malformed or the contextNode is invalid, DOMXPath::evaluate() returns false.

范例

Example #1 Getting the count of all the english books

<?php

$doc = new DOMDocument;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

$tbody = $doc->getElementsByTagName('tbody')->item(0);

// our query is relative to the tbody node
$query = 'count(row/entry[. = "en"])';

$entries = $xpath->evaluate($query, $tbody);
echo "There are $entries english books\n";

?>

以上例程会输出：

There are 2 english books

参见

  • DOMXPath::query() - Evaluates the given XPath expression


Evaluates the given XPath expression

  • ? DOMXPath::evaluate
  • DOMXPath::registerNamespace ?
  • PHP Manual
  • DOMXPath
  • Evaluates the given XPath expression

DOMXPath::query

(PHP 5, PHP 7)

DOMXPath::query — Evaluates the given XPath expression

说明

public DOMXPath::query ( string $expression , DOMNode|null $contextNode = null , bool $registerNodeNS = true ) : mixed

Executes the given XPath expression.

参数

expression

The XPath expression to execute.

contextNode

The optional contextNode can be specified for doing relative XPath queries. By default, the queries are relative to the root element.

registerNodeNS

The optional registerNodeNS can be specified to disable automatic registration of the context node.

返回值

Returns a DOMNodeList containing all nodes matching the given XPath expression. Any expression which does not return nodes will return an empty DOMNodeList.

If the expression is malformed or the contextNode is invalid, DOMXPath::query() returns false.

范例

Example #1 Getting all the english books

<?php

$doc = new DOMDocument;

// We don't want to bother with white spaces
$doc->preserveWhiteSpace = false;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

// We start from the root element
$query = '//book/chapter/para/informaltable/tgroup/tbody/row/entry[. = "en"]';

$entries = $xpath->query($query);

foreach ($entries as $entry) {
    echo "Found {$entry->previousSibling->previousSibling->nodeValue}," .
         " by {$entry->previousSibling->nodeValue}\n";
}
?>

以上例程会输出：

Found The Grapes of Wrath, by John Steinbeck
Found The Pearl, by John Steinbeck

We can also use the contextNode parameter to shorten our expression:

<?php

$doc = new DOMDocument;
$doc->preserveWhiteSpace = false;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

$tbody = $doc->getElementsByTagName('tbody')->item(0);

// our query is relative to the tbody node
$query = 'row/entry[. = "en"]';

$entries = $xpath->query($query, $tbody);

foreach ($entries as $entry) {
    echo "Found {$entry->previousSibling->previousSibling->nodeValue}," .
         " by {$entry->previousSibling->nodeValue}\n";
}
?>

参见

  • DOMXPath::evaluate() - Evaluates the given XPath expression and returns a typed result if possible


Registers the namespace with the DOMXPath object

  • ? DOMXPath::query
  • DOMXPath::registerPhpFunctions ?
  • PHP Manual
  • DOMXPath
  • Registers the namespace with the DOMXPath object

DOMXPath::registerNamespace

(PHP 5, PHP 7)

DOMXPath::registerNamespace — Registers the namespace with the DOMXPath object

说明

public DOMXPath::registerNamespace ( string $prefix , string $namespace ) : bool

Registers the namespace and prefix with the DOMXPath object.

参数

prefix

The prefix.

namespace

The URI of the namespace.

返回值

成功时返回 true， 或者在失败时返回 false。


Register PHP functions as XPath functions

  • ? DOMXPath::registerNamespace
  • DOM 函数 ?
  • PHP Manual
  • DOMXPath
  • Register PHP functions as XPath functions

DOMXPath::registerPhpFunctions

(PHP 5 >= 5.3.0, PHP 7)

DOMXPath::registerPhpFunctions — Register PHP functions as XPath functions

说明

public DOMXPath::registerPhpFunctions ( string|array|null $restrict = null ) : void

This method enables the ability to use PHP functions within XPath expressions.

参数

restrict

Use this parameter to only allow certain functions to be called from XPath.

This parameter can be either a string (a function name) or an array of function names.

返回值

没有返回值。

范例

The following examples use book.xml which contains the following:

Example #1 book.xml

<?xml version="1.0" encoding="UTF-8"?>
<books>
 <book>
  <title>PHP Basics</title>
  <author>Jim Smith</author>
  <author>Jane Smith</author>
 </book>
 <book>
  <title>PHP Secrets</title>
  <author>Jenny Smythe</author>
 </book>
 <book>
  <title>XML basics</title>
  <author>Joe Black</author>
 </book>
</books>

Example #2 DOMXPath::registerPHPFunctions() with php:functionString

<?php
$doc = new DOMDocument;
$doc->load('book.xml');

$xpath = new DOMXPath($doc);

// Register the php: namespace (required)
$xpath->registerNamespace("php", "http://php.net/xpath");

// Register PHP functions (no restrictions)
$xpath->registerPHPFunctions();

// Call substr function on the book title
$nodes = $xpath->query('//book[php:functionString("substr", title, 0, 3) = "PHP"]');

echo "Found {$nodes->length} books starting with 'PHP':\n";
foreach ($nodes as $node) {
    $title  = $node->getElementsByTagName("title")->item(0)->nodeValue;
    $author = $node->getElementsByTagName("author")->item(0)->nodeValue;
    echo "$title by $author\n";
}

?>

以上例程的输出类似于：

Found 2 books starting with 'PHP':
PHP Basics by Jim Smith
PHP Secrets by Jenny Smythe

Example #3 DOMXPath::registerPHPFunctions() with php:function

<?php
$doc = new DOMDocument;
$doc->load('book.xml');

$xpath = new DOMXPath($doc);

// Register the php: namespace (required)
$xpath->registerNamespace("php", "http://php.net/xpath");

// Register PHP functions (has_multiple only)
$xpath->registerPHPFunctions("has_multiple");

function has_multiple($nodes) {
    // Return true if more than one author
    return count($nodes) > 1;
}
// Filter books with multiple authors
$books = $xpath->query('//book[php:function("has_multiple", author)]');

echo "Books with multiple authors:\n";
foreach ($books as $book) {
    echo $book->getElementsByTagName("title")->item(0)->nodeValue . "\n";
}

?>

以上例程的输出类似于：

Books with multiple authors:
PHP Basics

参见

  • DOMXPath::registerNamespace() - Registers the namespace with the DOMXPath object
  • DOMXPath::query() - Evaluates the given XPath expression
  • DOMXPath::evaluate() - Evaluates the given XPath expression and returns a typed result if possible


DOM 函数

Table of Contents

  • dom_import_simplexml — Gets a DOMElement object from a SimpleXMLElement object


Gets a DOMElement object from a SimpleXMLElement object

  • ? DOM 函数
  • libxml ?
  • PHP Manual
  • DOM 函数
  • Gets a DOMElement object from a SimpleXMLElement object

dom_import_simplexml

(PHP 5, PHP 7)

dom_import_simplexml — Gets a DOMElement object from a SimpleXMLElement object

说明

dom_import_simplexml ( object $node ) : DOMElement|null

This function takes the node node of class SimpleXML and makes it into a DOMElement node. This new object can then be used as a native DOMElement node.

参数

node

The SimpleXMLElement node.

返回值

The DOMElement node added or false if any errors occur.

范例

Example #1 Import SimpleXML into DOM with dom_import_simplexml()

<?php

$sxe = simplexml_load_string('<books><book><title>blah</title></book></books>');

if ($sxe === false) {
    echo 'Error while parsing the document';
    exit;
}

$dom_sxe = dom_import_simplexml($sxe);
if (!$dom_sxe) {
    echo 'Error while converting XML';
    exit;
}

$dom = new DOMDocument('1.0');
$dom_sxe = $dom->importNode($dom_sxe, true);
$dom_sxe = $dom->appendChild($dom_sxe);

echo $dom->saveXML();

?>

参见

  • simplexml_import_dom() - Get a SimpleXMLElement object from a DOM node


libxml

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • libXMLError — The libXMLError class
  • libxml 函数
    • libxml_clear_errors — Clear libxml error buffer
    • libxml_disable_entity_loader — Disable the ability to load external entities
    • libxml_get_errors — Retrieve array of errors
    • libxml_get_last_error — Retrieve last error from libxml
    • libxml_set_external_entity_loader — Changes the default external entity loader
    • libxml_set_streams_context — Set the streams context for the next libxml document load or write
    • libxml_use_internal_errors — Disable libxml errors and allow user to fetch error information as needed


简介

These functions/constants are available as of PHP 5.1.0, and the following core extensions rely on this libxml extension: DOM, libxml, SimpleXML, SOAP, WDDX, XSL, XML, XMLReader, XMLRPC 和 XMLWriter.


  • ? 安装／配置
  • 安装 ?
  • PHP Manual
  • 安装／配置
  • 需求

需求

This extension requires » libxml >= 2.6.0.


安装

The libxml extension is enabled by default, although it may be disabled with --disable-libxml.

The optional --with-libxml-dir directive is used to specify the location of libxml on the system that PHP is being compiled on, otherwise only the default locations are scanned. The configure process checks for libxml (specifically, xml2-config) in the following order:

  1. The location ([DIR]) specified with --with-libxml-dir ([DIR]=/bin/xml2-config)

  2. /usr/local/bin/xml2-config

  3. /usr/bin/xml2-config

If configure cannot find xml2-config in the directory specified by --with-libxml-dir, then it'll continue on and check the default locations.


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

LIBXML_BIGLINES (int)
Allows line numbers greater than 65535 to be reported correctly.

Note:

Only available as of PHP 7.0.0 with Libxml >= 2.9.0

LIBXML_COMPACT (int)
Activate small nodes allocation optimization. This may speed up your application without needing to change the code.

Note:

Only available in Libxml >= 2.6.21

LIBXML_DTDATTR (int)
Default DTD attributes
LIBXML_DTDLOAD (int)
Load the external subset
LIBXML_DTDVALID (int)
Validate with the DTD
LIBXML_HTML_NOIMPLIED (int)
Sets HTML_PARSE_NOIMPLIED flag, which turns off the automatic adding of implied html/body... elements.

Note:

Only available in Libxml >= 2.7.7 (as of PHP >= 5.4.0)

LIBXML_HTML_NODEFDTD (int)
Sets HTML_PARSE_NODEFDTD flag, which prevents a default doctype being added when one is not found.

Note:

Only available in Libxml >= 2.7.8 (as of PHP >= 5.4.0)

LIBXML_NOBLANKS (int)
Remove blank nodes
LIBXML_NOCDATA (int)
Merge CDATA as text nodes
LIBXML_NOEMPTYTAG (int)
Expand empty tags (e.g. <br/> to <br></br>)

Note:

This option is currently just available in the DOMDocument::save and DOMDocument::saveXML functions.

LIBXML_NOENT (int)
Substitute entities
Caution

Enabling entity substitution may facilitate XML External Entity (XXE) attacks.

LIBXML_NOERROR (int)
Suppress error reports
LIBXML_NONET (int)
Disable network access when loading documents
LIBXML_NOWARNING (int)
Suppress warning reports
LIBXML_NOXMLDECL (int)
Drop the XML declaration when saving a document

Note:

Only available in Libxml >= 2.6.21

LIBXML_NSCLEAN (int)
Remove redundant namespace declarations
LIBXML_PARSEHUGE (int)
Sets XML_PARSE_HUGE flag, which relaxes any hardcoded limit from the parser. This affects limits like maximum depth of a document or the entity recursion, as well as limits of the size of text nodes.

Note:

Only available in Libxml >= 2.7.0 (as of PHP >= 5.3.2 and PHP >= 5.2.12)

LIBXML_PEDANTIC (int)
Sets XML_PARSE_PEDANTIC flag, which enables pedantic error reporting.

Note:

Available as of PHP >= 5.4.0

LIBXML_XINCLUDE (int)
Implement XInclude substitution
LIBXML_ERR_ERROR (int)
A recoverable error
LIBXML_ERR_FATAL (int)
A fatal error
LIBXML_ERR_NONE (int)
No errors
LIBXML_ERR_WARNING (int)
A simple warning
LIBXML_VERSION (int)
libxml version like 20605 or 20617
LIBXML_DOTTED_VERSION (string)
libxml version like 2.6.5 or 2.6.17
LIBXML_SCHEMA_CREATE (int)
Create default/fixed value nodes during XSD schema validation

Note:

Only available in Libxml >= 2.6.14 (as of PHP >= 5.5.2)


The libXMLError class

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

简介

Contains various information about errors thrown by libxml. The error codes are described within the official » xmlError API documentation.

类摘要

libXMLError {
/* 属性 */
public int $level ;
public int $code ;
public int $column ;
public string $message ;
public string $file ;
public int $line ;
}

属性

level

the severity of the error (one of the following constants: LIBXML_ERR_WARNING, LIBXML_ERR_ERROR or LIBXML_ERR_FATAL)

code

The error's code.

column

The column where the error occurred.

Note:

This property isn't entirely implemented in libxml and therefore 0 is often returned.

message

The error message, if any.

file

The filename, or empty if the XML was loaded from a string.

line

The line where the error occurred.


libxml 函数

Table of Contents

  • libxml_clear_errors — Clear libxml error buffer
  • libxml_disable_entity_loader — Disable the ability to load external entities
  • libxml_get_errors — Retrieve array of errors
  • libxml_get_last_error — Retrieve last error from libxml
  • libxml_set_external_entity_loader — Changes the default external entity loader
  • libxml_set_streams_context — Set the streams context for the next libxml document load or write
  • libxml_use_internal_errors — Disable libxml errors and allow user to fetch error information as needed


Clear libxml error buffer

  • ? libxml 函数
  • libxml_disable_entity_loader ?
  • PHP Manual
  • libxml 函数
  • Clear libxml error buffer

libxml_clear_errors

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

libxml_clear_errors — Clear libxml error buffer

说明

libxml_clear_errors ( ) : void

libxml_clear_errors() clears the libxml error buffer.

返回值

没有返回值。

参见

  • libxml_get_errors() - Retrieve array of errors
  • libxml_get_last_error() - Retrieve last error from libxml


Disable the ability to load external entities

  • ? libxml_clear_errors
  • libxml_get_errors ?
  • PHP Manual
  • libxml 函数
  • Disable the ability to load external entities

libxml_disable_entity_loader

(PHP 5 >= 5.2.11, PHP 7, PHP 8)

libxml_disable_entity_loader — Disable the ability to load external entities

Warning

本函数已自 PHP 8.0.0 起被废弃。强烈建议不要依赖本函数。

说明

libxml_disable_entity_loader ( bool $disable = true ) : bool

Disable/enable the ability to load external entities. Note that disabling the loading of external entities may cause general issues with loading XML documents. However, as of libxml 2.9.0 entity substitution is disabled by default, so there is no need to disable the loading of external entities, unless there is the need to resolve internal entity references with LIBXML_NOENT. Generally, it is preferable to use libxml_set_external_entity_loader() to suppress loading of external entities.

参数

disable

Disable (true) or enable (false) libxml extensions (such as DOM, XMLWriter and XMLReader) to load external entities.

返回值

Returns the previous value.

参见

  • libxml_use_internal_errors() - Disable libxml errors and allow user to fetch error information as needed
  • libxml_set_external_entity_loader() - Changes the default external entity loader
  • The LIBXML_NONET constant


Retrieve array of errors

  • ? libxml_disable_entity_loader
  • libxml_get_last_error ?
  • PHP Manual
  • libxml 函数
  • Retrieve array of errors

libxml_get_errors

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

libxml_get_errors — Retrieve array of errors

说明

libxml_get_errors ( ) : array

Retrieve array of errors.

返回值

Returns an array with LibXMLError objects if there are any errors in the buffer, or an empty array otherwise.

范例

Example #1 A libxml_get_errors() example

This example demonstrates how to build a simple libxml error handler.

<?php

libxml_use_internal_errors(true);

$xmlstr = <<< XML
<?xml version='1.0' standalone='yes'?>
<movies>
 <movie>
  <titles>PHP: Behind the Parser</title>
 </movie>
</movies>
XML;

$doc = simplexml_load_string($xmlstr);
$xml = explode("\n", $xmlstr);

if ($doc === false) {
    $errors = libxml_get_errors();

    foreach ($errors as $error) {
        echo display_xml_error($error, $xml);
    }

    libxml_clear_errors();
}

function display_xml_error($error, $xml)
{
    $return  = $xml[$error->line - 1] . "\n";
    $return .= str_repeat('-', $error->column) . "^\n";

    switch ($error->level) {
        case LIBXML_ERR_WARNING:
            $return .= "Warning $error->code: ";
            break;
         case LIBXML_ERR_ERROR:
            $return .= "Error $error->code: ";
            break;
        case LIBXML_ERR_FATAL:
            $return .= "Fatal Error $error->code: ";
            break;
    }

    $return .= trim($error->message) .
               "\n  Line: $error->line" .
               "\n  Column: $error->column";

    if ($error->file) {
        $return .= "\n  File: $error->file";
    }

    return "$return\n\n--------------------------------------------\n\n";
}

?>

以上例程会输出：

  <titles>PHP: Behind the Parser</title>
----------------------------------------------^
Fatal Error 76: Opening and ending tag mismatch: titles line 4 and title
  Line: 4
  Column: 46

--------------------------------------------

参见

  • libxml_get_last_error() - Retrieve last error from libxml
  • libxml_clear_errors() - Clear libxml error buffer


Retrieve last error from libxml

  • ? libxml_get_errors
  • libxml_set_external_entity_loader ?
  • PHP Manual
  • libxml 函数
  • Retrieve last error from libxml

libxml_get_last_error

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

libxml_get_last_error — Retrieve last error from libxml

说明

libxml_get_last_error ( ) : LibXMLError|false

Retrieve last error from libxml.

返回值

Returns a LibXMLError object if there is any error in the buffer, false otherwise.

参见

  • libxml_get_errors() - Retrieve array of errors
  • libxml_clear_errors() - Clear libxml error buffer


Changes the default external entity loader

  • ? libxml_get_last_error
  • libxml_set_streams_context ?
  • PHP Manual
  • libxml 函数
  • Changes the default external entity loader

libxml_set_external_entity_loader

(PHP 5 >= 5.4.0, PHP 7, PHP 8)

libxml_set_external_entity_loader — Changes the default external entity loader

说明

libxml_set_external_entity_loader ( callable|null $resolver_function ) : bool

Changes the default external entity loader. This can be used to suppress the expansion of arbitrary external entities to avoid XXE attacks, even when LIBXML_NOENT has been set for the respective operation, and is usually preferable over calling libxml_disable_entity_loader().

参数

resolver_function

A callable with the following signature:

resolver ( string $public_id , string $system_id , array $context ) : resource|string|null
public_id
The public ID.
system_id
The system ID.
context
An array with the four elements "directory", "intSubName", "extSubURI" and "extSubSystem".
This callable should return a 资源(resource), a string from which a resource can be opened. If null is returned, the entity reference resolution will fail.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 libxml_set_external_entity_loader() example

<?php
$xml = <<<XML
<!DOCTYPE foo PUBLIC "-//FOO/BAR" "http://example.com/foobar">
<foo>bar</foo>
XML;

$dtd = <<<DTD
<!ELEMENT foo (#PCDATA)>
DTD;

libxml_set_external_entity_loader(
    function ($public, $system, $context) use($dtd) {
        var_dump($public);
        var_dump($system);
        var_dump($context);
        $f = fopen("php://temp", "r+");
        fwrite($f, $dtd);
        rewind($f);
        return $f;
    }
);

$dd = new DOMDocument;
$r  = $dd->loadXML($xml);

var_dump($dd->validate());
?>

以上例程会输出：

string(10) "-//FOO/BAR"
string(25) "http://example.com/foobar"
array(4) {
    ["directory"]    => NULL
    ["intSubName"]   => NULL
    ["extSubURI"]    => NULL
    ["extSubSystem"] => NULL
}
bool(true)

参见

  • libxml_disable_entity_loader() - Disable the ability to load external entities


Set the streams context for the next libxml document load or write

  • ? libxml_set_external_entity_loader
  • libxml_use_internal_errors ?
  • PHP Manual
  • libxml 函数
  • Set the streams context for the next libxml document load or write

libxml_set_streams_context

(PHP 5, PHP 7, PHP 8)

libxml_set_streams_context — Set the streams context for the next libxml document load or write

说明

libxml_set_streams_context ( resource $context ) : void

Sets the streams context for the next libxml document load or write.

参数

context

The stream context resource (created with stream_context_create())

返回值

没有返回值。

范例

Example #1 A libxml_set_streams_context() example

<?php

$opts = array(
    'http' => array(
        'user_agent' => 'PHP libxml agent',
    )
);

$context = stream_context_create($opts);
libxml_set_streams_context($context);

// request a file through HTTP
$doc = DOMDocument::load('http://www.example.com/file.xml');

?>

参见

  • stream_context_create() - 创建资源流上下文


Disable libxml errors and allow user to fetch error information as needed

  • ? libxml_set_streams_context
  • SimpleXML ?
  • PHP Manual
  • libxml 函数
  • Disable libxml errors and allow user to fetch error information as needed

libxml_use_internal_errors

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

libxml_use_internal_errors — Disable libxml errors and allow user to fetch error information as needed

说明

libxml_use_internal_errors ( bool|null $use_errors = null ) : bool

libxml_use_internal_errors() allows you to disable standard libxml errors and enable user error handling.

参数

use_errors

Enable (true) user error handling or disable (false) user error handling. Disabling will also clear any existing libxml errors.

返回值

This function returns the previous value of use_errors.

更新日志

版本 | 说明
8.0.0 | use_errors is nullable now. Previously, its default was false.

范例

Example #1 A libxml_use_internal_errors() example

This example demonstrates the basic usage of libxml errors and the value returned by this function.

<?php

// enable user error handling
var_dump(libxml_use_internal_errors(true));

// load the document
$doc = new DOMDocument;

if (!$doc->load('file.xml')) {
    foreach (libxml_get_errors() as $error) {
        // handle errors here
    }

    libxml_clear_errors();
}

?>

以上例程会输出：

bool(false)

参见

  • libxml_clear_errors() - Clear libxml error buffer
  • libxml_get_errors() - Retrieve array of errors


SimpleXML

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Basic SimpleXML usage
    • Dealing with XML errors
  • SimpleXMLElement — The SimpleXMLElement class
    • SimpleXMLElement::addAttribute — Adds an attribute to the SimpleXML element
    • SimpleXMLElement::addChild — Adds a child element to the XML node
    • SimpleXMLElement::asXML — Return a well-formed XML string based on SimpleXML element
    • SimpleXMLElement::attributes — Identifies an element's attributes
    • SimpleXMLElement::children — Finds children of given node
    • SimpleXMLElement::__construct — Creates a new SimpleXMLElement object
    • SimpleXMLElement::count — Counts the children of an element
    • SimpleXMLElement::getDocNamespaces — Returns namespaces declared in document
    • SimpleXMLElement::getName — Gets the name of the XML element
    • SimpleXMLElement::getNamespaces — Returns namespaces used in document
    • SimpleXMLElement::registerXPathNamespace — Creates a prefix/ns context for the next XPath query
    • SimpleXMLElement::saveXML — 别名 SimpleXMLElement::asXML
    • SimpleXMLElement::__toString — Returns the string content
    • SimpleXMLElement::xpath — Runs XPath query on XML data
  • SimpleXMLIterator — The SimpleXMLIterator class
    • SimpleXMLIterator::current — Returns the current element
    • SimpleXMLIterator::getChildren — Returns the sub-elements of the current element
    • SimpleXMLIterator::hasChildren — Checks whether the current element has sub elements
    • SimpleXMLIterator::key — Return current key
    • SimpleXMLIterator::next — Move to next element
    • SimpleXMLIterator::rewind — Rewind to the first element
    • SimpleXMLIterator::valid — Check whether the current element is valid
  • SimpleXML 函数
    • simplexml_import_dom — Get a SimpleXMLElement object from a DOM node
    • simplexml_load_file — Interprets an XML file into an object
    • simplexml_load_string — Interprets a string of XML into an object


简介

SimpleXML 扩展提供了一个非常简单和易于使用的工具集，能将 XML 转换成一个带有一般属性选择器和数组迭代器的对象。


  • ? 简介
  • 需求 ?
  • PHP Manual
  • SimpleXML
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


需求

此扩展需要 libxml PHP 扩展。这表示需要使用 --with-libxml，或在 PHP 7.4 之前的版本中使用 --enable-libxml， 尽管这将隐式完成因为 libxml 是缺省开启的。

The SimpleXML extension requires PHP 5.


安装

此扩展默认为启用，编译时可通过下列选项禁用： --disable-simplexml

Note: Before PHP 5.1.2, --enable-simplexml is required to enable this extension.


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • SimpleXML
  • 预定义常量

预定义常量

此扩展没有定义常量。


  • ? 预定义常量
  • Basic SimpleXML usage ?
  • PHP Manual
  • SimpleXML
  • 范例

范例

Table of Contents

  • Basic SimpleXML usage
  • Dealing with XML errors


Basic SimpleXML usage

Many examples in this reference require an XML string. Instead of repeating this string in every example, we put it into a file which we include in each example. This included file is shown in the following example section. Alternatively, you could create an XML document and read it with simplexml_load_file().

Example #1 Include file example.php with XML string

<?php
$xmlstr = <<<XML
<?xml version='1.0' standalone='yes'?>
<movies>
 <movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Ms. Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&#211;r</actor>
   </character>
  </characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <great-lines>
   <line>PHP solves all my web problems</line>
  </great-lines>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
 </movie>
</movies>
XML;
?>

The simplicity of SimpleXML appears most clearly when one extracts a string or number from a basic XML document.

Example #2 Getting <plot>

<?php
include 'example.php';

$movies = new SimpleXMLElement($xmlstr);

echo $movies->movie[0]->plot;
?>

以上例程会输出：

   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.

Accessing elements within an XML document that contain characters not permitted under PHP's naming convention (e.g. the hyphen) can be accomplished by encapsulating the element name within braces and the apostrophe.

Example #3 Getting <line>

<?php
include 'example.php';

$movies = new SimpleXMLElement($xmlstr);

echo $movies->movie->{'great-lines'}->line;
?>

以上例程会输出：

PHP solves all my web problems

Example #4 Accessing non-unique elements in SimpleXML

When multiple instances of an element exist as children of a single parent element, normal iteration techniques apply.

<?php
include 'example.php';

$movies = new SimpleXMLElement($xmlstr);

/* For each <character> node, we echo a separate <name>. */
foreach ($movies->movie->characters->character as $character) {
   echo $character->name, ' played by ', $character->actor, PHP_EOL;
}

?>

以上例程会输出：

Ms. Coder played by Onlivia Actora
Mr. Coder played by El Actór

Note:

Properties ($movies->movie in previous example) are not arrays. They are iterable and accessible objects.

Example #5 Using attributes

So far, we have only covered the work of reading element names and their values. SimpleXML can also access element attributes. Access attributes of an element just as you would elements of an array.

<?php
include 'example.php';

$movies = new SimpleXMLElement($xmlstr);

/* Access the <rating> nodes of the first movie.
 * Output the rating scale, too. */
foreach ($movies->movie[0]->rating as $rating) {
    switch((string) $rating['type']) { // Get attributes as element indices
    case 'thumbs':
        echo $rating, ' thumbs up';
        break;
    case 'stars':
        echo $rating, ' stars';
        break;
    }
}
?>

以上例程会输出：

7 thumbs up5 stars

Example #6 Comparing Elements and Attributes with Text

To compare an element or attribute with a string or pass it into a function that requires a string, you must cast it to a string using (string). Otherwise, PHP treats the element as an object.

<?php
include 'example.php';

$movies = new SimpleXMLElement($xmlstr);

if ((string) $movies->movie->title == 'PHP: Behind the Parser') {
    print 'My favorite movie.';
}

echo htmlentities((string) $movies->movie->title);
?>

以上例程会输出：

My favorite movie.PHP: Behind the Parser

Example #7 Comparing Two Elements

Two SimpleXMLElements are considered different even if they point to the same element since PHP 5.2.0.

<?php
include 'example.php';

$movies1 = new SimpleXMLElement($xmlstr);
$movies2 = new SimpleXMLElement($xmlstr);
var_dump($movies1 == $movies2); // false since PHP 5.2.0
?>

以上例程会输出：

bool(false)

Example #8 Using XPath

SimpleXML includes built-in XPath support. To find all <character> elements:

<?php
include 'example.php';

$movies = new SimpleXMLElement($xmlstr);

foreach ($movies->xpath('//character') as $character) {
    echo $character->name, ' played by ', $character->actor, PHP_EOL;
}
?>

'//' serves as a wildcard. To specify absolute paths, omit one of the slashes.

以上例程会输出：

Ms. Coder played by Onlivia Actora
Mr. Coder played by El Actór

Example #9 Setting values

Data in SimpleXML doesn't have to be constant. The object allows for manipulation of all of its elements.

<?php
include 'example.php';
$movies = new SimpleXMLElement($xmlstr);

$movies->movie[0]->characters->character[0]->name = 'Miss Coder';

echo $movies->asXML();
?>

以上例程会输出：

<?xml version="1.0" standalone="yes"?>
<movies>
 <movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Miss Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&#xD3;r</actor>
   </character>
  </characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <great-lines>
   <line>PHP solves all my web problems</line>
  </great-lines>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
 </movie>
</movies>

Example #10 Adding elements and attributes

Since PHP 5.1.3, SimpleXML has had the ability to easily add children and attributes.

<?php
include 'example.php';
$movies = new SimpleXMLElement($xmlstr);

$character = $movies->movie[0]->characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $movies->movie[0]->addChild('rating', 'PG');
$rating->addAttribute('type', 'mpaa');

echo $movies->asXML();
?>

以上例程会输出：

<?xml version="1.0" standalone="yes"?>
<movies>
 <movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Ms. Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&#xD3;r</actor>
   </character>
  <character><name>Mr. Parser</name><actor>John Doe</actor></character></characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <great-lines>
   <line>PHP solves all my web problems</line>
  </great-lines>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
 <rating type="mpaa">PG</rating></movie>
</movies>

Example #11 DOM Interoperability

PHP has a mechanism to convert XML nodes between SimpleXML and DOM formats. This example shows how one might change a DOM element to SimpleXML.

<?php
$dom = new DOMDocument;
$dom->loadXML('<books><book><title>blah</title></book></books>');
if (!$dom) {
    echo 'Error while parsing the document';
    exit;
}

$books = simplexml_import_dom($dom);

echo $books->book[0]->title;
?>

以上例程会输出：

blah


Dealing with XML errors

Dealing with XML errors when loading documents is a very simple task. Using the libxml functionality it is possible to suppress all XML errors when loading the document and then iterate over the errors.

The libXMLError object, returned by libxml_get_errors(), contains several properties including the message, line and column (position) of the error.

Example #1 Loading broken XML string

<?php
libxml_use_internal_errors(true);
$sxe = simplexml_load_string("<?xml version='1.0'><broken><xml></broken>");
if ($sxe === false) {
    echo "Failed loading XML\n";
    foreach(libxml_get_errors() as $error) {
        echo "\t", $error->message;
    }
}
?>

以上例程会输出：

Failed loading XML
    Blank needed here
    parsing XML declaration: '?>' expected
    Opening and ending tag mismatch: xml line 1 and broken
    Premature end of data in tag broken line 1

参见

  • libxml_use_internal_errors()
  • libxml_get_errors()
  • libXMLError


The SimpleXMLElement class

(PHP 5, PHP 7, PHP 8)

简介

Represents an element in an XML document.

类摘要

SimpleXMLElement implements Traversable {
/* 方法 */
final public __construct ( string $data , int $options = 0 , bool $data_is_url = false , string $ns = "" , bool $is_prefix = false )
public addAttribute ( string $name , string $value = ? , string $namespace = ? ) : void
public addChild ( string $name , string $value = ? , string $namespace = ? ) : SimpleXMLElement
public asXML ( string $filename = ? ) : mixed
public attributes ( string $ns = null , bool $is_prefix = false ) : SimpleXMLElement
public children ( string $ns = ? , bool $is_prefix = false ) : SimpleXMLElement
public count ( ) : int
public getDocNamespaces ( bool $recursive = false , bool $from_root = true ) : array
public getName ( ) : string
public getNamespaces ( bool $recursive = false ) : array
public registerXPathNamespace ( string $prefix , string $ns ) : bool
public __toString ( ) : string
public xpath ( string $path ) : array
}

Table of Contents

  • SimpleXMLElement::addAttribute — Adds an attribute to the SimpleXML element
  • SimpleXMLElement::addChild — Adds a child element to the XML node
  • SimpleXMLElement::asXML — Return a well-formed XML string based on SimpleXML element
  • SimpleXMLElement::attributes — Identifies an element's attributes
  • SimpleXMLElement::children — Finds children of given node
  • SimpleXMLElement::__construct — Creates a new SimpleXMLElement object
  • SimpleXMLElement::count — Counts the children of an element
  • SimpleXMLElement::getDocNamespaces — Returns namespaces declared in document
  • SimpleXMLElement::getName — Gets the name of the XML element
  • SimpleXMLElement::getNamespaces — Returns namespaces used in document
  • SimpleXMLElement::registerXPathNamespace — Creates a prefix/ns context for the next XPath query
  • SimpleXMLElement::saveXML — 别名 SimpleXMLElement::asXML
  • SimpleXMLElement::__toString — Returns the string content
  • SimpleXMLElement::xpath — Runs XPath query on XML data


Adds an attribute to the SimpleXML element

  • ? SimpleXMLElement
  • SimpleXMLElement::addChild ?
  • PHP Manual
  • SimpleXMLElement
  • Adds an attribute to the SimpleXML element

SimpleXMLElement::addAttribute

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

SimpleXMLElement::addAttribute — Adds an attribute to the SimpleXML element

说明

public SimpleXMLElement::addAttribute ( string $name , string $value = ? , string $namespace = ? ) : void

Adds an attribute to the SimpleXML element.

参数

name

The name of the attribute to add.

value

The value of the attribute.

namespace

If specified, the namespace to which the attribute belongs.

返回值

没有返回值。

范例

Note:

Listed examples may include example.php, which refers to the XML string found in the first example of the basic usage guide.

Example #1 Add attributes and children to a SimpleXML element

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
$sxe->addAttribute('type', 'documentary');

$movie = $sxe->addChild('movie');
$movie->addChild('title', 'PHP2: More Parser Stories');
$movie->addChild('plot', 'This is all about the people who make it work.');

$characters = $movie->addChild('characters');
$character  = $characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $movie->addChild('rating', '5');
$rating->addAttribute('type', 'stars');

echo $sxe->asXML();

?>

以上例程的输出类似于：

<?xml version="1.0" standalone="yes"?>
<movies type="documentary">
 <movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Ms. Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&#xD3;r</actor>
   </character>
  </characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <great-lines>
   <line>PHP solves all my web problems</line>
  </great-lines>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
 </movie>
 <movie>
  <title>PHP2: More Parser Stories</title>
  <plot>This is all about the people who make it work.</plot>
  <characters>
   <character>
    <name>Mr. Parser</name>
    <actor>John Doe</actor>
   </character>
  </characters>
  <rating type="stars">5</rating>
 </movie>
</movies>

参见

  • SimpleXMLElement::addChild() - Adds a child element to the XML node
  • Basic SimpleXML usage


Adds a child element to the XML node

  • ? SimpleXMLElement::addAttribute
  • SimpleXMLElement::asXML ?
  • PHP Manual
  • SimpleXMLElement
  • Adds a child element to the XML node

SimpleXMLElement::addChild

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

SimpleXMLElement::addChild — Adds a child element to the XML node

说明

public SimpleXMLElement::addChild ( string $name , string $value = ? , string $namespace = ? ) : SimpleXMLElement

Adds a child element to the node and returns a SimpleXMLElement of the child.

参数

name

The name of the child element to add.

value

If specified, the value of the child element.

namespace

If specified, the namespace to which the child element belongs.

返回值

The addChild method returns a SimpleXMLElement object representing the child added to the XML node.

范例

Note:

Listed examples may include example.php, which refers to the XML string found in the first example of the basic usage guide.

Example #1 Add attributes and children to a SimpleXML element

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
$sxe->addAttribute('type', 'documentary');

$movie = $sxe->addChild('movie');
$movie->addChild('title', 'PHP2: More Parser Stories');
$movie->addChild('plot', 'This is all about the people who make it work.');

$characters = $movie->addChild('characters');
$character  = $characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $movie->addChild('rating', '5');
$rating->addAttribute('type', 'stars');

echo $sxe->asXML();

?>

以上例程的输出类似于：

<?xml version="1.0" standalone="yes"?>
<movies type="documentary">
 <movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Ms. Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&#xD3;r</actor>
   </character>
  </characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <great-lines>
   <line>PHP solves all my web problems</line>
  </great-lines>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
 </movie>
 <movie>
  <title>PHP2: More Parser Stories</title>
  <plot>This is all about the people who make it work.</plot>
  <characters>
   <character>
    <name>Mr. Parser</name>
    <actor>John Doe</actor>
   </character>
  </characters>
  <rating type="stars">5</rating>
 </movie>
</movies>

参见

  • SimpleXMLElement::addAttribute() - Adds an attribute to the SimpleXML element
  • Basic SimpleXML usage


Return a well-formed XML string based on SimpleXML element

  • ? SimpleXMLElement::addChild
  • SimpleXMLElement::attributes ?
  • PHP Manual
  • SimpleXMLElement
  • Return a well-formed XML string based on SimpleXML element

SimpleXMLElement::asXML

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::asXML — Return a well-formed XML string based on SimpleXML element

说明

public SimpleXMLElement::asXML ( string $filename = ? ) : mixed

The asXML method formats the parent object's data in XML version 1.0.

参数

filename

If specified, the function writes the data to the file rather than returning it.

返回值

If the filename isn't specified, this function returns a string on success and false on error. If the parameter is specified, it returns true if the file was written successfully and false otherwise.

范例

Example #1 Get XML

<?php
$string = <<<XML
<a>
 <b>
  <c>text</c>
  <c>stuff</c>
 </b>
 <d>
  <c>code</c>
 </d>
</a>
XML;

$xml = new SimpleXMLElement($string);

echo $xml->asXML();

?>

以上例程会输出：

<?xml version="1.0"?>
<a>
 <b>
  <c>text</c>
  <c>stuff</c>
 </b>
 <d>
  <c>code</c>
 </d>
</a>

asXML also works on Xpath results:

Example #2 Using asXML() on SimpleXMLElement::xpath() results

<?php
// Continued from example XML above.

/* Search for <a><b><c> */
$result = $xml->xpath('/a/b/c');

foreach ($result as $node) {
    echo $node->asXML();
}
?>

以上例程会输出：

<c>text</c><c>stuff</c>

参见

  • SimpleXMLElement::__toString() - Returns the string content
  • Basic SimpleXML usage


Identifies an element's attributes

  • ? SimpleXMLElement::asXML
  • SimpleXMLElement::children ?
  • PHP Manual
  • SimpleXMLElement
  • Identifies an element's attributes

SimpleXMLElement::attributes

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::attributes — Identifies an element's attributes

说明

public SimpleXMLElement::attributes ( string $ns = null , bool $is_prefix = false ) : SimpleXMLElement

This function provides the attributes and values defined within an xml tag.

Note: SimpleXML 建起了一个给大多数方法添加迭代属性的规则。不能通过使用 var_dump() 或任何可检查对象的其它东西来查看。

参数

ns

An optional namespace for the retrieved attributes

is_prefix

Default to false

返回值

Returns a SimpleXMLElement object that can be iterated over to loop through the attributes on the tag.

Returns null if called on a SimpleXMLElement object that already represents an attribute and not a tag.

更新日志

版本 | 说明
5.2.0 | The optional parameter is_prefix was added.

范例

Example #1 Interpret an XML string

<?php
$string = <<<XML
<a>
 <foo name="one" game="lonely">1</foo>
</a>
XML;

$xml = simplexml_load_string($string);
foreach($xml->foo[0]->attributes() as $a => $b) {
    echo $a,'="',$b,"\"\n";
}
?>

以上例程会输出：

name="one"
game="lonely"

参见

  • Basic SimpleXML usage


Finds children of given node

  • ? SimpleXMLElement::attributes
  • SimpleXMLElement::__construct ?
  • PHP Manual
  • SimpleXMLElement
  • Finds children of given node

SimpleXMLElement::children

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::children — Finds children of given node

说明

public SimpleXMLElement::children ( string $ns = ? , bool $is_prefix = false ) : SimpleXMLElement

This method finds the children of an element. The result follows normal iteration rules.

Note: SimpleXML 建起了一个给大多数方法添加迭代属性的规则。不能通过使用 var_dump() 或任何可检查对象的其它东西来查看。

参数

ns

An XML namespace.

is_prefix

If is_prefix is true, ns will be regarded as a prefix. If false, ns will be regarded as a namespace URL.

返回值

Returns a SimpleXMLElement element, whether the node has children or not.

范例

Example #1 Traversing a children() pseudo-array

<?php
$xml = new SimpleXMLElement(
'<person>
 <child role="son">
  <child role="daughter"/>
 </child>
 <child role="daughter">
  <child role="son">
   <child role="son"/>
  </child>
 </child>
</person>');

foreach ($xml->children() as $second_gen) {
    echo ' The person begot a ' . $second_gen['role'];

    foreach ($second_gen->children() as $third_gen) {
        echo ' who begot a ' . $third_gen['role'] . ';';

        foreach ($third_gen->children() as $fourth_gen) {
            echo ' and that ' . $third_gen['role'] .
                ' begot a ' . $fourth_gen['role'];
        }
    }
}
?>

以上例程会输出：

The person begot a son who begot a daughter; The person
begot a daughter who begot a son; and that son begot a son

Example #2 Using namespaces

<?php
$xml = '<example xmlns:foo="my.foo.urn">
  <foo:a>Apple</foo:a>
  <foo:b>Banana</foo:b>
  <c>Cherry</c>
</example>';

$sxe = new SimpleXMLElement($xml);

$kids = $sxe->children('foo');
var_dump(count($kids));

$kids = $sxe->children('foo', TRUE);
var_dump(count($kids));

$kids = $sxe->children('my.foo.urn');
var_dump(count($kids));

$kids = $sxe->children('my.foo.urn', TRUE);
var_dump(count($kids));

$kids = $sxe->children();
var_dump(count($kids));
?>
int(0)
int(2)
int(2)
int(0)
int(1)

注释

SimpleXMLElement::children() returns a node object no matter if the current node has children or not. Use count() on the return value to see if there are any children. As of PHP 5.3.0, SimpleXMLElement::count() may be used instead.

参见

  • SimpleXMLElement::count() - Counts the children of an element
  • count() - 计算数组中的单元数目，或对象中的属性个数


Creates a new SimpleXMLElement object

  • ? SimpleXMLElement::children
  • SimpleXMLElement::count ?
  • PHP Manual
  • SimpleXMLElement
  • Creates a new SimpleXMLElement object

SimpleXMLElement::__construct

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::__construct — Creates a new SimpleXMLElement object

说明

final public SimpleXMLElement::__construct ( string $data , int $options = 0 , bool $data_is_url = false , string $ns = "" , bool $is_prefix = false )

Creates a new SimpleXMLElement object.

参数

data

A well-formed XML string or the path or URL to an XML document if data_is_url is true.

options

Optionally used to specify additional Libxml parameters, which affect reading of XML documents. Options which affect the output of XML documents (e.g. LIBXML_NOEMPTYTAG) are silently ignored.

Note:

It may be necessary to pass LIBXML_PARSEHUGE to be able to process deeply nested XML or very large text nodes.

data_is_url

By default, data_is_url is false. Use true to specify that data is a path or URL to an XML document instead of string data.

ns

Namespace prefix or URI.

is_prefix

true if ns is a prefix, false if it's a URI; defaults to false.

返回值

Returns a SimpleXMLElement object representing data.

错误／异常

Produces an E_WARNING error message for each error found in the XML data and additionally throws an Exception if the XML data could not be parsed.

Tip

Use libxml_use_internal_errors() to suppress all XML errors, and libxml_get_errors() to iterate over them afterwards.

更新日志

版本 | 说明
5.2.0 | Added the ns and is_prefix parameters.
5.1.2 | Added the options and data_is_url parameters.

范例

Note:

Listed examples may include example.php, which refers to the XML string found in the first example of the basic usage guide.

Example #1 Create a SimpleXMLElement object

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
echo $sxe->movie[0]->title;

?>

以上例程会输出：

PHP: Behind the Parser

Example #2 Create a SimpleXMLElement object from a URL

<?php

$sxe = new SimpleXMLElement('http://example.org/document.xml', NULL, TRUE);
echo $sxe->asXML();

?>

参见

  • Basic SimpleXML usage
  • simplexml_load_string() - Interprets a string of XML into an object
  • simplexml_load_file() - Interprets an XML file into an object
  • Dealing with XML errors
  • libxml_use_internal_errors() - Disable libxml errors and allow user to fetch error information as needed


Counts the children of an element

  • ? SimpleXMLElement::__construct
  • SimpleXMLElement::getDocNamespaces ?
  • PHP Manual
  • SimpleXMLElement
  • Counts the children of an element

SimpleXMLElement::count

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SimpleXMLElement::count — Counts the children of an element

说明

public SimpleXMLElement::count ( ) : int

This method counts the number of children of an element.

返回值

Returns the number of elements of an element.

范例

Example #1 Counting the number of children

<?php
$xml = <<<EOF
<people>
 <person name="Person 1">
  <child/>
  <child/>
  <child/>
 </person>
 <person name="Person 2">
  <child/>
  <child/>
  <child/>
  <child/>
  <child/>
 </person>
</people>
EOF;

$elem = new SimpleXMLElement($xml);

foreach ($elem as $person) {
    printf("%s has got %d children.\n", $person['name'], $person->count());
}
?>

以上例程会输出：

Person 1 has got 3 children.
Person 2 has got 5 children.

参见

  • SimpleXMLElement::children() - Finds children of given node


Returns namespaces declared in document

  • ? SimpleXMLElement::count
  • SimpleXMLElement::getName ?
  • PHP Manual
  • SimpleXMLElement
  • Returns namespaces declared in document

SimpleXMLElement::getDocNamespaces

(PHP 5 >= 5.1.2, PHP 7, PHP 8)

SimpleXMLElement::getDocNamespaces — Returns namespaces declared in document

说明

public SimpleXMLElement::getDocNamespaces ( bool $recursive = false , bool $from_root = true ) : array

Returns namespaces declared in document

参数

recursive

If specified, returns all namespaces declared in parent and child nodes. Otherwise, returns only namespaces declared in root node.

from_root

Allows you to recursively check namespaces under a child node instead of from the root of the XML doc.

返回值

The getDocNamespaces method returns an array of namespace names with their associated URIs.

范例

Example #1 Get document namespaces

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns">
    <p:person id="1">John Doe</p:person>
    <p:person id="2">Susie Q. Public</p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getDocNamespaces();
var_dump($namespaces);

?>

以上例程会输出：

array(1) {
   ["p"]=>
   string(21) "http://example.org/ns"
}

Example #2 Working with multiple namespaces

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns" xmlns:t="http://example.org/test">
    <p:person t:id="1">John Doe</p:person>
    <p:person t:id="2" a:addr="123 Street" xmlns:a="http://example.org/addr">
        Susie Q. Public
    </p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getDocNamespaces(TRUE);
var_dump($namespaces);

?>

以上例程会输出：

array(3) {
  ["p"]=>
  string(21) "http://example.org/ns"
  ["t"]=>
  string(23) "http://example.org/test"
  ["a"]=>
  string(23) "http://example.org/addr"
}

参见

  • SimpleXMLElement::getNamespaces() - Returns namespaces used in document
  • SimpleXMLElement::registerXPathNamespace() - Creates a prefix/ns context for the next XPath query


Gets the name of the XML element

  • ? SimpleXMLElement::getDocNamespaces
  • SimpleXMLElement::getNamespaces ?
  • PHP Manual
  • SimpleXMLElement
  • Gets the name of the XML element

SimpleXMLElement::getName

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

SimpleXMLElement::getName — Gets the name of the XML element

说明

public SimpleXMLElement::getName ( ) : string

Gets the name of the XML element.

返回值

The getName method returns as a string the name of the XML tag referenced by the SimpleXMLElement object.

范例

Note:

Listed examples may include example.php, which refers to the XML string found in the first example of the basic usage guide.

Example #1 Get XML element names

<?php
include 'example.php';
$sxe = new SimpleXMLElement($xmlstr);

echo $sxe->getName() . "\n";

foreach ($sxe->children() as $child)
{
    echo $child->getName() . "\n";
}

?>

以上例程会输出：

movies
movie


Returns namespaces used in document

  • ? SimpleXMLElement::getName
  • SimpleXMLElement::registerXPathNamespace ?
  • PHP Manual
  • SimpleXMLElement
  • Returns namespaces used in document

SimpleXMLElement::getNamespaces

(PHP 5 >= 5.1.2, PHP 7, PHP 8)

SimpleXMLElement::getNamespaces — Returns namespaces used in document

说明

public SimpleXMLElement::getNamespaces ( bool $recursive = false ) : array

Returns namespaces used in document

参数

recursive

If specified, returns all namespaces used in parent and child nodes. Otherwise, returns only namespaces used in root node.

返回值

The getNamespaces method returns an array of namespace names with their associated URIs.

范例

Example #1 Get document namespaces in use

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns" xmlns:t="http://example.org/test">
    <p:person id="1">John Doe</p:person>
    <p:person id="2">Susie Q. Public</p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getNamespaces(true);
var_dump($namespaces);

?>

以上例程会输出：

array(1) {
  ["p"]=>
  string(21) "http://example.org/ns"
}

参见

  • SimpleXMLElement::getDocNamespaces() - Returns namespaces declared in document
  • SimpleXMLElement::registerXPathNamespace() - Creates a prefix/ns context for the next XPath query


Creates a prefix/ns context for the next XPath query

  • ? SimpleXMLElement::getNamespaces
  • SimpleXMLElement::saveXML ?
  • PHP Manual
  • SimpleXMLElement
  • Creates a prefix/ns context for the next XPath query

SimpleXMLElement::registerXPathNamespace

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

SimpleXMLElement::registerXPathNamespace — Creates a prefix/ns context for the next XPath query

说明

public SimpleXMLElement::registerXPathNamespace ( string $prefix , string $ns ) : bool

Creates a prefix/ns context for the next XPath query. In particular, this is helpful if the provider of the given XML document alters the namespace prefixes. registerXPathNamespace will create a prefix for the associated namespace, allowing one to access nodes in that namespace without the need to change code to allow for the new prefixes dictated by the provider.

参数

prefix

The namespace prefix to use in the XPath query for the namespace given in ns.

ns

The namespace to use for the XPath query. This must match a namespace in use by the XML document or the XPath query using prefix will not return any results.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Setting a namespace prefix to use in an XPath query

<?php

$xml = <<<EOD
<book xmlns:chap="http://example.org/chapter-title">
    <title>My Book</title>
    <chapter id="1">
        <chap:title>Chapter 1</chap:title>
        <para>Donec velit. Nullam eget tellus vitae tortor gravida scelerisque.
            In orci lorem, cursus imperdiet, ultricies non, hendrerit et, orci.
            Nulla facilisi. Nullam velit nisl, laoreet id, condimentum ut,
            ultricies id, mauris.</para>
    </chapter>
    <chapter id="2">
        <chap:title>Chapter 2</chap:title>
        <para>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Proin
            gravida. Phasellus tincidunt massa vel urna. Proin adipiscing quam
            vitae odio. Sed dictum. Ut tincidunt lorem ac lorem. Duis eros
            tellus, pharetra id, faucibus eu, dapibus dictum, odio.</para>
    </chapter>
</book>
EOD;

$sxe = new SimpleXMLElement($xml);

$sxe->registerXPathNamespace('c', 'http://example.org/chapter-title');
$result = $sxe->xpath('//c:title');

foreach ($result as $title) {
  echo $title . "\n";
}

?>

以上例程会输出：

Chapter 1
Chapter 2

Notice how the XML document shown in the example sets a namespace with a prefix of chap. Imagine that this document (or another one like it) may have used a prefix of c in the past for the same namespace. Since it has changed, the XPath query will no longer return the proper results and the query will require modification. Using registerXPathNamespace avoids future modification of the query even if the provider changes the namespace prefix.

参见

  • SimpleXMLElement::xpath() - Runs XPath query on XML data
  • SimpleXMLElement::getDocNamespaces() - Returns namespaces declared in document
  • SimpleXMLElement::getNamespaces() - Returns namespaces used in document


别名 SimpleXMLElement::asXML

  • ? SimpleXMLElement::registerXPathNamespace
  • SimpleXMLElement::__toString ?
  • PHP Manual
  • SimpleXMLElement
  • 别名 SimpleXMLElement::asXML

SimpleXMLElement::saveXML

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

SimpleXMLElement::saveXML — 别名 SimpleXMLElement::asXML()

说明

此方法是该方法的别名： SimpleXMLElement::asXML()


Returns the string content

  • ? SimpleXMLElement::saveXML
  • SimpleXMLElement::xpath ?
  • PHP Manual
  • SimpleXMLElement
  • Returns the string content

SimpleXMLElement::__toString

(PHP 5 >= 5.3.0, PHP 7, PHP 8)

SimpleXMLElement::__toString — Returns the string content

说明

public SimpleXMLElement::__toString ( ) : string

Returns text content that is directly in this element. Does not return text content that is inside this element's children.

参数

此函数没有参数。

返回值

Returns the string content on success or an empty string on failure.

范例

Example #1 Get string content

<?php
$xml = new SimpleXMLElement('<a>1 <b>2 </b>3</a>');
echo $xml;
?>

以上例程会输出：

1 3

参见

  • SimpleXMLElement::asXML() - Return a well-formed XML string based on SimpleXML element


Runs XPath query on XML data

  • ? SimpleXMLElement::__toString
  • SimpleXMLIterator ?
  • PHP Manual
  • SimpleXMLElement
  • Runs XPath query on XML data

SimpleXMLElement::xpath

(PHP 5, PHP 7, PHP 8)

SimpleXMLElement::xpath — Runs XPath query on XML data

说明

public SimpleXMLElement::xpath ( string $path ) : array

The xpath method searches the SimpleXML node for children matching the XPath path.

参数

path

An XPath path

返回值

Returns an array of SimpleXMLElement objects or false in case of an error.

范例

Example #1 Xpath

<?php
$string = <<<XML
<a>
 <b>
  <c>text</c>
  <c>stuff</c>
 </b>
 <d>
  <c>code</c>
 </d>
</a>
XML;

$xml = new SimpleXMLElement($string);

/* Search for <a><b><c> */
$result = $xml->xpath('/a/b/c');

while(list( , $node) = each($result)) {
    echo '/a/b/c: ',$node,"\n";
}

/* Relative paths also work... */
$result = $xml->xpath('b/c');

while(list( , $node) = each($result)) {
    echo 'b/c: ',$node,"\n";
}
?>

以上例程会输出：

/a/b/c: text
/a/b/c: stuff
b/c: text
b/c: stuff

Notice that the two results are equal.

参见

  • SimpleXMLElement::registerXPathNamespace() - Creates a prefix/ns context for the next XPath query
  • SimpleXMLElement::getDocNamespaces() - Returns namespaces declared in document
  • SimpleXMLElement::getNamespaces() - Returns namespaces used in document
  • Basic SimpleXML usage


The SimpleXMLIterator class

(PHP 5 >= 5.1.3, PHP 7, PHP 8)

简介

The SimpleXMLIterator provides recursive iteration over all nodes of a SimpleXMLElement object.

类摘要

SimpleXMLIterator extends SimpleXMLElement implements RecursiveIterator , Countable {
/* 方法 */
public current ( ) : mixed
public getChildren ( ) : SimpleXMLIterator
public hasChildren ( ) : bool
public key ( ) : mixed
public next ( ) : void
public rewind ( ) : void
public valid ( ) : bool
/* 继承的方法 */
final public SimpleXMLElement::__construct ( string $data , int $options = 0 , bool $data_is_url = false , string $ns = "" , bool $is_prefix = false )
public SimpleXMLElement::addAttribute ( string $name , string $value = ? , string $namespace = ? ) : void
public SimpleXMLElement::addChild ( string $name , string $value = ? , string $namespace = ? ) : SimpleXMLElement
public SimpleXMLElement::asXML ( string $filename = ? ) : mixed
public SimpleXMLElement::attributes ( string $ns = null , bool $is_prefix = false ) : SimpleXMLElement
public SimpleXMLElement::children ( string $ns = ? , bool $is_prefix = false ) : SimpleXMLElement
public SimpleXMLElement::count ( ) : int
public SimpleXMLElement::getDocNamespaces ( bool $recursive = false , bool $from_root = true ) : array
public SimpleXMLElement::getName ( ) : string
public SimpleXMLElement::getNamespaces ( bool $recursive = false ) : array
public SimpleXMLElement::registerXPathNamespace ( string $prefix , string $ns ) : bool
public SimpleXMLElement::__toString ( ) : string
public SimpleXMLElement::xpath ( string $path ) : array
}

Table of Contents

  • SimpleXMLIterator::current — Returns the current element
  • SimpleXMLIterator::getChildren — Returns the sub-elements of the current element
  • SimpleXMLIterator::hasChildren — Checks whether the current element has sub elements
  • SimpleXMLIterator::key — Return current key
  • SimpleXMLIterator::next — Move to next element
  • SimpleXMLIterator::rewind — Rewind to the first element
  • SimpleXMLIterator::valid — Check whether the current element is valid


Returns the current element

  • ? SimpleXMLIterator
  • SimpleXMLIterator::getChildren ?
  • PHP Manual
  • SimpleXMLIterator
  • Returns the current element

SimpleXMLIterator::current

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::current — Returns the current element

说明

public SimpleXMLIterator::current ( ) : mixed

This method returns the current element as a SimpleXMLIterator object or null.

参数

此函数没有参数。

返回值

Returns the current element as a SimpleXMLIterator object or null on failure.

范例

Example #1 Return the current element

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>PHP basics</book><book>XML basics</book></books>');
var_dump($xmlIterator->current());

$xmlIterator->rewind(); // rewind to first element
var_dump($xmlIterator->current());
?>

以上例程会输出：

NULL
object(SimpleXMLIterator)#2 (1) {
  [0]=>
  string(10) "PHP basics"
}

参见

  • SimpleXMLIterator::key() - Return current key
  • SimpleXMLIterator::next() - Move to next element
  • SimpleXMLIterator::rewind() - Rewind to the first element
  • SimpleXMLIterator::valid() - Check whether the current element is valid
  • SimpleXMLElement


Returns the sub-elements of the current element

  • ? SimpleXMLIterator::current
  • SimpleXMLIterator::hasChildren ?
  • PHP Manual
  • SimpleXMLIterator
  • Returns the sub-elements of the current element

SimpleXMLIterator::getChildren

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::getChildren — Returns the sub-elements of the current element

说明

public SimpleXMLIterator::getChildren ( ) : SimpleXMLIterator

This method returns a SimpleXMLIterator object containing sub-elements of the current SimpleXMLIterator element.

参数

此函数没有参数。

返回值

Returns a SimpleXMLIterator object containing the sub-elements of the current element.

范例

Example #1 Return the sub-elements of the current element

<?php
$xml = <<<XML
<books>
    <book>
        <title>PHP Basics</title>
        <author>Jim Smith</author>
    </book>
    <book>XML basics</book>
</books>
XML;

$xmlIterator = new SimpleXMLIterator($xml);
for( $xmlIterator->rewind(); $xmlIterator->valid(); $xmlIterator->next() ) {
    foreach($xmlIterator->getChildren() as $name => $data) {
    echo "The $name is '$data' from the class " . get_class($data) . "\n";
    }
}
?>

以上例程会输出：

The title is 'PHP Basics' from the class SimpleXMLIterator
The author is 'Jim Smith' from the class SimpleXMLIterator


Checks whether the current element has sub elements

  • ? SimpleXMLIterator::getChildren
  • SimpleXMLIterator::key ?
  • PHP Manual
  • SimpleXMLIterator
  • Checks whether the current element has sub elements

SimpleXMLIterator::hasChildren

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::hasChildren — Checks whether the current element has sub elements

说明

public SimpleXMLIterator::hasChildren ( ) : bool

This method checks whether the current SimpleXMLIterator element has sub-elements.

参数

此函数没有参数。

返回值

true if the current element has sub-elements, otherwise false

范例

Example #1 Check whether the current element has sub-elements

<?php
$xml = <<<XML
<books>
    <book>
        <title>PHP Basics</title>
        <author>Jim Smith</author>
    </book>
    <book>XML basics</book>
</books>
XML;

$xmlIterator = new SimpleXMLIterator( $xml );
for( $xmlIterator->rewind(); $xmlIterator->valid(); $xmlIterator->next() ) {
    if($xmlIterator->hasChildren()) {
        var_dump($xmlIterator->current());
    }
}
?>

以上例程会输出：

object(SimpleXMLIterator)#2 (2) {
  ["title"]=>
  string(10) "PHP Basics"
  ["author"]=>
  string(9) "Jim Smith"
}


Return current key

  • ? SimpleXMLIterator::hasChildren
  • SimpleXMLIterator::next ?
  • PHP Manual
  • SimpleXMLIterator
  • Return current key

SimpleXMLIterator::key

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::key — Return current key

说明

public SimpleXMLIterator::key ( ) : mixed

This method gets the XML tag name of the current element.

参数

此函数没有参数。

返回值

Returns the XML tag name of the element referenced by the current SimpleXMLIterator object or false

范例

Example #1 Get the current XML tag key

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>PHP basics</book><book>XML basics</book></books>');

echo var_dump($xmlIterator->key());
$xmlIterator->rewind(); // rewind to the first element
echo var_dump($xmlIterator->key());

?>

以上例程会输出：

bool(false)
string(4) "book"


Move to next element

  • ? SimpleXMLIterator::key
  • SimpleXMLIterator::rewind ?
  • PHP Manual
  • SimpleXMLIterator
  • Move to next element

SimpleXMLIterator::next

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::next — Move to next element

说明

public SimpleXMLIterator::next ( ) : void

This method moves the SimpleXMLIterator to the next element.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Move to the next element

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>PHP Basics</book><book>XML basics</book></books>');
$xmlIterator->rewind(); // rewind to the first element
$xmlIterator->next();

var_dump($xmlIterator->current());
?>

以上例程会输出：

object(SimpleXMLIterator)#2 (1) {
  [0]=>
  string(10) "XML basics"
}


Rewind to the first element

  • ? SimpleXMLIterator::next
  • SimpleXMLIterator::valid ?
  • PHP Manual
  • SimpleXMLIterator
  • Rewind to the first element

SimpleXMLIterator::rewind

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::rewind — Rewind to the first element

说明

public SimpleXMLIterator::rewind ( ) : void

This method rewinds the SimpleXMLIterator to the first element.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Rewind to the first element

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>PHP Basics</book><book>XML Basics</book></books>');
$xmlIterator->rewind();

var_dump($xmlIterator->current());
?>

以上例程会输出：

object(SimpleXMLIterator)#2 (1) {
  [0]=>
  string(10) "PHP Basics"
}


Check whether the current element is valid

  • ? SimpleXMLIterator::rewind
  • SimpleXML 函数 ?
  • PHP Manual
  • SimpleXMLIterator
  • Check whether the current element is valid

SimpleXMLIterator::valid

(PHP 5, PHP 7, PHP 8)

SimpleXMLIterator::valid — Check whether the current element is valid

说明

public SimpleXMLIterator::valid ( ) : bool

This method checks if the current element is valid after calls to SimpleXMLIterator::rewind() or SimpleXMLIterator::next().

参数

此函数没有参数。

返回值

Returns true if the current element is valid, otherwise false

范例

Example #1 Check whether the current element is valid

<?php
$xmlIterator = new SimpleXMLIterator('<books><book>SQL Basics</book></books>');

$xmlIterator->rewind(); // rewind to the first element
echo var_dump($xmlIterator->valid()); // bool(true)

$xmlIterator->next(); // advance to the next element
echo var_dump($xmlIterator->valid()); // bool(false) because there is only one element
?>


SimpleXML 函数

Table of Contents

  • simplexml_import_dom — Get a SimpleXMLElement object from a DOM node
  • simplexml_load_file — Interprets an XML file into an object
  • simplexml_load_string — Interprets a string of XML into an object


Get a SimpleXMLElement object from a DOM node

  • ? SimpleXML 函数
  • simplexml_load_file ?
  • PHP Manual
  • SimpleXML 函数
  • Get a SimpleXMLElement object from a DOM node

simplexml_import_dom

(PHP 5, PHP 7, PHP 8)

simplexml_import_dom — Get a SimpleXMLElement object from a DOM node

说明

simplexml_import_dom ( DOMNode $node , string $class_name = "SimpleXMLElement" ) : SimpleXMLElement|null

This function takes a node of a DOM document and makes it into a SimpleXML node. This new object can then be used as a native SimpleXML element.

参数

node

A DOM Element node

class_name

You may use this optional parameter so that simplexml_import_dom() will return an object of the specified class. That class should extend the SimpleXMLElement class.

返回值

Returns a SimpleXMLElement or null on failure.

范例

Example #1 Importing DOM

<?php
$dom = new DOMDocument;
$dom->loadXML('<books><book><title>blah</title></book></books>');
if (!$dom) {
    echo 'Error while parsing the document';
    exit;
}

$s = simplexml_import_dom($dom);

echo $s->book[0]->title;
?>

以上例程会输出：

blah

参见

  • dom_import_simplexml() - Gets a DOMElement object from a SimpleXMLElement object
  • Basic SimpleXML usage


Interprets an XML file into an object

  • ? simplexml_import_dom
  • simplexml_load_string ?
  • PHP Manual
  • SimpleXML 函数
  • Interprets an XML file into an object

simplexml_load_file

(PHP 5, PHP 7, PHP 8)

simplexml_load_file — Interprets an XML file into an object

说明

simplexml_load_file ( string $filename , string $class_name = "SimpleXMLElement" , int $options = 0 , string $ns = "" , bool $is_prefix = false ) : SimpleXMLElement|false

Convert the well-formed XML document in the given file to an object.

参数

filename

Path to the XML file

Note:

Libxml 2 unescapes the URI, so if you want to pass e.g. b&c as the URI parameter a, you have to call simplexml_load_file(rawurlencode('http://example.com/?a=' . urlencode('b&c'))). Since PHP 5.1.0 you don't need to do this because PHP will do it for you.

class_name

You may use this optional parameter so that simplexml_load_file() will return an object of the specified class. That class should extend the SimpleXMLElement class.

options

Since PHP 5.1.0 and Libxml 2.6.0, you may also use the options parameter to specify additional Libxml parameters.

ns

Namespace prefix or URI.

is_prefix

true if ns is a prefix, false if it's a URI; defaults to false.

返回值

Returns an object of class SimpleXMLElement with properties containing the data held within the XML document, 或者在失败时返回 false.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

错误／异常

Produces an E_WARNING error message for each error found in the XML data.

Tip

Use libxml_use_internal_errors() to suppress all XML errors, and libxml_get_errors() to iterate over them afterwards.

更新日志

版本 | 说明
5.2.0 | The optional parameter is_prefix was added.

范例

Example #1 Interpret an XML document

<?php
// The file test.xml contains an XML document with a root element
// and at least an element /[root]/title.

if (file_exists('test.xml')) {
    $xml = simplexml_load_file('test.xml');

    print_r($xml);
} else {
    exit('Failed to open test.xml.');
}
?>

This script will display, on success:

SimpleXMLElement Object
(
  [title] => Example Title
  ...
)

At this point, you can go about using $xml->title and any other elements.

参见

  • simplexml_load_string() - Interprets a string of XML into an object
  • SimpleXMLElement::__construct() - Creates a new SimpleXMLElement object
  • Dealing with XML errors
  • libxml_use_internal_errors() - Disable libxml errors and allow user to fetch error information as needed
  • Basic SimpleXML usage


Interprets a string of XML into an object

  • ? simplexml_load_file
  • WDDX ?
  • PHP Manual
  • SimpleXML 函数
  • Interprets a string of XML into an object

simplexml_load_string

(PHP 5, PHP 7, PHP 8)

simplexml_load_string — Interprets a string of XML into an object

说明

simplexml_load_string ( string $data , string $class_name = "SimpleXMLElement" , int $options = 0 , string $ns = "" , bool $is_prefix = false ) : SimpleXMLElement|false

Takes a well-formed XML string and returns it as an object.

参数

data

A well-formed XML string

class_name

You may use this optional parameter so that simplexml_load_string() will return an object of the specified class. That class should extend the SimpleXMLElement class.

options

Since PHP 5.1.0 and Libxml 2.6.0, you may also use the options parameter to specify additional Libxml parameters.

ns

Namespace prefix or URI.

is_prefix

true if ns is a prefix, false if it's a URI; defaults to false.

返回值

Returns an object of class SimpleXMLElement with properties containing the data held within the xml document, 或者在失败时返回 false.

Warning

此函数可能返回布尔值 false，但也可能返回等同于 false 的非布尔值。请阅读 布尔类型章节以获取更多信息。应使用 === 运算符来测试此函数的返回值。

错误／异常

Produces an E_WARNING error message for each error found in the XML data.

Tip

Use libxml_use_internal_errors() to suppress all XML errors, and libxml_get_errors() to iterate over them afterwards.

更新日志

版本 | 说明
5.2.0 | The optional parameter is_prefix was added.

范例

Example #1 Interpret an XML string

<?php
$string = <<<XML
<?xml version='1.0'?>
<document>
 <title>Forty What?</title>
 <from>Joe</from>
 <to>Jane</to>
 <body>
  I know that's the answer -- but what's the question?
 </body>
</document>
XML;

$xml = simplexml_load_string($string);

print_r($xml);
?>

以上例程会输出：

SimpleXMLElement Object
(
  [title] => Forty What?
  [from] => Joe
  [to] => Jane
  [body] =>
   I know that's the answer -- but what's the question?
)

At this point, you can go about using $xml->body and such.

参见

  • simplexml_load_file() - Interprets an XML file into an object
  • SimpleXMLElement::__construct() - Creates a new SimpleXMLElement object
  • Dealing with XML errors
  • libxml_use_internal_errors() - Disable libxml errors and allow user to fetch error information as needed
  • Basic SimpleXML usage


WDDX

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • wddx examples
  • WDDX 函数
    • wddx_add_vars — Add variables to a WDDX packet with the specified ID
    • wddx_deserialize — Unserializes a WDDX packet
    • wddx_packet_end — Ends a WDDX packet with the specified ID
    • wddx_packet_start — Starts a new WDDX packet with structure inside it
    • wddx_serialize_value — Serialize a single value into a WDDX packet
    • wddx_serialize_vars — Serialize variables into a WDDX packet


简介

Warning

This extension is DEPRECATED and UNBUNDLED as of PHP 7.4.0.

These functions are intended for work with » WDDX.

Warning

Do not pass untrusted user input to wddx_deserialize(). Unserialization can result in code being loaded and executed due to object instantiation and autoloading, and a malicious user may be able to exploit this. Use a safe, standard data interchange format such as JSON (via json_decode() and json_encode()) if you need to pass serialized data to the user.


需求

此扩展需要 libxml PHP 扩展。这表示需要使用 --with-libxml，或在 PHP 7.4 之前的版本中使用 --enable-libxml， 尽管这将隐式完成因为 libxml 是缺省开启的。

In order to use WDDX, you will need to install the expat library (which comes with Apache 1.3.7 or higher).


安装

PHP 7.4

此扩展已被移至 » PECL 资源库且不再与 PHP 捆绑。7.4.0

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/wddx.

PHP < 7.4

After installing the required expat library, compile PHP with --enable-wddx, and use --with-libexpat-dir for expat.

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。


资源类型

This extension defines a WDDX packet identifier returned by wddx_packet_start().


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • WDDX
  • 预定义常量

预定义常量

此扩展没有定义常量。


  • ? 预定义常量
  • wddx examples ?
  • PHP Manual
  • WDDX
  • 范例

范例

Table of Contents

  • wddx examples


wddx examples

All the functions that serialize variables use the first element of an array to determine whether the array is to be serialized into an array or structure. If the first element has string key, then it is serialized into a structure, otherwise, into an array.

Example #1 Serializing a single value with WDDX

<?php
echo wddx_serialize_value("PHP to WDDX packet example", "PHP packet");
?>

This example will produce:

<wddxPacket version='1.0'><header comment='PHP packet'/><data>
<string>PHP to WDDX packet example</string></data></wddxPacket>

Example #2 Using incremental packets with WDDX

<?php
$pi = 3.1415926;
$packet_id = wddx_packet_start("PHP");
wddx_add_vars($packet_id, "pi");

/* Suppose $cities came from database */
$cities = array("Austin", "Novato", "Seattle");
wddx_add_vars($packet_id, "cities");

$packet = wddx_packet_end($packet_id);
echo $packet;
?>

This example will produce:

<wddxPacket version='1.0'><header comment='PHP'/><data><struct>
<var name='pi'><number>3.1415926</number></var><var name='cities'>
<array length='3'><string>Austin</string><string>Novato</string>
<string>Seattle</string></array></var></struct></data></wddxPacket>

Note:

If you want to serialize non-ASCII characters you have to convert your data to UTF-8 first (see utf8_encode() and iconv()).


WDDX 函数

Table of Contents

  • wddx_add_vars — Add variables to a WDDX packet with the specified ID
  • wddx_deserialize — Unserializes a WDDX packet
  • wddx_packet_end — Ends a WDDX packet with the specified ID
  • wddx_packet_start — Starts a new WDDX packet with structure inside it
  • wddx_serialize_value — Serialize a single value into a WDDX packet
  • wddx_serialize_vars — Serialize variables into a WDDX packet


Add variables to a WDDX packet with the specified ID

  • ? WDDX 函数
  • wddx_deserialize ?
  • PHP Manual
  • WDDX 函数
  • Add variables to a WDDX packet with the specified ID

wddx_add_vars

(PHP 4, PHP 5, PHP 7)

wddx_add_vars — Add variables to a WDDX packet with the specified ID

Warning

该函数已在 PHP 7.4.0 中 移除。

说明

wddx_add_vars ( resource $packet_id , mixed $var_name , mixed ...$var_names ) : bool

Serializes the passed variables and add the result to the given packet.

参数

This function takes a variable number of parameters.

packet_id

A WDDX packet, returned by wddx_packet_start().

var_name

Can be either a string naming a variable or an array containing strings naming the variables or another array, etc.

var_names

返回值

成功时返回 true， 或者在失败时返回 false。


Unserializes a WDDX packet

  • ? wddx_add_vars
  • wddx_packet_end ?
  • PHP Manual
  • WDDX 函数
  • Unserializes a WDDX packet

wddx_deserialize

(PHP 4, PHP 5, PHP 7)

wddx_deserialize — Unserializes a WDDX packet

Warning

该函数已在 PHP 7.4.0 中 移除。

说明

wddx_deserialize ( string $packet ) : mixed

Unserializes a WDDX packet.

Warning

Do not pass untrusted user input to wddx_deserialize(). Unserialization can result in code being loaded and executed due to object instantiation and autoloading, and a malicious user may be able to exploit this. Use a safe, standard data interchange format such as JSON (via json_decode() and json_encode()) if you need to pass serialized data to the user.

参数

packet

A WDDX packet, as a string or stream.

返回值

Returns the deserialized value which can be a string, a number or an array. Note that structures are deserialized into associative arrays.


Ends a WDDX packet with the specified ID

  • ? wddx_deserialize
  • wddx_packet_start ?
  • PHP Manual
  • WDDX 函数
  • Ends a WDDX packet with the specified ID

wddx_packet_end

(PHP 4, PHP 5, PHP 7)

wddx_packet_end — Ends a WDDX packet with the specified ID

Warning

该函数已在 PHP 7.4.0 中 移除。

说明

wddx_packet_end ( resource $packet_id ) : string

Ends and returns the given WDDX packet.

参数

packet_id

A WDDX packet, returned by wddx_packet_start().

返回值

Returns the string containing the WDDX packet.


Starts a new WDDX packet with structure inside it

  • ? wddx_packet_end
  • wddx_serialize_value ?
  • PHP Manual
  • WDDX 函数
  • Starts a new WDDX packet with structure inside it

wddx_packet_start

(PHP 4, PHP 5, PHP 7)

wddx_packet_start — Starts a new WDDX packet with structure inside it

Warning

该函数已在 PHP 7.4.0 中 移除。

说明

wddx_packet_start ( string $comment = ? ) : resource

Start a new WDDX packet for incremental addition of variables. It automatically creates a structure definition inside the packet to contain the variables.

参数

comment

An optional comment string.

返回值

Returns a packet ID for use in later functions, or false on error.


Serialize a single value into a WDDX packet

  • ? wddx_packet_start
  • wddx_serialize_vars ?
  • PHP Manual
  • WDDX 函数
  • Serialize a single value into a WDDX packet

wddx_serialize_value

(PHP 4, PHP 5, PHP 7)

wddx_serialize_value — Serialize a single value into a WDDX packet

Warning

该函数已在 PHP 7.4.0 中 移除。

说明

wddx_serialize_value ( mixed $var , string $comment = ? ) : string

Creates a WDDX packet from a single given value.

参数

var

The value to be serialized

comment

An optional comment string that appears in the packet header.

返回值

Returns the WDDX packet, or false on error.


Serialize variables into a WDDX packet

  • ? wddx_serialize_value
  • XMLDiff ?
  • PHP Manual
  • WDDX 函数
  • Serialize variables into a WDDX packet

wddx_serialize_vars

(PHP 4, PHP 5, PHP 7)

wddx_serialize_vars — Serialize variables into a WDDX packet

Warning

该函数已在 PHP 7.4.0 中 移除。

说明

wddx_serialize_vars ( mixed $var_name , mixed ...$var_names ) : string

Creates a WDDX packet with a structure that contains the serialized representation of the passed variables.

参数

This function takes a variable number of parameters.

var_name

Can be either a string naming a variable or an array containing strings naming the variables or another array, etc.

var_names

返回值

Returns the WDDX packet, or false on error.

范例

Example #1 wddx_serialize_vars() example

<?php
$a = 1;
$b = 5.5;
$c = array("blue", "orange", "violet");
$d = "colors";

$clvars = array("c", "d");
echo wddx_serialize_vars("a", "b", $clvars);
?>

以上例程会输出：

<wddxPacket version='1.0'><header/><data><struct><var name='a'><number>1</number></var>
<var name='b'><number>5.5</number></var><var name='c'><array length='3'>
<string>blue</string><string>orange</string><string>violet</string></array></var>
<var name='d'><string>colors</string></var></struct></data></wddxPacket>


XML diff and merge

  • 简介
  • 安装／配置
    • 需求
    • 安装
  • XMLDiff\Base — The XMLDiff\Base class
    • XMLDiff\Base::__construct — Constructor
    • XMLDiff\Base::diff — Produce diff of two XML documents
    • XMLDiff\Base::merge — Produce new XML document based on diff
  • XMLDiff\DOM — The XMLDiff\DOM class
    • XMLDiff\DOM::diff — Diff two DOMDocument objects
    • XMLDiff\DOM::merge — Produce merged DOMDocument
  • XMLDiff\Memory — The XMLDiff\Memory class
    • XMLDiff\Memory::diff — Diff two XML documents
    • XMLDiff\Memory::merge — Produce merged XML document
  • XMLDiff\File — The XMLDiff\File class
    • XMLDiff\File::diff — Diff two XML files
    • XMLDiff\File::merge — Produce merged XML document


简介

The extension is able to produce diffs of two XML documents and then to apply the difference to the source document. The diff is a XML document containing copy/insert/delete instruction nodes in human readable format. DOMDocument objects, local files and strings in memory can be processed.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • XMLDiff
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装


需求

libdiffmark - version 0.10 is bundled with the extension. If diffmark is available from your system packages, its usage is strongly encouraged.

libxml extension

DOM extension


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/xmldiff.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/xmldiff/.


The XMLDiff\Base class

(PECL xmldiff >= 0.8.0)

简介

Base abstract class for all the comparsion classes in the extension.

类摘要

XMLDiff\Base {
/* 方法 */
public __construct ( string $nsname )
abstract public diff ( mixed $from , mixed $to ) : mixed
abstract public merge ( mixed $src , mixed $diff ) : mixed
}

Table of Contents

  • XMLDiff\Base::__construct — Constructor
  • XMLDiff\Base::diff — Produce diff of two XML documents
  • XMLDiff\Base::merge — Produce new XML document based on diff


Constructor

  • ? XMLDiff\Base
  • XMLDiff\Base::diff ?
  • PHP Manual
  • XMLDiff\Base
  • Constructor

XMLDiff\Base::__construct

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::__construct — Constructor

说明

public XMLDiff\Base::__construct ( string $nsname )

Base constructor for all the worker classes in the xmldiff extension.

参数

nsname

Custom namespace name for the diff document. The default namespace is http://www.locus.cz/diffmark and that's enough to avoid namespace conflicts. Use this parameter if you want to change it for some reason.

返回值


Produce diff of two XML documents

  • ? XMLDiff\Base::__construct
  • XMLDiff\Base::merge ?
  • PHP Manual
  • XMLDiff\Base
  • Produce diff of two XML documents

XMLDiff\Base::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::diff — Produce diff of two XML documents

说明

abstract public XMLDiff\Base::diff ( mixed $from , mixed $to ) : mixed

Abstract diff method to be implemented by inheriting classes.

The basic purpose of this method is to produce diff of the two documents. The param order matters and will produce different output.

参数

from

Source XML document.

to

Target XML document.

返回值

Implementation dependent.


Produce new XML document based on diff

  • ? XMLDiff\Base::diff
  • XMLDiff\DOM ?
  • PHP Manual
  • XMLDiff\Base
  • Produce new XML document based on diff

XMLDiff\Base::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::merge — Produce new XML document based on diff

说明

abstract public XMLDiff\Base::merge ( mixed $src , mixed $diff ) : mixed

Abstract merge method to be implemented by inheriting classes.

Basically the method purpose is to produce a new XML document based on the diff information.

参数

src

Source XML document.

diff

Document produced by the diff method.

返回值

Implementation dependent.


The XMLDiff\DOM class

(PECL xmldiff >= 0.8.0)

简介

类摘要

XMLDiff\DOM extends XMLDiff\Base {
/* 方法 */
public diff ( DOMDocument $from , DOMDocument $to ) : DOMDocument
public merge ( DOMDocument $src , DOMDocument $diff ) : DOMDocument
/* 继承的方法 */
public XMLDiff\Base::__construct ( string $nsname )
abstract public XMLDiff\Base::diff ( mixed $from , mixed $to ) : mixed
abstract public XMLDiff\Base::merge ( mixed $src , mixed $diff ) : mixed
}

Table of Contents

  • XMLDiff\DOM::diff — Diff two DOMDocument objects
  • XMLDiff\DOM::merge — Produce merged DOMDocument


Diff two DOMDocument objects

  • ? XMLDiff\DOM
  • XMLDiff\DOM::merge ?
  • PHP Manual
  • XMLDiff\DOM
  • Diff two DOMDocument objects

XMLDiff\DOM::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\DOM::diff — Diff two DOMDocument objects

说明

public XMLDiff\DOM::diff ( DOMDocument $from , DOMDocument $to ) : DOMDocument

Diff two DOMDocument instances and produce the new one containing the diff information.

参数

from

Source DOMDocument object.

to

Target DOMDocument object.

返回值

DOMDocument with the diff information or NULL.


Produce merged DOMDocument

  • ? XMLDiff\DOM::diff
  • XMLDiff\Memory ?
  • PHP Manual
  • XMLDiff\DOM
  • Produce merged DOMDocument

XMLDiff\DOM::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\DOM::merge — Produce merged DOMDocument

说明

public XMLDiff\DOM::merge ( DOMDocument $src , DOMDocument $diff ) : DOMDocument

Create new DOMDocument based on the diff.

参数

src

Source DOMDocument object.

diff

DOMDocument object containing the diff information.

返回值

Merged DOMDocument or NULL.


The XMLDiff\Memory class

(PECL xmldiff >= 0.8.0)

简介

类摘要

XMLDiff\Memory extends XMLDiff\Base {
/* 方法 */
public diff ( string $from , string $to ) : string
public merge ( string $src , string $diff ) : string
/* 继承的方法 */
public XMLDiff\Base::__construct ( string $nsname )
abstract public XMLDiff\Base::diff ( mixed $from , mixed $to ) : mixed
abstract public XMLDiff\Base::merge ( mixed $src , mixed $diff ) : mixed
}

Table of Contents

  • XMLDiff\Memory::diff — Diff two XML documents
  • XMLDiff\Memory::merge — Produce merged XML document


Diff two XML documents

  • ? XMLDiff\Memory
  • XMLDiff\Memory::merge ?
  • PHP Manual
  • XMLDiff\Memory
  • Diff two XML documents

XMLDiff\Memory::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\Memory::diff — Diff two XML documents

说明

public XMLDiff\Memory::diff ( string $from , string $to ) : string

Diff two strings containing XML documents and produce the diff information.

参数

from

Source XML document.

to

Target XML document.

返回值

String with the XML document containing the diff information or NULL.


Produce merged XML document

  • ? XMLDiff\Memory::diff
  • XMLDiff\File ?
  • PHP Manual
  • XMLDiff\Memory
  • Produce merged XML document

XMLDiff\Memory::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\Memory::merge — Produce merged XML document

说明

public XMLDiff\Memory::merge ( string $src , string $diff ) : string

Create new XML document based on diffs and source document.

参数

src

Source XML document.

diff

XML document containing diff information.

返回值

String with the new XML document or NULL.


The XMLDiff\File class

(PECL xmldiff >= 0.8.0)

简介

类摘要

XMLDiff\File extends XMLDiff\Base {
/* 方法 */
public diff ( string $from , string $to ) : string
public merge ( string $src , string $diff ) : string
/* 继承的方法 */
public XMLDiff\Base::__construct ( string $nsname )
abstract public XMLDiff\Base::diff ( mixed $from , mixed $to ) : mixed
abstract public XMLDiff\Base::merge ( mixed $src , mixed $diff ) : mixed
}

Table of Contents

  • XMLDiff\File::diff — Diff two XML files
  • XMLDiff\File::merge — Produce merged XML document


Diff two XML files

  • ? XMLDiff\File
  • XMLDiff\File::merge ?
  • PHP Manual
  • XMLDiff\File
  • Diff two XML files

XMLDiff\File::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\File::diff — Diff two XML files

说明

public XMLDiff\File::diff ( string $from , string $to ) : string

Diff two local XML files and produce string with the diff information.

参数

from

Path to the source document.

to

Path to the target document.

返回值

String with the XML document containing the diff information or NULL.


Produce merged XML document

  • ? XMLDiff\File::diff
  • XML 解析器 ?
  • PHP Manual
  • XMLDiff\File
  • Produce merged XML document

XMLDiff\File::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\File::merge — Produce merged XML document

说明

public XMLDiff\File::merge ( string $src , string $diff ) : string

Create new XML document based on diffs and source document.

参数

src

Path to the source XML document.

diff

Path to the XML document with the diff information.

返回值

String with the new XML document or NULL.


XML 解析器

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 事件处理器
  • Case Folding(大写转换)
  • 错误代码
  • 字符编码
  • 范例
    • XML 元素结构例程
    • XML 标签映射例程
    • XML 外部实体例程
  • XML 解析器函数
    • utf8_decode — 将用 UTF-8 方式编码的 ISO-8859-1 字符串转换成单字节的 ISO-8859-1 字符串。
    • utf8_encode — 将 ISO-8859-1 编码的字符串转换为 UTF-8 编码
    • xml_error_string — 获取 XML 解析器的错误字符串
    • xml_get_current_byte_index — 获取 XML 解析器的当前字节索引
    • xml_get_current_column_number — 获取 XML 解析器的当前列号
    • xml_get_current_line_number — 获取 XML 解析器的当前行号
    • xml_get_error_code — 获取 XML 解析器错误代码
    • xml_parse_into_struct — 将 XML 数据解析到数组中
    • xml_parse — 开始解析一个 XML 文档
    • xml_parser_create_ns — 生成一个支持命名空间的 XML 解析器
    • xml_parser_create — 建立一个 XML 解析器
    • xml_parser_free — 释放指定的 XML 解析器
    • xml_parser_get_option — 从 XML 解析器获取选项设置信息
    • xml_parser_set_option — 为指定 XML 解析进行选项设置
    • xml_set_character_data_handler — 建立字符数据处理器
    • xml_set_default_handler — 建立默认处理器
    • xml_set_element_handler — 建立起始和终止元素处理器
    • xml_set_end_namespace_decl_handler — 建立终止命名空间声明处理器
    • xml_set_external_entity_ref_handler — 建立外部实体指向处理器
    • xml_set_notation_decl_handler — 建立注释声明处理器
    • xml_set_object — 在对象中使用 XML 解析器
    • xml_set_processing_instruction_handler — 建立处理指令（PI）处理器
    • xml_set_start_namespace_decl_handler — 建立起始命名空间声明处理器
    • xml_set_unparsed_entity_decl_handler — 建立未解析实体定义声明处理器


简介

XML(可扩展标记语言，eXtensible Markup Language) 是一种在互联网上用于结构化文档交互的数据格式。 它是互联网协会(W3C)定义的一个标准。与 XML 及其相关技术的信息可访问 » http://www.w3.org/XML/。

此 PHP 扩展实现 支持 James Clark 使用 PHP 编写的 expat。 此工具包可解析(但不能验证) XML 文档。它支持 PHP 所提供的 3 种字符编码： US-ASCII, ISO-8859-1 和 UTF-8。 不支持 UTF-16。

此扩展可 创建 XML 解析器 并为不同的 XML 事件定义 处理程序(handler)。 每个 XML 解析器还存在少数可以调节的 参数。


需求

此扩展需要 libxml PHP 扩展。这表示需要使用 --with-libxml，或在 PHP 7.4 之前的版本中使用 --enable-libxml， 尽管这将隐式完成因为 libxml 是缺省开启的。

缺省情况下，此扩展使用expat compat layer 。也可使用expat， 此库位于 » http://www.jclark.com/xml/expat.html。 使用expat库中的 Makefile 是不会默认构建出库文件的，可使用以下构建规则进行构建：

libexpat.a: $(OBJS)
    ar -rc $@ $(OBJS)
    ranlib $@
expat 的源代码 RPM 安装包可在 » http://sourceforge.net/projects/expat/ 找到。


安装

此扩展默认为启用，编译时可通过下列选项禁用： --disable-xml

这些函数默认为有效的，使用了捆绑的 expat 库。您可以通过参数 --disable-xml 来屏蔽 XML 的支持。如果您将 PHP 编译为 Apache 1.3.9 或更高版本的一个模块， PHP 将自动使用 Apache 捆绑的 expat 库。如果您不希望使用该捆绑的 expat 库，请在运行 PHP 的 configure 配置脚本时使用参数 --with-expat-dir=DIR，其中 DIR 应该指向 expat 安装的根目录。

PHP 的 Windows 版本已内建对此扩展的支持。不需要载入额外的扩展来使用这些函数。


资源类型

xml_parser_create() 与 xml_parser_create_ns() 返回的 XML 资源会引用 XML 解析器实例，以被此扩展提供的函数使用。


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

XML_ERROR_NONE (integer)
XML_ERROR_NO_MEMORY (integer)
XML_ERROR_SYNTAX (integer)
XML_ERROR_NO_ELEMENTS (integer)
XML_ERROR_INVALID_TOKEN (integer)
XML_ERROR_UNCLOSED_TOKEN (integer)
XML_ERROR_PARTIAL_CHAR (integer)
XML_ERROR_TAG_MISMATCH (integer)
XML_ERROR_DUPLICATE_ATTRIBUTE (integer)
XML_ERROR_JUNK_AFTER_DOC_ELEMENT (integer)
XML_ERROR_PARAM_ENTITY_REF (integer)
XML_ERROR_UNDEFINED_ENTITY (integer)
XML_ERROR_RECURSIVE_ENTITY_REF (integer)
XML_ERROR_ASYNC_ENTITY (integer)
XML_ERROR_BAD_CHAR_REF (integer)
XML_ERROR_BINARY_ENTITY_REF (integer)
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF (integer)
XML_ERROR_MISPLACED_XML_PI (integer)
XML_ERROR_UNKNOWN_ENCODING (integer)
XML_ERROR_INCORRECT_ENCODING (integer)
XML_ERROR_UNCLOSED_CDATA_SECTION (integer)
XML_ERROR_EXTERNAL_ENTITY_HANDLING (integer)
XML_OPTION_CASE_FOLDING (integer)
XML_OPTION_TARGET_ENCODING (integer)
XML_OPTION_SKIP_TAGSTART (integer)
XML_OPTION_SKIP_WHITE (integer)
XML_SAX_IMPL (string)
指定 SAX 实现方法。可为 libxml 或 expat.


事件处理器

XML 事件处理器的定义如下：

被支持的 XML 处理器
PHP 处理器函数 | 事件描述
xml_set_element_handler() | 当 XML 解析器遇到开始或结束标签时，会触发元素事件。 开始标签和结束标签有不同的处理器。
xml_set_character_data_handler() | 字符数据范指 XML 文档中所有非标记的内容，包括标签之间的空格。 注意，XML 解析器不会添加或删除任何空格，由应用程序(你)来判断空格是否有意义。
xml_set_processing_instruction_handler() | PHP 程序员必须熟练掌握处理指令(PI)。<?php ?>是处理指令， 其中php被称为"处理指令对象"。 除所有以"XML"开头的处理指令对象是系统保留的外， 其他的处理函数均是由应用程序指定的。
xml_set_default_handler() | 不执行其他处理函数，则会执行缺省的处理函数。 在缺省的处理函数中可取得如 XML 和文档类型声明等信息。
xml_set_unparsed_entity_decl_handler() | 未解析的实体声明(NDATA)会调用此处理函数。
xml_set_notation_decl_handler() | 符号声明会调用此处理函数
xml_set_external_entity_ref_handler() | 当 XML 解析器发现对外部已解析的普通实体的引用时， 会调用此处理函数。例如，引用一个文件或URL。实例可参见 XML 外部实体例程。


Case Folding(大写转换)

元素处理函数可取得元素名称转换为 case-folded(大写字母)形式。 Case-folding 被定义为"将非大写字母替换为相对应的大写字母的字符串操作"。换句话说，在 XML 中，case-folding 就是转换为大写。

默认情况下，所有的通过处理函数的元素名都被转换为大写字母。每个 XML 解析器可分别通过xml_parser_get_option()与 xml_parser_set_option()函数来查询与控制此项功能。


错误代码

下列常量是 XML 相关的错误代码(xml_parse()函数的返回值):

  • XML_ERROR_NONE
  • XML_ERROR_NO_MEMORY
  • XML_ERROR_SYNTAX
  • XML_ERROR_NO_ELEMENTS
  • XML_ERROR_INVALID_TOKEN
  • XML_ERROR_UNCLOSED_TOKEN
  • XML_ERROR_PARTIAL_CHAR
  • XML_ERROR_TAG_MISMATCH
  • XML_ERROR_DUPLICATE_ATTRIBUTE
  • XML_ERROR_JUNK_AFTER_DOC_ELEMENT
  • XML_ERROR_PARAM_ENTITY_REF
  • XML_ERROR_UNDEFINED_ENTITY
  • XML_ERROR_RECURSIVE_ENTITY_REF
  • XML_ERROR_ASYNC_ENTITY
  • XML_ERROR_BAD_CHAR_REF
  • XML_ERROR_BINARY_ENTITY_REF
  • XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF
  • XML_ERROR_MISPLACED_XML_PI
  • XML_ERROR_UNKNOWN_ENCODING
  • XML_ERROR_INCORRECT_ENCODING
  • XML_ERROR_UNCLOSED_CDATA_SECTION
  • XML_ERROR_EXTERNAL_ENTITY_HANDLING


字符编码

PHP 的 XML 扩展通过几种不同的字符编码支持» Unicode 字符集。 有两类字符编码， 原始编码 和 目标编码. 在PHP的内部展现中，文档始终是使用UTF-8编码。

当 XML 被 解析 后，原始编码就完成了。 在创建 XML 解析器时, 可以指定原始编码(在XML 解析器此后的生命周期里，不能修改此编码)。 被支持的原始编码有 ISO-8859-1, US-ASCII 和 UTF-8. 前两种是单字节编码, 即每一个字符表现为一个字节。 UTF-8 可将字符编码为一串不定数量(最高21)的位(bit), 排列成1到4个字节。 PHP 中使用的默认原始编码是ISO-8859-1.

当 PHP 将数据传给 XML 处理函数时，目标编码就完成了。 在创建 XML 处理器时，目标编码被设定为与原始编码相同，但可任意修改。 目标编码会影响字符数据及标签名，与处理指令目标。

如 XML 解析器遇到原始编码所能表示的范围之外的字符时，会返回一个错误。

如 PHP 遇到在被解析的 XML 文档中不能用所指定的目标编码表示的字符时， 这个问题字符会被"降级"。通常来说，就是那些字符会被替换成问号(?)。


范例

Table of Contents

  • XML 元素结构例程
  • XML 标签映射例程
  • XML 外部实体例程


XML 元素结构例程

第一个例程缩进显示文档中的开始元素结构。

Example #1 显示 XML 元素结构

<?php
$file = "data.xml";
$depth = array();

function startElement($parser, $name, $attrs)
{
    global $depth;
    for ($i = 0; $i < $depth[$parser]; $i++) {
        echo "  ";
    }
    echo "$name\n";
    $depth[$parser]++;
}

function endElement($parser, $name)
{
    global $depth;
    $depth[$parser]--;
}

$xml_parser = xml_parser_create();
xml_set_element_handler($xml_parser, "startElement", "endElement");
if (!($fp = fopen($file, "r"))) {
    die("could not open XML input");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>


XML 标签映射例程

Example #1 将 XML 映射为 HTML

此例程直接地将 XML 标签映射为 HTML 标签。 在"map_array"中未找到的元素将被忽略。 当然，此例程只针对特定的 XML 文档类型起作用。

<?php
$file = "data.xml";
$map_array = array(
    "BOLD"     => "B",
    "EMPHASIS" => "I",
    "LITERAL"  => "TT"
);

function startElement($parser, $name, $attrs)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "<$map_array[$name]>";
    }
}

function endElement($parser, $name)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "</$map_array[$name]>";
    }
}

function characterData($parser, $data)
{
    echo $data;
}

$xml_parser = xml_parser_create();
// use case-folding so we are sure to find the tag in $map_array
xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, true);
xml_set_element_handler($xml_parser, "startElement", "endElement");
xml_set_character_data_handler($xml_parser, "characterData");
if (!($fp = fopen($file, "r"))) {
    die("could not open XML input");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>


XML 外部实体例程

此例程用于加亮 XML 代码。举例说明如何使用外部实体引用来包含和解析其他文档， 及处理指令是如何被处理的，及判断处理指令所包含代码是否"可信任"的一种方法

用于此例程的 XML 文档位于此例程的下方(xmltest.xml 和 xmltest2.xml)。

Example #1 外部实体例程

<?php
$file = "xmltest.xml";

function trustedFile($file)
{
    // 仅信任本地文件
    if (!preg_match("@^([a-z]+)\:\/\/@i", $file)
        && fileowner($file) == getmyuid()) {
            return true;
    }
    return false;
}

function startElement($parser, $name, $attribs)
{
    echo "&lt;<font color=\"#0000cc\">$name</font>";
    if (count($attribs)) {
        foreach ($attribs as $k => $v) {
            echo " <font color=\"#009900\">$k</font>=\"<font
                   color=\"#990000\">$v</font>\"";
        }
    }
    echo "&gt;";
}

function endElement($parser, $name)
{
    echo "&lt;/<font color=\"#0000cc\">$name</font>&gt;";
}

function characterData($parser, $data)
{
    echo "<b>$data</b>";
}

function PIHandler($parser, $target, $data)
{
    switch (strtolower($target)) {
        case "php":
            global $parser_file;
            // 如何要解析的文档是"可信任"的, 则说明可安全
            // 地执行其内部的 PHP 代码。否则，显示代码内容。
            if (trustedFile($parser_file[$parser])) {
                eval($data);
            } else {
                printf("Untrusted PHP code: <i>%s</i>",
                        htmlspecialchars($data));
            }
            break;
    }
}

function defaultHandler($parser, $data)
{
    if (substr($data, 0, 1) == "&" && substr($data, -1, 1) == ";") {
        printf('<font color="#aa00aa">%s</font>',
                htmlspecialchars($data));
    } else {
        printf('<font size="-1">%s</font>',
                htmlspecialchars($data));
    }
}

function externalEntityRefHandler($parser, $openEntityNames, $base, $systemId,
                                  $publicId) {
    if ($systemId) {
        if (!list($parser, $fp) = new_xml_parser($systemId)) {
            printf("Could not open entity %s at %s\n", $openEntityNames,
                   $systemId);
            return false;
        }
        while ($data = fread($fp, 4096)) {
            if (!xml_parse($parser, $data, feof($fp))) {
                printf("XML error: %s at line %d while parsing entity %s\n",
                       xml_error_string(xml_get_error_code($parser)),
                       xml_get_current_line_number($parser), $openEntityNames);
                xml_parser_free($parser);
                return false;
            }
        }
        xml_parser_free($parser);
        return true;
    }
    return false;
}

function new_xml_parser($file)
{
    global $parser_file;

    $xml_parser = xml_parser_create();
    xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, 1);
    xml_set_element_handler($xml_parser, "startElement", "endElement");
    xml_set_character_data_handler($xml_parser, "characterData");
    xml_set_processing_instruction_handler($xml_parser, "PIHandler");
    xml_set_default_handler($xml_parser, "defaultHandler");
    xml_set_external_entity_ref_handler($xml_parser, "externalEntityRefHandler");

    if (!($fp = @fopen($file, "r"))) {
        return false;
    }
    if (!is_array($parser_file)) {
        settype($parser_file, "array");
    }
    $parser_file[$xml_parser] = $file;
    return array($xml_parser, $fp);
}

if (!(list($xml_parser, $fp) = new_xml_parser($file))) {
    die("could not open XML input");
}

echo "<pre>";
while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d\n",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
echo "</pre>";
echo "parse complete\n";
xml_parser_free($xml_parser);

?>

Example #2 xmltest.xml

<?xml version='1.0'?>
<!DOCTYPE chapter SYSTEM "/just/a/test.dtd" [
<!ENTITY plainEntity "FOO entity">
<!ENTITY systemEntity SYSTEM "xmltest2.xml">
]>
<chapter>
 <TITLE>Title &plainEntity;</TITLE>
 <para>
  <informaltable>
   <tgroup cols="3">
    <tbody>
     <row><entry>a1</entry><entry morerows="1">b1</entry><entry>c1</entry></row>
     <row><entry>a2</entry><entry>c2</entry></row>
     <row><entry>a3</entry><entry>b3</entry><entry>c3</entry></row>
    </tbody>
   </tgroup>
  </informaltable>
 </para>
 &systemEntity;
 <section id="about">
  <title>About this Document</title>
  <para>
   <!-- this is a comment -->
   <?php echo 'Hi!  This is PHP version ' . phpversion(); ?>
  </para>
 </section>
</chapter>

此文件包含在 xmltest.xml 中:

Example #3 xmltest2.xml

<?xml version="1.0"?>
<!DOCTYPE foo [
<!ENTITY testEnt "test entity">
]>
<foo>
   <element attrib="value"/>
   &testEnt;
   <?php echo "This is some more PHP code being executed."; ?>
</foo>


XML 解析器函数

Table of Contents

  • utf8_decode — 将用 UTF-8 方式编码的 ISO-8859-1 字符串转换成单字节的 ISO-8859-1 字符串。
  • utf8_encode — 将 ISO-8859-1 编码的字符串转换为 UTF-8 编码
  • xml_error_string — 获取 XML 解析器的错误字符串
  • xml_get_current_byte_index — 获取 XML 解析器的当前字节索引
  • xml_get_current_column_number — 获取 XML 解析器的当前列号
  • xml_get_current_line_number — 获取 XML 解析器的当前行号
  • xml_get_error_code — 获取 XML 解析器错误代码
  • xml_parse_into_struct — 将 XML 数据解析到数组中
  • xml_parse — 开始解析一个 XML 文档
  • xml_parser_create_ns — 生成一个支持命名空间的 XML 解析器
  • xml_parser_create — 建立一个 XML 解析器
  • xml_parser_free — 释放指定的 XML 解析器
  • xml_parser_get_option — 从 XML 解析器获取选项设置信息
  • xml_parser_set_option — 为指定 XML 解析进行选项设置
  • xml_set_character_data_handler — 建立字符数据处理器
  • xml_set_default_handler — 建立默认处理器
  • xml_set_element_handler — 建立起始和终止元素处理器
  • xml_set_end_namespace_decl_handler — 建立终止命名空间声明处理器
  • xml_set_external_entity_ref_handler — 建立外部实体指向处理器
  • xml_set_notation_decl_handler — 建立注释声明处理器
  • xml_set_object — 在对象中使用 XML 解析器
  • xml_set_processing_instruction_handler — 建立处理指令（PI）处理器
  • xml_set_start_namespace_decl_handler — 建立起始命名空间声明处理器
  • xml_set_unparsed_entity_decl_handler — 建立未解析实体定义声明处理器


将用 UTF-8 方式编码的 ISO-8859-1 字符串转换成单字节的 ISO-8859-1 字符串。

  • ? XML 解析器函数
  • utf8_encode ?
  • PHP Manual
  • XML 解析器函数
  • 将用 UTF-8 方式编码的 ISO-8859-1 字符串转换成单字节的 ISO-8859-1 字符串。

utf8_decode

(PHP 4, PHP 5, PHP 7, PHP 8)

utf8_decode — 将用 UTF-8 方式编码的 ISO-8859-1 字符串转换成单字节的 ISO-8859-1 字符串。

描述

utf8_decode ( string $data ) : string

该函数将用 UTF-8 编码的数据解码为 ISO-8859-1 编码。

请参阅 utf8_encode() 以查看关于 UTF-8 编码的解释。


将 ISO-8859-1 编码的字符串转换为 UTF-8 编码

  • ? utf8_decode
  • xml_error_string ?
  • PHP Manual
  • XML 解析器函数
  • 将 ISO-8859-1 编码的字符串转换为 UTF-8 编码

utf8_encode

(PHP 4, PHP 5, PHP 7, PHP 8)

utf8_encode — 将 ISO-8859-1 编码的字符串转换为 UTF-8 编码

描述

utf8_encode ( string $data ) : string

该函数将 data 字符串转换为 UTF-8 编码，并返回编码后的字符串。UTF-8 是一种用于将宽字符值转换为字节流的 Unicode 的标准机制。UTF-8 对于纯 ASCII 字符来说是透明的，且是自同步的（也就是说这使得程序能够得知字符从字节流的何处开始），并可被普通字符串比较函数用以比较等操作。PHP 可将 UTF-8 编码为多达四个字节的字符，如：

UTF-8 编码
字节（bytes） | 位（bits） | 表 示
1 | 7 | 0bbbbbbb
2 | 11 | 110bbbbb 10bbbbbb
3 | 16 | 1110bbbb 10bbbbbb 10bbbbbb
4 | 21 | 11110bbb 10bbbbbb 10bbbbbb 10bbbbbb

每个 UTF-8 表示一个能被用以储存字符数据的位。


获取 XML 解析器的错误字符串

  • ? utf8_encode
  • xml_get_current_byte_index ?
  • PHP Manual
  • XML 解析器函数
  • 获取 XML 解析器的错误字符串

xml_error_string

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_error_string — 获取 XML 解析器的错误字符串

说明

xml_error_string ( int $code ) : string

根据给定的 code 获得 XML 解析器错误字符串。

参数

code

由 xml_get_error_code() 返回的错误代码。

返回值

返回与 code 描述的错误代码参数对应的文本描述字符串，若没有与之对应的描述，则返回 false。

参见

  • xml_get_error_code() - 获取 XML 解析器错误代码


获取 XML 解析器的当前字节索引

  • ? xml_error_string
  • xml_get_current_column_number ?
  • PHP Manual
  • XML 解析器函数
  • 获取 XML 解析器的当前字节索引

xml_get_current_byte_index

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_get_current_byte_index — 获取 XML 解析器的当前字节索引

说明

xml_get_current_byte_index ( resource $parser ) : int

获取指定的 XML 解析器的当前字节索引（current byte index）。

参数

parser

指向要取得字节索引的 XML 解析器的引用。

返回值

如果 parser 没有指向一个合法的解析器，该函数将返回 false，否则将返回解析器当前在其数据缓冲区中的字节索引（起始值为 0）。

注释

Warning

该函数将返回根据UTF-8编码的文本的字节索引，而不论输入是否是其他的编码。

参见

  • xml_get_current_column_index()
  • xml_get_current_line_index()


获取 XML 解析器的当前列号

  • ? xml_get_current_byte_index
  • xml_get_current_line_number ?
  • PHP Manual
  • XML 解析器函数
  • 获取 XML 解析器的当前列号

xml_get_current_column_number

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_get_current_column_number — 获取 XML 解析器的当前列号

说明

xml_get_current_column_number ( resource $parser ) : int

获得指定 XML 解析器当前的列号。

参数

parser

一个指向要获取列号的 XML 解析器的指针。

返回值

如果 parser 参数没有指向一个合法的解析器，该函数将返回 false，否则将返回指定解析器所在行（由函数 xml_get_current_line_number() 给定）的当前列号。

参见

  • xml_get_current_byte_index() - 获取 XML 解析器的当前字节索引
  • xml_get_current_line_index()


获取 XML 解析器的当前行号

  • ? xml_get_current_column_number
  • xml_get_error_code ?
  • PHP Manual
  • XML 解析器函数
  • 获取 XML 解析器的当前行号

xml_get_current_line_number

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_get_current_line_number — 获取 XML 解析器的当前行号

说明

xml_get_current_line_number ( resource $parser ) : int

获取指定 XML 解析器当前的行号。

参数

parser

一个指向要获取当前行号的 XML 解析器的指针。

返回值

如果 parser 参数没有指向一个合法的解析器，该函数将返回 false，否则将返回指定解析器在其缓存中的当前行号。

参见

  • xml_get_current_column_index()
  • xml_get_current_byte_index() - 获取 XML 解析器的当前字节索引


获取 XML 解析器错误代码

  • ? xml_get_current_line_number
  • xml_parse_into_struct ?
  • PHP Manual
  • XML 解析器函数
  • 获取 XML 解析器错误代码

xml_get_error_code

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_get_error_code — 获取 XML 解析器错误代码

说明

xml_get_error_code ( resource $parser ) : int

获取 XML 解析器错误代码。

参数

parser

一个指向要返回错误代码的 XML 解析器的指针

返回值

如果 parser 参数没有指向一个合法的解析器，该函数将返回 false，否则将返回错误代码列表中的一个错误代码。

参见

  • xml_error_string() - 获取 XML 解析器的错误字符串


将 XML 数据解析到数组中

  • ? xml_get_error_code
  • xml_parse ?
  • PHP Manual
  • XML 解析器函数
  • 将 XML 数据解析到数组中

xml_parse_into_struct

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parse_into_struct — 将 XML 数据解析到数组中

说明

xml_parse_into_struct ( resource $parser , string $data , array &$values , array &$index = ? ) : int

该函数将 XML 文件解析到两个对应的数组中，index 参数含有指向 values 数组中对应值的指针。最后两个数组参数可由指针传递给函数。

Note:

xml_parse_into_struct() 失败返回 0，成功返回 1。这和 false 与 true 不同，使用例如 === 的运算符时要注意。

以下范例显示了由该函数生成的数组的内部结构。我们简单地将一个 note 嵌入到一个 para 标记中，解析后我们可以打印出生成的数组的结构：

Example #1 xml_parse_into_struct() 示例

<?php
$simple = "<para><note>simple note</note></para>";
$p = xml_parser_create();
xml_parse_into_struct($p, $simple, $vals, $index);
xml_parser_free($p);
echo "Index array\n";
print_r($index);
echo "\nVals array\n";
print_r($vals);
?>

运行以上代码，我们得到的输出将是：

Index array
Array
(
    [PARA] => Array
        (
            [0] => 0
            [1] => 2
        )

    [NOTE] => Array
        (
            [0] => 1
        )

)

Vals array
Array
(
    [0] => Array
        (
            [tag] => PARA
            [type] => open
            [level] => 1
        )

    [1] => Array
        (
            [tag] => NOTE
            [type] => complete
            [level] => 2
            [value] => simple note
        )

    [2] => Array
        (
            [tag] => PARA
            [type] => close
            [level] => 1
        )

)

如果您的 XML 文档很复杂，基于该文档的事件处理（Event-driven）解析（基于 expat 扩展库）也会对应的变得复杂。该函数生成的并非 DOM 风格的对象，而是横向的树状结构。因此，我们能够方便的建立表达 XML 文件数据的对象。我们假设以下 XML 文件表示一个关于氨基酸信息的小型数据库：

Example #2 moldb.xml - 分子信息的小型数据库

<?xml version="1.0"?>
<moldb>

    <molecule>
        <name>Alanine</name>
        <symbol>ala</symbol>
        <code>A</code>
        <type>hydrophobic</type>
    </molecule>

    <molecule>
        <name>Lysine</name>
        <symbol>lys</symbol>
        <code>K</code>
        <type>charged</type>
    </molecule>

</moldb>
以下是解析该文档并生成相应对象的代码：

Example #3 parsemoldb.php - 将 moldb.xml 解析到分子（molecular）对象的数组中

<?php

class AminoAcid {
    var $name;  // aa 姓名
    var $symbol;    // 三字母符号
    var $code;  // 单字母代码
    var $type;  // hydrophobic, charged 或 neutral

    function AminoAcid ($aa)
    {
        foreach ($aa as $k=>$v)
            $this->$k = $aa[$k];
    }
}

function readDatabase($filename)
{
    // 读取 aminoacids 的 XML 数据
    $data = implode("",file($filename));
    $parser = xml_parser_create();
    xml_parser_set_option($parser, XML_OPTION_CASE_FOLDING, 0);
    xml_parser_set_option($parser, XML_OPTION_SKIP_WHITE, 1);
    xml_parse_into_struct($parser, $data, $values, $tags);
    xml_parser_free($parser);

    // 遍历 XML 结构
    foreach ($tags as $key=>$val) {
        if ($key == "molecule") {
            $molranges = $val;
            // each contiguous pair of array entries are the
            // lower and upper range for each molecule definition
            for ($i=0; $i < count($molranges); $i+=2) {
                $offset = $molranges[$i] + 1;
                $len = $molranges[$i + 1] - $offset;
                $tdb[] = parseMol(array_slice($values, $offset, $len));
            }
        } else {
            continue;
        }
    }
    return $tdb;
}

function parseMol($mvalues)
{
    for ($i=0; $i < count($mvalues); $i++) {
        $mol[$mvalues[$i]["tag"]] = $mvalues[$i]["value"];
    }
    return new AminoAcid($mol);
}

$db = readDatabase("moldb.xml");
echo "** Database of AminoAcid objects:\n";
print_r($db);

?>
在执行完 parsemoldb.php 后，变量 $db 将包含有一个由 AminoAcid 对象组成的数组，该脚本的输出如下：
** Database of AminoAcid objects:
Array
(
    [0] => aminoacid Object
        (
            [name] => Alanine
            [symbol] => ala
            [code] => A
            [type] => hydrophobic
        )

    [1] => aminoacid Object
        (
            [name] => Lysine
            [symbol] => lys
            [code] => K
            [type] => charged
        )

)


开始解析一个 XML 文档

  • ? xml_parse_into_struct
  • xml_parser_create_ns ?
  • PHP Manual
  • XML 解析器函数
  • 开始解析一个 XML 文档

xml_parse

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parse — 开始解析一个 XML 文档

说明

xml_parse ( resource $parser , string $data , bool $is_final = false ) : int

xml_parse() 解析 XML 文档。已配置事件的处理器根据需要被无限次调用。

参数

parser

一个指向将要使用的 XML 解析器的指针

data

需要解析的数据集。您可以多次对新的数据调用 xml_parse() 函数来分段解析一个文档；只要在解析最后一段数据时将 is_final 参数设置为 true。

is_final

如果被设置为 true，则 data 为当前解析中最后一段数据。

返回值

成功时返回1，失败时返回0

若解析失败，可以使用如下函数获取错误信息：
xml_get_error_code(),
xml_error_string(),
xml_get_current_line_number(),
xml_get_current_column_number() 和
xml_get_current_byte_index()。

Note:

将 is_final 参数设置为 true，项目的错误将会报告在数据的末尾。


生成一个支持命名空间的 XML 解析器

  • ? xml_parse
  • xml_parser_create ?
  • PHP Manual
  • XML 解析器函数
  • 生成一个支持命名空间的 XML 解析器

xml_parser_create_ns

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

xml_parser_create_ns — 生成一个支持命名空间的 XML 解析器

描述

xml_parser_create_ns ( string $encoding = ? , string $sep = ? ) : resource

函数 xml_parser_create_ns() 建立一个新的支持 XML 命名空间的解析器并返回可被其它 XML 函数使用的资源句柄。

通过有命名空间支持的解析器，传递给各种各样句柄函数的标签参数将由命名空间和标签名组成。命名空间和标签名的分隔符由 seperator 参数制定的字符串决定，其默认值为":"。

可选参数 encoding 在 PHP 4 中用来指定要被解析的 XML 输入的字符编码方式。PHP 5 开始，自动侦测输入的 XML 的编码，因此 encoding 参数仅用来指定解析后输出数据的编码。在 PHP 4 总，默认输出的编码与输入数据的编码是相同的。如果传递了空字符串，解析器会尝试搜索头 3 或 4 个字节以确定文档的编码。在 PHP 5.0.0 和 5.0.1 总，默认输出的字符编码是 ISO-8859-1，而 PHP 5.0.2 及以上版本是 UTF-8。解析器支持的编码有 ISO-8859-1, UTF-8 和 US-ASCII。

请参阅函数 xml_parser_create() 和 xml_parser_free()。


建立一个 XML 解析器

  • ? xml_parser_create_ns
  • xml_parser_free ?
  • PHP Manual
  • XML 解析器函数
  • 建立一个 XML 解析器

xml_parser_create

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parser_create — 建立一个 XML 解析器

描述

xml_parser_create ( string $encoding = ? ) : resource

函数 xml_parser_create() 建立一个新的 XML 解析器并返回可被其它 XML 函数使用的资源句柄。

可选参数 encoding 在 PHP 4 中用来指定要被解析的 XML 输入的字符编码方式。PHP 5 开始，自动侦测输入的 XML 的编码，因此 encoding 参数仅用来指定解析后输出数据的编码。在 PHP 4 总，默认输出的编码与输入数据的编码是相同的。如果传递了空字符串，解析器会尝试搜索头 3 或 4 个字节以确定文档的编码。在 PHP 5.0.0 和 5.0.1 总，默认输出的字符编码是 ISO-8859-1，而 PHP 5.0.2 及以上版本是 UTF-8。解析器支持的编码有 ISO-8859-1, UTF-8 和 US-ASCII。

请参阅函数 xml_parser_create_ns() 和 xml_parser_free()。


释放指定的 XML 解析器

  • ? xml_parser_create
  • xml_parser_get_option ?
  • PHP Manual
  • XML 解析器函数
  • 释放指定的 XML 解析器

xml_parser_free

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parser_free — 释放指定的 XML 解析器

描述

xml_parser_free ( resource $parser ) : bool

parser
指向要释放的 XML 解析器的指针。

如果 parser 参数没有指向一个合法的解析器，该函数将返回 false，否则将释放指定的解析器并返回 true。


从 XML 解析器获取选项设置信息

  • ? xml_parser_free
  • xml_parser_set_option ?
  • PHP Manual
  • XML 解析器函数
  • 从 XML 解析器获取选项设置信息

xml_parser_get_option

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parser_get_option — 从 XML 解析器获取选项设置信息

描述

xml_parser_get_option ( resource $parser , int $option ) : mixed

parser
指向要获取设置信息的 XML 解析器的指针。
option
要获取的设置选项名称。可以使用 XML_OPTION_CASE_FOLDING 和 XML_OPTION_TARGET_ENCODING 常量。其说明见 xml_parser_set_option()。

如果 parser 参数没有指向一个合法的解析器或者 option 参数无效，该函数将返回 false（同时产生 E_WARNING 警告）。否则将返回指定设置选项的值。


为指定 XML 解析进行选项设置

  • ? xml_parser_get_option
  • xml_set_character_data_handler ?
  • PHP Manual
  • XML 解析器函数
  • 为指定 XML 解析进行选项设置

xml_parser_set_option

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_parser_set_option — 为指定 XML 解析进行选项设置

说明

xml_parser_set_option ( resource $parser , int $option , mixed $value ) : bool

parser
指向要设置选项信息的 XML 解析器的指针。
option
要设置的选项名称。请参考下文。
value
要给选项设置的新值。

如果 parser 参数没有指向一个合法的解析器或者指定的选项无法设置，该函数将返回 false，否则将会把选项设置为指定的值并返回 true。

可被设置的选项如下：

XML 解析器选项
选项常量 | 数据类型 | 描述
XML_OPTION_CASE_FOLDING | integer | 控制在该 XML 解析器中 大小写折叠（case-folding） 是否有效。其默认值为有效。
XML_OPTION_SKIP_TAGSTART | integer | 指明在一个标记名前应略过几个字符。
XML_OPTION_SKIP_WHITE | integer | 是否略过由白空字符组成的值。
XML_OPTION_TARGET_ENCODING | string | 设置该 XML 解析器所使用的目标编码（target encoding）方式。其默认值和由 xml_parser_create() 函数设置的源编码（source encoding）方式相同。支持的目标编码方式有 ISO-8859-1、US-ASCII 和 UTF-8。


建立字符数据处理器

  • ? xml_parser_set_option
  • xml_set_default_handler ?
  • PHP Manual
  • XML 解析器函数
  • 建立字符数据处理器

xml_set_character_data_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_character_data_handler — 建立字符数据处理器

说明

xml_set_character_data_handler ( resource $parser , callable $handler ) : bool

为 parser 变量指向的 XML 解析器指定字符数据处理函数。

参数

parser

XML 解析器的引用，用于建立字符数据处理器。

handler

handler 为表示一个函数名称的字符串，该函数必须在为 parser 指定的解析器调用 xml_parse() 函数时已存在。

由 handler 参数命名的函数名必须接受两个参数：

handler ( resource $parser , string $data )
parser
第一个参数 parser 为指向要调用处理器的 XML 解析器的指针。
data
第二个参数 data 为包含有字符数据的字符串。

Character data handler is called for every piece of a text in the XML document. It can be called multiple times inside each fragment (e.g. for non-ASCII strings).

如果处理器函数名被设置为空字符串或者 false，则该有问题的处理器将被屏蔽。

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

返回值

成功时返回 true， 或者在失败时返回 false。


建立默认处理器

  • ? xml_set_character_data_handler
  • xml_set_element_handler ?
  • PHP Manual
  • XML 解析器函数
  • 建立默认处理器

xml_set_default_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_default_handler — 建立默认处理器

说明

xml_set_default_handler ( resource $parser , callable $handler ) : bool

为 parser 指定的 XML 处理器建立默认处理函数。

参数

parser

XML 解析器的引用，用于建立默认处理器函数。

handler

handler 为表示一个函数名称的字符串，该函数必须在为 parser 指定的解析器调用 xml_parse() 函数时已存在。

由 handler 参数命名的函数名必须接受两个参数：

handler ( resource $parser , string $data )
parser
第一个参数 parser 为指向要调用处理器的 XML 解析器的指针。
data
第二个参数 data 为包含有字符数据的字符串。其内容可以是 XML 声明、文档类型声明、实体名或者其它没有已存在处理器的地数据。

如果处理器函数名被设置为空字符串或者 false，则该有问题的处理器将被屏蔽。

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

返回值

成功时返回 true， 或者在失败时返回 false。


建立起始和终止元素处理器

  • ? xml_set_default_handler
  • xml_set_end_namespace_decl_handler ?
  • PHP Manual
  • XML 解析器函数
  • 建立起始和终止元素处理器

xml_set_element_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_element_handler — 建立起始和终止元素处理器

说明

xml_set_element_handler ( resource $parser , callable $start_element_handler , callable $end_element_handler ) : bool

为 parser 参数指定的 XML 解析器建立元素处理器函数。参数 start_element_handler 和 end_element_handler 为表示函数名称的字符串，这些函数必须在为 parser 指定的解析器调用 xml_parse() 函数时已存在。

参数

parser

XML 解析器的引用，用于建立起始和终止元素处理器。

start_element_handler

由 start_element_handler 参数命名的函数名必须接受三个参数：

start_element_handler ( resource $parser , string $name , array $attribs )
parser
第一个参数 parser 为指向要调用处理器的 XML 解析器的指针。
name
第二个参数 name 为该处理器为之被调用的元素名。如果大小写折叠（case-folding）对该解析器有效，元素名将用大写字母表示。
attribs
第三个参数 attribs 为一个包含有对应元素的属性的数组（如果该元素有属性）。数组元素的下标为属性名，元素的值即为属性的值。属性名将以和元素名同样的标准进行大小写折叠（case-folded），其值不进行大小写折叠。 属性的原始顺序将会被参数保留，用 each() 函数遍历 attribs 时，该数组下表的顺序和属性的顺序相同。

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

end_element_handler

由 end_element_handler 参数命名的函数名必须接受两个参数：

end_element_handler ( resource $parser , string $name )
parser
第一个参数 parser 为指向要调用处理器的 XML 解析器的指针。
name
第二个参数 name 为该处理器为之被调用的元素名。如果大小写折叠（case-folding）对该解析器有效，元素名将用大写字母表示。

如果处理器函数名被设置为空字符串或者 false，则该有问题的处理器将被屏蔽。

返回值

成功时返回 true， 或者在失败时返回 false。


建立终止命名空间声明处理器

  • ? xml_set_element_handler
  • xml_set_external_entity_ref_handler ?
  • PHP Manual
  • XML 解析器函数
  • 建立终止命名空间声明处理器

xml_set_end_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

xml_set_end_namespace_decl_handler — 建立终止命名空间声明处理器

说明

xml_set_end_namespace_decl_handler ( resource $parser , callable $handler ) : bool

Set a handler to be called when leaving the scope of a namespace declaration. This will be called, for each namespace declaration, after the handler for the end tag of the element in which the namespace was declared.

参数

parser

A reference to the XML parser.

handler

handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept two parameters, and should return an integer value. If the value returned from the handler is false (which it will be if no value is returned), the XML parser will stop parsing and xml_get_error_code() will return XML_ERROR_EXTERNAL_ENTITY_HANDLING.

handler ( resource $parser , string $prefix )
parser
The first parameter, parser, is a reference to the XML parser calling the handler.
prefix
The prefix is a string used to reference the namespace within an XML object.

If a handler function is set to an empty string, or false, the handler in question is disabled.

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

返回值

成功时返回 true， 或者在失败时返回 false。

注释

Note:

This event is not supported under LibXML.

参见

  • xml_set_start_namespace_decl_handler() - 建立起始命名空间声明处理器


建立外部实体指向处理器

  • ? xml_set_end_namespace_decl_handler
  • xml_set_notation_decl_handler ?
  • PHP Manual
  • XML 解析器函数
  • 建立外部实体指向处理器

xml_set_external_entity_ref_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_external_entity_ref_handler — 建立外部实体指向处理器

说明

xml_set_external_entity_ref_handler ( resource $parser , callable $handler ) : bool

为 parser 参数指定的 XML 解析器建立外部实体指向处理器函数。

参数

parser

XML 解析器的引用，用于建立外部实体指向处理器。

handler

参数 handler 为表示函数名称的字符串，函数必须在为 parser 指定的解析器调用 xml_parse() 函数时已存在。

由 handler 参数命名的函数名必须接受五个参数，并应该返回一个整型值。如果处理器的返回值为 false（这也是函数没有确定返回值时的返回值），XML 解析器将停止解析， xml_get_error_code() 函数将返回 XML_ERROR_EXTERNAL_ENTITY_HANDLING。

handler ( resource $parser , string $open_entity_names , string $base , string $system_id , string $public_id )
parser
第一个参数 parser 为指向要调用处理器的 XML 解析器的指针。
open_entity_names
第二个参数 open_entity_names 是为该实体的解析开放的实体名列表（包括被指向的实体名），这些实体名由空格隔开。
base
这个参数是解析外部实体的系统标识符（system_id）的基础。当前该参数通常都被设置为空字符串。
system_id
第四个参数 system_id 是在实体定义声明中指定的系统标识符。
public_id
第五个参数 public_id 是在实体定义声明中指定的公共标识符，如果未指定任何标识符，则该字符串为空。公共标识符中的空格将按照 XML 的要求被正常化。

如果处理器函数名被设置为空字符串或者 false，则该有问题的处理器将被屏蔽。

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

返回值

成功时返回 true， 或者在失败时返回 false。


建立注释声明处理器

  • ? xml_set_external_entity_ref_handler
  • xml_set_object ?
  • PHP Manual
  • XML 解析器函数
  • 建立注释声明处理器

xml_set_notation_decl_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_notation_decl_handler — 建立注释声明处理器

说明

xml_set_notation_decl_handler ( resource $parser , callable $handler ) : bool

为 parser 参数指定的 XML 解析器建立注释声明处理器函数。

注释声明是文档 DTD 的一部分，并有如下格式：

<!NOTATION <parameter>name</parameter>
{<parameter>system_id</parameter> | <parameter>public_id</parameter>}?>
。请参考 » XML 1.0 参考的第 4.7 节以了解注释声明的定义。

参数

parser

XML 解析器的引用，用于设置声明处理器函数。

handler

handler 为表示函数名称的字符串，函数必须在为 parser 指定的解析器调用 xml_parse() 函数时已存在。

由 handler 参数命名的函数名必须接受五个参数：

handler ( resource $parser , string $notation_name , string $base , string $system_id , string $public_id )
parser
第一个参数 parser 为指向要调用处理器的 XML 解析器的指针。
notation_name
该参数为以上注释格式定义中的 name 参数。
base
这个参数是解析注释声明的系统标识符（system_id）的基础。当前该参数通常都被设置为空字符串。
system_id
外部注释声明的系统标识符。
public_id
外部注释声明的公共标识符。

如果处理器函数名被设置为空字符串或者 false，则该有问题的处理器将被屏蔽。

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

返回值

成功时返回 true， 或者在失败时返回 false。


在对象中使用 XML 解析器

  • ? xml_set_notation_decl_handler
  • xml_set_processing_instruction_handler ?
  • PHP Manual
  • XML 解析器函数
  • 在对象中使用 XML 解析器

xml_set_object

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_object — 在对象中使用 XML 解析器

描述

xml_set_object ( resource $parser , object &$object ) : pool

该函数使得 parser 指定的解析器可以被用在 object 对象中。所有的回叫函数（callback function）都可以由 xml_set_element_handler() 等函数来设置，它们被假定为 object 对象的方法。

Example #1 xml_set_object() 示例

<?php
class xml  {
    var $parser;

    function xml()
    {
        $this->parser = xml_parser_create();

        xml_set_object($this->parser, $this);
        xml_set_element_handler($this->parser, "tag_open", "tag_close");
        xml_set_character_data_handler($this->parser, "cdata");
    }

     function parse($data)
    {
        xml_parse($this->parser, $data);
    }

    function tag_open($parser, $tag, $attributes)
    {
        var_dump($parser, $tag, $attributes);
    }

    function cdata($parser, $cdata)
    {
        var_dump($parser, $cdata);
    }

    function tag_close($parser, $tag)
    {
        var_dump($parser, $tag);
    }

} // end of class xml

$xml_parser = new xml();
$xml_parser->parse("<A ID='hallo'>PHP</A>");
?>


建立处理指令（PI）处理器

  • ? xml_set_object
  • xml_set_start_namespace_decl_handler ?
  • PHP Manual
  • XML 解析器函数
  • 建立处理指令（PI）处理器

xml_set_processing_instruction_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_processing_instruction_handler — 建立处理指令（PI）处理器

说明

xml_set_processing_instruction_handler ( resource $parser , callable $handler ) : bool

为 parser 参数指定的 XML 解析器建立处理指令（PI）处理器函数。

处理指令有如下格式：

<?
target data
?>
您可以将 PHP 代码放置在类似的标识符中，但要注意一个限制：在 XML 处理指令（PI）中，PI 的终止符（?>）不能被引号引用，因此该字符序列不应该在您用 PI 嵌入到 XML 文档中的 PHP 代码中出现。否则，剩下的 PHP 代码，包括"真正"的 PI 终止符将被当作字符数据处理。

参数

parser

XML 解析器的引用，用于建立处理指令（PI）处理器。

handler

参数 handler 为表示函数名称的字符串，函数必须在为 parser 指定的解析器调用 xml_parse() 函数时已存在。

由 handler 参数命名的函数名必须接受三个参数：

handler ( resource $parser , string $target , string $data )
parser
第一个参数 parser 为指向要调用处理器的 XML 解析器的指针。
target
第二个参数 target 为 PI 对象（PI target）。
data
第三个参数 data 包含了 PI 数据。

如果处理器函数名被设置为空字符串或者 false，则该有问题的处理器将被屏蔽。

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

返回值

成功时返回 true， 或者在失败时返回 false。


建立起始命名空间声明处理器

  • ? xml_set_processing_instruction_handler
  • xml_set_unparsed_entity_decl_handler ?
  • PHP Manual
  • XML 解析器函数
  • 建立起始命名空间声明处理器

xml_set_start_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PHP 8)

xml_set_start_namespace_decl_handler — 建立起始命名空间声明处理器

说明

xml_set_start_namespace_decl_handler ( resource $parser , callable $handler ) : bool

Set a handler to be called when a namespace is declared. Namespace declarations occur inside start tags. But the namespace declaration start handler is called before the start tag handler for each namespace declared in that start tag.

参数

parser

A reference to the XML parser.

handler

handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept three parameters, and should return an integer value. If the value returned from the handler is false (which it will be if no value is returned), the XML parser will stop parsing and xml_get_error_code() will return XML_ERROR_EXTERNAL_ENTITY_HANDLING.

handler ( resource $parser , string $prefix , string $uri )
parser
The first parameter, parser, is a reference to the XML parser calling the handler.
prefix
The prefix is a string used to reference the namespace within an XML object.
uri
Uniform Resource Identifier (URI) of namespace.

If a handler function is set to an empty string, or false, the handler in question is disabled.

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • xml_set_end_namespace_decl_handler() - 建立终止命名空间声明处理器


建立未解析实体定义声明处理器

  • ? xml_set_start_namespace_decl_handler
  • XMLReader ?
  • PHP Manual
  • XML 解析器函数
  • 建立未解析实体定义声明处理器

xml_set_unparsed_entity_decl_handler

(PHP 4, PHP 5, PHP 7, PHP 8)

xml_set_unparsed_entity_decl_handler — 建立未解析实体定义声明处理器

说明

xml_set_unparsed_entity_decl_handler ( resource $parser , callable $handler ) : bool

为 parser 参数指定的 XML 解析器建立未解析实体定义声明处理器函数。

当 XML 解析器遇到如下含有 NDATA 声明的外部实体定义声明时，该 handler 处理器将被调用：

<!ENTITY <parameter>name</parameter> {<parameter>publicId</parameter> | <parameter>systemId</parameter>}
        NDATA <parameter>notationName</parameter>

请参阅 » XML 1.0 参考的第 4.2.2 节以获取有关已声明外部实体注释定义的信息。

参数

parser

XML 解析器的引用，用于建立未解析实体定义声明处理器。

handler

参数handler 为表示函数名称的字符串，这个函数必须在为 parser 指定的解析器调用 xml_parse() 函数时已存在。

由 handler 参数命名的函数名必须接受六个参数：

handler ( resource $parser , string $entity_name , string $base , string $system_id , string $public_id , string $notation_name )
parser
第一个参数 parser 为指向要调用处理器的 XML 解析器的指针。
entity_name
将被定义的实体名。
base
这个参数是解析外部实体的系统标识符（system_id）的基础。当前该参数通常都被设置为空字符串。
system_id
外部实体的系统标识符。
public_id
外部实体的公共标识符。
notation_name
该实体的注释名（请参阅 xml_set_notation_decl_handler()）。

如果处理器函数名被设置为空字符串或者 false，则该有问题的处理器将被屏蔽。

Note: 除了函数名，含有对象引用的数组和方法名也可以作为参数。

返回值

成功时返回 true， 或者在失败时返回 false。


XMLReader

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • XMLReader — The XMLReader class
    • XMLReader::close — Close the XMLReader input
    • XMLReader::expand — Returns a copy of the current node as a DOM object
    • XMLReader::getAttribute — Get the value of a named attribute
    • XMLReader::getAttributeNo — Get the value of an attribute by index
    • XMLReader::getAttributeNs — Get the value of an attribute by localname and URI
    • XMLReader::getParserProperty — Indicates if specified property has been set
    • XMLReader::isValid — Indicates if the parsed document is valid
    • XMLReader::lookupNamespace — Lookup namespace for a prefix
    • XMLReader::moveToAttribute — Move cursor to a named attribute
    • XMLReader::moveToAttributeNo — Move cursor to an attribute by index
    • XMLReader::moveToAttributeNs — Move cursor to a named attribute
    • XMLReader::moveToElement — Position cursor on the parent Element of current Attribute
    • XMLReader::moveToFirstAttribute — Position cursor on the first Attribute
    • XMLReader::moveToNextAttribute — Position cursor on the next Attribute
    • XMLReader::next — Move cursor to next node skipping all subtrees
    • XMLReader::open — Set the URI containing the XML to parse
    • XMLReader::read — Move to next node in document
    • XMLReader::readInnerXml — Retrieve XML from current node
    • XMLReader::readOuterXml — Retrieve XML from current node, including itself
    • XMLReader::readString — Reads the contents of the current node as a string
    • XMLReader::setParserProperty — Set parser options
    • XMLReader::setRelaxNGSchema — Set the filename or URI for a RelaxNG Schema
    • XMLReader::setRelaxNGSchemaSource — Set the data containing a RelaxNG Schema
    • XMLReader::setSchema — Validate document against XSD
    • XMLReader::XML — Set the data containing the XML to parse


简介

The XMLReader extension is an XML Pull parser. The reader acts as a cursor going forward on the document stream and stopping at each node on the way.

编码

It is important to note that internally, libxml uses the UTF-8 encoding and as such, the encoding of the retrieved contents will always be in UTF-8 encoding.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • XMLReader
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

The XMLReader extension was initially a PECL extension for PHP 5. It was later moved to the PHP source (bundled) as of PHP 5.1.0, and later enabled by default as of PHP 5.1.2.

此扩展默认为启用，编译时可通过下列选项禁用： --disable-xmlreader


  • ? 运行时配置
  • XMLReader ?
  • PHP Manual
  • 安装／配置
  • 资源类型

资源类型

此扩展没有定义资源类型。


The XMLReader class

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

简介

The XMLReader extension is an XML Pull parser. The reader acts as a cursor going forward on the document stream and stopping at each node on the way.

类摘要

XMLReader {
/* 常量 */
const int NONE = 0 ;
const int ELEMENT = 1 ;
const int ATTRIBUTE = 2 ;
const int TEXT = 3 ;
const int CDATA = 4 ;
const int ENTITY_REF = 5 ;
const int ENTITY = 6 ;
const int PI = 7 ;
const int COMMENT = 8 ;
const int DOC = 9 ;
const int DOC_TYPE = 10 ;
const int DOC_FRAGMENT = 11 ;
const int NOTATION = 12 ;
const int WHITESPACE = 13 ;
const int SIGNIFICANT_WHITESPACE = 14 ;
const int END_ELEMENT = 15 ;
const int END_ENTITY = 16 ;
const int XML_DECLARATION = 17 ;
const int LOADDTD = 1 ;
const int DEFAULTATTRS = 2 ;
const int VALIDATE = 3 ;
const int SUBST_ENTITIES = 4 ;
/* 属性 */
public readonly int $attributeCount ;
public readonly string $baseURI ;
public readonly int $depth ;
public readonly bool $hasAttributes ;
public readonly bool $hasValue ;
public readonly bool $isDefault ;
public readonly bool $isEmptyElement ;
public readonly string $localName ;
public readonly string $name ;
public readonly string $namespaceURI ;
public readonly int $nodeType ;
public readonly string $prefix ;
public readonly string $value ;
public readonly string $xmlLang ;
/* 方法 */
public close ( ) : bool
public expand ( DOMNode|null $baseNode = null ) : DOMNode|false
public getAttribute ( string $name ) : string|null
public getAttributeNo ( int $index ) : string|null
public getAttributeNs ( string $name , string $namespace ) : string|null
public getParserProperty ( int $property ) : bool
public isValid ( ) : bool
public lookupNamespace ( string $prefix ) : string|null
public moveToAttribute ( string $name ) : bool
public moveToAttributeNo ( int $index ) : bool
public moveToAttributeNs ( string $name , string $namespace ) : bool
public moveToElement ( ) : bool
public moveToFirstAttribute ( ) : bool
public moveToNextAttribute ( ) : bool
public next ( string|null $name = null ) : bool
public static open ( string $uri , string|null $encoding = null , int $flags = 0 ) : bool|XMLReader
public read ( ) : bool
public readInnerXml ( ) : string
public readOuterXml ( ) : string
public readString ( ) : string
public setParserProperty ( int $property , bool $value ) : bool
public setRelaxNGSchema ( string|null $filename ) : bool
public setRelaxNGSchemaSource ( string|null $source ) : bool
public setSchema ( string|null $filename ) : bool
public static XML ( string $source , string|null $encoding = null , int $flags = 0 ) : bool|XMLReader
}

属性

attributeCount

The number of attributes on the node

baseURI

The base URI of the node

depth

Depth of the node in the tree, starting at 0

hasAttributes

Indicates if node has attributes

hasValue

Indicates if node has a text value

isDefault

Indicates if attribute is defaulted from DTD

isEmptyElement

Indicates if node is an empty element tag

localName

The local name of the node

name

The qualified name of the node

namespaceURI

The URI of the namespace associated with the node

nodeType

The node type for the node

prefix

The prefix of the namespace associated with the node

value

The text value of the node

xmlLang

The xml:lang scope which the node resides

预定义常量

XMLReader Node Types

XMLReader::NONE

No node type

XMLReader::ELEMENT

Start element

XMLReader::ATTRIBUTE

Attribute node

XMLReader::TEXT

Text node

XMLReader::CDATA

CDATA node

XMLReader::ENTITY_REF

Entity Reference node

XMLReader::ENTITY

Entity Declaration node

XMLReader::PI

Processing Instruction node

XMLReader::COMMENT

Comment node

XMLReader::DOC

Document node

XMLReader::DOC_TYPE

Document Type node

XMLReader::DOC_FRAGMENT

Document Fragment node

XMLReader::NOTATION

Notation node

XMLReader::WHITESPACE

Whitespace node

XMLReader::SIGNIFICANT_WHITESPACE

Significant Whitespace node

XMLReader::END_ELEMENT

End Element

XMLReader::END_ENTITY

End Entity

XMLReader::XML_DECLARATION

XML Declaration node

XMLReader Parser Options

XMLReader::LOADDTD

Load DTD but do not validate

XMLReader::DEFAULTATTRS

Load DTD and default attributes but do not validate

XMLReader::VALIDATE

Load DTD and validate while parsing

XMLReader::SUBST_ENTITIES

Substitute entities and expand references

Table of Contents

  • XMLReader::close — Close the XMLReader input
  • XMLReader::expand — Returns a copy of the current node as a DOM object
  • XMLReader::getAttribute — Get the value of a named attribute
  • XMLReader::getAttributeNo — Get the value of an attribute by index
  • XMLReader::getAttributeNs — Get the value of an attribute by localname and URI
  • XMLReader::getParserProperty — Indicates if specified property has been set
  • XMLReader::isValid — Indicates if the parsed document is valid
  • XMLReader::lookupNamespace — Lookup namespace for a prefix
  • XMLReader::moveToAttribute — Move cursor to a named attribute
  • XMLReader::moveToAttributeNo — Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs — Move cursor to a named attribute
  • XMLReader::moveToElement — Position cursor on the parent Element of current Attribute
  • XMLReader::moveToFirstAttribute — Position cursor on the first Attribute
  • XMLReader::moveToNextAttribute — Position cursor on the next Attribute
  • XMLReader::next — Move cursor to next node skipping all subtrees
  • XMLReader::open — Set the URI containing the XML to parse
  • XMLReader::read — Move to next node in document
  • XMLReader::readInnerXml — Retrieve XML from current node
  • XMLReader::readOuterXml — Retrieve XML from current node, including itself
  • XMLReader::readString — Reads the contents of the current node as a string
  • XMLReader::setParserProperty — Set parser options
  • XMLReader::setRelaxNGSchema — Set the filename or URI for a RelaxNG Schema
  • XMLReader::setRelaxNGSchemaSource — Set the data containing a RelaxNG Schema
  • XMLReader::setSchema — Validate document against XSD
  • XMLReader::XML — Set the data containing the XML to parse


Close the XMLReader input

  • ? XMLReader
  • XMLReader::expand ?
  • PHP Manual
  • XMLReader
  • Close the XMLReader input

XMLReader::close

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::close — Close the XMLReader input

说明

public XMLReader::close ( ) : bool

Closes the input the XMLReader object is currently parsing.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::open() - Set the URI containing the XML to parse
  • XMLReader::xml() - Set the data containing the XML to parse


Returns a copy of the current node as a DOM object

  • ? XMLReader::close
  • XMLReader::getAttribute ?
  • PHP Manual
  • XMLReader
  • Returns a copy of the current node as a DOM object

XMLReader::expand

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::expand — Returns a copy of the current node as a DOM object

说明

public XMLReader::expand ( DOMNode|null $baseNode = null ) : DOMNode|false

This method copies the current node and returns the appropriate DOM object.

参数

baseNode

A DOMNode defining the target DOMDocument for the created DOM object.

返回值

The resulting DOMNode or false on error.


Get the value of a named attribute

  • ? XMLReader::expand
  • XMLReader::getAttributeNo ?
  • PHP Manual
  • XMLReader
  • Get the value of a named attribute

XMLReader::getAttribute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::getAttribute — Get the value of a named attribute

说明

public XMLReader::getAttribute ( string $name ) : string|null

Returns the value of a named attribute or null if the attribute does not exist or not positioned on an element node.

参数

name

The name of the attribute.

更新日志

版本 | 说明
8.0.0 | This function can no longer return false.

返回值

The value of the attribute, or null if no attribute with the given name is found or not positioned on an element node.

参见

  • XMLReader::getAttributeNo() - Get the value of an attribute by index
  • XMLReader::getAttributeNs() - Get the value of an attribute by localname and URI


Get the value of an attribute by index

  • ? XMLReader::getAttribute
  • XMLReader::getAttributeNs ?
  • PHP Manual
  • XMLReader
  • Get the value of an attribute by index

XMLReader::getAttributeNo

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::getAttributeNo — Get the value of an attribute by index

说明

public XMLReader::getAttributeNo ( int $index ) : string|null

Returns the value of an attribute based on its position or an empty string if attribute does not exist or not positioned on an element node.

参数

index

The position of the attribute.

返回值

The value of the attribute, or an empty string (before PHP 5.6) or null (from PHP 5.6 onwards) if no attribute exists at index or is not positioned on the element.

更新日志

版本 | 说明
5.6.0 | XMLReader::getAttributeNo() now returns null if the attribute doesn't exist.

参见

  • XMLReader::getAttribute() - Get the value of a named attribute
  • XMLReader::getAttributeNs() - Get the value of an attribute by localname and URI


Get the value of an attribute by localname and URI

  • ? XMLReader::getAttributeNo
  • XMLReader::getParserProperty ?
  • PHP Manual
  • XMLReader
  • Get the value of an attribute by localname and URI

XMLReader::getAttributeNs

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::getAttributeNs — Get the value of an attribute by localname and URI

说明

public XMLReader::getAttributeNs ( string $name , string $namespace ) : string|null

Returns the value of an attribute by name and namespace URI or an empty string if attribute does not exist or not positioned on an element node.

参数

name

The local name.

namespace

The namespace URI.

返回值

The value of the attribute, or an empty string (before PHP 5.6) or null (from PHP 5.6 onwards) if no attribute with the given name and namespace is found or not positioned of element.

更新日志

版本 | 说明
8.0.0 | This function can no longer return false.
5.6.0 | XMLReader::getAttributeNS() now returns null if the attribute doesn't exist.

参见

  • XMLReader::getAttribute() - Get the value of a named attribute
  • XMLReader::getAttributeNo() - Get the value of an attribute by index


Indicates if specified property has been set

  • ? XMLReader::getAttributeNs
  • XMLReader::isValid ?
  • PHP Manual
  • XMLReader
  • Indicates if specified property has been set

XMLReader::getParserProperty

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::getParserProperty — Indicates if specified property has been set

说明

public XMLReader::getParserProperty ( int $property ) : bool

Indicates if specified property has been set.

参数

property

One of the parser option constants.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::setParserProperty() - Set parser options


Indicates if the parsed document is valid

  • ? XMLReader::getParserProperty
  • XMLReader::lookupNamespace ?
  • PHP Manual
  • XMLReader
  • Indicates if the parsed document is valid

XMLReader::isValid

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::isValid — Indicates if the parsed document is valid

说明

public XMLReader::isValid ( ) : bool

Returns a boolean indicating if the document being parsed is currently valid.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Validating XML

<?php
$xml = XMLReader::open('test.xml');

// The validate parser option must be enabled for
// this method to work properly
$xml->setParserProperty(XMLReader::VALIDATE, true);

var_dump($xml->isValid());
?>

注释

Note: This checks the current node, not the entire document.

参见

  • XMLReader::setParserProperty() - Set parser options
  • XMLReader::setRelaxNGSchema() - Set the filename or URI for a RelaxNG Schema
  • XMLReader::setRelaxNGSchemaSource() - Set the data containing a RelaxNG Schema
  • XMLReader::setSchema() - Validate document against XSD


Lookup namespace for a prefix

  • ? XMLReader::isValid
  • XMLReader::moveToAttribute ?
  • PHP Manual
  • XMLReader
  • Lookup namespace for a prefix

XMLReader::lookupNamespace

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::lookupNamespace — Lookup namespace for a prefix

说明

public XMLReader::lookupNamespace ( string $prefix ) : string|null

Lookup in scope namespace for a given prefix.

参数

prefix

String containing the prefix.

返回值

The value of the namespace, or null if no namespace exists.

更新日志

版本 | 说明
8.0.0 | This function can no longer return false.


Move cursor to a named attribute

  • ? XMLReader::lookupNamespace
  • XMLReader::moveToAttributeNo ?
  • PHP Manual
  • XMLReader
  • Move cursor to a named attribute

XMLReader::moveToAttribute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToAttribute — Move cursor to a named attribute

说明

public XMLReader::moveToAttribute ( string $name ) : bool

Positions cursor on the named attribute.

参数

name

The name of the attribute.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::moveToElement() - Position cursor on the parent Element of current Attribute
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToFirstAttribute() - Position cursor on the first Attribute


Move cursor to an attribute by index

  • ? XMLReader::moveToAttribute
  • XMLReader::moveToAttributeNs ?
  • PHP Manual
  • XMLReader
  • Move cursor to an attribute by index

XMLReader::moveToAttributeNo

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToAttributeNo — Move cursor to an attribute by index

说明

public XMLReader::moveToAttributeNo ( int $index ) : bool

Positions cursor on attribute based on its position.

参数

index

The position of the attribute.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::moveToElement() - Position cursor on the parent Element of current Attribute
  • XMLReader::moveToAttribute() - Move cursor to a named attribute
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToFirstAttribute() - Position cursor on the first Attribute


Move cursor to a named attribute

  • ? XMLReader::moveToAttributeNo
  • XMLReader::moveToElement ?
  • PHP Manual
  • XMLReader
  • Move cursor to a named attribute

XMLReader::moveToAttributeNs

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToAttributeNs — Move cursor to a named attribute

说明

public XMLReader::moveToAttributeNs ( string $name , string $namespace ) : bool

Positions cursor on the named attribute in specified namespace.

参数

name

The local name.

namespace

The namespace URI.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::moveToElement() - Position cursor on the parent Element of current Attribute
  • XMLReader::moveToAttribute() - Move cursor to a named attribute
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToFirstAttribute() - Position cursor on the first Attribute


Position cursor on the parent Element of current Attribute

  • ? XMLReader::moveToAttributeNs
  • XMLReader::moveToFirstAttribute ?
  • PHP Manual
  • XMLReader
  • Position cursor on the parent Element of current Attribute

XMLReader::moveToElement

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToElement — Position cursor on the parent Element of current Attribute

说明

public XMLReader::moveToElement ( ) : bool

Moves cursor to the parent Element of current Attribute.

返回值

Returns true if successful and false if it fails or not positioned on Attribute when this method is called.

参见

  • XMLReader::moveToAttribute() - Move cursor to a named attribute
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToFirstAttribute() - Position cursor on the first Attribute


Position cursor on the first Attribute

  • ? XMLReader::moveToElement
  • XMLReader::moveToNextAttribute ?
  • PHP Manual
  • XMLReader
  • Position cursor on the first Attribute

XMLReader::moveToFirstAttribute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToFirstAttribute — Position cursor on the first Attribute

说明

public XMLReader::moveToFirstAttribute ( ) : bool

Moves cursor to the first Attribute.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::moveToElement() - Position cursor on the parent Element of current Attribute
  • XMLReader::moveToAttribute() - Move cursor to a named attribute
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToNextAttribute() - Position cursor on the next Attribute


Position cursor on the next Attribute

  • ? XMLReader::moveToFirstAttribute
  • XMLReader::next ?
  • PHP Manual
  • XMLReader
  • Position cursor on the next Attribute

XMLReader::moveToNextAttribute

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::moveToNextAttribute — Position cursor on the next Attribute

说明

public XMLReader::moveToNextAttribute ( ) : bool

Moves cursor to the next Attribute if positioned on an Attribute or moves to first attribute if positioned on an Element.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::moveToElement() - Position cursor on the parent Element of current Attribute
  • XMLReader::moveToAttribute() - Move cursor to a named attribute
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToFirstAttribute() - Position cursor on the first Attribute


Move cursor to next node skipping all subtrees

  • ? XMLReader::moveToNextAttribute
  • XMLReader::open ?
  • PHP Manual
  • XMLReader
  • Move cursor to next node skipping all subtrees

XMLReader::next

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::next — Move cursor to next node skipping all subtrees

说明

public XMLReader::next ( string|null $name = null ) : bool

Positions cursor on the next node skipping all subtrees. If no such node exists, the cursor is moved to the end of the document.

参数

name

The name of the next node to move to.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | name is nullable now.

参见

  • XMLReader::moveToNextAttribute() - Position cursor on the next Attribute
  • XMLReader::moveToElement() - Position cursor on the parent Element of current Attribute
  • XMLReader::moveToAttribute() - Move cursor to a named attribute


Set the URI containing the XML to parse

  • ? XMLReader::next
  • XMLReader::read ?
  • PHP Manual
  • XMLReader
  • Set the URI containing the XML to parse

XMLReader::open

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::open — Set the URI containing the XML to parse

说明

public static XMLReader::open ( string $uri , string|null $encoding = null , int $flags = 0 ) : bool|XMLReader

Set the URI containing the XML document to be parsed.

参数

uri

URI pointing to the document.

encoding

The document encoding or null.

flags

A bitmask of the LIBXML_* constants.

返回值

成功时返回 true， 或者在失败时返回 false。 If called statically, returns an XMLReader 或者在失败时返回 false.

错误／异常

This method may be called statically, but prior to PHP 8.0.0, will issue an E_DEPRECATED error in this case.

更新日志

版本 | 说明
8.0.0 | XMLReader::open() is now declared as static method, but can still be called on an XMLReader instance.

参见

  • XMLReader::xml() - Set the data containing the XML to parse
  • XMLReader::close() - Close the XMLReader input


Move to next node in document

  • ? XMLReader::open
  • XMLReader::readInnerXml ?
  • PHP Manual
  • XMLReader
  • Move to next node in document

XMLReader::read

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::read — Move to next node in document

说明

public XMLReader::read ( ) : bool

Moves cursor to the next node in the document.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::moveToElement() - Position cursor on the parent Element of current Attribute
  • XMLReader::moveToAttribute() - Move cursor to a named attribute
  • XMLReader::next() - Move cursor to next node skipping all subtrees


Retrieve XML from current node

  • ? XMLReader::read
  • XMLReader::readOuterXml ?
  • PHP Manual
  • XMLReader
  • Retrieve XML from current node

XMLReader::readInnerXml

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

XMLReader::readInnerXml — Retrieve XML from current node

说明

public XMLReader::readInnerXml ( ) : string

Reads the contents of the current node, including child nodes and markup.

参数

此函数没有参数。

返回值

Returns the contents of the current node as a string. Empty string on failure.

注释

Caution

此函数仅在 PHP 与 libxml 20620 或以上版本编译时可用。

参见

  • XMLReader::readString() - Reads the contents of the current node as a string
  • XMLReader::readOuterXml() - Retrieve XML from current node, including itself
  • XMLReader::expand() - Returns a copy of the current node as a DOM object


Retrieve XML from current node, including itself

  • ? XMLReader::readInnerXml
  • XMLReader::readString ?
  • PHP Manual
  • XMLReader
  • Retrieve XML from current node, including itself

XMLReader::readOuterXml

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

XMLReader::readOuterXml — Retrieve XML from current node, including itself

说明

public XMLReader::readOuterXml ( ) : string

Reads the contents of the current node, including the node itself.

参数

此函数没有参数。

返回值

Returns the contents of current node, including itself, as a string. Empty string on failure.

注释

Caution

此函数仅在 PHP 与 libxml 20620 或以上版本编译时可用。

参见

  • XMLReader::readString() - Reads the contents of the current node as a string
  • XMLReader::readInnerXml() - Retrieve XML from current node
  • XMLReader::expand() - Returns a copy of the current node as a DOM object


Reads the contents of the current node as a string

  • ? XMLReader::readOuterXml
  • XMLReader::setParserProperty ?
  • PHP Manual
  • XMLReader
  • Reads the contents of the current node as a string

XMLReader::readString

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

XMLReader::readString — Reads the contents of the current node as a string

说明

public XMLReader::readString ( ) : string

Reads the contents of the current node as a string.

参数

此函数没有参数。

返回值

Returns the content of the current node as a string. Empty string on failure.

注释

Caution

此函数仅在 PHP 与 libxml 20620 或以上版本编译时可用。

参见

  • XMLReader::readOuterXml() - Retrieve XML from current node, including itself
  • XMLReader::readInnerXml() - Retrieve XML from current node
  • XMLReader::expand() - Returns a copy of the current node as a DOM object


Set parser options

  • ? XMLReader::readString
  • XMLReader::setRelaxNGSchema ?
  • PHP Manual
  • XMLReader
  • Set parser options

XMLReader::setParserProperty

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::setParserProperty — Set parser options

说明

public XMLReader::setParserProperty ( int $property , bool $value ) : bool

Set parser options. The options must be set after
XMLReader::open() or
XMLReader::xml() are called and before
the first XMLReader::read() call.

参数

property

One of the parser option constants.

value

If set to true the option will be enabled otherwise will be disabled.

返回值

成功时返回 true， 或者在失败时返回 false。


Set the filename or URI for a RelaxNG Schema

  • ? XMLReader::setParserProperty
  • XMLReader::setRelaxNGSchemaSource ?
  • PHP Manual
  • XMLReader
  • Set the filename or URI for a RelaxNG Schema

XMLReader::setRelaxNGSchema

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::setRelaxNGSchema — Set the filename or URI for a RelaxNG Schema

说明

public XMLReader::setRelaxNGSchema ( string|null $filename ) : bool

Set the filename or URI for the RelaxNG Schema to use for validation.

参数

filename

filename or URI pointing to a RelaxNG Schema.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::setRelaxNGSchemaSource() - Set the data containing a RelaxNG Schema
  • XMLReader::setSchema() - Validate document against XSD
  • XMLReader::isValid() - Indicates if the parsed document is valid


Set the data containing a RelaxNG Schema

  • ? XMLReader::setRelaxNGSchema
  • XMLReader::setSchema ?
  • PHP Manual
  • XMLReader
  • Set the data containing a RelaxNG Schema

XMLReader::setRelaxNGSchemaSource

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::setRelaxNGSchemaSource — Set the data containing a RelaxNG Schema

说明

public XMLReader::setRelaxNGSchemaSource ( string|null $source ) : bool

Set the data containing a RelaxNG Schema to use for validation.

参数

source

String containing the RelaxNG Schema.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XMLReader::setRelaxNGSchema() - Set the filename or URI for a RelaxNG Schema
  • XMLReader::setSchema() - Validate document against XSD
  • XMLReader::isValid() - Indicates if the parsed document is valid


Validate document against XSD

  • ? XMLReader::setRelaxNGSchemaSource
  • XMLReader::XML ?
  • PHP Manual
  • XMLReader
  • Validate document against XSD

XMLReader::setSchema

(PHP 5 >= 5.2.0, PHP 7, PHP 8)

XMLReader::setSchema — Validate document against XSD

说明

public XMLReader::setSchema ( string|null $filename ) : bool

Use W3C XSD schema to validate the document as it is processed. Activation is only possible before the first Read().

参数

filename

The filename of the XSD schema.

返回值

成功时返回 true， 或者在失败时返回 false。

错误／异常

Issues E_WARNING if libxml was built without schema support, the schema contains errors or if XMLReader::read() has already been called.

注释

Caution

此函数仅在 PHP 与 libxml 20620 或以上版本编译时可用。

参见

  • XMLReader::setRelaxNGSchema() - Set the filename or URI for a RelaxNG Schema
  • XMLReader::setRelaxNGSchemaSource() - Set the data containing a RelaxNG Schema
  • XMLReader::isValid() - Indicates if the parsed document is valid


Set the data containing the XML to parse

  • ? XMLReader::setSchema
  • XMLWriter ?
  • PHP Manual
  • XMLReader
  • Set the data containing the XML to parse

XMLReader::XML

(PHP 5 >= 5.1.0, PHP 7, PHP 8)

XMLReader::XML — Set the data containing the XML to parse

说明

public static XMLReader::XML ( string $source , string|null $encoding = null , int $flags = 0 ) : bool|XMLReader

Set the data containing the XML to parse.

参数

source

String containing the XML to be parsed.

encoding

The document encoding or null.

flags

A bitmask of the LIBXML_* constants.

返回值

成功时返回 true， 或者在失败时返回 false。 If called statically, returns an XMLReader 或者在失败时返回 false.

错误／异常

This method may be called statically, but prior to PHP 8.0.0, will issue an E_DEPRECATED error in this case.

更新日志

版本 | 说明
8.0.0 | XMLReader::XML() is now declared as static method, but can still be called on an XMLReader instance.

参见

  • XMLReader::open() - Set the URI containing the XML to parse
  • XMLReader::close() - Close the XMLReader input


XMLWriter

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Creating a simple XML document
    • Working with XML namespaces
    • Working with the OO API
  • XMLWriter — The XMLWriter class
    • XMLWriter::endAttribute — End attribute
    • XMLWriter::endCdata — End current CDATA
    • XMLWriter::endComment — Create end comment
    • XMLWriter::endDocument — End current document
    • XMLWriter::endDtd — End current DTD
    • XMLWriter::endDtdAttlist — End current DTD AttList
    • XMLWriter::endDtdElement — End current DTD element
    • XMLWriter::endDtdEntity — End current DTD Entity
    • XMLWriter::endElement — End current element
    • XMLWriter::endPi — End current PI
    • XMLWriter::flush — Flush current buffer
    • XMLWriter::fullEndElement — End current element
    • XMLWriter::openMemory — Create new xmlwriter using memory for string output
    • XMLWriter::openUri — Create new xmlwriter using source uri for output
    • XMLWriter::outputMemory — Returns current buffer
    • XMLWriter::setIndent — Toggle indentation on/off
    • XMLWriter::setIndentString — Set string used for indenting
    • XMLWriter::startAttribute — Create start attribute
    • XMLWriter::startAttributeNs — Create start namespaced attribute
    • XMLWriter::startCdata — Create start CDATA tag
    • XMLWriter::startComment — Create start comment
    • XMLWriter::startDocument — Create document tag
    • XMLWriter::startDtd — Create start DTD tag
    • XMLWriter::startDtdAttlist — Create start DTD AttList
    • XMLWriter::startDtdElement — Create start DTD element
    • XMLWriter::startDtdEntity — Create start DTD Entity
    • XMLWriter::startElement — Create start element tag
    • XMLWriter::startElementNs — Create start namespaced element tag
    • XMLWriter::startPi — Create start PI tag
    • XMLWriter::text — Write text
    • XMLWriter::writeAttribute — Write full attribute
    • XMLWriter::writeAttributeNs — Write full namespaced attribute
    • XMLWriter::writeCdata — Write full CDATA tag
    • XMLWriter::writeComment — Write full comment tag
    • XMLWriter::writeDtd — Write full DTD tag
    • XMLWriter::writeDtdAttlist — Write full DTD AttList tag
    • XMLWriter::writeDtdElement — Write full DTD element tag
    • XMLWriter::writeDtdEntity — Write full DTD Entity tag
    • XMLWriter::writeElement — Write full element tag
    • XMLWriter::writeElementNs — Write full namespaced element tag
    • XMLWriter::writePi — Writes a PI
    • XMLWriter::writeRaw — Write a raw XML text


简介

This is the XMLWriter extension. It wraps the libxml xmlWriter API.

This extension represents a writer that provides a non-cached, forward-only means of generating streams or files containing XML data.

This extension can be used in an object oriented style or a procedural one. Every method documented describes the alternative procedural call.


  • ? 简介
  • 需求 ?
  • PHP Manual
  • XMLWriter
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装
  • 运行时配置
  • 资源类型


安装

The XMLWriter extension was initially a PECL extension for PHP 5. It was later added to the PHP source (bundled) as of PHP 5.1.2. This extension is enabled by default.

此扩展默认为启用，编译时可通过下列选项禁用： --disable-xmlwriter


资源类型

Prior to PHP 8.0.0, there was one resource type used by the procedural version of the XMLWriter extension: returned by xmlwriter_open_memory() or xmlwriter_open_uri().


  • ? 资源类型
  • 范例 ?
  • PHP Manual
  • XMLWriter
  • 预定义常量

预定义常量

此扩展没有定义常量。


范例

Table of Contents

  • Creating a simple XML document
  • Working with XML namespaces
  • Working with the OO API


Creating a simple XML document

This example shows how to use XMLWriter to create a XML document in memory.

Example #1 Creating a simple XML document

<?php

$xw = xmlwriter_open_memory();
xmlwriter_set_indent($xw, 1);
$res = xmlwriter_set_indent_string($xw, ' ');

xmlwriter_start_document($xw, '1.0', 'UTF-8');

// A first element
xmlwriter_start_element($xw, 'tag1');

// Attribute 'att1' for element 'tag1'
xmlwriter_start_attribute($xw, 'att1');
xmlwriter_text($xw, 'valueofatt1');
xmlwriter_end_attribute($xw);

xmlwriter_write_comment($xw, 'this is a comment.');

// Start a child element
xmlwriter_start_element($xw, 'tag11');
xmlwriter_text($xw, 'This is a sample text, ?');
xmlwriter_end_element($xw); // tag11

xmlwriter_end_element($xw); // tag1

// CDATA
xmlwriter_start_element($xw, 'testc');
xmlwriter_write_cdata($xw, "This is cdata content");
xmlwriter_end_element($xw); // testc

xmlwriter_start_element($xw, 'testc');
xmlwriter_start_cdata($xw);
xmlwriter_text($xw, "test cdata2");
xmlwriter_end_cdata($xw);
xmlwriter_end_element($xw); // testc

// A processing instruction
xmlwriter_start_pi($xw, 'php');
xmlwriter_text($xw, '$foo=2;echo $foo;');
xmlwriter_end_pi($xw);

xmlwriter_end_document($xw);

echo xmlwriter_output_memory($xw);

以上例程会输出：

<?xml version="1.0" encoding="UTF-8"?>
<tag1 att1="valueofatt1">
 <!--this is a comment.-->
 <tag11>This is a sample text, ?</tag11>
</tag1>
<testc><![CDATA[This is cdata content]]></testc>
<testc><![CDATA[test cdata2]]></testc>
<?php $foo=2;echo $foo;?>


Working with XML namespaces

This example shows how to create namespaced XML elements.

Example #1 Working with XML namespaces

<?php

$xw = xmlwriter_open_memory();
xmlwriter_set_indent($xw, 1);
$res = xmlwriter_set_indent_string($xw, ' ');

xmlwriter_start_document($xw, '1.0', 'UTF-8');
// A first element
xmlwriter_start_element_ns($xw,'prefix', 'books', 'uri');
xmlwriter_start_attribute($xw, 'isbn');

xmlwriter_start_attribute_ns($xw, 'prefix', 'isbn', 'uri');
xmlwriter_end_attribute($xw);

xmlwriter_end_attribute($xw);

xmlwriter_text($xw, 'book1');
xmlwriter_end_element($xw);

xmlwriter_end_document($xw);

echo xmlwriter_output_memory($xw);

以上例程会输出：

<?xml version="1.0" encoding="UTF-8"?>
<prefix:books isbn="" prefix:isbn="" xmlns:prefix="uri">book1</prefix:books>


Working with the OO API

This example shows how to work with XMLWriter's object oriented API.

Example #1 Working with the OO API

<?php

$xw = new XMLWriter();
$xw->openMemory();
$xw->startDocument("1.0");
$xw->startElement("book");
$xw->text("example");
$xw->endElement();
$xw->endDocument();
echo $xw->outputMemory();

以上例程会输出：

<?xml version="1.0"?>
<book>example</book>


The XMLWriter class

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

简介

类摘要

XMLWriter {
/* 方法 */
public endAttribute ( ) : bool
public endCdata ( ) : bool
public endComment ( ) : bool
public endDocument ( ) : bool
public endDtd ( ) : bool
public endDtdAttlist ( ) : bool
public endDtdElement ( ) : bool
public endDtdEntity ( ) : bool
public endElement ( ) : bool
public endPi ( ) : bool
public flush ( bool $empty = true ) : string|int
public fullEndElement ( ) : bool
public openMemory ( ) : bool
public openUri ( string $uri ) : bool
public outputMemory ( bool $flush = true ) : string
public setIndent ( bool $enable ) : bool
public setIndentString ( string $indentation ) : bool
public startAttribute ( string $name ) : bool
public startAttributeNs ( string|null $prefix , string $name , string|null $namespace ) : bool
public startCdata ( ) : bool
public startComment ( ) : bool
public startDocument ( string|null $version = "1.0" , string|null $encoding = null , string|null $standalone = null ) : bool
public startDtd ( string $qualifiedName , string|null $publicId = null , string|null $systemId = null ) : bool
public startDtdAttlist ( string $name ) : bool
public startDtdElement ( string $qualifiedName ) : bool
public startDtdEntity ( string $name , bool $isParam ) : bool
public startElement ( string $name ) : bool
public startElementNs ( string|null $prefix , string $name , string|null $namespace ) : bool
public startPi ( string $target ) : bool
public text ( string $content ) : bool
public writeAttribute ( string $name , string $value ) : bool
public writeAttributeNs ( string|null $prefix , string $name , string|null $namespace , string $value ) : bool
public writeCdata ( string $content ) : bool
public writeComment ( string $content ) : bool
public writeDtd ( string $name , string|null $publicId = null , string|null $systemId = null , string|null $content = null ) : bool
public writeDtdAttlist ( string $name , string $content ) : bool
public writeDtdElement ( string $name , string $content ) : bool
public writeDtdEntity ( string $name , string $content , bool $isParam = false , string|null $publicId = null , string|null $systemId = null , string|null $notationData = null ) : bool
public writeElement ( string $name , string|null $content = null ) : bool
public writeElementNs ( string|null $prefix , string $name , string|null $namespace , string|null $content = null ) : bool
public writePi ( string $target , string $content ) : bool
public writeRaw ( string $content ) : bool
}

Table of Contents

  • XMLWriter::endAttribute — End attribute
  • XMLWriter::endCdata — End current CDATA
  • XMLWriter::endComment — Create end comment
  • XMLWriter::endDocument — End current document
  • XMLWriter::endDtd — End current DTD
  • XMLWriter::endDtdAttlist — End current DTD AttList
  • XMLWriter::endDtdElement — End current DTD element
  • XMLWriter::endDtdEntity — End current DTD Entity
  • XMLWriter::endElement — End current element
  • XMLWriter::endPi — End current PI
  • XMLWriter::flush — Flush current buffer
  • XMLWriter::fullEndElement — End current element
  • XMLWriter::openMemory — Create new xmlwriter using memory for string output
  • XMLWriter::openUri — Create new xmlwriter using source uri for output
  • XMLWriter::outputMemory — Returns current buffer
  • XMLWriter::setIndent — Toggle indentation on/off
  • XMLWriter::setIndentString — Set string used for indenting
  • XMLWriter::startAttribute — Create start attribute
  • XMLWriter::startAttributeNs — Create start namespaced attribute
  • XMLWriter::startCdata — Create start CDATA tag
  • XMLWriter::startComment — Create start comment
  • XMLWriter::startDocument — Create document tag
  • XMLWriter::startDtd — Create start DTD tag
  • XMLWriter::startDtdAttlist — Create start DTD AttList
  • XMLWriter::startDtdElement — Create start DTD element
  • XMLWriter::startDtdEntity — Create start DTD Entity
  • XMLWriter::startElement — Create start element tag
  • XMLWriter::startElementNs — Create start namespaced element tag
  • XMLWriter::startPi — Create start PI tag
  • XMLWriter::text — Write text
  • XMLWriter::writeAttribute — Write full attribute
  • XMLWriter::writeAttributeNs — Write full namespaced attribute
  • XMLWriter::writeCdata — Write full CDATA tag
  • XMLWriter::writeComment — Write full comment tag
  • XMLWriter::writeDtd — Write full DTD tag
  • XMLWriter::writeDtdAttlist — Write full DTD AttList tag
  • XMLWriter::writeDtdElement — Write full DTD element tag
  • XMLWriter::writeDtdEntity — Write full DTD Entity tag
  • XMLWriter::writeElement — Write full element tag
  • XMLWriter::writeElementNs — Write full namespaced element tag
  • XMLWriter::writePi — Writes a PI
  • XMLWriter::writeRaw — Write a raw XML text


End attribute

  • ? XMLWriter
  • XMLWriter::endCdata ?
  • PHP Manual
  • XMLWriter
  • End attribute

XMLWriter::endAttribute

xmlwriter_end_attribute

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endAttribute -- xmlwriter_end_attribute — End attribute

说明

面向对象风格

public XMLWriter::endAttribute ( ) : bool

过程化风格

xmlwriter_end_attribute ( XMLWriter $writer ) : bool

Ends the current attribute.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startAttribute() - Create start attribute
  • XMLWriter::startAttributeNs() - Create start namespaced attribute
  • XMLWriter::writeAttribute() - Write full attribute
  • XMLWriter::writeAttributeNs() - Write full namespaced attribute


End current CDATA

  • ? XMLWriter::endAttribute
  • XMLWriter::endComment ?
  • PHP Manual
  • XMLWriter
  • End current CDATA

XMLWriter::endCdata

xmlwriter_end_cdata

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endCdata -- xmlwriter_end_cdata — End current CDATA

说明

面向对象风格

public XMLWriter::endCdata ( ) : bool

过程化风格

xmlwriter_end_cdata ( XMLWriter $writer ) : bool

Ends the current CDATA section.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startCdata() - Create start CDATA tag
  • XMLWriter::writeCdata() - Write full CDATA tag


Create end comment

  • ? XMLWriter::endCdata
  • XMLWriter::endDocument ?
  • PHP Manual
  • XMLWriter
  • Create end comment

XMLWriter::endComment

xmlwriter_end_comment

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 1.0.0)

XMLWriter::endComment -- xmlwriter_end_comment — Create end comment

说明

面向对象风格

public XMLWriter::endComment ( ) : bool

过程化风格

xmlwriter_end_comment ( XMLWriter $writer ) : bool

Ends the current comment.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startComment() - Create start comment
  • XMLWriter::writeComment() - Write full comment tag


End current document

  • ? XMLWriter::endComment
  • XMLWriter::endDtd ?
  • PHP Manual
  • XMLWriter
  • End current document

XMLWriter::endDocument

xmlwriter_end_document

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDocument -- xmlwriter_end_document — End current document

说明

面向对象风格

public XMLWriter::endDocument ( ) : bool

过程化风格

xmlwriter_end_document ( XMLWriter $writer ) : bool

Ends the current document.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startDocument() - Create document tag


End current DTD

  • ? XMLWriter::endDocument
  • XMLWriter::endDtdAttlist ?
  • PHP Manual
  • XMLWriter
  • End current DTD

XMLWriter::endDtd

xmlwriter_end_dtd

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDtd -- xmlwriter_end_dtd — End current DTD

说明

面向对象风格

public XMLWriter::endDtd ( ) : bool

过程化风格

xmlwriter_end_dtd ( XMLWriter $writer ) : bool

Ends the DTD of the document.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startDtd() - Create start DTD tag
  • XMLWriter::writeDtd() - Write full DTD tag


End current DTD AttList

  • ? XMLWriter::endDtd
  • XMLWriter::endDtdElement ?
  • PHP Manual
  • XMLWriter
  • End current DTD AttList

XMLWriter::endDtdAttlist

xmlwriter_end_dtd_attlist

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDtdAttlist -- xmlwriter_end_dtd_attlist — End current DTD AttList

说明

面向对象风格

public XMLWriter::endDtdAttlist ( ) : bool

过程化风格

xmlwriter_end_dtd_attlist ( XMLWriter $writer ) : bool

Ends the current DTD attribute list.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startDtdAttlist() - Create start DTD AttList
  • XMLWriter::writeDtdAttlist() - Write full DTD AttList tag


End current DTD element

  • ? XMLWriter::endDtdAttlist
  • XMLWriter::endDtdEntity ?
  • PHP Manual
  • XMLWriter
  • End current DTD element

XMLWriter::endDtdElement

xmlwriter_end_dtd_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDtdElement -- xmlwriter_end_dtd_element — End current DTD element

说明

面向对象风格

public XMLWriter::endDtdElement ( ) : bool

过程化风格

xmlwriter_end_dtd_element ( XMLWriter $writer ) : bool

Ends the current DTD element.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startDtdElement() - Create start DTD element
  • XMLWriter::writeDtdElement() - Write full DTD element tag


End current DTD Entity

  • ? XMLWriter::endDtdElement
  • XMLWriter::endElement ?
  • PHP Manual
  • XMLWriter
  • End current DTD Entity

XMLWriter::endDtdEntity

xmlwriter_end_dtd_entity

(PHP 5 >= 5.2.1, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endDtdEntity -- xmlwriter_end_dtd_entity — End current DTD Entity

说明

面向对象风格

public XMLWriter::endDtdEntity ( ) : bool

过程化风格

xmlwriter_end_dtd_entity ( XMLWriter $writer ) : bool

Ends the current DTD entity.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startDtdEntity() - Create start DTD Entity
  • XMLWriter::writeDtdEntity() - Write full DTD Entity tag


End current element

  • ? XMLWriter::endDtdEntity
  • XMLWriter::endPi ?
  • PHP Manual
  • XMLWriter
  • End current element

XMLWriter::endElement

xmlwriter_end_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endElement -- xmlwriter_end_element — End current element

说明

面向对象风格

public XMLWriter::endElement ( ) : bool

过程化风格

xmlwriter_end_element ( XMLWriter $writer ) : bool

Ends the current element.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startElement() - Create start element tag
  • XMLWriter::writeElement() - Write full element tag


End current PI

  • ? XMLWriter::endElement
  • XMLWriter::flush ?
  • PHP Manual
  • XMLWriter
  • End current PI

XMLWriter::endPi

xmlwriter_end_pi

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::endPi -- xmlwriter_end_pi — End current PI

说明

面向对象风格

public XMLWriter::endPi ( ) : bool

过程化风格

xmlwriter_end_pi ( XMLWriter $writer ) : bool

Ends the current processing instruction.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startPi() - Create start PI tag
  • XMLWriter::writePi() - Writes a PI


Flush current buffer

  • ? XMLWriter::endPi
  • XMLWriter::fullEndElement ?
  • PHP Manual
  • XMLWriter
  • Flush current buffer

XMLWriter::flush

xmlwriter_flush

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 1.0.0)

XMLWriter::flush -- xmlwriter_flush — Flush current buffer

说明

面向对象风格

public XMLWriter::flush ( bool $empty = true ) : string|int

过程化风格

xmlwriter_flush ( XMLWriter $writer , bool $empty = true ) : string|int

Flushes the current buffer.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

empty

Whether to empty the buffer or not. Default is true.

返回值

If you opened the writer in memory, this function returns the generated XML buffer, Else, if using URI, this function will write the buffer and return the number of written bytes.

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
8.0.0 | This function can no longer return false.


End current element

  • ? XMLWriter::flush
  • XMLWriter::openMemory ?
  • PHP Manual
  • XMLWriter
  • End current element

XMLWriter::fullEndElement

xmlwriter_full_end_element

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL xmlwriter >= 2.0.4)

XMLWriter::fullEndElement -- xmlwriter_full_end_element — End current element

说明

面向对象风格

public XMLWriter::fullEndElement ( ) : bool

过程化风格

xmlwriter_full_end_element ( XMLWriter $writer ) : bool

End the current xml element. Writes an end tag even if the element is empty.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endElement() - End current element


Create new xmlwriter using memory for string output

  • ? XMLWriter::fullEndElement
  • XMLWriter::openUri ?
  • PHP Manual
  • XMLWriter
  • Create new xmlwriter using memory for string output

XMLWriter::openMemory

xmlwriter_open_memory

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::openMemory -- xmlwriter_open_memory — Create new xmlwriter using memory for string output

说明

面向对象风格

public XMLWriter::openMemory ( ) : bool

过程化风格

xmlwriter_open_memory ( ) : XMLWriter|false

Creates a new XMLWriter using memory for string output.

参数

返回值

面向对象风格: 成功时返回 true， 或者在失败时返回 false。

过程化风格: Returns a new XMLWriter for later use with the xmlwriter functions on success, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | This function returns now an XMLWriter instance on success. Previouly, a 资源(resource) has been returned in this case.

参见

  • XMLWriter::openUri() - Create new xmlwriter using source uri for output


Create new xmlwriter using source uri for output

  • ? XMLWriter::openMemory
  • XMLWriter::outputMemory ?
  • PHP Manual
  • XMLWriter
  • Create new xmlwriter using source uri for output

XMLWriter::openUri

xmlwriter_open_uri

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::openUri -- xmlwriter_open_uri — Create new xmlwriter using source uri for output

说明

面向对象风格

public XMLWriter::openUri ( string $uri ) : bool

过程化风格

xmlwriter_open_uri ( string $uri ) : XMLWriter|false

Creates a new XMLWriter using uri for the output.

参数

uri

The URI of the resource for the output.

返回值

面向对象风格: 成功时返回 true， 或者在失败时返回 false。

过程化风格: Returns a new XMLWriter instance for later use with the xmlwriter functions on success, 或者在失败时返回 false.

更新日志

版本 | 说明
8.0.0 | This function returns now an XMLWriter instance on success. Previouly, a 资源(resource) has been returned in this case.

范例

Example #1 Direct output of XML

It is possible to directly output XML by using the php://output stream wrapper.

<?php
$out =new XMLWriter();
$out->openURI('php://output');
?>

注释

Note:

On Windows, files opened with this function are locked until the writer is released.

参见

  • XMLWriter::openMemory() - Create new xmlwriter using memory for string output


Returns current buffer

  • ? XMLWriter::openUri
  • XMLWriter::setIndent ?
  • PHP Manual
  • XMLWriter
  • Returns current buffer

XMLWriter::outputMemory

xmlwriter_output_memory

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::outputMemory -- xmlwriter_output_memory — Returns current buffer

说明

面向对象风格

public XMLWriter::outputMemory ( bool $flush = true ) : string

过程化风格

xmlwriter_output_memory ( XMLWriter $writer , bool $flush = true ) : string

Returns the current buffer.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

flush

Whether to flush the output buffer or not. Default is true.

返回值

Returns the current buffer as a string.

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::flush() - Flush current buffer


Toggle indentation on/off

  • ? XMLWriter::outputMemory
  • XMLWriter::setIndentString ?
  • PHP Manual
  • XMLWriter
  • Toggle indentation on/off

XMLWriter::setIndent

xmlwriter_set_indent

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::setIndent -- xmlwriter_set_indent — Toggle indentation on/off

说明

面向对象风格

public XMLWriter::setIndent ( bool $enable ) : bool

过程化风格

xmlwriter_set_indent ( XMLWriter $writer , bool $enable ) : bool

Toggles indentation on or off.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

enable

Whether indentation is enabled.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

范例

Example #1 XMLWriter::setIndent() and mixed Content

Enabling indentation is not suitable for mixed content, because the indent string is also inserted before inline elements.

<?php
$writer = new XMLWriter();
$writer->openMemory();
$writer->setIndent(2);
$writer->startDocument();
$writer->startElement('p');
$writer->text('before');
$writer->writeElement('a', 'element');
$writer->text('after');
$writer->endElement();
$writer->endDocument();
echo $writer->outputMemory();
?>

以上例程会输出：

<?xml version="1.0"?>
<p>before <a>element</a>
after</p>

注释

Note:

The indent is reset when an xmlwriter is opened.

参见

  • XMLWriter::setIndentString() - Set string used for indenting


Set string used for indenting

  • ? XMLWriter::setIndent
  • XMLWriter::startAttribute ?
  • PHP Manual
  • XMLWriter
  • Set string used for indenting

XMLWriter::setIndentString

xmlwriter_set_indent_string

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::setIndentString -- xmlwriter_set_indent_string — Set string used for indenting

说明

面向对象风格

public XMLWriter::setIndentString ( string $indentation ) : bool

过程化风格

xmlwriter_set_indent_string ( XMLWriter $writer , string $indentation ) : bool

Sets the string which will be used to indent each element/attribute of the resulting xml.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

indentation

The indentation string.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

注释

Note:

The indent is reset when an xmlwriter is opened.

参见

  • XMLWriter::setIndent() - Toggle indentation on/off


Create start attribute

  • ? XMLWriter::setIndentString
  • XMLWriter::startAttributeNs ?
  • PHP Manual
  • XMLWriter
  • Create start attribute

XMLWriter::startAttribute

xmlwriter_start_attribute

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startAttribute -- xmlwriter_start_attribute — Create start attribute

说明

面向对象风格

public XMLWriter::startAttribute ( string $name ) : bool

过程化风格

xmlwriter_start_attribute ( XMLWriter $writer , string $name ) : bool

Starts an attribute.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The attribute name.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

范例

Example #1 Basic XMLWriter::startAttribute() Usage

<?php
$writer = new XMLWriter;
$writer->openURI('php://output');
$writer->startDocument('1.0', 'UTF-8');?>
$writer->startElement('element');
$writer->startAttribute('attribute');
$writer->text('value');
$writer->endAttribute();
$writer->endElement();
$writer->endDocument();

以上例程的输出类似于：

<?xml version="1.0" encoding="UTF-8"?>
<element attribute="value"/>

参见

  • XMLWriter::startAttributeNs() - Create start namespaced attribute
  • XMLWriter::endAttribute() - End attribute
  • XMLWriter::writeAttribute() - Write full attribute
  • XMLWriter::writeAttributeNs() - Write full namespaced attribute


Create start namespaced attribute

  • ? XMLWriter::startAttribute
  • XMLWriter::startCdata ?
  • PHP Manual
  • XMLWriter
  • Create start namespaced attribute

XMLWriter::startAttributeNs

xmlwriter_start_attribute_ns

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startAttributeNs -- xmlwriter_start_attribute_ns — Create start namespaced attribute

说明

面向对象风格

public XMLWriter::startAttributeNs ( string|null $prefix , string $name , string|null $namespace ) : bool

过程化风格

xmlwriter_start_attribute_ns ( XMLWriter $writer , string|null $prefix , string $name , string|null $namespace ) : bool

Starts a namespaced attribute.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

prefix

The namespace prefix.

name

The attribute name.

namespace

The namespace URI. If namespace is null, the namespace declaration will be omitted.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
8.0.0 | prefix is nullable now.

参见

  • XMLWriter::startAttribute() - Create start attribute
  • XMLWriter::endAttribute() - End attribute
  • XMLWriter::writeAttribute() - Write full attribute
  • XMLWriter::writeAttributeNs() - Write full namespaced attribute


Create start CDATA tag

  • ? XMLWriter::startAttributeNs
  • XMLWriter::startComment ?
  • PHP Manual
  • XMLWriter
  • Create start CDATA tag

XMLWriter::startCdata

xmlwriter_start_cdata

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startCdata -- xmlwriter_start_cdata — Create start CDATA tag

说明

面向对象风格

public XMLWriter::startCdata ( ) : bool

过程化风格

xmlwriter_start_cdata ( XMLWriter $writer ) : bool

Starts a CDATA.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endCdata() - End current CDATA
  • XMLWriter::writeCdata() - Write full CDATA tag


Create start comment

  • ? XMLWriter::startCdata
  • XMLWriter::startDocument ?
  • PHP Manual
  • XMLWriter
  • Create start comment

XMLWriter::startComment

xmlwriter_start_comment

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 1.0.0)

XMLWriter::startComment -- xmlwriter_start_comment — Create start comment

说明

面向对象风格

public XMLWriter::startComment ( ) : bool

过程化风格

xmlwriter_start_comment ( XMLWriter $writer ) : bool

Starts a comment.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endComment() - Create end comment
  • XMLWriter::writeComment() - Write full comment tag


Create document tag

  • ? XMLWriter::startComment
  • XMLWriter::startDtd ?
  • PHP Manual
  • XMLWriter
  • Create document tag

XMLWriter::startDocument

xmlwriter_start_document

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDocument -- xmlwriter_start_document — Create document tag

说明

面向对象风格

public XMLWriter::startDocument ( string|null $version = "1.0" , string|null $encoding = null , string|null $standalone = null ) : bool

过程化风格

xmlwriter_start_document ( XMLWriter $writer , string|null $version = "1.0" , string|null $encoding = null , string|null $standalone = null ) : bool

Starts a document.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

version

The version number of the document as part of the XML declaration.

encoding

The encoding of the document as part of the XML declaration.

standalone

yes or no.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endDocument() - End current document


Create start DTD tag

  • ? XMLWriter::startDocument
  • XMLWriter::startDtdAttlist ?
  • PHP Manual
  • XMLWriter
  • Create start DTD tag

XMLWriter::startDtd

xmlwriter_start_dtd

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDtd -- xmlwriter_start_dtd — Create start DTD tag

说明

面向对象风格

public XMLWriter::startDtd ( string $qualifiedName , string|null $publicId = null , string|null $systemId = null ) : bool

过程化风格

xmlwriter_start_dtd ( XMLWriter $writer , string $qualifiedName , string|null $publicId = null , string|null $systemId = null ) : bool

Starts a DTD.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

qualifiedName

The qualified name of the document type to create.

publicId

The external subset public identifier.

systemId

The external subset system identifier.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endDtd() - End current DTD
  • XMLWriter::writeDtd() - Write full DTD tag


Create start DTD AttList

  • ? XMLWriter::startDtd
  • XMLWriter::startDtdElement ?
  • PHP Manual
  • XMLWriter
  • Create start DTD AttList

XMLWriter::startDtdAttlist

xmlwriter_start_dtd_attlist

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDtdAttlist -- xmlwriter_start_dtd_attlist — Create start DTD AttList

说明

面向对象风格

public XMLWriter::startDtdAttlist ( string $name ) : bool

过程化风格

xmlwriter_start_dtd_attlist ( XMLWriter $writer , string $name ) : bool

Starts a DTD attribute list.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The attribute list name.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endDtdAttlist() - End current DTD AttList
  • XMLWriter::writeDtdAttlist() - Write full DTD AttList tag


Create start DTD element

  • ? XMLWriter::startDtdAttlist
  • XMLWriter::startDtdEntity ?
  • PHP Manual
  • XMLWriter
  • Create start DTD element

XMLWriter::startDtdElement

xmlwriter_start_dtd_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDtdElement -- xmlwriter_start_dtd_element — Create start DTD element

说明

面向对象风格

public XMLWriter::startDtdElement ( string $qualifiedName ) : bool

过程化风格

xmlwriter_start_dtd_element ( XMLWriter $writer , string $qualifiedName ) : bool

Starts a DTD element.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

qualifiedName

The qualified name of the document type to create.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endDtdElement() - End current DTD element
  • XMLWriter::writeDtdElement() - Write full DTD element tag


Create start DTD Entity

  • ? XMLWriter::startDtdElement
  • XMLWriter::startElement ?
  • PHP Manual
  • XMLWriter
  • Create start DTD Entity

XMLWriter::startDtdEntity

xmlwriter_start_dtd_entity

(PHP 5 >= 5.2.1, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startDtdEntity -- xmlwriter_start_dtd_entity — Create start DTD Entity

说明

面向对象风格

public XMLWriter::startDtdEntity ( string $name , bool $isParam ) : bool

过程化风格

xmlwriter_start_dtd_entity ( XMLWriter $writer , string $name , bool $isParam ) : bool

Starts a DTD entity.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The name of the entity.

isParam

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endDtdEntity() - End current DTD Entity
  • XMLWriter::writeDtdEntity() - Write full DTD Entity tag


Create start element tag

  • ? XMLWriter::startDtdEntity
  • XMLWriter::startElementNs ?
  • PHP Manual
  • XMLWriter
  • Create start element tag

XMLWriter::startElement

xmlwriter_start_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startElement -- xmlwriter_start_element — Create start element tag

说明

面向对象风格

public XMLWriter::startElement ( string $name ) : bool

过程化风格

xmlwriter_start_element ( XMLWriter $writer , string $name ) : bool

Starts an element.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The element name.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endElement() - End current element
  • XMLWriter::writeElement() - Write full element tag


Create start namespaced element tag

  • ? XMLWriter::startElement
  • XMLWriter::startPi ?
  • PHP Manual
  • XMLWriter
  • Create start namespaced element tag

XMLWriter::startElementNs

xmlwriter_start_element_ns

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startElementNs -- xmlwriter_start_element_ns — Create start namespaced element tag

说明

面向对象风格

public XMLWriter::startElementNs ( string|null $prefix , string $name , string|null $namespace ) : bool

过程化风格

xmlwriter_start_element_ns ( XMLWriter $writer , string|null $prefix , string $name , string|null $namespace ) : bool

Starts a namespaced element.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

prefix

The namespace prefix. If prefix is null, the namespace will be omitted.

name

The element name.

namespace

The namespace URI. If namespace is null, the namespace declaration will be omitted.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endElement() - End current element
  • XMLWriter::writeElementNs() - Write full namespaced element tag


Create start PI tag

  • ? XMLWriter::startElementNs
  • XMLWriter::text ?
  • PHP Manual
  • XMLWriter
  • Create start PI tag

XMLWriter::startPi

xmlwriter_start_pi

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::startPi -- xmlwriter_start_pi — Create start PI tag

说明

面向对象风格

public XMLWriter::startPi ( string $target ) : bool

过程化风格

xmlwriter_start_pi ( XMLWriter $writer , string $target ) : bool

Starts a processing instruction tag.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

target

The target of the processing instruction.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::endPi() - End current PI
  • XMLWriter::writePi() - Writes a PI


Write text

  • ? XMLWriter::startPi
  • XMLWriter::writeAttribute ?
  • PHP Manual
  • XMLWriter
  • Write text

XMLWriter::text

xmlwriter_text

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::text -- xmlwriter_text — Write text

说明

面向对象风格

public XMLWriter::text ( string $content ) : bool

过程化风格

xmlwriter_text ( XMLWriter $writer , string $content ) : bool

Writes a text.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

content

The contents of the text. The characters <, >, & and " are written as entity references (i.e. &lt;, &gt;, &amp; and &quot;, respectively). All other characters including ' are written literally. To write the special XML characters literally, or to write literal entity references, xmlwriter_write_raw() has to be used.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。


Write full attribute

  • ? XMLWriter::text
  • XMLWriter::writeAttributeNs ?
  • PHP Manual
  • XMLWriter
  • Write full attribute

XMLWriter::writeAttribute

xmlwriter_write_attribute

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeAttribute -- xmlwriter_write_attribute — Write full attribute

说明

面向对象风格

public XMLWriter::writeAttribute ( string $name , string $value ) : bool

过程化风格

xmlwriter_write_attribute ( XMLWriter $writer , string $name , string $value ) : bool

Writes a full attribute.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The name of the attribute.

value

The value of the attribute.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

范例

Example #1 Intermixing Sub-elements and Attributes

If writing sub-elements and attributes is intermixed, any attempt to write attributes after the first sub-element will fail and return false.

<?php
$xml = new XMLWriter();
$xml->openMemory();

$xml->startElement('element');
$xml->writeAttribute('attr1', '0');
$xml->writeElement('subelem', '0');
var_dump($xml->writeAttribute('attr2', '0'));
$xml->endElement();

echo $xml->flush();
?>

以上例程会输出：

bool(false)
<element attr1="0"><subelem>0</subelem></element>

参见

  • XMLWriter::writeAttributeNs() - Write full namespaced attribute
  • XMLWriter::startAttribute() - Create start attribute
  • XMLWriter::startAttributeNs() - Create start namespaced attribute
  • XMLWriter::endAttribute() - End attribute


Write full namespaced attribute

  • ? XMLWriter::writeAttribute
  • XMLWriter::writeCdata ?
  • PHP Manual
  • XMLWriter
  • Write full namespaced attribute

XMLWriter::writeAttributeNs

xmlwriter_write_attribute_ns

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeAttributeNs -- xmlwriter_write_attribute_ns — Write full namespaced attribute

说明

面向对象风格

public XMLWriter::writeAttributeNs ( string|null $prefix , string $name , string|null $namespace , string $value ) : bool

过程化风格

xmlwriter_write_attribute_ns ( XMLWriter $writer , string|null $prefix , string $name , string|null $namespace , string $value ) : bool

Writes a full namespaced attribute.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

prefix

The namespace prefix. If prefix is null, the namespace will be omitted.

name

The attribute name.

namespace

The namespace URI. If namespace is null, the namespace declaration will be omitted.

value

The attribute value.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::writeAttribute() - Write full attribute
  • XMLWriter::startAttribute() - Create start attribute
  • XMLWriter::startAttributeNs() - Create start namespaced attribute
  • XMLWriter::endAttribute() - End attribute


Write full CDATA tag

  • ? XMLWriter::writeAttributeNs
  • XMLWriter::writeComment ?
  • PHP Manual
  • XMLWriter
  • Write full CDATA tag

XMLWriter::writeCdata

xmlwriter_write_cdata

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeCdata -- xmlwriter_write_cdata — Write full CDATA tag

说明

面向对象风格

public XMLWriter::writeCdata ( string $content ) : bool

过程化风格

xmlwriter_write_cdata ( XMLWriter $writer , string $content ) : bool

Writes a full CDATA.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

content

The contents of the CDATA.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

范例

Example #1 Basic xmlwriter_write_cdata() Usage

<?php
// set up the document
$xml = new XmlWriter();
$xml->openMemory();
$xml->setIndent(true);
$xml->startDocument('1.0', 'UTF-8');
$xml->startElement('mydoc');
$xml->startElement('myele');

// CData output
$xml->startElement('mycdataelement');
$xml->writeCData("text for inclusion as CData");
$xml->endElement();

// end the document and output
$xml->endElement();
$xml->endElement();
echo $xml->outputMemory(true);
?>

以上例程会输出：

<mydoc>
 <myele>
  <mycdataelement><![CDATA[text for inclusion as CData]?]></mycdataelement>
 </myele>
</mydoc>

参见

  • XMLWriter::startCdata() - Create start CDATA tag
  • XMLWriter::endCdata() - End current CDATA


Write full comment tag

  • ? XMLWriter::writeCdata
  • XMLWriter::writeDtd ?
  • PHP Manual
  • XMLWriter
  • Write full comment tag

XMLWriter::writeComment

xmlwriter_write_comment

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeComment -- xmlwriter_write_comment — Write full comment tag

说明

面向对象风格

public XMLWriter::writeComment ( string $content ) : bool

过程化风格

xmlwriter_write_comment ( XMLWriter $writer , string $content ) : bool

Writes a full comment.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

content

The contents of the comment.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startComment() - Create start comment
  • XMLWriter::endComment() - Create end comment


Write full DTD tag

  • ? XMLWriter::writeComment
  • XMLWriter::writeDtdAttlist ?
  • PHP Manual
  • XMLWriter
  • Write full DTD tag

XMLWriter::writeDtd

xmlwriter_write_dtd

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDtd -- xmlwriter_write_dtd — Write full DTD tag

说明

面向对象风格

public XMLWriter::writeDtd ( string $name , string|null $publicId = null , string|null $systemId = null , string|null $content = null ) : bool

过程化风格

xmlwriter_write_dtd ( XMLWriter $writer , string $name , string|null $publicId = null , string|null $systemId = null , string|null $content = null ) : bool

Writes a full DTD.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The DTD name.

publicId

The external subset public identifier.

systemId

The external subset system identifier.

content

The content of the DTD.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startDtd() - Create start DTD tag
  • XMLWriter::endDtd() - End current DTD


Write full DTD AttList tag

  • ? XMLWriter::writeDtd
  • XMLWriter::writeDtdElement ?
  • PHP Manual
  • XMLWriter
  • Write full DTD AttList tag

XMLWriter::writeDtdAttlist

xmlwriter_write_dtd_attlist

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDtdAttlist -- xmlwriter_write_dtd_attlist — Write full DTD AttList tag

说明

面向对象风格

public XMLWriter::writeDtdAttlist ( string $name , string $content ) : bool

过程化风格

xmlwriter_write_dtd_attlist ( XMLWriter $writer , string $name , string $content ) : bool

Writes a DTD attribute list.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The name of the DTD attribute list.

content

The content of the DTD attribute list.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startDtdAttlist() - Create start DTD AttList
  • XMLWriter::endDtdAttlist() - End current DTD AttList


Write full DTD element tag

  • ? XMLWriter::writeDtdAttlist
  • XMLWriter::writeDtdEntity ?
  • PHP Manual
  • XMLWriter
  • Write full DTD element tag

XMLWriter::writeDtdElement

xmlwriter_write_dtd_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDtdElement -- xmlwriter_write_dtd_element — Write full DTD element tag

说明

面向对象风格

public XMLWriter::writeDtdElement ( string $name , string $content ) : bool

过程化风格

xmlwriter_write_dtd_element ( XMLWriter $writer , string $name , string $content ) : bool

Writes a full DTD element.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The name of the DTD element.

content

The content of the element.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startDtdElement() - Create start DTD element
  • XMLWriter::endDtdElement() - End current DTD element


Write full DTD Entity tag

  • ? XMLWriter::writeDtdElement
  • XMLWriter::writeElement ?
  • PHP Manual
  • XMLWriter
  • Write full DTD Entity tag

XMLWriter::writeDtdEntity

xmlwriter_write_dtd_entity

(PHP 5 >= 5.2.1, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDtdEntity -- xmlwriter_write_dtd_entity — Write full DTD Entity tag

说明

面向对象风格

public XMLWriter::writeDtdEntity ( string $name , string $content , bool $isParam = false , string|null $publicId = null , string|null $systemId = null , string|null $notationData = null ) : bool

过程化风格

xmlwriter_write_dtd_entity ( XMLWriter $writer , string $name , string $content , bool $isParam = false , string|null $publicId = null , string|null $systemId = null , string|null $notationData = null ) : bool

Writes a full DTD entity.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The name of the entity.

content

The content of the entity.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
8.0.0 | publicId, systemId and notationData are nullable now.

参见

  • XMLWriter::startDtdEntity() - Create start DTD Entity
  • XMLWriter::endDtdEntity() - End current DTD Entity


Write full element tag

  • ? XMLWriter::writeDtdEntity
  • XMLWriter::writeElementNs ?
  • PHP Manual
  • XMLWriter
  • Write full element tag

XMLWriter::writeElement

xmlwriter_write_element

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeElement -- xmlwriter_write_element — Write full element tag

说明

面向对象风格

public XMLWriter::writeElement ( string $name , string|null $content = null ) : bool

过程化风格

xmlwriter_write_element ( XMLWriter $writer , string $name , string|null $content = null ) : bool

Writes a full element tag.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

name

The element name.

content

The element contents.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startElement() - Create start element tag
  • XMLWriter::endElement() - End current element
  • XMLWriter::writeElementNs() - Write full namespaced element tag


Write full namespaced element tag

  • ? XMLWriter::writeElement
  • XMLWriter::writePi ?
  • PHP Manual
  • XMLWriter
  • Write full namespaced element tag

XMLWriter::writeElementNs

xmlwriter_write_element_ns

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writeElementNs -- xmlwriter_write_element_ns — Write full namespaced element tag

说明

面向对象风格

public XMLWriter::writeElementNs ( string|null $prefix , string $name , string|null $namespace , string|null $content = null ) : bool

过程化风格

xmlwriter_write_element_ns ( XMLWriter $writer , string|null $prefix , string $name , string|null $namespace , string|null $content = null ) : bool

Writes a full namespaced element tag.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

prefix

The namespace prefix. If prefix is null, the namespace will be omitted.

name

The element name.

namespace

The namespace URI. If namespace is null, the namespace declaration will be omitted.

content

The element contents.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startElementNs() - Create start namespaced element tag
  • XMLWriter::endElement() - End current element
  • XMLWriter::writeElement() - Write full element tag


Writes a PI

  • ? XMLWriter::writeElementNs
  • XMLWriter::writeRaw ?
  • PHP Manual
  • XMLWriter
  • Writes a PI

XMLWriter::writePi

xmlwriter_write_pi

(PHP 5 >= 5.1.2, PHP 7, PHP 8, PECL xmlwriter >= 0.1.0)

XMLWriter::writePi -- xmlwriter_write_pi — Writes a PI

说明

面向对象风格

public XMLWriter::writePi ( string $target , string $content ) : bool

过程化风格

xmlwriter_write_pi ( XMLWriter $writer , string $target , string $content ) : bool

Writes a processing instruction.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

target

The target of the processing instruction.

content

The content of the processing instruction.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::startPi() - Create start PI tag
  • XMLWriter::endPi() - End current PI


Write a raw XML text

  • ? XMLWriter::writePi
  • XSL ?
  • PHP Manual
  • XMLWriter
  • Write a raw XML text

XMLWriter::writeRaw

xmlwriter_write_raw

(PHP 5 >= 5.2.0, PHP 7, PHP 8, PECL xmlwriter >= 2.0.4)

XMLWriter::writeRaw -- xmlwriter_write_raw — Write a raw XML text

说明

面向对象风格

public XMLWriter::writeRaw ( string $content ) : bool

过程化风格

xmlwriter_write_raw ( XMLWriter $writer , string $content ) : bool

Writes a raw xml text.

参数

xmlwriter

仅用于过程调用。被修改的 XMLWriter 实例对象。此资源来自于对 xmlwriter_open_uri() 或 xmlwriter_open_memory() 的调用。

content

The text string to write.

返回值

成功时返回 true， 或者在失败时返回 false。

更新日志

版本 | 说明
8.0.0 | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。

参见

  • XMLWriter::text() - Write text


XSL

  • 简介
  • 安装／配置
    • 需求
    • 安装
    • 运行时配置
    • 资源类型
  • 预定义常量
  • 范例
    • Example collection.xml and collection.xsl files
    • Error handling with libxml error handling functions
  • XSLTProcessor — The XSLTProcessor class
    • XSLTProcessor::__construct — Creates a new XSLTProcessor object
    • XSLTProcessor::getParameter — Get value of a parameter
    • XSLTProcessor::getSecurityPrefs — Get security preferences
    • XSLTProcessor::hasExsltSupport — Determine if PHP has EXSLT support
    • XSLTProcessor::importStylesheet — Import stylesheet
    • XSLTProcessor::registerPHPFunctions — Enables the ability to use PHP functions as XSLT functions
    • XSLTProcessor::removeParameter — Remove parameter
    • XSLTProcessor::setParameter — Set value for a parameter
    • XSLTProcessor::setProfiling — Sets profiling output file
    • XSLTProcessor::setSecurityPrefs — Set security preferences
    • XSLTProcessor::transformToDoc — Transform to a DOMDocument
    • XSLTProcessor::transformToUri — Transform to URI
    • XSLTProcessor::transformToXml — Transform to XML


简介

The XSL extension implements the XSL standard, performing » XSLT transformations using the » libxslt library


需求

此扩展需要 libxml PHP 扩展。这表示需要使用 --with-libxml，或在 PHP 7.4 之前的版本中使用 --enable-libxml， 尽管这将隐式完成因为 libxml 是缺省开启的。

This extension uses libxslt which can be found at » http://xmlsoft.org/XSLT/. libxslt version 1.1.0 or greater is required.


安装

PHP 5 includes the XSL extension by default and can be enabled by adding the argument --with-xsl[=DIR] to your configure line (DIR being the libxslt installation directory).


预定义常量

下列常量由此扩展定义，且仅在此扩展编译入 PHP 或在运行时动态载入时可用。

XSL_CLONE_AUTO (int)
XSL_CLONE_NEVER (int)
XSL_CLONE_ALWAYS (int)
LIBXSLT_VERSION (int)
libxslt version like 10117. Available as of PHP 5.1.2.
LIBXSLT_DOTTED_VERSION (string)
libxslt version like 1.1.17. Available as of PHP 5.1.2.
LIBEXSLT_VERSION (int)
libexslt version like 813. Available as of PHP 5.1.2.
LIBEXSLT_DOTTED_VERSION (string)
libexslt version like 1.1.17. Available as of PHP 5.1.2.
XSL_SECPREF_NONE (int)
Deactivate all security restrictions.
XSL_SECPREF_READ_FILE (int)
Disallows reading files.
XSL_SECPREF_WRITE_FILE (int)
Disallows writing files.
XSL_SECPREF_CREATE_DIRECTORY (int)
Disallows creating directories.
XSL_SECPREF_READ_NETWORK (int)
Disallows reading network files.
XSL_SECPREF_WRITE_NETWORK (int)
Disallows writing network files.
XSL_SECPREF_DEFAULT (int)
Disallows all write access, i.e. a bitmask of XSL_SECPREF_WRITE_NETWORK | XSL_SECPREF_CREATE_DIRECTORY | XSL_SECPREF_WRITE_FILE.


范例

Table of Contents

  • Example collection.xml and collection.xsl files
  • Error handling with libxml error handling functions


Example collection.xml and collection.xsl files

Many examples in this reference require both an XML and an XSL file. We will use collection.xml and collection.xsl that contains the following:

Example #1 collection.xml

<collection>
 <cd>
  <title>Fight for your mind</title>
  <artist>Ben Harper</artist>
  <year>1995</year>
 </cd>
 <cd>
  <title>Electric Ladyland</title>
  <artist>Jimi Hendrix</artist>
  <year>1997</year>
 </cd>
</collection>

Example #2 collection.xsl

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
 <xsl:param name="owner" select="'Nicolas Eliaszewicz'"/>
 <xsl:output method="html" encoding="iso-8859-1" indent="no"/>
 <xsl:template match="collection">
  Hey! Welcome to <xsl:value-of select="$owner"/>'s sweet CD collection!
  <xsl:apply-templates/>
 </xsl:template>
 <xsl:template match="cd">
  <h1><xsl:value-of select="title"/></h1>
  <h2>by <xsl:value-of select="artist"/> - <xsl:value-of select="year"/></h2>
  <hr />
 </xsl:template>
</xsl:stylesheet>


Error handling with libxml error handling functions

libxml offers a number of functions for handling errors, which can be employed to capture and deal with errors in XSLT processing.

Example #1 fruits.xml

A valid XML file.

<fruits>
 <fruit>Apple</fruit>
 <fruit>Banana</fruit>
 <fruit>Cherry</fruit>
</fruits>

Example #2 fruits.xsl

Contains an invalid select expression.

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
 <xsl:output method="html" encoding="utf-8" indent="no"/>
 <xsl:template match="fruits">
  <ul>
   <xsl:apply-templates/>
  </ul>
 </xsl:template>
 <xsl:template match="fruit">
  <li><xsl:value-of select="THIS IS A DELIBERATE ERROR!"/></li>
 </xsl:template>
</xsl:stylesheet>

Example #3 Collating and printing errors

The example below captures and displays libxml errors raised when calling XSLTProcessor::importStyleSheet() with a stylesheet containing an error.

<?php

$xmldoc = new DOMDocument();
$xsldoc = new DOMDocument();
$xsl = new XSLTProcessor();

$xmldoc->loadXML('fruits.xml');
$xsldoc->loadXML('fruits.xsl');

libxml_use_internal_errors(true);
$result = $xsl->importStyleSheet($xsldoc);
if (!$result) {
    foreach (libxml_get_errors() as $error) {
        echo "Libxml error: {$error->message}\n";
    }
}
libxml_use_internal_errors(false);

if ($result) {
    echo $xsl->transformToXML($xmldoc);
}

?>

以上例程的输出类似于：

Libxml error: Invalid expression

Libxml error: compilation error: file fruits.xsl line 9 element value-of
Libxml error: xsl:value-of : could not compile select expression 'THIS IS A DELIBERATE ERROR!'


The XSLTProcessor class

(PHP 5, PHP 7, PHP 8)

简介

类摘要

XSLTProcessor {
/* 方法 */
public getParameter ( string $namespace , string $name ) : string|false
public getSecurityPrefs ( ) : int
public hasExsltSupport ( ) : bool
public importStylesheet ( object $stylesheet ) : bool
public registerPHPFunctions ( array|string|null $functions = null ) : void
public removeParameter ( string $namespace , string $name ) : bool
public setParameter ( string $namespace , string $name , string $value ) : bool
public setProfiling ( string|null $filename ) : bool
public setSecurityPrefs ( int $preferences ) : int
public transformToDoc ( object $document , string|null $returnClass = null ) : DOMDocument|false
transformToURI ( DOMDocument $doc , string $uri ) : int
public transformToXml ( object $document ) : string|false|null
}

Table of Contents

  • XSLTProcessor::__construct — Creates a new XSLTProcessor object
  • XSLTProcessor::getParameter — Get value of a parameter
  • XSLTProcessor::getSecurityPrefs — Get security preferences
  • XSLTProcessor::hasExsltSupport — Determine if PHP has EXSLT support
  • XSLTProcessor::importStylesheet — Import stylesheet
  • XSLTProcessor::registerPHPFunctions — Enables the ability to use PHP functions as XSLT functions
  • XSLTProcessor::removeParameter — Remove parameter
  • XSLTProcessor::setParameter — Set value for a parameter
  • XSLTProcessor::setProfiling — Sets profiling output file
  • XSLTProcessor::setSecurityPrefs — Set security preferences
  • XSLTProcessor::transformToDoc — Transform to a DOMDocument
  • XSLTProcessor::transformToUri — Transform to URI
  • XSLTProcessor::transformToXml — Transform to XML


Creates a new XSLTProcessor object

  • ? XSLTProcessor
  • XSLTProcessor::getParameter ?
  • PHP Manual
  • XSLTProcessor
  • Creates a new XSLTProcessor object

XSLTProcessor::__construct

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::__construct — Creates a new XSLTProcessor object

说明

XSLTProcessor::__construct ( )

Creates a new XSLTProcessor object.

参数

此函数没有参数。

返回值

没有返回值。

范例

Example #1 Creating an XSLTProcessor

<?php

$xsldoc = new DOMDocument();
$xsldoc->load($xsl_filename);

$xmldoc = new DOMDocument();
$xmldoc->load($xml_filename);

$xsl = new XSLTProcessor();
$xsl->importStyleSheet($xsldoc);
echo $xsl->transformToXML($xmldoc);

?>


Get value of a parameter

  • ? XSLTProcessor::__construct
  • XSLTProcessor::getSecurityPrefs ?
  • PHP Manual
  • XSLTProcessor
  • Get value of a parameter

XSLTProcessor::getParameter

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::getParameter — Get value of a parameter

说明

public XSLTProcessor::getParameter ( string $namespace , string $name ) : string|false

Gets a parameter if previously set by XSLTProcessor::setParameter().

参数

namespace

The namespace URI of the XSLT parameter.

name

The local name of the XSLT parameter.

返回值

The value of the parameter (as a string), or false if it's not set.

参见

  • XSLTProcessor::setParameter() - Set value for a parameter
  • XSLTProcessor::removeParameter() - Remove parameter


Get security preferences

  • ? XSLTProcessor::getParameter
  • XSLTProcessor::hasExsltSupport ?
  • PHP Manual
  • XSLTProcessor
  • Get security preferences

XSLTProcessor::getSecurityPrefs

(PHP >= 5.4.0, PHP 7, PHP 8)

XSLTProcessor::getSecurityPrefs — Get security preferences

说明

public XSLTProcessor::getSecurityPrefs ( ) : int

Gets the security preferences.

参数

此函数没有参数。

返回值

A bitmask consisting of XSL_SECPREF_READ_FILE, XSL_SECPREF_WRITE_FILE, XSL_SECPREF_CREATE_DIRECTORY, XSL_SECPREF_READ_NETWORK, XSL_SECPREF_WRITE_NETWORK.


Determine if PHP has EXSLT support

  • ? XSLTProcessor::getSecurityPrefs
  • XSLTProcessor::importStylesheet ?
  • PHP Manual
  • XSLTProcessor
  • Determine if PHP has EXSLT support

XSLTProcessor::hasExsltSupport

(PHP 5 >= 5.0.4, PHP 7, PHP 8)

XSLTProcessor::hasExsltSupport — Determine if PHP has EXSLT support

说明

public XSLTProcessor::hasExsltSupport ( ) : bool

This method determines if PHP was built with the » EXSLT library.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Testing EXSLT support

<?php

$proc = new XSLTProcessor;
if (!$proc->hasExsltSupport()) {
    die('EXSLT support not available');
}

// do EXSLT stuff here ..

?>


Import stylesheet

  • ? XSLTProcessor::hasExsltSupport
  • XSLTProcessor::registerPHPFunctions ?
  • PHP Manual
  • XSLTProcessor
  • Import stylesheet

XSLTProcessor::importStylesheet

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::importStylesheet — Import stylesheet

说明

public XSLTProcessor::importStylesheet ( object $stylesheet ) : bool

This method imports the stylesheet into the XSLTProcessor for transformations.

参数

stylesheet

The imported style sheet as a DOMDocument or SimpleXMLElement object.

返回值

成功时返回 true， 或者在失败时返回 false。


Enables the ability to use PHP functions as XSLT functions

  • ? XSLTProcessor::importStylesheet
  • XSLTProcessor::removeParameter ?
  • PHP Manual
  • XSLTProcessor
  • Enables the ability to use PHP functions as XSLT functions

XSLTProcessor::registerPHPFunctions

(PHP 5 >= 5.0.4, PHP 7, PHP 8)

XSLTProcessor::registerPHPFunctions — Enables the ability to use PHP functions as XSLT functions

说明

public XSLTProcessor::registerPHPFunctions ( array|string|null $functions = null ) : void

This method enables the ability to use PHP functions as XSLT functions within XSL stylesheets.

参数

functions

Use this parameter to only allow certain functions to be called from XSLT.

This parameter can be either a string (a function name) or an array of functions.

返回值

没有返回值。

范例

Example #1 Simple PHP Function call from a stylesheet

<?php
$xml = <<<EOB
<allusers>
 <user>
  <uid>bob</uid>
 </user>
 <user>
  <uid>joe</uid>
 </user>
</allusers>
EOB;
$xsl = <<<EOB
<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0"
     xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
     xmlns:php="http://php.net/xsl">
<xsl:output method="html" encoding="utf-8" indent="yes"/>
 <xsl:template match="allusers">
  <html><body>
    <h2>Users</h2>
    <table>
    <xsl:for-each select="user">
      <tr><td>
        <xsl:value-of
             select="php:function('ucfirst',string(uid))"/>
      </td></tr>
    </xsl:for-each>
    </table>
  </body></html>
 </xsl:template>
</xsl:stylesheet>
EOB;
$xmldoc = DOMDocument::loadXML($xml);
$xsldoc = DOMDocument::loadXML($xsl);

$proc = new XSLTProcessor();
$proc->registerPHPFunctions();
$proc->importStyleSheet($xsldoc);
echo $proc->transformToXML($xmldoc);
?>


Remove parameter

  • ? XSLTProcessor::registerPHPFunctions
  • XSLTProcessor::setParameter ?
  • PHP Manual
  • XSLTProcessor
  • Remove parameter

XSLTProcessor::removeParameter

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::removeParameter — Remove parameter

说明

public XSLTProcessor::removeParameter ( string $namespace , string $name ) : bool

Removes a parameter, if set. This will make the processor use the default value for the parameter as specified in the stylesheet.

参数

namespace

The namespace URI of the XSLT parameter.

name

The local name of the XSLT parameter.

返回值

成功时返回 true， 或者在失败时返回 false。

参见

  • XSLTProcessor::setParameter() - Set value for a parameter
  • XSLTProcessor::getParameter() - Get value of a parameter


Set value for a parameter

  • ? XSLTProcessor::removeParameter
  • XSLTProcessor::setProfiling ?
  • PHP Manual
  • XSLTProcessor
  • Set value for a parameter

XSLTProcessor::setParameter

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::setParameter — Set value for a parameter

说明

public XSLTProcessor::setParameter ( string $namespace , string $name , string $value ) : bool
public XSLTProcessor::setParameter ( string $namespace , array $options ) : bool

Sets the value of one or more parameters to be used in subsequent transformations with XSLTProcessor. If the parameter doesn't exist in the stylesheet it will be ignored.

参数

namespace

The namespace URI of the XSLT parameter.

name

The local name of the XSLT parameter.

value

The new value of the XSLT parameter.

options

An array of name => value pairs.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Changing the owner before the transformation

<?php

$collections = array(
    'Marc Rutkowski' => 'marc',
    'Olivier Parmentier' => 'olivier'
);

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // attach the xsl rules

foreach ($collections as $name => $file) {
    // Load the XML source
    $xml = new DOMDocument;
    $xml->load('collection_' . $file . '.xml');

    $proc->setParameter('', 'owner', $name);
    $proc->transformToURI($xml, 'file:///tmp/' . $file . '.html');
}

?>

参见

  • XSLTProcessor::getParameter() - Get value of a parameter
  • XSLTProcessor::removeParameter() - Remove parameter


Sets profiling output file

  • ? XSLTProcessor::setParameter
  • XSLTProcessor::setSecurityPrefs ?
  • PHP Manual
  • XSLTProcessor
  • Sets profiling output file

XSLTProcessor::setProfiling

(PHP >= 5.3.0, PHP 7, PHP 8)

XSLTProcessor::setProfiling — Sets profiling output file

说明

public XSLTProcessor::setProfiling ( string|null $filename ) : bool

Sets the file to output profiling information when processing a stylesheet.

参数

filename

Path to the file to dump profiling information.

返回值

成功时返回 true， 或者在失败时返回 false。

范例

Example #1 Example profiling output

<?php
// Load the XML source
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->setProfiling('profiling.txt');
$proc->importStyleSheet($xsl); // attach the xsl rules

echo trim($proc->transformToDoc($xml)->firstChild->wholeText);
?>

The above code will produce the following information in the profiling file:

number               match                name      mode  Calls Tot 100us Avg

    0                   cd                                    2      3      1
    1           collection                                    1      1      1

                         Total                                3      4


Set security preferences

  • ? XSLTProcessor::setProfiling
  • XSLTProcessor::transformToDoc ?
  • PHP Manual
  • XSLTProcessor
  • Set security preferences

XSLTProcessor::setSecurityPrefs

(PHP >= 5.4.0, PHP 7, PHP 8)

XSLTProcessor::setSecurityPrefs — Set security preferences

说明

public XSLTProcessor::setSecurityPrefs ( int $preferences ) : int

Sets the security preferences.

参数

preferences

The new security preferences. The following constants can be ORed: XSL_SECPREF_READ_FILE, XSL_SECPREF_WRITE_FILE, XSL_SECPREF_CREATE_DIRECTORY, XSL_SECPREF_READ_NETWORK, XSL_SECPREF_WRITE_NETWORK. Alternatively, XSL_SECPREF_NONE or XSL_SECPREF_DEFAULT can be passed.

返回值

Returns the old security preferences.


Transform to a DOMDocument

  • ? XSLTProcessor::setSecurityPrefs
  • XSLTProcessor::transformToUri ?
  • PHP Manual
  • XSLTProcessor
  • Transform to a DOMDocument

XSLTProcessor::transformToDoc

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::transformToDoc — Transform to a DOMDocument

说明

public XSLTProcessor::transformToDoc ( object $document , string|null $returnClass = null ) : DOMDocument|false

Transforms the source node to a DOMDocument applying the stylesheet given by the XSLTProcessor::importStylesheet() method.

参数

document

The node to be transformed.

返回值

The resulting DOMDocument or false on error.

范例

Example #1 Transforming to a DOMDocument

<?php

// Load the XML source
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // attach the xsl rules

echo trim($proc->transformToDoc($xml)->firstChild->wholeText);

?>

以上例程会输出：

Hey! Welcome to Nicolas Eliaszewicz's sweet CD collection!

参见

  • XSLTProcessor::transformToUri() - Transform to URI
  • XSLTProcessor::transformToXml() - Transform to XML


Transform to URI

  • ? XSLTProcessor::transformToDoc
  • XSLTProcessor::transformToXml ?
  • PHP Manual
  • XSLTProcessor
  • Transform to URI

XSLTProcessor::transformToUri

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::transformToUri — Transform to URI

说明

XSLTProcessor::transformToURI ( DOMDocument $doc , string $uri ) : int

Transforms the source node to an URI applying the stylesheet given by the XSLTProcessor::importStylesheet() method.

参数

doc

The document to transform.

uri

The target URI for the transformation.

返回值

Returns the number of bytes written or false if an error occurred.

范例

Example #1 Transforming to a HTML file

<?php

// Load the XML source
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // attach the xsl rules

$proc->transformToURI($xml, 'file:///tmp/out.html');

?>

参见

  • XSLTProcessor::transformToDoc() - Transform to a DOMDocument
  • XSLTProcessor::transformToXml() - Transform to XML


Transform to XML

  • ? XSLTProcessor::transformToUri
  • 图形用户界面(GUI) 扩展 ?
  • PHP Manual
  • XSLTProcessor
  • Transform to XML

XSLTProcessor::transformToXml

(PHP 5, PHP 7, PHP 8)

XSLTProcessor::transformToXml — Transform to XML

说明

public XSLTProcessor::transformToXml ( object $document ) : string|false|null

Transforms the source node to a string applying the stylesheet given by the xsltprocessor::importStylesheet() method.

参数

document

The DOMDocument or SimpleXMLElement object to be transformed.

返回值

The result of the transformation as a string or false on error.

范例

Example #1 Transforming to a string

<?php

// Load the XML source
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // attach the xsl rules

echo $proc->transformToXML($xml);

?>

以上例程会输出：

Hey! Welcome to Nicolas Eliaszewicz's sweet CD collection!

<h1>Fight for your mind</h1><h2>by Ben Harper - 1995</h2><hr>
<h1>Electric Ladyland</h1><h2>by Jimi Hendrix - 1997</h2><hr>

参见

  • XSLTProcessor::transformToDoc() - Transform to a DOMDocument
  • XSLTProcessor::transformToUri() - Transform to URI


图形用户界面(GUI) 扩展

  • UI
    • 简介
    • 安装／配置
    • UI\Point — Represents a position (x,y)
    • UI\Size — Represents dimenstions (width, height)
    • UI\Window — Window
    • UI\Control — Control
    • UI\Menu — Menu
    • UI\MenuItem — Menu Item
    • UI\Area — Area
    • UI\Executor — Execution Scheduler
    • UI\Controls\Tab — Tab Control
    • UI\Controls\Check — Check Control
    • UI\Controls\Button — Button Control
    • UI\Controls\ColorButton — ColorButton Control
    • UI\Controls\Label — Label Control
    • UI\Controls\Entry — Entry Control
    • UI\Controls\MultilineEntry — MultilineEntry Control
    • UI\Controls\Spin — Spin Control
    • UI\Controls\Slider — Slider Control
    • UI\Controls\Progress — Progress Control
    • UI\Controls\Separator — Control Separator
    • UI\Controls\Combo — Combo Control
    • UI\Controls\EditableCombo — EdiableCombo Control
    • UI\Controls\Radio — Radio Control
    • UI\Controls\Picker — Picker Control
    • UI\Controls\Form — Control Form (Arrangement)
    • UI\Controls\Grid — Control Grid (Arrangement)
    • UI\Controls\Group — Control Group (Arrangement)
    • UI\Controls\Box — Control Box (Arrangement)
    • UI\Draw\Pen — Draw Pen
    • UI\Draw\Path — Draw Path
    • UI\Draw\Matrix — Draw Matrix
    • UI\Draw\Color — Color Representation
    • UI\Draw\Stroke — Draw Stroke
    • UI\Draw\Brush — Brushes
    • UI\Draw\Brush\Gradient — Gradient Brushes
    • UI\Draw\Brush\LinearGradient — Linear Gradient
    • UI\Draw\Brush\RadialGradient — Radial Gradient
    • UI\Draw\Text\Layout — Represents Text Layout
    • UI\Draw\Text\Font — Represents a Font
    • UI\Draw\Text\Font\Descriptor — Font Descriptor
    • UI 函数
    • UI\Draw\Text\Font\Weight — Font Weight Settings
    • UI\Draw\Text\Font\Italic — Italic Font Settings
    • UI\Draw\Text\Font\Stretch — Font Stretch Settings
    • UI\Draw\Line\Cap — Line Cap Settings
    • UI\Draw\Line\Join — Line Join Settings
    • UI\Key — Key Identifiers
    • UI\Exception\InvalidArgumentException — InvalidArgumentException
    • UI\Exception\RuntimeException — RuntimeException


UI

  • 简介
  • 安装／配置
    • 需求
    • 安装
  • UI\Point — Represents a position (x,y)
    • UI\Point::at — Size Coercion
    • UI\Point::__construct — Construct a new Point
    • UI\Point::getX — Retrieves X
    • UI\Point::getY — Retrieves Y
    • UI\Point::setX — Set X
    • UI\Point::setY — Set Y
  • UI\Size — Represents dimenstions (width, height)
    • UI\Size::__construct — Construct a new Size
    • UI\Size::getHeight — Retrieves Height
    • UI\Size::getWidth — Retrives Width
    • UI\Size::of — Point Coercion
    • UI\Size::setHeight — Set Height
    • UI\Size::setWidth — Set Width
  • UI\Window — Window
    • UI\Window::add — Add a Control
    • UI\Window::__construct — Construct a new Window
    • UI\Window::error — Show Error Box
    • UI\Window::getSize — Get Window Size
    • UI\Window::getTitle — Get Title
    • UI\Window::hasBorders — Border Detection
    • UI\Window::hasMargin — Margin Detection
    • UI\Window::isFullScreen — Full Screen Detection
    • UI\Window::msg — Show Message Box
    • UI\Window::onClosing — Closing Callback
    • UI\Window::open — Open Dialog
    • UI\Window::save — Save Dialog
    • UI\Window::setBorders — Border Use
    • UI\Window::setFullScreen — Full Screen Use
    • UI\Window::setMargin — Margin Use
    • UI\Window::setSize — Set Size
    • UI\Window::setTitle — Window Title
  • UI\Control — Control
    • UI\Control::destroy — Destroy Control
    • UI\Control::disable — Disable Control
    • UI\Control::enable — Enable Control
    • UI\Control::getParent — Get Parent Control
    • UI\Control::getTopLevel — Get Top Level
    • UI\Control::hide — Hide Control
    • UI\Control::isEnabled — Determine if Control is enabled
    • UI\Control::isVisible — Determine if Control is visible
    • UI\Control::setParent — Set Parent Control
    • UI\Control::show — Control Show
  • UI\Menu — Menu
    • UI\Menu::append — Append Menu Item
    • UI\Menu::appendAbout — Append About Menu Item
    • UI\Menu::appendCheck — Append Checkable Menu Item
    • UI\Menu::appendPreferences — Append Preferences Menu Item
    • UI\Menu::appendQuit — Append Quit Menu Item
    • UI\Menu::appendSeparator — Append Menu Item Separator
    • UI\Menu::__construct — Construct a new Menu
  • UI\MenuItem — Menu Item
    • UI\MenuItem::disable — Disable Menu Item
    • UI\MenuItem::enable — Enable Menu Item
    • UI\MenuItem::isChecked — Detect Checked
    • UI\MenuItem::onClick — On Click Callback
    • UI\MenuItem::setChecked — Set Checked
  • UI\Area — Area
    • UI\Area::onDraw — Draw Callback
    • UI\Area::onKey — Key Callback
    • UI\Area::onMouse — Mouse Callback
    • UI\Area::redraw — Redraw Area
    • UI\Area::scrollTo — Area Scroll
    • UI\Area::setSize — Set Size
  • UI\Executor — Execution Scheduler
    • UI\Executor::__construct — Construct a new Executor
    • UI\Executor::kill — Stop Executor
    • UI\Executor::onExecute — Execution Callback
    • UI\Executor::setInterval — Interval Manipulation
  • UI\Controls\Tab — Tab Control
    • UI\Controls\Tab::append — Append Page
    • UI\Controls\Tab::delete — Delete Page
    • UI\Controls\Tab::hasMargin — Margin Detection
    • UI\Controls\Tab::insertAt — Insert Page
    • UI\Controls\Tab::pages — Page Count
    • UI\Controls\Tab::setMargin — Set Margin
  • UI\Controls\Check — Check Control
    • UI\Controls\Check::__construct — Construct a new Check
    • UI\Controls\Check::getText — Get Text
    • UI\Controls\Check::isChecked — Checked Detection
    • UI\Controls\Check::onToggle — Toggle Callback
    • UI\Controls\Check::setChecked — Set Checked
    • UI\Controls\Check::setText — Set Text
  • UI\Controls\Button — Button Control
    • UI\Controls\Button::__construct — Construct a new Button
    • UI\Controls\Button::getText — Get Text
    • UI\Controls\Button::onClick — Click Handler
    • UI\Controls\Button::setText — Set Text
  • UI\Controls\ColorButton — ColorButton Control
    • UI\Controls\ColorButton::getColor — Get Color
    • UI\Controls\ColorButton::onChange — Change Handler
    • UI\Controls\ColorButton::setColor — Set Color
  • UI\Controls\Label — Label Control
    • UI\Controls\Label::__construct — Construct a new Label
    • UI\Controls\Label::getText — Get Text
    • UI\Controls\Label::setText — Set Text
  • UI\Controls\Entry — Entry Control
    • UI\Controls\Entry::__construct — Construct a new Entry
    • UI\Controls\Entry::getText — Get Text
    • UI\Controls\Entry::isReadOnly — Detect Read Only
    • UI\Controls\Entry::onChange — Change Handler
    • UI\Controls\Entry::setReadOnly — Set Read Only
    • UI\Controls\Entry::setText — Set Text
  • UI\Controls\MultilineEntry — MultilineEntry Control
    • UI\Controls\MultilineEntry::append — Append Text
    • UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry
    • UI\Controls\MultilineEntry::getText — Get Text
    • UI\Controls\MultilineEntry::isReadOnly — Read Only Detection
    • UI\Controls\MultilineEntry::onChange — Change Handler
    • UI\Controls\MultilineEntry::setReadOnly — Set Read Only
    • UI\Controls\MultilineEntry::setText — Set Text
  • UI\Controls\Spin — Spin Control
    • UI\Controls\Spin::__construct — Construct a new Spin
    • UI\Controls\Spin::getValue — Get Value
    • UI\Controls\Spin::onChange — Change Handler
    • UI\Controls\Spin::setValue — Set Value
  • UI\Controls\Slider — Slider Control
    • UI\Controls\Slider::__construct — Construct a new Slider
    • UI\Controls\Slider::getValue — Get Value
    • UI\Controls\Slider::onChange — Change Handler
    • UI\Controls\Slider::setValue — Set Value
  • UI\Controls\Progress — Progress Control
    • UI\Controls\Progress::getValue — Get Value
    • UI\Controls\Progress::setValue — Set Value
  • UI\Controls\Separator — Control Separator
    • UI\Controls\Separator::__construct — Construct a new Separator
  • UI\Controls\Combo — Combo Control
    • UI\Controls\Combo::append — Append Option
    • UI\Controls\Combo::getSelected — Get Selected Option
    • UI\Controls\Combo::onSelected — Selected Handler
    • UI\Controls\Combo::setSelected — Set Selected Option
  • UI\Controls\EditableCombo — EdiableCombo Control
    • UI\Controls\EditableCombo::append — Append Option
    • UI\Controls\EditableCombo::getText — Get Text
    • UI\Controls\EditableCombo::onChange — Change Handler
    • UI\Controls\EditableCombo::setText — Set Text
  • UI\Controls\Radio — Radio Control
    • UI\Controls\Radio::append — Append Option
    • UI\Controls\Radio::getSelected — Get Selected Option
    • UI\Controls\Radio::onSelected — Selected Handler
    • UI\Controls\Radio::setSelected — Set Selected Option
  • UI\Controls\Picker — Picker Control
    • UI\Controls\Picker::__construct — Construct a new Picker
  • UI\Controls\Form — Control Form (Arrangement)
    • UI\Controls\Form::append — Append Control
    • UI\Controls\Form::delete — Delete Control
    • UI\Controls\Form::isPadded — Padding Detection
    • UI\Controls\Form::setPadded — Set Padding
  • UI\Controls\Grid — Control Grid (Arrangement)
    • UI\Controls\Grid::append — Append Control
    • UI\Controls\Grid::isPadded — Padding Detection
    • UI\Controls\Grid::setPadded — Set Padding
  • UI\Controls\Group — Control Group (Arrangement)
    • UI\Controls\Group::append — Append Control
    • UI\Controls\Group::__construct — Construct a new Group
    • UI\Controls\Group::getTitle — Get Title
    • UI\Controls\Group::hasMargin — Margin Detection
    • UI\Controls\Group::setMargin — Set Margin
    • UI\Controls\Group::setTitle — Set Title
  • UI\Controls\Box — Control Box (Arrangement)
    • UI\Controls\Box::append — Append Control
    • UI\Controls\Box::__construct — Construct a new Box
    • UI\Controls\Box::delete — Delete Control
    • UI\Controls\Box::getOrientation — Get Orientation
    • UI\Controls\Box::isPadded — Padding Detection
    • UI\Controls\Box::setPadded — Set Padding
  • UI\Draw\Pen — Draw Pen
    • UI\Draw\Pen::clip — Clip a Path
    • UI\Draw\Pen::fill — Fill a Path
    • UI\Draw\Pen::restore — Restore
    • UI\Draw\Pen::save — Save
    • UI\Draw\Pen::stroke — Stroke a Path
    • UI\Draw\Pen::transform — Matrix Transform
    • UI\Draw\Pen::write — Draw Text at Point
  • UI\Draw\Path — Draw Path
    • UI\Draw\Path::addRectangle — Draw a Rectangle
    • UI\Draw\Path::arcTo — Draw an Arc
    • UI\Draw\Path::bezierTo — Draw Bezier Curve
    • UI\Draw\Path::closeFigure — Close Figure
    • UI\Draw\Path::__construct — Construct a new Path
    • UI\Draw\Path::end — Finalize Path
    • UI\Draw\Path::lineTo — Draw a Line
    • UI\Draw\Path::newFigure — Draw Figure
    • UI\Draw\Path::newFigureWithArc — Draw Figure with Arc
  • UI\Draw\Matrix — Draw Matrix
    • UI\Draw\Matrix::invert — Invert Matrix
    • UI\Draw\Matrix::isInvertible — Invertible Detection
    • UI\Draw\Matrix::multiply — Multiply Matrix
    • UI\Draw\Matrix::rotate — Rotate Matrix
    • UI\Draw\Matrix::scale — Scale Matrix
    • UI\Draw\Matrix::skew — Skew Matrix
    • UI\Draw\Matrix::translate — Translate Matrix
  • UI\Draw\Color — Color Representation
    • UI\Draw\Color::__construct — Construct new Color
    • UI\Draw\Color::getChannel — Color Manipulation
    • UI\Draw\Color::setChannel — Color Manipulation
  • UI\Draw\Stroke — Draw Stroke
    • UI\Draw\Stroke::__construct — Construct a new Stroke
    • UI\Draw\Stroke::getCap — Get Line Cap
    • UI\Draw\Stroke::getJoin — Get Line Join
    • UI\Draw\Stroke::getMiterLimit — Get Miter Limit
    • UI\Draw\Stroke::getThickness — Get Thickness
    • UI\Draw\Stroke::setCap — Set Line Cap
    • UI\Draw\Stroke::setJoin — Set Line Join
    • UI\Draw\Stroke::setMiterLimit — Set Miter Limit
    • UI\Draw\Stroke::setThickness — Set Thickness
  • UI\Draw\Brush — Brushes
    • UI\Draw\Brush::__construct — Construct a new Brush
    • UI\Draw\Brush::getColor — Get Color
    • UI\Draw\Brush::setColor — Set Color
  • UI\Draw\Brush\Gradient — Gradient Brushes
    • UI\Draw\Brush\Gradient::addStop — Stop Manipulation
    • UI\Draw\Brush\Gradient::delStop — Stop Manipulation
    • UI\Draw\Brush\Gradient::setStop — Stop Manipulation
  • UI\Draw\Brush\LinearGradient — Linear Gradient
    • UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient
  • UI\Draw\Brush\RadialGradient — Radial Gradient
    • UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient
  • UI\Draw\Text\Layout — Represents Text Layout
    • UI\Draw\Text\Layout::__construct — Construct a new Text Layout
    • UI\Draw\Text\Layout::setColor — Set Color
    • UI\Draw\Text\Layout::setWidth — Set Width
  • UI\Draw\Text\Font — Represents a Font
    • UI\Draw\Text\Font::__construct — Construct a new Font
    • UI\Draw\Text\Font::getAscent — Font Metrics
    • UI\Draw\Text\Font::getDescent — Font Metrics
    • UI\Draw\Text\Font::getLeading — Font Metrics
    • UI\Draw\Text\Font::getUnderlinePosition — Font Metrics
    • UI\Draw\Text\Font::getUnderlineThickness — Font Metrics
  • UI\Draw\Text\Font\Descriptor — Font Descriptor
    • UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor
    • UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family
    • UI\Draw\Text\Font\Descriptor::getItalic — Style Detection
    • UI\Draw\Text\Font\Descriptor::getSize — Size Detection
    • UI\Draw\Text\Font\Descriptor::getStretch — Style Detection
    • UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection
  • UI 函数
    • UI\Draw\Text\Font\fontFamilies — Retrieve Font Families
    • UI\quit — Quit UI Loop
    • UI\run — Enter UI Loop
  • UI\Draw\Text\Font\Weight — Font Weight Settings
  • UI\Draw\Text\Font\Italic — Italic Font Settings
  • UI\Draw\Text\Font\Stretch — Font Stretch Settings
  • UI\Draw\Line\Cap — Line Cap Settings
  • UI\Draw\Line\Join — Line Join Settings
  • UI\Key — Key Identifiers
  • UI\Exception\InvalidArgumentException — InvalidArgumentException
  • UI\Exception\RuntimeException — RuntimeException


简介

This extension wraps libui to provide an OO API for the cross platform development of native look-and-feel user interfaces .


  • ? 简介
  • 需求 ?
  • PHP Manual
  • UI
  • 安装／配置

安装／配置

Table of Contents

  • 需求
  • 安装


需求

Installation requires the libui library, and PHP 7 or newer.

This extension requires the » libui library version 0.1.0 or higher to be installed. See the libui documentation for a list of prerequisites.


安装

此 » PECL 扩展未与 PHP 捆绑。

安装此 PECL 扩展相关的信息可在手册中标题为 PECL 扩展的安装章节中找到。更多信息如新的发行版本、下载、源文件、 维护人员信息及变更日志等，都在此处： » https://pecl.php.net/package/ui.

此扩展在 Windows 平台的二进制扩展 (DLL 文件) PECL 可以在 PECL 官方网站上下载。


Represents a position (x,y)

(UI 0.9.9)

简介

Points are used throughout UI to represent co-ordinates on a screen, control, or area.

类摘要

final UI\Point {
/* 属性 */
public $x ;
public $y ;
/* Constructor */
public __construct ( float $x , float $y )
/* 方法 */
public static at ( float $point ) : UI\Point
public static at ( UI\Size $size ) : UI\Point
public getX ( ) : float
public getY ( ) : float
public setX ( float $point )
public setY ( float $point )
}

属性

x

Holds the X co-ordinate, can be read/written directly

y

Holds the Y co-ordinate, can be read/written directly

Table of Contents

  • UI\Point::at — Size Coercion
  • UI\Point::__construct — Construct a new Point
  • UI\Point::getX — Retrieves X
  • UI\Point::getY — Retrieves Y
  • UI\Point::setX — Set X
  • UI\Point::setY — Set Y


Size Coercion

  • ? UI\Point
  • UI\Point::__construct ?
  • PHP Manual
  • UI\Point
  • Size Coercion

UI\Point::at

(UI 1.0.2)

UI\Point::at — Size Coercion

说明

public static UI\Point::at ( float $point ) : UI\Point
public static UI\Point::at ( UI\Size $size ) : UI\Point

Shall return a UI\Point object where x and y are equal to those supplied, either in float or UI\Size form

参数

point

The value for x and y

size

The Size to convert

返回值

The resulting Point


Construct a new Point

  • ? UI\Point::at
  • UI\Point::getX ?
  • PHP Manual
  • UI\Point
  • Construct a new Point

UI\Point::__construct

(UI 0.9.9)

UI\Point::__construct — Construct a new Point

说明

public UI\Point::__construct ( float $x , float $y )

Construct a new Point using new co-ordinates

参数

x

The new X co-ordinate

y

The new Y co-ordinate


Retrieves X

  • ? UI\Point::__construct
  • UI\Point::getY ?
  • PHP Manual
  • UI\Point
  • Retrieves X

UI\Point::getX

(UI 0.9.9)

UI\Point::getX — Retrieves X

说明

public UI\Point::getX ( ) : float

Retrieves the X co-ordinate

参数

此函数没有参数。

返回值

The current X co-ordinate


Retrieves Y

  • ? UI\Point::getX
  • UI\Point::setX ?
  • PHP Manual
  • UI\Point
  • Retrieves Y

UI\Point::getY

(UI 0.9.9)

UI\Point::getY — Retrieves Y

说明

public UI\Point::getY ( ) : float

Retrieves the Y co-ordinate

参数

此函数没有参数。

返回值

The current Y co-ordinate


Set X

  • ? UI\Point::getY
  • UI\Point::setY ?
  • PHP Manual
  • UI\Point
  • Set X

UI\Point::setX

(UI 0.9.9)

UI\Point::setX — Set X

说明

public UI\Point::setX ( float $point )

Set the X co-ordinate

参数

point

The new X co-ordinate

返回值


Set Y

  • ? UI\Point::setX
  • UI\Size ?
  • PHP Manual
  • UI\Point
  • Set Y

UI\Point::setY

(UI 0.9.9)

UI\Point::setY — Set Y

说明

public UI\Point::setY ( float $point )

Set the Y co-ordinate

参数

point

The new Y co-ordinate

返回值


Represents dimenstions (width, height)

(UI 0.9.9)

简介

Sizes are used throughout UI to represent the size of a screen, control, or area.

类摘要

final UI\Size {
/* 属性 */
public $width ;
public $height ;
/* Constructor */
public __construct ( float $width , float $height )
/* 方法 */
public getHeight ( ) : float
public getWidth ( ) : float
public static of ( float $size ) : UI\Size
public static of ( UI\Point $point ) : UI\Size
public setHeight ( float $size )
public setWidth ( float $size )
}

属性

width

Holds the width, can be read/written directly

height

Holds the height, can be read/written directly

Table of Contents

  • UI\Size::__construct — Construct a new Size
  • UI\Size::getHeight — Retrieves Height
  • UI\Size::getWidth — Retrives Width
  • UI\Size::of — Point Coercion
  • UI\Size::setHeight — Set Height
  • UI\Size::setWidth — Set Width


Construct a new Size

  • ? UI\Size
  • UI\Size::getHeight ?
  • PHP Manual
  • UI\Size
  • Construct a new Size

UI\Size::__construct

(UI 0.9.9)

UI\Size::__construct — Construct a new Size

说明

public UI\Size::__construct ( float $width , float $height )

Construct a new Size using new width and height

参数

width

The new width

height

The new height


Retrieves Height

  • ? UI\Size::__construct
  • UI\Size::getWidth ?
  • PHP Manual
  • UI\Size
  • Retrieves Height

UI\Size::getHeight

(UI 0.9.9)

UI\Size::getHeight — Retrieves Height

说明

public UI\Size::getHeight ( ) : float

Retrieves the Height

参数

此函数没有参数。

返回值

The current Height


Retrives Width

  • ? UI\Size::getHeight
  • UI\Size::of ?
  • PHP Manual
  • UI\Size
  • Retrives Width

UI\Size::getWidth

(UI 0.9.9)

UI\Size::getWidth — Retrives Width

说明

public UI\Size::getWidth ( ) : float

Retrieves the Width

参数

此函数没有参数。

返回值

The current Width


Point Coercion

  • ? UI\Size::getWidth
  • UI\Size::setHeight ?
  • PHP Manual
  • UI\Size
  • Point Coercion

UI\Size::of

(UI 1.0.2)

UI\Size::of — Point Coercion

说明

public static UI\Size::of ( float $size ) : UI\Size
public static UI\Size::of ( UI\Point $point ) : UI\Size

Shall return a UI\Size object where width and height are equal to those supplied, either in float or UI\Point form

参数

size

The value for width and height

point

The Point to convert

返回值

The resulting Size


Set Height

  • ? UI\Size::of
  • UI\Size::setWidth ?
  • PHP Manual
  • UI\Size
  • Set Height

UI\Size::setHeight

(UI 0.9.9)

UI\Size::setHeight — Set Height

说明

public UI\Size::setHeight ( float $size )

Set new Height

参数

size

The new Height

返回值


Set Width

  • ? UI\Size::setHeight
  • UI\Window ?
  • PHP Manual
  • UI\Size
  • Set Width

UI\Size::setWidth

(UI 0.9.9)

UI\Size::setWidth — Set Width

说明

public UI\Size::setWidth ( float $size )

Set new Width

参数

size

The new Width

返回值


Window

(UI 0.9.9)

简介

Represents a UI Window

类摘要

UI\Window extends UI\Control {
/* 属性 */
protected $controls ;
/* Constructor */
public __construct ( string $title , Size $size , bool $menu = false )
/* 方法 */
public add ( UI\Control $control )
public error ( string $title , string $msg )
public getSize ( ) : UI\Size
public getTitle ( ) : string
public hasBorders ( ) : bool
public hasMargin ( ) : bool
public isFullScreen ( ) : bool
public msg ( string $title , string $msg )
protected onClosing ( ) : int
public open ( ) : string
public save ( ) : string
public setBorders ( bool $borders )
public setFullScreen ( bool $full )
public setMargin ( bool $margin )
public setSize ( UI\Size $size )
public setTitle ( string $title )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

属性

controls

Contains controls, should not be manipulated directly

Table of Contents

  • UI\Window::add — Add a Control
  • UI\Window::__construct — Construct a new Window
  • UI\Window::error — Show Error Box
  • UI\Window::getSize — Get Window Size
  • UI\Window::getTitle — Get Title
  • UI\Window::hasBorders — Border Detection
  • UI\Window::hasMargin — Margin Detection
  • UI\Window::isFullScreen — Full Screen Detection
  • UI\Window::msg — Show Message Box
  • UI\Window::onClosing — Closing Callback
  • UI\Window::open — Open Dialog
  • UI\Window::save — Save Dialog
  • UI\Window::setBorders — Border Use
  • UI\Window::setFullScreen — Full Screen Use
  • UI\Window::setMargin — Margin Use
  • UI\Window::setSize — Set Size
  • UI\Window::setTitle — Window Title


Add a Control

  • ? UI\Window
  • UI\Window::__construct ?
  • PHP Manual
  • UI\Window
  • Add a Control

UI\Window::add

(UI 0.9.9)

UI\Window::add — Add a Control

说明

public UI\Window::add ( UI\Control $control )

Shall add a Control to this Window

参数

control

The Control to add

返回值


Construct a new Window

  • ? UI\Window::add
  • UI\Window::error ?
  • PHP Manual
  • UI\Window
  • Construct a new Window

UI\Window::__construct

(UI 0.9.9)

UI\Window::__construct — Construct a new Window

说明

public UI\Window::__construct ( string $title , Size $size , bool $menu = false )

Shall construct a new Window

参数

title

The title of the Window

size

The size of the Window

menu

Menu switch


Show Error Box

  • ? UI\Window::__construct
  • UI\Window::getSize ?
  • PHP Manual
  • UI\Window
  • Show Error Box

UI\Window::error

(UI 0.9.9)

UI\Window::error — Show Error Box

说明

public UI\Window::error ( string $title , string $msg )

Shall show an error box

参数

title

The title of the error box

msg

The message for the error box


Get Window Size

  • ? UI\Window::error
  • UI\Window::getTitle ?
  • PHP Manual
  • UI\Window
  • Get Window Size

UI\Window::getSize

(UI 0.9.9)

UI\Window::getSize — Get Window Size

说明

public UI\Window::getSize ( ) : UI\Size

Shall return the size of this Window

参数

此函数没有参数。

返回值


Get Title

  • ? UI\Window::getSize
  • UI\Window::hasBorders ?
  • PHP Manual
  • UI\Window
  • Get Title

UI\Window::getTitle

(UI 0.9.9)

UI\Window::getTitle — Get Title

说明

public UI\Window::getTitle ( ) : string

Shall retrieve the title of this Window

参数

此函数没有参数。

返回值


Border Detection

  • ? UI\Window::getTitle
  • UI\Window::hasMargin ?
  • PHP Manual
  • UI\Window
  • Border Detection

UI\Window::hasBorders

(UI 0.9.9)

UI\Window::hasBorders — Border Detection

说明

public UI\Window::hasBorders ( ) : bool

Shall detect if borders are used on this Window

参数

此函数没有参数。

返回值


Margin Detection

  • ? UI\Window::hasBorders
  • UI\Window::isFullScreen ?
  • PHP Manual
  • UI\Window
  • Margin Detection

UI\Window::hasMargin

(UI 0.9.9)

UI\Window::hasMargin — Margin Detection

说明

public UI\Window::hasMargin ( ) : bool

Shall detect if margins are used on this Window

参数

此函数没有参数。

返回值


Full Screen Detection

  • ? UI\Window::hasMargin
  • UI\Window::msg ?
  • PHP Manual
  • UI\Window
  • Full Screen Detection

UI\Window::isFullScreen

(UI 0.9.9)

UI\Window::isFullScreen — Full Screen Detection

说明

public UI\Window::isFullScreen ( ) : bool

Shall detect if this Window us using the whole screen

参数

此函数没有参数。

返回值


Show Message Box

  • ? UI\Window::isFullScreen
  • UI\Window::onClosing ?
  • PHP Manual
  • UI\Window
  • Show Message Box

UI\Window::msg

(UI 0.9.9)

UI\Window::msg — Show Message Box

说明

public UI\Window::msg ( string $title , string $msg )

Shall show a message box

参数

title

The title of the message box

msg

The message


Closing Callback

  • ? UI\Window::msg
  • UI\Window::open ?
  • PHP Manual
  • UI\Window
  • Closing Callback

UI\Window::onClosing

(UI 0.9.9)

UI\Window::onClosing — Closing Callback

说明

protected UI\Window::onClosing ( ) : int

Should gracefully destroy this Window

参数

此函数没有参数。

返回值


Open Dialog

  • ? UI\Window::onClosing
  • UI\Window::save ?
  • PHP Manual
  • UI\Window
  • Open Dialog

UI\Window::open

(UI 0.9.9)

UI\Window::open — Open Dialog

说明

public UI\Window::open ( ) : string

Shall show an open file dialog

参数

此函数没有参数。

返回值

Returns the name of the file selected for opening


Save Dialog

  • ? UI\Window::open
  • UI\Window::setBorders ?
  • PHP Manual
  • UI\Window
  • Save Dialog

UI\Window::save

(UI 0.9.9)

UI\Window::save — Save Dialog

说明

public UI\Window::save ( ) : string

Shall show a save dialog

参数

此函数没有参数。

返回值

Returns the file name selecting for saving


Border Use

  • ? UI\Window::save
  • UI\Window::setFullScreen ?
  • PHP Manual
  • UI\Window
  • Border Use

UI\Window::setBorders

(UI 0.9.9)

UI\Window::setBorders — Border Use

说明

public UI\Window::setBorders ( bool $borders )

Shall enable or disable the use of borders on this Window

参数

borders


Full Screen Use

  • ? UI\Window::setBorders
  • UI\Window::setMargin ?
  • PHP Manual
  • UI\Window
  • Full Screen Use

UI\Window::setFullScreen

(UI 0.9.9)

UI\Window::setFullScreen — Full Screen Use

说明

public UI\Window::setFullScreen ( bool $full )

Shall enable or disable the use of the full screen for this Window

Warning

本函数还未编写文档，仅有参数列表。

参数

full


Margin Use

  • ? UI\Window::setFullScreen
  • UI\Window::setSize ?
  • PHP Manual
  • UI\Window
  • Margin Use

UI\Window::setMargin

(UI 0.9.9)

UI\Window::setMargin — Margin Use

说明

public UI\Window::setMargin ( bool $margin )

Shall enable or disable the use of margins for this Window

参数

margin


Set Size

  • ? UI\Window::setMargin
  • UI\Window::setTitle ?
  • PHP Manual
  • UI\Window
  • Set Size

UI\Window::setSize

(UI 0.9.9)

UI\Window::setSize — Set Size

说明

public UI\Window::setSize ( UI\Size $size )

Shall set the size of this Window

参数

size

返回值


Window Title

  • ? UI\Window::setSize
  • UI\Control ?
  • PHP Manual
  • UI\Window
  • Window Title

UI\Window::setTitle

(UI 0.9.9)

UI\Window::setTitle — Window Title

说明

public UI\Window::setTitle ( string $title )

Shall set the title for this Window

参数

title

The new title


Control

(UI 0.9.9)

简介

This is the closed base class for all UI Controls.

类摘要

final UI\Control {
/* 方法 */
public destroy ( )
public disable ( )
public enable ( )
public getParent ( ) : UI\Control
public getTopLevel ( ) : int
public hide ( )
public isEnabled ( ) : bool
public isVisible ( ) : bool
public setParent ( UI\Control $parent )
public show ( )
}

Table of Contents

  • UI\Control::destroy — Destroy Control
  • UI\Control::disable — Disable Control
  • UI\Control::enable — Enable Control
  • UI\Control::getParent — Get Parent Control
  • UI\Control::getTopLevel — Get Top Level
  • UI\Control::hide — Hide Control
  • UI\Control::isEnabled — Determine if Control is enabled
  • UI\Control::isVisible — Determine if Control is visible
  • UI\Control::setParent — Set Parent Control
  • UI\Control::show — Control Show


Destroy Control

  • ? UI\Control
  • UI\Control::disable ?
  • PHP Manual
  • UI\Control
  • Destroy Control

UI\Control::destroy

(UI 0.9.9)

UI\Control::destroy — Destroy Control

说明

public UI\Control::destroy ( )

Shall destroy this Control

参数

此函数没有参数。

返回值


Disable Control

  • ? UI\Control::destroy
  • UI\Control::enable ?
  • PHP Manual
  • UI\Control
  • Disable Control

UI\Control::disable

(UI 0.9.9)

UI\Control::disable — Disable Control

说明

public UI\Control::disable ( )

Shall disable this Control

参数

此函数没有参数。

返回值


Enable Control

  • ? UI\Control::disable
  • UI\Control::getParent ?
  • PHP Manual
  • UI\Control
  • Enable Control

UI\Control::enable

(UI 0.9.9)

UI\Control::enable — Enable Control

说明

public UI\Control::enable ( )

Shall enable this Control

参数

此函数没有参数。

返回值


Get Parent Control

  • ? UI\Control::enable
  • UI\Control::getTopLevel ?
  • PHP Manual
  • UI\Control
  • Get Parent Control

UI\Control::getParent

(UI 0.9.9)

UI\Control::getParent — Get Parent Control

说明

public UI\Control::getParent ( ) : UI\Control

Shall return the parent Control

参数

此函数没有参数。

返回值


Get Top Level

  • ? UI\Control::getParent
  • UI\Control::hide ?
  • PHP Manual
  • UI\Control
  • Get Top Level

UI\Control::getTopLevel

(UI 0.9.9)

UI\Control::getTopLevel — Get Top Level

说明

public UI\Control::getTopLevel ( ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Hide Control

  • ? UI\Control::getTopLevel
  • UI\Control::isEnabled ?
  • PHP Manual
  • UI\Control
  • Hide Control

UI\Control::hide

(UI 0.9.9)

UI\Control::hide — Hide Control

说明

public UI\Control::hide ( )

Shall hide this Control

参数

此函数没有参数。

返回值


Determine if Control is enabled

  • ? UI\Control::hide
  • UI\Control::isVisible ?
  • PHP Manual
  • UI\Control
  • Determine if Control is enabled

UI\Control::isEnabled

(UI 0.9.9)

UI\Control::isEnabled — Determine if Control is enabled

说明

public UI\Control::isEnabled ( ) : bool

Shall detect if this Control is enabled

参数

此函数没有参数。

返回值


Determine if Control is visible

  • ? UI\Control::isEnabled
  • UI\Control::setParent ?
  • PHP Manual
  • UI\Control
  • Determine if Control is visible

UI\Control::isVisible

(UI 0.9.9)

UI\Control::isVisible — Determine if Control is visible

说明

public UI\Control::isVisible ( ) : bool

Shall detect if this Control is visible

参数

此函数没有参数。

返回值


Set Parent Control

  • ? UI\Control::isVisible
  • UI\Control::show ?
  • PHP Manual
  • UI\Control
  • Set Parent Control

UI\Control::setParent

(UI 0.9.9)

UI\Control::setParent — Set Parent Control

说明

public UI\Control::setParent ( UI\Control $parent )

Shall set the parent Control of this Control

参数

parent

The parent Control

返回值


Control Show

  • ? UI\Control::setParent
  • UI\Menu ?
  • PHP Manual
  • UI\Control
  • Control Show

UI\Control::show

(UI 0.9.9)

UI\Control::show — Control Show

说明

public UI\Control::show ( )

Shall show this Control

参数

此函数没有参数。

返回值


Menu

(UI 0.9.9)

简介

Menus must be constructed before the first Window, and can be shown on any Window

类摘要

UI\Menu {
/* Constructor */
public __construct ( string $name )
/* 方法 */
public append ( string $name , string $type = UI\MenuItem::class ) : UI\MenuItem
public appendAbout ( string $type = UI\MenuItem::class ) : UI\MenuItem
public appendCheck ( string $name , string $type = UI\MenuItem::class ) : UI\MenuItem
public appendPreferences ( string $type = UI\MenuItem::class ) : UI\MenuItem
public appendQuit ( string $type = UI\MenuItem::class ) : UI\MenuItem
public appendSeparator ( )
}

Table of Contents

  • UI\Menu::append — Append Menu Item
  • UI\Menu::appendAbout — Append About Menu Item
  • UI\Menu::appendCheck — Append Checkable Menu Item
  • UI\Menu::appendPreferences — Append Preferences Menu Item
  • UI\Menu::appendQuit — Append Quit Menu Item
  • UI\Menu::appendSeparator — Append Menu Item Separator
  • UI\Menu::__construct — Construct a new Menu


Append Menu Item

  • ? UI\Menu
  • UI\Menu::appendAbout ?
  • PHP Manual
  • UI\Menu
  • Append Menu Item

UI\Menu::append

(UI 0.9.9)

UI\Menu::append — Append Menu Item

说明

public UI\Menu::append ( string $name , string $type = UI\MenuItem::class ) : UI\MenuItem

Shall append a new Menu Item

参数

name

The name (text) for the new item

type

The type for the new item

返回值

A constructed object of the given type


Append About Menu Item

  • ? UI\Menu::append
  • UI\Menu::appendCheck ?
  • PHP Manual
  • UI\Menu
  • Append About Menu Item

UI\Menu::appendAbout

(UI 0.9.9)

UI\Menu::appendAbout — Append About Menu Item

说明

public UI\Menu::appendAbout ( string $type = UI\MenuItem::class ) : UI\MenuItem

Shall append an About menu item

参数

type

The type for the new item

返回值

A constructed About menu item of the given type


Append Checkable Menu Item

  • ? UI\Menu::appendAbout
  • UI\Menu::appendPreferences ?
  • PHP Manual
  • UI\Menu
  • Append Checkable Menu Item

UI\Menu::appendCheck

(UI 0.9.9)

UI\Menu::appendCheck — Append Checkable Menu Item

说明

public UI\Menu::appendCheck ( string $name , string $type = UI\MenuItem::class ) : UI\MenuItem

Shall append a checkable menu item

参数

name

The name (text) for the new item

type

The type for the new item

返回值

A constructed checkable menu item of the given type


Append Preferences Menu Item

  • ? UI\Menu::appendCheck
  • UI\Menu::appendQuit ?
  • PHP Manual
  • UI\Menu
  • Append Preferences Menu Item

UI\Menu::appendPreferences

(UI 0.9.9)

UI\Menu::appendPreferences — Append Preferences Menu Item

说明

public UI\Menu::appendPreferences ( string $type = UI\MenuItem::class ) : UI\MenuItem

Shall append a Preferences menu item

参数

type

The type for the new item

返回值

A constructed Preferences menu item of the given type


Append Quit Menu Item

  • ? UI\Menu::appendPreferences
  • UI\Menu::appendSeparator ?
  • PHP Manual
  • UI\Menu
  • Append Quit Menu Item

UI\Menu::appendQuit

(UI 0.9.9)

UI\Menu::appendQuit — Append Quit Menu Item

说明

public UI\Menu::appendQuit ( string $type = UI\MenuItem::class ) : UI\MenuItem

Shall append a Quit menu item

参数

type

The type for the new item

返回值

A constructed Quit menu item of the given type


Append Menu Item Separator

  • ? UI\Menu::appendQuit
  • UI\Menu::__construct ?
  • PHP Manual
  • UI\Menu
  • Append Menu Item Separator

UI\Menu::appendSeparator

(UI 0.9.9)

UI\Menu::appendSeparator — Append Menu Item Separator

说明

public UI\Menu::appendSeparator ( )

Shall append a separator

参数

此函数没有参数。


Construct a new Menu

  • ? UI\Menu::appendSeparator
  • UI\MenuItem ?
  • PHP Manual
  • UI\Menu
  • Construct a new Menu

UI\Menu::__construct

(UI 0.9.9)

UI\Menu::__construct — Construct a new Menu

说明

public UI\Menu::__construct ( string $name )

Shall construct a new Menu

参数

name

The name (text) for the menu


Menu Item

(UI 0.9.9)

简介

Menu Items should only be created by the Menu

类摘要

UI\MenuItem {
/* 方法 */
public disable ( )
public enable ( )
public isChecked ( ) : bool
protected onClick ( )
public setChecked ( bool $checked )
}

Table of Contents

  • UI\MenuItem::disable — Disable Menu Item
  • UI\MenuItem::enable — Enable Menu Item
  • UI\MenuItem::isChecked — Detect Checked
  • UI\MenuItem::onClick — On Click Callback
  • UI\MenuItem::setChecked — Set Checked


Disable Menu Item

  • ? UI\MenuItem
  • UI\MenuItem::enable ?
  • PHP Manual
  • UI\MenuItem
  • Disable Menu Item

UI\MenuItem::disable

(UI 0.9.9)

UI\MenuItem::disable — Disable Menu Item

说明

public UI\MenuItem::disable ( )

Shall disable this Menu Item

参数

此函数没有参数。


Enable Menu Item

  • ? UI\MenuItem::disable
  • UI\MenuItem::isChecked ?
  • PHP Manual
  • UI\MenuItem
  • Enable Menu Item

UI\MenuItem::enable

(UI 0.9.9)

UI\MenuItem::enable — Enable Menu Item

说明

public UI\MenuItem::enable ( )

Shall enable this Menu Item

参数

此函数没有参数。


Detect Checked

  • ? UI\MenuItem::enable
  • UI\MenuItem::onClick ?
  • PHP Manual
  • UI\MenuItem
  • Detect Checked

UI\MenuItem::isChecked

(UI 0.9.9)

UI\MenuItem::isChecked — Detect Checked

说明

public UI\MenuItem::isChecked ( ) : bool

Shall detect if this Menu Item is checked

参数

此函数没有参数。


On Click Callback

  • ? UI\MenuItem::isChecked
  • UI\MenuItem::setChecked ?
  • PHP Manual
  • UI\MenuItem
  • On Click Callback

UI\MenuItem::onClick

(UI 0.9.9)

UI\MenuItem::onClick — On Click Callback

说明

protected UI\MenuItem::onClick ( )

Shall be executed when this Menu Item is clicked

参数

此函数没有参数。


Set Checked

  • ? UI\MenuItem::onClick
  • UI\Area ?
  • PHP Manual
  • UI\MenuItem
  • Set Checked

UI\MenuItem::setChecked

(UI 0.9.9)

UI\MenuItem::setChecked — Set Checked

说明

public UI\MenuItem::setChecked ( bool $checked )

Shall set the checked status of this Menu Item

参数

checked

The new status


Area

(UI 0.9.9)

简介

An Area represents a canvas which can be used to draw, and respond to mouse and key events.

类摘要

UI\Area extends UI\Control {
/* Constants */
const int Ctrl ;
const int Alt ;
const int Shift ;
const int Super ;
const int Down ;
const int Up ;
/* 方法 */
protected onDraw ( UI\Draw\Pen $pen , UI\Size $areaSize , UI\Point $clipPoint , UI\Size $clipSize )
protected onKey ( string $key , int $ext , int $flags )
protected onMouse ( UI\Point $areaPoint , UI\Size $areaSize , int $flags )
public redraw ( )
public scrollTo ( UI\Point $point , UI\Size $size )
public setSize ( UI\Size $size )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

预定义常量

UI\Area::Ctrl

Shall be set in the modifiers passed to key and mouse events when the CTRL key is active

UI\Area::Alt

Shall be set in the modifiers passed to key and mouse events when the ALT key is active

UI\Area::Shift

Shall be set in the modifiers passed to key and mouse events when the SHIFT key is active

UI\Area::Super

UI\Area::Down

Shall be set in the modifiers passed to key and mouse events

UI\Area::Up

Shall be set in the modifiers passed to key and mouse events

Table of Contents

  • UI\Area::onDraw — Draw Callback
  • UI\Area::onKey — Key Callback
  • UI\Area::onMouse — Mouse Callback
  • UI\Area::redraw — Redraw Area
  • UI\Area::scrollTo — Area Scroll
  • UI\Area::setSize — Set Size


Draw Callback

  • ? UI\Area
  • UI\Area::onKey ?
  • PHP Manual
  • UI\Area
  • Draw Callback

UI\Area::onDraw

(UI 0.9.9)

UI\Area::onDraw — Draw Callback

说明

protected UI\Area::onDraw ( UI\Draw\Pen $pen , UI\Size $areaSize , UI\Point $clipPoint , UI\Size $clipSize )

Shall be invoked when this Area requires redrawing

参数

pen

A Pen suitable for drawing in this Area

areaSize

The size of the Area

clipPoint

The clip point of the Area

clipSize

The clip size of the Area


Key Callback

  • ? UI\Area::onDraw
  • UI\Area::onMouse ?
  • PHP Manual
  • UI\Area
  • Key Callback

UI\Area::onKey

(UI 0.9.9)

UI\Area::onKey — Key Callback

说明

protected UI\Area::onKey ( string $key , int $ext , int $flags )

Shall be executed on key events

参数

key

The key pressed

ext

The extended key pressed

flags

Event modifiers

返回值


Mouse Callback

  • ? UI\Area::onKey
  • UI\Area::redraw ?
  • PHP Manual
  • UI\Area
  • Mouse Callback

UI\Area::onMouse

(UI 0.9.9)

UI\Area::onMouse — Mouse Callback

说明

protected UI\Area::onMouse ( UI\Point $areaPoint , UI\Size $areaSize , int $flags )

Shall be executed on mouse events

参数

areaPoint

The co-ordinates of the event

areaSize

The size of the area of the event

flags

Event modifiers


Redraw Area

  • ? UI\Area::onMouse
  • UI\Area::scrollTo ?
  • PHP Manual
  • UI\Area
  • Redraw Area

UI\Area::redraw

(UI 0.9.9)

UI\Area::redraw — Redraw Area

说明

public UI\Area::redraw ( )

Requests that this Area is redrawn

参数

此函数没有参数。

返回值


Area Scroll

  • ? UI\Area::redraw
  • UI\Area::setSize ?
  • PHP Manual
  • UI\Area
  • Area Scroll

UI\Area::scrollTo

(UI 0.9.9)

UI\Area::scrollTo — Area Scroll

说明

public UI\Area::scrollTo ( UI\Point $point , UI\Size $size )

Scroll this Area

参数

point

The point to scroll to

size

The size of the scroll pane


Set Size

  • ? UI\Area::scrollTo
  • UI\Executor ?
  • PHP Manual
  • UI\Area
  • Set Size

UI\Area::setSize

(UI 0.9.9)

UI\Area::setSize — Set Size

说明

public UI\Area::setSize ( UI\Size $size )

Sets the size of this Area

参数

size

The new size


Execution Scheduler

(UI 2.0.0)

简介

This facility schedules repetitive execution of a callback, useful for animations and other such activities.

类摘要

abstract UI\Executor {
/* Constructor */
public __construct ( )
public __construct ( int $microseconds )
public __construct ( int $seconds , int $microseconds )
/* 方法 */
public kill ( ) : void
abstract protected onExecute ( ) : void
public setInterval ( int $microseconds ) : bool
public setInterval ( int $seconds , int $microseconds ) : bool
}

Table of Contents

  • UI\Executor::__construct — Construct a new Executor
  • UI\Executor::kill — Stop Executor
  • UI\Executor::onExecute — Execution Callback
  • UI\Executor::setInterval — Interval Manipulation


Construct a new Executor

  • ? UI\Executor
  • UI\Executor::kill ?
  • PHP Manual
  • UI\Executor
  • Construct a new Executor

UI\Executor::__construct

(UI 2.0.0)

UI\Executor::__construct — Construct a new Executor

说明

public UI\Executor::__construct ( )
public UI\Executor::__construct ( int $microseconds )
public UI\Executor::__construct ( int $seconds , int $microseconds )

Shall construct an executor with the given interval, will not start executing until main loop is entered

参数

seconds

Seconds between executions

microseconds

Microseconds between executions


Stop Executor

  • ? UI\Executor::__construct
  • UI\Executor::onExecute ?
  • PHP Manual
  • UI\Executor
  • Stop Executor

UI\Executor::kill

(UI 2.0.0)

UI\Executor::kill — Stop Executor

说明

public UI\Executor::kill ( ) : void

Shall stop an executor, the executor cannot be restarted

参数

此函数没有参数。

返回值


Execution Callback

  • ? UI\Executor::kill
  • UI\Executor::setInterval ?
  • PHP Manual
  • UI\Executor
  • Execution Callback

UI\Executor::onExecute

(UI 2.0.0)

UI\Executor::onExecute — Execution Callback

说明

abstract protected UI\Executor::onExecute ( ) : void

Shall be repetitively queued for execution in the main thread

参数

此函数没有参数。

返回值


Interval Manipulation

  • ? UI\Executor::onExecute
  • UI\Controls\Tab ?
  • PHP Manual
  • UI\Executor
  • Interval Manipulation

UI\Executor::setInterval

(UI 2.0.0)

UI\Executor::setInterval — Interval Manipulation

说明

public UI\Executor::setInterval ( int $microseconds ) : bool
public UI\Executor::setInterval ( int $seconds , int $microseconds ) : bool

Shall set the new interval. An interval of 0 will pause the executor until a new interval has been set

参数

seconds

microseconds

返回值

Indication of success


Tab Control

(UI 0.9.9)

简介

A Tab can contain many pages of Controls, each with a title, each selectable by the user.

类摘要

UI\Controls\Tab extends UI\Control {
/* 属性 */
protected $controls ;
/* 方法 */
public append ( string $name , UI\Control $control ) : int
public delete ( int $index ) : bool
public hasMargin ( int $page ) : bool
public insertAt ( string $name , int $page , UI\Control $control )
public pages ( ) : int
public setMargin ( int $page , bool $margin )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

属性

controls

Contains controls, should not be manipulated directly

Table of Contents

  • UI\Controls\Tab::append — Append Page
  • UI\Controls\Tab::delete — Delete Page
  • UI\Controls\Tab::hasMargin — Margin Detection
  • UI\Controls\Tab::insertAt — Insert Page
  • UI\Controls\Tab::pages — Page Count
  • UI\Controls\Tab::setMargin — Set Margin


Append Page

  • ? UI\Controls\Tab
  • UI\Controls\Tab::delete ?
  • PHP Manual
  • UI\Controls\Tab
  • Append Page

UI\Controls\Tab::append

(UI 0.9.9)

UI\Controls\Tab::append — Append Page

说明

public UI\Controls\Tab::append ( string $name , UI\Control $control ) : int

Append a new page to this Tab

参数

name

The name for the new page

control

The control for the new page

返回值

Shall return the index of the appended control, may be 0


Delete Page

  • ? UI\Controls\Tab::append
  • UI\Controls\Tab::hasMargin ?
  • PHP Manual
  • UI\Controls\Tab
  • Delete Page

UI\Controls\Tab::delete

(UI 0.9.9)

UI\Controls\Tab::delete — Delete Page

说明

public UI\Controls\Tab::delete ( int $index ) : bool

Shall remove the selected page from this Tab

参数

index

The index of the page to remove

返回值

Indication of success


Margin Detection

  • ? UI\Controls\Tab::delete
  • UI\Controls\Tab::insertAt ?
  • PHP Manual
  • UI\Controls\Tab
  • Margin Detection

UI\Controls\Tab::hasMargin

(UI 0.9.9)

UI\Controls\Tab::hasMargin — Margin Detection

说明

public UI\Controls\Tab::hasMargin ( int $page ) : bool

Shall detect if the given page has a margin.

参数

page

The index of the page

返回值


Insert Page

  • ? UI\Controls\Tab::hasMargin
  • UI\Controls\Tab::pages ?
  • PHP Manual
  • UI\Controls\Tab
  • Insert Page

UI\Controls\Tab::insertAt

(UI 0.9.9)

UI\Controls\Tab::insertAt — Insert Page

说明

public UI\Controls\Tab::insertAt ( string $name , int $page , UI\Control $control )

Shall insert a new page into this Tab

参数

name

The name for the new page

page

The index to perform the insertion before

control

The control for the new page


Page Count

  • ? UI\Controls\Tab::insertAt
  • UI\Controls\Tab::setMargin ?
  • PHP Manual
  • UI\Controls\Tab
  • Page Count

UI\Controls\Tab::pages

(UI 0.9.9)

UI\Controls\Tab::pages — Page Count

说明

public UI\Controls\Tab::pages ( ) : int

Shall return the number of pages in this Tab

参数

此函数没有参数。

返回值

The number of pages in this Tab


Set Margin

  • ? UI\Controls\Tab::pages
  • UI\Controls\Check ?
  • PHP Manual
  • UI\Controls\Tab
  • Set Margin

UI\Controls\Tab::setMargin

(UI 0.9.9)

UI\Controls\Tab::setMargin — Set Margin

说明

public UI\Controls\Tab::setMargin ( int $page , bool $margin )

Shall enable or disable margins on the selected page

参数

page

The page to select

margin

Margin switch


Check Control

(UI 0.9.9)

简介

A Check is a labelled checkable box

类摘要

UI\Controls\Check extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* 方法 */
public getText ( ) : string
public isChecked ( ) : bool
protected onToggle ( )
public setChecked ( bool $checked )
public setText ( string $text )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\Check::__construct — Construct a new Check
  • UI\Controls\Check::getText — Get Text
  • UI\Controls\Check::isChecked — Checked Detection
  • UI\Controls\Check::onToggle — Toggle Callback
  • UI\Controls\Check::setChecked — Set Checked
  • UI\Controls\Check::setText — Set Text


Construct a new Check

  • ? UI\Controls\Check
  • UI\Controls\Check::getText ?
  • PHP Manual
  • UI\Controls\Check
  • Construct a new Check

UI\Controls\Check::__construct

(UI 0.9.9)

UI\Controls\Check::__construct — Construct a new Check

说明

public UI\Controls\Check::__construct ( string $text )

Shall construct a new Check

参数

text

The text (label) for the Check box


Get Text

  • ? UI\Controls\Check::__construct
  • UI\Controls\Check::isChecked ?
  • PHP Manual
  • UI\Controls\Check
  • Get Text

UI\Controls\Check::getText

(UI 0.9.9)

UI\Controls\Check::getText — Get Text

说明

public UI\Controls\Check::getText ( ) : string

Shall return the text (label) for this Check

参数

此函数没有参数。

返回值

The current text (label)


Checked Detection

  • ? UI\Controls\Check::getText
  • UI\Controls\Check::onToggle ?
  • PHP Manual
  • UI\Controls\Check
  • Checked Detection

UI\Controls\Check::isChecked

(UI 0.9.9)

UI\Controls\Check::isChecked — Checked Detection

说明

public UI\Controls\Check::isChecked ( ) : bool

Shall detect the status of this Check

参数

此函数没有参数。


Toggle Callback

  • ? UI\Controls\Check::isChecked
  • UI\Controls\Check::setChecked ?
  • PHP Manual
  • UI\Controls\Check
  • Toggle Callback

UI\Controls\Check::onToggle

(UI 0.9.9)

UI\Controls\Check::onToggle — Toggle Callback

说明

protected UI\Controls\Check::onToggle ( )

Shall be executed when the status of this Check is changed

参数

此函数没有参数。


Set Checked

  • ? UI\Controls\Check::onToggle
  • UI\Controls\Check::setText ?
  • PHP Manual
  • UI\Controls\Check
  • Set Checked

UI\Controls\Check::setChecked

(UI 0.9.9)

UI\Controls\Check::setChecked — Set Checked

说明

public UI\Controls\Check::setChecked ( bool $checked )

Shall change the status of this Check

参数

checked

The new status


Set Text

  • ? UI\Controls\Check::setChecked
  • UI\Controls\Button ?
  • PHP Manual
  • UI\Controls\Check
  • Set Text

UI\Controls\Check::setText

(UI 0.9.9)

UI\Controls\Check::setText — Set Text

说明

public UI\Controls\Check::setText ( string $text )

Shall set the text (label) for this Check

参数

text

The new text (label)


Button Control

(UI 0.9.9)

简介

Represents a labelled clickable button

类摘要

UI\Controls\Button extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* 方法 */
public getText ( ) : string
protected onClick ( )
public setText ( string $text )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\Button::__construct — Construct a new Button
  • UI\Controls\Button::getText — Get Text
  • UI\Controls\Button::onClick — Click Handler
  • UI\Controls\Button::setText — Set Text


Construct a new Button

  • ? UI\Controls\Button
  • UI\Controls\Button::getText ?
  • PHP Manual
  • UI\Controls\Button
  • Construct a new Button

UI\Controls\Button::__construct

(UI 0.9.9)

UI\Controls\Button::__construct — Construct a new Button

说明

public UI\Controls\Button::__construct ( string $text )

Shall construct a new Button

参数

text

The text (label) for this Button


Get Text

  • ? UI\Controls\Button::__construct
  • UI\Controls\Button::onClick ?
  • PHP Manual
  • UI\Controls\Button
  • Get Text

UI\Controls\Button::getText

(UI 0.9.9)

UI\Controls\Button::getText — Get Text

说明

public UI\Controls\Button::getText ( ) : string

Shall retrieve the text (label) for this Button

参数

此函数没有参数。

返回值

The current text (label)


Click Handler

  • ? UI\Controls\Button::getText
  • UI\Controls\Button::setText ?
  • PHP Manual
  • UI\Controls\Button
  • Click Handler

UI\Controls\Button::onClick

(UI 0.9.9)

UI\Controls\Button::onClick — Click Handler

说明

protected UI\Controls\Button::onClick ( )

Shall be executed when this Button is clicked

参数

此函数没有参数。


Set Text

  • ? UI\Controls\Button::onClick
  • UI\Controls\ColorButton ?
  • PHP Manual
  • UI\Controls\Button
  • Set Text

UI\Controls\Button::setText

(UI 0.9.9)

UI\Controls\Button::setText — Set Text

说明

public UI\Controls\Button::setText ( string $text )

Shall set the text (label) for this Button

参数

text

The new text (label)


ColorButton Control

(UI 0.9.9)

简介

A Color Button is a button which displays a color picker when clicked

类摘要

UI\Controls\ColorButton extends UI\Control {
/* 方法 */
public getColor ( ) : UI\Color
protected onChange ( )
public setColor ( UI\Draw\Color $color )
public setColor ( int $color )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\ColorButton::getColor — Get Color
  • UI\Controls\ColorButton::onChange — Change Handler
  • UI\Controls\ColorButton::setColor — Set Color


Get Color

  • ? UI\Controls\ColorButton
  • UI\Controls\ColorButton::onChange ?
  • PHP Manual
  • UI\Controls\ColorButton
  • Get Color

UI\Controls\ColorButton::getColor

(UI 0.9.9)

UI\Controls\ColorButton::getColor — Get Color

说明

public UI\Controls\ColorButton::getColor ( ) : UI\Color

Shall retrieve the currently selected Color

参数

此函数没有参数。

返回值


Change Handler

  • ? UI\Controls\ColorButton::getColor
  • UI\Controls\ColorButton::setColor ?
  • PHP Manual
  • UI\Controls\ColorButton
  • Change Handler

UI\Controls\ColorButton::onChange

(UI 0.9.9)

UI\Controls\ColorButton::onChange — Change Handler

说明

protected UI\Controls\ColorButton::onChange ( )

Shall be executed when the selected Color is changed

参数

此函数没有参数。


Set Color

  • ? UI\Controls\ColorButton::onChange
  • UI\Controls\Label ?
  • PHP Manual
  • UI\Controls\ColorButton
  • Set Color

UI\Controls\ColorButton::setColor

(UI 0.9.9)

UI\Controls\ColorButton::setColor — Set Color

说明

public UI\Controls\ColorButton::setColor ( UI\Draw\Color $color )
public UI\Controls\ColorButton::setColor ( int $color )

Shall set the currently selected Color

参数

color

The new color


Label Control

(UI 0.9.9)

简介

A Label is a single line of text, meant to identify, for the user, some element of the interface.

类摘要

UI\Controls\Label extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* 方法 */
public getText ( ) : string
public setText ( string $text )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\Label::__construct — Construct a new Label
  • UI\Controls\Label::getText — Get Text
  • UI\Controls\Label::setText — Set Text


Construct a new Label

  • ? UI\Controls\Label
  • UI\Controls\Label::getText ?
  • PHP Manual
  • UI\Controls\Label
  • Construct a new Label

UI\Controls\Label::__construct

(UI 0.9.9)

UI\Controls\Label::__construct — Construct a new Label

说明

public UI\Controls\Label::__construct ( string $text )

Shall construct a new Label

参数

text

The text for this label


Get Text

  • ? UI\Controls\Label::__construct
  • UI\Controls\Label::setText ?
  • PHP Manual
  • UI\Controls\Label
  • Get Text

UI\Controls\Label::getText

(UI 0.9.9)

UI\Controls\Label::getText — Get Text

说明

public UI\Controls\Label::getText ( ) : string

Shall return the current text for this Label

Warning

本函数还未编写文档，仅有参数列表。

参数

此函数没有参数。

返回值


Set Text

  • ? UI\Controls\Label::getText
  • UI\Controls\Entry ?
  • PHP Manual
  • UI\Controls\Label
  • Set Text

UI\Controls\Label::setText

(UI 0.9.9)

UI\Controls\Label::setText — Set Text

说明

public UI\Controls\Label::setText ( string $text )

Shall set the text for this Label

参数

text

The new text


Entry Control

(UI 0.9.9)

简介

An Entry is a text entry control, suitable for entering plain text, passwords, or search terms.

类摘要

UI\Controls\Entry extends UI\Control {
/* Constants */
const int Normal ;
const int Password ;
const int Search ;
/* Constructor */
public __construct ( int $type = UI\Controls\Entry::Normal )
/* 方法 */
public getText ( ) : string
public isReadOnly ( ) : bool
protected onChange ( )
public setReadOnly ( bool $readOnly )
public setText ( string $text )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

预定义常量

UI\Controls\Entry::Normal

A normal single line entry

UI\Controls\Entry::Password

A password entry

UI\Controls\Entry::Search

A search entry

Table of Contents

  • UI\Controls\Entry::__construct — Construct a new Entry
  • UI\Controls\Entry::getText — Get Text
  • UI\Controls\Entry::isReadOnly — Detect Read Only
  • UI\Controls\Entry::onChange — Change Handler
  • UI\Controls\Entry::setReadOnly — Set Read Only
  • UI\Controls\Entry::setText — Set Text


Construct a new Entry

  • ? UI\Controls\Entry
  • UI\Controls\Entry::getText ?
  • PHP Manual
  • UI\Controls\Entry
  • Construct a new Entry

UI\Controls\Entry::__construct

(UI 0.9.9)

UI\Controls\Entry::__construct — Construct a new Entry

说明

public UI\Controls\Entry::__construct ( int $type = UI\Controls\Entry::Normal )

Construct a new entry of the given type

参数

type

Entry::Normal, Entry::Password, or Entry::Search


Get Text

  • ? UI\Controls\Entry::__construct
  • UI\Controls\Entry::isReadOnly ?
  • PHP Manual
  • UI\Controls\Entry
  • Get Text

UI\Controls\Entry::getText

(UI 0.9.9)

UI\Controls\Entry::getText — Get Text

说明

public UI\Controls\Entry::getText ( ) : string

Shall return the current text from this Entry

参数

此函数没有参数。

返回值

The current text


Detect Read Only

  • ? UI\Controls\Entry::getText
  • UI\Controls\Entry::onChange ?
  • PHP Manual
  • UI\Controls\Entry
  • Detect Read Only

UI\Controls\Entry::isReadOnly

(UI 0.9.9)

UI\Controls\Entry::isReadOnly — Detect Read Only

说明

public UI\Controls\Entry::isReadOnly ( ) : bool

Shall detect if this Entry is read only

参数

此函数没有参数。

返回值


Change Handler

  • ? UI\Controls\Entry::isReadOnly
  • UI\Controls\Entry::setReadOnly ?
  • PHP Manual
  • UI\Controls\Entry
  • Change Handler

UI\Controls\Entry::onChange

(UI 0.9.9)

UI\Controls\Entry::onChange — Change Handler

说明

protected UI\Controls\Entry::onChange ( )

Shall be executed when the text in this Entry changes

参数

此函数没有参数。


Set Read Only

  • ? UI\Controls\Entry::onChange
  • UI\Controls\Entry::setText ?
  • PHP Manual
  • UI\Controls\Entry
  • Set Read Only

UI\Controls\Entry::setReadOnly

(UI 0.9.9)

UI\Controls\Entry::setReadOnly — Set Read Only

说明

public UI\Controls\Entry::setReadOnly ( bool $readOnly )

Shall enable or disable read only for this Entry

参数

readOnly


Set Text

  • ? UI\Controls\Entry::setReadOnly
  • UI\Controls\MultilineEntry ?
  • PHP Manual
  • UI\Controls\Entry
  • Set Text

UI\Controls\Entry::setText

(UI 0.9.9)

UI\Controls\Entry::setText — Set Text

说明

public UI\Controls\Entry::setText ( string $text )

Shall set the text for this Entry

参数

text

The new text


MultilineEntry Control

(UI 0.9.9)

简介

A Multiline Entry is a text entry control able to hold multiple lines of text, with or without wrapping.

类摘要

UI\Controls\MultilineEntry extends UI\Control {
/* Constants */
const int Wrap ;
const int NoWrap ;
/* Constructor */
public __construct ( int $type = ? )
/* 方法 */
public append ( string $text )
public getText ( ) : string
public isReadOnly ( ) : bool
protected onChange ( )
public setReadOnly ( bool $readOnly )
public setText ( string $text )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

预定义常量

UI\Controls\MultilineEntry::Wrap

Allow lines to wrap

UI\Controls\MultilineEntry::NoWrap

Do not allow lines to wrap

Table of Contents

  • UI\Controls\MultilineEntry::append — Append Text
  • UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry
  • UI\Controls\MultilineEntry::getText — Get Text
  • UI\Controls\MultilineEntry::isReadOnly — Read Only Detection
  • UI\Controls\MultilineEntry::onChange — Change Handler
  • UI\Controls\MultilineEntry::setReadOnly — Set Read Only
  • UI\Controls\MultilineEntry::setText — Set Text


Append Text

  • ? UI\Controls\MultilineEntry
  • UI\Controls\MultilineEntry::__construct ?
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Append Text

UI\Controls\MultilineEntry::append

(UI 0.9.9)

UI\Controls\MultilineEntry::append — Append Text

说明

public UI\Controls\MultilineEntry::append ( string $text )

Shall append the given text to the text in this Multiline Entry

参数

text

The text to append


Construct a new Multiline Entry

  • ? UI\Controls\MultilineEntry::append
  • UI\Controls\MultilineEntry::getText ?
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Construct a new Multiline Entry

UI\Controls\MultilineEntry::__construct

(UI 0.9.9)

UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry

说明

public UI\Controls\MultilineEntry::__construct ( int $type = ? )

Shall construct a new Multiline Entry of the given type

参数

type

MultilineEntry::Wrap or MultilineEntry::NoWrap


Get Text

  • ? UI\Controls\MultilineEntry::__construct
  • UI\Controls\MultilineEntry::isReadOnly ?
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Get Text

UI\Controls\MultilineEntry::getText

(UI 0.9.9)

UI\Controls\MultilineEntry::getText — Get Text

说明

public UI\Controls\MultilineEntry::getText ( ) : string

Shall return the text in this Multiline Entry

参数

此函数没有参数。


Read Only Detection

  • ? UI\Controls\MultilineEntry::getText
  • UI\Controls\MultilineEntry::onChange ?
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Read Only Detection

UI\Controls\MultilineEntry::isReadOnly

(UI 0.9.9)

UI\Controls\MultilineEntry::isReadOnly — Read Only Detection

说明

public UI\Controls\MultilineEntry::isReadOnly ( ) : bool

Shall detect if this Multiline Entry is read only

参数

此函数没有参数。


Change Handler

  • ? UI\Controls\MultilineEntry::isReadOnly
  • UI\Controls\MultilineEntry::setReadOnly ?
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Change Handler

UI\Controls\MultilineEntry::onChange

(UI 0.9.9)

UI\Controls\MultilineEntry::onChange — Change Handler

说明

protected UI\Controls\MultilineEntry::onChange ( )

Shall be executed when the text in this Multiline Entry is changed

参数

此函数没有参数。


Set Read Only

  • ? UI\Controls\MultilineEntry::onChange
  • UI\Controls\MultilineEntry::setText ?
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Set Read Only

UI\Controls\MultilineEntry::setReadOnly

(UI 0.9.9)

UI\Controls\MultilineEntry::setReadOnly — Set Read Only

说明

public UI\Controls\MultilineEntry::setReadOnly ( bool $readOnly )

Shall enable or disable read only on this Multiline Entry

参数

readOnly


Set Text

  • ? UI\Controls\MultilineEntry::setReadOnly
  • UI\Controls\Spin ?
  • PHP Manual
  • UI\Controls\MultilineEntry
  • Set Text

UI\Controls\MultilineEntry::setText

(UI 0.9.9)

UI\Controls\MultilineEntry::setText — Set Text

说明

public UI\Controls\MultilineEntry::setText ( string $text )

Shall set the text in this Multiline Entry

参数

text

The new text


Spin Control

(UI 0.9.9)

简介

A Spin box is a text box with an up-down control which changes the integer value in the box, within a defined range

类摘要

UI\Controls\Spin extends UI\Control {
/* Constructor */
public __construct ( int $min , int $max )
/* 方法 */
public getValue ( ) : int
protected onChange ( )
public setValue ( int $value )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\Spin::__construct — Construct a new Spin
  • UI\Controls\Spin::getValue — Get Value
  • UI\Controls\Spin::onChange — Change Handler
  • UI\Controls\Spin::setValue — Set Value


Construct a new Spin

  • ? UI\Controls\Spin
  • UI\Controls\Spin::getValue ?
  • PHP Manual
  • UI\Controls\Spin
  • Construct a new Spin

UI\Controls\Spin::__construct

(UI 0.9.9)

UI\Controls\Spin::__construct — Construct a new Spin

说明

public UI\Controls\Spin::__construct ( int $min , int $max )

Constructs a new Spin with the given range

参数

min

The minimum value allowed

max

The maximum value allowed


Get Value

  • ? UI\Controls\Spin::__construct
  • UI\Controls\Spin::onChange ?
  • PHP Manual
  • UI\Controls\Spin
  • Get Value

UI\Controls\Spin::getValue

(UI 0.9.9)

UI\Controls\Spin::getValue — Get Value

说明

public UI\Controls\Spin::getValue ( ) : int

Get the value in this Spin

参数

此函数没有参数。


Change Handler

  • ? UI\Controls\Spin::getValue
  • UI\Controls\Spin::setValue ?
  • PHP Manual
  • UI\Controls\Spin
  • Change Handler

UI\Controls\Spin::onChange

(UI 0.9.9)

UI\Controls\Spin::onChange — Change Handler

说明

protected UI\Controls\Spin::onChange ( )

Shall be executed when the value in this Spin changes

参数

此函数没有参数。


Set Value

  • ? UI\Controls\Spin::onChange
  • UI\Controls\Slider ?
  • PHP Manual
  • UI\Controls\Spin
  • Set Value

UI\Controls\Spin::setValue

(UI 0.9.9)

UI\Controls\Spin::setValue — Set Value

说明

public UI\Controls\Spin::setValue ( int $value )

Set the value in this Spin

参数

value

The new value


Slider Control

(UI 0.9.9)

简介

A Slider is a control which represents a range, and a current value in the range. The sliding element of the control (sometimes called the "thumb") reflects the value, and can be adjusted within the range.

类摘要

UI\Controls\Slider extends UI\Control {
/* Constructor */
public __construct ( int $min , int $max )
/* 方法 */
public getValue ( ) : int
protected onChange ( )
public setValue ( int $value )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\Slider::__construct — Construct a new Slider
  • UI\Controls\Slider::getValue — Get Value
  • UI\Controls\Slider::onChange — Change Handler
  • UI\Controls\Slider::setValue — Set Value


Construct a new Slider

  • ? UI\Controls\Slider
  • UI\Controls\Slider::getValue ?
  • PHP Manual
  • UI\Controls\Slider
  • Construct a new Slider

UI\Controls\Slider::__construct

(UI 0.9.9)

UI\Controls\Slider::__construct — Construct a new Slider

说明

public UI\Controls\Slider::__construct ( int $min , int $max )

Construct a new Slider with the given range

参数

min

The minimum allowed value

max

The maximum allowed value


Get Value

  • ? UI\Controls\Slider::__construct
  • UI\Controls\Slider::onChange ?
  • PHP Manual
  • UI\Controls\Slider
  • Get Value

UI\Controls\Slider::getValue

(UI 0.9.9)

UI\Controls\Slider::getValue — Get Value

说明

public UI\Controls\Slider::getValue ( ) : int

Get the value from this Slider

参数

此函数没有参数。


Change Handler

  • ? UI\Controls\Slider::getValue
  • UI\Controls\Slider::setValue ?
  • PHP Manual
  • UI\Controls\Slider
  • Change Handler

UI\Controls\Slider::onChange

(UI 0.9.9)

UI\Controls\Slider::onChange — Change Handler

说明

protected UI\Controls\Slider::onChange ( )

Shall be executed when the value of this Slider changes

参数

此函数没有参数。


Set Value

  • ? UI\Controls\Slider::onChange
  • UI\Controls\Progress ?
  • PHP Manual
  • UI\Controls\Slider
  • Set Value

UI\Controls\Slider::setValue

(UI 0.9.9)

UI\Controls\Slider::setValue — Set Value

说明

public UI\Controls\Slider::setValue ( int $value )

Shall set the value for this Slider

参数

value

The new value


Progress Control

(UI 0.9.9)

简介

A Progress control is a familiar Progress bar: It represents progress as a percentage, with a possible range of 0 to 100 (inclusive).

类摘要

UI\Controls\Progress extends UI\Control {
/* 方法 */
public getValue ( ) : int
public setValue ( int $value )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\Progress::getValue — Get Value
  • UI\Controls\Progress::setValue — Set Value


Get Value

  • ? UI\Controls\Progress
  • UI\Controls\Progress::setValue ?
  • PHP Manual
  • UI\Controls\Progress
  • Get Value

UI\Controls\Progress::getValue

(UI 0.9.9)

UI\Controls\Progress::getValue — Get Value

说明

public UI\Controls\Progress::getValue ( ) : int

Shall retrieve the current value of this Progress bar

参数

此函数没有参数。


Set Value

  • ? UI\Controls\Progress::getValue
  • UI\Controls\Separator ?
  • PHP Manual
  • UI\Controls\Progress
  • Set Value

UI\Controls\Progress::setValue

(UI 0.9.9)

UI\Controls\Progress::setValue — Set Value

说明

public UI\Controls\Progress::setValue ( int $value )

Shall set the value for this Progress bar

参数

value

An integer between 0 and 100 (inclusive)


Control Separator

(UI 0.9.9)

简介

A Separator represents a control separator, it has no other function.

类摘要

UI\Controls\Separator extends UI\Control {
/* Constants */
const int Horizontal ;
const int Vertical ;
/* Constructor */
public __construct ( int $type = UI\Controls\Separator::Horizontal )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

预定义常量

UI\Controls\Separator::Horizontal

A Horizontal Separator

UI\Controls\Separator::Vertical

A Vertical Separator

Table of Contents

  • UI\Controls\Separator::__construct — Construct a new Separator


Construct a new Separator

  • ? UI\Controls\Separator
  • UI\Controls\Combo ?
  • PHP Manual
  • UI\Controls\Separator
  • Construct a new Separator

UI\Controls\Separator::__construct

(UI 0.9.9)

UI\Controls\Separator::__construct — Construct a new Separator

说明

public UI\Controls\Separator::__construct ( int $type = UI\Controls\Separator::Horizontal )

Shall construct a new Separator of the given type

参数

type

Separator::Horizonal or Separator::Vertical


Combo Control

(UI 0.9.9)

简介

A Combo control represents a list of options, like the familiar select HTML element.

类摘要

UI\Controls\Combo extends UI\Control {
/* 方法 */
public append ( string $text )
public getSelected ( ) : int
protected onSelected ( )
public setSelected ( int $index )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\Combo::append — Append Option
  • UI\Controls\Combo::getSelected — Get Selected Option
  • UI\Controls\Combo::onSelected — Selected Handler
  • UI\Controls\Combo::setSelected — Set Selected Option


Append Option

  • ? UI\Controls\Combo
  • UI\Controls\Combo::getSelected ?
  • PHP Manual
  • UI\Controls\Combo
  • Append Option

UI\Controls\Combo::append

(UI 0.9.9)

UI\Controls\Combo::append — Append Option

说明

public UI\Controls\Combo::append ( string $text )

Append an option to this Combo

参数

text

The text for the new option


Get Selected Option

  • ? UI\Controls\Combo::append
  • UI\Controls\Combo::onSelected ?
  • PHP Manual
  • UI\Controls\Combo
  • Get Selected Option

UI\Controls\Combo::getSelected

(UI 0.9.9)

UI\Controls\Combo::getSelected — Get Selected Option

说明

public UI\Controls\Combo::getSelected ( ) : int

Shall retrieve the index of the option selected in this Combo

参数

此函数没有参数。


Selected Handler

  • ? UI\Controls\Combo::getSelected
  • UI\Controls\Combo::setSelected ?
  • PHP Manual
  • UI\Controls\Combo
  • Selected Handler

UI\Controls\Combo::onSelected

(UI 0.9.9)

UI\Controls\Combo::onSelected — Selected Handler

说明

protected UI\Controls\Combo::onSelected ( )

Shall be executed when an option is selected in this Combo

参数

此函数没有参数。


Set Selected Option

  • ? UI\Controls\Combo::onSelected
  • UI\Controls\EditableCombo ?
  • PHP Manual
  • UI\Controls\Combo
  • Set Selected Option

UI\Controls\Combo::setSelected

(UI 0.9.9)

UI\Controls\Combo::setSelected — Set Selected Option

说明

public UI\Controls\Combo::setSelected ( int $index )

Shall set the currently selected option in this Combo

参数

index

The index of the option to select


EdiableCombo Control

(UI 0.9.9)

简介

An Editable Combo is a Combo which allows the user to enter custom options

类摘要

UI\Controls\EditableCombo extends UI\Control {
/* 方法 */
public append ( string $text )
public getText ( ) : string
protected onChange ( )
public setText ( string $text )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\EditableCombo::append — Append Option
  • UI\Controls\EditableCombo::getText — Get Text
  • UI\Controls\EditableCombo::onChange — Change Handler
  • UI\Controls\EditableCombo::setText — Set Text


Append Option

  • ? UI\Controls\EditableCombo
  • UI\Controls\EditableCombo::getText ?
  • PHP Manual
  • UI\Controls\EditableCombo
  • Append Option

UI\Controls\EditableCombo::append

(UI 0.9.9)

UI\Controls\EditableCombo::append — Append Option

说明

public UI\Controls\EditableCombo::append ( string $text )

Shall append a new option to this Editable Combo

参数

text

The text for the new option


Get Text

  • ? UI\Controls\EditableCombo::append
  • UI\Controls\EditableCombo::onChange ?
  • PHP Manual
  • UI\Controls\EditableCombo
  • Get Text

UI\Controls\EditableCombo::getText

(UI 0.9.9)

UI\Controls\EditableCombo::getText — Get Text

说明

public UI\Controls\EditableCombo::getText ( ) : string

Get the value of the currently selected option in this Editable Combo

参数

此函数没有参数。


Change Handler

  • ? UI\Controls\EditableCombo::getText
  • UI\Controls\EditableCombo::setText ?
  • PHP Manual
  • UI\Controls\EditableCombo
  • Change Handler

UI\Controls\EditableCombo::onChange

(UI 0.9.9)

UI\Controls\EditableCombo::onChange — Change Handler

说明

protected UI\Controls\EditableCombo::onChange ( )

Shall be executed when the value of this Editable Combobox changes

参数

此函数没有参数。


Set Text

  • ? UI\Controls\EditableCombo::onChange
  • UI\Controls\Radio ?
  • PHP Manual
  • UI\Controls\EditableCombo
  • Set Text

UI\Controls\EditableCombo::setText

(UI 0.9.9)

UI\Controls\EditableCombo::setText — Set Text

说明

public UI\Controls\EditableCombo::setText ( string $text )

Shall set the text of the currently selected option in this Editable Combo

参数

text

The new text


Radio Control

(UI 0.9.9)

简介

A Radio is similar to the radio input type familiar from HTML

类摘要

UI\Controls\Radio extends UI\Control {
/* 方法 */
public append ( string $text )
public getSelected ( ) : int
protected onSelected ( )
public setSelected ( int $index )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

Table of Contents

  • UI\Controls\Radio::append — Append Option
  • UI\Controls\Radio::getSelected — Get Selected Option
  • UI\Controls\Radio::onSelected — Selected Handler
  • UI\Controls\Radio::setSelected — Set Selected Option


Append Option

  • ? UI\Controls\Radio
  • UI\Controls\Radio::getSelected ?
  • PHP Manual
  • UI\Controls\Radio
  • Append Option

UI\Controls\Radio::append

(UI 0.9.9)

UI\Controls\Radio::append — Append Option

说明

public UI\Controls\Radio::append ( string $text )

Shall append a new option to this Radio

参数

text

The text (label) for the option


Get Selected Option

  • ? UI\Controls\Radio::append
  • UI\Controls\Radio::onSelected ?
  • PHP Manual
  • UI\Controls\Radio
  • Get Selected Option

UI\Controls\Radio::getSelected

(UI 0.9.9)

UI\Controls\Radio::getSelected — Get Selected Option

说明

public UI\Controls\Radio::getSelected ( ) : int

Shall retrieve the index of the currently selected option in this Radio

参数

此函数没有参数。


Selected Handler

  • ? UI\Controls\Radio::getSelected
  • UI\Controls\Radio::setSelected ?
  • PHP Manual
  • UI\Controls\Radio
  • Selected Handler

UI\Controls\Radio::onSelected

(UI 0.9.9)

UI\Controls\Radio::onSelected — Selected Handler

说明

protected UI\Controls\Radio::onSelected ( )

Shall be executed when the option selected in this Radio changes

参数

此函数没有参数。


Set Selected Option

  • ? UI\Controls\Radio::onSelected
  • UI\Controls\Picker ?
  • PHP Manual
  • UI\Controls\Radio
  • Set Selected Option

UI\Controls\Radio::setSelected

(UI 0.9.9)

UI\Controls\Radio::setSelected — Set Selected Option

说明

public UI\Controls\Radio::setSelected ( int $index )

Shall set the currently selected option in this Radio

参数

index

The index of the option to select


Picker Control

(UI 0.9.9)

简介

A Picker represents a button which when clicked presents a native Date/Time/DateTime Picker interface to the user.

类摘要

UI\Controls\Picker extends UI\Control {
/* Constants */
const int Date ;
const int Time ;
const int DateTime ;
/* Constructor */
public __construct ( int $type = UI\Controls\Picker::Date )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

预定义常量

UI\Controls\Picker::Date

A Date Picker

UI\Controls\Picker::Time

A Time Picker

UI\Controls\Picker::DateTime

A Date and Time Picker

Table of Contents

  • UI\Controls\Picker::__construct — Construct a new Picker


Construct a new Picker

  • ? UI\Controls\Picker
  • UI\Controls\Form ?
  • PHP Manual
  • UI\Controls\Picker
  • Construct a new Picker

UI\Controls\Picker::__construct

(UI 0.9.9)

UI\Controls\Picker::__construct — Construct a new Picker

说明

public UI\Controls\Picker::__construct ( int $type = UI\Controls\Picker::Date )

Construct a new Picker of the given type

参数

type

Picker::Date, Picker::Time, or Picker::DateTime


Control Form (Arrangement)

(UI 0.9.9)

简介

A Form is a control which allows the arrangement of other controls into a familiar layout (the form).

类摘要

UI\Controls\Form extends UI\Control {
/* 属性 */
protected $controls ;
/* 方法 */
public append ( string $label , UI\Control $control , bool $stretchy = false ) : int
public delete ( int $index ) : bool
public isPadded ( ) : bool
public setPadded ( bool $padded )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

属性

controls

Contains controls, should not be manipulated directly

Table of Contents

  • UI\Controls\Form::append — Append Control
  • UI\Controls\Form::delete — Delete Control
  • UI\Controls\Form::isPadded — Padding Detection
  • UI\Controls\Form::setPadded — Set Padding


Append Control

  • ? UI\Controls\Form
  • UI\Controls\Form::delete ?
  • PHP Manual
  • UI\Controls\Form
  • Append Control

UI\Controls\Form::append

(UI 0.9.9)

UI\Controls\Form::append — Append Control

说明

public UI\Controls\Form::append ( string $label , UI\Control $control , bool $stretchy = false ) : int

Shall append the control to the form, and set the label

参数

label

The text for the label

control

A control

stretchy

Should be set true to stretch the control

返回值

Shall return the index of the appended control, may be 0


Delete Control

  • ? UI\Controls\Form::append
  • UI\Controls\Form::isPadded ?
  • PHP Manual
  • UI\Controls\Form
  • Delete Control

UI\Controls\Form::delete

(UI 0.9.9)

UI\Controls\Form::delete — Delete Control

说明

public UI\Controls\Form::delete ( int $index ) : bool

Shall delete the control at the given index in this Form

参数

index

The index of the control to remove

返回值

Indication of succcess


Padding Detection

  • ? UI\Controls\Form::delete
  • UI\Controls\Form::setPadded ?
  • PHP Manual
  • UI\Controls\Form
  • Padding Detection

UI\Controls\Form::isPadded

(UI 0.9.9)

UI\Controls\Form::isPadded — Padding Detection

说明

public UI\Controls\Form::isPadded ( ) : bool

Shall detect if padding is enabled on this Form

参数

此函数没有参数。


Set Padding

  • ? UI\Controls\Form::isPadded
  • UI\Controls\Grid ?
  • PHP Manual
  • UI\Controls\Form
  • Set Padding

UI\Controls\Form::setPadded

(UI 0.9.9)

UI\Controls\Form::setPadded — Set Padding

说明

public UI\Controls\Form::setPadded ( bool $padded )

Shall enable or disable padding on this Form

参数

padded


Control Grid (Arrangement)

(UI 0.9.9)

简介

A Grid is a control which is allows the arrangement of children into a grid

类摘要

UI\Controls\Grid extends UI\Control {
/* Constants */
const int Fill ;
const int Start ;
const int Center ;
const int End ;
const int Leading ;
const int Top ;
const int Trailing ;
const int Bottom ;
/* 属性 */
protected $controls ;
/* 方法 */
public append ( UI\Control $control , int $left , int $top , int $xspan , int $yspan , bool $hexpand , int $halign , bool $vexpand , int $valign )
public isPadded ( ) : bool
public setPadded ( bool $padding )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

预定义常量

UI\Controls\Grid::Fill

UI\Controls\Grid::Start

UI\Controls\Grid::Center

UI\Controls\Grid::End

UI\Controls\Grid::Leading

UI\Controls\Grid::Top

UI\Controls\Grid::Trailing

UI\Controls\Grid::Bottom

属性

controls

Contains controls, should not be manipulated directly

Table of Contents

  • UI\Controls\Grid::append — Append Control
  • UI\Controls\Grid::isPadded — Padding Detection
  • UI\Controls\Grid::setPadded — Set Padding


Append Control

  • ? UI\Controls\Grid
  • UI\Controls\Grid::isPadded ?
  • PHP Manual
  • UI\Controls\Grid
  • Append Control

UI\Controls\Grid::append

(UI 0.9.9)

UI\Controls\Grid::append — Append Control

说明

public UI\Controls\Grid::append ( UI\Control $control , int $left , int $top , int $xspan , int $yspan , bool $hexpand , int $halign , bool $vexpand , int $valign )

Warning

本函数还未编写文档，仅有参数列表。

参数

control

The Control to append

left

top

xspan

yspan

hexpand

halign

vexpand

valign

返回值


Padding Detection

  • ? UI\Controls\Grid::append
  • UI\Controls\Grid::setPadded ?
  • PHP Manual
  • UI\Controls\Grid
  • Padding Detection

UI\Controls\Grid::isPadded

(UI 0.9.9)

UI\Controls\Grid::isPadded — Padding Detection

说明

public UI\Controls\Grid::isPadded ( ) : bool

Shall detect if padding is enabled on this Grid

参数

此函数没有参数。


Set Padding

  • ? UI\Controls\Grid::isPadded
  • UI\Controls\Group ?
  • PHP Manual
  • UI\Controls\Grid
  • Set Padding

UI\Controls\Grid::setPadded

(UI 0.9.9)

UI\Controls\Grid::setPadded — Set Padding

说明

public UI\Controls\Grid::setPadded ( bool $padding )

Shall enable or disable padding for this Grid

参数

padding


Control Group (Arrangement)

(UI 0.9.9)

简介

A Group is a titled container for child controls

类摘要

UI\Controls\Group extends UI\Control {
/* 属性 */
protected $controls ;
/* Constructor */
public __construct ( string $title )
/* 方法 */
public append ( UI\Control $control )
public getTitle ( ) : string
public hasMargin ( ) : bool
public setMargin ( bool $margin )
public setTitle ( string $title )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

属性

controls

Contains controls, should not be manipulated directly

Table of Contents

  • UI\Controls\Group::append — Append Control
  • UI\Controls\Group::__construct — Construct a new Group
  • UI\Controls\Group::getTitle — Get Title
  • UI\Controls\Group::hasMargin — Margin Detection
  • UI\Controls\Group::setMargin — Set Margin
  • UI\Controls\Group::setTitle — Set Title


Append Control

  • ? UI\Controls\Group
  • UI\Controls\Group::__construct ?
  • PHP Manual
  • UI\Controls\Group
  • Append Control

UI\Controls\Group::append

(No version information available, might only be in Git)

UI\Controls\Group::append — Append Control

说明

public UI\Controls\Group::append ( UI\Control $control )

Shall append a control to this Group

参数

control

The control to append


Construct a new Group

  • ? UI\Controls\Group::append
  • UI\Controls\Group::getTitle ?
  • PHP Manual
  • UI\Controls\Group
  • Construct a new Group

UI\Controls\Group::__construct

(UI 0.9.9)

UI\Controls\Group::__construct — Construct a new Group

说明

public UI\Controls\Group::__construct ( string $title )

Shall construct a new Group with the given title

参数

title

The text for the title label


Get Title

  • ? UI\Controls\Group::__construct
  • UI\Controls\Group::hasMargin ?
  • PHP Manual
  • UI\Controls\Group
  • Get Title

UI\Controls\Group::getTitle

(UI 0.9.9)

UI\Controls\Group::getTitle — Get Title

说明

public UI\Controls\Group::getTitle ( ) : string

Shall return the current title for this Group

参数

此函数没有参数。

返回值

The current title


Margin Detection

  • ? UI\Controls\Group::getTitle
  • UI\Controls\Group::setMargin ?
  • PHP Manual
  • UI\Controls\Group
  • Margin Detection

UI\Controls\Group::hasMargin

(UI 0.9.9)

UI\Controls\Group::hasMargin — Margin Detection

说明

public UI\Controls\Group::hasMargin ( ) : bool

Shall detect if this Group has a margin

参数

此函数没有参数。


Set Margin

  • ? UI\Controls\Group::hasMargin
  • UI\Controls\Group::setTitle ?
  • PHP Manual
  • UI\Controls\Group
  • Set Margin

UI\Controls\Group::setMargin

(UI 0.9.9)

UI\Controls\Group::setMargin — Set Margin

说明

public UI\Controls\Group::setMargin ( bool $margin )

Shall enable or disable margins for this Group

参数

margin


Set Title

  • ? UI\Controls\Group::setMargin
  • UI\Controls\Box ?
  • PHP Manual
  • UI\Controls\Group
  • Set Title

UI\Controls\Group::setTitle

(UI 0.9.9)

UI\Controls\Group::setTitle — Set Title

说明

public UI\Controls\Group::setTitle ( string $title )

Shall set the title for this Group

参数

title

The text for the new title


Control Box (Arrangement)

(UI 0.9.9)

简介

A Box allows the arrangement of other controls

类摘要

UI\Controls\Box extends UI\Control {
/* Constants */
const int Vertical ;
const int Horizontal ;
/* 属性 */
protected $controls ;
/* Constructor */
public __construct ( int $orientation = UI\Controls\Box::Horizontal )
/* 方法 */
public append ( Control $control , bool $stretchy = false ) : int
public delete ( int $index ) : bool
public getOrientation ( ) : int
public isPadded ( ) : bool
public setPadded ( bool $padded )
/* 继承的方法 */
public UI\Control::destroy ( )
public UI\Control::disable ( )
public UI\Control::enable ( )
public UI\Control::getParent ( ) : UI\Control
public UI\Control::getTopLevel ( ) : int
public UI\Control::hide ( )
public UI\Control::isEnabled ( ) : bool
public UI\Control::isVisible ( ) : bool
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( )
}

属性

controls

Contains controls, should not be manipulated directly

预定义常量

UI\Controls\Box::Vertical

UI\Controls\Box::Horizontal

Table of Contents

  • UI\Controls\Box::append — Append Control
  • UI\Controls\Box::__construct — Construct a new Box
  • UI\Controls\Box::delete — Delete Control
  • UI\Controls\Box::getOrientation — Get Orientation
  • UI\Controls\Box::isPadded — Padding Detection
  • UI\Controls\Box::setPadded — Set Padding


Append Control

  • ? UI\Controls\Box
  • UI\Controls\Box::__construct ?
  • PHP Manual
  • UI\Controls\Box
  • Append Control

UI\Controls\Box::append

(UI 0.9.9)

UI\Controls\Box::append — Append Control

说明

public UI\Controls\Box::append ( Control $control , bool $stretchy = false ) : int

Shall append the given control to this Box

参数

control

The control to append

stretchy

Set true to stretch the control

返回值

Shall return the index of the appended control, may be 0


Construct a new Box

  • ? UI\Controls\Box::append
  • UI\Controls\Box::delete ?
  • PHP Manual
  • UI\Controls\Box
  • Construct a new Box

UI\Controls\Box::__construct

(UI 0.9.9)

UI\Controls\Box::__construct — Construct a new Box

说明

public UI\Controls\Box::__construct ( int $orientation = UI\Controls\Box::Horizontal )

Shall construct a new box

参数

orientation

Box::Horizontal or Box::Vertical


Delete Control

  • ? UI\Controls\Box::__construct
  • UI\Controls\Box::getOrientation ?
  • PHP Manual
  • UI\Controls\Box
  • Delete Control

UI\Controls\Box::delete

(UI 0.9.9)

UI\Controls\Box::delete — Delete Control

说明

public UI\Controls\Box::delete ( int $index ) : bool

Shall delete the control at the given index from this Box

参数

index

The index of the control to delete

返回值

Indication of success


Get Orientation

  • ? UI\Controls\Box::delete
  • UI\Controls\Box::isPadded ?
  • PHP Manual
  • UI\Controls\Box
  • Get Orientation

UI\Controls\Box::getOrientation

(UI 0.9.9)

UI\Controls\Box::getOrientation — Get Orientation

说明

public UI\Controls\Box::getOrientation ( ) : int

Shall retrieve the orientation of this Box

参数

此函数没有参数。


Padding Detection

  • ? UI\Controls\Box::getOrientation
  • UI\Controls\Box::setPadded ?
  • PHP Manual
  • UI\Controls\Box
  • Padding Detection

UI\Controls\Box::isPadded

(UI 0.9.9)

UI\Controls\Box::isPadded — Padding Detection

说明

public UI\Controls\Box::isPadded ( ) : bool

Shall detect if padding is enabled on this Box

参数

此函数没有参数。


Set Padding

  • ? UI\Controls\Box::isPadded
  • UI\Draw\Pen ?
  • PHP Manual
  • UI\Controls\Box
  • Set Padding

UI\Controls\Box::setPadded

(UI 0.9.9)

UI\Controls\Box::setPadded — Set Padding

说明

public UI\Controls\Box::setPadded ( bool $padded )

Shall enable or disable padding on this Box

参数

padded


Draw Pen

(UI 0.9.9)

简介

The Pen is passed to the Area Draw event handler, it is used for clipping, filling, stroking, and writing to Draw Paths.

类摘要

final UI\Draw\Pen {
/* 方法 */
public clip ( UI\Draw\Path $path )
public fill ( UI\Draw\Path $path , UI\Draw\Brush $with )
public fill ( UI\Draw\Path $path , UI\Draw\Color $with )
public fill ( UI\Draw\Path $path , int $with )
public restore ( )
public save ( )
public stroke ( UI\Draw\Path $path , UI\Draw\Brush $with , UI\Draw\Stroke $stroke )
public stroke ( UI\Draw\Path $path , UI\Draw\Color $with , UI\Draw\Stroke $stroke )
public stroke ( UI\Draw\Path $path , int $with , UI\Draw\Stroke $stroke )
public transform ( UI\Draw\Matrix $matrix )
public write ( UI\Point $point , UI\Draw\Text\Layout $layout )
}

Table of Contents

  • UI\Draw\Pen::clip — Clip a Path
  • UI\Draw\Pen::fill — Fill a Path
  • UI\Draw\Pen::restore — Restore
  • UI\Draw\Pen::save — Save
  • UI\Draw\Pen::stroke — Stroke a Path
  • UI\Draw\Pen::transform — Matrix Transform
  • UI\Draw\Pen::write — Draw Text at Point


Clip a Path

  • ? UI\Draw\Pen
  • UI\Draw\Pen::fill ?
  • PHP Manual
  • UI\Draw\Pen
  • Clip a Path

UI\Draw\Pen::clip

(UI 0.9.9)

UI\Draw\Pen::clip — Clip a Path

说明

public UI\Draw\Pen::clip ( UI\Draw\Path $path )

Shall clip the given Path

参数

path

The path to clip


Fill a Path

  • ? UI\Draw\Pen::clip
  • UI\Draw\Pen::restore ?
  • PHP Manual
  • UI\Draw\Pen
  • Fill a Path

UI\Draw\Pen::fill

(UI 0.9.9)

UI\Draw\Pen::fill — Fill a Path

说明

public UI\Draw\Pen::fill ( UI\Draw\Path $path , UI\Draw\Brush $with )
public UI\Draw\Pen::fill ( UI\Draw\Path $path , UI\Draw\Color $with )
public UI\Draw\Pen::fill ( UI\Draw\Path $path , int $with )

Shall fill the given path

参数

path

The path to fill

with

The color or brush to fill with


Restore

  • ? UI\Draw\Pen::fill
  • UI\Draw\Pen::save ?
  • PHP Manual
  • UI\Draw\Pen
  • Restore

UI\Draw\Pen::restore

(UI 0.9.9)

UI\Draw\Pen::restore — Restore

说明

public UI\Draw\Pen::restore ( )

Shall restore a previously saved Pen

参数

此函数没有参数。


Save

  • ? UI\Draw\Pen::restore
  • UI\Draw\Pen::stroke ?
  • PHP Manual
  • UI\Draw\Pen
  • Save

UI\Draw\Pen::save

(UI 0.9.9)

UI\Draw\Pen::save — Save

说明

public UI\Draw\Pen::save ( )

Shall save the Pen

参数

此函数没有参数。


Stroke a Path

  • ? UI\Draw\Pen::save
  • UI\Draw\Pen::transform ?
  • PHP Manual
  • UI\Draw\Pen
  • Stroke a Path

UI\Draw\Pen::stroke

(UI 0.9.9)

UI\Draw\Pen::stroke — Stroke a Path

说明

public UI\Draw\Pen::stroke ( UI\Draw\Path $path , UI\Draw\Brush $with , UI\Draw\Stroke $stroke )
public UI\Draw\Pen::stroke ( UI\Draw\Path $path , UI\Draw\Color $with , UI\Draw\Stroke $stroke )
public UI\Draw\Pen::stroke ( UI\Draw\Path $path , int $with , UI\Draw\Stroke $stroke )

Shall stroke the given path

参数

path

The path to stroke

with

The color or brush to stroke with

stroke

The configuration of the stroke


Matrix Transform

  • ? UI\Draw\Pen::stroke
  • UI\Draw\Pen::write ?
  • PHP Manual
  • UI\Draw\Pen
  • Matrix Transform

UI\Draw\Pen::transform

(UI 0.9.9)

UI\Draw\Pen::transform — Matrix Transform

说明

public UI\Draw\Pen::transform ( UI\Draw\Matrix $matrix )

Shall perform matrix transformation

参数

matrix

The matrix to use


Draw Text at Point

  • ? UI\Draw\Pen::transform
  • UI\Draw\Path ?
  • PHP Manual
  • UI\Draw\Pen
  • Draw Text at Point

UI\Draw\Pen::write

(UI 0.9.9)

UI\Draw\Pen::write — Draw Text at Point

说明

public UI\Draw\Pen::write ( UI\Point $point , UI\Draw\Text\Layout $layout )

Shall draw the given text layout at the given point

参数

point

The point to perform the drawing

layout

The layout of the text to draw


Draw Path

(UI 0.9.9)

简介

A Draw Path guides a Draw Pen, telling the Pen where to draw on an Area.

类摘要

UI\Draw\Path {
/* Constants */
const int Winding ;
const int Alternate ;
/* Constructor */
public __construct ( int $mode = UI\Draw\Path::Winding )
/* 方法 */
public addRectangle ( UI\Point $point , UI\Size $size )
public arcTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public bezierTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public closeFigure ( )
public end ( )
public lineTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public newFigure ( UI\Point $point )
public newFigureWithArc ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
}

预定义常量

UI\Draw\Path::Winding

This is the default draw path mode

UI\Draw\Path::Alternate

This is the alternate draw path mode

Table of Contents

  • UI\Draw\Path::addRectangle — Draw a Rectangle
  • UI\Draw\Path::arcTo — Draw an Arc
  • UI\Draw\Path::bezierTo — Draw Bezier Curve
  • UI\Draw\Path::closeFigure — Close Figure
  • UI\Draw\Path::__construct — Construct a new Path
  • UI\Draw\Path::end — Finalize Path
  • UI\Draw\Path::lineTo — Draw a Line
  • UI\Draw\Path::newFigure — Draw Figure
  • UI\Draw\Path::newFigureWithArc — Draw Figure with Arc


Draw a Rectangle

  • ? UI\Draw\Path
  • UI\Draw\Path::arcTo ?
  • PHP Manual
  • UI\Draw\Path
  • Draw a Rectangle

UI\Draw\Path::addRectangle

(UI 0.9.9)

UI\Draw\Path::addRectangle — Draw a Rectangle

说明

public UI\Draw\Path::addRectangle ( UI\Point $point , UI\Size $size )

Shall map the path of a rectangle of the given size, at the given point

参数

point

The point to begin the shape

size

The size of the rectangle


Draw an Arc

  • ? UI\Draw\Path::addRectangle
  • UI\Draw\Path::bezierTo ?
  • PHP Manual
  • UI\Draw\Path
  • Draw an Arc

UI\Draw\Path::arcTo

(UI 0.9.9)

UI\Draw\Path::arcTo — Draw an Arc

说明

public UI\Draw\Path::arcTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Shall map the path for an arc

参数

point

The point to begin mapping

radius

The radius of the arc

angle

The angle of the arc

sweep

The sweep of the arc

negative

返回值


Draw Bezier Curve

  • ? UI\Draw\Path::arcTo
  • UI\Draw\Path::closeFigure ?
  • PHP Manual
  • UI\Draw\Path
  • Draw Bezier Curve

UI\Draw\Path::bezierTo

(UI 0.9.9)

UI\Draw\Path::bezierTo — Draw Bezier Curve

说明

public UI\Draw\Path::bezierTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Shall draw a bezier curve

参数

point

The point at which to begin mapping

radius

The radius of the curve

angle

The angle of the curve

sweep

The sweep of the curve

negative


Close Figure

  • ? UI\Draw\Path::bezierTo
  • UI\Draw\Path::__construct ?
  • PHP Manual
  • UI\Draw\Path
  • Close Figure

UI\Draw\Path::closeFigure

(UI 0.9.9)

UI\Draw\Path::closeFigure — Close Figure

说明

public UI\Draw\Path::closeFigure ( )

Shall close the current figure

参数

此函数没有参数。


Construct a new Path

  • ? UI\Draw\Path::closeFigure
  • UI\Draw\Path::end ?
  • PHP Manual
  • UI\Draw\Path
  • Construct a new Path

UI\Draw\Path::__construct

(UI 0.9.9)

UI\Draw\Path::__construct — Construct a new Path

说明

public UI\Draw\Path::__construct ( int $mode = UI\Draw\Path::Winding )

Shall construct a new path in the given mode

参数

mode

Path::Winding or Path::Alternate


Finalize Path

  • ? UI\Draw\Path::__construct
  • UI\Draw\Path::lineTo ?
  • PHP Manual
  • UI\Draw\Path
  • Finalize Path

UI\Draw\Path::end

(UI 0.9.9)

UI\Draw\Path::end — Finalize Path

说明

public UI\Draw\Path::end ( )

Shall finalize this Path

参数

此函数没有参数。


Draw a Line

  • ? UI\Draw\Path::end
  • UI\Draw\Path::newFigure ?
  • PHP Manual
  • UI\Draw\Path
  • Draw a Line

UI\Draw\Path::lineTo

(UI 0.9.9)

UI\Draw\Path::lineTo — Draw a Line

说明

public UI\Draw\Path::lineTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Shall map the path for a line

参数

point

The point to begin mapping

radius

angle

sweep

negative

返回值


Draw Figure

  • ? UI\Draw\Path::lineTo
  • UI\Draw\Path::newFigureWithArc ?
  • PHP Manual
  • UI\Draw\Path
  • Draw Figure

UI\Draw\Path::newFigure

(UI 0.9.9)

UI\Draw\Path::newFigure — Draw Figure

说明

public UI\Draw\Path::newFigure ( UI\Point $point )

Shall map a new figure at the given point

参数

point

The point to begin mapping


Draw Figure with Arc

  • ? UI\Draw\Path::newFigure
  • UI\Draw\Matrix ?
  • PHP Manual
  • UI\Draw\Path
  • Draw Figure with Arc

UI\Draw\Path::newFigureWithArc

(UI 0.9.9)

UI\Draw\Path::newFigureWithArc — Draw Figure with Arc

说明

public UI\Draw\Path::newFigureWithArc ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

参数

point

radius

angle

sweep

negative

返回值


Draw Matrix

(UI 0.9.9)

简介

类摘要

UI\Draw\Matrix {
/* 方法 */
public invert ( )
public isInvertible ( ) : bool
public multiply ( UI\Draw\Matrix $matrix ) : UI\Draw\Matrix
public rotate ( UI\Point $point , float $amount )
public scale ( UI\Point $center , UI\Point $point )
public skew ( UI\Point $point , UI\Point $amount )
public translate ( UI\Point $point )
}

Table of Contents

  • UI\Draw\Matrix::invert — Invert Matrix
  • UI\Draw\Matrix::isInvertible — Invertible Detection
  • UI\Draw\Matrix::multiply — Multiply Matrix
  • UI\Draw\Matrix::rotate — Rotate Matrix
  • UI\Draw\Matrix::scale — Scale Matrix
  • UI\Draw\Matrix::skew — Skew Matrix
  • UI\Draw\Matrix::translate — Translate Matrix


Invert Matrix

  • ? UI\Draw\Matrix
  • UI\Draw\Matrix::isInvertible ?
  • PHP Manual
  • UI\Draw\Matrix
  • Invert Matrix

UI\Draw\Matrix::invert

(UI 0.9.9)

UI\Draw\Matrix::invert — Invert Matrix

说明

public UI\Draw\Matrix::invert ( )

Shall invert this matrix

参数

此函数没有参数。


Invertible Detection

  • ? UI\Draw\Matrix::invert
  • UI\Draw\Matrix::multiply ?
  • PHP Manual
  • UI\Draw\Matrix
  • Invertible Detection

UI\Draw\Matrix::isInvertible

(UI 0.9.9)

UI\Draw\Matrix::isInvertible — Invertible Detection

说明

public UI\Draw\Matrix::isInvertible ( ) : bool

Shall detect if this Matrix may be inverted

参数

此函数没有参数。


Multiply Matrix

  • ? UI\Draw\Matrix::isInvertible
  • UI\Draw\Matrix::rotate ?
  • PHP Manual
  • UI\Draw\Matrix
  • Multiply Matrix

UI\Draw\Matrix::multiply

(UI 0.9.9)

UI\Draw\Matrix::multiply — Multiply Matrix

说明

public UI\Draw\Matrix::multiply ( UI\Draw\Matrix $matrix ) : UI\Draw\Matrix

Shall multiply this matrix with the given matrix

参数

此函数没有参数。

返回值

The new Matrix


Rotate Matrix

  • ? UI\Draw\Matrix::multiply
  • UI\Draw\Matrix::scale ?
  • PHP Manual
  • UI\Draw\Matrix
  • Rotate Matrix

UI\Draw\Matrix::rotate

(UI 0.9.9)

UI\Draw\Matrix::rotate — Rotate Matrix

说明

public UI\Draw\Matrix::rotate ( UI\Point $point , float $amount )

Shall rotate this Matrix

参数

point

amount


Scale Matrix

  • ? UI\Draw\Matrix::rotate
  • UI\Draw\Matrix::skew ?
  • PHP Manual
  • UI\Draw\Matrix
  • Scale Matrix

UI\Draw\Matrix::scale

(UI 0.9.9)

UI\Draw\Matrix::scale — Scale Matrix

说明

public UI\Draw\Matrix::scale ( UI\Point $center , UI\Point $point )

Shall scale this Matrix

参数

center

point


Skew Matrix

  • ? UI\Draw\Matrix::scale
  • UI\Draw\Matrix::translate ?
  • PHP Manual
  • UI\Draw\Matrix
  • Skew Matrix

UI\Draw\Matrix::skew

(UI 0.9.9)

UI\Draw\Matrix::skew — Skew Matrix

说明

public UI\Draw\Matrix::skew ( UI\Point $point , UI\Point $amount )

Shall skew this Matrix

参数

point

amount


Translate Matrix

  • ? UI\Draw\Matrix::skew
  • UI\Draw\Color ?
  • PHP Manual
  • UI\Draw\Matrix
  • Translate Matrix

UI\Draw\Matrix::translate

(UI 0.9.9)

UI\Draw\Matrix::translate — Translate Matrix

说明

public UI\Draw\Matrix::translate ( UI\Point $point )

Shall translate this Matrix

参数

point


Color Representation

(UI 0.9.9)

简介

Represents RGBA colours, individual channels are accessible via public properties.

类摘要

UI\Draw\Color {
/* Constants */
const int Red ;
const int Green ;
const int Blue ;
const int Alpha ;
/* 属性 */
public $r ;
public $g ;
public $b ;
public $a ;
/* Constructor */
public __construct ( UI\Draw\Color $color = ? )
public __construct ( int $color = ? )
/* 方法 */
public getChannel ( int $channel ) : float
public setChannel ( int $channel , float $value ) : void
}

属性

r

Provides access to the red channel

g

Provides access to the green channel

b

Provides access to the blue channel

a

Provides access to the alpha channel

预定义常量

UI\Draw\Color::Red

Identifies the red channel

UI\Draw\Color::Green

Identifies the green channel

UI\Draw\Color::Blue

Identifies the blue channel

UI\Draw\Color::Alpha

Identifies the alpha channel

Table of Contents

  • UI\Draw\Color::__construct — Construct new Color
  • UI\Draw\Color::getChannel — Color Manipulation
  • UI\Draw\Color::setChannel — Color Manipulation


Construct new Color

  • ? UI\Draw\Color
  • UI\Draw\Color::getChannel ?
  • PHP Manual
  • UI\Draw\Color
  • Construct new Color

UI\Draw\Color::__construct

(UI 0.9.9)

UI\Draw\Color::__construct — Construct new Color

说明

public UI\Draw\Color::__construct ( UI\Draw\Color $color = ? )
public UI\Draw\Color::__construct ( int $color = ? )

Shall construct a new color

参数

color

May be UI\Draw\Color or RRGGBBAA


Color Manipulation

  • ? UI\Draw\Color::__construct
  • UI\Draw\Color::setChannel ?
  • PHP Manual
  • UI\Draw\Color
  • Color Manipulation

UI\Draw\Color::getChannel

(UI 0.9.9)

UI\Draw\Color::getChannel — Color Manipulation

说明

public UI\Draw\Color::getChannel ( int $channel ) : float

Shall retrieve the value for a channel

参数

channel

Constant channel identity

返回值

The current value of the requested channel


Color Manipulation

  • ? UI\Draw\Color::getChannel
  • UI\Draw\Stroke ?
  • PHP Manual
  • UI\Draw\Color
  • Color Manipulation

UI\Draw\Color::setChannel

(UI 0.9.9)

UI\Draw\Color::setChannel — Color Manipulation

说明

public UI\Draw\Color::setChannel ( int $channel , float $value ) : void

Shall set the selected channel to the given value

参数

channel

Constant channel identity

value

The new value for the selected channel

返回值


Draw Stroke

(UI 0.9.9)

简介

Holds the configuration for the Pen to perform a stroke

类摘要

UI\Draw\Stroke {
/* Constructor */
public __construct ( int $cap = UI\Draw\Line\Cap::Flat , int $join = UI\Draw\Line\Join::Miter , float $thickness = 1 , float $miterLimit = 10 )
/* 方法 */
public getCap ( ) : int
public getJoin ( ) : int
public getMiterLimit ( ) : float
public getThickness ( ) : float
public setCap ( int $cap )
public setJoin ( int $join )
public setMiterLimit ( float $limit )
public setThickness ( float $thickness )
}

Table of Contents

  • UI\Draw\Stroke::__construct — Construct a new Stroke
  • UI\Draw\Stroke::getCap — Get Line Cap
  • UI\Draw\Stroke::getJoin — Get Line Join
  • UI\Draw\Stroke::getMiterLimit — Get Miter Limit
  • UI\Draw\Stroke::getThickness — Get Thickness
  • UI\Draw\Stroke::setCap — Set Line Cap
  • UI\Draw\Stroke::setJoin — Set Line Join
  • UI\Draw\Stroke::setMiterLimit — Set Miter Limit
  • UI\Draw\Stroke::setThickness — Set Thickness


Construct a new Stroke

  • ? UI\Draw\Stroke
  • UI\Draw\Stroke::getCap ?
  • PHP Manual
  • UI\Draw\Stroke
  • Construct a new Stroke

UI\Draw\Stroke::__construct

(UI 0.9.9)

UI\Draw\Stroke::__construct — Construct a new Stroke

说明

public UI\Draw\Stroke::__construct ( int $cap = UI\Draw\Line\Cap::Flat , int $join = UI\Draw\Line\Join::Miter , float $thickness = 1 , float $miterLimit = 10 )

Shall construct a new Stroke

参数

cap

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, or UI\Draw\Line\Cap::Square

join

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, or UI\Draw\Line\Join::Bevel

thickness

The thickness of the stroke

miterLimit

Miter limit (default is sensible for all supported platforms)


Get Line Cap

  • ? UI\Draw\Stroke::__construct
  • UI\Draw\Stroke::getJoin ?
  • PHP Manual
  • UI\Draw\Stroke
  • Get Line Cap

UI\Draw\Stroke::getCap

(UI 0.9.9)

UI\Draw\Stroke::getCap — Get Line Cap

说明

public UI\Draw\Stroke::getCap ( ) : int

Shall retrieve the line cap setting of this Stroke

参数

此函数没有参数。

返回值

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, or UI\Draw\Line\Cap::Square


Get Line Join

  • ? UI\Draw\Stroke::getCap
  • UI\Draw\Stroke::getMiterLimit ?
  • PHP Manual
  • UI\Draw\Stroke
  • Get Line Join

UI\Draw\Stroke::getJoin

(UI 0.9.9)

UI\Draw\Stroke::getJoin — Get Line Join

说明

public UI\Draw\Stroke::getJoin ( ) : int

Shall retrieve the line join setting of this Stroke

参数

此函数没有参数。

返回值

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, or UI\Draw\Line\Join::Bevel


Get Miter Limit

  • ? UI\Draw\Stroke::getJoin
  • UI\Draw\Stroke::getThickness ?
  • PHP Manual
  • UI\Draw\Stroke
  • Get Miter Limit

UI\Draw\Stroke::getMiterLimit

(UI 0.9.9)

UI\Draw\Stroke::getMiterLimit — Get Miter Limit

说明

public UI\Draw\Stroke::getMiterLimit ( ) : float

Shall retrieve the miter limit of this Stroke

参数

此函数没有参数。

返回值

The current miter limit


Get Thickness

  • ? UI\Draw\Stroke::getMiterLimit
  • UI\Draw\Stroke::setCap ?
  • PHP Manual
  • UI\Draw\Stroke
  • Get Thickness

UI\Draw\Stroke::getThickness

(UI 0.9.9)

UI\Draw\Stroke::getThickness — Get Thickness

说明

public UI\Draw\Stroke::getThickness ( ) : float

Shall retrieve the thickness of this Stroke

参数

此函数没有参数。

返回值

The current thickness


Set Line Cap

  • ? UI\Draw\Stroke::getThickness
  • UI\Draw\Stroke::setJoin ?
  • PHP Manual
  • UI\Draw\Stroke
  • Set Line Cap

UI\Draw\Stroke::setCap

(UI 0.9.9)

UI\Draw\Stroke::setCap — Set Line Cap

说明

public UI\Draw\Stroke::setCap ( int $cap )

Shall set the line cap setting for this Stroke

参数

cap

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, or UI\Draw\Line\Cap::Square


Set Line Join

  • ? UI\Draw\Stroke::setCap
  • UI\Draw\Stroke::setMiterLimit ?
  • PHP Manual
  • UI\Draw\Stroke
  • Set Line Join

UI\Draw\Stroke::setJoin

(UI 0.9.9)

UI\Draw\Stroke::setJoin — Set Line Join

说明

public UI\Draw\Stroke::setJoin ( int $join )

Shall set the line join setting for this Stroke

参数

join

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, or UI\Draw\Line\Join::Bevel

返回值


Set Miter Limit

  • ? UI\Draw\Stroke::setJoin
  • UI\Draw\Stroke::setThickness ?
  • PHP Manual
  • UI\Draw\Stroke
  • Set Miter Limit

UI\Draw\Stroke::setMiterLimit

(UI 0.9.9)

UI\Draw\Stroke::setMiterLimit — Set Miter Limit

说明

public UI\Draw\Stroke::setMiterLimit ( float $limit )

Set the miter limit for this Stroke

参数

limit

The new limit


Set Thickness

  • ? UI\Draw\Stroke::setMiterLimit
  • UI\Draw\Brush ?
  • PHP Manual
  • UI\Draw\Stroke
  • Set Thickness

UI\Draw\Stroke::setThickness

(UI 0.9.9)

UI\Draw\Stroke::setThickness — Set Thickness

说明

public UI\Draw\Stroke::setThickness ( float $thickness )

Shall set the thickness for this Stroke

参数

thickness

The new thickness


Brushes

(UI 0.9.9)

简介

Represents a solid color brush

类摘要

UI\Draw\Brush {
/* Constructor */
public __construct ( UI\Draw\Color $color )
public __construct ( int $color )
/* 方法 */
public getColor ( ) : UI\Draw\Color
public setColor ( UI\Draw\Color $color ) : void
public setColor ( int $color ) : void
}

Table of Contents

  • UI\Draw\Brush::__construct — Construct a new Brush
  • UI\Draw\Brush::getColor — Get Color
  • UI\Draw\Brush::setColor — Set Color


Construct a new Brush

  • ? UI\Draw\Brush
  • UI\Draw\Brush::getColor ?
  • PHP Manual
  • UI\Draw\Brush
  • Construct a new Brush

UI\Draw\Brush::__construct

(UI 0.9.9)

UI\Draw\Brush::__construct — Construct a new Brush

说明

public UI\Draw\Brush::__construct ( UI\Draw\Color $color )
public UI\Draw\Brush::__construct ( int $color )

Shall construct a solid brush using the given color

参数

color

Can be a UI\Draw\Color or RRGGBBAA


Get Color

  • ? UI\Draw\Brush::__construct
  • UI\Draw\Brush::setColor ?
  • PHP Manual
  • UI\Draw\Brush
  • Get Color

UI\Draw\Brush::getColor

(UI 0.9.9)

UI\Draw\Brush::getColor — Get Color

说明

public UI\Draw\Brush::getColor ( ) : UI\Draw\Color

Shall return a UI\Draw\Color for this brush

参数

此函数没有参数。

返回值

The current color of the brush


Set Color

  • ? UI\Draw\Brush::getColor
  • UI\Draw\Brush\Gradient ?
  • PHP Manual
  • UI\Draw\Brush
  • Set Color

UI\Draw\Brush::setColor

(UI 0.9.9)

UI\Draw\Brush::setColor — Set Color

说明

public UI\Draw\Brush::setColor ( UI\Draw\Color $color ) : void
public UI\Draw\Brush::setColor ( int $color ) : void

Shall set the color of this brush to the color provided

参数

color

Can be a UI\Draw\Color or RRGGBBAA

返回值


Gradient Brushes

(UI 2.0.0)

简介

Abstract for gradient brushes

类摘要

abstract UI\Draw\Brush\Gradient extends UI\Draw\Brush {
/* 方法 */
public addStop ( float $position , UI\Draw\Color $color ) : int
public addStop ( float $position , int $color ) : int
public delStop ( int $index ) : int
public setStop ( int $index , float $position , UI\Draw\Color $color ) : bool
public setStop ( int $index , float $position , int $color ) : bool
/* 继承的方法 */
public UI\Draw\Brush::getColor ( ) : UI\Draw\Color
public UI\Draw\Brush::setColor ( UI\Draw\Color $color ) : void
public UI\Draw\Brush::setColor ( int $color ) : void
}

Table of Contents

  • UI\Draw\Brush\Gradient::addStop — Stop Manipulation
  • UI\Draw\Brush\Gradient::delStop — Stop Manipulation
  • UI\Draw\Brush\Gradient::setStop — Stop Manipulation


Stop Manipulation

  • ? UI\Draw\Brush\Gradient
  • UI\Draw\Brush\Gradient::delStop ?
  • PHP Manual
  • UI\Draw\Brush\Gradient
  • Stop Manipulation

UI\Draw\Brush\Gradient::addStop

(UI 2.0.0)

UI\Draw\Brush\Gradient::addStop — Stop Manipulation

说明

public UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color ) : int
public UI\Draw\Brush\Gradient::addStop ( float $position , int $color ) : int

Shall at a stop of the given color at the given position

参数

position

The position for the new stop

color

The color for the new stop, may be UI\Draw\Color or RRGGBBAA

返回值

Total number of stops


Stop Manipulation

  • ? UI\Draw\Brush\Gradient::addStop
  • UI\Draw\Brush\Gradient::setStop ?
  • PHP Manual
  • UI\Draw\Brush\Gradient
  • Stop Manipulation

UI\Draw\Brush\Gradient::delStop

(UI 2.0.0)

UI\Draw\Brush\Gradient::delStop — Stop Manipulation

说明

public UI\Draw\Brush\Gradient::delStop ( int $index ) : int

Warning

本函数还未编写文档，仅有参数列表。

参数

index

返回值

Total number of stops


Stop Manipulation

  • ? UI\Draw\Brush\Gradient::delStop
  • UI\Draw\Brush\LinearGradient ?
  • PHP Manual
  • UI\Draw\Brush\Gradient
  • Stop Manipulation

UI\Draw\Brush\Gradient::setStop

(UI 2.0.0)

UI\Draw\Brush\Gradient::setStop — Stop Manipulation

说明

public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , UI\Draw\Color $color ) : bool
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , int $color ) : bool

参数

index

The index of the stop to set

position

The position for the stop

color

The color for the stop, may be UI\Draw\Color or RRGGBBAA

返回值

Indication of success


Linear Gradient

(UI 2.0.0)

简介

类摘要

UI\Draw\Brush\LinearGradient extends UI\Draw\Brush\Gradient {
/* Constructor */
public __construct ( UI\Point $start , UI\Point $end )
/* 继承的方法 */
public UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color ) : int
public UI\Draw\Brush\Gradient::addStop ( float $position , int $color ) : int
public UI\Draw\Brush\Gradient::delStop ( int $index ) : int
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , UI\Draw\Color $color ) : bool
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , int $color ) : bool
}

Table of Contents

  • UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient


Construct a Linear Gradient

  • ? UI\Draw\Brush\LinearGradient
  • UI\Draw\Brush\RadialGradient ?
  • PHP Manual
  • UI\Draw\Brush\LinearGradient
  • Construct a Linear Gradient

UI\Draw\Brush\LinearGradient::__construct

(UI 2.0.0)

UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient

说明

public UI\Draw\Brush\LinearGradient::__construct ( UI\Point $start , UI\Point $end )

Shall construct a new linear gradient

参数

start

end


Radial Gradient

(UI 2.0.0)

简介

类摘要

UI\Draw\Brush\RadialGradient extends UI\Draw\Brush\Gradient {
/* Constructor */
public __construct ( UI\Point $start , UI\Point $outer , float $radius )
/* 继承的方法 */
public UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color ) : int
public UI\Draw\Brush\Gradient::addStop ( float $position , int $color ) : int
public UI\Draw\Brush\Gradient::delStop ( int $index ) : int
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , UI\Draw\Color $color ) : bool
public UI\Draw\Brush\Gradient::setStop ( int $index , float $position , int $color ) : bool
}

Table of Contents

  • UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient


Construct a new Radial Gradient

  • ? UI\Draw\Brush\RadialGradient
  • UI\Draw\Text\Layout ?
  • PHP Manual
  • UI\Draw\Brush\RadialGradient
  • Construct a new Radial Gradient

UI\Draw\Brush\RadialGradient::__construct

(UI 2.0.0)

UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient

说明

public UI\Draw\Brush\RadialGradient::__construct ( UI\Point $start , UI\Point $outer , float $radius )

Shall construct a new radial gradient

参数

start

outer

radius


Represents Text Layout

(UI 0.9.9)

简介

A Text Layout represents the layout of text which will be drawn by the Pen

类摘要

UI\Draw\Text\Layout {
/* Constructor */
public __construct ( string $text , UI\Draw\Text\Font $font , float $width )
/* 方法 */
public setColor ( UI\Draw\Color $color , int $start = 0 , int $end = ? )
public setColor ( int $color , int $start = 0 , int $end = ? )
public setWidth ( float $width )
}

Table of Contents

  • UI\Draw\Text\Layout::__construct — Construct a new Text Layout
  • UI\Draw\Text\Layout::setColor — Set Color
  • UI\Draw\Text\Layout::setWidth — Set Width


Construct a new Text Layout

  • ? UI\Draw\Text\Layout
  • UI\Draw\Text\Layout::setColor ?
  • PHP Manual
  • UI\Draw\Text\Layout
  • Construct a new Text Layout

UI\Draw\Text\Layout::__construct

(UI 0.9.9)

UI\Draw\Text\Layout::__construct — Construct a new Text Layout

说明

public UI\Draw\Text\Layout::__construct ( string $text , UI\Draw\Text\Font $font , float $width )

Shall construct a new Text Layout

参数

text

The text for the layout

font

The font to use for writing

width

The width of the layout


Set Color

  • ? UI\Draw\Text\Layout::__construct
  • UI\Draw\Text\Layout::setWidth ?
  • PHP Manual
  • UI\Draw\Text\Layout
  • Set Color

UI\Draw\Text\Layout::setColor

(UI 0.9.9)

UI\Draw\Text\Layout::setColor — Set Color

说明

public UI\Draw\Text\Layout::setColor ( UI\Draw\Color $color , int $start = 0 , int $end = ? )
public UI\Draw\Text\Layout::setColor ( int $color , int $start = 0 , int $end = ? )

Shall set the Color for all of, or a range of the text in the Layout

参数

color

The color to use

start

The starting character

end

The ending character, by default the end of the string


Set Width

  • ? UI\Draw\Text\Layout::setColor
  • UI\Draw\Text\Font ?
  • PHP Manual
  • UI\Draw\Text\Layout
  • Set Width

UI\Draw\Text\Layout::setWidth

(UI 0.9.9)

UI\Draw\Text\Layout::setWidth — Set Width

说明

public UI\Draw\Text\Layout::setWidth ( float $width )

Shall set the width of this Text Layout

参数

width

The new width


Represents a Font

(UI 0.9.9)

简介

Loads a described font

类摘要

UI\Draw\Text\Font {
/* Constructor */
public __construct ( UI\Draw\Text\Font\Descriptor $descriptor )
/* 方法 */
public getAscent ( ) : float
public getDescent ( ) : float
public getLeading ( ) : float
public getUnderlinePosition ( ) : float
public getUnderlineThickness ( ) : float
}

Table of Contents

  • UI\Draw\Text\Font::__construct — Construct a new Font
  • UI\Draw\Text\Font::getAscent — Font Metrics
  • UI\Draw\Text\Font::getDescent — Font Metrics
  • UI\Draw\Text\Font::getLeading — Font Metrics
  • UI\Draw\Text\Font::getUnderlinePosition — Font Metrics
  • UI\Draw\Text\Font::getUnderlineThickness — Font Metrics


Construct a new Font

  • ? UI\Draw\Text\Font
  • UI\Draw\Text\Font::getAscent ?
  • PHP Manual
  • UI\Draw\Text\Font
  • Construct a new Font

UI\Draw\Text\Font::__construct

(UI 0.9.9)

UI\Draw\Text\Font::__construct — Construct a new Font

说明

public UI\Draw\Text\Font::__construct ( UI\Draw\Text\Font\Descriptor $descriptor )

Shall construct a new Font using the given descriptor

参数

descriptor

The descriptor for the Font


Font Metrics

  • ? UI\Draw\Text\Font::__construct
  • UI\Draw\Text\Font::getDescent ?
  • PHP Manual
  • UI\Draw\Text\Font
  • Font Metrics

UI\Draw\Text\Font::getAscent

(UI 1.0.3)

UI\Draw\Text\Font::getAscent — Font Metrics

说明

public UI\Draw\Text\Font::getAscent ( ) : float

参数

此函数没有参数。

返回值


Font Metrics

  • ? UI\Draw\Text\Font::getAscent
  • UI\Draw\Text\Font::getLeading ?
  • PHP Manual
  • UI\Draw\Text\Font
  • Font Metrics

UI\Draw\Text\Font::getDescent

(UI 1.0.3)

UI\Draw\Text\Font::getDescent — Font Metrics

说明

public UI\Draw\Text\Font::getDescent ( ) : float

参数

此函数没有参数。

返回值


Font Metrics

  • ? UI\Draw\Text\Font::getDescent
  • UI\Draw\Text\Font::getUnderlinePosition ?
  • PHP Manual
  • UI\Draw\Text\Font
  • Font Metrics

UI\Draw\Text\Font::getLeading

(UI 1.0.3)

UI\Draw\Text\Font::getLeading — Font Metrics

说明

public UI\Draw\Text\Font::getLeading ( ) : float

参数

此函数没有参数。

返回值


Font Metrics

  • ? UI\Draw\Text\Font::getLeading
  • UI\Draw\Text\Font::getUnderlineThickness ?
  • PHP Manual
  • UI\Draw\Text\Font
  • Font Metrics

UI\Draw\Text\Font::getUnderlinePosition

(UI 1.0.3)

UI\Draw\Text\Font::getUnderlinePosition — Font Metrics

说明

public UI\Draw\Text\Font::getUnderlinePosition ( ) : float

参数

此函数没有参数。

返回值


Font Metrics

  • ? UI\Draw\Text\Font::getUnderlinePosition
  • UI\Draw\Text\Font\Descriptor ?
  • PHP Manual
  • UI\Draw\Text\Font
  • Font Metrics

UI\Draw\Text\Font::getUnderlineThickness

(UI 1.0.3)

UI\Draw\Text\Font::getUnderlineThickness — Font Metrics

说明

public UI\Draw\Text\Font::getUnderlineThickness ( ) : float

参数

此函数没有参数。

返回值


Font Descriptor

(UI 0.9.9)

简介

Describes a font

类摘要

UI\Draw\Text\Font\Descriptor {
/* Constructor */
public __construct ( string $family , float $size , int $weight = UI\Draw\Text\Font\Weight::Normal , int $italic = UI\Draw\Text\Font\Italic::Normal , int $stretch = UI\Draw\Text\Font\Stretch::Normal )
/* 方法 */
public getFamily ( ) : string
public getItalic ( ) : int
public getSize ( ) : float
public getStretch ( ) : int
public getWeight ( ) : int
}

Table of Contents

  • UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor
  • UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family
  • UI\Draw\Text\Font\Descriptor::getItalic — Style Detection
  • UI\Draw\Text\Font\Descriptor::getSize — Size Detection
  • UI\Draw\Text\Font\Descriptor::getStretch — Style Detection
  • UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection


Construct a new Font Descriptor

  • ? UI\Draw\Text\Font\Descriptor
  • UI\Draw\Text\Font\Descriptor::getFamily ?
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Construct a new Font Descriptor

UI\Draw\Text\Font\Descriptor::__construct

(UI 0.9.9)

UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor

说明

public UI\Draw\Text\Font\Descriptor::__construct ( string $family , float $size , int $weight = UI\Draw\Text\Font\Weight::Normal , int $italic = UI\Draw\Text\Font\Italic::Normal , int $stretch = UI\Draw\Text\Font\Stretch::Normal )

Shall construct a new Font Descriptor

参数

family

The name of a valid family of fonts

size

The preferred size

weight

UI\Draw\Text\Font\Weight constant

italic

UI\Draw\Text\Font\Italic constant

stretch

UI\Draw\Text\Font\Stretch constant


Get Font Family

  • ? UI\Draw\Text\Font\Descriptor::__construct
  • UI\Draw\Text\Font\Descriptor::getItalic ?
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Get Font Family

UI\Draw\Text\Font\Descriptor::getFamily

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family

说明

public UI\Draw\Text\Font\Descriptor::getFamily ( ) : string

Shall return the requested font family

参数

此函数没有参数。

返回值


Style Detection

  • ? UI\Draw\Text\Font\Descriptor::getFamily
  • UI\Draw\Text\Font\Descriptor::getSize ?
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Style Detection

UI\Draw\Text\Font\Descriptor::getItalic

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getItalic — Style Detection

说明

public UI\Draw\Text\Font\Descriptor::getItalic ( ) : int

Shall return constant setting

参数

此函数没有参数。

返回值


Size Detection

  • ? UI\Draw\Text\Font\Descriptor::getItalic
  • UI\Draw\Text\Font\Descriptor::getStretch ?
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Size Detection

UI\Draw\Text\Font\Descriptor::getSize

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getSize — Size Detection

说明

public UI\Draw\Text\Font\Descriptor::getSize ( ) : float

Shall return the requested size

参数

此函数没有参数。

返回值


Style Detection

  • ? UI\Draw\Text\Font\Descriptor::getSize
  • UI\Draw\Text\Font\Descriptor::getWeight ?
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Style Detection

UI\Draw\Text\Font\Descriptor::getStretch

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getStretch — Style Detection

说明

public UI\Draw\Text\Font\Descriptor::getStretch ( ) : int

Shall return requested stretch

参数

此函数没有参数。

返回值


Weight Detection

  • ? UI\Draw\Text\Font\Descriptor::getStretch
  • UI 函数 ?
  • PHP Manual
  • UI\Draw\Text\Font\Descriptor
  • Weight Detection

UI\Draw\Text\Font\Descriptor::getWeight

(UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection

说明

public UI\Draw\Text\Font\Descriptor::getWeight ( ) : int

Shall return requested weight

参数

此函数没有参数。

返回值


UI 函数

Table of Contents

  • UI\Draw\Text\Font\fontFamilies — Retrieve Font Families
  • UI\quit — Quit UI Loop
  • UI\run — Enter UI Loop


Retrieve Font Families

  • ? UI 函数
  • UI\quit ?
  • PHP Manual
  • UI 函数
  • Retrieve Font Families

UI\Draw\Text\Font\fontFamilies

(UI 0.9.9)

UI\Draw\Text\Font\fontFamilies — Retrieve Font Families

说明

UI\Draw\Text\Font\fontFamilies ( ) : array

Returns an array of valid font families for the current system

参数

此函数没有参数。


Quit UI Loop

  • ? UI\Draw\Text\Font\fontFamilies
  • UI\run ?
  • PHP Manual
  • UI 函数
  • Quit UI Loop

UI\quit

(UI 2.0.0)

UI\quit — Quit UI Loop

说明

UI\quit ( ) : void

Shall cause the main loop to be exited

参数

此函数没有参数。

返回值


Enter UI Loop

  • ? UI\quit
  • UI\Draw\Text\Font\Weight ?
  • PHP Manual
  • UI 函数
  • Enter UI Loop

UI\run

(UI 2.0.0)

UI\run — Enter UI Loop

说明

UI\run ( int $flags = ? ) : void

Shall cause PHP to enter into the main loop, by default control will not be returned to the caller

参数

flags

Set UI\Loop to return control, and UI\Wait to return control after waiting

返回值


Font Weight Settings

(UI 0.9.9)

简介

类摘要

final UI\Draw\Text\Font\Weight {
/* Constants */
const int Thin ;
const int UltraLight ;
const int Light ;
const int Book ;
const int Normal ;
const int Medium ;
const int SemiBold ;
const int Bold ;
const int UltraBold ;
const int Heavy ;
const int UltraHeavy ;
}


Italic Font Settings

(UI 0.9.9)

简介

类摘要

final UI\Draw\Text\Font\Italic {
/* Constants */
const int Normal = 0 ;
const int Oblique = 1 ;
const int Italic = 2 ;
}


Font Stretch Settings

(UI 0.9.9)

简介

类摘要

final UI\Draw\Text\Font\Stretch {
/* Constants */
const int UltraCondensed = 0 ;
const int ExtraCondensed = 1 ;
const int Condensed = 2 ;
const int SemiCondensed = 3 ;
const int Normal = 4 ;
const int SemiExpanded = 5 ;
const int Expanded = 6 ;
const int ExtraExpanded = 7 ;
const int UltraExpanded = 8 ;
}


Line Cap Settings

(UI 0.9.9)

简介

类摘要

final UI\Draw\Line\Cap {
/* Constants */
const int Flat ;
const int Round ;
const int Square ;
}


Line Join Settings

(UI 0.9.9)

简介

类摘要

final UI\Draw\Line\Join {
/* Constants */
const int Miter ;
const int Round ;
const int Bevel ;
}


Key Identifiers

(UI 1.0.0)

简介

类摘要

final UI\Key {
/* Constants */
const int Escape ;
const int Insert ;
const int Delete ;
const int Home ;
const int End ;
const int PageUp ;
const int PageDown ;
const int Up ;
const int Down ;
const int Left ;
const int Right ;
const int F1 ;
const int F2 ;
const int F3 ;
const int F4 ;
const int F5 ;
const int F6 ;
const int F7 ;
const int F8 ;
const int F9 ;
const int F10 ;
const int F11 ;
const int F12 ;
const int N0 ;
const int N1 ;
const int N2 ;
const int N3 ;
const int N4 ;
const int N5 ;
const int N6 ;
const int N7 ;
const int N8 ;
const int N9 ;
const int NDot ;
const int NEnter ;
const int NAdd ;
const int NSubtract ;
const int NMultiply ;
const int NDivide ;
}


InvalidArgumentException

(UI 1.0.3)

简介

类摘要

UI\Exception\InvalidArgumentException extends InvalidArgumentException implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


RuntimeException

(UI 1.0.3)

简介

类摘要

UI\Exception\RuntimeException extends RuntimeException implements Throwable {
/* 继承的属性 */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* 继承的方法 */
final public Exception::getMessage ( ) : string
final public Exception::getPrevious ( ) : Throwable
final public Exception::getCode ( ) : mixed
final public Exception::getFile ( ) : string
final public Exception::getLine ( ) : int
final public Exception::getTrace ( ) : array
final public Exception::getTraceAsString ( ) : string
public Exception::__toString ( ) : string
final private Exception::__clone ( ) : void
}


FAQ：常见问题

  • 一般信息
  • 邮件列表
  • 获取 PHP
  • 数据库问题
  • 安装 — 安装常见问题
  • 编译问题
  • 使用 PHP
  • 密码散列 — 密码散列安全
  • PHP 和 HTML
  • PHP 和 COM
  • 其他问题


一般信息

本章包括了有关 PHP 的大多数一般问题： 它是什么和它做什么。

  1. PHP是什么？
  2. PHP 这个缩写指的是什么？
  3. PHP 版本之间有什么联系？
  4. 可以同时运行几个不同版本的 PHP 吗？
  5. 我觉得自己发现了一个 bug！应该告诉谁？
PHP是什么？

根据本手册的 前言：

PHP 是一种 HTML 嵌入式的脚本语言。 它的很多语法来自 C，Java 和 Perl， 并具有几个 PHP 独有的特点。 该语言的主要目标是让 Web 开发人员快速地书写动态生成的网页。

PHP 这个缩写指的是什么？

PHP 是PHP: Hypertext Preprocessor的首字母缩写。 很多人有些糊涂了，因为缩写中的第一个字母也来自缩写。 这种方法叫做递归缩写（recursive acronyms）， 对此好奇的人可以访问 » 在线计算机词典（Free On-Line Dictionary of Computing） 或者Wikipedia上 » 递归缩写 的解释。

PHP 版本之间有什么联系？

PHP/FI 2.0 是最早的 PHP 版本，已经不再支持。 PHP 3 是 PHP/FI 2.0 的后继者，要好很多。 PHP 7 是目前一代的 PHP，内部使用了 Zend 引擎 3 代， 除了很多新功能之外还提供了许多附加的 面向对象编程（OOP） 特性。

可以同时运行几个不同版本的 PHP 吗？

可以，请参阅见 PHP 源程序发行包中的 INSTALL文件。

我觉得自己发现了一个 bug！应该告诉谁？

应该访问 PHP Bug 数据库并确认你发现的不是一个已知的 bug。 如果你在数据库中没有看到同样的， 用报告表单来报告此 bug。 使用 bug 数据库而不是给某个邮件列表发邮件非常重要， 因为该 bug 会被分配一个跟踪号码， 这样你就有可能在以后回来查看该 bug 的状态。 Bug 数据库在 » https://bugs.php.net/。


邮件列表

本章包括有关如何与 PHP 团体接触的问题。最好的方法是邮件列表。

  1. 有没有 PHP 的邮件列表？
  2. 还有其它的团体吗？
  3. 我可以建立我自己的PHP邮件列表吗？
  4. 救命！我看来不能订阅／取消任何一个邮件列表！
  5. 在哪里有个邮件列表的归档吗？
  6. 我可以在邮件列表中问什么？
  7. 向邮件列表发帖子时我需要包括些什么信息？
有没有 PHP 的邮件列表？

当然有！有很多关于几个主题的邮件列表。所有邮件列表的完整列表在 » 技术支持页面。

最通用的邮件列表是 php-general。要订阅，发送一封邮件到 » php-general-subscribe@lists.php.net。不需要在邮件主题或内容中包括任何特殊单词。要取消订阅，发送一封邮件到 » php-general-unsubscribe@lists.php.net。

也可以在我们的 » 技术支持页面通过 web 界面来订阅和取消。

还有其它的团体吗？

世界上有无数 PHP 团体。我们的 » 技术支持页面上有例如一些 IRC 服务器和其它语种的邮件列表。

我可以建立我自己的PHP邮件列表吗？

百分百可以！实际上，我们不仅允许这么做，而且鼓励这么做！ 通过分享您在PHP方面的知识和经验来帮助他人， 有助于促进PHP组织和PHP语言本身的增长和发展。

救命！我看来不能订阅／取消任何一个邮件列表！

如果你在订阅或取消 php-general 邮件列表上有问题，可能是因为邮件列表软件没法确定你正确的邮件地址。如果你的 email 地址是 joeblow@example.com，可以将订阅请求发送到 php-general-subscribe-joeblow=example.com@lists.php.net，或者将取消请求发送到 php-general-unsubscribe-joeblow=example.com@lists.php.net。对其它邮件列表用类似的地址。

The most common reason folks have a hard time unsubscribing from our mailing lists is due to the use of mail forwarders. For example, if your email address is danbrown@example.com, but you subscribed to the mailing list with the forwarder php-lists@example.com and forward that to danbrown@example.com, attempting to unsubscribe danbrown@example.com will not work, as that address is not even known to our systems. Instead, you will need to unsubscribe the address to which the mail is being sent - in this example, php-lists@example.com.

在哪里有个邮件列表的归档吗？

是的，你可以在 » 技术支持页面找到归档站点的列表。 You will also find dozens of sites that archive and/or syndicate our mailing list content by using your favorite Internet search engine and searching for "php mailing list archives".

邮件列表的文章也被作为新闻组消息归档。你可以用新闻组客户端来访问位于 » news://news.php.net/的新闻组服务器。也有一个试验性质的新闻组服务器的 web 界面位于 » http://news.php.net/。

我可以在邮件列表中问什么？

由于 PHP 一天比一天更流行，php-general 邮件列表的流量增加到现在的每天 150 到 200 个帖子。由于此原因，为了每个人的利益，使用此列表是你在寻找过所有其它地方后的最后手段。

在你向列表发帖之前请先看看本 FAQ 以及手册是不是能找到帮助。如果找不到的话试试邮件列表归档（见上面）。如果你有安装或者配置 PHP 的问题请从头到尾读一遍所有包含的文档和 README 文件。如果还是不能找到任何可以帮助你的信息，那么很欢迎你使用此邮件列表。

To ensure that you receive the best responses (and to reduce the likelihood of frustrating your fellow developers), please be sure to post your question to the appropriate list. For example, if you are having difficulties installing PHP, you should send your question to the php-install mailing list. A caveat: some lists have similar names and completely different uses; a question regarding PHP scripts on Windows should be directed to the Windows PHP users list, not to the Windows Internals list.

在提问之前，阅读一下 » 怎样聪明地发问这篇文章对每个人都是个好主意。

向邮件列表发帖子时我需要包括些什么信息？

像"我不能启动运行 PHP！帮帮我！哪里出错了？"之类的贴子对任何人都完全没有用。如果你在启动和运行 PHP 上有问题你必须包括你运行的操作系统，你试图配置的 PHP 版本，你怎样得到的（预编译的，CVS，RPM 等等），目前为止你都做了些什么，卡在了何处以及确切的错误信息。

这也同样适用于其它问题。你必须包括你做了什么，卡在了哪里，你试图做什么以及，如果有的话，确切的错误信息。如果你有源代码的问题那你需要包括不起作用部分的代码。可是不要包括超出所必需的代码！这将使贴子很难读并使很多人为此而跳过它。如果你不确定应该在邮件中包括多少信息，那包括多一些比一点点更好。

另一件重要的事是记住在主题一行中概述你的问题。类似"救命！"或者"这是怎么回事？"的主题会被一大半读者忽略。

最后，我们鼓励你阅读一下 » 怎样聪明地发问这篇文章。这对每个人都有很大帮助，尤其是你自己。


获取 PHP

本章包括 PHP 下载地址以及操作系统相关问题的详细资料。

  1. PHP 可以从哪里得到？
  2. 有预先编译好的可执行版本吗？
  3. 编译一些可选的 PHP 扩展库所需的库文件可以从哪里得到？
  4. 怎样使这些库起作用？
  5. 在我的 Windows 机器上通过 Git 仓库获取最新的 PHP 源码后，我应该如何去编译？
  6. 哪里可以找到 browscap.ini 文件？
PHP 可以从哪里得到？

可以从任何一个 PHP 网络成员的站点下载 PHP。这些信息在 » https://www.php.net/。还可以通过匿名 SVN 得到绝对是最新版的源程序。更多信息请访问 [broken link]。

有预先编译好的可执行版本吗？

我们只为 Windows 系统提供了预编译的可执行文件，因为我们没法为每个主流的 Linux/Unix 平台编译每一种扩展库组和的 PHP。同样注意，如今很多 Linux 的发行版本已经内置了 PHP。Windows 可执行文件可以从我们的 » 下载页面下载，至于 Linux 可执行文件，请访问你的 Linux 发布商的站点。

编译一些可选的 PHP 扩展库所需的库文件可以从哪里得到？

Note: 有 * 号标记的不是多线程的库，不应该用作多线程 Windows web 服务器（IIS，Netscape）的服务器模块。不过这在 Unix 环境下没有关系。

  • » LDAP (Unix)
  • » LDAP (Unix/Win): Mozilla Directory (LDAP) SDK
  • » 免费 LDAP 服务器
  • » Berkeley DB2 (Unix/Win): http://www.sleepycat.com/.
  • » SNMP* (Unix):
  • » GD* (Unix/Win)
  • » mSQL* (Unix)
  • » PostgreSQL (Unix)
  • » IMAP* (Win/Unix)
  • » Sybase-CT* (Linux, libc5)：内置
  • » FreeType (libttf):
  • » ZLib (Unix/Win32)
  • » expat XML parser (Unix/Win32)
  • » PDFLib
  • » mcrypt
  • » mhash
  • » t1lib
  • » dmalloc
  • » aspell
  • » readline

怎样使这些库起作用？

需要按照这些库提供的说明进行。一些库可以在运行 PHP 的"configure"时自动检测到（例如 GD 库），其它的必需用" --with-EXTENSION"选项来激活。运行" configure --help"来得到完整的列表。

在我的 Windows 机器上通过 Git 仓库获取最新的 PHP 源码后，我应该如何去编译？

参见 PHP Wiki 内的最新说明： » Step by Step Build Instructions

哪里可以找到 browscap.ini 文件？

可以从 » http://browscap.org/得到一个 browscap.ini文件。


数据库问题

本节包括 PHP 和数据库之间关系的常见问题。 事实上， PHP 可以访问如今现有的任何数据库。

  1. 听说 PHP 有可能访问 Microsoft SQL Server，怎样访问？
  2. 能访问 Microsoft Access 数据库吗？
  3. 为什么我已经使用了十多年的 MySQL 扩展（ext/mysql） 不建议继续使用了？ 它被废弃了吗？我应该选择什么替代方案？如何迁移到新的方案？
  4. 为什么我得到类似如下的错误： “Warning: 0 is not a MySQL result index in <file> on line <x>” 或者 “Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>”？
听说 PHP 有可能访问 Microsoft SQL Server，怎样访问？

在 Unix 机器中，你可以使用 PDO_ODBC 或者 Unified ODBC API 来访问 Microsoft SQL Server 数据库。

在 Windows 机器中，你可以使用 PDO_SQLSRV 或 SQLSRV 来访问 Microsoft SQL Server 数据库。

同时，也可以参考下一个问题。

能访问 Microsoft Access 数据库吗？

可以。如果完全在 Windows 9x/Me/NT/2000 下运行，那已经有了所有所需的工具， 可以用 ODBC 和 Microsoft's ODBC drivers for Microsoft Access database。

如果在 Unix 下运行 PHP 而想访问 Windows 中的 MS Access， 那需要 Unix ODBC 驱动程序。 » OpenLink Software 有一个基于 Unix 的 ODBC 驱动程序可以做这件事。

另外一个替代方案是用带 Windows ODBC 驱动的 SQL Server 并用它来储存数据， 可以通过 Microsoft Access（用 ODBC）和 PHP（用内置驱动）来访问， 或者用一个 Access 和 PHP 都识别的中间文件格式， 例如 flat 文件或者 dBase 数据库。 关于这一点 OpenLink Software 的 Tim Hayes 写道：

当可以通过 ODBC 直接从 PHP 访问数据库时——例如用 OpenLink 的驱动程序， 使用其它数据库做中间媒介不是一个好主意。 如果确实需要一个中间文件格式， OpenLink 已经发布了对应于 Windows NT，Linux 和其它 Unix 平台的 Virtuoso（一个虚拟数据库引擎）。 请访问我们的 » 网站来免费下载。

还有一个已被证实有效的选择是在 Windows 下用 MySQL 和它的 MyODBC 驱动来同步数据库。 Steve Lawrence 写道：

  • 根据 MySQL 的说明在你的平台上安装 MySQL。可以从 » http://www.mysql.com/得到最新版。 除了设定数据库和配置用户帐号以外不需要特殊的配置， 应该在 host 字段中放一个 % 或者要用来访问 MySQL 的 Windows 机器名。 记下自己的服务器名， 用户名和密码。
  • 从 MySQL 网站下载 MyODBC for Windows 驱动程序。 在你的 Windows 机器中安装它。 可以用此程序中包括的工具来测试其操作。
  • 用控制面板中的 ODBC 管理器新建一个用户或系统 dsn， 设定 dsn 名称， 输入你在第一步中配置的 MySQL 数据库的主机名，用户名，密码，端口等。
  • 完整安装 Access， 这样可以确保得到适当的插件... 至少需要安装 ODBC 支持和连接表管理器。
  • 新建一个 Access 数据库。 在 Table 窗口点击右键并选择 Link Tables， 或者在 File 菜单下选择 Get External Data -> Link Tables。 当文件浏览窗口打开后，选择文件类型为：ODBC。 接着选择 System dsn 以及在第三步建立的 dsn 的名字。 再选择要连接的表，点击 OK。 现在你可以在你的 MySQL 服务器中打开表并新建／删除／编辑数据了！ 也可以构造查询，导入／导出表到 MySQL，构造表单和报告等。

提示与技巧：

  • 可以在 Access 中构造表并导出到 MySQL 中， 再把它们连接回来。 这样可以使表的建立更快。
  • 在 Access 中建立表时， 必需定义一个基本键名来取得表的写权限。 确认在把表连接到 Access 之前在 MySQL 中建立了基本键名。
  • 如果在 MySQL 中修改了表， 必须重新连接到 Access。 打开 Tools>Add-ins>Linked table manager， 找到你的 ODBC DSN，然后在这里选择要重新连接的表。 也可以在这里移动 dsn 源， 在点击 OK 之前选中 "always prompt for new location"。

为什么我已经使用了十多年的 MySQL 扩展（ext/mysql） 不建议继续使用了？ 它被废弃了吗？我应该选择什么替代方案？如何迁移到新的方案？

在 选择一种 MySQL API 一节中 描述了 3 中 MySQL 扩展。 不应该继续使用旧的 API 了，可能将来的某一天旧 API 就会被废弃甚至从 PHP 中移除。 当然，旧的 API 曾经是非常主流的，很多用户都用了它，所以这个被废弃及移除的过程不会太快。 但是仍然强烈建议使用 mysqli 或 PDO_MySQL 来访问 MySQL 数据库。

自动迁移脚本目前还没有。 mysqli API 包括了面向过程和面向对象的两种风格的调用方式，并且面向过程的版本中提供的 API 和 ext/mysql 是非常相似的。

不可以同时混合使用这几种 MySQL API。 例如，你不可以把一个 mysqli 的连接资源传入到 PDO_MySQL 或者 ext/mysql 中去使用。

为什么我得到类似如下的错误： "Warning: 0 is not a MySQL result index in <file> on line <x>" 或者 "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>"？

你试图用一个值为 0 的结果资源号。 0 表示你的查询由于某原因失败了， 需要在提交查询之后 和在使用返回结果资源号之前检查错误。 正确的方法是用类似如下的代码：

<?php

$result = mysql_query("SELECT * FROM tables_priv");
if (!$result) {
    echo mysql_error();
    exit;
}
?>
或者
<?php

$result = mysql_query("SELECT * FROM tables_priv")
    or die("Bad query: " . mysql_error());
?>


安装常见问题

本章包括了安装 PHP 的常见问题。PHP 可以用于几乎任何操作系统（可能除了 OS X 之前的 MacOS 之外），以及几乎任何 web 服务器。

要安装 PHP，请按照 安装与配置一章中的指示进行。

  1. 为什么不应该在实际运作环境中的 Apache2 中使用线程化的 MPM？
  2. Unix/Windows：应该上哪儿去找我的 php.ini 文件？
  3. Unix：我安装了 PHP，但每次我打开一个页面时，只得到一条“Document Contains No Data”消息！这是怎么回事？
  4. Unix：我从 RPMS 安装了 PHP，但是 Apache 不处理 PHP 页面！这是怎么回事？
  5. Unix：我从 RPMS 安装了 PHP 3，但它没有把我需要的数据库支持编译进去！这是怎么回事？
  6. Unix：我给 Apache 加上了 FrontPage extensions 补丁，结果 PHP 突然不工作了。PHP 和 Apache FrontPage extensions 兼容吗？
  7. Unix/Windows：我已经安装了 PHP，但当我试着通过浏览器访问 PHP 脚本时，得到了一个空白页面。
  8. Unix/Windows：我已经安装了 PHP，但当我试着通过浏览器访问 PHP 脚本时，得到了一个服务器的 500 错误。
  9. 某些操作系统：我已经在不出错的情况下安装了 PHP，但当我试着启动 Apache 时得到了一个未定义符号错误： [mybox:user /src/php4] root# apachectl configtest apachectl: /usr/local/apache/bin/httpd Undefined symbols: _compress _uncompress
  10. Windows：我已经安装了 PHP，但当我试着通过浏览器访问 PHP 脚本时，得到如下错误： cgi error: The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:
  11. Windows：我已经照着所有的说明做了，但还是不能让 PHP 和 IIS 一起工作！
  12. 当在 IIS，PWS，OmniHTTPD 或者 Xitami 中以 CGI 方式运行 PHP 时，出现如下错误： Security Alert! PHP CGI cannot be accessed directly..
  13. 怎样得知我的 php.ini 是否被找到和应用了？似乎我做的修改都没有生效。
  14. 怎样将 PHP 目录加入到 Windows 路径 PATH中去？
  15. 怎样使 php.ini 文件在 Windows 下被 PHP 所用？
  16. 有可能使 PHP 运作于 Apache 的 content negotiation（MultiViews 选项）吗？
  17. PHP 是否仅限于处理 GET 和 POST 请求方法？
为什么不应该在实际运作环境中的 Apache2 中使用线程化的 MPM？

PHP 是粘合剂。它将几十种第三方的库粘合到一起来创建很酷的 web 应用，并通过很直观且易于学习的语言界面使其看上去好像一个整体。PHP 的灵活与强大依赖于底层平台的稳定与耐用。起码需要将一个可运作的操作系统，一个可运作的 web 服务器以及可运作的第三方库粘合起来。其中任何一方不运作了，PHP 都需要有方法来识别出问题并且快速解决。如果没有完全独立的执行线程，完全独立的内存单元和稳定的空间对付每个请求，那底层架构就太复杂以至于不稳定因素更容易进入到 PHP 系统中。

如果必须要用线程化的 MPM，看看 FastCGI 配置，使 PHP 运行于自己独立的内存空间中。

最后需要指出，不使用线程化 MPM 的警告在 Windows 系统中没那么强烈，因为 Windows 中的大多数库都理应在多线程下安全运行。

Unix/Windows：应该上哪儿去找我的 php.ini 文件？

UNIX 中默认在 /usr/local/lib目录中，也就是 <install-path>/lib。很多人会在编译时通过 --with-config-file-path标记来改变路径。例如可以将路径设为：

--with-config-file-path=/etc
然后从发行包中将 php.ini-dist拷贝为 /etc/php.ini并编辑它来作出想要的修改。

--with-config-file-scan-dir=PATH

Windows 中 php.ini 文件的默认路径在 Windows 目录下。如果使用的是 Apache 服务器，则会首先在 Apache 的安装目录中寻找 php.ini，例如 C:\Program Files\Apache Group\Apache。这样同一台机器上不同版本的 Apache 就可以有不同的 php.ini 文件。

参见 配置文件。

Unix：我安装了 PHP，但每次我打开一个页面时，只得到一条"Document Contains No Data"消息！这是怎么回事？

这可能意味着 PHP 发生了某类错误而导致了 core dump。查看服务器的错误日志看看是不是这样，再用一个小的测试例子试着重现此问题。如果你会用"gdb"的话，那么在 bug 报告中提供回溯跟踪很有助于帮开发人员查明问题。如果你用 Apache 的模块方式使用 PHP，试着这么做：

  • 停止 httpd 进程

  • gdb httpd

  • 停止 httpd 进程

  • > run -X -f /path/to/httpd.conf

  • 然后在你的浏览器中访问导致错误的 URL

  • > run -X -f /path/to/httpd.conf

  • 如果你遇到 core dump，gdb 此时就会通知你

  • 输入：bt

  • 你应该在 bug 报告中包括回溯追踪记录。应该提交到 » https://bugs.php.net/

如果你的脚本使用了正则表达式函数（ ereg()等），应该确认在编译 PHP 和 Apache 时使用了同一个正则表达式包。在 PHP 和 Apache 1.3.x 中应该自动就是这样。

Unix：我从 RPMS 安装了 PHP，但是 Apache 不处理 PHP 页面！这是怎么回事？

假定你的 Apache 和 PHP 都是从 RPM 包中安装的，你需要在 httpd.conf 文件中取消以下部分或所有行的注释，或者把它们添加到该文件中：

# Extra Modules
AddModule mod_php.c
AddModule mod_php3.c
AddModule mod_perl.c

# Extra Modules
LoadModule php_module         modules/mod_php.so
LoadModule php3_module        modules/libphp3.so     # for PHP 3
LoadModule php4_module        modules/libphp4.so     # for PHP 4
LoadModule perl_module        modules/libperl.so
并且把：
AddType application/x-httpd-php3 .php3    # for PHP 3
AddType application/x-httpd-php .php      # for PHP 4
添加到全局属性中，或者添加到你希望加入 PHP 支持的虚拟域中。

Unix：我从 RPMS 安装了 PHP 3，但它没有把我需要的数据库支持编译进去！这是怎么回事？

由于 PHP 3 构造的原因，不容易编译出一个完全灵活的 PHP RPM 包来。这个问题在 PHP 4 中解决了。对于 PHP 3 来说，我们目前建议你用 PHP 发行包中 INSTALL.REDHAT 文件中所描述的机制。如果你坚持要用 PHP 3 的 RPM 版本，请接着往下看。

为了简化安装 以及由于 RPMS 使用了 /usr/ 而不是标准的 /usr/local/ 目录来存放文件，制作 RPM 包的人设定 RPMS 不安装任何数据库支持。你需要告诉 RPM 说明文件，你想要支持哪个数据库以及你的数据库服务器最高层路径。

下面的例子解说了如何在用模块安装下的 Apache 中加入流行的 MySQL 数据库服务器支持的过程。

当然这些信息可以调整用于任何 PHP 支持的数据库服务器。本例中我们也假定你从 RPMS 中完整安装了 MySQL 和 Apache。

  • 先去掉 mod_php3：

    rpm -e mod_php3

  • 然后取得源文件的 rpm 包并安装它，而不是编译它。

    rpm -Uvh mod_php3-3.0.5-2.src.rpm

  • 接着编辑 /usr/src/redhat/SPECS/mod_php3.spec文件

    在 %build 一节加入你想要的数据库支持，以及路径。

    对应于 MySQL 你应该加入 --with-mysql=/usr。则 %build 一节看上去将类似这样：

    ./configure --prefix=/usr \ --with-apxs=/usr/sbin/apxs \ --with-config-file-path=/usr/lib \ --enable-debug=no \ --enable-safe-mode \ --with-exec-dir=/usr/bin \ --with-mysql=/usr \ --with-system-regex

  • 一旦完成了这个修改，就这样建立二进制程序的 rpm 包：

    rpm -bb /usr/src/redhat/SPECS/mod_php3.spec

  • 然后安装 rpm

    rpm -ivh /usr/src/redhat/RPMS/i386/mod_php3-3.0.5-2.i386.rpm

确认重新启动了 Apache，这下你就有了用 RPM 安装的并且带 MySQL 支持的 PHP 3 了。注意按照 PHP 3 发行包中 INSTALL.REDHAT文件的说明来编译其实也许更容易一些。

Unix：我给 Apache 加上了 FrontPage extensions 补丁，结果 PHP 突然不工作了。PHP 和 Apache FrontPage extensions 兼容吗？

兼容的。PHP 可以和 FrontPage extensions 一起工作，问题是 FrontPage 补丁修改了几个 PHP 依赖的 Apache 构造。在 FrontPage 补丁安装之后之后重新编译 PHP（用"make clean ; make"）可以解决此问题。

Unix/Windows：我已经安装了 PHP，但当我试着通过浏览器访问 PHP 脚本时，得到了一个空白页面。

用浏览器中的"查看源文件"，你可能会发现能看到 PHP 脚本的源程序。这意味着 web 服务器没有把脚本发送给 PHP 解释。服务器配置在某处有问题，请对照 PHP 安装说明仔细检查服务器配置。

Unix/Windows：我已经安装了 PHP，但当我试着通过浏览器访问 PHP 脚本时，得到了一个服务器的 500 错误。

当服务器尝试运行 PHP 时出了错。要想看到有意义的错误信息，在命令行中转到 PHP 可执行程序（Windows 中是 php.exe）所在目录下并运行 php -i。如果 PHP 运行有任何问题，那么会显示相应的错误信息，这将给你下一步要做什么的线索。如果你得到满屏幕 HTML 代码（ phpinfo()函数的输出）的话说明 PHP 本身工作正常，你的问题可能和你的服务器配置有关，要仔细检查。

某些操作系统：我已经在不出错的情况下安装了 PHP，但当我试着启动 Apache 时得到了一个未定义符号错误：
[mybox:user /src/php4] root# apachectl configtest apachectl: /usr/local/apache/bin/httpd Undefined symbols: _compress _uncompress

这实际上和 PHP 没有关系，而和 MySQL 的客户端库有关。有的需要 --with-zlib，有的不需要。这个问题也包括在 MySQL 的 FAQ 中。

Windows：我已经安装了 PHP，但当我试着通过浏览器访问 PHP 脚本时，得到如下错误：
cgi error: The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

这个错误信息意味着 PHP 根本就不能产生任何输出。要想看到有意义的错误信息，在命令行中转到 PHP 可执行程序（Windows 中是 php.exe）所在目录下并运行 php -i。如果 PHP 运行有任何问题，那么会显示相应的错误信息，这将给你下一步要做什么的线索。如果你得到满屏幕 HTML 代码（ phpinfo()函数的输出）的话说明 PHP 本身工作正常。

一旦 PHP 在命令行中工作正常，试着通过浏览器再次访问脚本。如果还失败的话那可能是如下原因之一：

  • 文件权限问题，你的 PHP 脚本， php.exe， php4ts.dll，php.ini 或任何你要加载的 PHP 扩展库是匿名 internet 用户 ISUR_<machinename>无权访问的。
  • 脚本文件不存在（或者有可能不在你以为的地方，注意 web 文档的目录）。注意在 IIS 中通过 Internet 服务管理器设定脚本映射时选中"检查文件是否存在"可以捕捉到此错误。这样一来如果脚本文件不存在的话服务器就会返回一个 404 错误信息。还有一个额外的好处就是 IIS 会基于 NTLanMan 权限来替你对脚本文件做任何所需要的认证。
Windows：我已经照着所有的说明做了，但还是不能让 PHP 和 IIS 一起工作！

确认需要运行 PHP 脚本的任何用户有权限运行 php.exe！IIS 使用了一个在安装 IIS 时添加的匿名用户，这个用户需要有访问 php.exe的权限。同样任何认证用户也需要执行 php.exe的权限。在 IIS4 中你还需要告诉它 PHP 是一个脚本引擎。此外，你可能还需要阅读 此常见问题。

当在 IIS，PWS，OmniHTTPD 或者 Xitami 中以 CGI 方式运行 PHP 时，出现如下错误： Security Alert! PHP CGI cannot be accessed directly..

必须将 cgi.force_redirect选项设为 0。 默认值为 1，因此要确认此选项没有被注释掉（用 ;）。和其它选项一样，是在 php.ini 中设定的。

因为默认值是 1，因此你必须百分之百确认使用了正确的 php.ini 文件。详细信息请阅读 此常见问题。

怎样得知我的 php.ini 是否被找到和应用了？似乎我做的修改都没有生效。

要确认你的 php.ini 被 PHP 使用了，调用 phpinfo()，在接近开头的位置有一项叫做 Configuration File (php.ini)。这里将告诉你 PHP 在哪里找到了 php.ini 并且是否使用了。如果只显示一个目录则 没有使用任何 php.ini 文件，你应将你的 php.ini 文件放到该目录中。如果 php.ini 包括在该路径中则它已被应用了。

如果 php.ini 被使用了并且你是以模块方式运行 PHP 的，确保在修改了 php.ini 之后重新启动你的 web server。

怎样将 PHP 目录加入到 Windows 路径 PATH中去？

在 Windows NT，2000，XP 和 2003 下：

  • 进入控制面板并打开"系统"图标（开始 -> 设置 -> 控制面板 -> 系统，Windows XP/2003 中是：开始 -> 控制面板 -> 系统）

  • 选择"高级"标签页

  • 点击"环境变量"按钮

  • 在"系统变量"栏中

  • 找到 Path 这一项（可能需要向下滚动才能找到）

  • 鼠标双击 Path 这一项

  • 在最后加入你的 PHP 目录，包括前面的";"（例如： ;C:\php）

  • 点击"确定"并重新启动电脑

在 Windows 98/Me 中需要编辑 autoexec.bat文件：

  • 打开记事本（开始 -> 运行，然后输入 notepad 并点确定）

  • 打开 C:\autoexec.bat文件

  • 找到这么一行：PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;..... 并在最后加上 ;C:\php

  • 保存文件并重新启动电脑

Note: 记住在上述修改之后重新启动，以确保对 PATH的改变生效。

PHP 手册过去提倡把文件拷贝到 Windows 系统目录中去，这是因为该目录（ C:\Windows， C:\WINNT，等等）默认就在系统路径中。但是把文件拷贝到 Windows 系统目录中这一方式早已不被提倡，还可能造成问题。

怎样使 php.ini 文件在 Windows 下被 PHP 所用？

有几种方法。如果使用 Apache，阅读专门的安装指示（ Apache 1， Apache 2），否则就必须设定 PHPRC环境变量：

在 Windows NT，2000，XP 和 2003 种：

  • 进入控制面板并打开"系统"图标（开始 -> 设置 -> 控制面板 -> 系统，Windows XP/2003 中是：开始 -> 控制面板 -> 系统）

  • 选择"高级"标签页

  • 点击"环境变量"按钮

  • 在"系统变量"栏中

  • 点击"新建"按钮并在"变量名"中输入"PHPRC"，在"变量值"中输入 php.ini 文件所在的目录（例如： C:\php）

  • 点击"确定"并重新启动电脑

在 Windows 98/Me 中需要编辑 autoexec.bat文件：

  • 打开记事本（开始 -> 运行，然后输入 notepad 并点确定）

  • 打开 C:\autoexec.bat文件

  • 在文件结尾处加入一行： set PHPRC=C:\php（将 C:\php替换为你的 php.ini 实际存在的目录）。注意路径中不能包含空格。例如将 PHP 安装到了 C:\Program Files\PHP中，你需要输入 C:\PROGRA~1\PHP替代之

  • 保存文件并重新启动电脑

有可能使 PHP 运作于 Apache 的 content negotiation（MultiViews 选项）吗？

如果到 PHP 文件的连接包含扩展名，一切都运行完美。本解答只针对到 PHP 文件的连接不包含扩展名时，而希望通过 content negotiation 来从不包含扩展名的 URL 来选择 PHP 文件的情况。在此种情况下，将 AddType application/x-httpd-php .php替换为：

# PHP 4
AddHandler php-script php
AddType text/html php

# PHP 5
AddHandler php5-script php
AddType text/html php
此方案对于 Apache 1 不适用，因为 PHP 模块不捕获 php-script。

PHP 是否仅限于处理 GET 和 POST 请求方法？

不是，PHP 有可能处理任何请求方法，例如 CONNECT。适当的回应状态可以用 header()发送。如果仅需要处理 GET 和 POST 方法，可以通过如下的 Apache 配置实现：

<LimitExcept GET POST>
Deny from all
</LimitExcept>


编译问题

本节汇集了大多数编译时出现的常见错误。

  1. 我用匿名 GIT 服务得到了最新版的 PHP，但是里面没有 configure 脚本！
  2. 我在配置 PHP 和 Apache 一起工作时遇到了问题。说没找到 httpd.h，但这个文件明明就在那里！
  3. 当运行 PHP 配置时（ ./configure），遇到类似如下的问题： checking lex output file root... ./configure: lex: command not found configure: error: cannot find output from lex; giving up
  4. 当试图启动 Apache 时，得到类似如下错误信息： fatal: relocation error: file /path/to/libphp4.so: symbol ap_block_alarms: referenced symbol not found
  5. 当运行 configure 时，报告说找不到头文件或 GD 库或 gdbm，或其它的什么包！
  6. 当编译 language-parser.tab.c文件时，报错说 yytname undeclared。
  7. 当我运行 make时，看上去一切正常，可当连接最后的程序时报告说找不到某些文件而失败了。
  8. 当连接 PHP 时，报告说有一些未定义的引用。
  9. 我不知道怎样把 PHP 和 Apache 1.3 一起编译。
  10. 我按照所有的步骤在 UNIX 下安装了PHP 的 Apache 模块版本，但我的 PHP 脚本被显示在浏览器中或者提示保存此文件。
  11. 说要用： --activate-module=src/modules/php4/libphp4.a，但是此文件根本不存在，于是我改成了 --activate-module=src/modules/php4/libmodphp4.a，结果不行。怎么回事？
  12. 当我用 --activate-module=src/modules/php4/libphp4.a试着把 PHP 编译成 Apache 的静态模块时，报告说我的编译器不服从 ANSI 标准。
  13. 当我用 --with-apxs编译 PHP 时得到奇怪的错误信息。
  14. 在 make的过程中，在 microtime 中出错，还有很多 RUSAGE_之类的东西。
  15. 当带 MySQL 编译 PHP 时，可以正确地运行configure，但是在 make的过程中出现了类似以下的错误信息： ext/mysql/ libmysqlclient /my_tempnam.o(.text+0x46): In function my_tempnam': /php4/ext/mysql/ libmysqlclient /my_tempnam.c:103: the use of tempnam' is dangerous, better use mkstemp'，这是怎么回事
  16. 我想升级我的 PHP。上哪里找到我用来配置目前的 PHP 的 ./configure的参数呢？
  17. 和 GD 库一起编译 PHP 时，要么给出一个奇怪的编译错误，要么在运行时出现 segfaults。
  18. 当编译 PHP 时我看到一些随机的错误，好像死了。我用的是 Solaris，不知道有没有关系。
我用匿名 GIT 服务得到了最新版的 PHP，但是里面没有 configure 脚本！

你必须安装有 GNU autoconf 包，这样才可以从 configure.in生成 configure 脚本。从 GIT 服务中得到源程序后只要在最高层的目录中运行 ./buildconf即可。（同时要注意，除非你用了 --enable-maintainer-mode选项来运行 configure，否则即使 configure.in文件更新了，configure 脚本也不会自动重新生成。所以当你发现 configure.in文件更新了时要确保手工重新生成 configure 脚本。有一个症状是在 configure 之后或者运行 config.status时在 Makefile 中寻找类似 @VARIABLE@ 的东西。）

我在配置 PHP 和 Apache 一起工作时遇到了问题。说没找到 httpd.h，但这个文件明明就在那里！

你需要告诉 configure/setup 脚本你的 Apache 源程序最上层的目录位置。这意味着你需要这样指定 --with-apache=/path/to/apache而 不是这样 --with-apache=/path/to/apache/src。

当运行 PHP 配置时（ ./configure），遇到类似如下的问题：
checking lex output file root... ./configure: lex: command not found configure: error: cannot find output from lex; giving up

请认真阅读 PHP 的 安装说明，并注意要编译 PHP 需要同时安装 flex 和 bison。根据设置的不同，可以从源代码编译 bison 和 flex，要么通过已编译好的发行包，例如 RPM。

当试图启动 Apache 时，得到类似如下错误信息：
fatal: relocation error: file /path/to/libphp4.so: symbol ap_block_alarms: referenced symbol not found

该错误通常在 Apache 的核心程序被编译为共享用途的 DSO 库时发生。请尝试重新配置 Apache，确保至少使用了如下参数：

--enable-shared=max --enable-rule=SHARED_CORE

更多信息，请阅读 Apache 顶层目录的 INSTALL文件或者 Apache 的 » DSO 手册。

当运行 configure 时，报告说找不到头文件或 GD 库或 gdbm，或其它的什么包！

可以通过指定附加的选项让 configure 脚本在非标准的路径中寻找头文件和库并传递给 C 预处理器和连接器，例如：

    CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure
如果用 csh 的变种作为你的登录 shell（为什么？），那就是：
    env CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure

当编译 language-parser.tab.c文件时，报错说 yytname undeclared。

需要更新 Bison 的版本。最新版本在 » http://www.gnu.org/software/bison/bison.html。

当我运行 make时，看上去一切正常，可当连接最后的程序时报告说找不到某些文件而失败了。

一些旧版本的 make 没有正确将 functions 目录下编译后的文件放到同一个目录下。试试运行 cp *.o functions然后再运行 make看看有没有什么帮助。如果成功了，那你确实需要更新到最新版的 GNU make。

当连接 PHP 时，报告说有一些未定义的引用。

看看连接的这一行命令，确认所有适当的库都包括在最后了。通常可能漏掉了"-ldl"和你包括的任何数据库支持所需要的库。

一些人也报告说在和 Apache 连接时他们不得不紧接着 libphp4.a之后加上"-ldl"。

我不知道怎样把 PHP 和 Apache 1.3 一起编译。

这其实很简单。小心地照着以下步骤来：

  • 从 » http://httpd.apache.org/download.cgi下载最新版的 Apache 1.3。
  • 解压缩到某处，例如 /usr/local/src/apache-1.3。
  • 编译 PHP，先运行 ./configure --with-apache=/<path>/apache-1.3（用你 apache-1.3 所在的真实路径替换掉 <path>。）
  • 输入 make接着是 make install来编译 PHP 并把必要的文件拷贝到 Apache 的源程序目录树中。
  • 改变当前目录到 /<path>/apache-1.3/src目录并编辑 Configuration文件。添加这一行： AddModule modules/php4/libphp4.a。
  • 输入 ./configure接着是 make。
  • 你现在应该有一个包括 PHP 支持的 httpd 可执行程序了！

注意：也可以用新的 Apache ./configure脚本。参见 Apache 发行包中 README.configure文件中的说明。也看看 PHP 发行包中的 INSTALL文件。

我按照所有的步骤在 UNIX 下安装了PHP 的 Apache 模块版本，但我的 PHP 脚本被显示在浏览器中或者提示保存此文件。

这说明 PHP 模块出于某些原因没有被调用。在寻求更多帮助前先检查三件事：

  • 确认你运行的 httpd 程序就是你刚刚编译的新 httpd 程序。运行： /path/to/binary/httpd -l 如果你没看到 mod_php4.c被列出来那你就没有运行对程序。找到并正确安装程序。
  • 确认你在 Apache .conf文件中加入了正确的 Mime 类型。应该是： AddType application/x-httpd-php .php 也确认 AddType 这一行没有隐藏在 <Virtualhost> 或者 <Directory> 块中，这可能会造成你的测试脚本所在位置没有被应用到此设置。
  • 最后，Apache 1.2 和 Apache 1.3 之间默认配置文件的位置改变了。你要确认你添加 AddType 行的文件就是实际上用的。你可以在你的 httpd.conf 中添加一个明显的语法错误或者其它明显修改，这可以告诉你是否读取了正确的文件。

说要用： --activate-module=src/modules/php4/libphp4.a，但是此文件根本不存在，于是我改成了 --activate-module=src/modules/php4/libmodphp4.a，结果不行。怎么回事？

注意 libphp4.a文件本来就不该存在，apache 进程将创建它！

当我用 --activate-module=src/modules/php4/libphp4.a试着把 PHP 编译成 Apache 的静态模块时，报告说我的编译器不服从 ANSI 标准。

这是一个 Apache 误报的错误信息，在新的版本中已经修正了。

当我用 --with-apxs编译 PHP 时得到奇怪的错误信息。

这里要检查三件事。首先，出于某些原因当 Apache 生成 apxs Perl 脚本时，有时没有正确的编译和标记变量就结束了。找到你的 apxs 脚本（用命令 which apxs），有时会在 /usr/local/apache/bin/apxs或者 /usr/sbin/apxs。打开并检查类似如下的行：

my $CFG_CFLAGS_SHLIB  = ' ';          # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = ' ';          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = ' ';          # substituted via Makefile.tmpl
如果你看到这几行，那问题就在这里。它们可能包含了仅仅空格或者其它不正确的值，例如"q()"。改成这样：
my $CFG_CFLAGS_SHLIB  = '-fpic -DSHARED_MODULE'; # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = 'gcc';                   # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(-shared);              # substituted via Makefile.tmpl
第二个可能的问题仅可能在在 Red Hat 6.1 和 6.2 中发生。Red Hat 发行的 apxs 脚本坏了。查找这一行：
my $CFG_LIBEXECDIR    = 'modules';         # substituted via APACI install
如果你看到上面这一行，改成这样：
my $CFG_LIBEXECDIR    = '/usr/lib/apache'; # substituted via APACI install
最后，如果你重新配置或者重装了 Apache，在 ./configure之后和 make之前增加一个 make clean命令。

在 make的过程中，在 microtime 中出错，还有很多 RUSAGE_之类的东西。

如果 make时遇到类似这样的问题：

microtime.c: In function `php_if_getrusage':
microtime.c:94: storage size of `usg' isn't known
microtime.c:97: `RUSAGE_SELF' undeclared (first use in this function)
microtime.c:97: (Each undeclared identifier is reported only once
microtime.c:97: for each function it appears in.)
microtime.c:103: `RUSAGE_CHILDREN' undeclared (first use in this function)
make[3]: *** [microtime.lo] Error 1
make[3]: Leaving directory `/home/master/php-4.0.1/ext/standard'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/master/php-4.0.1/ext/standard'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/master/php-4.0.1/ext'
make: *** [all-recursive] Error 1

你的系统坏了。你需要安装一个符合你的 glibc 的 glibc-devel 包来修复 /usr/include中的文件。这和 PHP 绝对没有任何关系。要证实这一点，试试这个简单的测试：

$ cat >test.c <<X
#include <sys/resource.h>
X
$ gcc -E test.c >/dev/null
如果出现错误，那你就知道头文件坏了。

当带 MySQL 编译 PHP 时，可以正确地运行configure，但是在 make的过程中出现了类似以下的错误信息： ext/mysql/ libmysqlclient /my_tempnam.o(.text+0x46): In function my_tempnam': /php4/ext/mysql/ libmysqlclient /my_tempnam.c:103: the use of tempnam' is dangerous, better use mkstemp'，这是怎么回事

首先，我们需要认识到这只是个 警告，而非致命错误。由于这条信息通常是在 make的最后输出的，所以看起来它可能像是一个致命错误，但实际上不是。当然，如果将编译器设置成遇见警告信息时停止，则这也可以算是致命错误。另外值得一提的是，MySQL 的支持是默认打开的。

Note:

自 PHP 4.3.2 起，你将在编译（make）结束后看到下面的文字：

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

我想升级我的 PHP。上哪里找到我用来配置目前的 PHP 的 ./configure的参数呢？

要么在你用来编译当前的 PHP 的源码树中查看 config.nice 文件，如果没有，只要运行此脚本：

<?php phpinfo(); ?>
在输出的顶端显示了用来配置此 PHP 的 ./configure参数。

和 GD 库一起编译 PHP 时，要么给出一个奇怪的编译错误，要么在运行时出现 segfaults。

确保你的 GD 库和 PHP 在连接时使用了用同样的支持库（例如 libpng）。

当编译 PHP 时我看到一些随机的错误，好像死了。我用的是 Solaris，不知道有没有关系。

当编译 PHP 时使用非 GNU 的工具会导致问题。确保使用 GNU 工具来确保能够正确编译 PHP。例如，在 Solaris 下面不论使用 SunOS BSD 兼容或者 Solaris 版本的 sed都不行，但是使用 GNU 或者 Sun POSIX (xpg4) 版本的 sed就可以。相关连接： » GNU sed， » GNU flex， » GNU bison。


使用 PHP

本节汇集了你在写 PHP 脚本时可能碰到的大多数普通错误。

  1. 我忘了 PHP 函数的参数顺序，它们是随机的吗？
  2. 我想写一个可以处理任何表单来的数据的通用 PHP 脚本。我怎么知道哪个 POST 方法变量可用呢？
  3. 我需要在所有的单引号（'）前加一个反斜线（\），使它们变成（\'）。我如何能够通过正则表达式来实现？ 我同样希望能够将 " 转换成 \"，将 \ 转换成 \\。
  4.           当我这样做时，输出显示的次序是错的：

<?php
function myfunc($argument)
{
    echo $argument + 10;
}
$variable = 10;
echo "myfunc($variable) = " . myfunc($variable);
?>

          这是怎么回事？
  5. 下面代码怎么没有分成两行显示？ <pre> <?php echo "This should be the first line."; ?> <?php echo "This should show up after the new line above."; ?> </pre>
  6. 我得到消息 “Warning: Cannot send session cookie - headers already sent...” 或者 “Cannot add header information - headers already sent...”。
  7. 我需要直接访问请求报头中的信息，怎么能办到？
  8. 当我用 IIS 进行 HTTP 认证时得到 “No Input file specified” 消息。
  9. Windows：不能访问另一台电脑上用 IIS 共享的文件。
  10. 我怎样混合使用 XML 和 PHP？它不认我的 <?xml 标记！
  11. 哪里可以找到所有可用的 PHP 预定义变量的完整列表？
  12. 怎样才能不用非免费的商业库（例如 PDFLib） 来生成 PDF 文档？我想要个免费的并且不需要再连接别的 PDF 库。
  13. 我试着在用户自定义函数中访问一个标准的 CGI 变量（例如 $DOCUMENT_ROOT 或 $HTTP_REFERER），但是找不到，哪里出了错？
  14. 有些 PHP 选项可以接受缩写的字节值，与仅能接受 int 字节值相反。都有哪些缩写字节值？
  15. 在 Windows 下，使用 localhost 访问的时候提示连接超时，但是使用 "127.0.0.1" 的时候正常，为什么？
我忘了 PHP 函数的参数顺序，它们是随机的吗？

PHP 是一个将数百个外部库连接在一起的粘合剂，尽管有时候会有一些混乱。这里有一些简单的经验法则：

数组函数 参数的顺序为 "needle, haystack"， 字符串函数 则相反，顺序为 "haystack, needle"。

我想写一个可以处理任何表单来的数据的通用 PHP 脚本。我怎么知道哪个 POST 方法变量可用呢？

PHP 提供很多" 预定义变量"，例如超全局变量 $_POST。可以遍历 $_POST变量，因为它是一个和所有通过 POST 方法传递数据相联系的数组。例如，可以用 foreach简单地遍历它，检查 empty()值，以及将它们输出。

<?php
$empty = $post = array();
foreach ($_POST as $varname => $varvalue) {
    if (empty($varvalue)) {
        $empty[$varname] = $varvalue;
    } else {
        $post[$varname] = $varvalue;
    }
}

print "<pre>";
if (empty($empty)) {
    print "None of the POSTed values are empty, posted:\n";
    var_dump($post);
} else {
    print "We have " . count($empty) . " empty values\n";
    print "Posted:\n"; var_dump($post);
    print "Empty:\n";  var_dump($empty);
    exit;
}
?>

我需要在所有的单引号（'）前加一个反斜线（\），使它们变成（\'）。我如何能够通过正则表达式来实现？ 我同样希望能够将 " 转换成 \"，将 \ 转换成 \\。

假设是针对数据库，请使用数据库自带的转义机制。比如，针对 MySQL 使用
mysql_real_escape_string() 函数，针对 PostgreSQL 则使用
pg_escape_string() 函数。还有两个标准函数
addslashes() 和
stripslashes() 可以在旧的 PHP 版本中实现类似的操作。

当我这样做时，输出显示的次序是错的：
<?php
function myfunc($argument)
{
    echo $argument + 10;
}
$variable = 10;
echo "myfunc($variable) = " . myfunc($variable);
?>
这是怎么回事？

要在一个表达式中（例如在上面的例子中和其它字符串连接）使用函数的结果，需要 return 这个值，而不是 echo 它。

下面代码怎么没有分成两行显示？
<pre>
<?php echo "This should be the first line."; ?>
<?php echo "This should show up after the new line above."; ?>
</pre>

在 PHP 中，一段代码的结束标记要么是"?>"要么是"?>\n"（\n 表示换行）。因此在上面的例子中，输出的句子将显示在同一行中，因为 PHP 忽略了代码结束标记后面的换行。这意味着如果要输出一个换行符，需要在每段 PHP 代码的结束标记后面多加一个换行。

PHP 为什么这么做呢？因为在格式化正常的 HTML 时，这样通常会更容易。假如输出了换行而你不需要这个换行时，就不得不用一个非常长的行来达到这样的效果，或者让产生的 HTML 页面的源文件的格式很难读。

我得到消息 "Warning: Cannot send session cookie - headers already sent..." 或者 "Cannot add header information - headers already sent..."。

函数 header()， setcookie() 和 session 函数需要在输出流中添加头信息。但是头信息只能在其它任何输出内容之前发送。在使用这些函数前不能有任何（如 HTML）的输出。函数 headers_sent() 能够检查脚本是否已经发送了头信息。请参阅 输出控制函数。

我需要直接访问请求报头中的信息，怎么能办到？

如果以 Apache 的模块方式运行 PHP，那么函数 getallheaders() 可以做这件事。因此下面的代码可以显示所有的请求报头：

<?php
$headers = getallheaders();
foreach ($headers as $name => $content) {
    echo "headers[$name] = $content<br />\n";
}
?>

请参阅函数
apache_lookup_uri()、
apache_response_headers() 和
fsockopen()。

当我用 IIS 进行 HTTP 认证时得到 "No Input file specified" 消息。

IIS 的安全模型这里有毛病。这是所有 IIS 下运行的 CGI 程序所共有的问题。一个解决办法是建立一个纯 HTML 文件（不经过 PHP 解析）作为要进入认证目录的登录页面，然后用 META 标记来重定向到 PHP 页面，或者用一个连接到 PHP 页面。然后 PHP 就可以正确识别认证信息了。如果是用 ISAPI 模块，那没有这个问题。其它 NT 下的 web 服务器不受此影响。更多信息见 » http://support.microsoft.com/kb/q160422/ 及 HTTP 认证 一章。

Windows：不能访问另一台电脑上用 IIS 共享的文件。

必须要做些修改。打开 Internet 信息服务，找到你的 PHP 文件并打开属性页，选择 文件安全性标签，点击 匿名访问和身份验证控制的"编辑"按钮。

解决此问题有两个方法，一是不要选中 匿名访问并且选中 集成 Windows 身份验证，二是选中 匿名访问并编辑匿名访问使用的帐户，改成一个有权限的。

我怎样混合使用 XML 和 PHP？它不认我的 <?xml 标记！

要能够在 PHP 代码中直接嵌入 <?xml，需要将 PHP 设置项 short_open_tags设置为 0以关闭短标记格式。无法通过函数 ini_set()来更改这项设置。不管 short_open_tags是开或者关，都可以用类似于 <?php echo '<?xml'; ?>的方法达到目的。该项设置的默认值为开。

哪里可以找到所有可用的 PHP 预定义变量的完整列表？

请阅读手册中的 预定义变量 一章，该部分的文档已经包含了一部分可以用于你的脚本的预定义变量的列表。可用变量的完整列表（及更多信息）可以通过调用 phpinfo() 函数来查阅。请务必阅读手册中 来自 PHP 之外的变量 一节，这部分文档阐述了外部变量的概念，例如来自 HTML 表单、Cookie 和 URL 的变量。

Note: register_globals 重要说明：

自 PHP 4.2.0 起，PHP 指令 register_globals 的默认值为 off。PHP 社区鼓励开发者不要依赖于此指令, 用其他手段替代，例如superglobals。

怎样才能不用非免费的商业库（例如 PDFLib） 来生成 PDF 文档？我想要个免费的并且不需要再连接别的 PDF 库。

有几个选择，例如 » FPDF 和 » TCPDF 模块。

我试着在用户自定义函数中访问一个标准的 CGI 变量（例如 $DOCUMENT_ROOT 或 $HTTP_REFERER），但是找不到，哪里出了错？

使用 $_SERVER['DOCUMENT_ROOT'] 和 $_SERVER['HTTP_REFERER'] 替代。

有些 PHP 选项可以接受缩写的字节值，与仅能接受 int 字节值相反。都有哪些缩写字节值？

可用的选择有 K（对应 Kilobytes），M（对应 Megabytes）和 G（对应 Gigabytes；自 PHP 5.1.0 起可用），区分大小写。其余的都认为是字节。 1M等于一个 Megabyte，即 1048576 字节。 1K 等于一个 Kilobyte，即 1024 字节。不能在 php.ini 之外使用这些符号，最好用整数的 int 字节值。参见 ini_get() 文档中的转换示例。要注意，数字类型为 int 会自动取整，这意味着 0.5M 与 0 是等价的。

Note: kilobyte 和 kibibyte 的区别

PHP 将一个千字节（kilobyte）描述为等于 1024 字节（bytes），而 IEC 标准则认为这是一个 kibibyte。结论：k 和 K = 1024 bytes.

在 Windows 下，使用 localhost 访问的时候提示连接超时，但是使用 "127.0.0.1" 的时候正常，为什么？

在 PHP 5.3.4 之前，如果启用了 IPv6，PHP 内部的网络解析代码有一个 bug，会导致处理 localhost 相关的地址时失败。可以通过使用 "127.0.0.1" 或在 hosts 文件中禁止 IPv6 来解决这个问题。


密码散列安全

本部分解释使用散列函数对密码进行安全处理背后的原因， 以及如何有效的进行密码散列处理。

  1. 为什么需要把应用程序中用户的密码进行散列化？
  2. 为何诸如 md5 和 sha1 这样的常见散列函数不适合用在密码保护场景？
  3. 如果不建议使用常用散列函数保护密码， 那么我应该如何对密码进行散列处理？
  4. “盐”是什么？
  5. 我应该如何保存“盐”？
为什么需要把应用程序中用户的密码进行散列化？

当设计一个需要接受用户密码的应用时， 对密码进行散列是最基本的，也是必需的安全考虑。 如果不对密码进行散列处理，那么一旦应用的数据库受到攻击， 那么用户的密码将被窃取。 同时，窃取者也可以使用用户账号和密码去尝试其他的应用， 如果用户没有为每个应用单独设置密码，那么将面临风险。

通过对密码进行散列处理，然后再保存到数据库中， 这样就使得攻击者无法直接获取原始密码， 同时还可以保证你的应用可以对原始密码进行相同的散列处理， 然后比对散列结果。

需要着重提醒的是，密码散列只能保护密码 不会被从数据库中直接窃取， 但是无法保证注入到应用中的 恶意代码拦截到原始密码。

为何诸如 md5() 和 sha1() 这样的常见散列函数不适合用在密码保护场景？

MD5，SHA1 以及 SHA256 这样的散列算法是面向快速、高效 进行散列处理而设计的。随着技术进步和计算机硬件的提升， 破解者可以使用"暴力"方式来寻找散列码 所对应的原始数据。

因为现代化计算机可以快速的"反转"上述散列算法的散列值， 所以很多安全专家都强烈建议 不要在密码散列中使用这些散列算法。

如果不建议使用常用散列函数保护密码， 那么我应该如何对密码进行散列处理？

当进行密码散列处理的时候，有两个必须考虑的因素： 计算量以及"盐"。 散列算法的计算量越大， 暴力破解所需的时间就越长。

PHP 5.5 提供了 一个原生密码散列 API， 它提供一种安全的方式来完成密码 散列和 验证。 PHP 5.3.7 及后续版本中都提供了一个 » 纯 PHP 的兼容库。

PHP 5.3 及后续版本中，还可以使用 crypt() 函数， 它支持多种散列算法。 针对每种受支持的散列算法，PHP 都提供了对应的原生实现， 所以在使用此函数的时候， 你需要保证所选的散列算法是你的系统所能够支持的。

当对密码进行散列处理的时候，建议采用 Blowfish 算法， 这是密码散列 API 的默认算法。 相比 MD5 或者 SHA1，这个算法提供了更高的计算量， 同时还有具有良好的伸缩性。

如果使用 crypt() 函数来进行密码验证， 那么你需要选择一种耗时恒定的字符串比较算法来避免时序攻击。 （译注：就是说，字符串比较所消耗的时间恒定， 不随输入数据的多少变化而变化） PHP 中的 == 和 === 操作符 和 strcmp() 函数都不是耗时恒定的字符串比较， 但是 password_verify() 可以帮你完成这项工作。 我们鼓励你尽可能的使用 原生密码散列 API。

"盐"是什么？

加解密领域中的"盐"是指在进行散列处理的过程中 加入的一些数据，用来避免从已计算的散列值表 （被称作"彩虹表"）中 对比输出数据从而获取明文密码的风险。

简单而言，"盐"就是为了提高散列值被破解的难度 而加入的少量数据。 现在有很多在线服务都能够提供 计算后的散列值以及其对应的原始输入的清单， 并且数据量极其庞大。 通过加"盐"就可以避免直接从清单中查找到对应明文的风险。

如果不提供"盐"，password_hash() 函数会随机生成"盐"。 非常简单，行之有效。

我应该如何保存"盐"？

当使用 password_hash() 或者 crypt() 函数时， "盐"会被作为生成的散列值的一部分返回。 你可以直接把完整的返回值存储到数据库中， 因为这个返回值中已经包含了足够的信息， 可以直接用在 password_verify() 或 crypt() 函数来进行密码验证。

下图展示了 crypt() 或 password_hash() 函数返回值的结构。 如你所见，算法的信息以及"盐"都已经包含在返回值中， 在后续的密码验证中将会用到这些信息。

password_hash 和 crypt 函数返回值的组成部分，依次为：所选择的算法， 算法选项，所使用的


PHP 和 HTML

PHP 和 HTML 有很多相互作用：PHP 能生成 HTML，HTML 可以向 PHP 传递信息。在阅读这些常见问题之前，先学会怎样 从 PHP 之外取得变量很重要。此主题的手册页也包括很多例子。还要仔细留意 register_globals对你意味着什么。

  1. 当我通过表单／URL 传值时需要用什么编码／解码方法？
  2. 我在试用 <input type="image"> 标记，但是没有 $foo.x和 $foo.y变量，它们哪去了？
  3. 怎样在 HTML 的 <form> 中建立数组？
  4. 怎样从可多选的 HTML 的 select multiple 标记中得到所有结果？
  5. 怎样从 Javascript 传递一个变量到 PHP？
当我通过表单／URL 传值时需要用什么编码／解码方法？

在几个环节上编码方式很重要。假定有 string $data，其中包含了想通过非编码方式传递的字符串，那这是相关步骤：

  • HTML 解析。要指定一个任意的字符串， 必须将其放在双引号中，并用 htmlspecialchars()处理整个值。

  • URL：URL 由几部分组成。如果希望自己的数据被当作其中一项来解释， 必须用 urlencode()对其编码。

Example #1 隐藏的 HTML 表单单元

<?php
    echo "<input type='hidden' value='" . htmlspecialchars($data) . "' />\n";
?>

Note: 用 urlencode()来处理 $data是错误的，因为是浏览器的责任来 urlencode()数据。所有流行的浏览器都能正确处理。注意不论何种方法（例如 GET 或 POST）都会这样。不过只会在用 GET 请求时注意到这一点，因为 POST 请求通常是隐藏的。

Example #2 等待用户编辑的数据

<?php
    echo "<textarea name='mydata'>\n";
    echo htmlspecialchars($data)."\n";
    echo "</textarea>";
?>

Note: 数据会按照预期的显示在浏览器中，因为浏览器会解释 HTML 转义符号。 当提交时，不论是 GET 或者 POST 方法，数据都会被浏览器进行 urlencode 来传输，并直接被 PHP urldecode。所以最终不需要自己处理任何 urlencoding/urldecoding，全都是自动处理的。

Example #3 URL 中的例子

<?php
    echo "<a href='" . htmlspecialchars("/nextpage.php?stage=23&data=" .
        urlencode($data)) . "'>\n";
?>

Note: 事实上这在编造一个 HTML 的 GET 请求，因此需要手工对数据进行 urlencode()。

Note: 需要对整个 URL 进行 htmlspecialchars()，因为 URL 是作为 HTML 属性的一个值出现的。在本例中，浏览器会首先对值进行 un- htmlspecialchars()，然后再传递此 URL。PHP 将能正确理解 URL，因为对数据进行了 urlencoded()。 要注意到 URL 中的 &被替换成了 &amp;。如果忘了这一步，尽管大多数浏览器都能恢复，但也不总是这样。因此即使 URL 不是动态的，也 需要对 URL 进行 htmlspecialchars()。

我在试用 <input type="image"> 标记，但是没有 $foo.x和 $foo.y变量，它们哪去了？

当提交表单时，可以用图片代替标准的提交按钮，用类似这样的标记：

<input type="image" src="image.gif" name="foo" />
当用户点击了图片的任何部分，该表单会被发送到服务器并加上两个额外的变量： foo.x和 foo.y。

因为 foo.x和 foo.y在 PHP 中会成为非法的变量名，它们被自动转换成了 foo_x和 foo_y。也就是用下划线代替了点。因此，可以按照在 来自 PHP 之外的变量这一节中说明的那样访问这些变量。例如， $_GET['foo_x']。

Note:

请求变量名中的空格被转换为下划线。

怎样在 HTML 的 <form> 中建立数组？

要使你的 <form> 结果被当成 array发送到 PHP 脚本，要对 <input>，<select> 或者 <textarea> 单元这样命名：

<input name="MyArray[]" />
<input name="MyArray[]" />
<input name="MyArray[]" />
<input name="MyArray[]" />
注意变量名后的方括号，这使其成为一个数组。可以通过给不同的单元分配相同的名字来把单元分组到不同的数组里：
<input name="MyArray[]" />
<input name="MyArray[]" />
<input name="MyOtherArray[]" />
<input name="MyOtherArray[]" />
这将产生两个数组，MyArray 和 MyOtherArray，并发送给 PHP 脚本。还可以给数组分配指定的键名：
<input name="AnotherArray[]" />
<input name="AnotherArray[]" />
<input name="AnotherArray[email]" />
<input name="AnotherArray[phone]" />
AnotherArray 数组将包含键名 0，1，email 和 phone。

Note:

指定数组的键名是 HTML 的可选项。如果不指定键名，则数组被按照单元在表单中出现的顺序填充。第一个例子将包含键名 0，1，2 和 3。

参见 数组函数和 来自 PHP 之外的变量。

怎样从可多选的 HTML 的 select multiple 标记中得到所有结果？

可多选的 select multiple 标记是 HTML 的一个构造，允许用户从一个列表中选择多个项目。这些项目接着被传递给该表单 action 中指定的处理程序。问题是它们都会被用同样的名字传递。例如：

<select name="var" multiple="yes">
每个被选项将这样被传递到表单处理程序：
var=option1 var=option2 var=option3
每个选项将覆盖前面一个 $var变量的内容。解决方案是用 PHP 的"表单单元数组"特性。使用方法如下：
<select name="var[]" multiple="yes">
这将告诉 PHP 将 $var当成数组对待，每个对 var[] 的赋值都会给数组增加一项。第一项将成为 $var[0]，下一个是 $var[1]，等等。可以用 count()函数来测定选择了多少个项目，必要时可以用 sort()函数来对选项的数组进行排序。

注意如果在 JavaScript 中通过名字来引用单元，单元名字中的 []可能会造成问题。用表单单元中的数字序号来替代，或者将变量名用单引号括起来并用其作为单元数组的索引，例如：

variable = documents.forms[0].elements['var[]'];

怎样从 Javascript 传递一个变量到 PHP？

由于 Javascript （通常情况下）是客户端技术，而 PHP （通常情况下）是服务器端技术，而且 HTTP 是一种"无状态"协议，因此两种语言之间不能直接共享变量。

但是，有可能在二者之间传递变量。一种实现的方法是用 PHP 生成 Javascript 代码，并让浏览器自动刷新，将特定的变量传递回 PHP 脚本。以下例子显示了如何这样做——让 PHP 代码取得显示屏幕的高度和宽度，通常只能在客户端这么做。

<?php
if (isset($_GET['width']) AND isset($_GET['height'])) {
  // output the geometry variables
  echo "Screen width is: ". $_GET['width'] ."<br />\n";
  echo "Screen height is: ". $_GET['height'] ."<br />\n";
} else {
  // pass the geometry variables
  // (preserve the original query string
  //   -- post variables will need to handled differently)

  echo "<script language='javascript'>\n";
  echo "  location.href=\"${_SERVER['SCRIPT_NAME']}?${_SERVER['QUERY_STRING']}"
            . "&width=\" + screen.width + \"&height=\" + screen.height;\n";
  echo "</script>\n";
  exit();
}
?>


PHP 和 COM

PHP 可以在 Win32 平台中访问 COM 和 DCOM 对象。

  1. 我建立了一个 DLL 来做某种计算。有办法在 PHP 中运行这个 DLL 吗？
  2. “Unsupported variant type: xxxx (0xxxxx)”是什么意思？
  3. 在 PHP 中有可能操纵可视对象吗？
  4. 可以将一个 COM 对象保存在 session 中吗？
  5. 怎样可以捕获 COM 的错误？
  6. 我能像在 Perl 中一样从 PHP 脚本生成 DLL 文件吗？
  7. “Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}”是什么意思？
  8. 怎样从远端服务器运行 COM 对象？
  9. 我得到一个“DCOM is disabled in C:\path...\scriptname.php on line 6”信息，应该怎么办？
  10. 有可能在 PHP 页面中加载／操纵 ActiveX 对象吗？
  11. 有可能得到一个组件在运行中的实例吗？
  12. 有办法处理 COM 对象中发送的事件吗？
  13. 我在尝试调用一个打开了多于一个接口的 COM 对象中的方法时碰到问题，应该怎么办？
  14. 这么说 PHP 可以和 COM 一起工作，那么 COM+ 呢？
  15. 如果 PHP 可以操纵 COM 对象，那么可以设想结合 PHP 用 MTS 来管理组件资源吗？
我建立了一个 DLL 来做某种计算。有办法在 PHP 中运行这个 DLL 吗？

如果这是个简单的 DLL 那么还没有办法在 PHP 中运行它。如果这个 DLL 中包含有一个 COM 服务器并且它实现了 IDispatch 接口，那有可能访问它。

"Unsupported variant type: xxxx (0xxxxx)"是什么意思？

有几十种 VARIANT 类型以及它们的组合。大多数已经被支持了但还有几种尚未实现。数组没有完全被支持。只有一维的仅用作索引的数组可以在 PHP 和 COM 之间传递。如果你发现其它未支持的类型，请当作一个 bug 报告（如果尚未被报告的话）并提供尽可能多的信息。

在 PHP 中有可能操纵可视对象吗？

一般来说是可以的，但是 PHP 大都用来作为 web 脚本语言并运行在 web 服务器的上下文环境中，因此可视对象决不会在服务器的桌面上显示。如果你把 PHP 用作应用程序脚本例如结合 PHP-GTK 来使用，那么访问和通过 COM 来操纵可视对象方面没有限制。

可以将一个 COM 对象保存在 session 中吗？

不行。COM 的实例被看作是资源，因此只在一个脚本的上下文中有效。

怎样可以捕获 COM 的错误？

在 PHP 5 中，COM 扩展会发出 com_exception异常信息，可以捕获并检查 code成员来决定下一步的行为。

在 PHP 4 中除了用 PHP 自己提供的办法之外（@，track_errors，..）不可能捕获 COM 的错误。

我能像在 Perl 中一样从 PHP 脚本生成 DLL 文件吗？

不行，PHP 没有这样的工具。

"Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}"是什么意思？

此错误可以有多种原因：

  • 错误的 CLSID
  • 找不到所请求的 DLL
  • 所请求的组件没有实现 IDispatch 接口

怎样从远端服务器运行 COM 对象？

完全和运行本地对象一样。只须将远端服务器的 IP 作为第二个变量传递给 COM 的构造函数即可。

确认在 php.ini 中设定了 =&true;。

我得到一个"DCOM is disabled in C:\path...\scriptname.php on line 6"信息，应该怎么办？

编辑 php.ini 并设定 =&true;。

有可能在 PHP 页面中加载／操纵 ActiveX 对象吗？

这不关 PHP 的事。如果在 HTML 文档中请求的话，ActiveX 对象被加载在客户端。这和 PHP 脚本没有关系，因此也不可能和服务器端发生直接的交互作用。

有可能得到一个组件在运行中的实例吗？

在绰号的帮助下这有可能。如果你想得到同一个 word 实例的多个引用你可以这样建立此实例：

<?php
$word = new COM("C:\docs\word.doc");
?>

如果没有运行中的实例这将建立一个新的实例，否则将会返回正在运行中的实例的句柄，如果可用的话。

有办法处理 COM 对象中发送的事件吗？

可以自定义事件收报方并且用 com_event_sink()函数绑定之。可以用 com_print_typeinfo()来让 PHP 产生事件收报方类的框架。

我在尝试调用一个打开了多于一个接口的 COM 对象中的方法时碰到问题，应该怎么办？

我也不知道怎么办，我想这没办法。如果什么人有对此问题的明确信息请 » 告诉我。:)

这么说 PHP 可以和 COM 一起工作，那么 COM+ 呢？

COM+ 通过使用 MTS 和 MSMQ 来管理组件的框架扩展了 COM，但并没有什么特殊之处使 PHP 非要支持这样的组件。

如果 PHP 可以操纵 COM 对象，那么可以设想结合 PHP 用 MTS 来管理组件资源吗？

PHP 本身还并不处理事务。因而如果出错也不会发动撤回机制。如果你使用了支持事务处理的组件那你不得不自己实现事务管理。


其他问题

有些问题没法归到其它类中，可以在这里找到。

  1. 在 Windows 中怎样处理 bz2 压缩的文档？
在 Windows 中怎样处理 bz2 压缩的文档？

如果没有能处理 bz2 文件的压缩工具，从 Redhat » 下载一个命令行工具（进一步信息见下面）。

如果不喜欢用命令行工具，可以试试免费工具例如 » Stuffit Expander， » UltimateZip， » 7-Zip或者 » Quick Zip。如果有像 » WinRAR或者 » Power Archiver之类的工具，可以很容易用它解压缩 bz2 文件。如果用 Total Commander（前身为 Windows Commander），可以从 » Total Commander网站免费得到一个 bz2 插件。

来自 Redhat 的 bzip2 命令行工具：

Win2K Sp2 用户下载最新版本 1.0.2，所有其它 Windows 用户应该用版本 1.00。下载后重命名可执行文件为 bzip2.exe。为方便起见将其放到一个在你路径中的目录，例如 C:\Windows，C 表示你安装 Windows 的盘符。

注意：lang 指的是你的语种，x 是想要的格式，例如：pdf。要解压缩 php_manual_lang.x.bz2，按照下面的简单说明进行：

  • 打开一个命令行窗口
  • 进入存放已下载的 php_manual_lang.x.bz2 的目录
  • 调用 bzip2 -d php_manual_lang.x.bz2，将 php_manual_lang.x 释放到同一个目录

在下载了包含很多 html 文件的 php_manual_lang.tar.bz2 的情况下，过程是一样的。唯一区别是得到了一个 php_manual_lang.tar 文件。tar 格式可以被大多数 Windows 下流行的压缩工具所处理，例如 » WinZip。


附录

  • PHP 及其相关工程的历史
    • PHP 的历史
    • PHP 相关工程的历史
    • PHP 相关书籍
    • PHP 相关文章
  • 从 PHP 7.4.x 移植到 PHP 8.0.x
    • 新特性
    • 不向后兼容的变更
    • PHP 8.0 废弃的功能
    • 其他变更
  • 从 PHP 7.3.x 移植到 PHP 7.4.x
    • 新特性
    • 新的类和接口
    • 新函数
    • 新的全局常量
    • 不向后兼容的变更
    • PHP 7.4.x 废弃的功能
    • 移除的扩展
    • 其他变更
    • Windows 支持
  • 从 PHP 7.2.x 移植到 PHP 7.3.x
    • 新特性
    • 新函数
    • 新的全局常量
    • 不向下兼容的变更
    • PHP 7.3.x 中废弃的功能
    • 其它变更
    • Windows 支持
  • 从 PHP 7.1.x 移植到 PHP 7.2.x
    • 新特性
    • 新函数
    • 新全局常量
    • 不向下兼容的变更
    • PHP 7.2.x 中废弃的功能
    • 其他变更
  • 从 PHP 7.0.x 移植到 PHP 7.1.x
    • 新特性
    • 新的函数
    • 新增的全局常量
    • 不向后兼容的变更
    • PHP 7.1.x 中废弃的特性
    • 变动的函数
    • 其它改动
    • Windows 支持
  • 从 PHP 5.6.x 移植到 PHP 7.0.x
    • 不向后兼容的变更
    • 新特性
    • PHP 7.0.x 弃用的功能
    • 变更的函数
    • 新函数
    • 新的类和接口
    • 新的全局常量
    • SAPI 模块的变化
    • 移除的扩展和 SAPI
    • Other Changes
  • 从 PHP 5.5.x 移植到 PHP 5.6.x
    • 向后不兼容
    • 新特性
    • PHP 5.6.x 中已废止的特性
    • 函数的变化
    • 新加函数
    • OpenSSL changes in PHP 5.6.x
    • 扩展中的变动
    • 新加的全局常量
  • PHP 的调试
    • 关于调试器
  • 配置选项
    • 核心配置选项列表
  • php.ini 配置
    • php.ini 配置选项列表
    • php.ini 配置段列表
    • php.ini 核心配置选项说明
  • 扩展库列表／归类
    • 按字母顺序
    • 按归属分
    • 按状态分
  • 函数别名列表
  • 保留字列表
    • 关键词列表
    • 预定义类
    • 预定义常量
    • 其他保留字列表
  • 资源类型列表
  • 可用过滤器列表
    • 字符串过滤器
    • string.strip_tags
    • 转换过滤器
    • 压缩过滤器
    • 加密过滤器
  • 所支持的套接字传输器（Socket Transports）列表
    • Internet 领域：TCP，UDP，SSL 和 TLS
    • Unix 领域：Unix 和 UDG
  • PHP 类型比较表
  • 解析器代号列表
  • 用户空间命名指南
    • 全局命名空间
    • 规则
    • 提示
  • 关于本手册
    • 手册的格式
    • 关于用户注释
    • 如何阅读函数的定义（函数原型）
    • 本手册中所涉及的 PHP 版本
    • 如何得到关于 PHP 更多的信息
    • 如何帮助改进本文档
    • 如何生成手册的各种格式
    • 手册译文
  • Creative Commons Attribution 3.0
  • 索引
    • 函数和方法列表
    • 示例列表
  • 更新日志


PHP 及其相关工程的历史

Table of Contents

  • PHP 的历史
  • PHP 相关工程的历史
  • PHP 相关书籍
  • PHP 相关文章

PHP 在过去的几年里走过了漫长的道路。成长为处理 web 的最卓越的语言并非易事。如果对 PHP 如何发展到今天很感兴趣，那么请继续读下去吧。以前的 PHP 发行版可以在 » PHP 博物馆找到。


PHP 的历史

PHP/FI

PHP 继承自一个老的工程，名叫 PHP/FI。PHP/FI 在 1995 年由 Rasmus Lerdorf 创建，最初只是一套简单的 Perl 脚本，用来跟踪访问他主页的人们的信息。它给这一套脚本取名为"Personal Home Page Tools"。随着更多功能需求的增加，Rasmus 写了一个更大的 C 语言的实现，它可以访问数据库，可以让用户开发简单的动态 Web 程序。Rasmus » 发布了 PHP/FI 的源代码，以便每个人都可以使用它，同时大家也可以修正它的 Bug 并且改进它的源代码。

PHP/FI，一个专为个人主页／表单提供解释程序的程序，已经包含了今天 PHP 的一些基本功能。它有着 Perl 样式的变量，自动解释表单变量，并可以嵌入 HTML。语法本身与 Perl 很相似，但是它很有限，很简单，还稍微有些不协调。

到1997年，PHP/FI 2.0，也就是它的 C 语言实现的第二版在全世界已经有几千个用户（估计）和大约 50,000 个域名安装，大约是 Internet 所有域名的 1%。但是那时只有几个人在为该工程撰写少量当代码，它仍然只是一个人的工程。

PHP/FI 2.0 在经历了数个 beta 版本的发布后于 1997 年 11 月发布了官方正式版本。不久，PHP 3.0 的第一个 alpha 版本的发布，PHP 从此走向了成功。

PHP 3

PHP 3.0 是类似于当今 PHP 语法结构的第一个版本。Andi Gutmans 和 Zeev Suraski 在为一所大学的项目中开发电子商务程序时发现 PHP/FI 2.0 功能明显不足，于是他们重写了代码。这就是 PHP 3.0。经过Andi，Rasmus 和 Zeev 一系列的努力，考虑到 PHP/FI 已存在的用户群，他们决定联合发布 PHP 3.0 作为 PHP/FI 2.0 的官方后继版本。而 PHP/FI 2.0 的进一步开发几乎终止了。

PHP 3.0 的一个最强大的功能是它的可扩展性。除了给最终用户提供数据库、协议和 API 的基础结构，它的可扩展性还吸引了大量的开发人员加入并提交新的模块。后来证实，这是 PHP 3.0 取得巨大成功的关键。PHP 3.0 中的其它关键功能包括面向对象的支持和更强大和协调的语法结构。

这个全新的语言伴随着一个新的名称发布。它从 PHP/FI 2.0 的名称中移去了暗含"本语言只限于个人使用"的部分。它被命名为简单的缩写"PHP"。这是一种递归的缩写，它的全称是——PHP: Hypertext Preprocessor。

1998 年末，PHP 的安装人数几近 10,000，有大约 100,000 个网站报告他们使用了 PHP。在 PHP 3.0 的顶峰，Internet 上 10% 的 web 服务器上都安装了它。

约九个月的公开测试后，官方于 1998 年 6 月正式发布 PHP 3.0。

PHP 4

1998 年的冬天，PHP 3.0 官方发布不久，Andi Gutmans 和 Zeev Suraski 开始重新编写 PHP 代码。设计目标是增强复杂程序运行时的性能和 PHP 自身代码的模块性。PHP 3.0 的新功能和广泛的第三方数据库、API的支持使得这样程序的编写成为可能，但是 PHP 3.0 没有高效处理如此复杂程序的能力。

新的被称为"Zend Engine"（这是 Zeev 和 Andi 的缩写）的引擎，成功的实现了设计目标，并在 1999 年中期首次引入 PHP。基于该引擎并结合了更多新功能的 PHP 4.0，在 PHP 3.0 发布两年后，于2000年5月发布了官方正式版本。除了更高的性能以外，PHP 4.0 还包含了其它一些关键功能，比如：支持更多的 web 服务器；HTTP Sessions 支持；输出缓冲；更安全的处理用户输入的方法；一些新的语言结构。

今天，已经有 10,000 名开发人员（估计）和几百万网站报告已安装了 PHP，占整个 Internet 域名的 20%。

PHP 的开发小组有很多优秀的开发人员，同时还有大量的优秀人才在进行 PHP 相关工程的开发工作，如 PEAR 和 PHP 文档的工程。

PHP 5

PHP 5 在长时间的开发及多个预发布版本后，于 2004 年 7 月发布正式版本。它的核心是 Zend 引擎 2 代，引入了新的对象模型和大量新功能。


PHP 相关工程的历史

PEAR

» PEAR，PHP 扩展与应用资源库（PHP Extension and Application Repository，原为 PHP Extension and Add-on Repository）是 PHP 程序的基础类，并可能在将来增强为在开发人员间分发 PHP 和 C 语言编写的 PHP 扩展的关键方法。

PEAR 在 2000 年 1 月于 Tel Aviv 举行的 PHP 开发者会议（PDM）中诞生。这个工程由 Stig S. Bakken 创建。现在，他正专注于他的第一个小女儿，Malin Bakken。

2000 年早些时候，PEAR 已经成长为一个巨大的，有意义的工程。大量的开发人员在为实现普通的、可重用的、功能强大的代码而努力工作着。这给整个 PHP 团体都带来极大的益处。今天 PEAR 包含了大量的基础类，包括数据库访问、内容缓存、数学计算、电子商务等等。

有关 PEAR 的更多信息见其» 手册。

PHP 质量保证体系（QA）

» PHP 质量保证体系于2000年夏设立，因为用户批评 PHP 在发布前没有进行足够的针对产品环境的测试。质量保证小组由精通 PHP 基础代码的核心人员组成。这些开发人员将精力花费在本地化和修复 PHP 的 bug 上。除此之外，其他小组成员也在各种不同的平台上对这些修复进行测试并提供反馈信息。

PHP-GTK

» PHP-GTK 是编写客户端图形用户界面（GUI）程序的 PHP 解决方案。Andrei Zmievski 回忆了 PHP-GTK 计划和创建的过程：

"我总是对 GUI 编程有着浓厚的兴趣。我发现 Gtk+ 是一个非常好的工具包，除了一点——它使用的 C 语言很令人乏味。目睹了 PyGtk 和 GTK-Perl 的实现，我决定尝试 PHP 是否也能够被做成 Gtk+ 的接口。2000 年 8 月，我有了更多的业余时间，于是我开始试验。我参考了 PyGtk 的实现方法，因为它有着相当完全的实现和漂亮的面向对象的接口。James Henstridge，PyG 的作者，在最初的筹备阶段提供了极大的帮助。

"手工写 Gtk+ 函数全部的接口几乎是不可能的事情，所以我把重点放在了代码生成上，就像 PyGtk 做的一样。代码生成器是一个PHP 程序，它可以读取包含 Gtk+ 类、常量和方法信息的一系列的 .defs 文件并生成与 PHP 相接口的 C 代码。无法自动生成的部分可以提交到 .overrides 文件。

"代码生成器和基础结构的工作花了我一定的时间，因为我在 2000 年秋天这段时间里只能花很少的时间在 PHP-GTK 上。在我把 PHP-GTK 给 Frank Kromann 演示过后，他产生了浓厚的兴趣，并开始帮助我完成代码生成器和 Win32 的实现。当我们写了第一个 Hello World 程序并设法使之工作之时，我们的喜悦之情溢于言表。两个多月后，这个工程初见成效，并于 2001 年 3 月 1 日发布了内部版本。这个故事迅速的打击了 SlashDot。

"感到 PHP-GTK 前景广阔，我便为它专门设置了邮件列表和 CVS 知识库。同时，gtk.php.net 网站也在 Colin Viebrock 的帮助下建立起来。文档的工作也由 James Moore 承担起来。

"PHP-GTK 发布之后，它愈加流行。我们有自己的文档小组，手册持续更新。人们开始为 PHP-GTK 编写扩展。越来越多的程序已经开始使用它了。"


PHP 相关书籍

随着 PHP 的成长，人们越来越认识到它是一个世界流行的开发平台。看到这种趋势的最有趣方法之一就是：这些年 PHP 相关书籍越来越多。

据我们所知，最早的 PHP 专业书籍是"php- dynamische webauftritte professionell realisieren"——一本 1999 年出版的德国书籍，作者是 Egon Schmid、Christian Cartus 和 Richard Blume。第一本关于 PHP 的英文书随后出版，书名是"Core PHP Programming"，作者为：Leon Atkinson。这两本书都是写 PHP 3.0 的。

这两本书是这类图书的第一本——随后，大量的 PHP 相关图书上市。英文版本超过 40 种，德文 50 种，法文 20 种！除此之外，你可以发现西班牙文、韩文、日文、中文和希伯来文等等语言版本的 PHP 相关图书。

这么大量的图书，这么多作者的写作，这么多出版商的出版，并出现了这么多语言的版本——这强烈的证明 PHP 在世界范围内的成功！


PHP 相关文章

据我们所知，关于 PHP 的在杂志上的第一篇文章于 1998 年末在法国的"Informatiques Magazine"杂志上发表，是描述 PHP 3.0 的。据记载，这是大量出版在杂志上 PHP 相关文章的第一篇。

关于 PHP 的文章出现在 Dr. Dobbs、Linux Enterprise、Linux Magazine 等等出版物上。关于在 Windows 下如何转换 ASP 程序到 PHP 的文章甚至出现在了微软自己的 MSDN 上！


从 PHP 7.4.x 移植到 PHP 8.0.x

Table of Contents

  • 新特性
  • 不向后兼容的变更
  • PHP 8.0 废弃的功能
  • 其他变更

新的主版本号带来了一些 新特性 和 不兼容处， 在生产环境上切换 PHP 版本前需要做测试。

参见 PHP 版本迁移指南 7.0.x、 7.1.x、 7.2.x、 7.3.x、 7.4.x。


新特性

PHP 核心中的新特性

命名参数

注解（Attributes）

新增注解的功能。

构造器属性提升（Constructor Property Promotion）

新增构造器属性提升功能（在构造函数中声明类的属性）。

联合类型

新增 联合类型。

Match 表达式

新增 match 表达式。

Nullsafe 运算符

新增 Nullsafe 运算符(?->)。

其他新特性

  • 新增 WeakMap 类。

  • 新增 ValueError 类。

  • 现在，只要类型兼容，任意数量的函数参数都可以用一个可变参数替换。 例如允许编写下面的代码：

    <?php
    class A {
         public function     method(int $many, string $parameters, $here) {}
    }
    class     B extends A {
         public function     method(...$everything) {}
    }
    ?>

  • static ("后期静态绑定"中) 可以作为返回类型：

    <?php
    class Test {
         public function     create(): static {
              return new static();
         }
    }
    ?>

  • 现在可以通过 $object::class 获取类名，返回的结果和 get_class($object) 一致。

  • new、instanceof 可用于任何表达式， 用法为 new (expression)(...$args) 和 $obj instanceof (expression)。

  • 添加对一些变量语法一致性的修复，例如现在能够编写 Foo::BAR::$baz。

  • 添加 Stringable interface， 当一个类定义 __toString() 方法后会自动实现该接口。

  • Trait 可以定义私有抽象方法（abstract private method）。 类必须实现 trait 定义的该方法。

  • 可作为表达式使用 throw。 使得可以编写以下用法：

    <?php
    $fn     = fn() => throw new Exception('Exception in arrow function');
    $user = $session->user ?? throw new Exception('Must have user');

  • 参数列表中的末尾逗号为可选。

    <?php
    function functionWithLongSignature(
            Type1 $parameter1,
            Type2 $parameter2, // <-- 这个逗号也被允许了
    ) {
    }

  • 现在允许 catch (Exception) 一个 exception 而无需捕获到变量中。

  • 支持 mixed 类型。

  • Private methods declared on a parent class no longer enforce any inheritance rules on the methods of a child class (with the exception of final private constructors). The following example illustrates which restrictions have been removed:

    <?php
    class ParentClass {
        private function     method1() {}
        private function     method2() {}
        private static function     method3() {}
            // Throws a warning, as "final" no longer has an effect:
            private final function method4() {}
    }
    class     ChildClass extends ParentClass {
            // All of the following are now allowed, even though the modifiers aren't
        // the same as for the private methods in the parent class.
            public abstract function method1() {}
        public static function     method2() {}
        public function     method3() {}
        public function     method4() {}
    }
    ?>

  • get_resource_id() has been added, which returns the same value as (int) $resource. It provides the same functionality under a clearer API.

Date and Time

  • DateTime::createFromInterface() and DateTimeImmutable::createFromInterface() have been added.

  • The DateTime format specifier p has been added, which is the same as P but returns Z rather than +00:00 for UTC.

DOM

DOMParentNode and DOMChildNode with new traversal and manipulation APIs have been added.

Filter

FILTER_VALIDATE_BOOL has been added as an alias for FILTER_VALIDATE_BOOLEAN. The new name is preferred, as it uses the canonical type name.

Enchant

enchant_dict_add(), enchant_dict_is_added(), and LIBENCHANT_VERSION have been added.

FPM

Added a new option pm.status_listen that allows getting the status from different endpoint (e.g. port or UDS file) which is useful for getting the status when all children are busy with serving long running requests.

Hash

HashContext objects can now be serialized.

Internationalization Functions

The IntlDateFormatter::RELATIVE_FULL,
IntlDateFormatter::RELATIVE_LONG,
IntlDateFormatter::RELATIVE_MEDIUM, and
IntlDateFormatter::RELATIVE_SHORT
constants have been added.

LDAP

ldap_count_references() has been added, which returns the number of reference messages in a search result.

OPcache

If the opcache.record_warnings ini setting is enabled, OPcache will record compile-time warnings and replay them on the next include, even if it is served from cache.

OpenSSL

Added Cryptographic Message Syntax (CMS) (» RFC 5652) support composed of functions for encryption, decryption, signing, verifying and reading. The API is similar to the API for PKCS #7 functions with an addition of new encoding constants: OPENSSL_ENCODING_DER, OPENSSL_ENCODING_SMIME and OPENSSL_ENCODING_PEM:

  • openssl_cms_encrypt() encrypts the message in the file with the certificates and outputs the result to the supplied file.
  • openssl_cms_decrypt() that decrypts the S/MIME message in the file and outputs the results to the supplied file.
  • openssl_cms_read() that exports the CMS file to an array of PEM certificates.
  • openssl_cms_sign() that signs the MIME message in the file with a cert and key and output the result to the supplied file.
  • openssl_cms_verify() that verifies that the data block is intact, the signer is who they say they are, and returns the certs of the signers.

Regular Expressions (Perl-Compatible)

preg_last_error_msg() has been added, which returns a human-readable message for the last PCRE error. It complements preg_last_error(), which returns an integer enum value instead.

Reflection

  • The following methods can now return information about default values of parameters of internal functions:

    • ReflectionParameter::isDefaultValueAvailable()
    • ReflectionParameter::getDefaultValue()
    • ReflectionParameter::isDefaultValueConstant()
    • ReflectionParameter::getDefaultValueConstantName()

SQLite3

SQLite3::setAuthorizer() and respective class constants have been added to set a userland callback that will be used to authorize or not an action on the database.

Standard Library

  • str_contains(), str_starts_with() and str_ends_with() have been added, which check whether haystack contains, starts with or ends with needle, respectively.

  • fdiv() has been added, which performs a floating-point division under IEEE 754 semantics. Division by zero is considered well-defined and will return one of Inf, -Inf or NaN.

  • get_debug_type() has been added, which returns a type useful for error messages. Unlike gettype(), it uses canonical type names, returns class names for objects, and indicates the resource type for resources.

  • printf() and friends now support the %h and %H format specifiers. These are the same as %g and %G, but always use "." as the decimal separator, rather than determining it through the LC_NUMERIC locale.

  • printf() and friends now support using "*" as width or precision, in which case the width/precision is passed as an argument to printf. This also allows using precision -1 with %g, %G, %h and %H. For example, the following code can be used to reproduce PHP's default floating point formatting:

    <?php
    printf    ("%.*H", (int) ini_get("precision"), $float);
    printf("%.*H", (int) ini_get("serialize_precision"), $float);
    ?>

  • proc_open() now supports pseudo-terminal (PTY) descriptors. The following attaches stdin, stdout and stderr to the same PTY:

    <?php
    $proc     = proc_open($command, [['pty'], ['pty'], ['pty']], $pipes);
    ?>

  • proc_open() now supports socket pair descriptors. The following attaches a distinct socket pair to stdin, stdout and stderr:

    <?php
    $proc     = proc_open($command, [['socket'], ['socket'], ['socket']], $pipes);
    ?>

    Unlike pipes, sockets do not suffer from blocking I/O issues on Windows. However, not all programs may work correctly with stdio sockets.

  • Sorting functions are now stable, which means that equal-comparing elements will retain their original order.

  • array_diff(), array_intersect() and their variations can now be used with a single array as argument. This means that usages like the following are now possible:

    <?php
    // OK even if $excludes is empty:
    array_diff($array, ...$excludes);
    // OK even if $arrays only contains a single array:
    array_intersect(...$arrays);
    ?>

  • The flag parameter of ob_implicit_flush() was changed to accept a bool rather than an int.

Tokenizer

PhpToken adds an object-based interface to the tokenizer. It provides a more uniform and ergonomic representation, while being more memory efficient and faster.

Zip

  • The Zip extension has been updated to version 1.19.1.

  • New ZipArchive::setMtimeName() and ZipArchive::setMtimeIndex() to set the modification time of an entry.

  • New ZipArchive::registerProgressCallback() to provide updates during archive close.

  • New ZipArchive::registerCancelCallback() to allow cancellation during archive close.

  • New ZipArchive::replaceFile() to replace an entry content.

  • New ZipArchive::isCompressionMethodSupported() to check optional compression features.

  • New ZipArchive::isEncryptionMethodSupported() to check optional encryption features.

  • The ZipArchive::lastId property to get the index value of the last added entry has been added.

  • Errors can now be checked after an archive has been closed using the
ZipArchive::status and
ZipArchive::statusSys properties, or the
ZipArchive::getStatusString() method.

  • The 'remove_path' option of ZipArchive::addGlob() and ZipArchive::addPattern() is now treated as an arbitrary string prefix (for consistency with the 'add_path' option), whereas formerly it was treated as a directory name.

  • Optional compression / encryption features are now listed in phpinfo.


不向后兼容的变更

PHP 核心中不向后兼容的变更

字符串与数字的比较

数字与非数字形式的字符串之间的非严格比较现在将首先将数字转为字符串，然后比较这两个字符串。 数字与数字形式的字符串之间的比较仍然像之前那样进行。 请注意，这意味着 0 == "not-a-number" 现在将被认为是 false 。

Comparison | Before | After
0 == "0" | true | true
0 == "0.0" | true | true
0 == "foo" | true | false
0 == "" | true | false
42 == " 42" | true | true
42 == "42foo" | true | false

其它不向后兼容的变更

  • match 现在是一个保留字。

  • 断言（Assertion）失败现在默认抛出异常。如果想要改回之前的行为，可以在 INI 设置中设置 assert.exception=0 。

  • 与类名相同的方法名将不再被当做构造方法。应该使用__construct() 来取代它。

  • 不再允许通过静态调用的方式去调用非静态方法。因此is_callable()在检查一个类名与非静态方法 时将返回失败（应当检查一个类的实例）。

  • (real) 和 (unset) 转换已被移除。

  • The track_errors ini directive has been removed. This means that php_errormsg is no longer available. The error_get_last() function may be used instead.

  • The ability to define case-insensitive constants has been removed. The third argument to define() may no longer be true.

  • The ability to specify an autoloader using an __autoload() function has been removed. spl_autoload_register() should be used instead.

  • The errcontext argument for custom error handlers has been removed.

  • create_function() has been removed. Anonymous functions may be used instead.

  • each() has been removed. foreach or ArrayIterator should be used instead.

  • The ability to unbind this from closures that were created from a method, using Closure::fromCallable() or ReflectionMethod::getClosure(), has been removed.

  • The ability to unbind this from proper closures that contain uses of this has also been removed.

  • The ability to use array_key_exists() with objects has been removed. isset() or property_exists() may be used instead.

  • The behavior of array_key_exists() regarding the type of the key parameter has been made consistent with isset() and normal array access. All key types now use the usual coercions and array/object keys throw a TypeError.

  • Any array that has a number n as its first numeric key will use n+1 for its next implicit key, even if n is negative.

  • The default error_reporting level is now E_ALL. Previously it excluded E_NOTICE and E_DEPRECATED.

  • display_startup_errors is now enabled by default.

  • Using parent inside a class that has no parent will now result in a fatal compile-time error.

  • The @ operator will no longer silence fatal errors (E_ERROR, E_CORE_ERROR, E_COMPILE_ERROR, E_USER_ERROR, E_RECOVERABLE_ERROR, E_PARSE). Error handlers that expect error_reporting to be 0 when @ is used, should be adjusted to use a mask check instead:

    <?php
    // Replace
    function my_error_handler($err_no, $err_msg, $filename, $linenum) {
        if (    error_reporting() == 0) {
            return;     // Silenced
            }
            // ...
    }

    // With
    function my_error_handler($err_no, $err_msg, $filename, $linenum) {
        if (!(    error_reporting() & $err_no)) {
            return;     // Silenced
            }
            // ...
    }
    ?>

    Additionally, care should be taken that error messages are not displayed in production environments, which can result in information leaks. Please ensure that display_errors=Off is used in conjunction with error logging.

  • #[ is no longer interpreted as the start of a comment, as this syntax is now used for attributes.

  • Inheritance errors due to incompatible method signatures (LSP violations) will now always generate a fatal error. Previously a warning was generated in some cases.

  • The precedence of the concatenation operator has changed relative to bitshifts and addition as well as subtraction.

    <?php
    echo "Sum: " . $a + $b;
    // was previously interpreted as:
    echo ("Sum: " . $a) + $b;
    // is now interpreted as:
    echo "Sum:" . ($a + $b);
    ?>

  • Arguments with a default value that resolves to null at runtime will no longer implicitly mark the argument type as nullable. Either an explicit nullable type, or an explicit null default value has to be used instead.

    <?php
    // Replace
    function test(int $arg = CONST_RESOLVING_TO_NULL) {}
    // With
    function test(?int $arg = CONST_RESOLVING_TO_NULL) {}
    // Or
    function test(int $arg = null) {}
    ?>

  • A number of warnings have been converted into Error exceptions:

    • Attempting to write to a property of a non-object. Previously this implicitly created an stdClass object for null, false and empty strings.
    • Attempting to append an element to an array for which the PHP_INT_MAX key is already used.
    • Attempting to use an invalid type (array or object) as an array key or string offset.
    • Attempting to write to an array index of a scalar value.
    • Attempting to unpack a non-array/Traversable.
    • Attempting to access unqualified constants which are undefined. Previously, unqualified constant accesses resulted in a warning and were interpreted as strings.

    A number of notices have been converted into warnings:

    • Attempting to read an undefined variable.
    • Attempting to read an undefined property.
    • Attempting to read an undefined array key.
    • Attempting to read a property of a non-object.
    • Attempting to access an array index of a non-array.
    • Attempting to convert an array to string.
    • Attempting to use a resource as an array key.
    • Attempting to use null, a boolean, or a float as a string offset.
    • Attempting to read an out-of-bounds string offset.
    • Attempting to assign an empty string to a string offset.

  • Attempting to assign multiple bytes to a string offset will now emit a warning.

  • Unexpected characters in source files (such as NUL bytes outside of strings) will now result in a ParseError exception instead of a compile warning.

  • Uncaught exceptions now go through "clean shutdown", which means that destructors will be called after an uncaught exception.

  • The compile time fatal error "Only variables can be passed by reference" has been delayed until runtime, and converted into an "Argument cannot be passed by reference" Error exception.

  • Some "Only variables should be passed by reference" notices have been converted to "Argument cannot be passed by reference" exception.

  • The generated name for anonymous classes has changed. It will now include the name of the first parent or interface:

    <?php
    new class extends ParentClass {};
    // -> ParentClass@anonymous
    new class implements FirstInterface, SecondInterface {};
    // -> FirstInterface@anonymous
    new class {};
    // -> class@anonymous
    ?>

    The name shown above is still followed by a NUL byte and a unique suffix.

  • Non-absolute trait method references in trait alias adaptations are now required to be unambiguous:

    <?php
    class X {
        use     T1, T2 {
                func as otherFunc;
        }
        function     func() {}
    }
    ?>

    If both T1::func() and T2::func() exist, this code was previously silently accepted, and func was assumed to refer to T1::func. Now it will generate a fatal error instead, and either T1::func or T2::func needs to be written explicitly.

  • The signature of abstract methods defined in traits is now checked against the implementing class method:

    <?php
    trait MyTrait {
        abstract private function     neededByTrait(): string;
    }

    class     MyClass {
        use     MyTrait;

            // Error, because of return type mismatch.
            private function neededByTrait(): int { return 42; }
    }
    ?>

  • Disabled functions are now treated exactly like non-existent functions. Calling a disabled function will report it as unknown, and redefining a disabled function is now possible.

  • data:// stream wrappers are no longer writable, which matches the documented behavior.

  • The arithmetic and bitwise operators +, -, *, /, **, %, <<, >>, &, |, ^, ~, ++, -- will now consistently throw a TypeError when one of the operands is an array, 资源(resource) or non-overloaded object. The only exception to this is the array + array merge operation, which remains supported.

  • Float to string casting will now always behave locale-independently.

    <?php
setlocale(LC_ALL, "de_DE");
$f = 3.14;
echo $f, "\n";
// Previously: 3,14
// Now:        3.14
?>

    See printf(), number_format() and NumberFormatter() for ways to customize number formatting.

  • Support for deprecated curly braces for offset access has been removed.

    <?php
// Instead of:
$array{0};
$array{"key"};
// Write:
$array[0];
$array["key"];
?>

  • Applying the final modifier on a private method will now produce a warning unless that method is the constructor.

  • If an object constructor exit()s, the object destructor will no longer be called. This matches the behavior when the constructor throws.

  • Namespaced names can no longer contain whitespace: While Foo\Bar will be recognized as a namespaced name, Foo \ Bar will not. Conversely, reserved keywords are now permitted as namespace segments, which may also change the interpretation of code: new\x is now the same as constant('new\x'), not new \x().

  • Nested ternaries now require explicit parentheses.

  • debug_backtrace() and Exception::getTrace() will no longer provide references to arguments. It will not be possible to change function arguments through the backtrace.

  • Numeric string handling has been altered to be more intuitive and less error-prone. Trailing whitespace is now allowed in numeric strings for consistency with how leading whitespace is treated. This mostly affects:

    • The is_numeric() function
    • String-to-string comparisons
    • Type declarations
    • Increment and decrement operations

    The concept of a "leading-numeric string" has been mostly dropped; the cases where this remains exist in order to ease migration. Strings which emitted an E_NOTICE "A non well-formed numeric value encountered" will now emit an E_WARNING "A non-numeric value encountered" and all strings which emitted an E_WARNING "A non-numeric value encountered" will now throw a TypeError. This mostly affects:

    • Arithmetic operations
    • Bitwise operations

    This E_WARNING to TypeError change also affects the E_WARNING "Illegal string offset 'string'" for illegal string offsets. The behavior of explicit casts to int/float from strings has not been changed.

  • Magic Methods will now have their arguments and return types checked if they have them declared. The signatures should match the following list:

    • __call(string $name, array $arguments): mixed
    • __callStatic(string $name, array $arguments): mixed
    • __clone(): void
    • __debugInfo(): ?array
    • __get(string $name): mixed
    • __invoke(mixed $arguments): mixed
    • __isset(string $name): bool
    • __serialize(): array
    • __set(string $name, mixed $value): void
    • __set_state(array $properties): object
    • __sleep(): array
    • __unserialize(array $data): void
    • __unset(string $name): void
    • __wakeup(): void

  • call_user_func_array() array keys will now be interpreted as parameter names, instead of being silently ignored.

  • Declaring a function called assert() inside a namespace is no longer allowed, and issues E_COMPILE_ERROR. The assert() function is subject to special handling by the engine, which may lead to inconsistent behavior when defining a namespaced function with the same name.

Resource to Object Migration

Several 资源(resource)s have been migrated to objects. Return value checks using is_resource() should be replaced with checks for false.

  • curl_init() will now return a CurlHandle object rather than a 资源(resource). The curl_close() function no longer has an effect, instead the CurlHandle instance is automatically destroyed if it is no longer referenced.

  • curl_multi_init() will now return a CurlMultiHandle object rather than a 资源(resource). The curl_multi_close() function no longer has an effect, instead the CurlMultiHandle instance is automatically destroyed if it is no longer referenced.

  • curl_share_init() will now return a CurlShareHandle object rather than a 资源(resource). The curl_share_close() function no longer has an effect, instead the CurlShareHandle instance is automatically destroyed if it is no longer referenced.

  • enchant_broker_init() will now return an EnchantBroker object rather than a 资源(resource).

  • enchant_broker_request_dict() and enchant_broker_request_pwl_dict() will now return an EnchantDictionary object rather than a 资源(resource).

  • The GD extension now uses GdImage objects as the underlying data structure for images, rather than 资源(resource)s. The imagedestroy() function no longer has an effect; instead the GdImage instance is automatically destroyed if it is no longer referenced.

  • openssl_x509_read() and openssl_csr_sign() will now return an OpenSSLCertificate object rather than a 资源(resource). The openssl_x509_free() function is deprecated and no longer has an effect, instead the OpenSSLCertificate instance is automatically destroyed if it is no longer referenced.

  • openssl_csr_new() will now return an OpenSSLCertificateSigningRequest object rather than a 资源(resource).

  • openssl_pkey_new() will now return an OpenSSLAsymmetricKey object rather than a 资源(resource). The openssl_pkey_free() function is deprecated and no longer has an effect, instead the OpenSSLAsymmetricKey instance is automatically destroyed if it is no longer referenced.

  • shmop_open() will now return a Shmop object rather than a 资源(resource). The shmop_close() function no longer has an effect, and is deprecated; instead the Shmop instance is automatically destroyed if it is no longer referenced.

  • socket_create(), socket_create_listen(), socket_accept(), socket_import_stream(), socket_addrinfo_connect(), socket_addrinfo_bind(), and socket_wsaprotocol_info_import() will now return a Socket object rather than a 资源(resource). socket_addrinfo_lookup() will now return an array of AddressInfo objects rather than 资源(resource)s.

  • msg_get_queue() will now return an SysvMessageQueue object rather than a 资源(resource).

  • sem_get() will now return an SysvSemaphore object rather than a 资源(resource).

  • shm_attach() will now return an SysvSharedMemory object rather than a 资源(resource).

  • xml_parser_create() and xml_parser_create_ns() will now return an XmlParser object rather than a 资源(resource). The xml_parser_free() function no longer has an effect, instead the XmlParser instance is automatically destroyed if it is no longer referenced.

  • The XMLWriter functions now accept and return, respectively, XMLWriter objects instead of 资源(resource)s.

  • inflate_init() will now return an InflateContext object rather than a 资源(resource).

  • deflate_init() will now return a DeflateContext object rather than a 资源(resource).

COM and .Net (Windows)

The ability to import case-insensitive constants from type libraries has been removed. The second argument to com_load_typelib() may no longer be false; com.autoregister_casesensitive may no longer be disabled; case-insensitive markers in com.typelib_file are ignored.

CURL

CURLOPT_POSTFIELDS no longer accepts objects as arrays. To interpret an object as an array, perform an explicit (array) cast. The same applies to other options accepting arrays as well.

Date and Time

mktime() and gmmktime() now require at least one argument. time() can be used to get the current timestamp.

DOM

Unimplemented classes from the DOM extension that had no behavior and contained test data have been removed. These classes have also been removed in the latest version of the DOM standard:

  • DOMNameList
  • DomImplementationList
  • DOMConfiguration
  • DomError
  • DomErrorHandler
  • DOMImplementationSource
  • DOMLocator
  • DOMUserDataHandler
  • DOMTypeInfo

Enchant

  • enchant_broker_list_dicts(), enchant_broker_describe() and enchant_dict_suggest() will now return an empty array instead of null.

Exif

read_exif_data() has been removed; exif_read_data() should be used instead.

Filter

  • The FILTER_FLAG_SCHEME_REQUIRED and FILTER_FLAG_HOST_REQUIRED flags for the FILTER_VALIDATE_URL filter have been removed. The scheme and host are (and have been) always required.

  • The INPUT_REQUEST and INPUT_SESSION source for filter_input() etc. have been removed. These were never implemented and their use always generated a warning.

GD

  • The deprecated functions image2wbmp() has been removed.

  • The deprecated functions png2wbmp() and jpeg2wbmp() have been removed.

  • The default mode parameter of imagecropauto() no longer accepts -1. IMG_CROP_DEFAULT should be used instead.

  • On Windows, php_gd2.dll has been renamed to php_gd.dll.

GMP

gmp_random() has been removed. One of gmp_random_range() or gmp_random_bits() should be used instead.

Iconv

iconv implementations which do not properly set errno in case of errors are no longer supported.

IMAP

  • The unused default_host argument of imap_headerinfo() has been removed.

  • The imap_header() function which is an alias of imap_headerinfo() has been removed.

Internationalization Functions

  • The deprecated constant INTL_IDNA_VARIANT_2003 has been removed.

  • The deprecated Normalizer::NONE constant has been removed.

LDAP

  • The deprecated functions ldap_sort(),
ldap_control_paged_result() and
ldap_control_paged_result_response() have been removed.

  • The interface of ldap_set_rebind_proc() has changed; the callback parameter does not accept empty strings anymore; null should be used instead.

MBString

  • The mbstring.func_overload directive has been removed. The related MB_OVERLOAD_MAIL, MB_OVERLOAD_STRING, and MB_OVERLOAD_REGEX constants have also been removed. Finally, the "func_overload" and "func_overload_list" entries in mb_get_info() have been removed.

  • mb_parse_str() can no longer be used without specifying a result array.

  • A number of deprecated mbregex aliases have been removed. See the following list for which functions should be used instead:

    • mbregex_encoding() → mb_regex_encoding()
    • mbereg() → mb_ereg()
    • mberegi() → mb_eregi()
    • mbereg_replace() → mb_ereg_replace()
    • mberegi_replace() → mb_eregi_replace()
    • mbsplit() → mb_split()
    • mbereg_match() → mb_ereg_match()
    • mbereg_search() → mb_ereg_search()
    • mbereg_search_pos() → mb_ereg_search_pos()
    • mbereg_search_regs() → mb_ereg_search_regs()
    • mbereg_search_init() → mb_ereg_search_init()
    • mbereg_search_getregs() → mb_ereg_search_getregs()
    • mbereg_search_getpos() → mb_ereg_search_getpos()
    • mbereg_search_setpos() → mb_ereg_search_setpos()

  • The e modifier for mb_ereg_replace() has been removed. mb_ereg_replace_callback() should be used instead.

  • A non-string pattern argument to mb_ereg_replace() will now be interpreted as a string instead of an ASCII codepoint. The previous behavior may be restored with an explicit call to chr().

  • The needle argument for mb_strpos(),
mb_strrpos(), mb_stripos(),
mb_strripos(), mb_strstr(),
mb_stristr(), mb_strrchr() and
mb_strrichr() can now be empty.

  • The is_hex parameter, which was not used internally, has been removed from mb_decode_numericentity().

  • The legacy behavior of passing the encoding as the third argument instead of an offset for the mb_strrpos() function has been removed; an explicit 0 offset with the encoding should be provided as the fourth argument instead.

  • The ISO_8859-* character encoding aliases have been replaced by ISO8859-* aliases for better interoperability with the iconv extension. The mbregex ISO 8859 aliases with underscores (ISO_8859_* and ISO8859_*) have also been removed.

  • mb_ereg() and mb_eregi() will now return boolean true on a successfuly match. Previously they returned integer 1 if matches was not passed, or max(1, strlen($matches[0])) if matches was passed.

OCI8

  • The OCI-Lob class is now called OCILob, and the OCI-Collection class is now called OCICollection for name compliance enforced by PHP 8 arginfo type annotation tooling.

  • Several alias functions have been marked as deprecated.

  • oci_internal_debug() and its alias ociinternaldebug() have been removed.

ODBC

  • odbc_connect() no longer reuses connections.

  • The unused flags parameter of odbc_exec() has been removed.

OpenSSL

  • openssl_seal() and openssl_open() now require method to be passed, as the previous default of "RC4" is considered insecure.

Regular Expressions (Perl-Compatible)

When passing invalid escape sequences they are no longer interpreted as literals. This behavior previously required the X modifier - which is now ignored.

PHP Data Objects

  • The default error handling mode has been changed from "silent" to "exceptions". See Errors and error handling for details.

  • The signatures of some PDO methods have changed:

    • PDO::query(string $query, ?int $fetchMode = null, mixed ...$fetchModeArgs)
    • PDOStatement::setFetchMode(int $mode, mixed ...$args)

PDO ODBC

The php.ini directive pdo_odbc.db2_instance_name has been removed.

PostgreSQL

  • The deprecated pg_connect() syntax using multiple parameters instead of a connection string is no longer supported.

  • The deprecated pg_lo_import() and pg_lo_export() signature that passes the connection as the last argument is no longer supported. The connection should be passed as first argument instead.

  • pg_fetch_all() will now return an empty array instead of false for result sets with zero rows.

Phar

Metadata associated with a phar will no longer be automatically unserialized, to fix potential security vulnerabilities due to object instantiation, autoloading, etc.

Reflection

  • The method signatures

    • ReflectionClass::newInstance($args)
    • ReflectionFunction::invoke($args)
    • ReflectionMethod::invoke($object, $args)

    have been changed to:

    • ReflectionClass::newInstance(...$args)
    • ReflectionFunction::invoke(...$args)
    • ReflectionMethod::invoke($object, ...$args)

    Code that must be compatible with both PHP 7 and PHP 8 can use the following signatures to be compatible with both versions:

    • ReflectionClass::newInstance($arg = null, ...$args)
    • ReflectionFunction::invoke($arg = null, ...$args)
    • ReflectionMethod::invoke($object, $arg = null, ...$args)

  • The ReflectionType::__toString() method will now return a complete debug representation of the type, and is no longer deprecated. In particular the result will include a nullability indicator for nullable types. The format of the return value is not stable and may change between PHP versions.

  • Reflection export() methods have been removed. Instead reflection objects can be cast to string.

  • ReflectionMethod::isConstructor() and
ReflectionMethod::isDestructor() now also return true for
__construct() and
__destruct() methods of interfaces.
Previously, this would only be true for methods of classes and traits.

  • ReflectionType::isBuiltin() method has been moved to ReflectionNamedType. ReflectionUnionType does not have it.

Sockets

  • The deprecated AI_IDN_ALLOW_UNASSIGNED and AI_IDN_USE_STD3_ASCII_RULES flags for socket_addrinfo_lookup() have been removed.

Standard PHP Library (SPL)

  • SplFileObject::fgetss() has been removed.

  • SplHeap::compare() now specifies a method signature. Inheriting classes implementing this method will now have to use a compatible method signature.

  • SplDoublyLinkedList::push(), SplDoublyLinkedList::unshift() and SplQueue::enqueue() now return void instead of true.

  • spl_autoload_register() will now always throw a TypeError on invalid arguments, therefore the second argument do_throw is ignored and a notice will be emitted if it is set to false.

  • SplFixedArray is now an IteratorAggregate and not an Iterator. SplFixedArray::rewind(), SplFixedArray::current(), SplFixedArray::key(), SplFixedArray::next(), and SplFixedArray::valid() have been removed. In their place, SplFixedArray::getIterator() has been added. Any code which uses explicit iteration over SplFixedArray must now obtain an Iterator through SplFixedArray::getIterator(). This means that SplFixedArray is now safe to use in nested loops.

Standard Library

  • assert() will no longer evaluate string arguments, instead they will be treated like any other argument. assert($a == $b) should be used instead of assert('$a == $b'). The assert.quiet_eval ini directive and the ASSERT_QUIET_EVAL constant have also been removed, as they would no longer have any effect.

  • parse_str() can no longer be used without specifying a result array.

  • The string.strip_tags filter has been removed.

  • The needle argument of strpos(), strrpos(), stripos(), strripos(), strstr(), strchr(), strrchr(), and stristr() will now always be interpreted as a string. Previously non-string needles were interpreted as an ASCII code point. An explicit call to chr() can be used to restore the previous behavior.

  • The needle argument for strpos(),
strrpos(), stripos(), strripos(),
strstr(), stristr() and strrchr() can
now be empty.

  • The length argument for substr(), substr_count(), substr_compare(), and iconv_substr() can now be null. null values will behave as if no length argument was provided and will therefore return the remainder of the string instead of an empty string.

  • The length argument for array_splice() can now be null. null values will behave identically to omitting the argument, thus removing everything from the offset to the end of the array.

  • The args argument of vsprintf(), vfprintf(), and vprintf() must now be an array. Previously any type was accepted.

  • The 'salt' option of password_hash() is no longer supported. If the 'salt' option is used a warning is generated, the provided salt is ignored, and a generated salt is used instead.

  • The quotemeta() function will now return an empty string if an empty string was passed. Previously false was returned.

  • The following functions have been removed:

    • hebrevc()
    • convert_cyr_string()
    • money_format()
    • ezmlm_hash()
    • restore_include_path()
    • get_magic_quotes_gpc()
    • get_magic_quotes_runtime()
    • fgetss()

  • FILTER_SANITIZE_MAGIC_QUOTES has been removed.

  • Calling implode() with parameters in a reverse order ($pieces, $glue) is no longer supported.

  • parse_url() will now distinguish absent and empty queries and fragments:

    • http://example.com/foo → query = null, fragment = null
    • http://example.com/foo? → query = "", fragment = null
    • http://example.com/foo# → query = null, fragment = ""
    • http://example.com/foo?# → query = "", fragment = ""
    Previously all cases resulted in query and fragment being null.

  • var_dump() and debug_zval_dump() will now print floating-point numbers using serialize_precision rather than precision. In a default configuration, this means that floating-point numbers are now printed with full accuracy by these debugging functions.

  • If the array returned by __sleep() contains non-existing properties, these are now silently ignored. Previously, such properties would have been serialized as if they had the value null.

  • The default locale on startup is now always "C". No locales are inherited from the environment by default. Previously, LC_ALL was set to "C", while LC_CTYPE was inherited from the environment. However, some functions did not respect the inherited locale without an explicit setlocale() call. An explicit setlocale() call is now always required if a locale component should be changed from the default.

  • The deprecated DES fallback in crypt() has been removed. If an unknown salt format is passed to crypt(), the function will fail with *0 instead of falling back to a weak DES hash now.

  • Specifying out of range rounds for SHA256/SHA512 crypt() will now fail with *0 instead of clamping to the closest limit. This matches glibc behavior.

  • The result of sorting functions may have changed, if the array contains elements that compare as equal.

  • Any functions accepting callbacks that are not explicitly specified to accept parameters by reference will now warn if a callback with reference parameters is used. Examples include array_filter() and array_reduce(). This was already the case for most, but not all, functions previously.

  • The HTTP stream wrapper as used by functions like file_get_contents() now advertises HTTP/1.1 rather than HTTP/1.0 by default. This does not change the behavior of the client, but may cause servers to respond differently. To retain the old behavior, set the 'protocol_version' stream context option, e.g.

    <?php
    $ctx     = stream_context_create(['http' => ['protocol_version' => '1.0']]);
    echo     file_get_contents('http://example.org', false, $ctx);
    ?>

  • Calling crypt() without an explicit salt is no longer supported. If you would like to produce a strong hash with an auto-generated salt, use password_hash() instead.

  • substr(), mb_substr(), iconv_substr() and grapheme_substr() now consistently clamp out-of-bounds offsets to the string boundary. Previously, false was returned instead of the empty string in some cases.

  • On Windows, the program execution functions (proc_open(), exec(), popen() etc.) using the shell, now consistently execute %comspec% /s /c "$commandline", which has the same effect as executing $commandline (without additional quotes).

Sysvsem

  • The auto_release parameter of sem_get() was changed to accept bool values rather than int.

Tidy

  • The use_include_path parameter, which was not used internally, has been removed from tidy_repair_string().

  • tidy::repairString() and tidy::repairFile() became static methods.

Tokenizer

  • T_COMMENT tokens will no longer include a trailing newline. The newline will instead be part of a following T_WHITESPACE token. It should be noted that T_COMMENT is not always followed by whitespace, it may also be followed by T_CLOSE_TAG or end-of-file.

  • Namespaced names are now represented using the T_NAME_QUALIFIED (Foo\Bar), T_NAME_FULLY_QUALIFIED (\Foo\Bar) and T_NAME_RELATIVE (namespace\Foo\Bar) tokens. T_NS_SEPARATOR is only used for standalone namespace separators, and only syntactially valid in conjunction with group use declarations.

XMLReader

XMLReader::open() and XMLReader::xml() are now static methods. They can still be called as instance methods, but inheriting classes need to declare them as static if they override these methods.

XML-RPC

The XML-RPC extension has been moved to PECL and is no longer part of the PHP distribution.

Zip

ZipArchive::OPSYS_Z_CPM has been removed (this name was a typo). Use ZipArchive::OPSYS_CPM instead.

Zlib

  • gzgetss() has been removed.

  • zlib.output_compression is no longer automatically disabled for Content-Type: image/*.

Windows PHP Test Packs

The test runner has been renamed from run-test.php to run-tests.php, to match its name in php-src.


PHP 8.0 废弃的功能

PHP 核心中废弃的功能

  • 如果带有默认值的参数后面跟着一个必要的参数，那么默认值就会无效。这在 PHP 8.0.0 中已被废弃，通常可以通过删除默认值，不影响现有功能：

    <?php
    function test($a = [], $b) {} // 之前
    function test($a, $b) {}      // 之后
    ?>

    这条规则的一个例外是 Type $param = null 形式的参数，其中 null 的默认值使得类型隐式为空。这种用法仍然是允许的，但仍建议使用显式可空类型。

    <?php
    function test(A $a = null, $b) {} // 旧写法，仍可用
    function test(?A $a, $b) {}       // 推荐写法
    ?>

  • Calling get_defined_functions() with exclude_disabled explicitly set to false is deprecated and no longer has an effect. get_defined_functions() will never include disabled functions.

Enchant

  • enchant_broker_set_dict_path() and enchant_broker_get_dict_path() are deprecated, because that functionality is neither available in libenchant < 1.5 nor in libenchant-2.

  • enchant_dict_add_to_personal() is deprecated; use enchant_dict_add() instead.

  • enchant_dict_is_in_session() is deprecated; use enchant_dict_is_added() instead.

  • enchant_broker_free() and enchant_broker_free_dict() are deprecated; unset the object instead.

  • The ENCHANT_MYSPELL and ENCHANT_ISPELL constants are deprecated.

LibXML

libxml_disable_entity_loader() has been deprecated. As libxml 2.9.0 is now required, external entity loading is guaranteed to be disabled by default, and this function is no longer needed to protect against XXE attacks.

PGSQL / PDO PGSQL

  • The constant PG_VERSION_STR now has the same value as PG_VERSION, and thus is deprecated.

  • Function aliases in the pgsql extension have been deprecated. See the following list for which functions should be used instead:

    • pg_errormessage() → pg_last_error()
    • pg_numrows() → pg_num_rows()
    • pg_numfields() → pg_num_fields()
    • pg_cmdtuples() → pg_affected_rows()
    • pg_fieldname() → pg_field_name()
    • pg_fieldsize() → pg_field_size()
    • pg_fieldtype() → pg_field_type()
    • pg_fieldnum() → pg_field_num()
    • pg_result() → pg_fetch_result()
    • pg_fieldprtlen() → pg_field_prtlen()
    • pg_fieldisnull() → pg_field_is_null()
    • pg_freeresult() → pg_free_result()
    • pg_getlastoid() → pg_last_oid()
    • pg_locreate() → pg_lo_create()
    • pg_lounlink() → pg_lo_unlink()
    • pg_loopen() → pg_lo_open()
    • pg_loclose() → pg_lo_close()
    • pg_loread() → pg_lo_read()
    • pg_lowrite() → pg_lo_write()
    • pg_loreadall() → pg_lo_read_all()
    • pg_loimport() → pg_lo_import()
    • pg_loexport() → pg_lo_export()
    • pg_setclientencoding() → pg_set_client_encoding()
    • pg_clientencoding() -> pg_client_encoding()

Standard Library

  • Sort comparison functions that return true or false will now throw a deprecation warning, and should be replaced with an implementation that returns an integer less than, equal to, or greater than zero.

    <?php
    // Replace
    usort($array, fn($a, $b) => $a > $b);
    // With
    usort($array, fn($a, $b) => $a <=> $b);
    ?>

Zip

  • Using an empty file as ZipArchive is deprecated. Libzip 1.6.0 does not accept empty files as valid zip archives any longer. The existing workaround will be removed in the next version.

  • The procedural API of Zip is deprecated. Use ZipArchive instead. Iteration over all entries can be accomplished using ZipArchive::statIndex() and a for loop:

    <?php
    // iterate using the procedural API
    assert(is_resource($zip));
    while (    $entry = zip_read($zip)) {
        echo     zip_entry_name($entry);
    }

    // iterate using the object-oriented API
    assert($zip instanceof ZipArchive);
    for (    $i = 0; $entry = $zip->statIndex($i); $i++) {
        echo     $entry['name'];
    }
    ?>

Reflection

  • ReflectionFunction::isDisabled() is deprecated, as it is no longer possible to create a ReflectionFunction for a disabled function. This method now always returns false.

  • ReflectionParameter::getClass(),
ReflectionParameter::isArray(), and
ReflectionParameter::isCallable() are deprecated.
ReflectionParameter::getType() and the
ReflectionType APIs should be used instead.


其他变更

SAPI 模块的变更

Apache2Handler

PHP 模块从 php7_module 重命名为 php_module。

Function 的变更

Reflection

可通过新参数 filter 来过滤 ReflectionClass::getConstants() 和 ReflectionClass::getReflectionConstants() 的返回结果。 新增三个常量，搭配使用：

  • ReflectionClassConstant::IS_PUBLIC
  • ReflectionClassConstant::IS_PROTECTED
  • ReflectionClassConstant::IS_PRIVATE

Zip

  • ZipArchive::addGlob() 和 ZipArchive::addPattern() 方法中 options 数组参数可接受更多的值：

    • flags
    • comp_method
    • comp_flags
    • env_method
    • enc_password

  • ZipArchive::addEmptyDir()、ZipArchive::addFile()、 ZipArchive::addFromString() 方法新增 flags 参数。 可用于名称编码 (ZipArchive::FL_ENC_*) 与条目（entry）替换 (ZipArchive::FL_OVERWRITE)。

  • ZipArchive::extractTo() 现在会储存文件的修改时间。

其他扩展变更

CURL

  • 现在 CURL 扩展要求 libcurl 版本至少为 7.29.0。

  • 移除了 curl_version() 废弃的参数 version。

日期/时间

现在 DatePeriod 实现（implements）了 IteratorAggregate (之前是 Traversable)。

DOM

现在 DOMNamedNodeMap 与 DOMNodeList 实现（implements）了 IteratorAggregate (之前是 Traversable)。

国际化

现在 IntlBreakIterator 与 ResourceBundle 实现（implements）了 IteratorAggregate (之前是 Traversable)。

Enchant

现在环境允许时，enchant 会默认使用 libenchant-2。 仍然支持 libenchant 1，但已经废弃，并将在未来移除。

GD

  • imagepolygon()、 imageopenpolygon()、imagefilledpolygon() 的参数 num_points 现在为可选参数。 这些函数可用三或四个参数去调用。 省略参数时，会按 count($points)/2 计算。

  • 新增函数 imagegetinterpolation()，可获取当前的插值（interpolation）。

JSON

现在无法禁用 JSON 扩展，将是任意 PHP 版本的内置功能，类似 date 扩展。

MBString

更新 Unicode 数据表版本到 13.0.0。

PDO

现在 PDOStatement 实现（implements）了 IteratorAggregate (之前是 Traversable)。

LibXML

现在要求 libxml 最小版本为 2.9.0。 这代表着确保了默认情况下禁用了外部实体加载（external entity loading）的功能。 无需额外步骤即可防范 XML 外部实体注入攻击（XXE attacks）。

MySQLi / PDO MySQL

  • 未使用 mysqlnd 时（也是默认且推荐的做法）， 支持的最小 libmysqlclient 版本为 5.5。

  • 现在 mysqli_result 实现（implements）了 IteratorAggregate (之前是 Traversable)。

PGSQL / PDO PGSQL

PGSQL 与 PDO PGSQL 扩展需要 libpq 的版本号至少为 9.1。

Readline

在交互提示开始之前调用 readline_completion_function() （例如在 auto_prepend_file 中）， 将重写默认的交互输入补全函数。 之前，只有交互提示（interactive prompt）开始后， readline_completion_function() 才会运行。

SimpleXML

现在 SimpleXMLElement 实现（implements）了 RecursiveIterator 并吸收了 SimpleXMLIterator 的功能。 SimpleXMLIterator 是 SimpleXMLElement 的一个空扩展。

INI 文件处理的变更

  • com.dotnet_version 是一个新的 INI 指令，用于选择 dotnet 对象的 .NET framework 版本。

  • zend.exception_string_param_max_len 是一个新的 INI 指令，用于设置字符串化的调用栈（stack strace）的最大字符串长度。

EBCDIC

不再支持 EBCDIC targets，虽然它不太可能还在当初的地方继续运行。

性能

  • opcache 扩展新增了即时编译(JIT) 支持。

  • array_slice() 用于没有空隙的数组时， 将不会扫描整个数组去查找开始的位移（offset）。 在 offset 较大、长度较小时，会显著减少函数的运行时间。

  • 当本地化 LC_CTYPE 为 "C" 时（也是默认值）， strtolower() 会使用 SIMD 的实现。


从 PHP 7.3.x 移植到 PHP 7.4.x

Table of Contents

  • 新特性
  • 新的类和接口
  • 新函数
  • 新的全局常量
  • 不向后兼容的变更
  • PHP 7.4.x 废弃的功能
  • 移除的扩展
  • 其他变更
  • Windows 支持

这个新的小版本带来了大量的 新特性 和 少量的兼容性调整 在生产环境切换 PHP 版本前应该进行相关测试。

参见 PHP 版本迁移指南 7.0.x， 7.1.x， 7.2.x 和 7.3.x。


新特性

PHP 核心中的新特性

属性添加限定类型

类的属性中现在支持添加指定的类型。

<?php
class User {
    public int $id;
    public string $name;
}
?>
上面的例子中，会强制要求 $user->id 只能为 int 类型，同时 $user->name 只能为 string 类型。

箭头函数

箭头函数 提供了一种更简洁的定义函数的方法。

<?php
$factor = 10;
$nums = array_map(fn($n) => $n * $factor, [1, 2, 3, 4]);
// $nums = array(10, 20, 30, 40);
?>

有限返回类型协变与参数类型逆变

以下代码将不会正常工作：

<?php
class A {}
class B extends A {}

class Producer {
    public function method(): A {}
}
class ChildProducer extends Producer {
    public function method(): B {}
}
?>
只有在使用自动加载的情况下，才会有完整的差异支持。在一个文件内，只有非循环类型引用是可能的，因为在引用之前，所有的类都需要可用。

空合并运算符赋值

<?php
$array['key'] ??= computeDefault();
// 等同于以下旧写法
if (!isset($array['key'])) {
    $array['key'] = computeDefault();
}
?>

数组展开操作

<?php
$parts = ['apple', 'pear'];
$fruits = ['banana', 'orange', ...$parts, 'watermelon'];
// ['banana', 'orange', 'apple', 'pear', 'watermelon'];
?>

数值文字分隔符

数字文字可以在数字之间包含下划线。

<?php
6.674_083e-11; // float
299_792_458;   // decimal
0xCAFE_F00D;   // hexadecimal
0b0101_1111;   // binary
?>

Weak references

Weak references allow the programmer to retain a reference to an object that does not prevent the object from being destroyed.

允许从 __toString() 抛出异常

现在允许从 __toString() 抛出异常。之前的版本，将会导致一个致命错误。新版本中，之前发生致命错误的代码，已经被转换为 Error 异常。

CURL

CURLFile now supports stream wrappers in addition to plain file names, if the extension has been built against libcurl >= 7.56.0.

Filter

The FILTER_VALIDATE_FLOAT filter now supports the min_range and max_range options, with the same semantics as FILTER_VALIDATE_INT.

FFI

FFI is a new extension, which provides a simple way to call native functions, access native variables, and create/access data structures defined in C libraries.

GD

Added the IMG_FILTER_SCATTER image filter to apply a scatter filter to images.

Hash

Added crc32c hash using Castagnoli's polynomial. This CRC32 variant is used by storage systems, such as iSCSI, SCTP, Btrfs and ext4.

Multibyte String

Added the mb_str_split() function, which provides the same functionality as str_split(), but operating on code points rather than bytes.

OPcache

新增 缓存预加载 特性。

Regular Expressions (Perl-Compatible)

The preg_replace_callback() and preg_replace_callback_array() functions now accept an additional flags argument, with support for the PREG_OFFSET_CAPTURE and PREG_UNMATCHED_AS_NULL flags. This influences the format of the matches array passed to to the callback function.

PDO

The username and password can now be specified as part of the PDO DSN for the mysql, mssql, sybase, dblib, firebird and oci drivers. Previously this was only supported by the pgsql driver. If a username/password is specified both in the constructor and the DSN, the constructor takes precedence.

It is now possible to escape question marks in SQL queries to avoid them being interpreted as parameter placeholders. Writing ?? allows sending a single question mark to the database and e.g. use the PostgreSQL JSON key exists (?) operator.

PDO_OCI

PDOStatement::getColumnMeta() is now available.

PDO_SQLite

PDOStatement::getAttribute(PDO::SQLITE_ATTR_READONLY_STATEMENT) allows checking whether the statement is read-only, i.e. if it doesn't modify the database.

PDO::setAttribute(PDO::SQLITE_ATTR_EXTENDED_RESULT_CODES, true) enables the use of SQLite3 extended result codes in PDO::errorInfo() and PDOStatement::errorInfo().

SQLite3

Added SQLite3::lastExtendedErrorCode() to fetch the last extended result code.

Added SQLite3::enableExtendedResultCodes($enable = true), which will make SQLite3::lastErrorCode() return extended result codes.

Standard

strip_tags() with array of tag names

strip_tags() now also accepts an array of allowed tags: instead of strip_tags($str, '<a><p>') you can now write strip_tags($str, ['a', 'p']).

Custom object serialization

A new mechanism for custom object serialization has been added, which uses two new magic methods: __serialize and __unserialize.

<?php
// Returns array containing all the necessary state of the object.
public function __serialize(): array;

// Restores the object state from the given data array.
public function __unserialize(array $data): void;
?>
The new serialization mechanism supersedes the Serializable interface, which will be deprecated in the future.

Array merge functions without arguments

array_merge() and array_merge_recursive() may now be called without any arguments, in which case they will return an empty array. This is useful in conjunction with the spread operator, e.g. array_merge(...$arrays).

proc_open() function

proc_open() now accepts an array instead of a string for the command. In this case the process will be opened directly (without going through a shell) and PHP will take care of any necessary argument escaping.

<?php
proc_open(['php', '-r', 'echo "Hello World\n";'], $descriptors, $pipes);
?>

proc_open() now supports redirect and null descriptors.

<?php
// Like 2>&1 on the shell
proc_open($cmd, [1 => ['pipe', 'w'], 2 => ['redirect', 1]], $pipes);
// Like 2>/dev/null or 2>nul on the shell
proc_open($cmd, [1 => ['pipe', 'w'], 2 => ['null']], $pipes);
?>

argon2i(d) without libargon

password_hash() now has the argon2i and argon2id implementations from the sodium extension when PHP is built without libargon.


  • ? 新特性
  • 新函数 ?
  • PHP Manual
  • 从 PHP 7.3.x 移植到 PHP 7.4.x
  • 新的类和接口

新的类和接口

Reflection

  • ReflectionReference


新函数

PHP 核心中新增的函数

  • get_mangled_object_vars()
  • password_algos()
  • sapi_windows_set_ctrl_handler()

GD

  • imagecreatefromtga()

OpenSSL

  • openssl_x509_verify()

Process Control

  • pcntl_unshare()

SQLite3

  • SQLite3::backup()
  • SQLite3Stmt::getSQL()


新的全局常量

PHP 核心中预定义的常量

  • PHP_WINDOWS_EVENT_CTRL_C
  • PHP_WINDOWS_EVENT_CTRL_BREAK

Multibyte String

  • MB_ONIGURUMA_VERSION

Sockets

添加了 FreeBSD 系统中特有的选项：

  • SO_LABEL
  • SO_PEERLABEL
  • SO_LISTENQLIMIT
  • SO_LISTENQLEN
  • SO_USER_COOKIE

Tidy

  • TIDY_TAG_ARTICLE
  • TIDY_TAG_ASIDE
  • TIDY_TAG_AUDIO
  • TIDY_TAG_BDI
  • TIDY_TAG_CANVAS
  • TIDY_TAG_COMMAND
  • TIDY_TAG_DATALIST
  • TIDY_TAG_DETAILS
  • TIDY_TAG_DIALOG
  • TIDY_TAG_FIGCAPTION
  • TIDY_TAG_FIGURE
  • TIDY_TAG_FOOTER
  • TIDY_TAG_HEADER
  • TIDY_TAG_HGROUP
  • TIDY_TAG_MAIN
  • TIDY_TAG_MARK
  • TIDY_TAG_MENUITEM
  • TIDY_TAG_METER
  • TIDY_TAG_NAV
  • TIDY_TAG_OUTPUT
  • TIDY_TAG_PROGRESS
  • TIDY_TAG_SECTION
  • TIDY_TAG_SOURCE
  • TIDY_TAG_SUMMARY
  • TIDY_TAG_TEMPLATE
  • TIDY_TAG_TIME
  • TIDY_TAG_TRACK
  • TIDY_TAG_VIDEO


不向后兼容的变更

PHP 核心中不向后兼容的变更

以数组形式访问非数组

尝试以数组方式访问 null，bool， int，float 或 resource （例如 $null["key"]）将会抛出 notice 通知。

get_declared_classes() 函数

get_declared_classes() 函数将不再返回匿名的类，假如它们没有被实例化的话。

fn 关键词

fn 成为了保留关键词。需要特别注意，它不能再做为函数名或类名使用，但是仍然可以做为方法名和常量名存在。

文件尾部的 <?php 标签

文件尾部的 <?php 标签（不包含空行）将会被解释成一个 PHP 头标签。Previously it was interpreted either as a short opening tag followed by literal php and resulted in a syntax error (with short_open_tag=1) or was interpreted as a literal <?php string (with short_open_tag=0).

Stream wrappers

When using include/require on a stream, streamWrapper::stream_set_option() will be invoked with the STREAM_OPTION_READ_BUFFER option. Custom stream wrapper implementations may need to implement the streamWrapper::stream_set_option() method to avoid a warning (always returning false is a sufficient implementation).

Serialization 序列化

序列化类型 o 被移除。因为它不是由 PHP 生成的，这可能会影响到之前项目中手动生成的序列化字符串。

密码算法常量

密码哈希算法标识符现在是可空字符串，而不再是整数。

  • PASSWORD_DEFAULT 之前是 int 1; 现在是 null
  • PASSWORD_BCRYPT 之前是 int 1; 现在是 string '2y'
  • PASSWORD_ARGON2I 之前是 int 2; 现在是 string 'argon2i'
  • PASSWORD_ARGON2ID 之前是 int 3; 现在是 string 'argon2id'

应用中如果正常使用了常量 PASSWORD_DEFAULT，PASSWORD_BCRYPT，PASSWORD_ARGON2I 和 PASSWORD_ARGON2ID 将不会受到影响。

htmlentities() 函数

htmlentities() will now raise a notice (instead of a strict standards warning) if it is used with an encoding for which only basic entity substitution is supported, in which case it is equivalent to htmlspecialchars().

fread() and fwrite() 函数

fread() 和 fwrite() 在操作失败的时候会返回 false。之前的版本中会返回空字符串或 0。EAGAIN/EWOULDBLOCK 不视为故障。

这些函数现在也会在失败时发出 NOTICE 通知，例如当试图写入一个只读文件资源时。

BCMath Arbitrary Precision Mathematics

BCMath functions will now warn if a non well-formed number is passed, such as "32foo". The argument will be interpreted as zero, as before.

CURL

Attempting to serialize a CURLFile class will now generate an exception. Previously the exception was only thrown on unserialization.

Using CURLPIPE_HTTP1 is deprecated, and is no longer supported as of cURL 7.62.0.

The $version parameter of curl_version() is deprecated. If any value not equal to the default CURLVERSION_NOW is passed, a warning is raised and the parameter is ignored.

Date and Time

Calling var_dump() or similar on a DateTime or DateTimeImmutable instance will no longer leave behind accessible properties on the object.

Comparison of DateInterval objects (using ==, <, and so on) will now generate a warning and always return false. Previously all DateInterval objects were considered equal, unless they had properties.

Intl

The default parameter value of idn_to_ascii() and idn_to_utf8() is now INTL_IDNA_VARIANT_UTS46 instead of the deprecated INTL_IDNA_VARIANT_2003.

MySQLi

The embedded server functionality has been removed. It was broken since at least PHP 7.0.

The undocumented mysqli::$stat property has been removed in favor of mysqli::stat().

OpenSSL

The openssl_random_pseudo_bytes() function will now throw an exception in error situations, similar to random_bytes(). In particular, an Error is thrown if the number of requested bytes is less than or equal to zero, and an Exception is thrown if sufficient randomness cannot be gathered. The $crypto_strong output argument is guaranteed to always be true if the function does not throw, so explicitly checking it is not necessary.

Regular Expressions (Perl-Compatible)

When PREG_UNMATCHED_AS_NULL mode is used, trailing unmatched capturing groups will now also be set to null (or [null, -1] if offset capture is enabled). This means that the size of the $matches will always be the same.

PHP Data Objects

Attempting to serialize a PDO or PDOStatement instance will now generate an Exception rather than a PDOException, consistent with other internal classes which do not support serialization.

Reflection

Reflection objects will now generate an exception if an attempt is made to serialize them. Serialization for reflection objects was never supported and resulted in corrupted reflection objects. It has been explicitly prohibited now.

Standard PHP Library (SPL)

Calling get_object_vars() on an ArrayObject instance will now always return the properties of the ArrayObject itself (or a subclass). Previously it returned the values of the wrapped array/object unless the ArrayObject::STD_PROP_LIST flag was specified.

Other affected operations are:

  • ReflectionObject::getProperties()
  • reset(), current(), etc. Use Iterator methods instead.
  • Potentially others working on object properties as a list.

(array) casts are not affected. They will continue to return either the wrapped array, or the ArrayObject properties, depending on whether the ArrayObject::STD_PROP_LIST flag is used.

SplPriorityQueue::setExtractFlags() will throw an exception if zero is passed. Previously this would generate a recoverable fatal error on the next extraction operation.

ArrayObject, ArrayIterator, SplDoublyLinkedList and SplObjectStorage now support the __serialize() and __unserialize() mechanism in addition to the Serializable interface. This means that serialization payloads created on older PHP versions can still be unserialized, but new payloads created by PHP 7.4 will not be understood by older versions.

Tokenizer

token_get_all() will now emit a T_BAD_CHARACTER token for unexpected characters instead of leaving behind holes in the token stream.

接收到的 Cookies

从 PHP 7.4.11 开始，为了安全考虑，接受到的 Cookie 中的 names 参数不再被 URL 编码。


PHP 7.4.x 废弃的功能

PHP 核心中废弃的功能

没有显式括号的嵌套三元运算符

嵌套的三元操作中，必须明确使用显式括号来决定操作的顺序。以前，如果不使用括号，在大多数情况下，左关联性不会导致预期的行为。

<?php
1 ? 2 : 3 ? 4 : 5;   // deprecated
(1 ? 2 : 3) ? 4 : 5; // ok
1 ? 2 : (3 ? 4 : 5); // ok
?>

大括号访问数组和字符串索引

使用大括号访问数组及字符串索引的方式已被废弃。请使用 $var[$idx] 的语法来替代 $var{$idx}。

(real) 类型和 is_real() 函数

(real) 类型已被废弃，请使用 (float) 来替代。

同时被废弃的还有 is_real() 函数，请使用 is_float() 来替代。

Unbinding $this when $this is used

Unbinding $this of a non-static closure that uses $this is deprecated.

parent 关键词在没父类的类中使用

在没有父类的类中使用 parent 关键词已被废弃，并且在将来的 PHP 版本中将会抛出一个编译错误。目前只在运行时访问父类时才会产生错误。

allow_url_include INI 选项

配置文件中的 allow_url_include 选项被废弃。如果启用了该选项，将会产生一个弃用通知。

基础转换函数中的无效字符处理

在下面这些基础转换函数中，base_convert(),
bindec(), octdec() 和
hexdec()
如果传入了非法字符，将会抛出一个弃用通知。函数会忽略掉无效字符后正常返回结果。前导空格和尾部空格，以及类型为
0x (取决于基数) 被允许传入。

在对象中使用 array_key_exists()

在一个对象中使用 array_key_exists() 已被废弃。请使用 isset() 或 property_exists() 来替代。

魔术引号函数

魔术引号函数 get_magic_quotes_gpc() 和 get_magic_quotes_runtime() 已被废弃。它们将永远返回 false。

hebrevc() 函数

hebrevc() 函数已被废弃。 可以用 nl2br(hebrev($str)) 来替代，更好的方法是启用 Unicode RTL 来支持。

convert_cyr_string() 函数

convert_cyr_string() 函数已被废弃。可以用 mb_convert_string()， iconv() 或 UConverter 替代。

money_format() 函数

money_format() 函数已被废弃。 可以用更国际化的 NumberFormatter 功能来替代。

ezmlm_hash() 函数

ezmlm_hash() 函数已被废弃。

restore_include_path() 函数

restore_include_path() 函数已被废弃。可以用 ini_restore('include_path') 替代。

Implode 函数的参数顺序

implode() 允许反转参数顺序的特性已被废弃，请使用 implode($glue, $parts) 来替代 implode($parts, $glue)。

COM

导入类型库的大小写不敏感的常量注册已被废弃。

Filter

FILTER_SANITIZE_MAGIC_QUOTES 已被废弃，使用 FILTER_SANITIZE_ADD_SLASHES 来替代。

Multibyte String

Passing a non-string pattern to mb_ereg_replace() is deprecated. Currently, non-string patterns are interpreted as ASCII codepoints. In PHP 8, the pattern will be interpreted as a string instead.

Passing the encoding as 3rd parameter to mb_strrpos() is deprecated. Instead pass a 0 offset, and encoding as 4th parameter.

Lightweight Directory Access Protocol

ldap_control_paged_result_response() 和
ldap_control_paged_result() 函数已被废弃。控制页面操作可以使用
ldap_search() 替代。

Reflection

调用 ReflectionType::__toString() 现在将会抛出一个弃用通知。 该方法从 PHP 7.1 开始，在 ReflectionNamedType::getName() 的文档中已经被声明废弃，但是由于技术原因，并没有抛出弃用通知。

The export() methods on all Reflection classes are deprecated. Construct a Reflection object and convert it to string instead:

<?php
// ReflectionClass::export(Foo::class, false) is:
echo new ReflectionClass(Foo::class), "\n";

// $str = ReflectionClass::export(Foo::class, true) is:
$str = (string) new ReflectionClass(Foo::class);
?>

Socket

常量 AI_IDN_ALLOW_UNASSIGNED 和 AI_IDN_USE_STD3_ASCII_RULES 在 socket_addrinfo_lookup() 中不再可用，因为该常量在 glibc 中已被废弃。


移除的扩展

这些扩展已经被转移到 PECL 中，不再是 PHP 发行版的一部分。这些扩展的 PECL 包版本将根据用户的需要来自行安装。

  • Firebird/Interbase - access to an InterBase and/or Firebird based database is still available with the PDO Firebird driver.
  • Recode
  • WDDX


其他变更

性能提升

PHP 核心

为 array_key_exists() 函数添加了一个专门的 VM opcache 优化，如果该函数可以被静态解析，则可以提高该函数的性能。如果你在项目中使用了命名空间，可能会需要使用 \array_key_exists() 来显性的导入该函数。

正则表达式 (Perl-Compatible)

When preg_match() in UTF-8 mode ("u" modifier) is repeatedly called on the same string (but possibly different offsets), it will only be checked for UTF-8 validity once.

INI 配置文件处理的变化

zend.exception_ignore_args is a new INI directive for including or excluding arguments from stack traces generated from exceptions.

opcache.preload_user is a new INI directive for specifying the user account under which preloading code is execute if it would otherwise be run as root (which is not allowed for security reasons).

迁移到 pkg-config

一些扩展已经迁移到只使用 pkg-config 来检测库的依赖性。一般来说，这意味着不再用 --with-foo-dir=DIR 或类似的参数，而是使用 --with-foo。自定义库的路径可以通过向 PKG_CONFIG_PATH 添加额外的目录，或通过 FOO_CFLAGS 和 FOO_LIBS 来明确指定。

以下扩展和 SAPI 会受到影响：

  • CURL:
    • --with-curl 选项不再接受一个目录。
  • Enchant:
    • --with-enchant 选项不再接受一个目录。
  • FPM:
    • --with-fpm-systemd now uses only pkg-config for libsystem checks. The libsystemd minimum required version is 209.
  • GD:
    • --with-gd 改变为 --enable-gd (whether to enable the extension at all) 和 --with-external-gd (to opt into using an external libgd, rather than the bundled one).
    • --with-png-dir 参数被移除。需要 libpng 支持。
    • --with-zlib-dir 参数被移除。需要 zlib 支持。
    • --with-freetype-dir 改变为 --with-freetype
    • --with-jpeg-dir 改变为 --with-jpeg
    • --with-webp-dir 改变为 --with-webp
    • --with-xpm-dir 改变为 --with-xpm
  • IMAP:
    • --with-kerberos-systemd 选项不再接受一个目录。
  • Intl:
    • --with-icu-dir 被移除。如果使用了 --enable-intl 参数，需要 libicu 支持。
  • LDAP:
    • --with-ldap-sasl 选项不再接受一个目录。
  • Libxml:
    • --with-libxml-dir 被移除。
    • --enable-libxml 改变为 --with-libxml。
    • --with-libexpat-dir 被重命名为 --with-expat 并且该选项不再接受一个目录。
  • Litespeed:
    • --with-litespeed 改变为 --enable-litespeed。
  • Mbstring:
    • --with-onig 被移除。如果指定了 --disable-mbregex 参数，则需要 libonig 支持。
  • ODBC:
    • --with-iodbc 选项不再接受一个目录。
    • --with-unixODBC without a directory now uses pkg-config (preferred). Directory is still accepted for old versions without libodbc.pc.
  • OpenSSL:
    • --with-openssl 选项不再接受一个目录。
  • PCRE:
    • --with-pcre-regex 被移除。Instead --with-external-pcre is provided to opt into using an external PCRE library, rather than the bundled one.
  • PDO_SQLite:
    • --with-pdo-sqlite 选项不再接受一个目录。
  • Readline:
    • --with-libedit 选项不再接受一个目录。
  • Sodium:
    • --with-sodium 选项不再接受一个目录。
  • SQLite3:
    • --with-sqlite3 选项不再接受一个目录。
  • XSL:
    • --with-xsl 选项不再接受一个目录。
  • Zip:
    • --with-libzip 被移除。
    • --enable-zip 改变为 --with-zip。

CSV escaping

fputcsv(),
fgetcsv(),
SplFileObject::fputcsv(),
SplFileObject::fgetcsv(), and
SplFileObject::setCsvControl()
now accept an empty string as $escape argument,
which disables the proprietary PHP escaping mechanism.

The behavior of str_getcsv() has been adjusted accordingly (formerly, an empty string was identical to using the default).

SplFileObject::getCsvControl() now may also return an empty string for the third array element, accordingly.

Data Filtering

The filter extension no longer exposes --with-pcre-dir for Unix builds and can now reliably be built as shared when using ./configure

GD

The behavior of imagecropauto() in the bundled libgd has been synced with that of system libgd:

  • IMG_CROP_DEFAULT is no longer falling back to IMG_CROP_SIDES
  • Threshold-cropping now uses the algorithm of system libgd

The default $mode parameter of imagecropauto() has been changed to IMG_CROP_DEFAULT; passing -1 is now deprecated.

imagescale() now supports aspect ratio preserving scaling to a fixed height by passing -1 as $new_width.

HASH Message Digest Framework

The hash extension cannot be disabled anymore and is always an integral part of any PHP build, similar to the date extension.

Intl

The intl extension now requires at least ICU 50.1.

ResourceBundle now implements Countable.

Lightweight Directory Access Protocol

Support for nsldap and umich_ldap has been removed.

Libxml

All libxml-based extensions now require libxml 2.7.6 or newer.

Multibyte String

The oniguruma library is no longer bundled with PHP, instead libonig needs to be available on the system. Alternatively --disable-mbregex can be used to disable the mbregex component.

OPcache

The --disable-opcache-file and --enable-opcache-file configure options have been removed in favor of the opcache.file_cache INI directive.

Password Hashing

The password_hash() and functions now accept nullable string and int for $algo argument.

PEAR

Installation of PEAR (including PECL) is no longer enabled by default. It can be explicitly enabled using --with-pear. This option is deprecated and may be removed in the future.

Reflection

The numeric values of the modifier constants (IS_ABSTRACT, IS_DEPRECATED, IS_EXPLICIT_ABSTRACT, IS_FINAL, IS_IMPLICIT_ABSTRACT, IS_PRIVATE, IS_PROTECTED, IS_PUBLIC, and IS_STATIC) on the ReflectionClass, ReflectionFunction, ReflectionMethod, ReflectionObject, and ReflectionProperty classes have changed.

SimpleXML

SimpleXMLElement now implements Countable.

SQLite3

The bundled libsqlite has been removed. To build the SQLite3 extension a system libsqlite3 ≥ 3.7.4 is now required. To build the PDO_SQLite extension a system libsqlite3 ≥ 3.5.0 is now required.

Serialization and unserialization of SQLite3, SQLite3Stmt and SQLite3Result is now explicitly forbidden. Formerly, serialization of instances of these classes was possible, but unserialization yielded unusable objects.

The @param notation can now also be used to denote SQL query parameters.

Zip

The bundled libzip library has been removed. A system libzip >= 0.11 is now necessary to build the zip extension.


Windows 支持

configure flags

configure 命令现在支持 CFLAGS 和 LDFLAGS 环境变量。

CTRL handling

CTRL+C and CTRL+BREAK on console can be caught by setting a handler function with sapi_windows_set_ctrl_handler().

proc_open() on Windows can be passed a "create_process_group" option. It is required if the child process is supposed to handle CTRL events.

OPcache

OPcache now supports an arbitrary number of separate caches per user via the the INI directive opcache.cache_id. All processes with the same cache ID and user share an OPcache instance.

stat

The stat implementation has been refactored.

  • An inode number is delivered and is based on the NTFS file index.
  • The device number is now based on the volume serial number.

Note that both values are derived from the system and provided as-is on 64-bit systems. On 32-bit systems, these values might overflow the 32-bit integer in PHP, so they're fake.

libsqlite3

libsqlite3 is no longer compiled statically into php_sqlite3.dll and php_pdo_sqlite.dll, but rather available as libsqlite3.dll. Refer to the installation instructions for SQLite3 and PDO_SQLITE, respectively.


从 PHP 7.2.x 移植到 PHP 7.3.x

Table of Contents

  • 新特性
  • 新函数
  • 新的全局常量
  • 不向下兼容的变更
  • PHP 7.3.x 中废弃的功能
  • 其它变更
  • Windows 支持

这个新的小版本带来了大量的 新特性和 少量的兼容性调整 在生产环境切换 PHP 版本前应该进行相关测试。

参见 PHP 版本迁移指南 7.0.x、 7.1.x、 7.2.x。


新特性

PHP 核心

更灵活的 Heredoc 和 Nowdoc 语法

Heredoc 和 Nowdoc 语法变的更灵活。现在支持闭合标记符的缩进，并且不再强制闭合标记符的换行。

Array Destructuring supports Reference Assignments

Array destructuring now supports reference assignments using the syntax [&$a, [$b, &$c]] = $d. The same is also supported for list().

Instanceof Operator accepts Literals

instanceof now allows literals as the first operand, in which case the result is always false.

CompileError Exception instead of some Compilation Errors

A new CompileError exception has been added, from which ParseError inherits. A small number of compilation errors will now throw a CompileError instead of generating a fatal error. Currently this only affects compilation errors that may be thrown by token_get_all() in TOKEN_PARSE mode, but more errors may be converted in the future.

Trailing Commas are allowed in Calls

Trailing commas in function and method calls are now allowed.

Argon2id Support

The --with-password-argon2[=dir] configure argument now provides support for both Argon2i and Argon2id hashes in the password_hash(), password_verify(), password_get_info(), and password_needs_rehash() functions. Passwords may be hashed and verified using the PASSWORD_ARGON2ID constant. Support for both Argon2i and Argon2id in the password_*() functions now requires PHP be linked against libargon2 reference library ≥ 20161029.

FastCGI Process Manager

New options have been added to customize the FPM logging:

log_limit
This global option can be used for setting the log limit for the logged line which allows to log messages longer than 1024 characters without wrapping. It also fixes various wrapping issues.
log_buffering
This global option allows an experimental logging without extra buffering.
decorate_workers_output
This pool option allows to disable the output decoration for workers output when catch_workers_output is enabled.

BC Math Functions

bcscale() can now also be used as getter to retrieve the current scale in use.

Lightweight Directory Access Protocol

Full support for LDAP Controls has been added to the LDAP querying functions and ldap_parse_result():

  • A $serverctrls parameter to send controls to the
server in ldap_add(),
ldap_mod_replace(), ldap_mod_add(),
ldap_mod_del(), ldap_rename(),
ldap_compare(), ldap_delete(),
ldap_modify_batch(),
ldap_search(), ldap_list() and
ldap_read() has been added.
  • The out parameter $serverctrls to get controls from the server in ldap_parse_result() has been added.
  • Support for LDAP_OPT_SERVER_CONTROLS and LDAP_OPT_CLIENT_CONTROLS in ldap_get_option() and ldap_set_option() has been fixed.

Multibyte String Functions

Full Case-Mapping and Case-Folding Support

Support for full case-mapping and case-folding has been added. Unlike simple case-mapping, full case-mapping may change the length of the string. For example:

<?php
mb_strtoupper("Stra?e");
// Produces STRA?E on PHP 7.2
// Produces STRASSE on PHP 7.3
?>
The different casing mapping and folding modes are available through mb_convert_case():
  • MB_CASE_LOWER (used by mb_strtolower())
  • MB_CASE_UPPER (used by mb_strtoupper())
  • MB_CASE_TITLE
  • MB_CASE_FOLD
  • MB_CASE_LOWER_SIMPLE
  • MB_CASE_UPPER_SIMPLE
  • MB_CASE_TITLE_SIMPLE
  • MB_CASE_FOLD_SIMPLE (used by case-insensitive operations)
Only unconditional, language agnostic full case-mapping is performed.

Case-Insensitive String Operations use Case-Folding

Case-insensitive string operations now use case-folding instead of case- mapping during comparisons. This means that more characters will be considered (case insensitively) equal now.

MB_CASE_TITLE performs Title-Case Conversion

mb_convert_case() with MB_CASE_TITLE now performs title-case conversion based on the Cased and CaseIgnorable derived Unicode properties. In particular this also improves handling of quotes and apostrophes.

Unicode 11 Support

The Multibyte String data tables have been updated for Unicode 11.

Long String Support

The Multibyte String Functions now correctly support strings larger than 2GB.

Performance Improvements

Performance of the Multibyte String extension has been significantly improved across the board. The largest improvements are in case conversion functions.

Named Captures Support

The mb_ereg_* functions now support named captures. Matching functions like mb_ereg() will now return named captures both using their group number and their name, similar to PCRE:

<?php
mb_ereg('(?<word>\w+)', '国', $matches);
// => [0 => "国", 1 => "国", "word" => "国"];
?>
Additionally, mb_ereg_replace() now supports the \k<> and \k'' notations to reference named captures in the replacement string:
<?php
mb_ereg_replace('\s*(?<word>\w+)\s*', "_\k<word>_\k'word'_", ' foo ');
// => "_foo_foo_"
?>
\k<> and \k'' can also be used for numbered references, which also works with group numbers greater than 9.

Readline

Support for the completion_append_character and completion_suppress_append options has been added to readline_info(). These options are only available if PHP is linked against libreadline (rather than libedit).


新函数

PHP 内核

  • array_key_first()
  • array_key_last()
  • gc_status()
  • hrtime()
  • is_countable()
  • net_get_interfaces()

FastCGI 进程管理器

  • fpm_get_status()

Date and Time

  • DateTime::createFromImmutable()

GNU Multiple Precision

  • gmp_binomial()
  • gmp_kronecker()
  • gmp_lcm()
  • gmp_perfect_power()

国际化相关函数

  • Normalizer::getRawDecomposition()
  • normalizer_get_raw_decomposition()
  • Spoofchecker::setRestrictionLevel()

Lightweight Directory Access Protocol

  • ldap_add_ext()
  • ldap_bind_ext()
  • ldap_delete_ext()
  • ldap_exop_refresh()
  • ldap_mod_add_ext()
  • ldap_mod_replace_ext()
  • ldap_mod_del_ext()
  • ldap_rename_ext()

OpenSSL

  • openssl_pkey_derive()

Sockets

  • socket_wsaprotocol_info_export()
  • socket_wsaprotocol_info_import()
  • socket_wsaprotocol_info_release()


新的全局常量

PHP 核心中预定义的常量

  • PASSWORD_ARGON2ID

Client URL Library

  • CURLAUTH_BEARER
  • CURLAUTH_GSSAPI
  • CURLE_WEIRD_SERVER_REPLY
  • CURLINFO_APPCONNECT_TIME_T
  • CURLINFO_CONNECT_TIME_T
  • CURLINFO_CONTENT_LENGTH_DOWNLOAD_T
  • CURLINFO_CONTENT_LENGTH_UPLOAD_T
  • CURLINFO_FILETIME_T
  • CURLINFO_HTTP_VERSION
  • CURLINFO_NAMELOOKUP_TIME_T
  • CURLINFO_PRETRANSFER_TIME_T
  • CURLINFO_PROTOCOL
  • CURLINFO_PROXY_SSL_VERIFYRESULT
  • CURLINFO_REDIRECT_TIME_T
  • CURLINFO_SCHEME
  • CURLINFO_SIZE_DOWNLOAD_T
  • CURLINFO_SIZE_UPLOAD_T
  • CURLINFO_SPEED_DOWNLOAD_T
  • CURLINFO_SPEED_UPLOAD_T
  • CURLINFO_STARTTRANSFER_TIME_T
  • CURLINFO_TOTAL_TIME_T
  • CURL_LOCK_DATA_CONNECT
  • CURL_LOCK_DATA_PSL
  • CURL_MAX_READ_SIZE
  • CURLOPT_ABSTRACT_UNIX_SOCKET
  • CURLOPT_DISALLOW_USERNAME_IN_URL
  • CURLOPT_DNS_SHUFFLE_ADDRESSES
  • CURLOPT_HAPPY_EYEBALLS_TIMEOUT_MS
  • CURLOPT_HAPROXYPROTOCOL
  • CURLOPT_KEEP_SENDING_ON_ERROR
  • CURLOPT_PRE_PROXY
  • CURLOPT_PROXY_CAINFO
  • CURLOPT_PROXY_CAPATH
  • CURLOPT_PROXY_CRLFILE
  • CURLOPT_PROXY_KEYPASSWD
  • CURLOPT_PROXY_PINNEDPUBLICKEY
  • CURLOPT_PROXY_SSLCERT
  • CURLOPT_PROXY_SSLCERTTYPE
  • CURLOPT_PROXY_SSL_CIPHER_LIST
  • CURLOPT_PROXY_SSLKEY
  • CURLOPT_PROXY_SSLKEYTYPE
  • CURLOPT_PROXY_SSL_OPTIONS
  • CURLOPT_PROXY_SSL_VERIFYHOST
  • CURLOPT_PROXY_SSL_VERIFYPEER
  • CURLOPT_PROXY_SSLVERSION
  • CURLOPT_PROXY_TLS13_CIPHERS
  • CURLOPT_PROXY_TLSAUTH_PASSWORD
  • CURLOPT_PROXY_TLSAUTH_TYPE
  • CURLOPT_PROXY_TLSAUTH_USERNAME
  • CURLOPT_REQUEST_TARGET
  • CURLOPT_SOCKS5_AUTH
  • CURLOPT_SSH_COMPRESSION
  • CURLOPT_SUPPRESS_CONNECT_HEADERS
  • CURLOPT_TIMEVALUE_LARGE
  • CURLOPT_TLS13_CIPHERS
  • CURLPROXY_HTTPS
  • CURLSSH_AUTH_GSSAPI
  • CURL_SSLVERSION_MAX_DEFAULT
  • CURL_SSLVERSION_MAX_NONE
  • CURL_SSLVERSION_MAX_TLSv1_0
  • CURL_SSLVERSION_MAX_TLSv1_1
  • CURL_SSLVERSION_MAX_TLSv1_2
  • CURL_SSLVERSION_MAX_TLSv1_3
  • CURL_SSLVERSION_TLSv1_3
  • CURL_VERSION_ALTSVC (as of PHP 7.3.6)
  • CURL_VERSION_ASYNCHDNS
  • CURL_VERSION_BROTLI
  • CURL_VERSION_CONV
  • CURL_VERSION_CURLDEBUG (as of PHP 7.3.6)
  • CURL_VERSION_DEBUG
  • CURL_VERSION_GSSAPI
  • CURL_VERSION_GSSNEGOTIATE
  • CURL_VERSION_HTTPS_PROXY
  • CURL_VERSION_IDN
  • CURL_VERSION_LARGEFILE
  • CURL_VERSION_MULTI_SSL
  • CURL_VERSION_NTLM
  • CURL_VERSION_NTLM_WB
  • CURL_VERSION_PSL (as of PHP 7.3.6)
  • CURL_VERSION_SPNEGO
  • CURL_VERSION_SSPI
  • CURL_VERSION_TLSAUTH_SRP

Data Filtering

  • FILTER_SANITIZE_ADD_SLASHES

JavaScript Object Notation

  • JSON_THROW_ON_ERROR

Lightweight Directory Access Protocol

  • LDAP_CONTROL_ASSERT
  • LDAP_CONTROL_MANAGEDSAIT
  • LDAP_CONTROL_PROXY_AUTHZ
  • LDAP_CONTROL_SUBENTRIES
  • LDAP_CONTROL_VALUESRETURNFILTER
  • LDAP_CONTROL_PRE_READ
  • LDAP_CONTROL_POST_READ
  • LDAP_CONTROL_SORTREQUEST
  • LDAP_CONTROL_SORTRESPONSE
  • LDAP_CONTROL_PAGEDRESULTS
  • LDAP_CONTROL_AUTHZID_REQUEST
  • LDAP_CONTROL_AUTHZID_RESPONSE
  • LDAP_CONTROL_SYNC
  • LDAP_CONTROL_SYNC_STATE
  • LDAP_CONTROL_SYNC_DONE
  • LDAP_CONTROL_DONTUSECOPY
  • LDAP_CONTROL_PASSWORDPOLICYREQUEST
  • LDAP_CONTROL_PASSWORDPOLICYRESPONSE
  • LDAP_CONTROL_X_INCREMENTAL_VALUES
  • LDAP_CONTROL_X_DOMAIN_SCOPE
  • LDAP_CONTROL_X_PERMISSIVE_MODIFY
  • LDAP_CONTROL_X_SEARCH_OPTIONS
  • LDAP_CONTROL_X_TREE_DELETE
  • LDAP_CONTROL_X_EXTENDED_DN
  • LDAP_CONTROL_VLVREQUEST
  • LDAP_CONTROL_VLVRESPONSE

Multibyte String

  • MB_CASE_FOLD
  • MB_CASE_LOWER_SIMPLE
  • MB_CASE_UPPER_SIMPLE
  • MB_CASE_TITLE_SIMPLE
  • MB_CASE_FOLD_SIMPLE

OpenSSL

  • STREAM_CRYPTO_PROTO_SSLv3
  • STREAM_CRYPTO_PROTO_TLSv1_0
  • STREAM_CRYPTO_PROTO_TLSv1_1
  • STREAM_CRYPTO_PROTO_TLSv1_2

PostgreSQL

  • PGSQL_DIAG_SCHEMA_NAME
  • PGSQL_DIAG_TABLE_NAME
  • PGSQL_DIAG_COLUMN_NAME
  • PGSQL_DIAG_DATATYPE_NAME
  • PGSQL_DIAG_CONSTRAINT_NAME
  • PGSQL_DIAG_SEVERITY_NONLOCALIZED


不向下兼容的变更

PHP 核心

Heredoc/Nowdoc Ending Label Interpretation

Due to the introduction of flexible heredoc/nowdoc syntax, doc strings that contain the ending label inside their body may cause syntax errors or change in interpretation. For example in:

<?php
$str = <<<FOO
abcdefg
   FOO
FOO;
?>
the indented occurrence of FOO did not previously have any special meaning. Now it will be interpreted as the end of the heredoc string and the following FOO; will cause a syntax error. This issue can always be resolved by choosing an ending label that does not occur within the contents of the string.

Continue Targeting Switch issues Warning

continue statements targeting switch control flow structures will now generate a warning. In PHP such continue statements are equivalent to break, while they behave as continue 2 in other languages.

<?php
while ($foo) {
    switch ($bar) {
      case "baz":
         continue;
         // Warning: "continue" targeting switch is equivalent to
         //          "break". Did you mean to use "continue 2"?
   }
}
?>

Strict Interpretation of Integer String Keys on ArrayAccess

Array accesses of type $obj["123"], where $obj implements ArrayAccess and "123" is an integer string literal will no longer result in an implicit conversion to integer, i.e., $obj->offsetGet("123") will be called instead of $obj->offsetGet(123). This matches existing behavior for non-literals. The behavior of arrays is not affected in any way, they continue to implicitly convert integral string keys to integers.

Static Properties no longer separated by Reference Assignment

In PHP, static properties are shared between inheriting classes, unless the static property is explicitly overridden in a child class. However, due to an implementation artifact it was possible to separate the static properties by assigning a reference. This loophole has been fixed.

<?php
class Test {
    public static $x = 0;
}
class Test2 extends Test { }

Test2::$x = &$x;
$x = 1;

var_dump(Test::$x, Test2::$x);
// Previously: int(0), int(1)
// Now:        int(1), int(1)
?>

References returned by Array and Property Accesses are immediately unwrapped

References returned by array and property accesses are now unwrapped as part of the access. This means that it is no longer possible to modify the reference between the access and the use of the accessed value:

<?php
$arr = [1];
$ref =& $arr[0];
var_dump($arr[0] + ($arr[0] = 2));
// Previously: int(4), Now: int(3)
?>
This makes the behavior of references and non-references consistent. Please note that reading and writing a value inside a single expression remains undefined behavior and may change again in the future.

Argument Unpacking of Traversables with non-Integer Keys no longer supported

Argument unpacking stopped working with Traversables with non-integer keys. The following code worked in PHP 5.6-7.2 by accident.

<?php
function foo(...$args) {
    var_dump($args);
}
function gen() {
    yield 1.23 => 123;
}
foo(...gen());
?>

Miscellaneous

The ext_skel utility has been completely redesigned with new options and some old options removed. This is now written in PHP and has no external dependencies.

Support for BeOS has been dropped.

Exceptions thrown due to automatic conversion of warnings into exceptions in EH_THROW mode (e.g. some DateTime exceptions) no longer populate error_get_last() state. As such, they now work the same way as manually thrown exceptions.

TypeError now reports wrong types as int and bool instead of integer and boolean, respectively.

Undefined variables passed to compact() will now be reported as a notice.

getimagesize() and related functions now report the mime type of BMP images as image/bmp instead of image/x-ms-bmp, since the former has been registered with the IANA (see » RFC 7903).

stream_socket_get_name() will now return IPv6 addresses wrapped in brackets. For example "[::1]:1337" will be returned instead of "::1:1337".

BCMath Arbitrary Precision Mathematics

All warnings thrown by BCMath functions are now using PHP's error handling. Formerly some warnings have directly been written to stderr.

bcmul() and bcpow() now return numbers with the requested scale. Formerly, the returned numbers may have omitted trailing decimal zeroes.

IMAP, POP3 and NNTP

rsh/ssh logins are disabled by default. Use imap.enable_insecure_rsh if you want to enable them. Note that the IMAP library does not filter mailbox names before passing them to the rsh/ssh command, thus passing untrusted data to this function with rsh/ssh enabled is insecure.

Multibyte String

Due to added support for named captures, mb_ereg_*() patterns using named captures will behave differently. In particular named captures will be part of matches and mb_ereg_replace() will interpret additional syntax. See Named Captures for more information.

MySQL Improved Extension

Prepared statements now properly report the fractional seconds for DATETIME, TIME and TIMESTAMP columns with decimals specifier (e.g. TIMESTAMP(6) when using microseconds). Formerly, the fractional seconds part was simply omitted from the returned values.

MySQL Functions (PDO_MYSQL)

Prepared statements now properly report the fractional seconds for DATETIME, TIME and TIMESTAMP columns with decimals specifier (e.g. TIMESTAMP(6) when using microseconds). Formerly, the fractional seconds part was simply omitted from the returned values. Please note that this only affects the usage of PDO_MYSQL with emulated prepares turned off (e.g. using the native preparation functionality). Statements using connections having PDO::ATTR_EMULATE_PREPARES=true (which is the default) were not affected by the bug fixed and have already been getting the proper fractional seconds values from the engine.

Reflection

Reflection export to string now uses int and bool instead of integer and boolean, respectively.

Standard PHP Library (SPL)

If an SPL autoloader throws an exception, following autoloaders will not be executed. Previously all autoloaders were executed and exceptions were chained.

SimpleXML

Mathematic operations involving SimpleXML objects will now treat the text as an int or float, whichever is more appropriate. Previously values were treated as ints unconditionally.

Incoming Cookies

As of PHP 7.3.23, the names of incoming cookies are no longer url-decoded for security reasons.


PHP 7.3.x 中废弃的功能

PHP 核心中废弃的功能

大小写不敏感的常量

大小写不敏感的常量声明现已被废弃。将 true 作为第三个参数传递给 define() 将会导致一个废弃警告。大小写不敏感的使用（在读取时使用一个与声明时不同的大小写方式）也已被废弃。

命名空间中的 assert()

废弃：在一个命名空间中声明一个名为 assert() 的函数。 assert() 函数属于引擎特殊处理的情况，当在命名空间中使用相同名字去定义 函数时也许会导致不一致的行为。

在字符串中搜索非字符串内容

废弃：将一个非字符串内容传递给字符串搜索函数。 在将来所有待搜索的内容都将被视为字符串，而不是 ASCII 编码值。如果需要依赖这个特性，你应该 要么显示地进行类型转换（转为字符串），或者显示地调用 chr()。 以下是受到影响的方法：

  • strpos()
  • strrpos()
  • stripos()
  • strripos()
  • strstr()
  • strchr()
  • strrchr()
  • stristr()

Strip-Tags Streaming

fgetss() 函数和 string.strip_tags stream filter 已经被废弃。这同样影响了 SplFileObject::fgetss() 方法和 gzgetss() 函数。

Data Filtering

对于 FILTER_FLAG_SCHEME_REQUIRED 和 FILTER_FLAG_HOST_REQUIRED 常量的显示使用已被废弃。 总之，FILTER_VALIDATE_URL 已经隐含了这两者。

图像处理和 GD 库

image2wbmp() 已被废弃。

国际化相关函数

如果 PHP 关联的ICU ≥ 56, 那么 Normalizer::NONE 形式的使用将会导致抛出一个废弃警告。

多字节字符串

以下在文档中不存在的 mbereg_*() 别名已被废弃。请使用相应的 mb_ereg_*() 变体替代。

  • mbregex_encoding()
  • mbereg()
  • mberegi()
  • mbereg_replace()
  • mberegi_replace()
  • mbsplit()
  • mbereg_match()
  • mbereg_search()
  • mbereg_search_pos()
  • mbereg_search_regs()
  • mbereg_search_init()
  • mbereg_search_getregs()
  • mbereg_search_getpos()
  • mbereg_search_setpos()

ODBC 和 DB2 函数 (PDO_ODBC)

pdo_odbc.db2_instance_name ini 设置项在先前已被废弃。 它在文档中自 PHP 5.1.1 起被废弃


其它变更

PHP 核心

Set(raw)cookie 函数接受 $option 数组参数

setcookie() and setrawcookie() now also support the following signature:

setcookie ( string $name , string $value = "" , array $options = [] ) : bool
where $options is an associative array which may have any of the keys "expires", "path", "domain", "secure", "httponly" and "samesite".

新的 Syslog ini 配置

The following ini Directives have been added to customize logging, if error_log is set to syslog:

syslog.facility
Specifies what type of program is logging the message.
syslog.filter
Specifies the filter type to filter the logged messages. There are three supported filter types - all, no-ctrl and ascii.
syslog.ident
Specifies the ident string which is prepended to every message.

垃圾回收机制

The cyclic GC has been enhanced, which may result in considerable performance improvements.

其它

var_export() now exports stdClass objects as an array cast to an object ((object) array( ... )), rather than using the nonexistent method stdClass::__setState().

debug_zval_dump() was changed to display recursive arrays and objects in the same way as var_dump(). Now, it doesn't display them twice.

array_push() and array_unshift() can now also be called with a single argument, which is particularly convenient wrt. the spread operator.

Interactive PHP Debugger

The unused constants PHPDBG_FILE, PHPDBG_METHOD, PHPDBG_LINENO and PHPDBG_FUNC have been removed.

FastCGI 进程管理器

getallheaders() 函数现已可用。

Client URL Library

libcurl ≥ 7.15.5 is now required.

Data Filtering

FILTER_VALIDATE_FLOAT now also supports a thousand option, which defines the set of allowed thousand separator chars. The default ("',.") is fully backward compatible with former PHP versions.

FILTER_SANITIZE_ADD_SLASHES has been added as an alias of the magic_quotes filter (FILTER_SANITIZE_MAGIC_QUOTES). The magic_quotes filter is subject to removal in future versions of PHP.

FTP

The default transfer mode has been changed to binary.

国际化相关函数

Normalizer::NONE is deprecated, when PHP is linked with ICU ≥ 56.

Introduced Normalizer::FORM_KC_CF as Normalizer::normalize() argument for NFKC_Casefold normalization; available when linked with ICU ≥ 56.

JavaScript Object Notation

A new flag has been added, JSON_THROW_ON_ERROR, which can be used with json_decode() or json_encode() and causes these functions to throw the new JsonException upon an error, instead of setting the global error state that is retrieved with json_last_error() and json_last_error_msg(). JSON_PARTIAL_OUTPUT_ON_ERROR takes precedence over JSON_THROW_ON_ERROR.

Multibyte String

The configuration option --with-libmbfl is no longer available.

ODBC (Unified)

Support for ODBCRouter and Birdstep including the birdstep.max_links ini directive has been removed.

OPcache

The opcache.inherited_hack ini directive has been removed. The value has already been ignored since PHP 5.3.0.

OpenSSL

The min_proto_version and max_proto_version ssl stream options as well as related constants for possible TLS protocol values have been added.

Regular Expressions (Perl-Compatible)

The PCRE extension has been upgraded to PCRE2, which may cause minor behavioral changes (for instance, character ranges in classes are now more strictly interpreted), and augments the existing regular expression syntax.

preg_quote() now also escapes the '#' character.

Microsoft SQL Server and Sybase Functions (PDO_DBLIB)

The attribute PDO::DBLIB_ATTR_SKIP_EMPTY_ROWSETS to enable automatic skipping of empty rowsets has been added.

The PDO::DBLIB_ATTR_TDS_VERSION attribute which exposes the TDS version has been added.

DATETIME2 columns are now treated like DATETIME columns.

SQLite Functions (PDO_SQLITE)

SQLite3 databases can now be opened in read-only mode by setting the new PDO::SQLITE_ATTR_OPEN_FLAGS attribute to PDO::SQLITE_OPEN_READONLY.

Session Handling

session_set_cookie_params() now also supports the following signature:

session_set_cookie_params ( array $options ) : bool
where $options is an associative array which may have any of the keys "lifetime", "path", "domain", "secure", "httponly" and "samesite". Accordingly, the return value of session_get_cookie_params() now also has an element with the key "samesite". Furthermore, the new session.cookie_samesite ini option to set the default of the SameSite directive for cookies has been added. It defaults to "" (empty string), so no SameSite directive is set. Can be set to "Lax" or "Strict", which sets the respective SameSite directive.

Tidy

Building against » tidyp is now also supported transparently. Since tidyp offers no API to get the release date, tidy_get_release() and tidy::getRelease() return 'unknown' in this case.

XML Parser

The return value of the xml_set_external_entity_ref_handler() callback is no longer ignored if the extension has been built against libxml. Formerly, the return value has been ignored, and parsing did never stop.

Zip

Building against the bundled libzip is discouraged, but still possible by adding --without-libzip to the configuration.

Zlib Compression

The zlib/level context option for the compress.zlib wrapper to facilitate setting the desired compression level has been added.


Windows 支持

PHP 核心

更符合 POSIX 标准的文件删除方法

File descriptors are opened in shared read/write/delete mode by default. This effectively maps the POSIX semantics and allows to delete files with handles in use. It is not 100% same, some platform differences still persist. After the deletion, the filename entry is blocked, until all the opened handles to it are closed.


从 PHP 7.1.x 移植到 PHP 7.2.x

Table of Contents

  • 新特性
  • 新函数
  • 新全局常量
  • 不向下兼容的变更
  • PHP 7.2.x 中废弃的功能
  • 其他变更

这个新的小版本带来了大量的 新特性和 少量的兼容性调整 在生产环境切换 PHP 版本前应该进行相关测试。

参见 PHP 版本迁移指南 7.0.x 和 7.1.x。


新特性

新的对象类型

这种新的对象类型, object, 引进了可用于逆变（contravariant）参数输入和协变（covariant）返回任何对象类型。

<?php

function test(object $obj) : object
{
    return new SplQueue();
}

test(new StdClass());

通过名称加载扩展

扩展文件不再需要通过文件加载 (Unix下以.so为文件扩展名，在Windows下以 .dll 为文件扩展名) 进行指定。可以在php.ini配置文件进行启用, 也可以使用 dl() 函数进行启用。

允许重写抽象方法(Abstract method)

当一个抽象类继承于另外一个抽象类的时候，继承后的抽象类可以重写被继承的抽象类的抽象方法。

<?php

abstract class A
{
    abstract function test(string $s);
}
abstract class B extends A
{
    // overridden - still maintaining contravariance for parameters and covariance for return
    abstract function test($s) : int;
}

使用Argon2算法生成密码散列

Argon2 已经被加入到密码散列（password hashing） API (这些函数以 password_ 开头), 以下是暴露出来的常量:

  • PASSWORD_ARGON2I
  • PASSWORD_ARGON2_DEFAULT_MEMORY_COST
  • PASSWORD_ARGON2_DEFAULT_TIME_COST
  • PASSWORD_ARGON2_DEFAULT_THREADS

新增 ext/PDO（PDO扩展） 字符串扩展类型

当你准备支持多语言字符集，PDO的字符串类型已经扩展支持国际化的字符集。以下是扩展的常量：

  • PDO::PARAM_STR_NATL
  • PDO::PARAM_STR_CHAR
  • PDO::ATTR_DEFAULT_STR_PARAM

这些常量通过PDO::PARAM_STR利用位运算OR进行计算：

<?php

$db->quote('über', PDO::PARAM_STR | PDO::PARAM_STR_NATL);

为 ext/PDO新增额外的模拟调试信息

PDOStatement::debugDumpParams()方法已经更新，当发送SQL到数据库的时候，在一致性、行查询（包括替换绑定占位符）将会显示调试信息。这一特性已经加入到模拟调试中（在模拟调试打开时可用）。

ext/LDAP（LDAP扩展） 支持新的操作方式

LDAP 扩展已经新增了EXOP支持. 扩展暴露以下函数和常量:

  • ldap_parse_exop()
  • ldap_exop()
  • ldap_exop_passwd()
  • ldap_exop_whoami()
  • LDAP_EXOP_START_TLS
  • LDAP_EXOP_MODIFY_PASSWD
  • LDAP_EXOP_REFRESH
  • LDAP_EXOP_WHO_AM_I
  • LDAP_EXOP_TURN

ext/sockets（sockets扩展）添加了地址信息

sockets扩展现在具有查找地址信息的能力，且可以连接到这个地址，或者进行绑定和解析。为此添加了以下一些函数:

  • socket_addrinfo_lookup()
  • socket_addrinfo_connect()
  • socket_addrinfo_bind()
  • socket_addrinfo_explain()

扩展了参数类型

重写方法和接口实现的参数类型现在可以省略了。不过这仍然是符合LSP，因为现在这种参数类型是逆变的。

<?php

interface A
{
    public function Test(array $input);
}

class B implements A
{
    public function Test($input){} // type omitted for $input
}

允许分组命名空间的尾部逗号

命名空间可以在PHP 7中使用尾随逗号进行分组引入。

<?php

use Foo\Bar\{
    Foo,
    Bar,
    Baz,
};


新函数

PHP 内核

  • stream_isatty()
  • sapi_windows_vt100_support()

SPL

  • spl_object_id()

DOM

  • DomNodeList::count()
  • DOMNamedNodeMap::count()

FTP

  • ftp_append()

GD

  • imagesetclip()
  • imagegetclip()
  • imageopenpolygon()
  • imageresolution()
  • imagecreatefrombmp()
  • imagebmp()

Hash

  • hash_hmac_algos()

LDAP

  • ldap_parse_exop()
  • ldap_exop()
  • ldap_exop_passwd()
  • ldap_exop_whoami()

Multibyte String

  • mb_chr()
  • mb_ord()
  • mb_scrub()

Oracle OCI8

  • oci_register_taf_callback()
  • oci_unregister_taf_callback()

Sockets

  • socket_addrinfo_lookup()
  • socket_addrinfo_connect()
  • socket_addrinfo_bind()
  • socket_addrinfo_explain()

Sodium

  • sodium_add()
  • sodium_bin2hex()
  • sodium_compare()
  • sodium_crypto_aead_aes256gcm_decrypt()
  • sodium_crypto_aead_aes256gcm_encrypt()
  • sodium_crypto_aead_aes256gcm_is_available()
  • sodium_crypto_aead_aes256gcm_keygen()
  • sodium_crypto_aead_chacha20poly1305_decrypt()
  • sodium_crypto_aead_chacha20poly1305_encrypt()
  • sodium_crypto_aead_chacha20poly1305_ietf_decrypt()
  • sodium_crypto_aead_chacha20poly1305_ietf_encrypt()
  • sodium_crypto_aead_chacha20poly1305_ietf_keygen()
  • sodium_crypto_aead_chacha20poly1305_keygen()
  • sodium_crypto_auth_keygen()
  • sodium_crypto_auth_verify()
  • sodium_crypto_auth()
  • sodium_crypto_box_keypair_from_secretkey_and_publickey()
  • sodium_crypto_box_keypair()
  • sodium_crypto_box_open()
  • sodium_crypto_box_publickey_from_secretkey()
  • sodium_crypto_box_publickey()
  • sodium_crypto_box_seal_open()
  • sodium_crypto_box_seal()
  • sodium_crypto_box_secretkey()
  • sodium_crypto_box_seed_keypair()
  • sodium_crypto_box()
  • sodium_crypto_generichash_final()
  • sodium_crypto_generichash_init()
  • sodium_crypto_generichash_keygen()
  • sodium_crypto_generichash_update()
  • sodium_crypto_generichash()
  • sodium_crypto_kdf_derive_from_key()
  • sodium_crypto_kdf_keygen()
  • sodium_crypto_kx_client_session_keys()
  • sodium_crypto_kx_keypair()
  • sodium_crypto_kx_publickey()
  • sodium_crypto_kx_secretkey()
  • sodium_crypto_kx_seed_keypair()
  • sodium_crypto_kx_server_session_keys()
  • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify()
  • sodium_crypto_pwhash_scryptsalsa208sha256_str()
  • sodium_crypto_pwhash_scryptsalsa208sha256()
  • sodium_crypto_pwhash_str_verify()
  • sodium_crypto_pwhash_str()
  • sodium_crypto_pwhash()
  • sodium_crypto_scalarmult_base()
  • sodium_crypto_scalarmult()
  • sodium_crypto_secretbox_keygen()
  • sodium_crypto_secretbox_open()
  • sodium_crypto_secretbox()
  • sodium_crypto_shorthash_keygen()
  • sodium_crypto_shorthash()
  • sodium_crypto_sign_detached()
  • sodium_crypto_sign_ed25519_pk_to_curve25519()
  • sodium_crypto_sign_ed25519_sk_to_curve25519()
  • sodium_crypto_sign_keypair_from_secretkey_and_publickey()
  • sodium_crypto_sign_keypair()
  • sodium_crypto_sign_open()
  • sodium_crypto_sign_publickey_from_secretkey()
  • sodium_crypto_sign_publickey()
  • sodium_crypto_sign_secretkey()
  • sodium_crypto_sign_seed_keypair()
  • sodium_crypto_sign_verify_detached()
  • sodium_crypto_sign()
  • sodium_crypto_stream_keygen()
  • sodium_crypto_stream_xor()
  • sodium_crypto_stream()
  • sodium_hex2bin()
  • sodium_increment()
  • sodium_memcmp()
  • sodium_memzero()
  • sodium_pad()
  • sodium_unpad()

ZIP

  • ZipArchive::count()
  • ZipArchive::setEncryptionName()
  • ZipArchive::setEncryptionIndex()


新全局常量

PHP 内核

  • PHP_FLOAT_DIG
  • PHP_FLOAT_EPSILON
  • PHP_FLOAT_MIN
  • PHP_FLOAT_MAX
  • PHP_OS_FAMILY

文件信息

  • FILEINFO_EXTENSION

JSON

  • JSON_INVALID_UTF8_IGNORE
  • JSON_INVALID_UTF8_SUBSTITUTE

GD

  • IMG_EFFECT_MULTIPLY
  • IMG_BMP

LDAP

  • LDAP_EXOP_START_TLS
  • LDAP_EXOP_MODIFY_PASSWD
  • LDAP_EXOP_REFRESH
  • LDAP_EXOP_WHO_AM_I
  • LDAP_EXOP_TURN

密码散列

  • PASSWORD_ARGON2I
  • PASSWORD_ARGON2_DEFAULT_MEMORY_COST
  • PASSWORD_ARGON2_DEFAULT_TIME_COST
  • PASSWORD_ARGON2_DEFAULT_THREADS

PCRE

  • PREG_UNMATCHED_AS_NULL

PDO

  • PDO::PARAM_STR_NATL
  • PDO::PARAM_STR_CHAR
  • PDO::ATTR_DEFAULT_STR_PARAM

Sodium

  • SODIUM_LIBRARY_VERSION
  • SODIUM_LIBRARY_MAJOR_VERSION
  • SODIUM_LIBRARY_MINOR_VERSION
  • SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES
  • SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES
  • SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES
  • SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES
  • SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES
  • SODIUM_CRYPTO_AUTH_BYTES
  • SODIUM_CRYPTO_AUTH_KEYBYTES
  • SODIUM_CRYPTO_BOX_SEALBYTES
  • SODIUM_CRYPTO_BOX_SECRETKEYBYTES
  • SODIUM_CRYPTO_BOX_PUBLICKEYBYTES
  • SODIUM_CRYPTO_BOX_KEYPAIRBYTES
  • SODIUM_CRYPTO_BOX_MACBYTES
  • SODIUM_CRYPTO_BOX_NONCEBYTES
  • SODIUM_CRYPTO_BOX_SEEDBYTES
  • SODIUM_CRYPTO_KDF_BYTES_MIN
  • SODIUM_CRYPTO_KDF_BYTES_MAX
  • SODIUM_CRYPTO_KDF_CONTEXTBYTES
  • SODIUM_CRYPTO_KDF_KEYBYTES
  • SODIUM_CRYPTO_KX_SEEDBYTES
  • SODIUM_CRYPTO_KX_SESSIONKEYBYTES
  • SODIUM_CRYPTO_KX_PUBLICKEYBYTES
  • SODIUM_CRYPTO_KX_SECRETKEYBYTES
  • SODIUM_CRYPTO_KX_KEYPAIRBYTES
  • SODIUM_CRYPTO_GENERICHASH_BYTES
  • SODIUM_CRYPTO_GENERICHASH_BYTES_MIN
  • SODIUM_CRYPTO_GENERICHASH_BYTES_MAX
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN
  • SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX
  • SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13
  • SODIUM_CRYPTO_PWHASH_ALG_DEFAULT
  • SODIUM_CRYPTO_PWHASH_SALTBYTES
  • SODIUM_CRYPTO_PWHASH_STRPREFIX
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE
  • SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE
  • SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE
  • SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE
  • SODIUM_CRYPTO_SCALARMULT_BYTES
  • SODIUM_CRYPTO_SCALARMULT_SCALARBYTES
  • SODIUM_CRYPTO_SHORTHASH_BYTES
  • SODIUM_CRYPTO_SHORTHASH_KEYBYTES
  • SODIUM_CRYPTO_SECRETBOX_KEYBYTES
  • SODIUM_CRYPTO_SECRETBOX_MACBYTES
  • SODIUM_CRYPTO_SECRETBOX_NONCEBYTES
  • SODIUM_CRYPTO_SIGN_BYTES
  • SODIUM_CRYPTO_SIGN_SEEDBYTES
  • SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES
  • SODIUM_CRYPTO_SIGN_SECRETKEYBYTES
  • SODIUM_CRYPTO_SIGN_KEYPAIRBYTES
  • SODIUM_CRYPTO_STREAM_NONCEBYTES
  • SODIUM_CRYPTO_STREAM_KEYBYTES

Zip

  • ZipArchive::EM_NONE
  • ZipArchive::EM_AES_128
  • ZipArchive::EM_AES_192
  • ZipArchive::EM_AES_256


不向下兼容的变更

防止 number_format() 返回负零

之前版本中，number_format() 有可能会返回 -0。虽然这是符合 IEEE 754 规范的，但是这样会导致可读性不好，新版本中会将这样的负数去掉。

<?php

var_dump(number_format(-0.01)); // 新版本输出 string(1) "0" 旧版本输出 string(2) "-0"

转换对象和数组中的数字键

将数组转换为对象，或将对象转换为数组时，数字键现在得到了更好的处理（无论是通过显式转换还是通过 settype() 函数）。

这意味着现在可以访问数组中的整数(或者说是字符串整数)键，这些键会映射到对象中：

<?php

// array to object
$arr = [0 => 1];
$obj = (object)$arr;
var_dump(
    $obj,
    $obj->{'0'}, // 新写法
    $obj->{0} // 新写法
);

以上例程会输出：

object(stdClass)#1 (1) {
  ["0"]=>    // string key now, rather than integer key
  int(1)
}
int(1)
int(1)

从对象转换成的数组中的整数（或者说是字符串整数）键现在也可以直接访问：

<?php

// object to array
$obj = new class {
    public function __construct()
    {
        $this->{0} = 1;
    }
};
$arr = (array)$obj;
var_dump(
    $arr,
    $arr[0], // 新写法
    $arr['0'] // 新写法
);

以上例程会输出：

array(1) {
  [0]=>    // integer key now, rather than string key
  int(1)
}
int(1)
int(1)

get_class() 函数不再接受 null 参数

之前版本中，传递 null 给 get_class() 函数将返回当前类名。在新版本中，此行为会抛出一个 E_WARNING 错误。如果想实现与之前版本同样的效果，请不要传递任何参数进来。

计算非可数类型（non-countable）时发出警告

对非可数类型调用 count()（或 sizeof()）函数，会抛出一个 E_WARNING 错误。

<?php

var_dump(
    count(null), // NULL is not countable
    count(1), // integers are not countable
    count('abc'), // strings are not countable
    count(new stdclass), // objects not implementing the Countable interface are not countable
    count([1,2]) // arrays are countable
);

以上例程会输出：

Warning: count(): Parameter must be an array or an object that implements Countable in %s on line %d

Warning: count(): Parameter must be an array or an object that implements Countable in %s on line %d

Warning: count(): Parameter must be an array or an object that implements Countable in %s on line %d

Warning: count(): Parameter must be an array or an object that implements Countable in %s on line %d
int(0)
int(1)
int(1)
int(1)
int(2)

ext/hash 从资源变成对象

As part of the long-term migration away from resources, the Hash extension has been updated to use objects instead of resources. The change should be seamless for PHP developers, except for where is_resource() checks have been made (which will need updating to is_object() instead).

SSL/TLS 的默认选项的改进

下列默认选项被修改：

  • tls:// 默认为 TLSv1.0 or TLSv1.1 or TLSv1.2
  • ssl:// 成为 tls:// 的别名
  • STREAM_CRYPTO_METHOD_TLS_* 常量默认为 TLSv1.0 或 TLSv1.1 + TLSv1.2，替代之前的 TLSv1.0

gettype() 在闭包资源中的返回值

之前版本中，如果在一个闭包资源中使用 gettype() 会返回字符串 "unknown type"，现在将会返回字符 "resource (closed)"。

is_object() 和 __PHP_Incomplete_Class

之前版本中，对 __PHP_Incomplete_Class 调用 is_object() 函数会返回 false，现在会返回 true。

提升未定义常量的错误级别

调用未定义的常量，现在会抛出一个 E_WARNING 错误(之前版本中为 E_NOTICE)。在下一个 PHP 大版本中，将会抛出一个 Error 错误。

Windows 支持

官方支持的最低 Windows 版本为 Windows 7/Server 2008 R2。

Checks on default property values of traits

Compatibility checks upon default trait property values will no longer perform casting.

object 保留字的变化

object 在之前的 PHP 7.0 版本 中被声明为软保留字（soft-reserved）。现在变更为强制保留字，禁止在任何类或接口中使用该名称。

NetWare 支持

NetWare 已不再被支持。

array_unique() with SORT_STRING

While array_unique() with SORT_STRING formerly copied the array and removed non-unique elements (without packing the array afterwards), now a new array is built by adding the unique elements. This can result in different numeric indexes.

bcmod() changes with floats

The bcmod() function no longer truncates fractional numbers to integers. As such, its behavior now follows fmod(), rather than the % operator. For example bcmod('4', '3.5') now returns 0.5 instead of 1.

Hashing functions and non-cryptographic hashes

The hash_hmac(), hash_hmac_file(), hash_pbkdf2(), and hash_init() (with HASH_HMAC) functions no longer accept non-cryptographic hashes.

json_decode() 函数变更

The json_decode() function option, JSON_OBJECT_AS_ARRAY, is now used if the second parameter (assoc) is null. Previously, JSON_OBJECT_AS_ARRAY was always ignored.

rand() and mt_rand() output

Sequences generated by rand() and mt_rand() for a specific seed may differ from PHP 7.1 on 64-bit machines (due to the fixing of a modulo bias bug in the implementation).

sql.safe_mode ini 选项移除

sql.safe_mode ini 设置项已被移除。

Changes to date_parse() and date_parse_from_format()

The zone element of the array returned by date_parse() and date_parse_from_format() represents seconds instead of minutes now, and its sign is inverted. For instance -120 is now 7200.

Incoming Cookies

As of PHP 7.2.34, the names of incoming cookies are no longer url-decoded for security reasons.


PHP 7.2.x 中废弃的功能

不带引号的字符串

不带引号的字符串是不存在的全局常量，转化成他们自身的字符串。 在以前，该行为会产生 E_NOTICE，但现在会产生 E_WARNING。在下一个 PHP 主版本中，将抛出 Error 异常。

<?php

var_dump(NONEXISTENT);

/* Output:
Warning: Use of undefined constant NONEXISTENT - assumed 'NONEXISTENT' (this will throw an Error in a future version of PHP) in %s on line %d
string(11) "NONEXISTENT"
*/

png2wbmp() 和 jpeg2wbmp()

GD 扩展内的 png2wbmp() 和 jpeg2wbmp() 现已被废弃，将在下一个 PHP 主版本中移除。

INTL_IDNA_VARIANT_2003 转化

Intl 扩展废弃了 INTL_IDNA_VARIANT_2003 转化，为idn_to_ascii() 和 idn_to_utf8() 的默认选项。 PHP 7.4 会把默认值设置为 INTL_IDNA_VARIANT_UTS46， 并在下一个 PHP 主版本中完全移除 INTL_IDNA_VARIANT_2003。

__autoload() 方法

__autoload() 方法已被废弃， 因为和 spl_autoload_register() 相比功能较差 (因为无法链式处理多个 autoloader)， 而且也无法在两种 autoloading 样式中配合使用。

track_errors ini 设置和 $php_errormsg 变量

当开启了 track_errors ini 设置，出现非致命错误时， 会在本地作用域创建 $php_errormsg 变量。 由于提供了更好的方式： error_get_last() 来获取此类错误信息，该功能被废弃。

create_function() 函数

考虑到此函数的安全隐患问题（它是 eval() 的瘦包装器），该过时的函数现在已被废弃。 更好的选择是匿名函数。

mbstring.func_overload ini 设置

由于此设置会影响环境中的字符串系列函数，带来相互操作中的问题，它现在已被废弃。

(unset) 类型强制转化

转化任意表达式为此类型，结果总是 null，所以这个多余的类型转化现在也就被废弃了。

parse_str() 不加第二个参数

使用 parse_str() 时，不加第二个参数会导致查询字符串参数导入当前符号表。 考虑到安全隐患问题，不加第二个参数使用 parse_str() 的行为已被废弃。 此函数的第二个选项为必填项，它使查询字符串转为 Array。

gmp_random() 函数

此函数基于未知的、取决于平台的 limb 尺寸产生随机数。因此，该函数已被废弃。 使用更好的方式产生随机数： GMP 扩展中的 gmp_random_bits() 和 gmp_random_range()。

each() 函数

使用此函数遍历时，比普通的 foreach 更慢， 并且给新语法的变化带来实现问题。因此它被废弃了。

assert() 一个字符串参数

assert() 字符串参数将要求它能被 eval() 执行。 考虑到可能被执行远程代码，废弃了字符串的 assert()，最好提供 bool 的表达式。

错误处理器内的 $errcontext 参数

$errcontext 参数包含了错误网站的所有本地变量。 考虑到它很少被用到，而且还会导致内部优化问题，它现在被废弃了。 代替用法：调试器应该自己取回错误站点的本地变量。

read_exif_data() 函数

read_exif_data() 别名已被废弃 使用 exif_read_data() 函数代替。


其他变更

移动 utf8_encode() 和 utf8_decode()

utf8_encode() 和 utf8_decode() 现在已经作为字符串处理函数移到标准扩展中， 在此之前需要启用 XML 扩展才能使用。

mail() 和 mb_sendmail() 的变更

mail() 和 mb_sendmail() 函数中的 $additional_headers 参数变更为 array，此前为 string。

支持 LMDB

DBA 扩展现在已经支持 LMDB。

PHP 构建系统的变更

  • Unix: 构建 PHP 需要 Autoconf 2.64 或更高的版本。
  • Unix: --with-pdo-oci 配置选项不再需要指定 Oracle Instant Client 的版本号数字。
  • Unix: 移除了 --enable-gd-native-ttf 配置参数。自 PHP 5.5.0 以来就已经不再使用。
  • Windows: 添加了 --with-config-profile 配置参数。 可用于保存细节配置，就像是神奇的 config.nice.bat 文件。

GD的变更

  • 当编译时使用了系统的 libgd，imageantialias() 也能生效。
  • imagegd() 以真彩色储存真彩色图像。在此之前，会转化为调色板图像。

移动 MCrypt 到 PECL

MCrypt 扩展从内核移动到 PECL。 考虑到 mcrypt 库自 2007 年以来未见任何更新，不再建议使用。 代替品即可以用 OpenSSL，也可以用 Sodium。

session_module_name()

传递给 session_module_name() 函数的模块名不允许为 "user"，将会抛出一个 E_RECOVERABLE_ERROR，之前版本会忽略这个问题。


从 PHP 7.0.x 移植到 PHP 7.1.x

Table of Contents

  • 新特性
  • 新的函数
  • 新增的全局常量
  • 不向后兼容的变更
  • PHP 7.1.x 中废弃的特性
  • 变动的函数
  • 其它改动
  • Windows 支持

这个新的小版本带来了大量的 新特性和 少量的兼容性调整 在生产环境切换 PHP 版本前应该进行相关测试。

参见 PHP 版本迁移指南 7.0.x。


新特性

可为空（Nullable）类型

参数以及返回值的类型现在可以通过在类型前加上一个问号使之允许为空。 当启用这个特性时，传入的参数或者函数返回的结果要么是给定的类型，要么是 null 。

<?php

function testReturn(): ?string
{
    return 'elePHPant';
}

var_dump(testReturn());

function testReturn(): ?string
{
    return null;
}

var_dump(testReturn());

function test(?string $name)
{
    var_dump($name);
}

test('elePHPant');
test(null);
test();

以上例程会输出：

string(10) "elePHPant"
NULL
string(10) "elePHPant"
NULL
Uncaught Error: Too few arguments to function test(), 0 passed in...

Void 函数

一个新的返回值类型void被引入。 返回值声明为 void 类型的方法要么干脆省去 return 语句，要么使用一个空的 return 语句。 对于 void 函数来说，null 不是一个合法的返回值。

<?php
function swap(&$left, &$right) : void
{
    if ($left === $right) {
        return;
    }

    $tmp = $left;
    $left = $right;
    $right = $tmp;
}

$a = 1;
$b = 2;
var_dump(swap($a, $b), $a, $b);

以上例程会输出：

null
int(2)
int(1)

试图去获取一个 void 方法的返回值会得到 null ，并且不会产生任何警告。这么做的原因是不想影响更高层次的方法。

Symmetric array destructuring

短数组语法（[]）现在作为list()语法的一个备选项，可以用于将数组的值赋给一些变量（包括在foreach中）。

<?php
$data = [
    [1, 'Tom'],
    [2, 'Fred'],
];

// list() style
list($id1, $name1) = $data[0];

// [] style
[$id1, $name1] = $data[0];

// list() style
foreach ($data as list($id, $name)) {
    // logic here with $id and $name
}

// [] style
foreach ($data as [$id, $name]) {
    // logic here with $id and $name
}

类常量可见性

现在起支持设置类常量的可见性。

<?php
class ConstDemo
{
    const PUBLIC_CONST_A = 1;
    public const PUBLIC_CONST_B = 2;
    protected const PROTECTED_CONST = 3;
    private const PRIVATE_CONST = 4;
}

iterable 伪类

现在引入了一个新的被称为iterable的伪类 (与callable类似)。 这可以被用在参数或者返回值类型中，它代表接受数组或者实现了Traversable接口的对象。 至于子类，当用作参数时，子类可以收紧父类的iterable类型到array 或一个实现了Traversable的对象。对于返回值，子类可以拓宽父类的 array或对象返回值类型到iterable。

<?php
function iterator(iterable $iter)
{
    foreach ($iter as $val) {
        //
    }
}

多异常捕获处理

一个catch语句块现在可以通过管道字符(|)来实现多个异常的捕获。 这对于需要同时处理来自不同类的不同异常时很有用。

<?php
try {
    // some code
} catch (FirstException | SecondException $e) {
    // handle first and second exceptions
}

list()现在支持键名

现在list()和它的新的[]语法支持在它内部去指定键名。这意味着它可以将任意类型的数组 都赋值给一些变量（与短数组语法类似）

<?php
$data = [
    ["id" => 1, "name" => 'Tom'],
    ["id" => 2, "name" => 'Fred'],
];

// list() style
list("id" => $id1, "name" => $name1) = $data[0];

// [] style
["id" => $id1, "name" => $name1] = $data[0];

// list() style
foreach ($data as list("id" => $id, "name" => $name)) {
    // logic here with $id and $name
}

// [] style
foreach ($data as ["id" => $id, "name" => $name]) {
    // logic here with $id and $name
}

支持为负的字符串偏移量

现在所有支持偏移量的字符串操作函数 都支持接受负数作为偏移量，包括通过[]或{}操作字符串下标。在这种情况下，一个负数的偏移量会被理解为一个从字符串结尾开始的偏移量。

<?php
var_dump("abcdef"[-2]);
var_dump(strpos("aabbcc", "b", -3));

以上例程会输出：

string (1) "e"
int(3)

Negative string and array offsets are now also supported in the simple variable parsing syntax inside of strings.

<?php
$string = 'bar';
echo "The last character of '$string' is '$string[-1]'.\n";
?>

以上例程会输出：

The last character of 'bar' is 'r'.

ext/openssl 支持 AEAD

通过给openssl_encrypt()和openssl_decrypt() 添加额外参数，现在支持了AEAD (模式 GCM and CCM)。

通过 Closure::fromCallable() 将callables转为闭包

Closure新增了一个静态方法，用于将callable快速地 转为一个Closure 对象。

<?php
class Test
{
    public function exposeFunction()
    {
        return Closure::fromCallable([$this, 'privateFunction']);
    }

    private function privateFunction($param)
    {
        var_dump($param);
    }
}

$privFunc = (new Test)->exposeFunction();
$privFunc('some value');

以上例程会输出：

string(10) "some value"

异步信号处理

一个新的名为 pcntl_async_signals() 的方法现在被引入， 用于启用无需 ticks （这会带来很多额外的开销）的异步信号处理。

<?php
pcntl_async_signals(true); // turn on async signals

pcntl_signal(SIGHUP,  function($sig) {
    echo "SIGHUP\n";
});

posix_kill(posix_getpid(), SIGHUP);

以上例程会输出：

SIGHUP

HTTP/2 server push support in ext/curl

对服务器推送的支持现在已经被加入到 CURL 扩展中（ 需要版本 7.46 或更高）。这个可以通过 curl_multi_setopt() 函数与新的常量 CURLMOPT_PUSHFUNCTION 来进行调节。常量 CURL_PUST_OK 和 CURL_PUSH_DENY 也已经被添加进来，以便服务器推送的回调函数来表明自己会同意或拒绝处理。

套接字上下文选项

新增 tcp_nodelay 选项。


新的函数

PHP Core

  • sapi_windows_cp_get()
  • sapi_windows_cp_set()
  • sapi_windows_cp_conv()
  • sapi_windows_cp_is_utf8()

Closure

  • Closure::fromCallable()

CURL

  • curl_multi_errno()
  • curl_share_errno()
  • curl_share_strerror()

OpenSSL

  • openssl_get_curve_names()

Session

  • session_create_id()
  • session_gc()

SPL

  • is_iterable()

PCNTL

  • pcntl_async_signals()
  • pcntl_signal_get_handler()


新增的全局常量

PHP 核心中预定义的常量

  • PHP_FD_SETSIZE

CURL

  • CURLMOPT_PUSHFUNCTION
  • CURL_PUSH_OK
  • CURL_PUSH_DENY

Data Filtering

  • FILTER_FLAG_EMAIL_UNICODE

Image Processing and GD

  • IMAGETYPE_WEBP

JSON

  • JSON_UNESCAPED_LINE_TERMINATORS

LDAP

  • LDAP_OPT_X_SASL_NOCANON
  • LDAP_OPT_X_SASL_USERNAME
  • LDAP_OPT_X_TLS_CACERTDIR
  • LDAP_OPT_X_TLS_CACERTFILE
  • LDAP_OPT_X_TLS_CERTFILE
  • LDAP_OPT_X_TLS_CIPHER_SUITE
  • LDAP_OPT_X_TLS_KEYFILE
  • LDAP_OPT_X_TLS_RANDOM_FILE
  • LDAP_OPT_X_TLS_CRLCHECK
  • LDAP_OPT_X_TLS_CRL_NONE
  • LDAP_OPT_X_TLS_CRL_PEER
  • LDAP_OPT_X_TLS_CRL_ALL
  • LDAP_OPT_X_TLS_DHFILE
  • LDAP_OPT_X_TLS_CRLFILE
  • LDAP_OPT_X_TLS_PROTOCOL_MIN
  • LDAP_OPT_X_TLS_PROTOCOL_SSL2
  • LDAP_OPT_X_TLS_PROTOCOL_SSL3
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_0
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_1
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_2
  • LDAP_OPT_X_TLS_PACKAGE
  • LDAP_OPT_X_KEEPALIVE_IDLE
  • LDAP_OPT_X_KEEPALIVE_PROBES
  • LDAP_OPT_X_KEEPALIVE_INTERVAL

PostgreSQL

  • PGSQL_NOTICE_LAST
  • PGSQL_NOTICE_ALL
  • PGSQL_NOTICE_CLEAR

SPL

  • MT_RAND_PHP


不向后兼容的变更

当传递参数过少时将抛出错误

在过去如果我们调用一个用户定义的函数时，提供的参数不足，那么将会产生一个警告(warning)。 现在，这个警告被提升为一个错误异常(Error exception)。这个变更仅对用户定义的函数生效， 并不包含内置函数。例如：

<?php
function test($param){}
test();

以上例程在 PHP 5.5 中的输出：

Uncaught Error: Too few arguments to function test(), 0 passed in %s on line %d and exactly 1 expected in %s:%d

Forbid dynamic calls to scope introspection functions

Dynamic calls for certain functions have been forbidden (in the form of $func() or array_map('extract', ...), etc). These functions either inspect or modify another scope, and present with them ambiguous and unreliable behavior. The functions are as follows:

  • assert() - with a string as the first argument
  • compact()
  • extract()
  • func_get_args()
  • func_get_arg()
  • func_num_args()
  • get_defined_vars()
  • mb_parse_str() - with one arg
  • parse_str() - with one arg
<?php
(function () {
    'func_num_args'();
})();

以上例程会输出：

Warning: Cannot call func_num_args() dynamically in %s on line %d

Invalid class, interface, and trait names

The following names cannot be used to name classes, interfaces, or traits:

  • void
  • iterable

Numerical string conversions now respect scientific notation

Integer operations and conversions on numerical strings now respect scientific notation. This also includes the (int) cast operation, and the following functions: intval() (where the base is 10), settype(), decbin(), decoct(), and dechex().

Fixes to mt_rand() algorithm

mt_rand() will now default to using the fixed version of the Mersenne Twister algorithm. If deterministic output from mt_srand() was relied upon, then the MT_RAND_PHP with the ability to preserve the old (incorrect) implementation via an additional optional second parameter to mt_srand().

rand() aliased to mt_rand() and srand() aliased to mt_srand()

rand() and srand() have now been made aliases to mt_rand() and mt_srand(), respectively. This means that the output for the following functions have changes: rand(), shuffle(), str_shuffle(), and array_rand().

Disallow the ASCII delete control character in identifiers

The ASCII delete control character (0x7F) can no longer be used in identifiers that are not quoted.

error_log changes with syslog value

If the error_log ini setting is set to syslog, the PHP error levels are mapped to the syslog error levels. This brings finer differentiation in the error logs in contrary to the previous approach where all the errors are logged with the notice level only.

在不完整的对象上不再调用析构方法

析构方法在一个不完整的对象（例如在构造方法中抛出一个异常）上将不再会被调用。

call_user_func()不再支持对传址的函数的调用

call_user_func() 现在在调用一个以引用作为参数的函数时将始终失败。

字符串不再支持空索引操作符 The empty index operator is not supported for strings anymore

对字符串使用一个空索引操作符（例如$str[] = $x）将会抛出一个致命错误， 而不是静默地将其转为一个数组。

ini配置项移除

下列ini配置项已经被移除：

  • session.entropy_file
  • session.entropy_length
  • session.hash_function
  • session.hash_bits_per_character

Array ordering when elements are automatically created during by reference assignments has changed

The order of the elements in an array has changed when those elements have been automatically created by referencing them in a by reference assignment. For example:

<?php
$array = [];
$array["a"] =& $array["b"];
$array["b"] = 1;
var_dump($array);
?>

以上例程在 PHP 7.0 中的输出：

array(2) {
  ["a"]=>
  &int(1)
  ["b"]=>
  &int(1)
}

以上例程在 PHP 7.1 中的输出：

array(2) {
  ["b"]=>
  &int(1)
  ["a"]=>
  &int(1)
}

Sort order of equal elements

The internal sorting algorithm has been improved, what may result in different sort order of elements, which compare as equal, than before.

Note:

Don't rely on the order of elements which compare as equal; it might change anytime.

Error message for E_RECOVERABLE errors

The error message for E_RECOVERABLE errors has been changed from "Catchable fatal error" to "Recoverable fatal error".

$options parameter of unserialize()

The allowed_classes element of the $options parameter of unserialize() is now strictly typed, i.e. if anything other than an array or a boolean is given, unserialize() returns false and issues an E_WARNING.

DateTime constructor incorporates microseconds

DateTime and DateTimeImmutable now properly incorporate microseconds when constructed from the current time, either explicitly or with a relative string (e.g. "first day of next month"). This means that naive comparisons of two newly created instances will now more likely return false instead of true:

<?php
new DateTime() == new DateTime();
?>

Fatal errors to Error exceptions conversions

In the Date extension, invalid serialization data for DateTime or DatePeriod classes, or timezone initialization failure from serialized data, will now throw an Error exception from the __wakeup() or __set_state() methods, instead of resulting in a fatal error.

In the DBA extension, data modification functions (such as dba_insert()) will now throw an Error exception instead of triggering a catchable fatal error if the key does not contain exactly two elements.

In the DOM extension, invalid schema or RelaxNG validation contexts will now throw an Error exception instead of resulting in a fatal error. Similarly, attempting to register a node class that does not extend the appropriate base class, or attempting to read an invalid property or write to a readonly property, will also now throw an Error exception.

In the IMAP extension, email addresses longer than 16385 bytes will throw an Error exception instead of resulting in a fatal error.

In the Intl extension, failing to call the parent constructor in a class extending Collator before invoking the parent methods will now throw an Error instead of resulting in a recoverable fatal error. Also, cloning a Transliterator object will now throw an Error exception on failure to clone the internal transliterator instead of resulting in a fatal error.

In the LDAP extension, providing an unknown modification type to ldap_batch_modify() will now throw an Error exception instead of resulting in a fatal error.

In the mbstring extension, the mb_ereg() and mb_eregi() functions will now throw a ParseError exception if an invalid PHP expression is provided and the 'e' option is used.

In the Mcrypt extension, the mcrypt_encrypt() and mcrypt_decrypt() will now throw an Error exception instead of resulting in a fatal error if mcrypt cannot be initialized.

In the mysqli extension, attempting to read an invalid property or write to a readonly property will now throw an Error exception instead of resulting in a fatal error.

In the Reflection extension, failing to retrieve a reflection object or retrieve an object property will now throw an Error exception instead of resulting in a fatal error.

In the Session extension, custom session handlers that do not return strings for session IDs will now throw an Error exception instead of resulting in a fatal error when a function is called that must generate a session ID.

In the SimpleXML extension, creating an unnamed or duplicate attribute will now throw an Error exception instead of resulting in a fatal error.

In the SPL extension, attempting to clone an SplDirectory object will now throw an Error exception instead of resulting in a fatal error. Similarly, calling ArrayIterator::append() when iterating over an object will also now throw an Error exception.

In the standard extension, the assert() function, when provided with a string argument as its first parameter, will now throw a ParseError exception instead of resulting in a catchable fatal error if the PHP code is invalid. Similarly, calling forward_static_call() outside of a class scope will now throw an Error exception.

In the Tidy extension, creating a tidyNode manually will now throw an Error exception instead of resulting in a fatal error.

In the WDDX extension, a circular reference when serializing will now throw an Error exception instead of resulting in a fatal error.

In the XML-RPC extension, a circular reference when serializing will now throw an instance of Error exception instead of resulting in a fatal error.

In the Zip extension, the ZipArchive::addGlob() method will now throw an Error exception instead of resulting in a fatal error if glob support is not available.

Lexically bound variables cannot reuse names

Variables bound to a closure via the use construct cannot use the same name as any superglobals, $this, or any parameter. For example, all of these function definition will result in a fatal error:

<?php
$f = function () use ($_SERVER) {};
$f = function () use ($this) {};
$f = function ($param) use ($param) {};

JSON encoding and decoding

The serialize_precision ini setting now controls the serialization precision when encoding doubles.

Decoding an empty key now results in an empty property name, rather than _empty_ as a property name.

<?php
var_dump(json_decode(json_encode(['' => 1])));

以上例程的输出类似于：

object(stdClass)#1 (1) {
  [""]=>
  int(1)
}

When supplying the JSON_UNESCAPED_UNICODE flag to json_encode(), the sequences U+2028 and U+2029 are now escaped.

Changes to mb_ereg() and mb_eregi() parameter semantics

The third paramter to the mb_ereg() and mb_eregi() functions (regs) will now be set to an empty array if nothing was matched. Formely, the parameter would not have been modified.

Drop support for the sslv2 stream

The sslv2 stream has now been dropped in OpenSSL.


PHP 7.1.x 中废弃的特性

ext/mcrypt

mcrypt 扩展已经过时了大约10年，并且用起来很复杂。因此它被废弃并且被 OpenSSL 所取代。 从PHP 7.2起它将被从核心代码中移除并且移到PECL中。

mb_ereg_replace()和mb_eregi_replace()的Eval选项

对于mb_ereg_replace()和mb_eregi_replace()的 e模式修饰符现在已被废弃。


变动的函数

PHP 核心

  • getopt() 函数增加了第三个参数，这是一个可选参数。 通过以引用的方式传入参数， 它可以用来存储参数列表中下一个参数的下标位置。
  • getenv() 可以不传入任何参数。 如果不传入参数，此函数会以关联数组的形式 返回所有的环境变量。
  • get_headers() 增加了一个参数， 可以用来解析自定义的流上下文。
  • output_reset_rewrite_vars() 函数不再重置会话 URL 重写变量了。
  • parse_url() 更加严格的限制， 并且提供对 RFC3986 的支持。
  • unpack() 函数增加第三个参数， 这是一个可选参数，用来指定开始解包的位置。

文件系统

  • file_get_contents() 接受负数作为搜索偏移量， 前提是流上下文必须是可搜索的。
  • tempnam() 会在退回使用系统临时目录的时候，产生警告。

JSON

  • json_encode() 增加新的选项： JSON_UNESCAPED_LINE_TERMINATORS。 这个选项可以在指定 JSON_UNESCAPED_UNICODE 选项的时候， 对于 U+2028 和 U+2029 这两个字符不再进行转义。

多子节字符

  • mb_ereg() 不接受无效的字节序列。
  • mb_ereg_replace() 不接受无效的字节序列。

PDO

  • PDO::lastInsertId() 在用于 PostgreSQL 数据库的时候， 如果当前会话（到 PostgreSQL 的数据库连接）上尚未调用过 nextval， 那么此方法会触发一个错误。

PostgreSQL

  • pg_last_notice() 增加一个用来指定操作的可选参数。 可使用以下常量作为此参数的值： PGSQL_NOTICE_LAST, PGSQL_NOTICE_ALL 或 PGSQL_NOTICE_CLEAR。
  • pg_fetch_all() 增加第二个参数，这是一个可选参数， 它用来指定返回结果的类型 （类似于 pg_fetch_array() 的第三个参数）。
  • pg_select() 增加第四个参数，这是一个可选参数， 它用来指定返回结果的类型 （类似于 pg_fetch_array() 的第三个参数）。

Session

  • session_start() 当无法成功初始化会话的时候，返回 false， 并且不会初始化超级变量 $_SESSION。


其它改动

无效字符串计算的通知和警告

New E_WARNING and E_NOTICE errors have been introduced when invalid strings are coerced using operators expecting numbers (+ - * / ** % << >> | & ^) or their assignment equivalents. An E_NOTICE is emitted when the string begins with a numeric value but contains trailing non-numeric characters, and an E_WARNING is emitted when the string does not contain a numeric value.

<?php
'1b' + 'something';

以上例程会输出：

Notice: A non well formed numeric value encountered in %s on line %d
Warning: A non-numeric value encountered in %s on line %d

八进制转义序列溢出时发出警告

Previously, 3-octet octal string escape sequences would overflow silently. Now, they will still overflow, but E_WARNING will be emitted.

<?php
var_dump("\500");

以上例程会输出：

Warning: Octal escape sequence overflow \500 is greater than \377 in %s on line %d
string(1) "@"

$this 不一致的修正

Whilst $this is considered a special variable in PHP, it lacked proper checks to ensure it wasn't used as a variable name or reassigned. This has now been rectified to ensure that $this cannot be a user-defined variable, reassigned to a different value, or be globalised.

无需散列即可生成 Session ID

Session ID 将不再在生成时进行哈希。这一变化，会导致以下四个 ini 设置不再使用：

  • session.entropy_file
  • session.entropy_length
  • session.hash_function
  • session.hash_bits_per_character

并增加以下两个 ini 设置：

  • session.sid_length - 定义会话 ID 的长度（为了向后兼容，默认为 32 个字符）
  • session.sid_bits_per_character - 定义了每个字符的存储位数（即增加了会话 ID 中可使用的字符范围），为了向后兼容，默认为 4

INI 文件处理的变化

precision

If the value is set to -1, then the dtoa mode 0 is used. The default value is still 14.

serialize_precision

If the value is set to -1, then the dtoa mode 0 is used. The value -1 is now used by default.

gd.jpeg_ignore_warning

The default of this php.ini setting has been changed to 1, so by default libjpeg warnings are ignored.

opcache.enable_cli

The default of this php.ini setting has been changed to 1 (enabled) in PHP 7.1.2, and back to 0 (disabled) in PHP 7.1.7.

Session ID generation with a CSPRNG only

Session IDs will now only be generated with a CSPRNG.

More informative TypeError messages when null is allowed

TypeError exceptions for arg_info type checks will now provide more informative error messages. If the parameter type or return type accepts null (by either having a default value of null or being a nullable type), then the error message will now mention this with a message of "must be ... or null" or "must ... or be null."


Windows 支持

Support for long and UTF-8 path

If a web application is UTF-8 conform, no further action is required. For applications depending on paths in non UTF-8 encodings for I/O, an explicit INI directive has to be set. The encoding INI settings check relies on the order in the core:

  • internal_encoding
  • default_charset
  • zend.multibyte

Several functions for codepage handling were introduced:

  • sapi_windows_cp_set() to set the default codepage
  • sapi_windows_cp_get() to retrieve the current codepage
  • sapi_windows_cp_is_utf8()
  • sapi_windows_cp_conv() to convert between codepages, using iconv() compatible signature

These functions are thread safe.

The console output codepage is adjusted depending on the encoding used in PHP. Depending on the concrete system OEM codepage, the visible output might or might be not correct. For example, in the default cmd.exe and on a system with the OEM codepage 437, outputs in codepages 1251, 1252, 1253 and some others can be shown correctly when using UTF-8. On the same system, chars in codepage like 20932 probably won't be shown correctly. This refers to the particular system rules for codepage, font compatibility and the particular console program used. PHP automatically sets the console codepage according to the encoding rules from php.ini. Using alternative consoles instead of cmd.exe directly might bring better experience in some cases.

Nevertheless be aware, runtime codepage switch after the request start might bring unexpected side effects on CLI. The preferable way is php.ini, When PHP CLI is used in a console emulator, that doesn't support Unicode, it might possibly be required, to avoid changing the console codepage. The best way to achieve it is by setting the default or internal encoding to correspond the ANSI codepage. Another method is to set the INI directives output_encoding and input_encoding to the required codepage, in which case however the difference between internal and I/O codepage is likely to cause mojibake. In rare cases, if PHP happens to crash gracefully, the original console codepage might be not restored. In this case, the chcp command can be used, to restore it manually.

Special awareness for the DBCS systems - the codepage switch on runtime using ini_set() is likely to cause display issues. The difference to the non DBCS systems is, that the extended characters require two console cells to be displayed. In certain case, only the mapping of the characters into the glyph set of the font could happen, no actual font change. This is the nature of DBCS systems, the most simple way to prevent display issues is to avoid usage of ini_set() for the codepage change.

As a result of UTF-8 support in the streams, PHP scripts are not limited to ASCII or ANSI filenames anymore. This is supported out of the box on CLI. For other SAPI, the documentation for the corresponding server is useful.

Long paths support is transparent. Paths longer than 260 bytes get automatically prefixed with \\?\. The max path length is limited to 2048 bytes. Be aware, that the path segment limit (basename length) still persists.

For the best portability, it is strongely recommended to handle filenames, I/O and other related topics UTF-8. Additionally, for the console applications, the usage of a TrueType font is preferable and the usage of ini_set() for the codepage change is discouraged.

readline

readline 扩展 现在通过 » WinEditLine 库 来实现了支持。因此，一个交互式的 CLI 命令行也得到了支持。(php.exe -a)。

PHP_FCGI_CHILDREN

PHP_FCGI_CHILDREN is now respected. If this environment variable is defined, the first php-cgi.exe process will exec the specified number of children. These will share the same TCP socket.

ftok()

Added support for ftok()


从 PHP 5.6.x 移植到 PHP 7.0.x

Table of Contents

  • 不向后兼容的变更
  • 新特性
  • PHP 7.0.x 弃用的功能
  • 变更的函数
  • 新函数
  • 新的类和接口
  • 新的全局常量
  • SAPI 模块的变化
  • 移除的扩展和 SAPI
  • Other Changes

尽管 PHP 7.0 是一个新的大版本，我们仍将致力于使迁移变得平缓。 这个版本主要消除在之前版本中不推荐使用的内容，使得语言变得更加通用一致。

这儿有一些值得关注的 少量的兼容性调整 以及 新的特性，同时在生产环境切换 PHP 版本之前，应该对代码进行测试。


不向后兼容的变更

错误和异常处理相关的变更

在 PHP 7 中，很多致命错误以及可恢复的致命错误，都被转换为异常来处理了。 这些异常继承自 Error 类，此类实现了 Throwable 接口 （所有异常都实现了这个基础接口）。

这也意味着，当发生错误的时候，以前代码中的一些错误处理的代码将无法被触发。 因为在 PHP 7 版本中，已经使用抛出异常的错误处理机制了。 （如果代码中没有捕获 Error 异常，那么会引发致命错误）。

PHP 7 中的错误处理的更完整的描述，请参见 PHP 7 错误处理。 本迁移指导主要是列出对兼容性有影响的变更。

set_exception_handler() 不再保证收到的一定是 Exception 对象

抛出 Error 对象时，如果 set_exception_handler() 里的异常处理代码声明了类型 Exception ，将会导致 fatal error。

想要异常处理器同时支持 PHP5 和 PHP7，应该删掉异常处理器里的类型声明。如果代码仅仅是升级到 PHP7，则可以把类型 Exception 替换成 Throwable。

<?php
// PHP 5 时代的代码将会出现问题
function handler(Exception $e) { ... }
set_exception_handler('handler');

// 兼容 PHP 5 和 7
function handler($e) { ... }

// 仅支持 PHP 7
function handler(Throwable $e) { ... }
?>

当内部构造器失败的时候，总是抛出异常

在之前版本中，如果内部类的构造器出错，会返回 null 或者一个不可用的对象。 从 PHP 7 开始，如果内部类构造器发生错误， 那么会抛出异常。

解析错误会抛出 ParseError 异常

解析错误会抛出 ParseError 异常。 对于 eval() 函数，需要将其包含到一个 catch 代码块中来处理解析错误。

E_STRICT 警告级别变更

原有的 E_STRICT 警告都被迁移到其他级别。 E_STRICT 常量会被保留，所以调用 error_reporting(E_ALL|E_STRICT) 不会引发错误。

E_STRICT 警告级别变更
场景 | 新的级别/行为
将资源类型的变量用作键来进行索引 | E_NOTICE
抽象静态方法 | 不再警告，会引发错误
重复定义构造器函数 | 不再警告，会引发错误
在继承的时候，方法签名不匹配 | E_WARNING
在两个 trait 中包含相同的（兼容的）属性 | 不再警告，会引发错误
以非静态调用的方式访问静态属性 | E_NOTICE
变量应该以引用的方式赋值 | E_NOTICE
变量应该以引用的方式传递（到函数参数中） | E_NOTICE
以静态方式调用实例方法 | E_DEPRECATED

关于变量处理的变化

PHP 7 现在使用了抽象语法树来解析源代码。这使得许多由于之前的PHP的解释器的限制所不可能实现的改进得以实现。 但出于一致性的原因导致了一些特殊例子的变动，而这些变动打破了向后兼容。 在这一章中将详细介绍这些例子。

关于间接使用变量、属性和方法的变化

对变量、属性和方法的间接调用现在将严格遵循从左到右的顺序来解析，而不是之前的混杂着几个特殊案例的情况。 下面这张表说明了这个解析顺序的变化。

间接调用的表达式的新旧解析顺序
表达式 | PHP 5 的解析方式 | PHP 7 的解析方式
$$foo['bar']['baz'] | ${$foo['bar']['baz']} | ($$foo)['bar']['baz']
$foo->$bar['baz'] | $foo->{$bar['baz']} | ($foo->$bar)['baz']
$foo->$bar['baz']() | $foo->{$bar['baz']}() | ($foo->$bar)['baz']()
Foo::$bar['baz']() | Foo::{$bar['baz']}() | (Foo::$bar)['baz']()

使用了旧的从右到左的解析顺序的代码必须被重写，明确的使用大括号来表明顺序（参见上表中间一列）。 这样使得代码既保持了与PHP 7.x的前向兼容性，又保持了与PHP 5.x的后向兼容性。

这同样影响了 global 关键字。如果需要的话可以使用大括号来模拟之前的行为。

<?php
function f() {
    // Valid in PHP 5 only.
    global $$foo->bar;

    // Valid in PHP 5 and 7.
    global ${$foo->bar};
}
?>

关于list()处理方式的变更

list() 不再以反向的顺序来进行赋值

list() 现在会按照变量定义的顺序来给他们进行赋值，而非反过来的顺序。 通常来说，这只会影响list() 与数组的[]操作符一起使用的案例，如下所示：

<?php
list($a[], $a[], $a[]) = [1, 2, 3];
var_dump($a);
?>

以上例程在 PHP 5 中的输出：

array(3) {
  [0]=>
  int(3)
  [1]=>
  int(2)
  [2]=>
  int(1)
}

以上例程在 PHP 7 中的输出：

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

总之，我们推荐不要依赖list()的赋值顺序，因为这是一个在未来也许会变更的实现细节。

空的list()赋值支持已经被移除

list() 结构现在不再能是空的。如下的例子不再被允许：

<?php
list() = $a;
list(,,) = $a;
list($x, list(), $y) = $a;
?>
list()不再能解开string

list() 不再能解开字符串（string）变量。 你可以使用str_split()来代替它。

Array ordering when elements are automatically created during by reference assignments has changed

The order of the elements in an array has changed when those elements have been automatically created by referencing them in a by reference assignment. For example:

<?php
$array = [];
$array["a"] =& $array["b"];
$array["b"] = 1;
var_dump($array);
?>

以上例程在 PHP 5 中的输出：

array(2) {
  ["b"]=>
  &int(1)
  ["a"]=>
  &int(1)
}

以上例程在 PHP 7 中的输出：

array(2) {
  ["a"]=>
  &int(1)
  ["b"]=>
  &int(1)
}

函数参数附近的括号不再影响行为

在 PHP 5中，在以引用方式传递函数参数时，使用冗余的括号对可以隐匿严格标准 的警告。现在，这个警告总会触发。

<?php
function getArray() {
    return [1, 2, 3];
}

function squareArray(array &$a) {
    foreach ($a as &$v) {
        $v **= 2;
    }
}

// Generates a warning in PHP 7.
squareArray((getArray()));
?>

以上例程会输出：

Notice: Only variables should be passed by reference in /tmp/test.php on line 13

foreach的变化

foreach发生了细微的变化，控制结构， 主要围绕阵列的内部数组指针和迭代处理的修改。

foreach不再改变内部数组指针

在PHP7之前，当数组通过 foreach 迭代时，数组指针会移动。现在开始，不再如此，见下面代码

<?php
$array = [0, 1, 2];
foreach ($array as &$val) {
    var_dump(current($array));
}
?>

以上例程在 PHP 5 中的输出：

int(1)
int(2)
bool(false)

以上例程在 PHP 7 中的输出：

int(0)
int(0)
int(0)

foreach 通过值遍历时，操作的值为数组的副本

当默认使用通过值遍历数组时，foreach 实际操作的是数组的迭代副本，而非数组本身。这就意味着，foreach 中的操作不会修改原数组的值。

foreach通过引用遍历时，有更好的迭代特性

当使用引用遍历数组时，现在 foreach 在迭代中能更好的跟踪变化。例如，在迭代中添加一个迭代值到数组中，参考下面的代码：

<?php
$array = [0];
foreach ($array as &$val) {
    var_dump($val);
    $array[1] = 1;
}
?>

以上例程在 PHP 5 中的输出：

int(0)

以上例程在 PHP 7 中的输出：

int(0)
int(1)

非Traversable 对象的遍历

迭代一个非Traversable对象将会与迭代一个引用数组的行为相同。 这将导致在对象添加或删除属性时， foreach通过引用遍历时，有更好的迭代特性也能被应用

Changes to integer handling

无效的八进制字符（Invalid octal literals）

在之前，一个八进制字符如果含有无效数字，该无效数字将被静默删节(0128 将被解析为 012). 现在这样的八进制字符将产生解析错误。

负位移运算（Negative bitshifts）

以负数形式进行的位移运算将会抛出一个 ArithmeticError：

<?php
var_dump(1 >> -1);
?>

以上例程在 PHP 5 中的输出：

int(0)

以上例程在 PHP 7 中的输出：

Fatal error: Uncaught ArithmeticError: Bit shift by negative number in /tmp/test.php:2
Stack trace:
#0 {main}
  thrown in /tmp/test.php on line 2

超范围后产生位移

超出 integer 位宽的位移操作（无论哪个方向）将始终得到 0 作为结果。在从前，这一操作是结构依赖的。

除以零的变化

之前的版本中，当 0 被做为除数时，无论是除数 (/) 或取模 (%) 操作，都会抛出一个 E_WARNING 错误并返回 false。现在，除法运算符 (/) 会返回一个由 IEEE 754 指定的浮点数：+INF, -INF 或 NAN。取模操作符 (%) 则会抛出一个 DivisionByZeroError 异常，并且不再产生 E_WARNING 错误。

<?php
var_dump(3/0);
var_dump(0/0);
var_dump(0%0);
?>

以上例程在 PHP 5 中的输出：

Warning: Division by zero in %s on line %d
bool(false)

Warning: Division by zero in %s on line %d
bool(false)

Warning: Division by zero in %s on line %d
bool(false)

以上例程在 PHP 7 中的输出：

Warning: Division by zero in %s on line %d
float(INF)

Warning: Division by zero in %s on line %d
float(NAN)

PHP Fatal error:  Uncaught DivisionByZeroError: Modulo by zero in %s line %d

string处理上的调整

十六进制字符串不再被认为是数字

含十六进制字符串不再被认为是数字。例如：

<?php
var_dump("0x123" == "291");
var_dump(is_numeric("0x123"));
var_dump("0xe" + "0x1");
var_dump(substr("foo", "0x1"));
?>

以上例程在 PHP 5 中的输出：

bool(true)
bool(true)
int(15)
string(2) "oo"

以上例程在 PHP 7 中的输出：

bool(false)
bool(false)
int(0)

Notice: A non well formed numeric value encountered in /tmp/test.php on line 5
string(3) "foo"

filter_var() 函数可以用于检查一个 string 是否含有十六进制数字,并将其转换为integer:

<?php
$str = "0xffff";
$int = filter_var($str, FILTER_VALIDATE_INT, FILTER_FLAG_ALLOW_HEX);
if (false === $int) {
    throw new Exception("Invalid integer!");
}
var_dump($int); // int(65535)
?>

\u{ 可能引起错误

由于新的 Unicode codepoint escape syntax语法， 紧连着无效序列并包含\u{ 的字串可能引起致命错误。 为了避免这一报错，应该避免反斜杠开头。

被移除的函数（Removed functions）

call_user_method() and call_user_method_array()

这两个函数从PHP 4.1.0 开始被废弃，应该使用 call_user_func() 和 call_user_func_array()。 你也可以考虑使用 变量函数 或者 ... 操作符。

所有的 ereg* 函数

所有 ereg 系列函数被删掉了。 PCRE 作为推荐的替代品。

mcrypt 别名

已废弃的 mcrypt_generic_end() 函数已被移除，请使用mcrypt_generic_deinit()代替。

此外，已废弃的 mcrypt_ecb(),
mcrypt_cbc(), mcrypt_cfb() 和
mcrypt_ofb() 函数已被移除，请配合恰当的MCRYPT_MODE_* 常量来使用 mcrypt_decrypt()进行代替。

所有 ext/mysql 函数

所有 ext/mysql 函数已被删掉了。 如何选择不同的 MySQL API，详情请见 选择 MySQL API。

所有 ext/mssql 函数

所有 ext/mssql 函数已被移除。

  • PDO_SQLSRV
  • PDO_ODBC
  • SQLSRV
  • Unified ODBC API

intl 别名

已废弃的 datefmt_set_timezone_id() 和
IntlDateFormatter::setTimeZoneID() 函数已被移除，请使用 datefmt_set_timezone() 与
IntlDateFormatter::setTimeZone()代替。

set_magic_quotes_runtime()

移除了 set_magic_quotes_runtime() 和它的别名 magic_quotes_runtime()。 它们在 PHP 5.3.0 中已经被废弃， 并由于 PHP 5.4.0 移除魔术引号（Magic Quotes）而没有用处。

set_socket_blocking()

已废弃的 set_socket_blocking() 函数已被移除，请使用stream_set_blocking()代替。

dl() in PHP-FPM

dl()在 PHP-FPM 不再可用，在 CLI 和 embed SAPIs 中仍可用。

GD Type1 functions

Support for PostScript Type1 fonts has been removed from the GD extension, resulting in the removal of the following functions:

  • imagepsbbox()
  • imagepsencodefont()
  • imagepsextendfont()
  • imagepsfreefont()
  • imagepsloadfont()
  • imagepsslantfont()
  • imagepstext()

推荐使用 TrueType 字体和相关的函数作为替代。

被移除掉的 INI 配置指令

被移除的功能

以下 INI 配置指令已经被移除，同时移除的还有其对应的功能

  • always_populate_raw_post_data
  • asp_tags

xsl.security_prefs

xsl.security_prefs 指令被移除 在预处理的时候，取而代之的方法 XsltProcessor::setSecurityPrefs() 应该被调用到

其他向后兼容相关的变更

new 操作符创建的对象不能以引用方式赋值给变量

new 语句创建的对象不能 以引用的方式赋值给变量。

<?php
class C {}
$c =& new C;
?>

以上例程在 PHP 5 中的输出：

Deprecated: Assigning the return value of new by reference is deprecated in /tmp/test.php on line 3

以上例程在 PHP 7 中的输出：

Parse error: syntax error, unexpected 'new' (T_NEW) in /tmp/test.php on line 3

无效的类、接口以及 trait 命名

不能以下列名字来命名类、接口以及 trait：

  • bool
  • int
  • float
  • string
  • null
  • true
  • false

此外，也不要使用下列的名字来命名类、接口以及 trait。虽然在 PHP 7.0 中， 这并不会引发错误， 但是这些名字是保留给将来使用的。

  • resource
  • object
  • mixed
  • numeric

移除了 ASP 和 script PHP 标签

使用类似 ASP 的标签，以及 script 标签来区分 PHP 代码的方式被移除。 受到影响的标签有：

被移除的 ASP 和 script 标签
开标签 | 闭标签
<% | %>
<%= | %>
<script language="php"> | </script>

从不匹配的上下文发起调用

在不匹配的上下文中以静态方式调用非静态方法， 在 PHP 5.6 中已经废弃， 但是在 PHP 7.0 中， 会导致被调用方法中未定义 $this 变量，以及此行为已经废弃的警告。

<?php
class A {
    public function test() { var_dump($this); }
}

// 注意：并没有从类 A 继承
class B {
    public function callNonStaticMethodOfA() { A::test(); }
}

(new B)->callNonStaticMethodOfA();
?>

以上例程在 PHP 5.6 中的输出：

Deprecated: Non-static method A::test() should not be called statically, assuming $this from incompatible context in /tmp/test.php on line 8
object(B)#1 (0) {
}

以上例程在 PHP 7 中的输出：

Deprecated: Non-static method A::test() should not be called statically in /tmp/test.php on line 8

Notice: Undefined variable: this in /tmp/test.php on line 3
NULL

yield 变更为右联接运算符

在使用 yield 关键字的时候，不再需要括号， 并且它变更为右联接操作符，其运算符优先级介于 print 和 => 之间。 这可能导致现有代码的行为发生改变：

<?php
echo yield -1;
// 在之前版本中会被解释为：
echo (yield) - 1;
// 现在，它将被解释为：
echo yield (-1);

yield $foo or die;
// 在之前版本中会被解释为：
yield ($foo or die);
// 现在，它将被解释为：
(yield $foo) or die;
?>

可以通过使用括号来消除歧义。

函数定义不可以包含多个同名参数

在函数定义中，不可以包含两个或多个同名的参数。 例如，下面代码中的函数定义会触发 E_COMPILE_ERROR 错误：

<?php
function foo($a, $b, $unused, $unused) {
    //
}
?>

Switch 语句不可以包含多个 default 块

在 switch 语句中，两个或者多个 default 块的代码已经不再被支持。 例如，下面代码中的 switch 语句会触发 E_COMPILE_ERROR 错误：

<?php
switch (1) {
    default:
    break;
    default:
    break;
}
?>

在函数中检视参数值会返回 当前 的值

当在函数代码中使用 func_get_arg() 或
func_get_args() 函数来检视参数值，
或者使用 debug_backtrace() 函数查看回溯跟踪，
以及在异常回溯中所报告的参数值是指参数当前的值（有可能是已经被函数内的代码改变过的值），
而不再是参数被传入函数时候的原始值了。

<?php
function foo($x) {
    $x++;
    var_dump(func_get_arg(0));
}
foo(1);?>

以上例程在 PHP 5 中的输出：

1

以上例程在 PHP 7 中的输出：

2

$HTTP_RAW_POST_DATA 被移除

不再提供 $HTTP_RAW_POST_DATA 变量。 请使用 php://input 作为替代。

INI 文件中 # 注释格式被移除

在 INI 文件中，不再支持以 # 开始的注释行， 请使用 ;（分号）来表示注释。 此变更适用于 php.ini 以及用 parse_ini_file() 和 parse_ini_string() 函数来处理的文件。

JSON 扩展已经被 JSOND 取代

JSON 扩展已经被 JSOND 扩展取代。 对于数值的处理，有以下两点需要注意的： 第一，数值不能以点号（.）结束 （例如，数值 34. 必须写作 34.0 或 34）。 第二，如果使用科学计数法表示数值，e 前面必须不是点号（.） （例如，3.e3 必须写作 3.0e3 或 3e3）。 另外，空字符串不再被视作有效的 JSON 字符串。

在数值溢出的时候，内部函数将会失败

将浮点数转换为整数的时候，如果浮点数值太大，导致无法以整数表达的情况下， 在之前的版本中，内部函数会直接将整数截断，并不会引发错误。 在 PHP 7.0 中，如果发生这种情况，会引发 E_WARNING 错误，并且返回 null。

自定义会话处理器的返回值修复

在自定义会话处理器中，如果函数的返回值不是 false，也不是 -1， 会引发致命错误。现在，如果这些函数的返回值不是布尔值，也不是 -1 或者 0，函数调用结果将被视为失败，并且引发 E_WARNING 错误。

相等的元素在排序时的顺序问题

由于内部排序算法进行了提升， 可能会导致对比时被视为相等的多个元素之间的顺序不稳定。

Note:

在对比时被视为相等的多个元素之间的排序顺序是不可信赖的，即使是相等的两个元素， 他们的位置也可能被排序算法所改变。

错误的使用 break 和 switch 语句

在循环或者 switch 语句之外使用 break 和 continue 被视为编译型错误（之前视为运行时错误），会引发 E_COMPILE_ERROR 错误。

Mhash 不再是一个单独的扩展了

Mhash 扩展已经被完全整合进 Hash 扩展了。
因此，不要再使用 extension_loaded() 函数来检测是否支持 MHash 扩展了，
建议使用 function_exists() 函数来进行检测。
另外，函数 get_loaded_extensions() 以及相关的特性中，也不再报告
和 MHash 扩展相关的信息了。

declare(ticks)

declare(ticks) 指示符不再泄漏到不同的编译单元中。


新特性

标量类型声明

标量类型声明 有两种模式: 强制 (默认) 和 严格模式。 现在可以使用下列类型参数（无论用强制模式还是严格模式）： 字符串(string), 整数 (int), 浮点数 (float), 以及布尔值 (bool)。它们扩充了PHP5中引入的其他类型：类名，接口，数组和 回调类型。

<?php
// Coercive mode
function sumOfInts(int ...$ints)
{
    return array_sum($ints);
}

var_dump(sumOfInts(2, '3', 4.1));

以上例程会输出：

int(9)

要使用严格模式，一个 declare 声明指令必须放在文件的顶部。这意味着严格声明标量是基于文件可配的。 这个指令不仅影响参数的类型声明，也影响到函数的返回值声明（参见 返回值类型声明, 内置的PHP函数以及扩展中加载的PHP函数）

完整的标量类型声明文档和示例参见类型声明章节。

返回值类型声明

PHP 7 增加了对返回类型声明的支持。 类似于参数类型声明，返回类型声明指明了函数返回值的类型。可用的类型与参数声明中可用的类型相同。

<?php

function arraysSum(array ...$arrays): array
{
    return array_map(function(array $array): int {
        return array_sum($array);
    }, $arrays);
}

print_r(arraysSum([1,2,3], [4,5,6], [7,8,9]));

以上例程会输出：

Array
(
    [0] => 6
    [1] => 15
    [2] => 24
)

完整的标量类型声明文档和示例可参见 返回值类型声明.

null合并运算符

由于日常使用中存在大量同时使用三元表达式和 isset()的情况， 我们添加了null合并运算符 (??) 这个语法糖。如果变量存在且值不为null， 它就会返回自身的值，否则返回它的第二个操作数。

<?php
// Fetches the value of $_GET['user'] and returns 'nobody'
// if it does not exist.
$username = $_GET['user'] ?? 'nobody';
// This is equivalent to:
$username = isset($_GET['user']) ? $_GET['user'] : 'nobody';

// Coalesces can be chained: this will return the first
// defined value out of $_GET['user'], $_POST['user'], and
// 'nobody'.
$username = $_GET['user'] ?? $_POST['user'] ?? 'nobody';
?>

太空船操作符（组合比较符）

太空船操作符用于比较两个表达式。当$a小于、等于或大于$b时它分别返回-1、0或1。 比较的原则是沿用 PHP 的常规比较规则进行的。

<?php
// 整数
echo 1 <=> 1; // 0
echo 1 <=> 2; // -1
echo 2 <=> 1; // 1

// 浮点数
echo 1.5 <=> 1.5; // 0
echo 1.5 <=> 2.5; // -1
echo 2.5 <=> 1.5; // 1

// 字符串
echo "a" <=> "a"; // 0
echo "a" <=> "b"; // -1
echo "b" <=> "a"; // 1
?>

通过 define() 定义常量数组

Array 类型的常量现在可以通过 define() 来定义。在 PHP5.6 中仅能通过 const 定义。

<?php
define('ANIMALS', [
    'dog',
    'cat',
    'bird'
]);

echo ANIMALS[1]; // 输出 "cat"
?>

匿名类

现在支持通过new class 来实例化一个匿名类，这可以用来替代一些"用后即焚"的完整类定义。

<?php
interface Logger {
    public function log(string $msg);
}

class Application {
    private $logger;

    public function getLogger(): Logger {
         return $this->logger;
    }

    public function setLogger(Logger $logger) {
         $this->logger = $logger;
    }
}

$app = new Application;
$app->setLogger(new class implements Logger {
    public function log(string $msg) {
        echo $msg;
    }
});

var_dump($app->getLogger());
?>

以上例程会输出：

object(class@anonymous)#2 (0) {
}

详细文档可以参考 匿名类.

Unicode codepoint 转译语法

这接受一个以16进制形式的 Unicode codepoint，并打印出一个双引号或heredoc包围的 UTF-8 编码格式的字符串。 可以接受任何有效的 codepoint，并且开头的 0 是可以省略的。

echo "\u{aa}";
echo "\u{0000aa}";
echo "\u{9999}";

以上例程会输出：

a
a (same as before but with optional leading 0's)
香

Closure::call()

Closure::call() 现在有着更好的性能，简短干练的暂时绑定一个方法到对象上闭包并调用它。

<?php
class A {private $x = 1;}

// PHP 7 之前版本的代码
$getXCB = function() {return $this->x;};
$getX = $getXCB->bindTo(new A, 'A'); // 中间层闭包
echo $getX();

// PHP 7+ 及更高版本的代码
$getX = function() {return $this->x;};
echo $getX->call(new A);

以上例程会输出：

1
1

为unserialize()提供过滤

这个特性旨在提供更安全的方式解包不可靠的数据。它通过白名单的方式来防止潜在的代码注入。

<?php

// 将所有的对象都转换为 __PHP_Incomplete_Class 对象
$data = unserialize($foo, ["allowed_classes" => false]);

// 将除 MyClass 和 MyClass2 之外的所有对象都转换为 __PHP_Incomplete_Class 对象
$data = unserialize($foo, ["allowed_classes" => ["MyClass", "MyClass2"]);

// 默认情况下所有的类都是可接受的，等同于省略第二个参数
$data = unserialize($foo, ["allowed_classes" => true]);

IntlChar

新增加的 IntlChar 类旨在暴露出更多的 ICU 功能。这个类自身定义了许多静态方法用于操作多字符集的 unicode 字符。

<?php

printf('%x', IntlChar::CODEPOINT_MAX);
echo IntlChar::charName('@');
var_dump(IntlChar::ispunct('!'));

以上例程会输出：

10ffff
COMMERCIAL AT
bool(true)

若要使用此类，请先安装Intl扩展

预期

预期是向后兼用并增强之前的 assert() 的方法。 它使得在生产环境中启用断言为零成本，并且提供当断言失败时抛出特定异常的能力。

老版本的API出于兼容目的将继续被维护，assert()现在是一个语言结构，它允许第一个参数是一个表达式，而不仅仅是一个待计算的 string或一个待测试的boolean。

<?php
ini_set('assert.exception', 1);

class CustomError extends AssertionError {}

assert(false, new CustomError('Some error message'));
?>

以上例程会输出：

Fatal error: Uncaught CustomError: Some error message

关于这个特性的完整说明，包括如何在开发和生产环境中配置它，可以在assert()的 expectations section章节找到。

Group use declarations

从同一 namespace 导入的类、函数和常量现在可以通过单个 use 语句 一次性导入了。

<?php

// PHP 7 之前的代码
use some\namespace\ClassA;
use some\namespace\ClassB;
use some\namespace\ClassC as C;

use function some\namespace\fn_a;
use function some\namespace\fn_b;
use function some\namespace\fn_c;

use const some\namespace\ConstA;
use const some\namespace\ConstB;
use const some\namespace\ConstC;

// PHP 7+ 及更高版本的代码
use some\namespace\{ClassA, ClassB, ClassC as C};
use function some\namespace\{fn_a, fn_b, fn_c};
use const some\namespace\{ConstA, ConstB, ConstC};
?>

生成器可以返回表达式

此特性基于 PHP 5.5 版本中引入的生成器特性构建的。 它允许在生成器函数中通过使用 return 语法来返回一个表达式 （但是不允许返回引用值）， 可以通过调用 Generator::getReturn() 方法来获取生成器的返回值， 但是这个方法只能在生成器完成产生工作以后调用一次。

<?php

$gen = (function() {
    yield 1;
    yield 2;

    return 3;
})();

foreach ($gen as $val) {
    echo $val, PHP_EOL;
}

echo $gen->getReturn(), PHP_EOL;

以上例程会输出：

1
2
3

在生成器中能够返回最终的值是一个非常便利的特性， 因为它使得调用生成器的客户端代码可以直接得到生成器（或者其他协同计算）的返回值， 相对于之前版本中客户端代码必须先检查生成器是否产生了最终的值然后再进行响应处理 来得方便多了。

Generator delegation

现在，只需在最外层生成其中使用 yield from， 就可以把一个生成器自动委派给其他的生成器， Traversable 对象或者 array。

<?php

function gen()
{
    yield 1;
    yield 2;

    yield from gen2();
}

function gen2()
{
    yield 3;
    yield 4;
}

foreach (gen() as $val)
{
    echo $val, PHP_EOL;
}

?>

以上例程会输出：

1
2
3
4

整数除法函数 intdiv()

新加的函数 intdiv() 用来进行 整数的除法运算。

<?php

var_dump(intdiv(10, 3));
?>

以上例程会输出：

int(3)

会话选项

session_start() 可以接受一个 array 作为参数， 用来覆盖 php.ini 文件中设置的 会话配置选项。

在调用 session_start() 的时候， 传入的选项参数中也支持 session.lazy_write 行为， 默认情况下这个配置项是打开的。它的作用是控制 PHP 只有在会话中的数据发生变化的时候才 写入会话存储文件，如果会话中的数据没有发生改变，那么 PHP 会在读取完会话数据之后， 立即关闭会话存储文件，不做任何修改，可以通过设置 read_and_close 来实现。

例如，下列代码设置 session.cache_limiter 为 private，并且在读取完毕会话数据之后马上关闭会话存储文件。

<?php
session_start([
    'cache_limiter' => 'private',
    'read_and_close' => true,
]);
?>

preg_replace_callback_array()

在 PHP 7 之前，当使用 preg_replace_callback() 函数的时候， 由于针对每个正则表达式都要执行回调函数，可能导致过多的分支代码。 而使用新加的 preg_replace_callback_array() 函数， 可以使得代码更加简洁。

现在，可以使用一个关联数组来对每个正则表达式注册回调函数， 正则表达式本身作为关联数组的键， 而对应的回调函数就是关联数组的值。

CSPRNG Functions

新加入两个跨平台的函数： random_bytes() 和 random_int() 用来产生高安全级别的随机字符串和随机整数。

可以使用 list() 函数来展开实现了 ArrayAccess 接口的对象

在之前版本中，list() 函数不能保证 正确的展开实现了 ArrayAccess 接口的对象， 现在这个问题已经被修复。

其他特性

  • 允许在克隆表达式上访问对象成员，例如： (clone $foo)->bar()。


PHP 7.0.x 弃用的功能

PHP4 风格的构造函数

PHP4 风格的构造函数（方法名和类名一样）将被弃用，并在将来移除。 如果在类中仅使用了 PHP4 风格的构造函数，PHP7 会产生 E_DEPRECATED 警告。 如果还定义了 __construct() 方法则不受影响。

<?php
class foo {
    function foo() {
        echo 'I am the constructor';
    }
}
?>

以上例程会输出：

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; foo has a deprecated constructor in example.php on line 3

静态调用非静态的方法

废弃了 静态（Static） 调用未声明成 static 的方法，未来可能会彻底移除该功能。

<?php
class foo {
    function bar() {
        echo 'I am not static!';
    }
}

foo::bar();
?>

以上例程会输出：

Deprecated: Non-static method foo::bar() should not be called statically in - on line 8
I am not static!

password_hash() 盐值选项

废弃了 password_hash() 函数中的盐值选项，阻止开发者生成自己的盐值（通常更不安全）。 开发者不传该值时，该函数自己会生成密码学安全的盐值。因此再无必要传入自己自定义的盐值。

capture_session_meta SSL 上下文选项

废弃了 capture_session_meta 内的 SSL 上下文选项。 现在可以通过 stream_get_meta_data() 获取 SSL 元数据（metadata）。

LDAP 中的废弃

以下函数已被废弃：

  • ldap_sort()


变更的函数

PHP 核心

  • debug_zval_dump() 现在打印 "int" 替代 "long", 打印 "float" 替代 "double"
  • dirname() 增加了可选的第二个参数, depth, 获取当前目录向上 depth 级父目录的名称。
  • getrusage() 现在支持 Windows.
  • mktime() and gmmktime() 函数不再接受 is_dst 参数。
  • preg_replace() 函数不再支持 "\e" (PREG_REPLACE_EVAL). 应当使用 preg_replace_callback() 替代。
  • setlocale() 函数不再接受 category 传入字符串。 应当使用 LC_* 常量。
  • exec(), system() and passthru() 函数对 NULL 增加了保护.
  • shmop_open() 现在返回一个资源而非一个int， 这个资源可以传给shmop_size(), shmop_write(), shmop_read(), shmop_close() 和 shmop_delete().
  • substr() 现在当 start 的值与 string 的长度相同时将返回一个空字符串。
  • xml_parser_free()不再足以释放解析器资源，如果它引用了一个对象，而这个对象又引用了那个解析器资源。在这种情况下，需要额外地取消设置 $parser。


新函数

Closure

  • Closure::call()

CSPRNG

  • random_bytes()
  • random_int()

错误处理和日志

  • error_clear_last()

Generator

  • Generator::getReturn()

GNU 多重精度

  • gmp_random_seed()

Math

  • intdiv()

PCRE

  • preg_replace_callback_array()

PHP 选项和信息

  • gc_mem_caches()
  • get_resources()

POSIX

  • posix_setrlimit()

Reflection

  • ReflectionParameter::getType()
  • ReflectionParameter::hasType()
  • ReflectionFunctionAbstract::getReturnType()
  • ReflectionFunctionAbstract::hasReturnType()

Zip

  • ZipArchive::setCompressionIndex()
  • ZipArchive::setCompressionName()

Zlib Compression

  • inflate_add()
  • deflate_add()
  • inflate_init()
  • deflate_init()


新的类和接口

Intl

  • IntlChar

Reflection

  • ReflectionGenerator
  • ReflectionType

会话（Session）管理器

  • SessionUpdateTimestampHandlerInterface

Exception 等级

  • Throwable
  • Error
  • TypeError
  • ParseError
  • AssertionError
  • ArithmeticError
  • DivisionByZeroError


新的全局常量

内核预定义常量

  • PHP_INT_MIN

GD

  • IMG_WEBP (自 PHP 7.0.10 起)

JSON

  • JSON_ERROR_INVALID_PROPERTY_NAME
  • JSON_ERROR_UTF16

LibXML

  • LIBXML_BIGLINES

PCRE

  • PREG_JIT_STACKLIMIT_ERROR

POSIX

  • POSIX_RLIMIT_AS
  • POSIX_RLIMIT_CORE
  • POSIX_RLIMIT_CPU
  • POSIX_RLIMIT_DATA
  • POSIX_RLIMIT_FSIZE
  • POSIX_RLIMIT_LOCKS
  • POSIX_RLIMIT_MEMLOCK
  • POSIX_RLIMIT_MSGQUEUE
  • POSIX_RLIMIT_NICE
  • POSIX_RLIMIT_NOFILE
  • POSIX_RLIMIT_NPROC
  • POSIX_RLIMIT_RSS
  • POSIX_RLIMIT_RTPRIO
  • POSIX_RLIMIT_RTTIME
  • POSIX_RLIMIT_SIGPENDING
  • POSIX_RLIMIT_STACK
  • POSIX_RLIMIT_INFINITY

Zlib

  • ZLIB_ENCODING_RAW
  • ZLIB_ENCODING_DEFLATE
  • ZLIB_ENCODING_GZIP
  • ZLIB_FILTERED
  • ZLIB_HUFFMAN_ONLY
  • ZLIB_FIXED
  • ZLIB_RLE
  • ZLIB_DEFAULT_STRATEGY
  • ZLIB_BLOCK
  • ZLIB_FINISH
  • ZLIB_FULL_FLUSH
  • ZLIB_NO_FLUSH
  • ZLIB_PARTIAL_FLUSH
  • ZLIB_SYNC_FLUSH


SAPI 模块的变化

FPM

listen 端口现在同时监听 IPv4 和 IPv6 地址。

在 PHP 5 中，listen 指令如果仅带一个端口数字， 则会监听所有网络接口，但只是 IPv4。 现在 PHP 7 会同时接受来自 IPv4 和 IPv6 上的请求。

指定了 ip 地址后不受此影响；它们会继续仅仅监听在指定的地址和协议上。


移除的扩展和 SAPI

移除的扩展

  • ereg
  • mssql
  • mysql
  • sybase_ct

移除的 SAPI

  • aolserver
  • apache
  • apache_hooks
  • apache2filter
  • caudium
  • continuity
  • isapi
  • milter
  • nsapi
  • phttpd
  • pi3web
  • roxen
  • thttpd
  • tux
  • webjames


Other Changes

放宽了保留词限制

现在允许全局保留词用于类/接口/Trait 中的属性、常量和方法名。 在引入新关键词时，此变更减少了对向后兼容的破坏，避免了 API 命名的限制。

使用流畅的接口实现内部 DSL 时，这非常有用：

<?php
// 以前不能用  'new'、'private' 和 'for'
Project::new('Project Name')->private()->for('purpose here')->with('username here');
?>

唯一的限制是： class关键词不能用于常量名，否则会和 类名解析语法冲突 (ClassName::class)。

移除 date.timezone 警告

调用任意 date- 开头或者其他基于时间的函数时， 未设置 date.timezone INI 设置的情况下， 之前会产生警告。 现在移除了警告（date.timezone 默认仍然是 UTC）


从 PHP 5.5.x 移植到 PHP 5.6.x

Table of Contents

  • 向后不兼容
  • 新特性
  • PHP 5.6.x 中已废止的特性
  • 函数的变化
  • 新加函数
  • OpenSSL changes in PHP 5.6.x
  • 扩展中的变动
  • 新加的全局常量

PHP 5.6 中大多数的改善对旧项目没有影响。有一些 不兼容处 和 新功能 需要 注意下，并且在正式布署升级后的项目前应该测试您的代码。


向后不兼容

虽然大部分 PHP 5 的代码无需修改即可正常运行， 但是有部分代码是无法向后兼容的：

使用数组标识符为类定义数组类型的属性时，数组的键不会被覆盖

在 PHP 5.6 之前的版本中，为类定义数组类型的属性时， 如果数组中同时使用了显式数组键和隐式数组键，并且显式的键和隐式的序列键相同， 那么数组的键将被覆盖。例如：

<?php
class C {
    const ONE = 1;
    public $array = [
        self::ONE => 'foo',
        'bar',
        'quux',
    ];
}

var_dump((new C)->array);
?>

以上例程在 PHP 5.5 中的输出：

array(2) {
  [0]=>
  string(3) "bar"
  [1]=>
  string(4) "quux"
}

以上例程在 PHP 5.6 中的输出：

array(3) {
  [1]=>
  string(3) "foo"
  [2]=>
  string(3) "bar"
  [3]=>
  string(4) "quux"
}

严格的 json_decode()

对于 JSON 字面量 true，false 和
null，如果不采用小写格式，将会被 json_decode() 函数拒绝，
同时相应的设置 json_last_error()。
在之前的版本中，json_decode() 函数可以接受这些字面量的
全部大写或者大小写混写的格式。

此变更仅会影响传入到 json_decode() 中的 JSON 格式无效的情况， 有效的 JSON 输入不会受到影响并且能够正确解析。

当使用 SSL/TLS 的时候，流封装器默认验证端点证书和主机名

All encrypted client streams now enable peer verification by default. By default, this will use OpenSSL's default CA bundle to verify the peer certificate. In most cases, no changes will need to be made to communicate with servers with valid SSL certificates, as distributors generally configure OpenSSL to use known good CA bundles.

The default CA bundle may be overridden on a global basis by setting either the openssl.cafile or openssl.capath configuration setting, or on a per request basis by using the cafile or capath context options.

While not recommended in general, it is possible to disable peer certificate verification for a request by setting the verify_peer context option to false, and to disable peer name validation by setting the verify_peer_name context option to false.

GMP 资源现为对象

GMP 资源现为对象。 GMP 扩展中的基于函数的 API 实现不受影响， 只有在代码中使用 is_resource() 或类似函数 来显示检测是否资源类型的代码才会受到影响。

Mcrypt 函数需要有效长度的密钥和初始向量

mcrypt_encrypt()，mcrypt_decrypt()，
mcrypt_cbc()，mcrypt_cfb()，
mcrypt_ecb()，mcrypt_generic() 以及
mcrypt_ofb() 函数不再接受无效长度的密钥和初始向量，
对于需要初始向量的分组加密模式，如果不提供初始向量，函数调用将会失败。

cURL 文件上传

必须先设置 CURLOPT_SAFE_UPLOAD 为 false 才能够使用 @file 语法来上传文件。 建议使用 CURLFile 类来上传文件。


新特性

使用表达式定义常量

在之前的 PHP 版本中， 必须使用静态值来定义常量，声明属性以及指定函数参数默认值。 现在你可以使用包括数值、字符串字面量以及其他常量在内的数值表达式来 定义常量、声明属性以及设置函数参数默认值。

<?php
const ONE = 1;
const TWO = ONE * 2;

class C {
    const THREE = TWO + 1;
    const ONE_THIRD = ONE / self::THREE;
    const SENTENCE = 'The value of THREE is '.self::THREE;

    public function f($a = ONE + self::THREE) {
        return $a;
    }
}

echo (new C)->f()."\n";
echo C::SENTENCE;
?>

以上例程会输出：

4
The value of THREE is 3

现在可以通过 const 关键字来定义类型为 array 的常量。

<?php
const ARR = ['a', 'b'];

echo ARR[0];
?>

以上例程会输出：

a

使用 ... 运算符定义变长参数函数

现在可以不依赖 func_get_args()， 使用 ... 运算符 来实现 变长参数函数。

<?php
function f($req, $opt = null, ...$params) {
    // $params 是一个包含了剩余参数的数组
    printf('$req: %d; $opt: %d; number of params: %d'."\n",
           $req, $opt, count($params));
}

f(1);
f(1, 2);
f(1, 2, 3);
f(1, 2, 3, 4);
f(1, 2, 3, 4, 5);
?>

以上例程会输出：

$req: 1; $opt: 0; number of params: 0
$req: 1; $opt: 2; number of params: 0
$req: 1; $opt: 2; number of params: 1
$req: 1; $opt: 2; number of params: 2
$req: 1; $opt: 2; number of params: 3

使用 ... 运算符进行参数展开

在调用函数的时候，使用 ... 运算符， 将 数组 和 可遍历 对象展开为函数参数。 在其他编程语言，比如 Ruby中，这被称为连接运算符，。

<?php
function add($a, $b, $c) {
    return $a + $b + $c;
}

$operators = [2, 3];
echo add(1, ...$operators);
?>

以上例程会输出：

6

使用 ** 进行幂运算

加入右连接运算符 ** 来进行幂运算。 同时还支持简写的 **= 运算符，表示进行幂运算并赋值。

<?php
printf("2 ** 3 ==      %d\n", 2 ** 3);
printf("2 ** 3 ** 2 == %d\n", 2 ** 3 ** 2);

$a = 2;
$a **= 3;
printf("a ==           %d\n", $a);
?>

以上例程会输出：

2 ** 3 ==      8
2 ** 3 ** 2 == 512
a ==           8

use function 以及 use const

use 运算符 被进行了扩展以支持在类中导入外部的函数和常量。 对应的结构为 use function 和 use const。

<?php
namespace Name\Space {
    const FOO = 42;
    function f() { echo __FUNCTION__."\n"; }
}

namespace {
    use const Name\Space\FOO;
    use function Name\Space\f;

    echo FOO."\n";
    f();
}
?>

以上例程会输出：

42
Name\Space\f

phpdbg

PHP 的 SAPI 模块中实现了一个 交互式调试器，叫做 phpdbg。更多信息，请访问 phpdbg documentation。

默认字符编码

对于一些字符编码相关的函数，例如 htmlentities()， html_entity_decode() 以及 htmlspecialchars() 使用 default_charset 作为默认字符集。请注意，对于 iconv（现已废弃） 和 mbstring 相关的函数， 如果分别设置了他们的编码， 那么这些对应设置的优先级高于 default_charset。

default_charset 的默认值是 UTF-8。

php://input 是可重用的了

只要你需要，你可以多次打开并读取 php://input。 同时，这个特性使得在处理 POST 的数据的时候， 可以明显降低对于内存的需求量。

大文件上传

现在可以支持大于 2GB 的文件上传。

GMP 支持运算符重载

GMP 支持运算符重载， 并且造型成数值类型。 这使得使用 GMP 的代码更加直观。

<?php
$a = gmp_init(42);
$b = gmp_init(17);

if (version_compare(PHP_VERSION, '5.6', '<')) {
    echo gmp_intval(gmp_add($a, $b)), PHP_EOL;
    echo gmp_intval(gmp_add($a, 17)), PHP_EOL;
    echo gmp_intval(gmp_add(42, $b)), PHP_EOL;
} else {
    echo $a + $b, PHP_EOL;
    echo $a + 17, PHP_EOL;
    echo 42 + $b, PHP_EOL;
}
?>

以上例程会输出：

59
59
59

使用 hash_equals() 比较字符串避免时序攻击

加入 hash_equals() 函数， 以恒定的时间消耗来进行字符串比较， 以避免时序攻击。 比如当比较 crypt() 密码散列值的时候，就可以使用此函数。 （假定你不能使用 password_hash() 和 password_verify()， 这两个函数也可以抵抗时序攻击）

<?php
$expected  = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$correct   = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$incorrect = crypt('1234',  '$2a$07$usesomesillystringforsalt$');

var_dump(hash_equals($expected, $correct));
var_dump(hash_equals($expected, $incorrect));
?>

以上例程会输出：

bool(true)
bool(false)

__debugInfo()

加入 __debugInfo()， 当使用 var_dump() 输出对象的时候， 可以用来控制要输出的属性和值。

<?php
class C {
    private $prop;

    public function __construct($val) {
        $this->prop = $val;
    }

    public function __debugInfo() {
        return [
            'propSquared' => $this->prop ** 2,
        ];
    }
}

var_dump(new C(42));
?>

以上例程会输出：

object(C)#1 (1) {
  ["propSquared"]=>
  int(1764)
}

gost-crypto 散列算法

加入 gost-crypto 散列算法。 它使用 » RFC 4357, 11.2 小节 定义的 CryptoPro S-box 表实现了 GOST 散列函数。

SSL/TLS 提升

在 PHP 5.6 中对 SSL/TLS 的支持进行了大幅度的提升。 这其中包括 默认启用端点验证 选项来支持证书指纹比对， 以避免 TLS 重新协商攻击。 还增加了很多 SSL 上下文选项， 以便在使用加密流的时候， 能够更好的控制协议和验证的相关设置。

这些变动在 PHP 5.6.x 中的 OpenSSL 变更 中有详细描述。

pgsql 异步支持

pgsql 扩展现在支持 异步方式连接数据库及执行查询， 也即可以使用非阻塞的方式和 PostgreSQL 数据库进行交互。 使用 PGSQL_CONNECT_ASYNC 常量可以 建立异步连接，pg_connect_poll()， pg_socket()， pg_consume_input() 和 pg_flush() 函数 可以用来处理异步连接和查询。


PHP 5.6.x 中已废止的特性

从不兼容的上下文调用方法

现在已废止从不兼容的上下文调用方法， 并且产生 E_DEPRECATED 错误 （以前是 E_STRICT）。 在 PHP 的后续版本中可能彻底移除对此特性的支持。

以下是不兼容上下文调用方法的示例：

<?php
class A {
    function f() { echo get_class($this); }
}

class B {
    function f() { A::f(); }
}

(new B)->f();
?>

以上例程会输出：

Deprecated: Non-static method A::f() should not be called statically, assuming $this from incompatible context in - on line 7
B

$HTTP_RAW_POST_DATA 和 always_populate_raw_post_data

使用 always_populate_raw_post_data 会导致在填充 $HTTP_RAW_POST_DATA 时产生 E_DEPRECATED 错误。 请使用 php://input 替代 $HTTP_RAW_POST_DATA， 因为它可能在后续的 PHP 版本中被移除。 设置 always_populate_raw_post_data 为 -1 （这样会强制 $HTTP_RAW_POST_DATA 未定义，所以也不回导致 E_DEPRECATED 的错误） 来体验新的行为。

iconv 和 mbstring 编码设置

iconv 和 mbstring 配置选项中 和编码相关的选项都已废弃， 请使用 default_charset。 废弃的选项有：

  • iconv.input_encoding
  • iconv.output_encoding
  • iconv.internal_encoding
  • mbstring.http_input
  • mbstring.http_output
  • mbstring.internal_encoding


函数的变化

PHP 内核

  • 如果省略 salt 参数，crypt() 会产生 E_NOTICE错误。
  • substr_compare() 的 length 参数现在接受 0 的值。
  • unserialize() will now fail if passed serialised data that has been manipulated to attempt to instantiate an object without calling its constructor.

cURL

  • 只有设置 CURLOPT_SAFE_UPLOAD 为 false 的情况下， 才接受 @file 语法上传文件。 最好使用 CURLFile 代替。

Mcrypt

  • mcrypt_create_iv() 的 source 现在默认值是 MCRYPT_DEV_URANDOM，而非 MCRYPT_DEV_RANDOM。

OpenSSL

  • 如果 SSL 上下文选项已经提供 crypto_type 选项， stream_socket_enable_crypto() 可以忽略 crypto_type 参数。

PostgreSQL

  • pg_insert()、pg_select()、 pg_update()、pg_delete() 不再是实验性质的。
  • 如果数据库连接 socket 流设置为非阻塞（non-blocking）模式，
pg_send_execute()、
pg_send_prepare()、pg_send_query()
、pg_send_query_params() 不再会阻塞查询直到写入完成。

Reflection

  • ReflectionClass::newInstanceWithoutConstructor() 现在允许非 Final 的内部类实例化。

XMLReader

  • 和 XMLReader::getAttribute() 一样，未找到属性的情况下，
XMLReader::getAttributeNs() 和
XMLReader::getAttributeNo() 会返回 null 。


新加函数

日期和时间

  • DateTimeImmutable::createFromMutable()

GMP

  • gmp_root()
  • gmp_rootrem()

Hash

  • hash_equals()

LDAP

  • ldap_escape()
  • ldap_modify_batch()

MySQLi

  • mysqli_get_links_stats()

OCI8

  • oci_get_implicit_resultset()

OpenSSL

  • openssl_get_cert_locations()
  • openssl_x509_fingerprint()
  • openssl_spki_new()
  • openssl_spki_verify()
  • openssl_spki_export_challenge()
  • openssl_spki_export()

PostgreSQL

  • pg_connect_poll()
  • pg_consume_input()
  • pg_flush()
  • pg_socket()

PDO_PGSQL

  • PDO::pgsqlGetNotify()
  • PDO::pgsqlGetPid()

Session

  • session_abort()
  • session_reset()

Zip

  • ZipArchive::setPassword()


OpenSSL changes in PHP 5.6.x

Stream wrappers now verify peer certificates and host names by default when using SSL/TLS

All encrypted client streams now enable peer verification by default. By default, this will use OpenSSL's default CA bundle to verify the peer certificate. In most cases, no changes will need to be made to communicate with servers with valid SSL certificates, as distributors generally configure OpenSSL to use known good CA bundles.

The default CA bundle may be overridden on a global basis by setting either the openssl.cafile or openssl.capath configuration setting, or on a per request basis by using the cafile or capath context options.

While not recommended in general, it is possible to disable peer certificate verification for a request by setting the verify_peer context option to false, and to disable peer name validation by setting the verify_peer_name context option to false.

Certificate fingerprints

Support has been added for extracting and verifying certificate fingerprints. openssl_x509_fingerprint() has been added to extract a fingerprint from an X.509 certificate, and two SSL stream context options have been added: capture_peer_cert to capture the peer's X.509 certificate, and peer_fingerprint to assert that the peer's certificate should match the given fingerprint.

Default ciphers updated

The default ciphers used by PHP have been updated to a more secure list based on the » Mozilla cipher recommendations, with two additional exclusions: anonymous Diffie-Hellman ciphers, and RC4.

This list can be accessed via the new OPENSSL_DEFAULT_STREAM_CIPHERS constant, and can be overridden (as in previous PHP versions) by setting the ciphers context option.

Compression disabled by default

SSL/TLS compression has been disabled by default to mitigate the CRIME attack. PHP 5.4.13 added a disable_compression context option to allow compression to be disabled: this is now set to true (that is, compression is disabled) by default.

Allow servers to prefer their cipher order

The honor_cipher_order SSL context option has been added to allow encrypted stream servers to mitigate BEAST vulnerabilities by preferring the server's ciphers to the client's.

Access the negotiated protocol and cipher

The protocol and cipher that were negotiated for an encrypted stream can now be accessed via stream_get_meta_data() or stream_context_get_options() when the capture_session_meta SSL context option is set to true.

<?php
$ctx = stream_context_create(['ssl' => [
    'capture_session_meta' => TRUE
]]);

$html = file_get_contents('https://google.com/', FALSE, $ctx);
$meta = stream_context_get_options($ctx)['ssl']['session_meta'];
var_dump($meta);
?>

以上例程会输出：

array(4) {
  ["protocol"]=>
  string(5) "TLSv1"
  ["cipher_name"]=>
  string(20) "ECDHE-RSA-AES128-SHA"
  ["cipher_bits"]=>
  int(128)
  ["cipher_version"]=>
  string(11) "TLSv1/SSLv3"
}

New options for perfect forward secrecy in encrypted stream servers

Encrypted client streams already support perfect forward secrecy, as it is generally controlled by the server. PHP encrypted server streams using certificates capable of perfect forward secrecy do not need to take any additional action to enable PFS; however a number of new SSL context options have been added to allow more control over PFS and deal with any compatibility issues that may arise.

ecdh_curve

This option allows the selection of a specific curve for use with ECDH ciphers. If not specified, prime256v1 will be used.

dh_param

A path to a file containing parametrs for Diffie-Hellman key exchange, such as that created by the following command:

openssl dhparam -out /path/to/my/certs/dh-2048.pem 2048
single_dh_use

If set to true, a new key pair will be created when using Diffie-Hellman parameters, thereby improving forward secrecy.

single_ecdh_use

If set to true, a new key pair will always be generated when ECDH cipher suites are negotiated. This improves forward secrecy.

SSL/TLS version selection

It is now possible to select specific versions of SSL and TLS via the crypto_method SSL context option or by specifying a specific transport when creating a stream wrapper (for example, by calling stream_socket_client() or stream_socket_server()).

The crypto_method SSL context option accepts a bitmask enumerating the protocols that are permitted, as does the crypto_type of stream_socket_enable_crypto().

Selected protocol versions and corresponding options
Protocol(s) | Client flag | Server flag | Transport
Any TLS or SSL version | STREAM_CRYPTO_METHOD_ANY_CLIENT | STREAM_CRYPTO_METHOD_ANY_SERVER | ssl://
Any TLS version | STREAM_CRYPTO_METHOD_TLS_CLIENT | STREAM_CRYPTO_METHOD_TLS_SERVER | tls://
TLS 1.0 | STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_0_SERVER | tlsv1.0://
TLS 1.1 | STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_1_SERVER | tlsv1.1://
TLS 1.2 | STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_2_SERVER | tlsv1.2://
SSL 3 | STREAM_CRYPTO_METHOD_SSLv3_CLIENT | STREAM_CRYPTO_METHOD_SSLv3_SERVER | sslv3://
<?php

// Requiring TLS 1.0 or better when using file_get_contents():
$ctx = stream_context_create([
    'ssl' => [
        'crypto_method' => STREAM_CRYPTO_METHOD_TLS_CLIENT,
    ],
]);
$html = file_get_contents('https://google.com/', false, $ctx);

// Requiring TLS 1.1 or 1.2:
$ctx = stream_context_create([
    'ssl' => [
        'crypto_method' => STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT |
                           STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT,
    ],
]);
$html = file_get_contents('https://google.com/', false, $ctx);

// Connecting using the tlsv1.2:// stream socket transport.
$sock = stream_socket_client('tlsv1.2://google.com:443/');

?>

openssl_get_cert_locations() added

The openssl_get_cert_locations() function has been added: it returns the default locations PHP will search when looking for CA bundles.

<?php
var_dump(openssl_get_cert_locations());
?>

以上例程会输出：

array(8) {
  ["default_cert_file"]=>
  string(21) "/etc/pki/tls/cert.pem"
  ["default_cert_file_env"]=>
  string(13) "SSL_CERT_FILE"
  ["default_cert_dir"]=>
  string(18) "/etc/pki/tls/certs"
  ["default_cert_dir_env"]=>
  string(12) "SSL_CERT_DIR"
  ["default_private_dir"]=>
  string(20) "/etc/pki/tls/private"
  ["default_default_cert_area"]=>
  string(12) "/etc/pki/tls"
  ["ini_cafile"]=>
  string(0) ""
  ["ini_capath"]=>
  string(0) ""
}

SPKI support

Support has been added for generating, extracting and verifying signed public key and challenges (SPKAC). openssl_spki_new(), openssl_spki_verify(), openssl_spki_export_challenge(), and openssl_spki_export() have been added to create, verify export PEM public key and associated challenge from SPKAC's generated from a KeyGen HTML5 element.

openssl_spki_new

Generates a new SPKAC using private key, challenge string and hashing algorithm.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
?>

以上例程会输出：

SPKAC=MIIBXjCByDCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEA3L0IfUijj7+A8CPC8EmhcdNoe5fUAog7OrBdhn7EkxFButUp40P7+LiYiygYG1TmoI/a5EgsLU3s9twEz3hmgY9mYIqb/rb+SF8qlD/K6KVyUORC7Wlz1Df4L8O3DuRGzx6/+3jIW6cPBpfgH1sVuYS1vDBsP/gMMIxwTsKJ4P0CAwEAARYkYjViMzYxMTktNjY5YS00ZDljLWEyYzctMGZjNGFhMjVlMmE2MA0GCSqGSIb3DQEBAwUAA4GBAF7hu0ifzmjonhAak2FhhBRsKFDzXdKIkrWxVNe8e0bZzMrWOxFM/rqBgeH3/gtOUDRS5Fnzyq425UsTYbjfiKzxGeCYCQJb1KJ2V5Ij/mIJHZr53WYEXHQTNMGR8RPm7IxwVXVSHIgAfXsXZ9IXNbFbcaLRiSTr9/N4U+MXUWL7
openssl_spki_verify

Verifies provided SPKAC.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
var_dump(openssl_spki_verify($spkac));
?>
openssl_spki_export_challenge

Exports associated challenge from provided SPKAC.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
$challenge = openssl_spki_export_challenge($spkac):
echo $challenge;
?>

以上例程会输出：

challenge string
openssl_spki_export

Exports the PEM formatted RSA public key from SPKAC.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
echo openssl_spki_export($spkac);
?>

以上例程会输出：

-----BEGIN PUBLIC KEY-----
MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDcvQh9SKOPv4DwI8LwSaFx02h7
l9QCiDs6sF2GfsSTEUG61SnjQ/v4uJiLKBgbVOagj9rkSCwtTez23ATPeGaBj2Zg
ipv+tv5IXyqUP8ropXJQ5ELtbXPUN/gvw7cO5EbPHr/7eMhbpw8Gl+AfWxW5hLW8
MGw/+AwwjHBOwong/QIDAQAB
-----END PUBLIC KEY-----


扩展中的变动

cURL

在 cURL 库中的一些被标记为废弃的常量， 现在已经被移除：

  • CURLOPT_CLOSEPOLICY
  • CURLCLOSEPOLICY_CALLBACK
  • CURLCLOSEPOLICY_LEAST_RECENTLY_USED
  • CURLCLOSEPOLICY_LEAST_TRAFFIC
  • CURLCLOSEPOLICY_OLDEST
  • CURLCLOSEPOLICY_SLOWEST

OCI8

  • 加入 oci_get_implicit_resultset() 函数 来支持 Oracle Database 12c 的隐式结果集。
  • 如果使用 oci_execute($s, OCI_NO_AUTO_COMMIT) 执行 SELECT 语句， 在连接关闭时发起内部的事物回滚不再是冗余的。
  • 通过 --enable-dtrace 配置选项 控制 DTrace 探针。
  • oci_internal_debug() 现在是无操作函数。
  • 在 phpinfo() 输出中 OCI8 的格式发生变动。

Zip

加入 --with-libzip 配置选项， 使得你可以使用系统安装的 libzip。 最低支持 libzip 0.11 版本，建议使用 0.11.2 或更高的版本。

MySQLi

新加 mysqli.rollback_on_cached_plink 选项，对于事务回滚的连接，将其返回到持久连接池中。


新加的全局常量

GD

  • IMG_WEBP （自 PHP 5.6.25 起）

LDAP

  • LDAP_ESCAPE_DN
  • LDAP_ESCAPE_FILTER

OpenSSL

  • OPENSSL_DEFAULT_STREAM_CIPHERS
  • STREAM_CRYPTO_METHOD_ANY_CLIENT
  • STREAM_CRYPTO_METHOD_ANY_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_0_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_1_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_2_SERVER

PostgreSQL

  • PGSQL_CONNECT_ASYNC
  • PGSQL_CONNECTION_AUTH_OK
  • PGSQL_CONNECTION_AWAITING_RESPONSE
  • PGSQL_CONNECTION_MADE
  • PGSQL_CONNECTION_SETENV
  • PGSQL_CONNECTION_SSL_STARTUP
  • PGSQL_CONNECTION_STARTED
  • PGSQL_DML_ESCAPE
  • PGSQL_POLLING_ACTIVE
  • PGSQL_POLLING_FAILED
  • PGSQL_POLLING_OK
  • PGSQL_POLLING_READING
  • PGSQL_POLLING_WRITING


  • ? 新加的全局常量
  • 关于调试器 ?
  • PHP Manual
  • 附录
  • PHP 的调试

PHP 的调试

Table of Contents

  • 关于调试器


关于调试器

PHP 带来了 phpdbg 交互式调试器。也可以使用外部调试器。» Zend IDE 就是其中之一，它包含一个调试器。也有一些免费的调试器，比如在 » http://www.php-debugger.com/dbg/ 上的 DBG，» Advanced PHP Debugger（APD）或者 » Xdebug。


  • ? 关于调试器
  • 核心配置选项列表 ?
  • PHP Manual
  • 附录
  • 配置选项

配置选项

Table of Contents

  • 核心配置选项列表


核心配置选项列表

下面是 PHP 的 configure 脚本使用的部分选项的列表，用于类 Unix 环境的编译。大部分配置选项在扩展模块参考页面适当的位置列出，而不是在这里。要查看所有可用配置选项的列表，在运行 autoconf 命令后在 PHP 的源代码目录运行 ./configure --help（参见安装与配置一章）。也可以阅读 » GNU configure 文档以获得有关 configure 命令的更详细信息，例如 --prefix=PREFIX。

Note:

这些选项只用在编译的时候。如果想要修改 PHP 的运行时配置，请阅读运行时配置。

  • 杂项
  • PHP 行为
  • 服务器

PHP 配置选项

杂项选项

--enable-debug

编译时加入调试符号。

--with-layout=TYPE

设置被安装文件的布局。TYPE 是 PHP（默认）或 GNU。

--with-pear=DIR

在 DIR（默认为 PREFIX/lib/php）中安装 PEAR。

--without-pear

不安装 PEAR。

--enable-sigchild

使用 PHP 自带的 SIGCHLD 处理器。

--disable-rpath

禁用在搜索路径中传递其他运行库。

--enable-libgcc

启用 libgcc 的精确链接。

--enable-php-streams

包含试验性的 PHP 流。不要使用此选项，除非是要测试代码！

--with-zlib-dir[=DIR]

定义 zlib 的安装目录。

--with-tsrm-pthreads

使用 POSIX 线程（默认）。

--enable-shared[=PKGS]

编译共享库 [default=yes]。

--enable-static[=PKGS]

编译静态库 [default=yes]。

--enable-fast-install[=PKGS]

为快速安装优化 [default=yes]。

--with-gnu-ld

假设 C 编译器使用 GNU ld [default=no]。

--disable-libtool-lock

避免锁死（可能破坏并联的编译）。

--with-pic

尝试仅使用 PIC/非 PIC 对象 [default=use both]。

--enable-memory-limit

编译内存限制支持功能。(自PHP 5.2.1开始不可用，默认enable)

--disable-url-fopen-wrapper

禁用 URL 形式的 fopen 封装协议。该协议允许通过 HTTP 或者 FTP 访问文件。 （自PHP5.2.5开始不可用）

--enable-versioning

仅导出必须的符号。查看 INSTALL 文件以获得更多信息。

PHP 选项

--enable-maintainer-mode

对偶然安装一下的情形启用此选项，使得不检查编译规则和依赖关系。

--with-config-file-path=PATH

设置 php.ini 的搜索路径。默认为 PREFIX/lib。

--enable-safe-mode

默认启用安全模式。

Warning

本特性已自 PHP 5.3.0 起废弃并将自 PHP 5.4.0 起移除。

--with-exec-dir[=DIR]

在安全模式时仅允许在 DIR 目录中执行。默认目录为 /usr/local/php/bin。

Warning

本特性已自 PHP 5.3.0 起废弃并将自 PHP 5.4.0 起移除。

--enable-magic-quotes

默认启用 magic quotes。

Warning

本特性已自 PHP 5.3.0 起废弃并将自 PHP 5.4.0 起移除。

--disable-short-tags

默认禁用短形式的开始标签 <? 。

--enable-zend-multibyte

在词法与语法分析时允许多字节编码被执行。如果在编译 PHP 时使用了这个选项，就能够在 declare 结构中使用 encoding 指令。

Warning

本特性已自 PHP 5.3.0 起废弃并将自 PHP 5.4.0 起移除。

--with-libdir

指定Uxin系统库文件目录用于构建 PHP。 对于64位系统, 需要指定 lib64 目录,比如 --with-libdir=lib64。

SAPI 选项

下面的列表包含 PHP 可用的 SAPI（服务器应用编程接口）。

--with-apxs[=FILE]

编译共享的 Apache 模块。FILE 是可选的 Apache apxs 工具的路径，默认指向 apxs。请确认指定的 apxs 已经安装在服务器中，并且它不是 Apache 源码包中的那个 apxs。

--with-apache[=DIR]

编译静态 Apache 模块。DIR 是 Apache 编译目录的顶层，默认为 /usr/local/apache。

--with-mod_charset

启用 mod_charset 的转换表（俄文的 Apache 使用）。

--with-apxs2[=FILE]

编译共享的 Apache 2.0 模块。FILE 是可选的 Apache apxs 工具的路径，默认指向 apxs。

--disable-cli

禁止编译 PHP 的 CLI 版本（使用它将同时强制使用 --without-pear 选项）。更多信息请参阅 PHP 的命令行模式。

--enable-phpdbg

启用 phpdbg 调试 SAPI 模块支持，PHP 5.6.x 以后的版本有效。

--enable-embed[=TYPE]

启用编译嵌入的 SAPI 库。TYPE 或者为 shared 或者为 static，默认为 shared。

--with-servlet[=DIR]

包含 servlet 支持。DIR 是 JSDK 的安装目录。此 SAPI 要求 java 扩展必须作为共享模块编译到 PHP 中。

--disable-cgi

禁止编译 CGI 版本的 PHP。

PHP 5.3.0 起，这个选项会启用 FastCGI，而在以前，必须使用 --enable-fastcgi 启用 FastCGI。

--enable-force-cgi-redirect

启用内部服务器重定向的安全检测。如果在 Apache 下使用 CGI 版本的 PHP，请启用该选项。

PHP 5.3.0 起，默认有效并不再存在。要禁用此功能，需要在 INI 配置文件中将 cgi.force_redirect 设为 0。

--enable-discard-path

如果启用该选项，PHP CGI 目录可以安全的放在 web 目录树的外面，人们无法避开 .htaccess 的安全限制。

PHP 5.3.0 起，默认禁用并不在存在。要启用此功能，需要设置 cgi-redirect INI 指令为 1。

--enable-fastcgi

如果启用，CGI 模块将被编译为支持 FastCGI。

PHP 5.3.0 起，此参数不再存在，并使用 --enable-cgi 替代。

--disable-path-info-check

如果该选项被禁用，例如 /info.php/test?a=b 形式的路径将不能工作。更多信息请参考 » Apache 手册。

从 PHP 5.3.0 起，此选项默认开启并且不再使用。如果想禁用此特性，需要在 INI 配置中将 cgi.fix_pathinfo 设置成 0。


php.ini 配置

Table of Contents

  • php.ini 配置选项列表
  • php.ini 配置段列表
  • php.ini 核心配置选项说明


php.ini 配置选项列表

可以在 php.ini 中使用下列配置选项对 PHP 进行配置。

"可修改范围"列决定了该配置选项在什么情况下可以被设置。查看 配置可被设定范围 列表查看具体定义。

配置选项
名字 | 默认 | 可修改范围 | 更新日志
allow_url_fopen | "1" | PHP_INI_SYSTEM |
allow_url_include | "0" | PHP_INI_SYSTEM | 从 PHP 7.4.0 开始被废弃。
arg_separator.input | "&" | PHP_INI_PERDIR |
arg_separator.output | "&" | PHP_INI_ALL |
assert.active | "1" | PHP_INI_ALL |
assert.bail | "0" | PHP_INI_ALL |
assert.callback | NULL | PHP_INI_ALL |
assert.exception | "0" | PHP_INI_ALL |
assert.quiet_eval | "0" | PHP_INI_ALL |
assert.warning | "1" | PHP_INI_ALL |
auto_append_file | NULL | PHP_INI_PERDIR |
auto_detect_line_endings | "0" | PHP_INI_ALL |
auto_globals_jit | "1" | PHP_INI_PERDIR |
auto_prepend_file | NULL | PHP_INI_PERDIR |
bcmath.scale | "0" | PHP_INI_ALL |
browscap | NULL | PHP_INI_SYSTEM |
cgi.check_shebang_line | "1" | PHP_INI_SYSTEM |
cgi.discard_path | "0" | PHP_INI_SYSTEM |
cgi.fix_pathinfo | "1" | PHP_INI_SYSTEM |
cgi.force_redirect | "1" | PHP_INI_SYSTEM |
cgi.nph | "0" | PHP_INI_ALL |
cgi.redirect_status_env | NULL | PHP_INI_SYSTEM |
cgi.rfc2616_headers | "0" | PHP_INI_ALL |
child_terminate | "0" | PHP_INI_ALL |
cli.pager | "" | PHP_INI_ALL | 自 PHP 5.4.0 可用.
cli.prompt | "\\b \\> " | PHP_INI_ALL | 自 PHP 5.4.0 可用.
cli_server.color | "0" | PHP_INI_ALL | PHP 5.4.0. 起生效
com.allow_dcom | "0" | PHP_INI_SYSTEM |
com.autoregister_typelib | "0" | PHP_INI_ALL |
com.autoregister_verbose | "0" | PHP_INI_ALL |
com.autoregister_casesensitive | "1" | PHP_INI_ALL |
com.code_page | "" | PHP_INI_ALL |
com.dotnet_version | "" | PHP_INI_SYSTEM | As of PHP 8.0.0
com.typelib_file | "" | PHP_INI_SYSTEM |
curl.cainfo | NULL | PHP_INI_SYSTEM | 自 PHP 5.3.7. 起有效
date.default_latitude | "31.7667" | PHP_INI_ALL |
date.default_longitude | "35.2333" | PHP_INI_ALL |
date.sunrise_zenith | "90.83" | PHP_INI_ALL |
date.sunset_zenith | "90.83" | PHP_INI_ALL |
date.timezone | "" | PHP_INI_ALL |
dba.default_handler | DBA_DEFAULT | PHP_INI_ALL |
default_charset | "UTF-8" | PHP_INI_ALL | 默认值为 "UTF-8"
default_mimetype | "text/html" | PHP_INI_ALL |
default_socket_timeout | "60" | PHP_INI_ALL |
disable_classes | "" | php.ini only |
disable_functions | "" | php.ini only |
display_errors | "1" | PHP_INI_ALL |
display_startup_errors | "0" | PHP_INI_ALL |
docref_ext | "" | PHP_INI_ALL |
docref_root | "" | PHP_INI_ALL |
doc_root | NULL | PHP_INI_SYSTEM |
enable_dl | "1" | PHP_INI_SYSTEM | 本过时特性将肯定会在未来被移除。
enable_post_data_reading | On | PHP_INI_PERDIR |
engine | "1" | PHP_INI_ALL |
error_append_string | NULL | PHP_INI_ALL |
error_log | NULL | PHP_INI_ALL |
error_prepend_string | NULL | PHP_INI_ALL |
error_reporting | NULL | PHP_INI_ALL |
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL |
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL |
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL |
exif.encode_jis | "" | PHP_INI_ALL |
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL |
exif.decode_jis_intel | "JIS" | PHP_INI_ALL |
exit_on_timeout | "" | PHP_INI_ALL |
expect.timeout | "10" | PHP_INI_ALL |
expect.loguser | "1" | PHP_INI_ALL |
expect.logfile | "" | PHP_INI_ALL |
expect.match_max | "" | PHP_INI_ALL |
expose_php | "1" | php.ini only |
extension | NULL | php.ini only |
extension_dir | "/path/to/php" | PHP_INI_SYSTEM |
fastcgi.impersonate | "0" | PHP_INI_SYSTEM |
fastcgi.logging | "1" | PHP_INI_SYSTEM |
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM |
fbsql.autocommit | "1" | PHP_INI_SYSTEM |
fbsql.batchsize | "1000" | PHP_INI_ALL |
fbsql.default_database | "" | PHP_INI_SYSTEM |
fbsql.default_database_password | "" | PHP_INI_SYSTEM |
fbsql.default_host | NULL | PHP_INI_SYSTEM |
fbsql.default_password | "" | PHP_INI_SYSTEM |
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM |
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM |
fbsql.max_connections | "128" | PHP_INI_SYSTEM |
fbsql.max_links | "128" | PHP_INI_SYSTEM |
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM |
fbsql.max_results | "128" | PHP_INI_SYSTEM |
fbsql.show_timestamp_decimals | "0" | PHP_INI_SYSTEM |
file_uploads | "1" | PHP_INI_SYSTEM |
filter.default | "unsafe_raw" | PHP_INI_PERDIR | PHP_INI_ALL in filter <= 0.9.4. Available since PHP 5.2.0.
filter.default_flags | NULL | PHP_INI_PERDIR | PHP_INI_ALL in filter <= 0.9.4. Available since PHP 5.2.0.
from | "" | PHP_INI_ALL |
gd.jpeg_ignore_warning | "1" | PHP_INI_ALL |
geoip.custom_directory | "" | PHP_INI_ALL |
hard_timeout | "2" | PHP_INI_SYSTEM | PHP 7.1.0 起可用
highlight.comment | "#FF8000" | PHP_INI_ALL |
highlight.default | "#0000BB" | PHP_INI_ALL |
highlight.html | "#000000" | PHP_INI_ALL |
highlight.keyword | "#007700" | PHP_INI_ALL |
highlight.string | "#DD0000" | PHP_INI_ALL |
html_errors | "1" | PHP_INI_ALL |
ibase.allow_persistent | "1" | PHP_INI_SYSTEM |
ibase.max_persistent | "-1" | PHP_INI_SYSTEM |
ibase.max_links | "-1" | PHP_INI_SYSTEM |
ibase.default_db | NULL | PHP_INI_SYSTEM |
ibase.default_user | NULL | PHP_INI_ALL |
ibase.default_password | NULL | PHP_INI_ALL |
ibase.default_charset | NULL | PHP_INI_ALL |
ibase.timestampformat | "%Y-%m-%d %H:%M:%S" | PHP_INI_ALL |
ibase.dateformat | "%Y-%m-%d" | PHP_INI_ALL |
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL |
ibm_db2.binmode | "1" | PHP_INI_ALL |
ibm_db2.i5_all_pconnect | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.6.5.
ibm_db2.i5_allow_commit | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.4.9.
ibm_db2.i5_dbcs_alloc | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.5.0.
ibm_db2.instance_name | NULL | PHP_INI_SYSTEM | Available since ibm_db2 1.0.2.
ibm_db2.i5_ignore_userid | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.8.0.
iconv.input_encoding | "" | PHP_INI_ALL | 在 PHP 5.6.0 中废弃。
iconv.output_encoding | "" | PHP_INI_ALL | 在 PHP 5.6.0 中废弃。
iconv.internal_encoding | "" | PHP_INI_ALL | 在 PHP 5.6.0 中废弃。
ignore_repeated_errors | "0" | PHP_INI_ALL |
ignore_repeated_source | "0" | PHP_INI_ALL |
ignore_user_abort | "0" | PHP_INI_ALL |
implicit_flush | "0" | PHP_INI_ALL |
include_path | ".:/path/to/php/pear" | PHP_INI_ALL |
intl.default_locale |  | PHP_INI_ALL |
intl.error_level | 0 | PHP_INI_ALL |
intl.use_exceptions | 0 | PHP_INI_ALL | Available since PHP 5.5 and PECL 3.0.0a1
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.array_index_start | "1" | PHP_INI_ALL | Available since ingres 1.4.0.
ingres.auto | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.blob_segment_length | "4096" | PHP_INI_ALL | Available since ingres 1.2.0.
ingres.cursor_mode | "0" | PHP_INI_ALL | Available since ingres 1.1.0.
ingres.default_database | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.default_password | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.default_user | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.describe | 1 | PHP_INI_ALL | Available since ingres 2.1.0
ingres.fetch_buffer_size | 100 | PHP_INI_ALL | Available since ingres 2.1.0
ingres.max_links | "-1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.reuse_connection | "1" | PHP_INI_ALL | Available since ingres 2.0.0
ingres.scrollable | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.trace | "0" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.trace_connect | "0" | PHP_INI_ALL | Available since ingres 1.2.1.
ingres.utf8 | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
last_modified | "0" | PHP_INI_ALL |
ldap.max_links | "-1" | PHP_INI_SYSTEM |
log_errors | "0" | PHP_INI_ALL |
log_errors_max_len | "1024" | PHP_INI_ALL |
mail.add_x_header | "0" | PHP_INI_PERDIR |
mail.force_extra_parameters | NULL | php.ini only |
mail.log | "" | PHP_INI_PERDIR |
max_execution_time | "30" | PHP_INI_ALL |
max_input_nesting_level | "64" | PHP_INI_PERDIR |
max_input_vars | 1000 | PHP_INI_PERDIR |
max_input_time | "-1" | PHP_INI_PERDIR |
mbstring.language | "neutral" | PHP_INI_ALL | PHP_INI_PERDIR 位于 PHP <= 5.2.6
mbstring.detect_order | NULL | PHP_INI_ALL |
mbstring.http_input | "pass" | PHP_INI_ALL |
mbstring.http_output | "pass" | PHP_INI_ALL |
mbstring.internal_encoding | NULL | PHP_INI_ALL |
mbstring.script_encoding | NULL | PHP_INI_ALL | 在 PHP 5.4.0. 中移除， 使用 zend.script_encoding 代替。
mbstring.substitute_character | NULL | PHP_INI_ALL |
mbstring.func_overload | "0" | PHP_INI_SYSTEM | PHP <= 5.2.6 是 PHP_INI_PERDIR。 Deprecated as of PHP 7.2.0; removed as of PHP 8.0.0.
mbstring.encoding_translation | "0" | PHP_INI_PERDIR |
mbstring.http_output_conv_mimetypes | "^(text/|application/xhtml\+xml)" | PHP_INI_ALL | Available as of PHP 5.3.0.
mbstring.strict_detection | "0" | PHP_INI_ALL | 自 PHP 5.1.2 起有效。
mcrypt.algorithms_dir | null | PHP_INI_ALL |
mcrypt.modes_dir | null | PHP_INI_ALL |
memcache.allow_failover | "1" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.max_failover_attempts | "20" | PHP_INI_ALL | Available since memcache 2.1.0.
memcache.chunk_size | "8192" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.default_port | "11211" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.hash_strategy | "standard" | PHP_INI_ALL | Available since memcache 2.2.0.
memcache.hash_function | "crc32" | PHP_INI_ALL | Available since memcache 2.2.0.
session.save_handler | "files" | PHP_INI_ALL | Supported since memcache 2.1.2
session.save_path | "" | PHP_INI_ALL | Supported since memcache 2.1.2
memcache.protocol | ascii | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.redundancy | 1 | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.session_redundancy | 2 | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.compress_threshold | 20000 | >PHP_INI_ALL | Supported since memcache 3.0.3
memcache.lock_timeout | 15 | >PHP_INI_ALL | Supported since memcache 3.0.4
memory_limit | "128M" | PHP_INI_ALL |
mongo.allow_empty_keys | 0 | PHP_INI_ALL |
mongo.allow_persistent | 1 | PHP_INI_ALL | Removed in 1.2.0
mongo.chunk_size | 262144 | PHP_INI_ALL |
mongo.cmd | "$" | PHP_INI_ALL |
mongo.default_host | "localhost" | PHP_INI_ALL |
mongo.default_port | 27017 | PHP_INI_ALL |
mongo.is_master_interval | 15 | PHP_INI_ALL | Added in 1.2.10, before 1.3.0 the default value was 60.
mongo.long_as_object | 0 | PHP_INI_ALL |
mongo.native_long | 1 | PHP_INI_ALL | Before 1.5.0, the default value was 0.
mongo.ping_interval | 5 | PHP_INI_ALL | Added in 1.2.10
mongo.utf8 | 1 | PHP_INI_ALL |
mysql.allow_local_infile | "1" | PHP_INI_SYSTEM |
mysql.allow_persistent | "1" | PHP_INI_SYSTEM |
mysql.max_persistent | "-1" | PHP_INI_SYSTEM |
mysql.max_links | "-1" | PHP_INI_SYSTEM |
mysql.trace_mode | "0" | PHP_INI_ALL | 自 PHP 4.3.0 起可用
mysql.default_port | NULL | PHP_INI_ALL |
mysql.default_socket | NULL | PHP_INI_ALL | 自 PHP 4.0.1 起可用
mysql.default_host | NULL | PHP_INI_ALL |
mysql.default_user | NULL | PHP_INI_ALL |
mysql.default_password | NULL | PHP_INI_ALL |
mysql.connect_timeout | "60" | PHP_INI_ALL | 自 PHP 4.3.0 起可用。在 PHP <= 4.3.2 时为 PHP_INI_SYSTEM
mysqli.allow_local_infile | "0" | PHP_INI_SYSTEM | 自PHP 5.2.4起可用。在 PHP 7.2.16 和 7.3.3 之前，默认值为 "1"
mysqli.local_infile_directory |  | PHP_INI_SYSTEM |
mysqli.allow_persistent | "1" | PHP_INI_SYSTEM | 自PHP 5.3.0起可用。
mysqli.max_persistent | "-1" | PHP_INI_SYSTEM | 自PHP 5.3.0起可用。
mysqli.max_links | "-1" | PHP_INI_SYSTEM |
mysqli.default_port | "3306" | PHP_INI_ALL |
mysqli.default_socket | NULL | PHP_INI_ALL |
mysqli.default_host | NULL | PHP_INI_ALL |
mysqli.default_user | NULL | PHP_INI_ALL | 自PHP 5.0.0起可用。
mysqli.default_pw | NULL | PHP_INI_ALL |
mysqli.reconnect | "0" | PHP_INI_SYSTEM |
mysqli.rollback_on_cached_plink | TRUE | PHP_INI_SYSTEM | 自 PHP 5.6.0 起可用。
mysqlnd.collect_statistics | "1" | PHP_INI_SYSTEM |
mysqlnd.collect_memory_statistics | "0" | PHP_INI_SYSTEM |
mysqlnd.debug | "" | PHP_INI_SYSTEM |
mysqlnd.log_mask | 0 | PHP_INI_ALL |
mysqlnd.mempool_default_size | 16000 | PHP_INI_ALL |
mysqlnd.net_read_timeout | "86400" | PHP_INI_ALL | Before PHP 7.2.0 the default value was "31536000" and the changeability was PHP_INI_SYSTEM
mysqlnd.net_cmd_buffer_size | "4096" | PHP_INI_SYSTEM |
mysqlnd.net_read_buffer_size | "32768" | PHP_INI_SYSTEM |
mysqlnd.sha256_server_public_key | "" | PHP_INI_PERDIR |
mysqlnd.trace_alloc | "" | PHP_INI_SYSTEM |
mysqlnd.fetch_data_copy | 0 | PHP_INI_ALL |
mysqlnd_memcache.enable | 1 | PHP_INI_SYSTEM | Available since 1.0.0
mysqlnd_ms.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.force_config_usage | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.ini_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.config_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.collect_statistics | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.multi_master | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.disable_rw_split | 0 | PHP_INI_SYSTEM |
mysqlnd_mux.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.enable_qc | 1 | PHP_INI_SYSTEM |
mysqlnd_qc.ttl | 30 | PHP_INI_ALL |
mysqlnd_qc.cache_by_default | 0 | PHP_INI_ALL |
mysqlnd_qc.cache_no_table | 0 | PHP_INI_ALL |
mysqlnd_qc.use_request_time | 0 | PHP_INI_ALL |
mysqlnd_qc.time_statistics | 1 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics | 0 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics_log_file | /tmp/mysqlnd_qc.stats | PHP_INI_SYSTEM |
mysqlnd_qc.collect_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.query_trace_bt_depth | 3 | PHP_INI_SYSTEM |
mysqlnd_qc.collect_normalized_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.ignore_sql_comments | 1 | PHP_INI_ALL |
mysqlnd_qc.slam_defense | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.slam_defense_ttl | 30 | PHP_INI_SYSTEM |
mysqlnd_qc.std_data_copy | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.apc_prefix | qc_ | PHP_INI_ALL |
mysqlnd_qc.memc_server | 127.0.0.1 | PHP_INI_ALL |
mysqlnd_qc.memc_port | 11211 | PHP_INI_ALL |
mysqlnd_qc.sqlite_data_file | :memory: | PHP_INI_ALL |
mysqlnd_uh.enable | 1 | PHP_INI_SYSTEM |
mysqlnd_uh.report_wrong_types | 1 | PHP_INI_ALL |
oci8.connection_class | "" | PHP_INI_ALL | Available since PHP 5.3 (PECL OCI8 1.3).
oci8.default_prefetch | "100" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.events | Off | PHP_INI_SYSTEM | Available since PHP 5.3 (PECL OCI8 1.3).
oci8.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.old_oci_close_semantics | Off | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.persistent_timeout | "-1" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.ping_interval | "60" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.privileged_connect | Off | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.statement_cache_size | "20" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
odbc.default_db * | NULL | PHP_INI_ALL |
odbc.default_user * | NULL | PHP_INI_ALL |
odbc.default_pw * | NULL | PHP_INI_ALL |
odbc.allow_persistent | "1" | PHP_INI_SYSTEM |
odbc.check_persistent | "1" | PHP_INI_SYSTEM |
odbc.max_persistent | "-1" | PHP_INI_SYSTEM |
odbc.max_links | "-1" | PHP_INI_SYSTEM |
odbc.defaultlrl | "4096" | PHP_INI_ALL |
odbc.defaultbinmode | "1" | PHP_INI_ALL |
odbc.default_cursortype | "3" | PHP_INI_ALL | Available as of PHP 5.3.0
opcache.enable | "1" | PHP_INI_ALL |
opcache.enable_cli | "0" | PHP_INI_SYSTEM | 在 PHP 7.1.2 至 7.1.6 （含）的版本，默认值是"1"
opcache.memory_consumption | "128" | PHP_INI_SYSTEM | 在 PHP 7.0.0 之前，默认值是 "64"
opcache.interned_strings_buffer | "8" | PHP_INI_SYSTEM | 在 PHP 7.0.0 之前，默认值是 "4"
opcache.max_accelerated_files | "10000" | PHP_INI_SYSTEM | 在 PHP 7.0.0 之前，默认值是 "2000"
opcache.max_wasted_percentage | "5" | PHP_INI_SYSTEM |
opcache.use_cwd | "1" | PHP_INI_SYSTEM |
opcache.validate_timestamps | "1" | PHP_INI_ALL |
opcache.revalidate_freq | "2" | PHP_INI_ALL |
opcache.revalidate_path | "0" | PHP_INI_ALL |
opcache.save_comments | "1" | PHP_INI_SYSTEM |
opcache.load_comments | "1" | PHP_INI_ALL | 从 PHP 7.0.0 开始被移除
opcache.fast_shutdown | "0" | PHP_INI_SYSTEM | 从 PHP 7.2.0 开始被移除
opcache.enable_file_override | "0" | PHP_INI_SYSTEM |
opcache.optimization_level | "0x7FFFBFFF" | PHP_INI_SYSTEM | 从 PHP 5.6.18 开始，默认值从 0xFFFFFFFF 修改为 0x7FFFBFFF
opcache.inherited_hack | "1" | PHP_INI_SYSTEM | 自 PHP 7.3.0 被移除
opcache.dups_fix | "0" | PHP_INI_ALL |
opcache.blacklist_filename | "" | PHP_INI_SYSTEM |
opcache.max_file_size | "0" | PHP_INI_SYSTEM |
opcache.consistency_checks | "0" | PHP_INI_ALL |
opcache.force_restart_timeout | "180" | PHP_INI_SYSTEM |
opcache.error_log | "" | PHP_INI_SYSTEM |
opcache.log_verbosity_level | "1" | PHP_INI_SYSTEM |
opcache.preferred_memory_model | "" | PHP_INI_SYSTEM |
opcache.protect_memory | "0" | PHP_INI_SYSTEM |
opcache.mmap_base | null | PHP_INI_SYSTEM |
opcache.restrict_api | "" | PHP_INI_SYSTEM |
opcache.file_update_protection | "2" | PHP_INI_ALL |
opcache.huge_code_pages | "0" | PHP_INI_SYSTEM |
opcache.lockfile_path | "/tmp" | PHP_INI_SYSTEM |
opcache.opt_debug_level | "0" | PHP_INI_SYSTEM |
opcache.file_cache | NULL | PHP_INI_SYSTEM | 从 PHP 7.0.0 开始支持
opcache.file_cache_only | "0" | PHP_INI_SYSTEM | 从 PHP 7.0.0 开始支持
opcache.file_cache_consistency_checks | "1" | PHP_INI_SYSTEM | 从 PHP 7.0.0 开始支持
opcache.file_cache_fallback | "1" | PHP_INI_SYSTEM | 从 PHP 7.0.0 开始支持，仅适用于 Windows 平台
opcache.validate_permission | "0" | PHP_INI_SYSTEM | 从 PHP 7.0.14 开始支持
opcache.validate_root | "0" | PHP_INI_SYSTEM | 从 PHP 7.0.14 开始支持
opcache.preload | "" | PHP_INI_SYSTEM | 从 PHP 7.4.0 开始支持
opcache.preload_user | "" | PHP_INI_SYSTEM | 从 PHP 7.4.0 开始支持
open_basedir | NULL | PHP_INI_ALL | 在 PHP < 5.2.3 时是 PHP_INI_SYSTEM。
output_buffering | "0" | PHP_INI_PERDIR |
output_handler | NULL | PHP_INI_PERDIR |
pcre.backtrack_limit | "100000" | PHP_INI_ALL | php 5.2.0 起可用。
pcre.recursion_limit | "100000" | PHP_INI_ALL | php 5.2.0 起可用。
pcre.jit | "1" | PHP_INI_ALL | PHP 7.0.0 起可用
pdo.dsn.* |  | 仅 php.ini |
pdo_odbc.connection_pooling | "strict" | PHP_INI_ALL | Available since PHP 5.1.0.
pdo_odbc.db2_instance_name | NULL | PHP_INI_SYSTEM | Available since PHP 5.1.1. 本过时特性将肯定会在未来被移除。
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM |
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM |
pgsql.max_links | "-1" | PHP_INI_SYSTEM |
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM | 从 PHP 4.2.0 起开始存在
pgsql.ignore_notice | "0" | PHP_INI_ALL | 从 PHP 4.3.0 起开始存在
pgsql.log_notice | "0" | PHP_INI_ALL | 从 PHP 4.3.0 起开始存在
phar.readonly | "1" | PHP_INI_ALL |
phar.require_hash | "1" | PHP_INI_ALL |
phar.cache_list | "" | PHP_INI_SYSTEM |
post_max_size | "8M" | PHP_INI_PERDIR |
precision | "14" | PHP_INI_ALL |
realpath_cache_size | "16K" | PHP_INI_SYSTEM |
realpath_cache_ttl | "120" | PHP_INI_SYSTEM |
register_argc_argv | "1" | PHP_INI_PERDIR |
report_memleaks | "1" | PHP_INI_ALL |
report_zend_debug | "1" | PHP_INI_ALL |
request_order | "" | PHP_INI_PERDIR |
runkit.superglobal | "" | PHP_INI_PERDIR |
runkit.internal_override | "0" | PHP_INI_SYSTEM |
sendmail_from | NULL | PHP_INI_ALL |
sendmail_path | "/usr/sbin/sendmail -t -i" | PHP_INI_SYSTEM |
serialize_precision | "-1" | PHP_INI_ALL | PHP 7.1.0 之前，默认值为 17。
session.save_path | "" | PHP_INI_ALL |
session.name | "PHPSESSID" | PHP_INI_ALL |
session.save_handler | "files" | PHP_INI_ALL |
session.auto_start | "0" | PHP_INI_PERDIR |
session.gc_probability | "1" | PHP_INI_ALL |
session.gc_divisor | "100" | PHP_INI_ALL |
session.gc_maxlifetime | "1440" | PHP_INI_ALL |
session.serialize_handler | "php" | PHP_INI_ALL |
session.cookie_lifetime | "0" | PHP_INI_ALL |
session.cookie_path | "/" | PHP_INI_ALL |
session.cookie_domain | "" | PHP_INI_ALL |
session.cookie_secure | "" | PHP_INI_ALL |
session.cookie_httponly | "" | PHP_INI_ALL | 自 PHP 5.2.0 起有效
session.cookie_samesite | "" | PHP_INI_ALL | 自 PHP 7.3.0 起有效
session.use_strict_mode | "0" | PHP_INI_ALL | 自 PHP 5.5.2 起有效
session.use_cookies | "1" | PHP_INI_ALL |
session.use_only_cookies | "1" | PHP_INI_ALL |
session.referer_check | "" | PHP_INI_ALL |
session.cache_limiter | "nocache" | PHP_INI_ALL |
session.cache_expire | "180" | PHP_INI_ALL |
session.use_trans_sid | "0" | PHP_INI_ALL |
session.trans_sid_tags | "a=href,area=href,frame=src,form=" | PHP_INI_ALL | 自 PHP 7.1.0 起有效。
session.trans_sid_hosts | $_SERVER['HTTP_HOST'] | PHP_INI_ALL | 自 PHP 7.1.0 起有效。
session.sid_length | "32" | PHP_INI_ALL | 自 PHP 7.1.0 起有效。
session.sid_bits_per_character | "4" | PHP_INI_ALL | 自 PHP 7.1.0 起有效。
session.upload_progress.enabled | "1" | PHP_INI_PERDIR |
session.upload_progress.cleanup | "1" | PHP_INI_PERDIR |
session.upload_progress.prefix | "upload_progress_" | PHP_INI_PERDIR |
session.upload_progress.name | "PHP_SESSION_UPLOAD_PROGRESS" | PHP_INI_PERDIR |
session.upload_progress.freq | "1%" | PHP_INI_PERDIR |
session.upload_progress.min_freq | "1" | PHP_INI_PERDIR |
session.lazy_write | "1" | PHP_INI_ALL |
session.hash_function | "0" | PHP_INI_ALL | 自 PHP 7.1.0 起移除。
session.hash_bits_per_character | "4" | PHP_INI_ALL | 自 PHP 7.1.0 起移除。
session.entropy_file | "" | PHP_INI_ALL | 自 PHP 7.1.0 起移除。
session.entropy_length | "0" | PHP_INI_ALL | 自 PHP 7.1.0 起移除。
short_open_tag | "1" | PHP_INI_PERDIR |
SMTP | "localhost" | PHP_INI_ALL |
smtp_port | "25" | PHP_INI_ALL |
soap.wsdl_cache_enabled | 1 | PHP_INI_ALL |
soap.wsdl_cache_dir | /tmp | PHP_INI_ALL |
soap.wsdl_cache_ttl | 86400 | PHP_INI_ALL |
soap.wsdl_cache | 1 | PHP_INI_ALL |
soap.wsdl_cache_limit | 5 | PHP_INI_ALL |
sql.safe_mode | "0" | PHP_INI_SYSTEM |
sqlite3.extension_dir | "" | PHP_INI_SYSTEM | PHP 5.3.11 起可用
sqlite3.defensive | 1 | PHP_INI_SYSTEM | PHP 7.2.17 和 7.3.4 起可用，libsqlite ≥ 3.26.0。
syslog.facility | "LOG_USER" | PHP_INI_SYSTEM | 从 PHP 7.3.0 起可用。
syslog.filter | "no-ctrl" | PHP_INI_ALL | 从 PHP 7.3.0 起可用。
syslog.ident | "php" | PHP_INI_SYSTEM | 从 PHP 7.3.0 起可用。
sys_temp_dir | "" | PHP_INI_SYSTEM |
sysvshm.init_mem | 10000 | PHP_INI_SYSTEM |
tidy.default_config | "" | PHP_INI_SYSTEM |
tidy.clean_output | "0" | PHP_INI_USER | PHP_INI_PERDIR prior to PHP 5.4.0
track_errors | "0" | PHP_INI_ALL | 自 PHP 7.2.0 起废弃。
unserialize_callback_func | NULL | PHP_INI_ALL |
uploadprogress.file.filename_template | "/tmp/upt_%s.txt" | PHP_INI_ALL |
upload_max_filesize | "2M" | PHP_INI_PERDIR |
max_file_uploads | 20 | PHP_INI_SYSTEM |
upload_tmp_dir | NULL | PHP_INI_SYSTEM |
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL |
user_agent | NULL | PHP_INI_ALL |
user_dir | NULL | PHP_INI_SYSTEM |
user_ini.cache_ttl | "300" | PHP_INI_SYSTEM |
user_ini.filename | ".user.ini" | PHP_INI_SYSTEM |
uopz.disable | "0" | PHP_INI_SYSTEM | Available as of uopz 5.0.2
uopz.exit | "0" | PHP_INI_SYSTEM | Available as of uopz 6.0.1
uopz.overloads | "1" | PHP_INI_SYSTEM | Available as of uopz 2.0.2. Removed as of uopz 5.0.0.
variables_order | "EGPCS" | PHP_INI_PERDIR |
vld.active | "0" | PHP_INI_SYSTEM |
vld.execute | "1" | PHP_INI_SYSTEM | 从 vld 0.8.0 起可用。
vld.skip_append | "0" | PHP_INI_SYSTEM | 从 vld 0.8.0 起可用。
vld.skip_prepend | "0" | PHP_INI_SYSTEM | 从 vld 0.8.0 起可用。
windows.show_crt_warning | "0" | PHP_INI_ALL |
xbithack | "0" | PHP_INI_ALL |
xmlrpc_errors | "0" | PHP_INI_SYSTEM |
xmlrpc_error_number | "0" | PHP_INI_ALL |
yaz.keepalive | "120" | PHP_INI_ALL |
yaz.log_mask | NULL | PHP_INI_ALL | 从 yaz 1.0.3 起可用。
zend.assertions | "1" | PHP_INI_ALL |
zend.detect_unicode | "1" | PHP_INI_ALL |
zend.enable_gc | "1" | PHP_INI_ALL |
zend.multibyte | "0" | PHP_INI_PERDIR |
zend.script_encoding | NULL | PHP_INI_ALL |
zend.signal_check | "0" | PHP_INI_SYSTEM |
zend_extension | NULL | php.ini only |
zlib.output_compression | "0" | PHP_INI_ALL |
zlib.output_compression_level | "-1" | PHP_INI_ALL |
zlib.output_handler | "" | PHP_INI_ALL |


php.ini 配置段列表

This list includes the php.ini sections you can set to configure your PHP setup on a per Host or Path basis. These sections are optional.

These sections don't directly affect PHP. They are used to group other php.ini directives together and to get them to act upon a particular host or on a particular path.

These sections are used only in CGI/FastCGI mode and they can not set extension and zend_extension directives.

配置段
名字 | 可修改范围 | 更新日志
[HOST=] | PHP_INI_SYSTEM | 在 PHP 5.3.0 时增加。
[PATH=] | PHP_INI_SYSTEM | 在 PHP 5.3.0 时增加。

这是配置指令的简短说明。

[HOST=<host>]

This section allows you to define a set of php.ini directives that will take effect on the named host.

Example #1 Activate full on-screen error reporting for dev. domain

[HOST=dev.site.com]
error_reporting = E_ALL
display_errors = On

[PATH=<path>]

This section allows you to define a set of php.ini directives that will take effect when a script runs from the named path.

Example #2 Add security script for protected areas

[PATH=/home/site/public/secure]
auto_prepend_file=security.php


php.ini 核心配置选项说明

该列表只包含核心的 php.ini 配置选项。扩展的配置选项在各个扩展的文档页面分别被描述。比如，有关 session 的选项可以在 sessions 页面找到。

Note:

以下列出了未设置 php.ini 时的默认值；开发环境和生产环境的 php.ini 值可能会有所不同。

语言选项

语言和杂类配置选项
名字 | 默认 | 可修改范围 | 更新日志
short_open_tag | "1" | PHP_INI_PERDIR |
precision | "14" | PHP_INI_ALL |
serialize_precision | "-1" | PHP_INI_ALL | 在 PHP 7.1.0 以前，默认值为 17。
disable_functions | "" | 仅仅为 PHP_INI_SYSTEM |
disable_classes | "" | 仅仅为 php.ini |
exit_on_timeout | "" | PHP_INI_ALL |
expose_php | "1" | php.ini only |
hard_timeout | "2" | PHP_INI_SYSTEM | 从 PHP 7.1.0 起可用
zend.exception_ignore_args | "0" | PHP_INI_ALL | 从 PHP 7.4.0 起可用
zend.multibyte | "0" | PHP_INI_ALL |
zend.script_encoding | NULL | PHP_INI_ALL |
zend.detect-unicode | NULL | PHP_INI_ALL | 从 PHP 5.4.0 起可用
zend.signal_check | "0" | PHP_INI_SYSTEM |
zend.assertions | "1" | PHP_INI_ALL |

这是配置指令的简短说明。

short_open_tag bool

决定是否允许使用 PHP 代码开始标志的缩写形式（<? ?>）。如果要和 XML 结合使用 PHP，可以禁用此选项以便于嵌入使用 <?xml ?>。否则还可以通过 PHP 来输出，例如：<?php echo '<?xml version="1.0"'; ?>。如果禁用了，必须使用 PHP 代码开始标志的完整形式（<?php ?>）。

Note:

本指令不会影响到缩写形式 <?=，因为它总是可用的。

precision int
浮点数中显示有效数字的位数。-1 means that an enhanced algorithm for rounding such numbers will be used.
serialize_precision int
The number of significant digits stored while serializing floating point numbers. -1 means that an enhanced algorithm for rounding such numbers will be used.
expose_php bool

决定是否暴露 PHP 被安装在服务器上（例如在 Web 服务器的信息头中加上其签名：X-Powered-By: PHP/5.3.7)。

disable_functions string

本指令可用于禁止某些函数。接受逗号分隔的函数名列表作为参数。

此指令仅能禁用 内置函数。 不能影响用户自定义函数。

本指令只能设置在 php.ini 中。例如，无法在 httpd.conf 中设置。

disable_classes string
本指令可以使你禁用某些类。用逗号分隔类名。 本指令只能设置在 php.ini 中。例如不能将其设置在 httpd.conf。
zend.assertions int
When set to 1, assertion code will be generated and executed (development mode). When set to 0, assertion code will be generated but it will be skipped (not executed) at runtime. When set to -1, assertion code will not be generated, making the assetions zero-cost (production mode).

Note:

If a process is started in production mode, zend.assertions cannot be changed at runtime, since the code for assertions was not generated.

If a process is started in development mode, zend.assertions cannot be set to -1 at runtime.

hard_timeout int

zend.exception_ignore_args bool

从异常产生的堆栈中排除参数。

zend.multibyte bool

启用多字节编码的源文件解析功能。启用 zend.multibyte 是使用 SJIS、BIG5 等在多字节字符串数据中包含特殊字符的字符编码所必需的。ISO-8859-1 兼容的编码，如 UTF-8、EUC 等，则不需要这个选项。

启用 zend.multibyte 需要 mbstring 扩展可用。

zend.script_encoding string

This value will be used unless a declare(encoding=...) directive appears at the top of the script. When ISO-8859-1 incompatible encoding is used, both zend.multibyte and zend.script_encoding must be used.

Literal strings will be transliterated from zend.script_enconding to mbstring.internal_encoding, as if mb_convert_encoding() would have been called.

zend.detect_unicode bool

Check for BOM (Byte Order Mark) and see if the file contains valid multibyte characters. This detection is performed before processing of __halt_compiler(). Available only in Zend Multibyte mode.

zend.signal_check bool

To check for replaced signal handlers on shutdown.

exit_on_timeout bool

这是一个用于 Apache 1 的 mod_php-only 指令，如果 PHP 执行超时，会强制 Apache 子程序退出.这样的超时会导致 Apache 1 内部的 longjmp() 调用，从而使一些扩展处于不一致的状态。通过终止进程，任何未完成的锁或内存将被清理。

资源限制

资源限制
名字 | 默认 | 可修改范围 | 更新日志
memory_limit | "128M" | PHP_INI_ALL |

这是配置指令的简短说明。

memory_limit int

设置了一个脚本允许分配的最大内存量，以字节（bytes）为单位。这有助于防止写得不好的脚本吃掉服务器上所有可用的内存。请注意，如果不需要内存限制，请将此指令设置为 -1。

当使用 int 时, 其值以字节来衡量。还可以使用在FAQ中描述的速记符。

请参阅：max_execution_time。

性能调整

性能调整
名字 | 默认 | 可修改范围 | 更新日志
realpath_cache_size | "4M" | PHP_INI_SYSTEM | PPHP 7.0.16 和 7.1.2 之前，默认值为 "16K"
realpath_cache_ttl | "120" | PHP_INI_SYSTEM |

Note:

启用 open_basedir 将会 禁用 realpath cache。

这是配置指令的简短说明。

realpath_cache_size int

设定 PHP 使用的 realpath 缓存的大小。在 PHP 打开很多文件的系统中，这个值应该增加，以优化文件操作的数量。

这里的大小表示存储的路径字符串的总字节数，加上与缓存条目相关的数据大小。这意味着，为了在缓存中存储更长的路径，缓存大小必须更大。这个值不直接控制可以缓存的不同路径的数量。

缓存输入数据所需的大小取决于操作系统。

realpath_cache_ttl integer

缓存给定文件或目录的真实路径信息的持续时间（以秒为单位）。对于很少改变文件的系统，可以考虑增加该值。

数据处理

数据处理配置选项
名字 | 默认 | 可修改范围 | 更新日志
arg_separator.output | "&" | PHP_INI_ALL |
arg_separator.input | "&" | PHP_INI_PERDIR |
variables_order | "EGPCS" | PHP_INI_PERDIR |
request_order | "" | PHP_INI_PERDIR |
auto_globals_jit | "1" | PHP_INI_PERDIR |
register_argc_argv | "1" | PHP_INI_PERDIR |
enable_post_data_reading | "1" | PHP_INI_PERDIR | 从 PHP 5.4.0 起可用。
post_max_size | "8M" | PHP_INI_PERDIR |
auto_prepend_file | NULL | PHP_INI_PERDIR |
auto_append_file | NULL | PHP_INI_PERDIR |
default_mimetype | "text/html" | PHP_INI_ALL |
default_charset | "UTF-8" | PHP_INI_ALL |
input_encoding | "" | PHP_INI_ALL |
output_encoding | "" | PHP_INI_ALL |
internal_encoding | "" | PHP_INI_ALL |

这是配置指令的简短说明。

arg_separator.output string

在 PHP 生成的 URL 中用来分隔参数的分隔符。

arg_separator.input string

PHP 用于将输入的 URL 解析为变量的分隔符列表。

Note:

本指令中的每一个字符都被视为分隔符！

variables_order string

Sets the order of the EGPCS (Environment, Get, Post, Cookie, and Server) variable parsing. For example, if variables_order is set to "SP" then PHP will create the superglobals $_SERVER and $_POST, but not create $_ENV, $_GET, and $_COOKIE. Setting to "" means no superglobals will be set.

Warning

In both the CGI and FastCGI SAPIs, $_SERVER is also populated by values from the environment; S is always equivalent to ES regardless of the placement of E elsewhere in this directive.

Note:

The content and order of $_REQUEST is also affected by this directive.

request_order string

This directive describes the order in which PHP registers GET, POST and Cookie variables into the _REQUEST array. Registration is done from left to right, newer values override older values.

If this directive is not set, variables_order is used for $_REQUEST contents.

Note that the default distribution php.ini files does not contain the 'C' for cookies, due to security concerns.

auto_globals_jit bool

When enabled, the SERVER, REQUEST, and ENV variables are created when they're first used (Just In Time) instead of when the script starts. If these variables are not used within a script, having this directive on will result in a performance gain.

Warning

Usage of SERVER, REQUEST, and ENV variables is checked during the compile time so using them through e.g. variable variables will not cause their initialization.

register_argc_argv bool
Tells PHP whether to declare the argv & argc variables (that would contain the GET information). See also command line.
enable_post_data_reading bool
Disabling this option causes $_POST and $_FILES not to be populated. The only way to read postdata will then be through the php://input stream wrapper. This can be useful to proxy requests or to process the POST data in a memory efficient fashion.
post_max_size int
Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize. Generally speaking, memory_limit should be larger than post_max_size. 当使用 int 时, 其值以字节来衡量。还可以使用在FAQ中描述的速记符。 If the size of post data is greater than post_max_size, the $_POST and $_FILES superglobals are empty. This can be tracked in various ways, e.g. by passing the $_GET variable to the script processing the data, i.e. <form action="edit.php?processed=1">, and then checking if $_GET['processed'] is set.

Note:

PHP allows shortcuts for byte values, including K (kilo), M (mega) and G (giga). PHP will do the conversions automatically if you use any of these. Be careful not to exceed the 32 bit signed integer limit (if you're using 32bit versions) as it will cause your script to fail.

Changelog for post_max_size
版本 | 说明
5.3.4 | post_max_size = 0 will not disable the limit when the content type is application/x-www-form-urlencoded or is not registered with PHP.
5.3.2 , 5.2.12 | Allow unlimited post size by setting post_max_size to 0.

auto_prepend_file string

Specifies the name of a file that is automatically parsed before the main file. The file is included as if it was called with the require function, so include_path is used.

The special value none disables auto-prepending.

auto_append_file string

Specifies the name of a file that is automatically parsed after the main file. The file is included as if it was called with the require function, so include_path is used.

The special value none disables auto-appending.

Note: If the script is terminated with exit(), auto-append will not occur.

default_mimetype string

By default, PHP will output a media type using the Content-Type header. To disable this, simply set it to be empty.

PHP's built-in default media type is set to text/html.

default_charset string

"UTF-8" is the default value and its value is used as the default character encoding for htmlentities(), html_entity_decode() and htmlspecialchars() if the encoding parameter is omitted. The value of default_charset will also be used to set the default character set for iconv functions if the iconv.input_encoding, iconv.output_encoding and iconv.internal_encoding configuration options are unset, and for mbstring functions if the mbstring.http_input mbstring.http_output mbstring.internal_encoding configuration option is unset.

All versions of PHP will use this value as the charset within the default Content-Type header sent by PHP if the header isn't overridden by a call to header().

Setting default_charset to an empty value is not recommended.

input_encoding string

This setting is used for multibyte modules such as mbstring and iconv. Default is empty.

output_encoding string

This setting is used for multibyte modules such as mbstring and iconv. Default is empty.

internal_encoding string

This setting is used for multibyte modules such as mbstring and iconv. Default is empty. If empty, default_charset is used.

See also: magic_quotes_gpc, magic_quotes_runtime, and magic_quotes_sybase.

Paths and Directories

Paths and Directories Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
include_path | ".;/path/to/php/pear" | PHP_INI_ALL |
open_basedir | NULL | PHP_INI_ALL |
doc_root | NULL | PHP_INI_SYSTEM |
user_dir | NULL | PHP_INI_SYSTEM |
user_ini.cache_ttl | "300" | PHP_INI_SYSTEM |
user_ini.filename | ".user.ini" | PHP_INI_SYSTEM |
extension_dir | "/path/to/php" | PHP_INI_SYSTEM |
extension | NULL | php.ini only |
zend_extension | NULL | php.ini only |
cgi.check_shebang_line | "1" | PHP_INI_SYSTEM |
cgi.discard_path | "0" | PHP_INI_SYSTEM |
cgi.fix_pathinfo | "1" | PHP_INI_SYSTEM |
cgi.force_redirect | "1" | PHP_INI_SYSTEM |
cgi.nph | "0" | PHP_INI_SYSTEM |
cgi.redirect_status_env | NULL | PHP_INI_SYSTEM |
cgi.rfc2616_headers | "0" | PHP_INI_ALL |
fastcgi.impersonate | "0" | PHP_INI_SYSTEM |
fastcgi.logging | "1" | PHP_INI_SYSTEM |

这是配置指令的简短说明。

include_path string

Specifies a list of directories where the require, include, fopen(), file(), readfile() and file_get_contents() functions look for files. The format is like the system's PATH environment variable: a list of directories separated with a colon in Unix or semicolon in Windows.

PHP considers each entry in the include path separately when looking for files to include. It will check the first path, and if it doesn't find it, check the next path, until it either locates the included file or returns with an E_WARNING or an E_ERROR. You may modify or set your include path at runtime using set_include_path().

Example #1 Unix include_path

include_path=".:/php/includes"

Example #2 Windows include_path

include_path=".;c:\php\includes"

Using a . in the include path allows for relative includes as it means the current directory. However, it is more efficient to explicitly use include './file' than having PHP always check the current directory for every include.

Note:

ENV variables are also accessible in .ini files. As such it is possible to reference the home directory using ${LOGIN} and ${USER}.

Environment variables may vary between Server APIs as those environments may be different.

Example #3 Unix include_path using ${USER} env variable

include_path = ".:${USER}/pear/php"

open_basedir string

Limit the files that can be accessed by PHP to the specified directory-tree, including the file itself. This directive is NOT affected by whether Safe Mode is turned On or Off.

When a script tries to access the filesystem, for example using include, or fopen(), the location of the file is checked. When the file is outside the specified directory-tree, PHP will refuse to access it. All symbolic links are resolved, so it's not possible to avoid this restriction with a symlink. If the file doesn't exist then the symlink couldn't be resolved and the filename is compared to (a resolved) open_basedir.

open_basedir can affect more than just filesystem functions; for example if MySQL is configured to use mysqlnd drivers, LOAD DATA INFILE will be affected by open_basedir. Much of the extended functionality of PHP uses open_basedir in this way.

The special value . indicates that the working directory of the script will be used as the base-directory. This is, however, a little dangerous as the working directory of the script can easily be changed with chdir().

In httpd.conf, open_basedir can be turned off (e.g. for some virtual hosts) the same way as any other configuration directive with "php_admin_value open_basedir none".

Under Windows, separate the directories with a semicolon. On all other systems, separate the directories with a colon. As an Apache module, open_basedir paths from parent directories are now automatically inherited.

The restriction specified with open_basedir is a directory name, not a prefix.

The default is to allow all files to be opened.

Note:

open_basedir can be tightened at run-time. This means that if open_basedir is set to /www/ in php.ini a script can tighten the configuration to /www/tmp/ at run-time with ini_set(). When listing several directories, you can use the PATH_SEPARATOR constant as a separator regardless of the operating system.

Note:

Using open_basedir will set realpath_cache_size to 0 and thus disable the realpath cache.

doc_root string

PHP's "root directory" on the server. Only used if non-empty. If PHP was not compiled with FORCE_REDIRECT, you should set doc_root if you are running PHP as a CGI under any web server (other than IIS). The alternative is to use the cgi.force_redirect configuration below.

user_ini.cache_ttl int

user_ini.filename string

user_dir string

The base name of the directory used on a user's home directory for PHP files, for example public_html .

extension_dir string

In what directory PHP should look for dynamically loadable extensions. See also: enable_dl, and dl().

extension string

Which dynamically loadable extensions to load when PHP starts up.

zend_extension string

Name of dynamically loadable Zend extension (for example XDebug) to load when PHP starts up.

cgi.check_shebang_line bool

Controls whether CGI PHP checks for line starting with #! (shebang) at the top of the running script. This line might be needed if the script support running both as stand-alone script and via PHP CGI. PHP in CGI mode skips this line and ignores its content if this directive is turned on.

cgi.discard_path bool

If this is enabled, the PHP CGI binary can safely be placed outside of the web tree and people will not be able to circumvent .htaccess security.

cgi.fix_pathinfo bool

Provides real PATH_INFO/ PATH_TRANSLATED support for CGI. PHP's previous behaviour was to set PATH_TRANSLATED to SCRIPT_FILENAME, and to not grok what PATH_INFO is. For more information on PATH_INFO, see the CGI specs. Setting this to 1 will cause PHP CGI to fix its paths to conform to the spec. A setting of zero causes PHP to behave as before. It is turned on by default. You should fix your scripts to use SCRIPT_FILENAME rather than PATH_TRANSLATED.

cgi.force_redirect bool

cgi.force_redirect is necessary to provide security running PHP as a CGI under most web servers. Left undefined, PHP turns this on by default. You can turn it off at your own risk.

Note:

Windows Users: When using IIS this option must be turned off. For OmniHTTPD or Xitami the same applies.

cgi.nph bool

If cgi.nph is enabled it will force cgi to always sent Status: 200 with every request.

cgi.redirect_status_env string

If cgi.force_redirect is turned on, and you are not running under Apache or Netscape (iPlanet) web servers, you may need to set an environment variable name that PHP will look for to know it is OK to continue execution.

Note:

Setting this variable may cause security issues, know what you are doing first.

cgi.rfc2616_headers int

Tells PHP what type of headers to use when sending HTTP response code. If it's set to 0, PHP sends a » RFC 3875 "Status:" header that is supported by Apache and other web servers. When this option is set to 1, PHP will send » RFC 2616 compliant headers.

If this option is enabled, and you are running PHP in a CGI environment (e.g. PHP-FPM) you should not use standard RFC 2616 style HTTP status response headers, you should instead use their RFC 3875 equivalent e.g. instead of header("HTTP/1.0 404 Not found"); you should use header("Status: 404 Not Found");

Leave it set to 0 unless you know what you're doing.

fastcgi.impersonate string

FastCGI under IIS (on WINNT based OS) supports the ability to impersonate security tokens of the calling client. This allows IIS to define the security context that the request runs under. mod_fastcgi under Apache does not currently support this feature (03/17/2002) Set to 1 if running under IIS. Default is zero.

fastcgi.logging bool

Turns on SAPI logging when using FastCGI. Default is to enable logging.

File Uploads

File Uploads Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
file_uploads | "1" | PHP_INI_SYSTEM |
upload_tmp_dir | NULL | PHP_INI_SYSTEM |
max_input_nesting_level | 64 | PHP_INI_PERDIR |
max_input_vars | 1000 | PHP_INI_PERDIR |
upload_max_filesize | "2M" | PHP_INI_PERDIR |
max_file_uploads | 20 | PHP_INI_SYSTEM |

这是配置指令的简短说明。

file_uploads bool

Whether or not to allow HTTP file uploads. See also the upload_max_filesize, upload_tmp_dir, and post_max_size directives.

upload_tmp_dir string

The temporary directory used for storing files when doing file upload. Must be writable by whatever user PHP is running as. If not specified PHP will use the system's default.

If the directory specified here is not writable, PHP falls back to the system default temporary directory. If open_basedir is on, then the system default directory must be allowed for an upload to succeed.

upload_max_filesize int

The maximum size of an uploaded file.

当使用 int 时, 其值以字节来衡量。还可以使用在FAQ中描述的速记符。
max_file_uploads int

The maximum number of files allowed to be uploaded simultaneously. Starting with PHP 5.3.4, upload fields left blank on submission do not count towards this limit.

General SQL

General SQL Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
sql.safe_mode | "0" | PHP_INI_SYSTEM | Removed as of PHP 7.2.0

这是配置指令的简短说明。

sql.safe_mode bool

If turned on, database connection functions that specify default values will use those values in place of any user-supplied arguments. For details on the default values, see the documentation for the relevant connection functions.

Warning

This feature has been REMOVED as of PHP 7.2.0.

Windows Specific

Windows Specific Configuration Options
名字 | 默认 | 可修改范围 | 更新日志
windows.show_crt_warning | "0" | PHP_INI_ALL |

这是配置指令的简短说明。

windows.show_crt_warning bool

This directive shows the Windows CRT warnings when enabled.


扩展库列表／归类

Table of Contents

  • 按字母顺序
  • 按归属分
  • 按状态分

本附录将 PHP 手册中的 150 多个扩展库以不同标准分类。


按字母顺序

  • Apache
  • APCu
  • 数组
  • BC Math
  • Bzip2
  • Calendar
  • Classkit
  • 类/对象
  • COM
  • CSPRNG
  • Ctype
  • CUBRID
  • cURL
  • 日期/时间
  • DBA
  • dBase
  • DB++
  • Direct IO
  • 目录
  • DOM
  • Data Structures
  • Eio
  • Enchant
  • 错误处理
  • Ev
  • Event
  • 程序执行
  • Exif
  • Expect
  • FANN
  • FANN
  • FrontBase
  • FDF
  • Fileinfo
  • filePro
  • 文件系统
  • Filter
  • FastCGI 进程管理器
  • FTP
  • 函数处理
  • Gearman
  • Gender
  • GeoIP
  • Gettext
  • Gmagick
  • GMP
  • GnuPG
  • Hash
  • HRTime
  • Firebird/InterBase
  • IBM DB2
  • iconv
  • GD
  • ImageMagick
  • IMAP
  • PHP 选项/信息
  • Ingres
  • Inotify
  • intl
  • JSON
  • LDAP
  • libxml
  • Lua
  • LZF
  • Mail
  • Mailparse
  • Math
  • 多字节字符串
  • Mcrypt
  • Memcache
  • Memcached
  • Memtrack
  • Mhash
  • Misc.
  • Mongo
  • MongoDB\BSON
  • MongoDB\Driver
  • mqseries
  • Mysql（原始）
  • Mysqli
  • Mysqlnd
  • mysqlnd_memcache
  • mysqlnd_ms
  • mysqlnd_mux
  • mysqlnd_qc
  • mysqlnd_uh
  • Ncurses
  • 网络
  • OAuth
  • OCI8
  • OPcache
  • OpenAL
  • OpenSSL
  • 输出控制
  • Paradox
  • Parle
  • 密码散列算法
  • PCNTL
  • PCRE
  • PDO
  • CUBRID (PDO)
  • MS SQL Server (PDO)
  • Firebird (PDO)
  • IBM (PDO)
  • Informix (PDO)
  • MySQL (PDO)
  • Oracle (PDO)
  • ODBC and DB2 (PDO)
  • PostgreSQL (PDO)
  • SQLite (PDO)
  • MS SQL Server (PDO)
  • PostgreSQL
  • Phar
  • POSIX
  • Proctitle
  • PS
  • Pspell
  • pthreads
  • Quickhash
  • Radius
  • Rar
  • Readline
  • Recode
  • 反射
  • POSIX Regex
  • RRD
  • ScoutAPM
  • SeasLog
  • Semaphore
  • Sessions
  • Shared Memory
  • SimpleXML
  • SNMP
  • SOAP
  • Sockets
  • Sodium
  • Solr
  • Sphinx
  • SPL
  • SQLite3
  • SQLSRV
  • ssdeep
  • SSH2
  • Statistics
  • Stomp
  • Streams
  • 字符串
  • SVM
  • SVN
  • Swoole
  • Sync
  • Taint
  • TCP
  • Tidy
  • Tokenizer
  • tokyo_tyrant
  • Trader
  • UI
  • ODBC
  • uopz
  • URLs
  • V8js
  • Variable handling
  • Varnish
  • WDDX
  • Weakref
  • win32service
  • WinCache
  • wkhtmltox
  • xattr
  • xdiff
  • Xhprof
  • XML 解析器
  • XMLDiff
  • XMLReader
  • XML-RPC
  • XMLWriter
  • XSL
  • Yaconf
  • Yaf
  • Yaml
  • Yar
  • YAZ
  • Zip
  • Zlib
  • 0MQ消息系统
  • ZooKeeper


按归属分

核心扩展库

以下并非真正的扩展库，它们属于 PHP 内核的一部分，不能通过编译选项将其排除。

  • 数组

  • 类/对象

  • CSPRNG

  • 日期/时间

  • 目录

  • 错误处理

  • 程序执行

  • 文件系统

  • Filter

  • 函数处理

  • Hash

  • PHP 选项/信息

  • Mail

  • Math

  • Misc.

  • 网络

  • 输出控制

  • 密码散列算法

  • Phar

  • 反射

  • POSIX Regex

  • Sessions

  • SPL

  • Streams

  • 字符串

  • Tokenizer

  • URLs

  • Variable handling

绑定的扩展库

以下扩展库绑定在 PHP 发行包中。

  • Apache

  • BC Math

  • Calendar

  • COM

  • Ctype

  • DBA

  • Exif

  • Fileinfo

  • FTP

  • iconv

  • GD

  • intl

  • JSON

  • 多字节字符串

  • OPcache

  • PCNTL

  • PCRE

  • PDO

  • POSIX

  • Semaphore

  • Shared Memory

  • Sockets

  • SQLite3

  • XML-RPC

  • Zlib

外部扩展库

这些扩展库已经包含在PHP中但是需要编译它们才能使用，并且可能需要额外的扩展库。

  • Bzip2

  • cURL

  • dBase

  • DOM

  • Enchant

  • FrontBase

  • Gettext

  • GMP

  • Firebird/InterBase

  • IMAP

  • LDAP

  • libxml

  • Mcrypt

  • Mhash

  • Mysql（原始）

  • Mysqli

  • Mysqlnd

  • OCI8

  • OpenSSL

  • MS SQL Server (PDO)

  • Firebird (PDO)

  • MySQL (PDO)

  • Oracle (PDO)

  • ODBC and DB2 (PDO)

  • PostgreSQL (PDO)

  • SQLite (PDO)

  • PostgreSQL

  • Pspell

  • Readline

  • Recode

  • SimpleXML

  • SNMP

  • SOAP

  • Sodium

  • Tidy

  • ODBC

  • WDDX

  • XML 解析器

  • XMLReader

  • XMLWriter

  • XSL

  • Zip

PECL 扩展库

以下扩展来自 » PECL，它们可能需要额外的库。还有更多的 PECL 扩展存在，但是在 PHP 手册中尚未有文档。

  • Classkit

  • CUBRID

  • DB++

  • Direct IO

  • Eio

  • Ev

  • Event

  • Expect

  • FDF

  • filePro

  • Gearman

  • Gender

  • GeoIP

  • Gmagick

  • GnuPG

  • IBM DB2

  • ImageMagick

  • Ingres

  • Inotify

  • Lua

  • LuaSandbox

  • LZF

  • Mailparse

  • Memcache

  • Memcached

  • Memtrack

  • Mongo

  • mqseries

  • mysqlnd_memcache

  • mysqlnd_ms

  • mysqlnd_mux

  • mysqlnd_qc

  • mysqlnd_uh

  • Ncurses

  • OAuth

  • OpenAL

  • Paradox

  • CUBRID (PDO)

  • IBM (PDO)

  • Informix (PDO)

  • MS SQL Server (PDO)

  • Proctitle

  • PS

  • pthreads

  • Quickhash

  • Radius

  • Rar

  • RRD

  • runkit7

  • ScoutAPM

  • SeasLog

  • Solr

  • Sphinx

  • SQLSRV

  • ssdeep

  • SSH2

  • Statistics

  • Stomp

  • Swoole

  • SVM

  • SVN

  • Taint

  • TCP

  • tokyo_tyrant

  • Trader

  • V8js

  • Varnish

  • Weakref

  • win32service

  • WinCache

  • xattr

  • xdiff

  • Xhprof

  • Yaf

  • Yaml

  • YAZ

  • ZooKeeper


按状态分

此部分所列出的扩展项不适用于生产环境――它们要么太老（已废弃），要么太新（试验中）。

已废弃的扩展库

以下扩展库已被废弃，通常有其他的扩展库替代。

  • Memtrack

试验中的扩展库

以下扩展库的行为――包括其函数的名称和所记载的有关此扩展库的其它任何东西――可能没有任何通知就在 PHP 的未来版本中进行变更。使用这些扩展时风险自担。

  • DB++

  • Hash

  • ImageMagick

  • Ncurses

  • Paradox

  • MS SQL Server (PDO)

  • Firebird (PDO)

  • Oracle (PDO)

  • PS

  • XML-RPC


函数别名列表

这里是函数别名列表，所有的别名列表如下。通常使用别名并不是一个好主意，这是因为它可能会废弃不用或者重新定义。这会导致不可移植脚本的出现。本列表是为了帮助想要升级他们旧有脚本到新版本语法的开发人员。很多 PHP 函数都有一个别名，可以用别名调用它。在某些情况下，两个名称都非常合适，无从取舍，is_int() 和 is_integer() 就是一个很好的例子。而有些情况则是，由于内部 API 的清理或其它一些原因，函数名被修改，但是老的名称保留了下来，以确保向后兼容性。使用这种别名通常不是个好主意，因为这种别名可能会被完全废弃或更名，导致脚本难以移植到新版本的 PHP 上。我们提供了本列表，来帮助那些要升级旧程序到更新语法的人。

别名列表
别名 | 主函数 | 使用的扩展模块
_ | gettext() | Gettext
chop | rtrim() | 基本语法
close | closedir() | 基本语法
com_get | com_propget() | COM
com_propset | com_propput() | COM
com_set | com_propput() | COM
die | exit() | 杂类函数
diskfreespace | disk_free_space() | 文件系统函数
doubleval | floatval() | 基本语法
fbsql | fbsql_db_query() | FrontBase
fputs | fwrite() | 基本语法
gzputs | gzwrite() | Zlib
i18n_convert | mb_convert_encoding() | 多字节字符串函数
i18n_discover_encoding | mb_detect_encoding() | 多字节字符串函数
i18n_http_input | mb_http_input() | 多字节字符串函数
i18n_http_output | mb_http_output() | 多字节字符串函数
i18n_internal_encoding | mb_internal_encoding() | 多字节字符串函数
i18n_ja_jp_hantozen | mb_convert_kana() | 多字节字符串函数
i18n_mime_header_decode | mb_decode_mimeheader() | 多字节字符串函数
i18n_mime_header_encode | mb_encode_mimeheader() | 多字节字符串函数
imap_create | imap_createmailbox() | IMAP
imap_fetchtext | imap_body() | IMAP
imap_getmailboxes | imap_list_full() | IMAP
imap_getsubscribed | imap_lsub_full() | IMAP
imap_header | imap_headerinfo() | IMAP
imap_listmailbox | imap_list() | IMAP
imap_listsubscribed | imap_lsub() | IMAP
imap_rename | imap_renamemailbox() | IMAP
imap_scan | imap_listscan() | IMAP
imap_scanmailbox | imap_listscan() | IMAP
ini_alter | ini_set() | 基本语法
is_double | is_float() | 基本语法
is_integer | is_int() | 基本语法
is_long | is_int() | 基本语法
is_real | is_float() | 基本语法
is_writeable | is_writable() | 基本语法
join | implode() | 基本语法
key_exists | array_key_exists() | 基本语法
ldap_close | ldap_unbind() | LDAP
magic_quotes_runtime | set_magic_quotes_runtime() | 基本语法
mbstrcut | mb_strcut() | 多字节字符串函数
mbstrlen | mb_strlen() | 多字节字符串函数
mbstrpos | mb_strpos() | 多字节字符串函数
mbstrrpos | mb_strrpos() | 多字节字符串函数
mbsubstr | mb_substr() | 多字节字符串函数
mysql | mysql_db_query() | MySQL
mysql_createdb | mysql_create_db() | MySQL
mysql_db_name | mysql_result() | MySQL
mysql_dbname | mysql_result() | MySQL
mysql_dropdb | mysql_drop_db() | MySQL
mysql_fieldflags | mysql_field_flags() | MySQL
mysql_fieldlen | mysql_field_len() | MySQL
mysql_fieldname | mysql_field_name() | MySQL
mysql_fieldtable | mysql_field_table() | MySQL
mysql_fieldtype | mysql_field_type() | MySQL
mysql_freeresult | mysql_free_result() | MySQL
mysql_listdbs | mysql_list_dbs() | MySQL
mysql_listfields | mysql_list_fields() | MySQL
mysql_listtables | mysql_list_tables() | MySQL
mysql_numfields | mysql_num_fields() | MySQL
mysql_numrows | mysql_num_rows() | MySQL
mysql_selectdb | mysql_select_db() | MySQL
mysql_tablename | mysql_result() | MySQL
ociassignelem | OCI-Collection::assignElem | OCI8
ocibindbyname | oci_bind_by_name() | OCI8
ocicancel | oci_cancel() | OCI8
ocicloselob | OCI-Lob::close | OCI8
ocicollappend | OCI-Collection::append | OCI8
ocicollassign | OCI-Collection::assign | OCI8
ocicollmax | OCI-Collection::max | OCI8
ocicollsize | OCI-Collection::size | OCI8
ocicolltrim | OCI-Collection::trim | OCI8
ocicolumnisnull | oci_field_is_null() | OCI8
ocicolumnname | oci_field_name() | OCI8
ocicolumnprecision | oci_field_precision() | OCI8
ocicolumnscale | oci_field_scale() | OCI8
ocicolumnsize | oci_field_size() | OCI8
ocicolumntype | oci_field_type() | OCI8
ocicolumntyperaw | oci_field_type_raw() | OCI8
ocicommit | oci_commit() | OCI8
ocidefinebyname | oci_define_by_name() | OCI8
ocierror | oci_error() | OCI8
ociexecute | oci_execute() | OCI8
ocifetch | oci_fetch() | OCI8
ocifetchinto | oci_fetch_array(), oci_fetch_row(), oci_fetch_assoc(), oci_fetch_object() | OCI8
ocifetchstatement | oci_fetch_all() | OCI8
ocifreecollection | OCI-Collection::free | OCI8
ocifreecursor | oci_free_statement() | OCI8
ocifreedesc | oci_free_descriptor() | OCI8
ocifreestatement | oci_free_statement() | OCI8
ocigetelem | OCI-Collection::getElem | OCI8
ociinternaldebug | oci_internal_debug() | OCI8
ociloadlob | OCI-Lob::load | OCI8
ocilogon | oci_connect() | OCI8
ocinewcollection | oci_new_collection() | OCI8
ocinewcursor | oci_new_cursor() | OCI8
ocinewdescriptor | oci_new_descriptor() | OCI8
ocinlogon | oci_new_connect() | OCI8
ocinumcols | oci_num_fields() | OCI8
ociparse | oci_parse() | OCI8
ocipasswordchange | oci_password_change() | OCI8
ociplogon | oci_pconnect() | OCI8
ociresult | oci_result() | OCI8
ocirollback | oci_rollback() | OCI8
ocisavelob | OCI-Lob::save | OCI8
ocisavelobfile | OCI-Lob::import | OCI8
ociserverversion | oci_server_version() | OCI8
ocisetprefetch | oci_set_prefetch() | OCI8
ocistatementtype | oci_statement_type() | OCI8
ociwritelobtofile | OCI-Lob::export | OCI8
ociwritetemporarylob | OCI-Lob::writeTemporary | OCI8
odbc_do | odbc_exec() | ODBC
odbc_field_precision | odbc_field_len() | ODBC
pg_clientencoding | pg_client_encoding() | PostgreSQL
pg_setclientencoding | pg_set_client_encoding() | PostgreSQL
pos | current() | 基本语法
recode | recode_string() | Recode
show_source | highlight_file() | 基本语法
sizeof | count() | 基本语法
snmpwalkoid | snmprealwalk() | SNMP
strchr | strstr() | 基本语法
xptr_new_context | xpath_new_context() |


保留字列表

Table of Contents

  • 关键词列表
  • 预定义类
  • 预定义常量
  • 其他保留字列表

以下是 PHP 中预定义标识符的列表。没有列在下面的标识符可以在脚本中作为自定义标识符使用。这些列表包括关键字和预定义变量、常量和类名。这些列表可能有遗漏，它是不完整的。


关键词列表

这些词语在 PHP 中有着特殊的意义。它们中有些像是函数，有些像是常量......但是它们不是的，它们只是语言结构的一部分。不能使用它们的任何一个作为常量、方法名或是类名。但是可以将它们作为变量名使用，不过这样会导致混淆。

从PHP7.0.0开始这些关键字允许被用作类的属性、常量以及类的方法名，或者接口名和traints名，除了class不能被用作常量名。

PHP 关键词
__halt_compiler() | abstract | and | array() | as
break | callable (as of PHP 5.4) | case | catch | class
clone | const | continue | declare | default
die() | do | echo | else | elseif
empty() | enddeclare | endfor | endforeach | endif
endswitch | endwhile | eval() | exit() | extends
final | finally (从PHP 5.5开始) | for | foreach | function
global | goto (从PHP 5.3开始) | if | implements | include
include_once | instanceof | insteadof (从PHP 5.4开始) | interface | isset()
list() | namespace (从PHP 5.3开始) | new | or | print
private | protected | public | require | require_once
return | static | switch | throw | trait (从PHP 5.4开始)
try | unset() | use | var | while
xor | yield (从PHP 5.5开始) |  |  |
编译时常量
__CLASS__ | __DIR__ (从PHP 5.3开始) | __FILE__ | __FUNCTION__ | __LINE__ | __METHOD__
__NAMESPACE__ (从PHP 5.3开始) | __TRAIT__ (从PHP 5.4开始) |  |  |  |


预定义类

本节列出标准的预定义类。各种扩展库定义了其它类，其说明在各自的参考文档中。

标准类

这些类由一些内建在 PHP 中的标准函数定义。

Directory
由dir()创建.
stdClass
Created by typecasting to object.
__PHP_Incomplete_Class
Possibly created by unserialize().

自 PHP 5 起预定义的类

这些额外的预定义类是 PHP 5.0.0 引进的。

exception
ErrorException
Available since PHP 5.1.0.
php_user_filter

Closure

PHP5.3.0中引入了一个预定义的final类Closure，它可以用于实现 匿名函数

关于更多信息，可以查看匿名函数.

Generator

The predefined final class Generator was introduced in PHP 5.5.0. It is used for representing generators.

For more information, see its class page.

从PHP 7开始预定义的类和接口

这些预定义的类和接口是在PHP 7.0.0 中开始引入的。

ArithmeticError
AssertionError
DivisionByZeroError
Error
Throwable
ParseError
TypeError

特殊的类

以下这些标识符由于它们有特殊的用处，因此不可作为类名

self
Current class.
static
Current class in runtime.
parent
Parent class.


预定义常量

内核预定义常量

这些常量在 PHP 的内核中定义。它包含 PHP、Zend 引擎和 SAPI 模块。

PHP_VERSION (string)
The current PHP version as a string in "major.minor.release[extra]" notation.
PHP_MAJOR_VERSION (int)
The current PHP "major" version as an integer (e.g., int(5) from version "5.2.7-extra"). Available since PHP 5.2.7.
PHP_MINOR_VERSION (int)
The current PHP "minor" version as an integer (e.g., int(2) from version "5.2.7-extra"). Available since PHP 5.2.7.
PHP_RELEASE_VERSION (int)
The current PHP "release" version as an integer (e.g., int(7) from version "5.2.7-extra"). Available since PHP 5.2.7.
PHP_VERSION_ID (int)
The current PHP version as an integer, useful for version comparisons (e.g., int(50207) from version "5.2.7-extra"). Available since PHP 5.2.7.
PHP_EXTRA_VERSION (string)
The current PHP "extra" version as a string (e.g., '-extra' from version "5.2.7-extra"). Often used by distribution vendors to indicate a package version. Available since PHP 5.2.7.
PHP_ZTS (int)
Available since PHP 5.2.7.
PHP_DEBUG (int)
Available since PHP 5.2.7.
PHP_MAXPATHLEN (int)
The maximum length of filenames (including path) supported by this build of PHP. Available since PHP 5.3.0.
PHP_OS (string)
The operating system PHP was built for.
PHP_OS_FAMILY (string)
The operating system family PHP was built for. Either of 'Windows', 'BSD', 'Darwin', 'Solaris', 'Linux' or 'Unknown'. Available as of PHP 7.2.0.
PHP_SAPI (string)
The Server API for this build of PHP.参见 php_sapi_name()。
PHP_EOL (string)
当前平台中对于换行符的定义。自 PHP 5.0.2 起可用
PHP_INT_MAX (int)
当前 PHP 版本支持的最大整型数字。在 32 位系统中通常为 int(2147483647)，64 位系统中为 int(9223372036854775807)。自 PHP 5.0.5 起可用。
PHP_INT_MIN (int)
当前 PHP 版本支持的最大整型数字。在 32 位系统中通常为 int(-2147483648)，64 系统中为 int(-9223372036854775808)。自 PHP 7.0.0 起可用。通常情况下 PHP_INT_MIN === ~PHP_INT_MAX。
PHP_INT_SIZE (int)
The size of an integer in bytes in this build of PHP. 自 PHP 5.0.5 起可用
PHP_FLOAT_DIG (int)
Number of decimal digits that can be rounded into a float and back without precision loss. Available as of PHP 7.2.0.
PHP_FLOAT_EPSILON (float)
Smallest representable positive number x, so that x + 1.0 != 1.0. Available as of PHP 7.2.0.
PHP_FLOAT_MIN (float)
Smallest representable positive floating point number. If you need the smallest representable negative floating point number, use - PHP_FLOAT_MAX. Available as of PHP 7.2.0.
PHP_FLOAT_MAX (float)
Largest representable floating point number. Available as of PHP 7.2.0.
DEFAULT_INCLUDE_PATH (string)
PEAR_INSTALL_DIR (string)
PEAR_EXTENSION_DIR (string)
PHP_EXTENSION_DIR (string)
PHP_PREFIX (string)
The value "--prefix" was set to at configure.
PHP_BINDIR (string)
Specifies where the binaries were installed into.
PHP_BINARY (string)
Specifies the PHP binary path during script execution. Available since PHP 5.4.
PHP_MANDIR (string)
Specifies where the manpages were installed into. Available since PHP 5.3.7.
PHP_LIBDIR (string)
PHP_DATADIR (string)
PHP_SYSCONFDIR (string)
PHP_LOCALSTATEDIR (string)
PHP_CONFIG_FILE_PATH (string)
PHP_CONFIG_FILE_SCAN_DIR (string)
PHP_SHLIB_SUFFIX (string)
The build-platform's shared library suffix, such as "so" (most Unixes) or "dll" (Windows).
PHP_FD_SETSIZE (string)
The maximum number of file descriptors for select system calls. Available as of PHP 7.1.0.
E_ERROR (int)
Error reporting constant
E_WARNING (int)
Error reporting constant
E_PARSE (int)
Error reporting constant
E_NOTICE (int)
Error reporting constant
E_CORE_ERROR (int)
Error reporting constant
E_CORE_WARNING (int)
Error reporting constant
E_COMPILE_ERROR (int)
Error reporting constant
E_COMPILE_WARNING (int)
Error reporting constant
E_USER_ERROR (int)
Error reporting constant
E_USER_WARNING (int)
Error reporting constant
E_USER_NOTICE (int)
Error reporting constant
E_RECOVERABLE_ERROR (int)
Error reporting constant. Available since PHP 5.2.0
E_DEPRECATED (int)
Error reporting constant. Available since PHP 5.3.0
E_USER_DEPRECATED (int)
Error reporting constant. Available since PHP 5.3.0
E_ALL (int)
Error reporting constant
E_STRICT (int)
Error reporting constant
__COMPILER_HALT_OFFSET__ (int)
自 PHP 5.1.0 起有效
true (boolean)
See Booleans.
false (boolean)
See Booleans.
null (null)
See Null.
PHP_WINDOWS_EVENT_CTRL_C (int)
A Windows CTRL+C event. Available as of PHP 7.4.0 (Windows only).
PHP_WINDOWS_EVENT_CTRL_BREAK (int)
A Windows CTRL+BREAK event. Available as of PHP 7.4.0 (Windows only).

参见 魔术常量。

标准预定义常量

所有在核心扩展 的常量是 PHP 默认定义的。


其他保留字列表

以下关键字不可被用于类名、接口名和trait名，并且它们被禁止用于命名空间。

Reserved words
int (从PHP 7开始) | float (从PHP 7开始) | bool (从PHP 7开始) | string (从PHP 7开始)
true (从PHP 7开始) | false (从PHP 7开始) | null (从PHP 7开始)

以下关键词已经被建议保留。尽管你仍然可以将它们用于类名、接口名和trait名（以及命名空间），但是考虑到在将来的PHP版本中可能会使用，因此非常不推荐去使用它们。

Soft reserved words
resource (从PHP 7开始) object (从PHP 7开始) mixed (从PHP 7开始) numeric (从PHP 7开始)


资源类型列表

以下是一个建立，使用和销毁资源的函数列表。可以用 is_resource()函数测定一个变量是否是资源，函数 get_resource_type()则返回该资源的类型。

资源类型
资源类型名称 | 建立者 | 使用者 | 销毁者 | 定义
aspell | aspell_new() | aspell_check(), aspell_check_raw(), aspell_suggest() | None | Aspell dictionary
bzip2 | bzopen() | bzerrno(), bzerror(), bzerrstr(), bzflush(), bzread(), bzwrite() | bzclose() | Bzip2 file
COM | com_load() | com_invoke(), com_propget(), com_get(), com_propput(), com_set(), com_propput() | None | COM object reference
VARIANT
cpdf | cpdf_open() | cpdf_page_init(), cpdf_finalize_page(), cpdf_finalize(), cpdf_output_buffer(), cpdf_save_to_file(), cpdf_set_current_page(), cpdf_begin_text(), cpdf_end_text(), cpdf_show(), cpdf_show_xy(), cpdf_text(), cpdf_set_font(), cpdf_set_leading(), cpdf_set_text_rendering(), cpdf_set_horiz_scaling(), cpdf_set_text_rise(), cpdf_set_text_matrix(), cpdf_set_text_pos(), cpdf_set_text_pos(), cpdf_set_word_spacing(), cpdf_continue_text(), cpdf_stringwidth(), cpdf_save(), cpdf_translate(), cpdf_restore(), cpdf_scale(), cpdf_rotate(), cpdf_setflat(), cpdf_setlinejoin(), cpdf_setlinecap(), cpdf_setmiterlimit(), cpdf_setlinewidth(), cpdf_setdash(), cpdf_moveto(), cpdf_rmoveto(), cpdf_curveto(), cpdf_lineto(), cpdf_rlineto(), cpdf_circle(), cpdf_arc(), cpdf_rect(), cpdf_closepath(), cpdf_stroke(), cpdf_closepath_fill_stroke(), cpdf_fill_stroke(), cpdf_clip(), cpdf_fill(), cpdf_setgray_fill(), cpdf_setgray_stroke(), cpdf_setgray(), cpdf_setrgbcolor_fill(), cpdf_setrgbcolor_stroke(), cpdf_setrgbcolor(), cpdf_add_outline(), cpdf_set_page_animation(), cpdf_import_jpeg(), cpdf_place_inline_image(), cpdf_add_annotation() | cpdf_close() | PDF document with CPDF lib
cpdf outline
curl | curl_copy_handle(), curl_init() | curl_copy_handle(), curl_errno(), curl_error(), curl_exec(), curl_getinfo(), curl_setopt() | curl_close() | Curl session
dbm | dbmopen() | dbmexists(), dbmfetch(), dbminsert(), dbmreplace(), dbmdelete(), dbmfirstkey(), dbmnextkey() | dbmclose() | Link to DBM database
dba | dba_open() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | dba_close() | Link to DBA database
dba persistent | dba_popen() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | None | Persistent link to DBA database
dbase | dbase_open() | dbase_pack(), dbase_add_record(), dbase_replace_record(), dbase_delete_record(), dbase_get_record(), dbase_get_record_with_names(), dbase_numfields(), dbase_numrecords() | dbase_close() | Link to Dbase database
dbx_link_object | dbx_connect() | dbx_query() | dbx_close() | dbx connection
dbx_result_object | dbx_query() | None | dbx result
domxml attribute
domxml document
domxml node
xpath context
xpath object
fbsql link | fbsql_change_user(), fbsql_connect() | fbsql_autocommit(), fbsql_blob_size(), fbsql_clob_size(), fbsql_commit(), fbsql_change_user(), fbsql_create_blob(), fbsql_create_db(), fbsql_create_clob(), fbsql_data_seek(), fbsql_database_password(), fbsql_database(), fbsql_db_query(), fbsql_db_status(), fbsql_drop_db(), fbsql_errno(), fbsql_error(), fbsql_get_autostart_info(), fbsql_hostname(), fbsql_insert_id(), fbsql_list_dbs(), fbsql_password(), fbsql_read_blob(), fbsql_read_clob(), fbsql_rollback(), fbsql_select_db(), fbsql_set_password(), fbsql_set_transaction(), fbsql_start_db(), fbsql_stop_db(), fbsql_username() | fbsql_close() | Link to fbsql database
fbsql plink | fbsql_change_user(), fbsql_pconnect() | fbsql_autocommit(), fbsql_change_user(), fbsql_create_db(), fbsql_data_seek(), fbsql_db_query(), fbsql_drop_db(), fbsql_select_db(), fbsql_errno(), fbsql_error(), fbsql_insert_id(), fbsql_list_dbs() | None | Persistent link to fbsql database
fbsql result | fbsql_db_query(), fbsql_list_dbs(), fbsql_query(), fbsql_list_fields(), fbsql_list_tables(), fbsql_tablename() | fbsql_affected_rows(), fbsql_fetch_array(), fbsql_fetch_assoc(), fbsql_fetch_field(), fbsql_fetch_lengths(), fbsql_fetch_object(), fbsql_fetch_row(), fbsql_field_flags(), fbsql_field_name(), fbsql_field_len(), fbsql_field_seek(), fbsql_field_table(), fbsql_field_type(), fbsql_next_result(), fbsql_num_fields(), fbsql_num_rows(), fbsql_result(), fbsql_num_rows() | fbsql_free_result() | fbsql result
fdf | fdf_open() | fdf_create(), fdf_save(), fdf_get_value(), fdf_set_value(), fdf_next_field_name(), fdf_set_ap(), fdf_set_status(), fdf_get_status(), fdf_set_file(), fdf_get_file(), fdf_set_flags(), fdf_set_opt(), fdf_set_submit_form_action(), fdf_set_javascript_action() | fdf_close() | FDF File
ftp | ftp_connect(), ftp_ssl_connect() | ftp_login(), ftp_pwd(), ftp_cdup(), ftp_chdir(), ftp_mkdir(), ftp_rmdir(), ftp_nlist(), ftp_rawlist(), ftp_systype(), ftp_pasv(), ftp_get(), ftp_fget(), ftp_put(), ftp_fput(), ftp_size(), ftp_mdtm(), ftp_rename(), ftp_delete(), ftp_site(), ftp_alloc(), ftp_chmod(), ftp_exec(), ftp_get_option(), ftp_nb_continue(), ftp_nb_fget(), ftp_nb_fput(), ftp_nb_get(), ftp_nb_put(), ftp_raw(), ftp_set_option() | ftp_close() | FTP stream
gd | imagecreate(), imagecreatefromgd(), imagecreatefromgd2(), imagecreatefromgd2part(), imagecreatefromgif(), imagecreatefromjpeg(), imagecreatefrompng(), imagecreatefromwbmp(), imagecreatefromstring(), imagecreatefromxbm(), imagecreatefromxpm(), imagecreatetruecolor(), imagerotate() | imagearc(), imagechar(), imagecharup(), imagecolorallocate(), imagecolorat(), imagecolorclosest(), imagecolorexact(), imagecolorresolve(), imagegammacorrect(), imagegammacorrect(), imagecolorset(), imagecolorsforindex(), imagecolorstotal(), imagecolortransparent(), imagecopy(), imagecopyresized(), imagedashedline(), imagefill(), imagefilledpolygon(), imagefilledrectangle(), imagefilltoborder(), imagegif(), imagepng(), imagejpeg(), imagewbmp(), imageinterlace(), imageline(), imagepolygon(), imagepstext(), imagerectangle(), imagerotate(), imagesetpixel(), imagestring(), imagestringup(), imagesx(), imagesy(), imagettftext(), imagefilledarc(), imageellipse(), imagefilledellipse(), imagecolorclosestalpha(), imagecolorexactalpha(), imagecolorresolvealpha(), imagecopymerge(), imagecopymergegray(), imagecopyresampled(), imagetruecolortopalette(), imagesetbrush(), imagesettile(), imagesetthickness(), image2wbmp(), imagealphablending(), imageantialias(), imagecolorallocatealpha(), imagecolorclosesthwb(), imagecolordeallocate(), imagecolormatch(), imagefilter(), imagefttext(), imagegd(), imagegd2(), imageistruecolor(), imagelayereffect(), imagepalettecopy(), imagesavealpha(), imagesetstyle(), imagexbm() | imagedestroy() | GD Image
gd font | imageloadfont() | imagechar(), imagecharup(), imagefontheight() | None | Font for GD
gd PS encoding
gd PS font | imagepsloadfont() | imagepstext(), imagepsslantfont(), imagepsextendfont(), imagepsencodefont(), imagepsbbox() | imagepsfreefont() | PS font for GD
GMP integer | gmp_init() | gmp_intval(), gmp_strval(), gmp_add(), gmp_sub(), gmp_mul(), gmp_div_q(), gmp_div_r(), gmp_div_qr(), gmp_div(), gmp_mod(), gmp_divexact(), gmp_cmp(), gmp_neg(), gmp_abs(), gmp_sign(), gmp_fact(), gmp_sqrt(), gmp_sqrtrm(), gmp_perfect_square(), gmp_pow(), gmp_powm(), gmp_prob_prime(), gmp_gcd(), gmp_gcdext(), gmp_invert(), gmp_legendre(), gmp_jacobi(), gmp_random(), gmp_and(), gmp_or(), gmp_xor(), gmp_setbit(), gmp_clrbit(), gmp_scan0(), gmp_scan1(), gmp_popcount(), gmp_hamdist() | None | GMP Number
hyperwave document | hw_cp(), hw_docbyanchor(), hw_getremote(), hw_getremotechildren() | hw_children(), hw_childrenobj(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getsrcbydestobj(), hw_getandlock(), hw_gettext(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_inscoll(), hw_pipedocument(), hw_unlock() | hw_deleteobject() | Hyperwave object
hyperwave link | hw_connect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | hw_close(), hw_free_document() | Link to Hyperwave server
hyperwave link persistent | hw_pconnect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | None | Persistent link to Hyperwave server
icap | icap_open() | icap_fetch_event(), icap_list_events(), icap_store_event(), icap_snooze(), icap_list_alarms(), icap_delete_event() | icap_close() | Link to icap server
imap | imap_open() | imap_append(), imap_body(), imap_check(), imap_createmailbox(), imap_delete(), imap_deletemailbox(), imap_expunge(), imap_fetchbody(), imap_fetchstructure(), imap_headerinfo(), imap_header(), imap_headers(), imap_listmailbox(), imap_getmailboxes(), imap_get_quota(), imap_status(), imap_listsubscribed(), imap_set_quota(), imap_set_quota(), imap_getsubscribed(), imap_mail_copy(), imap_mail_move(), imap_num_msg(), imap_num_recent(), imap_ping(), imap_renamemailbox(), imap_reopen(), imap_subscribe(), imap_undelete(), imap_unsubscribe(), imap_scanmailbox(), imap_mailboxmsginfo(), imap_fetchheader(), imap_uid(), imap_msgno(), imap_search(), imap_fetch_overview() | imap_close() | Link to IMAP, POP3 server
imap chain persistent
imap persistent
ingres | ingres_connect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | ingres_close() | Link to ingresII base
ingres persistent | ingres_pconnect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | None | Persistent link to ingresII base
interbase blob
interbase link | ibase_connect() | ibase_query(), ibase_prepare(), ibase_trans() | ibase_close() | Link to Interbase database
interbase link persistent | ibase_pconnect() | ibase_query(), ibase_prepare(), ibase_trans() | None | Persistent link to Interbase database
interbase query | ibase_prepare() | ibase_execute() | ibase_free_query() | Interbase query
interbase result | ibase_query() | ibase_fetch_row(), ibase_fetch_object(), ibase_field_info(), ibase_num_fields() | ibase_free_result() | Interbase Result
interbase transaction | ibase_trans() | ibase_commit() | ibase_rollback() | Interbase transaction
java
ldap link | ldap_connect(), ldap_search() | ldap_count_entries(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_next_attribute(), ldap_next_entry() | ldap_close() | ldap connection
ldap result | ldap_read() | ldap_add(), ldap_compare(), ldap_bind(), ldap_count_entries(), ldap_delete(), ldap_errno(), ldap_error(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_get_option(), ldap_list(), ldap_modify(), ldap_mod_add(), ldap_mod_replace(), ldap_next_attribute(), ldap_next_entry(), ldap_mod_del(), ldap_set_option(), ldap_unbind() | ldap_free_result() | ldap search result
ldap result entry
mcal | mcal_open(), mcal_popen() | mcal_create_calendar(), mcal_rename_calendar(), mcal_rename_calendar(), mcal_delete_calendar(), mcal_fetch_event(), mcal_list_events(), mcal_append_event(), mcal_store_event(), mcal_delete_event(), mcal_list_alarms(), mcal_event_init(), mcal_event_set_category(), mcal_event_set_title(), mcal_event_set_description(), mcal_event_set_start(), mcal_event_set_end(), mcal_event_set_alarm(), mcal_event_set_class(), mcal_next_recurrence(), mcal_event_set_recur_none(), mcal_event_set_recur_daily(), mcal_event_set_recur_weekly(), mcal_event_set_recur_monthly_mday(), mcal_event_set_recur_monthly_wday(), mcal_event_set_recur_yearly(), mcal_fetch_current_stream_event(), mcal_event_add_attribute(), mcal_expunge() | mcal_close() | Link to calendar server
SWFAction
SWFBitmap
SWFButton
SWFDisplayItem
SWFFill
SWFFont
SWFGradient
SWFMorph
SWFMovie
SWFShape
SWFSprite
SWFText
SWFTextField
mnogosearch agent
mnogosearch result
msql link | msql_connect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | msql_close() | Link to mSQL database
msql link persistent | msql_pconnect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | None | Persistent link to mSQL
msql query | msql_db_query(), msql_list_dbs(), msql_list_fields(), msql_list_tables(), msql_query() | msql(), msql_affected_rows(), msql_data_seek(), msql_dbname(), msql_fetch_array(), msql_fetch_field(), msql_fetch_object(), msql_fetch_row(), msql_field_seek(), msql_field_table(), msql_field_flags(), msql_field_len(), msql_field_name(), msql_field_type(), msql_num_fields(), msql_num_rows(), msql_numfields(), msql_numrows(), msql_result() | msql_free_result(), msql_free_result() | mSQL result
mssql link | mssql_connect() | mssql_query(), mssql_select_db() | mssql_close() | Link to Microsoft SQL Server database
mssql link persistent | mssql_pconnect() | mssql_query(), mssql_select_db() | None | Persistent link to Microsoft SQL Server
mssql result | mssql_query() | mssql_data_seek(), mssql_fetch_array(), mssql_fetch_field(), mssql_fetch_object(), mssql_fetch_row(), mssql_field_length(), mssql_field_name(), mssql_field_seek(), mssql_field_type(), mssql_num_fields(), mssql_num_rows(), mssql_result() | mssql_free_result() | Microsoft SQL Server result
mysql link | mysql_connect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | mysql_close() | Link to MySQL database
mysql link persistent | mysql_pconnect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | None | Persistent link to MySQL database
mysql result | mysql_db_query(), mysql_list_dbs(), mysql_list_fields(), mysql_list_processes(), mysql_list_tables(), mysql_query(), mysql_unbuffered_query() | mysql_data_seek(), mysql_db_name(), mysql_fetch_array(), mysql_fetch_assoc(), mysql_fetch_field(), mysql_fetch_lengths(), mysql_fetch_object(), mysql_fetch_row(), mysql_fetch_row(), mysql_field_flags(), mysql_field_name(), mysql_field_len(), mysql_field_seek(), mysql_field_table(), mysql_field_type(), mysql_num_fields(), mysql_num_rows(), mysql_result(), mysql_tablename() | mysql_free_result() | MySQL result
oci8 collection
oci8 connection | ocilogon(), ociplogon(), ocinlogon() | ocicommit(), ociserverversion(), ocinewcursor(), ociparse(), ocierror() | ocilogoff() | Link to Oracle database
oci8 descriptor
oci8 server
oci8 session
oci8 statement | ocinewdescriptor() | ocirollback(), ocinewdescriptor(), ocirowcount(), ocidefinebyname(), ocibindbyname(), ociexecute(), ocinumcols(), ociresult(), ocifetch(), ocifetchinto(), ocifetchstatement(), ocicolumnisnull(), ocicolumnname(), ocicolumnsize(), ocicolumntype(), ocistatementtype(), ocierror() | ocifreestatement() | Oracle Cursor
odbc link | odbc_connect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | odbc_close() | Link to ODBC database
odbc link persistent | odbc_pconnect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | None | Persistent link to ODBC database
odbc result | odbc_prepare() | odbc_binmode(), odbc_cursor(), odbc_execute(), odbc_fetch_into(), odbc_fetch_row(), odbc_field_name(), odbc_field_num(), odbc_field_type(), odbc_field_len(), odbc_field_precision(), odbc_field_scale(), odbc_longreadlen(), odbc_num_fields(), odbc_num_rows(), odbc_result(), odbc_result_all(), odbc_setoption() | odbc_free_result() | ODBC result
birdstep link
birdstep result
OpenSSL key | openssl_get_privatekey(), openssl_get_publickey() | openssl_sign(), openssl_seal(), openssl_open(), openssl_verify() | openssl_free_key() | OpenSSL key
OpenSSL X.509 | openssl_x509_read() | openssl_x509_parse(), openssl_x509_checkpurpose() | openssl_x509_free() | Public Key
oracle Cursor | ora_open() | ora_bind(), ora_columnname(), ora_columnsize(), ora_columntype(), ora_error(), ora_errorcode(), ora_exec(), ora_fetch(), ora_fetch_into(), ora_getcolumn(), ora_numcols(), ora_numrows(), ora_parse() | ora_close() | Oracle cursor
oracle link | ora_logon() | ora_do(), ora_error(), ora_errorcode(), ora_rollback(), ora_commitoff(), ora_commiton(), ora_open(), ora_commit() | ora_logoff() | Link to oracle database
oracle link persistent | ora_plogon() | ora_do(), ora_error(), ora_errorcode(), ora_rollback(), ora_commitoff(), ora_commiton(), ora_open(), ora_commit() | None | Persistent link to oracle database
pdf document | pdf_new() | pdf_add_bookmark(), pdf_add_launchlink(), pdf_add_locallink(), pdf_add_note(), pdf_add_pdflink(), pdf_add_weblink(), pdf_arc(), pdf_attach_file(), pdf_begin_page(), pdf_circle(), pdf_clip(), pdf_closepath(), pdf_closepath_fill_stroke(), pdf_closepath_stroke(), pdf_concat(), pdf_continue_text(), pdf_curveto(), pdf_end_page(), pdf_endpath(), pdf_fill(), pdf_fill_stroke(), pdf_findfont(), pdf_get_buffer(), pdf_get_image_height(), pdf_get_image_width(), pdf_get_parameter(), pdf_get_value(), pdf_lineto(), pdf_moveto(), pdf_open_ccitt(), pdf_open_file(), pdf_open_image_file(), pdf_place_image(), pdf_rect(), pdf_restore(), pdf_rotate(), pdf_save(), pdf_scale(), pdf_setdash(), pdf_setflat(), pdf_setfont(), pdf_setgray(), pdf_setgray_fill(), pdf_setgray_stroke(), pdf_setlinecap(), pdf_setlinejoin(), pdf_setlinewidth(), pdf_setmiterlimit(), pdf_setpolydash(), pdf_setrgbcolor(), pdf_setrgbcolor_fill(), pdf_setrgbcolor_stroke(), pdf_set_border_color(), pdf_set_border_dash(), pdf_set_border_style(), pdf_set_char_spacing(), pdf_set_duration(), pdf_set_font(), pdf_set_horiz_scaling(), pdf_set_parameter(), pdf_set_text_pos(), pdf_set_text_rendering(), pdf_set_value(), pdf_set_word_spacing(), pdf_show(), pdf_show_boxed(), pdf_show_xy(), pdf_skew(), pdf_stringwidth(), pdf_stroke(), pdf_translate(), pdf_add_thumbnail(), pdf_arcn(), pdf_begin_pattern(), pdf_begin_template(), pdf_end_pattern(), pdf_end_template(), pdf_initgraphics(), pdf_makespotcolor(), pdf_set_info(), pdf_setcolor(), pdf_setmatrix(), pdf_open_memory_image() | pdf_close(), pdf_delete() | PDF document
pdf image | pdf_open_image(), pdf_open_image_file(), pdf_open_memory_image() | pdf_get_image_height(), pdf_get_image_width(), pdf_open_CCITT(), pdf_place_image() | pdf_close_image() | Image in PDF file
pdf object
pdf outline
pgsql large object | pg_lo_open() | pg_lo_open(), pg_lo_create(), pg_lo_read(), pg_lo_read_all(), pg_lo_seek(), pg_lo_tell(), pg_lo_unlink(), pg_lo_write() | pg_lo_close() | PostgreSQL Large Object
pgsql link | pg_connect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | pg_close() | Link to PostgreSQL database
pgsql link persistent | pg_pconnect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | None | Persistent link to PostgreSQL database
pgsql result | pg_execute(), pg_query(), pg_query_params(), pg_get_result() | pg_fetch_array(), pg_fetch_object(), pg_fetch_result(), pg_fetch_row(), pg_field_is_null(), pg_field_name(), pg_field_num(), pg_field_prtlen(), pg_field_size(), pg_field_type(), pg_last_oid(), pg_num_fields(), pg_num_rows(), pg_result_error(), pg_result_status() | pg_free_result() | PostgreSQL result
pgsql string
printer
printer brush
printer font
printer pen
pspell | pspell_new(), pspell_new_config(), pspell_new_personal() | pspell_add_to_personal(), pspell_add_to_session(), pspell_check(), pspell_clear_session(), pspell_config_ignore(), pspell_config_mode(), pspell_config_personal(), pspell_config_repl(), pspell_config_runtogether(), pspell_config_save_repl(), pspell_save_wordlist(), pspell_store_replacement(), pspell_suggest() | None | pspell dictionary
pspell config | pspell_config_create() | pspell_new_config() | None | pspell configuration
Sablotron XSLT | xslt_create() | xslt_closelog(), xslt_openlog(), xslt_run(), xslt_set_sax_handler(), xslt_errno(), xslt_error(), xslt_fetch_result(), xslt_free() | xslt_free() | XSLT parser
shmop | shmop_open() | shmop_read(), shmop_write(), shmop_size(), shmop_delete() | shmop_close()
sockets file descriptor set | socket() | accept_connect(), bind(), connect(), listen(), read(), write() | close() | Socket
sockets i/o vector
stream | opendir() | readdir(), rewinddir() | closedir() | Dir handle
stream | fopen(), tmpfile() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), flock(), fpassthru(), fputs(), fwrite(), fread(), fseek(), ftell(), fstat(), ftruncate(), set_file_buffer(), rewind() | fclose() | File handle
stream | popen(), fsockopen(), pfsockopen() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | pclose() | Process handle
socket | fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | fclose() | Socket handle
sybase-db link | sybase_connect() | sybase_query(), sybase_select_db() | sybase_close() | Link to Sybase database using DB library
sybase-db link persistent | sybase_pconnect() | sybase_query(), sybase_select_db() | None | Persistent link to Sybase database using DB library
sybase-db result | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Sybase result using DB library
sybase-ct link | sybase_connect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | sybase_close() | Link to Sybase database using CT library
sybase-ct link persistent | sybase_pconnect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | None | Persistent link to Sybase database using CT library
sybase-ct result | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Sybase result using CT library
sysvsem | sem_get() | sem_acquire() | sem_release() | System V Semaphore
sysvshm | shm_attach() | shm_remove(), shm_put_var(), shm_get_var(), shm_remove_var() | shm_detach() | System V Shared Memory
wddx | wddx_packet_start() | wddx_add_vars() | wddx_packet_end() | WDDX packet
xml | xml_parser_create(), xml_parser_create_ns() | xml_set_object(), xml_set_element_handler(), xml_set_character_data_handler(), xml_set_processing_instruction_handler(), xml_set_default_handler(), xml_set_unparsed_entity_decl_handler(), xml_set_notation_decl_handler(), xml_set_external_entity_ref_handler(), xml_parse(), xml_get_error_code(), xml_error_string(), xml_get_current_line_number(), xml_get_current_column_number(), xml_get_current_byte_index(), xml_parse_into_struct(), xml_parser_set_option(), xml_parser_get_option() | xml_parser_free() | XML parser
zlib | gzopen() | gzeof(), gzgetc(), gzgets(), gzgetss(), gzpassthru(), gzputs(), gzread(), gzrewind(), gzseek(), gztell(), gzwrite() | gzclose() | gz-compressed file


可用过滤器列表

Table of Contents

  • 字符串过滤器
  • string.strip_tags
  • 转换过滤器
  • 压缩过滤器
  • 加密过滤器

下面列出了用在 stream_filter_append()中的几个内置的流过滤器。用户的 PHP 版本中的过滤器也许比这里列出的更多（或更少）。

值得指出 stream_filter_append()与 stream_filter_prepend()之间有少许不平衡。每个 PHP 流都含有一个小的 读取缓冲区，它存储了来自文件系统或其它资源的几段数据以便更有效率地处理。数据一从资源进入流的内部缓冲区，立刻被附上的过滤器处理而不管 PHP 程序是否真的已经准备好接收数据。当过滤器是 appended时如果数据等待在读取缓冲区，数据将被立即通过过滤器处理，使其效果看上去是透明的。然而当过滤器是 prepended时如果数据等待在读取缓冲区，数据将 不会被该过滤器处理。该数据将会等到从资源取得下一段数据后才会被处理。

用 stream_get_filters()来列出 PHP 中已安装的过滤器。


字符串过滤器

每个过滤器都正如其名字暗示的那样工作并与内置的 PHP 字符串函数的行为相对应。对于指定过滤器的更多信息，请参考该函数的手册页。

string.rot13（自 PHP 4.3.0 起）使用此过滤器等同于用 str_rot13()函数处理所有的流数据。

Example #1 string.rot13

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.rot13');
fwrite($fp, "This is a test.\n");
/* Outputs:  Guvf vf n grfg.   */
?>

string.toupper（自 PHP 5.0.0 起）使用此过滤器等同于用 strtoupper()函数处理所有的流数据。

Example #2 string.toupper

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.toupper');
fwrite($fp, "This is a test.\n");
/* Outputs:  THIS IS A TEST.   */
?>

string.tolower（自 PHP 5.0.0 起）使用此过滤器等同于用 strtolower()函数处理所有的流数据。

Example #3 string.tolower

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.tolower');
fwrite($fp, "This is a test.\n");
/* Outputs:  this is a test.   */
?>


string.strip_tags

使用此过滤器等同于用 strip_tags()函数处理所有的流数据。可以用两种格式接收参数：一种是和 strip_tags()函数第二个参数相似的一个包含有标记列表的字符串，一种是一个包含有标记名的数组。

Warning

本特性已自 PHP 7.3.0 起废弃。强烈建议不要使用本特性。

Example #1 string.strip_tags

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, "<b><i><u>");
fwrite($fp, "<b>bolded text</b> enlarged to a <h1>level 1 heading</h1>\n");
fclose($fp);
/* Outputs:  <b>bolded text</b> enlarged to a level 1 heading   */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, array('b','i','u'));
fwrite($fp, "<b>bolded text</b> enlarged to a <h1>level 1 heading</h1>\n");
fclose($fp);
/* Outputs:  <b>bolded text</b> enlarged to a level 1 heading   */
?>


转换过滤器

如同 string.* 过滤器，convert.* 过滤器的作用就和其名字一样。转换过滤器是 PHP 5.0.0 添加的。对于指定过滤器的更多信息，请参考该函数的手册页。

convert.base64-encode和 convert.base64-decode使用这两个过滤器等同于分别用 base64_encode()和 base64_decode()函数处理所有的流数据。 convert.base64-encode支持以一个关联数组给出的参数。如果给出了 line-length，base64 输出将被用 line-length个字符为 长度而截成块。如果给出了 line-break-chars，每块将被用给出的字符隔开。这些参数的效果和用 base64_encode()再加上 chunk_split()相同。

Example #1 convert.base64-encode & convert.base64-decode

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode');
fwrite($fp, "This is a test.\n");
fclose($fp);
/* Outputs:  VGhpcyBpcyBhIHRlc3QuCg==  */

$param = array('line-length' => 8, 'line-break-chars' => "\r\n");
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode', STREAM_FILTER_WRITE, $param);
fwrite($fp, "This is a test.\n");
fclose($fp);
/* Outputs:  VGhpcyBp
          :  cyBhIHRl
          :  c3QuCg==  */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-decode');
fwrite($fp, "VGhpcyBpcyBhIHRlc3QuCg==");
fclose($fp);
/* Outputs:  This is a test.  */
?>

convert.quoted-printable-encode和 convert.quoted-printable-decode使用此过滤器的 decode 版本等同于用 quoted_printable_decode()函数处理所有的流数据。没有和 convert.quoted-printable-encode相对应的函数。 convert.quoted-printable-encode支持以一个关联数组给出的参数。除了支持和 convert.base64-encode一样的附加参数外， convert.quoted-printable-encode还支持布尔参数 binary和 force-encode-first。 convert.base64-decode只支持 line-break-chars参数作为从编码载荷中剥离的类型提示。

Example #2 convert.quoted-printable-encode & convert.quoted-printable-decode

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.quoted-printable-encode');
fwrite($fp, "This is a test.\n");
/* Outputs:  =This is a test.=0A  */
?>


压缩过滤器

虽然 压缩封装协议提供了在本地文件系统中 创建 gzip 和 bz2 兼容文件的方法，但不代表可以在网络的流中提供通用压缩的意思，也不代表可以将一个非压缩的流转换成一个压缩流。对此，压缩过滤器可以在任何时候应用于任何流资源。

Note: 压缩过滤器 不产生命令行工具如 gzip的头和尾信息。只是压缩和解压数据流中的有效载荷部分。

zlib.deflate（压缩）和 zlib.inflate（解压）实现了定义与 » RFC 1951的压缩算法。 deflate过滤器可以接受以一个关联数组传递的最多三个参数。 level定义了压缩强度（1-9）。数字更高通常会产生更小的载荷，但要消耗更多的处理时间。存在两个特殊压缩等级：0（完全不压缩）和 -1（zlib 内部默认值，目前是 6）。 window是压缩回溯窗口大小，以二的次方表示。更高的值（大到 15 —— 32768 字节）产生更好的压缩效果但消耗更多内存，低的值（低到 9 —— 512 字节）产生产生较差的压缩效果但内存消耗低。目前默认的 window大小是 15。 memory用来指示要分配多少工作内存。合法的数值范围是从 1（最小分配）到 9（最大分配）。内存分配仅影响速度，不会影响生成的载荷的大小。

Note: 因为最常用的参数是压缩等级，也可以提供一个整数值作为此参数（而不用数组）。

zlib.* 压缩过滤器自 PHP 版本 5.1.0起可用，在激活 zlib的前提下。也可以通过安装来自 » PECL的 » zlib_filter包作为一个后门在 5.0.x版中使用。此过滤器在 PHP 4 中 不可用。

Example #1 zlib.deflate和 zlib.inflate

<?php
$params = array('level' => 6, 'window' => 15, 'memory' => 9);

$original_text = "This is a test.\nThis is only a test.\nThis is not an important string.\n";
echo "The original text is " . strlen($original_text) . " characters long.\n";

$fp = fopen('test.deflated', 'w');
stream_filter_append($fp, 'zlib.deflate', STREAM_FILTER_WRITE, $params);
fwrite($fp, $original_text);
fclose($fp);

echo "The compressed file is " . filesize('test.deflated') . " bytes long.\n";
echo "The original text was:\n";
/* Use readfile and zlib.inflate to decompress on the fly */
readfile('php://filter/zlib.inflate/resource=test.deflated');

/* Generates output:

The original text is 70 characters long.
The compressed file is 56 bytes long.
The original text was:
This is a test.
This is only a test.
This is not an important string.

 */
?>

Example #2 zlib.deflate简单参数用法

<?php
$original_text = "This is a test.\nThis is only a test.\nThis is not an important string.\n";
echo "The original text is " . strlen($original_text) . " characters long.\n";

$fp = fopen('test.deflated', 'w');
/* Here "6" indicates compression level 6 */
stream_filter_append($fp, 'zlib.deflate', STREAM_FILTER_WRITE, 6);
fwrite($fp, $original_text);
fclose($fp);

echo "The compressed file is " . filesize('test.deflated') . " bytes long.\n";

/* Generates output:

The original text is 70 characters long.
The compressed file is 56 bytes long.

 */
?>

bzip2.compress和 bzip2.decompress工作的方式与上面讲的 zlib 过滤器相同。 bzip2.compress过滤器接受以一个关联数组给出的最多两个参数： blocks是从 1 到 9 的整数值，指定分配多少个 100K 字节的内存块作为工作区。 work是 0 到 250 的整数值，指定在退回到一个慢一些，但更可靠的算法之前做多少次常规压缩算法的尝试。调整此参数仅影响到速度，压缩输出和内存使用都不受此设置的影响。将此参数设为 0 指示 bzip 库使用内部默认算法。 bzip2.decompress过滤器仅接受一个参数，可以用普通的布尔值传递，或者用一个关联数组中的 small单元传递。当 small设为 &true; 值时，指示 bzip 库用最小的内存占用来执行解压缩，代价是速度会慢一些。

bzip2.* 压缩过滤器自 PHP 版本 5.1.0起可用，在激活 bz2支持的前提下。也可以通过安装来自 » PECL的 » bz2_filter包作为一个后门在 5.0.x版中使用。此过滤器在 PHP 4 中 不可用。

Example #3 bzip2.compress和 bzip2.decompress

<?php
$param = array('blocks' => 9, 'work' => 0);

echo "The original file is " . filesize('LICENSE') . " bytes long.\n";

$fp = fopen('LICENSE.compressed', 'w');
stream_filter_append($fp, 'bzip2.compress', STREAM_FILTER_WRITE, $param);
fwrite($fp, file_get_contents('LICENSE'));
fclose($fp);

echo "The compressed file is " . filesize('LICENSE.compressed') . " bytes long.\n";

/* Generates output:

The original text is 3288 characters long.
The compressed file is 1488 bytes long.

 */
?>


加密过滤器

mcrypt.*和 mdecrypt.*使用 libmcrypt 提供了对称的加密和解密。这两组过滤器都支持 mcrypt 扩展库中相同的算法，格式为 mcrypt.ciphername，其中 ciphername是密码的名字，将被传递给 mcrypt_module_open()。有以下五个过滤器参数可用：

mcrypt 过滤器参数
参数 | 是否必须 | 默认值 | 取值举例
mode | 可选 | cbc | cbc, cfb, ecb, nofb, ofb, stream
algorithms_dir | 可选 | ini_get('mcrypt.algorithms_dir') | algorithms 模块的目录
modes_dir | 可选 | ini_get('mcrypt.modes_dir') | modes 模块的目录
iv | 必须 | N/A | 典型为 8，16 或 32 字节的二进制数据。根据密码而定
key | 必须 | N/A | 典型为 8，16 或 32 字节的二进制数据。根据密码而定

Example #1 用 3DES 将文件加密输出

<?php
$passphrase = 'My secret';

/* Turn a human readable passphrase
 * into a reproducable iv/key pair
 */
$iv = substr(md5('iv'.$passphrase, true), 0, 8);
$key = substr(md5('pass1'.$passphrase, true) .
               md5('pass2'.$passphrase, true), 0, 24);
$opts = array('iv'=>$iv, 'key'=>$key);

$fp = fopen('secert-file.enc', 'wb');
stream_filter_append($fp, 'mcrypt.tripledes', STREAM_FILTER_WRITE, $opts);
fwrite($fp, 'Secret secret secret data');
fclose($fp);
?>

Example #2 读取加密的文件

<?php
$passphrase = 'My secret';

/* Turn a human readable passphrase
 * into a reproducable iv/key pair
 */
$iv = substr(md5('iv'.$passphrase, true), 0, 8);
$key = substr(md5('pass1'.$passphrase, true) .
               md5('pass2'.$passphrase, true), 0, 24);
$opts = array('iv'=>$iv, 'key'=>$key);

$fp = fopen('secert-file.enc', 'rb');
stream_filter_append($fp, 'mdecrypt.tripledes', STREAM_FILTER_WRITE, $opts);
$data = rtrim(stream_get_contents($fp));
fclose($fp);

echo $data;
?>


所支持的套接字传输器（Socket Transports）列表

Table of Contents

  • Internet 领域：TCP，UDP，SSL 和 TLS
  • Unix 领域：Unix 和 UDG

以下是 PHP 内置用于基于流的套接字函数例如 fsockopen()和 stream_socket_client()的各种 URL 风格的套接字传输器。这些传输器 不适用于 Sockets 扩展库。

要得到自己的 PHP 版本中所安装的传输器列表，使用 stream_get_transports()。


Internet 领域：TCP，UDP，SSL 和 TLS

PHP 3，PHP 4，PHP 5。 ssl://& tls://自 PHP 4.3 起可用。

sslv2://& sslv3://自 PHP 5.0.2 起可用。

Note: 如果没有指定传输器，则假定为 tcp://。

  • 127.0.0.1
  • fe80::1
  • www.example.com
  • tcp://127.0.0.1
  • tcp://fe80::1
  • tcp://www.example.com
  • udp://www.example.com
  • ssl://www.example.com
  • sslv2://www.example.com
  • sslv3://www.example.com
  • tls://www.example.com

Internet 领域套接字在目标地址中还期望有一个端口号。在 fsockopen()中在第二个参数中指定，这样就不会影响传输器的 URL。然而在 stream_socket_client()和相关的函数中是用传统的 URL，端口号在传输器 URL 后面以冒号分隔而指定。

  • tcp://127.0.0.1:80
  • tcp://[fe80::1]:80
  • tcp://www.example.com:80

Note: 带端口号的 IPv6 数字地址
在上面的第二个例子中，IPv4 和主机名的例子只加了一个冒号和端口号，但 IPv6 的地址被放在方括号中： [fe80::1]。这是为了将 IPv6 地址中的冒号和用来分隔端口号的冒号区别开来。

ssl://和 tls://传输器（仅在 openssl 支持已编译入 PHP 后可用）是 tcp://传输器加入 SSL 加密后的扩展。在 PHP 4.3.0 中 OpenSSL 支持必须被静态编译入 PHP，在 PHP 5.0.0 中可以编译为模块或者静态的。

ssl://将根据远程服务器的兼容性和参数设置尝试与之建立 SSL V2 或 SSL V3 链接 sslv2://和 sslv3://将明确的选择 SSL V2 或 SSL V3 协议进行连接。

ssl://和 tls://传输器的上下文选项（自 PHP 4.3.2 起）
名称 | 用法 | 默认值
verify_peer | &true; 或 &false;。用于 SSL 证书请求验证。 | &false;
allow_self_signed | &true; 或 &false;。允许自签名的证书。 | &false;
cafile | 本地文件系统中证书授权机构文件的位置，应和 verify_peer上下文选项一起使用来认证远端的身份。 |
capath | 如果没有指定 cafile或者如果该处没找到证书，则在 capath指定的目录中搜索相配的证书。 capath必须是一个正确的被散列化的证书目录。 |
local_cert | 文件系统中本地证书文件的路径。必须是一个用 PEM 编码并包含你的证书和私人密钥的文件。可以选择包括发行者的证书链。 |
passphrase | 你的 local_cert文件编码的 passphrase。 |
CN_match | 所期待的 Common Name。PHP 能进行有限的通配符匹配。如果 Common Name 与此不匹配，连接尝试会失败。 |

Note: 因为 ssl://是 https:// 和 ftps:// 封装协议的底层传输器，适用于 ssl://的任何上下文选项也适用于 https://和 ftps://。


Unix 领域：Unix 和 UDG

unix://自 PHP 3 起可用， udg://自 PHP 5 起可用。

  • unix:///tmp/mysock
  • udg:///tmp/mysock

unix://提供了在 Unix 域中对套接字流连接的访问。 udg://提供了替代的传输器以用户数据报协议（UDP）来访问 Unix 域套接字。

Unix 域套接字（UNIX Domain Socket），和 Internet Domain Socket 不同，不期望端口号。在 fsockopen()中 portno参数应被设为 0。


PHP 类型比较表

以下的表格显示了 PHP 类型 和 比较运算符 在松散和严格比较时的作用。该补充材料还和 类型戏法 的相关章节内容有关。同时，大量的用户注释和 » BlueShoes 的工作也给该材料提供了帮助。

在使用这些表格之前，需要明白变量类型及它们的意义。例如，"42" 是一个字符串而 42 是一个整数。false 是一个布尔值而 "false" 是一个字符串。

Note:

HTML 表单并不传递整数、浮点数或者布尔值，它们只传递字符串。要想检测一个字符串是不是数字，可以使用 is_numeric() 函数。

Note:

在没有定义变量 $x 的时候，诸如 if ($x) 的用法会导致一个 E_NOTICE 级别的错误。所以，可以考虑用 empty() 或者 isset() 函数来初始化变量。

Note:

某些数值操作会导致一个特殊值，可以用常量 NAN 表示。 无论是松散还是严格比较，这个值和其他任意值（包括它自身，但排除 true）比较时都会产生 false 的结果， 例如 NAN != NAN 和 NAN !== NAN。 导致 NAN 的操作例子包括 sqrt(-1)、asin(2)、 acosh(0)。

使用 PHP 函数对变量 $x 进行比较
表达式 | gettype() | empty() | is_null() | isset() | boolean : if($x)
$x = ""; | string | true | false | true | false
$x = null; | NULL | true | true | false | false
var $x; | NULL | true | true | false | false
$x is undefined | NULL | true | true | false | false
$x = array(); | array | true | false | true | false
$x = array('a', 'b'); | array | false | false | true | true
$x = false; | boolean | true | false | true | false
$x = true; | boolean | false | false | true | true
$x = 1; | integer | false | false | true | true
$x = 42; | integer | false | false | true | true
$x = 0; | integer | true | false | true | false
$x = -1; | integer | false | false | true | true
$x = "1"; | string | false | false | true | true
$x = "0"; | string | true | false | true | false
$x = "-1"; | string | false | false | true | true
$x = "php"; | string | false | false | true | true
$x = "true"; | string | false | false | true | true
$x = "false"; | string | false | false | true | true

松散比较 ==
 | true | false | 1 | 0 | -1 | "1" | "0" | "-1" | null | array() | "php" | ""
true | true | false | true | false | true | true | false | true | false | false | true | false
false | false | true | false | true | false | false | true | false | true | true | false | true
1 | true | false | true | false | false | true | false | false | false | false | false | false
0 | false | true | false | true | false | false | true | false | true | false | true | true
-1 | true | false | false | false | true | false | false | true | false | false | false | false
"1" | true | false | true | false | false | true | false | false | false | false | false | false
"0" | false | true | false | true | false | false | true | false | false | false | false | false
"-1" | true | false | false | false | true | false | false | true | false | false | false | false
null | false | true | false | true | false | false | false | false | true | true | false | true
array() | false | true | false | false | false | false | false | false | true | true | false | false
"php" | true | false | false | true | false | false | false | false | false | false | true | false
"" | false | true | false | true | false | false | false | false | true | false | false | true

严格比较 ===
 | true | false | 1 | 0 | -1 | "1" | "0" | "-1" | null | array() | "php" | ""
true | true | false | false | false | false | false | false | false | false | false | false | false
false | false | true | false | false | false | false | false | false | false | false | false | false
1 | false | false | true | false | false | false | false | false | false | false | false | false
0 | false | false | false | true | false | false | false | false | false | false | false | false
-1 | false | false | false | false | true | false | false | false | false | false | false | false
"1" | false | false | false | false | false | true | false | false | false | false | false | false
"0" | false | false | false | false | false | false | true | false | false | false | false | false
"-1" | false | false | false | false | false | false | false | true | false | false | false | false
null | false | false | false | false | false | false | false | false | true | false | false | false
array() | false | false | false | false | false | false | false | false | false | true | false | false
"php" | false | false | false | false | false | false | false | false | false | false | true | false
"" | false | false | false | false | false | false | false | false | false | false | false | true


解析器代号列表

PHP 语言的不同部分在内部被表示为类似 T_SR 的类型。PHP 在解析错误时输出这样的标识符，例如 "Parse error: unexpected T_SR, expecting ',' or ';' in script.php on line 10."。

应该知道 T_SR 的含义。对于所有不知道的人，下表列出了这些标识符，PHP 语法和在手册中适当位置的参考。

代号
代号 | 语法 | 参考
T_ABSTRACT | abstract | 抽象类（自 PHP 5.0.0 起可用）
T_AND_EQUAL | &= | 赋值运算符
T_ARRAY | array() | array()，数组语法
T_ARRAY_CAST | (array) | 类型转换
T_AS | as | foreach
T_BAD_CHARACTER |  | 在 ASCII 32 之前除了 \t (0x09), \n (0x0a) 和 \r (0x0d) 以外的任何字符
T_BOOLEAN_AND | && | 逻辑运算符
T_BOOLEAN_OR | || | 逻辑运算符
T_BOOL_CAST | (bool) 或 (boolean) | 类型转换
T_BREAK | break | break
T_CASE | case | switch
T_CATCH | catch | 异常（自 PHP 5.0.0 起可用）
T_CHARACTER |  |
T_CLASS | class | 类和对象
T_CLONE | clone | 类和对象。仅用于 PHP 5。
T_CLOSE_TAG | ?> 或 %> |
T_COMMENT | // 或 #，以及 PHP 5 下的 /* */ | 注释
T_CONCAT_EQUAL | .= | 赋值运算符
T_CONST | const |
T_CONSTANT_ENCAPSED_STRING | "foo" 或 'bar' | 字符串语法
T_CONTINUE | continue |
T_CURLY_OPEN |  |
T_DEC | -- | 递增/递减运算符
T_DECLARE | declare | declare
T_DEFAULT | default | switch
T_DIV_EQUAL | /= | 赋值运算符
T_DNUMBER | 0.12，等等 | 浮点数
T_DOC_COMMENT | /** */ | PHPDoc 风格的注释（仅用于 PHP 5）
T_DO | do | do..while
T_DOLLAR_OPEN_CURLY_BRACES | ${ | 复杂变量解析语法
T_DOUBLE_ARROW | => | 数组语法
T_DOUBLE_CAST | (real), (double) 或 (float) | 类型转换
T_DOUBLE_COLON | :: | 见下面的 T_PAAMAYIM_NEKUDOTAYIM
T_ECHO | echo | echo
T_ELSE | else | else
T_ELSEIF | elseif | elseif
T_EMPTY | empty | empty()
T_ENCAPSED_AND_WHITESPACE |  |
T_ENDDECLARE | enddeclare | declare，替代语法
T_ENDFOR | endfor | for，替代语法
T_ENDFOREACH | endforeach | foreach，替代语法
T_ENDIF | endif | if，替代语法
T_ENDSWITCH | endswitch | switch，替代语法
T_ENDWHILE | endwhile | while，替代语法
T_END_HEREDOC |  | heredoc 语法
T_EVAL | eval() | eval()
T_EXIT | exit 或 die | exit(), die()
T_EXTENDS | extends | extends，类和对象
T_FILE | __FILE__ | 常量
T_FINAL | final | Final 关键字（自 PHP 5.0.0 起可用）
T_FOR | for | for
T_FOREACH | foreach | foreach
T_FUNCTION | function 或 cfunction | 函数
T_GLOBAL | global | 变量范围
T_HALT_COMPILER | __halt_compiler() | __halt_compiler（自 PHP 5.1.0 起可用）
T_IF | if | if
T_IMPLEMENTS | implements | 对象接口（自 PHP 5.0.0 起可用）
T_INC | ++ | 递增／递减运算符
T_INCLUDE | include() | include
T_INCLUDE_ONCE | include_once() | include_once
T_INLINE_HTML |  |
T_INSTANCEOF | instanceof | type operators（仅 PHP5）
T_INT_CAST | (int) 或 (integer) | 类型转换
T_INTERFACE | interface | 对象接口（自 PHP 5.0.0 起可用）
T_ISSET | isset() | isset()
T_IS_EQUAL | == | 比较运算符
T_IS_GREATER_OR_EQUAL | >= | 比较运算符
T_IS_IDENTICAL | === | 比较运算符
T_IS_NOT_EQUAL | != or <> | 比较运算符
T_IS_NOT_IDENTICAL | !== | 比较运算符
T_IS_SMALLER_OR_EQUAL | <= | 比较运算符
T_LINE | __LINE__ | 常量
T_LIST | list() | list()
T_LNUMBER | 123，012，0x1ac，等等 | 整型
T_LOGICAL_AND | and | 逻辑运算符
T_LOGICAL_OR | or | 逻辑运算符
T_LOGICAL_XOR | xor | 逻辑运算符
T_MINUS_EQUAL | -= | 赋值运算符
T_ML_COMMENT | /* 和 */ | 注释（仅用于 PHP 4）
T_MOD_EQUAL | %= | 赋值运算符
T_MUL_EQUAL | *= | 赋值运算符
T_NEW | new | 类和对象
T_NUM_STRING |  |
T_OBJECT_CAST | (object) | 类型转换
T_OBJECT_OPERATOR | -> | 类和对象
T_OPEN_TAG | <?php, <? 或 <% | 从 HTML 转义
T_OPEN_TAG_WITH_ECHO | <?= or <%= | 从 HTML 转义
T_OR_EQUAL | |= | 赋值运算符
T_PAAMAYIM_NEKUDOTAYIM | :: | ::。也定义为 T_DOUBLE_COLON。
T_PLUS_EQUAL | += | 赋值运算符
T_PRINT | print() | print
T_PRIVATE | private | 类和对象。仅用于 PHP 5。
T_PUBLIC | public | 类和对象。仅用于 PHP 5。
T_PROTECTED | protected | 类和对象。仅用于 PHP 5。
T_REQUIRE | require() | require
T_REQUIRE_ONCE | require_once() | require_once
T_RETURN | return | 返回值
T_SL | << | 位运算符
T_SL_EQUAL | <<= | 赋值运算符
T_SR | >> | 位运算符
T_SR_EQUAL | >>= | 赋值运算符
T_START_HEREDOC | <<< | heredoc 语法
T_STATIC | static | 变量范围
T_STRING |  |
T_STRING_CAST | (string) | 类型转换
T_STRING_VARNAME |  |
T_SWITCH | switch | switch
T_THROW | throw | 异常（自 PHP 5.0.0 起可用）
T_TRY | try | 异常（自 PHP 5.0.0 起可用）
T_UNSET | unset() | unset()
T_UNSET_CAST | (unset) | （无文档; 类型为 null）
T_USE | use | （未实现）
T_VAR | var | 类和对象
T_VARIABLE | $foo | 变量
T_WHILE | while | while，do..while
T_WHITESPACE |  |
T_XOR_EQUAL | ^= | 赋值运算符
T_FUNC_C | __FUNCTION__ | 常量，自 PHP 4.3.0 起可用
T_CLASS_C | __CLASS__ | 常量，自 PHP 4.3.0 起可用

参见 token_name()。


用户空间命名指南

Table of Contents

  • 全局命名空间
  • 规则
  • 提示

以下是在用户空间 PHP 代码中怎样最佳选择标识符名称的指南。当在全局命名空间中选择创建的符号名称时，要考虑到以下指导方针以免未来的 PHP 版本破坏掉用户使用的符号名称。


全局命名空间

以下代码结构会进入全局命名空间：

  • functions（函数）

  • classes（类）

  • interfaces（接口）

  • constants（常量，并非类常量）

  • 在函数／方法之外定义的变量


规则

以下列表指出了 PHP 工程在选择新的内部标识符时保留给自己的权利。最终指南是官方的» 编码标准：

  • PHP 拥有最顶层命名空间，但是会尝试找到合体的描述命名以避免任何明显的冲突。

  • 函数名在两个词中间使用下划线，类名则同时使用 camelCase 和 PascalCase 规则。

  • PHP 在任何扩展库的全局符号前附加上扩展库的名称（此规则在过去则有无数例外）。例如：

    • curl_close()

    • mysql_query()

    • PREG_SPLIT_DELIM_CAPTURE

    • new DOMDocument()

    • strpos()（以前的一个失误例子）

    • new SplFileObject()

  • Iterators 和 Exceptions 则只是简单加上 "Iterator" 和 "Exception" 后缀。例如：

    • ArrayIterator

    • LogicException

  • PHP 保留所有以 __ 开头的符号作为魔术符号。建议用户不要在 PHP 中创建以 __ 打头的符号，除非是要使用有文档记载的魔术函数功能。例如：

    • __get()

    • __autoload()


提示

要写出能经受住时间考验的代码，建议在全局的命名空间中，尽量不要用变量、函数或类名，以避免与其它用户空间代码出现命名空间冲突。

防止函数和类的命名冲突的一个常见方法是使用自己专属名字的 namespace。

<?php

namespace MyProject;

function my_function() {
    return true;
}

\MyProject\my_function();

这仍然需要你跟踪已经使用过的命名空间，但一旦你用了在决定了要使用的命名空间后，你可以添加所有的函数和类到它，不用再考虑冲突。

最好的做法是，尽量控制一下添加到全局范围内的变量，以防止与第三方代码的命名产生命名空间冲突。

Note: Variable scoping

Because of PHP's scoping rules variables defined inside functions and methods are not in the global scope and as such cannot conflict with other variables defined in the global scope.


关于本手册

Table of Contents

  • 手册的格式
  • 关于用户注释
  • 如何阅读函数的定义（函数原型）
  • 本手册中所涉及的 PHP 版本
  • 如何得到关于 PHP 更多的信息
  • 如何帮助改进本文档
  • 如何生成手册的各种格式
  • 手册译文


手册的格式

《PHP 参考手册》提供了多种不同格式的版本，它们可以分为两组：在线阅读版本和可下载打包版本。

Note:

有些出版商可能已经出版了本手册的一些印刷版本。不推荐印刷版，因为 PHP 参考手册更新得非常快，这些印刷版本的内容很快将过时。

可以访问 » PHP.net 网站及其众多的镜像站点来在线阅读《PHP 参考手册》。为了保证最佳的访问速度，应该选择地理位置最接近的镜像站点。PHP 手册的在线版本目前有两种 CSS 样式表：便于浏览和便于打印。

和绝大多数离线格式的手册相比，在线阅读版本有两个显著的优点，即它集成了用户注释，并且可以使用其中的 » URL 快捷方式快速进入手册中想阅读的部分；但是，它的明显的缺点是必须要联网才能阅读。

目前，《PHP 参考手册》提供多种离线阅读格式，最适合于自己的格式取决于所使用的操作系统和个人的阅读习惯。关于《PHP 参考手册》如何被制作成如此多的版本，请查阅本附录中如何生成手册的各种格式一节。

跨平台性最好的格式是 HTML 格式格式。HTML 格式提供了两种方式：一种只有一个很大的 HTML 文件；另一种方式是每一节分成一个独立文件（它们形成一个包含有几千个文件的文件包）。我们提供的是这两种版本的压缩包，需要使用解压缩工具解压出压缩包中的文件。

对于 Windows 平台，我们利用了 Windows HTML 帮助应用程序结合本手册的 HTML 格式，形成了本手册的 Windows HTML 帮助版本。该版本提供手册的全文搜索、完整的索引以及书签功能。很多 Windows 平台下流行的 PHP 集成开发环境也集成了该版本的手册，以给开发者提供最方便快捷的参考。CHM 阅读器也有 Linux 版本，可以到 » xCHM 或 » GnoCHM 网站了解更多信息。

同时，PHP 手册也有» 扩展 CHM 版本提供下载。它更新的速度比较慢，但是提供了附加的功能。由于制作帮助页面时采用的技术的特殊性，它只可在 Microsoft Windows 下工作。


关于用户注释

用户注释在本手册的开发过程中搬演了相当重要的角色。通过允许手册的读者利用它们的浏览器提供范例、解释和进一步的阐述，我们便能够把这些反馈信息包含到手册的正文中。而且，当这些注释被包含后，读者就可以在线通过它们被提交的格式来阅读它们，也可以通过某些离线格式来阅读。

Note:

用户注释在网上出现之前并不成熟，因此这些文字和代码的质量，甚至它们的真实性无从得到保证（这并不是说本手册本身的质量和准确性没有任何的保证）。

Note:

由于用户注释被认为是 PHP 手册的一部分，因此它使用本文档的许可协议（目前为创作共用许可协议）。请查阅手册版权页以了解更多详细信息。


如何阅读函数的定义（函数原型）

文档中的每个函数都只是快速参考，学会如何阅读和理解文档将使得 PHP 的使用更加简单。和依赖赖于复制／粘贴范例比起来，用户一定更希望知道如何阅读函数的定义（函数原型）：

Note: 先决条件，对变量类型的基本理解

尽管 PHP 是一种松散类型语言，但变量类型有重要的意义，需要理解它的基本知识。

函数定义告诉我们函数返回什么类型的值，让我们用函数 strlen() 的定义作为第一个范例：

strlen

(PHP 4, PHP 5, PHP 7)
strlen -- Get string length

说明
strlen ( string $string ) : int

返回给定的字符串 string 的长度。

对函数定义的解释
组成部分 | 说明
strlen | 函数名称。
(PHP 4, PHP 5, PHP 7) | strlen() 在 PHP 4, PHP 5 和 PHP 7 的所有版本中都存在。
( string $string ) | 第一个（本例中是唯一的）参数，在该函数中名为 string，且类型为 string。
int | 该函数返回的值的类型，这里为整型 int（即以数字来衡量的字符串的长度）。

可以将以上函数的定义写成一般形式：

          函数名          ( 参数类型           参数名 )        返回类型
      function name    ( parameter type   parameter name ) : returned type

很多函数都有多个变量，例如 in_array()。其函数原型如下：

      in_array ( mixed $needle, array $haystack , bool $strict = false ) : bool

这是什么意思？in_array() 返回一个"布尔"值，成功（如果在参数 haystack 中能找到参数 needle）则返回 true, 或者在失败时返回 false（如果在参数 haystack 中找不到参数 needle）。第一个参数被命名为 needle 且其类型不定，因此我们将其称为"混和"类型。该混和类型的 needle 参数（我们要找的对象）可以是一个标量的值（字符串、整数、或者浮点数），或者一个数组。haystack（我们寻找的范围）是第二个参数。第三个可选参数被命名为 strict。所有的可选参数都用 [ 方括号 ] 括起来。手册表明 strict 参数默认值为布尔值 false。需要了解函数工作的细节，请参阅手册中和该函数相关的页面。

函数参数前的 & 符号使参数以 引用 方式传递，如下所见：

       preg_match ( string $pattern , string $subject [, array &$matches
      [, int $flags = 0 [, int $offset = 0 ]]] ) : int

在这个例子中，我们可以看到，第三个可选参数 &$matches 会意引用方式传递。

有的函数包含更复杂的 PHP 版本信息。我们拿 html_entity_decode() 举例：

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

它意味着该函数只可在 PHP 4.3.0 及以后发布的版本中使用。


本手册中所涉及的 PHP 版本

本手册包含有 PHP 过去，现在和未来版本的信息。如果（不同版本）有功能变化则作为注释、更新日志以及插入文本方式在手册页中注明。 文档内最早的版本是 PHP 7.0.0。

当对应于最新（尚未发布）开发版的 PHP 有文档存在时，将会被标记为"可在 Git 获取"或者"开发版本"。应该计划好相关变更，虽不多见但确有可能会有变动。

所有开发都放置于 Git 中，应按照» 匿名 Git 访问页面中的方法来取出。

要澄清一点，手册会指明 PHP 的主版本号，次版本号和发布编号。以 PHP 7.3.1 为例，5 是主版本号，3 是次版本号，1 是发布编号。通常 PHP 只会在主、次版本更新时增加新特性，在发布编号更新时修正错误。不过也不完全是这样。

还要注意 PHP 手册是以现在时态书写的，而不是将来时态，即使某特性当前还尚未可用。原因是这样一来手册就可以经受住时间的考验，而不用在每次 PHP 更新时都去修改无聊的语法。

PHP 手册会多次列出 PHP 配置选项的"默认值"。默认值是没有 php.ini 配置文件时的值，所以与 php.ini-development 和 php.ini-production 存在很大差异。同时这些值也是基于最新版本的 PHP。请参考 PHP 配置选项列表以了解更多信息。


如何得到关于 PHP 更多的信息

本手册并不打算提供基本的编程开发指导。刚学编程的或者新手程序员会发现仅仅用本手册来学习如何用 PHP 编程是一件很困难的事情。应该寻找一本更适合初学者的书。

目前，PHP 官方提供了许多邮件列表来讨论 PHP 编程相关的各个方面的问题。如果卡在了某个问题上，可以到该邮件列表寻求帮助。有关支持以及邮件列表请访问 » PHP.net 支持页面。


如何帮助改进本文档

可以通过以下三种途径来帮助改善本文档。

如果发现本手册任何一个格式的版本中有错误，请通过设在 » https://bugs.php.net/ 的纠错系统向我们报告，并将提交的错误分类为"文档问题 (Documentation Problem)"。所有文档相关的问题，包括手册格式，都应作为错误提交。

Note:

请勿滥用纠错系统来寻求帮助。如需帮助请访问» 支持页面。

通过提交注释，用户可以向其它读者提供更多的范例、解释和阐述。但请勿在注释系统提交错误报告。更多细节见关于用户注释一节。

PHP 手册被翻译成很多种语言。如果懂英语和另一种语言，可以加入翻译团队来帮助改善文档。关于开始一个新语种的翻译，或者加入某一个语言版本的翻译工作，请下载并阅读 » http://doc.php.net/tutorial/。

PHP 文档项目也有一个 IRC 频道，许多手册作者都常去。可以访问 irc.efnet.org 服务器上的 #php.doc 与他们讨论改善 PHP 文档的方法。


如何生成手册的各种格式

本手册使用 XML 语言编写，同时运用了 » DocBook XML DTD。还用了 » PhD（基于 [PH]P 的 [D]ocBook 渲染器）来维护和格式化。

将 XML 语言作为源文件格式，使得我们只需维护该源文件文档，就可以可以利用它生成许多其它的输出格式。生在在线手册格式的工具是 » PhD。我们使用 » Microsoft HTML Help Workshop 来生成本手册的 Windows HTML 帮助 格式。当然，PHP 本身也完成了其它一些转换和格式化工作。

PHP 手册被生成多种不同语言和格式，详情见 » https://www.php.net/docs.php。XML 格式的源代码可以通过 SVN 下载，并通过 » https://svn.php.net/viewvc/ 在线浏览。文档存放于 phpdoc 模块中。


手册译文

《PHP 参考手册》不但有各种不同的格式，而且还有各种语言的版本。手册的正文最初是用英语撰写的，后来有来自全世界各地的工作组致力于本手册各种语言版本的翻译工作。如果某个函数或者章节的内容尚未被翻译，则该语言版本手册的发布将落后于英语版本。

翻译工作者首先从本手册的 XML 源代码（可于 » https://github.com/php/doc-en" 获取）入手，将这些源代码翻译成他们的母语。不要从生成后的版本开始翻译（比如 HTML 或纯文本版）。因为编译系统会负责将 XML 源代码转换成可阅读版本。

Note:

要帮忙翻译手册，请发一封空的电子邮件到 » phpdoc-subscribe@lists.php.net 加入 phpdoc 邮件列表以便与文档翻译小组取得联系。邮件列表的地址为 phpdoc@lists.php.net。请在电子邮件中声明对文档翻译工作感兴趣，有人会回复并帮助加入到已经存在的翻译小组，或者开始新语种的翻译工作。

目前，本手册已经（或部分）有超过 10 种语言可用。

可以访问 » https://www.php.net/docs.php 来下载各种版本。


Creative Commons Attribution 3.0

THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/OR OTHER APPLICABLE LAW. ANY USE OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT LAW IS PROHIBITED.

BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. TO THE EXTENT THIS LICENSE MAY BE CONSIDERED TO BE A CONTRACT, THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH TERMS AND CONDITIONS.

1. Definitions

  1. "Adaptation" means a work based upon the Work, or upon the Work and other pre-existing works, such as a translation, adaptation, derivative work, arrangement of music or other alterations of a literary or artistic work, or phonogram or performance and includes cinematographic adaptations or any other form in which the Work may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work that constitutes a Collection will not be considered an Adaptation for the purpose of this License. For the avoidance of doubt, where the Work is a musical work, performance or phonogram, the synchronization of the Work in timed-relation with a moving image ("synching") will be considered an Adaptation for the purpose of this License.
  2. "Collection" means a collection of literary or artistic works, such as encyclopedias and anthologies, or performances, phonograms or broadcasts, or other works or subject matter other than works listed in Section 1(f) below, which, by reason of the selection and arrangement of their contents, constitute intellectual creations, in which the Work is included in its entirety in unmodified form along with one or more other contributions, each constituting separate and independent works in themselves, which together are assembled into a collective whole. A work that constitutes a Collection will not be considered an Adaptation (as defined above) for the purposes of this License.
  3. "Distribute" means to make available to the public the original and copies of the Work or Adaptation, as appropriate, through sale or other transfer of ownership.
  4. "Licensor" means the individual, individuals, entity or entities that offer(s) the Work under the terms of this License.
  5. "Work" means the literary and/or artistic work offered under the terms of this License including without limitation any production in the literary, scientific and artistic domain, whatever may be the mode or form of its expression including digital form, such as a book, pamphlet and other writing; a lecture, address, sermon or other work of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography; a work of drawing, painting, architecture, sculpture, engraving or lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art; an illustration, map, plan, sketch or three-dimensional work relative to geography, topography, architecture or science; a performance; a broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or circus performer to the extent it is not otherwise considered a literary or artistic work.
  6. "You" means an individual or entity exercising rights under this License who has not previously violated the terms of this License with respect to the Work, or who has received express permission from the Licensor to exercise rights under this License despite a previous violation.
  7. "Publicly Perform" means to perform public recitations of the Work and to communicate to the public those public recitations, by any means or process, including by wire or wireless means or public digital performances; to make available to the public Works in such a way that members of the public may access these Works from a place and at a place individually chosen by them; to perform the Work to the public by any means or process and the communication to the public of the performances of the Work, including by public digital performance; to broadcast and rebroadcast the Work by any means including signs, sounds or images.
  8. "Reproduce" means to make copies of the Work by any means including without limitation by sound or visual recordings and the right of fixation and reproducing fixations of the Work, including storage of a protected performance or phonogram in digital form or other electronic medium.

2. Fair Dealing Rights. Nothing in this License is intended to reduce, limit, or restrict any uses free from copyright or rights arising from limitations or exceptions that are provided for in connection with the copyright protection under copyright law or other applicable laws.

3. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the rights in the Work as stated below:

  1. to Reproduce the Work, to incorporate the Work into one or more Collections, and to Reproduce the Work as incorporated in the Collections;
  2. to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable steps to clearly label, demarcate or otherwise identify that changes were made to the original Work. For example, a translation could be marked "The original work was translated from English to Spanish," or a modification could indicate "The original work has been modified.";
  3. to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
  4. to Distribute and Publicly Perform Adaptations.

  5. For the avoidance of doubt:

    1. Non-waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise by You of the rights granted under this License;
    2. Waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme can be waived, the Licensor waives the exclusive right to collect such royalties for any exercise by You of the rights granted under this License; and,
    3. Voluntary License Schemes. The Licensor waives the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary licensing schemes, via that society, from any exercise by You of the rights granted under this License.

The above rights may be exercised in all media and formats whether now known or hereafter devised. The above rights include the right to make such modifications as are technically necessary to exercise the rights in other media and formats. Subject to Section 8(f), all rights not expressly granted by Licensor are hereby reserved.

4. Restrictions. The license granted in Section 3 above is expressly made subject to and limited by the following restrictions:

  1. You may Distribute or Publicly Perform the Work only under the terms of this License. You must include a copy of, or the Uniform Resource Identifier (URI) for, this License with every copy of the Work You Distribute or Publicly Perform. You may not offer or impose any terms on the Work that restrict the terms of this License or the ability of the recipient of the Work to exercise the rights granted to that recipient under the terms of the License. You may not sublicense the Work. You must keep intact all notices that refer to this License and to the disclaimer of warranties with every copy of the Work You Distribute or Publicly Perform. When You Distribute or Publicly Perform the Work, You may not impose any effective technological measures on the Work that restrict the ability of a recipient of the Work from You to exercise the rights granted to that recipient under the terms of the License. This Section 4(a) applies to the Work as incorporated in a Collection, but this does not require the Collection apart from the Work itself to be made subject to the terms of this License. If You create a Collection, upon notice from any Licensor You must, to the extent practicable, remove from the Collection any credit as required by Section 4(b), as requested. If You create an Adaptation, upon notice from any Licensor You must, to the extent practicable, remove from the Adaptation any credit as required by Section 4(b), as requested.
  2. If You Distribute, or Publicly Perform the Work or any Adaptations or Collections, You must, unless a request has been made pursuant to Section 4(a), keep intact all copyright notices for the Work and provide, reasonable to the medium or means You are utilizing: (i) the name of the Original Author (or pseudonym, if applicable) if supplied, and/or if the Original Author and/or Licensor designate another party or parties (e.g., a sponsor institute, publishing entity, journal) for attribution ("Attribution Parties") in Licensor's copyright notice, terms of service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the extent reasonably practicable, the URI, if any, that Licensor specifies to be associated with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and (iv) , consistent with Section 3(b), in the case of an Adaptation, a credit identifying the use of the Work in the Adaptation (e.g., "French translation of the Work by Original Author," or "Screenplay based on original Work by Original Author"). The credit required by this Section 4 (b) may be implemented in any reasonable manner; provided, however, that in the case of a Adaptation or Collection, at a minimum such credit will appear, if a credit for all contributing authors of the Adaptation or Collection appears, then as part of these credits and in a manner at least as prominent as the credits for the other contributing authors. For the avoidance of doubt, You may only use the credit required by this Section for the purpose of attribution in the manner set out above and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship or endorsement by the Original Author, Licensor and/or Attribution Parties, as appropriate, of You or Your use of the Work, without the separate, express prior written permission of the Original Author, Licensor and/or Attribution Parties.
  3. Except as otherwise agreed in writing by the Licensor or as may be otherwise permitted by applicable law, if You Reproduce, Distribute or Publicly Perform the Work either by itself or as part of any Adaptations or Collections, You must not distort, mutilate, modify or take other derogatory action in relation to the Work which would be prejudicial to the Original Author's honor or reputation. Licensor agrees that in those jurisdictions (e.g. Japan), in which any exercise of the right granted in Section 3(b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modification or other derogatory action prejudicial to the Original Author's honor and reputation, the Licensor will waive or not assert, as appropriate, this Section, to the fullest extent permitted by the applicable national law, to enable You to reasonably exercise Your right under Section 3(b) of this License (right to make Adaptations) but not otherwise.

5. Representations, Warranties and Disclaimer

UNLESS OTHERWISE MUTUALLY AGREED TO BY THE PARTIES IN WRITING, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND CONCERNING THE WORK, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WARRANTIES OF TITLE, MERCHANTIBILITY, FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT, OR THE ABSENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO SUCH EXCLUSION MAY NOT APPLY TO YOU.

6. Limitation on Liability. EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. Termination.

  1. This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals or entities who have received Adaptations or Collections from You under this License, however, will not have their licenses terminated provided such individuals or entities remain in full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination of this License.
  2. Subject to the above terms and conditions, the license granted here is perpetual (for the duration of the applicable copyright in the Work). Notwithstanding the above, Licensor reserves the right to release the Work under different license terms or to stop distributing the Work at any time; provided, however that any such election will not serve to withdraw this License (or any other license that has been, or is required to be, granted under the terms of this License), and this License will continue in full force and effect unless terminated as stated above.

8. Miscellaneous

  1. Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor offers to the recipient a license to the Work on the same terms and conditions as the license granted to You under this License.
  2. Each time You Distribute or Publicly Perform an Adaptation, Licensor offers to the recipient a license to the original Work on the same terms and conditions as the license granted to You under this License.
  3. If any provision of this License is invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of the terms of this License, and without further action by the parties to this agreement, such provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable.
  4. No term or provision of this License shall be deemed waived and no breach consented to unless such waiver or consent shall be in writing and signed by the party to be charged with such waiver or consent
  5. This License constitutes the entire agreement between the parties with respect to the Work licensed here. There are no understandings, agreements or representations with respect to the Work not specified here. Licensor shall not be bound by any additional provisions that may appear in any communication from You. This License may not be modified without the mutual written agreement of the Licensor and You.
  6. The rights granted under, and the subject matter referenced, in this License were drafted utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on September 28, 1979), the Rome Convention of 1961, the WIPO Copyright Treaty of 1996, the WIPO Performances and Phonograms Treaty of 1996 and the Universal Copyright Convention (as revised on July 24, 1971). These rights and subject matter take effect in the relevant jurisdiction in which the License terms are sought to be enforced according to the corresponding provisions of the implementation of those treaty provisions in the applicable national law. If the standard suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are deemed to be included in the License; this License is not intended to restrict the license of any rights under applicable law.


  • ? Creative Commons Attribution 3.0
  • 函数和方法列表 ?
  • PHP Manual
  • 附录
  • 索引

索引

Table of Contents

  • 函数和方法列表
  • 示例列表


函数和方法列表

手册中所有函数和方法的列表

a b c d e f g h i j k l m n o p q r s t u v w x y z _ ?

  • a
    • abs - 绝对值
    • acos - 反余弦
    • acosh - 反双曲余弦
    • addcslashes - 以 C 语言风格使用反斜线转义字符串中的字符
    • addslashes - 使用反斜线引用字符串
    • apache_child_terminate - 在本次请求结束后终止 apache 子进程
    • apache_getenv - 获取 Apache subprocess_env 变量
    • apache_get_modules - 获得已加载的Apache模块列表
    • apache_get_version - 获得Apache版本信息
    • apache_lookup_uri - 对指定的 URI 执行部分请求并返回所有有关信息
    • apache_note - 取得或设置 apache 请求记录
    • apache_request_headers - 获取全部 HTTP 请求头信息
    • apache_response_headers - 获得全部 HTTP 响应头信息
    • apache_setenv - 设置 Apache 子进程环境变量
    • APCUIterator::current - Get current item
    • APCUIterator::getTotalCount - Get total count
    • APCUIterator::getTotalHits - Get total cache hits
    • APCUIterator::getTotalSize - Get total cache size
    • APCUIterator::key - Get iterator key
    • APCUIterator::next - Move pointer to next item
    • APCUIterator::rewind - Rewinds iterator
    • APCUIterator::valid - Checks if current position is valid
    • APCUIterator::__construct - Constructs an APCUIterator iterator object
    • apcu_add - Cache a new variable in the data store
    • apcu_cache_info - Retrieves cached information from APCu's data store
    • apcu_cas - Updates an old value with a new value
    • apcu_clear_cache - Clears the APCu cache
    • apcu_dec - Decrease a stored number
    • apcu_delete - Removes a stored variable from the cache
    • apcu_enabled - Whether APCu is usable in the current environment
    • apcu_entry - Atomically fetch or generate a cache entry
    • apcu_exists - Checks if entry exists
    • apcu_fetch - Fetch a stored variable from the cache
    • apcu_inc - Increase a stored number
    • apcu_key_info - Get detailed information about the cache key
    • apcu_sma_info - Retrieves APCu Shared Memory Allocation information
    • apcu_store - Cache a variable in the data store
    • AppendIterator::append - Appends an iterator
    • AppendIterator::current - Gets the current value
    • AppendIterator::getArrayIterator - Gets the ArrayIterator
    • AppendIterator::getInnerIterator - Gets the inner iterator
    • AppendIterator::getIteratorIndex - Gets an index of iterators
    • AppendIterator::key - Gets the current key
    • AppendIterator::next - Moves to the next element
    • AppendIterator::rewind - Rewinds the Iterator
    • AppendIterator::valid - Checks validity of the current element
    • AppendIterator::__construct - Constructs an AppendIterator
    • array - 新建一个数组
    • ArrayAccess::offsetExists - 检查一个偏移位置是否存在
    • ArrayAccess::offsetGet - 获取一个偏移位置的值
    • ArrayAccess::offsetSet - 设置一个偏移位置的值
    • ArrayAccess::offsetUnset - 复位一个偏移位置的值
    • ArrayIterator::append - Append an element
    • ArrayIterator::asort - Sort array by values
    • ArrayIterator::count - Count elements
    • ArrayIterator::current - Return current array entry
    • ArrayIterator::getArrayCopy - Get array copy
    • ArrayIterator::getFlags - Get behavior flags
    • ArrayIterator::key - Return current array key
    • ArrayIterator::ksort - Sort array by keys
    • ArrayIterator::natcasesort - Sort an array naturally, case insensitive
    • ArrayIterator::natsort - Sort an array naturally
    • ArrayIterator::next - Move to next entry
    • ArrayIterator::offsetExists - Check if offset exists
    • ArrayIterator::offsetGet - Get value for an offset
    • ArrayIterator::offsetSet - Set value for an offset
    • ArrayIterator::offsetUnset - Unset value for an offset
    • ArrayIterator::rewind - Rewind array back to the start
    • ArrayIterator::seek - Seek to position
    • ArrayIterator::serialize - Serialize
    • ArrayIterator::setFlags - Set behaviour flags
    • ArrayIterator::uasort - Sort with a user-defined comparison function and maintain index association
    • ArrayIterator::uksort - Sort by keys using a user-defined comparison function
    • ArrayIterator::unserialize - Unserialize
    • ArrayIterator::valid - Check whether array contains more entries
    • ArrayIterator::__construct - Construct an ArrayIterator
    • ArrayObject::append - 追加新的值作为最后一个元素。
    • ArrayObject::asort - Sort the entries by value
    • ArrayObject::count - 统计 ArrayObject 内 public 属性的数量
    • ArrayObject::exchangeArray - Exchange the array for another one
    • ArrayObject::getArrayCopy - Creates a copy of the ArrayObject
    • ArrayObject::getFlags - Gets the behavior flags
    • ArrayObject::getIterator - Create a new iterator from an ArrayObject instance
    • ArrayObject::getIteratorClass - Gets the iterator classname for the ArrayObject
    • ArrayObject::ksort - Sort the entries by key
    • ArrayObject::natcasesort - Sort an array using a case insensitive "natural order" algorithm
    • ArrayObject::natsort - Sort entries using a "natural order" algorithm
    • ArrayObject::offsetExists - Returns whether the requested index exists
    • ArrayObject::offsetGet - Returns the value at the specified index
    • ArrayObject::offsetSet - 为指定索引设定新的值
    • ArrayObject::offsetUnset - Unsets the value at the specified index
    • ArrayObject::serialize - Serialize an ArrayObject
    • ArrayObject::setFlags - Sets the behavior flags
    • ArrayObject::setIteratorClass - Sets the iterator classname for the ArrayObject
    • ArrayObject::uasort - Sort the entries with a user-defined comparison function and maintain key association
    • ArrayObject::uksort - Sort the entries by keys using a user-defined comparison function
    • ArrayObject::unserialize - Unserialize an ArrayObject
    • ArrayObject::__construct - Construct a new array object
    • array_change_key_case - 将数组中的所有键名修改为全大写或小写
    • array_chunk - 将一个数组分割成多个
    • array_column - 返回数组中指定的一列
    • array_combine - 创建一个数组，用一个数组的值作为其键名，另一个数组的值作为其值
    • array_count_values - 统计数组中所有的值
    • array_diff - 计算数组的差集
    • array_diff_assoc - 带索引检查计算数组的差集
    • array_diff_key - 使用键名比较计算数组的差集
    • array_diff_uassoc - 用用户提供的回调函数做索引检查来计算数组的差集
    • array_diff_ukey - 用回调函数对键名比较计算数组的差集
    • array_fill - 用给定的值填充数组
    • array_fill_keys - 使用指定的键和值填充数组
    • array_filter - 使用回调函数过滤数组的元素
    • array_flip - 交换数组中的键和值
    • array_intersect - 计算数组的交集
    • array_intersect_assoc - 带索引检查计算数组的交集
    • array_intersect_key - 使用键名比较计算数组的交集
    • array_intersect_uassoc - 带索引检查计算数组的交集，用回调函数比较索引
    • array_intersect_ukey - 用回调函数比较键名来计算数组的交集
    • array_keys - 返回数组中部分的或所有的键名
    • array_key_exists - 检查数组里是否有指定的键名或索引
    • array_key_first - 获取指定数组的第一个键值
    • array_key_last - 获取一个数组的最后一个键值
    • array_map - 为数组的每个元素应用回调函数
    • array_merge - 合并一个或多个数组
    • array_merge_recursive - 递归地合并一个或多个数组
    • array_multisort - 对多个数组或多维数组进行排序
    • array_pad - 以指定长度将一个值填充进数组
    • array_pop - 弹出数组最后一个单元（出栈）
    • array_product - 计算数组中所有值的乘积
    • array_push - 将一个或多个单元压入数组的末尾（入栈）
    • array_rand - 从数组中随机取出一个或多个随机键
    • array_reduce - 用回调函数迭代地将数组简化为单一的值
    • array_replace - 使用传递的数组替换第一个数组的元素
    • array_replace_recursive - 使用传递的数组递归替换第一个数组的元素
    • array_reverse - 返回单元顺序相反的数组
    • array_search - 在数组中搜索给定的值，如果成功则返回首个相应的键名
    • array_shift - 将数组开头的单元移出数组
    • array_slice - 从数组中取出一段
    • array_splice - 去掉数组中的某一部分并用其它值取代
    • array_sum - 对数组中所有值求和
    • array_udiff - 用回调函数比较数据来计算数组的差集
    • array_udiff_assoc - 带索引检查计算数组的差集，用回调函数比较数据
    • array_udiff_uassoc - 带索引检查计算数组的差集，用回调函数比较数据和索引
    • array_uintersect - 计算数组的交集，用回调函数比较数据
    • array_uintersect_assoc - 带索引检查计算数组的交集，用回调函数比较数据
    • array_uintersect_uassoc - 带索引检查计算数组的交集，用单独的回调函数比较数据和索引
    • array_unique - 移除数组中重复的值
    • array_unshift - 在数组开头插入一个或多个单元
    • array_values - 返回数组中所有的值
    • array_walk - 使用用户自定义函数对数组中的每个元素做回调处理
    • array_walk_recursive - 对数组中的每个成员递归地应用用户函数
    • arsort - 对数组进行逆向排序并保持索引关系
    • asin - 反正弦
    • asinh - 反双曲正弦
    • asort - 对数组进行排序并保持索引关系
    • assert - 检查一个断言是否为 false
    • assert_options - 设置/获取断言的各种标志
    • atan - 反正切
    • atan2 - 两个参数的反正切
    • atanh - 反双曲正切
  • b
    • base64_decode - 对使用 MIME base64 编码的数据进行解码
    • base64_encode - 使用 MIME base64 对数据进行编码
    • basename - 返回路径中的文件名部分
    • BaseResult::getWarnings - Fetch warnings from last operation
    • BaseResult::getWarningsCount - Fetch warning count from last operation
    • base_convert - 在任意进制之间转换数字
    • bcadd - 2个任意精度数字的加法计算
    • bccomp - 比较两个任意精度的数字
    • bcdiv - 2个任意精度的数字除法计算
    • bcmod - 对一个任意精度数字取模
    • bcmul - 2个任意精度数字乘法计算
    • bcpow - 任意精度数字的乘方
    • bcpowmod - Raise an arbitrary precision number to another, reduced by a specified modulus
    • bcscale - 设置所有bc数学函数的默认小数点保留位数
    • bcsqrt - 任意精度数字的二次方根
    • bcsub - 2个任意精度数字的减法
    • bin2hex - 函数把包含数据的二进制字符串转换为十六进制值
    • bindec - 二进制转换为十进制
    • bindtextdomain - Sets or gets the path for a domain
    • bind_textdomain_codeset - Specify or get the character encoding in which the messages from the DOMAIN message catalog will be returned
    • boolval - 获取变量的布尔值
    • bson_decode - 反序列化一个 BSON 对象为 PHP 数组
    • bson_encode - 序列化一个 PHP 变量为 BSON 字符串
    • bzclose - 关闭一个 bzip2 文件
    • bzcompress - 把一个字符串压缩成 bzip2 编码数据
    • bzdecompress - 解压经 bzip2 编码过的数据
    • bzerrno - 返回一个 bzip2 错误码
    • bzerror - 返回包含 bzip2 错误号和错误字符串的一个 array
    • bzerrstr - 返回一个 bzip2 的错误字符串
    • bzflush - 强制写入所有写缓冲区的数据
    • bzopen - 打开 bzip2 压缩文件
    • bzread - bzip2 文件二进制安全地读取
    • bzwrite - 二进制安全地写入 bzip2 文件
  • c
    • CachingIterator::count - The number of elements in the iterator
    • CachingIterator::current - Return the current element
    • CachingIterator::getCache - Retrieve the contents of the cache
    • CachingIterator::getFlags - Get flags used
    • CachingIterator::getInnerIterator - Returns the inner iterator
    • CachingIterator::hasNext - Check whether the inner iterator has a valid next element
    • CachingIterator::key - Return the key for the current element
    • CachingIterator::next - Move the iterator forward
    • CachingIterator::offsetExists - The offsetExists purpose
    • CachingIterator::offsetGet - The offsetGet purpose
    • CachingIterator::offsetSet - The offsetSet purpose
    • CachingIterator::offsetUnset - The offsetUnset purpose
    • CachingIterator::rewind - Rewind the iterator
    • CachingIterator::setFlags - The setFlags purpose
    • CachingIterator::valid - Check whether the current element is valid
    • CachingIterator::__construct - Construct a new CachingIterator object for the iterator
    • CachingIterator::__toString - Return the string representation of the current element
    • CallbackFilterIterator::accept - Calls the callback with the current value, the current key and the inner iterator as arguments
    • CallbackFilterIterator::__construct - Create a filtered iterator from another iterator
    • call_user_func - 把第一个参数作为回调函数调用
    • call_user_func_array - 调用回调函数，并把一个数组参数作为回调函数的参数
    • cal_days_in_month - 返回某个历法中某年中某月的天数
    • cal_from_jd - 转换Julian Day计数到一个支持的历法。
    • cal_info - 返回选定历法的信息
    • cal_to_jd - 从一个支持的历法转变为Julian Day计数。
    • ceil - 进一法取整
    • chdir - 改变目录
    • checkdate - 验证一个格里高里日期
    • checkdnsrr - 给指定的主机（域名）或者IP地址做DNS通信检查
    • chgrp - 改变文件所属的组
    • chmod - 改变文件模式
    • chop - rtrim 的别名
    • chown - 改变文件的所有者
    • chr - 返回指定的字符
    • chroot - 改变根目录
    • chunk_split - 将字符串分割成小块
    • classkit_import - Import new class method definitions from a file
    • classkit_method_add - Dynamically adds a new method to a given class
    • classkit_method_copy - Copies a method from class to another
    • classkit_method_redefine - Dynamically changes the code of the given method
    • classkit_method_remove - Dynamically removes the given method
    • classkit_method_rename - Dynamically changes the name of the given method
    • class_alias - 为一个类创建别名
    • class_exists - 检查类是否已定义
    • class_implements - 返回指定的类实现的所有接口。
    • class_parents - 返回指定类的父类。
    • class_uses - Return the traits used by the given class
    • clearstatcache - 清除文件状态缓存
    • Client::getClient - Get client session
    • Client::__construct - Client constructor
    • cli_get_process_title - Returns the current process title
    • cli_set_process_title - Sets the process title
    • closedir - 关闭目录句柄
    • closelog - 关闭系统日志链接
    • Closure::bind - 复制一个闭包，绑定指定的$this对象和类作用域。
    • Closure::bindTo - 复制当前闭包对象，绑定指定的$this对象和类作用域。
    • Closure::__construct - 用于禁止实例化的构造函数
    • Collator::asort - Sort array maintaining index association
    • Collator::compare - Compare two Unicode strings
    • Collator::create - Create a collator
    • Collator::getAttribute - Get collation attribute value
    • Collator::getErrorCode - Get collator's last error code
    • Collator::getErrorMessage - Get text for collator's last error code
    • Collator::getLocale - Get the locale name of the collator
    • Collator::getSortKey - Get sorting key for a string
    • Collator::getStrength - Get current collation strength
    • Collator::setAttribute - Set collation attribute
    • Collator::setStrength - Set collation strength
    • Collator::sort - Sort array using specified collator
    • Collator::sortWithSortKeys - Sort array using specified collator and sort keys
    • Collator::__construct - Create a collator
    • Collectable::isGarbage - Determine whether an object has been marked as garbage
    • Collectable::setGarbage - Mark an object as garbage
    • Collection::add - Add collection document
    • Collection::addOrReplaceOne - Add or replace collection document
    • Collection::count - Get document count
    • Collection::createIndex - Create collection index
    • Collection::dropIndex - Drop collection index
    • Collection::existsInDatabase - Check if collection exists in database
    • Collection::find - Search for document
    • Collection::getName - Get collection name
    • Collection::getOne - Get one document
    • Collection::getSchema - Get schema object
    • Collection::getSession - Get session object
    • Collection::modify - Modify collection documents
    • Collection::remove - Remove collection documents
    • Collection::removeOne - Remove one collection document
    • Collection::replaceOne - Replace one collection document
    • Collection::__construct - Collection constructor
    • CollectionAdd::execute - Execute the statement
    • CollectionAdd::__construct - CollectionAdd constructor
    • CollectionFind::bind - Bind value to query placeholder
    • CollectionFind::execute - Execute the statement
    • CollectionFind::fields - Set document field filter
    • CollectionFind::groupBy - Set grouping criteria
    • CollectionFind::having - Set condition for aggregate functions
    • CollectionFind::limit - Limit number of returned documents
    • CollectionFind::lockExclusive - Execute operation with EXCLUSIVE LOCK
    • CollectionFind::lockShared - Execute operation with SHARED LOCK
    • CollectionFind::offset - Skip given number of elements to be returned
    • CollectionFind::sort - Set the sorting criteria
    • CollectionFind::__construct - CollectionFind constructor
    • CollectionModify::arrayAppend - Append element to an array field
    • CollectionModify::arrayInsert - Insert element into an array field
    • CollectionModify::bind - Bind value to query placeholder
    • CollectionModify::execute - Execute modify operation
    • CollectionModify::limit - Limit number of modified documents
    • CollectionModify::patch - Patch document
    • CollectionModify::replace - Replace document field
    • CollectionModify::set - Set document attribute
    • CollectionModify::skip - Skip elements
    • CollectionModify::sort - Set the sorting criteria
    • CollectionModify::unset - Unset the value of document fields
    • CollectionModify::__construct - CollectionModify constructor
    • CollectionRemove::bind - Bind value to placeholder
    • CollectionRemove::execute - Execute remove operation
    • CollectionRemove::limit - Limit number of documents to remove
    • CollectionRemove::sort - Set the sorting criteria
    • CollectionRemove::__construct - CollectionRemove constructor
    • ColumnResult::getCharacterSetName - Get character set
    • ColumnResult::getCollationName - Get collation name
    • ColumnResult::getColumnLabel - Get column label
    • ColumnResult::getColumnName - Get column name
    • ColumnResult::getFractionalDigits - Get fractional digit length
    • ColumnResult::getLength - Get column field length
    • ColumnResult::getSchemaName - Get schema name
    • ColumnResult::getTableLabel - Get table label
    • ColumnResult::getTableName - Get table name
    • ColumnResult::getType - Get column type
    • ColumnResult::isNumberSigned - Check if signed type
    • ColumnResult::isPadded - Check if padded
    • ColumnResult::__construct - ColumnResult constructor
    • com::__construct - com class constructor
    • CommonMark\CQL::__construct - CQL Construction
    • CommonMark\CQL::__invoke - CQL Execution
    • CommonMark\Interfaces\IVisitable::accept - Visitation
    • CommonMark\Interfaces\IVisitor::enter - Visitation
    • CommonMark\Interfaces\IVisitor::leave - Visitation
    • CommonMark\Node::accept - Visitation
    • CommonMark\Node::appendChild - AST Manipulation
    • CommonMark\Node::insertAfter - AST Manipulation
    • CommonMark\Node::insertBefore - AST Manipulation
    • CommonMark\Node::prependChild - AST Manipulation
    • CommonMark\Node::replace - AST Manipulation
    • CommonMark\Node::unlink - AST Manipulation
    • CommonMark\Node\BulletList::__construct - BulletList Construction
    • CommonMark\Node\CodeBlock::__construct - CodeBlock Construction
    • CommonMark\Node\Heading::__construct - Heading Construction
    • CommonMark\Node\Image::__construct - Image Construction
    • CommonMark\Node\Link::__construct - Link Construction
    • CommonMark\Node\OrderedList::__construct - OrderedList Construction
    • CommonMark\Node\Text::__construct - Text Construction
    • CommonMark\Parse - Parsing
    • CommonMark\Parser::finish - Parsing
    • CommonMark\Parser::parse - Parsing
    • CommonMark\Parser::__construct - Parsing
    • CommonMark\Render - Rendering
    • CommonMark\Render\HTML - Rendering
    • CommonMark\Render\Latex - Rendering
    • CommonMark\Render\Man - Rendering
    • CommonMark\Render\XML - Rendering
    • compact - 建立一个数组，包括变量名和它们的值
    • COMPersistHelper::GetCurFileName - Get current filename
    • COMPersistHelper::GetMaxStreamSize - Get maximum stream size
    • COMPersistHelper::InitNew - Initialize object to default state
    • COMPersistHelper::LoadFromFile - Load object from file
    • COMPersistHelper::LoadFromStream - Load object from stream
    • COMPersistHelper::SaveToFile - Save object to file
    • COMPersistHelper::SaveToStream - Save object to stream
    • COMPersistHelper::__construct - Construct a COMPersistHelper object
    • Componere\Abstract\Definition::addInterface - Add Interface
    • Componere\Abstract\Definition::addMethod - Add Method
    • Componere\Abstract\Definition::addTrait - Add Trait
    • Componere\Abstract\Definition::getReflector - Reflection
    • Componere\cast - Casting
    • Componere\cast_by_ref - Casting
    • Componere\Definition::addConstant - Add Constant
    • Componere\Definition::addProperty - Add Property
    • Componere\Definition::getClosure - Get Closure
    • Componere\Definition::getClosures - Get Closures
    • Componere\Definition::isRegistered - State Detection
    • Componere\Definition::register - Registration
    • Componere\Definition::__construct - Definition Construction
    • Componere\Method::getReflector - Reflection
    • Componere\Method::setPrivate - Accessibility Modification
    • Componere\Method::setProtected - Accessibility Modification
    • Componere\Method::setStatic - Accessibility Modification
    • Componere\Method::__construct - Method Construction
    • Componere\Patch::apply - Application
    • Componere\Patch::derive - Patch Derivation
    • Componere\Patch::getClosure - Get Closure
    • Componere\Patch::getClosures - Get Closures
    • Componere\Patch::isApplied - State Detection
    • Componere\Patch::revert - Reversal
    • Componere\Patch::__construct - Patch Construction
    • Componere\Value::hasDefault - Value Interaction
    • Componere\Value::isPrivate - Accessibility Detection
    • Componere\Value::isProtected - Accessibility Detection
    • Componere\Value::isStatic - Accessibility Detection
    • Componere\Value::setPrivate - Accessibility Modification
    • Componere\Value::setProtected - Accessibility Modification
    • Componere\Value::setStatic - Accessibility Modification
    • Componere\Value::__construct - Value Construction
    • com_create_guid - Generate a globally unique identifier (GUID)
    • com_event_sink - Connect events from a COM object to a PHP object
    • com_get_active_object - Returns a handle to an already running instance of a COM object
    • com_load_typelib - 装载一个 Typelib
    • com_message_pump - Process COM messages, sleeping for up to timeoutms milliseconds
    • com_print_typeinfo - Print out a PHP class definition for a dispatchable interface
    • Cond::broadcast - 广播条件变量
    • Cond::create - 创建一个条件变量
    • Cond::destroy - 销毁条件变量
    • Cond::signal - 发送唤醒信号
    • Cond::wait - 等待
    • connection_aborted - 检查客户端是否已经断开
    • connection_status - 返回连接的状态位
    • constant - 返回一个常量的值
    • Context 参数 - Context 参数列表
    • convert_cyr_string - 将字符由一种 Cyrillic 字符转换成另一种
    • convert_uudecode - 解码一个 uuencode 编码的字符串
    • convert_uuencode - 使用 uuencode 编码一个字符串
    • copy - 拷贝文件
    • cos - 余弦
    • cosh - 双曲余弦
    • count - 计算数组中的单元数目，或对象中的属性个数
    • Countable::count - 统计一个对象的元素个数
    • count_chars - 返回字符串所用字符的信息
    • crc32 - 计算一个字符串的 crc32 多项式
    • create_function - Create an anonymous (lambda-style) function
    • CrudOperationBindable::bind - Bind value to placeholder
    • CrudOperationLimitable::limit - Set result limit
    • CrudOperationSkippable::skip - Number of operations to skip
    • CrudOperationSortable::sort - Sort results
    • crypt - 单向字符串散列
    • ctype_alnum - 做字母和数字字符检测
    • ctype_alpha - 做纯字符检测
    • ctype_cntrl - 做控制字符检测
    • ctype_digit - 做纯数字检测
    • ctype_graph - 做可打印字符串检测，空格除外
    • ctype_lower - 做小写字符检测
    • ctype_print - 做可打印字符检测
    • ctype_punct - 检测可打印的字符是不是不包含空白、数字和字母
    • ctype_space - 做空白字符检测
    • ctype_upper - 做大写字母检测
    • ctype_xdigit - 检测字符串是否只包含十六进制字符
    • cubrid_affected_rows - Return the number of rows affected by the last SQL statement
    • cubrid_bind - Bind variables to a prepared statement as parameters
    • cubrid_client_encoding - Return the current CUBRID connection charset
    • cubrid_close - Close CUBRID connection
    • cubrid_close_prepare - Close the request handle
    • cubrid_close_request - Close the request handle
    • cubrid_column_names - Get the column names in result
    • cubrid_column_types - Get column types in result
    • cubrid_col_get - Get contents of collection type column using OID
    • cubrid_col_size - Get the number of elements in collection type column using OID
    • cubrid_commit - Commit a transaction
    • cubrid_connect - Open a connection to a CUBRID Server
    • cubrid_connect_with_url - Establish the environment for connecting to CUBRID server
    • cubrid_current_oid - Get OID of the current cursor location
    • cubrid_data_seek - Move the internal row pointer of the CUBRID result
    • cubrid_db_name - Get db name from results of cubrid_list_dbs
    • cubrid_disconnect - Close a database connection
    • cubrid_drop - Delete an instance using OID
    • cubrid_errno - Return the numerical value of the error message from previous CUBRID operation
    • cubrid_error - Get the error message
    • cubrid_error_code - Get error code for the most recent function call
    • cubrid_error_code_facility - Get the facility code of error
    • cubrid_error_msg - Get last error message for the most recent function call
    • cubrid_execute - Execute a prepared SQL statement
    • cubrid_fetch - Fetch the next row from a result set
    • cubrid_fetch_array - Fetch a result row as an associative array, a numeric array, or both
    • cubrid_fetch_assoc - Return the associative array that corresponds to the fetched row
    • cubrid_fetch_field - Get column information from a result and return as an object
    • cubrid_fetch_lengths - Return an array with the lengths of the values of each field from the current row
    • cubrid_fetch_object - Fetch the next row and return it as an object
    • cubrid_fetch_row - Return a numerical array with the values of the current row
    • cubrid_field_flags - Return a string with the flags of the given field offset
    • cubrid_field_len - Get the maximum length of the specified field
    • cubrid_field_name - Return the name of the specified field index
    • cubrid_field_seek - Move the result set cursor to the specified field offset
    • cubrid_field_table - Return the name of the table of the specified field
    • cubrid_field_type - Return the type of the column corresponding to the given field offset
    • cubrid_free_result - Free the memory occupied by the result data
    • cubrid_get - Get a column using OID
    • cubrid_get_autocommit - Get auto-commit mode of the connection
    • cubrid_get_charset - Return the current CUBRID connection charset
    • cubrid_get_class_name - Get the class name using OID
    • cubrid_get_client_info - Return the client library version
    • cubrid_get_db_parameter - Returns the CUBRID database parameters
    • cubrid_get_query_timeout - Get the query timeout value of the request
    • cubrid_get_server_info - Return the CUBRID server version
    • cubrid_insert_id - Return the ID generated for the last updated AUTO_INCREMENT column
    • cubrid_is_instance - Check whether the instance pointed by OID exists
    • cubrid_list_dbs - Return an array with the list of all existing CUBRID databases
    • cubrid_load_from_glo - Read data from a GLO instance and save it in a file
    • cubrid_lob2_bind - Bind a lob object or a string as a lob object to a prepared statement as parameters
    • cubrid_lob2_close - Close LOB object
    • cubrid_lob2_export - Export the lob object to a file
    • cubrid_lob2_import - Import BLOB/CLOB data from a file
    • cubrid_lob2_new - Create a lob object
    • cubrid_lob2_read - Read from BLOB/CLOB data
    • cubrid_lob2_seek - Move the cursor of a lob object
    • cubrid_lob2_seek64 - Move the cursor of a lob object
    • cubrid_lob2_size - Get a lob object's size
    • cubrid_lob2_size64 - Get a lob object's size
    • cubrid_lob2_tell - Tell the cursor position of the LOB object
    • cubrid_lob2_tell64 - Tell the cursor position of the LOB object
    • cubrid_lob2_write - Write to a lob object
    • cubrid_lob_close - Close BLOB/CLOB data
    • cubrid_lob_export - Export BLOB/CLOB data to file
    • cubrid_lob_get - Get BLOB/CLOB data
    • cubrid_lob_send - Read BLOB/CLOB data and send straight to browser
    • cubrid_lob_size - Get BLOB/CLOB data size
    • cubrid_lock_read - Set a read lock on the given OID
    • cubrid_lock_write - Set a write lock on the given OID
    • cubrid_move_cursor - Move the cursor in the result
    • cubrid_new_glo - Create a glo instance
    • cubrid_next_result - Get result of next query when executing multiple SQL statements
    • cubrid_num_cols - Return the number of columns in the result set
    • cubrid_num_fields - Return the number of columns in the result set
    • cubrid_num_rows - Get the number of rows in the result set
    • cubrid_pconnect - Open a persistent connection to a CUBRID server
    • cubrid_pconnect_with_url - Open a persistent connection to CUBRID server
    • cubrid_ping - Ping a server connection or reconnect if there is no connection
    • cubrid_prepare - Prepare a SQL statement for execution
    • cubrid_put - Update a column using OID
    • cubrid_query - Send a CUBRID query
    • cubrid_real_escape_string - Escape special characters in a string for use in an SQL statement
    • cubrid_result - Return the value of a specific field in a specific row
    • cubrid_rollback - Roll back a transaction
    • cubrid_save_to_glo - Save requested file in a GLO instance
    • cubrid_schema - Get the requested schema information
    • cubrid_send_glo - Read data from glo and send it to std output
    • cubrid_seq_drop - Delete an element from sequence type column using OID
    • cubrid_seq_insert - Insert an element to a sequence type column using OID
    • cubrid_seq_put - Update the element value of sequence type column using OID
    • cubrid_set_add - Insert a single element to set type column using OID
    • cubrid_set_autocommit - Set autocommit mode of the connection
    • cubrid_set_db_parameter - Sets the CUBRID database parameters
    • cubrid_set_drop - Delete an element from set type column using OID
    • cubrid_set_query_timeout - Set the timeout time of query execution
    • cubrid_unbuffered_query - Perform a query without fetching the results into memory
    • cubrid_version - Get the CUBRID PHP module's version
    • CURL context options - CURL 上下文选项列表
    • CURLFile::getFilename - 获取被上传文件的 文件名
    • CURLFile::getMimeType - 获取被上传文件的 MIME 类型
    • CURLFile::getPostFilename - 获取 POST 请求时使用的 文件名
    • CURLFile::setMimeType - 设置被上传文件的 MIME 类型
    • CURLFile::setPostFilename - 设置 POST 请求时使用的文件名
    • CURLFile::__construct - 创建 CURLFile 对象
    • curl_close - 关闭 cURL 会话
    • curl_copy_handle - 复制一个cURL句柄和它的所有选项
    • curl_errno - 返回最后一次的错误代码
    • curl_error - 返回当前会话最后一次错误的字符串
    • curl_escape - 使用 URL 编码给定的字符串
    • curl_exec - 执行 cURL 会话
    • curl_getinfo - 获取一个cURL连接资源句柄的信息
    • curl_init - 初始化 cURL 会话
    • curl_multi_add_handle - 向curl批处理会话中添加单独的curl句柄
    • curl_multi_close - 关闭一组cURL句柄
    • curl_multi_errno - 返回上一次 curl 批处理的错误码
    • curl_multi_exec - 运行当前 cURL 句柄的子连接
    • curl_multi_getcontent - 如果设置了CURLOPT_RETURNTRANSFER，则返回获取的输出的文本流
    • curl_multi_info_read - 获取当前解析的cURL的相关传输信息
    • curl_multi_init - 返回一个新cURL批处理句柄
    • curl_multi_remove_handle - 移除cURL批处理句柄资源中的某个句柄资源
    • curl_multi_select - 等待所有cURL批处理中的活动连接
    • curl_multi_setopt - 为 cURL 并行处理设置一个选项
    • curl_multi_strerror - 返回字符串描述的错误代码
    • curl_pause - 暂停和取消暂停一个连接。
    • curl_reset - 重置一个 libcurl 会话句柄的所有的选项
    • curl_setopt - 设置 cURL 传输选项
    • curl_setopt_array - 为 cURL 传输会话批量设置选项
    • curl_share_close - 关闭 cURL 共享句柄
    • curl_share_errno - 返回共享 curl 句柄的最后一次错误号
    • curl_share_init - 初始化一个 cURL 共享句柄。
    • curl_share_setopt - 为 cURL 共享句柄设置选项。
    • curl_share_strerror - 返回错误号对应的错误消息
    • curl_strerror - 返回错误代码的字符串描述
    • curl_unescape - 解码给定的 URL 编码的字符串
    • curl_version - 获取 cURL 版本信息
    • current - 返回数组中的当前值
  • d
    • data:// - 数据（RFC 2397）
    • DatabaseObject::existsInDatabase - Check if object exists in database
    • DatabaseObject::getName - Get object name
    • DatabaseObject::getSession - Get session name
    • date - 格式化一个本地时间／日期
    • DateInterval::createFromDateString - Sets up a DateInterval from the relative parts of the string
    • DateInterval::format - Formats the interval
    • DateInterval::__construct - Creates a new DateInterval object
    • DatePeriod::getDateInterval - Gets the interval
    • DatePeriod::getEndDate - Gets the end date
    • DatePeriod::getRecurrences - Gets the number of recurrences
    • DatePeriod::getStartDate - Gets the start date
    • DatePeriod::__construct - Creates a new DatePeriod object
    • DateTime::add - 给一个 DateTime 对象增加一定量的天，月，年，小时，分钟 以及秒。
    • DateTime::createFromFormat - 根据给定的格式解析日期时间字符串
    • DateTime::createFromImmutable - Returns new DateTime object encapsulating the given DateTimeImmutable object
    • DateTime::createFromInterface - Returns new DateTime object encapsulating the given DateTimeInterface object
    • DateTime::diff - Returns the difference between two DateTime objects
    • DateTime::format - Returns date formatted according to given format
    • DateTime::getLastErrors - 获取警告和错误信息
    • DateTime::getOffset - Returns the timezone offset
    • DateTime::getTimestamp - Gets the Unix timestamp
    • DateTime::getTimezone - Return time zone relative to given DateTime
    • DateTime::modify - 修改日期时间对象的值
    • DateTime::setDate - 设置 DateTime 对象的日期
    • DateTime::setISODate - 设置 ISO 日期
    • DateTime::setTime - 设置 DateTime 对象的时间
    • DateTime::setTimestamp - 以 Unix 时间戳的方式设置 DateTime 对象
    • DateTime::setTimezone - 设置 DateTime 对象的时区
    • DateTime::sub - 对一个 DateTime 对象减去一定量的 日、月、年、小时、分钟和秒。
    • DateTime::__construct - 返回一个新的 DateTime 对象
    • DateTime::__set_state - __set_state 魔术方法处理函数
    • DateTime::__wakeup - The __wakeup handler
    • DateTimeImmutable::add - Adds an amount of days, months, years, hours, minutes and seconds
    • DateTimeImmutable::createFromFormat - Parses a time string according to a specified format
    • DateTimeImmutable::createFromInterface - Returns new DateTimeImmutable object encapsulating the given DateTimeInterface object
    • DateTimeImmutable::createFromMutable - Returns new DateTimeImmutable object encapsulating the given DateTime object
    • DateTimeImmutable::getLastErrors - Returns the warnings and errors
    • DateTimeImmutable::modify - Creates a new object with modified timestamp
    • DateTimeImmutable::setDate - Sets the date
    • DateTimeImmutable::setISODate - Sets the ISO date
    • DateTimeImmutable::setTime - Sets the time
    • DateTimeImmutable::setTimestamp - Sets the date and time based on a Unix timestamp
    • DateTimeImmutable::setTimezone - Sets the time zone
    • DateTimeImmutable::sub - Subtracts an amount of days, months, years, hours, minutes and seconds
    • DateTimeImmutable::__construct - Returns new DateTimeImmutable object
    • DateTimeImmutable::__set_state - The __set_state handler
    • DateTimeZone::getLocation - 返回与时区相关的定位信息。
    • DateTimeZone::getName - 返回时区名称。
    • DateTimeZone::getOffset - 返回相对于 GMT 的时差。
    • DateTimeZone::getTransitions - Returns all transitions for the timezone
    • DateTimeZone::listAbbreviations - 返回一个包含 dst (夏令时)，时差和时区信息的关联数组。
    • DateTimeZone::listIdentifiers - 返回一个包含了所有时区标示符的索引数组。
    • DateTimeZone::__construct - 创建新的DateTimeZone对象
    • date_add - 别名 DateTime::add
    • date_create - 别名 DateTime::__construct
    • date_create_from_format - 别名 DateTime::createFromFormat
    • date_create_immutable - 别名 DateTimeImmutable::__construct
    • date_create_immutable_from_format - 别名 DateTimeImmutable::createFromFormat
    • date_date_set - 别名 DateTime::setDate
    • date_default_timezone_get - 取得一个脚本中所有日期时间函数所使用的默认时区
    • date_default_timezone_set - 设定用于一个脚本中所有日期时间函数的默认时区
    • date_diff - 别名 DateTime::diff
    • date_format - 别名 DateTime::format
    • date_get_last_errors - 别名 DateTime::getLastErrors
    • date_interval_create_from_date_string - 别名 DateInterval::createFromDateString
    • date_interval_format - 别名 DateInterval::format
    • date_isodate_set - 别名 DateTime::setISODate
    • date_modify - 别名 DateTime::modify
    • date_offset_get - 别名 DateTime::getOffset
    • date_parse - 返回指定日期/时间的详细信息的关联数组
    • date_parse_from_format - Get info about given date formatted according to the specified format
    • date_sub - 别名 DateTime::sub
    • date_sunrise - 返回给定的日期与地点的日出时间
    • date_sunset - 返回给定的日期与地点的日落时间
    • date_sun_info - Returns an array with information about sunset/sunrise and twilight begin/end
    • date_timestamp_get - 别名 DateTime::getTimestamp
    • date_timestamp_set - 别名 DateTime::setTimestamp
    • date_timezone_get - 别名 DateTime::getTimezone
    • date_timezone_set - 别名 DateTime::setTimezone
    • date_time_set - 别名 DateTime::setTime
    • db2_autocommit - Returns or sets the AUTOCOMMIT state for a database connection
    • db2_bind_param - Binds a PHP variable to an SQL statement parameter
    • db2_client_info - Returns an object with properties that describe the DB2 database client
    • db2_close - Closes a database connection
    • db2_columns - Returns a result set listing the columns and associated metadata for a table
    • db2_column_privileges - Returns a result set listing the columns and associated privileges for a table
    • db2_commit - Commits a transaction
    • db2_connect - Returns a connection to a database
    • db2_conn_error - Returns a string containing the SQLSTATE returned by the last connection attempt
    • db2_conn_errormsg - Returns the last connection error message and SQLCODE value
    • db2_cursor_type - Returns the cursor type used by a statement resource
    • db2_escape_string - Used to escape certain characters
    • db2_exec - Executes an SQL statement directly
    • db2_execute - Executes a prepared SQL statement
    • db2_fetch_array - Returns an array, indexed by column position, representing a row in a result set
    • db2_fetch_assoc - Returns an array, indexed by column name, representing a row in a result set
    • db2_fetch_both - Returns an array, indexed by both column name and position, representing a row in a result set
    • db2_fetch_object - Returns an object with properties representing columns in the fetched row
    • db2_fetch_row - Sets the result set pointer to the next row or requested row
    • db2_field_display_size - Returns the maximum number of bytes required to display a column
    • db2_field_name - Returns the name of the column in the result set
    • db2_field_num - Returns the position of the named column in a result set
    • db2_field_precision - Returns the precision of the indicated column in a result set
    • db2_field_scale - Returns the scale of the indicated column in a result set
    • db2_field_type - Returns the data type of the indicated column in a result set
    • db2_field_width - Returns the width of the current value of the indicated column in a result set
    • db2_foreign_keys - Returns a result set listing the foreign keys for a table
    • db2_free_result - Frees resources associated with a result set
    • db2_free_stmt - Frees resources associated with the indicated statement resource
    • db2_get_option - Retrieves an option value for a statement resource or a connection resource
    • db2_last_insert_id - Returns the auto generated ID of the last insert query that successfully executed on this connection
    • db2_lob_read - Gets a user defined size of LOB files with each invocation
    • db2_next_result - Requests the next result set from a stored procedure
    • db2_num_fields - Returns the number of fields contained in a result set
    • db2_num_rows - Returns the number of rows affected by an SQL statement
    • db2_pclose - Closes a persistent database connection
    • db2_pconnect - Returns a persistent connection to a database
    • db2_prepare - Prepares an SQL statement to be executed
    • db2_primary_keys - Returns a result set listing primary keys for a table
    • db2_procedures - Returns a result set listing the stored procedures registered in a database
    • db2_procedure_columns - Returns a result set listing stored procedure parameters
    • db2_result - Returns a single column from a row in the result set
    • db2_rollback - Rolls back a transaction
    • db2_server_info - Returns an object with properties that describe the DB2 database server
    • db2_set_option - Set options for connection or statement resources
    • db2_special_columns - Returns a result set listing the unique row identifier columns for a table
    • db2_statistics - Returns a result set listing the index and statistics for a table
    • db2_stmt_error - Returns a string containing the SQLSTATE returned by an SQL statement
    • db2_stmt_errormsg - Returns a string containing the last SQL statement error message
    • db2_tables - Returns a result set listing the tables and associated metadata in a database
    • db2_table_privileges - Returns a result set listing the tables and associated privileges in a database
    • dbase_add_record - Adds a record to a database
    • dbase_close - Closes a database
    • dbase_create - Creates a database
    • dbase_delete_record - Deletes a record from a database
    • dbase_get_header_info - Gets the header info of a database
    • dbase_get_record - Gets a record from a database as an indexed array
    • dbase_get_record_with_names - Gets a record from a database as an associative array
    • dbase_numfields - Gets the number of fields of a database
    • dbase_numrecords - Gets the number of records in a database
    • dbase_open - Opens a database
    • dbase_pack - Packs a database
    • dbase_replace_record - Replaces a record in a database
    • dba_close - Close a DBA database
    • dba_delete - Delete DBA entry specified by key
    • dba_exists - Check whether key exists
    • dba_fetch - Fetch data specified by key
    • dba_firstkey - Fetch first key
    • dba_handlers - List all the handlers available
    • dba_insert - Insert entry
    • dba_key_split - Splits a key in string representation into array representation
    • dba_list - List all open database files
    • dba_nextkey - Fetch next key
    • dba_open - Open database
    • dba_optimize - Optimize database
    • dba_popen - Open database persistently
    • dba_replace - Replace or insert entry
    • dba_sync - Synchronize database
    • dbplus_add - Add a tuple to a relation
    • dbplus_aql - Perform AQL query
    • dbplus_chdir - Get/Set database virtual current directory
    • dbplus_close - Close a relation
    • dbplus_curr - Get current tuple from relation
    • dbplus_errcode - Get error string for given errorcode or last error
    • dbplus_errno - Get error code for last operation
    • dbplus_find - Set a constraint on a relation
    • dbplus_first - Get first tuple from relation
    • dbplus_flush - Flush all changes made on a relation
    • dbplus_freealllocks - Free all locks held by this client
    • dbplus_freelock - Release write lock on tuple
    • dbplus_freerlocks - Free all tuple locks on given relation
    • dbplus_getlock - Get a write lock on a tuple
    • dbplus_getunique - Get an id number unique to a relation
    • dbplus_info - Get information about a relation
    • dbplus_last - Get last tuple from relation
    • dbplus_lockrel - Request write lock on relation
    • dbplus_next - Get next tuple from relation
    • dbplus_open - Open relation file
    • dbplus_prev - Get previous tuple from relation
    • dbplus_rchperm - Change relation permissions
    • dbplus_rcreate - Creates a new DB++ relation
    • dbplus_rcrtexact - Creates an exact but empty copy of a relation including indices
    • dbplus_rcrtlike - Creates an empty copy of a relation with default indices
    • dbplus_resolve - Resolve host information for relation
    • dbplus_restorepos - Restore position
    • dbplus_rkeys - Specify new primary key for a relation
    • dbplus_ropen - Open relation file local
    • dbplus_rquery - Perform local (raw) AQL query
    • dbplus_rrename - Rename a relation
    • dbplus_rsecindex - Create a new secondary index for a relation
    • dbplus_runlink - Remove relation from filesystem
    • dbplus_rzap - Remove all tuples from relation
    • dbplus_savepos - Save position
    • dbplus_setindex - Set index
    • dbplus_setindexbynumber - Set index by number
    • dbplus_sql - Perform SQL query
    • dbplus_tcl - Execute TCL code on server side
    • dbplus_tremove - Remove tuple and return new current tuple
    • dbplus_undo - Undo
    • dbplus_undoprepare - Prepare undo
    • dbplus_unlockrel - Give up write lock on relation
    • dbplus_unselect - Remove a constraint from relation
    • dbplus_update - Update specified tuple in relation
    • dbplus_xlockrel - Request exclusive lock on relation
    • dbplus_xunlockrel - Free exclusive lock on relation
    • dcgettext - Overrides the domain for a single lookup
    • dcngettext - Plural version of dcgettext
    • debug_backtrace - 产生一条回溯跟踪(backtrace)
    • debug_print_backtrace - 打印一条回溯。
    • debug_zval_dump - Dumps a string representation of an internal zend value to output
    • decbin - 十进制转换为二进制
    • dechex - 十进制转换为十六进制
    • decoct - 十进制转换为八进制
    • define - 定义一个常量
    • defined - 检查某个名称的常量是否存在
    • deflate_add - Incrementally deflate data
    • deflate_init - Initialize an incremental deflate context
    • deg2rad - 将角度转换为弧度
    • delete - 参见 unlink 或 unset
    • dgettext - Override the current domain
    • die - 等同于 exit
    • dio_close - Closes the file descriptor given by fd
    • dio_fcntl - Performs a c library fcntl on fd
    • dio_open - Opens a file (creating it if necessary) at a lower level than the C library input/ouput stream functions allow
    • dio_read - Reads bytes from a file descriptor
    • dio_seek - Seeks to pos on fd from whence
    • dio_stat - Gets stat information about the file descriptor fd
    • dio_tcsetattr - Sets terminal attributes and baud rate for a serial port
    • dio_truncate - Truncates file descriptor fd to offset bytes
    • dio_write - Writes data to fd with optional truncation at length
    • dir - 返回一个 Directory 类实例
    • Directory::close - 释放目录句柄
    • Directory::read - 从目录句柄中读取条目
    • Directory::rewind - 倒回目录句柄
    • DirectoryIterator::current - Return the current DirectoryIterator item
    • DirectoryIterator::getATime - Get last access time of the current DirectoryIterator item
    • DirectoryIterator::getBasename - Get base name of current DirectoryIterator item
    • DirectoryIterator::getCTime - Get inode change time of the current DirectoryIterator item
    • DirectoryIterator::getExtension - Gets the file extension
    • DirectoryIterator::getFilename - Return file name of current DirectoryIterator item
    • DirectoryIterator::getGroup - Get group for the current DirectoryIterator item
    • DirectoryIterator::getInode - Get inode for the current DirectoryIterator item
    • DirectoryIterator::getMTime - Get last modification time of current DirectoryIterator item
    • DirectoryIterator::getOwner - Get owner of current DirectoryIterator item
    • DirectoryIterator::getPath - Get path of current Iterator item without filename
    • DirectoryIterator::getPathname - Return path and file name of current DirectoryIterator item
    • DirectoryIterator::getPerms - Get the permissions of current DirectoryIterator item
    • DirectoryIterator::getSize - Get size of current DirectoryIterator item
    • DirectoryIterator::getType - Determine the type of the current DirectoryIterator item
    • DirectoryIterator::isDir - Determine if current DirectoryIterator item is a directory
    • DirectoryIterator::isDot - Determine if current DirectoryIterator item is '.' or '..'
    • DirectoryIterator::isExecutable - Determine if current DirectoryIterator item is executable
    • DirectoryIterator::isFile - Determine if current DirectoryIterator item is a regular file
    • DirectoryIterator::isLink - Determine if current DirectoryIterator item is a symbolic link
    • DirectoryIterator::isReadable - Determine if current DirectoryIterator item can be read
    • DirectoryIterator::isWritable - Determine if current DirectoryIterator item can be written to
    • DirectoryIterator::key - Return the key for the current DirectoryIterator item
    • DirectoryIterator::next - Move forward to next DirectoryIterator item
    • DirectoryIterator::rewind - Rewind the DirectoryIterator back to the start
    • DirectoryIterator::seek - Seek to a DirectoryIterator item
    • DirectoryIterator::valid - Check whether current DirectoryIterator position is a valid file
    • DirectoryIterator::__construct - Constructs a new directory iterator from a path
    • DirectoryIterator::__toString - Get file name as a string
    • dirname - 返回路径中的目录部分
    • diskfreespace - disk_free_space 的别名
    • disk_free_space - 返回目录中的可用空间
    • disk_total_space - 返回一个目录的磁盘总大小
    • dl - 运行时载入一个 PHP 扩展
    • dngettext - Plural version of dgettext
    • dns_check_record - 别名 checkdnsrr
    • dns_get_mx - 别名 getmxrr
    • dns_get_record - 获取指定主机的DNS记录
    • DocResult::fetchAll - Get all rows
    • DocResult::fetchOne - Get one row
    • DocResult::getWarnings - Get warnings from last operation
    • DocResult::getWarningsCount - Get warning count from last operation
    • DocResult::__construct - DocResult constructor
    • DOMAttr::isId - Checks if attribute is a defined ID
    • DOMAttr::__construct - Creates a new DOMAttr object
    • DOMCdataSection::__construct - Constructs a new DOMCdataSection object
    • DOMCharacterData::appendData - Append the string to the end of the character data of the node
    • DOMCharacterData::deleteData - Remove a range of characters from the node
    • DOMCharacterData::insertData - Insert a string at the specified 16-bit unit offset
    • DOMCharacterData::replaceData - Replace a substring within the DOMCharacterData node
    • DOMCharacterData::substringData - Extracts a range of data from the node
    • DOMComment::__construct - Creates a new DOMComment object
    • DOMDocument::createAttribute - Create new attribute
    • DOMDocument::createAttributeNS - Create new attribute node with an associated namespace
    • DOMDocument::createCDATASection - Create new cdata node
    • DOMDocument::createComment - Create new comment node
    • DOMDocument::createDocumentFragment - Create new document fragment
    • DOMDocument::createElement - Create new element node
    • DOMDocument::createElementNS - Create new element node with an associated namespace
    • DOMDocument::createEntityReference - Create new entity reference node
    • DOMDocument::createProcessingInstruction - Creates new PI node
    • DOMDocument::createTextNode - Create new text node
    • DOMDocument::getElementById - Searches for an element with a certain id
    • DOMDocument::getElementsByTagName - Searches for all elements with given local tag name
    • DOMDocument::getElementsByTagNameNS - Searches for all elements with given tag name in specified namespace
    • DOMDocument::importNode - Import node into current document
    • DOMDocument::load - Load XML from a file
    • DOMDocument::loadHTML - Load HTML from a string
    • DOMDocument::loadHTMLFile - Load HTML from a file
    • DOMDocument::loadXML - Load XML from a string
    • DOMDocument::normalizeDocument - Normalizes the document
    • DOMDocument::registerNodeClass - Register extended class used to create base node type
    • DOMDocument::relaxNGValidate - Performs relaxNG validation on the document
    • DOMDocument::relaxNGValidateSource - Performs relaxNG validation on the document
    • DOMDocument::save - Dumps the internal XML tree back into a file
    • DOMDocument::saveHTML - Dumps the internal document into a string using HTML formatting
    • DOMDocument::saveHTMLFile - Dumps the internal document into a file using HTML formatting
    • DOMDocument::saveXML - Dumps the internal XML tree back into a string
    • DOMDocument::schemaValidate - Validates a document based on a schema. Only XML Schema 1.0 is supported.
    • DOMDocument::schemaValidateSource - Validates a document based on a schema
    • DOMDocument::validate - Validates the document based on its DTD
    • DOMDocument::xinclude - Substitutes XIncludes in a DOMDocument Object
    • DOMDocument::__construct - Creates a new DOMDocument object
    • DOMDocumentFragment::appendXML - Append raw XML data
    • DOMElement::getAttribute - Returns value of attribute
    • DOMElement::getAttributeNode - Returns attribute node
    • DOMElement::getAttributeNodeNS - Returns attribute node
    • DOMElement::getAttributeNS - Returns value of attribute
    • DOMElement::getElementsByTagName - Gets elements by tagname
    • DOMElement::getElementsByTagNameNS - Get elements by namespaceURI and localName
    • DOMElement::hasAttribute - Checks to see if attribute exists
    • DOMElement::hasAttributeNS - Checks to see if attribute exists
    • DOMElement::removeAttribute - Removes attribute
    • DOMElement::removeAttributeNode - Removes attribute
    • DOMElement::removeAttributeNS - Removes attribute
    • DOMElement::setAttribute - Adds new attribute
    • DOMElement::setAttributeNode - Adds new attribute node to element
    • DOMElement::setAttributeNodeNS - Adds new attribute node to element
    • DOMElement::setAttributeNS - Adds new attribute
    • DOMElement::setIdAttribute - Declares the attribute specified by name to be of type ID
    • DOMElement::setIdAttributeNode - Declares the attribute specified by node to be of type ID
    • DOMElement::setIdAttributeNS - Declares the attribute specified by local name and namespace URI to be of type ID
    • DOMElement::__construct - Creates a new DOMElement object
    • DOMEntityReference::__construct - Creates a new DOMEntityReference object
    • DOMImplementation::createDocument - Creates a DOMDocument object of the specified type with its document element
    • DOMImplementation::createDocumentType - Creates an empty DOMDocumentType object
    • DOMImplementation::hasFeature - Test if the DOM implementation implements a specific feature
    • DOMImplementation::__construct - Creates a new DOMImplementation object
    • DOMNamedNodeMap::count - Get number of nodes in the map
    • DOMNamedNodeMap::getNamedItem - Retrieves a node specified by name
    • DOMNamedNodeMap::getNamedItemNS - Retrieves a node specified by local name and namespace URI
    • DOMNamedNodeMap::item - Retrieves a node specified by index
    • DOMNode::appendChild - Adds new child at the end of the children
    • DOMNode::C14N - Canonicalize nodes to a string
    • DOMNode::C14NFile - Canonicalize nodes to a file
    • DOMNode::cloneNode - Clones a node
    • DOMNode::getLineNo - Get line number for a node
    • DOMNode::getNodePath - Get an XPath for a node
    • DOMNode::hasAttributes - Checks if node has attributes
    • DOMNode::hasChildNodes - Checks if node has children
    • DOMNode::insertBefore - Adds a new child before a reference node
    • DOMNode::isDefaultNamespace - Checks if the specified namespaceURI is the default namespace or not
    • DOMNode::isSameNode - Indicates if two nodes are the same node
    • DOMNode::isSupported - Checks if feature is supported for specified version
    • DOMNode::lookupNamespaceUri - Gets the namespace URI of the node based on the prefix
    • DOMNode::lookupPrefix - Gets the namespace prefix of the node based on the namespace URI
    • DOMNode::normalize - Normalizes the node
    • DOMNode::removeChild - Removes child from list of children
    • DOMNode::replaceChild - Replaces a child
    • DOMNodeList::count - Get number of nodes in the list
    • DOMNodeList::item - Retrieves a node specified by index
    • DOMProcessingInstruction::__construct - Creates a new DOMProcessingInstruction object
    • DOMText::isElementContentWhitespace - Returns whether this text node contains whitespace in element content
    • DOMText::isWhitespaceInElementContent - Indicates whether this text node contains whitespace
    • DOMText::splitText - Breaks this node into two nodes at the specified offset
    • DOMText::__construct - Creates a new DOMText object
    • DOMXPath::evaluate - Evaluates the given XPath expression and returns a typed result if possible
    • DOMXPath::query - Evaluates the given XPath expression
    • DOMXPath::registerNamespace - Registers the namespace with the DOMXPath object
    • DOMXPath::registerPhpFunctions - Register PHP functions as XPath functions
    • DOMXPath::__construct - Creates a new DOMXPath object
    • dom_import_simplexml - Gets a DOMElement object from a SimpleXMLElement object
    • dotnet::__construct - dotnet class constructor
    • doubleval - floatval 的别名
    • Ds\Collection::clear - Removes all values
    • Ds\Collection::copy - Returns a shallow copy of the collection
    • Ds\Collection::isEmpty - Returns whether the collection is empty
    • Ds\Collection::toArray - Converts the collection to an array
    • Ds\Deque::allocate - Allocates enough memory for a required capacity
    • Ds\Deque::apply - Updates all values by applying a callback function to each value
    • Ds\Deque::capacity - Returns the current capacity
    • Ds\Deque::clear - Removes all values from the deque
    • Ds\Deque::contains - Determines if the deque contains given values
    • Ds\Deque::copy - Returns a shallow copy of the deque
    • Ds\Deque::count - Returns the number of values in the collection
    • Ds\Deque::filter - Creates a new deque using a callable to determine which values to include
    • Ds\Deque::find - Attempts to find a value's index
    • Ds\Deque::first - Returns the first value in the deque
    • Ds\Deque::get - Returns the value at a given index
    • Ds\Deque::insert - Inserts values at a given index
    • Ds\Deque::isEmpty - Returns whether the deque is empty
    • Ds\Deque::join - Joins all values together as a string
    • Ds\Deque::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Deque::last - Returns the last value
    • Ds\Deque::map - Returns the result of applying a callback to each value
    • Ds\Deque::merge - Returns the result of adding all given values to the deque
    • Ds\Deque::pop - Removes and returns the last value
    • Ds\Deque::push - Adds values to the end of the deque
    • Ds\Deque::reduce - Reduces the deque to a single value using a callback function
    • Ds\Deque::remove - Removes and returns a value by index
    • Ds\Deque::reverse - Reverses the deque in-place
    • Ds\Deque::reversed - Returns a reversed copy
    • Ds\Deque::rotate - Rotates the deque by a given number of rotations
    • Ds\Deque::set - Updates a value at a given index
    • Ds\Deque::shift - Removes and returns the first value
    • Ds\Deque::slice - Returns a sub-deque of a given range
    • Ds\Deque::sort - Sorts the deque in-place
    • Ds\Deque::sorted - Returns a sorted copy
    • Ds\Deque::sum - Returns the sum of all values in the deque
    • Ds\Deque::toArray - Converts the deque to an array
    • Ds\Deque::unshift - Adds values to the front of the deque
    • Ds\Deque::__construct - Creates a new instance
    • Ds\Hashable::equals - Determines whether an object is equal to the current instance
    • Ds\Hashable::hash - Returns a scalar value to be used as a hash value
    • Ds\Map::allocate - Allocates enough memory for a required capacity
    • Ds\Map::apply - Updates all values by applying a callback function to each value
    • Ds\Map::capacity - Returns the current capacity
    • Ds\Map::clear - Removes all values
    • Ds\Map::copy - Returns a shallow copy of the map
    • Ds\Map::count - Returns the number of values in the map
    • Ds\Map::diff - Creates a new map using keys that aren't in another map
    • Ds\Map::filter - Creates a new map using a callable to determine which pairs to include
    • Ds\Map::first - Returns the first pair in the map
    • Ds\Map::get - Returns the value for a given key
    • Ds\Map::hasKey - Determines whether the map contains a given key
    • Ds\Map::hasValue - Determines whether the map contains a given value
    • Ds\Map::intersect - Creates a new map by intersecting keys with another map
    • Ds\Map::isEmpty - Returns whether the map is empty
    • Ds\Map::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Map::keys - Returns a set of the map's keys
    • Ds\Map::ksort - Sorts the map in-place by key
    • Ds\Map::ksorted - Returns a copy, sorted by key
    • Ds\Map::last - Returns the last pair of the map
    • Ds\Map::map - Returns the result of applying a callback to each value
    • Ds\Map::merge - Returns the result of adding all given associations
    • Ds\Map::pairs - Returns a sequence containing all the pairs of the map
    • Ds\Map::put - Associates a key with a value
    • Ds\Map::putAll - Associates all key-value pairs of a traversable object or array
    • Ds\Map::reduce - Reduces the map to a single value using a callback function
    • Ds\Map::remove - Removes and returns a value by key
    • Ds\Map::reverse - Reverses the map in-place
    • Ds\Map::reversed - Returns a reversed copy
    • Ds\Map::skip - Returns the pair at a given positional index
    • Ds\Map::slice - Returns a subset of the map defined by a starting index and length
    • Ds\Map::sort - Sorts the map in-place by value
    • Ds\Map::sorted - Returns a copy, sorted by value
    • Ds\Map::sum - Returns the sum of all values in the map
    • Ds\Map::toArray - Converts the map to an array
    • Ds\Map::union - Creates a new map using values from the current instance and another map
    • Ds\Map::values - Returns a sequence of the map's values
    • Ds\Map::xor - Creates a new map using keys of either the current instance or of another map, but not of both
    • Ds\Map::__construct - Creates a new instance
    • Ds\Pair::clear - Removes all values
    • Ds\Pair::copy - Returns a shallow copy of the pair
    • Ds\Pair::isEmpty - Returns whether the pair is empty
    • Ds\Pair::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Pair::toArray - Converts the pair to an array
    • Ds\Pair::__construct - Creates a new instance
    • Ds\PriorityQueue::allocate - Allocates enough memory for a required capacity
    • Ds\PriorityQueue::capacity - Returns the current capacity
    • Ds\PriorityQueue::clear - Removes all values
    • Ds\PriorityQueue::copy - Returns a shallow copy of the queue
    • Ds\PriorityQueue::count - Returns the number of values in the queue
    • Ds\PriorityQueue::isEmpty - Returns whether the queue is empty
    • Ds\PriorityQueue::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\PriorityQueue::peek - Returns the value at the front of the queue
    • Ds\PriorityQueue::pop - Removes and returns the value with the highest priority
    • Ds\PriorityQueue::push - Pushes values into the queue
    • Ds\PriorityQueue::toArray - Converts the queue to an array
    • Ds\PriorityQueue::__construct - Creates a new instance
    • Ds\Queue::allocate - Allocates enough memory for a required capacity
    • Ds\Queue::capacity - Returns the current capacity
    • Ds\Queue::clear - Removes all values
    • Ds\Queue::copy - Returns a shallow copy of the queue
    • Ds\Queue::count - Returns the number of values in the queue
    • Ds\Queue::isEmpty - Returns whether the queue is empty
    • Ds\Queue::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Queue::peek - Returns the value at the front of the queue
    • Ds\Queue::pop - Removes and returns the value at the front of the queue
    • Ds\Queue::push - Pushes values into the queue
    • Ds\Queue::toArray - Converts the queue to an array
    • Ds\Queue::__construct - Creates a new instance
    • Ds\Sequence::allocate - Allocates enough memory for a required capacity
    • Ds\Sequence::apply - Updates all values by applying a callback function to each value
    • Ds\Sequence::capacity - Returns the current capacity
    • Ds\Sequence::contains - Determines if the sequence contains given values
    • Ds\Sequence::filter - Creates a new sequence using a callable to determine which values to include
    • Ds\Sequence::find - Attempts to find a value's index
    • Ds\Sequence::first - Returns the first value in the sequence
    • Ds\Sequence::get - Returns the value at a given index
    • Ds\Sequence::insert - Inserts values at a given index
    • Ds\Sequence::join - Joins all values together as a string
    • Ds\Sequence::last - Returns the last value
    • Ds\Sequence::map - Returns the result of applying a callback to each value
    • Ds\Sequence::merge - Returns the result of adding all given values to the sequence
    • Ds\Sequence::pop - Removes and returns the last value
    • Ds\Sequence::push - Adds values to the end of the sequence
    • Ds\Sequence::reduce - Reduces the sequence to a single value using a callback function
    • Ds\Sequence::remove - Removes and returns a value by index
    • Ds\Sequence::reverse - Reverses the sequence in-place
    • Ds\Sequence::reversed - Returns a reversed copy
    • Ds\Sequence::rotate - Rotates the sequence by a given number of rotations
    • Ds\Sequence::set - Updates a value at a given index
    • Ds\Sequence::shift - Removes and returns the first value
    • Ds\Sequence::slice - Returns a sub-sequence of a given range
    • Ds\Sequence::sort - Sorts the sequence in-place
    • Ds\Sequence::sorted - Returns a sorted copy
    • Ds\Sequence::sum - Returns the sum of all values in the sequence
    • Ds\Sequence::unshift - Adds values to the front of the sequence
    • Ds\Set::add - Adds values to the set
    • Ds\Set::allocate - Allocates enough memory for a required capacity
    • Ds\Set::capacity - Returns the current capacity
    • Ds\Set::clear - Removes all values
    • Ds\Set::contains - Determines if the set contains all values
    • Ds\Set::copy - Returns a shallow copy of the set
    • Ds\Set::count - Returns the number of values in the set
    • Ds\Set::diff - Creates a new set using values that aren't in another set
    • Ds\Set::filter - Creates a new set using a callable to determine which values to include
    • Ds\Set::first - Returns the first value in the set
    • Ds\Set::get - Returns the value at a given index
    • Ds\Set::intersect - Creates a new set by intersecting values with another set
    • Ds\Set::isEmpty - Returns whether the set is empty
    • Ds\Set::join - Joins all values together as a string
    • Ds\Set::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Set::last - Returns the last value in the set
    • Ds\Set::merge - Returns the result of adding all given values to the set
    • Ds\Set::reduce - Reduces the set to a single value using a callback function
    • Ds\Set::remove - Removes all given values from the set
    • Ds\Set::reverse - Reverses the set in-place
    • Ds\Set::reversed - Returns a reversed copy
    • Ds\Set::slice - Returns a sub-set of a given range
    • Ds\Set::sort - Sorts the set in-place
    • Ds\Set::sorted - Returns a sorted copy
    • Ds\Set::sum - Returns the sum of all values in the set
    • Ds\Set::toArray - Converts the set to an array
    • Ds\Set::union - Creates a new set using values from the current instance and another set
    • Ds\Set::xor - Creates a new set using values in either the current instance or in another set, but not in both
    • Ds\Set::__construct - Creates a new instance
    • Ds\Stack::allocate - Allocates enough memory for a required capacity
    • Ds\Stack::capacity - Returns the current capacity
    • Ds\Stack::clear - Removes all values
    • Ds\Stack::copy - Returns a shallow copy of the stack
    • Ds\Stack::count - Returns the number of values in the stack
    • Ds\Stack::isEmpty - Returns whether the stack is empty
    • Ds\Stack::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Stack::peek - Returns the value at the top of the stack
    • Ds\Stack::pop - Removes and returns the value at the top of the stack
    • Ds\Stack::push - Pushes values onto the stack
    • Ds\Stack::toArray - Converts the stack to an array
    • Ds\Stack::__construct - Creates a new instance
    • Ds\Vector::allocate - Allocates enough memory for a required capacity
    • Ds\Vector::apply - Updates all values by applying a callback function to each value
    • Ds\Vector::capacity - Returns the current capacity
    • Ds\Vector::clear - Removes all values
    • Ds\Vector::contains - Determines if the vector contains given values
    • Ds\Vector::copy - Returns a shallow copy of the vector
    • Ds\Vector::count - Returns the number of values in the collection
    • Ds\Vector::filter - Creates a new vector using a callable to determine which values to include
    • Ds\Vector::find - Attempts to find a value's index
    • Ds\Vector::first - Returns the first value in the vector
    • Ds\Vector::get - Returns the value at a given index
    • Ds\Vector::insert - Inserts values at a given index
    • Ds\Vector::isEmpty - Returns whether the vector is empty
    • Ds\Vector::join - Joins all values together as a string
    • Ds\Vector::jsonSerialize - Returns a representation that can be converted to JSON
    • Ds\Vector::last - Returns the last value
    • Ds\Vector::map - Returns the result of applying a callback to each value
    • Ds\Vector::merge - Returns the result of adding all given values to the vector
    • Ds\Vector::pop - Removes and returns the last value
    • Ds\Vector::push - Adds values to the end of the vector
    • Ds\Vector::reduce - Reduces the vector to a single value using a callback function
    • Ds\Vector::remove - Removes and returns a value by index
    • Ds\Vector::reverse - Reverses the vector in-place
    • Ds\Vector::reversed - Returns a reversed copy
    • Ds\Vector::rotate - Rotates the vector by a given number of rotations
    • Ds\Vector::set - Updates a value at a given index
    • Ds\Vector::shift - Removes and returns the first value
    • Ds\Vector::slice - Returns a sub-vector of a given range
    • Ds\Vector::sort - Sorts the vector in-place
    • Ds\Vector::sorted - Returns a sorted copy
    • Ds\Vector::sum - Returns the sum of all values in the vector
    • Ds\Vector::toArray - Converts the vector to an array
    • Ds\Vector::unshift - Adds values to the front of the vector
    • Ds\Vector::__construct - Creates a new instance
  • e
    • each - 返回数组中当前的键／值对并将数组指针向前移动一步
    • easter_date - 得到指定年份的复活节午夜时的Unix时间戳。
    • easter_days - 得到指定年份的3月21日到复活节之间的天数
    • echo - 输出一个或多个字符串
    • eio_busy - Artificially increase load. Could be useful in tests, benchmarking
    • eio_cancel - Cancels a request
    • eio_chmod - Change file/directory permissions
    • eio_chown - Change file/directory permissions
    • eio_close - Close file
    • eio_custom - Execute custom request like any other eio_* call
    • eio_dup2 - Duplicate a file descriptor
    • eio_event_loop - Polls libeio until all requests proceeded
    • eio_fallocate - Allows the caller to directly manipulate the allocated disk space for a file
    • eio_fchmod - Change file permissions
    • eio_fchown - Change file ownership
    • eio_fdatasync - Synchronize a file's in-core state with storage device
    • eio_fstat - Get file status
    • eio_fstatvfs - Get file system statistics
    • eio_fsync - Synchronize a file's in-core state with storage device
    • eio_ftruncate - Truncate a file
    • eio_futime - Change file last access and modification times
    • eio_get_event_stream - Get stream representing a variable used in internal communications with libeio
    • eio_get_last_error - Returns string describing the last error associated with a request resource
    • eio_grp - Creates a request group
    • eio_grp_add - Adds a request to the request group
    • eio_grp_cancel - Cancels a request group
    • eio_grp_limit - Set group limit
    • eio_init - (Re-)initialize Eio
    • eio_link - Create a hardlink for file
    • eio_lstat - Get file status
    • eio_mkdir - Create directory
    • eio_mknod - Create a special or ordinary file
    • eio_nop - Does nothing, except go through the whole request cycle
    • eio_npending - Returns number of finished, but unhandled requests
    • eio_nready - Returns number of not-yet handled requests
    • eio_nreqs - Returns number of requests to be processed
    • eio_nthreads - Returns number of threads currently in use
    • eio_open - Opens a file
    • eio_poll - Can be to be called whenever there are pending requests that need finishing
    • eio_read - Read from a file descriptor at given offset
    • eio_readahead - Perform file readahead into page cache
    • eio_readdir - Reads through a whole directory
    • eio_readlink - Read value of a symbolic link
    • eio_realpath - Get the canonicalized absolute pathname
    • eio_rename - Change the name or location of a file
    • eio_rmdir - Remove a directory
    • eio_seek - Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence
    • eio_sendfile - Transfer data between file descriptors
    • eio_set_max_idle - Set maximum number of idle threads
    • eio_set_max_parallel - Set maximum parallel threads
    • eio_set_max_poll_reqs - Set maximum number of requests processed in a poll
    • eio_set_max_poll_time - Set maximum poll time
    • eio_set_min_parallel - Set minimum parallel thread number
    • eio_stat - Get file status
    • eio_statvfs - Get file system statistics
    • eio_symlink - Create a symbolic link
    • eio_sync - Commit buffer cache to disk
    • eio_syncfs - Calls Linux' syncfs syscall, if available
    • eio_sync_file_range - Sync a file segment with disk
    • eio_truncate - Truncate a file
    • eio_unlink - Delete a name and possibly the file it refers to
    • eio_utime - Change file last access and modification times
    • eio_write - Write to file
    • empty - 检查一个变量是否为空
    • EmptyIterator::current - The current() method
    • EmptyIterator::key - The key() method
    • EmptyIterator::next - The next() method
    • EmptyIterator::rewind - The rewind() method
    • EmptyIterator::valid - The valid() method
    • enchant_broker_describe - Enumerates the Enchant providers
    • enchant_broker_dict_exists - Whether a dictionary exists or not. Using non-empty tag
    • enchant_broker_free - Free the broker resource and its dictionaries
    • enchant_broker_free_dict - Free a dictionary resource
    • enchant_broker_get_dict_path - Get the directory path for a given backend
    • enchant_broker_get_error - Returns the last error of the broker
    • enchant_broker_init - Create a new broker object capable of requesting
    • enchant_broker_list_dicts - Returns a list of available dictionaries
    • enchant_broker_request_dict - Create a new dictionary using a tag
    • enchant_broker_request_pwl_dict - Creates a dictionary using a PWL file
    • enchant_broker_set_dict_path - Set the directory path for a given backend
    • enchant_broker_set_ordering - Declares a preference of dictionaries to use for the language
    • enchant_dict_add - Add a word to personal word list
    • enchant_dict_add_to_personal - 别名 enchant_dict_add
    • enchant_dict_add_to_session - Add 'word' to this spell-checking session
    • enchant_dict_check - Check whether a word is correctly spelled or not
    • enchant_dict_describe - Describes an individual dictionary
    • enchant_dict_get_error - Returns the last error of the current spelling-session
    • enchant_dict_is_added - Whether or not 'word' exists in this spelling-session
    • enchant_dict_is_in_session - 别名 enchant_dict_is_added
    • enchant_dict_quick_check - Check the word is correctly spelled and provide suggestions
    • enchant_dict_store_replacement - Add a correction for a word
    • enchant_dict_suggest - Will return a list of values if any of those pre-conditions are not met
    • end - 将数组的内部指针指向最后一个单元
    • ereg - 正则表达式匹配
    • eregi - 不区分大小写的正则表达式匹配
    • eregi_replace - 不区分大小写的正则表达式替换
    • ereg_replace - 正则表达式替换
    • Error::getCode - 获取错误代码
    • Error::getFile - 获取错误发生时的文件
    • Error::getLine - 获取错误发生时的行号
    • Error::getMessage - 获取错误信息
    • Error::getPrevious - 返回先前的 Throwable
    • Error::getTrace - 获取调用栈（stack trace）
    • Error::getTraceAsString - 获取字符串形式的调用栈（stack trace）
    • Error::__clone - 克隆 error
    • Error::__construct - 初始化 error 对象
    • Error::__toString - error 的字符串表达
    • ErrorException::getSeverity - 获取异常的严重程度
    • ErrorException::__construct - 构造一个异常（Exception）
    • error_clear_last - 清除最近一次错误
    • error_get_last - 获取最后发生的错误
    • error_log - 发送错误信息到某个地方
    • error_reporting - 设置应该报告何种 PHP 错误
    • escapeshellarg - 把字符串转码为可以在 shell 命令里使用的参数
    • escapeshellcmd - shell 元字符转义
    • Ev::backend - Returns an integer describing the backend used by libev
    • Ev::depth - Returns recursion depth
    • Ev::embeddableBackends - Returns the set of backends that are embeddable in other event loops
    • Ev::feedSignal - Feed a signal event info Ev
    • Ev::feedSignalEvent - Feed signal event into the default loop
    • Ev::iteration - Return the number of times the default event loop has polled for new events
    • Ev::now - Returns the time when the last iteration of the default event loop has started
    • Ev::nowUpdate - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress
    • Ev::recommendedBackends - Returns a bit mask of recommended backends for current platform
    • Ev::resume - Resume previously suspended default event loop
    • Ev::run - Begin checking for events and calling callbacks for the default loop
    • Ev::sleep - Block the process for the given number of seconds
    • Ev::stop - Stops the default event loop
    • Ev::supportedBackends - Returns the set of backends supported by current libev configuration
    • Ev::suspend - Suspend the default event loop
    • Ev::time - Returns the current time in fractional seconds since the epoch
    • Ev::verify - Performs internal consistency checks(for debugging)
    • eval - 把字符串作为PHP代码执行
    • EvCheck::createStopped - Create instance of a stopped EvCheck watcher
    • EvCheck::__construct - Constructs the EvCheck watcher object
    • EvChild::createStopped - Create instance of a stopped EvCheck watcher
    • EvChild::set - Configures the watcher
    • EvChild::__construct - Constructs the EvChild watcher object
    • EvEmbed::createStopped - Create stopped EvEmbed watcher object
    • EvEmbed::set - Configures the watcher
    • EvEmbed::sweep - Make a single, non-blocking sweep over the embedded loop
    • EvEmbed::__construct - Constructs the EvEmbed object
    • Event::add - Makes event pending
    • Event::addSignal - Makes signal event pending
    • Event::addTimer - Makes timer event pending
    • Event::del - Makes event non-pending
    • Event::delSignal - Makes signal event non-pending
    • Event::delTimer - Makes timer event non-pending
    • Event::free - Make event non-pending and free resources allocated for this event
    • Event::getSupportedMethods - Returns array with of the names of the methods supported in this version of Libevent
    • Event::pending - Detects whether event is pending or scheduled
    • Event::set - Re-configures event
    • Event::setPriority - Set event priority
    • Event::setTimer - Re-configures timer event
    • Event::signal - Constructs signal event object
    • Event::timer - Constructs timer event object
    • Event::__construct - Constructs Event object
    • EventBase::dispatch - Dispatch pending events
    • EventBase::exit - Stop dispatching events
    • EventBase::free - Free resources allocated for this event base
    • EventBase::getFeatures - Returns bitmask of features supported
    • EventBase::getMethod - Returns event method in use
    • EventBase::getTimeOfDayCached - Returns the current event base time
    • EventBase::gotExit - Checks if the event loop was told to exit
    • EventBase::gotStop - Checks if the event loop was told to exit
    • EventBase::loop - Dispatch pending events
    • EventBase::priorityInit - Sets number of priorities per event base
    • EventBase::reInit - Re-initialize event base(after a fork)
    • EventBase::stop - Tells event_base to stop dispatching events
    • EventBase::__construct - Constructs EventBase object
    • EventBuffer::add - Append data to the end of an event buffer
    • EventBuffer::addBuffer - Move all data from a buffer provided to the current instance of EventBuffer
    • EventBuffer::appendFrom - Moves the specified number of bytes from a source buffer to the end of the current buffer
    • EventBuffer::copyout - Copies out specified number of bytes from the front of the buffer
    • EventBuffer::drain - Removes specified number of bytes from the front of the buffer without copying it anywhere
    • EventBuffer::enableLocking - 说明
    • EventBuffer::expand - Reserves space in buffer
    • EventBuffer::freeze - Prevent calls that modify an event buffer from succeeding
    • EventBuffer::lock - Acquires a lock on buffer
    • EventBuffer::prepend - Prepend data to the front of the buffer
    • EventBuffer::prependBuffer - Moves all data from source buffer to the front of current buffer
    • EventBuffer::pullup - Linearizes data within buffer and returns it's contents as a string
    • EventBuffer::read - Read data from an evbuffer and drain the bytes read
    • EventBuffer::readFrom - Read data from a file onto the end of the buffer
    • EventBuffer::readLine - Extracts a line from the front of the buffer
    • EventBuffer::search - Scans the buffer for an occurrence of a string
    • EventBuffer::searchEol - Scans the buffer for an occurrence of an end of line
    • EventBuffer::substr - Substracts a portion of the buffer data
    • EventBuffer::unfreeze - Re-enable calls that modify an event buffer
    • EventBuffer::unlock - Releases lock acquired by EventBuffer::lock
    • EventBuffer::write - Write contents of the buffer to a file or socket
    • EventBuffer::__construct - Constructs EventBuffer object
    • EventBufferEvent::close - Closes file descriptor associated with the current buffer event
    • EventBufferEvent::connect - Connect buffer event's file descriptor to given address or UNIX socket
    • EventBufferEvent::connectHost - Connects to a hostname with optionally asyncronous DNS resolving
    • EventBufferEvent::createPair - Creates two buffer events connected to each other
    • EventBufferEvent::disable - Disable events read, write, or both on a buffer event
    • EventBufferEvent::enable - Enable events read, write, or both on a buffer event
    • EventBufferEvent::free - Free a buffer event
    • EventBufferEvent::getDnsErrorString - Returns string describing the last failed DNS lookup attempt
    • EventBufferEvent::getEnabled - Returns bitmask of events currently enabled on the buffer event
    • EventBufferEvent::getInput - Returns underlying input buffer associated with current buffer event
    • EventBufferEvent::getOutput - Returns underlying output buffer associated with current buffer event
    • EventBufferEvent::read - Read buffer's data
    • EventBufferEvent::readBuffer - Drains the entire contents of the input buffer and places them into buf
    • EventBufferEvent::setCallbacks - Assigns read, write and event(status) callbacks
    • EventBufferEvent::setPriority - Assign a priority to a bufferevent
    • EventBufferEvent::setTimeouts - Set the read and write timeout for a buffer event
    • EventBufferEvent::setWatermark - Adjusts read and/or write watermarks
    • EventBufferEvent::sslError - Returns most recent OpenSSL error reported on the buffer event
    • EventBufferEvent::sslFilter - Create a new SSL buffer event to send its data over another buffer event
    • EventBufferEvent::sslGetCipherInfo - Returns a textual description of the cipher
    • EventBufferEvent::sslGetCipherName - Returns the current cipher name of the SSL connection
    • EventBufferEvent::sslGetCipherVersion - Returns version of cipher used by current SSL connection
    • EventBufferEvent::sslGetProtocol - Returns the name of the protocol used for current SSL connection
    • EventBufferEvent::sslRenegotiate - Tells a bufferevent to begin SSL renegotiation
    • EventBufferEvent::sslSocket - Creates a new SSL buffer event to send its data over an SSL on a socket
    • EventBufferEvent::write - Adds data to a buffer event's output buffer
    • EventBufferEvent::writeBuffer - Adds contents of the entire buffer to a buffer event's output buffer
    • EventBufferEvent::__construct - Constructs EventBufferEvent object
    • EventConfig::avoidMethod - Tells libevent to avoid specific event method
    • EventConfig::requireFeatures - Enters a required event method feature that the application demands
    • EventConfig::setMaxDispatchInterval - Prevents priority inversion
    • EventConfig::__construct - Constructs EventConfig object
    • EventDnsBase::addNameserverIp - Adds a nameserver to the DNS base
    • EventDnsBase::addSearch - Adds a domain to the list of search domains
    • EventDnsBase::clearSearch - Removes all current search suffixes
    • EventDnsBase::countNameservers - Gets the number of configured nameservers
    • EventDnsBase::loadHosts - Loads a hosts file (in the same format as /etc/hosts) from hosts file
    • EventDnsBase::parseResolvConf - Scans the resolv.conf-formatted file
    • EventDnsBase::setOption - Set the value of a configuration option
    • EventDnsBase::setSearchNdots - Set the 'ndots' parameter for searches
    • EventDnsBase::__construct - Constructs EventDnsBase object
    • EventHttp::accept - Makes an HTTP server accept connections on the specified socket stream or resource
    • EventHttp::addServerAlias - Adds a server alias to the HTTP server object
    • EventHttp::bind - Binds an HTTP server on the specified address and port
    • EventHttp::removeServerAlias - Removes server alias
    • EventHttp::setAllowedMethods - Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
    • EventHttp::setCallback - Sets a callback for specified URI
    • EventHttp::setDefaultCallback - Sets default callback to handle requests that are not caught by specific callbacks
    • EventHttp::setMaxBodySize - Sets maximum request body size
    • EventHttp::setMaxHeadersSize - Sets maximum HTTP header size
    • EventHttp::setTimeout - Sets the timeout for an HTTP request
    • EventHttp::__construct - Constructs EventHttp object(the HTTP server)
    • EventHttpConnection::getBase - Returns event base associated with the connection
    • EventHttpConnection::getPeer - Gets the remote address and port associated with the connection
    • EventHttpConnection::makeRequest - Makes an HTTP request over the specified connection
    • EventHttpConnection::setCloseCallback - Set callback for connection close
    • EventHttpConnection::setLocalAddress - Sets the IP address from which HTTP connections are made
    • EventHttpConnection::setLocalPort - Sets the local port from which connections are made
    • EventHttpConnection::setMaxBodySize - Sets maximum body size for the connection
    • EventHttpConnection::setMaxHeadersSize - Sets maximum header size
    • EventHttpConnection::setRetries - Sets the retry limit for the connection
    • EventHttpConnection::setTimeout - Sets the timeout for the connection
    • EventHttpConnection::__construct - Constructs EventHttpConnection object
    • EventHttpRequest::addHeader - Adds an HTTP header to the headers of the request
    • EventHttpRequest::cancel - Cancels a pending HTTP request
    • EventHttpRequest::clearHeaders - Removes all output headers from the header list of the request
    • EventHttpRequest::closeConnection - Closes associated HTTP connection
    • EventHttpRequest::findHeader - Finds the value belonging a header
    • EventHttpRequest::free - Frees the object and removes associated events
    • EventHttpRequest::getBufferEvent - Returns EventBufferEvent object
    • EventHttpRequest::getCommand - Returns the request command(method)
    • EventHttpRequest::getConnection - Returns EventHttpConnection object
    • EventHttpRequest::getHost - Returns the request host
    • EventHttpRequest::getInputBuffer - Returns the input buffer
    • EventHttpRequest::getInputHeaders - Returns associative array of the input headers
    • EventHttpRequest::getOutputBuffer - Returns the output buffer of the request
    • EventHttpRequest::getOutputHeaders - Returns associative array of the output headers
    • EventHttpRequest::getResponseCode - Returns the response code
    • EventHttpRequest::getUri - Returns the request URI
    • EventHttpRequest::removeHeader - Removes an HTTP header from the headers of the request
    • EventHttpRequest::sendError - Send an HTML error message to the client
    • EventHttpRequest::sendReply - Send an HTML reply to the client
    • EventHttpRequest::sendReplyChunk - Send another data chunk as part of an ongoing chunked reply
    • EventHttpRequest::sendReplyEnd - Complete a chunked reply, freeing the request as appropriate
    • EventHttpRequest::sendReplyStart - Initiate a chunked reply
    • EventHttpRequest::__construct - Constructs EventHttpRequest object
    • EventListener::disable - Disables an event connect listener object
    • EventListener::enable - Enables an event connect listener object
    • EventListener::getBase - Returns event base associated with the event listener
    • EventListener::getSocketName - Retreives the current address to which the listener's socket is bound
    • EventListener::setCallback - The setCallback purpose
    • EventListener::setErrorCallback - Set event listener's error callback
    • EventListener::__construct - Creates new connection listener associated with an event base
    • EventSslContext::__construct - Constructs an OpenSSL context for use with Event classes
    • EventUtil::getLastSocketErrno - Returns the most recent socket error number
    • EventUtil::getLastSocketError - Returns the most recent socket error
    • EventUtil::getSocketFd - Returns numeric file descriptor of a socket, or stream
    • EventUtil::getSocketName - Retreives the current address to which the socket is bound
    • EventUtil::setSocketOption - Sets socket options
    • EventUtil::sslRandPoll - Generates entropy by means of OpenSSL's RAND_poll()
    • EventUtil::__construct - The abstract constructor
    • EvFork::createStopped - Creates a stopped instance of EvFork watcher class
    • EvFork::__construct - Constructs the EvFork watcher object
    • EvIdle::createStopped - Creates instance of a stopped EvIdle watcher object
    • EvIdle::__construct - Constructs the EvIdle watcher object
    • EvIo::createStopped - Create stopped EvIo watcher object
    • EvIo::set - Configures the watcher
    • EvIo::__construct - Constructs EvIo watcher object
    • EvLoop::backend - Returns an integer describing the backend used by libev
    • EvLoop::check - Creates EvCheck object associated with the current event loop instance
    • EvLoop::child - Creates EvChild object associated with the current event loop
    • EvLoop::defaultLoop - Returns or creates the default event loop
    • EvLoop::embed - Creates an instance of EvEmbed watcher associated with the current EvLoop object
    • EvLoop::fork - Creates EvFork watcher object associated with the current event loop instance
    • EvLoop::idle - Creates EvIdle watcher object associated with the current event loop instance
    • EvLoop::invokePending - Invoke all pending watchers while resetting their pending state
    • EvLoop::io - Create EvIo watcher object associated with the current event loop instance
    • EvLoop::loopFork - Must be called after a fork
    • EvLoop::now - Returns the current "event loop time"
    • EvLoop::nowUpdate - Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress
    • EvLoop::periodic - Creates EvPeriodic watcher object associated with the current event loop instance
    • EvLoop::prepare - Creates EvPrepare watcher object associated with the current event loop instance
    • EvLoop::resume - Resume previously suspended default event loop
    • EvLoop::run - Begin checking for events and calling callbacks for the loop
    • EvLoop::signal - Creates EvSignal watcher object associated with the current event loop instance
    • EvLoop::stat - Creates EvStat watcher object associated with the current event loop instance
    • EvLoop::stop - Stops the event loop
    • EvLoop::suspend - Suspend the loop
    • EvLoop::timer - Creates EvTimer watcher object associated with the current event loop instance
    • EvLoop::verify - Performs internal consistency checks(for debugging)
    • EvLoop::__construct - Constructs the event loop object
    • EvPeriodic::again - Simply stops and restarts the periodic watcher again
    • EvPeriodic::at - Returns the absolute time that this watcher is supposed to trigger next
    • EvPeriodic::createStopped - Create a stopped EvPeriodic watcher
    • EvPeriodic::set - Configures the watcher
    • EvPeriodic::__construct - Constructs EvPeriodic watcher object
    • EvPrepare::createStopped - Creates a stopped instance of EvPrepare watcher
    • EvPrepare::__construct - Constructs EvPrepare watcher object
    • EvSignal::createStopped - Create stopped EvSignal watcher object
    • EvSignal::set - Configures the watcher
    • EvSignal::__construct - Constructs EvSignal watcher object
    • EvStat::attr - Returns the values most recently detected by Ev
    • EvStat::createStopped - Create a stopped EvStat watcher object
    • EvStat::prev - Returns the previous set of values returned by EvStat::attr
    • EvStat::set - Configures the watcher
    • EvStat::stat - Initiates the stat call
    • EvStat::__construct - Constructs EvStat watcher object
    • EvTimer::again - Restarts the timer watcher
    • EvTimer::createStopped - Creates EvTimer stopped watcher object
    • EvTimer::set - Configures the watcher
    • EvTimer::__construct - Constructs an EvTimer watcher object
    • EvWatcher::clear - Clear watcher pending status
    • EvWatcher::feed - Feeds the given revents set into the event loop
    • EvWatcher::getLoop - Returns the loop responsible for the watcher
    • EvWatcher::invoke - Invokes the watcher callback with the given received events bit mask
    • EvWatcher::keepalive - Configures whether to keep the loop from returning
    • EvWatcher::setCallback - Sets new callback for the watcher
    • EvWatcher::start - Starts the watcher
    • EvWatcher::stop - Stops the watcher
    • EvWatcher::__construct - Abstract constructor of a watcher object
    • Exception::getCode - 获取异常代码
    • Exception::getFile - 创建异常时的程序文件名称
    • Exception::getLine - 获取创建的异常所在文件中的行号
    • Exception::getMessage - 获取异常消息内容
    • Exception::getPrevious - 返回异常链中的前一个异常
    • Exception::getTrace - 获取异常追踪信息
    • Exception::getTraceAsString - 获取字符串类型的异常追踪信息
    • Exception::__clone - 异常克隆
    • Exception::__construct - 异常构造函数
    • Exception::__toString - 将异常对象转换为字符串
    • exec - 执行一个外部程序
    • Executable::execute - Execute statement
    • ExecutionStatus::__construct - ExecutionStatus constructor
    • exif_imagetype - 判断一个图像的类型
    • exif_read_data - 从 JPEG 或 TIFF 文件中读取 EXIF 头信息
    • exif_tagname - 获取指定索引的头名称
    • exif_thumbnail - 取得嵌入在 TIFF 或 JPEG 图像中的缩略图
    • exit - 输出一个消息并且退出当前脚本
    • exp - 计算 e 的指数
    • expect:// - 处理交互式的流
    • expect_expectl - Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen
    • expect_popen - Execute command via Bourne shell, and open the PTY stream to the process
    • explode - 使用一个字符串分割另一个字符串
    • expm1 - 返回 exp(number) - 1，甚至当 number 的值接近零也能计算出准确结果
    • expression - Bind prepared statement variables as parameters
    • Expression::__construct - Expression constructor
    • extension_loaded - 检查一个扩展是否已经加载
    • extract - 从数组中将变量导入到当前的符号表
    • ezmlm_hash - 计算 EZMLM 所需的散列值
  • f
    • FANNConnection::getFromNeuron - 返回开始连接的神经元。
    • FANNConnection::getToNeuron - 返回终止神经元的位置。
    • FANNConnection::getWeight - 返回连接权重。
    • FANNConnection::setWeight - 设置连接权重。
    • FANNConnection::__construct - 连接构造器
    • fann_cascadetrain_on_data - 在整个数据集上训练，使用一段时间的 Cascade2 训练算法。
    • fann_cascadetrain_on_file - 读取文件并在整个数据集上训练，使用 Cascade2 训练算法训练一段时间。
    • fann_clear_scaling_params - 清除缩放参数
    • fann_copy - 创建一个 fann 结构体的副本。
    • fann_create_from_file - 从配置文件中构建一个反向传播神经网络。
    • fann_create_shortcut - 创建一个含快捷连接而非全连接的标准反向传播神经网络。
    • fann_create_shortcut_array - 创建一个含快捷连接而非全连接的标准反向传播神经网络。
    • fann_create_sparse - 创建一个标准的反向传播神经网络，该网络不是全连接。
    • fann_create_sparse_array - 创建一个标准的反向传播神经网络，该网络使用一个表示每层大小的数组来构造，但是并不是全连接的。
    • fann_create_standard - 创建标准的全连接反向传播神经网络。
    • fann_create_standard_array - 创建一个全连接的反向传播神经网络，该网络使用一个表示每层大小的数组来构造。
    • fann_create_train - 创建一个空的训练数据结构。
    • fann_create_train_from_callback - 从用户提供的函数创建训练数据结构。
    • fann_descale_input - 在获取基于先前计算的参数之后，在输入向量中缩小数据
    • fann_descale_output - 在获取基于先前计算的参数之后，在输出向量中缩小数据
    • fann_descale_train - 基于先前计算的参数来缩小输入和输出数据
    • fann_destroy - 销毁整个网络并且适当地释放所有的关联内存。
    • fann_destroy_train - 销毁训练数据。
    • fann_duplicate_train_data - 返回 fann 训练数据精确的副本。
    • fann_get_activation_function - 返回激励函数
    • fann_get_activation_steepness - 为提供的神经和网络层数返回激活陡度
    • fann_get_bias_array - 获取网络中每一层的偏差数
    • fann_get_bit_fail - 失败位的数量
    • fann_get_bit_fail_limit - 返回训练期间使用的误差限制
    • fann_get_cascade_activation_functions - 返回级联激活函数
    • fann_get_cascade_activation_functions_count - 返回级联激活函数的数量
    • fann_get_cascade_activation_steepnesses - 返回级联激活陡度
    • fann_get_cascade_activation_steepnesses_count - 激活陡度的数量
    • fann_get_cascade_candidate_change_fraction - 返回级联候选变化分数
    • fann_get_cascade_candidate_limit - 返回候选限度
    • fann_get_cascade_candidate_stagnation_epochs - 返回层叠候选停滞周期的数量
    • fann_get_cascade_max_cand_epochs - 返回候选周期的最大值
    • fann_get_cascade_max_out_epochs - 返回输出周期的最大值
    • fann_get_cascade_min_cand_epochs - 返回最小的候选周期
    • fann_get_cascade_min_out_epochs - 返回最小输出周期
    • fann_get_cascade_num_candidates - 返回训练期间使用的候选数量
    • fann_get_cascade_num_candidate_groups - 返回候选组的数量
    • fann_get_cascade_output_change_fraction - 返回级联输出变化分数
    • fann_get_cascade_output_stagnation_epochs - 返回级联输出停滞周期的数量
    • fann_get_cascade_weight_multiplier - 返回权重因子
    • fann_get_connection_array - 获取网络中的连接。
    • fann_get_connection_rate - 获取当网络创建时连接的使用率。
    • fann_get_errno - 返回最后一个错误数字。
    • fann_get_errstr - 返回最后的错误字符串。
    • fann_get_layer_array - 获取网络中每层的神经元数量。
    • fann_get_learning_momentum - 返回学习动量
    • fann_get_learning_rate - 返回学习速率
    • fann_get_MSE - 从网络中读取均方误差。
    • fann_get_network_type - 获取所创建的神经网络类型。
    • fann_get_num_input - 获取输入神经元的数量。
    • fann_get_num_layers - 获取神经网络的层数。
    • fann_get_num_output - 获取输出神经元的数量。
    • fann_get_quickprop_decay - 返回衰退值，用于在 quickprop 训练迭代时衰减权重
    • fann_get_quickprop_mu - 返回放大系数
    • fann_get_rprop_decrease_factor - 返回 RPROP 训练期间的衰减系数
    • fann_get_rprop_delta_max - 返回最大步长
    • fann_get_rprop_delta_min - 返回最小步长
    • fann_get_rprop_delta_zero - 返回初始步长
    • fann_get_rprop_increase_factor - 返回 RPROP 训练的递增系数
    • fann_get_sarprop_step_error_shift - 返回 sarprop 步值的误差偏移
    • fann_get_sarprop_step_error_threshold_factor - 返回 sarprop 算法步值的误差阈值系数
    • fann_get_sarprop_temperature - 返回 sarprop 算法温度
    • fann_get_sarprop_weight_decay_shift - 返回 sarprop 算法权重衰减变化值
    • fann_get_total_connections - 获取整个网络中所有的连接数。
    • fann_get_total_neurons - 获取整个网络中神经元的数量。
    • fann_get_training_algorithm - 返回训练算法。
    • fann_get_train_error_function - 返回训练中使用的错误函数。
    • fann_get_train_stop_function - 返回训练中使用的停止函数。
    • fann_init_weights - 使用 Widrow 和 Nguyen 算法初始化权重。
    • fann_length_train_data - 返回训练数据中训练模式的数量。
    • fann_merge_train_data - 合并训练数据。
    • fann_num_input_train_data - 返回训练数据中每个训练模式输入的数量。
    • fann_num_output_train_data - 返回训练数据中每个训练模式输出的数量。
    • fann_print_error - 打印错误字符串。
    • fann_randomize_weights - 给每个连接赋一个介于 min_weight 和 max_weight 之间的随机权重。
    • fann_read_train_from_file - 读取存储训练数据的文件。
    • fann_reset_errno - 重置最后的错误代码。
    • fann_reset_errstr - 重置最后的错误字符串。
    • fann_reset_MSE - 重置网络中的均方误差。
    • fann_run - 将通过神经网络运行输入。
    • fann_save - 将整个网络保存至配置文件。
    • fann_save_train - 将训练结构体保存至文件。
    • fann_scale_input - 在以前计算参数的基础上，在训练之前放大输入向量中的数据
    • fann_scale_input_train_data - 在训练数据中缩放输入至指定范围
    • fann_scale_output - 在以前计算参数的基础上，在训练之前放大输出向量中的数据
    • fann_scale_output_train_data - 在训练数据中缩放输出至指定范围
    • fann_scale_train - 在以前计算参数的基础上，缩放输入和输出数据
    • fann_scale_train_data - 在训练数据中缩放输入和输出到指定的范围
    • fann_set_activation_function - 为已应用的神经元和层设置激活函数
    • fann_set_activation_function_hidden - 为所有隐藏层设置激活函数
    • fann_set_activation_function_layer - 为已应用的层中所有的神经元设置激活函数。
    • fann_set_activation_function_output - 为输出层设置激活函数
    • fann_set_activation_steepness - 为提供的神经元和层设置激活陡度
    • fann_set_activation_steepness_hidden - 为所有隐藏层中所有的神经元设置激活函数陡度
    • fann_set_activation_steepness_layer - 为提供的层中所有的神经元设置激活陡度
    • fann_set_activation_steepness_output - 在输出层中设置激活陡度
    • fann_set_bit_fail_limit - 设置训练期间使用的误差
    • fann_set_callback - 设置训练期间使用的回调函数。
    • fann_set_cascade_activation_functions - 设置级联候选激活函数的数组
    • fann_set_cascade_activation_steepnesses - 设置级联候选激活陡度的数组。
    • fann_set_cascade_candidate_change_fraction - 设置级联候选更改分数
    • fann_set_cascade_candidate_limit - 设置候选限度
    • fann_set_cascade_candidate_stagnation_epochs - 设置级联候选停止周期数
    • fann_set_cascade_max_cand_epochs - 设置最大候选周期数
    • fann_set_cascade_max_out_epochs - 设置最大输出周期
    • fann_set_cascade_min_cand_epochs - 设置最小候选周期
    • fann_set_cascade_min_out_epochs - 设置最小输出周期
    • fann_set_cascade_num_candidate_groups - 设置候选组数量
    • fann_set_cascade_output_change_fraction - 设置级联输出改变分数
    • fann_set_cascade_output_stagnation_epochs - 设置级联输出停滞周期的值
    • fann_set_cascade_weight_multiplier - 设置权重因子
    • fann_set_error_log - 设置错误记录保存的位置。
    • fann_set_input_scaling_params - 根据训练数据计算将来使用的输入比例参数
    • fann_set_learning_momentum - 设置学习动量。
    • fann_set_learning_rate - 设置学习速率。
    • fann_set_output_scaling_params - 根据训练数据计算将来使用的输出缩放参数
    • fann_set_quickprop_decay - 设置quickprop算法衰减因子
    • fann_set_quickprop_mu - 设置 quickprop 算法放大因子
    • fann_set_rprop_decrease_factor - 使用 RPROP 算法训练时，设置下降因子
    • fann_set_rprop_delta_max - 设置最大步长
    • fann_set_rprop_delta_min - 设置最小步长
    • fann_set_rprop_delta_zero - 设置初始步长
    • fann_set_rprop_increase_factor - 使用 RPROP 算法训练时，设置增长因子
    • fann_set_sarprop_step_error_shift - 设置 sarprop 算法的步误差偏移量
    • fann_set_sarprop_step_error_threshold_factor - 设置 sarprop 算法的步误差阈值因子
    • fann_set_sarprop_temperature - 设置 sarprop 算法的温度
    • fann_set_sarprop_weight_decay_shift - 设置 sarprop 算法的权重衰减偏移值
    • fann_set_scaling_params - 根据训练数据计算输入和输出缩放参数以供将来使用
    • fann_set_training_algorithm - 设置训练算法。
    • fann_set_train_error_function - 设置训练期间使用的错误函数。
    • fann_set_train_stop_function - 设置训练期间使用的停止函数。
    • fann_set_weight - 在网络中设置一个连接。
    • fann_set_weight_array - 在网络中设置一个连接。
    • fann_shuffle_train_data - 打算训练数据，使顺序随机。
    • fann_subset_train_data - 返回一个训练数据子集的副本。
    • fann_test - 使用一组输入和一组期望的输出来测试。
    • fann_test_data - 使用训练数据来测试并且计算出 MSE
    • fann_train - 使用一个输入集和一个期望的输出集来迭代训练一次。
    • fann_train_epoch - 使用一组训练数据训练一个周期。
    • fann_train_on_data - 在整个数据集上训练一段时间。
    • fann_train_on_file - 在从某个文件读取的整个数据集上训练一段时间。
    • fastcgi_finish_request - 冲刷(flush)所有响应的数据给客户端
    • fbird_add_user - 别名 ibase_add_user
    • fbird_affected_rows - 别名 ibase_affected_rows
    • fbird_backup - 别名 ibase_backup
    • fbird_blob_add - 别名 ibase_blob_add
    • fbird_blob_cancel - Cancel creating blob
    • fbird_blob_close - 别名 ibase_blob_close
    • fbird_blob_create - 别名 ibase_blob_create
    • fbird_blob_echo - 别名 ibase_blob_echo
    • fbird_blob_get - 别名 ibase_blob_get
    • fbird_blob_import - 别名 ibase_blob_import
    • fbird_blob_info - 别名 ibase_blob_info
    • fbird_blob_open - 别名 ibase_blob_open
    • fbird_close - 别名 ibase_close
    • fbird_commit - 别名 ibase_commit
    • fbird_commit_ret - 别名 ibase_commit_ret
    • fbird_connect - 别名 ibase_connect
    • fbird_db_info - 别名 ibase_db_info
    • fbird_delete_user - 别名 ibase_delete_user
    • fbird_drop_db - 别名 ibase_drop_db
    • fbird_errcode - 别名 ibase_errcode
    • fbird_errmsg - 别名 ibase_errmsg
    • fbird_execute - 别名 ibase_execute
    • fbird_fetch_assoc - 别名 ibase_fetch_assoc
    • fbird_fetch_object - 别名 ibase_fetch_object
    • fbird_fetch_row - 别名 ibase_fetch_row
    • fbird_field_info - 别名 ibase_field_info
    • fbird_free_event_handler - 别名 ibase_free_event_handler
    • fbird_free_query - 别名 ibase_free_query
    • fbird_free_result - 别名 ibase_free_result
    • fbird_gen_id - 别名 ibase_gen_id
    • fbird_maintain_db - 别名 ibase_maintain_db
    • fbird_modify_user - 别名 ibase_modify_user
    • fbird_name_result - 别名 ibase_name_result
    • fbird_num_fields - 别名 ibase_num_fields
    • fbird_num_params - 别名 ibase_num_params
    • fbird_param_info - 别名 ibase_param_info
    • fbird_pconnect - 别名 ibase_pconnect
    • fbird_prepare - 别名 ibase_prepare
    • fbird_query - 别名 ibase_query
    • fbird_restore - 别名 ibase_restore
    • fbird_rollback - 别名 ibase_rollback
    • fbird_rollback_ret - 别名 ibase_rollback_ret
    • fbird_server_info - 别名 ibase_server_info
    • fbird_service_attach - 别名 ibase_service_attach
    • fbird_service_detach - 别名 ibase_service_detach
    • fbird_set_event_handler - 别名 ibase_set_event_handler
    • fbird_trans - 别名 ibase_trans
    • fbird_wait_event - 别名 ibase_wait_event
    • fbsql_affected_rows - Get number of affected rows in previous FrontBase operation
    • fbsql_autocommit - Enable or disable autocommit
    • fbsql_blob_size - Get the size of a BLOB
    • fbsql_change_user - Change logged in user of the active connection
    • fbsql_clob_size - Get the size of a CLOB
    • fbsql_close - Close FrontBase connection
    • fbsql_commit - Commits a transaction to the database
    • fbsql_connect - Open a connection to a FrontBase Server
    • fbsql_create_blob - Create a BLOB
    • fbsql_create_clob - Create a CLOB
    • fbsql_create_db - Create a FrontBase database
    • fbsql_database - Get or set the database name used with a connection
    • fbsql_database_password - Sets or retrieves the password for a FrontBase database
    • fbsql_data_seek - Move internal result pointer
    • fbsql_db_query - Send a FrontBase query
    • fbsql_db_status - Get the status for a given database
    • fbsql_drop_db - Drop (delete) a FrontBase database
    • fbsql_errno - Returns the error number from previous operation
    • fbsql_error - Returns the error message from previous operation
    • fbsql_fetch_array - Fetch a result row as an associative array, a numeric array, or both
    • fbsql_fetch_assoc - Fetch a result row as an associative array
    • fbsql_fetch_field - Get column information from a result and return as an object
    • fbsql_fetch_lengths - Get the length of each output in a result
    • fbsql_fetch_object - Fetch a result row as an object
    • fbsql_fetch_row - Get a result row as an enumerated array
    • fbsql_field_flags - Get the flags associated with the specified field in a result
    • fbsql_field_len - Returns the length of the specified field
    • fbsql_field_name - Get the name of the specified field in a result
    • fbsql_field_seek - Set result pointer to a specified field offset
    • fbsql_field_table - Get name of the table the specified field is in
    • fbsql_field_type - Get the type of the specified field in a result
    • fbsql_free_result - Free result memory
    • fbsql_get_autostart_info - 说明
    • fbsql_hostname - Get or set the host name used with a connection
    • fbsql_insert_id - Get the id generated from the previous INSERT operation
    • fbsql_list_dbs - List databases available on a FrontBase server
    • fbsql_list_fields - List FrontBase result fields
    • fbsql_list_tables - List tables in a FrontBase database
    • fbsql_next_result - Move the internal result pointer to the next result
    • fbsql_num_fields - Get number of fields in result
    • fbsql_num_rows - Get number of rows in result
    • fbsql_password - Get or set the user password used with a connection
    • fbsql_pconnect - Open a persistent connection to a FrontBase Server
    • fbsql_query - Send a FrontBase query
    • fbsql_read_blob - Read a BLOB from the database
    • fbsql_read_clob - Read a CLOB from the database
    • fbsql_result - Get result data
    • fbsql_rollback - Rollback a transaction to the database
    • fbsql_rows_fetched - Get the number of rows affected by the last statement
    • fbsql_select_db - Select a FrontBase database
    • fbsql_set_characterset - Change input/output character set
    • fbsql_set_lob_mode - Set the LOB retrieve mode for a FrontBase result set
    • fbsql_set_password - Change the password for a given user
    • fbsql_set_transaction - Set the transaction locking and isolation
    • fbsql_start_db - Start a database on local or remote server
    • fbsql_stop_db - Stop a database on local or remote server
    • fbsql_tablename - 别名 fbsql_table_name
    • fbsql_table_name - Get table name of field
    • fbsql_username - Get or set the username for the connection
    • fbsql_warnings - Enable or disable FrontBase warnings
    • fclose - 关闭一个已打开的文件指针
    • fdf_add_doc_javascript - Adds javascript code to the FDF document
    • fdf_add_template - Adds a template into the FDF document
    • fdf_close - Close an FDF document
    • fdf_create - Create a new FDF document
    • fdf_enum_values - Call a user defined function for each document value
    • fdf_errno - Return error code for last fdf operation
    • fdf_error - Return error description for FDF error code
    • fdf_get_ap - Get the appearance of a field
    • fdf_get_attachment - Extracts uploaded file embedded in the FDF
    • fdf_get_encoding - Get the value of the /Encoding key
    • fdf_get_file - Get the value of the /F key
    • fdf_get_flags - Gets the flags of a field
    • fdf_get_opt - Gets a value from the opt array of a field
    • fdf_get_status - Get the value of the /STATUS key
    • fdf_get_value - Get the value of a field
    • fdf_get_version - Gets version number for FDF API or file
    • fdf_header - Sets FDF-specific output headers
    • fdf_next_field_name - Get the next field name
    • fdf_open - Open a FDF document
    • fdf_open_string - Read a FDF document from a string
    • fdf_remove_item - Sets target frame for form
    • fdf_save - Save a FDF document
    • fdf_save_string - Returns the FDF document as a string
    • fdf_set_ap - Set the appearance of a field
    • fdf_set_encoding - Sets FDF character encoding
    • fdf_set_file - Set PDF document to display FDF data in
    • fdf_set_flags - Sets a flag of a field
    • fdf_set_javascript_action - Sets an javascript action of a field
    • fdf_set_on_import_javascript - Adds javascript code to be executed when Acrobat opens the FDF
    • fdf_set_opt - Sets an option of a field
    • fdf_set_status - Set the value of the /STATUS key
    • fdf_set_submit_form_action - Sets a submit form action of a field
    • fdf_set_target_frame - Set target frame for form display
    • fdf_set_value - Set the value of a field
    • fdf_set_version - Sets version number for a FDF file
    • fdiv - Divides two numbers, according to IEEE 754
    • feof - 测试文件指针是否到了文件结束的位置
    • FFI::addr - Creates an unmanaged pointer to C data
    • FFI::alignof - Gets the alignment
    • FFI::arrayType - Dynamically constructs a new C array type
    • FFI::cast - Performs a C type cast
    • FFI::cdef - Creates a new FFI object
    • FFI::free - Releases an unmanaged data structure
    • FFI::isNull - Checks whether a FFI\CData is a null pointer
    • FFI::load - Loads C declarations from a C header file
    • FFI::memcmp - Compares memory areas
    • FFI::memcpy - Copies one memory area to another
    • FFI::memset - Fills a memory area
    • FFI::new - Creates a C data structure
    • FFI::scope - Instantiates an FFI object with C declarations parsed during preloading
    • FFI::sizeof - Gets the size of C data or types
    • FFI::string - Creates a PHP string from a memory area
    • FFI::type - Creates an FFI\CType object from a C declaration
    • FFI::typeof - Gets the FFI\CType of FFI\CData
    • fflush - 将缓冲内容输出到文件
    • fgetc - 从文件指针中读取字符
    • fgetcsv - 从文件指针中读入一行并解析 CSV 字段
    • fgets - 从文件指针中读取一行
    • fgetss - 从文件指针中读取一行并过滤掉 HTML 标记
    • file - 把整个文件读入一个数组中
    • file:// - 访问本地文件系统
    • fileatime - 取得文件的上次访问时间
    • filectime - 取得文件的 inode 修改时间
    • filegroup - 取得文件的组
    • fileinode - 取得文件的 inode
    • filemtime - 取得文件修改时间
    • fileowner - 取得文件的所有者
    • fileperms - 取得文件的权限
    • filepro - Read and verify the map file
    • filepro_fieldcount - Find out how many fields are in a filePro database
    • filepro_fieldname - Gets the name of a field
    • filepro_fieldtype - Gets the type of a field
    • filepro_fieldwidth - Gets the width of a field
    • filepro_retrieve - Retrieves data from a filePro database
    • filepro_rowcount - Find out how many rows are in a filePro database
    • filesize - 取得文件大小
    • FilesystemIterator::current - The current file
    • FilesystemIterator::getFlags - Get the handling flags
    • FilesystemIterator::key - Retrieve the key for the current file
    • FilesystemIterator::next - Move to the next file
    • FilesystemIterator::rewind - Rewinds back to the beginning
    • FilesystemIterator::setFlags - Sets handling flags
    • FilesystemIterator::__construct - Constructs a new filesystem iterator
    • filetype - 取得文件类型
    • file_exists - 检查文件或目录是否存在
    • file_get_contents - 将整个文件读入一个字符串
    • file_put_contents - 将一个字符串写入文件
    • FilterIterator::accept - Check whether the current element of the iterator is acceptable
    • FilterIterator::current - Get the current element value
    • FilterIterator::getInnerIterator - Get the inner iterator
    • FilterIterator::key - Get the current key
    • FilterIterator::next - Move the iterator forward
    • FilterIterator::rewind - Rewind the iterator
    • FilterIterator::valid - Check whether the current element is valid
    • FilterIterator::__construct - Construct a filterIterator
    • filter_has_var - 检测是否存在指定类型的变量
    • filter_id - 返回与某个特定名称的过滤器相关联的id
    • filter_input - 通过名称获取特定的外部变量，并且可以通过过滤器处理它
    • filter_input_array - 获取一系列外部变量，并且可以通过过滤器处理它们
    • filter_list - 返回所支持的过滤器列表
    • filter_var - 使用特定的过滤器过滤一个变量
    • filter_var_array - 获取多个变量并且过滤它们
    • finfo::buffer - 别名 finfo_buffer()
    • finfo::file - 别名 finfo_file()
    • finfo::set_flags - 别名 finfo_set_flags()
    • finfo::__construct - 别名 finfo_open
    • finfo_close - 关闭 fileinfo 资源
    • finfo_open - 创建一个 fileinfo 资源
    • floatval - 获取变量的浮点值
    • flock - 轻便的咨询文件锁定
    • floor - 舍去法取整
    • flush - 刷新输出缓冲
    • fmod - 返回除法的浮点数余数
    • fnmatch - 用模式匹配文件名
    • fopen - 打开文件或者 URL
    • forward_static_call - Call a static method
    • forward_static_call_array - Call a static method and pass the arguments as array
    • fpassthru - 输出文件指针处的所有剩余数据
    • fprintf - 将格式化后的字符串写入到流
    • fputcsv - 将行格式化为 CSV 并写入文件指针
    • fputs - fwrite 的别名
    • fread - 读取文件（可安全用于二进制文件）
    • FrenchToJD - 从一个French Republican历法的日期得到Julian Day计数。
    • fscanf - 从文件中格式化输入
    • fseek - 在文件指针中定位
    • fsockopen - 打开一个网络连接或者一个Unix套接字连接
    • fstat - 通过已打开的文件指针取得文件信息
    • ftell - 返回文件指针读/写的位置
    • ftok - Convert a pathname and a project identifier to a System V IPC key
    • ftp:// - 访问 FTP(s) URLs
    • FTP context options - FTP context option listing
    • ftp_alloc - 为要上传的文件分配空间
    • ftp_append - 将文件内容追加到 FTP 服务器上的指定文件
    • ftp_cdup - 切换到当前目录的父目录
    • ftp_chdir - 在 FTP 服务器上改变当前目录
    • ftp_chmod - 设置 FTP 服务器上的文件权限
    • ftp_close - 关闭一个 FTP 连接
    • ftp_connect - 建立一个新的 FTP 连接
    • ftp_delete - 删除 FTP 服务器上的一个文件
    • ftp_exec - 在 FTP 服务器运行指定的命令
    • ftp_fget - 从 FTP 服务器上下载一个文件并保存到本地一个已经打开的文件中
    • ftp_fput - 上传一个已经打开的文件到 FTP 服务器
    • ftp_get - 从 FTP 服务器上下载一个文件
    • ftp_get_option - 返回当前 FTP 连接的各种不同的选项设置
    • ftp_login - 登录 FTP 服务器
    • ftp_mdtm - 返回指定文件的最后修改时间
    • ftp_mkdir - 建立新目录
    • ftp_mlsd - 返回指定目录中的文件列表
    • ftp_nb_continue - 连续获取／发送文件（以不分块的方式 non-blocking）
    • ftp_nb_fget - 从 FTP 服务器获取文件并写入到一个打开的文件（非阻塞）
    • ftp_nb_fput - 将文件存储到 FTP 服务器 （非阻塞）
    • ftp_nb_get - 从 FTP 服务器上获取文件并写入本地文件（non-blocking）
    • ftp_nb_put - 存储一个文件至 FTP 服务器（non-blocking）
    • ftp_nlist - 返回给定目录的文件列表
    • ftp_pasv - 返回当前 FTP 被动模式是否打开
    • ftp_put - 上传文件到 FTP 服务器
    • ftp_pwd - 返回当前目录名
    • ftp_quit - ftp_close 的 别名
    • ftp_raw - 向 FTP 服务器发送命令
    • ftp_rawlist - 返回指定目录下文件的详细列表
    • ftp_rename - 更改 FTP 服务器上的文件或目录名
    • ftp_rmdir - 删除目录
    • ftp_set_option - 设置各种 FTP 运行时选项
    • ftp_site - 向服务器发送 SITE 命令
    • ftp_size - 返回指定文件的大小
    • ftp_ssl_connect - 打开 SSL-FTP 连接
    • ftp_systype - 返回远程 FTP 服务器的操作系统类型
    • ftruncate - 将文件截断到给定的长度
    • function_exists - 如果给定的函数已经被定义就返回 true
    • func_get_arg - 返回参数列表的某一项
    • func_get_args - 返回一个包含函数参数列表的数组
    • func_num_args - Returns the number of arguments passed to the function
    • fwrite - 写入文件（可安全用于二进制文件）
  • g
    • gc_collect_cycles - 强制收集所有现存的垃圾循环周期
    • gc_disable - 停用循环引用收集器
    • gc_enable - 激活循环引用收集器
    • gc_enabled - 返回循环引用计数器的状态
    • gc_mem_caches - Reclaims memory used by the Zend Engine memory manager
    • gc_status - Gets information about the garbage collector
    • gd_info - 取得当前安装的 GD 库的信息
    • GearmanClient::addOptions - Add client options
    • GearmanClient::addServer - Add a job server to the client
    • GearmanClient::addServers - Add a list of job servers to the client
    • GearmanClient::addTask - Add a task to be run in parallel
    • GearmanClient::addTaskBackground - Add a background task to be run in parallel
    • GearmanClient::addTaskHigh - Add a high priority task to run in parallel
    • GearmanClient::addTaskHighBackground - Add a high priority background task to be run in parallel
    • GearmanClient::addTaskLow - Add a low priority task to run in parallel
    • GearmanClient::addTaskLowBackground - Add a low priority background task to be run in parallel
    • GearmanClient::addTaskStatus - Add a task to get status
    • GearmanClient::clearCallbacks - Clear all task callback functions
    • GearmanClient::clone - Create a copy of a GearmanClient object
    • GearmanClient::context - Get the application context
    • GearmanClient::data - Get the application data (deprecated)
    • GearmanClient::do - Run a single task and return a result [deprecated]
    • GearmanClient::doBackground - Run a task in the background
    • GearmanClient::doHigh - Run a single high priority task
    • GearmanClient::doHighBackground - Run a high priority task in the background
    • GearmanClient::doJobHandle - Get the job handle for the running task
    • GearmanClient::doLow - Run a single low priority task
    • GearmanClient::doLowBackground - Run a low priority task in the background
    • GearmanClient::doNormal - Run a single task and return a result
    • GearmanClient::doStatus - Get the status for the running task
    • GearmanClient::echo - Send data to all job servers to see if they echo it back [deprecated]
    • GearmanClient::error - Returns an error string for the last error encountered
    • GearmanClient::getErrno - Get an errno value
    • GearmanClient::jobStatus - Get the status of a background job
    • GearmanClient::ping - Send data to all job servers to see if they echo it back
    • GearmanClient::removeOptions - Remove client options
    • GearmanClient::returnCode - Get the last Gearman return code
    • GearmanClient::runTasks - Run a list of tasks in parallel
    • GearmanClient::setClientCallback - Callback function when there is a data packet for a task (deprecated)
    • GearmanClient::setCompleteCallback - Set a function to be called on task completion
    • GearmanClient::setContext - Set application context
    • GearmanClient::setCreatedCallback - Set a callback for when a task is queued
    • GearmanClient::setData - Set application data (deprecated)
    • GearmanClient::setDataCallback - Callback function when there is a data packet for a task
    • GearmanClient::setExceptionCallback - Set a callback for worker exceptions
    • GearmanClient::setFailCallback - Set callback for job failure
    • GearmanClient::setOptions - Set client options
    • GearmanClient::setStatusCallback - Set a callback for collecting task status
    • GearmanClient::setTimeout - Set socket I/O activity timeout
    • GearmanClient::setWarningCallback - Set a callback for worker warnings
    • GearmanClient::setWorkloadCallback - Set a callback for accepting incremental data updates
    • GearmanClient::timeout - Get current socket I/O activity timeout value
    • GearmanClient::wait - Wait for I/O activity on all connections in a client
    • GearmanClient::__construct - Create a GearmanClient instance
    • GearmanJob::complete - Send the result and complete status (deprecated)
    • GearmanJob::data - Send data for a running job (deprecated)
    • GearmanJob::exception - Send exception for running job (deprecated)
    • GearmanJob::fail - Send fail status (deprecated)
    • GearmanJob::functionName - Get function name
    • GearmanJob::handle - Get the job handle
    • GearmanJob::returnCode - Get last return code
    • GearmanJob::sendComplete - Send the result and complete status
    • GearmanJob::sendData - Send data for a running job
    • GearmanJob::sendException - Send exception for running job (exception)
    • GearmanJob::sendFail - Send fail status
    • GearmanJob::sendStatus - Send status
    • GearmanJob::sendWarning - Send a warning
    • GearmanJob::setReturn - Set a return value
    • GearmanJob::status - Send status (deprecated)
    • GearmanJob::unique - Get the unique identifier
    • GearmanJob::warning - Send a warning (deprecated)
    • GearmanJob::workload - Get workload
    • GearmanJob::workloadSize - Get size of work load
    • GearmanJob::__construct - Create a GearmanJob instance
    • GearmanTask::create - Create a task (deprecated)
    • GearmanTask::data - Get data returned for a task
    • GearmanTask::dataSize - Get the size of returned data
    • GearmanTask::function - Get associated function name (deprecated)
    • GearmanTask::functionName - Get associated function name
    • GearmanTask::isKnown - Determine if task is known
    • GearmanTask::isRunning - Test whether the task is currently running
    • GearmanTask::jobHandle - Get the job handle
    • GearmanTask::recvData - Read work or result data into a buffer for a task
    • GearmanTask::returnCode - Get the last return code
    • GearmanTask::sendData - Send data for a task (deprecated)
    • GearmanTask::sendWorkload - Send data for a task
    • GearmanTask::taskDenominator - Get completion percentage denominator
    • GearmanTask::taskNumerator - Get completion percentage numerator
    • GearmanTask::unique - Get the unique identifier for a task
    • GearmanTask::uuid - Get the unique identifier for a task (deprecated)
    • GearmanTask::__construct - Create a GearmanTask instance
    • GearmanWorker::addFunction - Register and add callback function
    • GearmanWorker::addOptions - Add worker options
    • GearmanWorker::addServer - Add a job server
    • GearmanWorker::addServers - Add job servers
    • GearmanWorker::clone - Create a copy of the worker
    • GearmanWorker::echo - Test job server response
    • GearmanWorker::error - Get the last error encountered
    • GearmanWorker::getErrno - Get errno
    • GearmanWorker::options - Get worker options
    • GearmanWorker::register - Register a function with the job server
    • GearmanWorker::removeOptions - Remove worker options
    • GearmanWorker::returnCode - Get last Gearman return code
    • GearmanWorker::setId - Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers
    • GearmanWorker::setOptions - Set worker options
    • GearmanWorker::setTimeout - Set socket I/O activity timeout
    • GearmanWorker::timeout - Get socket I/O activity timeout
    • GearmanWorker::unregister - Unregister a function name with the job servers
    • GearmanWorker::unregisterAll - Unregister all function names with the job servers
    • GearmanWorker::wait - Wait for activity from one of the job servers
    • GearmanWorker::work - Wait for and perform jobs
    • GearmanWorker::__construct - Create a GearmanWorker instance
    • Gender\Gender::connect - Connect to an external name dictionary
    • Gender\Gender::country - Get textual country representation
    • Gender\Gender::get - Get gender of a name
    • Gender\Gender::isNick - Check if the name0 is an alias of the name1
    • Gender\Gender::similarNames - Get similar names
    • Gender\Gender::__construct - Construct the Gender object
    • Generator::current - 返回当前产生的值
    • Generator::key - 返回当前产生的键
    • Generator::next - 生成器继续执行
    • Generator::rewind - 重置迭代器
    • Generator::send - 向生成器中传入一个值
    • Generator::throw - 向生成器中抛入一个异常
    • Generator::valid - 检查迭代器是否被关闭
    • Generator::__wakeup - 序列化回调
    • geoip_asnum_by_name - 获取自治系统号(ASN)
    • geoip_continent_code_by_name - 获取七大洲的大写字母简称
    • geoip_country_code3_by_name - 获取三个字母组成的国家简称
    • geoip_country_code_by_name - 获取国家代码
    • geoip_country_name_by_name - 获取国家的全称
    • geoip_database_info - 获取 GeoIP 数据库的信息
    • geoip_db_avail - GeoIP 数据库是否可用
    • geoip_db_filename - 返回 GeoIP 数据库相对应的文件名
    • geoip_db_get_all_info - 返回所有 GeoIP 数据库类型的详细信息
    • geoip_domain_by_name - 获取二级域名
    • geoip_id_by_name - 获取网络连接类型
    • geoip_isp_by_name - 获取 ISP (网络服务提供商)的名称
    • geoip_netspeedcell_by_name - 获取网络连接速度
    • geoip_org_by_name - 获取机构的名称
    • geoip_record_by_name - 返回 GeoIP 数据库中详细的城市信息
    • geoip_region_by_name - 获取国家和地区代码
    • geoip_region_name_by_code - 返回给定的国家和地区代码组合所对应的地区名称
    • geoip_setup_custom_directory - 自定义 GeoIP 数据库的目录
    • geoip_time_zone_by_country_and_region - 返回国家和地区的时区
    • getallheaders - 获取全部 HTTP 请求头信息
    • getcwd - 取得当前工作目录
    • getdate - 取得日期／时间信息
    • getenv - 获取一个环境变量的值
    • gethostbyaddr - 获取指定的IP地址对应的主机名
    • gethostbyname - 返回主机名对应的 IPv4地址。
    • gethostbynamel - 获取互联网主机名对应的 IPv4 地址列表
    • gethostname - 获取主机名
    • getimagesize - 取得图像大小
    • getimagesizefromstring - 从字符串中获取图像尺寸信息
    • getlastmod - 获取页面最后修改的时间
    • getmxrr - 获取互联网主机名对应的 MX 记录
    • getmygid - 获取当前 PHP 脚本拥有者的 GID
    • getmyinode - 获取当前脚本的索引节点（inode）
    • getmypid - 获取 PHP 进程的 ID
    • getmyuid - 获取 PHP 脚本所有者的 UID
    • getopt - 从命令行参数列表中获取选项
    • getprotobyname - Get protocol number associated with protocol name
    • getprotobynumber - Get protocol name associated with protocol number
    • getrandmax - 显示随机数最大的可能值
    • getrusage - 获取当前资源使用状况
    • getservbyname - 获取互联网服务协议对应的端口
    • getservbyport - Get Internet service which corresponds to port and protocol
    • getSession - Connect to a MySQL server
    • gettext - Lookup a message in the current domain
    • gettimeofday - 取得当前时间
    • gettype - 获取变量的类型
    • get_browser - 获取浏览器具有的功能
    • get_called_class - 后期静态绑定（"Late Static Binding"）类的名称
    • get_cfg_var - 获取 PHP 配置选项的值
    • get_class - 返回对象的类名
    • get_class_methods - 返回由类的方法名组成的数组
    • get_class_vars - 返回由类的默认属性组成的数组
    • get_current_user - 获取当前 PHP 脚本所有者名称
    • get_declared_classes - 返回由已定义类的名字所组成的数组
    • get_declared_interfaces - 返回一个数组包含所有已声明的接口
    • get_declared_traits - 返回所有已定义的 traits 的数组
    • get_defined_constants - 返回所有常量的关联数组，键是常量名，值是常量值
    • get_defined_functions - 返回所有已定义函数的数组
    • get_defined_vars - 返回由所有已定义变量所组成的数组
    • get_extension_funcs - 返回模块函数名称的数组
    • get_headers - 取得服务器响应一个 HTTP 请求所发送的所有标头
    • get_html_translation_table - 返回使用 htmlspecialchars 和 htmlentities 后的转换表
    • get_included_files - 返回被 include 和 require 文件名的 array
    • get_include_path - 获取当前的 include_path 配置选项
    • get_loaded_extensions - 返回所有编译并加载模块名的 array
    • get_magic_quotes_gpc - 获取当前 magic_quotes_gpc 的配置选项设置
    • get_magic_quotes_runtime - 获取当前 magic_quotes_runtime 配置选项的激活状态
    • get_meta_tags - 从一个文件中提取所有的 meta 标签 content 属性，返回一个数组
    • get_object_vars - 返回由对象属性组成的关联数组
    • get_parent_class - 返回对象或类的父类名
    • get_required_files - 别名 get_included_files
    • get_resources - Returns active resources
    • get_resource_id - Returns an integer identifier for the given resource
    • get_resource_type - 返回资源（resource）类型
    • glob - 寻找与模式匹配的文件路径
    • glob:// - 查找匹配的文件路径模式
    • GlobIterator::count - Get the number of directories and files
    • GlobIterator::__construct - Construct a directory using glob
    • Gmagick::addimage - Adds new image to Gmagick object image list
    • Gmagick::addnoiseimage - Adds random noise to the image
    • Gmagick::annotateimage - Annotates an image with text
    • Gmagick::blurimage - Adds blur filter to image
    • Gmagick::borderimage - Surrounds the image with a border
    • Gmagick::charcoalimage - Simulates a charcoal drawing
    • Gmagick::chopimage - Removes a region of an image and trims
    • Gmagick::clear - Clears all resources associated to Gmagick object
    • Gmagick::commentimage - Adds a comment to your image
    • Gmagick::compositeimage - Composite one image onto another
    • Gmagick::cropimage - Extracts a region of the image
    • Gmagick::cropthumbnailimage - Creates a crop thumbnail
    • Gmagick::current - The current purpose
    • Gmagick::cyclecolormapimage - Displaces an image's colormap
    • Gmagick::deconstructimages - Returns certain pixel differences between images
    • Gmagick::despeckleimage - The despeckleimage purpose
    • Gmagick::destroy - The destroy purpose
    • Gmagick::drawimage - Renders the GmagickDraw object on the current image
    • Gmagick::edgeimage - Enhance edges within the image
    • Gmagick::embossimage - Returns a grayscale image with a three-dimensional effect
    • Gmagick::enhanceimage - Improves the quality of a noisy image
    • Gmagick::equalizeimage - Equalizes the image histogram
    • Gmagick::flipimage - Creates a vertical mirror image
    • Gmagick::flopimage - The flopimage purpose
    • Gmagick::frameimage - Adds a simulated three-dimensional border
    • Gmagick::gammaimage - Gamma-corrects an image
    • Gmagick::getcopyright - Returns the GraphicsMagick API copyright as a string
    • Gmagick::getfilename - The filename associated with an image sequence
    • Gmagick::getimagebackgroundcolor - Returns the image background color
    • Gmagick::getimageblueprimary - Returns the chromaticy blue primary point
    • Gmagick::getimagebordercolor - Returns the image border color
    • Gmagick::getimagechanneldepth - Gets the depth for a particular image channel
    • Gmagick::getimagecolors - Returns the color of the specified colormap index
    • Gmagick::getimagecolorspace - Gets the image colorspace
    • Gmagick::getimagecompose - Returns the composite operator associated with the image
    • Gmagick::getimagedelay - Gets the image delay
    • Gmagick::getimagedepth - Gets the depth of the image
    • Gmagick::getimagedispose - Gets the image disposal method
    • Gmagick::getimageextrema - Gets the extrema for the image
    • Gmagick::getimagefilename - Returns the filename of a particular image in a sequence
    • Gmagick::getimageformat - Returns the format of a particular image in a sequence
    • Gmagick::getimagegamma - Gets the image gamma
    • Gmagick::getimagegreenprimary - Returns the chromaticy green primary point
    • Gmagick::getimageheight - Returns the image height
    • Gmagick::getimagehistogram - Gets the image histogram
    • Gmagick::getimageindex - Gets the index of the current active image
    • Gmagick::getimageinterlacescheme - Gets the image interlace scheme
    • Gmagick::getimageiterations - Gets the image iterations
    • Gmagick::getimagematte - Check if the image has a matte channel
    • Gmagick::getimagemattecolor - Returns the image matte color
    • Gmagick::getimageprofile - Returns the named image profile
    • Gmagick::getimageredprimary - Returns the chromaticity red primary point
    • Gmagick::getimagerenderingintent - Gets the image rendering intent
    • Gmagick::getimageresolution - Gets the image X and Y resolution
    • Gmagick::getimagescene - Gets the image scene
    • Gmagick::getimagesignature - Generates an SHA-256 message digest
    • Gmagick::getimagetype - Gets the potential image type
    • Gmagick::getimageunits - Gets the image units of resolution
    • Gmagick::getimagewhitepoint - Returns the chromaticity white point
    • Gmagick::getimagewidth - Returns the width of the image
    • Gmagick::getpackagename - Returns the GraphicsMagick package name
    • Gmagick::getquantumdepth - Returns the Gmagick quantum depth as a string
    • Gmagick::getreleasedate - Returns the GraphicsMagick release date as a string
    • Gmagick::getsamplingfactors - Gets the horizontal and vertical sampling factor
    • Gmagick::getsize - Returns the size associated with the Gmagick object
    • Gmagick::getversion - Returns the GraphicsMagick API version
    • Gmagick::hasnextimage - Checks if the object has more images
    • Gmagick::haspreviousimage - Checks if the object has a previous image
    • Gmagick::implodeimage - Creates a new image as a copy
    • Gmagick::labelimage - Adds a label to an image
    • Gmagick::levelimage - Adjusts the levels of an image
    • Gmagick::magnifyimage - Scales an image proportionally 2x
    • Gmagick::mapimage - Replaces the colors of an image with the closest color from a reference image
    • Gmagick::medianfilterimage - Applies a digital filter
    • Gmagick::minifyimage - Scales an image proportionally to half its size
    • Gmagick::modulateimage - Control the brightness, saturation, and hue
    • Gmagick::motionblurimage - Simulates motion blur
    • Gmagick::newimage - Creates a new image
    • Gmagick::nextimage - Moves to the next image
    • Gmagick::normalizeimage - Enhances the contrast of a color image
    • Gmagick::oilpaintimage - Simulates an oil painting
    • Gmagick::previousimage - Move to the previous image in the object
    • Gmagick::profileimage - Adds or removes a profile from an image
    • Gmagick::quantizeimage - Analyzes the colors within a reference image
    • Gmagick::quantizeimages - The quantizeimages purpose
    • Gmagick::queryfontmetrics - Returns an array representing the font metrics
    • Gmagick::queryfonts - Returns the configured fonts
    • Gmagick::queryformats - Returns formats supported by Gmagick
    • Gmagick::radialblurimage - Radial blurs an image
    • Gmagick::raiseimage - Creates a simulated 3d button-like effect
    • Gmagick::read - Reads image from filename
    • Gmagick::readimage - Reads image from filename
    • Gmagick::readimageblob - Reads image from a binary string
    • Gmagick::readimagefile - The readimagefile purpose
    • Gmagick::reducenoiseimage - Smooths the contours of an image
    • Gmagick::removeimage - Removes an image from the image list
    • Gmagick::removeimageprofile - Removes the named image profile and returns it
    • Gmagick::resampleimage - Resample image to desired resolution
    • Gmagick::resizeimage - Scales an image
    • Gmagick::rollimage - Offsets an image
    • Gmagick::rotateimage - Rotates an image
    • Gmagick::scaleimage - Scales the size of an image
    • Gmagick::separateimagechannel - Separates a channel from the image
    • Gmagick::setCompressionQuality - Sets the object's default compression quality
    • Gmagick::setfilename - Sets the filename before you read or write the image
    • Gmagick::setimagebackgroundcolor - Sets the image background color
    • Gmagick::setimageblueprimary - Sets the image chromaticity blue primary point
    • Gmagick::setimagebordercolor - Sets the image border color
    • Gmagick::setimagechanneldepth - Sets the depth of a particular image channel
    • Gmagick::setimagecolorspace - Sets the image colorspace
    • Gmagick::setimagecompose - Sets the image composite operator
    • Gmagick::setimagedelay - Sets the image delay
    • Gmagick::setimagedepth - Sets the image depth
    • Gmagick::setimagedispose - Sets the image disposal method
    • Gmagick::setimagefilename - Sets the filename of a particular image in a sequence
    • Gmagick::setimageformat - Sets the format of a particular image
    • Gmagick::setimagegamma - Sets the image gamma
    • Gmagick::setimagegreenprimary - Sets the image chromaticity green primary point
    • Gmagick::setimageindex - Set the iterator to the position in the image list specified with the index parameter
    • Gmagick::setimageinterlacescheme - Sets the interlace scheme of the image
    • Gmagick::setimageiterations - Sets the image iterations
    • Gmagick::setimageprofile - Adds a named profile to the Gmagick object
    • Gmagick::setimageredprimary - Sets the image chromaticity red primary point
    • Gmagick::setimagerenderingintent - Sets the image rendering intent
    • Gmagick::setimageresolution - Sets the image resolution
    • Gmagick::setimagescene - Sets the image scene
    • Gmagick::setimagetype - Sets the image type
    • Gmagick::setimageunits - Sets the image units of resolution
    • Gmagick::setimagewhitepoint - Sets the image chromaticity white point
    • Gmagick::setsamplingfactors - Sets the image sampling factors
    • Gmagick::setsize - Sets the size of the Gmagick object
    • Gmagick::shearimage - Creating a parallelogram
    • Gmagick::solarizeimage - Applies a solarizing effect to the image
    • Gmagick::spreadimage - Randomly displaces each pixel in a block
    • Gmagick::stripimage - Strips an image of all profiles and comments
    • Gmagick::swirlimage - Swirls the pixels about the center of the image
    • Gmagick::thumbnailimage - Changes the size of an image
    • Gmagick::trimimage - Remove edges from the image
    • Gmagick::write - 别名 Gmagick::writeimage
    • Gmagick::writeimage - Writes an image to the specified filename
    • Gmagick::__construct - The Gmagick constructor
    • GmagickDraw::annotate - Draws text on the image
    • GmagickDraw::arc - Draws an arc
    • GmagickDraw::bezier - Draws a bezier curve
    • GmagickDraw::ellipse - Draws an ellipse on the image
    • GmagickDraw::getfillcolor - Returns the fill color
    • GmagickDraw::getfillopacity - Returns the opacity used when drawing
    • GmagickDraw::getfont - Returns the font
    • GmagickDraw::getfontsize - Returns the font pointsize
    • GmagickDraw::getfontstyle - Returns the font style
    • GmagickDraw::getfontweight - Returns the font weight
    • GmagickDraw::getstrokecolor - Returns the color used for stroking object outlines
    • GmagickDraw::getstrokeopacity - Returns the opacity of stroked object outlines
    • GmagickDraw::getstrokewidth - Returns the width of the stroke used to draw object outlines
    • GmagickDraw::gettextdecoration - Returns the text decoration
    • GmagickDraw::gettextencoding - Returns the code set used for text annotations
    • GmagickDraw::line - The line purpose
    • GmagickDraw::point - Draws a point
    • GmagickDraw::polygon - Draws a polygon
    • GmagickDraw::polyline - Draws a polyline
    • GmagickDraw::rectangle - Draws a rectangle
    • GmagickDraw::rotate - Applies the specified rotation to the current coordinate space
    • GmagickDraw::roundrectangle - Draws a rounded rectangle
    • GmagickDraw::scale - Adjusts the scaling factor
    • GmagickDraw::setfillcolor - Sets the fill color to be used for drawing filled objects
    • GmagickDraw::setfillopacity - The setfillopacity purpose
    • GmagickDraw::setfont - Sets the fully-specified font to use when annotating with text
    • GmagickDraw::setfontsize - Sets the font pointsize to use when annotating with text
    • GmagickDraw::setfontstyle - Sets the font style to use when annotating with text
    • GmagickDraw::setfontweight - Sets the font weight
    • GmagickDraw::setstrokecolor - Sets the color used for stroking object outlines
    • GmagickDraw::setstrokeopacity - Specifies the opacity of stroked object outlines
    • GmagickDraw::setstrokewidth - Sets the width of the stroke used to draw object outlines
    • GmagickDraw::settextdecoration - Specifies a decoration
    • GmagickDraw::settextencoding - Specifies the text code set
    • GmagickPixel::getcolor - Returns the color
    • GmagickPixel::getcolorcount - Returns the color count associated with this color
    • GmagickPixel::getcolorvalue - Gets the normalized value of the provided color channel
    • GmagickPixel::setcolor - Sets the color
    • GmagickPixel::setcolorvalue - Sets the normalized value of one of the channels
    • GmagickPixel::__construct - The GmagickPixel constructor
    • gmdate - 格式化一个 GMT/UTC 日期／时间
    • gmmktime - 取得 GMT 日期的 UNIX 时间戳
    • gmp_abs - Absolute value
    • gmp_add - Add numbers
    • gmp_and - Bitwise AND
    • gmp_binomial - Calculates binomial coefficient
    • gmp_clrbit - Clear bit
    • gmp_cmp - Compare numbers
    • gmp_com - Calculates one's complement
    • gmp_div - 别名 gmp_div_q
    • gmp_divexact - Exact division of numbers
    • gmp_div_q - Divide numbers
    • gmp_div_qr - Divide numbers and get quotient and remainder
    • gmp_div_r - Remainder of the division of numbers
    • gmp_export - Export to a binary string
    • gmp_fact - Factorial
    • gmp_gcd - Calculate GCD
    • gmp_gcdext - Calculate GCD and multipliers
    • gmp_hamdist - Hamming distance
    • gmp_import - Import from a binary string
    • gmp_init - Create GMP number
    • gmp_intval - Convert GMP number to integer
    • gmp_invert - Inverse by modulo
    • gmp_jacobi - Jacobi symbol
    • gmp_kronecker - Kronecker symbol
    • gmp_lcm - Calculate LCM
    • gmp_legendre - Legendre symbol
    • gmp_mod - Modulo operation
    • gmp_mul - Multiply numbers
    • gmp_neg - Negate number
    • gmp_nextprime - Find next prime number
    • gmp_or - Bitwise OR
    • gmp_perfect_power - Perfect power check
    • gmp_perfect_square - Perfect square check
    • gmp_popcount - Population count
    • gmp_pow - Raise number into power
    • gmp_powm - Raise number into power with modulo
    • gmp_prob_prime - Check if number is "probably prime"
    • gmp_random - Random number
    • gmp_random_bits - Random number
    • gmp_random_range - Random number
    • gmp_random_seed - Sets the RNG seed
    • gmp_root - Take the integer part of nth root
    • gmp_rootrem - Take the integer part and remainder of nth root
    • gmp_scan0 - Scan for 0
    • gmp_scan1 - Scan for 1
    • gmp_setbit - Set bit
    • gmp_sign - Sign of number
    • gmp_sqrt - Calculate square root
    • gmp_sqrtrem - Square root with remainder
    • gmp_strval - Convert GMP number to string
    • gmp_sub - Subtract numbers
    • gmp_testbit - Tests if a bit is set
    • gmp_xor - Bitwise XOR
    • gmstrftime - 根据区域设置格式化 GMT/UTC 时间／日期
    • gnupg_adddecryptkey - Add a key for decryption
    • gnupg_addencryptkey - Add a key for encryption
    • gnupg_addsignkey - Add a key for signing
    • gnupg_cleardecryptkeys - Removes all keys which were set for decryption before
    • gnupg_clearencryptkeys - Removes all keys which were set for encryption before
    • gnupg_clearsignkeys - Removes all keys which were set for signing before
    • gnupg_decrypt - Decrypts a given text
    • gnupg_decryptverify - Decrypts and verifies a given text
    • gnupg_encrypt - Encrypts a given text
    • gnupg_encryptsign - Encrypts and signs a given text
    • gnupg_export - Exports a key
    • gnupg_geterror - Returns the errortext, if a function fails
    • gnupg_getprotocol - Returns the currently active protocol for all operations
    • gnupg_import - Imports a key
    • gnupg_init - Initialize a connection
    • gnupg_keyinfo - Returns an array with information about all keys that matches the given pattern
    • gnupg_setarmor - Toggle armored output
    • gnupg_seterrormode - Sets the mode for error_reporting
    • gnupg_setsignmode - Sets the mode for signing
    • gnupg_sign - Signs a given text
    • gnupg_verify - Verifies a signed text
    • grapheme_extract - Function to extract a sequence of default grapheme clusters from a text buffer, which must be encoded in UTF-8
    • grapheme_stripos - Find position (in grapheme units) of first occurrence of a case-insensitive string
    • grapheme_stristr - Returns part of haystack string from the first occurrence of case-insensitive needle to the end of haystack
    • grapheme_strlen - Get string length in grapheme units
    • grapheme_strpos - Find position (in grapheme units) of first occurrence of a string
    • grapheme_strripos - Find position (in grapheme units) of last occurrence of a case-insensitive string
    • grapheme_strrpos - Find position (in grapheme units) of last occurrence of a string
    • grapheme_strstr - Returns part of haystack string from the first occurrence of needle to the end of haystack
    • grapheme_substr - Return part of a string
    • GregorianToJD - 转变一个Gregorian历法日期到Julian Day计数
    • gzclose - Close an open gz-file pointer
    • gzcompress - Compress a string
    • gzdecode - Decodes a gzip compressed string
    • gzdeflate - Deflate a string
    • gzencode - Create a gzip compressed string
    • gzeof - Test for EOF on a gz-file pointer
    • gzfile - Read entire gz-file into an array
    • gzgetc - Get character from gz-file pointer
    • gzgets - Get line from file pointer
    • gzgetss - Get line from gz-file pointer and strip HTML tags
    • gzinflate - Inflate a deflated string
    • gzopen - Open gz-file
    • gzpassthru - Output all remaining data on a gz-file pointer
    • gzputs - 别名 gzwrite
    • gzread - Binary-safe gz-file read
    • gzrewind - Rewind the position of a gz-file pointer
    • gzseek - Seek on a gz-file pointer
    • gztell - Tell gz-file pointer read/write position
    • gzuncompress - Uncompress a compressed string
    • gzwrite - Binary-safe gz-file write
  • h
    • hash - 生成哈希值 （消息摘要）
    • hash_algos - 返回已注册的哈希算法列表
    • hash_copy - 拷贝哈希运算上下文
    • hash_equals - 可防止时序攻击的字符串比较
    • hash_file - 给指定文件的内容生成哈希值
    • hash_final - 结束增量哈希，并且返回摘要结果
    • hash_hkdf - Generate a HKDF key derivation of a supplied key input
    • hash_hmac - 使用 HMAC 方法生成带有密钥的哈希值
    • hash_hmac_algos - Return a list of registered hashing algorithms suitable for hash_hmac
    • hash_hmac_file - 使用 HMAC 方法和给定文件的内容生成带密钥的哈希值
    • hash_init - 初始化增量哈希运算上下文
    • hash_pbkdf2 - 生成所提供密码的 PBKDF2 密钥导出
    • hash_update - 向活跃的哈希运算上下文中填充数据
    • hash_update_file - 从文件向活跃的哈希运算上下文中填充数据
    • hash_update_stream - 从打开的流向活跃的哈希运算上下文中填充数据
    • header - 发送原生 HTTP 头
    • headers_list - 返回已发送的 HTTP 响应头（或准备发送的）
    • headers_sent - 检测 HTTP 头是否已经发送
    • header_register_callback - 调用一个 header 函数
    • header_remove - 删除之前设置的 HTTP 头
    • hebrev - 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew）
    • hebrevc - 将逻辑顺序希伯来文（logical-Hebrew）转换为视觉顺序希伯来文（visual-Hebrew），并且转换换行符
    • hex2bin - 转换十六进制字符串为二进制字符串
    • hexdec - 十六进制转换为十进制
    • highlight_file - 语法高亮一个文件
    • highlight_string - 字符串的语法高亮
    • hrtime - 获取系统的高精度时间
    • HRTime\PerformanceCounter::getFrequency - Timer frequency in ticks per second
    • HRTime\PerformanceCounter::getTicks - Current ticks from the system
    • HRTime\PerformanceCounter::getTicksSince - Ticks elapsed since the given value
    • HRTime\StopWatch::getElapsedTicks - Get elapsed ticks for all intervals
    • HRTime\StopWatch::getElapsedTime - Get elapsed time for all intervals
    • HRTime\StopWatch::getLastElapsedTicks - Get elapsed ticks for the last interval
    • HRTime\StopWatch::getLastElapsedTime - Get elapsed time for the last interval
    • HRTime\StopWatch::isRunning - Whether the measurement is running
    • HRTime\StopWatch::start - Start time measurement
    • HRTime\StopWatch::stop - Stop time measurement
    • htmlentities - 将字符转换为 HTML 转义字符
    • htmlspecialchars - 将特殊字符转换为 HTML 实体
    • htmlspecialchars_decode - 将特殊的 HTML 实体转换回普通字符
    • html_entity_decode - Convert HTML entities to their corresponding characters
    • http:// - 访问 HTTP(s) 网址
    • HTTP context 选项 - HTTP context 的选项列表
    • http_build_query - 生成 URL-encode 之后的请求字符串
    • http_response_code - 获取/设置响应的 HTTP 状态码
    • hypot - 计算一直角三角形的斜边长度
  • i
    • ibase_add_user - Add a user to a security database
    • ibase_affected_rows - Return the number of rows that were affected by the previous query
    • ibase_backup - Initiates a backup task in the service manager and returns immediately
    • ibase_blob_add - Add data into a newly created blob
    • ibase_blob_cancel - Cancel creating blob
    • ibase_blob_close - Close blob
    • ibase_blob_create - Create a new blob for adding data
    • ibase_blob_echo - Output blob contents to browser
    • ibase_blob_get - Get len bytes data from open blob
    • ibase_blob_import - Create blob, copy file in it, and close it
    • ibase_blob_info - Return blob length and other useful info
    • ibase_blob_open - Open blob for retrieving data parts
    • ibase_close - Close a connection to an InterBase database
    • ibase_commit - Commit a transaction
    • ibase_commit_ret - Commit a transaction without closing it
    • ibase_connect - Open a connection to a database
    • ibase_db_info - Request statistics about a database
    • ibase_delete_user - Delete a user from a security database
    • ibase_drop_db - Drops a database
    • ibase_errcode - Return an error code
    • ibase_errmsg - Return error messages
    • ibase_execute - Execute a previously prepared query
    • ibase_fetch_assoc - Fetch a result row from a query as an associative array
    • ibase_fetch_object - Get an object from a InterBase database
    • ibase_fetch_row - Fetch a row from an InterBase database
    • ibase_field_info - Get information about a field
    • ibase_free_event_handler - Cancels a registered event handler
    • ibase_free_query - Free memory allocated by a prepared query
    • ibase_free_result - Free a result set
    • ibase_gen_id - Increments the named generator and returns its new value
    • ibase_maintain_db - Execute a maintenance command on the database server
    • ibase_modify_user - Modify a user to a security database
    • ibase_name_result - Assigns a name to a result set
    • ibase_num_fields - Get the number of fields in a result set
    • ibase_num_params - Return the number of parameters in a prepared query
    • ibase_param_info - Return information about a parameter in a prepared query
    • ibase_pconnect - Open a persistent connection to an InterBase database
    • ibase_prepare - Prepare a query for later binding of parameter placeholders and execution
    • ibase_query - Execute a query on an InterBase database
    • ibase_restore - Initiates a restore task in the service manager and returns immediately
    • ibase_rollback - Roll back a transaction
    • ibase_rollback_ret - Roll back a transaction without closing it
    • ibase_server_info - Request information about a database server
    • ibase_service_attach - Connect to the service manager
    • ibase_service_detach - Disconnect from the service manager
    • ibase_set_event_handler - Register a callback function to be called when events are posted
    • ibase_trans - Begin a transaction
    • ibase_wait_event - Wait for an event to be posted by the database
    • iconv - 字符串按要求的字符编码来转换
    • iconv_get_encoding - 获取 iconv 扩展的内部配置变量
    • iconv_mime_decode - 解码一个MIME头字段
    • iconv_mime_decode_headers - 一次性解码多个 MIME 头字段
    • iconv_mime_encode - Composes a MIME header field
    • iconv_set_encoding - 为字符编码转换设定当前设置
    • iconv_strlen - 返回字符串的字符数统计
    • iconv_strpos - Finds position of first occurrence of a needle within a haystack
    • iconv_strrpos - Finds the last occurrence of a needle within a haystack
    • iconv_substr - 截取字符串的部分
    • idate - 将本地时间日期格式化为整数
    • idn_to_ascii - 将域名转换为 IDNA ASCII 格式
    • idn_to_utf8 - 将域名从 IDNA ASCII 转换为 Unicode
    • ignore_user_abort - 设置客户端断开连接时是否中断脚本的执行
    • image2wbmp - 以 WBMP 格式将图像输出到浏览器或文件
    • imageaffine - 返回经过仿射变换后的图像，剪切区域可选
    • imageaffinematrixconcat - Concatenate two affine transformation matrices
    • imageaffinematrixget - Get an affine transformation matrix
    • imagealphablending - 设定图像的混色模式
    • imageantialias - 是否使用抗锯齿（antialias）功能
    • imagearc - 画椭圆弧
    • imagebmp - Output a BMP image to browser or file
    • imagechar - 水平地画一个字符
    • imagecharup - 垂直地画一个字符
    • imagecolorallocate - 为一幅图像分配颜色
    • imagecolorallocatealpha - 为一幅图像分配颜色 + alpha
    • imagecolorat - 取得某像素的颜色索引值
    • imagecolorclosest - 取得与指定的颜色最接近的颜色的索引值
    • imagecolorclosestalpha - 取得与指定的颜色加透明度最接近的颜色
    • imagecolorclosesthwb - 取得与给定颜色最接近的色度的黑白色的索引
    • imagecolordeallocate - 取消图像颜色的分配
    • imagecolorexact - 取得指定颜色的索引值
    • imagecolorexactalpha - 取得指定的颜色加透明度的索引值
    • imagecolormatch - 使一个图像中调色板版本的颜色与真彩色版本更能匹配
    • imagecolorresolve - 取得指定颜色的索引值或有可能得到的最接近的替代值
    • imagecolorresolvealpha - 取得指定颜色 + alpha 的索引值或有可能得到的最接近的替代值
    • imagecolorset - 给指定调色板索引设定颜色
    • imagecolorsforindex - 取得某索引的颜色
    • imagecolorstotal - 取得一幅图像的调色板中颜色的数目
    • imagecolortransparent - 将某个颜色定义为透明色
    • imageconvolution - 用系数 div 和 offset 申请一个 3x3 的卷积矩阵
    • imagecopy - 拷贝图像的一部分
    • imagecopymerge - 拷贝并合并图像的一部分
    • imagecopymergegray - 用灰度拷贝并合并图像的一部分
    • imagecopyresampled - 重采样拷贝部分图像并调整大小
    • imagecopyresized - 拷贝部分图像并调整大小
    • imagecreate - 新建一个基于调色板的图像
    • imagecreatefrombmp - 由文件或 URL 创建一个新图象。
    • imagecreatefromgd - 从 GD 文件或 URL 新建一图像
    • imagecreatefromgd2 - 从 GD2 文件或 URL 新建一图像
    • imagecreatefromgd2part - 从给定的 GD2 文件或 URL 中的部分新建一图像
    • imagecreatefromgif - 由文件或 URL 创建一个新图象。
    • imagecreatefromjpeg - 由文件或 URL 创建一个新图象。
    • imagecreatefrompng - 由文件或 URL 创建一个新图象。
    • imagecreatefromstring - 从字符串中的图像流新建一图像
    • imagecreatefromwbmp - 由文件或 URL 创建一个新图象。
    • imagecreatefromwebp - 由文件或 URL 创建一个新图象。
    • imagecreatefromxbm - 由文件或 URL 创建一个新图象。
    • imagecreatefromxpm - 由文件或 URL 创建一个新图象。
    • imagecreatetruecolor - 新建一个真彩色图像
    • imagecrop - Crop an image to the given rectangle
    • imagecropauto - Crop an image automatically using one of the available modes
    • imagedashedline - 画一虚线
    • imagedestroy - 销毁一图像
    • imageellipse - 画一个椭圆
    • imagefill - 区域填充
    • imagefilledarc - 画一椭圆弧且填充
    • imagefilledellipse - 画一椭圆并填充
    • imagefilledpolygon - 画一多边形并填充
    • imagefilledrectangle - 画一矩形并填充
    • imagefilltoborder - 区域填充到指定颜色的边界为止
    • imagefilter - 对图像使用过滤器
    • imageflip - Flips an image using a given mode
    • imagefontheight - 取得字体高度
    • imagefontwidth - 取得字体宽度
    • imageftbbox - 给出一个使用 FreeType 2 字体的文本框
    • imagefttext - 使用 FreeType 2 字体将文本写入图像
    • imagegammacorrect - 对 GD 图像应用 gamma 修正
    • imagegd - 将 GD 图像输出到浏览器或文件
    • imagegd2 - 将 GD2 图像输出到浏览器或文件
    • imagegetclip - Get the clipping rectangle
    • imagegetinterpolation - Get the interpolation method
    • imagegif - 输出图象到浏览器或文件。
    • imagegrabscreen - Captures the whole screen
    • imagegrabwindow - Captures a window
    • imageinterlace - 启用或禁用隔行扫描
    • imageistruecolor - 检查图像是否为真彩色图像
    • imagejpeg - 输出图象到浏览器或文件。
    • imagelayereffect - 设定 alpha 混色标志以使用绑定的 libgd 分层效果
    • imageline - 画一条线段
    • imageloadfont - 载入一新字体
    • imageopenpolygon - Draws an open polygon
    • imagepalettecopy - 将调色板从一幅图像拷贝到另一幅
    • imagepalettetotruecolor - Converts a palette based image to true color
    • imagepng - 以 PNG 格式将图像输出到浏览器或文件
    • imagepolygon - 画一个多边形
    • imagerectangle - 画一个矩形
    • imageresolution - Get or set the resolution of the image
    • imagerotate - 用给定角度旋转图像
    • imagesavealpha - 设置标记以在保存 PNG 图像时保存完整的 alpha 通道信息（与单一透明色相反）
    • imagescale - Scale an image using the given new width and height
    • imagesetbrush - 设定画线用的画笔图像
    • imagesetclip - Set the clipping rectangle
    • imagesetinterpolation - Set the interpolation method
    • imagesetpixel - 画一个单一像素
    • imagesetstyle - 设定画线的风格
    • imagesetthickness - 设定画线的宽度
    • imagesettile - 设定用于填充的贴图
    • imagestring - 水平地画一行字符串
    • imagestringup - 垂直地画一行字符串
    • imagesx - 取得图像宽度
    • imagesy - 取得图像高度
    • imagetruecolortopalette - 将真彩色图像转换为调色板图像
    • imagettfbbox - 取得使用 TrueType 字体的文本的范围
    • imagettftext - 用 TrueType 字体向图像写入文本
    • imagetypes - 返回当前 PHP 版本所支持的图像类型
    • imagewbmp - 以 WBMP 格式将图像输出到浏览器或文件
    • imagewebp - 将 WebP 格式的图像输出到浏览器或文件
    • imagexbm - 将 XBM 图像输出到浏览器或文件
    • image_type_to_extension - 取得图像类型的文件后缀
    • image_type_to_mime_type - 取得 getimagesize，exif_read_data，exif_thumbnail，exif_imagetype 所返回的图像类型的 MIME 类型
    • Imagick::adaptiveBlurImage - Adds adaptive blur filter to image
    • Imagick::adaptiveResizeImage - Adaptively resize image with data dependent triangulation
    • Imagick::adaptiveSharpenImage - Adaptively sharpen the image
    • Imagick::adaptiveThresholdImage - Selects a threshold for each pixel based on a range of intensity
    • Imagick::addImage - Adds new image to Imagick object image list
    • Imagick::addNoiseImage - Adds random noise to the image
    • Imagick::affineTransformImage - Transforms an image
    • Imagick::animateImages - Animates an image or images
    • Imagick::annotateImage - Annotates an image with text
    • Imagick::appendImages - Append a set of images
    • Imagick::autoLevelImage - Description
    • Imagick::averageImages - Average a set of images
    • Imagick::blackThresholdImage - Forces all pixels below the threshold into black
    • Imagick::blueShiftImage - Description
    • Imagick::blurImage - Adds blur filter to image
    • Imagick::borderImage - Surrounds the image with a border
    • Imagick::brightnessContrastImage - Description
    • Imagick::charcoalImage - Simulates a charcoal drawing
    • Imagick::chopImage - Removes a region of an image and trims
    • Imagick::clampImage - Description
    • Imagick::clear - Clears all resources associated to Imagick object
    • Imagick::clipImage - Clips along the first path from the 8BIM profile
    • Imagick::clipImagePath - Description
    • Imagick::clipPathImage - Clips along the named paths from the 8BIM profile
    • Imagick::clone - Makes an exact copy of the Imagick object
    • Imagick::clutImage - Replaces colors in the image
    • Imagick::coalesceImages - Composites a set of images
    • Imagick::colorFloodfillImage - Changes the color value of any pixel that matches target
    • Imagick::colorizeImage - Blends the fill color with the image
    • Imagick::colorMatrixImage - Description
    • Imagick::combineImages - Combines one or more images into a single image
    • Imagick::commentImage - Adds a comment to your image
    • Imagick::compareImageChannels - Returns the difference in one or more images
    • Imagick::compareImageLayers - Returns the maximum bounding region between images
    • Imagick::compareImages - Compares an image to a reconstructed image
    • Imagick::compositeImage - 把一张图合并到一张图
    • Imagick::contrastImage - Change the contrast of the image
    • Imagick::contrastStretchImage - Enhances the contrast of a color image
    • Imagick::convolveImage - Applies a custom convolution kernel to the image
    • Imagick::count - Get the number of images
    • Imagick::cropImage - 截图图片的一块区域
    • Imagick::cropThumbnailImage - 创建缩略图
    • Imagick::current - Returns a reference to the current Imagick object
    • Imagick::cycleColormapImage - Displaces an image's colormap
    • Imagick::decipherImage - Deciphers an image
    • Imagick::deconstructImages - Returns certain pixel differences between images
    • Imagick::deleteImageArtifact - Delete image artifact
    • Imagick::deleteImageProperty - Description
    • Imagick::deskewImage - Removes skew from the image
    • Imagick::despeckleImage - Reduces the speckle noise in an image
    • Imagick::destroy - Destroys the Imagick object
    • Imagick::displayImage - Displays an image
    • Imagick::displayImages - Displays an image or image sequence
    • Imagick::distortImage - Distorts an image using various distortion methods
    • Imagick::drawImage - 把 ImagickDraw 对象渲染到当前图片上
    • Imagick::edgeImage - Enhance edges within the image
    • Imagick::embossImage - Returns a grayscale image with a three-dimensional effect
    • Imagick::encipherImage - Enciphers an image
    • Imagick::enhanceImage - Improves the quality of a noisy image
    • Imagick::equalizeImage - Equalizes the image histogram
    • Imagick::evaluateImage - Applies an expression to an image
    • Imagick::exportImagePixels - Exports raw image pixels
    • Imagick::extentImage - Set image size
    • Imagick::filter - Description
    • Imagick::flattenImages - Merges a sequence of images
    • Imagick::flipImage - Creates a vertical mirror image
    • Imagick::floodFillPaintImage - Changes the color value of any pixel that matches target
    • Imagick::flopImage - Creates a vertical mirror image
    • Imagick::forwardFourierTransformImage - Description
    • Imagick::frameImage - Adds a simulated three-dimensional border
    • Imagick::functionImage - Applies a function on the image
    • Imagick::fxImage - Evaluate expression for each pixel in the image
    • Imagick::gammaImage - Gamma-corrects an image
    • Imagick::gaussianBlurImage - Blurs an image
    • Imagick::getColorspace - Gets the colorspace
    • Imagick::getCompression - Gets the object compression type
    • Imagick::getCompressionQuality - Gets the object compression quality
    • Imagick::getCopyright - Returns the ImageMagick API copyright as a string
    • Imagick::getFilename - The filename associated with an image sequence
    • Imagick::getFont - Gets font
    • Imagick::getFormat - Returns the format of the Imagick object
    • Imagick::getGravity - Gets the gravity
    • Imagick::getHomeURL - Returns the ImageMagick home URL
    • Imagick::getImage - Returns a new Imagick object
    • Imagick::getImageAlphaChannel - 获取图像的 alpha 通道
    • Imagick::getImageArtifact - Get image artifact
    • Imagick::getImageAttribute - Description
    • Imagick::getImageBackgroundColor - Returns the image background color
    • Imagick::getImageBlob - Returns the image sequence as a blob
    • Imagick::getImageBluePrimary - Returns the chromaticy blue primary point
    • Imagick::getImageBorderColor - Returns the image border color
    • Imagick::getImageChannelDepth - Gets the depth for a particular image channel
    • Imagick::getImageChannelDistortion - Compares image channels of an image to a reconstructed image
    • Imagick::getImageChannelDistortions - Gets channel distortions
    • Imagick::getImageChannelExtrema - Gets the extrema for one or more image channels
    • Imagick::getImageChannelKurtosis - The getImageChannelKurtosis purpose
    • Imagick::getImageChannelMean - Gets the mean and standard deviation
    • Imagick::getImageChannelRange - Gets channel range
    • Imagick::getImageChannelStatistics - Returns statistics for each channel in the image
    • Imagick::getImageClipMask - Gets image clip mask
    • Imagick::getImageColormapColor - Returns the color of the specified colormap index
    • Imagick::getImageColors - Gets the number of unique colors in the image
    • Imagick::getImageColorspace - Gets the image colorspace
    • Imagick::getImageCompose - Returns the composite operator associated with the image
    • Imagick::getImageCompression - Gets the current image's compression type
    • Imagick::getImageCompressionQuality - Gets the current image's compression quality
    • Imagick::getImageDelay - Gets the image delay
    • Imagick::getImageDepth - Gets the image depth
    • Imagick::getImageDispose - Gets the image disposal method
    • Imagick::getImageDistortion - Compares an image to a reconstructed image
    • Imagick::getImageExtrema - Gets the extrema for the image
    • Imagick::getImageFilename - Returns the filename of a particular image in a sequence
    • Imagick::getImageFormat - Returns the format of a particular image in a sequence
    • Imagick::getImageGamma - Gets the image gamma
    • Imagick::getImageGeometry - Gets the width and height as an associative array
    • Imagick::getImageGravity - Gets the image gravity
    • Imagick::getImageGreenPrimary - Returns the chromaticy green primary point
    • Imagick::getImageHeight - Returns the image height
    • Imagick::getImageHistogram - Gets the image histogram
    • Imagick::getImageIndex - Gets the index of the current active image
    • Imagick::getImageInterlaceScheme - Gets the image interlace scheme
    • Imagick::getImageInterpolateMethod - Returns the interpolation method
    • Imagick::getImageIterations - Gets the image iterations
    • Imagick::getImageLength - Returns the image length in bytes
    • Imagick::getImageMatte - Return if the image has a matte channel
    • Imagick::getImageMatteColor - Returns the image matte color
    • Imagick::getImageMimeType - Description
    • Imagick::getImageOrientation - Gets the image orientation
    • Imagick::getImagePage - Returns the page geometry
    • Imagick::getImagePixelColor - Returns the color of the specified pixel
    • Imagick::getImageProfile - Returns the named image profile
    • Imagick::getImageProfiles - Returns the image profiles
    • Imagick::getImageProperties - Returns the image properties
    • Imagick::getImageProperty - Returns the named image property
    • Imagick::getImageRedPrimary - Returns the chromaticity red primary point
    • Imagick::getImageRegion - Extracts a region of the image
    • Imagick::getImageRenderingIntent - Gets the image rendering intent
    • Imagick::getImageResolution - 获取图像的x,y轴分辨率
    • Imagick::getImagesBlob - Returns all image sequences as a blob
    • Imagick::getImageScene - Gets the image scene
    • Imagick::getImageSignature - Generates an SHA-256 message digest
    • Imagick::getImageSize - Returns the image length in bytes
    • Imagick::getImageTicksPerSecond - Gets the image ticks-per-second
    • Imagick::getImageTotalInkDensity - Gets the image total ink density
    • Imagick::getImageType - Gets the potential image type
    • Imagick::getImageUnits - 获取图像的分辨率单位
    • Imagick::getImageVirtualPixelMethod - Returns the virtual pixel method
    • Imagick::getImageWhitePoint - Returns the chromaticity white point
    • Imagick::getImageWidth - Returns the image width
    • Imagick::getInterlaceScheme - Gets the object interlace scheme
    • Imagick::getIteratorIndex - Gets the index of the current active image
    • Imagick::getNumberImages - Returns the number of images in the object
    • Imagick::getOption - Returns a value associated with the specified key
    • Imagick::getPackageName - Returns the ImageMagick package name
    • Imagick::getPage - Returns the page geometry
    • Imagick::getPixelIterator - Returns a MagickPixelIterator
    • Imagick::getPixelRegionIterator - Get an ImagickPixelIterator for an image section
    • Imagick::getPointSize - Gets point size
    • Imagick::getQuantum - Description
    • Imagick::getQuantumDepth - Gets the quantum depth
    • Imagick::getQuantumRange - Returns the Imagick quantum range
    • Imagick::getRegistry - Description
    • Imagick::getReleaseDate - Returns the ImageMagick release date
    • Imagick::getResource - Returns the specified resource's memory usage
    • Imagick::getResourceLimit - Returns the specified resource limit
    • Imagick::getSamplingFactors - Gets the horizontal and vertical sampling factor
    • Imagick::getSize - Returns the size associated with the Imagick object
    • Imagick::getSizeOffset - Returns the size offset
    • Imagick::getVersion - Returns the ImageMagick API version
    • Imagick::haldClutImage - Replaces colors in the image
    • Imagick::hasNextImage - Checks if the object has more images
    • Imagick::hasPreviousImage - Checks if the object has a previous image
    • Imagick::identifyFormat - Description
    • Imagick::identifyImage - Identifies an image and fetches attributes
    • Imagick::implodeImage - Creates a new image as a copy
    • Imagick::importImagePixels - Imports image pixels
    • Imagick::inverseFourierTransformImage - Description
    • Imagick::labelImage - Adds a label to an image
    • Imagick::levelImage - Adjusts the levels of an image
    • Imagick::linearStretchImage - Stretches with saturation the image intensity
    • Imagick::liquidRescaleImage - Animates an image or images
    • Imagick::listRegistry - Description
    • Imagick::magnifyImage - Scales an image proportionally 2x
    • Imagick::mapImage - Replaces the colors of an image with the closest color from a reference image
    • Imagick::matteFloodfillImage - Changes the transparency value of a color
    • Imagick::medianFilterImage - Applies a digital filter
    • Imagick::mergeImageLayers - Merges image layers
    • Imagick::minifyImage - Scales an image proportionally to half its size
    • Imagick::modulateImage - Control the brightness, saturation, and hue
    • Imagick::montageImage - Creates a composite image
    • Imagick::morphImages - Method morphs a set of images
    • Imagick::morphology - Description
    • Imagick::mosaicImages - Forms a mosaic from images
    • Imagick::motionBlurImage - Simulates motion blur
    • Imagick::negateImage - Negates the colors in the reference image
    • Imagick::newImage - 创建一张图片
    • Imagick::newPseudoImage - Creates a new image
    • Imagick::nextImage - Moves to the next image
    • Imagick::normalizeImage - Enhances the contrast of a color image
    • Imagick::oilPaintImage - Simulates an oil painting
    • Imagick::opaquePaintImage - Changes the color value of any pixel that matches target
    • Imagick::optimizeImageLayers - Removes repeated portions of images to optimize
    • Imagick::orderedPosterizeImage - Performs an ordered dither
    • Imagick::paintFloodfillImage - Changes the color value of any pixel that matches target
    • Imagick::paintOpaqueImage - Change any pixel that matches color
    • Imagick::paintTransparentImage - Changes any pixel that matches color with the color defined by fill
    • Imagick::pingImage - Fetch basic attributes about the image
    • Imagick::pingImageBlob - Quickly fetch attributes
    • Imagick::pingImageFile - Get basic image attributes in a lightweight manner
    • Imagick::polaroidImage - Simulates a Polaroid picture
    • Imagick::posterizeImage - Reduces the image to a limited number of color level
    • Imagick::previewImages - Quickly pin-point appropriate parameters for image processing
    • Imagick::previousImage - Move to the previous image in the object
    • Imagick::profileImage - Adds or removes a profile from an image
    • Imagick::quantizeImage - Analyzes the colors within a reference image
    • Imagick::quantizeImages - Analyzes the colors within a sequence of images
    • Imagick::queryFontMetrics - Returns an array representing the font metrics
    • Imagick::queryFonts - Returns the configured fonts
    • Imagick::queryFormats - Returns formats supported by Imagick
    • Imagick::radialBlurImage - Radial blurs an image
    • Imagick::raiseImage - Creates a simulated 3d button-like effect
    • Imagick::randomThresholdImage - Creates a high-contrast, two-color image
    • Imagick::readImage - Reads image from filename
    • Imagick::readImageBlob - 从二进制字符串里读取图片
    • Imagick::readImageFile - Reads image from open filehandle
    • Imagick::readimages - Description
    • Imagick::recolorImage - Recolors image
    • Imagick::reduceNoiseImage - Smooths the contours of an image
    • Imagick::remapImage - Remaps image colors
    • Imagick::removeImage - Removes an image from the image list
    • Imagick::removeImageProfile - Removes the named image profile and returns it
    • Imagick::render - Renders all preceding drawing commands
    • Imagick::resampleImage - Resample image to desired resolution
    • Imagick::resetImagePage - Reset image page
    • Imagick::resizeImage - Scales an image
    • Imagick::rollImage - Offsets an image
    • Imagick::rotateImage - Rotates an image
    • Imagick::rotationalBlurImage - Description
    • Imagick::roundCorners - Rounds image corners
    • Imagick::sampleImage - Scales an image with pixel sampling
    • Imagick::scaleImage - Scales the size of an image
    • Imagick::segmentImage - Segments an image
    • Imagick::selectiveBlurImage - Description
    • Imagick::separateImageChannel - Separates a channel from the image
    • Imagick::sepiaToneImage - Sepia tones an image
    • Imagick::setBackgroundColor - Sets the object's default background color
    • Imagick::setColorspace - Set colorspace
    • Imagick::setCompression - Sets the object's default compression type
    • Imagick::setCompressionQuality - Sets the object's default compression quality
    • Imagick::setFilename - Sets the filename before you read or write the image
    • Imagick::setFirstIterator - Sets the Imagick iterator to the first image
    • Imagick::setFont - Sets font
    • Imagick::setFormat - Sets the format of the Imagick object
    • Imagick::setGravity - Sets the gravity
    • Imagick::setImage - Replaces image in the object
    • Imagick::setImageAlphaChannel - Sets image alpha channel
    • Imagick::setImageArtifact - Set image artifact
    • Imagick::setImageAttribute - Description
    • Imagick::setImageBackgroundColor - Sets the image background color
    • Imagick::setImageBias - Sets the image bias for any method that convolves an image
    • Imagick::setImageBiasQuantum - Description
    • Imagick::setImageBluePrimary - Sets the image chromaticity blue primary point
    • Imagick::setImageBorderColor - Sets the image border color
    • Imagick::setImageChannelDepth - Sets the depth of a particular image channel
    • Imagick::setImageClipMask - Sets image clip mask
    • Imagick::setImageColormapColor - Sets the color of the specified colormap index
    • Imagick::setImageColorspace - Sets the image colorspace
    • Imagick::setImageCompose - Sets the image composite operator
    • Imagick::setImageCompression - 设置图片压缩的类型
    • Imagick::setImageCompressionQuality - 设置图片压缩的质量
    • Imagick::setImageDelay - Sets the image delay
    • Imagick::setImageDepth - Sets the image depth
    • Imagick::setImageDispose - Sets the image disposal method
    • Imagick::setImageExtent - Sets the image size
    • Imagick::setImageFilename - Sets the filename of a particular image
    • Imagick::setImageFormat - 为图片设置指定的格式
    • Imagick::setImageGamma - Sets the image gamma
    • Imagick::setImageGravity - Sets the image gravity
    • Imagick::setImageGreenPrimary - Sets the image chromaticity green primary point
    • Imagick::setImageIndex - Set the iterator position
    • Imagick::setImageInterlaceScheme - Sets the image compression
    • Imagick::setImageInterpolateMethod - Sets the image interpolate pixel method
    • Imagick::setImageIterations - Sets the image iterations
    • Imagick::setImageMatte - Sets the image matte channel
    • Imagick::setImageMatteColor - Sets the image matte color
    • Imagick::setImageOpacity - Sets the image opacity level
    • Imagick::setImageOrientation - Sets the image orientation
    • Imagick::setImagePage - Sets the page geometry of the image
    • Imagick::setImageProfile - Adds a named profile to the Imagick object
    • Imagick::setImageProperty - Sets an image property
    • Imagick::setImageRedPrimary - Sets the image chromaticity red primary point
    • Imagick::setImageRenderingIntent - Sets the image rendering intent
    • Imagick::setImageResolution - Sets the image resolution
    • Imagick::setImageScene - Sets the image scene
    • Imagick::setImageTicksPerSecond - Sets the image ticks-per-second
    • Imagick::setImageType - Sets the image type
    • Imagick::setImageUnits - Sets the image units of resolution
    • Imagick::setImageVirtualPixelMethod - Sets the image virtual pixel method
    • Imagick::setImageWhitePoint - Sets the image chromaticity white point
    • Imagick::setInterlaceScheme - Sets the image compression
    • Imagick::setIteratorIndex - Set the iterator position
    • Imagick::setLastIterator - Sets the Imagick iterator to the last image
    • Imagick::setOption - Set an option
    • Imagick::setPage - Sets the page geometry of the Imagick object
    • Imagick::setPointSize - Sets point size
    • Imagick::setProgressMonitor - Description
    • Imagick::setRegistry - Description
    • Imagick::setResolution - Sets the image resolution
    • Imagick::setResourceLimit - Sets the limit for a particular resource
    • Imagick::setSamplingFactors - Sets the image sampling factors
    • Imagick::setSize - Sets the size of the Imagick object
    • Imagick::setSizeOffset - Sets the size and offset of the Imagick object
    • Imagick::setType - Sets the image type attribute
    • Imagick::shadeImage - Creates a 3D effect
    • Imagick::shadowImage - Simulates an image shadow
    • Imagick::sharpenImage - Sharpens an image
    • Imagick::shaveImage - Shaves pixels from the image edges
    • Imagick::shearImage - Creating a parallelogram
    • Imagick::sigmoidalContrastImage - Adjusts the contrast of an image
    • Imagick::sketchImage - Simulates a pencil sketch
    • Imagick::smushImages - Description
    • Imagick::solarizeImage - Applies a solarizing effect to the image
    • Imagick::sparseColorImage - Interpolates colors
    • Imagick::spliceImage - Splices a solid color into the image
    • Imagick::spreadImage - Randomly displaces each pixel in a block
    • Imagick::statisticImage - Description
    • Imagick::steganoImage - Hides a digital watermark within the image
    • Imagick::stereoImage - Composites two images
    • Imagick::stripImage - 去掉图片的所有配置和设置
    • Imagick::subImageMatch - Description
    • Imagick::swirlImage - Swirls the pixels about the center of the image
    • Imagick::textureImage - Repeatedly tiles the texture image
    • Imagick::thresholdImage - Changes the value of individual pixels based on a threshold
    • Imagick::thumbnailImage - Changes the size of an image
    • Imagick::tintImage - Applies a color vector to each pixel in the image
    • Imagick::transformImage - Convenience method for setting crop size and the image geometry
    • Imagick::transformImageColorspace - Transforms an image to a new colorspace
    • Imagick::transparentPaintImage - Paints pixels transparent
    • Imagick::transposeImage - Creates a vertical mirror image
    • Imagick::transverseImage - Creates a horizontal mirror image
    • Imagick::trimImage - Remove edges from the image
    • Imagick::uniqueImageColors - Discards all but one of any pixel color
    • Imagick::unsharpMaskImage - Sharpens an image
    • Imagick::valid - Checks if the current item is valid
    • Imagick::vignetteImage - Adds vignette filter to the image
    • Imagick::waveImage - Applies wave filter to the image
    • Imagick::whiteThresholdImage - Force all pixels above the threshold into white
    • Imagick::writeImage - 把图片写入指定的文件
    • Imagick::writeImageFile - Writes an image to a filehandle
    • Imagick::writeImages - Writes an image or image sequence
    • Imagick::writeImagesFile - Writes frames to a filehandle
    • Imagick::__construct - The Imagick constructor
    • Imagick::__toString - Returns the image as a string
    • ImagickDraw::affine - Adjusts the current affine transformation matrix
    • ImagickDraw::annotation - Draws text on the image
    • ImagickDraw::arc - Draws an arc
    • ImagickDraw::bezier - Draws a bezier curve
    • ImagickDraw::circle - Draws a circle
    • ImagickDraw::clear - Clears the ImagickDraw
    • ImagickDraw::clone - Makes an exact copy of the specified ImagickDraw object
    • ImagickDraw::color - Draws color on image
    • ImagickDraw::comment - Adds a comment
    • ImagickDraw::composite - Composites an image onto the current image
    • ImagickDraw::destroy - Frees all associated resources
    • ImagickDraw::ellipse - Draws an ellipse on the image
    • ImagickDraw::getClipPath - Obtains the current clipping path ID
    • ImagickDraw::getClipRule - Returns the current polygon fill rule
    • ImagickDraw::getClipUnits - Returns the interpretation of clip path units
    • ImagickDraw::getFillColor - Returns the fill color
    • ImagickDraw::getFillOpacity - Returns the opacity used when drawing
    • ImagickDraw::getFillRule - Returns the fill rule
    • ImagickDraw::getFont - Returns the font
    • ImagickDraw::getFontFamily - Returns the font family
    • ImagickDraw::getFontSize - Returns the font pointsize
    • ImagickDraw::getFontStretch - Description
    • ImagickDraw::getFontStyle - Returns the font style
    • ImagickDraw::getFontWeight - Returns the font weight
    • ImagickDraw::getGravity - Returns the text placement gravity
    • ImagickDraw::getStrokeAntialias - Returns the current stroke antialias setting
    • ImagickDraw::getStrokeColor - Returns the color used for stroking object outlines
    • ImagickDraw::getStrokeDashArray - Returns an array representing the pattern of dashes and gaps used to stroke paths
    • ImagickDraw::getStrokeDashOffset - Returns the offset into the dash pattern to start the dash
    • ImagickDraw::getStrokeLineCap - Returns the shape to be used at the end of open subpaths when they are stroked
    • ImagickDraw::getStrokeLineJoin - Returns the shape to be used at the corners of paths when they are stroked
    • ImagickDraw::getStrokeMiterLimit - Returns the stroke miter limit
    • ImagickDraw::getStrokeOpacity - Returns the opacity of stroked object outlines
    • ImagickDraw::getStrokeWidth - Returns the width of the stroke used to draw object outlines
    • ImagickDraw::getTextAlignment - Returns the text alignment
    • ImagickDraw::getTextAntialias - Returns the current text antialias setting
    • ImagickDraw::getTextDecoration - Returns the text decoration
    • ImagickDraw::getTextEncoding - Returns the code set used for text annotations
    • ImagickDraw::getTextInterlineSpacing - Description
    • ImagickDraw::getTextInterwordSpacing - Description
    • ImagickDraw::getTextKerning - Description
    • ImagickDraw::getTextUnderColor - Returns the text under color
    • ImagickDraw::getVectorGraphics - Returns a string containing vector graphics
    • ImagickDraw::line - Draws a line
    • ImagickDraw::matte - Paints on the image's opacity channel
    • ImagickDraw::pathClose - Adds a path element to the current path
    • ImagickDraw::pathCurveToAbsolute - Draws a cubic Bezier curve
    • ImagickDraw::pathCurveToQuadraticBezierAbsolute - Draws a quadratic Bezier curve
    • ImagickDraw::pathCurveToQuadraticBezierRelative - Draws a quadratic Bezier curve
    • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute - Draws a quadratic Bezier curve
    • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative - Draws a quadratic Bezier curve
    • ImagickDraw::pathCurveToRelative - Draws a cubic Bezier curve
    • ImagickDraw::pathCurveToSmoothAbsolute - Draws a cubic Bezier curve
    • ImagickDraw::pathCurveToSmoothRelative - Draws a cubic Bezier curve
    • ImagickDraw::pathEllipticArcAbsolute - Draws an elliptical arc
    • ImagickDraw::pathEllipticArcRelative - Draws an elliptical arc
    • ImagickDraw::pathFinish - Terminates the current path
    • ImagickDraw::pathLineToAbsolute - Draws a line path
    • ImagickDraw::pathLineToHorizontalAbsolute - Draws a horizontal line path
    • ImagickDraw::pathLineToHorizontalRelative - Draws a horizontal line
    • ImagickDraw::pathLineToRelative - Draws a line path
    • ImagickDraw::pathLineToVerticalAbsolute - Draws a vertical line
    • ImagickDraw::pathLineToVerticalRelative - Draws a vertical line path
    • ImagickDraw::pathMoveToAbsolute - Starts a new sub-path
    • ImagickDraw::pathMoveToRelative - Starts a new sub-path
    • ImagickDraw::pathStart - Declares the start of a path drawing list
    • ImagickDraw::point - Draws a point
    • ImagickDraw::polygon - Draws a polygon
    • ImagickDraw::polyline - Draws a polyline
    • ImagickDraw::pop - Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw
    • ImagickDraw::popClipPath - Terminates a clip path definition
    • ImagickDraw::popDefs - Terminates a definition list
    • ImagickDraw::popPattern - Terminates a pattern definition
    • ImagickDraw::push - Clones the current ImagickDraw and pushes it to the stack
    • ImagickDraw::pushClipPath - Starts a clip path definition
    • ImagickDraw::pushDefs - Indicates that following commands create named elements for early processing
    • ImagickDraw::pushPattern - Indicates that subsequent commands up to a ImagickDraw::opPattern() command comprise the definition of a named pattern
    • ImagickDraw::rectangle - Draws a rectangle
    • ImagickDraw::render - Renders all preceding drawing commands onto the image
    • ImagickDraw::resetVectorGraphics - Description
    • ImagickDraw::rotate - Applies the specified rotation to the current coordinate space
    • ImagickDraw::roundRectangle - Draws a rounded rectangle
    • ImagickDraw::scale - Adjusts the scaling factor
    • ImagickDraw::setClipPath - Associates a named clipping path with the image
    • ImagickDraw::setClipRule - Set the polygon fill rule to be used by the clipping path
    • ImagickDraw::setClipUnits - Sets the interpretation of clip path units
    • ImagickDraw::setFillAlpha - Sets the opacity to use when drawing using the fill color or fill texture
    • ImagickDraw::setFillColor - Sets the fill color to be used for drawing filled objects
    • ImagickDraw::setFillOpacity - Sets the opacity to use when drawing using the fill color or fill texture
    • ImagickDraw::setFillPatternURL - Sets the URL to use as a fill pattern for filling objects
    • ImagickDraw::setFillRule - Sets the fill rule to use while drawing polygons
    • ImagickDraw::setFont - Sets the fully-specified font to use when annotating with text
    • ImagickDraw::setFontFamily - Sets the font family to use when annotating with text
    • ImagickDraw::setFontSize - Sets the font pointsize to use when annotating with text
    • ImagickDraw::setFontStretch - Sets the font stretch to use when annotating with text
    • ImagickDraw::setFontStyle - Sets the font style to use when annotating with text
    • ImagickDraw::setFontWeight - Sets the font weight
    • ImagickDraw::setGravity - Sets the text placement gravity
    • ImagickDraw::setResolution - Description
    • ImagickDraw::setStrokeAlpha - Specifies the opacity of stroked object outlines
    • ImagickDraw::setStrokeAntialias - Controls whether stroked outlines are antialiased
    • ImagickDraw::setStrokeColor - Sets the color used for stroking object outlines
    • ImagickDraw::setStrokeDashArray - Specifies the pattern of dashes and gaps used to stroke paths
    • ImagickDraw::setStrokeDashOffset - Specifies the offset into the dash pattern to start the dash
    • ImagickDraw::setStrokeLineCap - Specifies the shape to be used at the end of open subpaths when they are stroked
    • ImagickDraw::setStrokeLineJoin - Specifies the shape to be used at the corners of paths when they are stroked
    • ImagickDraw::setStrokeMiterLimit - Specifies the miter limit
    • ImagickDraw::setStrokeOpacity - Specifies the opacity of stroked object outlines
    • ImagickDraw::setStrokePatternURL - Sets the pattern used for stroking object outlines
    • ImagickDraw::setStrokeWidth - Sets the width of the stroke used to draw object outlines
    • ImagickDraw::setTextAlignment - Specifies a text alignment
    • ImagickDraw::setTextAntialias - Controls whether text is antialiased
    • ImagickDraw::setTextDecoration - Specifies a decoration
    • ImagickDraw::setTextEncoding - Specifies the text code set
    • ImagickDraw::setTextInterlineSpacing - Description
    • ImagickDraw::setTextInterwordSpacing - Description
    • ImagickDraw::setTextKerning - Description
    • ImagickDraw::setTextUnderColor - Specifies the color of a background rectangle
    • ImagickDraw::setVectorGraphics - Sets the vector graphics
    • ImagickDraw::setViewbox - Sets the overall canvas size
    • ImagickDraw::skewX - Skews the current coordinate system in the horizontal direction
    • ImagickDraw::skewY - Skews the current coordinate system in the vertical direction
    • ImagickDraw::translate - Applies a translation to the current coordinate system
    • ImagickDraw::__construct - The ImagickDraw constructor
    • ImagickPixel::clear - Clears resources associated with this object
    • ImagickPixel::destroy - Deallocates resources associated with this object
    • ImagickPixel::getColor - Returns the color
    • ImagickPixel::getColorAsString - Returns the color as a string
    • ImagickPixel::getColorCount - Returns the color count associated with this color
    • ImagickPixel::getColorQuantum - Description
    • ImagickPixel::getColorValue - Gets the normalized value of the provided color channel
    • ImagickPixel::getColorValueQuantum - Description
    • ImagickPixel::getHSL - Returns the normalized HSL color of the ImagickPixel object
    • ImagickPixel::getIndex - Description
    • ImagickPixel::isPixelSimilar - Check the distance between this color and another
    • ImagickPixel::isPixelSimilarQuantum - Description
    • ImagickPixel::isSimilar - Check the distance between this color and another
    • ImagickPixel::setColor - Sets the color
    • ImagickPixel::setColorCount - Description
    • ImagickPixel::setColorValue - Sets the normalized value of one of the channels
    • ImagickPixel::setColorValueQuantum - Description
    • ImagickPixel::setHSL - Sets the normalized HSL color
    • ImagickPixel::setIndex - Description
    • ImagickPixel::__construct - The ImagickPixel constructor
    • ImagickPixelIterator::clear - Clear resources associated with a PixelIterator
    • ImagickPixelIterator::destroy - Deallocates resources associated with a PixelIterator
    • ImagickPixelIterator::getCurrentIteratorRow - Returns the current row of ImagickPixel objects
    • ImagickPixelIterator::getIteratorRow - Returns the current pixel iterator row
    • ImagickPixelIterator::getNextIteratorRow - Returns the next row of the pixel iterator
    • ImagickPixelIterator::getPreviousIteratorRow - Returns the previous row
    • ImagickPixelIterator::newPixelIterator - Returns a new pixel iterator
    • ImagickPixelIterator::newPixelRegionIterator - Returns a new pixel iterator
    • ImagickPixelIterator::resetIterator - Resets the pixel iterator
    • ImagickPixelIterator::setIteratorFirstRow - Sets the pixel iterator to the first pixel row
    • ImagickPixelIterator::setIteratorLastRow - Sets the pixel iterator to the last pixel row
    • ImagickPixelIterator::setIteratorRow - Set the pixel iterator row
    • ImagickPixelIterator::syncIterator - Syncs the pixel iterator
    • ImagickPixelIterator::__construct - The ImagickPixelIterator constructor
    • imap_8bit - Convert an 8bit string to a quoted-printable string
    • imap_alerts - Returns all IMAP alert messages that have occurred
    • imap_append - Append a string message to a specified mailbox
    • imap_base64 - Decode BASE64 encoded text
    • imap_binary - Convert an 8bit string to a base64 string
    • imap_body - Read the message body
    • imap_bodystruct - Read the structure of a specified body section of a specific message
    • imap_check - Check current mailbox
    • imap_clearflag_full - Clears flags on messages
    • imap_close - Close an IMAP stream
    • imap_create - 别名 imap_createmailbox
    • imap_createmailbox - Create a new mailbox
    • imap_delete - Mark a message for deletion from current mailbox
    • imap_deletemailbox - Delete a mailbox
    • imap_errors - Returns all of the IMAP errors that have occurred
    • imap_expunge - Delete all messages marked for deletion
    • imap_fetchbody - Fetch a particular section of the body of the message
    • imap_fetchheader - Returns header for a message
    • imap_fetchmime - Fetch MIME headers for a particular section of the message
    • imap_fetchstructure - Read the structure of a particular message
    • imap_fetchtext - 别名 imap_body
    • imap_fetch_overview - Read an overview of the information in the headers of the given message
    • imap_gc - Clears IMAP cache
    • imap_getacl - Gets the ACL for a given mailbox
    • imap_getmailboxes - Read the list of mailboxes, returning detailed information on each one
    • imap_getsubscribed - List all the subscribed mailboxes
    • imap_get_quota - Retrieve the quota level settings, and usage statics per mailbox
    • imap_get_quotaroot - Retrieve the quota settings per user
    • imap_header - 别名 imap_headerinfo
    • imap_headerinfo - Read the header of the message
    • imap_headers - Returns headers for all messages in a mailbox
    • imap_last_error - Gets the last IMAP error that occurred during this page request
    • imap_list - Read the list of mailboxes
    • imap_listmailbox - 别名 imap_list
    • imap_listscan - Returns the list of mailboxes that matches the given text
    • imap_listsubscribed - 别名 imap_lsub
    • imap_lsub - List all the subscribed mailboxes
    • imap_mail - Send an email message
    • imap_mailboxmsginfo - Get information about the current mailbox
    • imap_mail_compose - Create a MIME message based on given envelope and body sections
    • imap_mail_copy - Copy specified messages to a mailbox
    • imap_mail_move - Move specified messages to a mailbox
    • imap_mime_header_decode - Decode MIME header elements
    • imap_msgno - Gets the message sequence number for the given UID
    • imap_mutf7_to_utf8 - Decode a modified UTF-7 string to UTF-8
    • imap_num_msg - Gets the number of messages in the current mailbox
    • imap_num_recent - Gets the number of recent messages in current mailbox
    • imap_open - Open an IMAP stream to a mailbox
    • imap_ping - Check if the IMAP stream is still active
    • imap_qprint - Convert a quoted-printable string to an 8 bit string
    • imap_rename - 别名 imap_renamemailbox
    • imap_renamemailbox - Rename an old mailbox to new mailbox
    • imap_reopen - Reopen IMAP stream to new mailbox
    • imap_rfc822_parse_adrlist - Parses an address string
    • imap_rfc822_parse_headers - Parse mail headers from a string
    • imap_rfc822_write_address - Returns a properly formatted email address given the mailbox, host, and personal info
    • imap_savebody - Save a specific body section to a file
    • imap_scan - 别名 imap_listscan
    • imap_scanmailbox - 别名 imap_listscan
    • imap_search - This function returns an array of messages matching the given search criteria
    • imap_setacl - Sets the ACL for a given mailbox
    • imap_setflag_full - Sets flags on messages
    • imap_set_quota - Sets a quota for a given mailbox
    • imap_sort - Gets and sort messages
    • imap_status - Returns status information on a mailbox
    • imap_subscribe - Subscribe to a mailbox
    • imap_thread - Returns a tree of threaded message
    • imap_timeout - Set or fetch imap timeout
    • imap_uid - This function returns the UID for the given message sequence number
    • imap_undelete - Unmark the message which is marked deleted
    • imap_unsubscribe - Unsubscribe from a mailbox
    • imap_utf7_decode - Decodes a modified UTF-7 encoded string
    • imap_utf7_encode - Converts ISO-8859-1 string to modified UTF-7 text
    • imap_utf8 - Converts MIME-encoded text to UTF-8
    • imap_utf8_to_mutf7 - Encode a UTF-8 string to modified UTF-7
    • implode - 将一个一维数组的值转化为字符串
    • inet_ntop - Converts a packed internet address to a human readable representation
    • inet_pton - Converts a human readable IP address to its packed in_addr representation
    • InfiniteIterator::next - Moves the inner Iterator forward or rewinds it
    • InfiniteIterator::__construct - Constructs an InfiniteIterator
    • inflate_add - Incrementally inflate encoded data
    • inflate_get_read_len - Get number of bytes read so far
    • inflate_get_status - Get decompression status
    • inflate_init - Initialize an incremental inflate context
    • ingres_autocommit - Switch autocommit on or off
    • ingres_autocommit_state - Test if the connection is using autocommit
    • ingres_charset - Returns the installation character set
    • ingres_close - Close an Ingres database connection
    • ingres_commit - Commit a transaction
    • ingres_connect - Open a connection to an Ingres database
    • ingres_cursor - Get a cursor name for a given result resource
    • ingres_errno - Get the last Ingres error number generated
    • ingres_error - Get a meaningful error message for the last error generated
    • ingres_errsqlstate - Get the last SQLSTATE error code generated
    • ingres_escape_string - Escape special characters for use in a query
    • ingres_execute - Execute a prepared query
    • ingres_fetch_array - Fetch a row of result into an array
    • ingres_fetch_assoc - Fetch a row of result into an associative array
    • ingres_fetch_object - Fetch a row of result into an object
    • ingres_fetch_proc_return - Get the return value from a procedure call
    • ingres_fetch_row - Fetch a row of result into an enumerated array
    • ingres_field_length - Get the length of a field
    • ingres_field_name - Get the name of a field in a query result
    • ingres_field_nullable - Test if a field is nullable
    • ingres_field_precision - Get the precision of a field
    • ingres_field_scale - Get the scale of a field
    • ingres_field_type - Get the type of a field in a query result
    • ingres_free_result - Free the resources associated with a result identifier
    • ingres_next_error - Get the next Ingres error
    • ingres_num_fields - Get the number of fields returned by the last query
    • ingres_num_rows - Get the number of rows affected or returned by a query
    • ingres_pconnect - Open a persistent connection to an Ingres database
    • ingres_prepare - Prepare a query for later execution
    • ingres_query - Send an SQL query to Ingres
    • ingres_result_seek - Set the row position before fetching data
    • ingres_rollback - Roll back a transaction
    • ingres_set_environment - Set environment features controlling output options
    • ingres_unbuffered_query - Send an unbuffered SQL query to Ingres
    • ini_alter - 别名 ini_set
    • ini_get - 获取一个配置选项的值
    • ini_get_all - 获取所有配置选项
    • ini_restore - 恢复配置选项的值
    • ini_set - 为一个配置选项设置值
    • inotify_add_watch - Add a watch to an initialized inotify instance
    • inotify_init - Initialize an inotify instance
    • inotify_queue_len - Return a number upper than zero if there are pending events
    • inotify_read - Read events from an inotify instance
    • inotify_rm_watch - Remove an existing watch from an inotify instance
    • intdiv - 对除法结果取整
    • interface_exists - 检查接口是否已被定义
    • IntlBreakIterator::createCharacterInstance - Create break iterator for boundaries of combining character sequences
    • IntlBreakIterator::createCodePointInstance - Create break iterator for boundaries of code points
    • IntlBreakIterator::createLineInstance - Create break iterator for logically possible line breaks
    • IntlBreakIterator::createSentenceInstance - Create break iterator for sentence breaks
    • IntlBreakIterator::createTitleInstance - Create break iterator for title-casing breaks
    • IntlBreakIterator::createWordInstance - Create break iterator for word breaks
    • IntlBreakIterator::current - Get index of current position
    • IntlBreakIterator::first - Set position to the first character in the text
    • IntlBreakIterator::following - Advance the iterator to the first boundary following specified offset
    • IntlBreakIterator::getErrorCode - Get last error code on the object
    • IntlBreakIterator::getErrorMessage - Get last error message on the object
    • IntlBreakIterator::getLocale - Get the locale associated with the object
    • IntlBreakIterator::getPartsIterator - Create iterator for navigating fragments between boundaries
    • IntlBreakIterator::getText - Get the text being scanned
    • IntlBreakIterator::isBoundary - Tell whether an offset is a boundary?s offset
    • IntlBreakIterator::last - Set the iterator position to index beyond the last character
    • IntlBreakIterator::next - Advance the iterator the next boundary
    • IntlBreakIterator::preceding - Set the iterator position to the first boundary before an offset
    • IntlBreakIterator::previous - Set the iterator position to the boundary immediately before the current
    • IntlBreakIterator::setText - Set the text being scanned
    • IntlBreakIterator::__construct - Private constructor for disallowing instantiation
    • IntlCalendar::add - Add a (signed) amount of time to a field
    • IntlCalendar::after - Whether this object?s time is after that of the passed object
    • IntlCalendar::before - Whether this object?s time is before that of the passed object
    • IntlCalendar::clear - Clear a field or all fields
    • IntlCalendar::createInstance - Create a new IntlCalendar
    • IntlCalendar::equals - Compare time of two IntlCalendar objects for equality
    • IntlCalendar::fieldDifference - Calculate difference between given time and this object?s time
    • IntlCalendar::fromDateTime - Create an IntlCalendar from a DateTime object or string
    • IntlCalendar::get - Get the value for a field
    • IntlCalendar::getActualMaximum - The maximum value for a field, considering the object?s current time
    • IntlCalendar::getActualMinimum - The minimum value for a field, considering the object?s current time
    • IntlCalendar::getAvailableLocales - Get array of locales for which there is data
    • IntlCalendar::getDayOfWeekType - Tell whether a day is a weekday, weekend or a day that has a transition between the two
    • IntlCalendar::getErrorCode - Get last error code on the object
    • IntlCalendar::getErrorMessage - Get last error message on the object
    • IntlCalendar::getFirstDayOfWeek - Get the first day of the week for the calendar?s locale
    • IntlCalendar::getGreatestMinimum - Get the largest local minimum value for a field
    • IntlCalendar::getKeywordValuesForLocale - Get set of locale keyword values
    • IntlCalendar::getLeastMaximum - Get the smallest local maximum for a field
    • IntlCalendar::getLocale - Get the locale associated with the object
    • IntlCalendar::getMaximum - Get the global maximum value for a field
    • IntlCalendar::getMinimalDaysInFirstWeek - Get minimal number of days the first week in a year or month can have
    • IntlCalendar::getMinimum - Get the global minimum value for a field
    • IntlCalendar::getNow - Get number representing the current time
    • IntlCalendar::getRepeatedWallTimeOption - Get behavior for handling repeating wall time
    • IntlCalendar::getSkippedWallTimeOption - Get behavior for handling skipped wall time
    • IntlCalendar::getTime - Get time currently represented by the object
    • IntlCalendar::getTimeZone - Get the object?s timezone
    • IntlCalendar::getType - Get the calendar type
    • IntlCalendar::getWeekendTransition - Get time of the day at which weekend begins or ends
    • IntlCalendar::inDaylightTime - Whether the object?s time is in Daylight Savings Time
    • IntlCalendar::isEquivalentTo - Whether another calendar is equal but for a different time
    • IntlCalendar::isLenient - Whether date/time interpretation is in lenient mode
    • IntlCalendar::isSet - Whether a field is set
    • IntlCalendar::isWeekend - Whether a certain date/time is in the weekend
    • IntlCalendar::roll - Add value to field without carrying into more significant fields
    • IntlCalendar::set - Set a time field or several common fields at once
    • IntlCalendar::setFirstDayOfWeek - Set the day on which the week is deemed to start
    • IntlCalendar::setLenient - Set whether date/time interpretation is to be lenient
    • IntlCalendar::setMinimalDaysInFirstWeek - Set minimal number of days the first week in a year or month can have
    • IntlCalendar::setRepeatedWallTimeOption - Set behavior for handling repeating wall times at negative timezone offset transitions
    • IntlCalendar::setSkippedWallTimeOption - Set behavior for handling skipped wall times at positive timezone offset transitions
    • IntlCalendar::setTime - Set the calendar time in milliseconds since the epoch
    • IntlCalendar::setTimeZone - Set the timezone used by this calendar
    • IntlCalendar::toDateTime - Convert an IntlCalendar into a DateTime object
    • IntlCalendar::__construct - Private constructor for disallowing instantiation
    • IntlChar::charAge - Get the "age" of the code point
    • IntlChar::charDigitValue - Get the decimal digit value of a decimal digit character
    • IntlChar::charDirection - Get bidirectional category value for a code point
    • IntlChar::charFromName - Find Unicode character by name and return its code point value
    • IntlChar::charMirror - Get the "mirror-image" character for a code point
    • IntlChar::charName - Retrieve the name of a Unicode character
    • IntlChar::charType - Get the general category value for a code point
    • IntlChar::chr - Return Unicode character by code point value
    • IntlChar::digit - Get the decimal digit value of a code point for a given radix
    • IntlChar::enumCharNames - Enumerate all assigned Unicode characters within a range
    • IntlChar::enumCharTypes - Enumerate all code points with their Unicode general categories
    • IntlChar::foldCase - Perform case folding on a code point
    • IntlChar::forDigit - Get character representation for a given digit and radix
    • IntlChar::getBidiPairedBracket - Get the paired bracket character for a code point
    • IntlChar::getBlockCode - Get the Unicode allocation block containing a code point
    • IntlChar::getCombiningClass - Get the combining class of a code point
    • IntlChar::getFC_NFKC_Closure - Get the FC_NFKC_Closure property for a code point
    • IntlChar::getIntPropertyMaxValue - Get the max value for a Unicode property
    • IntlChar::getIntPropertyMinValue - Get the min value for a Unicode property
    • IntlChar::getIntPropertyValue - Get the value for a Unicode property for a code point
    • IntlChar::getNumericValue - Get the numeric value for a Unicode code point
    • IntlChar::getPropertyEnum - Get the property constant value for a given property name
    • IntlChar::getPropertyName - Get the Unicode name for a property
    • IntlChar::getPropertyValueEnum - Get the property value for a given value name
    • IntlChar::getPropertyValueName - Get the Unicode name for a property value
    • IntlChar::getUnicodeVersion - Get the Unicode version
    • IntlChar::hasBinaryProperty - Check a binary Unicode property for a code point
    • IntlChar::isalnum - Check if code point is an alphanumeric character
    • IntlChar::isalpha - Check if code point is a letter character
    • IntlChar::isbase - Check if code point is a base character
    • IntlChar::isblank - Check if code point is a "blank" or "horizontal space" character
    • IntlChar::iscntrl - Check if code point is a control character
    • IntlChar::isdefined - Check whether the code point is defined
    • IntlChar::isdigit - Check if code point is a digit character
    • IntlChar::isgraph - Check if code point is a graphic character
    • IntlChar::isIDIgnorable - Check if code point is an ignorable character
    • IntlChar::isIDPart - Check if code point is permissible in an identifier
    • IntlChar::isIDStart - Check if code point is permissible as the first character in an identifier
    • IntlChar::isISOControl - Check if code point is an ISO control code
    • IntlChar::isJavaIDPart - Check if code point is permissible in a Java identifier
    • IntlChar::isJavaIDStart - Check if code point is permissible as the first character in a Java identifier
    • IntlChar::isJavaSpaceChar - Check if code point is a space character according to Java
    • IntlChar::islower - Check if code point is a lowercase letter
    • IntlChar::isMirrored - Check if code point has the Bidi_Mirrored property
    • IntlChar::isprint - Check if code point is a printable character
    • IntlChar::ispunct - Check if code point is punctuation character
    • IntlChar::isspace - Check if code point is a space character
    • IntlChar::istitle - Check if code point is a titlecase letter
    • IntlChar::isUAlphabetic - Check if code point has the Alphabetic Unicode property
    • IntlChar::isULowercase - Check if code point has the Lowercase Unicode property
    • IntlChar::isupper - Check if code point has the general category "Lu" (uppercase letter)
    • IntlChar::isUUppercase - Check if code point has the Uppercase Unicode property
    • IntlChar::isUWhiteSpace - Check if code point has the White_Space Unicode property
    • IntlChar::isWhitespace - Check if code point is a whitespace character according to ICU
    • IntlChar::isxdigit - Check if code point is a hexadecimal digit
    • IntlChar::ord - Return Unicode code point value of character
    • IntlChar::tolower - Make Unicode character lowercase
    • IntlChar::totitle - Make Unicode character titlecase
    • IntlChar::toupper - Make Unicode character uppercase
    • IntlCodePointBreakIterator::getLastCodePoint - Get last code point passed over after advancing or receding the iterator
    • IntlDateFormatter::create - Create a date formatter
    • IntlDateFormatter::format - Format the date/time value as a string
    • IntlDateFormatter::formatObject - Formats an object
    • IntlDateFormatter::getCalendar - Get the calendar type used for the IntlDateFormatter
    • IntlDateFormatter::getCalendarObject - Get copy of formatter?s calendar object
    • IntlDateFormatter::getDateType - Get the datetype used for the IntlDateFormatter
    • IntlDateFormatter::getErrorCode - Get the error code from last operation
    • IntlDateFormatter::getErrorMessage - Get the error text from the last operation
    • IntlDateFormatter::getLocale - Get the locale used by formatter
    • IntlDateFormatter::getPattern - Get the pattern used for the IntlDateFormatter
    • IntlDateFormatter::getTimeType - Get the timetype used for the IntlDateFormatter
    • IntlDateFormatter::getTimeZone - Get formatter?s timezone
    • IntlDateFormatter::getTimeZoneId - Get the timezone-id used for the IntlDateFormatter
    • IntlDateFormatter::isLenient - Get the lenient used for the IntlDateFormatter
    • IntlDateFormatter::localtime - Parse string to a field-based time value
    • IntlDateFormatter::parse - Parse string to a timestamp value
    • IntlDateFormatter::setCalendar - Sets the calendar type used by the formatter
    • IntlDateFormatter::setLenient - Set the leniency of the parser
    • IntlDateFormatter::setPattern - Set the pattern used for the IntlDateFormatter
    • IntlDateFormatter::setTimeZone - Sets formatter?s timezone
    • IntlGregorianCalendar::getGregorianChange - Get the Gregorian Calendar change date
    • IntlGregorianCalendar::isLeapYear - Determine if the given year is a leap year
    • IntlGregorianCalendar::setGregorianChange - Set the Gregorian Calendar the change date
    • IntlGregorianCalendar::__construct - Create the Gregorian Calendar class
    • IntlIterator::current - Get the current element
    • IntlIterator::key - Get the current key
    • IntlIterator::next - Move forward to the next element
    • IntlIterator::rewind - Rewind the iterator to the first element
    • IntlIterator::valid - Check if current position is valid
    • IntlPartsIterator::getBreakIterator - Get IntlBreakIterator backing this parts iterator
    • IntlRuleBasedBreakIterator::getBinaryRules - Get the binary form of compiled rules
    • IntlRuleBasedBreakIterator::getRules - Get the rule set used to create this object
    • IntlRuleBasedBreakIterator::getRuleStatus - Get the largest status value from the break rules that determined the current break position
    • IntlRuleBasedBreakIterator::getRuleStatusVec - Get the status values from the break rules that determined the current break position
    • IntlRuleBasedBreakIterator::__construct - Create iterator from ruleset
    • IntlTimeZone::countEquivalentIDs - Get the number of IDs in the equivalency group that includes the given ID
    • IntlTimeZone::createDefault - Create a new copy of the default timezone for this host
    • IntlTimeZone::createEnumeration - Get an enumeration over time zone IDs associated with the given country or offset
    • IntlTimeZone::createTimeZone - Create a timezone object for the given ID
    • IntlTimeZone::createTimeZoneIDEnumeration - Get an enumeration over system time zone IDs with the given filter conditions
    • IntlTimeZone::fromDateTimeZone - Create a timezone object from DateTimeZone
    • IntlTimeZone::getCanonicalID - Get the canonical system timezone ID or the normalized custom time zone ID for the given time zone ID
    • IntlTimeZone::getDisplayName - Get a name of this time zone suitable for presentation to the user
    • IntlTimeZone::getDSTSavings - Get the amount of time to be added to local standard time to get local wall clock time
    • IntlTimeZone::getEquivalentID - Get an ID in the equivalency group that includes the given ID
    • IntlTimeZone::getErrorCode - Get last error code on the object
    • IntlTimeZone::getErrorMessage - Get last error message on the object
    • IntlTimeZone::getGMT - Create GMT (UTC) timezone
    • IntlTimeZone::getID - Get timezone ID
    • IntlTimeZone::getIDForWindowsID - Translate a Windows timezone into a system timezone
    • IntlTimeZone::getOffset - Get the time zone raw and GMT offset for the given moment in time
    • IntlTimeZone::getRawOffset - Get the raw GMT offset (before taking daylight savings time into account
    • IntlTimeZone::getRegion - Get the region code associated with the given system time zone ID
    • IntlTimeZone::getTZDataVersion - Get the timezone data version currently used by ICU
    • IntlTimeZone::getUnknown - Get the "unknown" time zone
    • IntlTimeZone::getWindowsID - Translate a system timezone into a Windows timezone
    • IntlTimeZone::hasSameRules - Check if this zone has the same rules and offset as another zone
    • IntlTimeZone::toDateTimeZone - Convert to DateTimeZone object
    • IntlTimeZone::useDaylightTime - Check if this time zone uses daylight savings time
    • intl_error_name - Get symbolic name for a given error code
    • intl_get_error_code - Get the last error code
    • intl_get_error_message - Get description of the last error
    • intl_is_failure - Check whether the given error code indicates failure
    • intval - 获取变量的整数值
    • in_array - 检查数组中是否存在某个值
    • ip2long - 将 IPV4 的字符串互联网协议转换成长整型数字
    • iptcembed - 将二进制 IPTC 数据嵌入到一幅 JPEG 图像中
    • iptcparse - 将二进制 IPTC 块解析为单个标记
    • isset - 检测变量是否已设置并且非 null
    • is_a - 如果对象属于该类或该类是此对象的父类则返回 true
    • is_array - 检测变量是否是数组
    • is_bool - 检测变量是否是布尔值
    • is_callable - 检测参数是否为合法的可调用结构
    • is_countable - Verify that the contents of a variable is a countable value
    • is_dir - 判断给定文件名是否是一个目录
    • is_double - is_float 的别名
    • is_executable - 判断给定文件名是否可执行
    • is_file - 判断给定文件名是否为一个正常的文件
    • is_finite - 判断是否为有限值
    • is_float - 检测变量是否是浮点型
    • is_infinite - 判断是否为无限值
    • is_int - 检测变量是否是整数
    • is_integer - is_int 的别名
    • is_iterable - Verify that the contents of a variable is an iterable value
    • is_link - 判断给定文件名是否为一个符号连接
    • is_long - is_int 的别名
    • is_nan - 判断是否为合法数值
    • is_null - 检测变量是否为 null
    • is_numeric - 检测变量是否为数字或数字字符串
    • is_object - 检测变量是否是一个对象
    • is_readable - 判断给定文件名是否可读
    • is_real - is_float 的别名
    • is_resource - 检测变量是否为资源类型
    • is_scalar - 检测变量是否是一个标量
    • is_soap_fault - Checks if a SOAP call has failed
    • is_string - 检测变量是否是字符串
    • is_subclass_of - 如果此对象是该类的子类，则返回 true
    • is_tainted - Checks whether a string is tainted
    • is_uploaded_file - 判断文件是否是通过 HTTP POST 上传的
    • is_writable - 判断给定的文件名是否可写
    • is_writeable - is_writable 的别名
    • Iterator::current - 返回当前元素
    • Iterator::key - 返回当前元素的键
    • Iterator::next - 向前移动到下一个元素
    • Iterator::rewind - 返回到迭代器的第一个元素
    • Iterator::valid - 检查当前位置是否有效
    • IteratorAggregate::getIterator - 获取一个外部迭代器
    • IteratorIterator::current - Get the current value
    • IteratorIterator::getInnerIterator - Get the inner iterator
    • IteratorIterator::key - Get the key of the current element
    • IteratorIterator::next - Forward to the next element
    • IteratorIterator::rewind - Rewind to the first element
    • IteratorIterator::valid - Checks if the iterator is valid
    • IteratorIterator::__construct - Create an iterator from anything that is traversable
    • iterator_apply - 为迭代器中每个元素调用一个用户自定义函数
    • iterator_count - 计算迭代器中元素的个数
    • iterator_to_array - 将迭代器中的元素拷贝到数组
  • j
    • JDDayOfWeek - 返回星期的日期
    • JDMonthName - 返回月份的名称
    • JDToFrench - 转变一个Julian Day计数到French Republican历法的日期
    • JDToGregorian - 转变一个Julian Day计数为Gregorian历法日期
    • jdtojewish - 转换一个julian天数为Jewish历法的日期
    • JDToJulian - 转变一个Julian Day计数到Julian历法的日期
    • jdtounix - 转变Julian Day计数为一个Unix时间戳
    • JewishToJD - 转变一个Jewish历法的日期为一个Julian Day计数
    • join - 别名 implode
    • jpeg2wbmp - 将 JPEG 图像文件转换为 WBMP 图像文件
    • JsonSerializable::jsonSerialize - 指定需要被序列化成 JSON 的数据
    • json_decode - 对 JSON 格式的字符串进行解码
    • json_encode - 对变量进行 JSON 编码
    • json_last_error - 返回最后发生的错误
    • json_last_error_msg - Returns the error string of the last json_encode() or json_decode() call
    • JulianToJD - 转变一个Julian历法的日期为Julian Day计数
  • k
    • key - 从关联数组中取得键名
    • key_exists - 别名 array_key_exists
    • krsort - 对数组按照键名逆向排序
    • ksort - 对数组按照键名排序
  • l
    • lcfirst - 使一个字符串的第一个字符小写
    • lcg_value - 组合线性同余发生器
    • lchgrp - 修改符号链接的所有组
    • lchown - 修改符号链接的所有者
    • ldap_8859_to_t61 - Translate 8859 characters to t61 characters
    • ldap_add - Add entries to LDAP directory
    • ldap_add_ext - Add entries to LDAP directory
    • ldap_bind - 绑定 LDAP 目录
    • ldap_bind_ext - Bind to LDAP directory
    • ldap_close - 别名 ldap_unbind
    • ldap_compare - Compare value of attribute found in entry specified with DN
    • ldap_connect - Connect to an LDAP server
    • ldap_control_paged_result - Send LDAP pagination control
    • ldap_control_paged_result_response - Retrieve the LDAP pagination cookie
    • ldap_count_entries - Count the number of entries in a search
    • ldap_delete - Delete an entry from a directory
    • ldap_delete_ext - Delete an entry from a directory
    • ldap_dn2ufn - Convert DN to User Friendly Naming format
    • ldap_err2str - Convert LDAP error number into string error message
    • ldap_errno - Return the LDAP error number of the last LDAP command
    • ldap_error - Return the LDAP error message of the last LDAP command
    • ldap_escape - Escape a string for use in an LDAP filter or DN
    • ldap_exop - Performs an extended operation
    • ldap_exop_passwd - PASSWD extended operation helper
    • ldap_exop_refresh - Refresh extended operation helper
    • ldap_exop_whoami - WHOAMI extended operation helper
    • ldap_explode_dn - Splits DN into its component parts
    • ldap_first_attribute - Return first attribute
    • ldap_first_entry - Return first result id
    • ldap_first_reference - Return first reference
    • ldap_free_result - Free result memory
    • ldap_get_attributes - Get attributes from a search result entry
    • ldap_get_dn - Get the DN of a result entry
    • ldap_get_entries - Get all result entries
    • ldap_get_option - Get the current value for given option
    • ldap_get_values - Get all values from a result entry
    • ldap_get_values_len - Get all binary values from a result entry
    • ldap_list - Single-level search
    • ldap_modify - 别名 ldap_mod_replace
    • ldap_modify_batch - Batch and execute modifications on an LDAP entry
    • ldap_mod_add - Add attribute values to current attributes
    • ldap_mod_add_ext - Add attribute values to current attributes
    • ldap_mod_del - Delete attribute values from current attributes
    • ldap_mod_del_ext - Delete attribute values from current attributes
    • ldap_mod_replace - Replace attribute values with new ones
    • ldap_mod_replace_ext - Replace attribute values with new ones
    • ldap_next_attribute - Get the next attribute in result
    • ldap_next_entry - Get next result entry
    • ldap_next_reference - Get next reference
    • ldap_parse_exop - Parse result object from an LDAP extended operation
    • ldap_parse_reference - Extract information from reference entry
    • ldap_parse_result - Extract information from result
    • ldap_read - Read an entry
    • ldap_rename - Modify the name of an entry
    • ldap_rename_ext - Modify the name of an entry
    • ldap_sasl_bind - Bind to LDAP directory using SASL
    • ldap_search - Search LDAP tree
    • ldap_set_option - Set the value of the given option
    • ldap_set_rebind_proc - Set a callback function to do re-binds on referral chasing
    • ldap_sort - Sort LDAP result entries on the client side
    • ldap_start_tls - Start TLS
    • ldap_t61_to_8859 - Translate t61 characters to 8859 characters
    • ldap_unbind - Unbind from LDAP directory
    • levenshtein - 计算两个字符串之间的编辑距离
    • libxml_clear_errors - Clear libxml error buffer
    • libxml_disable_entity_loader - Disable the ability to load external entities
    • libxml_get_errors - Retrieve array of errors
    • libxml_get_last_error - Retrieve last error from libxml
    • libxml_set_external_entity_loader - Changes the default external entity loader
    • libxml_set_streams_context - Set the streams context for the next libxml document load or write
    • libxml_use_internal_errors - Disable libxml errors and allow user to fetch error information as needed
    • LimitIterator::current - Get current element
    • LimitIterator::getInnerIterator - Get inner iterator
    • LimitIterator::getPosition - Return the current position
    • LimitIterator::key - Get current key
    • LimitIterator::next - Move the iterator forward
    • LimitIterator::rewind - Rewind the iterator to the specified starting offset
    • LimitIterator::seek - Seek to the given position
    • LimitIterator::valid - Check whether the current element is valid
    • LimitIterator::__construct - Construct a LimitIterator
    • link - 建立一个硬连接
    • linkinfo - 获取一个连接的信息
    • list - 把数组中的值赋给一组变量
    • Locale::acceptFromHttp - Tries to find out best available locale based on HTTP "Accept-Language" header
    • Locale::canonicalize - Canonicalize the locale string
    • Locale::composeLocale - Returns a correctly ordered and delimited locale ID
    • Locale::filterMatches - Checks if a language tag filter matches with locale
    • Locale::getAllVariants - Gets the variants for the input locale
    • Locale::getDefault - Gets the default locale value from the INTL global 'default_locale'
    • Locale::getDisplayLanguage - Returns an appropriately localized display name for language of the inputlocale
    • Locale::getDisplayName - Returns an appropriately localized display name for the input locale
    • Locale::getDisplayRegion - Returns an appropriately localized display name for region of the input locale
    • Locale::getDisplayScript - Returns an appropriately localized display name for script of the input locale
    • Locale::getDisplayVariant - Returns an appropriately localized display name for variants of the input locale
    • Locale::getKeywords - Gets the keywords for the input locale
    • Locale::getPrimaryLanguage - Gets the primary language for the input locale
    • Locale::getRegion - Gets the region for the input locale
    • Locale::getScript - Gets the script for the input locale
    • Locale::lookup - Searches the language tag list for the best match to the language
    • Locale::parseLocale - Returns a key-value array of locale ID subtag elements
    • Locale::setDefault - Sets the default runtime locale
    • localeconv - Get numeric formatting information
    • localtime - 取得本地时间
    • log - 自然对数
    • log1p - 返回 log(1 + number)，甚至当 number 的值接近零也能计算出准确结果
    • log10 - 以 10 为底的对数
    • log_cmd_delete - Callback When Deleting Documents
    • log_cmd_insert - Callback When Inserting Documents
    • log_cmd_update - Callback When Updating Documents
    • log_getmore - Callback When Retrieving Next Cursor Batch
    • log_killcursor - Callback When Executing KILLCURSOR operations
    • log_reply - Callback When Reading the MongoDB reply
    • log_write_batch - Callback When Writing Batches
    • long2ip - 将长整型转化为字符串形式带点的互联网标准格式地址（IPV4）
    • lstat - 给出一个文件或符号连接的信息
    • ltrim - 删除字符串开头的空白字符（或其他字符）
    • Lua::assign - 将一个php变量赋值给Lua
    • Lua::call - 调用Lua函数
    • Lua::eval - 将字符串当做Lua代码执行
    • Lua::getVersion - 获取Lua版本
    • Lua::include - 解析Lua脚本文件
    • Lua::registerCallback - 向Lua中注册php函数
    • Lua::__construct - Lua 构造方法
    • LuaClosure::__invoke - 调用luaclosure
    • LuaSandbox::callFunction - Call a function in a Lua global variable
    • LuaSandbox::disableProfiler - Disable the profiler
    • LuaSandbox::enableProfiler - Enable the profiler.
    • LuaSandbox::getCPUUsage - Fetch the current CPU time usage of the Lua environment
    • LuaSandbox::getMemoryUsage - Fetch the current memory usage of the Lua environment
    • LuaSandbox::getPeakMemoryUsage - Fetch the peak memory usage of the Lua environment
    • LuaSandbox::getProfilerFunctionReport - Fetch profiler data
    • LuaSandbox::getVersionInfo - Return the versions of LuaSandbox and Lua
    • LuaSandbox::loadBinary - Load a precompiled binary chunk into the Lua environment
    • LuaSandbox::loadString - Load Lua code into the Lua environment
    • LuaSandbox::pauseUsageTimer - Pause the CPU usage timer
    • LuaSandbox::registerLibrary - Register a set of PHP functions as a Lua library
    • LuaSandbox::setCPULimit - Set the CPU time limit for the Lua environment
    • LuaSandbox::setMemoryLimit - Set the memory limit for the Lua environment
    • LuaSandbox::unpauseUsageTimer - Unpause the timer paused by LuaSandbox::pauseUsageTimer
    • LuaSandbox::wrapPhpFunction - Wrap a PHP callable in a LuaSandboxFunction
    • LuaSandboxFunction::call - Call a Lua function
    • LuaSandboxFunction::dump - Dump the function as a binary blob
    • LuaSandboxFunction::__construct - Unused
    • lzf_compress - LZF compression
    • lzf_decompress - LZF decompression
    • lzf_optimized_for - Determines what LZF extension was optimized for
  • m
    • mail - 发送邮件
    • mailparse_determine_best_xfer_encoding - Gets the best way of encoding
    • mailparse_msg_create - Create a mime mail resource
    • mailparse_msg_extract_part - Extracts/decodes a message section
    • mailparse_msg_extract_part_file - Extracts/decodes a message section
    • mailparse_msg_extract_whole_part_file - Extracts a message section including headers without decoding the transfer encoding
    • mailparse_msg_free - Frees a MIME resource
    • mailparse_msg_get_part - Returns a handle on a given section in a mimemessage
    • mailparse_msg_get_part_data - Returns an associative array of info about the message
    • mailparse_msg_get_structure - Returns an array of mime section names in the supplied message
    • mailparse_msg_parse - Incrementally parse data into buffer
    • mailparse_msg_parse_file - Parses a file
    • mailparse_rfc822_parse_addresses - Parse RFC 822 compliant addresses
    • mailparse_stream_encode - Streams data from source file pointer, apply encoding and write to destfp
    • mailparse_uudecode_all - Scans the data from fp and extract each embedded uuencoded file
    • main - 虚拟的main
    • max - 找出最大值
    • mb_check_encoding - 检查字符串在指定的编码里是否有效
    • mb_chr - Get a specific character
    • mb_convert_case - 对字符串进行大小写转换
    • mb_convert_encoding - 转换字符的编码
    • mb_convert_kana - Convert "kana" one from another ("zen-kaku", "han-kaku" and more)
    • mb_convert_variables - 转换一个或多个变量的字符编码
    • mb_decode_mimeheader - 解码 MIME 头字段中的字符串
    • mb_decode_numericentity - 根据 HTML 数字字符串解码成字符
    • mb_detect_encoding - 检测字符的编码
    • mb_detect_order - 设置/获取 字符编码的检测顺序
    • mb_encode_mimeheader - 为 MIME 头编码字符串
    • mb_encode_numericentity - Encode character to HTML numeric string reference
    • mb_encoding_aliases - Get aliases of a known encoding type
    • mb_ereg - Regular expression match with multibyte support
    • mb_eregi - Regular expression match ignoring case with multibyte support
    • mb_eregi_replace - Replace regular expression with multibyte support ignoring case
    • mb_ereg_match - Regular expression match for multibyte string
    • mb_ereg_replace - Replace regular expression with multibyte support
    • mb_ereg_replace_callback - Perform a regular expression search and replace with multibyte support using a callback
    • mb_ereg_search - Multibyte regular expression match for predefined multibyte string
    • mb_ereg_search_getpos - Returns start point for next regular expression match
    • mb_ereg_search_getregs - Retrieve the result from the last multibyte regular expression match
    • mb_ereg_search_init - Setup string and regular expression for a multibyte regular expression match
    • mb_ereg_search_pos - Returns position and length of a matched part of the multibyte regular expression for a predefined multibyte string
    • mb_ereg_search_regs - Returns the matched part of a multibyte regular expression
    • mb_ereg_search_setpos - Set start point of next regular expression match
    • mb_get_info - 获取 mbstring 的内部设置
    • mb_http_input - 检测 HTTP 输入字符编码
    • mb_http_output - 设置/获取 HTTP 输出字符编码
    • mb_internal_encoding - 设置/获取内部字符编码
    • mb_language - 设置/获取当前的语言
    • mb_list_encodings - 返回所有支持编码的数组
    • mb_ord - Get code point of character
    • mb_output_handler - 在输出缓冲中转换字符编码的回调函数
    • mb_parse_str - 解析 GET/POST/COOKIE 数据并设置全局变量
    • mb_preferred_mime_name - 获取 MIME 字符串
    • mb_regex_encoding - Set/Get character encoding for multibyte regex
    • mb_regex_set_options - Set/Get the default options for mbregex functions
    • mb_scrub - Description
    • mb_send_mail - 发送编码过的邮件
    • mb_split - 使用正则表达式分割多字节字符串
    • mb_strcut - 获取字符的一部分
    • mb_strimwidth - 获取按指定宽度截断的字符串
    • mb_stripos - 大小写不敏感地查找字符串在另一个字符串中首次出现的位置
    • mb_stristr - 大小写不敏感地查找字符串在另一个字符串里的首次出现
    • mb_strlen - 获取字符串的长度
    • mb_strpos - 查找字符串在另一个字符串中首次出现的位置
    • mb_strrchr - 查找指定字符在另一个字符串中最后一次的出现
    • mb_strrichr - 大小写不敏感地查找指定字符在另一个字符串中最后一次的出现
    • mb_strripos - 大小写不敏感地在字符串中查找一个字符串最后出现的位置
    • mb_strrpos - 查找字符串在一个字符串中最后出现的位置
    • mb_strstr - 查找字符串在另一个字符串里的首次出现
    • mb_strtolower - 使字符串小写
    • mb_strtoupper - 使字符串大写
    • mb_strwidth - 返回字符串的宽度
    • mb_str_split - Given a multibyte string, return an array of its characters
    • mb_substitute_character - 设置/获取替代字符
    • mb_substr - 获取部分字符串
    • mb_substr_count - 统计字符串出现的次数
    • mcrypt_cbc - 以 CBC 模式加解密数据
    • mcrypt_cfb - 以 CFB 模式加解密数据
    • mcrypt_create_iv - 从随机源创建初始向量
    • mcrypt_decrypt - 使用给定参数解密密文
    • mcrypt_ecb - 已废弃：使用 ECB 模式加解密数据
    • mcrypt_encrypt - 使用给定参数加密明文
    • mcrypt_enc_get_algorithms_name - 返回打开的算法名称
    • mcrypt_enc_get_block_size - 返回打开的算法的分组大小
    • mcrypt_enc_get_iv_size - 返回打开的算法的初始向量大小
    • mcrypt_enc_get_key_size - 返回打开的模式所能支持的最长密钥
    • mcrypt_enc_get_modes_name - 返回打开的模式的名称
    • mcrypt_enc_get_supported_key_sizes - 以数组方式返回打开的算法所支持的密钥长度
    • mcrypt_enc_is_block_algorithm - 检测打开模式的算法是否为分组算法
    • mcrypt_enc_is_block_algorithm_mode - 检测打开的模式是否支持分组加密
    • mcrypt_enc_is_block_mode - 检测打开的模式是否以分组方式输出
    • mcrypt_enc_self_test - 在打开的模块上进行自检
    • mcrypt_generic - 加密数据
    • mcrypt_generic_deinit - 对加密模块进行清理工作
    • mcrypt_generic_end - 终止加密
    • mcrypt_generic_init - 初始化加密所需的缓冲区
    • mcrypt_get_block_size - 获得加密算法的分组大小
    • mcrypt_get_cipher_name - 获取加密算法名称
    • mcrypt_get_iv_size - 返回指定算法/模式组合的初始向量大小
    • mcrypt_get_key_size - 获取指定加密算法的密钥大小
    • mcrypt_list_algorithms - 获取支持的加密算法
    • mcrypt_list_modes - 获取所支持的模式
    • mcrypt_module_close - 关闭加密模块
    • mcrypt_module_get_algo_block_size - 返回指定算法的分组大小
    • mcrypt_module_get_algo_key_size - 获取打开模式所支持的最大密钥大小
    • mcrypt_module_get_supported_key_sizes - 以数组形式返回打开的算法所支持的密钥大小
    • mcrypt_module_is_block_algorithm - 检测指定算法是否为分组加密算法
    • mcrypt_module_is_block_algorithm_mode - 返回指定模块是否是分组加密模式
    • mcrypt_module_is_block_mode - 检测指定模式是否以分组方式输出
    • mcrypt_module_open - 打开算法和模式对应的模块
    • mcrypt_module_self_test - 在指定模块上执行自检
    • mcrypt_ofb - 使用 OFB 模式加密/解密数据
    • md5 - 计算字符串的 MD5 散列值
    • md5_file - 计算指定文件的 MD5 散列值
    • mdecrypt_generic - 解密数据
    • Memcache::add - 增加一个条目到缓存服务器
    • Memcache::addServer - 向连接池中添加一个memcache服务器
    • Memcache::close - 关闭memcache连接
    • Memcache::connect - 打开一个memcached服务端连接
    • Memcache::decrement - 减小元素的值
    • Memcache::delete - 从服务端删除一个元素
    • Memcache::flush - 清洗（删除）已经存储的所有的元素
    • Memcache::get - 从服务端检回一个元素
    • Memcache::getExtendedStats - 缓存服务器池中所有服务器统计信息
    • Memcache::getServerStatus - 用于获取一个服务器的在线/离线状态
    • Memcache::getStats - 获取服务器统计信息
    • Memcache::getVersion - 返回服务器版本信息
    • Memcache::increment - 增加一个元素的值
    • Memcache::pconnect - 打开一个到服务器的持久化连接
    • Memcache::replace - 替换已经存在的元素的值
    • Memcache::set - Store data at the server
    • Memcache::setCompressThreshold - 开启大值自动压缩
    • Memcache::setServerParams - 运行时修改服务器参数和状态
    • Memcached::add - 向一个新的key下面增加一个元素
    • Memcached::addByKey - 在指定服务器上的一个新的key下增加一个元素
    • Memcached::addServer - 向服务器池中增加一个服务器
    • Memcached::addServers - 向服务器池中增加多台服务器
    • Memcached::append - 向已存在元素后追加数据
    • Memcached::appendByKey - 向指定服务器上已存在元素后追加数据
    • Memcached::cas - 比较并交换值
    • Memcached::casByKey - 在指定服务器上比较并交换值
    • Memcached::decrement - 减小数值元素的值
    • Memcached::decrementByKey - Decrement numeric item's value, stored on a specific server
    • Memcached::delete - 删除一个元素
    • Memcached::deleteByKey - 从指定的服务器删除一个元素
    • Memcached::deleteMulti - Delete multiple items
    • Memcached::deleteMultiByKey - Delete multiple items from a specific server
    • Memcached::fetch - 抓取下一个结果
    • Memcached::fetchAll - 抓取所有剩余的结果
    • Memcached::flush - 作废缓存中的所有元素
    • Memcached::get - 检索一个元素
    • Memcached::getAllKeys - Gets the keys stored on all the servers
    • Memcached::getByKey - 从特定的服务器检索元素
    • Memcached::getDelayed - 请求多个元素
    • Memcached::getDelayedByKey - 从指定的服务器上请求多个元素
    • Memcached::getMulti - 检索多个元素
    • Memcached::getMultiByKey - 从特定服务器检索多个元素
    • Memcached::getOption - 获取Memcached的选项值
    • Memcached::getResultCode - 返回最后一次操作的结果代码
    • Memcached::getResultMessage - 返回最后一次操作的结果描述消息
    • Memcached::getServerByKey - 获取一个key所映射的服务器信息
    • Memcached::getServerList - 获取服务器池中的服务器列表
    • Memcached::getStats - 获取服务器池的统计信息
    • Memcached::getVersion - 获取服务器池中所有服务器的版本信息
    • Memcached::increment - 增加数值元素的值
    • Memcached::incrementByKey - Increment numeric item's value, stored on a specific server
    • Memcached::isPersistent - Check if a persitent connection to memcache is being used
    • Memcached::isPristine - Check if the instance was recently created
    • Memcached::prepend - 向一个已存在的元素前面追加数据
    • Memcached::prependByKey - Prepend data to an existing item on a specific server
    • Memcached::quit - 关闭所有打开的链接。
    • Memcached::replace - 替换已存在key下的元素
    • Memcached::replaceByKey - Replace the item under an existing key on a specific server
    • Memcached::resetServerList - Clears all servers from the server list
    • Memcached::set - 存储一个元素
    • Memcached::setByKey - 将元素存储到指定的服务器上
    • Memcached::setMulti - 存储多个元素
    • Memcached::setMultiByKey - Store multiple items on a specific server
    • Memcached::setOption - 设置一个memcached选项
    • Memcached::setOptions - Set Memcached options
    • Memcached::setSaslAuthData - Set the credentials to use for authentication
    • Memcached::touch - Set a new expiration on an item
    • Memcached::touchByKey - Set a new expiration on an item on a specific server
    • Memcached::__construct - 创建一个Memcached实例
    • memcache_debug - 转换调试输出的开/关
    • memory_get_peak_usage - 返回分配给 PHP 内存的峰值
    • memory_get_usage - 返回分配给 PHP 的内存量
    • MessageFormatter::create - Constructs a new Message Formatter
    • MessageFormatter::format - Format the message
    • MessageFormatter::formatMessage - Quick format message
    • MessageFormatter::getErrorCode - Get the error code from last operation
    • MessageFormatter::getErrorMessage - Get the error text from the last operation
    • MessageFormatter::getLocale - Get the locale for which the formatter was created
    • MessageFormatter::getPattern - Get the pattern used by the formatter
    • MessageFormatter::parse - Parse input string according to pattern
    • MessageFormatter::parseMessage - Quick parse input string
    • MessageFormatter::setPattern - Set the pattern used by the formatter
    • metaphone - Calculate the metaphone key of a string
    • method_exists - 检查类的方法是否存在
    • mhash - Computes hash
    • mhash_count - Gets the highest available hash ID
    • mhash_get_block_size - Gets the block size of the specified hash
    • mhash_get_hash_name - Gets the name of the specified hash
    • mhash_keygen_s2k - Generates a key
    • microtime - 返回当前 Unix 时间戳和微秒数
    • mime_content_type - 检测文件的 MIME 类型
    • min - 找出最小值
    • mkdir - 新建目录
    • mktime - 取得一个日期的 Unix 时间戳
    • money_format - 将数字格式化成货币字符串
    • Mongo::connectUtil - Connects with a database server
    • Mongo::getPoolSize - Get pool size for connection pools
    • Mongo::getSlave - Returns the address being used by this for slaveOkay reads
    • Mongo::getSlaveOkay - Get slaveOkay setting for this connection
    • Mongo::poolDebug - Returns information about all connection pools
    • Mongo::setPoolSize - Set the size for future connection pools
    • Mongo::setSlaveOkay - Change slaveOkay setting for this connection
    • Mongo::switchSlave - Choose a new secondary for slaveOkay reads
    • Mongo::__construct - The __construct purpose
    • MongoBinData::__construct - 创建一个新的二进制数据对象
    • MongoBinData::__toString - 二进制数据对象的字符串表达形式。
    • MongoClient::close - 关闭连接
    • MongoClient::connect - 连接到数据库服务器
    • MongoClient::dropDB - 删除一个数据库 [已废弃]
    • MongoClient::getConnections - 返回所有已打开连接的信息
    • MongoClient::getHosts - 更新所有关联主机的状态信息
    • MongoClient::getReadPreference - 获取此连接的读取首选项
    • MongoClient::getWriteConcern - Get the write concern for this connection
    • MongoClient::killCursor - Kills a specific cursor on the server
    • MongoClient::listDBs - 列出所有有效数据库
    • MongoClient::selectCollection - 获取数据库的文档集
    • MongoClient::selectDB - 获取一个数据库
    • MongoClient::setReadPreference - 为该连接设置读取选项
    • MongoClient::setWriteConcern - Set the write concern for this connection
    • MongoClient::__construct - 创建一个新的数据库连接对象
    • MongoClient::__get - 取得一个数据库
    • MongoClient::__toString - 该连接的字符串表达方式
    • MongoCode::__construct - 创建一个新的代码对象
    • MongoCode::__toString - 返回代码的字符串形式
    • MongoCollection::aggregate - Perform an aggregation using the aggregation framework
    • MongoCollection::aggregateCursor - Execute an aggregation pipeline command and retrieve results through a cursor
    • MongoCollection::batchInsert - Inserts multiple documents into this collection
    • MongoCollection::count - 返回集合中的文档数量
    • MongoCollection::createDBRef - 创建一个数据库引用
    • MongoCollection::createIndex - Creates an index on the specified field(s) if it does not already exist
    • MongoCollection::deleteIndex - Deletes an index from this collection
    • MongoCollection::deleteIndexes - 删除集合的所有索引
    • MongoCollection::distinct - 获取集合里指定键的不同值的列表。
    • MongoCollection::drop - 删除该集合
    • MongoCollection::ensureIndex - Creates an index on the specified field(s) if it does not already exist
    • MongoCollection::find - 查询该集合，并返回结果集的 MongoCursor
    • MongoCollection::findAndModify - Update a document and return it
    • MongoCollection::findOne - Queries this collection, returning a single element
    • MongoCollection::getDBRef - Fetches the document pointed to by a database reference
    • MongoCollection::getIndexInfo - Returns information about indexes on this collection
    • MongoCollection::getName - 返回这个集合的名称
    • MongoCollection::getReadPreference - Get the read preference for this collection
    • MongoCollection::getSlaveOkay - Get slaveOkay setting for this collection
    • MongoCollection::getWriteConcern - Get the write concern for this collection
    • MongoCollection::group - Performs an operation similar to SQL's GROUP BY command
    • MongoCollection::insert - 插入文档到集合中
    • MongoCollection::parallelCollectionScan - Returns an array of cursors to iterator over a full collection in parallel
    • MongoCollection::remove - 从集合中删除记录
    • MongoCollection::save - 保存一个文档到集合
    • MongoCollection::setReadPreference - Set the read preference for this collection
    • MongoCollection::setSlaveOkay - Change slaveOkay setting for this collection
    • MongoCollection::setWriteConcern - Set the write concern for this database
    • MongoCollection::toIndexString - Converts keys specifying an index to its identifying string
    • MongoCollection::update - Update records based on a given criteria
    • MongoCollection::validate - Validates this collection
    • MongoCollection::__construct - 创建一个新的集合
    • MongoCollection::__get - Gets a collection
    • MongoCollection::__toString - String representation of this collection
    • MongoCommandCursor::batchSize - Limits the number of elements returned in one batch
    • MongoCommandCursor::createFromDocument - Create a new command cursor from an existing command response document
    • MongoCommandCursor::current - Returns the current element
    • MongoCommandCursor::dead - Checks if there are results that have not yet been sent from the database
    • MongoCommandCursor::getReadPreference - Get the read preference for this command
    • MongoCommandCursor::info - Gets information about the cursor's creation and iteration
    • MongoCommandCursor::key - Returns the current result's index within the result set
    • MongoCommandCursor::next - Advances the cursor to the next result
    • MongoCommandCursor::rewind - Executes the command and resets the cursor to the start of the result set
    • MongoCommandCursor::setReadPreference - Set the read preference for this command
    • MongoCommandCursor::timeout - Sets a client-side timeout for this command
    • MongoCommandCursor::valid - Checks if the cursor is reading a valid result
    • MongoCommandCursor::__construct - Create a new command cursor
    • MongoCursor::addOption - Adds a top-level key/value pair to a query
    • MongoCursor::awaitData - Sets whether this cursor will wait for a while for a tailable cursor to return more data
    • MongoCursor::batchSize - Limits the number of elements returned in one batch
    • MongoCursor::count - Counts the number of results for this query
    • MongoCursor::current - Returns the current element
    • MongoCursor::dead - Checks if there are results that have not yet been sent from the database
    • MongoCursor::doQuery - Execute the query
    • MongoCursor::explain - Return an explanation of the query, often useful for optimization and debugging
    • MongoCursor::fields - Sets the fields for a query
    • MongoCursor::getNext - Advances the cursor to the next result, and returns that result
    • MongoCursor::getReadPreference - Get the read preference for this query
    • MongoCursor::hasNext - Checks if there are any more elements in this cursor
    • MongoCursor::hint - Gives the database a hint about the query
    • MongoCursor::immortal - Sets whether this cursor will timeout
    • MongoCursor::info - Gets information about the cursor's creation and iteration
    • MongoCursor::key - Returns the current result's _id, or its index within the result set
    • MongoCursor::limit - Limits the number of results returned
    • MongoCursor::maxTimeMS - Sets a server-side timeout for this query
    • MongoCursor::next - Advances the cursor to the next result, and returns that result
    • MongoCursor::partial - If this query should fetch partial results from mongos if a shard is down
    • MongoCursor::reset - Clears the cursor
    • MongoCursor::rewind - Returns the cursor to the beginning of the result set
    • MongoCursor::setFlag - Sets arbitrary flags in case there is no method available the specific flag
    • MongoCursor::setReadPreference - Set the read preference for this query
    • MongoCursor::skip - Skips a number of results
    • MongoCursor::slaveOkay - Sets whether this query can be done on a secondary [deprecated]
    • MongoCursor::snapshot - Use snapshot mode for the query
    • MongoCursor::sort - Sorts the results by given fields
    • MongoCursor::tailable - Sets whether this cursor will be left open after fetching the last results
    • MongoCursor::timeout - Sets a client-side timeout for this query
    • MongoCursor::valid - Checks if the cursor is reading a valid result
    • MongoCursor::__construct - Create a new cursor
    • MongoCursorException::getHost - 遇到该错误的服务器的 hostname
    • MongoCursorInterface::batchSize - Limits the number of elements returned in one batch
    • MongoCursorInterface::dead - Checks if there are results that have not yet been sent from the database
    • MongoCursorInterface::getReadPreference - Get the read preference for this query
    • MongoCursorInterface::info - Gets information about the cursor's creation and iteration
    • MongoCursorInterface::setReadPreference - Set the read preference for this query
    • MongoCursorInterface::timeout - Sets a client-side timeout for this query
    • MongoDate::toDateTime - Returns a DateTime object representing this date
    • MongoDate::__construct - 创建一个新的日期。
    • MongoDate::__toString - 返回该日期的字符串形式的表达
    • MongoDB::authenticate - 登录到数据库
    • MongoDB::command - 执行一条 Mongo 指令
    • MongoDB::createCollection - 创建一个集合
    • MongoDB::createDBRef - 创建数据库引用
    • MongoDB::drop - 删除数据库
    • MongoDB::dropCollection - Drops a collection [deprecated]
    • MongoDB::execute - 在数据库服务器上运行JavaScript
    • MongoDB::forceError - Creates a database error
    • MongoDB::getCollectionInfo - Returns information about collections in this database
    • MongoDB::getCollectionNames - Gets an array of names for all collections in this database
    • MongoDB::getDBRef - Fetches the document pointed to by a database reference
    • MongoDB::getGridFS - Fetches toolkit for dealing with files stored in this database
    • MongoDB::getProfilingLevel - Gets this database's profiling level
    • MongoDB::getReadPreference - Get the read preference for this database
    • MongoDB::getSlaveOkay - Get slaveOkay setting for this database
    • MongoDB::getWriteConcern - Get the write concern for this database
    • MongoDB::lastError - Check if there was an error on the most recent db operation performed
    • MongoDB::listCollections - Gets an array of MongoCollection objects for all collections in this database
    • MongoDB::prevError - Checks for the last error thrown during a database operation
    • MongoDB::repair - Repairs and compacts this database
    • MongoDB::resetError - Clears any flagged errors on the database
    • MongoDB::selectCollection - Gets a collection
    • MongoDB::setProfilingLevel - Sets this database's profiling level
    • MongoDB::setReadPreference - Set the read preference for this database
    • MongoDB::setSlaveOkay - Change slaveOkay setting for this database
    • MongoDB::setWriteConcern - Set the write concern for this database
    • MongoDB::__construct - 选择一个数据库
    • MongoDB::__get - Gets a collection
    • MongoDB::__toString - The name of this database
    • MongoDB context options - MongoDB context option listing
    • MongoDBRef::create - 创建一个新的数据库引用
    • MongoDBRef::get - 获取引用所指向的对象
    • MongoDBRef::isRef - 检测数组是否为数据库引用
    • MongoDB\BSON\Binary::getData - Returns the Binary's data
    • MongoDB\BSON\Binary::getType - Returns the Binary's type
    • MongoDB\BSON\Binary::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Binary::serialize - Serialize a Binary
    • MongoDB\BSON\Binary::unserialize - Unserialize a Binary
    • MongoDB\BSON\Binary::__construct - Construct a new Binary
    • MongoDB\BSON\Binary::__toString - Returns the Binary's data
    • MongoDB\BSON\BinaryInterface::getData - Returns the BinaryInterface's data
    • MongoDB\BSON\BinaryInterface::getType - Returns the BinaryInterface's type
    • MongoDB\BSON\BinaryInterface::__toString - Returns the BinaryInterface's data
    • MongoDB\BSON\DBPointer::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\DBPointer::serialize - Serialize a DBPointer
    • MongoDB\BSON\DBPointer::unserialize - Unserialize a DBPointer
    • MongoDB\BSON\DBPointer::__construct - Construct a new DBPointer (unused)
    • MongoDB\BSON\DBPointer::__toString - Returns an empty string
    • MongoDB\BSON\Decimal128::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Decimal128::serialize - Serialize a Decimal128
    • MongoDB\BSON\Decimal128::unserialize - Unserialize a Decimal128
    • MongoDB\BSON\Decimal128::__construct - Construct a new Decimal128
    • MongoDB\BSON\Decimal128::__toString - Returns the string representation of this Decimal128
    • MongoDB\BSON\Decimal128Interface::__toString - Returns the string representation of this Decimal128Interface
    • MongoDB\BSON\fromJSON - Returns the BSON representation of a JSON value
    • MongoDB\BSON\fromPHP - Returns the BSON representation of a PHP value
    • MongoDB\BSON\Int64::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Int64::serialize - Serialize an Int64
    • MongoDB\BSON\Int64::unserialize - Unserialize an Int64
    • MongoDB\BSON\Int64::__construct - Construct a new Int64 (unused)
    • MongoDB\BSON\Int64::__toString - Returns the string representation of this Int64
    • MongoDB\BSON\Javascript::getCode - Returns the Javascript's code
    • MongoDB\BSON\Javascript::getScope - Returns the Javascript's scope document
    • MongoDB\BSON\Javascript::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Javascript::serialize - Serialize a Javascript
    • MongoDB\BSON\Javascript::unserialize - Unserialize a Javascript
    • MongoDB\BSON\Javascript::__construct - Construct a new Javascript
    • MongoDB\BSON\Javascript::__toString - Returns the Javascript's code
    • MongoDB\BSON\JavascriptInterface::getCode - Returns the JavascriptInterface's code
    • MongoDB\BSON\JavascriptInterface::getScope - Returns the JavascriptInterface's scope document
    • MongoDB\BSON\JavascriptInterface::__toString - Returns the JavascriptInterface's code
    • MongoDB\BSON\MaxKey::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\MaxKey::serialize - Serialize a MaxKey
    • MongoDB\BSON\MaxKey::unserialize - Unserialize a MaxKey
    • MongoDB\BSON\MaxKey::__construct - Construct a new MaxKey
    • MongoDB\BSON\MinKey::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\MinKey::serialize - Serialize a MinKey
    • MongoDB\BSON\MinKey::unserialize - Unserialize a MinKey
    • MongoDB\BSON\MinKey::__construct - Construct a new MinKey
    • MongoDB\BSON\ObjectId::getTimestamp - Returns the timestamp component of this ObjectId
    • MongoDB\BSON\ObjectId::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\ObjectId::serialize - Serialize an ObjectId
    • MongoDB\BSON\ObjectId::unserialize - Unserialize an ObjectId
    • MongoDB\BSON\ObjectId::__construct - Construct a new ObjectId
    • MongoDB\BSON\ObjectId::__toString - Returns the hexidecimal representation of this ObjectId
    • MongoDB\BSON\ObjectIdInterface::getTimestamp - Returns the timestamp component of this ObjectIdInterface
    • MongoDB\BSON\ObjectIdInterface::__toString - Returns the hexidecimal representation of this ObjectIdInterface
    • MongoDB\BSON\Regex::getFlags - Returns the Regex's flags
    • MongoDB\BSON\Regex::getPattern - Returns the Regex's pattern
    • MongoDB\BSON\Regex::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Regex::serialize - Serialize a Regex
    • MongoDB\BSON\Regex::unserialize - Unserialize a Regex
    • MongoDB\BSON\Regex::__construct - Construct a new Regex
    • MongoDB\BSON\Regex::__toString - Returns the string representation of this Regex
    • MongoDB\BSON\RegexInterface::getFlags - Returns the RegexInterface's flags
    • MongoDB\BSON\RegexInterface::getPattern - Returns the RegexInterface's pattern
    • MongoDB\BSON\RegexInterface::__toString - Returns the string representation of this RegexInterface
    • MongoDB\BSON\Serializable::bsonSerialize - Provides an array or document to serialize as BSON
    • MongoDB\BSON\Symbol::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Symbol::serialize - Serialize a Symbol
    • MongoDB\BSON\Symbol::unserialize - Unserialize a Symbol
    • MongoDB\BSON\Symbol::__construct - Construct a new Symbol (unused)
    • MongoDB\BSON\Symbol::__toString - Returns the Symbol as a string
    • MongoDB\BSON\Timestamp::getIncrement - Returns the increment component of this Timestamp
    • MongoDB\BSON\Timestamp::getTimestamp - Returns the timestamp component of this Timestamp
    • MongoDB\BSON\Timestamp::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Timestamp::serialize - Serialize a Timestamp
    • MongoDB\BSON\Timestamp::unserialize - Unserialize a Timestamp
    • MongoDB\BSON\Timestamp::__construct - Construct a new Timestamp
    • MongoDB\BSON\Timestamp::__toString - Returns the string representation of this Timestamp
    • MongoDB\BSON\TimestampInterface::getIncrement - Returns the increment component of this TimestampInterface
    • MongoDB\BSON\TimestampInterface::getTimestamp - Returns the timestamp component of this TimestampInterface
    • MongoDB\BSON\TimestampInterface::__toString - Returns the string representation of this TimestampInterface
    • MongoDB\BSON\toCanonicalExtendedJSON - Returns the Canonical Extended JSON representation of a BSON value
    • MongoDB\BSON\toJSON - Returns the Legacy Extended JSON representation of a BSON value
    • MongoDB\BSON\toPHP - Returns the PHP representation of a BSON value
    • MongoDB\BSON\toRelaxedExtendedJSON - Returns the Relaxed Extended JSON representation of a BSON value
    • MongoDB\BSON\Undefined::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Undefined::serialize - Serialize a Undefined
    • MongoDB\BSON\Undefined::unserialize - Unserialize a Undefined
    • MongoDB\BSON\Undefined::__construct - Construct a new Undefined (unused)
    • MongoDB\BSON\Undefined::__toString - Returns an empty string
    • MongoDB\BSON\Unserializable::bsonUnserialize - Constructs the object from a BSON array or document
    • MongoDB\BSON\UTCDateTime::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\UTCDateTime::serialize - Serialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::toDateTime - Returns the DateTime representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::unserialize - Unserialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::__construct - Construct a new UTCDateTime
    • MongoDB\BSON\UTCDateTime::__toString - Returns the string representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTimeInterface::toDateTime - Returns the DateTime representation of this UTCDateTimeInterface
    • MongoDB\BSON\UTCDateTimeInterface::__toString - Returns the string representation of this UTCDateTimeInterface
    • MongoDB\Driver\BulkWrite::count - Count number of write operations in the bulk
    • MongoDB\Driver\BulkWrite::delete - Add a delete operation to the bulk
    • MongoDB\Driver\BulkWrite::insert - Add an insert operation to the bulk
    • MongoDB\Driver\BulkWrite::update - Add an update operation to the bulk
    • MongoDB\Driver\BulkWrite::__construct - Create a new BulkWrite
    • MongoDB\Driver\Command::__construct - Create a new Command
    • MongoDB\Driver\Cursor::current - Returns the current element
    • MongoDB\Driver\Cursor::getId - Returns the ID for this cursor
    • MongoDB\Driver\Cursor::getServer - Returns the server associated with this cursor
    • MongoDB\Driver\Cursor::isDead - Checks if the cursor is exhausted or may have additional results
    • MongoDB\Driver\Cursor::key - Returns the current result's index within the cursor
    • MongoDB\Driver\Cursor::next - Advances the cursor to the next result
    • MongoDB\Driver\Cursor::rewind - Rewind the cursor to the first result
    • MongoDB\Driver\Cursor::setTypeMap - Sets a type map to use for BSON unserialization
    • MongoDB\Driver\Cursor::toArray - Returns an array containing all results for this cursor
    • MongoDB\Driver\Cursor::valid - Checks if the current position in the cursor is valid
    • MongoDB\Driver\Cursor::__construct - Create a new Cursor (not used)
    • MongoDB\Driver\CursorId::serialize - Serialize a CursorId
    • MongoDB\Driver\CursorId::unserialize - Unserialize a CursorId
    • MongoDB\Driver\CursorId::__construct - Create a new CursorId (not used)
    • MongoDB\Driver\CursorId::__toString - String representation of the cursor ID
    • MongoDB\Driver\Exception\RuntimeException::hasErrorLabel - Returns whether an error label is associated with an exception
    • MongoDB\Driver\Exception\WriteException::getWriteResult - Returns the WriteResult for the failed write operation
    • MongoDB\Driver\Manager::createClientEncryption - Create a new ClientEncryption object
    • MongoDB\Driver\Manager::executeBulkWrite - Execute one or more write operations
    • MongoDB\Driver\Manager::executeCommand - Execute a database command
    • MongoDB\Driver\Manager::executeQuery - Execute a database query
    • MongoDB\Driver\Manager::executeReadCommand - Execute a database command that reads
    • MongoDB\Driver\Manager::executeReadWriteCommand - Execute a database command that reads and writes
    • MongoDB\Driver\Manager::executeWriteCommand - Execute a database command that writes
    • MongoDB\Driver\Manager::getReadConcern - Return the ReadConcern for the Manager
    • MongoDB\Driver\Manager::getReadPreference - Return the ReadPreference for the Manager
    • MongoDB\Driver\Manager::getServers - Return the servers to which this manager is connected
    • MongoDB\Driver\Manager::getWriteConcern - Return the WriteConcern for the Manager
    • MongoDB\Driver\Manager::selectServer - Select a server matching a read preference
    • MongoDB\Driver\Manager::startSession - Start a new client session for use with this client
    • MongoDB\Driver\Manager::__construct - Create new MongoDB Manager
    • MongoDB\Driver\Monitoring\addSubscriber - Registers a new monitoring event subscriber
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getCommandName - Returns the command name
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getDurationMicros - Returns the command's duration in microseconds
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getError - Returns the Exception associated with the failed command
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getOperationId - Returns the command's operation ID
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getReply - Returns the command reply document
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getRequestId - Returns the command's request ID
    • MongoDB\Driver\Monitoring\CommandFailedEvent::getServer - Returns the Server on which the command was executed
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getCommand - Returns the command document
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getCommandName - Returns the command name
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getDatabaseName - Returns the database on which the command was executed
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getOperationId - Returns the command's operation ID
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getRequestId - Returns the command's request ID
    • MongoDB\Driver\Monitoring\CommandStartedEvent::getServer - Returns the Server on which the command was executed
    • MongoDB\Driver\Monitoring\CommandSubscriber::commandFailed - Notification method for a failed command
    • MongoDB\Driver\Monitoring\CommandSubscriber::commandStarted - Notification method for a started command
    • MongoDB\Driver\Monitoring\CommandSubscriber::commandSucceeded - Notification method for a successful command
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getCommandName - Returns the command name
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getDurationMicros - Returns the command's duration in microseconds
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getOperationId - Returns the command's operation ID
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getReply - Returns the command reply document
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getRequestId - Returns the command's request ID
    • MongoDB\Driver\Monitoring\CommandSucceededEvent::getServer - Returns the Server on which the command was executed
    • MongoDB\Driver\Monitoring\removeSubscriber - Unregisters an existing monitoring event subscriber
    • MongoDB\Driver\Query::__construct - Create a new Query
    • MongoDB\Driver\ReadConcern::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\ReadConcern::getLevel - Returns the ReadConcern's "level" option
    • MongoDB\Driver\ReadConcern::isDefault - Checks if this is the default read concern
    • MongoDB\Driver\ReadConcern::serialize - Serialize a ReadConcern
    • MongoDB\Driver\ReadConcern::unserialize - Unserialize a ReadConcern
    • MongoDB\Driver\ReadConcern::__construct - Create a new ReadConcern
    • MongoDB\Driver\ReadPreference::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\ReadPreference::getHedge - Returns the ReadPreference's "hedge" option
    • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds - Returns the ReadPreference's "maxStalenessSeconds" option
    • MongoDB\Driver\ReadPreference::getMode - Returns the ReadPreference's "mode" option
    • MongoDB\Driver\ReadPreference::getModeString - Returns the ReadPreference's "mode" option as a string
    • MongoDB\Driver\ReadPreference::getTagSets - Returns the ReadPreference's "tagSets" option
    • MongoDB\Driver\ReadPreference::serialize - Serialize a ReadPreference
    • MongoDB\Driver\ReadPreference::unserialize - Unserialize a ReadPreference
    • MongoDB\Driver\ReadPreference::__construct - Create a new ReadPreference
    • MongoDB\Driver\Server::executeBulkWrite - Execute one or more write operations on this server
    • MongoDB\Driver\Server::executeCommand - Execute a database command on this server
    • MongoDB\Driver\Server::executeQuery - Execute a database query on this server
    • MongoDB\Driver\Server::executeReadCommand - Execute a database command that reads on this server
    • MongoDB\Driver\Server::executeReadWriteCommand - Execute a database command that reads and writes on this server
    • MongoDB\Driver\Server::executeWriteCommand - Execute a database command that writes on this server
    • MongoDB\Driver\Server::getHost - Returns the hostname of this server
    • MongoDB\Driver\Server::getInfo - Returns an array of information about this server
    • MongoDB\Driver\Server::getLatency - Returns the latency of this server
    • MongoDB\Driver\Server::getPort - Returns the port on which this server is listening
    • MongoDB\Driver\Server::getTags - Returns an array of tags describing this server in a replica set
    • MongoDB\Driver\Server::getType - Returns an integer denoting the type of this server
    • MongoDB\Driver\Server::isArbiter - Checks if this server is an arbiter member of a replica set
    • MongoDB\Driver\Server::isHidden - Checks if this server is a hidden member of a replica set
    • MongoDB\Driver\Server::isPassive - Checks if this server is a passive member of a replica set
    • MongoDB\Driver\Server::isPrimary - Checks if this server is a primary member of a replica set
    • MongoDB\Driver\Server::isSecondary - Checks if this server is a secondary member of a replica set
    • MongoDB\Driver\Server::__construct - Create a new Server (not used)
    • MongoDB\Driver\WriteConcern::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\WriteConcern::getJournal - Returns the WriteConcern's "journal" option
    • MongoDB\Driver\WriteConcern::getW - Returns the WriteConcern's "w" option
    • MongoDB\Driver\WriteConcern::getWtimeout - Returns the WriteConcern's "wtimeout" option
    • MongoDB\Driver\WriteConcern::isDefault - Checks if this is the default write concern
    • MongoDB\Driver\WriteConcern::serialize - Serialize a WriteConcern
    • MongoDB\Driver\WriteConcern::unserialize - Unserialize a WriteConcern
    • MongoDB\Driver\WriteConcern::__construct - Create a new WriteConcern
    • MongoDB\Driver\WriteConcernError::getCode - Returns the WriteConcernError's error code
    • MongoDB\Driver\WriteConcernError::getInfo - Returns metadata document for the WriteConcernError
    • MongoDB\Driver\WriteConcernError::getMessage - Returns the WriteConcernError's error message
    • MongoDB\Driver\WriteError::getCode - Returns the WriteError's error code
    • MongoDB\Driver\WriteError::getIndex - Returns the index of the write operation corresponding to this WriteError
    • MongoDB\Driver\WriteError::getInfo - Returns metadata document for the WriteError
    • MongoDB\Driver\WriteError::getMessage - Returns the WriteError's error message
    • MongoDB\Driver\WriteResult::getDeletedCount - Returns the number of documents deleted
    • MongoDB\Driver\WriteResult::getInsertedCount - Returns the number of documents inserted (excluding upserts)
    • MongoDB\Driver\WriteResult::getMatchedCount - Returns the number of documents selected for update
    • MongoDB\Driver\WriteResult::getModifiedCount - Returns the number of existing documents updated
    • MongoDB\Driver\WriteResult::getServer - Returns the server associated with this write result
    • MongoDB\Driver\WriteResult::getUpsertedCount - Returns the number of documents inserted by an upsert
    • MongoDB\Driver\WriteResult::getUpsertedIds - Returns an array of identifiers for upserted documents
    • MongoDB\Driver\WriteResult::getWriteConcernError - Returns any write concern error that occurred
    • MongoDB\Driver\WriteResult::getWriteErrors - Returns any write errors that occurred
    • MongoDB\Driver\WriteResult::isAcknowledged - Returns whether the write was acknowledged
    • MongoGridFS::delete - Remove a file and its chunks from the database
    • MongoGridFS::drop - Drops the files and chunks collections
    • MongoGridFS::find - Queries for files
    • MongoGridFS::findOne - Returns a single file matching the criteria
    • MongoGridFS::get - Retrieve a file from the database
    • MongoGridFS::put - Stores a file in the database
    • MongoGridFS::remove - Remove files and their chunks from the database
    • MongoGridFS::storeBytes - Stores a string of bytes in the database
    • MongoGridFS::storeFile - Stores a file in the database
    • MongoGridFS::storeUpload - Stores an uploaded file in the database
    • MongoGridFS::__construct - Creates new file collections
    • MongoGridFSCursor::current - Returns the current file
    • MongoGridFSCursor::getNext - Return the next file to which this cursor points, and advance the cursor
    • MongoGridFSCursor::key - Returns the current result's filename
    • MongoGridFSCursor::__construct - Create a new cursor
    • MongoGridFSFile::getBytes - Returns this file's contents as a string of bytes
    • MongoGridFSFile::getFilename - Returns this file's filename
    • MongoGridFSFile::getResource - Returns a resource that can be used to read the stored file
    • MongoGridFSFile::getSize - Returns this file's size
    • MongoGridFSFile::write - Writes this file to the filesystem
    • MongoGridfsFile::__construct - Create a new GridFS file
    • MongoId::getHostname - 获取这台机器上 id 所使用的 hostname
    • MongoId::getInc - 返回用于创建 id 所增加的值
    • MongoId::getPID - 获取进程 ID
    • MongoId::getTimestamp - 获取新纪元时间到 id 创建时的秒数。
    • MongoId::isValid - Check if a value is a valid ObjectId
    • MongoId::__construct - 创建一个新的id
    • MongoId::__set_state - 创建一个假的 MongoId
    • MongoId::__toString - 返回该 id 十六进制的表示形式
    • MongoInt32::__construct - 创建一个新的 32位 integer。
    • MongoInt32::__toString - 返回该 32 位 integer 的字符串表示。
    • MongoInt64::__construct - 创建一个新的 64 位 integer。
    • MongoInt64::__toString - 返回该 64 位 integer 的字符串表示形式。
    • MongoLog::getCallback - Gets the previously set callback function
    • MongoLog::getLevel - Gets the level(s) currently being logged
    • MongoLog::getModule - Gets the module(s) currently being logged
    • MongoLog::setCallback - Sets a callback function to be invoked for events
    • MongoLog::setLevel - Sets the level(s) to be logged
    • MongoLog::setModule - Sets the module(s) to be logged
    • MongoPool::getSize - Get pool size for connection pools
    • MongoPool::info - Returns information about all connection pools
    • MongoPool::setSize - Set the size for future connection pools
    • MongoRegex::__construct - 创建一个新的正则表达式
    • MongoRegex::__toString - 正则表达式的字符串表达形式
    • MongoResultException::getDocument - 获取完整的结果文档
    • MongoTimestamp::__construct - 创建一个新的时间戳。
    • MongoTimestamp::__toString - 返回时间戳的字符串表示形式
    • MongoWriteConcernException::getDocument - Get the error document
    • move_uploaded_file - 将上传的文件移动到新位置
    • mqseries_back - MQSeries MQBACK
    • mqseries_begin - MQseries MQBEGIN
    • mqseries_close - MQSeries MQCLOSE
    • mqseries_cmit - MQSeries MQCMIT
    • mqseries_conn - MQSeries MQCONN
    • mqseries_connx - MQSeries MQCONNX
    • mqseries_disc - MQSeries MQDISC
    • mqseries_get - MQSeries MQGET
    • mqseries_inq - MQSeries MQINQ
    • mqseries_open - MQSeries MQOPEN
    • mqseries_put - MQSeries MQPUT
    • mqseries_put1 - MQSeries MQPUT1
    • mqseries_set - MQSeries MQSET
    • mqseries_strerror - Returns the error message corresponding to a result code (MQRC)
    • msg_get_queue - Create or attach to a message queue
    • msg_queue_exists - Check whether a message queue exists
    • msg_receive - Receive a message from a message queue
    • msg_remove_queue - Destroy a message queue
    • msg_send - Send a message to a message queue
    • msg_set_queue - Set information in the message queue data structure
    • msg_stat_queue - Returns information from the message queue data structure
    • mt_getrandmax - 显示随机数的最大可能值
    • mt_rand - 生成更好的随机数
    • mt_srand - 播下一个更好的随机数发生器种子
    • MultipleIterator::attachIterator - Attaches iterator information
    • MultipleIterator::containsIterator - Checks if an iterator is attached
    • MultipleIterator::countIterators - Gets the number of attached iterator instances
    • MultipleIterator::current - Gets the registered iterator instances
    • MultipleIterator::detachIterator - Detaches an iterator
    • MultipleIterator::getFlags - Gets the flag information
    • MultipleIterator::key - Gets the registered iterator instances
    • MultipleIterator::next - Moves all attached iterator instances forward
    • MultipleIterator::rewind - Rewinds all attached iterator instances
    • MultipleIterator::setFlags - Sets flags
    • MultipleIterator::valid - Checks the validity of sub iterators
    • MultipleIterator::__construct - Constructs a new MultipleIterator
    • Mutex::create - 创建一个互斥量
    • Mutex::destroy - 销毁互斥量
    • Mutex::lock - 给互斥量加锁
    • Mutex::trylock - 尝试给互斥量加锁
    • Mutex::unlock - 释放互斥量上的锁
    • mysqli::$affected_rows - Gets the number of affected rows in a previous MySQL operation
    • mysqli::$client_info - 获取 MySQL 客户端信息
    • mysqli::$connect_errno - Returns the error code from last connect call
    • mysqli::$connect_error - Returns a string description of the last connect error
    • mysqli::$error - Returns a string description of the last error
    • mysqli::$error_list - Returns a list of errors from the last command executed
    • mysqli::$field_count - Returns the number of columns for the most recent query
    • mysqli::$host_info - 返回一个表述使用的连接类型的字符串
    • mysqli::$info - 返回最近执行的 SQL 语句的信息
    • mysqli::$insert_id - 返回最后一条插入语句产生的自增 ID
    • mysqli::$protocol_version - 返回MySQL使用的协议版本号
    • mysqli::$server_info - 返回MySQL服务器的版本号
    • mysqli::$server_version - 作为一个整数返回MySQL服务器的版本
    • mysqli::$sqlstate - 返回上一次 SQL 操作的 SQLSTATE 错误信息
    • mysqli::$thread_id - 返回当前连接的线程 ID
    • mysqli::$warning_count - Returns the number of warnings from the last query for the given link
    • mysqli::autocommit - 打开或关闭本次数据库连接的自动命令提交事务模式
    • mysqli::begin_transaction - Starts a transaction
    • mysqli::change_user - Changes the user of the specified database connection
    • mysqli::character_set_name - 返回当前数据库连接的默认字符编码
    • mysqli::close - 关闭先前打开的数据库连接
    • mysqli::commit - 提交一个事务
    • mysqli::debug - Performs debugging operations
    • mysqli::dump_debug_info - 将调试信息输出到日志
    • mysqli::errno - 返回最近函数调用的错误代码
    • mysqli::get_charset - Returns a character set object
    • mysqli::get_connection_stats - 返回客户端连接的统计数据
    • mysqli::get_warnings - Get result of SHOW WARNINGS
    • mysqli::init - 初始化 MySQLi 并返回一个资源类型的值，这个值可以作为 mysqli_real_connect() 函数的传入参数
    • mysqli::kill - 让服务器杀掉一个 MySQL 线程
    • mysqli::more_results - 检查批量查询中是否还有查询结果
    • mysqli::multi_query - 执行查询
    • mysqli::next_result - 为读取 multi_query 执行之后的下一个结果集做准备
    • mysqli::options - 设置选项
    • mysqli::ping - ping 一个连接，或者如果连接处于断开状态，重新连接
    • mysqli::poll - 轮询连接
    • mysqli::prepare - 准备执行一个 SQL 语句
    • mysqli::query - 对数据库执行一次查询
    • mysqli::real_connect - 建立一个 MySQL 服务器连接
    • mysqli::real_escape_string - 根据当前连接的字符集，对于 SQL 语句中的特殊字符进行转义
    • mysqli::real_query - 执行一个mysql查询
    • mysqli::reap_async_query - 获取异步查询的结果
    • mysqli::refresh - 刷新
    • mysqli::release_savepoint - 从当前事务的保存点中移除一个命名保存点
    • mysqli::rollback - 回退当前事务
    • mysqli::savepoint - 在当前事务中增加一个命名保存点
    • mysqli::select_db - 选择用于数据库查询的默认数据库
    • mysqli::set_charset - 设置默认字符编码
    • mysqli::set_opt - Alias of mysqli_options
    • mysqli::ssl_set - 使用 SSL 建立到数据库之间的安全连接
    • mysqli::stat - 获取当前系统状态信息
    • mysqli::stmt_init - 初始化一条语句并返回一个用于mysqli_stmt_prepare(调用)的对象
    • mysqli::store_result - 转移上一次查询返回的结果集
    • mysqli::thread_safe - 返回是否是线程安全的
    • mysqli::use_result - Initiate a result set retrieval
    • mysqli::__construct - Open a new connection to the MySQL server
    • mysqli_connect - 别名 mysqli::__construct
    • mysqli_driver::$report_mode - Sets mysqli error reporting mode
    • mysqli_driver::embedded_server_end - Stop embedded server
    • mysqli_driver::embedded_server_start - Initialize and start embedded server
    • mysqli_escape_string - 别名 mysqli_real_escape_string
    • mysqli_execute - mysqli_stmt_execute 的别名
    • mysqli_get_client_stats - 返回客户端进程统计信息
    • mysqli_get_client_version - 作为一个整数返回MySQL客户端的版本
    • mysqli_get_links_stats - 返回打开和缓存的链接相关信息
    • mysqli_report - 别名 mysqli_driver->report_mode
    • mysqli_result::$current_field - Get current field offset of a result pointer
    • mysqli_result::$field_count - Get the number of fields in a result
    • mysqli_result::$lengths - Returns the lengths of the columns of the current row in the result set
    • mysqli_result::$num_rows - Gets the number of rows in a result
    • mysqli_result::data_seek - Adjusts the result pointer to an arbitrary row in the result
    • mysqli_result::fetch_all - Fetches all result rows as an associative array, a numeric array, or both
    • mysqli_result::fetch_array - Fetch a result row as an associative, a numeric array, or both
    • mysqli_result::fetch_assoc - Fetch a result row as an associative array
    • mysqli_result::fetch_field - Returns the next field in the result set
    • mysqli_result::fetch_fields - Returns an array of objects representing the fields in a result set
    • mysqli_result::fetch_field_direct - Fetch meta-data for a single field
    • mysqli_result::fetch_object - Returns the current row of a result set as an object
    • mysqli_result::fetch_row - Get a result row as an enumerated array
    • mysqli_result::field_seek - Set result pointer to a specified field offset
    • mysqli_result::free - Frees the memory associated with a result
    • mysqli_stmt::$affected_rows - Returns the total number of rows changed, deleted, or inserted by the last executed statement
    • mysqli_stmt::$errno - Returns the error code for the most recent statement call
    • mysqli_stmt::$error - Returns a string description for last statement error
    • mysqli_stmt::$error_list - Returns a list of errors from the last statement executed
    • mysqli_stmt::$field_count - Returns the number of columns in the given statement
    • mysqli_stmt::$insert_id - Get the ID generated from the previous INSERT operation
    • mysqli_stmt::$num_rows - Return the number of rows in statements result set
    • mysqli_stmt::$param_count - Returns the number of parameters for the given statement
    • mysqli_stmt::$sqlstate - Returns SQLSTATE error from previous statement operation
    • mysqli_stmt::attr_get - Used to get the current value of a statement attribute
    • mysqli_stmt::attr_set - Used to modify the behavior of a prepared statement
    • mysqli_stmt::bind_param - Binds variables to a prepared statement as parameters
    • mysqli_stmt::bind_result - Binds variables to a prepared statement for result storage
    • mysqli_stmt::close - Closes a prepared statement
    • mysqli_stmt::data_seek - Seeks to an arbitrary row in statement result set
    • mysqli_stmt::execute - Executes a prepared Query
    • mysqli_stmt::fetch - Fetch results from a prepared statement into the bound variables
    • mysqli_stmt::free_result - Frees stored result memory for the given statement handle
    • mysqli_stmt::get_result - Gets a result set from a prepared statement
    • mysqli_stmt::get_warnings - Get result of SHOW WARNINGS
    • mysqli_stmt::more_results - Check if there are more query results from a multiple query
    • mysqli_stmt::next_result - Reads the next result from a multiple query
    • mysqli_stmt::prepare - Prepare an SQL statement for execution
    • mysqli_stmt::reset - Resets a prepared statement
    • mysqli_stmt::result_metadata - Returns result set metadata from a prepared statement
    • mysqli_stmt::send_long_data - Send data in blocks
    • mysqli_stmt::store_result - Transfers a result set from a prepared statement
    • mysqli_stmt::__construct - Constructs a new mysqli_stmt object
    • mysqli_warning::next - Fetch next warning
    • MysqlndUhConnection::changeUser - Changes the user of the specified mysqlnd database connection
    • MysqlndUhConnection::charsetName - Returns the default character set for the database connection
    • MysqlndUhConnection::close - Closes a previously opened database connection
    • MysqlndUhConnection::connect - Open a new connection to the MySQL server
    • MysqlndUhConnection::endPSession - End a persistent connection
    • MysqlndUhConnection::escapeString - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
    • MysqlndUhConnection::getAffectedRows - Gets the number of affected rows in a previous MySQL operation
    • MysqlndUhConnection::getErrorNumber - Returns the error code for the most recent function call
    • MysqlndUhConnection::getErrorString - Returns a string description of the last error
    • MysqlndUhConnection::getFieldCount - Returns the number of columns for the most recent query
    • MysqlndUhConnection::getHostInformation - Returns a string representing the type of connection used
    • MysqlndUhConnection::getLastInsertId - Returns the auto generated id used in the last query
    • MysqlndUhConnection::getLastMessage - Retrieves information about the most recently executed query
    • MysqlndUhConnection::getProtocolInformation - Returns the version of the MySQL protocol used
    • MysqlndUhConnection::getServerInformation - Returns the version of the MySQL server
    • MysqlndUhConnection::getServerStatistics - Gets the current system status
    • MysqlndUhConnection::getServerVersion - Returns the version of the MySQL server as an integer
    • MysqlndUhConnection::getSqlstate - Returns the SQLSTATE error from previous MySQL operation
    • MysqlndUhConnection::getStatistics - Returns statistics about the client connection
    • MysqlndUhConnection::getThreadId - Returns the thread ID for the current connection
    • MysqlndUhConnection::getWarningCount - Returns the number of warnings from the last query for the given link
    • MysqlndUhConnection::init - Initialize mysqlnd connection
    • MysqlndUhConnection::killConnection - Asks the server to kill a MySQL thread
    • MysqlndUhConnection::listFields - List MySQL table fields
    • MysqlndUhConnection::listMethod - Wrapper for assorted list commands
    • MysqlndUhConnection::moreResults - Check if there are any more query results from a multi query
    • MysqlndUhConnection::nextResult - Prepare next result from multi_query
    • MysqlndUhConnection::ping - Pings a server connection, or tries to reconnect if the connection has gone down
    • MysqlndUhConnection::query - Performs a query on the database
    • MysqlndUhConnection::queryReadResultsetHeader - Read a result set header
    • MysqlndUhConnection::reapQuery - Get result from async query
    • MysqlndUhConnection::refreshServer - Flush or reset tables and caches
    • MysqlndUhConnection::restartPSession - Restart a persistent mysqlnd connection
    • MysqlndUhConnection::selectDb - Selects the default database for database queries
    • MysqlndUhConnection::sendClose - Sends a close command to MySQL
    • MysqlndUhConnection::sendQuery - Sends a query to MySQL
    • MysqlndUhConnection::serverDumpDebugInformation - Dump debugging information into the log for the MySQL server
    • MysqlndUhConnection::setAutocommit - Turns on or off auto-committing database modifications
    • MysqlndUhConnection::setCharset - Sets the default client character set
    • MysqlndUhConnection::setClientOption - Sets a client option
    • MysqlndUhConnection::setServerOption - Sets a server option
    • MysqlndUhConnection::shutdownServer - The shutdownServer purpose
    • MysqlndUhConnection::simpleCommand - Sends a basic COM_* command
    • MysqlndUhConnection::simpleCommandHandleResponse - Process a response for a basic COM_* command send to the client
    • MysqlndUhConnection::sslSet - Used for establishing secure connections using SSL
    • MysqlndUhConnection::stmtInit - Initializes a statement and returns a resource for use with mysqli_statement::prepare
    • MysqlndUhConnection::storeResult - Transfers a result set from the last query
    • MysqlndUhConnection::txCommit - Commits the current transaction
    • MysqlndUhConnection::txRollback - Rolls back current transaction
    • MysqlndUhConnection::useResult - Initiate a result set retrieval
    • MysqlndUhConnection::__construct - The __construct purpose
    • MysqlndUhPreparedStatement::execute - Executes a prepared Query
    • MysqlndUhPreparedStatement::prepare - Prepare an SQL statement for execution
    • MysqlndUhPreparedStatement::__construct - The __construct purpose
    • mysqlnd_memcache_get_config - Returns information about the plugin configuration
    • mysqlnd_memcache_set - Associate a MySQL connection with a Memcache connection
    • mysqlnd_ms_dump_servers - Returns a list of currently configured servers
    • mysqlnd_ms_fabric_select_global - Switch to global sharding server for a given table
    • mysqlnd_ms_fabric_select_shard - Switch to shard
    • mysqlnd_ms_get_last_gtid - 返回最后的全局同步 ID (GTID)
    • mysqlnd_ms_get_last_used_connection - Returns an array which describes the last used connection
    • mysqlnd_ms_get_stats - Returns query distribution and connection statistics
    • mysqlnd_ms_match_wild - Finds whether a table name matches a wildcard pattern or not
    • mysqlnd_ms_query_is_select - 查询给定的 SQL 会发送给 master、slave 还是最后使用的 MySQL server 执行。
    • mysqlnd_ms_set_qos - Sets the quality of service needed from the cluster
    • mysqlnd_ms_set_user_pick_server - Sets a callback for user-defined read/write splitting
    • mysqlnd_ms_xa_begin - Starts a distributed/XA transaction among MySQL servers
    • mysqlnd_ms_xa_commit - Commits a distributed/XA transaction among MySQL servers
    • mysqlnd_ms_xa_gc - Garbage collects unfinished XA transactions after severe errors
    • mysqlnd_ms_xa_rollback - Rolls back a distributed/XA transaction among MySQL servers
    • mysqlnd_qc_clear_cache - Flush all cache contents
    • mysqlnd_qc_get_available_handlers - Returns a list of available storage handler
    • mysqlnd_qc_get_cache_info - Returns information on the current handler, the number of cache entries and cache entries, if available
    • mysqlnd_qc_get_core_stats - Statistics collected by the core of the query cache
    • mysqlnd_qc_get_normalized_query_trace_log - Returns a normalized query trace log for each query inspected by the query cache
    • mysqlnd_qc_get_query_trace_log - Returns a backtrace for each query inspected by the query cache
    • mysqlnd_qc_set_cache_condition - Set conditions for automatic caching
    • mysqlnd_qc_set_is_select - Installs a callback which decides whether a statement is cached
    • mysqlnd_qc_set_storage_handler - Change current storage handler
    • mysqlnd_qc_set_user_handlers - Sets the callback functions for a user-defined procedural storage handler
    • mysqlnd_uh_convert_to_mysqlnd - Converts a MySQL connection handle into a mysqlnd connection handle
    • mysqlnd_uh_set_connection_proxy - Installs a proxy for mysqlnd connections
    • mysqlnd_uh_set_statement_proxy - Installs a proxy for mysqlnd statements
    • mysql_affected_rows - 取得前一次 MySQL 操作所影响的记录行数
    • mysql_client_encoding - 返回字符集的名称
    • mysql_close - 关闭 MySQL 连接
    • mysql_connect - 打开一个到 MySQL 服务器的连接
    • mysql_create_db - 新建一个 MySQL 数据库
    • mysql_data_seek - 移动内部结果的指针
    • mysql_db_name - 取得 mysql_list_dbs 返回的结果数据
    • mysql_db_query - 发送一条 MySQL 查询
    • mysql_drop_db - 丢弃（删除）一个 MySQL 数据库
    • mysql_errno - 返回上一个 MySQL 操作中的错误信息的数字编码
    • mysql_error - 返回上一个 MySQL 操作产生的文本错误信息
    • mysql_escape_string - 转义一个字符串用于 mysql_query
    • mysql_fetch_array - 从结果集中取得一行作为关联数组
    • mysql_fetch_assoc - 从结果集中取得一行作为关联数组
    • mysql_fetch_field - 从结果集中取得列信息并作为对象返回
    • mysql_fetch_lengths - 取得结果集中每个输出的长度
    • mysql_fetch_object - 从结果集中取得一行作为对象返回
    • mysql_fetch_row - 从结果集中取得一行作为枚举数组
    • mysql_field_flags - 从结果中取得和指定字段关联的标志
    • mysql_field_len - 返回指定字段的长度
    • mysql_field_name - 取得结果中指定字段的字段名
    • mysql_field_seek - 将结果集中的指针设定为制定的字段偏移量
    • mysql_field_table - 取得指定字段所在的表名
    • mysql_field_type - 取得结果集中指定字段的类型
    • mysql_free_result - 释放结果内存
    • mysql_get_client_info - 取得 MySQL 客户端信息
    • mysql_get_host_info - 取得 MySQL 主机信息
    • mysql_get_proto_info - 取得 MySQL 协议信息
    • mysql_get_server_info - 取得 MySQL 服务器信息
    • mysql_info - 取得最近一条查询的信息
    • mysql_insert_id - 取得上一步 INSERT 操作产生的 ID
    • mysql_list_dbs - 列出 MySQL 服务器中所有的数据库
    • mysql_list_fields - 列出 MySQL 结果中的字段
    • mysql_list_processes - 列出 MySQL 进程
    • mysql_list_tables - 列出 MySQL 数据库中的表
    • mysql_num_fields - 取得结果集中字段的数目
    • mysql_num_rows - 取得结果集中行的数目
    • mysql_pconnect - 打开一个到 MySQL 服务器的持久连接
    • mysql_ping - Ping 一个服务器连接，如果没有连接则重新连接
    • mysql_query - 发送一条 MySQL 查询
    • mysql_real_escape_string - 转义 SQL 语句中使用的字符串中的特殊字符，并考虑到连接的当前字符集
    • mysql_result - 取得结果数据
    • mysql_select_db - 选择 MySQL 数据库
    • mysql_set_charset - 设置客户端的字符集
    • mysql_stat - 取得当前系统状态
    • mysql_tablename - 取得表名
    • mysql_thread_id - 返回当前线程的 ID
    • mysql_unbuffered_query - 向 MySQL 发送一条 SQL 查询，并不获取和缓存结果的行
    • mysql_xdevapi\Client::close - Close client
  • n
    • natcasesort - 用“自然排序”算法对数组进行不区分大小写字母的排序
    • natsort - 用“自然排序”算法对数组排序
    • ncurses_addch - Add character at current position and advance cursor
    • ncurses_addchnstr - Add attributed string with specified length at current position
    • ncurses_addchstr - Add attributed string at current position
    • ncurses_addnstr - Add string with specified length at current position
    • ncurses_addstr - Output text at current position
    • ncurses_assume_default_colors - Define default colors for color 0
    • ncurses_attroff - Turn off the given attributes
    • ncurses_attron - Turn on the given attributes
    • ncurses_attrset - Set given attributes
    • ncurses_baudrate - Returns baudrate of terminal
    • ncurses_beep - Let the terminal beep
    • ncurses_bkgd - Set background property for terminal screen
    • ncurses_bkgdset - Control screen background
    • ncurses_border - Draw a border around the screen using attributed characters
    • ncurses_bottom_panel - Moves a visible panel to the bottom of the stack
    • ncurses_can_change_color - Checks if terminal color definitions can be changed
    • ncurses_cbreak - Switch off input buffering
    • ncurses_clear - Clear screen
    • ncurses_clrtobot - Clear screen from current position to bottom
    • ncurses_clrtoeol - Clear screen from current position to end of line
    • ncurses_color_content - Retrieves RGB components of a color
    • ncurses_color_set - Set active foreground and background colors
    • ncurses_curs_set - Set cursor state
    • ncurses_define_key - Define a keycode
    • ncurses_def_prog_mode - Saves terminals (program) mode
    • ncurses_def_shell_mode - Saves terminals (shell) mode
    • ncurses_delay_output - Delay output on terminal using padding characters
    • ncurses_delch - Delete character at current position, move rest of line left
    • ncurses_deleteln - Delete line at current position, move rest of screen up
    • ncurses_delwin - Delete a ncurses window
    • ncurses_del_panel - Remove panel from the stack and delete it (but not the associated window)
    • ncurses_doupdate - Write all prepared refreshes to terminal
    • ncurses_echo - Activate keyboard input echo
    • ncurses_echochar - Single character output including refresh
    • ncurses_end - Stop using ncurses, clean up the screen
    • ncurses_erase - Erase terminal screen
    • ncurses_erasechar - Returns current erase character
    • ncurses_filter - Set LINES for iniscr() and newterm() to 1
    • ncurses_flash - Flash terminal screen (visual bell)
    • ncurses_flushinp - Flush keyboard input buffer
    • ncurses_getch - Read a character from keyboard
    • ncurses_getmaxyx - Returns the size of a window
    • ncurses_getmouse - Reads mouse event
    • ncurses_getyx - Returns the current cursor position for a window
    • ncurses_halfdelay - Put terminal into halfdelay mode
    • ncurses_has_colors - Checks if terminal has color capabilities
    • ncurses_has_ic - Check for insert- and delete-capabilities
    • ncurses_has_il - Check for line insert- and delete-capabilities
    • ncurses_has_key - Check for presence of a function key on terminal keyboard
    • ncurses_hide_panel - Remove panel from the stack, making it invisible
    • ncurses_hline - Draw a horizontal line at current position using an attributed character and max. n characters long
    • ncurses_inch - Get character and attribute at current position
    • ncurses_init - Initialize ncurses
    • ncurses_init_color - Define a terminal color
    • ncurses_init_pair - Define a color pair
    • ncurses_insch - Insert character moving rest of line including character at current position
    • ncurses_insdelln - Insert lines before current line scrolling down (negative numbers delete and scroll up)
    • ncurses_insertln - Insert a line, move rest of screen down
    • ncurses_insstr - Insert string at current position, moving rest of line right
    • ncurses_instr - Reads string from terminal screen
    • ncurses_isendwin - Ncurses is in endwin mode, normal screen output may be performed
    • ncurses_keyok - Enable or disable a keycode
    • ncurses_keypad - Turns keypad on or off
    • ncurses_killchar - Returns current line kill character
    • ncurses_longname - Returns terminals description
    • ncurses_meta - Enables/Disable 8-bit meta key information
    • ncurses_mouseinterval - Set timeout for mouse button clicks
    • ncurses_mousemask - Sets mouse options
    • ncurses_mouse_trafo - Transforms coordinates
    • ncurses_move - Move output position
    • ncurses_move_panel - Moves a panel so that its upper-left corner is at [startx, starty]
    • ncurses_mvaddch - Move current position and add character
    • ncurses_mvaddchnstr - Move position and add attributed string with specified length
    • ncurses_mvaddchstr - Move position and add attributed string
    • ncurses_mvaddnstr - Move position and add string with specified length
    • ncurses_mvaddstr - Move position and add string
    • ncurses_mvcur - Move cursor immediately
    • ncurses_mvdelch - Move position and delete character, shift rest of line left
    • ncurses_mvgetch - Move position and get character at new position
    • ncurses_mvhline - Set new position and draw a horizontal line using an attributed character and max. n characters long
    • ncurses_mvinch - Move position and get attributed character at new position
    • ncurses_mvvline - Set new position and draw a vertical line using an attributed character and max. n characters long
    • ncurses_mvwaddstr - Add string at new position in window
    • ncurses_napms - Sleep
    • ncurses_newpad - Creates a new pad (window)
    • ncurses_newwin - Create a new window
    • ncurses_new_panel - Create a new panel and associate it with window
    • ncurses_nl - Translate newline and carriage return / line feed
    • ncurses_nocbreak - Switch terminal to cooked mode
    • ncurses_noecho - Switch off keyboard input echo
    • ncurses_nonl - Do not translate newline and carriage return / line feed
    • ncurses_noqiflush - Do not flush on signal characters
    • ncurses_noraw - Switch terminal out of raw mode
    • ncurses_pair_content - Retrieves foreground and background colors of a color pair
    • ncurses_panel_above - Returns the panel above panel
    • ncurses_panel_below - Returns the panel below panel
    • ncurses_panel_window - Returns the window associated with panel
    • ncurses_pnoutrefresh - Copies a region from a pad into the virtual screen
    • ncurses_prefresh - Copies a region from a pad into the virtual screen
    • ncurses_putp - Apply padding information to the string and output it
    • ncurses_qiflush - Flush on signal characters
    • ncurses_raw - Switch terminal into raw mode
    • ncurses_refresh - Refresh screen
    • ncurses_replace_panel - Replaces the window associated with panel
    • ncurses_resetty - Restores saved terminal state
    • ncurses_reset_prog_mode - Resets the prog mode saved by def_prog_mode
    • ncurses_reset_shell_mode - Resets the shell mode saved by def_shell_mode
    • ncurses_savetty - Saves terminal state
    • ncurses_scrl - Scroll window content up or down without changing current position
    • ncurses_scr_dump - Dump screen content to file
    • ncurses_scr_init - Initialize screen from file dump
    • ncurses_scr_restore - Restore screen from file dump
    • ncurses_scr_set - Inherit screen from file dump
    • ncurses_show_panel - Places an invisible panel on top of the stack, making it visible
    • ncurses_slk_attr - Returns current soft label key attribute
    • ncurses_slk_attroff - Turn off the given attributes for soft function-key labels
    • ncurses_slk_attron - Turn on the given attributes for soft function-key labels
    • ncurses_slk_attrset - Set given attributes for soft function-key labels
    • ncurses_slk_clear - Clears soft labels from screen
    • ncurses_slk_color - Sets color for soft label keys
    • ncurses_slk_init - Initializes soft label key functions
    • ncurses_slk_noutrefresh - Copies soft label keys to virtual screen
    • ncurses_slk_refresh - Copies soft label keys to screen
    • ncurses_slk_restore - Restores soft label keys
    • ncurses_slk_set - Sets function key labels
    • ncurses_slk_touch - Forces output when ncurses_slk_noutrefresh is performed
    • ncurses_standend - Stop using 'standout' attribute
    • ncurses_standout - Start using 'standout' attribute
    • ncurses_start_color - Initializes color functionality
    • ncurses_termattrs - Returns a logical OR of all attribute flags supported by terminal
    • ncurses_termname - Returns terminals (short)-name
    • ncurses_timeout - Set timeout for special key sequences
    • ncurses_top_panel - Moves a visible panel to the top of the stack
    • ncurses_typeahead - Specify different filedescriptor for typeahead checking
    • ncurses_ungetch - Put a character back into the input stream
    • ncurses_ungetmouse - Pushes mouse event to queue
    • ncurses_update_panels - Refreshes the virtual screen to reflect the relations between panels in the stack
    • ncurses_use_default_colors - Assign terminal default colors to color id -1
    • ncurses_use_env - Control use of environment information about terminal size
    • ncurses_use_extended_names - Control use of extended names in terminfo descriptions
    • ncurses_vidattr - Display the string on the terminal in the video attribute mode
    • ncurses_vline - Draw a vertical line at current position using an attributed character and max. n characters long
    • ncurses_waddch - Adds character at current position in a window and advance cursor
    • ncurses_waddstr - Outputs text at current postion in window
    • ncurses_wattroff - Turns off attributes for a window
    • ncurses_wattron - Turns on attributes for a window
    • ncurses_wattrset - Set the attributes for a window
    • ncurses_wborder - Draws a border around the window using attributed characters
    • ncurses_wclear - Clears window
    • ncurses_wcolor_set - Sets windows color pairings
    • ncurses_werase - Erase window contents
    • ncurses_wgetch - Reads a character from keyboard (window)
    • ncurses_whline - Draws a horizontal line in a window at current position using an attributed character and max. n characters long
    • ncurses_wmouse_trafo - Transforms window/stdscr coordinates
    • ncurses_wmove - Moves windows output position
    • ncurses_wnoutrefresh - Copies window to virtual screen
    • ncurses_wrefresh - Refresh window on terminal screen
    • ncurses_wstandend - End standout mode for a window
    • ncurses_wstandout - Enter standout mode for a window
    • ncurses_wvline - Draws a vertical line in a window at current position using an attributed character and max. n characters long
    • next - 将数组中的内部指针向前移动一位
    • ngettext - Plural version of gettext
    • nl2br - 在字符串所有新行之前插入 HTML 换行标记
    • nl_langinfo - Query language and locale information
    • NoRewindIterator::current - Get the current value
    • NoRewindIterator::getInnerIterator - Get the inner iterator
    • NoRewindIterator::key - Get the current key
    • NoRewindIterator::next - Forward to the next element
    • NoRewindIterator::rewind - Prevents the rewind operation on the inner iterator
    • NoRewindIterator::valid - Validates the iterator
    • NoRewindIterator::__construct - Construct a NoRewindIterator
    • Normalizer::getRawDecomposition - Gets the Decomposition_Mapping property for the given UTF-8 encoded code point
    • Normalizer::isNormalized - Checks if the provided string is already in the specified normalization form
    • Normalizer::normalize - Normalizes the input provided and returns the normalized string
    • NumberFormatter::create - Create a number formatter
    • NumberFormatter::format - Format a number
    • NumberFormatter::formatCurrency - Format a currency value
    • NumberFormatter::getAttribute - Get an attribute
    • NumberFormatter::getErrorCode - Get formatter's last error code
    • NumberFormatter::getErrorMessage - Get formatter's last error message
    • NumberFormatter::getLocale - Get formatter locale
    • NumberFormatter::getPattern - Get formatter pattern
    • NumberFormatter::getSymbol - Get a symbol value
    • NumberFormatter::getTextAttribute - Get a text attribute
    • NumberFormatter::parse - Parse a number
    • NumberFormatter::parseCurrency - Parse a currency number
    • NumberFormatter::setAttribute - Set an attribute
    • NumberFormatter::setPattern - Set formatter pattern
    • NumberFormatter::setSymbol - Set a symbol value
    • NumberFormatter::setTextAttribute - Set a text attribute
    • number_format - 以千位分隔符方式格式化一个数字
  • o
    • OAuth::disableDebug - 关闭详细的调试
    • OAuth::disableRedirects - 关闭重定向
    • OAuth::disableSSLChecks - 关闭 SSL 检查
    • OAuth::enableDebug - 启用详细调试
    • OAuth::enableRedirects - 启用重定向
    • OAuth::enableSSLChecks - 启用 SSL 检查
    • OAuth::fetch - 获取一个 OAuth 受保护的资源
    • OAuth::generateSignature - 生成一个签名
    • OAuth::getAccessToken - 获取一个访问令牌
    • OAuth::getCAPath - 获取 CA 信息
    • OAuth::getLastResponse - 获取最后一次的响应
    • OAuth::getLastResponseHeaders - 获取最后一次响应的头信息
    • OAuth::getLastResponseInfo - 获取关于最后一次响应的 HTTP 信息
    • OAuth::getRequestHeader - 生成 OAuth 头信息字符串签名
    • OAuth::getRequestToken - 获取一个请求令牌
    • OAuth::setAuthType - 设置授权类型
    • OAuth::setCAPath - 设置 CA 路径和信息
    • OAuth::setNonce - 为后续请求设置现时标志
    • OAuth::setRequestEngine - 设置目标请求引擎
    • OAuth::setRSACertificate - 设置 RSA 证书
    • OAuth::setSSLChecks - 调整特定的SSL请求检查
    • OAuth::setTimestamp - 设置时间戳
    • OAuth::setToken - 设置令牌和 secret
    • OAuth::setVersion - 设置 OAuth 版本
    • OAuth::__construct - 新建一个 OAuth 对象
    • OAuth::__destruct - 析构函数
    • OAuthProvider::addRequiredParameter - 添加必需的参数
    • OAuthProvider::callconsumerHandler - 调用 consumerNonceHandler 回调函数
    • OAuthProvider::callTimestampNonceHandler - 调用 timestampNonceHandler 回调函数
    • OAuthProvider::calltokenHandler - 调用 tokenNonceHandler 回调函数
    • OAuthProvider::checkOAuthRequest - 检查一个 oauth 请求
    • OAuthProvider::consumerHandler - 设置 consumerHandler 句柄回调函数
    • OAuthProvider::generateToken - 生成一个随机令牌
    • OAuthProvider::is2LeggedEndpoint - is2LeggedEndpoint
    • OAuthProvider::isRequestTokenEndpoint - 设置 isRequestTokenEndpoint
    • OAuthProvider::removeRequiredParameter - 移除一个必需的参数
    • OAuthProvider::reportProblem - 报告问题
    • OAuthProvider::setParam - 设置一个参数
    • OAuthProvider::setRequestTokenPath - 设置请求令牌路径
    • OAuthProvider::timestampNonceHandler - 设置 timestampNonceHandler 句柄回调函数
    • OAuthProvider::tokenHandler - 设置 tokenHandler 句柄回调函数
    • OAuthProvider::__construct - 新建一个 OAuthProvider 对象
    • oauth_get_sbs - 生成一个签名字符基串
    • oauth_urlencode - 将 URI 编码为 RFC 3986 规范
    • ob_clean - 清空（擦掉）输出缓冲区
    • ob_end_clean - 清空（擦除）缓冲区并关闭输出缓冲
    • ob_end_flush - 冲刷出（送出）输出缓冲区内容并关闭缓冲
    • ob_flush - 冲刷出（送出）输出缓冲区中的内容
    • ob_get_clean - 得到当前缓冲区的内容并删除当前输出缓。
    • ob_get_contents - 返回输出缓冲区的内容
    • ob_get_flush - 刷出（送出）缓冲区内容，以字符串形式返回内容，并关闭输出缓冲区。
    • ob_get_length - 返回输出缓冲区内容的长度
    • ob_get_level - 返回输出缓冲机制的嵌套级别
    • ob_get_status - 得到所有输出缓冲区的状态
    • ob_gzhandler - 在ob_start中使用的用来压缩输出缓冲区中内容的回调函数。ob_start callback function to gzip output buffer
    • ob_iconv_handler - 以输出缓冲处理程序转换字符编码
    • ob_implicit_flush - 打开/关闭绝对刷送
    • ob_list_handlers - 列出所有使用中的输出处理程序。
    • ob_start - 打开输出控制缓冲
    • ob_tidyhandler - ob_start callback function to repair the buffer
    • ocibindbyname - 别名 oci_bind_by_name
    • ocicancel - 别名 oci_cancel
    • ocicloselob - 别名 OCI-Lob::close
    • ocicollappend - 别名 OCICollection::append
    • ocicollassign - 别名 OCICollection::assign
    • ocicollassignelem - 别名 OCICollection::assignElem
    • OCICollection::append - Appends element to the collection
    • OCICollection::assign - Assigns a value to the collection from another existing collection
    • OCICollection::assignElem - Assigns a value to the element of the collection
    • OCICollection::free - Frees the resources associated with the collection object
    • OCICollection::getElem - Returns value of the element
    • OCICollection::max - Returns the maximum number of elements in the collection
    • OCICollection::size - Returns size of the collection
    • OCICollection::trim - Trims elements from the end of the collection
    • ocicollgetelem - 别名 OCICollection::getElem
    • ocicollmax - 别名 OCICollection::max
    • ocicollsize - 别名 OCICollection::size
    • ocicolltrim - 别名 OCICollection::trim
    • ocicolumnisnull - 别名 oci_field_is_null
    • ocicolumnname - 别名 oci_field_name
    • ocicolumnprecision - 别名 oci_field_precision
    • ocicolumnscale - 别名 oci_field_scale
    • ocicolumnsize - 别名 oci_field_size
    • ocicolumntype - 别名 oci_field_type
    • ocicolumntyperaw - 别名 oci_field_type_raw
    • ocicommit - 别名 oci_commit
    • ocidefinebyname - 别名 oci_define_by_name
    • ocierror - 别名 oci_error
    • ociexecute - 别名 oci_execute
    • ocifetch - 别名 oci_fetch
    • ocifetchinto - Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row
    • ocifetchstatement - 别名 oci_fetch_all
    • ocifreecollection - 别名 OCICollection::free
    • ocifreecursor - 别名 oci_free_statement
    • ocifreedesc - 别名 OCI-Lob::free
    • ocifreestatement - 别名 oci_free_statement
    • ociinternaldebug - 别名 oci_internal_debug
    • ociloadlob - 别名 OCI-Lob::load
    • OCILob::append - Appends data from the large object to another large object
    • OCILob::close - Closes LOB descriptor
    • OCILob::eof - Tests for end-of-file on a large object's descriptor
    • OCILob::erase - Erases a specified portion of the internal LOB data
    • OCILob::export - Exports LOB's contents to a file
    • OCILob::flush - Flushes/writes buffer of the LOB to the server
    • OCILob::free - Frees resources associated with the LOB descriptor
    • OCILob::getBuffering - Returns current state of buffering for the large object
    • OCILob::import - Imports file data to the LOB
    • OCILob::load - Returns large object's contents
    • OCILob::read - Reads part of the large object
    • OCILob::rewind - Moves the internal pointer to the beginning of the large object
    • OCILob::save - Saves data to the large object
    • OCILob::saveFile - 别名 OCILob::import
    • OCILob::seek - Sets the internal pointer of the large object
    • OCILob::setBuffering - Changes current state of buffering for the large object
    • OCILob::size - Returns size of large object
    • OCILob::tell - Returns the current position of internal pointer of large object
    • OCILob::truncate - Truncates large object
    • OCILob::write - Writes data to the large object
    • OCILob::writeTemporary - Writes a temporary large object
    • OCILob::writeToFile - 别名 OCILob::export
    • ocilogoff - 别名 oci_close
    • ocilogon - 别名 oci_connect
    • ocinewcollection - 别名 oci_new_collection
    • ocinewcursor - 别名 oci_new_cursor
    • ocinewdescriptor - 别名 oci_new_descriptor
    • ocinlogon - 别名 oci_new_connect
    • ocinumcols - 别名 oci_num_fields
    • ociparse - 别名 oci_parse
    • ociplogon - 别名 oci_pconnect
    • ociresult - 别名 oci_result
    • ocirollback - 别名 oci_rollback
    • ocirowcount - 别名 oci_num_rows
    • ocisavelob - 别名 OCI-Lob::save
    • ocisavelobfile - 别名 OCI-Lob::import
    • ociserverversion - 别名 oci_server_version
    • ocisetprefetch - 别名 oci_set_prefetch
    • ocistatementtype - 别名 oci_statement_type
    • ociwritelobtofile - 别名 OCI-Lob::export
    • ociwritetemporarylob - 别名 OCI-Lob::writeTemporary
    • oci_bind_array_by_name - Binds a PHP array to an Oracle PL/SQL array parameter
    • oci_bind_by_name - 绑定一个 PHP 变量到一个 Oracle 位置标志符
    • oci_cancel - 中断游标读取数据
    • oci_client_version - Returns the Oracle client library version
    • oci_close - 关闭 Oracle 连接
    • oci_commit - 提交未执行的事务处理
    • oci_connect - 建立一个到 Oracle 服务器的连接
    • oci_define_by_name - 在 SELECT 中使用 PHP 变量作为定义的步骤
    • oci_error - 返回上一个错误
    • oci_execute - 执行一条语句
    • oci_fetch - Fetches the next row into result-buffer
    • oci_fetch_all - 获取结果数据的所有行到一个数组
    • oci_fetch_array - Returns the next row from a query as an associative or numeric array
    • oci_fetch_assoc - Returns the next row from a query as an associative array
    • oci_fetch_object - Returns the next row from a query as an object
    • oci_fetch_row - Returns the next row from a query as a numeric array
    • oci_field_is_null - 检查字段是否为 null
    • oci_field_name - 返回字段名
    • oci_field_precision - 返回字段精度
    • oci_field_scale - 返回字段范围
    • oci_field_size - 返回字段大小
    • oci_field_type - 返回字段的数据类型
    • oci_field_type_raw - 返回字段的原始 Oracle 数据类型
    • oci_free_descriptor - Frees a descriptor
    • oci_free_statement - 释放关联于语句或游标的所有资源
    • oci_get_implicit_resultset - Returns the next child statement resource from a parent statement resource that has Oracle Database Implicit Result Sets
    • oci_internal_debug - Enables or disables internal debug output
    • oci_lob_copy - Copies large object
    • oci_lob_is_equal - Compares two LOB/FILE locators for equality
    • oci_new_collection - 分配新的 collection 对象
    • oci_new_connect - 建定一个到 Oracle 服务器的新连接
    • oci_new_cursor - 分配并返回一个新的游标（语句句柄）
    • oci_new_descriptor - 初始化一个新的空 LOB 或 FILE 描述符
    • oci_num_fields - 返回结果列的数目
    • oci_num_rows - 返回语句执行后受影响的行数
    • oci_parse - 配置 Oracle 语句预备执行
    • oci_password_change - 修改 Oracle 用户的密码
    • oci_pconnect - 使用一个持久连接连到 Oracle 数据库
    • oci_register_taf_callback - Register a user-defined callback function for Oracle Database TAF
    • oci_result - 返回所取得行中字段的值
    • oci_rollback - 回滚未提交的事务
    • oci_server_version - 返回服务器版本信息
    • oci_set_action - Sets the action name
    • oci_set_call_timeout - Sets a millisecond timeout for database calls
    • oci_set_client_identifier - Sets the client identifier
    • oci_set_client_info - Sets the client information
    • oci_set_db_operation - Sets the database operation
    • oci_set_edition - Sets the database edition
    • oci_set_module_name - Sets the module name
    • oci_set_prefetch - 设置预提取行数
    • oci_statement_type - 返回 OCI 语句的类型
    • oci_unregister_taf_callback - Unregister a user-defined callback function for Oracle Database TAF
    • octdec - 八进制转换为十进制
    • odbc_autocommit - Toggle autocommit behaviour
    • odbc_binmode - Handling of binary column data
    • odbc_close - Close an ODBC connection
    • odbc_close_all - Close all ODBC connections
    • odbc_columnprivileges - Lists columns and associated privileges for the given table
    • odbc_columns - Lists the column names in specified tables
    • odbc_commit - Commit an ODBC transaction
    • odbc_connect - Connect to a datasource
    • odbc_cursor - Get cursorname
    • odbc_data_source - Returns information about available DSNs
    • odbc_do - 别名 odbc_exec
    • odbc_error - Get the last error code
    • odbc_errormsg - Get the last error message
    • odbc_exec - Directly execute an SQL statement
    • odbc_execute - Execute a prepared statement
    • odbc_fetch_array - Fetch a result row as an associative array
    • odbc_fetch_into - Fetch one result row into array
    • odbc_fetch_object - Fetch a result row as an object
    • odbc_fetch_row - Fetch a row
    • odbc_field_len - Get the length (precision) of a field
    • odbc_field_name - Get the columnname
    • odbc_field_num - Return column number
    • odbc_field_precision - 别名 odbc_field_len
    • odbc_field_scale - Get the scale of a field
    • odbc_field_type - Datatype of a field
    • odbc_foreignkeys - Retrieves a list of foreign keys
    • odbc_free_result - Free resources associated with a result
    • odbc_gettypeinfo - Retrieves information about data types supported by the data source
    • odbc_longreadlen - Handling of LONG columns
    • odbc_next_result - Checks if multiple results are available
    • odbc_num_fields - Number of columns in a result
    • odbc_num_rows - Number of rows in a result
    • odbc_pconnect - Open a persistent database connection
    • odbc_prepare - Prepares a statement for execution
    • odbc_primarykeys - Gets the primary keys for a table
    • odbc_procedurecolumns - Retrieve information about parameters to procedures
    • odbc_procedures - Get the list of procedures stored in a specific data source
    • odbc_result - Get result data
    • odbc_result_all - Print result as HTML table
    • odbc_rollback - Rollback a transaction
    • odbc_setoption - Adjust ODBC settings
    • odbc_specialcolumns - Retrieves special columns
    • odbc_statistics - Retrieve statistics about a table
    • odbc_tableprivileges - Lists tables and the privileges associated with each table
    • odbc_tables - Get the list of table names stored in a specific data source
    • ogg:// - 音频流
    • opcache_compile_file - 无需运行，即可编译并缓存 PHP 脚本
    • opcache_get_configuration - 获取缓存的配置信息
    • opcache_get_status - 获取缓存的状态信息
    • opcache_invalidate - 废除脚本缓存
    • opcache_is_script_cached - Tells whether a script is cached in OPCache
    • opcache_reset - 重置字节码缓存的内容
    • openal_buffer_create - Generate OpenAL buffer
    • openal_buffer_data - Load a buffer with data
    • openal_buffer_destroy - Destroys an OpenAL buffer
    • openal_buffer_get - Retrieve an OpenAL buffer property
    • openal_buffer_loadwav - Load a .wav file into a buffer
    • openal_context_create - Create an audio processing context
    • openal_context_current - Make the specified context current
    • openal_context_destroy - Destroys a context
    • openal_context_process - Process the specified context
    • openal_context_suspend - Suspend the specified context
    • openal_device_close - Close an OpenAL device
    • openal_device_open - Initialize the OpenAL audio layer
    • openal_listener_get - Retrieve a listener property
    • openal_listener_set - Set a listener property
    • openal_source_create - Generate a source resource
    • openal_source_destroy - Destroy a source resource
    • openal_source_get - Retrieve an OpenAL source property
    • openal_source_pause - Pause the source
    • openal_source_play - Start playing the source
    • openal_source_rewind - Rewind the source
    • openal_source_set - Set source property
    • openal_source_stop - Stop playing the source
    • openal_stream - Begin streaming on a source
    • opendir - 打开目录句柄
    • openlog - Open connection to system logger
    • openssl_cipher_iv_length - 获取密码iv长度
    • openssl_cms_decrypt - Decrypt a CMS message
    • openssl_cms_encrypt - Encrypt a CMS message
    • openssl_cms_read - Export the CMS file to an array of PEM certificates
    • openssl_cms_sign - Sign a file
    • openssl_cms_verify - Verify a CMS signature
    • openssl_csr_export - 将CSR作为字符串导出
    • openssl_csr_export_to_file - 将CSR导出到文件
    • openssl_csr_get_public_key - 返回CSR的公钥
    • openssl_csr_get_subject - 返回CSR的主题
    • openssl_csr_new - 生成一个 CSR
    • openssl_csr_sign - 用另一个证书签署 CSR (或者本身) 并且生成一个证书
    • openssl_decrypt - 解密数据
    • openssl_dh_compute_key - 计算远程DH密钥(公钥)和本地DH密钥的共享密钥
    • openssl_digest - 计算摘要
    • openssl_encrypt - 加密数据
    • openssl_error_string - 返回 openSSL 错误消息
    • openssl_free_key - 释放密钥资源
    • openssl_get_cert_locations - 检索可用的证书位置
    • openssl_get_cipher_methods - 获取可用的加密算法
    • openssl_get_curve_names - 获得ECC的可用曲线名称列表
    • openssl_get_md_methods - 获取可用的摘要算法
    • openssl_get_privatekey - 别名 openssl_pkey_get_private
    • openssl_get_publickey - 别名 openssl_pkey_get_public
    • openssl_open - 打开密封的数据
    • openssl_pbkdf2 - 生成一个 PKCS5 v2 PBKDF2 字符串
    • openssl_pkcs7_decrypt - 解密一个 S/MIME 加密的消息
    • openssl_pkcs7_encrypt - 加密一个 S/MIME 消息
    • openssl_pkcs7_read - 将PKCS7文件导出为PEM格式证书的数组
    • openssl_pkcs7_sign - 对一个 S/MIME 消息进行签名
    • openssl_pkcs7_verify - 校验一个已签名的 S/MIME 消息的签名
    • openssl_pkcs12_export - 将 PKCS#12 兼容证书存储文件导出到变量
    • openssl_pkcs12_export_to_file - 输出一个 PKCS#12 兼容的证书存储文件
    • openssl_pkcs12_read - 将 PKCS#12 证书存储区解析到数组中
    • openssl_pkey_derive - Computes shared secret for public value of remote and local DH or ECDH key
    • openssl_pkey_export - 将一个密钥的可输出表示转换为字符串
    • openssl_pkey_export_to_file - 将密钥导出到文件中
    • openssl_pkey_free - 释放一个私钥
    • openssl_pkey_get_details - 返回包含密钥详情的数组
    • openssl_pkey_get_private - 获取私钥
    • openssl_pkey_get_public - 从证书中解析公钥，以供使用。
    • openssl_pkey_new - 生成一个新的私钥
    • openssl_private_decrypt - 使用私钥解密数据
    • openssl_private_encrypt - 使用私钥加密数据
    • openssl_public_decrypt - 使用公钥解密数据
    • openssl_public_encrypt - 使用公钥加密数据
    • openssl_random_pseudo_bytes - 生成一个伪随机字节串
    • openssl_seal - 密封 (加密) 数据
    • openssl_sign - Generate signature
    • openssl_spki_export - 通过签名公钥和挑战导出一个可用的PEM格式的公钥
    • openssl_spki_export_challenge - 导出与签名公钥和挑战相关的挑战字符串
    • openssl_spki_new - 生成一个新的签名公钥和挑战
    • openssl_spki_verify - 验证签名公钥和挑战。
    • openssl_verify - 验证签名
    • openssl_x509_checkpurpose - 验证是否可以为特定目的使用证书
    • openssl_x509_check_private_key - 检查私钥是否对应于证书
    • openssl_x509_export - 以字符串格式导出证书
    • openssl_x509_export_to_file - 导出证书至文件
    • openssl_x509_fingerprint - 计算一个给定的x.509证书的指纹或摘要
    • openssl_x509_free - 释放证书资源
    • openssl_x509_parse - 解析一个X509证书并作为一个数组返回信息
    • openssl_x509_read - 解析一个x.509证书并返回一个资源标识符
    • openssl_x509_verify - Verifies digital signature of x509 certificate against a public key
    • ord - 转换字符串第一个字节为 0-255 之间的值
    • OuterIterator::getInnerIterator - Returns the inner iterator for the current entry
    • output_add_rewrite_var - 添加URL重写器的值（Add URL rewriter values）
    • output_reset_rewrite_vars - 重设URL重写器的值（Reset URL rewriter values）
  • p
    • pack - 将数据打包成二进制字符串
    • parallel\bootstrap - Bootstrapping
    • parallel\Channel::close - Closing
    • parallel\Channel::make - Access
    • parallel\Channel::open - Access
    • parallel\Channel::recv - Sharing
    • parallel\Channel::send - Sharing
    • parallel\Channel::__construct - Channel Construction
    • parallel\Events::addChannel - Targets
    • parallel\Events::addFuture - Targets
    • parallel\Events::poll - Polling
    • parallel\Events::remove - Targets
    • parallel\Events::setBlocking - Behaviour
    • parallel\Events::setInput - Input
    • parallel\Events::setTimeout - Behaviour
    • parallel\Events\Input::add - Inputs
    • parallel\Events\Input::clear - Inputs
    • parallel\Events\Input::remove - Inputs
    • parallel\Future::cancel - Cancellation
    • parallel\Future::cancelled - State Detection
    • parallel\Future::done - State Detection
    • parallel\Future::value - Resolution
    • parallel\run - Execution
    • parallel\Runtime::close - Runtime Graceful Join
    • parallel\Runtime::kill - Runtime Join
    • parallel\Runtime::run - Execution
    • parallel\Runtime::__construct - Runtime Construction
    • parallel\Sync::get - Access
    • parallel\Sync::notify - Synchronization
    • parallel\Sync::set - Access
    • parallel\Sync::wait - Synchronization
    • parallel\Sync::__construct - Construction
    • parallel\Sync::__invoke - Synchronization
    • ParentIterator::accept - Determines acceptability
    • ParentIterator::getChildren - Return the inner iterator's children contained in a ParentIterator
    • ParentIterator::hasChildren - Check whether the inner iterator's current element has children
    • ParentIterator::next - Move the iterator forward
    • ParentIterator::rewind - Rewind the iterator
    • ParentIterator::__construct - Constructs a ParentIterator
    • Parle\Lexer::advance - Process next lexer rule
    • Parle\Lexer::build - Finalize the lexer rule set
    • Parle\Lexer::callout - Define token callback
    • Parle\Lexer::consume - Pass the data for processing
    • Parle\Lexer::dump - Dump the state machine
    • Parle\Lexer::getToken - Retrieve the current token
    • Parle\Lexer::insertMacro - Insert regex macro
    • Parle\Lexer::push - Add a lexer rule
    • Parle\Lexer::reset - Reset lexer
    • Parle\Parser::advance - Process next parser rule
    • Parle\Parser::build - Finalize the grammar rules
    • Parle\Parser::consume - Consume the data for processing
    • Parle\Parser::dump - Dump the grammar
    • Parle\Parser::errorInfo - Retrieve the error information
    • Parle\Parser::left - Declare a token with left-associativity
    • Parle\Parser::nonassoc - Declare a token with no associativity
    • Parle\Parser::precedence - Declare a precedence rule
    • Parle\Parser::push - Add a grammar rule
    • Parle\Parser::reset - Reset parser state
    • Parle\Parser::right - Declare a token with right-associativity
    • Parle\Parser::sigil - Retrieve a matching part of a rule
    • Parle\Parser::token - Declare a token
    • Parle\Parser::tokenId - Get token id
    • Parle\Parser::trace - Trace the parser operation
    • Parle\Parser::validate - Validate input
    • Parle\RLexer::advance - Process next lexer rule
    • Parle\RLexer::build - Finalize the lexer rule set
    • Parle\RLexer::callout - Define token callback
    • Parle\RLexer::consume - Pass the data for processing
    • Parle\RLexer::dump - Dump the state machine
    • Parle\RLexer::getToken - Retrieve the current token
    • Parle\RLexer::insertMacro - Insert regex macro
    • Parle\RLexer::push - Add a lexer rule
    • Parle\RLexer::pushState - Push a new start state
    • Parle\RLexer::reset - Reset lexer
    • Parle\RParser::advance - Process next parser rule
    • Parle\RParser::build - Finalize the grammar rules
    • Parle\RParser::consume - Consume the data for processing
    • Parle\RParser::dump - Dump the grammar
    • Parle\RParser::errorInfo - Retrieve the error information
    • Parle\RParser::left - Declare a token with left-associativity
    • Parle\RParser::nonassoc - Declare a token with no associativity
    • Parle\RParser::precedence - Declare a precedence rule
    • Parle\RParser::push - Add a grammar rule
    • Parle\RParser::reset - Reset parser state
    • Parle\RParser::right - Declare a token with right-associativity
    • Parle\RParser::sigil - Retrieve a matching part of a rule
    • Parle\RParser::token - Declare a token
    • Parle\RParser::tokenId - Get token id
    • Parle\RParser::trace - Trace the parser operation
    • Parle\RParser::validate - Validate input
    • Parle\Stack::pop - Pop an item from the stack
    • Parle\Stack::push - Push an item into the stack
    • parse_ini_file - 解析一个配置文件
    • parse_ini_string - 解析配置字符串
    • parse_str - 将字符串解析成多个变量
    • parse_url - 解析 URL，返回其组成部分
    • passthru - 执行外部程序并且显示原始输出
    • password_algos - Get available password hashing algorithm IDs
    • password_get_info - 返回指定散列（hash）的相关信息
    • password_hash - 创建密码的散列（hash）
    • password_needs_rehash - 检测散列值是否匹配指定的选项
    • password_verify - 验证密码是否和散列值匹配
    • pathinfo - 返回文件路径的信息
    • pclose - 关闭进程文件指针
    • pcntl_alarm - 为进程设置一个alarm闹钟信号
    • pcntl_async_signals - Enable/disable asynchronous signal handling or return the old setting
    • pcntl_errno - 别名 pcntl_get_last_error
    • pcntl_exec - 在当前进程空间执行指定程序
    • pcntl_fork - 在当前进程当前位置产生分支（子进程）。译注：fork是创建了一个子进程，父进程和子进程 都从fork的位置开始向下继续执行，不同的是父进程执行过程中，得到的fork返回值为子进程 号，而子进程得到的是0。
    • pcntl_getpriority - 获取任意进程的优先级
    • pcntl_get_last_error - Retrieve the error number set by the last pcntl function which failed
    • pcntl_setpriority - 修改任意进程的优先级
    • pcntl_signal - 安装一个信号处理器
    • pcntl_signal_dispatch - 调用等待信号的处理器
    • pcntl_signal_get_handler - Get the current handler for specified signal
    • pcntl_sigprocmask - 设置或检索阻塞信号
    • pcntl_sigtimedwait - 带超时机制的信号等待
    • pcntl_sigwaitinfo - 等待信号
    • pcntl_strerror - Retrieve the system error message associated with the given errno
    • pcntl_wait - 等待或返回 fork 的子进程状态
    • pcntl_waitpid - 等待或返回fork的子进程状态
    • pcntl_wexitstatus - 返回一个中断的子进程的返回代码
    • pcntl_wifexited - 检查状态代码是否代表一个正常的退出。
    • pcntl_wifsignaled - 检查子进程状态码是否代表由于某个信号而中断
    • pcntl_wifstopped - 检查子进程当前是否已经停止
    • pcntl_wstopsig - 返回导致子进程停止的信号
    • pcntl_wtermsig - 返回导致子进程中断的信号
    • PDO::beginTransaction - 启动一个事务
    • PDO::commit - 提交一个事务
    • PDO::cubrid_schema - Get the requested schema information
    • PDO::errorCode - 获取跟数据库句柄上一次操作相关的 SQLSTATE
    • PDO::errorInfo - Fetch extended error information associated with the last operation on the database handle
    • PDO::exec - 执行一条 SQL 语句，并返回受影响的行数
    • PDO::getAttribute - 取回一个数据库连接的属性
    • PDO::getAvailableDrivers - 返回一个可用驱动的数组
    • PDO::inTransaction - 检查是否在一个事务内
    • PDO::lastInsertId - 返回最后插入行的ID或序列值
    • PDO::pgsqlCopyFromArray - Copy data from PHP array into table
    • PDO::pgsqlCopyFromFile - Copy data from file into table
    • PDO::pgsqlCopyToArray - Copy data from database table into PHP array
    • PDO::pgsqlCopyToFile - Copy data from table into file
    • PDO::pgsqlGetNotify - Get asynchronous notification
    • PDO::pgsqlGetPid - Get the server PID
    • PDO::pgsqlLOBCreate - Creates a new large object
    • PDO::pgsqlLOBOpen - Opens an existing large object stream
    • PDO::pgsqlLOBUnlink - Deletes the large object
    • PDO::prepare - 准备要执行的语句，并返回语句对象
    • PDO::query - 执行 SQL 语句，以 PDOStatement 对象形式返回结果集
    • PDO::quote - 为 SQL 查询里的字符串添加引号
    • PDO::rollBack - 回滚一个事务
    • PDO::setAttribute - 设置属性
    • PDO::sqliteCreateAggregate - Registers an aggregating User Defined Function for use in SQL statements
    • PDO::sqliteCreateCollation - Registers a User Defined Function for use as a collating function in SQL statements
    • PDO::sqliteCreateFunction - Registers a User Defined Function for use in SQL statements
    • PDO::__construct - 创建一个表示数据库连接的 PDO 实例
    • PDOStatement::bindColumn - 绑定一列到一个 PHP 变量
    • PDOStatement::bindParam - 绑定一个参数到指定的变量名
    • PDOStatement::bindValue - 把一个值绑定到一个参数
    • PDOStatement::closeCursor - 关闭游标，使语句能再次被执行。
    • PDOStatement::columnCount - 返回结果集中的列数
    • PDOStatement::debugDumpParams - 打印一条 SQL 预处理命令
    • PDOStatement::errorCode - 获取跟上一次语句句柄操作相关的 SQLSTATE
    • PDOStatement::errorInfo - 获取跟上一次语句句柄操作相关的扩展错误信息
    • PDOStatement::execute - 执行一条预处理语句
    • PDOStatement::fetch - 从结果集中获取下一行
    • PDOStatement::fetchAll - 返回一个包含结果集中所有行的数组
    • PDOStatement::fetchColumn - 从结果集中的下一行返回单独的一列。
    • PDOStatement::fetchObject - 获取下一行并作为一个对象返回。
    • PDOStatement::getAttribute - 检索一个语句属性
    • PDOStatement::getColumnMeta - 返回结果集中一列的元数据
    • PDOStatement::nextRowset - 在一个多行集语句句柄中推进到下一个行集
    • PDOStatement::rowCount - 返回受上一个 SQL 语句影响的行数
    • PDOStatement::setAttribute - 设置一个语句属性
    • PDOStatement::setFetchMode - 为语句设置默认的获取模式。
    • PDO_CUBRID DSN - Connecting to CUBRID databases
    • PDO_DBLIB DSN - Connecting to Microsoft SQL Server and Sybase databases
    • PDO_FIREBIRD DSN - Connecting to Firebird databases
    • PDO_IBM DSN - Connecting to IBM databases
    • PDO_INFORMIX DSN - Connecting to Informix databases
    • PDO_MYSQL DSN - Connecting to MySQL databases
    • PDO_OCI DSN - Connecting to Oracle databases
    • PDO_ODBC DSN - Connecting to ODBC or DB2 databases
    • PDO_PGSQL DSN - Connecting to PostgreSQL databases
    • PDO_SQLITE DSN - Connecting to SQLite databases
    • PDO_SQLSRV DSN - Connecting to MS SQL Server and SQL Azure databases
    • pfsockopen - 打开一个持久的网络连接或者Unix套接字连接。
    • pg_affected_rows - 返回受影响的记录数目
    • pg_cancel_query - 取消异步查询
    • pg_client_encoding - 取得客户端编码方式
    • pg_close - 关闭一个 PostgreSQL 连接
    • pg_connect - 打开一个 PostgreSQL 连接
    • pg_connection_busy - 获知连接是否为忙
    • pg_connection_reset - 重置连接（再次连接）
    • pg_connection_status - 获得连接状态
    • pg_connect_poll - 正在进行尝试轮询 PostgreSQL 链接状态。
    • pg_consume_input - Reads input on the connection
    • pg_convert - 将关联的数组值转换为适合 SQL 语句的格式。
    • pg_copy_from - 根据数组将记录插入表中
    • pg_copy_to - 将一个表拷贝到数组中
    • pg_dbname - 获得数据库名
    • pg_delete - 删除记录
    • pg_end_copy - 与 PostgreSQL 后端同步
    • pg_escape_bytea - 转义 bytea 类型的二进制数据
    • pg_escape_identifier - Escape a identifier for insertion into a text field
    • pg_escape_literal - Escape a literal for insertion into a text field
    • pg_escape_string - 转义 text/char 类型的字符串
    • pg_execute - Sends a request to execute a prepared statement with given parameters, and waits for the result
    • pg_fetch_all - 从结果中提取所有行作为一个数组
    • pg_fetch_all_columns - Fetches all rows in a particular result column as an array
    • pg_fetch_array - 提取一行作为数组
    • pg_fetch_assoc - 提取一行作为关联数组
    • pg_fetch_object - 提取一行作为对象
    • pg_fetch_result - 从结果资源中返回值
    • pg_fetch_row - 提取一行作为枚举数组
    • pg_field_is_null - 测试字段是否为 null
    • pg_field_name - 返回字段的名字
    • pg_field_num - 返回字段的编号
    • pg_field_prtlen - 返回打印出来的长度
    • pg_field_size - 返回指定字段占用内部存储空间的大小
    • pg_field_table - Returns the name or oid of the tables field
    • pg_field_type - 返回相应字段的类型名称
    • pg_field_type_oid - Returns the type ID (OID) for the corresponding field number
    • pg_flush - 刷新链接中已处理的数据查询
    • pg_free_result - 释放查询结果占用的内存
    • pg_get_notify - Ping 数据库连接
    • pg_get_pid - Ping 数据库连接
    • pg_get_result - 取得异步查询结果
    • pg_host - 返回和某连接关联的主机名
    • pg_insert - 将数组插入到表中
    • pg_last_error - 得到某连接的最后一条错误信息
    • pg_last_notice - 返回 PostgreSQL 服务器最新一条公告信息
    • pg_last_oid - 返回上一个对象的 oid
    • pg_lo_close - 关闭一个大型对象
    • pg_lo_create - 新建一个大型对象
    • pg_lo_export - 将大型对象导出到文件
    • pg_lo_import - 将文件导入为大型对象
    • pg_lo_open - 打开一个大型对象
    • pg_lo_read - 从大型对象中读入数据
    • pg_lo_read_all - 读入整个大型对象并直接发送给浏览器
    • pg_lo_seek - 移动大型对象中的指针
    • pg_lo_tell - 返回大型对象的当前指针位置
    • pg_lo_truncate - Truncates a large object
    • pg_lo_unlink - 删除一个大型对象
    • pg_lo_write - 向大型对象写入数据
    • pg_meta_data - 获得表的元数据
    • pg_num_fields - 返回字段的数目
    • pg_num_rows - 返回行的数目
    • pg_options - 获得和连接有关的选项
    • pg_parameter_status - Looks up a current parameter setting of the server
    • pg_pconnect - 打开一个持久的 PostgreSQL 连接
    • pg_ping - Ping 数据库连接
    • pg_port - 返回该连接的端口号
    • pg_prepare - Submits a request to create a prepared statement with the given parameters, and waits for completion
    • pg_put_line - 向 PostgreSQL 后端发送以 NULL 结尾的字符串
    • pg_query - 执行查询
    • pg_query_params - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text
    • pg_result_error - 获得查询结果的错误信息
    • pg_result_error_field - Returns an individual field of an error report
    • pg_result_seek - 在结果资源中设定内部行偏移量
    • pg_result_status - 获得查询结果的状态
    • pg_select - 选择记录
    • pg_send_execute - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s)
    • pg_send_prepare - Sends a request to create a prepared statement with the given parameters, without waiting for completion
    • pg_send_query - 发送异步查询
    • pg_send_query_params - Submits a command and separate parameters to the server without waiting for the result(s)
    • pg_set_client_encoding - 设定客户端编码
    • pg_set_error_verbosity - Determines the verbosity of messages returned by pg_last_error and pg_result_error
    • pg_socket - Get a read only handle to the socket underlying a PostgreSQL connection
    • pg_trace - 启动一个 PostgreSQL 连接的追踪功能
    • pg_transaction_status - Returns the current in-transaction status of the server
    • pg_tty - 返回该连接的 tty 号
    • pg_unescape_bytea - 取消 bytea 类型中的字符串转义
    • pg_untrace - 关闭 PostgreSQL 连接的追踪功能
    • pg_update - 更新表
    • pg_version - Returns an array with client, protocol and server version (when available)
    • phar:// - PHP 归档
    • Phar::addEmptyDir - 添加一个空目录到 phar 档案
    • Phar::addFile - 将一个文件从文件系统添加到 phar 档案中
    • Phar::addFromString - 以字符串的形式添加一个文件到 phar 档案
    • Phar::apiVersion - Returns the api version
    • Phar::buildFromDirectory - Construct a phar archive from the files within a directory
    • Phar::buildFromIterator - Construct a phar archive from an iterator
    • Phar::canCompress - Returns whether phar extension supports compression using either zlib or bzip2
    • Phar::canWrite - Returns whether phar extension supports writing and creating phars
    • Phar::compress - Compresses the entire Phar archive using Gzip or Bzip2 compression
    • Phar::compressFiles - Compresses all files in the current Phar archive
    • Phar::convertToData - Convert a phar archive to a non-executable tar or zip file
    • Phar::convertToExecutable - Convert a phar archive to another executable phar archive file format
    • Phar::copy - Copy a file internal to the phar archive to another new file within the phar
    • Phar::count - Returns the number of entries (files) in the Phar archive
    • Phar::createDefaultStub - Create a phar-file format specific stub
    • Phar::decompress - Decompresses the entire Phar archive
    • Phar::decompressFiles - Decompresses all files in the current Phar archive
    • Phar::delete - 删除 phar 档案中的一个文件
    • Phar::delMetadata - Deletes the global metadata of the phar
    • Phar::extractTo - Extract the contents of a phar archive to a directory
    • Phar::getAlias - Get the alias for Phar
    • Phar::getMetadata - Returns phar archive meta-data
    • Phar::getModified - Return whether phar was modified
    • Phar::getPath - Get the real path to the Phar archive on disk
    • Phar::getSignature - Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive
    • Phar::getStub - Return the PHP loader or bootstrap stub of a Phar archive
    • Phar::getSupportedCompression - Return array of supported compression algorithms
    • Phar::getSupportedSignatures - Return array of supported signature types
    • Phar::getVersion - Return version info of Phar archive
    • Phar::hasMetadata - Returns whether phar has global meta-data
    • Phar::interceptFileFuncs - Instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions
    • Phar::isBuffering - Used to determine whether Phar write operations are being buffered, or are flushing directly to disk
    • Phar::isCompressed - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
    • Phar::isFileFormat - Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter
    • Phar::isValidPharFilename - Returns whether the given filename is a valid phar filename
    • Phar::isWritable - Returns true if the phar archive can be modified
    • Phar::loadPhar - Loads any phar archive with an alias
    • Phar::mapPhar - Reads the currently executed file (a phar) and registers its manifest
    • Phar::mount - Mount an external path or file to a virtual location within the phar archive
    • Phar::mungServer - Defines a list of up to 4 $_SERVER variables that should be modified for execution
    • Phar::offsetExists - Determines whether a file exists in the phar
    • Phar::offsetGet - Gets a PharFileInfo object for a specific file
    • Phar::offsetSet - Set the contents of an internal file to those of an external file
    • Phar::offsetUnset - Remove a file from a phar
    • Phar::running - Returns the full path on disk or full phar URL to the currently executing Phar archive
    • Phar::setAlias - Set the alias for the Phar archive
    • Phar::setDefaultStub - Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader
    • Phar::setMetadata - Sets phar archive meta-data
    • Phar::setSignatureAlgorithm - Set the signature algorithm for a phar and apply it
    • Phar::setStub - Used to set the PHP loader or bootstrap stub of a Phar archive
    • Phar::startBuffering - Start buffering Phar write operations, do not modify the Phar object on disk
    • Phar::stopBuffering - Stop buffering write requests to the Phar archive, and save changes to disk
    • Phar::unlinkArchive - Completely remove a phar archive from disk and from memory
    • Phar::webPhar - mapPhar for web-based phars. front controller for web applications
    • Phar::__construct - Construct a Phar archive object
    • PharData::addEmptyDir - Add an empty directory to the tar/zip archive
    • PharData::addFile - Add a file from the filesystem to the tar/zip archive
    • PharData::addFromString - Add a file from the filesystem to the tar/zip archive
    • PharData::buildFromDirectory - Construct a tar/zip archive from the files within a directory
    • PharData::buildFromIterator - Construct a tar or zip archive from an iterator
    • PharData::compress - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
    • PharData::compressFiles - Compresses all files in the current tar/zip archive
    • PharData::convertToData - Convert a phar archive to a non-executable tar or zip file
    • PharData::convertToExecutable - Convert a non-executable tar/zip archive to an executable phar archive
    • PharData::copy - Copy a file internal to the phar archive to another new file within the phar
    • PharData::decompress - Decompresses the entire Phar archive
    • PharData::decompressFiles - Decompresses all files in the current zip archive
    • PharData::delete - Delete a file within a tar/zip archive
    • PharData::delMetadata - Deletes the global metadata of a zip archive
    • PharData::extractTo - Extract the contents of a tar/zip archive to a directory
    • PharData::isWritable - Returns true if the tar/zip archive can be modified
    • PharData::offsetSet - Set the contents of a file within the tar/zip to those of an external file or string
    • PharData::offsetUnset - Remove a file from a tar/zip archive
    • PharData::setAlias - Dummy function (Phar::setAlias is not valid for PharData)
    • PharData::setDefaultStub - Dummy function (Phar::setDefaultStub is not valid for PharData)
    • PharData::setMetadata - Sets phar archive meta-data
    • PharData::setSignatureAlgorithm - Set the signature algorithm for a phar and apply it
    • PharData::setStub - Dummy function (Phar::setStub is not valid for PharData)
    • PharData::__construct - Construct a non-executable tar or zip archive object
    • PharFileInfo::chmod - Sets file-specific permission bits
    • PharFileInfo::compress - Compresses the current Phar entry with either zlib or bzip2 compression
    • PharFileInfo::decompress - Decompresses the current Phar entry within the phar
    • PharFileInfo::delMetadata - Deletes the metadata of the entry
    • PharFileInfo::getCompressedSize - Returns the actual size of the file (with compression) inside the Phar archive
    • PharFileInfo::getContent - Get the complete file contents of the entry
    • PharFileInfo::getCRC32 - Returns CRC32 code or throws an exception if CRC has not been verified
    • PharFileInfo::getMetadata - Returns file-specific meta-data saved with a file
    • PharFileInfo::getPharFlags - Returns the Phar file entry flags
    • PharFileInfo::hasMetadata - Returns the metadata of the entry
    • PharFileInfo::isCompressed - Returns whether the entry is compressed
    • PharFileInfo::isCRCChecked - Returns whether file entry has had its CRC verified
    • PharFileInfo::setMetadata - Sets file-specific meta-data saved with a file
    • PharFileInfo::__construct - Construct a Phar entry object
    • Phar 上下文（context）选项 - Phar 上下文（context）选项列表
    • php:// - 访问各个输入/输出流（I/O streams）
    • phpcredits - 打印 PHP 贡献者名单
    • phpdbg_break_file - Inserts a breakpoint at a line in a file
    • phpdbg_break_function - Inserts a breakpoint at entry to a function
    • phpdbg_break_method - Inserts a breakpoint at entry to a method
    • phpdbg_break_next - Inserts a breakpoint at the next opcode
    • phpdbg_clear - Clears all breakpoints
    • phpdbg_color - Sets the color of certain elements
    • phpdbg_end_oplog - 说明
    • phpdbg_exec - Attempts to set the execution context
    • phpdbg_get_executable - 说明
    • phpdbg_prompt - Sets the command prompt
    • phpdbg_start_oplog - 说明
    • phpinfo - 输出关于 PHP 配置的信息
    • PhpToken::getTokenName - Returns the name of the token.
    • PhpToken::is - Tells whether the token is of given kind.
    • PhpToken::isIgnorable - Tells whether the token would be ignored by the PHP parser.
    • PhpToken::tokenize - Splits given source into PHP tokens, represented by PhpToken objects.
    • PhpToken::__construct - Returns a new PhpToken object
    • PhpToken::__toString - Returns the textual content of the token.
    • phpversion - 获取当前的PHP版本
    • php_ini_loaded_file - 取得已加载的 php.ini 文件的路径
    • php_ini_scanned_files - 返回从额外 ini 目录里解析的 .ini 文件列表
    • php_sapi_name - 返回 web 服务器和 PHP 之间的接口类型
    • php_strip_whitespace - 返回删除注释和空格后的PHP源码
    • php_uname - 返回运行 PHP 的系统的有关信息
    • php_user_filter::filter - Called when applying the filter
    • php_user_filter::onClose - Called when closing the filter
    • php_user_filter::onCreate - Called when creating the filter
    • pht\AtomicInteger::dec - Decrements the atomic integer's value by one
    • pht\AtomicInteger::get - Gets the atomic integer's value
    • pht\AtomicInteger::inc - Increments the atomic integer's value by one
    • pht\AtomicInteger::lock - Acquires the atomic integer's mutex lock
    • pht\AtomicInteger::set - Sets the atomic integer's value
    • pht\AtomicInteger::unlock - Releases the atomic integer's mutex lock
    • pht\AtomicInteger::__construct - AtomicInteger creation
    • pht\HashTable::lock - Acquires the hash table's mutex lock
    • pht\HashTable::size - Gets the size of the hash table
    • pht\HashTable::unlock - Releases the hash table's mutex lock
    • pht\Queue::front - Returns the first value from a queue
    • pht\Queue::lock - Acquires the queue's mutex lock
    • pht\Queue::pop - Pops a value off of the front of a queue
    • pht\Queue::push - Pushes a value to the end of a queue
    • pht\Queue::size - Gets the size of the queue
    • pht\Queue::unlock - Releases the queue's mutex lock
    • pht\Runnable::run - The entry point of a threaded class
    • pht\Thread::addClassTask - Class threading
    • pht\Thread::addFileTask - File threading
    • pht\Thread::addFunctionTask - Function threading
    • pht\Thread::join - Joins a thread
    • pht\Thread::start - Starts the new thread
    • pht\Thread::taskCount - Gets a thread's task count
    • pht\Threaded::lock - Acquires the mutex lock
    • pht\Threaded::unlock - Releases the mutex lock
    • pht\Vector::deleteAt - Deletes a value in the vector
    • pht\Vector::insertAt - Inserts a value into the vector
    • pht\Vector::lock - Acquires the vector's mutex lock
    • pht\Vector::pop - Pops a value to the vector
    • pht\Vector::push - Pushes a value to the vector
    • pht\Vector::resize - Resizes a vector
    • pht\Vector::shift - Shifts a value from the vector
    • pht\Vector::size - Gets the size of the vector
    • pht\Vector::unlock - Releases the vector's mutex lock
    • pht\Vector::unshift - Unshifts a value to the vector front
    • pht\Vector::updateAt - Updates a value in the vector
    • pht\Vector::__construct - Vector creation
    • pi - 得到圆周率值
    • png2wbmp - 将 PNG 图像文件转换为 WBMP 图像文件
    • Pool::collect - 回收已完成任务的引用
    • Pool::resize - 改变 Pool 对象的可容纳 Worker 对象的数量
    • Pool::shutdown - 停止所有的 Worker 对象
    • Pool::submit - 提交对象以执行
    • Pool::submitTo - 提交一个任务到特定的 Worker 以执行
    • Pool::__construct - 创建新的 Worker 对象池
    • popen - 打开进程文件指针
    • pos - current 的别名
    • posix_access - Determine accessibility of a file
    • posix_ctermid - Get path name of controlling terminal
    • posix_errno - 别名 posix_get_last_error
    • posix_getcwd - Pathname of current directory
    • posix_getegid - Return the effective group ID of the current process
    • posix_geteuid - Return the effective user ID of the current process
    • posix_getgid - Return the real group ID of the current process
    • posix_getgrgid - Return info about a group by group id
    • posix_getgrnam - Return info about a group by name
    • posix_getgroups - Return the group set of the current process
    • posix_getlogin - Return login name
    • posix_getpgid - Get process group id for job control
    • posix_getpgrp - Return the current process group identifier
    • posix_getpid - 返回当前进程 id
    • posix_getppid - Return the parent process identifier
    • posix_getpwnam - Return info about a user by username
    • posix_getpwuid - Return info about a user by user id
    • posix_getrlimit - Return info about system resource limits
    • posix_getsid - Get the current sid of the process
    • posix_getuid - Return the real user ID of the current process
    • posix_get_last_error - Retrieve the error number set by the last posix function that failed
    • posix_initgroups - Calculate the group access list
    • posix_isatty - Determine if a file descriptor is an interactive terminal
    • posix_kill - Send a signal to a process
    • posix_mkfifo - Create a fifo special file (a named pipe)
    • posix_mknod - Create a special or ordinary file (POSIX.1)
    • posix_setegid - Set the effective GID of the current process
    • posix_seteuid - Set the effective UID of the current process
    • posix_setgid - Set the GID of the current process
    • posix_setpgid - Set process group id for job control
    • posix_setrlimit - Set system resource limits
    • posix_setsid - Make the current process a session leader
    • posix_setuid - Set the UID of the current process
    • posix_strerror - Retrieve the system error message associated with the given errno
    • posix_times - Get process times
    • posix_ttyname - Determine terminal device name
    • posix_uname - Get system name
    • pow - 指数表达式
    • preg_filter - 执行一个正则表达式搜索和替换
    • preg_grep - 返回匹配模式的数组条目
    • preg_last_error - 返回最后一个PCRE正则执行产生的错误代码
    • preg_last_error_msg - Returns the error message of the last PCRE regex execution
    • preg_match - 执行匹配正则表达式
    • preg_match_all - 执行一个全局正则表达式匹配
    • preg_quote - 转义正则表达式字符
    • preg_replace - 执行一个正则表达式的搜索和替换
    • preg_replace_callback - 执行一个正则表达式搜索并且使用一个回调进行替换
    • preg_replace_callback_array - Perform a regular expression search and replace using callbacks
    • preg_split - 通过一个正则表达式分隔字符串
    • prev - 将数组的内部指针倒回一位
    • print - 输出字符串
    • printf - 输出格式化字符串
    • print_r - 以易于理解的格式打印变量。
    • proc_close - 关闭由 proc_open 打开的进程并且返回进程退出码
    • proc_get_status - 获取由 proc_open 函数打开的进程的信息
    • proc_nice - 修改当前进程的优先级
    • proc_open - 执行一个命令，并且打开用来输入/输出的文件指针。
    • proc_terminate - 杀除由 proc_open 打开的进程
    • property_exists - 检查对象或类是否具有该属性
    • pspell_add_to_personal - Add the word to a personal wordlist
    • pspell_add_to_session - Add the word to the wordlist in the current session
    • pspell_check - Check a word
    • pspell_clear_session - Clear the current session
    • pspell_config_create - Create a config used to open a dictionary
    • pspell_config_data_dir - Location of language data files
    • pspell_config_dict_dir - Location of the main word list
    • pspell_config_ignore - Ignore words less than N characters long
    • pspell_config_mode - Change the mode number of suggestions returned
    • pspell_config_personal - Set a file that contains personal wordlist
    • pspell_config_repl - Set a file that contains replacement pairs
    • pspell_config_runtogether - Consider run-together words as valid compounds
    • pspell_config_save_repl - Determine whether to save a replacement pairs list along with the wordlist
    • pspell_new - Load a new dictionary
    • pspell_new_config - Load a new dictionary with settings based on a given config
    • pspell_new_personal - Load a new dictionary with personal wordlist
    • pspell_save_wordlist - Save the personal wordlist to a file
    • pspell_store_replacement - Store a replacement pair for a word
    • pspell_suggest - Suggest spellings of a word
    • ps_add_bookmark - Add bookmark to current page
    • ps_add_launchlink - Adds link which launches file
    • ps_add_locallink - Adds link to a page in the same document
    • ps_add_note - Adds note to current page
    • ps_add_pdflink - Adds link to a page in a second pdf document
    • ps_add_weblink - Adds link to a web location
    • ps_arc - Draws an arc counterclockwise
    • ps_arcn - Draws an arc clockwise
    • ps_begin_page - Start a new page
    • ps_begin_pattern - Start a new pattern
    • ps_begin_template - Start a new template
    • ps_circle - Draws a circle
    • ps_clip - Clips drawing to current path
    • ps_close - Closes a PostScript document
    • ps_closepath - Closes path
    • ps_closepath_stroke - Closes and strokes path
    • ps_close_image - Closes image and frees memory
    • ps_continue_text - Continue text in next line
    • ps_curveto - Draws a curve
    • ps_delete - Deletes all resources of a PostScript document
    • ps_end_page - End a page
    • ps_end_pattern - End a pattern
    • ps_end_template - End a template
    • ps_fill - Fills the current path
    • ps_fill_stroke - Fills and strokes the current path
    • ps_findfont - Loads a font
    • ps_get_buffer - Fetches the full buffer containig the generated PS data
    • ps_get_parameter - Gets certain parameters
    • ps_get_value - Gets certain values
    • ps_hyphenate - Hyphenates a word
    • ps_include_file - Reads an external file with raw PostScript code
    • ps_lineto - Draws a line
    • ps_makespotcolor - Create spot color
    • ps_moveto - Sets current point
    • ps_new - Creates a new PostScript document object
    • ps_open_file - Opens a file for output
    • ps_open_image - Reads an image for later placement
    • ps_open_image_file - Opens image from file
    • ps_open_memory_image - Takes an GD image and returns an image for placement in a PS document
    • ps_place_image - Places image on the page
    • ps_rect - Draws a rectangle
    • ps_restore - Restore previously save context
    • ps_rotate - Sets rotation factor
    • ps_save - Save current context
    • ps_scale - Sets scaling factor
    • ps_setcolor - Sets current color
    • ps_setdash - Sets appearance of a dashed line
    • ps_setflat - Sets flatness
    • ps_setfont - Sets font to use for following output
    • ps_setgray - Sets gray value
    • ps_setlinecap - Sets appearance of line ends
    • ps_setlinejoin - Sets how contected lines are joined
    • ps_setlinewidth - Sets width of a line
    • ps_setmiterlimit - Sets the miter limit
    • ps_setoverprintmode - Sets overprint mode
    • ps_setpolydash - Sets appearance of a dashed line
    • ps_set_border_color - Sets color of border for annotations
    • ps_set_border_dash - Sets length of dashes for border of annotations
    • ps_set_border_style - Sets border style of annotations
    • ps_set_info - Sets information fields of document
    • ps_set_parameter - Sets certain parameters
    • ps_set_text_pos - Sets position for text output
    • ps_set_value - Sets certain values
    • ps_shading - Creates a shading for later use
    • ps_shading_pattern - Creates a pattern based on a shading
    • ps_shfill - Fills an area with a shading
    • ps_show - Output text
    • ps_show2 - Output a text at current position
    • ps_show_boxed - Output text in a box
    • ps_show_xy - Output text at given position
    • ps_show_xy2 - Output text at position
    • ps_stringwidth - Gets width of a string
    • ps_string_geometry - Gets geometry of a string
    • ps_stroke - Draws the current path
    • ps_symbol - Output a glyph
    • ps_symbol_name - Gets name of a glyph
    • ps_symbol_width - Gets width of a glyph
    • ps_translate - Sets translation
    • putenv - 设置环境变量的值
    • px_close - Closes a paradox database
    • px_create_fp - Create a new paradox database
    • px_date2string - Converts a date into a string
    • px_delete - Deletes resource of paradox database
    • px_delete_record - Deletes record from paradox database
    • px_get_field - Returns the specification of a single field
    • px_get_info - Return lots of information about a paradox file
    • px_get_parameter - Gets a parameter
    • px_get_record - Returns record of paradox database
    • px_get_schema - Returns the database schema
    • px_get_value - Gets a value
    • px_insert_record - Inserts record into paradox database
    • px_new - Create a new paradox object
    • px_numfields - Returns number of fields in a database
    • px_numrecords - Returns number of records in a database
    • px_open_fp - Open paradox database
    • px_put_record - Stores record into paradox database
    • px_retrieve_record - Returns record of paradox database
    • px_set_blob_file - Sets the file where blobs are read from
    • px_set_parameter - Sets a parameter
    • px_set_tablename - Sets the name of a table (deprecated)
    • px_set_targetencoding - Sets the encoding for character fields (deprecated)
    • px_set_value - Sets a value
    • px_timestamp2string - Converts the timestamp into a string
    • px_update_record - Updates record in paradox database
  • q
    • QuickHashIntHash::add - This method adds a new entry to the hash
    • QuickHashIntHash::delete - This method deletes am entry from the hash
    • QuickHashIntHash::exists - This method checks whether a key is part of the hash
    • QuickHashIntHash::get - This method retrieves a value from the hash by its key
    • QuickHashIntHash::getSize - Returns the number of elements in the hash
    • QuickHashIntHash::loadFromFile - This factory method creates a hash from a file
    • QuickHashIntHash::loadFromString - This factory method creates a hash from a string
    • QuickHashIntHash::saveToFile - This method stores an in-memory hash to disk
    • QuickHashIntHash::saveToString - This method returns a serialized version of the hash
    • QuickHashIntHash::set - This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashIntHash::update - This method updates an entry in the hash with a new value
    • QuickHashIntHash::__construct - Creates a new QuickHashIntHash object
    • QuickHashIntSet::add - This method adds a new entry to the set
    • QuickHashIntSet::delete - This method deletes an entry from the set
    • QuickHashIntSet::exists - This method checks whether a key is part of the set
    • QuickHashIntSet::getSize - Returns the number of elements in the set
    • QuickHashIntSet::loadFromFile - This factory method creates a set from a file
    • QuickHashIntSet::loadFromString - This factory method creates a set from a string
    • QuickHashIntSet::saveToFile - This method stores an in-memory set to disk
    • QuickHashIntSet::saveToString - This method returns a serialized version of the set
    • QuickHashIntSet::__construct - Creates a new QuickHashIntSet object
    • QuickHashIntStringHash::add - This method adds a new entry to the hash
    • QuickHashIntStringHash::delete - This method deletes am entry from the hash
    • QuickHashIntStringHash::exists - This method checks whether a key is part of the hash
    • QuickHashIntStringHash::get - This method retrieves a value from the hash by its key
    • QuickHashIntStringHash::getSize - Returns the number of elements in the hash
    • QuickHashIntStringHash::loadFromFile - This factory method creates a hash from a file
    • QuickHashIntStringHash::loadFromString - This factory method creates a hash from a string
    • QuickHashIntStringHash::saveToFile - This method stores an in-memory hash to disk
    • QuickHashIntStringHash::saveToString - This method returns a serialized version of the hash
    • QuickHashIntStringHash::set - This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashIntStringHash::update - This method updates an entry in the hash with a new value
    • QuickHashIntStringHash::__construct - Creates a new QuickHashIntStringHash object
    • QuickHashStringIntHash::add - This method adds a new entry to the hash
    • QuickHashStringIntHash::delete - This method deletes am entry from the hash
    • QuickHashStringIntHash::exists - This method checks whether a key is part of the hash
    • QuickHashStringIntHash::get - This method retrieves a value from the hash by its key
    • QuickHashStringIntHash::getSize - Returns the number of elements in the hash
    • QuickHashStringIntHash::loadFromFile - This factory method creates a hash from a file
    • QuickHashStringIntHash::loadFromString - This factory method creates a hash from a string
    • QuickHashStringIntHash::saveToFile - This method stores an in-memory hash to disk
    • QuickHashStringIntHash::saveToString - This method returns a serialized version of the hash
    • QuickHashStringIntHash::set - This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashStringIntHash::update - This method updates an entry in the hash with a new value
    • QuickHashStringIntHash::__construct - Creates a new QuickHashStringIntHash object
    • quoted_printable_decode - 将 quoted-printable 字符串转换为 8-bit 字符串
    • quoted_printable_encode - 将 8-bit 字符串转换成 quoted-printable 字符串
    • quotemeta - 转义元字符集
  • r
    • rad2deg - 将弧度数转换为相应的角度数
    • radius_acct_open - Creates a Radius handle for accounting
    • radius_add_server - Adds a server
    • radius_auth_open - Creates a Radius handle for authentication
    • radius_close - Frees all ressources
    • radius_config - Causes the library to read the given configuration file
    • radius_create_request - Create accounting or authentication request
    • radius_cvt_addr - Converts raw data to IP-Address
    • radius_cvt_int - Converts raw data to integer
    • radius_cvt_string - Converts raw data to string
    • radius_demangle - Demangles data
    • radius_demangle_mppe_key - Derives mppe-keys from mangled data
    • radius_get_attr - Extracts an attribute
    • radius_get_tagged_attr_data - Extracts the data from a tagged attribute
    • radius_get_tagged_attr_tag - Extracts the tag from a tagged attribute
    • radius_get_vendor_attr - Extracts a vendor specific attribute
    • radius_put_addr - Attaches an IP address attribute
    • radius_put_attr - Attaches a binary attribute
    • radius_put_int - Attaches an integer attribute
    • radius_put_string - Attaches a string attribute
    • radius_put_vendor_addr - Attaches a vendor specific IP address attribute
    • radius_put_vendor_attr - Attaches a vendor specific binary attribute
    • radius_put_vendor_int - Attaches a vendor specific integer attribute
    • radius_put_vendor_string - Attaches a vendor specific string attribute
    • radius_request_authenticator - Returns the request authenticator
    • radius_salt_encrypt_attr - Salt-encrypts a value
    • radius_send_request - Sends the request and waits for a reply
    • radius_server_secret - Returns the shared secret
    • radius_strerror - Returns an error message
    • rand - 产生一个随机整数
    • random_bytes - Generates cryptographically secure pseudo-random bytes
    • random_int - Generates cryptographically secure pseudo-random integers
    • range - 根据范围创建数组，包含指定的元素
    • rar:// - RAR
    • RarArchive::close - Close RAR archive and free all resources
    • RarArchive::getComment - Get comment text from the RAR archive
    • RarArchive::getEntries - Get full list of entries from the RAR archive
    • RarArchive::getEntry - Get entry object from the RAR archive
    • RarArchive::isBroken - Test whether an archive is broken (incomplete)
    • RarArchive::isSolid - Check whether the RAR archive is solid
    • RarArchive::open - Open RAR archive
    • RarArchive::setAllowBroken - Whether opening broken archives is allowed
    • RarArchive::__toString - Get text representation
    • RarEntry::extract - Extract entry from the archive
    • RarEntry::getAttr - Get attributes of the entry
    • RarEntry::getCrc - Get CRC of the entry
    • RarEntry::getFileTime - Get entry last modification time
    • RarEntry::getHostOs - Get entry host OS
    • RarEntry::getMethod - Get pack method of the entry
    • RarEntry::getName - Get name of the entry
    • RarEntry::getPackedSize - Get packed size of the entry
    • RarEntry::getStream - Get file handler for entry
    • RarEntry::getUnpackedSize - Get unpacked size of the entry
    • RarEntry::getVersion - Get minimum version of RAR program required to unpack the entry
    • RarEntry::isDirectory - Test whether an entry represents a directory
    • RarEntry::isEncrypted - Test whether an entry is encrypted
    • RarEntry::__toString - Get text representation of entry
    • RarException::isUsingExceptions - Check whether error handling with exceptions is in use
    • RarException::setUsingExceptions - Activate and deactivate error handling with exceptions
    • rar_wrapper_cache_stats - Cache hits and misses for the URL wrapper
    • rawurldecode - 对已编码的 URL 字符串进行解码
    • rawurlencode - 按照 RFC 3986 对 URL 进行编码
    • readdir - 从目录句柄中读取条目
    • readfile - 输出文件
    • readgzfile - Output a gz-file
    • readline - 读取一行
    • readline_add_history - 添加一行命令行历史记录
    • readline_callback_handler_install - 初始化一个 readline 回调接口，然后终端输出提示信息并立即返回
    • readline_callback_handler_remove - 移除上一个安装的回调函数句柄并且恢复终端设置
    • readline_callback_read_char - 当一个行被接收时读取一个字符并且通知 readline 调用回调函数
    • readline_clear_history - 清除历史
    • readline_completion_function - 注册一个完成函数
    • readline_info - 获取/设置readline内部的各个变量
    • readline_list_history - 获取命令历史列表
    • readline_on_new_line - 通知readline将光标移动到新行
    • readline_read_history - 读取命令历史
    • readline_redisplay - 重绘显示区
    • readline_write_history - 写入历史记录
    • readlink - 返回符号连接指向的目标
    • read_exif_data - 别名 exif_read_data
    • realpath - 返回规范化的绝对路径名
    • realpath_cache_get - 获取真实目录缓存的详情
    • realpath_cache_size - 获取真实路径缓冲区的大小
    • recode - 别名 recode_string
    • recode_file - Recode from file to file according to recode request
    • recode_string - Recode a string according to a recode request
    • RecursiveArrayIterator::getChildren - Returns an iterator for the current entry if it is an array or an object
    • RecursiveArrayIterator::hasChildren - Returns whether current entry is an array or an object
    • RecursiveCachingIterator::getChildren - Return the inner iterator's children as a RecursiveCachingIterator
    • RecursiveCachingIterator::hasChildren - Check whether the current element of the inner iterator has children
    • RecursiveCachingIterator::__construct - Construct
    • RecursiveCallbackFilterIterator::getChildren - Return the inner iterator's children contained in a RecursiveCallbackFilterIterator
    • RecursiveCallbackFilterIterator::hasChildren - Check whether the inner iterator's current element has children
    • RecursiveCallbackFilterIterator::__construct - Create a RecursiveCallbackFilterIterator from a RecursiveIterator
    • RecursiveDirectoryIterator::getChildren - Returns an iterator for the current entry if it is a directory
    • RecursiveDirectoryIterator::getSubPath - Get sub path
    • RecursiveDirectoryIterator::getSubPathname - Get sub path and name
    • RecursiveDirectoryIterator::hasChildren - Returns whether current entry is a directory and not '.' or '..'
    • RecursiveDirectoryIterator::key - Return path and filename of current dir entry
    • RecursiveDirectoryIterator::next - Move to next entry
    • RecursiveDirectoryIterator::rewind - Rewind dir back to the start
    • RecursiveDirectoryIterator::__construct - Constructs a RecursiveDirectoryIterator
    • RecursiveFilterIterator::getChildren - Return the inner iterator's children contained in a RecursiveFilterIterator
    • RecursiveFilterIterator::hasChildren - Check whether the inner iterator's current element has children
    • RecursiveFilterIterator::__construct - Create a RecursiveFilterIterator from a RecursiveIterator
    • RecursiveIterator::getChildren - Returns an iterator for the current entry
    • RecursiveIterator::hasChildren - Returns if an iterator can be created for the current entry
    • RecursiveIteratorIterator::beginChildren - Begin children
    • RecursiveIteratorIterator::beginIteration - Begin Iteration
    • RecursiveIteratorIterator::callGetChildren - Get children
    • RecursiveIteratorIterator::callHasChildren - Has children
    • RecursiveIteratorIterator::current - Access the current element value
    • RecursiveIteratorIterator::endChildren - End children
    • RecursiveIteratorIterator::endIteration - End Iteration
    • RecursiveIteratorIterator::getDepth - Get the current depth of the recursive iteration
    • RecursiveIteratorIterator::getInnerIterator - Get inner iterator
    • RecursiveIteratorIterator::getMaxDepth - Get max depth
    • RecursiveIteratorIterator::getSubIterator - The current active sub iterator
    • RecursiveIteratorIterator::key - Access the current key
    • RecursiveIteratorIterator::next - Move forward to the next element
    • RecursiveIteratorIterator::nextElement - Next element
    • RecursiveIteratorIterator::rewind - Rewind the iterator to the first element of the top level inner iterator
    • RecursiveIteratorIterator::setMaxDepth - Set max depth
    • RecursiveIteratorIterator::valid - Check whether the current position is valid
    • RecursiveIteratorIterator::__construct - Construct a RecursiveIteratorIterator
    • RecursiveRegexIterator::getChildren - Returns an iterator for the current entry
    • RecursiveRegexIterator::hasChildren - Returns whether an iterator can be obtained for the current entry
    • RecursiveRegexIterator::__construct - Creates a new RecursiveRegexIterator
    • RecursiveTreeIterator::beginChildren - Begin children
    • RecursiveTreeIterator::beginIteration - Begin iteration
    • RecursiveTreeIterator::callGetChildren - Get children
    • RecursiveTreeIterator::callHasChildren - Has children
    • RecursiveTreeIterator::current - Get current element
    • RecursiveTreeIterator::endChildren - End children
    • RecursiveTreeIterator::endIteration - End iteration
    • RecursiveTreeIterator::getEntry - Get current entry
    • RecursiveTreeIterator::getPostfix - Get the postfix
    • RecursiveTreeIterator::getPrefix - Get the prefix
    • RecursiveTreeIterator::key - Get the key of the current element
    • RecursiveTreeIterator::next - Move to next element
    • RecursiveTreeIterator::nextElement - Next element
    • RecursiveTreeIterator::rewind - Rewind iterator
    • RecursiveTreeIterator::setPostfix - Set postfix
    • RecursiveTreeIterator::setPrefixPart - Set a part of the prefix
    • RecursiveTreeIterator::valid - Check validity
    • RecursiveTreeIterator::__construct - Construct a RecursiveTreeIterator
    • Reflection::export - Exports
    • Reflection::getModifierNames - 获取修饰符的名称
    • ReflectionClass::export - 导出一个类
    • ReflectionClass::getConstant - 获取定义过的一个常量
    • ReflectionClass::getConstants - 获取一组常量
    • ReflectionClass::getConstructor - 获取类的构造函数
    • ReflectionClass::getDefaultProperties - 获取默认属性
    • ReflectionClass::getDocComment - 获取文档注释
    • ReflectionClass::getEndLine - 获取最后一行的行数
    • ReflectionClass::getExtension - 根据已定义的类获取所在扩展的 ReflectionExtension 对象
    • ReflectionClass::getExtensionName - 获取定义的类所在的扩展的名称
    • ReflectionClass::getFileName - 获取定义类的文件名
    • ReflectionClass::getInterfaceNames - 获取接口（interface）名称
    • ReflectionClass::getInterfaces - 获取接口
    • ReflectionClass::getMethod - 获取一个类方法的 ReflectionMethod。
    • ReflectionClass::getMethods - 获取方法的数组
    • ReflectionClass::getModifiers - 获取类的修饰符
    • ReflectionClass::getName - 获取类名
    • ReflectionClass::getNamespaceName - 获取命名空间的名称
    • ReflectionClass::getParentClass - 获取父类
    • ReflectionClass::getProperties - 获取一组属性
    • ReflectionClass::getProperty - 获取类的一个属性的 ReflectionProperty
    • ReflectionClass::getReflectionConstant - Gets a ReflectionClassConstant for a class's constant
    • ReflectionClass::getReflectionConstants - Gets class constants
    • ReflectionClass::getShortName - 获取短名
    • ReflectionClass::getStartLine - 获取起始行号
    • ReflectionClass::getStaticProperties - 获取静态（static）属性
    • ReflectionClass::getStaticPropertyValue - 获取静态（static）属性的值
    • ReflectionClass::getTraitAliases - 返回 trait 别名的一个数组
    • ReflectionClass::getTraitNames - 返回这个类所使用 traits 的名称的数组
    • ReflectionClass::getTraits - 返回这个类所使用的 traits 数组
    • ReflectionClass::hasConstant - 检查常量是否已经定义
    • ReflectionClass::hasMethod - 检查方法是否已定义
    • ReflectionClass::hasProperty - 检查属性是否已定义
    • ReflectionClass::implementsInterface - 接口的实现
    • ReflectionClass::inNamespace - 检查是否位于命名空间中
    • ReflectionClass::isAbstract - 检查类是否是抽象类（abstract）
    • ReflectionClass::isAnonymous - 检查类是否是匿名类
    • ReflectionClass::isCloneable - 返回了一个类是否可复制
    • ReflectionClass::isFinal - 检查类是否声明为 final
    • ReflectionClass::isInstance - 检查类的实例
    • ReflectionClass::isInstantiable - 检查类是否可实例化
    • ReflectionClass::isInterface - 检查类是否是一个接口（interface）
    • ReflectionClass::isInternal - 检查类是否由扩展或核心在内部定义
    • ReflectionClass::isIterable - Check whether this class is iterable
    • ReflectionClass::isIterateable - 检查是否可迭代（iterateable）
    • ReflectionClass::isSubclassOf - 检查是否为一个子类
    • ReflectionClass::isTrait - 返回了是否为一个 trait
    • ReflectionClass::isUserDefined - 检查是否由用户定义的
    • ReflectionClass::newInstance - 从指定的参数创建一个新的类实例
    • ReflectionClass::newInstanceArgs - 从给出的参数创建一个新的类实例。
    • ReflectionClass::newInstanceWithoutConstructor - 创建一个新的类实例而不调用它的构造函数
    • ReflectionClass::setStaticPropertyValue - 设置静态属性的值
    • ReflectionClass::__construct - 初始化 ReflectionClass 类
    • ReflectionClass::__toString - 返回 ReflectionClass 对象字符串的表示形式。
    • ReflectionClassConstant::export - Export
    • ReflectionClassConstant::getDeclaringClass - Gets declaring class
    • ReflectionClassConstant::getDocComment - Gets doc comments
    • ReflectionClassConstant::getModifiers - Gets the class constant modifiers
    • ReflectionClassConstant::getName - Get name of the constant
    • ReflectionClassConstant::getValue - Gets value
    • ReflectionClassConstant::isPrivate - Checks if class constant is private
    • ReflectionClassConstant::isProtected - Checks if class constant is protected
    • ReflectionClassConstant::isPublic - Checks if class constant is public
    • ReflectionClassConstant::__construct - Constructs a ReflectionClassConstant
    • ReflectionClassConstant::__toString - Returns the string representation of the ReflectionClassConstant object
    • ReflectionExtension::export - Export
    • ReflectionExtension::getClasses - Gets classes
    • ReflectionExtension::getClassNames - 获取类名称
    • ReflectionExtension::getConstants - 获取常量
    • ReflectionExtension::getDependencies - 获取依赖
    • ReflectionExtension::getFunctions - 获取扩展中的函数
    • ReflectionExtension::getINIEntries - 获取ini配置
    • ReflectionExtension::getName - 获取扩展名称
    • ReflectionExtension::getVersion - 获取扩展版本号
    • ReflectionExtension::info - 输出扩展信息
    • ReflectionExtension::isPersistent - 返回扩展是否持久化载入
    • ReflectionExtension::isTemporary - 返回扩展是否是临时载入
    • ReflectionExtension::__clone - Clones
    • ReflectionExtension::__construct - Constructs a ReflectionExtension
    • ReflectionExtension::__toString - To string
    • ReflectionFunction::export - Exports function
    • ReflectionFunction::getClosure - Returns a dynamically created closure for the function
    • ReflectionFunction::invoke - Invokes function
    • ReflectionFunction::invokeArgs - Invokes function args
    • ReflectionFunction::isDisabled - Checks if function is disabled
    • ReflectionFunction::__construct - Constructs a ReflectionFunction object
    • ReflectionFunction::__toString - To string
    • ReflectionFunctionAbstract::getClosureScopeClass - Returns the scope associated to the closure
    • ReflectionFunctionAbstract::getClosureThis - 返回本身的匿名函数
    • ReflectionFunctionAbstract::getDocComment - 获取注释内容
    • ReflectionFunctionAbstract::getEndLine - 获取结束行号
    • ReflectionFunctionAbstract::getExtension - 获取扩展信息
    • ReflectionFunctionAbstract::getExtensionName - 获取扩展名称
    • ReflectionFunctionAbstract::getFileName - 获取文件名称
    • ReflectionFunctionAbstract::getName - 获取函数名称
    • ReflectionFunctionAbstract::getNamespaceName - 获取命名空间
    • ReflectionFunctionAbstract::getNumberOfParameters - 获取参数数目
    • ReflectionFunctionAbstract::getNumberOfRequiredParameters - 获取必须输入参数个数
    • ReflectionFunctionAbstract::getParameters - 获取参数
    • ReflectionFunctionAbstract::getReturnType - Gets the specified return type of a function
    • ReflectionFunctionAbstract::getShortName - 获取函数短名称
    • ReflectionFunctionAbstract::getStartLine - 获取开始行号
    • ReflectionFunctionAbstract::getStaticVariables - 获取静态变量
    • ReflectionFunctionAbstract::hasReturnType - Checks if the function has a specified return type
    • ReflectionFunctionAbstract::inNamespace - 检查是否处于命名空间
    • ReflectionFunctionAbstract::isClosure - 检查是否是匿名函数
    • ReflectionFunctionAbstract::isDeprecated - 检查是否已经弃用
    • ReflectionFunctionAbstract::isGenerator - 判断函数是否是一个生成器函数
    • ReflectionFunctionAbstract::isInternal - 判断函数是否是内置函数
    • ReflectionFunctionAbstract::isUserDefined - 检查是否是用户定义
    • ReflectionFunctionAbstract::isVariadic - Checks if the function is variadic
    • ReflectionFunctionAbstract::returnsReference - 检查是否返回参考信息
    • ReflectionFunctionAbstract::__clone - 复制函数
    • ReflectionFunctionAbstract::__toString - 字符串化
    • ReflectionGenerator::getExecutingFile - Gets the file name of the currently executing generator
    • ReflectionGenerator::getExecutingGenerator - Gets the executing Generator object
    • ReflectionGenerator::getExecutingLine - Gets the currently executing line of the generator
    • ReflectionGenerator::getFunction - Gets the function name of the generator
    • ReflectionGenerator::getThis - Gets the $this value of the generator
    • ReflectionGenerator::getTrace - Gets the trace of the executing generator
    • ReflectionGenerator::__construct - Constructs a ReflectionGenerator object
    • ReflectionMethod::export - 输出一个回调方法
    • ReflectionMethod::getClosure - 返回一个动态建立的方法调用接口，译者注：可以使用这个返回值直接调用非公开方法。
    • ReflectionMethod::getDeclaringClass - 获取被反射的方法所在类的反射实例
    • ReflectionMethod::getModifiers - 获取方法的修饰符
    • ReflectionMethod::getPrototype - 返回方法原型 (如果存在)
    • ReflectionMethod::invoke - Invoke
    • ReflectionMethod::invokeArgs - 带参数执行
    • ReflectionMethod::isAbstract - 判断方法是否是抽象方法
    • ReflectionMethod::isConstructor - 判断方法是否是构造方法
    • ReflectionMethod::isDestructor - 判断方法是否是析构方法
    • ReflectionMethod::isFinal - 判断方法是否定义 final
    • ReflectionMethod::isPrivate - 判断方法是否是私有方法
    • ReflectionMethod::isProtected - 判断方法是否是保护方法 (protected)
    • ReflectionMethod::isPublic - 判断方法是否是公开方法
    • ReflectionMethod::isStatic - 判断方法是否是静态方法
    • ReflectionMethod::setAccessible - 设置方法是否访问
    • ReflectionMethod::__construct - ReflectionMethod 的构造函数
    • ReflectionMethod::__toString - 返回反射方法对象的字符串表达
    • ReflectionObject::export - Export
    • ReflectionObject::__construct - Constructs a ReflectionObject
    • ReflectionParameter::allowsNull - Checks if null is allowed
    • ReflectionParameter::canBePassedByValue - Returns whether this parameter can be passed by value
    • ReflectionParameter::export - Exports
    • ReflectionParameter::getClass - 获得类型提示类。
    • ReflectionParameter::getDeclaringClass - Gets declaring class
    • ReflectionParameter::getDeclaringFunction - Gets declaring function
    • ReflectionParameter::getDefaultValue - Gets default parameter value
    • ReflectionParameter::getDefaultValueConstantName - Returns the default value's constant name if default value is constant or null
    • ReflectionParameter::getName - Gets parameter name
    • ReflectionParameter::getPosition - Gets parameter position
    • ReflectionParameter::getType - Gets a parameter's type
    • ReflectionParameter::hasType - Checks if parameter has a type
    • ReflectionParameter::isArray - Checks if parameter expects an array
    • ReflectionParameter::isCallable - Returns whether parameter MUST be callable
    • ReflectionParameter::isDefaultValueAvailable - 检查是否有默认值。
    • ReflectionParameter::isDefaultValueConstant - Returns whether the default value of this parameter is a constant
    • ReflectionParameter::isOptional - Checks if optional
    • ReflectionParameter::isPassedByReference - Checks if passed by reference
    • ReflectionParameter::isVariadic - Checks if the parameter is variadic
    • ReflectionParameter::__clone - Clone
    • ReflectionParameter::__construct - Construct
    • ReflectionParameter::__toString - To string
    • ReflectionProperty::export - Export
    • ReflectionProperty::getDeclaringClass - Gets declaring class
    • ReflectionProperty::getDefaultValue - Returns the default value declared for a property
    • ReflectionProperty::getDocComment - Gets the property doc comment
    • ReflectionProperty::getModifiers - Gets the property modifiers
    • ReflectionProperty::getName - Gets property name
    • ReflectionProperty::getType - Gets a property's type
    • ReflectionProperty::getValue - Gets value
    • ReflectionProperty::hasDefaultValue - Checks if property has a default value declared
    • ReflectionProperty::hasType - Checks if property has a type
    • ReflectionProperty::isDefault - Checks if property is a default property
    • ReflectionProperty::isInitialized - Checks whether a property is initialized
    • ReflectionProperty::isPrivate - Checks if property is private
    • ReflectionProperty::isProtected - Checks if property is protected
    • ReflectionProperty::isPublic - Checks if property is public
    • ReflectionProperty::isStatic - Checks if property is static
    • ReflectionProperty::setAccessible - Set property accessibility
    • ReflectionProperty::setValue - Set property value
    • ReflectionProperty::__clone - Clone
    • ReflectionProperty::__construct - Construct a ReflectionProperty object
    • ReflectionProperty::__toString - To string
    • ReflectionType::allowsNull - Checks if null is allowed
    • ReflectionType::__toString - To string
    • ReflectionZendExtension::export - Export
    • ReflectionZendExtension::getAuthor - Gets author
    • ReflectionZendExtension::getCopyright - Gets copyright
    • ReflectionZendExtension::getName - Gets name
    • ReflectionZendExtension::getURL - Gets URL
    • ReflectionZendExtension::getVersion - Gets version
    • ReflectionZendExtension::__clone - Clone handler
    • ReflectionZendExtension::__construct - Constructor
    • ReflectionZendExtension::__toString - To string handler
    • Reflector::export - Exports
    • Reflector::__toString - 转化成字符串
    • RegexIterator::accept - Get accept status
    • RegexIterator::getFlags - Get flags
    • RegexIterator::getMode - Returns operation mode
    • RegexIterator::getPregFlags - Returns the regular expression flags
    • RegexIterator::getRegex - Returns current regular expression
    • RegexIterator::setFlags - Sets the flags
    • RegexIterator::setMode - Sets the operation mode
    • RegexIterator::setPregFlags - Sets the regular expression flags
    • RegexIterator::__construct - Create a new RegexIterator
    • register_shutdown_function - 注册一个会在php中止时执行的函数
    • register_tick_function - Register a function for execution on each tick
    • rename - 重命名一个文件或目录
    • reset - 将数组的内部指针指向第一个单元
    • ResourceBundle::count - Get number of elements in the bundle
    • ResourceBundle::create - Create a resource bundle
    • ResourceBundle::get - Get data from the bundle
    • ResourceBundle::getErrorCode - Get bundle's last error code
    • ResourceBundle::getErrorMessage - Get bundle's last error message
    • ResourceBundle::getLocales - Get supported locales
    • restore_error_handler - 还原之前的错误处理函数
    • restore_exception_handler - 恢复之前定义过的异常处理函数。
    • restore_include_path - 还原 include_path 配置选项的值
    • Result::getAffectedItemsCount - Get affected row count
    • Result::getAutoIncrementValue - Get autoincremented value
    • Result::getGeneratedIds - Get generated ids
    • Result::getWarnings - Get warnings from last operation
    • Result::getWarningsCount - Get warning count from last operation
    • Result::__construct - Result constructor
    • rewind - 倒回文件指针的位置
    • rewinddir - 倒回目录句柄
    • rmdir - 删除目录
    • round - 对浮点数进行四舍五入
    • RowResult::fetchAll - Get all rows from result
    • RowResult::fetchOne - Get row from result
    • RowResult::getColumnNames - Get all column names
    • RowResult::getColumns - Get column metadata
    • RowResult::getColumnsCount - Get column count
    • RowResult::getWarnings - Get warnings from last operation
    • RowResult::getWarningsCount - Get warning count from last operation
    • RowResult::__construct - RowResult constructor
    • rpmaddtag - Add tag retrieved in query
    • rpmdbinfo - Get information from installed RPM
    • rpmdbsearch - Search RPM packages
    • rpminfo - Get information from a RPM file
    • rpmvercmp - RPM version comparison
    • RRDCreator::addArchive - Adds RRA - archive of data values for each data source
    • RRDCreator::addDataSource - Adds data source definition for RRD database
    • RRDCreator::save - Saves the RRD database to a file
    • RRDCreator::__construct - Creates new RRDCreator instance
    • rrdc_disconnect - Close any outstanding connection to rrd caching daemon
    • RRDGraph::save - Saves the result of query into image
    • RRDGraph::saveVerbose - Saves the RRD database query into image and returns the verbose information about generated graph
    • RRDGraph::setOptions - Sets the options for rrd graph export
    • RRDGraph::__construct - Creates new RRDGraph instance
    • RRDUpdater::update - Update the RRD database file
    • RRDUpdater::__construct - Creates new RRDUpdater instance
    • rrd_create - Creates rrd database file
    • rrd_error - Gets latest error message
    • rrd_fetch - Fetch the data for graph as array
    • rrd_first - Gets the timestamp of the first sample from rrd file
    • rrd_graph - Creates image from a data
    • rrd_info - Gets information about rrd file
    • rrd_last - Gets unix timestamp of the last sample
    • rrd_lastupdate - Gets information about last updated data
    • rrd_restore - Restores the RRD file from XML dump
    • rrd_tune - Tunes some RRD database file header options
    • rrd_update - Updates the RRD database
    • rrd_version - Gets information about underlying rrdtool library
    • rrd_xport - Exports the information about RRD database
    • rsort - 对数组逆向排序
    • rtrim - 删除字符串末端的空白字符（或者其他字符）
    • runkit7_constant_add - Similar to define(), but allows defining in class definitions as well
    • runkit7_constant_redefine - Redefine an already defined constant
    • runkit7_constant_remove - Remove/Delete an already defined constant
    • runkit7_function_add - Add a new function, similar to create_function
    • runkit7_function_copy - Copy a function to a new function name
    • runkit7_function_redefine - Replace a function definition with a new implementation
    • runkit7_function_remove - Remove a function definition
    • runkit7_function_rename - Change a function's name
    • runkit7_import - Process a PHP file importing function and class definitions, overwriting where appropriate
    • runkit7_method_add - Dynamically adds a new method to a given class
    • runkit7_method_copy - Copies a method from class to another
    • runkit7_method_redefine - Dynamically changes the code of the given method
    • runkit7_method_remove - Dynamically removes the given method
    • runkit7_method_rename - Dynamically changes the name of the given method
    • runkit7_object_id - Return the integer object handle for given object
    • runkit7_superglobals - Return numerically indexed array of registered superglobals
    • runkit7_zval_inspect - Returns information about the passed in value with data types, reference counts, etc
  • s
    • sapi_windows_cp_conv - Convert string from one codepage to another
    • sapi_windows_cp_get - Get current codepage
    • sapi_windows_cp_is_utf8 - Indicates whether the codepage is UTF-8 compatible
    • sapi_windows_cp_set - Set process codepage
    • sapi_windows_generate_ctrl_event - Send a CTRL event to another process
    • sapi_windows_set_ctrl_handler - Set or remove a CTRL event handler
    • sapi_windows_vt100_support - Get or set VT100 support for the specified stream associated to an output buffer of a Windows console.
    • scandir - 列出指定路径中的文件和目录
    • Schema::createCollection - Add collection to schema
    • Schema::dropCollection - Drop collection from schema
    • Schema::existsInDatabase - Check if exists in database
    • Schema::getCollection - Get collection from schema
    • Schema::getCollectionAsTable - Get collection table object
    • Schema::getCollections - Get all schema collections
    • Schema::getName - Get schema name
    • Schema::getSession - Get schema session
    • Schema::getTable - Get schema table
    • Schema::getTables - Get schema tables
    • Schema::__construct - constructor
    • SchemaObject::getSchema - Get schema object
    • scoutapm_get_calls - Returns a list of instrumented calls that have occurred
    • scoutapm_list_instrumented_functions - List functions scoutapm will instrument.
    • SeasLog::alert - 记录 alert 日志
    • SeasLog::analyzerCount - Get log count by level, log_path and key_word
    • SeasLog::analyzerDetail - Get log detail by level, log_path, key_word, start, limit, order
    • SeasLog::closeLoggerStream - Manually release stream flow from logger
    • SeasLog::critical - 记录 critical 日志
    • SeasLog::debug - 记录 debug 日志
    • SeasLog::emergency - 记录 emergency 日志
    • SeasLog::error - 记录 error 日志
    • SeasLog::flushBuffer - 将日志缓存刷新到介质中，文件介质，或者发送到远端的 TCP/UDP 服务地址。
    • SeasLog::getBasePath - 获得 SeasLog 根目录
    • SeasLog::getBuffer - 获取内存中的日志缓存数组
    • SeasLog::getBufferEnabled - Determin if buffer enabled
    • SeasLog::getDatetimeFormat - 获取 SeasLog 日期格式
    • SeasLog::getLastLogger - 获得 SeasLog 最近的一次 Logger 名称
    • SeasLog::getRequestID - 获得当前 SeasLog 中用于区分请求的 request_id
    • SeasLog::getRequestVariable - Get SeasLog request variable
    • SeasLog::info - Record info log information
    • SeasLog::log - 公共的日志记录函数
    • SeasLog::notice - 记录 notice 日志
    • SeasLog::setBasePath - 设置 SeasLog 根目录
    • SeasLog::setDatetimeFormat - 设置 SeasLog 日期格式
    • SeasLog::setLogger - 设置 SeasLog 的 Logger 名
    • SeasLog::setRequestID - 设置可以由 SeasLog 用于区分请求的 request_id
    • SeasLog::setRequestVariable - Manually set SeasLog request variable
    • SeasLog::warning - Record warning log information
    • SeasLog::__construct - Description
    • SeasLog::__destruct - Description
    • seaslog_get_author - 获取 SeasLog 作者
    • seaslog_get_version - 获取 SeasLog 的版本
    • SeekableIterator::seek - Seeks to a position
    • sem_acquire - Acquire a semaphore
    • sem_get - Get a semaphore id
    • sem_release - Release a semaphore
    • sem_remove - Remove a semaphore
    • Serializable::serialize - 对象的字符串表示
    • Serializable::unserialize - 构造对象
    • serialize - 产生一个可存储的值的表示
    • Session::close - Close session
    • Session::createSchema - Create new schema
    • Session::dropSchema - Drop a schema
    • Session::generateUUID - Get new UUID
    • Session::getDefaultSchema - Get default schema name
    • Session::getSchema - Get a new schema object
    • Session::getSchemas - Get the schemas
    • Session::getServerVersion - Get server version
    • Session::listClients - Get client list
    • Session::quoteName - Add quotes
    • Session::releaseSavepoint - Release set savepoint
    • Session::rollback - Rollback transaction
    • Session::rollbackTo - Rollback transaction to savepoint
    • Session::setSavepoint - Create savepoint
    • Session::sql - Execute SQL query
    • Session::startTransaction - Start transaction
    • Session::__construct - Description constructor
    • SessionHandler::close - Close the session
    • SessionHandler::create_sid - Return a new session ID
    • SessionHandler::destroy - Destroy a session
    • SessionHandler::gc - Cleanup old sessions
    • SessionHandler::open - Initialize session
    • SessionHandler::read - Read session data
    • SessionHandler::write - Write session data
    • SessionHandlerInterface::close - Close the session
    • SessionHandlerInterface::destroy - Destroy a session
    • SessionHandlerInterface::gc - Cleanup old sessions
    • SessionHandlerInterface::open - Initialize session
    • SessionHandlerInterface::read - Read session data
    • SessionHandlerInterface::write - Write session data
    • session_abort - Discard session array changes and finish session
    • session_cache_expire - 返回当前缓存的到期时间
    • session_cache_limiter - 读取/设置缓存限制器
    • session_commit - session_write_close 的别名
    • session_create_id - Create new session id
    • session_decode - 解码会话数据
    • session_destroy - 销毁一个会话中的全部数据
    • session_encode - 将当前会话数据编码为一个字符串
    • session_gc - Perform session data garbage collection
    • session_get_cookie_params - 获取会话 cookie 参数
    • session_id - 获取/设置当前会话 ID
    • session_is_registered - 检查变量是否在会话中已经注册
    • session_module_name - 获取/设置会话模块名称
    • session_name - 读取/设置会话名称
    • session_regenerate_id - 使用新生成的会话 ID 更新现有会话 ID
    • session_register_shutdown - 关闭会话
    • session_reset - Re-initialize session array with original values
    • session_save_path - 读取/设置当前会话的保存路径
    • session_set_cookie_params - 设置会话 cookie 参数
    • session_set_save_handler - 设置用户自定义会话存储函数
    • session_start - 启动新会话或者重用现有会话
    • session_status - 返回当前会话状态
    • session_unregister - Unregister a global variable from the current session
    • session_unset - 释放所有的会话变量
    • session_write_close - Write session data and end session
    • setcookie - 发送 Cookie
    • setlocale - 设置地区信息
    • setproctitle - Set the process title
    • setrawcookie - 发送未经 URL 编码的 cookie
    • setthreadtitle - Set the thread title
    • settype - 设置变量的类型
    • set_error_handler - 设置用户自定义的错误处理函数
    • set_exception_handler - 设置用户自定义的异常处理函数
    • set_file_buffer - stream_set_write_buffer 的别名
    • set_include_path - 设置 include_path 配置选项
    • set_time_limit - 设置脚本最大执行时间
    • sha1 - 计算字符串的 sha1 散列值
    • sha1_file - 计算文件的 sha1 散列值
    • shell_exec - 通过 shell 环境执行命令，并且将完整的输出以字符串的方式返回。
    • shmop_close - Close shared memory block
    • shmop_delete - Delete shared memory block
    • shmop_open - Create or open shared memory block
    • shmop_read - Read data from shared memory block
    • shmop_size - Get size of shared memory block
    • shmop_write - Write data into shared memory block
    • shm_attach - Creates or open a shared memory segment
    • shm_detach - Disconnects from shared memory segment
    • shm_get_var - Returns a variable from shared memory
    • shm_has_var - Check whether a specific entry exists
    • shm_put_var - Inserts or updates a variable in shared memory
    • shm_remove - Removes shared memory from Unix systems
    • shm_remove_var - Removes a variable from shared memory
    • show_source - 别名 highlight_file
    • shuffle - 打乱数组
    • similar_text - 计算两个字符串的相似度
    • SimpleXMLElement::addAttribute - Adds an attribute to the SimpleXML element
    • SimpleXMLElement::addChild - Adds a child element to the XML node
    • SimpleXMLElement::asXML - Return a well-formed XML string based on SimpleXML element
    • SimpleXMLElement::attributes - Identifies an element's attributes
    • SimpleXMLElement::children - Finds children of given node
    • SimpleXMLElement::count - Counts the children of an element
    • SimpleXMLElement::getDocNamespaces - Returns namespaces declared in document
    • SimpleXMLElement::getName - Gets the name of the XML element
    • SimpleXMLElement::getNamespaces - Returns namespaces used in document
    • SimpleXMLElement::registerXPathNamespace - Creates a prefix/ns context for the next XPath query
    • SimpleXMLElement::saveXML - 别名 SimpleXMLElement::asXML
    • SimpleXMLElement::xpath - Runs XPath query on XML data
    • SimpleXMLElement::__construct - Creates a new SimpleXMLElement object
    • SimpleXMLElement::__toString - Returns the string content
    • SimpleXMLIterator::current - Returns the current element
    • SimpleXMLIterator::getChildren - Returns the sub-elements of the current element
    • SimpleXMLIterator::hasChildren - Checks whether the current element has sub elements
    • SimpleXMLIterator::key - Return current key
    • SimpleXMLIterator::next - Move to next element
    • SimpleXMLIterator::rewind - Rewind to the first element
    • SimpleXMLIterator::valid - Check whether the current element is valid
    • simplexml_import_dom - Get a SimpleXMLElement object from a DOM node
    • simplexml_load_file - Interprets an XML file into an object
    • simplexml_load_string - Interprets a string of XML into an object
    • sin - 正弦
    • sinh - 双曲正弦
    • sizeof - count 的别名
    • sleep - 延缓执行
    • snmp2_get - Fetch an SNMP object
    • snmp2_getnext - Fetch the SNMP object which follows the given object id
    • snmp2_real_walk - Return all objects including their respective object ID within the specified one
    • snmp2_set - Set the value of an SNMP object
    • snmp2_walk - Fetch all the SNMP objects from an agent
    • snmp3_get - Fetch an SNMP object
    • snmp3_getnext - Fetch the SNMP object which follows the given object id
    • snmp3_real_walk - Return all objects including their respective object ID within the specified one
    • snmp3_set - Set the value of an SNMP object
    • snmp3_walk - Fetch all the SNMP objects from an agent
    • SNMP::close - Close SNMP session
    • SNMP::get - Fetch an SNMP object
    • SNMP::getErrno - Get last error code
    • SNMP::getError - Get last error message
    • SNMP::getnext - Fetch an SNMP object which follows the given object id
    • SNMP::set - Set the value of an SNMP object
    • SNMP::setSecurity - Configures security-related SNMPv3 session parameters
    • SNMP::walk - Fetch SNMP object subtree
    • SNMP::__construct - Creates SNMP instance representing session to remote SNMP agent
    • snmpget - 获取一个 SNMP 对象
    • snmpgetnext - Fetch the SNMP object which follows the given object id
    • snmprealwalk - 返回指定的所有对象，包括它们各自的对象 ID
    • snmpset - 设置一个 SNMP 对象
    • snmpwalk - 从代理返回所有的 SNMP 对象
    • snmpwalkoid - 查询关于网络实体的信息树
    • snmp_get_quick_print - 返回 UCD 库中 quick_print 设置的当前值
    • snmp_get_valueretrieval - Return the method how the SNMP values will be returned
    • snmp_read_mib - Reads and parses a MIB file into the active MIB tree
    • snmp_set_enum_print - Return all values that are enums with their enum value instead of the raw integer
    • snmp_set_oid_numeric_print - Set the OID output format
    • snmp_set_oid_output_format - Set the OID output format
    • snmp_set_quick_print - 设置 UCD SNMP 库中 quick_print 的值
    • snmp_set_valueretrieval - Specify the method how the SNMP values will be returned
    • SoapClient::__call - Calls a SOAP function (deprecated)
    • SoapClient::__construct - SoapClient constructor
    • SoapClient::__doRequest - Performs a SOAP request
    • SoapClient::__getCookies - Get list of cookies
    • SoapClient::__getFunctions - Returns list of available SOAP functions
    • SoapClient::__getLastRequest - Returns last SOAP request
    • SoapClient::__getLastRequestHeaders - Returns the SOAP headers from the last request
    • SoapClient::__getLastResponse - Returns last SOAP response
    • SoapClient::__getLastResponseHeaders - Returns the SOAP headers from the last response
    • SoapClient::__getTypes - Returns a list of SOAP types
    • SoapClient::__setCookie - Defines a cookie for SOAP requests
    • SoapClient::__setLocation - Sets the location of the Web service to use
    • SoapClient::__setSoapHeaders - Sets SOAP headers for subsequent calls
    • SoapClient::__soapCall - Calls a SOAP function
    • SoapFault::__construct - SoapFault constructor
    • SoapFault::__toString - Obtain a string representation of a SoapFault
    • SoapHeader::__construct - SoapHeader constructor
    • SoapParam::__construct - SoapParam constructor
    • SoapServer::addFunction - 添加一个或多个函数来处理SOAP请求
    • SoapServer::addSoapHeader - Add a SOAP header to the response
    • SoapServer::fault - Issue SoapServer fault indicating an error
    • SoapServer::getFunctions - Returns list of defined functions
    • SoapServer::handle - Handles a SOAP request
    • SoapServer::setClass - Sets the class which handles SOAP requests
    • SoapServer::setObject - Sets the object which will be used to handle SOAP requests
    • SoapServer::setPersistence - Sets SoapServer persistence mode
    • SoapServer::__construct - SoapServer constructor
    • SoapVar::__construct - SoapVar constructor
    • socket_accept - Accepts a connection on a socket
    • socket_addrinfo_bind - Create and bind to a socket from a given addrinfo
    • socket_addrinfo_connect - Create and connect to a socket from a given addrinfo
    • socket_addrinfo_explain - Get information about addrinfo
    • socket_addrinfo_lookup - Get array with contents of getaddrinfo about the given hostname
    • socket_bind - 给套接字绑定名字
    • socket_clear_error - 清除套接字或者最后的错误代码上的错误
    • socket_close - 关闭套接字资源
    • socket_cmsg_space - Calculate message buffer size
    • socket_connect - 开启一个套接字连接
    • socket_create - 创建一个套接字（通讯节点）
    • socket_create_listen - Opens a socket on port to accept connections
    • socket_create_pair - Creates a pair of indistinguishable sockets and stores them in an array
    • socket_export_stream - Export a socket into a stream that encapsulates a socket
    • socket_getopt - 别名 socket_get_option
    • socket_getpeername - Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
    • socket_getsockname - Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
    • socket_get_option - Gets socket options for the socket
    • socket_get_status - 别名 stream_get_meta_data
    • socket_import_stream - Import a stream
    • socket_last_error - Returns the last error on the socket
    • socket_listen - Listens for a connection on a socket
    • socket_read - Reads a maximum of length bytes from a socket
    • socket_recv - 从已连接的socket接收数据
    • socket_recvfrom - Receives data from a socket whether or not it is connection-oriented
    • socket_recvmsg - Read a message
    • socket_select - Runs the select() system call on the given arrays of sockets with a specified timeout
    • socket_send - Sends data to a connected socket
    • socket_sendmsg - Send a message
    • socket_sendto - Sends a message to a socket, whether it is connected or not
    • socket_setopt - 别名 socket_set_option
    • socket_set_block - Sets blocking mode on a socket
    • socket_set_blocking - 别名 stream_set_blocking
    • socket_set_nonblock - Sets nonblocking mode for file descriptor fd
    • socket_set_option - Sets socket options for the socket
    • socket_set_timeout - 别名 stream_set_timeout
    • socket_shutdown - Shuts down a socket for receiving, sending, or both
    • socket_strerror - Return a string describing a socket error
    • socket_write - Write to a socket
    • socket_wsaprotocol_info_export - Exports the WSAPROTOCOL_INFO Structure
    • socket_wsaprotocol_info_import - Imports a Socket from another Process
    • socket_wsaprotocol_info_release - Releases an exported WSAPROTOCOL_INFO Structure
    • sodium_add - Add large numbers
    • sodium_base642bin - Description
    • sodium_bin2base64 - Description
    • sodium_bin2hex - Encode to hexadecimal
    • sodium_compare - Compare large numbers
    • sodium_crypto_aead_aes256gcm_decrypt - Decrypt in combined mode with precalculation
    • sodium_crypto_aead_aes256gcm_encrypt - Encrypt in combined mode with precalculation
    • sodium_crypto_aead_aes256gcm_is_available - Check if hardware supports AES256-GCM
    • sodium_crypto_aead_aes256gcm_keygen - Get random bytes for key
    • sodium_crypto_aead_chacha20poly1305_decrypt - Verify that the ciphertext includes a valid tag
    • sodium_crypto_aead_chacha20poly1305_encrypt - Encrypt a message
    • sodium_crypto_aead_chacha20poly1305_ietf_decrypt - Verify that the ciphertext includes a valid tag
    • sodium_crypto_aead_chacha20poly1305_ietf_encrypt - Encrypt a message
    • sodium_crypto_aead_chacha20poly1305_ietf_keygen - Get random bytes for key
    • sodium_crypto_aead_chacha20poly1305_keygen - Get random bytes for key
    • sodium_crypto_aead_xchacha20poly1305_ietf_decrypt - Description
    • sodium_crypto_aead_xchacha20poly1305_ietf_encrypt - Description
    • sodium_crypto_aead_xchacha20poly1305_ietf_keygen - Description
    • sodium_crypto_auth - Compute a tag for the message
    • sodium_crypto_auth_keygen - Get random bytes for key
    • sodium_crypto_auth_verify - Verifies that the tag is valid for the message
    • sodium_crypto_box - Encrypt a message
    • sodium_crypto_box_keypair - Randomly generate a secret key and a corresponding public key
    • sodium_crypto_box_keypair_from_secretkey_and_publickey - Description
    • sodium_crypto_box_open - Verify and decrypt a ciphertext
    • sodium_crypto_box_publickey - Description
    • sodium_crypto_box_publickey_from_secretkey - Description
    • sodium_crypto_box_seal - Encrypt a message
    • sodium_crypto_box_seal_open - Decrypt the ciphertext
    • sodium_crypto_box_secretkey - Description
    • sodium_crypto_box_seed_keypair - Deterministically derive the key pair from a single key
    • sodium_crypto_generichash - Get a hash of the message
    • sodium_crypto_generichash_final - Complete the hash
    • sodium_crypto_generichash_init - Initialize a hash
    • sodium_crypto_generichash_keygen - Get random bytes for key
    • sodium_crypto_generichash_update - Add message to a hash
    • sodium_crypto_kdf_derive_from_key - Derive a subkey
    • sodium_crypto_kdf_keygen - Get random bytes for key
    • sodium_crypto_kx_client_session_keys - Description
    • sodium_crypto_kx_keypair - Creates a new sodium keypair
    • sodium_crypto_kx_publickey - Description
    • sodium_crypto_kx_secretkey - Description
    • sodium_crypto_kx_seed_keypair - Description
    • sodium_crypto_kx_server_session_keys - Description
    • sodium_crypto_pwhash - Derive a key from a password
    • sodium_crypto_pwhash_scryptsalsa208sha256 - Derives a key from a password
    • sodium_crypto_pwhash_scryptsalsa208sha256_str - Get an ASCII encoded hash
    • sodium_crypto_pwhash_scryptsalsa208sha256_str_verify - Verify that the password is a valid password verification string
    • sodium_crypto_pwhash_str - Get an ASCII-encoded hash
    • sodium_crypto_pwhash_str_needs_rehash - Description
    • sodium_crypto_pwhash_str_verify - Verifies that a password matches a hash
    • sodium_crypto_scalarmult - Compute a shared secret given a user's secret key and another user's public key
    • sodium_crypto_scalarmult_base - 别名 sodium_crypto_box_publickey_from_secretkey
    • sodium_crypto_secretbox - Encrypt a message
    • sodium_crypto_secretbox_keygen - Get random bytes for key
    • sodium_crypto_secretbox_open - Verify and decrypt a ciphertext
    • sodium_crypto_secretstream_xchacha20poly1305_init_pull - Description
    • sodium_crypto_secretstream_xchacha20poly1305_init_push - Description
    • sodium_crypto_secretstream_xchacha20poly1305_keygen - Description
    • sodium_crypto_secretstream_xchacha20poly1305_pull - Description
    • sodium_crypto_secretstream_xchacha20poly1305_push - Description
    • sodium_crypto_secretstream_xchacha20poly1305_rekey - Description
    • sodium_crypto_shorthash - Compute a fixed-size fingerprint for the message
    • sodium_crypto_shorthash_keygen - Get random bytes for key
    • sodium_crypto_sign - Sign a message
    • sodium_crypto_sign_detached - Sign the message
    • sodium_crypto_sign_ed25519_pk_to_curve25519 - Convert an Ed25519 public key to a Curve25519 public key
    • sodium_crypto_sign_ed25519_sk_to_curve25519 - Convert an Ed25519 secret key to a Curve25519 secret key
    • sodium_crypto_sign_keypair - Randomly generate a secret key and a corresponding public key
    • sodium_crypto_sign_keypair_from_secretkey_and_publickey - Description
    • sodium_crypto_sign_open - Check that the signed message has a valid signature
    • sodium_crypto_sign_publickey - Description
    • sodium_crypto_sign_publickey_from_secretkey - Extract the public key from the secret key
    • sodium_crypto_sign_secretkey - Description
    • sodium_crypto_sign_seed_keypair - Deterministically derive the key pair from a single key
    • sodium_crypto_sign_verify_detached - Verify signature for the message
    • sodium_crypto_stream - Generate a deterministic sequence of bytes from a seed
    • sodium_crypto_stream_keygen - Get random bytes for key
    • sodium_crypto_stream_xor - Encrypt a message
    • sodium_hex2bin - Decodes a hexadecimally encoded binary string
    • sodium_increment - Increment large number
    • sodium_memcmp - Test for equality in constant-time
    • sodium_memzero - Overwrite buf with zeros
    • sodium_pad - Add padding data
    • sodium_unpad - Remove padding data
    • SolrClient::addDocument - Adds a document to the index
    • SolrClient::addDocuments - Adds a collection of SolrInputDocument instances to the index
    • SolrClient::commit - Finalizes all add/deletes made to the index
    • SolrClient::deleteById - Delete by Id
    • SolrClient::deleteByIds - Deletes by Ids
    • SolrClient::deleteByQueries - Removes all documents matching any of the queries
    • SolrClient::deleteByQuery - Deletes all documents matching the given query
    • SolrClient::getById - Get Document By Id. Utilizes Solr Realtime Get (RTG)
    • SolrClient::getByIds - Get Documents by their Ids. Utilizes Solr Realtime Get (RTG)
    • SolrClient::getDebug - Returns the debug data for the last connection attempt
    • SolrClient::getOptions - Returns the client options set internally
    • SolrClient::optimize - Defragments the index
    • SolrClient::ping - Checks if Solr server is still up
    • SolrClient::query - Sends a query to the server
    • SolrClient::request - Sends a raw update request
    • SolrClient::rollback - Rollbacks all add/deletes made to the index since the last commit
    • SolrClient::setResponseWriter - Sets the response writer used to prepare the response from Solr
    • SolrClient::setServlet - Changes the specified servlet type to a new value
    • SolrClient::system - Retrieve Solr Server information
    • SolrClient::threads - Checks the threads status
    • SolrClient::__construct - Constructor for the SolrClient object
    • SolrClient::__destruct - Destructor for SolrClient
    • SolrClientException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrCollapseFunction::getField - Returns the field that is being collapsed on
    • SolrCollapseFunction::getHint - Returns collapse hint
    • SolrCollapseFunction::getMax - Returns max parameter
    • SolrCollapseFunction::getMin - Returns min parameter
    • SolrCollapseFunction::getNullPolicy - Returns null policy
    • SolrCollapseFunction::getSize - Returns size parameter
    • SolrCollapseFunction::setField - Sets the field to collapse on
    • SolrCollapseFunction::setHint - Sets collapse hint
    • SolrCollapseFunction::setMax - Selects the group heads by the max value of a numeric field or function query
    • SolrCollapseFunction::setMin - Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::setNullPolicy - Sets the NULL Policy
    • SolrCollapseFunction::setSize - Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::__construct - Constructor
    • SolrCollapseFunction::__toString - Returns a string representing the constructed collapse function
    • SolrDisMaxQuery::addBigramPhraseField - Adds a Phrase Bigram Field (pf2 parameter)
    • SolrDisMaxQuery::addBoostQuery - Adds a boost query field with value and optional boost (bq parameter)
    • SolrDisMaxQuery::addPhraseField - Adds a Phrase Field (pf parameter)
    • SolrDisMaxQuery::addQueryField - Add a query field with optional boost (qf parameter)
    • SolrDisMaxQuery::addTrigramPhraseField - Adds a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::addUserField - Adds a field to User Fields Parameter (uf)
    • SolrDisMaxQuery::removeBigramPhraseField - Removes phrase bigram field (pf2 parameter)
    • SolrDisMaxQuery::removeBoostQuery - Removes a boost query partial by field name (bq)
    • SolrDisMaxQuery::removePhraseField - Removes a Phrase Field (pf parameter)
    • SolrDisMaxQuery::removeQueryField - Removes a Query Field (qf parameter)
    • SolrDisMaxQuery::removeTrigramPhraseField - Removes a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::removeUserField - Removes a field from The User Fields Parameter (uf)
    • SolrDisMaxQuery::setBigramPhraseFields - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setBigramPhraseSlop - Sets Bigram Phrase Slop (ps2 parameter)
    • SolrDisMaxQuery::setBoostFunction - Sets a Boost Function (bf parameter)
    • SolrDisMaxQuery::setBoostQuery - Directly Sets Boost Query Parameter (bq)
    • SolrDisMaxQuery::setMinimumMatch - Set Minimum "Should" Match (mm)
    • SolrDisMaxQuery::setPhraseFields - Sets Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setPhraseSlop - Sets the default slop on phrase queries (ps parameter)
    • SolrDisMaxQuery::setQueryAlt - Set Query Alternate (q.alt parameter)
    • SolrDisMaxQuery::setQueryPhraseSlop - Specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
    • SolrDisMaxQuery::setTieBreaker - Sets Tie Breaker parameter (tie parameter)
    • SolrDisMaxQuery::setTrigramPhraseFields - Directly Sets Trigram Phrase Fields (pf3 parameter)
    • SolrDisMaxQuery::setTrigramPhraseSlop - Sets Trigram Phrase Slop (ps3 parameter)
    • SolrDisMaxQuery::setUserFields - Sets User Fields parameter (uf)
    • SolrDisMaxQuery::useDisMaxQueryParser - Switch QueryParser to be DisMax Query Parser
    • SolrDisMaxQuery::useEDisMaxQueryParser - Switch QueryParser to be EDisMax
    • SolrDisMaxQuery::__construct - Class Constructor
    • SolrDocument::addField - Adds a field to the document
    • SolrDocument::clear - Drops all the fields in the document
    • SolrDocument::current - Retrieves the current field
    • SolrDocument::deleteField - Removes a field from the document
    • SolrDocument::fieldExists - Checks if a field exists in the document
    • SolrDocument::getChildDocuments - Returns an array of child documents (SolrDocument)
    • SolrDocument::getChildDocumentsCount - Returns the number of child documents
    • SolrDocument::getField - Retrieves a field by name
    • SolrDocument::getFieldCount - Returns the number of fields in this document
    • SolrDocument::getFieldNames - Returns an array of fields names in the document
    • SolrDocument::getInputDocument - Returns a SolrInputDocument equivalent of the object
    • SolrDocument::hasChildDocuments - Checks whether the document has any child documents
    • SolrDocument::key - Retrieves the current key
    • SolrDocument::merge - Merges source to the current SolrDocument
    • SolrDocument::next - Moves the internal pointer to the next field
    • SolrDocument::offsetExists - Checks if a particular field exists
    • SolrDocument::offsetGet - Retrieves a field
    • SolrDocument::offsetSet - Adds a field to the document
    • SolrDocument::offsetUnset - Removes a field
    • SolrDocument::reset - This is an alias to SolrDocument::clear()
    • SolrDocument::rewind - Resets the internal pointer to the beginning
    • SolrDocument::serialize - Used for custom serialization
    • SolrDocument::sort - Sorts the fields in the document
    • SolrDocument::toArray - Returns an array representation of the document
    • SolrDocument::unserialize - Custom serialization of SolrDocument objects
    • SolrDocument::valid - Checks if the current position internally is still valid
    • SolrDocument::__clone - Creates a copy of a SolrDocument object
    • SolrDocument::__construct - Constructor
    • SolrDocument::__destruct - Destructor
    • SolrDocument::__get - Access the field as a property
    • SolrDocument::__isset - Checks if a field exists
    • SolrDocument::__set - Adds another field to the document
    • SolrDocument::__unset - Removes a field from the document
    • SolrDocumentField::__construct - Constructor
    • SolrDocumentField::__destruct - Destructor
    • SolrException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrGenericResponse::__construct - Constructor
    • SolrGenericResponse::__destruct - Destructor
    • SolrIllegalArgumentException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrIllegalOperationException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrInputDocument::addChildDocument - Adds a child document for block indexing
    • SolrInputDocument::addChildDocuments - Adds an array of child documents
    • SolrInputDocument::addField - Adds a field to the document
    • SolrInputDocument::clear - Resets the input document
    • SolrInputDocument::deleteField - Removes a field from the document
    • SolrInputDocument::fieldExists - Checks if a field exists
    • SolrInputDocument::getBoost - Retrieves the current boost value for the document
    • SolrInputDocument::getChildDocuments - Returns an array of child documents (SolrInputDocument)
    • SolrInputDocument::getChildDocumentsCount - Returns the number of child documents
    • SolrInputDocument::getField - Retrieves a field by name
    • SolrInputDocument::getFieldBoost - Retrieves the boost value for a particular field
    • SolrInputDocument::getFieldCount - Returns the number of fields in the document
    • SolrInputDocument::getFieldNames - Returns an array containing all the fields in the document
    • SolrInputDocument::hasChildDocuments - Returns true if the document has any child documents
    • SolrInputDocument::merge - Merges one input document into another
    • SolrInputDocument::reset - This is an alias of SolrInputDocument::clear
    • SolrInputDocument::setBoost - Sets the boost value for this document
    • SolrInputDocument::setFieldBoost - Sets the index-time boost value for a field
    • SolrInputDocument::sort - Sorts the fields within the document
    • SolrInputDocument::toArray - Returns an array representation of the input document
    • SolrInputDocument::__clone - Creates a copy of a SolrDocument
    • SolrInputDocument::__construct - Constructor
    • SolrInputDocument::__destruct - Destructor
    • SolrModifiableParams::__construct - Constructor
    • SolrModifiableParams::__destruct - Destructor
    • SolrObject::getPropertyNames - Returns an array of all the names of the properties
    • SolrObject::offsetExists - Checks if the property exists
    • SolrObject::offsetGet - Used to retrieve a property
    • SolrObject::offsetSet - Sets the value for a property
    • SolrObject::offsetUnset - Unsets the value for the property
    • SolrObject::__construct - Creates Solr object
    • SolrObject::__destruct - Destructor
    • SolrParams::add - This is an alias for SolrParams::addParam
    • SolrParams::addParam - Adds a parameter to the object
    • SolrParams::get - This is an alias for SolrParams::getParam
    • SolrParams::getParam - Returns a parameter value
    • SolrParams::getParams - Returns an array of non URL-encoded parameters
    • SolrParams::getPreparedParams - Returns an array of URL-encoded parameters
    • SolrParams::serialize - Used for custom serialization
    • SolrParams::set - An alias of SolrParams::setParam
    • SolrParams::setParam - Sets the parameter to the specified value
    • SolrParams::toString - Returns all the name-value pair parameters in the object
    • SolrParams::unserialize - Used for custom serialization
    • SolrPingResponse::getResponse - Returns the response from the server
    • SolrPingResponse::__construct - Constructor
    • SolrPingResponse::__destruct - Destructor
    • SolrQuery::addExpandFilterQuery - Overrides main filter query, determines which documents to include in the main group
    • SolrQuery::addExpandSortField - Orders the documents within the expanded groups (expand.sort parameter)
    • SolrQuery::addFacetDateField - Maps to facet.date
    • SolrQuery::addFacetDateOther - Adds another facet.date.other parameter
    • SolrQuery::addFacetField - Adds another field to the facet
    • SolrQuery::addFacetQuery - Adds a facet query
    • SolrQuery::addField - Specifies which fields to return in the result
    • SolrQuery::addFilterQuery - Specifies a filter query
    • SolrQuery::addGroupField - Add a field to be used to group results
    • SolrQuery::addGroupFunction - Allows grouping results based on the unique values of a function query (group.func parameter)
    • SolrQuery::addGroupQuery - Allows grouping of documents that match the given query
    • SolrQuery::addGroupSortField - Add a group sort field (group.sort parameter)
    • SolrQuery::addHighlightField - Maps to hl.fl
    • SolrQuery::addMltField - Sets a field to use for similarity
    • SolrQuery::addMltQueryField - Maps to mlt.qf
    • SolrQuery::addSortField - Used to control how the results should be sorted
    • SolrQuery::addStatsFacet - Requests a return of sub results for values within the given facet
    • SolrQuery::addStatsField - Maps to stats.field parameter
    • SolrQuery::collapse - Collapses the result set to a single document per group
    • SolrQuery::getExpand - Returns true if group expanding is enabled
    • SolrQuery::getExpandFilterQueries - Returns the expand filter queries
    • SolrQuery::getExpandQuery - Returns the expand query expand.q parameter
    • SolrQuery::getExpandRows - Returns The number of rows to display in each group (expand.rows)
    • SolrQuery::getExpandSortFields - Returns an array of fields
    • SolrQuery::getFacet - Returns the value of the facet parameter
    • SolrQuery::getFacetDateEnd - Returns the value for the facet.date.end parameter
    • SolrQuery::getFacetDateFields - Returns all the facet.date fields
    • SolrQuery::getFacetDateGap - Returns the value of the facet.date.gap parameter
    • SolrQuery::getFacetDateHardEnd - Returns the value of the facet.date.hardend parameter
    • SolrQuery::getFacetDateOther - Returns the value for the facet.date.other parameter
    • SolrQuery::getFacetDateStart - Returns the lower bound for the first date range for all date faceting on this field
    • SolrQuery::getFacetFields - Returns all the facet fields
    • SolrQuery::getFacetLimit - Returns the maximum number of constraint counts that should be returned for the facet fields
    • SolrQuery::getFacetMethod - Returns the value of the facet.method parameter
    • SolrQuery::getFacetMinCount - Returns the minimum counts for facet fields should be included in the response
    • SolrQuery::getFacetMissing - Returns the current state of the facet.missing parameter
    • SolrQuery::getFacetOffset - Returns an offset into the list of constraints to be used for pagination
    • SolrQuery::getFacetPrefix - Returns the facet prefix
    • SolrQuery::getFacetQueries - Returns all the facet queries
    • SolrQuery::getFacetSort - Returns the facet sort type
    • SolrQuery::getFields - Returns the list of fields that will be returned in the response
    • SolrQuery::getFilterQueries - Returns an array of filter queries
    • SolrQuery::getGroup - Returns true if grouping is enabled
    • SolrQuery::getGroupCachePercent - Returns group cache percent value
    • SolrQuery::getGroupFacet - Returns the group.facet parameter value
    • SolrQuery::getGroupFields - Returns group fields (group.field parameter values)
    • SolrQuery::getGroupFormat - Returns the group.format value
    • SolrQuery::getGroupFunctions - Returns group functions (group.func parameter values)
    • SolrQuery::getGroupLimit - Returns the group.limit value
    • SolrQuery::getGroupMain - Returns the group.main value
    • SolrQuery::getGroupNGroups - Returns the group.ngroups value
    • SolrQuery::getGroupOffset - Returns the group.offset value
    • SolrQuery::getGroupQueries - Returns all the group.query parameter values
    • SolrQuery::getGroupSortFields - Returns the group.sort value
    • SolrQuery::getGroupTruncate - Returns the group.truncate value
    • SolrQuery::getHighlight - Returns the state of the hl parameter
    • SolrQuery::getHighlightAlternateField - Returns the highlight field to use as backup or default
    • SolrQuery::getHighlightFields - Returns all the fields that Solr should generate highlighted snippets for
    • SolrQuery::getHighlightFormatter - Returns the formatter for the highlighted output
    • SolrQuery::getHighlightFragmenter - Returns the text snippet generator for highlighted text
    • SolrQuery::getHighlightFragsize - Returns the number of characters of fragments to consider for highlighting
    • SolrQuery::getHighlightHighlightMultiTerm - Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries
    • SolrQuery::getHighlightMaxAlternateFieldLength - Returns the maximum number of characters of the field to return
    • SolrQuery::getHighlightMaxAnalyzedChars - Returns the maximum number of characters into a document to look for suitable snippets
    • SolrQuery::getHighlightMergeContiguous - Returns whether or not the collapse contiguous fragments into a single fragment
    • SolrQuery::getHighlightRegexMaxAnalyzedChars - Returns the maximum number of characters from a field when using the regex fragmenter
    • SolrQuery::getHighlightRegexPattern - Returns the regular expression for fragmenting
    • SolrQuery::getHighlightRegexSlop - Returns the deviation factor from the ideal fragment size
    • SolrQuery::getHighlightRequireFieldMatch - Returns if a field will only be highlighted if the query matched in this particular field
    • SolrQuery::getHighlightSimplePost - Returns the text which appears after a highlighted term
    • SolrQuery::getHighlightSimplePre - Returns the text which appears before a highlighted term
    • SolrQuery::getHighlightSnippets - Returns the maximum number of highlighted snippets to generate per field
    • SolrQuery::getHighlightUsePhraseHighlighter - Returns the state of the hl.usePhraseHighlighter parameter
    • SolrQuery::getMlt - Returns whether or not MoreLikeThis results should be enabled
    • SolrQuery::getMltBoost - Returns whether or not the query will be boosted by the interesting term relevance
    • SolrQuery::getMltCount - Returns the number of similar documents to return for each result
    • SolrQuery::getMltFields - Returns all the fields to use for similarity
    • SolrQuery::getMltMaxNumQueryTerms - Returns the maximum number of query terms that will be included in any generated query
    • SolrQuery::getMltMaxNumTokens - Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support
    • SolrQuery::getMltMaxWordLength - Returns the maximum word length above which words will be ignored
    • SolrQuery::getMltMinDocFrequency - Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs
    • SolrQuery::getMltMinTermFrequency - Returns the frequency below which terms will be ignored in the source document
    • SolrQuery::getMltMinWordLength - Returns the minimum word length below which words will be ignored
    • SolrQuery::getMltQueryFields - Returns the query fields and their boosts
    • SolrQuery::getQuery - Returns the main query
    • SolrQuery::getRows - Returns the maximum number of documents
    • SolrQuery::getSortFields - Returns all the sort fields
    • SolrQuery::getStart - Returns the offset in the complete result set
    • SolrQuery::getStats - Returns whether or not stats is enabled
    • SolrQuery::getStatsFacets - Returns all the stats facets that were set
    • SolrQuery::getStatsFields - Returns all the statistics fields
    • SolrQuery::getTerms - Returns whether or not the TermsComponent is enabled
    • SolrQuery::getTermsField - Returns the field from which the terms are retrieved
    • SolrQuery::getTermsIncludeLowerBound - Returns whether or not to include the lower bound in the result set
    • SolrQuery::getTermsIncludeUpperBound - Returns whether or not to include the upper bound term in the result set
    • SolrQuery::getTermsLimit - Returns the maximum number of terms Solr should return
    • SolrQuery::getTermsLowerBound - Returns the term to start at
    • SolrQuery::getTermsMaxCount - Returns the maximum document frequency
    • SolrQuery::getTermsMinCount - Returns the minimum document frequency to return in order to be included
    • SolrQuery::getTermsPrefix - Returns the term prefix
    • SolrQuery::getTermsReturnRaw - Whether or not to return raw characters
    • SolrQuery::getTermsSort - Returns an integer indicating how terms are sorted
    • SolrQuery::getTermsUpperBound - Returns the term to stop at
    • SolrQuery::getTimeAllowed - Returns the time in milliseconds allowed for the query to finish
    • SolrQuery::removeExpandFilterQuery - Removes an expand filter query
    • SolrQuery::removeExpandSortField - Removes an expand sort field from the expand.sort parameter
    • SolrQuery::removeFacetDateField - Removes one of the facet date fields
    • SolrQuery::removeFacetDateOther - Removes one of the facet.date.other parameters
    • SolrQuery::removeFacetField - Removes one of the facet.date parameters
    • SolrQuery::removeFacetQuery - Removes one of the facet.query parameters
    • SolrQuery::removeField - Removes a field from the list of fields
    • SolrQuery::removeFilterQuery - Removes a filter query
    • SolrQuery::removeHighlightField - Removes one of the fields used for highlighting
    • SolrQuery::removeMltField - Removes one of the moreLikeThis fields
    • SolrQuery::removeMltQueryField - Removes one of the moreLikeThis query fields
    • SolrQuery::removeSortField - Removes one of the sort fields
    • SolrQuery::removeStatsFacet - Removes one of the stats.facet parameters
    • SolrQuery::removeStatsField - Removes one of the stats.field parameters
    • SolrQuery::setEchoHandler - Toggles the echoHandler parameter
    • SolrQuery::setEchoParams - Determines what kind of parameters to include in the response
    • SolrQuery::setExpand - Enables/Disables the Expand Component
    • SolrQuery::setExpandQuery - Sets the expand.q parameter
    • SolrQuery::setExpandRows - Sets the number of rows to display in each group (expand.rows). Server Default 5
    • SolrQuery::setExplainOther - Sets the explainOther common query parameter
    • SolrQuery::setFacet - Maps to the facet parameter. Enables or disables facetting
    • SolrQuery::setFacetDateEnd - Maps to facet.date.end
    • SolrQuery::setFacetDateGap - Maps to facet.date.gap
    • SolrQuery::setFacetDateHardEnd - Maps to facet.date.hardend
    • SolrQuery::setFacetDateStart - Maps to facet.date.start
    • SolrQuery::setFacetEnumCacheMinDefaultFrequency - Sets the minimum document frequency used for determining term count
    • SolrQuery::setFacetLimit - Maps to facet.limit
    • SolrQuery::setFacetMethod - Specifies the type of algorithm to use when faceting a field
    • SolrQuery::setFacetMinCount - Maps to facet.mincount
    • SolrQuery::setFacetMissing - Maps to facet.missing
    • SolrQuery::setFacetOffset - Sets the offset into the list of constraints to allow for pagination
    • SolrQuery::setFacetPrefix - Specifies a string prefix with which to limits the terms on which to facet
    • SolrQuery::setFacetSort - Determines the ordering of the facet field constraints
    • SolrQuery::setGroup - Enable/Disable result grouping (group parameter)
    • SolrQuery::setGroupCachePercent - Enables caching for result grouping
    • SolrQuery::setGroupFacet - Sets group.facet parameter
    • SolrQuery::setGroupFormat - Sets the group format, result structure (group.format parameter)
    • SolrQuery::setGroupLimit - Specifies the number of results to return for each group. The server default value is 1
    • SolrQuery::setGroupMain - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple
    • SolrQuery::setGroupNGroups - If true, Solr includes the number of groups that have matched the query in the results
    • SolrQuery::setGroupOffset - Sets the group.offset parameter
    • SolrQuery::setGroupTruncate - If true, facet counts are based on the most relevant document of each group matching the query
    • SolrQuery::setHighlight - Enables or disables highlighting
    • SolrQuery::setHighlightAlternateField - Specifies the backup field to use
    • SolrQuery::setHighlightFormatter - Specify a formatter for the highlight output
    • SolrQuery::setHighlightFragmenter - Sets a text snippet generator for highlighted text
    • SolrQuery::setHighlightFragsize - The size of fragments to consider for highlighting
    • SolrQuery::setHighlightHighlightMultiTerm - Use SpanScorer to highlight phrase terms
    • SolrQuery::setHighlightMaxAlternateFieldLength - Sets the maximum number of characters of the field to return
    • SolrQuery::setHighlightMaxAnalyzedChars - Specifies the number of characters into a document to look for suitable snippets
    • SolrQuery::setHighlightMergeContiguous - Whether or not to collapse contiguous fragments into a single fragment
    • SolrQuery::setHighlightRegexMaxAnalyzedChars - Specify the maximum number of characters to analyze
    • SolrQuery::setHighlightRegexPattern - Specify the regular expression for fragmenting
    • SolrQuery::setHighlightRegexSlop - Sets the factor by which the regex fragmenter can stray from the ideal fragment size
    • SolrQuery::setHighlightRequireFieldMatch - Require field matching during highlighting
    • SolrQuery::setHighlightSimplePost - Sets the text which appears after a highlighted term
    • SolrQuery::setHighlightSimplePre - Sets the text which appears before a highlighted term
    • SolrQuery::setHighlightSnippets - Sets the maximum number of highlighted snippets to generate per field
    • SolrQuery::setHighlightUsePhraseHighlighter - Whether to highlight phrase terms only when they appear within the query phrase
    • SolrQuery::setMlt - Enables or disables moreLikeThis
    • SolrQuery::setMltBoost - Set if the query will be boosted by the interesting term relevance
    • SolrQuery::setMltCount - Set the number of similar documents to return for each result
    • SolrQuery::setMltMaxNumQueryTerms - Sets the maximum number of query terms included
    • SolrQuery::setMltMaxNumTokens - Specifies the maximum number of tokens to parse
    • SolrQuery::setMltMaxWordLength - Sets the maximum word length
    • SolrQuery::setMltMinDocFrequency - Sets the mltMinDoc frequency
    • SolrQuery::setMltMinTermFrequency - Sets the frequency below which terms will be ignored in the source docs
    • SolrQuery::setMltMinWordLength - Sets the minimum word length
    • SolrQuery::setOmitHeader - Exclude the header from the returned results
    • SolrQuery::setQuery - Sets the search query
    • SolrQuery::setRows - Specifies the maximum number of rows to return in the result
    • SolrQuery::setShowDebugInfo - Flag to show debug information
    • SolrQuery::setStart - Specifies the number of rows to skip
    • SolrQuery::setStats - Enables or disables the Stats component
    • SolrQuery::setTerms - Enables or disables the TermsComponent
    • SolrQuery::setTermsField - Sets the name of the field to get the Terms from
    • SolrQuery::setTermsIncludeLowerBound - Include the lower bound term in the result set
    • SolrQuery::setTermsIncludeUpperBound - Include the upper bound term in the result set
    • SolrQuery::setTermsLimit - Sets the maximum number of terms to return
    • SolrQuery::setTermsLowerBound - Specifies the Term to start from
    • SolrQuery::setTermsMaxCount - Sets the maximum document frequency
    • SolrQuery::setTermsMinCount - Sets the minimum document frequency
    • SolrQuery::setTermsPrefix - Restrict matches to terms that start with the prefix
    • SolrQuery::setTermsReturnRaw - Return the raw characters of the indexed term
    • SolrQuery::setTermsSort - Specifies how to sort the returned terms
    • SolrQuery::setTermsUpperBound - Sets the term to stop at
    • SolrQuery::setTimeAllowed - The time allowed for search to finish
    • SolrQuery::__construct - Constructor
    • SolrQuery::__destruct - Destructor
    • SolrQueryResponse::__construct - Constructor
    • SolrQueryResponse::__destruct - Destructor
    • SolrResponse::getDigestedResponse - Returns the XML response as serialized PHP data
    • SolrResponse::getHttpStatus - Returns the HTTP status of the response
    • SolrResponse::getHttpStatusMessage - Returns more details on the HTTP status
    • SolrResponse::getRawRequest - Returns the raw request sent to the Solr server
    • SolrResponse::getRawRequestHeaders - Returns the raw request headers sent to the Solr server
    • SolrResponse::getRawResponse - Returns the raw response from the server
    • SolrResponse::getRawResponseHeaders - Returns the raw response headers from the server
    • SolrResponse::getRequestUrl - Returns the full URL the request was sent to
    • SolrResponse::getResponse - Returns a SolrObject representing the XML response from the server
    • SolrResponse::setParseMode - Sets the parse mode
    • SolrResponse::success - Was the request a success
    • SolrServerException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrUpdateResponse::__construct - Constructor
    • SolrUpdateResponse::__destruct - Destructor
    • SolrUtils::digestXmlResponse - Parses an response XML string into a SolrObject
    • SolrUtils::escapeQueryChars - Escapes a lucene query string
    • SolrUtils::getSolrVersion - Returns the current version of the Solr extension
    • SolrUtils::queryPhrase - Prepares a phrase from an unescaped lucene string
    • solr_get_version - 返回当前Solr扩展的版本
    • sort - 对数组排序
    • soundex - Calculate the soundex key of a string
    • SphinxClient::addQuery - Add query to multi-query batch
    • SphinxClient::buildExcerpts - Build text snippets
    • SphinxClient::buildKeywords - Extract keywords from query
    • SphinxClient::close - 关闭先前打开的持久连接
    • SphinxClient::escapeString - Escape special characters
    • SphinxClient::getLastError - Get the last error message
    • SphinxClient::getLastWarning - Get the last warning
    • SphinxClient::open - 建立到搜索服务端的持久连接
    • SphinxClient::query - 执行搜索查询
    • SphinxClient::resetFilters - Clear all filters
    • SphinxClient::resetGroupBy - Clear all group-by settings
    • SphinxClient::runQueries - Run a batch of search queries
    • SphinxClient::setArrayResult - 控制搜索结果集的返回格式
    • SphinxClient::setConnectTimeout - Set connection timeout
    • SphinxClient::setFieldWeights - Set field weights
    • SphinxClient::setFilter - 增加整数值过滤器
    • SphinxClient::setFilterFloatRange - Add new float range filter
    • SphinxClient::setFilterRange - Add new integer range filter
    • SphinxClient::setGeoAnchor - Set anchor point for a geosphere distance calculations
    • SphinxClient::setGroupBy - Set grouping attribute
    • SphinxClient::setGroupDistinct - Set attribute name for per-group distinct values count calculations
    • SphinxClient::setIDRange - Set a range of accepted document IDs
    • SphinxClient::setIndexWeights - Set per-index weights
    • SphinxClient::setLimits - 设置返回结果集偏移量和数目
    • SphinxClient::setMatchMode - 设置全文查询的匹配模式
    • SphinxClient::setMaxQueryTime - Set maximum query time
    • SphinxClient::setOverride - Sets temporary per-document attribute value overrides
    • SphinxClient::setRankingMode - Set ranking mode
    • SphinxClient::setRetries - Set retry count and delay
    • SphinxClient::setSelect - Set select clause
    • SphinxClient::setServer - 设置searchd的主机名和TCP端口
    • SphinxClient::setSortMode - Set matches sorting mode
    • SphinxClient::status - Queries searchd status
    • SphinxClient::updateAttributes - Update document attributes
    • SphinxClient::__construct - Create a new SphinxClient object
    • SplDoublyLinkedList::add - Add/insert a new value at the specified index
    • SplDoublyLinkedList::bottom - Peeks at the node from the beginning of the doubly linked list
    • SplDoublyLinkedList::count - Counts the number of elements in the doubly linked list
    • SplDoublyLinkedList::current - Return current array entry
    • SplDoublyLinkedList::getIteratorMode - Returns the mode of iteration
    • SplDoublyLinkedList::isEmpty - Checks whether the doubly linked list is empty
    • SplDoublyLinkedList::key - Return current node index
    • SplDoublyLinkedList::next - Move to next entry
    • SplDoublyLinkedList::offsetExists - Returns whether the requested $index exists
    • SplDoublyLinkedList::offsetGet - Returns the value at the specified $index
    • SplDoublyLinkedList::offsetSet - Sets the value at the specified $index to $newval
    • SplDoublyLinkedList::offsetUnset - Unsets the value at the specified $index
    • SplDoublyLinkedList::pop - Pops a node from the end of the doubly linked list
    • SplDoublyLinkedList::prev - Move to previous entry
    • SplDoublyLinkedList::push - Pushes an element at the end of the doubly linked list
    • SplDoublyLinkedList::rewind - Rewind iterator back to the start
    • SplDoublyLinkedList::serialize - Serializes the storage
    • SplDoublyLinkedList::setIteratorMode - Sets the mode of iteration
    • SplDoublyLinkedList::shift - Shifts a node from the beginning of the doubly linked list
    • SplDoublyLinkedList::top - Peeks at the node from the end of the doubly linked list
    • SplDoublyLinkedList::unserialize - Unserializes the storage
    • SplDoublyLinkedList::unshift - Prepends the doubly linked list with an element
    • SplDoublyLinkedList::valid - Check whether the doubly linked list contains more nodes
    • SplDoublyLinkedList::__construct - Constructs a new doubly linked list
    • SplFileInfo::getATime - Gets last access time of the file
    • SplFileInfo::getBasename - Gets the base name of the file
    • SplFileInfo::getCTime - 获取文件 inode 修改时间
    • SplFileInfo::getExtension - Gets the file extension
    • SplFileInfo::getFileInfo - Gets an SplFileInfo object for the file
    • SplFileInfo::getFilename - Gets the filename
    • SplFileInfo::getGroup - Gets the file group
    • SplFileInfo::getInode - Gets the inode for the file
    • SplFileInfo::getLinkTarget - Gets the target of a link
    • SplFileInfo::getMTime - Gets the last modified time
    • SplFileInfo::getOwner - Gets the owner of the file
    • SplFileInfo::getPath - Gets the path without filename
    • SplFileInfo::getPathInfo - Gets an SplFileInfo object for the path
    • SplFileInfo::getPathname - Gets the path to the file
    • SplFileInfo::getPerms - Gets file permissions
    • SplFileInfo::getRealPath - Gets absolute path to file
    • SplFileInfo::getSize - Gets file size
    • SplFileInfo::getType - Gets file type
    • SplFileInfo::isDir - Tells if the file is a directory
    • SplFileInfo::isExecutable - Tells if the file is executable
    • SplFileInfo::isFile - Tells if the object references a regular file
    • SplFileInfo::isLink - Tells if the file is a link
    • SplFileInfo::isReadable - Tells if file is readable
    • SplFileInfo::isWritable - Tells if the entry is writable
    • SplFileInfo::openFile - Gets an SplFileObject object for the file
    • SplFileInfo::setFileClass - Sets the class used with SplFileInfo::openFile
    • SplFileInfo::setInfoClass - Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo
    • SplFileInfo::__construct - 构建一个新的 SplFileInfo 对象
    • SplFileInfo::__toString - Returns the path to the file as a string
    • SplFileObject::current - Retrieve current line of file
    • SplFileObject::eof - Reached end of file
    • SplFileObject::fflush - Flushes the output to the file
    • SplFileObject::fgetc - Gets character from file
    • SplFileObject::fgetcsv - Gets line from file and parse as CSV fields
    • SplFileObject::fgets - Gets line from file
    • SplFileObject::fgetss - Gets line from file and strip HTML tags
    • SplFileObject::flock - Portable file locking
    • SplFileObject::fpassthru - Output all remaining data on a file pointer
    • SplFileObject::fputcsv - Write a field array as a CSV line
    • SplFileObject::fread - Read from file
    • SplFileObject::fscanf - Parses input from file according to a format
    • SplFileObject::fseek - Seek to a position
    • SplFileObject::fstat - Gets information about the file
    • SplFileObject::ftell - Return current file position
    • SplFileObject::ftruncate - Truncates the file to a given length
    • SplFileObject::fwrite - Write to file
    • SplFileObject::getChildren - No purpose
    • SplFileObject::getCsvControl - Get the delimiter, enclosure and escape character for CSV
    • SplFileObject::getCurrentLine - Alias of SplFileObject::fgets
    • SplFileObject::getFlags - Gets flags for the SplFileObject
    • SplFileObject::getMaxLineLen - Get maximum line length
    • SplFileObject::hasChildren - SplFileObject does not have children
    • SplFileObject::key - Get line number
    • SplFileObject::next - Read next line
    • SplFileObject::rewind - Rewind the file to the first line
    • SplFileObject::seek - Seek to specified line
    • SplFileObject::setCsvControl - Set the delimiter, enclosure and escape character for CSV
    • SplFileObject::setFlags - Sets flags for the SplFileObject
    • SplFileObject::setMaxLineLen - Set maximum line length
    • SplFileObject::valid - Not at EOF
    • SplFileObject::__construct - Construct a new file object
    • SplFileObject::__toString - Alias of SplFileObject::fgets
    • SplFixedArray::count - Returns the size of the array
    • SplFixedArray::current - Return current array entry
    • SplFixedArray::fromArray - Import a PHP array in a SplFixedArray instance
    • SplFixedArray::getSize - Gets the size of the array
    • SplFixedArray::key - Return current array index
    • SplFixedArray::next - Move to next entry
    • SplFixedArray::offsetExists - Returns whether the requested index exists
    • SplFixedArray::offsetGet - Returns the value at the specified index
    • SplFixedArray::offsetSet - Sets a new value at a specified index
    • SplFixedArray::offsetUnset - Unsets the value at the specified $index
    • SplFixedArray::rewind - Rewind iterator back to the start
    • SplFixedArray::setSize - Change the size of an array
    • SplFixedArray::toArray - Returns a PHP array from the fixed array
    • SplFixedArray::valid - Check whether the array contains more elements
    • SplFixedArray::__construct - Constructs a new fixed array
    • SplFixedArray::__wakeup - Reinitialises the array after being unserialised
    • SplHeap::compare - Compare elements in order to place them correctly in the heap while sifting up
    • SplHeap::count - Counts the number of elements in the heap
    • SplHeap::current - Return current node pointed by the iterator
    • SplHeap::extract - Extracts a node from top of the heap and sift up
    • SplHeap::insert - Inserts an element in the heap by sifting it up
    • SplHeap::isCorrupted - Tells if the heap is in a corrupted state
    • SplHeap::isEmpty - Checks whether the heap is empty
    • SplHeap::key - Return current node index
    • SplHeap::next - Move to the next node
    • SplHeap::recoverFromCorruption - Recover from the corrupted state and allow further actions on the heap
    • SplHeap::rewind - Rewind iterator back to the start (no-op)
    • SplHeap::top - Peeks at the node from the top of the heap
    • SplHeap::valid - Check whether the heap contains more nodes
    • SplHeap::__construct - Constructs a new empty heap
    • split - 用正则表达式将字符串分割到数组中
    • spliti - 用正则表达式不区分大小写将字符串分割到数组中
    • SplMaxHeap::compare - Compare elements in order to place them correctly in the heap while sifting up
    • SplMinHeap::compare - Compare elements in order to place them correctly in the heap while sifting up
    • SplObjectStorage::addAll - Adds all objects from another storage
    • SplObjectStorage::attach - Adds an object in the storage
    • SplObjectStorage::contains - Checks if the storage contains a specific object
    • SplObjectStorage::count - Returns the number of objects in the storage
    • SplObjectStorage::current - Returns the current storage entry
    • SplObjectStorage::detach - Removes an object from the storage
    • SplObjectStorage::getHash - Calculate a unique identifier for the contained objects
    • SplObjectStorage::getInfo - Returns the data associated with the current iterator entry
    • SplObjectStorage::key - Returns the index at which the iterator currently is
    • SplObjectStorage::next - Move to the next entry
    • SplObjectStorage::offsetExists - Checks whether an object exists in the storage
    • SplObjectStorage::offsetGet - Returns the data associated with an object
    • SplObjectStorage::offsetSet - Associates data to an object in the storage
    • SplObjectStorage::offsetUnset - Removes an object from the storage
    • SplObjectStorage::removeAll - Removes objects contained in another storage from the current storage
    • SplObjectStorage::removeAllExcept - Removes all objects except for those contained in another storage from the current storage
    • SplObjectStorage::rewind - Rewind the iterator to the first storage element
    • SplObjectStorage::serialize - Serializes the storage
    • SplObjectStorage::setInfo - Sets the data associated with the current iterator entry
    • SplObjectStorage::unserialize - Unserializes a storage from its string representation
    • SplObjectStorage::valid - Returns if the current iterator entry is valid
    • SplObserver::update - Receive update from subject
    • SplPriorityQueue::compare - Compare priorities in order to place elements correctly in the heap while sifting up
    • SplPriorityQueue::count - Counts the number of elements in the queue
    • SplPriorityQueue::current - Return current node pointed by the iterator
    • SplPriorityQueue::extract - Extracts a node from top of the heap and sift up
    • SplPriorityQueue::getExtractFlags - Get the flags of extraction
    • SplPriorityQueue::insert - Inserts an element in the queue by sifting it up
    • SplPriorityQueue::isCorrupted - Tells if the priority queue is in a corrupted state
    • SplPriorityQueue::isEmpty - Checks whether the queue is empty
    • SplPriorityQueue::key - Return current node index
    • SplPriorityQueue::next - Move to the next node
    • SplPriorityQueue::recoverFromCorruption - Recover from the corrupted state and allow further actions on the queue
    • SplPriorityQueue::rewind - Rewind iterator back to the start (no-op)
    • SplPriorityQueue::setExtractFlags - Sets the mode of extraction
    • SplPriorityQueue::top - Peeks at the node from the top of the queue
    • SplPriorityQueue::valid - Check whether the queue contains more nodes
    • SplPriorityQueue::__construct - Constructs a new empty queue
    • SplQueue::dequeue - Dequeues a node from the queue
    • SplQueue::enqueue - Adds an element to the queue
    • SplQueue::setIteratorMode - Sets the mode of iteration
    • SplQueue::__construct - Constructs a new queue implemented using a doubly linked list
    • SplStack::setIteratorMode - Sets the mode of iteration
    • SplStack::__construct - Constructs a new stack implemented using a doubly linked list
    • SplSubject::attach - Attach an SplObserver
    • SplSubject::detach - Detach an observer
    • SplSubject::notify - Notify an observer
    • SplTempFileObject::__construct - Construct a new temporary file object
    • spl_autoload - __autoload()函数的默认实现
    • spl_autoload_call - 尝试调用所有已注册的 __autoload() 函数来装载请求类
    • spl_autoload_extensions - 注册并返回 spl_autoload 函数使用的默认文件扩展名
    • spl_autoload_functions - 返回所有已注册的 __autoload() 函数
    • spl_autoload_register - 注册给定的函数作为 __autoload 的实现
    • spl_autoload_unregister - 注销已注册的 __autoload() 函数
    • spl_classes - 返回所有可用的SPL类
    • spl_object_hash - 返回指定对象的hash id
    • spl_object_id - Return the integer object handle for given object
    • Spoofchecker::areConfusable - Checks if given strings can be confused
    • Spoofchecker::isSuspicious - Checks if a given text contains any suspicious characters
    • Spoofchecker::setAllowedLocales - Locales to use when running checks
    • Spoofchecker::setChecks - Set the checks to run
    • Spoofchecker::__construct - Constructor
    • sprintf - Return a formatted string
    • SQLite3::backup - Backup one database to another database
    • SQLite3::busyTimeout - Sets the busy connection handler
    • SQLite3::changes - Returns the number of database rows that were changed (or inserted or deleted) by the most recent SQL statement
    • SQLite3::close - Closes the database connection
    • SQLite3::createAggregate - Registers a PHP function for use as an SQL aggregate function
    • SQLite3::createCollation - Registers a PHP function for use as an SQL collating function
    • SQLite3::createFunction - Registers a PHP function for use as an SQL scalar function
    • SQLite3::enableExceptions - Enable throwing exceptions
    • SQLite3::escapeString - Returns a string that has been properly escaped
    • SQLite3::exec - Executes a result-less query against a given database
    • SQLite3::lastErrorCode - Returns the numeric result code of the most recent failed SQLite request
    • SQLite3::lastErrorMsg - Returns English text describing the most recent failed SQLite request
    • SQLite3::lastInsertRowID - Returns the row ID of the most recent INSERT into the database
    • SQLite3::loadExtension - Attempts to load an SQLite extension library
    • SQLite3::open - Opens an SQLite database
    • SQLite3::openBlob - Opens a stream resource to read a BLOB
    • SQLite3::prepare - Prepares an SQL statement for execution
    • SQLite3::query - Executes an SQL query
    • SQLite3::querySingle - Executes a query and returns a single result
    • SQLite3::setAuthorizer - Configures a callback to be used as an authorizer to limit what a statement can do
    • SQLite3::version - Returns the SQLite3 library version as a string constant and as a number
    • SQLite3::__construct - Instantiates an SQLite3 object and opens an SQLite 3 database
    • SQLite3Result::columnName - Returns the name of the nth column
    • SQLite3Result::columnType - Returns the type of the nth column
    • SQLite3Result::fetchArray - Fetches a result row as an associative or numerically indexed array or both
    • SQLite3Result::finalize - Closes the result set
    • SQLite3Result::numColumns - Returns the number of columns in the result set
    • SQLite3Result::reset - Resets the result set back to the first row
    • SQLite3Stmt::bindParam - Binds a parameter to a statement variable
    • SQLite3Stmt::bindValue - Binds the value of a parameter to a statement variable
    • SQLite3Stmt::clear - Clears all current bound parameters
    • SQLite3Stmt::close - Closes the prepared statement
    • SQLite3Stmt::execute - Executes a prepared statement and returns a result set object
    • SQLite3Stmt::getSQL - Get the SQL of the statement
    • SQLite3Stmt::paramCount - Returns the number of parameters within the prepared statement
    • SQLite3Stmt::readOnly - Returns whether a statement is definitely read only
    • SQLite3Stmt::reset - Resets the prepared statement
    • sqlsrv_begin_transaction - Begins a database transaction
    • sqlsrv_cancel - Cancels a statement
    • sqlsrv_client_info - Returns information about the client and specified connection
    • sqlsrv_close - Closes an open connection and releases resourses associated with the connection
    • sqlsrv_commit - Commits a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_configure - Changes the driver error handling and logging configurations
    • sqlsrv_connect - Opens a connection to a Microsoft SQL Server database
    • sqlsrv_errors - Returns error and warning information about the last SQLSRV operation performed
    • sqlsrv_execute - Executes a statement prepared with sqlsrv_prepare
    • sqlsrv_fetch - Makes the next row in a result set available for reading
    • sqlsrv_fetch_array - Returns a row as an array
    • sqlsrv_fetch_object - Retrieves the next row of data in a result set as an object
    • sqlsrv_field_metadata - Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query
    • sqlsrv_free_stmt - Frees all resources for the specified statement
    • sqlsrv_get_config - Returns the value of the specified configuration setting
    • sqlsrv_get_field - Gets field data from the currently selected row
    • sqlsrv_has_rows - Indicates whether the specified statement has rows
    • sqlsrv_next_result - Makes the next result of the specified statement active
    • sqlsrv_num_fields - Retrieves the number of fields (columns) on a statement
    • sqlsrv_num_rows - Retrieves the number of rows in a result set
    • sqlsrv_prepare - Prepares a query for execution
    • sqlsrv_query - Prepares and executes a query
    • sqlsrv_rollback - Rolls back a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_rows_affected - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
    • sqlsrv_send_stream_data - Sends data from parameter streams to the server
    • sqlsrv_server_info - Returns information about the server
    • SqlStatement::bind - Bind statement parameters
    • SqlStatement::execute - Execute the operation
    • SqlStatement::getNextResult - Get next result
    • SqlStatement::getResult - Get result
    • SqlStatement::hasMoreResults - Check for more results
    • SqlStatement::__construct - Description constructor
    • SqlStatementResult::fetchAll - Get all rows from result
    • SqlStatementResult::fetchOne - Get single row
    • SqlStatementResult::getAffectedItemsCount - Get affected row count
    • SqlStatementResult::getColumnNames - Get column names
    • SqlStatementResult::getColumns - Get columns
    • SqlStatementResult::getColumnsCount - Get column count
    • SqlStatementResult::getGeneratedIds - Get generated ids
    • SqlStatementResult::getLastInsertId - Get last insert id
    • SqlStatementResult::getWarnings - Get warnings from last operation
    • SqlStatementResult::getWarningsCount - Get warning count from last operation
    • SqlStatementResult::hasData - Check if result has data
    • SqlStatementResult::nextResult - Get next result
    • SqlStatementResult::__construct - Description constructor
    • sql_regcase - 产生用于不区分大小的匹配的正则表达式
    • sqrt - 平方根
    • srand - 播下随机数发生器种子
    • sscanf - 根据指定格式解析输入的字符
    • ssdeep_fuzzy_compare - Calculates the match score between two fuzzy hash signatures
    • ssdeep_fuzzy_hash - Create a fuzzy hash from a string
    • ssdeep_fuzzy_hash_filename - Create a fuzzy hash from a file
    • ssh2:// - Secure Shell 2
    • ssh2_auth_agent - Authenticate over SSH using the ssh agent
    • ssh2_auth_hostbased_file - Authenticate using a public hostkey
    • ssh2_auth_none - Authenticate as "none"
    • ssh2_auth_password - Authenticate over SSH using a plain password
    • ssh2_auth_pubkey_file - Authenticate using a public key
    • ssh2_connect - Connect to an SSH server
    • ssh2_disconnect - Close a connection to a remote SSH server
    • ssh2_exec - Execute a command on a remote server
    • ssh2_fetch_stream - Fetch an extended data stream
    • ssh2_fingerprint - Retrieve fingerprint of remote server
    • ssh2_forward_accept - Accept a connection created by a listener
    • ssh2_forward_listen - Bind a port on the remote server and listen for connections
    • ssh2_methods_negotiated - Return list of negotiated methods
    • ssh2_poll - Poll the channels/listeners/streams for events
    • ssh2_publickey_add - Add an authorized publickey
    • ssh2_publickey_init - Initialize Publickey subsystem
    • ssh2_publickey_list - List currently authorized publickeys
    • ssh2_publickey_remove - Remove an authorized publickey
    • ssh2_scp_recv - Request a file via SCP
    • ssh2_scp_send - Send a file via SCP
    • ssh2_sftp - Initialize SFTP subsystem
    • ssh2_sftp_chmod - Changes file mode
    • ssh2_sftp_lstat - Stat a symbolic link
    • ssh2_sftp_mkdir - Create a directory
    • ssh2_sftp_readlink - Return the target of a symbolic link
    • ssh2_sftp_realpath - Resolve the realpath of a provided path string
    • ssh2_sftp_rename - Rename a remote file
    • ssh2_sftp_rmdir - Remove a directory
    • ssh2_sftp_stat - Stat a file on a remote filesystem
    • ssh2_sftp_symlink - Create a symlink
    • ssh2_sftp_unlink - Delete a file
    • ssh2_shell - Request an interactive shell
    • ssh2_tunnel - Open a tunnel through a remote server
    • SSL 上下文选项 - SSL 上下文选项清单
    • stat - 给出文件的信息
    • Statement::getNextResult - Get next result
    • Statement::getResult - Get result
    • Statement::hasMoreResults - Check if more results
    • Statement::__construct - Description constructor
    • stats_absolute_deviation - Returns the absolute deviation of an array of values
    • stats_cdf_beta - Calculates any one parameter of the beta distribution given values for the others
    • stats_cdf_binomial - Calculates any one parameter of the binomial distribution given values for the others
    • stats_cdf_cauchy - Calculates any one parameter of the Cauchy distribution given values for the others
    • stats_cdf_chisquare - Calculates any one parameter of the chi-square distribution given values for the others
    • stats_cdf_exponential - Calculates any one parameter of the exponential distribution given values for the others
    • stats_cdf_f - Calculates any one parameter of the F distribution given values for the others
    • stats_cdf_gamma - Calculates any one parameter of the gamma distribution given values for the others
    • stats_cdf_laplace - Calculates any one parameter of the Laplace distribution given values for the others
    • stats_cdf_logistic - Calculates any one parameter of the logistic distribution given values for the others
    • stats_cdf_negative_binomial - Calculates any one parameter of the negative binomial distribution given values for the others
    • stats_cdf_noncentral_chisquare - Calculates any one parameter of the non-central chi-square distribution given values for the others
    • stats_cdf_noncentral_f - Calculates any one parameter of the non-central F distribution given values for the others
    • stats_cdf_noncentral_t - Calculates any one parameter of the non-central t-distribution give values for the others
    • stats_cdf_normal - Calculates any one parameter of the normal distribution given values for the others
    • stats_cdf_poisson - Calculates any one parameter of the Poisson distribution given values for the others
    • stats_cdf_t - Calculates any one parameter of the t-distribution given values for the others
    • stats_cdf_uniform - Calculates any one parameter of the uniform distribution given values for the others
    • stats_cdf_weibull - Calculates any one parameter of the Weibull distribution given values for the others
    • stats_covariance - Computes the covariance of two data sets
    • stats_dens_beta - Probability density function of the beta distribution
    • stats_dens_cauchy - Probability density function of the Cauchy distribution
    • stats_dens_chisquare - Probability density function of the chi-square distribution
    • stats_dens_exponential - Probability density function of the exponential distribution
    • stats_dens_f - Probability density function of the F distribution
    • stats_dens_gamma - Probability density function of the gamma distribution
    • stats_dens_laplace - Probability density function of the Laplace distribution
    • stats_dens_logistic - Probability density function of the logistic distribution
    • stats_dens_normal - Probability density function of the normal distribution
    • stats_dens_pmf_binomial - Probability mass function of the binomial distribution
    • stats_dens_pmf_hypergeometric - Probability mass function of the hypergeometric distribution
    • stats_dens_pmf_negative_binomial - Probability mass function of the negative binomial distribution
    • stats_dens_pmf_poisson - Probability mass function of the Poisson distribution
    • stats_dens_t - Probability density function of the t-distribution
    • stats_dens_uniform - Probability density function of the uniform distribution
    • stats_dens_weibull - Probability density function of the Weibull distribution
    • stats_harmonic_mean - Returns the harmonic mean of an array of values
    • stats_kurtosis - Computes the kurtosis of the data in the array
    • stats_rand_gen_beta - Generates a random deviate from the beta distribution
    • stats_rand_gen_chisquare - Generates a random deviate from the chi-square distribution
    • stats_rand_gen_exponential - Generates a random deviate from the exponential distribution
    • stats_rand_gen_f - Generates a random deviate from the F distribution
    • stats_rand_gen_funiform - Generates uniform float between low (exclusive) and high (exclusive)
    • stats_rand_gen_gamma - Generates a random deviate from the gamma distribution
    • stats_rand_gen_ibinomial - Generates a random deviate from the binomial distribution
    • stats_rand_gen_ibinomial_negative - Generates a random deviate from the negative binomial distribution
    • stats_rand_gen_int - Generates random integer between 1 and 2147483562
    • stats_rand_gen_ipoisson - Generates a single random deviate from a Poisson distribution
    • stats_rand_gen_iuniform - Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)
    • stats_rand_gen_noncentral_chisquare - Generates a random deviate from the non-central chi-square distribution
    • stats_rand_gen_noncentral_f - Generates a random deviate from the noncentral F distribution
    • stats_rand_gen_noncentral_t - Generates a single random deviate from a non-central t-distribution
    • stats_rand_gen_normal - Generates a single random deviate from a normal distribution
    • stats_rand_gen_t - Generates a single random deviate from a t-distribution
    • stats_rand_get_seeds - Get the seed values of the random number generator
    • stats_rand_phrase_to_seeds - Generate two seeds for the RGN random number generator
    • stats_rand_ranf - Generates a random floating point number between 0 and 1
    • stats_rand_setall - Set seed values to the random generator
    • stats_skew - Computes the skewness of the data in the array
    • stats_standard_deviation - Returns the standard deviation
    • stats_stat_binomial_coef - Returns a binomial coefficient
    • stats_stat_correlation - Returns the Pearson correlation coefficient of two data sets
    • stats_stat_factorial - Returns the factorial of an integer
    • stats_stat_independent_t - Returns the t-value from the independent two-sample t-test
    • stats_stat_innerproduct - Returns the inner product of two vectors
    • stats_stat_paired_t - Returns the t-value of the dependent t-test for paired samples
    • stats_stat_percentile - Returns the percentile value
    • stats_stat_powersum - Returns the power sum of a vector
    • stats_variance - Returns the variance
    • Stomp::abort - Rolls back a transaction in progress
    • Stomp::ack - Acknowledges consumption of a message
    • Stomp::begin - Starts a transaction
    • Stomp::commit - Commits a transaction in progress
    • Stomp::error - Gets the last stomp error
    • Stomp::getReadTimeout - Gets read timeout
    • Stomp::getSessionId - Gets the current stomp session ID
    • Stomp::hasFrame - Indicates whether or not there is a frame ready to read
    • Stomp::readFrame - Reads the next frame
    • Stomp::send - Sends a message
    • Stomp::setReadTimeout - Sets read timeout
    • Stomp::subscribe - Registers to listen to a given destination
    • Stomp::unsubscribe - Removes an existing subscription
    • Stomp::__construct - 打开一个连接
    • Stomp::__destruct - Closes stomp connection
    • StompException::getDetails - Get exception details
    • StompFrame::__construct - Constructor
    • stomp_connect_error - Returns a string description of the last connect error
    • stomp_version - Gets the current stomp extension version
    • strcasecmp - 二进制安全比较字符串（不区分大小写）
    • strchr - 别名 strstr
    • strcmp - 二进制安全字符串比较
    • strcoll - 基于区域设置的字符串比较
    • strcspn - 获取不匹配遮罩的起始子字符串的长度
    • streamWrapper::dir_closedir - Close directory handle
    • streamWrapper::dir_opendir - Open directory handle
    • streamWrapper::dir_readdir - Read entry from directory handle
    • streamWrapper::dir_rewinddir - Rewind directory handle
    • streamWrapper::mkdir - Create a directory
    • streamWrapper::rename - Renames a file or directory
    • streamWrapper::rmdir - Removes a directory
    • streamWrapper::stream_cast - Retrieve the underlaying resource
    • streamWrapper::stream_close - Close a resource
    • streamWrapper::stream_eof - Tests for end-of-file on a file pointer
    • streamWrapper::stream_flush - Flushes the output
    • streamWrapper::stream_lock - Advisory file locking
    • streamWrapper::stream_metadata - Change stream metadata
    • streamWrapper::stream_open - Opens file or URL
    • streamWrapper::stream_read - Read from stream
    • streamWrapper::stream_seek - Seeks to specific location in a stream
    • streamWrapper::stream_set_option - Change stream options
    • streamWrapper::stream_stat - Retrieve information about a file resource
    • streamWrapper::stream_tell - Retrieve the current position of a stream
    • streamWrapper::stream_truncate - Truncate stream
    • streamWrapper::stream_write - Write to stream
    • streamWrapper::unlink - Delete a file
    • streamWrapper::url_stat - Retrieve information about a file
    • streamWrapper::__construct - Constructs a new stream wrapper
    • streamWrapper::__destruct - Destructs an existing stream wrapper
    • stream_bucket_append - Append bucket to brigade
    • stream_bucket_make_writeable - Return a bucket object from the brigade for operating on
    • stream_bucket_new - Create a new bucket for use on the current stream
    • stream_bucket_prepend - Prepend bucket to brigade
    • stream_context_create - 创建资源流上下文
    • stream_context_get_default - Retrieve the default stream context
    • stream_context_get_options - 获取资源流/数据包/上下文的参数
    • stream_context_get_params - Retrieves parameters from a context
    • stream_context_set_default - Set the default stream context
    • stream_context_set_option - 对资源流、数据包或者上下文设置参数
    • stream_context_set_params - Set parameters for a stream/wrapper/context
    • stream_copy_to_stream - Copies data from one stream to another
    • stream_filter_append - Attach a filter to a stream
    • stream_filter_prepend - Attach a filter to a stream
    • stream_filter_register - Register a user defined stream filter
    • stream_filter_remove - 从资源流里移除某个过滤器
    • stream_get_contents - 读取资源流到一个字符串
    • stream_get_filters - 获取已注册的数据流过滤器列表
    • stream_get_line - 从资源流里读取一行直到给定的定界符
    • stream_get_meta_data - 从封装协议文件指针中取得报头／元数据
    • stream_get_transports - 获取已注册的套接字传输协议列表
    • stream_get_wrappers - 获取已注册的流类型
    • stream_isatty - Check if a stream is a TTY
    • stream_is_local - Checks if a stream is a local stream
    • stream_notification_callback - A callback function for the notification context parameter
    • stream_register_wrapper - 别名 stream_wrapper_register
    • stream_resolve_include_path - Resolve filename against the include path
    • stream_select - Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
    • stream_set_blocking - 为资源流设置阻塞或者阻塞模式
    • stream_set_chunk_size - 设置资源流区块大小
    • stream_set_read_buffer - Set read file buffering on the given stream
    • stream_set_timeout - Set timeout period on a stream
    • stream_set_write_buffer - Sets write file buffering on the given stream
    • stream_socket_accept - 接受由 stream_socket_server 创建的套接字连接
    • stream_socket_client - Open Internet or Unix domain socket connection
    • stream_socket_enable_crypto - Turns encryption on/off on an already connected socket
    • stream_socket_get_name - 获取本地或者远程的套接字名称
    • stream_socket_pair - 创建一对完全一样的网络套接字连接流
    • stream_socket_recvfrom - Receives data from a socket, connected or not
    • stream_socket_sendto - Sends a message to a socket, whether it is connected or not
    • stream_socket_server - Create an Internet or Unix domain server socket
    • stream_socket_shutdown - Shutdown a full-duplex connection
    • stream_supports_lock - Tells whether the stream supports locking
    • stream_wrapper_register - 注册一个用 PHP 类实现的 URL 封装协议
    • stream_wrapper_restore - Restores a previously unregistered built-in wrapper
    • stream_wrapper_unregister - Unregister a URL wrapper
    • strftime - 根据区域设置格式化本地时间／日期
    • stripcslashes - 反引用一个使用 addcslashes 转义的字符串
    • stripos - 查找字符串首次出现的位置（不区分大小写）
    • stripslashes - 反引用一个引用字符串
    • strip_tags - 从字符串中去除 HTML 和 PHP 标记
    • stristr - strstr 函数的忽略大小写版本
    • strlen - 获取字符串长度
    • strnatcasecmp - 使用“自然顺序”算法比较字符串（不区分大小写）
    • strnatcmp - 使用自然排序算法比较字符串
    • strncasecmp - 二进制安全比较字符串开头的若干个字符（不区分大小写）
    • strncmp - 二进制安全比较字符串开头的若干个字符
    • strpbrk - 在字符串中查找一组字符的任何一个字符
    • strpos - 查找字符串首次出现的位置
    • strptime - 解析由 strftime 生成的日期／时间
    • strrchr - 查找指定字符在字符串中的最后一次出现
    • strrev - 反转字符串
    • strripos - 计算指定字符串在目标字符串中最后一次出现的位置（不区分大小写）
    • strrpos - 计算指定字符串在目标字符串中最后一次出现的位置
    • strspn - 计算字符串中全部字符都存在于指定字符集合中的第一段子串的长度。
    • strstr - 查找字符串的首次出现
    • strtok - 标记分割字符串
    • strtolower - 将字符串转化为小写
    • strtotime - 将任何字符串的日期时间描述解析为 Unix 时间戳
    • strtoupper - 将字符串转化为大写
    • strtr - 转换指定字符
    • strval - 获取变量的字符串值
    • str_contains - Determine if a string contains a given substring
    • str_ends_with - Checks if a string ends with a given substring
    • str_getcsv - 解析 CSV 字符串为一个数组
    • str_ireplace - str_replace 的忽略大小写版本
    • str_pad - 使用另一个字符串填充字符串为指定长度
    • str_repeat - 重复一个字符串
    • str_replace - 子字符串替换
    • str_rot13 - 对字符串执行 ROT13 转换
    • str_shuffle - 随机打乱一个字符串
    • str_split - 将字符串转换为数组
    • str_starts_with - Checks if a string starts with a given substring
    • str_word_count - 返回字符串中单词的使用情况
    • substr - 返回字符串的子串
    • substr_compare - 二进制安全比较字符串（从偏移位置比较指定长度）
    • substr_count - 计算字串出现的次数
    • substr_replace - 替换字符串的子串
    • SVM::crossvalidate - Test training params on subsets of the training data
    • SVM::getOptions - Return the current training parameters
    • SVM::setOptions - Set training parameters
    • SVM::train - Create a SVMModel based on training data
    • SVM::__construct - Construct a new SVM object
    • SVMModel::checkProbabilityModel - Returns true if the model has probability information
    • SVMModel::getLabels - Get the labels the model was trained on
    • SVMModel::getNrClass - Returns the number of classes the model was trained with
    • SVMModel::getSvmType - Get the SVM type the model was trained with
    • SVMModel::getSvrProbability - Get the sigma value for regression types
    • SVMModel::load - Load a saved SVM Model
    • SVMModel::predict - Predict a value for previously unseen data
    • SVMModel::predict_probability - Return class probabilities for previous unseen data
    • SVMModel::save - Save a model to a file
    • SVMModel::__construct - Construct a new SVMModel
    • svn_add - 计划在工作目录添加项
    • svn_auth_get_parameter - Retrieves authentication parameter
    • svn_auth_set_parameter - Sets an authentication parameter
    • svn_blame - Get the SVN blame for a file
    • svn_cat - Returns the contents of a file in a repository
    • svn_checkout - Checks out a working copy from the repository
    • svn_cleanup - Recursively cleanup a working copy directory, finishing incomplete operations and removing locks
    • svn_client_version - Returns the version of the SVN client libraries
    • svn_commit - 将修改的本地文件副本发送至版本库
    • svn_delete - Delete items from a working copy or repository
    • svn_diff - Recursively diffs two paths
    • svn_export - Export the contents of a SVN directory
    • svn_fs_abort_txn - Abort a transaction, returns true if everything is okay, false otherwise
    • svn_fs_apply_text - Creates and returns a stream that will be used to replace
    • svn_fs_begin_txn2 - Create a new transaction
    • svn_fs_change_node_prop - Return true if everything is ok, false otherwise
    • svn_fs_check_path - Determines what kind of item lives at path in a given repository fsroot
    • svn_fs_contents_changed - Return true if content is different, false otherwise
    • svn_fs_copy - Copies a file or a directory, returns true if all is ok, false otherwise
    • svn_fs_delete - Deletes a file or a directory, return true if all is ok, false otherwise
    • svn_fs_dir_entries - Enumerates the directory entries under path; returns a hash of dir names to file type
    • svn_fs_file_contents - Returns a stream to access the contents of a file from a given version of the fs
    • svn_fs_file_length - Returns the length of a file from a given version of the fs
    • svn_fs_is_dir - Return true if the path points to a directory, false otherwise
    • svn_fs_is_file - Return true if the path points to a file, false otherwise
    • svn_fs_make_dir - Creates a new empty directory, returns true if all is ok, false otherwise
    • svn_fs_make_file - Creates a new empty file, returns true if all is ok, false otherwise
    • svn_fs_node_created_rev - Returns the revision in which path under fsroot was created
    • svn_fs_node_prop - Returns the value of a property for a node
    • svn_fs_props_changed - Return true if props are different, false otherwise
    • svn_fs_revision_prop - Fetches the value of a named property
    • svn_fs_revision_root - Get a handle on a specific version of the repository root
    • svn_fs_txn_root - Creates and returns a transaction root
    • svn_fs_youngest_rev - Returns the number of the youngest revision in the filesystem
    • svn_import - Imports an unversioned path into a repository
    • svn_log - Returns the commit log messages of a repository URL
    • svn_ls - Returns list of directory contents in repository URL, optionally at revision number
    • svn_mkdir - Creates a directory in a working copy or repository
    • svn_repos_create - Create a new subversion repository at path
    • svn_repos_fs - Gets a handle on the filesystem for a repository
    • svn_repos_fs_begin_txn_for_commit - Create a new transaction
    • svn_repos_fs_commit_txn - Commits a transaction and returns the new revision
    • svn_repos_hotcopy - Make a hot-copy of the repos at repospath; copy it to destpath
    • svn_repos_open - Open a shared lock on a repository
    • svn_repos_recover - Run recovery procedures on the repository located at path
    • svn_revert - Revert changes to the working copy
    • svn_status - Returns the status of working copy files and directories
    • svn_update - Update working copy
    • Swoole\Async::dnsLookup - Async and non-blocking hostname to IP lookup.
    • Swoole\Async::read - Read file stream asynchronously.
    • Swoole\Async::readFile - Read a file asynchronously.
    • Swoole\Async::set - Update the async I/O options.
    • Swoole\Async::write - Write data to a file stream asynchronously.
    • Swoole\Async::writeFile - Description
    • Swoole\Atomic::add - Add a number to the value to the atomic object.
    • Swoole\Atomic::cmpset - Compare and set the value of the atomic object.
    • Swoole\Atomic::get - Get the current value of the atomic object.
    • Swoole\Atomic::set - Set a new value to the atomic object.
    • Swoole\Atomic::sub - Subtract a number to the value of the atomic object.
    • Swoole\Atomic::__construct - Construct a swoole atomic object.
    • Swoole\Buffer::append - Append the string or binary data at the end of the memory buffer and return the new size of memory allocated.
    • Swoole\Buffer::clear - Reset the memory buffer.
    • Swoole\Buffer::expand - Expand the size of memory buffer.
    • Swoole\Buffer::read - Read data from the memory buffer based on offset and length.
    • Swoole\Buffer::recycle - Release the memory to OS which is not used by the memory buffer.
    • Swoole\Buffer::substr - Read data from the memory buffer based on offset and length. Or remove data from the memory buffer.
    • Swoole\Buffer::write - Write data to the memory buffer. The memory allocated for the buffer will not be changed.
    • Swoole\Buffer::__construct - Fixed size memory blocks allocation.
    • Swoole\Buffer::__destruct - Destruct the Swoole memory buffer.
    • Swoole\Buffer::__toString - Get the string value of the memory buffer.
    • Swoole\Channel::pop - Read and pop data from swoole channel.
    • Swoole\Channel::push - Write and push data into Swoole channel.
    • Swoole\Channel::stats - Get stats of swoole channel.
    • Swoole\Channel::__construct - Construct a Swoole Channel
    • Swoole\Channel::__destruct - Destruct a Swoole channel.
    • Swoole\Client::close - Close the connection established.
    • Swoole\Client::connect - Connect to the remote TCP or UDP port.
    • Swoole\Client::getpeername - Get the remote socket name of the connection.
    • Swoole\Client::getsockname - Get the local socket name of the connection.
    • Swoole\Client::isConnected - Check if the connection is established.
    • Swoole\Client::on - Add callback functions triggered by events.
    • Swoole\Client::pause - Pause receiving data.
    • Swoole\Client::pipe - Redirect the data to another file descriptor.
    • Swoole\Client::recv - Receive data from the remote socket.
    • Swoole\Client::resume - Resume receiving data.
    • Swoole\Client::send - Send data to the remote TCP socket.
    • Swoole\Client::sendfile - Send file to the remote TCP socket.
    • Swoole\Client::sendto - Send data to the remote UDP address.
    • Swoole\Client::set - Set the Swoole client parameters before the connection is established.
    • Swoole\Client::sleep - Remove the TCP client from system event loop.
    • Swoole\Client::wakeup - Add the TCP client back into the system event loop.
    • Swoole\Client::__construct - Create Swoole sync or async TCP/UDP client, with or without SSL.
    • Swoole\Client::__destruct - Destruct the Swoole client.
    • Swoole\Connection\Iterator::count - Count connections.
    • Swoole\Connection\Iterator::current - Return current connection entry.
    • Swoole\Connection\Iterator::key - Return key of the current connection.
    • Swoole\Connection\Iterator::next - Move to the next connection.
    • Swoole\Connection\Iterator::offsetExists - Check if offet exists.
    • Swoole\Connection\Iterator::offsetGet - Offset to retrieve.
    • Swoole\Connection\Iterator::offsetSet - Assign a Connection to the specified offset.
    • Swoole\Connection\Iterator::offsetUnset - Unset an offset.
    • Swoole\Connection\Iterator::rewind - Rewinds iterator
    • Swoole\Connection\Iterator::valid - Check if current position is valid.
    • Swoole\Coroutine::call_user_func - Call a callback given by the first parameter
    • Swoole\Coroutine::call_user_func_array - Call a callback with an array of parameters
    • Swoole\Coroutine::cli_wait - Description
    • Swoole\Coroutine::create - Description
    • Swoole\Coroutine::getuid - Description
    • Swoole\Coroutine::resume - Description
    • Swoole\Coroutine::suspend - Description
    • Swoole\Coroutine\Client::close - Description
    • Swoole\Coroutine\Client::connect - Description
    • Swoole\Coroutine\Client::getpeername - Description
    • Swoole\Coroutine\Client::getsockname - Description
    • Swoole\Coroutine\Client::isConnected - Description
    • Swoole\Coroutine\Client::recv - Description
    • Swoole\Coroutine\Client::send - Description
    • Swoole\Coroutine\Client::sendfile - Description
    • Swoole\Coroutine\Client::sendto - Description
    • Swoole\Coroutine\Client::set - Description
    • Swoole\Coroutine\Client::__construct - Description
    • Swoole\Coroutine\Client::__destruct - Description
    • Swoole\Coroutine\Http\Client::addFile - Description
    • Swoole\Coroutine\Http\Client::close - Description
    • Swoole\Coroutine\Http\Client::execute - Description
    • Swoole\Coroutine\Http\Client::get - Description
    • Swoole\Coroutine\Http\Client::getDefer - Description
    • Swoole\Coroutine\Http\Client::isConnected - Description
    • Swoole\Coroutine\Http\Client::post - Description
    • Swoole\Coroutine\Http\Client::recv - Description
    • Swoole\Coroutine\Http\Client::set - Description
    • Swoole\Coroutine\Http\Client::setCookies - Description
    • Swoole\Coroutine\Http\Client::setData - Description
    • Swoole\Coroutine\Http\Client::setDefer - Description
    • Swoole\Coroutine\Http\Client::setHeaders - Description
    • Swoole\Coroutine\Http\Client::setMethod - Description
    • Swoole\Coroutine\Http\Client::__construct - Description
    • Swoole\Coroutine\Http\Client::__destruct - Description
    • Swoole\Coroutine\MySQL::close - Description
    • Swoole\Coroutine\MySQL::connect - Description
    • Swoole\Coroutine\MySQL::getDefer - Description
    • Swoole\Coroutine\MySQL::query - Description
    • Swoole\Coroutine\MySQL::recv - Description
    • Swoole\Coroutine\MySQL::setDefer - Description
    • Swoole\Coroutine\MySQL::__construct - Description
    • Swoole\Coroutine\MySQL::__destruct - Description
    • Swoole\Event::add - Add new callback functions of a socket into the EventLoop.
    • Swoole\Event::defer - Add a callback function to the next event loop.
    • Swoole\Event::del - Remove all event callback functions of a socket.
    • Swoole\Event::exit - Exit the eventloop, only available at client side.
    • Swoole\Event::set - Update the event callback functions of a socket.
    • Swoole\Event::wait - Description
    • Swoole\Event::write - Write data to the socket.
    • Swoole\Http\Client::addFile - Add a file to the post form.
    • Swoole\Http\Client::close - Close the http connection.
    • Swoole\Http\Client::download - Download a file from the remote server.
    • Swoole\Http\Client::execute - Send the HTTP request after setting the parameters.
    • Swoole\Http\Client::get - Send GET http request to the remote server.
    • Swoole\Http\Client::isConnected - Check if the HTTP connection is connected.
    • Swoole\Http\Client::on - Register callback function by event name.
    • Swoole\Http\Client::post - Send POST http request to the remote server.
    • Swoole\Http\Client::push - Push data to websocket client.
    • Swoole\Http\Client::set - Update the HTTP client paramters.
    • Swoole\Http\Client::setCookies - Set the http request cookies.
    • Swoole\Http\Client::setData - Set the HTTP request body data.
    • Swoole\Http\Client::setHeaders - Set the HTTP request headers.
    • Swoole\Http\Client::setMethod - Set the HTTP request method.
    • Swoole\Http\Client::upgrade - Upgrade to websocket protocol.
    • Swoole\Http\Client::__construct - Construct the async HTTP client.
    • Swoole\Http\Client::__destruct - Destruct the HTTP client.
    • Swoole\Http\Request::rawcontent - Get the raw HTTP POST body.
    • Swoole\Http\Request::__destruct - Destruct the HTTP request.
    • Swoole\Http\Response::cookie - Set the cookies of the HTTP response.
    • Swoole\Http\Response::end - Send data for the HTTP request and finish the response.
    • Swoole\Http\Response::gzip - Enable the gzip of response content.
    • Swoole\Http\Response::header - Set the HTTP response headers.
    • Swoole\Http\Response::initHeader - Init the HTTP response header.
    • Swoole\Http\Response::rawcookie - Set the raw cookies to the HTTP response.
    • Swoole\Http\Response::sendfile - Send file through the HTTP response.
    • Swoole\Http\Response::status - Set the status code of the HTTP response.
    • Swoole\Http\Response::write - Append HTTP body content to the HTTP response.
    • Swoole\Http\Response::__destruct - Destruct the HTTP response.
    • Swoole\Http\Server::on - Bind callback function to HTTP server by event name.
    • Swoole\Http\Server::start - Start the swoole http server.
    • Swoole\Lock::lock - Try to acquire the lock. It will block if the lock is not available.
    • Swoole\Lock::lock_read - Lock a read-write lock for reading.
    • Swoole\Lock::trylock - Try to acquire the lock and return straight away even the lock is not available.
    • Swoole\Lock::trylock_read - Try to lock a read-write lock for reading and return straight away even the lock is not available.
    • Swoole\Lock::unlock - Release the lock.
    • Swoole\Lock::__construct - Construct a memory lock.
    • Swoole\Lock::__destruct - Destory a Swoole memory lock.
    • Swoole\Mmap::open - Map a file into memory and return the stream resource which can be used by PHP stream operations.
    • Swoole\MySQL::close - Close the async MySQL connection.
    • Swoole\MySQL::connect - Connect to the remote MySQL server.
    • Swoole\MySQL::getBuffer - Description
    • Swoole\MySQL::on - Register callback function based on event name.
    • Swoole\MySQL::query - Run the SQL query.
    • Swoole\MySQL::__construct - Construct an async MySQL client.
    • Swoole\MySQL::__destruct - Destory the async MySQL client.
    • Swoole\Process::alarm - High precision timer which triggers signal with fixed interval.
    • Swoole\Process::close - Close the pipe to the child process.
    • Swoole\Process::daemon - Change the process to be a daemon process.
    • Swoole\Process::exec - Execute system commands.
    • Swoole\Process::exit - Stop the child processes.
    • Swoole\Process::freeQueue - Destroy the message queue created by swoole_process::useQueue.
    • Swoole\Process::kill - Send signal to the child process.
    • Swoole\Process::name - Set name of the process.
    • Swoole\Process::pop - Read and pop data from the message queue.
    • Swoole\Process::push - Write and push data into the message queue.
    • Swoole\Process::read - Read data sending to the process.
    • Swoole\Process::signal - Send signal to the child processes.
    • Swoole\Process::start - Start the process.
    • Swoole\Process::statQueue - Get the stats of the message queue used as the communication method between processes.
    • Swoole\Process::useQueue - Create a message queue as the communication method between the parent process and child processes.
    • Swoole\Process::wait - Wait for the events of child processes.
    • Swoole\Process::write - Write data into the pipe and communicate with the parent process or child processes.
    • Swoole\Process::__construct - Construct a process.
    • Swoole\Process::__destruct - Destory the process.
    • Swoole\Redis\Server::format - Description
    • Swoole\Redis\Server::setHandler - Description
    • Swoole\Redis\Server::start - Description
    • Swoole\Serialize::pack - Serialize the data.
    • Swoole\Serialize::unpack - Unserialize the data.
    • Swoole\Server::addlistener - Add a new listener to the server.
    • Swoole\Server::addProcess - Add a user defined swoole_process to the server.
    • Swoole\Server::after - Trigger a callback function after a period of time.
    • Swoole\Server::bind - Bind the connection to a user defined user ID.
    • Swoole\Server::clearTimer - Stop and destory a timer.
    • Swoole\Server::close - Close a connection to the client.
    • Swoole\Server::confirm - Check status of the connection.
    • Swoole\Server::connection_info - Get the connection info by file description.
    • Swoole\Server::connection_list - Get all of the established connections.
    • Swoole\Server::defer - Delay execution of the callback function at the end of current EventLoop.
    • Swoole\Server::exist - Check if the connection is existed.
    • Swoole\Server::finish - Used in task process for sending result to the worker process when the task is finished.
    • Swoole\Server::getClientInfo - Get the connection info by file description.
    • Swoole\Server::getClientList - Get all of the established connections.
    • Swoole\Server::getLastError - Get the error code of the most recent error.
    • Swoole\Server::heartbeat - Check all the connections on the server.
    • Swoole\Server::listen - Listen on the given IP and port, socket type.
    • Swoole\Server::on - Register a callback function by event name.
    • Swoole\Server::pause - Stop receiving data from the connection.
    • Swoole\Server::protect - Set the connection to be protected mode.
    • Swoole\Server::reload - Restart all the worker process.
    • Swoole\Server::resume - Start receving data from the connection.
    • Swoole\Server::send - Send data to the client.
    • Swoole\Server::sendfile - Send file to the connection.
    • Swoole\Server::sendMessage - Send message to worker processes by ID.
    • Swoole\Server::sendto - Send data to the remote UDP address.
    • Swoole\Server::sendwait - Send data to the remote socket in the blocking way.
    • Swoole\Server::set - Set the runtime settings of the swoole server.
    • Swoole\Server::shutdown - Shutdown the master server process, this function can be called in worker processes.
    • Swoole\Server::start - Start the Swoole server.
    • Swoole\Server::stats - Get the stats of the Swoole server.
    • Swoole\Server::stop - Stop the Swoole server.
    • Swoole\Server::task - Send data to the task worker processes.
    • Swoole\Server::taskwait - Send data to the task worker processes in blocking way.
    • Swoole\Server::taskWaitMulti - Execute multiple tasks concurrently.
    • Swoole\Server::tick - Repeats a given function at every given time-interval.
    • Swoole\Server::__construct - Construct a Swoole server.
    • Swoole\Server\Port::on - Register callback functions by event.
    • Swoole\Server\Port::set - Set protocol of the server port.
    • Swoole\Server\Port::__construct - Construct a server port
    • Swoole\Server\Port::__destruct - Destory server port
    • Swoole\Table::column - Set the data type and size of the columns.
    • Swoole\Table::count - Count the rows in the table, or count all the elements in the table if $mode = 1.
    • Swoole\Table::create - Create the swoole memory table.
    • Swoole\Table::current - Get the current row.
    • Swoole\Table::decr - Decrement the value in the Swoole table by $row_key and $column_key.
    • Swoole\Table::del - Delete a row in the Swoole table by $row_key.
    • Swoole\Table::destroy - Destroy the Swoole table.
    • Swoole\Table::exist - Check if a row is existed by $row_key.
    • Swoole\Table::get - Get the value in the Swoole table by $row_key and $column_key.
    • Swoole\Table::incr - Increment the value by $row_key and $column_key.
    • Swoole\Table::key - Get the key of current row.
    • Swoole\Table::next - Iterator the next row.
    • Swoole\Table::rewind - Rewind the iterator.
    • Swoole\Table::set - Update a row of the table by $row_key.
    • Swoole\Table::valid - Check current if the current row is valid.
    • Swoole\Table::__construct - Construct a Swoole memory table with fixed size.
    • Swoole\Timer::after - Trigger a callback function after a period of time.
    • Swoole\Timer::clear - Delete a timer by timer ID.
    • Swoole\Timer::exists - Check if a timer is existed.
    • Swoole\Timer::tick - Repeats a given function at every given time-interval.
    • Swoole\WebSocket\Server::exist - Check if the file descriptor exists.
    • Swoole\WebSocket\Server::on - Register event callback function
    • Swoole\WebSocket\Server::pack - Get a pack of binary data to send in a single frame.
    • Swoole\WebSocket\Server::push - Push data to the remote client.
    • Swoole\WebSocket\Server::unpack - Unpack the binary data received from the client.
    • swoole_async_dns_lookup - Async and non-blocking hostname to IP lookup
    • swoole_async_read - Read file stream asynchronously
    • swoole_async_readfile - Read a file asynchronously
    • swoole_async_set - Update the async I/O options
    • swoole_async_write - Write data to a file stream asynchronously
    • swoole_async_writefile - Write data to a file asynchronously
    • swoole_client_select - Get the file description which are ready to read/write or error
    • swoole_cpu_num - Get the number of CPU
    • swoole_errno - Get the error code of the latest system call
    • swoole_event_add - Add new callback functions of a socket into the EventLoop
    • swoole_event_defer - Add callback function to the next event loop
    • swoole_event_del - Remove all event callback functions of a socket
    • swoole_event_exit - Exit the eventloop, only available at the client side
    • swoole_event_set - Update the event callback functions of a socket
    • swoole_event_wait - Start the event loop
    • swoole_event_write - Write data to a socket
    • swoole_get_local_ip - Get the IPv4 IP addresses of each NIC on the machine
    • swoole_last_error - Get the lastest error message
    • swoole_load_module - Load a swoole extension
    • swoole_select - Select the file descriptions which are ready to read/write or error in the eventloop
    • swoole_set_process_name - Set the process name
    • swoole_strerror - Convert the Errno into error messages
    • swoole_timer_after - Trigger a one time callback function in the future
    • swoole_timer_exists - Check if a timer callback function is existed
    • swoole_timer_tick - Trigger a timer tick callback function by time interval
    • swoole_version - Get the version of Swoole
    • symlink - 建立符号连接
    • SyncEvent::fire - Fires/sets the event
    • SyncEvent::reset - Resets a manual event
    • SyncEvent::wait - Waits for the event to be fired/set
    • SyncEvent::__construct - Constructs a new SyncEvent object
    • SyncMutex::lock - Waits for an exclusive lock
    • SyncMutex::unlock - Unlocks the mutex
    • SyncMutex::__construct - Constructs a new SyncMutex object
    • SyncReaderWriter::readlock - Waits for a read lock
    • SyncReaderWriter::readunlock - Releases a read lock
    • SyncReaderWriter::writelock - Waits for an exclusive write lock
    • SyncReaderWriter::writeunlock - Releases a write lock
    • SyncReaderWriter::__construct - Constructs a new SyncReaderWriter object
    • SyncSemaphore::lock - Decreases the count of the semaphore or waits
    • SyncSemaphore::unlock - Increases the count of the semaphore
    • SyncSemaphore::__construct - Constructs a new SyncSemaphore object
    • SyncSharedMemory::first - Check to see if the object is the first instance system-wide of named shared memory
    • SyncSharedMemory::read - Copy data from named shared memory
    • SyncSharedMemory::size - Returns the size of the named shared memory
    • SyncSharedMemory::write - Copy data to named shared memory
    • SyncSharedMemory::__construct - Constructs a new SyncSharedMemory object
    • syslog - Generate a system log message
    • system - 执行外部程序，并且显示输出
    • sys_getloadavg - 获取系统的负载（load average）
    • sys_get_temp_dir - 返回用于临时文件的目录
  • t
    • Table::count - Get row count
    • Table::delete - Delete rows from table
    • Table::existsInDatabase - Check if table exists in database
    • Table::getName - Get table name
    • Table::getSchema - Get table schema
    • Table::getSession - Get table session
    • Table::insert - Insert table rows
    • Table::isView - Check if table is view
    • Table::select - Select rows from table
    • Table::update - Update rows in table
    • Table::__construct - Table constructor
    • TableDelete::bind - Bind delete query parameters
    • TableDelete::execute - Execute delete query
    • TableDelete::limit - Limit deleted rows
    • TableDelete::orderby - Set delete sort criteria
    • TableDelete::where - Set delete search condition
    • TableDelete::__construct - TableDelete constructor
    • TableInsert::execute - Execute insert query
    • TableInsert::values - Add insert row values
    • TableInsert::__construct - TableInsert constructor
    • TableSelect::bind - Bind select query parameters
    • TableSelect::execute - Execute select statement
    • TableSelect::groupBy - Set select grouping criteria
    • TableSelect::having - Set select having condition
    • TableSelect::limit - Limit selected rows
    • TableSelect::lockExclusive - Execute EXCLUSIVE LOCK
    • TableSelect::lockShared - Execute SHARED LOCK
    • TableSelect::offset - Set limit offset
    • TableSelect::orderby - Set select sort criteria
    • TableSelect::where - Set select search condition
    • TableSelect::__construct - TableSelect constructor
    • TableUpdate::bind - Bind update query parameters
    • TableUpdate::execute - Execute update query
    • TableUpdate::limit - Limit update row count
    • TableUpdate::orderby - Set sorting criteria
    • TableUpdate::set - Add field to be updated
    • TableUpdate::where - Set search filter
    • TableUpdate::__construct - TableUpdate constructor
    • taint - Taint a string
    • tan - 正切
    • tanh - 双曲正切
    • tcpwrap_check - Performs a tcpwrap check
    • tempnam - 建立一个具有唯一文件名的文件
    • textdomain - Sets the default domain
    • Thread::detach - 执行
    • Thread::getCreatorId - 识别
    • Thread::getCurrentThread - 识别
    • Thread::getCurrentThreadId - 识别
    • Thread::getThreadId - 识别
    • Thread::globally - 执行
    • Thread::isJoined - 状态监测
    • Thread::isStarted - 状态检测
    • Thread::join - 同步
    • Thread::kill - 执行
    • Thread::start - 执行
    • Threaded::chunk - 操作
    • Threaded::count - 操作
    • Threaded::extend - Runtime Manipulation
    • Threaded::from - Creation
    • Threaded::getTerminationInfo - 错误检测
    • Threaded::isRunning - 状态检测
    • Threaded::isTerminated - 状态检测
    • Threaded::isWaiting - 状态检测
    • Threaded::lock - 同步控制
    • Threaded::merge - 操作
    • Threaded::notify - 同步控制
    • Threaded::notifyOne - Synchronization
    • Threaded::pop - 操作
    • Threaded::run - 执行
    • Threaded::shift - Manipulation
    • Threaded::synchronized - 同步控制
    • Threaded::unlock - 同步控制
    • Threaded::wait - Synchronization
    • tidy::$errorBuffer - Return warnings and errors which occurred parsing the specified document
    • tidy::body - Returns a tidyNode object starting from the <body> tag of the tidy parse tree
    • tidy::cleanRepair - Execute configured cleanup and repair operations on parsed markup
    • tidy::diagnose - Run configured diagnostics on parsed and repaired markup
    • tidy::getConfig - Get current Tidy configuration
    • tidy::getHtmlVer - Get the Detected HTML version for the specified document
    • tidy::getOpt - Returns the value of the specified configuration option for the tidy document
    • tidy::getOptDoc - Returns the documentation for the given option name
    • tidy::getRelease - Get release date (version) for Tidy library
    • tidy::getStatus - Get status of specified document
    • tidy::head - Returns a tidyNode object starting from the <head> tag of the tidy parse tree
    • tidy::html - Returns a tidyNode object starting from the <html> tag of the tidy parse tree
    • tidy::isXhtml - Indicates if the document is a XHTML document
    • tidy::isXml - Indicates if the document is a generic (non HTML/XHTML) XML document
    • tidy::parseFile - Parse markup in file or URI
    • tidy::parseString - Parse a document stored in a string
    • tidy::repairFile - Repair a file and return it as a string
    • tidy::repairString - Repair a string using an optionally provided configuration file
    • tidy::root - Returns a tidyNode object representing the root of the tidy parse tree
    • tidy::__construct - Constructs a new tidy object
    • tidyNode::getParent - Returns the parent node of the current node
    • tidyNode::hasChildren - Checks if a node has children
    • tidyNode::hasSiblings - Checks if a node has siblings
    • tidyNode::isAsp - Checks if this node is ASP
    • tidyNode::isComment - Checks if a node represents a comment
    • tidyNode::isHtml - Checks if a node is an element node
    • tidyNode::isJste - Checks if this node is JSTE
    • tidyNode::isPhp - Checks if a node is PHP
    • tidyNode::isText - Checks if a node represents text (no markup)
    • tidyNode::__construct - Private constructor to disallow direct instantiation
    • tidy_access_count - Returns the Number of Tidy accessibility warnings encountered for specified document
    • tidy_config_count - Returns the Number of Tidy configuration errors encountered for specified document
    • tidy_error_count - Returns the Number of Tidy errors encountered for specified document
    • tidy_get_output - Return a string representing the parsed tidy markup
    • tidy_warning_count - Returns the Number of Tidy warnings encountered for specified document
    • time - 返回当前的 Unix 时间戳
    • timezone_abbreviations_list - 别名 DateTimeZone::listAbbreviations
    • timezone_identifiers_list - 别名 DateTimeZone::listIdentifiers
    • timezone_location_get - 别名 DateTimeZone::getLocation
    • timezone_name_from_abbr - Returns the timezone name from abbreviation
    • timezone_name_get - 别名 DateTimeZone::getName
    • timezone_offset_get - 别名 DateTimeZone::getOffset
    • timezone_open - 别名 DateTimeZone::__construct
    • timezone_transitions_get - 别名 DateTimeZone::getTransitions
    • timezone_version_get - 获取 timezonedb 的版本
    • time_nanosleep - 延缓执行若干秒和纳秒
    • time_sleep_until - 使脚本睡眠到指定的时间为止。
    • tmpfile - 建立一个临时文件
    • token_get_all - 将提供的源码按 PHP 标记进行分割
    • token_name - 获取提供的 PHP 解析器代号的符号名称
    • TokyoTyrant::add - Adds to a numeric key
    • TokyoTyrant::connect - Connect to a database
    • TokyoTyrant::connectUri - Connects to a database
    • TokyoTyrant::copy - Copies the database
    • TokyoTyrant::ext - Execute a remote script
    • TokyoTyrant::fwmKeys - Returns the forward matching keys
    • TokyoTyrant::get - The get purpose
    • TokyoTyrant::getIterator - Get an iterator
    • TokyoTyrant::num - Number of records in the database
    • TokyoTyrant::out - Removes records
    • TokyoTyrant::put - Puts values
    • TokyoTyrant::putCat - Concatenates to a record
    • TokyoTyrant::putKeep - Puts a record
    • TokyoTyrant::putNr - Puts value
    • TokyoTyrant::putShl - Concatenates to a record
    • TokyoTyrant::restore - Restore the database
    • TokyoTyrant::setMaster - Set the replication master
    • TokyoTyrant::size - Returns the size of the value
    • TokyoTyrant::stat - Get statistics
    • TokyoTyrant::sync - Synchronize the database
    • TokyoTyrant::tune - Tunes connection values
    • TokyoTyrant::vanish - Empties the database
    • TokyoTyrant::__construct - Construct a new TokyoTyrant object
    • TokyoTyrantIterator::current - Get the current value
    • TokyoTyrantIterator::key - Returns the current key
    • TokyoTyrantIterator::next - Move to next key
    • TokyoTyrantIterator::rewind - Rewinds the iterator
    • TokyoTyrantIterator::valid - Rewinds the iterator
    • TokyoTyrantIterator::__construct - Construct an iterator
    • TokyoTyrantQuery::addCond - Adds a condition to the query
    • TokyoTyrantQuery::count - Counts records
    • TokyoTyrantQuery::current - Returns the current element
    • TokyoTyrantQuery::hint - Get the hint string of the query
    • TokyoTyrantQuery::key - Returns the current key
    • TokyoTyrantQuery::metaSearch - Retrieve records with multiple queries
    • TokyoTyrantQuery::next - Moves the iterator to next entry
    • TokyoTyrantQuery::out - Removes records based on query
    • TokyoTyrantQuery::rewind - Rewinds the iterator
    • TokyoTyrantQuery::search - Searches records
    • TokyoTyrantQuery::setLimit - Limit results
    • TokyoTyrantQuery::setOrder - Orders results
    • TokyoTyrantQuery::valid - Checks the validity of current item
    • TokyoTyrantQuery::__construct - Construct a new query
    • TokyoTyrantTable::add - Adds a record
    • TokyoTyrantTable::genUid - Generate unique id
    • TokyoTyrantTable::get - Get a row
    • TokyoTyrantTable::getIterator - Get an iterator
    • TokyoTyrantTable::getQuery - Get a query object
    • TokyoTyrantTable::out - Remove records
    • TokyoTyrantTable::put - Store a row
    • TokyoTyrantTable::putCat - Concatenates to a row
    • TokyoTyrantTable::putKeep - Put a new record
    • TokyoTyrantTable::putNr - Puts value
    • TokyoTyrantTable::putShl - Concatenates to a record
    • TokyoTyrantTable::setIndex - Sets index
    • touch - 设定文件的访问和修改时间
    • trader_acos - Vector Trigonometric ACos
    • trader_ad - Chaikin A/D Line
    • trader_add - Vector Arithmetic Add
    • trader_adosc - Chaikin A/D Oscillator
    • trader_adx - Average Directional Movement Index
    • trader_adxr - Average Directional Movement Index Rating
    • trader_apo - Absolute Price Oscillator
    • trader_aroon - Aroon
    • trader_aroonosc - Aroon Oscillator
    • trader_asin - Vector Trigonometric ASin
    • trader_atan - Vector Trigonometric ATan
    • trader_atr - Average True Range
    • trader_avgprice - Average Price
    • trader_bbands - Bollinger Bands
    • trader_beta - Beta
    • trader_bop - Balance Of Power
    • trader_cci - Commodity Channel Index
    • trader_cdl2crows - Two Crows
    • trader_cdl3blackcrows - Three Black Crows
    • trader_cdl3inside - Three Inside Up/Down
    • trader_cdl3linestrike - Three-Line Strike
    • trader_cdl3outside - Three Outside Up/Down
    • trader_cdl3starsinsouth - Three Stars In The South
    • trader_cdl3whitesoldiers - Three Advancing White Soldiers
    • trader_cdlabandonedbaby - Abandoned Baby
    • trader_cdladvanceblock - Advance Block
    • trader_cdlbelthold - Belt-hold
    • trader_cdlbreakaway - Breakaway
    • trader_cdlclosingmarubozu - Closing Marubozu
    • trader_cdlconcealbabyswall - Concealing Baby Swallow
    • trader_cdlcounterattack - Counterattack
    • trader_cdldarkcloudcover - Dark Cloud Cover
    • trader_cdldoji - Doji
    • trader_cdldojistar - Doji Star
    • trader_cdldragonflydoji - Dragonfly Doji
    • trader_cdlengulfing - Engulfing Pattern
    • trader_cdleveningdojistar - Evening Doji Star
    • trader_cdleveningstar - Evening Star
    • trader_cdlgapsidesidewhite - Up/Down-gap side-by-side white lines
    • trader_cdlgravestonedoji - Gravestone Doji
    • trader_cdlhammer - Hammer
    • trader_cdlhangingman - Hanging Man
    • trader_cdlharami - Harami Pattern
    • trader_cdlharamicross - Harami Cross Pattern
    • trader_cdlhighwave - High-Wave Candle
    • trader_cdlhikkake - Hikkake Pattern
    • trader_cdlhikkakemod - Modified Hikkake Pattern
    • trader_cdlhomingpigeon - Homing Pigeon
    • trader_cdlidentical3crows - Identical Three Crows
    • trader_cdlinneck - In-Neck Pattern
    • trader_cdlinvertedhammer - Inverted Hammer
    • trader_cdlkicking - Kicking
    • trader_cdlkickingbylength - Kicking - bull/bear determined by the longer marubozu
    • trader_cdlladderbottom - Ladder Bottom
    • trader_cdllongleggeddoji - Long Legged Doji
    • trader_cdllongline - Long Line Candle
    • trader_cdlmarubozu - Marubozu
    • trader_cdlmatchinglow - Matching Low
    • trader_cdlmathold - Mat Hold
    • trader_cdlmorningdojistar - Morning Doji Star
    • trader_cdlmorningstar - Morning Star
    • trader_cdlonneck - On-Neck Pattern
    • trader_cdlpiercing - Piercing Pattern
    • trader_cdlrickshawman - Rickshaw Man
    • trader_cdlrisefall3methods - Rising/Falling Three Methods
    • trader_cdlseparatinglines - Separating Lines
    • trader_cdlshootingstar - Shooting Star
    • trader_cdlshortline - Short Line Candle
    • trader_cdlspinningtop - Spinning Top
    • trader_cdlstalledpattern - Stalled Pattern
    • trader_cdlsticksandwich - Stick Sandwich
    • trader_cdltakuri - Takuri (Dragonfly Doji with very long lower shadow)
    • trader_cdltasukigap - Tasuki Gap
    • trader_cdlthrusting - Thrusting Pattern
    • trader_cdltristar - Tristar Pattern
    • trader_cdlunique3river - Unique 3 River
    • trader_cdlupsidegap2crows - Upside Gap Two Crows
    • trader_cdlxsidegap3methods - Upside/Downside Gap Three Methods
    • trader_ceil - Vector Ceil
    • trader_cmo - Chande Momentum Oscillator
    • trader_correl - Pearson's Correlation Coefficient (r)
    • trader_cos - Vector Trigonometric Cos
    • trader_cosh - Vector Trigonometric Cosh
    • trader_dema - Double Exponential Moving Average
    • trader_div - Vector Arithmetic Div
    • trader_dx - Directional Movement Index
    • trader_ema - Exponential Moving Average
    • trader_errno - Get error code
    • trader_exp - Vector Arithmetic Exp
    • trader_floor - Vector Floor
    • trader_get_compat - Get compatibility mode
    • trader_get_unstable_period - Get unstable period
    • trader_ht_dcperiod - Hilbert Transform - Dominant Cycle Period
    • trader_ht_dcphase - Hilbert Transform - Dominant Cycle Phase
    • trader_ht_phasor - Hilbert Transform - Phasor Components
    • trader_ht_sine - Hilbert Transform - SineWave
    • trader_ht_trendline - Hilbert Transform - Instantaneous Trendline
    • trader_ht_trendmode - Hilbert Transform - Trend vs Cycle Mode
    • trader_kama - Kaufman Adaptive Moving Average
    • trader_linearreg - Linear Regression
    • trader_linearreg_angle - Linear Regression Angle
    • trader_linearreg_intercept - Linear Regression Intercept
    • trader_linearreg_slope - Linear Regression Slope
    • trader_ln - Vector Log Natural
    • trader_log10 - Vector Log10
    • trader_ma - Moving average
    • trader_macd - Moving Average Convergence/Divergence
    • trader_macdext - MACD with controllable MA type
    • trader_macdfix - Moving Average Convergence/Divergence Fix 12/26
    • trader_mama - MESA Adaptive Moving Average
    • trader_mavp - Moving average with variable period
    • trader_max - Highest value over a specified period
    • trader_maxindex - Index of highest value over a specified period
    • trader_medprice - Median Price
    • trader_mfi - Money Flow Index
    • trader_midpoint - MidPoint over period
    • trader_midprice - Midpoint Price over period
    • trader_min - Lowest value over a specified period
    • trader_minindex - Index of lowest value over a specified period
    • trader_minmax - Lowest and highest values over a specified period
    • trader_minmaxindex - Indexes of lowest and highest values over a specified period
    • trader_minus_di - Minus Directional Indicator
    • trader_minus_dm - Minus Directional Movement
    • trader_mom - Momentum
    • trader_mult - Vector Arithmetic Mult
    • trader_natr - Normalized Average True Range
    • trader_obv - On Balance Volume
    • trader_plus_di - Plus Directional Indicator
    • trader_plus_dm - Plus Directional Movement
    • trader_ppo - Percentage Price Oscillator
    • trader_roc - Rate of change : ((price/prevPrice)-1)*100
    • trader_rocp - Rate of change Percentage: (price-prevPrice)/prevPrice
    • trader_rocr - Rate of change ratio: (price/prevPrice)
    • trader_rocr100 - Rate of change ratio 100 scale: (price/prevPrice)*100
    • trader_rsi - Relative Strength Index
    • trader_sar - Parabolic SAR
    • trader_sarext - Parabolic SAR - Extended
    • trader_set_compat - Set compatibility mode
    • trader_set_unstable_period - Set unstable period
    • trader_sin - Vector Trigonometric Sin
    • trader_sinh - Vector Trigonometric Sinh
    • trader_sma - Simple Moving Average
    • trader_sqrt - Vector Square Root
    • trader_stddev - Standard Deviation
    • trader_stoch - Stochastic
    • trader_stochf - Stochastic Fast
    • trader_stochrsi - Stochastic Relative Strength Index
    • trader_sub - Vector Arithmetic Subtraction
    • trader_sum - Summation
    • trader_t3 - Triple Exponential Moving Average (T3)
    • trader_tan - Vector Trigonometric Tan
    • trader_tanh - Vector Trigonometric Tanh
    • trader_tema - Triple Exponential Moving Average
    • trader_trange - True Range
    • trader_trima - Triangular Moving Average
    • trader_trix - 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA
    • trader_tsf - Time Series Forecast
    • trader_typprice - Typical Price
    • trader_ultosc - Ultimate Oscillator
    • trader_var - Variance
    • trader_wclprice - Weighted Close Price
    • trader_willr - Williams' %R
    • trader_wma - Weighted Moving Average
    • trait_exists - 检查指定的 trait 是否存在
    • Transliterator::create - Create a transliterator
    • Transliterator::createFromRules - Create transliterator from rules
    • Transliterator::createInverse - Create an inverse transliterator
    • Transliterator::getErrorCode - Get last error code
    • Transliterator::getErrorMessage - Get last error message
    • Transliterator::listIDs - Get transliterator IDs
    • Transliterator::transliterate - Transliterate a string
    • Transliterator::__construct - Private constructor to deny instantiation
    • trigger_error - 产生一个用户级别的 error/warning/notice 信息
    • trim - 去除字符串首尾处的空白字符（或者其他字符）
  • u
    • uasort - 使用用户自定义的比较函数对数组中的值进行排序并保持索引关联
    • ucfirst - 将字符串的首字母转换为大写
    • UConverter::convert - Convert string from one charset to another
    • UConverter::fromUCallback - Default "from" callback function
    • UConverter::getAliases - Get the aliases of the given name
    • UConverter::getAvailable - Get the available canonical converter names
    • UConverter::getDestinationEncoding - Get the destination encoding
    • UConverter::getDestinationType - Get the destination converter type
    • UConverter::getErrorCode - Get last error code on the object
    • UConverter::getErrorMessage - Get last error message on the object
    • UConverter::getSourceEncoding - Get the source encoding
    • UConverter::getSourceType - Get the source converter type
    • UConverter::getStandards - Get standards associated to converter names
    • UConverter::getSubstChars - Get substitution chars
    • UConverter::reasonText - Get string representation of the callback reason
    • UConverter::setDestinationEncoding - Set the destination encoding
    • UConverter::setSourceEncoding - Set the source encoding
    • UConverter::setSubstChars - Set the substitution chars
    • UConverter::toUCallback - Default "to" callback function
    • UConverter::transcode - Convert string from one charset to another
    • UConverter::__construct - Create UConverter object
    • ucwords - 将字符串中每个单词的首字母转换为大写
    • UI\Area::onDraw - Draw Callback
    • UI\Area::onKey - Key Callback
    • UI\Area::onMouse - Mouse Callback
    • UI\Area::redraw - Redraw Area
    • UI\Area::scrollTo - Area Scroll
    • UI\Area::setSize - Set Size
    • UI\Control::destroy - Destroy Control
    • UI\Control::disable - Disable Control
    • UI\Control::enable - Enable Control
    • UI\Control::getParent - Get Parent Control
    • UI\Control::getTopLevel - Get Top Level
    • UI\Control::hide - Hide Control
    • UI\Control::isEnabled - Determine if Control is enabled
    • UI\Control::isVisible - Determine if Control is visible
    • UI\Control::setParent - Set Parent Control
    • UI\Control::show - Control Show
    • UI\Controls\Box::append - Append Control
    • UI\Controls\Box::delete - Delete Control
    • UI\Controls\Box::getOrientation - Get Orientation
    • UI\Controls\Box::isPadded - Padding Detection
    • UI\Controls\Box::setPadded - Set Padding
    • UI\Controls\Box::__construct - Construct a new Box
    • UI\Controls\Button::getText - Get Text
    • UI\Controls\Button::onClick - Click Handler
    • UI\Controls\Button::setText - Set Text
    • UI\Controls\Button::__construct - Construct a new Button
    • UI\Controls\Check::getText - Get Text
    • UI\Controls\Check::isChecked - Checked Detection
    • UI\Controls\Check::onToggle - Toggle Callback
    • UI\Controls\Check::setChecked - Set Checked
    • UI\Controls\Check::setText - Set Text
    • UI\Controls\Check::__construct - Construct a new Check
    • UI\Controls\ColorButton::getColor - Get Color
    • UI\Controls\ColorButton::onChange - Change Handler
    • UI\Controls\ColorButton::setColor - Set Color
    • UI\Controls\Combo::append - Append Option
    • UI\Controls\Combo::getSelected - Get Selected Option
    • UI\Controls\Combo::onSelected - Selected Handler
    • UI\Controls\Combo::setSelected - Set Selected Option
    • UI\Controls\EditableCombo::append - Append Option
    • UI\Controls\EditableCombo::getText - Get Text
    • UI\Controls\EditableCombo::onChange - Change Handler
    • UI\Controls\EditableCombo::setText - Set Text
    • UI\Controls\Entry::getText - Get Text
    • UI\Controls\Entry::isReadOnly - Detect Read Only
    • UI\Controls\Entry::onChange - Change Handler
    • UI\Controls\Entry::setReadOnly - Set Read Only
    • UI\Controls\Entry::setText - Set Text
    • UI\Controls\Entry::__construct - Construct a new Entry
    • UI\Controls\Form::append - Append Control
    • UI\Controls\Form::delete - Delete Control
    • UI\Controls\Form::isPadded - Padding Detection
    • UI\Controls\Form::setPadded - Set Padding
    • UI\Controls\Grid::append - Append Control
    • UI\Controls\Grid::isPadded - Padding Detection
    • UI\Controls\Grid::setPadded - Set Padding
    • UI\Controls\Group::append - Append Control
    • UI\Controls\Group::getTitle - Get Title
    • UI\Controls\Group::hasMargin - Margin Detection
    • UI\Controls\Group::setMargin - Set Margin
    • UI\Controls\Group::setTitle - Set Title
    • UI\Controls\Group::__construct - Construct a new Group
    • UI\Controls\Label::getText - Get Text
    • UI\Controls\Label::setText - Set Text
    • UI\Controls\Label::__construct - Construct a new Label
    • UI\Controls\MultilineEntry::append - Append Text
    • UI\Controls\MultilineEntry::getText - Get Text
    • UI\Controls\MultilineEntry::isReadOnly - Read Only Detection
    • UI\Controls\MultilineEntry::onChange - Change Handler
    • UI\Controls\MultilineEntry::setReadOnly - Set Read Only
    • UI\Controls\MultilineEntry::setText - Set Text
    • UI\Controls\MultilineEntry::__construct - Construct a new Multiline Entry
    • UI\Controls\Picker::__construct - Construct a new Picker
    • UI\Controls\Progress::getValue - Get Value
    • UI\Controls\Progress::setValue - Set Value
    • UI\Controls\Radio::append - Append Option
    • UI\Controls\Radio::getSelected - Get Selected Option
    • UI\Controls\Radio::onSelected - Selected Handler
    • UI\Controls\Radio::setSelected - Set Selected Option
    • UI\Controls\Separator::__construct - Construct a new Separator
    • UI\Controls\Slider::getValue - Get Value
    • UI\Controls\Slider::onChange - Change Handler
    • UI\Controls\Slider::setValue - Set Value
    • UI\Controls\Slider::__construct - Construct a new Slider
    • UI\Controls\Spin::getValue - Get Value
    • UI\Controls\Spin::onChange - Change Handler
    • UI\Controls\Spin::setValue - Set Value
    • UI\Controls\Spin::__construct - Construct a new Spin
    • UI\Controls\Tab::append - Append Page
    • UI\Controls\Tab::delete - Delete Page
    • UI\Controls\Tab::hasMargin - Margin Detection
    • UI\Controls\Tab::insertAt - Insert Page
    • UI\Controls\Tab::pages - Page Count
    • UI\Controls\Tab::setMargin - Set Margin
    • UI\Draw\Brush::getColor - Get Color
    • UI\Draw\Brush::setColor - Set Color
    • UI\Draw\Brush::__construct - Construct a new Brush
    • UI\Draw\Brush\Gradient::addStop - Stop Manipulation
    • UI\Draw\Brush\Gradient::delStop - Stop Manipulation
    • UI\Draw\Brush\Gradient::setStop - Stop Manipulation
    • UI\Draw\Brush\LinearGradient::__construct - Construct a Linear Gradient
    • UI\Draw\Brush\RadialGradient::__construct - Construct a new Radial Gradient
    • UI\Draw\Color::getChannel - Color Manipulation
    • UI\Draw\Color::setChannel - Color Manipulation
    • UI\Draw\Color::__construct - Construct new Color
    • UI\Draw\Matrix::invert - Invert Matrix
    • UI\Draw\Matrix::isInvertible - Invertible Detection
    • UI\Draw\Matrix::multiply - Multiply Matrix
    • UI\Draw\Matrix::rotate - Rotate Matrix
    • UI\Draw\Matrix::scale - Scale Matrix
    • UI\Draw\Matrix::skew - Skew Matrix
    • UI\Draw\Matrix::translate - Translate Matrix
    • UI\Draw\Path::addRectangle - Draw a Rectangle
    • UI\Draw\Path::arcTo - Draw an Arc
    • UI\Draw\Path::bezierTo - Draw Bezier Curve
    • UI\Draw\Path::closeFigure - Close Figure
    • UI\Draw\Path::end - Finalize Path
    • UI\Draw\Path::lineTo - Draw a Line
    • UI\Draw\Path::newFigure - Draw Figure
    • UI\Draw\Path::newFigureWithArc - Draw Figure with Arc
    • UI\Draw\Path::__construct - Construct a new Path
    • UI\Draw\Pen::clip - Clip a Path
    • UI\Draw\Pen::fill - Fill a Path
    • UI\Draw\Pen::restore - Restore
    • UI\Draw\Pen::save - Save
    • UI\Draw\Pen::stroke - Stroke a Path
    • UI\Draw\Pen::transform - Matrix Transform
    • UI\Draw\Pen::write - Draw Text at Point
    • UI\Draw\Stroke::getCap - Get Line Cap
    • UI\Draw\Stroke::getJoin - Get Line Join
    • UI\Draw\Stroke::getMiterLimit - Get Miter Limit
    • UI\Draw\Stroke::getThickness - Get Thickness
    • UI\Draw\Stroke::setCap - Set Line Cap
    • UI\Draw\Stroke::setJoin - Set Line Join
    • UI\Draw\Stroke::setMiterLimit - Set Miter Limit
    • UI\Draw\Stroke::setThickness - Set Thickness
    • UI\Draw\Stroke::__construct - Construct a new Stroke
    • UI\Draw\Text\Font::getAscent - Font Metrics
    • UI\Draw\Text\Font::getDescent - Font Metrics
    • UI\Draw\Text\Font::getLeading - Font Metrics
    • UI\Draw\Text\Font::getUnderlinePosition - Font Metrics
    • UI\Draw\Text\Font::getUnderlineThickness - Font Metrics
    • UI\Draw\Text\Font::__construct - Construct a new Font
    • UI\Draw\Text\Font\Descriptor::getFamily - Get Font Family
    • UI\Draw\Text\Font\Descriptor::getItalic - Style Detection
    • UI\Draw\Text\Font\Descriptor::getSize - Size Detection
    • UI\Draw\Text\Font\Descriptor::getStretch - Style Detection
    • UI\Draw\Text\Font\Descriptor::getWeight - Weight Detection
    • UI\Draw\Text\Font\Descriptor::__construct - Construct a new Font Descriptor
    • UI\Draw\Text\Font\fontFamilies - Retrieve Font Families
    • UI\Draw\Text\Layout::setColor - Set Color
    • UI\Draw\Text\Layout::setWidth - Set Width
    • UI\Draw\Text\Layout::__construct - Construct a new Text Layout
    • UI\Executor::kill - Stop Executor
    • UI\Executor::onExecute - Execution Callback
    • UI\Executor::setInterval - Interval Manipulation
    • UI\Executor::__construct - Construct a new Executor
    • UI\Menu::append - Append Menu Item
    • UI\Menu::appendAbout - Append About Menu Item
    • UI\Menu::appendCheck - Append Checkable Menu Item
    • UI\Menu::appendPreferences - Append Preferences Menu Item
    • UI\Menu::appendQuit - Append Quit Menu Item
    • UI\Menu::appendSeparator - Append Menu Item Separator
    • UI\Menu::__construct - Construct a new Menu
    • UI\MenuItem::disable - Disable Menu Item
    • UI\MenuItem::enable - Enable Menu Item
    • UI\MenuItem::isChecked - Detect Checked
    • UI\MenuItem::onClick - On Click Callback
    • UI\MenuItem::setChecked - Set Checked
    • UI\Point::at - Size Coercion
    • UI\Point::getX - Retrieves X
    • UI\Point::getY - Retrieves Y
    • UI\Point::setX - Set X
    • UI\Point::setY - Set Y
    • UI\Point::__construct - Construct a new Point
    • UI\quit - Quit UI Loop
    • UI\run - Enter UI Loop
    • UI\Size::getHeight - Retrieves Height
    • UI\Size::getWidth - Retrives Width
    • UI\Size::of - Point Coercion
    • UI\Size::setHeight - Set Height
    • UI\Size::setWidth - Set Width
    • UI\Size::__construct - Construct a new Size
    • UI\Window::add - Add a Control
    • UI\Window::error - Show Error Box
    • UI\Window::getSize - Get Window Size
    • UI\Window::getTitle - Get Title
    • UI\Window::hasBorders - Border Detection
    • UI\Window::hasMargin - Margin Detection
    • UI\Window::isFullScreen - Full Screen Detection
    • UI\Window::msg - Show Message Box
    • UI\Window::onClosing - Closing Callback
    • UI\Window::open - Open Dialog
    • UI\Window::save - Save Dialog
    • UI\Window::setBorders - Border Use
    • UI\Window::setFullScreen - Full Screen Use
    • UI\Window::setMargin - Margin Use
    • UI\Window::setSize - Set Size
    • UI\Window::setTitle - Window Title
    • UI\Window::__construct - Construct a new Window
    • uksort - 使用用户自定义的比较函数对数组中的键名进行排序
    • umask - 改变当前的 umask
    • uniqid - 生成一个唯一ID
    • unixtojd - 转变Unix时间戳为Julian Day计数
    • unlink - 删除文件
    • unpack - Unpack data from binary string
    • unregister_tick_function - De-register a function for execution on each tick
    • unserialize - 从已存储的表示中创建 PHP 的值
    • unset - 释放给定的变量
    • untaint - Untaint strings
    • uopz_add_function - Adds non-existent function or method
    • uopz_allow_exit - Allows control over disabled exit opcode
    • uopz_backup - Backup a function
    • uopz_compose - Compose a class
    • uopz_copy - Copy a function
    • uopz_delete - Delete a function
    • uopz_del_function - Deletes previously added function or method
    • uopz_extend - Extend a class at runtime
    • uopz_flags - Get or set flags on function or class
    • uopz_function - Creates a function at runtime
    • uopz_get_exit_status - Retrieve the last set exit status
    • uopz_get_hook - Gets previously set hook on function or method
    • uopz_get_mock - Get the current mock for a class
    • uopz_get_property - Gets value of class or instance property
    • uopz_get_return - Gets a previous set return value for a function
    • uopz_get_static - Gets the static variables from function or method scope
    • uopz_implement - Implements an interface at runtime
    • uopz_overload - Overload a VM opcode
    • uopz_redefine - Redefine a constant
    • uopz_rename - Rename a function at runtime
    • uopz_restore - Restore a previously backed up function
    • uopz_set_hook - Sets hook to execute when entering a function or method
    • uopz_set_mock - Use mock instead of class for new objects
    • uopz_set_property - Sets value of existing class or instance property
    • uopz_set_return - Provide a return value for an existing function
    • uopz_set_static - Sets the static variables in function or method scope
    • uopz_undefine - Undefine a constant
    • uopz_unset_hook - Removes previously set hook on function or method
    • uopz_unset_mock - Unset previously set mock
    • uopz_unset_return - Unsets a previously set return value for a function
    • urldecode - 解码已编码的 URL 字符串
    • urlencode - 编码 URL 字符串
    • user_error - trigger_error 的别名
    • use_soap_error_handler - Set whether to use the SOAP error handler
    • usleep - 以指定的微秒数延迟执行
    • usort - 使用用户自定义的比较函数对数组中的值进行排序
    • utf8_decode - 将用 UTF-8 方式编码的 ISO-8859-1 字符串转换成单字节的 ISO-8859-1 字符串。
    • utf8_encode - 将 ISO-8859-1 编码的字符串转换为 UTF-8 编码
  • v
    • V8Js::executeString - Execute a string as Javascript code
    • V8Js::getExtensions - Return an array of registered extensions
    • V8Js::getPendingException - Return pending uncaught Javascript exception
    • V8Js::registerExtension - Register Javascript extensions for V8Js
    • V8Js::__construct - Construct a new V8Js object
    • V8JsException::getJsFileName - The getJsFileName purpose
    • V8JsException::getJsLineNumber - The getJsLineNumber purpose
    • V8JsException::getJsSourceLine - The getJsSourceLine purpose
    • V8JsException::getJsTrace - The getJsTrace purpose
    • variant::__construct - variant class constructor
    • variant_abs - Returns the absolute value of a variant
    • variant_add - "Adds" two variant values together and returns the result
    • variant_and - Performs a bitwise AND operation between two variants
    • variant_cast - Convert a variant into a new variant object of another type
    • variant_cat - Concatenates two variant values together and returns the result
    • variant_cmp - Compares two variants
    • variant_date_from_timestamp - Returns a variant date representation of a Unix timestamp
    • variant_date_to_timestamp - Converts a variant date/time value to Unix timestamp
    • variant_div - Returns the result from dividing two variants
    • variant_eqv - Performs a bitwise equivalence on two variants
    • variant_fix - Returns the integer portion of a variant
    • variant_get_type - Returns the type of a variant object
    • variant_idiv - Converts variants to integers and then returns the result from dividing them
    • variant_imp - Performs a bitwise implication on two variants
    • variant_int - Returns the integer portion of a variant
    • variant_mod - Divides two variants and returns only the remainder
    • variant_mul - Multiplies the values of the two variants
    • variant_neg - Performs logical negation on a variant
    • variant_not - Performs bitwise not negation on a variant
    • variant_or - Performs a logical disjunction on two variants
    • variant_pow - Returns the result of performing the power function with two variants
    • variant_round - Rounds a variant to the specified number of decimal places
    • variant_set - Assigns a new value for a variant object
    • variant_set_type - Convert a variant into another type "in-place"
    • variant_sub - Subtracts the value of the right variant from the left variant value
    • variant_xor - Performs a logical exclusion on two variants
    • VarnishAdmin::auth - Authenticate on a varnish instance
    • VarnishAdmin::ban - Ban URLs using a VCL expression
    • VarnishAdmin::banUrl - Ban an URL using a VCL expression
    • VarnishAdmin::clearPanic - Clear varnish instance panic messages
    • VarnishAdmin::connect - Connect to a varnish instance administration interface
    • VarnishAdmin::disconnect - Disconnect from a varnish instance administration interface
    • VarnishAdmin::getPanic - Get the last panic message on a varnish instance
    • VarnishAdmin::getParams - Fetch current varnish instance configuration parameters
    • VarnishAdmin::isRunning - Check if the varnish slave process is currently running
    • VarnishAdmin::setCompat - Set the class compat configuration param
    • VarnishAdmin::setHost - Set the class host configuration param
    • VarnishAdmin::setIdent - Set the class ident configuration param
    • VarnishAdmin::setParam - Set configuration param on the current varnish instance
    • VarnishAdmin::setPort - Set the class port configuration param
    • VarnishAdmin::setSecret - Set the class secret configuration param
    • VarnishAdmin::setTimeout - Set the class timeout configuration param
    • VarnishAdmin::start - Start varnish worker process
    • VarnishAdmin::stop - Stop varnish worker process
    • VarnishAdmin::__construct - VarnishAdmin constructor
    • VarnishLog::getLine - Get next log line
    • VarnishLog::getTagName - Get the log tag string representation by its index
    • VarnishLog::__construct - Varnishlog constructor
    • VarnishStat::getSnapshot - Get the current varnish instance statistics snapshot
    • VarnishStat::__construct - VarnishStat constructor
    • var_dump - 打印变量的相关信息
    • var_export - 输出或返回一个变量的字符串表示
    • version_compare - 对比两个「PHP 规范化」的版本数字字符串
    • vfprintf - 将格式化字符串写入流
    • virtual - 执行 Apache 子请求
    • vprintf - 输出格式化字符串
    • vsprintf - 返回格式化字符串
    • Vtiful\Kernel\Excel::addSheet - Vtiful\Kernel\Excel addSheet
    • Vtiful\Kernel\Excel::autoFilter - Vtiful\Kernel\Excel autoFilter
    • Vtiful\Kernel\Excel::constMemory - Vtiful\Kernel\Excel constMemory
    • Vtiful\Kernel\Excel::data - Vtiful\Kernel\Excel data
    • Vtiful\Kernel\Excel::fileName - Vtiful\Kernel\Excel fileName
    • Vtiful\Kernel\Excel::getHandle - Vtiful\Kernel\Excel getHandle
    • Vtiful\Kernel\Excel::header - Vtiful\Kernel\Excel header
    • Vtiful\Kernel\Excel::insertFormula - Vtiful\Kernel\Excel insertFormula
    • Vtiful\Kernel\Excel::insertImage - Vtiful\Kernel\Excel insertImage
    • Vtiful\Kernel\Excel::insertText - Vtiful\Kernel\Excel insertText
    • Vtiful\Kernel\Excel::mergeCells - Vtiful\Kernel\Excel mergeCells
    • Vtiful\Kernel\Excel::output - Vtiful\Kernel\Excel output
    • Vtiful\Kernel\Excel::setColumn - Vtiful\Kernel\Excel setColumn
    • Vtiful\Kernel\Excel::setRow - Vtiful\Kernel\Excel setRow
    • Vtiful\Kernel\Excel::__construct - Vtiful\Kernel\Excel constructor
    • Vtiful\Kernel\Format::align - Vtiful\Kernel\Format align
    • Vtiful\Kernel\Format::bold - Vtiful\Kernel\Format bold
    • Vtiful\Kernel\Format::italic - Vtiful\Kernel\Format italic
    • Vtiful\Kernel\Format::underline - Vtiful\Kernel\Format underline
  • w
    • Warning::__construct - Warning constructor
    • wddx_add_vars - Add variables to a WDDX packet with the specified ID
    • wddx_deserialize - Unserializes a WDDX packet
    • wddx_packet_end - Ends a WDDX packet with the specified ID
    • wddx_packet_start - Starts a new WDDX packet with structure inside it
    • wddx_serialize_value - Serialize a single value into a WDDX packet
    • wddx_serialize_vars - Serialize variables into a WDDX packet
    • WeakMap::count - Counts the number of live entries in the map
    • WeakMap::current - Returns the current value under iteration
    • WeakMap::key - Returns the current key under iteration
    • WeakMap::next - Advances to the next map element
    • WeakMap::offsetExists - Checks whether a certain object is in the map
    • WeakMap::offsetGet - Returns the value pointed to by a certain object
    • WeakMap::offsetSet - Updates the map with a new key-value pair
    • WeakMap::offsetUnset - Removes an entry from the map
    • WeakMap::rewind - Rewinds the iterator to the beginning of the map
    • WeakMap::valid - Returns whether the iterator is still on a valid map element
    • WeakMap::__construct - Constructs a new map
    • Weakref::acquire - Acquires a strong reference on that object
    • Weakref::get - Returns the object pointed to by the weak reference
    • Weakref::release - Releases a previously acquired reference
    • Weakref::valid - Checks whether the object referenced still exists
    • Weakref::__construct - Constructs a new weak reference
    • win32_continue_service - Resumes a paused service
    • win32_create_service - Creates a new service entry in the SCM database
    • win32_delete_service - Deletes a service entry from the SCM database
    • win32_get_last_control_message - Returns the last control message that was sent to this service
    • win32_pause_service - Pauses a service
    • win32_query_service_status - Queries the status of a service
    • win32_send_custom_control - Send a custom control to the service
    • win32_set_service_exit_code - Define or return the exit code for the current running service
    • win32_set_service_exit_mode - Define or return the exit mode for the current running service
    • win32_set_service_status - Update the service status
    • win32_start_service - Starts a service
    • win32_start_service_ctrl_dispatcher - Registers the script with the SCM, so that it can act as the service with the given name
    • win32_stop_service - Stops a service
    • wincache_fcache_fileinfo - Retrieves information about files cached in the file cache
    • wincache_fcache_meminfo - Retrieves information about file cache memory usage
    • wincache_lock - Acquires an exclusive lock on a given key
    • wincache_ocache_fileinfo - Retrieves information about files cached in the opcode cache
    • wincache_ocache_meminfo - Retrieves information about opcode cache memory usage
    • wincache_refresh_if_changed - Refreshes the cache entries for the cached files
    • wincache_rplist_fileinfo - Retrieves information about resolve file path cache
    • wincache_rplist_meminfo - Retrieves information about memory usage by the resolve file path cache
    • wincache_scache_info - Retrieves information about files cached in the session cache
    • wincache_scache_meminfo - Retrieves information about session cache memory usage
    • wincache_ucache_add - Adds a variable in user cache only if variable does not already exist in the cache
    • wincache_ucache_cas - Compares the variable with old value and assigns new value to it
    • wincache_ucache_clear - Deletes entire content of the user cache
    • wincache_ucache_dec - Decrements the value associated with the key
    • wincache_ucache_delete - Deletes variables from the user cache
    • wincache_ucache_exists - Checks if a variable exists in the user cache
    • wincache_ucache_get - Gets a variable stored in the user cache
    • wincache_ucache_inc - Increments the value associated with the key
    • wincache_ucache_info - Retrieves information about data stored in the user cache
    • wincache_ucache_meminfo - Retrieves information about user cache memory usage
    • wincache_ucache_set - Adds a variable in user cache and overwrites a variable if it already exists in the cache
    • wincache_unlock - Releases an exclusive lock on a given key
    • wkhtmltox\Image\Converter::convert - Perform Image conversion
    • wkhtmltox\Image\Converter::getVersion - Determine version of Converter
    • wkhtmltox\Image\Converter::__construct - Create a new Image converter
    • wkhtmltox\PDF\Converter::add - Add an object for conversion
    • wkhtmltox\PDF\Converter::convert - Perform PDF conversion
    • wkhtmltox\PDF\Converter::getVersion - Determine version of Converter
    • wkhtmltox\PDF\Converter::__construct - Create a new PDF converter
    • wkhtmltox\PDF\Object::__construct - Create a new PDF Object
    • wordwrap - 打断字符串为指定数量的字串
    • Worker::collect - Collect references to completed tasks
    • Worker::getStacked - 获取剩余的栈大小
    • Worker::isShutdown - 状态检测
    • Worker::isWorking - 状态检测
    • Worker::shutdown - 关闭 Worker
    • Worker::stack - 将要执行的任务入栈
    • Worker::unstack - 将要执行的任务出栈
  • x
    • xattr_get - Get an extended attribute
    • xattr_list - Get a list of extended attributes
    • xattr_remove - Remove an extended attribute
    • xattr_set - Set an extended attribute
    • xattr_supported - Check if filesystem supports extended attributes
    • xdiff_file_bdiff - Make binary diff of two files
    • xdiff_file_bdiff_size - Read a size of file created by applying a binary diff
    • xdiff_file_bpatch - Patch a file with a binary diff
    • xdiff_file_diff - Make unified diff of two files
    • xdiff_file_diff_binary - Alias of xdiff_file_bdiff
    • xdiff_file_merge3 - Merge 3 files into one
    • xdiff_file_patch - Patch a file with an unified diff
    • xdiff_file_patch_binary - Alias of xdiff_file_bpatch
    • xdiff_file_rabdiff - Make binary diff of two files using the Rabin's polynomial fingerprinting algorithm
    • xdiff_string_bdiff - Make binary diff of two strings
    • xdiff_string_bdiff_size - Read a size of file created by applying a binary diff
    • xdiff_string_bpatch - Patch a string with a binary diff
    • xdiff_string_diff - Make unified diff of two strings
    • xdiff_string_diff_binary - Alias of xdiff_string_bdiff
    • xdiff_string_merge3 - Merge 3 strings into one
    • xdiff_string_patch - Patch a string with an unified diff
    • xdiff_string_patch_binary - Alias of xdiff_string_bpatch
    • xdiff_string_rabdiff - Make binary diff of two strings using the Rabin's polynomial fingerprinting algorithm
    • xhprof_disable - 停止 xhprof 分析器
    • xhprof_enable - 启动 xhprof 性能分析器
    • xhprof_sample_disable - 停止 xhprof 性能采样分析器
    • xhprof_sample_enable - 以采样模式启动 XHProf 性能分析
    • XMLDiff\Base::diff - Produce diff of two XML documents
    • XMLDiff\Base::merge - Produce new XML document based on diff
    • XMLDiff\Base::__construct - Constructor
    • XMLDiff\DOM::diff - Diff two DOMDocument objects
    • XMLDiff\DOM::merge - Produce merged DOMDocument
    • XMLDiff\File::diff - Diff two XML files
    • XMLDiff\File::merge - Produce merged XML document
    • XMLDiff\Memory::diff - Diff two XML documents
    • XMLDiff\Memory::merge - Produce merged XML document
    • XMLReader::close - Close the XMLReader input
    • XMLReader::expand - Returns a copy of the current node as a DOM object
    • XMLReader::getAttribute - Get the value of a named attribute
    • XMLReader::getAttributeNo - Get the value of an attribute by index
    • XMLReader::getAttributeNs - Get the value of an attribute by localname and URI
    • XMLReader::getParserProperty - Indicates if specified property has been set
    • XMLReader::isValid - Indicates if the parsed document is valid
    • XMLReader::lookupNamespace - Lookup namespace for a prefix
    • XMLReader::moveToAttribute - Move cursor to a named attribute
    • XMLReader::moveToAttributeNo - Move cursor to an attribute by index
    • XMLReader::moveToAttributeNs - Move cursor to a named attribute
    • XMLReader::moveToElement - Position cursor on the parent Element of current Attribute
    • XMLReader::moveToFirstAttribute - Position cursor on the first Attribute
    • XMLReader::moveToNextAttribute - Position cursor on the next Attribute
    • XMLReader::next - Move cursor to next node skipping all subtrees
    • XMLReader::open - Set the URI containing the XML to parse
    • XMLReader::read - Move to next node in document
    • XMLReader::readInnerXml - Retrieve XML from current node
    • XMLReader::readOuterXml - Retrieve XML from current node, including itself
    • XMLReader::readString - Reads the contents of the current node as a string
    • XMLReader::setParserProperty - Set parser options
    • XMLReader::setRelaxNGSchema - Set the filename or URI for a RelaxNG Schema
    • XMLReader::setRelaxNGSchemaSource - Set the data containing a RelaxNG Schema
    • XMLReader::setSchema - Validate document against XSD
    • XMLReader::XML - Set the data containing the XML to parse
    • xmlrpc_decode - 将 XML 译码为 PHP 本身的类型
    • xmlrpc_decode_request - 将 XML 译码为 PHP 本身的类型
    • xmlrpc_encode - 为 PHP 的值生成 XML
    • xmlrpc_encode_request - 为 PHP 的值生成 XML
    • xmlrpc_get_type - 为 PHP 的值获取 xmlrpc 的类型
    • xmlrpc_is_fault - Determines if an array value represents an XMLRPC fault
    • xmlrpc_parse_method_descriptions - 将 XML 译码成方法描述的列表
    • xmlrpc_server_add_introspection_data - 添加自我描述的文档
    • xmlrpc_server_call_method - 解析 XML 请求同时调用方法
    • xmlrpc_server_create - 创建一个 xmlrpc 服务端
    • xmlrpc_server_destroy - 销毁服务端资源
    • xmlrpc_server_register_introspection_callback - 注册一个 PHP 函数用于生成文档
    • xmlrpc_server_register_method - 注册一个 PHP 函数用于匹配 xmlrpc 方法名
    • xmlrpc_set_type - 为一个 PHP 字符串值设置 xmlrpc 的类型、base64 或日期时间
    • XMLWriter::endAttribute - End attribute
    • XMLWriter::endCdata - End current CDATA
    • XMLWriter::endComment - Create end comment
    • XMLWriter::endDocument - End current document
    • XMLWriter::endDtd - End current DTD
    • XMLWriter::endDtdAttlist - End current DTD AttList
    • XMLWriter::endDtdElement - End current DTD element
    • XMLWriter::endDtdEntity - End current DTD Entity
    • XMLWriter::endElement - End current element
    • XMLWriter::endPi - End current PI
    • XMLWriter::flush - Flush current buffer
    • XMLWriter::fullEndElement - End current element
    • XMLWriter::openMemory - Create new xmlwriter using memory for string output
    • XMLWriter::openUri - Create new xmlwriter using source uri for output
    • XMLWriter::outputMemory - Returns current buffer
    • XMLWriter::setIndent - Toggle indentation on/off
    • XMLWriter::setIndentString - Set string used for indenting
    • XMLWriter::startAttribute - Create start attribute
    • XMLWriter::startAttributeNs - Create start namespaced attribute
    • XMLWriter::startCdata - Create start CDATA tag
    • XMLWriter::startComment - Create start comment
    • XMLWriter::startDocument - Create document tag
    • XMLWriter::startDtd - Create start DTD tag
    • XMLWriter::startDtdAttlist - Create start DTD AttList
    • XMLWriter::startDtdElement - Create start DTD element
    • XMLWriter::startDtdEntity - Create start DTD Entity
    • XMLWriter::startElement - Create start element tag
    • XMLWriter::startElementNs - Create start namespaced element tag
    • XMLWriter::startPi - Create start PI tag
    • XMLWriter::text - Write text
    • XMLWriter::writeAttribute - Write full attribute
    • XMLWriter::writeAttributeNs - Write full namespaced attribute
    • XMLWriter::writeCdata - Write full CDATA tag
    • XMLWriter::writeComment - Write full comment tag
    • XMLWriter::writeDtd - Write full DTD tag
    • XMLWriter::writeDtdAttlist - Write full DTD AttList tag
    • XMLWriter::writeDtdElement - Write full DTD element tag
    • XMLWriter::writeDtdEntity - Write full DTD Entity tag
    • XMLWriter::writeElement - Write full element tag
    • XMLWriter::writeElementNs - Write full namespaced element tag
    • XMLWriter::writePi - Writes a PI
    • XMLWriter::writeRaw - Write a raw XML text
    • xml_error_string - 获取 XML 解析器的错误字符串
    • xml_get_current_byte_index - 获取 XML 解析器的当前字节索引
    • xml_get_current_column_number - 获取 XML 解析器的当前列号
    • xml_get_current_line_number - 获取 XML 解析器的当前行号
    • xml_get_error_code - 获取 XML 解析器错误代码
    • xml_parse - 开始解析一个 XML 文档
    • xml_parser_create - 建立一个 XML 解析器
    • xml_parser_create_ns - 生成一个支持命名空间的 XML 解析器
    • xml_parser_free - 释放指定的 XML 解析器
    • xml_parser_get_option - 从 XML 解析器获取选项设置信息
    • xml_parser_set_option - 为指定 XML 解析进行选项设置
    • xml_parse_into_struct - 将 XML 数据解析到数组中
    • xml_set_character_data_handler - 建立字符数据处理器
    • xml_set_default_handler - 建立默认处理器
    • xml_set_element_handler - 建立起始和终止元素处理器
    • xml_set_end_namespace_decl_handler - 建立终止命名空间声明处理器
    • xml_set_external_entity_ref_handler - 建立外部实体指向处理器
    • xml_set_notation_decl_handler - 建立注释声明处理器
    • xml_set_object - 在对象中使用 XML 解析器
    • xml_set_processing_instruction_handler - 建立处理指令（PI）处理器
    • xml_set_start_namespace_decl_handler - 建立起始命名空间声明处理器
    • xml_set_unparsed_entity_decl_handler - 建立未解析实体定义声明处理器
    • XSLTProcessor::getParameter - Get value of a parameter
    • XSLTProcessor::getSecurityPrefs - Get security preferences
    • XSLTProcessor::hasExsltSupport - Determine if PHP has EXSLT support
    • XSLTProcessor::importStylesheet - Import stylesheet
    • XSLTProcessor::registerPHPFunctions - Enables the ability to use PHP functions as XSLT functions
    • XSLTProcessor::removeParameter - Remove parameter
    • XSLTProcessor::setParameter - Set value for a parameter
    • XSLTProcessor::setProfiling - Sets profiling output file
    • XSLTProcessor::setSecurityPrefs - Set security preferences
    • XSLTProcessor::transformToDoc - Transform to a DOMDocument
    • XSLTProcessor::transformToUri - Transform to URI
    • XSLTProcessor::transformToXml - Transform to XML
    • XSLTProcessor::__construct - Creates a new XSLTProcessor object
  • y
    • Yac::add - Store into cache
    • Yac::delete - Remove items from cache
    • Yac::dump - Dump cache
    • Yac::flush - Flush the cache
    • Yac::get - Retrieve values from cache
    • Yac::info - Status of cache
    • Yac::set - Store into cache
    • Yac::__construct - Constructor
    • Yac::__get - Getter
    • Yac::__set - Setter
    • Yaconf::get - Retrieve a item
    • Yaconf::has - Determine if a item exists
    • Yaf_Action_Abstract::execute - 执行动作
    • Yaf_Action_Abstract::getController - 得到控制器实例
    • Yaf_Action_Abstract::getControllerName - Get controller name
    • Yaf_Application::app - 获取当前的Yaf_Application实例
    • Yaf_Application::bootstrap - 调用bootstrap
    • Yaf_Application::clearLastError - 清除最后的错误信息
    • Yaf_Application::environ - 获取当前Yaf_Application的环境名
    • Yaf_Application::execute - 运行回调函数
    • Yaf_Application::getAppDirectory - 获取应用的目录
    • Yaf_Application::getConfig - 获取 Yaf_Config_Abstract 的实例
    • Yaf_Application::getDispatcher - 获取 Yaf_Dispatcher 的实例
    • Yaf_Application::getLastErrorMsg - 获取最近产生的错误的错误信息
    • Yaf_Application::getLastErrorNo - 获取最后产生的错误的错误代码
    • Yaf_Application::getModules - 获取在配置文件中申明的模块
    • Yaf_Application::run - 运行 Yaf_Application
    • Yaf_Application::setAppDirectory - 改变应用目录
    • Yaf_Application::__construct - Yaf_Application的构造函数
    • Yaf_Application::__destruct - 析构函数
    • Yaf_Config_Abstract::get - Getter
    • Yaf_Config_Abstract::readonly - 寻找只读配置
    • Yaf_Config_Abstract::set - Setter
    • Yaf_Config_Abstract::toArray - 转换为数组
    • Yaf_Config_Ini::count - 返回配置的节数量
    • Yaf_Config_Ini::current - 返回当前节点
    • Yaf_Config_Ini::key - 返回当前元素的键
    • Yaf_Config_Ini::next - 向前移动到下一个元素
    • Yaf_Config_Ini::offsetExists - 检查一个偏移位置是否存在
    • Yaf_Config_Ini::offsetGet - 获取一个偏移位置的值
    • Yaf_Config_Ini::offsetSet - 设置一个偏移位置的值
    • Yaf_Config_Ini::offsetUnset - 复位一个偏移位置的值
    • Yaf_Config_Ini::readonly - 检查配置是否只读
    • Yaf_Config_Ini::rewind - 检查当前位置是否有效
    • Yaf_Config_Ini::toArray - 转换为数组的格式
    • Yaf_Config_Ini::valid - 检查迭代器是否有效
    • Yaf_Config_Ini::__construct - 构造函数
    • Yaf_Config_Ini::__get - 读取节点配置
    • Yaf_Config_Ini::__isset - 检查节点是否存在
    • Yaf_Config_Ini::__set - The __set purpose
    • Yaf_Config_Simple::count - 返回配置的节数量
    • Yaf_Config_Simple::current - 返回当前节点
    • Yaf_Config_Simple::key - 返回当前元素的键
    • Yaf_Config_Simple::next - 向前移动到下一个元素
    • Yaf_Config_Simple::offsetExists - 检查一个偏移位置是否存在
    • Yaf_Config_Simple::offsetGet - 获取一个偏移位置的值
    • Yaf_Config_Simple::offsetSet - 设置一个偏移位置的值
    • Yaf_Config_Simple::offsetUnset - 复位一个偏移位置的值
    • Yaf_Config_Simple::readonly - 检查配置是否只读
    • Yaf_Config_Simple::rewind - 检查当前位置是否有效
    • Yaf_Config_Simple::toArray - 转换为数组的格式
    • Yaf_Config_Simple::valid - 检查迭代器是否有效
    • Yaf_Config_Simple::__construct - 构造函数
    • Yaf_Config_Simple::__get - 读取节点配置
    • Yaf_Config_Simple::__isset - 检查节点是否存在
    • Yaf_Config_Simple::__set - 设置节点配置
    • Yaf_Controller_Abstract::display - The display purpose
    • Yaf_Controller_Abstract::forward - The forward purpose
    • Yaf_Controller_Abstract::getInvokeArg - The getInvokeArg purpose
    • Yaf_Controller_Abstract::getInvokeArgs - The getInvokeArgs purpose
    • Yaf_Controller_Abstract::getModuleName - 获取当前控制器所属的模块名
    • Yaf_Controller_Abstract::getName - Get self name
    • Yaf_Controller_Abstract::getRequest - The getRequest purpose
    • Yaf_Controller_Abstract::getResponse - The getResponse purpose
    • Yaf_Controller_Abstract::getView - 获取当前的视图引擎
    • Yaf_Controller_Abstract::getViewpath - The getViewpath purpose
    • Yaf_Controller_Abstract::init - 控制器初始化
    • Yaf_Controller_Abstract::initView - The initView purpose
    • Yaf_Controller_Abstract::redirect - The redirect purpose
    • Yaf_Controller_Abstract::render - 渲染视图模板
    • Yaf_Controller_Abstract::setViewpath - The setViewpath purpose
    • Yaf_Controller_Abstract::__construct - Yaf_Controller_Abstract constructor
    • Yaf_Dispatcher::autoRender - 开启/关闭自动渲染功能
    • Yaf_Dispatcher::catchException - 开启/关闭自动异常捕获功能
    • Yaf_Dispatcher::disableView - 关闭自动渲染
    • Yaf_Dispatcher::dispatch - 分发请求
    • Yaf_Dispatcher::enableView - 开启自动渲染
    • Yaf_Dispatcher::flushInstantly - 打开关闭自动响应
    • Yaf_Dispatcher::getApplication - 获取当前的Yaf_Application实例
    • Yaf_Dispatcher::getDefaultAction - Retrive the default action name
    • Yaf_Dispatcher::getDefaultController - Retrive the default controller name
    • Yaf_Dispatcher::getDefaultModule - Retrive the default module name
    • Yaf_Dispatcher::getInstance - 获取当前的Yaf_Dispatcher实例
    • Yaf_Dispatcher::getRequest - 获取当前的请求实例
    • Yaf_Dispatcher::getRouter - 获取路由器
    • Yaf_Dispatcher::initView - 初始化视图引擎并返回它
    • Yaf_Dispatcher::registerPlugin - 注册一个插件
    • Yaf_Dispatcher::returnResponse - The returnResponse purpose
    • Yaf_Dispatcher::setDefaultAction - 设置路由的默认动作
    • Yaf_Dispatcher::setDefaultController - 设置路由的默认控制器
    • Yaf_Dispatcher::setDefaultModule - 设置路由的默认模块
    • Yaf_Dispatcher::setErrorHandler - 设置错误处理函数
    • Yaf_Dispatcher::setRequest - The setRequest purpose
    • Yaf_Dispatcher::setView - 设置视图引擎
    • Yaf_Dispatcher::throwException - 开启/关闭异常抛出
    • Yaf_Dispatcher::__construct - Yaf_Dispatcher 构造函数
    • Yaf_Exception::getPrevious - The getPrevious purpose
    • Yaf_Exception::__construct - The __construct purpose
    • Yaf_Loader::autoload - The autoload purpose
    • Yaf_Loader::clearLocalNamespace - The clearLocalNamespace purpose
    • Yaf_Loader::getInstance - The getInstance purpose
    • Yaf_Loader::getLibraryPath - get the library path
    • Yaf_Loader::getLocalNamespace - Retrive all register namespaces info
    • Yaf_Loader::getNamespacePath - Retieve path of a registered namespace
    • Yaf_Loader::import - The import purpose
    • Yaf_Loader::isLocalName - The isLocalName purpose
    • Yaf_Loader::registerLocalNamespace - 注册本地类前缀
    • Yaf_Loader::registerNamespace - Register namespace with searching path
    • Yaf_Loader::setLibraryPath - 改变library路径
    • Yaf_Loader::__construct - The __construct purpose
    • Yaf_Plugin_Abstract::dispatchLoopShutdown - The dispatchLoopShutdown purpose
    • Yaf_Plugin_Abstract::dispatchLoopStartup - The dispatchLoopStartup purpose
    • Yaf_Plugin_Abstract::postDispatch - The postDispatch purpose
    • Yaf_Plugin_Abstract::preDispatch - The preDispatch purpose
    • Yaf_Plugin_Abstract::preResponse - The preResponse purpose
    • Yaf_Plugin_Abstract::routerShutdown - The routerShutdown purpose
    • Yaf_Plugin_Abstract::routerStartup - RouterStartup hook
    • Yaf_Registry::del - Remove an item from registry
    • Yaf_Registry::get - Retrieve an item from registry
    • Yaf_Registry::has - Check whether an item exists
    • Yaf_Registry::set - Add an item into registry
    • Yaf_Registry::__construct - Yaf_Registry implements singleton
    • Yaf_Request_Abstract::clearParams - Remove all params
    • Yaf_Request_Abstract::getActionName - The getActionName purpose
    • Yaf_Request_Abstract::getBaseUri - The getBaseUri purpose
    • Yaf_Request_Abstract::getControllerName - The getControllerName purpose
    • Yaf_Request_Abstract::getEnv - 取得ENV变量的值
    • Yaf_Request_Abstract::getException - The getException purpose
    • Yaf_Request_Abstract::getLanguage - The getLanguage purpose
    • Yaf_Request_Abstract::getMethod - The getMethod purpose
    • Yaf_Request_Abstract::getModuleName - The getModuleName purpose
    • Yaf_Request_Abstract::getParam - The getParam purpose
    • Yaf_Request_Abstract::getParams - The getParams purpose
    • Yaf_Request_Abstract::getRequestUri - The getRequestUri purpose
    • Yaf_Request_Abstract::getServer - 返回SERVER变量的值
    • Yaf_Request_Abstract::isCli - The isCli purpose
    • Yaf_Request_Abstract::isDispatched - The isDispatched purpose
    • Yaf_Request_Abstract::isGet - The isGet purpose
    • Yaf_Request_Abstract::isHead - The isHead purpose
    • Yaf_Request_Abstract::isOptions - The isOptions purpose
    • Yaf_Request_Abstract::isPost - The isPost purpose
    • Yaf_Request_Abstract::isPut - The isPut purpose
    • Yaf_Request_Abstract::isRouted - The isRouted purpose
    • Yaf_Request_Abstract::isXmlHttpRequest - The isXmlHttpRequest purpose
    • Yaf_Request_Abstract::setActionName - The setActionName purpose
    • Yaf_Request_Abstract::setBaseUri - The setBaseUri purpose
    • Yaf_Request_Abstract::setControllerName - The setControllerName purpose
    • Yaf_Request_Abstract::setDispatched - The setDispatched purpose
    • Yaf_Request_Abstract::setModuleName - The setModuleName purpose
    • Yaf_Request_Abstract::setParam - The setParam purpose
    • Yaf_Request_Abstract::setRequestUri - The setRequestUri purpose
    • Yaf_Request_Abstract::setRouted - The setRouted purpose
    • Yaf_Request_Http::get - 从客户端返回变量
    • Yaf_Request_Http::getCookie - 返回Cookie变量
    • Yaf_Request_Http::getFiles - The getFiles purpose
    • Yaf_Request_Http::getPost - 返回POST变量
    • Yaf_Request_Http::getQuery - fetch a query parameter
    • Yaf_Request_Http::getRaw - Retrieve Raw request body
    • Yaf_Request_Http::getRequest - The getRequest purpose
    • Yaf_Request_Http::isXmlHttpRequest - 是否为Ajax请求
    • Yaf_Request_Http::__construct - The __construct purpose
    • Yaf_Request_Simple::get - The get purpose
    • Yaf_Request_Simple::getCookie - The getCookie purpose
    • Yaf_Request_Simple::getFiles - The getFiles purpose
    • Yaf_Request_Simple::getPost - The getPost purpose
    • Yaf_Request_Simple::getQuery - The getQuery purpose
    • Yaf_Request_Simple::getRequest - The getRequest purpose
    • Yaf_Request_Simple::isXmlHttpRequest - The isXmlHttpRequest purpose
    • Yaf_Request_Simple::__construct - The __construct purpose
    • Yaf_Response_Abstract::appendBody - 往已有的响应body后附加新的内容
    • Yaf_Response_Abstract::clearBody - 清除已经设置的响应body
    • Yaf_Response_Abstract::clearHeaders - The clearHeaders purpose
    • Yaf_Response_Abstract::getBody - 获取已经设置的响应body
    • Yaf_Response_Abstract::getHeader - The getHeader purpose
    • Yaf_Response_Abstract::prependBody - The prependBody purpose
    • Yaf_Response_Abstract::response - send response
    • Yaf_Response_Abstract::setAllHeaders - The setAllHeaders purpose
    • Yaf_Response_Abstract::setBody - 设置响应的Body
    • Yaf_Response_Abstract::setHeader - The setHeader purpose
    • Yaf_Response_Abstract::setRedirect - The setRedirect purpose
    • Yaf_Response_Abstract::__construct - The __construct purpose
    • Yaf_Response_Abstract::__destruct - The __destruct purpose
    • Yaf_Response_Abstract::__toString - The __toString purpose
    • Yaf_Router::addConfig - 向Router中添加配置文件中定义的路由
    • Yaf_Router::addRoute - 往Router中添加新的路由
    • Yaf_Router::getCurrentRoute - 取得当前有效的路由名
    • Yaf_Router::getRoute - The getRoute purpose
    • Yaf_Router::getRoutes - The getRoutes purpose
    • Yaf_Router::route - The route purpose
    • Yaf_Router::__construct - Yaf_Router constructor
    • Yaf_Route_Interface::assemble - 将指定路由规则组合成一个url
    • Yaf_Route_Interface::route - route a request
    • Yaf_Route_Map::assemble - 组合url
    • Yaf_Route_Map::route - The route purpose
    • Yaf_Route_Map::__construct - The __construct purpose
    • Yaf_Route_Regex::assemble - 组合url
    • Yaf_Route_Regex::route - The route purpose
    • Yaf_Route_Regex::__construct - The __construct purpose
    • Yaf_Route_Rewrite::assemble - 组合url
    • Yaf_Route_Rewrite::route - The route purpose
    • Yaf_Route_Rewrite::__construct - The __construct purpose
    • Yaf_Route_Simple::assemble - 组合url
    • Yaf_Route_Simple::route - Route a request
    • Yaf_Route_Simple::__construct - Yaf_Route_Simple constructor
    • Yaf_Route_Static::assemble - 组合url
    • Yaf_Route_Static::match - The match purpose
    • Yaf_Route_Static::route - Route a request
    • Yaf_Route_Supervar::assemble - 组合url
    • Yaf_Route_Supervar::route - The route purpose
    • Yaf_Route_Supervar::__construct - The __construct purpose
    • Yaf_Session::count - The count purpose
    • Yaf_Session::current - The current purpose
    • Yaf_Session::del - The del purpose
    • Yaf_Session::getInstance - The getInstance purpose
    • Yaf_Session::has - The has purpose
    • Yaf_Session::key - The key purpose
    • Yaf_Session::next - The next purpose
    • Yaf_Session::offsetExists - The offsetExists purpose
    • Yaf_Session::offsetGet - The offsetGet purpose
    • Yaf_Session::offsetSet - The offsetSet purpose
    • Yaf_Session::offsetUnset - The offsetUnset purpose
    • Yaf_Session::rewind - The rewind purpose
    • Yaf_Session::start - The start purpose
    • Yaf_Session::valid - The valid purpose
    • Yaf_Session::__construct - The __construct purpose
    • Yaf_Session::__get - The __get purpose
    • Yaf_Session::__isset - The __isset purpose
    • Yaf_Session::__set - The __set purpose
    • Yaf_Session::__unset - The __unset purpose
    • Yaf_View_Interface::assign - 为视图引擎分配一个模板变量
    • Yaf_View_Interface::display - 渲染一个视图模板, 并直接输出给请求端
    • Yaf_View_Interface::getScriptPath - The getScriptPath purpose
    • Yaf_View_Interface::render - 渲染一个视图模板
    • Yaf_View_Interface::setScriptPath - The setScriptPath purpose
    • Yaf_View_Simple::assign - 为视图引擎分配一个模板变量
    • Yaf_View_Simple::assignRef - The assignRef purpose
    • Yaf_View_Simple::clear - Clear Assigned values
    • Yaf_View_Simple::display - 渲染一个视图模板, 并直接输出给请求端
    • Yaf_View_Simple::eval - 渲染模板
    • Yaf_View_Simple::getScriptPath - 获取模板目录
    • Yaf_View_Simple::render - 渲染模板
    • Yaf_View_Simple::setScriptPath - 设置模板的目录
    • Yaf_View_Simple::__construct - Constructor of Yaf_View_Simple
    • Yaf_View_Simple::__get - 获取视图引擎的一个模板变量值
    • Yaf_View_Simple::__isset - The __isset purpose
    • Yaf_View_Simple::__set - 为视图引擎分配一个模板变量
    • yaml_emit - Returns the YAML representation of a value
    • yaml_emit_file - Send the YAML representation of a value to a file
    • yaml_parse - Parse a YAML stream
    • yaml_parse_file - Parse a YAML stream from a file
    • yaml_parse_url - Parse a Yaml stream from a URL
    • Yar_Client::setOpt - 设置调用的配置
    • Yar_Client::__call - 调用远程服务
    • Yar_Client::__construct - 创建一个客户端实例
    • Yar_Client_Exception::getType - The getType purpose
    • Yar_Concurrent_Client::call - 注册一个并行的服务调用
    • Yar_Concurrent_Client::loop - 发送所有注册的并行调用
    • Yar_Server::handle - 启动HTTP RPC Server
    • Yar_Server::__construct - 创建一个HTTP RPC Server
    • Yar_Server_Exception::getType - 获取异常的原始类型
    • yaz_addinfo - Returns additional error information
    • yaz_ccl_conf - Configure CCL parser
    • yaz_ccl_parse - Invoke CCL Parser
    • yaz_close - Close YAZ connection
    • yaz_connect - Prepares for a connection to a Z39.50 server
    • yaz_database - Specifies the databases within a session
    • yaz_element - Specifies Element-Set Name for retrieval
    • yaz_errno - Returns error number
    • yaz_error - Returns error description
    • yaz_es - Prepares for an Extended Service Request
    • yaz_es_result - Inspects Extended Services Result
    • yaz_get_option - Returns value of option for connection
    • yaz_hits - Returns number of hits for last search
    • yaz_itemorder - Prepares for Z39.50 Item Order with an ILL-Request package
    • yaz_present - Prepares for retrieval (Z39.50 present)
    • yaz_range - Specifies a range of records to retrieve
    • yaz_record - Returns a record
    • yaz_scan - Prepares for a scan
    • yaz_scan_result - Returns Scan Response result
    • yaz_schema - Specifies schema for retrieval
    • yaz_search - Prepares for a search
    • yaz_set_option - Sets one or more options for connection
    • yaz_sort - Sets sorting criteria
    • yaz_syntax - Specifies the preferred record syntax for retrieval
    • yaz_wait - Wait for Z39.50 requests to complete
  • z
    • zend_thread_id - 返回当前线程的唯一识别符
    • zend_version - 获取当前 Zend 引擎的版本
    • ZipArchive::addEmptyDir - Add a new directory
    • ZipArchive::addFile - Adds a file to a ZIP archive from the given path
    • ZipArchive::addFromString - Add a file to a ZIP archive using its contents
    • ZipArchive::addGlob - Add files from a directory by glob pattern
    • ZipArchive::addPattern - Add files from a directory by PCRE pattern
    • ZipArchive::close - Close the active archive (opened or newly created)
    • ZipArchive::count - Counts the number of files in the archive
    • ZipArchive::deleteIndex - Delete an entry in the archive using its index
    • ZipArchive::deleteName - Delete an entry in the archive using its name
    • ZipArchive::extractTo - 解压缩文件
    • ZipArchive::getArchiveComment - Returns the Zip archive comment
    • ZipArchive::getCommentIndex - Returns the comment of an entry using the entry index
    • ZipArchive::getCommentName - Returns the comment of an entry using the entry name
    • ZipArchive::getExternalAttributesIndex - Retrieve the external attributes of an entry defined by its index
    • ZipArchive::getExternalAttributesName - Retrieve the external attributes of an entry defined by its name
    • ZipArchive::getFromIndex - Returns the entry contents using its index
    • ZipArchive::getFromName - Returns the entry contents using its name
    • ZipArchive::getNameIndex - Returns the name of an entry using its index
    • ZipArchive::getStatusString - Returns the status error message, system and/or zip messages
    • ZipArchive::getStream - Get a file handler to the entry defined by its name (read only)
    • ZipArchive::isCompressionMethodSupported - Check if a compression method is supported by libzip
    • ZipArchive::isEncryptionMethodSupported - Check if a encryption method is supported by libzip
    • ZipArchive::locateName - Returns the index of the entry in the archive
    • ZipArchive::open - Open a ZIP file archive
    • ZipArchive::registerCancelCallback - Register a callback to allow cancellation during archive close.
    • ZipArchive::registerProgressCallback - Register a callback to provide updates during archive close.
    • ZipArchive::renameIndex - Renames an entry defined by its index
    • ZipArchive::renameName - Renames an entry defined by its name
    • ZipArchive::replaceFile - Replace file in ZIP archive with a given path
    • ZipArchive::setArchiveComment - Set the comment of a ZIP archive
    • ZipArchive::setCommentIndex - Set the comment of an entry defined by its index
    • ZipArchive::setCommentName - Set the comment of an entry defined by its name
    • ZipArchive::setCompressionIndex - Set the compression method of an entry defined by its index
    • ZipArchive::setCompressionName - Set the compression method of an entry defined by its name
    • ZipArchive::setEncryptionIndex - Set the encryption method of an entry defined by its index
    • ZipArchive::setEncryptionName - Set the encryption method of an entry defined by its name
    • ZipArchive::setExternalAttributesIndex - Set the external attributes of an entry defined by its index
    • ZipArchive::setExternalAttributesName - Set the external attributes of an entry defined by its name
    • ZipArchive::setMtimeIndex - Set the modification time of an entry defined by its index
    • ZipArchive::setMtimeName - Set the modification time of an entry defined by its name
    • ZipArchive::setPassword - Set the password for the active archive
    • ZipArchive::statIndex - Get the details of an entry defined by its index
    • ZipArchive::statName - Get the details of an entry defined by its name
    • ZipArchive::unchangeAll - Undo all changes done in the archive
    • ZipArchive::unchangeArchive - Revert all global changes done in the archive
    • ZipArchive::unchangeIndex - Revert all changes done to an entry at the given index
    • ZipArchive::unchangeName - Revert all changes done to an entry with the given name
    • Zip context options - Zip context option listing
    • zip_close - 关闭一个ZIP档案文件
    • zip_entry_close - 关闭目录项
    • zip_entry_compressedsize - 检索目录项压缩过后的大小
    • zip_entry_compressionmethod - 检索目录实体的压缩方法
    • zip_entry_filesize - 检索目录实体的实际大小
    • zip_entry_name - 检索目录项的名称
    • zip_entry_open - 打开用于读取的目录实体
    • zip_entry_read - 读取一个打开了的压缩目录实体
    • zip_open - 打开ZIP存档文件
    • zip_read - 读取ZIP存档文件中下一项
    • zlib:// - 压缩流
    • zlib_decode - Uncompress any raw/gzip/zlib encoded data
    • zlib_encode - Compress data with the specified encoding
    • zlib_get_coding_type - Returns the coding type used for output compression
    • ZMQ::__construct - ZMQ constructor
    • ZMQContext::getOpt - Get context option
    • ZMQContext::getSocket - Create a new socket
    • ZMQContext::isPersistent - Whether the context is persistent
    • ZMQContext::setOpt - Set a socket option
    • ZMQContext::__construct - Construct a new ZMQContext object
    • ZMQDevice::getIdleTimeout - Get the idle timeout
    • ZMQDevice::getTimerTimeout - Get the timer timeout
    • ZMQDevice::run - Run the new device
    • ZMQDevice::setIdleCallback - Set the idle callback function
    • ZMQDevice::setIdleTimeout - Set the idle timeout
    • ZMQDevice::setTimerCallback - Set the timer callback function
    • ZMQDevice::setTimerTimeout - Set the timer timeout
    • ZMQDevice::__construct - Construct a new device
    • ZMQPoll::add - Add item to the poll set
    • ZMQPoll::clear - Clear the poll set
    • ZMQPoll::count - Count items in the poll set
    • ZMQPoll::getLastErrors - Get poll errors
    • ZMQPoll::poll - Poll the items
    • ZMQPoll::remove - Remove item from poll set
    • ZMQSocket::bind - Bind the socket
    • ZMQSocket::connect - Connect the socket
    • ZMQSocket::disconnect - Disconnect a socket
    • ZMQSocket::getEndpoints - Get list of endpoints
    • ZMQSocket::getPersistentId - Get the persistent id
    • ZMQSocket::getSocketType - Get the socket type
    • ZMQSocket::getSockOpt - Get socket option
    • ZMQSocket::isPersistent - Whether the socket is persistent
    • ZMQSocket::recv - Receives a message
    • ZMQSocket::recvMulti - Receives a multipart message
    • ZMQSocket::send - Sends a message
    • ZMQSocket::sendmulti - Sends a multipart message
    • ZMQSocket::setSockOpt - Set a socket option
    • ZMQSocket::unbind - Unbind the socket
    • ZMQSocket::__construct - Construct a new ZMQSocket
    • Zookeeper::addAuth - Specify application credentials
    • Zookeeper::close - Close the zookeeper handle and free up any resources
    • Zookeeper::connect - Create a handle to used communicate with zookeeper
    • Zookeeper::create - Create a node synchronously
    • Zookeeper::delete - Delete a node in zookeeper synchronously
    • Zookeeper::exists - Checks the existence of a node in zookeeper synchronously
    • Zookeeper::get - Gets the data associated with a node synchronously
    • Zookeeper::getAcl - Gets the acl associated with a node synchronously
    • Zookeeper::getChildren - Lists the children of a node synchronously
    • Zookeeper::getClientId - Return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
    • Zookeeper::getConfig - Get instance of ZookeeperConfig
    • Zookeeper::getRecvTimeout - Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect
    • Zookeeper::getState - Get the state of the zookeeper connection
    • Zookeeper::isRecoverable - Checks if the current zookeeper connection state can be recovered
    • Zookeeper::set - Sets the data associated with a node
    • Zookeeper::setAcl - Sets the acl associated with a node synchronously
    • Zookeeper::setDebugLevel - Sets the debugging level for the library
    • Zookeeper::setDeterministicConnOrder - Enable/disable quorum endpoint order randomization
    • Zookeeper::setLogStream - Sets the stream to be used by the library for logging
    • Zookeeper::setWatcher - Set a watcher function
    • Zookeeper::__construct - Create a handle to used communicate with zookeeper
    • ZookeeperConfig::add - Add servers to the ensemble
    • ZookeeperConfig::get - Gets the last committed configuration of the ZooKeeper cluster as it is known to the server to which the client is connected, synchronously
    • ZookeeperConfig::remove - Remove servers from the ensemble
    • ZookeeperConfig::set - Change ZK cluster ensemble membership and roles of ensemble peers
    • zookeeper_dispatch - Calls callbacks for pending operations
  • _
    • __autoload - 尝试加载未定义的类
    • __halt_compiler - 中断编译器的执行
  • ?
    • 套接字上下文选项 - 套接字上下文选项列表


示例列表

手册中所有示例的列表

  • Example#0 - 一个介绍性的范例
  • Example#1 - 第一个 PHP 脚本：hello.php
  • Example#2 - 从 PHP 获取系统信息
  • Example#3 - 打印一个变量（数组元素）
  • Example#4 - 流程控制与函数的使用
  • Example#5 - 混和 HTML 和 PHP 模式
  • Example#6 - 一个简单的 HTML 表单
  • Example#7 - 打印来自表单的数据
  • Example#8 - PHP 的 Apache 共享模块版本安装说明
  • Example#9 - PHP 的 Apache 静态模块版本安装说明
  • Example#10 - 重启动 Apache 的示例命令
  • Example#11 -
  • Example#12 -
  • Example#13 -
  • Example#14 -
  • Example#15 -
  • Example#16 -
  • Example#17 -
  • Example#18 -
  • Example#19 -
  • Example#20 -
  • Example#21 -
  • Example#22 -
  • Example#23 -
  • Example#24 - Partial lighttpd.conf
  • Example#25 - 产生 FastCGI 应答器
  • Example#26 - 连接远程 php-fastcgi 实例
  • Example#27 -
  • Example#28 -
  • Example#29 - 在 OpenBSD 系统下的软件包的安装示例
  • Example#30 - Debian 下将 PHP 安装入 Apache 2 的例子
  • Example#31 - 安装完 PHP 后停止并启动 Apache
  • Example#32 - 取得 PHP 附加软件包的列表
  • Example#33 - 安装 PHP 的 MySQL 和 cURL 支持
  • Example#34 - 推荐的 OpCache 配置
  • Example#35 - 推荐的 WinCache 配置
  • Example#36 - 命令行下配置 IIS 和 PHP
  • Example#37 - PHP 5 压缩包的结构
  • Example#38 - php.ini 中的 CGI 和 FastCGI 设定
  • Example#39 - 配置 FastCGI 扩展以处理 PHP 请求
  • Example#40 - 配置文件访问权限
  • Example#41 - 配置 FastCGI 和 PHP 的回收
  • Example#42 - 配置 FastCGI 超时设定
  • Example#43 - 改变 php.ini 文件的位置
  • Example#44 - php.ini 中的 CGI 和 FastCGI 设定
  • Example#45 - 创建 IIS FastCGI 处理池
  • Example#46 - 创建对应于 PHP 请求的处理程序映射
  • Example#47 - 确定用于 IIS 匿名认证的用户帐号
  • Example#48 - 配置文件访问权限
  • Example#49 - 将 index.php 设为 IIS 的默认文档
  • Example#50 - 配置 FastCGI 和 PHP 的回收
  • Example#51 - 配置 FastCGI 超时设定
  • Example#52 - 改变 php.ini 文件的位置
  • Example#53 - PHP 作为 Apache 1.3.x 的一个模块
  • Example#54 - PHP 以 CGI 方式运行在 Apache 1.3.x
  • Example#55 - PHP 在 Apache 2.x 中作为 handler
  • Example#56 -
  • Example#57 - Apache 2.x 下 CGI 方式的 PHP
  • Example#58 - 配置 Apache 以 FastCGI 方式运行 PHP
  • Example#59 - Sambar 的 ISAPI 设置
  • Example#60 - 在 Windows 下启用 Bzip2 扩展库
  • Example#61 - 注册表变化
  • Example#62 - 给运行池传递环境变量和设置 PHP 的配置值
  • Example#63 - 在 nginx.conf 中设定 PHP
  • Example#64 - phpinfo call
  • Example#65 - php.ini 中的环境变量
  • Example#66 - php.ini 例子
  • Example#67 - Apache 配置例子
  • Example#68 - PHP 开始和结束标记
  • Example#69 - 使用条件的高级分离术
  • Example#70 - 包含末尾换行符的结束标记的例子
  • Example#71 - 整数文字表达
  • Example#72 - 32 位系统下的整数溢出
  • Example#73 - 64 位系统下的整数溢出
  • Example#74 - 非法的示例
  • Example#75 - Heredoc 结构的字符串示例
  • Example#76 - Heredoc 结构在参数中的示例
  • Example#77 - 使用 Heredoc 结构来初始化静态值
  • Example#78 - 在 heredoc 结构中使用双引号
  • Example#79 - Nowdoc 结构字符串示例
  • Example#80 - 静态数据的示例
  • Example#81 - 简单语法示例
  • Example#82 - 一些字符串示例
  • Example#83 - PHP 5.3 和 PHP 5.4 的区别
  • Example#84 - 一个简单数组
  • Example#85 - 类型强制与覆盖示例
  • Example#86 - 混合 integer 和 string 键名
  • Example#87 - 没有键名的索引数组
  • Example#88 - 仅对部分单元指定键名
  • Example#89 - 访问数组单元
  • Example#90 - 数组解引用
  • Example#91 - 使用 array()
  • Example#92 - 集合
  • Example#93 - 在循环中改变单元
  • Example#94 - 下标从 1 开始的数组
  • Example#95 - 填充数组
  • Example#96 - 数组排序
  • Example#97 - 递归和多维数组
  • Example#98 - Iterable 可迭代参数类型示例
  • Example#99 - 可迭代参数默认值示例
  • Example#100 - 可迭代返回类型示例
  • Example#101 - 可迭代生成器返回类型的示例
  • Example#102 - 可迭代的类型协变示例
  • Example#103 - 回调函数示例
  • Example#104 - 使用 Closure 的示例
  • Example#105 -
  • Example#106 - 在类中使用类型声明
  • Example#107 - 在接口中使用类型声明
  • Example#108 - 返回类型声明
  • Example#109 - 返回一个对象
  • Example#110 - 定义可空（Nullable）的参数类型
  • Example#111 - 定义可空（Nullable）的返回类型
  • Example#112 - 旧版本中实现允许为空参数的示例
  • Example#113 - 参数值的严格类型
  • Example#114 - 参数值的类型强制转化
  • Example#115 - 返回值的严格类型
  • Example#116 - 类型强制转换为联合类型的例子
  • Example#117 - 传引用参数的类型
  • Example#118 - 捕获 TypeError
  • Example#119 - 未初始化变量的默认值
  • Example#120 - 使用 global
  • Example#121 - 使用 $GLOBALS 替代 global
  • Example#122 - 演示超全局变量和作用域的例子
  • Example#123 - 演示需要静态变量的例子
  • Example#124 - 使用静态变量的例子
  • Example#125 - 静态变量与递归函数
  • Example#126 - 声明静态变量
  • Example#127 - 可变属性示例
  • Example#128 - 一个简单的 HTML 表单
  • Example#129 - 从一个简单的 POST HTML 表单访问数据
  • Example#130 - 更复杂的表单变量
  • Example#131 - 一个 setcookie 的示例
  • Example#132 - 合法与非法的常量名
  • Example#133 - 定义常量
  • Example#134 - 使用关键字 const 定义常量
  • Example#135 - 结合方向
  • Example#136 - Undefined order of evaluation
  • Example#137 - +、- 、. 具有相同的优先级
  • Example#138 - 引用赋值
  • Example#139 - 整数的 AND，OR 和 XOR 位运算符
  • Example#140 - 字符串的 XOR 运算符
  • Example#141 - 整数的位移
  • Example#142 - Boolean/null comparison
  • Example#143 - 标准数组比较代码
  • Example#144 - 赋默认值
  • Example#145 - 不清晰的三元运算符行为
  • Example#146 - 设置默认值
  • Example#147 - 嵌套 NULL 合并运算符
  • Example#148 - 涉及字符变量的算数运算
  • Example#149 - 逻辑运算符示例
  • Example#150 - 比较数组
  • Example#151 - 对类使用 instanceof
  • Example#152 - 对继承类使用 instanceof
  • Example#153 - 使用 instanceof 检查对象不是某个类的实例
  • Example#154 - 对接口使用 instanceof
  • Example#155 - 对其它变量使用 instanceof
  • Example#156 - 用 instanceof 检测其它变量
  • Example#157 - 使用 instanceof 测试常量
  • Example#158 - switch 结构
  • Example#159 - switch 结构可以用 string
  • Example#160 - Structure of a match expression
  • Example#161 - Example of an unhandled match expression
  • Example#162 - Using a generalized match expressions to branch on integer ranges
  • Example#163 - Using a generalized match expressions to branch on string content
  • Example#164 - Tick 的用法示例
  • Example#165 - Ticks 的用法示例
  • Example#166 - 对脚本指定编码方式
  • Example#167 - 基本的 include 例子
  • Example#168 - 函数中的包含
  • Example#169 - 通过 HTTP 进行的 include
  • Example#170 - 比较 include 的返回值
  • Example#171 - include 和 return 语句
  • Example#172 - 使用输出缓冲来将 PHP 文件包含入一个字符串
  • Example#173 - goto 示例
  • Example#174 - goto 跳出循环示例
  • Example#175 - 以下写法无效
  • Example#176 - 展示函数用途的伪代码
  • Example#177 - 有条件的函数
  • Example#178 - 函数中的函数
  • Example#179 - 递归函数
  • Example#180 - 向函数传递数组
  • Example#181 - 函数参数使用尾部逗号
  • Example#182 - Passing optional arguments after mandatory arguments
  • Example#183 - 用引用传递函数参数
  • Example#184 - 在函数中使用默认参数
  • Example#185 - 使用非标量类型作为默认参数
  • Example#186 - 函数默认参数的不正确用法
  • Example#187 - 函数默认参数正确的用法
  • Example#188 - 使用 ... 来访问变量参数
  • Example#189 - 使用 ... 来传递参数
  • Example#190 - 输入提示的变量参数
  • Example#191 - 在 PHP 早期版本中访问可变参数
  • Example#192 - 命名参数的语法
  • Example#193 - 通过位置传参与命名参数的对比
  • Example#194 - 参数顺序不同的示例（同上例）
  • Example#195 - 命名参数与位置参数结合使用
  • Example#196 - Error exception when passing the same parameter multiple times
  • Example#197 - return 的使用
  • Example#198 - 返回一个数组以得到多个返回值
  • Example#199 - 从函数返回一个引用
  • Example#200 - 可变函数示例
  • Example#201 - 可变方法范例
  • Example#202 - Variable 方法和静态属性示例
  • Example#203 - Complex callables
  • Example#204 - 匿名函数示例
  • Example#205 - 匿名函数变量赋值示例
  • Example#206 - 从父作用域继承变量
  • Example#207 - Closures 和作用域
  • Example#208 - 自动绑定 $this
  • Example#209 - 试图在静态匿名函数中使用 $this
  • Example#210 - 试图将对象绑定到静态匿名函数
  • Example#211 - 箭头函数自动捕捉变量的值
  • Example#212 - 箭头函数自动捕捉变量的值，即使在嵌套的情况下
  • Example#213 - 合法的箭头函数例子
  • Example#214 - 来自外部范围的值不能在箭头函数内修改
  • Example#215 - 简单的类定义
  • Example#216 - 使用 $this 伪变量的示例
  • Example#217 - 创建实例
  • Example#218 - 对象赋值
  • Example#219 - 创建新对象
  • Example#220 - 访问新创建对象的成员
  • Example#221 - 访问类属性 vs. 调用类方法
  • Example#222 - 类属性被赋值为匿名函数时的调用示例
  • Example#223 - 简单的类继承
  • Example#224 - Compatible child methods
  • Example#225 - Fatal error when a child method removes a parameter
  • Example#226 - Fatal error when a child method makes an optional parameter mandatory
  • Example#227 - Error when using named arguments and parameters were renamed in a child class
  • Example#228 - 类名的解析
  • Example#229 - 解析不存在的类名
  • Example#230 - 类名解析
  • Example#231 - Nullsafe 操作符
  • Example#232 - 属性声明
  • Example#233 - 示例：使用 nowdoc 初始化属性
  • Example#234 - 定义和使用一个类常量
  • Example#235 - 静态数据示例
  • Example#236 - 自动加载示例
  • Example#237 - 另一个例子
  • Example#238 - 自动加载在 PHP 5.3.0+ 中的异常处理
  • Example#239 - 自动加载在 PHP 5.3.0+ 中的异常处理 - 没有自定义异常机制
  • Example#240 - 继承中的构造函数
  • Example#241 - 使用构造器参数
  • Example#242 - 使用构造器属性提升
  • Example#243 - 使用 static 创造方法
  • Example#244 - 析构函数示例
  • Example#245 - 属性声明
  • Example#246 - 方法声明
  • Example#247 - PHP 7.1.0 中的常量声明
  • Example#248 - 访问同一个对象类型的私有成员
  • Example#249 - 继承示例
  • Example#250 - 在类的外部使用 :: 操作符
  • Example#251 - 在类定义内部使用 ::
  • Example#252 - 调用父类的方法
  • Example#253 - 静态方法示例
  • Example#254 - 静态属性示例
  • Example#255 - 抽象类示例
  • Example#256 - 抽象类示例
  • Example#257 - 接口示例
  • Example#258 - 可扩充的接口
  • Example#259 - 继承多个接口
  • Example#260 - 使用接口常量
  • Example#261 - Trait 示例
  • Example#262 - 优先顺序示例
  • Example#263 - 另一个优先级顺序的例子
  • Example#264 - 多个 trait 的用法
  • Example#265 - 冲突的解决
  • Example#266 - 修改方法的访问控制
  • Example#267 - 从 trait 来组成 trait
  • Example#268 - 表示通过抽象方法来进行强制要求
  • Example#269 - 静态变量
  • Example#270 - 静态方法
  • Example#271 - 定义属性
  • Example#272 - 解决冲突
  • Example#273 - 使用 __get()，__set()，__isset() 和 __unset() 进行属性重载
  • Example#274 - 使用 __call() 和 __callStatic() 对方法重载
  • Example#275 - 简单的对象遍历
  • Example#276 - 实现 Iterator 接口的对象遍历
  • Example#277 - 通过实现 IteratorAggregate 来遍历对象
  • Example#278 - Sleep 和 wakeup
  • Example#279 - 序列化和反序列化
  • Example#280 - 简单示例
  • Example#281 - 使用 __invoke()
  • Example#282 - 使用 __set_state()>（PHP 5.1.0 起）
  • Example#283 - Using __debugInfo()
  • Example#284 - Final 方法示例
  • Example#285 - Final 类示例
  • Example#286 - 复制一个对象
  • Example#287 - PHP 5 的对象比较
  • Example#288 - self:: 用法
  • Example#289 - static:: 简单用法
  • Example#290 - 非静态环境下使用 static::
  • Example#291 - 转发和非转发调用
  • Example#292 - 引用和对象
  • Example#293 - 命名空间语法示例
  • Example#294 - 声明单个命名空间
  • Example#295 - 声明单个命名空间
  • Example#296 - 声明分层次的单个命名空间
  • Example#297 - 定义多个命名空间，简单组合语法
  • Example#298 - 定义多个命名空间，大括号语法
  • Example#299 - 定义多个命名空间和不包含在命名空间中的代码
  • Example#300 - 定义多个命名空间和不包含在命名空间中的代码
  • Example#301 - 在命名空间内部访问全局类、函数和常量
  • Example#302 - 动态访问元素
  • Example#303 - 动态访问命名空间的元素
  • Example#304 - __NAMESPACE__ 示例, 在命名空间中的代码
  • Example#305 - __NAMESPACE__ 示例，全局代码
  • Example#306 - 使用 __NAMESPACE__ 动态创建名称
  • Example#307 - namespace 操作符，命名空间中的代码
  • Example#308 - namespace 操作符, 全局代码
  • Example#309 - 使用 use 操作符导入/使用别名
  • Example#310 - 通过 use 操作符导入/使用别名，一行中包含多个 use 语句
  • Example#311 - 导入和动态名称
  • Example#312 - 导入和完全限定名称
  • Example#313 - Illegal importing rule
  • Example#314 - 使用全局空间说明
  • Example#315 - 在命名空间中访问全局类
  • Example#316 - 命名空间中后备的全局函数/常量
  • Example#317 - 名称解析示例
  • Example#318 - Accessing global classes outside a namespace
  • Example#319 - Accessing global classes outside a namespace
  • Example#320 - Accessing internal classes in namespaces
  • Example#321 - Accessing internal classes, functions or constants in namespaces
  • Example#322 - Fully Qualified names
  • Example#323 - Qualified names
  • Example#324 - Unqualified class names
  • Example#325 - Unqualified function or constant names
  • Example#326 - Dangers of using namespaced names inside a double-quoted string
  • Example#327 - Undefined constants
  • Example#328 - Undefined constants
  • Example#329 - 内置的异常处理类
  • Example#330 - 扩展 PHP 内置的异常处理类
  • Example#331 - 将错误报告转成异常
  • Example#332 - 抛出一个异常
  • Example#333 - 带 finally 块的异常处理
  • Example#334 - finally 和 return 相互之间的影响
  • Example#335 - 异常嵌套
  • Example#336 - 多个异常的捕获处理
  • Example#337 - 忽略捕获的变量
  • Example#338 - 以表达式的形式抛出
  • Example#339 - 将 range 实现为生成器
  • Example#340 - 一个简单的生成值的例子
  • Example#341 - 生成一个键值对
  • Example#342 - 生成nulls
  • Example#343 - 使用引用来生成值
  • Example#344 - yield from with iterator_to_array
  • Example#345 - yield from 的基本用法
  • Example#346 - yield from 并返回多个值
  • Example#347 - 用注解实现接口的可选方法
  • Example#348 - 注解语法
  • Example#349 - 通过反射 API 读取注解
  • Example#350 - 使用反射 API 读取指定的注解
  • Example#351 - 目标限定使用的注解
  • Example#352 - 简单的 Attribute 类
  • Example#353 - 使用 IS_REPEATABLE 允许注解在声明中出现多次
  • Example#354 - 对未定义的变量使用引用
  • Example#355 - 在函数内引用全局变量
  • Example#356 - 引用与 foreach 语句
  • Example#357 - $GLOBALS 范例
  • Example#358 - $_SERVER 范例
  • Example#359 - $_GET 范例
  • Example#360 - $_POST 范例
  • Example#361 - $_ENV 范例
  • Example#362 - $_COOKIE 范例
  • Example#363 - $php_errormsg 范例
  • Example#364 - $http_response_header 范例
  • Example#365 - $argc 范例
  • Example#366 - $argv 范例
  • Example#367 - Exception::getMessage示例
  • Example#368 - Exception::getPrevious示例
  • Example#369 - Exception::getCode示例
  • Example#370 - Exception::getFile示例
  • Example#371 - Exception::getLine示例
  • Example#372 - Exception::getTrace示例
  • Example#373 - Exception::getTraceAsString示例
  • Example#374 - Exception::__toString示例
  • Example#375 - 使用set_error_handler函数将错误信息托管至ErrorException
  • Example#376 - ErrorException::getSeverity 例子
  • Example#377 - Error::getMessage 例子
  • Example#378 - Error::getPrevious 例子
  • Example#379 - Error::getCode 例子
  • Example#380 - Error::getFile 例子
  • Example#381 - Error::getLine 例子
  • Example#382 - Error::getTrace 例子
  • Example#383 - Error::getTraceAsString 例子
  • Example#384 - Error::__toString 例子
  • Example#385 - 基本用法
  • Example#386 - 基本用法
  • Example#387 - Basic usage
  • Example#388 - ArrayAccess::offsetExists 范例
  • Example#389 - Basic usage
  • Example#390 - Closure::bind 实例
  • Example#391 - Closure::bindTo 实例
  • Example#392 - Generator::key example
  • Example#393 - 用 Generator::send 向生成器函数中传值
  • Example#394 - Basic bindto usage example
  • Example#395 - 获取一个页面并发送 POST 数据
  • Example#396 - 忽略重定向并获取 header 和内容
  • Example#397 - 获取一个页面，并以POST发送数据
  • Example#398 - Basic password usage example
  • Example#399 - 检测重定向后最终的 URL
  • Example#400 - php://temp/maxmemory
  • Example#401 - php://filter/resource=<待过滤的数据流>
  • Example#402 - php://filter/read=<读链需要应用的过滤器列表>
  • Example#403 - php://filter/write=<写链需要应用的过滤器列表>
  • Example#404 - php://memory 和 php://temp 是一次性的
  • Example#405 - 打印 data:// 的内容
  • Example#406 - 获取媒体类型
  • Example#407 - 基本用法
  • Example#408 - 从一个活动连接中打开字节流
  • Example#409 - This $session variable must be kept available!
  • Example#410 - Traversing a RAR archive
  • Example#411 - Opening an encrypted file (header encryption)
  • Example#412 - 不对变量进行安全检查会导致……
  • Example#413 - ……文件系统攻击
  • Example#414 - 更安全的文件名检查
  • Example#415 - 更安全的文件名检查
  • Example#416 - 会被 Null 字符问题攻击的代码
  • Example#417 - 验证输入的正确做法
  • Example#418 - Hashing password field
  • Example#419 - 一段实现数据分页显示的代码…… 也可以被用作创建一个超级用户（PostgreSQL 数据库）。
  • Example#420 - 显示文章……以及一些密码（任何数据库系统）
  • Example#421 - 从重设密码……到获得更多权限（任何数据库系统）
  • Example#422 - 攻击数据库所在主机的操作系统（MSSQL Server 数据库）
  • Example#423 - 一个实现分页更安全的方法
  • Example#424 - 用自定义的 HTML 页面攻击变量
  • Example#425 - 利用变量打开调式功能
  • Example#426 - 用 E_ALL 来查找危险的变量
  • Example#427 - 危险的变量用法
  • Example#428 - 把 PHP 隐藏为另一种语言
  • Example#429 - 使用未知的扩展名作为 PHP 的扩展名
  • Example#430 - 用 HTML 做 PHP 的文件后缀
  • Example#431 - Basic HTTP 认证范例
  • Example#432 - Digest HTTP 认证范例
  • Example#433 - 强迫重新输入用户名和密码的 HTTP 认证的范例
  • Example#434 - 一个简单的 XForms 搜索表单
  • Example#435 - 使用 XForm 来产生 $_POST
  • Example#436 - 文件上传表单
  • Example#437 - 验证上传的文件
  • Example#438 - 上传一组文件
  • Example#439 - 上传多个文件
  • Example#440 - 保存 HTTP PUT 文件
  • Example#441 - 获取远程文件的标题
  • Example#442 - 将数据保存到远程服务器
  • Example#443 -
  • Example#444 - 使用该参数，PHP 将打印出内置以及已加载的 PHP 及 Zend 模块：
  • Example#445 - 显示双引号语法解析错误的范例
  • Example#446 - Using single quotes to prevent the shell's variable substitution
  • Example#447 - 使用 -B，-R 和 -E 选项来计算一个项目总行数的例子。
  • Example#448 - 使用 -v 将 PHP、SAPI 名称和 Zend 的版本信息写入标准输出。
  • Example#449 - --ini example
  • Example#450 - basic --rf usage
  • Example#451 - --rc example
  • Example#452 - --re example
  • Example#453 - --ri example
  • Example#454 - Execute PHP script as shell script
  • Example#455 - 试图以命令行方式运行的 PHP 脚本（script.php）
  • Example#456 - 运行 PHP 命令行脚本的批处理文件（script.bat）
  • Example#457 - Executing code using the interactive shell
  • Example#458 - Tab completion
  • Example#459 - Setting php.ini settings in the interactive shell
  • Example#460 - 启动Web服务器
  • Example#461 - 启动时指定根目录
  • Example#462 - 使用路由（Router）脚本
  • Example#463 - 生成一个新的zval容器
  • Example#464 - 显示zval信息
  • Example#465 - 增加一个zval的引用计数
  • Example#466 - 减少引用计数
  • Example#467 - Creating a array zval
  • Example#468 - 添加一个已经存在的元素到数组中
  • Example#469 - 从数组中删除一个元素
  • Example#470 - 把数组作为一个元素添加到自己
  • Example#471 - Unsetting $a
  • Example#472 - Memory usage example
  • Example#473 - GC性能影响
  • Example#474 - 执行以上脚本
  • Example#475 - 重新编译PHP以启用GC benchmarking
  • Example#476 - GC 统计数据
  • Example#477 - all_probes.d for tracing all PHP Static Probes with DTrace
  • Example#478 - all_probes.stp for tracing all PHP Static Probes with SystemTap
  • Example#479 - A apcu_add example
  • Example#480 - A apcu_cache_info example
  • Example#481 - apcu_cas example
  • Example#482 - apcu_dec example
  • Example#483 - A apcu_delete example
  • Example#484 - An apcu_entry example
  • Example#485 - apcu_exists example
  • Example#486 - A apcu_fetch example
  • Example#487 - apcu_inc example
  • Example#488 - A apcu_key_info example
  • Example#489 - A apcu_sma_info example
  • Example#490 - A apcu_store example
  • Example#491 - A APCUIterator::__construct example
  • Example#492 - 在脚本中使用错误句柄
  • Example#493 - debug_backtrace 范例
  • Example#494 - debug_print_backtrace 范例
  • Example#495 - error_clear_last 例子
  • Example#496 - An error_get_last 范例
  • Example#497 - error_log 范例
  • Example#498 - error_reporting 范例
  • Example#499 - restore_error_handler 范例
  • Example#500 - restore_exception_handler 范例
  • Example#501 - 用 set_error_handler 和 trigger_error 进行错误处理
  • Example#502 - set_exception_handler 范例
  • Example#503 - trigger_error 示例
  • Example#504 - Calling a function from shared library
  • Example#505 - Calling a function, returning a structure through an argument
  • Example#506 - Accessing existing C variables
  • Example#507 - Creating and Modifying C variables
  • Example#508 - Working with C arrays
  • Example#509 - Working with C enums
  • Example#510 -
  • Example#511 -
  • Example#512 - Creating large array in a function
  • Example#513 - 输出控制举例
  • Example#514 - ob_end_clean example
  • Example#515 - ob_end_flush example
  • Example#516 - A simple ob_get_clean example
  • Example#517 - A simple ob_get_contents example
  • Example#518 - ob_get_flush example
  • Example#519 - A simple ob_get_length example
  • Example#520 - ob_gzhandler example
  • Example#521 - ob_list_handlers example
  • Example#522 - 用户自定义回调函数的例子
  • Example#523 - 以兼容 PHP 5.3 和 5.4 的方式创建一个不可擦除的输出缓冲区
  • Example#524 - output_add_rewrite_var example
  • Example#525 - output_reset_rewrite_vars example
  • Example#526 - assert_options 例子
  • Example#527 - 使用自定义处理程序处理失败的断言
  • Example#528 - 使用自定义处理器打印描述信息
  • Example#529 - Expectations without a custom exception
  • Example#530 - Expectations with a custom exception
  • Example#531 - cli_get_process_title example
  • Example#532 - cli_set_process_title example
  • Example#533 - dl 例子
  • Example#534 - extension_loaded 例子
  • Example#535 - 一个 gc_enabled 例子
  • Example#536 - gc_status Usage
  • Example#537 - get_current_user 例子
  • Example#538 - get_defined_constants 例子
  • Example#539 - 打印 XML 函数
  • Example#540 - get_include_path 例子
  • Example#541 - get_included_files 范例
  • Example#542 - get_loaded_extensions 范例
  • Example#543 - get_magic_quotes_runtime 例子
  • Example#544 - Unfiltered get_resources
  • Example#545 - Filtered get_resources
  • Example#546 - getenv 例子
  • Example#547 - getlastmod 例子
  • Example#548 - getopt 例子：基本用法
  • Example#549 - getopt 例子：引入长选项
  • Example#550 - getopt 例子：传递同一多个选项
  • Example#551 - getopt 例子：使用 optind
  • Example#552 - getrusage 例子
  • Example#553 - ini_get_all 例子
  • Example#554 - 禁用 details
  • Example#555 - 一些 ini_get 例子
  • Example#556 - ini_restore 例子
  • Example#557 - 设置一个 ini 选项
  • Example#558 - 一个 memory_get_usage 例子
  • Example#559 - php_ini_loaded_file 例子
  • Example#560 - 列出返回的 ini 文件的简单例子
  • Example#561 - php_sapi_name 例子
  • Example#562 - 一些 php_uname 的例子
  • Example#563 - 一些系统相关常量的例子
  • Example#564 - 打印普遍名单
  • Example#565 - 打印核心开发者和文档组
  • Example#566 - 打印所有贡献者
  • Example#567 - phpinfo 范例
  • Example#568 - phpversion 范例
  • Example#569 - PHP_VERSION_ID 范例和用法
  • Example#570 - 设置一个环境变量
  • Example#571 - restore_include_path 例子
  • Example#572 - set_include_path 例子
  • Example#573 - 添加到include path
  • Example#574 - sys_get_temp_dir 例子
  • Example#575 - version_compare examples
  • Example#576 - zend_thread_id 例子
  • Example#577 - zend_version 例子
  • Example#578 - Custom Superglobals with runkit.superglobal=_FOO,_BAR in php.ini
  • Example#579 - A runkit7_function_add example
  • Example#580 - A runkit7_function_copy example
  • Example#581 - A runkit7_function_redefine example
  • Example#582 - runkit7_method_add example
  • Example#583 - runkit7_method_copy example
  • Example#584 - runkit7_method_redefine example
  • Example#585 - runkit7_method_remove example
  • Example#586 - runkit7_method_rename example
  • Example#587 - Basic uopz_add_function Usage
  • Example#588 - uopz_allow_exit example
  • Example#589 - uopz_backup example
  • Example#590 - uopz_compose example
  • Example#591 - uopz_copy example
  • Example#592 - Basic uopz_del_function Usage
  • Example#593 - uopz_delete example
  • Example#594 - uopz_delete class example
  • Example#595 - uopz_extend example
  • Example#596 - uopz_flags example
  • Example#597 - "Unfinalize" a Class
  • Example#598 - uopz_function example
  • Example#599 - uopz_function class example
  • Example#600 - uopz_get_exit_status example
  • Example#601 - Basic uopz_get_hook Usage
  • Example#602 - uopz_get_mock example
  • Example#603 - Basic uopz_get_property Usage
  • Example#604 - uopz_get_return example
  • Example#605 - Basic uopz_get_static Usage
  • Example#606 - uopz_implement example
  • Example#607 - uopz_overload example
  • Example#608 - uopz_redefine example
  • Example#609 - uopz_rename example
  • Example#610 - uopz_rename class example
  • Example#611 - uopz_restore example
  • Example#612 - Basic uopz_set_hook Usage
  • Example#613 - uopz_set_mock example
  • Example#614 - uopz_set_mock example
  • Example#615 - uopz_set_mock and static members
  • Example#616 - Basic uopz_set_property Usage
  • Example#617 - uopz_set_return example
  • Example#618 - uopz_set_return example
  • Example#619 - uopz_set_return class example
  • Example#620 - Basic uopz_set_static Usage
  • Example#621 - uopz_undefine example
  • Example#622 - Basic uopz_unset_hook Usage
  • Example#623 - uopz_unset_mock example
  • Example#624 - uopz_unset_return example
  • Example#625 - Weakref usage example
  • Example#626 - WeakRef usage example
  • Example#627 - Weakref::acquire example
  • Example#628 - Nested acquire/release example
  • Example#629 - Weakref::__construct example
  • Example#630 - Weakref::release example
  • Example#631 - Weakmap usage example
  • Example#632 - wincache.ignorelist example
  • Example#633 - Authentication configuration for wincache.php
  • Example#634 - Enabling WinCache session handler
  • Example#635 - Enabling WinCache functions reroutes
  • Example#636 - Reroute.ini file content
  • Example#637 - A wincache_fcache_fileinfo example
  • Example#638 - A wincache_fcache_meminfo example
  • Example#639 - Using wincache_lock
  • Example#640 - A wincache_ocache_fileinfo example
  • Example#641 - A wincache_ocache_meminfo example
  • Example#642 - A wincache_refresh_if_changed example
  • Example#643 - A wincache_rplist_fileinfo example
  • Example#644 - A wincache_rplist_meminfo example
  • Example#645 - A wincache_scache_info example
  • Example#646 - A wincache_scache_meminfo example
  • Example#647 - wincache_ucache_add with key as a string
  • Example#648 - wincache_ucache_add with key as an array
  • Example#649 - Using wincache_ucache_cas
  • Example#650 - using wincache_ucache_clear
  • Example#651 - Using wincache_ucache_dec
  • Example#652 - Using wincache_ucache_delete with key as a string
  • Example#653 - Usingwincache_ucache_delete with key as an array
  • Example#654 - Using wincache_ucache_delete with key as an array where some elements cannot be deleted
  • Example#655 - Using wincache_ucache_exists
  • Example#656 - wincache_ucache_get with key as a string
  • Example#657 - wincache_ucache_get with key as an array
  • Example#658 - Using wincache_ucache_inc
  • Example#659 - Using wincache_ucache_info
  • Example#660 - A wincache_ucache_meminfo example
  • Example#661 - wincache_ucache_set with key as a string
  • Example#662 - wincache_ucache_set with key as an array
  • Example#663 - Using wincache_unlock
  • Example#664 - Xhprof 范例，可选使用图形界面
  • Example#665 - xhprof_disable 范例
  • Example#666 - xhprof_enable 范例
  • Example#667 - xhprof_sample_disable 范例
  • Example#668 - Make sure the item is stored
  • Example#669 - Using CHAP passwords
  • Example#670 - radius_acct_open example
  • Example#671 - radius_add_server example
  • Example#672 - radius_auth_open example
  • Example#673 - radius_create_request example
  • Example#674 - radius_cvt_addr example
  • Example#675 - radius_cvt_int example
  • Example#676 - radius_cvt_string example
  • Example#677 - radius_get_attr example
  • Example#678 - radius_get_tagged_attr_data example
  • Example#679 - radius_get_tagged_attr_tag example
  • Example#680 - radius_get_vendor_attr example
  • Example#681 - radius_put_attr example
  • Example#682 - radius_put_int example
  • Example#683 - radius_put_string example
  • Example#684 - radius_put_vendor_attr example
  • Example#685 - Writing a string with a specified color to the screen
  • Example#686 - ncurses_getmouse example
  • Example#687 - Writing a string with a specified color to the screen
  • Example#688 - Writing a string with a specified color to the screen
  • Example#689 - ncurses_mousemask example
  • Example#690 - Writing a string with a specified color to the screen
  • Example#691 - Readline Callback Interface Example
  • Example#692 - readline Example
  • Example#693 - bzip2 小例子
  • Example#694 - 压缩数据
  • Example#695 - 解压一个字符串
  • Example#696 - bzerror 范例
  • Example#697 - bzopen 范例
  • Example#698 - bzread 范例
  • Example#699 - bzwrite 范例
  • Example#700 - Using an external file
  • Example#701 - Using a file within a phar archive
  • Example#702 - Converting a phar archive from phar to tar file format
  • Example#703 - phar.cache_list usage example
  • Example#704 - 一个 Phar::addEmptyDir 示例
  • Example#705 - 一个 Phar::addFile 示例
  • Example#706 - 一个 Phar::addFromString 示例
  • Example#707 - A Phar::apiVersion example
  • Example#708 - A Phar::buildFromDirectory example
  • Example#709 - A Phar::buildFromIterator with SplFileInfo
  • Example#710 - A Phar::buildFromIterator with other iterators
  • Example#711 - A Phar::canCompress example
  • Example#712 - A Phar::canWrite example
  • Example#713 - A Phar::compress example
  • Example#714 - A Phar::compressFiles example
  • Example#715 - A Phar::__construct example
  • Example#716 - A Phar::convertToData example
  • Example#717 - A Phar::convertToExecutable example
  • Example#718 - A Phar::copy example
  • Example#719 - A Phar::count example
  • Example#720 - A Phar::createDefaultStub example
  • Example#721 - A Phar::decompress example
  • Example#722 - A Phar::decompressFiles example
  • Example#723 - A Phar::delMetaData example
  • Example#724 - 一个 Phar::delete 示例
  • Example#725 - A Phar::extractTo example
  • Example#726 - A Phar::getMetadata example
  • Example#727 - A Phar::getStub example
  • Example#728 - A Phar::hasMetadata example
  • Example#729 - A Phar::interceptFileFuncs example
  • Example#730 - A Phar::interceptFileFuncs example
  • Example#731 - A Phar::isBuffering example
  • Example#732 - A Phar::isCompressed example
  • Example#733 - A Phar::loadPhar example
  • Example#734 - A Phar::mapPhar example
  • Example#735 - A Phar::mount example
  • Example#736 - A Phar::mungServer example
  • Example#737 - A Phar::offsetExists example
  • Example#738 - Phar::offsetGet example
  • Example#739 - A Phar::offsetSet example
  • Example#740 - A Phar::offsetUnset example
  • Example#741 - A Phar::running example
  • Example#742 - A Phar::setAlias example
  • Example#743 - A Phar::setDefaultStub example
  • Example#744 - A Phar::setMetadata example
  • Example#745 - A Phar::setStub example
  • Example#746 - A Phar::startBuffering example
  • Example#747 - A Phar::stopBuffering example
  • Example#748 - A Phar::unlinkArchive example
  • Example#749 - A Phar::webPhar example
  • Example#750 - A PharData::addEmptyDir example
  • Example#751 - A PharData::addFile example
  • Example#752 - A PharData::addFromString example
  • Example#753 - A PharData::buildFromDirectory example
  • Example#754 - A PharData::buildFromIterator with SplFileInfo
  • Example#755 - A PharData::buildFromIterator with other iterators
  • Example#756 - A PharData::compress example
  • Example#757 - A PharData::compressFiles example
  • Example#758 - A PharData::__construct example
  • Example#759 - A PharData::convertToData example
  • Example#760 - A PharData::convertToExecutable example
  • Example#761 - A PharData::copy example
  • Example#762 - A PharData::decompress example
  • Example#763 - A PharData::decompressFiles example
  • Example#764 - A PharData::delMetaData example
  • Example#765 - A PharData::delete example
  • Example#766 - A PharData::extractTo example
  • Example#767 - A PharData::offsetSet example
  • Example#768 - A PharData::offsetUnset example
  • Example#769 - A Phar::setMetadata example
  • Example#770 - A PharFileInfo::chmod example
  • Example#771 - A PharFileInfo::compress example
  • Example#772 - A PharFileInfo::__construct example
  • Example#773 - A PharFileInfo::decompress example
  • Example#774 - A PharFileInfo::delMetaData example
  • Example#775 - A PharFileInfo::getCRC32 example
  • Example#776 - A PharFileInfo::getCompressedSize example
  • Example#777 - A PharFileInfo::getMetadata example
  • Example#778 - A PharFileInfo::getPharFlags example
  • Example#779 - A PharFileInfo::isCRCChecked example
  • Example#780 - A PharFileInfo::isCompressed example
  • Example#781 - A PharFileInfo::setMetadata example
  • Example#782 - Rar installation
  • Example#783 - On-the-fly decompression
  • Example#784 - RAR extension filesystem extraction example
  • Example#785 - 面向对象风格
  • Example#786 - 过程化风格
  • Example#787 - 面向对象风格
  • Example#788 - 过程化风格
  • Example#789 - 面向对象风格
  • Example#790 - 过程化风格
  • Example#791 - 面向对象风格
  • Example#792 - 过程化风格
  • Example#793 - 面向对象风格
  • Example#794 - 过程化风格
  • Example#795 - 面向对象风格
  • Example#796 - 过程化风格
  • Example#797 - 面向对象风格
  • Example#798 - 过程化风格
  • Example#799 - Volume Callback
  • Example#800 - 面向对象风格
  • Example#801 - 过程化风格
  • Example#802 - RarArchive::__toString example
  • Example#803 - RarEntry::extract example
  • Example#804 - How to extract all files in archive:
  • Example#805 - RarEntry::getAttr example
  • Example#806 - RarEntry::getHostOs example (version >= 2.0.0)
  • Example#807 - RarEntry::getHostOs example (version <= 1.0.0)
  • Example#808 - RarEntry::getMethod example
  • Example#809 - RarEntry::getName example
  • Example#810 - RarEntry::getPackedSize example
  • Example#811 - RarEntry::getStream example
  • Example#812 - RarEntry::getUnpackedSize example
  • Example#813 - RarEntry::getVersion example
  • Example#814 - RarException::isUsingExceptions example
  • Example#815 - RarException::setUsingExceptions example
  • Example#816 - 创建一个 Zip 归档
  • Example#817 - 输出文档细节和列表
  • Example#818 - Zip 流封装，读取一个 OpenOffice 文件的元信息
  • Example#819 - Zip 使用范例
  • Example#820 - Create a new directory in an archive
  • Example#821 - Open and add
  • Example#822 - Add an entry to a new archive
  • Example#823 - Add file to a directory inside an archive
  • Example#824 - ZipArchive::addGlob example
  • Example#825 - ZipArchive::addPattern example
  • Example#826 - Delete file from archive using its index
  • Example#827 - Deleting a file and directory from an archive, using names
  • Example#828 - Extract all entries
  • Example#829 - Extract two entries
  • Example#830 - Dump an archive comment
  • Example#831 - Dump an entry comment
  • Example#832 - Dump an entry comment
  • Example#833 - Extract all entries with Unix rights
  • Example#834 - Get the file contents
  • Example#835 - Get the file contents
  • Example#836 - Convert an image from a zip entry
  • Example#837 - ZipArchive::getNameIndex example
  • Example#838 - Get the entry contents with fread and store it
  • Example#839 - Same as the previous example but with fopen and the zip stream wrapper
  • Example#840 - Stream wrapper and image, can be used with the xml function as well
  • Example#841 - Create an archive and then use it with ZipArchive::locateName
  • Example#842 - Open and extract
  • Example#843 - Create an archive
  • Example#844 - Create an temporary archive
  • Example#845 - Archive a file
  • Example#846 - Archive a file
  • Example#847 - Rename one entry
  • Example#848 - Rename one entry
  • Example#849 - Open and replace
  • Example#850 - Create an archive and set a comment
  • Example#851 - Open an archive and set a comment for an entry
  • Example#852 - Open an archive and set a comment for an entry
  • Example#853 - Add files with different compression methods to an archive
  • Example#854 - Add files with different compression methods to an archive
  • Example#855 - Add file and set compression method
  • Example#856 - Archive and encrypt a file
  • Example#857 - Archive a file, with its Unix rights
  • Example#858 - Archive a file
  • Example#859 - Archive a file
  • Example#860 - Dump the stat info of an entry
  • Example#861 - Dump the stat info of an entry
  • Example#862 - Small Zlib Example
  • Example#863 - Working with the incremental compression and decompression API as of PHP 7.0.0
  • Example#864 - gzclose example
  • Example#865 - gzcompress example
  • Example#866 - gzdeflate example
  • Example#867 - Creating a gzip file
  • Example#868 - gzeof example
  • Example#869 - gzfile example
  • Example#870 - gzgetc example
  • Example#871 - gzgets example
  • Example#872 - gzgetss example
  • Example#873 - gzinflate example
  • Example#874 - gzopen Example
  • Example#875 - gzpassthru example
  • Example#876 - gzread example
  • Example#877 - gzseek example
  • Example#878 - gzuncompress example
  • Example#879 - gzwrite example
  • Example#880 - zlib_encode example
  • Example#881 - random_bytes example
  • Example#882 - random_int example
  • Example#883 - hash_algos 例程
  • Example#884 - hash_copy 例程
  • Example#885 - hash_equals 例程
  • Example#886 - 使用 hash_file
  • Example#887 - hash_final 例程
  • Example#888 - hash_hkdf example
  • Example#889 - hash_hmac_algos example
  • Example#890 - hash_hmac_file 例程
  • Example#891 - hash_hmac 例程
  • Example#892 - 增量哈希运算例程
  • Example#893 - hash_pbkdf2 例程，基础用法
  • Example#894 - hash_update_stream 例程
  • Example#895 - 一个 hash 例程
  • Example#896 - 使用 PHP 5.4 或者更高版本计算 tiger 哈希值
  • Example#897 - 在 2.4.x 或更高版本，使用 256 比特的密钥，AES 算法和 CBC 模式来加密输入数据
  • Example#898 - mcrypt_create_iv 例程
  • Example#899 - mcrypt_enc_get_algorithms_name 例程
  • Example#900 - mcrypt_enc_get_modes_name 例程
  • Example#901 - mcrypt_enc_get_supported_key_sizes 例程
  • Example#902 - mcrypt_encrypt 例程
  • Example#903 - mcrypt_get_block_size 例程
  • Example#904 - mcrypt_get_cipher_name 例程
  • Example#905 - mcrypt_get_iv_size 例程
  • Example#906 - mcrypt_get_key_size 例程
  • Example#907 - mcrypt_list_algorithms 例程
  • Example#908 - mcrypt_list_modes 例程
  • Example#909 - mcrypt_module_open 例程
  • Example#910 - 在加密中使用 mcrypt_module_open
  • Example#911 - mcrypt_module_self_test 例程
  • Example#912 - mdecrypt_generic 例程
  • Example#913 - Computes the MD5 digest and hmac and print it out as hex
  • Example#914 - Traversing all hashes
  • Example#915 - mhash_get_block_size Example
  • Example#916 - mhash_get_hash_name Example
  • Example#917 - openssl_cipher_iv_length 范例
  • Example#918 - openssl_csr_export_to_file() 范例
  • Example#919 - openssl_csr_export() 范例
  • Example#920 - openssl_csr_get_public_key() example
  • Example#921 - openssl_csr_get_subject() 范例
  • Example#922 - 创建一个自签名的证书
  • Example#923 - 在PHP 7.1+版本中创建一个自签名的ECC证书
  • Example#924 - openssl_csr_sign example - signing a CSR (how to implement your own CA)
  • Example#925 - PHP 7.1+ 下 GCM 模式的 AES 认证加密例子
  • Example#926 - PHP 5.6+ 的 AES 认证加密例子
  • Example#927 - openssl_error_string example
  • Example#928 - openssl_get_cert_locations 范例
  • Example#929 - openssl_get_cipher_methods example
  • Example#930 - openssl_get_curve_names 范例
  • Example#931 - openssl_get_md_methods 范例：
  • Example#932 - openssl_open 范例
  • Example#933 - openssl_pbkdf2() 范例
  • Example#934 - openssl_pkcs12_read 范例
  • Example#935 - openssl_pkcs7_decrypt 范例
  • Example#936 - openssl_pkcs7_encrypt 范例
  • Example#937 - openssl_pkcs7_sign 范例
  • Example#938 - openssl_pkey_derive example
  • Example#939 - Obtain the public key from a private key
  • Example#940 - openssl_random_pseudo_bytes 范例：
  • Example#941 - openssl_seal 范例：
  • Example#942 - openssl_sign example
  • Example#943 - openssl_sign example
  • Example#944 - openssl_spki_export_challenge 范例：
  • Example#945 - openssl_spki_export_challenge 来自 <keygen> 元素的范例：
  • Example#946 - openssl_spki_export 范例：
  • Example#947 - openssl_spki_export example from <keygen>
  • Example#948 - openssl_spki_new 范例：
  • Example#949 - openssl_spki_verify 范例：
  • Example#950 - openssl_spki_verify example from <keygen>
  • Example#951 - openssl_verify 范例：
  • Example#952 - openssl_verify 范例：
  • Example#953 - openssl_x509_verify example
  • Example#954 - Basic password usage
  • Example#955 - password_hash 例子
  • Example#956 - password_hash 手动设置 cost 的例子
  • Example#957 - 寻找最佳 cost 的 password_hash 例子
  • Example#958 - 使用 Argon2i 的password_hash例子
  • Example#959 - password_needs_rehash用法
  • Example#960 - password_verify 例子
  • Example#961 - sodium_crypto_kx_keypair usage
  • Example#962 - password_hash example
  • Example#963 - password_hash example
  • Example#964 - DBA example
  • Example#965 - Traversing a database
  • Example#966 - dba_handlers Example
  • Example#967 - List Privileges for a Column
  • Example#968 - List Columns of a Table
  • Example#969 - DSN-less connections
  • Example#970 - List available DSNs
  • Example#971 - odbc_execute and odbc_prepare example
  • Example#972 - odbc_fetch_into examples
  • Example#973 - odbc_next_result
  • Example#974 - odbc_execute and odbc_prepare example
  • Example#975 - List primary Keys of a Column
  • Example#976 - List Columns of a stored Procedure
  • Example#977 - List stored Procedures of a Database
  • Example#978 - odbc_result examples
  • Example#979 - odbc_setoption examples
  • Example#980 - List Statistics of a Table
  • Example#981 - List Privileges of a Table
  • Example#982 - List Tables in a Catalog
  • Example#983 - 使用 PDO::ATTR_DRIVER_NAME 的例子
  • Example#984 - 连接到 MySQL
  • Example#985 - 处理连接错误
  • Example#986 - 关闭一个连接
  • Example#987 - 持久化连接
  • Example#988 - 在事务中执行批处理
  • Example#989 - 用预处理语句进行重复插入
  • Example#990 - 用预处理语句进行重复插入
  • Example#991 - 使用预处理语句获取数据
  • Example#992 - 带输出参数调用存储过程
  • Example#993 - 带输入/输出参数调用存储过程
  • Example#994 - 占位符的无效使用
  • Example#995 - 创建 PDO 实例并设置错误模式
  • Example#996 - 创建 PDO 实例并在构造函数中设置错误模式
  • Example#997 - 从数据库中显示一张图片
  • Example#998 - 插入一张图片到数据库
  • Example#999 - 插入一张图片到数据库：Oracle
  • Example#1000 - 回滚一个事务
  • Example#1001 - 提交一个基础事务
  • Example#1002 - 提交一个DDL事务
  • Example#1003 - Create a PDO instance via driver invocation
  • Example#1004 - Create a PDO instance via URI invocation
  • Example#1005 - 使用别名创建一个PDO实例
  • Example#1006 - 取得一个 SQLSTATE 码
  • Example#1007 - Displaying errorInfo() fields for a PDO_ODBC connection to a DB2 database
  • Example#1008 - 发出一条 DELETE 语句
  • Example#1009 - 取回数据库连接属性
  • Example#1010 - 一个 PDO::getAvailableDrivers 的例子
  • Example#1011 - 用命名参数形式准备 SQL 语句参数
  • Example#1012 - 用问号形式准备 SQL 语句参数
  • Example#1013 - 展示 PDO::query 的使用
  • Example#1014 - 普通字符串加引号
  • Example#1015 - 危险字符串加引号
  • Example#1016 - 复杂字符串加引号
  • Example#1017 - 回滚一个事务
  • Example#1018 - 把结果集输出绑定到 PHP 变量
  • Example#1019 - 执行一条使用命名占位符的预处理语句
  • Example#1020 - 执行一条使用问号占位符的预处理语句
  • Example#1021 - 使用 INOUT 参数调用一个存储过程
  • Example#1022 - 执行一条使用命名占位符的预处理语句
  • Example#1023 - 执行一条使用问号占位符的预处理语句
  • Example#1024 - 一个 PDOStatement::closeCursor 的例子
  • Example#1025 - 计算列数
  • Example#1026 - PDOStatement::debugDumpParams 使用命名参数的例子
  • Example#1027 - PDOStatement::debugDumpParams 使用未命名参数的例子
  • Example#1028 - 取回一个 SQLSTATE 码
  • Example#1029 - 显示连接到DB2数据库的 PDO_ODBC 连接的 errorInfo() 的字段
  • Example#1030 - 执行一条绑定变量的预处理语句
  • Example#1031 - 使用一个含有插入值的数组执行一条预处理语句（命名参数）
  • Example#1032 - 使用一个含有插入值的数组执行一条预处理语句（占位符）
  • Example#1033 - 执行一条问号占位符的预处理语句
  • Example#1034 - 使用数组执行一条含有 IN 子句的预处理语句
  • Example#1035 - 使用不同的提取方式获取行
  • Example#1036 - 使用一个可滚动游标获取行
  • Example#1037 - 获取结果集中所有剩余的行
  • Example#1038 - 获取结果集中单独一列的所有值
  • Example#1039 - 根据单独的一列把所有值分组
  • Example#1040 - 每行结果实例化一个类
  • Example#1041 - 每行调用一次函数
  • Example#1042 - 返回下一行的第一列
  • Example#1043 - 检索列的元数据
  • Example#1044 - 获取由一个存储过程返回的多个行集
  • Example#1045 - 返回删除的行数
  • Example#1046 - 计算由一个 SELECT 语句返回的行数
  • Example#1047 - 设置获取模式
  • Example#1048 - Insert LOBs in CUBRID PDO
  • Example#1049 - Fetch LOBs in CUBRID PDO
  • Example#1050 - Insert set in CUBRID PDO with default data type.
  • Example#1051 - Specify data type when insert set in CUBRID PDO
  • Example#1052 - PDO_CUBRID DSN examples
  • Example#1053 - A PDO::cubrid_schema example
  • Example#1054 - PDO_DBLIB DSN examples
  • Example#1055 - PDO_FIREBIRD DSN example with path
  • Example#1056 - PDO_FIREBIRD DSN example with port and path
  • Example#1057 - PDO_FIREBIRD DSN example with localhost and path to employee.fdb on Debian system
  • Example#1058 - PDO_FIREBIRD DSN to connect to a dialect 1 database
  • Example#1059 - PDO_IBM DSN example using db2cli.ini
  • Example#1060 - PDO_IBM DSN example using a connection string
  • Example#1061 - PDO_INFORMIX DSN example using odbc.ini
  • Example#1062 - PDO_INFORMIX DSN example using a connection string
  • Example#1063 - Forcing queries to be buffered in mysql
  • Example#1064 - PDO_MYSQL DSN examples
  • Example#1065 - PDO_SQLSRV DSN examples
  • Example#1066 - PDO_OCI DSN examples
  • Example#1067 - PDO_ODBC DSN example (ODBC driver manager)
  • Example#1068 - PDO_ODBC DSN example (IBM DB2 uncataloged connection)
  • Example#1069 - PDO_ODBC DSN example (Microsoft Access uncataloged connection)
  • Example#1070 - PDO_PGSQL DSN examples
  • Example#1071 - A PDO::pgsqlLOBCreate example
  • Example#1072 - A PDO::pgsqlLOBOpen example
  • Example#1073 - A PDO::pgsqlLOBUnlink example
  • Example#1074 - PDO_SQLITE DSN examples
  • Example#1075 - max_length aggregation function example
  • Example#1076 - PDO::sqliteCreateCollation example
  • Example#1077 - PDO::sqliteCreateFunction example
  • Example#1078 - 数据查询的例子
  • Example#1079 - 数据插入的例子
  • Example#1080 - cubrid_bind example
  • Example#1081 - cubrid_bind BLOB/CLOB example
  • Example#1082 - cubrid_bind BLOB/CLOB example
  • Example#1083 - cubrid_close_prepare example
  • Example#1084 - cubrid_close_request example
  • Example#1085 - cubrid_col_get example
  • Example#1086 - cubrid_col_size example
  • Example#1087 - cubrid_column_names example
  • Example#1088 - cubrid_column_types example
  • Example#1089 - cubrid_commit example
  • Example#1090 - cubrid_connect_with_url url without properties example
  • Example#1091 - cubrid_connect_with_url url with properties example
  • Example#1092 - cubrid_connect example
  • Example#1093 - cubrid_current_oid example
  • Example#1094 - cubrid_disconnect example
  • Example#1095 - cubrid_drop example
  • Example#1096 - cubrid_error_code_facility example
  • Example#1097 - cubrid_error_code example
  • Example#1098 - cubrid_error_msg example
  • Example#1099 - cubrid_execute example
  • Example#1100 - cubrid_fetch example
  • Example#1101 - cubrid_free_result example
  • Example#1102 - cubrid_get_charset example
  • Example#1103 - cubrid_get_class_name example
  • Example#1104 - cubrid_get_client_info example
  • Example#1105 - cubrid_get_db_parameter example
  • Example#1106 - cubrid_get_query_timeout example
  • Example#1107 - cubrid_get_server_info example
  • Example#1108 - cubrid_get example
  • Example#1109 - cubrid_insert_id example
  • Example#1110 - cubrid_is_instance example
  • Example#1111 - cubrid_lob_close example
  • Example#1112 - cubrid_lob_export example
  • Example#1113 - cubrid_lob_get example
  • Example#1114 - cubrid_lob_send example
  • Example#1115 - cubrid_lob_size example
  • Example#1116 - cubrid_lob2_bind example
  • Example#1117 - cubrid_lob2_export example
  • Example#1118 - cubrid_lob2_export example
  • Example#1119 - cubrid_lob2_read example 1
  • Example#1120 - cubrid_lob2_read example 2
  • Example#1121 - cubrid_lob2_seek64 example
  • Example#1122 - cubrid_lob2_seek example
  • Example#1123 - cubrid_lob2_write example 1
  • Example#1124 - cubrid_lob2_write example 2
  • Example#1125 - cubrid_lock_read example
  • Example#1126 - cubrid_lock_write example
  • Example#1127 - cubrid_move_cursor example
  • Example#1128 - cubrid_next_result example
  • Example#1129 - cubrid_num_cols example
  • Example#1130 - cubrid_num_rows example
  • Example#1131 - cubrid_pconnect_with_url url without properties example
  • Example#1132 - cubrid_pconnect_with_url url with properties example
  • Example#1133 - cubrid_connect example
  • Example#1134 - cubrid_prepare example
  • Example#1135 - cubrid_put example
  • Example#1136 - cubrid_rollback example
  • Example#1137 - cubrid_schema example
  • Example#1138 - cubrid_seq_drop example
  • Example#1139 - cubrid_seq_insert example
  • Example#1140 - cubrid_seq_put example
  • Example#1141 - cubrid_set_add example
  • Example#1142 - cubrid_get_db_parameter example
  • Example#1143 - cubrid_set_drop example
  • Example#1144 - cubrid_version example
  • Example#1145 - cubrid_affected_rows example
  • Example#1146 - cubrid_client_encoding example
  • Example#1147 - cubrid_close example
  • Example#1148 - cubrid_data_seek example
  • Example#1149 - cubrid_db_name example
  • Example#1150 - cubrid_errno example
  • Example#1151 - cubrid_error example
  • Example#1152 - cubrid_fetch_array example
  • Example#1153 - cubrid_fetch_assoc example
  • Example#1154 - cubrid_fetch_field example
  • Example#1155 - cubrid_fetch_lengths example
  • Example#1156 - cubrid_fetch_object example
  • Example#1157 - cubrid_fetch_row example
  • Example#1158 - cubrid_field_flags example
  • Example#1159 - cubrid_field_len example
  • Example#1160 - cubrid_field_name example
  • Example#1161 - cubrid_field_seek example
  • Example#1162 - cubrid_field_table example
  • Example#1163 - cubrid_field_type example
  • Example#1164 - cubrid_list_dbs example
  • Example#1165 - cubrid_num_fields example
  • Example#1166 - cubrid_ping example
  • Example#1167 - Invalid Query
  • Example#1168 - Valid Query
  • Example#1169 - cubrid_real_escape_string example
  • Example#1170 - cubrid_result example
  • Example#1171 - cubrid_unbuffered_query example
  • Example#1172 - cubrid_load_from_glo example
  • Example#1173 - cubrid_new_glo example
  • Example#1174 - cubrid_save_to_glo example
  • Example#1175 - cubrid_send_glo example
  • Example#1176 - Inserting a record in a dBase database
  • Example#1177 - Closing a dBase database file
  • Example#1178 - Creating a dBase database file
  • Example#1179 - Showing header information for a dBase database file
  • Example#1180 - Listing all the registered members in the database
  • Example#1181 - dbase_numfields Example
  • Example#1182 - Looping over all the records of the database
  • Example#1183 - Opening a dBase database file
  • Example#1184 - Emptying a dBase database
  • Example#1185 - Updating a record in the database
  • Example#1186 - ibase_backup example
  • Example#1187 - ibase_backup example with arguments
  • Example#1188 - ibase_blob_get example
  • Example#1189 - ibase_blob_import example
  • Example#1190 - ibase_connect example
  • Example#1191 - ibase_execute example
  • Example#1192 - ibase_fetch_object example
  • Example#1193 - ibase_field_info example
  • Example#1194 - ibase_name_result example
  • Example#1195 - ibase_num_fields example
  • Example#1196 - ibase_query example
  • Example#1197 - ibase_restore example
  • Example#1198 - ibase_restore example with arguments
  • Example#1199 - ibase_service_attach example
  • Example#1200 - ibase_service_attach example
  • Example#1201 - ibase_service_attach example using hostname/port syntax
  • Example#1202 - ibase_service_detach example
  • Example#1203 - ibase_set_event_handler example
  • Example#1204 - fbsql_close example
  • Example#1205 - fbsql_connect example
  • Example#1206 - fbsql_create_blob example
  • Example#1207 - fbsql_create_clob example
  • Example#1208 - fbsql_create_db example
  • Example#1209 - fbsql_data_seek example
  • Example#1210 - fbsql_create_clob example
  • Example#1211 - fbsql_errno Example
  • Example#1212 - fbsql_error Example
  • Example#1213 - fbsql_fetch_array example
  • Example#1214 - fbsql_fetch_assoc example
  • Example#1215 - fbsql_fetch_field example
  • Example#1216 - fbsql_fetch_object example
  • Example#1217 - fbsql_field_name example
  • Example#1218 - fbsql_field_type example
  • Example#1219 - fbsql_list_dbs example
  • Example#1220 - fbsql_list_fields example
  • Example#1221 - fbsql_next_result example
  • Example#1222 - fbsql_num_rows example
  • Example#1223 - fbsql_query example
  • Example#1224 - fbsql_query example
  • Example#1225 - fbsql_read_blob example
  • Example#1226 - fbsql_read_clob example
  • Example#1227 - fbsql_table_name example
  • Example#1228 - Retrieving the AUTOCOMMIT value for a connection
  • Example#1229 - Setting the AUTOCOMMIT value for a connection
  • Example#1230 - Binding PHP variables to a prepared statement
  • Example#1231 - Calling stored procedures with IN and OUT parameters
  • Example#1232 - Inserting a binary large object (BLOB) directly from a file
  • Example#1233 - A db2_client_info example
  • Example#1234 - Closing a connection
  • Example#1235 - Retrieving an SQLSTATE value for a failed connection attempt
  • Example#1236 - Retrieving the error message returned by a failed connection attempt
  • Example#1237 - Creating a cataloged connection
  • Example#1238 - Creating an uncataloged connection
  • Example#1239 - Creating a connection with autocommit off by default
  • Example#1240 - i5/OS best performance
  • Example#1241 - Using trusted context
  • Example#1242 - A db2_escape_string example
  • Example#1243 - Creating a table with db2_exec
  • Example#1244 - Executing a SELECT statement with a scrollable cursor
  • Example#1245 - Returning XML data as an SQL ResultSet
  • Example#1246 - Performing a "JOIN" with XML data
  • Example#1247 - Returning SQL data as part of a larger XML document
  • Example#1248 - Preparing and executing an SQL statement with parameter markers
  • Example#1249 - Calling a stored procedure with an OUT parameter
  • Example#1250 - Returning XML data as an SQL ResultSet
  • Example#1251 - Performing a "JOIN" with XML data
  • Example#1252 - Returning SQL data as part of a larger XML document
  • Example#1253 - Iterating through a forward-only cursor
  • Example#1254 - Retrieving specific rows with db2_fetch_array from a scrollable cursor
  • Example#1255 - Iterating through a forward-only cursor
  • Example#1256 - Retrieving specific rows with db2_fetch_assoc from a scrollable cursor
  • Example#1257 - Iterating through a forward-only cursor
  • Example#1258 - Retrieving specific rows with db2_fetch_both from a scrollable cursor
  • Example#1259 - A db2_fetch_object example
  • Example#1260 - Iterating through a result set
  • Example#1261 - i5/OS recommended alternatives to db2_fetch_row/db2_result
  • Example#1262 - Setting and retrieving parameters through a connection resource
  • Example#1263 - A db2_last_insert_id example
  • Example#1264 - Iterating through different types of data
  • Example#1265 - Calling a stored procedure that returns multiple result sets
  • Example#1266 - Retrieving the number of fields in a result set
  • Example#1267 - Closing a persistent connection
  • Example#1268 - A db2_pconnect example
  • Example#1269 - Using trusted context
  • Example#1270 - Preparing and executing an SQL statement with parameter markers
  • Example#1271 - A db2_result example
  • Example#1272 - Rolling back a DELETE statement
  • Example#1273 - A db2_server_info example
  • Example#1274 - Setting one parameter with a connection resource
  • Example#1275 - Setting multiple parameters with a connection resource
  • Example#1276 - Setting multiple parameters with an invalid key
  • Example#1277 - Setting multiple parameters with an invalid value
  • Example#1278 - Setting multiple parameters with a connection resource and the wrong type
  • Example#1279 - Setting multiple parameters with the wrong resource
  • Example#1280 - Putting it all together
  • Example#1281 - i5/OS cursors are read-only
  • Example#1282 - Example usage of PassEnv for Ingres
  • Example#1283 - Simple Ingres Example
  • Example#1284 - ingres_charset - Get the installation character set
  • Example#1285 - Open a connection to an Ingres database
  • Example#1286 - Get cursor name for a query resource
  • Example#1287 - Get the last Ingres error number generated
  • Example#1288 - Get a message for the last error generated
  • Example#1289 - Get the last SQLSTATE error code generated
  • Example#1290 - Escape special characters for use in a query
  • Example#1291 - Fetch a row of result into an array
  • Example#1292 - Fetch a row into an associative array
  • Example#1293 - Fetch a row into an object
  • Example#1294 - Get the return value from a procedure call
  • Example#1295 - Fetch a row of result into an enumerated array
  • Example#1296 - Free a result resource
  • Example#1297 - Send a simple select
  • Example#1298 - Passing query parameters to ingres_query
  • Example#1299 - Inserting a BLOB with parameter types
  • Example#1300 - Position the cursor on the 3rd row
  • Example#1301 - Set date_format to ISO4
  • Example#1302 - Set timezone to HONG-KONG
  • Example#1303 - Issue a simple un-buffered select
  • Example#1304 - Passing query parameters to ingres_unbuffered_query
  • Example#1305 - Inserting a BLOB with parameter types
  • Example#1306 -
  • Example#1307 -
  • Example#1308 -
  • Example#1309 -
  • Example#1310 -
  • Example#1311 -
  • Example#1312 -
  • Example#1313 -
  • Example#1314 -
  • Example#1315 -
  • Example#1316 -
  • Example#1317 -
  • Example#1318 -
  • Example#1319 -
  • Example#1320 -
  • Example#1321 - 查询串语法的读取首选项URI链接
  • Example#1322 - Setting read preferences with array syntax for tag sets
  • Example#1323 - Passing a WriteConcern to a write operation
  • Example#1324 - Connection string WriteConcerns
  • Example#1325 - MongoDB::setWriteConcern and MongoCollection::setWriteConcern
  • Example#1326 - Unacknowledged WriteConcern, followed with Acknowledged Write
  • Example#1327 - Acknowledged Writes
  • Example#1328 - Majority Acknowledged Write
  • Example#1329 - Acknowledged and Journaled Write
  • Example#1330 - 针对“admin”数据库的认证
  • Example#1331 - 针对一般数据库的认证
  • Example#1332 - 链接到一个复制
  • Example#1333 -
  • Example#1334 -
  • Example#1335 -
  • Example#1336 -
  • Example#1337 -
  • Example#1338 - Inheriting read preferences from the database level down to the cursor
  • Example#1339 -
  • Example#1340 -
  • Example#1341 -
  • Example#1342 -
  • Example#1343 -
  • Example#1344 -
  • Example#1345 -
  • Example#1346 - MongoClient 基本用法
  • Example#1347 - MongoClient::close 例子
  • Example#1348 - MongoClient::__construct 集群例子
  • Example#1349 - 连接到一个域套接字（domain socket）
  • Example#1350 - MongoClient::__construct 验证的例子
  • Example#1351 - MongoClient::__construct 读取选项例子
  • Example#1352 - MongoClient::getConnections 例子
  • Example#1353 - MongoClient::getReadPreference 返回值例子
  • Example#1354 - MongoClient::getWriteConcern return value example
  • Example#1355 - MongoClient::killCursor example
  • Example#1356 - MongoClient::listDBs 例子
  • Example#1357 - MongoClient::selectCollection 例子
  • Example#1358 - MongoClient::setReadPreference 标签集数组语法的例子
  • Example#1359 - MongoClient::setWriteConcern example
  • Example#1360 - 选择一个数据库
  • Example#1361 - MongoDB::command "distinct"实例
  • Example#1362 - MongoDB::command "distinct"实例
  • Example#1363 - MongoDB::command MapReduce实例
  • Example#1364 - MongoDB::command "textSearch"实例
  • Example#1365 - MongoDB::command "geoNear"实例
  • Example#1366 - MongoDB::createCollection 固定大小集合 实例
  • Example#1367 - MongoDB::createDBRef实例
  • Example#1368 - MongoDB::createDBRef实例
  • Example#1369 - MongoDB::drop 例子
  • Example#1370 - 简单的 MongoDB::execute 实例
  • Example#1371 - 带参数的 MongoDB::execute 实例
  • Example#1372 - 作用域实例
  • Example#1373 - MongoDB::getCollectionInfo example
  • Example#1374 - MongoDB::getCollectionNames example
  • Example#1375 - MongoDB::getDBRef example
  • Example#1376 - MongoDB::getGridFS example
  • Example#1377 - MongoDB::getReadPreference return value example
  • Example#1378 - MongoDB::getWriteConcern return value example
  • Example#1379 - MongoDB::lastError null error example
  • Example#1380 - MongoDB::lastError duplicate key example
  • Example#1381 - MongoDB::listCollections example
  • Example#1382 - MongoDB::repair example
  • Example#1383 - MongoDB::setReadPreference tag set array syntax example
  • Example#1384 - MongoDB::setWriteConcern example
  • Example#1385 - MongoCollection::aggregate example
  • Example#1386 - MongoCollection::aggregate example
  • Example#1387 - MongoCollection::aggregate example
  • Example#1388 - MongoCollection::aggregate with command options
  • Example#1389 - MongoCollection::aggregateCursor example
  • Example#1390 - MongoCollection::aggregateCursor example with different initial batch size
  • Example#1391 - MongoCollection::batchInsert example
  • Example#1392 - MongoCollection::batchInsert example with ignoring errors
  • Example#1393 - MongoCollection::count 例子
  • Example#1394 - MongoCollection::createDBRef 例子
  • Example#1395 - MongoCollection::createIndex example
  • Example#1396 - Geospatial Indexing
  • Example#1397 - Drop duplicates example
  • Example#1398 - MongoCollection::deleteIndex example
  • Example#1399 - MongoCollection::deleteIndexes 例子
  • Example#1400 - MongoCollection::distinct 例子
  • Example#1401 - 内嵌文档的 MongoCollection::distinct 例子
  • Example#1402 - MongoCollection::drop 例子
  • Example#1403 - MongoCollection::ensureIndex example
  • Example#1404 - Geospatial Indexing
  • Example#1405 - Drop duplicates example
  • Example#1406 - MongoCollection::find 例子
  • Example#1407 - MongoCollection::find 例子
  • Example#1408 - 使用 $where 的 MongoCollection::find 例子
  • Example#1409 - 使用 $in 的 MongoCollection::find 例子
  • Example#1410 - 以数组形式获取结果集
  • Example#1411 - MongoCollection::findAndModify example
  • Example#1412 - MongoCollection::findAndModify error handling
  • Example#1413 - MongoCollection::findOne document by its id.
  • Example#1414 - MongoCollection::findOne document by some condition.
  • Example#1415 - MongoCollection::getDBRef example
  • Example#1416 - MongoCollection::getIndexInfo example
  • Example#1417 - MongoCollection::getName 例子
  • Example#1418 - MongoCollection::getReadPreference return value example
  • Example#1419 - MongoCollection::getWriteConcern return value example
  • Example#1420 - MongoCollection::group example
  • Example#1421 - MongoCollection::group example
  • Example#1422 - Passing a keys function
  • Example#1423 - MongoCollection::insert _id 例子
  • Example#1424 - MongoCollection::insert 确认写入的例子
  • Example#1425 - MongoCollection::parallelCollectionScan example
  • Example#1426 - MongoCollection::remove 的 justOne 例子
  • Example#1427 - MongoCollection::save 例子
  • Example#1428 - MongoCollection::setReadPreference tag set array syntax example
  • Example#1429 - MongoDB::setWriteConcern example
  • Example#1430 - MongoCollection::toIndexString example
  • Example#1431 - MongoCollection::__toString example
  • Example#1432 - MongoCollection::update
  • Example#1433 - MongoCollection::update upsert examples
  • Example#1434 - MongoCollection::update multiple example
  • Example#1435 - MongoCursor basic usage
  • Example#1436 - Iterating over MongoCursor
  • Example#1437 - Adding options to MongoCursor
  • Example#1438 - Adding a comment with MongoCursor::addOption example
  • Example#1439 - MongoCursor::addOption example
  • Example#1440 - MongoCursor::awaitData example
  • Example#1441 - MongoCursor::batchSize and combinations with MongoCursor::limit
  • Example#1442 - MongoCursor::count example
  • Example#1443 - MongoCursor::doQuery example
  • Example#1444 - MongoCursor::explain example
  • Example#1445 - MongoCursor::getReadPreference return value example
  • Example#1446 - MongoCursor::info example
  • Example#1447 - MongoCursor::maxTimeMS example
  • Example#1448 - MongoCursor::setFlag example
  • Example#1449 - MongoCursor::setReadPreference tag set array syntax example
  • Example#1450 - MongoCursor::slaveOkay example
  • Example#1451 - MongoCursor::sort example
  • Example#1452 - MongoCursor::tailable example
  • Example#1453 - MongoCursor::timeout example
  • Example#1454 - Adding options to MongoCommandCursor
  • Example#1455 - MongoCommandCursor::batchSize
  • Example#1456 - MongoCommandCursor example
  • Example#1457 - MongoCommandCursor::createFromDocument
  • Example#1458 - MongoCommandCursor::getReadPreference return value example
  • Example#1459 - MongoCommandCursor::info example
  • Example#1460 - MongoCommandCursor::rewind
  • Example#1461 - MongoCommandCursor::setReadPreference tag set array syntax example
  • Example#1462 - MongoCommandCursor::timeout example
  • Example#1463 - MongoId::__construct 例子
  • Example#1464 - 参数的例子
  • Example#1465 - MongoId::__toString 例子
  • Example#1466 - MongoCode::__construct 例子
  • Example#1467 - 使用具有 $where 的 MongoCode
  • Example#1468 - MongoCode::__toString 例子
  • Example#1469 - Storing dates with MongoDate
  • Example#1470 - MongoDate::__construct 例子
  • Example#1471 - MongoDate::toDateTime example
  • Example#1472 - 正则表达式
  • Example#1473 - MongoRegex::__construct 例子
  • Example#1474 - MongoRegex::__toString 例子
  • Example#1475 -
  • Example#1476 - 链接文档
  • Example#1477 - Creating MongoDBRef links
  • Example#1478 - MongoDBRef::create 例子
  • Example#1479 - MongoCollection::createDBRef 例子
  • Example#1480 - MongoGridFS::findOne example
  • Example#1481 - MongoGridFS::storeBytes with additional metadata
  • Example#1482 - MongoGridFS::storeFile with additional metadata
  • Example#1483 - MongoGridFS::storeUpload HTML form example
  • Example#1484 - MongoGridFSFile::getBytes example
  • Example#1485 - MongoGridFSFile::getResource example
  • Example#1486 - MongoGridFSFile::write example
  • Example#1487 - MongoLog::setCallback example
  • Example#1488 - Changing pool size
  • Example#1489 - Mongo::setPoolSize example
  • Example#1490 - Changing pool size
  • Example#1491 - Mongo::setPoolSize example
  • Example#1492 - MongoResultException::getDocument 例子
  • Example#1493 - Catching MongoDuplicateKeyException
  • Example#1494 - Catching MongoProtocolException
  • Example#1495 - MongoDB\Driver\Manager::__construct basic example
  • Example#1496 - MongoDB\Driver\Manager::__construct basic examples
  • Example#1497 - MongoDB\Driver\Manager::executeBulkWrite example
  • Example#1498 - MongoDB\Driver\Manager::executeCommand with a command returning a single result document
  • Example#1499 - MongoDB\Driver\Manager::executeCommand with a command returning a cursor
  • Example#1500 - Limiting execution time for a command
  • Example#1501 - MongoDB\Driver\Manager::executeQuery example
  • Example#1502 - Limiting execution time for a query
  • Example#1503 - MongoDB\Driver\Manager::getReadConcern example
  • Example#1504 - MongoDB\Driver\Manager::getReadPreference example
  • Example#1505 - MongoDB\Driver\Manager::getServers example
  • Example#1506 - MongoDB\Driver\Manager::getWriteConcern example
  • Example#1507 - Composing MongoDB\Driver\Command to provide a helper to create collections
  • Example#1508 - MongoDB\Driver\Command::__construct example
  • Example#1509 - MongoDB\Driver\Command::__construct example
  • Example#1510 - MongoDB\Driver\Query::__construct example
  • Example#1511 - Mixed write operations are grouped by type
  • Example#1512 - Ordered write operations causing an error
  • Example#1513 - MongoDB\Driver\BulkWrite::__construct example
  • Example#1514 - MongoDB\Driver\BulkWrite::count example
  • Example#1515 - MongoDB\Driver\BulkWrite::delete example
  • Example#1516 - MongoDB\Driver\BulkWrite::insert example
  • Example#1517 - MongoDB\Driver\BulkWrite::update example
  • Example#1518 - MongoDB\Driver\WriteConcern::bsonSerialize with majority write concern
  • Example#1519 - MongoDB\Driver\WriteConcern::bsonSerialize with wtimeout and journal
  • Example#1520 - MongoDB\Driver\WriteConcern::__construct example
  • Example#1521 - MongoDB\Driver\WriteConcern::getJournal example
  • Example#1522 - MongoDB\Driver\WriteConcern::getW example
  • Example#1523 - MongoDB\Driver\WriteConcern::getWtimeout example
  • Example#1524 - MongoDB\Driver\WriteConcern::isDefault example
  • Example#1525 - MongoDB\Driver\ReadPreference::bsonSerialize with primary read preference
  • Example#1526 - MongoDB\Driver\ReadPreference::bsonSerialize with secondary read preference and tag sets
  • Example#1527 - MongoDB\Driver\ReadPreference::bsonSerialize with secondary read preference and max staleness
  • Example#1528 - MongoDB\Driver\ReadPreference::__construct example
  • Example#1529 - MongoDB\Driver\ReadPreference::getMaxStalenessSeconds example
  • Example#1530 - MongoDB\Driver\ReadPreference::getMode example
  • Example#1531 - MongoDB\Driver\ReadPreference::getModeString example
  • Example#1532 - MongoDB\Driver\ReadPreference::getTagSets example
  • Example#1533 - MongoDB\Driver\ReadConcern::bsonSerialize with empty read concern
  • Example#1534 - MongoDB\Driver\ReadConcern::bsonSerialize with local read concern
  • Example#1535 - MongoDB\Driver\ReadConcern::__construct example
  • Example#1536 - MongoDB\Driver\ReadConcern::getLevel example
  • Example#1537 - MongoDB\Driver\ReadConcern::isDefault example
  • Example#1538 - Reading a result set
  • Example#1539 - Reading a result set for a tailable cursor
  • Example#1540 - MongoDB\Driver\Cursor::getId example
  • Example#1541 - MongoDB\Driver\Cursor::getServer example
  • Example#1542 - MongoDB\Driver\Cursor::isDead example
  • Example#1543 - MongoDB\Driver\Cursor::setTypeMap example
  • Example#1544 - MongoDB\Driver\Cursor::toArray example
  • Example#1545 - MongoDB\Driver\CursorId::__toString example
  • Example#1546 - MongoDB\Driver\Server::getHost example
  • Example#1547 - MongoDB\Driver\Server::getInfo example
  • Example#1548 - MongoDB\Driver\Server::getLatency example
  • Example#1549 - MongoDB\Driver\Server::getPort example
  • Example#1550 - MongoDB\Driver\WriteConcernError::getCode example
  • Example#1551 - MongoDB\Driver\WriteConcernError::getInfo example
  • Example#1552 - MongoDB\Driver\WriteConcernError::getMessage example
  • Example#1553 - MongoDB\Driver\WriteError::getCode example
  • Example#1554 - MongoDB\Driver\WriteError::getIndex example
  • Example#1555 - MongoDB\Driver\WriteError::getMessage example
  • Example#1556 - MongoDB\Driver\WriteResult::getDeletedCount example
  • Example#1557 - MongoDB\Driver\WriteResult::getInsertedCount example
  • Example#1558 - MongoDB\Driver\WriteResult::getMatchedCount example
  • Example#1559 - MongoDB\Driver\WriteResult::getModifiedCount example
  • Example#1560 - MongoDB\Driver\WriteResult::getServer example
  • Example#1561 - MongoDB\Driver\WriteResult::getUpsertedCount example
  • Example#1562 - MongoDB\Driver\WriteResult::getUpsertedIds example
  • Example#1563 - MongoDB\Driver\WriteResult::getWriteConcernError example
  • Example#1564 - MongoDB\Driver\WriteResult::getWriteErrors with a single error
  • Example#1565 - MongoDB\Driver\WriteResult::getWriteErrors with multiple errors
  • Example#1566 - MongoDB\Driver\WriteResult::isAcknowledged with acknowledged write concern
  • Example#1567 - MongoDB\Driver\WriteResult::isAcknowledged with unacknowledged write concern
  • Example#1568 - MongoDB\BSON\fromJSON example
  • Example#1569 - MongoDB\BSON\fromPHP example
  • Example#1570 - MongoDB\BSON\toCanonicalExtendedJSON example
  • Example#1571 - MongoDB\BSON\toJSON example
  • Example#1572 - MongoDB\BSON\toPHP example
  • Example#1573 - MongoDB\BSON\toRelaxedExtendedJSON example
  • Example#1574 - MongoDB\BSON\Binary::__construct example
  • Example#1575 - MongoDB\BSON\Binary::getData example
  • Example#1576 - MongoDB\BSON\Binary::getType example
  • Example#1577 - MongoDB\BSON\Binary::__toString example
  • Example#1578 - MongoDB\BSON\Decimal128::__construct example
  • Example#1579 - MongoDB\BSON\Decimal128::__toString example
  • Example#1580 - MongoDB\BSON\Javascript::__construct example
  • Example#1581 - MongoDB\BSON\Javascript::getCode example
  • Example#1582 - MongoDB\BSON\Javascript::getScope example
  • Example#1583 - MongoDB\BSON\Javascript::__toString example
  • Example#1584 - MongoDB\BSON\MaxKey::__construct example
  • Example#1585 - MongoDB\BSON\MinKey::__construct example
  • Example#1586 - MongoDB\BSON\ObjectId::__construct example
  • Example#1587 - MongoDB\BSON\ObjectId::getTimestamp example
  • Example#1588 - MongoDB\BSON\ObjectId::__toString example
  • Example#1589 - MongoDB\BSON\Regex::__construct example
  • Example#1590 - MongoDB\BSON\Regex::getFlags example
  • Example#1591 - MongoDB\BSON\Regex::getPattern example
  • Example#1592 - MongoDB\BSON\Regex::__toString example
  • Example#1593 - MongoDB\BSON\Timestamp::__construct example
  • Example#1594 - MongoDB\BSON\Timestamp::__toString example
  • Example#1595 - MongoDB\BSON\UTCDateTime::__construct example
  • Example#1596 - MongoDB\BSON\UTCDatetime::toDateTime example
  • Example#1597 - MongoDB\BSON\UTCDateTime::__toString example
  • Example#1598 - MongoDB\BSON\Serializable::bsonSerialize returning an associative array for root document
  • Example#1599 - MongoDB\BSON\Serializable::bsonSerialize returning a sequential array for root document
  • Example#1600 - MongoDB\BSON\Serializable::bsonSerialize returning an associative array for document field
  • Example#1601 - MongoDB\BSON\Serializable::bsonSerialize returning a sequential array for document field
  • Example#1602 - MongoDB\BSON\Unserializable::bsonUnserialize example
  • Example#1603 - MongoDB\BSON\Int64::__toString example
  • Example#1604 - MongoDB\Driver\Exception\WriteException::getWriteResult example
  • Example#1605 - Comparing the MySQL APIs
  • Example#1606 - Configure commands for using mysqlnd or libmysqlclient
  • Example#1607 - Unbuffered query example: mysqli
  • Example#1608 - Unbuffered query example: pdo_mysql
  • Example#1609 - Problems with setting the character set with SQL
  • Example#1610 - Setting the character set example: mysqli
  • Example#1611 - Setting the character set example: pdo_mysql
  • Example#1612 - Easy migration from the old mysql extension
  • Example#1613 - Object-oriented and procedural interface
  • Example#1614 - Bad coding style
  • Example#1615 - Special meaning of localhost
  • Example#1616 - Setting defaults
  • Example#1617 - Connecting to MySQL
  • Example#1618 - Navigation through buffered results
  • Example#1619 - Navigation through unbuffered results
  • Example#1620 - Text protocol returns strings by default
  • Example#1621 - Native data types with mysqlnd and connection option
  • Example#1622 - First stage: prepare
  • Example#1623 - Second stage: bind and execute
  • Example#1624 - INSERT prepared once, executed multiple times
  • Example#1625 - Less round trips using multi-INSERT SQL
  • Example#1626 - Native datatypes
  • Example#1627 - Output variable binding
  • Example#1628 - Using mysqli_result to fetch results
  • Example#1629 - Buffered result set for flexible read out
  • Example#1630 - Calling a stored procedure
  • Example#1631 - Using session variables
  • Example#1632 - Fetching results from stored procedures
  • Example#1633 - Stored Procedures and Prepared Statements
  • Example#1634 - Stored Procedures and Prepared Statements using bind API
  • Example#1635 - Multiple Statements
  • Example#1636 - SQL Injection
  • Example#1637 - Setting autocommit mode with SQL and through the API
  • Example#1638 - Commit and rollback
  • Example#1639 - Accessing result set meta data
  • Example#1640 - Prepared statements metadata
  • Example#1641 - $mysqli->affected_rows example
  • Example#1642 - mysqli::autocommit example
  • Example#1643 - mysqli::begin_transaction example
  • Example#1644 - mysqli::change_user example
  • Example#1645 - mysqli::character_set_name example
  • Example#1646 - mysqli::commit example
  • Example#1647 - $mysqli->connect_errno example
  • Example#1648 - $mysqli->connect_error example
  • Example#1649 - mysqli::__construct example
  • Example#1650 - Extending mysqli class
  • Example#1651 - Manual error handling
  • Example#1652 - Generating a Trace File
  • Example#1653 - mysqli->errno example
  • Example#1654 - $mysqli->error_list example
  • Example#1655 - $mysqli->error example
  • Example#1656 - $mysqli->field_count example
  • Example#1657 - mysqli::get_charset example
  • Example#1658 - mysqli_get_client_info
  • Example#1659 - mysqli_get_client_version
  • Example#1660 - A mysqli_get_connection_stats 例程
  • Example#1661 - $mysqli->host_info example
  • Example#1662 - $mysqli->protocol_version example
  • Example#1663 - $mysqli->server_info example
  • Example#1664 - $mysqli->server_version example
  • Example#1665 - $mysqli->info 例程
  • Example#1666 - $mysqli->insert_id 例程
  • Example#1667 - mysqli::kill 例程
  • Example#1668 - mysqli::multi_query 例程
  • Example#1669 - mysqli::ping 例程
  • Example#1670 - A mysqli_poll 例程
  • Example#1671 - mysqli::prepare 例程
  • Example#1672 - mysqli::query example
  • Example#1673 - mysqli::real_connect 例子
  • Example#1674 - mysqli::real_escape_string 例程
  • Example#1675 - mysqli::rollback example
  • Example#1676 - mysqli::select_db example
  • Example#1677 - mysqli::set_charset example
  • Example#1678 - $mysqli->sqlstate 例程
  • Example#1679 - mysqli::stat 例程
  • Example#1680 - $mysqli->thread_id 例程
  • Example#1681 - mysqli::use_result example
  • Example#1682 - $mysqli->warning_count example
  • Example#1683 - 面向对象风格
  • Example#1684 - 过程化风格
  • Example#1685 - 面向对象风格
  • Example#1686 - 过程化风格
  • Example#1687 - 面向对象风格
  • Example#1688 - 过程化风格
  • Example#1689 - 面向对象风格
  • Example#1690 - 过程化风格
  • Example#1691 - 面向对象风格
  • Example#1692 - 过程化风格
  • Example#1693 - 面向对象风格
  • Example#1694 - 过程化风格
  • Example#1695 - 面向对象风格
  • Example#1696 - 过程化风格
  • Example#1697 - 面向对象风格
  • Example#1698 - 过程化风格
  • Example#1699 - 面向对象风格
  • Example#1700 - 过程化风格
  • Example#1701 - 面向对象风格
  • Example#1702 - 过程化风格
  • Example#1703 - 面向对象风格
  • Example#1704 - 过程化风格
  • Example#1705 - 面向对象风格
  • Example#1706 - 过程化风格
  • Example#1707 - 面向对象风格
  • Example#1708 - 过程化风格
  • Example#1709 - 面向对象风格
  • Example#1710 - 过程化风格
  • Example#1711 - 面向对象风格
  • Example#1712 - 过程化风格
  • Example#1713 - 面向对象风格
  • Example#1714 - 面向对象风格
  • Example#1715 - 过程化风格
  • Example#1716 - 面向对象风格
  • Example#1717 - 过程化风格
  • Example#1718 - 面向对象风格
  • Example#1719 - 过程化风格
  • Example#1720 - 面向对象风格
  • Example#1721 - 过程化风格
  • Example#1722 - mysqli_result::fetch_array example
  • Example#1723 - mysqli_result::fetch_assoc example
  • Example#1724 - Comparison of mysqli_result iterator and mysqli_result::fetch_assoc usage
  • Example#1725 - 面向对象风格
  • Example#1726 - 过程化风格
  • Example#1727 - 面向对象风格
  • Example#1728 - 过程化风格
  • Example#1729 - 面向对象风格
  • Example#1730 - 过程化风格
  • Example#1731 - mysqli_result::fetch_object example
  • Example#1732 - mysqli_result::fetch_row example
  • Example#1733 - 面向对象风格
  • Example#1734 - 过程化风格
  • Example#1735 - 面向对象风格
  • Example#1736 - 过程化风格
  • Example#1737 - 面向对象风格
  • Example#1738 - 过程化风格
  • Example#1739 - 面向对象风格
  • Example#1740 - 过程化风格
  • Example#1741 - 面向对象风格
  • Example#1742 - 过程化风格
  • Example#1743 - Error reporting except bad index errors
  • Example#1744 - mysqli_connect 例程
  • Example#1745 - A mysqli_get_client_stats 例程
  • Example#1746 - Connecting to a MySQL Server
  • Example#1747 - Creating a Schema and Collection on the MySQL Server
  • Example#1748 - Storing and Retrieving Data
  • Example#1749 - Fetching and Iterating Multiple Documents
  • Example#1750 - mysql_xdevapi\Expression example
  • Example#1751 - URI examples
  • Example#1752 - mysql_xdevapi\getSession example
  • Example#1753 - mysql_xdevapi\RowResult::getWarnings example
  • Example#1754 - mysql_xdevapi\RowResult::getWarningsCount example
  • Example#1755 - mysql_xdevapi\Client::__construct example
  • Example#1756 - mysql_xdevapi\Collection::add example
  • Example#1757 - mysql_xdevapi\Collection::addOrReplaceOne example
  • Example#1758 - mysql_xdevapi\Collection::getOne example
  • Example#1759 - mysql_xdevapi\Collection::count example
  • Example#1760 - mysql_xdevapi\Collection::createIndex example
  • Example#1761 - mysql_xdevapi\Collection::dropIndex example
  • Example#1762 - mysql_xdevapi\Collection::existsInDatabase example
  • Example#1763 - mysql_xdevapi\Collection::find example
  • Example#1764 - mysql_xdevapi\Collection::getName example
  • Example#1765 - mysql_xdevapi\Collection::getOne example
  • Example#1766 - mysql_xdevapi\Collection::getSchema example
  • Example#1767 - mysql_xdevapi\Collection::getSession example
  • Example#1768 - mysql_xdevapi\Collection::modify example
  • Example#1769 - mysql_xdevapi\Collection::remove example
  • Example#1770 - mysql_xdevapi\Collection::removeOne example
  • Example#1771 - mysql_xdevapi\Collection::replaceOne example
  • Example#1772 - mysql_xdevapi\CollectionAdd::__construct example
  • Example#1773 - mysql_xdevapi\CollectionAdd::execute example
  • Example#1774 - mysql_xdevapi\CollectionFind::bind example
  • Example#1775 - CollectionFind example
  • Example#1776 - CollectionFind example
  • Example#1777 - mysql_xdevapi\CollectionFind::fields example
  • Example#1778 - mysql_xdevapi\CollectionFind::groupBy example
  • Example#1779 - mysql_xdevapi\CollectionFind::having example
  • Example#1780 - mysql_xdevapi\CollectionFind::limit example
  • Example#1781 - mysql_xdevapi\CollectionFind::lockExclusive example
  • Example#1782 - mysql_xdevapi\CollectionFind::lockShared example
  • Example#1783 - mysql_xdevapi\CollectionFind::offset example
  • Example#1784 - mysql_xdevapi\CollectionFind::sort example
  • Example#1785 - mysql_xdevapi\CollectionModify::arrayAppend example
  • Example#1786 - mysql_xdevapi\CollectionModify::arrayInsert example
  • Example#1787 - mysql_xdevapi\CollectionModify::bind example
  • Example#1788 - mysql_xdevapi\CollectionModify::__construct example
  • Example#1789 - mysql_xdevapi\CollectionModify::execute example
  • Example#1790 - mysql_xdevapi\CollectionModify::limit example
  • Example#1791 - mysql_xdevapi\CollectionModify::patch example
  • Example#1792 - mysql_xdevapi\CollectionModify::replace example
  • Example#1793 - mysql_xdevapi\CollectionModify::set example
  • Example#1794 - mysql_xdevapi\CollectionModify::skip example
  • Example#1795 - mysql_xdevapi\CollectionModify::sort example
  • Example#1796 - mysql_xdevapi\CollectionModify::unset example
  • Example#1797 - mysql_xdevapi\CollectionRemove::bind example
  • Example#1798 - mysql_xdevapi\Collection::remove example
  • Example#1799 - mysql_xdevapi\CollectionRemove::execute example
  • Example#1800 - mysql_xdevapi\CollectionRemove::limit example
  • Example#1801 - mysql_xdevapi\CollectionRemove::sort example
  • Example#1802 - mysql_xdevapi\ColumnResult::__construct example
  • Example#1803 - mysql_xdevapi\ColumnResult::getCharacterSetName example
  • Example#1804 - mysql_xdevapi\ColumnResult::getCollationName example
  • Example#1805 - mysql_xdevapi\ColumnResult::getColumnLabel example
  • Example#1806 - mysql_xdevapi\ColumnResult::getColumnName example
  • Example#1807 - mysql_xdevapi\ColumnResult::getFractionalDigits example
  • Example#1808 - mysql_xdevapi\ColumnResult::getLength example
  • Example#1809 - mysql_xdevapi\ColumnResult::getSchemaName example
  • Example#1810 - mysql_xdevapi\ColumnResult::getTableLabel example
  • Example#1811 - mysql_xdevapi\ColumnResult::getTableName example
  • Example#1812 - mysql_xdevapi\ColumnResult::getType example
  • Example#1813 - mysql_xdevapi\ColumnResult::isNumberSigned example
  • Example#1814 - mysql_xdevapi\ColumnResult::isPadded example
  • Example#1815 - mysql_xdevapi\CrudOperationBindable::bind example
  • Example#1816 - mysql_xdevapi\CrudOperationLimitable::limit example
  • Example#1817 - mysql_xdevapi\CrudOperationSkippable::skip example
  • Example#1818 - mysql_xdevapi\CrudOperationSortable::sort example
  • Example#1819 - mysql_xdevapi\DatabaseObject::existsInDatabase example
  • Example#1820 - mysql_xdevapi\DatabaseObject::getName example
  • Example#1821 - mysql_xdevapi\DatabaseObject::getSession example
  • Example#1822 - A DocResult example
  • Example#1823 - mysql_xdevapi\DocResult::fetchAll example
  • Example#1824 - mysql_xdevapi\DocResult::fetchOne example
  • Example#1825 - mysql_xdevapi\DocResult::getWarnings example
  • Example#1826 - mysql_xdevapi\DocResult::getWarningsCount example
  • Example#1827 - execute() examples
  • Example#1828 - mysql_xdevapi\ExecutionStatus::__construct example
  • Example#1829 - mysql_xdevapi\Expression::__construct example
  • Example#1830 - mysql_xdevapi\Result::__construct example
  • Example#1831 - mysql_xdevapi\Result::getAffectedItemsCount example
  • Example#1832 - mysql_xdevapi\Result::getAutoIncrementValue example
  • Example#1833 - mysql_xdevapi\Result::getGeneratedIds example
  • Example#1834 - mysql_xdevapi\RowResult::getWarnings example
  • Example#1835 - mysql_xdevapi\RowResult::getWarningsCount example
  • Example#1836 - mysql_xdevapi\RowResult::__construct example
  • Example#1837 - mysql_xdevapi\RowResult::fetchAll example
  • Example#1838 - mysql_xdevapi\RowResult::fetchOne example
  • Example#1839 - mysql_xdevapi\RowResult::getColumnsCount example
  • Example#1840 - mysql_xdevapi\RowResult::getColumnNames example
  • Example#1841 - mysql_xdevapi\RowResult::getColumns example
  • Example#1842 - mysql_xdevapi\RowResult::getWarnings example
  • Example#1843 - mysql_xdevapi\RowResult::getWarningsCount example
  • Example#1844 - Schema::__construct example
  • Example#1845 - Schema::createCollection example
  • Example#1846 - Schema::dropCollection example
  • Example#1847 - Schema::existsInDatabase example
  • Example#1848 - Schema::getCollection example
  • Example#1849 - Schema::getCollectionAsTable example
  • Example#1850 - mysql_xdevapi\Schema::getCollections example
  • Example#1851 - mysql_xdevapi\Schema::getName example
  • Example#1852 - mysql_xdevapi\Schema::getSession example
  • Example#1853 - mysql_xdevapi\Schema::getTable example
  • Example#1854 - mysql_xdevapi\Schema::getTables example
  • Example#1855 - mysql_xdevapi\Session::getSchema example
  • Example#1856 - mysql_xdevapi\Session::close example
  • Example#1857 - mysql_xdevapi\Session::commit example
  • Example#1858 - mysql_xdevapi\Session::__construct example
  • Example#1859 - mysql_xdevapi\Session::createSchema example
  • Example#1860 - mysql_xdevapi\Session::dropSchema example
  • Example#1861 - mysql_xdevapi\Session::generateUuid example
  • Example#1862 - mysql_xdevapi\Session::getSchema example
  • Example#1863 - mysql_xdevapi\Session::getSchema example
  • Example#1864 - mysql_xdevapi\Session::getSchemas example
  • Example#1865 - mysql_xdevapi\Session::getServerVersion example
  • Example#1866 - mysql_xdevapi\Session::listClients example
  • Example#1867 - mysql_xdevapi\Session::quoteName example
  • Example#1868 - mysql_xdevapi\Session::releaseSavepoint example
  • Example#1869 - mysql_xdevapi\Session::rollback example
  • Example#1870 - mysql_xdevapi\Session::rollbackTo example
  • Example#1871 - mysql_xdevapi\Session::setSavepoint example
  • Example#1872 - mysql_xdevapi\Session::sql example
  • Example#1873 - mysql_xdevapi\Session::startTransaction example
  • Example#1874 - mysql_xdevapi\SqlStatement::bind example
  • Example#1875 - mysql_xdevapi\SqlStatement::__construct example
  • Example#1876 - mysql_xdevapi\SqlStatement::execute example
  • Example#1877 - mysql_xdevapi\SqlStatement::getNextResult example
  • Example#1878 - mysql_xdevapi\SqlStatement::getResult example
  • Example#1879 - mysql_xdevapi\SqlStatement::hasMoreResults example
  • Example#1880 - mysql_xdevapi\SqlStatementResult::__construct example
  • Example#1881 - mysql_xdevapi\SqlStatementResult::fetchAll example
  • Example#1882 - mysql_xdevapi\SqlStatementResult::fetchOne example
  • Example#1883 - mysql_xdevapi\SqlStatementResult::getAffectedItemsCount example
  • Example#1884 - mysql_xdevapi\SqlStatementResult::getColumnsCount example
  • Example#1885 - mysql_xdevapi\SqlStatementResult::getColumnNames example
  • Example#1886 - mysql_xdevapi\SqlStatementResult::getColumns example
  • Example#1887 - mysql_xdevapi\SqlStatementResult::getGeneratedIds example
  • Example#1888 - mysql_xdevapi\SqlStatementResult::getLastInsertId example
  • Example#1889 - mysql_xdevapi\SqlStatementResult::getWarnings example
  • Example#1890 - mysql_xdevapi\SqlStatementResult::getWarningsCount example
  • Example#1891 - mysql_xdevapi\SqlStatementResult::hasData example
  • Example#1892 - mysql_xdevapi\SqlStatementResult::nextResult example
  • Example#1893 - mysql_xdevapi\Statement::__construct example
  • Example#1894 - mysql_xdevapi\Statement::getNextResult example
  • Example#1895 - mysql_xdevapi\Statement::getResult example
  • Example#1896 - mysql_xdevapi\Statement::hasMoreResults example
  • Example#1897 - mysql_xdevapi\Table::__construct example
  • Example#1898 - mysql_xdevapi\Table::count example
  • Example#1899 - mysql_xdevapi\Table::delete example
  • Example#1900 - mysql_xdevapi\Table::existsInDatabase example
  • Example#1901 - mysql_xdevapi\Table::getName example
  • Example#1902 - mysql_xdevapi\Table::getSchema example
  • Example#1903 - mysql_xdevapi\Table::getSession example
  • Example#1904 - mysql_xdevapi\Table::insert example
  • Example#1905 - mysql_xdevapi\Table::isView example
  • Example#1906 - mysql_xdevapi\Table::count example
  • Example#1907 - mysql_xdevapi\Table::update example
  • Example#1908 - mysql_xdevapi\TableDelete::bind example
  • Example#1909 - mysql_xdevapi\TableDelete::__construct example
  • Example#1910 - mysql_xdevapi\TableDelete::execute example
  • Example#1911 - mysql_xdevapi\TableDelete::limit example
  • Example#1912 - mysql_xdevapi\TableDelete::orderBy example
  • Example#1913 - mysql_xdevapi\TableDelete::where example
  • Example#1914 - mysql_xdevapi\TableInsert::__construct example
  • Example#1915 - mysql_xdevapi\TableInsert::execute example
  • Example#1916 - mysql_xdevapi\TableInsert::values example
  • Example#1917 - mysql_xdevapi\TableSelect::bind example
  • Example#1918 - mysql_xdevapi\TableSelect::__construct example
  • Example#1919 - mysql_xdevapi\TableSelect::execute example
  • Example#1920 - mysql_xdevapi\TableSelect::groupBy example
  • Example#1921 - mysql_xdevapi\TableSelect::having example
  • Example#1922 - mysql_xdevapi\TableSelect::limit example
  • Example#1923 - mysql_xdevapi\TableSelect::lockExclusive example
  • Example#1924 - mysql_xdevapi\TableSelect::lockShared example
  • Example#1925 - mysql_xdevapi\TableSelect::offset example
  • Example#1926 - mysql_xdevapi\TableSelect::orderBy example
  • Example#1927 - mysql_xdevapi\TableSelect::where example
  • Example#1928 - mysql_xdevapi\TableUpdate::bind example
  • Example#1929 - mysql_xdevapi\TableUpdate::__construct example
  • Example#1930 - mysql_xdevapi\TableUpdate::execute example
  • Example#1931 - mysql_xdevapi\TableUpdate::limit example
  • Example#1932 - mysql_xdevapi\TableUpdate::orderby example
  • Example#1933 - mysql_xdevapi\TableUpdate::set example
  • Example#1934 - mysql_xdevapi\TableUpdate::where example
  • Example#1935 - mysql_xdevapi\Warning::__construct example
  • Example#1936 - MySQL 扩展概述范例
  • Example#1937 - mysql_affected_rows 例子
  • Example#1938 - 使用事务处理的 mysql_affected_rows 例子
  • Example#1939 - mysql_client_encoding 例子
  • Example#1940 - mysql_close 例子
  • Example#1941 - mysql_connect 例子
  • Example#1942 - mysql_connect 例子：使用 hostname:port 语法
  • Example#1943 - mysql_connect 例子：使用 ":/path/to/socket" 语法
  • Example#1944 - 替代 mysql_create_db 的例子
  • Example#1945 - mysql_data_seek 例子
  • Example#1946 - mysql_db_name 例子
  • Example#1947 - mysql_drop_db alternative example
  • Example#1948 - mysql_errno 例子
  • Example#1949 - mysql_error 例子
  • Example#1950 - mysql_escape_string 例子
  • Example#1951 - msql_fetch_array 示例
  • Example#1952 - 扩展的 mysql_fetch_assoc 例子
  • Example#1953 - mysql_fetch_field
  • Example#1954 - mysql_fetch_field example
  • Example#1955 - mysql_fetch_object example
  • Example#1956 - mysql_fetch_object example
  • Example#1957 - Fetching one row with mysql_fetch_row
  • Example#1958 - mysql_field_name 例子
  • Example#1959 - mysql_field_name example
  • Example#1960 - mysql_field_type 例子
  • Example#1961 - mysql_field_type example
  • Example#1962 - A mysql_free_result example
  • Example#1963 - mysql_get_client_info 例子
  • Example#1964 - mysql_get_host_info 例子
  • Example#1965 - mysql_get_proto_info 例子
  • Example#1966 - mysql_get_server_info 例子
  • Example#1967 - 相关的 MySQL 语句
  • Example#1968 - mysql_insert_id 例子
  • Example#1969 - mysql_list_dbs 例子
  • Example#1970 - mysql_list_fields 例子
  • Example#1971 - mysql_list_processes 例子
  • Example#1972 - mysql_list_tables 例子
  • Example#1973 - mysql_num_rows 例子
  • Example#1974 - 无效的查询
  • Example#1975 - 有效的查询
  • Example#1976 - mysql_real_escape_string 例子
  • Example#1977 - mysql_real_escape_string requires a connection example
  • Example#1978 - An example SQL Injection Attack
  • Example#1979 - mysql_result 例子
  • Example#1980 - mysql_select_db 例子
  • Example#1981 - mysql_select_db example
  • Example#1982 - mysql_stat 例子
  • Example#1983 - mysql_tablename example
  • Example#1984 - mysql_thread_id 例子
  • Example#1985 - 启用插件(php.ini)
  • Example#1986 - 最基本的插件配置文件 (mysqlnd_ms_plugin.ini)
  • Example#1987 - 建议最基本的插件配置文件 (mysqlnd_ms_plugin.ini)
  • Example#1988 - 使用一个服务器同时作为 master 和 slave（仅用于测试！）
  • Example#1989 - 插件指定的配置文件 (mysqlnd_ms_plugin.ini)
  • Example#1990 - 开启一个负载均衡链接
  • Example#1991 - Executing statements
  • Example#1992 - 配置了一个 master 和一个 slave 的插件
  • Example#1993 - 陷阱：连接状态和 SQL 用户变量
  • Example#1994 - 配置一个 master 和一个 slave 的插件
  • Example#1995 - SQL hints 禁止连接切换
  • Example#1996 - 与同步延迟斗争
  • Example#1997 - Table creation on a slave
  • Example#1998 - 配置一个 master 和一个 slave 的插件
  • Example#1999 - 在事务中使用 SQL hints
  • Example#2000 - 事务相关负载均衡下的 trx_stickiness 设置
  • Example#2001 - Transaction aware
  • Example#2002 - General pattern for XA transactions
  • Example#2003 - Local and global transactions are mutually exclusive
  • Example#2004 - Transaction coordinator state store
  • Example#2005 - session 一致性：读取写入内容
  • Example#2006 - Requesting session consistency
  • Example#2007 - Maximum age/slave lag
  • Example#2008 - 限制 slave 延迟
  • Example#2009 - 不设置故障处理
  • Example#2010 - No slave within time limit
  • Example#2011 - 在 master 创建计数器表
  • Example#2012 - Plugin config: SQL for client-side GTID injection
  • Example#2013 - Transparent global transaction ID injection
  • Example#2014 - Plugin config: SQL for fetching GTID
  • Example#2015 - Obtaining GTID after injection
  • Example#2016 - Plugin config: Checking for a certain GTID
  • Example#2017 - Session consistency service level and GTID combined
  • Example#2018 - 使用 MySQL 5.6.5-m8 内置 GTID
  • Example#2019 - Recap: quality of service to request read your writes
  • Example#2020 - Plugin config: no special entries for caching
  • Example#2021 - Caching a slave request
  • Example#2022 - Read your writes and caching combined
  • Example#2023 - 手动故障转移，可选自动
  • Example#2024 - 手动故障转移
  • Example#2025 - Cluster node groups
  • Example#2026 - 通过 SQL hints 完成手动分区
  • Example#2027 - Plugin config: Fabric hosts instead of MySQL servers
  • Example#2028 - Manual partitioning using SQL hints
  • Example#2029 - Provoking a connection error
  • Example#2030 - 在查询执行时产生连接错误
  • Example#2031 - 产生一个连接错误
  • Example#2032 - 非常基础的错误处理
  • Example#2033 - Provoking a transient error
  • Example#2034 - 短错误尝试循环
  • Example#2035 - Enabling the plugin (php.ini)
  • Example#2036 - Basic plugin configuration (mysqlnd_ms_plugin.ini) for MySQL Replication
  • Example#2037 - Multiple primaries - multi master (php.ini)
  • Example#2038 - Primary copy with multiple primaries and paritioning
  • Example#2039 - Multiple primaries - multi master (php.ini)
  • Example#2040 - Synchronous update anywhere cluster
  • Example#2041 - General pattern for XA transactions
  • Example#2042 - Converting a PHP array (hash) into JSON format
  • Example#2043 - Using section names example
  • Example#2044 - List of anonymous slaves
  • Example#2045 - Master list using symbolic names
  • Example#2046 - Keywords to configure a server
  • Example#2047 - New roundrobin filter, old functionality
  • Example#2048 - The user filter replaces mysqlnd_ms_set_user_pick_server
  • Example#2049 - Common error message in case of configuration file issues (upto version 1.5.0)
  • Example#2050 - Improved configuration file validation since 1.5.0
  • Example#2051 - Possibly more precise error due to mysqlnd_ms.force_config_usage=1
  • Example#2052 - Minimum pluging configuration for use with MySQL Fabric
  • Example#2053 - Optional timeout for communication with Fabric
  • Example#2054 - Warnings about the violation of transaction boundaries
  • Example#2055 - Invalid filter sequence
  • Example#2056 - Random load balancing with random filter
  • Example#2057 - Random once load balancing with random filter
  • Example#2058 - Referencing error
  • Example#2059 - Assigning a weight for load balancing
  • Example#2060 - roundrobin filter
  • Example#2061 - Setting a callback
  • Example#2062 - Using a callback
  • Example#2063 - Returning random masters and slaves
  • Example#2064 - Manual partitioning
  • Example#2065 - Global limit on slave lag
  • Example#2066 - Optional master failover when failing to connect to slave (PECL/mysqlnd_ms < 1.4.0)
  • Example#2067 - New syntax since 1.4.0
  • Example#2068 - Disabling lazy connection
  • Example#2069 - String escaping on a lazy connection handle
  • Example#2070 - Master on write for consistent reads
  • Example#2071 - Using master to execute transactions
  • Example#2072 - No automatic failover, error handling pitfall
  • Example#2073 - Retry loop for transient errors
  • Example#2074 - SQL definition for the MySQL state store transaction table
  • Example#2075 - SQL definition for the MySQL state store transaction table
  • Example#2076 - SQL definition for the MySQL state store garbage collection table
  • Example#2077 - Using section names example
  • Example#2078 - List-like syntax
  • Example#2079 - Verify plugin activity in a non-threaded deployment model
  • Example#2080 - Recording statistics during shutdown
  • Example#2081 - Example demonstrating the usage of mysqlnd_ms constants
  • Example#2082 - mysqlnd_ms_dump_servers example
  • Example#2083 - mysqlnd_ms_get_last_gtid example
  • Example#2084 - mysqlnd_ms_get_last_used_connection example
  • Example#2085 - mysqlnd_ms_get_stats example
  • Example#2086 - mysqlnd_ms_match_wild example
  • Example#2087 - mysqlnd_ms_query_is_select example
  • Example#2088 - mysqlnd_ms_set_qos example
  • Example#2089 - mysqlnd_ms_set_user_pick_server example
  • Example#2090 - Enabling the plugin (php.ini)
  • Example#2091 - Using the MYSQLND_QC_ENABLE_SWITCH SQL hint
  • Example#2092 - Using the MYSQLND_QC_DISABLE_SWITCH SQL hint
  • Example#2093 - Example showing which type of statements are not cached
  • Example#2094 - Enabling caching for all statements using the mysqlnd_qc.cache_no_table ini setting
  • Example#2095 - Setting the TTL with the mysqlnd_qc.ttl ini setting
  • Example#2096 - Setting TTL with SQL hints
  • Example#2097 - Setting a callback with mysqlnd_qc_set_is_select
  • Example#2098 - Enabling the slam defense mechanism
  • Example#2099 - Collecting a query trace
  • Example#2100 - Setting the backtrace depth with the mysqlnd_qc.query_trace_bt_depth ini setting
  • Example#2101 - Collecting statistics data with the mysqlnd_qc.time_statistics ini setting
  • Example#2102 - Example mysqlnd_qc_get_cache_info usage
  • Example#2103 - Example mysqlnd_qc_get_normalized_query_trace_log usage
  • Example#2104 - Using a user-defined storage handler
  • Example#2105 - Using SQL hint constants
  • Example#2106 - Example mysqlnd_qc_set_cache_condition usage
  • Example#2107 - mysqlnd_qc_get_available_handlers example
  • Example#2108 - mysqlnd_qc_get_cache_info example
  • Example#2109 - mysqlnd_qc_get_core_stats example
  • Example#2110 - mysqlnd_qc_get_normalized_query_trace_log example
  • Example#2111 - mysqlnd_qc_get_query_trace_log example
  • Example#2112 - mysqlnd_qc_set_cache_condition example
  • Example#2113 - mysqlnd_qc_set_is_select example
  • Example#2114 - mysqlnd_qc_set_storage_handler example
  • Example#2115 - Enabling the plugin (php.ini)
  • Example#2116 - Pseudo-code: what a built-in class does
  • Example#2117 - Installing a proxy
  • Example#2118 - Proxy registration, mysqlnd_uh.enable=1
  • Example#2119 - Proxy installation disabled
  • Example#2120 - Connection proxy
  • Example#2121 - Prepared statement proxy
  • Example#2122 - Basic Monitoring
  • Example#2123 - MysqlndUhConnection::changeUser example
  • Example#2124 - MysqlndUhConnection::charsetName example
  • Example#2125 - MysqlndUhConnection::close example
  • Example#2126 - MysqlndUhConnection::connect example
  • Example#2127 - MysqlndUhConnection::endPSession example
  • Example#2128 - MysqlndUhConnection::escapeString example
  • Example#2129 - MysqlndUhConnection::getAffectedRows example
  • Example#2130 - MysqlndUhConnection::getErrorNumber example
  • Example#2131 - MysqlndUhConnection::getErrorString example
  • Example#2132 - MysqlndUhConnection::getFieldCount example
  • Example#2133 - MysqlndUhConnection::getHostInformation example
  • Example#2134 - MysqlndUhConnection::getLastInsertId example
  • Example#2135 - MysqlndUhConnection::getLastMessage example
  • Example#2136 - MysqlndUhConnection::getProtocolInformation example
  • Example#2137 - MysqlndUhConnection::getServerInformation example
  • Example#2138 - MysqlndUhConnection::getServerStatistics example
  • Example#2139 - MysqlndUhConnection::getServerVersion example
  • Example#2140 - MysqlndUhConnection::getSqlstate example
  • Example#2141 - MysqlndUhConnection::getStatistics example
  • Example#2142 - MysqlndUhConnection::getThreadId example
  • Example#2143 - MysqlndUhConnection::getWarningCount example
  • Example#2144 - MysqlndUhConnection::init example
  • Example#2145 - MysqlndUhConnection::kill example
  • Example#2146 - MysqlndUhConnection::listFields example
  • Example#2147 - MysqlndUhConnection::listMethod example
  • Example#2148 - MysqlndUhConnection::moreResults example
  • Example#2149 - MysqlndUhConnection::nextResult example
  • Example#2150 - MysqlndUhConnection::ping example
  • Example#2151 - MysqlndUhConnection::query example
  • Example#2152 - MysqlndUhConnection::queryReadResultsetHeader example
  • Example#2153 - MysqlndUhConnection::reapQuery example
  • Example#2154 - MysqlndUhConnection::refreshServer example
  • Example#2155 - MysqlndUhConnection::restartPSession example
  • Example#2156 - MysqlndUhConnection::selectDb example
  • Example#2157 - MysqlndUhConnection::sendClose example
  • Example#2158 - MysqlndUhConnection::sendQuery example
  • Example#2159 - MysqlndUhConnection::serverDumpDebugInformation example
  • Example#2160 - MysqlndUhConnection::setAutocommit example
  • Example#2161 - MysqlndUhConnection::setCharset example
  • Example#2162 - MysqlndUhConnection::setClientOption example
  • Example#2163 - MysqlndUhConnection::setServerOption example
  • Example#2164 - MysqlndUhConnection::simpleCommand example
  • Example#2165 - MysqlndUhConnection::simpleCommandHandleResponse example
  • Example#2166 - MysqlndUhConnection::sslSet example
  • Example#2167 - MysqlndUhConnection::stmtInit example
  • Example#2168 - MysqlndUhConnection::storeResult example
  • Example#2169 - MysqlndUhConnection::txCommit example
  • Example#2170 - MysqlndUhConnection::txRollback example
  • Example#2171 - MysqlndUhConnection::useResult example
  • Example#2172 - MysqlndUhPreparedStatement::execute example
  • Example#2173 - MysqlndUhPreparedStatement::prepare example
  • Example#2174 - mysqlnd_uh_convert_to_mysqlnd example
  • Example#2175 - mysqlnd_uh_set_connection_proxy example
  • Example#2176 - Enabling the plugin (php.ini)
  • Example#2177 - SQL table used for the Quickstart
  • Example#2178 - Basic example.
  • Example#2179 - mysqlnd_memcache_get_config example
  • Example#2180 - mysqlnd_memcache_set example with var_dump as a simple debugging callback.
  • Example#2181 - Basic query
  • Example#2182 - Inserting with bind variables
  • Example#2183 - Binding in the WHERE clause of a query
  • Example#2184 - Inserting and fetching a CLOB
  • Example#2185 - Using a PL/SQL stored function
  • Example#2186 - Using a PL/SQL stored procedure
  • Example#2187 - Calling a PL/SQL function that returns a REF CURSOR
  • Example#2188 -
  • Example#2189 - user_oci8_probes.d for tracing all user-level PHP OCI8 Static Probes with DTrace
  • Example#2190 - oci_bind_array_by_name example
  • Example#2191 - oci_bind_by_name 例子
  • Example#2192 - oci_bind_by_name 例子
  • Example#2193 - oci_bind_by_name 例子
  • Example#2194 - Inserting data with oci_bind_by_name
  • Example#2195 - Binding once for multiple executions
  • Example#2196 - Binding with a foreach loop
  • Example#2197 - Binding in a WHERE clause
  • Example#2198 - Binding with a LIKE clause
  • Example#2199 - Binding with REGEXP_LIKE
  • Example#2200 - Binding Multiple Values in an IN Clause
  • Example#2201 - Binding a ROWID returned by a query
  • Example#2202 - Binding a ROWID on INSERT
  • Example#2203 - Binding for a PL/SQL stored function
  • Example#2204 - Binding parameters for a PL/SQL stored procedure
  • Example#2205 - Binding a CLOB column
  • Example#2206 - Binding a PL/SQL BOOLEAN
  • Example#2207 - oci_client_version example
  • Example#2208 - Closing a connection
  • Example#2209 - Database connections are not closed until all references are closed
  • Example#2210 - Closing a connection opened more than once
  • Example#2211 - Connections are closed when variables go out of scope
  • Example#2212 - oci_commit 例子
  • Example#2213 - oci_commit example
  • Example#2214 - oci_connect 例子
  • Example#2215 - Basic oci_connect using Easy Connect syntax
  • Example#2216 - Basic oci_connect using a Network Connect name
  • Example#2217 - oci_connect with an explicit character set
  • Example#2218 - Using multiple calls to oci_connect
  • Example#2219 - oci_define_by_name 例子
  • Example#2220 - 连接错误后显示 Oracle 错误信息
  • Example#2221 - 语法解析错误后显示 Oracle 错误信息
  • Example#2222 - 执行错误后显示 Oracle 错误信息和出错的语句
  • Example#2223 - oci_execute for queries
  • Example#2224 - oci_execute without specifying a mode example
  • Example#2225 - oci_execute with OCI_NO_AUTO_COMMIT example
  • Example#2226 - oci_execute with different commit modes example
  • Example#2227 - oci_execute with OCI_DESCRIBE_ONLY example
  • Example#2228 - oci_fetch_all 例子
  • Example#2229 - oci_fetch_all example
  • Example#2230 - oci_fetch_all example with OCI_FETCHSTATEMENT_BY_ROW
  • Example#2231 - oci_fetch_all with OCI_NUM
  • Example#2232 - oci_fetch_array with OCI_BOTH
  • Example#2233 - oci_fetch_array with OCI_NUM
  • Example#2234 - oci_fetch_array with OCI_ASSOC
  • Example#2235 - oci_fetch_array with OCI_RETURN_NULLS
  • Example#2236 - oci_fetch_array with OCI_RETURN_LOBS
  • Example#2237 - oci_fetch_array with case sensitive column names
  • Example#2238 - oci_fetch_array with columns having duplicate names
  • Example#2239 - oci_fetch_array with DATE columns
  • Example#2240 - oci_fetch_array with REF CURSOR
  • Example#2241 - Pagination with oci_fetch_array using a LIMIT-like query
  • Example#2242 - oci_fetch_array with Oracle Database Implicit Result Sets
  • Example#2243 - oci_fetch_assoc Example
  • Example#2244 - oci_fetch_object example
  • Example#2245 - oci_fetch_object with case sensitive column names
  • Example#2246 - oci_fetch_object with LOBs
  • Example#2247 - oci_fetch_row Example
  • Example#2248 - oci_fetch with defined variables
  • Example#2249 - oci_fetch with oci_result
  • Example#2250 - oci_field_name 例子
  • Example#2251 - oci_field_size例子
  • Example#2252 - oci_field_type 例子
  • Example#2253 - Fetching Implicit Result Sets in a loop
  • Example#2254 - Getting child statement handles individually
  • Example#2255 - Explicitly setting the Prefetch Count
  • Example#2256 - Implicit Result Set example without using oci_get_implicit_resultset
  • Example#2257 - oci_new_connect 例子
  • Example#2258 - oci_new_connect example
  • Example#2259 - 在 Oracle 的存储过程中使用 REF CURSOR
  • Example#2260 - 在 Oracle 的 select 语句中使用 REF CURSOR
  • Example#2261 - oci_new_descriptor 例子
  • Example#2262 - oci_new_descriptor 例子
  • Example#2263 - oci_num_fields 例子
  • Example#2264 - oci_num_rows 例子
  • Example#2265 - oci_rollback example
  • Example#2266 - Rolling back to a SAVEPOINT example
  • Example#2267 - oci_server_version 例子
  • Example#2268 - Setting the action
  • Example#2269 - Setting the timeout
  • Example#2270 - Setting the client identifier to the application user
  • Example#2271 - Setting the client information
  • Example#2272 - Setting the DBOP
  • Example#2273 - Two scripts can use different versions of myfunc() at the same time
  • Example#2274 - Setting the module name
  • Example#2275 - Changing the default prefetch value for a query
  • Example#2276 - Changing the default prefetch for a REF CURSOR fetch
  • Example#2277 - Setting the prefetch value when passing a REF CURSOR back to Oracle
  • Example#2278 - oci_statement_type 例子
  • Example#2279 - Creating a Paradox database with two fields
  • Example#2280 - Turn a paradox date into a human readable form
  • Example#2281 - Set the date/time fields in a paradox database to the current date/time
  • Example#2282 - Opening a Paradox database
  • Example#2283 - Opening a Paradox database
  • Example#2284 - Turn a paradox timestamp into a human readable form
  • Example#2285 - PostgreSQL extension overview example
  • Example#2286 - PostgreSQL user defined functions example
  • Example#2287 - pg_affected_rows 例子
  • Example#2288 - pg_close 例子
  • Example#2289 - 使用 pg_connect
  • Example#2290 - pg_connection_busy 例子
  • Example#2291 - pg_connection_reset 例子
  • Example#2292 - pg_connection_status 例子
  • Example#2293 - pg_connection_status 例子
  • Example#2294 - pg_convert example
  • Example#2295 - pg_copy_from example
  • Example#2296 - pg_dbname 例子
  • Example#2297 - pg_delete 例子
  • Example#2298 - pg_end_copy 例子
  • Example#2299 - pg_escape_identifier example
  • Example#2300 - pg_escape_literal example
  • Example#2301 - Using pg_execute
  • Example#2302 - pg_fetch_all_columns example
  • Example#2303 - pg_fetch_all 例子
  • Example#2304 - pg_fetch_array
  • Example#2305 - pg_fetch_assoc 例子
  • Example#2306 - pg_fetch_object
  • Example#2307 - pg_fetch_row 例子
  • Example#2308 - pg_field_is_null 例子
  • Example#2309 - 获取字段信息
  • Example#2310 - Getting table information about a field
  • Example#2311 - Getting information about fields
  • Example#2312 - pg_free_result example
  • Example#2313 - PostgreSQL NOTIFY 消息
  • Example#2314 - PostgreSQL 后端 PID
  • Example#2315 - pg_insert example
  • Example#2316 - pg_last_notice example
  • Example#2317 - pg_lo_export example
  • Example#2318 - pg_lo_import 例子
  • Example#2319 - pg_lo_truncate example
  • Example#2320 - pg_lo_unlink example
  • Example#2321 - 取得表的元数据
  • Example#2322 - pg_parameter_status example
  • Example#2323 - Using pg_pconnect
  • Example#2324 - pg_ping
  • Example#2325 - Using pg_prepare
  • Example#2326 - pg_put_line 例子
  • Example#2327 - Using pg_query_params
  • Example#2328 - pg_result_error_field example
  • Example#2329 - pg_select example
  • Example#2330 - Using pg_send_execute
  • Example#2331 - Using pg_send_prepare
  • Example#2332 - Using pg_send_query_params
  • Example#2333 - 异步查询
  • Example#2334 - pg_set_error_verbosity example
  • Example#2335 - pg_transaction_status example
  • Example#2336 - pg_update example
  • Example#2337 - pg_version example
  • Example#2338 - Backup an existing database
  • Example#2339 - SQLite3::changes example
  • Example#2340 - SQLite3::close example
  • Example#2341 - SQLite3::__construct example
  • Example#2342 - max_length aggregation function example
  • Example#2343 - SQLite3::createCollation example
  • Example#2344 - SQLite3::createFunction example
  • Example#2345 - SQLite3::enableExceptions example
  • Example#2346 - SQLite3::exec example
  • Example#2347 - SQLite3::loadExtension example
  • Example#2348 - SQLite3::open example
  • Example#2349 - SQLite3::openBlob example
  • Example#2350 - Incrementally writing a BLOB
  • Example#2351 - SQLite3::prepare example
  • Example#2352 - SQLite3::query example
  • Example#2353 - SQLite3::querySingle example
  • Example#2354 - SQLite3::setAuthorizer example
  • Example#2355 - SQLite3::version example
  • Example#2356 - SQLite3Stmt::bindParam Usage
  • Example#2357 - SQLite3Stmt::bindValue example
  • Example#2358 - Inspecting the expanded SQL
  • Example#2359 - sqlsrv_begin_transaction example
  • Example#2360 - sqlsrv_cancel example
  • Example#2361 - sqlsrv_client_info example
  • Example#2362 - sqlsrv_close example
  • Example#2363 - sqlsrv_commit example
  • Example#2364 - Connect using Windows Authentication.
  • Example#2365 - Connect by specifying a user name and password.
  • Example#2366 - Connect on a specified port.
  • Example#2367 - functionname example
  • Example#2368 - sqlsrv_execute example
  • Example#2369 - Retrieving an associative array.
  • Example#2370 - Retrieving a numeric array.
  • Example#2371 - sqlsrv_fetch_object example
  • Example#2372 - sqlsrv_fetch example
  • Example#2373 - sqlsrv_field_metadata example
  • Example#2374 - sqlsrv_free_stmt example
  • Example#2375 - sqlsrv_get_field example
  • Example#2376 - sqlsrv_has_rows example
  • Example#2377 - sqlsrv_next_result example
  • Example#2378 - sqlsrv_num_fields example
  • Example#2379 - sqlsrv_num_rows example
  • Example#2380 - sqlsrv_prepare example
  • Example#2381 - sqlsrv_query example
  • Example#2382 - sqlsrv_rollback example
  • Example#2383 - sqlsrv_rows_affected example
  • Example#2384 - sqlsrv_send_stream_data example
  • Example#2385 - sqlsrv_server_info example
  • Example#2386 - Putting and getting a key-value pair
  • Example#2387 - TokyoTyrant::add example
  • Example#2388 - TokyoTyrant::connect example
  • Example#2389 - TokyoTyrant::connectUri example
  • Example#2390 - TokyoTyrant::copy example
  • Example#2391 - TokyoTyrant::ext example
  • Example#2392 - TokyoTyrant::fwmKeys example
  • Example#2393 - TokyoTyrant::get example
  • Example#2394 - TokyoTyrant::getIterator example
  • Example#2395 - TokyoTyrant::num example
  • Example#2396 - TokyoTyrant::out example
  • Example#2397 - TokyoTyrant::put example
  • Example#2398 - TokyoTyrant::putCat example
  • Example#2399 - tokyotyrant::putKeep example
  • Example#2400 - TokyoTyrant::putNr example
  • Example#2401 - TokyoTyrant::putShl example
  • Example#2402 - TokyoTyrant::setMaster example
  • Example#2403 - TokyoTyrant::size example
  • Example#2404 - TokyoTyrant::stat example
  • Example#2405 - TokyoTyrant::vanish example
  • Example#2406 - TokyoTyrantTable::genUid example
  • Example#2407 - TokyoTyrantTable::get example
  • Example#2408 - TokyoTyrantTable::getIterator example
  • Example#2409 - TokyoTyrantTable::getQuery example
  • Example#2410 - TokyoTyrantTable::out example
  • Example#2411 - TokyoTyrantTable::put example
  • Example#2412 - TokyoTyrantTable::putCat example
  • Example#2413 - TokyoTyrantTable::putKeep example
  • Example#2414 - TokyoTyrantQuery::addCond example
  • Example#2415 - TokyoTyrantQuery::__construct example
  • Example#2416 - TokyoTyrantQuery::count example
  • Example#2417 - TokyoTyrantQuery iterator example
  • Example#2418 - TokyoTyrantQuery::hint example
  • Example#2419 - TokyoTyrantQuery iterator example
  • Example#2420 - TokyoTyrantQuery::metaSearch example
  • Example#2421 - TokyoTyrantQuery iterator example
  • Example#2422 - TokyoTyrantQuery::out example
  • Example#2423 - TokyoTyrantQuery iterator example
  • Example#2424 - TokyoTyrantQuery::search example
  • Example#2425 - TokyoTyrantQuery iterator example
  • Example#2426 - TokyoTyrantIterator::__construct example
  • Example#2427 - cal_days_in_month example
  • Example#2428 - cal_from_jd example
  • Example#2429 - cal_info example
  • Example#2430 - easter_date example
  • Example#2431 - easter_days example
  • Example#2432 - Calendar functions
  • Example#2433 - jdtojewish Example
  • Example#2434 - DateTimeImmutable::add/sub add intervals which cover elapsed time
  • Example#2435 - DateTimeImmutable::modify and strtotime increment or decrement individual component values
  • Example#2436 - Adding or subtracting times can over- or underflow dates
  • Example#2437 - DateTime::add 例程
  • Example#2438 - Further DateTime::add 例程
  • Example#2439 - 当在 DateTime 上加月的时候要注意
  • Example#2440 - DateTime::__construct 例程
  • Example#2441 - DateTime::__construct 的复杂用法
  • Example#2442 - DateTime::createFromFormat 例程
  • Example#2443 - DateTime::createFromFormat 的复杂用法
  • Example#2444 - 格式化字符串中包含了需要进行转义的字符
  • Example#2445 - Creating a mutable date time object
  • Example#2446 - Creating a mutable date time object
  • Example#2447 - DateTime::getLastErrors 例程
  • Example#2448 - DateTime::modify 例程
  • Example#2449 - 增加或者减少月份的时候需要注意
  • Example#2450 - DateTime::setDate 例程
  • Example#2451 - 超出范围的部分会向上一级增加
  • Example#2452 - DateTime::setISODate 例程
  • Example#2453 - 超出有效范围的部分，会加到上一级
  • Example#2454 - 找出来某个周所属的月份
  • Example#2455 - DateTime::setTime 例程
  • Example#2456 - 超出有效范围的部分会增加到上一级
  • Example#2457 - DateTime::setTimestamp 例程
  • Example#2458 - PHP 5.2 之后的版本中，DateTime::setTimestamp 替代方案
  • Example#2459 - DateTime::setTimeZone 例程
  • Example#2460 - DateTime::sub 例程
  • Example#2461 - Further DateTime::sub 例程
  • Example#2462 - 减去一定量的月份的时候需要注意
  • Example#2463 - Creating an immutable date time object
  • Example#2464 - Creating an immutable date time object
  • Example#2465 - DateTime::diff example
  • Example#2466 - DateTime object comparison
  • Example#2467 - DateTime::format example
  • Example#2468 - DateTime::getOffset example
  • Example#2469 - DateTime::getTimestamp example
  • Example#2470 - DateTime::getTimezone example
  • Example#2471 - Catching errors when instantiating DateTimeZone
  • Example#2472 - DateTimeZone::getLocation 函数的范例：
  • Example#2473 - DateTimeZone::getOffset 例子
  • Example#2474 - A timezone_transitions_get example
  • Example#2475 - timezone_abbreviations_list 函数的范例：
  • Example#2476 - timezone_identifiers_list 函数的范例：
  • Example#2477 - DateInterval example
  • Example#2478 - Parsing valid date intervals
  • Example#2479 - DateInterval example
  • Example#2480 - DateInterval and carry over points
  • Example#2481 - DateInterval and DateTime::diff with the %a and %d modifiers
  • Example#2482 - DatePeriod example
  • Example#2483 - DatePeriod example with DatePeriod::EXCLUDE_START_DATE
  • Example#2484 - DatePeriod::getDateInterval example
  • Example#2485 - DatePeriod::getEndDate example
  • Example#2486 - DatePeriod::getEndDate without an end date
  • Example#2487 - DatePeriod::getStartDate example
  • Example#2488 - checkdate 例子
  • Example#2489 - 获取默认时区
  • Example#2490 - 获取一个时区的简写
  • Example#2491 - 获取默认时区
  • Example#2492 - date_parse_from_format example
  • Example#2493 - date_parse 示例
  • Example#2494 - date_parse 使用相对格式
  • Example#2495 - A date_sun_info example
  • Example#2496 - Polar night
  • Example#2497 - Midnight sun
  • Example#2498 - date_sunrise 例子
  • Example#2499 - date_sunset 例子
  • Example#2500 - date 例子
  • Example#2501 - 在 date 中转义字符
  • Example#2502 - date 和 mktime 例子
  • Example#2503 - date 格式举例
  • Example#2504 - date 函数示例
  • Example#2505 - 对 date 函数中的格式字符串进行转义
  • Example#2506 - date 和 mktime 联合使用示例
  • Example#2507 - date 函数格式化
  • Example#2508 - getdate 例子
  • Example#2509 - gettimeofday 例子
  • Example#2510 - gmdate 例子
  • Example#2511 - gmmktime 在 Windows 中的边界
  • Example#2512 - gmstrftime 例子
  • Example#2513 - localtime 例子
  • Example#2514 - 用 microtime 对脚本的运行计时
  • Example#2515 - 基本例子
  • Example#2516 - mktime 例子
  • Example#2517 - 下个月的最后一天
  • Example#2518 - strftime 区域的例子
  • Example#2519 - ISO 8601:1988 week number example
  • Example#2520 - %e 修改器跨平台兼容的例子
  • Example#2521 - 显示所有已知和未知的格式
  • Example#2522 - strptime 例子
  • Example#2523 - strtotime 例子
  • Example#2524 - 失败检查
  • Example#2525 - time 例子
  • Example#2526 - A timezone_name_from_abbr example
  • Example#2527 - 获取 timezonedb 版本
  • Example#2528 - Measure several code blocks execution and get the total
  • Example#2529 - Closing an open file descriptor
  • Example#2530 - Setting and clearing a lock
  • Example#2531 - Opening a file descriptor
  • Example#2532 - Positioning in a file
  • Example#2533 - Setting the baud rate on a serial port
  • Example#2534 - chdir 例子
  • Example#2535 - chroot example
  • Example#2536 - closedir 例子
  • Example#2537 - dir 示例
  • Example#2538 - getcwd 例子
  • Example#2539 - opendir 例子
  • Example#2540 - 列出目录中的所有文件
  • Example#2541 - 列出当前目录的所有文件并去掉 . 和 ..
  • Example#2542 - 一个简单的 scandir 例子
  • Example#2543 - scandir 在 PHP 4 中的实现
  • Example#2544 - finfo_buffer 函数例程
  • Example#2545 - finfo_file 例程
  • Example#2546 - 面向对象风格
  • Example#2547 - 过程化风格
  • Example#2548 - mime_content_type 示例
  • Example#2549 - basename 例子
  • Example#2550 - 改变文件所属的组
  • Example#2551 - 简单的 chown 用法
  • Example#2552 - clearstatcache 例子
  • Example#2553 - copy 例子
  • Example#2554 - dirname 例子
  • Example#2555 - disk_free_space 例子
  • Example#2556 - disk_total_space 例子
  • Example#2557 - 一个简单 fclose 例子
  • Example#2558 - 处理 feof 的超时
  • Example#2559 - 使用无效文件指针的 feof 例子
  • Example#2560 - File write example using fflush
  • Example#2561 - 一个 fgetc 例子
  • Example#2562 - 读取并显示 CSV 文件的整个内容
  • Example#2563 - 逐行读取文件
  • Example#2564 - 一行行读取一个 PHP 文件
  • Example#2565 - 测试一个文件是否存在
  • Example#2566 - Get and output the source of the homepage of a website
  • Example#2567 - Searching within the include_path
  • Example#2568 - Reading a section of a file
  • Example#2569 - Using stream contexts
  • Example#2570 - Simple usage example
  • Example#2571 - Using flags
  • Example#2572 - file 例子
  • Example#2573 - fileatime 例子
  • Example#2574 - filectime 例子
  • Example#2575 - 查找文件所在的组
  • Example#2576 - 将某个文件和当前文件的 inode 进行对比
  • Example#2577 - filemtime 例子
  • Example#2578 - 找到文件的所有者
  • Example#2579 - 以八进制的形式显示文件的权限
  • Example#2580 - 输出全部权限
  • Example#2581 - filesize 例子
  • Example#2582 - filetype 例子
  • Example#2583 - flock 例子
  • Example#2584 - flock 使用 LOCK_NB 选项
  • Example#2585 - 用 shell 中的通配符模式匹配来检查颜色名称
  • Example#2586 - fopen 例子
  • Example#2587 - 对二进制文件使用 fpassthru
  • Example#2588 - fputcsv 例子
  • Example#2589 - 一个简单的 fread 例子
  • Example#2590 - Binary fread example
  • Example#2591 - Remote fread examples
  • Example#2592 - fscanf 例子
  • Example#2593 - users.txt 的内容
  • Example#2594 - fseek 例子
  • Example#2595 - fstat 例子
  • Example#2596 - ftell 例子
  • Example#2597 - File truncation example
  • Example#2598 - 一个简单的 fwrite 例子
  • Example#2599 - 怎样用 glob 方便地替代 opendir 和相关函数
  • Example#2600 - is_dir 例子
  • Example#2601 - is_executable 例子
  • Example#2602 - is_file 例子
  • Example#2603 - 创建并确认一个文件是否为符号连接
  • Example#2604 - is_readable 例子
  • Example#2605 - is_uploaded_file 例子
  • Example#2606 - is_writable 例子
  • Example#2607 - 更改符号链接的所有组
  • Example#2608 - Changing the owner of a symbolic link
  • Example#2609 - Creating a simple hard link
  • Example#2610 - linkinfo 例子
  • Example#2611 - stat 和 lstat 的对照
  • Example#2612 - mkdir 例子
  • Example#2613 - 通过 recursive 参数使用 mkdir
  • Example#2614 - Uploading multiple files
  • Example#2615 - sample.ini 的内容
  • Example#2616 - parse_ini_file 例子
  • Example#2617 - parse_ini_file parsing a php.ini file
  • Example#2618 - pathinfo 例子
  • Example#2619 - pathinfo example showing difference between null and no extension
  • Example#2620 - pclose 例子
  • Example#2621 - popen 例子
  • Example#2622 - popen 例子
  • Example#2623 - 使用 readfile 强制下载
  • Example#2624 - readlink 例
  • Example#2625 - realpath_cache_get example
  • Example#2626 - realpath_cache_size example
  • Example#2627 - realpath 例子
  • Example#2628 - Windows 上的 realpath
  • Example#2629 - rename 例子
  • Example#2630 - rewind overwriting example
  • Example#2631 - rmdir 例子
  • Example#2632 - stat 例子
  • Example#2633 - Using stat information together with touch
  • Example#2634 - 创建一个符号连接
  • Example#2635 - tempnam 例子
  • Example#2636 - tmpfile 例子
  • Example#2637 - touch 例子
  • Example#2638 - 使用 time 参数的 touch
  • Example#2639 - umask 例子
  • Example#2640 - 基本的 unlink 用法
  • Example#2641 - Example usage of inotify
  • Example#2642 - setproctitle example
  • Example#2643 - setthreadtitle example
  • Example#2644 - Checks if system administrator has signed the file
  • Example#2645 - Prints names of all extended attributes of file
  • Example#2646 - Removes all extended attributes of a file
  • Example#2647 - Sets extended attributes on .wav file
  • Example#2648 - xattr_supported example
  • Example#2649 - xdiff_file_bdiff_size example
  • Example#2650 - xdiff_file_bdiff example
  • Example#2651 - xdiff_file_bpatch example
  • Example#2652 - xdiff_file_diff_binary example
  • Example#2653 - xdiff_file_diff example
  • Example#2654 - xdiff_file_merge3 example
  • Example#2655 - xdiff_file_patch_binary example
  • Example#2656 - xdiff_file_patch example
  • Example#2657 - Patch reversing example
  • Example#2658 - xdiff_file_rabdiff example
  • Example#2659 - xdiff_string_bdiff_size example
  • Example#2660 - xdiff_string_diff example
  • Example#2661 - xdiff_string_patch example
  • Example#2662 - Enchant Usage Example
  • Example#2663 - List the backends provided by the given broker
  • Example#2664 - A enchant_broker_dict_exists example
  • Example#2665 - List all available dictionaries for one broker
  • Example#2666 - A enchant_broker_request_dict example
  • Example#2667 - Adding a word to a PWL
  • Example#2668 - A enchant_dict_describe example
  • Example#2669 - A enchant_dict_quick_check example
  • Example#2670 - A enchant_dict_suggest example
  • Example#2671 - Usage example.
  • Example#2672 - Using Gender\Gender::country
  • Example#2673 - bindtextdomain example
  • Example#2674 - gettext-check
  • Example#2675 - ngettext example
  • Example#2676 - iconv_get_encoding 例子
  • Example#2677 - iconv_mime_decode_headers 例子
  • Example#2678 - iconv_mime_decode实例
  • Example#2679 - iconv_mime_encode example
  • Example#2680 - iconv_set_encoding 例子
  • Example#2681 - iconv 例子
  • Example#2682 - ob_iconv_handler 例子：
  • Example#2683 - Example of using the procedural API
  • Example#2684 - Example of using the object-oriented API
  • Example#2685 - FRENCH_COLLATION rules
  • Example#2686 - ALTERNATE_HANDLING rules
  • Example#2687 - CASE_FIRST rules
  • Example#2688 - CASE_LEVEL rules
  • Example#2689 - collator_asortexample
  • Example#2690 - collator_compareexample
  • Example#2691 - Collator::__construct example
  • Example#2692 - collator_create example
  • Example#2693 - collator_get_attribute example
  • Example#2694 - collator_get_error_code example
  • Example#2695 - collator_get_error_message example
  • Example#2696 - collator_get_locale example
  • Example#2697 - collator_get_sort_keyexample
  • Example#2698 - collator_get_strength example
  • Example#2699 - collator_set_attribute example
  • Example#2700 - collator_set_strength example
  • Example#2701 - collator_sort_with_sort_keys example
  • Example#2702 - collator_sort example
  • Example#2703 - numfmt_create example
  • Example#2704 - NumberFormatter::create example
  • Example#2705 - numfmt_format_currency example
  • Example#2706 - OO example
  • Example#2707 - numfmt_format example
  • Example#2708 - OO example
  • Example#2709 - numfmt_get_attribute example
  • Example#2710 - OO example
  • Example#2711 - numfmt_get_error_code example
  • Example#2712 - OO example
  • Example#2713 - numfmt_get_error_message example
  • Example#2714 - OO example
  • Example#2715 - numfmt_get_locale example
  • Example#2716 - numfmt_get_pattern example
  • Example#2717 - OO example
  • Example#2718 - numfmt_get_symbol example
  • Example#2719 - OO example
  • Example#2720 - numfmt_get_text_attribute example
  • Example#2721 - OO example
  • Example#2722 - numfmt_parse_currency example
  • Example#2723 - OO example
  • Example#2724 - numfmt_parse example
  • Example#2725 - OO example
  • Example#2726 - numfmt_set_attribute example
  • Example#2727 - OO example
  • Example#2728 - numfmt_set_pattern example
  • Example#2729 - OO example
  • Example#2730 - numfmt_set_symbol example
  • Example#2731 - OO example
  • Example#2732 - numfmt_set_text_attribute example
  • Example#2733 - OO example
  • Example#2734 - locale_accept_from_http example
  • Example#2735 - OO example
  • Example#2736 - locale_compose example
  • Example#2737 - OO example
  • Example#2738 - locale_filter_matches example
  • Example#2739 - OO example
  • Example#2740 - locale_get_all_variants example
  • Example#2741 - OO example
  • Example#2742 - locale_get_default example
  • Example#2743 - OO example
  • Example#2744 - locale_get_display_language example
  • Example#2745 - OO example
  • Example#2746 - locale_get_display_name example
  • Example#2747 - OO example
  • Example#2748 - locale_get_display_region example
  • Example#2749 - OO example
  • Example#2750 - locale_get_display_script example
  • Example#2751 - OO example
  • Example#2752 - locale_get_display_variant example
  • Example#2753 - OO example
  • Example#2754 - locale_get_keywords example
  • Example#2755 - OO example
  • Example#2756 - locale_get_primary_language example
  • Example#2757 - OO example
  • Example#2758 - locale_get_region example
  • Example#2759 - OO example
  • Example#2760 - locale_get_script example
  • Example#2761 - OO example
  • Example#2762 - locale_lookup example
  • Example#2763 - OO example
  • Example#2764 - locale_parse example
  • Example#2765 - OO example
  • Example#2766 - locale_set_default example
  • Example#2767 - OO example
  • Example#2768 - Normalizer::getRawDecomposition example
  • Example#2769 - normalizer_is_normalized example
  • Example#2770 - OO example
  • Example#2771 - normalizer_normalize example
  • Example#2772 - OO example
  • Example#2773 - msgfmt_create example
  • Example#2774 - OO example
  • Example#2775 - msgfmt_format_message example
  • Example#2776 - OO example
  • Example#2777 - msgfmt_format example
  • Example#2778 - OO example
  • Example#2779 - msgfmt_get_error_message example
  • Example#2780 - OO example
  • Example#2781 - msgfmt_get_locale example
  • Example#2782 - OO example
  • Example#2783 - msgfmt_get_pattern example
  • Example#2784 - OO example
  • Example#2785 - msgfmt_parse_message example
  • Example#2786 - OO example
  • Example#2787 - msgfmt_parse example
  • Example#2788 - OO example
  • Example#2789 - msgfmt_set_pattern example
  • Example#2790 - OO example
  • Example#2791 - IntlCalendar::add
  • Example#2792 - IntlCalendar::after
  • Example#2793 - IntlCalendar::clear examples
  • Example#2794 - IntlCalendar::createInstance
  • Example#2795 - IntlCalendar::equals
  • Example#2796 - IntlCalendar::fieldDifference
  • Example#2797 - IntlCalendar::fromDateTime
  • Example#2798 - IntlCalendar::get
  • Example#2799 - IntlCalendar::getActualMaximum
  • Example#2800 - IntlCalendar::getAvailableLocales
  • Example#2801 - IntlCalendar::getDayOfWeekType
  • Example#2802 - IntlCalendar::getErrorCode and IntlCalendar::getErrorMessage
  • Example#2803 - IntlCalendar::getErrorMessage
  • Example#2804 - IntlCalendar::getFirstDayOfWeek
  • Example#2805 - IntlCalendar::getKeyworkValuesForLocale
  • Example#2806 - Maxima examples
  • Example#2807 - IntlCalendar::getLocale
  • Example#2808 - IntlCalendar::getMinimalDaysInFirstWeek
  • Example#2809 - IntlCalendar::getNow
  • Example#2810 - IntlCalendar::getRepeatedWallTimeOption
  • Example#2811 - IntlCalendar::getSkippedWallTimeOption
  • Example#2812 - IntlCalendar::getTime
  • Example#2813 - IntlCalendar::getTimeZone
  • Example#2814 - IntlCalendar::getType
  • Example#2815 - IntlCalendar::inDaylightTime
  • Example#2816 - IntlCalendar::isEquivalentTo
  • Example#2817 - IntlCalendar::isLenient
  • Example#2818 - IntlCalendar::isWeekend
  • Example#2819 - IntlCalendar::roll
  • Example#2820 - IntlCalendar::set
  • Example#2821 - IntlCalendar::setFirstDayOfWeek
  • Example#2822 - IntlCalendar::setTime
  • Example#2823 - IntlCalendar::setTimeZone
  • Example#2824 - IntlCalendar::toDateTime
  • Example#2825 - datefmt_create example
  • Example#2826 - OO example
  • Example#2827 - datefmt_format example
  • Example#2828 - OO example
  • Example#2829 - With IntlCalendar object
  • Example#2830 - IntlDateFormatter::formatObject examples
  • Example#2831 - datefmt_get_calendar example
  • Example#2832 - OO example
  • Example#2833 - datefmt_get_datetype example
  • Example#2834 - OO example
  • Example#2835 - datefmt_get_error_code example
  • Example#2836 - OO example
  • Example#2837 - datefmt_get_error_message example
  • Example#2838 - OO example
  • Example#2839 - datefmt_get_locale example
  • Example#2840 - OO example
  • Example#2841 - datefmt_get_pattern example
  • Example#2842 - OO example
  • Example#2843 - datefmt_get_timetype example
  • Example#2844 - OO example
  • Example#2845 - datefmt_get_timezone_id example
  • Example#2846 - OO example
  • Example#2847 - IntlDateFormatter::getCalendarObject example
  • Example#2848 - IntlDateFormatter::getTimeZone examples
  • Example#2849 - datefmt_is_lenient example
  • Example#2850 - OO example
  • Example#2851 - datefmt_localtime example
  • Example#2852 - OO example
  • Example#2853 - OO example
  • Example#2854 - datefmt_parse example
  • Example#2855 - datefmt_set_calendar example
  • Example#2856 - OO example
  • Example#2857 - Example with IntlCalendar argument
  • Example#2858 - datefmt_set_lenient example
  • Example#2859 - OO example
  • Example#2860 - datefmt_set_pattern example
  • Example#2861 - OO example
  • Example#2862 - IntlDateFormatter::setTimeZone examples
  • Example#2863 - resourcebundle_count example
  • Example#2864 - OO example
  • Example#2865 - resourcebundle_create example
  • Example#2866 - ResourceBundle::create example
  • Example#2867 - resourcebundle_get_error_code example
  • Example#2868 - OO example
  • Example#2869 - resourcebundle_get_error_message example
  • Example#2870 - OO example
  • Example#2871 - resourcebundle_get example
  • Example#2872 - OO example
  • Example#2873 - resourcebundle_locales example
  • Example#2874 - OO example
  • Example#2875 - Spoofchecker::areConfusable example
  • Example#2876 - Spoofchecker::isSuspicious example
  • Example#2877 - Retrieving the registered transliterator IDs
  • Example#2878 - Converting escaped UTF-16 code units
  • Example#2879 - grapheme_extract example
  • Example#2880 - grapheme_stripos example
  • Example#2881 - grapheme_stristr example
  • Example#2882 - grapheme_strlen example
  • Example#2883 - grapheme_strpos example
  • Example#2884 - grapheme_strripos example
  • Example#2885 - grapheme_strrpos example
  • Example#2886 - grapheme_strstr example
  • Example#2887 - grapheme_substr example
  • Example#2888 - idn_to_ascii 示例
  • Example#2889 - idn_to_utf8 示例
  • Example#2890 - Testing different code points
  • Example#2891 - Testing different code points
  • Example#2892 - Testing different code points
  • Example#2893 - Testing different code points
  • Example#2894 - Testing different code points
  • Example#2895 - Testing different code points
  • Example#2896 - Testing different code points
  • Example#2897 - Testing different code points
  • Example#2898 - Testing different code points
  • Example#2899 - Enumerating over a sample range of code points
  • Example#2900 - Enumerating over a sample range of code points
  • Example#2901 - Testing different code points
  • Example#2902 - Testing different code points
  • Example#2903 - Testing different code points
  • Example#2904 - Testing different code points
  • Example#2905 - Testing different code points
  • Example#2906 - Testing different properties
  • Example#2907 - Testing different properties
  • Example#2908 - Testing different properties
  • Example#2909 - Testing different code points
  • Example#2910 - Testing different properties
  • Example#2911 - Testing different properties
  • Example#2912 - Testing different properties
  • Example#2913 - Testing different properties
  • Example#2914 - Testing different properties
  • Example#2915 - Testing different properties
  • Example#2916 - Testing different code points
  • Example#2917 - Testing different code points
  • Example#2918 - Testing different code points
  • Example#2919 - Testing different code points
  • Example#2920 - Testing different code points
  • Example#2921 - Testing different code points
  • Example#2922 - Testing different code points
  • Example#2923 - Testing different code points
  • Example#2924 - Testing different code points
  • Example#2925 - Testing different code points
  • Example#2926 - Testing different code points
  • Example#2927 - Testing different code points
  • Example#2928 - Testing different code points
  • Example#2929 - Testing different code points
  • Example#2930 - Testing different code points
  • Example#2931 - Testing different code points
  • Example#2932 - Testing different code points
  • Example#2933 - Testing different code points
  • Example#2934 - Testing different code points
  • Example#2935 - Testing different code points
  • Example#2936 - Testing different code points
  • Example#2937 - Testing different code points
  • Example#2938 - Testing different code points
  • Example#2939 - Testing different code points
  • Example#2940 - Testing different code points
  • Example#2941 - Testing different code points
  • Example#2942 - Testing different code points
  • Example#2943 - Testing different code points
  • Example#2944 - Testing different code points
  • Example#2945 - Testing different code points
  • Example#2946 - Testing different code points
  • Example#2947 - Testing different code points
  • Example#2948 - intl_error_name example
  • Example#2949 - intl_get_error_code example
  • Example#2950 - intl_get_error_message example
  • Example#2951 - intl_is_failure example
  • Example#2952 - php.ini 设置例子
  • Example#2953 - php.ini 里 EUC-JP 用户的设置
  • Example#2954 - php.ini 里 SJIS 用户的设置
  • Example#2955 - 在 php.ini 中禁用 HTTP 输入转换
  • Example#2956 - php.ini 设置例子
  • Example#2957 - 脚本例子
  • Example#2958 - mb_convert_case 例子
  • Example#2959 - 非拉丁 UTF-8 文本的mb_convert_case 例子
  • Example#2960 - mb_convert_encoding 例子
  • Example#2961 - mb_convert_kana example
  • Example#2962 - mb_convert_variables 例子
  • Example#2963 - convmap 例子
  • Example#2964 - convmap 的例子： 编码(escape) JavaScript 字符串
  • Example#2965 - mb_detect_encoding 例子
  • Example#2966 - mb_detect_order 例子
  • Example#2967 - 案例展示了无效的检测顺序
  • Example#2968 - mb_encode_mimeheader 例子
  • Example#2969 - map example
  • Example#2970 - mb_encode_numericentity example
  • Example#2971 - mb_encoding_aliases example
  • Example#2972 - mb_ereg_replace_callback example
  • Example#2973 - mb_ereg_replace_callback using anonymous function supported in PHP 5.3.0 or later
  • Example#2974 - mb_internal_encoding 例子
  • Example#2975 - mb_list_encodings 例子
  • Example#2976 - mb_output_handler 例子
  • Example#2977 - mb_preferred_mime_name 例子
  • Example#2978 - mb_strimwidth 例子
  • Example#2979 - mb_strtolower 例子
  • Example#2980 - 非拉丁 UTF-8 文本的 mb_strtolower 例子
  • Example#2981 - mb_strtoupper 例子
  • Example#2982 - 非拉丁 UTF-8 文本的 mb_strtoupper 例子
  • Example#2983 - mb_substitute_character 例子
  • Example#2984 - mb_substr_count 例子
  • Example#2985 - pspell_add_to_personal
  • Example#2986 - pspell_check Example
  • Example#2987 - pspell_add_to_personal Example
  • Example#2988 - pspell_config_create
  • Example#2989 - pspell_config_ignore
  • Example#2990 - pspell_config_mode Example
  • Example#2991 - pspell_config_personal
  • Example#2992 - pspell_config_repl
  • Example#2993 - pspell_config_runtogether
  • Example#2994 - pspell_new_config
  • Example#2995 - pspell_new_personal
  • Example#2996 - pspell_new
  • Example#2997 - pspell_add_to_personal
  • Example#2998 - pspell_store_replacement
  • Example#2999 - pspell_suggest example
  • Example#3000 - Basic recode_file example
  • Example#3001 - Basic recode_string example
  • Example#3002 - exif_imagetype 例子
  • Example#3003 - exif_read_data 例子
  • Example#3004 - exif_tagname 函数例程
  • Example#3005 - exif_thumbnail 例子
  • Example#3006 - 使用 PHP 创建 PNG 图像
  • Example#3007 - 使用 Alpha 通道为图像加水印
  • Example#3008 - 使用 imagecopymerge 函数创建半透明水印
  • Example#3009 - 使用 gd_info
  • Example#3010 - getimagesize（文件）
  • Example#3011 - getimagesize（URL）
  • Example#3012 - getimagesize() 和 MIME 类型
  • Example#3013 - getimagesize() 返回 IPTC
  • Example#3014 - getimagesize and MIME types
  • Example#3015 - getimagesize example
  • Example#3016 - getimagesize (URL)
  • Example#3017 - getimagesize() returning IPTC
  • Example#3018 - getimagesizefromstring 函数例程
  • Example#3019 - image_type_to_extension 例子
  • Example#3020 - image_type_to_mime_type (file)
  • Example#3021 - image2wbmp 例子
  • Example#3022 - imageaffinematrixconcat example
  • Example#3023 - imageaffinematrixget example
  • Example#3024 - imagealphablending usage example
  • Example#3025 - A comparison of two lines, one with anti-aliasing switched on
  • Example#3026 - 用 imagearc 画一个圆
  • Example#3027 - Saving a BMP file
  • Example#3028 - imagechar 例子
  • Example#3029 - imagecharup 例子
  • Example#3030 - imagecolorallocate 例子
  • Example#3031 - 使用 imagecolorallocatealpha 的例子
  • Example#3032 - Example of using imagecolorallocatealpha
  • Example#3033 - 取得各自的 RGB 值
  • Example#3034 - Search for a set of colors in an image
  • Example#3035 - 使用 imagecolorclosesthwb 的例子
  • Example#3036 - Get colors from the GD logo
  • Example#3037 - imagecolormatch 例子
  • Example#3038 - Using imagecoloresolvealpha to get colors from an image
  • Example#3039 - imagecolorsforindex 例子
  • Example#3040 - Embossing the PHP.net logo
  • Example#3041 - Gaussian blur
  • Example#3042 - 简单的例子
  • Example#3043 - 按比例对图像重新采样
  • Example#3044 - Resizing an image
  • Example#3045 - 新建一个新的 GD 图像流并输出图像
  • Example#3046 - Convert an BMP image to a PNG image using imagecreatefrombmp
  • Example#3047 - imagecreatefromgd2 例子
  • Example#3048 - imagecreatefromgd2part example
  • Example#3049 - imagecreatefromgd 例子
  • Example#3050 - 处理创建过程中的错误
  • Example#3051 - 处理创建过程中的错误
  • Example#3052 - 处理创建 PNG 过程中的错误
  • Example#3053 - imagecreatefromstring example
  • Example#3054 - 处理创建 WBMP 过程中的错误
  • Example#3055 - Convert an WebP image to a jpeg image using imagecreatefromwebp
  • Example#3056 - Convert an XBM image to a png image using imagecreatefromxbm
  • Example#3057 - Creating an image instance using imagecreatefromxpm
  • Example#3058 - 新建一个新的 GD 图像流并输出图像
  • Example#3059 - imagecrop example
  • Example#3060 - Proper handling of auto-cropping
  • Example#3061 - imageellipse 例子
  • Example#3062 - imagefill 例子
  • Example#3063 - 创建一 3D 效果的饼状图
  • Example#3064 - imagefilledellipse 例子
  • Example#3065 - imagefilledpolygon 例子
  • Example#3066 - imagefilter 灰度例子
  • Example#3067 - imagefilter 亮度例子
  • Example#3068 - imagefilter 上彩例子
  • Example#3069 - imagefilter grayscale example
  • Example#3070 - imagefilter brightness example
  • Example#3071 - imagefilter colorize example
  • Example#3072 - imagefilter negate example
  • Example#3073 - imagefilter pixelate example
  • Example#3074 - Flips an image vertically
  • Example#3075 - Flips the image horizontally
  • Example#3076 - imageftbbox example
  • Example#3077 - imagefttext example
  • Example#3078 - 输出一个 GD2 图像
  • Example#3079 - 保存 GD2 图像
  • Example#3080 - imagegetclip example
  • Example#3081 - 使用 imagegif 输出一个图像
  • Example#3082 - 使用 imagegif 将一个 PNG 转换成 GIF
  • Example#3083 - imagegrabscreen example
  • Example#3084 - imagegrabwindow example
  • Example#3085 - 使用 imageinterlace 打开隔行扫描
  • Example#3086 - Simple detection of true color image instances using imageistruecolor
  • Example#3087 - 输出 JPEG 图像
  • Example#3088 - 保存一副 JPEG 图像
  • Example#3089 - 以 75% 的图像质量输出图像
  • Example#3090 - imagelayereffect example
  • Example#3091 - 画一条粗线
  • Example#3092 - 使用 imageloadfont
  • Example#3093 - imageopenpolygon example
  • Example#3094 - Converts any image resource to true color
  • Example#3095 - imagepolygon 例子
  • Example#3096 - Setting and getting the resolution of an image
  • Example#3097 - 将图像旋转 180 度
  • Example#3098 - imagesavealpha 例子
  • Example#3099 - imagesetinterpolation example
  • Example#3100 - imagesetstyle 例子
  • Example#3101 - imagesetthickness example
  • Example#3102 - imagestring 例子
  • Example#3103 - 使用 imagesx
  • Example#3104 - 使用 imagesy
  • Example#3105 - Converting a true color image to a palette-based image
  • Example#3106 - imagettftext 例子
  • Example#3107 - imagetypes 例子
  • Example#3108 - 保存为 WebP 图像文件
  • Example#3109 - 保存一个 XBM 文件
  • Example#3110 - 以不同前景色保存一个 XBM 文件
  • Example#3111 - Embedding IPTC data into a JPEG
  • Example#3112 - iptcparse() used together with getimagesize
  • Example#3113 - jpeg2wbmp 例子
  • Example#3114 - png2wbmp 例子
  • Example#3115 - Gmagick Example
  • Example#3116 - Gmagick::despeckleimage example
  • Example#3117 - Gmagick::setCompressionQuality
  • Example#3118 - Creating a thumbnail in Imagick
  • Example#3119 - Make a thumbnail of all JPG files in a directory
  • Example#3120 - Creating a reflection of an image
  • Example#3121 - Filling text with gradient
  • Example#3122 - Read in GIF image and resize all frames
  • Example#3123 - Create a PHP logo
  • Example#3124 - Using Imagick::adaptiveBlurImage:
  • Example#3125 - Using Imagick::adaptiveResizeImage
  • Example#3126 - A Imagick::adaptiveSharpenImage example
  • Example#3127 - Imagick::adaptiveThresholdImage
  • Example#3128 - Imagick::addNoiseImage
  • Example#3129 - Imagick::affineTransformImage
  • Example#3130 - Using Imagick::annotateImage:
  • Example#3131 - Imagick::appendImages example
  • Example#3132 - Imagick::autoLevelImage
  • Example#3133 - Imagick::blackThresholdImage
  • Example#3134 - Imagick::blueShiftImage
  • Example#3135 - Using Imagick::blurImage:
  • Example#3136 - Imagick::borderImage
  • Example#3137 - Imagick::brightnessContrastImage
  • Example#3138 - Imagick::charcoalImage
  • Example#3139 - Using Imagick::chopImage:
  • Example#3140 - Imagick object cloning in different versions of imagick
  • Example#3141 - Using Imagick::clutImage:
  • Example#3142 - Imagick::colorizeImage
  • Example#3143 - Imagick::colorMatrixImage
  • Example#3144 - Using Imagick::commentImage:
  • Example#3145 - Using Imagick::compareImageLayers
  • Example#3146 - Using Imagick::compareImages:
  • Example#3147 - Imagick::contrastImage
  • Example#3148 - Imagick::convolveImage
  • Example#3149 - Imagick::cropImage
  • Example#3150 - Imagick::deskewImage
  • Example#3151 - Imagick::despeckleImage
  • Example#3152 - Using Imagick::distortImage:
  • Example#3153 - Imagick::edgeImage
  • Example#3154 - Imagick::embossImage
  • Example#3155 - Imagick::enhanceImage
  • Example#3156 - Imagick::equalizeImage
  • Example#3157 - Using Imagick::evaluateImage
  • Example#3158 - Using Imagick::exportImagePixels
  • Example#3159 - Imagick::filter
  • Example#3160 - Imagick::flipImage
  • Example#3161 - Imagick::floodfillPaintImage example
  • Example#3162 - Imagick::flopImage
  • Example#3163 - Imagick::forwardFourierTransformImage
  • Example#3164 - Imagick::frameImage
  • Example#3165 - Create a sinusoidal gradient
  • Example#3166 - Create a gradient from the polynomial (4x^2 - 4x + 1)
  • Example#3167 - Create a complex gradient from the polynomial (4x^2 - 4x^2 + 1) modulated by a sinusoidal gradient
  • Example#3168 - Imagick::fxImage
  • Example#3169 - Imagick::gammaImage
  • Example#3170 - Imagick::gaussianBlurImage
  • Example#3171 - Imagick::getImageGeometry
  • Example#3172 - Generates Imagick::getImageHistogram
  • Example#3173 - Using Imagick::getImageLength:
  • Example#3174 - Using Imagick::getImageProperties:
  • Example#3175 - Using Imagick::getImageProperty:
  • Example#3176 - Using Imagick::getIteratorIndex:
  • Example#3177 - Imagick::getPixelIterator
  • Example#3178 - Imagick::getPixelRegionIterator example
  • Example#3179 - Getting the size of a raw RGB image set at 200x400, after scaling to 400x800 (compared to width / height)
  • Example#3180 - Imagick::haldClutImage
  • Example#3181 - Imagick::identifyFormat
  • Example#3182 - Example Result Format
  • Example#3183 - Imagick::implodeImage
  • Example#3184 - Imagick::importImagePixels example
  • Example#3185 - Imagick::levelImage
  • Example#3186 - Imagick::linearStretchImage
  • Example#3187 - Imagick::magnifyImage
  • Example#3188 - Imagick::medianFilterImage
  • Example#3189 - Imagick::mergeImageLayers
  • Example#3190 - Imagick::modulateImage
  • Example#3191 - Convolve Imagick::morphology
  • Example#3192 - Correlate Imagick::morphology
  • Example#3193 - Erode Imagick::morphology
  • Example#3194 - Erode Intensity Imagick::morphology
  • Example#3195 - Dilate Imagick::morphology
  • Example#3196 - Dilate intensity Imagick::morphology
  • Example#3197 - Distance with Chebyshev kernel Imagick::morphology
  • Example#3198 - Distance with Manhattan kernel Imagick::morphology
  • Example#3199 - Distance with ocatagonal kernel Imagick::morphology
  • Example#3200 - Distance with Euclidean kernel Imagick::morphology
  • Example#3201 - Edge Imagick::morphology
  • Example#3202 - Open Imagick::morphology
  • Example#3203 - Open intensity Imagick::morphology
  • Example#3204 - Close Imagick::morphology
  • Example#3205 - Close Intensity Imagick::morphology
  • Example#3206 - Smooth Imagick::morphology
  • Example#3207 - Edge in Imagick::morphology
  • Example#3208 - Edge out Imagick::morphology
  • Example#3209 - The 'TopHat' method, or more specifically 'White Top Hat', returns the pixels that were removed by a Opening of the shape, that is the pixels that were removed to round off the points, and the connecting bridged between shapes. Imagick::morphology
  • Example#3210 - The 'BottomHat' method, also known as 'Black TopHat' is the pixels that a Closing of the shape adds to the image. That is the pixels that were used to fill in the 'holes', 'gaps', and 'bridges'. Imagick::morphology
  • Example#3211 - Hit and Miss Imagick::morphology
  • Example#3212 - Thinning Imagick::morphology
  • Example#3213 - Thicken Imagick::morphology
  • Example#3214 - Thick to generate a convex hull Imagick::morphology
  • Example#3215 - Iterative morphology Imagick::morphology
  • Example#3216 - Helper functon to get an image silhouette Imagick::morphology
  • Example#3217 - Imagick::motionBlurImage
  • Example#3218 - Imagick::negateImage
  • Example#3219 - Using Imagick::newImage:
  • Example#3220 - Imagick::newPseudoImage
  • Example#3221 - Imagick::normalizeImage
  • Example#3222 - Imagick::oilPaintImage
  • Example#3223 - Using Imagick::optimizeImageLayers
  • Example#3224 - Imagick::orderedPosterizeImage
  • Example#3225 - Using Imagick::pingImageBlob
  • Example#3226 - Using Imagick::pingImageFile
  • Example#3227 - A Imagick::polaroidImage example
  • Example#3228 - Imagick::posterizeImage
  • Example#3229 - Imagick::quantizeImage
  • Example#3230 - Using Imagick::queryFontMetrics:
  • Example#3231 - Imagick::queryFonts
  • Example#3232 - Imagick::queryFormats
  • Example#3233 - Imagick::radialBlurImage
  • Example#3234 - Imagick::raiseImage
  • Example#3235 - Imagick::randomThresholdImage
  • Example#3236 - Imagick::readImageBlob
  • Example#3237 - Imagick::recolorImage
  • Example#3238 - Imagick::reduceNoiseImage
  • Example#3239 - Imagick::resampleImage
  • Example#3240 - Imagick::resizeImage
  • Example#3241 - Imagick::rollImage
  • Example#3242 - Imagick::rotateImage
  • Example#3243 - Imagick::rotationalBlurImage
  • Example#3244 - Using Imagick::roundCorners:
  • Example#3245 - Imagick::scaleImage
  • Example#3246 - Imagick::segmentImage
  • Example#3247 - Imagick::selectiveBlurImage
  • Example#3248 - Imagick::separateImageChannel
  • Example#3249 - Imagick::sepiaToneImage
  • Example#3250 - Imagick::setCompressionQuality
  • Example#3251 - A Imagick::setFont example
  • Example#3252 - A Imagick::setImage example
  • Example#3253 - Imagick::setImageArtifact
  • Example#3254 - Imagick::setImageBias
  • Example#3255 - Imagick::setImageClipMask
  • Example#3256 - Modify animated Gif with Imagick::setImageDelay
  • Example#3257 - Basic Imagick::setImageIterations usage
  • Example#3258 - A Imagick::setImageOpacity example
  • Example#3259 - Imagick::setImageOrientation
  • Example#3260 - Using Imagick::setImageProperty:
  • Example#3261 - Imagick::setImageResolution
  • Example#3262 - Modify animated Gif with Imagick::setImageTicksPerSecond
  • Example#3263 - Using Imagick::setIteratorIndex:
  • Example#3264 - Attempt to reach '$extent' sizeImagick::setOption
  • Example#3265 - Imagick::setOption
  • Example#3266 - Imagick::setOption
  • Example#3267 - A Imagick::setPointSize example
  • Example#3268 - Imagick::setProgressMonitor
  • Example#3269 - Imagick::setSamplingFactors
  • Example#3270 - Imagick::shadeImage
  • Example#3271 - Imagick::shadowImage
  • Example#3272 - Imagick::sharpenImage
  • Example#3273 - Imagick::shaveImage
  • Example#3274 - Imagick::shearImage
  • Example#3275 - Create a gradient image using Imagick::sigmoidalContrastImage suitable for blending two images together smoothly, with the blending defined by $contrast and $the midpoint
  • Example#3276 - Imagick::sketchImage
  • Example#3277 - Imagick::smushImages
  • Example#3278 - Imagick::solarizeImage
  • Example#3279 - SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage
  • Example#3280 - SPARSECOLORMETHOD_BILINEAR Imagick::sparseColorImage
  • Example#3281 - SPARSECOLORMETHOD_SPEPARDS Imagick::sparseColorImage
  • Example#3282 - SPARSECOLORMETHOD_VORONOI Imagick::sparseColorImage
  • Example#3283 - SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage
  • Example#3284 - createGradientImage is used by other examples. Imagick::sparseColorImage
  • Example#3285 - Imagick::spliceImage
  • Example#3286 - Imagick::spreadImage
  • Example#3287 - Imagick::statisticImage
  • Example#3288 - Imagick::subImageMatch
  • Example#3289 - Imagick::swirlImage
  • Example#3290 - Imagick::textureImage
  • Example#3291 - Imagick::thresholdImage
  • Example#3292 - Imagick::thumbnailImage
  • Example#3293 - Imagick::tintImage
  • Example#3294 - Using Imagick::transformImage:
  • Example#3295 - Imagick::transformImageColorspace example
  • Example#3296 - Imagick::transformImageColorspace
  • Example#3297 - Imagick::transparentPaintImage
  • Example#3298 - Imagick::transposeImage
  • Example#3299 - Imagick::transverseImage
  • Example#3300 - Using Imagick::trimImage:
  • Example#3301 - Imagick::uniqueImageColors
  • Example#3302 - Imagick::unsharpMaskImage
  • Example#3303 - Imagick::vignetteImage
  • Example#3304 - WaveImage can be quite slow Imagick::waveImage
  • Example#3305 - Imagick::whiteThresholdImage
  • Example#3306 - ImagickDraw::affine
  • Example#3307 - ImagickDraw::arc
  • Example#3308 - ImagickDraw::bezier
  • Example#3309 - ImagickDraw::circle
  • Example#3310 - ImagickDraw::composite
  • Example#3311 - ImagickDraw::ellipse
  • Example#3312 - ImagickDraw::line
  • Example#3313 - ImagickDraw::matte
  • Example#3314 - ImagickDraw::pathCurveToQuadraticBezierAbsolute
  • Example#3315 - ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute
  • Example#3316 - ImagickDraw::pathCurveToQuadraticBezierSmoothRelative
  • Example#3317 - ImagickDraw::pathStart
  • Example#3318 - ImagickDraw::point
  • Example#3319 - ImagickDraw::polygon
  • Example#3320 - ImagickDraw::polyline
  • Example#3321 - ImagickDraw::popDefs
  • Example#3322 - ImagickDraw::push
  • Example#3323 - ImagickDraw::pushPattern
  • Example#3324 - ImagickDraw::rectangle
  • Example#3325 - ImagickDraw::rotate
  • Example#3326 - ImagickDraw::roundRectangle
  • Example#3327 - ImagickDraw::scale
  • Example#3328 - ImagickDraw::setClipPath
  • Example#3329 - ImagickDraw::setClipRule
  • Example#3330 - ImagickDraw::setClipUnits
  • Example#3331 - ImagickDraw::setFillAlpha
  • Example#3332 - ImagickDraw::setFillColor
  • Example#3333 - ImagickDraw::setFillOpacity
  • Example#3334 - ImagickDraw::setFillRule
  • Example#3335 - ImagickDraw::setFont
  • Example#3336 - ImagickDraw::setFontFamily
  • Example#3337 - ImagickDraw::setFontSize
  • Example#3338 - ImagickDraw::setFontStretch
  • Example#3339 - ImagickDraw::setFontStyle
  • Example#3340 - ImagickDraw::setFontWeight
  • Example#3341 - ImagickDraw::setGravity
  • Example#3342 - ImagickDraw::setStrokeAlpha
  • Example#3343 - ImagickDraw::setStrokeAntialias
  • Example#3344 - ImagickDraw::setStrokeColor
  • Example#3345 - ImagickDraw::setStrokeDashArray
  • Example#3346 - ImagickDraw::setStrokeDashOffset
  • Example#3347 - ImagickDraw::setStrokeLineCap
  • Example#3348 - ImagickDraw::setStrokeLineJoin
  • Example#3349 - ImagickDraw::setStrokeMiterLimit
  • Example#3350 - ImagickDraw::setStrokeOpacity
  • Example#3351 - ImagickDraw::setStrokeWidth
  • Example#3352 - ImagickDraw::setTextAlignment
  • Example#3353 - ImagickDraw::setTextAntialias
  • Example#3354 - ImagickDraw::setTextDecoration
  • Example#3355 - ImagickDraw::setTextUnderColor
  • Example#3356 - ImagickDraw::setVectorGraphics
  • Example#3357 - ImagickDraw::setViewBox
  • Example#3358 - ImagickDraw::skewX
  • Example#3359 - ImagickDraw::skewY
  • Example#3360 - ImagickDraw::translate
  • Example#3361 - ImagickPixel::construct
  • Example#3362 - Basic Imagick::getColor usage
  • Example#3363 - Basic Imagick::getColorAsString usage
  • Example#3364 - ImagickPixel getColorCount
  • Example#3365 - Basic Imagick::getColorValue usage
  • Example#3366 - ImagickPixel::getColorValueQuantum
  • Example#3367 - Basic Imagick::getHSL example
  • Example#3368 - ImagickPixel::isSimilar
  • Example#3369 - ImagickPixel::setColor
  • Example#3370 - Basic Imagick::setColorValue usage
  • Example#3371 - ImagickPixel::setColorValueQuantum
  • Example#3372 - Use ImagickPixel::setHSL to modify a color
  • Example#3373 - ImagickPixelIterator::clear
  • Example#3374 - ImagickPixelIterator::construct
  • Example#3375 - ImagickPixelIterator::getNextIteratorRow
  • Example#3376 - ImagickPixelIterator::resetIterator
  • Example#3377 - ImagickPixelIterator::setIteratorRow
  • Example#3378 - imap_append example
  • Example#3379 - imap_check example
  • Example#3380 - imap_createmailbox example
  • Example#3381 - imap_delete example
  • Example#3382 - imap_fetch_overview example
  • Example#3383 - imap_gc example
  • Example#3384 - imap_get_quota example
  • Example#3385 - imap_get_quota 4.3 or greater example
  • Example#3386 - imap_get_quotaroot example
  • Example#3387 - imap_getacl example
  • Example#3388 - imap_getmailboxes example
  • Example#3389 - imap_list example
  • Example#3390 - imap_mail_compose example
  • Example#3391 - imap_mailboxmsginfo example
  • Example#3392 - imap_mime_header_decode example
  • Example#3393 - Different use of imap_open
  • Example#3394 - imap_open example
  • Example#3395 - imap_ping Example
  • Example#3396 - imap_reopen example
  • Example#3397 - imap_rfc822_parse_adrlist example
  • Example#3398 - imap_rfc822_write_address example
  • Example#3399 - imap_search example
  • Example#3400 - imap_set_quota example
  • Example#3401 - imap_setflag_full example
  • Example#3402 - imap_status example
  • Example#3403 - imap_thread Example
  • Example#3404 - imap_timeout example
  • Example#3405 - Basic imap_utf8 Usage
  • Example#3406 - 计算散列值并订阅一个用户
  • Example#3407 - Sending mail.
  • Example#3408 - Sending mail with extra headers.
  • Example#3409 - Sending mail with an additional command line parameter.
  • Example#3410 - Sending HTML email
  • Example#3411 - mailparse_determine_best_xfer_encoding example
  • Example#3412 - mailparse_rfc822_parse_addresses example
  • Example#3413 - mailparse_stream_encode example
  • Example#3414 - mailparse_uudecode_all example
  • Example#3415 - bcadd 示例
  • Example#3416 - bccomp example
  • Example#3417 - bcdiv 示例
  • Example#3418 - bcmod example
  • Example#3419 - bcmul 示例
  • Example#3420 - bcpow 示例
  • Example#3421 - bcpow scale example
  • Example#3422 - bcscale example
  • Example#3423 - bcsqrt 示例
  • Example#3424 - bcsub example
  • Example#3425 - Factorial function using GMP
  • Example#3426 - gmp_abs example
  • Example#3427 - gmp_add example
  • Example#3428 - gmp_and example
  • Example#3429 - gmp_clrbit example
  • Example#3430 - gmp_cmp example
  • Example#3431 - gmp_com example
  • Example#3432 - gmp_div_q example
  • Example#3433 - Division of GMP numbers
  • Example#3434 - gmp_div_r example
  • Example#3435 - gmp_divexact example
  • Example#3436 - gmp_export example
  • Example#3437 - gmp_fact example
  • Example#3438 - gmp_gcd example
  • Example#3439 - Solving a linear Diophantine equation
  • Example#3440 - gmp_hamdist example
  • Example#3441 - gmp_import example
  • Example#3442 - Creating GMP number
  • Example#3443 - gmp_intval example
  • Example#3444 - gmp_invert example
  • Example#3445 - gmp_jacobi example
  • Example#3446 - gmp_legendre example
  • Example#3447 - gmp_mod example
  • Example#3448 - gmp_mul example
  • Example#3449 - gmp_neg example
  • Example#3450 - gmp_nextprime example
  • Example#3451 - gmp_or example
  • Example#3452 - gmp_perfect_square example
  • Example#3453 - gmp_popcount example
  • Example#3454 - gmp_pow example
  • Example#3455 - gmp_powm example
  • Example#3456 - gmp_prob_prime example
  • Example#3457 - gmp_random_bits example
  • Example#3458 - gmp_random_range example
  • Example#3459 - gmp_random_seed example
  • Example#3460 - gmp_random example
  • Example#3461 - gmp_scan0 example
  • Example#3462 - gmp_scan1 example
  • Example#3463 - gmp_setbit example - 0 index
  • Example#3464 - gmp_setbit example - 1 index
  • Example#3465 - gmp_setbit example - clearing a bit
  • Example#3466 - gmp_sign example
  • Example#3467 - gmp_sqrt example
  • Example#3468 - gmp_sqrtrem example
  • Example#3469 - Converting a GMP number to a string
  • Example#3470 - gmp_sub example
  • Example#3471 - gmp_testbit example
  • Example#3472 - gmp_xor example
  • Example#3473 - abs 例子
  • Example#3474 - base_convert 例子
  • Example#3475 - bindec 例子
  • Example#3476 - bindec 将输入解读为无符号整数
  • Example#3477 - ceil 例子
  • Example#3478 - cos 例子
  • Example#3479 - decbin 例子
  • Example#3480 - dechex 例子
  • Example#3481 - 大整数的 dechex 例子
  • Example#3482 - decoct 范例
  • Example#3483 - deg2rad 例子
  • Example#3484 - exp 例子
  • Example#3485 - Using fdiv
  • Example#3486 - floor 例子
  • Example#3487 - fmod 的使用
  • Example#3488 - hexdec 例子
  • Example#3489 - intdiv 的一些例子
  • Example#3490 - is_nan 例子
  • Example#3491 - 使用 max 的例子
  • Example#3492 - min 用法的例子
  • Example#3493 - 计算一个随机浮点数
  • Example#3494 - mt_rand 例子
  • Example#3495 - mt_srand 例子
  • Example#3496 - octdec 例子
  • Example#3497 - pi 例子
  • Example#3498 - pow 的一些例子
  • Example#3499 - rad2deg 例子
  • Example#3500 - rand 例子
  • Example#3501 - round 例子
  • Example#3502 - mode 例子
  • Example#3503 - sin 例子
  • Example#3504 - sqrt 例子
  • Example#3505 - srand 例子
  • Example#3506 - tan 例子
  • Example#3507 - Evaluating a FDF document
  • Example#3508 - Adding JavaScript code to a FDF
  • Example#3509 - Populating a PDF document
  • Example#3510 - Storing an uploaded file
  • Example#3511 - Detecting all fieldnames in a FDF
  • Example#3512 - Accessing the form data
  • Example#3513 - Accessing the form data
  • Example#3514 - Retrieving FDF as a string
  • Example#3515 - Passing FDF data to a second form
  • Example#3516 - gnupg clearsign example (procedural)
  • Example#3517 - gnupg clearsign example (OO)
  • Example#3518 - keylistiterator
  • Example#3519 - Procedural gnupg_adddecryptkey example
  • Example#3520 - OO gnupg_adddecryptkey example
  • Example#3521 - Procedural gnupg_addencryptkey example
  • Example#3522 - OO gnupg_addencryptkey example
  • Example#3523 - Procedural gnupg_addsignkey example
  • Example#3524 - OO gnupg_addsignkey example
  • Example#3525 - Procedural gnupg_cleardecryptkeys example
  • Example#3526 - OO gnupg_cleardecryptkeys example
  • Example#3527 - Procedural gnupg_clearencryptkeys example
  • Example#3528 - OO gnupg_clearencryptkeys example
  • Example#3529 - Procedural gnupg_clearsignkeys example
  • Example#3530 - OO gnupg_clearsignkeys example
  • Example#3531 - Procedural gnupg_decrypt example
  • Example#3532 - OO gnupg_decrypt example
  • Example#3533 - Procedural gnupg_decryptverify example
  • Example#3534 - OO gnupg_decryptverify example
  • Example#3535 - Procedural gnupg_encrypt example
  • Example#3536 - OO gnupg_encrypt example
  • Example#3537 - Procedural gnupg_encryptsign example
  • Example#3538 - OO gnupg_encryptsign example
  • Example#3539 - Procedural gnupg_export example
  • Example#3540 - OO gnupg_export example
  • Example#3541 - Procedural gnupg_geterror example
  • Example#3542 - OO gnupg_geterror example
  • Example#3543 - Procedural gnupg_getprotocol example
  • Example#3544 - OO gnupg_getprotocol example
  • Example#3545 - Procedural gnupg_import example
  • Example#3546 - OO gnupg_import example
  • Example#3547 - Procedural gnupg_init example
  • Example#3548 - OO gnupg initializer example
  • Example#3549 - Procedural gnupg_keyinfo example
  • Example#3550 - OO gnupg_keyinfo example
  • Example#3551 - Procedural gnupg_setarmor example
  • Example#3552 - OO gnupg_setarmor example
  • Example#3553 - Procedural gnupg_seterrormode example
  • Example#3554 - OO gnupg_seterrormode example
  • Example#3555 - Procedural gnupg_setsignmode example
  • Example#3556 - OO gnupg_setsignmode example
  • Example#3557 - Procedural gnupg_sign example
  • Example#3558 - OO gnupg_sign example
  • Example#3559 - Procedural gnupg_verify example
  • Example#3560 - OO gnupg_verify example
  • Example#3561 - Creating and using a pattern
  • Example#3562 - Creating and using a template
  • Example#3563 - Hyphennate a text
  • Example#3564 - Drawing a rectangle
  • Example#3565 - Creating and using a spot color
  • Example#3566 - Rotation of the coordinate system
  • Example#3567 - Placing text at a given position
  • Example#3568 - Drawing a dashed line
  • Example#3569 - Translation of the coordinate system
  • Example#3570 - A rpmdbinfo example
  • Example#3571 - Searching for the package owning a file
  • Example#3572 - A rpminfo example
  • Example#3573 - example
  • Example#3574 - example
  • Example#3575 - example
  • Example#3576 - example
  • Example#3577 - example
  • Example#3578 - example
  • Example#3579 - example
  • Example#3580 - example
  • Example#3581 - example
  • Example#3582 - example
  • Example#3583 - example
  • Example#3584 - example
  • Example#3585 - example
  • Example#3586 - example
  • Example#3587 - example
  • Example#3588 - example
  • Example#3589 - example
  • Example#3590 - example
  • Example#3591 - example
  • Example#3592 - Incorrect requests
  • Example#3593 - Calling request from a request callback
  • Example#3594 - Calling request from a request callback
  • Example#3595 - Using eio with libevent
  • Example#3596 - Cancelling a request
  • Example#3597 - Calling eio_chmod
  • Example#3598 - Making a custom request
  • Example#3599 - Grouping requests
  • Example#3600 - Using eio with libevent extension
  • Example#3601 - Using eio with event extension
  • Example#3602 - eio_cancel example
  • Example#3603 - eio_custom example
  • Example#3604 - eio_event_loop example
  • Example#3605 - eio_lstat example
  • Example#3606 - Using eio with libevent
  • Example#3607 - Grouping requests
  • Example#3608 - eio_grp example
  • Example#3609 - eio_link example
  • Example#3610 - eio_lstat example
  • Example#3611 - eio_mkdir example
  • Example#3612 - eio_mknod example
  • Example#3613 - eio_nreqs example
  • Example#3614 - eio_open example
  • Example#3615 - eio_poll example
  • Example#3616 - eio_read example
  • Example#3617 - eio_readdir example
  • Example#3618 - eio_readlink example
  • Example#3619 - eio_realpath example
  • Example#3620 - eio_rename example
  • Example#3621 - eio_rmdir example
  • Example#3622 - eio_stat example
  • Example#3623 - eio_statvfs example
  • Example#3624 - eio_symlink example
  • Example#3625 - Simple timers
  • Example#3626 - Periodic timer. Tick each 10.5 seconds
  • Example#3627 - Periodic timer. Use reschedule callback
  • Example#3628 - Periodic timer. Tick every 10.5 seconds starting at now
  • Example#3629 - Wait until STDIN is readable
  • Example#3630 - Use some async I/O to access a socket
  • Example#3631 - Embedding one loop into another
  • Example#3632 - Embedding loop created with kqueue backend into the default loop
  • Example#3633 - Handle SIGTERM signal
  • Example#3634 - Monitor changes of /var/log/messages
  • Example#3635 - Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay
  • Example#3636 - Process status changes
  • Example#3637 - Using reschedule callback
  • Example#3638 - Embedding loop created with kqueue backend into the default loop
  • Example#3639 - Embedding one loop into another
  • Example#3640 - Embedding loop created with kqueue backend into the default loop
  • Example#3641 - Embedding loop created with kqueue backend into the default loop
  • Example#3642 - Periodic timer. Use reschedule callback
  • Example#3643 - Periodic timer. Tick every 10.5 seconds starting at now
  • Example#3644 - Hourly watcher
  • Example#3645 - Handle SIGTERM signal
  • Example#3646 - Monitor changes of /var/log/messages
  • Example#3647 - Monitor changes of /var/log/messages
  • Example#3648 - Simple timers
  • Example#3649 - Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay
  • Example#3650 - Register an I/O watcher for some UDP socket but do not keep the event loop from running just because of that watcher.
  • Example#3651 - Expect Usage Example
  • Example#3652 - Another Expect Usage Example
  • Example#3653 - expect_expectl example
  • Example#3654 - expect_popen example
  • Example#3655 - 进程控制示例
  • Example#3656 - pcntl_fork 示例
  • Example#3657 - pcntl_signal_dispatch 示例
  • Example#3658 - pcntl_signal_get_handler example
  • Example#3659 - pcntl_signal示例
  • Example#3660 - pcntl_sigprocmask 示例
  • Example#3661 - pcntl_sigwaitinfo example
  • Example#3662 - posix_access example
  • Example#3663 - posix_ctermid example
  • Example#3664 - posix_get_last_error example
  • Example#3665 - posix_getcwd example
  • Example#3666 - posix_getegid example
  • Example#3667 - posix_geteuid example
  • Example#3668 - posix_getgid example
  • Example#3669 - Example use of posix_getgrgid
  • Example#3670 - Example use of posix_getgrnam
  • Example#3671 - Example use of posix_getgroups
  • Example#3672 - Example use of posix_getlogin
  • Example#3673 - Example use of posix_getpgid
  • Example#3674 - posix_getpid 的使用例子
  • Example#3675 - Example use of posix_getppid
  • Example#3676 - Example use of posix_getpwnam
  • Example#3677 - Example use of posix_getpwuid
  • Example#3678 - Example use of posix_getrlimit
  • Example#3679 - Example use of posix_getsid
  • Example#3680 - Example use of posix_getuid
  • Example#3681 - A posix_mknod example
  • Example#3682 - posix_setegid example
  • Example#3683 - posix_setgid example
  • Example#3684 - posix_setuid example
  • Example#3685 - posix_strerror example
  • Example#3686 - Example use of posix_times
  • Example#3687 - Example use of posix_uname
  • Example#3688 - escapeshellarg 的例子
  • Example#3689 - escapeshellcmd example
  • Example#3690 - exec 例程
  • Example#3691 - 使用 proc_open 函数将进程设置为高优先级
  • Example#3692 - proc_open 例程
  • Example#3693 - shell_exec 例程
  • Example#3694 - system 例程
  • Example#3695 - Example showing Future as return value
  • Example#3696 - Example showing Future as synchronization point
  • Example#3697 - 获取对象属性表中的部分条目
  • Example#3698 - 计算对象中的属性数量
  • Example#3699 - Runtime inheritance
  • Example#3700 - Thread safe objects from closures
  • Example#3701 - 检测线程运行时的致命错误
  • Example#3702 - 检测对象状态
  • Example#3703 - 检测对象状态
  • Example#3704 - 检测对象状态
  • Example#3705 - 给对象属性加锁
  • Example#3706 - 合并数据到对象的属性表
  • Example#3707 - 等待和唤醒
  • Example#3708 - Notifications and Waiting
  • Example#3709 - 弹出对象属性表中的最后一项数据
  • Example#3710 - 弹出对象属性表中第一项数据
  • Example#3711 - 同步
  • Example#3712 - 给对象属性表加锁
  • Example#3713 - 等待和唤醒
  • Example#3714 - 返回创建线程的线程或进程ID
  • Example#3715 - 获取当前执行线程
  • Example#3716 - 返回当前执行线程的ID
  • Example#3717 - 返回引用线程的ID
  • Example#3718 - 在全局范围执行代码块
  • Example#3719 - 检测线程状态
  • Example#3720 - 监测线程是否开始执行
  • Example#3721 - 加入线程
  • Example#3722 - 杀除线程
  • Example#3723 - 开始线程
  • Example#3724 - A basic example of Worker::collect
  • Example#3725 - Worker::getStacked 基本示例
  • Example#3726 - 检测 Worker 对象状态
  • Example#3727 - 检测 Worker 对象状态
  • Example#3728 - 关闭 Worker
  • Example#3729 - 向 Worker 中入栈任务并执行
  • Example#3730 - 从 Worker 栈中移除对象
  • Example#3731 - protected 方法示例： 标记为 protected 的方法在同一时间仅允许一个线程访问
  • Example#3732 - private 方法示例：标记为 private 的方法只能由创建该对象的线程调用
  • Example#3733 - Pool::collect 基本用法示例
  • Example#3734 - 创建 Pool 对象
  • Example#3735 - 完全停止一个 Pool
  • Example#3736 - 提交任务
  • Example#3737 - 提交任务到特定的 Worker
  • Example#3738 - 互斥量的创建与销毁
  • Example#3739 - 互斥量的创建与销毁
  • Example#3740 - 互斥量加锁与解锁
  • Example#3741 - 互斥量的加锁与解锁
  • Example#3742 - 互斥量的加锁与解锁
  • Example#3743 - 广播条件变量
  • Example#3744 - 条件变量的创建与销毁
  • Example#3745 - 条件变量的创建与销毁
  • Example#3746 - 发送唤醒信号
  • Example#3747 - 等待条件变量
  • Example#3748 - New immutability semantics of Threaded
  • Example#3749 - Volatile use-case
  • Example#3750 - Adding a new class task to a thread
  • Example#3751 - Adding a new file task to a thread
  • Example#3752 - Adding a new function task to a thread
  • Example#3753 - Joining a thread
  • Example#3754 - Starting a new thread
  • Example#3755 - Getting the task count of a thread
  • Example#3756 - Locking a hash table's mutex lock
  • Example#3757 - Getting a hash table's size
  • Example#3758 - Locking a hash table's mutex lock
  • Example#3759 - Creating a new vector
  • Example#3760 - Deleting values in a vector
  • Example#3761 - Inserting a value into a vector
  • Example#3762 - Locking a vector's mutex lock
  • Example#3763 - Popping a value from a vector
  • Example#3764 - Pushing values to a vector
  • Example#3765 - Resizing a vector
  • Example#3766 - Shifting a value from a vector
  • Example#3767 - Getting a vector's size
  • Example#3768 - Locking a vector's mutex lock
  • Example#3769 - Unshifting a value to the front of a vector
  • Example#3770 - Updating a value in a vector
  • Example#3771 - Retrieving the front value of a queue
  • Example#3772 - Retrieving the front value in a loop (bad example - don't do this)
  • Example#3773 - Retrieving the front value in a loop (good example)
  • Example#3774 - Locking a queue's mutex lock
  • Example#3775 - Popping a value from a queue
  • Example#3776 - Pushing a value to a queue
  • Example#3777 - Getting a queue's size
  • Example#3778 - Locking a queue's mutex lock
  • Example#3779 - Creating a new atomic integer
  • Example#3780 - Decrementing an atomic integer's value
  • Example#3781 - Getting an atomic integer's value
  • Example#3782 - Incrementing an atomic integer's value
  • Example#3783 - Grouping together an atomic integer's operations (requiring a mutex lock)
  • Example#3784 - Setting an atomic integer's value
  • Example#3785 - Grouping together an atomic integer's operations (requiring a mutex lock)
  • Example#3786 - Shared Memory Operations Overview
  • Example#3787 - Closing shared memory block
  • Example#3788 - Deleting shared memory block
  • Example#3789 - Create a new shared memory block
  • Example#3790 - Reading shared memory block
  • Example#3791 - Getting the size of the shared memory block
  • Example#3792 - Writing to shared memory block
  • Example#3793 - SyncMutex::__construct named mutex with lock timeout example
  • Example#3794 - SyncMutex::__construct unnamed mutex example
  • Example#3795 - SyncMutex::lock example
  • Example#3796 - SyncMutex::unlock example
  • Example#3797 - SyncSemaphore::__construct example
  • Example#3798 - SyncSemaphore::lock example
  • Example#3799 - SyncSemaphore::unlock example
  • Example#3800 - SyncEvent::__construct example
  • Example#3801 - SyncEvent::fire example
  • Example#3802 - SyncEvent::reset example
  • Example#3803 - SyncEvent::wait example
  • Example#3804 - SyncReaderWriter::__construct example
  • Example#3805 - SyncReaderWriter::readlock example
  • Example#3806 - SyncReaderWriter::readunlock example
  • Example#3807 - SyncReaderWriter::writelock example
  • Example#3808 - SyncReaderWriter::writeunlock example
  • Example#3809 - SyncSharedMemory::__construct example
  • Example#3810 - SyncSharedMemory::first example
  • Example#3811 - SyncSharedMemory::__construct example
  • Example#3812 - SyncSharedMemory::size example
  • Example#3813 - SyncSharedMemory::write example
  • Example#3814 - geoip_asnum_by_name函数的范例：
  • Example#3815 - geoip_continent_code_by_name 函数的使用范例：
  • Example#3816 - geoip_country_code_by_name 函数的范例：
  • Example#3817 - geoip_country_code3_by_name 函数的使用范例：
  • Example#3818 - geoip_country_name_by_name 函数的使用范例：
  • Example#3819 - geoip_database_info 函数的使用范例：
  • Example#3820 - geoip_db_avail 函数的使用范例：
  • Example#3821 - geoip_db_filename函数的使用范例：
  • Example#3822 - geoip_db_get_all_info 使用范例：
  • Example#3823 - geoip_db_get_all_info 使用范例：
  • Example#3824 - 一个 geoip_domain_by_name 使用范例：
  • Example#3825 - 一个 geoip_id_by_name 使用范例：
  • Example#3826 - 一个 geoip_isp_by_name 使用范例：
  • Example#3827 - 一个 geoip_netspeedcell_by_name 使用范例：
  • Example#3828 - 一个 geoip_org_by_name 使用范例：
  • Example#3829 - geoip_record_by_name 例子：
  • Example#3830 - geoip_region_by_name 例子：
  • Example#3831 - geoip_region_name_by_code 使用美国和加拿大地区的范例。
  • Example#3832 - geoip_region_name_by_code 使用 FIPS 代码的范例：
  • Example#3833 - geoip_setup_custom_directory 例子：
  • Example#3834 - geoip_time_zone_by_country_and_region 使用美国和加拿大地区的范例：
  • Example#3835 - geoip_time_zone_by_country_and_region 使用 FIPS 代码的范例：
  • Example#3836 - xor.data file
  • Example#3837 - 一般训练
  • Example#3838 - 一般测试
  • Example#3839 - fann_create_train_from_callback example
  • Example#3840 - fann_read_train_from_file 函数的使用范例：
  • Example#3841 - JsonSerializable::jsonSerialize 例子 returning an array
  • Example#3842 - JsonSerializable::jsonSerialize 例子 返回了一个关联数组 array
  • Example#3843 - JsonSerializable::jsonSerialize 例子 返回一个 integer
  • Example#3844 - JsonSerializable::jsonSerialize 例子 返回一个 string
  • Example#3845 - json_decode 的例子
  • Example#3846 - Accessing invalid object properties
  • Example#3847 - common mistakes using json_decode
  • Example#3848 - depth errors
  • Example#3849 - json_decode of large integers
  • Example#3850 - json_encode 例子
  • Example#3851 - json_encode 函数中 options 参数的用法
  • Example#3852 - 选项 JSON_NUMERIC_CHECK 例子
  • Example#3853 - 连续与非连续数组示例
  • Example#3854 - 选项 JSON_PRESERVE_ZERO_FRACTION 的例子
  • Example#3855 - json_last_error 例子
  • Example#3856 - json_encode 的 json_last_error
  • Example#3857 - Lua::assign示例
  • Example#3858 - Lua::call示例
  • Example#3859 - Lua::eval示例
  • Example#3860 - Lua::registerCallback示例
  • Example#3861 - LuaClosure::__invoke示例
  • Example#3862 - Execute some Lua code
  • Example#3863 - Calling a Lua function
  • Example#3864 - Profiling Lua code
  • Example#3865 - Loading code into Lua
  • Example#3866 - Manipulating the usage timer
  • Example#3867 - Registering PHP functions to call from Lua
  • Example#3868 - Calling a Lua function
  • Example#3869 - Calling a Lua function
  • Example#3870 - constant 的例子
  • Example#3871 - 定义常量
  • Example#3872 - 以保留名称定义常量
  • Example#3873 - 检查常量
  • Example#3874 - eval 例子 - 简单的文本合并
  • Example#3875 - exit 例子
  • Example#3876 - exit 状态码例子
  • Example#3877 - 无论如何，Shutdown函数与析构函数都会被执行
  • Example#3878 - 列出所有用户浏览器的信息
  • Example#3879 - __halt_compiler 例子
  • Example#3880 - highlight_string 例子
  • Example#3881 - hrtime 的用法
  • Example#3882 - ignore_user_abort例子
  • Example#3883 - pack 范例
  • Example#3884 - php_strip_whitespace 的例子
  • Example#3885 - Basic sapi_windows_generate_ctrl_event Usage
  • Example#3886 - Basic sapi_windows_set_ctrl_handler Usage
  • Example#3887 - sapi_windows_vt100_support default state
  • Example#3888 - sapi_windows_vt100_support changing state
  • Example#3889 - Example usage of VT100 support enabled
  • Example#3890 - sleep 的例子
  • Example#3891 - sys_getloadavg 的例子
  • Example#3892 - time_nanosleep 的例子
  • Example#3893 - time_sleep_until 的一个例子
  • Example#3894 - uniqid 例子
  • Example#3895 - unpack example
  • Example#3896 - unpack example with a repeater
  • Example#3897 - unpack example with unnamed keys
  • Example#3898 - usleep例子
  • Example#3899 - 获取与设置根目录
  • Example#3900 - 获取与设置 Logger
  • Example#3901 - 快速写入日志
  • Example#3902 - 快速获取某级别下日志的数量
  • Example#3903 - 获取某级别下日志的详情
  • Example#3904 - seaslog_get_author example
  • Example#3905 - seaslog_get_version example
  • Example#3906 - SeasLog::alert例子
  • Example#3907 - SeasLog::analyzerCount example
  • Example#3908 - SeasLog::analyzerDetail example
  • Example#3909 - SeasLog::closeLoggerStream example
  • Example#3910 - SeasLog::__construct example
  • Example#3911 - SeasLog::critical example
  • Example#3912 - SeasLog::debug example
  • Example#3913 - SeasLog::__destruct example
  • Example#3914 - SeasLog::emergency example
  • Example#3915 - SeasLog::error example
  • Example#3916 - SeasLog::flushBuffer example
  • Example#3917 - SeasLog::getBasePath example
  • Example#3918 - SeasLog::getBuffer example
  • Example#3919 - SeasLog::getBufferEnabled example
  • Example#3920 - SeasLog::getDatetimeFormat example
  • Example#3921 - SeasLog::getLastLogger example
  • Example#3922 - SeasLog::getRequestID example
  • Example#3923 - SeasLog::getRequestVariable example
  • Example#3924 - SeasLog::info example
  • Example#3925 - SeasLog::log example
  • Example#3926 - SeasLog::notice example
  • Example#3927 - SeasLog::setBasePath example
  • Example#3928 - SeasLog::setDatetimeFormat example
  • Example#3929 - SeasLog::setLogger example
  • Example#3930 - SeasLog::setRequestID example
  • Example#3931 - SeasLog::setRequestVariable example
  • Example#3932 - SeasLog::warning example
  • Example#3933 - SplDoublyLinkedList::__construct example
  • Example#3934 - SplStack::__construct example
  • Example#3935 - SplQueue::__construct example
  • Example#3936 - Efficiently handling tasks with SplQueue
  • Example#3937 - SplFixedArray usage example
  • Example#3938 - SplFixedArray::__construct example
  • Example#3939 - SplFixedArray::count example
  • Example#3940 - SplFixedArray::fromArray example
  • Example#3941 - SplFixedArray::getSize example
  • Example#3942 - SplFixedArray::setSize example
  • Example#3943 - SplFixedArray::toArray example
  • Example#3944 - SplObjectStorage as a set
  • Example#3945 - SplObjectStorage as a map
  • Example#3946 - SplObjectStorage::addAll example
  • Example#3947 - SplObjectStorage::attach example
  • Example#3948 - SplObjectStorage::contains example
  • Example#3949 - SplObjectStorage::count example
  • Example#3950 - SplObjectStorage::current example
  • Example#3951 - SplObjectStorage::detach example
  • Example#3952 - SplObjectStorage::getHash example
  • Example#3953 - SplObjectStorage::getInfo example
  • Example#3954 - SplObjectStorage::key example
  • Example#3955 - SplObjectStorage::next example
  • Example#3956 - SplObjectStorage::offsetExists example
  • Example#3957 - SplObjectStorage::offsetGet example
  • Example#3958 - SplObjectStorage::offsetSet example
  • Example#3959 - SplObjectStorage::offsetUnset example
  • Example#3960 - SplObjectStorage::removeAll example
  • Example#3961 - SplObjectStorage::removeAllExcept example
  • Example#3962 - SplObjectStorage::rewind example
  • Example#3963 - SplObjectStorage::serialize example
  • Example#3964 - SplObjectStorage::setInfo example
  • Example#3965 - SplObjectStorage::unserialize example
  • Example#3966 - SplObjectStorage::valid example
  • Example#3967 - AppendIterator::append example
  • Example#3968 - Iterating AppendIterator with foreach
  • Example#3969 - Iterating AppendIterator with the AppendIterator API
  • Example#3970 - AppendIterator::getInnerIterator example
  • Example#3971 - AppendIterator.getIteratorIndex basic example
  • Example#3972 - AppendIterator::key basic example
  • Example#3973 - ArrayIterator::current example
  • Example#3974 - ArrayIterator::key example
  • Example#3975 - ArrayIterator::next example
  • Example#3976 - ArrayIterator::rewind example
  • Example#3977 - ArrayIterator::valid example
  • Example#3978 - CachingIterator::getCache example
  • Example#3979 - Available callback arguments
  • Example#3980 - Callback basic examples
  • Example#3981 - A DirectoryIterator::__construct example
  • Example#3982 - A DirectoryIterator::current example
  • Example#3983 - A DirectoryIterator::getATime example
  • Example#3984 - A DirectoryIterator::getBasename example
  • Example#3985 - DirectoryIterator::getCTime example
  • Example#3986 - DirectoryIterator::getExtension example
  • Example#3987 -
  • Example#3988 - A DirectoryIterator::getFilename example
  • Example#3989 - DirectoryIterator::getGroup example
  • Example#3990 - DirectoryIterator::getInode example
  • Example#3991 - A DirectoryIterator::getMTime example
  • Example#3992 - DirectoryIterator::getOwner example
  • Example#3993 - DirectoryIterator::getPath example
  • Example#3994 - DirectoryIterator::getPathname example
  • Example#3995 - DirectoryIterator::getPerms example
  • Example#3996 - DirectoryIterator::getSize example
  • Example#3997 - DirectoryIterator::getType example
  • Example#3998 - DirectoryIterator::isDir example
  • Example#3999 - A DirectoryIterator::isDot example
  • Example#4000 - DirectoryIterator::isExecutable example
  • Example#4001 - DirectoryIterator::isFile example
  • Example#4002 - A DirectoryIterator::isLink example
  • Example#4003 - DirectoryIterator::isReadable example
  • Example#4004 - DirectoryIterator::isWritable example
  • Example#4005 - A DirectoryIterator::key example
  • Example#4006 - DirectoryIterator::next example
  • Example#4007 - DirectoryIterator::rewind example
  • Example#4008 - DirectoryIterator::seek example
  • Example#4009 - A DirectoryIterator::__toString example
  • Example#4010 - A DirectoryIterator::valid example
  • Example#4011 - FilesystemIterator::__construct example
  • Example#4012 - FilesystemIterator::current example
  • Example#4013 - FilesystemIterator::key example
  • Example#4014 - FilesystemIterator::next example
  • Example#4015 - FilesystemIterator::rewind example
  • Example#4016 - FilesystemIterator::key example
  • Example#4017 - FilterIterator::accept example
  • Example#4018 - GlobIterator example
  • Example#4019 - GlobIterator::count example
  • Example#4020 - InfiniteIterator::__construct example
  • Example#4021 - LimitIterator usage example
  • Example#4022 - LimitIterator::__construct example
  • Example#4023 - LimitIterator::getPosition example
  • Example#4024 - Iterating a MultipleIterator
  • Example#4025 - NoRewindIterator::__construct example
  • Example#4026 - NoRewindIterator::rewind example
  • Example#4027 - RecursiveArrayIterator::getChildren example
  • Example#4028 - RecursiveArrayIterator::hasChildren example
  • Example#4029 - Available callback arguments
  • Example#4030 - Recursive callback basic example
  • Example#4031 - RecursiveCallbackFilterIterator::hasChildren basic usage
  • Example#4032 - RecursiveDirectoryIterator example
  • Example#4033 - getSubPath example
  • Example#4034 - getSubPathname example
  • Example#4035 - Basic RecursiveFilterIterator example
  • Example#4036 - RecursiveFilterIterator example
  • Example#4037 - Iterating a RecursiveIteratorIterator
  • Example#4038 - RecursiveRegexIterator::__construct example
  • Example#4039 - RecursiveRegexIterator::getChildren example
  • Example#4040 - RecursiveRegexIterator::hasChildren example
  • Example#4041 - RegexIterator::accept example
  • Example#4042 - RegexIterator::__construct example
  • Example#4043 - RegexIterator::getFlags example
  • Example#4044 - RegexIterator::getMode example
  • Example#4045 - RegexIterator::getPregFlags example
  • Example#4046 - RegexIterator::setFlags example
  • Example#4047 - RegexIterator::setMode example
  • Example#4048 - RegexIterator::setPregFlags example
  • Example#4049 - Countable::count example
  • Example#4050 - Basic usage
  • Example#4051 - SeekableIterator::seek example
  • Example#4052 - class_implements example
  • Example#4053 - class_parents example
  • Example#4054 - class_uses example
  • Example#4055 - iterator_apply example
  • Example#4056 - iterator_count example
  • Example#4057 - iterator_to_array example
  • Example#4058 - spl_autoload_extensions 示例
  • Example#4059 - spl_autoload_register 作为 __autoload 函数的替代
  • Example#4060 - class 未能加载的 spl_autoload_register 例子
  • Example#4061 - spl_classes example
  • Example#4062 - A spl_object_hash example
  • Example#4063 - A spl_object_id example
  • Example#4064 - SplFileInfo::__construct 示例
  • Example#4065 - SplFileInfo::getBasename example
  • Example#4066 - SplFileInfo::getCTime 例子
  • Example#4067 - SplFileInfo::getExtension example
  • Example#4068 -
  • Example#4069 - SplFileInfo::getFilename example
  • Example#4070 - SplFileInfo::getGroup example
  • Example#4071 - SplFileInfo::getLinkTarget example
  • Example#4072 - SplFileInfo::getOwner example
  • Example#4073 - SplFileInfo::getPath example
  • Example#4074 - SplFileInfo::getPathInfo example
  • Example#4075 - SplFileInfo::getPathname example
  • Example#4076 - SplFileInfo::getPerms example
  • Example#4077 - SplFileInfo::getRealPath example
  • Example#4078 - SplFileInfo::getType example
  • Example#4079 - SplFileInfo::isDir example
  • Example#4080 - SplFileInfo::isExecutable example
  • Example#4081 - SplFileInfo::isFile example
  • Example#4082 - SplFileInfo::isLink example
  • Example#4083 - SplFileInfo::isReadable example
  • Example#4084 - SplFileInfo::openFile example
  • Example#4085 - SplFileInfo::setFileClass example
  • Example#4086 - SplFileInfo::setFileClass example
  • Example#4087 - SplFileInfo::__toString example
  • Example#4088 - SplFileObject::__construct example
  • Example#4089 - SplFileObject::current example
  • Example#4090 - SplFileObject::eof example
  • Example#4091 - SplFileObject::fflush example
  • Example#4092 - SplFileObject::fgetc example
  • Example#4093 - SplFileObject::fgetcsv example
  • Example#4094 - SplFileObject::READ_CSV example
  • Example#4095 - SplFileObject::fgets example
  • Example#4096 - SplFileObject::fgetss example
  • Example#4097 - SplFileObject::flock example
  • Example#4098 - SplFileObject::fpassthru example
  • Example#4099 - SplFileObject::fputcsv example
  • Example#4100 - SplFileObject::fread example
  • Example#4101 - SplFileObject::fscanf example
  • Example#4102 - SplFileObject::fseek example
  • Example#4103 - SplFileObject::fstat example
  • Example#4104 - SplFileObject::ftell example
  • Example#4105 - SplFileObject::ftruncate example
  • Example#4106 - SplFileObject::fwrite example
  • Example#4107 - SplFileObject::getCsvControl example
  • Example#4108 - SplFileObject::getFlags example
  • Example#4109 - SplFileObject::getMaxLineLen example
  • Example#4110 - SplFileObject::key example
  • Example#4111 - SplFileObject::key example with SplFileObject::setMaxLineLen
  • Example#4112 - SplFileObject::next example
  • Example#4113 - SplFileObject::rewind example
  • Example#4114 - SplFileObject::seek example
  • Example#4115 - SplFileObject::setCsvControl example
  • Example#4116 - SplFileObject::setFlags example
  • Example#4117 - SplFileObject::setMaxLineLen example
  • Example#4118 - SplFileObject::valid example
  • Example#4119 - SplTempFileObject example
  • Example#4120 - ArrayObject::append 例子
  • Example#4121 - ArrayObject::asort example
  • Example#4122 - ArrayObject::__construct example
  • Example#4123 - ArrayObject::count 例子
  • Example#4124 - ArrayObject::exchangeArray example
  • Example#4125 - ArrayObject::getArrayCopy example
  • Example#4126 - ArrayObject::getFlags example
  • Example#4127 - ArrayObject::getIterator example
  • Example#4128 - ArrayObject::getIteratorClass example
  • Example#4129 - ArrayObject::ksort example
  • Example#4130 - ArrayObject::natcasesort example
  • Example#4131 - ArrayObject::natsort example
  • Example#4132 - ArrayObject::offsetExists example
  • Example#4133 - ArrayObject::offsetGet example
  • Example#4134 - ArrayObject::offsetSet 例子
  • Example#4135 - ArrayObject::offsetUnset example
  • Example#4136 - ArrayObject::serialize example
  • Example#4137 - ArrayObject::setFlags example
  • Example#4138 - ArrayObject::setIteratorClass example
  • Example#4139 - ArrayObject::uasort example
  • Example#4140 - ArrayObject::uksort example
  • Example#4141 - Using file_get_contents to retrieve data from multiple sources
  • Example#4142 - Making a POST request to an https server
  • Example#4143 - Writing data to a compressed file
  • Example#4144 - A Stream for reading/writing global variables
  • Example#4145 - Listing files from tar archives
  • Example#4146 - stream_bucket_prepend examples
  • Example#4147 - 使用 stream_context_create
  • Example#4148 - Using stream_context_get_default
  • Example#4149 - stream_context_get_options 的例子
  • Example#4150 - stream_context_get_params example
  • Example#4151 - stream_context_set_default example
  • Example#4152 - A stream_copy_to_stream example
  • Example#4153 - Controlling where filters are applied
  • Example#4154 - Filter for capitalizing characters on foo-bar.txt stream
  • Example#4155 - Registering a generic filter class to match multiple filter names.
  • Example#4156 - 动态地重新过滤一个资源流
  • Example#4157 - stream_get_contents 例子
  • Example#4158 - 使用 stream_get_filters
  • Example#4159 - 使用 stream_get_transports
  • Example#4160 - stream_get_wrappers 例子
  • Example#4161 - 检查一个流类型是否存在
  • Example#4162 - stream_is_local example
  • Example#4163 - stream_isatty example
  • Example#4164 - stream_notification_callback example
  • Example#4165 - Simple progressbar for commandline download client
  • Example#4166 - stream_resolve_include_path example
  • Example#4167 - stream_select Example
  • Example#4168 - stream_set_timeout example
  • Example#4169 - stream_set_write_buffer example
  • Example#4170 - stream_socket_client example
  • Example#4171 - Using UDP connection
  • Example#4172 - stream_socket_enable_crypto example
  • Example#4173 - A stream_socket_pair example
  • Example#4174 - stream_socket_recvfrom example
  • Example#4175 - stream_socket_sendto Example
  • Example#4176 - Using TCP server sockets
  • Example#4177 - Using UDP server sockets
  • Example#4178 - A stream_socket_shutdown example
  • Example#4179 - 如何注册一个 stream wrapper
  • Example#4180 - Basic Tidy usage
  • Example#4181 - tidy::getBody example
  • Example#4182 - tidy::cleanrepair example
  • Example#4183 - tidy::__construct example
  • Example#4184 - tidy::diagnose example
  • Example#4185 - tidy_get_error_buffer example
  • Example#4186 - tidy::getConfig example
  • Example#4187 - tidy_getopt example
  • Example#4188 - Print all options along with their documentation and default value
  • Example#4189 - tidy::getStatus example
  • Example#4190 - tidy::head example
  • Example#4191 - tidy::html example
  • Example#4192 - tidy::parseFile example
  • Example#4193 - tidy::parseString example
  • Example#4194 - tidy::repairFile example
  • Example#4195 - tidy::repairString example
  • Example#4196 - tidy::root example
  • Example#4197 - tidyNode::hasChildren example
  • Example#4198 - tidyNode::hasChildren example
  • Example#4199 - tidyNode::hasSiblings example
  • Example#4200 - Extract ASP code from a mixed HTML document
  • Example#4201 - Extract comments from a mixed HTML document
  • Example#4202 - Extract HTML code from a mixed HTML document
  • Example#4203 - Extract JSTE code from a mixed HTML document
  • Example#4204 - Extract PHP code from a mixed HTML document
  • Example#4205 - Extract text from a mixed HTML document
  • Example#4206 - ob_tidyhandler example
  • Example#4207 - tidy_access_count example
  • Example#4208 - tidy_config_count example
  • Example#4209 - tidy_error_count example
  • Example#4210 - tidy_get_output example
  • Example#4211 - tidy_warning_count example
  • Example#4212 - Strip comments with the tokenizer
  • Example#4213 - PhpToken::getTokenName example
  • Example#4214 - PhpToken::is example
  • Example#4215 - Usage with array
  • Example#4216 - PhpToken::isIgnorable example
  • Example#4217 - PhpToken::__toString example
  • Example#4218 - PhpToken::tokenize example
  • Example#4219 - Extending PhpToken
  • Example#4220 - token_get_all examples
  • Example#4221 - token_name example
  • Example#4222 - base64_decode 示例
  • Example#4223 - base64_encode 示例
  • Example#4224 - get_headers 例子
  • Example#4225 - get_headers using HEAD example
  • Example#4226 - get_meta_tags 解析了什么
  • Example#4227 - get_meta_tags 返回什么些
  • Example#4228 - http_build_query 使用示例
  • Example#4229 - http_build_query 使用数字下标的元素
  • Example#4230 - http_build_query 使用复杂的数组
  • Example#4231 - http_build_query 使用对象
  • Example#4232 - parse_url 例子
  • Example#4233 - parse_url 解析丢失协议的例子
  • Example#4234 - rawurldecode 示例
  • Example#4235 - 在 FTP URL 里包含一个密码
  • Example#4236 - rawurlencode 示例 2
  • Example#4237 - urldecode 示例
  • Example#4238 - urlencode 例子
  • Example#4239 - urlencode 与 htmlentities 例子
  • Example#4240 - Basic Javascript execution
  • Example#4241 - Yaml 范例
  • Example#4242 - Parse callback example
  • Example#4243 - Emit callback example
  • Example#4244 - yaml_emit example
  • Example#4245 - yaml_parse example
  • Example#4246 - 一个典型的应用目录结构
  • Example#4247 - 入口文件
  • Example#4248 - 重写规则
  • Example#4249 - 应用配置文件
  • Example#4250 - 默认控制器
  • Example#4251 - 默认视图文件
  • Example#4252 - 运行应用
  • Example#4253 - config为数组的例子
  • Example#4254 - config为ini文件的例子
  • Example#4255 - A Bootstrapexample
  • Example#4256 - Yaf_Application::bootstrapexample
  • Example#4257 - Yaf_Application::clearLastErrorexample
  • Example#4258 - A ini config file example
  • Example#4259 - Yaf_Application::__constructexample
  • Example#4260 - Yaf_Application::__constructexample
  • Example#4261 - Yaf_Application::environexample
  • Example#4262 - Yaf_Application::executeexample
  • Example#4263 - Yaf_Application::getConfigexample
  • Example#4264 - Yaf_Application::getDispatcherexample
  • Example#4265 - Yaf_Application::getLastErrorMsgexample
  • Example#4266 - Yaf_Application::getLastErrorNoexample
  • Example#4267 - Yaf_Application::getModulesexample
  • Example#4268 - Bootstrap example
  • Example#4269 - Yaf_Dispatcher::autoRenderexample
  • Example#4270 - Yaf_Dispatcher::catchExceptionexample
  • Example#4271 - Yaf_Dispatcher::registerPluginexample
  • Example#4272 - A custom View engineexample
  • Example#4273 - Yaf_Dispatcher::setViewexample
  • Example#4274 - Yaf_Dispatcher::throwexceptionexample
  • Example#4275 - Yaf_Dispatcher::throwexceptionexample
  • Example#4276 - Yaf_Config_Iniexample
  • Example#4277 - 在一个独立的文件中定义action
  • Example#4278 - Dummy_action.php
  • Example#4279 - Yaf_Controller_Abstract::forward例子
  • Example#4280 - Yaf_Action_Abstract::executeexample
  • Example#4281 - Yaf_Action_Abstract::executeexample
  • Example#4282 - Yaf_View_Simple::assignexample
  • Example#4283 - templateexample
  • Example#4284 - Yaf_View_Simple::assignRefexample
  • Example#4285 - templateexample
  • Example#4286 - Yaf_View_Simple::clearexample
  • Example#4287 - Yaf_View_Simple::__constructorexample
  • Example#4288 - Yaf_View_Simple::__setexample
  • Example#4289 - Config example
  • Example#4290 - 注册本地命名空间
  • Example#4291 - 加载类
  • Example#4292 - 加载命名空间类
  • Example#4293 - MVC类加载例子
  • Example#4294 - MVC 类区别
  • Example#4295 - MVC loading example
  • Example#4296 - Yaf_Loader::registerNamespaceexample
  • Example#4297 - Yaf_Loader::registerLocalNamespaceexample
  • Example#4298 - Yaf_Loader::registerNamespaceexample
  • Example#4299 - Plugin example
  • Example#4300 - Yaf_Plugin_Abstract::routerShutdownexample
  • Example#4301 - Yaf_Response_Abstract::appendBodyexample
  • Example#4302 - Yaf_Response_Abstract::getBodyexample
  • Example#4303 - Yaf_Response_Abstract::prependBodyexample
  • Example#4304 - Yaf_Response_Abstract::responseexample
  • Example#4305 - Yaf_Response_Abstract::setBodyexample
  • Example#4306 - Yaf_Route_Map::assembleexample
  • Example#4307 - Yaf_Route_Mapexample
  • Example#4308 - Yaf_Route_Mapexample
  • Example#4309 - Yaf_Route_Mapexample
  • Example#4310 - Yaf_Route_Regex::assembleexample
  • Example#4311 - Yaf_Route_Regexexample
  • Example#4312 - Yaf_Route_Regex(as of 2.3.0)example
  • Example#4313 - Yaf_Route_Regexexample
  • Example#4314 - Yaf_Route_Rewrite::assembleexample
  • Example#4315 - Yaf_Route_Rewriteexample
  • Example#4316 - Yaf_Route_Rewriteexample
  • Example#4317 - Yaf_Route_Rewrite(as of 2.3.0)example
  • Example#4318 - Apache的跳转规则
  • Example#4319 - Apache的跳转规则
  • Example#4320 - Lighttpd的跳转规则
  • Example#4321 - Nginx的跳转规则
  • Example#4322 - Yaf_Route_Static(default route)example
  • Example#4323 - application.iniexample
  • Example#4324 - Yaf_Dispatcher::autoConfigexample
  • Example#4325 - Yaf_Dispatcher::autoRenderexample
  • Example#4326 - 注册一些路由到Bootstrap
  • Example#4327 - plugin Dummy.php (under application.directory/plugins)
  • Example#4328 - Yaf_Route_Simple::assembleexample
  • Example#4329 - Yaf_Route_Simple::routeexample
  • Example#4330 - Yaf_Route_Simple::routeexample
  • Example#4331 - Yaf_Route_Static::assembleexample
  • Example#4332 - Yaf_Route_Static::routeexample
  • Example#4333 - Yaf_Route_Supervar::assembleexample
  • Example#4334 - Yaf_Route_Supervarexample
  • Example#4335 - INI example
  • Example#4336 - INI sections example
  • Example#4337 - INIexample
  • Example#4338 - Taintexample
  • Example#4339 - Vector
  • Example#4340 - Map
  • Example#4341 - Ds\Collection::clear example
  • Example#4342 - Ds\Collection::copy example
  • Example#4343 - Ds\Collection::isEmpty example
  • Example#4344 - Ds\Collection::toArray example
  • Example#4345 - Ds\Hashable::hash example
  • Example#4346 - Ds\Sequence::allocate example
  • Example#4347 - Ds\Sequence::apply example
  • Example#4348 - Ds\Sequence::capacity example
  • Example#4349 - Ds\Sequence::contains example
  • Example#4350 - Ds\Sequence::filter example using callback function
  • Example#4351 - Ds\Sequence::filter example without a callback function
  • Example#4352 - Ds\Sequence::find example
  • Example#4353 - Ds\Sequence::first example
  • Example#4354 - Ds\Sequence::get example
  • Example#4355 - Ds\Sequence::get example using array syntax
  • Example#4356 - Ds\Sequence::insert example
  • Example#4357 - Ds\Sequence::join example using a separator string
  • Example#4358 - Ds\Sequence::join example without a separator string
  • Example#4359 - Ds\Sequence::last example
  • Example#4360 - Ds\Sequence::map example
  • Example#4361 - Ds\Sequence::merge example
  • Example#4362 - Ds\Sequence::pop example
  • Example#4363 - Ds\Sequence::push example
  • Example#4364 - Ds\Sequence::reduce with initial value example
  • Example#4365 - Ds\Sequence::reduce without an initial value example
  • Example#4366 - Ds\Sequence::remove example
  • Example#4367 - Ds\Sequence::reverse example
  • Example#4368 - Ds\Sequence::reversed example
  • Example#4369 - Ds\Sequence::rotate example
  • Example#4370 - Ds\Sequence::set example
  • Example#4371 - Ds\Sequence::set example using array syntax
  • Example#4372 - Ds\Sequence::shift example
  • Example#4373 - Ds\Sequence::slice example
  • Example#4374 - Ds\Sequence::sort example
  • Example#4375 - Ds\Sequence::sort example using a comparator
  • Example#4376 - Ds\Sequence::sorted example
  • Example#4377 - Ds\Sequence::sorted example using a comparator
  • Example#4378 - Ds\Sequence::sum integer example
  • Example#4379 - Ds\Sequence::sum float example
  • Example#4380 - Ds\Sequence::unshift example
  • Example#4381 - Ds\Vector::allocate example
  • Example#4382 - Ds\Vector::apply example
  • Example#4383 - Ds\Vector::capacity example
  • Example#4384 - Ds\Vector::clear example
  • Example#4385 - Ds\Vector::__construct example
  • Example#4386 - Ds\Vector::contains example
  • Example#4387 - Ds\Vector::copy example
  • Example#4388 - Ds\Vector::filter example using callback function
  • Example#4389 - Ds\Vector::filter example without a callback function
  • Example#4390 - Ds\Vector::find example
  • Example#4391 - Ds\Vector::first example
  • Example#4392 - Ds\Vector::get example
  • Example#4393 - Ds\Vector::get example using array syntax
  • Example#4394 - Ds\Vector::insert example
  • Example#4395 - Ds\Vector::isEmpty example
  • Example#4396 - Ds\Vector::join example using a separator string
  • Example#4397 - Ds\Vector::join example without a separator string
  • Example#4398 - Ds\Vector::last example
  • Example#4399 - Ds\Vector::map example
  • Example#4400 - Ds\Vector::merge example
  • Example#4401 - Ds\Vector::pop example
  • Example#4402 - Ds\Vector::push example
  • Example#4403 - Ds\Vector::reduce with initial value example
  • Example#4404 - Ds\Vector::reduce without an initial value example
  • Example#4405 - Ds\Vector::remove example
  • Example#4406 - Ds\Vector::reverse example
  • Example#4407 - Ds\Vector::reversed example
  • Example#4408 - Ds\Vector::rotate example
  • Example#4409 - Ds\Vector::set example
  • Example#4410 - Ds\Vector::set example using array syntax
  • Example#4411 - Ds\Vector::shift example
  • Example#4412 - Ds\Vector::slice example
  • Example#4413 - Ds\Vector::sort example
  • Example#4414 - Ds\Vector::sort example using a comparator
  • Example#4415 - Ds\Vector::sorted example
  • Example#4416 - Ds\Vector::sorted example using a comparator
  • Example#4417 - Ds\Vector::sum integer example
  • Example#4418 - Ds\Vector::sum float example
  • Example#4419 - Ds\Vector::toArray example
  • Example#4420 - Ds\Vector::unshift example
  • Example#4421 - Ds\Deque::allocate example
  • Example#4422 - Ds\Deque::apply example
  • Example#4423 - Ds\Deque::capacity example
  • Example#4424 - Ds\Deque::clear example
  • Example#4425 - Ds\Deque::__construct example
  • Example#4426 - Ds\Deque::contains example
  • Example#4427 - Ds\Deque::copy example
  • Example#4428 - Ds\Deque::filter example using callback function
  • Example#4429 - Ds\Deque::filter example without a callback function
  • Example#4430 - Ds\Deque::find example
  • Example#4431 - Ds\Deque::first example
  • Example#4432 - Ds\Deque::get example
  • Example#4433 - Ds\Deque::get example using array syntax
  • Example#4434 - Ds\Deque::insert example
  • Example#4435 - Ds\Deque::isEmpty example
  • Example#4436 - Ds\Deque::join example using a separator string
  • Example#4437 - Ds\Deque::join example without a separator string
  • Example#4438 - Ds\Deque::last example
  • Example#4439 - Ds\Deque::map example
  • Example#4440 - Ds\Deque::merge example
  • Example#4441 - Ds\Deque::pop example
  • Example#4442 - Ds\Deque::push example
  • Example#4443 - Ds\Deque::reduce with initial value example
  • Example#4444 - Ds\Deque::reduce without an initial value example
  • Example#4445 - Ds\Deque::remove example
  • Example#4446 - Ds\Deque::reverse example
  • Example#4447 - Ds\Deque::reversed example
  • Example#4448 - Ds\Deque::rotate example
  • Example#4449 - Ds\Deque::set example
  • Example#4450 - Ds\Deque::set example using array syntax
  • Example#4451 - Ds\Deque::shift example
  • Example#4452 - Ds\Deque::slice example
  • Example#4453 - Ds\Deque::sort example
  • Example#4454 - Ds\Deque::sort example using a comparator
  • Example#4455 - Ds\Deque::sorted example
  • Example#4456 - Ds\Deque::sorted example using a comparator
  • Example#4457 - Ds\Deque::sum integer example
  • Example#4458 - Ds\Deque::sum float example
  • Example#4459 - Ds\Deque::toArray example
  • Example#4460 - Ds\Deque::unshift example
  • Example#4461 - Ds\Map::allocate example
  • Example#4462 - Ds\Map::apply example
  • Example#4463 - Ds\Map::capacity example
  • Example#4464 - Ds\Map::clear example
  • Example#4465 - Ds\Map::__construct example
  • Example#4466 - Ds\Map::copy example
  • Example#4467 - Ds\Map::diff example
  • Example#4468 - Ds\Map::filter example using callback function
  • Example#4469 - Ds\Map::filter example without a callback function
  • Example#4470 - Ds\Map::first example
  • Example#4471 - Ds\Map::get example
  • Example#4472 - Ds\Map::get example using array syntax
  • Example#4473 - Ds\Map::hasKey example
  • Example#4474 - Ds\Map::hasValue example
  • Example#4475 - Ds\Map::intersect example
  • Example#4476 - Ds\Map::isEmpty example
  • Example#4477 - Ds\Map::keys example
  • Example#4478 - Ds\Map::ksort example
  • Example#4479 - Ds\Map::ksort example using a comparator
  • Example#4480 - Ds\Map::ksorted example
  • Example#4481 - Ds\Map::ksorted example using a comparator
  • Example#4482 - Ds\Map::last example
  • Example#4483 - Ds\Map::map example
  • Example#4484 - Ds\Map::merge example
  • Example#4485 - Ds\Map::pairs example
  • Example#4486 - Ds\Map::put example
  • Example#4487 - Ds\Map::put example using objects as keys
  • Example#4488 - Ds\Map::putAll example
  • Example#4489 - Ds\Map::reduce with initial value example
  • Example#4490 - Ds\Map::reduce without an initial value example
  • Example#4491 - Ds\Map::remove example
  • Example#4492 - Ds\Map::reverse example
  • Example#4493 - Ds\Map::reversed example
  • Example#4494 - Ds\Map::skip example
  • Example#4495 - Ds\Map::slice example
  • Example#4496 - Ds\Map::sort example
  • Example#4497 - Ds\Map::sort example using a comparator
  • Example#4498 - Ds\Map::sort example
  • Example#4499 - Ds\Map::sort example using a comparator
  • Example#4500 - Ds\Map::sum integer example
  • Example#4501 - Ds\Map::sum float example
  • Example#4502 - Ds\Map::toArray example
  • Example#4503 - Ds\Map::union example
  • Example#4504 - Ds\Map::values example
  • Example#4505 - Ds\Map::xor example
  • Example#4506 - Ds\Pair::clear example
  • Example#4507 - Ds\Pair::copy example
  • Example#4508 - Ds\Pair::isEmpty example
  • Example#4509 - Ds\Pair::toArray example
  • Example#4510 - Ds\Set::add example using integers
  • Example#4511 - Ds\Set::add example using objects
  • Example#4512 - Ds\Set::allocate example
  • Example#4513 - Ds\Set::capacity example
  • Example#4514 - Ds\Set::clear example
  • Example#4515 - Ds\Set::__construct example
  • Example#4516 - Ds\Set::contains example
  • Example#4517 - Ds\Set::copy example
  • Example#4518 - Ds\Set::diff example
  • Example#4519 - Ds\Set::filter example using callback function
  • Example#4520 - Ds\Set::filter example without a callback function
  • Example#4521 - Ds\Set::first example
  • Example#4522 - Ds\Set::get example
  • Example#4523 - Ds\Set::get example using array syntax
  • Example#4524 - Ds\Set::intersect example
  • Example#4525 - Ds\Set::isEmpty example
  • Example#4526 - Ds\Set::join example using a separator string
  • Example#4527 - Ds\Set::join example without a separator string
  • Example#4528 - Ds\Set::last example
  • Example#4529 - Ds\Set::merge example
  • Example#4530 - Ds\Set::reduce with initial value example
  • Example#4531 - Ds\Set::reduce without an initial value example
  • Example#4532 - Ds\Set::remove example
  • Example#4533 - Ds\Set::reverse example
  • Example#4534 - Ds\Set::reversed example
  • Example#4535 - Ds\Set::slice example
  • Example#4536 - Ds\Set::sort example
  • Example#4537 - Ds\Set::sort example using a comparator
  • Example#4538 - Ds\Set::sorted example
  • Example#4539 - Ds\Set::sorted example using a comparator
  • Example#4540 - Ds\Set::sum integer example
  • Example#4541 - Ds\Set::sum float example
  • Example#4542 - Ds\Set::toArray example
  • Example#4543 - Ds\Set::union example
  • Example#4544 - Ds\Set::xor example
  • Example#4545 - Ds\Stack::clear example
  • Example#4546 - Ds\Stack::__construct example
  • Example#4547 - Ds\Stack::copy example
  • Example#4548 - Ds\Stack::isEmpty example
  • Example#4549 - Ds\Stack::peek example
  • Example#4550 - Ds\Stack::pop example
  • Example#4551 - Ds\Stack::push example
  • Example#4552 - Ds\Stack::toArray example
  • Example#4553 - Ds\Queue::allocate example
  • Example#4554 - Ds\Queue::capacity example
  • Example#4555 - Ds\Queue::clear example
  • Example#4556 - Ds\Queue::__construct example
  • Example#4557 - Ds\Queue::copy example
  • Example#4558 - Ds\Queue::isEmpty example
  • Example#4559 - Ds\Queue::peek example
  • Example#4560 - Ds\Queue::pop example
  • Example#4561 - Ds\Queue::push example
  • Example#4562 - Ds\Queue::toArray example
  • Example#4563 - Ds\PriorityQueue::allocate example
  • Example#4564 - Ds\PriorityQueue::capacity example
  • Example#4565 - Ds\PriorityQueue::clear example
  • Example#4566 - Ds\PriorityQueue::__construct example
  • Example#4567 - Ds\PriorityQueue::copy example
  • Example#4568 - Ds\PriorityQueue::isEmpty example
  • Example#4569 - Ds\PriorityQueue::peek example
  • Example#4570 - Ds\PriorityQueue::pop example
  • Example#4571 - Ds\PriorityQueue::push example
  • Example#4572 - Ds\PriorityQueue::toArray example
  • Example#4573 - 使用 PHP cURL 模块获取 example.com 的主页
  • Example#4574 - 初始化新的 cURL 会话，并获取一张网页
  • Example#4575 - 复制一个cURL句柄
  • Example#4576 - curl_errno 例子
  • Example#4577 - curl_error 例子
  • Example#4578 - curl_escape 示例
  • Example#4579 - 获取网页
  • Example#4580 - curl_getinfo example
  • Example#4581 - 初始化新的 cURL 会话并获取一个网页
  • Example#4582 - curl_multi_add_handle example
  • Example#4583 - curl_multi_close example
  • Example#4584 - curl_multi_exec example
  • Example#4585 - 一个curl_multi_info_read范例
  • Example#4586 - curl_multi_init example
  • Example#4587 - curl_multi_strerror 函数的范例：
  • Example#4588 - curl_reset 示例
  • Example#4589 - 初始化新的 cURL 会话并抓取 web 页面
  • Example#4590 - 我们对curl_setopt_array的等价实现
  • Example#4591 - 初始化一个新的cURL会话并获取一个网页
  • Example#4592 - 上传文件 (PHP 5.5.0 后被废弃)
  • Example#4593 - curl_share_setopt 函数范例：
  • Example#4594 - curl_share_init 函数的范例：
  • Example#4595 - curl_share_setopt 函数的范例：
  • Example#4596 - curl_errno 函数的范例：
  • Example#4597 - curl_escape 示例
  • Example#4598 - curl_version 例子
  • Example#4599 - CURLFile::__construct 示例
  • Example#4600 - Simple HTTP client
  • Example#4601 - HTTP client using asynchronous DNS resolver
  • Example#4602 - Echo server
  • Example#4603 - SSL echo server
  • Example#4604 - Signal handler
  • Example#4605 - Use libevent's loop to process requests of `eio' extension
  • Example#4606 - Miscellaneous
  • Example#4607 - Simple HTTP server
  • Example#4608 - Simple HTTPS server
  • Example#4609 - OpenSSL connection
  • Example#4610 - EventHttpConnection::makeRequest example
  • Example#4611 - Connection listener based on a UNIX domain socket
  • Example#4612 - Simple SMTP server
  • Example#4613 - Handling SIGTERM signal
  • Example#4614 - Event::addSignal example
  • Example#4615 - Event::addTimer example
  • Example#4616 - EventBase::getFeatures example
  • Example#4617 - EventBase::getMethod example
  • Example#4618 - EventBuffer::search example
  • Example#4619 - EventBufferEvent::connect example
  • Example#4620 - Connect to UNIX domain socket which presumably is served by a server, read response from the server and output it to the console
  • Example#4621 - EventBufferEvent::connectHost example
  • Example#4622 - Buffer event's read callback
  • Example#4623 - EventBufferEvent::getOutput example
  • Example#4624 - EventBufferEvent::sslError example
  • Example#4625 - Simple SMTP server
  • Example#4626 - EventConfig::avoidMethod example
  • Example#4627 - EventConfig::__construct example
  • Example#4628 - EventConfig::requireFeatures example
  • Example#4629 - EventHttp::accept example
  • Example#4630 - EventHttp::addServerAlias example
  • Example#4631 - EventHttp::bind example
  • Example#4632 - Simple HTTP server
  • Example#4633 - EventHttp::setCallback example
  • Example#4634 - EventHttp::setDefaultCallback example
  • Example#4635 - EventHttpConnection::makeRequest example
  • Example#4636 - EventHttpConnection::setCloseCallback example
  • Example#4637 - EventHttpRequest::__construct example
  • Example#4638 - EventHttpRequest::sendError example
  • Example#4639 - EventListener::__construct example
  • Example#4640 - EventSslContext::__construct example
  • Example#4641 - FTP 例程
  • Example#4642 - ftp_alloc 函数例程
  • Example#4643 - ftp_cdup 例子
  • Example#4644 - ftp_chdir 例子
  • Example#4645 - ftp_chmod 函数例程
  • Example#4646 - ftp_close 例子
  • Example#4647 - ftp_connect 示例
  • Example#4648 - ftp_delete 例子
  • Example#4649 - ftp_exec 示例
  • Example#4650 - ftp_fget 例子
  • Example#4651 - ftp_fput 例子
  • Example#4652 - ftp_get_option 示例
  • Example#4653 - ftp_get 例子
  • Example#4654 - ftp_login 例子
  • Example#4655 - ftp_mdtm 示例
  • Example#4656 - ftp_mkdir example
  • Example#4657 - ftp_mlsd 示例
  • Example#4658 - ftp_nb_continue 示例
  • Example#4659 - ftp_nb_fget 函数例程
  • Example#4660 - ftp_nb_fput 函数例程
  • Example#4661 - ftp_nb_get 示例
  • Example#4662 - 通过 ftp_nb_get 恢复下载一个文件
  • Example#4663 - 使用 ftp_nb_get 从指定位置恢复下载文件
  • Example#4664 - ftp_nb_put 示例
  • Example#4665 - 使用 ftp_nb_put 来续传文件
  • Example#4666 - ftp_nlist 例子
  • Example#4667 - ftp_pasv 实例
  • Example#4668 - ftp_put 实例
  • Example#4669 - ftp_pwd 例子
  • Example#4670 - 使用 ftp_raw 登录远程 FTP 服务器
  • Example#4671 - ftp_rawlist 示例
  • Example#4672 - ftp_rename 例子
  • Example#4673 - ftp_rmdir 示例
  • Example#4674 - ftp_set_option 例子
  • Example#4675 - 向一个 FTP 服务器发送一条 SITE 命令
  • Example#4676 - ftp_size 示例
  • Example#4677 - ftp_ssl_connect 函数例程
  • Example#4678 - ftp_systype 示例
  • Example#4679 - Basic Gearman client and worker
  • Example#4680 - Basic Gearman client and worker, background
  • Example#4681 - Basic Gearman client and worker, submitting tasks
  • Example#4682 - Adding two job servers
  • Example#4683 - Add two job servers
  • Example#4684 - Basic submission of two tasks
  • Example#4685 - Basic submission of two tasks with passing application context
  • Example#4686 - Two tasks, one background and one not
  • Example#4687 - A high priority task along with two normal tasks
  • Example#4688 - A low priority task along with two normal tasks
  • Example#4689 - Monitor completion of multiple background tasks
  • Example#4690 - Simple job submission with immediate return
  • Example#4691 - Submitting a job and retrieving incremental status
  • Example#4692 - Submit and monitor a background job
  • Example#4693 - Simple job submission with immediate return
  • Example#4694 - Submitting a job and retrieving incremental status
  • Example#4695 - Get the status of a long running job
  • Example#4696 - Monitor the status of a long running background job
  • Example#4697 - Simple worker making use of extra application context data
  • Example#4698 - Add alternate Gearman servers
  • Example#4699 - Add two job servers
  • Example#4700 - GearmanWorker::setId example
  • Example#4701 - A simple worker with a 5 second timeout
  • Example#4702 - Running worker in non-blocking mode
  • Example#4703 - GearmanWorker::work example
  • Example#4704 - Testing support for paged result control
  • Example#4705 - LDAP search example
  • Example#4706 - Bind with ppolicy information
  • Example#4707 - Modify description only if it's not empty
  • Example#4708 - Read some values before deletion
  • Example#4709 - Delete a reference
  • Example#4710 - Use pagination for a search
  • Example#4711 - Complete example with authenticated bind
  • Example#4712 - 使用 LDAP Bind
  • Example#4713 - Using LDAP Bind Anonymously
  • Example#4714 - Complete example of password check
  • Example#4715 - Example of connecting to LDAP server.
  • Example#4716 - Example of connecting securely to LDAP server.
  • Example#4717 - LDAP pagination
  • Example#4718 - LDAP pagination
  • Example#4719 - ldap-count-entries example
  • Example#4720 - Enumerating all LDAP error messages
  • Example#4721 - Generating and catching an error
  • Example#4722 - Searching for an email address
  • Example#4723 - PASSWD extended operation
  • Example#4724 - Whoami extended operation
  • Example#4725 - Show the list of attributes held for a particular directory entry
  • Example#4726 - Check protocol version
  • Example#4727 - List all values of the "mail" attribute for a directory entry
  • Example#4728 - Produce a list of all organizational units of an organization
  • Example#4729 - Add a telephone number to a contact
  • Example#4730 - Rename a user
  • Example#4731 - Add two e-mail addresses to a user
  • Example#4732 - Change a user's password
  • Example#4733 - Change a user's password (Active Directory)
  • Example#4734 - ldap_parse_result example
  • Example#4735 - LDAP search
  • Example#4736 - Set protocol version
  • Example#4737 - Set server controls
  • Example#4738 - LDAP sort
  • Example#4739 - memcache扩展概览示例
  • Example#4740 - 使用memcache的session处理器
  • Example#4741 - Memcache::add示例
  • Example#4742 - Memcache::addServer 示例
  • Example#4743 - Memcache::close示例
  • Example#4744 - Memcache::connect example
  • Example#4745 - Memcache::decrement example
  • Example#4746 - Memcache::delete example
  • Example#4747 - Memcache::flush示例
  • Example#4748 - Memcache::get 示例
  • Example#4749 - Memcache::getExtendedStats 示例
  • Example#4750 - Memcache::getServerStatus 示例
  • Example#4751 - Memcache::getVersion 示例
  • Example#4752 - Memcache::increment示例
  • Example#4753 - Memcache::pconnect示例
  • Example#4754 - Memcache::replace示例
  • Example#4755 - Memcache::set 示例
  • Example#4756 - Memcache::set 示例
  • Example#4757 - Memcache::setCompressThreshold 示例
  • Example#4758 - Memcache::setServerParams 示例
  • Example#4759 - 结果回调示例
  • Example#4760 - 通读回调示例
  • Example#4761 - Memcached::addServer example
  • Example#4762 - Memcached::addServers示例
  • Example#4763 - Memcached::append示例
  • Example#4764 - Memcached::cas 示例
  • Example#4765 - 创建一个Memcached对象
  • Example#4766 - Memcached::decrement 示例
  • Example#4767 - Memcached::delete 示例
  • Example#4768 - Memcached::fetch 示例
  • Example#4769 - Memcached::getDelayed 示例
  • Example#4770 - Memcached::flush 示例
  • Example#4771 - Memcached::get 示例 #1
  • Example#4772 - Memcached::get 示例 #2
  • Example#4773 - Memcached::getDelayed 示例
  • Example#4774 - Memcached::getMulti 的 Memcached v3 示例
  • Example#4775 - Memcached::getMulti 的 Memcached v1 和 v2 示例
  • Example#4776 - Memcached::GET_PRESERVE_ORDER 的 Memcached v3 示例
  • Example#4777 - Memcached::GET_PRESERVE_ORDER 的 Memcached v1 和 v2 示例
  • Example#4778 - 获取Memcached选项
  • Example#4779 - Memcached::getResultCode 示例
  • Example#4780 - Memcached::getResultMessage 示例
  • Example#4781 - Memcached::getServerByKey 示例
  • Example#4782 - Memcached::getServerList 示例
  • Example#4783 - Memcached::getStats 示例
  • Example#4784 - Memcached::getVersion 示例
  • Example#4785 - Memcached::increment 示例
  • Example#4786 - Memcached::prepend 示例
  • Example#4787 - Memcached::set 示例
  • Example#4788 - Memcached::setByKey 示例
  • Example#4789 - Memcached::setMulti 示例
  • Example#4790 - 设置一个memcached选项值
  • Example#4791 - Setting Memcached options
  • Example#4792 - mqseries_back example
  • Example#4793 - mqseries_begin example
  • Example#4794 - mqseries_close example
  • Example#4795 - mqseries_cmit example
  • Example#4796 - mqseries_conn example
  • Example#4797 - mqseries_connx example
  • Example#4798 - mqseries_connx example using SSL connection & OCSP Responder URL
  • Example#4799 - mqseries_disc example
  • Example#4800 - mqseries_get example
  • Example#4801 - mqseries_inq example
  • Example#4802 - mqseries_open example
  • Example#4803 - mqseries_put example
  • Example#4804 - mqseries_strerror example
  • Example#4805 - 使用 dns_get_record函数
  • Example#4806 - 使用dns_get_record配合DNS_ANY的例子
  • Example#4807 - fsockopen的例子
  • Example#4808 - 使用UDP连接
  • Example#4809 - 一个使用 gethostbyaddr 的简单例子
  • Example#4810 - 简单的 gethostbyname 例子
  • Example#4811 - gethostbynamel 例子
  • Example#4812 - 简单的 gethostname 例子
  • Example#4813 - getprotobyname example
  • Example#4814 - getservbyname 例子
  • Example#4815 - header_register_callback 例子
  • Example#4816 - 取消指定的头
  • Example#4817 - 取消之前全部指定的头
  • Example#4818 - 下载对话框
  • Example#4819 - 缓存指令
  • Example#4820 - 使用 headers_list 的例子
  • Example#4821 - 使用 headers_sent 的例子
  • Example#4822 - Web 服务器环境内使用 http_response_code
  • Example#4823 - 在 CLI 环境内使用 http_response_code
  • Example#4824 - inet_ntop Example
  • Example#4825 - inet_pton Example
  • Example#4826 - ip2long 例子
  • Example#4827 - 显示IP地址
  • Example#4828 - setcookie 发送例子
  • Example#4829 - setcookie 删除例子
  • Example#4830 - setcookie 和数组
  • Example#4831 - Using syslog
  • Example#4832 - Procedural usage of rrd
  • Example#4833 - OO usage of rrd
  • Example#4834 - RRDGraph::setOptions example
  • Example#4835 - Set multiple color options
  • Example#4836 - RRDUpdater::update examples
  • Example#4837 - Fetch instrumented calls
  • Example#4838 - Fetch the list of functions scoutapm will instrument
  • Example#4839 - snmp_get_quick_print 示例
  • Example#4840 - Using snmp_get_valueretrieval
  • Example#4841 - Using snmp_read_mib
  • Example#4842 - Using snmp_set_enum_print
  • Example#4843 - Using snmprealwalk
  • Example#4844 - Using snmp_set_valueretrieval
  • Example#4845 - Using snmp2_get
  • Example#4846 - Using snmp2_get_next
  • Example#4847 - Using snmp2_real_walk
  • Example#4848 - Using snmp2_set
  • Example#4849 - Using snmp2_set for setting BITS SNMP object id
  • Example#4850 - snmp2_walk Example
  • Example#4851 - Using snmp3_get
  • Example#4852 - Using snmp3_getnext
  • Example#4853 - Using snmp3_real_walk
  • Example#4854 - Using snmp3_set
  • Example#4855 - Using snmp3_set for setting BITS SNMP object id
  • Example#4856 - snmp3_walk Example
  • Example#4857 - Using snmpgetnext
  • Example#4858 - Using snmprealwalk
  • Example#4859 - SNMP::close example
  • Example#4860 - Fetching sysLocation
  • Example#4861 - Single SNMP object
  • Example#4862 - Multiple SNMP objects
  • Example#4863 - SNMP::getErrno example
  • Example#4864 - SNMP::getError example
  • Example#4865 - Single SNMP object
  • Example#4866 - Miltiple SNMP objects
  • Example#4867 - Set single SNMP object id
  • Example#4868 - Set multiple values using single SNMP::set call
  • Example#4869 - Using SNMP::set for setting BITS SNMP object id
  • Example#4870 - SNMP::setSecurity example
  • Example#4871 - SNMP::walk example
  • Example#4872 - suffixAsKey example
  • Example#4873 - Socket举例：简单的TCP/IP服务器
  • Example#4874 - Socket举例：简单的TCP/IP客户端
  • Example#4875 - 使用 socket_bind 来设置套接字资源地址
  • Example#4876 - socket_create_pair example
  • Example#4877 - socket_create_pair IPC example
  • Example#4878 - socket_get_option example
  • Example#4879 - socket_import_stream example
  • Example#4880 - socket_last_error example
  • Example#4881 - socket_recv 范例
  • Example#4882 - socket_recvfrom example
  • Example#4883 - Using null with socket_select
  • Example#4884 - Understanding socket_select's result
  • Example#4885 - socket_select example
  • Example#4886 - socket_sendto Example
  • Example#4887 - socket_set_block example
  • Example#4888 - socket_set_nonblock example
  • Example#4889 - socket_set_option example
  • Example#4890 - socket_strerror example
  • Example#4891 - Authenticating with a ssh agent
  • Example#4892 - Authentication using a public hostkey
  • Example#4893 - Retrieving a list of authentication methods
  • Example#4894 - Authenticating with a password
  • Example#4895 - Authentication using a public key
  • Example#4896 - ssh2_connect example
  • Example#4897 - Executing a command
  • Example#4898 - Opening a shell and retrieving the stderr stream associated with it
  • Example#4899 - Checking the fingerprint against a known value
  • Example#4900 - Determining what methods were negotiated
  • Example#4901 - Adding a publickey with ssh2_publickey_add
  • Example#4902 - Listing authorized keys with ssh2_publickey_list
  • Example#4903 - Downloading a file via SCP
  • Example#4904 - Uploading a file via SCP
  • Example#4905 - Changing the mode of a file on a remote server
  • Example#4906 - Stating a symbolic link via SFTP
  • Example#4907 - Creating a directory on a remote server
  • Example#4908 - Reading a symbolic link
  • Example#4909 - Resolving a pathname
  • Example#4910 - Renaming a file via sftp
  • Example#4911 - Removing a directory on a remote server
  • Example#4912 - Stating a file via SFTP
  • Example#4913 - Creating a symbolic link
  • Example#4914 - Deleting a file
  • Example#4915 - Opening a file via SFTP
  • Example#4916 - Requesting an interactive shell
  • Example#4917 - Opening a tunnel to an arbitrary host
  • Example#4918 - 面向对象风格
  • Example#4919 - 过程化风格
  • Example#4920 - stomp_connect_error example
  • Example#4921 - stomp_version example
  • Example#4922 - 面向对象风格
  • Example#4923 - 过程化风格
  • Example#4924 - 面向对象风格
  • Example#4925 - 过程化风格
  • Example#4926 - 面向对象风格
  • Example#4927 - 过程化风格
  • Example#4928 - 面向对象风格
  • Example#4929 - 过程化风格
  • Example#4930 - 面向对象风格
  • Example#4931 - 过程化风格
  • Example#4932 - 面向对象风格
  • Example#4933 - 过程化风格
  • Example#4934 - 面向对象风格
  • Example#4935 - 过程化风格
  • Example#4936 - 面向对象风格
  • Example#4937 - 过程化风格
  • Example#4938 - 面向对象风格
  • Example#4939 - 过程化风格
  • Example#4940 - Train from array
  • Example#4941 - Train from a file
  • Example#4942 - svn_add 例子
  • Example#4943 - Default authentication example
  • Example#4944 - svn_blame example
  • Example#4945 - Basic example
  • Example#4946 - Basic example
  • Example#4947 - Basic example
  • Example#4948 - Basic example
  • Example#4949 - 基本示例
  • Example#4950 - Basic example
  • Example#4951 - Diffing two revisions of a repository path
  • Example#4952 - Portably diffing two local files
  • Example#4953 - svn_export example
  • Example#4954 - Basic example
  • Example#4955 - svn_log example
  • Example#4956 - svn_ls example
  • Example#4957 - Basic example
  • Example#4958 - Basic example
  • Example#4959 - Deny all connections from localhost
  • Example#4960 - Ban an URL
  • Example#4961 - Get statistic snapshot
  • Example#4962 - Read varnish shared memory log
  • Example#4963 - VarnishAdmin::__construct example
  • Example#4964 - Parallel searching using Yaz
  • Example#4965 - CCL configuration
  • Example#4966 - CCL Parsing
  • Example#4967 - Record Update
  • Example#4968 - Array for GRS-1 record
  • Example#4969 - Working with MARCXML
  • Example#4970 - PHP function that scans titles
  • Example#4971 - Query Examples
  • Example#4972 - Sort Criterias
  • Example#4973 - A ZMQContext example
  • Example#4974 - A ZMQContext example
  • Example#4975 - A ZMQContext example
  • Example#4976 - A ZMQSocket example
  • Example#4977 - A send/recv example
  • Example#4978 - A ZMQPoll example
  • Example#4979 - zookeeper_dispatch example #1
  • Example#4980 - zookeeper_dispatch example #2
  • Example#4981 - Zookeeper::addAuth example
  • Example#4982 - Zookeeper::create example
  • Example#4983 - Zookeeper::delete example
  • Example#4984 - Zookeeper::exists example
  • Example#4985 - Zookeeper::get example
  • Example#4986 - Zookeeper::get stat example
  • Example#4987 - Zookeeper::getAcl example
  • Example#4988 - Zookeeper::getChildren example
  • Example#4989 - Zookeeper::set example
  • Example#4990 - Zookeeper::setAcl example
  • Example#4991 - Zookeeper::setDebugLevel example
  • Example#4992 - ZookeeperConfig::add example
  • Example#4993 - ZookeeperConfig::get example
  • Example#4994 - ZookeeperConfig::remove example
  • Example#4995 - ZookeeperConfig::set example
  • Example#4996 - solr_get_version example
  • Example#4997 - Contents of the BootStrap file
  • Example#4998 - Adding a document to the index
  • Example#4999 - Merging one document into another document
  • Example#5000 - Searching for documents - SolrObject responses
  • Example#5001 - Searching for documents - SolrDocument responses
  • Example#5002 - Simple TermsComponent example - basic
  • Example#5003 - Simple TermsComponent example - using a prefix
  • Example#5004 - Simple TermsComponent example - specifying a minimum frequency
  • Example#5005 - Simple Facet Example
  • Example#5006 - Simple Facet Example - with optional field override for mincount
  • Example#5007 - Facet Date Example
  • Example#5008 - Connecting to SSL-Enabled Server
  • Example#5009 - Collapsing a SolrQuery
  • Example#5010 - Solr Real Time Get (RTG) example SolrClient::getById
  • Example#5011 - SolrInputDocument::addChildDocument example
  • Example#5012 - SolrInputDocument::addChildDocuments example
  • Example#5013 - SolrDocument::toArray example
  • Example#5014 - SolrObject::__construct example
  • Example#5015 - SolrObject::offsetUnset example
  • Example#5016 - SolrClient::addDocument example
  • Example#5017 - SolrClient::addDocument example 2
  • Example#5018 - SolrClient::addDocuments example
  • Example#5019 - SolrClient::__construct example
  • Example#5020 - SolrQuery::deleteByQuery example
  • Example#5021 - SolrClient::getById example
  • Example#5022 - SolrClient::getByIds example
  • Example#5023 - SolrClient::ping example
  • Example#5024 - SolrClient::query example
  • Example#5025 - SolrClient::request example
  • Example#5026 - SolrClient::setResponseWriter example
  • Example#5027 - SolrParams::setParam example
  • Example#5028 - SolrQuery::addFacetField example
  • Example#5029 - SolrQuery::addFacetField example
  • Example#5030 - SolrQuery::addFilterQuery example
  • Example#5031 - SolrQuery::addGroupSortField example
  • Example#5032 - SolrQuery::collapse example
  • Example#5033 - SolrQuery::setExpand example
  • Example#5034 - SolrDisMaxQuery::addBigramPhraseField example
  • Example#5035 - SolrDisMaxQuery::addBoostQuery example
  • Example#5036 - SolrDisMaxQuery::addPhraseField example
  • Example#5037 - SolrDisMaxQuery::addQueryField example
  • Example#5038 - SolrDisMaxQuery::addTrigramPhraseField example
  • Example#5039 - SolrDisMaxQuery::addUserField example
  • Example#5040 - SolrDisMaxQuery::__construct example
  • Example#5041 - SolrDisMaxQuery::removeBigramPhraseField example
  • Example#5042 - SolrDisMaxQuery::removeBoostQuery example
  • Example#5043 - SolrDisMaxQuery::removePhraseField example
  • Example#5044 - SolrDisMaxQuery::removeQueryField example
  • Example#5045 - SolrDisMaxQuery::removeTrigramPhraseField example
  • Example#5046 - SolrDisMaxQuery::removeUserField example
  • Example#5047 - SolrDisMaxQuery::setBigramPhraseFields example
  • Example#5048 - SolrDisMaxQuery::setBigramPhraseSlop example
  • Example#5049 - SolrDisMaxQuery::setBoostFunction example
  • Example#5050 - SolrDisMaxQuery::setBoostQuery example
  • Example#5051 - SolrDisMaxQuery::setMinimumMatch example
  • Example#5052 - SolrDisMaxQuery::setPhraseFields example
  • Example#5053 - SolrDisMaxQuery::setPhraseSlop example
  • Example#5054 - SolrDisMaxQuery::setQueryAlt example
  • Example#5055 - SolrDisMaxQuery::setQueryPhraseSlop example
  • Example#5056 - SolrDisMaxQuery::setTieBreaker example
  • Example#5057 - SolrDisMaxQuery::setTrigramPhraseFields example
  • Example#5058 - SolrDisMaxQuery::setTrigramPhraseSlop example
  • Example#5059 - SolrDisMaxQuery::setUserFields example
  • Example#5060 - SolrDisMaxQuery::useDisMaxQueryParser example
  • Example#5061 - SolrDisMaxQuery::useEDisMaxQueryParser example
  • Example#5062 - SolrCollapseFunction::__construct example
  • Example#5063 - SolrCollapseFunction::setHint example
  • Example#5064 - SolrCollapseFunction::setMax example
  • Example#5065 - 基本使用范例
  • Example#5066 - 用 .htaccess 禁用一个目录的 PHP 解析
  • Example#5067 - apache_get_modules 示例
  • Example#5068 - apache_get_version example
  • Example#5069 - apache_getenv example
  • Example#5070 - apache_lookup_uri 例子
  • Example#5071 - Passing information between PHP and Perl
  • Example#5072 - Logging values in access.log
  • Example#5073 - apache_request_headers 示例
  • Example#5074 - apache_response_headers 示例
  • Example#5075 - 使用 apache_setenv 设置一个 Apache 环境变量
  • Example#5076 - getallheaders 示例
  • Example#5077 - 在 $_SESSION 中注册变量。
  • Example#5078 - 从 $_SESSION 中反注册变量。
  • Example#5079 - 某单一用户的点击数
  • Example#5080 - 样例信息
  • Example#5081 - session_cache_expire 示例
  • Example#5082 - session_cache_limiter 示例
  • Example#5083 - session_create_id example with session_regenerate_id
  • Example#5084 - 销毁会话数据以及 $_SESSION
  • Example#5085 - session_gc example for task managers like cron
  • Example#5086 - session_gc example for user accessible script
  • Example#5087 - session_name 示例
  • Example#5088 - A session_regenerate_id 示例
  • Example#5089 - Avoiding lost session by session_regenerate_id
  • Example#5090 - 自定义会话管理器： 完整代码请参见 SessionHandlerInterface。
  • Example#5091 - 使用对象自定义会话保存管理器
  • Example#5092 - page1.php
  • Example#5093 - page2.php
  • Example#5094 - 覆盖 Cookie 超时时间设定
  • Example#5095 - 读取会话之后立即关闭会话存储文件
  • Example#5096 - Using SessionHandler to add encryption to internal PHP save handlers.
  • Example#5097 - Example using SessionHandlerInterface
  • Example#5098 - Tokenize comma separated integer list
  • Example#5099 - Tokenize assign statement
  • Example#5100 - Simple calculator
  • Example#5101 - Parse words out from a sentence
  • Example#5102 - 合法模式示例
  • Example#5103 - 非法模式示例
  • Example#5104 - 比较preg_filter 和preg_replace的示例
  • Example#5105 - preg_grep 示例
  • Example#5106 - preg_last_error_msg example
  • Example#5107 - preg_last_error 示例
  • Example#5108 - 查找所有文本中的电话号码。
  • Example#5109 - 查找匹配的HTML标签（贪婪）
  • Example#5110 - 使用子命名组
  • Example#5111 - 查找文本字符串"php"
  • Example#5112 - 查找单词"word"
  • Example#5113 - 获取URL中的域名
  • Example#5114 - 使用命名子组
  • Example#5115 - preg_quote示例
  • Example#5116 - 将文本中的单词替换为斜体
  • Example#5117 - preg_replace_callback_array example
  • Example#5118 - preg_replace_callback 和 匿名函数
  • Example#5119 - preg_replace_callback示例
  • Example#5120 - preg_replace_callback 使用递归构造处理 BB 码的封装
  • Example#5121 - 使用后向引用紧跟数值原文
  • Example#5122 - preg_replace 中使用基于索引的数组
  • Example#5123 - 替换一些值
  • Example#5124 - 剥离空白字符
  • Example#5125 - 使用参数 count
  • Example#5126 - preg_split示例：获取搜索字符串的部分
  • Example#5127 - 将一个字符串分隔为组成它的字符
  • Example#5128 - 分隔一个字符串并获取每部分的偏移量
  • Example#5129 - 正则表达式例子
  • Example#5130 - ereg_replace 例子
  • Example#5131 - ereg_replace 例子
  • Example#5132 - 将 URL 替换为超连接
  • Example#5133 - ereg 例子
  • Example#5134 - 高亮搜索结果
  • Example#5135 - eregi 例子
  • Example#5136 - split 例子
  • Example#5137 - split 例子
  • Example#5138 - spliti 例子
  • Example#5139 - sql_regcase 例子
  • Example#5140 - addcslashes 例子
  • Example#5141 - 一个 addslashes 例子
  • Example#5142 - chr 例子
  • Example#5143 - chunk_split 例子
  • Example#5144 - convert_uudecode 例子
  • Example#5145 - convert_uuencode 例子
  • Example#5146 - count_chars 示例
  • Example#5147 - 显示一个 crc32 校验码
  • Example#5148 - crypt 范例
  • Example#5149 - 利用 htpasswd 进行 crypt 加密
  • Example#5150 - 以不同散列类型使用 crypt
  • Example#5151 - echo 例子
  • Example#5152 - explode 例子
  • Example#5153 - explode return examples
  • Example#5154 - limit 参数的例子
  • Example#5155 - fprintf: zero-padded integers
  • Example#5156 - fprintf: formatting currency
  • Example#5157 - Translation Table Example
  • Example#5158 - hex2bin 例子
  • Example#5159 - Decoding HTML entities
  • Example#5160 - htmlentities 例子
  • Example#5161 - ENT_IGNORE 用法示例
  • Example#5162 - 一个 htmlspecialchars_decode 的例子
  • Example#5163 - htmlspecialchars 例子
  • Example#5164 - implode 例子
  • Example#5165 - lcfirst 例子：
  • Example#5166 - levenshtein 例子：
  • Example#5167 - localeconv example
  • Example#5168 - ltrim的使用范例
  • Example#5169 - md5_file 使用范例
  • Example#5170 - md5 范例
  • Example#5171 - metaphone basic example
  • Example#5172 - Using the max_phonemes parameter
  • Example#5173 - Using the max_phonemes parameter
  • Example#5174 - money_format 例子
  • Example#5175 - nl2br 使用范例
  • Example#5176 - 使用 is_xhtml 生成合法的 HTML 标记
  • Example#5177 - 各种换行分隔符
  • Example#5178 - number_format Example
  • Example#5179 - ord 范例
  • Example#5180 - 检查 UTF-8 字符串的每一个字节
  • Example#5181 - parse_str 的使用
  • Example#5182 - parse_str 名称改写
  • Example#5183 - print 范例
  • Example#5184 - rtrim 使用范例
  • Example#5185 - setlocale Examples
  • Example#5186 - setlocale Examples for Windows
  • Example#5187 - sha1_file 范例
  • Example#5188 - sha1 范例
  • Example#5189 - Soundex Examples
  • Example#5190 - Argument swapping
  • Example#5191 - Specifying padding character
  • Example#5192 - Position specifier with other specifiers
  • Example#5193 - sprintf: zero-padded integers
  • Example#5194 - sprintf: formatting currency
  • Example#5195 - sprintf: scientific notation
  • Example#5196 - sscanf 例子
  • Example#5197 - sscanf - using optional parameters
  • Example#5198 - Using the empty string ''
  • Example#5199 - Showing case-sensitivity
  • Example#5200 - Using the empty string ''
  • Example#5201 - Showing case-sensitivity
  • Example#5202 - str_ireplace 范例
  • Example#5203 - str_pad 范例
  • Example#5204 - str_repeat 范例
  • Example#5205 - str_replace 基本范例
  • Example#5206 - 可能的 str_replace 替换范例
  • Example#5207 - str_rot13 范例
  • Example#5208 - str_shuffle 范例
  • Example#5209 - str_split 使用范例
  • Example#5210 - Using the empty string ''
  • Example#5211 - Showing case-sensitivity
  • Example#5212 - str_word_count 范例
  • Example#5213 - strcasecmp 范例
  • Example#5214 - strcmp 例子
  • Example#5215 - strcspn example
  • Example#5216 - strip_tags 范例
  • Example#5217 - stripos 范例
  • Example#5218 - stripslashes 范例
  • Example#5219 - 对数组使用 stripslashes
  • Example#5220 - stristr 范例
  • Example#5221 - 测试字符串的存在与否
  • Example#5222 - 使用非字符串 needle
  • Example#5223 - strlen 范例
  • Example#5224 - strpbrk 范例
  • Example#5225 - 使用 ===
  • Example#5226 - 使用 !==
  • Example#5227 - 使用位置偏移量
  • Example#5228 - strrchr 范例
  • Example#5229 - 使用 strrev 反转字符串
  • Example#5230 - strripos 简单范例
  • Example#5231 - 检查字串是否存在
  • Example#5232 - 使用偏移位置进行查找
  • Example#5233 - strspn 范例
  • Example#5234 - strstr 范例
  • Example#5235 - strtok 示例
  • Example#5236 - 当 strtok 找不到标记时的反应
  • Example#5237 - strtolower 范例
  • Example#5238 - strtoupper 范例
  • Example#5239 - strtr 范例
  • Example#5240 - 使用两个参数的 strtr 范例
  • Example#5241 - strtr behavior comparison
  • Example#5242 - substr_compare 范例
  • Example#5243 - substr_count 范例
  • Example#5244 - substr_replace 范例
  • Example#5245 - Using substr_replace to replace multiple strings at once
  • Example#5246 - 使用负数 start
  • Example#5247 - 使用负数 length
  • Example#5248 - substr 基本用法
  • Example#5249 - substr casting behaviour
  • Example#5250 -
  • Example#5251 - trim 使用范例
  • Example#5252 - 使用 trim 清理数组值
  • Example#5253 - ucfirst 范例
  • Example#5254 - ucwords 范例
  • Example#5255 - ucwords 自定义 delimiters 的例子
  • Example#5256 - vfprintf: 前导 0 的整数
  • Example#5257 - vprintf: 前导 0 的整数
  • Example#5258 - vsprintf: 前导 0 的整数
  • Example#5259 - wordwrap 范例
  • Example#5260 - wordwrap 范例
  • Example#5261 - wordwrap 例子
  • Example#5262 - array_change_key_case例一
  • Example#5263 - array_chunk 例子
  • Example#5264 - 从结果集中取出first names列
  • Example#5265 - 从结果集中总取出last names列，用相应的id作为键值
  • Example#5266 - username 列是从对象获取 public 的 "username" 属性
  • Example#5267 - 获取 username 列，从对象通过魔术方法 __get 获取 private 的 "username" 属性。
  • Example#5268 - 一个 array_combine 简单的例子
  • Example#5269 - array_count_values 例子
  • Example#5270 - array_diff_assoc 例子
  • Example#5271 - array_diff_assoc example
  • Example#5272 - array_diff_key 例
  • Example#5273 - array_diff_uassoc 例子
  • Example#5274 - array_diff_ukey 例子
  • Example#5275 - array_diff 例子
  • Example#5276 - array_diff example with non-matching types
  • Example#5277 - array_fill_keys 范例
  • Example#5278 - array_fill 例子
  • Example#5279 - array_filter 示例
  • Example#5280 - array_filter 不使用 callback 参数时
  • Example#5281 - array_filter 不使用 mode 参数时
  • Example#5282 - array_flip 例子
  • Example#5283 - array_flip 例子 : 冲突
  • Example#5284 - array_intersect_assoc 例子
  • Example#5285 - array_intersect_key 例子
  • Example#5286 - array_intersect_uassoc 例子
  • Example#5287 - array_intersect_ukey 例子
  • Example#5288 - array_intersect 例子
  • Example#5289 - array_key_exists 例子
  • Example#5290 - array_key_exists 与 isset 的对比
  • Example#5291 - array_key_first 基本用法
  • Example#5292 - array_keys 例子
  • Example#5293 - array_map 例子
  • Example#5294 - array_map 使用匿名函数 (PHP 5.3.0 起)
  • Example#5295 - array_map：使用更多的数组
  • Example#5296 - 多个数组的合并操作
  • Example#5297 - 仅有 array1 时，callback 设置为 null
  • Example#5298 - array_map 键（key）是 string
  • Example#5299 - array_merge_recursive 例子
  • Example#5300 - array_merge 示例
  • Example#5301 - Simple array_merge 示例
  • Example#5302 - array_merge 合并非数组的类型
  • Example#5303 - 多个数组排序
  • Example#5304 - 排序多维数组
  • Example#5305 - 对数据库结果进行排序
  • Example#5306 - 不区分大小写字母排序
  • Example#5307 - array_pad 例子
  • Example#5308 - array_pop 例子
  • Example#5309 - array_product 例子
  • Example#5310 - array_push 例子
  • Example#5311 - array_rand 例子
  • Example#5312 - array_reduce 例子
  • Example#5313 - array_replace_recursive 范例
  • Example#5314 - array_replace_recursive 及其递归表现
  • Example#5315 - array_replace 范例
  • Example#5316 - array_reverse 例子
  • Example#5317 - array_search 例子
  • Example#5318 - array_shift 例子
  • Example#5319 - array_slice 例子
  • Example#5320 - array_slice 于索引从 1 开始的 array
  • Example#5321 - array_slice 与混合类型键的 array
  • Example#5322 - array_splice 例子
  • Example#5323 - 几个以不同表达式实现相同效果的 array_splice 例子
  • Example#5324 - array_sum 例子
  • Example#5325 - array_udiff_assoc 例子
  • Example#5326 - array_udiff_uassoc 例子
  • Example#5327 - array_udiff 使用 stdClass 对象的例子
  • Example#5328 - array_udiff 使用 DateTime 对象的例子
  • Example#5329 - array_uintersect_assoc 例子
  • Example#5330 - array_uintersect_uassoc 例子
  • Example#5331 - array_uintersect 例子
  • Example#5332 - array_unique 例子
  • Example#5333 - array_unique 和类型
  • Example#5334 - array_unshift 例子
  • Example#5335 - array_values 例子
  • Example#5336 - array_walk_recursive 例子
  • Example#5337 - array_walk 例子
  • Example#5338 - array 例子
  • Example#5339 - array 的自动索引
  • Example#5340 - 从 1 开始索引的 array
  • Example#5341 - 访问双引号内的数组
  • Example#5342 - arsort 例子
  • Example#5343 - asort 例子
  • Example#5344 - compact 例子
  • Example#5345 - count 例子
  • Example#5346 - 递归 count 例子
  • Example#5347 - current 函数使用示例
  • Example#5348 - each 例子
  • Example#5349 - 用 each 遍历数组
  • Example#5350 - end 例子
  • Example#5351 - extract 例子
  • Example#5352 - in_array 例子
  • Example#5353 - in_array 严格类型检查例子
  • Example#5354 - in_array 中用数组作为 needle
  • Example#5355 - key 例子
  • Example#5356 - krsort 例子
  • Example#5357 - ksort 例子
  • Example#5358 - list 例子
  • Example#5359 - list 用法的一个例子
  • Example#5360 - 使用嵌套的 list
  • Example#5361 - 在 list 中使用数组索引
  • Example#5362 - list 和索引顺序定义
  • Example#5363 - 带键的 list
  • Example#5364 - natcasesort 例子
  • Example#5365 - natsort 基本用法的操作示例
  • Example#5366 - natsort examples demonstrating potential gotchas
  • Example#5367 - next 及相关函数的用法示例
  • Example#5368 - prev 及相关函数用法示例
  • Example#5369 - range 例子
  • Example#5370 - reset 例子
  • Example#5371 - rsort 例
  • Example#5372 - shuffle 例子
  • Example#5373 - sort 例子
  • Example#5374 - 使用 sort 不区分大小写自然排序的例子
  • Example#5375 - uasort 的基本例子
  • Example#5376 - uksort 例子
  • Example#5377 - usort 例子
  • Example#5378 - 使用多维数组的 usort 例子
  • Example#5379 - usort example using a member function of an object
  • Example#5380 - usort example using a closure to sort a multi-dimensional array
  • Example#5381 - classes.inc
  • Example#5382 - test_script.php
  • Example#5383 - class_alias 例子
  • Example#5384 - class_exists 例子
  • Example#5385 - autoload parameter 例子
  • Example#5386 - get_called_class 的使用
  • Example#5387 - get_class_methods 示例
  • Example#5388 - get_class_vars example
  • Example#5389 - get_class_vars and scoping behaviour
  • Example#5390 - 使用 get_class
  • Example#5391 - 超类中使用 get_class
  • Example#5392 - 命名空间中的类使用 get_class
  • Example#5393 - get_declared_classes 例子
  • Example#5394 - get_declared_interfaces 例子
  • Example#5395 - 使用 get_object_vars
  • Example#5396 - Use of get_object_vars
  • Example#5397 - 使用 get_parent_class
  • Example#5398 - Using get_parent_class
  • Example#5399 - interface_exists 例子
  • Example#5400 - is_a 例子
  • Example#5401 - 在 PHP 5 中使用 instanceof 运算符
  • Example#5402 - is_subclass_of 例子
  • Example#5403 - is_subclass_of example
  • Example#5404 - method_exists 例子
  • Example#5405 - Static method_exists 例子
  • Example#5406 - A property_exists example
  • Example#5407 - classkit_import example
  • Example#5408 - classkit_method_add example
  • Example#5409 - classkit_method_copy example
  • Example#5410 - classkit_method_redefine example
  • Example#5411 - classkit_method_remove example
  • Example#5412 - classkit_method_rename example
  • Example#5413 - A ctype_alnum 示例 (使用默认的区域设置)
  • Example#5414 - 一个 ctype_alpha 例子（使用默认的语言环境）
  • Example#5415 - 一个 ctype_cntrl 例子
  • Example#5416 - 一个 ctype_digit 例子
  • Example#5417 - 一个通过 ctype_digit 来比对字符和整数的例子。
  • Example#5418 - 一个 ctype_graph 例子
  • Example#5419 - 一个 ctype_lower 例子 (使用默认的语言环境)
  • Example#5420 - 一个 ctype_print 例子
  • Example#5421 - 一个 ctype_punct 的例子
  • Example#5422 - 一个 ctype_space 例子
  • Example#5423 - 一个 ctype_upper 例子 （使用当前默认语言环境）
  • Example#5424 - 一个 ctype_xdigit 的例子
  • Example#5425 - Configuring the default filter to act like htmlspecialchars
  • Example#5426 - Configuring the default filter to act like htmlspecialchars
  • Example#5427 - Validating email addresses with filter_var
  • Example#5428 - Validating IP addresses with filter_var
  • Example#5429 - Passing options to filter_var
  • Example#5430 - Sanitizing and validating email addresses
  • Example#5431 - Configuring a default filter
  • Example#5432 - 一个 filter_input_array 的例子
  • Example#5433 - 一个 filter_input 的例子
  • Example#5434 - 一个 filter_list 的例子
  • Example#5435 - 一个 filter_var_array 的例子
  • Example#5436 - 一个 filter_var 的示例
  • Example#5437 - call_user_func_array例子
  • Example#5438 - call_user_func_array使用命名空间的情况
  • Example#5439 - 把完整的函数作为回调传入call_user_func_array
  • Example#5440 - 传引用
  • Example#5441 - call_user_func 的参考例子
  • Example#5442 - call_user_func 的例子
  • Example#5443 - call_user_func 命名空间的使用
  • Example#5444 - 用call_user_func来调用一个类里面的方法
  • Example#5445 - 把完整的函数作为回调传入call_user_func
  • Example#5446 - Creating an anonymous function with create_function
  • Example#5447 - Making a general processing function with create_function
  • Example#5448 - Using anonymous functions as callback functions
  • Example#5449 - forward_static_call_array example
  • Example#5450 - forward_static_call example
  • Example#5451 - func_get_arg 例子
  • Example#5452 - func_get_arg PHP 5.3 前后对比的例子
  • Example#5453 - func_get_arg example of byref and byval arguments
  • Example#5454 - func_get_args 例子
  • Example#5455 - PHP 5.3 前后使用 func_get_args 在的对比
  • Example#5456 - func_get_args example of byref and byval arguments
  • Example#5457 - func_num_args example
  • Example#5458 - func_num_args example before and after PHP 5.3
  • Example#5459 - function_exists 的例子
  • Example#5460 - get_defined_functions 例子
  • Example#5461 - register_shutdown_function 例子
  • Example#5462 - register_tick_function example
  • Example#5463 - Quickhash Example
  • Example#5464 - Quickhash ArrayAccess Example
  • Example#5465 - Quickhash Iterator Example
  • Example#5466 - Quickhash String Values Example
  • Example#5467 - QuickHashIntSet::add example
  • Example#5468 - QuickHashIntSet::__construct example
  • Example#5469 - QuickHashIntSet::delete example
  • Example#5470 - QuickHashIntSet::exists example
  • Example#5471 - QuickHashIntSet::getSize example
  • Example#5472 - QuickHashIntSet::loadFromFile example
  • Example#5473 - QuickHashIntSet::loadFromString example
  • Example#5474 - QuickHashIntSet::saveToFile example
  • Example#5475 - QuickHashIntSet::saveToString example
  • Example#5476 - QuickHashIntHash::add example
  • Example#5477 - QuickHashIntHash::__construct example
  • Example#5478 - QuickHashIntHash::delete example
  • Example#5479 - QuickHashIntHash::exists example
  • Example#5480 - QuickHashIntHash::get example
  • Example#5481 - QuickHashIntHash::getSize example
  • Example#5482 - QuickHash IntHash file format
  • Example#5483 - QuickHash IntHash file format
  • Example#5484 - QuickHashIntHash::loadFromFile example
  • Example#5485 - QuickHashIntHash::loadFromString example
  • Example#5486 - QuickHashIntHash::saveToFile example
  • Example#5487 - QuickHashIntHash::saveToString example
  • Example#5488 - QuickHashIntHash::set example
  • Example#5489 - QuickHashIntHash::update example
  • Example#5490 - QuickHashStringIntHash::add example
  • Example#5491 - QuickHashStringIntHash::__construct example
  • Example#5492 - QuickHashStringIntHash::delete example
  • Example#5493 - QuickHashStringIntHash::get example
  • Example#5494 - QuickHashStringIntHash::getSize example
  • Example#5495 - QuickHash StringIntHash file format
  • Example#5496 - QuickHash IntHash file format
  • Example#5497 - QuickHashStringIntHash::loadFromFile example
  • Example#5498 - QuickHashStringIntHash::loadFromString example
  • Example#5499 - QuickHashStringIntHash::saveToFile example
  • Example#5500 - QuickHashStringIntHash::saveToString example
  • Example#5501 - QuickHashStringIntHash::set example
  • Example#5502 - QuickHashStringIntHash::update example
  • Example#5503 - QuickHashIntStringHash::add example
  • Example#5504 - QuickHashIntStringHash::__construct example
  • Example#5505 - QuickHashIntStringHash::delete example
  • Example#5506 - QuickHashIntStringHash::get example
  • Example#5507 - QuickHashIntStringHash::getSize example
  • Example#5508 - QuickHash IntString file format
  • Example#5509 - QuickHash IntString file format
  • Example#5510 - QuickHashIntStringHash::loadFromFile example
  • Example#5511 - QuickHashIntStringHash::loadFromString example
  • Example#5512 - QuickHashIntStringHash::saveToFile example
  • Example#5513 - QuickHashIntStringHash::saveToString example
  • Example#5514 - QuickHashIntStringHash::set example
  • Example#5515 - QuickHashIntStringHash::update example
  • Example#5516 - Shell 里的一个反射例子（一个终端）
  • Example#5517 - 扩展内置的类
  • Example#5518 - Reflection::getModifierNames 例子
  • Example#5519 - ReflectionClass 的基本用法
  • Example#5520 - ReflectionClass::export 的基本用法
  • Example#5521 - ReflectionClass::getConstructor 的基本用法
  • Example#5522 - ReflectionClass::getDefaultProperties 例子
  • Example#5523 - ReflectionClass::getDocComment 例子
  • Example#5524 - ReflectionClass::getEndLine 例子
  • Example#5525 - ReflectionClass::getExtension 的基本用法
  • Example#5526 - ReflectionClass::getExtensionName 的基本用法
  • Example#5527 - ReflectionClass::getInterfaceNames 例子
  • Example#5528 - ReflectionClass::getInterfaces 例子
  • Example#5529 - ReflectionClass::getMethod 的基本用法
  • Example#5530 - ReflectionClass::getMethods 的基本用法
  • Example#5531 - 从 ReflectionClass::getMethods 中过滤结果
  • Example#5532 - ReflectionClass::getName 例子
  • Example#5533 - ReflectionClass::getNamespaceName 例子
  • Example#5534 - ReflectionClass::getProperties 过滤例子
  • Example#5535 - ReflectionClass::getProperty 的基本用法
  • Example#5536 - Basic ReflectionClass::getReflectionConstants example
  • Example#5537 - ReflectionClass::getShortName 例子
  • Example#5538 - ReflectionClass::getStaticPropertyValue 的基本用法
  • Example#5539 - ReflectionClass::hasConstant 例子
  • Example#5540 - ReflectionClass::hasMethod 例子
  • Example#5541 - ReflectionClass::hasProperty 例子
  • Example#5542 - ReflectionClass::inNamespace 例子
  • Example#5543 - ReflectionClass::isAbstract 例子
  • Example#5544 - ReflectionClass::isAnonymous example
  • Example#5545 - ReflectionClass::isCloneable 的基本用法
  • Example#5546 - ReflectionClass::isFinal 例子
  • Example#5547 - ReflectionClass::isInstance 相关例子
  • Example#5548 - ReflectionClass::isInstantiable 例子
  • Example#5549 - ReflectionClass::isInterface 基本用法
  • Example#5550 - ReflectionClass::isInternal 的基本用法
  • Example#5551 - Basic ReflectionClass::isIterable Usage
  • Example#5552 - ReflectionClass::isIterateable 例子
  • Example#5553 - ReflectionClass::newInstanceArgs 的基本用法
  • Example#5554 - ReflectionClass::__toString 例子
  • Example#5555 - ReflectionExtension example
  • Example#5556 - ReflectionExtension::getClasses example
  • Example#5557 - ReflectionExtension::getClassNames example
  • Example#5558 - ReflectionExtension::getConstants example
  • Example#5559 - ReflectionExtension::getDependencies example
  • Example#5560 - ReflectionExtension::getFunctions example
  • Example#5561 - ReflectionExtension::getINIEntries example
  • Example#5562 - ReflectionExtension::getName example
  • Example#5563 - ReflectionExtension::getVersion example
  • Example#5564 - ReflectionExtension::info example
  • Example#5565 - ReflectionFunction::__construct example
  • Example#5566 - ReflectionFunction::invoke example
  • Example#5567 - ReflectionFunction::invokeArgs example
  • Example#5568 - ReflectionFunction::invokeArgs with references example
  • Example#5569 - ReflectionFunction::__toString example
  • Example#5570 - ReflectionFunctionAbstract::getReturnType example
  • Example#5571 - Usage on built-in functions
  • Example#5572 - ReflectionFunctionAbstract::hasReturnType example
  • Example#5573 - Usage on built-in functions
  • Example#5574 - ReflectionFunctionAbstract::isDeprecated example
  • Example#5575 - ReflectionMethod::__construct example
  • Example#5576 - ReflectionMethod::getDeclaringClass example
  • Example#5577 - ReflectionMethod::getModifiers example
  • Example#5578 - ReflectionMethod::getPrototype example
  • Example#5579 - ReflectionMethod::invoke example
  • Example#5580 - ReflectionMethod::invokeArgs example
  • Example#5581 - ReflectionMethod::__toString example
  • Example#5582 - Using the ReflectionParameter class
  • Example#5583 - 使用 ReflectionParameter 类
  • Example#5584 - Getting the class that declared the method
  • Example#5585 - Getting default values of function parameters
  • Example#5586 - Getting default values' constant names of function parameters
  • Example#5587 - ReflectionParameter::getType Usage as of PHP 7.1.0
  • Example#5588 - ReflectionParameter::getType Usage before PHP 7.1.0
  • Example#5589 - ReflectionParameter::hasType example
  • Example#5590 - ReflectionProperty::__construct example
  • Example#5591 - Getting value from private and protected properties using ReflectionProperty class
  • Example#5592 - ReflectionClass::getDefaultValue example
  • Example#5593 - ReflectionProperty::getDocComment example
  • Example#5594 - Multiple property declarations
  • Example#5595 - ReflectionProperty::getType example
  • Example#5596 - ReflectionProperty::getValue example
  • Example#5597 - ReflectionClass::hasDefaultValue example
  • Example#5598 - ReflectionProperty::hasType example
  • Example#5599 - ReflectionClass::isDefault example
  • Example#5600 - ReflectionProperty::isInitialized example
  • Example#5601 - Simple Class definition
  • Example#5602 - ReflectionProperty::setValue example
  • Example#5603 - ReflectionType::allowsNull example
  • Example#5604 - ReflectionType::__toString example
  • Example#5605 - ReflectionGenerator::__construct example
  • Example#5606 - ReflectionGenerator::getExecutingFile example
  • Example#5607 - ReflectionGenerator::getExecutingGenerator example
  • Example#5608 - ReflectionGenerator::getExecutingLine example
  • Example#5609 - ReflectionGenerator::getFunction example
  • Example#5610 - ReflectionGenerator::getThis example
  • Example#5611 - ReflectionGenerator::getTrace example
  • Example#5612 - boolval examples
  • Example#5613 - debug_zval_dump example
  • Example#5614 -
  • Example#5615 -
  • Example#5616 - 一个简单的 empty 与 isset 的比较。
  • Example#5617 - 在字符串偏移量上使用empty
  • Example#5618 - get_resource_id example
  • Example#5619 - gettype 示例
  • Example#5620 - intval 例子
  • Example#5621 - is_bool 示例
  • Example#5622 - is_callable 例子
  • Example#5623 - is_countable examples
  • Example#5624 - is_int 示例
  • Example#5625 - is_iterable examples
  • Example#5626 - is_scalar 示例
  • Example#5627 - isset 例子
  • Example#5628 - 在字符串位移中使用 isset
  • Example#5629 - print_r 例子
  • Example#5630 - return 参数的例子
  • Example#5631 - serialize 示例
  • Example#5632 - settype 示例
  • Example#5633 - unserialize 例子
  • Example#5634 - unserialize_callback_func 例子
  • Example#5635 - unset 示例
  • Example#5636 - 使用 (unset) 类型强制转换
  • Example#5637 - var_dump 例子
  • Example#5638 - var_export 示例
  • Example#5639 - 输出类 stdClass (自 PHP 7.3.0 起)
  • Example#5640 - 输出对象 (自 PHP 5.1.0 起)
  • Example#5641 - 使用 __set_state() (自 PHP 5.1.0 起)
  • Example#5642 -
  • Example#5643 - OAuth::fetch example
  • Example#5644 - OAuth::getAccessToken 例子
  • Example#5645 - OAuth::getRequestToken 例子
  • Example#5646 - OAuth::setRequestEngine 例子
  • Example#5647 - 一个 OAuth::setRsaCertificate 例子
  • Example#5648 - OAuth::setToken 例子
  • Example#5649 - OAuthProvider::__construct 例子
  • Example#5650 - OAuthProvider::consumerHandler 回调的例子
  • Example#5651 - OAuthProvider::generateToken 例子
  • Example#5652 - OAuthProvider::is2LeggedEndpoint 例子
  • Example#5653 - OAuthProvider::timestampNonceHandler 回调的例子
  • Example#5654 - OAuthProvider::tokenHandler 回调的例子
  • Example#5655 - is_soap_fault example
  • Example#5656 - SOAP's standard method for error reporting is exceptions
  • Example#5657 - SoapClient::__construct example
  • Example#5658 - SoapClient::__doRequest example
  • Example#5659 - SoapClient::__getFunctions example
  • Example#5660 - SoapClient::__getLastRequest() example
  • Example#5661 - SoapClient::__getLastRequestHeaders() example
  • Example#5662 - SoapClient::__getLastResponse() example
  • Example#5663 - SoapClient::__getLastResponse() example
  • Example#5664 - SoapClient::__getTypes example
  • Example#5665 - SoapClient::__setLocation example
  • Example#5666 - SoapClient::__setSoapHeaders example
  • Example#5667 - Set Multiple Headers
  • Example#5668 - SoapClient::__soapCall example
  • Example#5669 - SoapServer::addFunction example
  • Example#5670 - SoapServer::__construct example
  • Example#5671 - SoapServer::getFunctions example
  • Example#5672 - SoapServer::handle example
  • Example#5673 - SoapServer::setPersistence example
  • Example#5674 - Some examples
  • Example#5675 - Some examples
  • Example#5676 - SoapHeader::__construct example
  • Example#5677 - SoapParam::__construct example
  • Example#5678 - SoapVar::__construct example
  • Example#5679 - Yar Server示例
  • Example#5680 - 通过浏览器访问(GET请求)
  • Example#5681 - Yar Client示例
  • Example#5682 - Yar Concurrent Client示例
  • Example#5683 - Yar_Server::__construct示例
  • Example#5684 - Yar_Server::handle示例
  • Example#5685 - Yar_Client::__call example
  • Example#5686 - Yar_Client::__construct示例
  • Example#5687 - Yar_Client::setOpt示例
  • Example#5688 - Yar_Concurrent_Client::call示例
  • Example#5689 - Yar_Concurrent_Client::loop example
  • Example#5690 - Yar_Server_Exception::getType示例
  • Example#5691 - Yar_Client_Exception::getType example
  • Example#5692 - XMLRPC client functions example
  • Example#5693 - XML-RPC type example
  • Example#5694 - A xmlrpc_set_type example
  • Example#5695 - For Each in ASP
  • Example#5696 - foreach in PHP
  • Example#5697 - com example (1)
  • Example#5698 - com example (2)
  • Example#5699 - dotnet example
  • Example#5700 - variant example
  • Example#5701 - Basic COMPersistHelper::saveToFile Usage
  • Example#5702 - COM event sink example
  • Example#5703 - Registering a PHP script to run as a service
  • Example#5704 - Unregistering a service
  • Example#5705 - Running as a service
  • Example#5706 - A win32_create_service example
  • Example#5707 - A win32_create_service example with dependencies
  • Example#5708 - A win32_create_service example with recovery
  • Example#5709 - A win32_delete_service example
  • Example#5710 - A win32_start_service_ctrl_dispatcher example
  • Example#5711 - book.xml
  • Example#5712 - Creating a new DOMAttr object
  • Example#5713 - DOMAttr::isId() Example
  • Example#5714 - Creating a new DOMCdataSection object
  • Example#5715 - Creating a new DOMComment
  • Example#5716 - Creating a new DOMDocument
  • Example#5717 - Creating a new element and inserting it as root
  • Example#5718 - Passing text containing an unescaped & as value
  • Example#5719 - Creating a new element and inserting it as root
  • Example#5720 - A namespace prefix example
  • Example#5721 - DOMDocument::getElementById() Example
  • Example#5722 - Basic Usage Example
  • Example#5723 - Get all the XInclude elements
  • Example#5724 - DOMDocument::importNode example
  • Example#5725 - Creating a Document
  • Example#5726 - Creating a Document
  • Example#5727 - Creating a Document
  • Example#5728 - Creating a Document
  • Example#5729 - Static invocation of loadXML
  • Example#5730 - Adding a new method to DOMElement to ease our code
  • Example#5731 - Retrieving elements as custom class
  • Example#5732 - Retrieving owner document
  • Example#5733 - Custom objects are transient
  • Example#5734 - Saving a DOM tree into a file
  • Example#5735 - Saving a HTML tree into a string
  • Example#5736 - Saving a HTML tree into a file
  • Example#5737 - Saving a DOM tree into a string
  • Example#5738 - Example of DTD validation
  • Example#5739 - DOMDocument::xinclude() example
  • Example#5740 - Appending XML data to your document
  • Example#5741 - Creating a new DOMElement
  • Example#5742 - Setting an attribute
  • Example#5743 - Creating a new DOMEntityReference
  • Example#5744 - Creating a document with an attached DTD
  • Example#5745 - Testing your DOM Implementation
  • Example#5746 - Adding a child
  • Example#5747 - Nested children
  • Example#5748 - DOMNode::getLineNo example
  • Example#5749 - DOMNode::getNodePath example
  • Example#5750 - Removing a child
  • Example#5751 - Traversing all the entries of the table
  • Example#5752 - Creating a new DOMProcessingInstruction object
  • Example#5753 - Creating a new DOMText
  • Example#5754 - Getting the count of all the english books
  • Example#5755 - Getting all the english books
  • Example#5756 - book.xml
  • Example#5757 - DOMXPath::registerPHPFunctions with php:functionString
  • Example#5758 - DOMXPath::registerPHPFunctions with php:function
  • Example#5759 - Import SimpleXML into DOM with dom_import_simplexml
  • Example#5760 - A libxml_get_errors example
  • Example#5761 - libxml_set_external_entity_loader example
  • Example#5762 - A libxml_set_streams_context example
  • Example#5763 - A libxml_use_internal_errors example
  • Example#5764 - Include file example.php with XML string
  • Example#5765 - Getting <plot>
  • Example#5766 - Getting <line>
  • Example#5767 - Accessing non-unique elements in SimpleXML
  • Example#5768 - Using attributes
  • Example#5769 - Comparing Elements and Attributes with Text
  • Example#5770 - Comparing Two Elements
  • Example#5771 - Using XPath
  • Example#5772 - Setting values
  • Example#5773 - Adding elements and attributes
  • Example#5774 - DOM Interoperability
  • Example#5775 - Loading broken XML string
  • Example#5776 - Add attributes and children to a SimpleXML element
  • Example#5777 - Add attributes and children to a SimpleXML element
  • Example#5778 - Get XML
  • Example#5779 - Using asXML() on SimpleXMLElement::xpath results
  • Example#5780 - Interpret an XML string
  • Example#5781 - Traversing a children() pseudo-array
  • Example#5782 - Using namespaces
  • Example#5783 - Create a SimpleXMLElement object
  • Example#5784 - Create a SimpleXMLElement object from a URL
  • Example#5785 - Counting the number of children
  • Example#5786 - Get document namespaces
  • Example#5787 - Working with multiple namespaces
  • Example#5788 - Get XML element names
  • Example#5789 - Get document namespaces in use
  • Example#5790 - Setting a namespace prefix to use in an XPath query
  • Example#5791 - Get string content
  • Example#5792 - Xpath
  • Example#5793 - Return the current element
  • Example#5794 - Return the sub-elements of the current element
  • Example#5795 - Check whether the current element has sub-elements
  • Example#5796 - Get the current XML tag key
  • Example#5797 - Move to the next element
  • Example#5798 - Rewind to the first element
  • Example#5799 - Check whether the current element is valid
  • Example#5800 - Importing DOM
  • Example#5801 - Interpret an XML document
  • Example#5802 - Interpret an XML string
  • Example#5803 - Serializing a single value with WDDX
  • Example#5804 - Using incremental packets with WDDX
  • Example#5805 - wddx_serialize_vars example
  • Example#5806 - 显示 XML 元素结构
  • Example#5807 - 将 XML 映射为 HTML
  • Example#5808 - 外部实体例程
  • Example#5809 - xmltest.xml
  • Example#5810 - xmltest2.xml
  • Example#5811 - xml_parse_into_struct 示例
  • Example#5812 - moldb.xml - 分子信息的小型数据库
  • Example#5813 - parsemoldb.php - 将 moldb.xml 解析到分子（molecular）对象的数组中
  • Example#5814 - xml_set_object 示例
  • Example#5815 - Validating XML
  • Example#5816 - Creating a simple XML document
  • Example#5817 - Working with XML namespaces
  • Example#5818 - Working with the OO API
  • Example#5819 - Direct output of XML
  • Example#5820 - XMLWriter::setIndent and mixed Content
  • Example#5821 - Basic XMLWriter::startAttribute Usage
  • Example#5822 - Intermixing Sub-elements and Attributes
  • Example#5823 - Basic xmlwriter_write_cdata Usage
  • Example#5824 - collection.xml
  • Example#5825 - collection.xsl
  • Example#5826 - fruits.xml
  • Example#5827 - fruits.xsl
  • Example#5828 - Collating and printing errors
  • Example#5829 - Creating an XSLTProcessor
  • Example#5830 - Testing EXSLT support
  • Example#5831 - Simple PHP Function call from a stylesheet
  • Example#5832 - Changing the owner before the transformation
  • Example#5833 - Example profiling output
  • Example#5834 - Transforming to a DOMDocument
  • Example#5835 - Transforming to a HTML file
  • Example#5836 - Transforming to a string
  • Example#5837 - 隐藏的 HTML 表单单元
  • Example#5838 - 等待用户编辑的数据
  • Example#5839 - URL 中的例子
  • Example#5840 - Activate full on-screen error reporting for dev. domain
  • Example#5841 - Add security script for protected areas
  • Example#5842 - Unix include_path
  • Example#5843 - Windows include_path
  • Example#5844 - Unix include_path using ${USER} env variable
  • Example#5845 - string.rot13
  • Example#5846 - string.toupper
  • Example#5847 - string.tolower
  • Example#5848 - string.strip_tags
  • Example#5849 - convert.base64-encode & convert.base64-decode
  • Example#5850 - convert.quoted-printable-encode & convert.quoted-printable-decode
  • Example#5851 - zlib.deflate和 zlib.inflate
  • Example#5852 - zlib.deflate简单参数用法
  • Example#5853 - bzip2.compress和 bzip2.decompress
  • Example#5854 - 用 3DES 将文件加密输出
  • Example#5855 - 读取加密的文件


更新日志

对绑定的扩展的函数有以下更新。

Version | Function | Description
Since 5.0.0 | get_parent_class | The object parameter is optional if called from the object's method.
Since 5.0 | cal_info | 参数calendar作为可选项，缺省时默认值为"所有历法"。
Since 4.3.0 | easter_date | year参数可选，缺省的默认值是当年。
easter_days | 参数year 可选，缺省默认值是当年。
easter_days | 引入参数 method。
Since 4.2.0 | srand | seed 成为可选，省略时会默认使用随机值。
Since 4.0.5 | get_parent_class | If object is a string, returns the name of the parent class of the class with that name.
prior to 5.3.0 | get_object_vars | If the object isn't an object, then get_object_vars would return false
Prior to 5.1.3 | imagecolorallocatealpha | Returns -1 if the allocation failed.
prior to 4.2.0 | get_object_vars | If the variables declared in the class of which the object is an instance, have not been assigned a value, those will not be returned in the array
PHP 7.0.15, PHP 7.1.1 | get_defined_functions | 增加 exclude_disabled 参数。
PHP 5.3.2 (PECL OCI8 1.4) | oci_set_prefetch | Before this release, rows must be >= 1.
PHP 5.3 (PECL OCI8 1.3.4) | oci_set_prefetch | Before this release, prefetching was limited to the lesser of rows rows and 1024 * rows bytes. The byte size restriction has now been removed.
PECL 3.0.0 | IntlDateFormatter::format | Support for providing IntlCalendar objects to the datetime parameter was added.
Before 5.1.0 | get_parent_class | If called without parameter outside object, this function would have returned null with a warning.
8.0.3 | bind_textdomain_codeset | codeset is nullable now. Previously, it was not possible to retrieve the currently set encoding.
bindtextdomain | directory is nullable now. Previously, it was not possible to retrieve the currently set directory.
8.0.0, PECL OCI8 3.0.0 | OCICollection::append | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.
OCICollection::assign | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.
OCICollection::assignElem | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.
OCICollection::free | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.
OCICollection::getElem | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.
OCICollection::max | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.
OCICollection::size | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.
OCICollection::trim | The OCI-Collection class was renamed to OCICollection to align with PHP naming standards.
OCILob::append | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::close | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::eof | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::erase | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::export | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::flush | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::free | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::getBuffering | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::import | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::load | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::read | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::rewind | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::save | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::saveFile | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::seek | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::setBuffering | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::size | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::tell | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::truncate | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::write | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::writeTemporary | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
OCILob::writeToFile | The OCI-Lob class was renamed to OCILob to align with PHP naming standards.
8.0.0 | DateTime::format | Prior to this version, false was returned on failure.
DateTime::format | The format character p has been added.
DateTime::getOffset | Prior to this version, false was returned on failure.
DateTime::getTimestamp | These functions no longer return false on failure.
DOMImplementation::createDocument | doctype is now nullable.
array_filter | callback 回调现在可以为空（nullable）。
bcpowmod | scale is now nullable.
com_event_sink | sink_interface is nullable now.
com_get_active_object | codepage is nullable now.
deflate_add | context expects a DeflateContext instance now; previously, a resource was expected.
deflate_init | On success, this function returns a DeflateContext instance now; previously, a resource was returned.
enchant_broker_describe | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_describe | Prior to this version, the function returned false on failure.
enchant_broker_dict_exists | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_free | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_free_dict | dictionary expects a EnchantDictionary now; previoulsy, a 资源(resource) was expected.
enchant_broker_get_dict_path | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_get_error | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_init | On success, this function returns an EnchantBroker instance now; previoulsy, a 资源(resource) was retured.
enchant_broker_list_dicts | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_list_dicts | Prior to this version, the function returned false on failure.
enchant_broker_request_dict | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_request_dict | On success, this function returns an EnchantDictionary instance now; previoulsy, a 资源(resource) was retured.
enchant_broker_request_pwl_dict | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_request_pwl_dict | On success, this function returns an EnchantDictionary instance now; previoulsy, a 资源(resource) was retured.
enchant_broker_set_dict_path | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_broker_set_ordering | broker expects an EnchantBroker instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_add | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_add_to_session | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_check | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_describe | Prior to this version, the function returned false on failure.
enchant_dict_describe | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_get_error | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_is_added | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_quick_check | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_store_replacement | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
enchant_dict_suggest | dictionary expects an EnchantDictionary instance now; previoulsy, a 资源(resource) was expected.
gmp_binomial | This function no longer returns false on failure.
gmp_export | This function no longer returns false on failure.
gmp_import | This function no longer returns false on failure.
gzgets | length is nullable now; previously, the default was 1024.
gzwrite | length is nullable now; previously, the default was 0.
html_entity_decode | encoding is nullable now.
iconv_strpos | encoding is nullable now.
iconv_strrpos | encoding is nullable now.
inflate_add | context expects an InflateContext instance now; previously, a resource was expected.
inflate_get_read_len | context expects an InflateContext instance now; previously, a resource was expected.
inflate_get_status | context expects an InflateContext instance now; previously, a resource was expected.
inflate_init | On success, this function returns an InflateContext instance now; previously, a resource was returned.
ldap_add | controls is nullable now; previously, it defaulted to [].
ldap_add_ext | controls is nullable now; previously, it defaulted to [].
ldap_bind_ext | controls is nullable now; previously, it defaulted to [].
ldap_compare | controls is nullable now; previously, it defaulted to [].
ldap_delete | controls is nullable now; previously, it defaulted to [].
ldap_delete_ext | controls is nullable now; previously, it defaulted to [].
ldap_exop_passwd | controls is nullable now; previously, it defaulted to [].
ldap_list | controls is nullable now; previously, it defaulted to [].
ldap_mod_add | controls is nullable now; previously, it defaulted to [].
ldap_mod_del | controls is nullable now; previously, it defaulted to [].
ldap_mod_replace | controls is nullable now; previously, it defaulted to [].
ldap_modify_batch | controls is nullable now; previously, it defaulted to [].
ldap_mod_add_ext | controls is nullable now; previously, it defaulted to [].
ldap_mod_del_ext | controls is nullable now; previously, it defaulted to [].
ldap_mod_replace_ext | controls is nullable now; previously, it defaulted to [].
ldap_read | controls is nullable now; previously, it defaulted to [].
ldap_rename | controls is nullable now; previously, it defaulted to [].
ldap_rename_ext | controls is nullable now; previously, it defaulted to [].
ldap_sasl_bind | dn, password, mech, realm, authc_id, authz_id and props are nullable now.
ldap_search | controls is nullable now; previously, it defaulted to [].
ldap_set_rebind_proc | callback is nullable now.
libxml_use_internal_errors | use_errors is nullable now. Previously, its default was false.
mb_chr | 现在 encoding 可以为 null。
mb_convert_kana | 现在 encoding 可以为 null。
mb_encode_numericentity | 现在 encoding 可以为 null。
mb_ereg | This function returns true on success now. Previously, it returned the byte length of the matched string if a match for pattern was found in string and matches was passed. If the optional parameter matches was not passed or the length of the matched string was 0, this function returned 1.
mb_ereg_match | options is nullable now.
mb_ereg_replace | options is nullable now.
mb_ereg_replace_callback | options is nullable now.
mb_ereg_search | pattern and options are nullable now.
mb_ereg_search_init | pattern and options are nullable now.
mb_ereg_search_pos | pattern and options are nullable now.
mb_ereg_search_regs | pattern and options are nullable now.
mb_eregi | This function returns true on success now. Previously, it returned the byte length of the matched string if a match for pattern was found in string and matches was passed. If the optional parameter matches was not passed or the length of the matched string was 0, this function returned 1.
mb_eregi_replace | options is nullable now.
mb_get_info | 参数 type 中的 "func_overload" 和 "func_overload_list" 不再被支持。
mb_ord | 现在 encoding 可以为 null。
mb_regex_encoding | 现在 encoding 可以为 null。
mb_regex_set_options | options is nullable now.
mb_regex_set_options | If the parameter options is given and not null, the previous options are returned. Formerly, the current options have been returned.
mb_scrub | 现在 encoding 可以为 null。
mb_str_split | This function no longer returns false on failure.
mb_str_split | 现在 encoding 可以为 null。
metaphone | The function returned false on failure.
mhash | key is now nullable.
msg_get_queue | On success, this function returns a SysvMessageQueue instance now; previously, a resource was returned.
msg_receive | queue expects a SysvMessageQueue instance now; previously, a resource was expected.
msg_remove_queue | queue expects a SysvMessageQueue instance now; previously, a resource was expected.
msg_send | queue expects a SysvMessageQueue instance now; previously, a resource was expected.
msg_set_queue | queue expects a SysvMessageQueue instance now; previously, a resource was expected.
msg_stat_queue | queue expects a SysvMessageQueue instance now; previously, a resource was expected.
odbc_columns | schema, table and column are now nullable.
odbc_error | odbc is nullable now.
odbc_errormsg | odbc is nullable now.
odbc_exec | flags was removed.
odbc_fetch_row | row is nullable now.
odbc_procedurecolumns | Prior to this version, the function could only be called with either one or five arguments.
odbc_procedures | Prior to this version, the function could only be called with either one or four arguments.
odbc_tables | schema, table and types are now nullable.
openssl_pkey_new | 成功时此函数会返回 OpenSSLAsymmetricKey 的实例；在之前版本中，则会返回类似为 OpenSSL key 的 资源(resource)。
openssl_sign | private_key accepts an OpenSSLAsymmetricKey or OpenSSLCertificate instance now; previously, a 资源(resource) of type OpenSSL key or OpenSSL X.509 was accepted.
openssl_x509_verify | public_key accepts an OpenSSLAsymmetricKey or OpenSSLCertificate instance now; previously, a 资源(resource) of type OpenSSL key or OpenSSL X.509 was accepted.
openssl_x509_verify | certificate accepts an OpenSSLCertificate instance now; previously, a 资源(resource) of type OpenSSL X.509 was accepted.
parse_str | result 是必须项。
sem_acquire | semaphore expects a SysvSemaphore instance now; previously, a resource was expected.
sem_get | On success, this function returns a SysvSemaphore instance now; previously, a resource was returned.
sem_get | The type of auto_release has been changed from int to bool.
sem_release | semaphore expects a SysvSemaphore instance now; previously, a resource was expected.
sem_remove | semaphore expects a SysvSemaphore instance now; previously, a resource was expected.
shm_attach | size is nullable now.
shm_attach | On success, this function returns an SysvSharedMemory instance now; previously, a resource was returned.
shm_detach | shm expects a SysvSharedMemory instance now; previously, a resource was expected.
shm_get_var | shm expects a SysvSharedMemory instance now; previously, a resource was expected.
shm_has_var | shm expects a SysvSharedMemory instance now; previously, a resource was expected.
shm_put_var | shm expects a SysvSharedMemory instance now; previously, a resource was expected.
shm_remove | shm expects a SysvSharedMemory instance now; previously, a resource was expected.
shm_remove_var | shm expects a SysvSharedMemory instance now; previously, a resource was expected.
shmop_close | shmop expects a Shmop instance now; previously, a resource was expected.
shmop_delete | shmop expects a Shmop instance now; previously, a resource was expected.
shmop_open | On success, this function returns an Shmop instance now; previously, a resource was returned.
shmop_read | shmop expects a Shmop instance now; previously, a resource was expected.
shmop_size | shmop expects a Shmop instance now; previously, a resource was expected.
shmop_write | shmop expects a Shmop instance now; previously, a resource was expected.
shmop_write | Prior to PHP 8.0.0, false was returned on failure.
socket_accept | On success, this function returns a Socket instance now; previously, a resource was returned.
socket_addrinfo_bind | address is an AddressInfo instance now; previously, it was a resource.
socket_addrinfo_bind | On success, this function returns a Socket instance now; previously, a resource was returned.
socket_addrinfo_connect | address is an AddressInfo instance now; previously, it was a resource.
socket_addrinfo_connect | On success, this function returns a Socket instance now; previously, a resource was returned.
socket_addrinfo_explain | address is an AddressInfo instance now; previously, it was a resource.
socket_addrinfo_lookup | On success, this function returns a array of AddressInfo instances now; previously, an array of resources was returned.
socket_addrinfo_lookup | service is nullable now.
socket_connect | socket is a Socket instance now; previously, it was a resource.
socket_connect | port 允许为空。
socket_create_listen | On success, this function returns a Socket instance now; previously, a resource was returned.
socket_create_pair | pair is a reference to an array of Socket instances now; previously, it was a reference to an array of resources.
socket_export_stream | socket is a Socket instance now; previously, it was a resource.
socket_get_option | socket is a Socket instance now; previously, it was a resource.
socket_getpeername | socket is a Socket instance now; previously, it was a resource.
socket_getsockname | socket is a Socket instance now; previously, it was a resource.
socket_import_stream | On success, this function returns a Socket instance now; previously, a resource was returned.
socket_last_error | socket is a Socket instance now; previously, it was a resource.
socket_last_error | socket is nullable now.
socket_listen | socket is a Socket instance now; previously, it was a resource.
socket_read | socket is a Socket instance now; previously, it was a resource.
socket_recvfrom | socket is a Socket instance now; previously, it was a resource.
socket_recvmsg | socket is a Socket instance now; previously, it was a resource.
socket_send | socket is a Socket instance now; previously, it was a resource.
socket_sendmsg | socket is a Socket instance now; previously, it was a resource.
socket_sendto | socket is a Socket instance now; previously, it was a resource.
socket_sendto | port is nullable now.
socket_set_block | socket is a Socket instance now; previously, it was a resource.
socket_set_nonblock | socket is a Socket instance now; previously, it was a resource.
socket_set_option | socket is a Socket instance now; previously, it was a resource.
socket_shutdown | socket is a Socket instance now; previously, it was a resource.
socket_write | length is nullable now.
socket_write | socket is a Socket instance now; previously, it was a resource.
socket_wsaprotocol_info_export | socket is a Socket instance now; previously, it was a resource.
socket_wsaprotocol_info_import | On success, this function returns a Socket instance now; previously, a resource was returned.
soundex | Prior to this version, calling the function with an empty string returned false for no particular reason.
sprintf | This function no longer returns false on failure.
ReflectionClass::getReflectionConstants | filter has been added.
ReflectionParameter::getDefaultValue | This method now allows getting the default value of parameters of built-in functions and built-in class methods. Previously, a ReflectionException was thrown.
ReflectionParameter::getDefaultValueConstantName | This method now allows getting the default values' constant names of built-in functions and built-in class methods. Previously, a ReflectionException was thrown.
ReflectionProperty::getValue | object is nullable now.
ReflectionProperty::isInitialized | object is nullable now.
SoapClient::__doRequest | The type of oneWay is bool now; formerly it was int.
SoapClient::__setCookie | value is now nullable.
SoapServer::handle | request is now nullable.
tidy::__construct | filename, config, encoding and useIncludePath are nullable now.
tidy::parseFile | config and encoding are nullable now.
tidy::parseString | config and encoding are nullable now.
tidy::repairFile | config and encoding are nullable now.
tidy::repairFile | tidy::repairFile is a static method now.
tidy::repairString | tidy::repairString is a static method now.
tidy::repairString | This function no longer accepts the useIncludePath parameter.
tidy::repairString | config and encoding are nullable now.
XMLReader::getAttribute | This function can no longer return false.
XMLReader::getAttributeNs | This function can no longer return false.
XMLReader::lookupNamespace | This function can no longer return false.
XMLReader::next | name is nullable now.
XMLReader::open | XMLReader::open is now declared as static method, but can still be called on an XMLReader instance.
XMLReader::XML | XMLReader::XML is now declared as static method, but can still be called on an XMLReader instance.
XMLWriter::endAttribute | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endCdata | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endComment | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endDocument | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endDtd | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endDtdAttlist | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endDtdElement | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endDtdEntity | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endElement | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::endPi | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::flush | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::flush | This function can no longer return false.
XMLWriter::fullEndElement | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::openMemory | This function returns now an XMLWriter instance on success. Previouly, a 资源(resource) has been returned in this case.
XMLWriter::openUri | This function returns now an XMLWriter instance on success. Previouly, a 资源(resource) has been returned in this case.
XMLWriter::outputMemory | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::setIndent | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::setIndentString | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startAttribute | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startAttributeNs | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startAttributeNs | prefix is nullable now.
XMLWriter::startCdata | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startComment | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startDocument | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startDtd | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startDtdAttlist | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startDtdElement | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startDtdEntity | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startElement | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startElementNs | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::startPi | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::text | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeAttribute | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeAttributeNs | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeCdata | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeComment | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeDtd | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeDtdAttlist | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeDtdElement | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeDtdEntity | publicId, systemId and notationData are nullable now.
XMLWriter::writeDtdEntity | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeElement | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeElementNs | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writePi | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
XMLWriter::writeRaw | 现在 writer 需要 XMLWriter 实例， 之前需要的是 resource。
7.4.0 | array_merge | 允许不带参数调用，之前版本至少需要一个参数。
array_merge_recursive | 允许不传递参数调用，之前的版本中至少需要一个参数。
get_magic_quotes_gpc | 该函数已被废弃。
gzread | This functions returns false on failure now; previously 0 was returned.
gzwrite | This functions returns false on failure now; previously 0 was returned.
hash_algos | 支持 crc32c。
idn_to_ascii | 现在 variant 的默认值为 INTL_IDNA_VARIANT_UTS46 ， 而不是已弃用的 INTL_IDNA_VARIANT_2003 。
idn_to_utf8 | 现在 variant 的默认值为 INTL_IDNA_VARIANT_UTS46 ， 而不是已弃用的 INTL_IDNA_VARIANT_2003 。
imagecropauto | The default value of mode has been changed to IMG_CROP_AUTO. Formerly, the default value has been -1 which corresponds to IMG_CROP_DEFAULT, but passing -1 is now deprecated.
imagecropauto | The behavior of imagecropauto() in the bundled libgd has been synced with that of system libgd: IMG_CROP_DEFAULT no longer falls back to IMG_CROP_SIDES and threshold-cropping now uses the same algorithm as system libgd.
implode | 把参数 glue 放到 pieces 的后面已被废弃（就是不按文档中的顺序传递参数）。
ldap_control_paged_result | This function has been deprecated.
ldap_control_paged_result_response | This function has been deprecated.
password_hash | 现在 algo 参数可支持 string 类型，但为了向后兼容也支持 int 类型。
password_needs_rehash | 现在 algo 参数可以支持 string 类型，但为了向后兼容性，同时支持 int 类型。
preg_replace_callback | 新增 flags 参数。
preg_replace_callback_array | The flags parameter was added.
SQLite3Stmt::bindParam | param now also supports the @param notation.
SQLite3Stmt::bindValue | param now also supports the @param notation.
7.3.24, 7.4.12 | tidyNode::isHtml | This function has been fixed to have reasonable behavior. Previously, almost any node was reported as being an HTML node.
7.3.14, 7.4.2 | dba_open | The lmdb driver now supports an additional $mapsize parameter.
7.3.0 | apache_request_headers | 此函数可用于 FPM SAPI 模式。
array_push | 可以只用一个参数来调用此函数，之前版本中至少需要两个参数。
array_unshift | 现在可以只用一个参数来调用，之前至少需要两个参数。
compact | 现在，如果字符串指向的变量未定义，compact 会产生 E_NOTICE 级错误。 在此之前，此类问题会静默忽略掉。
define | 废弃了 case_insensitive，并将在 8.0.0 版中移除。
ftp_nb_fget | 参数 mode 变为可选参数。 在之前的版本中，这是一个必填参数。
ftp_nb_fput | 参数 mode 变为可选参数。 在之前的版本中，这是一个必填参数。
ftp_nb_get | mode 参数变为可选，之前是强制性的。
ftp_nb_put | mode 参数为可选，之前版本中为必填。
ftp_put | mode 参数为可选，之前版本中为必选。
is_countable | is_countable has been added.
json_decode | JSON_THROW_ON_ERROR options was added.
json_encode | options 参数新增 JSON_THROW_ON_ERROR 常量。
list | 支持在数组解构时传引用。
password_hash | 增加 PASSWORD_ARGON2ID，支持 Argon2id 密码算法。
preg_quote | 字符 # 被增加为需要转义的。
session_set_cookie_params | 增加 options 参数， 可以通过传入一个关联数组对各个选项进行设置。 同时，通过使用这个参数还可以对 SameSite cookie 进行设置。
setcookie | An alternative signature supporting an options array has been added. This signature supports also setting of the SameSite cookie attribute.
unlink | 现在 Windows 也可以用 unlink 删除文件句柄还在使用中的文件了，在此之前是无法删除的。 然而，还是无法重新创建文件，需要等到所有句柄都关闭才可以。
var_export | Now exports stdClass objects as an array cast to an object ((object) array( ... )), rather than using the nonexistent method stdClass::__setState. The practical effect is that now stdClass is exportable, and the resulting code will even work on earlier versions of PHP.
7.3 | ldap_add | Support for controls added
ldap_compare | Support for controls added
ldap_delete | Support for controls added
ldap_exop | Support for serverctrls added
ldap_exop_passwd | Support for controls added
ldap_list | Support for controls added
ldap_mod_add | Support for controls added
ldap_mod_del | Support for controls added
ldap_mod_replace | Support for controls added
ldap_modify_batch | Support for controls added
ldap_mod_add_ext | Support for controls added
ldap_mod_del_ext | Support for controls added
ldap_mod_replace_ext | Support for controls added
ldap_parse_result | Support for controls added
ldap_read | Support for controls added
ldap_rename | Support for controls added
ldap_rename_ext | Support for controls added
ldap_search | Support for controls added
7.2.19, 7.3.6, 7.4.0 | DatePeriod::__construct | recurrences must be greater than 0 now.
7.2.18, 7.3.5 | substr_compare | offset 现在可能等于 main_str。
7.2.0 | count | 当无效的 countable 类型传递给 array_or_countable 参数时，count 会产生警告。
date_parse | 返回数组的 zone 键现在代表秒，而不是分钟。 并且正负符号已反转，例如：之前是 -120 现在是 7200。
date_parse_from_format | The zone element of the returned array represents seconds instead of minutes now, and its sign is inverted. For instance -120 is now 7200.
gettype | 现在，已关闭的资源报告为 'resource (closed)'。 此前，已关闭的资源报告为 'unknown type'。
hash_copy | 接受的参数以及返回值从资源类型修改为 HashContext 对象类型。
hash_final | 接收参数从资源类型修改为 HashContext 对象类型。
hash_hmac | 不再支持非加密的哈希函数（adler32，crc32，crc32b，fnv132，fnv1a32，fnv164，fnv1a64，joaat）。
hash_hmac_file | 不再支持非加密的哈希函数（adler32，crc32，crc32b，fnv132，fnv1a32，fnv164，fnv1a64，joaat）。
hash_init | 返回 HashContext 对象，不再返回资源类型。
hash_init | 当使用 HASH_HMAC 选项的时候，不再支持非加密的哈希函数（adler32，crc32，crc32b，fnv132，fnv1a32，fnv164，fnv1a64，joaat）。
hash_pbkdf2 | 不再支持非加密的哈希函数（adler32，crc32，crc32b，fnv132，fnv1a32，fnv164，fnv1a64，joaat）。
hash_update | 接收参数从资源类型修改为 HashContext 对象类型。
hash_update_file | 接收参数从资源类型修改为 HashContext 对象类型。
hash_update_stream | 接收参数从资源类型修改为 HashContext 对象类型。
idn_to_ascii | INTL_IDNA_VARIANT_2003 已被弃用； 可以使用 INTL_IDNA_VARIANT_UTS46 代替。
idn_to_utf8 | INTL_IDNA_VARIANT_2003 已被弃用； 可以使用 INTL_IDNA_VARIANT_UTS46 代替。
json_decode | JSON_INVALID_UTF8_IGNORE, and JSON_INVALID_UTF8_SUBSTITUTE options were added.
json_encode | options 参数新增 JSON_INVALID_UTF8_IGNORE 和 JSON_INVALID_UTF8_SUBSTITUTE 常量。
mail | 现在 additional_headers 参数开始支持 array。
number_format | number_format 现在无法返回 -0，之前可能返回 -0，因为 number 可能会是 -0.01。
openssl_pkcs7_verify | 新增 p7bfilename 参数。
pack | float 和 double 类型支持打断和小端。
parse_str | 不带第二个参数的情况下使用 parse_str 会产生 E_DEPRECATED 警告。
password_hash | 增加 PASSWORD_ARGON2I，支持 Argon2i 密码算法。
preg_match | 现在 $flags 参数支持 PREG_UNMATCHED_AS_NULL。
preg_match_all | 现在 $flags 参数可以支持 PREG_UNMATCHED_AS_NULL。
proc_nice | 在 Windows 平台上可用。
session_abort | The return type of this function is bool now. Formerly, it has been void.
session_module_name | 不允许设置模块名称为 "user"。 在之前的版本中，如果设置为 "user"，那么会被静默的忽略到。
session_name | session_name 函数会检查会话状态， 之前的版本仅仅检查 cookie 状态。 所以，旧版本的 PHP 允许你在调用 session_start 函数之后再调用 session_name 函数， 新版本的 PHP 不再允许这样做了。
session_reset | The return type of this function is bool now. Formerly, it has been void.
session_set_cookie_params | 成功时返回 true， 或者在失败时返回 false。 之前版本中是返回 void 的。
session_write_close | The return type of this function is bool now. Formerly, it has been void.
unpack | float and double types supports both Big Endian and Little Endian.
SQLite3::openBlob | The flags parameter has been added, allowing to write BLOBs; formerly only reading was supported.
7.1.5 | IntlDateFormatter::format | Support for providing general DateTimeInterface objects to the datetime parameter was added. Formerly, only proper DateTime objects were supported.
7.1.4 | PDO::sqliteCreateFunction | The flags parameter has been added.
SQLite3::createFunction | The flags parameter has been added.
7.1.0 | DateInterval::format | The F and f format characters were added.
DateTime::setTime | 新增 microsecond 参数。
array_rand | 内部随机化算法已从 libc rand 函数更改为使用 梅森旋转算法（Mersenne Twister） 随机数生成器。
getenv | 现在可以省略 varname 来检索所有环境变量的关联数组 array。
getopt | 添加 optind 参数。
grapheme_extract | Support for negative offsets has been added.
grapheme_stripos | Support for negative offsets has been added.
grapheme_strpos | Support for negative offsets has been added.
hash_algos | 加入 sha512/224，sha512/256，sha3-224，sha3-256，sha3-384 以及 sha3-512 算法的支持。
iconv_strpos | Support for negative offsets has been added.
json_decode | An empty JSON key ("") can be encoded to the empty object property instead of using a key with value _empty_.
json_encode | 对 Double 的值进行编码时，使用 serialize_precision 代替 precision。
json_encode | options 参数新增 JSON_UNESCAPED_LINE_TERMINATORS 常量。
list | 现在可以指定 list 中的键。 这就可以解构非数字键或者无顺序的数组。
long2ip | 参数 proper_address 的类型从 string 改成 integer。
mb_ereg | mb_ereg will now set matches to an empty array, if nothing matched. Formerly, matches was not modified in that case.
mb_ereg_replace | The function checks whether string is valid for the current encoding.
mb_ereg_replace | The e modifier has been deprecated.
mb_ereg_replace_callback | The function checks whether string is valid for the current encoding.
mb_ereg_search_setpos | Support for negative offsets has been added.
mb_eregi | mb_eregi will now set matches to an empty array, if nothing matched. Formerly, matches was not modified in that case.
mb_eregi_replace | The e modifier has been deprecated.
mb_eregi_replace | The function checks whether string is valid for the current encoding.
mb_strimwidth | 支持负数的 start 和 width。
mb_stripos | 支持 offset 使用负数。
mb_strpos | 支持负数的 offset。
openssl_decrypt | 添加了 tag 和 aad 参数。
openssl_encrypt | 增加了 tag、aad、tag_length 参数
openssl_pkey_new | 添加了 curve_name 配置参数使得可以创建 EC 密钥。
session_start | 当 session_start 执行失败， 无法开始一个会话的时候，会返回 false， 并且不会初始化超级变量 $_SESSION。
shuffle | 内置的随机数产生算法从 libc rand 函数改成 梅森旋转伪随机数生成算法。
str_shuffle | 内置的随机算法从 libc rand 函数改成了梅森旋转演伪随机数发生算法。
stripos | 开始支持负数的 offset。
strpos | 开始支持负数的 offset。
substr_count | 开始支持负数的 offset 和 length。
unpack | The optional offset has been added.
ReflectionType::__toString | ReflectionType::__toString has been deprecated.
SessionHandler::gc | Prior to this version, the function returned true on success.
SessionHandlerInterface::gc | Prior to this version, the function returned true on success.
7.1 | DateTime::__construct | 微秒部分不再是 '00000' 了，而是真实的微秒数据。
7.0.15,7.1.1 | pack | 添加了 “e”,“E”,“g” 和 “G” 代码以启用 float 和 double 的字节顺序支持。
7.0.11 | iconv_substr | 如果 str 等长于 offset 个字符， 将返回空字符串。之前的版本里，这种情况是会返回 false 的。
7.0.10 | SQLite3::__construct | The filename can now be empty to use a private, temporary on-disk database.
7.0.7 | curl_setopt | 引入 CURL_HTTP_VERSION_2、 CURL_HTTP_VERSION_2_PRIOR_KNOWLEDGE、 CURL_HTTP_VERSION_2TLS、 CURL_REDIR_POST_301、 CURL_REDIR_POST_302、 CURL_REDIR_POST_303、 CURL_REDIR_POST_ALL、 CURL_VERSION_KERBEROS5、 CURL_VERSION_PSL、 CURL_VERSION_UNIX_SOCKETS、 CURLAUTH_NEGOTIATE、 CURLAUTH_NTLM_WB、 CURLFTP_CREATE_DIR、 CURLFTP_CREATE_DIR_NONE、 CURLFTP_CREATE_DIR_RETRY、 CURLHEADER_SEPARATE、 CURLHEADER_UNIFIED、 CURLMOPT_CHUNK_LENGTH_PENALTY_SIZE、 CURLMOPT_CONTENT_LENGTH_PENALTY_SIZE、 CURLMOPT_MAX_HOST_CONNECTIONS、 CURLMOPT_MAX_PIPELINE_LENGTH、 CURLMOPT_MAX_TOTAL_CONNECTIONS、 CURLOPT_CONNECT_TO、 CURLOPT_DEFAULT_PROTOCOL、 CURLOPT_DNS_INTERFACE、 CURLOPT_DNS_LOCAL_IP4、 CURLOPT_DNS_LOCAL_IP6、 CURLOPT_EXPECT_100_TIMEOUT_MS、 CURLOPT_HEADEROPT、 CURLOPT_LOGIN_OPTIONS、 CURLOPT_PATH_AS_IS、 CURLOPT_PINNEDPUBLICKEY、 CURLOPT_PIPEWAIT、 CURLOPT_PROXY_SERVICE_NAME、 CURLOPT_PROXYHEADER、 CURLOPT_SASL_IR、 CURLOPT_SERVICE_NAME、 CURLOPT_SSL_ENABLE_ALPN、 CURLOPT_SSL_ENABLE_NPN、 CURLOPT_SSL_FALSESTART、 CURLOPT_SSL_VERIFYSTATUS、 CURLOPT_STREAM_WEIGHT、 CURLOPT_TCP_FASTOPEN、 CURLOPT_TFTP_NO_OPTIONS、 CURLOPT_UNIX_SOCKET_PATH、 CURLOPT_XOAUTH2_BEARER、 CURLPROTO_SMB、 CURLPROTO_SMBS、 CURLPROXY_HTTP_1_0、 CURLSSH_AUTH_AGENT 和 CURLSSLOPT_NO_REVOKE。
7.0.0 | array_column | input 参数现在可以是包含对象的数组。
assert | assert is now a language construct and not a function. assertion can now be an expression. The second parameter is now interpreted either as an exception (if a Throwable object is given), or as the description supported from PHP 5.4.8 onwards.
current | array 参数始终通过赋值来传递。之前的版本中，默认通过引用来传值。
define | 允许 array 的值。
dirname | 添加可选的 levels 参数。
getrusage | 此函数现在开始支持 Windows。
json_decode | An empty PHP string or value that after casting to string is an empty string (NULL, FALSE) results in JSON syntax error.
json_decode | Rejected RFC 7159 incompatible number formats - top level (07, 0xff, .1, -.1) and all levels ([1.], [1.e1])
key | array 现在总是会传值。 在此之前，它会尽可能传引用，否则就传值。
list | list 表达式不再可以完全为空。
list | 赋值操作的顺序发生了变化。
list | 字符串无法再被拆包（unpack）。
mktime | is_dst参数已经被移除。
openssl_open | 添加了 iv 参数
openssl_seal | 添加 iv 变量。
session_set_save_handler | 新增可选参数 validate_sid 和 update_timestamp。
session_start | 新加 options 参数。
substr | 如果 string 的字符串长度与 start 相同时将返回一个空字符串。在之前的版本中，这种情况将返回 false 。
5.6.5 | crypt | When the failure string "*0" is given as the salt, "*1" will now be returned for consistency with other crypt implementations. Prior to this version, PHP 5.6 would incorrectly return a DES hash.
5.6.3 | pack | 添加了 “q”、“q”、“J” 和 “P” 代码以支持处理 64 位数字。
5.6.0 | array_fill | count 现在可以是零。 之前 count 必须大于零。
array_filter | 添加可选的 mode 标志和常量（ ARRAY_FILTER_USE_KEY 和 ARRAY_FILTER_USE_BOTH ）
crypt | Raise E_NOTICE security warning if salt is omitted.
htmlentities | The default value for the encoding parameter was changed to be the value of the default_charset configuration option.
htmlspecialchars | The default value for the encoding parameter was changed to be the value of the default_charset configuration option.
json_decode | Invalid non-lowercased variants of the true, false and null literals are no longer accepted as valid input, and will generate warnings.
mb_regex_encoding | Default encoding is changed to UTF-8. It was EUC-JP Previously.
mcrypt_create_iv | source 参数的默认值是 MCRYPT_DEV_URANDOM。
mcrypt_decrypt | 不再接受无效长度的 key and iv 参数。 如果参数长度无效，则 mcrypt_decrypt 函数会产生警告并且返回 false。 之前版本中，对于长度不足的密钥和初始向量会在其后补齐 '\0' 使其达到有效长度。
mcrypt_encrypt | 不再接受无效长度的 key and iv 参数。 如果参数长度无效，则 mcrypt_decrypt 函数会产生警告并且返回 false。 之前版本中，对于长度不足的密钥和初始向量会在其后补齐 '\0' 使其达到有效长度。
pg_lo_truncate | Added truncate function. It supports PostgreSQL 9.3's 64bit large object. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.
stream_socket_enable_crypto | The crypto_type is now optional.
stream_socket_enable_crypto | Introduce STREAM_CRYPTO_METHOD_ANY_CLIENT, STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT, STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT, STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT, STREAM_CRYPTO_METHOD_ANY_SERVER, STREAM_CRYPTO_METHOD_TLSv1_0_SERVER, STREAM_CRYPTO_METHOD_TLSv1_1_SERVER, STREAM_CRYPTO_METHOD_TLSv1_2_SERVER.
ReflectionClass::newInstanceWithoutConstructor | All internal classes can now be instantiated except for those declared final.
XMLReader::getAttributeNo | XMLReader::getAttributeNo now returns null if the attribute doesn't exist.
XMLReader::getAttributeNs | XMLReader::getAttributeNS now returns null if the attribute doesn't exist.
5.5.38, 5.6.24, 7.0.9 | getenv | 添加 local_only 参数。
5.5.21 | crypt | When the failure string "*0" is given as the salt, "*1" will now be returned for consistency with other crypt implementations. Prior to this version, PHP 5.5 (and earlier branches) would incorrectly return a DES hash.
5.5.7 | getallheaders | 此函数可用于 CLI server。
5.5.2 | DOMDocument::schemaValidate | Added the flags parameter
DOMDocument::schemaValidateSource | Added the flags parameter
5.5.1 | hex2bin | 如果输入的字符串是无效的十六进制字符串则抛出一个警告，
session_set_save_handler | 新增可选参数 create_sid。
5.5.0/PECL 3.0.0 | IntlDateFormatter::create | An IntlCalendar object is allowed for calendar. Objects of type IntlTimeZone and DateTimeZone are allowed for timezone. Invalid timezone identifiers (including empty strings) are no longer allowed for timezone. If null is given for timezone, the timezone identifier given by date_default_timezone_get will be used instead of ICU?s default.
IntlDateFormatter::setCalendar | It became possible to pass an IntlCalendar object.
5.5.0 | empty | empty 现在支持表达式了，而不仅仅是变量。
ip2long | Prior to this version, on Windows ip2long would sometimes return a valid number even if passed a value which was not an (IPv4) Internet Protocol dotted address.
此函数会生成一个 E_DEPRECATED 错误。
mysql_list_dbs 函数已废弃，调用时会抛出 E_DEPRECATED 级别的错误。
函数会抛出一个 E_DEPRECATED 错误。
mysql_tablename 函数已废弃，调用时会抛出 E_DEPRECATED 级别的错误。
pack | “Z” 代码添加了与 “a” 等效的功能，以实现 Perl 兼容性。
setrawcookie | 发送给客户端的 Set-Cookie 头现在会加上 Max-Age 属性。
unpack | Changes were made to bring this function into line with Perl: The "a" code now retains trailing NULL bytes. The "A" code now strips all trailing ASCII whitespace (spaces, tabs, newlines, carriage returns, and NULL bytes). The "Z" code was added for NULL-padded strings, and removes trailing NULL bytes.
5.4.43, 5.5.27, 5.6.11 | escapeshellcmd | 感叹号会被空格所替换。
5.4.32, 5.5.16 | ucwords | 增加了 delimiters 参数。
5.4.8 | assert | 增加了参数 description。 description 现在也作为第四个参数提供给 ASSERT_CALLBACK 模式里的回调函数。
mb_strcut | Passing NULL as length extracts all bytes to the end of the string. Prior to this version NULL was treated the same as 0.
mb_substr | length 传入 NULL，则从 start 提取到字符串的结尾处。 在之前的版本里， NULL 会被当作 0 来处理。
5.4.7 | parse_url | 修复了 host 在 协议 省略时的识别。
5.4.4 | hex2bin | 如果输入的字符串有多余将抛出异常。 PHP 5.4.0 起字符串将被静默地接受，但是最后的字节会被截断。
5.4.0 | array_combine | （修复）早期版本中如果是空数组就报E_WARNING的错并且返回false。
array_multisort | array1_sort_flags 增加 SORT_NATURAL 和 SORT_FLAG_CASE 选项。
date_default_timezone_get | 不再使用 TZ 来推测时区。
date_default_timezone_get | 不再根据操作系统的信息来推测时区，因为这是不可靠的。
dns_get_record | 增加了参数raw。
empty | 检查非数字的字符串偏移量会返回 true.
filter_input_array | 添加 add_empty 参数.
filter_var_array | 添加 add_empty 参数。
get_html_translation_table | The default value for the encoding parameter was changed to UTF-8.
get_html_translation_table | The constants ENT_HTML401, ENT_XML1, ENT_XHTML and ENT_HTML5 were added.
get_magic_quotes_runtime | 总是返回 false，因为魔术引号（magic quotes）功能已经从 PHP 中移除。
getallheaders | 此函数可用于 FastCGI。 此前仅在PHP以 Apache 模块方式运行时支持。
htmlentities | encoding 参数的默认值改成 UTF-8。
htmlentities | 增加常量 ENT_SUBSTITUTE、 ENT_DISALLOWED、 ENT_HTML401、 ENT_XML1、 ENT_XHTML、 ENT_HTML5。
htmlspecialchars | encoding 参数的默认值改成 UTF-8。
htmlspecialchars | 增加常量 ENT_SUBSTITUTE、 ENT_DISALLOWED、 ENT_HTML401、 ENT_XML1、 ENT_XHTML、 ENT_HTML5。
htmlspecialchars_decode | 增加了 ENT_HTML401、ENT_XML1、 ENT_XHTML 和 ENT_HTML5 等常量。
http_build_query | 加入了 enc_type 参数。
iconv | 这个版本起，字符非法时候会返回 false，除非在输出字符里指定了 //IGNORE 。 在之前版本，它会返回一部分字符串。
imagewebp | 支持把 resource 流作为 to 参数传入。
isset | 检查字符的非数字偏移量将会返回 false。
json_decode | JSON_BIGINT_AS_STRING, and JSON_OBJECT_AS_ARRAY options were added.
json_decode | The options parameter was added.
number_format | This function now supports multiple bytes in dec_point and thousands_sep. Only the first byte of each separator was used in older versions.
openssl_decrypt | 将 raw_output 更改至 options。
openssl_encrypt | raw_output 改到 options。
scandir | sorting_order now accepts constants. Any nonzero value caused descending order in previous versions.
session_set_save_handler | 新增用来实现自定义会话处理器的接口 SessionHandlerInterface； 新增 PHP 内部会话处理器类：SessionHandler。
5.3.15, 5.4.5 | Collator::getSortKey | Sort keys do no longer contain any NUL bytes.
5.3.9 | DateTime::createFromFormat | 新增 format 格式字符串中对于 + 格式字符的支持。
5.3.7 | crypt | Added $2x$ and $2y$ Blowfish modes to deal with potential high-bit attacks.
5.3.6 | array_product | 空数组现在会产生 1，而之前此函数处理空数组会产生 0。
5.3.4 | get_html_translation_table | The encoding parameter was added.
rawurlencode | 因为 rawurlencode 使用了 EBCDIC，所以波浪线字符不会再被编码。
strip_tags | strip_tags ignores self-closing XHTML tags in allowable_tags.
5.3.3 | openssl_decrypt | 添加 iv 参数。
openssl_encrypt | 增加 iv 参数。
parse_url | 在 URL 解析失败时将不会产生 E_WARNING 级别的错误。
5.3.2 | crypt | 基于 Ulrich Drepper 的实现，新增基于 SHA-256 算法和 SHA-512 算法的 crypt。
crypt | 修正了 Blowfish 算法由于非法循环导致的问题，返回“失败”字符串（“*0” 或 “*1”）而不是转而使用 DES 算法。
flock | 在文件资源句柄关闭时不再自动解锁。现在要解锁必须手动进行。
5.3.1 | get_defined_constants | 仅作用于 Windows：内核常量归类到 Core，之前是 mhash。
5.3.0 起 | get_class | object 默认参数现在是 null ，所以，现在传入 null 到 object 参数时，和没传参数的结果一样。
5.3.0 | DateTime::__construct | 如果 time 参数不是一个有效的 日期/时间格式， 会抛出异常。 在之前的版本中是会发出一个错误。
DateTimeZone::listIdentifiers | 添加可选的 what 和 country 参数。
acosh | This function is now available on all platforms
array_multisort | array1_sort_flags 增加选项 SORT_LOCALE_STRING。
array_search | As with all internal PHP functions as of 5.3.0, array_search returns null if invalid parameters are passed to it.
asinh | 此函数在所有平台上均可用
atanh | 此函数在所有平台上都可以用了
call_user_func | 对面向对象里面的关键字的解析有所增强。在此之前，使用两个冒号来连接一个类和里面的一个方法，把它作为参数来作为回调函数的话，将会发出一个E_STRICT的警告，因为这个传入的参数被视为静态方法。
call_user_func_array | 对面向对象里面的关键字的解析有所增强。在此之前，使用两个冒号来连接一个类和里面的一个方法，把它作为参数来作为回调函数的话，将会发出一个E_STRICT的警告，因为这个传入的参数被视为静态方法。
checkdnsrr | 这个函数在Windows平台上也可以使用了。
clearstatcache | 增加了可选的 clear_realpath_cache 和 filename 参数.
crypt | PHP 现在包含了它自己的 MD5 Crypt 实现，包括标准 DES 算法，扩展的 DES 算法以及 Blowfish 算法。如果系统缺乏相应的实现，那么 PHP 将使用它自己的实现。
date_default_timezone_set | 现在会抛出 E_WARNING 而不是 E_STRICT。
dns_get_record | 在此版本之前，如果给参数authns传入值，则必须同时传入addtl的值。
dns_get_record | 可以是在windows平台上使用这个函数了。
expm1 | 此函数在所有平台上均可用
fgetcsv | 增加了 escape 参数。
fnmatch | 此函数开始在 Windows 平台上生效。
func_get_arg | 该函数可以在参数列表中使用。
func_get_arg | If this function is called from the outermost scope of a file which has been included by calling include or require from within a function in the calling file, it now generates a warning and returns false. （不知道如何翻译跟好，直接参考例2即可明白）
func_get_args | If this function is called from the outermost scope of a file which has been included by calling include or require from within a function in the calling file, it now generates a warning and returns false. （不知道如何翻译跟好，直接参考例2即可明白）
func_get_args | 该函数可以在参数列表中使用。
func_num_args | If this function is called from the outermost scope of a file which has been included by calling include or require from within a function in the calling file, it now generates a warning and returns -1.
func_num_args | This function can now be used in parameter lists.
get_cfg_var | get_cfg_var 被修复，能够返回 "array" 的 ini 选项。
get_defined_constants | 内核常量归类为 Core，之前是 internal。在 Windows 上，内核常量归类到 mhash。
get_object_vars | This function now returns NULL if the object isn't an object.
getimagesize | Added icon support.
getmxrr | Windows 平台上也能用这个函数了。
htmlentities | 增加常量 ENT_IGNORE。
htmlspecialchars | 增加常量 ENT_IGNORE。
imagecolorclosesthwb | 在 Windows 平台上可用
imagefilter | Pixelation support (IMG_FILTER_PIXELATE) was added.
ini_get | 当配置项不存在，之前会返回空字符串，现在会返回 false。
ini_get_all | 增加参数 details。
json_decode | Added the optional depth. The default recursion depth was increased from 128 to 512
link | 该功能在 Windows 平台下开始有效（Vista、 Server 2008 或更高版本）。
linkinfo | Windows 平台上开始可用（Vista、Server 2008 或更高版本）。
log1p | 此函数在所有平台上均可用
mcrypt_create_iv | 不再需要提前调用 srand 函数， 由本函数自动完成调用。
mcrypt_create_iv | MCRYPT_DEV_RANDOM 和 MCRYPT_DEV_URANDOM 在 Windows 平台也可用了。
mktime | mktime now throws E_DEPRECATED notice if the is_dst parameter is used.
nl2br | 新增可选的 is_xhtml 参数。在此之前，总是插入 '<br />'。
openssl_open | 添加了 method 参数
openssl_seal | 添加 method 变量。
property_exists | This function checks the existence of a property independent of accessibility.
rawurlencode | 现在符合了RFC 3986。
readlink | 此函数在 Windows 平台下可用（Vista、Server 2008 或更高版本）。
register_tick_function | Ticks are now supported on threaded web server modules.
round | 引入了 mode 参数
session_start | 如果函数调用失败返回 false， 之前版本返回了 true。
setlocale | This function now throws an E_DEPRECATED notice if a string is passed to the category parameter instead of one of the LC_* constants.
stream_context_create | 增加了可选参数 params 。
stream_socket_pair | 这个函数在windows平台不可用
stristr | 新增可选的 before_needle 参数。
strlen | Prior versions treated arrays as the string Array, thus returning a string length of 5 and emitting an E_NOTICE level error.
strstr | 新增可选的 before_needle 参数。
symlink | 此函数在 Windows 平台上可用（Vista、Server 2008 或更高版本）。
time_nanosleep | 至此之后该函数在Windows平台下可用。
time_sleep_until | 自此，函数在Windows平台可用。
5.2.11 | get_defined_constants | categorize 参数现在可以合适得被处理。 在此之前，categorize 被解释为 !is_null($categorize)，导致任何非 null 的值会强制常量分类。
5.2.10 | array_unique | 修改回 sort_flags 的默认值为 SORT_STRING。
ip2long | 再此之前的版本, ip2long 有时会返回即使这不是一个IPV4的标准地址的数字地址。
natsort | 用零填充的数字字符串 (例如 '00005')现在本质上会忽略掉填充的前道零。
5.2.9 | array_unique | 增加可选选项sort_flags，默认值 SORT_REGULAR。 5.2.9 之前，此函数内部使用 SORT_STRING 排序。
5.2.7 | round | round 的内部运作修改符合 C99 的标准。
5.2.6 | fopen | 增加了选项 'c' 和 'c+'
5.2.5 | addcslashes | The escape sequences \v and \f were added.
imagefilter | Alpha support for IMG_FILTER_COLORIZE was added.
5.2.4 | checkdnsrr | 增加了TXT的记录类型。
stream_wrapper_register | 添加 flags 参数.
5.2.3 | getimagesize | Read errors generated by this function downgraded to E_NOTICE from E_WARNING.
htmlentities | 增加参数 double_encode。
htmlspecialchars | 增加参数 double_encode。
json_decode | The nesting limit was increased from 20 to 128
PDOStatement::getColumnMeta | table 字段
5.2.2 - 5.2.6 | substr | If the start parameter indicates the position of a negative truncation or beyond, false is returned. Other versions get the string from start.
5.2.2 | ftp_ssl_connect | 以前版本中，如果无法使用 SSL 连接，将会返回一个非 SSL 的连接， 在 5.2.2 版本中修改为返回 false
phpinfo | 增加了“已加载的配置文件”信息，之前只存在“配置文件路径(php.ini)"。
proc_terminate | 之前的版本被用来销毁进程 resource。
token_get_all | Line numbers are returned in element 2
5.2.1 | json_decode | Added support for JSON decoding of basic types.
memory_get_peak_usage | 使用此函数无需在编译时加上 --enable-memory-limit 选项。
memory_get_usage | 不需要在编译时使用 --enable-memory-limit 选项就能够使用这个函数。
mt_srand | The Mersenne Twister implementation in PHP now uses a new seeding algorithm by Richard Wagner. Identical seeds no longer produce the same sequence of values they did in previous versions. This behavior is not expected to change again, but it is considered unsafe to rely upon it nonetheless.
proc_open | 为 other_options 参数增加 bypass_shell 选项。
5.2.0 | base64_decode | 增加了 strict 。
curl_multi_info_read | msgs_in_queue被加入。
imagettftext | It is now possible to specify an hexadecimal entity in text.
mb_strrpos | 增加了可选参数 offset。
memory_get_peak_usage | 添加参数 real_usage。
memory_get_usage | 增加了参数 real_usage。
openssl_verify | 添加了 signature_alg 参数。
pathinfo | 添加了常量 PATHINFO_FILENAME。
session_get_cookie_params | 在返回数组中加入 “httponly”。
session_set_cookie_params | 加入 httponly 参数。
setrawcookie | 增加了 httponly 参数。
simplexml_load_file | The optional parameter is_prefix was added.
simplexml_load_string | The optional parameter is_prefix was added.
PDOStatement::execute | input_parameters 中的键名必须和 SQL 中声明的相匹配。PHP 5.2.0 之前默认忽略。
SimpleXMLElement::attributes | The optional parameter is_prefix was added.
SimpleXMLElement::__construct | Added the ns and is_prefix parameters.
5.1.3 | curl_getinfo | 引入CURLINFO_HEADER_OUT.
get_headers | 自 PHP 5.1.3 起本函数使用默认的流上下文，其可以用 stream_context_get_default 函数设定和修改。
http_build_query | 方括号也会被转义。
5.1.2 | date_default_timezone_set | 本版本开始验证 timezone_identifier 参数。
http_build_query | 加入了参数 arg_separator。
parse_url | 增加了参数 component。
SimpleXMLElement::__construct | Added the options and data_is_url parameters.
5.1.1 | date | format 参数标准的可用日期/时间格式常量见： 常量
5.1.0 | ctype_digit | 在 PHP 5.1.0 之前，当 text 是一个空字符串的时候，该函数将返回 true 。
date | 现在发布 E_STRICT 和 E_NOTICE 时区错误。
date | 时间戳的有效取值范围为 GMT 时间的 1901 年 12 月 13 日至 GMT 时间的 2038 年 1 月 19 日。 （32 位有符号整数的取值范围）。 但是，在 PHP 5.1.0 之前的版本，在某些系统（例如 Windows）上有效取值范围为 1970 年 1 月 1 日至 2038 年 1 月 19 日。
date_sunrise | 现在发布 E_STRICT 和 E_NOTICE 时区错误。
date_sunset | 现在发布 E_STRICT 和 E_NOTICE 时区错误。
explode | 支持负数的 limit
file_get_contents | Added the offset and maxlen parameters.
file_put_contents | 添加了对 LOCK_EX 的支持和 data 参数处理 stream 资源的功能。
gettimeofday | 增加了参数 return_float。
imagerotate | 新增： ignore_transparent 。
localtime | 现在发布 E_STRICT 和 E_NOTICE 时区错误。
md5_file | 函数改用流 API。这意味着能够配合封装器使用该函数，比如 md5_file('http://example.com/..')。
mktime | 现在发布 E_STRICT 和 E_NOTICE 时区错误。
mktime | When called with no arguments, mktime throws E_STRICT notice. Use the time function instead.
mktime | is_dst 参数被废弃。出错时函数返回 false 而不再是 -1。修正了本函数可以接受年月日参数全为零。
stream_get_contents | 增加参数 offset 。
strftime | 现在发布 E_STRICT 和 E_NOTICE 时区错误。
5.0.0 | apache_get_modules | 可用于Apache 1或PHP Apache 2 filter API。 在此之前, 只可用于 Apache 2 handler API。
apache_get_version | 可用于 Apache 2 filter API.
checkdnsrr | 增加了AAAA的记录类型。
fgetss | 参数 length 从 此开始可选。
file_get_contents | Added context support.
file_put_contents | Added context support
is_executable | is_executable 开始可用以于 Windows。
jdtojewish | 增加了参数 fl。
opendir | path 支持 ftp:// URL wrapper
socket_create | 增加 AF_INET6 支持。
strip_tags | strip_tags 变为二进制安全的。
strrpos | 引入 offset 参数。
strrpos | 参数 needle 可以是一个多字符的字符串。


CHM 版本

  • 关于此版本
  • Using PHP Manual CHM Edition
    • The HTML Help Toolbar
    • The Navigation Pane
    • Keyboard Shortcuts
  • The Full Text Search
    • General searching rules
    • Searching for words or phrases
    • Defining search terms
    • Using nested expressions when searching
  • Integrating the PHP Manual


关于此版本

PHP 手册的 Windows HTML Help 版本是针对开发人员的，他们希望每时每刻都有手册在手头，并且不需要等待远程页面下载就可以阅读手册以及用户注解。此版本给你完整的手册内容加上用户注解，以及一些很棒的特色。这是由我们用来生成此格式的脚本产生的阅读程序以及其他人在皮肤样式上的贡献所提供的。

PHP 手册的此发行包中由很多文件组成，包括主要的手册文件 php_manual_zh.chm。你可以通过双击此文件查看本手册（你可能已经猜到了）。 你可能也会在目录中看到 php_manual_zh.chw 文件，该文件是在你第一次使用索引标签时生成的，包含了手册页面的索引。

对那些对 Microsoft HTML Help 的技术细节有兴趣的人来说，» http://www.helpware.net/ 是一个很棒的资源。有关 Microsoft 帮助格式和服务历史中的 Windows HTML Help 的更多信息与配置，见 » WinWriters article。


Using PHP Manual CHM Edition

Table of Contents

  • The HTML Help Toolbar
  • The Navigation Pane
  • Keyboard Shortcuts

When you double click on a CHM, a HTML Help Viewer window opens with three panes. On the left side of the window is the Navigation pane. It contains four navigational tabs: the Contents, Index, Search and Favorites tabs. On the right side of the window is the Topic pane. It displays the selected help topic, or the default help topic on startup. The help pages are all separate HTML files, your Internet Explorer displays the pages in the Topic pane. The third pane is the toolbar, which is located below the help window title bar. You can adjust the horizontal layout with dragging the vertical border between the Navigation pane and the Topic pane.

Note, that when you open the CHM the first time, it may appear in a strange position and size. From then, Windows remembers the window position, size and the last opened tab. All these including your favorites are stored in a file named hh.dat. If you move your file to another directory, all these remembered settings will be lost (including your favorites listing!). If you replace your CHM file with a new one, with the same name, this is not a problem though. The file names and path values are stored in hh.dat.


The HTML Help Toolbar

The HTML Help Toolbar contains the following icons, when you view the PHP Manual:

  • Hide/Show - Hides/shows the navigation pane.
  • Locate - Locates a topic in the contents tab (in case you reached a topic with search, index or favorites, and would like to see where it is in the table of contents tree view).
  • Back - Goes back in the history.
  • Forward - Goes forward in the history.
  • Refresh - Reloads the current page.
  • Home - Opens the startup page of the CHM.
  • Print - Opens the print dialog box.
  • Options - Provides a dropdown with more options.
Using this toolbar is really easy, many of the toolbar icons are strongly related to their Internet Explorer equivalents.


The Navigation Pane

The Navigation Pane contains four navigational tabs: the Contents, Index, Search and Favorites tabs. These all provide different methods to access a topic in the help file.

  • The contents tab reveals a tree like table of contents, where you can navigate to the desired topic by opening and closing parts of the tree. You can even access the deepest sections using this TOC. If you right click on an item here and choose "Print...", you'll have the option to print the selected topic or the selected topic and all subtopics. However printing is not the initial goal of this representation of the manual (the PDF version is suitable for printing).
  • The index tab lists a huge number of "keywords" (actually manual page titles). You can pick one, or start to type a keyword, see the list adjusting to your input, and then click on a topic, or press enter if the selected topic is the one you would like to see.
  • The search tab shows one of the most powerful features of the HTML Help Viewer, the full text search (also known as FTS). Here you can type in your search expression, optionally connecting words with AND/OR/NEAR/NOT. Before you click 'List topics', you can also set some options at the bottom. After the search results are displayed, you'll realize that manual text and user note results are separated. To sort out the two types, click on the 'Location' column header. Now from the search results list, you can pick a topic, and see it's page. The keywords you searched for are highlighted on the page.
  • The favorites tab enables you to store your most used topics in a list, easily accessible. Here you can see the list, add the current topic to it, remove one, or display a selected item. You can also specify your own title for the favorite, by typing it into the 'Current topic:' box. The user note page titles are prepended with a 'N:' string so you can distinguish them from normal manual pages in the favorites listing.


Keyboard Shortcuts

There are many keyboard shortcuts you can use to increase your productivity. Many users find it more appropriate to use these keyboard shortcuts to access topics, instead of clicking.

General Help Viewer Shortcuts
To | Press
Close the Help Viewer | ALT+F4
Display the Options menu | ALT+O
Hide or show the Navigation pane | ALT+O, and then T
Print a topic | ALT+O, and then P
Move back to the previous topic | ALT+LEFT ARROW
Move forward to the next topic (provided you have viewed it just previously) | ALT+RIGHT ARROW
Turn on or off search highlighting. | ALT+O, and then O
Return to the help file home page | ALT+O, and then H
Switch between the Navigation pane and the Topic pane | F6
Scroll through all the links in a topic or through all the options on a Navigation pane tab | TAB
Display context (right click) menu | SHIFT+F10
Contents Tab Shortcuts
To | Press
Display the Contents tab | ALT+C
Open and close a book or folder | PLUS SIGN and MINUS SIGN, or LEFT ARROW and RIGHT ARROW
Select a topic | DOWN ARROW and UP ARROW
Display the selected topic | ENTER
Index Tab Shortcuts
To | Press
Display the Index tab | ALT+N
Type a keyword to search for | ALT+W, and then type the word
Select a keyword in the list | UP ARROW and DOWN ARROW
Display the associated topic | ENTER or ALT+D
Search Tab shortcuts
To | Press
Display the Search tab | ALT+S
Type a keyword to search for | ALT+W, and then type the word
Start a search | ALT+L
Select a topic in the results list | ALT+T, and then UP ARROW and DOWN ARROW
Display the selected topic | ENTER or ALT+D
Search for a keyword in the result list of a prior search | ALT+U
Search for words similar to the keyword. For example, to find words like "running" and "runs" for the keyword "run" | ALT+M
Only search through topic titles | ALT+R
Favorites Tab Shortcuts
To | Press
Display the Favorites tab | ALT+I
Add the currently displayed topic to the Favorites list | ALT+A
Select a topic in the Favorites list | ALT+P, and then UP ARROW and DOWN ARROW
Display the selected topic | ENTER or ALT+D
Remove the selected topic from the list | ALT+R
Topic Pane Shortcuts
To | Press
Index Lookup | Select the words you would like to look up and press F1
Find on page | CTRL+F, and then adjust options
Refresh page | F5


The Full Text Search

Table of Contents

  • General searching rules
  • Searching for words or phrases
  • Defining search terms
  • Using nested expressions when searching

This edition of the PHP Manual includes an advanced full text search possibility provided by the viewer application. This enables users to search through every word in the help file to find a match. For example, if a user does a full-text search on the word "Apache", every topic that contains the word "Apache" will be listed. Advanced full-text search allows a user to search using boolean, wildcard, and nested expressions. A user can also limit the search to previous results, match similar words, or search topic titles only.

The usage of the search feature is fairly straightforward. Click on the search tab, type in the desired words and press ENTER (or click on "List Topics"). Then you'll receive a list of matches from the PHP Manual (and the notes). You can use the button with a right arrow on it to add boolean operators to your search (or you can type them in). As you see the results, you can use the column headings (Title, Location and Rank) to sort the topic list. The default order is by Rank. You can also adjust some parameters at the bottom of this tab.

The words found are highlighted on the current page in the Topic pane by default. You can turn off this feature by choosing the "Search Highlight Off" menu item in the Options menu. To can get this feature back similarly. If you are viewing a long topic, only the first 500 instances of a search word or phrase will be highlighted, due to a limitation of the viewer.


General searching rules

A basic search consists of the word or phrase you want to find. You can use wildcard expressions, nested expressions, boolean operators, similar word matches, a previous results list, or topic titles to further define your search.

The basic rules for formulating queries are as follows:

  • Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.
  • You may search for any combination of letters (a-z) and numbers (0-9). You cannot search for single letters (a, b, c, etc.) and common words, like: an, and, as, at, be, but, by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, with, you.
  • Punctuation marks such as the period (.), colon (:), semicolon (;), comma (,), and hyphen (-) are ignored during a search.
  • Group the elements of your search using double quotes or parentheses to set apart each element. You cannot search for quotation marks.

Note:

If you are searching for a file name with an extension, you should group the entire string in double quotes, ("filename.ext"). Otherwise, the period will break the file name into two separate terms. The default operation between terms is AND, so you will create the logical equivalent to "filename AND ext."


Searching for words or phrases

You can search for words or phrases and use wildcard expressions. Wildcard expressions allow you to search for one or more characters using a question mark or asterisk. The table below describes the results of these different kinds of searches.

Word and phrase searches
Search for | Example | Results
A single word | select | Topics that contain the word "select". (You will also find its grammatical variations, such as "selector" and "selection".)
A phrase | "new operator" or new operator | Topics that contain the literal phrase "new operator" and all its grammatical variations. Without the quotation marks, the query is equivalent to specifying "new AND operator," which will find topics containing both of the individual words, instead of the phrase.
Wildcard expressions | esc* or HT?? | Results for the first example include topics that contain the terms "ESC", "escape", "escalation", and so on. The asterisk cannot be the only character in the term. Results for the second example include topics that contain the terms "HTTP", "HTML" and so on. The question mark cannot be the only character in the term.

Note:

Select the Match similar words check box to include minor grammatical variations for the phrase you search. This feature only locates variations of the word with common suffixes. For example, a search on the word "add" will find "added," but it will not find "additive". This option is independent of other options or syntax. If you do a titles-only search, variations in titles will be matched. If you use quotes (or any other query operator) any variation of the word can appear; for example, "stemmed search" will also match "stemming search".


Defining search terms

The AND, OR, NOT, and NEAR operators enable you to precisely define your search by creating a relationship between search terms. The following table shows how you can use each of these operators. If no operator is specified, AND is used. For example, the query "server cgi security" is equivalent to "server AND cgi AND security".

Search operators
Search for | Example | Results
Both terms in the same topic | http AND apache | Topics containing both the words "http" and "apache".
Either term in a topic | ming OR swflib | Topics containing either the word "ming" or the word "swflib" or both.
The first term without the second term | xml NOT expat | Topics containing the word "xml" but not the word "expat".
Both terms in the same topic, close together | database NEAR security | Topics containing the word "database" within eight words of the word "security".

Note:

The |, &, and ! characters can also be used in place of OR AND and NOT respectively. This may not work if you use a very old version of the viewer.


Using nested expressions when searching

Nested expressions allow you to create complex searches for information. For example, "html AND ((smtp OR pop3) NEAR mail)" finds topics containing the word "html" along with the words "smtp" and "mail" close together, or containing "html" along with the words "pop3" and "mail" close together.

The basic rules for searching help topics using nested expressions are as follows:

  • You can use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.
  • If a query does not contain a nested expression, it is evaluated from left to right. For example: "mail NOT pop3 OR smtp" finds topics containing the word "mail" without the word "pop3" or topics containing the word "smtp". On the other hand, "mail NOT (pop3 OR smtp)" finds topics containing the word "mail" without either of the words "pop3" or "smtp".
  • You cannot nest expressions more than five levels deep.


Integrating the PHP Manual

Note:

The information provided here is mainly aimed at IDE authors, or advanced users who would like to integrate this CHM file to their favorite IDEs or other production environment components.

There are several editors out there with support for CHM integration, but you may need to know a few things about what the CHM contains to successfully integrate the manual into your environment.

The CHM is built using XSL style sheets from XML sources. This is unique currently in the PHP Manual family, as all other versions are generated using DSSSL style sheets. This also means, that non-intentional rendering differences may come up. A special conversion script is run on the XSLT output, adding several cute features, and packing up the manual with the preferences files and skin examples.

If you never worked with CHMs, you can think of them as compressed files with OS supported access for files inside and some added search and index support. However CHMs can only be viewed using the HTML Help Viewer, you can directly access files inside them using a special URL prefix, the CHM file name and the file you request from inside. As all the help content is stored in HTML files, you can show pages of the CHM in Internet Explorer.

Assume that you placed your php_manual_en.chm to c:\phpmanual the index file in the manual (which you see the first time) can be accessed with the following URL: mk:@MSITStore:C:\phpmanual\php_manual_en.chm::/_index.html. Here mk:@MSITStore: is the special "protocol", C:\phpmanual\php_manual_en.chm is the CHM with it's full path. The /_index.html part is the path to the index file inside the CHM and :: is just what you need to put between the CHM path and this file path.

Note:

All files are in the root directory of the CHM, unlike the previous CHM versions which included a language directory. Images, style sheets and other supplemental files have names starting with an underscore (like the main index shown above), to avoid name collisions.

The names of generated files follow the same rules as the online manual, except that the extension is .html and not .php. The most important is that function documentation files are named function.FUNCNAME.html where FUNCNAME is the function name, with all underscores converted to hyphens. Some examples are function.echo.html, function.mysql-close.html, function.imagecopy.html.

Using all this information, you can show a manual page for a function requested by a user. A simple example is included in the distribution, named php_quickref.hta. This is a » HTML Application to demonstrate the simple process of showing a manual page for a function. The quickRef() function defined therein does the job.

If you would like to integrate the manual into an IDE without direct support for the PHP manual (actually the underscore to hyphen conversion), you can use the included _function.html file to access a function page. This file is simply a redirector, and can be parameterized via the URL, as _function.html#mysql_close. This page will redirect you to the mysql_close function page (function.mysql-close.html) automatically. You can provide the full path of this file if your IDE supports context sensitive help, and provide the IDE specified string as the parameter. An example for this is the UltraEdit 9 intergation (see the edition's website).

The index of the manual (accessible via the index tab on the navigation pane) can also be used for integrational purposes. All the HTML pages are included in the index with their titles as index terms (including function description pages).

If you are a desktop application developer and would like to tightly integrate the CHM into your program (such as displaying the TOC tree in your IDE's help box), you can find more information at » http://www.helpware.net/, as well as links to other useful resources. The official site for HTML Help is at » http://www.microsoft.com/download/en/details.aspx?id=21138.